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Chapter 1: Introduction

The Draw module is a component of the Stage module. It contains all the tools necessary to create a 
paperless frame-by-frame animation project. There is no node system in this module, only the basic 
essential effects. Contrary to the Stage module, instead of creating effects in the Network view, you 
simply create them in the Timeline view. The Draw module also includes all the scene setup and camera 
features for you to do the compositing for your project.

This guide is divided as follows:

• Toon Boom Harmony - About this Help System on page 21

• About Toon Boom Harmony on page 27

• Starting Toon Boom Harmony on page 33

• Interface on page 67

• Character, Prop and Location Design on page 135

• Colour Styling and Colour Models on page 265

• Painting the Background on page 311

• Scanning on page 329

• Timing on page 355

• Ink and Paint on page 509

• Paperless Animation on page 433

• Morphing on page 561

• Character Building on page 593

• Library on page 647

• Cut-out Animation on page 677

• Import on page 739

• Scene Setup on page 801

• Animation Paths on page 843

• Sound on page 903

• Effects on page 931

• Export on page 975
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Chapter 2: Toon Boom Harmony - About this Help System
Toon Boom Harmony is an animation and digital content creation tool that offers you a wide array of 
features and options. Harmony is packaged in several different modules and allows you to create 
animation using the technique of your choice—see About Toon Boom Harmony on page 27.

This help system is built to guide you through the different workflows possible and explains which tool 
and module to use in a production context.

• Help Structure on the next page

• Tutorials and Other Help Tools on page 24
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Help Structure

The fundamental concepts of animation and Harmony are explained in this guide. It covers the 
essentials of various animation workflows, basic animation principles, as well as Harmony's interface. 
Depending on what you want to do, you can either start with this Fundamentals Guide to get 
immersed into the world of Harmony and animation or go right to the Getting Started Guide, which 
covers the main functions and tasks. All conceptual and reference topics are omitted to get you up and 
running in a very short amount of time.

If your work revolves more around system administration or coordination tasks, you will probably 
want to move over to the Installation Guide followed by the Control Center and Server Guide to learn 
how to install and configure Harmony.

The core of this help system revolves around the main animation techniques you can use in Harmony to 
create animation:

• Traditional Animation

• Paperless Animation

• Cut-out Animation

If you use one of the animation technique listed above to produce games, you can complete your 
learning process using the Gaming Guide.
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All workflows join in the compositing step of the process. All the information on compositing in 
Harmony can be found in the Compositing Guide. Finally, you can watch the rendered animations in 
the Play module. To learn how to use the Play module, refer to the Play guide.

If you are focusing on a single part of the workflow such as ink and paint or digital Xsheet creation, you 
can simply read the Fundamentals Guide and one of the corresponding module guides:

• Paint Guide

• Xsheet Guide

• Scan Guide

• Draw Guide

• Sketch Guide

Other satellite guides are also available to learn about additional information such as the preferences 
and keyboard shortcuts.

• Keyboard Shortcuts Guide

• Preferences Guide

• Scripting Guide

• Utilities Guide

If you are already a Harmony user and want to know more about the new features that were added to 
this latest version, refer to:

• Release Notes
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Tutorials and Other Help Tools

Aside from the main product documentation, you can find supplementary material to learn more 
about Harmony. The Toon Boom website's online resources section offers a variety of videos and 
samples that can further your knowledge of Harmony.

• Video Tutorials: toonboom.com/resources/video-tutorials/harmony-network

• Templates and Sample Scenes: toonboom.com/resources/templates/harmony-network

• Tips and Tricks: toonboom.com/resources/tips-and-tricks/harmony-network

• White Papers: toonboom.com/solutions/white-papers
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System Requirements

Here are the technical specifications for Toon Boom Harmony 11.1.

Harmony Network
Toon Boom Harmony Network is a server-client configuration. The server stores all the assets, and 
holds the database. The client machines simply run the software and allow the members of your team 
to work on Harmony and access the assets directly from the database.

Note that an Internet connection is required to activate the animation software.

Before installing Harmony, refer to the Harmony and Your IT Department white paper to learn about 
the network prerequisites for a Toon Boom Harmony installation. This document should be taken as a 
guide to help you understand the preliminary steps before performing a typical Harmony installation.

There are multiple ways of installing Harmony, as well as numerous types of hardware that can work 
with Harmony. To perform a custom installation which fits the studio’s requirements, a proper analysis 
of the studio is required, such as: the type of project, the productivity expected, and the delivery date, 
etc. If you are not yet familiar with Harmony, you should get in touch with your sales contact at Toon 
Boom to organize a needs analysis of your studio and production in order to make the best of 
Harmony and optimize your production pipeline.

The person who performs the installation should have the knowledge and expertise required for 
setting up and configuring networks, computers, and operating systems. If you do not have an IT 
department or someone who knows the network technology thoroughly, contact your sales 
representative at Toon Boom to organize an installation with our consulting department.

• White Paper: Harmony and Your IT Department

Harmony
Here are the specifications to install Harmony on client machines. Note that this does not encompass 
the network and server specifications for Harmony Network.

Requirements Windows Mac OS X

Operating System
Windows 7 64-bit
Windows 8 64-bit

Mac OS X 10.7.5
Mac OS X 10.8.5
Mac OS X 10.9.3 or later

 

Processor
Intel Core i7, 3.4 GHz
Intel Core i5, 3 GHz
Intel Core 2 Duo

Monitor
Optimized for 1920 x 1080 or higher
Minimum requirement is 1280 x 800

Memory
16 GB
8 GB
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4 GB

Video Card

Fast

‣ NVIDIA Geforce GTX 780

Medium

‣ NVIDIA Geforce GTX 560

‣ NVIDIA GeForce GTX 650

Slow

‣ Intel HD Graphics 4000, 
5000

‣ Intel Iris GraphicsNVIDIA 
GeForce GT 520, 620, 720

Fast

‣ NVIDIA GeForce GTX 
775M

Medium

‣ AMD Radeon HD 6770

‣ NVIDIA GeForce 750M

Slow

‣ Intel HD Graphics 4000, 
5000

‣ Intel Iris Graphics

‣ NVIDIA GeForce 320M

‣ Radeon HD 4670

Drawing Tablet

Best

‣ Wacom Intuos Pro

‣ Wacom Cintiq

Basic

‣ Wacom Bamboo

‣ Wacom Intuos

Media Player Apple QuickTime Player (free)
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Chapter 3: About Toon Boom Harmony
Toon Boom Harmony is the most advanced professional animation software on the market. Bringing 
together an impressive 2D drawing toolset with the ability to work in a real 3D space, and import 3D 
models,

Harmony Network combines the animation toolset of Harmony with an impressive database for 
collaborative workflow. Share assets, batch vectorize and render, and increase production efficiency.

Top Features

• Advanced Drawing Tools: Texture brushes, and thick and thin pencil lines

• Smart Colour Palettes: Colour you can adjust on the fly

• Character Rigging: Hierarchy, deform, and effects for creating sophisticated rigs

• Special Effects: An array of effects including highlights and shadows, glows, blurs, and a full 
particle effects engine

• Real 3D Camera: A camera you can reposition in a full 3D space

• 3D Integration: Allowing you to import 3D models, position and animate them in 3D space

• Batch Vectorizing and Rendering: Quickly process images for import and export through a 
single workstation or a render farm

• Database File Sharing: Share libraries, colour palettes, animation, and more across the whole 
team

• Production Pipeline Integration: Seamlessly integrate content from pre-production via 
Toon Boom Storyboard Pro

Toon Boom Pipeline
Toon Boom Harmony has been recognized for its excellence by winning many awards, including a 
Primetime Emmy® Engineering Award and the prestigious Ub Iwerks Annie Award for the integrated 
pipeline with Toon Boom Storyboard Pro.

Harmony works perfectly with Toon Boom Storyboard Pro for all pre-production phases. Therefore, 
animatics created in Toon Boom Storyboard Pro can be imported seamlessly in Harmony for 
animation and scene setup guidance.

Modules

          

 

Harmony Network is composed of the following modules:
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• Control Center below

• Stage on the facing page

• Draw on the facing page

• Sketch on page 30

• Scan on page 30

• Xsheet on page 31

• Paint on page 31

• Play on page 31

• Cloud on page 32

These modules are all accessible from:

• Windows: Start > Programs > Toon Boom Harmony 11.1

• Mac OS X: Applications > Toon Boom Harmony 11.1

• Linux: /usr/local/ToonBoomAnimation/harmony_11.1/lnx86_64/bin

• Controlcenter

• Stage

• Draw

• Sketch

• Scan

• Stage -xsheet

• Stage -paint

• Play

• ServerActivation

• ClientActivation

• LicenseWizard

Control Center

The Control Center module controls the database and organizes the production. The Control 
Center module is used to create the environments, jobs and scenes, as well as importing and 
exporting scene packages. The technical director or system administrator also uses the Control 
Center to create the login information for users to access the database.

Control Center is also available in a cloud form where users can access scenes via the Internet.

To learn more about Control Center, refer to the following guides:
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• Fundamentals Guide

• Installation Guide

• Control Center and Server Guide

Stage

The Stage module is the core of Harmony. It comprises all the major drawing, animation and 
compositing features. It is used to work in the scene: design, character breakdown, cut-out 
animation, traditional animation, ink and paint, exposure sheet, timeline, effects, compositing, 
camera moves, colour styling, and so on.

You cannot create scenes in Stage Harmony Network, you require Control Center. You create them 
directly in Stage with Harmony Stand Alone.

To learn more about Stage, refer to the following guides:

• Fundamentals Guide

• Getting Started Guide

• Traditional Animation Guide

• Paperless Animation Guide

• Cut-out Animation Guide

• Gaming Guide

• Compositing Guide

• Play Guide

• Preferences Guide

• Keyboard Shortcuts Guide

• Scripting Guide

• Utilities Guide

Draw
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The Draw module is a component of the Stage module. It contains all the tools necessary to create a 
paperless frame-by-frame animation project. There is no node system in this module, only the basic 
essential effects. Contrary to the Stage module, instead of creating effects in the Network view, you 
simply create them in the Timeline view. The Draw module also includes all the scene setup and 
camera features for you to do the compositing for your project.

• Fundamentals Guide

• Draw Guide

• Preferences Guide

Sketch

The Sketch module is a component of the Stage module. It contains the essential tools to animate 
frame-by-frame drawings and paint them. It allows you to add layers and animation, and paint and 
adjust the timing. There are no effects, camera or other compositing tools included in this module. 
The Sketch module allows you to focus on the paperless animation tasks at hand without being 
distracted by other features that are not necessary to your work.

To learn more about the Sketch module, refer to the following guides:

• Fundamentals Guide

• Sketch Guide

• Preferences Guide

Scan

The Scan module is used to scan drawings in batch. It creates a drawing list from the timing and 
exposure previously created in the exposure sheet (via Stage or Xsheet module).

It is possible to scan the drawings from a TWAIN device directly in the Stage module.

To learn more about the Scan module, refer to the following guides:

• Fundamentals Guide

• Scan Guide
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Xsheet

The Xsheet module is a component of the Stage module. It contains the tools used to create digital 
exposure sheets, columns and timing. It is mainly used in large traditional animation studios to 
maintain a structure and avoid users having to learn the full product application. This way, the Xsheet 
team can concentrate on their task without having to deal with the compositing and drawing tools.

To learn more about the Xsheet module, refer to the following guides:

• Fundamentals Guide

• Xsheet Guide

• Preferences Guide

Paint

Paint module is a component of the Stage module. It contains the drawing, painting and colour 
styling tools. It is mainly used in large traditional animation studios to maintain a structure and avoid 
users having to learn the full product application. This way, the colour styling or ink and paint team 
can concentrate on their task without having to deal with the compositing and timing tools.

To learn more about the Paint module, refer to the following guides:

• Fundamentals Guide

• Paint Guide

• Preferences Guide

Play

The Play module is used to play back the rendered image sequences enabling the user to view the 
final scenes and compositing results.

To learn more about the Play module, refer to the following guides:

• Fundamentals Guide

• Play Guide
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Cloud

Access your Database via the Cloud. When you're running a studio, you will most likely have a 
database set up.  This enables all the artists working on your production to share the same scenes 
and assets.

What the Toon Boom Cloud enables you to do is to host this database on the Internet.  When you do 
so, you can have freelancers log in from anywhere with an internet connection.  Then they can 
download a scene from the database, work on it, and upload it again.

No more need to spend time copying files to an FTP.  No need to have an admin exporting and 
importing files from the database.  Do it all directly through the Cloud.

To learn more about the Cloud module, refer to the following guides:

• Installation Guide

• Control Center and Server Guide
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Chapter 4: Starting Toon Boom Harmony
Once Harmony is installed, you are ready to start the application and animate! In this chapter, you will 
learn about starting the application, setting the resolution and opening the scenes. 

• Network Connection and Centralized Database on the next page

• Starting Draw on page 35

• Welcome Screen on page 40

• Saving a Scene on page 42

• Setting the Scene Length on page 51

• Adding a Drawing Layer on page 52

• Scene Settings on page 55

• Basic Commands on page 63

• Preferences on page 66
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Network Connection and Centralized Database

The Harmony solution is a revolutionary team-based infrastructure for animation production and 2D 
games. Its array of  features increases productivity and encourages creativity. Developed in conjunction 
with leading studios worldwide, Harmony is specifically designed for long-term episodic and feature 
length projects, providing a true animation pipeline. Several animators can work simultaneously on the 
same project while the asset library provides users with easy access to up-to-date media assets. 
Harmony is truly scalable; more than 100 staging clients can share animation just as easily as a few can. 

Note that Harmony can be used in Database mode via the Network connection or as a standalone 
application.

What is the Network Connection?

Harmony Network is the link between the client machines and the server. It lets you work on the 
different projects stored in the central Harmony database. 

At the heart of the Harmony solution is the server, which centralizes all the production assets in a 
repository. Loaded with production proven tools to manage administration tasks, the server is 
completely flexible and will fit in your existing infrastructure, whether you are on Windows, Linux or 
Mac OS X. To learn more, refer to the Control Center Guide.

Working with Harmony Stage Via Harmony Network

When you start Harmony Stage, you can opt to either work offline in the application as a standalone 
software, or connect to the database to work on projects via Harmony Network.

When working with Harmony Network, the scenes and their data are stored directly on the server. No 
data is saved or stored on the client machine. The client machines access the database and load the 
scenes and drawings directly from the server. Each time the user saves his scene, the data is updated 
directly on the server. There are no upload or download operations (check-in, check-out) done 
between the server and the clients.

If you have a standalone license, you will not have access to the database. You will automatically start the 
application in standalone mode.
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Starting Draw

You can run the Harmony on the Linux, Mac OS X or Windows operating systems.

How to start Harmony Draw

1. Do one of the following:

‣ Mac OS X: Double-click on the Harmony Draw  icon or select Applications > Toon Boom 
Harmony 11.1 > Draw.

‣ Windows: Double-click on the Harmony Draw icon or select Start > Programs/All 
Programs > Toon Boom Harmony 11.1  > Draw

‣ Linux: Select Applications > Toon Boom Harmony 11.1  > Draw

Toon Boom Harmony opens.

If you have a standalone license, Toon Boom Harmony will open directly with the Welcome screen.

2. In the User Name field, enter your username. It is generally provided by the supervisor, system 
administrator or team lead.

3. Select the  Connect to Database or Work Offline option.

‣ Connect to Database: (Your database must first be set up.) Lets you work on Harmony 
connected to the database so you can access scenes stored in the central database of the 
Toon Boom Server; certain options become available in the different menus. However, you 
will not be able to create new scenes directly from Harmony Stage and the available scenes 
will be the ones that were previously created using the Control Center.

‣ Work Offline: Enabled by default when you start Harmony for the first time. Using this 
mode lets you create new scenes and work locally on your machine on independent projects 
as you would with any local software. However, the following limitations apply:

• Options exclusive to Harmony Network will not be available in the different 
menus.

• You will not have access to any projects stored in the central database of the 
Toon Boom Server.

4. Click OK.

In Offline mode, the Welcome Screen opens—see Welcome Screen on page 40.

In Database mode, the Database Selector opens—see Connecting to the Database on the next 
page.
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Connecting to the Database

Before you can work in Draw via Harmony Network, you must be connected to the Harmony 
Database. When you connect to the database, you cannot create new scenes directly from Harmony 
Stage. The available scenes will be the ones that were previously created using the Control Center. 

How to connect to the Harmony database

1. Start  Draw—see Starting Draw on the previous page.

2. In the Toon Boom Stage window, select the Connect to Database option. 

 

3. In the User Name field, type in your Harmony username which is provided by your project lead or 
system administrator. 

 

4. Click OK. 

The Database Selector dialog box opens, displaying the environments available in Harmony 
database.
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5. In the Environments column, select the scene's environment (project, movie). 

 

6. In the Jobs column, select the scene's job (episode, sequence). 

7. In the Scenes column, select the scene. 

8. Get the permissions needed for this session by selecting one of the following options:

 

A Harmony project can be locked at various levels. Its timing, drawings, version and palettes can be 
locked. Locking means to get the rights to modify a scene or its assets. Other users cannot modify 
locked items. They will be prompted with an error message saying that the scene has been locked by 
another user. At that moment the scene will be displayed as read-only.

See the table below to understand the different lock possibilities.

Lock Description

Scene or Version Lock
Controls the Xsheet timing, layers, Network modules but not the draw-
ing, palettes, palette-lists or templates.

Drawing Lock Only one user can edit and save a locked drawing.

Palette Lock Only one user can edit and save a locked palette.

Palette-list Lock Only one user can edit and save a locked palette-list.

Library Folder lock Only one user can edit and save into that folder in the Library.

 

‣ Get rights to modify the scene: Allows the user to modify the selected version of the scene 
and access the version manager during the opened session.

‣ Get rights to modify the scene version: Allows the user to modify the currently selected 
scene version, but locks access to the version manager during the opened session.

‣ Get rights to modify the scene assets: Automatically gets all the edit rights to modify the 
scene and its assets. the user locking the scene using this option is the only user that can 
edit and save the scene version, all the drawings in that scene, all the palettes in the palette-
list, both palette-lists, but not the library folders..

9. Choose the version you want to open from the Version menu—see Saving a Scene on page 42.
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‣ The Saved By and Saved Date fields display the user who last saved the selected scene and 
the date of the last save.

 

10. Click Open.

Global Lock
Harmony Network has a lock system, referred to as Global Lock, for the different scenes and scene 
assets. As all the data on the server can be accessed directly and modified from any client machine by 
default, the scenes are locked. Users must obtain the rights to modify scenes in order to save their 
work on the server.

Only one user at a time can modify a scene. Once a scene is opened on a client machine, other users 
can only open the scene in read-only mode; they will not be able to save any modifications.

If you work in standalone mode, you automatically have the rights to modify all drawings and palettes.

The Global Lock has three levels:

A Harmony project can be locked at various levels. Its timing, drawings, version and palettes can be 
locked. Locking means to get the rights to modify a scene or its assets. Other users cannot modify 
locked items. They will be prompted with an error message saying that the scene has been locked by 
another user. At that moment the scene will be displayed as read-only.

See the table below to understand the different lock possibilities.

Lock Description

Scene or Version Lock
Controls the Xsheet timing, layers, Network modules but not the draw-
ing, palettes, palette-lists or templates.

Drawing Lock Only one user can edit and save a locked drawing.

Palette Lock Only one user can edit and save a locked palette.

Palette-list Lock Only one user can edit and save a locked palette-list.

Library Folder lock Only one user can edit and save into that folder in the Library.

 

‣ Get rights to modify the scene: Allows the user to modify the selected version of the scene 
and access the version manager during the opened session.

‣ Get rights to modify the scene version: Allows the user to modify the currently selected 
scene version, but locks access to the version manager during the opened session.

‣ Get rights to modify the scene assets: Automatically gets all the edit rights to modify the 
scene and its assets. the user locking the scene using this option is the only user that can edit 
and save the scene version, all the drawings in that scene, all the palettes in the palette-list, 
both palette-lists, but not the library folders..

These three levels of locking are available from the Database Selector when the user logs into 
Harmony. From there you can select a scene and obtain the rights to modify it by selecting the desired 
lock option.
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There are several different ways to obtain the rights to modify the scenes. It can be done when the 
user loads a scene from Harmony, inside the application once the scene is loaded, or when an 
environment, job or scene is created using the Control Center module.

Acquiring Rights to a Scene Once it is Loaded

If you opened a scene in read-only mode, but realize that you need to modify it, you can easily acquire 
the necessary rights without closing and reloading the scene. 

Note that it is not possible to acquire the rights to modify the scene assets once the scene is loaded. 
This process is done during the initial loading of the scene. To learn more about enabling the rights to 
modify while creating environments, jobs and scenes, refer to the Control Center guide.

How to set the scene's rights after the scene is loaded

‣ In the top menu, select File > Rights to Modify Scene or Rights to Modify Scene Version.
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Welcome Screen

When you start Toon Boom Harmony, the Welcome Screen appears. If a scene is already open, you 
can display the Welcome screen by selecting Help > Show Welcome Screen.

Note that Harmony Network does not display a Welcome Screen. It displays the Database Selector window.

The Welcome Screen allows you to:

1. Create scenes

2. Choose the scene resolution

3. Add or delete a custom scene resolution

4. Open recent scenes from a list

5. Open scenes by browsing

6. Open the Help documentation

7. Open Harmony directly without opening the Welcome screen first. 
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To display the Welcome screen later on, go to the top menu and select Help > Show Welcome 
Screen.

Accessing the Documentation

How to access the Harmony documentation

‣ In the Documentation section, click on the listed links to access the online documentation.

All the Harmony guides can also be opened directly in the software. From the top menu, select 
Help > Help or press F1.
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Saving a Scene

It is important to regularly save your scene. As you make changes to a scene, an asterisk (*) appears in 
the title bar beside the scene name to indicate that the scene contains unsaved changes.

It is quite frequent, when working on a scene, to try out different timings, effects, camera motions or 
parameters to see which one will work best. Harmony allows you to save a new version of your scene. 
It is really important to note that the drawings and palettes are the same between ALL the scene 
versions. You can modify the timing, effects, parameters and camera motion, but if you modify the 
drawings, they will be changed everywhere.

You can also automatically save your work. Refer to the Preferences guide to learn more about this 
function.

When you use Harmony Network and work in a scene on the database, there are many choices and 
options available when you save your work. 

• Save the scene as the current version.

• Save different versions representing different stages of the production of your scene.

• Save different versions representing different scene setups.

• Choose specific assets that you want to save, such as drawings or palettes. 

When you open the scene from the database and select the version you want to edit, you can save the 
changes you made in the current version or create a new version. The simplest way to save your work 
is to update the current version. 

You can delete any unnecessary versions using the Version Manager.

When working with multiple versions, you may want to merge some of the changes from one version 
into another. You may have created a version with some suggestions that you submitted to the 
director while continuing to work on the official version. If the director has approved some of the 
changes, you can go ahead and import them into the official version.

You might want to save some specific aspects of your scene or save a new version. The Advance Save 
feature allows you to do this. Once you have chosen the components to save, you will conclude the 
procedure by following the instructions in the  section. All the specific components that are selected 
throughout the different tabs of the Advanced Save dialog box will be saved. 

How to save a scene

‣ From the top menu, select File > Save.

‣ Press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X).

Auto-Save

How to open the Preferences dialog box

1. Do one of the following:

‣ Windows/Linux: From the top menu, select Edit > Preferences.

‣ Mac OS X: Select Stage > Preferences.

‣ Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

2. Select the General tab.
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3. In the Save section, select the Auto-save option.

• Interval (minutes): This is the frequency at which the auto-save takes place.

• Inactivity Interval (seconds): When Auto-save is about to take place, it verifies if you are 
drawing or doing anything in the application. If so, Auto-save waits this number of seconds 
before attempting another save.

• Ask Before Saving: Before performing an auto-save, you are prompted with a message to 
confirm if you want to save or not. You can choose to turn off this option.

• Enabled: This enables the Auto-save feature. If you do not want the system to automatically 
save your work, deselect this option. The auto-save is off by default.

How to save the current version of a scene in Harmony Network: 

1. Make sure that you have the necessary rights to save the current scene version. If you do not, you 
can acquire the rights by selecting File > Rights to Modify Scene Version or Rights to Modify 
Scene. 

2. From the top menu, select File > Save or press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X). 

When saving the scene for the first time, the Save dialog box opens, prompting you to name the 
version.

 

3. Edit the information in the current version:

‣ In the This Version field, enter a relevant name for the current version.

 

‣ In the Description field, enter a short description of the current version. 
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4. Click Save. 

How to delete versions

1. Make sure you have the necessary rights. If you do not, select File > Rights to Modify Scene. 

2. From the top menu, select File > Manage Versions. 

The Versions dialog box opens. 

 

3. In the Existing Versions list, select the scene version you want to delete. When a version is selected, 
information about it appears in the Description list.

4. Click Delete. 

The Confirm Delete Versions dialog box opens, warning you that the operation cannot be undone. 

 

5. Click one of the following:

‣ Yes: ONLY if you are absolutely certain that the version can be deleted.

‣ No: To cancel the operation and keep the version. 

About the Advanced Save dialog box

1. Make sure that you have the necessary rights to save the current scene version. If you do not, you 
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can acquire the rights by selecting File > Rights to Modify Scene Version or Rights to Modify 
Scene.  

2. From the top menu, select File > Advanced Save. 

The Advanced Save dialog box opens. 

File

In the File tab of the Save dialog box, you can do the following:
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• Save the scene as a new version 

• Overwrite an existing version 

• Set a new current version. 

Parameter Description

Save

‣ Enable this option if you want to save the modifications 
made to the current scene. 

‣ Deselect the Save option if you only want to save specific 
components of your scene listed in the Drawings, Palettes 
or Palette Lists tabs. This will disable all option in the File 
tab. 

This Version (number)
Saves the current version of the scene. You can rename the current ver-
sion by typing a new name into the field. 

New Version (number)
Saves the current scene as a new version. You can name this new version 
by typing a name into the field. 

Overwrite Existing Version
Lets you select an existing version of your scene from the list to over-
write it.

Description
Use this field to add or edit an existing description for the 
scene version you want to save. 

Mark as Current
Lets you set this scene version as the current one. This version will be 
automatically selected as the default current version when the scene is 
selected in the Database Selector dialog box

Drawings

The Drawings tab lists the modified drawings.
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Parameter Description

Drawing list
Lets you select the modified drawings to save, and deselect 
the ones you do not want to save.

Select All Selects all modified drawings in list.

Deselect All Deselects all modified drawings in the list.

Palettes

The Palette tab lists the modified colour palettes.
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Parameter Description

Colour Palette list
Lets you select the colour palette to save, and deselect the 
ones you do not want to save.

Show Recovered
Displays the recovered palettes in the list of modified 
palettes.

Select All Selects all modified colour palettes in the palette list.

Deselect All Deselects all modified colour palettes in the palette list.

Palette Lists

The Palette Lists tab lists all the modified colour palette lists.

 

Parameter Description

Palette Lists
Lets you select the modified palette list to save, and deselect 
the ones you do not want to save.

Show Recovered
Displays the recovered palettes in the list of modified 
palettes.

Select All Selects all modified palette lists in the list.

Deselect All Deselects all modified palette lists in the list.

How to save with advanced settings

1. After selecting the components to save, click Save. 
All the specific components that were selected throughout the different tabs of the Advanced 
Save dialog box are saved. 
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How to merge scene versions

1. From the top menu, select Edit > Open Merge Editor.

The Choose Scene Versions for Merge window opens.

2. In the Select Version to Merge Changes From list, select the scene version from which you want to 
merge the changes from in your current open version.

‣ In the Use Another Version for Reference section, you can select a different scene version to 
merge the changes into, rather than your current version.

3. Click Load.

The Merge Editor opens.
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4. From the right column, select the layers you want to merge the changes from into the reference 
version.

5. In the Select Element Range section, set the Start Frame and End Frame fields to indicate from 
what frame to what frame you want to take the changes from.

6. Click Merge Selected to complete the operation.

How to enable and disable the Open in Read Only mode if plugin syntax errors are 
detected preference

How to open the Preferences dialog box

1. Do one of the following:

‣ Windows/Linux: From the top menu, select Edit > Preferences.

‣ Mac OS X: Select Stage > Preferences.

‣ Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

2. Select the General tab.

3. In the Save section, enable or disable the Open in Read Only mode if plugin syntax errors are 
detected option.

 

50



Toon Boom Harmony 11.1 Draw Guide (Network)

Setting the Scene Length

Once you have opened your scene, you can set its length. 

How to set the scene length

1. From the top menu, select Scene > Scene Length.

The Set Scene Length dialog box opens.

2. In the Number of Frames field, enter the number of frames needed.

New Scene Startup Script
When you create a new scene, the TB_sceneCreated script automatically sets the scene length to 60 
frames and adds one of each of the following modules: drawing element, composite, display and 
write.

You can find the script in the Script Editor window.

You can customize this script to fit your current project needs. This way, you can set the default scene 
length to any number of frames you want, or even decide which types of elements and modules you 
want to be in your scene when you create it.

Refer to the Toon Boom Harmony Scripting Guide to learn more about using, creating and 
customizing scripts.
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Adding a Drawing Layer

Now that your scene is set up, you can start adding drawing layers.

How to add a drawing layer from the Timeline view

1. In the Timeline view, click the Add Drawing Layer button the .

The Add Drawing Layer window opens.

 

2. In the Name field, name your new layer.

3. Set the Line Art and Colour Art options to Vector to get a vector layer or to Bitmap to have a 
bitmap layer.

4. Click OK.

A new drawing layer is added to the Timeline view.
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Locking Drawings

The drawings are stored on the server database providing access to them from every client machine. 
They are locked to avoid different users from modifying the same drawings simultaneously. Only one 
person at a time can get the rights to modify them. The drawing rights are independent from the 
scene rights because in a production rush, two users may need to work on the same scene to finish 
painting the drawings faster. One user will get the rights for one set of drawings, and the second user 
the rights to another set of drawings. This prevents work from being duplicated.

When enabled, the Edit Drawings mode gives you the right to modify drawings, as well as create new 
drawings by drawing directly on an empty cell. This mode is enabled by default when you open a scene 
version with the rights enabled.

If you open the scene with full rights from the Welcome screen or Control Center, the Edit Drawing mode is 
not available.

When you disable the Edit Drawing Mode, you can use the Get Rights to Modify Drawings option on a 
selection of specific drawings. This is useful when, for example, many users are working on the same 
scene during the ink and paint process and they want to split the drawings to paint between them.

Also, once you got the rights to modify drawings, you can release these rights if necessary.

If your system crashes and the drawings remain locked, you can force the release of the rights. You 
must use this option carefully as data loss may occur if the scene is currently open and being edited by 
another person. Verify that no one else is using the scene prior to forcing the release of the drawing 
rights.

Since the drawings are stored on the server,  you might at times need to refresh the drawings that are 
displayed in your scene. 

How to enable the Edit Drawing Mode

1. From the top menu, select Edit > Edit Drawing Mode.

How to get the rights on a selection of drawings

1. Make sure that the Edit Drawing Mode is disabled.

2. In the Xsheet view, select the drawings you want to edit.

53



Chapter 4: Starting Toon Boom Harmony     Locking Drawings

3. From the top menu, select Edit > Get Rights to Modify Drawings or press Alt + L.

How to release the rights on a selection of drawings

1. In the Xsheet view, select the drawings you want to release.

2. From the top menu, select Edit > Release Rights to Modify Drawings or press Alt + Shift + L.

How to force the release of the rights of locked drawings

1. In the Xsheet view, select the drawings you want to release.

2. From the top menu, select Edit > Force Release Rights to Modify Drawings.

A Warning dialog box opens.

 

3. Do one of the following:

‣ Click Yes to force the release.

‣ Click No to cancel the force release. 

How to read changed drawings

‣ From the top menu, select File > Read Changed Drawings.
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Scene Settings

When you created your new scene, you set up the resolution and the alignment. However, if you want 
to change these initial settings later, you can do it using the Scene Settings dialog box. The different 
Scene Settings options are separated into four tabs.

How to open the Scene Settings dialog box

1. From the top menu, select Scene > Scene Settings.

The Scene Settings dialog box opens.
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Resolution Tab 

Parameter Description

Resolution Presets

You can select your project’s resolution (camera frame size) from this 
preset list.

‣ HDTV: High definition television delivers a higher quality image than 
standard television (4:3) does, because it has a greater number of 
lines of resolution. To take advantage of the superior quality your 
output device must be compatible with HDTV technology to make 
this resolution setting useful.

‣ HDTV_Vertical: The "vertical resolution" of HDTV_Vertical refers to 
how the images will be aligned in relation to the actual scene frame 
(default 4:3 grid). Note that the camera resolution and the scene 
frame are not the same. When working with 12 or 16 field drawing 
grids, the grid is a different aspect ratio from the camera frame. 
When you fit vertically, you fit the images with the top and bottom of 
the scene grid.

‣ film-1.33: Use this resolution setting for the academy film format 
that conforms to the standard 4:3 aspect ratio.

‣ film-1.66:  Use this resolution setting for the widescreen film format 
that conforms to the 16:9 aspect ratio.

‣ film-1.66_Vertical: This is essentially the same as film-1.66. Refers to 
how the drawing is fit into the scene frame. When working with 12 or 
16 field drawing grids, the grid is a different aspect ratio from the 
camera frame. When you fit vertically, you fit the images with the top 
and bottom of the scene frame.
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‣ NTSC: This is the standard analogue television broadcasting system 
used in North America and conforms to the North American 
standards on how rectangular pixels are displayed for computer and 
television screens.

‣ PAL: This resolution works best with the European format for 
television and computer screens, as the rectangular pixels are 
displayed at a different orientation.

‣ Low: This format is ideal for videos destined for the web, where size 
and fast download of a video file might take precedence over 
quality.

Selected Resolution 
Preset

Displays the selected resolution preset.

Save Resolution Set-
ting

Click the Save Resolution button after you define your new resolution 
to save it as a preset.

If you are working in Harmony Network, you will be prompter a dialog 
box asking you to name the new resolution as well as the level at 
which you want to save the resolution,conf file.

Pixel Dimensions

Displays the pixel dimensions for your project resolution.

If you decide to type in the pixel dimensions, or use the up and down 
arrows to change the pixel increments, you will have to save your 
custom selection in order to save it as a new preset. It will then appear 
in the resolution selection list. It doesn't modify the current resolution 
preset.

Aspect Ratio
Displays the ratio between the horizontal and vertical dimensions of the camera 
framing. Each resolution setting has a preset aspect ratio that cannot be 
changed.

Frame per second

Sets the frame rate for your project. The higher the frame rate, for 
example 30 fps, the faster the animation will pla. The lower the frame 
rate, for example 12 fps, the slower your animation will play. Avoid 
going under 12 frames per second as your animation will have a 
choppy playback. The human eye requires a minimum of 12 frames per 
second to perceive a fluid animation.

Field of View
Use these options to define the FOV (field of view) of the camera 
(angle of the camera cone) and how the drawing elements (and 
drawing grid) align to the scene grid. The drawing grid is always 
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scaled proportionally to a 4:3 ratio (unless you change the scene 
alignment), therefore changing the Field of View setting may not show 
a visible difference if your project resolution is also 4:3, such as NTSC.

‣ Horizontal Fit: The camera resolution is set to fit the left and right 
edges of the scene grid.

‣ Vertical Fit: The camera resolution is set to fit the top and bottom 
edges of the scene grid. 

‣ Custom Fov: After selecting this option, use the  now-active field to 
the right to enter in a value, in degrees, of the angle that you want 
the camera cone to be. Increasing this value  will make the camera 
cone wider (the angle is more obtuse), widening the FOV and 
making the grid and all elements appear farther away. Decreasing 
the default value  will create the opposite effect.

Projection

The Projection settings allows you to modify the type of camera your 
scene is using. You can either use a perspective camera (regular 
camera) or orthographic camera (no perspective).

‣ Perspective: The Perspective option is the default and most 
common option. Objects placed closer to the camera will be 
displayed bigger and objects placed further away will be displayed 

58



Toon Boom Harmony 11.1 Draw Guide (Network)

smaller.

‣ Orthographic: The Orthographic option is very specific to the 
gaming pipeline. It changes the camera from Perspective to 
Orthographic, meaning that there is no more perspective in the 
Camera view. Objects, when moved in depth will not change size. 
There is more information available about this option in the Gaming 
user guide. In order  to create scenes with the Orthographic camera 
by default, you need to create a new custom scene resolution.

Alignment Tab

Parameter Description

Alignment

The Alignment presets give you two preset options:

‣ 4:3 12 Fields: Defines the units of your project to have a 4:3 ratio 
and sets up 12 of these units to run both vertically and horizontally in 
four cardinal quarters (NW, NE, SW, SE). This Alignment preset is 
visible in the FOV and drawing grids.

‣ Square 12 Fields: Defines the units of your project to have a 1:1 or 
square ratio and sets up 12 units to run both vertically and 
horizontally in four cardinal quarters (NW, NE, SW, SE). This 
Alignment preset is NOT visible in the FOV and drawing grids.

Units Aspect Ratio

In the Units Aspect Ratio fields, enter the aspect ratio of the grid you 
will use. The aspect ratio describes the shape of the grid unit. A 
square grid unit would have the ratio 1:1, whereas a grid unit of aspect 
ratio 4:3 is a unit with one side 1.33 times as big as the other side.
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If the aspect ratio you want to use is 1:1, enter 1 in the Left/Right field 
(X-axis) and 1 in the Up/Down field (Y-axis). The default Aspect Ratio is 
set to 4:3 as it is the one used by traditional animators, who are 
accustomed to working with the grid system described above. 

Number of Units

In the Number of Units fields, enter the number of horizontal, vertical 
and depth units for your scene’s grid.

Animators who prefer to work traditionally will understand the default 
setting of 24 units horizontal by 24 units vertical as it, once again, 
corresponds to the grid above. Twelve is a common setting for the 
field depth.

Those who prefer to work in pixels should enter the pixel dimensions 
(3) of their project. This way if you want to move something over 600 
pixels you just need to type in 600 units.

Coordinat
es at 
Centre

In the Coordinates at Centre, you can enter a new coordinate for the 
centre of your scene.

By default, the (0,0) centre is set in the middle of the grid as shown in 
the grid above. If you want to change the centre of your grid, for 
example to the upper left corner, you would enter (-12, 12), -12 units 
across and 12 units up. That is of course unless you changed the 
number of units to match the pixel dimensions of your scene. Then you 
would enter negative half the width and positive half the height.

Save
Saves your current Alignment settings and be able to select them later from the 
list.
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If you change your scene‘s alignment from 4:3 12 Fields to Square 12 Fields part way though your project, 
you may find that the animation grid becomes offset. To correct this, choose the following setting from the 
Layer Properties panel‘s Advanced tab: Alignment > Alignment Rule > Centre First Page.

Bitmap Resolution Tab

The bitmap resolution settings at the scene level affects newly created bitmap art layers.

Parameter Description

Scene Resolution This is the scene resolution preset name and size in pixel.

Width

This is the width of the resolution for the bitmap that will be created. 
This is not the actual size of the bitmap. TVG drawings (Toon Boom 
drawing native format) have an infinite size. Bitmap TVGs are composed 
of small tiles. Therefore it does not mean that because you have art-
work at the four corners of your camera frame or even quite far outside 
of your drawing that your bitmap image will be very large and heavy. By 
default, it is set to the same width as the scene resolution.

Height
This is the height of the resolution for the bitmap that will be created. 
By default, it is set to the same height as the scene resolution.

Resolution Factor

This is the size of the bitmap resolution in relation to the scene res-
olution. If you increase the percentage, the width and height fields will 
increase accordingly. If you plan to animate the camera and zoom into 
your background, you will need to set a higher resolution so that the 
smaller area in which you will zoom will be 100% of the scene resolution.
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Advanced Tab

The Advanced tab contains an option for Toon Boom Digital Pro release 7.3 and Harmony release 
7.3. 

Since version 7.8, the method in which Z-Ordering is calculated has been optimized. Enable this 
option if you want to use the version 7.3 system.

Toon Boom Digital Pro and Toon Boom Harmony 7.3 allowed smaller values on the Z-axis such as 
0.0001. Since  version 7.8, the Z-ordering calculation is now optimized and allows only larger values 
such as 0.001.
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Basic Commands

This table lists the most common commands used in Harmony.

Command Action Access Methods

Open Displays the Open 
Scene dialog box. 
Browse your file system 
for a scene file.

The Open command is 
not disabled when a 
scene is opened. You 
can open a new scene 
from the current one 
and the previous scene 
will be closed.

File > Open

Press Ctrl + O 
(Windows/Linux) or ⌘  
+ O (Mac OS X).

Close Closes the currently 
opened scene, but does 
not close the Harmony 
application.

File > Close

Save Saves all changes made 
to the opened scene, 
drawings, palettes, and 
palette lists.

File > Save

Press Ctrl + S 
(Windows/Linux) or ⌘  
+ S (Mac OS X).

Quit Closes 
HarmonyHarmony 
Stage.

Windows/Linux: File > 
Quit

Mac OS X: Stage> 
Quit

 

Cut Removes selected 
objects. You can then 
paste the object or its 
properties to another 
object.

Edit > Cut

Press Ctrl + X 
(Windows/Linux) or ⌘  
+ X (Mac OS X).

Copy Copies selected objects 
and properties.

Edit > Copy

Press Ctrl + C 
(Windows/Linux) or ⌘  
+ C (Mac OS X).

Paste Places an object you cut 
or copied into the 
location you select in 
the Camera, Drawing 
and Timeline views.

Edit > Paste

Press Ctrl + V 
(Windows/Linux) or ⌘  
+ V (Mac OS X).
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Command Action Access Methods

Delete Removes selected 
objects.

Edit > Delete

Delete

Select All Selects all drawing 
objects in the current 
drawing window in the 
Drawing, Timeline and 
Camera views. This 
helps you manage 
multiple objects as one 
when moving them.

Edit > Select All

Press Ctrl + A 
(Windows/Linux) or ⌘  
+ A (Mac OS X).

Deselect All Deselects all selected 
objects in the Drawing 
and Camera views.

Edit > Deselect All

Esc

Undo Removes remove the 
last change made to 
your project. Harmony 
supports multiple undo, 
so you can undo 
changes you made in 
the order you made 
them.

Edit > Undo

Press Ctrl + Z 
(Windows/Linux) or ⌘  
+ Z (Mac OS X).

Redo Redoes and operation 
you have undone that 
you later decide to 
keep. This command is 
active only after you use 
the Undo command.

Edit > Redo

Press Ctrl + Shift + Z 
(Windows/Linux) or ⌘  
+ Shift + Z (Mac OS X).

Select Child Skipping 
Effects

Lets you select the first ele-
ment parented to the selec-
ted peg element in the 
Timeline view skipping 
effects in the hierarchy.

Animation > Select 
Child Skipping Effects

Press Shift + B.

Select Children Lets you select all 
elements parented to 
the selected peg 
element in the Timeline 
view.

Animation > Select 
Children

Select Child Lets you select the first 
element parented to 
the selected peg 
element in the Timeline 
View.

Animation > Select 
Child

Press Shift + B.

Select Parent 
Skipping Effects

Lets you select the Animation > Select 
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Command Action Access Methods

parent of the selected 
element in the Timeline 
view skipping effects in 
the hierarchy.

Parent Skipping 
Effects

Press B.

Select Parent Lets you select the 
parent of the selected 
element in the Timeline 
view.

Animation > Select 
Parent

Press B.

Select Previous 
Brother

Lets you select the next 
element (above current 
element) in the Timeline 
view.

Animation > Select 
Previous Brother

Press /.

Select Next Brother Lets you select the next 
element (below current 
element) in the Timeline 
view.

Animation > Select 
Next Brother

Press ?.

Help Launches the Toon 
Boom Harmony Online 
Help system, complete 
with instructions on 
how to use the system. 
This requires an 
internet connection.

Help > Help

Toon Boom Harmony 
on the Web

Launches the Toon 
Boom Harmony 
website, which features 
a Support and 
Community > Forum 
section.

Help > Toon Boom 
Harmony on the Web

About Use the About 
command to access 
general information 
about the software.

Windows/Linux: Help 
> About

Mac OS X: Stage > 
About
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Preferences

An important feature of Toon Boom Harmony is the Preferences dialog box. From here you can 
customize your interface, tool behaviour and shortcuts. Throughout this guide, you are often required 
to go to the Preferences dialog box to set parameters and options.

To learn about the different preferences available, refer to the Preferences Guide.

How to open the Preferences dialog box

1. Do one of the following:

‣ Windows/Linux: From the top menu, select Edit > Preferences.

‣ Mac OS X: Select Stage > Preferences.

‣ Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

66



Toon Boom Harmony 11.1 Draw Guide (Network)

Chapter 5: Interface
Knowing how to manage the Toon Boom Harmony interface helps you to work efficiently and organize 
your workspace conveniently. There are a series of views and toolbars you can use as you perform 
different operations. Usually, each person has a specific way of working in the interface and prefer 
particular views and toolbars. In this chapter, you will learn about the main elements of the interface 
and how to manage them.

Throughout this chapter you might notice slight differences between your interface and the images used to 
demonstrate the procedure. This is because the images are taken from Harmony Stage. Draw is a subset of 
Harmony Stage.

The Harmony interface is set to a dark theme by default. You have the option of switching to a light 
theme.

How to change the interface theme

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS 
X) .

The Preferences dialog box opens.

2. Select the General tab.

3. In the Options section, deselect the Use Dark StyleSheet option to use the light theme.

4. Restart Harmony.
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This chapter is divided as follows:

• Menus on the facing page

• Managing the Views on page 71

• Managing the Toolbars on page 75

• Managing the Workspace on page 80

• View References on page 85

• Toolbar References on page 125

• Interface Navigation on page 129
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Menus

Harmony has a large number of functions and options that you can access from the following menus:

Top Menu 

The top menu contains most of the commands. Depending on the view you are working in and the 
element, some commands are available and others not. The top menu is always located at the very 
top of the interface.

The top menu contains the following categories:

• File

• Edit

• View

• Play

• Insert

• Scene

• Drawing

• Animation

• Windows

• Help

On Mac OS X, there is a Stage category containing the following commands:

• Preferences

• About

• Quit

View Menu 

Some views have their own menu. These menus contain commands specifically related to that view.
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How to access the view menu

1. In the view's top-left corner, click the Menu  button.

A list of commands is displayed.

Quick Access Menu 

Each view has a quick access menu containing commands you will use most often. This menu is 
accessed by right-clicking anywhere in the view.
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Managing the Views

The Harmony user interface is composed of different views, each one designed for a specific purpose. 
You can modify the location and accessibility of the views by adding a new view as a tab or as a 
window. You can also swap the view locations around.

Throughout this chapter you might notice slight differences between your interface and the images used to 
demonstrate the procedure. This is because the images are taken from Harmony Stage. Draw is a subset of 
Harmony Stage.

It is important to know about the active view. When a view is active, a red rectangle appears around 
the view. Keyboard shortcuts and top menu options are linked to the active view. If a menu option is 
greyed out, it either means it does not apply to your layer, drawing or other type of selection or the 
option does not apply to the active view.

Workspace modifications are automatically saved when you exit the application unless you deselected 
the Automatically Save Workspace option in the Preferences dialog box.

How to add a view

1. Select the view you want to add from Windows > the desired view.

‣ You can also use the Window drop-down menu button in each view. Click the Add View 
button and select a view from the list.You can open several instances of the same view 
except for the Timeline, Tool Properties, Colour and Drawing views.
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By default, the view appears tabbed.

How to dock a floating window in the workspace

1. Drag the window’s tab onto one of the workspace’s views. You can drop the view onto the other 
existing tabs to tab the view with the other ones. You can also drop the view onto either side of an 
existing view to insert the floating one beside it. When you get close to one of the edges, a black 
rectangle will appear, indicating where the view will be inserted.

How to close a view

1. Click the Close View 
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 button.

‣ If there are several tabs in the same window, hold Shift down and click the Close View  
button to close all tabs together.

How to swap views around

1. Select the view's tab and drag it onto one of the view’s separators, top area or onto another 
view’s tab.

2. When a blue rectangle outline appears showing an available location for the view, release the 
mouse button and drop the view tab into position. One of three things will happen:

• The view becomes a tabbed window.

• The view becomes a floating window.

• The view becomes a new docked window.

How to resize a view

1. Position your cursor on the edge of the view you want to resize.

2. When you see the Resizing  cursor, click and drag the side of the window to the desired width 
or height.
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You can also temporarily hide a view to get more working space.

How to temporarily hide a view

1. On the edge of the window you want to hide, click the Collapse/Expand button. 

The view is compressed and only the Collapse/Expand button is visible.

2. Click the Collapse/Expand button again to redisplay the view.
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Managing the Toolbars

Harmony contains toolbars which, by default, are located at the top of the interface. Some of the 
workspace’s views also have their own toolbars which you can move around. You can reposition the 
toolbars to suit your work style or hide unused ones.

Throughout this chapter you might notice slight differences between your interface and the images used to 
demonstrate the procedure. This is because the images are taken from Harmony Stage. Draw is a subset of 
Harmony Stage.

You can display or hide toolbars using the menus. The Toolbar menu only contains the View toolbars 
of the views that are displayed in the workspace. As you show or hide views in your workspace, the 
Toolbar menu updates.

The top toolbars can also be displayed directly in a view. Only one instance of each toolbar can be 
displayed. If a toolbar is already displayed in the top area and you decide to display it in a view, the 
selected toolbar will move from the top area to the view.

The View toolbars can be customized to contain your favourite tools and options. Using the Toolbar 
Manager window, you can organize different toolbars to suit your working style.

If you prefer to have all your tools visible in the Tools toolbar, the Flat Tool Toolbar option allows you 
to expand the toolbar so there are no nested toolsets in the toolbar. When you set this option, you 
will need to close Harmony and restart it for the new interface to be displayed.   A default set of tools 
will appear in the toolbar. However, you can customize which tool icons appear in the toolbar to fit 
your work pattern. 

If the default toolbar does not contain the tools you require, you can customize the toolbar.

Once you are displaying the flat toolbars, you can customize the tools which appear in the toolbar. 
This means that you can change the default set of tools and replace the tools you use less frequently 
with ones use more often. This customizing is done through the Toolbar Manager.

How to show and hide a toolbar

1. From the top menu, select Windows > Toolbars > the desired toolbar.
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‣ You can right-click anywhere in the toolbar area to access Harmony toolbars. View toolbars, 
however, are not available by right-clicking the toolbar area. You can access the toolbar of 
any open and active view by right-clicking in the view's top area or the Windows menu. 

How to resize a toolbar

1. Hide a portion of a toolbar by dragging another open toolbar over its tail-end. 

2. Click on the arrows appearing at the end of the collapsed toolbar to expand it.
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How to move a toolbar

1. Select the toolbar you want to move by clicking its anchor point  and dragging it into a view toolbar 
area or another position in the top or side interface toolbar area.

2. When a highlighted zone appears showing an available location for the toolbar, release the mouse 
button and drop the toolbar into position.

‣ 1. Dock to the top toolbar area.
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‣ 2. Move a toolbar down a row.

‣ 3. Dock to the left toolbar area.

How to customize a view toolbar

1. In the chosen view, right-click on any button in the toolbar where you want to add or subtract a 
new button. You can also reorder the buttons. Make sure the button you right-click on is active.

2. From the menu, select Customize.

The Toolbar Manager window opens.

3. To add a new icon to your toolbar, select the tool or command from the Available Tools list and 
click the Right Arrow   button to switch it to the Toolbar list.

4. To remove an icon from your toolbar, select the tool or command in the Toolbar list and click the 
Left Arrow   button to switch to the Available Tools list.
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5. To reorder the icons in your toolbar, select the command to be moved from the Toolbar list and 
click the Up  or Down  buttons to move it to the correct location.

6. Click OK when you are finished.

How to use enable the Flat Tool Toolbar preference

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS 
X).

2. In the Preferences dialog box, select the General tab.

3. Select the Flat Tool Toolbar option. 

4. Click OK.

5. Save your work and close Harmony. 

6. Restart Harmony. 

The Tools toolbar no longer contains nested tools.
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Managing the Workspace

The Harmony interface is composed of several views. You can customize your workspace to suit your 
working style, save it as a new workspace, and load it from the Workspace toolbar.

The first time you open Harmony, the default workspace is loaded. Other workspaces are available 
such as the Hand-Drawn Animation and Compositing workspaces. These display different views and 
toolbars. You can access these workspaces, and any others you create, from the Windows menu and 
the Workspace toolbar.

By default, when you modify the look of a workspace, it is automatically saved. If you prefer to keep 
your workspaces as they are and only save the modifications when you really want to, you must disable 
the Automatically Save Workspace option.

The Workspace Manager allows you to modify, create, delete, rename and reorder you workspaces. 
You can save your workspace as a new version to avoid over-writing the current one. If you do not 
want to modify the current workspace, use the Workspace Manager to create another one and then 
modify that one.

You can also restore modified workspaces to their original default layout if you do not like the current 
modifications or inadvertently closed some windows.

How to load a workspace

1. Do one of the following:

‣ From the top menu, select Windows > Workspace > Workspace.  

‣ Select a workspace from the Workspace toolbar.

How to open the Workspace Manager
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1. Do one of the following:

‣ In the Workspace toolbar, click the         button.

‣ From the top menu, select Windows > Workspace > Workspace Manager.

How to create a new workspace

1. Open the Workspace Manager.

2. In the Available Workspaces list, select an existing workspace.

3. At the bottom of the Available Workspaces list, click the Add  button to add a workspace.

4. Select the new workspace that was created. Click Rename and give it a new name.
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5. Select the new workspace and click the Right Arrow  button to move it to the Workspace 
toolbar.

6. Click OK.

How to rename a workspace

1. Open the Workspace Manager.

2. Choose the workspace to be renamed from the list.

3. Double-click on the workspace to be renamed or click the Rename button. This allows you to edit 
the name. 

4. Type in the new name of the workspace.

5. Press the Enter/Return key to validate the name.

6. Click OK. 

How to disable the Automatically Save Workspace preference

1. From the top menu, select Edit > Preferences (Windows/Linux) orStage > Preferences (Mac OS 
X) to open the Preferences dialog box.

2. Select the General tab.

3. In the Options section, deselect the Automatically Save Workspace option.

4. Click OK. 
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The Save Workspace   button appears in the Workspace toolbar.

How to save a workspace manually

1. Do one of the following:

‣ In the Workspace toolbar, click the Save Workspace   button. 

‣ You can also select Windows > Workspace > Save Workspace.

How to save your workspace as a new version

1. From the top menu, select Windows > Workspace > Save Workspace As.

The Save Workspace As dialog box opens.

2. Type in a workspace name and click OK. 

How to delete a workspace

1. Open the Workspace Manager.

2. In the Workspace Manager, select the workspace to be deleted and click the Left Arrow   
button to move it to the Available Workspaces list.

3. Select the workspace from the Available Workspaces list, then click the Delete  button to 
delete the workspace.

4. Click OK.

How to show a workspace

1. Open the Workspace Manager.

2. In the Available Workspaces list, select the workspace to be displayed and click the Right Arrow  
 button to move it to the Workspace toolbar.

3. Click OK. 

How to hide a workspace

1. Open the Workspace Manager.

2. In the Workspace Manager, select the workspace to be hidden and click the Left Arrow   button 
to move it to the Available Workspaces list.

3. Click OK. 
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How to reorder workspaces

1. Open the Workspace Manager.

2. In the Workspace toolbar, select the workspace to be reordered and on the Up  or Down  
buttons to move it up or down.

3. Click OK. 

How to restore the default workspaces

‣ From the top menu select Windows > Restore Default Workspace.
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View References

Harmony contains a series of views that are each focused on a specific set of tasks. Here are the views 
available:

• Camera view

• Colour view

• Drawing view

• Function view

• Layer Properties view

• Library view

• Message Log view

• Model view

• Perspective view

• Script Editor view

• Side view

• Timeline view

• Tool Properties view

• Top view

• Xsheet view

Camera View
The Camera view is the centre of operations in Harmony. In this view, you will draw, paint, animate, 
create animation paths and see your results. You can also move through your symbol’s hierarchy.

The Camera view has a top and bottom toolbar that you can use to navigate in the view, change the 
display mode, or go back up your symbols hierarchy. 
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1. Light Table

When you have a drawing layer or drawing selected, the Light Table button  button allows you to 
fade the colours of the other layers so you can see the current artwork better as you edit with a 
drawing tool. Note that the light table does not work when using a layer editing tool such as the 
Transform  tool.

86



Toon Boom Harmony 11.1 Draw Guide (Network)

2. Current Drawing On Top

When this button is enabled, the drawing that you are currently editing with a drawing tool is 
temporarily displayed in front of all the other elements. The actual scene is not modified.

3. Camera Mask

The Camera Mask  button shows or hides a black mask around the scene’s frame to avoid seeing 
the unnecessary artwork. This option is handy when you are animating and setting up the scene. It 
allows you to see your scene’s composition better.

You can also access this feature from the top menu by selecting View > Show > Camera Mask.

4. Safe Area 

The Safe Area  button shows or hides the TV safety zone and the centre of the camera frame. The 
Safe Area will adapt to the scene resolution as well as the safety zone and frame’s centre.

You can also access this feature from the top menu by selecting View > Show > Safe Area.
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6. Outline Locked Drawings

Drawings that are locked in the Timeline view (cannot be selected in the Camera view) will be 
displayed as wireframes.

7. Reset View 

The Reset View  button will reset any panning, zooming or rotation done in the Camera view and 
return the display to the initial settings. You can also press Shift + M.

8. Zoom Menu

The Zoom menu lets you enlarge or reduce the Camera or Drawing view display. 

To make the camera frame size always match the size of your view, select the Fit to View option. 
Click the drop-down arrow and select a zoom level or press 1 and 2.
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9. OpenGL View Mode 

The OpenGL View Mode  button switches the Camera view to fast display, letting you see your 
animation play in real time. The OpenGL display requires less memory. The final look of your effects 
is not shown in the OpenGL View Mode. You must switch to the Render View Mode to see your 
effects.

9a. Render View Mode

The Render View Mode  button switches the Camera view to a fully rendered display showing the 
final image of the current frame. If a modification is done to your current frame or if you move to a 
different frame, click the Update Preview button to update the display if your preview does not 
update automatically.

The Render View Mode display lets you see the final look of your frames including effects and 
antialiasing. You cannot play back your scene in Render View Mode. To see your scene fully rendered 
and to play it back, you must press the Render and Play  button in the Playback toolbar.
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9b. Matte View Mode

The Matte View Mode  button switches the Camera view to a matte display showing the alpha 
channel of the elements in your scene. The transparency level ranges from 0 to 100 percent. Zero 
percent is completely transparent and represented by black and 100 percent is completely opaque 
and represented by white. Everything in between these extremes has a transparency level 
somewhere between 1 and 99 percent and is represented in various shades of grey. 

‣ To access the Matte View mode, click on the Render View Mode  button and select 
Matte View from the drop-down menu.

10. Drawing Name 

The Drawing Name field displays the name of the selected drawing, as well as the layer containing it. 
If the cell does not contain any drawing, an Empty Cell text is shown in the field.

11. Tool Name 

The Tool Name field displays the name of the selected tool. If you temporarily override a drawing 
tool using a keyboard shortcut, the tool’s name will be highlighted in red. You can temporarily 
override a tool by holding its keyboard shortcut without the [Alt] key. For example, the Select tool 
shortcut is Alt + S. If you hold down [S], you will switch to the Select tool. As soon as you release the 
key, you will return to the tool you were using.

12. Frame Number 

The Frame Number field displays the number of the current frame.

13. Selected Colour

The colour swatch displays the currently selected colour in the Colour view.

14. Camera View Toolbar

The Camera View toolbar contains all the tools and options you can use in the Camera view to draw, 
animate or set up the scene. The toolbar can be displayed or hidden by right-clicking on it and 
selecting or deselecting the Camera View toolbar.
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15. View Menu

The View menu contains all the tools and options that you can use in the Camera view to draw, 
animate or set up the scene.

16. Editing Stack Menu 

The Editing Stack menu displays the names of the symbols and their hierarchy when you are editing a 
symbol. You can click on the different names to go back up to the different parent symbols or the 
top/current project.

Colour View
The Colour view is where you create colours and palettes and import existing palettes into your 
project. The Colour view is also necessary for drawing, painting and creating colour styling.

The Colour view has two display modes:

• List mode

• Swatch mode

How to switch between the display modes

1. From the Colour View menu, select Colours > Swatch Mode and do one of the following:
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‣ Select the option to display the swatches.

‣ Deselect the option to display the colour list.

When you are painting on bitmap layers, the Colour view will look like the following. It contains a 
subset of the tools available when working with vector layers.

1. Add Colour 

The Add Colour  button lets you add a new colour swatch to the bottom of your colour list.

2. Remove Colour 

The Remove Colour  button lets you delete the currently selected colour swatches. If the colour 
swatch is used in your project, the Delete Colour dialog box will appear asking you to confirm the 
operation.

‣ Click OK to confirm the operation or Cancel to cancel it.

Zones painted with colour swatches which have been deleted will turn red, easily identifying them so 
you can repaint them with another colour swatch.
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3. Add Texture 

The Add Texture  button lets you add a bitmap colour swatch to your palette. You can load 
photos and textures and paint your drawings with it. The bitmap image must be a TGA or PSD file 
format.

4. Set Current Brush Colour 

The Set Current Brush Colour  button let you set the currently selected colour swatch as the 
colour used by the Brush  tool. If you select a new colour in the Colour view while using the Brush 
tool, the Set Current Brush Colour swatch will be updated.

5. Set Current Pencil Colour 

The Set Current Pencil Colour  button lets you set the currently selected colour swatch as the 
colour used by the Pencil , Polyline , Ellipse , Rectangle  and Line  tools. If you 
select a new colour in the Colour view while using any of these tools, the Set Current Pencil Colour 
swatch will be updated.

6. Set Current Paint Colour 

The Set Current Paint Colour  button lets you set the currently selected colour swatch as the 
colour used by the Brush  tool. If you select a new colour in the Colour view while using the Paint 
tool, the Set Current Paint Colour swatch will be updated.
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7. Link/Unlink Three Colours 

The Link/Unlink Three Colours  button lets you link the Set Current Brush Colour, Set Current 
Pencil Colour and Set Current Paint Colour swatches to the currently selected colour swatches in the 
Colour view.

8. Show/Hide Palette List View 

The Show/Hide Palette List View   button lets you display the Palette List view in the Colour view. This 
option is for the advanced user who wants to create colour palettes for their props and characters.

9. Colour Swatch Name 

Each colour swatch available in the Colour view can have its own name, making it easy to identify 
which colour is used to paint what part of your character or background. 

Two colours can have the same name.
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10. Colour Swatch 

A colour swatch is a specific colour used to paint a certain zone of a character or background. Colour 
palettes are composed of colour swatches. They can also be called colour pots. When you paint a 
zone with a colour swatch, the zone is linked to the swatch. So if you update the swatch’s tint, the 
zone will be updated along with it. This allows you to modify your animation colours even after it is 
completely painted.

11. Colour View Menu 

The Colour view   menu lets you access commands related to the Colour view such as creating 
new palettes, adding new colour swatches, and displaying the Tint panel.

12. Add Palette

The Add Palette  button lets you add a new palette to the bottom of your palette list.

13. Remove Palette 

The Remove Palette  button lets you delete the currently selected palette. If the colour swatch is 
used in your project, zones painted with colour swatches which have been deleted will turn red, 
easily identifying them so you can repaint them with another colour swatch.

14. Link Palette

The Link Palette button lets you access other palettes created in the project and link them to your 
scene.

15. Order Palette List

The Up and Down arrows let you reorder the selected palette. When using clone palettes (colour 
styles), the highest palette is the list will override its clone located lower in the list.
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16. Edit Palette Mode 

In Network mode, the Edit Palette Mode  button lets you get the rights to modify the palette. 
The palette files can be locked to avoid accidentally modifying the palette.

Drawing View
In Harmony, you can draw in the Drawing or Camera view. Although the two views are similar, when it 
comes to drawing, there are some differences.

Only the selected drawing is displayed by default in the Drawing view. You can use features, such as 
the light table to display the current drawing of all the enabled layers of your scene in washed-out 
colours, or the Onion Skin to display the previous and next drawings of the currently selected drawing 
layer.

1. Drawing Area

This is the main space in the Drawing view. It is where you draw and where the drawings are 
displayed.
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2. Zoom Menu

The Zoom menu lets you enlarge or reduce the Camera or Drawing view display. 

To make the camera frame size always match the size of your view, select the Fit to View option. 
Click the drop-down arrow and select a zoom level or press 1 and 2.

3. Drawing Name

The Drawing Name field displays the name of the selected drawing, as well as the layer containing it. 
If the cell does not contain any drawing, an Empty Cell text is shown in the field.

4. Tool Name

The Tool Name field displays the name of the selected tool. If you temporarily override a drawing 
tool using a keyboard shortcut, the tool’s name will be highlighted in red. You can temporarily 
override a tool by holding its keyboard shortcut without the [Alt] key. For example, the Select tool 
shortcut is Alt + S. If you hold down [S], you will switch to the Select tool. As soon as you release the 
key, you will return to the tool you were using.

5. Current Frame

This field displays the current frame of the animation you are working on.

6.Cursor Coordinates

This indicates the position of the mouse cursor in the drawing area.

7. Colour Picker

The Colour Picker allows you to select a colour for drawing.

8. Drawing Thumbnails Panel

The Drawing Thumbnails panel displays a list with thumbnails of the loaded drawings. The 
highlighted drawing is the one displayed in the drawing area. You can select the drawing you want to 
paint directly from this list.
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Function View
The Function view lets you edit function curves and parameters. It is a visual graph for adding, 
removing, and editing keyframes, as well as adjusting the velocity. The Function view allows you to 
display multiple functions in the background as a reference.

How to display functions in the Function view

1. Open the Function view.

The Function view is blank until you select the layer containing the functions you want to display.

2. To display a function in the Function view, click on the layer containing the functions to adjust in the 
Timeline view.

3. To select the functions you want to edit, select them in the Functions List section.

 

Parameter Description
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Function List

When selecting a layer in the Timeline view, all the 
corresponding functions are displayed. Until a keyframe is 
added on the function in the Timeline view, it will not be 
displayed in the Function view. Select all the functions you want 
to see and edit; hide the ones you do not.

 

The Display toolbar allows you to modify how the editing area 
is displayed. You can hide the grid, disable the synchronization 
with the current frame, reset the zoom level and normalize the 
function display by stacking them one over the other to 
compare them regardless of their value range.

Current Frame Displays the current scene frame.

Selected Keyframe Value Displays the value of the selected keyframe.

Display Advanced Parameter 
Values

Displays the Projection, Bias, Tension and Continuity 
parameters to adjust the curve around the selected keyframe.

Keyframe, Velocity and Inter-
polation Options

This toolbar lets you add and delete keyframes, adjust the 
velocity curve, adjust the segments to motion or stop-motion 
keyframes and set the velocity to create steps instead of a 
constant progression.

Function Type
This toolbar lets you click on the different function types to 
enable or disable all the listed functions of that type.

Value Scale
displays the value range for the displayed editing area. It can be ref-
erenced to know the value of a keyframe.

Selected Keyframe
The selected keyframe is displayed in red. When selected, the 
keyframe values are displayed in the corresponding fields.

Bezier Handles

The Bezier handles let you adjust the ease in and ease out of 
each keyframe. The more the handle is pulled out horizontally, 
the slower the animation will be. The more the handle is pulled 
out vertically, the faster the animation will be.

Function Curve
The thin line going from keyframe to keyframe is the actual 
curve. The section of a curve located between two keyframes is 
called a segment.

Frame Scale
The Frame Scale displays the frame range for the displayed 
editing area. It can be referenced to know the current frame of 
a keyframe.
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Layer Properties Editor
Each layer has its own set of properties that can be modified, including effect and peg layers. Display 
the Layer Properties editor if you want to modify some of the layer’s properties such as the name or 
the antialiasing quality. You can display the editor by selecting a layer in the Timeline view.

Library View
The Library view is used to store elements such as animation, drawings, backgrounds and puppets to 
reuse in different projects. You can also use the Library view to create and store your symbols.

To reuse an element from another project, you must create a template out of your drawings. A 
template is a mini scene that you import in your other project. A template has no link to the original 
scene. When you create a template, the full content of your selection is copied in the template.

You also have the possibility to create symbols. These can be used as drawing containers when you 
are creating puppets so that you can store different mouth shapes or hands to use while animating. 
Note that drawing layers already have this capability without being a symbol. You can also use 
symbols when you are building props, such as a skateboard whose wheel you want to reuse for the 
four skateboard wheels. 
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1. Library View Menu 

The Library View menu allows you to access commands that are related to the Library view, such as 
importing SWF movies and Illustrator files, adding a new folder and refreshing the library’s content.

2. Preview Window 

The Preview window is used to see the content of the currently selected template or symbol in the 
Template/Symbol list.

3. Preview Playback 

The Preview Playback button is used to play back the content of the selected template or symbol if it 
contains more than one frame. Press the Play  button to play back the preview.

4. Library Folder List 

The Library Folder List displays all the folders linked to the Library view. There are two default 
folders:

• Symbols: This folder is the only folder containing symbols. You can organize it by adding 
subfolders inside.

• StageLibrary: This is a default folder found on the hard drive in your user documents. This 
folder can contain templates, but no symbols.

You can link new library folders to the Library view and organize them with subfolders.
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5. Template/Symbol List 

The Template/Symbol list displays the templates or symbols contained in the selected library folder. 
You can display the templates and by right-clicking the symbols’ thumbnails and selecting View > 
Thumbnails.

Message Log View
The Message log view displays information gathered during a render task, such as which frames and 
at what time they were each rendered. The view also contains a list of the colour recovery operations.

Model View
Once you have a fully painted drawing, you can use it as a colour model and load it in the Model view. 
This drawing can be used and loaded in any of your Harmony scenes. 

Once a drawing is loaded in the Model view, you can use the Dropper  tool to select a colour from 
the model and use it to paint in the Camera or Drawing view without having to pick the colour from 
the colour palette.
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Perspective View
The Perspective view is used during scene setup. It allows you to see a multiplane scene’s orientation. 
The Perspective view is similar to a 3D display, as it lets you rotate the scene through all possible 
angles to understand the spacing between the elements. You can also position and rotate your layers 
and the camera inside the 3D display to achieve some 3D setup and camera moves.

1. The red circle rotates the view on its X axis.
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2. The green circle rotates the view on its Y axis.

3. The blue circle rotates the view on its Z axis.

4. This is a perspective grid reference.

5. The axis reference arrows let you maintain your orientation when navigating in the Perspective view.

6. There are three view option buttons displayed in the lower-left corner of the view.

‣ Show/Hide Camera: Shows or hides camera frame in the Perspective view. 

‣ Reset View: Resets the pan, rotation, and zoom of the Perspective view.

‣ Reset Rotation: Resets the rotation of the Perspective view.

7. This field displays the current zoom level in the Perspective view. You can use the Zoom level drop-
down menu to select a specific zoom level from the list. Zoom levels from 2.5% to 6400% are 
available; you can also select Fit To View to automatically use a zoom level that lets you see all your 
scene layers and information in the Perspective view at once.

8. This field displays the currently selected layer and drawing name.

9. This field displays the currently selected tool.

10. This field displays the currently selected frame of your animation.

11. This field displays the currently selected colour in the palette.

How to rotate a scene in the Perspective view

1. In the Tools toolbar, select the Rotate View   tool.

‣ Click in the view, and drag the cursor around to rotate the view.

‣ Press and hold Ctrl + Alt (Windows/Linux) or ⌘  + Alt (Mac OS X) and click and drag to 
rotate the view one axis at a time. 

Script Editor View
Qt Script provides access to many of the functions supported in the  interface. With Qt Script, you can 
automate a number of Harmony functions to speed the completion of various repetitive tasks. The 
Script Editor view allows you to edit existing scripts and create new ones. Refer to the Scripting guide 
to learn more about scripting with Harmony.
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Script List

On the left side of the Script Editor view, all existing script files are listed and can be modified in this 
view. The script format is JavaScript. Click on a  file to display its content in the Script Content 
window of the view.

Script Content

On the right side of the Script Editor view, the contents of the selected script are displayed and can 
be edited.

Search Toolbar

The Search toolbar allows you to search a string within the selected script content. You can use the 
Previous and Next buttons to navigate through the results.

Syntax Check

This function verifies the syntax of the currently displayed script and lists any error found.

Save Changes

Once you are satisfied with the modifications made to the script, click Save Changes to save the 
modifications.
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Side View
The Side view is used mainly for multiplane scenes and to position elements in 3D Space. It allows you 
to see a scene’s stage  from  the side. This lets the camera cone and spacing between the elements to 
be seen.

1. A thumbnail of each drawing layer in the scene. The order of the thumbnail images is based on each 
element’s FB position in the scene space. You can see a representation of the FB position of each 
layer in the camera cone.

2. The camera cone represents the camera’s position and field-of-view (FOV). 

3. The axis reference arrows let you maintain your orientation when navigating in the Perspective view.

4. There are two view option buttons displayed in the lower-left corner of the view.

‣ Show/Hide Camera: Shows or hides the camera frame in the Perspective view. 

‣ Reset View: Resets the pan, rotation and zoom of the Perspective view.

5. This field displays the current zoom level in the Perspective view. You can use the Zoom menu to 
select a zoom level from 2.5% to 6400%. You can also select Fit To View to automatically use a zoom 
level that lets you see all of the scene layers and information in the Perspective view at once.
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6. Displays the currently selected layer and drawing name.

7. Displays the currently selected tool.

8. Displays the currently selected frame of your animation.

9. Displays the currently selected colour in the palette.

Timeline View
To set your animation timing, you will mostly work with the Timeline and Xsheet views. It is extremely 
useful to become familiar with the Timeline view, how it works, and its interface.

The Timeline view is the main view used when adjusting the timing of drawings, adding keyframes and 
ordering layers. The Timeline view displays layers, effects, sounds, keyframe values, scene length, layer 
names, drawings, keyframes, timing, and frames.

The Timeline view allows you to read your timing from left to right. It represents the scene’s elements 
in their simplest form. You can also see the layers and their names, as well as the drawing’s exposure. 
The drawing name is displayed when you place the cursor above the drawing’s exposure.

You can see the drawing name when you display the Data view. The name of the drawing folder to 
which the layer is linked is displayed in the Data view.
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1. Enable/Disable All 

The Enable/Disable All  button is used to show or hide all layers simultaneously.

When you deselect a layer in the Timeline view, the corresponding column is hidden in the Xsheet 
view. When a column is hidden in the Xsheet view, the corresponding layer is disabled in the Timeline 
view.

To disable a particular layer, deselect the layer’s checkbox or press D.

To enable a particular layer, select the layer’s checkbox or press A.
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2. Show Selection and Hide All Others 

The Show Selection and Hide All Others  button is used to show only the currently selected layer 
in the Timeline view and disable all the other layers.

3. Add Layers

The Add Layers  button lets you add new layers to the Timeline view. When you click the Add 
Layers button, a drop-down menu will appear displaying the layer types available. You can add 
several different types of layers:

•  Camera

•  Colour-Card

•  Drawing

•  Mask

•  Peg

•  Quadmap

•  Effect

•  Sound

• An effect layer made in Harmony Draw will appear with this symbol  when opened in Toon 
Boom Harmony.

4. Delete Layers

The Delete Layers  button lets you delete the currently selected layers in the Timeline view.

5. Add Drawing Layer

The Add Drawing Layer  button lets you automatically add a new drawing layer to the Timeline 
view. By default, the layer is named Drawing.

6. Add Peg 

The Add Peg  button lets you add a peg layer to your timeline. If one or several layers are 
selected a peg will be added and parented to each individual layer.

7. Show/Hide Data View 

The Show/Hide Data View  button lets you display the current frame’s drawing exposure and 
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keyframe values corresponding to each individual layer.

• Hidden Data View

• Visible Data View

8. Current Drawing Displayed  

The highlighted drawing represents the drawing currently displayed and is linked to play head 
position. 

9. Current Frame 

The red play head represents the current frame displayed and marked in the Playback toolbar. If you 
slide the play head to the left or right, it will scrub through your frames and update the Camera view.

10. Split 

The Split  button lets you split the Timeline view in two sections, allowing you to see two 
different portions of the Timeline view. This way, if your scene length is very long, you can see the 
beginning and the end at the same time.
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11. Collapse/Expand Children 

The Collapse/Expand Children  button is used to display the children layers of a parent layer. Once a 
layer is parented to another layer, it is indented to the right and the Collapse / Expand Children 
button appears on the parent layer allowing you to show or hide the child layer.

12. Show/Hide Functions

The Show/Hide Functions  button lets you display the functions embedded in each layer. The 
functions are the different coordinates and value used to record a layer’s parameters at each frame. 
This information is stored on the function curves using keyframes.

13. Change Track Colour 

The Change Track Colour  button lets you change the colour of the exposed frames; this helps 
you to quickly locate a layer in the Timeline view. Double-click on the colour swatch to open the 
Select Colour window and choose a new colour. You can modify the layer for any type of layer, such 
as group, peg, drawing, and effects.
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14. Lock/Unlock Layer 

The Lock/Unlock Layer  button lets you prevent the selection or editing of a layer in the 
Camera view. To select some of the layers without selecting others, in the Timeline view, lock the 
layers you do not want to select.

In the top menu, there are a series of locking options. Select Animation > Lock > select one of the 
following actions:

•  Lock: Locks the currently selected element.

• Unlock: Unlocks the currently selected element.

• Lock All: Locks all the elements in the Camera view. 

• Unlock All: Unlocks all the elements in the Camera view.

• Lock All Others: Locks all the elements in the Camera view except the currently selected 
one.

You can display the locked drawings as outlines in the Camera view to quickly find out which 
drawings are locked.
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How to display locked drawings as outline

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac 
OS X).

2. In the Preferences dialog box, select the Camera tab.

3. In the Tools section, select the Show Locked Drawings As Outlines option.

15. Onion Skin 

The Onion Skin  button enables the Onion Skin option on a particular layer. If you want to see the 
previous and next frames of a specific layer, go to the Timeline view and click the Onion Skin button 
for that particular layer. Blue arrows appear on both sides of the play head. Pull on the blue arrows 
to add more frames to the onion skin display.

To activate the general Onion Skin preview, in the Tools toolbar, click the Onion Skin  button.

16. Drawing Substitution 

The Drawing Substitution  field is used to change the drawing exposed at the current frame. To 
access the Drawing Substitution field, you must first expand the Data view by clicking the Show/Hide 
Data View  button.

To change the current drawing, click the drawing value in blue and slide your cursor left or right when 
you see the hand  cursor, or double-click on the drawing name and type in a new value.

The drawing exposure will be changed for the entire block it is exposed, not just the current frame. 

17. Keyframe Value 

The Keyframe Value field is used to add, remove or modify a keyframe at the current frame. To 
access the Keyframe Value field, you must first expand the Data view by clicking the Show/Hide Data 
View  button. 

113



Chapter 5: Interface     View References

• To add a keyframe at the current frame, click the Add Keyframe  button. 

• To remove an existing keyframe at the current frame, click the Delete Keyframe  button.

• To change the current keyframe, either click and slide your cursor left or right when you see the 
hand  cursor, or double-click on the keyframe value and directly type a new value.

• To navigate through the existing keyframes, click the Previous Keyframe  and the Next 
Keyframe  buttons.

• To link your layer to an existing function or to create a new function, click the Show Function 
Menu  button to display the drop-down Function menu.

18. Zoom 

The Zoom tool is used to increase or reduce the width of the frames in the Timeline view. Drag the 
cursor to the right to increase the width or to the left to reduce it. You can also press 1 and 2.

19. Keyframe 

A black or red square is displayed in the Timeline view when a keyframe exists. You can select these 
keyframes and drag them wherever you want on the timeline. You can also copy, cut and delete 
them.

• To delete a keyframe without deleting the drawing exposure, go to the Timeline view and 
select the keyframe to be deleted and then select Animation > Delete Keyframes from the 
top menu.

When a parent layer is collapsed and a child layer contains a keyframe, a white square will be 
displayed.

20. Drawing Exposure 

In the Timeline view, when a drawing is exposed, it is represented as a grey block. If the drawing is 
exposed for several frames, the block is extended. When a second drawing is exposed, a new grey 
block is displayed.

• The exposure’s colour can be changed. To pick a new colour, double-click on the Change 
Track Colour  button in the corresponding layer.
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21. Dragging and Pasting Modes

As you animate, you will find that you reuse many positions, drawings, and keys. However, you may 
only want to paste the drawings or just the keys or maybe everything. There are different paste 
options available in the Timeline view which give you maximum flexibility when reusing and pasting.

Note that these modes also apply when you use drag instead of copy and paste.

There are three different modes for pasting your selection:

•  Paste Mode: All Drawing Attributes: Pastes the drawing exposure and keyframes.

• Paste Mode: Keyframes Only: Pastes only the keyframes.

•   Paste Mode: Exposures Only: Pastes only the drawing exposure.

22. Timeline View Modes

To streamline the process of working with elements in the Timeline view, there are three different 
view modes you can choose to work in. With each mode you select, certain elements may or may not 
be visible in the Timeline view. Depending on your workflow, this can be useful for quickly hiding 
elements when you want to focus on specific ones. To select a view mode, use the drop-down menu 
in the Timeline view.

Tool Properties View
The contextual Tool Properties view contains the most common options and operations related to the 
currently selected tool. As soon as you select a tool from the Tools toolbar, the Tool Properties view 
updates.

For example, if you choose the Select  tool in the Tools toolbar, the Tool Properties view will display 
the options and operations related to the Select tool, such as Snap to Contour, Apply to All Drawings, 
Flip Horizontal, and Flatten.
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Options

Options are different modes you can apply to a selected tool to modify its behaviour to fit the 
current task’s needs.

Operations

Operations are actions you can perform while using the selected tool.

Top View
The Top view is used mainly for multiplane scenes and to position elements in 3D Space. It allows you 
to see the scene’s stage  from above. This lets the camera cone and the spacing between the elements 
to be seen.

1. A thumbnail of each drawing layer in the scene. The order of the thumbnail images is based on each 
element’s FB position in the scene space. You can see a representation of the FB position of each 
layer in the camera cone.

2. The camera cone represents the camera’s position and field-of-view (FOV). 

3. The axis reference arrows let you maintain your orientation when navigating in the Perspective view.

4. There are two view option buttons displayed in the lower-left corner of the view.

‣ Show/Hide Camera: Shows or hides the camera frame in the Perspective view. 

‣ Reset View: Resets the pan, rotation and zoom of the Perspective view.

5. This field displays the current zoom level in the Perspective view. You can use the Zoom menu to 
select a zoom level from 2.5% to 6400%. You can also select Fit To View to automatically use a zoom 
level that lets you see all of the scene layers and information in the Perspective view at once.
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6. Displays the currently selected layer and drawing name.

7. Displays the currently selected tool.

8. Displays the currently selected frame of your animation.

9. Displays the currently selected colour in the palette.

Xsheet View
The Xsheet view lets you read the timing vertically, displays the drawing layers as columns, and shows 
the drawing’s name. You can also see the functions and keyframes of the motion paths in the Xsheet’s 
function columns. The value of each keyframe is shown in the Xsheet view; these are displayed as black 
squares in the Timeline view. The Xsheet view contains more details than the Timeline view, and is 
faster and easier to read.
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1. Xsheet Main Section

The Xsheet view has three sections. By default, only the main section is visible. It displays the drawing 
layers, also known as drawing columns.

When using advanced compositing and animation techniques, unconnected functions (motion paths) 
also appear in the main section. Unconnected functions mean that some motion paths are not 
attached to any particular layer.

When you reconnect functions to a layer, they are still visible in the main section.

2. Functions Section

The Functions section is used for more advanced techniques. This section displays the functions 
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(paths) related to the selected layer in the Timeline view. By default, the Functions section is hidden.

How to display the Functions section

1. In the Xsheet view, click the Expand button located on the right side of the main section. Click on 
the same button to collapse it. You can also use the Show Column List  button in the Xsheet 
View toolbar. If you select a drawing column in the main section of the Xsheet view, the function 
columns will not be displayed. You must select the layer from the Timeline view.
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3. Column List Section

The Column List section allows you to show and hide columns in the Xsheet view. When you hide a 
layer in the Xsheet view, it is also disabled in the Timeline view.

You can use the Column List to hide individual columns or hide an entire column type (drawing or 
function) from the Xsheet view. By default, the Functions section is hidden.

How to display the Column List section

1. In the Xsheet view, click the Expand button on the right side of the main section to show the 
Functions section. Click on the same button to collapse it. You can also use the Show Column List 

 button in the Xsheet View toolbar.

‣ In Harmony, you can also go to the Xsheet view menu and select View > Show Column 
List. 

2. Click the Expand button on the right side of the Functions section to display the Column List 
section.
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4. Xsheet View Toolbar

The Xsheet view has its own toolbar where you can find the most common features. This toolbar is 
displayed by default. If you do not see it, select Windows > Toolbars > Xsheet View. 

The Xsheet view must be part of your workspace in order to display its toolbar.

5. Column Header

Each column available in the Xsheet view has a header displaying the column’s name. The column’s 
name is the same as the corresponding timeline layer. If you rename one or the other, they will both 
be renamed.

A quick access menu is available when you right-click. This menu contains the command affecting an 
entire column such as renaming, changing the default colour, or deleting a column.

The tooltip that appears when you hover at the top of each Xsheet column shows the folder path to 
the source drawings for that column.
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6. Current Drawing

A drawing selected in dark red indicates that the drawing is currently displayed in the Drawing and 
Camera views. The current drawing selection is not linked to the drawing displayed in the Camera 
view since drawings from each visible layer are displayed at once.

6a. Current Frame

The darker frame appearing in the Xsheet view represents the current frame.

7. Drawing Exposure

In the drawing columns, you can see the drawing names and their exposure. You can use any 
alphanumeric symbol to name your drawing. When a drawing is exposed over more than one cell, a 
vertical black line is displayed to indicate the continuity of the exposure. When there is no drawing in 
a cell, the cell will be blank.

8. Frame Numbers
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On the left side of the Xsheet view, the frame numbers are shown indicating where you are. These 
read vertically instead of being displayed horizontally as they are in the Timeline view.

• To go to a particular frame, click the frame number.

• To select an entire range of frames, click and drag a selection downwards.

9. Current Frame Display

At the bottom-right of the Xsheet view, you can see the current frame number, as well as the column 
containing the drawing currently displayed in the Drawing view.

10. Function Column

The function columns are displayed in the Functions section of the Xsheet view. They represent the 
motion and rotation you applied to a drawing layer. 

A function column can also be related to an effect. Selecting the effect layer shows you the 
corresponding function column in the Xsheet view.

The function columns display the position value or effect value on each cell. If there is a keyframe on a 
cell, a black square is displayed. Holding the same value for several frames displays a vertical black 
line.

11. Increase/Decrease Exposure

You can quickly increase or decrease the exposure of the selected cell by clicking on the up and down 
arrows in the Increase/Decrease Exposure field.
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12Overwrite/Insert Modes

The Overwrite/Insert button allows you to decide the way the values are inserted into the Xsheet.
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Toolbar References

Harmony has several toolbars. The Top toolbars are available at the top of the interface and the View 
toolbars are in individual windows. View toolbars are only shown if the particular view is displayed in 
the workspace. This is a complete list of the toolbars available in Toon Boom Harmony.

Top Toolbars

Advanced Animation Toolbar

The Advanced Animation Toolbar contains tools to position and animate layers. The Scale, Translate 
and Rotate tools can be used to reposition the permanent pivot position of your layer. Unlike the 
Transform tool, each tool in the Advanced Animation toolbar performs a single operation either 
rotate, scale, translate or scale in relation to the camera distance.

Art Layer

A drawing is composed of two layers, a line layer and a colour layer. The colour layer is always placed 
under the line layer. These layers are accessible in the Drawing or Camera view (using drawing tools). 
When you view the final drawing, you will see the final composition of the lines and colours, not two 
separate layers. You need to change your Preferences to allow the use of those advanced Art layers 
in order to see them.

You can draw and paint in all layers. If you prefer to work in a single layer, everything can be done in 
Line Art.

• Line Art

• Colour Art

Coordinate Toolbar

Each time you select a keyframe or control point in the Camera, Timeline or Xsheet view, its 
parameters appear in the Coordinate toolbar. You can edit keyframes and control point 
parameters, such as the position, scale and rotation coordinates.

Control Point Toolbar

Each time you select a keyframe or control point in the Camera, Timeline or Xsheet view, its 
parameters appear in the Control Points toolbar. You can edit keyframes and control point 
parameters, such as the continuity, bias, tension and lock-in-time. 
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Easy Flipping Toolbar

Toon Boom Harmony has a flipping feature that lets you rapidly flip through the drawings in the 
Drawing view as is done with paper drawings.

Edit Toolbar

The Edit toolbar contains common operations such as Copy, Paste, Cut, Undo and Redo. These 
options can also be found in the Edit menu.

File Toolbar

The File toolbar contains the common file operations such as New, Save and Open. These options 
can also be found in the File menu.

Flip Toolbar

This toolbar lets you enable what type of drawing to include in your flipping selection. You can flip 
through the key, breakdown or in-between drawings individually, or view a combination.

Mark Drawing Toolbar

The Mark Drawing toolbar lets you identify drawings such as Key, Breakdown and In-between. The 
drawing Identification feature can help the animator stay well organized and save time when 
identifying key, breakdown or in-between drawings in the Xsheet and Timeline views. 

Onion Skin Toolbar

When designing or animating, it is useful to be able to see your previous drawings. The Onion Skin 
tool is used to preview the previous and subsequent drawings. By default, the previous drawings will 
appear with a shade of red and the next drawings will be displayed with a shade of green, but you 
can change the display options in the Preferences dialog box. In the Onion Skin toolbar, you can 
select what type of drawing you want to display in your onion skin display.
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Playback Toolbar

The Playback toolbar lets you play back your animation and sound. Use it to scrub the sound to 
create your lip-sync, loop the playback, navigate through frames, and change the playback range 
and speed.

Name Button Description

Play

Plays and stops the 
animation.

You can also select Play > 
Play Scene Forward or 
Stop.

Render and Play
Creates a render of your scene to 
play back the final result including the 
effects.

Loop

Repeatedly plays back your 
animation indefinitely.

You can also select Play > 
Loop.

Sound

Enables sound in the 
playback. 

You can also select Play > 
Enable Sound.

Sound Scrubbing

Enables sound scrubbing in 
the playback.

You can also select Play > 
Enable Sound Scrubbing.

Jog Frames
Lets you scroll through the play-
back’s frames.

Lets you change the playback frame 
range by entering new values in the 
Start and Stop fields. You can also 
click on the Start and Stop words to 
set the start or end frame at the cur-
rent frame.

FPS
Lets you enter a new value to change 
the speed of the playback.

Scripting Toolbar

The Scripting toolbar lets you import and access the scripts created to automate actions and 
operations.
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Tools Toolbar

The Tools toolbar contains all of the main tools you will use while working in Harmony. In the default 
workspace, you will find this toolbar on the left-most side of the interface.

Tool Presets Toolbar

The Tool Presets toolbar lets you create new tool presets and manage them.

Workspace Toolbar

The first time you open Harmony, the default workspace is loaded. Other workspaces are available 
such as the Hand-Drawn Animation and Compositing workspaces; these display different views and 
toolbars. You can access these workspaces and any you create, from the Windows menu and the 
Workspace toolbar.

View Toolbars
Here is a list of the view toolbars available in Harmony:

• Camera View Toolbar

• Drawing View Toolbar

• Library Toolbar

• Model View Toolbar

• Script Editor View Toolbar

• Timeline View Toolbar

• Xsheet View Toolbar
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Interface Navigation

Toon Boom Harmony supports zoom in, zoom out, rotate, pan and reset view for easy interface 
navigation for the views.

Command Action Access Methods

Zoom In Zooms into the view.

View > Zoom In

Press 2  or roll the mouse 
wheel up. 

In the Timeline view, press 
Ctrl (Windows/Linux) or ⌘  
(Mac OS X) and roll the 
mouse wheel up.

Zoom Out Zooms out of the view.

View > Zoom Out

Press 1 or roll the mouse 
wheel down. 

In the Timeline view, press 
Ctrl (Windows/Linux) or ⌘  
(Mac OS X) and roll the 
mouse wheel down.

Zoom In or Out Zooms in or out of the view.
Roll the middle mouse 
button up or down.

Pan Moving parallel to the view.

Hold down the Spacebar and 
drag the mouse in the direction 
in which you want to pan the 
view.

Recenter view
Recenters the view on your mouse 
cursor.

Press N

Reset Pan
Resets the view’s pan to its default 
position. 

View > Reset Pan  

Press Shift + N

Reset View
Resets the view to its default pos-
ition.

View > Reset View

Press Shift + M

 

Reset Rotation
Resets the view’s rotation to its 
default position.

View > Reset 
Rotation  

Press Shift + X

Reset Zoom
Resets the view’s zoom to its default 
position.

View > Reset Zoom

Toggle Full Screen
Enlarges the selected view to full 
screen. The full screen process is 
done in three stages. 

View > Toggle Full 
Screen

Press Ctrl + F 
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First, the selected view 
enlarges to the maximum 
width or height, but keeps 
the tool views such as 
Colour or Tool Properties 
view. 

Second, the view enlarges 
to full screen. 

Third, the view returns to 
its original size.

(Windows/Linux) or 
⌘  + F (Mac OS X)

Rotate 90 CW
Rotates the Camera view 90 degrees 
clockwise, like an animation table.

View > Rotate View CW

Rotate 90 CCW
Rotates the Camera view 90 degrees 
counter-clockwise, like an animation 
table.

View > Rotate View CCW

Toggle Quick Close-up

Use the Magnifier tool to 
quickly center on the 
mouse position and zoom 
in to a pre-defined value 
such as 4X. Then you can 
zoom out again. Hold the 
shift key and press Z to 
zoom in and back out 
again. Replacing the Reset 
Zoom by pressing  Shift +. 

The area where you zoom 
in or out is dependent on 
the cursor location in the 
Camera view. If you zoom 
in and them move the 
cursor to a different 
location when you zoom 
out the mouse will be 
centered on that location.

 

Using the Play Menu to Navigate
From the top menu, you can select any of the following commands from the Play menu to navigate 
around the interface.

Command Description

First Frame Jump to the first frame. You can also press <.

Next Frame
Jumps to the frame after the currently selected frame in the Timeline view. 
You can also press the period (.) key.

Last Frame Jumps to the last frame. You can also press >.

Previous Frame
Jumps to the frame before the frame currently selected in the Timeline 
view.  You can also press the comma (,) key.
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Go to Frame

Opens the Go to Frame window in which you can enter the 
number of the frame you want to display. 

You can also use the Go button, which you can add to the 
Timeline View toolbar through the Toolbar Manager. Open the 
Go to Frame dialog box and enter the frame number to jump 
to.

Enable Playback Plays back your animation from the Top, Side, or Perspective view.

Zoom Tool
From the Tools toolbar, use the Zoom   tool to zoom in and zoom out in the Camera or Drawing 
view.

• The keyboard shortcuts are  1 and 2.

• When the Zoom In mode is selected, hold Alt as you click to zoom out.

When you select the Zoom tool, its properties are displayed in the Tool Properties view.

Zoom Tool Options Button Description

Zoom In Zooms in

Zoom Out Zooms out

Operations Button Description

Perform Zoom In
Zoom in the Camera or Drawing view. 
The keyboard shortcut is 2.

Perform Zoom Out
Zoom out the Camera or Drawing view. 
The keyboard shortcut is 1.

Reset Zoom Restores the current zoom level to 100%.

Reset View
Restores the original display by resetting 
any pan, rotation or zoom actions.

Navigating between Frames and Columns
Once a cell is selected in the Timeline or Xsheet view, you can navigate between the drawings, frames, 
and layers using keyboard shortcuts that work in the Camera, Drawing, Timeline, and Xsheet views.

You can navigate through:
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• Drawings

• Frames

• Columns

How to navigate through drawings, frames and columns

1. In the Timeline or Xsheet view, select a cell.

2. Once the cell is selected, you can navigate between:

‣ Previous and next layers: From the top menu, select Drawing > Previous Layer and Next 
Layer or press H and J.

‣ Previous and next drawings: From the top menu, select Drawing > Previous Drawing and 
Next Drawing or press F and G.

‣ Previous and next frames: From the top menu, select Play > Previous Frame and Next 
Frame or press comma (,) and period (.).
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Chapter 6: Character, Prop and Location Design

Another important step in the project creation is the character, prop and location design. This 
determines the style and models to follow for the entire project. 

The design can be created on paper and scanned in or it can be created digitally. You can draw and 
even create the colours entirely on paper, while others like to design on paper and scan the drawings 
to create the colour model in a software program. The most popular method is to design directly in 
Harmony.

To save paper and time and avoid having to recreate colour palettes, Harmony gives you the ability to 
design all elements directly in the application. This keeps all your work within the same software, 
avoids using a lot of paper and losing time scanning in elements and importing them.

The character and prop design process is divided in three steps:

• Preparation on the next page

• Sketching the Model on page 138

• Cleaning and Inking the Model on page 151

Harmony has an extensive set of drawing tools that can be used to design your characters. You can 
learn more about this in the following topic:

• Drawing Tasks on page 153

Each drawing tool has a series of options to customize its behaviour and drawing style. You can learn 
more about them in the following section:

• Drawing Tool References on page 219
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Preparation

To prepare for the design task, you will need to go through a few steps:

• Getting References below

• Using the Workspace below

Getting References

Creating models requires two main reference sources, the script and the storyboard. Once you have 
the script in hand, you can learn about the characters and their personalities, the props, the 
ambiances, and so on. This will be your main reference, so it is very important to read it carefully.

The storyboard is the second reference source and it can be quite useful as well. Although it will not 
yet be the final version of the storyboard, it will show you what the character is doing and what props 
need to be designed.

Using the Workspace
Once your scene is created, you can open it and set your workspace.

To sketch the characters, props or locations directly in Harmony, you will mostly use the Camera or 
Drawing views along with the Colour, Timeline and Tool Properties views.
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Sketching the Model

Now that your references and scene are created, you can start designing. To draw your characters, 
props and key locations, you will need to learn the following:

• Drawing with the Brush or Pencil Tool below

• Override Tool on the facing page

• Relative Size on page 140

• Palettes and Colours on page 144

• Sketching the Character on page 148

Drawing with the Brush or Pencil Tool

The Brush  and Pencil  tools are used for drawing and sketching. Both  tools support pressure 
sensitivity, allowing you to create lines with variable thickness. The Brush tool produces contour vector 
lines. The Pencil and shape tools produce central vector lines. This means that a pencil line’s control 
points (used to deform its shape) are located along the length of the central spine, while the Brush 
line’s control points are located along the contour.
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• If you draw with the Brush tool and want to modify the thickness, use the Contour Editor  
tool. 

• If you draw with the Pencil tool and want to modify the thickness variation, use the Pencil Editor 
 tool. 

• You can also convert a brush zone into a pencil line with the Brush Stroke to Pencil Line   
option.

If you sketch a drawing using a semitransparent colour to get a paper-like feel, you should use the 
Brush tool as it produces a more realistic and natural feel. The pencil line is very useful for tracing clean 
or final drawings.

Also, it is recommended to use brush lines when designing cut-out puppet articulations which use 
patches.

Override Tool
The Override tool lets you increase productivity by rapidly switching between tools used for short 
tasks and your previous tool. Most drawing tool shortcuts are accessed using the Alt key followed by 
another key, such as the Eraser tool which is accessed by pressing Alt + E. 

If you are drawing with the Brush tool and need to briefly switch to the Eraser before continuing, hold 
down the E key while you are erasing. Once you are done, release the E key to return to the previous 
tool; in this case, the Brush tool. You can do the same for most drawing tools that have a shortcut 
composed of Alt followed by another key.
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Relative Size

The size relation between the props, characters and backgrounds is very important in maintaining 
consistency and structure throughout the project.

A production can contain many characters and props. It is not unusual for these to be created by 
different people. If there is no size control implemented, the characters and elements created by 
different artists can vary greatly. When this occurs, the characters that are placed together in a scene 
will be out of proportion. The animator or person doing the scene setup will then have to scale them 
to the correct size. 

When a character or prop is scaled down, the outline will become increasingly thinner. By the time the 
element is scaled to its proper size, the outline may be so thin that a difference between one 
character's outline and the one beside it will not look very good.

Here are a few tips you can use to create a suitable size relation.
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Line Up

A line up consists of copying and pasting all your character designs into the same drawing and then 
scaling them to the correct proportion in relation to the other characters. This line up is very 
important and should be handed to any animator, layout and posing artist or scene setup person 
working on the project.

For the prop design, it is recommended that you paste one of the main character's hands or even the 
full body beside the prop. This enables the animator to know what size to draw the prop.

In your character design scene, it is a good idea to create a column for the character line up.The line 
up is usually done during the character design step. When the character builder imports the model 
to the breakdown scene, the size relation should be correct.

Field Chart

Harmony includes a field chart in its Camera and Drawing views. This tool is very useful in setting the 
characters' and props' heights.

It is recommended that you keep the character design and breakdown inside the 12 field size. This 
ensures that it fits the default camera size and the template thumbnails. If some parts were drawn 
too big or too far apart, you can use the Reposition All Drawings tool and reposition, scale or rotate 
multiple drawings from different layers all at once.
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Use the Show Grid option to display a grid in the Drawing or Camera view.

Name Button Description Keyboard Shortcut

Show 
Grid

 

Displays the grid

From the top menu, 
select View > Grid > 
Show Grid

Press Ctrl + ' 
(Windows/Linux) or 
⌘  + ' (Mac OS X).

Square Displays a standard square grid
From the top menu, 
select View > Grid > 
Square.

12 Field Grid Displays a 12-field size grid
From the top menu, 
select View > Grid > 
12 Field Grid.

16 Field Grid Displays a 16-field size grid
From the top menu, 
select View > Grid > 
16 Field Grid.

Underlay
Displays the grid under the drawing 
elements

From the top menu, select 
View > Grid > Underlay

Overlay
Displays the grid over the drawing 
elements

From the top menu, select 
View > Grid > Overlay

How to use the Reposition All Drawings

1. In the Tools toolbar from the Select drop-down menu, select the Reposition All Drawings  
tool. This also automatically selects every stroke in your drawing in the Drawing and Camera 
views.

2. To deform or reposition a selection:

‣ To reposition, click and drag your selection to a new area.

‣ To scale, pull or push on the top, side, bottom or corner control points. Hold down Shift 
to lock the selection’s ratio.
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3. When you release your cursor, every drawing contained in the drawing layer you repositioned, 
scaled, rotated or skewed will follow the same transformation.

Brush Size

Harmony provides a variety of pens and brushes and also allows you to create and save your own 
through creating a tool preset.

It is a good idea to create and save pens with precise sizes and parameters to trace and design your 
models and breakdowns.

How to create a tool preset

1. In the Tools toolbar, select a tool, for example the Brush tool.

2. Use the Tool Properties view to customize the tool. 

3. To set a specific colour for your preset, in the Colour view, select the colour swatch to link to the 
tool. Note that when using this preset in another scene not using that colour palette, upon 
selecting this new preset, a colour recovery dialog box will appear asking to add this colour to 
your scene.

4. In the Tool Presets toolbar, click the New Tool Preset  button.

5. In the New Tool Preset dialog box, in the Name field, type a name for your new preset.

6. From the icon list, select an icon to quickly identify your preset or upload your own by clicking the 
File  button.
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7. (Optional) From the Shortcut menu, set a keyboard shortcut to quickly access your preset.

8. When you select any of the following options, they will take effect when you use the tool preset. If 
an option is deselected, then using a tool preset will not override your current settings. 

‣ Colour: Saves the current colour into the tool preset.

‣ Tool: Only the colour will be associated. You could, for example, set three different 
colours with shortcuts.  It would use the current tool with the chosen preset colour.

9. Click OK.

Palettes and Colours
Harmony has an integrated palette system. Each character, prop or background can have its own set 
of colours and each colour in the palette can be associated to colour fill zones on a drawing. You can 
create as many palettes and colours as you need.

Each scene created in Harmony includes a default colour palette which contains a standard set of 
colours for sketching and painting.
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You can sketch and design using the default palette without any problem. However, it is not 
recommended that you use the default palette for the colour models. A different colour palette should 
be created for each colour model. 

To sketch and design with a different colour swatch or create a palette for each character, prop or key 
location, you will need to learn how to manage the Harmony palettes.

How to create a new palette (Basic Palette Lists mode)

1. From the Colour View menu, select Palettes > New or click the New Palette button.

‣ Make sure that you have the necessary rights to modify the palette list. If you do not, select  
Edit > Edit Palette List Mode.

The Create Palette window opens.

2. Enter the palette name according to the model. 

3. Click OK.

The palette appears in the drawing element’s palette list.

How to lock or unlock the palette list 

‣ In the Colour view, click the Edit Palette Mode  button. 

A grey pencil icon appears in the top-right corner of the Palette list.

How to add or modify a solid colour swatch

1. In the Colour view, click the New Colour  button.

2. From the Colour View menu, select Colours > Edit or double-click on the colour swatch.

The Colour Picker window opens. 
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3. To set your colour, do one of the following:

‣ In the colour wheel, select a colour.

‣ Enter the HSV or RGB values in the corresponding fields. Select the R,G,B,H,S or V options 
to change the look of the colour picking area.

‣ Click the Dropper  button to select any colour on your screen. It can be from the Toon 
Boom Harmony interface, your operating system or any other open application. 

You can also click Multi Wheel Mode to open the Multiwheel Colour dialog box. This displays all 
the picking area styles together and also contains a picking undo list. To return to the regular 
Colour Picker window, click Single Wheel Mode.
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4. Click on the Shade Scale swatches to modify the shade of the selected colour. 

5. Adjust the desired level of transparency with the Alpha slider, or type the value directly in the Alpha 
field.

6. Click the Add button to add the current selected colour to the Colour Storage Library, so you can 
quickly access it later.

7. You can rename the colour swatch in the Colour Picker window or directly in the colour list by 
double-clicking on its name.
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Sketching the Character

You are now ready to sketch your models. There are two tasks to perform in order to draw your 
characters:

• Add a drawing layer

• Sketch the model

You have the choice to sketch your model as a bitmap or vector drawing. If you like the feel of drawing 
with bitmap lines, you can set your layer as bitmap. If you like drawing with vectors, you can set your 
layer as vector. If you use vector, you will be able to enlarge your drawing and zoom into it without 
losing quality or resolution. You can also use the Contour Editor and Select tools to resize and modify 
lines. If you draw with bitmap, you will not be able to scale the drawing beyond 100% of its resolution 
without encountering pixelization issues.

If you would like to separate your lines and colours on separated art layers, see Art Layers on 
page 603

How to add a drawing layer

1. In the Timeline view, click the Add Drawing Layer button the .

The Add Drawing Layer window opens.
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2. In the Name field, name your new layer.

3. Set the Line Art and Colour Art options to Vector to get a vector layer or to Bitmap to have a 
bitmap layer.

4. Click OK.

A new drawing layer is added to the Timeline view.

How to sketch a model

1. In the Tools toolbar, select the Brush  tool or press Alt + B.

2. In the Tool Properties view, select a brush preset and adjust its parameters.

3. In the Timeline or Xsheet view, click in the first cell of the drawing layer.

149



Chapter 6: Character, Prop and Location Design     Sketching the Character

4. In the Drawing or Camera view, enable the Grid (Field Chart). You can press Ctrl + ' 
(Windows/Linux) or ⌘  + ' (Mac OS X).

‣ Make sure the Drawing or Camera view is the active view while using the keyboard shortcut. 

5. In the Drawing or Camera  view, start drawing.

6. To select a different colour, in the Colour view, select a different colour swatch. Double-click on the 
colour swatch to open the Colour Picker window and modify the colour. Remember that anything 
already painted with that colour swatch will update to the new colour.

7. In the Camera or Drawing view, use the Rotary Table to rotate your workspace.You can press 
Ctrl+Alt (Windows/Linux) or Ctrl+⌘  (Mac OS X).

‣ The default keyboard shortcut to reset the workspace rotation is Shift + X.

8. If you decide to draw in the next cell and need to see your previous drawing, enable the Onion Skin 
by pressing Alt + O.
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Cleaning and Inking the Model

When your rough models are ready, it is time to clean and ink them. You can still use the default 
palette and colours to do so, especially if you are not the one doing the colour styling. If you have 
already created a palette for your model, you can add new colours for tracing.

If you want to keep your roughs and sketches, add a new drawing layer and trace in it using the Light 
Table. This is the equivalent of adding a sheet of paper and tracing over the rough using the animation 
disk light table. You only need to disable the rough layer to prevent it from appearing in the final scene 
render.

If you would like to separate your lines and colours on separated art layers, see Art Layers on 
page 603

How to trace your character in a new layer

1. In the Timeline view, add a new drawing layer and name it: clean.

2. If you work in the Drawing view, enable the Light Table or press Shift + L.

3. Do one of the following:

‣ In the Tools toolbar, select a drawing tool.

‣ From the top menu, select Drawing > Drawing Tools > desired tool.

4. In the Timeline or Xsheet view, select the cell in which you want to draw.

5. Trace the model.

6. To make perfect points and corners, you can intersect the two strokes to create a point. Using the 
Cutter  tool, you can automatically trim the excess portion. In the Tool Properties view, enable 
the Lasso  selection type. Make sure the Use Mouse Gesture  button is enabled. In this 
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mode, you can automatically delete any extra sections of line in your artwork by simply clicking, 
holding and dragging your mouse over it. 

7. If you are using the Pencil tool to clean your drawing, you will need to merge your pencil lines 
together after cropping the points.

‣ In the Tools toolbar, select the Select tool.

‣ In the Camera or Drawing view, select the two strokes to be merged.

‣ In the Tool Properties view, click the Merge Pencil Lines  button.

‣ You can also set the Join option to Mitre.
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Drawing Tasks

Harmony has a wide variety of drawing tools for all kinds of drawing tasks. This section covers how to 
use these tools. For the complete details on their options in the Tool Properties view, see Drawing 
Tool References on page 219.

In this topic, you will learn about:

• Current Drawing on Top below

• Drawing with the Pencil Tool on the next page

• Drawing with the Brush Tool on page 163

• Drawing with Textured Brushes  on page 170

• Viewing the Final Lines as You Draw on page 185

• Selecting the Current Colour of a Tool  on page 186See "Selecting the Current Colour of a Tool 
" on page 186

• Selecting Drawing Objects on page 188

• Erasing Parts of a Drawing on page 192

• Reshaping a Drawing Using the Contour Editor Tool on page 194

• Reshaping Pencil Lines with the Pencil Editor Tool on page 196

• Drawing with Shapes on page 198

• Drawing with the Polyline Tool on page 199

• Drawing with Invisible Lines on page 200

• Deforming a Drawing with the Perspective Tool on page 202

• Warping a Drawing with the Envelope Tool on page 203

• Cutting Drawing Parts on page 205

• Smoothing Lines  on page 206

• Working With Text  on page 207

• Working with Tool Presets on page 207

• More Drawing Tools on page 211

 

Current Drawing on Top
In Harmony, when you draw on a layer, the artwork is displayed in the correct order. For example, if 
the layer on which you are drawing is located behind an object on another layer, the lines you are 
drawing will be hidden behind that object.
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This lets you display the selected drawing on top of everything while you draw. By enabling this 
option, each time you select a drawing tool, the selected drawing is displayed in front of everything in 
the Camera view. 

The Show Current Drawing on Top status (enabled or disabled) is remembered when you exit 
Harmony. When you restart the application, the last status will be used.

You only need to enable this option once, it is not necessary to do it each time you select a drawing 
tool.

How to display your drawing on top

1. Do one of the following:

‣ From the top menu, select View > Show > Current Drawing on Top. 

‣ In the Camera bottom toolbar, click the Current Drawing on Top button.

2. In the Tools toolbar, select a drawing tool.

3. In the Camera view, start drawing.

Drawing with the Pencil Tool

 

The Pencil  tool is for drawing the final images, such as character modules, cut-out puppet and clean 
animation. The pencil creates a central vector shape. Pencil lines support pressure sensitivity and 
texture.
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How to draw with the Pencil tool

1. In the Timeline or Xsheet view, select the cell on which you want to draw.

 

2. In the Tools toolbar, select the Pencil  tool or press Alt + /.

3. In the Colour view, click a colour swatch to select a colour.

4. In the Drawing or Camera view, start drawing.

‣ When you get close to an existing pencil line, hold Alt to draw and connect your stroke to 
the existing one. Pencil lines are central vector lines and you might think your line is 
connected, but in fact, only the contour is touching the other one. Also, make sure the 
central vector crosses the other one.
To connect the start or end of your stroke, hold Alt when you start or finish drawing a line.

‣ To draw a straight line, press Shift + Alt as you draw.

How to modify the pencil settings

1. In the Tools toolbar, select the Pencil  tool or press Alt + /.

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you 
customize the different parameters in the Tool Properties view. Click the arrow button.
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The Pencil Properties window opens.

This is where you set the minimum and maximum sizes of your drawing tool which will produce 
the thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

Parameter Description

Maximum Size Sets the maximum width of the line.

Minimum Size Sets the minimum width of the line in relation to the maximum size.

Smoothness
Lets you modify the central line smoothness  of the line. This parameter 
smooths the initial movement of your line. Increasing the value will result 
in a smoother line with fewer control points.

Contour Smoothness
Optimizes the contour line smoothness of the line. This parameter will 
smooth the contour of the line once it has been traced; the higher the 
value, the fewer control points will compose your line.
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Shape

You can adjust the start, end, and joint  style of a selected 
pencil line.

• Start: Lets you select the style of the start  tip, which is the 
first tip you drew. You can choose between Round or Flat 
style.

• End: Lets you select the style of the end tip, which is the 
last tip you drew. You can choose between Round or Flat 
style.

• Join: Lets you select the joint style. The joints are where 
the line curves abruptly. You could also define the Join 
style as the corner style. You can choose between Round, 
Mitre and Bevel style.

Texture See Pencil Line Texture on page 160.

Working with Pencil Presets

A preset is a pencil with specific properties. You can work with regular pencil presets and thickness 
stencils.

Regular pencil presets allow you to set the size and smoothing of the line or shape. As you draw, the 
thickness of the line varies according the amount of pressure you apply with a pen and tablet.  

Thickness stencils that are indicated with this  icon  are also set with specific properties, but 
disregards the pressure you use with your pen and tablet. The line thickness varies. You can access 
thickness stencils from the list of presets on the Tool Properties view or create your own. 

How to select a pencil preset

1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

2. In the Tool Properties view, use the Presets menu to select a pencil preset.

157



Chapter 6: Character, Prop and Location Design     Drawing Tasks

3. In the Drawing or Camera view, draw your pencil line or shape.

How to select a pencil thickness stencil

1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

2. In the Tool Properties view, use the Presets menu to select a thickness stencil. They are marked 

with this  icon.

3. In the Drawing or Camera view, draw your pencil line or shape.

How to create a pencil preset

1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

2. In the Tool Properties view, adjust your pencil settings—see How to modify the pencil settings on 
page 155.

3. In the Tool Properties view, click the New Brush  button.
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The New Preset dialog box opens.

4. Type in a name for your new pencil thickness stencil and click OK.

5. Start drawing in the Drawing or  Camera view. 

How to create a pencil thickness stencil

1. In the Tools toolbar, select the Select  tool.

2. In the Camera view, select the pencil line or shape from which you want to take the style.

3. In the Tool Properties view, click the New Thickness Stencil  button.

A new thickness stencil is added to the end of the list in the Presets menu.

4. In the Presets menu, select a new thickness stencil and click on a line or shape in the Drawing or 
Camera view to apply the thickness stencil you created.

How to apply a thickness stencil to a pencil line or shape

1. In the Tools toolbar, select the Select  tool.

2. In the Drawing or Camera view, select the pencil line or shape on which you want to apply a style.

3. In the Tool Properties view, select the style you want to apply from the Presets list.
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The style you selected is applied to your selection.

How to rename a thickness stencil or pencil preset

1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

2. In the Presets menu, select the thickness stencil or preset you want to rename.

3. From the Brush menu, select Rename Brush.

The Rename Preset dialog box opens.

4. In the Name field, type in the new name.

How to delete a thickness stencil or pencil preset

1. In the Tools toolbar, select the Pencil  tool.

2. In the Presets menu, select the thickness stencil or preset to delete.

3. Click the Delete Preset  button.

Pencil Line Texture

You can apply a texture to a pencil line.

Pencil lines support texture. Before drawing, you can select or import a texture and apply it to your 
lines. You can also change it afterwards using the Select  tool. Textures are independent from pencil 
templates.

When you import a texture in your pencil styles, it is saved in your scene. If you want to add that 
texture to a bank that you will reuse in different scenes, you can add that texture to your preferences.
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How to apply a preset texture to a pencil line

1. In the Tools toolbar, select the Pencil  tool.

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you 
customize the different parameters in the Tool Properties view. Click the arrow button.

In the Pencil Properties display.

3. In the Texture section, select a texture for the pencil.

4. In the Camera or Drawing view, draw a pencil line.

How to create a pencil texture template with the Pencil tool

1. In the Tools toolbar, select the Pencil  tool.

2. In the Tool Properties view, click the arrow button beside the stroke preview area.

3. In the Pencil Properties editor, click the New Texture  button or select New Texture from the 
Texture menu.

‣ To delete a preset style, click the Delete Texture  button.

4. Browse for your bitmap texture file. 

The file must be a TGA or PSD. Your texture MUST HAVE an alpha channel.
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5. Click Open.

The imported texture is saved in your scene texture list.

6. In the Pencil Properties editor, select your new texture.

7. In the Tool Properties view, click the Texture menu and select Rename Texture.

The Rename Opacity Texture dialog box opens.

8. In the Name field, type the template name and click OK.

9. In the Camera or Drawing view, draw your pencil lines.

How to add a texture to your preferences

1. In the Tools toolbar, select the Pencil  tool.

2. In the Tool Properties view, click the arrow button beside the stroke preview area.

3. In the Pencil Properties property editor, select a texture from the Textures area to add to your 
preferences. 
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4. Click the Copy to Preference   button.

How to apply a preset texture to a pencil line

1. In the Tools toolbar, select the Select  tool.

2. In the Drawing or Camera view, select a pencil line.

3. In the Tool Properties view,  select a texture from the Textures area to apply to the selected 
stroke. 

Drawing with the Brush Tool
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The Brush    tool is pressure sensitive and can create a contour shape which gives a thick and thin line 
effect, as if the drawing was made with a paint brush.

With the Brush tool, you can draw as vector or bitmap, depending on your preference. When you add 
your drawing layer, you can simply select the vector or bitmap option.  If you use vector, you will be 
able to enlarge your drawing and zoom into it without losing quality or resolution. You can also use 
the Contour Editor and Select tools to resize and modify lines. If you draw with bitmap, you will not be 
able to scale your drawing beyond 100% of its resolution without encountering pixelization issues.

You can create your own brush styles. A variety of brush styles are provided allowing you to create and 
save your own.This way you can create brushes with precise sizes and parameters and save them so 
you can draw and design. Renaming a brush can make it easier to identify and access the brushes you 
use most frequently.

A dynamic brush  can be created for drawing using patterns created from your artwork. Create a new 
dynamic brush to copy a pattern you have drawn to reproduce it quickly. You can create dynamic 
brushes using a single or multiple patterns that will automatically switch through the patterns as you 
draw.

To draw with the Brush tool

1. In the Timeline view, click the Add Drawing Layer button the .

The Add Drawing Layer window opens.

 

2. In the Name field, name your new layer.

3. Set the Line Art and Colour Art options to Vector to get a vector layer or to Bitmap to have a 
bitmap layer.

4. Click OK.

A new drawing layer is added to the Timeline view.

5. In the Timeline or Xsheet view, select the cell on which you want to draw.
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6. In the Tools toolbar, select the Brush  tool or press Alt + B.

7. In the Colour view, click a colour swatch to select a colour.

8. In the Drawing or Camera view, start drawing.

‣ Hold Ctrl (Windows/Linux) or ⌘  (Mac OS X) to force a line to join the start and end of the 
shape while drawing.

The last colour you select while using the Brush tool is recalled the next time you select the Brush tool.

How to select a brush style

1. In the Tools toolbar, select the Brush  tool or press Alt + B.

2. In the Tool Properties, select a brush style from the Brush Presets section.
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How to modify the brush settings

1. In the Tools toolbar, select the Brush  tool or press Alt + B.

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you 
customize the different parameters in the Tool Properties view. Click the arrow button.

The Brush Properties window opens.

This is where you set the minimum and maximum sizes of your drawing tool which will produce 
the thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

Parameter Description

Maximum Size Sets the maximum width of the line.

Minimum Size Sets the minimum width of the line in relation to the maximum size.
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Smoothness
Lets you modify the central line smoothness  of the line. This parameter 
smooths the initial movement of your line. Increasing the value will result 
in a smoother line with fewer control points.

Contour Smoothness
Optimizes the contour line smoothness of the line. This parameter will 
smooth the contour of the line once it has been traced; the higher the 
value, the fewer control points will compose your line.

Tip Shape

Lets you select a tip shape from round and square ones to 
star shaped.

Texture  See How to draw with textured lines on page 171

How to create a brush preset

1. Make sure your current brush has the settings you want in the preset you are will create.

2. Do one of the following:

‣ In the Brush view, click the New Brush  button.

‣ From the Brush  menu, select New Brush Preset.

‣ In the Properties window of the tool you are using, click the  button in the upper-left 
corner.

3. In the New Preset window, type a name for your new brush preset.

The new brush is added to the end of the list of brush preset.

Brush presets cannot be updated. However you can select a preset, which applies those properties to the 
current brush. Then you can modify the properties, and create a new preset with the new properties. If 
desired, you can delete the old preset.

How to rename a brush

1. In the Tool Properties view, select a brush to rename. 

2. From the Brush  menu, select Rename Brush. 

3. Type in a new name for the brush.

How to delete a brush preset

1. Select the brush preset you want to delete.

2. Do one of the following:

‣ In the Brush Preset view, click the Delete Brush  button.

‣ From the Brush Preset  menu , select Delete Brush.

How to create a new dynamic brush

1. In the Tools toolbar, select a drawing tool.
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2. In the Camera view, draw the pattern you want to use as your dynamic brush stamp.

3. In the Tools toolbar, click the Select  tool and  select the parts of the drawing you want to 
repeat.

4. In the Tools toolbar, select the Brush  tool or press Alt + B.

5. In the Tool Properties view, click the Add Dynamic Brush  button to add your selection as a new 
dynamic brush preset.

6. From the Brush  menu, select Rename Brush.

The Rename Preset dialog box opens.

7. Type in a name for the new dynamic brush and click OK.

8. In the Camera or Drawing view, start drawing with your dynamic brush to quickly repeat a pattern.

9. To adjust the scale of your pattern to make it bigger or smaller as you stamp it, adjust the 
Maximum Size value in the Tool Properties view.

How to create a dynamic brush with multiple drawings

1. In the Timeline view, click the Add Drawing Layers   sbutton to create the layers you want to use 
as patterns in your dynamic brush. Make sure to rename your layers.
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2. In the Camera view, draw your individual pattern on a separated layer.

3. In the Tools toolbar, select the Select  tool.

4. In the Tool Properties view, disable the Works on Single Drawing  option to allow the Select 
tool to grab artwork on multiple layers.

5. In the Camera view, select all the drawings you want to add to your new dynamic brush.

6. In the Tools toolbar, select the Brush  tool or press Alt + B.
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7. Click the Add Dynamic Brush  button to add your selection as a new Dynamic Brush preset.

8. From the Brush menu, select Rename Brush.

The Rename Preset dialog box opens.

9. Type in a name for the new dynamic brush and click OK.

10. In the Camera or Drawing view, start drawing with your dynamic brush to quickly repeat a pattern. 
When you use this brush, you will cycle through the drawings.

Drawing with Textured Brushes 
 

In Harmony, you can use the Brush  tool to draw with bitmap textured lines.

In the Brush Tool Properties view, you will find a series of default textured brushes, but you can also 
create your own collection by importing PSD or TGA files in the Preset list.

To create your own texture brush, you must prepare your texture file in a third-party software, such as 
Adobe Photoshop. If your image has transparency in it, it will be supported. The texture file must be 
either a PSD or TGA file. It is recommended that you maintain your texture resolution between 100 x 
100 pixels and 400 x 400 pixels.
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When you use the Eraser tool to erase a portion of a textured line, the vector frame is cut straight and 
you lose the feather created while drawing with the Brush tool. In Harmony, a special option in the 
Eraser tool lets you create a soft edge on your textured lines. You can also cut or keep the vector 
frame as is.

Sometimes you need to hide the line texture to see the complete vector frame around your lines. This 
is useful to help you see any dirt floating around your drawing.

At some point, you may want to modify the look of a textured drawing. Maybe you find that your line 
is too smooth or too faint. You can adjust those parameters by using the Adjust Line Texture Opacity 
command.

To hide the line texture in the Camera view, you must enable the Show Drawing on Top option. From 
the top menu, select View > Show > Current Drawing on Top—see Current Drawing on Top on 
page 153.

To draw with textured lines, use the Brush tool and the correct pen in the list. You can also draw with 
pencil line texture—see Pencil Line Texture on page 160

How to draw with textured lines

1. In the Tools toolbar, select the Brush  tool or press  Alt + B.

2. In the Tool Properties view, select a brush and click the Arrow button to open the Brush Properties 
view.

3. In the Texture section, select the Select Texture option.

4. Set the following parameters:

‣ Hardness: The hardness value corresponds to the smoothness of the line edge. The lower 
the value, the more blurry and smooth the line edge will be. The higher the value, the 
sharper the line edge will be.
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‣ Minimum Opacity: This value corresponds to the transparency of the brush when the 
pressure is very light. Values closer to 0 produce a more transparent line.

‣ Maximum Opacity: This value corresponds to the transparency of the brush when the 
pressure is heavy. Values closer to 1 produce a more opaque line. 

‣ Select Texture: Lets you use and select a texture for your brush. The thumbnail displays the 
current texture. You can also browse for a texture file to import. Browsing for a texture file 
in a brush already using texture will replace the file currently in use, although it will not 
replace the texture in the lines already drawn.  If your image has transparency in it, it will be 
supported. The texture file must be either a PSD or TGA file. It is recommended that you 
maintain your texture resolution between 100 x 100 pixels and 400 x 400 pixels.

‣ Texture Scale: Changes the size of the texture in the lines you draw. If you are using a plaid 
texture, the squares will be larger if you increase the value and smaller if you decrease it.
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5. In the Camera or Drawing view, start drawing.

How to erase textured lines

1. In the Tools toolbar, select the Eraser  tool, press Alt + E.

2. In the Tool Properties view, click the arrow button.

The Brush Properties window opens.
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3. Adjust the following: 

‣ Maximum/Minimum Size: Defines the minimum and maximum width of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line.

‣ Contour Smoothing: Defines the number of control points added to the contour 
boundaries (around the line). Lower values mean that the line will appear as you draw it 
(with more control points added along the centre line). Higher values mean that the line will 
be smoothed out (removing control points from the centre line).

‣ Tip Shape: Lets you select a shape for the tip of the eraser. There are a variety of tips to 
choose from: round, square, oval, star-shaped, and more. This option is only available when 
the textured tip is not in use.

‣ Soft Tip: Gives the tip of your stroke a soft edge.

‣ Keep Vectors: Keeps your vector frames and does not cut them.

‣ Hardness: The smoothness of the line edge. The lower the value, the more blurry and 
smooth the line edge will be. The higher the value, the sharper the line edge will be.

‣ Saturation: The intensity of line colour.

‣ Maximum Opacity: The transparency of the brush when the pressure is heavy. Values closer 
to 1 produce a more opaque line. 

‣ Minimum Opacity: The transparency of the brush when the pressure is very light. Values 
closer to 0 produce a more transparent line.
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4. In the Camera or Drawing view, erase your textures lines.

How to adjust the line texture opacity

1. If you are in Camera view, select the Current Drawing on Top option—see Current Drawing on 
Top on page 153.

2. In the Timeline or Xsheet view, select the drawing that contains the opacity you want to adjust.

3. In the Camera or Drawing view menu, select Drawing > Adjust Line Texture Opacity.

The Adjust Line Texture Opacity dialog box opens. 

4. Drag the sliders toward the middle to increase the contrast and opacity of the textured lines.

5. If you want to apply the changes to all drawings exposed on the layer, select the Apply to All 
Drawings option and click OK.
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Drawing with Bitmap Brushes

With Harmony, you have the choice to draw with vector or bitmap brushes. When adding a new 
drawing layer in , you can set your art layers (Line, Art, Colour Art) to vector or bitmap. This way, you 
can draw in bitmap and paint in vector, draw everything in bitmap, or whatever other combination 
suits you.

Not all drawing tools are available when working on a bitmap layer. You can use the following tools:
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• Brush

• Cutter

• Dropper

• Ellipse

• Eraser

• Line

• Paint

• Paint Unpainted

• Pivot

• Rectangle

• Repaint

• Reposition All Drawings

• Select

• Text

• Unpaint

In , when adding a new drawing layer to the Timeline view, you can select the art mode for each art 
layer. You can set the Line Art layer to vector while setting the Colour Art as bitmap. You also have the 
opportunity to adjust them later by converting them from one to the other. If you are using the 
Overlay and Underlay layers, you can also set them to either bitmap or vector.

If you selected the incorrect art mode for your layers, you can open the Layer Properties view and 
modify them there directly. If you switch the art mode for a layer that already has strokes on it, the 
artwork will NOT be converted. You will be able to add new strokes. A drawing with bitmap strokes 
will be converted to a vector layer but the bitmap artwork will remain as bitmap. You will be able to 
use vector drawing tools to continue drawing on it. A drawing with vector lines switched to a bitmap 
layer will allow you to draw new bitmap strokes and move the vector strokes with the Select tool, but 
you will not be able to edit the vector art further. You need to convert the drawings in order to pass 
the artwork from one mode to the other.

To always reuse the same art mode settings, you can adjust them in the Preferences dialog box.

Before you start drawing in bitmap, it is important to understand that your artwork will now be 
resolution dependent. If you zoom in your scene, you artwork will be enlarged. It is important to plan 
ahead and decide how high of a resolution you need your artwork to be. If you plan to zoom in your 
scene, the smallest section of the image that the camera will frame must be 100% the size of your 
scene resolution. For example, if your scene resolution is set to 1920 x 1080 and you zoom  in at 300%, 
then the resolution of the bitmap also has to be set to 300%. It is important to change the bitmap 
layer resolution before you start drawing.
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The bitmap resolution can be set at the scene level or drawing level. The setting at the scene level 
affects newly created bitmap art layers. 

Note that even if your drawing resolution is set to be very large, it doesn't mean that your file will be 
very heavy. It depends on the amount of artwork your draw in it.

There is a function to change the resolution of bitmap art for individual drawings. You can reduce the 
resolution of your bitmap file as well as increase it. Be careful because enlarging the bitmap resolution 
on an existing drawing will result in a loss of quality.Harmony will perform a pixel smoothing pass 
(resampling) and create additional pixels to avoid losing too much quality, but only to a certain extent.  
For example, you used the default scene’s resolution for bitmap art but then discover you are zooming 
quite close into the lines.  If you do not want to see the pixels appear too much when you are zoomed 
in, you can set the bitmap resolution to 200% and the bitmap art will have a higher resolution with 
smaller pixels, but will NOT retain 100% of its quality. You can use this function on multiple drawings 
using the Apply to All Drawings option. Changing this option will affect existing and selected bitmap 
art layers.

If you drew an outline drawing on a bitmap layer, you can vectorize your artwork. Using a vector 
drawing layer, you can simply select your bitmap drawing and the vector cell on which you want your 
new vector layer to be, and use the Vectorize Line Art in Selected Drawing function.

You should avoid scaling up your bitmap strokes using the Select tool. If you do, keep in mind that 
when you continue drawing, your image will be resampled and your new strokes will be at the original 
resolution and not the scaled up size. 
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Your drawing should be scaled up using the Transform  tool instead of the Select tool to avoid creating 
very large bitmap layers.

How to add a bitmap layer

1. In the Timeline view, click the Add Drawing Layer button,

The Add Drawing Layer dialog box opens.

If you are using the Overlay and Underlay layers, those art layers are also displayed.

2. For each art layer, select the Vector or Bitmap option.
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3. Click OK.

How to change the art mode

1. Open the Layer Properties view.

2. In the Timeline view, select the layer you want to edit.

3. In the Layer Properties view, select the Drawing tab.

4. In the Art Layers section, select the art mode for each art layer.

How to convert drawings to match the art mode

1. In the Timeline view, select the layer that contains the drawings you want to convert.

2. From the Timeline view menu, select Layers > Convert Drawings to Match Art Layer Type.

You can also right-click on the selected layer and select Convert Drawings to Match Art Layer 
Type.

All drawings in the layer are converted to the selected art mode. Note that bitmap strokes are not 
vectorized when converted to a vector art layer. They are simply inserted in a square vector frame 
containing a bitmap texture.

How to change the bitmap layer resolution at the scene level

1. From the top menu, select Scene > Scene Settings.
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The Scene Settings dialog box opens.

2. Select the Bitmap Resolution tab.

3. Change the bitmap resolution settings and click OK.

The bitmap resolution settings at the scene level affects newly created bitmap art layers.

Parameter Description

Scene Resolution This is the scene resolution preset name and size in pixel.

Width

This is the width of the resolution for the bitmap that will be created. 
This is not the actual size of the bitmap. TVG drawings (Toon Boom 
drawing native format) have an infinite size. Bitmap TVGs are composed 
of small tiles. Therefore it does not mean that because you have art-
work at the four corners of your camera frame or even quite far outside 
of your drawing that your bitmap image will be very large and heavy. By 
default, it is set to the same width as the scene resolution.

Height
This is the height of the resolution for the bitmap that will be created. 
By default, it is set to the same height as the scene resolution.

Resolution Factor

This is the size of the bitmap resolution in relation to the scene res-
olution. If you increase the percentage, the width and height fields will 
increase accordingly. If you plan to animate the camera and zoom into 
your background, you will need to set a higher resolution so that the 
smaller area in which you will zoom will be 100% of the scene resolution.

How to change the bitmap resolution at the drawing level

1. In the Timeline view, select the drawing whose resolution you want to change.
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Note that the drawing can be enlarged slightly and retain its original look, but you may lose quality if you 
enlarge it too much. Pixels are created and a smoothing pass is applied. You should set your resolution 
before drawing. If you need to change the resolution of a drawing to be larger than the one set in the 
Scene Settings dialog box, create an empty drawing first and then follow this procedure.

2. From the top menu, select Drawing > Change Bitmap Drawing Resolution.

The Change Bitmap Drawing Resolution window opens.

Parameter Description

Scene Resolution This is the scene resolution preset name and size in pixel.

Width

This is the width of the resolution for the bitmap that will be created. 
This is not the actual size of the bitmap. TVG drawings (Toon Boom 
drawing native format) have an infinite size. Bitmap TVGs are composed 
of small tiles. Therefore it does not mean that because you have art-
work at the four corners of your camera frame or even quite far outside 
of your drawing that your bitmap image will be very large and heavy. By 
default, it is set to the same width as the scene resolution.

Height
This is the height of the resolution for the bitmap that will be created. 
By default, it is set to the same height as the scene resolution.

Resolution Factor

This is the size of the bitmap resolution in relation to the scene res-
olution. If you increase the percentage, the width and height fields will 
increase accordingly. If you plan to animate the camera and zoom into 
your background, you will need to set a higher resolution so that the 
smaller area in which you will zoom will be 100% of the scene resolution.

Resample Bitmap

When this option is selected, the existing bitmap image is 
modified to match the new resolution. If the width and height 
are increased, more pixels will be created to enlarge the 
image. Visually, the existing artwork will look the same, 
maybe a little bit smoothed out, but the size will look the 
same. When this option is deselected, the artwork is not 
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modified. Only the reference grid is resized. If the scene 
resolution is 1920 x 1080 and you reduce the bitmap 
resolution to 960 x 540, the image will be scaled up to twice 
the size of the scene.

Apply to All Drawings
The modified settings are applied to all drawings in the drawing layer 
for a given art layer. If the Apply to Line Art and Colour Art option is 
enabled, it will then be applied to all bitmap art layers.

3. Change the bitmap resolution.

4. Click OK.

How to draw with bitmap brushes

1. In the Timeline view, add a bitmap drawing layer—see How to add a bitmap layer on page 179.

2. In the Tools toolbar, select the Brush  tool or press Alt + B.

3. In the Colour view, select a colour.

‣ To switch the bitmap colour picker from HSV to RGB, in the Colour view menu, select 
Colour > Bitmap Colour Sliders > HSV Sliders or RGB Sliders. You can also right-click on 
the colour sliders and select RGB Sliders or HSV Sliders.

When using bitmap colours, there is no longer a link between the painted zones and selected colour. 
You can modify the colour picker as much as you want. Your drawing will not be affected. You can 
still select colours from your vector colour palette to use the same tint, but you will not create links 
between your drawing and the swatches.

4. In the Camera or Drawing view, start drawing.
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How to vectorize a bitmap drawing

1. In the Timeline view, add a vector drawing layer BELOW the bitmap drawing layer containing the 
drawing to vectorize. In your bitmap drawing, the artwork to vectorize must be placed on the Line 
Art layer (default drawing layer).

If you place the vector drawing on top of the bitmap layer, you will not be able to 
perform the operation. A warning dialog box will display.

2. On the right side of the Timeline view, select the bitmap drawing and corresponding cell in the 
vector drawing layer.

3. Right-click and select Drawing > Vectorize Line Art in Selected Drawing.

The Convert to Vector Drawing dialog box opens.
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4. In the Vectorization section, select a vectorization preset. You can customize your own preset 
using the Add or Edit buttons.

5. Click OK.

Your vectorized drawing is created in the vector drawing layer. Your bitmap drawing remains 
intact.

Viewing the Final Lines as You Draw

Everything you draw in Harmony is vector-based, unless you purposely elected to draw as bitmap. 
Although, when you draw in the Drawing or Camera view, notice that your lines may appear jagged. 
This is caused by the fast real-time display called OpenGL.  If you prefer to see smooth lines as you 
draw, you can enable the antialiasing preference.

Full Scene Antialiasing 

Full scene antialiasing is generated by your computer’s graphics card. This antialiasing will not only 
antialias your drawings, but all your different views in the interface. Full scene antialiasing is an option 
you can turn on and off; by default, it is disabled. 

There is no need to modify your graphic card settings.

Full Scene Antialiasing parameters are only valid while you work in your scene. The scene will be rendered 
to 100% of its resolution regardless of your preference settings or graphic card panel.

How to customize the full scene antialiasing parameters

For Mac OS X, you must restart Harmony after you change the parameters.
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1. In the Harmony, do one of the following:

‣ Windows/Linux: Select Edit > Preferences.

‣ Mac OS X: Stage > Preferences.

‣ Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

The Preferences dialog box opens.

2. In the OpenGL tab, go to the Full Scene Antialiasing section.

‣ Enable: Select this option to enable/disable the Full Scene Antialiasing.

Number or samples (For Mac OS): If you are using a Mac OS X computer, enter the number of samples 
you want to be used for the antialiasing process. The number of samples is basically equivalent to the 
amount of times a pixel will be enlarged to calculate the antialiasing. This technique is called 
supersampling. The higher the number of samples, the better the antialiasing quality will be, but the 
longer it will take to calculate.

3. Restart Harmony.

Selecting the Current Colour of a Tool 

While drawing and painting, you can let Harmony retain the last colour you selected for each one of 
the following tools:

• Brush

• Paint 

• Pencil, Ellipse, Line, Rectangle, Polyline

The Colour view has three swatches where you can set a colour for the Brush , Paint,   and Pencil   tools.

How to unlink the storage swatches

1. In the Colour view, if the storage swatches are linked, click the Link   button to unlink them.

2. Click on the Brush  storage swatch.
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3. In the Colour list, select the desired colour.

4. Click the Pencil   storage swatch.

5. In the Colour list, select a colour.

6. Click the Paint   storage swatch.

7. In the Colour list, select a colour.

If you prefer to have Toon Boom Harmony use the same colour swatches regardless of the selected tool, 
you can link the three swatches together.

How to link the storage swatches

1. In the Tools toolbar, select one of the following tools:

‣  Brush

‣  Paint

‣  Pencil

‣  Polyline

‣  Line

‣  Ellipse
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‣  Rectangle

2. In the Colour view, if the storage swatches are unlinked, click the Link   button to link them.

Each time you select a new colour for your current tool, all the storage swatches are updated.

Using Independent Colours when Working with Bitmap Layers
When working in the Colour view, by default the current colour is active for both vector and bitmap 
layers. You can however, use different reference colours for each layer. 

When using bitmap colours, there is no longer a link between the painted zones and selected colour. 
You can modify the colour picker as much as you want. Your drawing will not be affected. You can 
still select colours from your vector colour palette to use the same tint, but you will not create links 
between your drawing and the swatches.

How to use independent colours

‣ From the Colour view menu, select Colours > Independent Bitmap Colour.

Whichever colour you choose as the reference color is retained for that layer type.

 

Selecting Drawing Objects

The Select   tool is used to select strokes in both the Drawing and Camera views, and apply basic 
transformations, such as repositioning, rotating, scaling or skewing using the different handles of the 
bounding box.
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Sometimes, when you want to select multiple objects while leaving one unselected, it can be handy to 
select only the stroke or line that you do not want included in your selection. Then, you can invert the 
selection so that everything else becomes selected. This can be quite a time saver.

By default, when you draw a selection box, the Select tool will select only the drawing strokes of the 
current drawing. If you prefer the Select tool to select all the strokes on all layers, you can disable the 
Works on Single Drawing option in the Tool Properties view or the Select Tool Works on Single 
Drawing option in the Preferences dialog box.

Some of the transformations, such as rotation, scale, skew, and flip are done relative to the position of 
the pivot point. You can temporarily reposition this pivot point for a transformation using the Select  
tool.

How to select with the Select tool

1. In the Timeline view, select the cell on which you want to select drawing objects.

2. In the Tools toolbar, select the Select  tool or press Alt + S.

3. In the Camera or Drawing view, select the drawing objects.

‣ You can select all the drawing objects in a drawing by using Edit > Select All or by pressing 
Ctrl + A (Windows/Linux) or ⌘  + A (Mac OS X).

4. To deform or reposition a selection:

‣ To reposition, click the selected drawing object and drag the selection to a new area.

‣ To rotate, grab the selection box handle and rotate it.

‣ To scale, pull or push on the top, side, bottom or corner control point. Hold down Shift to 
lock the selection’s ratio.
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‣ To skew, drag sideways or up and down the sides or top and bottom segments, between 
the control points.

How to invert a selection

1. From the top menu, select Edit > Invert Selection or press Ctrl + Shift + I (Windows/Linux) or ⌘  + 
Shift + I (Mac OS X).

‣ You can also find the Invert Selection option in the Camera or Drawing View menu by 
selecting Edit > Invert Selection.

How to enable and disable the Select Tool Works on Single Drawing preference

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS 
X).

The Preferences dialog box opens.

2. In the Camera tab, go to the Tools section and select or deselect the Select Tool Works on Single 
Drawing option and click OK.

3. In the Tools toolbar, select the Select  tool or press Alt + S.

4. In the Camera view, make your selection. It is possible that you will have to restart Harmony 
depending on your system.
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How to temporarily reposition the pivot point

1. In the Camera or Drawing view, select the drawing object you want to transform. 

The pivot point appears in the middle of your selection.

2. Click the pivot point and drag it to a new position.

This becomes the new position of the pivot point for the current transformation and will remain 
there until you make a new selection.
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Erasing Parts of a Drawing

The Eraser tool is pressure sensitive, like the Brush tool, giving you more precision when erasing parts 
of a drawing. You can also use the Select tool to select drawing objects and delete them instead of 
erasing.

How to erase with the Eraser tool

1. In the Timeline or Xsheet view, select the cell that contains objects you want to erase.

2. In the Tools toolbar, select the Eraser  tool or press Alt + E.

3. In the Camera or Drawing view, start erasing.

How to modify the eraser settings

1. In the Tools toolbar, select the Eraser  tool .

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you 
customize the different parameters in the Tool Properties view. Click the arrow button.

The Brush Properties window opens.
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This is where you set the minimum and maximum sizes of your drawing tool which will produce 
the thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

Parameter Description

Maximum Size Sets the maximum width of the line.

Minimum Size Sets the minimum width of the line in relation to the maximum size.

Smoothness
Lets you modify the central line smoothness  of the line. This parameter 
smooths the initial movement of your line. Increasing the value will result 
in a smoother line with fewer control points.

Contour Smoothness
Optimizes the contour line smoothness of the line. This parameter will 
smooth the contour of the line once it has been traced; the higher the 
value, the fewer control points will compose your line.

Tip Shape

Lets you select a tip shape from round and square ones to 
star shaped.

Texture  See How to draw with textured lines on page 171
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Reshaping a Drawing Using the Contour Editor Tool

The Contour Editor tool is a powerful tool that allows you to add, remove or modify points on a 
vector line and control them with Bezier handles. It is used to correct line shapes and modify a single 
part of a colour zone. If a line is too thin or has a gap in it, you can modify and correct it with the 
Contour Editor tool. You can also use this tool to create elaborate shapes. 

The Contour Editor displays vector points around a shape and the central vector points in a pencil line. 
Pulling or pushing on these points adjusts the brush’s line thickness. Points can be selected and 
deleted. Each point has two Bezier handles for correcting the curves between two points. Shapes can 
be modified by pulling and pushing directly on the segment between the points. You can use it to 
perfect a central shape pencil line, a contour shape brush line, or even create an elaborate shape from 
a basic ellipse or square.

How to reshape with the Contour Editor tool

1. In the Timeline or Xsheet view, select the cell in which you want to draw.

2. In the Tools toolbar, select a shape tool: .

3. In the Tool Properties view, click the Ellipse  button, click the Auto Fill  button and set the 
pencil size to 0.

4. In the Drawing or Camera view, draw a circle.

5. In the Tools toolbar, select the Contour Editor  tool.

6. In the Drawing or Camera view, click the line to reshape it.
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7. Select one or several points by clicking on them or circling around.

8. Press Delete to delete a selected point.

Press Ctrl (Windows/Linux) or ⌘  (Mac OS X)and click on the contour to add a new point to adjust 
the contour.

9. To modify the shape, you can:

‣ Pull on the Bezier handle. Both point’s handles will move as one.

‣ Hold down Alt and pull on one of the Bezier handles. The point’s handle will move 
independently from the other one.

‣ Move the selected points to a new area.

‣ Pull directly on the line between two points. No selection is necessary. Holding down Shift 
will limit the contour modification to the curve between the two first points.

‣ If an anchor point has no visible Bezier handles, hold down the Alt key to display them.

‣ To add control points, press Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click the line.
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‣ To remove control points, select the control point and press Delete.

Reshaping Pencil Lines with the Pencil Editor Tool

The Pencil Editor  tool is used to modify the thick and thin contour of a pencil line. A pencil line is a central vector 
shape. The shape control points are located all along the central spine allowing you to adjust the stroke curve 
and position. When using the Contour Editor tool, you can reposition the spine of the stroke. When using the 
Pencil Editor tool, you can adjust the thick and thin areas of lines.

How to use the Pencil Editor tool

1. In the Tools toolbar, select the Pencil Editor  tool or press Alt + W.

2. In the Camera or Drawing view, select a pencil line and click the line to reshape it.

3. Select one or several points by clicking them or circling around.
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4. Press Delete to delete a selected point.

5. Press Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click the central spine to add a set of points to 
adjust the contour.

6. To modify the shape, you can:

‣ Move the selected points to a new area. If you select matching points on each side of the 
line, holding the Shift key will move them both.  This way you can thicken or thin a line from 
both sides at the same time.

‣ Pull on the Bezier handle to move both points’ handles as one.

‣ Hold down Alt and pull on one of the Bezier handles. It moves the handle independently 
from the other one.
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‣ Pull directly on the line between two points. No selection is necessary. Holding down the 
Shift key will limit the contour modification to the curve between the two first points.

‣ If an anchor point has no visible Bezier handle, hold down Alt to display them.

Drawing with Shapes

In Harmony, you can use the shape tools to draw circles, lines and squares. You can also easily reshape 
a square or circle into a much more complex drawing such as these butterfly wings—see Reshaping a 
Drawing Using the Contour Editor Tool on page 194 and Reshaping Pencil Lines with the Pencil Editor 
Tool on page 196.

How to draw with a Shape tool

1. In the Timeline or Xsheet view, select the cell on which you want to draw.

2. In the Tools toolbar, select a shape tool: .

3. To automatically fill the shape, in the Tool Properties view, select the Auto Fill  option.

4. In the Camera view, click and drag to draw the shape.
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‣ Hold down Shift to lock the rectangle or the ellipse ratio to 1:1.

‣ Hold down Alt to draw the rectangle or ellipse from its centre.

‣ Hold down Shift to snap the line every 15 degrees.

‣ Hold down Alt to snap the start or end of the line to a nearby stroke.

5. Use the Contour Editor  tool to deform the shape and create your drawing.

Drawing with the Polyline Tool

The Polyline tool is used to draw shapes with a central vector type of line. To form a shape, you click to 
add a point and then, without releasing the mouse, pull the handle in the desired direction before 
adding the next point and repeat the operation. To edit the shape, you can use the Contour Editor 
tool.

How to draw with the Polyline tool

1. In the Timeline view, select the cell on which you want to draw.

2. In the Tools toolbar, select the Polyline   tool or press Alt + _.
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3. In the Camera view, click and drag to create a point and a Bezier handle to shape your line.

‣ Press Alt to pull only one handle, instead of two.

‣ Press Shift to snap the handles to 45, 90, or 180 degrees.

4. Click a new area and drag to create a second point and Bezier handle.

 

5. Repeat the previous step until your shape is completed.

6. Press Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click to release the Polyline tool from the current 
path or shape that it is creating. Continue to use the tool to make multiple, independent paths or 
shapes.

7. If necessary, reshape the lines using the Contour Editor    tool—see Reshaping a Drawing Using 
the Contour Editor Tool on page 194.

Drawing with Invisible Lines

There are two different ways to draw invisible lines. 

Using the Pencil tool, you can draw as strokes only, meaning that the line will be invisible. This can be 
useful for drawing tones and highlights directly on the character.

The Stroke  tool draws invisible lines only. You cannot add thickness to the line, unlike the Close Gap 
tool that creates a short, straight line between two points. The stroke line will stay exactly where you 
draw it. This tool can be useful for closing a zone in a particular way or creating some hard shadows or 
highlight areas.
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Sometimes, it may be difficult to see your strokes, especially if your colours are similar to the blue 
stroke colour. In Harmony, you can display the strokes and washed-out the colours of your drawings 
so that the invisible lines stand out.

How to draw invisible lines with the Pencil tool

1. In the Timeline or Xsheet view, select the cell on which you want to draw.

2. In the Tools toolbar, select the Pencil  tool or press Alt + /.

3. From the top menu, select View > Drawing > Show Strokes  or press K. 

4. In the Tool Properties view, set the Pen Style size to 0. You can also adjust the smoothness.

5. In the Camera or Drawing view, start drawing.

If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first 
stroke, a Message dialog box opens.

Select the Don’t Show This Message Again option if you do not want the dialog box to notify you 
about the Show Strokes option.

6. Click OK.

7. You can modify the stroke shape with the Contour Editor  tool.

How to draw invisible lines with the Stroke tool

1. In the Timeline or Xsheet view, select the cell on which you want to draw.

2. In the Tools toolbar from the Paint drop-down menu, select the Stroke  tool or press Alt + V.

3. From the top menu, select View > Show Drawing > Show Strokes  or press K. 

4. In the Tool Properties view, you can adjust the smoothness.

5. In the Camera or Drawing view, start drawing.

If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first 
stroke, a Message dialog box opens.
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Select the Don’t Show This Message Again option if you do not want the dialog box to notify you 
about the Show Strokes option.

6. Click OK.

7. You can modify the stroke shape with the Contour Editor  tool.

How to show the strokes with washed-out colours

‣ From the top menu, select View > Show > Show Stroke With Colour Wash.

Deforming a Drawing with the Perspective Tool

The Perspective tool lets you deform a drawing selection and alter its perspective.

How to deform a drawing with the Perspective tool

1. In the Tools toolbar, select the Perspective  tool from the Contour Editor drop-down menu or 
press Alt + 0.

2. In the Camera or Drawing view, select a drawing to deform.

3. Click and drag the different anchor points to deform the shape.
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Warping a Drawing with the Envelope Tool

The Envelope tool lets you deform and warp part of a drawing using a grid envelope and Bezier 
handles.

How to warp a drawing with the Envelope tool

1. In the Tools toolbar, select the Envelope   tool from the Contour Editor drop-down menu.

2. In the Timeline view, select a drawing to deform.

3. In the Camera or Drawing view, select the region you want to deform
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4. Click and drag the different anchor points and handles to deform the image.

5. To display more controls, in the Tool Properties view, click the Show Advanced Controls  
button.

6. Increase the height and width of the grid to get more control points to deform your image.
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Cutting Drawing Parts

The Cutter tool lets you cut a drawing area to move, copy, cut or delete it.

How to cut with the Cutter tool

1. In the Tools toolbar, select the Cutter  tool or press Alt + T.

2. In the Camera view, make a selection around an area to cut away.
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‣ To delete the selected zone, press Delete.

‣ To move the selection, click the selection and drag it to a new area.

‣ Use the bounding box controls to scale, skew, or rotate the cut piece.

Smoothing Lines 

When drawing in a digital application, it is not like drawing on a sheet of paper. Sometimes the lines 
you draw may look as if they were drawn with an unsteady hand. When this occurs, you may need to 
correct the look of your lines.

Harmony has a very powerful tool you can use to optimize contours and reduce the number of points 
on the lines, the Smooth Editor  tool.

How to optimize lines with the Smooth Editor tool

1. In the Tools toolbar, select the Smooth Editor  tool or select  Drawing > Tools > Smooth 
Editor.

2. In the Camera or Drawing view, place your pointer over the lines to smooth. You may need to pass 
over the same line several times to remove more points and make the line smoother. Note that by 
default, the Smooth Editor tool colour is yellow, it was changed to orange for screen grab clarity—
see Smooth Editor Tool Options on page 256 to learn about the various settings available.
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Working With Text 

With the Text tool, you can type text in your project using various fonts and texts attributes. Text 
objects are part of a drawing, so you can manipulate them in the same way. OTF fonts are also 
supported.

How to add text to drawings 

1. Do one of the following: 

‣ In the Tools toolbar, select the Text  tool. 

‣ From the top menu, select Drawing > Tools > Text.

‣ Press Alt + 9.

2. In the Timeline view, select the cell containing the drawing on which you want to add text.

3. In the Drawing or Camera view, click on the location you want the text to begin.

4. You can use the Tool Properties view to select the font, font size and format of the text you will 
type—see Text Tool Options on page 258. 

5. Type in the desired text.

6. Click outside the text box to exit the typing mode.

If you want to create another text object, click outside the currently active text box. You can always 
return to edit the text by selecting the Text  tool and clicking in the text.

Working with Tool Presets
Tool presets let you save a variety of settings and are very handy and efficient for accessing the tools 
you use most often. That way, the tool is already set with the desired properties, such as colour, line 
thickness, whether to enable Draw Behind or Auto Flatten mode, and so on. You can create presets 
for these tools and many more: Brush, Pencil, Eraser, Rectangle, Ellipse, and Line. First, select a tool, 
adjust the properties, and then create a tool preset for it. Once you have created a tool preset, you 
can always make adjustments to fine-tune it, as well as create a keyboard shortcut for it.

The Tool Presets Toolbar

The Tool Presets toolbar lets you create new tool presets and manage them. There are four default 
brush presets to get you started—Rough Brush, Clean Pencil, Fill Paint, and Inking Brush. By default, 
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this toolbar is not displayed.

How to display the Tool Presets toolbar

‣ Select Windows > Toolbars > Tool Presets.

‣ Right-click an empty area below the top menu and select Tool Presets.

How to create a tool preset

1. In the Tools toolbar, select a tool, for example the Brush tool.

2. Use the Tool Properties view to customize the tool. 

3. To set a specific colour for your preset, in the Colour view, select the colour swatch to link to the 
tool. Note that when using this preset in another scene not using that colour palette, upon 
selecting this new preset, a colour recovery dialog box will appear asking to add this colour to 
your scene.

4. In the Tool Presets toolbar, click the New Tool Preset  button.

5. In the New Tool Preset dialog box, in the Name field, type a name for your new preset.

6. From the icon list, select an icon to quickly identify your preset or upload your own by clicking the 
File  button.
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7. (Optional) From the Shortcut menu, set a keyboard shortcut to quickly access your preset.

8. When you select any of the following options, they will take effect when you use the tool preset. If 
an option is deselected, then using a tool preset will not override your current settings. 

‣ Colour: Saves the current colour into the tool preset.

‣ Tool: Only the colour will be associated. You could, for example, set three different colours 
with shortcuts.  It would use the current tool with the chosen preset colour.

9. Click OK.

How to select a tool preset

‣ In the Tool Presets toolbar, click the tool preset  icon you assigned when creating the 
preset.  Note that when using this preset in a new scene not using the assigned colour 
swatch,  a colour recovery dialog box appears asking to add this colour to your scene.

How to delete a tool preset

1. In the Tool Presets toolbar, click the Manage Tool Presets  button.
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2. From the list of tool presets on the left, select a preset to delete and click the Trash icon.

How to import a tool preset

1. In the Tool Presets toolbar, click the Manage Tool Presets  button.

The Manage Tool Presets dialog box opens.

2. Click Import.

3. In the Select Folder window that opens, locate and select the preset(s) to import and click Select 
Folder.

How to export a tool preset

1. In the Tool Presets toolbar, click the Manage Tool Presets  button.

The Manage Tool Presets dialog box opens.

2. Click Export.

3. In the Export Brush Presets window that opens, click  Export.

4. Select a folder and click Select Folder.

How to update a tool preset

1. To update the colour of your preset, you must first select it in the Colour view.

2. In the Tool Presets toolbar, click the Manage Tool Presets  button.

3. In the Manage Tool Presets dialog box that opens, select the tool preset from the left side of the 
dialog box. 

4. Make any changes you would like to the preset.

5. Click Update.
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More Drawing Tools
Harmony offers a wide variety of useful tools to optimize your drawings and work more efficiently; 
tools such as Group, Arrange, and the animation disk to rotate your workspace.

• Arrange below

• Convert Brush Strokes to Pencil Lines on the next page

• Pencil Lines to Brush Strokes on the next page

• Strokes to Pencil Lines  on page 213

• Optimize on page 213

• Remove Extra Strokes on page 214

• Reduce Drawing Texture Resolution  on page 214

• Crop Brush Textures  on page 215

• Create Contour Stroke  on page 216

• Remove Contour Stroke  on page 216

• Grid on page 217

• Group/Ungroup on page 217

• Hand on page 218

• Rotate View on page 218

Arrange

The different Arrange options let you reorder drawing objects inside a single layer in the Drawing or 
Camera view.

Name Button Description Access Method

Bring to Front
Moves the selected art to the front 
(on top)

From the top menu, 
select Drawing > 
Arrange > Bring to 
Front.

Press Ctrl + Shift + 
PgUp 
(Windows/Linux) or 
⌘  + Shift + PgUp 
(Mac OS X).

Bring Forward
Moves the selected art one level for-
ward (closer to the front)

From the top menu, 
select Drawing > 
Arrange > Bring 
Forward.

Press Ctrl + PgUp 
(Windows/Linux) or 
⌘  + PgUp (Mac OS 
X).

Send Backward Moves the selected art one level From the top menu, 
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lower (behind)

select Drawing > 
Arrange > Send 
Backward.

Press Ctrl + PgDown 
(Windows/Linux) or 
⌘  + PgDown (Mac 
OS X).

Send to Back

Moves the selected art 
behind everything (bottom 
/ back)

 

From the top menu, 
select Drawing > 
Arrange > Send to 
Back.

Press Ctrl + Shift + 
PgDown 
(Windows/Linux) or 
⌘  + Shift + PgDown 
(Mac OS X).

Convert Brush Strokes to Pencil Lines

The Brushes Strokes to Pencil Lines  operation converts selected contour strokes into centreline pencil 
strokes. This command is only available from the top menu.

How to convert brush strokes to pencil lines

‣ From the top menu, select Drawing > Convert > Brush Strokes to Pencil Lines or press ̂ .

‣ Right-click on the selection, select Convert > Brush Strokes to Pencil Lines or press ̂

Pencil Lines to Brush Strokes

The Pencil Lines to Brush Strokes  operation converts the selected centreline pencil strokes into 
contour strokes brush lines.
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How to convert pencil lines to brush strokes

‣ From the top menu, select Drawing > Convert > Pencil Lines to Brush Strokes or press &.

‣ Right-click on the selection, select Convert > Pencil Lines to Brush Strokes or press &

Strokes to Pencil Lines 

The Strokes to Pencil Lines  operation converts the selected invisible line to a pencil line.

How to convert strokes to pencil lines

‣ From the top menu, select Drawing > Convert > Strokes to Pencil Lines or press Shift + 
F12 (Windows/Linux only).

‣ Right-click on the selection, select Convert > Strokes to Pencil Lines or press Shift + F12 
(Windows/Linux only)

Optimize

The Optimize command reduces the number of layers, such as overlapping brush strokes, in the 
selected drawing objects. Drawing objects will only be flattened and optimized if the selected objects 
do not change the appearance of the final image when they are merged. 

For example, if you have selected a number of partially transparent objects, which you layered to 
create an additive colour effect, the selected transparent drawing objects will not be merged. This is 
because merging the transparent drawing objects will cause them to lose the effect of the layered 
transparent colours. 

How to optimize

‣ Use the Select tool to select the drawing objects you want to optimize. 

‣ From the top menu, select Drawing > Optimize > Optimize.

‣ From the Camera or Drawing view menu, select Drawing > Optimize > Optimize. 
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Remove Extra Strokes

The Remove Extra Strokes option let you remove the invisible lines in your selection.

How to remove extra strokes

1. In the Tools toolbar, select the Select tool.

2. In the Camera or Drawing view, use the Select tool to select the drawing objects you want to 
remove invisible lines from. 

3. From the top menu, select Drawing > Optimize >  Remove Extra Strokes.

‣ From the Camera or Drawing view menu, select Drawing > Optimize > Remove Extra 
Strokes.

Reduce Drawing Texture Resolution 

If you import and vectorize as texture (colour) a high resolution image, the size of your drawing can be 
heavy. This option is used to reduce the size and resolution of the textures in your drawing. When you 
import and vectorize drawings using the grey or colour preset styles, you don't have control on the 
size of the bitmap texture. This tool allows you to reduce that bitmap texture.

How to reduce the drawing texture resolution

1. In the Tools toolbar, select the Select tool.

2. In the Camera or Drawing view, use the Select tool to select the drawing objects you want to 
reduce the texture resolution for.

3. From the top menu, select Drawing > Optimize > Reduce Drawing Texture Resolution.

‣ From the Camera or Drawing view menu, select Drawing > Optimize > Reduce Drawing 
Texture Resolution.

4. In the dialog box, drag the slider toward the left to reduce the texture resolution.

5. Enable the Apply to All Drawings option if you want the modification to be applied to all the 
drawings in your layer.

6. Click OK.
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Crop Brush Textures 

The Crop Brush Textures option is used to crop an unnecessarily large texture bitmap that lies unseen 
beneath the vector contour of a textured line. This often occurs when you cut and paste textured lines 
from one drawing into another. If you cut a portion from a textured line and paste it into a different 
drawing, Harmony pastes the entire unseen texture bitmap from the source drawing into the new one, 
even if you only took a small portion of the source drawing. Using the Crop Brush Texture command 
will crop away extraneous texture that does not touch the vector area. If there are many textured lines 
in your scene, this will greatly reduce the file size.

In the example shown above, a textured line is cut from a drawing and pasted into a new drawing. At 
first, it appears as if only a cropped section of the underlying texture bitmap was cut and pasted as 
well. However, using the Contour Editor tool to expand the vector envelope of the textured line, it is 
revealed that more texture bitmap exists beyond the cropped boundary. If you use the Crop Brush 
Texture command, the bitmap texture is cropped to the boundaries of the textured line’s vector 
contour (as seen in the fourth image where the vector envelope has been pulled out to reveal empty 
space).   

How to crop the brush texture

1. In the Timeline or Xsheet view, select the drawing whose texture you want to crop.

2. From the top menu, select Drawing > Optimize > Crop Brush Textures.

3. From the Camera or Drawing view menu, select Drawing > Optimize > Crop Brush Textures.
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Create Contour Stroke 

The Create Contour Stroke  option is used to add a permanent invisible line around a shape that 
was drawn directly in Harmony. This allows you to unpaint your lines with the Paint  tool but 
maintain the shape of the lines, should you need to repaint later.

This command is useful when inking and painting and using the Apply to All Drawings in Layer  
option.

How to create contour strokes

1. In the Tools toolbar, select the Select tool.

2. In the Camera or Drawing view, use the Select tool to select the drawing objects you want to 
create contour strokes for.

3. From the top menu, select Drawing  > Optimize > Create Contour Strokes.

Remove Contour Stroke 

The Remove Contour Stroke option is used to remove any permanently invisible lines that were 
created while scanning and vectorizing drawings or manually adding contour strokes. This is useful if 
you want to remove the intersection triangles created during vectorization.

How to remove contour strokes

1. In the Tools toolbar, select the Select tool.

2. In the Camera or Drawing view, use the Select tool to select the drawing objects you want to 
remove contour strokes for.

3. From the top menu, select Drawing  > Optimize > Remove Contour Strokes.
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Grid

Use the Show Grid option to display a grid in the Drawing or Camera view.

Name Button Description Keyboard Shortcut

Show 
Grid

 

Displays the grid

From the top menu, 
select View > Grid > 
Show Grid

Press Ctrl + ' 
(Windows/Linux) or 
⌘  + ' (Mac OS X).

Square Displays a standard square grid
From the top menu, 
select View > Grid > 
Square.

12 Field Grid Displays a 12-field size grid
From the top menu, 
select View > Grid > 
12 Field Grid.

16 Field Grid Displays a 16-field size grid
From the top menu, 
select View > Grid > 
16 Field Grid.

Underlay
Displays the grid under the drawing 
elements

From the top menu, select View 
> Grid > Underlay

Overlay
Displays the grid over the drawing 
elements

From the top menu, select View 
> Grid > Overlay

Group/Ungroup

Use the Group option to group selected drawing objects. This can help in the selection, repositioning, 
re-scaling and other transformations to be applied to multiple objects of a drawing. 
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• From the top menu, select Edit > Group > Group or Edit > Group > Ungroup.

• From the Camera or Drawing view menu,  select Edit > Group > Group or Edit > Group > 
Ungroup.

• Press Ctrl + G and Ctrl + Shift + G (Windows/Linux) or ⌘  + G and ⌘  + Shift + G (Mac OS X). 

Hand

Use the Hand tool to pan through the Drawing or Camera view.

• In the Tools toolbar, select the Hand  tool, click in the Drawing or Camera view and drag. 

• You can also Hold down the Spacebar, click in the Drawing or Camera view and move your 
mouse in the direction you want to pan the view.

Rotate View

The Rotate View  tool lets you rotate the Drawing or Camera view, the same way as you would do 
with a real animation disc. This tool can also be used in the Perspective view.

How to use the Rotate View tool

1. Do one of the following:

‣ From the top menu, select Drawing > Tools > Rotate View.

‣ Press Ctrl + Alt (Windows/Linux) or ⌘  + Alt (Mac OS X).

‣ In the Tools toolbar, select the Rotate View  tool.

‣ In the Drawing or Camera view, right-click and select Drawing Tools > Rotate View.

2. In the Drawing or Camera view, click and drag to rotate the space.
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Drawing Tool References

Harmony has a wide variety of drawing tools and each one of them has a series of options and modes 
available. This section covers these options. For details on how to use these tools, see Drawing Tasks 
on page 153.

• Pencil Tool Options below

• Brush Tool Options on page 224

• Select Tool Options on page 226

• Eraser Tool Options on page 236

• Contour Editor Options on page 237

• Pencil Editor Options on page 240

• Shape Tool Options on page 243

• Polyline Tool Options on page 248

• Stroke Tool Options  on page 249

• Perspective Tool Options on page 250

• Envelope Tool Options on page 251

• Cutter Tool Options on page 254

• Smooth Editor Tool Options on page 256

• Text Tool Options on page 258

• Drawing Pivot Tool on page 262

Pencil Tool Options
When you select the Pencil  tool, its properties and options appears in the Tool Properties view.
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Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the 
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to 
display advanced customization parameters,

Maximum Size and Smoothing

This is where you set the minimum and maximum sizes of your drawing tool which will produce the 
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

‣ Maximum and Minimum Size: Defines the maximum and minimum width of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line.

Adjusting the Pencil Line Style
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You can adjust the start, end, and joint  style of a selected pencil line.

• Start: Lets you select the style of the start  tip, which is the first tip you drew. You can choose 
between Round or Flat style.

• End: Lets you select the style of the end tip, which is the last tip you drew. You can choose 
between Round or Flat style.

• Join: Lets you select the joint style. The joints are where the line curves abruptly. You could 
also define the Join style as the corner style. You can choose between Round, Mitre and Bevel 
style.

Thickness Stencils

Harmony provides a variety of thickness stencils and also lets you create and save your own. It is a 
good idea to create and save pencils with precise sizes and parameters when you draw and design.

A thickness stencil saves a preset of how the thickness information looks across the length of the 
line.  When drawing with a thickness stencil, the pressure sensitivity of the tablet is discarded in order 
to apply the thickness stencil.

A thickness stencil can be used while drawing, or applied afterwards.

You also have the possibility to apply different textures to your lines by either using the preset ones 
or importing your own—see Working with Pencil Presets on page 157 and Pencil Line Texture on 
page 160.

Pencil Line Texture

You can apply a bitmap texture on your pencil line and adjust it as needed—see Pencil Line Texture 
on page 160

Draw Behind

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically  option automatically 
creates the corresponding strokes in the Colour Art layer. To access this option, you must be in the 
Advanced Art mode. 
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 Auto-Flatten Mode

When drawing on vector layers, lines do not usually become one object. The Auto-Flatten  mode 
automatically merges lines created with the existing ones into one single object as you draw. 

When drawing on a bitmap layer, you are laying down the bare pixels, so they are always flattened. 
You can no longer access the individual stroke after you draw it.

Using the Select tool, you can use the middle mouse button to select a segment of a 
flattened pencil line to create a nice finish on the lines and corners of your artwork.

Auto-Close Gap 

When using the pencil tool, you can automatically close strokes with an invisible stroke. 

It is recommended to keep this option enabled when drawing with the Pencil tool.

Line Building Mode

The Line Building  mode is very useful when drawing long lines and curves in small increments 
with pencil lines. As the pencil lines are central vector lines and it may be difficult to align the line tips 
perfectly to create a uniform stroke and close all gaps.

In this mode, you can draw lines in small increments and the tips are merge into one single stroke.
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This mode only works with pencil lines.

Auto Adjust Thickness

The Auto Adjust Thickness  tool is useful when you want to render a portion of a line thicker. 
When tracing a drawing on paper, you will often go back to a section of a curve to make it thicker to 
add dynamism to the line. Using the Auto Adjust Thickness tool, you can draw highlight strokes over 
the section to make thicker. Once you release the pen or mouse, the line becomes thicker following 
the shape and curve of the original stroke. This way is much faster and smoother than using the 
Pencil Editor tool. You do not have to add extra points and adjust the position and Bezier handles.

The default overlay colour is light yellow. If this colour is difficult to see because of the background or 
drawing colour, you can adjust the colour.

How to change the Auto Adjust Thickness Colour

1. In the Tools toolbar, select the Pencil  tool.

2. In the Tool Properties view, click the Auto Adjust Thickness  button.

3. Click the colour swatch.

The Colour Picker window opens.

4. In the Colour Picker window, select a new colour.

Line Pushing Mode

The Line Pushing Mode  option lets you draw highlight strokes over existing pencil lines. You can 
reshape the curves. Depending how you draw the pushing stroke over your line, the highlighted 
section will be reshaped in one direction or the other.
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The default overlay colour is light yellow. If this colour is difficult to see because of the background or 
drawing colour, you can adjust the colour.

To change the Line Pushing Mode colour

1. In the Tools toolbar, select the Pencil

 tool.

2. In the Tool Properties view, select the Line Pushing Mode  button.

3. Click the colour swatch.

The Colour Picker window opens.

4. In the Colour Picker window, select a new colour.

Brush Tool Options
When you select the Brush  tool, its properties and options appear in the Tool Properties view.
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Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the 
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to 
display advanced customization parameters,

Maximum Size and Smoothing

This is where you set the minimum and maximum sizes of your drawing tool which will produce the 
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

‣ Maximum and Minimum Size: Defines the maximum and minimum width of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line.

Brush Presets

Brush presets are created by saving the properties of the current brush to a new preset, which you 
can reuse for repeated tasks. You can create as many brush presets as you need—see Drawing with 
the Brush Tool on page 163. 

Draw Behind

When the Draw Behind  mode is enabled, the lines you draw will appear behind the art that 
already exists. 

Repaint Brush Mode

The Repaint Brush  is used to repaint zones that have already been painted, it will not affect 
empty zones or pencil lines. It also automatically flattens each of its brush lines so it does not add 
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new brush lines on top of existing ones. You can use this mode to paint tones or highlights onto your 
character.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically  option automatically 
creates the corresponding strokes in the Colour Art layer. To access this option, you must be in the 
Advanced Art mode. 

Auto-Flatten Mode

When enabled, the Auto-Flatten  mode automatically flattens the new lines created with the existing 
artwork as you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes 
and pencil lines will flatten with pencil lines.

Respect Protected Colour

The Respect Protected Colour  option prevent the colours you marked as protected in the 
Colour view to be repainted using the Repaint Brush mode or any of the painting tools.

Use Stored Colour Gradient

The Use Stored Colour Gradient  option makes your tool use the previously stored gradient 
position. This way, every new brush line or colour fill will use the stored gradient position.

Select Tool Options
When you choose the Select  tool, its properties and options appear in the Tool Properties view.

Lasso and Marquee

Choose between the Lasso  and Marquee  options to change the selection style of the  tool.
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• Click and hold Alt to temporarily switch from the current mode to the other.

Snap Options

You can enable different snapping modes to help you when repositioning drawings using the Select 
tool. 

•  Snap to Contour: Snaps your selection or point to any line you position it on. As soon as 
you move it close enough to another line, your point or selection will snap to it.

•  Snap and Align: Snaps the selected anchor point to any existing line while displaying 
temporary rulers as a guide that you can also snap your anchor point to.

•  Snap to Grid: Snaps your selection following the currently enabled grid. 

How to snap to grid

1. Do one of the following:

• Select View > Grid > Show Grid to display the grid in the Camera or Drawing view or press 
Ctrl + ' (Windows/Linux) or ⌘  + ' (Mac OS X).

• Select View > Grid > Square Grid, 12 Field Grid or 16 Field Grid for your current needs. 

2. In the Tools toolbar, select the Contour Editor  tool or press Alt + Q.

3. In the Contour Editor Tool Properties view, click the Snap to Grid  button.

4. In the Camera or Drawing view, click on the anchor point you want to snap following the grid, 
drag it to the desired position and release. 
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Select by Colour

The Select by Colour mode lets you select all the zones in your drawing painted with the same 
colour. 

Only the zones painted with the SAME colour swatch will be selected. If another zone is coloured with the 
exact same RGB value (same colour), but not painted with the same colour swatch, it will not be selected.

How to select areas by colour

1. In the Tools toolbar, select the Select  tool or press Alt + S.

2. In the Tool Properties view, click the Select by Colour button.

3. In the Camera view, click on any zone in your drawing.

All zones of the same colour are selected.

4. Click the Select tool again to return to the regular Select mode.

Permanent Selection

The Permanent Selection  option lets you maintain a selection over multiple drawings. Once this 
option is enabled, the selection zone made using the Select tool will remain as you navigate through 
drawings from a layer and drawings from other drawing layers. This option can be used to 
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simultaneously delete artwork inside or outside of the selection on several drawings when combined 
with the Apply to Multiple Drawings option.

Apply to All Drawings in Layer 

The Apply to All Drawings in Layer  option is used to perform an action on all the drawings 
contained in a layer. For example, you could enable the option to paint a section on all the drawings 
simultaneously. The Apply Tool to All Drawings option must be activated before performing the 
action and will stay enabled only for the next action. 

Apply to Line and Colour Art

The Apply to Line and Colour Art  option uses the concept of Line Art and Colour Art layers. Use 
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art 
layers, as well as the Overlay and Underlay layers. To access this option, you must be in the 
Advanced Art mode.

Works on Single Drawing

By default, when you draw a selection box in the Camera view, the Select tool will select only the 
drawing strokes of the current drawing. If you prefer the Select tool to select all the strokes on all 
layers, you can disable the Works on Single Drawing option in the Tool Properties view or the Select 
Tool Works on Single Drawing preference.
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Flip Horizontal and Vertical

The Flip Horizontal  and Flip Vertical  operations flip the current selection horizontally or 
vertically.

‣ From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW  and Rotate 90 Degrees CCW  operations rotate the current 
selection 90 degrees clockwise or counter-clockwise.

‣ From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 
Degrees CCW.

‣ Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or ⌘  + 7 and  ⌘  + 9 (Mac OS X).

Smooth

The Smooth  operation lets you smooth out selected drawing strokes and remove extra points.

‣ From the top menu, select Drawing> Optimize > Smooth or press Alt + Shift + S.

Flatten
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The Flatten  operation is used to merge drawing objects and brush strokes into a single layer. If 
you draw new lines to fix a drawing or line with many brush strokes, it can be useful to flatten them 
all into a single shape. By default, lines are drawn one on top of each other. If you intend to repaint 
the lines or modify their shape, it will be easier if they are flattened. 

‣ From the top menu, select Drawing > Optimize > Flatten or pres Alt + Shift + F.

Create Colour Art from Line Art

You can use the outline you traced on one of the four embedded layers and create invisible strokes 
to paint your drawings on separate layers. This provides more inking and painting flexibility. To 
access this option, you must be in the Advanced Art mode.

You can also configure the option to create the invisible strokes on any of the four embedded layers.

How to create Colour Art zones out of the Line Art content

1. In the Tools toolbar, select the Select  tool or press Alt + S.

2. In the Camera or Drawing view, select the artwork to transfer to the Colour Art.

3. In the Drawing View toolbar, click the Create Colour Art from Line Art  button or press *.

How to configure the Create Colour Art from Line Art option

1. In the Tools toolbar, select the Select  tool or press Alt + S.

2. In the Tool Properties view, Shift + click the Create Colour Art from Line Art  button.

The Configure Line Art to Colour Art dialog box opens.

Parameter Description

Use rendered version of the 
drawing

Renders the drawing and vectorize it to calculate the position of the 
centreline that will produce the colour art stroke.

Maximum Resolution for 
rendered image

The size of the rendered image.

Threshold for rendered image The value of grey processed to create the rendered vectorized arts.

Fitting error for rendered Bez-
iers

This value represents how precise the fitting of the colour art zone in 
relation to the line art will be.

Source layer Lets you select the layer (Line Art, Colour Art, Underlay or Overlay) 
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you want the colour art to be created from.

Destination layer
Lets you select the layer (Line Art, Colour Art, Underlay or Overlay) 
you want the colour art to be created on.

Clear Destination Art Layer 
First

Deletes the content before the colour art is added. This is 
useful when you already have artwork on the destination 
layer.

Perform Line Art to Colour 
Art Operation Immediately

Performs the Create Colour Art from Line Art command when you 
click OK.

Distribute to Layers

The Distribute to Layers  option is used to separate the selected art strokes and send them to 
new drawing layers. In the Camera view, once you have drawn your artwork, you can select the 
strokes you want to distribute using the Select  tool and click on the Distribute to Layers  
button; you can also select Drawing > Distribute to Layers. It will automatically take every stroke 
from the drawing selection made in the Camera view and separate them into a different layer for 
each. If an artwork is composed of several strokes, you must group them using Edit > Group > 
Group before using the Distribute to Layers option. This option cannot be done from the Drawing 
view.

Store Colour Gradient 

Use the Store Colour Gradient  operation to record the selected gradient’s position. This reuses 
the stored position of the gradient when drawing new brush lines or painting colour zones. Enable 
the Use Stored Colour Gradient  option in the Paint or Brush Tool Properties view to do this.

Pencil to Brush

The Pencil to Brush  operation converts the selected centre line pencil strokes into contour 
strokes brush lines.

From the top menu, select Drawing > Convert > Pencil Lines to Brush or press &.
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Merge Pencil Lines

 

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to align 
them and make it look like it is one single line. With the Select tool, you can select several pencil lines 
and merge them as one single object using the Merge Pencil Lines  option. The ends of your lines 
are adjusted to form one single line.

Points must be close enough to be merged. If there is a large gap between the lines, they will not be 
merged.

Reverse Pencil Thickness

The Reverse Pencil Thickness  option inverts the thick and thin section on a selected pencil line. 
This option will take the thickest size on the line and apply it to the thinnest, and it will apply the 
thinnest to the thickest.
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Width and Height

Use the Width and Height operation fields to enter specific values to resize the selected shape with 
precision.

1. Width: Type a value in this field to resize the width of your selection.

2. Height: Type a value in this field to resize the height of your selection.

3. Up/Down arrows: Use the up and down arrows to modify the value in the Width or Height fields.

4. Lock icon: Click the lock icon to lock or unlock the ratio between the Width and Height values.

Offset X and Y

Use the Offset X and Offset Y operation fields to enter specific values and precisely reposition the 
selected shape.

1. X: Type a value in this field to reposition your selection along the X-axis.

2. Y: Type a value in this field to reposition your selection along the Y-axis.

3. Up/Down arrows: Use the up and down arrows to modify the value in the X or Y value field.

Angle

The Angle operation lets you to enter specific values and accurately rotate the selected shape.

1. Angle: Type a degree value in this field to rotate your selection.

2. Up/Down arrows: Use the up and down arrows to modify the value in the Angle value field.

Adjusting the Pencil Line Thickness

Use the Adjusting the Pencil Line Thickness operation field to resize the selected centreline strokes. 
This operation is not permitted on contour line shapes, such as brush strokes or shape fills.

1. Minimum Size: Type a value in this field to set the minimum thickness of the selected centreline 
stroke.
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2. Maximum Size: Type a value in this field to set the maximum thickness of the selected centreline 
stroke.

3. Up/Down arrows: Use the up and down arrows to modify the value contained in the Thickness 
value field.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint  style of a selected pencil line.

• Start: Lets you select the style of the start  tip, which is the first tip you drew. You can choose 
between Round or Flat style.

• End: Lets you select the style of the end tip, which is the last tip you drew. You can choose 
between Round or Flat style.

• Join: Lets you select the joint style. The joints are where the line curves abruptly. You could 
also define the Join style as the corner style. You can choose between Round, Mitre and Bevel 
style.

Pencil Stencils

Toon Boom Harmony gives you the flexibility to change the style and thickness of your pencil lines 
even after they are drawn. You can apply preset pencil stencils or create your own—see Working 
with Pencil Presets on page 157.

Adding Texture to a Pencil Line

Pencil lines support texture. Once a pencil line is drawn, you can apply a preset texture or load your 
own. Textures are independent from pencil stencils—see Pencil Line Texture on page 160.

Adjusting the Text Selection

When you select text with the Select tool, the  tool properties will display the Text tool options on 
the bottom of the view. You can also press Alt + 9 to display only the Text properties in the Tool 
Properties view—see Text Tool Options on page 258.
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Eraser Tool Options
When you select the Eraser  tool, its properties and options appear in the Tool Properties view.

Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the 
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to 
display advanced customization parameters,

Maximum Size and Smoothing

This is where you set the minimum and maximum sizes of your drawing tool which will produce the 
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

‣ Maximum and Minimum Size: Defines the maximum and minimum width of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line.
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Eraser Presets

Eraser presets are created by saving the properties of the current eraser to a new preset, which you 
can reuse for repeated tasks. You can create as many eraser presets as you need—see Erasing Parts 
of a Drawing on page 192. 

The Eraser tool uses its own preset list, separated from the Brush tool. Toon Boom Harmony 
provides a variety of eraser styles and allows you to create and save your own. It is a good idea to 
create and save eraser with precise sizes and parameters to draw and design.

Eraser Blur Parameters 

Since Harmony lets you draw with textured lines and create feathered edges on them, you may also 
want to erase with smooth edges instead of the solid vector based eraser. The Eraser Blur 
Parameters allow you to adjust the smoothness of your eraser for the textured lines—see How to 
erase textured lines on page 173

Apply to Line and Colour Art

The Apply to Line and Colour Art  option uses the concept of Line Art and Colour Art layers. Use 
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art 
layers, as well as the Overlay and Underlay layers. To access this option, you must be in the 
Advanced Art mode.

Tip Style

Use the Tip Style option to customize the tip of the pencil line you are cutting.

Contour Editor Options
When you select the Contour Editor  tool, its properties and options appear in the Tool Properties 
view.

Lasso and Marquee

Choose between the Lasso  and Marquee  options to change the selection style of the  tool.

• Click and hold Alt to temporarily switch from the current mode to the other.
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Snap to Contour

The Snap to Contour  option will snap the selected anchor point to any line you position it on.

How to snap two shapes together

1. In the Tools toolbar, select the Contour Editor  tool or press Alt + Q.

2. In the Tool Properties view, click the Snap to Contour  button.

3. In the Camera or Drawing view, click on an anchor point you want to snap to the other shape, 
drag it on top of the contour line area and release it. 

 

Snap and Align

The Snap and Align  option lets you snap the selected anchor point to any existing line while 
displaying temporary rulers as a guide that you can also snap your anchor point to.

How to snap and align

1. In the Tools toolbar, select the Contour Editor  tool or press Alt + Q.

2. In the Tool Properties view, click the Snap and Align  button.

3. In the Camera or Drawing view, click on an anchor point you want to snap, drag it until a ruler is 
displayed, position it on the ruler or on the contour line and release. 
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Show Contour Editor Controls

 

Use the Show Contour Editor Controls  option to show the contour editor controls. You can use 
these controls to scale, reposition and rotate the selected anchor points.

Apply to Line and Colour Art

The Apply to Line and Colour Art  option uses the concept of Line Art and Colour Art layers. Use 
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art 
layers, as well as the Overlay and Underlay layers. To access this option, you must be in the 
Advanced Art mode.

Smooth Selection

The Smooth  operation lets you smooth out selected drawing strokes and remove extra points.

‣ From the top menu, select Drawing> Optimize > Smooth or press Alt + Shift + S.

Split Pencil Line and Join Pencil Lines

When drawing with the Polyline tool, your drawing has an even line thickness. You can use the Pencil 
Editor to adjust the thickness point by point, but if you want to adjust it quicker, you can use the 
Split Pencil Line and Point Pencil Lines options to create segments and apply a pencil stencil to your 
drawing. Note that if you did not join the pencil lines on your polyline stroke, the segments between 
the points will act as separated segments.
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How to split and join pencil lines

1. In the Tools toolbar, select the Contour Editor tool.

2. In the Drawing or Camera view, select the contour points you want to split or join.

3. In the Tool Properties view, click on the Join Pencil Lines or Separate Pencil Line buttons.

Pencil Editor Options
When you select the Pencil Editor tool, its properties and options appear in the Tool Properties view.
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Lasso and Marquee

Choose between the Lasso  and Marquee  options to change the selection style of the  tool.

• Click and hold Alt to temporarily switch from the current mode to the other.

Maximum Size and Smoothing

This is where you set the minimum and maximum sizes of your drawing tool which will produce the 
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

‣ Maximum and Minimum Size: Defines the maximum and minimum width of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint  style of a selected pencil line.
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• Start: Lets you select the style of the start  tip, which is the first tip you drew. You can choose 
between Round or Flat style.

• End: Lets you select the style of the end tip, which is the last tip you drew. You can choose 
between Round or Flat style.

• Join: Lets you select the joint style. The joints are where the line curves abruptly. You could 
also define the Join style as the corner style. You can choose between Round, Mitre and Bevel 
style.

Preset

To work with Pencil line presets, see Working with Pencil Presets on page 157.

Textures

To work with Pencil Line Texture, see Pencil Line Texture on page 160

Smooth

The Smooth  operation lets you smooth out selected drawing strokes and remove extra points.

‣ From the top menu, select Drawing> Optimize > Smooth or press Alt + Shift + S.

Pump Pencil Pressure

The Pump Pencil Pressure  option is used to increase the line thickness of a selected area on a 
pencil line.

Deflate Pencil Pressure
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The Deflate Pencil Pressure option is used to decrease the line thickness of a selected area on a 
pencil line.

Merge Pencil Lines

 

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to align 
them and make it look like it is one single line. With the Select tool, you can select several pencil lines 
and merge them as one single object using the Merge Pencil Lines  option. The ends of your lines 
are adjusted to form one single line.

Reverse Pencil Thickness

The Reverse Pencil Thickness  option inverts the thick and thin section on a selected pencil line. 
This option will take the thickest size on the line and apply it to the thinnest, and it will apply the 
thinnest to the thickest.

Shape Tool Options
When you select a shape tool (Rectangle, Ellipse, Line), its properties and options appear in the Tool 
Properties view.
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Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the 
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to 
display advanced customization parameters,

Size

Move the Size slider left to reduce the line thickness and to the right to increase its width.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint  style of a selected pencil line.
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• Start: Lets you select the style of the start  tip, which is the first tip you drew. You can choose 
between Round or Flat style.

• End: Lets you select the style of the end tip, which is the last tip you drew. You can choose 
between Round or Flat style.

• Join: Lets you select the joint style. The joints are where the line curves abruptly. You could 
also define the Join style as the corner style. You can choose between Round, Mitre and Bevel 
style.

Thickness Stencils

Toon Boom Harmony provides a variety of thickness stencils and also lets you create and save your 
own. It is a good idea to create and save pencils with precise sizes and parameters when you draw 
and design.

A thickness stencil saves a preset of how the thickness information looks across the length of the 
line.  When drawing with a thickness stencil, the pressure sensitivity of the tablet is discarded in order 
to apply the thickness stencil.

A thickness stencil can be used while drawing, or applied afterwards.

You also have the possibility to apply different textures to your lines by either using the preset ones 
or importing your own—see Working with Pencil Presets on page 157

Draw Behind

When the Draw Behind  mode is enabled, the lines you draw will appear behind the art that 
already exists. 

Snap Options

When drawing a shape, you can enable different snap modes to help you create your shape. 

• The Snap to Contour  option snaps your shape to any line you position it on. 

• The Snap and Align  option snaps the selected anchor point to any existing line, while 
displaying temporary rulers as a guide that you can also snap your anchor point to.

• The Snap to Grid  snaps your shape to the currently enabled grid. 
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Automatic Filling

Use the Automatic Filling  option to automatically fill your shape with the selected colour as you 
draw. By default, the Shape tool creates the contour of an empty shape that you can later fill using 
the Paint tool.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically  option automatically 
creates the corresponding strokes in the Colour Art layer. To access this option, you must be in the 
Advanced Art mode. 

Auto-Flatten Mode

When enabled, the Auto-Flatten  mode automatically flattens the new lines created with the existing 
artwork as you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes 
and pencil lines will flatten with pencil lines.

Using the Select tool, you can use the middle mouse button to select a segment of flattened pencil 
line. This creates a nice finish on the lines and corners of your artwork.
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Auto-Close Gap

When enabled, the Auto-Close Gap  mode automatically connects, with an invisible stroke, the 
pencil lines you draw close to each other in the Camera or Drawing view.

It is recommended to leave this option enabled when drawing with the Pencil tool.

Use Stored Colour Gradient

The Use Stored Colour Gradient  option makes your tool use the previously stored gradient 
position. This way, every new brush line or colour fill will use the stored gradient position.

Line Building Mode

The Line Building  mode is very useful when drawing long lines and curves in small increments 
with pencil lines. As the pencil lines are central vector lines and it may be difficult to align the line tips 
perfectly to create a uniform stroke and close all gaps.

In this mode, you can draw lines in small increments and the tips are merge into one single stroke.

This mode only works with pencil lines.
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Keep Proportion

When the Ellipse or Rectangle mode is enabled in the Tool Properties view, the Draw Circle or Draw 
Square option appears. When selecting these options, the shape produced will be a circle or square. 
Holding down the Shift key as you create your shape will maintain proportion. 

Polyline Tool Options
When you select the Polyline tool, its properties and options appear in the Tool Properties view.

Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the 
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to 
display advanced customization parameters,

Size

The Size parameter lets you set the size of the polyline that you will draw.
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Thickness Stencils

Harmony provides a variety of thickness stencils and also lets you create and save your own. It is a 
good idea to create and save pencils with precise sizes and parameters when you draw and design.

A thickness stencil saves a preset of how the thickness information looks across the length of the 
line.  When drawing with a thickness stencil, the pressure sensitivity of the tablet is discarded in order 
to apply the thickness stencil.

A thickness stencil can be used while drawing, or applied afterwards.

You also have the possibility to apply different textures to your lines by either using the preset ones 
or importing your own—see Working with Pencil Presets on page 157

Snap to Contour 

The Snap to Contour  option will snap your selection to any line you position it on.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically  option automatically 
creates the corresponding strokes in the Colour Art layer. To access this option, you must be in the 
Advanced Art mode. 

Auto-Flatten Mode

When enabled, the Auto-Flatten  mode automatically flattens the new lines created with the existing 
artwork as you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes 
and pencil lines will flatten with pencil lines.

Stroke Tool Options 
When you select the Stroke tool, its properties and options appears in the Tool Properties view.

Draw Stroke as Straight Lines 

Enable the Draw Stroke as Straight Lines  option if you want the new strokes you draw to be a 
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perfect straight line. Disable the option if you want the stroke to follow the mouse gesture.

Connect Line Ends 

Enable the Connect Line Ends  option if you want the start or end point of your new stroke to 
connect to your existing strokes to make sure no gaps are left in your drawing.

Auto-Flatten Mode

When enabled, the Auto-Flatten  mode automatically flattens the new lines created with the existing 
artwork as you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes 
and pencil lines will flatten with pencil lines.

Smoothness

You can modify the central line smoothness  of your line using this option. This parameter smooths 
the initial movement of your line. Increasing the value will result in a smoother line with fewer control 
points. Use the left and right arrows to increment the value by one full unit. Use the Up - Down slider 
to quickly increment the value.

Perspective Tool Options
Selecting the Perspective tool displays its properties and options in the Tool Properties view.

Lasso and Marquee

Choose between the Lasso  and Marquee  options to change the selection style of the  tool.

• Click and hold Alt to temporarily switch from the current mode to the other.

Snap Options

• The Snap to Contour  option will snap the selected anchor point to any line you position it 
on—see Contour Editor Options on page 237.

• The Snap and Align  option lets you snap the selected anchor point to any existing line 
while displaying temporary rulers as a guide that you can also snap your anchor point to—see 
Contour Editor Options on page 237.

• The Snap to Grid  option snaps your selection according to the currently enabled grid.

Apply to Line and Colour Art

The Apply to Line and Colour Art  option uses the concept of Line Art and Colour Art layers. Use 
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art 
layers, as well as the Overlay and Underlay layers. To access this option, you must be in the 
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Advanced Art mode.

Flip Horizontal and Vertical

The Flip Horizontal  and Flip Vertical  operations flip the current selection horizontally or 
vertically.

‣ From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW  and Rotate 90 Degrees CCW  operations rotate the current 
selection 90 degrees clockwise or counter-clockwise.

‣ From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 
Degrees CCW.

‣ Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or ⌘  + 7 and  ⌘  + 9 (Mac OS X).

Envelope Tool Options
Selecting the Envelope tool displays its properties and options in the Tool Properties view.
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Width and Height

Increase the width and height values to add more columns and rows to the deformation grids.

Lasso and Marquee

Choose between the Lasso  and Marquee  options to change the selection style of the  tool.

• Click and hold Alt to temporarily switch from the current mode to the other.

Snap Options

• The Snap to Contour  option will snap the selected anchor point to any line you position it 
on—see Contour Editor Options on page 237.

• The Snap and Align  option lets you snap the selected anchor point to any existing line while 
displaying temporary rulers as a guide that you can also snap your anchor point to—see 
Contour Editor Options on page 237.

• The Snap to Grid  option snaps your selection according to the currently enabled grid.

Show Advanced Controls

To display more controls,you can click on the Show Advanced Controls  button.
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Apply to Line and Colour Art

The Apply to Line and Colour Art  option uses the concept of Line Art and Colour Art layers. Use 
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art 
layers, as well as the Overlay and Underlay layers. To access this option, you must be in the 
Advanced Art mode.

Flip Horizontal and Vertical

The Flip Horizontal  and Flip Vertical  operations flip the current selection horizontally or 
vertically.

‣ From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.
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Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW  and Rotate 90 Degrees CCW  operations rotate the current 
selection 90 degrees clockwise or counter-clockwise.

‣ From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 
Degrees CCW.

‣ Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or ⌘  + 7 and  ⌘  + 9 (Mac OS X).

Smoothness

You can modify the central line smoothness  of your line using this option. This parameter smooths 
the deformed lines. Increasing the value will result in a smoother line with fewer control points. The 
more you increase the value, the less details and curves you will get. Use the left and right arrows to 
increment the value by one full unit. Use the Up - Down slider to quickly increment the value.

Cutter Tool Options
When you select the Cutter  tool, its properties and options appear in the Tool Properties view.

Lasso and Marquee

Choose between the Lasso  and Marquee  options to change the selection style of the  tool.

• Click and hold Alt to temporarily switch from the current mode to the other.

Apply to Line and Colour Art

The Apply to Line and Colour Art  option uses the concept of Line Art and Colour Art layers. Use 
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art 
layers, as well as the Overlay and Underlay layers. To access this option, you must be in the 
Advanced Art mode.

Use Mouse Gesture 

When using the Lasso  selection type, the Use Mouse Gesture  option lets you automatically 
delete any extra sections of line in your artwork by simply dragging your mouse over it. 
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For this operation to work, you lines CANNOT be flattened.

Use Mouse Gesture Breaker Mode

When using the Lasso  selection type, the Use Mouse Gesture Breaker Mode  option lets you 
draw an invisible stroke on a pencil line to cut it in two individual objects. Once a pencil line is cut with 
this option, you will be able to select the two portions independently with either the Cutter tool, 
Pencil Editor tool or Select tool.

This option only works with pencil lines.

Tip Style

Use the Tip Style option to customize the tip of the pencil line you are cutting.

Antialiasing

When drawing on a bitmap layer, lines are no longer clean vector shapes. For the edges to be 
smooth, a slight amount of antialiasing is used. When using the Cutter tool, you can cut a portion of 
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your drawing with or without antialiasing. By default, the option is enabled. If you want to cut your 
drawing using a hard edge, you can select the Antialiasing Off option.

Flip Horizontal and Vertical

The Flip Horizontal  and Flip Vertical  operations flip the current selection horizontally or 
vertically.

‣ From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW  and Rotate 90 Degrees CCW  operations rotate the current 
selection 90 degrees clockwise or counter-clockwise.

‣ From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 
Degrees CCW.

‣ Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or ⌘  + 7 and  ⌘  + 9 (Mac OS X).

Smooth Editor Tool Options
When you select the Smooth Editor tool, its properties and options appear in the Tool Properties 
view.
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Brush, Marquee and Lasso Smoothing Style 

The Smoothing Style options allow you to smooth a portion of your drawing by tracing a smoothing 
stroke over the zone to optimize or by selecting an area of the drawing with the Marquee or Lasso.

Note that by default, the Smooth Editor tool colour is yellow, it was changed to orange for screen 
grab clarity.

 

Show Control Points 

The Show Control Points  option allows you to show or hide the Bezier points around lines. 
When the Bezier points are displayed, you can see the result of your smoothing and the number of 
points left on the curve. When it is turned off, only the original artwork is displayed.

Minimum Size and Maximum Size 

This is where you set the minimum and maximum sizes of your drawing tool which will produce the 
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

This options is available while using the Brush Smoothing  style.

‣ Maximum and Minimum Size: Defines the maximum and minimum width of the stroke.

• Up/Down arrows: Use the up and down arrows to set the minimum and maximum size value.

Smoothness 

The Smoothness  impacts the strength of the smoothing result. The higher the value, the more 
points are removed and the smoother the curve. The Smoothness range is from 0 to 100; the default 
value is 20.
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Colour 

You can modify the colour of the control points displayed on the artwork while working with the 
Smooth Editor tool by double-clicking on the colour swatch.

Text Tool Options
Use the Text tool's properties to select the font type and other formatting options you want to apply 
to the text.

If you already wrote your text, you must first use the Text tool and select the text portion you want to 
format.

Font Type 

Use the Font drop-down menu to select a font. OTF fonts are supported.
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Font Style 

Use these buttons to select a style for your text:

•  Bold

•  Italic

Alignment 

Use these buttons to align the paragraph.

 Left  Centered

 Right  Justified

Font Size

Enter a size for the text.
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Kerning 

Use the kerning field to modify the spacing between letters and characters. You can select the Auto 
Kern option to set the kerning automatically based on the font’s predefined standard. A negative 
value decreases spacing between each character, creating a letter overlap and a positive value 
increases it.

Indent 

Enter a value in the Indent field to increase or decrease the indentation on the first line of your text. A 
positive value sets the first line of your paragraph farther to the right and a negative value sets it 
farther to the left.

Line Spacing 

Enter a value in the Line Spacing field to decrease or increase the space between each line of text.

Resizing the Text Box 

You can resize the text box by selecting your text box with the Text   tool and moving the anchor 
point right or left. Using the Select tool will distort and scale your text itself rather than changing the 
width and height of your text box.
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Converting Text into Separate Objects

Text contained in a text field is treated as a single drawing object. You can easily separate the text 
so each character becomes an individual drawing object that you can select and modify 
independently.

How to break a text object

1. In the Tools toolbar, click the Select  tool or press Alt + S.

2. In the Drawing or Camera view, select the text object you want to break.

3. From the top menu, select Drawing > Convert > Break ApartText Layers.

‣ From the Drawing or Camera view menu, select Drawing > Convert > Break ApartText 
Layers.

Each character is surrounded by a bounding box that you can modify; they remain text objects 
that you can edit.

4. If you want to convert your independent letter to a complete vector object that you can deform, 
use the Select tool to select the letters to convert.

5. From the top menu, select Drawing > Convert > Break Apart Text Layers to break the 
selection into a regular drawing object, with no more text attributes.

‣ From the Drawing or Camera view menu, select Drawing > Convert > Break Apart Text 
Layers to break the selection into a regular drawing object, with no more text attributes.
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Drawing Pivot Tool
The Drawing Pivot  tool lets you set the pivots on your character. You can set the drawing pivots 
on drawings and symbols.

Setting the Drawing Pivot for Symbos on All Frames

The Set the Pivot for Symbol on All Frames  option is enabled by default. When you set a drawing 
pivot on a symbol, all of its cells use the same drawing pivot. This means you do not have to set a 
drawing pivot on all frames. Once you set it, it is done.

If you prefer to set a different drawing pivot for a series of cells, you can deselect the option and set 
your pivots on each cell or cell range.

If you have already set several different pivots on your symbol's cells and selected the Set the Pivot for 
Symbol on All Frames option, once you set a new pivot on the same symbol, all of its pivots will be reset 
and will use your new pivot.

Snapping

When you drag the drawing pivot around, you can enable a snap option so that when the drawing 
pivot is released, it either snaps to the reference grid, drawing's contour, or aligns with an existing 
drawing stroke.

Reset Pivot

When you click the Reset Pivot  option, the drawing pivot of the selected drawing or symbol is 
reset to the centre of the Camera view.

Copying Pivot on Parent Symbol

When you import new extra drawings, such as hands and mouths, you can use the drawing pivot that 
was set on your drawings and report them to the symbol's cells. Use the Copy Pivot to Parent 
Symbol   command for this.

When you copy drawing pivots to the parent symbol, there is no link between the drawings' pivots and the 
symbol's pivots. If you modify the drawing pivot later, it will not link to the symbol. You would need to 
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perform the operation again. If you need to modify the symbol's pivots, you can do it directly on the 
symbol's cells.
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Chapter 7: Colour Styling and Colour Models

Once the characters, props and locations are designed, it is time for the colour styling and colour 
models creation. This is when the colours and moods are determined. The line models created during 
the design step are painted and organized as colour models for the colourists. 

Harmony has a great concept of colour palettes. Each character can have its own set of colours that is 
carried through the entire project called the master palette. If the master is modified, the colours in 
the entire project are updated simultanously. 

By doing the colour styling in Harmony, your master palette will be created at the same time, so you 
do not need to use third party software. Also you will not have to recreate the colour palette again in 
Harmony. It is possible to create this step in an external software, but it is a great time saver to do it 
directly in Harmony.

Throughout this chapter you might notice slight differences between your interface and the images used to 
demonstrate the procedure. This is because the images are taken from Harmony Stage. Draw is a subset of 
Harmony Stage.

To create the colour style and colour models, follow these steps:

• Preparation on the next page

• Working with Palettes on page 271

• Colours on page 296

• Painting the Model on page 308
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Preparation

Before painting, you need to organize the colour model scenes and bring in your references. The 
colour styling preparation is done in five steps:

• Colour Model Storage below

• Scene Creation below

• Setting Up the Workspace on the facing page

• Naming on page 268

Colour Model Storage
First, you will need to create a storage location for all your models and palettes. The best way to do 
this is to create a colour model scene. There are different possibilities available to structure your 
designs and colour model scenes. We strongly recommend that you put all of your colour models in 
the same scenes. It is important to maintain a structure for your models so they do not end up 
scattered throughout the project.

There are four main model categories:

If you have a small project, such as a short or an advertising contract, you can always place all the 
characters, props, effects, and locations in the same scene. For large projects such as feature-length 
productions or series, you should create four separate model scenes following these categories.

Scene Creation
In order to create colour models, you need to create your scenes.

When working on a paperless or cut-out animation project, if you have designed your characters, 
props, effects and locations directly in Harmony, you can paint your models directly in your design 
scene. You can also create a new colour model scene and import your  designs in that one. Refer to the 
Fundamentals Guide to learn more about creating a scene.
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If you have not already done so, refer to the Fundamentals Guide to learn about production structure, 
file organization, and how to create a Project root directory. We recommend storing your  colour 
model scenes in the root directory or in a colour models subdirectory for even better organization.

A useful way to name your colour model scene is to include the project name, then the colour model 
type such as characters, props, effects, or locations, and finally colourmodel. For example, a 
character colour model scene for the Adventure project would be named adventure_characters_
colourmodel. This ensures that you always know what scene corresponds to what.

To learn how to create environment, job, and scene for your colour models, refer to the Control 
Center and Server Guide.

Colour Model Scene Structure

To store your colour models in a scene, it is recommended that you create one drawing layer for each 
character, prop, effect, or location. You should name these according to the model.

You can also load other colour references in the scene to balance your overall colours. For example, if 
you work in a character colour model scene, it is a good idea to import some of the key locations to 
compare and adjust the colours so they match well.

Setting Up the Workspace
Now that your scenes are created and structured, you can open the corresponding colour model 
scene. For the optimal workspace for inking and painting, set up your workspace with these views:
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• Xsheet

• Camera 

• Drawing

• Colour

• Model

 

Naming
Now that your models are imported, you can rename them appropriately. You should rename 
elements (layers) and drawings corresponding to the model. This will help keep the work organized 
and make it easy for others to follow.

For example, if there is a black and white character model called Erik in one drawing element and its 
colour models in another one, rename your elements to include the character's name. For example, 
the colour model for Erik's armour could be named: erik_armour_colour.
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How to rename a drawing element

1. Do one of the following:

‣ In the Xsheet view, double-click on the column header of the drawing element.

‣ In the Timeline view, double-click on the drawing element's layer.

The Layer Properties window opens.

2. Type in a new name.
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How to rename a drawing

1. In the Xsheet view, click on a drawing name.

2. Do one of the following:

‣ From the Xsheet menu, select Drawings > Rename Drawing.

‣ Right-click on the drawing name and select Drawings >Rename Drawing.

‣ Press Ctrl + D (Windows/Linux) or ⌘  + D (Mac OS X).

The Rename Drawing dialog box opens.

3. Type in a new name and click OK.
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Working with Palettes

In animation, specific colours are used to paint each particular character. In order to maintain absolute 
consistency, a colour palette is created for each character, prop and effect throughout the production. 
These are referred to as master palette1s.

Master palettes contain a colour swatch for each zone to colour with a precise RGBA colour value.

Using a master colour palette has many benefits, including:

• Each character consistently retains their dedicated colours.

• You cannot accidentally use a colour which is not in the master palette.

• Standardization and colour consistency throughout the production

• Multiple artists can use the same colour palette and produce the same results.

Toon Boom Harmony uses palettes to hold all the colours needed to paint your elements, allowing 
complete control and consistency in your painting process. 

A palette2 is created by assigning a set of colours to each character, prop or effect. You will create a 
new palette and add a new colour, known as a colour swatch, for each zone of the character, such as 
the skin, hair, tongue, shirt, pants, and so on.

In Harmony, palettes are individual files that you can copy, transfer, and store. Palettes have a  *.plt 
file name extension—see Palette File Storage  on page 275. 

When a zone on the character is painted with the colour contained in a colour swatch, a link is 
automatically created between that colour swatch and the zone. This means that if the tint of the 
colour in the colour swatch is changed, any zone linked to it will update to the new tint. This is one way 
that colour palettes can save time and money in your production. 

Another advantage of this system is that you can create complete palettes for different lighting 
situations. For instance, in addition to the regular palette for a character, you could have one for that 
character in the rain using colours that are duller and less vibrant than the dry daytime colours, or yet 
another for using in a night scene. Using palettes linked to your character in this way allows you to 
instantly change its colouring to suit the mood and atmosphere of the scene without tediously 
repainting each element.

1A master palette is a group of colours attributed to a character or a prop. The palette is used throughout the 
entire production to maintain consistency in the look and to ensure that the same colours are used throughout 
the production. Also known as palette.
2A palette or master palette is a group of colours attributed to a character or a prop. The palette is used 
throughout the entire Toon Boom Studio project to maintain a consistency in the look and avoid the colour 
changing during the animation. Also referred to as a master palette.
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This section is divided as follows:

• Palette Lists below

• Palette File Storage  on page 275

• Creating a Colour Palette  on page 278

• Duplicating a Colour Palette  on page 282

• Cloning a Colour Palette  on page 284

• Palette Operations on page 286

• Importing and Linking Palettes on page 290

Palette Lists
The Colour view has two modes: basic and advanced.
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• Basic Mode

The Colour view’s basic mode only shows the Colour list. When you open Toon Boom Harmony, 
you only see the colours available in the Default palette which contains six basic colour swatches 
and is automatically named the same as your scene. For simple projects, you can manage with the 
default palette, but for movies, series, or shorts it is recommended that you create palettes for 
your characters. To create a palette, you have to switch to the Advanced mode of the Colour view 
and show the Palette list.

• Advanced Mode

The Advanced mode displays the list of all palettes that are linked to the scene. To create palettes 
for your characters, you must display the Palette list.

A palette list is a file containing all of the links to the original palette files. Every drawing layer has a 
palette list. The scene also has a palette list.  For example, a drawing layer can use three different 
palettes stored in three different locations, while another drawing layer can use two of these palettes 
plus another one coming from another scene. The palette list keep track of the locations of the 
palettes.

There are two types of palette lists:

• Scene Palette List 

The Scene Palette list is mainly used with cut-out animation, but is also very useful for paperless 
and traditional animations. A cut-out character will often be divided into 20 to 30 different drawing 
elements that use the character’s master palette.

The palette list is stored at the scene level instead of the Element directory. This way, all palettes 
linked to this list will appear in every drawing element created in the scene. There is no need to 
manually load the palette in each element.

The Scene Palette list is the simplest one to use. By default, Toon Boom Harmony is set to use only 
Scene Palette lists.

• Element Palette List

In Toon Boom Harmony, you can switch to Advanced Palette List mode and choose to save your 
palette at an element’s level. The Element Palette list is mainly used with traditional and paperless 
animation. Unlike cut-out animation, all columns (drawing elements) contain different characters, 
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props, backgrounds, and effects. The Element Palette list is used when you do not necessarily 
want all of the palettes for all of your elements linked in every column. 

The palette list is stored in the drawing element’s directory instead of directly in the Scene level. 
This ensures that the links to the palettes appear only in the appropriate element. If you prefer to 
access a global palette list, link your palettes to the Scene Palette list.

To prevent users from accidentally removing a link to a palette, the palette lists are locked. To link or 
create a new palette, the palette list must first be unlocked. 

When you are using several cloned palettes that are related to the same original palette, Toon Boom 
Harmony uses the highest palette in the list to determine the colour of the painted zones—see Cloning 
a Colour Palette  on page 284.

How to show or hide the Palette list

‣ In the Colour view, click the Show/Hide Palette List View  button to expand or collapse 
the Palette List area.

The Palette List window opens and displays all your palettes.
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How to lock and unlock to the palette list

‣ From the top menu, select Edit > Edit Palette List Mode. 

A grey pencil appears on the top-right corner of the Palette list to indicate that it can be modified.

 

How to set the Advanced Palette Lists mode

1. Do one of the following:

‣ From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences 
(Mac OS X).

‣ Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

2. Select the Advanced tab.

3. Select  the Advanced Palette Lists option.

4. Click OK.

How to reorder palettes in the Palette list

Do one of the following:

‣ From the Colour View menu, select Palettes > Move Up or Move Down. 

‣ In the Palette list, click the Up  and Down  buttons.

Palette File Storage 
In Harmony, palettes are individual *.plt files that can be copied, transferred and stored. When a 
palette is created from Harmony, it needs to be stored somewhere. By default, the palette file is 
stored in the scene directory in a palette-library folder unless you specify a different location. There are 
four locations where you can find palette-library folders:
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• Element

The Palette Library folder is stored directly in the drawing Element folder.

• Scene

The Palette Library folder is stored directly in the Scene folder.

• Job

The Palette Library folder is stored in a Job folder contained in the Scene folder.

• Environment

The Palette Library folder is stored in an Environment folder contained in the Scene folder.

By default, the palette is stored at the scene level. For simple projects and standalone projects, it is 
recommended to keep it as is. If you work with a larger studio, it is recommended to verify with them 
on the file structure.

This existing structure is compatible with Toon Boom Harmony Server. Toon Boom Harmony’s 
database has a leveled structure starting from the Environment down to the Element. Its client-server 
configuration allows all data, such as palettes and scenes, to be shared between a series of client 
machines.

Element Level 

Working with Harmony as a stand alone, the Element level is very useful when there are a lot of 
different palettes. When a colour model drawing is created, it is stored in its element folder. By 
storing the corresponding palette file with the colour model, the colourist can load them both from 
the same location. This also creates a more organized structure.

Scene Level 

Working with Toon Boom Harmony as a stand alone, a palette file can also be saved at the scene level, 
so that all of the palettes from the scene are stored together. The palette naming must be structured 
so the colourist or character builders can find the correct one. Saving the palettes at the scene level 
makes it very easy to back up the palettes and retrieve their location.
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The scene level can also be useful for cut-out animation. Instead of creating a colour model scene that 
includes all of the characters, props, effects, and location, the colour palette or model will often be 
directly imported to, or created in, the character building scene. Just as with a cut-out character 
building scene, each element uses the same palette so it would not be efficient to save the palette 
inside one element. Instead, it is saved at the scene level. This prevents a palette overload because all 
of the models are in different scenes. It also allows each scene to have its own set of palettes 
corresponding to its model.

When working on a cut-out animation production, it is highly recommended that you work with the 
Scene level.

Where to Save the Palette File
The palette storage location depends on the type of production and the backup plan being used. 
Some studios like to store their palettes at the Element level and others at the Environment level as 
this will not create a problem so long as the scene is in the Harmony structure. In fact, as long as the 
Harmony structure is maintained it can be stored at any level. However, difficulties may occur when the 
scene is backed up or transferred to another studio or database and removed from the structure.

What happens when you export a palette file?
It is important to understand what is happening to a palette file when the scene is exported.

Because of the Harmony client-server configuration, all of the data can be shared through all of the 
scenes in the database. This also includes the palette files, even if they are stored at the Element, 
Scene, Job, Drawing or Environment level. The palette files can be accessed from any scene of any 
project.

When you export scenes from Harmony to either archive or send them to other users or studios, the 
palettes stored in external scenes, jobs or environment will NOT be exported.

An exported scene will carry palettes stored in its own Element’s Palette Library, scene’s palette 
library, the Job and the Environment where it is stored. Any other palette from other Environments, 
Jobs, Elements or Scenes (even from the same job) will NOT follow. Instead a recovery palette will be 
created when the scene is reopened in another Harmony system. A recovery palette is a local palette 
created by the system when palettes and colours are missing. This palette is no longer shared with the 
rest of the project.

For example, in the following chart, if you export Scene 2 from Job 1, the package will carry the 
palettes from Scene 2, Job 1 and Environment. It WILL NOT carry the palettes from Element 3 in 
Scene 1, Scene 1 and Job 2. If Scene 2 was linked to any of these, the system will create a recovery 
palette the next time Scene 2 is opened in another Harmony system.
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The best place to store your palette is:

• Environment level for a movie or series

• Job level for a publicity or small project

• Scene level for a student exercise

To store your palette with their colour models, you can use the Element level, however, it will require 
more structure when exporting the scenes. The scene will have to be exported along with its colour 
model scene. The other studio you are working with must recreate an identical structure to yours, then 
import the received scenes into the same location as you have them in order to maintain the links.

Palette Backup
When sharing palettes between scenes, some users may accidentally modify the colours, even though 
the palettes are locked by default. That is why it is a good idea to copy and back up your palette 
libraries and master palette directories.

When a palette file is copied, it automatically becomes a clone palette, so there will not be any trouble 
replacing an altered file. Harmony automatically updates all of the files and drawings linked to it.

Creating a Colour Palette 
You can create a palette in either Basic or Advanced mode.
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By default, Toon Boom Harmony is set to the Basic mode. For simple productions, it is recommended 
to use the Basic mode.  This setting stores the palettes automatically for you and saves them at the 
Scene level. When you use the Advanced Palette Lists mode, you can decide at which level you want to 
store your palettes: Environment, Job, Scene, or Element.

If you are using Harmony Network, see Palette File Storage  on page 275.

Before you can create a palette in the Advanced Palette Lists mode, you must first set your 
preferences to Advanced Palette Lists mode in the Preferences dialog box. You also need to have the 
rights to modify the palette list. If you do not, select Edit > Edit Palette List Mode from the top menu.

You can remove palettes from your Palette list if they are not needed in your scene. The actual palette 
file will not be deleted and you can reimport it in your Palette list later on.

How to set the Advanced Palette Lists mode

1. Do one of the following:

‣ From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences 
(Mac OS X).

‣ Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

2. Select the Advanced tab.

3. Select  the Advanced Palette Lists option.

4. Click OK.

How to create a new palette (Basic Palette Lists mode)

1. From the Colour View menu, select Palettes > New or click the New Palette button.

‣ Make sure that you have the necessary rights to modify the palette list. If you do not, select  
Edit > Edit Palette List Mode.

The Create Palette window opens.

2. Enter the palette name according to the model. 

3. Click OK.

The palette appears in the drawing element’s palette list.
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How to create a palette from the Advanced Palette Lists mode

1. In the Timeline or Xsheet view, select the drawing that requires a palette. 

2. Make sure that you have the necessary rights to modify the palette list. If you do not, select  Edit > 
Edit Palette List Mode.

3. In the Colour view, click the Show Palette List View  button to display the palette list. 

4. Do one of the following:

‣ From the Colour view menu, select Palettes > New. 

‣ Click the Create Palette  button. 

The Palette Browser: Create Palette dialog box opens. 

5. Select the level to store the palette file. 

‣ Environment: The palette-library folder is stored in the scene's parent environment folder.

‣ Job: The  palette-library folder is stored in the scene's parent job folder. 

‣ Scene: The  palette-library folder is stored directly in the scene folder. 

‣ Element: The  palette-library folder is stored directly in the drawing element folder. 

When you select a level that has a palette stored in it, the palette names are displayed in the 
Palette field.
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6. Name the palette. There is no need to add the suffix "palette"  to the name as it is always 
recognized as a palette file.

 

7. Select a Palette List option.

 

‣ The Scene Palette List is mainly used with cut-out animation. A cut-out character will often 
be divided in twenty to thirty different drawing elements that use the character's master 
palette. 

The palette list is stored at the scene level instead of the Element directory. This way, all 
palettes linked to this list will appear in every drawing element created in the scene. There is no 
need to manually load the palette in each element. 

‣ The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-
out animation, all columns (drawing elements) contain different characters, props, 
backgrounds and effects. The Element Palette List is used because you do not necessarily 
want all of the palettes for all of your elements linked in every column. 

The palette list is stored in the drawing element's directory instead of directly in the Scene level. 
This ensures that the links to the palettes appear only in the appropriate element. If you prefer 
to access a global palette list, link your palettes to the Scene Palette List.

8. Click OK. 

The new palette appears in the palette list.

How to rename a palette

1. In the Colour view, select the palette to rename.
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2. Do one of the following:

‣ Right-click and select Rename.

‣ From the Colour View menu, select Palettes > Rename.

3. In the Rename dialog box, give the palette a new name and click OK.

How to remove a palette

1. In the Colour view, select the palette to remove.

2. Do one of the following:

‣ From the Colour View menu, select Palettes > Remove. 

‣ Right-click on the selected palette and select Remove.

‣ Click the Remove Palette button located above the Palette list.

If the palette was used in your scene, the zones painted with its colours turn red.

Duplicating a Colour Palette 
A duplicated palette is a simple copy of the original palette. It uses the same names, colour values, but 
has a different ID and is independent from the original palette. This ensures that both palettes are 
completely independent.

This option is used when there are similar models and you want to avoid recreating and naming all of 
the colours. You can change the values and the names afterward without affecting the original palette. 
You can also keep some RGBA values, such as the eyes, teeth, tongue, inside mouth, etc.
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How to duplicate a palette 

1. In the Colour view, select the palette to be duplicated.

2. Do one of the following:

‣ From the Colour View menu, select Palettes > Duplicate. 

‣ Right-click on the selected palette and select Duplicate.

The Palette Browser: Duplicate Palette window opens.

3. If you are in Advanced Palette List mode, select the palette storage level—see Palette File Storage  
on page 275.

4. In the New Palette Name field, name the palette.

5. In the New Palette Name field, name the palette.

6. Click OK.

The palette appears in the palette list.
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Cloning a Colour Palette 

A character usually has only one master palette, although there are times when the characters are 
placed in different lighting conditions and require a different colour shading. The night palette is a 
popular choice when a scene or sequence changes from day to night. It can be difficult and time-
consuming to repaint everything and creating two independent palettes can be quite complex. As an 
alternative, Toon Boom Harmony provides clone palettes.

The clone palette is a copy of the master palette. The colours in each palette have the same 
properties. The colours have the same identification number pointing to the same colour zones, but 
they can have different names and RGBA values. Depending on the activated palette (night or day), the 
painted drawing will update. So there is no need to repaint the animation, but to create or import a 
clone palette (palette style).

How to clone a palette

1. In the Colour view, select a palette to clone.

2. From the Colour View  menu, select Palettes > Clone or right-click and select Clone.

The Palette Browser: Clone Palette dialog box opens.
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3. If you are in Advanced Palette List mode, select the palette storage level—see Palette File Storage  
on page 275.

4. In the New Palette Name field, name the palette. It is recommended that you keep the "-clone" in 
the name.

5. Click OK.

The cloned palette appears in the palette list.

6. In the Palette list, select the clone palette you created to offset or blend colours—see Mixing 
Colours on page 305.

7. From the Colour View  menu, select Palettes> Tint Panel or right-click and select Tint Panel.

The Blend/Offset Tint panel opens.
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8. Select one or more colours to modify. You can select all your colours by pressing Ctrl + A 
(Windows/Linux) or ⌘  + A (Mac OS X).

9. Offset, blend, or mix the colours using the sliders and increasing the Amount value.

10. Select the Preview option to see a preview of the colours while you adjust them.

You can also modify the colours individually with the Colour Picker window.

Palette Operations

When you start Toon Boom Harmony connected to the database, you can access the Palette 
Operations dialog box which lets you clone, rename, or delete palettes. 

How to open the Palette Operations dialog box

1. Start Harmony Draw and log in. 

2. Close the Database Selector dialog box. 

3. From the top menu, select Tools > Palette Operations. 
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The Palette Operations dialog box opens. 

How to clone a palette in the Palette Operations dialog box 

1. Select the palette you want to clone at the location and level in which it was stored. 

2. Click Clone. 

A Warning dialog box opens. 

 

3. Select the Don't show this message again option if you do not want to see this message every 
time you perform this operation.

4. Click Yes.
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The Palette Browser dialog box opens. 

5. Select the level to store the palette file.

6. Name the palette. There is no need to add the suffix "palette"  to the name as it is always 
recognized as a palette file.

 

7. Select a Palette List option.

 

‣ The Scene Palette List is mainly used with cut-out animation. A cut-out character will often 
be divided in twenty to thirty different drawing elements that use the character's master 
palette. 

The palette list is stored at the scene level instead of the Element directory. This way, all 
palettes linked to this list will appear in every drawing element created in the scene. There is no 
need to manually load the palette in each element. 

‣ The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-
out animation, all columns (drawing elements) contain different characters, props, 
backgrounds and effects. The Element Palette List is used because you do not necessarily 
want all of the palettes for all of your elements linked in every column. 

The palette list is stored in the drawing element's directory instead of directly in the Scene level. 
This ensures that the links to the palettes appear only in the appropriate element. If you prefer 
to access a global palette list, link your palettes to the Scene Palette List.

8. Click OK.

How to rename a palette in the Palette Operation dialog box

1. Select the palette you want to rename at the location and level in which it was stored. 
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2. Click Rename.

A Warning dialog box opens. 

3. Select the Don't show this message again option if you do not want to see this message every 
time you perform this operation.

4. Click Yes.

The Rename Palette dialog box opens. 

 

5. Type in a name for the palette. 

6. Click OK. 

How to delete a palette in the Palette Operation dialog box

1. Select the palette you want to delete at the location and level in which it was stored. 
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2. Click Delete. 

A Warning dialog box opens. 

 

3. Select the Don't show this message again option if you do not want to see this message every 
time you perform this operation.

It is not recommended to disable the warning message as deleting a palette cannot be undone. 

4. Click Yes.

Importing and Linking Palettes
Before starting colouring work such as Ink and Paint or even creating new colour models, you may 
want to load existing colour palettes to your scene. You can do so by linking colour palettes to your 
palette lists.

You may encounter a case where only a colour palette is visible when a layer is selected. If you need 
that palette in a second layer, you can link the palette to the second layer's palette list, A good 
example would be a scene where there is a character on one layer and its arm is on another. In order 
for both layers to access the palette, you must link both Element Palette lists to that palette. If you 
palette is linked to the Scene Palette list, it will be accessible by all layers.
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If you created a palette in another project and you want to import it in your current project, you can 
browse for the palette file  on your computer and add it to your scene. When the palette is imported in 
your scene, the file is copied in the project’s directory. It is not linked to the original file.

Harmony lets you link an external palette to your scene without copying it in your project. This method 
is not recommended. It is always safer to have the palettes contained within the database to avoid 
data loss if the source palette were to be deleted or the project exported without including the 
external palettes.

You will notice that when you create or link a palette, a small icon appears on its left. These icons 
represent the palette linkage status.

Icon Description

Indicates that the palette is safe.

There won’t be any trouble once the scene will be exported. For example, 
the palette file is stored in the scene folder and is linked to the Scene Palette 
List. 

Indicates that the palette file is stored in a directory external to the scene’s 
structure.

The palette file is probably stored in a Master Palette directory on a hard 
drive external to the palette-libraries planned for the palette storage. The 
warning in this case is that if you move your Master Palette directory to 
another location, you may loose the palette in your scene.

Indicates that a palette file stored in a level such as Element, Scene, Job or 
Environment is linked to a Palette list that is not on the same level. 

For example, a palette file is stored into the Environment folder and is linked 
to the Element Palette list. The palette is shared.

How to link a colour palette

1. Do one of the following:

‣ From the Colour View menu, select Palettes > Link. 

‣ Right-click and select Link.

‣ Click the Import  button.

The Palette Browser: Link Palette dialog box opens.
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2. Select the level where the palette file is stored—see Palette File Storage  on page 275.

3. Select the palette list linking level by enabling either Scene Palette List or Element Palette List—
see Palette Lists on page 272.

The palette appears in the Colour view.

How to import a palette into your project

4. Do one of the following:

‣ From the Colour View menu, select Palettes > Import. 

‣ Right-click and select Import.

The Browser window opens.

5. Browse for a palette file located (*.plt) on your hard drive. You will generally find the palettes in 
your project's palette-library directory.

6. Click Open.

The Palette Browser opens.
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7. If you are in Advanced Palette mode, select the level where the palette file is stored—see Palette 
File Storage  on page 275.

8. If you are in Advanced Palette mode, select the palette list linking level by enabling either Scene 
Palette List or Element Palette List—see Palette Lists on page 272.

9. In the New Palette Name, name the imported palette.

The palette appears in the Colour view and the file is copied in your project.

How to link to an external palette

1. In the Colour view, click on the Create Palette  button to create your palette to be used as 
external.

2. Save your scene by selecting File > Save from the top menu or by clicking the Save   button or 
press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X).

3. On your computer or server, create a master directory. Ideally, this should be created in your Root 
folder to keep it within the project directory. You could also place it inside your Colour Model’s 
subdirectory. Refer to the Fundamentals Guide to learn more about project organization.

4. Name the folder appropriately, for example: Joe_master_palette.

5. From your operating system, browse to your Toon Boom Harmony scene and open the palette-
library folder.
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6. Select and copy your palette *.plt file to copy it to the master palette directory.

7. Create a new Toon Boom Harmony scene or open the scene where you will link this palette. 

8. In the Timeline or Xsheet view, select the element to link the palette to.

9. From the Colour View menu, select Palettes > Link to External.

The Link to External Palette dialog box opens.

10. Click Browse to search for your master palettes folder and select the palette *.plt file you want 
to link.

11. In the Palette list section, select how you want to load the palette; at the scene or element level.

12. Click OK.

The linked palette appears in the Colour view.

If a palette is outside the scene, the External  icon appears beside the palette name. 
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To link an element (such as a colour model) to the palette that is stored in the external palette directory, 
you must remove the original palette from the element’s palette list. You will then load the duplicated 
palette into the palette list using the Link to External command, like you did for the other elements. 
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Colours

Toon Boom Harmony has some very powerful colouring features when it comes to painting. To paint 
your drawings, you will use different colour swatches, unlike some other painting programs where you 
modify the main swatch each time you want to paint with a different colour. 

In the Colour view, you choose a different colour swatch for each colour you want to paint in your 
drawing. You can add as many swatches as you want. You can also rename them and modify existing 
ones.

When you modify the colour of an existing swatch, it automatically updates all the zones painted with 
this swatch throughout the entire project. The colour swatch has a unique ID number that associates it 
with the painted zones. This way, you can change the look of your character at any time without having 
to repaint it!

This section is divided as follows:
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• Adding a Colour Swatch  below

• Colour Display Modes  on page 303

• Copying and Pasting Colours  on page 304

• Mixing Colours on page 305

Adding a Colour Swatch 
You can use several different types of colour swatches.

A colour palette is an actual file that is on the hard drive. These palette files can be stored in a different 
location on the server. They can be stored in the Environment, Job, Scene, or Element folder and 
linked to any palette list. This means that if the original palette file is modified, it will update in every 
drawing element the palette is linked to. 

To avoid accidentally modifying the palette, the palette files can be locked. If a palette must be 
modified, you must get the rights to modify them before doing so.s

In Toon Boom Harmony, when you click on the Add Colour  button, a new colour swatch is created 
using the colour of the currently selected swatch from your palette. However, you can set a default 
colour to be used every time you create a new colour in your colour palette. This might be useful if you 
want to create different shades of the same basic colour.

The default colour is also the colour used when you choose to vectorize images that you are scanning 
into your scene, however you add the Default colour swatch to your palette in a different way, so that 
it is unique. It has a unique ID number that makes it recognizable from all the other colours in your 
colour palettes. Being able to change this colour allows you to change the basic colour of all scanned 
drawings. This can be useful on more than just an aesthetic level as sometimes when you go to NTSC 
or PAL, pure colours, such as pure black, can create problems.

How to lock or unlock the palette list 

‣ In the Colour view, click the Edit Palette Mode  button. 
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A grey pencil icon appears in the top-right corner of the Palette list.

How to add or modify a solid colour swatch

1. In the Colour view, click the New Colour  button.

2. From the Colour View menu, select Colours > Edit or double-click on the colour swatch.

The Colour Picker window opens. 

3. To set your colour, do one of the following:

‣ In the colour wheel, select a colour.

‣ Enter the HSV or RGB values in the corresponding fields. Select the R,G,B,H,S or V options 
to change the look of the colour picking area.

‣ Click the Dropper  button to select any colour on your screen. It can be from the Toon 
Boom Harmony interface, your operating system or any other open application. 
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You can also click Multi Wheel Mode to open the Multiwheel Colour dialog box. This displays all 
the picking area styles together and also contains a picking undo list. To return to the regular 
Colour Picker window, click Single Wheel Mode.

4. Click on the Shade Scale swatches to modify the shade of the selected colour. 

5. Adjust the desired level of transparency with the Alpha slider, or type the value directly in the Alpha 
field.
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6. Click the Add button to add the current selected colour to the Colour Storage Library, so you can 
quickly access it later.

7. You can rename the colour swatch in the Colour Picker window or directly in the colour list by 
double-clicking on its name.

How to change the default swatch colour for all your colour palettes

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS 
X).

2. In the Preferences dialog box, select the Drawing tab.

3. In the New Colour Pots section, select the Create New Colour Pot Using the Default Colour 
option. You can also click on the colour swatch beside the option to change the Default colour.

How to add a new colour swatch using the default colour

‣ From the Colour View menu, select Colours > New. 

A new swatch is added to your palette using the default colour swatch colour. The new swatch 
created with the New  command will be named New 0.

How to create a gradient colour swatch

1. In the Colour view, select a colour to modify .

2. Do one of the following:

‣ Click the new colour and from the Colour View  menu, select Colours > New. 

‣ Double-click on the colour swatch.

The Colour Picker window opens.
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3. Select the Gradient option.

4. Select the Linear or Radial option.

5. Adjust the Gradient arrows to modify the colours.

‣ Add extra colours by clicking between the arrows below the gradient bar. Then click on the 
Colour Preview to select a colour.

‣ Pull down the arrows to remove them.

‣ Move the arrows left and right to modify the gradient distance.

Refer to the Editing Gradients and Textures  on page 535 topic to learn how to reposition the gradient 
zones in your drawings.

How to create a texture colour

1. From the Colour View  menu, select Colours > New Texture or click the New Texture  button.

The Browser window opens.

2. Browse for a PSD or TGA bitmap file created with a third party software and click Open.

The texture is added to the colour list.
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Refer to the Editing Gradients and Textures  on page 535 topic to learn how to reposition your textured 
zones in your drawings.

You can also replace a texture once it is painted. If you decide to make the character’s shirt wool 
instead of plaid, just update the texture file in the swatch and the entire project updates. Any 
transformation previously applied to the texture’s position in your drawings will be kept.

How to replace a texture swatch

1. In the Colour view, select the texture swatch that contains the bitmap texture you want to replace.

2. From the Colour View  menu, select Colours > Edit Texture or double-click on the swatch.

The Browser window opens.

3. Browse for the new PSD or TGA bitmap file created in a third party software.

4. Click Open to update the colour swatch.
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How to delete a colour swatch

1. In the Colour view, select the colour swatches to delete.

2. Do one of the following:

‣ From the Colour View menu, select Colours > Delete.

‣ Click the Delete Colour  button. 

‣ Right-click and select Delete.

‣ Press Delete.

If the colour swatch is used in a drawing, the Delete Colour dialog box opens.

3. Click OK to delete the colours or click Cancel to abort the operation.

‣ If you delete colour swatches already in use, the zones painted with them turn red so you 
can easily identify them.

Colour Display Modes 
The Colour view has two display modes:

• List

• Swatch

You can alsodisplay the RGB values and names of your solid colour swatches instead of only the name. 
This option is not available when displaying the colours in Swatch mode.
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How to switch between the display modes

1. From the Colour View menu, and do one of the following: 

‣ Select Colours > Swatch Mode to display the swatches.

‣ Deselect Colours > Swatch Mode to display the colour list.

How to display the swatch colour values

‣ From the Colour View menu, select Palettes > Display Colour Values.   

The solid colour swatches’ RGB values will be displayed between the colour swatch and its name. 
The gradient colour swatches will be identified as (gradient).

Copying and Pasting Colours 
When you are creating palettes, you may want to copy colour swatches or their values and paste them 
in other palettes to save time. You can also quickly copy a colour value from a palette in your scene to 
a selected colour swatch in a different palette.

You can copy a selected colour swatch and paste it as a clone. Since it produces a clone colour swatch, 
it is impossible to use the Paste as Clone command in the same palette as you copied the original 
colour swatch from.

If you would like to keep a reference file of some colour IDs or use them with custom plug-ins, you can 
copy the colour swatch IDs. Here is an example of colour ID: 075cf5b552401130.
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How to copy and paste colours

1. In the Colour view, select one or more colours to copy.

‣ In the Colour view, click the Edit Palette Mode  button to be able to edit the colour list. 

2. In the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘  + C (Mac 
OS X).

3. In the Palette list, select the palette in which you want to paste the colours.

4. From the Colour View menu, select Colours > Paste as New Colours or press Ctrl + V 
(Windows/Linux) or ⌘  + V (Mac OS X).

‣ To paste the colour values of the copied swatch over an existing colour swatch, select 
Colours > Paste Colour Values.

How to clone a colour swatch

1. In the Colour view, select the colour swatch you want to clone.

‣ In the Colour view, click the Edit Palette Mode  button to be able to edit the colour list. 

2. From the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘  + C 
(Mac OS X).

3. In the Colour view, select the colour palette you want to paste the clone into or create a new 
palette.

4. From the Colour View menu, select Colours > Paste as Clone.

The cloned colour swatch appears in the palette.

How to copy a colour ID

1. In the Colour view, select the colour swatch you want toget the ID from.

‣ In the Colour view, click the Edit Palette Mode  button to be able to edit the colour list. 

2. From the Colour View menu, select Colours > Copy Colour ID or press Ctrl + C (Windows/Linux) 
or ⌘  + C (Mac OS X).

3. Paste the copied value as plain text in the desired document.

Mixing Colours
If you want to modify a series of colours at once to blend a tint in them or offset their RGBA values, you 
can use the Tint panel. This panel is quite useful when creating palette styles such as night and day 
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styles.

How to mix colours

1. In the Colour view, select the palette that contains the colours you want to offset or blend.

2. Do one of the following:

‣ From the Colour View menu, select Palettes > Tint Panel. 

‣ Right-click and select Tint Panel.

The Blend/Offset Tint panel opens.

3. Select one or more colours to modify in the colour list. To select all the colours, press Ctrl + A 
(Windows/Linux) or ⌘  + A (Mac OS X).

4. Select Preview option.

5. Select the Offset, Blend, or Mix option.
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Parameter Description

Offset

Offsets the selected colours by the adjustments made using 
the HSB and RGB sliders. Use the Amount slider to adjust the 
degree of offset. Use the Alpha slider to adjust the opacity of 
the selected colour. 

Blend

Blends the selected colours with the colour swatch in the top-right 
corner. Use the Amount slider to adjust the degree of blend. A blend of 
100% turns the selected colours into the same colour as the swatch. 
Adjusting the HSB and RGB sliders affect the swatch colour, which in 
turn affects the selected colours on the left. Use the Alpha slider to 
adjust the opacity of the swatch.

Mixer

Select a Base and Tint colour to form a third colour swatch. 
Use the slider just beneath to mix the Base and Tint colours 
by different amounts. This will affect the mixed swatch 
whether it is selected or not. Select either the Tint or Base 
swatch and use the HSB and RGB sliders to adjust its colour. 
This will affect the mixed swatch colour, which in turn affects 
the selected colours on the left.

6. Click Apply.
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Painting the Model

Now that you have created the colours and the palette, you are ready to paint your model.

The colour model needs to be painted in order to adjust the colours with the other elements in the 
production. You can paint your model regardless of the colour RGBA and adjust them later when all 
the elements are together.

Once your palette is created and your model is painted, you can import a key background and other 
characters using the Import Drawings option or the Library to compare and adjust the palettes—see 
Importing Models on page 531 to learn how to import your background file.

For paperless and cut-out animation, it is a good idea to provide a line-up template with the colour 
model to show the scale ratio between the characters, props and backgrounds. 

Once your colour model is completed, create a line-up template by pasting one of the production's 
main characters, or even just a hand, beside the colour model to show the relative size. This allows the 
animator, layout artist, or scene setup artist to retain the correct scaling throughout the entire project 
when setting the elements in the scene. You can store your template in the Library.

How to paint a colour model

1. From the Drawing or Camera View  menu, select View > Switch to Colour Art/Switch to Line Art 
or press L.
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2. Create your master colour palette—see Creating a Colour Palette  on page 278

3. Add new colours to the palette—see Adding a Colour Swatch  on page 297.

4. Select your Paint Bucket  tool. We recommend the Paint Unpainted  tool.

5. In the Colour view, select the colour you need to paint your drawing.

6. Paint the model by selecting colour swatches in the palette and clicking on your drawing. Note that 
only closed zones will be painted. If there is a gap in your artwork, you will need to close it in order 
to paint it.

7. If you would like to separate your lines and fill zones on separated art layers, see Art Layers on 
page 603.

8. Adjust the colours—see Mixing Colours on page 305.
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Chapter 8: Painting the Background

Not only does Toon Boom Harmony give you the ability to animate and composite, you can also use it 
to paint your backgrounds. You can use solid, gradient or textured colours to create vector-based 
and bitmap colouring. 

If you create multiplane moves, a vector background will generally be lighter and will allow extreme 
truck-ins.
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The background painting process consists of painting the black and white production backgrounds, 
also known as background layouts. For traditional animation, the background layouts are usually 
drawn on paper and then scanned in. For paperless and cut-out animation, the background layouts 
can either be drawn on paper or designed directly in Harmony.

This chapter is divided as follows:

• Preparation on the facing page

• Importing the Background Layout on page 315

•  Importing Palettes and Models on page 317

• Painting the Background on page 321
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Preparation

Before you begin painting, prepare by organizing your work and bringing in your references.

Setting the Scene

Once you chose your technique, it is time to open or create your scene and get ready to import your 
background layouts.

Working Directly in the Production Scenes

You can decide to import the background layout directly in the corresponding production scene 
and paint it there. This way, the background exists only in the production scene and not in a central 
storage scene, saving space on the hard disc drive and avoiding duplicate files.

Working in a Special Background Scene

You can decide to create a new scene, import all your background layouts and paint them in that 
scene. This scene will become the colour background storage scene.

It is useful to keep all the backgrounds in the same scene to compare the style and colours, use the 
same master palette, and keep track of the work and all existing backgrounds.

We recommend that you store this scene in the project root folder.

Using the Workspace

While inking and painting, you can use the Workspace Manager to save a frequently used layout and 
name it Ink and Paint, for example.

313



Chapter 8: Painting the Background     Preparation

314



Toon Boom Harmony 11.1 Draw Guide (Network)

Importing the Background Layout

When the background painting or production scene is ready, import your background layout in it. 
Designing your backgrounds and locations directly in Harmony can be a time saver and allows you to 
keep all your project materials in the same software.

Refer to Chapter 2: Import in the Compositing Guide to learn how to import bitmap images and the Scan 
Guide  to learn how to scan the layout.

Importing a Bitmap Layout

If your background layout was drawn on paper and scanned in a third-party software or simply 
drawn in a bitmap third-party software, you can import them using the Import Drawings command.

Scanning the Layout from a TWAIN Device

If your models were drawn on paper, you can also scan and import them using a TWAIN Device.

Importing a Toon Boom Harmony Vector-Based Layout

If the background layout was designed in Harmony, it can be imported into the scene through the 
Library view. To do so, create a template out of the main background layout and then import it in 
the scene.

Importing the Template in the Background Painting Scene

Once the template is created, you are ready to import it into your background painting scene. Drag 
the template to import it.
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There is no need to obtain the right to modify the library to import a template.
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 Importing Palettes and Models

In order to paint your background, you have to load the location colour model and its corresponding 
palettes. Prior to the painting process, the colour stylist creates the palettes and models and stores 
them in colour model templates and colour model scenes—see Colour Styling and Colour Models on 
page 265. 

Once your background layout is imported, you can start painting it. If you already created the location 
colour model in Harmony, you can load the required palette. If not, see Working with Palettes on 
page 271  to learn how to create a colour palette.

Importing a Colour Model Template
A good method of importing a palette is to import a template from the template library that contains 
the location colour model and master palette. This template should be created when you are creating 
your colour styling and colour model for your project. If you did not create any colour models, you can 
create your colour palette directly in the scene.

Once the templates are created, you are ready to import them in your scene.  Import the templates 
from the template library to make the models and their palettes available in your scene. Then you will 
be able to load the palettes in the corresponding drawing element and the colour models to the 
Model View.

There is no need to obtain the right to modify the library to import a template.
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How to import a template

1. Open the scene to ink and paint.

2. In the Library view, browse to the colour model storage folder.

3. Select the corresponding colour model template. 

4. Drag the selection to the  Timeline view. 

‣ If you drop the selection in the Timeline's left side, new elements and modules are created.

‣ If you drop the selection in the Timeline's right side, the information is inserted into existing 
elements. In order for the template to combine with existing elements, the structure needs 
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to be consistent. If it is not possible to merge the elements together, move on to the 
Timeline's left side to create new elements.

When you import a template in a scene, there is no link between the library and the scene. Instead, 
a copy of all drawings, effects, trajectories, and so on is created. This means that you are free to 
modify anything copied to your scene without affecting the original.

Loading Palettes and Models
Importing the colour model template in your scene creates a new drawing element. Importing also 
updates the master palettes; these palettes are now local to the scene.

If you are painting a drawing sequence, you can refer to the visual model to know where colours go, 
especially if the palette uses many colour swatches. Use the Model view to load the colour model so 
you can see it at the same time as you paint.

How to load your current drawing in the Model view

1. In the Timeline or Xsheet View, select the desired colour model drawing.

2. From the Model View menu, select Model > Use Current Drawing As Model.

The colour model is loaded in the Model View.

Once your model is loaded, you can import palettes in your drawing element.
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How to add a palette to your element

1. In the Xsheet or Timeline view, select the drawing element in which you want to load the palette.

2. Do one of the following:

‣ In the Colour view menu,  select Palettes >Link. 

‣ In the Colour view toolbar, click the Link Palette  button.

The Palette Browser window opens.

3. Select the location where the palette file is stored; it is usually at the Scene or Element level.

4. If you are working in Advanced Palette List mode, decide how you want the palette loaded: as a 
Scene or Element palette list.

5. Click OK.

In the Colour view of the drawing element, the palette appears in the palette list.
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Painting the Background

Now that your background layout, master palette and location colour model are imported in your 
scene, you are ready to paint your background.

A Harmonydrawing is composed of several art layers. Lines and colours can be separated or joined, 
depending on the animation process. When a traditional drawing is scanned in, strokes are 
automatically created in the Colour Art from the Line Art. For paperless drawings, once the drawing 
sequence is completed, create your Colour Art strokes if you plan to paint your animation in the 
Colour Art layer. Use the Create Colour Art from Line Art option to create strokes from your lines—
see Art Layers on page 603.

 

How to create strokes once the drawing is completed

You may prefer to create strokes once the drawing is cleaned up. In this case, select the full drawing 
and create the strokes in Colour Art.

1. Skip this step if you are creating strokes for a single drawing. Do one of the following:
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‣ In the Select Tool Properties view, click the Permanent Selection  tool.

‣ PressCtrl + Shift + P (Windows/Linux) or ⌘  + Shift + P (Mac OS X).

2. Do one of the following:

‣ In the Drawing Tools toolbar, click the Select  tool.

‣ Press Alt + S.

3. Select the entire animation sequence.

4. Do one of the following:

‣ In the Drawing or Camera view, select Drawing > Create Colour Art from Line Art.

‣ Press *

5. Repeat steps 1 to 4 for each drawing in the animation sequence.

How to create strokes while drawing in Line Art mode

If you have some traditional drawings that need to be fixed, for example, need extra lines to patch 
gaps, the strokes can be created in the Colour Art layer at the same time as the lines are drawn using 
the Auto-Create Colour Art from Brush feature. This feature creates strokes from the lines and brush 
strokes created in the Line Art layer as you draw.

You can use it to fix drawings, but if you draw a sketch from scratch it is better to create the strokes 
afterward using the Create Colour Art from Line Art option.

1. Do one of the following:

‣ In the Drawing or Camera View toolbar, click the Automatically Create Colour Art from 
Brush  button. You may have to customize the toolbar to display it.

‣ When the Brush, Pencil or any shape tool is enabled, in the Tool Properties editor,   click the 
Automatically Create Colour Art from Brush  button. 

2. Draw the extra lines required.

3. Once you are done, deselect the Automatically Create Colour Art  option.

You are now ready to paint your background.

How to paint your background

1. Do one of the following:

‣ In the Camera or Drawing view, switch to the Line Art or Colour Art to paint your model.

‣ Press L. 
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2. Select one of the Paint Bucket  tools. The Paint Unpainted  tool is recommended.

3. Paint the background by selecting the colours from the colour model or the palette, and clicking on 
the different drawing zones.

How to use the Stroke tool to create tone and highlight zones

You can use the Stroke  tool to draw invisible vector strokes and separate some of the drawing 
sections to create tone and highlight zones.

1. Do one of the following:

‣ In the Camera view or Drawing view menu,  select Drawing Tools > Stroke. 

‣ Press Alt + V.

2. Do one of the following:

‣ In the Camera view or Drawing view menu, select View > Show Strokes. 

‣ Press K.

The strokes appear.
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3. Draw the stroke on the background drawing.

4. In your colour palette, select the colour needed to paint the new zone.

5. In the Tools toolbar, click the  Repaint  button.

6. Do one of the following:

‣ In the Drawing or Camera View toolbar, select View > > Show Strokes to hide the strokes.

‣ Press K.
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How to use gradient colour

Using a gradient colour adds more depth and variation to your drawings.

1. In the Colour view, select the colour to be modified.

2. Do one of the following:

‣ In the Colour view menu, select Colour > Edit Colour.

‣ Double-click on the colour swatch.

The Colour Picker window opens.

3. Select the Gradient option.

4. Select the Linear or Radial option.
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5. Select the Gradient arrows to modify the colours.

‣ Click between the arrows to add extra colours.

‣ Pull down the arrows to remove them.

‣ Move the arrows left and right to modify the gradient distance.

6. Use the Edit Gradient/Texture tool to set your gradient's position.

How to use the Edit Gradient and Texture tool

1. Do one of the following:

‣ In the Camera view or Drawing view menu,  select Drawing Tools > Edit 
Gradient/Texture.

‣ Press Shift + F3.

2. Click on the gradient or texture colour to be modified.

The Edit Gradient/Texture selection frame appears.

  

3. Move the edit texture's parameters to the desired result.
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4. If the same modification needs to be applied to another gradient or texture zone, do one of the 
following:

‣ Select the modified zone and select Edit > Copy. 

‣ Press Ctrl + C (Windows/Linux) or ⌘  + C (Mac OS X).

5. Select the zone you want to modify.

6. Do one of the following:

‣ From the top menu, select Edit > Paste. 

‣ Press Ctrl + V (Windows/Linux) or ⌘  + V (Mac OS X).
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Chapter 12: Scanning

Once your traditional animation sequences are completed and cleaned up, you are ready to scan and 
import them in Harmony. The scan process is the point where the traditional production becomes 
digital. It is the moment where you use Harmony to control the project. 

This chapter is divided as follows:

• The Scanning Process on the next page

• Scanning and Importing Drawings on page 331

• Custom Vectorization Parameters  on page 786
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The Scanning Process

There are three steps in the scanning process which Harmony handles automatically: 

• Vectorization

• Line art and colour art creation

• Optical registration

You can choose the following vectorization styles, which are set at the vectorization step:

• Solid lines 

• Texture lines

This keeps your texture from the original drawing and applies it to your vectorized drawing as a 
bitmap filling zone.

Harmony receives images from any TWAIN device, such as  scanners or digital cameras. These images 
can either be loaded as bitmaps into your scene or converted into vector-based images that can be 
edited using Harmony.

You must install a TWAIN driver for your device in order to access its contents. Refer to the 
manufacturer of your device to get a TWAIN driver. Once all the animation layers are scanned in, you 
can set the timing in the digital exposure sheet.
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Scanning and Importing Drawings

Once your scene length is set, you can start scanning drawings and importing them into Harmony in 
one of the following ways:

A bitmap image is an image composed of pixels that are both size and resolution dependent. In 
Harmony, you can scan an image as a bitmap drawing.

You can turn bitmap images into vector drawings, while maintaining the sketchiness of a pencil line or 
into vector images with a bitmap fill. Both options can add life to an animation, which straight 
vectorization with smoothing does not usually afford.

How to scan images as bitmap drawings

1. From the top menu, select File > Import > From Scanner.

The Scan Drawings window opens.

2. Select your scanner from the Scanner list.

3. In the Layer section, decide if the scanned or imported image will be placed on a new layer or 
existing layer. 

‣ Create Layer: Scans or imports the image into a new layer. Select one of the following 
options:
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Parameter Description

Create Single Layer Named Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For 
example, the filenames a-1.tga, a-2.tga and b-1.tga will create 
layers named "a" and "b", where "a" has two drawings and 
"b" has one. When creating a single layer from these three file-
names, all three drawings will be inserted in the new layers.

‣ Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from 
the Layer list. You must scan into the same layer type if you are using an existing layer.

‣ Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix 
bitmap images with vector drawings on the same layer, the bitmap image must be 
encapsulated in a symbol and vice versa. Symbols will also be automatically added to the 
Symbol folder in the Library view.

4. In the Import Options section, select one of the following:

‣ Keep As Bitmap: Retains the imported image as a bitmap. In the Alignment section, decide 
on the size and placement of your image within the camera frame. Depending on the Scene 
Settings (the height and width in pixels that you chose for your project), an image that you 
import may get scaled to the point where all its individual pixels become visible. There are 
three options available in the Alignment section:

Parameter Description

Fit

Enlarges or shrinks (but not distorts) the image height to 
match the full height of the scene grid.

If the image orientation is landscape, this will enlarge or 
shrink (but not distort) your image width to match that of the 
scene grid.
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Note that the Fit alignment rule equals the Center Fit rule in 
the layer properties.

Pan

This is the opposite of the Fit parameter. If the image 
orientation is portrait, its width will be made to match the 
width of the scene grid. As a result, part of the image’s height 
will extend beyond the height of the frame. This can be useful 
if you want to make your background move up and down, or 
from left to right to make it appear as if the camera is 
panning, or to actually perform a camera pan.

The opposite will apply to a landscape image. Its height will 
be fit to the scene grid, therefore it is possible that the image 
will extend beyond the scene grid's boundaries.
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Note that the Pan alignment rule equals the Center First Page 
rule in the layer properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The 
system looks at the resolution of the bitmap image, for 
example 4000 x 2000, then compares it to the scene's 
resolution, for example 1920 x 1080, and adjusts the scale 
factor in proportion. So, in this example, the bitmap would 
appear at 208% (4000/1920). If you import a bitmap that is 
960 x 540, it will be displayed at 50% (960/1920) of the size of 
the project resolution.

Note that the Project Resolution alignment rule is equal to 
the As Is rule in the layer properties.

‣ Import As Bitmap Drawing: Imports a bitmap drawing into a vector layer where you can 
edit the image using the drawing tools. In the Alignment section, select one of the following:

Parameter Description

Vertical Fit
Enlarges or shrinks (but not distort) to your image height to match 
the full height of the scene frame (alignment grid).
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Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match 
the full width of the scene frame (alignment grid).

Actual Size

Scales the image in proportion to the scene's resolution. The system 
looks at the resolution of the bitmap image, for example 4000 x 
2000, then compares it to the scene's resolution, for example 1920 x 
1080, and adjusts the scale factor in proportion. So, in this example, 
the bitmap would appear at 208% (4000/1920). If you import a 
bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the 
size of the project resolution.

5. In the Drawing Options section, set the following options if desired:

‣ Drawing Name: Name of the drawing to import.

‣ Hold Value: Type the number of frames that the drawing will be exposed.
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‣ Scan and Advance: Lets you scan one drawing after another every time you click Scan.

‣ Flip Drawing: Mirrors the drawings horizontally and scans it this way.

6. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the 
view.

7. Click Scan to scan your drawing.

8. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next 
letter to capture your next frame.

9. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until 
you have finished scanning all your drawings.

How to import and vectorize bitmap drawings

1. From the top menu, select File > Import > From Scanner.

The Scan Drawings window opens.

2. Select your scanner from the Scanner list.

3. Click Preview to get a test scan of your drawing.

4. In the Layer section, select one of the following:

‣ Create Layer: Imports an image into a new layer. Type a name for the layer in the Name 
field. 
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‣ Add to Existing Layer: Imports the image into an existing layer. Select a layer from the 
Layer list.

5. In the Import Options section, select the Convert to Vector Drawing option.

6. In the Vectorization section, select one of the following:

‣ Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based 
drawing.

‣ Grey: Vectorizes the image as a mix of vector contour and greyscale bitmap filling. Lines 
keep the texture from the scan, and the white of the paper becomes transparent.

‣ New Preset: Lets you create a new preset.

‣ Delete Preset: Lets you delete any preset in the list.

‣ Custom vectorization: Lets you set custom vectorization parameters—see Creating a 
Vectorization Style  on page 794.

7. In the Drawing Options section, set the following options if desired:

‣ Drawing Name: Name of the drawing to import.

‣ Hold Value: Type the number of frames that the drawing will be exposed.

‣ Scan and Advance: Lets you scan one drawing after another every time you click Scan.

‣ Flip Drawing: Mirrors the drawings horizontally and scans it this way.

8. Adjust the Scale control and the sliders in the Preview Image window until you are satisfied with 
the view.

9. Click Scan to import your drawing.

10. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next 
letter to capture your next frame.
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11. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until 
you have finished scanning all your drawings.
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Custom Vectorization Parameters 

You can create your own vectorization settings with Harmony. 

The vectorization parameters you will create here can be saved, shared and also inserted into the 
VectOptions.conf file used by the Harmony Scan and Control Center modules when scanning or 
vectorizing a series of drawings.

You can use an interface to select and test the different options and you can also type in some 
advanced settings.

How to open the Vectorization Parameters dialog box

1. From the top menu, select File > Import > From Scanner.
You can also open it from any other import option that allows you to customize the vectorization 
parameters (i.e. from the scanner).

2. Select your file, decide on the layer options, and click Preview.

3. In the Vectorization section, click the New Preset  button.

The Vectorization Parameters dialog box opens.
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• Options Tab  below

• Help Tab on page 342

Options Tab 

The Options tab contains the main vectorization settings. More settings are available in the Help tab.

Parameter Description

Input

The input filters are applied to the bitmap image before it is 
vectorized.

One Pass: One threshold value is applied to both the Line and 
Colour Art. For drawings with distinct vector-style lines of 
mattes, you only need one pass.

Two Passes: Applies a different threshold value to each layer.

For greyscale drawings, you may want to perform the 
vectorization process twice to apply different threshold values 
to the Line and Colour Art layers.

Threshold: Determines which values in the scanned image are 
considered part of the Line or Colour Art layer and what will be 
eliminated from the vectorized drawing; 0% is white and 100% 
is black. The threshold is between these two values.

Expand Bitmap: Lets you enter a value to scale the bitmap to 
detect small variations in the line. Use this option if you scanned 
a greyscale image and want to preserve small variations in the 
texture to apply to the line art.

Jag Filter: Lets you enter a value to scale back the bitmap to 
remove some of the line’s roughness. This is useless when you 
have a drawing that appears quite rough; the Jag filter will 
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eliminate excess strokes in the final drawing.

Output

The output filters are applied during the vectorization process.

No Colour Art: Does not generate filling zones in the Colour 
Art layer.

No Texture: Does not generate texture in the Line Art in the 
final images. Select this option to create solid lines in the final 
line art.

Generate Matte in Underlay Layer: Creates an opaque zone 
behind your drawing’s lines to avoid seeing through the layers.

Colour as Texture: Converts colour values into a texture layer.

Optical Registration

The optical registration options are used to automatically align 
drawings based on the position of the peg holes on the 
animation paper. The peg holes must appear in the scanned 
drawings for the optical registration to work.

DPI: Lets you enter the dots-per-inch value of your image. You 
must enter the same value as the DPI used to scan the image.

Peg Side: Lets you select the position of the peg holes on your 
drawings. Identify whether they are on the top, bottom, left or 
right.

Strictness: Determines how exact the location of the peg holes 
must be for the software to recognize them. You have two 
values to choose from:

• Strict: The peg holes must be in a tightly defined area to 
be recognized.

• Loose: The peg holes can be recognized somewhere in a 
larger area. This is the recommended setting.

Field Chart: Lets you indicate the size of the animation paper; 
12 or 16.

Post Processing

The Post Processing filters are applied to the final vector 
images.

Remove Holes: Removes holes of a specified value that might 
make painting difficult.

Remove Dirt: Removes stray marks and dirt of a specified 
value. Try a value around 500.

Remove Hair: Removes small strokes that have no line art.

Remove Hair: Number of Passes: The number of times the 
drawing will be analyzed to identify hair marks.

Miscellaneous

Close Gaps: Closes gaps in the Colour Art so that you can 
paint it.

Smooth Passes for Line Art before Breaking Triangles: The 
number of times the smoothing operation runs before creating 
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the triangles that break lines in your drawing. If unnecessary 
triangles are appearing in your drawing, increase this value.

Smooth Passes for Line Art: The number of times the 
smoothing operation is performed after the triangles have 
been created. This further smooths the Line Art.

Preview

Show Strokes: Shows the strokes in the Vectorized Image 
panel.

Stroke Thickness: Shows the size of the strokes.

Help Tab

The Help tab contains the most advanced vectorization settings which you type in the Advanced 
Option fields at the bottom of the Options tab.

File IO Options 

-file <filename (including extension)> [ options ]

-infile <filename (including extension)>; same as -file

-outfile <filename>; alternate output file

-informat <format>; the input format. Used if reading from stdin

-debug; turn on debug mode

-noforce; don't force output if image is inconsistent

-version; print version information and quit

-output_version <version>; output files of this version. Valid versions can be: 0 or 604

-force_unamed_palette_for_texture; will generate a texture in TVG's internal palette

Registration Options 

-register <dpi side strictness>; perform optical registration.
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• Side can be one of left, right, top, bottom or l, r, t, b.

• Strictness can be either loose, strict or l, s.

-register_center_peg_holes; will use only round holes in 16 fields page

-rcph; short form of register_center_peg_holes

-registration_looseness_factor <factor>; registration looseness factor (default 2.000000)

-rlf; short form of registration_looseness_factor

-rdebug; output registration debug messages

-pegpitch <inch (default 8.000000)>; distance between peg bars

-threshr < (default 0.500000)>; threshold for optical registration; range 0.0 to 1.0

-rmargin <inch (default 1)>; region size where to look for peg bars 

-peg_distance_from_center <inch (default 5.25)>; peg distance from centre of the image 

-pdfc; short form of -peg_distance_from_center 

-out_peg_position <side (default same)>; wanted position of the peg on the drawing.

• Can be one of right, left, top, bottom (or r, l, t, b) or same.

• A rotation will be performed if it is different from the side passed to -register.

-output_peg_matrix; output the peg transformation matrix on standard output.

-scanner_calibrate; < (default 1.0000 1.0000) > x and y scale factors to be applied to scanner image.

Filtering Options 

-pixel <pixel_shape (default '4x3')>; Valid values: 4x3

-gap <worldUnits (default 10)>; close gaps up to this big

-pencil; generate line art only

-keep_dirt; don't filter out dirt

-thresh <threshold (default 0.2)>; range 0.0 to 1.0

-rmv_hairs <worldUnits (default 1)> <passes (default 1)> 

• remove hairs of size smaller than "size" in "passes" passes 

-rmv_holes <area (default 7)>; remove holes smaller than "area" 

-rmv_dirt <area (default 1)>; remove dirt smaller than "area" 

• try values between 100 and 500 for rmv_holes and rmv_dirt. The area is in world units squared

-rmv_triangles <worldUnits (default 30.000000)>; remove triangles at "pixels" 

• distance from each other. Use -no_break to remove all triangles

-no_texture; don't generate textured strokes

-color_as_texture; will vectorize the alpha channel and put the RGB colour in a textured colour

-noclosegap; disable all gap closing algorithms

-no_break; disable the breaking of line art

-jag_filter <pixels (default 0>; expand the pixels in the vectorization bitmap
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-expand_bitmap <pixels (default 0>; expand the pixels in the vectorization bitmap

-fit_errorc <error (default 1.000000>; fitting error for the colour art

-fit_errorl <error (default 1.000000>; fitting error for the line art

-smoothl <passes (default 1>; number of smooth passes for line art

-smoothc <passes (default 1>; number of smooth passes for colour art

-first_smooth <passes (default 0>; number of smooth passes for line art before breaking triangles

-first_smoothl <passes (default 0>; number of smooth passes for line art before breaking triangles

-first_smoothc <passes (default 0>; number of smooth passes for line art in colour art pass (needs -
2pass)

-2pass; specify two sets of parameters; one for line art "l", one for colour art "c"

(-thresh, -rmv_holes and -rmv_dirt will be overridden by -threshl, threshc, -rmv_holesl,

-rmv_holesc, -rmv_dirtl and -rmv_dirtc)

-threshl <threshold for line art (default 0.5)>; range 0.0 to 1.0

-threshc <threshold for color art (default 0.5)>; range 0.0 to 1.0

-jag_filterl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art

-jag_filterc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art

-expand_bitmapl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art

-expand_bitmapc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art

-rmv_holesl <area (default 7)>; remove line art holes smaller than "area" 

-rmv_holesc <area (default 7)>; remove colour art holes smaller than "area" 

-rmv_dirtl <area (default 1)>; remove line art dirt smaller than "area" 

-rmv_dirtc <area (default 1)>; remove colour art dirt smaller than "area" 

try values between 100 and 500 for rmv_holesl, rmv_holesc, rmv_dirtl and rmv_dirtc. The values are 
in world units squared 

-margins <inch (default 0.25)>; remove margin around bitmap 

-top_margin <inch (default 0.25)>; remove margin at top of bitmap 

-bottom_margin <inch (default 0.25)>; remove margin at bottom of bitmap 

-left_margin <inch (default 0.25)>; remove margin at left of bitmap 

-right_margin <inch (default 0.25)>; remove margin at right of bitmap 

-remove_peg_bars; remove the peg bar holes

-field_size <fields (default 12 or use value in scan file)>; set the drawing to this field size

-fs; short hand for -field_size

-peg_bar_size <inch (default 1)>; the size of the peg bar region

-noframe; do not put a frame around the colour art

-frame_fields <default -1.000000>; put a frame of the specified dimension around the colour art
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-downscale_input <default 1>; downscale the raw input by this integer factor

-downscale_texture <default 1>; downscale the output texture by this integer factor

-buildmatte; generate a matte on underlay for line test

-buildmatte_colourart; generate a matte on colour art for line test

Note: -buildmatte and -buildmatte_colourart are mutually exclusive

-copystrokes; copy original strokes when building matte.

Options for bitmap that has no registration information 

-pixel_margins <inch (default 0)>; remove margin around bitmap 

-top_pixel_margin <inch (default 0)>; remove margin at top of bitmap 

-bottom_pixel_margin <inch (default 0)>; remove margin at bottom of bitmap 

-left_pixel_margin <inch (default 0)>; remove margin at left of bitmap 

-right_pixel_margin <inch (default 0)>; remove margin at right of bitmap 

-dpi <(default -1)>; dpi information of input bitmap 

RGB Keying Options 

-rgb; generate separate zones for red, green and blue lines

-rgb_alpha <value (default 255)>; generate red, green and blue colour with alpha of this value

-no_red; ignore red colour in vectorization

-no_green; ignore green colour in vectorization

-no_blue; ignore blue colour in vectorization

-flatten; flatten the drawing after generating colours

-rmv_rgb_dirt <threshold area default 0.0>; remove red, green and blue regions smaller than area

-expand_bitmap_rgb <pixels (default 0>; expand the pixels in the vectorization bitmap for rgb

-threshrgb <value> <threshold for rgb vectorization default 0.200000>;

-threshsv <saturation threshold default 0.500000> <value threshold default 0.500000>; thresholds on 
saturation and value to consider a pixel to be grey

Colour Vectorization Options 

-color_vectorize; perform a colour vectorization

-file2 <colour art filename>; specify the colour art bitmap

-penstyle <center alpha (0.0-20.0)> <edge alpha (0.0-20.0)> <gamma (0-10)><centre pressure effect 
(0.0-1.0)> <edge pressure effect (0.0-1.0)><texture bitmap downscaling (0.2-20)> <texture bitmap 
file (valid filename or "" if no file)>; generate brush texture for the line art

-pressure_variation <strategy (0, 1 or 2)> <min pressure (0.0-1.0)> <max pressure (0.0-1.0)> <max 
variation (0.0-1.0)>; specify a pressure strategy for the centre line. 

-blur_radius <pixels (default 0)>; blur the penstyle texture generated

345



Chapter 12: Scanning     Help Tab

-color_contour_smooth_passes <times (default 3)>; perform number of smooth passes on contour 
before computing texture

-ccsp <times (default 3)>; short for -color_contour_smooth_passes

-color_rmv_holesl <world units (default 0.000000)>; remove holes of this size when computing 
texture

-color_fill_holesl <world units (default 0.000000)>; fill holes of this size for colour line art

Bubble Usage (implemented only for colour vectorization's line art)

-create_bubbles; add bubbles into the LineArt. Implemented for colour vectorization only 

-bubble_gap <value (default 3)>; max number of colour art points between 2 bubbles

-bubble_length <value (default 10)>; max number of circles in a bubble

-min_radius <value (default 1.5000)>; min radius of a circle in a bubble relative to the line thickness 
(must be >= 1.0)

-max_radius <value (default 3.5000)>; max radius of a circle in a bubble relative to the line thickness 
(must be >= 1.0)

-uniform_gap; the space between bubbles is constant 

4 Colour Vectorization

-4colours [key:value] ... [key:value] ; The key value list can be empty. The list of keys is:

rgbdiff:value ; between [0.0-1.0] or [0-255]

dark:value    ; between [0.0-1.0] or [0-255]

grey:value    ; between [0.0-1.0] or [0-255]

white:value   ; between [0.0-1.0] or [0-255]

dirt:value    ; dirt area. 200 is a good value

rt:value      ; between [0.0-1.0] or [0-255]

gt:value      ; between [0.0-1.0] or [0-255]

bt:value      ; between [0.0-1.0] or [0-255]

There must be no space between the colon and the key/value. For example: -4colours 
rgbdiff:20 dark:20 grey:120 white:250 dirt:200 rt:240 gt:240 bt:240

The Vectorization Parameters dialog box lets you vectorize pencil drawings, along with any red, blue 
or green pencil marks you may have used to indicate highlights and shadows. The drawing will be 
vectorized into pure red, blue, green and black (RGB values), while creating colour art zones wherever 
lines connect. After painting in your tones and highlights, change your pure RGB colours to 
transparent (0 Alpha) in the Colour Picker window and watch the indicator colour zone lines 
disappear.
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Creating a Vectorization Style 
With Harmony, you have the possibility to create custom vectorization parameters that can be saved 
and reused.

You can vectorize drawings using one of the following methods:

• Black and White: All the lines become vector based and 100% black. The white areas become 
completely transparent.

• Greyscale: All the lines preserve their initial textured look in grey shades as a bitmap image 
contained inside a vector frame. The white areas become completely transparent.

• Four Colours: With the advanced parameters, you can isolate the red, green, blue, and black 
lines and turn them into 100% vector lines, preserving their original colours—see Custom 
Vectorization Parameters  on page 786.

How to create or modify the vectorization parameters

1. Set the different options available in the Vectorization Parameters dialog box.
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2. Click the Vectorize  button to update the Vectorized Image preview.

The vectorized image is just a preview. The actual vectorization happens when you click OK in the 
Import Images dialog box. There are many options to try in the Vectorization Options dialog box. 
These are applied during the vectorization process.

3. To set advanced parameters, read the information on the Help tab, then type in the Advanced 
Options field at the bottom of the Options tab.

4. To save your vectorization parameters to reuse them later, share them, or use them to set the 
Harmony Scan module vectorization style list, click  Save.

5. In the Browser window, name and save the file.

6. To save the current settings as your default settings, click Save As Default. To restore the default 
settings, click Restore Defaults.

7. To load a vectorization style, click Load and locate the existing *.vof file.

8. Click OK.

Setting the VectOptions.conf File
Toon Boom Harmony Server uses a file called VectOptions.conf to get the vectorization style 
when batch vectorizing a series of drawings. A series of default styles is available in this file, but you 
will certainly want to create your own to fit your production style.

This section deals with setting the VectOptions.conf file on:
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• Setting the VectOptions.conf File on Windows and Mac OS X below

• Setting the VectOptions.conf File on Linux on page 351

Setting the VectOptions.conf File on Windows and Mac OS X

How to set the VectOptions.conf file on Windows or Mac OS X

1. Open the vectOptions.conf file:

‣ Windows: Select Programs / All Programs > Harmony 11.1 > Tools > Configuration 
Editor.

‣ Mac OS X: Select Applications > Harmony 11.1 > Tools > Configuration Editor.

The Configuration Editor window opens.

2. In the bottom section of the window, select the VectOptions.conf tab.

3. Scroll down the VectOptions.conf file to see all the different options available for creating your 
custom vectorization style. These options are the same as in the Vectorization Parameters dialog 
box. It is recommended that you create your vectorization style using Harmony and the 
Vectorization Parameters window and copy the result parameters in this file—see Creating a 
Vectorization Style  on page 794

4. Scroll down toward the bottom of the file to see the default styles. You can modify them or add 
new ones to the list using the parameters you got using the Vectorization Parameters window. 
Notice that some of the lines have a “#” sign at the beginning to indicate that the line is a comment 
and will not appear in the style list. The lines that have no sign at the beginning appear in the style 
list.
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5. To create a new style, type the following below the existing styles: 

style_name:

This should be followed by the name of your new style. For example: style_name: Black 
Lines.

6. Under the style name line, type the following: 

options:

7. Copy and paste the information in your *.vof style when saving your settings in the Vectorization 
Parameters window.

‣ To open the *.vof file, use any plain text editor application.

8. In the Configuration Editor’s top menu, select File > Save.

9. If you have Toon Boom Harmony Scan on your computer, you can start the application and verify 
that the new style appears in the Vectorization Style list under Edit > Vectorization Style.  
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If you are using the batch processing method available with Toon Boom Harmony Server 
to scan and vectorize your drawings, the selected style must be available on all the 
machines included in the batch processing list.

Refer to the Control Center Guide to learn more about setting up and using batch 
processing.

Setting the VectOptions.conf File on Linux

These are the two methods used to edit the VectOptions.conf file on Linux. 

• Using the “vi” text editor

• Using the “gedit” text editor 

How to set the VectOptions.conf file on Linux using the “vi” text editor

1. Open a Terminal window:
Menu: Applications > System Tools > Terminal

2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_11.0/etc

3. Change your user to "root":

$ su

‣ If your user is part of the sudoers list, enter the following command and go to See "Open 
the 'VectOptions.conf using the  "vi" text editor:" on page 351: 

$ sudo vi VectOptions.conf

4. Enter the "root" password.

5. Open the 'VectOptions.conf using the  "vi" text editor:

$ vi VectOptions.conf

6. To start editing, press the [i] key on your keyboard to enter Insert mode.

7. Once you are done editing the file, press Esc to exit Insert mode.

8. To save the changes made to the file, type the following and press Enter/Return:

$ :w!

351



Chapter 12: Scanning     Help Tab

9. To exit the "vi" editor and return to the Terminal, type the following and press Enter/Return:

$ :q

10. If you have Toon Boom Harmony Scan on your computer, you can start the application and verify 
that the new style appears in the Vectorization Style list under Edit > Vectorization Style.

If you are using the batch processing method available with Toon Boom Harmony Server 
to scan and vectorize your drawings, the selected style must be available on all the 
machines included in the batch processing list.

Refer to the Control Center Guide to learn more about setting up and using batch 
processing.

How to set the VectOptions.conf file on Linux using the “gedit” text editor

1. Open a Terminal window:
Menu: Applications> System Tools> Terminal

2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_11.0/etc

3. Change your user to "root":

$ su

‣ If your user is part of the sudoers list, enter the following command and go to See "Open 
the 'VectorOptions.conf using the  "gedit" text editor:" on page 352: 
$ sudo gedit VectOptions.conf

4. Enter the root password.

5. Open the 'VectorOptions.conf using the  "gedit" text editor:

$ gedit VectOptions.conf

6. Edit the parameters of the VectOptions.conf file like you would do in most text editor 
application.

7. Select File > Save.

8. Select File > Quit.
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9. If you have Harmony Scan on your computer, you can start the application and verify that the new 
style appears in the Vectorization Style list under Edit > Vectorization Style.

If you are using the batch processing method available with Toon Boom Harmony Server 
to scan and vectorize your drawings, the selected style must be available on all the 
machines included in the batch processing list.

Refer to the Control Center Guide to learn more about setting up and using batch 
processing.
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Chapter 13: Timing

Throughout this chapter you might notice slight differences between your interface and the images used to 
demonstrate the procedure. This is because the images are taken from Harmony Stage. Draw is a subset of 
Harmony Stage.

When you create hand-drawn animation traditionally or in a paperless environment, it is important to 
know how to set and modify the timing of your drawings. 

In a traditional workflow, the person in charge of the digital exposure sheet reproduces the paper 
exposure sheet created by the animator. In a paperless workflow, the animator creates and manages 
his own exposure sheet directly in Harmony without the need for reproduction.

If you are more of a traditional animator, you are more likely to work with an exposure sheet. If you are 
a digital animator, you may prefer to work with a timeline to visualize your timing. Harmony offers 
both.

The Xsheet view displays the digital reproduction of a traditional paper exposure sheet used in hand-
drawn animation. You can set the animation sequence's exposure and name the drawings.

The Timeline view is also used to visualize timing, and represents elements and groups of elements as 
layers.

You can adjust timing in both views; your choice depends on which technique you are used to working 
with. Depending on your working style, some actions may seem preferable to do in one view instead 
of another. Many of the actions you perform in the Xsheet can also be accomplished in the Timeline. 
This chapter will often show both techniques. You will be able to choose which one you prefer.

In this topic, you will learn how to work on your drawing’s exposure and length. The exposure and 
animation paths for symbols are covered in separate chapters.

The exposure sheet is not mandatory for Cut-out animation. It can be useful for creating characters and 
parts, but is not really needed for animation and timing. If you plan to work with Cut-out animation, you can 
still gain useful tips by reviewing the section on exposure sheets.
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The basic digital exposure sheet process is divided into the following steps:

• Preparation on the facing page

• Frames on page 359

• Filling Exposure on page 385

• Managing Drawings on page 407

• Modifying the Layer and Column Display on page 414

• Printing the Xsheet on page 430
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Preparation

The digital exposure task is quite simple. There are very few things to prepare in order to get ready.

Opening the Scene

The scene is generally created during a previous step such as scanning (in a traditional animation 
workflow), scene setup, digital layout, or production organization.

Using the Workspace

The person creating the exposure sheet will need only the Xsheet view to create the digital exposure 
sheet, although the Timeline view may also be helpful. If you are doing paperless animation, use the 
Camera or Drawing view if you want to sketch at the same time.

If you work with this layout often, you can use the Workspace Manager to save it as a 
workspace,and name it Xsheet, for example.

While drawing and animating paperless animation, you can use the Workspace Manager to save a 
frequently used layout and name it Paperless Animation, for example.
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Preparing References

To start an exposure sheet, you need to prepare your references. For traditional animation, you will 
need to reproduce the animator's paper exposure sheet. If you are working remotely, the studio can 
scan the paper exposure sheet using third-party software and send the digital files to be opened and 
viewed digitally. 

In paperless animation, you will usually create an exposure sheet from the Xsheet view.The 
information from your layout and posing or storyboard will help you approximate how many 
elements are required in the scene.
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Frames

Once the references are ready, you need to set the scene length by adding the right number of frames 
to your scene. You can set the global scene length from the top menu.

In the Xsheet and Timeline view, you can add and remove frames from a scene to edit its length.

How to set the scene length

1. From the top menu, select Scene > Scene Length.

The Set Scene Length dialog box opens.

2. In the Number of Frames field, enter the number of frames needed.

How to extend a scene in the Timeline view

1. In the Timeline view, drag the scene length bracket to the right to add more frames to your scene.

How to add frames before or after a selection to the extend scene length in the 
Xsheet view

You can add frames anywhere in the middle of the scene. If you select a frame row in the Xsheet view, 
Harmony will add the new frames before or after the selection, depending on your choice.

1. In the Xsheet view, select a frame row.

2. Do one of the following:

‣ From the top menu, select Scene >Frame > Add Frames Before Selection or Add 
Frames After Selection. 

‣ In the Xsheet view, right-click and select Frames > Add Frames Before Selection or Add 
Frames After Selection.
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‣ In the Xsheet view toolbar, click the Add Frames  button to add frame after your 
selection.

‣ Press Ctrl + G and Ctrl + H (Windows/Linux) or ⌘  + G and  Ctrl + H (Mac OS X).

The Add Frames dialog box opens.

3. In the Number of Frames to Add field, enter the number of frames needed in the scene.

How to add frames at the start or end to extend the scene length from the top menu

1. From the top menu, select Scene > Frame > Add Frames At Start or Add Frames At End.

‣ In the Xsheet view toolbar, press the Add Frames  button to add frame after your 
selection.

The Add Frames dialog box opens.

2. In the Number of Frames to Add field, enter the number of frames needed in the scene.

How to reduce the scene length in the Timeline view

When you remove frames at the end of a scene to reduce the scene length in the Timeline view, the 
exposed drawings and symbols are not deleted. They are still available if you extend the scene 
afterwards.

1. In the Timeline view, drag the scene length bracket to the left to remove frames from the scene.

How to remove a frame or a range of frames to reduce the scene length in the 
Xsheet view

In the Xsheet view, you can remove any selected frame range, such as the last frame.

1. In the Xsheet view, do one of the following:

‣ Select a frame in a given column.

‣ Select a frame range by clicking the first frame’s number and then dragging the selection 
highlight down to the last frame to delete.
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2. To delete the selected frames, do one of the following: 

‣ From the top menu, select Scene > Frame > Remove Selected Frames. 

‣ Press Delete to delete the selection. 

‣ Click Remove Frames  button. To remove several frame selections, click the button 
repeatedly.

If you selected a range of frames, the Warning dialog box may open.

3. To complete the operation:

‣ Click Yes to delete the selection.

‣ Click No to delete only the exposure in the cell and not the frames.

‣ Select the Don’t Show This Message Again option to prevent the warning message from 
being displayed each time you delete a frame range.
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Creating Drawing Elements

Before filling any value or setting any timing or exposure, you need to add different drawing elements.

Each drawing element is represented as a vertical element column in the Xsheet view and a horizontal 
element layer in the Timeline view.

In Harmony, whether you work in the Timeline or Xsheet view,  any modification you do to one view will 
be applied to both. You can also see your layers displayed in the Network view as modules.

To start an exposure sheet, you will use drawing elements. Drawing elements are drawing containers. 
Any image file, either bitmap or vector, will use a drawing element. 

When you add a drawing element to your scene, a folder is added to the scene directory. This folder is 
named the same way as the drawing element. Its purpose is to contain all the drawings related to this 
element. For example, in cut-out animation, a character can have many heads available. All of the head 
drawings will be contained in this folder, even if they are not exposed in the Timeline or the Xsheet 
view. There is always a drawing container connected to a drawing element (layer, column).

There are different element types available such as  Sound and Expression. A sound element will contain 
sound files. Expressions, Beziers, Eases, 3D Path, Quadmaps and Pegs are for motion purposes during the 
compositing step. It is not necessary to create these types to create your exposure sheet.

You can add drawing elements from the Timeline view, Xsheet view, and the Scene menu.

This section is divided as follows:

• Layer and Column Concepts below

• Layer and Column Types on the facing page

• Adding New Drawing Elements on page 365

• Deleting Layers and Columns on page 370

• Layer and Column Properties on page 371

• Modifying Layers and Columns on page 373

• Duplicating Layers and Columns on page 376

• Cloning Layers and Columns on page 376

• Adding an Annotation Column on page 377

Layer and Column Concepts
A layer is linked to a directory, the location where all its drawings are saved. This directory has the 
same name as the layer. When a name is typed in a cell,Harmony searches the layer's directory for the 
corresponding drawing to display. If there is no corresponding drawing, a new one is created.

Drawings are exposed in cells, and linked to the drawings saved in the layer's directory. Removing a 
drawing from a cell means it is not displayed. It will not be deleted from the directory.

A drawing that is exposed multiple times (for example, in a walk cycle) would be linked to the same 
original drawing in the layer's directory. If you modify, repaint, or correct the drawing, all exposed 
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drawings with the same name are updated simultaneously. You must duplicate or create a new 
drawing to modify a single exposure and retain the others.

When you create a drawing cycle, all of the repeated drawings are linked to the original files. This means that 
when you modify, repaint, or correct a drawing named “1,” all drawings named “1” are updated simultaneously. 
In order to modify a drawing independently from its other exposures, you must duplicate the drawing.

Layer and Column Types
A column is also known as a layer. There are several types of layers that you can add in the Xsheet and 
Timeline view. Each layer is tagged with an icon to help differentiate them. Some layers are 
represented differently in the Xsheet view. 

Drawing Layer

The most common layer type is the drawing layer. Any time you need to create a vector drawing or 
import a symbol or image, you can use a drawing layer. You can also create bitmap artwork on a 
drawing layer.

Bitmap images are contained in Bitmap layers.

Bitmap Layer
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If you import a picture or bitmap images in your project, they are inserted in a Bitmap layer. If you 
choose to vectorize your image when you import, the bitmap object will be placed on a Drawing 
layer. This way, you can have bitmap images mixed with vector drawings on a Drawing layer.

When importing a bitmap image, you have the option of encapsulating the image in a symbol. If you 
place a non-vectorized bitmap into a symbol, you will still not be able to mix vector drawings with it 
on the same layer. If you place a vectorized bitmap in a symbol, you must enter the symbol to be able 
to mix it with vector artwork. 

Camera Layer

You can only have one Camera layer at a time in your timeline. By default, there is no Camera layer 
when you create a scene. You need to add a Camera layer when you want to create a camera 
motion.

The Camera layer is not visible in the Xsheet view.

If you want to have several cameras with different settings, you can keep adding Camera layers in your 
Timeline view (however, only one will ever be visible at a time as you can only have one camera at a time 
in your timeline). To switch to a different camera, select Scene > Camera and select another camera layer.

Effect Layer

To enhance the look of your scene, you can add effect layers and attach your drawings to them. In 
Harmony, there is a series of effect modules in the Module Library view.

When you select the Effect layer in the Timeline view, the effect’s parameter columns are displayed in 
the Functions section of the  Xsheet view.

Colour-Card Layer

The Colour-Card layer is used to add a plain colour background to a scene. By default, your scene 
has no background colour and if you render it as a QuickTime movie or image sequence, it will have a 
black background.

This layer is not visible in the Xsheet view.

Peg Layer
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A Peg layer is a trajectory or motion path layer that does not contain drawings. It can be attached to 
any drawing layer, cut-out puppet, or other peg layers; they will all follow the trajectory you set in 
the Peg layer.

When you select the Peg layer in the Timeline view, the peg’s function columns are displayed in the  
Functions section of the Xsheet view.

Quadmap Layer

A Quadmap layer can be described as a deformation transformation layer that does not contain 
drawings. This can be attached to any drawing layer, cut-out puppet, or even other peg layers. They 
will all follow the deformation you set in the Quadmap layer.

When you select the Quadmap layer in the Timeline view, the Quadmap’s function columns are 
displayed in the Functions section of the Xsheet view.

Sound Layer

You can import sound files to add dialog and sound effects to your project. The sound layer will be 
added to your Timeline and Xsheet view when you import a sound file in your scene.

In the Xsheet view, the Sound layer is a dark grey colour.

Advanced Column Types
In the Xsheet view, you can add several advanced column types to create particular animation paths. 
When you create these columns, they are not linked automatically to any particular drawing layer. You 
can create a motion path using these columns and then link or unlink several drawing or peg layers to 
it.

Advanced column types include:

• Timing

• 3D Path

• 3D Rotation

• Bezier Curve

• Ease Curve

• Expression

• Annotation

Adding New Drawing Elements
There are different ways to add a drawing layer to your project. By default, when you create a new 
scene there is one Drawing column in the Xsheet view and one corresponding Drawing layer in the 
Timeline view.
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You can add an element for each drawing and it will appear as a column in the Xsheet view,  a layer in 
the Timeline view, and a module in the Network view.

How to add a drawing element from the Timeline view

1. Do one of the following:

‣ In the Timeline View menu, select Insert > Drawing. 

‣ In the Timeline view toolbar, click the Add Layers  button. 

‣

‣ Press Ctrl + R (Windows/Linux) or ⌘  + R (Mac OS X).

The Add Drawing Layer dialog box opens.

2. In the Name field, enter a relevant element name.

3. Do one of the following:

‣ Click OK to add the layer and close the dialog box.

‣ Click Apply to add the layer and keep the dialog box open to add another layer.

‣ Click Close to cancel the operation.

The new drawing element appears in the Timeline and Xsheet Views.

How to add multiple drawing elements from the Timeline view

1. In the Timeline View menu, select Insert > Add Layer(s).

The Add Layers dialog box opens.

2. In the Type menu, select the Drawing option.

3. In the Number field, enter the number of layers you want to add.
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4. In the Name field, type the name of the layer you want to add. If you are adding more than one 
layer, a numerical suffix will be added to subsequent layers.

5. Do one of the following:

‣ Click OK to add the layers and close the dialog box.

‣ Click Apply to add the layers and keep the dialog box open to add another layer.

‣ Click Close to cancel the operation.

The new drawing elements appear in the Timeline, Xsheet and Network views.

How to add a drawing element from the top menu

1. From the top menu, select Insert > Drawing.

The Add Drawing Layer dialog box opens.

2. In the Name field, type a relevant element name.

3. Click  OK.

The new drawing element appears in the Timeline, Xsheet and Network views.

How to add a drawing element from the Xsheet view

1. Do one of the following:

‣ In the Xsheet view menu, select Columns > Add Columns. 

‣ Click the Add Columns button. 

‣ Press Shift + C.

The Add Column dialog box opens.
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2. In the Name field, type a relevant element name.

3. In the Type field, select Drawing. 

4. To complete the operation:

‣ Click OK to add your new layers and close the dialog box.

‣ Click Apply to add your new layers and keep the dialog box open to add column.

‣ Click Close to cancel the operation.

The new drawing element appears in the Timeline and Xsheet Views—see Layer and Column Types 
on page 363.

How to create a column in Harmony using the advanced Add Column dialog box

You can use the advanced Add Column dialog box to make more file format and field size options 
available when you insert the column.

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS 
X) and select the Advanced tab.

2. In the Advanced Options section, select the Advanced Element Mode option to access the 
advanced Add Column dialog box.

3. Click OK.

4. In the Xsheet View menu, select Columns > Add Column or press Shift + C.

The Add Column dialog box opens.
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5. In the Name field, type the new column’s name.

6. In the Type drop-down menu, select the Drawing type.

7. In the Element section, select one of the following:

‣ Create New Element: Create an independent column with its own drawing folder.

‣ Reuse Existing Folder: Link your column to an existing folder within the Element folder of 
your scene. If you select this option, in the Folder drop-down field, select the folder to which 
you want to link your new column.

‣ Use Existing Element:Use drawings from an existing column in the new column. Both 
columns will be attached to the same set of drawings, but their timing will remain  
independent  from one another. If you modify one of the drawings, it will be modified in both 
columns. This is the same principle as the Clone column.

If you selected the Use Existing Element option, in the Name drop-down field, select the 
column to which you want to link your new column.

8. If you selected the Create New Element option:

‣ Deselect the Vector option if you want your layer to contain bitmap images or enable it if 
you want the layer to contain vector drawings. Most of the time, the Vector option will be 
enabled.

‣ If you deselected the Vector option, from the Bitmap Format  list, select which type of 
bitmap image you want to insert in the column. Select the SCAN type if you are planning to 
scan drawings using the Toon Boom Harmony Scan module.

‣ If you deselected the Vector option and you chose the SCAN type, from the Scan Type 
menu, select what kind of scanning you want to achieve.
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‣ In the Field Chart field, when importing traditional animation, indicate the size of paper on 
which the animation or background was drawn. If you are not using perforated animation 
paper, leave the 12 field default value as is.

9. Do one of the following: 

‣ Click OK button to create the new column and close the dialog box. 

‣ Click Apply to create the new column but keep the dialog box opened to create other new 
columns.

Deleting Layers and Columns
You can delete an element in the Timeline view or Xsheet view.

How to delete layers in the Timeline view

1. In the Timeline view, select the layers to be deleted.

2. Do one of the following:

‣ In the Timeline’s Layer toolbar, click the Delete Layers  button. 

‣ Right-click on the selection and select Delete.

The  Confirm Delete dialog box opens.

‣ Select the Delete Drawing Files and Element Folders option to delete all drawings and 
folder linked to this layer.

3. Select the Delete Xsheet Columns option if you also want to delete the existing column in the 
Xsheet view.

How to delete columns in the Xsheet view

1. In the Xsheet view, select the columns to be deleted by clicking on their header.

2. Do one of the following

‣ Right-click on the selection and select Delete Columns. 

‣ In the Xsheet View toolbar, click the Delete Columns  button.

‣ Press Delete.
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The Confirm Delete dialog box opens.

‣ Select the Delete Drawing Files and Element Folder option if you want to delete the 
drawings and folders linked to the selected column.

3. To complete the operation:

‣ Click OK to delete the selected layers.

‣ Click Cancel to cancel the operation.

The Warning dialog box may open.

4. Do one of the following:

‣ Click Yes to delete all the frames from your scene.

‣ Click No to keep the frames in your scene.

‣ Select the Don’t Show This Message Again option if you do not want the dialog box to 
display again in the future.

Layer and Column Properties
Each element has its own set of properties that can be modified, including effect and peg layers.

If you want to modify some of the element’s properties, display the Layer Properties or Column 
Properties editor. You can display the Layer Properties editor from the Timeline or Network view as a 
dialog box or open the Layer Properties as a view of its own.

The Layer Properties editor allows you to:

371



Chapter 13: Timing     Creating Drawing Elements

• Rename the layer

• Enable or disable the layer

• Lock the layer

• Change the track colour

• Activate the onion skin preview

• Adjust the positioning and animation parameters

• Adjust many other advanced parameters

The Column Properties editor allows you to:
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• Rename the layer

• Enable or disable the layer

• Adjust parameters for bitmap format, scan type and field chart

How to display the Column Properties editor from the Xsheet view

1. Do one of the following:

‣ In the Xsheet view, double-click on a column’s header.

‣ In the Xsheet view, right-click on a column's header and select Column Editor.

‣ Press Shift + E.

How to display the Layer Properties editor 

1. Do one of the following:

‣ In the top menu, select Windows > Layer Properties.

‣ In the Timeline view, double-click on a layer.

‣ Press Shift + E.

‣ In the Network view, click on the module’s yellow properties button.

2. In the Timeline or Xsheet view, select the layer whose properties you want to view.

The Xsheet column will not open the Layer Properties editor, but it will show the column properties 
allowing you to modify settings related to the Xsheet column.

Modifying Layers and Columns
Once you add layers and columns to your project, you can modify their properties, names, or 
ordering.

You can change the order of your elements in the Timeline view and Xsheet view. When you change the 
order of your elements in one view, the other one is updated.

The Element Manager lets you add, delete or modify elements (drawing folders) in your scene. If you 
have drawing folders that are not linked to a column in your scene, use the Element Manager to delete 
them if needed.
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How to rename a layer in the Timeline view

1. In the Timeline view, double-click on the name of the layer to rename.

2. In the Name field, rename the layer and press Enter/Return.

How to rename a layer in the Layer Properties editor

1. In the Timeline view, double-click anywhere on the layer except the layer name to rename.

The Layer Properties editor opens.

2. In the Name field, rename the layer.

3. Click Close.

How to rename a column

1. In the Xsheet view, double-click on a column name. Do not click on the drawing folder name that 
the column is linked to (this also appears in the column header just below the column name).

The Drawing dialog box opens.

2. In the Name field, rename the column.

3. Click OK.

How to reorder layers in the Timeline view

1. In the Timeline view, select the layers to move.

2. Drag the selection to the new location.

3. Do one of the following:

‣ Drop the selection on an existing layer to make it a child of another element layer.

‣ Drop it between the existing layers. Timeline layers that are located above the selection are 
displayed in front it. Layers located under it in the Timeline View are displayed behind it.
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How to reorder columns in the Xsheet view

1. In the Xsheet view, click on the column’s header with the middle mouse button.

2. Drag the column to its new position.

How to use the Element Manager dialog box

‣ From the top menu, select Scene > Element Manager.

Interface Element Action

Elements Displays a list of the elements 
contained in your scene.

Delete Elements Deletes the selected elements.

Delete Elements and Directories Deletes  the selected layer, as well as 
its directories (drawing folder).

Add/Modify Element Use this area to add or modify an element.

Name Type a new name in this field to create 
an element or to rename the selected 
element.

Vector Check this box if the new element is a vector 
drawing or if you want to enable the para-
meters on the selected element in the Ele-
ments list.
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Interface Element Action

Bitmap Format Select the file format of the bitmap layer 
from the drop-down list

Scan Type If you are planning to scan elements with the 
Toon Boom Harmony Scan module, select 
the scan type from the drop-down list.

Field Chart If you are importing traditional animation, 
select the size of the paper on which the 
animation was drawn.

Add Creates a new element with the current para-
meters entered in the Add/Modify Element 
section.

Modify  Applies the parameter changes made to the 
selected element.

Duplicating Layers and Columns
Duplicating an element provides you with a copy of the drawings and their exposure. You can modify 
anything you want in the duplicated element without affecting the original one. 

How to duplicate an element

1. In the Timeline or Xsheet view, click the layer you want to duplicate.

2. In the Xsheet View menu, select Drawings > Duplicate Drawings.

The new duplicated layer or column appears.

Cloning Layers and Columns
Cloning a layer or column provides you with a copy of the selected element that uses the same 
drawings as the original. For example, if you modify a drawing in the cloned or original column, it is 
updated in both columns. 

You can choose whether or not to copy the column timing to the cloned columns. 

• You can modify the column timing independently from each other, but the drawings remain 
linked.

• You can copy the columns timing, so drawings and timings remain linked.

You can clone selected modules from the Network view in the same way.

This feature is useful when you want to reuse a hand-drawn animation but have different timings.
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How to clone an element

1. In the Timeline or Xsheet view, select the layer or column you want to clone.

2. Do one of the following:

‣ In the Xsheet View toolbar, click the  Clone Selected Columns: Drawings Only  button.

‣ From the top menu, select Edit > Clone to clone the columns' drawings only.

‣ From the Timeline View menu, select Layers > Clone Selected Layers: Drawings Only or  
Layers > Clone Selected Layers: Drawings Only.

‣ In the Xsheet View or Timeline View toolbar, click the  Clone Selected Layers/Columns: 
Drawings Only  button.

The new cloned layer or column appears.

Adding an Annotation Column
The Annotation columns are useful for marking actions, corrections or other information related to 
your animation that you want to draw or write. This way, you can print your Xsheet, take it back to 
your animation table and work with the annotations.

How to add an annotation column

1. Do one of the following: 

‣ In the Xsheet View menu, select Columns > Add Columns. 

‣ In the Xsheet View toolbar, click the Add Columns  button. 

‣ Press Shift + C.

The Add Column dialog box opens.

2. In the Name field, type in an appropriate name.

3. From the Type list, select Annotation and click OK.

The new column appears.
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Drawing and Typing in the Annotation Column

In the annotation column, you can type in your notes and relevant information, as well as draw 
sketches and ideas that will be useful in producing your animation.

How to draw in the Annotation column

Before you can draw in the Annotation column, you must first activate the Enable Drawing option to 
activate the Drawing mode.

Pen tablet pressure sensitivity is not supported in the Annotation column.

1. Do one of the following:

‣ In the Xsheet View menu, select Annotation > Enable Drawing.

‣ In the Annotation column header, click to cycle through the icons, until the Brush  icon is 
displayed.

The Drawing mode is enabled.

2. To draw in an Annotation column, simply use your mouse or pen tablet.

 

How to type in an Annotation column

Typing in an Annotation column is independent from the Drawing mode. You can be in either mode 
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and the typing will work.

1. Do one of the following:

‣ In the selected cell, press Ctrl (Windows/Linux) or ⌘  (Mac OS X).

‣ In the selected cell, hold down Ctrl + Shift + click (Windows/Linux) or ⌘  + Shift + click (Mac 
OS X)..

2. In the selected cell, type the desired text.

To learn about typing values in the Xsheet view, refer to Typing Exposure on page 386.

How to erase part of a drawn annotation using Erasing mode

You can erase part or all of the Annotation column’s text and drawn annotations.

Annotations that you type in cannot be erased using this method.

1. In the Annotation column header, click to cycle through the icons until the Eraser  icon is 
displayed.

2. In the column, click and drag the cursor on top of the drawn annotation to erase parts of it.
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When using a pen on a tablet, you MUST flip your pen to the eraser side for the eraser to work.

How to erase an Annotation column selection

1. In the Annotation column header, click to cycle through the icons until the Select  icon is 
displayed.

2. In the Xsheet view, select the cell range you want to clear of text or drawn annotations. A selection 
is indicated by four pairs of dots on the left side of a cell. Do not select any cells if you plan to clear 
everything.

3. In the Xsheet view, right-click in the Annotation column.

4. Do one of the following:

‣ Select Annotation > Erase All to erase the entire content of the column.

‣ Select Annotation > Erase Selected Images to erase the images contained in the selected 
cell range. 

‣ Select Annotation > Erase Selected Texts to erase the text contained in the selected cell 
range.

Changing the Drawing Settings
You can change the pen size and colour when you draw in the Annotation column.

How to change the pen width

1. Right click on a frame within an annotation column or in the Xsheet View menu, select Annotation 
> Pen Width.  

2. Do one of the following:

‣ Select a pen width preset.

‣ Select  Change Current. 

If you selected the Change Current option, the Pen Width dialog box opens.
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3. In the Pen Width field, type the number of pixels you want the pen size to be.

4. Click OK.

How to change the pen colour

1. In the Xsheet View menu, select Annotation > Change Pen Colour.

The Select Colour dialog box opens.

2. Choose the new colour.

3. Click OK.

Displaying Tick Marks
When working with the Annotation columns, it is useful to display tick marks on odd-numbered 
frames.

To display the tick marks, you must run a short script.

How to display tick marks

1. From the top menu, select Windows > Script Editor.
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2. From the Script Editor menu, select File > New Script.

3. Type in a name for your script and click OK.

4. In the File list, select the script you created. 

5. On the right side of the view, type the following script:

function display_tick_marks()

{

preferences.setBool("XSHEET_ANNOTATION_FRAME_MARKER", true);

MessageLog.trace( preferences.getBool("XSHEET_ANNOTATION_FRAME_MARKER", 
false));

}

6. Click Verify.

The script is verified. 

7. From the File menu, select Play/Debug > Run.

A dialog box opens with your script selected in the Files column.

8. In the Functions column, select display_tick_marks and click OK.

Tick marks appear on odd frames in the Annotation column.

If you do not see tick marks, close and restart Harmony.

How to turn off the display of tick marks

1. Follow steps 1 to 5 of How to display tick marks and use the following script:

{

preferences.setBool("XSHEET_ANNOTATION_FRAME_MARKER", false);

MessageLog.trace( preferences.getBool("XSHEET_ANNOTATION_FRAME_MARKER", 
false));

}

2. Follow steps 6 to 8. 

All tick marks are removed from the Annotation column.

Importing an Annotation File
If you scanned your paper exposure sheet’s annotations or if you need to place some pictures or 
drawings in the annotation columns, you can easily import them.

How to import annotation files

1. In the Xsheet view, select the first cell in the annotation column where you want the imported 
image to start.
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2. Right click on the frame or from the Xsheet view menu, select Annotation > Import File. 

3. Browse for the bitmap image to import.

4. Click Open.

The image appears in the annotation column.

Linking External Files with Timing Columns
Timing columns are unique in that they can reference a source folder outside of the project folder to 
bring images into the project. For example, you may have background scenes created in a third party 
software that you might need to update in the future; by using Timing columns, you can dynamically 
link your backgrounds, expose different backgrounds at different times, and have live, automatic 
updating capabilities.

If the project file is moved, or the folder that the column is linked to is moved, then dynamic linking is 
broken and the images that were in that folder will disappear in Toon Boom Harmony.

How to use a Timing column

1. In the Xsheet view, click on the Add Columns  button.

2. In the Add Column dialog box, type in the name of the new column, then from the Type menu, 
select Timing.

3. Do one of the following:

‣ Click OK if you are finished.

‣ Click Apply if you want to continue adding more columns and column types.

A peach coloured column appears in the Xsheet with the name you typed in, and for the header, 
<unused>.
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4. In the Timing Column field, click the Arrow button to create a new timing column, or select the 
name of the column from the  list. If you have an element directory selected in the Name field, the 
Timing Column will indicate which files are called from that element directory. Remember that the 
file displayed at each frame is based on the element name, cell label, and extension. If the element 
is toto, the timing column is labeled 1, 2, and 3, and the extension is TVG, Harmony will display 
drawings totobody-1.tvg, totobody-2.tvg, and totobody-3.tvg at the selected frames. 

In the Xsheet, the <unused> header  changes to the name of the module in the Network view.

5. From the Extension  list, select the file format of the files you want to display.

6. Click OK.

7. In the Xsheet view, in the Timing column, type the number that corresponds to the suffix of the 
drawing file that you want to expose to make it appear in the Camera view.
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Filling Exposure

Harmony provides different tools to fill in exposures and values, create cycles, and set increments.

This section is divided as follows:

• Filling Exposure Mode below

• Typing Exposure on the next page

• Holding Exposure on page 388

• Extending a Single Exposure on page 389

• Extending an Exposure Sequence on page 390

• Dragging Cells on page 390

• Increasing and Decreasing Exposure on page 393

• Inserting Blank Cells on page 396

• Deleting Exposure on page 395

• Setting the Exposure on page 397

• Filling a Selection with a Single Exposure on page 398

• Filling a Selection with a Sequence on page 399

• Filling a Selection Randomly on page 401

• Filling Empty Cells on page 402

• Creating Cycles on page 403

• Managing Drawings on page 407

• Renaming a Drawing on page 407

• Deleting a Drawing on page 408

• Duplicating a Drawing on page 409

• Copying and Pasting Drawings on page 409

• Merging Drawings on page 412

Filling Exposure Mode
In the Xsheet view, you can fill columns using two different filling modes: Overwrite or Insert. These 
modes control the filling behaviour. The Timeline view only uses the Overwrite mode.

How to toggle between Overwrite and Insert modes

1. Do one of the following:

‣ In the bottom-right corner of the Xsheet view, click the Overwrite/Insert button.

‣ Press I.
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Overwrite Mode

By default, the Xsheet view is set to Overwrite mode. Adding a new value or a new value sequence 
overwrites existing ones. The existing timing sequence remains in the same place and is not pushed 
down the column.

Insert Mode

The Insert mode is the opposite of the Overwrite mode. When you add a new value or a new value 
sequence over existing ones, the new values are inserted between the old ones. The existing timing 
sequence is pushed down the column.

Typing Exposure
To fill in your exposure, you can directly type the values in the Xsheet view and Timeline view.

How type a value in the Timeline view

If you want to type an exact drawing name or value into the Timeline view, you must use the Data 
view section of the Timeline.

You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).
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1. In the Timeline view, click the Show Data View  button.

 

2. In the Drawing Substitution field, type the name of the drawing you want to create, and press 
Enter/Return.

How to type values in the Xsheet view

You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).

1. In an Xsheet column, double-click on one cell.

2. Type a value or drawing name in the cell.

3. Press Enter/Return to move to the next cell.

4. Press Esc to exit the typing mode and return to normal mode.

387



Chapter 13: Timing     Filling Exposure

Holding Exposure
Drawings in an animation project are not always exposed on a single frame; they are often exposed 
for more than one frame. The most common exposure of a drawing is two frames. In the industry, this 
type of exposure is known as animation in double frames or animation on twos. A drawing can also be 
exposed for three, four, five cells and so on. To prevent mistakes and save time, the Xsheet lets you 
hold your cells automatically as you type.

The  Set Exposure option allows you to choose how many frames you want to hold for your exposure.

• This option is only available in the Xsheet view.

• The selected Set Exposure settings will be kept from session to session. You will not 
have to set them every time you use Toon Boom Harmony.

How to hold exposure

1. In the Xsheet View menu, select Exposure > Hold Exposure > Hold 2 Cells.

2. In the Xsheet view, right-click and select Exposure > Set Exposure To > Set Exposure to 1, 2,3, 
or Set Exposure.

3. Type a value or drawing name in the cell.

‣ Press Enter/Return to move on to the next cell.

‣ Press Esc to quit the typing mode.

‣ If you selected Set Exposure, the Set Exposure dialog box opens. You can hold as many 
cells as needed.
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Extending a Single Exposure
Extending the exposure lets you select an Xsheet cell that contains a value and pull it down to the 
desired frame. 

How to extend a cell exposure gesturally

1. In the Xsheet view, select the red arrow  in the cell’s right side. Make sure you see the drag down 
 cursor.

2. Pull down the selected cell to the desired frame. 

The red selection box must be visible when releasing the mouse button. If not, the action is considered 
cancelled.

How to extend a sequence from the top menu

1. Do one of the following:

‣ In the top menu, select Animation > Cell > Extend Exposure.

‣ Press F5.

The Extend Exposure dialog box opens.

2. Enter the frame number you want to extend the cell to.
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Extending an Exposure Sequence
When working with a sequence that contains only numbers, you can extend an exposure sequence in a 
similar manner to extending a single exposure.

How to extend an exposure to create a sequence

1. In the Xsheet view, select a cell containing a number.

2. In the selected cell, click the red arrow  on the cell’s right side. Make sure to see the drag down  
cursor.

3. Hold down the Shift key. Make sure a plus (+) sign appears.

4. Pull down the selection box to the desired frame.

The red selection box must be visible when releasing the mouse button. If not, the action is considered 
cancelled.

5. First release the Shift key, then release the mouse button.

Dragging Cells
To readjust your timing, you can drag one or several cells to a new location. You can drag a cell to any 
other frame in the same column or into another column.

How to drag a cell to another location in the Timeline view

1. In the Timeline view, select one or several cells to move.
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2. Click on the cells selection and drag it to the new location.

3. Drop the selection. Do one of the following:

‣ Drop by simply releasing the mouse or pen to overwrite the existing cells.

‣ Hold Ctrl (Windows/Linux) or ⌘  (Mac OS X) while dropping the selection to copy the cells. 
The original cells will not be moved.

‣ Press Shift while dropping to insert the selection between the existing frames.

How to drag a cell to another location in the Xsheet view

1. In the Xsheet view, select one or more cells.

2. In the Xsheet view, select the small dotted area  on the left side of the selected cells.

391



Chapter 13: Timing     Filling Exposure

3. Drag the selection to any other cell in the same column or in another column.

4. Do one of the following:

‣ Drop the selection to overwrite the existing cells.

‣ Hold down Ctrl (Windows/Linux) or ⌘  (Mac OS X) while dropping the selection to copy the 
cells. The original selection will not be moved.

‣ Press Shift while dropping the selection to insert it between the existing frames.
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You can turn off the Gestural Drag Mode for the Xsheet view to prevent drawings from being 
dragged from one location to another. 

How to turn off the Gestural Drag mode

1. Do one of the following:

‣ In the Xsheet view, right-click and deselect the Gestural Drag Mode option. 

‣ Click the Toggle Gestural Drag Mode button (you may have to customize the  toolbar to display 
it).

 

The dragging pad disappears when the Gestural Drag mode is off.

This feature does not apply to Annotation columns.

Increasing and Decreasing Exposure
Once a value is entered in the Timeline or Xsheet view, you can increase and decrease its exposure.

How to increase exposure

Increasing the exposure adds one more exposure to a selected cell; repeating this action adds an 
extra cell each time. This is an efficient way of extending a drawing exposure and is always set in 
Insert mode. Increasing an exposure pushes the existing exposure ahead.

1. In the Timeline or Xsheet view, select a cell.
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2. Do one of the following: 

‣ In the top menu, select Animation > Cell > Increase Exposure. 

‣ Right-click on the selected cell and select Exposure > Increase Exposure. 

‣ Press +.

‣ In the Xsheet  or Timeline View toolbar, click the Increase Exposure  button.

How to decrease exposure

1. In the Timeline or Xsheet view, select a cell.

2. Do one of the following: 

‣ In the top menu, select Animation > Cell > Decrease Exposure. 

‣ Right-click on the selected cell and select Exposure > Decrease Exposure. 

‣ In the Xsheet  or Timeline View toolbar, click the Increase Exposure  button.

‣ Press -.

How to increase and decrease exposure using the Increase/Decrease Exposure field

You can use this option in the Xsheet view to increase or decrease the exposure of a selected drawing.

1. In the Xsheet view, select the cell to modify.
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2. Do one of the following:

‣ In the Xsheet's bottom right-corner, enter the number of cells over which the drawing will be 
exposed.

‣ In the Xsheet’s bottom-right corner, increase or decrease the drawing’s exposure by 
clicking the up or down arrows. 

‣ Press + to increase exposure.

‣ Press - to decrease exposure.

How to use the Clear Exposure and Pull feature

You can use this option to reduce a drawing’s exposure.

1. In the Timeline or Xsheet view, select or range of cells.

2. Do one of the following: 

‣ From the top menu, select Animation > Cell > Clear Exposure and Pull. 

‣ Right-click on the selected cell and select Exposure > Clear Exposure and Pull.

‣ In the Xsheet  or Timeline View toolbar, click the Clear Exposure and Pull  button.

3. The exposure is reduced by the selected number of cells.

Deleting Exposure
You can delete a drawing’s exposure in several ways. When you delete a drawing’s exposure from the 
Timeline or Xsheet view, you are not deleting the actual drawing file. You can always retrieve it by 
typing its name again in a cell.
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You can delete the exposure contained in a selected cell range  or delete the entire exposure of a 
drawing exposed over several cells . Note that you can also delete the exposure for drawings 
contained inside a collapsed group.

How to delete selected exposures

1. In the Timeline or Xsheet view, select the exposure you want to delete.

2. Do one of the following:

‣ Right-click and select Delete.

‣ Press Delete.

How to clear the entire exposure of a drawing

1. In the Timeline or Xsheet view, select a cell of a drawing exposed over several cells.

2. Do one of the following: 

‣ In the top menu, select Animation > Cell > Clear Exposure.

‣ In the Timeline view, right-click on the selection and select Exposure > Clear Exposure.

‣ In the Xsheet View toolbar, click the Clear Exposure  button (you may have to customize 
the toolbar to display it).

Inserting Blank Cells
You can place an empty cell between other cells. This is always done in Insert mode and pushes down 
existing exposure, even if you are set to Overwrite mode.

How to insert blank cells

1. In the Xsheet  or Timeline view, select the cell in which you want to insert a blank cell.

2. Do one of the following: 

‣ In the top menu, select Animation > Cell > Insert Blank Cell. 

‣ Right-click on the selected cell and select Exposure > Insert Blank Cell.

‣ In the Xsheet  or Timeline view toolbar, click the Insert Blank Cell  button (you may have 
to customize the toolbar to display it).

‣ Press Shift + J.

The blank cell is inserted.
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How to clear a selected cell range without changing the exposure and timing

1. In the Xsheet view, select the frame range to clear.

2. Right-click on the selected cells and select Clear.

Setting the Exposure
You can easily increase or decrease the exposure for a selected cell range by using the Set Exposure 
options.

How to set the exposure

1. In the Timeline or Xsheet view, select the cell range on which you want to set the exposure.
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2. Do one of the following:

‣ From the top menu, Animation > Cell > Set Exposure to > Set Exposure to 1, 2, or 3, or 
Set Exposure.

‣ In the Xsheet view, right click and select Exposure > Set Exposure to > Set Exposure to 1, 
2, or 3, or Set Exposure.

‣ In the Timeline View toolbar, click one of the Set Exposure  buttons (you may 
have to customize the toolbar to display them).

3. In the Xsheet view, right-click and select Exposure > Set Exposure to > Set Exposure to 1, 2, or 
3, or Set Exposure.

If you chose the Set Exposure option, the Set Exposure dialog box opens.

4. Type the number of frames you want the drawings to display and click OK.

The new timing is displayed in the Xsheet view.

Filling a Selection with a Single Exposure
The Fill Selection option lets you fill the same value over an entire selection. The selection can be over 
one cell, a cell range in one column, a cell range over many columns, an entire column, or many 
columns. You can use numbers, words, letters, or any alphanumeric value.
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How to fill a selection with a single exposure

1. In the Xsheet  or Timeline view, select a cell range.

2. Do one of the following: 

‣ In the top menu, select Animation > Cell >Fill Selection. 

‣ Click the Fill Selection  button in the Xsheet or Timeline view toolbar (you may have to 
customize the toolbar to display it).

‣ Press Ctrl + T (Windows/Linux) or ⌘  + T (Mac OS X)).

The Fill Selection dialog box opens.

3. In the Value field, type the desired value.

4. To insert a keyframe in the frame following the last cell in the selection, select the Add Key 
Exposure After option. Otherwise, leave it deselected.

5. Click OK.

Filling a Selection with a Sequence
You can create a numbered sequence over a selection. The sequence can be forward, backward, 
single, double or higher increment, as a cycle, and so on. The sequence can be over one cell, a cell 
range in one or more columns, or one or more columns.

How to fill a selection with a sequence

1. In the Xsheet or the Timeline view, select a cell range.
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2. Do one of the following:

‣ From the top menu, select Animation > Cell >Sequence Fill. 

‣ In the Timeline view, right-click and select Exposure > Sequence Fill.

‣ In the Xsheet View toolbar, click the Sequence Fill  button (you may have to customize 
the toolbar to display it).

‣ Press Ctrl + M (Windows/Linux) or ⌘  + M (Mac OS X).

The Sequence Fill dialog box opens.

3. In the Starting Value field, type the first number in the sequence.

4. In the Increment field, type the number by which the drawing number will increase from frame to 
frame. For example, an increment of 1 is used in this sequence:1-2-3-4; this sequence increments 
by 2: 1-3-5-7; and this one, by -2: 8-6-4-2.

5. In the Hold field, select an exposure holding value.

6. Select the Cycle option if you want a cycle; enter the number of cells for this cycle’s duration.

If you choose a two-cell hold, a cycle of three drawings will last for six cells.

7. If you selected a larger range than the amount of frames needed, select the End Frame option and 
type the last frame needed.
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8. If you want to have more than one digit in your numbers such as “001” instead of “1”, select the 
Padding option and add as many pound signs (#) as digits needed. In the field, you can type a 
letter or word to add before the drawing number.

9. To insert a keyframe in the frame following the last cell in the selection, select the Add Key 
Exposure After option. Otherwise, leave it deselected.

10. Click OK.

Filling a Selection Randomly
You can fill in random values over a selection. You can give a maximum and a minimum value and 
create a range for the system to choose the random values from. The selection can be over one cell, 
a cell range in one column or more, or an entire column or many entire columns.

How to fill cells randomly

1. In the Xsheet view, select a cell range.

2. Do one of the following:

‣ Select Animation > Cell > Fill Cells Randomly.

‣ In the Xsheet view, click the Fill Cells Randomly  button  (you may have to customize the 
toolbar to display it).

The Fill Cells Randomly dialog box opens.
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3. In the Minimum Value field, enter the lowest acceptable value.

4. In the Maximum Value field, enter the highest acceptable value.

5. In the Hold field, choose an exposure holding value.

6. If you are applying this option to a drawing column, enable the Whole Numbers option to avoid 
decimal points.

7. Click OK.

Filling Empty Cells
The Filling Empty Cells feature is used to extend the exposure of single frame drawings to fill the 
range of empty cells after each one.

When creating drawings on  cells that are not side-by-side, the exposure of the first drawing no longer 
fills automatically. You need to select the frame range where you want your drawings to hold their 
exposure up to the next drawing and use the Fill Empty Cells command.

How to fill empty cells

1. In the Xsheet view or Timeline view, select a cell range.
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2. Do one of the following:

‣ From the top menu, select Animation > Cell > Fill Empty Cells.

‣ In the Timeline View toolbar, click on the Fill Empty Cells  button.

Each drawing in the selection is exposed in the range of empty cells that follow it.

Creating Cycles
Once you have entered a series of drawings and exposures, you can create cycles out of them in 
several ways.

You can loop your drawings using the following commands:

• Paste Cycle

• Paste Reverse

• Create Cycle

When you create a drawing cycle, all of the repeated drawings are linked to the same original files. 
This means that when you modify, repaint, or correct a drawing named “1,” all drawings named “1” 
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are updated simultaneously. In order to modify a drawing independently from its other exposures, 
you must duplicate the drawing.

How to  create a cycle

1. In the Timeline view, select the cell range to loop.

2. In the Timeline View toolbar, click the Create Cycle  button (you may have to customize the 
toolbar to display it).

The Create Cycle dialog box opens.

3. Enter the number of cycles you want, including the current selection.

How to paste a cycle

1. In the Xsheet  or Timeline view, select the cell range to loop.

2. From the top menu, select Edit > Copy.

3. In the Xsheet  or Timeline  view, select the cell where you want your cycles to start.

4. Do one of the following:
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‣ From the top menu, select Edit > Paste Cycle. 

‣ Right-click and select Paste Cycle. 

‣ Press Ctrl + / (Windows/Linux) or ⌘  + / (Mac OS X).

The Paste Cycle dialog box opens.

5. Do one of the following:

‣ In the Number of Cycles field, enter the number of cycles you want to paste.

‣ Increase or decrease the number of cycles you want to paste.

6. In the Cycle Type menu, select the type of cycle you want to paste.

‣ Normal (forward): Pastes cycles as for all cycles, starting with the first cell of your selection 
and ending with the last.

‣ Reverse: Pastes cycles in the reverse order of the original selection, starting with the last 
cell of your selection and ending with the first one.

‣ Forward > Reverse: Pastes the first cycle in your selection as is, then the following one in 
reverse order. This repeated until all cycles are pasted.

‣ Reverse > Forward:  Pastes the first cycle in your selectionin reverse order, then the 
following one as is. This repeated until all cycles are pasted.

7. Click OK.

You can perform the same operation using the Paste Special dialog box. To open the Paste Special dialog 
box, select Edit > Paste Special or press Ctrl + B (Windows/Linux) or ⌘ + B (Mac OS X).    

How to paste a reversed cycle

1. In the Xsheet or Timeline view, select the cell range to paste in reverse order.
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2. From the top menu, select Edit > Copy.

3. In the Xsheet  or Timeline view, select the cell where you want your cycles to start.

4. Do one of the following:

‣ From the top menu, select Edit > Paste Reverse. 

‣ Right-click and select Paste Reverse. 

‣ Press Ctrl + . (Windows/Linux) or ⌘  + . (Mac OS X).
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Managing Drawings

Drawings that are created in Toon Boom Harmony are not stored in their cells. They are actual files 
stored in the project’s folder. If you want to rename a drawing or delete a drawing from your project, 
you need to edit the file and not the cells.

Throughout this chapter you might notice slight differences between your interface and the images used to 
demonstrate the procedure. This is because the images are taken from Harmony Stage. Draw is a subset of 
Harmony Stage.

This section is divided as follows:

• Renaming a Drawing below

• Deleting a Drawing on the next page

• Duplicating a Drawing on page 409

• Copying and Pasting Drawings on page 409

• Merging Drawings on page 412

Renaming a Drawing
To rename a drawing, you need to select the drawing cell and use the Rename Drawing command.

How to rename a drawing

1. In the Xsheet or Timeline view, select the drawing to rename.

2. Do one of the following:

In the Xsheet or Timeline View toolbar, click the Rename Drawing  button (you may have to 
customize the toolbar to display it).

‣ Press Ctrl + D (Windows/Linux) or ⌘  + D (Mac OS X).

The Rename Drawing dialog box opens.

3. In the New Name field, type in the new drawing name.

How to rename a drawing sequence with a prefix

You can rename a drawing sequence with a prefix, which can be quite useful for cut-out puppet 
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breakdown and deformation animation.

1. In the Xsheet or Timeline view, select your drawing sequence. Note that you can only select a 
drawing range in one column or layer at the time.

2. Right-click and select Drawings > Rename Drawing with Prefix.

The Rename Drawing with Prefix dialog box opens.

3. In the Prefix to Add field, type the prefix to add before the drawing name.

How to rename drawings by their frame position

You can rename a series of drawings relative to their frame position. This is useful in hand-drawn 
animation.

1. In the Xsheet or Timeline view, select the drawing sequence to be renamed.

2. From the top menu, select Drawing > Rename by Frame.

Deleting a Drawing
You can permanently delete a drawing file from a project's folder.

Deleting a drawing file is an operation that cannot be undone.
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How to delete a drawing

1. In the Xsheet  or Timeline view, select the drawings to delete.

2. Do one of the following:

‣ From the top menu, select Drawing > Delete Selected Drawings.

‣ Right-click and select Drawings > Delete Selected Drawings.

Duplicating a Drawing
If you want to modify a drawing that already exists, but keep the original drawing intact, you can 
duplicate the drawing and work on the copy. When duplicating a drawing, the selected cell is replaced 
with the new drawing. The exposure of the original drawing that was on the current cell is removed. 
The original drawing is not deleted from the project folder or other cells in which it is exposed.

With Toon Boom Harmony you can create a keyframe at the same time as you duplicate your drawing. 
This way you can modify and reposition drawings without affecting the original drawing.

How to duplicate a drawing

1. In the Xsheet or Timeline view, select the drawing to duplicate.

2. Do one of the following:

‣ From the top menu, select Drawing > Duplicate Drawing.

‣ Right-click  and select Drawings > Duplicate Drawings.

‣ In the Xsheet view toolbar, click the Drawing > Duplicate Drawing  button.

‣ Press Alt + Shift + D.

Copying and Pasting Drawings
When you copy and paste a selection in the Timeline or Xsheet view, you are not copying and pasting 
the actual drawings, you are pasting the exposure.
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If you want to copy and paste the selected drawings into a different layer or paste the selection in the 
same layer to duplicate the drawings, you must use the Paste Special feature.

There are three methods of pasting your selected drawings with the Paste Special dialog box:

• Never Create Drawing Files: Pastes all of your drawings as is. If there is a drawing in a cell, it is 
overwritten by the pasted selection.

• Always Create Drawings: Pastes all of your drawings as is, unless a pasted drawing has the 
same name as an existing one. In this case, the pasted drawing is duplicated and renamed.

• Only Create Drawings When They Do Not Exist: Pastes only the drawings that are named 
differently from existing drawings. If a drawing has the same name as an existing one, it is 
ignored and not pasted. This avoids the duplication of drawings in your layers.

This option is useful when you are pasting cut-out character templates containing drawings you 
may already have in your scene and some new ones. Using this option, you only paste the new 
drawings and are not duplicating all of the other parts you already have.

If you want to perform another Paste Special operation using the same settings you used previously, 
you can use the Paste Special Again command instead. You can paste your selection using the same 
settings as in the most recent Paste Special operation, without opening the Paste Special dialog box.

How to paste drawings with the Paste Special command

1. In the Xsheet or Timeline view, select the drawings to copy and press Ctrl + C (Windows/Linux) or 
⌘  + C (Mac OS X). 

2. In the Xsheet or Timeline view, select the cell where you want your pasted selection to start.

3. Do one of the following:

‣ Right-click and select Paste Special.

‣ From the top menu, select Edit > Paste Special.

‣ In the Xsheet  or Timeline View toolbar, click the Paste Special  button (you may need to 
customize the toolbar to display it).

‣ Press Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS X). 
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The Paste Special dialog box opens.

4. Select the Basic tab.

5. In the Drawings section, select an option: Always Create Drawings or Only Create Drawings 
When They Do Not Exist.

How to paste new drawings with the previous Paste Special settings

1. Do one of the following:

‣ From the top menu, select Edit > Paste Special Again.

‣ Right-click and select Paste Special Again

‣ In the Xsheet or Timeline view toolbar, click the Paste Special Again  button (you may 
have to customize the toolbar to display it).

‣ Press Ctrl + Shift  + B (Windows/Linux) or ⌘  + Shift + B (Mac OS X).
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Merging Drawings

There are two methods of merging drawings. 

• You can merge selected drawings in adjacent elements. The columns and layers will be left 
intact, and each new merged drawing will reside in the frames of the left-most column or lower 
layer.

• You can merge elements. All drawings will be merged. Unused columns and layers will be 
deleted, but the original drawing files are still accessible.

How to merge selected drawings

1. In the Xsheet view, select the drawings you want to merge.

2. Do one of the following:

‣ In the Xsheet View menu, select Columns> Merge Selected Drawings.

‣ In the Timeline View menu, select Layers > Merge Selected Drawings.
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3. Do one of the following:

‣ In the Xsheet View menu, select Columns > Merge Selected Columns.

‣ In the Timeline View menu, select Layers > Merge Selected Layers.

In the Xsheet view, the right-most column will contain the merged drawings and the remaining 
columns will be left blank at the corresponding frames. In the Timeline view, the bottom timeline 
layer will contain the merged drawings from all layers and the other layers will be left blank at the 
corresponding frames. Drawings are not deleted and are still accessible.

How to merge drawings in entire layers or columns

1. Do one of the following:

‣ In the Timeline view,select the layers you want to merge.

‣ In the Xsheet view, Shift-click the headers of the columns you want to merge.

2. Do one of the following:

‣ In the Xsheet View menu, select Columns > Merge Selected Columns.

‣ In the Timeline View menu, select Layers > Merge Selected Layers.
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In the Xsheet view, the right-most column will contain the merged drawings and the other columns 
will be deleted. In the Timeline view, the bottom timeline layer will contain the merged drawings 
from all layers and the other layers will be deleted. Drawings are not deleted and are still accessible.

Modifying the Layer and Column Display
You can change the way a layer in the Timeline view or a column in the Xsheet view display. You can 
stay organized without changing the content of elements or your animation output.

This section is divided as follows:

• Expanding and Collapsing Layers and Columns below

• Showing and Hiding Layers on the facing page

• Showing and Hiding Columns on page 417

• Modifying the Look of the Column on page 419

• Xsheet Thumbnails on page 423

• Changing the Colour of a Layer or Column on page 424

• Setting Scene Markers on page 425

• Setting Tempo Markers on page 429

Expanding and Collapsing Layers and Columns
To simplify the look of the Xsheet or Timeline view, you can expand and collapse your timeline layers 
and 3D columns. If some timeline layers are parented to other ones, you can collapse the parent layer 
to hide its children.   

How to collapse or expand a layer selection in the Timeline view

1. In the Timeline view, select the layer(s) to collapse or expand.

2. Do one of the following:

‣ Right-click on the selection and select Collapse/Expand > Collapse/Expand. 

‣ Click the Expand Children Arrow  button on the parent layer.

‣ Press  Ctrl + I (Windows/Linux) or ⌘  + I (Mac OS X).

‣ Click the Collapse/Expand  button  (you may have to customize the toolbar to display it).
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‣

How to collapse or expand all layers in the Timeline view

1. Do one of the following:

‣ Right-click on the layers and select Collapse/Expand > Expand All or Collapse All.

‣ In the Timeline View toolbar, click the Collapse All  or Expand All  buttons (you may 
have to customize the toolbar to display them).

‣ Press 0 and 9.

How to collapse and expand 3D path or rotation columns in the Xsheet view

2. In the Xsheet view, select the column header of the 3D path or 3D rotation column to collapse or 
expand.

3. Do one of the following:

‣ Right-click on the column’s header and select Expand/Collapse > Collapse Selection or 
Expand Selection.

‣ In the Xsheet View toolbar, click the Collapse Selection  or Expand Selection  
buttons (you may have to customize the toolbar to display it).

How to collapse or expand all 3D path and 3D rotation columns in the Xsheet view

Do one of the following:

‣ Right-click on any column’s header and select Expand/Collapse > Expand All or Collapse 
All.

‣ Press 0 and 9.

‣ In the Xsheet View toolbar, click the Collapse All  or Expand All  buttons  (you may 
have to customize the toolbar to display it).

Showing and Hiding Layers
As you work in the Drawing or Camera view, some layers may be in the way or are used as references. 
You can hide these layers to make your work area less cluttered and easier to navigate. You can show 
and hide layers in the Timeline view in several different ways.

How to show or hide all layers

1. Do one of the following:

‣ In the Timeline View toolbar, click the Enable All  button (you may have to customize the 
toolbar to display it).

‣ In the Timeline view’s Layer toolbar, click the Enable/Disable All  button to show or hide all 
layers. 
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How to show or hide individual layers

1. Do one of the following:

‣ In the Timeline View toolbar, click the Enable/Disable  button (you may have to customize the 
toolbar to display it).

‣ On the right side of the Timeline view, select or deselect the layer’s checkbox. 

When you deselect a layer in the Timeline view, the corresponding column is hidden in the Xsheet 
view.

How to enable the selected layer and disable all others

1. Do one of the following:

‣ In the Timeline View toolbar, click the Disable All Others  button (you may have to customize 
the toolbar to display it).

‣ In the Timeline view’s Layer toolbar, click the Show Selection and Hide All Others  button.

In the Timeline view, you can hide or show certain types of layers such as Group and Effect. 

How to show and hide layer types in the Timeline view

1. Do one of the following:

‣ From the Timeline View menu, select View > Show > Show Manager.

‣ You can also select View > Show > Show Sounds, Show Effects or Show Groups to 
immediately show or hide the selected type. This option will remain only for the current 
session. When you close and reopen Harmony, the default settings will return.

The Show Manager dialog box opens.

2. Select the types of layers you want to display and deselect the ones you want to turn off.

3. Click Set As Default to make these new settings the default ones that will be used each time to 
start the application. Click Restore Default to restore the settings used when installing the 
application.
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In the Xsheet view, you have the choice of hiding or showing certain types of columns such as 
Annotation and Functions.

Showing and Hiding Columns
The Xsheet view has a Column List section that can display all the columns contained in the exposure 
sheet. It can be used to hide individual columns.

If you need to see a column after it has been hidden, you can display it directly from the Xsheet view 
without using the Column List section.

You can also hide an entire column type, such as Drawing or Sound.

When a column is hidden in the Xsheet view, the corresponding layer is disabled in the Timeline view.

How to show a hidden column in the Xsheet view

1. In the Xsheet view menu, click on the thick grey line that represents a hidden column. You can also 
right-click on the column header and select Show Hidden Columns.

The Show Hidden Columns dialog box opens.

2. In the Show column, select the hidden columns you want to display in the Xsheet view.

‣ Click Check to select all the selected columns.

‣ Click Uncheck to deselcted all selected columns.

How to show all columns

‣ In the Xsheet view menu, select View > Unhide All Columns.

How to show and hide column types

1. In the Xsheet view, select View > Column Types Manager.

The Column Types dialog box opens.
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2. Select the types of columns you want to display and disable the ones you want to hide.

3. Click Set As Default if you want to make these new settings the default ones that will be used each 
time to start the application.

4. Click Restore Default if you want to restore the settings used when installing the application.

How to show or hide Xsheet columns using the Column List

5. On the right side of the Functions section, click the Expand  button to display the Column List 
section.

6. In the Column List section, select the columns to display and deselect the columns to hide. 

How to show or hide an Xsheet column type using the Column List

1. In the Column List section, click the button corresponding to the type you want to show or hide.

Column Type but-
ton 

Action

Show/Hide All Columns

Show/Hide Drawing Columns

Show/Hide Function Columns

Show/Hide 3D Path Columns

Show/Hide Sound Columns
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Show/Hide 3D Rotation Columns

Show/Hide Annotation Columns

How to show or hide function columns on the left side of the Xsheet view

1. Right-click on a column and select Tag > Function Columns Visible or Function Columns 
Invisible.

Modifying the Look of the Column
In Harmony, you can modify the way the column displays drawings, empty cells and the column width.

You can modify the following elements:

• Empty cells

• Row units

• Held exposure

• Column width

How to modify the look of empty cell

1. From the Xsheet View menu, select View > Empty Cells > With an “X” or Blank.

How to modify row units

1. From the Xsheet View menu, select View > Row Units > Frames or Feet.
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How to modify the look of a held exposure

‣ In the Xsheet View menu, select View > Held Exposures > Line or Value.

How to modify column width

1. In the Xsheet view, select any column to modify the width.

2. From the Xsheet view menu, select View > Set Columns Width.

The Xsheet Column Width dialog box opens.

3. In the Column Width field, enter the desired width in pixels.

4. To end the operation:

‣ Click OK to validate and close the dialog box.

‣ Click  Apply to validate the operation and keep the dialog box opened to adjust the next 
column’s width.

‣ Click  Set As Default to create all the new columns to this width.

‣ Click  Close to cancel the operation.

5. To restore all columns to the default value, in the Xsheet View menu, select  All Columns to 
Default Width.

Drawing Identification
In the Xsheet view, you can identify drawings as Key, Breakdown or In-between. This helps to keep the 
Xsheet well organized while animating.

When working with several animators, directors, or even other studios, the necessity for retakes will 
often arise. Harmony also gives you the possibility to mark new drawings as either Retake Key, Retake 
Breakdown, or Retake Inbetweens.

If your production requires you to mark drawings with a custom marker, you also have the option to 
create your own.

Make custom marks for the Xsheet by creating your own icons, then cutting, pasting and changing a 
bit of code. Not only is it possible to have your custom mark appear in the Xsheet and Mark Drawing 
toolbars, but also in the Onion Skin and Flip toolbars.
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You can create custom shortcuts for the Drawing Identification options in the Preferences dialog box.

How to mark a drawing as Key, Breakdown or In-between

1. From the top menu, select Windows > Toolbars > Mark Drawing. 

The Mark Drawing toolbar displays.

2. In the Xsheet view, select the cell you want to identify. This option is not available in the Timeline 
view.

3. In the Mark Drawing toolbar, click one of these buttons: Mark as Key Drawing , Mark as 
Breakdown Drawing  or Mark as In-between Drawing . In the Xsheet View menu, you can 
also select Drawing > Mark Drawing As > Key Drawing, Breakdown Drawing, In-between 
Drawing, Retake Key, Retake BD and Retake IB.

‣ If you selected Mark as Key Drawing, a  icon appears in the cell.

‣ If you selected Mark as Breakdown Drawing, a  icon appears in the cell.

‣ If you selected Mark as In-Between Drawing, there is no icon displayed in the cell since it is 
used to remove a Key or Breakdown marker.

421



Chapter 13: Timing     Merging Drawings

How to create custom markers

1. With a bitmap editing software, create the following icons in PNG format:

‣ Mark Drawing Toolbar icon (24 x 24 pixel)

‣ Onion Skin Toolbar icon (24 x 24 pixel)

‣ Flip Toolbar icon (24 x 24 pixel)

‣ Xsheet Column icon (16 x 16 pixel)

2. Close Harmony.

3. When your icons are ready, open the Toon Boom Harmony drawingTypes.d folder. 

If the drawingTypes.d folder does not exist, you must create it. To do so, copy the 
resources folder from the following location.

• Windows: C:/Program Files (x86)/Toon Boom Animation/Harmony 
11.1/resources/drawingTypes.d

• Mac OS X: /Applications/Harmony 11.1/resources/drawingTypes.d

• Linux: 
/usr/local/ToonBoomAnimation/ProductNameVersion/resources/drawingTypes.d

Stand-alone
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‣ Windows: C:\Users\USERNAME\AppData\Roaming\Toon Boom Animation\Toon 
Boom Harmony\full-1100-pref\drawingTypes.d

‣ Mac OS X: /Users/USERNAME/Library/Preferences/Toon Boom 
Animation/Toon Boom Harmony/full-1100-pref/drawingTypes.d

The Library folder is usually hidden in the Finder. To see all the hidden folders and files, 
type the following in a terminal window:

defaults write com.apple.Finder AppleShowAllFiles YES

‣ Linux: /home/USERNAME/Toon Boom Animation/Toon Boom Harmony/full-
1100-pref/drawingTypes.d/

Network

In Harmony Network, the path is global for all users so you must create the folder and place in 
/USA_DB.

‣ /USA_DB/drawingTypes.d

4. Paste your icons in the drawingTypes.d directory.

5. In the same directory, open the drawingTypes.xml file in a text editor.

6. For each custom icon you want to create, add the following line. Make sure to place it before this 
closing tag: </DrawingTypes>.

‣ <DrawingType text="NewButtonName" pixmapFile="XsheetIcon.png" 
commandIcon="MarkDrawingIcon.png" flipIcon="FlipIcon.png" 
onionIcon="OnionIcon.png" />

7. In that line, replace the following information with your new icon information:

‣ NewButtonName: Write the name of your new marker. This name will appear in the button 
tooltip.

‣ XsheetIcon.png: Write the name of the icon that you created to appear in the Xsheet 
column. Include the file extension.

‣ MarkDrawingIcon.png: Write the name of the icon that you created to appear in the Mark 
Drawing toolbar. Include the file extension.

‣ FlipIcon.png: Write the name of the icon that you created to appear in the Flip toolbar. 
Include the file extension.

‣ OnionIcon.png: Write the name of the icon that you created to appear in the Onion Skin 
toolbar. Include the file extension.

8. Save the file and close it.

9. Start Harmony.

Xsheet Thumbnails
When there are a large number of columns in the exposure sheet, it is not always easy to quickly 
identify a particular column. Displaying the column thumbnails makes this easier. This option displays a 
small thumbnail picture of the current frame below the column header.
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How to display the thumbnails

1. In the Xsheet view, select View > Show Thumbnails. 

The thumbnails appear.

Changing the Colour of a Layer or Column
To easily identify elements in the Timeline or Xsheet view, you can change the colour of layers and 
columns. 

How to change the layer’s colour in the Timeline view

1. Do one of the following:

‣ In the Timeline view, click the colour swatch of the layer you want to modify. 

2. In the Select Colour dialog box, select a new colour for your layer.

3. Click OK.

The layer’s background colour is updated. In a Drawing layer, exposed cells are the brighter, 
selected colour for easy identification. The corresponding column colour is also updated.
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How to reset a layer’s colour in the Timeline view

1. In the Timeline view, select the layers to reset.

2. In the Timeline View toolbar, click the Default Track Colour  button (you may have to customize 
the toolbar to display it).

How to change a column’s colour in the Xsheet view

1. In the Xsheet view, select one or more columns to modify.

2. Right-click on the column’s header and select Colour > Change Columns Colour.

3. In the Select Colour dialog box, select a new colour for your columns.

4. Click OK.

The column’s colour is updated. The corresponding column colour is also updated.

How to reset the column’s colour in the Xsheet view

1. In the Xsheet view, select the columns to reset.

2. Right-click on the column’s header and select Colour > Default Columns Colour.

Setting Scene Markers
Scene markers are visual indicators displayed at the top of the timeline in the frame counter area. You 
can use it to denote anything relevant to your work. You can indicate at the frames you want to clean 
up, a change in action, an impact, or where you intend to apply an effect. You can also add a note to a 
scene marker, which is displayed when you hover over the scene marker.

There are two ways to add a scene marker. You can make a frame range selection and mark that 
whole section or simply mark the current frame.
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How to mark the current frame

1. In the Timeline view, make sure the playhead is set on the frame you want to mark. Even if you 
right-click on a different frame, the scene marker will be created on the current frame, which means 
where the red playhead is.

2. Right-click in the frame counter area and select Scene Markers > Mark Current Frame.

The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or 
the colour of the last scene marker you created.

3. Double-click the Colour box to select a colour for your scene marker.

4. In the Note field, enter text to display a tooltip.

5. Click OK.

6. In the Timeline view, the scene marker is displayed at the current frame.  Hover over the scene 
marker to display its note as a tooltip.

How to create a scene marker on a frame range

1. In the Timeline view frame counter, select the frame range on which you want to mark your scene.

2. Right-click and select Scene Markers.
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The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or 
the colour of the last scene marker you created.

3. Click the colour swatch and select a colour for the scene marker.

4. In the Note field, enter text to display as a tooltip.

5. Click OK.

6. In the Timeline view, the scene marker is displayed over the selected frame counters. Hover over 
the scene marker to display its note as a tooltip.

How to edit a scene marker

If you select only a part of a scene marker, you will not open the scene marker for editing. You will only be 
able to create a new scene marker to overwrite it.

1. In the Timeline view frame counter, select the entire scene marker.

2. Right-click the selection and select Edit Scene Marker.

The Timeline Scene Marker dialog box opens.
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3. Make your changes.

4. Click OK.

How to delete a scene marker

1. In the Timeline view frame counter, at least one frame counter in the scene marker you want to 
delete.

2. Right-click the selection and select Delete Scene Marker.
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Setting Tempo Markers

Tempo markers are used to synchronize your animation with a musical score. This lets you reproduce 
the FPB (Frames Per Beat) and use the tempo signature as tempo markers. The Xsheet view allows 
you to pace your animation according to the tempo or beat of the soundtrack music or to any rhythmic 
sound, such as the ticking of a clock or water leaking from a spout.

How to set the tempo markers

1. In the Xsheet View menu, select View > Set Tempo Marker or in the sound column, right-click and 
select View > Set Tempo Marker.

The Tempo Marker dialog box opens.

2. Reproduce the tempo and beat value of your music or sound for the Xsheet view marker display.

‣ Starting Frame: Enter the number of the frame where you want the tempo markers to 
begin.

‣ Frames/Beat: Set the frames per beat value. This will determine the frequency (in frames) in 
which a beat marker will appear. Keep in mind that, by default, 24 frames represent 1 
second.

‣ Beat/Bar: Set the tempo of your music or sound. This will determine the frequency (in beats) 
in which a tempo marker will appear in the Xsheet view.

3. Click OK.
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Printing the Xsheet

Once you have marked all the information, corrections, and timing you want in the Xsheet view, you 
can print your exposure sheet. Printing the Xsheet allows you to take it with you to your animation 
table or give a copy to the animator. You can also use it to create your Xsheet skeleton directly in 
Harmony.

How to print your exposure sheet

1. Select File > Print > Xsheet.

The Print dialog box opens.
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2. To set up your print:

‣ Windows: In the Select Printer section, select your printer and adjust the rest of the printing 
settings. 

‣ Linux: In the Print Destination section, select your printer and adjust the rest of the printing 
settings. 

‣ Mac OS X: In the Printer section, select your printer and adjust the rest of the settings by 
clicking on the Parameters  button. You can also click  PDF and select an option from the 
menu if you want to save a PDF version of your exposure sheet. 

Refer to your printer user guide to learn more about its options.

3. Do one of the following:

‣ Windows and Mac OS X: Click Print. 

‣ Linux: Click OK.
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Chapter 14: Paperless Animation

Toon Boom Harmony is a powerful paperless animation software that incorporates animation and 
drawing tools to make your work easier and more efficient.

Although it is a digital process, paperless animation is still hand-drawn and the fundamental principles 
of animation still apply. 

One of the advantages of working with paperless animation is that you do not lose time scanning 
elements in and testing them because everything is already digital. You can simply draw your 
animation and play back your line test right away. This also saves the substantial amount of paper 
required by traditional animation. Another practical advantage is the ability to undo and redo some 
actions that are often difficult on paper, such as erasing brush strokes. 

This chapter is divided as follows:

• Preparation on page 435

• Rough Animation on page 449

• Secondary Animation on page 453

• Bringing Your Animation on Model on page 457

• Animation Clean-up on page 459

• Tools on page 465

• Advanced Tools on page 481

• Paperless Animation Preferences on page 507
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Preparation

To prepare for paperless animation with Harmony, you will need to complete the following tasks. 

• Setting Up Your Workspace below

• Setting the Scene Resolution and Length below

• Importing the Layout, Storyboard and Animatic on page 437

• Importing the Background Elements on page 440

• Creating the Drawing Elements on page 440

• Importing the Models on page 442

Setting Up Your Workspace
To sketch the animation directly in Harmony, you will mostly frequently need the Camera or Drawing 
view, the Xsheet or Timeline view, and the Tool Properties and Colour views. 

While drawing and animating paperless animation, you can use the Workspace Manager to save a 
frequently used layout and name it Paperless Animation, for example.

For more information on setting up your workspace, refer to Chapter 2: Interface in the Fundmentals 
Guide.

Setting the Scene Resolution and Length
If the scene resolution was not already set by the digital layout artist or by a Toon Boom Storyboard 
Pro import, it is the next step to be accomplished. The layout artist, scene planner or animator will 
often take care of this task prior to the animation when working with paperless and cut-out animation.

How to set the resolution and frame rate

1. From the top menu, select Scene > Scene Settings.

The Scene Settings dialog box opens.

2. Choose a resolution from the list or enter a new one.
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3. Set your frame rate.

4. Click OK.

It is important to set the resolution before you begin to set positioning and camera moves, as it may affect 
the ratio and composition.

Once you have set the resolution and frame rate, you must set the scene length by adding the right 
number of frames to the scene. You can set the scene length from the top menu. If you do not yet 
know the number of frames that will be needed, simply add some frames so you can draw different 
poses. However, if you only need to draw a background and one pose, you do not need to add more 
frames.

You do not need to do this step if you are importing your animatic in the QuickTime movie file 
format. The QuickTime import feature takes care of the scene length at the same time as the movie 
import.

How to set the scene length

1. From the top menu, select Scene > Scene Length.

The Set Scene Length dialog box opens.
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2. Type the scene duration in the Number of Frames field.

3. Click OK.

Importing the Layout, Storyboard and Animatic

To animate a scene, you need to import your layout, storyboard or animatic, depending on which 
technique you are using. The most popular method is the animatic.

If you created a digital layout prior to the scene animation, you will animate directly in that scene. In 
this case, there is no need to import references since they are already there.

Importing the Animatic

If you have an animatic available, you can import it. The animatic will give you the right timing to 
expose your animation poses. 

There are three ways to import an animatic in a scene.

How to import a QuickTime animatic 

Toon Boom lets you import QuickTime movie files in the scene, cut them as image sequences and 
import the sound as an independent soundtrack. 

1. From the top menu, select File > Import > Movie.

The Select QuickTime Movie window opens.
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2. Browse to your animatic.

3. Click Open.

4. The Import Movie window displays the conversion progress.

When the conversion is complete, the Import Images dialog box opens.

5. Click  OK.
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How to import an image sequence animatic

You can also import an animatic composed of a sequence of bitmap images that were created in a 
third-party software by using the Import Images feature.

Use the same technique to import layouts and poses that were created on paper and scanned in 
third-party software.

1. From the top menu, select Import > Images.

2. The Import Images dialog box opens.

3. Click OK.

How to import a Toon Boom Storyboard Pro animatic

If the animatic was created with Toon Boom Storyboard Pro, you need to create an Export to Toon 
Boom function from that software. This will create your scenes and import your layout and posing 
and camera moves. This must be done at the beginning of the production. When you work in 
Harmony, use the same technique as you would in any QuickTime animatic.

If your project was created using Toon Boom Storyboard Pro, the animatic and camera moves are 
already set in your scene and you can go ahead and import the background elements.
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Importing the Background Elements

Once the layout or animatic is set, you can import the background elements. 

There are two types of background elements you can import: bitmap and vector-based.

Bitmap background

You can import external bitmap background elements to your scene using the Import Images dialog 
box. Be sure to deselect the Convert to Toon Boom Vector Drawing option to retain your elements 
as bitmaps and preserve your colours.

To import a bitmap background, follow the  procedure to import an image sequence animatic—see 
Importing the Animatic on page 437. For in-depth information on importing bitmap images, refer to 
Chapter 7: How to Import Bitmap Images in the Getting Started Guide.

Vector-based background

If your background was painted using Harmony, it can be imported via the Template Library or with 
the Import Images dialog box. Select the Convert to Toon Boom Vector Drawing option since it is 
already a vector-based image.

If your background was created with a third party vector-based software, you can import it via the 
Template Library.

The external vector based formats supported are:

• AI

• PDF

• SWF

Creating the Drawing Elements
Before beginning to draw in the Camera or Drawing view, you must add a drawing element to the 
Xsheet or Timeline view. You will also need to select the appropriate cell in your drawing element. 
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How to add a drawing element from the top menu

1. From the top menu, select Insert > Drawing.

The Add Drawing Layer dialog box opens.

2. In the Name field, type a relevant element name.

3. Click  OK.

The new drawing element appears in the Timeline, Xsheet and Network views.

How to add a drawing element from the Timeline view

1. Do one of the following:

‣ In the Timeline View menu, select Insert > Drawing. 

‣ In the Timeline view toolbar, click the Add Layers  button. 

‣

‣ Press Ctrl + R (Windows/Linux) or ⌘  + R (Mac OS X).

The Add Drawing Layer dialog box opens.

2. In the Name field, enter a relevant element name.
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3. Do one of the following:

‣ Click OK to add the layer and close the dialog box.

‣ Click Apply to add the layer and keep the dialog box open to add another layer.

‣ Click Close to cancel the operation.

The new drawing element appears in the Timeline and Xsheet Views.

To learn more about creating new elements, see See "Adding New Drawing Elements" on page 365.

Importing the Models
In order to animate your characters and props, you must load the colour models and their 
corresponding palettes. 

Harmony makes good use of palettes. Each character can have his or her own colour palette with its 
own set of colours that can be reused in all the scenes. Each zone (for example, the shirt, eyes, shoes, 
and hair) can have its own colour swatch stored in the colour palette. Once the zone is painted with its 
corresponding colour, the zone and the colour are linked throughout the entire scene.

There is no need to repaint each zone individually. If you modify the colour after the painting process, 
all the corresponding zones in all  drawings and all  layers are changed simultaneously.

To learn more about palettes, see Working with Palettes on page 271. 

Prior to the paperless animation process, the colour stylist creates the palettes and models and stores 
them in templates or colour model scenes.
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To learn about creating colour models, see Colour Styling and Colour Models on page 265.

Importing Model Templates

Once the model templates are created, you are ready to import them into the scene. From the Library, 
import the appropriate templates to make the models and their palettes available in the scene. 

From there, you can:

• Load the palettes in the proper drawing element and

• Load the drawing models to the Model view.

There is no need to obtain the right to modify the Library in order to import a template.

How to import a model template

1. Open the Template Library.

2. In the Template Library, select the colour model storage folder.

3. Select the colour models you need and drag them to the Network or Timeline view. 
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‣ To create new layers and modules, drop the selection on the left side of the Timeline view.

‣ To insert the information into pre-existing layers, drop the selection on the right side of the 
Timeline view. In order for the template to combine with existing layers, the structure needs 
to be consistent. If you cannot merge the layers together, create new layers on the left side 
of the Timeline view.

When you import a template into a scene, there is no link between the Library and the scene. 
Instead, a copy of all elements is created, such as drawings, effects, and trajectories. You can modify 
anything copied in your scene.

Loading Palettes and Models

By importing the model templates in the scene, you have created a new drawing element. This also 
saves the master palettes in your scene. These palettes are local to the scene.

The first step is to load your model in the Model view. You will then have to load the palette in your 
animation column.

How to load the current drawing in the Model view

1. In the Timeline or Xsheet view, select the model's cell.

2. Do one of the following:

‣ From the Model view menu, select Use Current Drawing as Model.

‣ Right-click on the Model view and select Use Current Drawing as Model.
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The model appears in the Model view.

Once your model is loaded, you can import palettes in the animation column/layer.

If you are animating a character or prop, it is always a good idea to use its proper palette for 
drawing, especially if you need to use different colours to clean the drawing outlines. This will save 
the colourist from having to load the palette and repaint with the correct colours.

How to add a palette to your element

1. In the Timeline view or Xsheet view, select the cell in the drawing element that you plan to animate.

2. Do one of the following:

‣ From the Colour view menu, select Palettes > Link.

‣ Click the Link Palette  button.

The Palette Browser window opens.
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3. Select the level in which the palette file is stored (usually Element or Scene).

4. Select the palette from the list.

5. Click  OK.
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Creating the Drawings

Once your drawing elements have been created and your palettes are loaded, you are ready to create 
drawings for your animation. But before creating the drawings, you should familiarize yourself with the 
following operations.

There are two different ways to create drawings. You can create drawings automatically by letting 
Harmony do it for you or by typing names (Typing mode) in the Xsheet cells.

How to automatically create a drawing

1. From the Timeline or Xsheet view, select the appropriate cell and start drawing in the Camera or 
Drawing view. 

Harmony creates the drawing and names it using the next available number. If there is no existing 
drawing, then it will be named "1", then "2"  and so on—see Paperless Animation Preferences on 
page 507 to learn more about the Use Current Frame As Drawing Name option.

How to create a drawing using the Typing mode

1. To insert a drawing name in a column cell, double-click on the cell and type the name using 
alphanumeric values: 0-9, a-z, underscore (_) and dash (-). By default, if you press the 
Enter/Return key, the cursor will move on to the next cell. If you press the Esc key, it will quit the 
typing mode and return to normal mode—see See "Typing Exposure" on page 386 to learn more 
about the Typing mode.

Drawing Concept

When you add a drawing element to your scene, a folder is automatically added to the scene 
directory. This folder is named the same as the drawing element. Its purpose is to store all the 
drawings related to this drawing element. For example, when working with cut-out animation, a 
character can have many hands available. All of these hand drawings will be contained in this folder 
even if they are not exposed in the Timeline or Xsheet view. In other words, there is always a drawing 
container associated with a drawing element (layer, column).

All the drawings that were scanned in or created directly in Harmony will be saved in this directory. 
This means that when a value or drawing name is entered in the column, the Harmony will search the 
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directory for the corresponding drawing to display. If it is unable to find it, a new drawing will be 
created. The column cells are not storage places, but simply links to the corresponding directory. If 
you remove a drawing from the column exposure, it will not be deleted; it is simply not displayed. 
You can always access it again.

When you create a drawing cycle, all repeated drawings are linked to the same original files. So when 
you modify, repaint or correct drawing 1, the entire cycle will be updated; every time drawing 1 
appears, it is accessed from a single file.

Renaming a Drawing

When you want to rename a drawing, use the Rename Drawing command. Do not double-click on 
the frame and write a new name, as this will create a new drawing and hide your actual drawing. 
Note that your drawing will not be deleted; it is still contained inside the element folder. Simply re-
enter the name and it will reappear.

To learn how to rename a sequence of cells by prefix or by frame position, see See "Renaming a Drawing" 
on page 407.
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Rough Animation

The first step to complete a traditional paperless animation is the rough construction, which is the 
skeleton of your animation. You would usually start with the main action. For example, to animate a 
walk cycle, you will start with the torso motion and the legs. Head, arms and clothes will be added 
later during the secondary animation.

For a satisfactory animation, complete the main action before adding all the details. If you start 
animating all the details right away, you will lose a lot of time if you have to make corrections. Your 
animation will often look too rigid.

How to animate

1. Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X) to open the Preferences dialog box. 

2. Select the Exposure Sheet tab. 

3. Select the Use Current Frame as Drawing Name option. When this preference is enabled, 
drawings will be named like the frame they are created on (frame number).

4. In the Tools toolbar, select the Brush  tool or press Alt + B.

5. In the Colour view, select a colour for the brush. It is a good idea to choose a light colour for your 
rough animation. This will help you in the task that follows, the clean up process.

6. In the Timeline or Xsheet view, select the cell where the first drawing will appear.

7. In the Camera or Drawing view, draw the first key drawing.
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8. With your first cell still selected, do one of the following to mark your drawing as a key drawing. 
This will help you stay organized.

‣ In the Mark Drawing toolbar, click the Mark Selected Drawings as Key  button.

‣ In the Xsheet view, select Drawings > Mark Drawing As > Key Drawing.

‣ In the Timeline view, select Drawings > Mark Drawing As > Key Drawing.

9. In the Tools toolbar, click the Onion Skin  button. The Onion Skin feature displays your previous 
and next drawings as visual references to help you draw your new pose.

10. In the Timeline view, click and drag the blue onion skin markers to extend the number of previous 
and next visible drawings.

11. In the Timeline or Xsheet view, select the cell where your next key drawing will appear.

12. In the Camera or Drawing view, draw your second key drawing.
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13. In the Xsheet or Timeline view, identify the drawing as a key drawing.

14. In the Xsheet view, select a cell between the two key drawings.

15. From the Timeline View toolbar, click  to create an empty drawing or press Alt + Shift + R.

‣ In the Xsheet view, right-click and select Drawings > Create Empty Drawing or press Alt + 
Shift + R.

16. In the Camera or Drawing view, draw your new pose.
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17. If necessary, in the Xsheet or Timeline view, identify the new drawing as a key, breakdown or in-
between drawing using the Mark Drawing toolbar.

18. In the Timeline or Xsheet view, select a new cell and repeat the previous steps for each new 
drawing.

19. In the Timeline view, disable the layers you do not want to show during playback by disabling the 
check box.

20. In the Playback toolbar, click the Loop  button if you want the playback to loop.

21. In the Playback toolbar, click the Play  button to start the animation.
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Secondary Animation

Once your rough animation  is correct, you can start adding extra details, such as arms, clothes or hair.

You can add the extra details on the same layer with the same colour or you can also create a new 
colour so that you can always see your original sketch.

If you want to keep your rough animation as it is to avoid any mistakes, you can add an extra drawing 
element and use the Light Table feature to draw over the first drawing element. This technique can also be 
used if you want to reuse your rough animation for other characters. For example, if you have a rough walk-
cycle, you can reuse it for another character and add its personal features in a new layer. This way, you only 
need to animate the secondary animation instead of the whole body again.

How to create secondary animation on the same layer

1. In the Xsheet View, select the cell in which you want to add new details.

2. In the Colour view, create a new colour  (give it the same name and add the prefix _2 or _sec, for 
example) or select the same rough colour as before.

3. In the Drawing Tools toolbar, select your drawing tool.

4. In the Camera or Drawing view, draw the secondary animation.
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5. Do one of the following:

‣ In the Xsheet View, select the next cell in which you want to draw.

‣ In the Camera, Drawing or Xsheet view, press F and G to navigate between your drawings.

6. Do one of the following:

‣ In the top, Drawing View or Camera View menu, select View > Onion Skin > Show Onion 
Skin.

‣ In the Timeline view menu, select Onion Skin > Show Onion Skin.

‣ Press Alt + O.

7. Extend the onion skin.

8. In the Camera or Drawing view, draw the secondary animation.

9. Use the Flip and Easy Flipping toolbars to review your animation. You can also use the Playback 
toolbar to play the animation in real time.

How to create your secondary animation on an extra layer

1. In the top menu, Xsheet view or Timeline view, add a new drawing element and name it properly.

2. In the Timeline or Xsheet view, select the rough layer's timing.

3. Copy the timing and in the top menu, select Edit > Paste Special or Ctrl + B (Windows/Linux) or ⌘  
+ B (Mac OS X).

4. Choose Never create drawing files from the options to paste the timing but not the drawing files.
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5. In the Drawing view, enable the Light Table.

6. Do one of the following:

‣ In the Xsheet view, click the Columns List Panel  button to view and disable columns. 

‣ In the Timeline view, on its left-hand side, disable the extra columns.

 

7. In the Xsheet View, select the cell where you want to add the new details.

8. In the Colour Palette, create a new colour  (give it the same name and add the prefix _2 or _sec, for 
example) or select the same rough colour as before.

9. In the Drawing Tools toolbar, select your drawing tool.

10. In the Drawing or Camera view, draw the secondary animation.

11. Do one of the following:

‣ In the Xsheet View, select the next cell in which you want to draw.

‣ In the Camera, Drawing or Xsheet view, press F and G to navigate between your drawings.

12. Do one of the following:
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‣ In the top, Drawing View or Camera View menu, select View > Onion Skin > Show Onion 
Skin.

‣ In the Timeline view menu, select Onion Skin > Show Onion Skin.

‣ Press Alt + O.

13. Extend the onion skin.

14. In the Camera or Drawing view, draw the secondary animation.

15. Use the Flip and Easy Flipping toolbars to review your animation. 

 

You can also use the Playback toolbar to play the animation in real time.
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Bringing Your Animation on Model

If your primary and secondary animation were done as a rough drawing, it is now time to put your 
drawing on model. This means that you have to review your animation and ensure that every single 
detail is on model and there is no volume distortion. You can do this directly on the original sketch 
layer or on a new layer.

If your primary and secondary animation was done quite on model, you can proceed directly to the 
animation clean-up. If not, proceed the same way as you did for the secondary animation task to bring 
your animation on model.

457



Toon Boom Harmony 11.1 Draw Guide (Network)

458



Toon Boom Harmony 11.1 Draw Guide (Network)

Animation Clean-up

When your rough animation is ready, it is time to clean it up and ink it. The clean-up is also called 
tracing. It consists of tracing solid and clean lines over the rough animation to get closed zones. This is 
the final paperless animation step before the ink and paint step.

You will need to add a new drawing layer to create your cleaned up drawing. This is the equivalent of 
adding a sheet of paper and tracing the rough using the animation disk.

Tracing in a New Layer

If you plan on tracing your animation in the Drawing view, enable the light table to display all the layers in 
your project.

How to trace your animation in a new layer

1. In the Timeline View toolbar, click the Add Drawing Layer  button.

2. In the Timeline view, click the Lock button of the layer containing your rough animation to avoid 
selecting the layer in the Camera view.

3. In the Timeline or Xsheet view, in the new layer, select the cell corresponding to the first key 
drawing of your rough animation.

4. In the Tools toolbar, select the drawing tool of your choice. The Pencil  tool is recommended.

5. In the Colour view, select a colour for tracing your animation. A dark bold colour, such as black, 
would ensure that it contrasts well with the light colour of your rough animation.

6. In the Camera or Drawing view, start tracing the first key drawing.
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     Animation Clean-up

7. If you have some other layers in the way, you can disable them temporarily from the Timeline view 
so that only the rough animation and clean-up layer are displayed in the Camera view. 

8. In the Tools toolbar, click the Onion Skin  button and pull on the blue onion skin handles in the 
Timeline view to extend the number of frames you can see.

9. In the Timeline or Xsheet view, select the next cell corresponding to a rough drawing.

10. In the Camera view, trace your next drawing.

11. Repeat the previous steps for each drawing.

This method allows you to keep the roughs and the cleans intact. You only need to disable the rough layer 
to prevent it from appearing in the scene. 
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Tracing Directly Over

Tracing or cleaning directly over means to clean your drawing in the same cell. This method avoids 
adding too many layers to your scene or demanding too much power from a low performance 
graphics card when using the light table or onion skinning. However, the rough animation has to be 
removed.

This technique is the equivalent of sketching on paper with a blue animator pencil and then inking 
directly onto it in black. Harmony allows you to select all the zones using a certain colour from your 
palette. Then you can trace over your sketch with a different colour. Once you are done, you can select 
all the zones painted with the sketch colour and delete them, keeping only the clean drawing. 

How to trace directly over your rough animation

1. In the Timeline or Xsheet View, select the first rough drawing to clean.

 

2. Do one of the following:

‣ In the Colour view, if you have already made a palette for this character, select its outline 
colour.

‣ Create a new colour  in your palette and select it. It is recommended to name it Clean or 
Trace.

3. Select a drawing tool.

4. In the Camera or Drawing View, trace over your rough model.
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     Animation Clean-up

5. Do one of the following:

‣ In the Drawing  or Camera view menu, select View > Onion Skin > Show Onion Skin.

‣ In the Timeline view menu, select Onion Skin > Show Onion Skin.

‣ Press Alt + O.

6. In the Timeline view, extend the onion skin.

7. Do one of the following:

‣ In the Xsheet View, select the next cell in which you want to draw.

‣ In the Camera, Drawing or Xsheet view, press F and G to navigate between your drawings.

8. In the Camera or Drawing view, trace your next drawing.

9. Repeat steps 6 and 7 for each drawing.

10. Use the Flip and Easy Flipping toolbars to review your animation. You can also use the Playback 
toolbar to play the animation in real time.

11. Once the drawings are completed, select the rough colour from the Colour view.

12. Do one of the following:

‣ In the Drawing or Camera View menu,  select Edit > Select Strokes With Current Colour.

‣ Press Ctrl + Shift + A (Windows/Linux) or ⌘  + Shift + A (Mac OS X).
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13. In the Drawing or Camera View, Press Delete to delete the selected zone.

14. Repeat steps 10 to 13 for each drawing.
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Tools
To understand paperless animation, you must first discover the tools available. There are, of course, 
drawing tools, but also practical features such as setting a drawing as a key, breakdown or in-
between.

When you create hand-drawn animation digitally, there are certain tools you require in order to work 
efficiently, as you would with an animation table, paper and pencils. 

The onion skin and light table are used to preview previous and next drawings, cells, elements and 
frames. When designing or animating, it is very useful to see your previous drawings. Just as if you 
were building a cut-out puppet, you want to view other drawing elements to know where to draw the 
new element.

Onion Skin

 

The Onion Skin   tool lets you preview the previous and next drawings. By default, the previous 
drawings appear in a shade of red and the next drawings are displayed with a shade of green. You 
can change these colours in the Preferences dialog box. 

In the Drawing view, onion skinned drawings are based on the actual number of drawings before and 
after the current drawing. In the Camera view, onion skinned drawings can be based on actual 
drawings or the drawings in the frames before and after the current drawing.

How to enable onion skinning

1. Do one of the following:

‣ From the top menu, select View > Onion Skin > Show Onion Skin.

‣ In the Timeline view, click the Onion Skin  button on a layer. When enabled, the icon 
turns red .
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‣ In the Tools toolbar, click the Onion Skin  button.

‣ Press Alt + O.

How to onion skin by drawing in the Camera view

1. Do one of the following:

‣ From the top menu, select View > Onion Skin > Onion Skinning by Drawing.

‣ In the Camera view menu, select View > Onion Skin > Onion Skinning by Drawing.

‣ In the Timeline view menu, select Onion Skin > Onion Skinning by Drawing.

2. Click an icon, menu operation or keyboard shortcut to edit the display.

View > Onion Skin 
Menu Command

Tools toolbar 
icon

Keyboard Shortcut

No Previous Drawing ~

Previous Drawing !

Previous Two Draw-
ings

@

Previous Three Draw-
ings

#

No Next Drawing Ctrl + ̀  (Windows/Linux) or ⌘  + ̀  (Mac OS X)

Next Drawing Ctrl + 1 (Windows/Linux) or ⌘  + 1 (Mac OS X)

Next Two Drawings Ctrl + 2 (Windows/Linux) or ⌘  + 2 (Mac OS X)

Next Three Drawings Ctrl + 3 (Windows/Linux) or ⌘  + 3  (Mac OS X)

3. In the Camera view, the previous and next drawings appear with the current one.
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Onion skinning by frame in the Camera view

1. If they are not visible, display the blue onion skin markers in the Timeline view by doing one of the 
following:

‣ From the top menu, deselect View > Onion Skin > Onion Skinning by Drawing.

‣ In the Camera view menu, deselect View > Onion Skin > Onion Skinning by Drawing.

‣ In the Timeline view menu, deselect Onion Skin > Onion Skinning by Drawing.

2. In the Timeline view, drag the blue onion skin markers to select the number of previous and next 
drawings to display.

3. In the Camera view, the previous and next drawings appear with the current one.

Using the top light to modify onion skin settings

1. In the Camera or Drawing View toolbar, click the Top Light  button.

The Top Light dialog box opens.

2. Adjust the Onion Skin Opacity slider to modify the opacity value of the onion skin display.

3. Click OK.
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Using the Light Table

 

The light table  is used to preview the previous and subsequent active layers in washed-out colours. It 
is useful for seeing the other layers when designing, animating or cleaning up your animation. 

In the Camera view, when the light table is activated, all layers but the currently selected one are 
shown washed-out. The display returns to the normal mode when the Select tool or a scene setup 
tool is selected.

Only the currently selected drawing is displayed by default in the Drawing view. When enabling the 
light table, the other layers appear as a washed-out display and are used as a reference. You can not 
select or manipulate them.

How to enable the light table

1. Do one of the following:

‣ In the top menu, select View > Light Table.

‣ In the Drawing View toolbar, click the Light Table  button.

‣ In the bottom Camera View toolbar, click the Light Table  button.

‣ Press Shift + L. 

2. The drawings for the other layers are displayed as washed-out colours in the Camera and 
Drawing views.
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3. In the Timeline view, you can deselect the layers you want to hide from the light table.

Using the top light to modify light table settings

1. In the Camera or Drawing View toolbar, click the Top Light  button.

The Top Light dialog box opens.

2. Adjust the Light Table Opacity slider to modify the opacity value of the light table display.

3. Adjust the Light Table Wash slider to modify the washed-out value of the light table display.

4. Use the Bitmap Background Wash to modify the washed-out value of bitmap images in the 
scene.

5. Click OK.

Using the Rotary Table

Use the rotary table (animation disk) to rotate your Camera or Drawing view while you draw for 
increased flexibility. The rotary tables in each view are independent; if you rotate the Drawing view 
25 degrees, if you switch to the Camera view, you can use the rotary table in that view and rotate it 
to a different angle without affecting the settings in the other view.
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How to use the rotary table

1. Do one of the following:

‣ In the Camera or Drawing view, press Ctrl + Alt (Windows/Linux) or ⌘  + Alt (Mac OS X)

‣ In the Tools toolbar, click the Rotate View  button.

The rotary table appears.

2. Rotate the view to the desired angle.

3. Release the keyboard shortcut or switch to a new drawing tool.

4. Press Shift + X to reset the rotation.

Drawing Identification

The Drawing Identification tool can help you stay well organized and save time when identifying key, 
breakdown or in-between drawings in the Xsheet and Timeline view. 

With this tool, you the  animator can retain some habits from traditional paper animation, but feel 
just as comfortable animating in a paperless environment.

When working with several animators, directors, or even other studios, the necessity for retakes will 
often arise. You can also mark your new drawings as either Retake Key, Retake Breakdown, or 
Retake In-betweens.
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If your production requires that you mark your drawing with a custom marker, you also have the 
option to create your own.

Key Drawing

A key drawing is a visually significant pose in a movement, often an extreme position. For example, 
if a character that is sitting down falls on his back, the key poses would be the character sitting and 
the character on his back. Of course, it may vary from one animation to another.

Breakdown Drawing

A breakdown drawing is a pose somewhere between two key poses that better shows the 
movement. Most animation moves are arcs, such as an arm waving, somebody bending, or a leg 
walking. All of these movements are rotations. The breakdown pose is used to describe this curve 
better.

The breakdown drawing is then used to indicate secondary poses, also called the follow-through. 
These actions can be a big stomach jiggle as somebody jumps, a cloak floating behind somebody 
that is running, or arms moving after the main body action. These moves will generally have a 
different timing than the primary action. They will mainly start later and finish later. So, the 
breakdown drawings are used to complete the key drawings.

Note that a breakdown drawing is not always placed exactly in the middle of two keys. It will often 
be closer to one or the other depending on the timing and the action. Also, you can have more 
than one breakdown pose between two keys.
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In-between Drawing

In-between drawings can be considered the filling drawings. Once the timing is established by the 
key and breakdown poses, the in-between drawings will be added to complete the animation and 
make it more fluid.

In-betweens do not necessarily need to be placed exactly in the middle of two other poses. They 
can be placed closer to one or the other to create ease in or ease out of the movement.
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How to display the Mark Drawing toolbar

1. In the top menu, select Windows > Toolbars > Mark Drawing.

The Mark Drawing Toolbar appears.

How to mark a drawing as a key, breakdown or in-between

1. In the Xsheet view or Timeline view, select the cell that you want to mark. 

2. Do one of the following:

‣ In the Mark Drawing toolbar, select an icon.

‣ In the Xsheet or Timeline view menu, select a command in Drawing > Mark Drawing.

‣ Right-click the selection and select Drawings > Exposure > Mark Drawing.

Mark Drawing Commands Mark Drawing toolbar icon
Colour of marker in 
Timeline

Key Drawing Red (default)

Breakdown Drawing Blue (default)

In-between Drawing Not applicable

Retake Key Green

Retake BD Yellow 

Retake IB Purple
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If you mark an in-between drawing, there is no icon displayed in the cell since it is used to remove 
a key or breakdown marker.

You can change the colour of the key and breakdown markers in the Timeline view. 
Refer to the Preferences Guide to learn how to customize timeline markers.

 

You can create your own custom shortcuts for the Drawing Identification options. Refer to the 
Preferences Guide to learn how to customize keyboard shortcuts.

Custom Marks in the Xsheet View

Make custom marks for the Xsheet by creating your own icons, then cutting, pasting and changing 
a bit of code. Not only is it possible to have your custom mark appear in the Xsheet and Mark 
Drawing toolbar, but also in the Onion Skin and Flip toolbars.
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How to create your custom markers

1. With a bitmap editing software, create the following icons in PNG format:

‣ Mark Drawing Toolbar icon (24 x 24 pixel)

‣ Onion Skin Toolbar icon (24 x 24 pixel)

‣ Flip Toolbar icon (24 x 24 pixel)

‣ Xsheet Column icon (16 x 16 pixel)

2. Close Harmony.

3. Once your icons are ready, go to the Toon Boom Harmonyresources/drawingTypes.d 
directory:

• Network

‣ Mac OS X: /Users/*username*/Library/Preferences/Toon Boom 
Animation/Toon Boom Harmony/full-1100-pref/drawingTypes.d

‣ Linux:~/Toon Boom Animation/Toon Boom Harmony/full-1000-
pref/drawingTypes.d

‣ Windows: C:/Users/*username*/AppData/Roaming/Toon Boom 
Animation/Toon Boom Harmony/full-1100-pref/drawingTypes.d

4. Paste your icons in the resources/drawingTypes.ddirectory.

5. In that same directory, open the drawingTypes.xml file in a text editor.

6. For each custom icon you want to create, add the following line. Ensure it is placed before the 
closing </DrawingTypes> tag.
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‣ <DrawingType text="NewButtonName" pixmapFile="XsheetIcon.png" 
commandIcon="MarkDrawingIcon.png" flipIcon="FlipIcon.png" 
onionIcon="OnionIcon.png" />

7. In that line, replace the following information with your new icon information:

‣ NewButtonName: Write the name of your new marker. This name will appear in the 
button tooltip.

‣ XsheetIcon.png: Write the name of the icon that you created to appear in the Xsheet 
column. Include the file extension.

‣ MarkDrawingIcon.png: Write the name of the icon that you created to appear in the 
Mark Drawing toolbar. Include the file extension.

‣ FlipIcon.png: Write the name of the icon that you created to appear in the Flip toolbar. 
Include the file extension.

‣ OnionIcon.png: Write the name of the icon that you created to appear in the Onion Skin 
toolbar. Include the file extension.

8. Save the file and close it.

9. Start Harmony.

Note that no marker will appear in the Xsheet view for an in-between drawing. The in-between drawing 
is a regular drawing. The option is mainly used to remove a key or breakdown identification marker from 
a drawing.

Create Empty Drawing

The Create Empty Drawing  command automatically creates a drawing in the selected cell, replacing 
any drawing that may already be exposed in that cell and the following ones until it meets another 
drawing or a blank cell. 

How to create an empty drawing

1. In the Timeline or Xsheet view, select the cell in which you want to create an empty drawing.

2. Do one of the following:

‣ In the top menu, select Animation > Create Empty Drawing.

‣ In the Xsheet view menu, select Drawings > Create Empty Drawing.

‣ In the Xsheet View toolbar, click the Create Empty Drawing  button. 

‣ Press Alt + Shift + R.

The new drawing is created in the Xsheet and Timeline views.
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Reposition All Drawings

 

The Reposition All Drawings  option is used to reposition, scale, rotate or skew all drawing 
strokes on every drawing included in a layer. 

How to reposition all drawings

1. From the Tools toolbar, select the Reposition All Drawings  tool. This also automatically 
selects every stroke in your drawing in the Drawing and Camera view.

2. Do any of the following:

‣ To reposition, click and drag your selection to a new area.

477



     

‣ To rotate, rotate the selection box handle.

‣ To scale, pull or push on the top, side, bottom or corner control points. Hold down Shift 
to maintain the selection’s ratio.

‣ To skew, drag the sides or top and bottom segments, between the control points.

478



Toon Boom Harmony 11.1 Draw Guide (Network)

3. When you release your cursor, every drawing in the drawing layer you repositioned, scaled, 
rotated or skewed will follow the same transformation.

Tips and Tricks

Here are some tips and tricks that you can use to feel more comfortable while drawing:

Texture Pen and Transparent Pen

Use the texture pen or a transparent colour for a paper sketch effect.

Pen Tablet

Use a pen tablet to draw with a pen instead of the mouse. This allows for increased dexterity and 
speed, and accounts for pressure sensitivity. 
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Field Chart

Toon Boom Harmony also has a field chart included in its Camera and Drawing view. It is a useful 
tool to set the height of characters and props.
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Advanced Tools

Harmony has many useful features such as the Flipping toolbar, enhanced onion skin, extra drawing 
layers, and automated matte generation.

This section is divided as follows:

• Flipping and Easy Flipping Toolbars on page 483

• Onion Skin Toolbar  on page 485

• Drawing Identification on page 487

• Drawing Desk on page 491

• Shift and Trace  on page 495

• Art Layers on page 603

• Previewing Drawings on page 505
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Flipping and Easy Flipping Toolbars

Toon Boom Harmony allows you to rapidly flip through drawings in the Drawing view just as you do 
with paper drawings. You can flip through the key, breakdown or in-between drawings individually, or 
view a combination.

How to flip through drawings

1. Do one of the following:

‣ In the top menu, select Windows > Toolbars > Easy Flipping.  

‣ Select Windows > Toolbars > Flip.

2. In the Easy Flipping toolbar, click the Previous  or Next  button to see the previous or next 
drawing of your animation.

3. To display drawings in the first frame after you reach the last frame of your animation, select the 
Loop option.

4. Move the slider to the right to flip forward and to the left to flip backward through your drawings.

‣ The further you move the slider to the left or right, the faster the drawings will flip.

5. If you marked some of your drawings, you can flip through the markers and avoid seeing all the in-
betweens. Enable the Flip Key, Breakdown or In-between buttons in the Flip toolbar to see only 
one type or a combination—see See "Drawing Identification" on page 470
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Onion Skin Toolbar 

 

In the Drawing view, you can set up your onion skin to display marked drawings only, in the same way 
that you flip through your drawings marked as key, breakdown or in-between drawings—see See 
"Drawing Identification" on page 470

How to display marked drawings in the onion skin

1. From the top menu, select Windows > Toolbars > Onion Skin.

2. In the Tools toolbar, click the Show Onion Skin  button.

3. In the Timeline view, pull on the blue arrows to extend the number of drawings displayed in the 
onion skin preview.

4. In the Onion Skin toolbar, enable the markers you want to see in your Onion Skin preview.
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How to enable the onion skin in other layers

You might need to refer to previous and next drawings in other layers than the current one. In the 
Drawing view, use the Enable Onion Skin in Other Elements feature to see the previous and next 
drawings of the layers visible in Light Table mode.

1. In the top menu, select Windows > Toolbars > Onion Skin.

2. In the Tools toolbar, click the Onion Skin  button.

3. In the Drawing view, click the Light Table  button. 

4. In the Timeline view, pull on the blue arrows to extend the number of drawings displayed in the 
onion skin preview.

5. In the Onion Skin toolbar, enable the Enable Onion Skin in Other Elements option.

‣ The current layer is displayed by default in shades of green and red.

‣ Drawings in timeline layers above the current layer are displayed by default in shades of 
blue.

‣ Drawings in timeline layers below the current layer are displayed by default in shades of 
yellow.

You can change default onion skin display colours in the Preferences dialog box. 
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Drawing Identification
In the Xsheet view, you can identify drawings as Key, Breakdown or In-between. This helps to keep the 
Xsheet well organized while animating.

When working with several animators, directors, or even other studios, the necessity for retakes will 
often arise. Harmony also gives you the possibility to mark new drawings as either Retake Key, Retake 
Breakdown, or Retake Inbetweens.

If your production requires you to mark drawings with a custom marker, you also have the option to 
create your own.

Make custom marks for the Xsheet by creating your own icons, then cutting, pasting and changing a 
bit of code. Not only is it possible to have your custom mark appear in the Xsheet and Mark Drawing 
toolbars, but also in the Onion Skin and Flip toolbars.

You can create custom shortcuts for the Drawing Identification options in the Preferences dialog box.

How to mark a drawing as Key, Breakdown or In-between

1. From the top menu, select Windows > Toolbars > Mark Drawing. 

The Mark Drawing toolbar displays.

2. In the Xsheet view, select the cell you want to identify. This option is not available in the Timeline 
view.
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3. In the Mark Drawing toolbar, click one of these buttons: Mark as Key Drawing , Mark as 
Breakdown Drawing  or Mark as In-between Drawing . In the Xsheet View menu, you can 
also select Drawing > Mark Drawing As > Key Drawing, Breakdown Drawing, In-between 
Drawing, Retake Key, Retake BD and Retake IB.

‣ If you selected Mark as Key Drawing, a  icon appears in the cell.

‣ If you selected Mark as Breakdown Drawing, a  icon appears in the cell.

‣ If you selected Mark as In-Between Drawing, there is no icon displayed in the cell since it is 
used to remove a Key or Breakdown marker.

How to create custom markers

1. With a bitmap editing software, create the following icons in PNG format:

‣ Mark Drawing Toolbar icon (24 x 24 pixel)

‣ Onion Skin Toolbar icon (24 x 24 pixel)

‣ Flip Toolbar icon (24 x 24 pixel)

‣ Xsheet Column icon (16 x 16 pixel)

2. Close Harmony.

3. When your icons are ready, open the Toon Boom Harmony drawingTypes.d folder. 
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If the drawingTypes.d folder does not exist, you must create it. To do so, copy the 
resources folder from the following location.

• Windows: C:/Program Files (x86)/Toon Boom Animation/Harmony 
11.1/resources/drawingTypes.d

• Mac OS X: /Applications/Harmony 11.1/resources/drawingTypes.d

• Linux: 
/usr/local/ToonBoomAnimation/ProductNameVersion/resources/drawingTypes.d

Stand-alone

‣ Windows: C:\Users\USERNAME\AppData\Roaming\Toon Boom Animation\Toon 
Boom Harmony\full-1100-pref\drawingTypes.d

‣ Mac OS X: /Users/USERNAME/Library/Preferences/Toon Boom 
Animation/Toon Boom Harmony/full-1100-pref/drawingTypes.d

The Library folder is usually hidden in the Finder. To see all the hidden folders and files, 
type the following in a terminal window:

defaults write com.apple.Finder AppleShowAllFiles YES

‣ Linux: /home/USERNAME/Toon Boom Animation/Toon Boom Harmony/full-
1100-pref/drawingTypes.d/

Network

In Harmony Network, the path is global for all users so you must create the folder and place in 
/USA_DB.

‣ /USA_DB/drawingTypes.d

4. Paste your icons in the drawingTypes.d directory.

5. In the same directory, open the drawingTypes.xml file in a text editor.

6. For each custom icon you want to create, add the following line. Make sure to place it before this 
closing tag: </DrawingTypes>.

‣ <DrawingType text="NewButtonName" pixmapFile="XsheetIcon.png" 
commandIcon="MarkDrawingIcon.png" flipIcon="FlipIcon.png" 
onionIcon="OnionIcon.png" />

7. In that line, replace the following information with your new icon information:

‣ NewButtonName: Write the name of your new marker. This name will appear in the button 
tooltip.

‣ XsheetIcon.png: Write the name of the icon that you created to appear in the Xsheet 
column. Include the file extension.

‣ MarkDrawingIcon.png: Write the name of the icon that you created to appear in the Mark 
Drawing toolbar. Include the file extension.
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‣ FlipIcon.png: Write the name of the icon that you created to appear in the Flip toolbar. 
Include the file extension.

‣ OnionIcon.png: Write the name of the icon that you created to appear in the Onion Skin 
toolbar. Include the file extension.

8. Save the file and close it.

9. Start Harmony.
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Drawing Desk

You can work on a portion of an animation sequence or many drawings from different layers. To do 
this, select the segment needed in one or more layers in the Xsheet or Timeline view and then use the 
drawing desk to allow you to work only on these drawings.

The Drawing Desk is only available in the Drawing view.

How to send several drawings to the drawing desk

1. Do one of the following:

‣ In the Xsheet or Timeline view, select a consecutive cell range from one or several layers. 

‣ In the Xsheet view, hold down Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click on any cell to 
add it to the selection, even if it is not consecutive.

2. Do one of the following:

‣ In the Timeline or Xsheet view menu, select Drawings > Send Drawings to Desk.

‣ In the Xsheet view, right-click and select Send Drawings to Desk.

‣ In the Xsheet view, hold down the Alt key and click on the selection.

The drawing desk opens on the side of the Drawing view.
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The drawing desk is by default on the left side of the Drawing view. You can change its positioning in the 
Preferences dialog box.

3. If the drawing desk side panel is hidden, click the Arrow button, located on the right side of the 
view.

How to add more drawings to the drawing desk

1. In the Timeline or Xsheet view, select the drawings to be added.

2. Do one of the following:

‣ In the Timeline or Xsheet view menu, select Drawings > Add Drawings to Desk 

‣ Alt + click the selection.

How to clear drawings and send new ones to the drawing desk

1. Select a new drawing in the Timeline or Xsheet view.

2. In the Timeline or Xsheet view menu, select Drawings > Send Drawings to Desk.

The previous drawing desk selection is removed and replaced with the current selection.

How to change the size of drawing desk thumbnails

‣ Right-click the drawing desk and select No Thumbnail, Small Thumbnail, Medium 
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Thumbnail or Large Thumbnail.

How to change the position of a thumbnail in the drawing desk

‣ In the drawing desk, select the thumbnail.

‣ Click the Move Drawing Up  and Moving Drawing Down  buttons as needed, to 
move it to the new position in the drawing desk.

How to clear selected or all drawings from the drawing desk

1. In the drawing desk, select one or more drawings to remove.

2. Do one of the following:

‣ Right-click the drawing desk and select Remove Selected Drawings or Remove All 
Drawings.

‣ In the Drawing view, press Esc to remove all drawings.
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Shift and Trace 

When hand drawing animation, it is very important to stay on model as it is easy to lose the 
proportions or features of a character. The Shift and Trace feature lets you temporarily move a 
drawing so you can trace it on a new drawing. This is similar to animators working on an animation 
light table and using an entire character or cut-out pieces of a character and moving it underneath the 
new drawing to trace it.

Your drawings will not be modified. It will only be moved, rotated or scaled in the Shift and Trace 
mode. When you turn off this mode, the repositioned drawing returns to its normal state.

How to enable the Shift and Trace mode

1. Go to the Drawing view.

2. In the Tools toolbar, click the Show Onion Skin  button—see See "Onion Skin" on page 465.

3. Send the selected drawings to the drawing desk—see Drawing Desk on page 491.

4. In the Drawing Desk toolbar, click the Shift and Trace Enable  button.

Registration marks appear at the bottom of your drawings. 

How to shift

Using the shift and trace manipulator, you can move the registration marks to reposition selected 
drawings while you work.

1. In the Drawing Desk toolbar, click the Shift and Trace Manipulator  button.

At the bottom of the Drawing view, a window displays a zoomed in view of the manipulator. You 
can move the dividing line between the manipulator and the Drawing view to resize the area.

495



     

2. In the Drawing view, transform the drawing as needed, positioning it between your two key poses.

‣ To reposition, click and drag the drawing to a new area.

‣ To rotate from the centre peg, click the flat peg hole and rotate.

‣ To scale, pull or push on the triangle control.
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‣ To show the pivot point, hold Alt. The pivot point is in the middle of your current drawing 
view. To rotate from the pivot point, hold Alt and rotate.

‣ To scale from the pivot point, hold Shift and move your cursor.
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‣ Click and drag the pivot point to move it to a new position. Once the pivot point is moved, 
you can hold Alt and move your drawing to show it again.

3. To select another drawing and reposition it, hold down Ctrl (Windows/Linux) or ⌘  (Mac OS X).

4. If necessary, click the Shift and Trace Reset  button to reset the position of the modified 
drawing.

How to trace

1. In the drawing desk, select the drawing into which you want to trace.

2. Select the check box next to the drawing you want to allow to be temporarily transformed. By 
default, all drawings are enabled for Shift and Trace operations.

3. Select the drawing you want to move.
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4. If you want to trace more than one drawing at the same time, you can link them together. In the 
drawing desk, select several drawings and click the Link Drawings  button to lock their position 
together—see See "How to link your shift and trace drawings" on page 499.

5. In the Tools toolbar, select a drawing tool.

6. In the Drawing view, trace your drawing.

How to link your shift and trace drawings

When using the Shift and Trace feature, you can link different drawings from the drawing desk, so 
they move together when dragging or scaling. These drawings can be from different columns in the 
Xsheet view.

1. In the drawing desk, display the drawings you want to use for the Shift and Trace operation.

2. Hold down Ctrl (Windows/Linux) or ⌘  (Mac OS X) and select the drawings you want to link 
together.

3. In the Drawing Desk toolbar, click the Link Drawings button to enable linking.

Coloured boxes appear beside drawing thumbnails to identify different linked drawing groups.

A link icon appears beside the currently selected drawing and all drawings linked to it.

4. Shift your linked drawings.
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5. To unlink your drawings, select one of the linked drawings and click the Link Drawing button 
again to disable it.

6. You can shift your drawings independently.

7. To unlink your drawings, select one of the linked drawings and click the Link Drawing button 
again to disable it.

How to enable and disable individual onion skin drawings

You may end up with a lot of drawings in your onion skin display while working with the Shift and 
Trace feature. You can disable individual drawings from the onion skin display without deactivating 
them.

1. In the Tools toolbar, click the Onion Skin  button.

2. In the drawing desk, click on the drawing’s Onion Skin  button to enable or disable it.When 
enabled, the icon turns red .

Customizing Shift and Trace Shortcuts

If you use the Shift and Trace feature frequently, you can assign custom shortcuts for Shift and Trace 
operations in the Preferences dialog box—see See "Paperless Animation Preferences" on page 507.
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Art Layers

Art layers give you the possibility to divide the artwork in your drawing on different layers. For 
example, you can separate the outline and colour fill on two art layers, similar to 1950s traditional cell 
animation. These art layers are contained within a single drawing as opposed to the timeline layers or 
Xsheet columns where individual drawings with individual timing are stacked one on top of the other—
see Creating Strokes  on page 522. 

Toon Boom Harmony drawings include two layers in Advanced Art mode.

• Line Art below

• Colour Art on the next page

You can access the Art layers through the Camera and Drawing views bottom toolbar. By default, the 
art layers are hidden. Everything is drawn on the Line Art layer. You need to enable the Use Advanced 
Art Mode option.

Each layer can be used for separate hand-drawn animation tasks, letting you organize your work and 
facilitate creation and revision.

Line Art
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In hand-drawn animation, the Line Art layer is mainly used to trace and clean up animation. The 
outline is drawn in the Line Art layer and colour is painted in the Colour Art layer.

Colour Art

In hand-drawn animation, you use the Colour Art layer to paint your animation. The outline is drawn 
in the Line Art layer and colour is painted in the Colour Art layer. Strokes (invisible lines) are 
generated from Line Art to contain the painted area.

When you are doing rough animation, you may want to send a clip to somebody for feedback or 
approval before carrying on with your work. If you have several characters in your project that are 
overlapping, it may be difficult to understand what is going on as you can see through the 
characters. Toon Boom Harmony can generate a matte automatically in the Underlay, or even in the 
Colour Art layer, and fill all the zones inside your characters making them opaque. This process is 
fast and easy and allows you to send easy-to-understand movies.

How to enable the Use Advanced Art Mode preference

1. From the top menu, select Edit > Preferences ( Windows/Linux ) or Stage > Preferences ( Mac 
OS X ).

2. In the Preferences dialog box, select the General tab.

3. In the Advanced section, select the Use Advanced Art Mode option.

4. Click OK.

How to switch between drawing layers

1. In the  Art Layer toolbar, click the Line Art   or Colour Art    buttons. When switching art layer, 
it will allow you to edit the select layer without affecting the other one.
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2. Click the Preview All Enabled Art Layers   button to display both layers together. Even when the 
Preview mode is enabled, you will only be able to edit the select art layer. The other ones are only 
displayed as a reference. By default, the Preview mode is always enabled in the Camera view. You 
will only be able to see the select art layer by itself if you enable the Current Drawing on Top  
option located in the Camera bottom toolbar.

To edit both Line Art and Colour Art at the same time, you must enable the Apply to 
Line Art and Colour Art  button in the Tool Properties of the tools supporting the 
operation.

How to generate a matte

1. Do one of the following:

‣ In the Tools toolbar, select the Select  tool.

‣ Press Alt + S.

2. In the Camera or Drawing view, select the drawing you want to create a matte for. 

You can also apply the operation to all the drawings in the layer at the same time.

3. Do one of the following:

‣ From the top menu, select Drawing > Generate Auto-Matte. 

‣ In the Camera or Drawing view menu, select Drawing > Generate Auto-Matte.

The Auto-Matte dialog box opens.

4. If you want to create a matte for all the drawings included in your layer, select the Apply to 
Multiple Drawings option.

5. Depending on how precise or rough your line is, increase or decrease the radius value. The lower 
the value is, the closer to your lines’ contours the matte will be shaped. The higher the value is, the 
looser the matte will be shaped.
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6. In the Source Art menu, select the layer from which you want the matte created: Line Art or Colour 
Art.

7. In the Destination Art menu, select the layer you want the matte to be created on: Line Art or 
Colour Art.

8. If you already have artwork on the destination layer and you want the content to be deleted before 
the matte is added into it, select the Clear Destination Art First option.

9. If you want the contour of your lines to be copied as invisible lines in your matte drawing (in case 
you ever need to keep them for later), select the Copy Stroke in Destination option.

10. Click OK.
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Previewing Drawings

It is a good idea to preview your drawings to check your animation ink and paint, verify that there are 
no colour mistakes, or to play your animation in real time. You can do this by scrolling through your 
drawings or pressing F and G. You can also use the Preview option in the Xsheet view.

How to preview drawings from the Xsheet view

1. Save your scene. 

2. Do one of the following:

‣ From the top menu, select File > Save.

‣ Click the Save  button.

‣ Press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X).

3. In the Xsheet view, select the range of drawings or the whole column to preview.

4. In the Xsheet view menu, select View > Preview Selected Drawings.

Toon Boom Play opens.

5. In the Play window, press the Play  button to play back your drawings.

6. Select the Preroll option to see blank frames at the beginning and end of the animation sequence 
while looping the playback.
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Paperless Animation Preferences

When working in paperless animation, there are some preferences you can set in the Preferences 
dialog box to make your work easier and faster.

How to open the Preferences dialog box

‣ Windows/Linux: Select Edit > Preferences.

‣ Mac OS X: Select Stage > Preferences.

‣ Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

Task Tab Section
Option, button or 
parameter

If you use the Shift and Trace 
feature frequently, you can 
assign custom shortcuts.

Shortcuts Drawing Mode

Shift and 
Trace 
Drawing 
Move Down

Shift and 
Trace 
Drawing 
Move Up

Shift and 
Trace 
Drawing 
Reset 
Position

Shift and 
Trace 
Drawing 
Toggle Peg 
State

Shift and 
Trace 
Drawing 
Toggle 
Visibility

Shift and 
Trace Move 
Tool

Shift and 
Trace 
Rotate Tool

Shift and 
Trace Scale 
Tool

Shift and 
Trace 
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Toggle 
Manipulator

Shift and 
Trace 
Toggle 
View

You can change the colours 
for the onion skin and other 
elements. You can also 
change the colour of the key 
and breakdown markers 
displayed in the Timeline 
view.

General Colours Edit Colours

Drawing Colours Edit Colours

When naming your drawings 
in the Xsheet or Timeline 
view, you can set a 
preference to name your 
drawings based on their 
frame positions, which 
facilitates the creation of key 
poses (for example, a 
drawing created on frame 1 
is named "1", a drawing 
created on frame 5 is named 
"5"). 

Exposure Sheet Drawing Creation
Use Current Frame as 
Drawing Name

In the Drawing and Camera 
view, you can work in Line 
Art and Colour Art once you 
enable the Advanced Art 
mode. 

Advanced Advanced Options
Support 
Line and 
Colour Arts

Refer to the Preferences Guide for complete descriptions of each option, button and parameter.
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Chapter 28: Ink and Paint

When traditional animation is traced, cleaned up, scanned in and properly exposed, it is time for the 
ink and paint process. This consists of cleaning all dirt and hair (for example, dust that was in the 
scanner, dots that do not belong in the drawing, extra floating artwork around the drawing that must 
be removed), painting the lines and filling the colours in the empty zones on an entire animation 
sequence.

For paperless animation, the drawings are cleaned up directly in Harmony, so there is generally no dirt 
to clean, only painting and inking. 

For cut-out animation, once the character builder paints the pieces, there is no more ink and paint 
process because the same parts are always reused and moved around. The ink and paint process 
applies only to traditional and paperless animation workflows.

Harmony is optimized to ink and paint drawings efficiently. Since most of the drawings are vector-
based, the colour zones are completely filled and there are no scattered spots left blank. Also, there 
are some actions that can be applied on an entire animation sequence at once, like dirt removal, some 
colour filling, line repainting, and so on.

Harmony uses palettes to hold all the colours you need to paint your elements. A palette is created by 
assigning a set of colours to each character, prop or effect. The colour styling artist will create a new 
palette and add a new colour for each zone of the character, such as the skin, hair, tongue, shirt, 
pants, and so on. Each colour is known as a colour swatch—see Working with Palettes on page 271. 

  

When a zone on the character is painted with the colour contained in a colour swatch, a link is 
automatically created between that colour swatch and the zone. This means that if the tint of the 
colour in the colour swatch is changed, any zone linked to it will update to the new tint. This is one way 
that colour palettes can save time and money in your production. 
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Another advantage of this system is that you can create complete palettes for different lighting 
situations. For instance, in addition to the regular palette for a character, you could have one for that 
character in the rain using colours that are duller and less vibrant than the dry daytime colours, or yet 
another for using in a night scene. Using palettes linked to your character in this way allows you to 
instantly change its colouring to suit the mood and atmosphere of the scene without tediously 
repainting each element.

The ink and paint process is divided into the following steps:

• Preparation on the facing page

• Dirt Clean Up on page 515

• Art Layers on page 603

• Creating Strokes  on page 522

• Painting on page 524

• Inking the Lines on page 544

• Verifying the Zones are Painted on page 549

• Ink and Paint Tool Properties on page 552
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Preparation

The optimal workspace for creating colour models and inking/painting in traditional animation 
includes the following views:

• Xsheet

• Camera

• Drawing

• Colour

• Model

As there is no default workspace for these tasks you will need to create a custom workspace for 
yourself—refer to the Fundamentals Guide.

You may have a character or element palette that has colours that are very similar to the Drawing and 
Camera view's background colour. For example, a white eyeball colour on a white background which 
makes it difficult to know if the zone was painted. You can change the background colour of the 
Camera or Drawing view in the Preferences dialog box.
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How to change a view's background colour

1. Do one of the following:

‣ From the top menu, select Edit > Preferences.

‣ Mac OS X: Select Stage > Preferences.

‣ Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

The Preferences dialog box opens.

2. Select the General tab.

3. In the Colours section, click Edit Colours.

The Colours dialog box opens.
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4. Select the Camera or Drawing tab.

5. Change the background colour of: 

‣ Camera View: Click the Clear colour swatch.

‣ Drawing View: Click the Background colour swatch.
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The Select Colour dialog box opens.

6. Select a colour by clicking a colour swatch, clicking a colour in the colour gradient, or entering a 
HSV/RGB Value.

7. Click OK in the three opened dialog boxes to apply your changes.

When you need to paint drawings with similar colours throughout the palette, you can 
create a clone of that palette and change all the colours to very bright tints to facilitate 
the paint process—see .
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Dirt Clean Up

When paper drawings are passed through a scanner, there can be some hair and dirt scattered across 
them. These lines and dots need to be cleaned. Harmony provides different tools to help get rid of 
them quickly.

The Remove Dirt tool selects small dots and hairs on the drawing. Raising the Remove Dirt level will 
select bigger dots. When selecting larger dots, be careful not to lose small details like pupils and 
nostrils. Once you have chosen the level, you can apply it to the current drawing or the entire 
animation sequence. This is a quick way to get rid of most dirt and dust.

During this process, the dirt that will be removed is highlighted in red.

The Remove Art Outside Selection option lets you remove any art existing outside a selection. It is 
recommended that you clean your Colour Art level as well. If you have a stroke accumulation in your 
Colour Art, it can result in large output files, especially if you work in high-definition resolutions.
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If there are some marks that cannot be removed with the automated tools, you can erase them with 
the Eraser tool or select them with the Select tool and then delete them. It is always safer to select and 
delete them than to erase them, so you do not overlook anything.

How to use the Remove Dirt tool

1. Do one of the following:

‣ From the top menu, select Drawing > Clean Up > Remove Dirt.

‣ From the Camera or Drawing View  menu, select Drawing > Clean Up > Remove Dirt.

‣ Press Shift + D.

2. Increase the Remove Dirt value by moving the slider to the right.

3. Enable the Apply to All Drawings if you want to operation to be apply to all drawings in the layer.

How to clean dirt with Remove Art Outside Selection

1. In the Tools toolbar, select the  Select  tool.

2. In the Tool Properties view, enable the Permanent Selection option.

3. Draw a selection around the animation making sure to include the entire animation sequence.
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4. In the Camera or Drawing View  menu, select Drawing > Clean Up and one of the following 
options:

‣ Remove Art Outside Selection to delete artwork outside your selection on a single 
drawing.

‣ Remove Art Outside Selection on All Drawings to delete artwork outside your selection 
on all the drawings.

The art outside the selection is removed.

How to access the Eraser tool

‣ From the Tools toolbar, click the Eraser button.

‣ From the top menu, select Drawing > Drawing Tools > Eraser.

‣ From the Camera or Drawing View menu, select Drawing Tools > Eraser.

‣ Press Alt + E.

How to access the Select tool

‣ From the Tools toolbar, click the Select button.

‣ From the top menu, select Drawing > Drawing Tools > Select.

‣ From the Camera or Drawing View menu, select Drawing Tools > Select.

‣ Press Alt + S.
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Art Layers

Art layers give you the possibility to divide the artwork in your drawing on different layers. For 
example, you can separate the outline and colour fill on two art layers, similar to 1950s traditional cell 
animation. These art layers are contained within a single drawing as opposed to the timeline layers or 
Xsheet columns where individual drawings with individual timing are stacked one on top of the other—
see Creating Strokes  on page 522. 

Toon Boom Harmony drawings include two layers in Advanced Art mode.

• Line Art below

• Colour Art on the facing page

You can access the Art layers through the Camera and Drawing views bottom toolbar. By default, the 
art layers are hidden. Everything is drawn on the Line Art layer. You need to enable the Use Advanced 
Art Mode option.

Each layer can be used for separate hand-drawn animation tasks, letting you organize your work and 
facilitate creation and revision.

Line Art
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In hand-drawn animation, the Line Art layer is mainly used to trace and clean up animation. The 
outline is drawn in the Line Art layer and colour is painted in the Colour Art layer.

Colour Art

In hand-drawn animation, you use the Colour Art layer to paint your animation. The outline is drawn 
in the Line Art layer and colour is painted in the Colour Art layer. Strokes (invisible lines) are 
generated from Line Art to contain the painted area.

When you are doing rough animation, you may want to send a clip to somebody for feedback or 
approval before carrying on with your work. If you have several characters in your project that are 
overlapping, it may be difficult to understand what is going on as you can see through the 
characters. Toon Boom Harmony can generate a matte automatically in the Underlay, or even in the 
Colour Art layer, and fill all the zones inside your characters making them opaque. This process is 
fast and easy and allows you to send easy-to-understand movies.

How to enable the Use Advanced Art Mode preference

1. From the top menu, select Edit > Preferences ( Windows/Linux ) or Stage > Preferences ( Mac 
OS X ).

2. In the Preferences dialog box, select the General tab.

3. In the Advanced section, select the Use Advanced Art Mode option.

4. Click OK.

How to switch between drawing layers

1. In the  Art Layer toolbar, click the Line Art   or Colour Art    buttons. When switching art layer, 
it will allow you to edit the select layer without affecting the other one.
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2. Click the Preview All Enabled Art Layers   button to display both layers together. Even when the 
Preview mode is enabled, you will only be able to edit the select art layer. The other ones are only 
displayed as a reference. By default, the Preview mode is always enabled in the Camera view. You 
will only be able to see the select art layer by itself if you enable the Current Drawing on Top  
option located in the Camera bottom toolbar.

To edit both Line Art and Colour Art at the same time, you must enable the Apply to 
Line Art and Colour Art  button in the Tool Properties of the tools supporting the 
operation.

How to generate a matte

1. Do one of the following:

‣ In the Tools toolbar, select the Select  tool.

‣ Press Alt + S.

2. In the Camera or Drawing view, select the drawing you want to create a matte for. 

You can also apply the operation to all the drawings in the layer at the same time.

3. Do one of the following:

‣ From the top menu, select Drawing > Generate Auto-Matte. 

‣ In the Camera or Drawing view menu, select Drawing > Generate Auto-Matte.

The Auto-Matte dialog box opens.

4. If you want to create a matte for all the drawings included in your layer, select the Apply to 
Multiple Drawings option.

5. Depending on how precise or rough your line is, increase or decrease the radius value. The lower 
the value is, the closer to your lines’ contours the matte will be shaped. The higher the value is, the 
looser the matte will be shaped.
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6. In the Source Art menu, select the layer from which you want the matte created: Line Art or Colour 
Art.

7. In the Destination Art menu, select the layer you want the matte to be created on: Line Art or 
Colour Art.

8. If you already have artwork on the destination layer and you want the content to be deleted before 
the matte is added into it, select the Clear Destination Art First option.

9. If you want the contour of your lines to be copied as invisible lines in your matte drawing (in case 
you ever need to keep them for later), select the Copy Stroke in Destination option.

10. Click OK.
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Creating Strokes 

A  drawing is composed of Line and Colour filling layers. Lines and colours can be separated or kept 
together, depending on which animation process you use. The following diagram presents Line Art 
and Colour Art recommendations based on the selected animation workflow.

When a traditional drawing is scanned, strokes are automatically created in the Colour Art from the 
Line Art when drawings are vectorized unless you specified otherwise.

When working with Cut-out animation, we recommend that you do all of the work in the Line Art. 

Once the drawing sequence is completed for paperless drawings, you can proceed with creating 
Colour Art strokes if you plan to paint the animation in the Colour Art. Use the Create Colour Art from 
Line Art option to create strokes from your lines.

You can create strokes in the Colour Art during the following stages:

• After the full drawing is completed in Line Art

• While drawing in Line Art

You may have some traditional drawings that need to be fixed; for example, needing extra lines to 
patch gaps. Use the Auto-Create Colour Art from Brush option to create the strokes at the same time 
as the lines are drawn. This creates strokes from the lines and brush strokes created in the Line Art 
while you draw and is useful for fixing drawings. However, if you are drawing a new sketch, it is better 
to create the strokes afterward using the Create Colour Art from Line Art option.

How to create Colour Art zones out of the Line Art content

1. In the Tools toolbar, select the Select  tool or press Alt + S.

2. In the Tool Properties view, enable the Permanent Selection  option if you want to apply the 
operation on all drawings in the layer.

3. In the Camera or Drawing view, select the artwork to transfer to the Colour Art. Create a selection 
around the entire animation sequence if you want to apply the operation to all your drawings.
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4. In the Drawing View toolbar, click the Create Colour Art from Line Art  button or press *.

How to create strokes with the Auto-Create Colour Art From Brush option

1. From the Camera or Drawing View  menu,  select Drawing >Auto-Create Colour Art from Brush 
or press [Shift]+[F2].

2. Draw the required lines. 

3. Once you are done, deselect the Auto-Create Colour Art from Brush option. You are now ready 
to paint your model.
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Painting

You can choose to paint your animation in the Line Art or Colour Art level. You can paint in Line Art, 
but for traditional and paperless animation, you should fill your colour zones in Colour Art. You can 
access the art layers through the Art Layer toolbar—see Art Layers on page 603.

There are many advantages to separating the lines and colour zones, but the main one concerns the 
painting process. To paint very quickly, it is useful to not worry about painting over the lines. If the 
lines are separated, you can fill the zones very quickly and you will never accidentally paint the lines. 
Conversely, if you are inking the lines, you will not repaint the colour zones either.

If you have transparent lines, bitmap lines or textured lines with transparency, it is better to have your 
colour zones bleeding under your lines to avoid seeing the backgrounds and other elements through 
the lines.

To avoid painting in Line Art by mistake, turn off the Preview  mode and paint in the Drawing view rater 
than the Camera view. Press P to turn the mode on or off. 

This section is divided as follows:

• Painting Using the Paint Tool on the facing page

• Advanced Painting Features on page 526

• Selecting a Colour in a Drawing  on page 530

• Importing Models on page 531

• Editing Gradients and Textures  on page 535

• Closing Gaps on page 540

• Protecting Colours  on page 542

• Highlighting the Selected Colour  on page 542

• Inverting a Colour Selection on page 543
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Painting Using the Paint Tool

The main tool you will use to paint your drawings with is the Paint  tool. The Paint tool can be used in 
several different modes, which can be customized in the Tool Properties view.

The Paint tool paints closed zones, including brush strokes and pencil lines. If there are gaps in the 
lines defining a zone, you must close them using the Brush, Pencil, or Close Gap tools or the Automatic 
Close Gap option.

How to paint with the Paint tool

1. In the Timeline or Xsheet view, select the cell on which you want to paint.

2. Do one of the following:

‣ In the Tools toolbar, click the Paint  tool.

‣ Press Alt + I. 

3. In the Colour view, select a colour.

4. In the  Drawing or Camera view, start painting. You can click on a zone or pencil line to paint it, or 
you can trace a lasso or marquee selection to paint several zones or pencil lines at once.

The last colour you select while using the Paint tool will be remembered the next time you select the Paint 
tool if you are using the unlocked painting tools in the Colour view.

525



Chapter 28: Ink and Paint     Painting Using the Paint Tool

Advanced Painting Features
The following advanced painting features are available in Toon Boom Harmony and are described in 
this section:

• Repaint Selection 

• Repaint Selection On All Drawings 

• Repaint Outside Selection   

• Repaint Outside Selection On All Drawings 

• Unpaint Selection 

• Unpaint Selection On All Drawings 

• Unpaint Outside Selection 

• Unpaint Outside Selection On All Drawings

The Repaint Selection command is used to repaint any art inside a selection. You must first draw a 
selection using the Select  tool in order for this command to be available.

The Repaint Selection On All Drawings command is used to repaint any art inside a selection on all the 
drawings contained within the same layer. You must enable the Permanent Selection  option in the 
Select tool Tool Properties view and then select an area of your drawing using the Select  tool in order 
for this command to be available. The Permanent Selection option lets you maintain the same 
selection throughout the drawings of a same layer.
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The Repaint Outside Selection command is used to repaint any art outside a selection. If no selection 
has been drawn using the Select   tool, the entire drawing will be repainted.

The Repaint Outside Selection On All Drawings command is used to repaint any art outside a selection 
on all the drawings contained within the same layer. You must enable the Permanent Selection  
option in the Select tool Tool Properties view and then select an area of your drawing using the Select  
tool in order for this command to be available. The Permanent Selection option lets you maintain the 
same selection throughout the drawings of a same layer.

The Unpaint Selection command is used to unpaint any art existing inside a selection. You must first 
draw a selection using the Select  tool in order for this command to be available.

The Unpaint Selection on All Drawings command is used to unpaint all art contained inside a selection 
on all the drawings within the same layer. 
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You must enable the Permanent Selection  option in the Select tool Tool Properties view and then 
select an area of your drawing using the Select  tool in order for this command to be available. The 
Permanent Selection option lets you maintain the same selection throughout the drawings of a same 
layer.

The Unpaint Outside Selection command is used to unpaint any art existing outside a selection. If no 
selection have been drawn using the Select  tool, the entire drawing will be unpainted.

The Unpaint Outside Selection on All Drawings command is used to unpaint all art outside a selection 
on all the drawings within the same layer. You must enable the Permanent Selection  option in the 
Select tool Tool Properties view and then select an area of your drawing using the Select  tool in order 
for this command to be available. The Permanent Selection option lets you maintain the same 
selection throughout the drawings of a same layer.

How to access the Repaint Selection command

‣ From the top menu, select Drawing > Paint > Repaint Selection.

‣ From the Camera or Drawing view menu, select Drawing > Paint > Repaint Selection. 

How to access the Repaint Selection On All Drawings command

‣ From the top menu, select Drawing > Paint > Repaint Selection On All Drawings.

528



Toon Boom Harmony 11.1 Draw Guide (Network)

‣ From the Camera or Drawing view menu, select Drawing > Paint > Repaint Selection On 
All Drawings. 

How to access the Repaint Outside Selection command

‣ From the top menu, select Drawing > Paint > Repaint Outside Selection.

‣ From the Camera or Drawing view menu, select Drawing > Paint > Repaint Outside 
Selection. 

How to access the Repaint Outside Selection on All Drawings command

‣ From the top menu, select Drawing > Paint > Repaint Outside Selection on All Drawings.

‣ From the Camera or Drawing view menu, select Drawing > Paint > Repaint Outside 
Selection on All Drawings. 

How to access the Unpaint Selection command:

‣ From the top menu, select Drawing > Paint > Unpaint Selection.

‣ From the Camera or Drawing view menu, select Drawing > Paint > Unpaint Selection. 

How to access the Unpaint Selection On All Drawings command:

‣ From the top menu, select Drawing > Paint > Unpaint Selection On All Drawings.

‣ From the Camera or Drawing view menu, select Drawing > Paint > Unpaint Selection On 
All Drawings. 

How to access the Unpaint Selection command

‣ From the top menu, select Drawing > Paint > Unpaint Outside Selection.

‣ From the Camera or Drawing view menu, select Drawing > Paint > Unpaint Outside 
Selection. 

How to use the Unpaint Outside Selection On All Drawings command

‣ From the top menu, select Drawing > Paint > Unpaint Outside Selection On All 
Drawings.

‣ From the Camera or Drawing view menu, select Drawing > Paint > Unpaint Outside 
Selection On All Drawings. 
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Selecting a Colour in a Drawing 

While working in your Camera  or Drawing view, you can use the Dropper  tool to pick a colour from 
your drawing without going to the Colour view. 

How to use the Dropper tool

1. Do one of the following:

‣ In the Tools toolbar, select the Dropper  tool.

‣ From the top menu, select Drawing > Drawing Tools > Dropper.

‣ Press Alt + D. 

2. In the Camera or Drawing view, click on the desired colour.

‣ If you are using another drawing tool such as the Paint tool, you can temporarily hold down 
the D key and click in your drawing before releasing the key to pick your colour. When you 
release the key, Toon Boom Harmony will return to your previous tool. You may also want 
to select the zones painted with the colour currently selected in the Colour view. This can be 
useful for removing rough lines from a clean drawing.

How to select the zones painted with the current colour

1. In the Colour view, select the colour you want to select the corresponding zones from.

2. Do one of the following:

‣ Select Drawing > Select Strokes with Current Colour. 

‣ Press Ctrl + Shift + A (Windows/Linux) or ⌘  + Shift + A (Mac OS X).
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Importing Models

Once you have a fully painted drawing, you can use it as a colour model and load it in the Model view. 
That drawing can be used and loaded in any of your Harmony scenes. 

Once a drawing is loaded in the Model view, you can use the Dropper  to select a colour from the 
model and use it to paint in your Camera or Drawing view without having to pick the colour from the 
colour palette.

You can do more than just copy colours from a colour model. Harmony gives you the ability to copy 
parts of the character directly from its colour model and paste these elements into the Drawing or 
Camera views.

How to load a colour model from the Timeline or Xsheet view

1. In the Timeline or Xsheet view, select a drawing (*.tvg).

2. Bring the model into the Model view by doing one of the following:

‣ In the Timeline view, drag the selected drawing and drop it directly in the Model view.

‣ From the Model View menu, select Use Current Drawing as Model. 

‣ In the Model View toolbar’s extra buttons, click Current Drawing  button.

The model appears in the Model view.

How to browse for a colour model drawing on your hard drive

1. Do one of the following: 

‣ From the Model View menu, select Import Model. 

‣ Click the Import Model  button or from the Model View’s toolbar.

‣ Select File > Import > Colour Model.

2. In the Browser window, browse for any *.tvg drawing file on your hard drive or in the database.

3. Click Open. 
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The model appears in the Model view.

How to load the default models

1. In your scene’s folder, create a new folder and name it models.

2. On your hard drive copy the *.tvg drawing file you want to use as colour models in your scene.

3. Do one of the following:

‣ From the Model View menu, select Load Default Model. 

‣ In the Model View toolbar’s extra buttons, click the Load Default Model  button .

How to load a single drawing from the Library view

1. In the Library view, click the template containing the drawing to import in the Model view.

2. Right-click on the template and select Open As Folder.

3. In the Library view’s left side, select the template’s folder and continuing expanding its subfolders 
until *.tvg files appear on the right side.

4. In the Library view’s right side, select the TVG drawing to import and drag it into the Model view.

How to load a template with multiple drawings from the Library view

1. In the Library view, find the template you want to import in the Model view.

2. In the Library view’s right side, drag the template (*.tpl file) and drop it directly in the Model view.

3. Use the Previous Model   and Next Model  buttons in the Model view’s toolbar to view all 
the drawings contained in the template. This can often be the front, profile, and 3/4 views of a 
character.
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How to load a symbol from the Library view

1. In the Library view’s left side, select the Symbols folder.

2. In the Library view’s right side, select the symbol that you want to use as a model, and drag and 
drop it directly into the Model view.

3. Use the Previous Model  and Next Model  buttons in the Model view’s toolbar to view all the 
drawings contained in the template. This can often be the front, profile, and 3/4 views of a 
character.

How to clear a colour model

‣ In the Model View menu, select Clear Model or press Delete.

How to copy the entire model from the Model view

1. In the Model view’s toolbar, select the Select  tool.

2. In the Model view, select your model.
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3. From the top menu, select Edit > Copy Drawing Object or press Ctrl + C (Windows/Linux) or ⌘  + 
C (Mac OS X).

4. In the Timeline view, make sure that you have the correct layer and frame selected.

5. Select either the Drawing or Camera view then go to the top menu and select Edit > Paste 
Drawing Object, or select the Timeline view and from the top men select Edit > Paste cells in the 
Timeline or pressCtrl + V (Windows/Linux) or ⌘  + V (Mac OS X). 

The model now appears in the selected view.

How to copy part of the model from the Model view

1. In the Model view’s toolbar, select the Cutter  tool or press Alt + T.

2. In the Model view, use the Cutter tool to create a selection around the part of your model that you 
want to copy.

3. From the top menu, select Edit > Copy Drawing Object or press Ctrl + C (Windows/Linux) or ⌘  + 
C (Mac OS X).

4. In the Timeline view, make sure you have the correct layer and frame selected.

5. Do one of the following:

‣ Select the Drawing or Camera view and select Edit > Paste Drawing Object. 

‣ Select the Timeline view and select Edit > Paste cells in the Timeline or press Ctrl + V 
(Windows/Linux) or ⌘  + V (Mac OS X). 

The model appears in the selected view.
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Editing Gradients and Textures 

If you paint a zone with a gradient or texture colour, you can use the Edit Gradient/Texture tool to 
modify its position in the zone. You can move, scale, rotate and skew. If you want to match the colour 
to the animation, set the first texture position and copy the Edit Gradient/Texture position. When 
moving to the next drawing, you can select the next texture and paste the previous position to 
continue the modifications.

If you are painting a hand-drawn animation or if your want the Brush tool and Paint tool to use your 
gradient’s position, angle and scale settings instead of the default ones, you can store your own 
settings and reuse them afterward.

This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawn 
with textured “brushes”. If you then paint your textured pencil line with a gradient, you can do so and 
then edit both elements independently at the same time.

How to use Edit Gradient/Texture tool

1. Do one of the following: 

‣ In the Tools toolbar, click the Edit Texture  tool.

‣ From the  Camera or Drawing View  menu, select Drawing Tools > Edit Gradient/Texture

‣ Press Shift + F3.

2. Click the gradient or texture colour to modify.

A blue selection frame surrounds the selected gradient or texture.
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3. Edit the gradient or texture by adjusting the control handles around the selection frame.

How to store your gradient and texture settings

1. In the Tools toolbar, select the Select  tool or press Alt + S.

2. In the Camera or Drawing view, select the gradient or texture zone to store.

3. In the Tool Properties view, click the Store Colour Gradient  button.

How to use the stored gradient and texture settings

1. In the Tools toolbar, select the Brush  or Paint  tool.

2. In the Tool Properties view, click the Use Stored Colour Gradient  button.

3. In the Camera or Drawing view, draw and paint.

How to use Pencil Editor tool to edit the texture or gradient on a pencil line

1. Do one of the following:

‣ In the Tools toolbar, select the Pencil Editor  tool. 

‣ From the top menu, Drawing > Drawing Tools > Pencil Editor.

‣ Press Alt + W.

2. Click on the pencil line to be modified to bring up its contour envelope.
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3. Select one of the contour points around the envelope and move its position to change the size of 
the tiled texture or gradient. You can also pull directly on the lines of the contour envelope or play 
with the Bezier handles of any given point in order to continue to modify the envelope form.

Expanding the width of the envelope parallel to the pencil line’s central vector will cause the tiled 
texture to be stretched. Conversely, reducing the envelope’s width will cause the tiled texture to 
look squashed.

Reducing the contour’s width perpendicular to the pencil line’s central vector will reduce the 
number of tiles, while expanding it will increase the number of tiled images. 

This editing technique does not just work on texture fills, but can also be applied to pencil lines 
drawn with a textured “brush”.

How to use Edit Gradient/Texture tool to edit the texture or gradient on a pencil line

1. In the Tools toolbar, select the Edit Gradient/Texture  tool. You can also select this tool from 
the top menu under Drawing > Tools > Edit Gradient/Texture or press Shift + F3.

2. Click on the pencil line to be modified to bring up the editor controls.
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3. The editor controls delineate a single tile in the texture. For gradients, this is less applicable. Pull 
on the top of the editor controls to stretch the tiled texture throughout the length of the stroke. 

As gradients are parallel to the stroke’s central vector, this will stretch the way that the gradient is 
distributed in the pencil line’s envelope. The envelope still acts as a boundary for the texture or 
gradient.

 

4. Drag the editor control perpendicular to the stroke. You will feel it glide along the strokes central 
vector line. This is another way to resize the texture tile. Instead of stretching or shrinking it 
vertically, this motion stretches or shrinks it vertically. As gradients are parallel to the pencil line’s 
central vector, stretching them vertically gives no visual result.
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How to use Edit Gradient/Texture tool to edit both the texture and the gradient of a 
pencil line

1. Do one of the following:

‣ In the Tools toolbar, select the Edit Gradient/Texture  tool. 

‣ From the top menu, Drawing > Drawing Tools > Edit Gradient/Texture.

‣ Press Shift + F3.

2. Click on the pencil line to be modified to bring up the editor controls.

3. Use the top editor controls edit the gradient.

4. Use the bottom controls edit the “brush” texture.
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Closing Gaps

When painting, you may notice that some drawing areas are not closed. To close the zone, you can 
either draw the missing line with the Brush or Pencil tool, or close the gap with an invisible line using 
the Close Gap tool. 

The Close Gap tool lets you close small gaps in a drawing by creating small, invisible strokes between 
the two closest points to close the colour zone. You do not need to trace directly over the gap. You 
can draw it a few millimeters away. The two closest points automatically close the gap.

How to close gaps

1. From the top menu, select View > Show > Show Strokes or press K to see a preview of the result.

2. Enable the Auto-Flatten  option in the Tool Properties view if you want the strokes you draw to 
be flattened in your drawing instead of being on top. 

The Close Gaps dialog box opens.

3. Adjust the slider to set the size of the gap you want to be closed.

4. To close all gaps in the drawings of the selected layer, select the Apply to all drawings option and 
click OK.

5. In the Tools toolbar, select the Close Gaps tool.

6. In the Camera or Drawing view, trace a line near the gap to be closed. Your strokes will be invisible

The gap automatically closes.
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Protecting Colours 

When you are finished painting some zones, you can protect the colour swatch they are associated 
with, so the work cannot be accidentally painted over. 

When you are done inking one colour, you can lock it so that if you ever paint over it accidentally, the 
work already done will not be affected. You can also use the Protect Colour feature to block the filling 
colours if you painted all of the animation in Line Art and you plan to repaint the lines.

How to protect colours

1. In the Colour view, select the colour to be protected.

2. Do one of the following:

‣ Right-click and select Protect Colour.

‣ From the Colour view menu, select Colours > Protect Colour. 

A red bar appears beside the colour to indicate that it is locked.

Respecting Protected Colours 
When painting, the Respect Protected Colour option is enabled by default. In the Colour view, you 
can protect a colour swatch to avoid repainting or unpainting the zones linked to that swatch. If you 
disable this option, the Paint tool will not follow the protect colour rule and you will repaint or unpaint 
the protected colours on your drawings until you enable the option again.

How to toggle the Respect Protected Colours option

Do one of the following:

‣ Paint tool properties, click the Respect Protected Colour button.

‣ From the top menu, select Drawing > Colour Protection > Respect Colour Protection.

‣ Press Shift + S.

Highlighting the Selected Colour 
The Highlight Selected Colour option is used to identify colour swatch used in a drawing. For example, 
if you have unnamed colours in your palette and want to know if a particular colour was used on the 
current model or drawing, you can select the colour and use the Highlight Selected Colour option. 
Harmony will dim all the colours in the drawing except the selected one, so it stands out and can be 
identified. You can rename it accordingly.
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How to use the Highlight Selected Colour option

1. In the Colour view, select the colour you want to highlight.

2. From the Camera or Drawing menu, select View > Show > Highlight Selected Colour.

Inverting a Colour Selection
When you need to select all colour swatches but one, or select only a few swatches here and there,  it 
might be faster to select the only colour you do not need, in order to select and invert the selection.

How to invert a colour swatch selection in the Colour view

1. In the Colour view, select the colour swatch you DO NOT want to have in your final selection.

2. Do one of the following:

‣ From the Camera or Drawing View menu, select Edit > Invert Selection

‣ Press Ctrl + Shift + I (Windows/Linux) or ⌘  + Shift + I (Mac OS X).
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Inking the Lines

Some animation styles require you to paint the lines, a process also be called inking. To ink your lines, 
you must be in Line Art mode. You can repaint any type of lines including the texture lines—see Art 
Layers on page 603.

Unless you are repainting all of the lines on the whole animation sequence, do not use the Apply Tool 
to All Drawings option. Since the line positions change a lot over time, you risk painting lines that are 
not supposed to be painted.

These are the main tools used to ink the lines:

• Repaint Tool

• Repaint Brush Tool

• Ink Tool

• Protecting Colours

• Breaking Triangles

The main tool used to ink the lines is the Repaint tool. As the colour filling is probably done in the 
Colour Art, you will not have to worry about not touching it. The Repaint tool will not paint empty 
zones either.

During the vectorization process on traditional scanned drawings, triangles are added on the lines' 
intersections to break the artwork in segments. This way, when you paint a line, it will not repaint the 
whole drawing, only the relevant segment.

 

The Repaint Brush tool is used to paint a section by manually painting over the lines. This is useful 
when the vectorization triangles are not placed as you would like or you simply need to repaint a 
section of a segment. It is also useful for paperless animation, where there are no triangles. So, the 
Repaint Brush is used to paint a certain area. It acts like the Brush tool, but will only show on painted 
areas that are already painted. 

Unlike the Brush tool, the Repaint Brush flattens automatically. The brush strokes are not added one 
on top of each other.

When you are done inking one colour, you can lock it so if you ever paint over it accidentally, the work 
already done will not be affected. You can also use the Protect Colour feature to block the filling 
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colours if you painted all of the animation in Line Art and you plan to repaint the lines—see Protecting 
Colours  on page 542.

The Brush tool is often the most intuitive and rapid tool for creating rough sketches and clean lines. A 
single colour, such as black, is often used when tracing a clean version of a rough sketch. However, 
when it comes time to soft trace the lines in different colours, the flattened or unflattened clean brush 
strokes can suddenly become time consuming to ink. 

Toon Boom Harmony lets you create triangular breaks at natural line intersections. These 
intersections are the probable locations where colour line breaks may occur, such as where a sleeve 
meets a hand.

Although pencil lines can be painted in much the same way as closed zones, you can use the Paint, 
Repaint, Repaint Brush, and Ink tools to make painting segmented lines easier. Normally when you 
have a drawing, such as the one below, and you use the Paint tool to paint one of the lines, the entire 
line is painted.

However, if you select the Ink  tool instead and click on the same pencil line, only the segment that 
you clicked on between two intersections will be painted.

The newly inked segment will always be moved to the front of all other pencil strokes, even if it was 
behind all other pencil strokes before it was inked.

That is, unless you hold down Alt while clicking a segment. Then the opposite becomes true. The inked 
segment will be sent to the back, even if it was in front of all other segments to begin with.
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Painting and Inking can be used in combination depending on what it is that you need to paint. If you 
need to ink a character’s outline in black, it might be easier to use the Paint tool. If you need to paint 
the outline of a character’s neck with a tan colour and its shirt outline blue and both the neck and shirt 
belong to the same continuous outline, then the Ink tool might prove more useful.

How to select the Repaint Tool

1. In the Tools toolbar, select the Repaint  tool located in the Paint tool drop-down menu.

How to select the Repaint Brush

1. In the Tools toolbar, select the Brush  tool.

2. In the Tool Properties view, enable the Repaint Brush  mode.

How to select the Ink Tool

1. In the Tools toolbar, select the Ink  tool located in the Paint tool drop-down menu.

How to protect colours

1. In the Colour view, select a colour to lock.

2. Do one of the following:
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‣ Right-click and select Protect Colour.

‣ From the Colour view menu, select Colours > Protect Colour. 

A red bar appears beside the colour to indicate that it is locked.

How to create breaking triangles on a drawing

1. In the  Drawing or Camera view, use the Select tool to select part or all of the drawing to be 
broken.

2. From the top menu, select Drawing > Create Breaking Triangles. If your brush strokes are not 
flattened, they will be flattened automatically before the breaking occurs.

3. Use the Repaint tool  to paint the outline of different colour zones with different colours.
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Verifying the Zones are Painted

When the ink and paint process is completed, it is always a good idea to verify that every zone was 
painted properly.

The first step to check your ink and paint is to go through all  your drawings and verify that there are no 
colour mistakes. You can use the F and G keyboard shortcuts or the Preview option available in the 
Xsheet.

The backlight produces a silhouette effect by changing the drawing’s coloured areas into a single 
dark, solid colour use this to verify the completeness of the ink and paint process. Any unpainted 
zones can be seen as the light shows through the unpainted areas of the silhouetted drawing.

How to preview drawings from the Xsheet

1. First, save your scene. 

2. Do one of the following:

‣ From the top menu, select File> Save. 

‣ Click the Save  button. 

‣ Press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X).

3. In the Xsheet view, select the range of drawings or the whole column to preview.

4. In the Xsheet View  menu, select View > Preview Selected Drawings or press Alt + P.

The Play window opens.
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5. Play your drawings.

6. Select the Preroll option to see blank frames at the beginning and end of the animation sequence 
while looping the playback.

How to use the backlight

This feature is only available in the Drawing view.

1. Do one of the following:

‣ From  the top menu, select View > Backlight.

‣ In the Drawing View toolbar, click the Backlight button.

‣ Press Alt + Shift + B. 

2. Verify the drawings in the Colour Art to make sure that all the areas are painted. From the Camera 
or Drawing View menu , select View > Switch to Colour Art or press L.

3. In the Art Layer toolbar, click the Preview All Art Layers  button  to see the colour zones with 
lines to ensure that you did not forget any spots between the colour filling and lines.
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Ink and Paint Tool Properties

The Ink and Paint tool properties contain many options that will help you along with your task.

• Ink Tool Properties below

• Paint Tool Properties  on the facing page

Ink Tool Properties
When you select the Ink tool, its properties and options appear in the Tool Properties view.

Icon Tool Name Tool

Lasso and Marquee

The Lasso and Marquee options let you 
choose the type of selection the current tool 
will perform. The default selection mode is 
Marquee.

• Lasso  lets you draw a custom selection 
box around zones.

• Marquee  makes a rectangle selection 
box.

Hold down the Alt key to switch 
to the opposite mode of your 
selection.

How to invert a selection

1. Do one of the following:

‣ From the top menu, select Edit > 
Invert Selection. 

‣ From the Camera or Drawing 
menu, select Edit > Invert 
Selection.

‣ Press Ctrl + Shift + I 
(Windows/Linux) or ⌘  + Shift + I 
(Mac OS X). 

Show Inkable Lines

Highlights all pencil lines (no brush strokes) 
on the selected layer. Pencil line segments 
that are already inked with the selected 
swatch colour from the colour palette are 
also not highlighted.
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Be Smart on Con-
necting Lines

As you hover and move the cursor across 
intersecting pencil lines, the path that you 
create will be highlighted. When you click on 
your mouse or stylus the highlighted 
segments are inked.

With this option disabled, all the intersecting 
segments that your cursor comes near will 
be highlighted and become part of the 
selection, even if they were not situated in 
the direction of the chosen path.

Note: This option only works if the Ink tool 
is in Hover mode.

Select Mode

Use this  mode instead of the Hover 
Mode. In the Hover Mode, any potentially 
inkable pencil line will have its central vector 
line highlighted as the Ink tool’s cursor 
hovers over it. Use Ctrl (Windows/Linux) or 
⌘  (Mac OS X) to toggle between the two 
modes.

Select Newly Painted, 
Repainted, Unpainted 
Contours and Lines

Keeps a selection highlighted around the 
latest painted zone after using the Paint, 
Repaint, Unpaint, or Paint Unpainted tool.

Arrange Ink Lines
Brings all newly-inked lines to the front. Disable this 
option if you want all newly-inked lines to be sent to 
the back. Press Alt to toggle between the two options.

Mitre

As you hover over two perpendicular or 
nearly perpendicular segments, a 
highlighted path with a corner is created. 
Clicking on these highlighted segments inks 
both segments and makes them appear as a 
single stroke with a corner or bend.

Click the Mitre    button to choose from 
As is, Round, Mitre, and Bevel. 

Tip Style

Lets you customize the  edge of the Ink tool. 
Options include: Round, Flat, and Bevel.

Paint Tool Properties 
When you select the Paint tool, its properties and options appears in the Tools Properties view.
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Icon Tool

Lasso and Marquee  below

Painting Modes  below

Paint and Remove Texture  on page 556

Apply to Multiple Drawings  on page 556

Apply to All Visible Drawings  on page 557Apply to All Visible 
Drawings  on page 557

Respect Protected Colour  on page 557

Use Stored Colour Gradient  on page 558

Select Newly Painted/Repainted/Unpainted Contours/Lines on 
page 558

Automatic Close Gap  on page 558

Lasso and Marquee 

The Lasso and Marquee options let you choose the type of selection the current tool will perform. The 
default selection mode is Marquee.

• Lasso  lets you draw a custom selection box around zones.

• Marquee  makes a rectangle selection box.

Hold down the Alt key to switch to the opposite mode of your selection.

How to invert a selection

1. Do one of the following:

‣ From the top menu, select Edit > Invert Selection. 

‣ From the Camera or Drawing menu, select Edit > Invert Selection.

‣ Press Ctrl + Shift + I (Windows/Linux) or ⌘  + Shift + I (Mac OS X). 

Painting Modes 

The Paint tool has four different modes available:
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You can also find these tools directly in the Tools toolbar and in the Drawing Tools menu.

Paint Mode 

  

The Paint  mode paints everything it touches, including empty and filled zones.

Paint Unpainted Mode 

The Paint Unpainted  mode paints only empty zones. Any line or filled zone will remain unchanged.

 Repaint Mode 

The Repaint  mode paints everything it touches except empty zones. Any zone that is not painted 
will remain intact.
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Unpaint Mode 

The Unpaint  mode unpaints everything it touches, including empty and filled zones.

Paint and Remove Texture 

The Paint and Remove Texture  option is used when you vectorized images as greyscale texture 
style. An image vectorized as texture is a mix of bitmap filling encapsulated in a vector-based frame. 
Painting a textured zones with the Paint tool will change the tint of the textured lines. Painting the 
textured zones using the Paint and Remove Texture option transforms the bitmap filling into a 100% 
vector based zone and fills it with a solid colour.

Apply to Multiple Drawings 
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The Apply to Multiple Drawings  option is used for fast painting in hand-drawn animation. When 
you want to paint several drawings in a same layer at once, such as a walk cycle, you can enable this 
option and make a selection in your Camera or Drawing view. All the closed zones located within your 
Paint tool selection are painted with the selected colour swatch.

You do not need to enable the Onion Skin preview to use this option. The option will stay enabled only 
for the next action. If you want to use it again, you must click on the Apply to Multiple Drawings 
button again, or press Alt + A.

Apply to All Visible Drawings 

The Apply to All Visible Drawings  option is used to paint several drawings on separated layers on 
the current frames. If you have a character broken in several layers, you can enable this option to paint 
all your layers at once. The operation is only applied on the current frame. This option will stay enabled 
only for the next action. If you want to use it again, you must click on the Apply to All Visible Drawings 
button again.

This option is only available in the Camera view and does not affect symbols.

Respect Protected Colour 

The Respect Protected Colour option is enabled by default. In your Colour view, you can protect 
some colour swatches to avoid repainting or unpainting the zones linked to that swatch. 

If you disable this option the Paint tool will not follow the protect colour rule and will repaint or 
unpaint the protected colours on your drawings until you enable the option again—see Protecting 
Colours  on page 542.
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Use Stored Colour Gradient 

When you paint a zone with a gradient or textured colour swatch, the gradient or texture’s position is 
set relative to the size of the zone your are painting. If you want the Paint tool to use a particular size 
and position, you must first store your desired position and size using the Select  tool and then 
enable the Use Stored Colour Gradient   option in the Paint tool Tool Properties view—see Editing 
Gradients and Textures  on page 535.

Select Newly Painted/Repainted/Unpainted Contours/Lines

In the Paint   tool Tool Properties view, enabling this option  will keep a selection highlighted 
around the latest painted zone after using the Paint, Repaint, Unpaint, or Paint Unpainted tool.

Automatic Close Gap 

The Automatic Close Gap option has four modes available:
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The Automatic Close Gap options are used while painting drawings with small gaps. 
Instead of having to close them manually with the Brush tool or Close Gap tool, Toon Boom Harmony 
will analyze the drawing and close the gaps while you paint according to the selected mode. The 
automated gap closing should be done using the zoom function setting of your Camera or Drawing 
view. If your eye does not see the gap, Toon Boom Harmony won’t either—see Closing Gaps on 
page 540.
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Chapter 29: Morphing

Hand-drawn animation requires you to spend a lot of time tracing in-between drawings. Harmony 
speeds up the process using its helpful morphing feature. This powerful and useful feature creates 
computer-generated drawings and places them between vector drawings to save time and increase 
productivity. Animation created with the morphing feature can be reused in different projects. You can 
easily modify the timing and velocity (ease in and ease out).

One of the main uses of the morphing feature is effects animation. For example, animating smoke or 
water can be time-consuming because these types of effects are usually slow moving requiring a large 
number of closely placed inbetweens.

This chapter is divided as follows:

• Understanding Morphing on the next page

• Source and Destination Drawings on page 563

• Morphing Rules on page 564

• Creating a Basic Morphing Sequence on page 568

• Tool Properties View on page 571

• Adjusting the Velocity and Timing on page 574

• Morphing Tool and Hints on page 576

• Morphing Two Sequences in a Row on page 584

• Inserting a Morphing Key Drawing on page 585

• Converting Morphing Inbetweens to Drawings on page 586

• Morphing Holes and Transparencies on page 587

• Adjusting the Morphing Quality on page 590

• Tips and Tricks on page 591
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Understanding Morphing

The morphing feature is used to animate similar and simple shapes such as hair or smoke. It helps you 
by saving time when you are working on tedious inbetweening and tracing tasks This, in turn, provides 
you with more time to spend on complex animation tasks such as walk cycles or acrobatic sequences.

Ideas Behind Morphing

To learn how to morph drawings, it is better to start with basic shapes such as circles and rectangles. 
Once you are more familiar with the tool, you can increase your knowledge and expertise. In a very 
short time you will be producing some remarkable effects. 

It is helpful to know the pros and cons of morphing before you start. Understanding what you can do 
and which drawing lines may be more useful or problematic will enable you to design your key 
drawings so they morph efficiently. 

The more complex the shape is, the longer it takes to morph. If it takes more time to morph a drawing than 
to hand-draw it, then it is better to animate it instead of morphing. However, if you spot an occasion when 
you can morph your drawings, do it! It allows you to fix your timing and velocity in no time without having to 
create any extra drawings!
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Source and Destination Drawings

The morphing feature matches similar shapes in a source and a destination drawing. Harmony 
evaluates the source's shape properties and matches them to the most similar ones in the destination 
drawing.

Morphing works between similar shapes, which are drawings that have the same palette, colours and 
number of shapes. You can even change any shape into another one, as long as the source and 
destination keep the same colours, number of lines and number of shapes.
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Morphing Rules

Harmony follows a set of rules as it evaluates the shapes. Familiarize yourself with these basic 
morphing rules before you start morphing.

Note that a morphing sequence can only be done on vector drawings. You cannot morph bitmap layers or 
Toon Boom bitmap drawings.

Closest Similar Shape

A colour, line shape or zone will morph with the closest similar one in the destination drawing. This 
means it will morph with the zone nearest to it, as long as that zone uses the same palette's colour 
swatch (colour ID) and has the same vector properties (Central or Contour).

In the example above, the red heart shape (1) will morph with the closest shape using the same 
colour swatch. It will morph with the red diamond shape (1) in the next drawing. The red diamond 
shape (2) in the source drawing will morph with the red heart shape (2) located in the same area in 
the destination drawing. The black spade shape (3) in the source drawing will morph with the black 
club shape (3) located in the same area in the destination drawing. Finally, the black club shape (4) in 
the source drawing will morph into the black spade shape (4) located above in the destination 
drawing.

Pencil Line to Pencil Line

If you trace a shape using a pencil line such as the Ellipse , Rectangle , Polyline , Line  
or Pencil  tool, you have to morph it with another pencil line. Make sure that both drawings are 
pencil shapes (central vector).
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A pencil line will never morph with a brush stroke.

Pencil lines with thickness are supported in morphing sequences. The thickness will morph according 
to the thickest and thinnest areas in the source and destination drawings.

Pencil lines with textures are not supported in a morphing sequence. During the morphing, the 
texture will disappear and show without pencil line opacity texture.
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If you have pencil lines in your source drawing, the same number of pencil lines must be present in the 
destination drawings. A pencil line will appear if it is not found in the destination drawing. It will pop 
out on the first or last frame depending on which one it is drawn.

When two pencil lines cross one another, they are considered to be two lines and not four lines 
anymore (as it was in version 7.8 and below of the application). In this case, you must have two pencil 
lines in your destination drawing for your morphing to work correctly.

Fill Shape to Fill Shape

If you have a brush stroke or a colour fill ( contour vectors), make sure that you morph it with another  
brush stroke or fill zone. It is important to undersand that strokes drawn with the Brush tool are the 
same thing as zones painted with the Paint tool. Vector points are located along the contour. They 
are simply not the same size. Contour vectors will not morph with pencil lines (central vectors). A 
brush stroke can morph into a colour fill zone and vice versa as they are the exact same thing.
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Colour Swatch to Same Colour Swatch

Harmony does not morph between colours. If you want to perform a colour transition, you have to 
create the effect during the compositing step of your production. A colour palette is composed of 
colour swatches. Each colour swatch has its own unique identification number, even if two swatches 
are the same colour value, they are identified independently. A colour zone or shape will morph with 
another one painted with the same colour swatch.

Vanishing and Appearing

If a colour zone does not find a match in the first or the second drawing, it will progressively appear 
or disappear.

Colour Art to Colour Art and Line Art to Line Art

In Harmony, there is an advanced concept for painting your drawings called Line Art and Colour Art. 
Basically, an extra layer is added in your drawings so that you can fill the colour zones on a separate 
layer. The regular layer on which you are drawing is called Line Art and the extra layer under the Line 
Art is the Colour Art.

• A shape drawn in Colour Art can only be morphed with another shape existing in the Colour 
Art. 

• A shape drawn in Line Art can only be morphed with another shape existing in the Line Art. 

• A shape created in Colour Art can never morph with a shape created in Line Art.
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Creating a Basic Morphing Sequence

When it comes to morphing, you will need to practice and become at ease it. Once you are familiar 
with the basic rules, you can start creating morphing sequences. To begin, start with simple elements. 
When you are confident with the morphing process, you can start to use complex and advanced 
morphing techniques, such as head rotations or full characters.

You may want to delete an entire morphing sequence in order to redo a sequence from scratch.

How to create a basic morph

1. In the Timeline View toolbar, click the Add Drawing Layer  button to add a new layer to your 
project.

2. Rename the new layer ( for example, Morphing).

3. In the Timeline or Xsheet view, select the first cell in the layer.

4. Do one of the following:

‣ In the Tools toolbar, select the Rectangle  tool.

‣ Press  Alt + 7.

5. In the Camera or Drawing view, draw a rectangle.

6. Do one or both of the following:

‣ Hold down the Shift key to draw a square.

‣ Hold down the Alt key to draw the rectangle from its centre.

7. Paint your rectangle using the Paint tool.
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8. In the Xsheet or Timeline view, select the last cell.

9. Do one of the following:

‣ In the Tools toolbar, select the Ellipse  tool.

‣ Press  Alt + =.

10. Draw and paint the ellipse using the same outline colour as the rectangle.

11. In the Xsheet or Timeline view, select the first frame and all the frames up to and including the last 
frame, which is the rectangle drawing.

12. Do one of the following:

‣ From the top menu,  select Animation > Morphing > Create Morphing.

‣ In the Xsheet or Timeline view, right-click and select Morphing > Create Morphing 

‣ Press Alt + M.

Arrows appear between the two key drawings to show that computer generated in-betweens have 
been created.
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Use the Playback toolbar to play the morphing sequence. To flip through the inbetweens toggle between 
comma ( , ) and period ( . ). Press F4 to toggle between the two key drawings.

How to delete an entire morphing sequence 

1. In the Xsheet or Timeline view, right-click on a cell between two keyframes. 

2. Do one of the following:

‣ From the top menu, select Animation > Morphing > Delete Morphing.

‣ In the Xsheet or Timeline view, select Morphing > Delete Morphing.

The entire sequence between the two keyframes is removed.
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Tool Properties View

As you create and adjust your morphing sequences, you will often use the Tool Properties view. Using 
this view allows you to do things such as toggle between your key drawings, adjust the easing or 
select a hint type. 

How to access the content of the Tool Properties view

1. Do one of the following:

‣ In the Tools toolbar, select the Morphing  tool.

‣ Press F3.

Hint Type

The Hint Type drop-down menu allows you to select the correct hint to remedy any problem areas in 
your drawing—see Contour Hint on page 579 and Morphing Tool and Hints on page 576.

You can have more than one hint type in your drawings. You can mix all of the hint types in your 
morphing sequence.
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Hide Hints

The Hide Hints  button temporarily hides the hint points from the key drawings. Use this option 
when you have a series of hint points hiding some lines you would like to see.

Show Morphing in Place

The Show Morphing In Place  option is used with morphing layers. Enabling this option prevents 
the currently selected morphing layer from being shown on top of the others and maintains the 
correct layer ordering—see Morphing Layers.

Suggest Hints

The Suggest Hints  option is used to automatically set hint points on your key drawings as a help 
tool. If you are not sure where to set your hints, you can use this option. It will set the main hints 
which you can then fine tune.

Switch Between Drawings

The Switch Between Drawings  button is used to toggle between the two key drawings in your 
morphing sequence. This option is useful while setting hints. You can use the default keyboard 
shortcut F4 to toggle between your drawings.

Flatten

The Flatten  option is used when you have to morph a sequence with a semi-transparent or 
transparent colour in it—see Morphing Holes and Transparencies on page 587.

Quality

The Quality setting is used to make the lines of the morphed drawings smoother. Adjust this 
parameter when you are doing an extreme close up of your animation—see Adjusting the Morphing 
Quality on page 590.
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Easing

The Easing option is used to adjust the starting and ending velocity of your morphing sequence so 
that the motion is smooth and not mechanical.

You can adjust the Ease In and Ease Out value by dragging your cursor up and down or typing a new 
value. The values go from -1.0 to 1.0—see Adjusting the Velocity and Timing on the next page

Convert Hints

The Convert Hints  option is used to switch the type of the selected hint points. This option is 
useful when you position hints and then realize they are not the right type. You can select them and 
convert them to the correct type instead of deleting them and setting new ones.

Use the Morphing tool to select the hints and then convert them by going to the Tool Properties 
view and selecting the new hint type from the Convert Hints drop-down menu.

Time

The Time field is used to set the timing on Appearing Point and Vanishing Point hints. These hints are 
used to set the trajectory of appearing and vanishing objects, With the Time field, select your 
Appearing Point or Vanishing Point hint and type the frame number on which the object will start its 
appearing or vanishing animation.
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Adjusting the Velocity and Timing

Once you have set up a morphing sequence, you can control its timing and velocity. When you look at 
your animation you will notice that the morphing motion is constant. To produce a less mechanical 
motion, you will probably want to create some ease in or ease out.

If you did not place your source and destination drawings on the correct frames you may need to 
extend or shrink the sequence length.

If you have several morphing sequences on a single layer, you may find it easier to adjust their 
velocities on one function curve rather than several separate ones. Having all of your velocity 
parameters in one place is more efficient and easier to modify.

Adjusting the velocity in the Layer Properties editor also allows you to reverse a section of the 
morphing sequence. The sequence will always start with the source drawing and end at the 
destination. You can play the morphing sequence backwards or forwards during the animation.

You can have two levels of easing:

• In the Tool Properties View, you can adjust the velocity of each sequence in your layer 
independently

• In the Layer Properties editor, you can adjust the morphing velocity function to control the entire 
layer's easing

How to extend or shrink a morphing sequence length

1. In the Timeline view, select the source or destination drawing.

2. Click on your selection and drag the drawing to its new frame.
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How to adjust the velocity in the Tool Properties view

1. In the Timeline view, click on a frame in the morphing sequence you want to adjust.

2. In the Tool Properties view, increase and decrease the Ease In and Ease Out value to adjust the 
sequence's velocity.
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Morphing Tool and Hints

Harmony's Morphing  tool controls your morphing sequence, this works by placing different types 
of hints to help the system morph the animation the way that you want it.

Hints are points that are placed in both the source and destination drawings. They associate zones 
and lines between the two drawings. Hints are used to fix problem zones, such as a line that is not 
following the colour fill zone.

Corners and points are more challenging, in general. Animation curves are complex and may be unable 
to match corners. It will generally associate a corner with its nearest neighbour; this is not always 
correct and it is why we use hint points to determine what goes with what.

Using the Morphing Tool
Hints are identification points existing in both the source and destination drawings to create 
associations between the two of them.

To correct morphing distortions, Harmony has different types of hints available for controlling 
different types of problems:
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• Contour Hint on page 579

• Zone Hint on page 580

• Pencil Hint on page 580

• Vanishing Point Hint on page 581

• Appearing Point Hint on page 581

Each type of hint has a different purpose and they can all be used in the same drawing. Use the 
Morphing tool to add hints to your morphing sequences.

A hint will automatically appear in both the source and destination drawings when it is added. A hint 
cannot exist in a single drawing. If you delete a hint from one drawing, it will be also deleted from the 
other.

The key to placing your hints is to put them where the biggest problem is. Fix the largest distortions 
first, this may also fix the smaller ones at the same time.

Do not add too many hints, this is a common mistake when morphing, it takes some practice to learn 
how to correctly use and place hints.

To add and remove hints:

1. In the Timeline or Xsheet view, select the source or destination drawing of your morphing sequence.

2. In the Tools toolbar, select the Morphing  tool or press F3.
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Use your other morphing key drawing, shown in the Drawing view's bottom right corner, as a 
reference.

3. In the Tool Properties view, select the type of hint you want to use.

‣ Select Contour Hint to correct a brush line or colour zone's contour (Contour vector).
Contour Hint points will behave similar to Pencil Hint points when used on a pencil line. Note 
that you obtain better results using the Pencil Hint point on pencil line rather than Contour 
Hint points.

‣ Select Pencil Hint to correct a pencil line (Central vector).

‣ Select Zone Hint to correct a colour zone morphing match.

‣ Select Vanishing Point Hint to correct a vanishing shape's trajectory. 

‣ Select Appearing Point Hint to correct an appearing shape's trajectory. 

4. In the Camera or Drawing view, click on the drawing near the problematic area.
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5. Select the hint's point and move it to its correct position.

6. Select one or many hints and press Delete to remove extra or unused hints.

‣ To delete all of the hint points at once, press Shift + Delete.

7. In the Playback toolbar, press the Play  button to see the result.

Hints

Hint points in the source drawing are green and red in the destination drawing.

Contour Hint

The Contour Hint  point is used on the colour fill zone and brush lines; in other words, on 
Contour vectors. It allows the control of line thickness and contour position. Also, if a contour is not 
animated the way that it should be you can use hints to correct the animation. For example, if a flag 
is not waving properly.

When adding a Contour Hint point, make sure that you place it far enough away from the contour so 
that you can see it snap to the contour. 

The Contour Hint points are yellow.
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Do not place the Contour Hint directly on the line as it may look like it has snapped to the contour, when 
in fact, it has not and the morphing will remain unchanged.

To correct a brush stroke, place a hint on both sides of the line to indicate its thickness variations over 
time.

Zone Hint

The Zone Hint  point is used on a colour zone to control the proximity rule. The Zone Hint is 
placed in the centre of the colour zone. Sometimes a colour zone is not associated with the 
corresponding one by default. For example, in a splash animation there are many water droplets 
that are the same colour. The system automatically morphs the droplet to the nearest one. This is 
not always the one you may have predicted. A Zone Hint will force a colour zone to morph with 
another one.

Zone Hint points are cyan in colour so you can easily see them.

Pencil Hint

A Pencil Hint  point is used to control a pencil line, also known as central vector. It can be used on 
drawings that were done using the Pencil, Polyline, Ellipse, Line and Rectangle tools. Like the 
Contour Hint, the Pencil Hint snaps to the central vector. Make sure to place it far enough away from 
the line so you will see it snap when you move it.
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Pencil Hint points are magenta in colour so you can easily see them.

Vanishing Point Hint

A Vanishing Point Hint  is used to control the trajectory of a vanishing shape. A shape will vanish 
from the source drawing when there is no corresponding shape in the destination drawing. If you do 
not place a Vanishing Hint to control the point of disappearance, the shape will vanish into its centre.

Vanishing Point Hint points are green in colour so you can easily see them.

Appearing Point Hint

An Appearing Point Hint   is used to control the trajectory of an appearing shape. A shape will 
appear in the destination drawing when there is no corresponding shape in the source drawing. If 
you do not place an Appearing Point Hint to control the point of appearance, the shape will appear 
from its centre and expand outwards.
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Appearing Point Hint points are violet in colour so you can easily see them.

Copying Hint Points from One Drawing to Another

If you have two morphing sequences that use the same drawing and you would like to copy it and its 
hint points, you can do so in the Drawing view.

How to copy a drawing and its hints

1. Do one of the following:

‣ In the Tools toolbar, click the Select  tool.

‣ Press  Alt + S.

2. In the Drawing view, select the drawing to reuse in your second morphing sequence. 

3. Do one of the following:

‣ In the top menu, select Edit > Copy.

‣ Press Ctrl + C (Windows/Linux) or ⌘  + C (Mac OS X).

4. In the Timeline view, select the cell where the new drawing will be.
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5. In the Drawing view, paste your selection. 

6. Do one of the following:

‣ In the top menu, select Edit > Paste .

‣ Press Ctrl + V (Windows/Linux) or ⌘  + V (Mac OS X).

7. In the Timeline view, select the cell where the second drawing will be.

8. In the Drawing or Camera view, draw your second drawing.

9. Do one of the following:

‣ In the Timeline view, create the morphing sequence for the new drawings.

‣ Press Alt + M.

10. Do one of the following:

‣ In the Tools toolbar, select the Morphing  tool.

‣ Press F3.

11. In the Drawing or Camera view, position your hint points.
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Morphing Two Sequences in a Row

If you are morphing two sequences in a row, you will have to create a different set of hint points for 
each sequence.

Morphing two sequences in a row requires three drawings: 1, 2 and 3. Using these three drawings you 
create two morphing sequences; one sequence between drawings 1 and 2, and a second sequence 
between drawings 2 and 3.

Each morphing sequence has its own set of parameters and hints. This means that Drawing 2 will have a set 
of hints for the first sequence and another set for the second sequence. The two sets of hints will not show 
at the same time. Each set of hints that appears always corresponds to the morphing sequence you are 
working on.
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Inserting a Morphing Key Drawing

Once you have a morphing sequence, you can add a morphing key drawing.

A morphing key  drawing allows you to insert extra details into a morphing sequence. For example, 
during a morphing sequence you may need to insert a detail such as teeth or a mouth, this is easy to 
do when you use a morphing key  drawing. Instead of creating an entirely new drawing, convert a 
computer generated in-between to a morphing key  drawing and add your extra details to it and the 
next key drawing.

A morphing key  drawing converts a computer generated morphing frame into a real drawing that you 
can edit. It splits the morphing sequence into two sequences, retaining any previous modifications.

How to insert a morphing key drawing

1. In the Timeline or Xsheet view, select the morphing frame you want to transform into a morphing 
keyframe.

2. Do one of the following:

‣ In the top menu, select Animation > Morphing > Insert Morphing Key Drawing.

‣ Right-click and select Morphing > Insert Morphing Key Drawing.

The new morphing key  drawing appears.

3. In the Drawing or Camera view, draw your new details on the morphing key  drawing.

4. In the Playback toolbar, press the Play  button to see the result.
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Converting Morphing Inbetweens to Drawings

Harmony lets you convert your morphing inbetweens to real drawings that you can edit. 

This is useful when you manually edit your morphing sequence or if you prefer to have your animation 
timing in double frame (on twos) instead of single frame (on ones). 

How to convert morphing inbetweens to drawings

1. In the Timeline or Xsheet view, select a morphed drawing  in the morphing sequence you want to 
convert to real drawings.

2. Do one of the following:

‣ In the top menu,  select Animation > Morphing > Convert Morphing to Drawings.

‣ Right-click and select Morphing > Convert Morphing to Drawings.

The Converting Morph dialog box opens.

3. Type the drawing basename you want to give to your new drawings. In this case, you could type 
circle.

4. Click  OK.
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Morphing Holes and Transparencies

To be able to morph shapes with holes or transparent colours, it is important to understand the 
process of analyzing and morphing a shape. Harmony begins the process by reading the exterior 
outline of the entire shape. So if you are morphing a doughnut, it will first read the entire circular shape 
and ignore the central hole.

Once the general morphing shape is analyzed, the system will carry on analyzing the interior details 
such as colour zones and holes.

As you can see, because the hole was placed on top after the main shape was morphed, the centre is 
filled with an opaque brown colour. In order to avoid opaque holes, you have to paint the zone with a 
transparent colour so that you can control it and flatten the transparency to cut a hole through the 
main shape.

The same thing happens when you have holes painted with semi-transparent colours. To see through 
your shapes, you have to follow the same process as morphing shapes with holes.
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How to morph a shape with a hole

1. In your Colour view, select an unused colour swatch and set its alpha (transparency) to 0.

2. Paint both holes on the source and destination drawings.

3. In the Timeline or Xsheet view, click on a cell in your morphing sequence.

4. Do one of the following:

‣ In the Tools toolbar, select the Morphing  tool.

‣ Press F3.

5. In the Tool Properties view, enable the Flatten  button.

A hole appears in the shape.
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Adjusting the Morphing Quality

Increasing the morphing quality settings improves the line shape between vector points. It also creates 
a larger file, so only increase quality when you are zooming in closely. You can adjust the quality in the 
Tool Properties view and in the Preferences panel.

When morphing in Toon Boom Harmony, there is a preference you can set to help you set the default 
quality of morphing sequences. Refer to the following parameter in the Preferences Guide for 
complete descriptions.

• Drawing tab: Settings, Morphing Quality

How to set a morphing sequence's quality level

1. In the Timeline or Xsheet view, click on a cell in your morphing sequence.

2. Do one of the following:

‣ In the Tools toolbar, select the Morphing  tool.

‣ Press  F3.

3. In the Tool Properties view, adjust the Quality level.
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Tips and Tricks

This section provides a list of easy tips and tricks to help you morph your drawings more efficiently.

Using the Brush Tool as a Beginner

When learning about morphing, it is recommended that you use the Brush tool. You can use the 
Pencil line for simple closed shapes.

Flattening Drawings

Flatten your drawing before starting a morphing sequence.

Cleaning-up your Drawings

If you leave a dot, even the smallest one, it is possible that your morphing will create odd shapes. If 
the source line is closer to the dot than the destination line, the source line will morph into the dot 
and the destination line will disappear.

Using the Same Colour Swatch

Use the same colour swatch between two drawings. You cannot morph between two different 
colour swatches even if they have the same RGB values. This can be turned to your advantage for 
complex morphing.

Morphing Similar Shapes

Similar shapes should have the same number of colour zones. This only applies to the number of 
zones and lines and not the number of points on a curve.

Avoiding Crossing Zones During Morphing

If a zone inside a larger zone on the source drawing ends up outside on the destination drawing, the 
morphing will fail.

A line cannot cross another line during a morphing sequence. 

For example, if you are morphing a face so it turns from the front to the side, the nose is located in 
the middle of the face on the source drawing. However if after morphing, the nose ends up outside 
or merged with the face profile line on the destination drawing, this will give undesirable results. You 
can avoid this by using morphing layers and splitting the nose on a separate layer.
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Chapter 30: Character Building

Harmony is a great tool for building characters. You can use different techniques and features to 
break down your puppets. 

This chapter contains the following topics:

• Setting the Default Separate Position Preference on the next page

• Breaking Down the Character on page 596

• Ordering the Layers on page 607

• Rigging on page 610

• Adding Extra Drawings on page 622

• Setting the Pivots on page 624

• Storing the Character in the Library on page 628

• Appendix on page 630
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Setting the Default Separate Position Preference

Before you start adding layers to your puppets, you should enable the Default Separate Positions for 
Elements preference if it is not already done.

With the Default Separate Positions for Elements option selected, when you create new layers, their X, 
Y and Z axes are independent from each other.

By default, this preference is enabled. For cut-out animation, you want to have three independent axes 
so you can control them individually. When you lock the three positions together, each time you add a 
keyframe, it is added on all three positions at the same time.

When you separate the three positions and add a keyframe on one axis, it is not added on the other 
two. This gives you more freedom when animating with motion keyframes and nudging parts forward 
and backward over time.

How to enable the Default Separate Positions preference

1. Do one of the following:

‣ Windows/Linux: Select Edit > Preferences.

‣ Mac OS X: Select Stage > Preferences.

‣ Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

2. In the Preferences dialog box, select the General tab.

3. In the Settings section, select the Default Separate Positions for Elements option.
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4. Click OK.
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Breaking Down the Character

There are many techniques you can use to break down a puppet. In this section, you will learn about 
one of the most common and simplest methods. For your first character breakdown1, follow these 
instructions to get an idea of the way Harmony works. Once you understand Harmony's basic 
functions and commands, you will be able to create your own techniques to satisfy the needs of your 
production.

Refer to the Appendix on page 630 at the end of the chapter for alternate tips.

Tracing the Model
The main breakdown technique shown here is to trace your model, completing the hidden lines and 
filling the gaps—see the Appendix on page 630 to learn about more techniques.

How to break down a character

1. In the Timeline view, add a new drawing layer for each body part to separate. You can press Ctrl + 
R (Windows/Linux) or ⌘  + R (Mac OS X).

2. In the  Timeline view, select the layer's first cell in which you want to draw the part.

1In cut-out animation, the breakdown is the action of breaking a character into pieces to create a puppet with 
articulations. To breakdown a character, the artist will cut parts, such as hands and arms, from the character's 
model and paste them in separate layers. Next, the joints will be fixed and the pivots set. In  additional 
animation, a breakdown is an animation pose generally found between two key poses. The key poses are the 
main poses in an animation and the breakdowns are secondary poses, ones that help to describe the motion and 
the rotation curve.
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3. In the Tools toolbar, select a drawing tool.

4. In the Colour view, select a colour swatch.

5. In the Camera or Drawing view, draw the new part.

If you are working in the Drawing view, click the Light Table  button  in the Drawing View toolbar 
to display the other layers as washed out colours. You can also press Shift + L.

6. In the Tool Properties view, you can set the Pencil tool width to 0 to create an invisible hairline if 
you want to close a shape without drawing an actual stroke.

‣ Select View > Show > Show Strokes or press K to display the invisible lines.
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7. In the Tools toolbar, select the Paint or Paint Unpainted  tool to colour your drawing.

8. In the Colour view, select the corresponding colour.

9. In the Camera or Drawing view, paint your drawing.

10. In the Tools toolbar, select the Select  tool. Select your drawing and flatten the lines by clicking 
the Flatten  button in the Tool Properties view.

11. If your lines are composed of several pencil strokes, you might want to combine them into one 
single smooth pencil line. Using the Select tool, select the pencil lines to be merged and in the Tool 
Properties view, click the Merge Pencil Lines  button.
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12.Repeat the entire process until the break down is completed.

Articulations

Once your pieces are traced, you can proceed to the completion of the articulations.

Articulations are an important aspect of any cut-out break down because without them, a puppet 
cannot move properly and will not look good.

Classical Articulation

Classical articulation is the most popular technique for basic characters. It is quite simple and 
produces excellent results, but it is not the most efficient method. In many instances, it causes 
limitations and extra drawing corrections. For example, there may be a gap in the articulation if the 
part is bent too far. Joint design is usually a circle; the overlapping part cannot be sent behind without 
showing the joint.
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Classical articulation is done by erasing a part of the line from the overlay layer, leaving the colour 
overlapping the bottom one. You can use this technique for all the articulations on your puppet.

How to create a classical articulation

1. In the Timeline view, select the cell containing the first part to modify, such as the upper arm.

2. In the Tools toolbar, select the Pencil , Polyline , Ellipse , or Contour Editor tool.

3. In the Colour view, select an outline colour.

4. In the Drawing or Camera view, use your drawing tool to make sure that the joint overlaps the 
other part in a half-circle shape.
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‣ If you are working in the Drawing view, click the Light Table  button in the Drawing View 
toolbar or press Shift + L.

5. From the top menu, select View > Show > Show Strokes or press K to display the invisible lines 
that may be present in your drawing.

6. In the Drawing or Camera view, select all the strokes in your drawing.

7. In the Tools Properties view, click the Flatten  button.

8. In the Drawing or Camera view, select all the strokes in your drawing.

9. In the top menu, select Drawing > Optimize > Remove Extra Strokes to remove any unnecessary 
invisible lines in your drawing.

10. Repeat steps 1 to 9 for the other part of the joint.

11. In the Timeline  view, select the cell of the part that will be on top of the joint.

12. In the Tools toolbar, select the Select , Cutter or Eraser tool.

13. In the Drawing or Camera view, remove a part of the overlapping outline in order to have only the 
filling colour overlapping the joint.

14. In the Tools toolbar, select the Contour Editor tool.

15. In the Drawing or Camera view, adjust the colour fill so that the pencil outline does not overlap it. 
Be careful not to leave a gap between the line and the fill.
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When placing rotation pivots later on, make sure they are positioned at the centre of the articulation.
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Art Layers

Art layers give you the possibility to divide the artwork in your drawing on different layers. For 
example, you can separate the outline and colour fill on two art layers, similar to 1950s traditional cell 
animation. These art layers are contained within a single drawing as opposed to the timeline layers or 
Xsheet columns where individual drawings with individual timing are stacked one on top of the other—
see Creating Strokes  on page 522. 

Toon Boom Harmony drawings include two layers in Advanced Art mode.

• Line Art below

• Colour Art on the next page

You can access the Art layers through the Camera and Drawing views bottom toolbar. By default, the 
art layers are hidden. Everything is drawn on the Line Art layer. You need to enable the Use Advanced 
Art Mode option.

Each layer can be used for separate hand-drawn animation tasks, letting you organize your work and 
facilitate creation and revision.

Line Art
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In hand-drawn animation, the Line Art layer is mainly used to trace and clean up animation. The 
outline is drawn in the Line Art layer and colour is painted in the Colour Art layer.

Colour Art

In hand-drawn animation, you use the Colour Art layer to paint your animation. The outline is drawn 
in the Line Art layer and colour is painted in the Colour Art layer. Strokes (invisible lines) are 
generated from Line Art to contain the painted area.

When you are doing rough animation, you may want to send a clip to somebody for feedback or 
approval before carrying on with your work. If you have several characters in your project that are 
overlapping, it may be difficult to understand what is going on as you can see through the 
characters. Toon Boom Harmony can generate a matte automatically in the Underlay, or even in the 
Colour Art layer, and fill all the zones inside your characters making them opaque. This process is 
fast and easy and allows you to send easy-to-understand movies.

How to enable the Use Advanced Art Mode preference

1. From the top menu, select Edit > Preferences ( Windows/Linux ) or Stage > Preferences ( Mac 
OS X ).

2. In the Preferences dialog box, select the General tab.

3. In the Advanced section, select the Use Advanced Art Mode option.

4. Click OK.

How to switch between drawing layers

1. In the  Art Layer toolbar, click the Line Art   or Colour Art    buttons. When switching art layer, 
it will allow you to edit the select layer without affecting the other one.
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2. Click the Preview All Enabled Art Layers   button to display both layers together. Even when the 
Preview mode is enabled, you will only be able to edit the select art layer. The other ones are only 
displayed as a reference. By default, the Preview mode is always enabled in the Camera view. You 
will only be able to see the select art layer by itself if you enable the Current Drawing on Top  
option located in the Camera bottom toolbar.

To edit both Line Art and Colour Art at the same time, you must enable the Apply to 
Line Art and Colour Art  button in the Tool Properties of the tools supporting the 
operation.

How to generate a matte

1. Do one of the following:

‣ In the Tools toolbar, select the Select  tool.

‣ Press Alt + S.

2. In the Camera or Drawing view, select the drawing you want to create a matte for. 

You can also apply the operation to all the drawings in the layer at the same time.

3. Do one of the following:

‣ From the top menu, select Drawing > Generate Auto-Matte. 

‣ In the Camera or Drawing view menu, select Drawing > Generate Auto-Matte.

The Auto-Matte dialog box opens.

4. If you want to create a matte for all the drawings included in your layer, select the Apply to 
Multiple Drawings option.

5. Depending on how precise or rough your line is, increase or decrease the radius value. The lower 
the value is, the closer to your lines’ contours the matte will be shaped. The higher the value is, the 
looser the matte will be shaped.
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6. In the Source Art menu, select the layer from which you want the matte created: Line Art or Colour 
Art.

7. In the Destination Art menu, select the layer you want the matte to be created on: Line Art or 
Colour Art.

8. If you already have artwork on the destination layer and you want the content to be deleted before 
the matte is added into it, select the Clear Destination Art First option.

9. If you want the contour of your lines to be copied as invisible lines in your matte drawing (in case 
you ever need to keep them for later), select the Copy Stroke in Destination option.

10. Click OK.
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Ordering the Layers

At this point, it is possible that your character's pieces may show up in the wrong order.

There are several ways to fix this. First, you can reorder your layers by dragging them to a higher or 
lower level in the Timeline view. The top layer is displayed in front of the others and the bottom one is 
displayed behind. Second, you can use the Z-axis nudging (forward and backward) if you have extra 
views included in the same layers (front, three-quarter, back, etc.).

This topic is divided as follows:

• Ordering the Timeline Layers below

• Nudging Parts Backwards and Forwards on the next page

Ordering the Timeline Layers
In the Timeline view, the layer positioned at the top will be displayed in front and the ones below will 
be displayed behind. If you have multiple views, you should order your layers based on the most 
common view, which is generally the three-quarter front.

How to order the layers

‣ In the Timeline view, drag a layer to reorder it and drop it between other layers.
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If you drop it on a layer, it will create a parent hierarchy, so make sure to drop it between layers.

Nudging Parts Backwards and Forwards
If you created a hierarchy on your arms, legs or other body parts, it is possible that you will want a 
part, such as the hand, to appear in front of its parent. Yet, if you move the hand layer above the arm 
layer, you will break the hierarchy. To reorder a layer rigged in a hierarchy, nudge it backwards or 
forwards on the z-axis.

Harmony allows you to move your elements in three dimensions:

• Up and down (Y-axis)

• Left and right (X-axis)

• Backwards and forwards (Z-axis)

In the same way you create multiplane backgrounds (depth), you can perform a micro nudge of the 
part to be reordered and see it in front of the other elements, even if its layer is actually behind the 
other ones in the Timeline view. The forward-backward position can also be animated over time.

Repeat the following instructions for all the views.

How to nudge your parts backward and forward

1. In the Tools toolbar, select the Transform  tool. Make sure to enable the Animate  mode.
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2. In the Camera view, select the element you want to reorder. Make sure the focus (red outline) is 
around the Camera view before selecting the element.

3. To move the element forward,  press Alt + Down Arrow and to move the element backward,  press 
Alt + Up Arrow.
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Rigging

s

The rigging process is where building a puppet can take several different directions. 

• About Rigging below

• Rigging the Head on page 614

• Rigging the Body on page 615

• Creating a Hierarchy on page 616

• Ordering the Layers on page 607

• Adding the Master Peg on page 617

• Creating the Keyframes on page 618

• Masking on page 620

About Rigging
There are some basic concepts to know when rigging and layer parenting:
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• Simple Rigging below

• Parenting Layers on the next page

• Rigging Using Pegs on page 613

Simple Rigging

Simple rigging is very fast and easy to do. It is built as follows:

• All the body parts are independent

• All the timeline layers are attached to a master peg layer (trajectory layer)

The advantage of using this technique is that you are free to move any part around without being 
influenced by a parent layer.

However, since the parts are not parented to each other, the parts will move from point A to point B 
along a straight trajectory. The hand will not follow the arm's rotation. You will have to set more 
keyframes for the hand to move along a curved path.
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Parenting Layers

When you want one part to follow another part, such as the forearm following the arm, you can attach 
the layers one to the other. For example, you can attach the forearm layer to the arm layer without 
having to encapsulate the forearm into the arm layer. They will still be parented, but you can access 
the forearm directly without having to enter the arm layer.

The advantage of parenting layers is that the child layers will follow the parent smoothly without 
having to select them or create a series of keyframes.

612



Toon Boom Harmony 11.1 Draw Guide (Network)

The disadvantage of parenting layers is that you are not able to move the parent independently of its 
children, since the child layers receive all the transformation information from their parent.

Parenting layers, such as the arms and legs, and allowing the torso and hips to be independent from 
them is often a good solution.

To attach one layer to another, you must drag the desired layer onto the other one in the 
Timeline view.

Harmony offers powerful techniques to create hierarchies between your layers without 
having to encapsulate layers into each other. These techniques are a great improvement 
over the less efficient and time consuming method of creating parenting between your 
layers by inserting symbols into other symbols. Therefore, rigging with symbols inside 
symbols is NOT recommended.

Rigging Using Pegs

Peg layer are useful when you are doing more advanced puppet rigging. Peg layers are trajectory 
layers that do not contain drawings. They are motion paths that you can use to control your entire 
puppet or advanced hierarchies.

Parenting a drawing layer to a peg layer allows you to divide your motions on two separate levels.  This 
way, you do not affect any child layers that could be attached to that part. 

Then, you can perform your translation and rotation on the peg layer so all the parts attached to that 
peg layer follow the same trajectory.
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Rigging the Head
You will start by attaching the facial features to the head.

The advantage of parenting the head and the facial features to the same peg is that you can easily 
animate each facial feature, and they will all follow the head motion.

How to parent the facial features to the head

1. In the Timeline view, deselect any selected layers.

2. Select the head peg layer.

3. In the Timeline View Layer toolbar, click the Add Parent Peg  button to add a new peg layer to 
your timeline. You can rename the peg to keep your work organized.
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A new peg is added and parented to the head peg layer.

4. Select all the remaining head and facial feature layers and drag them ONTO the peg layer or 
BETWEEN the head peg layer and the new head peg to parent them.

Rigging the Body
Now that the character's head is ready, you can move on to the body. You can do a simple rigging 
where all the body parts are independent of each other, or create some parenting between some of 
the layers. Refer to Creating a Hierarchy on the next page to learn how to parent your layers.

Simple rigging consists of leaving the layers in the Timeline view without doing any kind of parenting. 
Later on, you will attach those layers to a master peg and organize them in the correct order.
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Creating a Hierarchy
Harmony lets you extend your rigging techniques beyond normal boundaries and sets new standards. 
You can create hierarchies without encapsulating pieces inside each other by creating a linked 
structure between layers.

You should create a hierarchy on the arms and legs, and keep them separated from the body. This 
gives you more animation freedom, and when you need to scale or skew the torso, it will not affect the 
entire body.

How to create a hierarchy in the Timeline view

‣ Drag the child piece (hand) and drop it ON the parent piece (forearm). Then, you can drag the 
parent (forearm) piece onto another parent piece (upper arm).

‣ See See "Nudging Parts Backwards and Forwards" on page 608 to reorder parts that should be in 
front of their parents.

Here is a basic rig with pegs example:
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Adding the Master Peg
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When you animate your character, you will probably need to resize and reposition it to fit your scene. 
When you need to scale down or move your character, it is a good idea to hook (attach) the whole 
puppet to a trajectory.

Attaching your puppet to a peg1 will allow you to scale it and reposition it without having to do this to 
the different parts and pieces. Only one layer will contain the position information, which makes your 
animation easier to modify and control.

How to add a master peg

1. In the Timeline view, select the top layer to parent a peg to it. You need to select a layer to be able 
to add a peg to your scene. Unless you use the Display All mode from the Display toolbar, you will 
get an error message if you try to add a peg without any selection.

2. In the Timeline view, click on the Add Peg  button.

A new peg is added to the timeline as a parent of the selected layer.

3. Name the new peg Master plus the character's name.

4. In the Timeline view, select all the layers you want to attach to your new peg. Remember that one 
item is already parented to that peg.

5. Drag your selection ON to the peg layer to parent all your character's pieces to the peg. If your 
layers are added above the already parented layers, move that parented layer back on top of the 
layer stack.

Creating the Keyframes
Once all your drawings are ordered and your master peg is added, you need to insert keyframes on 
each cell to create all of the function curves and block your pose in place.

1In traditional animation, a tool used to ensure accurate registration of action as cel layers move.  In digital 
animation, in which you are doing a more advanced puppet rigging, you can use peg layers. Peg layers are 
trajectory layers that do not contain drawings. They are motion paths that you can use to add path articulations. 
For the latter, you can also use the Inverse Kinematics tool.
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How to create the keyframes

1. In the Timeline view, collapse the master peg by clicking the Expand  arrow.

2. In the Timeline view, select the first cell.

3. Do one of the following:

‣ From the top menu, select Insert > Keyframe. 

‣ In the Timeline View toolbar, click the Add Keyframe  button.

‣ Press F6.s

If you use the F6 shortcut when working Flash keyboard shortcuts, this not only creates a keyframe but 
also duplicates a drawing.
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Masking

When rigging a character, there will be cases where you want to have the ability to move some pieces 
to give the illusion of a rotation or move the pupil within the white of the eye without having the extra 
bit of the drawing sticking out of the character or eyeball. To do so, you can use masks to cut anything 
you do not want to be visible.

How to mask an object

1. In the Timeline view, make sure the keyframe is added on the object that will be masking the piece 
to cut.

2. Select the layer that will be masking the piece you want to cut.

3. In the Timeline view, right-click on the layer and select Clone Selected Layers.

4. In the Timeline Layer toolbar, click on the Add Layer button and from the drop-down menu, click 
on Mask.
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5. Drag the object to be masked ONTO the Mask effect layer to connect it to the effect and drag the 
cloned layer ONTO the masking group layer to cut the object.

6. Your masking effect is most likely inverted and what you want to cut is probably showing. Double-
click on the Mask layer to open the Layer Properties window. In the Layer Properties window, 
enable the Inverted option.

7. Using the Transform tool, you can now move the cut object within the masking zone.
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Adding Extra Drawings

Your break down is now complete. You can move on to adding extra drawings your character needs, 
such as principal hand positions and mouth shapes. If you ever forget to add extra drawings in your 
main character's template, you can easily add them later.

Add your extra drawings in the layer corresponding to the part you are drawing. You should see the layers as 
containers for the different pieces. Each body part has its own container in which you can add more 
drawings of the same part.

How to add extra drawings

1. In the Timeline view, expand the master peg by clicking the Expand  arrow.
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2. In the Timeline view, select the cell where you want to add a new drawing. If you want to duplicate 
the current drawing and work from it, you can select Drawing > Duplicate Drawings or press Alt + 
Shift + D.

A new drawing is created in the selected cell and automatically extended to the next one. The new 
drawing is a duplicate of the one that was selected so it contains a duplicate of the art. You can 
modify it to create your new drawing or delete its contents in the Camera or Drawing view and 
start from scratch. 

3. In the Tools toolbar, select a drawing tool for drawing your extra part.

4. In the Camera or Drawing view, draw your new drawing.

5. Using the Select  tool, select your drawing and flatten the lines by clicking the Flatten  
button in the Tool Properties view.
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Setting the Pivots

The last step before storing the character in the library is to set the pivots for the different parts. 

Harmony has three types of pivots:

• Peg Pivot
The Peg pivot is a permanent pivot that is applied to the entire drawing layer. If you modify its 
position, it will be changed for the entire layer, modifying the animation, scale and rotation 
interpolation. The Peg pivot is set using the Rotate, Translate or Scale tool. The Transform tool 
will only move that pivot temporarily for positioning purposes, but the animation interpolation 
will be done from the original Peg pivot's position. The Transform tool is designed to move the 
pivot temporarily during the animation process. It also permits you to select multiple pegs and 
apply a common temporary pivot.

To permanently move a peg pivot, use the Rotate  or Scale  tool. 
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• Drawing Pivot
The Drawing pivot is contained within each drawing. In one layer, each drawing can have its own 
pivot. If you have many different views of a character within one layer, the pivot can be different 
and the animation will adjust to the pivot. The Drawing pivot can also be referred to as 
embedded pivot. If you are not mixing different views within the same layers or are using pegs 
to animate your layers, it is recommended to use the Peg pivot.

You can set a different pivot for each one of your drawings. For example, if you have a series of 
drawings from different views, they are not likely to rotate from the same location. In that case, you 
can set a different pivot for these drawings by using the Drawing Pivot  tool—see Drawing Pivot 
Tool on page 262.

• Symbol Pivot
The Symbol pivot is similar to the Drawing pivot. Each symbol cell can have its own pivot and act 
the same as the Drawing pivot. The Symbol pivot can also be referred to as embedded pivot. 
Inside a symbol, each drawing can have its own pivot. If you are not mixing different views within 
the same layers or are using pegs to animate your layers, it is recommended to use the Peg 
pivot—see Setting Different Pivots for a Puppet Using Symbols on page 643.

For a simple character rig, it is recommended to set the Peg pivot (even on drawing layers) using the 
Rotate  tool.

If you want the puppet's pieces to rotate correctly, you must set the pivot points right in the middle of 
an articulation, such as an elbow or a knee.

By default, your master peg pivot is placed at the centre of the Camera view, which generally equates 
to your character's hips. A good way to set your peg's pivot is to move it between the character's 
feet.
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How to set the pivots with the Rotate tool

1. In the top menu, select Windows > Toolbars > Advanced Animation.

2. In the Advanced Animation toolbar, select the Rotate  tool.

3. In the Camera or Timeline view, select the layer whose pivot you want to set. In the Camera view, 
you can also hold down Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click on the piece whose pivot 
you want to set.

4. In the Camera view, drag the blue pivot to reposition it. You can also drag the pivot marker to the 
desired location.
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5. Repeat the previous steps for all the pieces, including the eyes, nose and mouth.

How to set the master peg pivot with the Rotate tool

1. In the Advanced Animation toolbar, select the Rotate  or Scale  tool.

2. In the Timeline view, select the master peg layer.

3. In the Camera view, click the peg pivot and move it to its new location.

If you added other pegs to your rig, you must set their pivot using the same method.
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Storing the Character in the Library

For maximum efficiency and reuse of your character in different scenes, you must store a template in 
the Library view. You can create different kinds of templates, such as templates that include all the 
layers, a template for a body, key pose or even some containing only the head.

How to create a template from the Timeline view

1. In the Library view,right-click on the desired library folder and select Right To Modify.

2. In the Timeline view, collapse the master peg layer.

3. If your scene has a series of blank cells, they will also be included in the template if you drag the 
layer to the Library view. Reduce the scene length to have no empty cells before creating your 
template.

4. In the Timeline view, select your master peg and drag it to the Library view.

The Rename dialog box opens.

5. In the Name field, name the new template.

6. Click OK.

How to create a key pose template

1. In the Library view, right-click on the desired library folder and select Right To Modify.
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2. In the Timeline view, collapse the master peg layer.

3. Select the cell containing the desired view and drag it into the desired library folder.

The Rename dialog box opens.

4. In the Name field, type in a name for the template.

5. Click OK.

When you create a template from the Timeline view, you must first import your master 
template in order for everything to work properly when you reimport it into a scene. 
Once the master template is imported, you can import the key pose template's content 
into the right side of the Timeline view.
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Appendix

The many options and animation techniques available for building a puppet make it impossible to 
determine only one method to break down a character. Here are some advanced tips on breaking 
down puppets. As you become more familiar with the software, you will find more ways to improve 
the construction of your puppet.

This section is divided as follows:
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• Break Down: Cutting the Character in Pieces below

• Break Down: Distribute to Layers on page 642

• Setting Different Pivots for a Puppet Using Symbols on page 643

• Setting Pivots on a Frame Range on page 644

Break Down: Cutting the Character in Pieces

If you do not want to redraw all the artwork for your character, you can use the cut away technique 
where, with the Cutter tool, you select and send pieces of the model on a new layer.

The first step in breaking down your character is to do a rough cut down of the main parts, such as the 
body, arms, legs and head. Using the Create Drawing from Drawing Selection feature lets you 
automatically create layers and copy your selection in it.

This section is divided as follows:

• Breaking Down the Main Parts below

• Breaking Down the Secondary Parts on page 634

• See "Selecting and Incorporating to an Existing Layer" on page 637

• Breaking Down the Extra View Main Parts on page 637

• Breaking Down Secondary Parts in the Extra Views on page 639

Breaking Down the Main Parts

To break down the main body parts, you will use the Create Drawing From Drawing Selection feature. 
There is no need to create any layers prior to this process, you need to have your model well centered 
and sized in the Camera view.
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You do not need to make clean cuts around your parts; a rough one is sufficient as long as it includes 
all the artwork of the part you want to break down. You will clean the extra bits and pieces later.

Using the Cutter tool, you will roughly cut the main sections, and then use the Select  tool to select 
precise lines and colour zones.

How to break down the main parts

1. In the Timeline view, select the model's cell that corresponds to the first view to break down.

2. In the Tools toolbar, select the Cutter  tool.

‣ If you prefer to use the Select  tool, choose the Select  tool from the Tools toolbar or 
press Alt + S.

‣ In the Tool Properties view, you can switch to the Lasso  selection mode.

3. In the Camera view, create a selection around the first part to break down. If you click on a zone, 
the Cutter tool will select the zone. It will end the selection at the first point of intersection that it 
meets.

‣ Hold down Shift to create a new lasso selection around another zone and add it to your 
previous selection.

632



Toon Boom Harmony 11.1 Draw Guide (Network)

4. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 
(Windows/Linux) or ⌘  + F9 (Mac OS X).

The Create Drawing From Drawing Selection dialog box opens.

5. In the Layer Name field, type the name of the layer you want to create following the naming 
convention you established previously.

6. Deselect the Cut Artwork From Source option to keep the selected artwork on your original 
drawing. You do not want to cut the artwork from the colour model.

7. Click OK.

The new layer is created and your selection is copied in it. The drawing is created in the same frame 
number as the cell it was taken from.
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8. Repeat step 1 to 7 for each main body part.

Breaking Down the Secondary Parts

You should now have a layer for each main part of the character for the first view to break down. You 
are now ready to break down those main pieces into smaller ones.

Breaking down the secondary parts is similar to the main part break down process except that this 
time you will cut away the artwork from the layer it has been selected from.

How to break down the secondary parts

1. In the Timeline view, lock your model layer by clicking its Lock  button.

2. In the Timeline view, select the cell that corresponds to the main part you want to break down.

3. In the Tools toolbar, select the Cutter  tool.
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‣ If you prefer to use the Select  tool, choose the Select  tool from the Tools toolbar or 
press Alt + S.

4. In the Camera view, create a selection around the part to break down.

‣ If you click on a zone, the Cutter  tool will select the zone and end the selection at the first 
point of intersection that it meets. Click on the line with the Cutter tool to select it up to the 
next intersection.

5. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 
(Windows/Linux) or ⌘  + F9 (Mac OS X).

The Create Drawing From Drawing Selection dialog box opens.

6. In the Layer Name field, type the name of the layer you want to create following the naming 
convention you established previously.

7. Select the Cut Artwork From Source option to remove the selected artwork from your original 
drawing. In this case, you want to cut the artwork from the colour model.

8. Click OK.
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The new layer is created and your selection is copied in it. The drawing is created in the same frame 
number as the cell it was taken from.

9. Repeat steps 2 to 8 for each body part.
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If you forgot to add some artwork to a layer you previously created, you can always add it 
later. 

In the Camera view, select the artwork to send to the existing layer. Open the Create 
Drawing from Drawing Selection dialog box by pressing F9 (Windows/Linux) or ⌘  + F9 
(Mac OS X). In the dialog box, select an existing layer from the list instead of typing a new 
name. Click OK to add the artwork to the existing drawing in the layer you selected.

Selecting and Incorporating to an Existing Layer

Your first view should now be completely broken down. If your articulations are still rough and bits and 
pieces are missing you will fix those in the next step.

If your character model has more than one view, now is the time to break them down.

The process is very similar to breaking down the first view. You have two choices:

• Breaking down the new view in a net set of layers

• Braking down the new views in the same existing layers
If your layers are not in the correct order, you can reorder them later. Simply add the part that 
you are breaking down to the layer you previously created for the same body part.

Start by breaking down the main pieces, as you did before. The secondary parts will be broken down 
later on.

Breaking Down the Extra View Main Parts

Repeat the following steps for each extra view you need to break down.
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How to break down the other views

1. In the Timeline view, selected the model's cell corresponding to the view to break down. Don't 
forget to unlock the layer.

2. In the Tools toolbar, select the Cutter  tool.

‣ If you prefer to use the Select  tool, in the Tools toolbar select the Select  tool or press 
Alt + S.

3. In the Camera view, create a selection around the first part to break down. 

4. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 
(Windows/Linux) or ⌘  + F9 (Mac OS X).

The Create Drawing From Drawing Selection dialog box opens.

5. In the Layer Name field, select the corresponding layer from the list if you want to use the same 
layers or type a new name if you want to create a new layer.

6. Deselect the Cut Artwork From Source option to keep the selected artwork on your original 
drawing. You do not want to cut the artwork from the colour model.

7. Click OK.
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The artwork is inserted into the existing layer. The drawing is created in the same frame number as 
the cell it was taken from. It is not incorporated in the other view's drawings.

8. Repeat step 1 to 7 for each main body part.

Breaking Down Secondary Parts in the Extra Views

To break down the secondary parts for your extra views, follow the exact same process as you did for 
the first view you broke down, but you will incorporate the new parts in the existing layers—see 
Breaking Down the Secondary Parts on page 634.

Each view can have its own set of layers in the Timeline view, therefore each view does not necessarily 
need to have the same layer structure.

Here is an example of how your timeline should look at this stage:

Completing the Parts and Articulation

639



Chapter 30: Character Building     Appendix

Now that all the layers are created and the parts are basically broken down, it is time to clean up the 
parts and complete the articulation.

Cleaning the Parts

You will need to use a series of drawing tools to clean the parts:

•  Brush tool

•  Eraser tool

•  Select tool

•  Cutter tool

•  Contour Editor tool

•  Paint tool

•  Close Gap tool

How to clean your drawings

1. In the Tools toolbar, select the drawing tool you need to fix your drawings.

2. In the Timeline view, select the cell containing the drawing to fix.

3. In the Camera view, delete the extra bits using the Select  or Cutter  tool. You can also use 
the Eraser  tool.
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4. Draw the missing lines using the Brush  tool. If you use the Brush tool, it is recommended that 
you enable the Auto-Flatten  option in the Tool Properties view.

5. Using the Paint  tool, paint the gaps. You can close some gaps with invisible lines using the 
Close Gap  tool or press Alt + C.

6. Reshape your lines using the Contour Editor  tool or press Alt + Q.

7. Using the Select  tool, select the entire drawing and click the Flatten  button in the Tool 
Properties view to flatten your drawings.

8. From the top menu, select View > Show > Show Strokes to display the invisible lines that could 
be present in your drawing or press K.
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9. From the top menu, select Drawing > Optimize > Remove Extra Strokes to remove any 
unnecessary invisible lines in the drawing.

10. Repeat this entire process for each drawing to fix.

Break Down: Distribute to Layers
When breaking down a character, you can distribute each selected art stroke to a new layer. 

Each stroke you select in the Camera view is automatically placed on a new layer. One layer per stroke. 

If one part of your puppet is composed of several strokes, you must group them before distributing 
them onto new layers. 

You cannot distribute layers in the Drawing view; it must be done in the Camera view.

How to distribute to layers

1. In the Tools toolbar, click the Select  tool.

2. In the Camera view, select the art strokes you want to distribute to different layers.

3. From the top menu, select Drawing > Distribute to Layers or click the Distribute to Layers  
button in the Tool Properties view.
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Drawing layers are created in the Timeline view, each corresponding to the different strokes or 
groups of strokes selected. Each stroke or group of strokes is distributed into each new Drawing 
layer. The selected strokes in the original drawing layer are removed.

Setting Different Pivots for a Puppet Using Symbols
If you want the puppet's pieces to rotate correctly, you must set the pivot points onto the 
articulations. You can set the pivots using the Rotate tool which sets it for the entire layer or you can 
set the pivots directly on your symbol and have a different pivot for each symbol cell. By default, when 
you create symbols, the symbol pivot is located at the centre of your drawing. You will need to move it 
onto the shoulder or elbow.

You will set the pivot on the symbol's cells, not directly on the drawings. To set your pivots, you must 
be at the top level of your character building scene and not inside the symbols.

By default, when you set the pivot onto a symbol, all the cells use the same pivot. If you need different 
pivots for different cells, refer to the following procedure.

Do the following steps for each layer in the Timeline view.

How to set the pivots for the body parts

1. In the Tools toolbar, select the Drawing Pivot  tool or select Drawing > Tools > Drawing 
Pivot.

2. In the Camera or Timeline view, select the symbol on which you want to set a pivot.
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3. If you only want to set one pivot for your symbol, in the Tool Properties view, select theSet the 
Pivot for Symbol on All Frames  button.

‣ Deselect this button if you want to set a series of different pivots for your symbol's cells.

4. In the Camera view, click where you want the pivot to be. You can also drag the pivot marker to the 
desired location.

5. If you want to set a different pivot for another drawing or symbol cell, select the drawing or cell 
and in the Camera view, set the new pivot.
Make sure the Set the Pivot for Symbol on All Frames button is deselected.

Setting Pivots on a Frame Range
If you are using the drawing pivots rather than the Rotate tool pivot and if some elements need the 
same drawing pivot, such as all of the three-quarter hands, you can select all of these hands cells and 
set the pivot all at once. If your pivot is already correctly set on your first drawing, copy and paste that 
pivot onto the other drawings in the Timeline or Xsheet view.
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You must have the same drawing pivots on the extra parts from the same angle. If you substitute a 
drawing while the part is rotating, the animation risks popping out of place if the pivot is uneven.

How set the drawing pivot of a frame range

1. In the Drawing or Camera view, set the first drawing pivot of the series. For example, set it on 
hand-1.

2. In the Timeline view, select the cell that contains the correct pivot.

3. From the top menu, select Edit > Copy.

4. In the Timeline view, select the cell range that requires the same pivot.

5. From the top menu, select Edit > Paste Special or press Ctrl + B (Windows/Linux) or ⌘  + B (Mac 
OS X).
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The Paste Special dialog box opens.

6. In the Paste Special dialog box, select the Advanced tab.

7. In the Drawings section, select the Update Drawing Pivot option.

8. Click  OK.

You can also copy and paste the pivot from one drawing to another using the keyboard shortcuts Ctrl + C 
and Ctrl + V (Windows/Linux) or ⌘ + C and  ⌘ + V (Mac OS X) when the drawing pivot tool is active and 
the focus is around the Camera view.
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Chapter 31: Library

Using symbols and templates, you can share and reuse any elements you create in Harmony. The 
Harmony library lets you store several different elements such as puppets, backgrounds, animations 
and key poses. In fact, anything you create in Harmony can be stored in the library.

This chapter contains the following topics:

• Understanding the Library Concept on the next page

• Library View on page 651

• Structuring the Library on page 654

• Templates on page 665

• Symbols on page 658

• Importing Symbols and Templates on page 667

• Importing Files Through the Library on page 671

• Using Paste Special on page 672
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Understanding the Library Concept

The Library view is where you can store and reuse your artwork and animation in other scenes or build 
props and puppets.

• What is a Library? below

• What is a Symbol? below

• What is a Template? on the facing page

• Library in Harmony Network on the facing page

What is a Library?

A library is a folder where you store symbols and templates. You can access these folders from 
different projects. Using the library is as simple as dragging the content into the library to store your 
artwork and then dragging it to the Timeline or Camera view when you want to reuse it.

You can organize your library using several different subfolders and store them on your hard drive or 
network.

What is a Symbol?

A symbol is a container used to build your props, puppets and looping clips. You can use symbols to 
contain artwork and animation and manipulate them as a single object. You can also use symbols as a 
placeholder in which you place a series of different drawings for each body part of your puppets or 
when you have a repeating cycle. However, symbols are not necessary for creating characters. 

To create a symbol, drag your artwork to the Symbol library. When you drag a symbol from the 
Symbol library into your scene, it will be linked to the original symbol. If you drag a symbol into your 
scene several times in the Timeline view, they will all be linked to the original symbol. If you modify one, 
they will all be modified.

A symbol is local to the project and cannot be accessed directly from other scenes. To reuse a 
symbol's content in another scene, you must create a template out of it.

When a symbol is exposed in the Timeline view, the symbol's cells are represented as a movie strip.
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What is a Template?

A template is an individual copy of the artwork stored in the library which you can reuse in different 
scenes. Once a template is stored in the library, you can access it from any project.

Dragging a template into your scene copies the content in your Timeline and does not link it to the 
original. Yo can modify this individual copy at any time.

Library in Harmony Network

The library is a storage centre for all production assets; the elements stored in the library are called 
templates. Although it is mainly used for cut-out animation, the library is also useful for paperless and 
traditional animation processes. The library can contain any asset used in a Toon Boom Harmony 
production. 

When working on the database, the structure of the library differs from when working on Harmony 
Network. 

Harmony provides three default library folders: 
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• Symbols: The only library folder containing symbols for your project. You can organize the 
symbols library folder using subfolders, but you cannot create a second library for your symbols. 
This library is local to your project. 

• Environment: A folder located inside the Environment folder. Every asset stored in this folder is 
accessible from any job and scene contained within this environment. 

• Job: A folder located inside the Job folder. Every asset stored in this folder is accessible from 
any scene contained within this job. 

You can create a folder called "library"  in the usa_db folder on the server to create a global library. Once 
the Harmonyapplication is restarted, a "Global"  library folder will automatically appear in every user's library. 
Every asset stored in this folder is accessible from any scene, job and environment. 
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Library View

You use the Library view to create and manage your symbols and templates, display the folders and 
manage and all of the content. 

Library View Menu

The Library View menu lets you access commands specific to the Library view, such as opening a 
Library or getting the rights to modify a library folder.

Preview Window

The Preview window lets you preview the content of a symbol or template, and swap between 
drawings and symbol cells in the Timeline view. This window is also used as the Drawing Substitution 
window.

How to preview a template or symbol's content

1. In the Library view's right side, click or double-click on the symbol or template to preview.

2. In the Preview window, click the Play  button or drag the slider to scrub through the frames.
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Library Search Tool

When working on a movie or series, you will probably end up with many templates and symbols in 
your library. Using the Search tool, you can quickly find the templates and symbols in your folders.

How to use the Library Search tool

1. From the left side of the Library view, select the library in which you want to search.

2. In the Search field, type the name or partial name of the symbol or template you are looking for.

3. Click the left  and right  arrows to see the previous and next results. The Search engine 
will look for results within the library master folder and its subfolders. It will not look in other 
libraries.

Library List

The Library list lets you navigate through the different libraries and subfolders. You can also open, 
close and create new libraries from here.

The Library folders have these default libraries:

• Symbols: The only library folder containing symbols for your project. You can organize the 
symbols library folder using subfolders, but you cannot create a second library for your 
symbols. This library is local to your project. 

• Harmony Library: This folder contains templates and is stored on your hard drive. You can 
organize the Harmony library folder using subfolders. This folder does not contain symbols.
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Templates and Symbols List

s

The symbols and templates contained in the selected Library list can be displayed on the right side of 
the Library view as thumbnails, in a list or as details.

How to access the templates and symbols list display options

‣ In the Library view's right side, right-click and select View > List, Thumbnails or Details.

‣ In the Library View toolbar, you can click the following buttons:

 Thumbnails

 List

 Details
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Structuring the Library

As you will probably create a large number of symbols and templates, you will soon realize they need 
to be organized. You can create different libraries and subfolders to easily access your assets. For 
example, you can create a different library for each project and divide it into several categories, such 
as:

• Characters

• Props

• Backgrounds

Although you can only have one symbol library folder, you can organize it by creating subfolders.

There are two ways to create library folders. 

• Directly through your operating system

• Using Harmony's interface

Folders can be opened in Harmony when you require it. You can open any folder on your hard drive or 
network as a library. Opening a library means linking the folder to your Library view. You only need to 
open the library once. The library folder is available every time you open the application until you 
decide to close the library and unlink it.

You may not always require all the library folders in the Library List. If so, you can close the ones you 
do not need. Closing a folder does not delete it; it only unlinks it from the Library view. If you want to 
reopen it, locate it on your hard drive or network and open it in the Library view.

Symbol and template libraries need to be organized. You can create different subfolders on your hard 
drive or in the Harmony Library view, so you can easily access assets. By default, any new library you 
link to your Library view is locked to prevent accidental deletion or modification of symbols and 
templates. You must obtain the right to modify it before being able to add a new folder to it.

You can delete a folder from the library if its contents are no longer needed.

Warning: All templates and symbols in the folder will be deleted from your hard drive. Once deleted, the 
data cannot be retrieved.

Once you add a folder, you can rename it. This also renames the folder on your hard drive.

If you update the content of your libraries through your operating system, you will need to refresh your 
library folders in the Library view.

When you display thumbnails in the Library view, the system generates a series of small images 
(thumbnails) for you. You can generate template thumbnails yourself, if they do not display or if the 
process has been stopped.

You can also delete thumbnails if you want to send a template to another user or studio and keep your 
packages small.

How to create a library folder through your operating system

1. On your computer, create a new folder with a relevant name in the location where you want the 
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library to be stored.

How to create a library folder in Harmony

1. In the Library View menu, select Folders > Open Library.

The Browser window opens.

2. Browse for the location where you want to store your new library folder.

3. Click the New Folder button.

A new folder appears.

4. Name the new library folder with a relevant name and click OK.

The new library appears in the Library List section.

How to open a library

1. In the Library View menu, select Folders > Open Library.

The Browser window opens.

2. Browse to the location of the library folder.

3. Select the folder and click OK.

The new library appears in the Library Folders section.

How to close a library

1. On the right side of the Library view, select the library folder to close.

2. In the Library View menu, select Folders > Close Library.

The library closes.

How to create a folder

1. On the left side of the Library view, select the library folder to which you want to add a subfolder.

2. In the Library View menu, select Edit > Right to Modify.

3. In the Library View menu, select Folders > Nesw Folder.

The new folder appears in the Library. Click on the library containing the new folder and click the 
plus [+] sign to expand it.
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How to delete a folder

1. In the Library view's left side, select the folder to delete.

2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and 
select Right to Modify.

3. In the Library View menu, select Folders > Delete Folder or press Delete.

How to rename a folder

1. In the Library view's left side, select the folder to rename.

2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and 
select Right to Modify.

3. In the Library View menu, select Folders > Rename Folder.

4. Rename the selected folder.

5. Press Enter/Return to validate the operation.

How to refresh a library

1. In the Library view's left side, select the folder to refresh.

2. In the Library View menu, select Folders > Refresh or press F5.

The library displays the new content.

How to generate thumbnails

1. In the Library view's right side, select the template in which you want to generate thumbnails.

2. In the Library View menu, select View > Generate Thumbnails.

The progress bar appears.

656



Toon Boom Harmony 11.1 Draw Guide (Network)

How to delete thumbnails

1. In the Library View menu, select Edit > Delete Thumbnails.

All the thumbnails contained in the library are removed.
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Symbols

A symbol combines animation, artwork or layers into a single object that you can control in one layer. 
You can also create symbols out of each body part in your cut-out puppets.

You do not need to create symbols in order to create drawings or characters in Toon Boom Harmony.

When you delete a symbol, it will be deleted from your hard drive. You can use the Undo function to 
retrieve the data. The symbol cannot be retrieved once you close the application.

When you import a symbol from the library to the Timeline view it is linked to the original symbol in the 
library. If you import a symbol into your scene several times in the Timeline view, they will all be linked 
to the original symbol. If you modify one, they will all be modified. 

If you want to edit a symbol without modifying the other instances, you must duplicate the symbol 
first. If other symbols are nested inside the new symbol, they are not duplicated. If you modify them, 
the original and other instances will also be modified.

You can either edit a symbol from the Timeline view or from the Library view.

When you edit a symbol, the drawings contained in it are not placed at the centre of the stage, but are 
located in the position where they were created. The pivot is translated at the centre of the symbol.

When you enter a symbol to edit it, you are entering another scene with an independent timeline. You 
can nest many symbols one inside the other. To help you follow the hierarchy of your nested symbol, 
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take note of the Editing stack at the top of the Camera view which displays the path to your symbol's 
location. You can click on the symbol's name to move up the chain.

You can share a symbol and use its contents (the drawings) in another scene. To do this, you must first 
convert your symbol into a template. This conversion breaks the drawing's link with both the original 
scene and symbol. It then becomes a separate entity that you can import into other projects.

How to create a symbol from a drawing selection

1. In the Tools toolbar, select the Select  or Cutter  tool.

2. In the Camera view, select the drawing elements to create a symbol.

3. From the top menu, select Edit > Create Symbol or press F8.

‣ Clicking the Create Symbol  button in the Edit toolbar will create a symbol from the 
entire layer.

The Create Symbol from Drawing Selection dialog box opens.

4. In the Symbol Name field, type the name of the symbol.

‣ You can also select an existing layer from the Symbol Name drop-down menu. It will add 
your symbol on the layer's current cell. If there is already an exposure on that cell, the 
symbol will be added to a new layer.

5. You can choose to place the current selected artwork in the drawing or remove it:

‣ To remove currently selected artwork from the drawing and place it in the new symbol, 
select the Cut Artwork From Source Drawing option. 

‣ To keep currently selected artwork in both the drawing and in the new symbol, deselect the 
Cut Artwork From Source Drawing option.

6. Click OK.

The new symbol appears in the Library view's symbol folder and in the Timeline view as a new layer.
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How to create a symbol from the Timeline view

1. In the Timeline view, select the layer or cells from which your want to create a symbol.

2. Do one of the following:

‣ From the top menu, select Edit > Create Symbol. 

‣ In the Edit toolbar, click the Create Symbol  button.

‣ Press F8.

‣ Drag your selection to the Symbol folder in the Library view.

The Create Symbol dialog box opens

3. In the Enter Symbol's Name field, type the new symbol's name.

To rename a symbol once it is created, right-click on the symbol and select Rename.

4. Click OK.

The new symbol appears in the Library view's Symbol folder. The current selection is not replaced 
by the new symbol. The new symbol only appears in the library. You must drag it into your scene to 
use it.

How to create an empty symbol

1. In the Library view, select the Symbol folder.

2. Do one of the following:

‣ In the Library view's right side, right-click and select New Symbol. 
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‣ From the top menu, select Insert > Create Empty Symbol in Library.

The new empty symbol appears in the Library view.

The symbol is ready for you to edit (add content to). To go back to the root timeline, click the Top 
 button in the Camera view.

To rename a symbol once it is created, right-click on the symbol and select Rename.

How to delete a symbol

1. In the Library view, select the symbol to delete.

2. Right-click and select Delete or press Delete.

‣ If the symbol is currently in use in the scene, a warning message displays. Click OK to delete 
the symbol from the library and scene.

How to edit a symbol from the Timeline view

1. Do one of the following:

‣ In the Timeline view, double-click on the symbol's cell to edit the symbol. 

‣ In the Camera view, double-click on the symbol or press Ctrl + E (Windows/Linux) or ⌘  + E 
(Mac OS X)). 

‣ Click the Edit Selected Symbol  button in the Camera View toolbar's extra buttons.
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You are now inside the symbol and you are able to edit it.

2. Do one of the following:

‣ Click the Top  button in the Camera view's top-left corner to return to the project's 
timeline or press  Ctrl + Shift + E (Windows/Linux) or ⌘  + Shift + E (Mac OS X). 

‣ In the Timeline view's right side, right-click and select Symbols >Leave Current Symbol.

How to edit a symbol from the Library view

1. In the Library view, select the symbol to edit.

2. Right-click and select Edit > Edit Symbol or double-click on the symbol.

You are now inside the symbol and you are able to edit it.
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‣ Click the Top  button in the Camera view's top-left corner to return to the project's 
timeline or press  Ctrl + Shift + E (Windows/Linux) or ⌘  + Shift + E (Mac OS X). 

How to duplicate a symbol

1. In the Timeline view, go to the frame where you want to duplicate the symbol.

2. Select the symbol's cell.

3. From the top menu, select Edit > Duplicate Selected Symbol.

In the Library view, the symbol is duplicated and in the Timeline view, the current cell and its held 
exposure is replaced with the new symbol. You can now modify the symbol's content.

How to convert a symbol into a template

1. From the Library view, select the symbol to convert into a template and drag it to the Camera or 
Timeline view.  If you drop your symbol into the Camera view instead of the Timeline view, it will not 
be placed in the centre of your camera frame, but rather wherever your cursor drops it within the 
camera frame.

2. In the Timeline view, select the symbol's cells or layer and drag it to the Stage Library folder or to 
any other library folder. Make sure you have the right to modify the library folder.
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3. In the Rename dialog box, rename the new template.

4. Click OK.
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Templates

When you want to reuse artwork and animation from your project in other scenes, you must create a 
template from it. A template can be seen as a portable scene or package that you can drag inside your 
project. You can open a template and edit it just like any other project. If you want modify your 
templates, you can edit them using the Edit Template command.

You can create a template using the Timeline view.

To delete templates from your library, use the Library view. Harmony lets you undo the action if 
necessary. 

How to create a template from the Timeline view

1. In the Timeline view, select some cells or layers.

2. In the Library view, select a folder to store the template.

3. If a library folder is locked, right-click and select Right to Modify.

4. Drag the selection to the  Stage Library folder or any other library folder.

5. In the Rename dialog box, give the new template a name.

To rename a template once it is created, right-click on the symbol and select Rename.
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6. Click OK.

How to delete a template

1. In the Library view, select the folder containing the template to delete.

If the library folder is locked, right-click on the folder and select Right to Modify.

2. Right-click on the selection and select Delete or press Delete.

How to edit a template

1. In the Library view, select the folder containing the template to edit.

If the library folder is locked, right-click on the folder and select Right to Modify.

2. Right-click on the selection and select Edit Template.

A new Harmony application opens.

3. Edit the template.

4. From the top menu, select File > Save.

5. In the top menu, select File > Quit (Windows/Linux) or Stage > Quit (Mac OS X).
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Importing Symbols and Templates

There are several ways you can import symbols and templates in your scene.

Sometimes a character rig is not a straightforward matter. Rigs, which are usually saved as templates, 
can contain symbols such as a leg that was made with a patch. However, a symbol does not work in 
the same way as an action template. In the Timeline view, you can add an action template into another 
template of the same structure. When working on a layer on the right side of the Timeline view and 
you place a symbol into a symbol of the same structure, instead of being added to the previous 
symbol, the new symbol becomes a copy.  

For greater control over how the action template behaves when brought into the Timeline view, you 
can use the Paste Special feature—see Using Paste Special on page 672.

Since a template is like a scene, you can open the template's folder and select elements inside it such 
as drawings. 

Instead of importing the entire contents of a template, you may only want to import a few drawings or 
a palette. In this case, use the Open As Folder command to import the items you want. 

If you want to import a palette, simply drag the palette file into the Palette list section of the Colour 
view.

You can use the Expand Symbol command to extract a symbol's contents and place it on the root 
timeline. The symbol will not be removed from the Timeline view. Its contents will be copied and 
inserted into the root timeline. The symbol's layers will be parented to it in case you created motions 
and transformations on the drawing layer that contains the symbol. Breaking the hierarchy could result 
in the loss of any scaling and animation you may have created.

You can also expand a symbol within a group to avoid crowding the timeline with a series of layers. 
When you expand the symbols, the layers will be contained in a group module that you can expand to 
see the content.

How to import a template into the Timeline or Camera view

1. In the Library view, select the template you want to import.

2. Drag the selected template to the Camera view or to the left side of the Timeline view.
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3. You can also drag a template to the right side of the Timeline view and into existing layers if the 
layer structure is the same as the existing one.

How to import a symbol in the Timeline view

1. In the Library view, select the symbol you want to import.

2. Drag the selected symbol to one of the following:

‣ The Timeline view's left side to import it into the centre of the camera frame.

‣ The Camera view to place it at the location where you release your cursor.

This may be useful if you saved a character's body parts as separate symbols. If you dropped them into the 
Timeline view, then they would all appear in the centre, haphazardly one on top of the other. It would be 
more efficient to arrange them into their correct places as you bring them into the scene.

How to import a template with symbols

1. From the right side of the Library view, select the action template that contains symbols.

2. Hold down Alt (Windows/Linux) or ⌘  (Mac OS X) as you drag it from the Library view to the right 
side of the Timeline view and drop it next to a template with the exact same rig.

The Paste Special window opens.

3. Select the Advanced tab.

4. Select one of the following options from the Symbols menu:
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‣ Copy symbols if they do not exist: This is the default setting for this operation and will 
prevent symbols in an action template from being copied.

‣ Duplicate symbols: Makes copies of the symbols in your template.

How to open a template as a folder

1. In the Library view, select the folder that contains the template to open. If the library folder is 
locked, right-click on the folder and select Right to Modify.

2. Right-click on the selection and select Open As Folder.

3. In the library list section, click on the template's folder to display its content.

4. Drag the content to the Timeline or Colour view.

How to expand a symbol

1. In the Timeline view, select the symbol to expand.
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2. From the top menu, select Edit > Expand Symbol or press Shift + F8.

How to expand a symbol in a group

1. In the Timeline or Network view, select the symbol cell or symbol module you want to expand.

2. From the top menu, select Edit > Expand Selected Symbol in a Group.

3. In the Timeline view, click the plus sign (+) to see the group content. In the Network view, click the 
Expand Arrow to enter the group.
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Importing Files Through the Library

Harmony lets you import sound files and images directly through the library. Simply open the folder 
containing your files in the Library view and drag them directly from there.

How to open a file through the Library

1. In the Library View menu, select Folders > Open Library.

2. Browse for the folder containing the files you want to import.

3. Click Open.

4. From the Library's template list, drag the file you want to import in the Timeline or Camera view.
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Using Paste Special

When you import a template in the Timeline view, all layers are created as well as drawings and 
keyframes. You can choose to import only the keyframes without the drawings or import only the 
drawings that are not already in your layers. You can adjust the behaviour using the Paste Special 
dialog box.

When you import a symbol in your scene, its full length is exposed by default. If you import your 
symbol in the Timeline view’s left side, all the frames will be exposed. However, if you import it into an 
existing layer, you can use the Paste Special dialog box to adjust the import behaviour to fit your 
requirements.

Once you set the parameters, Harmony will reuse them each time you import a symbol in the Timeline 
view’s right side until you set new parameters.

How to open the Paste Special dialog box

1. In the Library view, select the Symbol or template to import.

2. While dragging the selection to the Timeline view, hold down Alt (Windows/Linux) or ⌘  (Mac OS 
X). 

Drop the selection in the Timeline view before releasing the keyboard shortcut key.

The Paste Special dialog box opens.

3. Set the parameters and click OK. 

Paste Special - Basic Tab

Drawings

Parameter Description

Only create drawing files 
when they do not exist

When adding exposures to a drawing layer, new drawings will be created 
only when drawings with the same name do not already exist in the des-
tination.

Always create drawings When adding exposures to a drawing layer, new drawings will always be 
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created. If drawing files with the same name already exist, Harmony will 
create a new name for the drawing.

Paste all Frames of the Sym-
bols (full movie)

When enabled, the Paste Special command exposes all the Symbol's 
frames instead of only the first one.

Cycle

Parameter Description

Number of Cycles The number of cycles your selection is repeated.

Cycle Type

Normal (forward): Pastes your selection as is, starting with the 
first cell and ending with the last.

Reverse: Pastes your selection in reverse, starting with the last 
cell and ending with the first.

Forward > Reverse: Pastes your selection as a yo-yo, starting 
with the first cell, going to the last one and ending with the first 
cell.

Reverse > Forward: Pastes your selection as a reverse yo-yo, 
starting with the last cell, going to the first one and ending with 
the last cell.

Number of Cycles: Lets you set the number of cycles.

Paste Special - Advanced Tab
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Drawings

Parameter Description

Drawings

Do Nothing: Does not create or overwrite drawings.

Update Drawing Pivot: Revises the drawing pivot in the 
destination to use the same drawing pivot as the first drawing 
in the template. If you have a range of drawings selected in the 
destination, the pivot points of all selected drawings will be 
updated.

Add/Remove Exposure: Creates/deletes exposure values in 
the selected layer. You have the following choices as to how to 
treat drawings be created when adding an exposure:

• Never create drawing files: When adding exposures to a 
drawing layer, drawing files will not be created.

• Only create drawing files when they do not exist: When 
adding exposures to a drawing layer, new drawings will be 
created only when drawings with the same name do not already 
exist in the destination.

• Always create drawing files: When adding exposures to a 
drawing layer, new drawings will always be created. If drawing 
files with the same name already exist,  Harmony will create a new 
name for the drawing.

• Key Drawing Mode (Substitution): Pasting an exposure value 
replaces the cell value in the current frame and in all frames 
following in sequence with the original cell value.

• Paste all Frames of the Symbols (full movie): When enabled, 
the Paste Special command exposes all the symbol's frames 
instead of only the first one.

Add/Remove Keyframes

Motion: Copies the properties of the selected motion 
keyframe to the new frame.

Velocity: Copies the properties of the selected velocity 
keyframe to the new frame.

Rotation: Copies the properties of the selected rotation 
keyframe to the new frame.

Skew: Copies the properties of the selected skew keyframe to 
the new frame.

Scale: Copies the properties of the selected scale keyframe to 
the new frame.

Force Keyframes at Function's Beginning and End: Adds a 
keyframe to the beginning and end of the pasted function, 
reproducing the source function.

Offset Keyframes: When pasting functions, offsets the 
keyframes from the function's last value by the values in the 
pasted function. This will continue the progression of a function 
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rather than repeat the values. 

Palettes

Do nothing: Does not create, overwrite, merge or link 
palettes.

Reuse palettes. Copy palettes if they do not exist: Palettes in 
the destination drawings are left as they are.

Copy and overwrite existing palettes: Overwrites destination 
palettes with the palettes from the source drawings.

Copy and create new palette files: Creates new palette files, 
placing them at the same relative environment and scene level 
as the source. If the palettes in the templates were stored at 
the environment level of the source scene, the paste operation 
will place the palettes in the environment level of the 
destination scene.

Copy and create new palette files in element folder: Creates 
new palette files in the element folders of the destination 
scene, rather than in the same relative job or environment.

Copy palette and merge colours. Add new colours only: 
Adds new colours to the destination palettes and ignores 
colours that are the same in the two palettes.

Copy palette and update existing colours only: Adds new 
colours to the destination palette and updates duplicate 
colours in the destination with colour values from the source.

Link to original palettes (colour model): Links the colour 
palettes in the destination scene to the palettes in the source. 
Use this to link drawings to the palettes in a colour model.

Copy scene palettes and merge colours. Add new colours 
only: Adds new colours to the destination scene palettes and 
ignores colours that are the same in the two palettes.

Copy scene palettes and update existing colours: Adds new 
colours to the destination scene palette and updates duplicate 
colours in the destination with the colour values from the 
source.

Symbols

Copy symbols if they do not exist: This is the default setting 
for this operation and will prevent symbols in a Action template 
from being copied.

Duplicate symbols: Creates a duplicate of the symbol instead 
of linking the symbol instance to the original one. The new 
symbol is created in the Library.

Cycles

Normal (forward): Pastes your selection as is, starting with the 
first cell and ending with the last.

Reverse: Pastes your selection in reverse, starting with the last 
cell and ending with the first.

Forward > Reverse: Pastes your selection as a yo-yo, starting 
with the first cell, going to the last one and ending with the first 
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cell.

Reverse > Forward: Pastes your selection as a reverse yo-yo, 
starting with the last cell, going to the first one and ending with 
the last cell.

Number of Cycles: Lets you set the number of cycles.

Modules

Create New Columns: A new column is created when you copy 
and paste modules from the Network view or Layer in the 
Timeline view. If the layers are linked to function curves, the 
function curves, drawings and timing will be duplicated.

Elements
Reuse Existing Elements: Lets you paste existing elements 
without creating new ones.  This should be used only when 
pasting within versions of the same scene.
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Chapter 32: Cut-out Animation

Harmony provides you with some great tools to animate your puppets. You can create simple 
animation using the Transform tool and you can create advanced animation using both forward and 
inverse kinematics. Harmony has advanced onion skinning and image swapping features to help you 
animate efficiently and quickly. For animation freedom, you have the ability to mix several different 
techniques of animation, such as simple rigging, hierarchy and symbol animation.

• Getting the Character on the next page

• Keyframes and Drawing Blocks on page 682

• Creating a Simple Cut-out Animation on page 684

• Selecting Layers to Animate or Position on page 687

• Navigating the Hierarchy on page 690

• Animating Using the Transform Tool on page 692

• Animating Using Inverse Kinematics on page 694

• Animating in Stop-motion on page 709

• Animating Using Computer-generated Interpolation on page 711

• Marking the Timeline on page 716

• Flipping Through Poses on page 719

• Using the Onion Skin in Cut-out Animation on page 720

• Flipping Parts on page 723

• Swapping Images on page 724

• Adding a New Drawing on page 728

• Ordering Layers Over Time on page 729

• Resetting a Transformation on page 731

• Creating Cycles on page 732

• Copying and Pasting Animation on page 735

• Adding Pegs on page 737
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Getting the Character

The first step in animating your character is to import a master template from the library.

How to import a character from the library

1. Create a new Harmony project.

2. In the Library view, select a character master template to animate.

3. Drag the selected template to the Camera or Timeline view’s left side.

4. In the Timeline view, drag the red scene length bracket to extend or shorten the scene length.

How to import a Network template (Master Template)

1. Create a new Harmony project.
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2. In the Library view, select the character's master template you want to animate.

3. Drag the selected template in the Network view.

4. In the Network view, connect the template's group module to the Composite module by clicking 
its out-port and dragging the connection to the Composite module until an in-port appears.

5. In the Timeline view, extend or shorten the scene length by dragging the scene length bracket.
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Selecting the Pose

If the template you imported contains several poses, you must choose which pose you will use to start 
your animation and remove the other ones.

If you created your different views in separate templates, you can import them on separate layers, and 
turn them on or off in the Timeline view depending on which one you need.

How to select the character's pose

1. In the Timeline view, collapse your character's layers.

2. In the Timeline view's right side, select the keyframe corresponding to the pose you want to keep.

3. Drag the selected keyframe to the first frame.

4. Select all the extra drawings and keyframes that you do not need and press Delete.

Extending the Exposure
Once you have chosen a pose, all that is left to do is extend the exposure of your character to the end 
of the scene.

How to extend the exposure of the character

1. In the Timeline view, collapse the character.
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2. In the Timeline view’s right side, select the last cell of the character.

3. Right-click and select Extend Exposure or press F5. You can also copy the first pose and paste it in 
the last cell.

The drawing exposure is extended to the end. You will not see any changes in the Timeline view 
when the master peg is collapsed.
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Keyframes and Drawing Blocks

When you extend the exposure of a drawing, it is represented by a grey block in the Timeline view. 
When you expose a second drawing, a second grey block is displayed.

You can consider these blocks as drawing blocks.

To animate the position of a block over time, you do not need to create a second block, you simply 
need to add a position keyframe. The position keyframes are coordinates indicating the position of 
your drawing on a particular frame. These appear as black squares in the Timeline view.

In the example below, notice that the keyframes are positioned on frames independently from the 
beginning and end of each drawing block.

You can keyframe three different positions for your drawing in the same drawing block and create a 
motion path between them.

Creating Keyframes and Drawings in the Timeline View
You can see how the Timeline view behaves differently depending on whether you create a new 
drawing, a new keyframe, or both at the same time.

How to create a drawing in the Timeline view

1. Do one of the following:

‣ From the top menu, select Drawing > Create Empty Drawing.

‣ In the Timeline View toolbar, click the Create Empty Drawing  button.

‣ Press Alt + Shift + R.

A new drawing block is inserted. 

682



Toon Boom Harmony 11.1 Draw Guide (Network)

How to create a keyframe in the Timeline view

1. Do one of the following:

‣ From the top menu, select Insert > Keyframe 

‣ In the Timeline View toolbar, click the Add Keyframe  button.

‣ Press F6.

A keyframe is created in the layer. 

How to create a drawing and a keyframe simultaneously in the Timeline view

1. Do one of the following:

‣ From the top menu, select Insert > Keyframe and Duplicate Drawing.

A drawing block is created which contains copies of the selected drawing and a keyframe.
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Creating a Simple Cut-out Animation

Here is how you can create a simple cut-out animation. Follow these steps so you can try out the 
animation tools you will learn in the next topics. 

How to create a simple cut-out animation

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

2. In the Tools toolbar, enable the Animate  mode so that everything you move will be keyframed 
automatically.

3. From the top menu, select Animation > Stop-Motion Keyframe so that the interpolation is not 
created automatically between keyframes.

4. In the Timeline view, collapse your character.

5. In the Timeline view, go to the frame where you want to set the first pose.
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6. In the Camera view, select the parts to animate.

7. Use the Transform  tool to rotate, skew, scale or translate the selection to its new position. To 
rotate the piece, place your cursor slightly outside of a corner until you see the rotation cursor.

A new keyframe appears in the Timeline view.

8. To ensure that nothing will move on your new pose, in the Timeline view, select the frame 
corresponding to the pose, right-click and select Add Keyframe or press F6.

9. In the Tools toolbar, enable the Onion Skin   feature.

10.In the Timeline view, go to the frame where you want to set your second keyframe.

11. If you want to make sure that nothing will move on your new pose, in the Timeline view, select the 
frame corresponding to the pose, right-click and select Add Keyframe or press F6.

12. In the Camera view, animate your character.
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13. Repeat this process until all the poses are done.
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Selecting Layers to Animate or Position

When you are animating characters, it is important to understand how the Animate mode allows you 
to create keyframes on the current frame or to reposition the entire layer.

Animate Mode
The Animate  button, in the Tools toolbar, turns keyframing on or off. When you enable the 
Animate mode, as soon as your move an element in the Camera view, a keyframe is positioned on the 
current frame in the Timeline view to indicate the new position.

When you turn off the Animate mode, and you select and move an element, the entire animation in the 
layer will be offset at once.

This means that when you are animating a character, you must enable the Animate mode. If you are 
scaling down your puppet to fit the scene composition and want to resize the entire animation, you 
must disable the Animate mode.

How to turn the Animate mode on or off

1. In the Tools toolbar, click the Animate  button or select Animation > Animate.

687



Chapter 32: Cut-out Animation     Selecting Layers to Animate or Position

Selecting Drawing Layers using the Transform Tool
To manipulate your drawing layers in order to animate them, you must use the Transform  tool. 
The Select tool is used to modify the drawing strokes and not the actual drawing layer.

When selecting your drawing layers with the Transform tool, make sure that the Peg Selection Mode 
option is turned off in the Transform Tool Properties view. If this option is enabled, it will limit the 
selection in the Camera view to pegs only.

How to select using the Transform tool

1. Do one of the following: 

‣ In the Tools toolbar, click the Transform  tool.

‣ From the top menu, select Animation > Tools > Transform.

‣ Press Shift + T. 

2. In the Transform Tool Properties view, make sure the Peg Selection  mode  is deselected.

3. In the Camera view, select the element to animate.

Selecting an Element in the Camera View Using the Transform Tool 

When you select an element in the Camera view using the Transform tool, make sure that the Peg 
Selection  mode  is disabled in the Transform Tool Properties view, the element selected is the 
actual drawing layer corresponding to the selected element. If you have a layer parented toa peg, you 
must either use the keyboard shortcuts to go up the hierarchy chain, select it in the Timeline view, or 
enable the Peg Selection  mode  option in the Transform Tool Properties view, this will limit the 
selection in the Camera view to pegs only.

If the layer has child layers, they will also be highlighted. Depending if you are using pegs or only 
drawing layers in your rig, the selection can be magenta, yellow or both.
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Selecting a Layer in the Timeline View

When you select a layer in the Timeline view, the corresponding element is highlighted in the Camera 
view. If the selected layer has child layers, they are also highlighted.
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Navigating the Hierarchy

If you created a layer hierarchy when you built your puppet, you can use the keyboard shortcuts to 
travel up and down the parent-child chain. You can also navigate between the children of the same 
parent. 

How to select the parent or child layer

1. In the Tools toolbar, select the Transform  tool.

2. In the Transform Tool Properties view, make sure the Peg Selection  mode  is deselected.

3. In the Camera or Timeline view, select a layer attached to a hierarchy.

4. From the top menu, select Animation > Select Parent or press B to select the parent layer. Now 
select Animation > Select Child or press Shift + B to select the child layer.

How to select the children layers

1. In the Tools toolbar, select the Transform  tool.

2. In the Camera or Timeline view, select a layer attached to a parent layer with several children or not 
parented at all.
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3. From the top menu, 

‣ Select Animation > Select Previous Brother or press / to select the previous child layer.

‣ Select Animation Select Next Brother or press ? to select the next child layer. 

‣ Select Animation > Select Children to select all child layers at the same time.
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Animating Using the Transform Tool

The Transform tool is the main tool to use when working with a cut-out character. The Transform tool 
has many useful functions: 

 

Using the individual Rotate, Translate, Scale and Skew tools is not recommended, as they move each 
piece from their own pivot point. They are compositing tools. The Transform tool creates a global 
selection, so that when many parts are selected, you can move them as one unit. The Transform tool is 
highly recommended for cut-out animation.

When animating with the Transform tool, make sure to select the right selection mode. In this 
example, make sure that the Peg Selection  Mode  is disabled in the  Tool Properties view or it will 
limit the selection in the Camera view to pegs only.
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If you have hierarchy connections in your cut-out character, the Transform tool will also be used as the 
Forward Kinematics equivalent. 

The Transform tool can be used on any kind of rigging.

When many parts are selected with the Transform tool, the first selected part's pivot will be used as 
the global selection's pivot. This pivot can be moved temporarily for the animation. When you offset 
the pivot, the permanent pivot is displayed as a ghost. 

 

The interpolation of your animation poses is always calculated from each individual part's permanent pivot. If 
you have a parent peg on a limb, make sure to select that parent peg rather than making a selection of each 
parts to avoid setting individual keyframes.

How to use the Transform tool

1. In the Tools toolbar, click the Transform  tool or press Shift + T.

2. In the Transform Tool Properties view, make sure the Peg Selection  mode  is deselected.

3. In the Timeline view, go to the frame you want to set the first position.

4. In the Timeline View toolbar, click the Add Keyframe  button or press F6. It is recommended to 
add a keyframe before moving your character. Moving a character's part without setting a 
keyframe will create keyframes only on certain parameters of your animation. You could run into 
issues later on when setting poses between existing ones. Creating a keyframe on all layers and 
parameters will ensure your pose is set and will not be modified by other poses later on.

5. In the Camera view, select the element to animate and move it.

6. In the Timeline view, go to the frame where you want to set the next position.

7. In the Timeline View toolbar, click the Add Keyframe  button or press F6.

8. In the Camera view, animate the character.
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Animating Using Inverse Kinematics

The Inverse Kinematics (IK) tool  allows you to pull on your character's extremities, such as the hands 
and feet, and have the rest of the body follow. It can be used on any piece connected in a hierarchy. 
However, you do not have to use IK every time you have a hierarchy rig. This tool is useful when you 
want to bend a character's knees, make it sit and move the rest of the body, and so on. It will also 
assist you with the posing of difficult moves. 

In most 3D animation software, Inverse Kinematics is implemented as a skeleton system. Harmony 
uses the rigging hierarchy already created in the Timeline view, so there is no need to place bones in 
the character. Inverse Kinematics in Harmony uses the connection between each of the parts' pivots.

Inverse Kinematics will not work on basic rigs without hierarchy because there is no hierarchy chain 
present. IK only works on a hierarchy where the pivots are properly set.

When animating a hierarchy puppet, you will use both the Transform and Inverse Kinematics tools.

• About IK Hierarchy Chains below

• Where to Start with Inverse Kinematics? on page 696

• Inverse Kinematics Tool Properties on page 697

• Setting Up the Character to Use IK on page 700

• Nails on page 703

• IK Keyframes on page 704

• When to Use the Inverse Kinematics (IK) Tool on page 706

About IK Hierarchy Chains
Before we go any further, a word about IK chains. There are three types of chains:
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• Single Chains below

• Direct Chains below

• See "All Chains" on page 696

Single Chains

The single chains are the most basic of chains. A single chain is a straight line with no secondary chain 
attached. It goes up to the first intersection.

Direct Chains

A direct chain is a single chain which goes directly to the core (root).
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All Chains

All chains are attached and move together when one part is moved.

Where to Start with Inverse Kinematics?
IK works best when you lock a part of the character on the spot, such as a foot on the floor, then select 
the entire body or another extremity and move it. It also works well in single chain mode when you 
need to simply position a limb.

Tip: To lock a part in place, use the IK Nail option—see Nails on page 703.

How to use the Inverse Kinematics tool

1. In the Tools toolbar, select the Inverse Kinematics  tool or press Shift + I.

2. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) on a part of the body.

The entire IK skeleton appears.

696



Toon Boom Harmony 11.1 Draw Guide (Network)

3. Click on a part of the body and pull on it to move the character.

4. Hold down the Shift key and click on the pivot belonging to the part you want to lock in place.You 
can Shift + click on a bone to lock the orientation of the bone.

5. Click on another part of the character and pull on it. 

Inverse Kinematics Tool Properties

Mode

The IK tool has a series of different modes available in the Tool Properties view.

Mode Button Description

Bone Selection Enabled by default, this mode lets you click on any bone 
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in a character and move it without having to select the 
actual layer.

When you disable this mode, you can not move any 
bone except the selected one. This allows you to grab 
and rotate the selected part from many angles and 
location. You can click completely outside the character 
and move the pieces.

Chain

• Simple Chain Mode: this is the default mode and will 
only allow for the movement of parts attached to a 
single chain up to the point of intersection. A single 
chain is a straight line with no secondary chain 
attached

• Direct Chain Mode: this mode will allow the 
movement of parts up a simple secondary chain to a 
principle chain as long as translation movement is 
possible (the principle chain is attached to its own 
peg), but will ignore all secondary chains. A direct 
chain is a single chain which goes directly to the core.

• All Chain Mode: this mode allows for the movement 
of all parts attached to all chains in the IK skeleton. 
All chains are attached and move simultaneously 
when one part is moved.

IK Manipulation

The main working mode for the Inverse Kinematics tool. 
Enable this mode when you want to animate and 
position your puppet.

Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) on 
a body part to select it. You do not need to select a 
part to be able to move it.

Apply IK Constraints
Lets you correct a part's position on a series of frames. For 
example, if the character's foot is sinking into the floor, you can 
correct its position and angle over a series of frames.

Bone Editing
Lets you fix the bone orientation on extremities such as hands and 
feet.

IK Options

Parameter Description

IK Keyframe
Used in combination with the IK Constraints mode, this option 
determines the starting frame of the constraint you will apply.
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Ease Shape

While you animate with the IK tool, prior to doing a movement 
you can set an easing preset so that your motion is not so 
mechanical.

Before moving your part, select a preset from the Ease Shape 
menu:

If you select a new preset in the list and move the part again on 
the same keyframe, the easing will be automatically updated.

Selection

Mode Button Description

Enable Trans-
lation If Top of 
Hierarchy

Used only on master pegs. This option is useful when you 
have a situation such as this: you want the character to do a 
perfect split (sitting down with the legs at right angles to the 
body or at the sides with the torso facing forwards), then the 
hip will need to translate and not just rotate on the spot. And 
since IK is all about rotation, you would select the hip layer 
and enable the translation option.
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Enable Rotation

This  option is enabled by default. The pivot disappear but 
you can still see the bone.

If you disable this option, the selected part cannot be rotated 
and will remain in the same position. You can use this option 
to simulate an arm in a plaster cast.

Exclude from IK
This option lets you exclude certain parts of your puppet 
from the IK influence, such as the eyes and mouth.

IK Nails
These options let you temporarily fix a part of a character to a spot 
either in translation or rotation.

Stiffness ---

When a certain part is selected, you can apply a stiffness value to it. A 
different stiffness value can be set to each body part individually. The 
greater the Stiffness value applied, the more difficult it is to make that 
part rotate, thereby rendering it stiff while the other parts continue to 
move freely on their joints.

Setting Up the Character to Use IK
The first time you display the character's skeleton, you will notice a series of bones on the extremities 
which are out of place, and there may also be some elements that you would like to exclude from the 
Inverse Kinematics chain.
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It is highly recommended to set up the skeleton before starting your animation.

Before fixing any bones, or excluding layers from the IK, it is important that you make sure all the 
elements you want to be parented in a chain are set up.

You do not need to have hierarchy chains all over the body. They could exist only on the legs and arms. 
If the body is not completely rigged in hierarchy, the skeleton will look a bit more messy, but the IK 
tool will still work properly.

When working with the IK tool, you will probably want to move the main parts around, but not 
necessarily the small ones such as the nose or ears. To do this, you can select some elements on your 
character and exclude them from the skeleton.

Once you remove the extra elements from your skeleton, you will want to set the bone orientation for 
the extremity parts. By default, they are oriented horizontally towards the right. This orientation often 
works for the feet but not necessarily for the hair or hands.

How to exclude elements from the skeleton

1. In the Tools toolbar, select the Inverse Kinematics   tool or press Shift + I.

2. In the Tool Properties view, make sure the IK Manipulation Mode  is enabled.

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) on the part to exclude 
from the IK.
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4. In the Tool Properties view, click the Exclude from IK  button.

5. Repeat the process for every part to be excluded from the IK.

How to set the bone orientation

1. In the Tools toolbar, select the Inverse Kinematics  tool or press Shift + I.

2. In the Tool Properties view, enable the Bone Editing  mode.

3. In the Camera view, click on the pivot belonging to the part whose bone you want to reposition, 
then pull the pivot in the direction you want the bone to be.

4. Repeat this process for each bone you want to position.

This command only works on the extremities.
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Nails
Often, you will want to animate only part of a character, such as the arm and not the entire body. You 
can do this using IK nails, which are IK constraints that temporarily cut or constrain the chain. With the 
IK nails, you can cut an IK chain or block a part on the spot. For example, you can fix a character's feet 
to the ground when he walks.

There are different types of constraints you can place on the chain:

• IK Nail: Blocks the X, Y and Z positions.

• Hold Orientation: Blocks the angle.

• Hold X: Blocks only the X position.

• Hold Y: Blocks only the Y position.

How to set an IK nail

1. In the Tools toolbar, select the Inverse Kinematics  tool or press Shift + I.

2. In the Tool Properties view, make sure the IK Manipulation Mode  is enabled.

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) on the part to set a nail 
on.

4. In the Tool Properties view, select a type of nail:

‣ You can also hold down the Shift key and click on any part's pivot to set a regular nail on it 
without having to select it.

‣ You can hold down the Shift key and click on the bone to set a Hold Orientation nail.

‣ You can select the nail type in the top menu by selecting Animation > IK Constraints > the 
desired nail.
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‣ You can remove the nail at anytime using the same technique you did to place the nail. It will 
not affect the animation.

5. To remove every nail except the Enable Min/Max Angle ones, from the top menu, select 
Animation > IK Constraints > Remove All Constraints.

IK Keyframes

When you animate a walking character and lock the feet down, the locked position will be perfect on 
the key poses. However, when you use the motion keyframes to auto in-between the animation, you 
will notice a movement of feet. This motion is caused by the in-betweening of the rotations.

The nail holds in place the body part on the keyframe, but it will not hold it for the entire duration 
between keyframes.

If you place a nail on the shoulder to move just the arm, you do not necessarily want to keep the 
shoulder in the same place until the next key pose. You will probably want the shoulder, or any other 
part that is nailed, to have a slight, natural motion following the main body action. Of course, this is 
not the case when you fix a hand or a foot on the spot. If you have a fixed hand or foot, you will 
probably want it to stay exactly where you placed it. That is why you can apply an IK constraint on a 
frame range and on selected body parts.

To fix the part on the same spot requires an angle (rotation) correction on the parts that are moving 
too much. For example, to fix a foot that is moving too much, you will correct the angles on the foot, 
leg and thigh. To fix a hand, you will correct the angles on the hand, forearm and upper arm.

How to apply IK constraints on a frame range

1. In the Tools toolbar, select the Inverse Kinematics  tool or press Shift + I.

2. In the Camera view, click on the part you want to apply the constraint to.

3. In the Timeline view, set the cursor to the first frame where you want to start applying the 
constraint.

4. In the Tool Properties view, enable the Apply IK Constraints  mode.

5. In the Tool Properties view, click on the IK Keyframe  button to enter the first frame number.
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6. In the Timeline view, move the playhead to the last frame on which you want to apply the 
constraint.

The IK Keyframe field should now look like this:

7. In the Camera view, set a nail at the top of the limb you are correcting. For a foot, set the nail on 
the thigh by holding down the Shift key and clicking its pivot.

8. In the Tool Properties view, select the type of constraint you want to apply to your piece.The most 
common case is a combination of the regular Nail  and Hold Orientation  options.

9. In the Camera view, click on the bone of the part you want to apply a constraint to.

A warning message appears asking you to confirm that you want to add your constraint on that 
particular piece and for that frame duration.

10. Click OK.

Your constraint are now be applied.
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When to Use the Inverse Kinematics (IK) Tool
Harmony provides different tools for animating cut-out characters and trajectories. The two main 
tools used to animate characters are the Transform and Inverse Kinematics tools.

Here, we will compare the usage of these tools and explain the Inverse Kinematics philosophy.

• Transform Tool

Also known as forward kinematics, the Transform tool is the main tool to use for cut-out 
animation. This tool rotates, scales, moves and skews selected elements as one global element.

Forward kinematics means that the limb is animated from the parent down to the last child as a 
single piece. In other words, if the shoulder is animated, then the arm, forearm and hand follow as 
a complete arm drawing.

• Inverse Kinematics Tool (IK)

This assistance tool helps you achieve complex motions, such as sitting down or knee bending. The 
Inverse Kinematics tool moves and rotates every selected element as a chain.

Inverse kinematics means that the element is animated from the child up to the parent. In other 
words, if the hand is animated, then the forearm, arm and shoulder follow the hand in a fairly 
natural way in terms of the movement, rotation and bending.

IK Tool and Rigging

The IK tool cannot be used on every type of cut-out character. It depends on the way the pieces and 
parts are attached to one another. In other words, it depends on the rigging type.

There are several ways to rig a puppet. These are the three main rigging techniques:
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The Basic Rig Technique

• This is the simplest rig technique.

• There are no connections between the parts. 

• They are free to move, rotate and scale independently one from the other. 

• The Inverse Kinematics tool CANNOT be used on this type of rigging. 

The Hierarchy Rig Technique

• This is the complex rig technique.

• All the parts are connected one to the other. 

• As they move, rotate and scale, they will influence all the other parts. 

• The Inverse Kinematics tool can be used on this type of rigging. 

The Mixed Rig Technique

• This is the best of the basic and hierarchy rig.

• Some parts are independent such as the torso. 

• Some parts are set up into a hierarchy such as the arms and legs.

• Independent parts are rigged in hierarchy using parent pegs.

• The Inverse Kinematics tool can be used on this type of rigging. 

Animating with the Tools

Puppets are animated by using a combination of the Transform and Inverse Kinematics tools.

You will mainly use the Transform tool (forward kinematics) as it has all the main motions: rotate, 
scale, skew, move and select. You can also control the exact position of the parts while using the 
Transform tool. As well, the Transform tool creates a temporary global pivot on the selection that can 
be moved around for the animation purpose.

To complete complex motions, such as bending the knees while keeping the feet on the ground, you 
can use the Inverse Kinematics tool as an assistance tool. By adding IK constraints (nails), it is possible 
to lock the feet or any other part to a particular spot and move the rest of the body, which will react to 
the constraints.

Inverse Kinematics Philosophy

It is important to keep in mind that the Inverse Kinematics tool is an assistance tool. You will not be 
using it to animate all the time.

Also, the Inverse Kinematics tool can be used to do the character's posing faster. Posing is a crucial 
part in the animation process. The IK tool can be used to pose the character more naturally, 
depending on your own preferences.

An IK nail can be added anywhere on the character to animate only a small part of the hierarchy chain, 
such as an arm or a portion of the arm.

Tips and Tricks for Inverse Kinematics

Here are some tips and tricks to help you to use the Inverse Kinematics tool.

• IK on Mixed Rigs  

The Inverse Kinematics tool can be used on a full puppet's body even if it is connected as a mixed 
rig, meaning some parts are rigged in a hierarchy and others not. For example, you can add IK nails 
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on the puppet's feet, select the full body master peg and move the character as if it was connected 
in a full hierarchy rig. This technique works on most mix rigs.

• IK Constraints  

It is important to remember that you can add and remove IK constraints (nails, hold orientation, 
etc.) at any time during the animation. They hold a certain part on the spot while you animate the 
rest of the body. Because they are not constricting one part to another object, you can add or 
remove them without affecting any of the animation you have already done.

• Useful Shortcuts

• While using the IK tool, you can Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) to select 
any part. 

• Hold down Altto rotate the selected part without affecting the IK chain. 

• Press Shiftand click in a part's pivot to add or remove an IK Nail. 

• Press Shiftand click on a bone to add or remove and Hold Orientation constraint.
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Animating in Stop-motion

To start animating your character, start by doing your key poses. In fact, most of your time will be 
spent doing key poses. It is better to work with stop-motion keyframes so Harmony does not 
automatically create the interpolation between your keyframes.

When using stop-motion keyframes, also known as stepkeyframes, the segment between two 
keyframes is constant. There is no animation generated by the computer between the poses. The 
drawing remains in position until the next keyframe, then moves to its new position.

Creating a Stop-motion Keyframe

You can create a stop-motion keyframe in several different ways. You can have Harmony create it 
automatically, transform a motion keyframe into a stop-motion keyframe, or even switch your 
preferences to get Harmony to always create stop-motion keyframes by default.

How to automatically create stop-motion keyframes

1. In the top menu, make sure the Animation > Stop-motion Keyframe option is deselected.

2. In the Timeline view, select the cell on which you want to add a keyframe.

3. Do one of the following:

‣ Right-click on the selection and select Add Keyframe. 

‣ In the Timeline View toolbar, click the Add Keyframe  button.

‣ Press F6. 

In the Camera view, if the Animate mode is enabled, as soon as you move the selected element, a 
keyframe is automatically created on the current frame.
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How to convert a motion keyframe into a stop-motion keyframe

1. In the Timeline view, select the motion keyframes to convert into stop-motion keyframes. The default 
keyboard shortcut is S.

2. Do one of the following:

‣ Right-click on the selection and select Set Stop-Motion Keyframes. 

‣ In the Timeline View toolbar, click the Stop-Motion Keyframe  button.

‣ Press Ctrl + L (Windows/Linux) or ⌘  + L (Mac OS X). 
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Animating Using Computer-generated Interpolation

After you have created the key poses, you can animate the in-between poses yourself or let Harmony 
do it using motion keyframes. When you use motion keyframes, your drawings gradually move to the 
next position instead of staying on the spot until the next keyframe.

Creating a Motion Keyframe

You can create a motion keyframe in several different ways. You can have Harmony create it 
automatically, transform a stop-motion keyframe into a motion keyframe and even switch your 
preferences to get Harmony to always create motion keyframes by default. 

How to automatically create stop-motion keyframes

1. In the top menu, make sure that the Animation > Stop-Motion Keyframe option is disabled.

2. In the Timeline view, select the cell where you want to add a keyframe.

3. Do one of the following:

‣ Right-click on the selection and select Add Keyframe. 

‣ Click the Add Keyframe  button in the Timeline View toolbar.

‣ Press F6. 

In the Camera view, if the Animate mode is enabled, as soon as you move the selected element, a 
keyframe will be automatically created on the current frame.

How to convert a stop-motion keyframe into a motion keyframe

1. In the Timeline view, select the stop-motion keyframes to convert into motion keyframes.
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2. Do one of the following:

‣ Right-click on the selection and select Set Motion Keyframes. 

‣ Click the Motion Keyframe  button in the Timeline View toolbar.

‣ Press Ctrl + K (Windows/Linux) or ⌘  + K (Mac OS X).  

Adjusting the Ease

To add ease in and ease out on your motion paths, you can display the function curve and modify the 
Bézier or Ease curve. To apply an ease to multiple functions and keyframes, you can use the Set Ease 
for Multiple Parameters feature and set the amount desired.

The velocity, or ease, is used on motion keyframes. The velocity must be adjusted directly on the 
function curve in the Function view or Function editor. When a keyframe is selected, easing values 
appear in the right handle and left handle fields, as well as the Bézier handle or Ease wheel controls on 
each selected keyframe. You can pull on them to adjust the ease in and ease out, or type values in the 
fields. 

If there are several functions whose velocity you want to adjust at the same time, such as the hand, 
forearm and arm of a cut-out character, you can apply the same velocity parameters to all the selected 
keyframes in one frame.

How to adjust the velocity in the Function view

1. In the Timeline view, click the Expand Function  button to display all the layer’s functions.
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2. Double-click on the desired function.

The Function Editor  opens.

The Function editor will not display if the function does not already exist. Add a keyframe to create the 
function.

3. Select a keyframe and pull on its Bézier handles or Ease wheel to adjust the velocity. Refer to the 
Compositing Guide to learn how to create Ease curves instead of Bezier curves.
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How to set ease on multiple parameters 

1. In the Timeline view, select a keyframe from one or more layers.

Only the first keyframe selected on a given layer will be considered when using the Set Ease for Multiple 
Parameter function. If many keyframes are selected on the same layer, the ease values will be applied only 
to the first one and the rest will be ignored.

2. In the Timeline view, right-click and select Set Ease For Multiple Parameters. In the Timeline View 
toolbar, you can click the Set Ease For Multiple Parameters  button. If the button is not in the 
Timeline View menu, you can add it through the Toolbar Manager. Right-click on the toolbar and 
select Customize.

The Set Ease For Multiple Parameters dialog box opens.

3. In the graph interface, pull on the Bézier handle to adjust the velocity for all the selected functions.
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4. If you want to apply these easing parameters to a certain type of function only, such as Rotation or 
Scale, in the Filters section, deselect the function types you do not want to affect.

‣ Motion: Applies the easing parameters to the selected Position X, Position Y, Position Z 
and 3D Path functions

‣ Rotation: Applies the easing parameters to the selected Angle functions.

‣ Scale: Applies the easing parameters to the selected Scale functions.

‣ Skew: Applies the easing parameters to the selected Skew functions.

‣ Morphing: Applies the easing parameters to the selected Morphing Velocity functions. 
Note that it applied to the Morphing velocity function in the Layer Properties dialog, not to 
the basic Morphing ease in the Tool Properties view.

‣ Other: Applies the easing parameters to all the other selected functions, such as all 
functions created to animate effect parameters.

5. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values 
are calculated in percentage.

‣ In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding 
to the length of time you want the easing to last. The value must be between 0% and 100%.

‣ In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong 
you want the easing out. The value must be between 0% and 100%.

‣ If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

6. Once done, click one of the following buttons:

‣ Apply: Applies the easing parameters to the selected keyframes.

‣ Apply/Previous: Applies the easing parameters to the selected keyframes and then selects 
the previous keyframe in the timeline.

‣ Apply/Next: Applies the easing parameters to the selected keyframes and then selects the 
next keyframe in the timeline.

‣ Close: Closes the dialog box. If you did not apply the modifications, they will be cancelled.
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Marking the Timeline

As you animate, the Timeline view will contain many layers and keyframes. You might want to identify 
them using coloured layers and scene markers.

Scene markers are visual indicators displayed at the top of the timeline in the frame counter area. You 
can use it to denote anything relevant to your work. You can indicate at the frames you want to clean 
up, a change in action, an impact, or where you intend to apply an effect. You can also add a note to a 
scene marker, which is displayed when you hover over the scene marker.

There are two ways to add a scene marker. You can make a frame range selection and mark that 
whole section or simply mark the current frame.

How to mark the current frame

1. In the Timeline view, make sure the playhead is set on the frame you want to mark. Even if you 
right-click on a different frame, the scene marker will be created on the current frame, which means 
where the red playhead is.

2. Right-click in the frame counter area and select Scene Markers > Mark Current Frame.

The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or 
the colour of the last scene marker you created.

3. Double-click the Colour box to select a colour for your scene marker.

4. In the Note field, enter text to display a tooltip.

5. Click OK.

6. In the Timeline view, the scene marker is displayed at the current frame.  Hover over the scene 
marker to display its note as a tooltip.
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How to create a scene marker on a frame range

1. In the Timeline view frame counter, select the frame range on which you want to mark your scene.

2. Right-click and select Scene Markers.

The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or 
the colour of the last scene marker you created.

3. Click the colour swatch and select a colour for the scene marker.

4. In the Note field, enter text to display as a tooltip.

5. Click OK.

6. In the Timeline view, the scene marker is displayed over the selected frame counters. Hover over 
the scene marker to display its note as a tooltip.

How to modify a layer's colour

The Change Track Colour  button is used to change the colour of the exposed frames so you can 
quickly locate a layer in the Timeline view. 

1. Click the swatch to open the Select Colour dialog box and choose a new colour. You can modify 
the layer for any type of layer, such as group, peg, drawing and effects.
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Flipping Through Poses

When animating, it is useful to flip through poses to see the flow of your animation without going 
through each frame in the Timeline view. Harmony lets you flip between the selected element’s 
keyframes. 

How to flip through poses

1. In the Camera or Timeline view, select a layer that contains the poses you want to view.

2. From the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe or 
press semicolon (;) and single quote ('). 
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Using the Onion Skin in Cut-out Animation

When animating cut-out characters, it is useful to see the previous and next frames on the animation. 
However, it can sometimes be confusing to see the onion skin for every part of the character. You will 
often only want to see the onion skin on a single part or a few parts, such as the arm, that are currently 
being animated. Harmony offers that possibility. 

While animating in the Camera view, there is a series of different onion skin options. You can enable 
these options in the menu or manually in the Timeline view using the layer's Show Onion Skin  
button. Unless you change the onion skin options when you display the onion skin, only the selected 
layers will be displayed in the onion skin preview.

How to use the onion skin

1. In the Tools toolbar, click the Onion Skin  button or press Alt + O.

2. In the Tools toolbar, click the Transform  tool or press Shift + T.

3. In the Camera view, select one or more elements.

4. From the top menu, select View > Onion Skin > Add to Onion Skin, Remove From Onion Skin, 
Remove Unselected from Onion Skin, Add All to Onion Skin or Remove All from Onion Skin.

Add to Onion Skin

The Add to Onion Skin command is used to add a series of selected elements to the onion skin 
preview. The keyboard shortcut is Shift + S.
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Remove from Onion Skin

The Remove From Onion Skin command is used to remove a series of selected elements from the 
onion skin preview. 

Remove Unselected from Onion Skin

The Remove Unselected from Onion Skin command is used to remove all elements except the ones 
selected from the onion skin preview.

Add All to Onion Skin

The Add All to Onion Skin command is used to add all of the scene's elements to the onion skin 
preview. The keyboard shortcut is Alt + Shift + O.
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Remove All from Onion Skin

The Remove All Onion Skin command is used to remove all of the scene's elements from the onion 
skin preview. The keyboard shortcut is Ctrl + Shift + O (Windows/Linux) or ⌘  + Shift + O (Mac OS 
X).
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Flipping Parts

If you want to flip a part, a limb or a whole puppet, use the Transform tool and the Flip Horizontal and 
Flip Vertical options. If the scaling parameter is not set to Separate Scale, the flip is not applied to the 
selection.

How to flip a selection

1. In the Animation Tools toolbar, select the Transform  tool or press Shift + T.

2. In the Tool Properties view, make sure the Peg Selection Mode  is disabled.

3. In the Camera view, select the parts to be flipped.

4. In the  Tool Properties view, click the Flip Horizontal  or Flip Vertical  option or press 4 or 5 
respectively.
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Swapping Images

Cut-out animation is not only about moving parts around. It is also about swapping drawings to give 
the animation a more traditional animation look. You can add as many new drawings as you want in 
your scene and use them in your current animation. You can also add new drawings to your library and  
import them in other scenes. 

It is not necessary to remember the frame on which you drew or imported the drawings as you can see 
them in the Drawing Substitution window. 

You cannot swap one symbol for another—only the symbol’s frames or layer’s drawings.

You can swap images in the Timeline or Library view. When you use the Drawing Substitution window 
in the Library view, you are not selecting drawings from the Library but drawings contained in your 
scene’s layers.  The Drawing Substitution and Preview area are simply sharing the same interface 
space.

It is important to understand that when you swap a drawing, its entire exposure is replaced up to the 
next drawing block.

Although, if you select a frame range to be swapped, the following exposure will remain the same 
even if it was part of the same drawing block.
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If you want to make sure that a certain drawing remains exposed on a particular frame and is not 
overridden by a drawing swap on an earlier frame, you can use the key exposure function. They key 
exposure feature breaks a drawing block into two pieces. The same drawing is used in both blocks. If 
you modify the artwork in one, the artwork be modified in the second one, but if you swap the 
exposure of the first one for another drawing, the second block will remain with the first drawing. This 
feature is used to avoid messing up your animation key poses. One of the most frequent layers it is 
used on is the mouth layer.

How to set a key exposure

1. In the Timeline view, select the drawing cell to set as your key exposure.

2. In the Timeline View toolbar, you can click the Add Key Exposure  button.

‣ To delete a key exposure, click the Remove Key Exposure button.

How to swap images in the Library view

1. In the Tools toolbar, select the Transform  tool.

2. In the Transform Tool Properties view, make sure the Peg Selection  button is deselected.

3. In the Camera view, use the Transform  tool to select the part you want to swap.
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4. In the Timeline view, select the cell range where you want to swap the drawing.

5. In the Library view, go to the Drawing Substitution window.

6. Scroll through the Symbol's frames or drawings by doing one of the following:

‣ From the top menu, select Animation > Substitute Drawing Previous or Substitute 
Drawing Next.

‣ Drag the slider left or right. 

‣ Press +.  

The drawing or symbol’s cell on the current frame is replaced by the selected one.
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How to swap a drawing in the Timeline view

1. In the Timeline view, click the Show Data View  button to expand the Data view.

2. In the Timeline view’s right side, select the cell containing the drawing or symbol’s cell to swap.

3. In the Data view, drag the pointer left or right to change the cell or drawing exposed for another 
one. You can also directly type the drawing name or Symbol’s cell number if you know it.
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Adding a New Drawing

If you need to add a new drawing in your scene, you can do so  by duplicating the existing drawing on 
the current frame. If you are using symbols, you can also add a new drawing inside the body part’s 
symbol. 

Duplicating a Drawing

If your character does not use symbols, you must duplicate the drawing on the cell where you need to 
use a new drawing. You could also create a new blank drawing, but duplicating the existing drawing 
allows you to keep the pivot you previously set (if you are using drawing pivots) and you can also reuse 
a portion of the existing artwork. When you create a new drawing, you get a blank cell with a pivot set 
at the centre of the Camera view. 

How to duplicate a drawing

1. In the Timeline or Camera view, select the drawing to duplicate.

2. From the top menu, select Drawing > Duplicate Drawing or press Alt + Shift + D.

The new drawing appears in the currently selected cell.

3. In the Camera view, draw the new piece.
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Ordering Layers Over Time

The layer ordering system in Harmony saves time and simplifies your work. There is no need to create 
a new layer or copy and paste artwork into other layers to change the order. The Z-axis 
(forward/backward) allows you to create a multiplane and move elements closer or farther from the 
camera. This allows you to move the puppet’s pieces in front of or behind other ones without 
physically changing the layer position. 

Harmony provides you with a shortcut to move the piece with a micro nudge on the Z-axis. A keyframe 
is created where different Z values can be entered. This allows for the piece to move forward and 
backwards in space without requiring you to change the drawing’s original position or break the layer 
hierarchy. This also means that the layer ordering is maintained throughout the scene. You can 
combine animation assets so Harmony can interpolate them. 

How to nudge elements on the Z-axis

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

2. In the Tools toolbar, click the Animate  button.

3. In the Camera view, click on the part to be repositioned and hold down the Alt key. Using the Up or 
Down arrow keys, nudge the part until it moves to the desired position.
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Resetting a Transformation

If you made too many transformations and it is not going where you want it to go, or simply because 
you want to reset a pose you are reusing from another animation, you can reset your character's 
position. Once the layers are positioned in the Camera view, you can easily return them to their 
original position. There are three different ways to reset a transformation.

Using the Reset command, you can reset the value of the selected element to the initial value of the 
active tool. For example, if the Rotate  tool is active, the transformation angle will be reset to 0 
and if the Transform  tool is active, all the transformation values will be reset.

The Reset All option resets all transformations on the current frame in a selected layer. Your keyframe 
will remain, but all the values will return to the default position. All transformation are reset regardless 
of the tool you are using.

The Reset All Except Z option resets all the transformations on the current frame except the Z 
position. This is useful when doing cut-out animation. Cut-out puppets often have a particular Z 
ordering for the different views of a character. You might want to reset the transformation, but not 
necessarily the Z position. 

In the Timeline view, you can also use the Clear All Values command to reset all transformation values 
on the selected layers. Right-click on the selected layers and select Layers > Clear All Values. 

When using the Transform  tool to select elements in the Camera view, always make sure that the Peg 
Selection Mode  option in the Tool Properties view is disabled or it will limit the selection to peg only.

How to reset the transformation on the current frame

1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

2. In the Timeline or directly in the Camera view, select the drawing layer(s) to reset.

3. From the top menu, select Animation > Reset or press Shift + R.

The selected layer(s) return to their original position.

How to reset all transformations on the current frame

1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

2. In the Timeline or directly in the Camera view, select the drawing layer(s) to reset.

3. From the top menu, select Animation > Reset All.

The selected layer(s) return to their original position.

How to reset all transformations except the Z position on the current frame

1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

2. In the Timeline or directly in the Camera view, select the drawing layer(s) to reset.

3. From the top menu, select Animation > Reset All Except Z.

The selected layer(s) return to their original position, except for the Z values.
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Creating Cycles

You can create cycles from a portion of your animation or completely reverse the flow of your 
animation.

How to create an animation cycle 

1. In the Xsheet or Timeline view, select the cell range and keyframes to loop.

2. From the top menu, select Edit > Copy.

3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4. From the top menu, select one of the following:

‣ Edit > Paste Cycle or press Ctrl + / (Windows/Linux) or ⌘  + / (Mac OS X).

The Paste Cycle dialog box opens.

‣ Edit > Paste Special or press Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS X).

The Paste Special dialog box opens.
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5. In the Number of Cycles field, enter the number of cycles to paste.

6. In the Cycle Type menu, select a type of cycle to paste.

‣ Normal (forward): Pastes your selection as is, starting with the first cell and ending with the 
last.

‣ Reverse: Pastes your selection reversed, beginning with the last cell and ending with the 
first.

‣ Forward -> Reverse: Pastes your selection as a yo-yo, starting with the first cell, going to 
the last cell and ending with the first cell.

‣ Reverse -> Forward: Pastes your selection as a reversed yo-yo, starting with the last cell, 
going to the first one and ending with the last cell.

7. Click OK.

How to create a reverse animation cycle

1. In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.
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2. From the top menu, select Edit > Copy.

3. In the Xsheet or Timeline view, select the cell where you want the cycles to start.

4. From the top menu, select Edit > Paste Reverse or press Ctrl + . (Windows/Linux) or ⌘  + . (Mac 
OS X).
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Copying and Pasting Animation

As you animate, you will find that you reuse many positions, drawings, and keys. However, you may 
only want to paste the drawings or just the keys or maybe everything. There are different paste 
options available in the Timeline view which give you maximum flexibility when reusing and pasting.

Note that these modes also apply when you use drag instead of copy and paste.

There are three different modes for pasting your selection:

•  Paste Mode: All Drawing Attributes: Pastes the drawing exposure and keyframes.

• Paste Mode: Keyframes Only: Pastes only the keyframes.

•   Paste Mode: Exposures Only: Pastes only the drawing exposure.

How to paste a selection using different modes

1. In the Timeline view, select the cells you want to copy and paste.

2. In the Timeline view's left side, enable the desired Paste  mode.

3. From the top menu, select Edit > Copy cells from the Timeline or press Ctrl + C (Windows/Linux) 
or ⌘  + C (Mac OS X).

4. In the Timeline view's right side, select the cell where you want to paste your selection.

5. Select Edit > Paste Cells in the Timeline  or press Ctrl + V (Windows/Linux) or ⌘  + V (Mac OS X).

Paste Mode: All Drawing Attributes

Paste Mode: Keyframes Only
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Paste Mode: Exposures Only
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Adding Pegs

Now that you have your puppet on stage, you probably need to resize and reposition it to fit your 
scene. When you need to scale down or move your character, it is a good idea to hook (attach) the 
whole puppet to a trajectory. 

In Harmony, there is a type of layer you can add to your timeline, allowing you to create a motion path 
or reposition drawings. This trajectory layer is called a peg. Any drawing or layer you hook to a peg 
will follow the defined motion path, rotation, scaling and skewing information.

Attaching your puppet to a peg allows you to scale and reposition it without having to do the same on 
all the different parts and pieces. Only one layer will contain the position information, making your 
animation easier to modify and control.

Next, position your character on the stage by moving it and scaling it to the correct size. You will not 
scale each layer individually. You either want to do it on the top symbol or top peg layer.

How to add a repositioning peg

1. In the Timeline view, select the top layer on which you want to parent a peg. 

You must select a layer to be able to add a peg to your scene. Unless you use the Display All mode from 
the Display toolbar, an error message will display if you try to add a peg without any selection.

2. In the Timeline view, click the Add Peg  button.

A new peg is added to the timeline as a parent of the selected layer.

3. Double-click on the name of new peg layer and rename it Master_Peg.

4. In the Timeline view, select all of the layers you want to attach to the new peg. Remember that one 
item is already parented to that peg.
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5. Drag your selection and drop it on the peg layer to parent all your character's pieces to the peg. If 
your layers are added above the already-parented layers, move that parented layer back on top of 
the layer stack.

How to reposition a character

1. In the Timeline view, select the top peg layer (master peg).

2. In the Tools toolbar, select the Transform  tool and disable the Animate  mode.

3. In the Camera view, position the character.
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Chapter 1: Import

Toon Boom Harmony allows you to import external content as well as being able to draw directly in 
the software. This means that characters, backgrounds and videos created in other drawing, painting 
and multimedia programs can be brought in and animated. You can import QuickTime videos, 
pictures, multilayered PSD files, as well as AI, SWF and PDF files. You can also scan your images and 
import them as bitmap or vectorize them.

This chapter contains the following topics:

• Importing Bitmap Images  on the next page

• Importing PSD Files as Separate Layers  on page 751

• Exporting and Reimporting a PSD Layout on page 758

• Scanning Images  on page 769

• Importing AI and PDF Files  on page 777

• Scanning Images  on page 769

• Importing Adobe Flash Files on page 780

• Importing QuickTime Movies  on page 784

• Custom Vectorization Parameters  on page 786

For sound import, refer to Importing a Sound File on page 904.
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Importing Bitmap Images 

Images can come in many different file formats and are usually saved in a format that retains the 
original specifications set by the image creator. Some formats can preserve the transparency or 
transparent layers, while others are not resolution dependent due to their vector nature. Toon Boom 
Harmony supports the following formats: JPEG, BMP, PNG, TGA, PSD, TIFF, SGI, TVG, OMF, PAL, 
SCAN.

When importing images and 3D models and linking images, your settings are saved in your user 
settings.

In this section, you will cover the following topics:

• Importing a Bitmap Image Without Vectorization  below

• Importing and Vectorizing Bitmap Images  on page 748

Importing a Bitmap Image Without Vectorization 

How to open the Import Images dialog box

1. Do one of the following:

‣ From the top menu, select File > Import > Images. 

‣ In the File toolbar, click the Import Images  button.

‣ In the Xsheet view, right-click anywhere in the frame area and select Import > Images.

The Import Images dialog box opens.
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How to import a bitmap image in its original format

1. In the Files section of the Import Images dialog box, click Browse to find and select one or more 
images on your computer.

2. Decide if the bitmap image will go on a new layer or an existing layer. To add the bitmap image to 
a new layer, go to step 4. To add the bitmap image to an existing layer, go to step 5.

3. Add the bitmap image to a new layer by selecting the Create Layer(s) option and one of the 
following options: 

‣ Create Single Layer Named: Creates a layer you can name.

‣ Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. 
For example, the filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b", 
where "a" has two drawings and "b" has one. When creating a single layer from these three 
filenames, all three drawings will be inserted in the new layers.

4. Select the Add to Existing Layer option if you want to place the bitmap image on a layer you select 
from the list.  If only vector  layers are available in your scene, they will not be displayed in the 
list. You can choose to encapsulate the bitmap in a symbol by selecting the Create Symbols for 
Imported Items option. 

5. In the Import Options section, select the Keep As Original Bitmap  option. In the Alignment 
section, decide on the size and placement of your image within the camera frame. Depending on 
the Scene Settings (the height and width in pixels that you chose for your project), an image that 
you import may be scaled to the point where all its individual pixels become visible. There are three 
options available in the Alignment section:

Parameter Description

Fit
Enlarges or shrinks (but not distorts) the image height to 
match the full height of the scene grid.
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If the image orientation is landscape, this will enlarge or 
shrink (but not distort) your image width to match that of 
the scene grid.

Note that the Fit alignment rule equals the Center Fit rule in 
the layer properties.

Pan

This is the opposite of the Fit parameter. If the image 
orientation is portrait, its width will be made to match the 
width of the scene grid. As a result, part of the image’s 
height will extend beyond the height of the frame. This can 
be useful if you want to make your background move up and 
down, or from left to right to make it appear as if the 
camera is panning, or to actually perform a camera pan.
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The opposite will apply to a landscape image. Its height will 
be fit to the scene grid, therefore it is possible that the 
image will extend beyond the scene grid's boundaries.

Note that the Pan alignment rule equals the Center First 
Page rule in the layer properties.

Project Res-
olution

Scales the image in proportion to the scene's resolution. 
The system looks at the resolution of the bitmap image, for 
example 4000 x 2000, then compares it to the scene's 
resolution, for example 1920 x 1080, and adjusts the scale 
factor in proportion. So, in this example, the bitmap would 
appear at 208% (4000/1920). If you import a bitmap that is 
960 x 540, it will be displayed at 50% (960/1920) of the size 
of the project resolution.
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Note that the Project Resolution alignment rule is equal to 
the As Is rule in the layer properties.

6. In the Transparency section, select one of the following from the Alpha menu:

Parameter Description

Premultiplied with 
White 

Individual pixels at the edge of an image are 
blended with white.

Premultiplied with 
Black 

Semi-transparent pixels in the original image 
are blended with black.

Straight 
Pixels at the edge of an image are blended with 
black, white and greys.

Clamp Colour to 
Alpha

Premultiplies the colour value with the alpha 
value. When the colour is clamped to the alpha, 
the colour value cannot be higher than the alpha 
value. It calculates the real colour value faster. 
When the RGB values are multiplied with the 
alpha value, that is, if you have a pixel of value 
R=247, G=188, B=29 and the alpha is 50% or 
the image has a 50% transparency, then the 
actual RGB values that are output would be half 
of the amounts listed above.

7. Click OK.

Adding Images to a Bitmap Layer

How to add more bitmap images to an existing bitmap layer

1. In the Timeline view, if the bitmap image is contained in a symbol, double-click on the bitmap 
symbol cell to edit the symbol. Otherwise, if the bitmap image is on a bitmap  layer, leave it as 
is.

 

2. If necessary, in the Timeline view, pull on the red bracket to extend the exposure.

3. From the top menu, select File > Import > Images or click the Import Image  button.

The Import Images dialog box opens.
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4. Click Browse to find and select one or several images on your computer.

5. In the Layer section, select the Add to Existing Layer option and select an existing bitmap layer 
from the menu.

6. Deselect the Create Symbol for Imported Items option.

7. In the Import Options section, select the Keep As Original Bitmap option. In the Alignment 
section, decide on the size and placement of your image within the camera frame. Depending on 
the Scene Settings (the height and width in pixels that you chose for your project), an image that 
you import may get scaled to the point where all its individual pixels become visible. There are 
three options available in the Alignment section:

Parameter Description

Fit

Enlarges or shrinks (but not distorts) the image height to 
match the full height of the scene grid.

If the image orientation is landscape, this will enlarge or 
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shrink (but not distort) your image width to match that of the 
scene grid.

Note that the Fit alignment rule equals the Center Fit rule in 
the layer properties.

Pan

This is the opposite of the Fit parameter. If the image 
orientation is portrait, its width will be made to match the 
width of the scene grid. As a result, part of the image’s height 
will extend beyond the height of the frame. This can be useful 
if you want to make your background move up and down, or 
from left to right to make it appear as if the camera is 
panning, or to actually perform a camera pan.

The opposite will apply to a landscape image. Its height will 
be fit to the scene grid, therefore it is possible that the image 
will extend beyond the scene grid's boundaries.
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Note that the Pan alignment rule equals the Center First Page 
rule in the layer properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The 
system looks at the resolution of the bitmap image, for 
example 4000 x 2000, then compares it to the scene's 
resolution, for example 1920 x 1080, and adjusts the scale 
factor in proportion. So, in this example, the bitmap would 
appear at 208% (4000/1920). If you import a bitmap that is 
960 x 540, it will be displayed at 50% (960/1920) of the size of 
the project resolution.

Note that the Project Resolution alignment rule is equal to 
the As Is rule in the layer properties.

8. In the Transparency section, select one of the following from the Alpha menu:

Parameter Description

Premultiplied with 
White 

Individual pixels at the edge of an image are blended with 
white.

Premultiplied with 
Black 

Pixels at the edge of an image are blended with black.

Straight 
Pixels at the edge of an image are blended with black, white 
and greys.

Clamp Colour to Alpha

Premultiplies the colour value with the alpha value. When the colour is 
clamped to the alpha, the colour value cannot be higher than the alpha 
value. It calculates the real colour value faster. When the RGB values are 
multiplied with the alpha value, that is to say, if you have a pixel of value 
R=247, G=188, B=29 and the alpha is 50% or the image has a 50% trans-
parency, then the actual RGB values that are output would be half of the 
amounts listed above.
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9. Click OK.

 

 Bitmap Image Quality 
If the bitmap images that you imported look blurry or slightly pixelated, you can clean up the image. 
You can change the quality of the preview in the Camera view and it will not affect the final render.

How to change the bitmap image quality

1. In the Camera view, double-click on the bitmap image to enter its symbol if the image is 
encapsulatesd or simply select the bitmap image layer in the Timeline view if it is not.

2. From the top menu or Camera menu, select View > Bitmap File Quality or press Ctrl + Q 
(Windows/Linux) or  ̂  + Q (Mac OS X).

The Bitmap Image Quality dialog box opens.

3. Drag the slider to the right to improve the quality.

4. Click OK.

5. If you are inside a symbol, go to the top of the Camera view and click Top to exit the symbol and 
return to your scene.

Importing and Vectorizing Bitmap Images 

You can turn bitmap images into vector drawings, while maintaining the sketchiness of a pencil line or 
into vector images with a bitmap fill. Both options can add life to an animation, which straight 
vectorization with smoothing does not usually afford.

How to import and vectorize a bitmap image

1. From the top menu, select File > Import > Images or click the Import Image  button in the File 
toolbar.

The Import Images dialog box opens.
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2. Click Browse to locate images.

3. In the Layer section, decide if the scanned or imported image will be placed on a new layer or 
existing layer. 

‣ Create Layer: Scans or imports the image into a new layer. Select one of the following 
options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For 
example, the filenames a-1.tga, a-2.tga and b-1.tga will create 
layers named "a" and "b", where "a" has two drawings and 
"b" has one. When creating a single layer from these three file-
names, all three drawings will be inserted in the new layers.

‣ Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from 
the Layer list. You must scan into the same layer type if you are using an existing layer.

‣ Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix 
bitmap images with vector drawings on the same layer, the bitmap image must be 
encapsulated in a symbol and vice versa. Symbols will also be automatically added to the 
Symbol folder in the Library view.

4. In the Import Options section, select the Convert to Toon Boom Vector Drawing option.

5. In the Vectorization section, decide whether you want to import your image in colour, black and 
white, or grey.In the Vectorization section, decide whether you want to import your image in colour, 
black and white,  grey, or if you want to add a new preset.
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‣ Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based 
drawing. 

‣ Grey: Vectorizes your image as a mix of vector contour and greyscale bitmap filling. Lines 
keep the texture from the scan, and the white of the paper becomes transparent.

‣ New Preset: The New Preset  button lets you create custom vectorization parameters via 
the Vectorization Parameters interface. 

You can double-click on any of the presets at any time to open the Vectorization 
Parameters dialog box to customize your option. 

The vectorized images are painted with the Vectorize Line colour swatch from the colour palette.

6. Click OK.

A symbol or new layer contains the vector drawing. For images contained in a symbol, double-click 
on the image’s first cell in the Timeline view to enter the symbol so you can edit the image. 
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Importing PSD Files as Separate Layers 

PSD files (a format exportable exclusively from Adobe Photoshop) are unique in that they are able to 
retain multiple layers. This is advantageous as the image remains fully editable in terms of any colour 
correction, effects, masking, transparency, or compositing that were made to the PSD file in Adobe 
Photoshop.

Note that your PSD image file must be set to RGB mode within Adobe Photoshop prior to being imported 
into Harmony.

How to import the separated layers of a PSD file

1. Organize your Adobe Photoshop file so that all your layers are “grouped” into individual folders, 
or that all the elements you want to import as a single layer in Harmony are grouped together in 
their own folder. Any layer that is not in a folder group, by itself or otherwise, will not be imported.

2. In Harmony, go to the top menu and select File > Import > Images or click the Import Image  
button.

The Import Drawings dialog box opens.
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3. In the Files section, click Browse to find and select the PSD image on your computer.

4. In the Layer section, select the Create Layer(s) option, then select one of the following options:

‣ Create Single Layer Named: Creates a layer you can name.

‣ Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. 
For example, the filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b", 
where "a" has two drawings and "b" has one. When creating a single layer from these three 
filenames, all three drawings will be inserted in the new layers.
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5. In the Import Options section, select one of the following:

‣ Keep As Original Bitmap: Retains an imported image as a bitmap. In the Alignment 
section, decide on the size and placement of your image within the camera frame. 
Depending on the Scene Settings (the height and width in pixels that you chose for your 
project), an image that you import may get scaled to the point where all its individual pixels 
become visible. There are three options available in the Alignment section:

Parameter Description

Fit

Enlarges or shrinks (but not distorts) the image height to 
match the full height of the scene grid.

If the image orientation is landscape, this will enlarge or 
shrink (but not distort) your image width to match that of the 
scene grid.

Note that the Fit alignment rule equals the Center Fit rule in 
the layer properties.

Pan

This is the opposite of the Fit parameter. If the image 
orientation is portrait, its width will be made to match the 
width of the scene grid. As a result, part of the image’s height 
will extend beyond the height of the frame. This can be useful 
if you want to make your background move up and down, or 
from left to right to make it appear as if the camera is 
panning, or to actually perform a camera pan.
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The opposite will apply to a landscape image. Its height will 
be fit to the scene grid, therefore it is possible that the image 
will extend beyond the scene grid's boundaries.

Note that the Pan alignment rule equals the Center First Page 
rule in the layer properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The 
system looks at the resolution of the bitmap image, for 
example 4000 x 2000, then compares it to the scene's 
resolution, for example 1920 x 1080, and adjusts the scale 
factor in proportion. So, in this example, the bitmap would 
appear at 208% (4000/1920). If you import a bitmap that is 
960 x 540, it will be displayed at 50% (960/1920) of the size of 
the project resolution.
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Note that the Project Resolution alignment rule is equal to 
the As Is rule in the layer properties.

‣ Import As Bitmap Drawing: Imports a drawing into a vector layer where you can edit the 
image using the drawing tools. In the Alignment section, select one of the following:

Parameter Description

Vertical Fit

Enlarges or shrinks (but not distort) to your image height to match 
the full height of the scene frame (alignment grid).

Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match 
the full width of the scene frame (alignment grid).

Actual Size

Scales the image in proportion to the scene's resolution. The system 
looks at the resolution of the bitmap image, for example 4000 x 
2000, then compares it to the scene's resolution, for example 1920 x 
1080, and adjusts the scale factor in proportion. So, in this example, 
the bitmap would appear at 208% (4000/1920). If you import a 
bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the 
size of the project resolution.
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‣ Convert to Toon Boom Vector Drawing: Imports a drawing and converts it to a Toon 
Boom vector drawing. In the Vectorization section, select one of the following:

Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based drawing.

Grey: Vectorizes the image as a mix of vector contour and greyscale bitmap filling. Lines keep the 
texture from the scan, and the white of the paper becomes transparent.

New Preset: Lets you create a new preset.

Delete Preset: Lets you delete any preset in the list.

Custom vectorization: Lets you set custom vectorization parameters—see Creating a 
Vectorization Style  on page 794.

6. Decide whether to select Vectorize Imported Items option.

If you decide to use the Vectorize Imported Items option, see Importing and Vectorizing Bitmap Images  on 
page 748 to learn more about vectorization settings.

If you disable the Vectorize Imported Items options, the Transparency and Alignment settings will appear in 
place of the Vectorization settings—see Importing a Bitmap Image Without Vectorization  on page 740.

7. Click OK.

The Multilayer Image Import Settings dialog box opens.

8. From the Create  menu, select one of the following:

‣ Single Layer: To import the Camera and Layout layers merged together.

‣ Separated Layers: To keep your Camera and Layout layers separated.

9. From the Transparency menu, select one of the following if applicable:
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Parameter Description

Premultiplied with 
White 

Individual pixels at the edge of an image are blended with 
white.

Premultiplied with 
Black 

Pixels at the edge of an image are blended with black.

Straight 
Pixels at the edge of an image are blended with black, white 
and greys.

Clamp Colour to Alpha

Premultiplies the colour value with the alpha value. When the colour is 
clamped to the alpha, the colour value cannot be higher than the alpha 
value. It calculates the real colour value faster. When the RGB values are 
multiplied with the alpha value, that is to say, if you have a pixel of value 
R=247, G=188, B=29 and the alpha is 50% or the image has a 50% trans-
parency, then the actual RGB values that are output would be half of the 
amounts listed above.

10. Click OK.

Your image appears as separate layers in the Timeline view, corresponding to the PSD layer group 
folders.

The artwork displayed in every one of your layers as a result of a multilayer PSD file import is linked to the 
same source image. This means that if you use the Drawing > Delete Selected Drawings command to 
physically delete the drawing from the project folder, the exposed drawing will be deleted in all layers at 
once. Once deleted from the project folder, the image cannot be retrieved unless you reimport your psd 
file.
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Exporting and Reimporting a PSD Layout

Toon Boom Harmony allows you to export the content of your scene as a PSD layout. This can be 
helpful for scene setup, background art retakes or even planning of animation.

Refer to Scene Setup on page 801 to learn more about the scene setup task.

Exporting a Layout
Before exporting a layout, all the elements must be well positioned. For example, if you plan to include 
a camera movement in this scene, you should also set this up, as you can export the camera keyframes 
to generate a clear and complete layout.

You can also create all the layouts for your production in the same Harmony  project which can be 
imported later on when you start each scene’s project. This will help set up the scene and begin its 
creation. You can use these layout PSD files to create the background art of each scene and make sure 
everything is correctly framed and at the right size. Finally, you can also have a layer with a drawing of 
the rough poses of the character or action and generate your layout posing from there.

Note that only the first frame of your drawing layers will be exported, as the layout image is one static PSD 
file.

For more information, refer to Scene Setup on page 801 and Animation Paths on 
page 843 and the Drawing chapter in the Paperless Animation Guide.

How to export your scene as a layout

Before exporting your scene as a layout, position your background elements, and everything you 
need as a reference in your scene, including a camera movement. 

1. From the top menu, select one of the following:
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‣ File > Export > Layout Image to export all the elements in your scene to the layout PSD 
file.

‣ File > Export > Layout Image from Selection to export only the elements. 

The Export Layout Image dialog box opens.

2. In the Export Layout Image dialog box, set the export parameters:

Parameter Description

Destination Path
Use the Browse button to select a location to save your layout and 
name the resulting PSD file.

 
File Pattern: Automatically puts the name of the scene and/or the frame 
number in the name of the file you create.

Image Size

The size of the PSD image file that will be exported. The resulting image 
will be 72 dpi as the standard television resolution and its size in pixel 
will fit your scene resolution settings. i.e HDTV, NTSC, PAL, etc. Note 
that if you have a camera movement going over the normal camera 
frame limit, for example a pan, the image will be bigger.

Options File Format: Lets you select the format to export your layout.

 
Export Camera Frame: This option is disabled by default. You can 
enable it to export an additional layer to your PSD file displaying the 
camera frame on it.

 Add a Camera Frame for each Key Frame: This option is 
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disabled by default, meaning that if you have a camera 
movement with more than a starting and an ending point, 
only these positions of the camera frame will appear on the 
camera layer of the exported layout PSD file. You must 
enable this option if you need to the in-between keyframes to 
also be displayed.

 

Label Camera Frame: Adds the camera position label in the 
top corner of the camera frames. The camera label is a single 
alphabet letter determining the order of the camera frame 
position.

 

Add Border to Layout: This option is disabled by default, 
meaning the layout image will take the complete PSD area, 
cropped at the very edge of the canvas. You can enable this 
option to add a transparent area all around the layout. You 
must setup the size of this area by using the Scale field lower. 
The resulting image will be larger.

 

• Scale: Sets the size of the transparent border around the 
layout image. By default the value is set to 100% to export 
the image as is with no transparent area around it. 
Increase the percentage value to add the extra around the 
image to create the border.

 

Adjust Scaling Factor: This option is enabled by default, 
meaning that when you have a camera zoom movement, the 
size of the layout image will be adjusted accordingly. The 
resulting percentage will be calculated following the maximal 
camera zoom value appearing in the layout. This allows the 
image to be exported at an appropriate resolution, 
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preventing the layout image from appearing pixelated or 
blurry when the camera zoom occurs. You can disable this 
option to export the image layout at the normal size.

 

• Scale: When the Adjust Scaling Factor option is enabled, 
the Scale value is automatically calculated according to the 
maximum camera zoom in your layout. You can modify this 
value.

Vector Options: If you export one or more vector-based 
drawing layers in your layout image, you have the option to 
export only the drawing layers you want. Enable or disable 
the following options to export or prevent the export of the 
corresponding art layers.

• Overlay:  Exports the art in the Overlay layer of the 
drawings to be exported to the layout image.

• Line Art:  Exports the art in the Line layer of the drawings 
to be exported to the layout image. 

• Colour Art:  Exports the art in the Colour layer of the 
drawings to be exported to the layout image.

• Underlay:  Exports the art in the Underlay layer of the 
drawings to be exported to the layout image.

3. Click OK to validate the settings and export a PSD file of your layout.

The resulting image is a PSD file with one or two layers, each of which is contained in a 
corresponding group. These groups make the layout PSD file ready for a multilayer PSD import. 

The Camera_Set group contains the camera drawing layer. If you selected the Export Camera 
option, this group and layer appear in your layout image.

The Layout_Set group contains a merged drawing layer of all the content of your scene’s first 
frame when you exported the layout image.
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An XLI file is exported along with your PSD file. This file contains all the necessary information for correctly 
importing and automatically positioning your layout image in a Harmony project. Do not delete the XLI file 
or rename it. Also, always keep it at the same location as the layout PSD file.

Importing a Photoshop Layout
If you exported a Photoshop layout image from a Harmony project, you can easily import it back into 
Harmony. Just be sure to import it at the beginning of the project for accurate scene planning.

How to import a PSD layout

1. In your Harmony project, select File > Import > Images.

The Import Images dialog box opens.

2. In the Files section, click Browse to find and select the PSD layout file on your computer. Note that 
this layout file must have its corresponding XLI file in the same folder.
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3. Once you have selected the layout file, the Use Position Information Contained in XLI file option 
appears in the Layer section. 

This option is enabled by default. When you import the layout image in your scene, it will be 
automatically positioned to fit the original layout scene creating an accurate layout guide. You can 
disable this option if you want the imported layout image to be imported according to the normal 
behaviour of the import process. The layout image will be incorrectly aligned as it was when it was 
first created.

4. In the Layer section, select the Create Layer(s) option, then select one of the following options:

‣ Create Single Layer Named: Creates a layer you can name.

‣ Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. 
For example, the filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b", 
where "a" has two drawings and "b" has one. When creating a single layer from these three 
filenames, all three drawings will be inserted in the new layers.

5. Select the Create Symbol for Imported Items option if you want the layers to be contained in 
symbols.

6. In the Import Options section, select one of the following:

‣ Keep As Original Bitmap: Retains an imported image as a bitmap. In the Alignment 
section, decide on the size and placement of your image within the camera frame. 
Depending on the Scene Settings (the height and width in pixels that you chose for your 
project), an image that you import may get scaled to the point where all its individual pixels 
become visible. There are three options available in the Alignment section:

Parameter Description

Fit
Enlarges or shrinks (but not distorts) the image height to 
match the full height of the scene grid.
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If the image orientation is landscape, this will enlarge or 
shrink (but not distort) your image width to match that of the 
scene grid.

Note that the Fit alignment rule equals the Center Fit rule in 
the layer properties.

Pan

This is the opposite of the Fit parameter. If the image 
orientation is portrait, its width will be made to match the 
width of the scene grid. As a result, part of the image’s height 
will extend beyond the height of the frame. This can be useful 
if you want to make your background move up and down, or 
from left to right to make it appear as if the camera is 
panning, or to actually perform a camera pan.
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The opposite will apply to a landscape image. Its height will 
be fit to the scene grid, therefore it is possible that the image 
will extend beyond the scene grid's boundaries.

Note that the Pan alignment rule equals the Center First Page 
rule in the layer properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The 
system looks at the resolution of the bitmap image, for 
example 4000 x 2000, then compares it to the scene's 
resolution, for example 1920 x 1080, and adjusts the scale 
factor in proportion. So, in this example, the bitmap would 
appear at 208% (4000/1920). If you import a bitmap that is 
960 x 540, it will be displayed at 50% (960/1920) of the size of 
the project resolution.
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Note that the Project Resolution alignment rule is equal to 
the As Is rule in the layer properties.

‣ Import As Toon Boom Bitmap Drawing: Imports a drawing into a vector layer where you 
can edit the image using the drawing tools. In the Alignment section, select one of the 
following:

Parameter Description

Vertical Fit

Enlarges or shrinks (but not distort) to your image height to match 
the full height of the scene frame (alignment grid).

Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match 
the full width of the scene frame (alignment grid).

Actual Size

Scales the image in proportion to the scene's resolution. The system 
looks at the resolution of the bitmap image, for example 4000 x 
2000, then compares it to the scene's resolution, for example 1920 x 
1080, and adjusts the scale factor in proportion. So, in this example, 
the bitmap would appear at 208% (4000/1920). If you import a 
bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the 
size of the project resolution.

766



Toon Boom Harmony 11.1 Draw Guide (Network)

‣ Convert to Toon Boom Vector Drawing: Imports a drawing and converts it to a Toon 
Boom vector drawing. In the Vectorization section, select one of the following:

Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based drawing.

Grey: Vectorizes the image as a mix of vector contour and greyscale bitmap filling. Lines keep the 
texture from the scan, and the white of the paper becomes transparent.

New Preset: Lets you create a new preset.

Delete Preset: Lets you delete any preset in the list.

Custom vectorization: Lets you set custom vectorization parameters—see Creating a 
Vectorization Style  on page 794.

7. Click OK.

The Multilayer Image Import Settings dialog box opens.

8. From the Create  menu, select one of the following:

‣ Single Layer: To import the Camera and Layout layers merged together.

‣ Separated Layers: To keep your Camera and Layout layers separated.

9. From the Transparency menu, select one of the following if applicable:

Parameter Description

Premultiplied with 
White 

Individual pixels at the edge of an image are blended with 
white.

Premultiplied with 
Black 

Pixels at the edge of an image are blended with black.

Straight 
Pixels at the edge of an image are blended with black, white 
and greys.

Clamp Colour to Alpha
Premultiplies the colour value with the alpha value. When the colour is 
clamped to the alpha, the colour value cannot be higher than the alpha 
value. It calculates the real colour value faster. When the RGB values are 
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multiplied with the alpha value, that is to say, if you have a pixel of value 
R=247, G=188, B=29 and the alpha is 50% or the image has a 50% trans-
parency, then the actual RGB values that are output would be half of the 
amounts listed above.

10. Click OK.

Your image appears as separate layers in the Timeline view, corresponding to the PSD layer group 
folders Camera_Set and Layout_Set. You can now use this layout as a guide for scene settings.

Refer to Scene Setup on page 801 to learn more about the scene setup task.
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Scanning Images 

Toon Boom Harmony can receive images from any TWAIN device such as scanners and digital 
cameras. These images can either be loaded into your scene as bitmaps or converted into vector- 
based images that can be edited using Toon Boom Harmony.

If your operating system does not automatically recognize your device after it has been connected, you 
must install the correct TWAIN drivers in order to access its contents. You can usually download the 
drivers from the device manufacturer’s website.

How to open the Scan Drawings window and set your scanner

1. From the top menu, select File > Import > From Scanner.

The Scan Drawings window opens. 

2. In the Scan Drawings window, select your scanner or other supported TWAIN device from the 
Scanner menu. If none are available, check your device to ensure that it is properly connected to 
your computer. If your device still does not appear in the menu, you may have to shut down and 
restart the software.

How to scan an image in its original format

3. In the Layer section, decide if the scanned or imported image will be placed on a new layer or 
existing layer. 
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‣ Create Layer: Scans or imports the image into a new layer. Select one of the following 
options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For 
example, the filenames a-1.tga, a-2.tga and b-1.tga will create 
layers named "a" and "b", where "a" has two drawings and 
"b" has one. When creating a single layer from these three file-
names, all three drawings will be inserted in the new layers.

‣ Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from 
the Layer list. You must scan into the same layer type if you are using an existing layer.

‣ Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix 
bitmap images with vector drawings on the same layer, the bitmap image must be 
encapsulated in a symbol and vice versa. Symbols will also be automatically added to the 
Symbol folder in the Library view.

4. In the Import Options section, select the Keep As Original Bitmap option.

5. In the Alignment section, decide on the size and placement of your scanned image within the 
camera frame. Depending on the scene settings (the height and width, in pixels, that you chose for 
your project), an image that you scan may be scaled to the point where all its individual pixels 
become visible.

Parameter Description

Fit

Enlarges or shrinks (but not distorts) the image height to 
match the full height of the scene grid.

If the image orientation is landscape, this will enlarge or 
shrink (but not distort) your image width to match that of the 
scene grid.
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Note that the Fit alignment rule equals the Center Fit rule in 
the layer properties.

Pan

This is the opposite of the Fit parameter. If the image 
orientation is portrait, its width will be made to match the 
width of the scene grid. As a result, part of the image’s height 
will extend beyond the height of the frame. This can be useful 
if you want to make your background move up and down, or 
from left to right to make it appear as if the camera is 
panning, or to actually perform a camera pan.

The opposite will apply to a landscape image. Its height will 
be fit to the scene grid, therefore it is possible that the image 
will extend beyond the scene grid's boundaries.
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Note that the Pan alignment rule equals the Center First Page 
rule in the layer properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The 
system looks at the resolution of the bitmap image, for 
example 4000 x 2000, then compares it to the scene's 
resolution, for example 1920 x 1080, and adjusts the scale 
factor in proportion. So, in this example, the bitmap would 
appear at 208% (4000/1920). If you import a bitmap that is 
960 x 540, it will be displayed at 50% (960/1920) of the size of 
the project resolution.

Note that the Project Resolution alignment rule is equal to 
the As Is rule in the layer properties.

6. In the Drawing Options section, set the following options if desired:

‣ Drawing Name: Name of the drawing to import.

‣ Hold Value: Type the number of frames that the drawing will be exposed.

‣ Scan and Advance: Lets you scan one drawing after another every time you click Scan.

‣ Flip Drawing: Mirrors the drawings horizontally and scans it this way.

7. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the 
view.
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8. Click Scan to scan your drawing.

9. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next 
letter to capture your next frame.

10. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until 
you have finished scanning all your drawings.

How to scan an image as a Toon Boom bitmap drawing

1. In the Import Options section, select the Import as Toon Boom Bitmap Drawing  option. 

2. In the Layer section, decide if the scanned or imported image will be placed on a new layer or 
existing layer. 

‣ Create Layer: Scans or imports the image into a new layer. Select one of the following 
options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For 
example, the filenames a-1.tga, a-2.tga and b-1.tga will create 
layers named "a" and "b", where "a" has two drawings and 
"b" has one. When creating a single layer from these three file-
names, all three drawings will be inserted in the new layers.

‣ Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from 
the Layer list. You must scan into the same layer type if you are using an existing layer.

‣ Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix 
bitmap images with vector drawings on the same layer, the bitmap image must be 
encapsulated in a symbol and vice versa. Symbols will also be automatically added to the 
Symbol folder in the Library view.

3. In the Alignment section, decide on the size and placement of your scanned image within the 
camera frame. Depending on the scene settings (the height and width, in pixels, that you chose for 
your project), an image that you scan may be scaled to the point where all its individual pixels 
become visible.

Make sure you are in the Camera view’s Render Mode when judging an imported image, otherwise it may 
appear blurry.

The following three Alignment Rules options are available:

Parameter Description

Vertical Fit
Enlarges or shrinks (but not distort) to your image height to match 
the full height of the scene frame (alignment grid).
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Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match 
the full width of the scene frame (alignment grid).

Actual Size

Scales the image in proportion to the scene's resolution. The system 
looks at the resolution of the bitmap image, for example 4000 x 
2000, then compares it to the scene's resolution, for example 1920 x 
1080, and adjusts the scale factor in proportion. So, in this example, 
the bitmap would appear at 208% (4000/1920). If you import a 
bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the 
size of the project resolution.

4. In the Drawing Options section, set the following options if desired:

‣ Drawing Name: Name of the drawing to import.

‣ Hold Value: Type the number of frames that the drawing will be exposed.
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‣ Scan and Advance: Lets you scan one drawing after another every time you click Scan.

‣ Flip Drawing: Mirrors the drawings horizontally and scans it this way.

5. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the 
view.

6. Click Scan to scan your drawing.

7. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next 
letter to capture your next frame.

8. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until 
you have finished scanning all your drawings.

How to scan an image and convert it to a Toon Boom vector drawing

1. In the Import Options section, select the Convert to Toon Boom Vector Drawing  option. You can 
choose to encapsulate the image in a symbol by selecting the Create Symbols for Imported Items 
option. 

2. In the Layer section, decide if the scanned or imported image will be placed on a new layer or 
existing layer. 

‣ Create Layer: Scans or imports the image into a new layer. Select one of the following 
options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For 
example, the filenames a-1.tga, a-2.tga and b-1.tga will create 
layers named "a" and "b", where "a" has two drawings and 
"b" has one. When creating a single layer from these three file-
names, all three drawings will be inserted in the new layers.

‣ Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from 
the Layer list. You must scan into the same layer type if you are using an existing layer.

‣ Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix 
bitmap images with vector drawings on the same layer, the bitmap image must be 
encapsulated in a symbol and vice versa. Symbols will also be automatically added to the 
Symbol folder in the Library view.

3. In the Vectorization section, decide whether you want to import your image in black and white or 
grey.
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Parameter Description

Black and White
Vectorizes drawings as a solid black line; creates a 100% vector-based 
drawing.

Grey
Vectorizes your image as a mix of vector contour and greyscale bitmap 
filling. Lines keep the texture from the scan, and the white of the paper 
becomes transparent.

4. In the Drawing Options section, set the following options if desired:

‣ Drawing Name: Name of the drawing to import.

‣ Hold Value: Type the number of frames that the drawing will be exposed.

‣ Scan and Advance: Lets you scan one drawing after another every time you click Scan.

‣ Flip Drawing: Mirrors the drawings horizontally and scans it this way.

5. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the 
view.

6. Click Scan to scan your drawing.

7. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next 
letter to capture your next frame.

8. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until 
you have finished scanning all your drawings.
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Importing AI and PDF Files 

You can import AI (Adobe Illustrator) and PDF files into Toon Boom Harmony to convert your files to 
the Toon Boom format (TVG) and create a colour palette based on the colour settings of the original 
file. 

When importing AI and PDF files:

• RGB is supported, CMYK is not.

• Gradients and textures are not supported.

• Only legacy versions of Adobe Illustrator are supported. Exported SWFs, including Actionscript 
2 and Actionscript 3, cannot be imported.

• When importing an Illustrator or PDF file in Toon Boom Harmony, by default the file will be 
imported as separate layers. The import will use the Illustrator file's top level groups as 
separate layer names. However, you can change this behaviour by deselecting the 
PDF/Illustrator Import as Separate Layers option, to import your file as a single layer .

How to import an AI or PDF file

1. In Library view, right-click on the Stage Library folder and select Right to Modify to unlock the 
library folder. Make sure the Lock icon disappears from the folder. If not, your library will remain 
locked and you will not be able to import files.

For more information, refer to the Library  chapter in the Cut-out Animation Guide.
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2. Do one of the following:

‣ In the top menu, select File > Import > SWF, Illustrator Files to Library. 

‣ Right-click on any unlocked folder and select Import Fi les.

The browser window opens.

3. Find and select your AI or PDF file in the Import Files dialog box and click Open.

The Rename dialog box opens.

4. Type in a name for the new template or keep the name of the original AI or PDF file. 

5. Click OK.

A new template folder is created in the Library view.

6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until 

the copy cursor  appears before releasing the folder.

The message window opens.

7. Click Yes to perform a colour recovery. Note that you can select the Do Not Ask Again For This 
Session option if you plan to import multiple AI or PDF files.
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The colour palette used to create the AI or PDF file is imported and a new palette is created under 
the imported file’s name.

To learn about the Support CMYK in PDF/Illustrator Import option, refer to the 
Preferences Guide.
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Importing Adobe Flash Files

If a project was started in Adobe Flash and it needs a more professional boost, such as camera 
movements or multiplaning, it can easily be imported into Harmony. The actual *.fla file is not 
supported, so you must export your project as a *.swf movie. 

How to import a Flash file

1. In Library view, right-click on the Stage Library folder and select Right to Modify to unlock the 
library folder. Make sure the Lock icon disappears from the folder. If not, your library will remain 
locked and you will not be able to import files.

For more information, refer to the Library  chapter in the Cut-out Animation Guide.

2. Do one of the following:

‣ In the top menu, select File > Import > SWF, Illustrator Files to Library. 

‣ Right-click on any unlocked folder and select Import Fi les.

The browser window opens.
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For more information, refer to the Library  chapter in the Cut-out Animation Guide.

3. Find and select your.swf file in the Import Files dialog box and click Open.

The Rename dialog box opens.

4. Type a name for the new template or keep the name of the original *.swf file. 

5. Click OK.

A new template folder is created in the Library view.

6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until 

the copy cursor  appears before releasing the folder.

7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before 
clicking the Yes button, you have the option of selecting the Do Not Ask Again For This Session 
option. This might be useful if you plan to import multiple *.swf movies.
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The colour palette used to create the AI or PDF file is imported and a new palette is created under 
the imported file’s name.

All the Flash layers are automatically attached to a parent peg called GlobalFlashPeg. DO NOT DELETE 
THIS PEG. To maintain the look of your movie, it is important that this peg is not deleted, nor its child 
layers detached.

The Adobe Flash file layers appear in the Timeline view. Symbols that were created in Flash become 
regular drawing layers, but can be reconverted into symbols in Harmony. Symbols within symbols 
or drawings within symbols collapse into their corresponding parent symbol.

Some layers in your SWF movie may be combined in a single layer as a result of optimization 
enhancements in your movie file. You can easily move these elements back onto separate layers—see 
Redistributing Elements below.

In addition, all drawing elements that are dynamically linked to the Toon Boom Harmony file are 
grouped together in one folder. In our example, this means that when you scroll through the 
Drawing Substitution preview in the Library view, the different hand, leg, tentacles, antennae, 
torso and facial positions are all organized together.

Redistributing Elements
In some instances, due to an optimization enhancement in the exported SWF file (CS4), some of the 
layers might be combined as a single layer. If so, you can quickly redistribute these elements onto 
individual layers again. 

How to distribute to layers

1. In the Tools toolbar, click the Select  tool.

2. In the Camera view, select the drawing that contains elements you want to redistribute onto 
individual layers.  To select the all the elements of the selected drawing layer, press Ctrl + A 
(Windows/Linux) or ⌘  + A (Mac OS X).

3. From the top menu, select Drawing > Distribute to Layers or click the Distribute to Layers  
button in the Select tool’s Tool Properties view.
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The number of drawing layers corresponding to the different grouped elements are created in the 
Timeline view.

‣ The selected elements in the original drawing layer are removed. Each element is 
distributed onto a new drawing layer.

4. Repeat the process for each drawing that contains elements to redistribute.
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Importing QuickTime Movies 

When creating an animation, it is not unusual to embed moving elements saved as videos within the 
animation. Toon Boom Harmony allows you to import QuickTime movies into your project. 

How to import a QuickTime movie

1. From the top menu, select File > Import > Movie.

2. Browse for the QuickTime movie to import and click Open.

The Import Drawings dialog box opens.

Do not browse for the movie file again. Leave the automatically generated field text as “many files 
selected”.
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3. Make your decisions for the Layer, Alignment and Transparency sections of this dialog box—see 
Importing a Bitmap Image Without Vectorization  on page 740.

4. Click OK.

The QuickTime video appears in the Timeline view as an image sequence. You can scroll through 
the film frame-by-frame just as you would scroll through your animation drawing-by-drawing.
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Custom Vectorization Parameters 

You can create your own vectorization settings with Harmony. 

The vectorization parameters you will create here can be saved, shared and also inserted into the 
VectOptions.conf file used by the Harmony Scan and Control Center modules when scanning or 
vectorizing a series of drawings.

You can use an interface to select and test the different options and you can also type in some 
advanced settings.

How to open the Vectorization Parameters dialog box

1. From the top menu, select File > Import > From Scanner.
You can also open it from any other import option that allows you to customize the vectorization 
parameters (i.e. from the scanner).

2. Select your file, decide on the layer options, and click Preview.

3. In the Vectorization section, click the New Preset  button.

The Vectorization Parameters dialog box opens.
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• Options Tab  below

• Help Tab on page 789

Options Tab 

The Options tab contains the main vectorization settings. More settings are available in the Help tab.

Parameter Description

Input

The input filters are applied to the bitmap image before it is 
vectorized.

One Pass: One threshold value is applied to both the Line and 
Colour Art. For drawings with distinct vector-style lines of 
mattes, you only need one pass.

Two Passes: Applies a different threshold value to each layer.

For greyscale drawings, you may want to perform the 
vectorization process twice to apply different threshold values 
to the Line and Colour Art layers.

Threshold: Determines which values in the scanned image are 
considered part of the Line or Colour Art layer and what will be 
eliminated from the vectorized drawing; 0% is white and 100% 
is black. The threshold is between these two values.

Expand Bitmap: Lets you enter a value to scale the bitmap to 
detect small variations in the line. Use this option if you scanned 
a greyscale image and want to preserve small variations in the 
texture to apply to the line art.

Jag Filter: Lets you enter a value to scale back the bitmap to 
remove some of the line’s roughness. This is useless when you 
have a drawing that appears quite rough; the Jag filter will 
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eliminate excess strokes in the final drawing.

Output

The output filters are applied during the vectorization process.

No Colour Art: Does not generate filling zones in the Colour 
Art layer.

No Texture: Does not generate texture in the Line Art in the 
final images. Select this option to create solid lines in the final 
line art.

Generate Matte in Underlay Layer: Creates an opaque zone 
behind your drawing’s lines to avoid seeing through the layers.

Colour as Texture: Converts colour values into a texture layer.

Optical Registration

The optical registration options are used to automatically align 
drawings based on the position of the peg holes on the 
animation paper. The peg holes must appear in the scanned 
drawings for the optical registration to work.

DPI: Lets you enter the dots-per-inch value of your image. You 
must enter the same value as the DPI used to scan the image.

Peg Side: Lets you select the position of the peg holes on your 
drawings. Identify whether they are on the top, bottom, left or 
right.

Strictness: Determines how exact the location of the peg holes 
must be for the software to recognize them. You have two 
values to choose from:

• Strict: The peg holes must be in a tightly defined area to 
be recognized.

• Loose: The peg holes can be recognized somewhere in a 
larger area. This is the recommended setting.

Field Chart: Lets you indicate the size of the animation paper; 
12 or 16.

Post Processing

The Post Processing filters are applied to the final vector 
images.

Remove Holes: Removes holes of a specified value that might 
make painting difficult.

Remove Dirt: Removes stray marks and dirt of a specified 
value. Try a value around 500.

Remove Hair: Removes small strokes that have no line art.

Remove Hair: Number of Passes: The number of times the 
drawing will be analyzed to identify hair marks.

Miscellaneous

Close Gaps: Closes gaps in the Colour Art so that you can 
paint it.

Smooth Passes for Line Art before Breaking Triangles: The 
number of times the smoothing operation runs before creating 
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the triangles that break lines in your drawing. If unnecessary 
triangles are appearing in your drawing, increase this value.

Smooth Passes for Line Art: The number of times the 
smoothing operation is performed after the triangles have 
been created. This further smooths the Line Art.

Preview

Show Strokes: Shows the strokes in the Vectorized Image 
panel.

Stroke Thickness: Shows the size of the strokes.

Help Tab

The Help tab contains the most advanced vectorization settings which you type in the Advanced 
Option fields at the bottom of the Options tab.

File IO Options 

-file <filename (including extension)> [ options ]

-infile <filename (including extension)>; same as -file

-outfile <filename>; alternate output file

-informat <format>; the input format. Used if reading from stdin

-debug; turn on debug mode

-noforce; don't force output if image is inconsistent

-version; print version information and quit

-output_version <version>; output files of this version. Valid versions can be: 0 or 604

-force_unamed_palette_for_texture; will generate a texture in TVG's internal palette

Registration Options 

-register <dpi side strictness>; perform optical registration.
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• Side can be one of left, right, top, bottom or l, r, t, b.

• Strictness can be either loose, strict or l, s.

-register_center_peg_holes; will use only round holes in 16 fields page

-rcph; short form of register_center_peg_holes

-registration_looseness_factor <factor>; registration looseness factor (default 2.000000)

-rlf; short form of registration_looseness_factor

-rdebug; output registration debug messages

-pegpitch <inch (default 8.000000)>; distance between peg bars

-threshr < (default 0.500000)>; threshold for optical registration; range 0.0 to 1.0

-rmargin <inch (default 1)>; region size where to look for peg bars 

-peg_distance_from_center <inch (default 5.25)>; peg distance from centre of the image 

-pdfc; short form of -peg_distance_from_center 

-out_peg_position <side (default same)>; wanted position of the peg on the drawing.

• Can be one of right, left, top, bottom (or r, l, t, b) or same.

• A rotation will be performed if it is different from the side passed to -register.

-output_peg_matrix; output the peg transformation matrix on standard output.

-scanner_calibrate; < (default 1.0000 1.0000) > x and y scale factors to be applied to scanner image.

Filtering Options 

-pixel <pixel_shape (default '4x3')>; Valid values: 4x3

-gap <worldUnits (default 10)>; close gaps up to this big

-pencil; generate line art only

-keep_dirt; don't filter out dirt

-thresh <threshold (default 0.2)>; range 0.0 to 1.0

-rmv_hairs <worldUnits (default 1)> <passes (default 1)> 

• remove hairs of size smaller than "size" in "passes" passes 

-rmv_holes <area (default 7)>; remove holes smaller than "area" 

-rmv_dirt <area (default 1)>; remove dirt smaller than "area" 

• try values between 100 and 500 for rmv_holes and rmv_dirt. The area is in world units squared

-rmv_triangles <worldUnits (default 30.000000)>; remove triangles at "pixels" 

• distance from each other. Use -no_break to remove all triangles

-no_texture; don't generate textured strokes

-color_as_texture; will vectorize the alpha channel and put the RGB colour in a textured colour

-noclosegap; disable all gap closing algorithms

-no_break; disable the breaking of line art

-jag_filter <pixels (default 0>; expand the pixels in the vectorization bitmap
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-expand_bitmap <pixels (default 0>; expand the pixels in the vectorization bitmap

-fit_errorc <error (default 1.000000>; fitting error for the colour art

-fit_errorl <error (default 1.000000>; fitting error for the line art

-smoothl <passes (default 1>; number of smooth passes for line art

-smoothc <passes (default 1>; number of smooth passes for colour art

-first_smooth <passes (default 0>; number of smooth passes for line art before breaking triangles

-first_smoothl <passes (default 0>; number of smooth passes for line art before breaking triangles

-first_smoothc <passes (default 0>; number of smooth passes for line art in colour art pass (needs -
2pass)

-2pass; specify two sets of parameters; one for line art "l", one for colour art "c"

(-thresh, -rmv_holes and -rmv_dirt will be overridden by -threshl, threshc, -rmv_holesl,

-rmv_holesc, -rmv_dirtl and -rmv_dirtc)

-threshl <threshold for line art (default 0.5)>; range 0.0 to 1.0

-threshc <threshold for color art (default 0.5)>; range 0.0 to 1.0

-jag_filterl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art

-jag_filterc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art

-expand_bitmapl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art

-expand_bitmapc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art

-rmv_holesl <area (default 7)>; remove line art holes smaller than "area" 

-rmv_holesc <area (default 7)>; remove colour art holes smaller than "area" 

-rmv_dirtl <area (default 1)>; remove line art dirt smaller than "area" 

-rmv_dirtc <area (default 1)>; remove colour art dirt smaller than "area" 

try values between 100 and 500 for rmv_holesl, rmv_holesc, rmv_dirtl and rmv_dirtc. The values are 
in world units squared 

-margins <inch (default 0.25)>; remove margin around bitmap 

-top_margin <inch (default 0.25)>; remove margin at top of bitmap 

-bottom_margin <inch (default 0.25)>; remove margin at bottom of bitmap 

-left_margin <inch (default 0.25)>; remove margin at left of bitmap 

-right_margin <inch (default 0.25)>; remove margin at right of bitmap 

-remove_peg_bars; remove the peg bar holes

-field_size <fields (default 12 or use value in scan file)>; set the drawing to this field size

-fs; short hand for -field_size

-peg_bar_size <inch (default 1)>; the size of the peg bar region

-noframe; do not put a frame around the colour art

-frame_fields <default -1.000000>; put a frame of the specified dimension around the colour art
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-downscale_input <default 1>; downscale the raw input by this integer factor

-downscale_texture <default 1>; downscale the output texture by this integer factor

-buildmatte; generate a matte on underlay for line test

-buildmatte_colourart; generate a matte on colour art for line test

Note: -buildmatte and -buildmatte_colourart are mutually exclusive

-copystrokes; copy original strokes when building matte.

Options for bitmap that has no registration information 

-pixel_margins <inch (default 0)>; remove margin around bitmap 

-top_pixel_margin <inch (default 0)>; remove margin at top of bitmap 

-bottom_pixel_margin <inch (default 0)>; remove margin at bottom of bitmap 

-left_pixel_margin <inch (default 0)>; remove margin at left of bitmap 

-right_pixel_margin <inch (default 0)>; remove margin at right of bitmap 

-dpi <(default -1)>; dpi information of input bitmap 

RGB Keying Options 

-rgb; generate separate zones for red, green and blue lines

-rgb_alpha <value (default 255)>; generate red, green and blue colour with alpha of this value

-no_red; ignore red colour in vectorization

-no_green; ignore green colour in vectorization

-no_blue; ignore blue colour in vectorization

-flatten; flatten the drawing after generating colours

-rmv_rgb_dirt <threshold area default 0.0>; remove red, green and blue regions smaller than area

-expand_bitmap_rgb <pixels (default 0>; expand the pixels in the vectorization bitmap for rgb

-threshrgb <value> <threshold for rgb vectorization default 0.200000>;

-threshsv <saturation threshold default 0.500000> <value threshold default 0.500000>; thresholds on 
saturation and value to consider a pixel to be grey

Colour Vectorization Options 

-color_vectorize; perform a colour vectorization

-file2 <colour art filename>; specify the colour art bitmap

-penstyle <center alpha (0.0-20.0)> <edge alpha (0.0-20.0)> <gamma (0-10)><centre pressure effect 
(0.0-1.0)> <edge pressure effect (0.0-1.0)><texture bitmap downscaling (0.2-20)> <texture bitmap 
file (valid filename or "" if no file)>; generate brush texture for the line art

-pressure_variation <strategy (0, 1 or 2)> <min pressure (0.0-1.0)> <max pressure (0.0-1.0)> <max 
variation (0.0-1.0)>; specify a pressure strategy for the centre line. 

-blur_radius <pixels (default 0)>; blur the penstyle texture generated
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-color_contour_smooth_passes <times (default 3)>; perform number of smooth passes on contour 
before computing texture

-ccsp <times (default 3)>; short for -color_contour_smooth_passes

-color_rmv_holesl <world units (default 0.000000)>; remove holes of this size when computing 
texture

-color_fill_holesl <world units (default 0.000000)>; fill holes of this size for colour line art

Bubble Usage (implemented only for colour vectorization's line art)

-create_bubbles; add bubbles into the LineArt. Implemented for colour vectorization only 

-bubble_gap <value (default 3)>; max number of colour art points between 2 bubbles

-bubble_length <value (default 10)>; max number of circles in a bubble

-min_radius <value (default 1.5000)>; min radius of a circle in a bubble relative to the line thickness 
(must be >= 1.0)

-max_radius <value (default 3.5000)>; max radius of a circle in a bubble relative to the line thickness 
(must be >= 1.0)

-uniform_gap; the space between bubbles is constant 

4 Colour Vectorization

-4colours [key:value] ... [key:value] ; The key value list can be empty. The list of keys is:

rgbdiff:value ; between [0.0-1.0] or [0-255]

dark:value    ; between [0.0-1.0] or [0-255]

grey:value    ; between [0.0-1.0] or [0-255]

white:value   ; between [0.0-1.0] or [0-255]

dirt:value    ; dirt area. 200 is a good value

rt:value      ; between [0.0-1.0] or [0-255]

gt:value      ; between [0.0-1.0] or [0-255]

bt:value      ; between [0.0-1.0] or [0-255]

There must be no space between the colon and the key/value. For example: -4colours 
rgbdiff:20 dark:20 grey:120 white:250 dirt:200 rt:240 gt:240 bt:240

The Vectorization Parameters dialog box lets you vectorize pencil drawings, along with any red, blue 
or green pencil marks you may have used to indicate highlights and shadows. The drawing will be 
vectorized into pure red, blue, green and black (RGB values), while creating colour art zones wherever 
lines connect. After painting in your tones and highlights, change your pure RGB colours to 
transparent (0 Alpha) in the Colour Picker window and watch the indicator colour zone lines 
disappear.
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Creating a Vectorization Style 
With Harmony, you have the possibility to create custom vectorization parameters that can be saved 
and reused.

You can vectorize drawings using one of the following methods:

• Black and White: All the lines become vector based and 100% black. The white areas become 
completely transparent.

• Greyscale: All the lines preserve their initial textured look in grey shades as a bitmap image 
contained inside a vector frame. The white areas become completely transparent.

• Four Colours: With the advanced parameters, you can isolate the red, green, blue, and black 
lines and turn them into 100% vector lines, preserving their original colours—see Custom 
Vectorization Parameters  on page 786.

How to create or modify the vectorization parameters

1. Set the different options available in the Vectorization Parameters dialog box.
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2. Click the Vectorize  button to update the Vectorized Image preview.

The vectorized image is just a preview. The actual vectorization happens when you click OK in the 
Import Images dialog box. There are many options to try in the Vectorization Options dialog box. 
These are applied during the vectorization process.

3. To set advanced parameters, read the information on the Help tab, then type in the Advanced 
Options field at the bottom of the Options tab.

4. To save your vectorization parameters to reuse them later, share them, or use them to set the 
Harmony Scan module vectorization style list, click  Save.

5. In the Browser window, name and save the file.

6. To save the current settings as your default settings, click Save As Default. To restore the default 
settings, click Restore Defaults.

7. To load a vectorization style, click Load and locate the existing *.vof file.

8. Click OK.

Setting the VectOptions.conf File
Toon Boom Harmony Server uses a file called VectOptions.conf to get the vectorization style 
when batch vectorizing a series of drawings. A series of default styles is available in this file, but you 
will certainly want to create your own to fit your production style.

This section deals with setting the VectOptions.conf file on:
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• Setting the VectOptions.conf File on Windows and Mac OS X below

• Setting the VectOptions.conf File on Linux on page 798

Setting the VectOptions.conf File on Windows and Mac OS X

How to set the VectOptions.conf file on Windows or Mac OS X

1. Open the vectOptions.conf file:

‣ Windows: Select Programs / All Programs > Harmony 11.1 > Tools > Configuration 
Editor.

‣ Mac OS X: Select Applications > Harmony 11.1 > Tools > Configuration Editor.

The Configuration Editor window opens.

2. In the bottom section of the window, select the VectOptions.conf tab.

3. Scroll down the VectOptions.conf file to see all the different options available for creating your 
custom vectorization style. These options are the same as in the Vectorization Parameters dialog 
box. It is recommended that you create your vectorization style using Harmony and the 
Vectorization Parameters window and copy the result parameters in this file—see Creating a 
Vectorization Style  on page 794

4. Scroll down toward the bottom of the file to see the default styles. You can modify them or add 
new ones to the list using the parameters you got using the Vectorization Parameters window. 
Notice that some of the lines have a “#” sign at the beginning to indicate that the line is a comment 
and will not appear in the style list. The lines that have no sign at the beginning appear in the style 
list.
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5. To create a new style, type the following below the existing styles: 

style_name:

This should be followed by the name of your new style. For example: style_name: Black 
Lines.

6. Under the style name line, type the following: 

options:

7. Copy and paste the information in your *.vof style when saving your settings in the Vectorization 
Parameters window.

‣ To open the *.vof file, use any plain text editor application.

8. In the Configuration Editor’s top menu, select File > Save.

9. If you have Toon Boom Harmony Scan on your computer, you can start the application and verify 
that the new style appears in the Vectorization Style list under Edit > Vectorization Style.  
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If you are using the batch processing method available with Toon Boom Harmony Server 
to scan and vectorize your drawings, the selected style must be available on all the 
machines included in the batch processing list.

Refer to the Control Center Guide to learn more about setting up and using batch 
processing.

Setting the VectOptions.conf File on Linux

These are the two methods used to edit the VectOptions.conf file on Linux. 

• Using the “vi” text editor

• Using the “gedit” text editor 

How to set the VectOptions.conf file on Linux using the “vi” text editor

1. Open a Terminal window:
Menu: Applications > System Tools > Terminal

2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_11.0/etc

3. Change your user to "root":

$ su

‣ If your user is part of the sudoers list, enter the following command and go to See "Open 
the 'VectOptions.conf using the  "vi" text editor:" on page 798: 

$ sudo vi VectOptions.conf

4. Enter the "root" password.

5. Open the 'VectOptions.conf using the  "vi" text editor:

$ vi VectOptions.conf

6. To start editing, press the [i] key on your keyboard to enter Insert mode.

7. Once you are done editing the file, press Esc to exit Insert mode.

8. To save the changes made to the file, type the following and press Enter/Return:

$ :w!
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9. To exit the "vi" editor and return to the Terminal, type the following and press Enter/Return:

$ :q

10. If you have Toon Boom Harmony Scan on your computer, you can start the application and verify 
that the new style appears in the Vectorization Style list under Edit > Vectorization Style.

If you are using the batch processing method available with Toon Boom Harmony Server 
to scan and vectorize your drawings, the selected style must be available on all the 
machines included in the batch processing list.

Refer to the Control Center Guide to learn more about setting up and using batch 
processing.

How to set the VectOptions.conf file on Linux using the “gedit” text editor

1. Open a Terminal window:
Menu: Applications> System Tools> Terminal

2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_11.0/etc

3. Change your user to "root":

$ su

‣ If your user is part of the sudoers list, enter the following command and go to See "Open 
the 'VectorOptions.conf using the  "gedit" text editor:" on page 799: 
$ sudo gedit VectOptions.conf

4. Enter the root password.

5. Open the 'VectorOptions.conf using the  "gedit" text editor:

$ gedit VectOptions.conf

6. Edit the parameters of the VectOptions.conf file like you would do in most text editor 
application.

7. Select File > Save.

8. Select File > Quit.
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9. If you have Harmony Scan on your computer, you can start the application and verify that the new 
style appears in the Vectorization Style list under Edit > Vectorization Style.

If you are using the batch processing method available with Toon Boom Harmony Server 
to scan and vectorize your drawings, the selected style must be available on all the 
machines included in the batch processing list.

Refer to the Control Center Guide to learn more about setting up and using batch 
processing.
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Chapter 2: Scene Setup

Setting up your scene can be compared to building a set for a television show. This is the point when 
you position each scene element such as the camera frame, the background elements and the 
characters.

This chapter contains the following topics:

• Importing the Scene Components  on the next page

• Setting the Camera Frame  on page 803

• Positioning the Scene Components  on page 807

• Cloning and Duplicating Layers  on page 831

• Creating a Multiplane on page 833

• Orthographic Camera on page 842
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Importing the Scene Components 

The first step in the scene setup task is gathering the scene’s different components and then 
importing them into your project. You might need to import some backgrounds, sound files or movie 
clips to complete your scene. You can refer to the following topics to learn how to bring those 
elements in.

• Importing Bitmap Images  on page 740

• Importing QuickTime Movies  on page 784

• Importing a Sound File on page 904
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Setting the Camera Frame 

The scene action occurs inside the camera frame, so it’s really important to set it up correctly.

The Camera layer is static which means that if you need to animate it, you must add a peg—see 
Animating the Camera on page 859 .

To set the camera frame, you need to add a camera layer to your scene, so you can edit the camera 
frame. If you have added more than one camera to the scene, you can switch the active camera by 
selecting Scene > Camera and then selecting a camera.

In the Timeline view, you can only see one camera at the time. If you add several cameras to your 
scene, you can use the Camera List to select the active one. You could use this feature if you are still 
working on your scene composition and have different camera framing to try out.

You can reposition your camera frame directly in the Camera view, using the Translate  and Rotate 
 tools.

Another way to set up your camera frame is to type the coordinates directly in the camera's Layer 
Properties dialog box. Doing this positions the camera precisely where you want it to be rather than 
gauging it visually—see Positioning an Element Using the Layer Properties  on page 822.

Once you set up your camera frame, you can always easily reset it to its original position. Use the 
Reset command to reset the value of the selected element to the initial value of the active tool. For 
example, if the Rotate  tool is active, the transformation angle will be reset to 0 and if the 
Transform  tool is active, then all parameters values will be reset.

You cannot add a camera inside a symbol.

How to add a camera layer in the Timeline view

1. Do one of the following:

‣ In the Timeline view, click the Add Layer  button and select Camera.

‣ From the top menu, select Insert > Camera.

A new camera layer is added to the scene and appears in the Timeline view.

How to select a camera from the Camera list (set the active camera)

1. From the top menu, select Scene > Camera > the desired camera.

If you only add one camera to your scene, you will only see Default Camera in your list.

How to reposition the camera frame directly in the Camera view

1. In the Tools toolbar, disable the Animate  mode.

2. Do one of the following: 
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‣ From the top menu, select Animation > Tools > Translate. 

‣ In the Advanced Animation toolbar, click the Translate  tool.

‣ Press Alt + 2.

3. In the Camera view, click on the camera frame to select it. You can also select the camera layer 
from the Timeline view.

The selected camera frame is highlighted in purple.

4. Drag the camera frame to a new position. 

5. To tilt the camera frame, do one of the following to select the Rotate tool:

‣ From the top menu, select Animation > Tools > Rotate.

‣ In the Advanced Animation toolbar, select the Rotate  tool.

‣ Pres Alt + 3.

6. In the Camera view, drag to rotate the camera frame until it reaches the desired rotation angle.
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How to set up the camera frame using the camera Layer Properties

‣ In the Timeline view, double-click on the Camera layer.

The camera Layer Properties dialog box opens.

Parameter Description

Enable/Disable Turns the camera layer on or off.

Change Track Colour

The Change Track Colour  button lets you change the colour of the 
exposed frames; this helps you to quickly locate a layer in the Timeline 
view. Double-click on the colour swatch to open the Select Colour win-
dow and choose a new colour. You can modify the layer for any type of 
layer, such as group, peg, drawing, and effects.

Name
Displays the current layer name. You can rename the layer by typing in a 
new layer name.
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Position

Displays the current position of the camera layer using X-axis 
(East/West), Y-axis (North/South) and Z-axis (Forward/Backward) 
coordinates. To reposition your camera frame, type in the new values 
corresponding to the desired position coordinates. You can also use 
the up and down arrows to set the value of each field—see Positioning 
an Element Using the Layer Properties  on page 822.

Angle
Displays the current rotation value. To set a new rotation position, type 
in a new angle value. You can also use the up and down arrows to set 
the new angle value.

Pivot

Displays the current position of the rotation pivot of the camera layer. 
The camera will perform a rotation taking the position of the pivot as its 
angle centre. By default, the pivot is set at the centre of the camera 
frame. To reposition the pivot point, type in new X and Y coordinates 
values in the appropriate field. You can also use the up and down 
arrows to set the position values.
In order to see the pivot's position you will need to have the Rotate tool 
selected.

Clipping Planes

You can change the near and far clipping planes of the 
camera. The near plane is the point on the camera cone 
where the camera is located. The far clipping plane is the far 
end of the camera cone. Nothing outside that range is visible. 
This is useful when dealing with 3D elements and 3D sets.  For 
example, the camera can be looking inside a 3D box or room 
and you might want the foreground wall to not obstruct the 
view of the interior. By default, the near clipping plane is set 
to 1 field and the far clipping plane is set to 1000 fields.

Override Scene FOV Enable the FOV field in which you can type in a new field-of-view value. 

FOV

Displays the current field-of-view default value. When 
enabled, you can type in a new zoom value for your camera 
frame. You can also use the up and down arrows to set the 
new zoom value.

Click on the Create Function button to animate the camera 
zoom value—see Animation Paths on page 843 to learn more 
about creating functions.

Set Default FOV Resets the custom zoom value to its default value. 

How to reset the camera position

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

2. In the Timeline or directly in the Camera view, select the camera layer.

3. From the top menu, select Animation > Reset or press Shift + R.

The camera automatically returns to its original position.
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Positioning the Scene Components 

Setting up the scene also involves positioning the different scene elements within the camera frame.

Here are the main features and topics you need to know about to position your elements:

• Animate Mode below

• Selecting a Layer  below

• Positioning an Element Using the Transform Tool  on page 812

• Positioning an Element Using the Advanced Animation Tools on page 819

• Flipping an Element on page 817

• Positioning an Element Using the Layer Properties  on page 822

• Auto Apply Option  on page 829

• Resetting a Transformation  on page 830

Animate Mode
When positioning elements, make sure the Animate Mode is turned off, or it will create a keyframe on 
your drawing layer. The animate mode is used to animate layers over time.

How to turn off the Animate mode

‣ In the Tools toolbar, click the Animate Mode  button.

‣ In the top menu, disable Animation > Animate.

Selecting a Layer 
There are different ways to select the layers you want to reposition in the Camera view.

You can select your elements directly in the Camera view using the Transform  tool. When using this 
tool, its properties and options appear in the Tool Properties view. Always make sure that the Peg 
Selection  Mode option in the Tool Properties view is disabled or it will limit the selection to pegs only.

You can change the display style of selected elements to a bounding box style. This removes the 
default overlay highlight and leaves only the bounding box around the selected element.
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When you have several layers in the Timeline view, you may find it hard to locate which one is selected. 
You can use the Centre on Selection feature to display the selected layer in the Timeline view.

How to select a layer in the Camera view

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

2. In the Transform Tool Properties view, make sure that the Peg Selection Mode  is deselected.

3. In the Camera view, select the element to be repositioned. You can select more than one element 
at a time.

The corresponding layers and columns are highlighted in the Timeline and Xsheet views.

How to set the bounding box selection style

1. Do one of the following:

‣ From the top menu, select View > Show > BBox Selection Style. 

‣ In the Camera View bottom toolbar, click the BBox Selection Style  button.

How to center on the selected layer in the Timeline view

1. In the Camera view, select a layer.

2. Click anywhere in the Timeline view to make it the currently active view.

3. Do one of the following:

‣ From the Timeline view menu, select View > Centre on Selection or press O. If your 
selected layer is in a group or is a child of one or more elements, continue pressing O to 
expand the layers in the Timeline until your selected layer becomes visible.

‣ In the Timeline View toolbar, click the Centre on Selection  button.

How to select from the Timeline or Xsheet view

‣ In the Timeline view, click the layer corresponding to the element you want to reposition. 

‣ In the Xsheet view, click the column header corresponding to the element you want to 
reposition.
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The selected element is highlighted in the Camera view.

How to select all elements within a group in the Timeline view

1. With a group collapsed or expanded, hold down Alt and click on the group in the Timeline view.

All elements contained within the group are selected.

Locking Layers in the Timeline View 
You can prevent correctly positioned layers from being selected by locking them in the Timeline view. 
This is useful for making a multiple selection inside the Camera view and leaving them visible. Once a 
layer has been locked, its locked state will be remembered the next time you open a saved project.

You can perform five types of locking actions on your layers:
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• The Lock  option lets you lock one or a multiple selection of layers. 

• The Unlock  button lets you unlock one or a multiple selection of locked layers.

• The Lock All  option lets you lock all the layers in the Timeline view. 

• The Unlock All  button lets you unlock all the layers in the Timeline view. 

• The Lock All Others  button lets you lock every layer except the selected ones.

How to lock a layer or a selection of layers

1. In the Timeline view, select one or more layers.

2. Do one of the following: 

‣ From the top menu, select Animation > Lock > Lock. 

‣ Click one of the selected layer’s Lock  icon. 

‣ Press Ctrl + Alt + L (Windows/Linux) or ⌘  + Alt + L (Mac OS X).

All selected layers are locked. 

 

How to unlock a locked layer or a selection of locked layers

1. In the Timeline view, select one or more locked layers.

2. Do one of the following: 

‣ From the top menu, select Animation > Lock > Unlock. 

‣ Click a selected layer’s Lock  icon. 

‣ Press Ctrl + Shift + K (Windows/Linux) or ⌘  + Shift + K (Mac OS X). 

All selected layers are unlocked.
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How to lock all layers

1. Do one of the following:

‣ From the top menu, select Animation > Lock > Lock All. 

‣ In the Timeline view, select all layers and click Lock  icon of a selected layer. 

‣ Press Ctrl + Shift + L (Windows/Linux) or ⌘  + Shift + L (Mac OS X).

All layers are locked.

How to unlock all layers

1. Do one of the following:

‣ From the top menu, select Animation > Lock > Unlock All. 

‣ Press Ctrl + Alt + Shift + L (Windows/Linux) or ⌘  + Alt + Shift + L (Mac OS X). 

All layers are unlocked.

How to lock all other layers

1. In the Timeline view, select the layers you do not want to lock.

2. Do one of the following: 

‣ From the top menu, select Animation > Lock > Lock All Others. 

‣ Press Ctrl + Alt + Shift + O (Windows/Linux) or ⌘  + Alt + Shift + O (Mac OS X). 

All layers are locked except the selected ones.
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Positioning an Element Using the Transform Tool 
Using the Transform tool, you can easily reposition, scale, rotate and even skew layers directly in the 
Camera view. 

When positioning a drawing layer using the Transform tool, always make sure the Peg Selection Mode 
 is deselected in the Tool Properties view. Otherwise, it will limit the selection to pegs in the 

Camera view.

Transformations, such as rotation, scale, skew and flip are made relative to the pivot point position. 
You can temporarily reposition the pivot point for each transformation using the Transform tool. Note 
that the pivot is only moved temporarily. When animating the position, the interpolation is calculated 
from the permanent pivot position—see Positioning an Element Using the Advanced Animation Tools 
on page 819.

How to temporarily reposition the pivot point

1. In the Tools toolbar, select the Transform  tool.

2. In the Tool Properties view, make sure the Peg Selection Mode  is disabled.

3. In the Camera view, select your element.

The pivot point appears in the Camera view.

4. Click on the pivot point and drag it to a new position.
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This will be the new position of the pivot point for the current transformation. It will remain in this 
position as long as you do not deselect the drawing. Using the Transform tool to reposition your 
pivot will temporarily override the existing pivot point position until you complete the current 
transformation. Then it returns automatically to its original position.

When you translate the pivot point using the Transform tool, the permanent pivot will appear as a 
ghost so you know where it is and also from where the animation will be interpolated when you 
create motion paths. The animation is always interpolated from the original pivot and not the 
temporary pivot.

How to pan a layer using the Transform tool

1. In the Tools toolbar, disable the Animate  mode.

2. In the Tools toolbar, select the Transform  tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

4. In the Camera view, select a drawing layer and drag the selection to a new area. You can select 
multiple layers to reposition them at the same time. Press Shift and select the different layers.

How to rotate a layer using the Transform tool

1. In the Tools toolbar, disable the Animate  mode.

2. In the Tools toolbar, select the Transform  tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

4. In the Camera view, select a drawing layer.

5. Place  the pointer outside of a corner of the bounding box and drag to rotate.
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You can display a rotation handle on the bounding box when transforming a layer. In the 
Preferences dialog box, select the Camera tab and then select the Use Rotation Lever 
with Transformation Tools option. This preference is off by default.

How to scale a layer using the Transform tool

1. In the Tools toolbar, disable the Animate  mode.

2. In the Tools toolbar, select the Transform  tool or press Shift + T.

3. In the Transform Tool Properties view, make sure the Peg Selection Mode  is deselected.

4. In the Camera view, select a drawing layer and pull or push on the size, top, or corner control 
point. Hold down Shift to lock the selection's aspect ratio. 

How to skew a layer using the Transform tool

1. In the Tools toolbar, disable the Animate  mode.

2. In the Tools toolbar, select the Transform  tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

4. In the Camera view, select a drawing layer.

5. Place  the cursor between two controls points and drag sideways or up and down. 
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Transform Tool Properties

Icon Tool

Lasso and Marquee below

Peg Selection Mode on the next page

Snap Options on the next page

Hide Manipulator Controls on the next page

Works on Single Drawing on the next page

Flip Horizontal and Flip Vertical on the next page

Rotate 90 Degrees CW and CCW on page 817

Offset X and Y  on page 817

Width and Height  on page 817

 Angle  on page 817

Lasso and Marquee

The Lasso and Marquee options let you choose the type of selection the current tool will perform. 
The default selection mode is Marquee.

• Lasso  lets you draw a custom selection box around zones.

• Marquee  makes a rectangle selection box.

Hold down the Alt key to switch to the opposite mode of your selection.

How to invert a selection

1. Do one of the following:

‣ From the top menu, select Edit > Invert Selection. 

‣ From the Camera or Drawing menu, select Edit > Invert Selection.
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‣ Press Ctrl + Shift + I (Windows/Linux) or ⌘  + Shift + I (Mac OS X). 

Peg Selection Mode

In the Camera view, the Peg Selection Mode limits the selection to peg layers instead of drawing 
layers. This mode is useful when you have created a character rig using peg layers for each drawing.  
That way, you do not accidentally select the drawing layer when you want to animate on the peg.

When disabled, the Transform  tool selects the drawing layers.

Snap Options

When transforming or repositioning a layer using the Transform tool, you can enable different snap 
options to help you. 

• Snap and Align: Snaps the selected layer to any existing line, while automatically 
displaying temporary rulers that guide you and that you can also snap your object to.

• Snap to Grid: Snaps your selection according to the currently enabled grid.

Hide Manipulator Controls

The Hide Manipulator Controls  button lets you hide the bounding box and manipulator controls 
from the Camera view when an element is selected.

Flip Horizontal and Flip Vertical

The Flip Horizontal  and Flip Vertical  buttons let you flip the selected element horizontally or 
vertically. You can also select Animation > Flip > Flip Horizontal and Flip Vertical from the top 
menu or press 4 or 5.

Works on Single Drawing

By default, when you draw a selection box in the Camera view, the Select tool will select only the 
drawing strokes of the current drawing. If you prefer the Select tool to select all the strokes on all 
layers, deselect the Works on Single Drawing  button.
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Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW  and Rotate 90 Degrees CCW  operations rotate the current 
selection 90 degrees clockwise or counter-clockwise.

‣ From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 
Degrees CCW.

‣ Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or ⌘  + 7 and  ⌘  + 9 (Mac OS X).

Width and Height 

The Width  and Height  fields allow you to enter specific values for accurately resizing a 
selected layer.

• Width: Enter a width value in this field to resize the width of your selection.

• Height: Enter a height value in this field to resize the height of your selection.

• Lock: Click the Lock icon to lock or unlock the ratio between the width and height values. 

Offset X and Y 

Use the Offset X and Offset Y  fields to enter specific values to reposition the selected layer 
accurately.

• X: Enter an offset value in this field to reposition the selected layer along the X-axis.

• Y: Enter an offset value in this field to reposition the selected layer along the Y-axis.

Angle 

The Angle  field lets you enter specific values to rotate the selected layer accurately. A positive 
value rotates the layer counterclockwise and a negative value rotates the layer clockwise.

• Angle: Enter a degree value in this field to rotate the selected layer.

Flipping an Element

There are two different options you can use when you want to flip your element.
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The Flip Horizontal and Flip Vertical options let you flip a drawing layer along the Camera view’s 
horizontal and vertical axis.

Once your drawing layer is rotated, the original horizontal and vertical axes change. The Flip Scale X 
and Flip Scale Y will perform a flip on your drawing layer following its original axis.

• The Flip Horizontal command flips the layer following the Camera view X-axis.

• The Flip Scale X command uses the original X-axis of the layer and flips the element following it.

How to flip a layer

1. In the Tools toolbar, disable the Animate  mode.

2. In the Tools toolbar, select the Transform  tool or press Shift + T.

3. In the Transform Tool Properties view, make sure the Peg Selection Mode  is deselected.

4. In the Camera view, use the Transform  tool to select a drawing layer to flip.

5. Do one of the following:

‣ From the top menu, select Animation > Flip > Flip Horizontal or Flip Vertical. 

‣ In the Tool Properties view, click the Flip Horizontal  and the Flip Vertical  buttons.

‣ Press 4 or 5. 
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How to flip an element following its original axis

1. In the Tools toolbar, disable the Animate  mode.

2. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

3. In the Camera view, use the Transform  tool to select an element that has already been 
transformed.

4. From the top menu, select Animation > Flip > Flip Scale X or Flip Scale Y.

Positioning an Element Using the Advanced Animation Tools
You can also use the advanced animation tools to position your layers. The difference between these 
tools and the Transform tool is that they modify only one parameter of the position such as the 
rotation or the scale as the Transform tool adjusts all parameters together.

Transformations, such as rotation, scale, skew and flip, are made relative to the pivot point position. 
You can reposition this pivot point anywhere using the advanced animation tools.
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How to permanently reposition the pivot point

1. In the Advanced Animation toolbar, select the Translate , Rotate , Scale , or Skew  
tool.

2. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) to select your element. 

The pivot point appears in the Camera view.

3. Drag the pivot point to a new position.

All transformations, including existing ones will be recalculated from this new pivot postion.

How to pan a layer using the Translate tool

1. In the Tools toolbar, disable the Animate  mode.

2. Do one of the following: 

‣ From the top menu, select Animation > Tools > Translate. 

‣ In the Advanced Animation toolbar, click the Translate  tool.

‣ Press Alt + 2.

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) on the element to select 
it and drag the selection to a new area. 

You can select multiple layers to reposition them at the same time. Press Ctrl + Shift + click 
(Windows/Linux) or ⌘  + Shift + click (Mac OS X) on each element to select them.

How to rotate a layer using the Rotate tool

1. In the Tools toolbar, disable the Animate 

820



Toon Boom Harmony 11.1 Draw Guide (Network)

 mode.

2. Do one of the following: 

‣ From the top menu, select Animation > Tools > Rotate. 

‣ In the Advanced Animation toolbar, click the Rotate  tool.

‣ Press the Alt + 3. 

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) on the element to select 
it and rotate the layer. 

You can select multiple layers to rotate them at the same time. Press Ctrl + Shift + click 
(Windows/Linux) or ⌘  + Shift + click (Mac OS X) on each element to select them. 

How to scale a layer using the Scale tool

1. In the Tools toolbar, disable the Animate  mode.

2. Do one of the following: 

‣ From the top menu, select Animation > Tools > Scale. 

‣ In the Advanced Animation toolbar, click the Scale  tool.

‣ Press Alt + 4. 

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) on the element to select 
it and pull or push either on the side, top or corner control point. Hold down Shift to lock the 
selection’s ratio when using the corner control points. 

You can select multiple layers to scale them at the same time. Press Ctrl + Shift + click 
(Windows/Linux) or ⌘  + Shift + click (Mac OS X) on each element to select them.

How to scale a layer using the Skew tool

1. In the Tools toolbar, disable the Animate  mode.

2. Do one of the following: 

‣ Select Animation > Tools > Skew. 
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‣ In the Advanced Animation toolbar, click the Skew  tool.

‣ Press Alt + 5.

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) on the element to select 
it and drag a side of the bounding box up, down or sideways. 

You can select multiple layers to skew them at the same time. Press Ctrl + Shift + click 
(Windows/Linux) or ⌘  + Shift + click (Mac OS X) on each element to select them. 

Positioning an Element Using the Layer Properties 
Each layer has a series of parameters that can be modified to adjust the object's position. These 
parameters can be access in the Layer Properties view. In the Layer Properties view, you can type in a 
value rather than moving the object in the Camera view. These values can also be animated over time.

You can also access a layer's parameters in the Timeline view. Click on the Expand Parameters arrow 
and the Show Data View button.
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It is important to understand the coordinate values in Harmony. Harmony's core is based on the 
origins of animation. In traditional animation, a scene's size and camera motion are calculated in fields. 
A field has a 4:3 ratio and measures 0.5 inch in width. A specific grid has been created for this purpose. 
It is known as a field chart. Harmony uses this unit of measurement as its coordinate system.

A field chart uses cardinal directions. The X axis is the east-west direction, the Y axis is the north-south 
direction and the Z axis is the forward-backward direction.

In Harmony, a drawing's pivot is located at the centre of the field chart, regardless where your 
drawing has been drawn on the page. Your drawing is the entire sheet of paper, not only the drawing 
strokes you have drawn on the page. This allows scanned drawings, imported images and paperless 
drawings to be properly registered together.

If you want to move your drawing in the upper left region of the camera frame, you would type in 
something like the following:

• X Axis: -4 or 4W (4 West)

• Y Axis: 5 or 5N (5 North)

If you want to move your drawing in the lower right region of the camera frame, you would type in 
something like the following:

• X Axis: 3 or 3E (3 East)

• Y Axis: -2 or 2S (2 South)

How to position an element using its Layer Properties dialog box

1. Do one of the following:
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‣ In the Timeline view, right-click on the drawing layer and select Layer Properties  

‣ Single-click or double-click on the layer.

‣ Press Shift + E. 

The Layer Properties dialog box opens.

The Enable 3D check box displays the 3D parameters in the Layer Properties—see Enabling the 3D 
Option.

2. In the Position section, type in the desired values:

‣ X - Left/right or east/west

‣ Y - Up/down or north/south

‣ Z - Forward/backward

As you type in the new values, the element’s position is updated in the Camera view. 

 

‣ In the (x) Axis field, type in a new East/West coordinate corresponding to the desired 
position.

‣ In the (y) Axis field, type in a new North/South coordinate corresponding to the desired 
position.
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‣ In the (z) Axis field, type in a new Forward/Backward coordinate corresponding to the 
desired position—see Creating a Multiplane on page 833.

‣ The Function  buttons are used to create function curves to add keyframes when 
animating.

3. In the Scale section, select one of the following: 

‣ Locked: Resizes the element while keeping its ratio.

(xy) Axis: Type in the horizontal and vertical scales value.

‣ Separate: Resizes the element with independent X and Y scales. This allows you to squash 
and stretch.

(x) Axis: Type in the horizontal scale value.

(y) Axis: Type in the vertical scale value.

‣ The Function  buttons are used to create function curves to add keyframes when 
animating.

4. In the Angle Z field, type in a degree value for the rotation angle. Note that you can enter values 
greater than 360 and -360 degrees. If you enter 720, the object will rotate twice.

5. In the Skew field, type in a degree value between -90 to 90 for the skew angle.

6. In the Pivot section, type in the desired coordinate value to reposition the transformation pivot. 
This will change the permanent position of the pivot.

‣ In the (x) Axis field, type in a new East/West coordinate corresponding to the desired 
position.

‣ In the (y) Axis field, type in a new North/South coordinate corresponding to the desired 
position.

Layer Properties Options

A drawing layer properties dialog box is composed of four tabs.
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• Transformation Tab

• Drawing Tab Image Tab below

Drawing Tab Image Tab

Parameter Description

Element Columns

Full Name: Select which element to connect to the module 
from the drop-down list of elements that already exist in your 
scene.

Drawing Path: Displays the full path to the current drawing.

Timing Columns

Name: Path to the file that you want to link to.

Timing Column: Link to the column that contains the desired 
timing.

Extension: When linking to a background file, enter its 
filename extension.

Field Chart: If you are importing traditional animation, select 
the size of the paper on which the animation was drawn.

Art Layers

Line Art/Colour Art Enabled: Lets you set layers as line art, 
colour art, or both.

Line Art Type: Designates the layer as a Line Art layer.

Colour Art Type:  Designates the layer as a Colour Art layer.

Antialiasing Quality: Smoothness setting applied to an art 
layer. Choose from Low (no antialiasing), Medium Low, 
Medium and High (extensive antialiasing). The higher the 
quality of the chosen setting, the greater the amount of 
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antialiasing that is applied. Higher quality images require 
more time to render and more memory from your system.

Bitmap File Options

When an image is created with an external software and that 
image has some transparency, there are several formats the 
software can use when writing the RBG channels. The 
purpose of the four import options for the transparency is for 
the user to tell Harmony how to interpret the RGB channels of 
the imported image. The correct option has to match the 
ouput format of the software that was used to create the 
image in the first place. For instance, if the you used Adobe 
Photoshop and exported an image as Straight, then it should 
be imported in Harmony as Straight in order to get the 
correct result.

Note that if the image has no alpha channel, or if it does have 
an alpha channel and all the pixels are 100% opaque, itdoes 
not make any difference which option is selected.

Colour: Controls the production of colour information from 
bitmap images. If this module reads 3 or 4-channel bitmaps, 
this selection determines whether the colour should be read 
or ignored. If this module reads 1-channel bitmaps, this 
selection determines whether the channel should be read as 
colour. When this option is selected with 1-channel images, 
the resulting image will be a greyscale image.

Transparency: Controls the production of alpha information 
from bitmap images. If this module reads a 1 or 3-channel 
image, this option will create a matte from the colour values 
in the image. If the module reads a 4-channel image and this 
option is not selected, the alpha information in the image will 
be ignored.

Transparency Type

• Premultiplied with Black: Semi-transparent pixels in the 
original image are blended with black.

• Premultiplied with White: Semi-transparent pixels in the 
original image are blended with white.

• Straight: Semi-transparent pixels in the original image are 
left as is (unmatted).

• Clamp Colour to Alpha: Semi-transparent pixels in the 
original image are blended with black. On import, each of 
the RGB channels is clamped so that a color value never 
exceed the alpha value for a given pixel. When the RGB 
values are multiplied with the alpha value, that is to say, if 
you have a pixel of value R=247, G=188, B=29 and the 
alpha is 50% or the image has a 50% transparency, then 
the actual RGB values output would be half of the amounts 
listed above. 
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Alignment Rule: The alignment rule selections are intended 
to deal with drawings that were created on paper of a 
different size or orientation from the default alignment rule 
(set up in the Scene Setting dialog box) or imported bitmap 
images. The drawings are then scaled to match Toon Boom 
Harmony alignment rectangle. Note that alignment rules are 
not based on the camera frame, but on the scene frame. 
Refer to the Fundamentals Guide to learn more about scene 
alignment and scene settings.

• Left: The default alignment for drawings; aligns the 
drawings on the left side of the scene’s alignment 
rectangle. Toon Boom Harmony scales the drawings to 
match their height to the alignment rectangle of the scene.

• Right: Aligns the drawings on the right side of the 
alignment rectangle. Toon Boom Harmony scales the 
drawings to match their height to the height of the 
alignment rectangle of the scene.

• Top: Aligns the drawings on the top of the alignment 
rectangle. Toon Boom Harmony scales the drawings to 
match their widths to the width of the alignment rectangle 
of the scene.

• Bottom: Aligns the drawings on the bottom of the 
alignment rectangle. Toon Boom Harmony scales the 
drawings to match their widths to the width of the 
alignment rectangle of the scene.

• Centre Fit: Centres the drawings.

• Centre Fill: Centres the drawings and then scales them so 
that the width or height fills the available space.

• Centre LR: Aligns the drawings in the left-right centre of 
the alignment rectangle. Toon Boom Harmony scales the 
drawings to match their height to the height of the 
alignment rectangle of the scene.

• Centre TB: Aligns the drawings in the top-bottom centre 
of the alignment rectangle. Toon Boom Harmony scales 
the drawings to match their widths to the width of the 
alignment rectangle of the scene.

• Stretch: Scales the drawings so that they fit within the 
alignment rectangle of the scene. This is particularly useful 
for images that you will manipulate with a Quadmap 
module. If the drawings in the Quadmap module do not 
have the same aspect ratio as the alignment rectangle of 
the scene (from the Scene Settings dialog box), the 
handles on the quadmap will not appear on the corners of 
the image, making it difficult to manipulate the quadmap. 
In this case, you would set the drawing layer of the 
quadmap images to Stretch so that the handles appear on 
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• Left: The default 
alignment for 
drawings; aligns 
the drawings on 
the left side of the 
scene’s alignment 
rectangle. Toon 
Boom Harmony 
scales the drawings 
to match their 
height to the 
alignment 
rectangle of the 
scene.

• Right: Aligns the 
drawings on the 
right side of the 
alignment 
rectangle. Toon 
Boom Harmony 
scales the drawings 
to match their 
height to the height 
of the alignment 
rectangle of the 
scene.

• Top: Aligns the 
drawings on the 
top of the 
alignment 
rectangle. Toon 
Boom Harmony 
scales the drawings 
to match their 
widths to the width 
of the alignment 
rectangle of the 
scene.

• Bottom: Aligns the 
drawings on the 
bottom of the 
alignment 
rectangle. Toon 
Boom Harmony 
scales the drawings 
to match their 
widths to the width 
of the alignment 
rectangle of the 
scene.

• Centre Fit: Centres 
the drawings.

• Centre Fill: 
Centres the 
drawings and then 
scales them so that 
the width or height 
fills the available 
space.

• Centre LR: Aligns 
the drawings in the 
left-right centre of 
the alignment 
rectangle. Toon 
Boom Harmony 
scales the drawings 
to match their 
height to the height 
of the alignment 
rectangle of the 
scene.

• Centre TB: Aligns 
the drawings in the 
top-bottom centre 
of the alignment 
rectangle. Toon 
Boom Harmony 
scales the drawings 
to match their 
widths to the width 
of the alignment 
rectangle of the 
scene.

• Stretch: Scales the 
drawings so that 
they fit within the 
alignment 
rectangle of the 
scene. This is 
particularly useful 
for images that you 
will manipulate with 
a Quadmap 
module. If the 
drawings in the 
Quadmap module 
do not have the 
same aspect ratio 
as the alignment 
rectangle of the 
scene (from the 
Scene Settings 
dialog box), the 
handles on the 
quadmap will not 
appear on the 
corners of the 
image, making it 
difficult to 
manipulate the 
quadmap. In this 
case, you would set 
the drawing layer 
of the quadmap 
images to Stretch 
so that the handles 
appear on the 
corner of the 
image. This can 
have the effect of 
distorting the 
images, but this is 
not an issue with 
images that will be 
distorted through 
the Quadmap 
module anyway.

• As Is: Leaves the 
drawings aligned 
as they are. 

• Centre First Page: 
Aligns the centre of 
the first part of a 
standard pan cel 
with the centre of 
the field chart.

Opacity
Lets you quickly change the transparency of the selected element. Opa-
city settings here will be reflected in both OpenGL preview, and full 
render.

Auto Apply Option 
When you modify a parameter in a property dialog box, Toon Boom Harmony calculates the 
modification automatically and displays the result immediately in the Camera view. If you do not want 
to immediately display every change made to your scene, you can turn off this default setting by 
deselecting the Auto Apply option. This is useful when you are working on a very heavy scene.

When you disable this function, Apply and OK buttons at added at the bottom of the Layer Properties 
view and any other parameter dialog box. 

• Click Apply to apply the current change.

• Click OK to apply the current change and close the Layer Properties.

If you want to always work in Auto-Apply mode, you can deselect the Auto-Apply option in the Preferences 
dialog box. Then, each time you start Harmony, the Auto-Apply  mode will be off. You must click the Apply 
button to see any modifications.

How to enable or disable the Auto Apply option

‣ From the top menu, select Edit > Auto-Apply.

How to enable or disable the Auto-Apply preference

1. In the top menu, select Edit > Preferences (Windows/Linux) or
Stage > Preferences (Mac OS X).

The Preferences dialog box opens.

2. In the Preferences dialog box, select the General tab.

3. In the Options section, select or deselect the Auto Apply option.
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Resetting a Transformation 
You can easily reset layers to their original position. With the Reset command, you can return the value 
of a selected element to the initial value of the active tool. For example, if the Rotate  tool is active, 
the transformation angle will be reset to 0 and if the Transform  tool is active, the all 
transformation parameters values will be reset.

When selecting elements in the Camera view using the Transform tool, always make sure that the Peg 
Selection Mode  is deselected in the Tool Properties view. Otherwise, it will limit the selection to 
pegs only.

How to completely reset the layers' position

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

2. In the Timeline or Camera view, select one or more drawing layers to reset. 

3. Do one of the following: 

‣ From the top menu, select Animation > Reset or press R.

‣ Right-click the selected layers and select Clear All Values.

‣ In the Timeline view menu, select Layers > Clear All Values.

The selected layers return to their original position.

How to reset a layer's parameter

1. In the Advanced Tools toolbar, select the Translate , Rotate , Scale , or Skew  tool 
based on the parameter to reset.

2. In the Timeline or Camera view, select the layer to reset. 

3. From the top menu, select Animation > Reset or press R.

The selected parameter returns to its original position.

How to reset all transformation values except Z

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

2. In the Timeline or Camera view, select one or more drawing layers to reset. 

3. From the top menu, select Animation > Reset All Except Z.

All values except for those set on the Z axis are reset.
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Cloning and Duplicating Layers 

At times, you will need to create a large group of characters such as a crowd, school of fish or flock of 
birds. You can do this by cloning or duplicating a layer during production. The difference between 
cloning and duplicating is that a clone uses the same drawings for all layers. A duplicate is simply an 
independent copy.

If you want to maintain the ability to modify drawings and propagate the changes through all layers, 
then you should clone drawings. If you simply want to copy your drawings and be able to modify your 
drawings without affecting the original layer, use the duplicate option.

Cloning Layers
A cloned layer is linked to the original element directory. If a drawing is modified in the original or 
cloned layer, both will be updated. However, clone layers can have linked or different timings.

When cloning layers, you have the ability to clone the drawings and the corresponding columns 
(timing) or only the drawings. If you choose to clone the drawings and timing, your module will be 
linked to the same element folder as well as the same drawing and function columns. Therefore, if you 
change the drawing exposure or keyframe on one layer, all cloned layers will be updated.

You may want to create a large group of characters reusing the same animation, but want to slightly 
offset the timing so they are not dancing or walking quite on the same beat. For example, if you create 
a walk-cycle for a soldier and want to use it for an entire army, you may want to have 50 layers with 50 
different drawing exposures to produce a slight difference in the timing. If you copy your layers and 
their drawings 50 times over, it will create a heavier scene. It is better to clone the 50 layers with only 
their drawings without linking to the same function and exposure columns. 

How to clone a layer

1. In the Timeline, Xsheet view, select a layer to clone. You can select multiple layers.

 

2. Do one of the following:

‣ From the Xsheet view menu, select Columns > Clone Selected Columns: Drawings Only 
or Columns > Clone Selected Columns: Drawings and Timing.

‣ From the top menu, select Edit > Clone to clone the columns' drawings only.
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‣ From the Timeline view menu, select Layers > Clone Selected Layers: Drawings Only or 
Layers > Clone Selected Layers: Drawings and Timing.

The cloned layer appears. 

 

Duplicating Layers
You can duplicate a layer to have a copy of the drawings that are independent from the original ones, 
as well as an independent timing (exposure). When you need the drawings to be modified 
independently, you will want to duplicate the layer instead of cloning it.

How to duplicate a layer

1. In the Timeline, Xsheet view, select a layer to clone. You can select multiple layers.

 

2. Do one of the following:

‣ In the Timeline view menu, select Layers > Duplicate Selected Layers.

‣ From the Xsheet view menu, select Columns > Duplicate Selected Layers.

‣ From the top menu, select Edit > Duplicate.

The duplicated layer appears.
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Creating a Multiplane

One of the most exciting features in Harmony is the multiplane or Z-depth. In the multiplane, you can 
create backgrounds in several layers, spread them on the Z-axis to add depth, and then move the 
camera through this environment to create an impressive perspective illusion.

Setting Up the Multiplane
To construct a multiplane, you must imagine what a real environment is like. Take a look at your 
background picture and imagine a camera moving through the space. Notice that objects in the 
picture move at different speeds depending on where they are in relation to the camera lens.

Building a multiplane requires an understanding of the scene's background, as well as the positioning 
of the elements on different layers.
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For example, in the background illustrated above, the main objects to be separated are:

1. Fern

2. Front tower

3. Second tower

4. Moon

5. Stars

6. Sky

Although the bottom of the tower is hidden behind the plant and the ladder, each of the multiplane 
layers should be a complete drawing. This is because hidden portions may show up during a camera 
move later on in the scene.

Distributing Elements on the Z-axis
Now is the time to distribute the layers that comprise your multiplane along the Z-axis. You can 
position layers on the Z-axis using the Side and Top view. 

Positioning your element closer to the camera makes them appear bigger. You can also move element 
towards the camera or away from the camera while keeping the same size aspect ratio in the Camera 
view.

It is a good idea to keep a Camera view open to see what your scene looks like while positioning 
elements in the Top or Side view—see Top View on page 837, Side View on page 839 and Perspective 
View on page 840.
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Positioning Elements in the Top and Side Views

Before distributing layers along the Z-axis using the Top and Side views, deselect the No Z Dragging 
option by selecting Animation > No Z Dragging. This option is disabled by default.

How to position an element in the Top and Side views

1. To maintain the visual scale in the Camera view as you move your element, in the Advanced 
Animation toolbar, select the Maintain Size  tool or press Alt + 6.

2. In the Side view, select one of the layers in the thumbnails section of the Top or Side view. You can 
also select a layer from the Timeline view.

The selected layer is highlighted in the Top, Side and Camera views.

3. Drag the layer to the correct depth position in the camera cone. Your element aspect will remain 
the same in the Camera view.

4. For your element to scale up or down in relation to their distance to the camera, do one of the 
following:
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‣ In the Tools toolbar, select the Transform  tool. Make sure the Peg Selection Mode  
option is disabled in the Tool Properties view.

‣ In the Advanced Animation toolbar, select the Translate  tool and select a layer from the 
thumbnails section of the Top or Side view.

‣ Select a layer from the Timeline view.

The selected layer is highlighted in the camera cone.

5. In the Top  view, drag the element sideways to position it horizontally . Hold Shift while dragging 
the element to make sure it only moves along the X-axis.

6. In the Side view, drag the selected element up or down to position it vertically. Hold Shift while 
dragging the element to make sure it only moves along the Y-axis.

Cumulative Z Value
You can see the cumulative Z value information in the Coordinates and Control Points view. When you 
select a drawing cell that includes a keyframe, it will display the cumulative Z value.

When a layer is parented to other layers that are moved forward or backward on the Z-axis, the 
currently selected layer's position Z value may not be accurate since its parent will also have an offset 
on the Z-axis. The Cumulative Z value is a compilation of all the Z-axis offsets to give the real Z-axis 
offset value related to the (0,0) centre.
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Top View
The Top view is used mainly for multiplane scenes and to position elements in 3D Space. It allows you 
to see the scene’s stage  from above. This lets the camera cone and the spacing between the elements 
to be seen.
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1. A thumbnail of each drawing layer in the scene. The order of the thumbnail images is based on each 
element’s FB position in the scene space. You can see a representation of the FB position of each 
layer in the camera cone.

2. The camera cone represents the camera’s position and field-of-view (FOV). 

3. The axis reference arrows let you maintain your orientation when navigating in the Perspective view.

4. There are two view option buttons displayed in the lower-left corner of the view.

‣ Show/Hide Camera: Shows or hides the camera frame in the Perspective view. 

‣ Reset View: Resets the pan, rotation and zoom of the Perspective view.

5. This field displays the current zoom level in the Perspective view. You can use the Zoom menu to 
select a zoom level from 2.5% to 6400%. You can also select Fit To View to automatically use a zoom 
level that lets you see all of the scene layers and information in the Perspective view at once.

6. Displays the currently selected layer and drawing name.

7. Displays the currently selected tool.

8. Displays the currently selected frame of your animation.
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9. Displays the currently selected colour in the palette.

Side View
The Side view is used mainly for multiplane scenes and to position elements in 3D Space. It allows you 
to see a scene’s stage  from  the side. This lets the camera cone and spacing between the elements to 
be seen.

1. A thumbnail of each drawing layer in the scene. The order of the thumbnail images is based on each 
element’s FB position in the scene space. You can see a representation of the FB position of each 
layer in the camera cone.

2. The camera cone represents the camera’s position and field-of-view (FOV). 

3. The axis reference arrows let you maintain your orientation when navigating in the Perspective view.

4. There are two view option buttons displayed in the lower-left corner of the view.

‣ Show/Hide Camera: Shows or hides the camera frame in the Perspective view. 

‣ Reset View: Resets the pan, rotation and zoom of the Perspective view.

5. This field displays the current zoom level in the Perspective view. You can use the Zoom menu to 
select a zoom level from 2.5% to 6400%. You can also select Fit To View to automatically use a zoom 
level that lets you see all of the scene layers and information in the Perspective view at once.
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6. Displays the currently selected layer and drawing name.

7. Displays the currently selected tool.

8. Displays the currently selected frame of your animation.

9. Displays the currently selected colour in the palette.

Perspective View
The Perspective view is used during scene setup. It allows you to see a multiplane scene’s orientation. 
The Perspective view is similar to a 3D display, as it lets you rotate the scene through all possible 
angles to understand the spacing between the elements. You can also position and rotate your layers 
and the camera inside the 3D display to achieve some 3D setup and camera moves.

1. The red circle rotates the view on its X axis.

2. The green circle rotates the view on its Y axis.

3. The blue circle rotates the view on its Z axis.
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4. This is a perspective grid reference.

5. The axis reference arrows let you maintain your orientation when navigating in the Perspective view.

6. There are three view option buttons displayed in the lower-left corner of the view.

‣ Show/Hide Camera: Shows or hides camera frame in the Perspective view. 

‣ Reset View: Resets the pan, rotation, and zoom of the Perspective view.

‣ Reset Rotation: Resets the rotation of the Perspective view.

7. This field displays the current zoom level in the Perspective view. You can use the Zoom level drop-
down menu to select a specific zoom level from the list. Zoom levels from 2.5% to 6400% are 
available; you can also select Fit To View to automatically use a zoom level that lets you see all your 
scene layers and information in the Perspective view at once.

8. This field displays the currently selected layer and drawing name.

9. This field displays the currently selected tool.

10. This field displays the currently selected frame of your animation.

11. This field displays the currently selected colour in the palette.

How to rotate a scene in the Perspective view

1. In the Tools toolbar, select the Rotate View   tool.

‣ Click in the view, and drag the cursor around to rotate the view.

‣ Press and hold Ctrl + Alt (Windows/Linux) or ⌘  + Alt (Mac OS X) and click and drag to 
rotate the view one axis at a time. 
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Orthographic Camera

The orthographic camera is specific to the gaming pipeline. It changes the camera type from 
perspective to orthographic. It becomes a camera without vanishing points. This means there is no 
more perspective in the Camera view. Objects, when moved on the Z-axis, will not change in size or 
scale.

Refer to the Gaming Guide to learn more about orthographic cameras and exporting animation for 
interactive games.

The orthographic camera can be set in the Scene Settings dialog box. In order  to create scenes with 
the orthographic camera, by default, you need to create a new custom scene resolution. Refer to the 
Fundamentals Guide to learn about custom resolutions.

How to set an orthographic camera

1. From the top menu, select Scene > Scene Settings.

2. Select the Resolution tab. 

3. In the Projection section, select Orthographic option.
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Chapter 3: Animation Paths

With Harmony, you can animate layers using computer-generated trajectories, create multiplane 
camera moves and camera shakes, adjust the easing, shape your paths with control points and much 
more.

This chapter contains the following topics:

• Animating a Layer on the next page

• Differences between Pegs and Animated Layers on page 846

• Layer Parameters on page 850

• Adding and Deleting Keyframes on page 853

• Motion and Stop-motion Keyframes on page 855

• Animating the Camera on page 859

• Modifying a Path in the Camera, Top and Side Views on page 862

• Modifying a Path in the Timeline View on page 867

• Modifying a Path in the Function View on page 870

• Modifying a Path in the Xsheet View on page 877

• Function Curves on page 879

• Copying and Pasting a Motion on page 886

• Adjusting the Ease on page 896

843



Chapter 3: Animation Paths     Animating a Layer

Animating a Layer

Before animating the position of drawing layers, you need to create motion paths which are 
trajectories on which you can attach drawing objects. Using keyframes, you can then record key 
positions along the trajectory. 

Harmony’s wide range of features let you produce simple and advanced motions and trajectories. By 
creating a simple motion, you will learn the basics animating a layer.

The Animate mode lets you keyframe drawing layers to create computer-generated animation. When 
the Animate mode is enabled, you can animate a layer's position and disable it to reposition a layer for 
the entire scene. In this mode, keyframes are created on selected layers at the current frame. 
Depending on what transformations were performed (rotation, translation, skew, etc.), the new 
keyframes are added on the corresponding parameters (function curves).

How to turn the Animate mode on or off

1. In the Tools toolbar, click the Animate  button or select Animation > Animate.

How to animate a layer

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

2. In the Tool Properties view, make sure that the Peg Selection Mode  is deselected.

3. In the Tools toolbar, enable the Animate  mode. This will create keyframes at the current frame 
when moving objects.

4. In the Timeline view, go to the first frame.

5. In the Camera view, select the element to animate and move it to its first position.

A keyframe is created on the first frame of the Timeline view.

6. In the Timeline view, go to the frame on which you want to set the second position.
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7. In the Camera view, move the element to its second position.

A second keyframe is created on the Timeline view.

8. Play back  your animation.

To see your motion animations in the Top, Side or Perspective views while you play back, you must 
turn on the Playback option. From the top menu, select Play > Enable Playback > Top View or 
Side View or Perspective View.
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Differences between Pegs and Animated Layers

There are two ways to create motion paths: animated drawing layers and pegs. They each have 
different purposes. 

You can create a motion path directly on layers (animated layers). 

You can control and define a trajectory using several different parameters, including:

• X, Y and Z positions (3D Path or Separate Positions)

• Angle (rotation)

• Skew

• X and Y Scales

• Euler Angle or Quaternion Angle (when 3D option is enabled)

• Z Scale (when 3D option is enabled)

Each parameter has its own function curve where you can add keyframes and control the easing. 

If you are not familiar with graphs and function curves, Harmony has a series of easy-to-use tools for 
visually controlling trajectories in the Camera and Timeline view.
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By default, a drawing layer can be animated using the same parameters as a peg, but you can disable 
this feature. Being able to switch your drawing layers so they can no longer be animated without a peg 
has certain advantages. In cut-out animation, it is easier to separate drawing exposure and keyframes 
to change the timing easier and rearrange keyframe position in the Timeline view. This also works for 
backward compatibility when bringing in templates created in older versions of the software, so as 
not to lose their offset keyframes or drawing substitution keyframes.

If you do not want to animate a drawing layer, you have the option of disabling its animation 
parameter. To do so, simply select the layer and in the Layer Properties view, deselect the Animate 
Using Animation Tools option on the Controls tab.

If your layer was already animated and you deselect the Animate Using Animation Tools option, your 
keyframes will be dimmed, enabling you  to easily  identify them as ones that cannot be modified. Select 
the Animate Using Animation Tools option in order  to modify them again.

A Peg layer is a trajectory that contains no drawings on which you can hook your drawings.

Pegs have been used for a long time in the traditional animation process, mainly for registration 
purposes. Peg holes at the bottom or top of the animation paper are used to keep all the sheets even 
and at the same registration.

There are three peg holes in regular animation paper. The centre peg hole is round while the left and 
right ones are oval shaped. The oval peg holes are located on each side of the page, four inches away 
from the centre peg hole.
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To keep the drawings together, the animator uses a peg bar. This peg bar has three pins that 
correspond to the shape and location of the peg holes. Peg bars are normally found at the bottom 
and top of animation discs.

Before digital compositing, the peg bars were also used to move layers on the camera stand to create 
pans and camera moves. They were the equivalent of digital trajectories. Harmony makes use of these 
concepts to create animation and camera motion. 

A peg is composed of many customizable parameters. These parameters are:

• X, Y and Z positions (3D Path or Separate Positions)

• Angle (rotation)

• Skew

• X and Y Scales

• Euler Angle or Quaternion Angle (when 3D option is enabled)

• Z Scale (when 3D option is enabled)

You can control a peg’s trajectory the same way as the animated drawing layer.

A peg layer is mainly used to control a series of drawing layers, such as clouds, a school of fish or a 
flock of birds. You can attach them to a peg layer and make them follow a trajectory as a single unit. 
This makes trajectory modifications much easier and faster. When building a puppet, most of the time 
you will add a master peg to control your puppet as one object.

In the Tool Properties view, the Peg Selection Mode  lets you automatically select the peg layers in 
the Camera view instead of the drawing layers. If you animate with pegs instead of animating the 
drawing layers directly, enable the Peg Selection Mode to avoid having to select in the Timeline view 
or use the Select Parent Skipping Effects command.

How to add a peg in the Timeline view

1. In the Timeline view, select the layer on which you want to attach a peg.

2. Do one of the following: 
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‣ From the Timeline View layers toolbar, click the Add Peg  button.

‣ From the top menu, select Insert > Peg.

‣ Right-click on the layer and select Add > Peg.

The layer that was originally selected becomes a child of the new parent Peg layer. The new Peg 
layer automatically takes the name of its child layer, with the addition of the suffix -P.

3. If you intend to add multiple pegs or if the layer name that was added to the peg does not 
accurately represent the content of the Peg layer, you can rename it. Clicking the layer name and 
type in a new name. Or double-click the layer and type a new name into the dialog box.

4. If you did not create your peg layer directly above the layer you intended on parenting it to, then 
drag the layer you want to attach to the peg and drop it directly below the Peg layer. The 
indentation of the layer below the Peg layer indicates whether it was correctly attached or not.

How to enable the Peg Selection Mode

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

2. In the Tool Properties view, click the Peg Selection Mode  button.

3. In the Camera view, select an element parented to a peg.
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Layer Parameters

A layer is composed of many customizable parameters, such as the X, Y and Z positions, angle 
(rotation), skew and scales. Each parameter has its own function which is a mathematical formula 
expressing the relationship between position values. You can view each function on a graph as a 
simple curve, such as the one below.

There are six options available for setting up function parameters:

‣ Locked Positions (3D Path)

‣ Separate Positions

‣ Locked Scales

‣ Separate Scales

‣ Quaternion (3D Rotation)

‣ Euler Angles (3D Rotation)

You must select 3D Path, Separate Positions, Separate Scale, or Locked Scale before starting the 
animation. When you lock or unlock parameters, this does not convert the functions from one to the 
other, but creates new ones.
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In a 3D Path, the X, Y and Z curves are locked together and controlled by a single velocity function. 
When you add a keyframe, it is added on all three trajectories at once, as is the velocity. This is very 
useful for long, smooth trajectories.

When the Separate Positions option is used, the X, Y and Z curves are independent and have velocity 
controls directly on their function curve. This is useful when you want to set keyframes on one of the 
curves without affecting the others.

When using the Scale parameter, you can use a single function curve controlling both the vertical and 
horizontal scale, or two separate scales. When using a single function curve, the values are the same 
for the X (horizontal) and Y (vertical) axes for uniform size changes without distortion. However, if you 
separate the scale functions, you can squash, stretch and skew your elements.

How to display the Layer parameters in the Timeline view

1. Do one of the following:

‣ In the Timeline’s left side, click a layer's Expand  button or press Alt + F. 

‣ In the Timeline view menu, select View > Show Functions.
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How to set the layer parameters

1. In the Timeline view, double-click on the layer on which you want to set the parameter. You can also 
see the parameters in the Layer Properties view when you select the layer in the Timeline view.

The Layer Properties editor opens.

2. Select the Transformation tab.

3. In the Position section, select the 3D Path or Separate option.

4. In the Scale section, select the Locked or Separate option.

5. Click Close.
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Adding and Deleting Keyframes

There are several different ways you can create keyframes. You can add a coordinate keyframe, 
position keyframe or a keyframe along with your drawing duplication.

You can create a keyframe without a drawing. This adds new coordinate points but the drawing in the 
layer stays the same. At the same time, you may also want to duplicate your drawing if you need to 
modify it and do not want to modify the original.

You can also add a Position keyframe instead of a regular keyframe. When you add a Position 
keyframe, keyframes will only be added on the X, Y and Z parameters of the selected layer. Keyframes 
are not added on the Angle, Scale and Skew parameters.

If you select a keyframe in the Timeline view and press the Delete key, you will also delete the drawing 
exposure. To only delete the keyframe, you must use the Delete Keyframe command.

How to create keyframes

1. In the Timeline view, select the cell on which you want to add a keyframe.

2. Add a keyframe  by doing one of the following:

‣ From the top menu, select Insert > Keyframe.

‣ Right-click  on the selection and select Insert Keyframe.

‣ Press F6.

‣ In the Timeline View toolbar, click the Add Keyframe  button.

If the Animate mode is enabled in the Camera view,  a keyframe is automatically created on the 
current frame.

How to create a keyframe and duplicate the drawing at the same time

1. In the Timeline view, select the cell containing the drawing where you want to add a keyframe and 
duplicate.

2. To add a keyframe and duplicate, do one of the following:

‣ From the top menu, select Insert > Keyframe and Duplicate Drawing.

‣ Right-click on the selection and select Insert Keyframe and Duplicate Drawing.

‣ Press F6.
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How to add a Position keyframe

1. In the Timeline view, select the cell where you want to add a position keyframe.

2. In the top menu, select Insert > Position Keyframe.

How to delete a keyframe

1. Do one of the following:

‣ Use the Transform  tool to select a keyframe to delete from the trajectory in the Camera 
view and press Delete.

‣ In the Timeline view, select a keyframe, right-click and select Delete Keyframes, or press 
F7. 

‣ In the Timeline view, select a keyframe and in the Timeline view menu, select Motion > 
Delete Keyframes.

‣ In the Timeline view, select a keyframe, and from the top menu, select Animation > Delete 
Keyframe.
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Motion and Stop-motion Keyframes

Interpolation is the computer-generated motion between two keyframes. Some animators and 
compositors like to create their own in-betweens, while others like to have the computer do it. 
Harmony has stop-motion (no interpolation) and motion keyframes (computer-generated 
interpolation).

A stop-motion keyframe means there is no computer-generated motion between two keyframes. The 
segment is constant or flat. The drawing remains still until the playback reaches the next keyframe, 
then the drawing pops to its new location.

A motion keyframe means that there is computer-generated motion between two keyframes. The 
segment has a variation over time. The drawing progressively moves towards the next keyframe 
location as the animation is played back.

You can switch a keyframe from stop-motion to motion at any time in the Timeline view and Function 
Editor.

In the Preferences dialog box, you can set a different colour for your stop-motion keyframes in order 
to create a greater visual difference in the Timeline view.
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How to switch between motion and stop-motion in the Timeline view

1. On the right side of the Timeline, select one or more keyframes to modify.

2. Switch between motion and stop-motion by doing one of the following:

‣ Right-click on the selected keyframes and select Set Motion Keyframes or Set Stop-
Motion Keyframes.

‣ Press Ctrl + K (Windows/Linux) or ⌘  + K (Mac OS X) for motion keyframes and Ctrl + L 
(Windows/Linux) or ⌘  + L (Mac OS X) for stop-motion keyframes.

‣ In the Timeline View toolbar, click the Motion Keyframe  or Stop-Motion Keyframe  
button.

How to switch between motion and stop-motion keyframes in the Function Editor

1. Open the Function Editor.

2. In the Timeline view, double-click on the layer that contains the keyframes you want to convert.

The Layer Properties dialog box opens.

3. Do one of the following:

‣ In the Transformation tab, click the Function Editor  button.

‣ In the Timeline view, click the Expand Function  button and double-click on the function 
to edit. Or press Alt + F.
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4. On the function curve, select one or more keyframes to modify.

5. Select or deselect the Stop-motion Keyframe  button to set a stop-motion or motion keyframe.

How to set the stop-motion keyframe colour

1. Open the Preferences dialog box by pressing Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

2. Select the General tab. 

3. In the Colours section, click Edit Colours.

4. In the Colours dialog box, select the Xsheet and Timeline tab.

5. In the Timeline section, click the  Stop Motion Keyframe swatch.

6. In the Select Colour window, select a new colour.

7. Click OK to close the Select Colour window.

8. Click OK to close the Colours dialog box.

9. Click OK to  close the Preferences dialog box.
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Constant Z
When using a 3D path, the X, Y and Z functions are working together using the same keyframes. This 
allows for the velocity to control the curve and create a smooth trajectory. Even if a function does not 
have any variation on its curve (for example, all keyframes are at zero), the velocity might add a slight 
motion to ensure a smooth trajectory. This can cause elements that are very close to each other on the 
Z-axis to pop in front of one another. This is why in cut-out animation it is recommended to use 
separate position settings. But if you work with 3D path, you can enable the Constant Z feature to 
avoid this from happening.

The Constant Z feature is used when creating motion keyframes. The Z function will use stop-motion 
keyframes and will not be interpolated, which can be very useful for cut-out animation. The Constant Z 
feature only works with 3D paths.

You can also enable the Constant Z option directly in the Function Editor for specific functions.

How to enable the Constant Z option

1. In the Timeline view, expand the layer on which you want to set the Constant Z feature. Note that 
the 3D Path option must be enabled for that particular layer.

2. Double-click on one of the position functions to open the Function editor.

3. In the Function Editor window, select the Constant Z  button.
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Animating the Camera

-Harmony has a camera that can move along the X, Y, and Z axes. Having the camera move on the Z-
axis offers the possibility to create truck in and truck out, as well as multiplane camera moves. The 
default camera position is centred and backed up to 12 fields.

It is important to understand the coordinate values in Harmony. Harmony's core is based on the 
origins of animation. In traditional animation, a scene's size and camera motion are calculated in fields. 
A field has a 4:3 ratio and measures 0.5 inch in width. A specific grid has been created for this purpose. 
It is known as a field chart. Harmony uses this unit of measurement as its coordinate system.

A field chart uses cardinal directions. The X axis is the east-west direction, the Y axis is the north-south 
direction and the Z axis is the forward-backward direction.

The camera is treated the same way as any other element. The same tools and selection modes are 
used to offset or animate it, but the camera is a static object. To animate the camera, you need to 
connect it to a peg layer. A peg is a trajectory layer.
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While making camera moves, you can use the Top, Side, and Camera views.

How to open the Top and Side views

‣ From the top menu, select Windows > Top or Side.

‣ From any existing window already open in your project, click the Add View  button at 
the top-right corner and select Top or Side.

How to add a camera and parent it to a peg

1. If you do not already have a camera layer, do one of the following: 

‣ From the top menu, select Insert > Camera.

‣ From the Timeline view layers toolbar, click the Add Layers  button and select Camera.

A new camera layer is added to the scene and appears in the Timeline view.

2. In the Timeline view, select the Camera layer.

3. From the Timeline View Layer toolbar, click the Add Peg  button.

A Peg layer appears directly above the Camera layer. The Camera layer is automatically attached 
to it. 

The Peg layer automatically takes the name of the camera and adds the suffix -P to indicate that it 
is a Peg layer, for example Camera-P.

If the new Peg layer did not appear directly above the camera, you may have clicked elsewhere in 
the scene, which deactivated the layer on which you want to add the Peg layer. 

‣ Select the Camera layer and drag and drop it under the new Peg layer. Or delete the 
misplaced Peg layer, select the Camera layer and click the Add Peg  button again.

How to animate the camera

1. In the Tools toolbar, enable the Animate  mode.

2. In the Tools toolbar, select the Transform  tool or press Shift + T.

3. On the right side of the Timeline view, on the Camera Peg layer, select  the frame at which you want 
the camera move to start.
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4. Do one of the following:

‣ Right-click and select Insert Keyframe.

‣ In the Timeline View toolbar, click the Add Keyframe  button.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera 
position as in this keyframe.

5. In the Top, Side or Camera view, select the camera (the large V-shaped cone) and move it to the 
desired position. In the Camera view, the camera is represented by a thin frame. You need to click 
directly on one of the edges.

6. On the Timeline view, click on another cell a bit further down in time to indicate where the camera 
move will end.

7. Select the camera in the Camera, Top or Side view and move it to the desired position. 

A second keyframe appears and a line is created between the two frames to indicate that the 
subsequent motion between the frames will be calculated and rendered by the program.

8. Play back  your animation.
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Modifying a Path in the Camera, Top and Side Views

Camera moves and motion paths can become quite advanced, especially with moves through 3D 
space. Harmony provides tools to view your camera’s path and make adjustments to it from both a 
2D and 3D perspective.

You can display the trajectory of a motion path when you select an object in the Timeline or Camera 
view.

If you want to see the trajectory, enable the Show Control Points on Selected Layers option in the 
Preferences dialog box.

A motion path is easy to manipulate. One important concept to understand is that a trajectory 
contains both keyframes and control points. Both can be used to shape a path; each have their own 
significance and behaviour, however only keyframes appear in the Timeline view. 

• Keyframe: Has a transformation value and a position in space at a given frame. Keyframes are 
locked in time.

• Control Point: Has a position but no fixed frame or timing. It is mainly used to deform a 
trajectory. There are no velocity handles available on a control point. The velocity segments are 
set between keyframes only, making curves and trajectories much smoother. Control points can 
only be added on a 3D path.

When you select a control point on a path, you can switch between a rounded or square corner by 
using the Linear/Curve command. 

How to view the layer’s trajectory using the Control command

1. Verify that the Camera view (click its tab) is selected and that the layer whose trajectory you want 
to display is selected in the Timeline view.

2. From the top menu, select View > Show > Control or press Shift + F11.
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If nothing appears in the Camera view, you may not have animated or selected the layer.

How to add a control point on a trajectory

1. In the Timeline or Camera view, select the peg or layer on which you want to add a control point.

2. If the selected element’s trajectory is not displayed, select View > Show > Control from the top 
menu or press Shift + F11.

The Trajectory appears in the Camera, Top, Side and Perspective views.

3. Add control points on a 3D path trajectory by placing the cursor where you want to add the point 
and press P once. If you hold the key down, control points will be added continuously until you 
release the key.
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How to display control points on selected layers

1. In the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X) 
or press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

The Preferences dialog box opens.

2. Select the Camera tab.

3. In the Control Points section, select the Show Control Points on Selected Layers option.

4. Click OK.

If the trajectory is hidden when you select an element, you may want to display it using the Control 
command.

How to adjust the Continuity, Tension and Bias parameters

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

2. In the Timeline view, select the layer that contains the parameters you want to adjust.

3. From the top menu, select View > Show > Control  or press Shift + F11 to display the trajectory.

4. In the Camera view, select a control point or keyframe.

5. In the Coordinates and Control Points view, adjust the Continuity, Tension and Bias parameters.
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How to adjust the control point preferences

1. From the top menu, select Edit > Preferences (Windows) or Stage > Preferences (Mac OS X).

The Preferences dialog box opens.

2. Select the Camera tab and adjust the parameters in the Control Points section.

How to toggle between a linear and curved corner

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

2. In the Camera view, select the point to convert.

3. From the top menu, select Animation > Linear/Curve.
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Offsetting a Trajectory
By offsetting a trajectory, you reposition the visual trajectory without offsetting or modifying your 
animation. By default, the trajectory is located at 0,0,0 fields. If your elements were drawn in a 
different location than the centre in the drawing area, it will look like the trajectory is not aligned with 
your drawing. Also, if you have several elements attached to one trajectory, you might want your 
trajectory to be a different location to represent the group's motion better.

How to offset a trajectory

1. In the Animation Tools toolbar, select the Spline Offset  tool or press Alt + 8.

2. In the Camera Top, Side or Timeline view, select the layer whose trajectory you want to offset.

3. From the top menu, select View > Show > Control to display the trajectory. If you do not display 
the trajectory, any transformation done using the Spline Offset tool will be ignored.

4. In the Camera view, move the trajectory to the proper position. You can move it on the X and Y 
axes, but also on the Z-axis using the Top and Side views.
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Modifying a Path in the Timeline View

When you select a peg or drawing layer in the Camera view and move it around, Harmony will 
automatically create keyframes on the corresponding function curves. If you want to modify these 
curves, you can do it through the peg or drawing layer parameters in the Timeline view.

Harmony lets you also flip between the selected layer's keyframes in the Timeline view.

 How to create the function curve in the Timeline view

1. In the Timeline view, double-click on a drawing or peg layer.

The Layer Properties window opens.

2. Identify the section for the type of function you want to create.

3. Click the drop-down arrow at the end of the corresponding row and select Create Bézier or 
Create Ease.

 How to add a keyframe in the Timeline view

1. On the right side of the Timeline view, select a cell on the layer’s function that you want to animate.

2. Do one of the following:

‣ Right-click the selected cell and select Insert Keyframe.

‣ Press F6.

‣ In the Timeline view menu, select Motion > Insert Keyframe.

‣ In the Timeline View toolbar, click the Add Keyframe  button.

How to delete a keyframe in the Timeline view

1. On the right side of the Timeline, select a keyframe to delete. You can [Shift]+click several 
keyframes to select a group before deleting the keyframes. 

2. Do one of the following:

867



Chapter 3: Animation Paths     Modifying a Path in the Timeline View

‣ Right-click on the selected keyframe and select Delete Keyframes.

‣ Press F7.

‣ In the Timeline view menu, select Motion > Delete Keyframes.

‣ In the Timeline View toolbar, click on the Delete Keyframes  button.

If you select a keyframe or group of keyframes and press Delete, the corresponding drawings on that cell 
are also deleted.

How to change the keyframe values in the Timeline view

1. In the Timeline view, open the drawing or layer’s parameters by clicking the Expand  button or 
press Alt + F. 

2. At the top of the Timeline view, click the Show/Hide Data View  button.

3. Select the parameter for which you want to create a function curve: Path, Velocity, Scale; x or y, 
Angle, or Skew.

4. Pass the cursor over the blue number value of the parameter layer being modified.

‣ Wait until the cursor changes to a white hand with a two-way arrow and then drag the hand 
slightly to the left or right to decrease or increase the value.
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OR

‣ Double-click on the blue number and enter a value into the field that appears.

How to flip through poses

1. In the Camera or Timeline view, select the layer that contains the keyframes you want to flip 
through.

 

2. From the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe or 
press semicolon (;) and single quote (').
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Modifying a Path in the Function View

If you are used to graphs and function curves, you can use the Function view to define trajectories.

The Function view graph displays the motion over the first and last keyframes set in the scene, as well 
as any keyframes created between. If the scene is 60 frames, but the character's motion ends at frame 
40, then the editor will only display up to frame 40.

The Function view lets you edit function curves and parameters. It is a visual graph for adding, 
removing, and editing keyframes, as well as adjusting the velocity. The Function view allows you to 
display multiple functions in the background as a reference.

How to display functions in the Function view

1. Open the Function view.

The Function view is blank until you select the layer containing the functions you want to display.

2. To display a function in the Function view, click on the layer containing the functions to adjust in the 
Timeline view.

3. To select the functions you want to edit, select them in the Functions List section.
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Parameter Description

Function List

When selecting a layer in the Timeline view, all the 
corresponding functions are displayed. Until a keyframe is 
added on the function in the Timeline view, it will not be 
displayed in the Function view. Select all the functions you want 
to see and edit; hide the ones you do not.

 

The Display toolbar allows you to modify how the editing area 
is displayed. You can hide the grid, disable the synchronization 
with the current frame, reset the zoom level and normalize the 
function display by stacking them one over the other to 
compare them regardless of their value range.

Current Frame Displays the current scene frame.

Selected Keyframe Value Displays the value of the selected keyframe.

Display Advanced Parameter 
Values

Displays the Projection, Bias, Tension and Continuity 
parameters to adjust the curve around the selected keyframe.

Keyframe, Velocity and Inter-
polation Options

This toolbar lets you add and delete keyframes, adjust the 
velocity curve, adjust the segments to motion or stop-motion 
keyframes and set the velocity to create steps instead of a 
constant progression.

Function Type
This toolbar lets you click on the different function types to 
enable or disable all the listed functions of that type.

Value Scale
displays the value range for the displayed editing area. It can be ref-
erenced to know the value of a keyframe.

Selected Keyframe
The selected keyframe is displayed in red. When selected, the 
keyframe values are displayed in the corresponding fields.

Bezier Handles

The Bezier handles let you adjust the ease in and ease out of 
each keyframe. The more the handle is pulled out horizontally, 
the slower the animation will be. The more the handle is pulled 
out vertically, the faster the animation will be.

Function Curve
The thin line going from keyframe to keyframe is the actual 
curve. The section of a curve located between two keyframes is 
called a segment.

Frame Scale
The Frame Scale displays the frame range for the displayed 
editing area. It can be referenced to know the current frame of 
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a keyframe.

How to edit a function in the Function view

1. In the graph of the Function editor, select a white keyframe. 

The keyframe turns red and displays a pointed yellow handle.

2. Drag the point up or down, or click and pull one of the handles to adjust the curve of the graph.

In this case, changing the velocity from a straight line (constant velocity) to a curved one, changes 
the ease-in (where the curve shoots up and then flattens out) and ease-out (where the curve 
flattens out and then shoots up) values.

The centre keyframe cannot be dragged up or down because the velocity is set. Theoretically, 
dragging it downwards towards zero would put it back to a place of nonmovement.

3. Press the Enter/Return key with the editor still open to watch the result of your curve adjustment in 
the Camera view.

How to add or delete keyframes in the Function editor

1. In the Timeline view, open the layer parameters by clicking the Expand Function  button next 
the layer's name.

2. Select the parameter for which you want to create a function curve: Path, Velocity, Scale: x or y, 
Angle or Skew.

3. Double-click on the parameter layer name to open the Function editor window or click once on the 
parameter layer to display it in the Function view.
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4. In the graph section, click on the frame number where you want like to make changes, or enter the 
frame number in the Frame field.

In the graph section, a vertical blue line indicates the selected frame number.

5. Do one of the following:

‣ In the Function editor, click the Add/Remove Keyframes  button. 

‣ In the Function view, click the Add Keyframe  and Delete keyframe buttons.

6. Click on the newly created keyframe and drag it up (to decrease the width of the object) or down 
(to increase the width of the object) or pull on the handles to create a smooth fluctuation of the 
drawing object's width.

7. If you do not like the changes you just made, select and delete the new keyframe by pressing  
Delete or clicking the Add/Remove Keyframes  button.

You can delete an existing keyframe by using the same process.

How to change a keyframe value in the Function view

1. In the Timeline view, open the peg element's parameters by clicking the Plus  sign next the peg 
layer's name.

2. Select the parameter for which you want to create a function curve: Path, Velocity, Scale:x or 
y,Angle or Skew. 

3. Double-click on the parameter layer name to open the Editor window or click once on the 
parameter layer to display it in the Function view.
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4. In the Value field, enter a value. You can also drag the keyframe up or down in the function graph. 

5. Press Enter/Return or click the Play  button to view the changes made in the Camera view.

6. Keep adjusting the values until you are satisfied with the results.

7. Click Close.

Function View
The Function view lets you edit function curves and parameters. It is a visual graph for adding, 
removing, and editing keyframes, as well as adjusting the velocity. The Function view allows you to 
display multiple functions in the background as a reference.
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How to display functions in the Function view

1. Open the Function view.

The Function view is blank until you select the layer containing the functions you want to display.

2. To display a function in the Function view, click on the layer containing the functions to adjust in the 
Timeline view.

3. To select the functions you want to edit, select them in the Functions List section.

 

Parameter Description

Function List

When selecting a layer in the Timeline view, all the 
corresponding functions are displayed. Until a keyframe is 
added on the function in the Timeline view, it will not be 
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displayed in the Function view. Select all the functions you want 
to see and edit; hide the ones you do not.

 

The Display toolbar allows you to modify how the editing area 
is displayed. You can hide the grid, disable the synchronization 
with the current frame, reset the zoom level and normalize the 
function display by stacking them one over the other to 
compare them regardless of their value range.

Current Frame Displays the current scene frame.

Selected Keyframe Value Displays the value of the selected keyframe.

Display Advanced Parameter 
Values

Displays the Projection, Bias, Tension and Continuity 
parameters to adjust the curve around the selected keyframe.

Keyframe, Velocity and Inter-
polation Options

This toolbar lets you add and delete keyframes, adjust the 
velocity curve, adjust the segments to motion or stop-motion 
keyframes and set the velocity to create steps instead of a 
constant progression.

Function Type
This toolbar lets you click on the different function types to 
enable or disable all the listed functions of that type.

Value Scale
displays the value range for the displayed editing area. It can be ref-
erenced to know the value of a keyframe.

Selected Keyframe
The selected keyframe is displayed in red. When selected, the 
keyframe values are displayed in the corresponding fields.

Bezier Handles

The Bezier handles let you adjust the ease in and ease out of 
each keyframe. The more the handle is pulled out horizontally, 
the slower the animation will be. The more the handle is pulled 
out vertically, the faster the animation will be.

Function Curve
The thin line going from keyframe to keyframe is the actual 
curve. The section of a curve located between two keyframes is 
called a segment.

Frame Scale
The Frame Scale displays the frame range for the displayed 
editing area. It can be referenced to know the current frame of 
a keyframe.
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Modifying a Path in the Xsheet View

If you are prefer working with the Xsheet view, you can also create keyframes and type values in the 
Xsheet view.

You cannot create function curves directly in the Xsheet view. You must do this in the Layer Properties 
editor or the Timeline view.

To edit a function column in the Xsheet view, you must first display the Functions section of the Xsheet 
view and then select the layer you want to modify. If you double-click on a function column's header, 
you will display the corresponding function curve in the Function editor.

How to display the function columns in the Xsheet view

1. In the Xsheet view, click on the Expand Function Section button.

2. In the Timeline view, select the layer containing the parameters to modify.

The columns appear in the Xsheet view. The columns will not appear if function curves were not 
previously created by adding keyframes or through the Layer Properties view.

How to add a keyframe in the Xsheet view

1. In the Xsheet view, go to the function column on which you want to add a keyframe.

2. Double-click on the cell on which you want to add a keyframe and type a numeric value.
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3. Press Enter/Return to continue to the next cell.

4. Press Esc to exit the typing mode.

How to convert a cell into a keyframe

1. In the Xsheet view, go to the function column on which you want to add a keyframe.

2. Select the cell to convert.

3. Right-click on the cell and select Set Selection As Keyframe or press F6.

‣ If you want to remove a keyframe, select the keyframe, right-click on the cell and select 
Clear Keyframe in Selection or press F7.
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Function Curves

By default, when a drawing layer or peg is added to a scene, no function curves are created. You will 
generally create the ones needed to avoid being overloaded with too many functions you might not 
use.

When you select an element in the Camera view and move it around, it will automatically create the 
corresponding function curves. If you need to create certain functions manually, you can always do it 
through the Layer Properties view or editor.  You can then share it with other layer parameters or set 
your keyframes directly on the function curve instead of the Timeline or Camera view.

You can also link a layer's parameter to an existing function curve or attach several parameters to the 
same function curve. For example, if you have an aircraft performing loops between clouds, you may 
want the camera to follow the aircraft's motion path. If you attach the camera to the aircraft's layer, 
the camera will also loop, but this may produce undesirable results and even induce a feeling of motion 
sickness as you watch the final animation. Instead, you can share the X, Y and Z position of the aircraft 
with the camera's peg layer, but ignore the angle, scale and skew. 

By default all the function curves you create are private. This means that the function curves can only be 
used and modified using their original parameter. If you want another layer or parameter to use the 
same function curve, you must make the function public by sharing it.

There are two ways to share a function:

• Share Functions command

• Layer Properties Editor

When you create a function curve in the Layer Properties view or editor, there are several choices 
available: 

• Create 3D Path: Creates a new 3D Path Column set

• Create Bezier: Creates a new Bezier curve

• Create Ease: Creates a new Ease curve

• Local: Disconnects the parameter from any function and turns it public

• 3D Path: Displays the list of every public 3D Path function available

• Bezier: Displays the list of every public Bezier curve available

• Ease: Displays the list of every public Ease curve available

• Velobased: Displays the list of every public velocity based curve available

• Expression: Displays the list of every public Expression function available

• 3D Rotation: Displays the list of every public 3D Rotation function available

• Connected: Displays the list of every public connected function curve

• Unconnected: Displays the list of every public unconnected function curve

• All: Displays the list of every public function curve

You have the choice of creating a new function curve or linking it to an existing public one. This way, 
you can have two or more parameters following the same function.

Depending on your favourite working method, you can create different types of function curves to suit 
your needs. 

You have several choices available:
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• Ease function

• Bezier function

• Velobased function

When you create a function to control a parameter over time (Scale, X, Y, Z, Rotate), you have the 
choice of an Ease or Bezier function.

These function editors present different ways of editing the values over time. The shape of the created 
graph indicates the velocity of the function, regardless of the chosen editor. The type of function that 
you choose is largely based on your working preference. 

With the Ease editor, you can edit the shape of the function curves using the ease-in and ease-out 
controls.

You can also create Velobased functions for certain effects, like changes in rotation or size over time. 
In these cases, the Velobased functions are linked to the velocity of a 3D path. You cannot change the 
shape of a Velobased function to control its velocity.

With Velobased functions, you can link changes in rotation or scaling to the velocity of a 3D path. This 
makes it possible for changes in rotation or scaling to progress at the same speed as changes to the 
position of an element.
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You can convert Ease and Bezier functions so you can edit them using the controls offered by that type 
of function. 

How to create the function curves

1. In the Timeline view, double-click on a layer.

The Layer Properties Editor opens.

2. Select the Transformation tab.

3. Click the Function Arrow button beside the local function information.

4. Create a 3D Path, Bezier, Ease or Velobased curve.

You can click the Function  button to open the Function editor.

5. Click OK.

How to share a function using the Share Functions command

1. In the Timeline view, select the function layer to share.
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2. Right-click  and select Share Functions.

The function becomes public to the other layers and parameters, and can be shared.

Public functions are visible in the main section of the Xsheet view.

3. In the Timeline view, open the Layer Properties editor of the layer that contains the parameters you 
want to link to the public function.

4. To open the Layer Properties editor, in the Timeline view, double-click on the layer containing the 
function to share or click once to display it in the Layer Properties view.

The Layer Properties Editor opens.

5. Select the Transformation tab.

6. Click the Function Arrow  button beside the function you want to link to the function column.

7. From the menu, select the function you just made public from the 3D Path, Bezier, Ease, 
Velobased, Expression, Connected, Unconnected, or All menu and attach it to your parameter.
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The two parameters are now both linked to the same function curve and should follow the same 
path. If you modify the curve, both parameters will update.

How to share function curves

1. To open the Layer Properties editor, in the Timeline view, double-click on the layer containing the 
function to share or click once to display it in the Layer Properties view.

2. Select the Transformation tab.

3. Click the Function Arrow  button beside the function to share.

4. In the drop-down menu, select Local.

5. Click the Function Arrow  button beside the Function field and choose a function from the drop-
down menu.

The function becomes public to the other layers and parameters, and can be shared.

Public functions are visible in the main section of the Xsheet view.
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6. In the same drop-down menu, where you chose the Local option (in our example), select the 
function you just made public from the 3D Path, Bezier, Ease, Velobased, Expression, 3D Path, 
Connected, Unconnected or All menu and attach it to your parameter.

7. In the Timeline view, open the Layer Properties editor of the other layer that contains the 
parameters you want to link to the public function.

8. In the Layer Properties editor or view, attach the parameter to the public function the same way 
you did for the first layer.

The two parameters are both linked to the same function curve and follow the same path. If you 
modify the curve, both parameters will update.

How to convert Ease and Bezier functions

1. In the Xsheet view, show the function columns.

2. In the Xsheet view, click on the Expand button located on the right side of the main section to show 
the Functions section. Click on the same button to collapse it. You can also use the Show Column 
List  button in the Xsheet View toolbar.
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3. Click the Expand button on the right side of the Functions section to display the Column List 
section.

4. In the Timeline view, click the layer that contains you function columns you want to display.

5. In the Xsheet view, right-click on the column header and select one of the following from the menu:

‣ Convert the column: The values of multiple effects may be linked to the original column. 
When you use the Convert the Column command, all links to the original column will transfer 
to the new converted column.

‣ Create a new column and update links: Creates a new function from the original. All links 
to the original column will transfer to the new column. The original function column will 
remain in the exposure sheet in case you decide you want to switch back to it.

‣ Create a new unused column: Creates a new column based on the values in the original 
column and leaves all links pointing to the original column. You can use this command to 
experiment with various functions and then link effect values to the new function curve 
column.
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Copying and Pasting a Motion

In the Timeline view, you can easily drag keyframes to change the animation timing, delete them, cycle 
them and even copy them.

As you animate, you will find that you reuse many positions, drawings, and keys. However, you may 
only want to paste the drawings or just the keys or maybe everything. There are different paste 
options available in the Timeline view which give you maximum flexibility when reusing and pasting.

Note that these modes also apply when you use drag instead of copy and paste.

There are three different modes for pasting your selection:

•  Paste Mode: All Drawing Attributes: Pastes the drawing exposure and keyframes.

• Paste Mode: Keyframes Only: Pastes only the keyframes.

•   Paste Mode: Exposures Only: Pastes only the drawing exposure.

When you have position keyframes set in your drawing layer and you want to move them around when 
moving your drawing's timing, you can use the Paste Special feature to only move selected keyframes.

You can also use the Paste Cycle and Paste Reverse feature to cycle your selection including keyframes 
and drawings.

If you want to cycle a portion of your animation, you can use the Paste Cycle command. You can also 
use the Paste Reverse command to completely reverse the flow of your animation.

How to paste a selection using the different Timeline pasting and dragging modes

1. In the Timeline view, select the cells you want to copy and paste.

2. In the Timeline view's left side, enable the desired Paste  mode.

3. From the top menu, select Edit > Copy cells from the Timeline or press Ctrl + C (Windows/Linux) 
or ⌘  + C (Mac OS X).

4. In the Timeline view's right side, select the cell on which you want to paste your selection.

5. From the top menu, select Edit > Paste Cells in the Timeline  or press Ctrl + V (Windows/Linux) or 
⌘  + V (Mac OS X).

Paste Mode: All Drawing Attributes
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Paste Mode: Keyframes Only

Paste Mode: Exposures Only

How to copy and paste a motion using Paste Special

1. In the Timeline view, select the keyframes, to copy and paste. If you want to move the keyframes, 
move on to step 3.

2. In the top menu, select Edit > Copy.

3. Edit your selection by doing the following:

‣ To paste the selection, in the Timeline view, select the first cell on which you want to paste 
your keyframes and from the top menu, select Edit > Paste Special.

‣ To move the selection, in the Timeline view, drag the selection and hold down Alt 
(Windows/Linux) or ⌘  (Mac OS X). Drop the selection where you need it and release the 
hot key.

The Paste Special window opens.

4. Set the Drawing, Pegs and Functions, and Cycles parameters. 
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5. Click OK.

How to open the Paste Special dialog box

1. In the Library view, select the symbol or template to import.

2. While dragging the selection to the Timeline view, hold down the Alt (Windows/Linux) or ⌘  (Mac 
OS X). Drop the selection in the Timeline view before releasing the hot key.

The Paste Special window opens.

3. Set the parameters.
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How to cycle a portion of an animation

1. In the Xsheet or Timeline view, select the cell range and keyframes to loop.

2. From the top menu, select Edit > Copy.

3. In the Xsheet or Timeline view, select the cell on which you want the cycles to start.

4. From the top menu, select Edit > Paste Cycle or press Ctrl + / (Windows/Linux) or ⌘  + / (Mac OS 
X).

The Paste Cycle dialog box opens.
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5. In the Number of Cycles field, increase or decrease the number of cycles you want to paste.

6. In the Cycle Type, select the type of cycle to paste.

‣ Normal (forward): Pastes your selection as it is, starting with the first cell and ending with 
the last.

‣ Reverse: Pastes your selection reversed, starting with the last cell and ending with the first.

‣ Forward > Reverse: Pastes your selection as a yo-yo, starting with the first cell, going to 
the last one and ending with the first cell.

‣ Reverse > Forward: Pastes your selection as a reversed yo-yo, starting with the last cell, 
going to the first one and ending with the last cell.

How to reverse the animation flow

1. In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.

2. From the top menu, select Edit > Copy.

3. In the Xsheet or Timeline view, select the cell on which you want the cycles to start.

4. From the top menu, select Edit > Paste Reverse or press Ctrl + . (Windows/Linux) or ⌘  + . (Mac 
OS X).
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Paste Special Options

Basic Tab

Parameter Description

Drawings

Only create drawing files when they do not exist: When adding 
exposures to a drawing layer, new drawings will be created only when 
drawings with the same name do not already exist in the destination.

Always create drawing files: When adding exposures to a drawing 
layer, new drawings will always be created. If drawing files with the 
same name already exist, Harmony will create a new name for the draw-
ing.

Paste all Frames of the Symbols (full movie): When enabled, the Paste 
Special command will expose all the Symbol's frames instead of the first 
one only.

Cycle

Number of Cycles: Use the up and down arrows to increase 
or decrease the number of cycles you want to paste. You can 
also type the value directly in the field.

Cycle Type

• Normal (forward): This pastes your selection as it is, starting 
with the first cell and ending with the last one.

• Reverse: This pastes your selection in reverse, starting with the 
last cell and ending with the first one.

• Forward -> Reverse: This pastes your selection as a yo-yo, 
starting with the first cell, going to the last one and ending with 
the first cell.

• Reverse -> Forward: This pastes your selection as a reverse 
yo-yo, starting with the last cell, going to the first one and 
ending with the last cell.
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Advanced Tab

Parameter Description

Drawings

Do Nothing: Does not create or overwrite drawings.

Update Drawing Pivot: Revises the drawing pivot in the 
destination to use the same drawing pivot as the first 
drawing in the template. If you have a range of drawings 
selected in the destination, the pivot points of all selected 
drawings will be updated.

Add/Remove Exposure: Creates/deletes exposure values in 
the selected layer.

You have the following choices as to how to treat drawings 
that will be created when adding an exposure:

• Never create drawing files: When adding exposures to 
a drawing layer, drawing files will not be created.

• Only create drawing files when they do not exist: 
When adding exposures to a drawing layer, new 
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drawings will be created only when drawings with the 
same name do not already exist in the destination.

• Always create drawing files: When adding exposures 
to a drawing layer, new drawings will always be created. 
If drawing files with the same name already exist, 
Harmony will create a new name for the drawing.

• Extend Exposure: Extends the exposure of drawings to 
fill the range of cells to the destination frame.

• Key Drawing Mode (Substitution): Pasting an 
exposure value replaces the cell value in the current 
frame and in all frames following in sequence with the 
original cell value.

• Paste all Frames of the Symbols (full movie): When 
enabled, the Paste Special command exposes all the 
Symbol's frames instead of only the first one.

Add/Remove Keyframes

Motion: Copies the properties of the selected motion 
keyframe to the new frame.

Velocity: Copies the properties of the selected velocity 
keyframe to the new frame.

Rotation: Copies the properties of the selected rotation 
keyframe to the new frame.

Skew: Copies the properties of the selected skew keyframe 
to the new frame.

Scale: Copies the properties of the selected scale keyframe 
to the new frame.

Force Keyframes at Function's Beginning and End: Adds a 
keyframe to the beginning and end of the pasted function, 
reproducing the source function.

Offset Keyframes: When pasting functions, this option 
offsets the keyframes from the function's last value by the 
values in the pasted function. This will continue the 
progression of a function rather than repeat the values. 

Options

Palettes

• Do nothing: Does not create, overwrite, merge or link 
palettes.

• Reuse palettes. Copy palettes if they do not exist: 
Palettes in the destination drawings are left as they are.

• Copy and overwrite existing palettes: Overwrites 
destination palettes with the palettes from the source 
drawings.

• Copy and create new palette files: Creates new palette 
files, placing them at the same relative environment and 
scene level as the source. If the palettes in the templates 
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were stored at the environment level of the source scene, the 
paste operation will place the palettes in the environment level 
of the destination scene.

• Copy and create new palette files in element folder: Creates 
new palette files in the element folders of the destination 
scene, rather than in the same relative job or environment.

• Copy palette and merge colours. Add new colours only: 
Adds new colours to the destination palettes and ignores 
colours that are the same in the two palettes.

• Copy palette and update existing colours only: Adds new 
colours to the destination palette and updates duplicate 
colours in the destination with colour values from the source.

• Link to original palettes (colour model): Links the colour 
palettes in the destination scene to the palettes in the source. 
Use this to link drawings to the palettes in a colour model.

• Copy scene palettes and merge colours. Add new colours 
only: Adds new colours to the destination scene palettes and 
ignores colours that are the same in the two palettes.

• Copy scene palettes and update existing colours: Adds new 
colours to the destination scene palette and updates duplicate 
colours in the destination with the colour values from the 
source.

• Duplicate All Symbol Content: Instead of linking the Symbol 
instance to the original one, the Symbol will be duplicated. A 
new Symbol is created in the Library.

Symbols

• Copy symbols if they do not exist: This is the default 
setting for this operation and will prevent Symbols in an 
Action template from being copied.

• Duplicate symbols: Creates a duplicate of the symbol 
instead of linking the Symbol instance to the original one. 
The new Symbol is created in the Library.

• Overwrite symbols: If a modification was made to a 
Symbol that does not exist in the basic rig template for a 
character, select this option to overwrite the previous 
Symbol.

Cycles

• Normal (forward): Pastes your selection as is, starting 
with the first cell and ending with the last.

• Reverse: Pastes your selection in reverse, starting with 
the last cell and ending with the first.

• Forward > Reverse: Pastes your selection as a yo-yo, 
starting with the first cell, going to the last one and ending 
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with the first cell.

• Reverse > Forward: Pastes your selection as a reverse yo-yo, 
starting with the last cell, going to the first one and ending with 
the last cell.

• Number of Cycles: Lets you set the number of cycles.

Modules: Create New Columns: A new column is created 
when you copy and paste modules from the Layer in the 
Timeline view. If the layers are linked to function curves, the 
function curves, drawings and timing will be duplicated.

Elements: Reuse existing elements: Lets you paste existing elements 
without creating new ones. This should be used only when pasting 
within versions of the same scene.
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Adjusting the Ease

To add ease in and ease out on motion paths, you can display the function curve and modify the Bezier 
or Ease curve. To apply ease to multiple functions and keyframes, you can use the Set Ease For 
Multiple Parameters script and set the amount.

The Velocity, or ease, is used on motion keyframes. The Velocity must be adjusted directly on the 
function curve in the Function view or Function editor. When a keyframe is selected, easing values 
appear in the right handle and left handle fields, as well as Bezier handle or Ease wheel controls on 
each selected keyframe. Pull on them to adjust the ease in and ease out, or type values in the fields.

You can reshape the velocity function using Bezier controls.

You can also reshape the velocity function using Ease controls.

You can create a stepped curve to hold the same value over a selected number of frames. This works 
well when you are animating drawings on 2s, for example, and you want to hold the same value for a 
function over those two frames.

If you have several functions whose velocity you want to adjust at the same time, you can use the Set 
Ease for Multiple Parameters dialog box. It allows you to apply the same velocity parameters to all the 
selected keyframes in the same frame.
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How to display the velocity curve

1. In the Timeline view, click the Expand  button on a layer or press Alt + F to display the layer’s 
functions.

2. Double-click the desired function.

The Function Editor opens as the Ease Editor or Bezier Editor.
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The editor will not be displayed if the function does not already exist. You can reshape the function 
using the Bézier or Ease controls.
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How to reshape a function using Bézier controls

1. Select a keyframe.

2. Drag the handles to modify the shape of the curve.

3. The Continuity options influence how you can move the handles:

‣ Straight: Lets you move the handles together, maintaining the same angle to the point.

‣ Corner: Lets you move the handles independently.

‣ Smooth: Lets you move the handles together, maintaining the same distance and angle to 
the point.

How to reshape the function using Ease controls

1. Click on the keyframe to select it.

2. To set the number of frames in the ease-in, press Alt, click to the right of the keyframe and drag 
the green line. The ease in slope is indicated in blue. 

As you change the values visually, the value in the Ease In field is updated. This value represents the 
number of frames in the ease-in.

3. To set the number of frames in the ease-out, press Alt, click to the left of the keyframe and drag 
the green line. The ease out slope is indicated in red. 

As you change the values visually, the value in the Ease Out field is updated. This value represents 
the number of frames in the ease-out.

4. To adjust the ease-in or ease-out, drag the handles around the keyframe.

The Continuity options, Corner and Straight, influence how you can move the handles:

‣ Straight: allows you to move the handles together, maintaining the same angle to the point.

‣ Corner: allows you to move the handles independently.

How to hold the same value over several frames

1. Click the Hold Value Editor  button.

The Hold Value editor opens.

2. In the Hold Value Editor, enter the following values:

‣ Start: Enter the starting frame for the effect.

‣ Stop: Enter the last frame for the effect.

‣ Step: Enter the number of frames to hold the value.

The function curve is updated based on the values you entered.
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You can reshape the curve to create a linear velocity, so the values are interpolated (tweened) 
consistently between keyframes. That is, there is no acceleration in the effect.

How to set eases on multiple parameters

1. In the Timeline view, select a keyframe on one or more layers.

Only the first selected keyframe will be considered when using the Set Ease For Multiple Parameter 
function. If many keyframes are selected on a same layer, the ease values will be applied only to the first 
one and the rest will be ignored.

2. In the Timeline view,right-click and select Set Ease For Multiple Parameters. In the Timeline View 
toolbar, you can click the Set Ease For Multiple Parameters  button.

The Set Ease For Multiple Parameters dialog box opens.

3. In the graph, pull on the Bezier handle to adjust the velocity for all the selected functions.
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4. In the Filters section, you can apply the easing parameters to a specific type of function only, such 
as Rotation or Scale. Deselect the function types you do not want to affect.

‣ Motion: If this option is enabled, the easing parameters will be applied to the selected 
Position X, Position Y, Position Z and 3D Path functions

‣ Rotation: If this option is enabled, the easing parameters will be applied to the selected 
Angle functions.

‣ Scale: If this option is enabled, the easing parameters will be applied to the selected Scale 
functions.

‣ Skew: If this option is enabled, the easing parameters will be applied to the selected Skew 
functions.

‣ Morphing: If this option is enabled, the easing parameters will be applied to the selected 
Morphing Velocity functions. Note that it applies to the Morphing velocity function found in 
the Layer Properties dialog and not to the basic morphing ease in the Tool Properties view.

‣ Other: If this option is enabled, the easing parameters will be applied to all the other the 
selected functions such as all functions created to animate effect parameters.

5. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values 
are calculated in percentage.

‣ In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding 
to the length of time you want the easing to last for. It is recommended to remain between 
0% and 100%. If you go beyond 100%, your motion will overshoot. 

‣ In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong 
you want the easing out to be. It is recommended to remain between 0% and 100%. If you 
go beyond 100%, your motion will overshoot. 

‣ If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

6. Once done, click on one of the following buttons:

‣ Apply: Applies the easing parameters to the selected keyframes.

‣ Apply/Previous: Applies the easing parameters to the selected keyframes and then selects 
the previous keyframe in the timeline.

‣ Apply/Next: Applies the easing parameters to the selected keyframes and then selects the 
next keyframe in the timeline.

‣ Close: Close the dialog box. If you did not apply the modifications, they will be cancelled.
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Chapter 4: Sound

With Harmony, you can import soundtracks and dialogue into your animation to make it more 
engaging and entertaining.There are several sound editing features you can use to synchronize sounds 
to individual frames or moments in time. You can also use them to trim unwanted seconds from the 
beginning and end of your sound files, as well as loop sounds that you want to continue throughout 
your animation.

Your ability to add dialogue to animation is greatly enhanced with the Harmony lip-sync tools. 
Harmony can analyze voice tracks to determine which of the eight animation phonemes (lip positions) 
would best apply to each frame of sound. With the mouth chart that is generated, you can easily draw 
lip positions for your character. Furthermore, Harmony can automatically apply drawings of lip 
positions to each frame of your animation based on the mouth chart.

This chapter contains the following topics:

• Importing a Sound File on the next page

• Sound Layer Properties - Sound Element Editor on page 905

• Sound Displays on page 907

• Sound Playback on page 909

• Sound Scrubbing on page 910

• Editing a Sound File on page 913

• Adding an Empty Sound Layer on page 921
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Importing a Sound File

If you decide to add sound to your movie, you must first prepare the sound outside of Harmony. Once 
this is done, you must add a sound element in Harmony to the organize the sound files in your 
animation. Sound will play in the movie until it reaches the end of the file or a stop frame that you have 
created in the Sound Element Editor.

You can import WAV, AIFF or MP3 sound files.

How to import a sound file

1. Do one of the following:

‣ From the top menu, select File > Import > Sound.

‣ In the Xsheet view, right-click anywhere in the frame area of the Xsheet view and select 
Import > Sounds.

‣ From the Xsheet view menu, select File > Import > Sounds.

‣ From the Timeline view menu, select Import > Sounds.

The Select Sound File dialog box opens.

2. From the Select Sound File dialog box, find and select a sound file.

The sound file  appears as a layer in the Timeline and Xsheet views.
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Sound Layer Properties - Sound Element Editor

When you select a sound layer in the Timeline view, the options related to that layer appear in the 
Layer Properties view or in the Sound Element Editor when you double click on the layer. 
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• Mute/Unmute: This button mutes and unmutes the sound layer during the scene play back.

• Layer Name: This field displays the layer's name.

• Sound Editor: This button opens the Sound editor.

• Start Frame/End Frame: These fields determine the start and end frame of the sound file.

• Detect: This button launches the automated lip-sync detection.

• Map: This button opens the Map Lip-sync dialog box.

• Mouth Shapes: This section shows the automated lip-sync detection during the scene play back. Click 
on the thumbnail image of each mouth to change the phoneme assigned to the current frame.
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Sound Displays

Within the Xsheet view, you can display the sound file in different ways, depending on your sound 
editing needs.

You can show or hide the waveform in the Timeline view by selecting the Waveform  button in the 
Timeline View toolbar. You must customize the toolbar to display this button because it is not 
included in this toolbar by default.

How to change the sound display in the Timeline view

1. In the Timeline view's right area, right-click in the frame section and select Show Sound 
Waveforms.

‣ You can change the waveform scale using the Zoom Waveform  icon on individual sound 
layers in the Timeline view's left side.

How to change the sound display in the Xsheet view

1. Right-click in the sound column or on the sound column header, and select Sound Display and one 
of the following:

‣ Sound Name: Shows the name of the sound file, as well as the file format. The line running 
vertically through the column frames between the same file name indicates a continuity of 
the same sound file in these frames.

‣ Mouth Shapes: Shows the letter (or name depending on the way you named your 
character's different mouth positions) in the column's frames. There is only one mouth 
position allotted per frame and this position should correspond to the sound file after 
performing a lip-sync.

‣ Waveform: Shows a vertical display of the sound file's actual waveform. In the column 
header, in the field under the column name, you can type in a percentage to zoom in or 
zoom out on the waveform, or pass the scroll cursor  over the Zoom Waveform  
icon.
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Sound Playback

Before playing back any sound, click the Enable Sound  button in the Playback toolbar or enable it 
through the Play menu (in the top menu). This will ensure that you can hear the sound layers in your 
scene, even the ones included within symbols.

How to play back sound

1. To select a starting point:

‣ In the Xsheet view, click on a cell in the sound column.

‣ In the Timeline view, click on a cell in the sound layer. You can also slide the red playhead to 
the correct cell.

2. In the Playback toolbar, activate the the Enable Sound  button.

3. Do one of the following:

‣ Click the Play  button in the Playback toolbar.

‣ From the top menu, select Play > Play Scene Forward or click on the Enter/Return key.

4. To hear the sound played back again and again, do one of the following:

‣ Click the Loop  button in the Playback toolbar 

‣ From the top menu, select Play >Loop.

Mute
If there are two or more sound layers and you want to listen to them independently, you can disable 
the unwanted sound by clicking the Mute Sound  button on the sound name layer in the Timeline 
view.
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Sound Scrubbing

Harmony uses a process known as Sound Scrubbing to let you hear sound in real-time while you move 
the playback pointer forward or backward. This is very useful for finely-tuned lip-synching. You can 
scrub sounds from the Timeline view. 

How to scrub a sound from the Timeline view

1. Do one of the following:

‣ From the top menu, select Play > Enable Sound Scrubbing. 

‣ In the Playback toolbar, enable the Sound Scrubbing  button. 

2. At the top of the Timeline view, drag the red playhead to hear the sound at each frame.

Analog Sound Scrubbing
Harmony is set to the digital sound scrubbing mode by default. This means that all sounds are played 
in real time. It also means that as you scrub over a frame, you will hear the section of your sound file 
that is allotted to that frame. As you are scrubbing, although it is accurate, the sound can sound 
clipped. It can also be difficult to hear nuances in pitch and tone. 

Harmony has an analog sound scrubbing option. When sound scrubbing in this mode, the sound is 
played back according to the speed that the playhead or jog is manually adjusted. Harmony's 
interface offers shuttle and jog sliders to perform analog sound scrubbing, however, external 
hardware and their corresponding software can be used in conjunction with Harmony for improved 
analog sound scrubbing results. 

910



Toon Boom Harmony 11.1 Draw Guide (Network)

Refer to the device's manual to configure its functionality with Harmony.

Performing an Analog Sound Scrub in Harmony

Before you can perform an analog sound scrub in Harmony, you have to learn about the Shuttle and 
Jog controls.

• Shuttle: Pull the Shuttle control backward or forward to make the red playhead in the Timeline 
view jump by large increments in the direction you are moving the shuttle.

• Jog: Drag the Jog control to make the "dial" rotate. The Jog controls finer incremental 
movements along the soundwave. Use the Frame field to see the frame number which you are 
on. As you rotate the dial, your speed in fps appears directly after the FPS field. 

How to perform an analog sound scrub

1. Do one of the following:

‣ From the top menu, select Play > Enable Sound Scrubbing. 

‣ In the Playback toolbar, enable the Sound Scrubbing  button. 
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2. In the top menu, select Edit > Preferences (Windows/Linux) or Stage> Preferences (Mac OS X).

3. In the Sound tab, select the Analog Sound Scrubbing option.

4. Click OK.

5. Do one of the following:

‣ In the Playback toolbar, use the Shuttle to find the general location of where you want to 
start your sound scrub. 

‣ In the Timeline view, drag the red playhead to the desired location.

6. In the Playback toolbar, use the Jog to fine-tune your scrub to just a few frames.
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Editing a Sound File

Now that you have successfully imported a sound file into Harmony, it is time to familiarize yourself 
with the sound editing interface. The Sound Element editor makes it possible to edit sounds that were 
created outside of Harmony and imported into your scene.

How to open the Sound Element editor

1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

The Sound Element Editor dialog box opens.

The Sound Element editor consists of three main parts.
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‣ Sound Element: The waveform in the Sound Element Editor is the actual sample that will be 
heard when the final movie is rendered. It may be shorter than the original sound sample 
due to the length of the scene. If any edits are made to the sound sample, they can be heard 
here. In the Sound Element panel, notice the coloured tabs that indicate the start and end 
frames of a sound segment. The frame number is displayed in the tab.

‣ Current Sound: Displays the original sound file in its entirety and is where you can edit its 
properties. This window remains empty until you click inside the Sound Element Editor.

‣ Lip-sync Preview: Lets you preview the automated detection and to manually insert 
different mouth positions to correspond with the sound sample. 

You can accomplish the following tasks in the Sound Element Editor:

• Changing the Start or End Frame of a Sound below

• Trimming the Start and End of a Sound File on page 916

• Looping a Sound on page 917

• Mixing the Sound Volume on page 918

• Customizing the Playback Range on page 919

• Recomputing the Mouth Chart on page 928

Changing the Start or End Frame of a Sound
To synchronize the sound with specific images in your scene, you must set a start frame for your 
sound. To make sure the sound ends by a certain frame, you must set an end frame.

In the Sound Element panel you will see some coloured tabs, these tabs represent the frames. The 
frame number is shown inside the tab flag marker. These tabs indicate the start and end frames of a 
sound segment.
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How to change start or end frame of a sound

1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

2. In the Sound Element Editor, select a sound sample from the Sound Element panel. To distinguish 
one sound section from another on the same sound layer, check the frame numbers that appear on 
tabs flanking the start and stop lines of each waveform section.

Click the Play  button in the Current Sound panel (only the selected sound plays).

3. Within the Sound Element panel, drag the selected clip to the frame number where you want it to 
start playing. 

You can only move the clip to a section that does not already contain a clip; you cannot overlap two 
clips in the same element.

4. To change the end frame, drag the yellow marker at the end of the waveform to the frame 
position.
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5. To hear how all the clips fit together in the element, click the Play  button  in the Sound Element 
panel.

If you only want to hear the selected clip, click the Play  button  in the Current Sound panel.

6. Click Apply/Next.

The Xsheet and Timeline views display the sound clip at the start frame you selected.

Trimming the Start and End of a Sound File
To play only a section of a sound file, use the Sound Element Editor to select the exact part you want 
to use. For example, if there is a bit of noise at the start of the sound, use the Sound Element Editor to 
cut the noise. 

The Sound Element Editor does not change the original sound file; it only plays a section of it, ignoring 
the rest. This means that the entire sound file is included on export. If you need to be mindful of file 
size, it is better to edit sound files completely in a sound editor before bringing them into Harmony.

How to trim the start and end of a sound file

1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.
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2. In the Sound Element Editor, select a sound sample from the Sound Element panel. To distinguish 
one sound section from another on the same sound layer, check the frame numbers that appear on 
tabs flanking the start and stop lines of each waveform section. Or select a soundwave and click 
the Play  button in the Current Sound panel (only the selected sound plays).

3. Using the Current Sound panel, decide on the part of the file you want to play by dragging the left 
and right boundaries of the selection area.

4. Click the Play  button in the Current Sound panel to check that you have trimmed the desired 
sections. Use the Zoom slider at the bottom of the panel to zoom in on the waveform so you can 
trim it more accurately.

5. Click Apply/Next. 

The trimmed sound sample appears in both the Timeline and Xsheet views at the start and end 
positions you selected.

Looping a Sound
To repeat a sound, specify the number of times that you want it to loop in the Sound Element editor.

How to loop a sound sample

1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

2. From the Sound Element panel, select the sound section you want to loop.

3. In the Current Sound panel, type the number of times you want the sound to play in the Number of 
Loops field.
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4. Press the Enter/Return key. 

The looped sound appears after the current sound. They are indicated by their grey waveforms, as 
opposed to black.

When you loop a sound, the looped sections fill the cells in the sound element (column or layer) 
until the next sound sample starts or until the scene ends. This means that the looping could be cut 
if the next sound sample starts too soon or if the scene ends too quickly.

Mixing the Sound Volume
You can adjust the volume of an entire sound clip or modify the volume in increments by adjusting the 
fade-in and fade-out times, otherwise known as sound envelopes. The fade edit only affects the 
playback; the original sound file is not affected.

How to adjust the overall volume of the entire sound clip

1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

2. In the Sound Element panel, select the sound you want to work on. 

A more detailed version of the selected sound appears in the Current Sound panel.

3. In the Current Sound panel, use the Volume slider to adjust the volume.

4. Click the Play  button in the Current Sound panel to verify the volume.

How to create the fade in/out effect on a sound clip

1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

2. In the Sound Element panel, select the sound you want to work on.

3. In the Current Sound panel, click on the thin blue line above the waveform to add an envelope 
marker.
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4. Drag the envelope markers to adjust the volume at that frame and to create the time of the 
transition. The line from the edge of the clip to the envelope marker identifies how the volume 
increases (fades-in) or decreases (fades-out) over time.

Dragging the marker to the bottom of the channel mutes the volume, while dragging it upwards 
increases the volume. 

To create an even effect, be sure to adjust the envelope markers uniformly in both the left and right 
(bottom and top) channels.

5. Click the Play  button in the Current Sound panel to check the fade envelopes.

Customizing the Playback Range
To hear a specific section of the sound element, adjust the playback range in the Sound Element Editor 
to start or stop at specific frames. This customized playback range does not affect the actual sound in 
the Sound element. 

How to change the playback range in the Sound Element Editor 

1. Drag the start or end range markers in the Sound Element panel to the boundary frames you want.
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2. When you click the Play  button to play back your sound in the Sound Element editor, it only 
plays the sound which exists between the two markers.
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Adding an Empty Sound Layer

When performing sound editing tasks, it can be useful to chop up a sound sample into different layers. 
For example, when performing a lip-sync, only a single view of the various mouth positions for a 
character can exist on one layer. Therefore, if you want to have a character turn its head from a profile 
view to a three-quarter view and have mouth position changes to fit with the sound sample from these 
two different views, you would need to cut up the sound samples needed for the profile view mouth 
positions on one layer and the sound samples needed for the three-quarter view on another.

For this task, you will need an empty sound layer. 

How to add an empty sound layer

1. From the top menu, select Windows > Toolbars > Timeline View. 

The Timeline view toolbar appears at the top of the Timeline view.

2. Right-click on the Timeline View toolbar and select Customize.

3. Choose the Add Sound  button from the Available Tools column on the left and add it to the 
Toolbar column on the right. Click Ok to accept the change.

4. Click the Add Sound  button.

An empty (silent) sound layer appears in both the Timeline and Xsheet views.

5. Rename the layers accordingly by double-clicking on the layer name and renaming it in the Sound 
Element Editor. Click Apply/Next to accept the change.
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6. Click the cell where you want to start the cut and Shift + click on the final cell of the cut. The sample 
to be cut becomes highlighted.

7. Drag the selection into the empty sound layer below.

8. You can now continue to cut-up and distribute the sound sample between the two layers or carry 
on to the lip-synching process for each layer and its corresponding facial view.

If you need to duplicate your sound layer to keep an unedited copy for safety, select the Duplicate 
Selected Layers button in the Timeline View toolbar. You must customize the toolbar to display this button 
because it is not included in this toolbar by default.
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Lip-sync

Adding a lip-sync to a project can really enhance its quality and storytelling. However, it can be difficult to 
shape a character's mouth to match the sound at a precise frame. 

To solve this problem, Harmony provides a lip-sync feature which analyzes the contents of a sound 
element and generates a mouth chart (see below) based on the eight animation phonemes (A, B, C, D, 
E, F, G, and X, which is used to represent silence).

The mouth shapes used by Harmony are based on the conventional mouth chart used in the animation 
industry.

The letters used to represent the shapes do NOT correspond to an actual sound.

If you are doing cut-out animation, refer to the Cut-out Animation Guide, Character Building chapter, 
"Adding Extra Drawings" topic to learn how to add extra drawings to your character.
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Here is an approximation of which sound each mouth shape can produce:

• A: m, b, p, h

• B: s, d, j, i, k, t

• C: e, a

• D: A, E

• E: o

• F: u, oo

• G: f, ph

• X: Silence, undetermined sound

You can lip-sync the traditional way or let the system automatically create the basic detection. 

You can refer to the mouth chart positions as you draw the shape of your character's mouth. 

Generating a Lip-sync Detection
There are two places where you can perform a lip-sync detection: Timeline or Xsheet views and Sound 
Element Editor.
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How to generate a  sound detection for lip-sync using the Xsheet or Timeline view

1. To show the mouth chart letters, if they are not already present in the Xsheet view,right-click on 
the sound column and select Lip-Sync > Sound Display > Mouth Shapes from the pop-up menu. 

2. In the Xsheet view or Timeline view, right-click on the sound layer's cells and select Lip-Sync > Auto 
Lip-Sync Detection. You can also select Animation > Lip-Sync > Auto Lip-Sync Detection from 
the top menu.

Harmony analyzes the selected sound clips and assigns a lip-sync letter to each frame. The X 
markers in the frame are replaced by these designated letters.

How to generate a sound detection for lip-sync using the Sound Element Editor

1. Do one of the following:

‣ In the Timeline view, double-click on the sound layer.

‣ In  the Xsheet view, double-click on the sound column header.

The Sound Element Editor opens.

2. In Sound Element panel, select the waveform for which you want to generate a mouth chart.

3. Right-click on the sound file and select Auto Lip-Sync Detection.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync 
letter to each sound cell.

Mapping the Lip-Sync Detection
Harmony can automatically map drawings in an element to the mouth chart you have generated for a 
sound. This can save time when you are lip-synching a voice track.

In the Lip-Sync Mapping dialog box, you can identify each lip drawing of a character. Harmony then 
automatically labels all of the cells in the character's element with the appropriate name.

How to automatically map lip-sync drawings to a mouth layer

1. To open the Lip-Sync Mapping dialog box, do one of the following:
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‣ In the Timeline view, right-click on any cell in the sound sample layer and select Lip-Sync > 
Map Lip-Sync. 

‣ From the top menu, select Animation > Lip-Sync > Map Lip-Sync.

The Lip-Sync Mapping dialog box opens.

2. From the Destination Layer menu, select the layer that contains the mouth positions for the 
character's voice track. 

3. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on 
the layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you 
want to use the drawings or select the desired symbol from the drop-down menu.

4. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the 
phoneme it represents. If your drawings are already named with the phoneme letters, you do not 
have to do anything.

5. Click OK. 

6. Press the Play  button in the Playback toolbar to see and hear the results in the Camera view. 
To play back your scene with sound, enable the Sound  button in the Playback toolbar. 

Modifying the Lip-sync
You can change the mouth position assigned to a frame if you think another position is more 
appropriate. 

For example, you may have a character who says nothing for 10 frames between two speeches. 
Harmony would normally assign an X image for the silent period. However, if you want your 
character's mouth to hang open in astonishment for these 10 frames, you can change the lip 
assignment for these frames from an X to an F.
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You can also change the mouth assignment of a sound in the Sound Element editor.

How to change the lip assignment of a sound in the Xsheet

1. Right-click in the cell that contains the mouth position you want to change.

2. From the pop-up menu, select Lip-Sync > Change Mouth Shape to and choose the letter that 
reflects the mouth position you want to use for that sound. You can also select Animation > Lip-
Sync > Lip-Sync > the desired mouth shape from the top menu.

The drawing is automatically updated in the Camera view.

How to change the mouth position assignment of a sound from the Sound Element 
editor

1. Double-click the sound layer name in the Timeline view or the sound column header in the Xsheet 
View to open the Sound Element editor.

2. In the Sound Element panel, drag the frame slider to the frame you want to change the mouth 
position assignment on.

In the Lip-sync image area, the image on top represents the lip position assigned to the current 
frame. 

3. To change the image assigned to the frame, click on the image of the mouth position you want 
from below the preview image. The preview image changes to the mouth position image you 
select. You can perform the same operation in the Layer Properties view.

The position is updated in the Timeline and Xsheet views.

Note that if you modify the lip-sync detection you must remap the detection to your mouth latyer. See See 
"Mapping the Lip-Sync Detection" on page 925
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Recomputing the Mouth Chart

When you generate the mouth chart for a sound in a sound element, you can either accept the mouth 
positions assigned by Harmony or assign your own lip-sync images.

However, if you change the sound's start frame or reassign its mouth position, you must reanalyze the 
sound and regenerate the mouth chart for it. This erases any manual modifications you may have made 
to the mouth assignments in the mouth chart.

To recompute the mouth chart for a selected sound from the Sound column

1. In a Sound column in the Xsheet or Timeline view,right-click on a cell that contains the sound file you 
want to recompute the lip-sync for. Select Lip-Sync > Auto Lip-Sync Detection from the pop-up 
menu. The mouth position assignment for each frame is recomputed, erasing any modifications you 
have made.

To recompute the mouth chart for a selected sound from the Sound Element Editor

1. Double-click the sound layer name in the Timeline view or the sound column header in the Xsheet 
view to open the Sound Element editor.

2. Click on the waveform in the Sound Element section in the Sound Element editor.

3. Right-click and select Auto-Lip Sync Detection. 

Manual Lip-sync
Harmony allows for the manual swapping of mouth position drawings to match a voice track. For this 
process, both sound scrubbing (listening to a soundwave broken up frame-by-frame) and drawing 
substitutions from the Library View are used.

How to perform a manual lip-sync

1. In the Playback toolbar, enable the Sound Scrubbing  button.

2. In the Timeline view, drag the red position indicator along the sound layer waveform.

3. When you reach a frame where a mouth position should go, for example, an open mouth with 
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

4. In the Timeline view, click on the Expand  button to display the Data view. 

5. Staying on your mouth shapes layer, place your cursor on top of the drawing name (often a letter) 
until it changes to the swapping  pointer.

6. Pull the cursor to see the list of mouth shape names and choose the one you want. The current 
drawing automatically changes to the new selection.

You can also use the Library view to swap drawings.

How to perform a manual lip-sync using the Library view

1. In the Playback toolbar, enable the Sound Scrubbing  button.

2. In the Timeline view, drag the red playhead along the waveform of your sound layer.
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3. When you reach a frame where a mouth position should go, for example, an open mouth with 
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

4. In the Drawing Substitution window of the Library view, click and drag the slider to choose a mouth 
shape. The current drawing is swapped for the one in the preview window.
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Chapter 5: Effects

Once your animation is completed, you can add effects such as blurs and glows to make your project 
look even better! Harmony provides you with a series of essential effects that you can add to your 
layers.

This chapter contains the following topics:

• Adding Effects  on the next page

• Animating an Effect Over Time  on page 935

• How Does an Effect  Work?  on page 937

• Using Effects  on page 939
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Adding Effects 

In Harmony, to add an effect to the Timeline view, add an effect layer, connect the desired layer to it, 
and adjust the parameters until you get the look you want.

This topic is divided as follows: 

• Adding Effects Through the Timeline View        below

Adding Effects Through the Timeline View       

How to add effect in the Timeline view

1. In the Timeline view, click the Add Layers button and select Effect > the desired effect. You can 
also select Insert > Effects > the desired effect from the top menu.

The effect appears in the Timeline view.

2. Drag the drawing layer on the new effect layer to parent them.
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3. In the Camera view, click the Render View Mode  button to see the result of rendering the 
scene's current frame and the effect .

4. In the Timeline view, double-click on the effect layer to open the Layer Properties window.

The Layer Properties view opens, displaying the parameters available for the selected effect.

5. In the Layer Properties view, adjust the effect’s parameters.

6. In the Camera view, click the Update Preview button to update the rendered preview.

7. To play back your scene with the final effects, in the Playback toolbar, click the Render and Play  
button.
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Previewing Effects

Most effects must be rendered so you can preview them properly. Some effects can be displayed in 
the OpenGL view, but most of them must be rendered and previewed in the Render Mode of the 
Camera view.

How to preview effects

1. In the Camera view status bar, click the Render Mode  button.

In the bottom-right corner of the Camera view, the progress bar indicates the status of the 
rendering. Depending on the size of the frame to render, it may take several seconds.

Once you preview your effect, you may want to adjust it. By default, as soon as you modify a 
parameter, Harmony will recalculate the preview image. If your scene is heavy and you do not want 
preview rendered automatically, you can disable the Auto-Render option and request the preview 
update yourself.

How to disable the Auto-Render option

1. In the Camera view status bar, click the Auto-Render  button.

Once the Auto-Render option is disabled, you must request the preview update by clicking the 
Auto-Render  button.

How to manually update the rendering preview

‣ In the Camera view status bar, click the Render button.

Note that you cannot play back your animation in Render mode. You must perform a render or a preview 
render to see your animation with the final effects.
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Animating an Effect Over Time 

In Harmony, to animate an effect over time, create a function curve by adding keyframes to the 
parameters you want to animate. To do this, you will use the Layer Properties view and the Timeline 
view. You can fine tune your animation using the Function view.

How to animate an effect over time

1. In the Timeline view, add the effect and connect the layers to it. See Adding Effects Through the 
Timeline View        on page 932.

2. Select the Effect layer.

3. To create the function curve:

‣ In the Layer Properties view, click on the Function  button you want to animate to 
create a function curve.

OR

‣ You can also expand the effect layer's parameters in the Timeline view by clicking on the 
Expand  Function button and add a keyframe using the F6 key to the parameter you 
want to animate.

4. In the Timeline view, click on the Show Data View  button.

5. In the Timeline view, go to the frame where you want to start animating the effect.

6. In the Data view, click on the Add Keyframe  button.
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7. In the Value field scroll to the keyframe value or type the value in the field.

‣ If your keyframes are stop-motion keyframes, in the Timeline view, select the new 
keyframes. Right-click on the selection and select Set Motion Keyframe.

8. Repeat this process for each keyframe to be added.

When compositing your scene, it will often happen that you want to animate the parameters of an 
effect over time. You may want to have an object fading in or out by changing the transparency level 
over time or increasing the colour contrast on one of your drawings over a certain frame range.

To animate an effect over time, create a function curve by adding keyframes to the parameters you 
want to animate. To do this, you will use these views: Layer Properties,  Network and Timeline. You 
can fine tune your animation using the Function view.
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How Does an Effect  Work? 

An effect always needs a drawing connection and sometimes a matte or shape connection. A matte 
provides drawing information that determines the area on which the effect will be applied on the 
drawing. The details and colours within the matte drawing do not matter, as the system will only use 
the shape and transparencies in it. A matte is also known as mask.

The matte principle can be demonstrated with the Tone effect.

The drawing layer is connected to the right port of the effect and the matte (mask) on the left. The 
Tone effect then applies darker colours where the matte overlaps the image, blurs the tone edge, and 
finally clips out the extra tone zone outside the drawing before outputting a final drawing with a tone.

You can adjust the tone's parameters in the Layer Properties view and link any of them to a function 
column to be animated over time. This means that all of the effects can be customized.
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Using Effects 

Here is the list of the main effects available in Harmony. Each effect and how to use it is described in 
the corresponding section.

• Blending  on the next page

• Directional-Blur on 
page 943Directional-Blur on 
page 943

•  Blur on page 946 Blur on 
page 946

• Motion-Blur  on page 963

• Brightness and Contrast  on 
page 947

• Colour-Override  on 
page 949

• Colour-Scale  on page 958

• Mask on page 959Mask on 
page 959Mask on page 959

• Glow  on page 959

• Highlight  on page 961

• Motion-Blur  
on page 963

• Shadow  on 
page 966

• Tone  on 
page 969

• Transparency 
 on page 971
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Blending 

Effects modules, like the Tone module and Highlight module, can control the colour and alpha 
composite operations for you. These modules were created with pre-set colour and alpha composite 
operations to fit the most frequently used, composite operations.

You might, however, still want to control the colour and alpha composite operation between two 
images using the Blending module, to create a multiplicity of lighting, shadow, filter or ambient 
effects. The Blending module combines two images into one output image, following the parameters 
you choose for your movie and images sequence or SWF movie exports.

The drawing module connected to the Blending effect will act as the blending image and will be 
applied to all the drawing layers situated under them in the Timeline view order.

Blending Properties

Parameter Description
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Name Use this field to rename the module.

Blend Mode and SWF Blend 
Mode

Choose the blending effect mode you wish to apply to your 
layer. The Blend Mode type will only be visible when the 
Camera view is set to Render  mode and will only export to 
a bitmap movie file or sequence of images.

Both the Blending module and Composite-Generic module 
have regular blending modes and legacy blending modes. The 
regular blending modes will take the source images and 
unmultiply them before blending the two inputs together. The 
images will be remultiplied when being output from the  
module. The legacy blending modes use the pre-multipled 
source images as is in order to apply the effect. Unmultiplying 
the images before processing them will give a final result closer 
to what can be found in software such as Adobe Photoshop.

• Normal: The layer attached to the effect acts as a normal 
layer and will not create any blending mode effect.

• Multiply: This operation multiplies the blending element 
colour with the output image. This will darken the colour of 
the overlapping area.

• Screen: This operation multiplies the inverted colour of the 
blending element with the image. This will lighten the colour 
of the overlapping area.

• Lighten (Lighten Legacy): This operation lightens the area 
of the output image which, is darker than the blending 
element’s colours. The lighter colours will remain 
unchanged.

• Darken: This operation darkens the area of the output 
image, which is lighter than the blending element’s colours. 
The darker colours will remain unchanged.

• Difference  (Difference Legacy): This operation subtracts 
the blending elements colour from the output image 
colours or vice-versa, depending on which of them has more 
bright colours. The final result will be colours that are more 
vibrant.

• Add (Add Legacy): This operation lightens the output 
image using the blending element.

• Subtract (Subtract Legacy): This operation darkens the 
output image using the blending element.

• Invert: This operation inverts the output image colours on 
the area overlapping the blending layer colours.

• Overlay (Overlay Legacy): This operation multiplies or 
screens the colours from the blending image, with those of 
the output image, depending on the base colour. Colours 
from the blending element overlay the colours of the 
drawing elements, while preserving the highlights and 
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shadows of the base colour. The base colour is not 
replaced, but mixed with the blend colour to reflect the 
lightness, or darkness, of the original colour.

• Hardlight(Hardlight Legacy): This operation multiplies, or 
screens, the colours of the blending layer with those of the 
output image, depending on the blend colour. If the blend 
colour is lighter than 50% grey, the image is lightened, as if 
it were screened. This is useful for adding highlights to an 
image. If the blend colour is darker than 50% grey, the 
image is darkened, as if it were multiplied. This is useful for 
adding shadows to an image. Painting with pure black or 
white results in pure black or white. Play with the Opacity 
value to create a subtler look.

• Alpha: This operation will blend the alpha value of the 
blending layer with the output image. This effect is not 
available for SWF Blend Mode.

• Erase: This operation produces a cutter effect using the 
blending element. This effect is not available for SWF Blend 
Mode.

• Divide (Divide Legacy): This operation divides the output 
image colour values by the blending layer colour values. The 
blending image colour values are inverted, creating a 
negative image. The negative image’s colour values are 
then multiplied by the right image colour values. This effect 
is not available for SWF Blend Mode.

• Replace: This operation replaces the output image by the 
blending layer. This effect is not available for SWF Blend 
Mode.

• Softlight: This operation darkens or lightens the colours in 
a soft and diffuse way, depending on the blend colour 
(image in left port). If the blend colour is lighter than 50% 
grey, the image is lightened. If the blend colour is darker 
than 50% grey, the image is darkened. Painting with pure 
black or white produces a distinctly darker or lighter area, 
but does not result in pure black or white. 

• Linear Light: This operation burns or dodges the colours by 
decreasing or increasing the brightness depending on the 
colour of the underlying colour. If the blend colour is lighter 
than 50% grey, the colour is lightened because the 
brightness is increased. If the blend colour is darker than 
50% grey, the colour is darkened because the brightness is 
decreased.

• Pin Light: This operation will replace the colours, 
depending on the underlying colour . If the blend colour is 
lighter than 50% grey, pixels darker than the underlying 
colour are replaced, and pixels lighter than the underlying 
colour do not change. If the blend colour is darker than 50% 
grey, pixels lighter than the underlying colour are replaced, 
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and pixels darker than the underlying colour do not change.

• Vivid Light: This operation burns or dodges the colours by 
decreasing or increasing the brightness depending on the 
colour of the underlying colour. If the colour is lighter than 
50% grey, the blend colour is lightened because the 
contrast is decreased. If the colour is darker than 50% grey, 
the blend colour is darkened because the contrast is 
increased.

• Exclusion: This operation produces a similar result to the 
Difference mode, but with a lower contrast. 

• Dodge: This operation will lighten the colour.

• Burn: This operation will darken the colour.

• Hue: This operation will result in a colour that will take the 
luminosity and saturation of the underlying colour, and the 
hue of the source colour.

• Saturation: This operation will result in a colour that will 
have the same luminosity and hue of the underlying colour, 
and the saturation of the source colour.

• Colour: This operation will result in a colour that will have 
the luminosity of the underlying colour, and the hue and 
saturation of the source colour.

• Luminosity: This operation will result in a colour which has 
the hue and saturation of the underlying colour, and the 
luminosity of the source colour. This mode is opposite to 
the Colour mode. 

It is possible to select two different blending modes in the same Blending effect layer, in the event that  you 
want to export your project to both a Bitmap and an SWF movie file with different results.

Directional-Blur
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The Directional-Blur effect creates the effect of a motion blur that pulls and smears the image from 
one contour edge to a different direction or angle. This effect is useful in creating the impression of 
speed, such as the streaks of colour that follow a car travelling at high speed.

Use the Directional-Blur editor to control the settings of the Directional-Blur effect.

Directional-Blur Property Editor

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the 
elements undergo a change of depth or scale. When this option 
is deselected, the effect's values remain unchanged regardless 
of any depth or scale changes. This option should be 
deselected when multiple drawings are composited and 
attached to this effect.

Radius

Size of the blur. The larger the value, the greater the strength or reach of 
the blur. The blur radius is affected by the drawing scale and camera pos-
ition. Click the Edit Curve button to change these values over time by 
adjusting the function curve.

Falloff Rate

The distance where the blur fades from the edge of the image. Select a 
value between 0 and 1. A fall-off rate of 0 causes the blur to fade out 
slowly, distributing the blur evenly from the edge of the character to the 
farthest edge of the blur. A fall-off rate of 1 causes the blur to fade out 
quickly, so the blur is heaviest closer to the edge of the image.

Angle

The direction of the blur. Enter a value from 0 to 360.

0: Blurs the image to the west.

90: Blurs the image to the south.

180: Blurs the image to the east.

270: Blurs the image to the north.

Direction of trail If you do not set an Angle for the direction of the blur, you can select a dir-
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ection (north, south, east, or west) from this menu. The calculations for 
this feature are faster than the calculations for the Angle setting.

Ignore Alpha
Controls the leading edge of the blur. Deselect this option for a solid or 
hard leading edge on the blur.

Extra Final Blur
Adds a second blur after the Directional-Blur is created. If you have a Dir-
ectional-Blur that begins at 0 and gradually gets stronger, deselect this 
option to ensure a smooth progression.

Number of Iterations
The number of times the blur is applied to the image. A higher number of 
iterations creates smoother transitions between colours and increases 
the blur, but also increases render time.
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 Blur

The Blur-Radial effect creates an effect that softens, fogs or obscures the image evenly in all directions. 
This effect is useful when you want to make cloudy images not realistically seen in detail, such as a 
drawing object that is farther back or in the background of your scene, usually blurry due to the laws 
of atmospheric perspective. Other uses include the general softening of objects such as snow, stars 
and shadows that do not naturally have a hard outline.

Use the Blur-Radial editor to change the values of the Blur effect.

Blur-Radial Properties

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements 
undergo a change of depth or scale. When this option is deselected, the 
effect's values remain unchanged regardless of any depth or scale 
changes. This option should be deselected when multiple drawings are 
composited and attached to this effect.

Radius

Size of the blur. The larger the value, the greater the strength or reach of 
the blur. The blur radius is affected by the drawing scale and camera pos-
ition. Click the Edit Curve button to change these values over time by 
adjusting the function curve.

Quality Select High for a slow and accurate operation or Low for a 
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faster operation with a more raw look.

Brightness and Contrast 

The Brightness and Contrast effect is used to modify the brilliance or dullness of an image or to create 
a greater difference between the lights and darks of an image by increasing their respective 
intensities. This effect can be used when an image appears too flat. Increasing the brightness or 
contrast can give a drawing a more attractive and 3D quality. This can be useful if you want to push 
your background to the rear by making it look dull and flat and pulling your foreground elements to 
the front by giving them a higher contrast.

Use the Brightness and Contrast editor to change the values of the Brightness and Contrast effect.

Brightness and Contrast Effect Properties

Brightness
A value that is less than 0 will darken the image; a value greater than 0 will 
brighten it. Attach a Bezier or Ease function to change the brightness 
over time.

Contrast
A value that is less than 0 will reduce contrast; a value greater than 0 will 
increase contrast. Attach a Bezier or Ease function to change the contrast 
over time.
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Colour-Card 

The Colour Card is a solid background the same size as the camera. The Colour Card lets you fill the 
scene's background with a solid colour when there is no background image. If no background or 
colour card is added to the scene, the resulting export will appear with a black background.

By default, the Colour Card has a Z ordering value of 12 Backward. This puts the Colour card behind 
all elements that have a value lower than 12 Backward. Most of the time, the Colour card will appear 
automatically behind all the scenes elements as they are all set to 0 Backward, unless you have 
changed the Z ordering of the scene components. If so, the Colour Card will be in front of the 
elements that are pushed back to more than 12 fields backward.

Colour Card Effect Properties

Parameter Description

Depth
The value used to determine composition order when the Z value of two 
elements is the same.

Offset Z
The front-back position of the Colour Card layer in 3D space. This value 
can be verified in the Top view.

Red/Green/Blue/Alpha

The colour and transparency of the Colour Card. You can also 
attach these parameters to function columns to change their 
values over time. 

Click the colour swatch to open the Colour Picker window and 
select a colour.
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Colour Swatch Opens the Colour Picker where you can specify the colour.

Colour-Override 

The Colour-Override processes the colours in a drawing layer. The drawings in this layer must be TVG 
files.

Using this effect you can change colours from the palette without affecting the actual palette, swap 
clone palettes, replace a specific colour zone with a bitmap texture or hide and display selected 
colours.

Use the Colour-Override effect to:

• Change colour values in drawings during the compositing process.

• Use colour values from a specific colour palette in the palette list.

• Establish the priority of override palettes in the palette list. For example, you may have different 
clones of the same palette, for example a daytime and nighttime version.

• Isolate specific areas of a drawing by selecting certain colours. For example, using specific 
colours to generate a matte for a glow effect.

• Hide certain colours.

Use the Colour-Override editor to set the colour override operations for TVG elements and their 
drawings.
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Colour-Override Editor Interface

The Colour-Override editor interface  is comprised of four sections: 

• Palettes below

• Colours below

• Palette Overrides on the facing page

• Colour Overrides on the facing page

Palettes

This section displays the palettes in the palette list of the selected layer. Drag these palettes into the 
Palette Overrides section to re-order them. You can load additional palettes in the palette list from 
either your project, by clicking on The Palette  button, or your computer by clicking on the Browse 

 button.

• The Palette  button allows you to load a palette contained within the project hierarchy 
(Environment, Job, Scene and Elements).

• The Browse  button allows you to load a palette located outside the project hierarchy, 
anywhere on your system or server.

Colours

This section displays the colours swatches of the selected palette. Drag a swatch into the Colour-
Overrides section to change its value or drag it into the Selected Colours section to render only that 
colour.
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Palette Overrides

This section forces the use of a particular palette or palette list order, during the composition process. 
You must drag palettes from the Palettes section to change their order. Harmony searches the 
palettes in the order that they appear in the palette list to find the colour values associated with the 
colour IDs of each image. To apply a different version of a colour palette, for example to switch from a 
day to a night palette, use the override section to change the order of colour palettes (you must be 
working with cloned palettes).

Colour Overrides

Drag a swatch from the Colours section to this section to override its value. You can also override a 
colour with a texture.
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Overriding a Colour

With the Colour-Override module, you can change the colour of some swatches. To do so, from the 
Colours section, you must drag the colour swatch to modify to the Colour-Overrides section.

Several options are available to modify your colours.

Once the swatch appears in the Colour-Overrides section, click on the Select Override Mode  button to 
right-click on the Override Colour word and select one of the following option in the drop-down menu:
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• Colour not visible: Renders the selected colour invisible in the Camera view.

• New RGB only: Overrides the colour swatch while maintaining its original alpha value. You can 
select a new colour by pressing the eye dropper  button or clicking directly on the colour 
swatch and choosing a new colour from the Colour Picker window.

• New alpha only: Overrides the swatch's alpha channel while maintaining its original RGB values. 
You can select a new alpha value by pressing the eye dropper  button or clicking directly on 
the colour swatch and choosing an alpha value from the Colour Picker window.

• New RGBA: Overrides the swatch's colour and alpha values. You can select a new colour by 
pressing the eye dropper  button or clicking directly on the colour swatch and choosing an 
alpha value from the Colour Picker window.

Overriding a Colour With a Texture

With the Colour Override module, can apply a texture over a selected colour. Any zone painted with 
the selected colour swatch will be overridden by the selected texture.

How to Apply a Texture Over a Colour

From the Colours section, select the colour swatch to override and drag it to the Colour Override 
section.

1. Once the swatch appears in the Colour Override section, select it and then click on the Select 
Override Mode  button to right-click on the Override Colour word and select one of the following 
option in the drop-down menu:

‣ Texture - Original Matrix

‣ Texture - Global Bbox Matrix

‣ Texture - Global Bbox Centered

‣ Texture - Contour Bbbox Matrix

‣ Texture - Scale to Screen

‣ Override With This Texture Centered on Overridden Objects Centre

‣ Texture - Use Input Peg

2. In the Colour-Override section, under the Texture Filename section, click on "Not used".
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3. Browse for your texture file.

4. Click on the Open button.

There are different ways to apply the texture over your colour:

The result will only be visible in the Camera view while in Render mode. In OpenGL mode, you will see your 
original colour.

The matrix position can be modified using the Edit Gradient and Texture  tool. To do so, your 
drawing zone must be painted with a gradient swatch or texture swatch.
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Texture - Original Matrix

Overrides the swatch's colour with a pattern or texture. You must right-click under the Texture header 
to bring up the Browser window to search for your texture. The texture's default matrix (fixed 
proportion and orientation) is mapped the full size of the bounding box of each colour area to be 
overridden.

Texture - Global Bbox Matrix

Overrides the colour with a texture that is scaled non-proportionally to the size of the bounding box 
encompassing the colour areas to be overridden. With multiple objects, it will look as though their fills 
were all traced and cut from the same piece of stretched or squashed fabric.

Texture - Global Bbox Centered

Overrides the colour with a texture that is scaled proportionally to the size of the bounding box 
encompassing all colour areas to be overridden. With multiple objects, it will look as though their fills 
were all traced and cut from the same piece of fabric.

Texture - Contour Bbox Matrix

Overrides the colour with a disproportionately scaled texture for each individual colour area. In other 
words, each fill area will not only have the texture scaled to its individual proportions, but also 
stretched or squashed to fit within its contours.

Texture - Scale to Screen

Disproportionately scales the texture to the output resolution before applying it as an override.

Override with this Texture Centered on Overridden Objects Centre

Overrides the colour with a texture that is centered in the bounding box encompassing all colour 
areas to be overridden. With multiple objects, it will look as though their fills were all traced and cut 
from the same piece of fabric. The texture will not be stretched or distorted. It will be tiled in 
proportion. The centre of the texture zone will be centered in the middle of the bounding box's 
centre.
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Texture - Use Input Peg

Overrides the colour with a texture that is scaled non-proportionally to the size of the bounding box 
encompassing the colour areas to be overridden. With multiple objects, it will look as though their fills 
were all traced and cut from the same piece of stretched or squashed fabric.

Rendering Selected Colours Only

With the Colour-Override module, you can isolate some colours in your drawing and render those 
ones only.

How to Render Selected Colours

1. From the Colours section, drag the colour swatches to render and drop them into the Render 
Selected Colours section.

You have to enable the Render Selected Colours option for the module to proceed with the operation.

Overriding a Texture on a Pencil Line

A pencil line can be drawn with a texture but also painted with a texture swatch. With the Colour-
Override module, you can either override either the pencil line's texture or texture fill and replace it by 
another one or you can also animate the texture's position.

With the Edit Gradient and Texture  tool, you can modify the size and position for both types of 
texture on a pencil line; the drawing texture and the filling texture. By doing that, you are actually 
modifying the texture's matrix.
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Modifying a Pencil Texture

You can modify and animate a pencil texture's position using the Colour-Override module and a Peg 
module. This lets you create a shaky line style which is a very popular design style. The main issue with 
this style is that it works well in traditional and tradigital animation, when the artist draws the line 
differently on each drawing, but it does not work in cut-out animation where the same drawing is used 
for the entire animation. The same issue happens when the same drawing is held for more than a few 
frames. The line moves during the animation, but stops moving during the drawing hold, which looks 
bad.

With the Colour-Override module, you can animate the position of the pencil line texture 
independently from the drawing exposure. Even if a drawing's exposure is held over several frames, 
the line will move.
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Colour-Scale 

The Colour-Scale effect offsets an images colours. This effect is useful in creating ambient transitions, 
such as from daytime to nighttime.

Use the Colour-Scale editor to set the colour scale effect by entering a value in the scale fields.

The actual colour values of the image are not changed; instead, the channels are multiplied by a 
selected amount. For example:

• If you enter a value of 1, the colour values do not change.

• If you enter a value greater than 1, you increase the colour channel value closer to 255 (or white).

• If you enter a value less than 1, you decrease the colour channel value closer to zero (0 or black).

You can set the colour scale value by entering a value in the field. You can also change the values of the 
colour scale effect over time by attaching it to a Bezier or Ease function curve  and adding 
keyframes.
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Mask

The Mask cuts out a portion of an image using a matte drawing. You can use the Mask to allow a 
character to disappear behind a background element or to cut a virtual hole into the layer itself. The 
Mask requires a matte input.

Use the Mask editor to invert the effect of the matte on an image. Instead of the object being hidden 
by the mask, it will only be visible where it intersects with the matte shape area. 

Glow 

The Glow effect adds a bright soft-edged light or diffuse light region around an image. The Glow 
effect is useful in creating a shining rim around objects such as the sun or stars.
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Use the Glow editor to control the direction of the blur that creates the glow, as well as its colour.

 

Glow Effect Properties

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements 
undergo a change of depth or scale. When this option is deselected, the 
effect's values remain unchanged regardless of any depth or scale 
changes. This option should be deselected when multiple drawings are 
composited and attached to this effect.

Blur Type

Directional: Blurs the matte in the direction you select. For 
example, if a character is walking east, the blur may fall to the 
west. 

Radial: Blurs the edges of the matte evenly around points that 
make up its edge.

Radius
Enter a value for the size of the blur. The larger the value, the greater the 
blur effect. The blur radius is affected by the drawing scale and camera 
position.

Directional Angle

If you select a Blur Directional type, you can select the direction 
of the blur by entering a value from 0 to 360 in this field.

‣ 0: Blurs the image to the west.

‣ 90: Blurs the image to the south.

‣ 180: Blurs the image to the east.

‣ 270: Blurs the image to the north.
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Directional Fall-off Rate

The distance where the blur fades from the edge of the image. 
Select a value between 0 and 1.

‣ A fall-off rate of zero causes the blur to fade out slowly, 
distributing the blur evenly from the edge of the character to 
the farthest edge of the blur.

‣ A fall-off rate of 1 causes the blur to fade out quickly so that 
the blur is heaviest closer to the edge of the image.

Invert Matte
Inverts the matte used to create the glow. The matte will become a black 
silhouette while the glow fills the background space.

Use Source Colour
Uses the colours painted in the matte for the glow effect. If you deselect 
this option, select a colour and alpha values in the Colour section.

Multiplicative Creates a more diffused glow.

Colour Lets you choose the colour and alpha values for the glow effect.

Highlight 

Use the Highlight effect to turn a drawing's area lighter to simulate a light source. To produce the 
highlight effect, you must draw a shape to control where the highlight will appear on the original 
drawing.

The Highlight effect uses a matte to determine the shape and position of the highlight on another 
element and can blur the edges to create a softer effect. Use the Highlight editor to control the type 
and amount of blur, as well as the colour of the highlight effect.
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Highlight Effect Properties

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements 
undergo a change of depth or scale. When this option is deselected, the 
effect's values remain unchanged regardless of any depth or scale 
changes. This option should be deselected when multiple drawings are 
composited and attached to this effect.

Blur Type

Directional: Blurs the matte in the direction you select. For 
example, if a character is walking east, the blur may fall to the 
west. 

Radial: Blurs the edges of the matte evenly around points that 
make up its edge.

Radius
Enter a value for the size of the blur. The larger the value, the greater the 
blur effect. The blur radius is affected by the drawing scale and camera 
position.

Directional Angle

If you select a Blur Directional type, you can select the direction 
of the blur by entering a value from 0 to 360 in this field.

‣ 0: Blurs the image to the west.

‣ 90: Blurs the image to the south.

‣ 180: Blurs the image to the east.

‣ 270: Blurs the image to the north.

Directional Fall-off Rate

The distance where the blur fades from the edge of the image. 
Select a value between 0 and 1.

‣ A fall-off rate of zero causes the blur to fade out slowly, 
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distributing the blur evenly from the edge of the character to 
the farthest edge of the blur.

‣ A fall-off rate of 1 causes the blur to fade out quickly so that 
the blur is heaviest closer to the edge of the image.

Invert Matte
Inverts the matte used to create the glow. The matte will become a black 
silhouette while the glow fills the background space.

Use Matte Colour
Uses the colours in the matte for the highlight effect. If you 
deselect this option, select a colour and alpha values in the 
Colour section.

Multiplicative Creates a more diffused glow.

Colour Lets you choose the colour and alpha values for the glow effect.

Motion-Blur 

The Motion-Blur effect is used to create a faded trail behind objects animated on a motion path. You 
cannot create a Motion-Blur on a hand-drawn animation. The layer must be moving along a trajectory 
(motion path) in order to work properly.

The Motion- Blur effect automatically creates a matte for the drawing layer attached to it, so it is not 
necessary to connect any matte into the Mask layer.

Use the Motion-Blur editor to modify the motion blur, crowd simulation or particle system effect.
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Motion-Blur Effect Properties

Parameter Description

Number of Frames in Trail Number of frames before the current frame that will be used in the trail.

Number of Samples
Number of copies of each drawing used in the trail. The higher the num-
ber, the more continuous the trail appears.

Fall-off Rate

The distance where the blur fades from the edge of the image. 
Select a value between 0 and 1. 

A fall-off rate of 0 causes the trail to fade out slowly, 
distributing the colour evenly from the edge of the character to 
the farthest edge of the trail. 

A fall-off rate of 1 causes the trail to fade out quickly so that the 
trail is more opaque closer to the edge of the image and 
transparent at the end of the trail.

Intensity
Select a value to define the opacity of the trail between 0 and 10. A value 
of 10 will make the trail very dark and almost opaque, where as a value of 
0 will make the trail quite pale and ghostly transparent.

Use Mirror on Edges

When enabled this option appear when the image is close to the edge of 
the camera frame. It forces the software to use a mirror of the image to 
calculate the blur so that it appears on both sides of the drawing object. 
Without this option once your drawing reaches the edge of the Camera 
frame, it gets cropped so does the trail.

Quadmap 

Use the Quadmap transformation layer to deform the shape of an element. For example, you can use 
it to create a drop-shadow effect on an element.
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You can edit the Quadmap visually in the Camera view.

How to edit the Quadmap in the Camera view

1. In the Timeline view, click the Add Layer  button and select Quadmap.

2. Do one of the following:

‣ Connect the Quadmap layer to the drawing layer that you want to deform.

3. In the Tools toolbar, disable the Animate mode to change the value for the Quadmap over the 
entire duration of the element.

4. In the Timeline view, click on the Quadmap layer to select it.

5. From the top menu, select View > Show > Control or press Shift + F11.

The quadmap handles appear around the element in the window. There is also a pivot point at the 
centre of the quadmap frame that you can reposition.

6. In the Camera view window, use the Transform tool to move the points on the quadmap. Shift + 
click to select multiple points.

The value of each point on the quadmap can be changed gradually. To do this, use the Quadmap 
module Layer Properties to attach the points to function curves.
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Only the X and Y values of each point in the quadmap can be changed.

• 2D Path: change the X and Y values simultaneously and control the velocity of the change.

• Separate: change the X and Y values separately. Each of these can be attached to separate 
function curves.

Shadow 

With the Shadow effect, you can turn a drawing into a shadow. It does not matter if your drawing layer 
is a fully coloured character, the Shadow effect will render it into a grey, semi-transparent, slightly 
blurry silhouette. 
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To add a shadow stretched out on the ground, simply add a Quadmap module to flip, stretch and 
skew the matte. Attach the entire effect to the same trajectory as your drawing layer and watch the 
shadow move along with your character. 

Do not forget that you need to connect your character in both the final Composite module and the Shadow 
effect if you want to see your character and its shadow.

Use the Shadow editor to modify the way the Shadow effect is created.

The Shadow effect uses the shape of the drawing connected to create the shadow behind another 
element and can blur the edges to create a softer effect. You can control the type and amount of blur, 
as well as the colour of the shadow, in this dialog box.
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• Truck Factor: Activated by default, this option readjusts the blur when the elements undergo a 
change of depth or scale. When this option is disabled, the effect's values remain unchanged 
regardless of any depth or scale changes. It is recommended that this option be disabled when 
multiple drawings are composited and attached to this effect.
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• Blur Type (Directional or Radial): 

• If Directional is selected, Harmony will blur the matte in the direction you select.

• If Radial is selected, Harmony will blur the edges of the matte evenly around points that make up 
the edge of it. 

• Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The 
blur radius is affected by the drawing scale and camera position.

• Directional Angle: If you select a Directional Blur Type, you can select the direction of the blur 
by entering a value from 0 to 360 in this field.

• 0: blurs the image to the west.

• 90: blurs the image to the south.

• 180: blurs the image to the east.

• 270: blurs the image to the north.

• Directional Fall-off Rate: The distance where the blur fades from the edge of the image. Select a 
value between 0 and 1.

• A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of 
the character to the farthest edge of the blur.

• A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the 
edge of the image.

• Invert Matte: Activate this option to invert the matte used to create the shadow. In the render 
mode, the background will appear grey, while a the matte shape will act as a cut-out window, 
allowing you to see the original background colours beneath. 

• Use Source Colour: Create the shadow using the matte shape's colour. Be sure that you are in 
render mode  to see this effect and that your background is NOT white and that you do 
NOT have a white colour card module attached to the composite. As the shadow matte only 
gives colour information, but no alpha, the matte is automatically multiplied with the 
background colours. If there is no colour card attached and the background appears black, you 
will see the matte colour at full opacity. If it is multiplied with a white background, the colours 
disappear into the full 255.    

• Multiplicative: Multiplies the shadow colours with the background.

• Red/Green/Blue/Alpha: In the RGBA fields, you can enter the value to add or subtract from the 
colour channels in the drawings or you can attach these values to function curves.

Tone 

The Tone effect lets you add a dark-coloured region to your drawing and simulate the shaded area 
away from a light source. To produce the tone effect, create a drawing to control where the tone will 
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appear. The Tone effect uses a matte to determine the shape and position of the tone on your 
drawing and can be blurred at the edges to create a softer effect. 

Use the Tone editor to control the type and amount of blur, as well as the colour of the tone.

Tone Effect Properties 

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the 
elements undergo a change of depth or scale. When disabled, 
the effect's values will remain unchanged regardless of depth 
or scale changes. It is recommended that this option be 
disabled when multiple drawings are composited and attached 
this effect.

Blur Type

Radial: The edges of the matte are blurred evenly around 
points that make up the edge of the matte.

Directional: The matte is blurred in the direction you select.

Radius
Enter a value for the size of the blur. The larger the value, the greater the 
blur effect. The blur radius is affected by the drawing scale and camera 
position.

Directional Angle

If you selected the Directional Blur type, you can set the 
direction of the blur by entering a value from 0 to 360 in this 
field.

0: Blurs the image to the west.
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90: Blurs the image to the south.

180: Blurs the image to the east.

270: Blurs the image to the north.

Directional Falloff Rate

The distance where the blur fades from the edge of the image. 
Select a value between 0 and 1.

0: Makes the blur fade out slowly, distributing the blur evenly 
from the edge of the character to the farthest edge of the blur.

1: Makes the blur fade out quickly. The blur is heaviest closer to 
the edge of the image.

Invert Matte Inverts the matte used to create the tone.

Use Matte Colour Uses the matte shape colour to create the tone.

Multiplicative Multiplies the tone colours with the background.

Colour

Red Red values of the image.

Green Green values of the image.

Blue Blue values of the image.

Alpha Alpha values of the image.

Colour Swatch
Opens the Colour Picker where you can specify the colour of the main 
flare.

Transparency 

The Transparency effect is used to make an image partially transparent. The Transparency effect is 
useful when fading images in and out, such as a phantom or to make something partially see-through, 
such as a window.
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Use the Transparency editor to control how translucent the element should be.

You can enter a value in the Transparency field or change the transparency value over time by linking it 
to a function curve. Entering a value of 100 in the Transparency field will make the element 100% 
transparent, in other words, invisible. Entering a value of 0 will render the element completely opaque.

It is also possible to adjust a layer/module's transparency directly in the Layer Properties window without 
using the Transparency module. In the layer's properties, go to the Drawing tab and adjust the Opacity 
parameter. This parameter is visible in OpenGL mode.
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Previewing and Playing Back Effects 

To preview your effects, you will have to perform a quick render. Effects must be calculated before 
they can be viewed in real time.

How to preview effects

1. In the Playback toolbar, click the Render and Play  button.

The Play module opens and loads the frames.

2. Once the frames are loaded, click the Play  button in the Play window.

Tip: While previewing effects, press Spacebar to stop and start playback.

Preview Resolution 

To make your previews calculate faster, you may want to render them out at a smaller resolution. You 
can use the Preview Resolution command so you will not have to modify the resolution of your scene 
every time you make a check preview.

The Preview Resolution command allows you to quickly ask for a preview at either a quarter, half or 
three-quarter of the scene resolution. You can even customize the preview resolution size.

How to use the Preview Resolution command

1. From the top menu, select View > Preview Resolutionand a resolution: Same as Scene 
Resolution, 3/4 of Scene Resolution, 1/2 of Scene Resolution, 1/3 of Scene Resolution, 1/4 of 
Scene ResolutionorCustom.

If you selected the Custom option, the Custom Preview Resolution dialog box opens.
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2. In the dialog box, select a resolution from the presets or type a new X-Y value.

3. Click OK.

4. Preview your effects animation.
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Chapter 6: Export

Now that you have finished your animation, it is time to render your movie. Depending on whether you 
plan to further edit your movie in a third party software, composite the movie in a larger body of work 
or put it up directly on the web, Harmony supports several formats for all your rendering needs.

This chapter contains the following topics:

• Exporting a QuickTime Movie on the next page

• Exporting an SWF Movie on page 983

• Exporting OpenGL Frames on page 985

• Batch Rendering on page 987
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Exporting a QuickTime Movie

If you require a video file, you can export your animation as a QuickTime movie. To render a 
QuickTime movie with transparency, you need to set the Depth setting to Millions of Colours +.

If your exported video is too small or too large, change the project size from the top menu in Scene > 
Scene Settings. This will change the size of the video output.

How to export a QuickTime Movie

1. From the top menu, select File > Export > Movie.

The Export to QuickTime Movie dialog box opens.

2. Click Browse and select a folder in which to save your movie and give it an appropriate file name 
for the export.

3. Click OK.

4. In the Display Source section, select the Display module to use for rendering your project.

5. From the Export Range section, decide whether you want to export the entire scene (All) or a 
specific frame range. If you decide on the latter, enter the frame range.

6. In the Resolution section, select one of the following from the menu:

‣ A preferred resolution ratio.

‣ Custom:  Enables the Width and Height fields so you can enter a specific size.
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7. In the Options section, click Movie Options.

Parameter Description

Video

Enables the customization of the video settings, filters and 
size.

Settings: Opens the Standard Video Compression Settings 
dialog box (see below).

Filter: Opens the Choose Video Filter dialog box, where 
you can select from a range of filters to apply to your video 
export.

Size: Opens the Export Size Settings dialog box. The size 
settings are overridden by the Harmony's scene settings.

Sound

Check this box to enable the customization of the sound set-
tings.

Settings: Opens the Sound Settings dialog box (see 
below).

Prepare for Internet Stream-
ing

Select this option to enable the customization of the Inter-
net streaming options.

8. In the Video section, click Settings.

The Standard Video Compression Settings dialog box opens.
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9. From the Compression Type menu, select a codec. The availability of certain compression settings 
depends on the Compression Type selected. For example, Animation is the default compression 
type and as a result the Data Rate option is greyed out. 

10. In the Motion section, choose a Frame Rate from the list. 

By default, it is set to match the frames-per-second (fps) of your Harmony project. If you choose a 
lower frame rate, your export playback will be faster than your actual project. The reverse is also 
true for a higher frame rate. 

11. If you want key frames inserted, select the Every option and set the number per frame. 

This is the option is recommended by QuickTime. Refer to the QuickTime documentation for further 
details.

12. In the Compressor section, choose a Depth based on your movie’s needs. For example, Millions of 
Colours+ houses an alpha channel.

13. In the Quality section, use the slider to choose a quality setting. Remember that the better the 
quality of the export, the larger the file.

14. From the Data Rate section, either choose to allow the program to automatically select the most 
optimal bit rate, or enter a Restricted rate to save space and allow for faster downloading at a cost 
to the quality of the export. 

15. In the same section, from the Optimized For menu, select the intended viewing method for the 
export.

16. Click OK.

17. From the Movie Settings dialog box, click Sound Settings.

The Sound Settings dialog box opens.
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18. From the Compressor menu, select a compression type. 

The default setting is None. This will preserve your original sound file without the loss of information. 
However, an uncompressed sound file will inevitably add “weight” to the overall size of your video 
export.

19. Select a Rate by pressing the arrow button next to kHz.

It is best to check and match the original properties of your sound file. For example, if your file has an 
audio sample rate of 48 kHz and you choose a conversion rate of 22.05 kHz, the sound will play at 
the same speed, but with higher frequencies missing.

For a standard film sound quality, choose 44.1 kHz, or 48 kHz for DVD quality. Anything less will 
make the sound “dull” or less bright. For things like recorded voice this doesn't matter so much, but 
for music it can make an audible difference.

If file size is a consideration, such as with videos for the Internet, then a lower rate might be more 
practical.

20. Next, choose the Size and the Use, which are related. Once again, it is advisable to check your 
original sound file properties. If the file was recorded in one channel (mono), there is little point in 
choosing the two channel (stereo) option. Although Mono can support a 16-bit channel, the extra 
information is unnecessary. Mono is generally paired with 8-bit and Stereo with 16-bit.

21. Click OK.

22. In the Export to QuickTime Movie dialog box, click OK.

A progress bar appears.

23. Browse to the location on your computer where you saved your QuickTime video and double-click on 
it to view the export.

How to set the depth to Millions of Colours + to export a QuickTime movie with 
transparency

‣ In the Standard Video Compression Settings dialog box, select Millions of Colors+ from the Depth 
menu—see Exporting a QuickTime Movie on page 976.
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Exporting Image Sequences

In Harmony, you can export scene as a bitmap image sequence. If there is sound in your scene, it will 
not be exported with the images.

If you want to export images with transparency, you need to select the file type that supports this 
option, such as TGA, PSD or PNG. The Colour Mode menu changes according to the File Type 
selected. For example, selecting TIF will result in only having "Colour" as a Colour Mode option, 
whereas PNG will have "Colour" and "Colour with Transparency".

How to render an Image Sequence

1. From the top menu, select File > Export > Images or press Ctrl + Shift + Y (Windows/Linux) or ⌘  
+ Shift + Y (Mac OS X).
The Export Images dialog box opens.

2. In the Output section, choose a prefix. The prefix is the file name. Each image in the sequence will 
have this name, plus a sequence number and file format extension. For example final-0001.jpg.

3. Click Browse and specify the location in which your movie will be saved. The default location is in 
the file directory’s frames folder.

4. In the Format section, choose the File Type, Colour Mode and Colour Depth from their respective 
drop-down menus.

5. In the Range section, select the Frame Range to render.

‣ All Frames: Exports export the entire scene.

‣ Selected Frames: Lets you specify the first and last frame of the frame range to export.

6. Select the Preview option to see the images being rendered.

7. Click OK.

If you selected the Preview option, a generic player opens so you can watch the image sequence 
strung together as a video. The image sequence is now available in the scene’s frames directory. 
You should be able to preview each frame as an individual image.

How to render an image sequence with transparency

1. Open the Export Images dialog box and select Format > Colour Mode > Colour with 
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Transparency from the menu.
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Exporting an SWF Movie

The SWF export supports some bitmap effects (which can be previewed in Render View  mode) 
and SWF Blend Modes (vector effects which can be previewed in OpenGL View  mode). 

The following are also supported:

• Pencil line thickness: They are converted to brush strokes in the SWF file.

• Auto Patch module for creating joint patches.

If you have not already done so, you should preview the SWF by using the SWF preview  button to 
see what the two types of effects look like when blended together. Once you are satisfied with the 
results, go ahead and export your movie. 

How to export a SWF movie

1. From the top menu, select File > Export > SWF.

The Export to Flash Movie (SWF) dialog box opens.

2. Click Browse and choose an appropriate file name and a destination path for your movie.

3. In the Display Source section, select a Display module to read from in the Export From Display 
Module menu.

4. In the Export Range section, select one of the following options:

‣ All: To export all the frames of your movie.

‣ Frames: To export a frame range. Enter the frame range in the fields.
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5. In the Options section, enter your Frame rate (fps). By default, it will be set to match the fps of your 
Harmony project. If you choose a lower frame rate, your export playback will be faster than your 
actual project. The reverse is also true for a higher frame rate. 

6. In the same section, select the JPEG quality:

‣ 100 = Full quality

‣ 50 = Average quality at about 1/5th of the size.

‣ 25 = Medium quality where loss of high image resolution starts to occur.

‣ 10 = Low quality where “macro-blocking” or large pixelation become obvious.

‣ 1 = Lowest quality where there is extreme loss of colour and detail and the image becomes 
nearly unrecognizable. 

7. If you want to prevent your movie from being imported in another application, select the Protect 
from Import option.

8. Select the Compress Movie option if you want to get a lighter format. The movie may lose some 
quality, but the file will be lighter.

9. In the Disabled Effects section, select the effects you do NOT want to be rendered in the SWF 
movie.

Note that certain Harmony effects are not listed in this section as they are not compatible and 
therefore not available for SWF export. These effects will not appear in the SWF render. 

10. Click OK.

11. Browse to the location on your computer where you saved your Flash Movie and double-click on it 
to view the export.
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Exporting OpenGL Frames

You can export the OpenGL frames (fast display mode) if you need a quick render for your scene. 
Some heavier scenes containing 3D, multiple effects and camera moves can be fairly long to export.

Use the Export OpenGL Frames dialog box to select the frames you want to render from the OpenGL 
Camera view, then save the rendered frames as image files or as a QuickTime movie.

Frames saved from OpenGL view have neither antialiasing nor special effects. To render final frames 
with effects, export Images or a Movie.

How to export OpenGL Frames

1. From the top menu, select File > Export > OpenGL Frames.

The Export OpenGL Frames dialog box opens.

2. In the Output section, in the Location field, click Browse to select a folder for the frames.

3. In the Filename field, enter a name (prefix) for the frames or revert to the default name by clicking 
Default.

4. In the Format section, decide if you want to export individual image frames or a movie.

‣ Suffix: Lets you select the desired suffix. If you intend to render only a few frames, use 1 or 
01, whereas if you intend to render 1000 frames, you can select 0001.

‣ Drawing Type: Lets you select the file type to render, such as TGA or SGI. 

5. Click Movie Options to customize the Audio and Video settings for the *.mov export—see 
Exporting a QuickTime Movie on page 976. 

6. From the Resolution section, select a resolution for export. If you are running some quick tests, 
then you might want to reduce the resolution to save time and space. You also have the option to 
set a Custom width and height to produce smaller or larger frames.

7. In the Range section, decide whether you want to render all your frames, a range of frames, the 
current frame or selected frames.

985



Chapter 6: Export     Exporting OpenGL Frames

8. Use the Display menu to select a Display module to use for rendering your OpenGL frames from.

9. Click OK.

986



Toon Boom Harmony 11.1 Draw Guide (Network)

Batch Rendering

Harmony Network has the possibility to render your scene locally or send it to a render farm so other 
computers can render your scenes while you continue working on your station. This option is not 
available with Harmony Stand Alone. The Harmony Network rendering processed are named:

• Local Rendering is done directly on the user machine using its CPU. To perform local rendering 
you must use Harmony Stage. 

• Batch Rendering lets you send a scene to render while you continue working in Harmony Stage. 
This way, you do not have to wait for the application to complete the render process. 

Batch rendering is a background process divided over several machines, or a render farm. Sending 
your scene to batch render will share the rendering load with other machines in the render farm and 
lessen the amount of work required by your computer. 

Refer to the Control Center and Server Guide to learn how to send scenes to batch render and check the 
status of the Render queue. 

How to send a scene to the batch rendering queue

1. Save all the contents of your scene, all drawings, colour palettes and the palette list. 

2. Select File > Save or press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X).

3. From the top menu, select File > Export > Export Images or press Ctrl + Shift + Y 
(Windows/Linux) or ⌘  + Shift + Y (Mac OS X).

If the system administrator did not complete the resolution configuration tasks, a warning 
message will open. This message notifies you that the resolution.conf file was not properly 
inserted in the configuration folder. 
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4. Click OK to continue. You will still be able to render your scene. 

The Export Images dialog box opens. 

5. In the Output section, add a prefix to the images to be output and the path to the location in which 
the files will be stored.

6. In the Format section, select a file type from the File Type list.

7. In the Colour Mode list, select an option to export your images: Colour, Colour with 
Transparency, or Greyscale.

8. In the Colour Depth menu, select the number of bits you want for your images.

9. In the Range section, select the frames you want to render: 

‣ All Frames: Sends all the frames in the scene to be rendered.

‣ Selected Frames: Sends a range of frames to be rendered. 

10. Select the Batch Composite option. 

11. Select the Chunk option if you want to split the frames into sets of frames or QuickTime movie into 
small chunks. Note that when the render farm (server) is done rendering all the small movie chunks, 
it will put them all back together to create one single movie file.

12. In the Size (Frames) field, enter the number of frames for each chunk. For example, if your scene is 
100 frames long and you enter a value of 20, there would be five entries in the queue of 20 frames 
each. 
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13. From the Camera menu, select the camera for rendering the scene's images. These are the Camera 
modules you created in your scene. 

14. Click OK to start the rendering process. 

A confirmation dialog box opens to inform you that the frames have been sent to the Render 
queue. 

‣ If the selected frames were already sent to the Render queue, a notification dialog box 
opens to inform you that these frames were already in the queue, but that they have been 
updated with the latest rendering request. 

You can also send scenes to batch rendering and check the status of the rendering queue from the 
Control Center module. 
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Glossary

alpha channel

The image's channel carrying the transparency information. An 
image already has three channels: red, green and blue (RGB). The 
alpha channel is the fourth channel (RGBA). The matte, or the 
transparency information, is stored in this fourth channel. An image 
without an alpha channel is always opaque.

animatic

A movie with sound that is developed from the storyboard. The 
storyboard panel is exposed for the duration of the scene and at 
times, the characters are placed on a trajectory to indicate motion. 
The camera moves are also animated. The animatic is used to 
determine the rhythm of a project and provides a good overview of 
the project before beginning production.

animation
A simulation of movement created by displaying a series of pictures 
or frames.

anime
An animation style known for its sinister and dark feel; popular in 
Japan.

arc

Action rarely occurs in a straight-forward manner; rather it typically 
unfolds in what storytellers refer to as an arc. The purpose of a 
story arc is to move a character or a situation from one state or 
scenario to the next.

aspect ratio
The relationship between the width and height dimensions for any 
scene, frame or film format. Television ratio is 4:3 and widescreen 
ratio is 16:9.

auto-feed

An automated method of feeding drawings into a scanner in which 
multiple drawings are stacked into a sheet feeder. When the 
scanner is activated, the drawings are scanned consecutively, 
without further user intervention.

automatic lip-sync detection
Automatically mapping drawings in an element to the mouth chart 
generated for a sound. This can save time when lip-syncing a voice 
track.

axis

An imaginary line around which an object rotates.

For 2D graphics, there are two axes:

• X: Horizontal

• Y: Vertical

For 3D graphics, there are three axes:

• X: Horizontal

• Y: Vertical

• Z: Depth

background
The part of a scene that is farthest to the rear. The background is 
the artwork, or decor, against which the animation takes place.

Bézier A method of defining curved lines invented by French 
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mathematician Pierre Bézier. A Bézier curve is a mathematical or 
parametric curve. Bézier curves use at least three points to define a 
curve. 

In Toon Boom, a function can be hooked to a Bézier curve and vary 
along with the curve value information. Bézier curves are also very 
useful in vector graphics. They are used to model smooth curves 
and can be scaled indefinitely.

bitmap
An image composed of pixels with a single resolution (size). If it is 
enlarged too much, it will lose definition and pixels will begin to 
appear. This is known as pixelation.

breakdown

In cut-out animation, breakdown is the action of breaking a 
character into pieces to create a puppet with articulations. To 
break down a character, the artist cuts part, such as hands and 
arms, from the character's model and pastes them in separate 
layers. Next, the joints are fixed and the pivots set.

In traditional animation, a breakdown is an animation pose 
generally found between two key poses. The key poses are the 
main poses in an animation and the breakdowns are secondary 
poses, ones that help to describe the motion and the rotation 
curve.

camera shake
Camera shake occurs in a scene when the camera moves slightly 
and quickly in several directions. This gives the impression of an 
impact, vibration or, for example, bumps on the road.

caption
In a storyboard, a caption is a text field containing dialogue, 
effects, sound, or slugging information.

cel

In traditional animation, a cel, also known as a celluloid, is a 
transparent sheet on which the animation is inked and painted 
before being sent to the camera.The picture's outline is drawn on 
the front of the cel and then coloured along the back. 

In Toon Boom, a cel is an individual space encountered in an 
Xsheet's column, from which you can expose a drawing or a 
function`s coordinate.

character design
Each character in an animated film is drawn from multiple angles in 
poster-style format, called a model sheet, which serves as a 
reference for the animators.

clean up 

After rough drawings have been tested and approved, all the noise 
in the image (excess lines, notes, etc) is removed to create final 
drawings which can be inked, painted and shot. The cleanup 
process refers to either tracing a clean line over a rough drawing to 
achieve the final version, or removing dirt and extra lines left by the 
scanning process.

CMYK
Cyan, Magenta, Yellow, Black. Refers to the process used by 
printers to define colour on the printed page.

colour card
A Colour Card is a solid colour card that is the same size as the 
camera. The Colour Card can be used to fill the background with a 
solid colour when there is no background image included.
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colour model

In animation, a colour model is the official colour design that must 
be used to paint the animation. A model is the definitive character, 
prop, or location design that each artist must follow for the 
production. 

colour wheel A display of the colour spectrum in the form of a circle. 

compositing

Compositing is the action of incorporating all of a scene's elements 
to create the final result prior to rendering. For example, the 
compositing artist will import all the animation sequences, 
background, overlays and underlays in the scene and position them 
correctly. The artist will then set the camera frame and animate it, if 
needed. Finally, the animator will create all the computer-
generated effects for the project.

cross dissolve An effect used to fade two scenes, one into the other.

cut
A direct transition between two scenes. When a cut is used, there 
are no transition effects inserted to pass from one scene to the 
next. The first scene ends and the second one starts immediately.

cut-out animation
The action of animating characters made of several pieces by 
moving them around frame by frame. Cut-out animation can either 
be computer generated or done traditionally using paper.

cycle
A group of images that together make up an action, such as 
walking. A cycle is an action repeated as a loop over a period of 
time. It can be a series of animated drawings or keyframes. 

dialogue The text spoken by a character in a movie or animation.

dope sheet

Used by animators, directors and other members of a crew to 
track the sequence and timing of images, dialogue, sound effects, 
sound tracks and camera moves. Also known as an exposure sheet 
or Xsheet.

doping To assig a particular drawing to a range of frames.

DPI

Dots Per Inch is the standard measure of resolution for 
computerized printers. It is sometimes applied to screens, in which 
case it should more accurately be referred to as pixels per inch. 
Either way, the dot is the smallest discrete element making up the 
image.

ease/velocity

In animation, the ease, also known as velocity, is the acceleration 
and deceleration of a motion. It can be a motion created by a 
function curve, or a series of animated drawings. Other common 
terms for ease-in and ease-out are slow-in and slow-out.

ease-in
Gradual acceleration in the action. Another common term for ease-
in is slow-in.

ease-out 
Gradual deceleration in the action. Another common term for ease-
out is slow-out.

establishing shot
A scene in which the viewer can see the whole area in which a 
sequence is happening. For example, if a child is playing on the 
ground in front of his house, the establishing shot would be a scene 
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where the viewer can see the house, the ground, a part of the 
street and the buildings around the central point of action. This 
helps the viewer understand the story location and scene 
orientation.

exposure
In animation, an exposure is the number of cels on which a drawing 
appears in the scene. For a drawing to appear longer, the 
exposure must be extended over a greater number of cels.

exposure sheet (Xsheet)

The exposure sheet or Xsheet, is a sheet with several vertical 
columns and horizontal frames used to indicate a scene's timing.

Each column represents a scene's layer. In each column, the 
drawing's numbers are indicated and repeated over the particular 
amount of frames they need to appear.

The exposure sheet is used by animators, directors and other 
members of a crew to track the sequence and timing of images, 
dialogue, sound effects, sound tracks and camera moves. Also 
known as a dope sheet.

fade in/fade out

Fade in or fade out is a transition effect used to open or close a 
sequence. A fade in occurs when the first scene appears 
progressively, from complete transparency to its complete opacity. 
A fade out occurs when the last scene progressively disappears, 
going from complete opacity to complete transparency.

fast-in Dramatic acceleration at the start of the action.

fast-out Dramatic acceleration at the end of the action.

field
In animation, a field is a measurement unit used to calculate 
motion, registration and camera positioning. A standard animation 
scene will vary between 6 to 12 fields.

field chart
A guide containing all the field units that animation and layout artists use to 
determine a scene size or camera motion.

film-1.33 
Use this resolution setting for the widescreen film format that 
conforms to the standard 4:3 pixel aspect ratio.

film-1.66 
Use this resolution setting for the widescreen film format that 
conforms to the 16:9 pixel aspect ratio. (The pixels are wider than 
they are high).

flipping

In traditional animation, flipping is the action of going through the 
drawings of an animation sequence very quickly in order to see the 
animation in motion. Flipping can also be the action of creating a 
mirror transformation of an object.

follow-through

The follow-through is the secondary motion caused by the main 
action. For example, a character wearing a cloak is running. The 
main action is the body running. This will cause the cloak to follow 
the motion, although it will not move at the same time, but react a 
few frames later and follow the main motion curve.

forward kinematics
Forward kinematics is a feature used to animate principally 3D 
characters and cut-out puppets with hierarchy. It is used to animate 
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a puppet from one of parent parts, such as a shoulder, and make 
the rest of the arm move with it as a single piece.

frame

A frame is a single photographic image in a movie. In traditional 
animation, the North American standard generally contains 24 
frames per second, while in Europe the standard is 25 frames per 
second.

frame rate

This is the measurement of the frequency (rate) at which an imaging 
device produces unique consecutive images, called frames. The 
term applies equally to computer graphics, video cameras, film 
cameras, and motion capture systems.

Frame rate is most often expressed in frames per second (FPS) and 
in progressive-scan monitors as hertz (Hz).

The frame rate is the speed at which the frames are played. They 
are generally calculated by frame per second. For example, a scene 
could be played back at 12, 24, 25, 30 or 60 frames per second or 
any other number

functions

A function is a computer generated motion, trajectory or path that 
elements, other trajectories and effects parameters can be 
attached to. The function can be controlled by adding keyframes 
and control points on the function curve.

gamut The range of colours that a particular device can represent.

HDTV 

High Definition Television delivers a higher quality image than 
standard television does because it has a greater number of lines 
of resolution. To take advantage of the superior quality and make 
full use of your resolution setting, your output device must be 
compatible with HDTV technology.

hold
This is a frame in the animation in which the character maintains its 
position without moving. A hold can be created between any two 
keyframes.

HSV
Hue, Saturation, Value. A method of defining colours in terms of 
hue (tint), saturation (shade) and value (tone or luminance).

in-between
The drawings that exist between the key poses. These are drawn 
to create fluid transitions between poses.

ink and paint
The ink and paint process is the action of painting the empty zones 
and colouring the lines on the final animation drawings, while 
following a colour model.

interpolation
In animation, the interpolation is the computer generated motion 
created between two keyframes. You have the choice to create 
interpolation, or not, between your keyframes.

jump cut

A jump cut is a jerky cut between two scenes. Typically, a jump cut 
is not visually pleasing. It is generally caused by one scene ending, 
and a second one starting, with similar a image. The lack of 
difference causes the eye to see a little jump between the two 
scenes. 
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key pose

Important positions in the action defining the starting and ending 
points of any smooth transition. Keys, or key poses, are the main 
drawings in an animation sequence describing the motion. For 
example, if an arm is waving, the keys will be of the arm at one 
extremity of the wave motion and the other extremity. By flipping 
those drawings, the animator can see the skeleton of the motion 
without having all of the drawings.

keyboard shortcuts 

One or more keyboard keys which, when used, cause an operation 
to be performed. Keyboard shortcuts are used throughout the 
Toon Boom software and form an integral part of the workflow. It 
is, in most cases, possible to customize the shortcuts in the 
Preferences dialog of the software.

The shortcuts are written as follows in the Toon Boom user 
documentation: Each key in a sequence is shown inside square 
brackets as in: [Ctrl]+[A]. The brackets "[ ]"  separate the key from 
the plus  sign (+). Neither the brackets, nor the plus sign are part of 
the sequence. To use a shortcut, press the key and the character 
simultaneously.

keyframe 
Important positions in the action defining the starting and ending 
points of any action. A keyframe is a computer generated position 
at a specific moment (frame) on a given trajectory.

layer
In animation, a layer is an individual column, level or character. A 
scene's layers are superposed to form the final image.

layout

The layout process is the communication step between the 
storyboard and the animation. The layout and posing process is 
the action of putting the storyboard on model, that is drawing the 
character following the design in the model pack, so that the 
animator can start his work. The layout artist will draw the 
background, create the camera and field guide matching the scene 
and the camera motion. Lastly, he will draw on model the main 
action poses.

layout and posing
The action of putting on model, that is, at the right scale, the 
storyboard for the animator to start his work.

library
A library is a storage area containing templates and assets that can 
be reused in any project or scenes.

light table
The Light Table feature allows you to see the other layers in 
transparency while you are working on a particular one in the 
Drawing view.

line of action
Direction that the action will follow. Also known as the Path of 
Action

lip-sync
The lip-sync is the character`s mouth synchronization with the 
dialogue sound track. Frame by frame, the mouth will be adjusted 
to fit the sound to give the illusion of the character is speaking.

low resolution
This format is ideal for videos destined for the web, where size and 
fast download of a video file might take precedence over quality. A 
low-resolution image is one that lacks fine detail.
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manual lip-sync detection

The manual swapping of mouth position drawings to match a voice 
track. For this process, both sound scrubbing (listening to a sound 
wave broken up frame-by-frame) and drawing substitutions from 
the Library view are used.

master palette

A master palette is a group of colours attributed to a character or 
a prop. The palette is used throughout the entire production to 
maintain consistency in the look and to ensure that the same 
colours are used throughout the production. Also known as 
palette.

model/colour model

In animation, a model is the definitive character, prop or location 
design that each artist must follow for the production. A colour 
model is the official colour design that must be used to paint the 
animation.

motion keyframe 
In Toon Boom, the motion keyframe is a keyframe with computer-
generated interpolation.

mouth chart 

Adding a lip-sync to a project can really enhance its quality and 
storytelling. However, it can be difficult to shape a character's 
mouth so that it matches the sound at the precise frame. To solve 
this problem, Toon Boom provides a lip-sync feature which 
analyses the contents of a sound element and generates a mouth 
chart based on the eight animation phonemes (A, B, C, D, E, F, G, 
and X, which is used to represent silence).

multiplane 

The effect of passing through multiple levels of drawings to create 
a sense of depth in a shot. A multiplane is a scene in which the 
layers are placed at different distances from the camera so that 
when the camera moves, a depth illusion occurs. With a multiplane, 
all the perspective and scale is calculated automatically.

NTSC

The standard analogue television broadcasting system used in 
North America. NTSC conforms to North American standards on 
how rectangular pixels are displayed for computer and television 
screens.

nudge
A small push (left, right, up, down, forward or backward) done 
with the keyboard arrow keys on a selected element. Nudging is 
used to move a selection very slightly and precisely.

onion skin
A feature that lets you see the previous and next drawings of a 
sequence.

overlay
A part of the scene environment, such as a chair or a bush, that is 
placed in front of the main animation.

PAL
A resolution that works best with the European format for 
television and computer screens, as the rectangular pixels are 
displayed at a different orientation.

palette/master palette

A palette or master palette is a group of colours attributed to a 
character or a prop. The palette is used throughout the entire 
project to maintain a consistency in the look and avoid the colour 
changing during the animation. Also referred to as a master 
palette.
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palette style

A palette style is a second version of an existing palette with a 
slight change in the tint and value. A palette style can be used to 
create the night version of a palette. It may also be called a clone 
palette.

pan To move the camera across the scene in any direction.

panel 
In a storyboard, a panel is a frame in a shot. A shot can be 
composed of one or several panels.

paperless animation/tradigital
The paperless animation process is the action of animating 
digitally. The main paperless animation process is to draw, frame 
by frame, the animation directly in the software.

passing position 
When drawing a walk sequence for a character, the passing 
position is the point at which one leg passes the other.

path of action
Direction that the action will follow. Also known as the Line of 
Action.

peg

In traditional animation, a tool used to ensure accurate registration 
of action as cel layers move. In digital animation, in which you are 
doing a more advanced puppet rigging, you can use peg layers. 
Peg layers are trajectory layers that do not contain drawings. They 
are motion paths that you can use to add path articulations. For 
the latter, you can also use the Inverse Kinematics tool.

phoneme Unit of sound in a language.

pivot A pivot is the point around which a peg or a drawing rotates.

pixel

Smallest element of an image displayed on a monitor or TV screen.

Pixel, short for Picture Element, is a single point in a graphic image. 
It is a small sample of an image, a dot, a square, or a very small 
section made out of smooth filtering. If you zoom in close enough 
on a digital image, you will see the pixels, which look like small 
squares of different colours and intensity.

pose-to-pose animation

The pose-to-pose animation process is the action of creating all the 
main action poses, called key poses, and then placing the 
secondary poses between the keys. The secondary poses are 
called breakdown. Finally, the animator fills the gaps with the in-
between drawings to achieve a smooth animation.

rendering 

The final step when animating by computer. During rendering, the 
computer takes each pixel that appears on screen and processes 
all of the components as well as adding motion blur before it 
produces a final image. In animation, the rendering process is the 
action of calculating the final images after the compositing 
process.

resolution

The resolution is the size of a scene, generally calculated in pixel. 
For example, the NTSC resolution is 720 x 480. Resolution type 
should match your final output: HDTV, film-1.33, film-1.66, NTSC, 
PAL, low.

RGB Red, Green, Blue: method of defining colour by specifying amounts 
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of these three colour components.

rigging 
The rigging process is the action of attaching the cut-out puppet 
parts one to the other.

rotary table
The Rotary Table is equivalent to the animation disk/table and 
allows one to rotate the workspace to be more comfortable while 
drawing.

rotoscoping 

Is an animation technique in which animators trace over live-action 
film movement, frame by frame, for use in animated films. The act 
of sketching over live-action footage to create an animated 
sequence.

roughs 
The roughs are the skeleton sketch of an animation or a design. 
Roughs mainly consist of sketch lines and shapes, though they can 
also contain design details.

safey area

In animation and movie parlance, the safey area is the zone at the 
centre of the scene's frame, one safe from being cropped by the TV 
frame. As a TV frame cuts a margin off the original frame size, 
maintaining a safey area ensures that the scene's main action will 
remain clearly visible once the film is screened on television.

scene 
A scene is a shot in a movie or show. A sequence is composed of 
several scenes. A scene changes to another scene by a simple cut, 
or a transition.

script 

The script is the original text containing all the movie or show 
information. In animation, the script contains all of the location 
descriptions, dialogues, time and more. A project starts with a 
script.

sequence 
In animation, a sequence is a series of scenes or shots forming a 
distinct part of the story or movie, usually connected by unity of 
location or time.

shot 
A shot is a scene in a movie or show. A sequence is composed of 
several shots. A shot changes to another shot by a simple cut, or a 
transition.

slow-in
Gradual acceleration in the action. Another common term for slow-
in is ease-in.

slow-out 
Gradual deceleration in the action. Another common term for slow-
out is ease-out.

slugging
In Storyboard Pro, slugging refers to indicating the start and stop 
times of dialogue and relevant actions.

sound scrubbing
A process that lets you hear sound in real time while you move the 
playhead forward or backward. This is very useful for finely-tuned 
lip-syncing.

stop-motion keyframe 
A stop-motion keyframe is a keyframe with no computer generated 
interpolation.

storyboard 
A visual plan of all the scenes and shots in an animation. The 
storyboard indicates what will happen, when it will happen and 
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how the objects in a scene are laid out.

straight-ahead 

A technique in which an entire sequence is drawn from the first 
position to the last, in order. There is very little planning in this 
methodology, and where the character ends up and how it gets 
there can be a surprise for both the audience and the animator. 
While this approach is a lot more spontaneous and creative, it can 
create inaccurate results.

strokes
Strokes are invisible vector lines forming the drawing zones. They 
can be adjusted with Bézier handles.

tablet/pen 
Device used in conjunction with, or instead of, a mouse to move a 
mouse pointer (sometimes referred to as the cursor) around the 
computer screen.

template 

In Toon Boom, a template is an asset stored in the library, one that 
can be reused in any project. A template can be a drawing, a series 
of keyframes, a sound file, a panel, a cut-out character, an effect, a 
trajectory, an animation, or anything else used in the software.

thumbnails A thumbnail is a very small image used as a reference or indicator.

timecode 
Timecode is timing information printed on a movie clip to indicate 
what scene, hour, minute and second is currently displayed on the 
screen.

timeline 
The timeline is a horizontal representation of the scene`s elements, 
timing and keyframes.

trace and paint 

After the rough animations have gone through cleanup and a final 
line or pencil test, each drawing is traced and painted for the final 
animation. In today's digital world, this may be done in a variety 
ways other than via the traditional celluloid or acetate methods.

track breakdown 
The soundtrack for animated film is broken down into individual 
sounds documenting the precise frame-by-frame position of each 
sound.

traditional animation 
The traditional animation process is the action of drawing on paper 
all of the animation sequences, before either scanning them or 
inking them on cels.

trajectory 
A computer generated path or trajectory that elements can follow. 
The trajectory can be controlled by control points, keyframes and 
velocity.

transition 
A transition is an effect placed between two scenes as they pass 
from one to the other. Common transition effects are cross-
dissolve and wipe.

underlay
In animation, an underlay is a specific part of the decor placed 
behind the main animation.

aspect ratio
The aspect ratio describes the shape of the grid unit. A square grid 
unit would have the ratio 1:1, whereas a grid unit of aspect ratio 
4:3 is a unit with one side 1.33 times as big as the other side.
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vector

A vector-based image is composed of points and Bézier curves. 
The computer reads the points and traces the segments, linking 
them to reproduce the image shape. There is no fixed size or 
resolution in a vector image. The graphic can be enlarged and 
distorted as much as desired and the system will simply recalculate 
the segments and rebuild the shapes. Vector images are translated 
and displayed in pixels once the calculation is done.

velocity/ease

In animation, the velocity, also known as ease, is the acceleration or 
deceleration of a motion. This can be achieved by a function curve, 
or via a series of animated drawings. Other common terms for 
ease-in and ease-out are slow-in and slow-out.

walk cycle 

To avoid making innumerable drawings, animators routinely make 
a walk cycle for their character. This comprises a series of drawings 
``on the spot``  that describe the walk for that character. The illusion 
of movement is created via the use of background pans.

workspace
In Toon Boom, the workspace is made up of the views, toolbars, 
and menus.

Xsheet (exposure sheet)

The Xsheet or exposure sheet, is a sheet with several vertical 
columns and horizontal frames used to indicate a scene's timing.

Each column represents a scene's layer. In each column, the 
drawing numbers are indicated and spread over the specific 
amount of frames they need to appear.

The exposure sheet is used by animators, directors and other 
members of a crew to track the sequence and timing of images, 
dialogue, sound effects, sound tracks and camera moves. Also 
known as a Dope Sheet.

zone An area which can be painted with colour.
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Index

4:3

12 fields  59

about

Cloud module  32

Draw module  29

Harmony  27

Harmony Control Center  28

Paint module  31

Play module  31

Scan  30

Sketch module  30

Stage  29

Xsheet module  31

adding

views  71

Advanced Animation toolbar  125

alignment  59

4:3 12 Fields  59

Square 12 Fields  59

alpha channel

_defined  990

animatic

_defined  990

animating

camera  860

animation

_defined  990

anime

_defined  990

Annotation column  377

changing drawing settings  380

drawing  378

erasing annotations  379-380
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importing Annotation file  382

pen colour  381

pen width  380

tick marks, displaying  381

typing  378

annotations

changing drawing settings  380

changing pen colour  381

changing pen width  380

drawing  378

erasing  379-380

typing  378

arc

_defined  990

area, safe  87

Art Layer toolbar  125

aspect ratio  57

_defined  990

defined  999

grid  59

auto-feed

_defined  990

auto-save

disabling on workspaces  82

axis

_defined  990

background

_defined  990

backing up

palettes  278

Bezier

_defined  990

bitmap images

_defined  991
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importing in original format  741

Bitmap layer  363

bitmap resolution

height  61, 181-182

resolution factor  61, 181-182

settings  61

width  61, 181-182

breakdown

_defined  991

character  596

camera

adding and parenting to peg  860

animating  860

Camera layer  364

camera mask  87

camera shake

_defined  991

Camera view  85

camera mask  87

Camera View toolbar  90

current drawing on top  87

Editing Stack menu  91

light table  86

Matte View mode  90

OpenGL view mode  89

outline locked drawings  88

Render View mode  89

resetting view  88

safe area  87

View menu  91

Zoom menu  88

Camera View toolbar  90

caption

_defined  991
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cel

_defined  991

celluloid

See cel.  991

centre coordinates, setting  60

character building

breaking down  596

character design

_defined  991

clean up

_defined  991

clockwise

rotating  130

cloning

layers and columns  376

closing

views  72

Cloud module

about  32

CMYK

_defined  991

Colour-Card

layer  364

colour card

_defined  991

colour model

_defined  996

defined  992

colour palettes

back up  278

location  275

locking  37-38

storage location  277

switching display modes  91

1004



Toon Boom Harmony 11.1 Draw Guide (Network)

Colour view  91

switching palette display modes  91

colour wheel

defined  992

Column Properties editor

displaying in Xsheet  373

columns

advanced types  365

cloning  376

deleting  370

duplicating  376

modifying  373

navigating  131

properties  371

renaming  374

reordering  375

Timing  383

types  363

Xsheet  362

commands

basic  63

compositing

defined  992

Control Center

about  28

Control Point toolbar  125

controls points  125

Coordinate toolbar  125

coordinates

keyframes and control point parameters  125

counterclockwise

rotating  130

creating

workspace, new  81
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cross dissolve

defined  992

current drawing on top, Camera view  87

customizing

toolbars  78

cut

defined  992

cut-out animation

creating  684

defined  992

selecting layers  690

cycle

defined  992

dark style interface  67

database

connecting  36

deleting

workspace  83

dialogue

defined  992

display

workspace  83

docking

floating window  72

documentation

accessing  41

dope sheet

defined  992

doping

defined  992

DPI

defined  992

Draw module

about  29
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drawing elements

adding  365

creating  362

duplicating  376

Drawing layer  363

drawing layers

adding  52

locking  53

Drawing view  96

drawings

current drawing on top  87

flipping through  126

importing  331

locking  37-38, 53

navigating  131

outline locked drawings  88

scanning  331

ease

defined  992

setting on multiple parameters  714

ease-in

defined  992

ease-out

defined  992

Easy Flipping toolbar  126

Editing Stack menu  91

editors

Column Properties  373

Layer Properties  100

Effect layer  364

Element Manager dialog box

parameters  375

elements

positioning in Top and Side views  835
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establishing shot

defined  992

exporting

palettes  277

exposure

_defined  993

exposure sheet

_defined  1000, 993

fade-in

_defined  993

fade-out

_defined  993

field

_defined  993

field chart

_defined  993

field of view  57

custom  57

horizontal fit  57

vertical fit  57

File toolbar  126

film-1.33  56

_defined  993

film-1.66  56

_defined  993

film-1.66_Vertical  56

flat toolbars  75, 79

Flip toolbar  126

flipping

_defined  993

follow-through

_defined  993

forward kinematics

_defined  993
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FOV (field of view)  57

custom  57

horizontal fit  57

vertical fit  57

fps  57

frame

_defined  994

frame rate

_defined  994

frames  359

adding  360

adding before/after selection  359

navigating  131

frames per second  57

full screen  129

Function view  98, 874

displaying functions  98, 870, 875

functions

_defined  994

displaying  98, 870, 875

gamut

_defined  994

get rights to modify  37-39

global lock  38

grid

aspect ratio, setting  59

centre coordinates, setting  60

number of units, setting  60

Harmony

dark style  67

interface  67

modules  27

starting  33, 35
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Harmony Network

centralized database  34

connecting to database  36

dark style  67

interface  67

network connections  34

starting  33, 35

HDTV  56

_defined  994

HDTV_Vertical  56

Help

Harmony  21

structure  22

hiding

views temporarily  74

workspace  83

Hold

_defined  994

how to

create a template  665

HSV

_defined  994

importing

Annotation file  382

bitmap drawings  336

bitmap image in original format  741

drawings  331

sound file  904

templates  667

in-between

_defined  994

ink and paint

_defined  994
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interface  67

dark style  67

docking a floating window  72

interpolation

_defined  994

jump cut

_defined  994

key pose

_defined  995

keyboard shortcuts

_defined  995

keyframes

_defined  995

Layer Properties editor  100

displaying  373

renaming layers  374

layers  362

_defined  995

adding drawing layer  52

bitmap  363

camera  364

cloning  376

Colour-Card  364

deleting  370

drawing  363

duplicating  376

effect  364

modifying  373

panning with Transform tool  813

Peg  364

properties  371

Quadmap  365

renaming  374

reordering  374
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rotating with Transform tool  813

selecting parent or child layer  690

skewing with Transform tool  814

Sound  365

types  363

layout

_defined  995

layout and posing

_defined  995

Libary folder

locking  37-38

library

_defined  995

Library view  100

light table

_defined  995

Camera view  86

line of action

_defined  995

linking

external files  383

lip-sync

_defined  995

auto detection, defined  990

mouth shapes  924

lip-sync detection

manual, defined  996

Llibrary view

importing templates  667

loading

workspace  80

locking  37-38

drawing  37-38

drawings  53
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global lock  38

Library folder  37-38

palette list  37-38

palettes  37-38

scenes  37-38

version  37-38

looping

playback  127

low resolution  57

_defined  995

manual lip-sync detection

_defined  996

Mark Drawing toolbar  126

mask

camera  87

master palette

_defined  996

exporting  277

master peg

adding  618

Matte View mode  90

menus  69

Editing Stack  91

View  91

Zoom  88

Message Log view  102

model

_defined  996

model sheet  See character design

Model view  102

modules

Cloud  32

Control Center  28

Draw  29
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Harmony  27

Paint  31

Play  31

Scan  30

Sketch  30

Stage  29

Xsheet  31

morphing

deleting  570

motion keyframe

_defined  996

mouth

chart  996

shapes  924

moving

toolbars  77

multiplane

_defined  996

positioning elements  835

navigating  129

centering screen on mouse  130

columns  131

drawings  131

frames  131

full screen  129

panning  129

Play menu  130

recentering view  129

resetting pan  129

resetting rotation  129

resetting views  129

resetting zoom  129

rotating clockwise  130

rotating counterclockwise  130
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zooming in  129

zooming in or out  129

zooming out  129

network connection  34

NTSC  57

_defined  996

nudge

_defined  996

Onion Skin toolbar  126

onion skinng

_defined  996

onion skinning

toolbar  126

OpenGL

view mode  89

opening

Workspace Manager  80

orthographic projection  58

outline locked drawings  88

overlay

_defined  996

Paint module

about  31

PAL  57

_defined  996

palette list

locking  37-38

palettes

_defined  996

backup  278

exporting  277

location  275

locking  37-38

storage location  277
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style, defined  997

switching display modes  91

panel

_defined  997

panning  129

_defined  997

layer using Transform tool  813

resetting  129

paperless animation

_defined  997

passing position

_defined  997

path of action

_defined  997

Peg layer  364

pegs

_defined  997

adding master  618

pen

_defined  999

perspective projection  58

Perspective view  103, 840

rotating a scene  104, 841

phoneme

_defined  997

pipeline

Toon Boom  27

pivot

_defined  997

repositioning permanently  820

pixel

_defined  997

dimensions  57

pixelation  See bitmap image
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Play menu  130

Play module

about  31

playback toolbar

Sound button  127

Playback toolbar  127

FPS button  127

Jog Frames button  127

Loop button  127

Play button  127

Render and Play button  127

Sound Scrubbing button  127

playing back  127

fps  127

jogging frames  127

looping  127

rendering and playing  127

sound  127

sound scrubbing  127

pose-to-pose

_defined  997

preferences  66

disabling auto-save workspace  82

flat toolbars  79

Preferences dialog box  66

product requirements

Harmony  25

Harmony Network  25

Harmony Stand Alone  25

projection settings  58

orthographic  58

perspective  58

projects

locking  37-38
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resolution  56

Quadmap layer  365

recentering

view  129

renaming

workspace  82

Render View mode  89

rendering

_defined  997

reordering

workspace  84

resetting

Camera view  88

pan  129

rotation  129

views  129

zoom  129

resizing

toolbars  76

views  73

resolution

_defined  997

bitmap  61

factor, bitmap  61, 181-182

film-1.33  56

film-1.66  56

film-1.66_Vertical  56

HDTV  56

HDTV_Vertical  56

height, bitmap  61, 181-182

Low  57

NTSC  57

PAL  57

presets  56
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scene  61, 181-182

width, bitmap  61, 181-182

restoring

workspace, default  84

RGB

_defined  997

rigging

_defined  998

adding master peg  618

rights to modify  37-39

rotary table

_defined  998

rotating

layer with Transform tool  813

resetting rotation  129

rotating clockwise  130

rotating counterclockwise  130

rotoscoping

_defined  998

roughs

_defined  998

safe area  87

_defined  998

saving

auto-saving scenes  42

scenes  42

workspace manually  83

scaling

layer with Transform tool  814

Scan module

about  30

scanning  329

drawings  331

images as bitmap drawings  331
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process  330

VectOptions.conf file  348, 795

scene resolution  61, 181-182

Scene Settings dialog box  55

scene setup

panning layer using Transform tool  813

repositioning pivot permanently  820

rotating layer with Transform tool  813

scaling layer with Transform tool  814

skewing layer with Transform tool  814

scenes

_defined  998

adding frames before/after selection  359

auto-saving  42

extending  359-360

locking  37-38

new scene startup script  51

reducing length  360

removing frames  360

rotating in Perspective view  104, 841

saving  42

scene length, setting  51

setting length  51, 359

settings  55

script

_defined  998

Script Editor view  104

scripting

toolbar  127

Scripting toolbar  127

scripts

new scene startup  51

scrubbing

_defined  998
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sequences

_defined  998

settings

projection  58

scene  55

shot

_defined  998

Side view  106, 839

opening  860

positioning elements  835

Sketch  30

about  30

skewing

layer with Transform tool  814

slow-in

_defined  998

slow_out

_defined  998

slugging

_defined  998

sound

importing sound file  904

scrubbing

_defined  998

Sound layer  365

Stage  29

about  29

starting

Harmony  33, 35

ToonBoomProductName  35

stop-motion keyframe

_defined  998

storyboard

_defined  998
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straight-ahead

_defined  999

strokes

_defined  999

swapping

views  73

switching

workspace  80

system requirements

Harmony  25

Harmony Network  25

Harmony Stand Alone  25

tablet

_defined  999

technical specifications

Harmony  25

Harmony Network  25

Harmony Stand Alone  25

templates

_defined  999

importing  667

thumbnails

_defined  999

tick marks, Xsheet

displaying  381

turning off  382

timecode

_defined  999

timeline

_defined  999

Timeline view  107

cloning layers and columns  376

modifying layers and columns  373

reducing scene length  360
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renaming layers  374

reordering layers  374

timing

adding frames before/after selection  359

Annotation column, adding  377

changing drawing settings  380

drawing in Annotation column  378

erasing annotation  379-380

extending scenes  359-360

frames  359

importing Annotation file  382

linking external files  383

preparing  357

reducing scene length  360

references  358

removing frames  360

scene length  51, 359

Timing column  383

typing in Annotation column  378

Timing column  383

linking external files  383

using  383

tool presets  128

Tool Presets toolbar  128

Tool Properties view  115

toolbars  125

Advanced Animation  125

Art Layer  125

Camera View  90

Control Point  125

Coordinate  125

customizing  78

Easy Flipping  126

Edit  126
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File  126

flat  75

Flip  126

hiding  75

managing  75

Mark Drawing  126

moving  77

Onion Skin  126

Playback  127

resizing  76

Scripting  127

showing and hiding  75

Tool Presets  128

Tools  128

top  125

view  128

Workspace  128

tools

Zoom  131

Tools toolbar  128

Top view  116, 837

opening  860

positioning elements  835

trace and paint

_defined  999

track breakdown

_defined  999

tradigital

_defined  997

traditional animation

_defined  999

scanning  329

trajectory

_defined  999
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Transform tool

panning layer  813

rotating layer  813

scaling layer  814

skewing layer  814

transition

_defined  999

underlay

_defined  999

VectOptions.conf file  348, 795

Linux  351, 798

Mac  349, 796

setting  349, 796

Windows  349, 796

vector

_defined  1000

vectorization

creating a style  347, 794

parameters, creating  347, 794

parameters, custom  339, 786

parameters, modifying  347, 794

Vectorization Parameters dialog box

Help tab  342, 789

opening  339, 786

Options tab  340, 787

vectorizing

bitmap drawings  336

velocity

defined  992, 1000

version

locking  37-38

View menu  91

view modes

Matte  90
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OpenGL  89

Render View  89

views  71

adding  71

Camera  85

closing  72

Colour  91

docking a floating window  72

Drawing  96

Function  98, 874

hiding temporarily  74

Library  100

managing  71

Message Log  102

Model  102

Perspective  103, 840

recentering  129

resetting  129

resizing  73

Script Editor  104

Side  106, 839

swapping  73

Timeline  107

Tooll Properties  115

Top  116, 837

Xsheet  117

walk cycle

_defined  1000

Welcome screen  40

workspace

_defined  1000

creating new  81

deleting  83

disabling auto-save  82
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displaying  83

hiding  83

loading  80

managing  80

renaming  82

reordering  84

restoring default  84

saving as new version  83

saving manually  83

showing  83

toolbar  128

Workspace Manager

opening  80

Workspace toolbar  128

Xsheet

typing in Annotation column  378

Xsheet view  31, 117

_defined  373, 1000

adding frames before/after selection  359

advanced column types  365

Annotation column, adding  377

changing drawing settingss  380

cloning layers and columns  376

columns  362

erasing annotations  379-380

importing Annotation file  382

layers  362

modifying layers and columns  373

removing frames  360

renaming columns  374

reordering columns  375

tick marks, displays  381

Timing column  383
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zone

_defined  1000

Zoom menu  88

Zoom tool  131

zooming

in  129

in or out  129

out  129

resetting zoom  129

Zoom tool  131
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