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Chapter 1: Introduction
Toon Boom Harmony is a complete animation software with advanced features for all your animation projects.
No matter your preferred animation work-style, Harmony manages your entire project, from importing assets
and content creation, all the way to animation, compositing and multi-platform rendering. Harmony boasts a 64bit engine, allowing you to export content faster, including elaborate scenes, large bitmaps, gradients and
complex backgrounds. Output sophisticated scenes with particles, complex effects, as well as 2D/3D
integration.
Harmony's re-engineered vector technology is the basis of the software's redesigned pencil line capabilities,
options that include lines that capture the pressure information from the digital tablet, as well as configurable
pencil line tips from which you can select round, square, or free control options. You also have the option to
create unlimited line styles, thanks to new pencil line support texture information; choose from a selection of
built-in textures, or create your own by using a pixmap program. Lastly, you can design and store unlimited line
styles and apply them to any pencil line in a drawing.
Harmony also includes a powerful deformation technology tool that permits the deformation of pixmap images
and vector drawings over a period of time. Specifically, this applies to the creation of a basic skeleton structure
in which the parent deformers will move the child deformers. This hierarchical principal also applies to the
deformation of curves within Harmony's software, in which a straight line can be altered to an arc, or a zigzag,
with only a few clicks.
Harmony includes a redesigned SDK infrastructure, facilitating the creation of plug-ins, allowing for easy access
to predesigned special effects. Lastly, the software allows for the importation of both 3D models and scenes.
From there, you need only manipulate all of the 2D and 3D elements into a unified environment and render them
as one.

Harmony works in conjunction with Toon Boom Storyboard Pro, which allows you to plan your
project, and time the scenes to audio before animating in Animate or Animate Pro.

To learn all about the features available in Toon Boom Harmony and how to use them in a production context,
refer to the following chapters:
•

Getting Started on page 53

•

Interface on page 99

•

Drawing on page 151

•

Traditional Animation on page 293

•

Colour on page 339

•

Timing on page 433

•

Morphing on page 527

•

Import on page 573

•

Library on page 625

•

Character Building on page 665

•

Scene Setup on page 761

50

Toon Boom Harmony 10.3 Stage User Guide

•

3D Space on page 847

•

Sound on page 903

•

Animation Paths on page 937

•

Cut-out Animation on page 1029

•

Deformation on page 1111

•

Effects on page 1199

•

Export on page 1409

In all Harmony documentation, the default keyboard shortcuts used are the Toon Boom Harmony set.
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Visual Markers

Visual Markers
Related Topics
The Related Topics sections, located at the end of each section, indicate that there is another section extent in
this guide, one that provides further information regarding the current topic. If you are reading the digital
version of this guide, you can click on the link to go directly to that section.

Note
This Note gives important information regarding the current topic.
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Chapter 2: Getting Started
Once the software is installed, you are ready to start the application and animate!

Topics Covered
•

Network Connection on the next page

•

Starting Toon Boom Harmony on page 56

•

Welcome Screen on page 62

•

Creating and Opening a Scene on page 63

•

Setting the Scene Length on page 68

•

Saving Different Versions of a Scene in the Database on page 69

•

Scene Settings on page 78

•

Adding a Drawing Layer on page 83

•

Verifying the Project Integrity on page 86

•

Basic Commands on page 88

•

Preferences on page 92
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Network Connection

What is the Harmony Network Solution and
2D Games?
The Harmony Solution is a revolutionary team-based infrastructure for animation production. Its array of cuttingedge features increases productivity and encourages creativity. Developed in conjunction with the leading
studios worldwide, Harmony is specifically designed for long-term episodic and feature length projects,
providing a true animation pipeline. Several animators can work simultaneously on the same project while the
asset library provides users with easy access to up-to-date media assets. Harmony is truly scalable; more than
100 staging clients can share animation just as easily as a few can.

Note that Harmony can be used in Database mode via the Network connection or as a stand-alone
application.

What is Network Connection?
Harmony Network is the link between the machines and the server. It lets you work on the different projects
stored in the central Harmony database.
At the heart of the Harmony solution is the server, which centralizes all the production assets in a repository.
Loaded with production proven tools to manage administration tasks, the server is completely flexible and will
fit in your existing infrastructure, whether you are on Windows, Linux or Mac OS X.
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To learn more, refer to the Harmony Server User Guide.

Working with Harmony Stage Via Harmony Network
When you launch Harmony Stage, you can opt to either work offline in the application as a stand alone software,
or connect to the database to work on projects via Harmony Network.
When working with the Harmony solution via Harmony Network, the scenes and their data are stored directly on
the server. No data is saved or stored on the client machine. The client machines access the database and load
the scenes and drawings directly from the server. Each time the user saves his scene, the data is updated directly
on the server. There are no upload or download operations done between the server and the clients.

If you have a stand-alone license, you will not have access to the database. You will automatically
launch the application in stand-alone mode.

Related Topics
•

Connecting to the Database on page 57
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Starting Toon Boom Harmony
You can run the software on Mac OS X, Windows, or Linux operating systems.
To start Harmony, do one of the following:
1. Launch Harmony:
‣

Mac OS X: Double-click on the Harmony Stage

icon or select Applications > Toon Boom

Harmony 10.3 > Stage.
‣

Windows: Double-click on the Harmony Stage

icon or select Start > Programs/All Programs >

Toon Boom Harmony 10.3 > Stage
‣

Linux: Select Applications > Toon Boom Harmony 10.3 > Stage

Toon Boom Harmony opens.

Two choices are available to you:
‣

Connect to Database
Enable this option to work on Harmony connected to the database. When you are connected to the
database, you can access scenes stored in the central database of Toon Boom Server and exclusive
options becomes available in the different menus. However, you will not be able to create new scenes
directly from Harmony Stage and the available scenes will be the ones that were previously created
using the Control Centre.

‣

Work Offline
The Work Offline mode is enabled by default when you launch Harmony for the first time. Using this
mode let’s you create new scenes and work locally on your machine on independent projects as you
would with any local software.
However, the following limitations apply:
- Options exclusive to the Harmony solution will not be available in the different menus.
- You will not have access to any projects stored in the central database of Toon Boom Server.
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If you have a standalone license, Toon Boom Harmony will open directly with the Welcome Screen.

2. Enable either the Work Offline or the Connect to Database option.
3. Click OK.
In Offline mode, the Welcome Screen opens—see Welcome Screen on page 62.
In Database mode, the Database Selector opens—see Connecting to the Database below.

Connecting to the Database
To be able to work in Stage via Harmony Network, you must be connected to the Harmony Database. When you
connect to the database, you cannot create new scenes directly from Harmony Stage. The available scenes will
be the ones that were previously created using the Control Center.

This process is only for Harmony Network licence.

To connect to the Harmony database:
1. StartHarmony Stage—see Starting Toon Boom Harmony on the previous page.
2. In the Toon Boom Stage window, select the Connect to Database option.

3. In the User Name field, enter your Harmony username which is provided by your project lead or system
administrator.

4. Click OK.
The Database Selector dialog box opens, displaying the environments available in Harmony database.
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5. In the Environments column, select the scene's environment (project, movie).

6. In the Jobs column, select the scene's job (episode, sequence).
7. In the Scenes column, select the scene.
8. Get the permissions needed for this session by selecting the appropriate options:

‣

Get rights to modify the scene
Allows the user to modify the selected version of the scene and have access to the version manager
during the opened session.

‣

Get rights to modify the scene version
Allows the user to modify the currently selected scene version, but locks access to the version
manager during the opened session.

‣

Get rights to modify the scene assets
Automatically gets all the edit rights for the selected version of the scene.

This option is only recommended if you are certain that the selected scene cannot be opened for
editing by several users at the same time. Large studios should avoid this option.

9. Choose the version you want to open from the Version drop-down menu.

‣

The Saved By and Saved Date fields display the user who was the last to save the selected scene and
the date of the last save.

Refer to the Saving Different Versions of a Scene in the Database on page 69 topic to learn more
about scene's versions.

10. Click on the Open button.
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Related Topics
•

Global Lock on the next page

•

Locking Drawings on page 83

•

Palette Lists and Palettes Lock on page 343

Preference Style
When you start Harmony for the first time, the Preference Style dialog box will open. This is the only time you will
see this dialog box, however, you can change the styles later on if you like using the Preference panel.

You have two choices. Select the one which fits your work style:
•

Yes: Sets Harmony’s default shortcut scheme and preferences to fit the Adobe® Flash® software
workflow style. For example, the Select tool is set to Marquee mode.

•

No: Sets Harmony’s default shortcut scheme and preferences to fit the Toon Boom professional products
workflow style. The Select tool is set to Lasso selection mode.
Once your choice is made, the Welcome Screen is displayed

You can always return to the Preference Style window later on to change the shortcut style.

Refer to the following topics to learn more about preferences and customizing the shortcuts:
•

Preferences on page 92

•

Keyboard Shortcuts on page 95

•

Preference Highlights on page 93
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Related Topics
•

Starting Toon Boom Harmony on page 56

Global Lock
If you work in stand-alone mode, you automatically have the rights to modify all drawings and
palettes.

Harmony Network has a lock system, referred to as Global Lock, for the different scenes and scene assets. As all
the data on the server can be accessed directly and modified from any client machine by default, the scenes are
locked. The users must obtain the rights to modify scenes in order to save their work onto the server.
Only one user at a time can modify a scene. Once a scene is opened on a client machine, other users can only
open the scene in read-only mode; they will not be able to save any modifications.
The Global Lock has three levels:
•

Get rights to modify the scene
Allows the user to modify the selected version of the scene and have access to the version manager during
the opened session.

•

Get rights to modify the scene version
Allows the user to modify the currently selected scene version, but locks access to the version manager
during the opened session.

•

Get rights to modify the scene assets
Automatically gets all the edit rights for the selected version of the scene. This option is only
recommended if you are certain that the selected scene cannot be opened for editing by several users at
the same time. Large studios should avoid this option.

These three levels of locking are available from the Database Selector when the user logs into Harmony. From
there you can select a scene and obtain the rights to modify it by enabling the desired lock option check boxes.
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There are several different ways to obtain the rights to modify the scenes. It can be done when the user loads a
scene from Harmony, inside the application once the scene is loaded, or when an environment, job or scene is
created using the Control Centre module.

Refer to the Harmony Server User Guide to learn more about Control Center.

Acquiring Rights to a Scene Once it is Loaded
If you opened a scene for read only, but realize that you will need to modify it, you can easily acquire the
necessary rights without closing and reloading the scene.
To set the scene's rights after the scene is loaded:

‣ In the top menu, select File > Rights to Modify Scene or Rights to Modify Scene Version.

Note that it is not possible to acquire the rights to modify the scene assets once the scene is loaded.
This process is done during the initial loading process of the scene.

To learn more about enabling the rights to modify while creating environments, jobs and scenes,
refer to the Harmony Server User Guide.

Related Topics
•

Locking Drawings on page 83

•

Palette Lists and Palettes Lock on page 343
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Welcome Screen
When you open Toon Boom Harmony, the Welcome Screen appears. If a scene is already open, you
can display the Welcome Screen by selecting Help > Show Welcome Screen.

The Welcome Screen allows you to:
1. Create scenes.
2. Choose the scene resolution.
3. Add or delete a custom scene resolution.
4. Open recent scenes from a list.
5. Open scenes by browsing.
6. Open the Help documentation.
7. Enable this option to open Harmony directly without opening the Welcome Screen first.
To display the Welcome Screen later on, go to the top menu and select Help > Show Welcome Screen.
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Creating and Opening a Scene
All scenes created via Harmony are independent and local to the computer.
You can either create a new scene using the Welcome Screen or the File menu:
•

Creating a Scene Using the Welcome Screen below

•

Creating a Scene Using the File Menu on the next page

•

New Scene Startup Script on page 66

Creating a Scene Using the Welcome Screen
To create a scene from the Welcome screen:
1. To select the scene’s location, in the Project Directory section, browse the files by clicking Browse
button.

2. In the Project Name field, type the scene’s name.

The scene name cannot exceed 23 characters.

3. Set the scene resolution by doing one of the following:
‣

In the Resolution window, select the scene’s resolution and click Create.

Your new scene is created.
‣

Add a new resolution to list by clicking the Add

button.

In the New Resolution dialog box, fill in the following fields and click Create.
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Resolution Name: Name your new resolution.
Width: Type the resolution width in pixels.
Height: Type the resolution height in pixels.
Frame Rate: Type the scene’s frame rate per second.

You can delete a custom resolution from the Resolution list by selecting it, and clicking the Delete
button under the Resolution window.

To open a scene from the Welcome screen:
1. In the Recent Scenes section, click Open Scene.
The Open Scene browser opens.
2. Browse and select the desired *.xstage file.
3. Click Open to open the scene.
To open a recent scene from the Welcome screen:

‣ In the Recent Scenes section, select a scene from the list.

Creating a Scene Using the File Menu
If a scene is already open and you want to create a new one, you can use the File menu.
To create a scene from the File menu:
1. Do one of the following:
‣

From the top menu, select File > New.

‣

In the File toolbar, click the New

‣

Press [Ctrl] + [N] (Windows/Linux) or [⌘ ] + [N] (Mac OS X).

button.

The New Scene dialog box opens.
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2. Select a scene directory by clicking the Browse

button.

3. In the Project Name field, type the scene's name.

The scene name cannot exceed 23 characters.

4. Set the scene resolution by doing one of the following:
‣

In the Resolution window, select the scene’s resolution and click Create.

Your new scene is created.
‣

Add a new resolution to list by clicking the Add

button.

In the New Resolution dialog box, fill in the following fields and click Create.
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Resolution Name: Name your new resolution.
Width: Type the resolution width in pixels.
Height: Type the resolution height in pixels.
Frame Rate: Type the scene’s frame rate per second.
To open a scene from the File menu:
1. Do one of the following:
‣

From the top menu, select File > Open.

‣

In the File toolbar, click the Browse

‣

Press [Ctrl] + [O] (Windows/Linux) or [⌘ ] + [O] (Mac OS X).

button.

The Open Scene browser opens.
2. Browse and select the desired *.xstage file.
3. Click Open.

New Scene Startup Script
When you create a new scene, the TB_sceneCreated script will automatically set the scene length to 60 frames
and add one of each of the following modules: drawing element, composite, display and write.
You can customize this script to fit your current project needs. This way, you can set the default scene length to
any number of frames you want, or even decide which types of elements and modules you wish to be in your
scene when you create it.

Refer to the Toon Boom Harmony Scripting Guide to learn more about using, creating and
customizing scripts.

Saving a Scene
It is important to regularly save your scene. As you make changes to a scene, an asterisk (*) appears in the title
bar beside the scene name to indicate that the scene contains unsaved changes.
To save a scene, do one of the following:
‣

Select File > Save.

‣

Press [Ctrl] + [S] (Windows/Linux) or [⌘ ] + [S] (Mac OS X).
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Related Topics
•

Welcome Screen on page 62
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Setting the Scene Length
Once you have created your scene, you can set its length.
To set the scene length from the top menu:
1. From the top menu, select Scene > Scene Length.
The Set Scene Length dialog box opens.

2. In the Number of Frames field, type the number of frames needed.
Refer to the following topics to learn more about adding and removing frames, and extending the scene’s
length:
•

Adding Frames on page 445

•

Deleting Frames on page 447

Related Topics
•

Getting Started on page 53

•

Creating and Opening a Scene on page 63
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Saving Different Versions of a Scene in the
Database
These options are only for Harmony Network.

When you use the Harmony Solution and work in a scene on the database, there are many choices and options
available when you save your work.
•

Save the scene as the current version

•

Save different versions representing different stages of production of your scene

•

Save different versions representing different scene setups

•

Choose specific assets that you want to save, such as drawings or palettes

Once you have a different version of a scene stored in the database, you can manage the following:
•

Saving the Current Version of a Scene below

•

Advanced Saving Options on the next page

•

Deleting Versions on page 74

•

Merging Scene Versions on page 75

Saving the Current Version of a Scene
When you open the scene from the database and you select the version you wanted to edit, you can either save
the changes you made in the current version, or create a new version. The simplest way to save your work is to
update the current version.
To save the current version of a scene:
1. Make sure that you have the necessary rights to save the current scene version. If you do not, you can
acquire the rights by selecting File > Rights to Modify Scene Version or Rights to Modify Scene.
2. Select File > Save or press [Ctrl] + [S] (Windows/Linux) or [⌘ ] + [S] (Mac OS X).
When saving the scene for the first time, the Save dialog box opens, prompting you to name the version.
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3. Edit the information in the current version:
‣

In the This Version field, enter a relevant name for the current version.

‣

In the Description field, enter a short description of the current version.

4. Click Save.

Advanced Saving Options
Once the scene you are working on has been saved, use these options to save the scene as a different version, or
to select specific components of the scene you want to save.
•

Selecting the Advanced Saving Options on the facing page

•

Saving your Advanced Saving Options on page 74

To open the Save dialog box:
1. Make sure that you have the necessary rights to save the current scene version. If you do not, you can
acquire the rights by selecting File > Rights to Modify Scene Version or Rights to Modify Scene.
2. Select File > Advanced Save.
The Advanced Save dialog box opens.
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Selecting the Advanced Saving Options
Select the components you want to save from the following tabs, each of which is explained in the following
topics:
•

File below

•

Drawings on page 73

•

Palettes on page 73

•

Palette Lists on page 74

Once you have chosen the components to be saved, you will conclude the procedure by following the
instructions in the section. After selecting the components to be saved, click on the Save button. All the specific
components that are selected throughout the different tabs of the Advanced Save dialog box will be saved.

File
In the File tab of the Save dialog box, you can do the following:
•

Save the scene as a new version

•

Overwrite an existing version

•

Set a new current version.
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A - Save:
•

Enable this option if you want to save the modifications made to the current scene.

•

Disable the Save option if you only want to save specific components of your scene listed in the
Drawings, Palettes or Palette Lists tabs. This will disable all option in the File tab.

B - This Version (number):

•

Enable this option if you want to save the current version of the scene. You can rename the current
version by typing a new name into the field.

C - New Version (number):

•

Enable this option if you want to save the current scene as a new version. You can name this new
version by typing a name into the field.

D - Overwrite Existing Version:

•

Enable this option and select an existing version of your scene from the list to overwrite it.

E - Description:
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•

Use this field to add or edit an existing description for the scene version you want to save.

F - Mark as Current:
•

Enable this option if you want to set this scene version as the current one. This version will be
automatically selected as the default current version when the scene is selected in the Database
Selector dialog box.

Drawings
The Drawings tab lists the modified drawings.

A - Drawing list:
•

Select the modified drawings that you want to save.

•

Deselect the modified drawings that you do not want to save.

B - Select All:
•

Click on the Select All button to select all modified drawings in list

C - Deselect All
•

Click on the Deselect All button to deselect all modified drawings in the list.

Palettes
The Palette tab lists the modified colour palettes.
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A - Colour Palette list:
•

Select the colour palette that you want to save.

•

Deselect the modified colour palette that you do not want to save.

B - Show Recovered:
•

Select this option if you want to display the recovered palettes in the list of modified palettes.

C - Select All:
•

Click on the Select All button to select all modified colour palettes in the palette list.

D - Deselect All
•

Click on the Deselect All button to deselect all modified colour palettes in the palette list.

Palette Lists
The Palette Lists tab lists all the modified colour palette lists.

A - Palette Lists list:
•

Select the modified palette lists that you want to save.

•

Deselect the modified palette lists that you do not want to save.

B - Show Recovered:
Select this option if you want to display the recovered palettes lists in the list.
C - Select All:
Click on the Select All button to select all modified palette lists in the list.
D - Deselect All
Click on the Deselect All button to deselect all modified palette lists in the list.

Saving your Advanced Saving Options
You should now have selected the components you wanted to save from the components.
Now that you have chosen the advanced saving criteria, do the following:
3. After selecting the components to be saved, click on the Save button.
All the specific components that are selected throughout the different tabs of the Advanced Save dialog
box will be saved.

Deleting Versions
You can delete any unnecessary versions using the Version Manager.
To delete versions:
1. Make sure you have the necessary rights. If you do not, select File > Rights to Modify Scene.
2. Select File > Manage Versions.
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The Versions dialog box opens.

3. In the Existing Versions list, select the scene version you want to delete. When a version is selected,
information about it appears in the Description list.
4. Click on the Delete button.
The Confirm Delete Versions dialog box opens, warning you that the operation cannot be undone.

5. ONLY if you are certain that the version can be deleted, click on the Yes button.
‣

Click on the No button if you want to cancel the operation and keep the version.

Merging Scene Versions
It is quite possible that when working with multiple versions, you will want to merge some of the changes from
one version into another. You might have created a version with some suggestions that you submitted to the
director, or to animation, while continuing to work on the official version. If the director approved some of the
changes, you can now use the Merge Editor window to import those changes in the official version.
To merge scene versions:
1. In the top menu, select Edit > Open Merge Editor.
The Choose Scene Versions to Merge Changes From opens.
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2. In the Choose Scene Versions to Merge Changes From section, select the scene version you want to
merge the changes from in your current open version.

‣

In the Use Another Version for Reference section, you could select a different scene version to
merge the changes into, rather than your current version.

3. Click on the Load button.
The Merge Editor opens.
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4. From the right column, select the layers you want to merge the changes from into the reference version.
5. In the Select Element Range section, set the Start Frame and End Frame fields to indicate from what
frame to what frame you wish to take the changes from.
6. Click on the Merge Selected button to complete the operation.

Related Topics
•

Creating and Opening a Scene on page 63
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Scene Settings
When you created your new scene, you set up the resolution and the alignment. However, if you want to change
these initial settings later, you can.
To change the scene settings:
From the top menu, select Scene > Scene Settings.
The Scene Settings dialog box opens.

The different Scene Settings options are separated into three tabs.
•

Resolution Tab below

•

Alignment Tab on page 80

•

Advanced Tab on page 82

Resolution Tab
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1. Project Resolution Type
2. Scene Resolution Setting
3. Pixel Dimensions
4. Save Custom Resolution
5. Aspect Ratio
6. Project Frame Rate
7. Field of View

Resolution
1. You can select your project’s resolution type from this area so it matches your intended output.
‣

HDTV: High definition television delivers a higher quality image than standard television does,
because it has a greater number of lines of resolution. To take advantage of the superior quality your
output device must be compatible with HDTV technology to make this resolution setting useful.

‣

HDTV_Vertical: The "vertical resolution" of HDTV_Vertical refers to how the drawing grid is fit into
the camera frame. When working with 12 or 16 field drawing grids, the grid is a different aspect ratio
from the camera frame. When you fit vertically, you fit the grid with the top and bottom of the camera
frame.

‣

film-1.33: Use this resolution setting for the academy film format that conforms to the standard 4:3
aspect ratio.

‣

film-1.66: Use this resolution setting for the widescreen film format that conforms to the 16:9 aspect
ratio.

‣

film-1.66_Vertical: This is essentially the same as film-1.66. Refers to how the drawing grid is fit into
the camera frame. When working with 12 or 16 field drawing grids, the grid is a different aspect ratio
from the camera frame. When you fit vertically, you fit the grid with the top and bottom of the camera
frame.

‣

NTSC: This is the standard analogue television broadcasting system used in North America and
conforms to the North American standards on how rectangular pixels are displayed for computer and
television screens.

‣

PAL: This resolution works best with the European format for television and computer screens, as the
rectangular pixels are displayed at a different orientation.

‣

Low: This format is ideal for videos destined for the web, where size and fast download of a video file
might take precedence over quality.

2. Displays the scene resolution setting selection.
3. Displays the pixel dimensions for your resolution selection.
If you decide to type in the pixel dimensions, or use the up and down arrows to change the pixel
increments, you will have to save your custom selection in order to make it active (4). It will then appear in
the resolution selection list (1).
4. Click Save to save and create your custom resolution as a setting. This button becomes active when you
create a custom resolution type (3).
5. The aspect ratio is the ratio between the horizontal and vertical dimensions of the Camera framing. Each
resolution setting has a preset aspect ratio that cannot be changed.
6. Select the frame rate for your project. The higher the frame rate, for example 30 fps, the smoother your
animation will look, but the heavier it will become, the lower the frame rate, for example 12 fps, the
choppier your animation may look, but the lighter it will be.
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7. Use these options to define the FOV of the camera and how the drawing elements (and drawing grid)
align to the camera. The drawing grid is always scaled proportionally to a 4:3 (1.33) ratio, therefore
changing the Field of View setting may not show a visible difference if your project resolution is also 4:3,
such as NTSC.
‣

Horizontal Fit: The drawing grid is fitted to the vertical (side) edges of the Camera view, so that the
width of the grid matches the width of your project resolution.

‣

Vertical Fit: The drawing grid is fitted to the horizontal (top and bottom) edges of the Camera view,
so that the height of the grid matches the height of your project resolution.

‣

Custom Fov: After selecting this option, use the now-active field to the right to enter in a value, in
degrees, of the angle that you want the camera cone to be. Increasing this value will make the camera
cone wider (the angle is more obtuse), widening the FOV and making the grid and all elements appear
farther away. Decreasing the default value will create the opposite effect.

Alignment Tab

1. Alignment Presets
2. Units Aspect Ratio
3. Number of Units
4. Coordinates at Centre
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Alignment Rules

1. The Alignment Presets give you two preset options:
‣

4:3 12 Fields: Defines the units of your project to have a 4:3 ratio and sets up 12 of these units to run
both vertically and horizontally in four cardinal quarters (NW, NE, SW, SE). This Alignment preset is
visible in the FOV and drawing grids.

‣

Square 12 Fields: Defines the units of your project to have a 1:1 or square ratio and sets up 12 units
to run both vertically and horizontally in four cardinal quarters (NW, NE, SW, SE). This Alignment
preset is NOT visible in the FOV and drawing grids.

2. In the Units Aspect Ratio fields, enter the aspect ratio of the grid you will use. The aspect ratio describes
the shape of the grid unit. A square grid unit would have the ratio 1:1, whereas a grid unit of aspect ratio
4:3 is a unit with one side 1.33 times as big as the other side.
‣

If the aspect ratio you want to use is 1:1, enter 1 in the Left/Right field (X-axis) and 1 in the Up/Down
field (Y-axis). The default Aspect Ratio is set to 4:3 as it is the one used by traditional animators, who
are accustomed to working with the grid system described above.

3. In the Number of Units fields, enter the number of horizontal, vertical and depth units for your scene’s
grid.
Animators who prefer to work traditionally will understand the default setting of 24 units horizontal by 24
units vertical as it, once again, corresponds to the grid above. Twelve is a common setting for the field
depth.
Those who prefer to work in pixels should enter the pixel dimensions (3) of their project. This way if you
want to move something over 600 pixels you just need to type in 600 units.
4. In the Coordinates at Centre, you can enter a new coordinate for the centre of your scene.
By default, the (0,0) centre is set in the middle of the grid as shown in the grid above. If you want to
change the centre of your grid, for example to the upper left corner, you would enter (-12, 12), -12 units
across and 12 units up. That is of course unless you changed the number of units to match the pixel
dimensions of your scene. Then you would enter negative half the width and positive half the height.
5. Click Save button to save your current Alignment settings and be able to select them later from the list.
The Choose Alignment Name dialog box opens.

81

Chapter 2: Getting Started Advanced Tab

Type in a name for your new alignment settings and click OK.

If you change your scene‘s alignment from 4:3 12 Fields to Square 12 Fields part way though your
project, you may find that the Animation grid becomes offset. To correct this, choose the following
setting from the Layer Properties panel‘s Advanced tab: Alignment > Alignment Rule > Centre
First Page.

Advanced Tab

The Advanced tab contains an option for Toon Boom Digital Pro release 7.3 and Harmony release 7.3.
Since version 7.8, the method in which Z-Ordering is calculated has been optimized. Enable this option if you
want to use the version 7.3 system.
Toon Boom Digital Pro and Toon Boom Harmony 7.3 allowed smaller values on the Z-axis such as 0.0001. Since
version 7.8, the Z-ordering calculation is now optimized and allows only larger values such as 0.001.

Related Topics
•

Creating and Opening a Scene on page 63

•

Setting the Scene Length on page 68
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Adding a Drawing Layer
Now that your scene is set up, you can add drawing layers.
To add a drawing layer from the Timeline view:
1. In the Timeline view, click the Add Drawing Layer

button.

A new drawing layer is added to the Timeline view.

Refer to the following topics to learn more about layers and how to add them.
•

Layers and Columns on page 449

•

Layer and Column Concepts on page 449

•

Adding New Drawing Layers on page 457

•

Deleting Layers and Columns on page 461

•

Modifying Layers on page 463

•

Duplicating Layers and Columns on page 471

•

Cloning Layers And Columns on page 472

Related Topics
•

Getting Started on page 53

Locking Drawings
The drawings are stored on the server database providing access to them from every client machine. They are
locked to avoid different users from modifying the same drawings simultaneously. Only one person at the time
can get the rights to modify them. The drawings' rights are independent from the scene's rights because in a
production rush, two users may need to work on the same scene to finish painting the drawings faster. One user
will get the rights for one set of drawings, and the second user the rights to another set of drawings. This
prevents work from being duplicated.
•

Edit Drawings Mode on the next page

•

Get Rights to Modify Drawings on the next page

•

Releasing the Rights to Modify Drawings on the next page

•

Releasing Rights if your System Crashes on the next page

•

Read Changed Drawings on page 85
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Edit Drawings Mode
When enabled, the Edit Drawings mode gives you the right to modify drawings, as well as create new drawings
by drawing directly on an empty cell. This mode is enabled by default when you open a scene version with the
rights enabled.
To enable the Edit Drawing Mode:
1. From the top menu, select Edit > Edit Drawing Mode.

Get Rights to Modify Drawings
When you disable the Edit Drawing Mode, you can use the Get Rights to Modify Drawings option on a selection
of specific drawings. This is proven useful when, for example, many users are working on the same scene during
the ink and paint process and they want to split the drawings to paint between them.
To get the rights on a selection of drawings:
1. Make sure that the Edit Drawing Mode is disabled.
2. In the Xsheet view, select the drawings you want to edit.
3. Select Edit > Get Rights to Modify Drawings or press [Alt] + [L].

Releasing the Rights to Modify Drawings
Once you get the rights to modify drawings, you can release these rights if necessary.
To release the rights on a selection of drawings:
1. In the Xsheet view, select the drawings you want to release.
2. Select Edit > Release Rights to Modify Drawings or press [Alt] + [Shift] + [L].

Releasing Rights if your System Crashes
If your system crashes and the drawings remain locked, you can force the release of the rights.

Use this option carefully; data loss may occur if the scene is currently open and being edited by
another person. Verify that no one else is using the scene prior to forcing the release of the
drawings' rights.

To force the release of the rights of locked drawings:
1. In the Xsheet view, select the drawings you want to release.
2. Select Edit > Force Release Rights to Modify Drawings.
A Warning dialog box opens.
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•

Click Yes if you want to continue to force the release.

•

Click No if you want to cancel the force release.

Read Changed Drawings
Since the drawings are stored on the server, you might at times need to refresh the drawings that are displayed
in your scene.
To read changed drawings:

‣ Select File > Read Changed Drawings.
Related Topics
•

Adding a Drawing Layer on page 83

•

How to Draw on page 153
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Verifying the Project Integrity
The Check Files command verifies the integrity of the drawing and palette files in your project.
To open the Check Files dialog box:

‣ In the top menu, select File > Check Files.

Check Files
Use the Check Files dialog box to verify that the data is consistent, correct, and accessible.

•

Click on the Check Colours button to open the Check Colours dialog box.

Check Colours
The Check Colours dialog box checks the palette integrity and displays the colour recovery data.
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Related Topics
•

Getting Started on page 53
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Basic Commands
This table lists the most common commands used in Harmony.
Command

Action

Access Methods

New

Starts a new scene while
closing any scene already
open. The New Scene dialog
box opens, asking for
directory, name, and
resolution information.

File > New

Displays the Open Scene
dialog box. Browse your file
system for a scene file.

File > Open

Open

The Open command is not
disabled when a scene is
opened. You can open a new
scene from the current one
and the previous scene will
be closed.

Press [Ctrl] + [N]
(Windows/Linux) or [⌘ ] +
[N] (Mac OS X).

Press [Ctrl] + [O]
(Windows/Linux) or [⌘ ] +
[O] (Mac OS X).

Open Recent

Displays a quick access list to
view and open recently used
Harmony files.

File > Open Recent

Close

Closes the currently opened
scene, but does not close the
Harmony application.

File > Close

Save

Saves all changes made to
the opened scene, drawings,
palettes, and palette lists.

File > Save

Saves the current state of a
scene as another scene. The
Save As window prompts
you to give a new name and
choose a different location
to this scene before saving it.
This will create a complete
scene directory for the new
scene.

File > Save As

Save As

The scene name cannot
exceed 23 characters.
Removed Unused Files
Import and Export
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Command

Action

Access Methods

Save As New Version

Saves the current scene as
another version. The Save
Version dialog box prompts
you to give a name for this
new version. This will create
a new .xstage file in your
current project directory.

File > Save As New
Version

Quit

Closes HarmonyHarmony
Stage.

Windows/Linux: File > Quit

Show Scan Information

Displays a status bar
showing the scanning
information at the bottom of
the Drawing and Camera
view.

Drawing View Menu >
View > Show > Show Scan
Information

Cut

Removes selected objects.
You can then paste the
object or its properties to
another object.

Edit > Cut

Copies selected objects and
properties.

Edit > Copy

Places an object you cut or
copied into the location you
select in the Camera,
Drawing and Timeline View.

Edit > Paste

Removes selected objects.

Edit > Delete

Copy

Paste

Delete

Mac OS X: Stage> Quit

Press [Ctrl] + [X]
(Windows/Linux) or [⌘ ] +
[X] (Mac OS X).

Press [Ctrl] + [C]
(Windows/Linux) or [⌘ ] +
[C] (Mac OS X).

Press [Ctrl] + [V]
(Windows/Linux) or [⌘ ] +
[V] (Mac OS X).

[Delete]
Select All

Deselect All

Undo

Selects all drawing objects in
the current drawing window
in the Drawing, Timeline and
Camera view. This helps you
manage multiple objects as
one when moving them.

Edit > Select All

Deselects all selected
objects in the Drawing and
Camer views.

Edit > Deselect All

Removes remove the last

Edit > Undo

89

Press [Ctrl] + [A]
(Windows/Linux) or [⌘ ] +
[A] (Mac OS X).

[Esc]

Chapter 2: Getting Started Basic Commands

Command

Action

Access Methods

change made to your
project. Harmony supports
multiple undo, so you can
undo changes you made in
the order you made them.

Press [Ctrl] + [Z]
(Windows/Linux) or [⌘ ] +
[Z] (Mac OS X).

Redoes and operation you
have undone that you later
decide to keep. This
command is active only after
you use the Undo command.

Edit > Redo

Lets you select the first element parented to the selected peg element in the
Timeline view skipping
effects in the hierarchy.

Animation > Select Child
Skipping Effects

Select Children

Lets you select all elements
parented to the selected peg
element in the Timeline view.

Animation > Select
Children

Select Child

Lets you select the first
element parented to the
selected peg element in the
Timeline View.

Animation > Select Child

Select Parent Skipping
Effects

Lets you select the parent of
the selected element in the
Timeline view skipping
effects in the hierarchy.

Animation > Select Parent
Skipping Effects

Select Parent

Lets you select the parent of
the selected element in the
Timeline view.

Animation > Select Parent

Select Previous Brother

Lets you select the next
element (above current
element) in the Timeline
view.

Animation > Select
Previous Brother

Lets you select the next
element (below current
element) in the Timeline
view.

Animation > Select Next
Brother

Use the Auto Render Write
command to render a frame
each time the current frame
is changed.

Scene > Render >Auto
Render Write

Redo

Select Child Skipping
Effects

Select Next Brother

Auto Render Write

You must have a Write
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Command

Action

Access Methods

module in your network to
use this command.
Message Log

The Message log view
displays information
gathered during a render
task, like which frames and
at what time they were each
rendered.

Windows > Message Log

Debug Mode

Enable the Debug Mode
option to gather and display
precise information about
each rendering frame such as
the modules encountered
and action taken.

Help > Debug Mode

Help

Launches the Toon Boom
Harmony Help System PDF,
complete with instructions
on how to use the system.

Help > Help

Toon Boom Harmony on
the Web

Launches the Toon Boom
Harmony website, which
features a Support and
Community > Forum
section.

Help > Toon Boom
Harmony on the Web

About

Use the About command to
access general information
about the software.

Windows/Linux: Help >
About

Brings back the Welcome
screen—see Welcome
Screen on page 62

Help > Show Welcome
Screen

Show Welcome Screen

Related Topics
•

Getting Started on page 53
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Preferences
An important feature of Toon Boom Harmony is the Preferences dialog box. From here you can customize your
interface, tool behaviour and shortcuts. Throughout this guide, you are often required to go to the Preferences
dialog box to set parameters and options.

In this section, you will learn how to access the Preferences panel and also find a general description of its
functionality.
To learn about the different preferences available and how they are used in a production context, refer to the
following topics:
•

Getting Started Preferences on page 94

•

User Interface Preferences - General Tab on page 145

•

Camera Preferences on page 1025

•

Network Tab Preferences on page 842

•

Exposure Sheet Preferences on page 522

•

Drawing Preferences on page 288

•

Template Preferences on page 663

•

Timeline Preferences on page 525
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•

Sound Preferences on page 936

•

OpenGL Drawing Preferences on page 288

•

Render Preferences on page 1444

•

Advanced Tab Preferences on page 291

•

Deformation Preferences on page 1195

Related Topics
•

Preference Highlights below

•

Getting Started Preferences on the next page

•

Keyboard Shortcuts on page 95

Preference Highlights
You can set over 80 preferences in the Preferences dialog box. You will learn about them as you read through
this guide and find out how they apply in a production context.
The Preferences panel is divided into the following tabs:
•

Shortcuts

•

General

•

Camera

•

Network

•

Exposure Sheet

•

Drawing

•

Template

•

Timeline

•

Sound

•

OpenGL

•

Render

•

Advanced

•

Deformation

•

Particle

Some preferences require you to exit and restart the application or to close a view and reopen it.

To access the Preferences dialog box:
Do one of the following:
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‣

From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X).

‣

Press [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).

Related Topics
•

Preferences on page 92

•

Getting Started Preferences below

•

Keyboard Shortcuts on the facing page

Getting Started Preferences
In this section, you will find useful preferences to get you started in the General and Timeline tabs.
•

General Tab below

•

Timeline Tab on the facing page

General Tab

Auto-Save
•

Interval (minutes): This is the frequency at which the auto-save takes place.

•

Inactivity Interval (seconds): When Auto-save is about to take place, it verify if you are drawing or doing
anything in the application. If so, Auto-save waits this number of seconds before attempting another save.

•

Ask Before Saving: Before performing an auto-save, the system will prompt you with a message to
confirm if you want to save or not. You can choose to turn off this option.

•

Enabled: This enables the Auto-save feature. If you do not want the system to automatically save your
work, deselect this option. The auto-save is off by default.
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HTML Browser for Unix
This option is used to view the online help on Linux machines. Enter the command to launch the browser,
including the path if necessary.

Timeline Tab

•

Show End of Scene Marker
Enable this feature if you would like to see the red bracket that delineates the end of your scene, in your
Timeline view. If you know that many different hands will be working on your scene, you may want to
disable this option so that the scene length is not increased or decreased by accident.

Related Topics
•

Keyboard Shortcuts below

Keyboard Shortcuts
To speed up your work, all of Toon Boom Harmony’s keyboard shortcuts can be customized. You can even
choose other software keyboard shortcut sets.
•

Selecting a Keyboard Shortcut Set below

•

Customizing a Keyboard Shortcut on the next page

Selecting a Keyboard Shortcut Set
In Toon Boom Harmony, you can choose a set of default keyboard shortcuts you are familiar with. You can
choose between the following:
•

Adobe Flash

•

Toon Boom Harmony

•

Toon Boom Studio

To switch keyboard shortcut sets:
1. Select Edit > Preferences or press [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).
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2. In the Preferences dialog box, select the Shortcuts tab.
3. From the Shortcut Set list, select the desired set.

Customizing a Keyboard Shortcut
You can also customize most of the shortcuts.
To set a shortcut:
1. Do one of the following:
‣

Windows: Select Edit > Preferences

‣

Mac OS X: Select Stage> Preferences.

‣

Press [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).

2. In the Preferences dialog box, select the Shortcuts tab.
3. In the left pane, select a category and then select a command to modify.
4. Click on the shortcut rectangle (above the right pane).

5. On your keyboard, click the desired shortcut.
‣

To remove any keyboard shortcut associated to a command, click Clear.

‣

To reset a command’s default keyboard shortcut, click Default.

6. Click OK.

If a keyboard shortcut is already in use, the Conflict Detected dialog box will appear notifying you of
the command to which it is already associated. You can continue to associate the shortcut or cancel
the operation and choose another command.
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Related Topics
•

Preferences on page 92
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Chapter 3: Interface

Knowing how to manage the Toon Boom Harmony interface helps you to work efficiently and organize your
workspace conveniently. There are a series of views and toolbars you can use as you perform different
operations. Each user has a preferred way of working in the interface and which views and toolbars they will use.
In this chapter, you will learn about the main elements of the interface and how to manage them.

Topics Covered
•

User Interface on the next page

•

Managing the Views on page 130

•

Managing the Toolbars on page 134

•

Managing the Workspace on page 138

•

Interface Navigation on page 143

•

Preferences on page 92
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User Interface

User Interface

This section takes you through the most common elements of the User Interface. Throughout the user guide, you
will learn about each view and toolbar and how and where to use them:
•

Views and Toolbars below

•

Interface Highlights on the facing page

Views and Toolbars
Toon Boom Harmony has several views and toolbars. The Top toolbars are available at the top of the interface
and the View toolbars are in individual windows. View toolbars are only shown if the particular view is displayed
in the workspace.
This is a complete list of the views and toolbars available in Toon Boom Harmony.

Views

Top Toolbars

Camera View on page 102

Advanced Animation Toolbar

Colour View on page 122

Control Point Toolbar

Coordinates and Control Points View on page 972

Coordinate Toolbar

Drawing View on page 156

Deformation Toolbar

Function View on page 984

Display Toolbar

Integrated Help View on page 1205

Easy Flipping Toolbar

Layer Properties View

Edit Toolbar
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Library View on page 126

File Toolbar

Message Log View

Flip Toolbar

Model View

Library Toolbar

Module Library View on page 1203

Mark Drawing Toolbar

Network View on page 801

Onion Skin Toolbar

Perspective View on page 832

Playback Toolbar on page 128

Script Editor View

Rendering Toolbar

Side View

Scripting Toolbar

Timeline View on page 111

Tools Toolbar

Tool Preset View

Workspace Toolbar

Tool Properties View on page 110
Top View
Xsheet View on page 436

View Toolbars
Camera View Toolbar
Colour View Toolbar
Deformation Toolbar
Drawing View Toolbar
Model View Toolbar
Timeline View Toolbar
Xsheet View Toolbar
Network View Toolbar

Interface Highlights
It’s important that you become familiar with the following elements of the user interface, this will help you to
start using Toon Boom Harmony. You can learn more about the highlights described here, and how to use them
in a production context, throughout this guide.
When you start Toon Boom Harmony for the first time, the default workspace is displayed. It contains all of the
main elements you need to use.
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1. Camera View below
2. Tools Toolbar on page 109
3. Tool Properties View on page 110
4. Timeline View on page 111
5. Menus on page 120
6. Colour View on page 122
7. Library View on page 126
8. Playback Toolbar on page 128

Related Topics
•

Managing the Workspace on page 138

•

Managing the Views on page 130

Camera View
The Camera view is the centre of operations in Toon Boom Harmony. It is in this view that you will draw, paint,
animate, create animation paths and see your results. You can also move through your symbol’s hierarchy.
The Camera view has a top and bottom toolbar that you can use to either navigate in the view, change the
display mode or go back up your symbols hierarchy.
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1. Update Preview below
2. OpenGL View Mode on the next page
3. Render View Mode on the next page and Matte View Mode on page 105
4. Camera View Options Menu on page 105
5. Zoom Drop-down Menu on page 107 and Toggle Quick Close-up on page 108
6. Overlay, Line Art, Colour Art, Underlay and Preview Mode on page 108
7. Drawing Name on page 109
8. Tool Name on page 109
9. Frame Number on page 109
10. Editing Stack Menu on page 109

Update Preview
The Update Preview

button lets you check the final look of your effects and fully antialiased image. When you

click the button, Toon Boom Harmony calculates the current frame final image. It displays the result in the
Render View Mode of the Camera view, it does not output an image.
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OpenGL View Mode

The OpenGL View Mode

button switches the Camera view to fast display, letting you see your animation

play in real time. The OpenGL display requires less memory. The final look of your effects is not shown in the
OpenGL View Mode. Switch to the Render View Mode to see your effects.

Render View Mode

The Render View Mode

button switches the Camera view to a fully rendered display showing the final image

of the current frame. If a modification is done to your current frame or if you move to a different frame, click on
the Update Preview button to update the display.
Use the Render View Mode display to see the final look of your frames including effects and antialiasing. You
cannot play back your scene in Render View Mode. To see your scene fully rendered and play it back, you must
select File > Export > Render Network and enable the Preview option in the Render Network dialog box.

104

Toon Boom Harmony 10.3 Stage User Guide

Matte View Mode

The Matte View Mode

button switches the Camera view to a matte display showing the alpha channel of the

elements in your scene. The transparency level ranges from 0 to 100 percent. Zero percent is completely
transparent and represented by black and 100 percent is completely opaque and represented by white.
Everything in between these extremes has a transparency level somewhere between 1 and 99 percent and is
represented in various shades of grey.
‣

To access the Matte View mode, click on the Render View Mode

button and select Matte View

from the drop-down menu.

Camera View Options Menu
The Camera View Option

menu contains several options related to the camera view display modes. Here are

the options contained in the menu:
•

Safe Area

•

Camera Mask

•

BBox Selection Style on the next page

•

Outline Locked Drawings

•

Current Drawing On Top

•

Show Strokes

•

Show Strokes with Colour Wash

•

Light Table

•

Reset View

•

Reset Rotation
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Safe Area

The Safe Area

button shows or hides the TV safety zone and the centre of the camera frame. The Safe Area

will adapt to the scene resolution as well as the safety zone and frame’s centre.
You can also access this feature from the top menu by selecting View > Show > Safe Area.

Camera Mask

The Camera Mask

button shows or hides a black mask around the scene’s frame to avoid seeing the

unnecessary artwork. This option is handy when you are animating and setting up the scene. It allows you to see
your scene’s composition better.
You can also access this feature from the top menu by selecting View > Show > Camera Mask.

BBox Selection Style
Selecting an object in the Camera view with the Transform tool will make a bounding box appear around the
object rather than causing the selected object to be tinted in fuchsia, red or yellow along with the bounding box.

Outline Locked Drawings
Drawings that are locked in the Timeline view (cannot be selected in the Camera view) will be displayed as wire
frames.
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Current Drawing On Top
If this option is enabled, the drawing that is being currently edited with a drawing tool will be temporarily
displayed in front of all the other elements. The actual scene is not modified by this option.

Show Strokes
When drawing with invisible lines such as with the Pencil tool and a line thickness with a value of “0”, the invisible
strokes will be displayed as thin blue lines and the tips of the strokes will be displayed as yellow squares which
helps indicating where the strokes end and where there are gaps in the outline.

Show Strokes with Colour Wash
When drawing with invisible lines such as with the Pencil tool and a line thickness with a value of “0”, the invisible
strokes will be displayed as thin blue lines and the tips of the strokes will be displayed as yellow squares which
helps indicating where there are gaps in the outline. The drawing colours will also be washed out to make the
invisible lines stick out better.

Light Table
By default, while using a drawing tool in the Camera view, the layers that are not being edited are washed out. If
the Light Table option is disabled, the drawings will all be displayed in normal colours even though they are not
being edited.

Reset View
The Reset View

button will reset any panning, zooming or rotation done in the Camera view and return the

display to the initial settings or press [Shift] + [M].

Reset Rotation
The Reset Rotation

button will reset any rotation done in the Camera view and return the display to the

initial rotation settings or press [Shift] + [X]].

Zoom Drop-down Menu
The Zoom menu lets you enlarge or reduce the Camera or Drawing view display.

To make the camera frame size always match the size of your view, select the Fit to View option.
Click the drop-down arrow and select a zoom level or press [1] and [2].
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Toggle Quick Close-up
Use the Magnifier tool to quickly center on the mouse position and zoom in to a pre-defined value such as 4X.
Then you can zoom out again. Hold the shift key and press [Z] to zoom in and back out again. Replacing the
Reset Zoom by pressing [Shift] + [Z].

The area where you zoom in or out is dependent on the cursor location in the Camera view. If you
zoom in and them move the cursor to a different location when you zoom out the mouse will be
centered on that location.

Overlay, Line Art, Colour Art, Underlay and Preview Mode
•

Overlay: Switches to the drawing’s Overlay layer. This layer is located above the Line Art layer. The
default keyboard shortcut is [:].

•

Line Art: Switches to the Line Art layer of the drawing. The default keyboard shortcut is [L].

•

Colour Art: Switches to the Colour Art layer of the drawing. The default keyboard shortcut is [L].

•

Underlay: Switches to the drawing’s Underlay layer. This layer is located under the Colour Art layer.
The default keyboard shortcut is[:].

•

Preview mode: Switches to Preview mode, so you can see both Line Art and Colour Art layers
simultaneously. The default keyboard shortcut is [Shift] + [P].
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You can display the Preview mode drop-down menu and select the Underlay and Overlay layers if you
want to show all four of them at the same time.

Drawing Name
The Drawing Name field displays the name of the selected drawing, as well as the layer containing it. If the cell
does not contain any drawing, an Empty Cell text is shown in the field.

Tool Name
The Tool Name field displays the name of the selected tool. If you override a tool using an overriding keyboard
shortcut, the tool’s name will be highlighted in red letters—see Override Tool on page 279 to learn how to
temporarily override a tool.

Frame Number
The Frame Number field displays the number of the current frame.

Editing Stack Menu

The Editing Stack menu displays the names of the symbols and their hierarchy when you are editing a symbol.
You can click on the different names to go back up to the different parent symbols or the top/current project.

Related Topics
•

Interface Highlights on page 101

Tools Toolbar

The Tools toolbar contains all of the main tools you will use while working in Toon Boom Harmony. In the default
workspace, you will find this toolbar on the left-most side of the interface.

Related Topics
•

Drawing on page 151

•

Traditional Animation on page 293

•

Colour on page 339

•

Morphing on page 527

•

Character Building on page 665
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•

Scene Setup on page 761

•

Animation Paths on page 937

•

Cut-out Animation on page 1029

Tool Properties View

The contextual Tool Properties view contains the most common options and operations related to the currently
selected tool. As soon as you select a tool from the Tools toolbar, the Tool Properties view will be updated.
For example, if you choose the Select

tool in the Tools toolbar, the Tool Properties view will display the

options and operations related to the Select tool such as Snap to Contour, Apply to All Drawings, Flip
Horizontal and Flatten.
To open the Tool Properties view:

‣ Select Windows > Tool Properties.

The content of the Tool Properties view is explained in detail in the following chapters:
•

Drawing on page 151

•

Traditional Animation on page 293

•

Colour on page 339

•

Scene Setup on page 761

•

Cut-out Animation on page 1029
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Timeline View

These are described later in this section.
1. Enable/Disable All on the next page
2. Show Selection and Hide All Others on the next page
3. Add Layers on page 113
4. Delete Layers on page 113
5. Add Drawing Layer on page 113
6. Add Peg on page 113
7. Show/Hide Data View on page 114
8. Current Drawing Displayed on page 114
9. Current Frame on page 114
10. Split on page 115
11. Show/Hide Children on page 115
12. Show/Hide Functions on page 115
13. Change Track Colour on page 115
14. Lock/Unlock Layer on page 116
15. Onion Skin on page 117
16. Drawing Substitution on page 117
17. Keyframe Value on page 118
18. Zoom on page 118
19. Keyframe on page 119
20. Drawing Exposure on page 119
21. Symbol Exposure on page 119
22. Dragging and Pasting Modes on page 119
23. Timeline View Modes on page 119
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The Timeline view is the main view used when adjusting the timing of your drawings, connect effects and order
your layers. The Timeline view displays the following:
•

Layers

•

Effects

•

Sounds

•

Keyframe Values

•

Scene Length

•

Layer Names

•

Drawings

•

Keyframes

•

Timing

•

Frames

Enable/Disable All
The Enable/Disable All

button is used to show or hide all your layers simultaneously.

To disable a particular layer, uncheck the layer’s checkbox or press [D]

To enable a particular layer, place a checkmark (tick) the layer’s checkbox or press [A].

When you disable a layer in the Timeline view, the corresponding column is hidden in the Xsheet
view. When a column is hidden in the Xsheet view, the corresponding layer is disabled in the
Timeline view.

Show Selection and Hide All Others

The Show Selection and Hide All Others

button is used to show only the currently selected layer in the

Timeline view and disable all the other layers.
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Add Layers
The Add Layers

button is used to add new layers to the Timeline view. When you click on the Add Layers

button, a drop-down menu will appear displaying the layer types available. You can add several different types of
layers:
•

Camera

•

Colour-Card

•

Drawing

•

Group

•

Peg

•

Quadmap

•

Sound

Delete Layers
The Delete Layers

button is used to delete the currently selected layers in the Timeline view. When you click

on the Delete Layers button, a Confirm Delete dialog box appears. Click OK to delete the layers or Cancel to
stop the operation.

Add Drawing Layer
The Add Drawing Layer

button is used to automatically add a new drawing layer to your timeline. By default,

the layer is named Drawing.

Add Peg
The Add Peg

button is used to add a peg layer to your timeline. There are several ways to use the Add Peg

button. Refer to Animation Paths on page 937 for more information about pegs and how to use them.
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Show/Hide Data View
The Show/Hide Data View

button is used to display the current frame’s drawing exposure and keyframe

values corresponding to each individual layer.

Hidden Data View

Visible Data View

Current Drawing Displayed

The drawing selected in red represents the drawing currently displayed and is linked to play head position.

Current Frame

The red play head represents the current frame displayed and marked in the Playback toolbar. If you slide the
play head to the left or the right it will scrub through your frames and update the Camera view display.
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Split

The Split

button is used to split the Timeline view in two sections allowing you to see two different portions

of your Timeline view. This way, if your scene length is very long, you can see the beginning and the end at once.

Show/Hide Children

The Show/Hide Children

button is used to display the children layers of a parent layer. Once a layer is

parented to another layer, it is indented to the right and the Show/Hide Children button appears on the parent
layer allowing you to show or hide the child layer.

Show/Hide Functions

The Show/Hide Functions

button is used to display the functions embedded in each layer. The Functions are

the different position and intensity information used to remember a layer’s position, scale or rotation as well as
an effect’s look on each frame. This information is stored on the function curves using keyframes. Refer to
Animation Paths on page 937 for more information about the function layers.

Change Track Colour
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The Change Track Colour

button is used to change the colour of the exposed frames, this helps you to

quickly locate a layer in the Timeline view. Double-click on the swatch to open the picking window and choose a
new colour.

Lock/Unlock Layer

The Lock/Unlock Layer

button is used to prevent the selection or editing of a layer in the Camera view.

To select some of the layers without selecting others, in the Timeline view, lock the layers you do not want to
select.
In the top menu, there are a series of locking options. Select Animation > Lock > select one of the following
actions:
•

Lock
This option locks the currently selected element.

•

Unlock
This option unlocks the currently selected element.

•

Lock All
This option locks all the elements in the Camera view.

•

Unlock All
This option unlocks all the elements in the Camera view.

•

Lock All Others
This option locks all the elements in the Camera view except the currently selected one.
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You can display the locked drawings as outlines in the Camera view if you want to quickly find out which drawings
are locked.

To display locked drawings as outline:
1. In the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X).
2. In the Preferences panel, go to the Camera tab.
3. In the Tools section, enable the Show Locked Drawings As Outlines option.

Onion Skin

The Onion Skin

button is used to enable the Onion Skin option on a particular layer. If you want to see the

previous and next frames of a specific layer, go to the Timeline view and click on the Onion Skin button for that
particular layer. Blue arrows appear on both sides of the play head. Pull on these blue arrows to add more
frames to the onion skin display.
To activate the general Onion Skin preview, in the Tools toolbar, click on the Onion Skin

button.

Drawing Substitution
The Drawing Substitution

field is used to change the drawing exposed at the current frame. To access the

Drawing Substitution field, you must first expand the Data view by clicking on the Show/Hide Data View
button.
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To change the current drawing either click and slide your cursor left or right when you see the hand

cursor,

or double-click on the drawing name and type a new value.

The drawing exposure will be changed for the entire block it is exposed, not just the current frame.

Keyframe Value

The Keyframe Value field is used to add, remove or modify a keyframe at the current frame. To access the
Keyframe Value field, you must first expand the Data view by clicking on the Show/Hide Data View
button.
•

To add a keyframe at the current frame, click on the Add Keyframe

button.

•

To remove an existing keyframe at the current frame, click on the Delete Keyframe

•

To change the current keyframe, either click and slide your cursor left or right when you see the hand

button.

cursor, or double-click on the keyframe value and directly type a new value.
•

To navigate through the existing keyframes, click on the Previous Keyframe

and the Next Keyframe

buttons.
•

To link your layer to an existing function or to create a new function, click on the Show Function Menu
button to display the drop-down Function menu.

Refer to Modifying a Path in the Timeline View on page 981 to learn more about using the Data view
and the Keyframe Value field.

Zoom

The Zoom tool is used to increase or reduce the width of the frames in the Timeline view. Drag the cursor to the
right to increase the width or to the left to reduce it. You can also press [1] and [2].
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Keyframe
A black square is displayed in the Timeline view when a keyframe exists. You are able to select these keyframes
and drag them wherever you want on the timeline. You can also copy, cut and delete them.
•

To delete a keyframe without deleting the drawing exposure, go to the Timeline view and select the
keyframe to be deleted and then select Animation > Delete Keyframes from the top menu.

When a parent layer is collapsed and a child layer contains a keyframe, a white square will be displayed.

Drawing Exposure

In the Timeline view, when a drawing is exposed, it is represented as a grey block. If the drawing is exposed for
several frames, the block is extended. When a second drawing is exposed, a new grey block is displayed.

‣ The exposure’s colour can be changed. To pick a new colour, double-click on the Change Track Colour
button in the corresponding layer.

Symbol Exposure

In the Timeline view, when a symbol is exposed it is represented as a small film frame. If the symbol is exposed
for several frames, the film frame is extended. When a second symbol’s frame is exposed, a new film frame is
displayed.

Timeline View Modes
To streamline the process of working with elements in the Timeline, there are three different view modes you can
choose to work in. With each mode you select, certain elements may or may not be visible in the Timeline.
Depending on your workflow, this can come in useful to quickly hide elements when you want to focus on specific
ones. To select a view mode, use the drop down menu located in the Timeline view.

Dragging and Pasting Modes
As you animate you will find that you may reuse a lot of positions, drawings and keys. However, you may only
want to paste the drawings, or just the keys or maybe everything. There are different paste options available in
the Timeline view which will give you the maximum flexibility when reusing and pasting.
There are three different modes for pasting your selection:
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Paste Mode: All Drawing Attributes
Pastes the drawing exposure and keyframes.

•

Paste Mode: Keyframes Only
Pastes only the keyframes.

•

Paste Mode: Exposures Only
Pastes only the drawing exposure.

Refer to Copying and Pasting Animation on page 1104

Related Topics
•

Timing on page 433

•

Character Building on page 665

•

Scene Setup on page 761

•

Animation Paths on page 937

•

Cut-out Animation on page 1029

•

Effects on page 1199

Menus
You can access the commands from the following menus:
•

Top Menu below

•

View Menu on the facing page

•

Quick Access Menu on page 122

Top Menu

The top menu contains most of the commands. Depending on the view you are working in and the element,
some commands are available and others not. The top menu is always located at the very top of the user
interface.
The top menu contains the following categories:
•

File

•

Edit

•

View

•

Play

•

Insert
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•

Scene

•

Drawing

•

Selected

•

Tools

•

Options

•

Colours

•

Palettes

•

Animation

•

Windows

•

Help

In the Mac OS X version, there is a Stage category containing the following commands:
•

Preferences

•

About

•

Quit

View Menu

Some views have their own menu. These menus contain commands specifically related to that view.
You can find a View menu in the following views:
‣

Colour View

‣

Camera View

‣

Drawing View

‣

Function View

‣

Library View

‣

Model View

‣

Module Library View

‣

Network View

‣

Perspective View

‣

Script Editor View

‣

Side View

‣

Top View

‣

Xsheet View

121

Chapter 3: Interface

Interface Highlights

To access the view menu, click on the Menu

button in the view’s top left corner.

Quick Access Menu

Each view has a Quick Access menu containing recurring actions. This menu is accessed by right-clicking
anywhere in the view.

Related Topics
•

Interface Highlights on page 101

Colour View
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1. Add Colour below
2. Remove Colour below
3. Add Texture on the next page
4. Set Current Brush Colour on the next page
5. Set Current Pencil Colour on the next page
6. Set Current Paint Colour on page 125
7. Link/Unlink Three Colours on page 125
8. Show/Hide Palette List View on page 125
9. Colour Swatch Name on page 125
10. Colour Swatch on page 126
11. Colour View Menu on page 126
The Colour View is where you create colours and palettes and import existing palettes into your project. The
Colour View is also necessary for drawing, painting and creating colour styling.
The Colour View has two display modes:
•

List Mode

•

Swatch Mode

To toggle between the display modes:
1. In the Colour View menu, select Colours > Swatch Mode.
‣

Enable the option to display the swatches.

‣

Disable the option to display the colour list.

Add Colour
The Add Colour

button is used to add a colour swatch to your palette. Click on the Add Colour button to

add a new swatch to the bottom of your colour list.

Remove Colour
The Remove Colour

button is used to delete the currently selected colour swatches. If the colour swatch is

used in your project, the Delete Colour dialog box will pop and will ask you to confirm the operation.

‣ Click OK to confirm the operation or Cancel to cancel it.
Zones painted with colour swatches which have been deleted will turn red, easily identifying them so you can
repaint them with another colour swatch.
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Add Texture

The Add Texture

button is used to add a bitmap colour swatch to your palette. Use this to load photos and

textures and paint your drawings with it. The bitmap image must be a TGA or PSD file format.

Set Current Brush Colour
The Set Current Brush Colour
by the Brush

button is used to set the currently selected colour swatch as the colour used

tool. If you select a new colour in the Colour view while using the Brush tool, the Set Current

Brush Colour swatch will be updated.

Set Current Pencil Colour
The Set Current Pencil Colour
by the Pencil

, Polyline

button is used to set the currently selected colour swatch as the colour used
, Ellipse

, Rectangle

and Line

tools. If you select a new colour in the

Colour view while using any of these tools, the Set Current Pencil Colour swatch will be updated.
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Set Current Paint Colour
The Set Current Paint Colour
the Brush

button is used to set the currently selected colour swatch as the colour used by

tool. If you select a new colour in the Colour view while using the Paint tool, the Set Current Paint

Colour swatch will be updated.

Link/Unlink Three Colours

The Link/Unlink Three Colours

button is used to link the Set Current Brush Colour, Set Current Pencil

Colour and Set Current Paint Colour swatches to the currently selected colour swatches in the Colour view.

Show/Hide Palette List View

The Show/Hide Palette List View

button is used to display the Palette List view in the Colour view. This

option is for the advanced user who wants to create colour palettes for their props and characters.

Colour Swatch Name

Each colour swatch available in the Colour view can have its own name, making it easy to identify which colour is
used to paint what part of your character or background.

Two colours can have the same name.
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Colour Swatch

A colour swatch is a specific colour used to paint a certain zone of a character or background. Colour palettes
are composed of colour swatches. They can also be called colour pots. When you paint a zone with a colour
swatch, the zone is linked to the swatch. So if you update the swatch’s tint, the zone will be updated along with
it. This allows you to modify your animation colours even after it is completely painted.

Colour View Menu
The Colour View

menu allows you to access commands that are specifically related to the Colour view such

as creating new palettes, adding new colour swatches and displaying the Tint panel. The commands listed in the
Colour View menu can also be found following a similar path from the top menu categories Colours and Palettes.

Edit Palette Mode
In Network mode, to avoid accidentally modifying the palette, the palette files can be locked. Enable the Edit
Palette Mode
to get the rights to modify the palette.

Related Topics
•

Colours on page 342

Library View

1. Library View Menu on the facing page
2. Preview Window on the facing page
3. Preview Playback on the facing page
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4. Library Folder List below
5. Template/Symbol List on the next page
The Library view is used to store elements such as animation, drawings, backgrounds and puppets to reuse
them in your different projects. You also use the Library view to create and store your symbols.
To reuse an element in another project, you must create a template out of your drawings. A template is a mini
scene that you import in your other project. A template has no link to the original scene. When you create a
template, the full content of your selection is copied in the template.
When you are creating a series of layers all using the same drawings or building puppets, you will create
symbols. These can be used as drawing containers when you are creating puppets so that you can store different
mouth shapes or hands to use while animating. You can also use symbols when you are building props, such as a
skateboard and you want to use the same wheel drawing for the four skateboard wheels.

Refer to Library on page 625 to learn more about using the library, symbols and templates in context.

Library View Menu
The Library View

menu allows you to access commands that are specifically related to the Library view such

as importing SWF movies and Illustrator files, adding a new folder and refreshing the library’s content.

Preview Window
The Preview window is used to see the content of the currently selected template or symbol in the
Template/Symbol list.

Preview Playback
The Preview Playback button is used to play back the content of the selected template or symbol if it contains
more than one frame. Press the Play
button to play back the preview.

Library Folder List
The Library Folder List displays all of the folders linked to the Library view. There are two default folders:
•

Symbols
The Symbols folder is the only folder containing symbols. The user can organize it by adding subfolders
inside.

•

Stage Library
The Stage Library folder is a default library found on the hard drive in the user’s documents. This folder
can contain templates, but no symbols.

The user can link new library folders to the Library view and organize them with subfolders.
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Template/Symbol List
The Template/Symbol list displays the templates or symbols contained in the selected library folder. If you rightclick, you can display the templates and symbols’ thumbnails by selecting View > Thumbnails.

Related Topics
•

Library on page 625

Playback Toolbar

Use it to play back your animation and sound. Use it to scrub your sound to create your lip-sync, looping your
playback, navigating through your frames, change the playback range and speed.
•

Click on the Play

button to play and stop the animation. You can also do this from the top menu by

selecting Play > Play Scene Forward or Stop.
•

Click on the Loop

button to repeat your playback indefinitely. Or do this from the top menu by

selecting Play > Loop.
•

Click on the Sound

button to enable sound in the playback. Or do this from the top menu by

selecting Play > Enable Sound.
•

Click on the Sound Scrubbing

button to enable sound scrubbing in the play back. Or do this from the

top menu by selecting Play > Enable Sound Scrubbing.
•

Click on the Render and Play

button to create a render of your scene to play back the final result

including the effects.
•

Scroll through the playback’s frames using the Jog Frames right and left arrows.

•

To change the playback frame range enter new values in the Start and Stop fields.

•

Enter a new value in the FPS field to change the speed of the playback.
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Play Menu
Select any of the following from the top menu Play heading:
•

First Frame jumps to the first frame. You can also press [<].

•

Next Frame jumps to the frame after the currently selected frame in the Timeline view. You can also press
[.].

•

Last Frame jumps the last frame. You can also press [>].

•

Previous Frame jumps to the frame before the frame currently selected in the Timeline view. You can also
press [,].

•

Go to Frame or use the Go

button, which can be added to the Timeline View toolbar through the

Toolbar Manager. Open the Go to Frame dialog box so you can type in the frame number to jump to.
•

Enable Playback view from either the Top, Side or Perspective views.
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Managing the Views
The Toon Boom Harmony user interface is composed of different views, each one designed for a specific
purpose. This section explains how you can modify the location and accessibility of the views by adding a new
view as a tab or as a window, you can also swap the view locations around.

Workspace modifications are automatically saved when you exit the application unless you disabled
the Automatically Save Workspace preference in the Preferences panel.

•

Adding a New View below

•

Closing a View on the facing page

•

Swapping Views on the facing page

•

Resizing a View on page 132

Adding a New View
To add a view:
1. Select the view you want to add from Windows > The desired view.

You can also use the Window drop-down menu button included in each view already available in the
workspace. Click on the button and select a view from the list. You can only open one instance of the
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same view. In other words, you cannot have two Camera views open at the same time.
You can open several instances of the same view except for the Timeline, Tool Properties, Colour and
Drawing views.

2. To dock a floating window in your workspace, drag the window’s tab onto one of the workspace’s views.

Closing a View
To close a view:
1. In the view to close, click on the Close View
‣

button.

If you have several tabs in the same window, hold [Shift] down and click on the Close View

button

to close all tabs together.

Swapping Views
With Harmony, you can easily swap views around.
To swap views around:
1. Select the view tab and drag it onto one of the view’s separators, top area or onto another view’s tab.
2. When a rectangle outline appears showing an available location for the view, release the mouse button
and drop the view tab into position. One of three things will happen:
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•

1. The view becomes a tabbed window.

•

2. The view becomes a floating window.

•

3. The view becomes a new docked window.

Resizing a View
To change the width and height of the views in the workspace, drag the side of the view.
To resize a view:
1. In the interface, position your cursor on the edge of the view you want to resize.
2. When you see the Resizing

cursor, click and drag the side of the window to the desired width or

height.

You can also temporarily hide a view to get more working space.
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To temporarily hide a view:
1. On the edge of the window you want to hide click on the Collapse/Expand button. The view is
compressed and only the Collapse/Expand button is visible.
2. Click on the same Collapse/Expand button to display the view again.

Related Topics
•

Managing the Toolbars on the next page

•

Managing the Workspace on page 138
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Managing the Toolbars
The Toon Boom Harmony user interface contains toolbars which, by default, are located at the top of the
interface. Some of the workspace’s views also have their own toolbars. These toolbars can be moved around.
You can reposition the toolbars to suit your work style or hide unused ones.
•

Showing or Hiding Toolbars below

•

Moving Toolbars on the facing page

•

Flat Tool Toolbar Preference on the facing page

•

Toolbar Manager on page 136

Showing or Hiding Toolbars
To show or hide a toolbar:

‣ Select Windows > Toolbars > the desired toolbar.
You may right-click anywhere in the toolbar area to access Toon Boom Harmony toolbars. View toolbars,
however, are not available by right-clicking the toolbar area. You can access the toolbar of any open and active
view by right-clicking in the workspace area.

You may also hide a portion of a toolbar by dragging another open toolbar over its tail-end.
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The Toolbar menu only contains the View toolbars of the views that are open in the workspace. As
you show or hide views in your workspace, the Toolbar menu will update.

Moving Toolbars
To move a toolbar:
1. Select the toolbar you want to move by clicking on its anchor point

and dragging it into a view

toolbar area or another position in the top or side interface toolbar area.

2. When a rectangle outline appears showing an available location for the toolbar, release the mouse button
and drop the toolbar into position.

‣

1. Dock to the top toolbar area.

‣

2. Move a toolbar down a row.

‣

3. Dock to the left toolbar area.

Flat Tool Toolbar Preference
By checking on this option you can expand the toolbar so that there are no nested toolsets in the toolbar. When
you check this option you will need to close Harmony and relaunch it for the new interface to be displayed. A
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default set of tools will appear in the toolbar. However, you can customize which tool icons appear in the toolbar
to fit your own work pattern.

To use the Flat Tool Toolbar:
1. Open the Preferences window, Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X)
and click on the General tab.
2. Enable the Flat Tool Toolbar preference by clicking on its checkbox.
3. Click on the OK button to apply the change.
4. Save your work and close Toon Boom Harmony.
5. Relaunch Toon Boom Harmony. You will notice that the Tools toolbar has changed and no longer
contains nested tools.
If the default toolbar does not contain the tools you require, you can custom-build the toolbar.
Once you have enabled the Flat Tool Toolbar preference, you can customize the tools which appear in the
toolbar. This means that you can change the default set of tools and replace the tools which you use less
frequently with ones which are used more often. This customizing is done through the Toolbar Manager.

Toolbar Manager
The View toolbars can be customized to contain your favourite tools and options. Use the Toolbar Manager
window to organize your different toolbars to suit your working preferences.
To customize your toolbars:
1. In the chosen view,right-click on any button in the toolbar where you wish to add or subtract a new
button.
2. From the pop-up menu, select Customize.

The Toolbar Manager window opens.
3. To add a new icon to your toolbar, select the tool or command from the Available Tools list and click on
the Right Arrow
button to switch it to the Toolbar list.
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4. To remove an icon from your toolbar, select the tool or command in the Toolbar list and click on the Left
Arrow
button to switch to the Available Tools list.

5. To reorder your icons in your toolbar, select the command to be moved in the Toolbar list and click on the
Up
or Down
buttons to move it to the correct location.

6. Click on the OK button when you are finished.

Related Topics
•

Managing the Workspace on the next page

•

Managing the Views on page 130
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Managing the Workspace
Toon Boom Harmony’s user interface is composed of several views. You can customize your workspace to suit
your working preferences, save it as a new workspace, and load it from the Workspace toolbar.
•

Loading a Workspace below

•

Workspace Manager below

•

Restoring the Default Workspaces on page 142

Loading a Workspace
The first time you open Toon Boom Harmony, the default workspace is loaded. Other workspaces are available
such as the Hand-Drawn Animation and the Compositing workspaces, these display different views and
toolbars. You can access these workspaces and any you create, from the Windows menu and the Workspace
toolbar.
To load a workspace:
1. In the top menu, select Windows > Workspace > Workspace or click on the drop-down arrow in the
Workspace toolbar and select a workspace from the list.

Workspace Manager

To open the Workspace Manager:
‣

In the Workspace toolbar, click on the

‣

In the top menu select Windows > Workspace > Workspace Manager.

button.

The Workspace Manager allows you to modify, create, delete, rename and reorder you workspaces.
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•

Creating a New Workspace below

•

Renaming a Workspace on the next page

•

Saving a Workspace on the next page

•

Deleting a Workspace on page 141

•

Showing and Hiding a Workspace on page 141

•

Reordering the Workspace List on page 142

Creating a New Workspace
To create a new workspace:
1. Open the Workspace Manager.
2. In the Available Workspaces list, select an existing workspace.

3. At the bottom of the Available Workspaces list, click on the Add

button to add a workspace.

4. Select the new workspace option, then click on the Rename button and give it a new name.

5. Select the new workspace and click on the Right Arrow

6. Click on the OK button.

139

button to send it to the Workspace toolbar.

Chapter 3: Interface

Workspace Manager

Renaming a Workspace
To rename a workspace:
1. Open the Workspace Manager.
2. Choose the workspace to be renamed from the list.
3. Double-click on the workspace to be renamed or click on the Rename button. This allows you to edit the
name.

4. Type in the new name of the workspace.
5. Press the [Enter/Return] key to validate the name.
6. Click on the OK button.

Saving a Workspace
By default, when you modify the look of a workspace, it is automatically saved. If you prefer to keep your
workspaces as they are and only save the modifications when you really want to, you have to disable the
Automatically Save Workspace preference.
To disable the Automatically Save Workspace preference:
1. In the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X) to open
the Preferences panel.
2. Go to the General tab.
3. In the Save section, disable the Automatically Save Workspace preference.

4. Press the OK button.
The Save Workspace

button appears in the Workspace toolbar.

To save a workspace manually:
1. In the Workspace toolbar, click on the Save Workspace

button.

You can also select Windows > Workspace > Save Workspace.
You can save your workspace as a new version to avoid over-writing the current one.
To save your workspace as a new version:
1. Select Windows > Workspace > Save Workspace As.
The Save Workspace As dialog box opens.
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2. In the text field, enter the new workspace name.
3. Click on the OK button to validate.

Deleting a Workspace
To delete a workspace:
1. Open the Workspace Manager.
2. In the Workspace Manager, select the workspace to be deleted and click on the Left Arrow

button

to send it to the Available Workspaces list.

3. Select the workspace in the Available Workspaces list then click on the Delete

button to delete the

workspace.
4. Click on the OK button.

Showing and Hiding a Workspace
To show a workspace:
1. Open the Workspace Manager.
2. In the Available Workspaces list, select the workspace to be displayed and click on the Right Arrow
button to send it to the Workspace toolbar.
3. Click on the OK button.
To hide a workspace:
1. Open the Workspace Manager.
2. In the Workspace Manager, select the workspace to be hidden and click on the Left Arrow
send it to the Available Workspaces list.
3. Click on the OK button.
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If you do not want to modify the current workspace, use the Workspace Manager to create another one and
then modify that one.

Reordering the Workspace List
To reorder workspaces:
1. Open the Workspace Manager.
2. In the Workspace toolbar, select the workspace to be reordered and click on the Up
buttons to move it up or down.

3. Click on the OK button.

Restoring the Default Workspaces
You can restore modified workspaces to their original default layout.
To restore the default workspaces:

‣ In the top menu select Windows > Restore Default Workspace.
Related Topics
•

Managing the Views on page 130

•

Managing the Toolbars on page 134
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Interface Navigation
Toon Boom Harmony supports zoom in, zoom out, rotate, pan and reset view for easy interface navigation for
the views.
•

Zoom In: Zooms into the view. From the top menu, select View > Zoom In , press [2], or roll the mouse
wheel up. In the Timeline and Xsheet views, press [Ctrl] and roll the mouse wheel up.

•

Zoom Out: Zooms out of the view. From the top menu, select View > Zoom Out , press [1], or roll the
mouse wheel down. In the Timeline and Xsheet views, press [Ctrl] and roll the mouse wheel down.

•

Zoom In and Out: Hold down [Spacebar] and the middle mouse button while dragging the mouse up or
down.

•

Pan: Hold down the [Spacebar] and drag the mouse in the direction in which you want to pan the view.

•

Reset Pan: Resets the view’s pan to its default position. From the top menu, select View > Reset Pan or
press [Shift] + [N].

•

Recenter view: Recenters the view on your mouse cursor or press [N].

•

Reset View: Resets the view to its default position. From the top menu, select View > Reset View or
press [Shift] + [M].

•

Reset Rotation: Resets the view’s rotation to its default position. From the top menu, select View >
Reset Rotation or press [Shift] + [X].

•

Reset Zoom: Resets the view’s zoom to its default position. From the top menu, select View > Reset
Zoom.

•

Toggle Full Screen: Enlarges the selected view to full screen. The full screen process is done in three
stages. From the top menu, select View > Toggle Full Screen or press [Ctrl] + [F] (Windows/Linux) or [⌘ ]
+ [F] (Mac OS X).
•

First, the selected view enlarges to the maximum width or height, but keeps the tool views such as
Colour or Tool Properties view.

•

Second, the view enlarges to full screen.

•

Third, the view returns to its original size.

•

Rotate 90 CW: Rotates the Camera view 90 degrees clockwise, like an animation table. From the top
menu, select View > Rotate View CW.

•

Rotate 90 CCW: Rotates the Camera view 90 degrees counter-clockwise, like an animation table. From
the top menu, select View > Rotate View CCW.

Related Topics
•

Zoom below

Zoom
From the Tools toolbar, use the Zoom

tool to zoom in and zoom out in the Camera or Drawing view.

•

The keyboard shortcuts are [1] and [2].

•

When the Zoom In mode is selected, hold [Alt] as you click to zoom out.
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Zoom Tool Properties
When you select the Zoom tool, its properties are displayed in the Tool Properties view.

Zoom In
Enable the Zoom In

mode in the Options section to zoom in when using the Zoom tool.

Zoom Out
Enable the Zoom Out

mode in the Options section to zoom out when using the Zoom tool.

Perform Zoom In
Use the Zoom In
•

operation to perform a zoom in the Camera or Drawing view.

The keyboard shortcut is [2].

Perform Zoom Out
Use the Zoom Out
•

operation to perform a zoom out in the Camera or Drawing view.

The keyboard shortcut is [1].

Reset Zoom
Use the Reset Zoom

operation to restore the current zoom level to 100%.

Reset View
The Reset View

restores the original display by resetting pan, rotation or zoom actions.

Related Topics
•

Interface Navigation on the previous page

•

Zoom on page 291
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Interface Preferences
Adjusting preferences to suit your work style allows you to work more efficiently.

To open the Preferences panel:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

Press [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).

In the Preferences panel, you will find the preference related to the interface in the Camera, OpenGL and General
tab.

Related Topics
•

User Interface Preferences - General Tab below

•

User Interface Preferences - Camera Tab on page 149

•

Full Scene Antialiasing Preference in the OpenGL tab on page 149

User Interface Preferences - General Tab
To customize your interface, you will use some of the preferences located in the General tab as well as the
Camera tab.

Automatically Save Workspace
The Automatically Save Workspace preference is enabled by default. Every time you add a view to your
workspace, remove a toolbar or change a view’s width, these modifications are saved when you quit the
application. If you do not want the system to save these modifications, disable the preference.
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This preference does not require you to restart the application.

Refer to the Managing the Workspace on page 138 section to learn more about this preference.

Focus on Mouse Enter
The Focus on Mouse Enter preference is disabled by default.
In Toon Boom Harmony, for the operations or keyboard shortcuts to work in the view in which you are working,
the focus must be in that view. When the focus is on a particular view, a red rectangle appears around its frame.
You must click in the view or on the view’s header for the focus to be done.
If you enable the Focus on Mouse Enter preference, you will not need to click in the view to get the focus. It will
be done as soon as your mouse enters the view.
This preference does not require you to restart the application.

If you enable the Focus On Mouse Enter preference, certain operations from the top menu may not
be available since the view focus may change as you make your way to the top menu. In this case use
keyboard shortcuts and quick access menus (right-click menus).

Flat Tool Toolbar
You can expand the toolbar so that there are no nested toolsets in the toolbar. You will need to close Harmony
and relaunch it for the new interface to be displayed. A default set of tools will appear in the toolbar. However,
you can customize which tool icons appear in the toolbar to fit your own work pattern.

Once you have enabled the Flat Tool Toolbar preference, you can customize the tools which appear in the
toolbar. This means that you can change the default set of tools and replace the tools which you use less
frequently with ones which are used more often. This customizing is done through the Toolbar Manager.
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To customize the toolbars refer to Toolbar Manager on page 136.

Levels of Undo
The Levels of Undo preference determines the number of actions retained by the Undo list. By default, 50 actions
are stored in the list. You can alter the number if you want to.
This preference does not require you to restart the application.

Colours
The Colours preference allows you to modify the colours of the different user interface views and elements. For
example, you can change the Camera view’s background colour from grey to white.
Altering these preferences requires you to restart the application or to close a view and reopen it for the
modifications to be applied.

Current View Border
The Current View Border preference sets the colour of the frame around the workspace view you are currently
using, also known as focus. By default, the colour is red. Click on the red colour swatch to select a new colour in
the Colour Picker window.

Current View Border in Template Edit
The Current View Border preference sets the colour of the frame around the workspace view you are currently
using when editing a template from your library view. By default, the colour is green. Click on the green colour
swatch to select a new colour in the Colour Picker window.

Edit Colours Button
Click on the Edit Colours button to open the Colours window.
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In the Colours window, you can modify any of the colours from the list. Most of the modifications will require you
to restart the application or close the view and reopen it to see them.
•

To restore all of the default interface’s colours, click on the Restore All Defaults button.

The Colours window is divided into the following categories:
•

Camera

•

Network

•

Exposure Sheet

•

Drawing

Click on any of the colour swatches and select a new colour from the Colour Picker window.
•

•

Onion Skin
•

Onion Skin After: Changes the colour display of the next drawing when using the Onion Skin feature.

•

Onion Skin Before: Changes the colour display of the previous drawing when using the Onion Skin
feature.

Others
•

Background: Changes the background colour of the Drawing and Model view.

•

Backlight: Changes the display colour of the Backlight option.

•

Grid: Changes the display colour of the grid when using the Show Grid option.

•

Colour View Background: Changes the background colour of the colour list area of the Colour view.

•

Colour Highlight Mode Opacity: Changes the opacity value of the washed out art when using the
Highlight Selected Colour option.

To restore all of the default interface’s colours, click on the Restore All Defaults button.
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Related Topics
•

User Interface Preferences - Camera Tab below

•

Full Scene Antialiasing Preference in the OpenGL tab below

User Interface Preferences - Camera Tab

Zoom Settings
In the Zoom Settings section, you can change the Camera View Default Zoom value from the drop-down menu.
This selection sets the Reset View value in the Camera, Top and Side views.

Related Topics
•

User Interface Preferences - General Tab on page 145

•

Full Scene Antialiasing Preference in the OpenGL tab below

Full Scene Antialiasing Preference in the OpenGL tab
The Full Scene Antialiasing is generated by your computer’s graphic card it provides a smooth line display in
OpenGL. This antialiasing will not only antialias your drawings but all your different views in the interface.
This preference can be turned on or off, Full Scene Antialiasing preference is disabled by default.
This option lets you see smooth lines as you draw as well as an antialiased drawing area. You can change the
value of the Full Scene Antialiasing using the Preferences dialog box to fit the current level used in the Camera or
Drawing view.
To use Full Scene Antialiasing do the following:
1. Select Edit > Preferences > OpenGL tab (Windows/Linux) or Stage > Preferences > OpenGL tab (Mac
OS X).
2. In the Full Scene Antialiasing section, select the Enable option.
3. In the Number or samples (For Mac OS), enter the number of samples you want to be used for the
antialiasing process. The number of samples is basically equivalent to the amount of time a pixel will be
enlarged to calculate the antialiasing. This technique is called supersampling. The higher the number of
samples, the better the antialiasing quality will be, but the longer it will take to calculate. The
recommended value is 4.
4. Restart Toon Boom Harmony.

149

Chapter 3: Interface

Interface Preferences

If you are using Windows or Linux, you must enable your graphic card’s antialiasing parameter. Refer
to your graphics card manufacturers user guide to learn how to do so. For example, the parameters
for an NVIDIA GeForce card may look like this:

Related Topics
•

User Interface Preferences - Camera Tab on the previous page

•

User Interface Preferences - General Tab on page 145
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Chapter 4: Drawing

In Toon Boom Harmony, many powerful tools, views and features are available so you can design, draw and
animate with ease. This chapter explains the main assets needed when drawing and animating in the software as
well as tips on how to start and use these tools efficiently.

Topics Covered
•

How to Draw on page 153

•

Tool Properties View on page 155

•

Drawing View on page 156

•

Camera View on page 159

•

Drawing with the Brush or the Pencil on page 165

•

Working with Tool Presets on page 167

•

Viewing the Final Lines as you Draw on page 174

•

Drawing Using the Pencil Tool on page 178

•

Drawing with the Brush Tool on page 196

•

Drawing with Line Texture on page 207

•

Selecting Drawing Objects on page 216

•

Erasing Parts of a Drawing on page 231

•

Reshaping a Drawing Using the Contour Editor Tool on page 235

•

Reshaping Pencil Lines with the Pencil Editor Tool on page 241
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•

Drawing with Shapes on page 247

•

Drawing with the Polyline Tool on page 255

•

Drawing Using Invisible Lines on page 258

•

Deforming a Drawing Using the Perspective Tool on page 262

•

Cutting Drawing Parts on page 266

•

Smoothing Lines on page 270

•

Working With Text on page 274

•

Override Tool on page 279

•

More Drawing Tools on page 280

•

Drawing Pivot Tool on page 286

•

Drawing Preferences on page 288
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How to Draw
As soon as Toon Boom Harmony is started, you can start to draw straight away using the default drawing layer.
How to draw:
1. In the Tools toolbar, select the Brush

tool or press [Alt] + [B].

2. In the Timeline or Xsheet view, click in the first cell of the drawing layer.
In Harmony Paint, select a drawing in the Drawing panel.

3. In the Drawing or Camera view, start drawing.

4. To select a different colour, in the Colour view, select the a different colour swatch. Double-click on the
colour swatch to open the Colour Picker window and modify the colour. Remember that anything already
painted with that colour swatch will update to the new colour.

If you are working in Database mode, refer to Locking Drawings on page 83 to learn how to lock and
unlock drawings.
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Related Topics
•

Adding a Colour Swatch on page 344

•

Adding New Drawing Layers on page 457

•

Tool Properties View on the facing page
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Tool Properties View
The Tool Properties view is where you can customize the currently selected tool. The options and operations
displayed changes according to each tool you select.

Manipulators
Manipulators are buttons which let you switch quickly between similar tools such as the Select tool and the
Transform tool or the Line, Rectangle and Ellipse tools.

Options
Options are different modes you can apply to a selected tool to modify its behaviour to fit the current task’s
needs.

Operations
Operations are actual actions you can perform while using the selected tool.

Related Topics
•

How to Draw on page 153
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Drawing View
In Toon Boom Harmony, you can draw in the Drawing or Camera view. Although the two views are similar, when
it comes to drawing, there are some differences.
Only the selected drawing is displayed by default in the Drawing view. You can use features, such as the light
table to display the current frame drawing of all the enabled layers of your scene in washed-out colours, or the
Onion Skin to display the previous and next drawings of the currently selected drawing layer.

1. Drawing Area below
2. Zoom Drop-down Menu on the facing page
3. Drawing View above
4. Drawing Name on the facing page
5. Tool Name on the facing page
6. Current Frame on the facing page
7. Cursor Coordinates on the facing page
8. Colour Picker on page 158

Drawing Area
This is the Drawing view’s main space, it is where you draw, and where the drawings are displayed.
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Zoom Drop-down Menu
The Zoom menu lets you enlarge or reduce the Camera or Drawing view display.

To make the camera frame size always match the size of your view, select the Fit to View option.
Click the drop-down arrow and select a zoom level or press [1] and [2].

Drawing Name
The Drawing Name field displays the name of the selected drawing, as well as the layer containing it. If the cell
does not contain any drawing, an Empty Cell text is shown in the field.

Tool Name
The Tool Name field displays the name of the selected tool. If you override a tool using an overriding keyboard
shortcut, the tool’s name will be highlighted in red letters—see Override Tool on page 279 to learn how to
temporarily override a tool.

Current Frame
This field displays the current frame of the animation you are working on.

Cursor Coordinates
This indicates the position of your mouse cursor in the drawing area.

Drawing Name
Displays the name of the currently selected drawing.
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Colour Picker
The Colour Picker allows you to select a colour to draw with.

Related Topics
•

Camera View on the facing page
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Camera View
In Toon Boom Harmony, you can draw in either the Drawing view or Camera view. Although the two views are
similar, when it comes to drawing, there are some differences.

1. Zoom Drop-down Menu on the next page
2. Overlay, Line Art, Colour Art, Underlay and Preview Mode on page 161
3. Drawing Name on page 162
4. Tool Name on page 162
5. Current Frame on page 162
6. Current Colour on page 162

For more details about the Camera view's interface, see Camera View on page 102

In the Camera view, you can use the Onion Skin feature to display previous and next drawings. By default, all the
enabled drawing layers in the selected frame are displayed, letting you edit them together. This way, you can use
the Select
tool to select many objects from individual layers at once.
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To make easier to select objects on a single drawing, you can set a preference. Select Edit >
Preferences and select the Camera tab, then select the Select tool Works on Single Drawing
option.

To enable the onion skin from the Timeline view:

‣ In the Timeline view, click the Onion Skin

icon of the desired layer.

By locking a layer, you can prevent yourself from being able to select it in the Camera view, while keeping the
drawing visible as a reference and disabling the layers you don’t want to display in the Camera view.
To lock a drawing layer:

‣ In the Timeline view, click the Lock

icon of the layer you don’t want to edit.

To hide a drawing layer:
1. In the Timeline view, click the check box corresponding to the layer you want to hide.

Zoom Drop-down Menu
The Zoom menu lets you enlarge or reduce the Camera or Drawing view display.

To make the camera frame size always match the size of your view, select the Fit to View option.
Click the drop-down arrow and select a zoom level or press [1] and [2].
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Overlay, Line Art, Colour Art, Underlay and Preview
Mode
•

Overlay: Switches to the drawing’s Overlay layer. This layer is located above the Line Art layer. The
default keyboard shortcut is [:].

•

Line Art: Switches to the Line Art layer of the drawing. The default keyboard shortcut is [L].

•

Colour Art: Switches to the Colour Art layer of the drawing. The default keyboard shortcut is [L].

•

Underlay: Switches to the drawing’s Underlay layer. This layer is located under the Colour Art layer.
The default keyboard shortcut is[:].

•

Preview mode: Switches to Preview mode, so you can see both Line Art and Colour Art layers
simultaneously. The default keyboard shortcut is [Shift] + [P].
You can display the Preview mode drop-down menu and select the Underlay and Overlay layers if you
want to show all four of them at the same time.

To activate the Preview Mode button in the Camera view bottom toolbar, you must enable the
Current Drawing on Top option.

To enable the Current Drawing On Top option:
1.

In the Camera bottom toolbar, click on the Camera Option button.

2.

In the drop-down menu, enable the Current Drawing on Top option.

See Show Current Drawing on Top on the next page.
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Drawing Name
The Drawing Name field displays the name of the selected drawing, as well as the layer containing it. If the cell
does not contain any drawing, an Empty Cell text is shown in the field.

Tool Name
The Tool Name field displays the name of the selected tool. If you override a tool using an overriding keyboard
shortcut, the tool’s name will be highlighted in red letters—see Override Tool on page 279 to learn how to
temporarily override a tool.

Current Frame
This field displays the current displayed frame of the animation.

Current Colour
This field displays the current colour name and its colour swatch. You can open the Colour Picker by doubleclicking the colour swatch—see Colour on page 339.

Related Topics
•

Show Current Drawing on Top below

•

Drawing View on page 156

Show Current Drawing on Top
In Toon Boom Harmony, when you draw on a layer, the artwork is displayed in the correct order. For example, if
the layer on which you are drawing is located behind an object on another layer, the lines you are drawing will be
hidden behind that object.
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This option lets you display the selected drawing on top of everything while your draw. By enabling this option,
each time you select a drawing tool, the selected drawing is displayed in front of everything in the Camera view.
The Timeline and Network view ordering remain unchanged.

The Show Current Drawing on Top status (enabled or disabled) is remembered when you exit
Harmony. When you restart the application, the last status will be used.

To display your drawing on top:
1. Do one of the following:
2. From the top menu, select View > Show > Current Drawing on Top.
3. In the Camera toolbar, click the Camera Option button and select the Current Drawing on Top option.

4. In the Tools toolbar, select a drawing tool.
5. In the Camera view, start drawing.

You only need to enable this option once, it is not necessary to do it each time you select a drawing
tool.
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Related Topics
•

Camera View on page 159

•

How to Draw on page 153
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Drawing with the Brush or the Pencil

The Brush

and Pencil

tools are used to draw and sketch with. Both tools support pressure sensitivity,

allowing you to create lines with variable thickness. The Pencil and shape tools produce central vector lines. The
Brush tool produces contour vector lines. This means that a pencil line’s control points (used to deform its
shape) are located along the length of the central spine and the Brush line’s control points are located along the
contour.
•

If you draw with the Pencil tool and want to modify the thickness variation, use the Pencil Editor

•

If you draw with the Brush tool and want to modify the thickness, use the Contour Editor

•

You can also convert a brush zone into a pencil line with the Brush Stroke to Pencil Line

tool.

tool.
option.

If you sketch a drawing using a semi-transparent colour to get a paper-like feel, you should use the Brush tool as
it produces a more realistic and natural feel. The pencil line is very useful for tracing, clean or final drawings.
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Also, it is recommended to use brush lines when designing cut-out puppets’ articulations which use patches.

Related Topics
•

Drawing Using the Pencil Tool on page 178

•

Drawing with the Brush Tool on page 196

•

Reshaping a Drawing Using the Contour Editor Tool on page 235

•

Drawing with Shapes on page 247

•

Patch Articulation on page 749

•

How to Draw on page 153
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Working with Tool Presets
Create tool presets for 20 different tools, including the Paint, Polyline, Transform, Brush and Select tools.
Define the colour, size and tool properties for the preset. Import a preset, or add a script, to have it perform
specified actions. In addition, assign shortcuts for up to 10 of these presets.

To create a Tool Preset:
1. From the Tools toolbar, select a drawing tool.
2. In the Tool Properties panel, customize the selected tool. For example, if you have the Brush tool
selected, you can tailor its maximum and minimum thickness, as well as assign a texture to it.
3. In the Colour view, create, or select, a colour.
4. In the Tool Presets view, click on the Create New Preset

button, or from the View

menu, select

New Preset.
The new preset appears in the swatch section of the Tool Presets view with much of its details filled in
based on the information provided in the Tool Properties panel.
To delete a Tool Preset:
1. In the Tool Presets view, select the preset that you would like to delete.
2. Click on the Delete Preset

button, or from the View

menu, select Delete Preset.

To save a Tool Preset:
1. In the Tool Presets view, select the preset that you would like to save.
2. Be sure that the Store in Preferences option is enabled (checked).
3. Either save your entire project, or from the View
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Customizing a Tool Preset
To customize a Tool Preset icon:
1. In the software, create an icon for your new tool preset. You can either export this icon as a *.png, or
simply save your scene.
2. In the Details section of the Tool Presets view, click on the Assigning icon to preset

button to bring

up the browser window.
3. Browse to and select the *.png that you just created, or browse to your current project folder and select
the *.tvg from your project's elements folder.
4. Click on the Open button.
The icon appears in both the Details section, and on the swatch of your new tool preset.

5. From the View

menu, select Icon Mode to view just the icons of your tool presets, instead of the

large swatches.

To customize a Tool Preset name:
1. In the Tool Presets swatch window, select the tool preset that you would like to rename.
2. In the Details section, delete the text "New Preset" and enter in the name of your choice.
The new name is automatically saved.
3. From the View

menu, select Swatch Mode to display just the name of your tool preset, as well as a

small sample of the preset's properties.
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To assign a shortcut for the Tool Preset:
1. In the top menu, go to Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X).
2. In the Preferences panel, in the Shortcuts tab, select Tool Presets and then the Tool Preset Shortcut
number.
3. In the field beside the Clear button, enter the new keyboard shortcut.
4. If you have more than one tool preset shortcut to create, continue selecting the Tool Preset Shortcut
number, and then enter the new keyboard shortcut.
5. When you are through, click on the OK button.
The shortcut is now displayed in the Tool Presets window, in the Shortcut drop-down menu next to its
Tool Preset Shortcut number. It is also displayed in the top, right corner of the large tool preset swatch.

All new tool presets will be assigned the shortcut for Tool Preset Shortcut, which is 0. In order to
change this, you will need to select another shortcut number from the Shortcut drop-down menu.

To customize the Tool Preset tool:
1. Before creating a new tool preset, from the Tools toolbar, select the drawing tool that you would like to
create the new preset for. This is the tool that automatically appears in the Tool drop-down list, in the
Tool Presets view, for a new preset.
The icon of the selected tool will appear in the upper, left corner of the large swatch of the tool preset.
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2. If you would like to change the currently selected tool for one of your presets, select another drawing tool
from the Tool drop-down menu.
3. If you would like to make your preset properties universally applicable to any drawing tool, uncheck the
Tool option box.
The tool icon will disappear from the large tool preset swatch.
To customize the size of the Tool Preset:
1. In the Tool Presets view, select the tool preset that you would like the modify.
2. In the Tool Properties panel, note that a new pen style called PRESET has automatically been created
and selected. This style is linked to the selected tool preset; any changes made in the Tool Properties
panel will directly affect the selected tool preset.

3. In the Tool Properties panel, adjust the minimum and maximum size values.
4. In the Tool Presets view, click on the pen size swatch to update it, or click on the Refresh
The large tool preset swatch updates automatically.
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5. If you would like to see just the maximum tip size of your tools in the swatch section, from the View
menu, select Swatch Mode (Small).

To customize the colour of the Tool Preset:
1. In the Tool Presets view, select the tool preset that you would like to modify.
2. In the Colour view, select, or create, a new colour swatch.
3. In the Tool Presets view, click on the colour swatch to update it, or on the Refresh

button.

4. If you would like to make your preset properties universally applicable for any colour selected in the
Colour view, uncheck the Colour option box.
The colour swatch will disappear from the Details section.

If you have the Colour option checked in the Tool Presets view, and then you click on a different
colour swatch in the Colour view, you will end up colouring with the newly selected colour swatch.
To ensure that you are using the colour assigned to the tool preset, click on the tool preset
immediately before beginning to use it.

To customize a Tool Preset using a script:
1. In the Tool Preset view, click on the Script button.
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The Script to Execute dialog box opens.

2. In the Enter new script field, enter the script string that will be used to modify your preset.
3. Click on the OK button.

For information concerning scripts, please refer to the Harmony Scripting Guide and the Script
Editor view.

Importing, Exporting and Sharing Tool Presets
Once you have created several tool presets, you might decide that you would like them to be available for
another project, either on your computer, or elsewhere for other users.
To make a Tool Preset available for multiple projects on the same computer:
Be sure that the Store in Preferences option box is checked before you save and close your project. If you do not
have this box checked for each tool preset, not only will the tool preset not be available in other projects, but it
will also not be saved between sessions on the same project.
To share a Tool Preset with other users:
1. In the Tool Presets view, from the View

menu, select Export Presets.

A browser window opens asking you to select a folder where it can save the *.xml file.
2. Click on the Choose button.
3. Transfer the folder containing the toolPresets.xml file to another computer, then launch Harmony
10.3.
4. On the second computer, in the Tool Presets view, from the View

menu , select Import Presets.

A browser window opens asking you to select the folder where the toolPresets.xml file exists.
5. Click on the Choose button.
The tool presets from the first computer now appear in Tool Presetsthe view of the second.

The toolPresets.xml file will appear as a greyed out file, or may not appear at all, if the Show
Hidden Files option is disabled on your computer. It is important to realize that the software is
looking for the location (folder) of the *.xml file and not the file itself.
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When you import the tool presets from another source, all those presets automatically have the
Store in Preferences option box unchecked. To ensure that these imported presets are saved for the
next session, be sure to check the Store in Preferences option box for each tool preset.

It may happen that when you open the Tool Presets view, all the tool presets that have a colour element will
appear in red, and the Colour swatch will show the error message: Lost Colour. This may occur for any
number of reasons, the most likely being that the new project is missing the necessary colour palette.
To recover lost colours:
1. In the Tool Presets view, from the View

menu , select Recover Lost Colours.

The colours are restored to the tool presets, and if the original palette was missing, a new recovered
palette will be created.
To remove temporary Tool Presets:
1. In the Tool Presets view, select a tool preset that you would like to delete.
2. Uncheck the Store in Preferences box for this preset.
3. Continue selecting and disabling this option box for any other preset that you would like to delete.
4. Be sure that no preset that you would like to save has the Store in Preferences option box disabled. For
example, if you imported presets from another source, all those presets have the Store in Preferences
option box automatically disabled by default. Once you remove a preset, this action is not undoable.
5. From the View

menu , select Purge non Savable Presets.

The unwanted presets are removed from the Tool Presets view.

Related Topics
•

Drawing with the Brush Tool on page 196

•

Drawing Using the Pencil Tool on page 178

•

Adding a Colour Swatch on page 344

•

Tool Properties View on page 155
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Viewing the Final Lines as you Draw

Everything you draw in Toon Boom Harmony is vector-based. Although, when you draw in the Camera or
Drawing view, you will notice that your lines may be jagged, this is caused by the fast real-time display called
OpenGL.
If you prefer to see smooth lines as you draw, you can enable the antialiasing. There are two types of antialiasing
in Toon Boom Harmony:
•

Full Scene Antialiasing below

•

Real-Time Antialiasing on the facing page

Full Scene Antialiasing
Not available in Harmony Paint.
The Full Scene Antialiasing is generated by your computer’s graphics card. This antialiasing will not only antialias
your drawings, but all your different views in the interface.
Full Scene Antialiasing is a preference you can turn on and off. By default, the Full Scene Antialiasing preference is
disabled.

Full Scene Antialiasing parameters are only valid while you work in your scene. The scene will be
rendered out to 100% of its resolution regardless of your settings in the preferences or graphic card
panel.
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To customize the full scene antialiasing parameters:

This procedure requires that if you have a Mac OS you must restart the Harmony after you have
changed the parameters.

1. If you are using Windows or Linux, you must enable your graphic card’s antialiasing parameter. Refer to
your graphics card manufacturers user guide to learn how to do so. For example, the parameters for an
NVIDIA GeForce card may look like this:

2. In the Harmony, do one of the following:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Stage > Preferences.

‣

Press [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).

The Preferences dialog box opens.
3. In the OpenGL tab, go to the Full Scene Antialiasing section.

‣

Enable: Select this option to enable/disable the Full Scene Antialiasing.

‣

Number or samples (For Mac OS): If you are using a Mac OS X computer, enter the number of
samples you want to be used for the antialiasing process. The number of samples is basically
equivalent to the amount of time a pixel will be enlarged to calculate the antialiasing. This technique is
called supersampling. The higher the number of samples, the better the antialiasing quality will be, but
the longer it will take to calculate.

4. Restart the Harmony.

Real-Time Antialiasing
It is highly recommended that you use Full Scene Antialiasing. The Real-Time Antialiasing method
is NOT RECOMMENDED as it is heavier to run than the Full Scene Antialiasing.
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Real-Time Antialiasing is generated by . This means that when you draw your lines, the preview becomes
antialiased as you go. If you zoom in more than 100% in the Camera view, pixels will start to appear. Your
elements are still fully vector based. Only the preview becomes pixelated. Your drawings are antialiased to the
scene’s resolution.
Antialiasing is a preference you can turn on and off. By default, the Real-Time Antialiasing preference is
disabled.
This option lets you see the final result of your scene as you draw. You can change the value of the antialiasing
through the Preferences dialog box, to fit to the current zoom level used in the Camera or Drawing view or to
disable it.

Real-Time Antialiasing parameters are only valid while you work in your scene. The scene will be
rendered out to 100% of its resolution regardless of your settings in the Preferences panel.

To customize the antialiasing parameters:
1. Select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X).
The [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).
The Preferences dialog box opens.
2. In the OpenGL tab, go to the Real-Time Antialiasing section.

•

‣

Enable check box: Click on the Enable check box to enable or disable the Real-Time Antialiasing. The
[Ctrl] + [Alt] + [A] (Windows/Linux) or [⌘ ] + [Alt] + [A] (Mac OS X).

‣

Render at this Factor Times the Scene Resolution: The default value is 1. This value corresponds to
how many times larger than the scene’s resolution you want your drawings to be antialiased. If you
zoom into your drawings to 200% you should set the value to 2.

‣

Tile Size: When the drawing is antialiased, the whole is broken into small tiles to make the process
faster. Only the tiles with artwork on are rendered out. When you modify a zone on your drawing, only
the modified tiles are updated.

Making the tiles too small results in sending more tiles to be rendered out, which makes the process
longer.
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•

Making the tiles too large results in sending bigger tiles out to be rendered out which is more of a strain
on the video card. Since the tiles are larger, they get updated more often because the artwork you modify
may be one of these tiles.
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Drawing Using the Pencil Tool

The Pencil

tool creates a centreline shape. Pencil lines now support pressure sensitivity and texture.

To draw with the Pencil tool:
In the Timeline or Xsheet view, select the cell on which you want to draw.
In Harmony Paint, select a drawing in the Drawing panel.

1. In the Tools toolbar, select the Pencil

tool or press [Alt] + [/].

2. In the Colour view, click a colour swatch to select a colour.

3. In the Drawing or Camera view, start drawing.
‣

When you get close to an existing pencil line, hold [Alt] to draw connect your stroke to the existing
one. Pencil lines are central vector lines and you might think your line is connected, but in fact, only the
contour is touching the other one. Also, make sure the central vector crosses the other one.
You can use the [Alt] key to connect the start of your stroke or the end of it by holding it when you
start drawing or when you finish your line.

‣

To draw a straight line, press [Shift] + [Alt] as you draw.
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Related Topics
•

Pencil Tool Options below

•

Drawing with the Brush or the Pencil on page 165

•

Drawing with Shapes on page 247

Pencil Tool Options
When you select the Pencil

tool, its properties and options appears in the Tool Properties view.

These are the options available for the Pencil tool:
•

Draw Behind on the next page

•

Create Colour Art Automatically on the next page

•

Auto-Flatten Mode on page 181
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•

Auto-Close Gap on the facing page

•

Line Building Mode on the facing page

•

Auto Adjust Thickness on page 182

•

Line Pushing Mode on page 183

•

Thickness Stencils on page 183

•

Minimum and Maximum Size on page 184

•

Central Line Smoothness on page 184

•

Contour Optimization on page 184

•

Changing the Line Shape on page 184

•

Previewing the Stroke on page 185

•

Pencil Line Texture on page 185

Draw Behind

When drawing on vector layers, the Draw Behind mode lets you paint behind existing art. By default, strokes will
appear over your work until you release the tool. If you want to have live preview of your stroke in draw behind
mode, you must activate the Realistic Preview option.
To activate Realistic Preview:
‣

From the top menu, select View > Realistic Preview.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically
corresponding strokes in the Colour Art layer.
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Auto-Flatten Mode
When drawing on vector layers, lines do not usually become one object. The Auto-Flatten mode automatically
merges lines created with the existing ones into one single object as you draw.
When drawing on a bitmap layer, you are laying down the bare pixels, so they are always flattened. You can no
longer access the individual stroke after you draw it.

Using the Select tool, you can use the middle mouse button to select a segment of a flattened pencil
line to create a nice finish on the lines and corners of your artwork.

Auto-Close Gap

When using the pencil tool, you can automatically close strokes with an invisible stroke.
It is recommended to keep this option enabled when drawing with the Pencil tool.

Line Building Mode
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The Line Building

mode is very useful when drawing long lines and curves in small increments with pencil

lines. As the pencil lines are central vector lines and it may be difficult to align the line tips perfectly to create a
uniform stroke and close all gaps.
In this mode, you can draw lines in small increments and the tip are merge into one single stroke.

This mode only works with pencil lines.

Auto Adjust Thickness

The Auto Adjust Thickness

tool is useful when you want to render a portion of a line thicker. When tracing a

drawing on paper, you will often go back to a section of a curve to make it thicker to add dynamism to the line.
Using the Auto Adjust Thickness tool, you can draw highlight strokes over the section to make thicker. Once you
release the pen or the mouse, the line gets thicker following the shape and curve of the original stroke. This way
is much faster and smoother than using the Pencil Editor tool. You do not have to add extra points and adjust
the position and Bezier handles.
The default overlay colour is light yellow. If this colour is difficult to see because of your background or drawing
colour, you can adjust the colour.
To change the Auto Adjust Thickness Colour:
1. In the Tools toolbar, select the Pencil

tool.

2. In the Tool Properties view, select the Auto Adjust Thickness
3. Click the colour swatch.

The Colour Picker window opens.
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4. In the Colour Picker window, select a new colour.

Line Pushing Mode

The Line Pushing Mode

option lets you draw highlight strokes over your existing pencil lines. You can

reshape the curves. Depending how you draw the pushing stroke over your line, the highlighted section will be
reshaped in one direction or the other.
The default overlay colour is light yellow. If this colour is difficult to see because of your background or drawing
colour, you can adjust the colour.
To change the Line Pushing Mode colour:
1. In the Tools toolbar, select the Pencil

tool.

2. In the Tool Properties view, select the Line Pushing Mode

button.

3. Click the colour swatch.

The Colour Picker window opens.
4. In the Colour Picker window, select a new colour.

Thickness Stencils
Toon Boom Harmony provides a variety of thickness stencils and also lets you create and save your own. It is a
good idea to create and save pencils with precise sizes and parameters when you draw and design.
A thickness stencil saves a preset of how the thickness information looks across the length of the line. When
drawing with a thickness stencil, the pressure sensitivity of the tablet is discarded in order to apply the thickness
stencil.
A thickness stencil can be used while drawing, or applied afterwards.
You also have the possibility to apply different textures to your lines by either using the preset ones or importing
your own—see Working with Templates on page 185
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Minimum and Maximum Size
This is where you set the minimum and maximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.

1. Minimum Size field: Type a value in this field to set the minimum width of the line.
2. Maximum Size field: Type a value in this field to set the maximum width of the line.
3. Up/Down arrows: Use the up and down arrows to set the minimum size value.
4. Up/Down arrows: Use the up and down arrows to set the maximum size value.

Central Line Smoothness
You can modify the Central Line Smoothness

of your line using this option. This parameter smoothes the

initial movement of your line. Increasing the value will result in a smoother line with fewer control points.

Contour Optimization
You can optimize the Contour Line Smoothness of you line using this option. This parameter will smooth the
contour of your line once the line has been traced, the higher the value the less control points will compose your
line.

1. Smoothness field: Type a value to set the smoothness of the line.
2. Contour Optimization field: Type a value to set the contour optimization of the line.
3. Up/Down arrows: Use the up and down arrows to set smoothness value.
4. Up/Down arrows: Use the up and down arrows to set the contour optimization value.

Changing the Line Shape
There are several line shape to choose from. You can select how the start, end, and joints in the pencil line are
drawn.
To change the line shape:
In the Pencil Properties window, click a line shape in the Shape section and select a shape from the menu.

•

Start: Make the beginning of the line round or flat.

•

End: Make the end of the line round or flat.
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•

Join: Make joints round, mitred, or bevelled.

Previewing the Stroke

1. The Arrow button lets you show or hide the Preview area.
2. The Preview field is where the brush line is displayed.

Pencil Line Texture
You can apply a bitmap texture on your pencil line and adjust it as needed—see Pencil Line Texture on page 189

Related Topics
•

Drawing with Line Texture on page 207

•

Pencil Line Texture on page 189

•

Working with Templates below

•

Drawing Using the Pencil Tool on page 178

Working with Templates

A template is a preset that already set with specific properties.
A template allows you to set the size and smoothing of the line or shape. As you draw, the thickness of the line
varies according the amount of pressure you use with a pen and tablet.
You can access templates from the list of preset on the Tool Properties view, or create your own.
•

Selecting a Pencil Template on the next page

•

Creating a Pencil Template on the next page
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•

Creating a Pencil Templatewith the Select Tool on the facing page

•

Renaming a Pencil Template on the facing page

•

Deleting a Pencil Template on page 188

•

Locking a Pencil Template on page 188

•

Applying a Pencil Template on page 188

Selecting a Pencil Template
Using the drop-down menu, you can select an existing pencil template.
To select a pencil template:
1. In the Tools toolbar, select the Pencil

, tool.

2. In the Tool Properties view, in the Pencil Template drop-down menu, select the template you want to
use.

3. In the Drawing or Camera view, draw your pencil line.

Creating a Pencil Template
To create a pencil template:
1. In the Tools toolbar, select the Pencil

, tool.

2. In the Tool Properties view, click the New Pencil

button.

A new pencil template is added to the end of the list in the Pencil Template drop-down menu.
3. Start drawing in the Camera or Drawing view.
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Creating a Pencil Templatewith the Select Tool
To create a pencil template with the Select tool:
1. In the Tools toolbar, select the Select

tool.

2. In the Camera view, select the pencil line you want to take the style from.

3. In the Tool Properties view, click the New Preset

button.

A new pencil template is added to the end of the list in the Presets drop-down menu.
4. In the Tool Properties view, click the Apply Pencil Template

button to apply to the style to your

selection.
5. In the Presets drop-down menu, select your new pencil template and click on a line or shape in the Camera
view to apply the pencil template you created.

Renaming a Pencil Template
To rename a pencil template:
1. In the Tools toolbar, select the Pencil

, tool.

2. In the Presets drop-down menu, select the pencil template you want to rename.
3. Click the Rename Pencil

button.

The Rename Preset dialog box opens.

4. In the Name field, type in a name for the selected pencil template you are renaming.
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Deleting a Pencil Template
To delete a pencil template:
1. In the Tools toolbar, select the Pencil

tool.

2. In the Presets drop-down menu, select the pencil template to delete.
3. Click the Delete Preset

button.

Locking a Pencil Template
To avoid modifying your pencil template inadvertently, you can lock them by enabling the Lock Pen

option.

Applying a Pencil Template
To apply a pencil templateto a pencil line:
1. In the Tools toolbar, select the Select

tool.

2. In the Camera or Drawing view, select the pencil line on which you want to apply a style.

3. In the Tool Properties view, select the style you want to apply from the Pencil drop-down menu.

4. In the Tool Properties view, click the Apply Pencil Template
selection.
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Related Topics
•

Pencil Tool Options on page 179

•

Shape Tool Options on page 248

•

Select Tool Properties on page 219

Pencil Line Texture
You can apply a texture on a pencil line.
•

Applying Texture to a Pencil Line below

•

Creating a Pencil Texture Template with the Pencil Tool on the next page

•

Adding a Texture to the Preferences on page 193

•

Applying a Preset Texture to a Pencil Line on page 194

•

Creating a Pencil Texture Template with the Select Tool on page 191

Applying Texture to a Pencil Line
Pencil lines support texture. Before drawing, you can select or import a texture and apply it to your lines. You
can also change it afterwards using the Select tool. Textures are independent from pencil templates.
To apply a preset texture to a pencil line:
1. In the Tools toolbar, select the Pencil

tool.

2. In the Tool Properties view, in the Texture drop-down menu, select a texture.
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3. If you want your lines to have soft tips instead of hard ends, select the Soft Tip option.
4. In the Camera or Drawing view, draw your pencil line.

Creating a Pencil Texture Template with the Pencil Tool
To create a pencil texture template with the Pencil tool:
1. In the Tools toolbar, select the Pencil

tool.

2. In the Tool Properties viewr, click the New Texture
‣

To delete a preset style, click the Delete Texture

button.
button.

3. Browse for your bitmap texture file.

The file must be a TGA or PSD. Your texture MUST HAVE an alpha channel.
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4. Click Open.
The imported texture is saved in your scene texture list.

5. In the Tool Properties view, in the Texture drop-down menu, select your new texture template.

6. In the Tool Properties view, click the Rename Texture

button.

The Rename Opacity Texture dialog box opens.

7. In the Name field, type the template name and click OK.
8. If you want your lines to have soft tips instead of hard ends, select the Soft Tip option.
9. In the Camera or Drawing view, draw your pencil lines.

Creating a Pencil Texture Template with the Select Tool
To create a pencil texture template with the Select tool:
1. In the Tools toolbar, select the Select

tool.

2. In the Camera view, select a pencil line on which to apply a texture.
3. In the Tool Properties viewr, click the New Texture
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‣

To delete a preset style, click on the Delete Texture

button. Note that you cannot delete the

textures stored in your preferences.
4. Browse for a bitmap texture file.

The file must be a TGA or PSD. Your texture MUST HAVE an alpha channel.

5. Click Open.
The imported texture is saved in your scene texture list.

6. In the Tool Properties view, in the Texture drop-down menu, select your new texture template.

7. In the Tool Properties view, click the Rename Texture

button.

The Rename Opacity Texture dialog box opens.

8. In the Name field, type the template name and click OK.
9. If you want your lines to have soft tips instead of hard ends, select the Soft Tip option.
10. In the Tool Properties view, click the Apply Texture
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Adding a Texture to the Preferences
When you import a texture in your pencil styles, it is saved in your scene. If you want to add that texture to a
bank that you will be able to reuse in different scenes, you can add that texture to your preferences.
To add a texture to your preferences:
1. In the Tools toolbar, select the Pencil

tool.

2. In the Tool Properties view, in the Texture drop-down menu, select the texture you want to add to your
preferences.

The selected texture appears in the Scene preview. If the texture is already saved in your preferences, you
will see the texture in both the Scene and the Pref. previews.

3. To save the texture in your preferences, click the Copy Current Texture into Preference arrow. You can
save the texture as a new one or, if there is already a texture saved in the preference, you can override it.

4. You might receive a scene from someone else or import a texture over your existing one by mistake. If you
want to override the Scene texture with the corresponding one available in your preferences, you can
click on the Copy Preference Texture into Current arrow.
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Applying a Preset Texture to a Pencil Line
To apply a preset texture to a pencil line:
1. In the Tools toolbar, select the Select

tool.

2. In the Camera view, select a pencil line.

3. In the Tool Properties view of the Select tool, select a texture from the Texture drop-down menu.

4. If you want the selected lines to have soft tips instead of hard ends, select the Soft Tip option.
5. In the Tool Properties view, click the Apply Texture
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Related Topics
•

Pencil Tool Options on page 179

•

Select Tool Properties on page 219

•

Drawing with Line Texture on page 207
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Drawing with the Brush Tool

The Brush

tool is pressure sensitive and can create a contour shape which gives a thick and thin line effect, as

if the drawing was made with a brush.
To draw with the Brush tool:
1. In the Timeline or Xsheet view, select the cell on which you want to draw.
In Harmony Paint, select a drawing in the Drawing panel.

2. In the Tools toolbar, select the Brush

tool or press [Alt] + [B].

3. In the Colour view, click a colour swatch to select a colour.

4.
5. In the Drawing or Camera view, start drawing.
‣

Hold [Ctrl] (Windows/Linux) or [⌘ ] (Mac OS X) to force a line to join the end and start of your shape
while drawing.
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The last colour you select while using the Brush tool is recalled the next time you select the Brush
tool.

Related Topics
•

Brush Tool Options below

Brush Tool Options
When you select the Brush

tool, its properties and options appear in the Tool Properties view.

These are the options available for the Brush tool:
•

Brush Tool Options above

•

Draw Behind on the next page

•

Repaint Brush Mode on the next page

•

Create Colour Art Automatically on the next page

•

Auto-Flatten Mode on page 199

•

Respect Protected Colour on page 199

•

Use Stored Colour Gradient on page 199

•

Drawing Magnifier on page 199

•

Brush Styles on page 200

•

Dynamic Brush on page 200

•

Minimum and Maximum Size on page 200

•

Central Line Smoothness on page 201
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•

Contour Optimization on page 201

•

Brush Tips on page 201

•

Preview on page 201

•

Line Texture on page 201

The Normal Brush Mode

creates contour lines as you draw, adding each brush lines on top of the last ones.

Draw Behind

When the Draw Behind

mode is enabled, the lines you draw will appear behind the art that already exists.

Repaint Brush Mode

The Repaint Brush

is used to repaint zones that have already been painted, it will not affect empty zones or

pencil lines. It also automatically flattens each of its brush lines so it does not add new brush lines on top of
existing ones. You can use this mode to paint tones or highlights onto your character.

Create Colour Art Automatically
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As you draw in the Line Art layer, the Create Colour Art Automatically

automatically creates the

corresponding strokes in the Colour Art layer.

Auto-Flatten Mode
When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing artwork as
you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes and pencil lines will flatten
with pencil lines.

Respect Protected Colour
The Respect Protected Colour

option prevent the colours you marked as protected in the Colour view to

be repainted using the Repaint Brush mode or any of the painting tools.

Refer to Protecting Colours on page 385 to learn how to use the Protect Colour feature.

Use Stored Colour Gradient
The Use Stored Colour Gradient

option makes your tool use the previously stored gradient position. This

way, every new brush line or colour fill will use the stored gradient position.

Refer to Storing Your Favourite Gradient or Texture Settings on page 380 to learn how to use the
Store Colour Gradient option.

Drawing Magnifier
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The Drawing Magnifier

tool allows you to magnify portions of your drawing. When this option is enabled,

you can hover over your drawings to see a close up of your lines in the Magnifier box.

This feature only works in the Drawing view.

To adjust the settings for the Drawing Magnifier:
1. In the top menu, select Edit > Preferences > Drawing.
2. Adjust the Magnifier window Width, Height, X-Axis Offset, Y-Axis Offset, and Zoom Factor.

Brush Styles
A variety of brush styles are provided allowing you to create and save your own. This way you can create brushes
with precise sizes and parameters and save them so you can draw and design—see Brush Styles on page 202

Dynamic Brush
A Dynamic Brush

can be created to allow you to draw using patterns created from your artwork—see

Dynamic Brush on page 204

Minimum and Maximum Size
This is where you set the minimum and maximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.

1. Minimum Size field: Type a value in this field to set the minimum width of the line.
2. Maximum Size field: Type a value in this field to set the maximum width of the line.
3. Up/Down arrows: Use the up and down arrows to set the minimum size value.
4. Up/Down arrows: Use the up and down arrows to set the maximum size value.
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Central Line Smoothness
You can modify the Central Line Smoothness

of your line using this option. This parameter smoothes the

initial movement of your line. Increasing the value will result in a smoother line with fewer control points.

Contour Optimization
You can optimize the Contour Line Smoothness of you line using this option. This parameter will smooth the
contour of your line once the line has been traced, the higher the value the less control points will compose your
line.

1. Smoothness field: Type a value to set the smoothness of the line.
2. Contour Optimization field: Type a value to set the contour optimization of the line.
3. Up/Down arrows: Use the up and down arrows to set smoothness value.
4. Up/Down arrows: Use the up and down arrows to set the contour optimization value.

Brush Tips

In this drop-down menu, you can find a variety of tip shapes from round and square ones to star shaped, select
the one you need.

Preview
The Preview field lets you see a preview of the style that will be produced after you customize the different
parameters in the Tool Properties view.

1. The Arrow button lets you show or hide the Preview area.
2. The Preview field is where the brush line is displayed.

Line Texture
In Toon Boom Harmony, you can draw with a textured line. Textured lines are a mixed bitmap image contained
in a vector frame. This allows you to sketch as if you are drawing on paper.
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Refer to the Drawing with Line Texture on page 207 topic to learn everything about line texture and
its parameters.

Related Topics
•

How to Draw on page 153

•

Drawing with the Brush Tool on page 196

•

Drawing with Line Texture on page 207

•

Working with Templates

Brush Styles
You can create your own brush styles.
•

Selecting a Brush Style below

•

Adding a Brush Style on the facing page

•

Renaming a Brush Style on the facing page

•

Deleting a Brush Style on the facing page

•

Locking a Brush Style on the facing page

Selecting a Brush Style
A variety of brush styles are provided allowing you to create and save your own.This way you can create brushes
with precise sizes and parameters and save them so you can draw and design.

To select a brush style:
1. Click the arrow button to get the Brush Style drop-down menu.
2. Select a brush style from the list.
To select a brush style:
•

In the Tool Properties, select a brush style from the Brush Presets section.
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Adding a Brush Style

To create a brush style:

‣ Click the Add Brush Style

button.

The new brush style appears at the end of the Brush Styles drop-down menu list.

Renaming a Brush Style

To rename a brush style:
1. Click the arrow button of the Brush Style drop-down menu.
2. Select the brush style you want to rename.
3. Click the Rename Brush Style

button.

The Rename Pen dialog box opens.

4. Type in a name for the selected brush style and click OK.

Deleting a Brush Style
To delete a brush style:
1. In the Tools toolbar, select the Brush tool.
2. In the Tool Properties view, in the Brush Style drop-down menu, select the brush style you want to delete
from the Brush Style list.
3. Click the Delete Brush Style

button.

Locking a Brush Style
To avoid modifying your brush style inadvertently, you can lock them by clicking the Lock Brush Settings
button.
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Related Topics
•

Brush Tool Options on page 197

Dynamic Brush
A Dynamic Brush

can be created to allow you to draw using patterns created from your artwork. Create a

new Dynamic Brush to copy a pattern you have drawn to reproduce it quickly. You can create dynamic brushed
using either a single pattern or a multiple one that will automatically switch through the patterns as you draw.
To create a new dynamic brush:
1. In the Tools toolbar, select a drawing tool.
2. In the Drawing or Camera view, draw the pattern you want to use as your Dynamic Brush stamp.

3. In the Tools toolbar, click the Select

4. In the Tools toolbar, select the Brush

tool and select the parts of the drawing you want to repeat.

tool.

5. In the Tool Properties view, click the Add Dynamic Brush

button to add your selection as a new

dynamic brush preset.
6. Click the Rename Brush Style

button.

The Rename Pencil dialog box opens.
7. Type in a name for the new dynamic brush and click OK.
8. In the Camera or Drawing view, start drawing with your dynamic brush to quickly repeat a pattern.
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9. To adjust the scale of your pattern to make it bigger or smaller as you stamp it, you can change the Scale
value in the Tool Properties view.

To create a dynamic brush with multiple drawings:
1. In the Timeline view, click the Add Drawing Layers

button to create as many layers as patterns you

want in your dynamic brush. It is recommended to rename your layers.

2. In the Camera view, draw your individual pattern on a separated layer.

3. In the Tools toolbar, select the Select

tool.

4. In the Camera view, select all the drawings you want to add to your new dynamic brush.
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5. In the Tools toolbar, select the Brush

tool.

6. Click the Add Dynamic Brush

button to add your selection as a new Dynamic Brush preset.

7. Click the Rename Brush Style

button.

The Rename Pencil dialog box opens.
8. Type in a name for the new dynamic brush and click OK.
9. In the Camera or Drawing view, start drawing with your dynamic brush to quickly repeat a pattern. When
you use this brush, you will cycle through the drawings.

Related Topics
•

Brush Tool Options on page 197
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Drawing with Line Texture

In Toon Boom Harmony, you can use the Brush

tool to draw with bitmap textured lines.

In the Brush Tool Properties view, you will find a series of default textured brushes but you can also create your
own collection by importing either PSD or TGA files in the Pen list.

The textured brush only work with the Brush tool. It does not work with the Pencil, Line, Ellipse,
Polyline or Rectangle tools.

Related Topics
•

How to Draw with Texture below

•

Adjusting the Line Texture Parameters on the next page

•

Creating Texture Brushes on page 210

•

Erasing Textured Lines on page 211

•

Hiding the Line Texture on page 213

•

Adjusting the Line Texture Opacity on page 214

How to Draw with Texture
To draw with textured lines, use the Brush tool and the correct pen in the list. You can also draw with pencil line
texture—see Pencil Line Texture on page 189
To draw with textured lines:
1. In the Tool toolbar, select the Brush

tool or press [Alt] + [B].
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2. In the Tool Properties view, select a textured brush from the Pen drop-down list.

3. In the Camera or Drawing view, start drawing.

Related Topics
•

Drawing with the Brush Tool on page 196

•

Pencil Line Texture on page 189

Adjusting the Line Texture Parameters
In the Brush Tool Properties view, there are a number of parameters you can use to adjust the look and feel of
your textured brush.
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1. Enable Texture: When selected, allows your brush to draw with texture. When deselected, the brush will
trace fully vector based lines.
2. Minimum Opacity: This value corresponds to the opacity of the brush when the pressure is very light. The
closer to zero the value is, the more transparent the line will be.

.
3. Maximum Opacity: This value corresponds to the opacity of the brush when the pressure is heavy. The closer
to 1 the value is the more opaque the line will be.
4. Hardness: The hardness value corresponds to the smoothness of the line edge. The lower the value, the more
blurry and smooth the line edge will be. The higher the value, the sharper the line edge will be.

5. Texture File: The Texture File button displays the texture currently in use or allows you to browse for a
texture file to import. Browsing for a texture file in a brush already using texture will replace the file currently in
use, although it will not replace the texture in the lines already drawn.

6. Texture Scale: This value changes the size of the texture file in the line. If you are using a plaid texture, the
squares will be larger if you increase the value and smaller if you decrease it.
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Related Topics
•

Drawing with Line Texture on page 207

Creating Texture Brushes
To create your own texture brush, you must prepare your texture file in a third-party software, such as Adobe
Photoshop. If your image has transparency in it, it will be supported. The texture file must be either a PSD or
TGA file.

It is recommended that you maintain your texture resolution between 100 x 100 pixels and 400 x
400 pixels.

To create your own texture brush:
1. In the Tools toolbar, select the Brush

tool or press [Alt] + [B].

2. In the Tool Properties view, click the New Brush

button to add a new brush to your list.

In the Texture section, select the Enable Texture option.

3. Click the Texture File button and browse for your bitmap texture file.
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The image colour will not be used, only the pattern in it.

4. In the Camera view, draw some lines and adjust the parameters to fit the style you are looking for. Note:
your pen list will be automatically saved.

Related Topics
•

Drawing with Line Texture on page 207

Erasing Textured Lines
When you use the Eraser tool to erase a portion of a textured line, the vector frame is cut straight and you lose
the feather created while drawing with the Brush tool. In Toon Boom Harmony, a special option in the Eraser
tool lets you create a soft edge on your textured lines. You can also cut or keep the vector frame as is.
To erase textured lines:
1. In the Tools toolbar, select the Eraser

tool, press [Alt] + [E].

2. In the Tool Properties view, select the Use Blur Parameters option.

3. While erasing, select the Keep Vectors option to keep your vector frames and not cut them.

4. Adjust Minimum Opacity and Maximum Opacity parameters of the eraser to change the transparency of
the erasing trail as you press harder on the pen tablet.

5. Adjust the Hardness and Eraser Saturation parameters of the eraser to control the amount of
smoothness and the size of the feather edge.

6. In the Camera or Drawing view, erase your textures lines.
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7. In the Tool Properties view, click the arrow button.
The Brush Properties panel opens.
8. Adjust the following:
‣

Maximum/Minimum Size: Defines the minimum and maximum width of the stroke.

‣

Smoothing: Defines the number of control points added to the centre line.

‣

Contour Smoothing: Defines the number of control points added to the contour boundaries (around
the line). Lower values mean that the line will appear as you draw it (with more control points added
along the centre line). Higher values mean that the line will be smoothed out (removing control points
from the centre line).

‣

Tip Shape: Lets you select a shape for the tip of the eraser. There are a variety of tips to choose from:
round, square, oval, star-shaped and more.

Related Topics
•

Drawing with Line Texture on page 207
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Hiding the Line Texture

Sometimes you need to hide the line texture to see the complete vector frame around your lines. This is useful to
help you see any dirt floating around your drawing.

To hide the line texture, you must deselect the Real-Time Antialiasing option. In the top menu,
select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X) and in the OpenGL
tab, deselect the Enable option in the Real-Time Antialiasing section. The default shortcut is [Ctrl] +
[Alt] + [A] (Windows/Linux) or [⌘] + [Alt] + [A] (Mac OS X).

To hide the line texture in the Camera view, you must enable the Show Drawing on Top option. In
the top menu, select View > Show > Current Drawing on Top. Refer to the Show Current Drawing
on Top on page 162 section to learn more about this option.

To hide the line texture:
1. Make sure the real-time antialiasing is deselected. If you are in the Camera view, select the Show Current
Drawing on Top option.
2. In the Camera or Drawing View

menu, select View > Show > Hide Line Texture or press [Ctrl] +

[Shift] + [H] (Windows/Linux) or [⌘ ] + [Shift] + [H] (Mac OS X).

Related Topics
•

Drawing with Line Texture on page 207
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Adjusting the Line Texture Opacity

At some point, you may want to modify the look of a textured drawing. Maybe you find that your line is too
smooth or too faint. You can adjust those parameters by using the Adjust Line Texture Opacity command.

To adjust the line texture, you must deselect the Real-Time Antialiasing option. In the top menu,
select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X) and in the OpenGL
tab, deselect the Enable option in the Real-Time Antialiasing section. The default shortcut is [Ctrl] +
[Alt] + [A] (Windows/Linux) or [⌘] + [Alt] + [A] (Mac OS X).

To be able to adjust the line texture in the Camera view, you must select the Show Drawing on Top
option. In the top menu, select View > Show > Current Drawing on Top.
Refer to the Show Current Drawing on Top on page 162 section to learn more about this option.

To adjust the line texture opacity:
1. Make sure that real-time antialiasing is deselected. If you are in Camera view, select the Show Current
Drawing on Top option.
2. In the Timeline or Xsheet view, select the drawing whose opacity you want to adjust.
3. In the Camera or Drawing view menu, select Drawing > Adjust Line Texture Opacity.
The Adjust Line Texture Opacity dialog box opens.
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4. Drag the sliders toward the middle to increase the contrast and opacity of the textured lines.
5. If you want to apply the changes to all drawings exposed on the layer, select the Apply to All Drawings
option and click OK.

Related Topics
•

Drawing with Line Texture on page 207
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Selecting Drawing Objects

The Select

tool is used to select drawing strokes in both the Drawing and Camera views, and apply basic

transformations, such as repositioning, rotating, scaling or skewing, using the different handles of the bounding
box.
To select with the Select tool:
1. In the Timeline view, select the cell on which you want to select drawing objects.
In Harmony Paint, select a drawing in the Drawing panel.
2. In the Tools toolbar, select the Select

tool or press [Alt] + [S].

3. In the Camera or Drawing view, select the drawing objects.
‣

You can select all the drawing objects in a drawing by using the Select All command or press [Ctrl] +
[A] (Windows/Linux) or [⌘ ] + [A] (Mac OS X).

4. To deform or reposition a selection:
‣

To reposition, click on the selected drawing object and drag the selection to a new area.

‣

To rotate, grab the selection box handle and rotate it.
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‣

To scale, pull or push either on the top, side, bottom or corner control point. Hold down [Shift] to lock
the selection’s ratio.

‣

To skew, drag sideways or up and down the sides or top and bottom segments, between the control
points.

Inverting a Selection
Not available in Harmony Paint.
Sometimes, when you want to select multiple objects, while leaving one unselected, it can be handy to select only
the stroke, or line, that you do not want included in your selection. Then, you can invert that selection so that
everything else becomes selected. This can be quite a time saver.
To invert a selection:
1. From the top menu, select Edit > Invert Selection or press [Ctrl] + [Shift] + [I] (Windows/Linux) or [⌘ ] +
[Shift] + [I] (Mac OS X).
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You can also find the Invert Selection option in the Camera View or Drawing View menu by
selecting Edit > Invert Selection.

Related Topics
•

Repositioning a Pivot Point below

•

Selection on Single or Multiple Layers on the facing page

•

Select Tool Properties on the facing page

Repositioning a Pivot Point
Some of the transformations such as rotation, scale, skew and flip, are done relative to the position of the pivot
point. You can temporarily reposition this pivot point for a transformation using the Select
tool.
To temporarily reposition the pivot point:
1. In the Camera or Drawing view, select the drawing object you want to transform.
The pivot point appears in the middle of your selection.

2. Click the pivot point and drag it to a new position.
This becomes the new position of the pivot point for the current transformation and will remain there until
you make a new selection.
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Related Topics
•

Selecting Drawing Objects on page 216

•

Select Tool Properties below

Selection on Single or Multiple Layers

By default, when you draw a selection box in the Camera view, the Select tool will select all the drawing strokes
and symbols in its path. If you would prefer the Select tool to only select the current drawing and not the other
visible drawings, you can enable the Select Tool Works on Single Drawing preference.
To enable the Select Tool Works on Single Drawing preference:
1. In the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X).
The Preferences dialog box opens.
2. In the Camera tab, go to the Tools section and select the Select Tool Works on Single Drawing
preference and click OK.
3. In the Tools toolbar, select the Select

tool or select [Alt] + [S].

4. In the Camera view, select your drawing.

Related Topics
•

Selecting Drawing Objects on page 216

•

Select Tool Properties below

Select Tool Properties
When you choose the Select

tool, its properties and options appear in the Tool Properties view.
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Related Topics
•

Manipulators on the facing page

•

Snap Options on the facing page

•

Permanent Selection on page 222

•

Apply to All Drawings in Layer on page 222

•

Apply to All Visible Drawings on page 223

•

Apply to Line and Colour Art on page 223

•

Select by Colour on page 223

•

Flip Horizontal and Vertical on page 224

•

Rotate 90 Degrees CW and CCW on page 224

•

Pencil to Brush on page 225

•

Smooth on page 225

•

Flatten on page 225

•

Store Colour Gradient on page 225

•

Merge Pencil Lines on page 226

•

Reverse Pencil Thickness on page 226

•

Create Colour Art from Line Art on page 227

•

Distribute to Layers on page 227

•

Width and Height on page 228

•

Offset X and Y on page 228

•

Angle on page 228

•

Adjusting the Pencil Line Thickness on page 229
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•

Adjusting the Pencil Line Style on page 229

•

Pencil Stencils on page 229

•

Adding Texture to a Pencil Line on page 230

•

Adjusting the Text Selection on page 230

Manipulators
Choose between the Select tool and the Transform tool. This is a fast way to switch between the Select tool
and Transform tool selection mode.

Snap Options
You can enable different snapping modes to help you when repositioning your drawings using the Select tool.
•

Snap to Contour: Snaps your selection or point to any line you position it on. As soon as you move it
close enough to another line, your point or selection will snap to it.

•

Snap and Align: Snaps the selected anchor point to any existing line while displaying temporary
rulers as a guide that you can also snap your anchor point to.

•

Snap to Grid: Snaps your selection following the currently enabled grid.

To snap to grid:
•

Select View > Grid > Show Grid to display the grid in the Camera or Drawing view or press [Ctrl] + [']
(Windows/Linux) or [⌘ ] + ['] (Mac OS X).

•

Select View > Grid > Square Grid, 12 Field Grid or 16 Field Grid for your current needs.

1. In the Tools toolbar, select the Contour Editor

tool or press [Alt] + [Q].

2. In the Contour Editor Tool Properties view, click the Snap to Grid

button.

3. In the Camera or Drawing view, click on an anchor point you want to snap following the grid, and drag it
to the desired position and release.
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Refer to the Grid on page 284 topic to learn more about the Grid feature.

Permanent Selection

The Permanent Selection

option is used to maintain a selection over multiple drawings. Once this option is

enabled, the selection zone made using the Select tool will remain as you navigate through drawings from a
layer and drawings from other drawing layers. This option can be used to simultaneously delete artwork inside
or outside of the selection on several drawings when combined with the Apply to Multiple Drawings option.

Apply to All Drawings in Layer

The Apply to All Drawings in Layer

option is used to perform an action on all the drawings contained in a

layer. For example, you could enable the option to paint a section on all the drawings simultaneously. The Apply
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Tool to All Drawings option must be activated before performing the action and will stay enabled only for the
next action.

Apply to All Visible Drawings

The Apply to All Visible Drawings

option is used to perform an action on all the visible drawings in the

Camera view. This option is not available in the Drawing view.

Apply to Line and Colour Art
The Apply to Line and Colour Art

option uses the concept of Line Art and Colour Art layers. Use this option

to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art layers, as well as the
Overlay and Underlay layers.

Select by Colour

The Select by Colour mode lets you select all the zones in your drawing painted with the same colour.

Only the zones painted with the SAME colour swatch will be selected. If another zone is coloured
with the exact same RGB value (same colour), but not painted with the same colour swatch, it will not
be selected.
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To select areas by colour:
1. In the Tools toolbar, select the Select

tool or press [Alt] + [S].

2. In the Tool Properties view, click the Select by Colour

button.

3. In the view, click on any zone in your drawing.
All zones of the same colour are selected.
4. Click the Select tool again to return to the regular Select mode.

Flip Horizontal and Vertical

The Flip Horizontal

and Flip Vertical

operations flip the current selection horizontally or vertically.

From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW

and Rotate 90 Degrees CCW

operations rotate the current selection 90

degrees clockwise or counter-clockwise.
From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 Degrees CCW.
Or press [Ctrl] + [7] and [Ctrl] + [9] (Windows/Linux) or [⌘ ] + [7] and [⌘ ] + [9] (Mac OS X).
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Pencil to Brush

The Pencil to Brush

operation converts the selected centreline pencil strokes into contour strokes brush

lines.
From the top menu, select Drawing > Convert > Pencil Lines to Brush or press [&].

Smooth

The Smooth

operation lets you smooth out selected drawing strokes and remove extra points. You can also

access this feature through the top menu, by selecting Drawing > Optimize > Smooth or press [Alt] + [Shift] +
[S].

Flatten

The Flatten

operation is used to merge drawing objects and brush strokes into a single layer. If you draw

new lines to fix a drawing or a line with many brush strokes, it can be useful to flatten them all into a single shape.
By default, lines are drawn one on top of each other, if you intend repainting the lines or modifying their shape, it
will be easier if they are flattened.
You can also access this feature through the top menu, by selecting Drawing > Optimize > Flatten. The [Alt] +
[Shift] + [F].

Store Colour Gradient
Use the Store Colour Gradient

operation to record the selected gradient’s position. This reuses the stored

position of the gradient when drawing new brush lines or painting colour zones. Enable the Use Stored Colour
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Gradient

option in the Paint or Brush Tool Properties view to do this.

Refer to Drawing with the Brush Tool on page 196 or Painting Using the Paint Tool on page 357 to
learn how to use the Use Stored Colour Gradient option.

Merge Pencil Lines

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to align them and
make it look like it is one single line. With the Select tool, you can select several pencil lines and merge them as
one single object using the Merge Pencil Lines
option. It will take your lines and adjust the ends to form one
single line.

Points have to be close enough to be merge. If there is a big gap between the lines, they will not be
merged.

Reverse Pencil Thickness

The Reverse Pencil Thickness

option will invert the thick and thin section on a selected pencil line. This

option will take the thickest size on the line and apply it to the thinnest, and it will apply the thinnest to the
thickest.
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Create Colour Art from Line Art
You can configure the Create Colour Art from Line Art option to suit your requirements.
To configure the Create Colour Art from Line Art option:
1. In the Select tool Tool Properties view, [Shift] + click the Create Colour Art from Line Art

button.

The Configure Line Art to Colour Art dialog box opens.

‣

Use rendered version of the drawing: This option will render the drawing and vectorize it to
calculate the position of the centreline that will produce the colour art stroke.

‣

Maximum Resolution for rendered image: The size of the rendered image.

‣

Threshold for rendered image: The value of grey processed to create the rendered vectorized arts.

‣

Fitting error for rendered beziers: This value represents how precise the fitting of the colour art zone
in relation to the line art will be.

‣

Source layer: Select the layer (Line Art, Colour Art, Underlay or Overlay) you want the colour art to
be created from.

‣

Destination layer: Select the layer (Line Art, Colour Art, Underlay or Overlay) you want the colour
art to be created on.

‣

Clear Destination Art Layer First: Enable this option if you already have artwork on the destination
layer and you want the content to be deleted before the colour art is added into it.

‣

Perform Line Art to Colour Art Operation Immediately: Enable this option to perform the Create
Colour Art from Line Art command when you click OK.

Refer to Line Art and Colour Art Layers on page 388 to learn more about the Line Art and Colour
Art concept.

Distribute to Layers
The Distribute to Layers

option is used to separate the selected art strokes and send them to new drawing

layers. In the Camera view, once you have drawn your artwork, you can select the strokes you want to distribute
using the Select
tool and click on the Distribute to Layer
button, you can also select Drawing >
Distribute to Layer. It will automatically take every stroke from the drawing selection made in the Camera view
and separate them into a different layer for each. If an artwork is composed of several strokes, you must group
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them using Edit > Group > Group before using the Distribute to Layer option. This option cannot be done from
the Drawing view.

Refer to Break Down: Distribute to Layers on page 741 to learn more about the Distribute to Layer
option.

Width and Height
Use the Width and Height operation fields to enter specific values to resize the selected shape with precision.

1. Width: Type a width value in this field to resize the width of your selection.
2. Height: Type a height value in this field to resize the height of your selection.
3. Up/Down arrows: Use the up and down arrows to modify the value contained in either the Width or
Height value field.
4. Lock icon: Click on the lock icon to lock or unlock the ratio between the width and height values.

Offset X and Y
Use the Offset X and Offset Y operation fields to enter specific values and precisely reposition the selected
shape.

1. X: Type an offset value in this field to reposition your selection along the X-axis.
2. Y: Type an offset value in this field to reposition your selection along the Y-axis.
3. Up/Down arrows: Use the up and down arrows to modify the value contained in either the X or Y value
field.

Angle
Use the Angle operation fields to enter specific values and accurately rotate the selected shape.

1. Angle: Type a degree value in this field to rotate your selection.
2. Up/Down arrows: Use the up and down arrows to modify the value contained in the Angle value field.
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Adjusting the Pencil Line Thickness
Use the Adjusting the Pencil Line Thickness operation field to resize the selected centreline strokes. This
operation is not permitted on contour line shapes, such as brush strokes or shape fills.

1. Minimum Size: Type a value in this field to set the minimum thickness of the selected centreline stroke.
2. Maximum Size: Type a value in this field to set the maximum thickness of the selected centreline stroke.
3. Up/Down arrows: Use the up and down arrows to modify the value contained in the Thickness value field.
4. Lock Proportions: Enable the Lock option for the minimum and maximum size to increase and decrease in
proportion.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.
•

Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between
Round or Flat style.

•

End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between
Round or Flat style.

•

Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define the
Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Pencil Stencils
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Toon Boom Harmony gives you the flexibility to change the style and thickness of your pencil lines even after they
are drawn. You can apply preset pencil stencils or create your own.

Refer to Working with Templates on page 185, Creating a Pencil Templatewith the Select Tool on
page 187 and Working with Templates on page 185.

Adding Texture to a Pencil Line
Pencil lines support texture. Once a pencil line is drawn, you can apply a preset texture or load your own.
Textures are independent from pencil stencils.

Refer to Pencil Line Texture on page 189, Applying a Preset Texture to a Pencil Line on page 194
and Creating a Pencil Texture Template with the Select Tool on page 191.

Adjusting the Text Selection
When you select text with the Select tool, the tool properites will display the Text tool options on the bottom of
the view. You can also press [Alt] + [9] to display only the Text properties in the Tool Propertie view.

Refer to Formatting the Text on page 274 to learn more about the Text tool Tool Properties.

Related Topics
•

Drawing Using the Pencil Tool on page 178

•

Pencil Tool Options on page 179

•

Working with Templates on page 185

•

Pencil Line Texture on page 189
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Erasing Parts of a Drawing

The Eraser tool is pressure sensitive, like the Brush tool, giving you more precision when erasing parts of a
drawing.
To erase with the Eraser tool:
1. In the Timeline or Xsheet view, select the cell where you want to erase.
In Harmony Paint, select a drawing in the Drawing panel.

2. In the Tools toolbar, select the Eraser

tool or press [Alt] + [E].

3. In the Camera or Drawing view, start erasing.

You can also use the Select tool to select drawing objects and delete them instead of erasing.

Related Topics
•

Eraser Tool Options below

•

Selecting Drawing Objects on page 216

Eraser Tool Options
When you select the Eraser

tool, its properties and options appear in the Tool Properties view.
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Related Topics
•

Tip Style below

•

Minimum and Maximum Size on the facing page

•

Central Line Smoothness on the facing page

•

Contour Optimization on the facing page

•

Eraser Tips on page 234

•

Preview on page 234

•

Eraser Styles on page 234

•

Eraser Blur Parameters on page 234

Tip Style

The Tip Style option affects the erased tip of pencil lines made with the Pencil, Ellipse, Rectangle, Line, and Polyline tools.
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Minimum and Maximum Size
This is where you set the minimum and maximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.

1. Minimum Size field: Type a value in this field to set the minimum width of the line.
2. Maximum Size field: Type a value in this field to set the maximum width of the line.
3. Up/Down arrows: Use the up and down arrows to set the minimum size value.
4. Up/Down arrows: Use the up and down arrows to set the maximum size value.

Central Line Smoothness
You can modify the Central Line Smoothness

of your line using this option. This parameter smoothes the

initial movement of your line. Increasing the value will result in a smoother line with fewer control points.

Contour Optimization
You can optimize the Contour Line Smoothness of you line using this option. This parameter will smooth the
contour of your line once the line has been traced, the higher the value the less control points will compose your
line.

1. Smoothness field: Type a value to set the smoothness of the line.
2. Contour Optimization field: Type a value to set the contour optimization of the line.
3. Up/Down arrows: Use the up and down arrows to set smoothness value.
4. Up/Down arrows: Use the up and down arrows to set the contour optimization value.
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Eraser Tips

In this drop-down menu, you can find a variety of tip shapes from round and square ones to star shaped, select
the one you need.

Preview
The Preview field lets you see a preview of the style that will be produced after you customize the different
parameters in the Tool Properties view.

1. The Arrow button lets you show or hide the Preview area.
2. The Preview field is where the brush line is displayed.
‣

Maximum/Minimum Size: Defines the minimum and maximum width of the stroke.

‣

Smoothing: Defines the number of control points added to the centre line.

‣

Contour Smoothing: Defines the number of control points added to the contour boundaries (around
the line). Lower values mean that the line will appear as you draw it (with more control points added
along the centre line). Higher values mean that the line will be smoothed out (removing control points
from the centre line).

‣

Tip Shape: Lets you select a shape for the tip of the eraser. There are a variety of tips to choose from:
round, square, oval, star-shaped and more.

Eraser Styles
The Eraser tool uses the same Brush Styles as the Brush tool. Toon Boom Harmony provides a variety of eraser
styles and allows you to create and save your own. It is a good idea to create and save eraser brushes with
precise sizes and parameters to draw and design—see Brush Styles on page 202

Eraser Blur Parameters
Since Toon Boom Harmony lets you draw with textured lines and create feathered edges on them, you may also
want to erase with smooth edges instead of the solid vector based eraser. The Eraser Blur Parameters allow you
to adjust the smoothness of your eraser for the textured lines—see Erasing Textured Lines on page 211
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Reshaping a Drawing Using the Contour
Editor Tool

When drawing on vector layers, the Contour Editor Tool is powerful. It allows you to add, remove or modify
points on a vector line and to control them with Bezier handles. It is used to correct line shapes and to modify a
single part of a colour zone. If a line is too thin or has a gap in it, you can modify and correct it with the Contour
Editor tool. This tool can also be used to create elaborate shapes.
The Contour Editor tool is powerful, it allows you to add, remove or modify points on a vector line and to
control them with Bezier handles. It is used to correct line shapes and to modify a single part of a colour zone. If a
line is too thin or has a gap in it, you can modify and correct it with the Contour Editor tool. This tool can also be
used to create elaborate shapes.
The Contour Editor displays vector points around a shape and the central vector points in a pencil line. Pulling or
pushing on these points adjusts the brush’s line thickness. Points can be selected and deleted. Each point has
two Bezier handles used to correct the curves between two points. Shapes can be modified by pulling and
pushing directly on the segment between the points. You can use it to perfect a central shape pencil line, a
contour shape brush line or even create an elaborate shape from a basic ellipse, or square.
To reshape with the Contour Editor tool:
1. In the Timeline or Xsheet view, select the cell in which you want to draw.In the Timeline or Thumbnails
view, select the cell and layer into which you want to draw.
In Harmony Paint, select a drawing in the Drawing panel.
2. In the Tools toolbar, select a shape

tool.

3. In the Tool Properties view, click the Ellipse

button, click the Auto Fill

size to 0.
4. In the Drawing or Camera view, draw a circle.
5. In the Stage view, draw a circle.
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6. In the Tools toolbar, select the Contour Editor

tool.

7. In the Drawing or Camera view, click the line to reshape it.
8. In the Stage view, click the line to reshape it.

9. Select one or several points by clicking on them or circling around.

10. Press [Delete] to delete a selected point.
Press [Ctrl] (Windows/Linux) or [⌘ ] (Mac OS X)and click on the contour to add a new point to adjust the
contour.
11. To modify the shape, you can:
‣

Pull on the Bezier handle. Both point’s handles will move as one.

‣

Hold down the [Alt] key and pull on one of the Bézier handles. The point’s handle will move
independently from the other one.

‣

Move the selected points to a new area.
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‣

Pull directly on the line between two points. No selection is necessary. Holding down the [Shift] key will
limit the contour modification to the curve between the two first points.

‣

If an anchor point has no visible Bezier, hold down the [Alt] key to get them.

To add control points, press [Ctrl] (Windows/Linux) or [⌘] (Mac OS X) and click the line.
To remove control points, select the control point and press [Delete].

Related Topics
•

Contour Editor Tool Properties below

Contour Editor Tool Properties
When you select the Contour Editor

tool, its properties and options appear in the Tool Properties view.

These are the options available for the Contour Editor tool:
•

Lasso and Marquee on the next page

•

Show Contour Editor Controls on the next page

•

Apply to Line and Colour Art on the next page

•

Snap to Contour on the next page

•

Snap and Align on page 239

•

Smooth Selection on page 239
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Lasso and Marquee
Choose between the Lasso
•

and Marquee

options to change the selection style of the tool.

Click and hold [Alt] to temporarily switch from the current mode to the other.

Show Contour Editor Controls

Use the Show Contour Editor Controls

option to show the contour editor controls. You can use these

controls to scale, reposition and rotate the selected anchor points.

Apply to Line and Colour Art
The Apply to Line and Colour Art

option uses the concept of Line Art and Colour Art layers. Use this option

to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art layers, as well as the
Overlay and Underlay layers.

Snap to Contour

The Snap to Contour

option will snap the selected anchor point to any line you position it on.

To snap two shapes together:
1. In the Tools toolbar, select the Contour Editor

tool or press [Alt] + [Q].
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2. In the Tool Properties view, click the Snap to Contour

button.

3. In the Camera or Drawing view, click on an anchor point you want to snap to the other shape, drag it on
top of the contour line area and release it.

Snap and Align

The Snap and Align

option lets you snap the selected anchor point to any existing line while displaying

temporary rulers as a guide that you can also snap your anchor point to.
To snap and align:
1. In the Tools toolbar, select the Contour Editor

tool or press [Alt] + [Q].

2. In the Tool Properties view, click the Snap and Align

button.

3. In the Camera or Drawing view, click on an anchor point you want to snap, drag it until a ruler is displayed,
position it on the ruler or on the contour line and release.

Smooth Selection
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The Smooth

operation lets you smooth out selected drawing strokes and remove extra points. You can also

access this feature through the top menu, by selecting Drawing > Optimize > Smooth or press [Alt] + [Shift] +
[S].

Related Topics
•

Reshaping a Drawing Using the Contour Editor Tool on page 235
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Reshaping Pencil Lines with the Pencil Editor
Tool

The Pencil Editor

tool is used to modify the thick and thin contour of a pencil line. A pencil line is a central vec-

tor shape. The shape control points are located all along the central spine allowing to adjust the stroke curve
and position. When using the Contour Editor tool, you will be able to reposition the spine of the stroke. When
using the Pencil Editor tool, you will be able to adjust the thick and thin areas of the line.

To use the Pencil Editor tool:
1. In the Tools toolbar, select the Pencil Editor

tool located in the Contour Editor drop-down menu or

press [Alt] + [W].
2. In the Camera or Drawing view, select a pencil line and click the line to reshape it.

3. Select one or several points by clicking them or circling around.
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4. Press [Delete] to delete a selected point.
5. Press [Ctrl] (Windows/Linux) or [⌘ ] (Mac OS X) and click the central spine to add a set of points to adjust
the contour.
6. To modify the shape, you can:
‣

Move the selected points to a new area. If you select matching points on each side of the line, holding
the Shift key will move them both. This way you can thicken or thin a line from both side at the same
time.

‣

Pull on the Bezier handle. Both points’ handles will move as one.

‣

Hold [Alt] down and pull on one of the Bezier handles. The point’s handle will move independently
from the other one.

242

Toon Boom Harmony 10.3 Stage User Guide

‣

Pull directly on the line in-between two points. No selection is necessary. Holding down the [Shift] key
will limit the contour modification to the curve between the two first points.

‣

If an anchor point has no visible Bezier, hold down the [Alt] key to get them.

Related Topics
•

Pencil Editor Properties below

Pencil Editor Properties
When you select the Pencil Editor tool, its properties and options appear in the Tool Properties view.
These are the options available for the Pencil Editor tool:
•

Lasso and Marquee below

•

Smooth on the next page

•

Pump Pencil Pressure on the next page

•

Deflate Pencil Pressure on the next page

•

Merge Pencil Lines on page 245

•

Reverse Pencil Thickness on page 245

•

Adjusting the Pencil Line Thickness on page 245

•

Pencil Editor Properties above

•

Working with Templates on page 185

•

Adding Texture to a Pencil Line on page 246

Lasso and Marquee
Choose between the Lasso
•

and Marquee

options to change the selection style of the tool.

Click and hold [Alt] to temporarily switch from the current mode to the other.
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Smooth

The Smooth

operation lets you smooth out selected drawing strokes and remove extra points. You can also

access this feature through the top menu, by selecting Drawing > Optimize > Smooth or press [Alt] + [Shift] +
[S].

Pump Pencil Pressure

The Pump Pencil Pressure

option is used to increase the line thickness of a selected area on a pencil line.

Deflate Pencil Pressure

The Deflate Pencil Pressure

option is used to decrease the line thickness of a selected area on a pencil line.
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Merge Pencil Lines

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to align them and
make it look like it is one single line. With the Select tool, you can select several pencil lines and merge them as
one single object using the Merge Pencil Lines
option. It will take your lines and adjust the ends to form one
single line.

Reverse Pencil Thickness

The Reverse Pencil Thickness

option will invert the thick and thin section on a selected pencil line. This

option will take the thickest size on the line and apply it to the thinnest, and it will apply the thinnest to the
thickest.

Adjusting the Pencil Line Thickness
This is where you set the minimum and maximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.

1. Minimum Size field: Type a value in this field to set the minimum width of the line.
2. Maximum Size field: Type a value in this field to set the maximum width of the line.
3. Up/Down arrows: Use the up and down arrows to set the minimum size value.
4. Up/Down arrows: Use the up and down arrows to set the maximum size value.
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Pencil Templates

Toon Boom Harmony gives you the flexibility to change the style and thickness of your lines even after they are
drawn. You can apply preset templates or create your own.

Refer to Working with Templates on page 185, Creating a Pencil Templatewith the Select Tool on
page 187 and Working with Templates on page 185.

Adding Texture to a Pencil Line
Pencil lines support texture. Once a pencil line is drawn, you can apply a preset texture or load your own.
Textures are independent from Pencil templates.

Refer to Pencil Line Texture on page 189, Applying a Preset Texture to a Pencil Line on page 194
and Creating a Pencil Texture Template with the Select Tool on page 191.

Related Topics
•

Reshaping Pencil Lines with the Pencil Editor Tool on page 241
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Drawing with Shapes

In Toon Boom Harmony, you can use the shape tools to draw with circles, lines and squares. You can also easily
reshape a square or circle into a much more complex drawing such as these butterfly wings.
The Shape tools are used to draw rectangles, ellipses and lines. You can use them on both vector and bitmap
layers. You can also easily reshape a square or circle into a much more complex drawing such as these butterfly
wings.

Refer to Reshaping a Drawing Using the Contour Editor Tool on page 235 and Reshaping Pencil Lines
with the Pencil Editor Tool on page 241 topics to learn more about the Contour Editor and Pencil
Editor tools.

To draw with a Shape tool:
1. In the Timeline or Xsheet view, select the cell where you want to draw.
1. In the Timeline or Thumbnails view, select the panel and layer on which you want to draw.In Harmony
Paint, select a drawing in the Drawing panel.
2. In the Tools toolbar, select a shape

tool.

3. In the Tool Properties view, you can switch between the different shapes mode.In the Shape Tool
Properties view, you can switch between the different shapes mode. Select either the Ellipse
or
Rectangle

tool.

4. In the CameraStage view, click and drag your mouse to draw the shape.
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‣

Hold down [Shift] to lock the rectangle or the ellipse ratio to 1:1.

‣

Hold down [Alt] to draw the rectangle or ellipse from its centre.

‣

Hold down [Shift] to snap the line every 15 degrees.

‣

Hold down [Alt] to snap the starting or end point of the line to a close by stroke.

5. Use the Contour Editor

tool to deform your shape and create your drawing.

Related Topics
•

Shape Tool Options below

Shape Tool Options
When you select a shape tool, its properties and options appear in the Tool Properties view.
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These are the options available for the shape tools:
•

Line, Rectangle and Ellipse below

•

Draw Behind on the next page

•

Snap Options on the next page

•

Line Building Mode on the next page

•

Automatic Filling on page 251

•

Create Colour Art Automatically on page 251

•

Auto-Flatten Mode on page 251

•

Auto-Close Gap on page 252

•

Use Stored Colour Gradient on page 252

•

Keep Proportion on page 252

•

Pencil Templates on page 253

•

Thickness Adjustment on page 253

•

Adjusting the Pencil Line Style on page 253

•

Applying Texture to a Pencil Line on page 253

Line, Rectangle and Ellipse
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Click on the

button corresponding to the shape you want. Click and drag your mouse to draw the

selected shape. The shape tools create centre lines.
Using the Ellipse or Rectangle option, press [Shift] to create a perfect round or a perfect square and press [Alt]
to create the shape from its centre.
Using the Line tool, press [Shift] to create a line which snaps-to every 15 degrees and then press [Alt] to connect
the start or end point of that line to another nearby line.

Draw Behind

When the Draw Behind

mode is enabled, the lines you draw will appear behind the art that already exists.

Snap Options
When drawing a shape, you can enable different snap modes to help you create your shape.
•

The Snap to Contour

•

The Snap and Align

option snaps your shape to any line you position it on.
option snaps the selected anchor point to any existing line, while displaying

temporary rulers as a guide that you can also snap your anchor point to.
•

The Snap to Grid

snaps your shape to the currently enabled grid.

Refer to the topic to learn more about the Grid feature.

Line Building Mode
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The Line Building

mode is very useful when drawing long lines and curves in small increments with pencil

lines. As the pencil lines are central vector lines and it may be difficult to align the line tips perfectly to create a
uniform stroke and close all gaps.
In this mode, you can draw lines in small increments and the tip are merge into one single stroke.

This mode only works with pencil lines.

Automatic Filling

Use the Automatic Filling

option to automatically fill your shape with the selected colour as you draw. By

default, the Shape tool creates the contour of an empty shape that you can later fill using the Paint tool.

Refer to Selecting the Current Colour of a Tool on page 355to learn more about selecting a fill
colour.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically

automatically creates the

corresponding strokes in the Colour Art layer.

Auto-Flatten Mode
When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing artwork as
you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes and pencil lines will flatten
with pencil lines.
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Using the Select tool, you can use the middle mouse button to select a segment of flattened pencil line. Use this
technique to create a nice finish to lines and corners in your artwork.

Auto-Close Gap

When enabled, the Auto-Close Gap

mode automatically connects, with an invisible stroke, the pencil lines

you draw close to each other in the Camera or Drawing view.

It is recommended to leave this option ENABLED when drawing with the Pencil tool.

Use Stored Colour Gradient
The Use Stored Colour Gradient

option makes your tool use the previously stored gradient position. This

way, every new brush line or colour fill will use the stored gradient position.

Keep Proportion
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When the Ellipse or Rectangle mode is enabled in the Tool Properties view, the Draw Circle or Draw Square
option appears. When selecting these options, the shape produced will either be a circle or a square. Holding
down the [Shift] key as you create your shape will maintain proportion.

Pencil Templates
Toon Boom Harmony provides a variety of pencil templates and also lets you create and save your own. It is a
good idea to create and save pencils with precise sizes and parameters when you draw and design.
You also have the possibility to apply different textures to your lines by either using the preset ones or importing
your own—see Working with Templates on page 185

Thickness Adjustment

Use the Size Adjustment field to set the thickness of the shape’s line.
1. Size: Type a value in this field to set the shape’s line thickness.
2. Up/Down arrows: Use the up and down arrows to modify the value contained in the Thickness value
field.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.
•

Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between
Round or Flat style.

•

End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between
Round or Flat style.

•

Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define the
Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Applying Texture to a Pencil Line
Pencil lines support texture. Once a pencil line is drawn, you can apply a preset texture or load your own.
Textures are independent from Pencil templates.
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Refer to Pencil Line Texture on page 189, Applying a Preset Texture to a Pencil Line on page 194
and Creating a Pencil Texture Template with the Select Tool on page 191.

Related Topics
•

Working with Templates
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Drawing with the Polyline Tool

The Polyline tool is used to draw shapes. It is a central vector type of line. To form a shape, you click to add a
point and then, without releasing the mouse, pull the handle in the desired direction before adding the next
point and repeat the operation. To edit the shape, you can use the Contour Editor tool.
To draw with the Polyline tool:
1. In the Timeline view, select the cell where you want to draw.
In Harmony Paint, select a drawing in the Drawing panel.
2. In the Tools toolbar, select the Polyline

tool or press [Alt] + [_].

3. In the Camera view, click and drag your mouse to create a point and a Bezier handle to shape your line.
‣

Press [Alt] to pull only one handle, instead of two.

‣

Press [Shift] to snap the handles to 45, 90, or 180 degrees.

4. Click again into a new area and drag the mouse to create a second point and Bezier handle.

5. Repeat the previous step until your shape is completed.
6. Press [Ctrl] (Windows/Linux) or [⌘ ] (Mac OS X) and click to release the Polyline tool from the current path
or shape that it is creating. Continue to use the tool to make multiple, independent paths or shapes.
7. If necessary, reshape the lines using the Contour Editor

tool.

Refer to Reshaping a Drawing Using the Contour Editor Tool on page 235 to learn more about the
Contour Editor tool.
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Related Topics
•

Polyline Tool Options below

Polyline Tool Options
When you select the Polyline tool, its properties and options appear in the Tool Properties view.

These are the options available for the Polyline tool:
•

Snap to Contour below

•

Create Colour Art Automatically below

•

Auto-Flatten Mode on the facing page

•

Pencil Templates on the facing page

•

Thickness Adjustment on the facing page
‣

Maximum/Minimum Size: Defines the minimum and maximum width of the stroke.

‣

Smoothing: Defines the number of control points added to the centre line.

‣

Contour Smoothing: Defines the number of control points added to the contour boundaries (around
the line). Lower values mean that the line will appear as you draw it (with more control points added
along the centre line). Higher values mean that the line will be smoothed out (removing control points
from the centre line).

Adjusting Polyline Style
Snap to Contour
The Snap to Contour

option will snap your selection to any line you position it on.

Create Colour Art Automatically
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As you draw in the Line Art layer, the Create Colour Art Automatically

automatically creates the

corresponding strokes in the Colour Art layer.

Auto-Flatten Mode
When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing artwork as
you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes and pencil lines will flatten
with pencil lines.

Pencil Templates

Toon Boom Harmony gives you the flexibility to change the style and thickness of your pencil lines even after they
are drawn. You can apply preset templates or create your own.

Refer to Working with Templates on page 185, Creating a Pencil Templatewith the Select Tool on
page 187 and Applying a Pencil Template on page 188.

Thickness Adjustment

Use the Size Adjustment field to set the thickness of the shape’s line.
1. Size: Type a value in this field to set the shape’s line thickness.
2. Up/Down arrows: Use the up and down arrows to modify the value contained in the Thickness value
field.

Related Topics
•

Drawing with the Polyline Tool on page 255
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Drawing Using Invisible Lines

There are two different ways to draw invisible lines:
•

Pencil Tool below

•

Stroke Tool on the facing page

Pencil Tool
Using the Pencil tool, you can draw as strokes only, meaning that the line will be invisible. This can be useful to
draw tones and highlights directly on the character.
To draw invisible lines with the Pencil tool:
1. In the Timeline or Xsheet view, select the cell where you want to draw.
In Harmony Paint, select a drawing in the Drawing panel.
2. In the Tools toolbar, select the Pencil

tool or press [Alt] + [/].

3. In the top menu, select View > Drawing > Show Strokes

or press [K].

In Harmony Paint, select View > Show Strokes.
4. In the Tool Properties view, set the Pen Style size to 0. You can also adjust the smoothness.
5. In the Camera or Drawing view, start drawing.
If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a
Message dialog box opens.

Select the Don’t Show This Message Again option if you do not want the dialog box to notify you about
the Show Strokes option. Click OK.
6. You can modify the stroke shape with the Contour Editor
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Stroke Tool
The Stroke

tool draws invisible lines only. You cannot add thickness to the line.

To draw invisible lines with the Stroke Pencil tool:
1. In the Timeline or Xsheet view, select the cell where you want to draw.
In Harmony Paint, select a drawing in the Drawing panel.
2. In the Tools toolbar, select the Stroke

tool or press [Alt] + [V].

3. In the top menu, select View > Show Drawing > Show Strokes

or press [K].

In Harmony Paint, select a drawing in the Drawing panel.
4. In the Tool Properties view, you can adjust the smoothness.
5. In the Camera or Drawing view, start drawing.
If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a
Message dialog box opens.

Select the Don’t Show This Message Again option if you do not want the dialog box to notify you about
the Show Strokes option. Click OK.
6. You can modify the stroke shape with the Contour Editor

Related Topics
•

Stroke Tool Options on the next page

•

Show Strokes as Washed-out Colours on the next page
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Show Strokes as Washed-out Colours

Sometimes, it may be difficult to see your strokes, especially if your colours are similar to the blue stroke colour.
In Harmony, you can display the strokes and washed-out the colours of your drawings so that the invisible lines
stand out.
To show the strokes with washed-out colours:

‣ In the top menu, select View > Show > Show Stroke With Colour Wash.
Related Topics
•

Drawing Using Invisible Lines on page 258

Stroke Tool Options
When you select the Stroke tool, its properties and options appears in the Tool Properties view.

Here are the options available for the Stroke tool:
•

Draw Stroke as Straight Lines on the facing page

•

Connect Line Ends on the facing page

•

Auto-Flatten Mode on the facing page

•

Central Line Smoothness on the facing page
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Draw Stroke as Straight Lines
Enable the Draw Stroke as Straight Lines

option if you want the new strokes that you will draw to be a

perfect straight line. Disable the option if you want the stroke to follow the mouse gesture.

Connect Line Ends
Enable the Connect Line Ends

option if you want the start or end point of your new stroke to connect to

your existing strokes to make sure no gaps are left in your drawing.

Auto-Flatten Mode
When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing artwork as
you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes and pencil lines will flatten
with pencil lines.

Central Line Smoothness
You can modify the Central Line Smoothness

of your line using this option. This parameter smoothes the

initial movement of your line. Increasing the value will result in a smoother line with fewer control points.

Related Topics
•

Drawing Using Invisible Lines on page 258

•

Show Strokes as Washed-out Colours on the previous page
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Deforming a Drawing Using the Perspective
Tool

The Perspective tool lets you deform a drawing selection and alter its perspective.
To deform a drawing with the Perspective tool:
1. In the Tools toolbar, select the Perspective

tool or press [Alt] + [0].

2. In the Camera or Drawing view, select a drawing to deform.
3. Click and drag the different anchor points to deform the shape.
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Related Topics
•

Perspective Tool Properties below

Perspective Tool Properties
Selecting the Perspective tool displays its properties and options in the Tool Properties view.

•

Lasso and Marquee below

•

Perspective Tool Properties above

•

Flip Horizontal and Vertical on the next page

•

Rotate 90 Degrees CW and CCW on the next page

Lasso and Marquee
Choose between the Lasso
•

and Marquee

options to change the selection style of the tool.

Click and hold [Alt] to temporarily switch from the current mode to the other.
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Snap to Contour
The Snap to Contour

option will snap the selected anchor point to any line you position it on—see Contour

Editor Tool Properties on page 237.

Snap and Align
The Snap and Align

option lets you snap the selected anchor point to any existing line while displaying

temporary rulers as a guide that you can also snap your anchor point to—see Contour Editor Tool Properties on
page 237.

Snap to Grid
The Snap to Grid

option snaps your selection according to the currently enabled grid.

Flip Horizontal and Vertical

The Flip Horizontal

and Flip Vertical

operations flip the current selection horizontally or vertically.

From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW

and Rotate 90 Degrees CCW

operations rotate the current selection 90

degrees clockwise or counter-clockwise.
From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 Degrees CCW.
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Or press [Ctrl] + [7] and [Ctrl] + [9] (Windows/Linux) or [⌘ ] + [7] and [⌘ ] + [9] (Mac OS X).

Related Topics
•

Deforming a Drawing Using the Perspective Tool on page 262
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Cutting Drawing Parts

The Cutter tool is used to cut a drawing area to move, copy, cut or delete it.
To cut with the Cutter tool:
1. In the Tools toolbar, select the Cutter

tool or press [Alt] + [T].

2. In the Camera view, trace a selection around the part to cut away.

‣

To delete the selected zone, press[Delete].

‣

To move the selection, click the selection and drag it to a new area.

‣

Use the bounding box controls to scale, skew, or rotate the cut piece.

Related Topics
•

Cutter Tool Options on the facing page
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Cutter Tool Options
When you select the Cutter

tool, its properties and options appear in the Tool Properties view.

Here are the options available for the Cutter tool:
•

Lasso and Marquee below

•

Apply to Line and Colour Art below

•

Use Mouse Gesture below

•

Use Mouse Gesture Breaker Mode on the next page

•

Tip Style on the next page

•

Flip Horizontal and Vertical on page 269

•

Rotate 90 Degrees CW and CCW on page 269

Lasso and Marquee
Choose between the Lasso
•

and Marquee

options to change the selection style of the tool.

Click and hold [Alt] to temporarily switch from the current mode to the other.

Apply to Line and Colour Art
The Apply to Line and Colour Art

option uses the concept of Line Art and Colour Art layers. Use this option

to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art layers, as well as the
Overlay and Underlay layers.

Use Mouse Gesture
When using the Lasso

selection type, the Use Mouse Gesture

option lets you automatically delete any

extra sections of line in your artwork by simply dragging your mouse over it.

For this operation to work, you lines CANNOT be flattened.
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Use Mouse Gesture Breaker Mode
When using the Lasso

selection type, the Use Mouse Gesture Breaker Mode

option lets you draw an

invisible stroke on a pencil line to cut it in two individual objects. Once a pencil line is cut with this option, you will
be able to select the two portions independently with either the Cutter tool, Pencil Editor tool or Select tool.

This option only works with pencil lines.

Tip Style

Use the Tip Style option to customize the tip of the pencil line you are cutting.
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Flip Horizontal and Vertical

The Flip Horizontal

and Flip Vertical

operations flip the current selection horizontally or vertically.

From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW

and Rotate 90 Degrees CCW

operations rotate the current selection 90

degrees clockwise or counter-clockwise.
From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 Degrees CCW.
Or press [Ctrl] + [7] and [Ctrl] + [9] (Windows/Linux) or [⌘ ] + [7] and [⌘ ] + [9] (Mac OS X).

Related Topics
•

Cutting Drawing Parts on page 266
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Smoothing Lines

When drawing in a digital application, it is not like drawing on a sheet of paper, sometimes the lines you draw
may look as if they were drawn with an unsteady hand. When this occurs, you may need to correct the look of
your lines.
Toon Boom Harmony has a very powerful tool you can use to optimize contours and reduce the number of
points on the lines, the Smooth Editor
tool.
To optimize lines with the Smooth tool:
1. In the Tools toolbar, select the Smooth Editor

tool or select Drawing > Tools > Smooth Editor.

In Harmony Paint, select Tools > Smooth Editor.
2. In the Camera or Drawing view, place your pointer over the lines to smooth. You may need to pass over
the same line several times to remove more points and make the line smoother.

Related Topics
•

Smooth Editor Tool Options on the facing page
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Smooth Editor Tool Options
When you select the Smooth Editor tool, its properties and options appear in the Tool Properties view.

Here are the options available for the Smooth Editor tool:
•

Brush, Marquee and Lasso Smoothing Style below

•

Show Control Points below

•

Minimum Size and Maximum Size below

•

Smoothness on the next page

•

Colour on the next page

Brush, Marquee and Lasso Smoothing Style
The Smoothing Style options allows you to smooth a portion of your drawing either by tracing a smoothing
stroke over the zone to optimize or by selecting an area of the drawing with the Marquee or the Lasso.

Show Control Points
The Show Control Points

option allows you to show or hide the Bezier points around your lines. When the

Bezier points are displayed, you can see the result of your smoothing and the number of points left on your
curve. When it is turned off, you will only see the original artwork.

Minimum Size and Maximum Size
This is where you set the minimum and maximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.
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1. Minimum Size field: Type a value in this field to set the minimum width of the line.
2. Maximum Size field: Type a value in this field to set the maximum width of the line.
3. Up/Down arrows: Use the up and down arrows to set the minimum size value.
4. Up/Down arrows: Use the up and down arrows to set the maximum size value.
This options is available while using the Brush Smoothing

style.

Smoothness
The Smoothness

impacts the strength of the smoothing result. The higher the value, the more points are

removed and the smoother the curve is.

Colour

You can modify the colour of the control points displayed on the artwork while working with the Smooth Editor
tool by double-clicking on the colour swatch.
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Related Topics
•

Smoothing Lines on page 270
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Working With Text
With the Text tool, you can type text in your project, using various fonts and texts attributes. Text objects are
part of a drawing, so you can manipulate them the same way.
To add text to your drawings:
1. Do one of the following:
‣

In the Tools toolbar, select the Text

‣

Select Drawing > Tools > Text.

‣

Press [Alt] + [9].
In Harmony Paint, select a Tools > Text.

tool.

2. In the Timeline view, select the cell containing the drawing you want to add text to.
3. In the Drawing or Camera view, click on the location you want your text to begin.

4. You can use the Tool Properties view to select the font, font size and format the text you will type—see
Formatting the Text below.
5. Type in the desired text.

6. Click outside the text box to exit the typing mode.
If you want to create another text object, click outside the currently active text box. You can always return
to edit the text by selecting the Text
tool and clicking in the text.

Related Topics
•

Formatting the Text below

Formatting the Text
Use the Text tool Tool Properties view to select the font type and other formatting options you want to apply to
the text.
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1. Font Type below
2. Font Style below
3. Alignment on the next page
4. Font Size on the next page
5. Kerning on the next page
6. Indent on page 277
7. Line Spacing on page 277

•

Resizing the Text Box on page 277

•

Converting Text into Separate Objects on page 278

If you already wrote your text, you must first use the Text tool and select the text portion you want to
format.

Font Type
Use this drop-down menu to select the desired font, from the list of fonts available in your system.

Font Style
Use these buttons to select a desired style for your text:
•

Bold

•

Italic
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Alignment
Use these buttons to align the paragraph.
Left

Centred

Right

Justified

Font Size
Type the desired size for the text in this field. You can also use the up and down arrow buttons to set the desired
value.

Kerning
Use the kerning field to modify the spacing between letters and characters. You can select the Auto Kern option
to set the kerning automatically, based on the font’s predefined standard. A negative value decreases spacing
between each character creating a letter overlap and a positive value increases it.
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Indent
Enter a value in the Indent field to increase or decrease the indentation on the first line of your text. A positive
value sets the first line of your paragraph farther to the right and a negative value sets it farther to the left.

Line Spacing
Enter a value in the Line Spacing field to decrease or increase the space between each line of text.

Resizing the Text Box
You can resize the text box by selecting your text box with the Text
or left.
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Using the Select tool will distort and scale your text itself rather than changing the width and height of your text
box.

Converting Text into Separate Objects
Text contained in a text field is treated as a single drawing object. You can easily separate the text so that each
character becomes an individual drawing object that you can select and modify independently.
To break a text object:
1. In the Tools toolbar, click on the Select

tool or press [Alt] + [S].

2. In the Drawing or Camera view, select the text object you want to break.

3. Select Drawing > Convert > Break Apart Text Layers.
In Harmony Paint, select Selected > Convert > Break Apart Text Layers.

Each character is now surrounded by its own bounding box that you can modify, they remain text objects
that you can edit.
4. If you want to convert your independent letter to a complete vector object that you can deform, using the
Select tool, select the letters to convert.
5. Select Drawing > Convert > Break Apart Text Layers to break the selection into a regular drawing
object, with no more text attributes.
In Harmony Paint, select Selected > Convert > Break Apart Text Layers.

Related Topics
•

Working With Text on page 274
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Override Tool
The Override Tool lets you increase productivity by rapidly switching between tools used for short tasks and
your previous tool. Most drawing tool shortcuts are accessed using the [Alt] key followed by another key, such as
the Eraser tool which is accessed by pressing [Alt] + [E].
If you are drawing with the Brush tool and need to briefly switch to the Eraser before continuing, hold down the
[E] key while you are erasing. Once done, release [E] to return to the previous tool, in this case, the Brush tool.
You can do the same for most drawing tools that have a shortcut composed of [Alt] followed by another key.

Related Topics
•

Keyboard Shortcuts on page 95

•

Tools Toolbar on page 109

279

Chapter 4: Drawing More Drawing Tools

More Drawing Tools
Harmony offers a wide variety of useful tools to optimze your drawings and work more efficiently; tools such as
Group, Arrange, and the animation disk to rotate your workspace.

Related Topics
•

Arrange below

•

Convert Brush Strokes to Pencil Lines on the facing page

•

Pencil Lines to Brush Strokes on the facing page

•

Strokes to Pencil Lines on the facing page

•

Optimize on page 282

•

Remove Extra Strokes on page 282

•

Reduce Drawing Texture Resolution on page 282

•

Crop Brush Textures on page 283

•

Create Contour Stroke on page 284

•

Remove Contour Stroke on page 284

•

Grid on page 284

•

Group/Ungroup on page 285

•

Hand on page 285

•

Rotate View on page 285

Arrange
Use the different Arrange options to reorder drawing objects inside a single layer in the Drawing or Camera
view.
•

Bring to Front button or select Drawing > Arrange > Bring to Front or press [Ctrl] + [Shift] + [PgUp]
(Windows/Linux) or [⌘ ] + [Shift] + [PgUp] (Mac OS X).
The selected art is moved to the top.

•

Bring Forward button or select Drawing > Arrange > Bring Forward or press [Ctrl] + [PgUp]
(Windows/Linux) or [⌘ ] + [PgUp] (Mac OS X).
The selected art is moved one level higher.

•

Send Backward button or select Drawing > Arrange > Send Backward or press [Ctrl] + [PgDown]
(Windows/Linux) or [⌘ ] + [PgDown] (Mac OS X).
The selected art is moved one level lower.

•

Send to Back button or select Drawing > Arrange > Send to Back or press [Ctrl] + [Shift] +
[PgDown] (Windows/Linux) or [⌘ ] + [Shift] + [PgDown] (Mac OS X).
The selected art is moved to the bottom.
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Convert Brush Strokes to Pencil Lines

The Brushes Strokes to Pencil Lines

operation converts the selected contour strokes into centreline pencil

strokes. This command is only available from the top menu.
To convert brush strokes to pencil lines:
‣

Select Drawing > Convert > Brush Strokes to Pencil Lines or press [^].

In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.

Pencil Lines to Brush Strokes

The Pencil Lines to Brush Strokes

operation converts the selected centreline pencil strokes into contour

strokes brush lines.
To convert pencil lines to brush strokes:
‣

From the top menu, select Drawing > Convert > Pencil Lines to Brush Strokes or press [&].

In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.

Strokes to Pencil Lines

The Strokes to Pencil Lines

operation converts the selected invisible line to a pencil line.
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To convert strokes to pencil lines:
‣

Select Drawing > Convert > Strokes to Pencil Lines. or press [Shift] + [F12] (Windows/Linux only).

In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.

Optimize

The Optimize command reduces the number of layers, such as overlapping brush strokes, in the selected
drawing objects. Drawing objects will only be flattened and optimized if the selected objects will not change the
appearance of the final image when they are merged.
For example, if you have selected a number of partially transparent objects, which you layered to create an
additive colour effect, the selected transparent drawing objects will not be merged. This is because merging the
transparent drawing objects will cause them to lose the effect of the layered transparent colours.
•

Use the Select tool to select the drawing objects you want to optimize.

•

Select Drawing > Optimize > Optimize.

In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.

Remove Extra Strokes
The Remove Extra Strokes option is used to remove the invisible lines in your selection.
•

Use the Select tool to select the drawing objects you want to remove invisible lines from.

•

Select Drawing > Optimize > Remove Extra Strokes.

In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.

Reduce Drawing Texture Resolution
If you import and vectorize as texture (colour) a high resolution image, the size of your drawing can be heavy.
This option is used to reduce the size and resolution of the textures in your drawing. When you import and
vectorize drawings using the grey or colour preset styles, you don't have control on the size of the bitmap
texture. This tool allows you to reduce that bitmap texture.
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To reduce the drawing texture resolution:
•

In the Timeline or Xsheet view, Select tool to select the drawing objects you want to reduce the texture
resolution for.remove invisible lines from.

•

Select Drawing > Optimize > Reduce Drawing Texture Resolution.

In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.

1. In the dialog box, drag the slider toward the left to reduce the texture resolution.
2. Enable the Apply to All Drawings option if you want the modification to be applied to all the drawings in
your layer.
3. Click OK.

Crop Brush Textures

The Crop Brush Textures option is used to crop an unnecessarily large texture bitmap that lies, unseen,
beneath the vector contour of a textured line. This often occurs when you cut and paste textured lines from one
drawing into another. If you cut a portion from a textured line and paste it into a different drawing, Toon Boom
Harmony pastes the entire unseen texture bitmap from the source drawing into the new one, even if you only
took a small portion of the source drawing. Using the Crop Brush Texture command will crop away extraneous
texture that does not touch the vector area. If there are many textured lines in your scene, this will greatly reduce
the file size.
In the example shown above, a textured line is cut from a drawing and pasted into a new drawing. At first
glance, it appears as if only a cropped section of the underlying texture bitmap was cut and pasted as well.
However, using the Contour Editor tool to expand the vector envelope of the textured line, it is revealed that
more texture bitmap exists beyond the cropped boundary. If you use the Crop Brush Texture command the
bitmap texture is cropped to the boundaries of the textured line’s vector contour (as seen in the fourth image
where the vector envelope has been pulled out to reveal empty space).
To crop the brush texture:
1. In the Timeline or Xsheet view, select the drawing you want to crop the texture for.
2. Select Drawing > Optimize > Crop Brush Textures.
In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.
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Create Contour Stroke
The Create Contour Stroke

option is used to add a permanent invisible line around a shape that was drawn

directly in the application. This allows you to unpaint your lines with the Paint

tool but to maintain the shape

of the lines should you need to repaint later.
This command is useful when inking and painting and using the Apply to All Drawings in Layer

option.

In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.

Remove Contour Stroke
The Remove Contour Stroke option is used to remove any permanently invisible lines that were either created
while scanning and vectorizing drawings or manually adding contour strokes. This is useful if you want to remove
the intersection triangles created during vectorization.
In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.

Grid

Use the Show Grid option to display a grid in the Drawing or Camera view.
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•

Select View > Grid > Show Grid. The [Ctrl] + ['] (Windows/Linux) or [⌘ ] + ['] (Mac OS X).

•

Select View > Grid > Square to display a standard square grid.

•

Select View > Grid > 12 Field Grid to display a 12 field size grid.

•

Select View > Grid > 16 Field Grid to display a 16 field size grid.

•

Select View > Grid > Underlay to display the grid behind the drawing elements.

•

Select View > Grid > Overlay to display the grid over the drawing elements.

Group/Ungroup
Use the Group

option to group the selected drawing objects. This can help in the selection, repositioning,

re-scaling and other transformations to be applied to multiple objects of a drawing.
In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.
•

Select Edit > Group > Group or Edit > Group > Ungroup.

•

Press [Ctrl] + [G] and [Ctrl] + [Shift] + [G] (Windows/Linux) or [⌘ ] + [G] and [⌘ ] + [Shift] + [G] (Mac OS X).

Hand
Use the Hand tool to pan through the Drawing and Camera view.
•

In the Tools toolbar, select the Hand

tool, click in the Drawing or Camera view and drag your cursor.

•

You can also Hold down the keyboard shortcut [Spacebar], click in the Drawing or Camera view and
move your mouse in the direction you want to pan the view.

Rotate View
Use the Rotate View

tool to rotate the Drawing or Camera view, the same way as you would do with a real

animation disc.
•

Select Drawing > Tools > Rotate View.

In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.
•

Press [Ctrl] + [Alt] (Windows/Linux) or [⌘ ] + [Alt] (Mac OS X).
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This tool can also be used in the Perspective view.

Related Topics
•

How to Draw on page 153

Drawing Pivot Tool
The Drawing Pivot

tool lets you set the pivots on your character. You can set the drawing pivots on

drawings and symbols.

•

Setting the Drawing Pivot for Symbols on All Frames below

•

Snapping on the facing page

•

Reset Pivot on the facing page

•

Copying Pivot on Parent Symbol on the facing page

Setting the Drawing Pivot for Symbols on All Frames
The Set the Pivot for Symbol on All Frames

option is enabled by default. When you set a drawing pivot on a

symbol, all of its cells use the same drawing pivot. This means you do not have to set a drawing pivot on all
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frames. Once you set it, it is done.
If you prefer to set a different drawing pivot for a series of cells, you can deselect the option and set your pivots
on each cell or cell range.

If you have already set several different pivots on your symbol's cells and selected the Set the Pivot
for Symbol on All Frames option, once you set a new pivot on the same symbol, all of its pivots will be
reset and will use your new pivot.

Snapping

When you drag the drawing pivot around, you can enable a snap option so that when the drawing pivot is
released, it either snaps to the reference grid, drawing's contour, or aligns with an existing drawing stroke.

Refer to Snap Options on page 221.

Reset Pivot
When you click the Reset Pivot

option, the drawing pivot of the selected drawing or symbol is reset to the

centre of the Camera view (stage).

Copying Pivot on Parent Symbol
When you import new extra drawings, such as hands and mouths, you can use the drawing pivot that was set on
your drawings and report them to the symbol's cells. Use the Copy Pivot to Parent Symbol
command for
this.

When you copy drawing pivots to the parent symbol, there is no link between the drawings' pivots
and the symbol's pivots. If you modify the drawing pivot later, it will not link to the symbol. You would
need to do the operation again. If you need to modify the symbol's pivots, you can do it directly on
the symbol's cells.

Related Topics
•

Setting the Pivots on page 716

•

Setting Pivots on a Frame Range on page 757

287

Chapter 4: Drawing Drawing Preferences

Drawing Preferences
When drawing or animating traditionally in Toon Boom Harmony, there are preferences you can set to help you
work more efficiently.
To open the Preferences dialog box:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

Press [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).

Related Topics
•

OpenGL Drawing Preferences below

•

Drawing on the facing page

•

Advanced Tab Preferences on page 291

OpenGL Drawing Preferences

Real-Time Antialiasing
By default, the Real-Time Antialiasing preference is disabled. This option lets you see smooth lines as you draw.
You can change the value of the Antialiasing using the Preferences dialog box, to fit the current level used in the
Camera or Drawing view.
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Refer to the Viewing the Final Lines as you Draw on page 174

Full Scene Antialiasing
By default, the Full Scene Antialiasing preference is disabled. This option lets you see smooth lines as you draw
as swell as an antialiased drawing area. You can change the value of the Full Scene Antialiasing using the
Preferences dialog box, to fit the current level used in the Camera or Drawing view.

Refer to the Viewing the Final Lines as you Draw on page 174.

Support Transparency in Pencil Lines
When the option is enabled, the pencil lines are displayed normally. The lines will be opaque (unless there are
transparencies). Disabling this option will reduce rendering times, but will display additive opacities for
overlapping pencil lines and unevenly filled curved pencil lines.

Drawing
These are the preferences you can find in the Drawing tab.
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Light Table
•

Onion Skin Render Style:
•

Normal: The onion skinned drawings is displayed in washed out colours.

•

Enable Shade: The previous onion skinned drawings are displayed in washed out red shades and the
next onion skinned drawings are displayed in washed out green shades.

•

Outlines Only: The onion skinned drawings are displayed as outlines only.

•

Light Table: Enable Shade: When enabled, the drawings appearing in the Light Table are displayed in
washed out colours in the Drawing view. When this option is disabled, the drawings appearing in the
Light Table are displayed using normal colours. This option is for the Drawing view only.

•

Light Table: Shade in Camera View: When enabled, the drawings appearing on other layers are
displayed in washed-out colours in the Camera view. When this option is disabled, the drawings
appearing on other layers are displayed using normal colours. This option is for the Camera view only.

•

Enable Onion Skin for Other Elements: When both Onion Skin and Light Table options are enabled, the
drawings appearing in the Light Table also display their previous and next onion skinned drawings. This
option is for the Drawing view only.

•

Onion Skin: Maximum Wash Value (0,0-1,0): The maximum washed-out value for onion skinned
drawings.

•

Onion Skin: Minimum Wash Value (0,0-1,0): The minimum washed-out value for onion skinned
drawings.
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•

Onion Skin: Maximum Opacity (0,0-1,0): The maximum opacity value for onion skinned drawings. (0 =
transparent).

•

Onion Skin: Minimum Opacity (0,0-1,0): The minimum opacity value for onion skinned drawings. (0 =
transparent).

•

Light Table: Wash (0,0-1,0): The washed-out value for the light table display.

•

Light Table: Opacity (0,0-1,0): The opacity value for the light table display. (0 = transparent).

Options
•

Grid On By Default: When opening the Drawing view, the grid displays automatically.

•

Select Tool is Lasso: When this option is enabled, the Select tool behaves as a lasso selector. When this
option is disabled, the Select tool behaves as a rectangle selector.

•

Brush Size Cursor: When this option is enabled, the brush tool displays the brush size as a circle around
the cursor.

•

Auto Save Pen Styles: When this option is enabled, new pens and pen styles are automatically saved.

•

Thumbnails View location: When sending a series of drawings to the Drawing view, the drawing list
appears in a Side panel. This preference changes the location of the Side panel in the Drawing view. By
default, the panel is displayed on the right-hand side of the Drawing view. You must restart the
application for this change to be applied.

•

Default Pencil Line Tip: Sets the default pencil line tip to either Round, Flat, or Bevel.

Zoom
•

Enable Paper Zoom: Enabling this option allows you to set the 100% Zoom level onscreen, in order to
physically match the measurements of your paper drawing.
•

Number of Pixels per Inch: Enter the PPI for your monitor. To obtain the PPI of your screen, divide
the height or width of your monitor's resolution setting by the corresponding physical height or width
of your monitor screen (resolution height divided by physical height, or resolution width divided by
physical width) in inches.

•

Maximum Zoom Factor: Sets the maximum zoom level for the paper zoom.

•

Magnifier Width: Sets the width of the Drawing Magnifier floating window.

•

Magnifier Height: Sets the height of the Drawing Magnifier floating window.

•

Magnifier Offset X: Sets the X-axis distance from which the Drawing Magnifier window floats from your
cursor.

•

Magnifier Offset Y: Sets the Y-axis distance from which the Drawing Magnifier window floats from your
cursor.

•

Magnifier Zoom Factor: Sets the magnification level of the Drawing Magnifier floating window.

•

Quick Close Up Zoom Factor: Sets the zoom level for the Quick Close up Zoom keyboard shortcut. The
default shortcut is [Shift] + [Z].

Advanced Tab Preferences
These are the related preferences you can find in the Advanced tab.
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Advanced Options
•

Restore Current Selected Drawing On Undo: If a drawing other than the current one is being affected
by an Undo command, the affected affected drawing is displayed.
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Topics Covered
•

Traditional Animation Tools on the next page

•

Basic Traditional Animation on page 304

•

Advanced Traditional Animation on page 311

•

Cleaning Scanned Drawings on page 332
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Traditional Animation Tools

Traditional Animation Tools

When you animate digitally using traditional techniques, there are certain tools you require in order to work
efficiently, as you would do with an animation table, paper and pencils. These tools are described in this section:
•

Onion Skin below

•

Light Table on page 296

•

Drawing Identification on page 297

•

Create Empty Drawing on page 300

•

Reposition All Drawings on page 301

Onion Skin

The Onion Skin

tool is used to preview the previous and subsequent drawings. When designing or

animating, it is useful to be able to see your previous drawings. By default, the previous drawings will appear
with a shade or red and the next drawings will be displayed with a shade of green but you can change the display
options in the Preferences panel.

Refer to the Drawing Preferences on page 288 topic to learn about the Onion Skin preferences.
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To use the Onion Skin feature:
1. Enable the Onion Skin feature:
‣

In the Tools toolbar, click on the Show Onion Skin

‣

In the Timeline view, click on the Onion Skin

‣

From the top menu, select View > Onion Skin > Show Onion Skin.

‣

Or press [Alt] + [O].

button.

icon. When enabled, the icon will turn red

.

2. You can select the number of previous and next drawings you want to show:
‣

In the Timeline view, click and drag the Onion Skin blue markers to choose how many previous and
next drawings will be displayed.

‣

Select View > Onion Skin > No Previous Drawing or press [~].

‣

Select View > Onion Skin > Previous Drawing or press[!].

‣

Select View > Onion Skin > Previous Two Drawings or press [@].

‣

Select View > Onion Skin > Previous Three Drawings or press [#].

‣

Select View > Onion Skin > No Next Drawing or press [Ctrl] + [`] (Windows/Linux) or [⌘ ] + [`]
(Mac OS X).

‣

Select View > Onion Skin > Next Drawing or press [Ctrl] + [1] (Windows/Linux) or [⌘ ] + [1] (Mac
OS X).

‣

Select View > Onion Skin > Next Two Drawings or press [Ctrl] + [2] (Windows/Linux) or [⌘ ] + [2]
(Mac OS X).

‣

Select View > Onion Skin > Next Three Drawings or press [Ctrl] + [3] (Windows/Linux) or [⌘ ] +
[3] (Mac OS X).

3. The previous and next drawings will appear in both the Camera and Drawing view.
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Related Topics
•

Traditional Animation Tools on page 294

Light Table

The Light Table

is used to preview the previous and subsequent active layers in washed-out colours. It is

useful to be able to see the other layers when designing, animating or cleaning up your animation.
In the Camera view, when the Light Table is activated all layers apart from the currently selected one are shown
washed-out. The display returns to the normal mode when the Select tool or a scene setup tool is selected.
Only the currently selected drawing is displayed by default in the Drawing view. When enabling the Light Table,
the other layers appear as a washed-out display and are used as a reference. You can not select or manipulate
them.
To use the Light Table feature:
1. Enable the Light Table feature:
‣

In the top menu, select View > Light Table.

‣

In the Drawing View toolbar, click on the Light Table
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‣

Or press [Shift] + [L].

2. The drawings for the other layers are displayed as washed-out colours in the Camera and Drawing view.

3. In the Timeline view, you can disable the layers you wish to hide from the Light Table.

Refer to the Drawing Preferences on page 288 topic to learn about the Light Table preferences.

Related Topics
•

Traditional Animation Tools on page 294

Drawing Identification
In the Xsheet view, you can identify your drawings as Key, Breakdown or In-between. This helps to keep your
Xsheet well organized while animating.
When working with several animators, directors, or even other studios, the necessity for retakes will often arise.
Harmony also gives you the possibility to mark your new drawings as either Retake Key, Retake Breakdown, or
Retake Inbetweens.
If your production requires you to mark your drawing with a custom marker, you also have the option to create
your own.
To mark a drawing as Key, Breakdown or In-between:
1. In the top menu, select Windows > Toolbars > Mark Drawing to display the Mark Drawing toolbar.

2. In the Xsheet view, select the cell you want to identify. This option is not available in the Timeline view.
3. In the Mark Drawing toolbar, press on the Mark as Key Drawing
Mark as In-between Drawing

, Mark as Breakdown Drawing

or

buttons. In the Xsheet View menu, you can also select Drawing > Mark

Drawing As > Key Drawing, Breakdown Drawing, In-between Drawing, Retake Key, Retake BD and
Retake IB.
‣

If you select Mark as Key Drawing, a

icon appears in the cell.
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‣

If you select Mark as Breakdown Drawing, a

‣

If you select Mark as In-Between Drawing, there is no icon displayed in the cell since it is used to
remove a Key or Breakdown marker.

icon appears in the cell.

You can create your own custom shortcuts for the Drawing Identification options by going in the
Preferences panel. Refer to Customizing a Keyboard Shortcut on page 96 to learn how to customize
keyboard shortcuts.

Custom Marks in the Xsheet View
Make custom marks for the Xsheet by creating your own icons, then cutting, pasting and changing a bit of code.
Not only is it possible to have your custom mark appear in the Xsheet and Mark Drawing toolbar, but also in the
Onion Skin and Flip toolbars.
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To create your custom markers:
1. With a bitmap editing software, create the following icons in PNG format:
‣

Mark Drawing Toolbar icon (24 x 24 pixel)

‣

Onion Skin Toolbar icon (24 x 24 pixel)

‣

Flip Toolbar icon (24 x 24 pixel)

‣

Xsheet Column icon (16 x 16 pixel)

2. Close Harmony.
3. Once your icons are ready, go to the Toon Boom Harmony resources/drawingTypes.d directory:
•

•

Stand-alone
‣

Mac OS X: /Applications/Toon Boom Harmony 10/resources/drawingTypes.d

‣

Linux: /usr/local/ToonBoomAnimation/harmony_10.0/resources/drawingTypes.d/

‣

Windows: C:/Program Files (x86)/Toon Boom
Animation//resources/drawingTypes.d

Network
‣

Mac OS X: /Users/*username*/Library/Preferences/Toon Boom Animation/Toon
Boom Harmony/full-1000-pref/drawingTypes.d

‣

Linux:~/Toon Boom Animation/Toon Boom Harmony/full-1000-pref/drawingTypes.d

‣

Windows: C:/Users/*username*/AppData/Roaming/Toon Boom Animation/Toon Boom
Harmony/full-1000-pref/drawingTypes.d

4. Paste your icons it the resources/drawingTypes.ddirectory.
5. In that same directory, open the drawingTypes.xml file in a text editor.
6. For each custom icon you want to create, add the following line. Make sure it is placed before the closing
</DrawingTypes> tag.
‣

<DrawingType text="NewButtonName" pixmapFile="XsheetIcon.png"
commandIcon="MarkDrawingIcon.png" flipIcon="FlipIcon.png" onionIcon="OnionIcon.png" />

7. In that line, replace the following information with your new icon information:
‣

NewButtonName: Write the name of your new marker. This name will appear in the button tooltip.
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‣

XsheetIcon.png: Write the name of the icon that you created to appear in the Xsheet column. Include
the file extension.

‣

MarkDrawingIcon.png: Write the name of the icon that you created to appear in the Mark Drawing
toolbar. Include the file extension.

‣

FlipIcon.png: Write the name of the icon that you created to appear in the Flip toolbar. Include the file
extension.

‣

OnionIcon.png: Write the name of the icon that you created to appear in the Onion Skin toolbar.
Include the file extension.

8. Save the file and close it.
9. Launch Harmony.

Related Topics
•

Traditional Animation Tools on page 294

Create Empty Drawing
The Create Empty Drawing

command automatically creates a drawing in the selected cell of the Timeline

and Xsheet view, replacing any drawing that may already be exposed in that cell and the following ones until it
meets another drawing.
To create an Empty Drawing:
1. In the Timeline or Xsheet view, select the cell you want to create an empty drawing in.
2. In the Xsheet View toolbar, click on the Create Empty Drawing
Animation > Create Empty Drawing or press [Alt] + [Shift] + [R].
3. The new drawing will be created in the Xsheet and Timeline views.

Related Topics
•

Traditional Animation Tools on page 294
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Reposition All Drawings

The Reposition All Drawings

option is used to reposition, scale, rotate or skew all drawing strokes on every

drawing included in a layer.
To reposition all drawings:
1. In the Tools toolbar, select the Reposition All Drawings

tool. This also automatically selects every

stroke in your drawing in the Drawing and Camera view.

2. To deform or reposition a selection:
‣

To reposition, click and drag your selection to a new area.

‣

To rotate, rotate the selection box handle.
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‣

To scale, pull or push either on the top, side, bottom or corner control points. Hold down [Shift] to
lock the selection’s ratio.

‣

To skew, drag the sides or top and bottom segments, between the control points.

3. When you release your cursor, every drawing contained in the drawing layer you repositioned, scaled,
rotated or skewed will follow the same transformation.
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Related Topics
•

Traditional Animation Tools on page 294
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Basic Traditional Animation

Basic Traditional Animation

Toon Boom Harmony lets you animate traditionally, but work entirely digitally. Many tools and features are
supplied to help you achieve that traditional animation look easily and efficiently.

Related Topics
•

Animating below

•

Cleaning Up on page 308

•

Setting the Timing on page 310

Animating

Now that you know about the existing tools, you can start your animation.
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The first step to complete is the rough animation, which is the skeleton of your animation. You would usually
start with the main action. For example, to animate a walk-cycle, you will start with the torso moves and the legs.
Head, arms and clothes will be added later, during the secondary animation.
For a satisfactory animation, complete the main action before adding all of the details. If you start animating all
of the details right away, you will lose a lot of time if you have to do corrections, and your animation will often
look too rigid.
To animate:
1. In the Preferences panel, you can set your preferences to Use Current Frame as Drawing Name. Refer to
Exposure Sheet on page 337 to learn more about this preference.
2. In the Tools toolbar, select the Brush

tool or press [Alt] + [B].

3. In the Colour view, select the colour you will use to draw. It is a good idea to choose a light colour for your
rough animation to help for the following task, the clean up process.

4. In the Timeline or Xsheet view, select the cell where the first drawing will appear.
5. In the Camera or Drawing view, draw the first key drawing.

6. Make sure your first key drawing is still selected, and in the Mark Drawing toolbar, click on the Mark
Selected Drawings as Key button.
‣

In the Xsheet view, you can also select Animation > Mark Drawing As > Key Drawing to identify your
drawing.
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7. In the Tools toolbar, click on the Enable Onion Skin

button.

8. In the Timeline view, click and drag the onion skin blue markers to extend the number of previous and
next visible drawings to fit your need.

9. In the Timeline or Xsheet view, select the cell where your next key drawing will appear.

10. In the Camera or Drawing view, draw your second key drawing.

11. In the Xsheet view, identify the drawing as a key drawing.

12. In the Xsheet view, select a cell between your two key drawings.
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13. From the Timeline View toolbar, click
‣

to create an empty drawing or press [Alt] + [Shift] + [R].

In the Xsheet view, right-click and select Drawings > Create Empty Drawing or press [Alt] + [Shift] +
[R].

14. Draw your new drawing.

15. If necessary, in the Xsheet view, identify the new drawing as a Key, Breakdown or In-between drawing.

16. In the Timeline or Xsheet view, select a new cell and repeat step 9 to step 15 for each new drawing.
17. In the Timeline view, disable the layers you do not want to show during playback.
18. In the Playback toolbar, click on the Loop
19. In the Playback toolbar, click on the Play

button if you want the playback to loop.
button to start the animation.

Related Topics
•

Cleaning Up on the next page

•

Setting the Timing on page 310
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Cleaning Up

When your rough animation is ready, it is time to clean it up and ink it. The clean-up is also called tracing. It
consists of tracing solid and clean lines over the rough animation to get closed zones. This is the final paperless
animation step before the ink and paint step.
You will need to add a new drawing layer to draw your clean. This is the equivalent of adding a sheet of paper
and tracing the rough using the animation disk.

If you plan on tracing your animation in the Drawing view, you will need to enable the Light Table
feature in order to display all the layers of your project.

To trace your animation in a new layer:
1. In the Timeline View toolbar, click on the Add Drawing Layer

button.

2. In the Timeline view, click the lock icon of the layer containing your rough animation to prevent selecting
the layer in the Camera view.

1.
2. In the Timeline or Xsheet view, select the new layer’s cell corresponding to the first key drawing of your
rough animation.
3. In the Tools toolbar, select the drawing tool of your choice. We recommend the Pencil

tool.

4. In the Colour view, select the colour you will use to trace your animation. Pick a dark bold colour such as
black to make sure it contrasts well with the light colour of your rough animation.
5. In the Camera or Drawing view, start tracing the first key drawing.
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6. If you have some other layers in the way, you can disable them temporarily from the Timeline view so that
only your rough animation and your clean up layer are displayed in the Camera view.
7. In the Tools toolbar, click on the Enable Onion Skin

button and extend the Onion Skin In the Timeline

view.

8. In the Timeline or Xsheet view, select the next cell corresponding to a rough drawing.
9. In the Camera view, trace your next drawing.

10. Repeat the previous steps for each drawing.

This method allows you to keep the roughs and the cleans intact. You only need to disable the rough
layer to prevent it from appearing in the scene.
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Related Topics
•

Animating on page 304

•

Setting the Timing below

Setting the Timing
Refer to the following topics in the Timing on page 433 chapter to learn how to set the timing of
your animation:

•

Filling Exposure on page 480

•

Filling Exposure Mode on page 480

•

Typing Exposure on page 481

•

Holding Exposure on page 483

•

Extending a Single Exposure on page 484

•

Extending an Exposure Sequence on page 484

•

Dragging Cells on page 485

•

Increasing and Decreasing Exposure on page 488

•

Deleting Exposure on page 491

•

Inserting Blank Cells on page 492

•

Setting the Exposure on page 493

•

Filling a Selection with a Single Exposure on page 494

•

Filling a Selection with a Sequence on page 495

•

Filling a Selection Randomly on page 497

•

Creating Cycles on page 498

Related Topics
•

Animating on page 304

•

Cleaning Up on page 308
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Toon Boom Harmony has many useful features such as the Flipping toolbar, enhanced Onion Skin, extra drawing
layers, automated matte and more.

Related Topics
•

Flip and Easy Flipping Toolbars below

•

Onion Skin Toolbar on page 313

•

Shift and Trace on page 315

•

More Drawing Layers on page 325

•

Multiple Drawings in the Drawing View on page 329

•

Preview Selected Drawings on page 330

Flip and Easy Flipping Toolbars
Toon Boom Harmony provides a Flip feature which allows you to rapidly flip through the drawings as one would
with paper drawings. You can flip through the Key, Breakdown or In-between drawings individually, or view a
combination.

The Flipping features only work in the Drawing view.
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To flip through your drawings:
1. In the top menu, select Window > Toolbars > Easy Flipping and Flip.

2. In the Easy Flipping toolbar, click on the Previous

or Next

button to see the previous or next

drawing of your animation.
3. Enable the Loop option to loop your animation during the flip. This way, when you reach the end of your
animation, the first drawings will show up again.

4. Move the slider to the right to flip forward and to the left to flip backward through your drawings.

‣

The more that you move the slider to the left or the right, the faster the drawings will flip.

5. If you marked some of your drawings as Key, Breakdown or In-between, you can flip through the markers
and avoid seeing all the in-betweens. Enable the Flip Key, Breakdown or In-between option in the Flip
toolbar, to see only one type or a combination. See Drawing Identification on page 297.

Related Topics
•

Drawing Identification on page 297

•

Advanced Traditional Animation on the previous page
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Onion Skin Toolbar

You can setup your onion skin to display only the marked drawings, in the same way that you flip through your
drawings marked as Key, Breakdown or Inbetween drawings. See Drawing Identification on page 297.

This Onion Skin feature only operates in the Drawing view.

To display the marked drawings in the onion skin:
1. In the top menu, select Window > Toolbars > Onion Skin.

2. In the Tools toolbar, enable the Onion Skin

feature.

3. In the Timeline view, pull on the blue arrows to extend the number of drawings displayed in the onion skin
preview.

4. In the Onion Skin toolbar, enable the markers you want to see in your Onion Skin preview.
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Related Topics
•

Drawing Identification on page 297

•

Enabling the Onion Skin in Other Layers below

•

Advanced Traditional Animation on page 311

•

Flip and Easy Flipping Toolbars on page 311

Enabling the Onion Skin in Other Layers
Sometime, you might need to refer to previous and next drawings in other layers than the current one. You can
activate the Enable Onion Skin in Other Elements option to see the previous and next drawings of the layers
visible in Light Table mode.

This Onion Skin feature only operates in the Drawing view.

To enable the onion skin in other layers:
1. In the top menu, select Window > Toolbars > Onion Skin.

2. In the Tools toolbar, enable the Onion Skin

feature.

3. In the Drawing view, enable the Light Table

option. This option is not available in the Camera view.

4. In the Timeline view, pull on the blue arrows to extend the number of drawings displayed in the onion skin
preview.
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5. In the Onion Skin toolbar, enable the Enable Onion Skin in Other Elements option.

‣

By default, layers located on top (in the Timeline view) of the current layer will be displayed as shades
of blue.

‣

By default, layers located below (in the Timeline view) of the current layer will be displayed as shades
of yellow.

‣

By default, the current layer will be displayed in shades of green and red.

You can change the Onion Skin display default colours in the Preferences panel. See General > Edit
Colours on page 336.

Related Topics
•

Advanced Traditional Animation on page 311

•

Flip and Easy Flipping Toolbars on page 311

•

Onion Skin Toolbar on page 313

Shift and Trace
When animating traditionally, it is very important to stay on model. Losing the proportions or features of a
character is easy to do. The Shift and Trace feature makes it possible to temporarily move a drawing so that you
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can trace it on another one. This is similar to animators working on an animation light table and using cut-out
pieces of a character to move it underneath the new drawing and trace it.
The Shift and Trace option will not modify your drawing, it will only allow it to be moved, rotated or scaled in the
Shift and Trace mode. As soon as you disable the Shift and Trace option, the repositioned drawing returns to its
normal state.

If you use the Shift and Trace feature a lot, you can assign custom shortcuts to the following
operations:
•

Shift and Trace Drawing Move Down

•

Shift and Trace Drawing Move Up

•

Shift and Trace Drawing Reset Position

•

Shift and Trace Drawing Toggle Peg State

•

Shift and Trace Drawing Toggle Visibility

•

Shift and Trace Move Tool

•

Shift and Trace Rotate Tool

•

Shift and Trace Scale Tool

•

Shift and Trace Toggle Manipulator

•

Shift and Trace Toggle View

Refer to Customizing a Keyboard Shortcut on page 96 to learn how to customize keyboard shortcuts.

To shift and trace:
1. In the Tools toolbar, enable the Onion Skin

feature.

2. Open a Drawing view.
3. In the Xsheet view, select the range of drawings you need to shift and trace. This selection should include
at least the layer containing the piece you need to trace and the new drawing in which you will trace.

4. In the Xsheet view, right-click on your drawing selection and select Drawings > Send to Drawing view.
The selected drawings are sent to the Thumbnail view which appears in the Drawing view.
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The Thumbnail view is situated by default on the right side of the Drawing view. You can change its
positioning via the Preferences panel.

5. Press on the Shift and Trace Enable

button to enable the option.

Registration holes appears at the bottom of your drawings.

At the bottom of the Drawing view, a close up window appears to display the registration marks up close
to be able to move and reposition them easier if you are zoomed out quite a bit while working on your
drawings.
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6. Select the Shift and Trace

tool.

7. Enable the Onion Skin. Select View > Onion Skin > Show Onion Skin or press [Alt] + [O].
8. If not done already, enable the check box corresponding to the drawing you want to allow to be
transformed temporarily. All drawings are enabled for Shift and Trace operations by default.

9. Select the drawing you want to move.

10. If you want to draw more than one drawing at once, you can link them together. In the Shift and Trace
panel, select several drawings and click on the Link Drawings and Unlink Drawings buttons to lock their
position together.

11. In the Drawing view, transform the drawing as needed, to position it between you two key poses:
‣

To reposition, click and drag the drawing to a new area.

‣

To rotate from the centre peg, click on the flat peg hole and rotate.
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‣

To scale, pull or push on the triangle control.

‣

Hold [Alt] to show the pivot point. The pivot point is situated in the middle of your current drawing
view. To rotate from the pivot point. Hold [Alt] and rotate
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‣

To scale from the pivot point, hold [Shift] and move your cursor.

‣

Click and drag the pivot point to move it to a new position. Once the pivot point have been moved,
you need to hold [Alt] and move your drawing in order to show it again.

320

Toon Boom Harmony 10.3 Stage User Guide

12. Once your drawing is repositioned, select the drawing into which you want to trace.

13. Select the drawing tool of your choice.
14. In the Drawing view, trace your drawing.

15. If you want to select another drawing and reposition it, you can hold down [Ctrl] (Windows/Linux) or [⌘ ]
(Mac OS X) and click on the Shift and Trace Registration marks (Peg holes).

16. If necessary, click on the Shift and Trace Reset

button to reset the position of the modified drawing.

17. Right-click in the drawing list column and select Remove All Drawings to close the drawing list.
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‣
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To remove one, or several, drawings from your selection without clearing the entire list, select the
drawings you want to remove using [Ctrl] (Windows/Linux) or [⌘ ] (Mac OS X), right-click in the
drawing list column and select Remove Selected Drawing.

Related Topics
•

Shift and Trace Linked Drawings below

•

Enabling and Disabling Individual Drawing Shift and Trace Onion Skin on page 324

Shift and Trace Linked Drawings
When using the Shift and Trace feature, you can link different drawings from the Drawing List so that they move
together when dragging or scaling. These drawings can be from different columns in the Xsheet view. Bars in
differing colours will appear beside the chain link icon to easily identify different linked groups.
To link your Shift and Trace Drawings:
1. In the Drawing view's Thumbnail area, display the drawings you want to use to perform your Shift and
Trace operation.
2. In the Thumbnail area, hold down [Ctrl] (Windows/Linux) or [⌘ ] (Mac OS X) and select the drawings your
want to link together.
3. In the Thumbnail area's toolbar, click on the Link Drawings button to link your selection.

A coloured bar and a link icon appear beside the linked drawings.
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4. Enabling the Shift and Trace feature, move your linked drawings.

5. If you want to unlink your drawings, in the Thumbnails area, select one of the linked drawings and click on
the Unlink Drawing button.

6. You can now move your drawings independently.
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Related Topics
•

Shift and Trace on page 315

Enabling and Disabling Individual Drawing Shift and Trace Onion
Skin
It is possible that you would end up with a lot of drawings in your onion skin display while working with the Shift
and Trace feature. You can disable individual drawings from the Onion Skin display without deactivating them.
To enable and disable individual drawing shift and trace onion skin display:
1. In the Tools toolbar, enable the Onion Skin

feature.

2. In the Drawing view’s Shift and Trace panel, click on the drawing’s onion skin icon to enable or disable it.

Related Topics
•

Shift and Trace on page 315
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More Drawing Layers

Toon Boom Harmony has four layers included in its drawings:
•

Overlay below

•

Line Art on the next page

•

Colour Art on page 327

•

Underlay on page 327
Each layer can be used for a traditional animation task, this helps to organize your work and make
things easier.

To switch between the drawing layers:
1. In the Camera or Drawing view bottom toolbar, click on either the Overlay
Line Art

, Colour Art

2. Click on the Preview

or Underlay

buttons.

button to display all the layers together. Select Overlay and Underlay in the

Preview button’s drop-down menu, to display all four layers.

Overlay
The Overlay layer can be used for a lot of different things:
•

,

Highlights and Tones
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•

Annotations and Corrections

•

Sketching
You can also simply draw in the Overlay layer, it is a regular layer.

Line Art
In traditional animation, you mainly use the Line Art layer to trace and clean up your animation. The outline is
drawn in the Line Art layer and you paint in the Colour Art layer.
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Colour Art
In traditional animation, you use the Colour Art layer to paint your animation. The outline is drawn in the Line Art
layer and you paint in the Colour Art layer. You need to generate invisible lines out of your Line Art to be able to
do so.

Underlay

The Underlay layer can be used for several things but mainly for sketching your rough animation or generating a
matte colour when doing line testing. See Generating a Matte for Your Animation below.

Related Topics
•

Line Art and Colour Art Layers on page 388

•

Generating a Matte for Your Animation below

Generating a Matte for Your Animation

When you are doing rough animation, you may want to send a clip to somebody for feedback or approval before
carrying on with your work. If you have several characters in your project that are overlapping, it may be difficult
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to understand what is going on as you can see though the characters. Toon Boom Harmony can generate a
matte automatically in the Underlay, or even in the Colour Art layer, and fill all the zones inside your characters
making them opaque. This process is fast and easy and allows you to send easy to understand movies.
To generate a matte:
1. In the Tools toolbar, select the Select

tool or press [Alt] + [S].

2. In the Camera or Drawing view, select the drawing you want to create a matte for.

You will also be able to apply the operation to all the drawings in the layer at the same time.

3. In the top menu, select Drawing > Generate Auto-Matte. You can also select the option in the Camera
or Drawing view menu under Drawing > Generate Auto-Matte.
The Auto-Matte dialog box opens.

4. If you want to create a matte for all the drawings included in your layer, enable the Apply to All Drawings
option.
5. Depending on how precise or rough your line is, you will need to increase or decrease the radius value.
The lower the value is, the closer to your lines’ contours the matte will be shaped and the higher the value
is, the looser the matte will be shaped.

6. In the Source Art drop-down menu, select the layer (Line Art, Colour Art, Underlay or Overlay) you want
the matte to be created from.
7. In the Destination Art drop-down menu, select the layer (Line Art, Colour Art, Underlay or Overlay) you
want the matte to be created on.
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8. If you already have artwork on the destination layer and you want the content to be deleted before the
matte is added into it, enable the Clear Destination Art First option.
9. If you want the contour of your lines to be also copied as invisible lines in your matte drawing in case you
ever need to keep them for later, enable the Copy Stroke in Destination option.
10. Click on the OK button to validate the operation.

Related Topics
•

More Drawing Layers on page 325

Multiple Drawings in the Drawing View
If you only want to work on a portion of an animation sequence or many drawings from different layers, you can.
To do this, select the segment needed in one or more layers in the Xsheet or Timeline view and then, use the
Send to Drawing View and Add Drawings to Drawing View options to send the selection to the Drawing view
and allow you to work only on these drawings.
To send several drawings to the Drawing View:
1. In the Xsheet or Timeline view, select a consecutive cell range from one or several layers. In the Xsheet
view, using [Ctrl] (Windows/Linux) or [⌘ ] (Mac OS X), you can click on any cell to add it on the selection,
even if it is not consecutive.

2. In the Timeline View or Xsheet View menu, select Drawings > Send to Drawing View. In the Xsheet view,
you can also hold down the [Alt] key and click on the selection.
The drawings appear at the side of the Drawing view.
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3. If the Drawing view side panel is hidden, click on the Arrow button, located to the right side of the view.

4. If you want to add some extra drawings to the Drawing view without having to start over, in the Xsheet
view, select the desired drawings to be added.
5. In the Xsheet View menu, select Drawings > Add Drawings to Drawing View or press [Alt] + click.
6. If you want to send a new drawing selection to the Drawing view and remove the current one, select a new
range of drawings in the Timeline or Xsheet view.
7. In the Timeline View or Xsheet View menu, select Drawings > Send to Drawing View.
8. To change the size of the thumbnails displayed in the side panel, right-click in the side panel and select No
Thumbnail, Small Thumbnail, Medium Thumbnail or Large Thumbnail.
9. To empty the drawing list accumulated in the Drawing view, right-click in the side panel and select
Remove Selected Drawings or Remove All Drawings.

Related Topics
•

Advanced Traditional Animation on page 311

Preview Selected Drawings
To check your animation ink and paint, to verify that there are no colour mistakes or to see your animation in real
time, you can scroll through your drawings or press [F] and [G]. You may also use the Preview option available in
the Xsheet view.
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To preview drawings from the Xsheet view:
1. Save your scene. In the top menu select File > Save or click on the Save

button or press [Ctrl] + [S]

(Windows/Linux) or [⌘ ] + [S] (Mac OS X).
2. In the Xsheet view, select the range of drawings or the whole column to preview.
3. In the Xsheet View menu, select View > Preview Selected Drawings.
The Toon Boom Play opens.
4. In the Play window, press the Play

button to play back your drawings.

5. Enable the Preroll option to see blank frames at the beginning and at the end of the animation sequence
while looping the playback.

Related Topics
•

Advanced Traditional Animation on page 311
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Cleaning Scanned Drawings

As paper drawings are passed through a scanner they may pick up dirt, hairs or dust. These foreign bodies
register as part of the drawing and will appear as unwanted marks on the scanned drawing. These marks need
to be cleaned. Toon Boom Harmony provides different features to remove them quickly.
Each of the removal features are described in the following sections:
•

Remove Dirt below

•

Remove Art Outside Selection on the facing page

•

Remove Art Inside Selection on page 334

•

Remove Hair on page 335

Remove Dirt

The Remove Dirt tool selects small dots and hairs on the drawing. Increasing the Remove Dirt level selects larger
dots for removal, but be careful not to lose small details like pupils and nostrils. Once the removal level is
chosen, you can apply it to either the current drawing or to the whole animation sequence.
This is a fast way to get rid of most dirt and dust.
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To use the Remove Dirt tool:
1. In the Timeline or Xsheet view, select the drawing to clean.
2. In the top menu, select Drawing > Clean Up > Remove Dirt or press [Shift] + [D].
In Harmony Paint, select Drawing > Remove Dirt.
The Remove Dirt dialog box opens.

3. Increase the Remove Dirt value by moving the slider to the right. As you increase the tolerance, larger
speckles will become highlighted to indicate that they have been included in the selection.
4. Enable the Apply to All Drawings option if you want to apply the operation to all the drawings in the
layer.
5. Click on the OK button.

Remove Art Outside Selection

The Remove Art Outside Selection option is used to delete any art existing outside a selection. If you have an
accumulation in your Colour Art, it can result in large output files, especially if you work in high definition
resolution. Simultaneously apply this operation to all of your drawings in the layer by using the Remove Art
Outside Selection On All Drawings command.
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To clean dirt with the Remove Art Outside Selection:
1. In the Tools toolbar, select the Select

tool or press [Alt] + [S].

2. If you want to apply the action to your entire animation, enable the Permanent Selection

option in

the Tool Properties view.
3. In the Camera or Drawing view, draw a selection around the animation. (Make the area large enough to
include the whole animation sequence).
4. In the top menu, select Drawing > Clean up > Remove Art Outside Selection option to delete artwork
outside your selection on one single drawing.
In Harmony Paint, select Selected > Remove Art Outside Selection.
‣

To apply the action to all the drawings contained in the layer, select the Drawing > Clean up >
Remove Art Outside Selection on All Drawings option from the top menu.
In Harmony Paint, select Selected > Remove Art Outside Selection On All Drawings.

Remove Art Inside Selection

The Remove Art Inside Selection option is used to delete any art inside a selection.
We recommend that you clean your Colour Art level as well. If you have an accumulation of strokes (almost
invisible, accidental or leftover marks) in your Colour Art, it can result in large output files, especially if you work
in high definition resolutions.
You can simultaneously apply this operation to all of your drawings in the layer by using the Remove Art Inside
Selection On All Drawings command.
To clean dirt with Remove Art Inside Selection:
1. In the Tools toolbar, select the Select

tool or press [Alt] + [S].

2. If you want to apply the action to your entire animation, in the Tool Properties view, enable the
Permanent Selection
option in the Tool Properties view.
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3. In the Camera or Drawing view, draw a selection around the animation. (Make sure to make the area
large enough to include all the zones to be cleaned up on all drawings).
4. In the top menu, select Drawing > Clean up > Remove Art Inside Selection option to delete artwork
inside your selection on one single drawing.
In Harmony Paint, select Selected > Remove Art Inside Selection.
‣

To apply the action on all your drawings contained in the layer, in the top menu, select Drawing >
Clean up > Remove Art Inside Selection on All Drawings option to delete artwork inside your
selection on all the drawings.
In Harmony Paint, select Selected > Remove Art Inside Selection on All Drawings.

Remove Hair

The Remove Hair command is used to remove any small strokes created in the Colour Art from very thick lines or
filled zones.
Increasing the Remove Hair level value will select larger strokes for removal from the drawing. You can also
select the Apply to All Drawings option to remove them on all drawings.
To use the Remove Hair tool:
1. In the Timeline or Xsheet view, select the drawing containing the drawing to clean.
2. In the top menu, select View > Show > Show Strokes to display the invisible lines or press [K].
3. In the top menu, select Drawing > Clean Up > Remove Hair.
In Harmony Paint, select Drawing > Remove Hair.
The Remove Hair dialog box opens.

4. Move the Hair Selection slider to the right to increase the number and length of hairs to be selected.
5. Enable the Apply to All Drawings option if you want to apply the operation to all the drawings in the
layer.
6. Click on the OK button.

Related Topics
•

Scanning Images on page 594

335

Chapter 5: Traditional Animation

Traditional Animation Preferences

Traditional Animation Preferences
When animating traditionally in Toon Boom Harmony, there are preferences you can set to help you work more
efficiently.
To open the Preferences panel:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

Or press [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).

Related Topics
•

General > Edit Colours below

•

Exposure Sheet on the facing page

General > Edit Colours
You can change the colours for the Onion Skin for Other Elements option.

Edit Colours for Onion Skin in Other Elements
To change the onion skin display colour:
1. In the Preferences panel, go to the General tab.
2. In the General tab, click on the Edit Colours button.
3. In the Edit Colours window, go to the Drawing tab.
4. In the Drawing tab, in the Onion Skin section, click on the colour swatch of the onion skin display you want
to change.
5. In the Colour Picker window, select the colour.
6. Click OK to confirm the colour.
7. Click OK to confirm and close the Edit Colours window.
8. Click OK to confirm the changes and close the Preferences panel.
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Refer to Enabling the Onion Skin in Other Layers on page 314 to learn more about the Onion Skin
for other Layers option.

Related Topics
•

Exposure Sheet below

Exposure Sheet

Current Frame as Drawing Name
The Current Frame as Drawing Name option can be enabled in the Preferences panel, under the Exposure Sheet
tab. Use this preference to automatically name the drawing corresponding to the frame position, this avoids
numbering conflicts while animating.

For example, using the default preferences, you start with the first drawing on frame 1, this drawing is called 1.
You then draw the extreme position drawing on frame 10, this drawing is called 2. Next, the in-between pose is
drawn on frame 5, this drawing is called 3 and so on.
At the end, you have a sequence like this: 1-9-4-6-3-8-5-7-10-2.

Instead, using the Use Current Frame as Drawing Name preference, each drawing is automatically named by its
frame number and the sequence looks like: 1-2-3-4-5-6-7-8-9-10.

Related Topics
•

General > Edit Colours on the previous page
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Chapter 6: Colour

With Toon Boom Harmony, you can add colour to your projects and even create sets of colours for your
characters. With Toon Boom Harmony’s colour palette concept, painting and colour styling has never been
easier!

Topics Covered
•

How to Paint on the next page

•

Colours on page 342

•

Colour Display Modes on page 353

•

Selecting the Current Colour of a Tool on page 355

•

Painting Using the Paint Tool on page 357

•

Painting Pencil Lines with the Ink Tool on page 366

•

Selecting a Colour in a Drawing on page 374

•

Editing Gradients and Textures on page 376

•

Closing Gaps Manually on page 382

•

Protecting Colours on page 385

•

Highlighting the Selected Colour on page 386

•

Line Art and Colour Art Layers on page 388

•

Verifying Zones are Painted on page 393

•

Palettes on page 394

•

Colour Model on page 423

•

Colour Preferences on page 428
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How to Paint
Learn how to paint your drawings by following these instructions.
To paint your drawings:
1. In the Tools toolbar, select the Paint

tool or press [Alt] + [I].

2. In the Colour view, select a colour from the palette.
‣

Double-click on a colour swatch to open the Colour Picker window and modify the colour.

The colour palette will only appear in the Colour view once a drawing element has been selected.

3. In the Camera or Drawing view, start painting the colours on your drawing.
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Related Topics
•

Colours on the next page

•

Colour View on page 122
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Colours
Toon Boom Harmony has some very powerful colouring features when it comes to painting. To paint your
drawings you will use different colour swatches, unlike some paint programs where you modify one swatch each
time you want to paint with a different colour.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You
can add as many swatches as you want. You can also rename them and modify existing ones.

When you modify the colour of an existing swatch it automatically updates all the zones painted with this swatch
throughout the entire project. The colour swatch has a unique ID number that associates it with the painted
zones. This way, you can change the look of your character at anytime without having to repaint it!

Related Topics
•

Adding a Colour Swatch on page 344

•

Deleting a Colour Swatch on page 351
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Palette Lists and Palettes Lock
Edit Palette List Mode
Every drawing element has a palette list. The scene also has a palette list. A palette list is a file containing all of
the links to the original palette files. For example, a drawing element can use three different palettes stored in
three different locations, while another drawing element can use two of these palettes plus another one coming
from another scene. The palette list keep tracks of the location of the palettes.
To prevent users accidentally removing a link to a palette, the palette lists are locked. To add a new link to a
palette, the user must first unlock the palette list.
To enable and disable the Edit Palette List Mode:
1. Select Edit > Edit Drawing Mode or Edit Palette List Mode. When the option is enabled, a check mark
appears beside it.
When in Edit Palette Lists Mode, a grey pencil appears on the top corner of the Colour view palette list
to indicate that it can be modified.

Before you can add, remove or modify colours from a palette, you need to have the right to edit palettes.

Edit Palette Mode
A colour palette is an actual file that can be found on the hard drive. These palette files can be stored in a
different location on the server machine. They can be stored in the Environment, Job, Scene or Element folder
and linked to any palette list. This means that if the original palette file is modified, it will update in every drawing
element the palette is linked to. To avoid accidentally modifying the palette, the palette files can be locked. The
user must get the rights to modify them.
To enable and disable the Edit Palette Mode:
1. In the Colour view, click on the Edit Palette Mode button.
When pushed in, the mode is enabled, a grey pencil icon appears in the top corner

When pushed out, the mode is disabled.
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Related Topics
•

Connecting to the Database on page 57

•

Global Lock on page 60

•

Locking Drawings on page 83

Adding a Colour Swatch
You can use three different types of colour swatches, these are described in the following sections:
•

Solid Colour Swatch below

•

Default Colour Swatch on page 347

•

Gradient Colour Swatch on page 348

•

Bitmap Texture Swatch on page 349

Solid Colour Swatch

To add or modify a solid colour swatch:
1. In the Colour view, click on the New Colour

button.

2. In the Colour View menu, select Colours > Edit. You can also double-click on the colour pot.
The Colour Picker window opens.
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3. To set your colour:
‣

In the colour wheel, select the desired colour.

OR
‣

Type in the HSV or RGB values in the corresponding fields. Click on the R,G,B,H,S or V radio buttons
to change the look of the colour picking area.

OR
‣

Click on the Dropper
button to select any colour on your screen. It can be from the Toon Boom
Harmony’s interface, your Operating System or any other open application.
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You can also click on the Multi Wheel Mode button to open the Multiwheel Colour dialog box. This
displays all the picking area styles together and also contains a picking undo list. Click on the Single
Wheel Mode button to go back to the regular Colour Picker window.

4. If needed, click on the Shade Scale’s swatches to modify the shade of the selected colour.

5. If necessary, adjust the desired level of transparency with the Alpha slider, or type the value directly in the
Alpha field.

6. If necessary, click on the Add button to add the current selected colour to the Colour Storage Library, so
you can quickly access it later.

7. You can rename the colour swatch in the Colour Picker window or directly in the colour list by doubleclicking on its name.
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Default Colour Swatch
In Toon Boom Harmony, when you click on the Add Colour

button, a new colour swatch is created using the

colour of the currently selected swatch from your palette. However, you can set a Default colour to be used
every time you create a new colour in your colour palette. This might be useful if you want to create different
shades of the same basic colour.
To change the default swatch colour for all your colour palettes:
1. In the top menu, go to Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X).
2. In the Preferences panel, under the Drawing tab, enable the Create New Colour Pot Using the Default
Colour option. In addition, You can click on the colour swatch, located just beside, to change the Default
colour.
The default colour is also the colour used when you choose to vectorize images that you are scanning into your
scene, however you add the Default colour swatch to your palette in a different way, so that it is unique. It has a
unique ID number that makes it recognizable from all the other colours in your colour palettes. Being able to
change this colour allows you to change the basic colour of all scanned drawings. This can be useful on more than
just an aesthetic level as sometimes when you go to NTSC or PAL, pure colours, such as pure black, can create
problems.

To add a new colour swatch using the default colour:
1. In the Colour View menu, select Colours > New.
A new swatch will be added to your palette using the default colour pot colour. The new swatch created
with the New command will be named New 0.

Refer to Colour Preferences on page 428 to learn more on the Create New Colour Pot Using The
Default Colour preference and how to customize the default colour pot colour.
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Gradient Colour Swatch

To create a gradient colour swatch:
1. In the Colour view, select the colour to be modified.

2. In the Colour View menu, select Colours > Edit. You can also double-click on the colour pot.
The Colour Picker window opens.

3. Enable the Gradient option.

4. Select the Linear or Radial option.
5. Select the Gradient arrows to modify the colours.
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‣

Click between the arrows to add extra colours.

‣

Pull down the arrows to remove them.

‣

Move the arrows left and right to modify the gradient distance.

Refer to the Editing Gradients and Textures on page 376 topic to learn how to reposition your
gradient zones in your drawings.

Bitmap Texture Swatch
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To create a texture colour:
1. In the Colour View menu, select Colours > New Texture or click on the New Texture

button.

The Browser window opens.
2. Browse for a PSD or TGA bitmap file created in a third party software.

3. Click on the Open button to create the colour swatch.

Refer to the Editing Gradients and Textures on page 376 topic to learn how to reposition your
textured zones in your drawings.

You can also replace a texture once it is painted. If you decide to make the character’s shirt wool instead of
plaid, just update the texture file in the swatch and the entire project updates. Any transformation previously
applied to the texture’s position in your drawings will be kept.

To replace a texture swatch:
1. In the Colour view, select the texture swatch you want to change the embedded bitmap texture file in.
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2. In the Colour View menu, select Colours > Edit Texture. You can also double-click on the swatch.
The Browser window opens.
3. Browse for the new PSD or TGA bitmap file created in a third party software.

4. Click on the Open button to update the colour swatch.

Related Topics
•

How to Paint on page 340

•

Deleting a Colour Swatch below

Deleting a Colour Swatch
To delete a colour swatch:
1. In the Colour view, select the colour swatches to delete.
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2. In the Colour View menu, select Colours > Delete. You can also click on the Delete Colour

button.

The default keyboard shortcut is [Delete].
If the colour swatch is used in a drawing, the Delete Colour dialog box opens.

3. Click OK to delete the colours or click Cancel to abort the operation.
‣

If you delete colour swatches already in use, the zones painted with them turn red so you can easily
identify them.

Related Topics
•

Adding a Colour Swatch on page 344
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Colour Display Modes
This section describes the colour modes.
•

Switching Between Thumbnails and List Display modes below

•

Displaying Colour Values below

Switching Between Thumbnails and List Display
modes
The Colour view has two display modes:
•

List Mode

•

Swatch Mode

To toggle between the display modes:
1. In the Colour View menu, select Colours > Swatch Mode.
‣

Enable the option to display the swatches.

‣

Disable the option to display the colour list.

Displaying Colour Values
When using Toon Boom Harmony, you can display the RGB values and names of your solid colour swatches.

This option is not available when displaying the colours in Swatch mode.

353

Chapter 6: Colour Displaying Colour Values

To display the swatch colour values:

‣ In the Colour View menu, select Palettes > Display Colour Values.
The solid colour swatches’ RGB values will be displayed between the colour swatch and its name. The
gradient colour swatches will be identified as (gradient).

Related Topics
•

Colour View on page 122
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Selecting the Current Colour of a Tool

While drawing and painting, you can let Harmony retain the last colour you selected for each one of the following
tools:
•

Brush

•

Paint

•

Pencil, Ellipse, Line, Rectangle, Polyline

The Colour view has three swatches where you can set a colour for the Brush

, Paint

and Pencil

tools.
To unlink the storage swatches:
1. In the Colour view, if the storage swatches are linked, click on the Linking

s
2. Click on the Brush

storage swatch.

3. In the Colour list, select the desired colour.
4. Click on the Pencil

storage swatch.

5. In the Colour list, select the desired colour.
6. Click on the Paint

storage swatch.
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7. In the Colour list, select the desired colour.

If you prefer not to use this behaviour and have Toon Boom Harmony use the same colour swatches regardless
of the selected tool, you can link the three swatches together.
To link the storage swatches:
1. In the Tools toolbar, select one of the following tool:
‣

Brush tool

‣

Paint tool

‣

Pencil tools:
•

Pencil tool

•

Polyline tool

•

Line tool

•

Ellipse tool

•

Rectangle tool

2. In the Colour view, if the storage swatches are linked, click on the Linking

button to link them.

Each time you select a new colour for your current tool, all the storage swatches are updated.

Related Topics
•

How to Paint on page 340
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Painting Using the Paint Tool

The main tool you will use to paint your drawings with is the Paint

tool. The Paint tool can be used in several

different modes, these can be customized in the Tool Properties view.
The Paint tool paints closed zones, this includes brush strokes, as well as pencil lines. If you have gaps in the lines
defining a zone, you will have to close them using either the Brush, Pencil, Close Gap tools or the Automatic
Close Gap option.
To paint with the Paint tool:
1. In the Timeline or Xsheet view, select the cell where you want to paint.

2. In the Tools toolbar, click on the Paint

tool or press [Alt] + [I]. You can also select the Paint tool in the

top menu under Drawing > Tools > Paint.
3. In the Colour view, select a colour.

4. In the Camera view, start painting. You can click on a zone or pencil line to paint it, or you can trace a lasso
or marquee selection to paint several zones or pencil lines at once.

The last colour you select while using the Paint tool will be remembered the next time you select the
Paint tool.
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Related Topics
•

Paint Tool Properties on the facing page

Create Breaking Triangles to Paint Brush Strokes
Not available in Harmony Paint.
The Brush tool is often the most intuitive and rapid tool for creating rough sketches and clean lines. A single
colour, such as black, is often used when tracing a clean version of a rough sketch. However, when it comes time
to soft trace the lines in different colours, the flattened or unflattened clean brush strokes can suddenly become
time consuming to ink.
Toon Boom Harmony provides a solution by creating triangular breaks at natural line intersections. These
intersections are the probable locations of where colour line breaks may occur, such as where a sleeve meets a
hand.
To create breaking triangles on a drawing:
1. In the Camera or Drawing view, use the Select tool to select part or all of the drawing to be broken.

2. In the top menu, select Drawing > Create Breaking Triangles. If your brush strokes are not flattened,
they will be flattened automatically before the breaking occurs.

3. Use the Repaint tool

to paint the outline of different colour zones with different colours.
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Paint Tool Properties
When you select the Paint tool, its properties and options appears in the Tools Properties view.

•

Lasso and Marquee below

•

Painting Mode on the next page

•

Automatic Close Gap on page 361

•

Paint and Remove Texture on page 362

•

Apply to Multiple Drawings on page 363

•

Apply to All Visible Drawings on page 363

•

Respect Protected Colour on page 364

•

Use Stored Colour Gradient on page 364

•

Select Newly Painted/Repainted/Unpainted Contours/Lines on page 365

Lasso and Marquee
The Lasso and Marquee options let you choose what type of selection the Paint tool will do when you will click
and drag your cursor to paint your drawings. The default selection mode is Marquee.
•

The Marquee

option makes a rectangle selection box. Everything inside the selection will be painted

according to the painting mode you selected.
•

The Lasso

option lets you draw a custom selection box around the zones to be painted. Everything

inside the selection will be painted according to the painting mode you selected.
Hold down the [Alt] key to switch to the opposite mode of your selection.
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Painting Mode
The Paint tool has four different modes available:

Paint Mode
Paint Unpainted Mode
Repaint Mode
Unpaint Mode
You can also find these tools directly in the Tools toolbar and in the Drawing Tools menu.

Paint Mode

The Paint

mode paints everything it touches, including empty and filled zones.

Paint Unpainted Mode

The Paint Unpainted

mode paints only empty zones. Any line or filled zone will remain unchanged.
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Repaint Mode

The Repaint

mode paints everything it touches except empty zones. Any zone that is not painted will remain

intact.

Unpaint Mode

The Unpaint

mode unpaints everything it touches, including empty and filled zones.

Automatic Close Gap
The Automatic Close Gap option has four modes available:

The Automatic Close Gap

option is used while painting drawings with small gaps. Instead of having to close

them manually either with the Brush tool or Close Gap tool, Toon Boom Harmony will analyze the drawing and
close the gaps while you paint according to the selected mode.
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The automated gap closing should be done using the zoom function setting of your Camera or Drawing view. If
your eye does not see the gap, Toon Boom Harmony won’t either.

Paint and Remove Texture

The Paint and Remove Texture

option is used when you vectorized some images as greyscale texture style.

An image vectorized as texture is a mix of bitmap filling encapsulated in a vector based frame. Painting a
textured zones with the Paint tool will change the tint of the textured lines. Painting the textured zones using the
Paint and Remove Texture option transforms the bitmap filling into a 100% vector based zone and fills it with a
solid colour.
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Apply to Multiple Drawings

The Apply to Multiple Drawings

option is used for hand-drawn animation fast painting. When you want to

paint several drawings in a same layer at once, such as a walk cycle, you can enable this option and make a
selection in your Camera or Drawing view. All the closed zones located within your Paint tool selection are
painted with the selected colour swatch.
You do not need to enable the Onion Skin preview to use this option. The option will stay enabled only for the
next action. If you want to use it again, you must click on the Apply to Multiple Drawings button again, or press
[Alt] + [A].

Apply to All Visible Drawings

The Apply to All Visible Drawings

option is used to paint several drawings on separated layers on the

current frames. If you have a character broken in several layers, you can enable this option to paint all your layers
at once. The operation is only applied on the current frame.
The option will stay enabled only for the next action. If you want to use it again, you must click on the Apply to
All Visible Drawings button again.
This option is only available in the Camera view and does not affect symbols.
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Respect Protected Colour
The Respect Protected Colour

option is enabled by default. In your Colour view, you can protect some

colour swatches to avoid repainting or unpainting the zones linked to that swatch.
If you disable this option the Paint tool will not follow the protect colour rule and will repaint or unpaint the
protected colours on your drawings until you enable the option again.

Refer to the Protecting Colours on page 385 topic to learn how to lock your colours.

Use Stored Colour Gradient

When you paint a zone with a gradient or textured colour swatch, the gradient or texture’s position is set
relative to the size of the zone your are painting. If you want the Paint tool to use a particular size and position,
you must first store your desired position and size using the Select
tool and then enable the Use Stored
Colour Gradient

option in the Paint tool Tool Properties view.

Refer to the Storing Your Favourite Gradient or Texture Settings on page 380 topics to learn how to
store your gradient or texture position.
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Select Newly Painted/Repainted/Unpainted Contours/Lines

In the Paint

tool Tool Properties view, engaging this option will keep a selection highlighted around the

latest painted zone after using either the Paint, Repaint, Unpaint, or Paint Unpainted tool.

Related Topics
•

Painting Using the Paint Tool on page 357
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Painting Pencil Lines with the Ink Tool
Although pencil lines can be painted in much the same way as closed zones, you can use the Paint, Repaint,
Repaint Brush, and Ink tools to make painting segmented lines easier.
Normally when you have a drawing, such as the one below, and you use the Paint tool to paint one of the lines,
the entire line is painted.

However, if you select the Ink

tool instead and click on the same pencil line, only the segment that you

clicked on between two intersections will be painted.

The newly inked segment will always be moved to the front of all other pencil strokes, even if it was behind all
other pencil strokes before it was inked.

That is, unless you hold down [Alt] while clicking a segment. Then the opposite becomes true. The inked segment
will be sent to the back, even if it was in front of all other segments to begin with.
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Painting and Inking can be used in combination depending on what it is that you need to paint. If you need to ink
a character’s outline in black, it might be easier to use the Paint tool. If you need to paint the outline of a
character’s neck with a tan colour and its shirt outline blue and both the neck and shirt belong to the same
continuous outline, then the Ink tool might prove more useful.

Related Topics
•

Ink Tool Properties below

Ink Tool Properties
When you select the Ink tool, its properties and options appears in the Tools Properties view.

•

Lasso and Marquee below

•

Show Inkable Lines on the next page

•

Be Smart on Connecting Lines on the next page

•

Select Mode on the next page

•

Arrange Ink Lines on the next page

•

Mitre on the next page

•

Tip Style on the next page

Lasso and Marquee
The Lasso and Marquee options let you choose what type of selection the Paint tool will do when you will click
and drag your cursor to paint your drawings. The default selection mode is Marquee.
•

The Marquee

option makes a rectangle selection box. Everything inside the selection will be painted

according to the painting mode you selected.
•

The Lasso

option lets you draw a custom selection box around the zones to be painted. Everything

inside the selection will be painted according to the painting mode you selected.

367

Chapter 6: Colour Painting Pencil Lines with the Ink Tool

Hold down the [Alt] key to switch to the opposite mode of your selection.

Show Inkable Lines
The Show Inkable Lines

option highlights all pencil lines (so no brush strokes) on the selected layer. Pencil

line segments that are already inked with the selected swatch colour from the colour palette are also not
highlighted.

Be Smart on Connecting Lines
With this

option selected, as you hover and move the cursor across intersecting pencil lines, the path that

you create will get highlighted. When you click on your mouse or stylus the highlighted segments will get inked.
With this option disabled, all the intersecting segments that your cursor comes near will get highlighted and
become part of the selection, even if they were not situated in the direction of the chosen path.
This option only works if the Ink tool is in Hover Mode and not Select Mode.

Select Mode
Use this

mode instead of the Hover Mode. In the Hover Mode, any potentially inkable pencil line will have

its central vector line highlighted as the Ink tool’s cursor hovers over it. Use [Ctrl] (Windows/Linux) or [⌘ ] (Mac
OS X) to toggle between the two modes.

Arrange Ink Lines
Use this

option to have every newly inked line be brought to the front. Disable this option to have every

newly inked line be sent to the back. Use [Alt] to toggle between the two options.

Mitre
As you hover over two perpendicular or nearly perpendicular segments a highlighted path with a corner is
created. Clicking on these highlighted segments inks both segments and makes them appear as a single stroke
with a corner or bend.
Click on the Mitre

button to reveal four options from its drop down menu. Select either Round, Mitre,

Bevel or As Is before creating corner selections to make a bend in the path either round, sharp, bevelled or
gapped.

Tip Style

Use the Tip Style option to customize the edge of the Ink tool.
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Related Topics
•

Painting Pencil Lines with the Ink Tool on page 366

Advanced Painting Features

The following advanced painting features are available in Toon Boom Harmony and are described in this section:
•

Repaint Selection on the next page

•

Repaint Selection On All Drawings on the next page

•

Repaint Outside Selection on page 371

•

Repaint Outside Selection On All Drawings on page 371

•

Unpaint Selection on page 372

•

Unpaint Selection On All Drawings on page 372

•

Unpaint Outside Selection on page 373

•

Unpaint Outside Selection On All Drawings on page 373
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Repaint Selection

The Repaint Selection command is used to repaint any art inside a selection. You must first draw a selection
using the Select
tool in order for this command to be available.
To use the Repaint Selection command:
‣

Select Drawing > Paint > Repaint Selection.

Repaint Selection On All Drawings

The Repaint Selection On All Drawings command is used to repaint any art inside a selection on all the drawings
contained within the same layer. You must enable the Permanent Selection
option in the Select tool Tool
Properties view and then draw a selection in your drawing using the Select

tool in order for this command to

be available. The Permanent Selection option is used to maintain the same selection throughout the drawings of
a same layer.
To use the Repaint Selection On All Drawings command:
‣

Select Drawing > Paint > Repaint Selection On All Drawings.
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Repaint Outside Selection

The Repaint Outside Selection command is used to repaint any art outside a selection. If no selection has been
drawn using the Select
tool, the entire drawing will be repainted.
To use the Repaint Outside Selection command:
‣

Select Drawing > Paint > Repaint Outside Selection.

Repaint Outside Selection On All Drawings

The Repaint Outside Selection On All Drawings command is used to repaint any art outside a selection on all the
drawings contained within the same layer. You must enable the Permanent Selection
option in the Select
tool Tool Properties view and then draw a selection in your drawing using the Select

tool in order for this

command to be available. The Permanent Selection option is used to maintain the same selection throughout the
drawings of a same layer.
To use the Repaint Outside Selection on All Drawings command:
‣

Select Drawing > Paint > Repaint Outside Selection on All Drawings.
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Unpaint Selection

The Unpaint Selection command is used to unpaint any art existing inside a selection. You must first draw a
selection using the Select
tool in order for this command to be available.
To use the Unpaint Selection command:
‣

Select Drawing > Paint > Unpaint Selection.

Unpaint Selection On All Drawings

The Unpaint Selection on All Drawings command is used to unpaint all art contained inside a selection on all the
drawings within the same layer. You must enable the Permanent Selection
option in the Select tool Tool
Properties view and then draw a selection in your drawing using the Select

tool in order for this command to

be available. The Permanent Selection option is used to maintain the same selection throughout the drawings of
a same layer.
To use the Unpaint Selection On All Drawings command:
‣

Select Drawing > Paint > Unpaint Selection On All Drawings.
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Unpaint Outside Selection

The Unpaint Outside Selection command is used to unpaint any art existing outside a selection. If no selection
have been drawn using the Select
tool, the entire drawing will be unpainted.
To use the Unpaint Selection command:
‣

Select Drawing > Paint > Unpaint Outside Selection.

Unpaint Outside Selection On All Drawings

The Unpaint Outside Selection on All Drawings command is used to unpaint all art outside a selection on all the
drawings within the same layer. You must enable the Permanent Selection
option in the Select tool Tool
Properties view and then draw a selection in your drawing using the Select

tool in order for this command to

be available. The Permanent Selection option is used to maintain the same selection throughout the drawings of
a same layer.
To use the Unpaint Outside Selection On All Drawings command:
‣

Select Drawing > Paint > Unpaint Outside Selection On All Drawings.

Related Topics
•

Select Tool Properties on page 219
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Selecting a Colour in a Drawing

While working in your Camera or Drawing view, you can use the Dropper

tool to pick a colour from your

drawing without going to the Colour view.
To use the Dropper tool:
1. In the Tools toolbar, select the Dropper

tool or press [Alt] + [D]. You can also select the Dropper tool

from Drawing > Tools > Dropper in the top menu.
2. In the Camera or Drawing view, click on the desired colour.
‣

If you are using another drawing tool such as the Paint tool, you can temporarily hold down the [D] key
and click in your drawing before releasing the key to pick your colour. Once you let go the hot key,
Toon Boom Harmony will go back to your previous tool.

You may also want to select the zones painted with the colour currently selected in the Colour view. This can be
useful to remove rough lines from a clean drawing.
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To select the zones painted with the current colour:
1. In the Colour view, select the colour you want to select the corresponding zones from.

2. Select Drawing > Select Strokes with Current Colour.
Or press [Ctrl] + [Shift] + [A] (Windows/Linux) or [⌘ ] + [Shift] + [A] (Mac OS X).

Related Topics
•

How to Paint on page 340
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Editing Gradients and Textures

If you paint a zone or pencil line with a gradient or texture you can use the Edit Gradient/Texture

tool to

modify its position in the zone. You can move, scale, rotate and skew. If you have to match the transformations
performed on a gradient or texture from one zone or pencil line to many others, you can copy and paste the Edit
Gradient/Texture position. When moving to the next drawing, you can select the next texture and paste the
previous position to continue the modifications.
To use Edit Gradient/Texture tool on a zone:
1. In the Tools toolbar, select the Edit Gradient/Texture

tool. You can also select this tool from the top

menu under Drawing> Tools > Edit Gradient/Texture or press [Shift] + [F3].
2. Click on the Gradient or Texture zone to be modified.

‣

If you want to modify several areas at once, hold down the [Shift] key and click on the zones to be
modified.
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3. Move the edit texture’s anchor points to the desired result.
‣

If the same modification needs to be applied to another gradient in another drawing or texture zone,
you can select the modified zone and select Edit > Copy. Select the zone to be modified in the other
drawing and select Edit > Paste.

A pencil line can have its gradient, texture or texture’s gradient edited in two different ways, either with the
Pencil Editor
or with the Edit Gradient/Texture
tool.
To use Pencil Editor tool to edit the texture or gradient on a pencil line:
1. In the Tools toolbar, select the Pencil Editor

tool. You can also select this tool from the top menu

under Drawing > Tools > Pencil Editor or press [Alt] + [W].
2. Click on the pencil line to be modified to bring up its contour envelope.

3. Select one of the contour points around the envelope and move its position to change the size of the tiled
texture or gradient. You can also pull directly on the lines of the contour envelope or play with the bezier
handles of any given point in order to continue to modify the envelope form.
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Expanding the width of the envelope parallel to the pencil line’s central vector will cause the tiled texture
to be stretched. Conversely, reducing the envelope’s width will cause the tiled texture to look squashed.
Reducing the contour’s width perpendicular to the pencil line’s central vector will reduce the number of
tiles, while expanding it will increase the number of tiled images.

This editing technique does not just work on texture fills, but can also be applied to pencil lines drawn
with a textured “brush”.
To use Edit Gradient/Texture tool to edit the texture or gradient on a pencil line:
1. In the Tools toolbar, select the Edit Gradient/Texture

tool. You can also select this tool from the top

menu under Drawing > Tools > Edit Gradient/Texture or press [Shift] + [F3].
2. Click on the pencil line to be modified to bring up the editor controls.

3. The editor controls delineate a single tile in the texture. For gradients, this is less applicable. Pull on the
top of the editor controls to stretch the tiled texture throughout the length of the stroke.
As gradients are parallel to the stroke’s central vector, this will stretch the way that the gradient is
distributed in the pencil line’s envelope. The envelope still acts as a boundary for the texture or gradient.
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4. Drag the editor control perpendicular to the stroke. You will feel it glide along the strokes central vector
line. This is another way to resize the texture tile. Instead of stretching or shrinking it vertically, this
motion stretches or shrinks it vertically. As gradients are parallel to the pencil line’s central vector,
stretching them vertically gives no visual result.

This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawn with
textured “brushes”. If you then paint your textured pencil line with a gradient, you can do so and then edit both
elements independently at the same time.
To use Edit Gradient/Texture tool to edit both the texture and the gradient of a pencil line:
1. In the Tools toolbar, select the Edit Gradient/Texture

tool. You can also select this tool from the top

menu under Drawing > Tools > Edit Gradient/Texture or press [Shift] + [F3].
2. Click on the pencil line to be modified to bring up the editor controls.

3. Use the top editor controls edit the gradient.
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4. Use the bottom controls edit the “brush” texture.

Related Topics
•

Drawing Using the Pencil Tool on page 178

•

Storing Your Favourite Gradient or Texture Settings below

Storing Your Favourite Gradient or Texture Settings
If you are painting a hand-drawn animation or if your want the Brush tool and Paint tool to use your gradient’s
position, angle and scale settings instead of the default ones, you can store your own settings and reuse them
afterward.
To store your gradient and texture settings:
1. In the Tools toolbar, select the Select

tool or press [Alt] + [S].

2. In the Camera or Drawing view, select the gradient or texture zone to store.
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3. In the Tool Properties view, click on the Store Colour Gradient

button.

To use the stored gradient and texture settings:
1. In the Tools toolbar, select the Brush

or Paint

tool.

2. In the Tool Properties view enable the Use Stored Colour Gradient
3. In the Camera or Drawing view, draw and paint.

Related Topics
•

Editing Gradients and Textures on page 376
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Closing Gaps Manually

When painting, notice that some of your drawing areas are not closed. To close the zone, you can either draw
the missing line with the Brush or Pencil tool, or close the gap with an invisible line. To do this, you will use the
Close Gap tool.
The Close Gap tool is used to close small gaps in a drawing. The Paint tool only paints closed areas. The Close
Gap tool will create a small, invisible stroke between the two closest points to close the colour zone. You do not
need to trace directly over the gap. You can draw it a few millimeters away. The two closest points automtically
close up the gap.
To close gaps:
1. In the Tools toolbar, select the Close Gap

tool, select Drawing> Tools > Close Gap or press [Alt] +

[C].
‣

Enable the Auto-Flatten

option in the Tool Properties view if you want the stroke you will draw to

be flattened in your drawing instead to be on top.
‣

You can display the invisible lines with the Show Strokes option under View > Show Strokes or press
[K].

‣

If you do not display the strokes, a Message dialog box will appear.

Enabling the Don’t Show This Message Again option prevents this Message dialog box from appearing.
2. In the Camera or Drawing view, trace an invisible line near to the gap to be closed. The gap will
automatically close.
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Related Topics
•

Close Gaps below

•

How to Paint on page 340

Close Gaps
When you have too many gaps in your drawings, you can use the Close Gaps feature in Toon Boom Harmony

1. Close Gaps slider: Use this slider to determine the size of the gap you want to be closed. Move the slider
to the left for smaller gaps and move it to the right for bigger gaps.
2. Apply to all drawings: Enable this option so that the Close Gaps feature is applied to all the drawings of
the selected layer.
To use the Close Gaps feature:
1. Select the Show Strokes option to see a preview of the result.
2. Select View > Show Strokes or press [K].
3. Select Drawing > Clean Up > Close Gaps or press[Shift] + [F10] (Windows/Linux only).
The Close Gaps dialog box opens.
4. Adjust the slider.

5. Select the Apply to all drawings option if needed.
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6. Click OK.

Refer to Colour Preferences on page 428 at the end of this chapter to learn more about the Close
Gap options.

Related Topics
•

Closing Gaps Manually on page 382
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Protecting Colours
When you are finished painting some zones, you can protect the colour swatch they are associated with so the
work cannot be accidentally painted over.
To use Protect Colour:
1. In the Colour view, select the colour to be protected.

2. In the Colour view menu, select Colours > Protect Colour. You can also right-click on the selected colour
and select Protect Colour.
A red bar will appear on the side of the colour, notifying you that it is locked.

Related Topics
•

Respect Protected Colour on page 364
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Highlighting the Selected Colour
The Highlight Selected Colour option is used to identify colour pots used in a drawing. For example, if you have
unnamed colours in your palette and you want to find out if a particular colour pot was used on the current
model or drawing, you can select the colour pot and use the Highlight Selected Colour option. The system will
wash out all the colours in the drawing except the selected one so that it stands out and can be identified. You
can rename it accordingly.

To use the Highlight Selected Colour option:
1. In the Colour view, select the colour you want to highlight.
2. In the Drawing view or Camera view menu, select View > Show > Highlight Selected Colour.

Related Topics
•

Selecting a Colour in a Drawing on page 374
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Inverting a Colour Selection
When you need to select all colour swatches but one, or select only a few swatches here and there, it might be
faster to select the only colour you do not need, in order to select and invert the selection.
To invert a colour swatch selection in the Colour view:
1. In the Colour view, select the colour swatch you DO NOT want to have in your final selection.

2. In the top menu, select Edit > Invert Selection.

Related Topics
•

Colours on page 342
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Line Art and Colour Art Layers
Toon Boom Harmony has an option allowing you to paint the lines and the colour fills separately.
In Toon Boom Harmony, a drawing is composed of four embedded layers:
•

Overlay Layer

•

Line Art Layer

•

Colour Art Layer

•

Underlay Layer

In general, use the Line Art and Colour Art layers. The Underlay and Overlay layers are used for advanced
purposes.
Refer to the topic to learn more about these layers.
By default, you draw on the Line Art layer. The colour layer is always placed under the Line Art layer. These layers
are accessible in the Drawing or Camera view (using drawing tools). When you look at your final drawing in the
Timeline, Xsheet or Network view, you will not see four layers; instead you will see the final composition of the
lines and colours.

You can draw and paint in all layers, but if you prefer working in a single layer, you can do everything in Line Art.
The main advantage of using the Line Art and Colour Art option is so you can repaint the lines easily. If your
colour fills are separated from the lines, it allows you to use the repaint tool and paint the lines without affecting
the colour zones. Also, it allows you to paint tones and highlights in line art and then add some transparency to
see the Colour Art through it.

In order to paint in the Colour Art, you must first use the Create Colour Art from Line Art option to
create colour zones in the Colour Art. You need to use this option to paint drawings vectorized as
greyscale texture style.

To toggle between Line Art and Colour Art and enable the Preview mode:
1. In the Tools toolbar, select any drawing tool.
2. To toggle between Line Art and Colour Art:
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‣

In the Drawing view,right-click and select Switch to Colour Art/Switch to Line Art or s[L].

‣

In the Drawing or Camera bottom toolbar, click on the Colour Art

‣

In the Drawing or Camera bottom toolbar, click on the Line Art

button.
button.

3. To preview the Line Art and Colour Art at the same time:
‣

In the Drawing view,right-click and select Preview Line Art and Colour Art. While using the Preview
mode, you still edit one mode at a time or press [Shift] + [P].

‣

In the Drawing or Camera bottom toolbar, click on the Preview

button. To be able to see only

one of the layers at a time in the Camera view, you must enable the Current Drawing on Top option,
available from the Camera bottom toolbar drop-down menu. If this option is not enabled, you will see
the final composition of all four layers.

In order to edit both Line Art and Colour Art at the same time, you must enable the Apply to Line Art
and Colour Art button in the Tool Properties of the tools supporting the operation.

Underlay and Overlay Layers
In Toon Boom Harmony, you have two extra art layers available beside the Line Art and the Colour Art, the
Underlay and the Overlay layers. The Underlay is situated at the very bottom and the Overlay at the very top.

Underlay
The Underlay

layer can be used like any other of the art layers available in the drawing, but since it is situated

behind everything else, you can use it to create a matte for a quick line-test, write notes or store your rough
animation.

Overlay
The Overlay

layer can be used as any other of the art layers available in the drawing, but since it is situated

on top of every other, it can be useful for writing notes about the colour model or animation or to draw the
highlight and tone shapes.

Related Topics
•

Generating a Matte for Your Animation on page 327

•

Creating Strokes to Paint Your Drawings on a Separated Layer on the next page

•

More Drawing Layers on page 325
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Creating Strokes to Paint Your Drawings on a
Separated Layer
You can use the outline you traced on one of the four embedded layers and create invisible strokes to paint your
drawings on separate layers, this provides more inking and painting flexibility.
To do so, you must use the Create Colour Art from Line Art option. You can also configure the option to create
the invisible strokes on any of the four embedded layers.
To create Colour Art zones out of the Line Art content:
1. In the Tools toolbar, select the Select

tool or press [Alt] + [S].

2. In the Camera or Drawing view, select the artwork to transfer to the Colour Art.

3. In the Drawing View toolbar, click on the Create Colour Art from Line Art
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To Configure the Line Art to Colour Art command settings:
1. In the Tools toolbar, select the Select

tool or press [Alt] + [S].

2. In the Tool Properties view, hold down the [Shift] key and click on the Create Colour Art from Line Art
button to open the Configure Line Art to Colour Art dialog box and modify the default settings of
this command.
The Configure Line Art to Colour Art dialog box opens.

3. Use rendered version of the drawing: This option will render the drawing and vectorize it to calculate the
position of the centreline that will produce the colour art stroke.
4. Maximum Resolution for rendered image: This is the size of the rendered image.
5. Threshold for rendered image: The value of grey processed to create the rendered vectorized arts.
6. Fitting error for generated Beziers: This value represents how precise the fitting of the colour art zone in
relation of the line art will be.
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7. Source Layer: In the Source Layer drop-down menu, select the layer (Line Art, Colour Art, Underlay or
Overlay) you want the strokes to be created from.
8. Destination Layer: In the Destination Layer drop-down menu, select the layer (Line Art, Colour Art,
Underlay or Overlay) you want the strokes to be created on.
9. Clear Destination Art Layer First: If you already have artwork on the destination layer and you want the
content to be deleted before the strokes are added into it, enable this option.
10. Perform Line Art to Colour Art Operation Immediately: Enable this check box to perform the Create
Colour Art from Line Art command when you click on the OK button of this window.

Related Topics
•

Line Art and Colour Art Layers on page 388
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Verifying Zones are Painted
When the painting process is completed, you should verify that each zone was painted correctly.
The Backlight feature produces a silhouette effect by changing the drawing’s coloured areas into a single dark,
solid colour use this to verify the completeness of the ink and paint process. Any unpainted zones can be seen as
the light shows through the unpainted areas of the silhouetted drawing.
To use the Backlight:

This feature is only available in the Drawing view.

1. In the top menu, select View > Backlight or press [Alt] + [Shift] + [B]. You can also click on the Backlight
button available in the Drawing View toolbar.
2. Verify the drawings in the Drawing view.

Related Topics
•

How to Paint on page 340

•

Painting Using the Paint Tool on page 357
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Palettes

In colour animation, specific colours are used to paint each particular character. In order to maintain absolute
consistency, a colour palette is created for each character, prop and effect throughout the production. These are
referred to as master palettes.
Master palettes contain a colour swatch for each zone to colour with a precise RGBA colour value.
Using a master colour palette has many benefits, including:
•

Each character consistently retains their dedicated colours.

•

You cannot accidentally use a colour which is not in the master palette.

•

Standardization and colour consistency throughout the production

•

Multiple artists can use the same colour palette and produce the same results.

Toon Boom Harmony uses palettes to hold all of the colours needed to paint your elements, allowing complete
control and consistency in your painting process.
A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette
and add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, tongue,
shirt, pants, etc.
This topic is divided as follows:
•

Displaying the Palette List on the facing page

•

Creating a Colour Palette on page 399

•

Copying and Pasting Colours on page 411

•

Removing a Colour Palette on page 412

•

Duplicating a Colour Palette on page 413

•

Cloning a Colour Palette on page 414
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•

Mixing the Colours on page 416

•

Importing a Colour Palette on page 418

•

Ordering the Palette List on page 422

Displaying the Palette List
The Colour view has two modes: basic and advanced.

Basic Mode
The Colour view’s basic mode only shows the Colour list. When you open Toon Boom Harmony, you only see the
colours available in the default palette. This default palette contains six basic colour swatches and is
automatically named the same as your scene. For simple projects, you can manage with the default palette, but
for movies, series or shorts it is recommended that you create palettes for your characters. To create a palette,
you have to switch to the advanced display of the Colour view and show the Palette list.

Advanced Mode
To create palettes for your characters, you must display the Palette list. Once you display the Palette list area, a
series of new buttons appear.
To show or hide the Palette List area:
1. In the Colour view, click on the Show/Hide Palette List View
Palette List area.
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•

Each palette you add in your scene will appear in the Palette list.

•

You can add, delete, import and order palettes in your scene using the Palette menu buttons.

Related Topics
•

Creating a Colour Palette on page 399

•

Toon Boom Harmony Palette File Storage below

Toon Boom Harmony Palette File Storage
In Harmony, palettes are individual *.plt files that can be copied, transferred and stored. When a palette is
created, it needs to be stored somewhere. Harmony is set on Basic Palette Lists mode which saves the palette at
the Scene level.
In Toon Boom Harmony, you can switch from Basic Palette Lists mode to Advanced Palette Lists mode which
will allow you to choose the folder level you want to save your palette files to.

Refer to the Creating a Colour Palette on page 399 section to learn more on how to access these
options.

There are four locations where you can find Palette Library folders: Element, Scene, Job and Environment
folders.
•

Element: The Palette Library folder is stored directly in the Drawing Element (Layer) folder.

•

Scene: The Palette Library folder is stored directly in the Scene folder.

•

Job: If you are working with Toon Boom Harmony as a stand alone version, the Palette Library folder is
stored in a Job folder contained within the Scene folder.
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•

Environment: If you are working with Toon Boom Harmony as a stand alone version, the Palette Library
folder is stored in an Environment folder contained in the Scene folder.

This existing structure is compatible with Toon Boom Harmony Server. Toon Boom Harmony’s database has a
leveled structure starting from the Environment down to the Element. They have a client-server configuration
that allows all data, such as palettes and scenes, to be shared between a series of client machines.
In Toon Boom Harmony, you can switch from Basic Palette Lists Mode to Advanced Palette Lists Mode and
choose the folder level you want to save your palette files to.

Element Level
Working with Harmony stand alone, the Element level is very useful when there are a lot of different palettes.
When a colour model drawing is created, it is stored in its element folder. By storing the corresponding palette
file with the colour model, the colourist is able to load them both from the same location. This also creates a
more organized structure.

Scene Level
Working with Toon Boom Harmony stand alone, a palette file can also be saved at the scene level so that all of
the palettes from the scene are stored together. The palette naming will have to be structured so that the
colourist or character builders can find the correct one. Saving the palettes at the scene level makes it very easy
to backup the palettes and retrieve their location.
The scene level can also be useful for Cut-out animation. Instead of creating a colour model scene that includes
all of the characters, props, effects, and location, the colour palette or model will often be directly imported to,
or created in, the character building scene. Just as with a Cut-out character building scene, each element uses
the same palette so it would not be efficient to save the palette inside one element. Instead, it is saved at the
scene level. This prevents a palette overload because all of the models are in different scenes. It also allows each
scene its own set of palettes corresponding to its model.
When working on a cut-out animation production, it is highly recommended to work with the Scene level.

Related Topics
•

Palettes on page 394

Scene Palette List and Element Palette List
There are two types of palette lists:
•

Scene Palette List on the next page

•

Element Palette List on the next page

Refer to the Colour Preferences on page 428 topic in this chapter to learn how to enable and disable
the Element Palette List mode.
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Scene Palette List
The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be divided in twenty
to thirty different drawing elements that use the character’s master palette.
The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to this
list will appear in every drawing element created in the scene. There is no need to manually load the palette in
each element.
The Scene Palette List is the simplest one to use. By default, Toon Boom Harmony is set to use only Scene
Palette Lists.

Element Palette List
In Toon Boom Harmony, you can switch to Advanced Palette Lists mode and choose to save your palette at an
element’s level. The Element Palette List is mainly used with Traditional and Paperless animation. Unlike Cut-out
animation, all columns (drawing elements) contain different characters, props, backgrounds and effects. The
Element Palette List is used because you do not necessarily want all of the palettes for all of your elements linked
in every column.
The palette list is stored in the drawing element’s directory instead of directly in the Scene level. This ensures
that the links to the palettes appear only in the appropriate element. If you prefer to access a global palette list,
link your palettes to the Scene Palette List.
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Related Topics
•

Creating a Colour Palette below

Creating a Colour Palette
You can create a palette in either basic or advanced mode:
•

Basic Palette Lists Mode below

•

Advanced Palette Lists Mode below

•

Renaming a Colour Palette on page 401

By default, Toon Boom Harmony is set on basic mode. For simple productions, it is recommended to use the
basic mode. For more advanced productions, it is a good idea to explore the possibilities of the advanced
mode.

If you are using Harmony Network, refer to Managing Palettes on page 401.

Basic Palette Lists Mode
To create a new palette (Basic Palette Lists mode):
1. In the Colour View menu, select Palettes > New or click on the New Palette

button.

The Create Palette window opens.
2. Enter the palette name according to the model.

3. Click OK.
The palette appears in the drawing element’s palette list.

Advanced Palette Lists Mode
To use this method, you first need to set your preferences to Advanced Palette Lists mode in the Preferences
panel.
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To set the Advanced Palette Lists mode:
1. Select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X) to open the
Preferences panel or press [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).
2. In the Advanced tab, enable the Advanced Palette Lists option.

3. Click OK.
To create a new palette (Advanced Palette Lists mode):
1. In the Timeline or Xsheet view, select the drawing that requires the palette.
2. In the Colour View menu, select Palettes > New or click on the Create Palette

button.

The advanced Palette Browser: Create Palette (Stand-alone mode) window opens.

‣ Palette Location: Select which location to store the palette file to.
•

Element: Displays the drawing layers in your scene.
•

Environment

•

Job

•

Scene

•

Element.

•

Palette: Displays the palettes available in the currently chosen storage folder.

•

Palette Name: Name the new palette.

‣ Palette List: Select either Scene Palette List or Element Palette List.
3. Select an element from the Element window.
4. If you want to save your palette at the element level, select the Element option from the Palette Location
section and then select the desired element form the Element list.
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5. Select either Scene Palette List or Element Palette List.
6. Click OK.
The palette is created.

Refer to the Toon Boom Harmony Palette File Storage on page 396 and topics to learn more about
palette storage location as well as scene and element palette lists.

Renaming a Colour Palette
To rename a palette:
1. In the Colour view, select the palette to rename.

2. In the Colour View menu, select Palettes > Rename.
3. In the Rename dialog box, rename the palette.

4. Click OK.

Related Topics
•

Copying and Pasting Colours on page 411

•

Removing a Colour Palette on page 412

•

Duplicating a Colour Palette on page 413

•

Cloning a Colour Palette on page 414

Managing Palettes
The Harmony Network solution incorporates palettes which hold all of the colours needed to paint elements, a
concept that brings complete control and consistency to the painting process. A palette is created by assigning
a set of colours to each character, prop or effect. The colour artist will create a new palette and add a new
colour, called a colour pot, for each zone of the character, such as the skin, hair, tongue, shirt, pants and so on.
When a zone on a character is painted with the colour contained in a colour pot, a link is automatically created
between that colour pot and the zone. This means that if the tint of the colour in the colour pot is modified, any
zone that is linked to it will automatically update to the new tint. This saves time and money spent on your
production. Another advantage of this system is that you can also create complete palettes for different lighting
situations. For instance, in addition to the regular palette for a character, you can have one for that character in
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the rain, using colours that are muted and less vibrant than the dry daytime colours, or another for use in a night
scene. Using palettes that are linked to your character this way allows you to instantly change colouring to suit
the mood and atmosphere of the scene without tediously repainting each element.

Related Topics
•

Creating a Palette in Harmony below

•

Palette Operations on page 406

•

Palette Storage on page 409

•

Palette Backup on page 411

Creating a Palette in Harmony
Harmony is set to Basic Palette Lists mode by default. This setting stores the palettes automatically for you and
saves them at the Scene level. When you use Advanced Palette Lists mode, you can decide at which level you
want to store your palettes; Environment, Job, Scene, Element.
To switch to Advanced Palette Lists mode:
1. Open the Preferences panel:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

The [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).

The Preferences panel opens.
2. Select the Advanced tab.

3. Enable the Advance Palette Lists mode.

4. Click on the OK button.
To create a palette from the Advanced Palette Lists mode:
1. Make sure that you have the necessary rights to modify the palette list. If you do not, select Edit > Edit
Palette List Mode, a check mark will appear beside the command to indicate that the mode is enabled.
2. In the Timeline or Xsheet view, select the drawing that requires a palette.
3. In the Colour view, click on the Show Palette List View
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4. In the Colour view, click on the Menu
Palette
button.

button and select Palettes > New or click on the Create

The Palette Browser: Create Palette dialog box opens.

5. Select which level to store the palette file in.

•

Environment

The Palette Library folder is stored in an Environment folder contained in the Scene folder.
•

Job
The Palette Library folder is stored in a Job folder contained in the Scene folder.

•

Scene
The Palette Library folder is stored directly in the Scene folder.

•

Element
The Palette Library folder is stored directly in the Drawing Element folder.
When you select a level that has a palette stored in it, the palette names are displayed in the Palette field.

6. Name the palette. (There is no need to add the suffix "palette" to the name as it is always recognized as a
palette file.)

7. Select a Palette List option:
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•

Scene Palette List
The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be divided in
twenty to thirty different drawing elements that use the character's master palette.
The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to
this list will appear in every drawing element created in the scene. There is no need to manually load the
palette in each element.

•

Element Palette List
The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-out
animation, all columns (drawing elements) contain different characters, props, backgrounds and effects.
The Element Palette List is used because you do not necessarily want all of the palettes for all of your
elements linked in every column.
The palette list is stored in the drawing element's directory instead of directly in the Scene level. This
ensures that the links to the palettes appear only in the appropriate element. If you prefer to access a
global palette list, link your palettes to the Scene Palette List.

8. Click on the OK button.
The new palette appears in the palette list.

Related Topics
•

Palette Storage on page 409

•

Linking a Palette in Harmony below

Linking a Palette in Harmony
To link a palette in Harmony:
1. Make sure that you have the necessary rights to modify the palette list. If you do not, select Edit > Edit
Palette List Mode, a check mark will appear beside the command to indicate that the mode is enabled.
2. In the Timeline or Xsheet view, select the drawing that requires a palette.
3. In the Colour view, click on the Show Palette List View
4. In the Colour view, click on the Menu

button to display the palette list.

button and select Palettes > Link or click on the Link Palette

button.
The Palette Browser: Link Palette dialog box opens.
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5. Select the location and level where the palette file is stored. When a level is selected, the palettes it
contains are displayed in the Palette field.

6. Select your palette.

7. Select a Palette List option:

•

Scene Palette List
The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be divided in
twenty to thirty different drawing elements that use the character's master palette.
The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to
this list will appear in every drawing element created in the scene. There is no need to manually load the
palette in each element.

•

Element Palette List
The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-out
animation, all columns (drawing elements) contain different characters, props, backgrounds and effects.
The Element Palette List is used because you do not necessarily want all of the palettes for all of your
elements linked in every column.
The palette list is stored in the drawing element's directory instead of directly in the Scene level. This
ensures that the links to the palettes appear only in the appropriate element. If you prefer to access a
global palette list, link your palettes to the Scene Palette List.

8. Click on the OK button.
The palette appears in the drawing element's palette list.
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Related Topics
•

Creating a Palette in Harmony on page 402

Palette Operations
When you launch Toon Boom Harmony connected to the database, you can have access to the Palette
Operations dialog box. The Palette Operations lets you clone, rename or delete palettes.
To open the Palette Operation dialog box:
1. Launch Toon Boom Harmony and login on the database. Refer to Connecting to the Database on
page 57.
2. Click on the Close button to close the Database Selector dialog box.
3. Select Tools > Palette Operations.
The Palette Operations dialog box opens.

To clone a palette in the Palette Operation dialog box:
1. Select the palette you want to clone at the location and level it was stored in.

2. Click on the Clone button.
3. A Warning dialog box opens.
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‣

Click in the checkbox beside Don't show this message again if you want to prevent the dialog box
from opening every time you do this operation.

4. Click on the Yes button to continue or click on the No button to cancel the palette cloning operation.
The Palette Browser dialog box opens.

5. Select the location level where you want the new palette to be stored.

6. Name the new palette.

7. Select a Palette List option:

•

Scene Palette List
The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be divided in
twenty to thirty different drawing elements that use the character's master palette.
The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to
this list will appear in every drawing element created in the scene. There is no need to manually load the
palette in each element.

•

Element Palette List
The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-out
animation, all columns (drawing elements) contain different characters, props, backgrounds and effects.
The Element Palette List is used because you do not necessarily want all of the palettes for all of your
elements linked in every column.
The palette list is stored in the drawing element's directory instead of directly in the Scene level. This
ensures that the links to the palettes appear only in the appropriate element. If you prefer to access a
global palette list, link your palettes to the Scene Palette List.

8. Click on the OK button.
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To rename a palette in the Palette Operation dialog box:
1. Select the palette you want to rename at the location and level it was stored in.

2. Click on the Rename button.
A Warning dialog box opens.

‣

Click in the checkbox beside Don't show this message again if you want to prevent the dialog box
from opening every time you click on the Rename button.

3. Click on the Yes button to continue or click on the No button to cancel the palette renaming operation.
The Rename Palette dialog box opens.

4. Rename the palette.
5. Click on the OK button.
To delete a palette in the Palette Operation dialog box:
1. Select the palette you want to clone at the location and level it was stored in.

2. Click on the Delete button. A Warning dialog box opens.

‣

Click in the checkbox beside Don't show this message again if you want to prevent the dialog box
from opening every time you click on the Delete button. It is not recommended to disable the warning
message in this case. Deleting a palette can not be undone.
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3. Click on the Yes button to continue or click on the No button to cancel the palette deleting operation.

Related Topics
•

Connecting to the Database on page 57.

Palette Storage
When a palette is created from Harmony it needs to be stored somewhere. In Harmony, palettes are individual
*.plt files that can be copied, transferred and stored.
The palette files are saved in the scene directory and stored in a Palette Library folder. There are four locations
where you can find Palette Library folders:
•

Element
The Palette Library folder is stored directly in the Drawing Element folder.

•

Scene
The Palette Library folder is stored directly in the Scene folder.

•

Job
The Palette Library folder is stored in a Job folder contained in the Scene folder.

•

Environment
The Palette Library folder is stored in an Environment folder contained in the Scene folder.

Related Topics
•

Where to Save the Palette File? below

•

What Happens when you Export a Palette File? below

Where to Save the Palette File?
The palette storage location depends on the type of production and the backup plan being used.
Some studios like to store their palettes at the Element level and others at the Environment level. This will not
create a problem as long as the scene is in the Harmony structure, in fact as long as the structure is maintained it
can be stored at any level. However, difficulties may occur when the scene is backed-up or transferred to another
studio or database and removed from the initial structure.

Related Topics
•

What Happens when you Export a Palette File? below

What Happens when you Export a Palette File?
It is important to understand what is happening to a palette file when the scene is exported.
Because of the Harmony client-server configuration, all of the data can be shared through all of the scenes via the
central database. This also includes the palette files, even if they are stored at the Element, Scene, Job, Drawing
or Environment level. This way, the palette files can be accessed from any scene of any project.
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When you export scenes from Harmony using the Control Center, either to archive them or to send them to
other users or studios, the palettes stored in external scenes, jobs or environment will NOT be exported. An
exported scene will only carry palettes stored in its own Element's palette library, Scene's palette library, Job
and Environment. Any other palette from other Environments, Jobs, Elements or Scenes (even from the same
job) will NOT follow. Instead a recovery palette will be created when the scene is reopened in another Harmony
system.
A recovery palette is a local palette created by the system when palettes and colours are missing. This palette is
no longer shared with the rest of the project because the original link is broken.
For example, look at this chart. If you export Scene 2 from Job 1, the package will carry the palettes from Scene
2, Job 1 and Environment. It WILL NOT carry the palettes from Element 3 in Scene 1, Scene 1 and Job 2.
If Scene 2 was linked to any of these, the system would create a recovery palette the next time that Scene 2 is
opened in another Toon Boom Harmony system.

The best place to store your palette is:
•

Environment level, for a movie or series

•

Job level, for a publicity or small project
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•

Scene level, for a student exercise

If you want to store your palettes with your colour models, you can use the Element level. However, this will
require more structure when exporting the different scenes of your project. The scenes will have to be exported
along with the colour model scene. Then, the other studio you are working with will have to recreate an identical
structure to yours, to be able to import the received scenes into the same location as you did. This will ensure
that the links are maintained.

Related Topics
•

Where to Save the Palette File? on page 409

Palette Backup
When sharing palettes between scenes, some users may modify the colours by accident. That is why it is a good
idea to copy and backup your palette libraries and master palette directories.
When a palette file is copied, it automatically becomes a clone palette, so there is no trouble as for replacing an
altered file. Harmony automatically updates all of the files and drawings linked to it.

Related Topics
•

Creating a Palette in Harmony on page 402

•

Palette Operations on page 406

•

Palette Storage on page 409

Copying and Pasting Colours
When you are creating palettes, you may want to copy colour swatches or their values and paste them in other
palettes to save time.
To copy and paste colours
1. In the Colour view, select the colour to copy.

2. In the Colour View menu, select Colours > Copy or press [Ctrl] + [C] (Windows/Linux) or [⌘ ] + [C] (Mac
OS X).
3. In the Palette list, select the palette in which you want to paste the colours.

4. In the Colour View menu, select Colours > Paste as New Colours or press [Ctrl] + [V] (Windows/Linux) or
[⌘ ] + [V] (Mac OS X).
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‣

If you want to paste the colour values of the copied swatch over an existing colour swatch,
select Colours > Paste as Values.

Copying Colours from Another Palette
In Toon Boom Harmony you can quickly copy a colour value from a palette in your scene to a selected colour
swatch in a different palette.
To use Copy Colour From:
1. In the Colour view, select the colour swatch you want to copy the colour into.
2. In the Colour View menu, select Colour > Copy Colour From, then select the palette where the colour you
want to copy is listed and finally select the colour.
The selected colour swatch will immediately change to this new colour.

Related Topics
•

Adding a Colour Swatch on page 344

Removing a Colour Palette
You can remove palettes from your Palette list if they are not needed in your scene. The actual palette file will not
be deleted and you will be able to reimport it in your Palette list later on.
To remove a palette:
1. In the Colour view, select the palette to remove.

2. In the Colour View menu, select Palettes > Remove or click on the Remove Palette
‣

If the palette was in use in your scene, the zones painted with its colours will turn red.

Related Topics
•

Creating a Colour Palette on page 399

•

Duplicating a Colour Palette on the facing page
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•

Cloning a Colour Palette on the next page

Duplicating a Colour Palette
A duplicate palette uses the same names, colour values, but has a different ID and is independent from the
original palette. This ensures that both palettes are completely independent.
This option is used when there are similar models and you want to avoid recreating and naming all of the colours.
You can change the values and the names afterward. You can also keep some RGBA values, such as the eyes,
teeth, tongue, inside mouth, etc.
To duplicate a palette:
1. In the Colour view, select the palette to be duplicated.

2. In the Colour View menu, select Palettes > Duplicate.
The Palette Browser: Duplicate Palette window opens.

3. Name the palette appropriately.
4. Click OK to create the palette.
The palette appears in the palette list.

Related Topics
•

Cloning a Colour Palette on the next page
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Cloning a Colour Palette

A character usually has only one master palette, although there are times when the characters are placed in
different lighting conditions and require a different colour shading. The night palette is a popular choice when a
scene or sequence changes from day to night. It can be difficult and time-consuming to repaint everything and
creating two independent palettes can be quite complex. As an alternative, Toon Boom Harmony provides clone
palettes.
The clone palette is a copy of the master palette. The colours in each palette have the same properties. The
colours have the same identification number pointing to the same colour zones, but they can have different
names and RGBA values. Depending on the activated palette (night or day), the painted drawing will update. So
there is no need to repaint the animation, but to create or import a clone palette (palette style).
To clone a palette:
1. In the Colour view, select the palette to be cloned.

2. In the Colour View menu, select Palettes > Clone.
The Palette Browser: Clone Palette window opens.

3. Name the palette. (It is recommended to keep the suffix“-clone” in the name.)
4. Click OK to create the palette.
The clone appears in the palette list.
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In the Colour view, you can also modify the colours individually by using the Colour Picker window or all at once
using the Tint Panel window.

If there is more than one clone palette loaded, the system will use the one highest in the palette list.

When you want to see through painted drawings, but still see the outlines, you can create a clone
palette where you set a lower alpha value on all of the filling colours. This trick can be handy when
setting pivot points on cut-out puppets.

Cloning a Colour Swatch
In Toon Boom Harmony, you can copy a selected colour swatch and paste it as a clone.
To clone a colour swatch:
1. In the Colour view, select the colour swatch you want to clone.
2. In the Colour View menu, select Colours > Copy. The [Ctrl] + [C] (Windows/Linux) or [⌘ ] + [C] (Mac OS X).
3. In the Colour view, select the colour palette you want to paste the clone into, or create a new palette.
4. In the Colour View menu, select Colours > Paste as Clone.
The cloned colour swatch appears in the palette.
Since it produces a clone colour swatch, it is impossible to use the Paste as Clone command in the same palette
as you copied the original colour swatch from. If you try to do it, a Message dialog box will open as a reminder.

415

Chapter 6: Colour Palettes

Related Topics
•

Mixing the Colours below

•

Duplicating a Colour Palette on page 413

Mixing the Colours
If you want to modify a series of colour at once to blend a tint in them or offset their RGBA values, you can use
the Tint panel. The Tint panel is quite useful when creating palette styles such as night and day styles.
To mix colours:
1. In the palette list, select the palette to offset or blend colours in it.

2. In the Colour View menu, select Palettes > Tint Panel.
The Blend/Offset Tint panel opens.

3. Select one or more colours to be modified in the colour list. To select all your colours, press [Ctrl] + [A]
(Windows/Linux) or [⌘ ] + [A] (Mac OS X).
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4. Check Preview.

5. Offset, Blend or Mix the selected colours.

‣

Offset

Use this option to simply offset the selected colours by the adjustments made using the HSB and RGB
sliders. Use the Amount slider to adjust the degree of offset. Use the Alpha slider to adjust the opacity of
the selected colour.
‣

Blend

Use this option to blend the selected colours with the colour swatch in the top right corner. Use the
Amount slider to adjust the degree of blend. A blend of 100% would turn the selected colours into the
same colour as the swatch. Adjusting the HSB and RGB sliders affect the swatch colour, which in turn
affects the selected colours on the left. Use the Alpha slider to adjust the opacity of the swatch.
‣

Mixer
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Select a Base and Tint colour to form a third colour swatch. Use the slider just beneath to mix the Base
and Tint colours by different amounts. This will affect the mixed swatch whether it is selected or not.
Select either the Tint or Base swatch and use the HSB and RGB sliders to adjust its colour. This will affect
the mixed swatch colour, which in turn affects the selected colours on the left.

6. Click on the Apply button.
7. Close the Tint Offset/Blend Panel window.

Related Topics
•

Cloning a Colour Palette on page 414

•

Adding a Colour Swatch on page 344

Importing Palettes
•

Importing a Colour Palette below

•

Linking a Colour Palette on the facing page

•

Linking your Master Palette on the facing page

•

Palette Linkage Status Icons on page 421

Importing a Colour Palette
If you created a palette in another project and you would like to import it in your current project, you can browse
for the palette file on your computer and add it to your project. When the palette is imported in your scene, the
file is copied in the project’s directory. It is not linked to the original file.
To import a palette into your project:
1. In the Colour View menu, select Palettes > Import or click on the Import Palette

button.

The Browser window opens.
2. Browse for a palette file located on your hard-drive. You will generally find the palettes in your projects’
Palette-Library directory.
3. Click on the Open button.
The palette appears in the Palette list.
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Linking a Colour Palette
You may encounter a scene where only the colour palette created for a certain layer is visible when that layer is
selected. A good example would be a scene where there is a character on one layer and the background on
another and each has its own custom colour palette. In order to see both colour palettes, independent of what
element is selected, you must link your palette list to another palette file within the Harmony structure.
To link a colour palette:
1. In the Colour View menu, select Palette > Link.
The Palette Browser window opens.

2. Select the level where the palette file is stored. (Usually Scene or Element)
3. Select the Scene or Element Palette list. See Scene Palette List and Element Palette List on page 397
topic for more information.
The palette appears in the Colour view.

See Scene Palette List and Element Palette List on page 397 topic for more information.

Linking your Master Palette
With Toon Boom Harmony as a stand-alone application, every scene is local to the machine. This means that all
of the scene’s data is only accessible from that particular scene. Palettes are also local to the scene: they can be
shared between all drawing layers, but not between scenes.
However, some users may want to share their palettes across a whole project. Toon Boom Harmony offers that
possibility.
By default, a palette is an independent file stored in your Toon Boom Harmony scene. This file can be copied,
moved or deleted.
To fully link a palette throughout an entire project, you need to create a central directory where you can copy all
of the palettes you have created. Every time you link a palette in an element, it is linked to this folder. If you
modify the palette, it will be updated throughout the whole project.
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To link your master palette:
1. In the Colour view, click on the Create Palette

button to create your master palette.

2. Save your scene by selecting File > Save from the top menu or by clicking on the Save

button or

press [Ctrl] + [S] (Windows/Linux) or [⌘ ] + [S] (Mac OS X).
3. In your operating system, create a master directory. Ideally, this should be created in your Root folder to
keep it within the project directory. You could also place it inside your Colour Model’s subdirectory.

4. Name the folder appropriately, for example: Joe’s_master_palettes.
5. From your operating system, browse to your Toon Boom Harmony scene and open the palette-library
folder.

6. Select and copy your palette.plt file to copy it to the master palette directory.

7. Create a new Toon Boom Harmony scene or open the scene where you will link this palette.
8. In the Timeline or Xsheet view, select the element to link the palette to.

9. In the Colour View menu, select Palettes > Link to External.
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The Link to External Palette dialog box opens.

‣

Files: Click on the button to browse to your master palettes folder and select the palette *.plt file
you want to link.

‣

Palette List: Select either you want to load this palette at scene or element level.

10. Click OK.
The linked palette appears in your Colour view.

If a palette is outside the scene, the External

icon appears beside the palette name.

To link an element (such as a colour model) to the palette that is stored in the external palette
directory, you must remove the original palette from the element’s palette list. You will then load the
duplicated palette into the palette list using the Link to External command, like you did for the other
elements.

Palette Linkage Status Icons
You will also notice that when you create or link a palette, a small icon will appear on its left. These icons
represent the palette linkage status.
•

Indicates a potentially dangerous situation.
Problems may occur when trying to export or link to the palette file. For example, a palette file is stored
into the element folder and is linked to the Scene Palette list. The issue in this case is that if you decide to
delete the layer containing the palette, you will loose it from your scene.

•

Indicates that the palette is safe.
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There won’t be any trouble once the scene will be exported. For example, the palette file is stored in the
scene folder and is linked to the Scene Palette List.
•

Indicates that the palette file is stored in a directory external to the scene’s structure.
The palette file is probably stored in a Master Palette directory on a hard drive external to the palettelibraries planned for the palette storage. The warning in this case is that if you move your Master Palette
directory to another location, you may loose the palette in your scene.

•

Indicates that a palette file stored in a level such as Element, Scene, Job or Environment is linked to a
Palette list that is not on the same level.
For example, a palette file is stored into the Environment folder and is linked to the Element Palette list.
The palette is shared.

Ordering the Palette List
When you are using several cloned palettes that are related to the same original palette, Toon Boom
Harmonyuses the highest palette in the list to determine the colour of the painted zones.
To reorder palettes in the Palette list:
1. In the Colour View menu, select Palettes > Move Up or Move Down. You can also use the Up
Down

icons.

Related Topics
•

Cloning a Colour Palette on page 414
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Colour Model

Once you have a fully painted drawing, you can use it as a colour model and load it in the Model view. That
drawing can be used and loaded in any of your Harmony scenes.
Once a drawing is loaded in the Model view, you can click on the Dropper

, select a colour from the model

and use it to paint in your Camera or Drawing view without having to pick the colour from the colour palette.
•

Loading a Colour Model below

•

Cutting, Copying and Pasting from a Colour Model on page 426

Loading a Colour Model
To load a colour model from your Timeline or Xsheet view:
1. In the Timeline or Xsheet view, select the desired drawing (*.tvg).

2. Bring the model into the Model view by doing one of the following:
‣

In the Timeline view, click and drag the selected drawing and drop it directly in the Model view.

‣

In the Model View menu, select Use Current Drawing as Model.
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‣

Use Current Drawing

button in the Model View toolbar’s extra buttons.

The model appears in the Model view.
To browse for a colour model drawing on your hard drive:
1. Do one of the following:
‣

In the Model View menu, select Import Model.

‣

Click the Import Model

‣

Select File > Import > Colour Model.

button or from the Model View’s toolbar.

2. In the Browser window, browse for any *.tvg drawing file on your hard drive.
3. Click Open.
The model appears in the Model view.
To load the Default models:
1. In your scene’s folder, create a new folder and name it models.
2. On your hard drive copy the *.tvg drawing file you want to use as colour models in your scene.
3. In the Model View menu, select Load Default Model. You can also click on the Load Default Model
button available in the Model View toolbar’s extra buttons.
To load a single drawing from the Library view:
1. In the Library view, click the template containing the drawing to import in the Model view.
2. Right-click on the template and select Open As Folder.
3. In the Library view’s left side, select the template’s folder and continuing expanding its sub-folders until
*.tvg files appear on the right side.

4. In the Library view’s right side, select the TVG drawing to import and drag it into the Model view.
To load a template with multiple drawings from the Library view:
1. In the Library view, find the template you want to import in the Model view.
2. In the Library view’s right side, click and drag the template (*.tpl file) and drop it directly in the Model
view.
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3. Use the Scroll Backward

and Scroll Forward

buttons, found in the Model view’s toolbar, to view

all the drawings contained in the template. This can often be the front, profile and 3/4 views of a
character.

To load a symbol from the Library view:
1. In the Library view’s left side, click on the Symbols folder.
2. In the Library view’s right side, select the symbol that you would like to use as a model and drag and drop
it directly into the Model view.

3. Use the Scroll Backward

and Scroll Forward

buttons, found in the Model view’s toolbar, to view

all the drawings contained in the symbol. This can often be the front, profile and 3/4 views of a character.
To clear a colour model:
1. In the Model View menu, select Clear Model or press [Delete].
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Cutting, Copying and Pasting from a Colour Model
You can do more than just copy colours from a colour model. Harmony gives you the ability to copy parts of the
character directly from its colour model and paste these elements into the Drawing or Camera views.
To copy the entire model from the Model view:
1. In the Model view’s toolbar, select the Select

tool.

2. In the Model view, select your model.

3. In the top menu, select Edit > Copy Drawing Object or press [Ctrl] + [C] (Windows/Linux) or [⌘ ] + [C]
(Mac OS X).
4. In the Timeline view, make sure that you have the correct layer and frame selected.
5. Select either the Drawing or Camera views then go to the top menu and select Edit > Paste Drawing
Object, or select the Timeline view and from the top men select Edit > Paste cells in the Timeline or
press [Ctrl] + [V] (Windows/Linux) or [⌘ ] + [V] (Mac OS X).
The model now appears in the selected view.
To copy part of the model from the Model view:
1. In the Model view’s toolbar, select the Cutter

tool or press [Alt] + [T].

2. In the Model view, use the Cutter tool to create a selection around the part of your model that you would
like to copy.

426

Toon Boom Harmony 10.3 Stage User Guide

3. In the top menu, select Edit > Copy Drawing Object or press [Ctrl] + [C] (Windows/Linux) or [⌘ ] + [C]
(Mac OS X).
4. In the Timeline view, make sure you have the correct layer and frame selected.
5. Do one of the following:
‣

Select the Drawing or Camera view and select Edit > Paste Drawing Object.

‣

Select the Timeline view and select Edit > Paste cells in the Timeline or press [Ctrl] + [V]
(Windows/Linux) or [⌘ ] + [V] (Mac OS X).

The model appears in the selected view.
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Colour Preferences
Adjusting preferences to suit your techniques allows you to paint your drawings more efficiently.
To open the Preferences panel:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

Or press [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).

In the Preferences panel, you will find the following preferences that are related to adding colours to your
project.

Drawing Tab

Default Multiwheel Colour Picker
Enable this option to display the Mutliwheel Colour Picker window instead of the regular Colour Picker.
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Sticky Eye Dropper
Enable this option to keep the Colour Picker’s Dropper tool active until it is released by clicking on the Dropper
icon again.

Create New Colour Pots Using Default Colour
Set the default colour for creating a new colour swatch. Enable the option so that this default colour is used each
time you add a new colour in your palettes. This option is useful for when you create new colour pots so that a
more recognizable colour is created and not just a duplicate of the currently selected colour. Choosing a colour
that is the opposite of your intended colour palette is recommended, such as grey if your palette will be filled
with bright, primary colours.

Auto Gap Closing on Startup
The values for automatic gap closing while painting drawings are:
•

0 = Disabled

•

1 = Small

•

2 = Medium

•

3 = Big

Auto Gap Closing in Pixel Units
Disabling this option will cause your gap to be zoom dependant. Zoom dependent means that the more you
zoom in, the smaller the gap you can close with the Close Gap tools. By enabling this option, you choose to
make the gap display available in pixel units, which is not zoom dependant.
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General Tab

Colour Management
In the General tab of the Preference panel, you will find the following options:
•

Default to Element Palette Lists: When this option is enabled the new, cloned, duplicated, imported and
linked palettes will be stored in the Element Palette list instead of the Scene Palette List.

•

Interactive Colour Recovery: If a colour palette for your scene is deleted or cannot be found, you will be
asked if you want to recover colours from the program’s memory. If this option is unchecked, the
program recovers missing colours without displaying a dialog box for your input.

•

Colour Recovery: If this option is unchecked, colour recovery will not occur.
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•

Replacement Colours: If colours are no longer available for your scene, these colours are automatically
replaced with the ones indicated by the Replacement Colour swatch. The default colour is red, as it acts
as a missing colour warning device.

Advanced Tab

Advanced Palette Lists
In the Advanced section, you will find the Advanced Palette Lists option. Enable this feature to switch your
palette list to advanced mode. The Advanced Palette Lists mode is used to create and store palettes in the
Scene or Element Palette List.

Shortcuts Tab

Go to Next/Previous Colour in the Colour Palette
Under the Colour Management section, you can set two new possible shortcuts. You can set a shortcut to Go to
the Next Colour in the Colour Palette or to Go to the Previous Colour.

431

Toon Boom Harmony 10.3 Stage User Guide

432

Toon Boom Harmony 10.3 Stage User Guide

Chapter 7: Timing

When you create hand-drawn animation, it is important to know how to set and modify the timing of your
drawings. You can adjust the timing in both the Timeline and Xsheet views, depending on which technique you
are used to working with. If you are a digital animator, you will probably use the Timeline view. If you are more of
a traditional animator, you will probably work with the Xsheet view (exposure sheet). Harmony offers you both.
In this topic, you will learn how to work on your drawing’s exposure and length. The exposure and animation
paths for symbols are covered in separate chapters.

Topics Covered
•

Understanding the Timeline View on the next page

•

Xsheet View on page 436

•

Frames on page 445

•

Layers and Columns on page 449

•

Filling Exposure on page 480

•

Navigating between Frames and Columns on page 502

•

Managing Drawings on page 504

•

Tempo Markers on page 510

•

Annotation Columns on page 512

•

Printing the Xsheet on page 519

•

Element Manager on page 521

•

Timing Preferences on page 522
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Understanding the Timeline View
To set your animation timing, you will mostly work with the Timeline and Xsheet views. This section will help you
become familiar with these views, how they work and the differences between them.
•

Timeline View below

•

Layer Section below

•

Timing Selection on the facing page

•

Data View Section on the facing page

Timeline View

The Timeline view allows you to read your timing from left to right. It represents the scene’s elements in their
simplest form.
In the Timeline view you can see your layers and their names as well as the drawing’s exposure. The drawing
name is displayed when you place your cursor above the drawing’s exposure.

You can also see the drawing name when you display the Data view. The name of the drawing folder to which the
layer is linked is displayed in the Data view.

Layer Section

The Layer section is located to the left of the Timeline view. This is where you add, delete, rename, reorder, and
parent layers. Any operation you do that affects the layer globally is done here.
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Timing Selection

The Timing section is located on the right side of the Timeline view. This is where you can increase and decrease
a drawing’s exposure, duplicate drawings, add blank cells, etc. Any operation you do that affects a drawing or
its timing is done in this section.

Data View Section

The Data view section is part of the Layer section. By default, the Data view is hidden.
The Data view allows you create new drawings by typing a new name in the Drawing Substitution field. You can
also swap between existing drawings by sliding your cursor
to the left or right.
To display the Data view:
‣

Click the Show Data View

button.

Related Topics
•

Swapping Images on page 1092
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Xsheet View

1. Xsheet Main Section on the facing page
2. Functions Section on page 438
3. Column List Section on page 439
4. Xsheet View Toolbar on page 440
5. Column Header on page 440
6. Current Drawing on page 441
7. Current Frame on page 441
8. Frame Numbers on page 442
9. Drawing Exposure on page 443
10. Current Frame Display on page 443
11. Function Column on page 443
12. Increase/Decrease Exposure on page 444
13. Overwrite/Insert Modes on page 444
There is also the Xsheet View menu

button in the top-left corner, which allows you to access commands

related to the Xsheet view.
The Xsheet view lets you read the timing vertically, displays the drawing layers as columns, and shows the
drawing’s name. You can also see the functions and keyframes of the motion paths in the Xsheet’s function
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columns. The value of each keyframe is shown in the Xsheet view; these are displayed as black squares in the
Timeline view. The Xsheet view contains more details than the Timeline view, and is faster and easier to read.

Related Topics
•

Adding and Deleting Keyframes on page 952

Xsheet Main Section

The Xsheet view has three sections. By default, only the main section is visible. It displays the drawing layers, also
known as drawing columns.
When using advanced compositing and animation techniques, unconnected functions (motion paths) also appear
in the main section. Unconnected functions mean that some motion paths are not attached to any particular
layer.

When you reconnect functions to a layer they are still visible in the main section.
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Refer to Sharing Functions on page 994 to learn about the unconnected functions.
Refer to the topic Showing and Hiding Columns on page 466 to learn how to temporarily hide
unconnected functions from the main section.

Related Topics
•

Xsheet View on page 436

Functions Section

The Functions section is used for more advanced techniques. This section displays the functions (paths) related
to the selected layer in the Timeline view. By default, the Functions section is hidden.
To display the Functions section:
1. In the Xsheet view, click on the Expand button located on the right side of the main section. Click on the
same button to collapse it. You can also use the Show Column List
button in the Xsheet View toolbar.
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If you select a drawing column in the main section of the Xsheet view, the function columns will not
be displayed. You must select the layer from the Timeline view.

Related Topics
•

Xsheet View on page 436

•

Animation Paths on page 937

Column List Section

The Column List section allows you to show and hide columns from your Xsheet view. When you hide a layer
using your Xsheet view, it is also disabled in the Timeline view.
You can use the Column List to hide individual columns or hide an entire column type (drawing or function) from
your Xsheet view. By default, the Functions section is hidden.
To display the Column List section:
1. In the Xsheet view, click the Expand button located on the right side of the main section to show the
Functions section. Click on the same button to collapse it. You can also use the Show Column List
button in the Xsheet View toolbar.
‣

In Harmony, you can also go to the Xsheet View menu and select View > Show Column List.

2. Click the Expand button on the right side of the Functions section to display the Column List section.
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Related Topics
•

Xsheet View on page 436

Xsheet View Toolbar

The Xsheet view has its own toolbar where you can find the most common features. This toolbar is displayed by
default. If you do not see it, select Windows > Toolbars > Xsheet View.
The Xsheet view must be part of your workspace in order to display its toolbar.

Refer to Toolbar Manager on page 136 to learn how to organize the buttons available in the Xsheet
View toolbar.

Related Topics
•

Xsheet View on page 436

Column Header

Each column available in the Xsheet view has a header displaying the column’s name. The column’s name is the
same as the corresponding timeline layer. If you rename one or the other, they will both be renamed.
A quick access menu is available when you right-click. This menu contains the command affecting an entire
column such as renaming, changing the default colour or deleting a column.
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In Harmony, the column header shows the layer’s name and the name of the drawing folder to which it is linked. If
the name of the layer is the same as the drawing folder, the drawing folder’s name will not be displayed. For
example; when you link a Timing column to a certain element (and thereby the Element’s folder).

The tooltip that appears when you hover your cursor at the top of each Xsheet column shows the absolute folder
path to the source drawings for that column.

Related Topics
•

Xsheet View on page 436

Current Drawing

A drawing selected in dark red indicates that the drawing is currently displayed in the Drawing view. The current
drawing selection is not linked to the drawing displayed in the Camera view since drawings from each visible
layer are displayed at once.

Related Topics
•

Xsheet View on page 436

Current Frame

The darker frame appearing in the Xsheet view represents the current frame displayed in the Camera view. It
does not necessarily correspond to the current drawing displayed in the Drawing view.
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Tip: To show the real time updated of the selected frame, click the Xsheet menu and select View >
Enable Playback.

There is a new option in the Xsheet to Enable Playback. This shows the real time update of what frame is
selected. You can turn this off or on view the View menu in Animate Pro, and I think by right-clicking in Animate
LB

Related Topics
•

Xsheet View on page 436

Frame Numbers

On the left side of the Xsheet view, the frame numbers are shown indicating where you are. These read vertically
instead of being displayed horizontally as they are in the Timeline view.
•

To go to a particular frame, click the frame number.

•

To select an entire range of frames, click and drag a selection downwards.

Related Topics
•

Xsheet View on page 436
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Drawing Exposure

In the drawing columns, you can see the drawing names and their exposure. You can use any alphanumeric
symbol to name your drawing. When a drawing is exposed over more than one cell, a vertical black line is
displayed to indicate the continuity of the exposure. When there is no drawing in a cell, the cell will be blank.

Related Topics
•

Xsheet View on page 436

Current Frame Display

At the bottom of the Xsheet view, you can see the current frame number as well as the column containing the
drawing currently displayed in the Drawing view

Related Topics
•

Xsheet View on page 436

Function Column
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The function columns are displayed in the Functions section of the Xsheet view. They represent the motion and
rotation you applied to your drawing layer. Only the function columns related to the selected layer are displayed.
A function column can also be related to an effect. Selecting your effect layer shows you the corresponding
function column in the Xsheet view.
The function columns display the position value or effect value on each cell. If there is a keyframe on a cell, a black
square is displayed. Holding the same value for several frames displays a vertical black line.
Holding the same value for several frames displays a vertical black line.

Related Topics
•

Xsheet View on page 436

Increase/Decrease Exposure

You can quickly increase or decrease the exposure of the selected cell by clicking on the up and down arrows in
the Increase/Decrease Exposure field.

Refer to the Increase/Decrease Exposure Field on page 490 topic to learn more about this feature.

Related Topics
•

Xsheet View on page 436

Overwrite/Insert Modes
The Overwrite/Insert button allows you to decide the way the values are inserted into your Xsheet.

Related Topics
•

Xsheet View on page 436
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Frames
One of the first things to learn in Toon Boom Harmony is how to add or delete frames in your scene.

Related Topics
•

Adding Frames below

•

Deleting Frames on page 447

Adding Frames
There are several ways to add frames to your scene using Toon Boom Harmony.

Related Topics
•

Setting the Scene Length below

•

Extending the Timeline View below

•

Adding Frames Before or After a Selection on the next page

•

Adding Frames to the Beginning or at the End of a Scene on the next page

Setting the Scene Length
You can set the global scene length from the top menu.
To set the set scene length:
1. Select Scene > Set Scene Length.
The Set Scene Length dialog box opens.

2. In the Number of Frames field, type how many frames are needed.

Extending the Timeline View
You can quickly extend your scene length in the Timeline view.
To extend your scene in the Timeline view:
1. In the Timeline view, drag the scene length bracket to the right to add more frames to your scene.
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Adding Frames Before or After a Selection
You can add frames anywhere in the middle of the scene. If you select a frame row in the Xsheet view, the system
will add the new frames before or after the selection, depending on your choice.
To add frames before or after selection:
1. In the Xsheet view, select a frame row.

2. Do one of the following:
‣

Select Scene >Frame >Add Frames Before Selection or Add Frames After Selection.

‣

Press [Ctrl] + [G] and [Ctrl] + [H] (Windows/Linux) or [⌘ ] + [G] and [Ctrl] + [H] (Mac OS X).

In Harmony Xsheet, select Frame >Add Frames Before Selection or Add Frames After Selection.
The Add Frames dialog box opens.

3. In the Number of Frames to Add field, enter the amount of frames needed in the scene.

To add new frames after your selection, you can also use the Add Frames

button in the Xsheet

View toolbar.

Adding Frames to the Beginning or at the End of a Scene
You can add some frames to the beginning or at the end of the scene.
To add frames at start or at end:
1. Select Scene > Frame > Add Frames at Start or Add Frames at End.
In Harmony Xsheet, select Frame > Add Frames at Start or Add Frames at End.
The Add Frames dialog box opens.

2. In the Number of Frames to Add field, enter the number of frames needed in the scene.
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To add new frames at the end of your scene, you can also use the Add Frames

button found in

the Xsheet View toolbar.

Related Topics
•

Deleting Frames below

Deleting Frames
There are three ways to delete frames from your scene:
•

Reducing the Timeline Length below

•

Removing Selected Frames below

•

Deleting a Selected Frame Range on the next page

When you remove frames from the end of your scene, the exposed drawings and symbols are not
deleted. If you extend your scene afterwards, these drawings and symbols are still available.

Reducing the Timeline Length
You can quickly reduce your scene length in the Timeline view.
To reduce your scene in the Timeline view:
1. In the Timeline view, drag the scene length bracket to the left to remove frames from your scene.

Removing Selected Frames
You can remove any selected frame in your Xsheet view, such as the last frame of your scene.
To remove a selected frame:
1. In the Xsheet view, select a frame in a given column.
2. In the Xsheet View toolbar, click the Remove Frames

button. To remove several frames, click the

button repeatedly.
You can also select Scene > Frame > Remove Selected Frames from the top menu.
In Harmony Xsheet, select Frame > Remove Selected Frames from the top menu.
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Deleting a Selected Frame Range
In the Xsheet view, you can remove any selected frame range.
To delete a frame range:
1. In the Xsheet view, select a frame range by clicking the first frame’s number and then dragging the
selection highlight down to the last frame to delete.

2. Do one of the following:
‣

Press [Delete] to delete the selection.

‣

From the top menu, select Scene > Frame > Remove Selected Frames.

‣

Click Remove Frames

button.

In Harmony Xsheet, go to Frame > Remove Selected Frames.
The Warning dialog box opens.

3. To complete the operation:
‣

Click Yes to delete the selection.

‣

Click No to only delete the exposure in the cell and not the frames.

‣

Select the Don’t Show This Message Again option to prevent the warning message from being
displayed each time you delete a frame range.

Related Topics
•

Adding Frames on page 445
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Layers and Columns
In Toon Boom Harmony there are two ways to see your layers:
•

As horizontal layers in the Timeline view

•

As vertical columns in the Xsheet view

In Harmony, you can also see your layers displayed in the Network view as modules.
Whether you work in the Timeline or Xsheet view, they are the same and any modification you do to one or the
other will be applied to both.

Related Topics
•

Layer and Column Concepts below

•

Adding New Drawing Layers on page 457

•

Deleting Layers and Columns on page 461

•

Modifying Layers on page 463

•

Duplicating Layers and Columns on page 471

•

Cloning Layers And Columns on page 472

•

Xsheet Thumbnails on page 473

•

Changing the Colour of a Layer or Column on page 473

•

Expanding and Collapsing Layers and Columns on page 476

•

Modifying the Look of the Column on page 477

When working in Harmony Xsheet, only the Xsheet view and its functionalities are available.

Layer and Column Concepts
In order to understand what happens when you duplicate a drawing, extend an exposure, create cycles or delete
a drawing, it is important to know how a layer works.
Each layer is linked to a directory, this is the location where all of that layers' drawings are saved. This directory
has the same name as the layer. When a value or drawing name is typed in a layer’s cell, the system looks in the
layer’s directory for the corresponding drawing to display. If there is no corresponding drawing, a new one is
created.
The layer’s cells are not used for storage, but are linked to the drawings contained in the layer’s directory. If you
remove a drawing from the layer exposure, it is not deleted, but is simply not displayed.
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When you create a drawing cycle, all of the repeated drawings are linked to the same original files. This means
that when you modify, repaint or correct a drawing named “1,” all drawings named “1” are updated
simultaneously. In order to modify a drawing independently from its other exposures, you must duplicate the
drawing.

Related Topics
•

Layers and Columns on the previous page

•

Layer Types below

•

Advanced Column Types on page 454

•

Layer Content on page 456

•

Adding New Drawing Layers on page 457

•

Deleting Layers and Columns on page 461

•

Modifying Layers on page 463

•

Duplicating Layers and Columns on page 471

•

Cloning Layers And Columns on page 472

•

Xsheet Thumbnails on page 473

•

Changing the Colour of a Layer or Column on page 473

•

Expanding and Collapsing Layers and Columns on page 476

•

Modifying the Look of the Column on page 477

•

Duplicating a Drawing on page 507

Layer Types
There are several types of layers that you can add in the Timeline view. Some layers are not represented the
same way in the Xsheet view.
•

Drawing Layer on the facing page
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•

Bitmap Layer below

•

Camera Layer on the next page

•

Effect Layer on the next page

•

Colour-Card Layer on the next page

•

Group Layer on page 453

•

Peg Layer on page 453

•

Quadmap Layer on page 453

•

Sound Layer on page 454

Drawing Layer

The most common layer type is the Drawing layer. Any time you need to create a vector drawing or import a
symbol, you can use a Drawing layer. In the Timeline view, the drawing layer is tagged with the Drawing
icon.

Bitmap images are contained in Bitmap layers.

Bitmap Layer

If you import picture or bitmap images in your project, they are inserted in a Bitmap layer. If you choose to
vectorize your image when you import, the Bitmap object will be placed on a Drawing layer. This way, you can
have bitmap images mixed with vector drawings on a Drawing layer.
When importing a bitmap image, you have the option of encapsulating the image in a symbol. If you place a nonvectorized bitmap into a symbol, you still will not be able to mix vector drawings with it on the same layer. If you
place a vectorized bitmap in a symbol, you must enter the symbol to be able to mix it with vector artwork.
In the Timeline view, the Bitmap layer is tagged with the Bitmap
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Camera Layer
You can only have one Camera layer at a time in your timeline. By default, there is no Camera layer when you
create a scene. You need to add a Camera layer when you want to create a camera motion.
In the Timeline view, the camera layer is tagged with the Camera

icon.

The Camera layer is not visible in the Xsheet view.

If you want to have several cameras with different settings, you can keep adding Camera layers in
your Timeline view (however, only one will ever be visible at a time as you can only have one camera
at a time in your timeline). To switch between the camera available, select Scene > Camera > select
the desired camera.

Effect Layer

To enhance the look of your scene, you can add effect layers and attach your drawings to them. In Toon Boom
Harmony, there is a series of effect modules in the Module Library view.
In the Timeline view, the Effect layer is tagged with the Effect

icon.

In the Xsheet view, you can see the Effect’s parameter columns in the Functions section when you select the
Effect layer in the Timeline view.

Colour-Card Layer

The Colour-Card layer is used to add plain colour background to your scene. By default, your scene has no
background colour and if you render it out as a QuickTime movie or image sequence it will have a black
background.
In the Timeline view, the Colour-Card layer is tagged with the Effect
The Colour-Card layer is not visible in the Xsheet view.
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Group Layer

A Group layer can be used to better organize both the Timeline and Network views. You can drag and drop
other layers onto a Group layer and then collapse the Group layer to hide these other layers from view.
If you create the Group layer in the Timeline, a corresponding module will appear in the Network view. Any layers
that you hook to the Group layer will appear in Group module hooked to an Input and Output port.

Peg Layer

A Peg layer can be described as a trajectory or motion path layer that does not contain drawings. This can be
attached to any drawing layer, cut-out puppet or other peg layers, they will all follow the trajectory you set in the
Peg layer.
In the Timeline view, the Peg layer is tagged with the Peg

icon.

In the Xsheet view, you can see the Peg’s function columns in the Functions section when you select the Peg layer
in the Timeline view.

Quadmap Layer
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A Quadmap layer can be described as a deformation transformation layer that does not contain drawings. This
can be attached to any drawing layer, cut-out puppet or even other peg layers they will all follow the
deformation you set in the Quadmap layer.
In the Timeline view, the Quadmap layer is tagged with the Quadmap

icon.

In the Xsheet view, you can see the Quadmap’s function columns in the Functions section when you select the
Quadmap layer in the Timeline view.

Sound Layer

You can import sound files to add dialog and sound effects to your project. The sound layer will be added to
your Timeline and Xsheet view when you import a sound file in your scene.
In the Timeline view, the Sound layer is tagged with the Sound

icon.

In the Xsheet view, the Sound layer is a dark grey colour.

Related Topics
•

Layers and Columns on page 449

•

Layer and Column Concepts on page 449

•

Advanced Column Types below

Advanced Column Types
In the Xsheet view, you can add several advanced column types:
•

Timing column

•

3D Path column

•

3D Rotation column

•

Bezier Curve column

•

Ease Curve column

•

Expression column

•

Annotation column

These columns are used to create particular animation paths. When you create those columns, they are not
linked to any particular drawing layer. You can create a motion path using these column and then attach several
drawing or peg layers to it.
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Related Topics
•

Timing Columns below

•

Annotation Columns on page 512

Timing Columns
Timing columns are unique in that they can reference a source folder outside of the project folder to bring
images into the project. An example of how this feature can be used is if you have many background scenes
created in a third party software that you might need to update in the future. By using Timing columns, you can
dynamically link your backgrounds, expose different backgrounds at different times, and have live, automatic
updating capabilities.

The danger with this type of dynamic linking is that if the project file is moved, or the folder that the
column is linked to is moved, then the link is broken and the images that were in that folder will
disappear in Toon Boom Harmony.

To use a Timing column:
1. In the Xsheet view, click on the Add Columns

button.

2. In the Add Column dialog box that appears, type in the name of the new column, then from the Type
drop-down menu select Timing.
3. Click OK if you are finished, or on the Apply button if you want to continue adding more columns and
column types.
A peach coloured column appears in your Xsheet with the name that you typed in, and for the moment,
<unused>.

4. In the Network view, add a new element module.
5. Open the Layer Properties editor by clicking on the yellow square.
6. In the Drawing tab, select the Timing Columns option.
7. In the Name field, enter the path of the folder you want to access. If you use the Browse button to locate a
folder, you will have to select a file in the folder you want and then delete the dash and the suffix (for
example, background-01 should be renamed to background) from the file name in the field. If you
leave the full file name selected, Stage will display that file for the entire duration of the scene, regardless
of the contents of the Timing Column field.
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This means that all the images in the folder that you are linking to are named using the naming
convention described above. If for some reason you are unable to access a certain directory, type the
directory extension directly in the path extension field at the top of the Browser window.

8. In the Timing Column field, click the Arrow button to create a new timing column, or select the name of
the column from the drop-down list. If you have an element directory selected in the Name field, the
Timing Column will indicate which files are called up from that element directory. Remember that the file
displayed at each frame is based on the element name, the cell label, and the extension. If the element is
toto, the timing column is labeled 1, 2, and 3, and the extension is TVG, Stage will display drawings
totobody-1.tvg, totobody-2.tvg, and totobody-3.tvg at the selected frames.

In the Xsheet, the <unused> should now have changed to the name of your module in the Network view.
9. From the Extension drop-down list, select the extension of the files you want to display.
10. Click OK when you are done.
11. In the Xsheet, in your Timing column, type in the number that corresponds to the suffix of the drawing file
that you wish to expose to make it appear in the Camera view.

Related Topics
•

Layers and Columns on page 449

•

Layer and Column Concepts on page 449

•

Advanced Column Types on page 454

•

Timing Columns on the previous page

•

Linking your Layer to an External Image on page 581

Layer Content
There are two types of elements that can be inserted in a drawing layer’s cell:
•

Vector drawings

•

Symbols

A layer can contain the two different elements, but only in different cells. You cannot put two symbols or a
drawing and a symbol into the same cell.
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If you want to mix bitmap images in your Drawing layers, you must first import your bitmap image as a symbol or
turn it into a symbol and insert it in your Drawing layer by dragging the symbol cell there through the Timeline.

Refer to What is a Symbol? on page 626 to learn more about symbols.

Related Topics
•

Layers and Columns on page 449

•

Layer and Column Concepts on page 449

•

Timing Columns on page 455

•

Advanced Column Types on page 454

•

Symbols on page 637

Adding New Drawing Layers
In this section, you will learn the different ways to add a drawing layer to your project. By default, when you
create a new scene there is one Drawing layer included in your Timeline view.
This topic is divided as follows:
•

Adding Drawing Layers in the Timeline View below

•

Adding a Drawing Layer from the Top Menu on the next page

•

Adding Drawing Columns in the Xsheet View on page 459

Adding Drawing Layers in the Timeline View
You can add a new layer in the Timeline view in several different ways:
•

Using the Layer toolbar

•

Using the Add Layers dialog box

•

Go to the Timeline view menu and select Insert > Drawing.

To add a Drawing layer using the Timeline’s Layer toolbar:
1. In the Timeline’s Layer toolbar, click the Add Layers
[⌘ ] + [R] (Mac OS X).
2. In the drop-down menu, select the Drawing option.
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A new layer appears in the Timeline and Xsheet views.

You can also click on the Add Drawing Layer button in the Timeline’s Layer toolbar or press [Ctrl] + [R]
(Windows/Linux) or [⌘] + [R] (Mac OS X).

To add drawing layers using the Add Layers dialog box:
1. In the Timeline view’s layer section,right-click and select Insert > Add Layer(s).
The Add Layers dialog box opens.

2. In the Type drop-down menu, select the Drawing option.
3. In the Number field, use the up and down arrows or type the number of layers you want to add at once.
4. In the Name field, type the name of the layer you want to add. If you are adding more than one layer at
once, all of the layers use that name with a numerical suffix added.
5. To complete the operation:
‣

Click OK to add your new layers and close the dialog box.

‣

Click Apply to add your new layers and keep the dialog box open to add another layer.

‣

Click Close to cancel the operation.

Adding a Drawing Layer from the Top Menu
You can add a new layer from the top menu.
To add a new layer from the top menu:
1. In the top menu, select Insert > Drawing.
A new layer appears in the Timeline and Xsheet views.
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Adding Drawing Columns in the Xsheet View
To add a drawing column:
1. Do one of the following:
‣

In the Xsheet view, right-click and select Columns > Add Column.

‣

In the Xsheet View toolbar, click the Add Columns

‣

To quickly add a Drawing column, press [Ctrl] + [R] (Windows/Linux) or [⌘ ] + [R] (Mac OS X).

button or press [Shift] + [C]].

The Add Columns dialog box opens.

2. In the Column Name field, name your column accordingly.
3. In the Column Type field, select Drawing.

Refer to the topic Layer Types on page 450 to know more about the different column types available.

4. To complete the operation:
‣

Click OK to add your new layers and close the dialog box.

‣

Click Apply to add your new layers and keep the dialog box open to add column.

‣

Click Close to cancel the operation.

In Harmony, you can use the advanced Add Column dialog box, with more file format and field size options, to
insert the column.
To create a column in Toon Boom Harmony using the advanced Add Column dialog box:
1. Select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X) and select the
Advanced tab.
2. In the Advanced Options section, select the Advanced Element Mode option to access the advanced
Add Column dialog box.
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3. Click OK.
4. In the Xsheet View menu, select Columns > Add Column or press [Shift] + [C].
The Add Column dialog box opens.

5. In the Name field, type the new column’s name.
6. In the Type drop-down menu, select the Drawing type.
7. In the Element section select if you either want to create a new column or link the new column to an
existing one:
‣

Create New Element: Select this option if you want your column to be an independent column with
its own drawing folder.

‣

Reuse Existing Folder: Select this option if you want to link your column to an existing folder within
the Element folder of your scene.
If you select the Reuse Existing Folder option, in the Folder drop-down field, select the folder to
which you want to link your new column.

‣

Use Existing Element: Select this option if you want your column to use drawings from an existing
column. Both columns will be attached to the same set of drawings, but their timing will remain
independent from one another. If you modify one of the drawings, it will be modified in both columns.
This is the same principle as the Clone column.
If you select the Use Existing Element option, in the Name drop-down field, select the column to
which you want to link your new column.

8. If you select the Create New Element option:
‣

Deselect the Vector option if you want your layer to contain bitmap images or enable it if you want the
layer to contain vector drawings. Most of the time, the Vector option will be enabled.

‣

If you deselected the Vector option, from the Bitmap Format drop-down list, select which type of
bitmap image you wish to insert in the column. Select the SCAN type if you are planning to scan
drawings using Toon Boom Harmony’s scan module.
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‣

If you deselected the Vector option and you chose the SCAN type, from the Scan Type drop-down,
select what kind of scanning you wish to achieve.

‣

In the Field Chart field, when importing traditional animation, indicate the size of paper on which the
animation or background was drawn. If you are not using perforated animation paper, leave the 12
field default value as is.

9. Do one of the following:
‣

Click OK button to create the new column and close the dialog box.

‣

Click Apply to create the new column but keep the dialog box opened to create other new columns.

Related Topics
•

Layers and Columns on page 449

•

Layer and Column Concepts on page 449

•

Advanced Column Types on page 454

•

Layer Content on page 456

•

Adding New Drawing Layers on page 457

•

Deleting Layers and Columns below

•

Modifying Layers on page 463

•

Duplicating Layers and Columns on page 471

•

Cloning Layers And Columns on page 472

•

Xsheet Thumbnails on page 473

•

Changing the Colour of a Layer or Column on page 473

•

Expanding and Collapsing Layers and Columns on page 476

•

Modifying the Look of the Column on page 477

Deleting Layers and Columns
You can delete layers from your projects in two different locations:
•

Deleting a layer from the Timeline view

•

Deleting a column from the Xsheet view

Deleting a Layer from the Timeline View
There are two ways to delete a layer in the Timeline view, using the Delete Layers
access menu. This will also delete the associated modules from the Network view.
To delete layers in the Timeline view:
1. In the Timeline view, select the layers to be deleted.
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2. In the Timeline’s Layer toolbar, click the Delete Layers

button.

You can also right-click on the selection and select Delete.
The Confirm Delete dialog box opens.

‣

Select the Delete Drawing Files and Element Folders option to delete all drawings and folder linked
to this layer.

3. Select the Delete Xsheet Columns option if you also want to delete the existing column in the Xsheet
view.

Deleting a Column from the Xsheet View
There are two ways to delete a layer in the Xsheet view, using the Delete Columns

button and via the quick

access menu.
To delete layers in the Xsheet view:
1. In the Xsheet view, select the columns to be deleted by clicking on their header.

2. In the Xsheet View toolbar, click the Delete Columns

button. You can also right-click on the selection

and select Delete Columns or press [Delete].
The Confirm Delete dialog box opens.

‣

Select the Delete Drawing Files and Element Folder option if you want to delete the drawings and
folders linked to the selected column.

3. To complete the operation:
‣

Click OK to delete the selected layers.
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‣

Click Cancel cancel the operation.

‣

Click Yes button delete all the frames from your scene.

‣

Click No button to keep the frames in your scene.

‣

Select the Don’t Show This Message Again option if you do not want the dialog box to pop again in
the future.

Related Topics
•

Layers and Columns on page 449

•

Layer and Column Concepts on page 449

•

Advanced Column Types on page 454

•

Layer Content on page 456

•

Adding New Drawing Layers on page 457

•

Deleting Layers and Columns on page 461

•

Modifying Layers below

•

Duplicating Layers and Columns on page 471

•

Cloning Layers And Columns on page 472

•

Xsheet Thumbnails on page 473

•

Changing the Colour of a Layer or Column on page 473

•

Expanding and Collapsing Layers and Columns on page 476

•

Modifying the Look of the Column on page 477

Modifying Layers
Once you added layers to your project, you can modify their properties, name or ordering.

Related Topics
•

Ordering Layers and Columns on the next page

•

Showing and Hiding Layers From the Timeline View on page 465

•

Showing and Hiding Columns on page 466

•

Layer Properties on page 469

•

Renaming Layers and Columns on page 470
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Ordering Layers and Columns
You can change the order of your layers in the Timeline and Xsheet views. When you change the order of your
layers in one of these views, the other one is updated.

Reordering Layers in the Timeline View
To reorder layers in the Timeline view:
1. In the Timeline view, select the layers to move.
2. Drag the selection to the new location and drop it in between the existing layers. Dropping the selection
on an existing layer would create a hierarchy. Layers located on top of the Timeline view are displayed in
front of the other ones. Layers located at the bottom are displayed behind.

Reordering Columns in the Xsheet View
You can reorder columns in the Xsheet view using the mouse’s middle button.
To reorder columns in the Xsheet view:

‣ In the Xsheet view, click on the column’s header with the middle mouse button and drag the column to its
new position.

Related Topics
•

Layers and Columns on page 449

•

Modifying Layers on the previous page

•

Showing and Hiding Layers From the Timeline View on the facing page

•

Showing and Hiding Columns on page 466

•

Layer Properties on page 469

•

Renaming Layers and Columns on page 470
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Showing and Hiding Layers From the Timeline View
As you work in the Drawing or Camera view, some layers may be in the way or are used as references. You can
hide these layers to make your work area easier and less cluttered. You can show and hide layers in the Timeline
view in several different ways.
To show or hide all layers in the Timeline view:

‣ In the Timeline’s Layer toolbar, click the Enable/Disable All
also click the Enable All

button to show or hide all layers. You can

button located in the Timeline view toolbar’s extra buttons.

To show or hide individual layers in the Timeline view:

‣ In the Timeline’s Layer toolbar, deselect the layer’s checkbox to disable a particular layer. Select the
layer’s checkbox to enable a particular layer. You can also click the Enable/Disable

button located in

the Timeline View toolbar’s extra buttons.

When you disable a layer in the Timeline view, the corresponding column is hidden in the Xsheet view.
To disable all layers but the selected one:

‣ In the Timeline’s Layer toolbar, click the Show Selection and Hide All Others

button to show only

the currently selected layer and disable all the other layers. You can also click the Disable All Others
button located in the Timeline View toolbar’s extra buttons.

In the Timeline view, you can hide or show certain types of layers such as Group and Effect.
To show and hide layer types in the Timeline view:
1. In the Timeline View menu, select View > Show > Show Manager.
‣

You can also select View > Show > Show Sounds, Show Effects or Show Groups to immediately
show or hide the selected type. This option will remain only for the current session. Once the
application is closed and reopened, the default settings will return.

The Show Manager dialog box opens.
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2. Select the types of layers you want to display and deselect the ones you want to turn off.
3. Click Set As Default to make these new settings the default ones that will be used each time to start the
application. Click Restore Default to restore the settings used when installing the application.
In the Xsheet view, you have the choice of hiding or showing certain types of columns such as Annotation
and Functions.
To show and hide layer types in the Timeline view:
1. In the Xsheet View menu, select View > Column Types Manager.
The Column Types dialog box opens.

2. Select the types of columns you want to display and disable the ones you want to hide.
3. Click Set As Default to make these new settings the default ones that will be used each time to start he
application. Click Restore Default to restore the settings used when installing the application.

Related Topics
•

Layers and Columns on page 449

•

Modifying Layers on page 463

•

Showing and Hiding Columns below

•

Layer Properties on page 469

•

Renaming Layers and Columns on page 470

Showing and Hiding Columns
The Xsheet view has a Column List section that shows all the columns contained in the exposure sheet. It can be
used to hide individual columns.
If you need to see a column after it has been hidden, you can display it directly from the Xsheet view without
using the Column List section.
You can also hide an entire column type, such as Drawing or Sound.
When a column is hidden in the Xsheet view, the corresponding layer is disabled in the Timeline view.
To show or hide columns in the Xsheet view:
1. In the Xsheet View toolbar, click the Show Column List

button.

2. Click the Expand button on the right side of the Functions section to display the Column List section.
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3. In the Column List section, select the columns to display and deselect the columns to hide. You can also
click the Hide Selected Column
button in the Xsheet View toolbar’s extra buttons.

To show a hidden column from the Xsheet view:
1. In the Xsheet view, click on the thick grey line that represents a hidden column. You can also right-click on
the column header and select Show Hidden Columns.

The Show Hidden Columns dialog box opens.

2. In the Show column, select the hidden columns you want to display in the Xsheet view.
‣

Click Check to select all the selected columns.

‣

Click Uncheck to deselcted all selected columns.

In Toon Boom Harmony, in the Xsheet view menu, you can select View > Unhide All Columns.
To hide a column type:
1. In the Column List section, click the Column Type button corresponding to the type you want to show or
hide.

‣

The Show/Hide All Columns

button shows or hides every column available in the Xsheet view.

‣

The Show Drawing Columns

button shows the Drawing columns.
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‣

The Show Function Columns

‣

The Show 3D Path Columns

‣

The Show Sound Columns

‣

The Show 3D Rotation Columns

button shows the 3D Rotation columns.

‣

The Show Annotation Columns

button shows the Annotation columns.

button shows the Bezier and Ease function columns.
button shows the 3D Path function columns.
button shows the Drawing columns.

To show or hide function columns on the left side of the Xsheet view:
‣

Right-click on a column and select Tag > Function Columns Visible or Function Columns Invisible.

Column Types Manager
As you work in Harmony Xsheet, some columns may be in the way or are used as references. You can hide these
columns to declutter your work area. In the Xsheet view, you can hide or show certain types of columns, such as
Annotation and Function.
To show and hide column types:
1. In the Xsheet View menu, select View > Column Types Manager.
The Column Types dialog box opens.

2. Select the types of columns you want to display and deselect the ones you want to hide.
3. Click Set As Default to make these new settings the default ones used each time you start the
application. Click Restore Default to restore the settings used when installing the application.

Related Topics
•

Layers and Columns on page 449

•

Modifying Layers on page 463

•

Showing and Hiding Layers From the Timeline View on page 465

•

Layer Properties on the facing page

•

Renaming Layers and Columns on page 470
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Layer Properties

Each layer has its own set of properties that can be modified, including effect and peg layers.
Display the Layer Properties editor if you want to modify some of the layer’s properties such as the name or the
antialiasing quality. You can display the editor from the Timeline or Network view or open the Layer Properties
as a view of its own.
The Xsheet column will not open the Layer Properties dialog box, it will show the Column Properties allowing
you to modify settings related to the Xsheet column.

The Drawing Layer Properties editor allows you to:
•

Rename the layer

•

Enable or disable the layer
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•

Lock the layer

•

Change the track colour

•

Activate the onion skin preview

•

Adjust the positioning and animation parameters

•

Adjust many other advanced parameters

To display the Layer Properties editor:
1. Do one of the following:
‣

In the Timeline view, double-click on a layer or press [Shift] + [E].

‣

In the Network view, click on the module’s yellow properties button.

‣

In the top menu, select Windows > Layer Properties.

2. In the Timeline or Xsheet view, select the layer whose properties you want to view.
To display the Column Properties Editor from the Xsheet view:
1. In the Xsheet view, double-click on a column’s header or press [Shift] + [E].

Related Topics
•

Layers and Columns on page 449

•

Modifying Layers on page 463

•

Showing and Hiding Layers From the Timeline View on page 465

•

Showing and Hiding Columns on page 466

•

Renaming Layers and Columns below

•

Adding New Drawing Layers on page 457

Renaming Layers and Columns
You can rename a layer in two different ways; in the Layer Properties editor or directly on the Timeline’s layer.
To rename a layer in the Timeline view:
1. In the Timeline view, double-click on the name of the layer to rename.
2. In the Name field, rename the layer and press [Enter/Return] to validate the modifications.

To rename a layer in the Layer Properties editor:
1. In the Timeline view, double-click on the layer to rename.
The Layer Properties editor opens.
2. In the Name field, rename the layer.
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3. Click Close.
To rename a column:
1. In the Xsheet view, double-click on the column name to rename. Do not click on the drawing folder name
that the column is linked to (this also appears in the column header just below the column name).
The Column Editor dialog box opens.

2. In the Name field, rename the column.
3. Click OK.
4. Click Apply/Next to apply the new name and open the editor for the following column.

Related Topics
•

Layers and Columns on page 449

•

Modifying Layers on page 463

•

Showing and Hiding Columns on page 466

Duplicating Layers and Columns
Duplicating a layer provides you with an independent copy of the drawings and their exposure. You can modify
anything you want in the duplicated layer without affecting the original one. In the Network view, you can
duplicate the selected modules in the same way.
To duplicate a layer:
1. In the Timeline or Xsheet view, click the layer you want to duplicate.

2. Select Edit > Duplicate or click the Duplicate Layer

button in the Xsheet View toolbar and

TimelineView toolbar.
In Harmony Xsheet, select Edit > Duplicate Selected Element.
The new duplicated layer or column appears.

Related Topics
•

Layers and Columns on page 449

•

Layer and Column Concepts on page 449

•

Advanced Column Types on page 454

•

Layer Content on page 456
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•

Adding New Drawing Layers on page 457

•

Deleting Layers and Columns on page 461

•

Modifying Layers on page 463

•

Cloning Layers And Columns below

•

Xsheet Thumbnails on the facing page

•

Changing the Colour of a Layer or Column on the facing page

•

Expanding and Collapsing Layers and Columns on page 476

•

Modifying the Look of the Column on page 477

Cloning Layers And Columns
Cloning a layer provides you with a copy of the selected layer that uses the same drawings as the original. If you
modify a drawing in the cloned or original layer it is updated in both layers. You can modify the layers’ timing
independently one from the other, but the drawings remain linked. You can clone selected modules from the
Network view in the same way.
This feature is useful when you want to reuse a hand-drawn animation but have different timings.
To clone a layer:
1. In the Timeline or Xsheet view, click on the layer you want to clone.

2. Select Edit > Clone or click the Clone Layer

button in the Xsheet View toolbar and Timeline View

toolbar.
In Harmony Xsheet, select Edit > Clone Selected Columns.
The new cloned layer or column appears.

Related Topics
•

Layers and Columns on page 449

•

Layer and Column Concepts on page 449

•

Advanced Column Types on page 454

•

Layer Content on page 456

•

Adding New Drawing Layers on page 457

•

Deleting Layers and Columns on page 461

•

Modifying Layers on page 463

•

Duplicating Layers and Columns on the previous page

•

Xsheet Thumbnails on the facing page

•

Changing the Colour of a Layer or Column on the facing page
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•

Expanding and Collapsing Layers and Columns on page 476

•

Modifying the Look of the Column on page 477

Xsheet Thumbnails
When there are a large number of columns in the exposure sheet, it is not always easy to quickly identify a
particular column. Displaying the column thumbnails makes this easier. This option displays a small thumbnail
picture of the current frame below the column header.
To display the thumbnails:
1. In the Xsheet view, click the Show Thumbnails

button.

The thumbnails appear.

Related Topics
•

Layers and Columns on page 449

•

Layer and Column Concepts on page 449

•

Advanced Column Types on page 454

•

Layer Content on page 456

•

Adding New Drawing Layers on page 457

•

Deleting Layers and Columns on page 461

•

Modifying Layers on page 463

•

Duplicating Layers and Columns on page 471

•

Cloning Layers And Columns on the previous page

•

Changing the Colour of a Layer or Column below

•

Expanding and Collapsing Layers and Columns on page 476

•

Modifying the Look of the Column on page 477

Changing the Colour of a Layer or Column
To easily identify layers in your Timeline and Xsheet views, you can change their colour.
To change the layer’s colour in the Timeline view:
1. Do one of the following:
‣

In the Timeline view, click the colour swatch of the layer you want to modify.
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‣

Select a layer and click the Change Track Colour

button in the Timeline View toolbar’s extra

buttons.

2. In the Colour Picker window, select a new colour for your layer and click OK.

The layer’s colour is updated.

To reset a layer’s colour in the Timeline view:
1. In the Timeline view, select the layers to reset and click the Default Track Colour
Timeline View toolbar’s extra buttons.
To change a column’s colour in the Xsheet view:
1. In the Xsheet view, select one or more columns to modify.
2. Right-click on the column’s header and select Colour > Change Columns Colour.
3. In the Colour Picker window, select a new colour for your columns and click OK.
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The column’s colour is updated.

To reset the column’s colour in the Xsheet view:
1. In the Xsheet view, select the columns to reset and right-click on the column’s header and select Colour >
Default Columns Colour.

Related Topics
•

Layers and Columns on page 449

•

Layer and Column Concepts on page 449

•

Advanced Column Types on page 454

•

Layer Content on page 456

•

Adding New Drawing Layers on page 457

•

Deleting Layers and Columns on page 461

•

Modifying Layers on page 463

•

Duplicating Layers and Columns on page 471

•

Cloning Layers And Columns on page 472

•

Xsheet Thumbnails on page 473

•

Expanding and Collapsing Layers and Columns on the next page

•

Modifying the Look of the Column on page 477
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Expanding and Collapsing Layers and Columns
To simplify the look of your Timeline and Xsheet view, you can collapse and expand your layers. If some layers are
parented to other ones, you can collapse the parent layer to hide all of its children. You can also collapse 3D Path
columns in the Xsheet view.
To collapse/expand a layer selection in the Timeline view:
1. In the Timeline view, select the layer(s) to collapse or expand.
2. Do one of the following:
‣

Right-click on the selection and select Collapse/Expand > Collapse/Expand.

‣

Click the Expand Children Arrow

‣

Press [Ctrl] + [I] (Windows/Linux) or [⌘ ] + [I] (Mac OS X).

‣

Click the Collapse/Expand

button on the parent layer.

button in the Timeline View toolbar’s extra buttons.

To collapse or expand all layers in the Timeline view:
Do one of the following:
‣

Right-click on the layers and select Collapse/Expand > Expand All or Collapse All.

‣

Press [0] and [9].

‣

Click the Collapse All

or Expand All

buttons in the Timeline View toolbar’s extra buttons.

To collapse and expand 3D Path columns in the Xsheet view:
1. In the Xsheet view, display the Functions section by clicking the Show Column List

button.

2. In the Functions section, select the header of the 3D Path column to collapse.
3. Do one of the following:
‣

Right-click on the column’s header and select Expand/Collapse > Collapse Selection.

‣

To expand a collapsed column, select the column’s header, right-click on the selection and select
Expand/Collapse > Expand Selection.

‣

Click the Collapse Selection

or Expand Selection

buttons in the Xsheet View toolbar’s

extra buttons.
To collapse or expand all 3D Path columns in the Xsheet view:
Do one of the following:
‣

Right-click on any column’s header and select Collapse/Expand > Expand All or Collapse All.

‣

The [0] and [9].

‣

Click the Collapse All

or Expand All

buttons in the Xsheet View toolbar’s extra buttons.
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Related Topics
•

Layers and Columns on page 449

•

Layer and Column Concepts on page 449

•

Advanced Column Types on page 454

•

Layer Content on page 456

•

Adding New Drawing Layers on page 457

•

Deleting Layers and Columns on page 461

•

Modifying Layers on page 463

•

Duplicating Layers and Columns on page 471

•

Cloning Layers And Columns on page 472

•

Xsheet Thumbnails on page 473

•

Changing the Colour of a Layer or Column on page 473

•

Modifying the Look of the Column below

•

Modifying the Look of the Column
In Toon Boom Harmony 10.3, you can modify the way the column displays drawings, empty cells and the column
width.
You can modify the following elements:
•

Empty Cells

•

Row Units

•

Held Exposure

•

Column Width

To modify the look of an empty cells:

‣ In the Xsheet View menu, select View > Empty Cells > With an “X” or Blank.

To modify the row units:

‣ In the Xsheet View menu, select View > Row Units > Frames or Feet.
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To modify the held exposure’s look:

‣ In the Xsheet View menu, select View > Held Exposures > Line or Value.

To modify the column’s width:
1. In the Xsheet view, select any column to modify the width.
2. In the Xsheet view menu, select View > Set Columns Width.
The Xsheet Column Width dialog box opens.

3. In the Column Width field, type the desired width in pixel.
4. To end the operation:
‣

Click on the OK button to validate and close the dialog box.

‣

Click on the Apply button to validate the operation and keep the dialog box opened to adjust the
next column’s width.

‣

Click on the Set As Default to create all the new columns to this width.

‣

Click on the Close button to cancel the operation.

5. To restore all columns to the default value, in the Xsheet view menu, select All Columns to Default
Width.

Related Topics
•

Layers and Columns on page 449

•

Layer and Column Concepts on page 449

•

Advanced Column Types on page 454

•

Layer Content on page 456

•

Adding New Drawing Layers on page 457
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•

Deleting Layers and Columns on page 461

•

Modifying Layers on page 463

•

Duplicating Layers and Columns on page 471

•

Cloning Layers And Columns on page 472

•

Xsheet Thumbnails on page 473

•

Changing the Colour of a Layer or Column on page 473

•

Expanding and Collapsing Layers and Columns on page 476
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Filling Exposure
Toon Boom Harmony provides different tools to fill-in exposures and values, create cycles, and set increments.

Related Topics
•

Filling Exposure Mode below

•

Typing Exposure on the facing page

•

Holding Exposure on page 483

•

Extending a Single Exposure on page 484

•

Extending an Exposure Sequence on page 484

•

Dragging Cells on page 485

•

Increasing and Decreasing Exposure on page 488

•

Inserting Blank Cells on page 492

•

Setting the Exposure on page 493

•

Filling a Selection with a Single Exposure on page 494

•

Filling a Selection with a Sequence on page 495

•

Filling a Selection Randomly on page 497

•

Creating Cycles on page 498

Filling Exposure Mode
In the Xsheet view, you can fill columns using two different filling modes: Overwrite or Insert. These modes
control the filling behaviour. The Timeline view only uses the Overwrite mode.
To toggle between Overwrite and Insert modes:

‣ In the Xsheet view’s right bottom corner, click the Overwrite/Insert button or press [I].

Overwrite Mode
By default, the Xsheet view is set to Overwrite mode. Add a new value or a new value sequence overwrites
existing ones. The existing timing sequence remains in the same place and is not pushed further down the
column.
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Insert Mode
The Insert mode is the opposite of the Overwrite mode. When you add a new value or a new value sequence over
existing ones, the new values are inserted between the old ones. The existing timing sequence is pushed down
the column.

Related Topics
•

Filling Exposure on the previous page

•

Filling Exposure Mode on the previous page

Typing Exposure
To fill in your exposure, you can directly type the values in the Xsheet and Timeline views.
•

Typing a Value in the Timeline View below

•

Typing a Value in the Xsheet View on the next page

Typing a Value in the Timeline View
If you want to type an exact drawing name or value into the Timeline view, you must use the Data view section of
the Timeline.
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You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).

To type a value in the Timeline view:
1. In the Timeline view, click the Show Data View

button.

2. In the Drawing Substitution field, type the name of the drawing you want to create, and press
[Enter/Return].

Typing a Value in the Xsheet View
To enter a value in a column’s cell, double-click in the cell and type the numbers or letters.

You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).

•

Press [Enter/Return] to move on to the next cell.

•

Press [Esc] to exit the typing mode and return to normal mode.

To type values in the Xsheet view:
1. In an Xsheet column, double-click on one cell.

2. Type a value or drawing name in the cell.

3. Press [Enter/Return] to move on to the next cell.

4. Press [Esc] to quit the typing mode.
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Related Topics
•

Filling Exposure on page 480

Holding Exposure
Drawings in an animation are not always exposed on a single frame, they are often exposed for more than one
frame. The most common exposure of a drawing is two frames. In the industry, this type of exposure is known as
animation in double frames. A drawing can also be exposed for three, four, five cells and so on. To prevent
mistakes and to save time, the Xsheet lets you hold your cells automatically as you type.
The Xsheet’s Set Exposure option allows you to choose how many frames you want to hold your exposure for.

•

This option is only available in the Xsheet view.

•

The selected Set Exposure, the settings will be kept from session to session. You will not
have to set them every time you use Toon Boom Harmony

To hold exposure:
1. In the Xsheet View menu, select Exposure > Hold 2 Cells.
2. Right-click the Xsheet view and select Exposure > Set Exposure To > Set Exposure to 1, 2, 3, or Set
Exposure.
In the Harmony Xsheet, select Option > Hold 2 Cells.
3. Type a value or drawing name in the cell.
‣

Press [Enter/Return] to move on to the next cell.

‣

Press [Esc] to quit the typing mode.

‣

If you selected Set Exposure, the Set Exposure dialog box opens. You can hold as many cells as
needed.
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Related Topics
•

Filling Exposure on page 480

Extending a Single Exposure
The Extend Exposure feature allows you to select an Xsheet’s cell containing a value and to pull it down to the
desired frame.
To extend a cell exposure:
1. In the Xsheet view, select the red arrow

in the cell’s right side. Make sure you see the drag down

cursor.

2. Pull down the selected cell to the desired frame.

The red selection box must be visible when releasing the mouse button. If not, the action is
considered cancelled.

Related Topics
•

Filling Exposure on page 480

Extending an Exposure Sequence
You can extend and create a sequence using almost the same procedure as you would when you extend a single
exposure. The only differences being that the selected cell must only contain numbers and that you need to press
the [Shift] key while pulling down on the selection.

The creation of the sequence only works with numbers in the selected cell, not letters.
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To create a sequence:
1. In the Xsheet view, select a cell containing a number.
2. In the selected cell, click on the red arrow on the cell’s right side. Make sure to see the drag down
cursor.

3. Hold down the [Shift] key. Make sure a plus (+) sign appears.
4. Pull down the selection box to the desired frame.

The red selection box must be visible when releasing the mouse button. If it is not visible, the action
is considered as cancelled.

5. First release the [Shift] key, then release the mouse button.

You can also select a cell and select Animation > Cell > Extend Exposure or press [F5]. In the dialog
box, type the frame number you want to extend the cell to.

Related Topics
•

Filling Exposure on page 480

Dragging Cells
To readjust your timing, you can drag one or several cells to a new location in both the Timeline and Xsheet
views.
You can drag a cell to any other frame in the same column or into another column.
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To drag a cell to another location in the Timeline view:
1. In the Timeline view, select one or several cells to move.

2. Click on the cells selection and drag it to the new location.

‣

If you drop the selection, it overwrites the existing cells.

‣

If you hold [Ctrl] (Windows/Linux) or [⌘ ] (Mac OS X) while dropping the selection, the cells are copied
and not moved.

‣

If your press [Shift] while dropping, the selection is inserted between the existing frames.

To drag a cell to another location in the Xsheet view:
1. In the Xsheet view, select one or more cells.

2. In the Xsheet view, select the small dotted area

on the left side of the selected cells.

3. Drag the selection to any other cell in the same column or in another column.

486

Toon Boom Harmony 10.3 Stage User Guide

‣

If you drop the selection, it overwrites the existing cells.

‣

If you hold [Ctrl] (Windows/Linux) or [⌘ ] (Mac OS X)while dropping the selection, the cells are copied
and not moved.

‣

If your press [Shift] while dropping, the selection is inserted between the existing frames.

You can turn off the Gestural Drag Mode for the Xsheet view to prevent drawings from being dragged from one
location to another. A Toggle Gestural Drag Mode button is available for this feature, accessible by customizing
the Xsheet View toolbar. Otherwise, access it by right-clicking on a cell or the Xsheet's Edit menu.
To turn off the Gestural Drag mode:

‣ In the Xsheet view, right-click and deselect the Gestural Drag Mode option.
487

Chapter 7: Timing Filling Exposure

‣ You can also customize the Xsheet View toolbar and display the Toggle Gestural Drag mode button to
enable and disable this option.

The dragging pad disappears when the Gestural Drag mode is off.

This feature does not apply for Annotation columns.

Related Topics
•

Filling Exposure on page 480

Increasing and Decreasing Exposure
Once a value is entered in the Timeline or Xsheet view, you can increase and decrease its exposure.

Related Topics
•

Increasing Exposure below

•

Decreasing Exposure on the facing page

•

Increase/Decrease Exposure Field on page 490

•

Clear Exposure and Pull on page 490

Increasing Exposure
Increasing the exposure adds one more exposure to a selected cell, repeating this action adds an extra cell every
time. This is a quick way of extending a drawing exposure and is always set in the Insert mode. Increasing an
exposure always pushes the existing exposure down.
To use Increase Exposure:
1. In the Timeline or Xsheet view, select a cell.
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2. Do one of the following:
‣

In the top menu, select Animation > Cell > Increase Exposure.

‣

Right-click on the selected cell and select Exposure > Increase Exposure.

‣

Press [+].

‣

In Harmony Xsheet,select Selected > Increase Exposure.

‣

Click the Increase Exposure

button in the Xsheet View and Timeline View toolbars’ extra buttons.

3. Repeat this action to add more cells to your drawing’s exposure.

Related Topics
•

Decreasing Exposure below

•

Increase/Decrease Exposure Field on the next page

Decreasing Exposure
Decreasing the exposure removes one exposure from a selected cell. Repeating this action removes an extra cell
every time. This is a rapid way to reduce a drawing exposure and remove the exposed drawing.
To decrease exposure:
1. In the Timeline or Xsheet view, select a cell.

2. Do one of the following:
‣

In the top menu, select Animation > Cell > Decrease Exposure.

‣

Right-click on the selected cell and select Exposure > Decrease Exposure.

‣

Press [-].

In Harmony Xsheet,select Selected > Decrease Exposure.
‣

Click the Increase Exposure

button in the Xsheet View and Timeline View toolbars’ extra buttons.

3. Repeat this action to decrease more cells to your drawing’s exposure.
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Related Topics
•

Increasing and Decreasing Exposure on page 488

•

Clear Exposure and Pull below

Increase/Decrease Exposure Field
Another technique you can use to quickly increase or decrease the exposure of a selected drawing is by making
use of the Increase/Decrease Exposure field available in the Xsheet view.
To increase and decrease exposure using the Increase/Decrease Exposure field:
1. In the Xsheet view, select the cell to modify.

2. In the Xsheet’s bottom-right corner, increase or decrease the drawing’s exposure by clicking the up or
down arrows. To increase the exposure, press [+]. To decrease the exposure, press [-].

Related Topics
•

Increasing and Decreasing Exposure on page 488

•

Decreasing Exposure on the previous page

•

Clear Exposure and Pull below

Clear Exposure and Pull
You can reduce a drawing’s exposure using the Clear Exposure and Pull option.
To use the Clear Exposure and Pull feature:
1. In the Timeline or Xsheet view, select a cell.
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2. Do one of the following:
‣

In the top menu, select Animation > Cell > Clear Exposure and Pull.

‣

Right-click on the selected cell and select Exposure > Clear Exposure and Pull.

‣

In Harmony Xsheet, select Selected > Clear Exposure and Pull.

‣

Click the Clear Exposure

‣

Press [Z].

button in the Xsheet View and Timeline View toolbars’ extra buttons.

Related Topics
•

Increasing and Decreasing Exposure on page 488

Deleting Exposure
You can delete a drawing’s exposure in several simple ways. Note that when you delete a drawing’s exposure
from the Timeline or Xsheet view, you are not deleting the actual drawing file. You can always bring it back by
typing its name again in a cell.
You can delete the exposure contained in a selected cell range or delete the entire exposure of a drawing
exposed over several cells. Note that you can also delete the exposure for drawings contained inside a collapsed
group.
To delete selected exposures:
1. In the Timeline or Xsheet view, select the exposure you want to delete.
2. Right-click on the selection and select Delete or press [Delete].
To completely clear the exposure of a drawing:
1. In the Timeline or Xsheet view, select a cell of a drawing exposed over several cells.
2. Do one of the following:
‣

In the top menu, select Animation > Cell > Clear Exposure.

‣

In the Timeline view, right-click on the selection and select Exposure > Clear Exposure.

‣

Click the Clear Exposure

button in the Timeline View toolbar’s extra buttons.

Related Topics
•

Filling Exposure on page 480

•

Layer and Column Concepts on page 449
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Inserting Blank Cells
Use the Insert Blank Cell option to place an empty cell between other cells. This is always done in Insert mode
and pushes down existing exposure, even if you are set to Overwrite mode.
To insert blank cells:
1. In the Xsheet or Timeline view, select the cell where you want to insert a blank cell.

2. Do one of the following:
‣

In the top menu, select Animation > Cell > Insert Blank Cell.

‣

In Harmony Xsheet, select Selected > Insert Blank Cell.

‣

Right-click on the selected cell and select Exposure > Insert Blank Cell.

‣

Press [Shift] + [J].

‣

Click the Insert Blank Cell

button in the Timeline View and Xsheet View toolbars’ extra buttons.

The blank cell is inserted.

To clear a selected cell range without changing the exposure and timing:
1. In the Xsheet view, select the frame range to clear.
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2. Right-click on the selected cells and select Clear.

Related Topics
•

Filling Exposure on page 480

Setting the Exposure
You can easily increase or decrease the exposure for a selected cell range by using the Set Exposure options.
To set the exposure:
1. In the Timeline or Xsheet view, select the cell range on which you want to set the exposure.

2. In the top menu, select one of the following:
‣

Animation > Cell > Set Exposure > Set Exposure to 1.

‣

Animation > Cell > Set Exposure > Set Exposure to 2.

‣

Animation > Cell > Set Exposure > Set Exposure to 3.

‣

Animation > Cell > Set Exposure.
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You can also click the Set Exposure

buttons in the Timeline View toolbar’s extra buttons

or right-click the selected cells and choose .
3. In Harmony Xsheet, right-click and select Exposure > Set Exposure to and then select one of the
following:

‣ Set Exposure to 1
‣ Set Exposure to 2
‣ Set Exposure to 3
‣ Set Exposure
If you choose the Set Exposure option, the Set Exposure dialog box opens.

4. Type the number of frames you want the drawings to display and click OK.
The new timing is displayed in the Xsheet view.

Related Topics
•

Filling Exposure on page 480

Filling a Selection with a Single Exposure
The Fill Selection option is used to fill the same value all over a selection. The selection can be over one cell, a cell
range in one column, a cell range over many columns, an entire column or many entire columns. You can use
numbers, words, letters or any alphanumeric value.
To use Fill Selection:
1. In the Xsheet or Timeline view, select a cell range.
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2. Do one of the following:
‣

Select Animation > Cell >Fill Selection.

‣

Press [Ctrl] + [T] (Windows/Linux) or [⌘ ] + [T] (Mac OS X)).

‣

In Harmony Xsheet, right-click and select Exposure > Fill Selection or press [Ctrl] + [T]
(Windows/Linux) or [⌘ ] + [T] (Mac OS X).

‣

Click the Fill Selection

button in the Xsheet View and Timeline View toolbars’ extra buttons.

The Fill Selection dialog box opens.

3. In the Value field, type the desired value and click OK.

Related Topics
•

Filling Exposure on page 480

Filling a Selection with a Sequence
The Sequence Fill option is used to create a number sequence over a selection. The sequence can be forward,
backward, single, double or higher increment, as a cycle, etc. The selection can be over one cell, a cell range in
one or more columns, an entire column, or several entire columns.
To fill a selection with a sequence:
1. In the Xsheet or the Timeline view, select a cell range.

2. If you are working in the Xsheet view, select Animation > Cell > Sequence Fill. Click the Sequence Fill
button in the Xsheet View toolbar's extra buttons.
In Harmony Xsheet, select Selected > Sequence Fill. You can also click on the Sequence Fill
available in the Xsheet View toolbar's extra buttons.
OR
If you are working in the Timeline view, right-click and select Exposure > Sequence Fill.
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‣

Press [Ctrl] + [M] (Windows/Linux) or [⌘ ] + [M] (Mac OS X).

The Sequence Fill dialog box opens.

3. In the Starting Value field, type the starting number for the number sequence.
4. In the Increment field, type the increment to which the number will change from frame to frame.
(1-2-3-4, 1-3-5-7, 10-9-8-7-6-5-4-3-2-1). The value can be positive or negative.
5. In the Hold field, choose an exposure holding value.
6. Select the Cycle option if you want a cycle; type the number of cells for this cycle’s duration.

If you choose a two cell hold, a cycle of three drawings will last for six cells.

7. If you selected a larger range than the amount of frames needed, select the End Frame option and type
the last frame needed.

8. If you want to have more than one digit in your numbers such as “001” instead of “1”, select the Padding
option and add as many pound signs (#) as digits needed. Also, you can type a letter or word in the field
for it to be added in front of the drawing number.

9. Click OK.
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Related Topics
•

Filling Exposure on page 480

Filling a Selection Randomly
The Fill Cells Randomly option is used to fill in random values over a selection. You can give a maximum and a
minimum value and create a range for the system to choose the random values from. The selection can be over
one cell, a cell range in one column, a cell range over many columns or an entire column or several entire columns.
To use Fill Cells Randomly:
1. In the Xsheet view, select a cell range.

2. Select Animation > Cell > Fill Cells Randomly.
In Harmony Xsheet, right-click and select Exposure > Cell > Fill Cells Randomly.
‣

You can also click on the Fill Cells Randomly

button available in the Xsheet View toolbar’s extra

buttons.
The Fill Cells Randomly dialog box opens.

3. In the Minimum Value field, type a minimum value.
4. In the Maximum Value field, type a maximum value.
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5. In the Hold field, choose an exposure holding value.
6. If you are applying this option to a drawing column, enable the Whole Numbers option to avoid decimal
points.
7. Click OK.

Related Topics
•

Filling Exposure on page 480

Creating Cycles
Once you have entered a series of drawings and exposures, you can create cycles out of them in several ways.
You can loop your drawings using the following commands:
•

Paste Cycle

•

Paste Reverse

•

Create Cycle

When you create a drawing cycle, all of the repeated drawings are linked to the same original files. This means
that when you modify, repaint or correct a drawing named “1” all drawings named “1” are updated
simultaneously. In order to modify a drawing independently from its other exposures, you must duplicate the
drawing.
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To use the Paste Cycle command:
1. In the Xsheet or Timeline view, select the cell range to loop.

2. In the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4. In the top menu, select Edit > Paste Cycle.
In Harmony Xsheet, right-click and select Paste Cycle.
‣

The [Ctrl] + [/] (Windows/Linux) or [⌘ ] + [/] (Mac OS X).

The Paste Cycle dialog box opens.

5. In the Number of Cycles field, use the up and down arrow to increase or decrease the amount of cycles
you want to paste. You can also directly type the value.
6. In the Cycle Type drop-down menu, select the type of cycle you want to paste.

‣

Normal (forward): Pastes your selection as it is, starting with the first cell and ending with the last
one.

‣

Reverse: Pastes your selection reversed, starting with the last cell and ending with the first one.

‣

Forward -> Reverse: Pastes your selection as a yo-yo, starting with the first cell, going to the last one
and ending with the first cell.

‣

Reverse -> Forward: Pastes your selection as a reversed yo-yo, starting with the last cell, going to the
first one and ending with the last cell.

7. Click OK.
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You can do the same operation using the Paste Special dialog box. To open the Paste Special dialog
box, select Edit > Paste Special or press [Ctrl] + [B] (Windows/Linux) or [⌘] + [B] (Mac OS X).

To use the Paste Reverse command:
1. In the Xsheet or Timeline view, select the cell range to paste inverted.

2. In the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4. In the top menu, select Edit > Paste Reverse.
In Harmony Xsheet, right-click and select Paste Reverse.
‣

Press [Ctrl] + [.] (Windows/Linux) or [⌘ ] + [.] (Mac OS X).
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To use the Create Cycle command:
1. In the Timeline view, select the cell range to loop.

2. In the Timeline View toolbar, click on the Create Cycle

button located in the toolbar’s extra buttons.

The Create Cycle dialog box opens.

3. Enter the number of cycles you want, including the current selection.

Related Topics
•

Filling Exposure on page 480
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Navigating between Frames and Columns
Once a cell is selected in the Timeline or Xsheet view, you can navigate between the layers, frames and drawings
using keyboard shortcuts that are effective in the Camera, Drawing, Timeline and Xsheet view.
You can navigate through:
•

Columns

•

Drawings

•

Frames

To navigate through the drawings, frames and columns:
1. In the Timeline or Xsheet view, select a cell.

2. Once the cell is selected, you can navigate between:
‣

Previous and next layers from the top menu, you can select Edit > Previous Layer and Next Layer.
You can also press [H] and [J].

‣

Previous and next drawings, from the top menu, select Edit > Previous Drawing and Next Drawing
or Drawing > Previous Drawing and Next Drawing. You can also press [F] and [G].
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‣

Previous and next frames, from the top menu, select Play > Previous Frame and Next Frame. You
can also press [,] and [.].
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Managing Drawings
Drawings that are created in Toon Boom Harmony are not encapsulated in their cells. They are actual files stored
in the project’s folder. If you want to rename a drawing or delete a drawing from your project, you need to edit
the file and not the cells.

You also have the option of marking your drawing as Key, Breakdown and In-betweens—see
Drawing Identification on page 297 to learn more about this feature.

Related Topics
•

Renaming a Drawing below

•

Renaming Drawings by Frame Position on page 506

•

Deleting a Drawing on page 506

•

Duplicating a Drawing on page 507

•

Copying and Pasting Drawings on page 508

•

Drawing Identification on page 297

Renaming a Drawing
To rename a drawing, you do not type the new name in the cell. You need to select the cell containing the
drawing and use the Rename Drawing command.
To rename a drawing:
1. In the Timeline or Xsheet view, select the drawing to rename.

2. Do one of the following:
‣

In Harmony Stage's top menu, select Drawing > Rename Drawing or press [Ctrl] + [D]
(Windows/Linux) or [⌘ ] + [D] (Mac OS X).

‣

Click the Rename Drawing

button in the Timeline View or Xsheet View toolbars’ extra buttons.

‣ In Harmony Xsheet, use the Rename Drawing
buttons.
The Rename Drawing dialog box opens.
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3. In the New Name field, type the new drawing name.

Related Topics
•

Managing Drawings on the previous page

•

Renaming Drawings with a Prefix below

•

Renaming Drawings by Frame Position on the next page

•

Deleting a Drawing on the next page

•

Duplicating a Drawing on page 507

•

Copying and Pasting Drawings on page 508

Renaming Drawings with a Prefix
You have a the possibility to rename a drawing sequence with a prefix. This option can be quite useful for cut-out
puppet breakdown and deformation animation.
To rename a drawing sequence with a prefix:
1. In the Xsheet or Timeline view, select your drawing sequence. Note that you can only select a drawing
range in one column or layer at the time.
2. Right-click and select Drawings > Rename Drawing with Prefix.
The Rename Drawing with Prefix dialog box opens.

3. In the Prefix to Add field, type the prefix you want to add before your drawing name.

Related Topics
•

Managing Drawings on the previous page

•

Renaming a Drawing on the previous page

•

Renaming Drawings by Frame Position on the next page

•

Deleting a Drawing on the next page

•

Duplicating a Drawing on page 507

•

Copying and Pasting Drawings on page 508

•

Deformation on page 1111

•

Character Building on page 665
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Renaming Drawings by Frame Position
You can rename a series of drawings relative to their frame position. This is useful in hand-drawn animation.
To rename drawings by their frame position:
1. In the Xsheet or Timeline view, select the drawing sequence to be renamed.

2. In the top menu, select Drawing > Rename by Frame.

Related Topics
•

Managing Drawings on page 504

•

Renaming a Drawing on page 504

•

Renaming Drawings with a Prefix on the previous page

•

Deleting a Drawing below

•

Duplicating a Drawing on the facing page

•

Copying and Pasting Drawings on page 508

Deleting a Drawing
To permanently delete a drawing file, select the drawing you want to delete and use the Delete Selected
Drawings command.

Deleting a drawing file is an operation that cannot be undone.

To delete a drawing:
1. In the Timeline or Xsheet view, select the drawings to delete.
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2. In the top menu, select Drawing > Delete Selected Drawings.

Related Topics
•

Managing Drawings on page 504

•

Renaming a Drawing on page 504

•

Renaming Drawings with a Prefix on page 505

•

Renaming Drawings by Frame Position on the previous page

•

Duplicating a Drawing below

•

Copying and Pasting Drawings on the next page

Duplicating a Drawing
If you want to modify a drawing that already exists, but keep the original drawing intact, you can duplicate the
drawing and work on the copy. When duplicating a drawing, the selected cell is replaced with the new drawing.
The exposure of the original drawing that was on the current cell is removed. The drawing is not deleted.
To duplicate a drawing:
1. In the Timeline or Xsheet view, select the drawing to duplicate.

2. In the Xsheet View toolbar, cilck the Duplicate Drawing

button.

3. In Harmony Stage's top menu, select Drawing > Duplicate Drawing or press [Alt] + [Shift] + [D].

With Toon Boom Harmony you can create a keyframe at the same time as you duplicate your drawing. This way
you can modify and reposition your drawings without affecting the original drawing.

Related Topics
•

Managing Drawings on page 504

•

Renaming a Drawing on page 504

•

Renaming Drawings by Frame Position on the previous page
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•

Deleting a Drawing on page 506

•

Duplicating a Drawing on the previous page

•

Copying and Pasting Drawings below

Copying and Pasting Drawings
When you copy and paste a selection in the Timeline or Xsheet view, you are not copying and pasting the actual
drawings, you are pasting the exposure.
If you want to copy and paste the selected drawings into a different layer or paste the selection in the same layer
to duplicate the drawings, you must use the Paste Special feature.
There are two main ways to paste your selected drawings with the Paste Special dialog box:
•

Always Create Drawings
This option pastes all of your drawings as they are. If a drawing has the same name as an existing one, it is
renamed and duplicated.

•

Only Create Drawings When They Do Not Exist
This option only pastes only the drawings that are named differently from existing drawings. If a drawing
has the same name as an existing one, it is ignored and not pasted. This avoids duplicating drawings in
your layers.
This option is useful when you are pasting cut-out character templates containing drawings you may
already have in your scene and some new ones. Using this option, you only paste the new drawings and
are not duplicating all of the other parts you already have.

To paste drawings with the Paste Special command:
1. In the Timeline or Xsheet view, select the drawings to copy.

2. In the Timeline or Xsheet view, select the cell where you want your pasted selection to start.

3. In the top menu, select Edit > Paste Special or press [Ctrl] + [B] (Windows/Linux) or [⌘ ] + [B] (Mac OS X).
You can also click the Paste Special
button in theTimeline View andXsheet View toolbars’ extra
buttons.
The Paste Special dialog box opens.
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4. Select the Basic tab.
5. In the Drawings section, select the Always Create Drawings or the Only Create Drawings When They
Do Not Exist option depending on what you need.

If you want to perform another paste special operation using the same settings you used previously,
you can use the Paste Special Again command instead of the Paste Special command. This feature
paste your selection using the same settings you used in your last paste special without opening the
Paste Special dialog box.
To use the Paste Special Again command, select Edit > Paste Special Again or press [Ctrl] + [Shift] +
[B] (Windows/Linux) or [⌘] + [Shift] + [B] (Mac OS X). You can also click the Paste Special Again
button in theTimeline View andXsheet View toolbars’ extra buttons.

Related Topics
•

Managing Drawings on page 504

•

Renaming a Drawing on page 504

•

Renaming Drawings with a Prefix on page 505

•

Renaming Drawings by Frame Position on page 506

•

Deleting a Drawing on page 506

•

Duplicating a Drawing on page 507
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Tempo Markers
Tempo markers are used to synchronize your animation with a musical score. Using this feature, you can
reproduce the FPB (Frames Per Beat) and the tempo signature as Tempo markers. The Xsheet view allows you
to pace your animation according to the tempo or beat of your soundtrack music or to any rhythmical sound,
such as the ticking of a clock or water leaking from a spout.

To set the Tempo Markers:
1. In the Xsheet View menu, select View > Set Tempo Marker.
The Tempo Marker dialog box opens.

2. Reproduce the tempo and beat value of your music or sound for the Xsheet view marker display.
‣

Starting Frame: Type the number of the frame where you want the tempo markers to begin.

‣

Frames/Beat: Set the Frames Per Beat value. This will determine the frequency (in frames) a beat
marker will appear. Keep in mind that, by default, 24 frames represent 1 second.

‣

Beat/Bar: Set the Tempo of your music or sound. This will determine the frequency (in beats) a tempo
marker will appear in the Xsheet view.

3. Click OK.
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Related Topics
•

Timing on page 433
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Annotation Columns
The Annotation columns are useful for marking actions, corrections or other information related to your
animation that you want to draw or write. This way, you can print your Xsheet, take it back to your animation
table and work with the annotations.

Related Topics
•

Adding an Annotation Column below

•

Drawing and Typing in the Annotation Column on the facing page

•

Changing the Drawing Settings on page 516

•

Importing an Annotation File on page 518

Adding an Annotation Column
To add an annotation column:
1. Do one of the following:
‣

In the Xsheet View menu, select Columns > Add Columns.

‣

In the Xsheet View toolbar, click the Add Columns

‣

Press [Shift] + [C].

button.

The Add Column dialog box opens.

2. In the Name field, type in an appropriate name.
3. From the Type list, select Annotation and click OK.
The new column appears.

Related Topics
•

Annotation Columns above

•

Drawing and Typing in the Annotation Column on the facing page

•

Changing the Drawing Settings on page 516

•

Importing an Annotation File on page 518
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Drawing and Typing in the Annotation Column

In the annotation column, you can type in your notes and relevant information, as well as draw sketches and
ideas which will be useful in producing your animation.
•

Drawing in the Annotation Column below

•

Typing in the Annotation Column on the next page

•

Erasing Annotation Column Content on the next page

Drawing in the Annotation Column
Before you can draw in the Annotation column, you must first activate the Enable Drawing option. Then you can
start drawing.

Pen tablet pressure sensitivity is not supported in the Annotation column.

To enable drawing in the Annotation column:
1. In the Xsheet View menu, select Annotation > Enable Drawing. You can also click on the column’s header
icon to toggle the Drawing, Selection and Erasing modes.
‣

The Select

icon indicates that the Select mode is enabled.

‣

The Brush

icon indicates that the Drawing mode is enabled.

‣

The Eraser

icon indicates that the Erasing mode is enabled.

When using a pen on a tablet, you MUST flip your pen to the eraser side for the eraser to work.

To draw in the Annotation column:

‣ To draw in an Annotation column, simply use your mouse or pen tablet.
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Typing in the Annotation Column
Typing in an Annotation column is independent from the Drawing mode. You can be in either mode and the
typing will work.
To type in an Annotation column:
1. In the Annotation column, press [Ctrl] (Windows/Linux) or [⌘ ] (Mac OS X) on the cell in which you want to
write. By pressing [Ctrl] + [Shift] + click (Windows/Linux) or [⌘ ] + [Shift] + click (Mac OS X) in the
Annotation column, you will enter the editing mode in the cell at the current frame.

2. In the selected cell, type the desired text.

Refer to Typing Exposure on page 481 for more information about typing values in the Xsheet view.

Erasing Annotation Column Content
You can erase part or all of the Annotation column’s content.
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To erase the Annotation content:
1. In the Xsheet view, enable the Erasing mode by clicking on the mode icons.

2. In the Xsheet view, select the cell range you want to clear from text or images. Do not select any cells if
you plan to clear everything.

3. In the Xsheet view, right-click in the Annotation column and select:
‣

Annotation > Erase All to erase completely the content of the column.

‣

Annotation > Erase Selected Images to erase the images contained in the selected cell range. Make
sure to disable the Drawing mode to do so.

‣

Annotation > Erase Selected Texts to erase the text contained in the selected cell range. Make sure
to disable the Drawing mode to do so.

Tip: You can also use the Erasing mode to erase part of a drawn annotation.

To erase part of a drawn annotation using Erasing mode:
1. In the Annotation column’s header, enable the Erasing mode.

2. In the column, click and drag the cursor on top of the drawn annotation to erase parts of it.

515

Chapter 7: Timing Annotation Columns

Annotations that you type in cannot be erased using this method.

Changing the Drawing Settings
You can change the pen size and colour when you draw in the annotation column.
To change the pen width:
1. In the Xsheet View menu, select Annotation > Pen Width > 1, 2, 3, 4 or Change Current.
If you selected the Change Current option, the Pen Width dialog box opens.

2. In the Pen Width field, type the amount of pixel you want the pen size to be.
To change the pen colour:
1. In the Xsheet View menu, select Annotation > Change Pen Colour.
The Select Colour dialog box opens.

2. Choose the new colour.

Related Topics
•

Annotation Columns on page 512

•

Adding an Annotation Column on page 512

•

Drawing and Typing in the Annotation Column on page 513

•

Importing an Annotation File on page 518
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Displaying Tick Marks
When working with the Annotation columns, it's useful to display tick marks on odd number frames. To display
the tick marks, you must run a small script.

To display tick marks:
1. From the top menu, select Windows > Script Editor.
2. From the Script Editor menu, select File > New Script.
3. Type in a name for your script and click OK.
4. In the File list, select the script you created.
5. In the right side of the view, type in the following script:
function display_tick_marks()
{
preferences.setBool("XSHEET_ANNOTATION_FRAME_MARKER", true);
MessageLog.trace( preferences.getBool("XSHEET_ANNOTATION_FRAME_MARKER", false));
}
6. Click Verify.
The script is verified.
7. From the File menu, select Play/Debug > Run.
8. In the Functions column, select display_tick_marks and click OK.
Tick marks appear on odd frames in the Annotation column.

If you do not see tick marks, close and restart Harmony.

To turn off the display of tick marks:
1. Follow steps 1 to 5 of To display tick marks and use the following script:
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{
preferences.setBool("XSHEET_ANNOTATION_FRAME_MARKER", false);
MessageLog.trace( preferences.getBool("XSHEET_ANNOTATION_FRAME_MARKER", false));
}
2. Follow steps 6 to 8.
3. Close and restart Harmony.

Importing an Annotation File
If you scanned your paper exposure sheet’s annotations or if you need to place some pictures or drawings in
your annotation columns, you can easily import them.
To import annotation files:
1. In the Xsheet view, select the first cell in the annotation column where you want the imported image to
start.

2. In the Xsheet view menu, select Annotation > Import File.
3. Browse for the bitmap image to import.
4. Click Open.
The image appears in the annotation column.

Related Topics
•

Annotation Columns on page 512

•

Adding an Annotation Column on page 512

•

Drawing and Typing in the Annotation Column on page 513

•

Changing the Drawing Settings on page 516
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Printing the Xsheet
Once your line test is completed and you have marked all the information, corrections and timing you want in
your Xsheet view, you can print out your exposure sheet. Printing out the Xsheet allows you to take it with you
to your animation table or to give a copy to the animator. You can also use it to create your Xsheet skeleton
directly in Toon Boom Harmony.
To print your exposure sheet:
1. Select File > Print > Xsheet.
The Print dialog box opens.

2. To setup your print:
‣

Windows: In the Select Printer section, select your printer and adjust the rest of the printing settings.

Refer to the printer user guide to learn more about its options.
‣

Linux: In the Print Destination section, select your printer and adjust the rest of the printing settings.

Refer to the printer user guide to learn more about its options.
‣

Mac OS X: In the Printer section, select your printer and adjust the rest of the settings by clicking on
the Parameters
button. You can also click on the PDF button and select an option from the dropdown menu if you want to save a PDF version of your exposure sheet.
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Refer to the printer user guide to learn more about its options.

3. Click on the Print button.

Related Topics
•

Timing on page 433
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Element Manager
Use the Element Manager to add, delete or modify elements (drawing folders) in your scene. If you have
drawing folders that are not linked to a column in your scene, use the Element Manager to delete them if need
be.
To open the Element Manager dialog box:

‣ Select Scene > Element Manager.

•

Elements: Displays a list of the elements contained in your scene.

•

Delete Elements: Press this button to delete the selected elements.

•

Delete Elements and Directories: Press this button to delete the selected layer, as well as its directories
(drawing folder).

•

Add/Modify Element: Use the options contained in this area to add or modify an element.
•

Name: Type a new name in this field to create an element or to rename the selected element.

•

Vector: Check this box if the new element is a vector drawing or if you want to enable the parameters
on the selected element in the Elements list.

•

Bitmap Format: Select the file format of the bitmap layer from the drop-down list.

•

Scan Type: If you are planning to scan elements with Toon Boom Harmony’s Scan module, select the
scan type from the drop-down list.

•

Field Chart: If you are importing traditional animation, select the size of the paper on which the
animation was drawn.

•

Add: Press this button to create a new element with the current parameters entered in the Add/Modify
Element section.

•

Modify: Press this button to apply the parameter changes made to the selected element.

Related Topics
•

Timing on page 433
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Timing Preferences
When adjusting your timing in the Timeline andXsheet views, you may want to set some preferences.
This section covers the preferences related to timing, Timeline and Xsheet view.

The preferences related to Harmony Xsheet can be found under the Exposure Sheet tab only.

You will find the preferences listed under the following tabs:
•

Exposure Sheet

•

Timeline

•

Advanced

To open the Preferences dialog box:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Select Stage> Preferences.

‣

Press [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).

Related Topics
•

Exposure Sheet Preferences below

•

Timeline Preferences on page 525

•

Advanced Preferences on page 525

Exposure Sheet Preferences
This is the Exposure Sheet preferences tab.
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Filtering
These preferences are used to display or hide certain layer types in the Xsheet view.
•

Show Drawing Columns: Displays the Drawing layers in the Xsheet view.

•

Show Function Columns: Displays the Function columns layers in the Xsheet view.

•

Show Annotation Columns: Displays the Annotation columns layers in the Xsheet view.

•

Show 3D Path Columns: Displays the 3D Path columns in the Xsheet view.

•

Show Sound Columns: Displays the Sound columns in the Xsheet view.

•

Centre of Current Frame: Turns auto-centering on or off when playing back a scene. Auto-centering
is to be used during sound breakdown with the ShuttleXpress device.

Options
•

Default Add Columns: The default position where the new column will be added.

•

Default Column Width: The default width value for the new column being created.

Element Manager
•

Pixmap Format: By default, when you create a new empty bitmap column, it will use the file format
indicated in the field as the new column format. The default value is SCAN, which means that it is set for
scanned-in drawings.

•

Scan Type: By default, the Scan Type is set to 2 which indicates that the element is a TVG vector drawing.
This function returns a string that is the scan type of the element. The scan type is COLOR, GRAY_SCALE
or BW.

•

Vector Type: By default, the Vector Type is set to 2 which indicates that the element is a TVG vector
drawing. This function returns the vector type for the given element. In theory, there is support for
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multiple types of vector drawing. In practice, only TVG has been implemented. The value 0: indicates that
the element is NOT a vector drawing. It is an IMAGE type.

New Element
•

Bitmap Format: By default, when you create a new empty bitmap column, it will use the file format
indicated in the field as the new column format. The default value is SCAN, which means that it is set for
scanned-in drawings.

•

Scan Type: By default, the Scan Type is set to 2 which equals vector import. This means that the imported bitmap
images will be placed into a Drawing layer. Scan type 1 is bitmap import.

Apply/Next
•

From Left to Right: When clicking the Apply/Next button in the Xsheet view Column Properties, the
next column to be displayed in the Column Properties will be the one on the right.

•

From Right to Left: When clicking the Apply/Next button in the Xsheet view Column Properties, the
next column to be displayed in the Column Properties will be the one on the left.

Zoom Levels
You can set the minimum and maxium zoom levels to view the Xsheet, depending on the number of columns and
rows in the project. Once you set a level, close and reopen the Xsheet so the new values take effect.
•

Minimum Zoom Level: Lets you set the lowest level of zoom. Choose a value between 1 and 6.

•

Maxium Zoom Level: Lets you set the highest level of zoom. Choose a value between 14 and 20.

Tip: You can set a keyboard shortcut to view your entire Xsheet.

Related Topics
•

Timing Preferences on page 522

•

Timeline Preferences on the facing page

•

Advanced Preferences on the facing page
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Timeline Preferences

Defaults
•

Show Groups: Displays the Group layers in the Timeline.

•

Show Effects: Displays the Effect layers in the Timeline.

•

Show Sound: Displays the Sound layers in the Timeline.

Paste/Drag & Drop
•

Add keyframes at beginning and end: Select this option to copy and paste a set of frames that includes
an interpolated sequence between two keyframes, but only extracts a partial section. Under normal
circumstances, cutting and pasting a function without either the start or end keyframe would render the
function null. This option caps the partial function with a new keyframe when you perform the paste.

Related Topics
•

Timing Preferences on page 522

•

Exposure Sheet Preferences on page 522

•

Advanced Preferences below

Advanced Preferences
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•

Advanced Element Mode: Displays more options in the Add Column dialog box and the Column
Properties dialog box.
•

Auto-rename Elements: Controls whether to rename the element whenever the corresponding
module name in the Network view or layer name in the Timeline view is changed.

Related Topics
•

Timing Preferences on page 522

•

Exposure Sheet Preferences on page 522

•

Timeline Preferences on the previous page
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Chapter 8: Morphing

Hand-drawn animation requires you to spend a lot of time tracing in-between drawings. Harmony speeds up the
process using its helpful Morphing feature. This powerful and useful feature creates computer generated
drawings and places them between vector drawings to save time and increase quality. Animation created with
the Morphing feature can be reused in different projects. You can easily modify the timing and velocity (ease in
and ease out).
One of the main uses of the Morphing feature is in effect animation. For example, animating smoke or water can
be time-consuming because these types of effects are usually slow moving requiring a large number of closely
placed in-betweens.

Topics Covered
•

Understanding Morphing on the next page

•

Source and Destination Drawings on page 529

•

Morphing Rules on page 530

•

Creating a Basic Morphing Sequence on page 534

•

Tool Properties View on page 537

•

Adjusting the Velocity and Timing on page 542

•

Morphing Tool and Hints on page 546

•

Morphing Layers on page 555

•

Morphing Two Sequences in a Row on page 562

•

Inserting a Morphing Key Drawing on page 563

•

Converting Morphing In-betweens to Drawings on page 565

•

Morphing Holes and Transparencies on page 566

•

Adjusting the Morphing Quality on page 569

•

Tips and Tricks on page 570

•

Morphing Preferences on page 571
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Understanding Morphing
The Morphing feature is used to animate similar and simple shapes such as hair or smoke. It helps you by saving
time when you are working on tedious in-betweening and tracing tasks This, in turn, provides you with more time
to spend on complex animation tasks such as walk-cycles or acrobatic sequences.

Ideas Behind Morphing
To learn how to morph drawings, it is better to start with basic shapes such as circles and rectangles. Once you
are more familiar with the tool, you can increase your knowledge and expertise. In a very short time you will be
producing some remarkable effects.
It is helpful to know the pros and cons of morphing before you start. Understanding what you can do and which
drawing lines can give you a problem will enable you to design your key drawings so they morph efficiently.

The more complex the shape is, the longer it takes to morph. If it takes more time to morph a drawing
than to hand draw it, then it is better to animate it instead of morphing. However, if you spot an
occasion when you can morph your drawings, do it! It allows you to fix your timing and velocity in no
time without having to create any extra drawings!

Related Topics
•

Source and Destination Drawings on the facing page
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Source and Destination Drawings

The Morphing feature matches similar shapes in two drawings. These are the source and destination drawings.
Harmony evaluates the source's shape properties and matches them to the most similar one in the destination
drawing.
Morphing works between similar shapes, which are drawings that have the same palette, colours and number of
shapes. You can even change a rabbit into an elephant, as long as source and destination keep the same colours
and number of shapes.

Related Topics
•

Creating a Basic Morphing Sequence on page 534

•

Morphing Rules on the next page
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Morphing Rules
Harmony follows a set of rules as it evaluates the shapes. Familiarize yourself with these basic morphing rules
before you start morphing.

Related Topics
•

Closest Similar Shape below

•

Pencil Line to Pencil Line below

•

Fill Shape to Fill Shape on page 532

•

Colour Swatch to Same Colour Swatch on page 532

•

Vanishing and Appearing on page 533

•

Colour Art to Colour Art and Line Art to Line Art on page 533

Closest Similar Shape
A colour, line shape or zone will morph with the closest similar one in the destination drawing. This means it will
morph with the zone nearest to it, as long as that zone uses the same palette's colour swatch (Colour ID) and
has the same vector properties (Central or Contour).

Pencil Line to Pencil Line
If you trace a shape using a pencil line such as the Ellipse

, Rectangle

, Polyline

, Line

or Pencil

tool, you have to morph it with another pencil line. Make sure that both drawings are pencil shapes (central
vector).
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A pencil line will never morph with a brush stroke.
Pencil lines with thickness ARE SUPPORTED in morphing sequences. The thickness will morph according to the
thickest and thinnest areas in the source and destination drawings.

Pencil lines with textures are NOT SUPPORTED in a morphing sequence. During the morphing, the texture will
disappear and show without pencil line opacity texture.

If you have pencil lines in your source drawing, the same number of pencil lines must be present in
the destination drawings. A pencil line will appear if it is not found in the destination drawing. It will
pop out on the first or last frame depending on which one it is drawn.
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When two pencil lines cross one another, they are considered to be two lines and not four lines
anymore (as it was in previous versions of the application). In this case, you must have two pencil lines
in your destination drawing for your morphing to work correctly.

Fill Shape to Fill Shape
If you have a brush line or a colour fill zone which are contour vectors, make sure that you morph it with another
fill or brush line. Contour vectors will not morph with pencil lines (central vectors). A brush line can morph into a
colour fill zone and vice versa.

Colour Swatch to Same Colour Swatch
Harmony does not morph colours. If you want to perform a colour transition, you have to create the effect at the
compositing level. A colour palette is composed of colour swatches. Each colour swatch has its own unique
identification number, even if two colours pots are the same shade of red, they are identified independently. A
colour zone or shape will morph with another one painted with the same colour swatch.
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Vanishing and Appearing
If a colour zone does not find a match in the first or the second drawing, it will progressively appear or
disappear.

Colour Art to Colour Art and Line Art to Line Art
In Harmony, there is an advanced concept for painting your drawings called Line Art and Colour Art. Basically, an
extra layer is added in your drawings so that you can fill the colour zones on a separate layer. The regular layer
on which you are drawing is called Line Art and the extra layer under the Line Art is the Colour Art.
•

A shape drawn in Colour Art can only be morphed with another shape existing in the Colour Art.

•

A shape drawn in Line Art can only be morphed with another shape existing in the Line Art.

•

A shape created in Colour Art can never morph with a shape created in Line Art.

Related Topics
•

Drawing with the Brush or the Pencil on page 165

•

Line Art and Colour Art Layers on page 388
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Creating a Basic Morphing Sequence

Once you are familiar with the basic rules, you can start creating morphing sequences. You need to practice and
become at ease with the Morphing feature. To begin, start with simple elements, once you become confident
with the morphing process you can move on to complex and advanced morphing techniques, such as head
rotation or full characters.
To create a basic morphing:
1. In the Timeline view, click on the Add Drawing Layer

button to add a new layer to your project.

2. Rename the new layer Morphing.
3. In the Timeline or Xsheet view, select the first cell in your layer.

4. In the Tools toolbar, select the Rectangle

tool or press [Alt] + [7].

5. In the Tool Properties view, enable the Auto Fill

option.

6. In the Colour view, click on the Set Paint Current Colour

button.

7. In the Colour list, select a colour to fill your rectangle with.

8. In the Colour view, click on the Set Pencil Current Colour
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9. In the Colour list, select a colour to trace your rectangle's outline with.

10. In the Camera or Drawing view, draw a rectangle.
‣

Hold down the [Shift] key if you want to draw a square.

‣

Hold down the [Alt] key if you want to draw the rectangle from its centre.

11.In the Xsheet or Timeline view, select the last cell.

12. Repeat Step 5 to Step 10 using the Ellipse

tool instead of the Rectangle tool or press [Alt] + [=].

‣

Draw an ellipse using the same outline colour as the rectangle ("Outline").

‣

Paint the ellipse with the same fill colour as the rectangle ("Fill").

13. In the Xsheet or Timeline view, select your first drawing's cell, the rectangle drawing.

14. In the Xsheet or Timeline view, right-click on the selection and select Morphing > Create Morphing or
press [Alt] + [M].
‣

In the top menu, you can also select Animation > Morphing > Create Morphing.
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Arrows appear between the two key drawings to show they are computer generated.

15. Use the Playback toolbar to play the morphing sequence. To flip through the in-betweens toggle between
[,] and [.] or press [F4] to toggle between the two key drawings.

Related Topics
•

Deleting a Morphing Sequence below

Deleting a Morphing Sequence
You may want to delete an entire morphing sequence in order to redo a sequence from scratch.
To delete an entire Morphing sequence:
1. In the Xsheet or Timeline view,right-click on a cell between two keyframes.
2. Select Morphing > Delete Morphing or from the top menu, select Animation > Morphing > Delete
Morphing.
The entire sequence between the two keyframes is removed.

Related Topics
•

Creating a Basic Morphing Sequence on page 534
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Tool Properties View

As you create and adjust your morphing sequences, you will often use the Tool Properties view. Using this view
allows you do things such as toggling between your key drawings, adjusting the easing or selecting a hint type.
To access the content of the Tool Properties view:

‣ Select the Morphing

tool in the Tools toolbar or press [F3].

Related Topics
•

Hint Type on the next page

•

Hide Hints on the next page

•

Show Morphing in Place on the next page

•

Suggest Hints on page 539

•

Switch Between Drawings on page 539

•

Flatten on page 539

•

Quality on page 539

•

Morphing Layers on page 540

•

Easing on page 540

•

Convert Hints on page 540

•

Time on page 541

537

Chapter 8: Morphing Hint Type

Hint Type

The Hint Type drop-down menu allows you to select the correct hint to remedy any problem areas in your
drawing.

You can have more than one hint type in your drawings. You can mix all of the hint types in your
morphing sequence.

Refer to:
•

Contour Hint on page 550

•

Morphing Tool and Hints on page 546

Hide Hints

The Hide Hints

button temporarily hides the hint points from the key drawings. Use this option when you

have a series of hint points hiding some lines you would like to see.

Show Morphing in Place
The Show Morphing In Place

option is used with morphing layers. Enabling this option prevents the currently

selected morphing layer from being shown on top of the others and maintains the correct layer ordering.
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Refer to Morphing Layers on page 555.

Suggest Hints
The Suggest Hints

option is used to automatically set hint points on your key drawings as a help tool. If you

are not sure where to set your hints, you can use this option. It will set the main hints which you can then fine
tune.

Switch Between Drawings
The Switch Between Drawings

button is used to toggle between the two key drawings in your morphing

sequence. This option is useful while setting hints or press [F4].

Flatten
The Flatten

option is used when you have to morph a sequence with a semi-transparent or transparent

colour in it.

Refer to Morphing Holes and Transparencies on page 566.

Quality
The Quality setting is used to make the lines of the morphed drawings smoother. Adjust this parameter when
you are doing an extreme close up of your animation.

Refer to Adjusting the Morphing Quality on page 569
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Morphing Layers

The Morphing Layers option is used when working with morphing layers. You can add, remove and manage your
different morphing layers in this space.

Refer to Morphing Layers on page 555

Easing

The Easing option is used to adjust the starting and ending velocity of your morphing sequence so that the
motion is smooth and not mechanical.
You can adjust the Ease In and Ease Out value by dragging your cursor up and down or typing a new value. The
values go from -1.0 to 1.0.

Refer to Adjusting the Velocity and Timing on page 542

Convert Hints

The Convert Hints

option is used to switch the type of the current selecting hint points. This option is useful

when you position hints and then realize they are not the right type. You can select them and convert them to the
correct type instead of deleting them and setting new ones.
Use the Morphing tool to select the hints and then convert them by going to the Tool Properties view and
selecting the new hint type from the Convert Hints drop-down menu.
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Time
The Time parameter is used to set the timing on Appearing Point and Vanishing Point hints. These hints are used
to set the trajectory of appearing and vanishing objects, they do not have to appear or disappear from the first
frame to the last frame of the morphing sequence. With the Time parameter, select your Appearing Point or
Vanishing Point hint and type the frame number on which the object will start its animation.

Refer to the Appearing Point Hint topic to learn more.

Related Topics
•

Morphing Tool and Hints on page 546
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Adjusting the Velocity and Timing

Once you have established a morphing sequence, you can control its timing and velocity. When you look at your
animation you will notice that the morphing motion is constant. To produce a less mechanical motion, you will
probably want to create some ease in or ease out.
If you did not place your source and destination drawings on the correct frames you may need to extend or
shrink the sequence length.
•

Changing the Morphing Sequence Length below

•

Adjusting the Velocity in the Layer Properties Editor below

Changing the Morphing Sequence Length
To extend or shrink a morphing sequence length:
1. In the Timeline view, select the source or destination drawing.
2. Click on your selection and drag the drawing to its new frame.

Adjusting the Velocity in the Layer Properties Editor
If you have several morphing sequences on a single layer, you may find it easier to adjust their velocities on one
function curve rather than several separate ones. Having all of your velocity parameters in one place is more
efficient and easier to modify.
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Adjusting the velocity in the Layer Properties editor also allows you to reverse a section of the morphing
sequence. The sequence will always start with the source drawing and end at the destination. You can play the
morphing sequence backwards or forwards during the animation.
You can have two levels of easing. It is possible to adjust the velocity of each sequence in your layer
independently using the Tool Properties view and then adjust the morphing velocity function in the Layer
Properties editor to control the entire layer's easing.
To adjust the velocity in the layer editor:
1. In the Timeline view, double-click on the drawing element module to open the Layer Properties editor.

2. In the Layer Properties editor, go to the Drawing tab and click on the Function

button to create a

function curve.

3. In the Layer Properties editor, click on the Function
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4. Add a keyframe at the first frame of the morphing (Source) and one at the end (Destination) by clicking on
the Add/Remove Keyframe
button.

5. Move the end keyframe up.

It is important that the last keyframe remains above the first one.

6. Make sure that the first keyframe is NOT a Stop-motion keyframe. To do this, uncheck the Stop-motion
Keyframe option to disable it. To use the Toggle Stop-Motion Segment feature, press [S].
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7. Click on the keyframes and pull the Bezier handles to create ease in and ease out. If you make the curve go
downward instead of upward, the animation will play backward until the curve starts to go upward again.

If you have more than one morphing sequence in the same layer, you need to add a keyframe on the
velocity curve for each source and destination drawings.

If you want your morphing to play back on a double frame exposure rather than single frame, you can
use the Hold Value editor and set the velocity to change every second frame, instead of every frame.
In the Morphing Function editor, click on the Hold Value Editor
hold the value for two frames.

Related Topics
•

Function Curves on page 992

•

Adjusting the Ease on page 1010
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Morphing Tool and Hints

Harmony provides the Morphing

tool to control your morphing sequence, this works by placing different

types of hints to help the system morph the animation the way that you want it.
Hints are points which are placed in both the source and destination drawings, they associate zones and lines
between the two drawings. Hints are used to fix problem zones, such as a line that is not following the colour fill
zone.

Corners and points generally give the most problems. The software does not necessarily understand the
animation curves and may be unable to match corners. It will generally associate a corner with the nearest one,
this is not always correct and it is why we use hint points to determine what goes with what.

Related Topics
•

Using the Morphing Tool on the facing page

•

Hints on page 549

•

Copying Hint Points from One Drawing to Another on page 552
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Using the Morphing Tool
Hints are identification points existing in both the source and destination drawings to create associations
between the two of them.
To correct morphing distortions, Harmony has different types of hints available for controlling different types of
problems:
•

Contour Hint on page 550

•

Zone Hint on page 550

•

Pencil Hint on page 551

•

Vanishing Point Hint on page 551

•

Appearing Point Hint on page 552

Each type of hint has a different purpose and they can all be used in the same drawing.
Use the Morphing tool to add hints to your morphing sequences. You can add different hints to your source and
destination drawings and combine all types of hints in the same drawing.
A hint will automatically appear in both the source and destination drawings when it is added. A hint cannot exist
in a single drawing. If you delete a hint from one drawing, it will be also deleted from the other.
The key to placing your hints is to put them where the biggest problem is. Fix the largest distortions first, this
may also fix the smaller ones at the same time.

Do not add too many hints, this is a common mistake when morphing, it takes some practice to learn how to
correctly use and place hints.
To add and remove hints:
1. In the Timeline or Xsheet view, select the source or destination drawing of your morphing sequence.

2. In the Tools toolbar, select the Morphing

tool or press [F3].
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Use your other morphing key drawing, shown in the Drawing view's bottom right corner, as a reference.

3. In the Tool Properties view, select the type of hint you want to use.

‣

Select Contour Hint to correct a brush line or colour zone's contour (Contour vector).
Contour Hint points will behave similar to Pencil Hint points when used on a pencil line. Note that you
obtain better results using the Pencil Hint point.

‣

Select Pencil Hint to correct a pencil line (Central vector).

‣

Select Zone Hint to correct a colour zone morphing match.

‣

Select Vanishing Point Hint to correct a vanishing shape's trajectory.

‣

Select Appearing Point Hint to correct an appearing shape's trajectory.

4. In the Camera or Drawing view, click on the drawing near the area to add a hint.
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5. Select the hint's point and move it to its correct position.

6. Select one or many hints and press [Delete] to remove extra or unused hints.
‣

To delete all of the hint points at once, press [Shift] + [Delete].

7. In the Playback toolbar, press the Play

button to see the result.

Related Topics
‣

Hints below

Hints
Here are the available hint points:
•

Contour Hint on the next page

•

Zone Hint on the next page

•

Pencil Hint on page 551

•

Vanishing Point Hint on page 551

•

Appearing Point Hint on page 552
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Contour Hint

The Contour Hint

point is used on the colour fill zone and brush lines; in other words, on Contour vectors. It

allows the control of line thickness and contour position. Also, if a contour is not animated the way that it should
be you can use hints to correct the animation. For example, if a flag is not waving properly.
When adding a Contour Hint point, make sure that you place it far enough away from the contour so that you
can see it snap to the contour.
The Contour Hint points are yellow.

Do not place the Contour Hint directly on the line as it may look like it has snapped to the contour,
when in fact, it has not and the morphing will remain unchanged.

To correct a brush stroke, place a hint on both sides of the line to indicate its thickness variations
over time.

Zone Hint
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The Zone Hint

point is used on a colour zone to control the proximity rule. The Zone Hint is placed in the

centre of the colour zone. Sometimes a colour zone is not associated with the corresponding one by default. For
example, in a splash animation there are many water droplets that are the same colour. The system
automatically morphs the droplet to the nearest one. This is not always correct. A Zone Hint will force a colour
zone to morph with another one.
Zone Hint points are cyan in colour so you can easily see them.

Pencil Hint

A Pencil Hint

point is used to control a pencil line, also known as central vector. It can be used on drawings

that were done using the Pencil, Polyline, Ellipse, Line and Rectangle tools. Like the Contour Hint, the Pencil Hint
snaps to the central vector. Make sure to place it far enough away from the line so you will see it snap when you
move it.
Pencil Hint points are magenta in colour so you can easily see them.

Vanishing Point Hint

A Vanishing Point Hint

is used to control the trajectory of a vanishing shape. A shape will vanish from the

source drawing when there is no corresponding shape in the destination drawing. If you do not place a Vanishing
Hint to control the point of disappearance, the shape will vanish into its centre.
Vanishing Point Hint points are green in colour so you can easily see them.
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Appearing Point Hint

An Appearing Point Hint

is used to control the trajectory of an appearing shape. A shape will appear in the

destination drawing when there is no corresponding shape in the source drawing. If you do not place an
Appearing Point Hint to control the point of appearance, the shape will appear from its centre and expand
outwards.
Appearing Point Hint points are violet in colour so you can easily see them.

Related Topics
•

Morphing Tool and Hints on page 546

Copying Hint Points from One Drawing to Another

If you have two morphing sequences that use the same drawing and you would like to copy it and its hint points,
you can do so in the Drawing view.
To copy a drawing and its hints:
1. In the Tools toolbar, select the Select

tool or press [Alt] + [S].
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2. In the Drawing view, select the drawing you will reuse in your second morphing sequence. In the top
menu, select Edit > Copy or press [Ctrl] + [C] (Windows/Linux) or [⌘ ] + [C] (Mac OS X).

3. In the Timeline view, select the cell where the new drawing will be.

4. In the Drawing view, paste your selection. In the top menu, select Edit > Paste or press [Ctrl] + [V]
(Windows/Linux) or [⌘ ] + [V] (Mac OS X).
5. In the Timeline view, select the cell where the second drawing will be.

6. In the Drawing or Camera view, draw your second drawing.

7. In the Timeline view, create the morphing sequence for the new drawings or press [Alt] + [M].
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8. In the Tools toolbar, select the Morphing

tool or press [F3].

9. In the Drawing or Camera view, position your hint points.

Related Topics
•

Morphing Tool and Hints on page 546
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Morphing Layers
Morphing layers simplify the morphing animation. Complex shapes are often too difficult to control and may not
work properly, by dividing the drawings into Morphing layers, the task becomes much easier.
The major points used in controlling a morphing sequence are the intersections. If there are many lines
intersecting within a drawing, the system will require more control. (Refer to the Morphing Hints section.)
An important aspect of morphing is to identify possible problem zones in order to fix them and avoid potentially
frustrating situations.
This topic is divided as follows:
•

Identifying Problem Zones below

•

Morphing Layer Properties on the next page

•

Creating a Morph with Morphing Layers on page 557

Identifying Problem Zones

Simple details that look easy to morph can sometimes be more difficult than they may initially appear to be. For
example, you may find that the nose becomes problem when performing a head rotation. As explained earlier,
the drawings need to be similar in their number of shapes. Generally, on a head rotation, the source nose is in
the centre of the face, but on the destination, the nose line is part of the face outline. This means that on the
source drawing, the nose and the face outline are two separate shapes, whereas they are combined into one
shape on the destination drawing.
Morphing a full face as demonstrated on the figure below will cause the source nose to slowly vanish as the
destination nose grows from the character's cheek.
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Any shape that is contained inside another one and has to morph out of that shape will be a problem for the
same reasons as the nose is. At some point during the morphing sequence, the shape contained inside the face
will merge with the face outline, and then become a separate shape again.

Morphing Layer Properties

It is because of these reasons, explained in the Identifying Problem Zones on the previous page section, that
morphing layers exist. Morphing layers are all contained in the same drawing layer. It is like having a mini
Timeline within a Timeline layer, or a mini Xsheet within an Xsheet column.
Each morphing layer can have its own duration and velocity. Also, because you only have a single element to
handle in your Timeline or Xsheet view, it will be treated as one element for the Compositing process, making
the compositors work easier.
You could separate all of your elements into different actual drawing elements and have many layers, but you
would have to create a large number of morphing sequences and make sure that you modify all of their timings
properly.
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Both solutions are correct, but morphing layers makes it easier to handle and does not change the
scene structure by adding more elements which can be very important for Cut-out animation
puppets. For example if you need to morph a front head to a three-quarter head where the ear
needs to be separated, you do not want to add a new ear layer at the same time and have to worry
about connecting it inside the puppet's construction. Instead, simply create an ear morphing layer
within the head layer.

Creating a Morph with Morphing Layers
When you click on a Morphing layer drawing, it automatically appears on top of the other ones. If you want it to
stay in place, for example the wing behind the body, enable the Show Morphing in Place
option in the
Morphing tool Properties view.
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Use a naming convention for each morphing layer such as ear_1, ear_2 or head_1, head_2. You can
also use the numbers 1 to 9 for the first layer, 10 to 19 for the second one, 20 to 29 for the third one
and so one. This technique is useful if you plan to do more than one morphing sequence in the same
column. For example, front head to three-quarter head to side head. The three-quarter drawings will
be used in both morphing sequences.

To create a morph with morphing layers:
1. In the Timeline view, add a new drawing element and name it properly.
2. In the first cell, draw the main source shape such as the head shape or body shape. Do not add details like
eyes.

3. In the Timeline View, select the destination cell, then enable and extend the Onion Skin.

4. In the destination cell, draw the second drawing.
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5. In the Timeline view, select the in-between cells, right-click and select Morphing > Create Morphing or
press [Alt] + [M],

6. In the Tools toolbar, select the Morphing

tool.

7. In the Morphing Tools Properties view, click on the Add Layer

button to add a new morphing layer.

8. Double-click on the new layer's name and name it appropriately.
9. Press [Enter/Return].

10. Use the Up
‣

and Down

arrow buttons to move the new layer above or below the Main layer.

If placed above the Main layer, it will be displayed in front. If it is placed below, it will be displayed
behind.
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11. To create new drawings, double-click on the blank area under the From section to create the source
drawing and the To section for the destination drawing and type a value different than the ones used for
the main layer.
12. Press [Enter/Return].
‣

You do not need to type any value for the Main layer as it uses the one from the Xsheet column.

13.Click on the new source drawing to start drawing the new part. (Make sure that you are working on the
proper drawing by verifying the name in the Camera or Drawing view's bottom left corner.)

14.In the Camera or Drawing view, draw the source drawing.

15. Once the source drawing is done, use the Morphing Tool Properties view and click on the destination
drawing's name and draw it in the Camera or Drawing View.
16. Repeat steps Step 7 to Step 13 for each layer needed. You can add as many layers as you want.
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17.Enable or disable the layers that you want to display or hide while drawing.

18.If you want to change the layer duration, click on the layer and change the start and stop numbers.

The length indicator changes according to the new values.
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Morphing Two Sequences in a Row

If you are morphing two sequences in a row, you will have to create a different set of hint points for each
sequence.
Morphing two sequences in a row requires three drawings: 1, 2 and 3. Using these three drawings you create
two morphing sequences; one sequence between drawings 1 and 2, and a second sequence between drawings 2
and 3.

Each morphing sequence has its own set of parameters and hints. This means that Drawing 2 will
have a set of hints for the first sequence and another set for the second sequence. The two sets of
hints will not show at the same time. Each set of hints that appears always corresponds to the
morphing sequence you are working on.

Related Topics
•

Creating a Basic Morphing Sequence on page 534
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Inserting a Morphing Key Drawing

Once you have a morphing sequence, you can add a Morphing Key drawing.
A Morphing Key drawing allows you to insert extra details into a morphing sequence. For example, during a
morphing sequence you may need to insert a detail such as teeth or a mouth, this is easy to do when you use a
Morphing Key drawing. Instead of creating an entirely new drawing, convert a computer generated in-between
to a Morphing Key drawing and add your extra details to it and the next key drawing.
A Morphing Key drawing converts a computer generated morphing frame into a real drawing that you can edit.
It splits the morphing sequence into two sequences, retaining any previous modifications.
To insert a Morphing Key drawing:
1. In the Timeline or Xsheet view, select the morphing frame you want to transform into a morphing
keyframe.

2. Right-click on your selection and select Morphing > Insert Morphing Key Drawing.
‣

In the top menu, you can also select Animation > Morphing > Insert Morphing Key Drawing.

The new Morphing Key drawing appears.

3. In the Drawing or Camera view, draw your new details on the Morphing Key drawing.
4. In the Playback toolbar, press the Play

button to see the result.
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Related Topics
•

Creating a Basic Morphing Sequence on page 534

564

Toon Boom Harmony 10.3 Stage User Guide

Converting Morphing In-betweens to
Drawings

Harmony lets you convert your morphing in-betweens to real drawings that you can edit.
This is useful when you manually edit your morphing sequence or if you prefer to have your animation timing in
double frame instead of single frame.
To convert morphing in-betweens to drawings
1. In the Timeline or Xsheet view, select a morphed drawing in the morphing sequence you want to convert
to real drawing.

2. Right-click on your selection and select Morphing > Convert Morphing to Drawings.
‣

In the top menu, you can also select Animation > Morphing > Convert Morphing to Drawings.

The Converting Morph dialog box opens.

3. Type the drawing basename you want to give to your new drawings. In this case, you could type circle.
4. Click on the OK button.

Related Topics
•

Creating a Basic Morphing Sequence on page 534
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Morphing Holes and Transparencies
To be able to morph shapes with holes or transparent colours, it is important to understand the process of
analyzing and morphing a shape. Harmony begins the process by reading the exterior outline of the entire
shape. So if you are morphing a doughnut, it will first read the entire circular shape and ignore the central hole.

Once the general morphing shape is analyzed, the system will carry on analyzing the interior details such as
colour zones and holes.

As you can see, because the hole was placed on top after the main shape was morphed, the centre is filled with
an opaque brown colour. In order to avoid opaque holes, you have to paint the zone with a transparent colour
so that you can control it and flatten the transparency to cut a hole through the main shape.
The same thing happens when you have holes painted with semi-transparent colours. To see through your
shapes, you have to follow the same process as morphing shapes with holes.
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To morph a shape with a hole:
1. In your Colour view, select an unused colour swatch and set its alpha (transparency) to 0.

2. Paint both holes on the source and destination drawings.

3. In the Timeline or Xsheet view, click on a cell in your morphing sequence.

4. In the Tools toolbar, select the Morphing

tool or press [F3].

5. In the Tool Properties view, enable the Flatten

option.

A hole appears in the shape.
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Related Topics
•

Creating a Basic Morphing Sequence on page 534
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Adjusting the Morphing Quality
To improve the morphing quality, zoom in close to a morphing animation when compositing.

Increasing the quality improves the line shape between vector points. It also creates a larger file, so only increase
quality when you are zooming in close.
To set a morphing sequence's quality level:
1. In the Timeline or Xsheet view, click on a cell in your morphing sequence.

2. In the Tools toolbar, select the Morphing

tool or press [F3].

3. In the Tool Properties view, increase or decrease the quality level by dragging your cursor up or down.
You can also type a new value directly in the text field.

Related Topics
•

Creating a Basic Morphing Sequence on page 534
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Tips and Tricks
This section provides a list of easy tips and tricks to help you morph your drawings more efficiently.

Morphing Similar Shapes
Similar shapes have the same number of colour zones. This only applies to the number of zones and lines and not
the number of points on a curve.

Avoiding Crossing Zones During Morphing
If a zone inside a larger zone on the source drawing ends up outside on the destination drawing, the morphing
will fail.
A line cannot cross another line during a morphing sequence.
For example, if you are morphing a face so it turns from the front to the side, the nose is located in the middle of
the face on the source drawing. However if after morphing, the nose ends up outside or merged with the face
profile line on the destination drawing, this will give undesirable results. You can avoid this by using morphing
layers and splitting the nose on a separate layer.

Using the Brush Tool as a Beginner
When learning about morphing, it is recommended that you use the Brush tool. You can use the Pencil line for
simple closed shapes.

Flattening Drawings
Flatten your drawing before starting a morphing sequence.

Cleaning-up your Drawings
If you leave a dot, even the smallest one, it is possible that your morphing will create odd shapes. If the source
line is closer to the dot than the destination line, the source line will morph into the dot and the destination line
will disappear.

Using the Same Colour Swatch
Use the same colour swatch between two drawings. You cannot morph between two different colour swatches
even if they have the same RGB values. This can be turned to your advantage for complex morphing.

Related Topics
•

Creating a Basic Morphing Sequence on page 534

•

Understanding Morphing on page 528
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Morphing Preferences
To open the Preferences panel:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

Or press [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).

Drawing Tab

Morphing Quality
The Morphing Quality preference is used to set the default quality value for the morphing sequences. If you
change this value, it will not affect the morphing sequence which was created previously.
After a morphing sequence has been created using this default quality value, it's quality can be changed manually
by using the Morphing Tool Properties.

Related Topics
•

Adjusting the Morphing Quality on page 569
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Chapter 9: Import

Toon Boom Harmony allows you to import external content as well as being able to draw directly in the
software. This means that characters, backgrounds and videos created in other drawing, painting and multimedia programs can be brought in and animated. You can import QuickTime videos, pictures, multi-layered PSD
files, as well as AI, SWF and PDF files. You can also scan your images in with a scanner and either import them as
bitmap or vectorize them.

Topics Covered
•

Importing Bitmap Images on the next page

•

Importing PSD Files as Separate Layers on page 584

•

Exporting and Re-Importing a PSD Layout on page 587

•

Scanning Images on page 594

•

Importing AI and PDF Files on page 599

•

Scanning Images on page 594

•

Importing from Adobe Flash on page 602

•

Importing QuickTime Movies on page 606

•

Custom Vectorization Parameters on page 608

•

Import Preferences on page 623

For sound import, refer to Importing a Sound File on page 905.
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Importing Bitmap Images

Images can come in many different file formats and are usually saved in a format that retains the original
specifications set by the image creator. Some formats are able to preserve transparency or transparent layers,
while others are not resolution dependent due to their vector nature. Toon Boom Harmonysupports the
following formats: JPEG, BMP, PNG, TGA, PSD, TIFF, SGI, TVG, OMF, PAL, SCAN.
When importing images and 3D models and linking images, your settings are saved in your user settings.
In this section, you will cover the following topics:
•

Importing a Bitmap Image without Vectorization below

•

Importing and Vectorizing Images on page 579

•

Linking your Layer to an External Image on page 581

Importing a Bitmap Image without Vectorization
A bitmap image is an image composed of pixels that is both size and resolution-dependant.
To import a bitmap image:
1. From the top menu select File > Import > Images. You can also click on the Import Images

button in

the File toolbar.
‣

In the Xsheet view, you can right-click anywhere in the frame area and select Import > Drawings.

The Import Images dialog box opens.
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2. In the Files section, click Browse to find and select one or several images on your computer.
3. In the Layer section, you have the option of creating a whole new layer for your image or adding the image
to an existing layer.
‣

To create a new layer, select Layer > Create Layer(s) > Create Single Layer Named and name your
layer accordingly.

OR
‣

To create a new layer using the file name, select Layer > Create Layer(s) > Create Layer(s) Based on
Filenames.

OR
‣

To add the image to an existing layer, select Layer > Add to Existing Layer and select the layer
already created in your Harmony file from the drop-down menu. If only vector
layers are available
in your scene (and therefore the drop-down menu), you will either have to Vectorize Imported Items,
Create Symbols for imported Items or check both options to put your bitmap image on a vector layer.

Refer to Adding Images to a Bitmap Layer on page 578 for more information.

If you vectorize your image usring the Vectorize as Colour option, you can import it on a vector layer,
and use vector tools on it.

4. In this case, uncheck the Vectorize Imported Items option.
The vectorization options are hidden and the Transparency section appears.
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5. In Toon Boom Harmony, if you want your bitmap images to be encapsulated in a symbol, enable the
Create Symbol for Imported Items option. If not, disable the option. If you chose to add your image to
an existing vector layer then the Create Symbol for Imported Items will automatically be checked and
greyed out.

To learn more about Symbols, refer to Library on page 625.

6. Next, in the Alignment section, you must decide on the size and placement of your image within the
camera frame. Depending on the Scene Settings (the height and width in pixels that you chose for your
project), an image that you import may get scaled to the point where all its individual pixels become
visible.

Be sure that you are in the Camera view’s Render Mode when judging an imported image, otherwise
it may appear blurry.when judging an imported image, otherwise it may appear blurry.

The following three options are available
•

•

Alignment > Rules > Fit
•

If your image orientation is portrait format, this selection will enlarge or shrink (but not distort) to your
image height to match the full height of the camera frame.

•

If your image orientation is landscape format, this selection will enlarge or shrink (but not distort) your
image width matches that of the camera frame.

Alignment > Rules > Pan
This selection achieves the opposite result of the Fit command.

•

•

If your image orientation is portrait, its width will be made to match the width of the camera frame. As
a result, part of the image’s height will extend beyond the height of the frame.

•

This can be useful if you want to make your background move up and down, or from left to right to
make it appear as if the camera is panning, or to actually perform a camera pan.

Alignment > Rules > Project Resolution
This selection will scale the image in proportion to the scene's resolution. The system looks at the
resolution of the bitmap image, for example 4000 x 2000, then compares it to the scene's resolution, for
example 1920 x 1080, and adjusts the scale factor in proportion. So in this example the bitmap would
appear at 208% (4000/1920). If you import a bitmap that is 960 x 540 it will be displayed at 50% (960/1920)
of the size of the project resolution.

7. The last step is to decide on the image’s transparency from the Alpha drop-down menu. For this, there
are four options available. These options deal with the way that the bitmap image will be antialiased,
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more specifically the way that the pixels along the edge are blended in the RGBA (red, green, blue, alpha
(transparent)) channels.

The options are:
‣

Premultiplied with White

Individual pixels at the edge of an image are blended with white.
‣

Premultiplied with Black

Pixels at the edge of an image are blended with black.
‣

Straight

Pixels at the edge of an image are blended with black, white and greys.
‣

Clamp Colour to Alpha

Select this option if you want to premultiply the colour value with the alpha value. When the colour is
clamped to the alpha, the colour value cannot be higher than the alpha value. If you have a pixel of value
R=247, G=188, B=29 and the alpha is 50% (the image is 50% transparent, then the actual RGB value
output would be half of the amounts listed above.
8. Click OK.

Related Topics
•

Adding Images to a Bitmap Layer on the next page

•

Importing and Vectorizing Images on page 579
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Adding Images to a Bitmap Layer
If you want to add more bitmap images to an existing bitmap layer:
1. In the Timeline view, if the bitmap image is contained in a Symbol, double-click on the bitmap symbol cell
to edit the symbol. Otherwise, if the bitmap image is on a bitmap
layer, leave it as is.

2. If necessary, in the Timeline view, pull on the red bracket to extend the exposure.
3. From the top menu, select File > Import > Images. You can also click on the Import Image

button.

The Import Images dialog box opens.

4. Click on the Browse button to find and select one or several images on your computer.
5. In the Layer section, choose Layer > Add to Existing Layer and select the bitmap layer already created in
your Toon Boom Harmony file from the drop-down menu.
6. Uncheck the Vectorize Imported Items option.

7. Disable the Create Symbol for Imported Items option.
8. Click on the OK button.
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Related Topics
•

Importing a Bitmap Image without Vectorization on page 574

•

Bitmap Image Quality below

Bitmap Image Quality
If the bitmap images that you have imported look blurry or slightly pixelated, follow the steps below to clean-up
the image. These steps will effect the quality of the preview in Camera view, but will have no effect on the final
render.
1. In the Camera view, double-click on the bitmap image to enter its symbol if the image is encapsulated or
simply select the bitmap image layer in the Timeline view if it isn’t.
2. In the top menu, select View > Bitmap Image Quality or press [Ctrl] + [Q] (All Platforms).
3. The Bitmap Image Quality dialog box opens.

4. Drag drag the Bitmap Image Quality slider to the right to improve the quality.
5. Click OK.
6. If you are inside a symbol, go to the top of the Camera view and click on Top to exit the symbol and return
to your scene.

Related Topics
•

Importing a Bitmap Image without Vectorization on page 574

Importing and Vectorizing Images

You can turn your images into vector drawings, while maintaining the sketchiness of a pencil line or into vector
images with a bitmap fill. Both options can add life to an animation, which straight vectorization with smoothing
does not usually afford.
To import and vectorize a bitmap image:
1. In the top menu, select File > Import > Images or click the ImportImage
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The Import Imagesdialog box opens.

2. Click Browse to locate images.
3. You can create a new layer for your image or add it to an existing layer.
‣

To create a new layer, select
Create Layer(s) > Create Single Layer Named and name your layer accordingly.

‣

To create a new layer using the file name, select
Create Layer(s) > Create Layer(s) Based on Filenames.

‣

To add the image to an existing layer, select Add to Existing Layer and select the layer already
created in your Harmony scene from the drop-down menu. If only vector
layers are available in
your scene (and therefore the drop-down menu), you will either have to Vectorize Imported Items,
Create Symbols for imported Items or check both options to put your bitmap image on a vector layer.

To mix bitmap images with vector drawings on the same layer, the bitmap image must be
encapsulated in a Symbol and vice versa. When you check the option Create Symbol for Imported
Items, these Symbols will also automatically be added to your Symbol Library.

4. In the Layer section, select the Vectorize Imported Items option.

5. In the Vectorization section, decide whether you want to import your image in colour, black and white, or
grey.
‣

Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based drawing.

‣

Colour: Vectorizes your image as a colourful bitmap texture within a vector frame.
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‣

Grey: Vectorizes your image as a mix of vector contour and greyscale bitmap filling. Lines keep the
texture from the scan, and the white of the paper becomes transparent.

‣

New Preset: The New Preset

button lets you create custom vectorization parameters via the

Vectorization Parameters interface.
‣

Delete Preset: The Delete Preset

button lets you delete any preset in the list.

You can double-click on any of the presets at any time to open the Vectorization Parameters dialog
box to customize your option.

The vectorized images are painted with the Vectorize Line colour swatch from the colour palette.

6. Click OK.

A Symbol or new layer contains the vector drawing. For images contained in a Symbol, double-click on the
image’s first cell in the Timeline view to enter the Symbol so you can edit the image.

Related Topics
•

Importing a Bitmap Image without Vectorization on page 574

Linking your Layer to an External Image
When working on a large production, you may want to centralize your backgrounds into one directory instead of
duplicating your background several times in different scenes. As backgrounds are generally reused in many
scenes, some studios like to save space on the server and link the different scenes to the background directory.
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Also, if they modify one background, it is modified everywhere at the same time without having to re-import it.
To do so, you must use the Timing columns.
Timing columns are Exposure Sheet columns linking to files that are outside the scene’s structure. Because of
these external links, care must be taken not to break the links by moving the scene’s location or the background
directory’s location. Breaking a link will result in images not appearing in your scene.

Refer to the Timing on page 433 chapter to learn more about using Timing columns.

If you are working with Toon Boom Harmony Server and all your scenes are located on a centralized server, you
can also use the Link to Images option.
To link the scene to an external image (Harmony Server only):
1. In the top menu, select File > Import > Link to Images.
The Link to Images dialog box opens.

2. Click on the Browse button to select the image you want to link your scene to.
3. Select the Create Timing Layer option if you want to create a new Timing column in your Xsheet view.
‣

Enable the Create Single Timing Named option and type the new column name in the text field.
OR

‣

Enable the Timing(s) Based on Filenames option if you want the new column to be named like the
selected file.

4. Enable the Add to Existing Timing Layer option if you want to insert the file into an existing Timing
column rather than creating a new one.
5. Enable the Copy to Timing Directory option if you want to copy the selected file into the Timing folder
located in the scene directory. Note that the Timing column will link to the Timing folder.
6. Enable the Vectorize Imported Items option to vectorize the image you want to link to. The original image
will not be modified. A vectorized copy will be placed in the same folder.
7. If you are vectorizing the image, select the vectorization parameters desired.
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Refer to the Custom Vectorization Parameters on page 608 section to learn more about the custom
parameters.

8. If you are linking to the original bitmap image, select the Alignment and Transparency options you want.
The following options are available:
‣

Alignment > Rules > Fit

•

If your image orientation is portrait, this selection will stretch or shrink (but not distort) your image to
match the full height of your project and therefore the camera frame.

•

If your image orientation is landscape, this selection will stretch your image to the full width of the
camera frame.

‣

Alignment > Rules > Pan

This choice will perform the opposite operation of the Fit command.
•

If your image orientation is portrait, its width will be made to match the width of the frame. As a
result, part of the image will extend beyond the height of the frame.

•

If your image orientation is landscape, the image will extend beyond the width of the camera frame.
This can be useful if you want to make your background move up and down, or from left to right to
make it appear as if the camera is panning, or to actually perform a camera pan.

‣

Alignment > Rules > Project Resolution

•

This option will match your project’s resolution and centre your image in the frame. If your image
resolution is smaller than that of your project, such as a 720 x 540 resolution and 640 x 480 image, the
image will become blurry after being imported. Make sure that the size of your image matches, or is
greater than, your scene resolution.

9. Click on the OK button.

Related Topics
•

Importing a Bitmap Image without Vectorization on page 574

•

Importing and Vectorizing Images on page 579
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Importing PSD Files as Separate Layers

PSD files (a format exportable exclusively from Adobe Photoshop) are unique in that they are able to retain
multiple layers. This is advantageous as the image remains fully editable in terms of any colour correction,
effects, masking, transparency, or compositing that were made to the PSD file in Adobe Photoshop.

Note that your PSD image file must be set to RGB mode within Adobe Photoshop prior to being
imported into Harmony.

To import the separated layers of a PSD file:
1. Organize your Adobe Photoshop file so that all your layers are “grouped” into individual folders, or that
all the elements you want to import as a single layer in Harmony are grouped together in their own folder.
Any layer that is not in a folder group, by itself or otherwise, will not be imported.

2. In Harmony, go to the top menu and select File > Import > Images or click the Import Image
The Import Drawings dialog box opens.
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3. Click Browse to find and select the PSD image on your computer.
4. Select the Create Layer(s) option.
5. Select the Create Single Layer Named or Create Layer(s) Based on Filenames option.
6. Decide whether to select Vectorize Imported Items option.

If you decide to use the Vectorize Imported Items option, see Importing and Vectorizing Images on
page 579 to learn more about vectorization settings.

If you decide to disable the Vectorize Imported Items options, the Transparency and Alignment
settings will appear in place of the Vectorization settings—see Importing a Bitmap Image without
Vectorization on page 574.

7. Decide whether to select the Create Symbol for Imported Items option.
8. Click OK.
The Multilayer Image Import Settings dialog box opens.

9. In the Image to Load menu, select:
‣

Composite Image to flatten your layers.
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‣

All Layers Image to keep your layers separated.

10. Select the Transparency Type if applicable. To learn more about the different Transparency Type options,
see Importing a Bitmap Image without Vectorization on page 574.
Your image should appear as separate layers in the Timeline view, corresponding to the PSD layer group
folders.

The artwork displayed in every one of your layers as a result of a multilayer PSD file import is linked
to the same source image. This means that if you use the Drawing > Delete Selected Drawings
command to physically delete the drawing from the project folder, the exposed drawing will be
deleted in all layers at once. Once deleted from the project folder, the image cannot be retrieved
unless you reimport your psd file.

Related Topics
•

Exporting and Re-Importing a PSD Layout on the facing page
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Exporting and Re-Importing a PSD Layout

Toon Boom Harmony allows you to export the content of your scene as a PSD layout. This can be helpful for
scene setup, background art retakes or even planning of animation.

Refer to Scene Setup on page 761 to learn more about the scene setup task.

Related Topics
•

Exporting a Layout below

•

Importing a Layout on page 591

Exporting a Layout
It is necessary to have all of your elements well positioned before you export your layout. If you plan to have a
camera movement in this scene, you should also set this up, as you can export the camera keyframes to generate
a clear and complete layout.
You could also create all of the layouts for your production in the same Toon Boom Harmony project. These
layouts can be imported later on when you start each scene’s project, this will help setup this will help to setup
the scene and begin it’s creation. These layout PSD files can also be used to create the background art of each
scene and make sure everything is correctly framed and at the right size. Finally, you can also have a layer
containing a drawing of the rough poses of the character or action and generate your layout posing from there.

Note that only the first frame of your drawing layers will be exported, as the layout image is one static
PSD file.
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Refer to the following chapters to learn more about scene setup, camera moves and drawing:
•

Drawing on page 151

•

Scene Setup on page 761

•

Animation Paths on page 937

To export your scene as a Layout:
Before you do this you should position your background elements, and everything you need as a reference in
your scene, including a camera movement.
1. Select File > Export > Layout Image to export all the elements of your scene in the layout PSD file
or if you want only the selected elements to be exported then select File > Export > Layout Image from
Selection.
The Export Layout Image dialog box opens.

2. In the Export Layout Image dialog box setup the export parameters:
Output: In the output section, use the Browse button to select a location where to save your layout and
name the resulting PSD file.
Image Size: This section displays the size of the PSD image file that will be exported. The resulting image
will be 72 dpi as the standard television resolution and its size in pixel will fit your scene resolution
settings. i.e HDTV, NTSC, PAL, etc. Note that if you have a camera movement going over the normal
camera frame limit, for example a pan, the image will be bigger.
Options:
‣

Export Camera Frame: This option is disabled by default. You can enable it to export an additional
layer to your PSD file displaying the camera frame on it.

Add a Camera Frame for each Key Frame:
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This option is disabled by default, meaning that if you have a camera movement with more than a starting
and an ending point, only these positions of the camera frame will appear on the camera layer of the
exported layout PSD file. You must enable this option if you need to the in-between keyframes to also be
displayed.
Label Camera Frame:

Enable this option to add the camera position label in the top corner of the camera frames. The camera
label is a single alphabet letter determining the order of the camera frame position.
Add Border to Layout:

This option is disabled by default, meaning the layout image will take the complete PSD area, cropped at
the very edge of the canvas. You can enable this option to add a transparent area all around the layout.
You must setup the size of this area by using the Scale field lower. The resulting image will be larger.
‣

Scale: Use the Scale field to set the size of the transparent border around the layout image. By default
the value is set to 100%, meaning that the image will be exported as is with no transparent area
around it. When you increase the percentage value the extra space will be added around the image to
create the border.

‣

Adjust Scaling Factor: This option is enabled by default, meaning that when you have a camera zoom
movement, the size of the layout image will be adjusted accordingly. The resulting percentage will be
calculated following the maximal camera zoom value appearing in the layout. This allows the image to
be exported at an appropriate resolution, preventing the layout image from appearing pixelated or
blurry when the camera zoom occurs. You can disable this option to export the image layout at the
normal size.

‣

Scale: When the Adjust Scaling Factor option is enabled, the Scale value is automatically calculated
according to the maximum camera zoom in your layout. You can modify this value.

Vector Options: If you export one or more vector-based drawing layers in your layout image, you have
the option to export only the drawing layers you want. Enable or disable the following options to export
or prevent the export of the corresponding art layers.
‣

Overlay:

Enable this option to export the art contained in the Overlay layer of the drawings to be

exported to the layout image. Disable this option to prevent this art layer from being exported.
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‣

Line Art:

Enable this option to export the art contained in the Line layer of the drawings to be

exported to the layout image. Disable this option to prevent this art layer from being exported.
‣

Colour Art:

Enable this option to export the art contained in the Colour layer of the drawings to

be exported to the layout image. Disable this option to prevent this art layer from being exported.
‣

Underlay:
Enable this option to export the art contained in the Underlay layer of the drawings to
be exported to the layout image. Disable this option to prevent this art layer from being exported.

3. Click OK to validate the settings and export a PSD file of your layout.
The resulting image will be a PSD file containing either one or two layers, each of which is contained in a
corresponding group. These groups make the layout PSD file ready for a multi-layer PSD import.

•

Camera_Set: This group contains the camera drawing layer. This group and layer will only appear in your
layout image if you enabled the Export Camera option during the export.

•

Layout_Set: This group contains a merged drawing layer of all the content of your scene’s first frame
when you exported the layout image.

Along with your PSD file will be exported an XLI file. Do not delete this file and always keep it at the
same location as the layout PSD file. These two files should not be renamed. This XLI file contains all
the necessary information to be able to correctly import and automatically position your layout image
in an Toon Boom Harmony project.
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Refer to the next topic Importing a Layout below to learn how to import a layout image in Toon Boom
Harmony.

Related Topics
•

Importing a Layout below

•

Exporting and Re-Importing a PSD Layout on page 587

Importing a Layout
It is very easy to re-import into Toon Boom Harmony any layout PSD image which was already exported from a
Toon Boom Harmony project.
This layout image should be imported at the beginning of the project to allow accurate scene planning.

Refer to the previous topic Exporting a Layout on page 587 to learn how to create an Toon Boom
Harmony layout.

To import a PSD layout file:
1. In your Toon Boom Harmony project, select File > Import > Images.
The Import Images dialog box opens.

2. In the Files section, use the Browse button to find your PSD layout file. Note that this layout image file
must have its corresponding XLI file in the same folder.
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3. Once you selected the layout image, you will notice a new option appearing in the Layer section.

‣

Use Position Information Contained in XLI file: This option is enabled by default, meaning that when
you import the layout image in your scene, it will be automatically positioned to fit the original layout
scene. Creating an accurate layout guide. You can disabled this option if you want the imported layout
image to be imported according to the normal behavior of the import process. The layout image will
be incorrectly aligned as it was when it was first created.

4. Select Layer > Create Layer(s) > Create Single Layer Named or Create Layer(s) Based on Filenames.
5. Decide whether to check or uncheck the Vectorize Imported Items option.
6. Enable or disable the Create Symbol for Imported Items if you want your layers to be contained in
symbols or not.
7. Click on the OK button.
The Multilayer Image Import Settings dialog box opens.

8. In the Image to Load field, select
‣

Composite Image: To import the Camera and Layout layers merged together.

‣

All Layers Image: To keep your Camera and Layout layers separated.

9. Select the Transparency Type. Refer to the Importing a Bitmap Image without Vectorization on page 574
section to learn more the different Transparency Type options.
10. Click on the OK button.
Your image should appear as separate layers in the Timeline view, corresponding to the PSD layer group folders
Camera_Set and Layout_Set. You can now use this layout as a guide for scene settings.
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Refer to Scene Setup on page 761 chapter to learn more about the scene setup task.

Related Topics
•

Exporting a Layout on page 587

•

Exporting and Re-Importing a PSD Layout on page 587
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Scanning Images

Toon Boom Harmony can receive images from any TWAIN device such as scanners and digital cameras. These
images can either be loaded into your scene as bitmaps or converted into vector- based images that can be
edited using Toon Boom Harmony.
If your operating system does not automatically recognize your device after it has been connected, you must
install the correct TWAIN drivers in order to access its contents. You can usually download the drivers from the
device manufacturer’s website.

TWAIN drivers are not always created for every model of scanner or digital camera. If TWAIN drivers
do not exist for your device, you will not be able to use it with Toon Boom Harmony.

You can scan in a single image or multiple images in the same session. Before you begin scanning, you need to
select your scanning device.
To scan drawings from a TWAIN device:
1. In the top menu, select File > Import > From Scanner.
The Scan Drawings window opens.

594

Toon Boom Harmony 10.3 Stage User Guide

2. Select your scanner or other supported TWAIN device from the drop-down menu. If none are available,
check your device to ensure that it is properly connected to your computer. If your device still does not
appear in the drop-down menu, you may have to shut down and relaunch the software.
3. You can import the images to scan into an existing layer or create a new one.

‣

To import the image into a new layer, enable the Create Layer option. In the Name field, type a name
for the layer.

‣

To import the image into an existing layer, select Add to Existing Layer and select the layer from the
drop-down list.

4. In the Scanner section, click Scan to open the scanning dialog box for your scanner.

5. Use the settings from your scanner to scan your drawings.

You must scan in colour if you want to import your images as vectorized textures (mix of vector and
bitmap) and in black and white if you want a solid black outline.

You can scan multiple drawings with your scanner before returning to the Scan Drawings dialog box.
6. Close the scanner dialog box when you are done.
The Scanner Album opens.
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7. Use the Scanner Album to preview the scanned drawings, remove drawings from the list or change their
order. Harmony will load the drawings based on their order in the Scanner Album.
8. Click Close to close the Scanner Album when you are done.
You will return to the Scan Drawings dialog box.
9. If you want to vectorize the images you import, select the Vectorize Imported Items option.
10. If you want the imported images to be encapsulated in a Symbol, enable the Create Symbol for Imported
Items option.
11. In the File Format drop-down list, select the file format in which you want to scan your drawings.
If you chose to vectorize the images as black and white, SCAN is the best file format to choose.
12. If you chose to vectorize your images, in the Vectorization section, you need to decide whether you would
like to import your image in colour, black and white, or if you would like to add a new preset.

‣

Black and White: This style vectorizes your drawings as a solid black line. This creates a 100% vectorbased drawing.

‣

Colour: This style vectorizes your image as a colour bitmap texture within a vector frame.

‣

New Preset: The New Preset

option or button allows you to create your own custom

vectorization parameters via the Vectorization Parameters interface.
The Vectorization Parameters dialog box will open automatically once you click on this button.
‣

Delete Preset: The Delete Preset

button allows you to delete any preset available in the list.
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Refer to the Custom Vectorization Parameters on page 608 section to learn more about the custom
parameters.

13. If you choose NOT to vectorize your images, then you must decide on the size and placement of your
image within the camera frame. Depending on the Scene Settings (the height and width in pixels that you
chose for your project), any image that you import may be scaled to the point where all its individual
pixels become visible.

The following three options are available:
‣

Alignment > Rules > Fit

•

If your image orientation is portrait, this selection will scale up or shrink (but not distort) your image’s
height to match the full height of the camera frame.

•

If your image orientation is landscape, this selection will scale up or shrink (but not distort) your
image’s size so that it’s width matches that of the camera frame.

‣

Alignment > Rules > Pan

This choice will perform the opposite operation of the Fit command.
•

If your image orientation is portrait, its width will be made to match the width of the camera frame. As
a result, part of the image’s height will extend beyond the height of the frame.

•

If your image orientation is landscape, the image will extend beyond the width of the camera frame.

•

This can be useful if you want to make your background move up and down, or from left to right to
make it appear as if the camera is panning, or to actually perform a camera pan.

‣

Alignment > Rules > Project Resolution

This selection will scale the image up or down in proportion to the scene's resolution. It looks at the
resolution of the bitmap image, for example 4000 x 2000, then compares it to the scene's resolution, for
example 1920 x 1080, and adjusts the scale factor in proportion. So in this example the bitmap would
appear at 208% (4000/1920). If you import a bitmap that is 960 x 540 it will be displayed at 50% (960/1920)
of the size of the project resolution.
14. The last step is to decide on the image’s transparency. For this, there are four options available. These
options deal with the way that the bitmap image has been antialiased; in other words, the edge blending
that has been used to transitions between RGBA (red, green, blue, alpha (transparent)) channels.

The options are:
‣

Premultiplied with White

Individual pixels at the edge of an image are blended with white.
‣

Premultiplied with Black

Pixels at the edge of an image are blended with black.
‣

Straight
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Pixels at the edge of an image are blended with black, white and greys.
‣

Clamp Colour to Alpha

Select this option when you want to premultiply the colour value with the alpha value. When the colour is
clamped to the alpha, the colour value cannot be higher than the alpha value. It calculates the real colour
value faster. When the RGB values are multiplied with the alpha value, that is to say, if you have a pixel of
value R=247, G=188, B=29 and the alpha is 50% or the image has a 50% transparency, then the actual
RGB values output would be half of the amounts listed above.
15. Click OK to import the images into your scene.

Related Topics
•

Cleaning Scanned Drawings on page 332
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Importing AI and PDF Files

You can import AI and PDF files into Toon Boom Harmony, it will convert your files to the Toon Boom format
(TVG) and create a colour palette based on the colour settings of the original file.

Only Legacy versions of Adobe Illustrator are supported. SWF's exported, including Actionscript 2
and Actionscript 3, cannot be imported.

To import an AI or PDF file:
Go to the Library view andright-click on the Stage Library folder. Choose Right to Modify to unlock the library
folder. Make sure the Lock icon disappears from the folder to unlock it, otherwise your library will remain locked
and not editable.

The option to import will not be available until this step is completed successfully
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For more information about the Library, see the Library on page 625 chapter.

1. In the top menu, select File > Import > SWF, Illustrator Files to Library. Orright-click on any unlocked
folder and select Import Fi les.
The browser window opens.
2. Find and select your AI file in the Import Files dialog box and click on Open.
The Rename dialog box opens.

3. Enter a name for the new template or keep the name of the original AI or PDF file.
4. Click OK.
5. Click and drag the new template folder from the Library view to the left side of the Timeline view; wait
until the copy cursor

appears before releasing the mouse button.

6. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before clicking
on the Yes button, you have the option to select the Do Not Ask Again For This Session option. This
might be useful if you plan to import multiple AI drawings.
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This process will import the colour palette used to create the Illustrator file and create a new palette in
Toon Boom Harmony under the imported file’s name.

Refer to the Import Preferences on page 623 section to learn about the Support CMYK in
PDF/Illustrator Import preferences.

Related Topics
•

Importing and Vectorizing Images on page 579

•

Importing from Adobe Flash on the next page

•

Import Preferences on page 623
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Importing from Adobe Flash

If a projects was started in Adobe Flash and it needs a more professional boost, such as camera movements or
multiplaning it can easily be imported into Toon Boom Harmony. The actual *.fla file is not supportable, so you
have to export your project to an *.swf movie.
To import a Flash file:
1. Go to the Library view and right-click on the Stage Library folder. Choose Right to Modify to unlock the
library folder. Make sure the Lock icon disappears from the folder to unlock it, otherwise your library is
locked and not editable.

The option to import will not be available until this step is completed successfully.

For more information about the Library, see the Library on page 625 chapter.

2. In the top menu, select File > Import > SWF, Illustrator Files to Library.
You can also right-click on any unlocked folder and
select Import Files.
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The browser window opens.
3. Find and select your .swf file in the Import Files dialog box and click on Open.
The Rename dialog box opens.

4. Enter a name for the new template or keep the name of the original *.swf file.
5. Click on the OK button.
6. Click and drag the new template folder from the Library view to the left side of the Timeline view; wait
until the copy cursor
appears before releasing the mouse button.

7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before clicking
on the Yes button, you have the option of selecting the Do Not Ask Again For This Session option. This
might be useful if you plan to import multiple *.swf movies.
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This process will import the colour palette used to create the Flash file and create a new palette in Toon
Boom Harmony under the imported file’s name.

All the Flash layers are automatically attached to a parent peg called GlobalFlashPeg.
DO NOT DELETE THIS PEG. To maintain the look of your movie, it is important that this peg is not
deleted, nor its child layers detached.

The Adobe Flash file layers should now appear in the Timeline view. Symbols that were created in Flash become
regular drawing layers, but can be reconverted into Symbols in Toon Boom Harmony. Symbols within symbols or
drawings within symbols collapse into their corresponding parent symbol.

Some of the layers contained in your SWF movie could end up being combined in a single layer as a
result of optimization enhancement in your movie file. You can easily bring these elements back on
separate layers. Refer to the Distribute To Layers below section to learn how.

In addition, all drawing elements that are dynamically linked to the Toon Boom Harmony file are grouped
together in one folder. This means that when you scroll through the Drawing Substitution preview in the Library
view, the different hand, leg, tentacles, antennae, torso and facial positions are all organized together.

Related Topics
•

Distribute To Layers below

•

Importing AI and PDF Files on page 599

Distribute To Layers
In some instances, due to an optimization enhancement in the exported SWF file (CS4), some of the layers might
be combined as a single layer. In that case, use the Distribute to Layers feature to quickly redistribute these
elements onto individual layers again.
To distribute to layer:
1. In the Tools toolbar, click on the Select

tool.

2. In the Camera view, select the drawing you want to redistribute the elements from. To select the all the
elements of the selected drawing layer, press [Ctrl] + [A] (Windows/Linux) or [⌘ ] + [A] (Mac OS X).
3. From the top menu, select Drawing > Distribute to Layers. You can also click on the Distribute to Layers
button in the Select tool’s Tool Properties view.
The number of drawing layers corresponding to the different grouped elements are created in the
Timeline view.
‣

The selected elements in the original drawing layer will be removed.

‣

Each element will be distributed into each new drawing layer.

4. Repeat the process for every drawing you need to distribute the element from.
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Related Topics
•

Importing from Adobe Flash on page 602

•

Select Tool Properties on page 219
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Importing QuickTime Movies

When creating an animation, it is not unusual to embed moving elements saved as videos within the animation.
Toon Boom Harmony allows you to import QuickTime movies into your project.
To Import a QuickTime movie:
1. In the top menu, select File > Import > Movie.
2. Browse for the QuickTime movie to import and click Open.
A progress bar appears.

The Import Drawings dialog box opens.

Do not browse for the movie file again; leave the automatically generated field text as “many files
selected”.

3. Make your decisions for the Layer, Alignment and Transparency.
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Refer to the Importing a Bitmap Image without Vectorization on page 574 section for further details
about the Import Drawings dialog box.

4. Click OK.
The QuickTime video appears in the Timeline view as an image sequence. You should be able to scroll through
the film frame-by-frame, just as you would scroll through your animation drawing-by-drawing.

Related Topics
•

Importing a Bitmap Image without Vectorization on page 574
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Custom Vectorization Parameters
You can create your own vectorization settings with Toon Boom Harmony.
The vectorization parameters you will create here can be saved, shared and also inserted into the
VectOptions.conf file used by the Harmony Scan and Control Center modules when scanning or vectorizing a
series of drawings.
You can use an interface to select and test the different options and you can also type in some advanced
settings.
To open the Vectorization Parameters dialog box:
1. Select File > Import > Images.
You can also open it from any other Import option that allows you to customize the vectorization
parameters (i.e. From Scanner).
2. Browse for and select your file and decide on your Layer options.
3. In the Vectorization section, click the Add New Preset
The Vectorization Parameters dialog box appears.

•

Options Tab on the facing page

•

Help Tab on page 611
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Options Tab
The options tab contains the main vectorization settings. More settings are available in the Help tab.

Input
The input filters are applied to the bitmap image before it is vectorized.
•

One Pass and Two Passes:
•

If you select one pass, one threshold value will be applied to both the Line and Colour Art. For
drawings with distinct vector-style lines of mattes, you only need one pass.

•

If you select two passes, you can apply a different threshold value to each layer.

For grayscale drawings, you may want to pass through the vectorization process twice to apply different
threshold values to the Line and Colour Art layers.
•

Threshold: Determines which values in the scanned image are considered part of the Line or Colour Art
layer and what will be eliminated from the vectorized drawing, 0% (zero) is white and 100% is black. The
threshold is between those two values.

•

Expand Bitmap: Enter a value to scale the bitmap to detect small variations in the line. Use this option if
you scanned a grayscale image and want to preserve small variations in the texture that will be applied to
the line art.

•

Jag Filter: Enter a value to scale back the bitmap to remove some of the line’s roughness. If you have a
drawing that appears quite rough, use the jag filter to eliminate excess strokes in the final drawing.

Output
The output filters are applied during the vectorization process.
•

No Colour Art: Does not generate filling zones in the Colour Art layer.
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•

No Texture: Does not generate texture in the Line Art in the final images. Select this option to create
solid lines in the final Line Art.

•

Generate Matte in Underlay Layer: Creates an opaque zone behind your drawing’s lines to avoid seeing
through the layers.

•

Colour as Texture: Converts colour values into a texture layer.

Optical Registration
The optical registration options are used to automatically align drawings based on the position of peg holes on
the animation paper. The peg holes must appear in the scanned drawings for the optical registration to work.
•

Optical Registration: Use peg holes to align drawings optically.

•

DPI: Type the dots-per-inch value of your image. You must enter the same value as the DPI used to scan
the image.

•

Peg Side: Select the position of the peg holes on your drawings. Identify whether they are on the top,
bottom, left or right.

•

Strictness: Determine how exact the location of the peg holes must be for the software to recognize
them. You have two values to choose from:

•

•

Strict: The peg holes must be in a tightly defined area to be recognized.

•

Loose: The peg holes can be recognized somewhere in a larger area. This is the recommended
setting.

Field Chart: Select 12 or 16 to indicate the size of your animation paper.

Post Processing
The Post Processing filters are applied to the final vector images.
•

Remove Holes: Removes holes of a specified value that might make painting difficult.

•

Remove Dirt: Removes stray marks and dirt of a specified value. Try a value around 500.

•

Remove Hair: Removes small strokes that have no line art.

•

Remove Hair: Number of Passes: The number of times the drawing will be analyzed to identify hair
marks.

Miscellaneous
•

Close gaps: Closes gaps in the Colour Art so that you can paint it.

•

Smooth passes for Line Art before breaking triangles: The number of times the smoothing operation
runs before creating the triangles that break lines in your drawing. If unnecessary triangles are appearing
in your drawing, increase this value.

•

Smooth passes for Line Art: The number of times the smoothing operation is performed after the
triangles have been created. This further smooths the Line Art.
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Preview
•

Show strokes: Shows the strokes in the Vectorized Image panel.

•

Stroke thickness: Shows the size of the strokes.

Help Tab
The Help tab contains the most advanced vectorization settings. You must type those in the Advanced Option
fields located at the bottom of the Options tab.

File IO Options
-file <filename (including extension)> [ options ]
-infile <filename (including extension)>; same as -file
-outfile <filename>; alternate output file
-informat <format>; the input format. Used if reading from stdin
-debug; turn on debug mode
-noforce; don't force output if image is inconsistent
-version; print version information and quit
-output_version <version>; output files of this version. Valid versions can be: 0 or 604
-force_unamed_palette_for_texture; will generate a texture in TVG's internal palette

Registration Options
-register <dpi side strictness>; perform optical registration.
•

Side can be one of left, right, top, bottom or l, r, t, b.

•

Strictness can be either loose, strict or l, s.

-register_center_peg_holes; will use only round holes in 16 fields page
-rcph; short form of register_center_peg_holes
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-registration_looseness_factor <factor>; registration looseness factor (default 2.000000)
-rlf; short form of registration_looseness_factor
-rdebug; output registration debug messages
-pegpitch <inch (default 8.000000)>; distance between peg bars
-threshr < (default 0.500000)>; threshold for optical registration; range 0.0 to 1.0
-rmargin <inch (default 1)>; region size where to look for peg bars
-peg_distance_from_center <inch (default 5.25)>; peg distance from centre of the image
-pdfc; short form of -peg_distance_from_center
-out_peg_position <side (default same)>; wanted position of the peg on the drawing.
•

Can be one of right, left, top, bottom (or r, l, t, b) or same.

•

A rotation will be performed if it is different from the side passed to -register.

-output_peg_matrix; output the peg transformation matrix on standard output.
-scanner_calibrate; < (default 1.0000 1.0000) > x and y scale factors to be applied to scanner image.

Filtering Options
-pixel <pixel_shape (default '4x3')>; Valid values: 4x3
-gap <worldUnits (default 10)>; close gaps up to this big
-pencil; generate line art only
-keep_dirt; don't filter out dirt
-thresh <threshold (default 0.2)>; range 0.0 to 1.0
-rmv_hairs <worldUnits (default 1)> <passes (default 1)>
•

remove hairs of size smaller than "size" in "passes" passes

-rmv_holes <area (default 7)>; remove holes smaller than "area"
-rmv_dirt <area (default 1)>; remove dirt smaller than "area"
•

try values between 100 and 500 for rmv_holes and rmv_dirt. The area is in world units squared

-rmv_triangles <worldUnits (default 30.000000)>; remove triangles at "pixels"
•

distance from each other. Use -no_break to remove all triangles

-no_texture; don't generate textured strokes
-color_as_texture; will vectorize the alpha channel and put the RGB colour in a textured colour
-noclosegap; disable all gap closing algorithms
-no_break; disable the breaking of line art
-jag_filter <pixels (default 0>; expand the pixels in the vectorization bitmap
-expand_bitmap <pixels (default 0>; expand the pixels in the vectorization bitmap
-fit_errorc <error (default 1.000000>; fitting error for the colour art
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-fit_errorl <error (default 1.000000>; fitting error for the line art
-smoothl <passes (default 1>; number of smooth passes for line art
-smoothc <passes (default 1>; number of smooth passes for colour art
-first_smooth <passes (default 0>; number of smooth passes for line art before breaking triangles
-first_smoothl <passes (default 0>; number of smooth passes for line art before breaking triangles
-first_smoothc <passes (default 0>; number of smooth passes for line art in colour art pass (needs -2pass)
-2pass; specify two sets of parameters; one for line art "l", one for colour art "c"
(-thresh, -rmv_holes and -rmv_dirt will be overridden by -threshl, threshc, -rmv_holesl,
-rmv_holesc, -rmv_dirtl and -rmv_dirtc)
-threshl <threshold for line art (default 0.5)>; range 0.0 to 1.0
-threshc <threshold for color art (default 0.5)>; range 0.0 to 1.0
-jag_filterl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art
-jag_filterc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art
-expand_bitmapl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art
-expand_bitmapc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art
-rmv_holesl <area (default 7)>; remove line art holes smaller than "area"
-rmv_holesc <area (default 7)>; remove colour art holes smaller than "area"
-rmv_dirtl <area (default 1)>; remove line art dirt smaller than "area"
-rmv_dirtc <area (default 1)>; remove colour art dirt smaller than "area"
try values between 100 and 500 for rmv_holesl, rmv_holesc, rmv_dirtl and rmv_dirtc. The values are in
world units squared
-margins <inch (default 0.25)>; remove margin around bitmap
-top_margin <inch (default 0.25)>; remove margin at top of bitmap
-bottom_margin <inch (default 0.25)>; remove margin at bottom of bitmap
-left_margin <inch (default 0.25)>; remove margin at left of bitmap
-right_margin <inch (default 0.25)>; remove margin at right of bitmap
-remove_peg_bars; remove the peg bar holes
-field_size <fields (default 12 or use value in scan file)>; set the drawing to this field size
-fs; short hand for -field_size
-peg_bar_size <inch (default 1)>; the size of the peg bar region
-noframe; do not put a frame around the colour art
-frame_fields <default -1.000000>; put a frame of the specified dimension around the colour art
-downscale_input <default 1>; downscale the raw input by this integer factor
-downscale_texture <default 1>; downscale the output texture by this integer factor
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-buildmatte; generate a matte on underlay for line test
-buildmatte_colourart; generate a matte on colour art for line test
Note: -buildmatte and -buildmatte_colourart are mutually exclusive
-copystrokes; copy original strokes when building matte.

Options for bitmap that has no registration information
-pixel_margins <inch (default 0)>; remove margin around bitmap
-top_pixel_margin <inch (default 0)>; remove margin at top of bitmap
-bottom_pixel_margin <inch (default 0)>; remove margin at bottom of bitmap
-left_pixel_margin <inch (default 0)>; remove margin at left of bitmap
-right_pixel_margin <inch (default 0)>; remove margin at right of bitmap
-dpi <(default -1)>; dpi information of input bitmap

RGB Keying Options
-rgb; generate separate zones for red, green and blue lines
-rgb_alpha <value (default 255)>; generate red, green and blue colour with alpha of this value
-no_red; ignore red colour in vectorization
-no_green; ignore green colour in vectorization
-no_blue; ignore blue colour in vectorization
-flatten; flatten the drawing after generating colours
-rmv_rgb_dirt <threshold area default 0.0>; remove red, green and blue regions smaller than area
-expand_bitmap_rgb <pixels (default 0>; expand the pixels in the vectorization bitmap for rgb
-threshrgb <value> <threshold for rgb vectorization default 0.200000>;
-threshsv <saturation threshold default 0.500000> <value threshold default 0.500000>; thresholds on
saturation and value to consider a pixel to be grey

Colour Vectorization Options
-color_vectorize; perform a colour vectorization
-file2 <colour art filename>; specify the colour art bitmap
-penstyle <center alpha (0.0-20.0)> <edge alpha (0.0-20.0)> <gamma (0-10)><centre pressure effect (0.0-1.0)>
<edge pressure effect (0.0-1.0)><texture bitmap downscaling (0.2-20)> <texture bitmap file (valid filename or
"" if no file)>; generate brush texture for the line art
-pressure_variation <strategy (0, 1 or 2)> <min pressure (0.0-1.0)> <max pressure (0.0-1.0)> <max variation
(0.0-1.0)>; specify a pressure strategy for the centre line.
-blur_radius <pixels (default 0)>; blur the penstyle texture generated
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-color_contour_smooth_passes <times (default 3)>; perform number of smooth passes on contour before
computing texture
-ccsp <times (default 3)>; short for -color_contour_smooth_passes
-color_rmv_holesl <world units (default 0.000000)>; remove holes of this size when computing texture
-color_fill_holesl <world units (default 0.000000)>; fill holes of this size for colour line art

Bubble Usage (implemented only for colour vectorization's line
art)
-create_bubbles; add bubbles into the LineArt. Implemented for colour vectorization only
-bubble_gap <value (default 3)>; max number of colour art points between 2 bubbles
-bubble_length <value (default 10)>; max number of circles in a bubble
-min_radius <value (default 1.5000)>; min radius of a circle in a bubble relative to the line thickness (must be >=
1.0)
-max_radius <value (default 3.5000)>; max radius of a circle in a bubble relative to the line thickness (must be >=
1.0)
-uniform_gap; the space between bubbles is constant

4 Colour Vectorization
-4colours [key:value] ... [key:value] ; The key value list can be empty. The list of keys is:
rgbdiff:value ; between [0.0-1.0] or [0-255]
dark:value ; between [0.0-1.0] or [0-255]
grey:value ; between [0.0-1.0] or [0-255]
white:value ; between [0.0-1.0] or [0-255]
dirt:value ; dirt area. 200 is a good value
rt:value ; between [0.0-1.0] or [0-255]
gt:value ; between [0.0-1.0] or [0-255]
bt:value ; between [0.0-1.0] or [0-255]

Note: There must be no space between the : and the key/value
Ex: -4colours rgbdiff:20 dark:20 grey:120 white:250 dirt:200 rt:240 gt:240 bt:240

Use the Vectorization Parameters dialog box to vectorize your pencil drawings, along with any red, blue or
green pencil marks that you may have used to indicate highlights and shadows. The system will vectorize the
drawing into pure red, blue, green and black (RGB values), while creating colour art zones wherever lines
connect. After painting in your tones and highlights, change your pure RGB colours to transparent (0 Alpha) in
the Colour Picker window and watch the indicator colour zone lines disappear.
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Related Topics
•

Creating a Vectorization Style below

•

Setting the VectOptions.conf File on the facing page

Creating a Vectorization Style
With Harmony, you have the possibility to create your own custom vectorization parameters that can be saved
and reused over and over.
You can vectorize your drawings using one of the following method:
•

Black and White, where all your lines become vector based, and 100% black and the white areas become
completely transparent.

•

Greyscale, where all your lines preserve their initial textured look in grey shades as a bitmap image
contained inside a vector frame, and the white areas become completely transparent.

•

Colour, where your actual image is completely preserved, as is as a bitmap image contained in a vector
frame.

•

Four Colours, where using the advanced parameters you can isolate red, green, blue and black lines and
turn them into 100% vector lines, thus preserving their original colours. See 4 Colour Vectorization on the
previous page.
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To create or modify the vectorization parameters:
1. Enable or disable the different options available in the Vectorization Parameters interface.

2. Click on the Vectorize

button to update the Vectorized Image preview.

The vectorized image is just a preview. The actual vectorization occurs when you click on the OK button in
the Import Images dialog box.
There are a number of options to try in the Vectorization Options dialog box. These are applied during
the vectorization process.
3. If you want to set advanced parameters, read the information located in the , then type in the Advanced
Options field located at the bottom of the Options tab.
4. If you want to save your vectorization parameters to either reuse them later, share them or use them to
set the Harmony Scan module vectorization style list, click Save.
5. In the Browser window, name and save the file.

6. If you want to save the current settings as your default settings, click Save As Default.
‣

If you want to restore the original Toon Boom Harmony’s default settings, click Restore Defaults.

7. If you want to load a vectorization style, click Load and locate the existing *.vof file.
8. Click OK to finish the vectorization setup.

Related Topics
•

Custom Vectorization Parameters on page 608

Setting the VectOptions.conf File
Toon Boom HarmonyServer uses a file called VectOptions.conf to get the vectorization style when batch
vectorizing a series of drawings. A series of default styles are available in this file, but you will certainly want to
create your own to fit your production style.
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This section deals with setting the VectOptions.conf file on:
•

Setting the VectOptions.conf File on Windows and Mac OS X below

•

Setting the VectOptions.conf File on Linux on page 620

Setting the VectOptions.conf File on Windows and Mac OS X
To set your VectOptions.conf file on Windows or Mac OS X:
1. Open the vectOptions.conf file:
‣

Windows: Select Programs / All Programs > Harmony 10.3 > Tools > Configuration Editor.

‣

Mac OS X: Select Applications > Harmony 10.3 > Tools > Configuration Editor.

The Configuration Editor window opens.

2. In the bottom section of the window, select the VectOptions.conf tab.
3. Scroll down the VectOptions.conf file. You will see all the different options available to create your custom
vectorization style. These options are the same as in the Vectorization Parameters dialog box. It is
recommended to create your vectorization style using Toon Boom Harmony and the Vectorization
Parameters window and copy the result parameters in this file.

Refer to the Creating a Vectorization Style on page 616 topic to learn more about creating a style
using the Vectorization Parameters dialog box.

4. Scroll down toward the bottom of the file to see the default styles. You can modify them or add new ones
to the list using the parameters you got using the Vectorization Parameters window.
You will notice that some of the lines have a “#” sign at the beginning. This means that the line is a
comment and will not appear in your style list. The lines that have no sign at the beginning appear in the
style list.
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5. To create a new style, below the existing ones, type style_name: and the name of your new style, for
example: style_name: Black Lines.
6. Under the style name line, type options: and copy and paste the information you got in your *.vof style
when saving your settings in the Vectorization Parameters window.
‣

To open the *.vof file, use any plain text editor application.

7. In the Configuration Editor’s top menu, select File > Save.
8. If you have Toon Boom Harmony Scan on your computer, you can launch the application and verify that
the new style appears in the Vectorization Style list under Edit > Vectorization Style.
Note: If you are using the batch processing method available with Toon Boom Harmony Server to scan
and vectorize your drawings, the select style must be available on all the machines included in the batch
processing list.

Refer to the Control Center and Server User Guide to learn more about setting up and using batch
processing.
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Setting the VectOptions.conf File on Linux
These are the two methods used to edit the VectOptions.conf file on Linux.
•

Using the “vi” text editor

•

Using the “gedit” text editor

To set your VectOptions.conf file on Linux using the “vi” text editor:
1. Open a Terminal window:
Menu: Applications> System Tools> Terminal
2. Open the etc folder inside the installation directory:
$ cd /usr/local/ToonBoomAnimation/harmony_10.0/etc
3. Change your user to "root":
$ su
‣

If your user is part of the sudoers list, enter the following command and go to Open the
'VectOptions.conf using the "vi" text editor::
$ sudo vi VectOptions.conf

4. Enter the "root" password.
5. Open the 'VectOptions.conf using the "vi" text editor:
$ vi VectOptions.conf
6. To start editing, press the [i] key on your keyboard to enter Insert mode.
7. Once you're done editing the file, press the escape [Esc] key to exit Insert mode.
8. To save the changes made to the file, type the following and press [Enter/Return]:
$ :w!
9. To exit the "vi" editor and return to the Terminal, type the following and press [Enter/Return]:
$ :q
10. If you have Toon Boom Harmony Scan on your computer, you can launch the application and verify that
the new style appears in the Vectorization Style list under Edit > Vectorization Style.
Note that if you are using the batch processing method available with Toon Boom Harmony Server to
scan and vectorize your drawings, the select style must be available on all the machines included in the
batch processing list.
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Refer to the Control Center and Server Guide to learn more about setting up and using batch
processing.

To set your VectOptions.conf file on Linux using the “vi” text editor:
1. Open a Terminal window:
Menu: Applications> System Tools> Terminal
2. Open the etc folder inside the installation directory:
$ cd /usr/local/ToonBoomAnimation/harmony_10.0/etc
3. Change your user to "root":
$ su
‣

If your user is part of the sudoers list, enter the following command and go to Open the
'VectorOptions.conf using the "gedit" text editor::
$ sudo gedit VectOptions.conf

4. Enter the root password.
5. Open the 'VectorOptions.conf using the "gedit" text editor:
$ gedit VectOptions.conf
6. Edit the parameters of the VectOptions.conf file like you would do in most text editor application.
7. To save your changes, select File> Save.
8. To exit the editor, select File> Quit.

If you have Harmony Scan on your computer, you can launch the application and verify that the new
style appears in the Vectorization Style list under Edit > Vectorization Style.
Note that if you are using the batch processing method available with Toon Boom Harmony Server to
scan and vectorize your drawings, the select style must be available on all the machines included in
the batch processing list.
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Refer to the Control Center and Server Guide to learn more about setting up and using batch
processing.

Related Topics
•

Creating a Vectorization Style on page 616

•

Custom Vectorization Parameters on page 608
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Import Preferences
In the Preferences panel, you will find the following preference that is related to importing PDF and Illustrator
files in your project.

Advanced Option
•

Support CMYK in PDF/Illustrator Import: When this preference is enabled, you will be able to
successfully import PDF and AI files that were created or exported in CMYK mode. The colours of the
resulting imported image may still not look 100% faithful to its CMYK original due to the RGB conversion.
It is recommended that you convert these files to RGB images before importing them into Toon Boom
Harmony. Disabling this function will cause all the colours of the imported image to be displayed as red to
indicate that the file was not converted to RBG prior to import.
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Chapter 10: Library

You can share and reuse any elements you create in Toon Boom Harmony using symbols and Templates.
Harmony has a library where you can store several different elements such as puppets, backgrounds, animations
and keyposes. In fact, anything you create in Harmony can be stored in the library.

Topics Covered
•

Understanding the Library Concept on the next page

•

Library View on page 629

•

Structuring the Library on page 632

•

Symbols on page 637

•

Templates on page 646

•

Importing Symbols and Templates on page 651

•

Template Preferences on page 663
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Understanding the Library Concept

Understanding the Library Concept
Use the Library view to reuse your artwork and animation in other scenes or to build props and puppets.
•

What is a Library? below

•

What is a Symbol? below

•

What is a Template? on the facing page

•

Library in Harmony Network on the facing page

What is a Library?
A library is a folder where you store your templates and symbols. You can access these folders from different
projects. Using the library is easy, just drag the content into the library to store your artwork and then drag it
into your Timeline or Camera view when you want to reuse it.
Organize your library using subfolders. You can keep several different library folders on your hard drive or
network.

What is a Symbol?

A symbol is a container or construction block used to build your props, puppets and looping clips. You can use
symbols to contain artwork and animation, to manipulate them as a single object, or as a case holder where you
will put a series of different drawings for each body part of your puppets, or when you have a repeating cycle.
However, symbols are not necessary for creating characters.
To create a symbol, drag your artwork to the Symbol library. When you drag a symbol from the Symbol library
into your scene, it will be linked to the original one. If you drag a symbol into your scene several times in the
Timeline view, they will all be linked to the original one. If you modify one, they will all be modified.
A symbol is local to the project and cannot be accessed directly from other scenes. To reuse a symbol's content
into another scene, you must create a template out of it.
When a symbol is exposed in the Timeline view, the symbol's cells are represented as a movie strip.
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What is a Template?

A template is an individual copy of the artwork stored in the library. This package can be reused in different
scenes. Once a template is stored in the library it can be accessed from any project.
Dragging a template into your scene copies the content in your Timeline and does not link it to the original. This
individual copy can be modified at will.

Library in Harmony Network
The library is a storage centre for all of the production assets; the elements stored in the library are called
templates. Although it is mainly used for cut-out animation, the library also serves paperless and traditional
animation processes. The library can contain any asset used in a Toon Boom Harmony production.
When working on the database, the structure of the library differs from when working on Harmony Stage as a
stand-alone application.

Harmony provides different library folders. There are three default library folders available:
•

Symbols
The only library folder containing symbols for your project. You can organize the symbols library folder
using subfolders, but you cannot create a second library for your symbols. This library is local to your
project.

•

Environment
A folder located inside the Environment folder. Every asset stored in this folder is accessible from any job
and scene contained within this environment.

•

Job
A folder located inside the Job folder. Every asset stored in this folder is accessible from any scene
contained within this job.

627

Chapter 10: Library

Library in Harmony Network

You can create a folder called "library" in the usa_db folder on the server to create a Global library.
Once the Harmonyapplication is restarted, a "Global" library folder will automatically appear in every
user's library. Every asset stored in this folder is accessible from any scene, job and environment.

Related Topics
•

Library View on the facing page

Library in Harmony Network
The library is a storage centre for all of the production assets; the elements stored in the library are called
templates. Although it is mainly used for cut-out animation, the library also serves paperless and traditional
animation processes. The library can contain any asset used in a Toon Boom Harmony production.
When working on the database, the structure of the library differs from when working on Harmony Stage as a
stand-alone application.

Harmony provides different library folders. There are three default library folders available:
•

Symbols
The only library folder containing symbols for your project. You can organize the symbols library folder
using subfolders, but you cannot create a second library for your symbols. This library is local to your
project.

•

Environment
A folder located inside the Environment folder. Every asset stored in this folder is accessible from any job
and scene contained within this environment.

•

Job
A folder located inside the Job folder. Every asset stored in this folder is accessible from any scene
contained within this job.

You can create a folder called "library" in the usa_db folder on the server to create a Global library.
Once the Harmonyapplication is restarted, a "Global" library folder will automatically appear in every
user's library. Every asset stored in this folder is accessible from any scene, job and environment.
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Library View

You use the Library view to create and manage your symbols and templates, display the folders and manage and
all of the content.
1. Library View Menu below
2. Preview and Drawing Substitution below
3. Library Search Tool on the next page
4. Library List on the next page
5. Templates and Symbols List on page 631

Library View Menu
The Library View menu lets you access commands specific to the Library view such as opening a Library or
getting the rights to modify a library folder.

Preview and Drawing Substitution

The Preview window, allows you to preview the content of a symbol or template and to swap between drawings
and symbol cells in your Timeline view. This window is also used as the Drawing Substitution window.
To preview a template or symbol's content:
1. In the Library view's right side, click or double-click on the symbol or template to preview.
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Library Search Tool

2. In the Preview window, click on the Play

button or drag the slider to scrub through the frames.

Library Search Tool
When working on a movie or series, you will most likely end up with a lot of templates and symbols in your
library. You have access to a Search tool to help you find templates and symbols in your folders.
To use the Library Search tool:
1. In the Library view, in the left side, select the library you wish to search in.

2. In the Search field, type the name or partial name of the symbol or template you are looking for.

3. Click on the left

and right

arrows to see the previous and next results. The Search engine will

look for result within the library master folder and its subfolders. It will not look in other libraries.

Library List

The Library list lets you navigate through the different libraries and subfolders. You can also open, close and
create new libraries from here.
The Library folders have these default libraries:
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•

Symbols: The only library folder containing Symbols for your project. You can organize the Symbols
library folder using subfolders, but you cannot create a second Library for your Symbols. This library is
local to your project.

•

Harmony Library: This folder contains templates and is stored on your hard drive. You can organize the
Harmony library folder using subfolders. This folder does not contain Symbols.

Templates and Symbols List

The symbols and templates contained in the selected Library list can be displayed on the right side of the Library
view as thumbnails, in a list or as details.
To access the templates and symbols list display options:

‣ In the Library view's right side, right-click and select View > List, Thumbnails or Details.
‣ In the Library View toolbar, you can click the following buttons:
Thumbnails
List
Details

Related Topics
•

Understanding the Library Concept on page 626
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Structuring the Library
As you will probably create a large number of Symbols and templates, you will soon realize that they need to be
organized. You can create different libraries and subfolders so you can easily access your assets. For example,
create a different library for each project and divide it into several categories, such as:
•

Characters

•

Props

•

Backgrounds

Although you can only have one Symbol library folder, you can organize it by creating subfolders.
•

Creating a Library below

•

Opening a Library on the facing page

•

Closing a Library on page 634

•

Creating a Folder on page 634

•

Deleting a Folder on page 634

•

Renaming a Folder on page 635

•

Refreshing the Library on page 635

•

Generating Thumbnails on page 635

Creating a Library
There are two ways to create Library folders.
•

Using Harmony's interface.

•

Directly through your operating system.

To create a library using your operating system, create a new folder with a relevant name in the location where
you want the library to be stored. This can be opened in Harmony when you require it. .
To create a library from Harmony:
1. In the Library view click on the Menu

button and select Folders > Open Library.

The Browser window opens.
2. Browse for the location where you want to store your new library.
3. Click the New Folder button.
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A new folder appears.

4. Name the new library with a relevant name and click OK.
The new library appears in the Library List section.

Opening a Library
You can open any folder on your hard drive or network as a library. Opening a library means linking the folder to
your Library view. You only need to open the library once. The library folder is available every time you open the
application until you decide to close the library and unlink it.
To open a library:
1. In the Library View menu, select Folders > Open Library.
The Browser window opens.
2. Browse to the location of the library folder.
3. Select the folder and click OK.
The new library appears in the Library Folders section.
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Closing a Library

Closing a Library
You may not always require all of the library folders in the Library List. If this is the case, you can close the ones
you do not need. Closing a folder does not delete it, but unlinks it from the Library view. If you want to reopen it,
locate it on your hard drive or network and open it in the Library view.
To close a library:
1. On the right side of the Library view, select the library folder to close.
2. In the Library View menu, select Folders > Close Library.
The library closes.

Creating a Folder
Symbol and template libraries need to be organized. You can create different subfolders on your hard drive or in
the Library view, so you can easily access your assets. By default, any new library you link to your Library view is
locked to prevent accidental deletion or modification of templates and Symbols. You must obtain the right to
modify it before being able to add a new folder to it.
To create a folder:
1. On the left side of the Library view, select the library folder to which you want to add a subfolder.
2. In the Library View menu, select Edit > Right to Modify.
3. In the Library View menu, select Folders > New Folder.
The new folder appears in the Library. Click on the library containing the new folder and click the plus [+]
sign to expand it.

Deleting a Folder
You can delete a folder from the library if its contents are no longer needed.

Warning: All templates and Symbols in the folder will be deleted from your hard drive. Once
deleted, the data cannot be retrieved.

To delete a folder:
1. In the Library view's left side, select the folder to delete.
2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and select
Right to Modify.
3. In the Library View menu, select Folders > Delete Folder or press [Delete].
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Renaming a Folder
Once you add a folder, you can rename it. This also renames the folder on your hard drive.
To rename a folder:
1. In the Library view's left side, select the folder to rename.
2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and select
Right to Modify.
3. In the Library View menu, select Folders > Rename Folder.
4. Rename the selected folder.

5. Press [Enter/Return] to validate the operation.

Refreshing the Library
If you update the content of your libraries through your operating system, you will need to refresh your library
folders in the Library view.
To refresh a library:
1. In the Library view's left side, select the folder to refresh.
2. In the Library View menu, select Folders > Refresh or press [F5].
The library displays the new content.

Generating Thumbnails
When you display thumbnails in the Library view, the system generates a series of small images (thumbnails) for
you. You can generate template thumbnails yourself, if they do not display or if the process has been stopped.
To generate thumbnails:
1. In the Library view's right side, select the template you want to generate thumbnails for.
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Generating Thumbnails

2. In the Library View menu, select View > Generate Thumbnails.
The progress bar appears.
You can also delete thumbnails if you want to send a template to another user or studio and keep your packages
small.
To delete thumbnails:
1. In the Library View menu, select Edit > Delete Thumbnails.
All the thumbnails contained in the library are removed.

Related Topics
•

Understanding the Library Concept on page 626
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Symbols

A symbol combines animation, artwork or layers into a single object that you can control in one layer. You can
also create symbols out of each body part in your cut-out puppets.

You do not need to create Symbols in order to create drawings or characters in Toon Boom Harmony.

Related Topics
•

Creating a Symbol below

•

Deleting a Symbol on page 641

•

Editing a Symbol on page 642

•

Duplicating a Symbol on page 644

•

Sharing a Symbol on page 644

Creating a Symbol
You can create symbols in several ways:
•

Creating a Symbol from a Drawing Selection below

•

Creating a Symbol from the Timeline View on page 639

•

Creating a Symbol from the Network View on page 639

•

Creating an Empty Symbol on page 640

Creating a Symbol from a Drawing Selection
To create a symbol from a drawing selection:
1. In the Tools toolbar, select the Select

or Cutter
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2. In the Camera view, select the drawing objects which you want to create a symbol out of.

3. In the top menu, select Edit > Create Symbol or press [F8]. You can also click on the Create Symbol
button in the Edit toolbar.
The Create Symbol from Drawing Selection dialog box opens

4. In the Symbol Name field, type the name of the symbol.
‣

You can also select an existing layer from the Symbol Name drop-down menu. It will add your symbol
on the layer's current cell. If there is already an exposure on that cell a warning message will appear
stating, "Layer Head already has an exposure on current frame. Can't perform operation."

‣

If you want to rename a symbol,right-click on the symbol and select Rename.

5. You can choose to leave the current selected artwork in the drawing or not:
‣

To remove currently selected artwork from the drawing and leave it in the new symbol, enable (place a
checkmark in the checkbox) the Cut Artwork From Source Drawing option.

‣

To keep currently selected artwork in both the drawing and in the new symbol, disable (remove the
checkmark from the checkbox) the Cut Artwork From Source Drawing option.

6. Click OK.
The new symbol appears in the Library view's symbol folder and in the Timeline view as a new layer.
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Creating a Symbol from the Timeline View
To create a symbol from the Timeline view:
1. In the Timeline view, select the layer or the cells from which your want to create a symbol.
2. In the top menu, select Edit > Create Symbol or press [F8]. You can also click on the Create Symbol
button in the Edit toolbar.
‣

Another way to create a symbol is to select the layer or cells from the Timeline view and to drag them
on the Symbol folder in the Library view.

The Create Symbol dialog box opens

3. In the Enter Symbol's Name field, type the new symbol's name.
‣

To rename a symbol once it is created, right-click on the symbol and select Rename.

4. Click OK.
The new symbol appears in the Library view's symbol folder.

The current selection is not replaced by the new symbol. The new symbol only appears in the library.
You must drag it into your scene to use it.

Creating a Symbol from the Network View
In Harmony, you can create symbols from the Network view.
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To create a symbol from the Network view:
1. In the Network view, select the modules from which you want to create a symbol.
2. In the top menu, select Edit > Create Symbol or press [F8]. You can also click on the Create Symbol
button in the Edit toolbar.
‣

Another way to create a symbol is to select the modules from the Network view and copy and paste
them inside the Symbol folder in the Library view or press [Ctrl] + [C] and [Ctrl] + [V] (Windows/Linux)
or [⌘ ] + [C] and [⌘ ] + [V] (Mac OS X).

The Create Symbol dialog box opens

3. In the Enter Symbol's Name field, type the new symbol's name.
‣

To rename a symbol once it is created,right-click on the symbol and select Rename.

4. Click OK.
The new symbol appears in the Library view's Symbol folder.

The current selection is not replaced by the new symbol. The new symbol only appears in the library.
You must drag it into your scene to use it.

Creating an Empty Symbol
To create an empty symbol:
1. In the Library view, select the Symbol folder.
2. In the Library view's right side,right-click and select New Symbol. You can also select Insert > Create
Empty Symbol in Library from the top menu.
The new empty symbol appears in the Library view.
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‣

The symbol is ready for you to edit (add content to). To go back to the root timeline, click on the Top
button in the Camera view.

‣

To rename a symbol once it is created,right-click on the symbol and select Rename.

Related Topics
•

Importing Symbols and Templates on page 651

Deleting a Symbol
Deleting a symbol is easy.

WARNING: THE SYMBOL WILL BE DELETED FROM YOUR HARD DRIVE. USE UNDO TO RETRIEVE
THE DATA. THE DATA CANNOT BE RETRIEVED ONCE YOU CLOSE THE APPLICATION.

To delete a symbol:
1. In the Library view, select the symbols to be deleted.
2. Right-click on the selection and select Delete or press [Delete].
‣

If the symbol is currently in use in the scene, a warning message will pop up and the symbol will not be
deleted.
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Related Topics
•

Creating a Symbol on page 637

Editing a Symbol
When you import a symbol from the library to the Timeline view it is linked to the original symbol in the library. If
you import a symbol into your scene several times in the Timeline view, they will all be linked to the original
symbol. If you modify one, they will all be modified.
If you want to edit a symbol without modifying the other instances, you must duplicate the symbol first, See
Duplicating a Symbol on page 644.
You can either edit a symbol from the Timeline view or from the Library view.
When you edit a symbol, the drawings contained in it are not placed at the centre of the stage, but are located in
the position where they were created. The pivot is translated at the centre of the symbol.
To edit a symbol from the Timeline view:
1. In the Timeline view, double-click on the symbol's cell to edit the symbol. You can also double-click on the
symbol in the Camera View or press [Ctrl] + [E] (Windows/Linux) or [⌘ ] + [E] (Mac OS X)). You can also
click on the Edit Selected Symbol
button, available in the Camera View toolbar's extra buttons.

You are now inside the symbol and you are able to edit it.

2. Click on the Top

button in the Camera view's top left corner to return to the project's timeline or

press [Ctrl] + [Shift] + [E] (Windows/Linux) or [⌘ ] + [Shift] + [E] (Mac OS X). In the Timeline view's right
side, right-click and select Symbols >Leave Current Symbol.
To edit a symbol from the Library view:
1. In the Library view, select the symbol to edit.
2. Right-click and select Edit > Edit Symbol. You can also double-click on the symbol.
You are now inside the symbol and you are able to edit it.
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3. Click on the Top

button in the Camera view's top left corner to go back to the project's timeline or

press [Ctrl] + [Shift] + [E] (Windows/Linux) or [⌘ ] + [Shift] + [E] (Mac OS X).

Related Topics
•

Creating a Symbol on page 637

Symbol Hierarchy
When you enter a symbol to edit it, you are entering another scene where you have an independent timeline for
your symbol. You can nest many symbols one inside the other. To help you follow the hierarchy of your nested
symbol, take note of the Editing stack at the top of the Camera view which displays the path to your symbol's
location. You can click on the symbols' name to move up the chain.

Related Topics
•

Editing a Symbol on the previous page
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Duplicating a Symbol
You must duplicate a symbol if you want to modify a copy of it without altering the original symbol and the other
copies.
To duplicate a symbol:
1. In the Timeline view, go to the frame where you want to duplicate the symbol.
2. Select the symbol's cell.

3. In the top menu, select Edit > Duplicate Selected Symbol.
In the Library view, the symbol is duplicated and in the Timeline view, the current cell is replaced with the
new symbol. You can now modify the symbol's content.

If other symbols are nested inside the new symbol, those ones are not duplicated. If you modify
them, the original and other instances will also be modified.

Related Topics
•

Creating a Symbol on page 637

Sharing a Symbol
You can share a symbol and use its contents (the drawing or drawings that it contains) in another scene. To do
this, you must first convert your symbol into a template. This conversion breaks the drawing's link with both the
original scene and symbol. It then becomes a separate entity that you can import into your other projects.
To convert a symbol into a template:
1. From the Library view, select the symbol to convert into a template and drag it to the Camera or Timeline
view.

If you drop your symbol into the Camera view instead of the Timeline view, it will not be placed in
the centre of your camera frame, but rather wherever your cursor drops it within the camera frame.

644

Toon Boom Harmony 10.3 Stage User Guide

2. In the Timeline view, select the symbol's cells or layer and drag it to the Stage Library folder or to any
other library folder. Make sure you have the right to modify the library folder.

3. In the Rename dialog box, rename the new template.

4. Click on the OK button.

Related Topics
•

Creating a Symbol on page 637
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Templates

If you want to reuse artwork and animation from your project into other scenes, you need to create a template
out of it. A template can be seen as a portable scene or package that you can drag inside your project.

Related Topics
•

Creating a Template below

•

Deleting a Template on page 650

•

Editing a Template on page 650

Creating a Template
You can create a template from both the Timeline and the Network views:
•

Master Template below

•

Creating a Template from the Network View

•

Action Templates

•

Creating a Template from the Timeline View on page 649

Master Template
You can create a master template out of a cut-out puppet you created so that you can reuse it throughout a
single project or a full production. A cut-out character's master template stores the entire rig, structure,
drawings and keyframes of the different poses of your puppet into a single asset.
Master templates are created from the Network view. Refer to the next topic to learn how to create a template
from the Network view.

Creating a Template from the Network View
The Timeline and the Network views have different ways to display the scene; each view displays different
information.
A main character's template, also known as a master template, is created from the Network view. This template
contains all the connections, effects, composites, modules, pegs, advanced groupings, function columns, scene
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lengths, drawings, timings, etc. The template is saved in the Library view and must be imported back into the
scene for use, either into the Network view or into the left side of the Timeline view.

If you are creating a template from a character rig master template, you should collapse everything
inside a master peg and put a keyframe on the first frame before creating the template.

To create a template from the Network view:
1. In the Library view, select the folder in which you want to store the template.
2. If the library folder is locked, right-click and select Right to Modify.
3. In the Network view, select the modules you want to create a template with and group them. It is very
important to group your cut-out character rig, previous to storing it in the Library.
4. Select Edit > Group > Group Selected Layers or press [Ctrl] + [G] (Windows/Linux) or [⌘ ] + [G] (Mac OS
X).

5. In the Network view, click on the group module's yellow button to rename it.
The Layer Properties dialog box opens.
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6. In the Network view, select your group module and copy and paste it inside the template folder in the
Library view or press [Ctrl] + [C] and [Ctrl] + [V] (Windows/Linux) or [⌘ ] + [C] and [⌘ ] + [V] (Mac OS X).

7. In the Rename dialog box, rename the new template.

‣

To rename a template, right-click on it and select Rename.

8. Click OK.

Action Templates
An action template, also known as animation template, is created from the Timeline view. This template mainly
contains keyframes and drawing exposures. When it is extracted from the Timeline view, it loses the extra
connections, effects and groupings from the Network View.
Action templates are designed to allow you to reuse animations, key poses and part of an animation. For
example, you can reuse head positions or a leg animation from a walk-cycle and place them inside other
animations. An animation template, also known as an action template, is created from the Timeline view. This
template mainly contains keyframes and drawing exposures.
An action template is used with a master template. It cannot be used on its own since it does not contain all of
the information required to rebuild the puppet skeleton and advanced connections. The standard process is to
first import the master template to the Network view or Timeline’s left window and then slide the action
template into the Timeline’s right window. This method allows you to first build the skeleton and then give it the
right pose.
The combination of master and action templates will function as long as the layer order and connections are the
same.
When you create an action template, be sure to name it so that you can easily identify it as an animation.
Refer to the next topic to learn how to create a template from the Timeline view.
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Creating a Template from the Timeline View
You can create a template out of a layer or cells. You can store anything available in the Timeline view as a
template.

When creating a template from the Timeline view, it will lose the extra connections, effects and
groupings from the Network view.

Creating a template selecting a layer will incorporate the layer and all the drawings that were created
in it, even if they're not exposed in the Timeline view. Selecting cells will only save those specific
drawings in the template.

To create a template from the Timeline view:
1. In the Timeline view, select some cells or layers.
2. In the Library view, select the folder in which you want to store the template.
3. If the library folder is locked,right-click and select Right to Modify.
4. Drag the selection to the Stage Library folder or to any other library folder.

5. In the Rename dialog box, rename the new template.

If you want to rename a template once it is created,right-click on it and select Rename.
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6. Click OK.

Related Topics
•

Importing a Network Template on page 653

•

Importing Symbols and Templates on the facing page

Deleting a Template
To delete templates from your library, use the Library view. Harmony lets you undo the action if necessary.

Do not delete them using the operating system.

To delete a template:
1. In the Library view, select the folder containing the template to delete.
‣

If the library folder is locked,right-click on the folder and select Right to Modify.

2. Right-click on the selection and select Delete or press [Delete].

Related Topics
•

Creating a Template on page 646

Editing a Template
A template is like a scene, you can open it and edit it as any regular project. If you want to do some modifications
in your templates, you can edit them using the Edit Template command.
To edit a template
1. In the Library view, select the folder containing the template to edit.
‣

If the library folder is locked,right-click on the folder and select Right to Modify.

2. Right-click on the selection and select Edit Template.
A new Harmony application opens.
3. Edit the template.
4. In the top menu, select File > Save.
5. In the top menu, select File > Quit (Windows/Linux) or Stage > Quit (Mac OS X).

Related Topics
•

Creating a Template on page 646
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Importing Symbols and Templates
There are several ways you can import templates and symbols in your scene.

Related Topics
•

Importing a Template below

•

Importing a Symbol on the next page

•

Importing a Network Template on page 653

•

Previewing a Symbol in the Network View on page 655

•

Opening a Template as a Folder on page 655

•

Using Paste Special on page 656

•

Expanding a Symbol on page 661

•

Animating Using Symbols on page 1083

Importing a Template
To import a template in the Timeline view:
1. In the Library view, select the template you want to import.
2. Drag the selected template to the Camera view or Timeline view's left side.
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3. You can also drag a template to the Timeline view's right side into existing layers if the layer structure is
the same as the existing one.

Related Topics
•

Importing Symbols and Templates on the previous page

Importing a Symbol
To import a symbol in the Timeline view:
1. In the Library view, select the symbol you want to import.
2. Drag the selected symbol to:
‣

The Timeline view's left side if you want to import it into the centre of the camera frame.

OR
‣

The Camera view if you want to place it where ever your mouse releases it.

This may be useful if you have saved a character's body parts as separate symbols. If you dropped
them into the timeline then they would all appear in the centre, haphazardly one on top of the other.
It would be more efficient to arrange them into their correct places as you bring them into the scene.

Related Topics
•

Importing Symbols and Templates on the previous page

Importing a Template with Symbols
Sometimes a characters rig is not a straightforward matter. Rigs, which are usually saved as templates, can
contain symbols, such as a leg that was made with a patch. However, a symbol does not work in the same way as
an action template. In the Timeline view, you can add an Action template into another template of the same
structure. When a symbol is dropped into the right side of the timeline layer into a symbol of the same structure,
instead of adding itself onto the previous symbol, the new symbol becomes a copy.
To take more control of how the action template will behave when brought into the Timeline view, bring it in
using a Paste Special.
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To import a template with symbols:
1. Select the action template containing symbols from the right side of the Library view.
2. As you drag it from the Library view to the right side of the Timeline view to drop it next to a template
with the exact same rig, hold down [Alt] (Windows/Linux) or [⌘ ] (Mac OS X).
The Paste Special window appears.

3. Click on the Advanced tab.
4. Select one of the following options from the Symbols drop-down menu:

‣

Copy symbols if they do not exist: This is the default setting for this operation and will prevent
symbols in an action template from being copied.

‣

Duplicate symbols: Select this option if you wish to make copies of the symbols in your template.

‣

Overwrite symbols: If for some reason, a modification was made to a symbol in the action template
that does not exist in the basic rig template for a character, select this option to overwrite the
previous symbol.

Related Topics
•

Using Paste Special on page 656

Importing a Network Template
To import a network template:
1. In the Library view, select the template or symbol you want to import.
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2. Drag the selected template to the Network, Camera or Timeline view's left side.

3. If necessary, in the Network view, connect your template into the Composite module. Do this by clicking
it's out-port and dragging the connection to the Composite module until an in-port appears.

If the template you are importing was created in the Network view, make sure to drop it in the
Network view or in the Timeline left side, if you do not do this some network connections could be
broken. If you are importing a template containing the exact same connections as a template you
imported previously, you can drop it in the Timeline view's right side over the existing layer. This will
combine both templates and keep the same existing layers.

Related Topics
•

Importing Symbols and Templates on page 651
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Previewing a Symbol in the Network View
In Harmony, when you import a symbol in your scene, you can navigate through it in the Network view.
To navigate in your Symbol:
1. In the Network view, select the symbol you want to open and press [Ctrl] + [E] (Windows/Linux) or [⌘ ] +
[E] (Mac OS X) to use the Edit Selected Symbol command.

2. In the Network view, inside the Symbol’s top module is the composition of your Symbol. In this example, a
group module was turned into a Symbol.

3. Click the Top

button in the Network view’s top-left corner to return to the top module or press [Ctrl]

+ [Shift] + [E] (Windows/Linux) or [⌘ ] + [Shift] + [E] (Mac OS X) to use the Leave Current Symbol
command.

Related Topics
•

Importing a Network Template on page 653

Opening a Template as a Folder
Since a template is like a scene, you can open the template's folder and select elements inside it such as
drawings.
Instead of importing the entire contents of a template you may only want to import a few drawings or a palette.
In this case, use the Open As Folder command to import the items you want.
If you want to import a palette, drag the palette file into the Palette List section of the Colour view.
To open a template as a folder:
1. In the Library view, select the folder containing the template to open.
‣

If the library folder is locked,right-click on the folder and select Right to Modify.

2. Right-click on the selection and select Open As Folder.
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3. In the library list section, click on the template's folder to display its content.

4. Drag the content to the Timeline or Colour view.

Related Topics
•

Creating a Template on page 646

Using Paste Special
When you import a Symbol in your scene, its full length is exposed by default. If you import your Symbol in the
Timeline view’s left side, all the frames will be exposed. However, if you import it into an existing layer, you can
use the Paste Special dialog box to adjust the import behaviour to fit your requirements.
When you import a template in the Timeline view, all layers are created as well as drawings and keyframes. You
can import only the keyframes without the drawings or import only the drawings that are not already in your
layers. You can adjust the behaviour using the Paste Special dialog box.
Once you set the parameters, Harmony will reuse them each time you import a Symbol in the Timeline view’s
right side until you set new parameters.
To open the Paste Special dialog box:
1. In the Library view, select the Symbol or template to import.
2. While dragging the selection to the Timeline view, hold down [Alt] (Windows/Linux) or [⌘ ] (Mac OS X).

Drop the selection in the Timeline view before releasing the keyboard shortcut key.

The Paste Special dialog box opens.
3. Set the parameters and click OK.
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Drawings
•

Only create drawing files when they do not exist: When adding exposures to a drawing layer, new
drawings will only be created if drawings of the same name do not already exist at the destination.

•

Always create drawing files: When adding exposures to a drawing layer, new drawings will always be
created. If drawing files with the same name already exist, Harmony will create a new name for the
drawing.

•

Extend Exposure: Extends the exposure of drawings to fill the range of cells to the destination frame.

•

Paste all Frames of the Symbols (full movie): When enabled, the Paste Special command exposes all the
Symbol’s frames instead of only the first.

Cycle
•

Number of Cycles: Use the up and down arrows to increase or decrease the number of cycles you want
to paste. You can also type the value directly in the field.

•

Cycle Type
‣

Normal (forward): Pastes your selection as is, starting with the first cell and ending with the last.

‣

Reverse: Pastes your selection in reverse, starting with the last cell and ending with the first.

‣

Forward -> Reverse: Pastes your selection as a yo-yo, starting with the first cell, going to the last one
and ending with the first cell.

‣

Reverse -> Forward: Pastes your selection as a reverse yo-yo, starting with the last cell, going to the
first one and ending with the last cell.
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Paste Special - Advanced Tab

Drawings
•

Do Nothing: Does not create or overwrite drawings.

•

Update Drawing Pivot: Revises the drawing pivot in the destination to use the same drawing pivot as the
first drawing in the template. If you have a range of drawings selected in the destination, the pivot points
of all selected drawings will be updated.

•

Add/Remove Exposure: Creates/deletes exposure values in the selected layer.
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You have the following choices as to how to treat drawings that will be created when adding an exposure:
•

Never create drawing files: When adding exposures to a drawing layer, drawing files will not be
created.

•

Only create drawing files when they do not exist: When adding exposures to a drawing layer, new
drawings will be created only when drawings with the same name do not already exist in the
destination.

•

Always create drawing files: When adding exposures to a drawing layer, new drawings will always be
created. If drawing files with the same name already exist, Harmony will create a new name for the
drawing.

•

Extend Exposure: Extends the exposure of drawings to fill the range of cells to the destination frame.

•

Key Drawing Mode (Substitution): Pasting an exposure value replaces the cell value in the current
frame and in all frames following in sequence with the original cell value.

•

Paste all Frames of the Symbols (full movie): When enabled, the Paste Special command exposes all
the symbol's frames instead of only the first one.

Add/Remove Keyframes
•

Motion: Copies the properties of the selected motion keyframe to the new frame.

•

Velocity: Copies the properties of the selected velocity keyframe to the new frame.

•

Rotation: Copies the properties of the selected rotation keyframe to the new frame.

•

Skew: Copies the properties of the selected skew keyframe to the new frame.

•

Scale: Copies the properties of the selected scale keyframe to the new frame.

•

Force Keyframes at Function's Beginning and End: Adds a keyframe to the beginning and end of the
pasted function, reproducing the source function.

•

Offset Keyframes: When pasting functions, this option offsets the keyframes from the function's last
value by the values in the pasted function. This will continue the progression of a function rather than
repeat the values.

Options
Palettes
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•
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•

Do nothing: Does not create, overwrite, merge or link palettes.

•

Reuse palettes. Copy palettes if they do not exist: Palettes in the destination drawings are left as
they are.

•

Copy and overwrite existing palettes: Overwrites destination palettes with the palettes from the
source drawings.

•

Copy and create new palette files: Creates new palette files, placing them at the same relative
environment and scene level as the source. If the palettes in the templates were stored at the
environment level of the source scene, the paste operation will place the palettes in the environment
level of the destination scene.

•

Copy and create new palette files in element folder: Creates new palette files in the element folders
of the destination scene, rather than in the same relative job or environment.

•

Copy palette and merge colours. Add new colours only: Adds new colours to the destination
palettes and ignores colours that are the same in the two palettes.

•

Copy palette and update existing colours only: Adds new colours to the destination palette and
updates duplicate colours in the destination with colour values from the source.

•

Link to original palettes (colour model): Links the colour palettes in the destination scene to the
palettes in the source. Use this to link drawings to the palettes in a colour model.

•

Copy scene palettes and merge colours. Add new colours only: Adds new colours to the
destination scene palettes and ignores colours that are the same in the two palettes.

•

Copy scene palettes and update existing colours: Adds new colours to the destination scene palette
and updates duplicate colours in the destination with the colour values from the source.

Duplicate All Symbol Content: Instead of linking the symbol instance to the original one, the symbol will
be duplicated. A new symbol is created in the Library.

Symbols
•

Copy symbols if they do not exist: This is the default setting for this operation and will prevent symbols
in a Action template from being copied.

•

Duplicate symbols: Creates a duplicate of the symbol instead of linking the symbol instance to the
original one. The new symbol is created in the Library.

Cycles
•

Normal (forward): This pastes your selection as it is, starting with the first cell and ending with the last
one.

•

Reverse: This pastes your selection reversed, starting with the last cell and ending with the first one.

•

Forward > Reverse: This pastes your selection as a yo-yo, starting with the first cell, going to the last
one and ending with the first cell.

•

Reverse > Forward: This pastes your selection as a reverse yo-yo, starting with the last cell, going to
the first one and ending with the last cell.

•

Number of Cycles: Use the up and down arrows to increase or decrease the number of cycles you
want to paste. You can also type the value directly in the field.

Modules
•

Create New Columns: If you enable this option a new column will be created when you copy and paste
modules from the Network view or Layer in the Timeline view. If the layers are linked to function curves,
the function curves, the drawings and the timing will be duplicated.

Elements
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•

Reuse Existing Elements: Lets you paste existing elements without creating new ones. This should be
used only when pasting within versions of the same scene.

Related Topics
•

Importing Symbols and Templates on page 651

Expanding a Symbol
You can use the Expand Symbol command to extract a symbol's content and place it on the root timeline. The
symbol will not be removed from the Timeline view. Its content will be copied and inserted into the root timeline.
The symbol's layers will be parented to it in case you created motions and transformation on the drawing layer
that is containing the symbol. Breaking the hierarchy could result in loosing any scaling and animation you may
have done.
You can also expand a symbol within a group to avoid crowding your Timeline with a series of layers. When you
will expand the symbols, the layers will be contained in a Group module which you can expand to see the
content.
To expand a symbol:
1. In the Timeline view, select the symbol to expand.

2. In the top menu, select Edit > Expand Symbol or press [Shift] + [F8].

To expand a symbol in a group:
1. In the Timeline or Network view, select the symbol module or symbol cell you want to expand.

2. In the top menu, select Edit > Expand Selected Symbol in a Group.
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3. In the Timeline view, click on the Plus sign to see the Group content. In the Network view, click on the
Expand Arrow to enter the group.
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Template Preferences
Adjusting preferences to suit your workflow allows you to work more efficiently.
To open the Preferences dialog box:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

Press [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).

In the Preferences panel's Template tab you will find the following preferences that are related to managing
templates and symbols.

Paste/Drag and Drop
•

Always Create New Drawings: By default, when you import timeline templates in the right section of the
Timeline view, to stack them, the system will analyze and create only the non-existing drawings and only
expose the already existing ones. When enabled, this option will automatically create new drawings for
every one of them that is exposed.

•

Palettes:
•

Ask User: When dropping a template into a scene, the system will ask if you want to link the palette to
the original or create a local copy in the scene.

•

Use Original Palette: The system will automatically link drawing elements to the original palette file. If
the original palette is not encountered a local copy will be created.

•

Use Copy of Palettes: The system will automatically create a local copy of the palette in the scene.

Editing a Template
•

Generate Thumbnails Automatically: When this option is enabled, the system will automatically create
thumbnails for the template when the user wants to see the thumbnails in the Template Library or when
saving a template modification.
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Toon Boom Harmony is a great tool for building your characters. You can make use of different techniques and
features to break down your puppets.

Topics Covered
•

Importing a Model on page 667

•

Relative Sizes on page 669

•

Studying the Model on page 671

•

Setting the Default Separate Position Preference on page 675

•

Naming Conventions on page 677

•

Disabling the Animation on Drawing Layers on page 680

•

Breaking Down the Character on page 682

•

Ordering the Layers on page 692

•

Rigging on page 696

•

Adding Extra Drawings on page 714

•

Setting the Pivots on page 716

•

Skeleton Optimization on page 721

•

Storing the Character in the Library on page 726

•

Appendix on page 729
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For more great options and features to create powerful and efficient puppets, refer to the chapter
about deformations. There, you will find a series of new features allowing you to bend, curve and
deform drawings, allowing for more realistic, cartoony and fluid animation. - see Deformation on
page 1111
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Importing a Model

To begin breaking down your puppet, you must first import your character into a new project. You can also draw
your character directly in the scene.
You can import your character in several different formats:
•

Library Template

•

Bitmap Image or Picture

•

External Vector Format

Model Alignment

When setting your character model in your scene, we recommend that you to centre it in the Camera view and
scale it to fit inside the safe area frame.
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If you have several views of your character, place each view in a separate cell and centre them one
on top of another. This will facilitate the break down process and will ensure that all of your puppets
are aligned and the same size.

Photo Puppets
If you are creating a cut-out puppet out of photos, break down the different parts in a bitmap editing software.
Then, import your parts and vectorize them as textured images.
A good way to set and import your bitmap parts is to organize them in a multi-layered PSD file.

Related Topics
•

If you previously created a template out of your character model, see Importing a Template on page 651
to learn how to import your character template into your building scene.

•

If your character model is a bitmap image or picture, see Importing Bitmap Images on page 574 to learn
how to import your image into your building scene.

•

If your character model is an AI, PDF or SWF file, refer to the following sections to learn how to import
your vector based image:

•

•

Importing AI and PDF Files on page 599

•

Importing from Adobe Flash on page 602

Refer to Importing PSD Files as Separate Layers on page 584 to learn how to import your bitmap images
and multi-layered PSD files.
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Relative Sizes
It is important to understand the relative size of every character and prop in order to maintain consistency and
structure throughout the project.
A production may contain many characters and props. It is not unusual for these to have been created by
different people. If there is no size control implemented, the characters and elements created by different artists
can vary greatly in size. When this occurs, the characters that are put together in a scene will be out of
proportion. The animator or person doing the scene setup will then have to scale them to the correct size.
When a character or a prop is scaled down, the outline will get increasingly thinner. By the time that the element
is scaled to its proper size, the outline may be so thin that the difference between one character's outline and
another's will not look very good.
These tips can be used to create and determine the correct relative sizes for each puppet:
•

Line Up below

•

Field Chart on the next page

•

Brush Size on the next page

Line Up

A line up consists of copying and pasting all of your character designs into the same drawing and then scaling
them so they are in proportion with each other. This line up is very important and should be handed to any
animator, layout and posing artist, or scene set up person working on the project.
For the prop design, it is recommended that you paste one of the main character's hands or even the full body
beside the prop. This enables the animator to know what size to draw or set the prop.

In your character design scene, it is a good idea to create a layer for the character line up. The line up
is usually done during the character design step. When the character builder imports the model to
the break down scene, the size relation should be correct.
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Field Chart

Harmony has a field chart included in its Camera and Drawing views. This tool is very useful when setting the
height of characters and props. You can display the field chart using the Show Grid option.
To display the field chart:

‣ In the top menu, select View > Grid > Show Grid.
‣ The keyboard shortcut is [Ctrl] + ['] (Windows/Linux) or [⌘ ] + ['] (Mac OS X).
‣ You can also click on the Show Grid

button available in the Camera view and Drawing view toolbars.

Brush Size
Harmony provides a variety of pens and brushes and also allows you to create and save your own. It is a good
idea to create and save pens with precise sizes and parameters to trace and design your models and break
downs.

Related Topics
•

Brush Styles on page 202
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Studying the Model

Now that you have imported or designed your model, the next step is to analyze it. This is done to determine
what parts will be broken apart and how they will be divided. Will the hair be separated into one, two or three
sections? Will the hand be separated from the sleeve? To determine what is best for your character, observe the
model in the Camera or Drawing view.
To help you improve the quality of your break down, here are some tips and tricks. The following examples are
from "Grossology" a production by Nelvana Limited:
•

Eyelids and Pupils below

•

Creating Mouth Shapes Directly on the Head on the next page

•

Keeping Fingers Attached to the Hand on the next page

•

Mixing Hand-Drawn Animation on page 673

•

Flipping Logos on page 674

•

Complete and Overlapping Pieces on page 674

Eyelids and Pupils
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For increased flexibility when animating the eyes, you can split them into three layers: the eyeball, the pupil and
the eyelid. The eyelid layer is used for the blink and to cut the pupil when it gets too close to the side of the
eyeball. For a more advanced break down, the two eyes are separated on their own individual three-layer sets.

Creating Mouth Shapes Directly on the Head

To animate more realistic lip syncing and facial expressions, you can create the mouth shapes on the head layer.
Just deform the jaw to match the mouth opening.

Keeping Fingers Attached to the Hand

To avoid needlessly complicating the break down, the fingers are not usually separated from the hand. The full
hand is a single layer with a bank of different hands stored inside. This technique is easy to work with and
produces a less mechanical effect.
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Mixing Hand-Drawn Animation

For more advanced cut-out animation and a more traditional animation look, some users will keep full arms and
full legs. This means that only hands and feet are separated from the limbs. The animator will create extra
drawing shapes and substitute them during the animation.

The animator may temporarily combine some parts to facilitate the work and produce a higher quality
animation. For example, combining both full legs and hips into a single drawing to create poses that would be
difficult using cut-out pieces. Both full legs could be drawn on the hip level and legs and feet exposure removed.
This technique is a mix of cut-out and hand-drawn animation.
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Flipping Logos

You can separate logos and letters that appear on a character or a prop. This allows you to flip and reuse a
character's puppet.

Complete and Overlapping Pieces

For a better result with animated parts, it is important to understand that they have to be properly overlapping
and complete. A common mistake is to trace the part just as it appears on the model.

Related Topics
•

Importing a Model on page 667
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Setting the Default Separate Position
Preference
Before you start adding layers to your puppets, you should enable the Default Separate Positions for Elements
preference if it is not already done.

If you enable the Default Separate Positions for Elements preference, when you create new layers, their X, Y and
Z axes will be independent one from the other.
By default, this preference is disabled, so when you animate your layers, the three directions are locked together
to form long and smooth trajectories controlled by a single easing parameter. However, when you do cut-out
animation, you will probably prefer to have three independent axes so that you can control them individually.

When you lock the three positions together, each time you add a keyframe, it is added on all three positions at
once.

When you separate the three positions, when you add a keyframe on one axis, it is not added on the other two.
This gives you more freedom when animating with motion keyframes and nudging parts forward and backward
over time.
To enable the Default Separate Positions preference:
1. In the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X). The
keyboard shorcut is [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).
2. In the Preferences panel, go to the General tab.
3. In the Settings section, enable the Default Separate Positions for Elements option.
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4. Click on the OK button.

Related Topics
•

Breaking Down the Character on page 682
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Naming Conventions
When working on a production, it is critical to keep work well organized. It is important to create a naming
convention chart before starting the project. It is crucial that everyone follows the criteria laid out in the naming
convention chart. When dealing with thousands of characters, pieces and puppets, it is easy to get lost.
This topic is divided as follows:
•

Adding a Prefix or Suffix to a Layer below

•

Naming the Drawings below

Adding a Prefix or Suffix to a Layer
It is highly recommended that you incorporate a naming convention for the layers. This will be very convenient in
later steps. We suggest that you add one or two letters for the character/prop name before the part name and a
"R" or a "L" for right and left to identify the corresponding character/prop:
•

Character Abby's right arm = ab_r_arm.

If you plan to work with different angles for your characters (front, side, three-quarter, back), you can add one or
two letters to identify the angle:
•

Character Abby's right arm, front view = ab_r_arm_f.

To add a prefix to a series of layers:
1. In the Network or Timeline view, select all the modules or layers to rename or press [Ctrl] + [A]
(Windows/Linux) or [⌘ ] + [A] (Mac OS X).
2. In the Scripting toolbar, click on the Add Prefix or Suffix Script

button. If the Scripting toolbar is not

visible, you can display it via the Windows > Toolbars menu.
The Add Prefix or Suffix dialog box opens.

3. Enable the Prefix or Suffix option, depending on what you want to add to the layer's name.
4. Type the prefix or suffix information to be added to the layer's name.
5. Click on the OK button.

Naming the Drawings
We recommend that you use a naming convention for your drawings. If you combine all of the angles of a
character in the same breakdown scene, it is a good idea to identify each angle used.
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Before breaking down the characters for your production, we recommend that you create a drawing name
convention that represents the angle used. For example, use "f" for front, "s" for side, "q" for three-quarter so
that the drawing name looks like: f1, f2, f3, s1, s2, etc. This will be quite useful during animation and drawing
substitution. Drawings are displayed in alphabetical and numerical order. This way, all the drawings for the front
view will be together, then all the drawings for the three quarter view, etc.
To add a prefix to one or more drawings:
1. In the Timeline view, select the drawing range to rename.

2. Right-click on the selection and select Drawings > Rename Drawing with Prefix.
The Rename Drawing with Prefix dialog box opens.

3. In the Prefix to Add field, type the characters you want to add before the current drawing name.
4. Click on the OK button.

To rename a drawing, select the drawing and use the Rename Drawing option. Do not double-click
on the frame and write a new name, as this will create a new drawing and hide your actual one. Note
that the hidden drawing has not been deleted and is still located within the element folder. Simply
retype the name and it will reappear.

Related Topics
•

Breaking Down the Character on page 682
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•

Rigging on page 696
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Disabling the Animation on Drawing Layers
By default, a drawing layer can be animated, but Harmony lets you disable this feature. Being able to switch your
drawings so they can no longer be animated without a peg has certain advantages. It means that you can have
access to the drawing substitution feature for this drawing layer, while being able to create keyframes on it's
parent peg. This feature is also available for backward compatibility when bringing in templates created in older
versions of the software, so as not to lose their offset keyframes or drawing substitution keyframes.
When selecting the element in the Camera view, the actual Drawing layer is selected, but the motion you will
create will automatically be transposed to the Peg layer. You cannot animate (add keyframes) directly onto the
drawing layer if the option is disabled. You will still be able to perform certain offset movements in the
Transformation tab of the Layer Properties, but not using any of the animation tools in the Tools toolbar.
There are two ways to disabled the Animate Using Animation Tools option:
•

Layer Properties View below

•

Preferences Panel on the facing page

Layer Properties View
When you disable the option in the Layer Properties view, the operation will be solely done on the selected layer
and not on any other ones.
To disable the Animate Using Animation Tools option in the Layer Properties view:
1. In the Timeline view, double-click on the layer that you want to set the parameter for.
The Layer Properties editor opens.
2. In the Advanced tab, disable the Animate Using Animation Tools option.

Notice how the availability of the layer functions is no longer an option in the Timeline view.
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3. Click the Close button.

Preferences Panel
If you know that you prefer this style of animation and you would like every drawing element that you create not
to be animated, you can disable the Element Module “Animate Using Animation Tools” Default Value
preference. This will disable the Animate Using Animation Tools option so that you don't have to do this through
the Layers Properties window for every layer. It is recommended to disable this preference before starting a new
character rig.
To disable the option in the Preferences panel:
1. To open the Preferences panel, go to:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

The keyboard shortcut is [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).

2. Go to the Advanced tab.
3. In the Advanced Options section, disabled the Element Module "Animate Using Animation Tools"
Default Value preference.

4. Close the Preferences panel.

Related Topics
•

Preview and Drawing Substitution on page 629

•

Swapping Images on page 1092
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Breaking Down the Character

There are many techniques you can use to break down a puppet. In this section, you will learn about one of the
most common and simplest method. For your first character break down, follow these instructions to get an
idea of the way Harmony works. Once you are used to the software and understand its basic functions and
commands, you will be able to create your own techniques to satisfy the needs of your production.

Refer to Appendix on page 729 at the end of the chapter for alternate technique tips.

Related Topics
•

Tracing the Model below

•

Articulations on page 686

Tracing the Model
The main break down technique shown here is to trace your model, completing the hidden lines and filling the
gaps. See the Appendix on page 729 to learn about more techniques.
To trace over your model:
1. In the Timeline view, add a new drawing layer for each body part to separate. You can press [Ctrl] + [R]
(Windows/Linux) or [⌘ ] + [R] (Mac OS X).

2. In the Timeline view, select the layer's first cell in which you want to draw the part.
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3. In the Tools toolbar, select the drawing tool needed.

4. In the Colour view, select the desired colour swatch.

5. In the Camera or Drawing view, draw the new part.

If you are working in the Drawing view, click on the Light Table button located in the Drawing View
toolbar to display the other layers as washed out colours. You can also press [Shift] + [L].

6. In the Tool Properties view, you can set the Pencil tool width to 0 to create an invisible hairline if you want
to close a shape without drawing an actual stroke.
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7. In the Tools toolbar, select the Paint or Paint Unpainted tool to colour your drawing.
8. In the Colour view, select the corresponding colour.
9. In the Camera or Drawing view, paint your drawing.

10. Using the Select tool, select your drawing and flatten your lines by clicking on the Flatten

button

located in the Tool Properties view.
11. If your lines are composed of several pencil strokes, you might want to combine them into one single
smooth pencil line using the Merge Pencil Lines option. Using the Select tool, select the pencil lines to be
merged and in the Tool Properties view, click on the Merge Pencil Lines
button.
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12.Repeat the entire process until the breakdown is completed.

Related Topics
•

Drawing Using the Pencil Tool on page 178
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Articulations

Once your pieces are traced, you can proceed to the completion of the articulations.
Articulations are an important aspect of any cut-out break down, without them a puppet cannot move properly
and will not look good.
This topic is divided as follows:
•

Classical Articulation below

•

Auto-patch Articulations on page 688

Classical Articulation
In this section, you will learn about classical articulation.
Classical articulation is the most popular technique for basic characters. It is quite simple and produces excellent
results, but it is not the most efficient method. In many instances, it causes limitations and extra drawing
corrections. For example, there may be a gap in the articulation if the part is bent too far. Joint design is usually
designed as a circle; the overlapping part cannot be sent behind without showing the joint.
For a more advanced articulation, see Patch Articulation on page 749 in the Appendix section.

686

Toon Boom Harmony 10.3 Stage User Guide

Classical articulation is done by erasing a part of the line from the overlay layer, leaving the colour overlapping
the bottom one.
Repeat the following instructions for all the articulations on your puppet.
To create a classical articulation:
1. In the Timeline view, select the cell containing the first part to modify, such as the upper arm.

2. In the Tools toolbar, select the Pencil, Polyline, Ellipse, or Contour Editor tool.
3. In the Colour view, select the outline colour.

4. In the Drawing or Camera view, use your drawing tool to make sure that the joint is overlapping the other
part in a half-circle shape.

‣

If you are working in the Drawing view, click on the Light Table

button located in the Drawing

View toolbar or press [Shift] + [L].
5. In the top menu, select View > Show > Show Strokes to display the invisible lines that could be present
in your drawing. You can also press [K].
6. In the Drawing or Camera view, select all the strokes in your drawing.
7. In the Tools Properties view, click on the Flatten button.
8. In the Drawing or Camera view, select all the strokes in your drawing.
9. In the top menu, select Drawing > Optimize > Remove Extra Strokes. This operation will remove any
unnecessary invisible lines in your drawing.
10. Repeat Step 1 to Step 9 for the other part of the joint.
11. In the Timeline view, select the cell of the part that will be on top of the joint.
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12. In the Tools toolbar, choose the Select, Cutter or Eraser tool.
13. In the Drawing or Camera view, remove a part of the overlapping outline in order to have only the filling
colour overlapping the joint.

14. In the Tools toolbar, select the Contour Editor tool.
15. In the Drawing or Camera view, adjust the colour fill so that the pencil outline does not overlap it. Be
careful not to leave a gap between the line and the fill.

When placing rotation pivots later on, make sure they are positioned at the centre of the articulation.

Auto-patch Articulations
Harmony has a very efficient module to automatically patch an articulation without you having to do any line
adjustment or colour overlapping. You can draw your two pieces with their complete lines overlapping each
other in semi-circles and the Auto-patch module will create a perfect articulation out of it. See Auto Patch on
page 1229.
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For the Auto-patch to work on your puppet, the only condition is to draw the outline with the Pencil tool (pencil
lines) on the Line Art layer or y our drawing and paint the colour on the Colour Art layer of your drawing. See
Creating Strokes to Paint Your Drawings on a Separated Layer on page 390.

Refer to the Auto Patch on page 1229 topic to learn how to connect your modules in the Network view and learn
more about the effect, Here is an example of an arm rigged with the Auto-patch module.
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You can use this technique in an even more efficient way by adding extra lines in the Overlay layer of your drawing
to create a fold illusion for an elbow bending.
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Related Topics
•

Patch Articulation on page 749

•

Auto Patch on page 1229
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Ordering the Layers

At this point, it is possible that your character's pieces may show up in the wrong order.
There are several ways to fix this. First, you can reorder your layers by dragging them to a higher or lower level in
the Timeline view. The top layer is displayed in front of the others and the bottom one is displayed behind.
Second, you can use the Z-axis nudging (forward and backward) if you have extra views included in the same
layers (front, three-quarter, back, etc.).
This topic is divided as follows:
•

Ordering the Timeline Layers below

•

Ordering Layers in the Network View on the facing page

•

Nudging Parts Backwards and Forwards on page 694

Ordering the Timeline Layers
In the Timeline view, the layer positioned at the top will be displayed in front and the ones below will be
displayed behind. If you have multiple views, you should order your layers based on the most common view,
which is generally the three-quarter front.
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To order the layers:
‣

In the Timeline view, drag a layer to reorder it and drop it between the other layers.

If you drop it on a layer, it will create a parent hierarchy, so make sure to drop it between layers.

Ordering Layers in the Network View

The Network view allows you to reorder your layers without breaking any hierarchy. For example, if you want the
Head layer to appear behind all of the facial features, in the Timeline view, you cannot simply move the layer
down because you will break the parenting between the head layers. In the Network view, since you have a set of
flexible connections, you can change the Composite module ordering without breaking the parenting between
the modules.
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The Composite module ordering corresponds to your Timeline ordering unless the Network's organization is
too complex for the Timeline's one. The element connected in the left-most port in the Composite module is
displayed in front in the Camera view and the one connected in the right-most port is displayed behind.
To order your layers in the Network view:
‣

In the Network view, select the module's output cable connected to the Composite module and drag
it to its new position.

Nudging Parts Backwards and Forwards
If you created a hierarchy on your arms, legs or other body parts, it is possible that you will want a part, such as
the hand, to appear in front of its parent. Yet, if you move the hand layer above the arm layer, you will break the
hierarchy. To reorder a layer rigged in a hierarchy, nudge it backwards or forwards on the z-axis.
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You will do the same for the layers that are not in the right order on the extra views. Do not place the
drawing on another layer. You want to keep all your drawings of the body parts in the same layers like
a box containing all of the hands or all of the shoes.

Harmony allows you to move your elements in three dimensions:
•

Up and Down (Y-axis)

•

Left and Right (X-axis)

•

Backwards and Forwards (Z-axis)

In the same way you create multiplane backgrounds (depth), you can do a micro nudge of the part to be
reordered and see it in front of the other elements, even if its layer is actually behind the other ones in the
Timeline view. The Forward-Backward position can also be animated over time.
Repeat the following instructions for all the views.
To nudge your parts backward and forward:
1. In the Tools toolbar, select the Transform

tool. Make sure to enable the Animate

mode.

2. In the Camera view, select the element that you want to reorder. Make sure that the focus (red outline) is
around the Camera view before selecting the element.
3. To move the element forward, press [Alt] + [Down Arrow] and to move the element backward, press [Alt]
+ [Up Arrow].

Related Topics
•

Adding the Master Peg on page 709

•

Creating a Hierarchy on page 707
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Rigging

The rigging process is where building a puppet can take several different directions.

In this section, you will learn how to create a simple rig. Afterward, you will learn how to add pegs
and create a hierarchy. You can also see more advanced tricks in the Appendix on page 729. For a
very flexible and advanced rig, see Deformation on page 1111.

Related Topics
•

About Rigging on the facing page

•

Adding Pegs on page 701

•

Rigging the Head on page 703

•

Rigging the Body on page 705

•

Creating a Hierarchy on page 707

•

Ordering the Layers on page 692

•

Adding the Master Peg on page 709

•

Creating the Keyframes on page 710

•

Masking on page 711
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About Rigging
There are few basic concepts to know about rigging and layer parenting:
•

Simple Rigging below

•

Parenting Layers on the next page

•

Rigging Using Pegs on page 700

Simple Rigging
Simple rigging is very fast and easy to do. It is built as follows:
•

All the body parts are independent

•

All the timeline's layers are attached to a master peg layer (trajectory layer)

The advantage of using this technique is that you are free to move any part around without being influenced by
any parent layer.

However, since the parts are not parented to each other, the parts will move from point A to point B along a
straight trajectory. The hand will not follow the arm's rotation. You will have to set more keyframes for the hand
to move along a curved path.
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Parenting Layers

When you want a part to follow another one, such as the forearm following the arm, you can attach the layers
one to the other. For example, you can attach the forearm layer to the arm layer without having to encapsulate
the forearm into the arm layer. They will still be parented, but you will be able to access the forearm directly
without having to enter the arm layer.
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The advantage of parenting layers is that the child layers will follow the parent smoothly without having to select
them or create a series of keyframes.

The disadvantage of parenting layers is that you are not able to move the parent independently of its children,
since the child layers receive all the transformation information from their parent.

Parenting layers such as the arms and legs and letting the torso and hips independent from those is often a good
solution.
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To attach one layer to another, you have to drag the desired layer onto the other one in the Timeline
view.
Harmony offers powerful techniques to create hierarchies between your layers without having to
encapsulate layers into each other. These techniques are a great improvement over the less efficient
and time consuming method of creating parenting between your layers by inserting symbols into
other symbols. Therefore, rigging with symbols inside symbols is NOT recommended.
This method is not recommended. For efficiency in your production, do not encapsulate symbols
inside symbols.

Rigging Using Pegs
When you are doing more advanced puppet rigging, you can use peg layers. Peg layers are trajectory layers that
do not contain drawings. They are motion paths that you can use to control your entire puppet or advanced
hierarchies.
Parenting a drawing layer to a peg layer allows you to divide your motions on two separate levels. This way, you
do not affect any child layers that could be attached to that part.
Then, you can perform your translation and rotation on the peg layer so that all the parts attached to that peg
layer follow the same trajectory.
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Related Topics
•

Rigging the Head on page 703

•

Rigging the Body on page 705

•

Creating a Hierarchy on page 707

Adding Pegs
To animate your pieces, you will need to parent them to pegs. Pegs are path layers allowing you to add
keyframes to modify the positions of your pieces over time. It is not mandatory, but it is helpful to have your
drawings and keyframes separated—see Disabling the Animation on Drawing Layers on page 680 for more
information on the the subject.
To parent your drawing layers to pegs:
1. In the Timeline view, select all your layers.

701

Chapter 11: Character Building Rigging

2. In the Timeline Layer toolbar, click the Add Parent Peg button to add a parent peg to all selected layers.

At this point, in the Network view, the layers look tangled.
3. In the Network View toolbar, select all the modules and click the Order Network Down
Network View toolbar.
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Related Topics
•

Creating a Hierarchy on page 707

Rigging the Head
You will start by attaching the facial features to the head.
The advantage of parenting the head and the facial features to the same peg is that you can easily animate each
facial feature, and they will all follow the head motion.
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To parent the facial features to the head:
1. In the Timeline view, deselect any layer that could be selected.
2. Select the head peg layer.

3. In the Timeline View Layer toolbar, click on the Add Parent Peg

button to add a new peg layer to

your timeline. You can rename the peg to keep your work organized.

A new peg is added and parented to the head peg layer.
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4. Select all the remaining head and facial features layer and drag them ONTO the peg layer or BETWEEN
the head peg layer and the new head peg to parent them.

Related Topics
•

Rigging the Body below

Rigging the Body
Now that the character's head is ready, you can move on to the body. You can do a simple rigging where all of
the body parts are independent one from the other, or create some parenting between some of the layers. Refer
to Creating a Hierarchy on page 707 to learn how to parent your layers.
Simple rigging consists of leaving the layers in the Timeline view without doing any kind of parenting. Later on,
you will attach those layers to a master peg and organize them in the correct order.
Your drawings must be connected to a Composite module. A Composite module takes all the drawing layers
connected in it and flattens them into a single image which allows you to organize your network and manipulate
your puppet easily. It also allows you to apply effects on your complete character. The Composite module is
useful when you have to deal with a lot of modules in the Network view.
If you import your layers into the Timeline view, they will automatically be connected to the Composite module
available in the Network view.
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Connecting Modules to a Composite Module
In Harmony, if your modules are not connected to your Composite module in the Network view, you can connect
them all at once following the Timeline order.
To connect your modules to a Composite module:
1. If you do not have a Composite module, open a Module Library view. In the top menu, select Window >
Module Library.
2. In the Module Library view, go to the Filters tab and select a Composite module.
3. Drag the Composite module to the Network view or press [Ctrl] + [H] (All Platforms).

4. In the Timeline view, select all the modules you can to connect to your Composite module.
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5. Right-click on your selection and select Connect To Composite > select the desired Composite
module.
You modules are now connected to your Composite module in the same order as the Timeline view.

Related Topics
•

Rigging the Head on page 703

•

Creating a Hierarchy below

Creating a Hierarchy
Harmony lets you extend your rigging techniques beyond normal boundaries and sets new standards. You can
create hierarchies without encapsulating pieces inside each other by creating a linked structure between your
layers.
You should create a hierarchy on your arms and legs and keep the arms and legs separated from the body. This
gives you more animation freedom. This way, when you need to scale or skew the torso, it will not affect the
entire body.
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To create a hierarchy in the Timeline view:

‣ Drag the child piece (hand) and drop it ON the parent piece (forearm). Then, you can drag the parent
(forearm) piece onto another parent piece (arm).

‣ See Nudging Parts Backwards and Forwards to reorder parts that should be in front of their parents.
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To create a hierarchy in the Network view:
‣

From the parent part, drag a new cable connection out of the module's output port (bottom) and
connect it to the child part module's input port (top).

Here is an example of a rig with a simple hierarchy:

Related Topics
•

Masking on page 711

•

Adding the Master Peg below

Adding the Master Peg

When you animate your character, you will probably need to resize and reposition it to fit your scene. When you
need to scale down or move your character, it is a good idea to hook (attach) the whole puppet to a trajectory.
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Attaching your puppet to a peg will allow you to scale it and reposition it without having to do this to your
different parts and pieces. Only one layer will contain the position information, this makes your animation easier
to modify and control.
To add a Master peg:
1. In the Timeline view, deselect any selected layers and click on the Add Peg

button located in the

Timeline Layers toolbar.
2. Name the new peg Master plus the character's name.
3. In the Timeline view, select all of the layers you want to attach to your new peg.
4. Drag your selection ON the peg layer to parent all your character's pieces to the peg.

Related Topics
•

Pegs on page 943

Creating the Keyframes
Once all of your drawings are ordered and your master peg is added, you need to insert keyframes on each cell
to create all of the function curves and block your pose in place.
To create the keyframes:
1. In the Timeline view, collapse the master peg by clicking on the Expand

2. In the Timeline view, select the first cell.
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3. In the top menu, select Insert > Keyframe or press [F6]. You can also click on the Add Keyframe
button located in the Timeline View toolbar.

Note: If you use [F6] when working the Flash flavour keyboard shortcuts, this not only creates a
keyframe but also duplicates a drawing.

Related Topics
•

Adding and Deleting Keyframes on page 952

Masking

When rigging a character, there will be cases where you will want to be able to move some pieces to give the
illusion of a rotation or move the pupil within the white of the eye without having the extra bit of the drawing
sticking out of the character or eyeball. To do so, you can use masks to cut anything you do not want to be
visible.
To mask an object:
1. In the Timeline view, make sure the keyframe is added on the object that will be masking the piece to cut.
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2. From the Module Library view, select a Cutter module and drag it to the Network view.
3. Connect the object you want to cut in the Cutter module's right port and connect the Cutter to the
Composite module.

4. Pull out a second cable from the masking object and connect it in the Cutter module's left port.

5. Your masking effect is most likely inverted and what you want to cut is probably showing. Click on the
Mask module's yellow button to open the Layer Properties window. In the Layer Properties window,
enable the Inverted option.
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6. Using the Transform tool, you can now move the cut object within the masking zone.

Related Topics
•

Adding the Master Peg on page 709
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Adding Extra Drawings

Your break down is now complete. You can move on to adding extra drawings your character needs, such as
principal hand positions and mouth shapes. If ever you forget to add extra drawings in your main character's
template, you will easily be able to add them later.

Add your extra drawings in the layer corresponding to the part which you are drawing. You should
see the layers as containers for the different pieces. Each part of the body has its own container
where you can add more drawings of the same part.

To add extra drawings:
1. In the Timeline view, expand the master peg by clicking on the Expand
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2. In the Timeline view, select the cell where you want to add your new drawing. If you want to duplicate the
current drawing and work from it, you can select Drawing > Duplicate Drawings or press [Alt] + [Shift] +
[D].
This creates a new drawing in the selected cell, automatically extended to the next one. This new drawing
is a duplicate of the one that was selected so it contains a duplicate of the art. You can modify it to create
your new drawing or delete its contents in the Camera or Drawing view and start from scratch.
3. In the Tools toolbar, select the drawing tool you need to draw your extra part.
4. In the Camera or Drawing view, draw your new drawing.

5. Using the Select

tool, select your drawing and flatten your lines by clicking on the Flatten

located in the Tool Properties view.
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Setting the Pivots

The last step before storing the character in the library is to set the pivots for the different parts.
Harmony has three types of pivots:
•

Peg Pivot
The Peg pivot is a permanent pivot that is applied to the entire drawing layer. If you modify its position, it
will be changed for the whole layer and will therefore modify the animation, scale and rotation
interpolation. the Peg pivot is set using either the Rotate, Translate or Scale tool. The Transform tool will
only move that pivot temporarily for positioning purpose, but the animation interpolation will be done
from the original Peg pivot's position.

•

Drawing Pivot
The Drawing pivot is contained within each drawing. In one layer, each drawing can have its own pivot. If
you have many different views of a character within one layer, the pivot can be different and the animation
will adjust to the pivot. The Drawing pivot can also be referred to as embedded pivot. If you are not
mixing different views within the same layers or are using pegs to animate your layers, it is recommended
to use the Peg pivot. See Drawing Pivot Tool on page 286.

•

Symbol Pivot
The Symbol pivot is similar to the Drawing pivot. Each symbol cell can have its own pivot and act the same
as the Drawing pivot. The Symbol pivot can also be referred to as embedded pivot. Inside a symbol, each
drawing can have its own pivot. If you are not mixing different views within the same layers or are using
pegs to animate your layers, it is recommended to use the Peg pivot. See Setting Different Pivots for a
Puppet Using Symbols on page 755.
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For a simple character rig, it is recommended to set the Peg pivot (even on drawing layers) using the Rotate tool.

You can set a different pivot for each one of your drawings. For example, if you have a series of
drawings from different views, they are not likely to rotate from the same location. In that case, you
can set a different pivot for these drawings by using the Drawing Pivot tool.

This topics is divided as follows:
•

Setting the Pivots Using the Rotate Tool below

•

Setting the Master Peg Pivot on page 719

Setting the Pivots Using the Rotate Tool
If you want your puppet's pieces to rotate correctly, you need to set the pivot points right in the middle of an
articulation such as an elbow or a knee.
Do the following steps for each layer in the Timeline view.
To set the pivots:
1. In the top menu, select Windows > Toolbars > Advanced Animation to display the Advanced Animation
toolbar.
2. In the Advanced Animation toolbar, select the Rotate

tool.

3. In the Camera or Timeline view, select the layer you want to set the pivot for. In the Camera view, you can
also hold down [Ctrl] (Windows/Linux) or [⌘ ] (Mac OS X) and click on the piece you want to set the pivot
for.
4. In the Camera view, drag the blue pivot where you want to the pivot to be. You can also drag the pivot
marker to the desired location.
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5. Repeat the previous steps for all the pieces, including the eyes, mouth and nose.
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Setting the Master Peg Pivot

By default, your master peg pivot is placed at the centre of the Camera view, which generally equates to your
character's hips. A good way to set your peg's pivot is to move it between your character's feet.
To permanently move a peg pivot, use the Rotate

or Scale

tool. While animating, you are easily able to

temporarily move this pivot to another location with the Transform tool.
The Transform tool is designed to move the pivot temporarily during the animation process. It also permits you
to select multiple pegs and apply a common temporary pivot.
To set the peg pivot:
1. In the Advanced Animation toolbar, select the Rotate
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2. In the Timeline view, select the master peg layer.

3. In the Camera view, click on the peg pivot and move it to its new location.

If you added other pegs to your rig, you must set their pivot following the same method.
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Skeleton Optimization
In the Network view, you can add extra modules, such as a Display, and group all of your modules to keep your
work organized.
There are four steps to make sure your puppet can be reused efficiently:
•

Deleting the Write Module below

•

Renaming the Display Module below

•

Changing the Composite Type on page 723

•

Grouping your Modules on page 723

Deleting the Write Module
The first step in optimizing your network is to delete the Write module. The Write module is used to render
certain portions of your Network view.
When you render your scene, if you have three or four characters in your scene and they each have a Write
module in their skeleton a render is created for each one of them and they overwrite each other.
To delete your Write module:
1. In the Network view, select your Write module.

2. In the top menu, select Edit > Delete or press [Delete].

Renaming the Display Module

A Display module allows you to see a section of your Network in your Camera view. By renaming your Display
module with your character's name, you will be able to quickly identify its Display in the Global Display toolbar
and isolate your character to see it better while working on it.
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To rename your Display module:
1. In the Network view, click on the Display module's Properties button to open the editor.

2. In the Layer Properties window, rename the Display module with your character's name.

3. Click on the Close button.

If you do not have a Display module in your network, you can add one by selecting one from the
Module Library view and dragging it into your Network view.

To add a Display module:
1. If you do not have a Module Library view opened, in the top menu, select Window > Module Library.
2. In the Module Library view, go to the IO tab and select the Display module.
3. Drag the module to your Network view.

4. Connect the Composite module's output port into the Display module's input port.
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Changing the Composite Type
When you create a character with Harmony, you have to connect all your modules in the Composite module. The
Composite module takes all the different images coming out of your drawing modules and flattens them into
one single image.
This is useful when it is time to apply an effect to your entire character or group your layers for a more organized
network.
The regular Composite module will flatten all the pieces into one image preventing interaction with props or
characters connected to a different Composite module. That is why you have to change the Composite module's
type to a special one that will still output one single image but will not flatten the drawings together. This will
allow you to nudge your drawings on the Z-axis so that parts of you characters can pass in front and behind
other characters and objects. This Composite type is called Pass Through.
To change your Composite module to a Pass Through type:
1. In the Network view, click on your Composite module's Properties button.

The Composite Layer Properties dialog box opens.
2. Select the Pass Through type.

3. Click on the Close button.

Grouping your Modules
Once your rigging is completed, you must group the puppet's skeleton. This helps you to organize large and
complex networks. This way, once you have imported two or three characters into the scene, three Group
modules will be displayed instead of all of the rigging connections of three puppets.
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To group your modules:
1. In the Network view, select all your modules.
2. In the top menu, select Edit > Group > Group or press [Ctrl] + [G] (Windows/Linux) or [⌘ ] + [G] (Mac OS
X).
Your modules are now grouped.
3. Click on the Group module's right arrow to enter the group.

4. If you do not have a Multi-Port Out module inside your group, in the Module Library view, go to the
Group tab and select a Multi-Port Out module.

5. Drag the Multi-Port-Out module to the Network view.
6. Connect the Composite module's output port into the Multi-Port Out module. This creates an output
port on your Group module.
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7. In the bottom left corner of the Network view, click on the Top word to go back to your network's root.
You should now see an output port on your Group module.

8. Click on the Group's Properties button to open the Layer Properties dialog box.

9. In the Layer Properties window, rename your Group module with your character's name.
10. Click on the Close button.

Related Topics
•

Network Navigation and Basic Rules on page 801
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Storing the Character in the Library
To be able to reuse your character in different scenes, you have to store a template in the Library view. You can
create different kinds of templates. You can create templates with all layers are included, a template for a body
key pose or even some containing only the head.
Harmony has a Timeline and a Network view. The Timeline view represents the layers in a linear and simple way.
The Network view allows you to create all sorts of complex connections that the Timeline view cannot display.
The result of this is that:
•

Any template created from the Timeline view has to be imported in the Timeline view.

•

Any template created from the Network view has to be imported in the Network view.

It is highly recommended that you create a cut-out puppet's main template from the Network view
since it contains advanced connections, Display modules and Composite modules.

This topic is divided as follows:
•

Network Template below

•

Key Pose Template on the facing page

Network Template
To create a template from the Network view:
1. In the Library view,right-click on the desired library folder and select Right To Modify.
2. In the Timeline view, collapse the master peg layer.

3. If your scene has a series of blank cells, they must also be included in the template if you drag the layer to
the Library view. Reduce the scene length so there are no empty cells before creating your template.
4. Add a keyframe on the collapsed character.
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5. In the Network view, select your character's group and in the top menu, select Edit > Copy. In the Library
view, select the folder where you want to store the template and in the top menu, select Edit > Paste.

The Rename dialog box opens.

6. In the Name field, name the new template.
7. Click on the OK button.

Key Pose Template
To create a key pose template:
1. In the Library view,right-click on the desired library folder and select Right To Modify.
2. In the Timeline view, collapse the master peg layer.
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3. Select the cell containing the desired view and drag it into the desired library folder.

The Rename dialog box opens.

4. In the Name field, name the new template.
5. Click on the OK button.

When you create a template from the Timeline view, for everything to work properly when you re
import it into a scene, you must first import your master template. Once the master template is
imported, you can import the key pose template's content into the right hand side of the Timeline
view.

When you create a template from a keyframe in the Timeline view's right side, it only copies the drawings and
keyframes. It does not copy all of the network advanced connections and composites. If you import your
Timeline template in the Network view or in the Timeline view's left side, your layers will be in the wrong order
and will not be connected to a composite.

Related Topics
•

Library on page 625

728

Toon Boom Harmony 10.3 Stage User Guide

Appendix

There are many options and animation techniques available when building a puppet, it is impossible to
determine only one method to break down a character. Here are some advanced tips on breaking down
puppets. As you become more familiar with the software, you will find more ways to improve the construction of
your puppet.

Related Topics
•

Break Down: Cutting the Character in Pieces on the next page

•

Break Down: Distribute to Layers on page 741

•

Break Down: Creating Ghost Drawings on page 743

•

Converting the Layers into Symbols on page 747

•

Patch Articulation on page 749

•

Setting Different Pivots for a Puppet Using Symbols on page 755

•

Setting Pivots on a Frame Range on page 757

•

Adding the New Drawings to an Existing Template in the Library
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Break Down: Cutting the Character in Pieces

If you do not want to redraw all the artwork for your character, you can use the cut away technique where, with
the Cutter tool, you select and send pieces of the model on a new layer.
The first step in breaking down your character is to do a rough cut down of the main parts such as the body,
arms, legs and head. Use the Create Drawing from Drawing Selection feature to automatically create your layers
and copy your selection in it.
This section is divided as follows:
•

Breaking Down the Main Parts below

•

Breaking Down the Secondary Parts on page 733

•

Selecting and Incorporating to an Existing Layer

•

Breaking Down the Extra View Main Parts on page 736

•

Breaking Down Secondary Parts in the Extra Views on page 737

Breaking Down the Main Parts
To break down the main body parts, you will use the Create Drawing From Drawing Selection feature. There is
no need to create any layers prior to this process, you need to have your model well centred and sized in the
Camera view.
You do not need to make clean cuts around your parts; a rough one is quite sufficient as long as it includes all of
the artwork of the part you want to break down. You will clean the extra bits and pieces later.
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You will use the Cutter

tool to roughly cut the main sections. You can also use the Select

tool to select

precise lines and colour zones.
To break down the main parts:
1. In the Timeline view, select the model's cell that corresponds to the first view to break down.

2. In the Tools toolbar, select the Cutter
‣

tool.

If you prefer to use the Select tool, choose the Select

tool from the Tools toolbar or press [Alt] +

[S].
‣

In the Tool Properties view, you can switch to the Lasso

selection mode.

3. In the Camera view, create a selection around the first part to break down. If you click on a zone, the
Cutter tool will select the zone. It will end the selection at the first point of intersection that it meets.

‣

If you hold down [Shift], you can create a new lasso selection around another zone and add it to your
previous selection.

731

Chapter 11: Character Building Appendix

4. In the top menu, select Edit > Create Drawing From Drawing Selection or press [F9].
The Create Drawing From Drawing Selection dialog box opens.

5. In the Layer Name field, type the name of the layer you want to create following the naming convention
you established previously.
6. Make sure to disable the Cut Artwork From Source option in order to keep the selected artwork on your
original drawing. You do not want to cut the artwork from your colour model.
7. Click on the OK button to complete the operation.
The new layer is created and your selection is copied in it. The drawing is created in the same frame
number as the cell it was taken from.

8. Repeat Step 1 to Step 7 for each main body part.

732

Toon Boom Harmony 10.3 Stage User Guide

Breaking Down the Secondary Parts

You should now have a layer for each main part of the character for the first view to break down. You are now
ready to break down those main pieces into smaller ones.
Breaking down the secondary parts is similar to the main part break down process except that this time you will
cut away the artwork from the layer it has been selected from.
To break down the secondary parts:
1. In the Timeline view, lock your model layer by clicking its Lock

button.

2. In the Timeline view, select the cell that corresponds to the main part you want to break down.

3. In the Tools toolbar, select the Cutter

tool.
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‣

If you prefer to use the Select tool, choose the Select

tool from the Tools toolbar or press [Alt] +

[S].
4. In the Camera view, create a selection around the part to break down.

‣

If you click on a zone, the Cutter

tool will select the zone. It will end the selection at the first point

of intersection that it meets.

5. In the top menu, select Edit > Create Drawing From Drawing Selection or press [F9].
The Create Drawing From Drawing Selection dialog box opens.

6. In the Layer Name field, enter the name of the layer you want to create, following the naming convention
you established previously.
7. Enable the Cut Artwork From Source option in order to remove the selected artwork from your original
drawing. In this case, you want to cut the artwork from your colour model.
8. Click on the OK button to complete the operation.
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The new layer is created and your selection is copied in it. The drawing is created in the same frame
number as the cell it was taken from.

9. Repeat Step 2 to Step 8 for each body part.
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If you forgot to add some artwork to a layer you previously created, you can always add it later.
In the Camera view, select the artwork to send to the existing layer. Open the Create Drawing from
Drawing Selection dialog box. The [F9]. In the dialog box, select an existing layer from the dropdown list instead of typing a new name. When you click on the OK button, the artwork will be added
to the existing drawing in the layer you selected.

Selecting and Incorporating to an Existing Layer
Your first view should now be completely broken down. If your articulations are still rough and bits and pieces
are missing you will fix those in the next step.
If your character model has more than one view, now is the time to break them down.
The process is very similar to breaking down the first view. You have two choices:
•

Breaking down the new view in a net set of layers

•

Braking down the new views in the same existing layers
If your layers are not in the correct order, you can reorder them later. Simply add the part that you are
breaking down to the layer you previously created for the same body part.

Start by breaking down the main pieces, as you did before. The secondary parts will be broken down later on.

Breaking Down the Extra View Main Parts
Repeat the following steps for each extra view you have to break down.
To break down the other views:
1. In the Timeline view, selected the model's cell corresponding to the view to break down.

2. In the Tools toolbar, select the Cutter
‣

tool.

If you prefer to use the Select tool, in the Tools toolbar select the Select
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3. In the Camera view, create a selection around the first part to break down.

4. In the top menu, select Edit > Create Drawing From Drawing Selection or press [F9].
The Create Drawing From Drawing Selection dialog box opens.

5. In the Layer Name field, select the corresponding layer from the drop-down list if you want to use the
same layers or type a new name if you want to create a new layer.
6. Make sure to disable the Cut Artwork From Source option in order to keep the selected artwork on your
original drawing. You do not want to cut the artwork from your colour model.
7. Click on the OK button to complete the operation.
The artwork is inserted into the existing layer. The drawing is created in the same frame number as the
cell it was taken from. It is not incorporated in the other view's drawings.

8. Repeat Step 1 to Step 7 for each main body part.

Breaking Down Secondary Parts in the Extra Views
To break down the secondary parts for your extra views you will follow the exact same process as you did for the
first view you broke down, but you will incorporate the new parts in the already existing layers—see Breaking
Down the Secondary Parts on page 733.
Each view can have its own set of layers in the Timeline, so that each view does not necessarily need to have the
same layer structure.
This is an example of how your timeline should look at this stage:
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Completing the Parts and Articulation

Now that all of your layers are created and your parts are basically broken down, it is time to clean up your parts
and complete the articulation.
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Cleaning the Parts
You will need to use a series of drawing tools to clean the parts:
•

Brush Tool

•

Eraser Tool

•

Select Tool

•

Cutter Tool

•

Contour Editor Tool

•

Paint Tool

•

Close Gap Tool

To clean your drawings:
1. In the Tools toolbar, select the drawing tool you need to fix your drawings.

2. In the Timeline view, select the cell containing the drawing to fix.

3. In the Camera view, delete the extra bits using the Select
Eraser

tool.
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4. Draw the missing lines using the Brush
enable the Auto-Flatten

5. Using the Paint

tool. If you use the Brush tool, it is recommended that you

option in the Tool Properties view.

tool, paint the gaps. You can close some gaps with invisible lines using the Close Gap

tool. The keyboard shortcut is [Alt] + [C].

6. Reshape your lines using the Contour Editor

tool. The keyboard shortcut is [Alt] + [Q].
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7. Using the Select tool, select your entire drawing and click on the Flatten

button in the Tool

Properties view to flatten your drawings.
8. In the top menu, select View > Show > Show Strokes to display the invisible lines that could be present
in your drawing or press [K].

9. In the top menu, select Drawing > Optimize > Remove Extra Strokes. This operation will remove any
unnecessary invisible lines in your drawing.
10. Repeat this entire process for each drawing to fix.

Related Topics
•

Drawing Using the Pencil Tool on page 178

•

Drawing with the Brush Tool on page 196

•

Erasing Parts of a Drawing on page 231

•

Drawing with Shapes on page 247

•

Cutting Drawing Parts on page 266

•

Reshaping a Drawing Using the Contour Editor Tool on page 235

•

Painting Using the Paint Tool on page 357

Break Down: Distribute to Layers
When breaking down your character, you can use the Distribute to Layers option to distribute the selected art
strokes to a new layer each.

This feature will automatically take each stroke from the drawing selection made in the Camera view
and separate them into different layers. If one of your puppet's part is composed of several strokes,
you must group them using Edit > Group > Group before using the Distribute to Layers option. This
option cannot be done in the Drawing view. It must be done from the Camera view.

To distribute to layers:
1. In the Tools toolbar, click on the Select

tool.
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2. In the Camera view, select the art strokes you want to distribute to different layers.

3. Select Drawing > Distribute to Layers. You can also click on the Distribute to Layers

button in the

Tool Properties view.
The number of drawing layers corresponding to different strokes or groups of strokes are created in the
Timeline view.

‣

The selected strokes in the original drawing layer will be removed.

‣

Each stroke or group of strokes will be distributed into each new Drawing layer.

Related Topics
•

Breaking Down the Character on page 682
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Break Down: Creating Ghost Drawings

At this point your basic break down should be almost complete. There is one optional step you can do before
moving on, adding extra drawings and expressions to your character; adding ghost drawings.
This topic is divided as follows:
•

Adding a Ghost Drawing below

Adding a Ghost Drawing
Right now, your timeline looks like this:

Some parts have no drawings in certain views. For example, the left eye has no drawing available for the Side
view. To make your puppet more efficient when you will animate, a good trick is too add invisible drawings that
you can select even when no image is necessary.
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If you need to select a part of your character to use the Drawing Substitution feature or Inverse Kinematics tool,
or to avoid having the system automatically fill in the exposure gaps when swapping images, then creating ghost
or invisible drawings can be very useful.
To create ghost drawings, copy one of the existing drawings, paste it in the empty cell and repaint it with a fully
transparent colour.
To create ghost drawings:
1. In the Colour view, add a fully transparent colour to your character's palette.

2. In the Timeline view, select the cell containing the drawing you want to copy to create your invisible
drawing.

3. In the Tools toolbar, select the Select

tool or press [Alt] + [S].

4. In the Camera or Drawing view, select the drawing to copy.

744

Toon Boom Harmony 10.3 Stage User Guide

5. In the top menu, select Edit > Copy or press [Ctrl] + [C] (Windows/Linux) or [⌘ ] + [C] (Mac OS X).
6. In the Timeline view, select the empty cell where you want to create your ghost.

7. Click on the Camera or Drawing view and in the top menu select Edit > Paste or press [Ctrl] + [V]
(Windows/Linux) or [⌘ ] + [V] (Mac OS X).
8. In the Colour view, select the transparent colour.

9. In the Tools toolbar, select the Select

tool and offset the drawing outside the body's area or press

[Alt] + [S].
10. In the Tools toolbar, select the Paint

tool or press [Alt] + [I].

11.In the Camera or Drawing view, repaint the drawing to make it invisible.

At this point, your timeline should look like this:
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At this point, you could decide to convert your layers to symbols. See Converting the Layers into
Symbols on the facing page.

Related Topics
•

Creating a Symbol on page 637
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Converting the Layers into Symbols

Converting your layers into symbols is optional. When animating, you will need to enter the symbol
to create a new drawing. IF YOU WANT TO USE MORPHING WHEN ANIMATING, KEEP YOUR
LAYERS AS DRAWINGS AND DO NOT USE SYMBOLS.

Once the breakdown is completed, you can create symbols out of each drawing. The symbol will encapsulate
each drawing of the layer. Later on, even if you only expose the first frame, such as the front head, you will still
have access to all of the head drawings you placed in the symbol. This will also allow you to add more drawings,
as your characters' master templates will evolve throughout the production of your movie or series.
To create a symbol:
1. To create a symbol:
‣

From the Timeline view, drag the layer to the Symbols library folder.

OR
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‣

In the Timeline view, select the layer to convert to symbol and in the top menu select Edit > Create
Symbol or press [F8]. You can also click on the Create Symbol
button available in the Edit
toolbar.

The Create Symbol dialog box opens.

2. In the Enter Symbol's Name field, type the new symbol's name. It is recommended that you keep your
original layer's name.
3. Click on the OK button.
4. Repeat this process for each layer in your Timeline view.

Make sure that all of your layers are stored in the symbol library.

Clearing the Main Timeline
All your layers should be stored in the library as symbols. Before building your puppet, you will need to remove
all of the current layers in your scene. All of your work is saved in the library.
If you are not sure that you put everything in your library, you can always perform a Save As on your scene and
work on a new version.
To save your scene as a new version:

‣ In the top menu, select File > Save As. You can also click on the Save As
toolbar.
To clean your Timeline:
1. In the Timeline view, select all of your layers.

2. In the Timeline's Layer toolbar, click on the Delete Layers
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3. In the Confirm Delete dialog box, click on the OK button to complete the operation.
Your timeline is now ready to receive the body part symbols for the rigging process.

Your Network view should look like this:

Patch Articulation

Harmony advanced rigging can use an articulation fixing technique called Patch Articulation. This technique is a
colour fill patch that is drawn onto a third layer and is used to cover the joint lines. It is a simple, yet powerful
method.
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With this technique, you avoid having to create a correction layer at the end of the animation to fill the gaps in
the joints. You do not need to worry about the articulations at all. Once a patch is set, the articulation is fixed for
the entire length of the animation.
To render this technique even more efficient, Harmony lets you draw the patch inside the same drawing, but on a
separate contained layer. The Line Art and Colour Art layers are not only useful in traditional ink and paint, but
also in advanced cut-out breakdown. You can draw the patch in the Colour Art layer and extract it in the
Network view. The advantage of doing it this way is that when animating and using the drawing substitution, the
patch drawing will change at the same time as the main drawing.
To create a patch articulation:
1. In the Tools toolbar, select the Transform

tool or press [Shift] + [T].

2. Only if you are planning to create you patch on an independent layer, do the following. If not, move on to
the next step.
‣

In the Timeline view, add a new drawing layer by clicking on the Add Drawing Layer
press [Ctrl] + [R] (Windows/Linux) or [⌘ ] + [R] (Mac OS X).
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‣

Rename the new layer patch or elbow.

3. In the Camera view, select the part you want to create a patch for. For example, if you are fixing the elbow
articulation, select the arm or forearm drawing to edit it.

4. In the Tools toolbar, select the Select

tool or press [Alt] + [S].

5. If you drew your lines with pencil lines, it is recommended to convert them to brush lines (fill shapes):
‣

In the Camera view, select your pencil lines.

‣

In the Tools Properties view, click on the Convert Brush Strokes to Pencil Lines
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‣

In the Camera view, select the piece's outline and fill.

‣

In the Tool Properties view, click on the Flatten

button. This will remove the exceeding colour fill

located under the contour stroke.

If you want to keep your lines as pencil and create a patch joint, you will need to use the Auto Patch
on page 1229 module.

6. In the Camera view, select the fill zone of the part's drawing.
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7. In the Camera view, right-click and select Copy.
8. To paste your selection:
‣

If you are using the recommended method, which is to paste your selection in the Colour Art, in the
Camera View or Drawing View bottom toolbar, click on the Colour Art
button.
OR

‣

If you are using an independent layer, in the Timeline view, select the cell in which you want to create
the patch.

9. In the Camera view, right-click and select Paste.
10. In the Tools toolbar, select the Cutter

tool.

11.In the Camera view, make a selection around the pasted zone to cut everything out but a small
overlapping zone to cover the articulation.

12. To extract the patch from the Colour Art layer:
‣

In the Network view, select the module containing the drawing with the patch.

‣

Copy and paste the selected module. Note that when you copy and paste from the network view, by
default it creates a clone, so any changes that are made to one affect the other.

‣

Click on the module's yellow button to open the Layer Properties window.

‣

In the Name field, add the word patch to the module's name.

‣

Close the Layer Properties window.
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13.From the Module Library's All Module tab, drag a Colour Art module and connect it below the Patch
module.

14.In the Network view, connect the main part you create the patch from and parent it to the patch module.

15. Select the patch module's connection to the Composite module and drag it in front of the piece to be
covered. In this case, the elbow patch is parented to the arm and connected in front of the forearm.
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16.Repeat the process for each articulation which requires fixing.

Setting Different Pivots for a Puppet Using Symbols
If you want your puppet's pieces to rotate correctly, you need to set the pivot points onto the articulations. You
can either set the pivots using the Rotate tool and have it set for the whole layer or you can set the pivots directly
on your symbol and have a different pivot for each symbol cell. By default, when you create your symbols, the
symbol pivot is located at the centre of your drawing. You will need to move it onto the shoulder or elbow.
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You will set the pivot on the symbol's cells, not directly on the drawings. To set your pivots, you have to be at the
top level of your character building scene and not inside the symbols.
By default, when you set your pivot onto your symbol, all the cells use the same pivot. If you need different pivots
for your different cells, refer to the following procedure.
Do the following steps for each layer in the Timeline view.
To set the pivots for the body parts:
1. In the Tools toolbar, select the Drawing Pivot

tool. You can also select Drawing > Tools > Drawing

Pivot.
2. In the Camera or Timeline view, select the symbol you want to set the pivot for.

3. In the Tool Properties view, if you only want to set one pivot for your symbol, make sure that the Set the
Pivot for Symbol on All Frames
option is enabled.

‣

Disable this option if you want to set a series of different pivots for your symbol's cells.

4. In the Camera view, click where you want the pivot to be. You can also drag the pivot marker to the
desired location.

5. If you want to set a different pivot for another drawing or symbol cell, select the drawing or cell and in the
Camera view, set the new pivot.
Make sure that the Set the Pivot for Symbol on All Frames option is DISABLED.
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Related Topics
•

Setting Pivots on a Frame Range below

Setting Pivots on a Frame Range
If you are using the drawing pivots rather than the Rotate tool pivot and if some elements need the same
drawing pivot, such as all of the three-quarter hands, you can select all of these hands cells and set the pivot all at
once. If your pivot is already correctly set on your first drawing, copy and paste that pivot onto the other
drawings in the Timeline or Xsheet view.

You must have the same drawing pivots on the extra parts from the same angle. If you substitute a drawing while
the part is rotating, the animation risks popping out of place if the pivot is uneven.
To set the pivot on a frame range:
1. In the Timeline view, select the cell where you want to set the same pivot. The cells have to be part of the
same layer.

2. In the Camera view, click where you want to the pivot to be. You can also drag the pivot marker to the
desired location.
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To copy and paste drawing pivots:
1. In the Drawing or Camera view, set the first drawing pivot of the series. For example, set it on hand-1.
2. In the Timeline view, select the cell that contains the correct pivot.

3. In the top menu, select Edit > Copy.
4. In the Timeline view, select the cell range that requires the same pivot.

5. In the top menu, select Edit > Paste Special or press [Ctrl] + [B] (Windows/Linux) or [⌘ ] + [B] (Mac OS X).
The Paste Special dialog box opens.

6. In the Paste Special dialog box, go to the Advanced tab.
7. In the Drawings section, enable the Update Drawing Pivot option.
8. Click on the OK button.
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You can also copy and paste the pivot from one drawing to another using the keyboard shortcuts
[Ctrl] + [C] and [Ctrl] + [V] (Windows/Linux) or [⌘] + [C] and [⌘] + [V] (Mac OS X) when the Drawing
Pivot tool is active and the focus is around the Camera view.

Related Topics
•

Setting the Pivots on page 716

Adding the New Drawings to an Existing Template in
the Library
To add new drawings to an existing drawing template:
1. In the Library view,right-click on the library folder containing the template to modify and select Right To
Modify.

2. In the Library view's right side,right-click on the extra drawings template to modify and select Edit
Template.
A new Harmony application opens.
3. In the Tools toolbar, select the desired drawing tool.
4. In the Colour view, select the desired colour.
5. In the template's timeline, select the blank cell where you want to draw your new piece.
6. In the Camera or Drawing view, draw the new pieces.

7. If you are using drawing pivots, in the Tools toolbar, select the Drawing Pivot

tool and in the Camera

view, set the pivot directly on the new drawing's cell. If you are using sybmols and symbol pivots, in this
case, you do not set the pivot on the symbol's cell.
8. In the top menu, select File > Save or press [Ctrl] + [S] (Windows/Linux) or [⌘ ] + [S] (Mac OS X).
9. In the top menu, select File > Quit (Windows/Linux) or Stage > Quit Toon Boom Stage (Mac OS X).
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Related Topics
•

Library on page 625
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Chapter 12: Scene Setup

Setting up your scene can be compared to building a set for a television show. This is the point when you
position each scene element such as the camera frame, the background elements and the characters.

Topics Covered
•

Importing the Scene Components on the next page

•

Setting the Camera Frame on page 763

•

Positioning the Scene Components on page 768

•

Cloning and Duplicating Layers on page 797

•

Setting Up the Network on page 800

•

Display Concepts on page 825

•

Creating a Multiplane on page 831

•

Scene Setup Preferences on page 838
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Importing the Scene Components
The first step in the scene setup task is gathering up the scene’s different components and then importing them
into your project.

Refer to the Setting Up the Network on page 800 and Display Concepts on page 825 sections to
learn more about the Network view connections and display concepts.

Backgrounds, Sounds and Movie
•

Importing Bitmap Images on page 574

•

Importing QuickTime Movies on page 606

•

Importing a Sound File on page 905

Templates and Symbols
Refer to Importing Symbols and Templates on page 651 to learn more.

Related Topics
•

Setting the Camera Frame on the facing page
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Setting the Camera Frame
The scene action occurs inside the camera frame, so it’s really important to set it up correctly.
•

Adding a Camera Layer below

•

Setting the Camera Using the Translate and Rotate Tools on the next page

•

Setting the Camera using the Camera Layer Properties on page 765

•

Resetting the Camera Position on page 767

•

Camera List on page 767

The Camera layer is static which means that if you need to animate it, you must add a peg.

Refer to the Animation Paths on page 937 chapter to learn how to animate layers using pegs.

Refer to 3D Camera Motion on page 867 to learn more about setting and moving the camera in the
3D space.

Adding a Camera Layer
To set the camera frame, you need to add a Camera layer to your scene so you can edit the default camera
frame.
To add a Camera layer in the Timeline view, do one of the following:

‣ In the Timeline view, click the Add Layer

button and select Camera.

‣ From the top menu, select Insert > Camera.
A new camera layer is added to your scene and appears in the Timeline view.

You cannot add a camera inside a symbol. If you try to do so, a warning message will pop-up and
inform you that this operation is not possible.
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If you've added more than one camera to your scene, you can switch the active camera by going to
Scene > Camera and selecting the camera you want to use.

In Toon Boom Harmony, you can also use the Network and Module Library views to add a camera layer into your
scene.
To add a Camera module in the Network view:
1. Display the Network view.
2. In the Module Library view, select a Camera module from the Favorites, Move or All Modules tab.

3. Drag the Camera module into the Network view.

Setting the Camera Using the Translate and Rotate
Tools
You can reposition your camera frame directly in the Camera view, using the Translate

and Rotate

tools.

To reposition the camera frame directly in the Camera view:
1. Select Animation > Tools > Translate or press [Alt] + [2].
2. In the Camera view, click on the camera frame to select it. You can also select the camera layer from the
Timeline view.
The selected camera frame is highlighted in purple.
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3. Drag the camera frame to a new position.

4. To tilt the camera frame, select Animation > Tools > Rotate or press [Alt] + [3].
5. In the Camera view, click on the camera frame to select it and rotate the camera frame until it reaches the
desired rotation angle.

The Translate and Rotate tools can also be found in the Advanced Animation toolbar.

Refer to the Managing the Toolbars on page 134 to learn how to display the Advanced Animation
toolbar.

Setting the Camera using the Camera Layer
Properties
One way to set up your camera frame is to type the coordinates directly in the Camera Properties dialog box.
Doing this positions the camera precisely where you want it.

Refer to 3D Camera Motion on page 867 to learn more about setting the camera in the 3D space.
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To set up the camera frame using the camera Layer Properties:

‣ In the Timeline view, double-click on the Camera layer.
The camera Layer Properties dialog box opens.

The legend below explains each of the Layer Properties:
1. Use the Enable/Disable check box to enable or disable the camera layer.
2. The Lock
‣

and Onion Skin

buttons.

Once you are satisfied of the camera frame position, you can use the Lock

button to lock the

camera layer and prevent changes on the camera frame position.
‣

The Onion Skin

button is used to enable the Onion Skin feature in the Camera and Drawing

view.
3. The Name field displays the current layer name and is used to rename it. Type in the new layer name.
4. The Position section displays the current position of the camera layer using X-axis (East, West), Y-axis
(North, South) and Z-axis (Forward, Backward) coordinates. To reposition your camera frame, type in the
new values corresponding to the desired position coordinates. You can also use the up and down arrows
to set the value of each field.
5. The Angle field displays the current rotation value. To set a new rotation position, type in a new angle
value. You can also use the up and down arrows to set the new angle value.
6. The Pivot field displays the current position of the rotation pivot of the camera layer. The camera will
perform a rotation taking the position of the pivot as its angle centre. By default, the pivot is set at the
centre of the camera frame. To reposition the pivot point, type in new X and Y coordinates values in the
appropriate field. You can also use the up and down arrows to set the position values.
In order to see the pivot's position you will need to have the Rotate tool selected.
7. Enable the Override Scene FOV check box to enable the FOV field in which you can type in a new fieldof-view value.
8. The FOV field displays the current field-of-view default value. When enabled, you can type in a new zoom
value for your camera frame. You can also use the up and down arrows to set the new zoom value.
9. Use the Set Default FOV to reset the custom zoom value to its default value.
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10. The Function button is used when animating the camera zoom value—see the Animation Paths on
page 937 chapter to learn more about creating functions.

Resetting the Camera Position
Once you set up your camera frame, you can always easily reset it to its original position. Use the Reset
command to reset the value of the selected element to the initial value of the active tool. For example, if the
Rotate
tool is active, the transformation angle will be reset to 0 and if the Transform
tool is active, then
the entire transformation values will be reset.
To reset the camera position:
1. In the Tools toolbar, select the Transform

tool or press [Shift] + [T].

2. In the Timeline or directly in the Camera view, select the camera layer.
3. Select Animation > Reset or press [Shift] + [R].
The camera automatically returns to its original position.

Camera List
You can only see one camera at the time in the Timeline view. If you add several cameras to your scene and you
want different settings on each, you can use the Camera List to display each of them. You can use this feature if
you are still working on your scene composition and you have different camera setups to choose from.
To select a camera from the Camera list:
1. In the top menu, select Scene > Camera > the desired camera.
‣

If you only add one camera to your scene, you will only see Default Camera in your list.

Related Topics
•

Positioning the Scene Components on the next page
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Positioning the Scene Components
Setting up the scene also involves positioning the different scene elements within the camera frame.
•

Animate Mode below

•

Selecting a Layer below

•

Positioning an Element Using the Transform Tool on page 777

•

Using Advanced Animation Tools to Position a Layer on page 780

•

Flipping an Element on page 784

•

Positioning an Element Using the Layer Properties on page 785

•

Auto-Apply Option on page 794

•

Resetting a Transformation on page 795

Animate Mode
When positioning elements, make sure that the Animate Mode is turned off, or it will create a keyframe within
the drawing layer.

To turn off the Animate mode:
‣

In the Tools toolbar, click the Animate Mode

button.

Related Topics
•

Selecting a Layer below

Selecting a Layer
There are different ways of selecting the layers you want to reposition in the Camera view.
The topic is divided as follows:
•

Selecting a Layer from the Camera View using the Transform Tool on the facing page

•

Bounding Box Selection Style on the facing page

•

Finding the Selected Layer in the Timeline View on the facing page

•

Finding the Selected Layer in the Network View on page 770

•

Selecting an Element from the Timeline or Xsheet View on page 770

•

Selecting all Elements Within a Group at the Same Time on page 770
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Selecting a Layer from the Camera View using the Transform Tool
You can select your elements directly in the Camera view using the Transform tool. When you select the
Transform tool, its properties and options appear in the Tool Properties view.
When using the Transform tool to select elements in the Camera view, always make sure that the Peg Selection
Mode option in the Transform Tool Properties view is disabled or else it will limit the selection to peg only.
To select from the Camera view:
1. In the Tools toolbar, select the Transform

tool or press [Shift] + [T].

2. In the Transform Tool Properties view, make sure that the Peg Selection Mode

is deselected.

3. In the Camera view, select the element to be repositioned. You can select more than one element at a
time.
The corresponding layers and columns are highlighted in the Timeline and Xsheet views.

Bounding Box Selection Style
You can change the display style of selected elements to Bounding Box. This will remove the normal selection
coloured highlight and leave only the bounding box around your selected element.

To set the bounding box selection style:
1. Select View > Show > BBox Selection Style.

Finding the Selected Layer in the Timeline View
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When you have several layers in your Timeline view, you may find it hard to locate which one is selected. Toon
Boom Harmony has an easy solution to this problem, you can use the Centre on Selection feature to display the
selected layer in the Timeline view.
To centre on the selected layer in the Timeline:
1. In the Camera view, select the desired layer.
2. Make the Timeline view the current active view.
3. From the Timeline menu, select View > Centre on Selection or press [O]. If your selected layer is in a
group, or a child of one or more elements, continue to press [O] to expand the layers in the Timeline until
your selected layer becomes visible.
4. You can also click the Centre On on Selection

button in the Timeline View toolbar.

Refer to the Managing the Toolbars on page 134 to find out more about customizing the toolbars.

Finding the Selected Layer in the Network View
Just as with the Timeline view and the many layers contained in it, when you have several modules in the Network
view, you may find it hard to locate which one is selected. You can also use the Centre on Selection feature to
focus on the selected module in the Network view.
To centre on the selected layer in the Network View:
1. In the Camera or Timeline view, select the desired layer.
2. Enable the focus in the Network view.
3. In the Network View menu, select View > Centre on Selection. You can also press the Centre On
Selection
button available in the Network View toolbar’s extra button or press [O].

Selecting an Element from the Timeline or Xsheet View
You can also select your elements from the Timeline or Xsheet view. This can be useful when there are too many
objects in the scene or when an object is hard to grab.
To select from the Timeline or Xsheet view:
‣

In the Timeline view, click the layer corresponding to the element you want to reposition.

‣

In the Xsheet view, click the column header corresponding to the element you want to reposition.

The selected element will be highlighted in the Camera view.

Selecting all Elements Within a Group at the Same Time
There is an easy way to select all the elements within a group at the same time. You can do this via the Network
or the Timeline view.
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To select all elements within a group in the Network view:
1. In the Network view, navigate to the group you would like to completely select.
2. Hold down and click-drag a marquee selection around the group module.

3. All elements within that group will now be selected.
To select all elements within a group in the Timeline view:
1. With a group collapsed or expanded, hold down [Alt] and click on the group in the Timeline view.

2. All elements contained within the specified group will be selected.

Related Topics
•

Transform Tool Properties on the next page
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Transform Tool Properties

•

Select and Transform tool below

•

Lasso and Marquee below

•

Peg Selection Mode on the facing page

•

Snap Option on the facing page

•

Hide Manipulator Controls on the facing page

•

Flip Horizontal and Flip Vertical on the facing page

•

Width and Height on page 774

•

Offset X and Y on page 774

•

Angle on page 774

Select and Transform tool
Switch between the Transform

and Select

tools directly from the Transform tool or Select tool Tool

Properties views.

Lasso and Marquee
Choose between the Lasso

and the Marquee

modes to change the selection style of the Transform

tool.
•

Click and hold [Alt] to temporarily switch from the current selected mode to the other.

To invert a selection:
•

From the top menu, select Edit > Invert Selection, or press [Ctrl] + [Shift] + [I] (Windows/Linux) or [⌘ ] +
[Shift] + [I] (Mac OS X).

You may also find the Invert Selection option from the Camera View or Drawing View menu by selecting Edit >
Invert Selection.
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Peg Selection Mode
Click the Peg Selection Mode
Transform

button to limit the selection in the Camera view to pegs. When disabled, the

tool selects the drawing layers.

This mode can be useful when you have created your character rig using peg layers for each
drawing. That way, you don't accidentally select the drawing layer, when you want to animate on the
peg.

Snap Option
When transforming or repositioning your layer using the Transform tool, you can enable different snap options
to help you.
•

Snap and Align: Snaps the selected layer to any existing line, while automatically displaying
temporary rulers that guide you and that you can also snap your object to.

•

Snap to Grid: Snaps your selection according to the currently enabled grid.

Hide Manipulator Controls
Enable the Hide Manipulator Controls

option to hide the bounding box and manipulator controls from the

Camera view when an element is selected.

Refer to following topics to learn more about the Snapping option utilities and the Grid feature:

•

Contour Editor Tool Properties on page 237 (Snap to Contour and Snap and Align)

•

More Drawing Tools on page 280 (Grid)

Flip Horizontal and Flip Vertical
Use these buttons to flip the selected element horizontally or vertically.
•

You can also select Animation > Flip > Flip Horizontal
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Width and Height
Use the Width

and Height

fields to enter specific values when you want to accurately resize the selected

layer.

1. Width: type a width value in this field to resize the width of your selection.
2. Height: type a height value in this field to resize the height of your selection.
3. Use the up and down arrows to modify the value contained in either the Width or Height value field.
4. Lock icon: Click on the lock icon to either lock or unlock the ratio between the width and height values.

Offset X and Y
Use the Offset X

and Offset Y

fields to enter specific values to reposition the selected layer accurately.

1. X: type an offset value in this field to reposition the selected layer along the X-axis.
2. Y: type an offset value in this field to reposition the selected layer along the Y-axis.
3. Use the up and down arrows to modify the value contained in either the X or Y value field.

Angle
Use the Angle

field to enter specific values to rotate the selected layer accurately. A positive value will

rotate the layer counter-clockwise and a negative value will rotate the layer clockwise.

1. Angle: type a degree value in this field to rotate the selected layer.
2. Use the up and down arrows to modify the value contained in the Angle value field.

Related Topics
•

Selecting a Layer on page 768

Locking Layers in the Timeline View
You can prevent correctly positioned layers from being selected by locking them in the Timeline view. This is
useful for making a multiple selection inside the Camera view and leaving them visible. Once a layer has been
locked, its locked state will be remembered next time you open your saved project.
You can perform five types of locking actions on your layers:
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•

Lock below

•

Unlock below

•

Lock All on the next page

•

Unlock All on the next page

•

Lock All Others on the next page

Lock
The Lock

option let you lock one or a multiple selection of layers.

To lock a layer or a selection of layers:
1. In the Timeline view, select one or more layers.

2. Do one of the following:
‣

From the top menu, select Animation > Lock > Lock.

‣

Click one of the selected layer’s Lock

‣

Press [Ctrl] + [Alt] + [L] (Windows/Linux) or [⌘ ] + [Alt] + [L] (Mac OS X).

icon.

All selected layers are locked.

Unlock
The Unlock

button lets you unlock one or a multiple selection of locked layers.

To unlock a locked layer or a selection of locked layers:
1. In the Timeline view, select one or many locked layers.

2. Do one of the following:
‣

Select Animation > Lock > Unlock.

‣

Click one of the selected layer’s Lock

icon.
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‣

Press [Ctrl] + [Shift] + [K] (Windows/Linux) or [⌘ ] + [Shift] + [K] (Mac OS X).

All selected layers are unlocked.

Lock All
The Lock All option lets you lock all the layers in the Timeline view at once.
To lock all layers:

‣ In the top menu, select Animation > Lock > Lock All.
‣ Click one of the selected layer’s Lock

icon.

‣ Press [Ctrl] + [Shift] + [L] (Windows/Linux) or [⌘ ] + [Shift] + [L] (Mac OS X).
All layers are locked.

Unlock All
The Unlock All

button lets you unlock all the layers in the Timeline view at once.

To unlock all layers:

‣ In the top menu, select Animation > Lock > Unlock All.
‣ Press [Ctrl] + [Alt] + [Shift] + [L] (Windows/Linux) or [⌘ ] + [Alt] + [Shift] + [L] (Mac OS X).
All layers are unlocked.

Lock All Others
The Lock All Others

button lets you lock every layer except the selected ones.
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To lock all other layers:
1. In the Timeline view, select the layers that you do not want to lock.

2. Do one of the following:
‣

In the top menu, select Animation > Lock > Lock All Others.

‣

Press [Ctrl] + [Alt] + [Shift] + [O] (Windows/Linux) or [⌘ ] + [Alt] + [Shift] + [O] (Mac OS X).

All layes are locked except the selected ones.

Related Topics
•

Selecting a Layer on page 768

Positioning an Element Using the Transform Tool
Using the Transform tool, you can easily reposition, scale, rotate and even skew layers directly in the Camera
view.

When positioning a drawing layer using the Transform tool, always make sure that the Peg Selection
Mode
is deselected in the Transform tool Tool Properties view. Otherwise, it will limit the
selection to pegs in the Camera view.

Refer to Positioning Elements in 3D Space on page 859 to learn about the 3D Transform tool and
how to position elements in 3D space.

•

Repositioning the Pivot Point Temporarily on the next page

•

Panning a Drawing Layer on page 779

•

Rotating a Drawing Layer on page 779

•

Scaling an Element on page 780

•

Skewing an Element on page 780
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Repositioning the Pivot Point Temporarily
Some transformations, such as rotation, scale, skew and flip, are made relative to the pivot point position. You
can temporarily reposition this pivot point for each transformation using the Transform
tool.
To temporarily reposition the pivot point:
1. In the Tools toolbar, select the Transform

tool.

2. In the Transform tool Tool Properties view, make sure that the Peg Selection Mode

is disabled.

3. In the Camera view, click on your element to select it.
The pivot point will appear in the Camera view.

4. Click on the pivot point and drag it to a new position.
This will be the new position of the pivot point for the current transformation. It will remain in this new
position as long as you do not deselect the drawing.

Using the Transform tool to reposition your pivot will temporarily override the existing pivot point
position until you complete the current transformation, it then returns automatically to its original
position.

When you translate the pivot using the Transform tool, the permanent pivot will appear as a ghost so
you know where it is and also from where the animation will be interpolated when you create motion
paths. The animation is always interpolated from the original pivot and not the temporary pivot.
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Panning a Drawing Layer

To pan a layer using the Transform tool:
1. In the Tools toolbar, select the Transform

tool or press [Shift] + [T].

2. In the Transform tool Tool Properties view, make sure the Peg Selection Mode

is deselected.

3. In the Camera view, select a drawing layer and drag the selection to a new area. You can select multiple
layers to reposition them at once.

Rotating a Drawing Layer

To rotate a layer using the Transform tool:
1. In the Tools toolbar, select the Transform

tool or press [Shift] + [T].

2. In the Transform tool Tool Properties view, make sure the Peg Selection Mode

is deselected.

3. In the Camera view, select a drawing layer and rotate the transform bonding box handle.
A preference in the Camera tab will add a rotation handle to your object’s bounding box.This preference is off by
default.
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Scaling an Element

To scale a layer using the Transform tool:
1. In the Tools toolbar, select the Transform

tool or press [Shift] + [T].

2. In the Transform tool Tool Properties view, make sure the Peg Selection Mode

is deselected.

3. In the Camera view, select a drawing layer and pull or push on the size, top, or corner control point. Hold
down [Shift] to lock the selection’s ratio.

Skewing an Element

To skew a layer using the Transform tool:
1. In the Tools toolbar, select the Transform

tool or press [Shift] + [T].

2. In the Transform tool Tool Properties view, make sure the Peg Selection Mode

is deselected.

3. In the Camera view, select a drawing layer and drag sideway or up and down the sides or top and bottom
segments, between the control points.

Related Topics
•

Using Advanced Animation Tools to Position a Layer below

Using Advanced Animation Tools to Position a Layer
You can also use the advanced animation tools to position your layers.
•

Repositioning a Drawing on the facing page
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•

Permanently Repositioning the Pivot Point below

•

Panning an Element Using the Translate Tool on the next page

•

Rotating an Element Using the Rotate Tool on the next page

•

Scaling an Element Using the Scale Tool on page 783

•

Skewing an Element Using the Skew Tool on page 783

Repositioning a Drawing
The Reposition Drawing tool allows you to reposition drawing elements in the Drawing view while
simultaneously creating keyframes for each drawing.
This allows you to easily reposition misaligned drawing elements that may require the same pivot point and
positioning in the Drawing view.

Permanently Repositioning the Pivot Point
Some transformations, such as the rotation, scale, skew and flip, are made relative to the pivot point position.
You can reposition this pivot point anywhere using the advanced animation tools.
To permanently reposition the pivot point:
1. In the Advanced Animation toolbar, select the Rotate

, Scale

or Skew

tool.

2. In the Camera view, [Ctrl] + click (Windows/Linux) or [⌘ ] + click (Mac OS X) to select your element.
The pivot point appears in the Camera view.

3. Drag the pivot point to a new position.

This is the new position of the pivot point for future transformations until you reposition it.
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Using the advanced animation tools to permanently reposition your pivot overrides the existing pivot
point position until you change its position again.

Panning an Element Using the Translate Tool

To pan a layer using the Translate tool:
1. Do one of the following:
‣

In the top menu, select Animation > Tools > Translate.

‣

In the Advanced Animation toolbar, click the Translate

‣

Press [Alt] + [2].

tool.

2. In the Camera view, [Ctrl] + click (Windows/Linux) or [⌘ ] + click (Mac OS X) on the element to select it
and drag the selection to a new area.
You can select multiple layers to reposition them at the same time. Press [Ctrl] + [Shift] + click
(Windows/Linux) or [⌘ ] + [Shift] + click (Mac OS X) on each element to select them.

Rotating an Element Using the Rotate Tool

To rotate a layer using the Rotate tool:
1. Do one of the following:
‣

Select Animation > Tools > Rotate.

‣

In the Advanced Animation toolbar, click the Rotate

‣

Press the [Alt] + [3].

tool.

2. In the Camera view, [Ctrl] + click (Windows/Linux) or [⌘ ] + click (Mac OS X) on the element to select it
and rotate the layer.
You can select multiple layers to rotate them at the same time. Press [Ctrl] + [Shift] + click
(Windows/Linux) or [⌘ ] + [Shift] + click (Mac OS X) on each element to select them.
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Scaling an Element Using the Scale Tool

To scale a layer using the Scale tool:
1. Do one of the following:
‣

Select Animation > Tools > Scale.

‣

In the Advanced Animation toolbar, click the Scale

‣

Press [Alt] + [4].

tool.

2. In the Camera view, [Ctrl] + click (Windows/Linux) or [⌘ ] + click (Mac OS X) on the element to select it
and pull or push either on the side, top or corner control point. Hold down [Shift] to lock the selection’s
ratio when using the corner control points.
You can select multiple layers to scale them at the same time. Press [Ctrl] + [Shift] + click (Windows/Linux)
or [⌘ ] + [Shift] + click (Mac OS X) on each element to select them.

Skewing an Element Using the Skew Tool

To scale a layer using the Skew tool:
1. Do one of the following:
‣

Select Animation > Tools > Skew.

‣

In the Advanced Animation toolbar, click the Skew

‣

Press [Alt] + [5].

tool.

2. In the Camera view, [Ctrl] + click (Windows/Linux) or [⌘ ] + click (Mac OS X) on the element to select it and
drag a side of the bounding box up, down or sideways.
You can select multiple layers to skew them at the same time. Press [Ctrl] + [Shift] + click (Windows/Linux)
or [⌘ ] + [Shift] + click (Mac OS X) on each element to select them.
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Refer to the Interface on page 99 chapter to learn how to display the Advanced Animation toolbar.

Related Topics
•

Positioning an Element Using the Transform Tool on page 777

Flipping an Element
There are two different options you can use when you want to flip your element.
•

Flip Horizontal and Flip Vertical below

•

Flip Scale X and Flip Scale Y below

Flip Horizontal and Flip Vertical
The Flip Horizontal and Flip Vertical options let you flip a drawing layer along the Camera view’s horizontal and
vertical axis.

To flip a layer:
1. In the Tools toolbar, select the Transform

tool or press [Shift] + [T]

2. In the Transform Tool Properties view, make sure that the Peg Selection Mode
3. In the Camera view, use the Transform

is deselected.

tool to select a drawing layer to flip.

4. Select Animation > Flip > Flip Horizontal or Flip Vertical or press [4] or [5].

Flip Scale X and Flip Scale Y
Once your drawing layer is rotated, the original horizontal and vertical axes change. The Flip Scale X and Flip
Scale Y will perform a flip on your drawing layer following its original axis.
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•

The Flip Horizontal command flips the Layer following the Camera view X-axis.

•

The Flip Scale X command remembers the original X-axis of the layer and flips the element following it.

To flip an element following its original axis:
1. In the Transform Tool Properties view, make sure that the Peg Selection Mode
2. In the Camera view, use the Transform

is deselected.

tool to select an element that has already been transformed.

3. Select Animation > Flip > Flip Scale X or Flip Scale Y.

Related Topics
•

Positioning an Element Using the Transform Tool on page 777

Positioning an Element Using the Layer Properties
To position an element using its Layer Properties dialog box:
1. In the Timeline view,right-click on the drawing layer and select Layer Properties or press [Shift] + [E]. You
can also double-click on the layer, or click once and see the parameters in the Layer Properties view.
‣

You can also open the Layer Properties dialog box from the Network view by clicking on the
module’s square yellow button.

The drawing Layer Properties dialog box opens.
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2. The Enable 3D check box displays the 3D parameters in the Layer Properties.

Refer to Positioning the Scene Components on page 768 to learn more about the 3D parameters
and how to use them to position your element in the 3D space.

3. In the Position section, type in the desired value of the new element position.

‣ Select the Separate option to enable the edit of the different coordinate fields.
‣ Select the 3D Path option to enable the use of a 3D path function when animating your element. Refer to
the Animation Paths on page 937 chapter to learn more about 3D paths and Velocity.
‣

In the (x) Axis field, type in a new East/West coordinate corresponding to the desired position.

‣

In the (y) Axis field, type in a new North/South coordinate corresponding to the desired position.

‣

In the (z) Axis field, type in a new Forward/Backward coordinate corresponding to the desired
position. Refer to the Creating a Multiplane on page 831 topic to learn more about positioning layers
on the Z-axis.
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‣

The Function

buttons are used to create function curves when animating.

4. In the Scale section, select one of the following:

‣

Separate: Resizes the element with independent X and Y scales. This allows you to squash and
stretch.
(x) Axis: Type in the horizontal scale value.
(y) Axis: Type in the vertical scale value.

‣

Locked: Resizes the element while keeping its ratio.
(xy) Axis: Type in the horizontal and vertical scales value.

5. In the Angle Z field, type in a degree value between -360 to 360 for the rotation angle.

6. In the Skew field, type in a degree value between -90 to 90 for the skew angle.

7. In the Pivot section, type in the desired coordinate value to reposition the transformation pivot. This will
change the permanent position of the pivot.

‣

In the (x) Axis field, type in a new East/West coordinate corresponding to the desired position.

‣

In the (y) Axis field, type in a new North/South coordinate corresponding to the desired position.

As you type in the new values, the element’s position is updated in the Camera view.

Refer to the Animation Paths on page 937 chapter to learn more about function curves and
animating elements on pegs.

Related Topics
•

Drawing Layer Properties Advanced Tab below

•

Drawing Layer Properties Drawing Tab on page 792

Drawing Layer Properties Advanced Tab
In the drawing layer's Layer Properties dialog box, you will find an Advanced tab containing some very useful
options:
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Animation
•

Animate Using Animation Tools: By default, a drawing layer can be animated, but Toon Boom Harmony
gives you the ability to disable this feature. Being able to switch your drawings so they can no longer be
animated without a peg has certain advantages. It means that you can have access to the drawing
substitution feature for this drawing layer, while being able to create keyframes on its parent peg. This
feature is also available for backward compatibility when bringing in templates created in older versions
of the software, so as not to lose their offset keyframes or drawing substitution keyframes.

Refer to the Cut-out Animation on page 1029 chapter to learn more about the Animate Using
Animation Tools option.

Angle Limit Value
Use this section to set a maximum and minimum rotation angle for your drawing. You will mainly use the option
for a cut-out character when you do not want an elbow to bend too far in or too far out.
•

Enable Min/Max Angle: Enable this option if you want to activate the minimum and maximum angle
constraints.

•

Min Angle: Type the minimum angle you want the drawing to rotate too.
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•

Max Angle: Type the maximum angle you want the drawing to rotate too.

Spline Offset
In the X, Y and Z axis fields, type the coordinates of where you want to offset the visual trajectory. By default, the
trajectory is displayed at the centre of the Camera view. If you want to move it so it corresponds better with
your drawing, either type new coordinates or use the Spline Offset
tool available in the Advanced
Animation toolbar.
To display the trajectory in the Camera view, select your drawing and select View > Show > Control.

Alignment
•

Alignment Rule: The alignment rule selections are intended to deal with drawings that were created on
paper of a different size or orientation from the default alignment rule (set up in the Scene Setting dialog
box). If you select Turn Before Alignment, the drawings are rotated and then scaled, based on the
option selected from the drop-down list. The drawings are then scaled to match Toon Boom Harmony
alignment rectangle.
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•

Left: The default alignment for drawings; aligns the drawings on the left side of the scene’s alignment
rectangle. Toon Boom Harmony scales the drawings to match their height to the alignment rectangle
of the scene.

•

Right: Aligns the drawings on the right side of the alignment rectangle. Toon Boom Harmony scales
the drawings to match their height to the height of the alignment rectangle of the scene.

•

Top: Aligns the drawings on the top of the alignment rectangle. Toon Boom Harmony scales the
drawings to match their widths to the width of the alignment rectangle of the scene.

•

Bottom: Aligns the drawings on the bottom of the alignment rectangle. Toon Boom Harmony scales
the drawings to match their widths to the width of the alignment rectangle of the scene.

•

Centre Fit: Centres the drawings.

•

Centre Fill: Centres the drawings and then scales them so that the width or height fills the available
space.

•

Centre LR: Aligns the drawings in the left-right centre of the alignment rectangle. Toon Boom
Harmony scales the drawings to match their height to the height of the alignment rectangle of the
scene.

•

Centre TB: Aligns the drawings in the top-bottom centre of the alignment rectangle. Toon Boom
Harmony scales the drawings to match their widths to the width of the alignment rectangle of the
scene.

•

Stretch: Scales the drawings so that they fit within the alignment rectangle of the scene. This is
particularly useful for images that you will manipulate with a Quadmap module. If the drawings in the
Quadmap module do not have the same aspect ratio as the alignment rectangle of the scene (from
the Scene Settings dialog box), the handles on the quadmap will not appear on the corners of the
image, making it difficult to manipulate the quadmap. In this case, you would set the drawing layer of
the quadmap images to Stretch so that the handles appear on the corner of the image. This can have
the effect of distorting the images, but this is not an issue with images that will be distorted through
the Quadmap module anyway.

•

As Is: Leaves the drawings aligned as they are.

•

Centre First Page: Aligns the centre of the first part of a standard pan cel with the centre of the field
chart.

•

Turn Before Alignment: This option rotates the drawings in the selected element 90 degrees to the left
before scaling and aligning them according to the alignment rule, and before performing any offset,
rotation or scaling for the element or the peg. This and the Alignment Rule are intended for drawings that
were created on paper of a different size or orientation than the other paper in the scene, and requires
alignment so as to be able to accurately treat them.

•

Flip Horizontal: Flips the drawing on the X-axis.

•

Flip Vertical: Flips the drawing on the Y-axis.

Clipping
•

No Clipping: Select this option if you do not want to clip the images in this module before an effect is
applied to it.

•

Clipping Factor (X)/(Y): This is an option for rendering images that are larger than the final frame. With
this option enabled, images can be moved by an Apply Peg Transformation module without black
entering into the composite as a result of early clipping. In addition, this option is useful for images that
have a blur that should appear in the frame even though the image itself is not in frame.
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Line Thickness
•

Adjust Pencil Lines Thickness: Enable this option if you are working with pencil lines. If you do not check
this option and are working with pencil lines, you will not see any changes to your lines in the Camera
view, in the Render mode after making adjustments in the Layer Properties panel.

•

Normal Thickness: Disables all overrides on the Line Thickness.

•

Zoom Independent Thickness: Select this if you do not want to display line thickness in proportion the
amount of zoom in the view window. Everything else will increase in size, but the line thickness will stay the
same.

•

Proportional: Enter a multiple by which you want to increase the line thickness. Entering 1 will result in no
change; entering 0 (zero) will hide the lines.

•

Constant: Enter a value in pixels (based on a 740x540 screen resolution) at which to maintain the line
thickness.

•

Minimum: Enter a value in pixels (based on a 74 x540 screen resolution) for the minimum line thickness
allowed.

•

Maximum: Enter a value in pixels (based on a 740x540 screen resolution) for the maximum line thickness
allowed.

To modify the line thickness:
•

The lines must be converted to Colour Art (select Drawing > Create Colour Art from Line Art).

•

To view this feature in the Camera view, you must first activate the Enable Variable Line Thickness
option, found in the OpenGL tab in the Preferences panel.

Refer to the OpenGL Tab Preferences on page 844 topic to learn more about this option.

Related Topics
•

Drawing Layer Properties Drawing Tab on the next page
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Drawing Layer Properties Drawing Tab

•

Full Name: Select which element to connect to the module from the drop-down list of elements that
already exist in your scene.

•

Drawing Path: Displays the full path to the current drawing.

•

Use Embedded Pivots: By default, this option is set to Apply Embedded Pivot on Drawing Layer.
•

Don’t Use Embedded Pivot: When this option is selected, the layer will not use the pivot set on the
drawing or symbol. The pivot will be located at the centre of the Camera view, meaning (0,0,0). If
there is a transformation applied on the layer, the pivot will be offset following the transformation.

•

Apply Embedded Pivot on Parent Peg: When this option is selected, the pivot set on the drawing or
symbol will automatically be applied to the first peg layer the drawing layer is connected to. When
selecting the element in the Camera view using the Transform tool, the peg layer will be selected. Even
when the drawing layer is selected in the Camera view, the transformation will be applied on the
parent peg.

You only need to use this option when you want to have the position of the pivot animate. This is
useful if you want to have multiple views all on the same layers in the Timeline view.
For simplicity and organization, it is recommended to keep all views on their own separate layers in
the Timeline view. Then you can simply set the pivot using the Rotate tool for the whole layer.
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•

Apply Embedded Pivot on Drawing Layer: This is the most common behaviour a user will use.
Automatically, the layer will use the pivot that was set on the drawing or symbol’s frame using the
Pivot tool.

Refer to the Setting the Pivots on page 716 to learn about using embedded pivots.

Vector Options
•

Read Overlay: Enable this option to display and render the Overlay layer of this drawing layer in your
scene and final export. Disabling it will hide it.

•

Read Line Art: Enable this option to display and render the Line Art layer of this drawing layer in your
scene and final export. Disabling it will hide it.

•

Read Colour Art: Enable this option to display and render the Colour Art layer of this drawing layer in
your scene and final export. Disabling it will hide it.

•

Read Underlay: Enable this option to display and render the Underlay layer of this drawing layer in your
scene and final export. Disabling it will hide it.

•

Antialiasing Quality: A smoothness setting applied to Colour Art.
•

Low: No antialiasing

•

Medium Low: Basic antialiasing

•

Medium: Improved antialiasing (Blurs the textures)

•

High: Improvied antialiasing (Does not blur the textures)

Higher quality images require more time to render and more system memory. Choose a lower quality if
you are rendering a pencil test.
•

Antialiasing Exponent: Controls the size of the area around the Line Art and Colour Art edges that is
used in the antialiasing process. A higher value uses less area, resulting in sharper edges, while a lower
value uses more area, resulting in softer edges. If the Antialiasing Quality value is set to Low (no
antialiasing) or Medium Low, this value is ignored. The accepted values are between 0 and 1.

•

Texture Filter: This option changes the way coloured pixels of TVG textures are calculated when
rendered for different degrees of accuracy.
•

Bilinear: This option takes the four pixels around each point and makes a bilinear interpolation
between them. (Medium Quality)

•

Nearest: This option chooses the colour of the closest pixel to a point. (Lower Quality)

•

Nearest (Filtered): This option is an improved version of Bilinear and improves the quality when
zooming on a texture. (Best Quality)

Bitmap Options
•

Read Colour: Controls the production of colour information from bitmap images. If this module reads 3
or 4-channel bitmaps, this selection determines whether the colour should be read or ignored. If this
module reads 1-channel bitmaps, this selection determines whether the channel should be read as colour.
When this option is selected with 1-channel images, the resulting image will be a greyscale image.
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•

Read Transparency: Controls the production of alpha information from bitmap images. If this module
reads a 1 or 3-channel image, this option will create a matte from the colour values in the image. If the
module reads a 4-channel image and this option is not selected, the alpha information in the image will be
ignored.

•

Transparency Type:
•

Premultiplied with Black: Pixels at the edge of an image are blended with black.

•

Premultiplied with White: Pixels at the edge of an image are blended with white.

•

Straight: Pixels at the edge of an image are blended with black, white and greys.

•

Clamp Colour to Alpha: Select this option when you want to pre-multiply the colour value with the
alpha value. When the colour is clamped to the alpha, the colour value cannot be higher than the alpha
value. It calculates the real colour value faster. When the RGB values are multiplied with the alpha
value, that is to say, if you have a pixel of value R=247, G=188, B=29 and the alpha is 50% or the image
has a 50% transparency, then the actual RGB values output would be half of the amounts listed above.

•

Depth: Overrides the order of cables in the network to determine how this element is rendered.

•

Morphing Velocity: Attaches a function curve to interpolate the morphing velocity between two frames.
The morphing velocity at a specific frame is the ratio of the difference between the current frame and the
first and last frames of the morphing.

•

Opacity: Use this slider to quickly change the opacity of the selected element. Opacity settings here will
be reflected in both OpenGL preview, and full render.

To learn about the Morphing Velocity option, refer to Adjusting the Velocity and Timing on
page 542.

Related Topics
•

Drawing Layer Properties Advanced Tab on page 787

Auto-Apply Option
When you modify a parameter in a property dialog box, Toon Boom Harmony calculates the modification
automatically and displays the result immediately in the Camera view. If you do not want to immediately display
every change made to your scene, you can turn off this default setting by disabling the Auto-Apply option. For
example, when you are working on a very heavy scene.
Disabling this function will result in adding Apply and OK buttons at the bottom of your Layer Properties view
and any other parameter dialog box.
•

Click Apply to apply the current change.

•

Click OK to apply the current change and close the Layer Properties.
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To disable or enable the Auto-Apply option:

‣ In the top menu, select Edit > Auto-Apply.
If you wish to always work in Auto-Apply mode, you can disable the Auto-Apply preference.
When the preference is disabled, each time you launch the application, your Auto-Apply mode will be set to
OFF. You will need to click on the Apply button to see the modifications.
To disable and enable the Auto-Apply preference:
1. In the top menu, select Edit > Preferences (Windows/Linux) or
Stage > Preferences (Mac OS X).
The Preferences panel opens.
2. In the Preferences panel, go to the General tab.
3. In the Options section, disable or enable the Auto Apply preference.

Related Topics
•

Positioning the Scene Components on page 768

Resetting a Transformation
You can easily reset layers to their original position in the Camera view. Use the Select command to reset the
value of the selected element to the initial value of the active tool. For example, if the Rotate
tool is active,
the transformation angle will be reset to 0 and if the Transform
values will be reset.
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When selecting elements in the Camera view using the Transform tool, always make sure that the
Peg Selection Mode
is deselected in the Transform tool Tool Properties view. Otherwise, it will
limit the selection to pegs only.

To reset the layers` position:
1. In the Tools toolbar, select the Transform

tool or press [Shift] + [T].

2. In the Timeline or Camera view, select one or more drawing layers to reset.
3. Do one of the following:
‣

From the top menu, select Animation > Reset or press [R].

‣

Right-click the selected layers and select Clear All Values.

‣

In the Timeline view, select Layers > Clear All Values from the Timeline View menu.

The selected layers return to their original position.
To reset all transformation values except Z:
1. In the Tools toolbar, select the Transform

tool or press [Shift] + [T].

2. In the Timeline or Camera view, select one or more drawing layers to reset.
3. Do one of the following:
‣

Select Animation > Reset All Except Z.

‣

In the Timeline view, right-click the selected layers and select Clear All Values.

All values, except for those set on the Z axis are reset.

Related Topics
•

Positioning the Scene Components on page 768
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Cloning and Duplicating Layers

You may need to clone or duplicate a layer during a production. This allows you to modify the layers’s drawings
or the timing independently from the original column.

Related Topics
•

Cloning Layers below

•

Duplicating Layers on the next page

Cloning Layers
A cloned layer is linked to the original element directory. If a drawing is modified in the original or cloned layer,
both will be updated. However, clone layers can have different timings.
For example, if you make a walk-cycle for a soldier and want to use it for a whole army, you may want to have
fifty layers with fifty different drawing exposures to produce a slight difference in the timing. You don’t
necessarily want the same drawing fifty times. If you copy your layers and their drawings fifty times over, it will
create a very heavy scene. It is better to clone the fifty layers from the same initial layer to have them all linked to
the same walk cycle drawings, producing fifty layers but one drawing directory. This will also allow you to correct
the drawings in one layer and have all of the other ones updated simultaneously.

When you clone a layer that is already linked to a function, the cloned layers are automatically linked
to the same function, so if you reposition the layers while in Animate
mode, they are all
repositioned to the same place because a keyframe is added to this function. If you want the layers to
move on a trajectory that is independent, make sure to unlink the function before cloning.
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To clone a layer:
1. In the Timeline view, select a layer to clone.
‣

In the Network view, select the module you want to clone.

2. In the Timeline View menu, select Layers > Clone Selected Layers.
‣

In the Network View menu, select Modules > Clone Selected Modules.

Note that the module appears in the Timeline view if it is not connected to the Composite module or if the
Display mode is not set on Display All.

Related Topics
•

Duplicating Layers below

•

Animation Paths on page 937

•

Setting Up the Network on page 800

Duplicating Layers
You can duplicate a layer to have a copy of the drawings that are independent from the original column, as well
as an independent timing (exposure). When you need the drawings to be modified independently, you will want
to duplicate the layer instead of cloning it.
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To duplicate a layer:
1. In the Timeline view, select the layer to duplicate.
‣

In the Network view, select the module you want to duplicate.

2. In the Timeline View menu, select Layers > Duplicate Selected Layers.
‣

In the Network View menu, select Modules > Duplicate Selected Modules. When you duplicate a
module, it does not automatically connect itself to the Composite module of your scene.

The duplicated layer appears.

By default when you select a module in the Network view and do a copy paste using [Ctrl] + [C] and
[Ctrl] + [V] (Windows/Linux) or [⌘] + [C] and [⌘] + [V] (Mac OS X), this creates a CLONE not a
duplicate. Modules will be linked to the same drawings. Pegs will be linked to the same function
columns.
To duplicate a layer in the Network view using shortcuts, you must do [Ctrl] + [C] (Windows/Linux) or
[⌘] + [C] (Mac OS X) and [Ctrl] + [B] (Windows/Linux) or [⌘] + [B] (Mac OS X) for Paste Special, and
selecte Create New Columns.

Related Topics
•

Setting Up the Network on the next page

•

Cloning Layers on page 797
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Setting Up the Network

The Network view uses a visual set of connections to show how each element in the scene is brought to the final
image. It allows you to add extra elements and effects, and to move beyond the possibilities offered by the
Timeline and Xsheet views.

Related Topics
•

Network View on the facing page

•

Network Navigation and Basic Rules on the facing page
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Network View

1. Modules
2. Navigator
3. Group Hierarchy Menu
4. Editing Stack Menu
5. Network View Toolbar
6. Network View Menu

Related Topics
•

Network Navigation and Basic Rules below

•

Integrated Help View on page 1205

Network Navigation and Basic Rules
The basic rules of the Network view are quite simple. Once you understand them, a lot can be accomplished.

Related Topics
•

About Modules on the next page
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•

Input and Output Ports below

•

Adding Modules on page 805

•

Composite Module on page 805

•

Organizing Modules on page 806

•

Connecting and Disconnecting Modules on page 806

•

Cable Styles on page 808

•

Navigator Display on page 809

•

Panning the Network View on page 810

About Modules

Each element in the Network view is called a module. There are several different types of modules:
Module

Description

Drawing

Transfers drawing information.

Effect

Processes effects on drawings and transfers drawing information.

Input/Output

Act as the interface between each module and network.

Move

Controls the camera and element transformations over time.

Compositing

Combines multiple source images.

Input and Output Ports
Each module has an input port at the top and an output port at the bottom. Some are blue and others are lightgreen or bright green.
•

Blue indicates drawing information.
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•

Light Green indicates position and movement.

•

Bright green shows the element on top of the composition and outputs that element’s Z position to the
Composite module. When many elements have different Z positions (multiplane, different distances from
the camera) and are placed through a Composite module that flattens them together (producing one
image with one Z value), the system needs to give a Z position to this new image. It uses the bright green
port information.

Finally, some modules contain more than one Input port. These are usually Effects modules needing different
drawing or position information in order to perform their calculation. When the two ports are blue, the Drawing
is on the right and the Matte is on the left. If it is light green, the drawing needs extra position information.

Viewing Port Information
On each port is a tooltip which displays the source of in-ports and the destination(s) of the out-ports.
To display port information:
‣

Hover your cursor over a port.

The port's tooltip displays source and destination information.

Navigating the Network View
You can navigate to the parent or child module of the selected module or selected cable in the Network.
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To navigate the Network view:
‣

In the Network view, select a module or cable, and press [Ctrl] + [Up]/[Down] arrows.

Adding Modules
Each module used to build a network is available in the Module Library view. In addition, each time you create a
layer from the Timeline or Xsheet views, the corresponding module is created in the Network view.
To import modules from the Module Library:
‣

In the Module Library, select a module and drag it to the Network view.

Composite Module

The Composite module allows you to use several images and output a single image. You can compare that to
doing pre-compositions in editing software. You connect several drawing modules in your Composite module
and one bitmap comes out of it.
By default, the image resulting from the Composite module is a bitmap. The layers are composited together
depending on their position on the Z-axis (forward-backward) first, then their order in the Composite module. If
two images are at the same position on the Z-axis, their order in the Composite will determine which one is
displayed in front and which one is displayed behind.
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Organizing Modules
When you are working in the Network view and adding many modules, your scene may look a bit messy and be
difficult to follow. To fix this, Harmony provides the Order Network script which organizes and displays the
modules in a more orderly fashion.
To organize your network:
1. In the Network view, select some or all of your modules.

2. Display the Scripting toolbar by selecting Window > Toolbars > Scripting.
3. Click the Order Network Up

or Order Network Down

button.

The Order Network Settings dialog box opens.

4. Set an X Overlap% value.
5. Set a Layer Spacing value.
6. Set a Vertical Spacing value.

Connecting and Disconnecting Modules
Making or removing connections between modules is quite simple.
To connect modules:
1. In the Network view, do one of the following:
‣

Extend a cable from the first module’s output port and connect it in the second module’s input port.
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‣

Select the module to connect, hold down the [Alt] key and drag the module on an existing cable.

It is now possible to create links between nodes in the Network views by clicking on one node and ctrl-clicking on
a second port. For example:
Select a node and [Ctrl]-click a port:
•

Click a node and then [Ctrl]-click the in-port of a different node. The nodes are linked.

•

Click the out-port of a node and then [Ctrl]-click a different node The nodes are linked.

•

Click the out-port of a node, and then [Ctrl]-click a Composite node. The node is linked to a new in-port of
the Composite.

•

Click a port of a node and then [Ctrl]+[Alt]-click a port of a Composite node. The selected port replaces
the link in the Composite's in-port.

•

Click an out-port of a node and then [Ctrl]-click the in-port of a Group node. The selected output port
replaces the link to the group.

•

Click an out-port of a node and then [Ctrl]+[Alt]-click the in-port of a Group node. The selected output
port links to a new in-port of the group.

You can reconnect a module's output port without unconnecting its destination port by dragging the
link while holding [Ctrl].

To disconnect modules:
1. In the Network view, do one of the following:
‣

Select the module to disconnect, hold down the [Alt] key and drag the module away.
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Cable Styles
You can customize the look of the cables in the Network view to fit your style of working. You can display the
cable lines as Bezier (curved) lines or straight lines.

To switch cable styles:

‣ In the Network View menu, select View > Cable Style > Bezier or Line.

Refer to Scene Setup Preferences on page 838 to learn how to set the cable style in the Preferences
dialog box.
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Navigator Display
The Navigator is a small square window inside the Network view that displays a bird's eye view of the network.
The view displayed in the Network view is shown framed in the Navigator display. You can drag this frame to pan
the current Network view display.

Showing and Hiding the Navigator
You can show or hide the Navigator from the Network view.
To show or hide the navigator, do one of the following:

‣ In the Network View menu, select View > Navigator > Hide Navigator or Show Navigator.
‣ Press [Ctrl] + [Shift] + [W] (Windows/Linux) or [⌘ ] + [Shift] + [W] (Mac OS X).
Positioning the Navigator
The Navigator display can be placed in any corner of the Network view.
To position the navigator:

‣ In the Network View menu, select View > Navigator > and select Top Left, Top Right, Bottom Left, or
Bottom Right.

Refer to Scene Setup Preferences on page 838 to learn how to set the Navigator display options in
the Preferences dialog box.
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Magnifying the Network view:
The magnifier helps you view the entire network so you can navigate and view the different modules.

To magnify the Network view:
1. Press [Z].
A black outline surrounds the area you were at before pressing [Z].
2. Change the magnification level of the magnifier by rolling the mouse wheel.

When the magnifier is displayed, it is possible to temporarily switch in and out of the magnified view
by clicking in the magnifier.

Panning the Network View
Once you have selected a node, you can pan the Network view to navigate around when your network grows
more complex.
To pan the Network view:
1. Select a node, press [Spacebar] and drag to a new location.

Related Topics
•

Composite Layer Properties on the facing page

•

Grouping Modules on page 813

•

Enabling and Disabling Modules on page 820

•

Module Thumbnails on page 821
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Composite Layer Properties

For more information about the Composite module options in a 3D environment context,
refer to Managing a Network with a 3D Scene Setup on page 871.

Composite Options
•

As Bitmap: when selected, it composites all of the images into a single, flat bitmap image. The Z value of
the final image will be based on the Output Z selection.

•

As Vector: when selected, it composites all of the images as a single vector image. The Z value of the final
image will be based on the Output Z selection.

•

As Seamless Bitmap: When selected, it composites all of the images into a single, flat bitmap image (just
like the As Bitmap compositing mode). The main difference between the As Bitmap and As Seamless
Bitmap modes is that the seamless version ensures that there is no visible seam between adjacent vector
drawings that have matching geometries. This can be useful for cut-out animation, where multiple
drawings may align perfectly like pieces of a puzzle. This can also be useful when building a 3D set out of
flat drawings rotated in 3D. In this case, using the Seamless mode will produce the correct result when
two drawings are either intersecting, or nearly intersecting, in 3D. Note that the As Seamless Bitmap
mode does not support the following effects: Shadow, Glow, Blending and Focus.

•

Pass Through: when selected, no compositing operations occur. No image will be merged or flattened.
Each individual image will keep its own properties. The compositing operations will happen only in the
next Composite module connected below. In this case, the Input Ordering options are ignored.
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If a Composite set to Pass Through it is the last one in the compositing chain, it will act the same as the
As Bitmap option. At that point, the Input Ordering options will be considered.
Input Ordering Options
•

2D: When selected, elements connected in the module are composited based on their port ordering. The
Z-axis (forward-backward) values are ignored. The scaling value will be correct, but the actual position on
the Z-axis will be ignored.
You can use the 2D composite type to create effects such as a camera recording overlay on your scene.
Since you always want this element to be in front regardless of the other elements Z-axis position, you can
set the option to 2D.

•

3D Flat: When selected, the Z-axis value of the elements connected in the Composite module are
considered, so the visual representation is correct in the Camera view. The output will be a flat image.

•

3D: When selected, the Z-axis value of the elements connected in the composite module are considered,
so the visual representation is correct in the Camera view. The image will not be flattened. The 3D aspect
of the elements will be kept. For example, if you rotated elements on the three axes, the information will
be retained and elements composited in lower levels will be able to intersect with the elements coming
from a 3D Composite module.
The 3D Composite module should only be used in advanced cases. It is better to use a Pass Through
composite type than a 3D composite type. This way, all the elements are composited together in the final
Composite module.

Output Options
•

Output Z: Use this selection to identify which element’s front-back value from the current composition will
be applied to the entire composited image in the next operation. If you select Portnumber, identify the
appropriate port by its position using the Port For Output Z menu. The port used appears in a bright
green the other ports on the Composite module. By default, the leftmost port is displayed in front and
the rightmost one is displayed behind.

Bitmap Options
These options are active when you select the As Bitmap mode.
•

Apply Focus: Activates the Focus effect for this module in the composite operation.
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•

Focus Multiplier: The value entered in this field is used as a multiplier for the radius value specified in the
Focus or Focus-Multiplier modules.

Vector Options
These options are active when you select the As Vector mode.
•

Palette Name: When you render files, you can use this field to set the name of the palette files that Toon
Boom Harmony will create for them.

•

Flatten: When selected, flattens vector drawings into one vector drawing file. Any transparency will be
lost in the process. This creates smaller vector files, but might increase the time required to composite
the drawings. This can be useful when reusing drawings. Because they will be vector files, you will still be
able to apply vector-based transformations and effects.

Related Topics
•

Network Navigation and Basic Rules on page 801

•

Managing a Network with a 3D Scene Setup on page 871

Grouping Modules
With so many connections and modules possible, the network can quickly become crowded. Keep things
organized by grouping your modules.

When you select part of a group, this indicated in the Timeline view by a light-blue colour on the
affected layer.

•

Grouping a Selection below

•

Grouping a Selection with Composite on the next page

•

Ungrouping a Selection on page 816

•

Entering and Exiting a Group Module on page 817

•

Moving a Selected Module to its Parent Group on page 818

Grouping a Selection
To group selected modules:
1. In the Network view, drag a selection around the modules you want to group.
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2. In the Network View menu, do one of the following:
‣

Select Edit > Group > Group Selected Layers

‣

Press [Ctrl] + [G] (Windows/Linux) or [⌘ ] + [G] (Mac OS X).

.

The modules are grouped.

To ensure that you have a Multi-Port Out Module in your group and that your group remains
connected, include a Composite module in your selection and make sure it is connected to the main
Composite module of the scene before grouping.

Grouping a Selection with Composite
There are several advantages to using the Group Selection With Composite command over the simple Group
Selection (which references both the Group layer in the Timeline and the Group module in the Network view.
One of the advantages of using this command is that it groups all the selected elements into a neat module that
has a nested composite. This means that there is only one connection coming out of the Group module. With the
simple Group module or command, the Group displays the same number of connections as elements in the
group. Both grouping commands display the same structure in the Timeline view.

Group Selection
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Group Selection With Composite

The Group Selection With Composite command should only be used before any work has been done in the
Network view and it recommended for objects whose stacking order is of no consequence.

Using the Group Selection from Composite command on elements that have effects, have been
tweaked in the Network view, or whose stacking order is of consequence, may cause the grouped
elements to lose their properties once grouped in this way. In addition, though you may only select a
few modules to group, if there are other layers in the timeline that exist between the selected layers,
they will automatically be grouped, even if not selected.

To group selected elements using the Group Selection With Composite command in the Network view:
1. In the Network view, select the elements that you wish to group.

2. Right-click in the Network view and select Group > Group Selection With Composite from the menu.
The selected modules will be grouped.
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To group selected elements using the Group Selection With Composite command in the Timeline view:
1. In the Timeline view, in the layers section, select the elements that you wish to group.
Any layers between the selected layers will automatically get grouped as well, so if the stacking order is of
no consequence, move extra layers either above or below the layers that you wish to group.
2. right-click on one of the highlighted layers and from the pop-up menu select Group Selection With
Composite.

The layers appear indented under a new Group layer in the Timeline view and in a new Group module in
the Network view.

Ungrouping a Selection
To ungroup a group:
1. In the Network view, select the group of modules you want to ungroup.

2. In the Network View menu, select Edit > Group > Ungroup
(Windows/Linux) or [⌘ ] + [Shift] + [G] (Mac OS X).
The selected group is ungrouped.
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Entering and Exiting a Group Module
Once you create a group module, it is easy to enter into or exit from it.
To enter a group module:
•

In the Network view, click the arrow on the right side of the group module you want to enter.

Inside the group module, the Multi-Port In and Multi-Port Out modules ensure that your connections
continue beyond the group.

To exit a group module:
1. In the Network view, click the destination in the Group Hierarchy menu. You can also select Modules >
Exit Group from the Network View menu or press [Backspace].
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‣

When you enter a group, the Group Hierarchy Menu displays the path to where you are. In this
example, we are inside the group named group. To exit this group, click on Top Group.

To move up a level in a group:
1. Click the arrow at the top of the Network view.

Moving a Selected Module to its Parent Group
Using the Move to Parent Group command allows you to move the selected module to the parent level,
maintaining all connections.
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If the operation cannot maintain the connections between the modules, you will be notified and the
operation will be terminated.

To move a selected module to its parent group:
1. In the Network view, go inside the group and select the modules you wish to move up to the parent group
level.

2. In the Network View menu, select Modules > Move to Parent Group or press [Ctrl] + [Shift] + [U]
(Windows/Linux) or [⌘ ] + [Shift] + [U] (Mac OS X).
The selected modules are moved to the parent group level.

Related Topics
•

Network Navigation and Basic Rules on page 801
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Enabling and Disabling Modules
As with the Timeline layers, you can turn the Network view modules on or off. When you turn off a module in the
Network view, its corresponding layer in the Timeline view is also turned off. Modules that are turned off are
displayed in red.
•

Enabling Modules below

•

Disabling Modules below

Enabling Modules
To enable modules:
1. In the Network view, select the disabled module(s) you want to enable.

2. In the Network View menu, select Modules > Enable or press [A]. This keyboard shortcut is also valid in
the Timeline view.

To enable all modules:
1. In the Network View menu, select Modules > Enable All.

Disabling Modules
To disable modules:
1. In the Network view, select the module(s) you want to enable.
2. In the Network View menu, select Modules > Disable or press [D].
To disable all other modules:
1. In the Network view, select the module(s) to remain enabled.
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2. In the Network View menu, select Modules > Disable All Others.
All modules are disabled except for those selected. This operation only affects the current level layers. It
does not affect the nested modules within a group.

Related Topics
•

Network Navigation and Basic Rules on page 801

Module Thumbnails
In the Network view, some modules have a thumbnail option, identified by an arrow next to the square yellow
button.

•

Show Thumbnails below

•

Hide Thumbnails on the next page

•

Hide All Thumbnails on page 823

Show Thumbnails
To show a module’s thumbnail:

‣ In the Network view, click on the arrow in the module.
The thumbnail opens.
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‣

If no thumbnail appears, click on the Render View Mode

button in the Camera view bottom

toolbar to generate them.
To show thumbnails of selected modules:
1. In the Network view, select the module(s) you want to display the thumbnail for.

2. In the Network View menu, select View > Show Selected Thumbnails or press [T].

‣

If no thumbnail appears, click the Render View Mode

button in the Camera view bottom toolbar

to generate them.

Hide Thumbnails
To hide a module’s thumbnail:

‣ In the Network view, click on the arrow in the module.
The thumbnail closes and the module returns to its closed state.
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To hide thumbnails for the selected modules:
1. In the Network view, select the module(s) you want to hide the thumbnail display for.

2. In the Network View menu, select View > Hide Selected Thumbnails or press [T].

Hide All Thumbnails
To hide all modules thumbnails:
1. In the Network View menu, select View > Hide All Thumbnails.

823

Chapter 12: Scene Setup Setting Up the Network

Related Topics
•

Network Navigation and Basic Rules on page 801

824

Toon Boom Harmony 10.3 Stage User Guide

Display Concepts
The Display module is an important element as it displays its content in the other views, primarily the Camera,
Timeline and Playback views. It is located in the Module Library and imported in the Network view and can be
connected to any module that outputs drawing images, such as drawing elements, effects or composite
modules.
•

Display Modules below

•

Global Display on the next page

•

Display All on the next page

•

Display Modes on page 827

Display Modules
You can have more than one Display module in a network allowing you to visualize different sections of the
scenes without disabling or disconnecting elements that could be in the way. This technique is useful in Cut-out
animation as it allows you to see one puppet without having all of the other characters in the way. It is also useful
during compositing and helps you visualize effects individually.
You can add a Display to your Network view by dragging one from the Module Library view.
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To use this display concept, you must first show the Display toolbar.

Global Display
Harmony uses a Display toolbar to select the different display modules available in the network.
When selecting a new display, all of the views will update to show the content of the new display module. The
Display toolbar is called the Global Display.
To select a different display module as a global display:

‣ Open the Display toolbar drop-down menu and select the desired display module from the list.
Every view display will be updated in sequence.

Display All
When your scene does not have a Display module, it is automatically set to Display All. This mode will set the
display to the same order as the Timeline view.
You can also set your display to Display All with the Display toolbar.

If you try to add a peg layer in the Timeline view without having a layer selected, the peg layer will
be floating in the Network view and will not be visible in the Timeline view. The Timeline view shows
If you switch to Display All, as a result of that, you run the risk of not realizing when you have floating
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modules that aren't connected to your composite. For this reason it's not recommended to work in
Display All mode.

Display Modes
Toon Boom Harmony has two display modes. By default, it is set on Basic Display mode.
•

Basic Display below

•

Advanced Display below

Basic Display
When creating a scene in Basic Display mode, a display module is automatically added to the network and
connected to the final composite module. All of the views are set to display this module. This means that only the
elements connected in that composite module will show in the Camera view.
You can add and connect more display modules to your network and select the one you want using the Global
Display drop-down menu. In Basic mode, every view is set to the same Display module.

Advanced Display
In Advanced Display mode, every view has its own Display drop down menu and each can be set to a different
Display module. To switch from Basic to Advanced Display mode, you must enable the Advanced Display
preference.
To enable the Advanced Display preference:
1. Select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X) to open the
Preferences panel. The [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).
2. In the Preferences panel, under the Advanced tab, select the Advanced Display option.

A Display drop-down menu appears in the top-left corner of the Camera, Timeline, Perspective, Top, and
Side views.

When Harmony is set on Advanced Display mode, a Display drop-down menu appears in each view. These
menus allow you to set the views for different displays. By default, all views are set on Global Display to follow
the Global Display toolbar selection. However, you may want different views set on different displays. For
example, you can have one Camera view to display the full scene and another Camera view to only display the
character being animated. In this case, the user will set the first Camera view on the final display and the second
on the character’s display module.
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If you want the views to follow the Global Display toolbar selection, set the view display menu to Global display.

Related Topics
•

Network View on page 801

Timeline View Modes
To streamline the process of working with elements in the Timeline, there are three different view modes you can
choose to work in. With each mode you select, certain elements may or may not be visible in the Timeline.
Depending on your workflow, this can come in useful to quickly hide elements when you want to focus on specific
ones. To select a view mode, use the drop down menu located in the Timeline view.

Normal View Mode
Normal View

mode is the default Timeline view mode, and will show everything that is connected to the

chosen Display. While in this mode, anything not connected to the currently set Global Display will not be shown
in the Timeline. This also means that you cannot add certain elements to view the Timeline, as by default, they
are added unconnected to any Display. An example of such an element type is a peg.

If you prefer to work as you did before, where you see everything in the Timeline whether it’s
connected to a Display or not, you can change a preference to Always Display Unconnected
Modules. You can find this preference in the Timeline tab—see Scene Setup Preferences on
page 838.
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Selection Only Mode
When working in Selection Only

mode, only elements currently selected in either the Camera or Network

view will be visible in the Timeline. This makes it easier to concentrate on one or a few elements at a time.

View Tagged Modules
The View Tagged Modules

mode lets you see only elements which have been assigned a Tagged status. An

item that has been tagged will appear in the Timeline with a small asterisks beside its name.

Tagging and Untagging Elements
Tagging or untagging elements in the Camera view:
1. Click to select one, or multiple elements in the Camera view.
2. Right-click on your selection and select Tag or Untag.

Tagging or untagging elements in the Network view:
1. Select one or several elements in the Network view.
2. Right-click on the selection and from the Tag menu, choose one of the following:
‣

Tag

‣

Untag

‣

Untag All
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‣

Untag All Others

Tagging or untagging elements in the Timeline view:
1. Click on one or more elements in the Timeline view.
2. Right-click on the selection and from the Tag menu, choose one of the following:
‣

Tag

‣

Untag

‣

Untag All

‣

Untag All Others

Working in View Tagged Modules mode
Once your elements are tagged, and you have switched over to View Tagged Modules mode, the Timeline view
will display only tagged elements. The red bar along the far left of the Timeline indicates you are in this view
mode.

While in View Tagged Modules mode, the asterisks will no longer be displayed beside the tagged elements.

Related Topics
•

Display Concepts on page 825
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Creating a Multiplane

One of the most exciting features in Toon Boom Harmony is the multiplane, or Z-depth. In the multiplane you can
create backgrounds in several layers, spread them on the Z-axis, add depth, and then move the camera through
this environment to create an impressive perspective illusion. You can create backgrounds, use a layered PSD file
or use a project from the sample material package.

Related Topics
•

Top View and Side View below

•

Perspective View on the next page

•

Setting Up the Multiplane on page 834

•

Distributing Elements on the Z-Axis on page 835

•

Positioning Elements in 3D Space on page 859

•

3D Camera Motion on page 867

Top View and Side View
The Top and Side views are used mainly for multiplane scenes and to position elements in 3D Space. They let the
scene’s stage to be seen from the top or the side. This lets the camera cone and the spacing between the
elements to be seen.

Refer to the following sections of the 3D Space on page 847 chapter to learn more about positioning
elements in 3D space and creating 3D Camera moves:
•

Positioning Elements in 3D Space on page 859

•

3D Camera Motion on page 867
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1. The camera cone represents the camera’s field-of-view (FOV).
2. A thumbnail of each drawing layer in your scene. The order of the thumbnail images is based on each
element’s FB position in the scene space. You can see a representation of the FB position of each layer in
the camera cone.

Refer to the Animation Paths on page 937 chapter to learn about keyframes, control points and
animation paths. Refer to the Creating a Multiplane on the previous page topic to learn how to
position your elements in the Top and Side view.

Related Topics
•

Perspective View below

•

Creating a Multiplane on the previous page

Perspective View
The Perspective view is used during scene setup. Its main use is to allow you to see your multiplane scene’s
orientation. The Perspective view is similar to a 3D display, as it lets you rotate your scene through all possible
angles to understand the spacing between the elements. You can also position and rotate your layers and the
camera inside the 3D display to achieve some 3D setup and camera moves.

Refer to the following sections of the 3D Space on page 847 chapter to learn more about positioning
elements in 3D space and creating 3D camera moves:
•

Positioning Elements in 3D Space on page 859

•

3D Camera Motion on page 867
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1. The blue circle represents a rotation of the X and Y axis plane.
2. The red circle represents the rotation of the Y and Z axis plane.
3. The green circle represents the rotation of the X and Z axis plane.
4. This is a perspective grid reference.
5. The axis reference arrows let you maintain your orientation when navigating in the Perspective view.
6. There are three view option buttons displayed in the lower-left corner of the view.
‣

Show/Hide Camera: Shows or hides camera frame in the Perspective view.

‣

Reset View: Resets the Pan, Rotation and Zoom of the Perspective view.

‣

Reset Rotation: Resets the rotation of the Perspective view.

7. This field displays the current zoom level in the Perspective view. You can use the Zoom level drop-down
menu to select a specific zoom level from the list. Zoom levels from 2.5% to 6400% are available, you can
also select Fit To View to automatically use a zoom level that lets you see all of your scene layers and
information in the Perspective view at once.

8. This field displays the currently selected layer and drawing name.
9. This field displays the currently selected tool.
10. This field displays the currently selected frame of your animation.
11. This field displays the current position of your cursor inside the Perspective view.
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To rotate a scene in the Perspective view:
1. In the Tools toolbar, select the Rotate View

tool.

‣

Click in the view, and drag your cursor around to rotate the view.

‣

Press and hold [Alt] + [Shift] and click and drag to rotate the view one axis at a time.

Related Topics
•

Creating a Multiplane on page 831

•

Top View and Side View on page 831

Setting Up the Multiplane
To construct a multiplane, you must imagine what a real environment is like. Take a look at your background
picture and imagine a camera moving across the space. You will notice that objects in the picture would move at
different speeds depending on where they are in relation to the camera lens.
Building a multiplane requires an understanding of the scene's background as well as the positioning of the
elements on different layers.

For example, in this background, the main objects to be separated are:
1. Fern
2. Front tower
3. Second tower
4. Moon
5. Stars
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6. Sky

Although the bottom of the tower is hidden behind the plant and the ladder, each of your multiplane
layers should be a complete drawing. This is because hidden portions may show up during a camera
movement later on in the scene

Related Topics
•

Distributing Elements on the Z-Axis below

Distributing Elements on the Z-Axis
Now is the time to distribute the layers composing your multiplane along the Z-axis, maintaining their distance.
You can position your layers on the Z-axis in the Side and Top view.
Positioning your element toward the camera will make your element bigger. Using the Maintain Size

tool,

you will be able to drag your element toward the camera while keeping the same size aspect in the Camera view.
This tool is available in the Advanced Animation toolbar.

It is a good idea to keep a Camera view opened to see what your scene looks like while positioning
your element in the Top or Side view.

Positioning Elements in the Top and Side Views

To be able to distribute the layers along the Z-axis using the Top and Side views, disable the No Z
Dragging option by selecting Animation > No Z Dragging.
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To position your element in the Top and Side views:
1. In the Advanced Animation toolbar, click the Maintain Size

tool or press [Alt] + [6].

2. In the Side view, select one of the layers in the thumbnails section of the Top or Side view. You can also
select your layer from the Timeline view.
The selected layer will be highlighted in the camera cone.

3. Click and drag the layer to the correct depth position in the camera cone. Your element aspect will remain
the same in the Camera view.

4. In the Tools toolbar, click the Transform

tool, or select the Translate

tool in the Advanced

Animation toolbar and select a layer from the thumbnails section of the Top or Side view. You can also
select your layer from the Timeline view.
‣

If you choose the Transform

tool, make sure that the Peg Selection Mode

the Transform tool's Tool Properties view.
The selected layer will be highlighted in the camera cone.
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5. In the T O P view, drag the element sideways to position horizontally. You can press and hold [Shift] while
dragging the element to make sure it only moves along the X-axis.
6. In the Side view, drag the selected element up or down to position it vertically. You can press and hold
[Shift] while dragging the element to make sure it only moves along the Y-axis.

Related Topics
•

Creating a Multiplane on page 831

•

Top View and Side View on page 831

•

Perspective View on page 832

•

Setting Up the Multiplane on page 834
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Scene Setup Preferences
When setting up your scene in Harmony, some preferences can help you work more efficiently.
•

General Tab Preferences below

•

Camera Tab Preferences on page 840

•

Network Tab Preferences on page 842

•

Timeline Tab Preferences on page 844

•

OpenGL Tab Preferences on page 844

•

Advanced Tab Preferences on page 846

To open the Preferences dialog box:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

Press [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).

General Tab Preferences
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Options

•

Auto Apply: When enabled, values entered or options selected in module editors are automatically applied to
elements in your scene. The Apply and OK buttons are hidden in the Layer Properties when this feature is
enabled.

•

Native Windows Playback: When enabled, the native Windows functions are used for play back in Enable
Cache mode.

•

Editors Always on Top: When enabled, the Layers and Function Editors are on top of the main window.

Settings

•

Minimum FOV: This is the minimum field-of-view value of the camera.

•

Maximum FOV: This is the maximum field-of-view value of the camera.
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Camera Tab Preferences

Tools

•

Show Locked Drawings As Outlines: In the Camera view, locked elements are displayed as outlines only.

•

Nudging Factor: The nudging increment value.

Zoom Settings

•

Camera View Default Zoom: The default zoom value for the Camera view.

•

Top/Side View Default Zoom: The default zoom value for the Top/Side views.
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Settings

•

Thumbnail Size: The thumbnail size, in pixels, that appears in the Top and Side views.

•

Small Bitmap Resolution: The size, in pixels, of the smaller bitmap version of your image. When you
import a bitmap image into a scene, a smaller version of it is created by the system in order to accelerate
the compositing and playback processes.

•

Override Small Bitmap Files: Enable this option if you want the system to generate new versions of the
already existing smaller bitmap files, every time you modify the Small Bitmap Resolution value. When the
option is disabled, the already existing smaller bitmap versions will not be regenerated and will keep the
same resolution as when they were created.

•

TV Safety: The ratio value for the TV Safety frame in proportion to the regular camera frame.

Wash Background

•

Enable in Camera: Dulls background bitmaps in Camera view. This allows you to see other elements
clearly, such as the ones that have not yet been painted.

•

Enable in Camera Drawing Mode: Dulls background bitmaps in Camera view while using drawing tools.
This allows you to see other elements clearly, such as the ones that have not yet been painted.

•

Wash Background Percentage: The Wash Percentage value.

Preview Wash

•

Enable For Out of Date Previews: When you disable the automatic render preview, you need to click on
the Update Preview button in either the Rendering toolbar or the Camera view bottom toolbar in order
to recalculate and update the preview. When this option is enabled, if ever the current render preview is
out of date and requires you to press the Update Preview button, the Camera view will display the
current preview as washed out colours.

•

Wash Background Percentage: This is the value in percentage by which the outdated preview will be
washed out.
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Network Tab Preferences

Parameter

Description

Navigator
Show Navigator

Show or hide the display of the Navigator in the Network view when starting
Toon Boom Harmony.

Navigator Starting Corner

Indicates which corner is the default Navigator’s position.

Magnifier
Width Multiple

Sets the width of the magnifier in tenths of the Network view width. Values
range from 0.1 to 10.

Aspect Ratio

Sets the width to height ratio of the magnifer. Values range from 0.1 to 10.

Opacity

Sets the transparency of the magnifier. Values range from 0 to 100. A value of
100 make the magnifer completely transparent. A value of 0 makes the magnifier completely opaque.

Options
Cable Type

Displays Network connections as Line (straight) or Bezier (curves).

Middle mouse button pans
the view

Lets you use the middle mouse button to pan the Network view.

Double-click on a module
opens the editor

Lets you open a module's property editor by double-clicking.

Port Output Ordering

Orders the Output Port Right to Left or Left to Right.

Port Input Ordering

Orders the Input Port Right to Left or Left to Right.

Element Mode Drawing Options
Antialiasing Quality

Smoothness setting applied to colour art. The higher the setting, the greater
the amount of antialiasing that is applied. Higher quality images require more
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time to render and more system memory. Choose a lower quality if you are
rendering a Pencil Test.
Low: No antialiasing
Medium Low: Some antialiasing
Medium: Medium antialiasing
High: Extensive antialiasing

Antialiasing Exponent

Controls the amount of area around the Line and Colour Art edges that is used
in the antialiasing process. A higher value uses less area, resulting in sharper
edges, while a lower value uses more area, resulting in softer edges. If the
Antialiasing Quality value is set to Low (no antialiasing), this value is ignored.

If the image to render out is larger than the value entered in the box, the system will create an external render for that special image. It will open a second
Enable External Read If Image
copy of Toon Boom Harmony in the background (not visible to the user), cut
Is Bigger Than
and set the image to the scene format and finally send it back to the original
scene.

Read Colour

Controls the production of colour information from bitmap images. If this module reads 3 or 4-channel bitmaps, this selection determines whether the colour
should be read or ignored. If this module reads 1-channel bitmaps, this selection determines whether the channel should be read as colour. When this
option is selected with 1-channel images, the result will be a greyscale image.

Alignment Rule

The Alignment position for the element module. The new element module will
be created following this default rule of alignment.

Read Transparency

Controls the production of alpha information from bitmap images. If this
module reads a 1 or 3-channel image, this option will create a matte from the
colour values in the image. If the module reads a 4-channel image and this
option is not selected, the alpha information in the image will be ignored.
Premultiplied with Black: Pixels at the edge of an image are blended with
black.
Premultiplied with White: Pixels at the edge of an image are blended with
white.

Transparency Type

Straight: Pixels at the edge of an image are blended with black, white and
greys.
Clamp Colour to Alpha: Select this option when you want to premultiply the
colour value with the alpha value. When the colour is clamped to the alpha, the
colour value cannot be higher than the alpha value. It calculates the real colour
value faster. When the RGB values are multiplied with the alpha value, that is to
say, if you have a pixel of value R=247, G=188, B=29 and the alpha is 50% or
the image has a 50% transparency, then the actual RGB values output would be
half of the amounts listed above
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Timeline Tab Preferences

Defaults
•

Always Display Unconnected Modules: Enable this preference if you prefer to see elements in the
Timeline that have not yet been connected to a particular Display, even when in Normal View mode. This
preference is not on by default.

OpenGL Tab Preferences
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Settings

•

Conservative Texture Management: Turns on and off conservative memory management for bitmap
texture files. Performance will improve when this is enabled. If disabled, you will have a better on-screen
rendering of bitmap files at the expense of slower performance.

•

Smooth Textures: Smooths out the pixels of bitmap images when zooming in; this improves bitmap
image quality.

•

Alternate Gradient and Cutter: This is an alternative way to disable write in the OpenGL Backbuffer,
required for some video cards (i.e. GeForce FX5200). Do not enable this option unless you are
experiencing problems with gradients and cutters in OpenGL.

•

Use PBuffer for Picking: This will use an off-screen buffer for picking, resulting in a quicker response. This
option should not be enabled if using a small capacity video card (32MB).

•

Support Triple Buffer: Enable this option for a better compatibility with Windows Vista if your video card
driver does not allow to disable the triple buffering option. Not enabling this option may result in a
dashing line when drawing a brush stroke.

•

Support Desktop Effects: Enable this option for better compatibility with Windows 7, Windows Vista
and Mac OS X desktop effects. This will prevent graphic compositing problems from happening when the
full-scene anti-aliasing option is enabled.

•

Maximum Texture Size: The size that the bitmap file will be reduced to when using the Conservative
Texture Management

•

Texture Memory: The amount of temporary memory used to store bitmap texture files.

•

Vector Drawing Maximum Texture Size: This is the size that the .tvg file will be reduced to for better
performance when in OpenGL render mode.

Drawings

•

Support Transparency in Pencil Lines: When the option is enabled, the pencil lines are displayed
normally. The lines will be opaque (unless there are transparencies). Disabling this option will reduce
rendering times, but will display additive opacities for overlapping pencil lines and unevenly filled curved
pencil lines.

•

Enable Variable Line Thickness: Turns on and off the rendering of the variable line thickness option of
the Element Module.
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Advanced Tab Preferences

Advanced Options
•

Advanced Display: Enable or disable the Advanced Display mode—see Display Concepts on page 825
topic to learn more about the functionality of Advanced Display.

•

Restore Current Selected Drawing On Undo: If a drawing other than the current one is being affected
by an Undo command, the system will display the affected drawing when this is enabled.
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Chapter 13: 3D Space

Toon Boom is well known for its multiplane space where you can move your layers forward and backward on the
Z-axis. Harmony now brings you a true three-dimensional space where you can actually rotate your camera and
layers on all axes. This permits you to perform a 360 degree rotation around your elements, create a floor and
even build sets!

If you use 3D effects in your animation, it NOT recommended to render your project as an SWF as
these effects are not supported by that format.

Related Topics
•

Enabling the 3D Option on the next page

•

3D Tools on page 854

•

Positioning Elements in 3D Space on page 859

•

3D Camera Motion on page 867
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Enabling the 3D Option

Enabling the 3D Option

To rotate layers in three axes instead of two, you must enable the 3D option in the layer properties. By default,
when you create layers in Harmony, you can only move them as flat layers.
To enable the 3D option:
1. In the Timeline view, select the layer you want to move in the 3D space.

2. Click on the selected layer once to display its properties in the Layer Properties view or double-click on it
to open properties in a dialog box.
3. In the Layer Properties dialog box, select the Transformation tab.

4. Select the Enable 3D option to display the 3D parameters for that layer.
5. Click Close.
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New parameters appear in the Layer Properties window.

Related Topics
•

3D Parameters below

3D Parameters
When working in 3D, notice that three sets of parameters are modified:
•

Scale below

•

Rotation on page 851

•

Pivot on page 852

Scale

When using 3D, the Z-axis parameter appears in the list of settings. You can have the Scale locked or separated.
When the Scale is locked, the object you are scaling is uniformly resized in three directions. When the Scale is
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Enabling the 3D Option

separated, the object you are scaling can be squashed and stretched in any direction without affecting the other
ones.

You cannot add thickness to an object by scaling it in the third dimension. Three-dimensional scaling
is used to scale objects that were rotated on their axes or to scale a group of objects laid out in threedimensions.
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Rotation

The main parameter you will use when working in three-dimensions is rotation. Without using the 3D rotation,
you are simply working using the multiplane technique.
3D rotation can be used in two different ways:
•

Quaternion Rotation below

•

Euler Angles Rotation below

Quaternion Rotation

Quaternion Rotation is very similar to the 3D path position parameters. A Quaternion is composed of three
rotation functions: X, Y and Z to control the rotation on three axes, and a velocity function to control the velocity
of the three rotation functions simultaneously.
The X, Y and Z functions are linked together, when you add a keyframe on one of them, it also adds it on the two
others.
If you are planning to animate an element such as the camera, you should use the Quaternion rather than the
Euler Angles. Quaternion creates smooth trajectory and interpolation since the path is controlled by the same
keyframes and a single velocity.

Euler Angles Rotation
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The Euler Angles Rotation is very similar to the Separate position parameters. The Euler Angles parameter is
composed of three functions: X, Y and Z to control the rotation on three axes. These three functions are
independent from one another, each having its own velocity.
When you add a keyframe on one function, the other ones do not receive it, allowing you to control each axis
independently.
Euler Angles are mainly used to position elements with exact coordinates and rotating elements on a single axis.
The interpolation between the keyframes will not be as smooth as the Quaternion one since each function works
individually.

Pivot

When working in 3D, the drawing or layer pivot becomes a location that can move on three axes. When you
work in two-dimensions, the pivot is mainly an anchor point somewhere in the drawing from where the
transformations will be performed. In 3D, the transformations are made on three axes, so the centre of rotation
and scaling also becomes three-dimensional.

By default, the pivot is positioned at the centre of the stage: (0,0,0). When you use the Pivot

tool to

reposition the centre of transformation, the pivot position is changed on the X and Y axes, but the Z-axis
remains at zero until you change it in the Top, Side or Perspective view using the transformation tools.

Related Topics
•

Function Curves on page 992

•

Layer Parameters on page 948
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•

Function View on page 984

•

Function Drop-down Menu on page 997
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3D Tools

3D Tools

Once the 3D option is enabled, your transformation tools become 3D transformation tools. These tools are
found in the Advanced Animation toolbars as well as the Transform
tool. Instead of letting you move
elements only on the X and Y axes, you can also manipulate them on the Z-axis.

Related Topics
•

3D Translate Tool below

•

3D Rotate Tool on page 856

•

3D Scale Tool on page 856

•

3D Transform Tool on page 857

•

Positioning the Scene Components on page 768

3D Translate Tool
Once you enable the 3D option, the 3D Translate

tool becomes available and you will see direction arrows

appear around the pivot points to indicate the different axes.
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You can click on the direction arrows to move your layer on only one axis. If you click anywhere else, the layer can
move freely on two axes at once. Once the arrow is selected, it will turn pink.

If you move the layers in the Perspective view, it may be difficult to control the motion since you may
not have the optimum point of view on your stage to understand the setup. In this case it is best to
use the direction arrows.

Related Topics
•

3D Rotate Tool on the next page

•

3D Scale Tool on the next page

•

3D Transform Tool on page 857
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3D Tools

3D Rotate Tool
Once you enable the 3D option, the 3D Rotate

tool becomes available and you will see a rotation sphere

appear around the pivot points indicating the different axes.

You can click on the direction ellipses to rotate your layer on one axis only. If you click anywhere else, the layer
rotates freely on two axes at once. Once the ellipse is selected, it will turn pink.

If you move the layers in the Perspective view, it may be difficult to control the motion since you may
not have the optimum point of view on your stage to understand the setup. In this case it is best to
use the direction ellipses.

Related Topics
•

3D Translate Tool on page 854

•

3D Scale Tool below

•

3D Transform Tool on the facing page

3D Scale Tool
Once you enable the 3D option, the 3D Scale

tool is available. You will see one of two things:

•

A scaling rectangle that appears if your drawing is flat.

•

A scaling cube that appears if your object has some rotated layers around the pivot points, indicating the
different axes.
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Click on one of the three control points to scale the shape on one axis. Hold down the [Shift] key to scale the
object proportionally. Once the control point is selected, it will turn pink.

If you move the layers in the Perspective view, it may be difficult to control the motion since you may
not have the optimum point of view on your stage to understand the setup.

Related Topics
•

3D Translate Tool on page 854

•

3D Rotate Tool on the previous page

•

3D Transform Tool below

3D Transform Tool

Once you enable the 3D option, the 3D Transform tool become available. This tool is a combination of the 3D
Translate, 3D Rotate and 3D Scale tools.
To translate an element, grab the direction arrows in the same way that you would with the Translate tool.
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3D Tools

To rotate an element, grab the rotation ellipses in the same way that you would with the Rotate tool.

To scale an element, grab the scaling control points in the same way that you would with the Scale tool.

Related Topics
•

3D Translate Tool on page 854

•

3D Rotate Tool on page 856

•

3D Scale Tool on page 856
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Positioning Elements in 3D Space

To position elements in 3D space, you need to understand what you want to build and what is involved in
building it.
Simple sets like the above one are easy to build, light to manage and probably what you will use 3D staging for
most often.
If you have a project based in a room, it can be useful to build it in 3D. This saves you having to redraw the
background for each scene and it will be entirely vector based.

Here, you can see some of the different backgrounds you can get in only three seconds from this set.
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Related Topics
•

Planning Your Pieces below

•

Using Complex Sets in Production Scenes on page 862

•

Positioning the Layers on page 863

Planning Your Pieces
When you are building a room, there are only a few pieces to prepare. Before starting to build your set, map out
the parts you need.

A complex set, that is more intricate in its design, will require more careful planning. Not only will you have to list
the pieces you'll need, but you will also have to think about what can be reused. If you have a series of windows in
your set, you would create a symbol out of the drawing, rather than copy paste it several times all over your set.
This way, if you need to make any correction to its design, you will only need to do it once and all the instances of
your symbol throughout your set will be corrected. The same can be done with for each pieces of your set.
Here is an example of all the source drawings required to build the castle.
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Those are the only drawings required to build the entire castle. As you can see there are not that many
considering the final result. The rest is constructed by assembling symbols and through reuse. However, keep in
mind that although you are using simple drawings and symbols to optimize your set, the more your add to your
project, the heavier the toll it takes on your machine's RAM. While the scene's package itself is really light,
running the scene places heavy demands on your RAM and video card.
Using the drawings shown previously, here are a couple of pieces that were put together.

Here is the final result, a large and impressive fortress.
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Map out the parts you need before you start to build the set
For a complex set, you need to plan more and, as it is a much more intricate design, it will require careful
thought. You not only have to list the pieces you need, but you also need to think of what can be reused. If you
have a series of windows, you do not want to copy/paste the drawing all over. Instead, you should create a
Symbol out of it. This way, if you need to make a correction to the design, you only need to do it once and it will
be corrected throughout. You can do the same for every piece of your set.

Related Topics
•

Using Complex Sets in Production Scenes below

•

Positioning the Layers on the facing page

•

Creating a Symbol on page 637

•

Importing a Symbol on page 652

Using Complex Sets in Production Scenes
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When your main set is built, you will want to store it in the Library. It is important to know that when you import
such a large structure in one of your production scenes, the set may be slow to run. To avoid long rendering
sessions or slow manipulation, remove all faces and planes that are not visible in your scene.

Related Topics
•

Planning Your Pieces on page 860

•

Positioning the Layers below

Positioning the Layers
Once you have your drawings and symbols assembled, it is time to position them. This section explains how this
is done using the simple room shown previously.
To position your layers, you require the following elements:
•

Camera View

•

Top View

•

Side View

•

Perspective View

•

Library View

•

Timeline View

•

3D Transformation Tools

•

Layer Properties View or dialog box

To position layers in the 3D space:
1. In the Timeline view, double-click on the new layer to open the Layer Properties dialog box.
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2. In the Transformation tab, check the Enable 3D option.

3. In the Rotation section, enable the Euler Angle option.

4. Type 90 in the Rotation's (x) Axis field to flip the floor so that it is flat on the ground.

5. To position the height of the floor, type values in the Position section of the Layer Properties, use the 3D
Translate
tool or 3D Transform
tool.
6. Repeat the process for the other pieces to import.
7. If you have parallel walls, once you have positioned one, select the Wall layer in the Timeline view.
8. In the top menu, select Edit > Duplicate to duplicate the layer.

If the drawing is contained inside a symbol, the symbol will not be duplicated, only the layer
containing the symbol. This way you are still using the same drawing.
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9. Once the layer is duplicated, use either the Layer Properties window to type the positioning values, or use
the 3D transformation tools.
10.When you are using the transformation tools, use the Camera, Top or Side view to position the elements
instead of the Perspective view to position your layers precisely.

11. If your walls are touching each others, you should have them intersect by extending one end of the wall
through the other wall. This prevents seeing a small gap in-between them.

There you go, you now have a complete 3D room.
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Related Topics
•

3D Tools on page 854

•

Top View and Side View on page 831

•

Perspective View on page 832
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3D Camera Motion
Once you have a 3D set, the exciting part is to do a camera motion in it. This section teaches you the main steps
required to perform a 3D camera motion. Once you know how to do this you can enjoy the delights of working in
3D space and travelling through your creations!
To create a 3D camera motion:
1. In the Tool toolbar, enable the Animate
2. In the Timeline view, click on the Add Layers

mode.
button and select Camera to add a camera to your

scene.

3. In the Timeline view, select the new camera layer.
4. In the Timeline Layer toolbar, click on the Add Peg

button to add a parent peg to the camera.

5. In the Timeline view, double-click on the new peg layer to open the Layer Properties dialog box.

6. In the Layer Properties dialog box, go to the Transformation tab and check off the Enable 3D option.

7. In the Rotation section, enable the Quaternion option.
8. In the Perspective view, click on the Show/Hide Camera button to see your camera cone.
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3D Camera Motion

9. Setup your workspace to display the Camera view and Perspective view at the same time so you can
compare the results.

10. In the Tools toolbar, select the Transform

tool.

11.In the Timeline view, select the Camera-Peg layer first frame and select Insert > Keyframe.

12.In the Timeline view, select the Camera-Peg layer.

13.In the Timeline view, go to the last frame.
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14.In the Perspective view, grab one of the rotation ellipses and rotate the camera on one axis only. Always
do one axis at a time, this keeps control of the positioning.

15.Once the camera is rotated in the correct angle, grab one of the direction arrows to move the camera to
the correct position.

Playing Back Your 3D Camera Moves
In order to see a playback of your 3D camera moves, you must be in the Perspective view.
To enable the playback mode in 3D:
1. In the top menu, select Play > Enable Playback > Perspective View.
2. In the Playback toolbar, press the Play button to see the results.

Related Topics
•

Locking Flat Drawings to the Camera Angle on the next page

•

Animating the Camera on page 960
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Playing Back Your 3D Camera Moves

Locking Flat Drawings to the Camera Angle

When you create a 3D camera motion in your scene, you will notice that layers are treated as flat objects,
animation layers that are supposed to face the camera at all times will look like a flat sheet of rotating paper.
Use the Ortholock layer when mixing flat animation layers with a set built in 3D. Ortholock forces your drawing
layer to always follow the Camera angle. It does not follow its position or zooming level, only the rotation. This
prevents drawings from being distorted by the camera motion.

Adding an Ortholock layer in a symbol will not give the correct result. The Ortholock contained
inside a symbol does not consider the position of the camera contained in the root scene. Keep your
Ortholock layers in the root scene.

To add an Ortholock layer:
1. In the Module Library view, go to the Move tab.
2. Select an Ortholock module and drag it to the Network view.
3. In the Network view, drag an output cable from the Ortholock module and connect it to the module you
want to keep facing the camera.

Related Topics
•

3D Camera Motion on page 867
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Managing a Network with a 3D Scene Setup
In Harmony, you can create very advanced networks using effects, complex connections and multiple-level
compositing.
The Composite module's main task takes all of your image's output and converts it into a single flat image that
you can render out. You can alter it further by manipulating a three dimensional scene setup. You can also modify
a Composite's behavior as seen in the Scene Setup on page 761 chapter.

Input and Output Options

The default options combination is:
•

As Bitmap, for the output behaviour

•

3D flat, for the input ordering

By default, a Composite module is set to output a flat bitmap image and to correctly composite elements
positioned in 3D space.
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For example, if you have two intersecting walls, and use the default combination, you will see the following
result:

This image is correctly represented in the Camera view and is output from the Composite module as a flat
drawing. The Z-axis value of your elements are not retained, it becomes an independent composition with only
one forward-backward value.

When building a 3D set out of planes, it is recommended that you set the composite mode to As
Seamless Bitmap. This avoids intersection issues when rendering the 3D objects created out of
planes.

3D Input Ordering Option
The visual result for the 3D Input Ordering option is the same as the 3D Flat option. The visual result in the
Camera view will be correct, but the elements will not be converted into a flat image. The 3D position of your
images will be remembered until the next Composite module. This mode is quite advanced and should only be
used in very advanced cases. Most of the time you will use the 3D Flat Input ordering option.

2D Input Ordering Option
If you switch the Input Ordering option to 2D, the walls will be calculated as flat 2D objects and not as 3D
objects. The perspective caused by the 3D rotation will be correctly represented, but the elements will not
intersect. The result will be similar to the following:
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Related Topics
•

How to Organize your 3D Composite Modules below

•

Composite Layer Properties on page 811

How to Organize your 3D Composite Modules
If you start combining several composite modules in your Network view, you must understand the way they work
if you want to get the desired result.
There is a specific order in which you should set your Composite modules.
It is important to understand that each time you process images through a 3D Flat Composite module, the
images will be merged together. Images processed in later Composite modules cannot be inserted between
images of the previous composite since it is a flat image.

If you place Pass-Through type Composite modules in your network, the images will not be processed together
before the final Composite. It is important to keep your final Composite as a 3D Flat Composite in order to read
the layer ordering correctly.
The most efficient networking system to use to obtain the desired result is likely the Pass-Through composite
mode throughout the whole network. This way, you can create individual compositions to keep your network
clean and organized, but process everything together at the end.
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Input and Output Options

When building a 3D set out of planes, it is recommended that you set the composite mode to As
Seamless Bitmap. This avoids intersection issues when rendering the 3D objects created out of
planes.
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Toon Boom Harmony provides you with impressive 2D-3D integration possibilities. This allows you to combine
the two animation genres within the same production resulting in some remarkable scene composition and a
unique style.
Harmony supports the following 3D formats:
•

3DS

•

OBJ

•

FBX

•

OSB

You can work with Autodesk Maya, PIXIE, or 3Dlight. For this guide, Autodesk Maya will be used. To work with
PIXIE or 3Dlight, contact support@toonboom.com.

All Harmony licenses include the 3D functionality by default. If you got your license at the initial
release of Harmony, you might not have the 3D license. If you are unable to work with 3D elements,
contact support@toonboom.com.

Related Topics
•

How 2D-3D Integration Works on page 877

•

Exporting a 3D Object for Harmony Using Autodesk Maya on page 879

•

Importing a 3D Object from Autodesk Maya to Harmony on page 882

•

Working in the Different Views on page 884

•

Manipulating the 3D Object on page 887

•

Rendering and Compositing 3D Models on page 895
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•

Rendering 3D Models on page 900
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How 2D-3D Integration Works
Harmony allows you to import 3D models and reposition them in Harmony and animate them over time.
•

Importing a Reference Model below

•

Rendering on the next page

Importing a Reference Model
When working in Harmony, the first thing to do is import a reference model. This model is what will be
represented in the OpenGL view. Animators can reposition this model, animate the camera, and interact with it.
Although several formats are supported, FBX is the recommended format as this will allow you to embed
textures for nicer looking reference models.
The following chapters show you how to import such a model and animate it in Harmony.
When importing an FBX model, remember that model will never be used for the final render. Harmonyitself does
not have a 3D rendering engine embedded.
Rendering of the OpenGL representation of the model is supported. However, this is not a high enough quality
for a final product. Instead, rendering is supported through outside rendering engines. The majority of users use
Maya Softrender, although 3Delight and Pixie are also supported.

Because this model is never used for a final render, you can optimize this model quite a bit. The imported FBX
model does not have to have high-res textures on it or sophisticated shaders. It can even have a lower poly count
than your final model. It does, however, need to be the same size as your final model, as Harmony will be sending
the position, rotation, and scale information of the model in the Harmony scene to Maya later to render.
Keeping the imported FBX file as light as possible will give you snappy performance while animating.

877

Chapter 14: 2D-3D Integration

How 2D-3D Integration Works

Rendering
When it comes to rendering, what happens at that stage is that a pipe is opened up between Harmony and the
rendering engine, in this case Maya Softrender.
Maya Batch is opened in the background, and the information from the Harmony scene file is sent to Maya. All
the information needed, including the animation on the model and the position of the camera, is all sent to Maya.
Maya Batch then opens up in the background, and the original .mb file is opened. This file should match the FBX
model in size, but may have a higher polygon count, a more advanced texturing setup, or even a more advanced
set of shaders. Since the full Maya scene is loaded, you can use any shader, lighting setup, and texture that Maya
Softrender supports.

The opened scene file repositions the model inside based on the information provided from the Harmony scene
file. For consistent lighting effects, you may want to parent the lighting rig to the model so it is also repositioned
along with the model.
The frame is then rendered and sent back to Harmony to be composited there. The data comes back into
Harmonyas a series of Maya .iff images. These images contain not just image data, but also depth information,
and Harmonywill use this depth information to properly clip any 2D layers that are interacting with the 3D model
in the Harmonyscene, resulting in a perfect composite without the need to track any masks.
You can also apply any effects that are supported on bitmaps to the rendered sequence, such as blurs, blending
modes.
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Exporting a 3D Object for Harmony Using
Autodesk Maya
Once you set up Toon Boom Harmony and your system for the use of 3D, the next step would be to generate
the 3D models you plan to import and use in your scene. You will need to use Autodesk Maya for this. Although
FBX models can be exported from any software and imported into Harmony, at the moment, only Maya is
supported for full rendering with effects.
To export a 3D object for Harmony:
1. In Autodesk Maya, create your 3D object.

You should also complete the texturing of your 3D object, as well as set up a few lights in your scene.
When you render your scene later through Harmony, it will use this original Maya scene to render with the
shaders, textures, and lighting of the scene.

When you animate the object in Harmony, it will use this scene file and push the animation from
Harmony into this scene. For this reason, you may want to parent the lights to the object, so the
lighting you set up moves with the object when it is animated. If not, you may end up with a situation
where the object is rotated out of the lighting, and you can see a very dark 3D object. In Maya, you
can parent one layer to another by middle-mouse clicking and dragging that layer.

2. Save your Maya binary file *.mb as you will use it later on.
3. Use the export command to export your model. Select File > Export All.
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Exporting a 3D Object for Harmony Using Autodesk Maya

The Export All dialog box opens.
4. In the Files of Type drop-down menu, select FBX Export.
5. Select the Embed Media option to see the textures on the model when you import the FBX model into
Harmony.
6. From the Type list, select Binary.
7. From the Version list, select FBX 2012.
8. When you complete the export, an*.fbx file will be created.
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Instructions may differ depending on the version of Autodesk Maya you are using. It is therefore
important that you refer to their documentation for the correct instructions on how to create and
export a 3D model.

Related Topics
•

Importing a 3D Object from Autodesk Maya to Harmony on the next page
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Importing a 3D Object from Autodesk Maya to Harmony

Importing a 3D Object from Autodesk Maya
to Harmony
Once you have exported a model in using Autodesk Maya, you can import it into Harmony and integrate it to
your 2D animation scene.
To import 3D model(s) from Autodesk Maya to Harmony:
1. In Harmony, select File > Import > 3D Models.
The Import 3D Models dialog box opens.

2. Click Browse and locate your *.fbx files.
3. Click Open to validate your choice and close the browsing window.
4. In the Import 3D Models dialog box, choose your import options.

‣

Create Layer(s): This option is selected by default, meaning that a new layer will be created for the
selected files for the import. You have two choices.

‣

Create Single Layer Named: Imports all your selected *.fbx files in the same layer. You can use the
active text field to name the layer.

‣

Create Layer(s) Based on Filename: Creates a different layer for each file selected for the import.
The layers will be automatically named in accordance with the file names.

‣

Add to Existing Layer: Imports the selected files into an existing layer in the scene. Use the dropdown menu to select a layer.

If you choose to add to an existing layer which is a vector layer, then it will encapsulate the 3D model
inside a symbol.

5. Click OK to validate your choices and import the selected file(s).
The 3D models are imported in the scene.
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Note that, if at this point, the Preview mode is set to Render View

mode, then the 3D model

will not be visible in the Camera view. If this is the case, click on the OpenGL View

button, you

should now be able to see your 3D models.

Using Peg Modules to Control the Position of 3D
Objects
You can use Peg modules to control the position of 3D objects, and connect them as you would with 2D layers to
create rigs.

Related Topics
•

Exporting a 3D Object for Harmony Using Autodesk Maya on page 879

•

Rendering and Compositing 3D Models on page 895
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Working in the Different Views
To be able to properly view and setup the 3D element in your scene, you will need to use the Perspective view
and Camera view together, as well as the Top and Side views.
•

Perspective View below

•

Camera View below

•

Top and Side Views on the facing page

Perspective View
In the Perspective view, you can see your scene in a complete 3D environment. This environment will allow you to
setup and animate your 3D model more easily. You can rotate the view on the three axes.
To rotate the Perspective view, hold down [Ctrl] + [Alt] (Windows/Linux) or [⌘ ] + [Alt] (Mac OS X), and click and
drag.

Camera View
You can preview the position of your 3D model in the Camera view and see what it will look like in the camera
frame. You can preview your scene in OpenGL
mode.
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To be able to view your 3D elements in Render

mode , you will first need to add a script module to your

Network view and setup your system with the correct path to the rendering utility you will be using. If you do not
complete this setup, the 3D model will simply not appear.

Top and Side Views
You can use the Top and Side views to help you position your element in the 3D environment. This can really help
you precisely visualize the actual position of your model without perspective.
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Top and Side Views

Related Topics
•

Rendering and Compositing 3D Models on page 895

•

3D Space on page 847
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Manipulating the 3D Object
Once you have imported the 3D model into your scene, you can easily manipulate it to setup your scene. You can
even add keyframes, just like any other elements and animate it on a trajectory.

Related Topics
•

Using Transformation Tools to Manipulate the 3D Models on the next page

•

Translate Tool on the next page

•

Rotate Tool on page 889

•

Scale Tool on page 890

•

Transform Tool on page 892

•

Scene Setup on page 761

•

3D Space on page 847

•

Animation Paths on page 937

Enabling the 3D Option
To rotate the 3D model in three axes instead of two, you must enable the 3D option in the layer properties. By
default, the new layers in Harmony display only the 2D options, allowing you to only move them as flat layers.
To enable the 3D option:
1. In the Timeline view, select the layer you want to move in the 3D space.

2. Click on the selected layer once to display its properties in the Layer Properties view or double-click on it
to open properties in a dialog box.
3. In the Layer Properties dialog box, select the Transformation tab.

4. Select the Enable 3D option to display the 3D parameters for that layer.
5. Click Close.
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Manipulating the 3D Object

Related Topics
•

3D Parameters on page 849

•

Using Transformation Tools to Manipulate the 3D Models below

Using Transformation Tools to Manipulate the 3D
Models
Once the 3D Option is enabled, your transformation tools automatically become 3D transformation tools, this
means that you can now manipulate them on the Z-axis as well. The Translate
, Rotate
and Scale
tools are found in the Advanced Animation toolbars and the Transform

tool can be found in the Tools

toolbar. You can use these tools to set up or animate your 3D model. Note that if you want to set up the
position of your 3D model, you must disable the Animate
mode. Do not forget to re-enable it when if you
want to animate it.

Related Topics
•

Translate Tool below

•

Rotate Tool on the facing page

•

Scale Tool on page 890

•

Transform Tool on page 892

•

Positioning the Scene Components on page 768

Translate Tool
Once you enable the3D Option, the3D Translate tool becomes available. Direction arrows will appear around
the pivot points to indicate the different axes.
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If you click on a direction arrows you can move your layer on only one axis. If you click anywhere else, the layer can
move freely on two axes at once. Once the arrow is selected, it will turn pink.

If you move the layers in the Perspective view, it may be difficult to control the motion, since you
may not have the optimum point of view on your stage to understand the setup. In this case it is best
to use the direction arrows to move the layers.

Related Topics
•

Rotate Tool below

•

Scale Tool on the next page

•

Transform Tool on page 892

•

Positioning the Scene Components on page 768

Rotate Tool
Once you enable the 3D Option, the 3D Rotate tool becomes available. A rotation sphere appear will around
the pivot points to indicate the different axes.
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Manipulating the 3D Object

You can click on the direction ellipses to rotate your layer on one axis only. If you click anywhere else, the layer
rotates freely on two axes at once. Once the ellipse is selected, it will turn pink.

If you move the layers in the Perspective view, it may be difficult to control the motion since you may
not have the optimum point of view on your stage to understand the setup. In this case it is best to
use the direction ellipses.

Related Topics
•

Translate Tool on page 888

•

Scale Tool below

•

Transform Tool on page 892

•

Positioning the Scene Components on page 768

Scale Tool
Once you enable the 3D Option, the 3D Scale tool is available. You will see one of two things:
•

A Scaling Rectangle, this appears if your drawing is flat.

•

A Scaling Cube, this appears if your object has some rotated layers around the pivot points, indicating the
different axes. If you click and drag on this Scaling Cube, it will scale proportionally on all axes.
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Click on one of the three control points to scale the shape on one axis. Hold down the [Shift] key to scale the
object proportionally. Once the control point is selected, it will turn pink.

If you move the layers in the Perspective view, it may be difficult to control the motion since you
may not have the optimum point of view on your stage to understand the setup.

Related Topics
•

Translate Tool on page 888

•

Rotate Tool on page 889

•

Transform Tool on the next page

•

Positioning the Scene Components on page 768
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Transform Tool

Once you enable the 3D Option, the3D Transform tool become available. This tool is a combination of the 3D
Translate, 3D Rotate and 3D Scale tools.
•

Translating an Element with the Transform Tool below

•

Rotating an Element with the Transform Tool on the facing page

•

Scaling an Element with the Transform Tool on the facing page

Translating an Element with the Transform Tool
To translate an element, grab the direction arrows in the same way that you would with the Translate
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Rotating an Element with the Transform Tool
To rotate an element, grab the rotation ellipses in the same way that you would with the Rotate

tool.

Scaling an Element with the Transform Tool
To scale an element, grab the scaling control points in the same way that you would with the Scale
If you click and drag on this scaling cube, it will scale proportionally on all axes.
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You can also set up all these position parameters using the Layer Properties dialog box. Refer to 3D
Parameters on page 849 to learn more about these 3D parameters.

Related Topics
•

Translate Tool on page 888

•

Rotate Tool on page 889

•

Scale Tool on page 890

•

Positioning the Scene Components on page 768
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Rendering and Compositing 3D Models
There are two ways to preview and render your 3D elements in Toon Boom Harmony. You can render your scene
using the OpenGL preview, or render calling Autodesk Maya, PIXIE or 3Delight in the background.
If you do not set up a plug-in to preview your model with Maya, or your 3D software, the preview and rendering
will be done using the OpenGL preview. The result will look flat and jagged, but it can be very handy while
working and exporting shots for approval.
If you render your scene calling Autodesk Maya, PIXIE or 3Delight, you will obtain a smooth result, replete with
texture and lighting.
To be able to render the 3D objects you imported in Harmony through Autodesk Maya soft render, you will need
to prepare your system by setting some environment variables, and adjusting your Network view in Harmony.

This section is very technical; if you need help, or experience problems while setting up the 3D
rendering, please contact the Toon Boom Support team at support@toonboom.com.

Related Topics
•

Preparing the Project Directory below

•

Setting the Path on Windows on the next page

Preparing the Project Directory
To set up rendering:
1. Copy your original Maya binary file *.mb into your Harmony project directory at the same location as the
*.fbx file you have imported. This *.fbx file should be in the elements folder, inside a subfolder named
like the element. For example: if the element is called PirateShip then the subfolder should be named
PirateShip.

You saved the Maya *.mb file in Exporting a 3D Object for Harmony Using Autodesk Maya on
page 879 of this document.

2. Rename the *.mb file so it has the same name as the *.osb file.
For example: if the *.fbx is called PirateShip-1.fbx, the name the *.mb as PirateShip-1.mb.
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3. Copy any textures used in the Maya project into this same folder.

Related Topics
•

Setting the Path on Windows below

•

Setting Up the Network View on page 899

Setting the Path on Windows
The Path needs to be set up so that when Harmony launches Maya, it knows where exactly to look for the
application. On Windows, this can be set up using an Environment Variable.
To set up the environment variable on Windows:
1. In Windows, go to Start.
2. Right-click on Computer and select Properties.
3. From the Computer Properties dialog box, select Advanced System Settings.

The System Properties dialog box opens.

896

Toon Boom Harmony 10.3 Stage User Guide

4. In the System Properties dialog box, click Environment Variables.
The Environment Variables dialog box opens.
5. The first variable to set up is the Maya path. Browse down in the System Variables section until you find
the variable called Path and select it.

6. Click Edit.
The Edit System Variable dialog box opens.
7. In the Variable value field, add a semicolon ";" at the end of the last path.
8. Copy the path to the bin folder of Maya following the semicolon.
For example: For Autodesk Maya 2011 on Windows, the path would be as follows:
C:\Program Files\Autodesk\Maya2011\bin

You can browse to the installation folder of Maya and copy the complete path to thebin folder from
the explorer browsing window to make sure you have the exact path.

9. Click OK.
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If you receive an error readout in the command line when you try to render, contact Support at
support@toonboom.com and provide the error readout content.

Related Topics
•

Preparing the Project Directory on page 895

•

Setting the Path on Mac OS X below

•

Setting Up the Network View on the facing page

Setting the Path on Mac OS X
The Path needs to be set up so that when Harmony launches Maya, it knows where exactly to look for the
application. On Mac, we can set this up by placing a script in usr/bin.

Creating and Setting Up the Script on Mac OS X
Follow these steps to create the script to call Maya and to set it up.

Contact support at support@toonboom.com if you experience any problem while creating the script
and setting it up or 3D rendering.

From the Terminal, we want to create a file that we can save the script in.
To create the script and set it up:
1. First, change directory to the directory where you want to create the script file:
cd /usr/bin
2. If the directory bin doesn't exist yet, then create it:
mkdir /usr/bin
3. We will now create the script file called maya:
sudo vim maya
4. Type in your password to grant administrator access
5. Now from inside the text editor, select "i" to go to Insert Mode, and copy and paste the following text.
Make sure the path is updated to the version of Maya you have running on your machine.
#!/bin/bash
exec /Applications/Autodesk/maya2014/Maya.app/Contents/MacOS/Maya "$@"
6. Save and exit by typing in:
Esc :wq
7. Now we need to edit the file to make sure that all users can access it. Type in:
chmod ugo+x maya
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Setting Up the Network View
Now that your environment variables have been properly set up, you need to take the final step and prepare
your network to call the Autodesk Maya rendering utility. Once it is done, you will be able to render the 3D
objects in your Harmony project and preview them in the Camera view in Render View
mode. This will allow
you to composite your 3D scene and effects.
There are two types of script module that work with the Harmony-Maya connection:
•

Render Maya Batch
This module uses the script renderMayaBatch();
This script starts up a Maya Batch session, renders the 3D elements on that frame, then closes the
session. It will open and close the session for every frame to be rendered.

•

Render Maya Batch Server
This module uses the script renderMayaBatchServer();
This script starts up a Maya Batch session that stays open so that when you render 3D objects through
multiple frames, it does not close the session between each of them.

To prepare the project network:
1. Launch Toon Boom Harmony.

It is recommended that you run it from the command line, this way, you will have a printout of the
process as it renders. Once it is launched, you might also want to display the Message Log view.

2. In the Network view, locate the 3D object module.
3.

In the Module Library view, select the RenderMayaBatch or RenderMayaBatchServer module and drag
it to the Network view.
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4. In the Network view, hold the [Alt] key down while dragging the Maya Render module right under the 3D
object module to connect it.

5. Repeat the previous steps for each 3D object module in your scene.
6. Save and reload your scene so that Autodesk Maya files can be retrieved from the project folder.
7. In the Camera view, click the Render View

button.

All the elements of your scene appear in this complete preview of the rendered scene.
8. If you want to add effect filter modules to your 3D object, make sure to connect them right under the
Maya render module.

You are now all set to render your animation project.

If it does not render as expected, run Toon Boom Harmony from the command line and see if you
received an error readout when clicking on the Render View button. Email this information to
support@toonboom.com.

Related Topics
•

Export on page 1409

Rendering 3D Models
When batch rendering 3D models originating from Maya, some unwanted artifacts may appear, particularly on
models with outlines. This is due to problems with the depth information. You can use the Z-Buffer Smoothing
module to smooth out the edges.
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To render 3D models:
1. In the Module Library, select the 3D tab.
2. Select the Z Buffer Smoothing module and drag it to the Network view.
3. In the Network view, place it between a MayaBatchRender module and the final Composite module.

4. Display the Z Buffer Smoothing module properties.
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5. Adjust the Histogram Range and Kernel Size parameters to achieve the optimal rendering of your Maya
models. In most cases, you will have to experiment with a balance between the histogram range and the
kernel size.

Z Buffer Smoothing Module Properties
Parameter

Description
Lets you define the range of clean pixels in the depth histogram when
rendering 3D models. Only opaque or semi-transparent values are considered.

Histogram Range

Kernel Size

A low value means fewer pixels are used in the depth calculations and may
flatten your object, while a higher value uses more pixels in the depth
calculations, but may not eliminate all the image artifacts.
Lets you determine the size of the matrix used for calculating the depth of a
single pixel. For example, for an operation with a kernel size of 3 pixels,
Harmony uses the pixels within a 1-pixel radius to calculate the effect. A larger
kernel size means longer calculations.
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Chapter 15: Sound

With Harmony, you can import soundtracks and dialogue into your animation to make it more engaging and
entertaining.There are several sound editing features that can be used to synchronize sounds to individual
frames or moments in time. You can also use them to trim unwanted seconds from the beginning and end of your
sound files, as well as to loop sounds that you want to continue throughout your animation.
Your ability to add dialogue to animation is greatly enhanced with the Harmony lip-sync tools. Harmony can
analyze voice tracks to determine which of the eight animation phonemes (lip positions) would best apply to
each frame of sound. With the mouth chart that the software generates, you can easily draw lip positions for
your character. Furthermore, Harmony can automatically apply drawings of lip positions to each frame of your
animation based on the mouth chart.

You can also synchronize your animation to a music score, refer to Tempo Markers on page 510 to
learn more.

Topics Covered
•

Importing a Sound File on page 905

•

Sound Layer Properties on page 907

•

Sound Displays on page 909

•

Sound Playback on page 910

•

Sound Scrubbing on page 911

•

Editing a Sound File on page 914

•

Add Empty Sound Layer on page 923

•

Lip-sync on page 925

•

Exporting a Sound File on page 1419
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•

Sound Preferences on page 936
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Importing a Sound File
If you decide to add sound to your movie, you must first prepare this sound outside of Harmony. When this is
done you must add a sound element in Harmony to the organize sound files in your animation. Sound will play in
the movie until it reaches the end of the file or a stop frame that you have created in the Sound Element Editor.

If you first create your project in Toon Boom Storyboard Pro, the sound will be cut up into the
different scenes for you automatically.

You can import WAV, AIFF or MP3 sound files using any of the methods listed below.
To import a sound file:
1. Select File > Import > Sound
‣

Right-click anywhere in the frame zone of the Xsheet view.

‣

From the Top menu

‣

From the Xsheet View menu

‣

From the Timeline View menu

The Select Sound File dialog box opens.

2. From the Select Sound File dialog box find and select your sound file from your computer.
Your sound file appears as a layer in both the Timeline and Xsheet view.
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Related Topics
•

Sound Layer Properties on the facing page

•

Sound Displays on page 909

•

Sound Playback on page 910

•

Sound Scrubbing on page 911

•

Editing a Sound File on page 914

•

Add Empty Sound Layer on page 923

•

Lip-sync on page 925
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Sound Layer Properties
When you select a sound layer in the Timeline view, the options related to that layer appear in the Layer
Properties view.

•

Mute/Unmute

This button mutes and unmutes the sound layer during the scene play back.
•

Layer Name

This field displays the layer's name.
•

Sound Editor

This button opens the Sound editor.
•

Start Frame/End Frame

These fields determine the start and end frame of the sound file.
•

Detect

This button launches the automated lip-sync detection.
•

Map

This button opens the Map Lip-sync dialog box.
•

Mouth Shapes

This section shows the automated lip-sync detection during the scene play back. Click on the thumbnail
image of each mouth to change the phoneme assigned to the current frame.

Related Topics
•

Importing a Sound File on page 905

•

Sound Displays on page 909

•

Sound Playback on page 910
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•

Sound Scrubbing on page 911

•

Editing a Sound File on page 914

•

Add Empty Sound Layer on page 923

•

Lip-sync on page 925
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Sound Displays
Within the Xsheet view, the sound file can be displayed in different ways, depending on your sound editing
needs.
To change the sound display:
1. Right-click in the sound column or on the sound column header, choose
Sound Display > and one of the following:
‣

Sound Name: Shows the name of the sound file, as well as the file format. The line running vertically
through the column frames between the same file name indicates a continuity of the same sound file in
these frames.

‣

Mouth Shapes: Show the letter (or name depending on the way you named your character's different
mouth positions) in the column's frames. There is only one mouth position allotted per frame and this
position should correspond to the sound file after performing a lip-sync.

‣

Waveform: Shows a vertical display of the sound file's actual waveform. In the column header, in the
field under the column name, you can type in a percentage to zoom-in or zoom-out on the waveform,
or pass the scroll cursor
over the Zoom Waveform
icon.

You can show/hide the waveform in the Timeline view by pressing the Waveform button in the
Timeline View toolbar.

Related Topics
•

Lip-sync on page 925

•

Sound Preferences on page 936
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Sound Playback
Before playing back any sound, click on the Enable Sound

button in the Playback toolbar or enable it

through the Play menu in the top menu. This will make sure that you can hear the sound layers in your scene, even
the ones included within symbols.
To play back your sound sample:
1. To select a starting point:
‣

In the Xsheet view, click on a cell in the sound column.

‣

In the Timeline view, click on a cell in the sound layer. You can also slide the red playhead to the correct
cell.

2. Click on the Play

button in the Playback toolbar or in the top menu select

Play > Play Scene Forward or click on the [Enter/Return] key.
3. If you would like to hear your sound sample played back again and again, click the Loop

button in the

Playback toolbar or the Loop option from the Play menu.

Mute
If you have two or more sound layers and would like listen to them independently, you can disable the unwanted
sound by clicking on the Mute Sound
icon located on the sound name layer in the Timeline view.

Related Topics
•

Importing a Sound File on page 905

•

Sound Layer Properties on page 907

•

Sound Displays on the previous page

•

Sound Scrubbing on the facing page

•

Editing a Sound File on page 914

•

Add Empty Sound Layer on page 923

•

Lip-sync on page 925
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Sound Scrubbing
Harmony uses a process known as Sound Scrubbing to let you hear sound in real-time while you move the
playback pointer forward or backward. This is very useful for finely-tuned lip-synching. You can scrub sounds
from the Timeline view.
To scrub a sound from the Timeline view:
1. In the Playback toolbar, click on the Sound Scrubbing

button or from the top menu, select

Play > Enable Sound Scrubbing. You can also activate Sound Scrubbing by right-clicking in the Timeline
view's frame bar.

2. At the top of the Timeline view, drag the red frame marker along to hear the sound at each frame. The
[Ctrl] + [Up Arrow] and [Ctrl] + [Down Arrow] (Windows/Linux) and [⌘ ] + [Up Arrow] and [⌘ ] + [Down
Arrow] (Mac OS X).

Related Topics
•

Analog Sound Scrubbing below

Analog Sound Scrubbing
Harmony is set to the digital sound scrubbing mode by default. This means that all sounds are played in real
time. It also means that as you scrub over a frame you will hear the section of your sound file that is allotted to
that frame. As you are scrubbing, although it is accurate, the sound can sound clipped. It can also be difficult to
hear nuances in pitch and tone.
Harmony has an analog sound scrubbing option. When sound scrubbing in this mode, the sound is played back
according to the speed that the playhead or jog is manually adjusted. Harmony's interface offers shuttle and jog
sliders to perform analog sound scrubbing, however, external hardware and their corresponding software can
be used in conjunction with Harmony for improved analog sound scrubbing results.
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Please refer to the device's manual to configure its functionality with Harmony.

Performing an Analog Sound Scrub in Harmony
Before you can perform an analog sound scrub in Harmony, you have to learn about the Shuttle and Jog.

•

Shuttle: Pull the Shuttle backward or forward to make the red playhead, in the Timeline view, jump by
large increments in the direction you are moving the shuttle.

•

Jog: Click and drag along the Jog to make the "dial" rotate. The Jog controls finer incremental
movements along the soundwave. Use the Frame field to see the frame number which you are on. As you
rotate the dial, your speed in fps appears directly after the FPS field.

To perform an analog sound scrub:
1. In the Playback toolbar, click on the Sound Scrubbing

button or from the top menu, select Play >

Enable Sound Scrubbing. You can also activate Sound Scrubbing by right-clicking in the Timeline view's
frame bar.
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2. In the top menu, go to Edit > Preferences (Windows/Linux) or Stage> Preferences (Mac OS X).
3. In the Sound tab enable the Analog Sound Scrubbing option.
4. Click on the OK button.
5. In the Playback toolbar, use the Shuttle to find the general location of where you would like to start your
sound scrub, or in the Timeline view, drag the red playhead to the desired location.
6. In the Playback toolbar, use the Jog to fine tune your scrub to just a few frames.

Related Topics
•

Sound Scrubbing on page 911
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Editing a Sound File
Now that you have successfully imported your sound file into Harmony, it is time to familiarize yourself with the
sound editing interface. The Sound Element editor makes it possible to edit sounds that were created outside of
Harmony and imported into your scene.
To open the Sound Element editor:
1. Either double-click the sound layer name in the Timeline view or the sound column header in the Xsheet
view.
The Sound Element Editor dialog box opens.

The Sound Element editor consists of three main parts.
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1. Sound Element - The wave form seen in the top Sound Element window is the actual sample that will
be heard when the final movie is rendered. It may be shorter than the original sound sample due to length
of the scene. If any edits are made to the sound sample, they can be heard here.
In the Sound Element panel you will see some coloured tabs, these tabs represent the frames. The frame
number is shown inside the tab flag marker. Note that these tabs indicate the start and end frames of a
sound segment.
2. Current Sound - The Current Sound window displays the original sound file in its entirety and is where
you can edit its properties. This window remains empty until you click inside the Sound Element window.
3. Lip-sync Preview - Is used to preview the automated detection and to manually insert different mouth
positions to correspond with the sound sample.
You can accomplish the following in the Sound Element editor:
•

Changing the Start or End Frame of a Sound on the next page

•

Trimming the Start and End of a Sound File on page 918

•

Looping a Sound on page 919

•

Mixing the Sound Volume on page 920

•

Customizing the Playback Range on page 921

•

Recomputing the Mouth Chart on page 931

Related Topics
•

Lip-sync on page 925
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Changing the Start or End Frame of a Sound
To synchronize the sound with specific images in your scene, you must set a start frame for your sound. To make
sure the sound ends by a certain frame, you must set an end frame.

In the Sound Element panel you will see some coloured tabs, these tabs represent the frames. The
frame number is shown inside the tab flag marker. These tabs indicate the start and end frames of a
sound segment.

To change start or end frame of a sound:
1. Either double-click the sound layer name in the Timeline view or the sound column header in the Xsheet
view to open the Sound Element editor.
2. Select the sound sample you want from the Sound Element panel. To distinguish one sound section from
another on the same sound layer, check the frame numbers that appear on tabs flanking the start and
stop lines of each waveform section.

Click on the Play

button in the Current Sound panel (only the selected sound plays).

3. Within the Sound Element panel, click and drag the selected clip to the frame number where you want it
to start playing.
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You can only move the clip to a section that does not already contain a clip; you cannot overlap two clips in the
same element.
4. To change the end frame, drag the yellow marker at the end of the waveform to the frame position.

5. To hear how all of the clips fit together in the element, click on the Play

button in the Sound Element

panel.

If you only want to hear the selected clip, click on the Play

button in the Current Sound panel.

6. Click Apply/Next when done.
The Xsheet and Timeline views display the sound clip at the start frame you selected.

Related Topics
•

Trimming the Start and End of a Sound File on the next page
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•

Looping a Sound on the facing page

•

Mixing the Sound Volume on page 920

•

Customizing the Playback Range on page 921

Trimming the Start and End of a Sound File
To play only a section of a sound file, use the Sound Element Editor to select the exact part you want to use. For
example, if there is a bit of noise at the start of the sound, use the Sound Element Editor to cut the noise.
The Sound Element Editor does not change the original sound file; it only plays a section of it, ignoring the rest.
This means that the entire sound file is included on export. If you need to be mindful of file size, it is better to edit
sound files completely in a sound editor before bringing them into Harmony.
To trim the start and end of a sound file:
1. Either double-click the sound layer name in the Timeline view or the sound column header in the Xsheet
view to open the Sound Element editor.
2. Select the sound you want to work on from the Sound Element panel.
3. Select the sound sample you want from the Sound Element panel. To distinguish one sound section from
another on the same sound layer, check the frame numbers that appear on tabs flanking the start and
stop lines of each waveform section. Or select a soundwave and click on the Play
button in the
Current Sound panel (only the selected sound will play).
4. Using the Current Sound panel, you can decide which part of the file you want to play by dragging the left
and right boundaries of the selection area.

5. Click on the Play

button in the Current Sound panel to check that you have trimmed the desired

sections. Use the Zoom slider at the bottom of the panel to zoom in on the wave form so that you can
trim it more accurately.

6. Click on the Apply/Next button.
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The trimmed sound sample should now appear in both the Timeline and Xsheet views at the start and end
positions that you selected.

Related Topics
•

Changing the Start or End Frame of a Sound on page 916

•

Looping a Sound below

•

Mixing the Sound Volume on the next page

•

Customizing the Playback Range on page 921

Looping a Sound
To repeat a sound, specify the number of times that you want it to loop in the Sound Element editor.
To loop a sound sample:
1. Either double-click the sound layer name in the Timeline view or the sound column header in the Xsheet
view to open the Sound Element editor.
2. From the Sound Element panel, select the sound section that you want to loop.
3. In the Current Sound panel, type the number of times you want the sound to play in the Number of Loops
field.

4. Press on the [Enter/Return] key. The looped sound appears after the current sound. They are indicated by
their grey waveforms, as opposed to black.
When you loop a sound, the looped sections fill the cells in the sound element (column or layer) until the next
sound sample starts or until the scene ends. This means that the looping could effectively get cut if the next
sound sample starts too soon, or if the scene ends too quickly.

Related Topics
•

Changing the Start or End Frame of a Sound on page 916

•

Trimming the Start and End of a Sound File on the previous page

•

Mixing the Sound Volume on the next page

•

Customizing the Playback Range on page 921
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Mixing the Sound Volume
You can adjust the volume of an entire sound clip or modify the volume in increments by adjusting the fade-in and
fade-out times, otherwise known as sound envelopes. The fade edit only affects the play back; the original sound
file is not affected.
To adjust the overall volume of the entire sound clip:
1.

Either double-click the sound layer name in the Timeline view or the sound column header in the Xsheet view to
open the Sound Element editor.

2. In the Sound Element panel, select the sound that you want to work on. A more detailed version of the
selected sound appears in the Current Sound panel.
3. In the Current Sound panel, use the Volume slider to adjust the volume.

4. Click on the Play

button in the Current Sound panel to verify the volume.

To create the fade in/out effect on a sound clip:
1. Either double-click the sound layer name in the Timeline view or the sound column header in the Xsheet
view to open the Sound Element editor.
2. In the Sound Element panel, select the sound you want to work on.
3. In the Current Sound panel, click on the thin blue line above waveform to add an envelope marker.

4. Drag the envelope markers to adjust the volume at that frame and to create the time of the transition.
The line from the edge of the clip to the envelope marker identifies how the volume either increases
(fades-in) or decreases (fades-out) over time.
Dragging the marker to the bottom of the channel will mute the volume, while dragging it upwards will
increase the volume.

To create an even effect, be sure to adjust the envelope markers uniformly in both the left and right
(bottom and top) channels.
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5. Click on the Play

button in the Current Sound panel to check the fade envelopes.

Related Topics
•

Changing the Start or End Frame of a Sound on page 916

•

Trimming the Start and End of a Sound File on page 918

•

Looping a Sound on page 919

•

Customizing the Playback Range below

Customizing the Playback Range
To hear a specific section of the sound element, adjust the playback range in the Sound Element Editor to start
or stop at specific frames. This customized playback range does not affect the actual sound in the Sound
element.
To change the playback range in the Sound Element Editor dialog box:
1. Drag the start or end range markers in the Sound Element panel to the boundary frames you want.

2. When you click on the Play

button to play back your sound in the Sound Element editor, it only plays

the sound which exists between the two markers.
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Related Topics
•

Changing the Start or End Frame of a Sound on page 916

•

Trimming the Start and End of a Sound File on page 918

•

Looping a Sound on page 919

•

Mixing the Sound Volume on page 920
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Add Empty Sound Layer
When performing sound editing tasks, it can be useful to chop up a sound sample into different layers. For
example, when performing a lip-sync, only a single view of the various mouth positions for a character can exist
on one layer. Therefore, if you would like to have your character turn its head from a profile view to a threequarter view and have mouth position changes to fit with the sound sample from these two different views, you
would need to cut-up the sound samples needed for the profile view mouth positions on one layer and the sound
samples needed for the three-quarter view on another.
For this task, you will need an empty sound layer.
To add an empty sound layer:
1. In the top menu, select Windows > Toolbars > Timeline View.
The Timeline view toolbar appears at the top of the Timeline view.

2. Right-click on the Timeline View toolbar and choose Customize.
3. Choose the Add Sound

button from the Available Tools column on the left and add it to the Toolbar

column on the right. Click Ok to accept the change.

4. Click on the Add Sound

button.

An empty (silent) sound layer should appear in both your Timeline and Xsheetviews.

5. Rename your layers accordingly.
6. Click the cell where you wish to start the cut and [Shift] + click on the final cell of the cut. The sample to be
cut becomes highlighted.
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7. Drag the selection into the empty sound layer below.

8. You can now continue to cut-up and distribute the sound sample between the two layers or carry on to
the lip-synching process for each layer and its corresponding facial view.

If you need to duplicate your sound layer to keep an unedited copy for safety, you can click on the
Duplicate Selected Layers button, located in the Timeline View toolbar.

Related Topics
•

Importing a Sound File on page 905

•

Sound Layer Properties on page 907

•

Sound Displays on page 909

•

Sound Playback on page 910

•

Sound Scrubbing on page 911

•

Editing a Sound File on page 914

•

Lip-sync on the facing page
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Lip-sync

Adding a lip-sync to a project can really enhance its quality and storytelling. However, it can be difficult to shape a
character's mouth so that it matches the sound at the precise frame.

To solve this problem Harmony provides a lip-sync feature which analyzes the contents of a sound element and
generates a mouth chart (see below) based on the eight animation phonemes (A, B, C, D, E, F, G, and X, which is
used to represent silence).
The mouth shapes used by Harmony are based on the conventional mouth chart used in the animation industry.

The letters used to represent the shapes do NOT correspond to an actual sound.

If you are doing cut-out animation, refer to the Harmony User Guide, Character Buidling chapter,
"Adding Extra Drawings" topic to learn how to add extra drawings to your character.
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Here is an approximation of which sound each mouth shape can produce:
•

A: m, b, p, h

•

B: s, d, j, i, k, t

•

C: e, a

•

D: A, E

•

E: o

•

F: u, oo

•

G: f, ph

•

X: Silence, undetermined sound

You can lip-sync the traditional way or let the system automatically create the basic detection.
You can refer to the mouth chart positions as you draw the shape of your character's mouth.

Related Topics
•

Generating a Lip-sync Detection on the facing page

•

Mapping the Lip-Sync Detection on page 928
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•

Modifying the Lip-sync on page 930

•

Manual Lip-sync on page 932

Generating a Lip-sync Detection
There are three places where you can perform a lip-sync detection:
•

Timeline and Xsheet Views below

•

Generating a Lip-sync Detection above

•

Layer Properties View on the next page

Timeline and Xsheet Views
To generate a sound detection for your lip-sync using the Xsheet or Timeline view:
1. To show the mouth chart letters, if they are not already present in the Xsheet view,right-click on the sound
column and select Lip-Sync > Sound Display > Mouth Shapes from the pop-up menu.
2. In the Xsheet view or Timeline view, right-click on the sound layer's cells and select Lip-Sync > Auto LipSync Detection. You can also select Animation > Lip-Sync > Auto Lip-Sync Detection from the top
menu.

Harmony analyzes the selected sound clips and assigns a lip-sync letter to each frame. The X markers in
the frame are replaced by these designated letters.

Sound Element Editor
To generate a sound detection for your lip-sync using the Sound Element Editor:
1. Double-click the sound layer name in the Timeline view or the sound column header in the Xsheet view to
open the Sound Element editor.
2. In Sound Element panel, select the waveform you want to generate the mouth chart for.
3. Right-click on the sound file and select Auto Lip-Sync Detection.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to
each sound cell.
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Layer Properties View
To generate a sound detection for your lip-sync using the Layer Properties view:
1. In the Timeline or Xsheet view, select your sound layer.
2. In the Layer Properties, click Detect.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to
each sound cell.

Related Topics
•

Manual Lip-sync on page 932

•

Mapping the Lip-Sync Detection below

•

Modifying the Lip-sync on page 930

Mapping the Lip-Sync Detection
Harmony can automatically map drawings in an element to the mouth chart you have generated for a sound. This
can save time when you are lip-synching a voice track.
In the Lip-Sync Mapping dialog box, you can identify each lip drawing of a character. Harmony then automatically
labels all of the cells in the character's element with the appropriate name.
To automatically map lip-sync drawings to a mouth layer:
1. To open the Lip-Sync Mapping dialog box, do one of the following:
‣

In the Timeline view,right-click on any cell in the sound sample layer and select Lip-Sync > Map LipSync.

‣

From the top menu, select Animation > Lip-Sync > Map Lip-Sync.

‣

In the Timeline view, select your sound layer and in the Layer Properties view, click Map.
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The Lip-Sync Mapping dialog box opens.

2. From the Destination Layer drop-down list, select the layer that contains the mouth positions for the
character's voice track.

3. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on the
layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to
use the drawings or select the desired symbol from the drop-down menu.
4. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the phoneme
it represents. If your drawings are already named with the phoneme letters, you do not have to do
anything.
5. Click OK.
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6. Press the Play

button in the Playback toolbar to see and hear the results in the Camera view. To play

back your scene with sound, enable the Sound

button in the Playback toolbar.

Related Topics
•

Generating a Lip-sync Detection on page 927

•

Manual Lip-sync on page 932

•

Modifying the Lip-sync below

Modifying the Lip-sync
You can change the mouth position assigned to a frame if you think another position is more appropriate.
For example, you may have a character who says nothing for 10 frames between two speeches. Harmony would
normally assign an X image for the silent period. However, if you want your character's mouth to hang open in
astonishment for these 10 frames, you can change the lip assignment for these frames from an X to an F.
To change the lip assignment of a sound in the Xsheet:
1. Right-click in the cell that contains the mouth position you want to change.
2. From the pop-up menu, select Lip-Sync > Change Mouth Shape to and choose the letter that reflects
the mouth position you want to use for that sound. You can also select Animation > Lip-Sync > Lip-Sync
> the desired mouth shape from the top menu.
The drawing is automatically updated in the Camera view.
You can also change the mouth assignment of a sound in the Sound Element editor.
To change the mouth position assignment of a sound from the Sound Element editor:
1. Double-click the sound layer name in the Timeline view or the sound column header in the Xsheet View to
open the Sound Element editor.
2. In the Sound Element panel, drag the frame slider to the frame you want to change the mouth position
assignment on.
In the Lip-sync image area, the image on top represents the lip position assigned to the current frame.
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3. To change the image assigned to the frame, click on the image of the mouth position you want from
below the preview image. The preview image changes to the mouth position image you select. You can
perform the same operation in the Layer Properties view.

The position is updated in the Timeline and Xsheet views.

Note that if you modify the lip-sync detection you must remap the detection to your mouth latyer.
See Mapping the Lip-Sync Detection

Related Topics
•

Recomputing the Mouth Chart below

Recomputing the Mouth Chart
When you generate the mouth chart for a sound in a sound element, you can either accept the mouth positions
assigned by Harmony or assign your own lip-sync images.
However, if you change the sound's start frame or reassign its mouth position, you must reanalyze the sound
and regenerate the mouth chart for it. This erases any manual modifications you may have made to the mouth
assignments in the mouth chart.
To recompute the mouth chart for a selected sound from the Sound column:
1. In a Sound column in the Xsheet or Timeline view,right-click on a cell that contains the sound file you want
to recompute the lip-sync for. Select Lip-Sync > Auto Lip-Sync Detection from the pop-up menu. The
mouth position assignment for each frame is recomputed, erasing any modifications you have made.
To recompute the mouth chart for a selected sound from the Sound Element Editor:
1. Double-click the sound layer name in the Timeline view or the sound column header in the Xsheet view to
open the Sound Element editor.
2. Click on the waveform in the Sound Element section in the Sound Element editor.
3. Right-click and select Auto-Lip Sync Detection.

Related Topics
•

Generating a Lip-sync Detection on page 927
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Manual Lip-sync
Harmony allows for the manual swapping of mouth position drawings to match a voice track. For this process,
both sound scrubbing (listening to a soundwave broken up frame-by-frame) and drawing substitutions from the
Library View are used.
To perform a manual lip-sync:
1. In the Playback toolbar, enable the Sound Scrubbing

button.

2. In the Timeline view, drag the red position indicator along the sound layer waveform.
3. When you reach a frame where a mouth position should go, for example, an open mouth with rounded
lips for an "oh" sound, click on that frame on your mouth shapes layer.
4. In the Timeline view, click on the Expand

button to display the Data view.

5. Staying on your mouth shapes layer, place your cursor on top of the drawing name (often a letter) until it
changes to the swapping
pointer.
6. Pull the cursor to see the list of mouth shape names and choose the one you want. The current drawing
automatically changes to the new selection.

You can also use the Library view to swap drawings.
To perform a manual lip-sync using the Library view:
1. In the Playback toolbar, enable the Sound Scrubbing

button.

2. In the Timeline view, drag the red playhead along the waveform of your sound layer.
3. When you reach a frame where a mouth position should go, for example, an open mouth with rounded
lips for an "oh" sound, click on that frame on your mouth shapes layer.
4. In the Drawing Substitution window of the Library view, click and drag the slider to choose a mouth
shape. The current drawing is swapped for the one in the preview window.

Related Topics
•

Preview and Drawing Substitution on page 629
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•

Sound Scrubbing on page 911
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Exporting a Sound File
At some point during the production, you might need to export your sound file to use it in another application
such as an editing software. Harmony allows you to export your sound files either as a merged soundtrack, or as
a series of individual files. The exported soundtracks are generated as *.wav files.

To export a soundtrack:
1. In the top menu, select File > Export > Soundtrack.
The Export Soundtracks dialog box opens.

2. In the Output section, click on the Browse button to select where you want to save the exported sound
file.
3. In the Export Range section, enable the All option if you want to export the sound over all the frames of
your scene, or enable the Frames option and set the start and end frames in the corresponding fields on
the right hand side.
4. In the Options drop-down menu, select one of the following options:
‣

Process Soundtracks Individually: Select this option if want each soundtrack from all layers to be
exported as individual files.

‣

Merge all Soundtracks: Select this option if you want Harmony to create one single sound file
combining all the sound files you imported in your scene. Note that it will only use the sound files used
in the selected frame range set in the Export Range section. If you selected to export all the frames, all
the sound files will be processed.

5. In the Sound Settings section, set the Rate, Size and Use parameters for the soundtracks to export. It is
a good idea to verify what is required by the software, or device, that you might next want to use the
sound file with.
6. Click on the OK button to export your sound file.
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The generated sound files appear in the selected directory and are named according to the scene name.
Individual files will keep their original name; only a prefix matching the scene name is added.

Related Topics
•

Importing a Sound File on page 905
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Sound Preferences
When working with sound in Harmony, you can set some preferences to help you work more efficiently.

Timeline Tab

Show Sound Waveform
Enable this option if you would like to see your imported sound's waveform in the Timeline view.

You can always toggle the visibility of the waveform in the Timeline view by adding the Show Sound
Waveform button from the Toolbar Manager. This button will work whether you have the Show
Sound Waveform option enabled or disabled in the Preferences panel.

Sound Tab

Analog Sound Scrubbing
Enable this option to switch from digital to analog sound scrubbing.

Analog Jog Speed
Choose a value between 1-20 for the Analog Jog Speed. The greater the jog speed value, the slower you can
scrub to have the sound play at an average pace. This controls how sensitive you would like the jog slider or dial
to be.

Analog Jog Dampening
Choose a value between 1-100 for the Analog Jog Dampening. The greater the value, the less precise the
software is at responding to the jog's changes in speed. However, he greater the value, the more smooth the
play back is using the job slider or dial.
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Movement is the essence of creating an animation; it is essentially what animation is: bringing drawings to life.
Sometimes this movement comes from the characters or objects themselves, while other times, it is the camera
moving through elements set-up on the camera "stage". Often these movements can be complex, such as a
helicopter moving across the screen with its rotor blades rotating, as the helicopter disappears into the
distance, it appears to get smaller in size as it recedes in space. Although this seems like a simple motion, you
must coordinate three movements to produce the correct effect.
The sophisticated systems integrated in Toon Boom Harmony have been specifically developed to
accommodate the your complex motion needs.

Topics Covered
•

Animating a Layer on page 939

•

Differences between Pegs and Animated Layers on page 941

•

Adding and Deleting Keyframes on page 952

•

Motion and Stop-motion Keyframes on page 955

•

Animating the Camera on page 960

•

Modifying a Path in the Camera View on page 969

•

Modifying a Path in the Timeline View on page 981

•

Modifying a Path in the Function View on page 984

•

Modifying a Path in the Xsheet View on page 990

•

Function Curves on page 992

•

Copying and Pasting a Motion on page 1001

•

Adjusting the Ease on page 1010

•

Expression Columns on page 1017
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•

Animation Path Preferences on page 1024
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Animating a Layer
This section describes the basics of animating a layer.
Harmony’s wide range of features let you produce accurate trajectories. However, before doing this, you must
learn the basics of animating a layer by creating a simple motion, and practice everything you learn in this lesson.
In this topic, you will find out about the two key elements in creating a motion:
•

Animate Mode below

•

Animating a Layer below

•

Enabling Playback on the next page

Animate Mode
When you enable this mode when you animate layers, Harmony will apply a transformation to the current frame.
Otherwise, a transformation is applied on the entire layer instead of only the current frame.
To enable the Animate Mode:
1. In the Tools toolbar, click the Animate Mode

button.

Animating a Layer
Follow these steps to perform a basic layer animation.
To animate a layer:
1. In the Tools toolbar, select the Transform

tool or press [Shift] + [T].

2. In the Transform Tool Properties view, make sure that the Peg Selection Mode
3. In the Tools toolbar, click the Animate Mode

button.

4. In the Timeline view, go to the first frame.

5. In the Camera view, select the element to animate and move it to its first position.
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6. In the Timeline view, go to the frame on which you want to set the second position.

7. Play back

your animation.

Enabling Playback
To see your motion animations in the Top, Side or Perspective views while you play back, you must turn on the
Playback option.
To enable the Playback option:
‣

From the top menu, select Play > Enable Playback > Top View, or Side View or Perspective View.

Related Topics
•

Motion and Stop-motion Keyframes on page 955
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Differences between Pegs and Animated
Layers

To animate the position of your drawings you need to create motion paths. Motion paths are trajectories on
which you can hook your drawing objects. You will use keyframes to record the key positions along the
trajectory.
There are two ways in which to create motion paths: animated layers and pegs. Animated drawing layers and
pegs have different purposes.
•

Animated Layers below

•

Pegs on page 943

Animated Layers
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You can create a motion path directly on your layers.
Drawing layers can house drawings and symbols. Also, in that same layer you can create a motion path using
keyframes and all the artwork contained in the layer will follow.

You can control and define your trajectory using several different parameters. These parameters are:
•

X, Y and Z positions

•

Angle (rotation)

•

Skew

•

X and Y scales

Each parameter has its own function curve where you can add keyframes and control the easing.
Do not worry about using graphs and function curves if you are not familiar with this concept. Harmony has a
series of easy-to-use tools for visually controlling your trajectories in the Camera view.
To animate a simple object such as an arrow in flight or a wheel spinning, you can use the integrated trajectory.
Also, each part of a cut-out puppet will be animated directly on the drawing layer.

If you do not want to animate a drawing layer, you have the option of disabling its animation
parameter. To do so, simply select the layer and in the Layer Properties view, deselect the Animate
Using Animation Tools option under the Advanced tab.
If your layer was already animated and you deselect the Animate Using Animation Tools option, your
keyframes will be dimmed, enabling you to easily identify them as ones that cannot be modified.
Select the option in order to modify them again.

Prevent Drawing Layers from being Animated
By default, a drawing layer can be animated but you can disable this feature and render a specific layer to be still.
Being able to switch your drawings so they can be animated or not has certain advantages. When selecting the
element in the Camera view, the actual Drawing layer is selected, but the motion you will create will
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automatically be transposed to the Peg layer (if parented to a peg layer). This means that you can have access to
the drawing substitution feature for this drawing layer, while being able to create keyframes on it's parent peg.
This feature is also available for backward compatibility.
To disable the animation feature on a layer:
1. In the Timeline view, double-click the layer on which you want to set the parameter.
The Layer Properties editor opens.

2. In the Advanced tab, deselect the Animate Using Animation Tools option.

Related Topics
•

Pegs below

•

Layer Parameters on page 948

Pegs
A Peg layer is a trajectory that contains no drawings on which you can hook your drawings.

Related Topics
•

Why Use a Peg Layer? below

•

The Origin of the Peg on the next page

•

Adding a Peg to the Timeline on page 945

•

Adding a Peg to the Network View on page 945

•

Peg Selection Mode on page 947

Why Use a Peg Layer?
A peg is composed of many customizable parameters. These parameters are:
•

X, Y and Z positions

•

Angle (rotation)

•

Skew

•

X and Y scales

•

3D rotation (when the 3D option is enabled)
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You can control a peg’s trajectory the same way as the animated drawing layer.
A peg layer is mainly used to control a series of drawing layers. If you have several drawing layers, such as clouds
or a character split into many parts, you can hook those to a peg layer and have them follow a trajectory as a
unit. When building a puppet, most of the time you will add a master peg to control your puppet as one object.

The Origin of the Peg

Pegs have been used for a long time in the traditional animation process, mainly for registration purposes. Peg
holes at the bottom (or top) of animation paper are used to keep all of the sheets even and at the same
registration.
There are three peg holes in regular animation paper. The centre peg hole is circular while the left and right ones
are rectangular. These rectangular peg holes are located on each side of the page, and four inches away from
the centre peg hole.
To keep the drawings together, the animator uses a peg bar. This peg bar has three pins that correspond to the
shape and location of the peg holes. Peg bars are normally found at the bottom and top of animation discs.
Before digital compositing, the peg bars were also used to move levels under the camera stand. They were the
equivalent of digital trajectories. Harmony makes use of these concepts to create animation and camera moves.
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Adding a Peg to the Timeline
To add a peg:
1. Select the layer on which you want to attach a peg.

2. Do one of the following:
‣

From the Timeline View layers toolbar, click the Add Peg

‣

From the top menu, select Insert > Peg.

‣

Right-click (Windows) or [Ctrl]+Click (Mac OS X) on the layer and select Add > Peg.

‣

In Harmony, select a Peg module from the Module Library and drag it to the Network view.

button.

The layer that was originally selected becomes a child of the new parent Peg layer. The new Peg layer
automatically takes the name of its child layer, with the addition of the suffix -P.

3. If you intend to add multiple pegs or if the layer name that was added to the peg does not accurately
represent the content of the Peg layer, you can rename it. Clicking the layer name and type in a new name.
Or double-click the layer and type a new name into the dialog box.

4. If you did not create your peg layer directly above the layer you intended on parenting it to, then drag the
layer you want to attach to the peg and drop it directly below the Peg layer. The indentation of the layer
below the Peg layer indicates whether it was correctly attached or not.

Adding a Peg to the Network View
In Harmony, you can add pegs to the Network view using the Module Library view and they will instantly appear
in the Timeline view. The modules you add to the Network view will be synchronized with the ones appearing in
the Timeline view.
To add a peg in your Network view via the Module Library:
1. In the Module Library view, select the Move tab.
2. Select a Peg module and drag it to the Network view.
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3. In the Network view, select the Peg module's out port and connect it to a Drawing or Camera module.

The advanced connections in the Network view are shown in the Timeline view, unless they cannot be
reproduced in a timeline layout.

To add a peg to your Network view using a keyboard shortcut:
1. In the Network view, position the pointer at the location to which you want to add the new peg module.
2. Add a new peg by pressing [Ctrl] + [P] (Windows/Linux) or [⌘ ] + [P] (Mac OS X).
The new peg appears in the Network view.

Making an Automatic Connection to a Parent Peg in the Network View
You can automatically create connections between modules in the Network view without having to drag cables
out of the ports.
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To create an automatic connection to a Parent Peg:
‣

In the Network view, select one or several drawing modules that are not parented to any other
module.

‣

Press [Ctrl] + [P] (Windows/Linux) or [⌘ ] + [P] (Mac OS X) to add a new peg module to the Network
view and automatically connect it to the selected modules.

‣

Press [Ctrl] + [Shift] + [P] (Windows/Linux) or [⌘ ] + [Shift] + [P] (Mac OS X) to add a peg to each
individual module.

Peg Selection Mode
In the Transform Tool Properties view, the Peg Selection Mode

lets you automatically select the peg layers

in the Camera view instead of the drawing layers.
If you animate with pegs instead of animating the drawing layers directly, enable the Peg Selection Mode to
avoid having to select in the Timeline view or use the Select Parent Skipping Effects command.
To enable the Peg Selection Mode:
1. In the Tools toolbar, select the Transform

tool.

2. In the Tool Properties view, click the Peg Selection Mode
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3. In the Camera view, select an element parented to a peg.

Related Topics
•

Layer Parameters below

Layer Parameters
A layer is composed of many customizable parameters, such as the X, Y and Z positions, angle (rotation), skew
and scales. Each parameter has its own function. A function is a mathematical formula expressing the relation
between position values. You can view each function on a graph as a simple curve such as this one.

Learn more:
•

3D Path on page 950

•

Separate Positions on page 950
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•

Locked Scales and Separated Scales on page 951

•

Setting the Parameters on page 951

To display the Layer parameters in the Timeline view:
1. Do one of the following:
‣

In the Timeline’s left side, click the Expand

‣

To display the functions of a selected layer, select View > Show Functions from the Timeline View
menu.

button or press [Alt] + [F].

2. There are six options available for setting up function parameters:
‣

Locked Positions (3D Path)

‣

Separate Positions

‣

Locked Scales

‣

Separate Scales

‣

Quaternion (3D Rotation)

‣

Euler Angles (3D Rotation)
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You must lock or unlock your functions before starting the animation. When you lock or unlock
parameters, this does not convert the functions from one to the other, but creates new ones.

3D Path
In a 3D Path, the X, Y and Z curves are locked together and controlled by a single velocity function. When you
add a keyframe, it is added on all three trajectories at once, as is the velocity. This is very useful for long, smooth
trajectories.

Separate Positions
When the Separate Positions option is used, the X, Y and Z curves are independent and have velocity controls
directly on their function curve. This is useful when you want to set keyframes on one of the curves without
affecting the others.
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Locked Scales and Separated Scales
When using the scale function, you can have a single function curve controlling both the vertical and horizontal
scale, or have the two scales separate. This means that when using the single function, the values will be the
same for the X (horizontal) and the Y (vertical) axes, enabling a uniform size change without distortion. However,
if you separate the scale functions, you will be able to squash, stretch and skew your elements.

Setting the Parameters
You can set the parameters for 2D motion.
To set the parameters:
1. In the Timeline view, double-click the layer on which you want to set the parameter.
The Layer Properties editor opens.

2. Select the Transformation tab.
3. In the Position section, select the 3D Path or Separate option.
4. In the Scale section, select the Locked or Separate option.
5. Click Close.

Related Topics
•

3D Parameters on page 849

•

3D Space on page 847
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Adding and Deleting Keyframes
You can create a keyframe in several different ways. You can add a coordinate keyframe, position keyframe or a
keyframe along with your drawing duplication.

Related Topics
•

Creating a Keyframe below

•

Adding a Keyframe and Duplicating a Drawing Simultaneously below

•

Position Keyframe on the facing page

•

Deleting Keyframes on the facing page

Creating a Keyframe
You can create a keyframe without a drawing. This adds new coordinate points but the drawing in the layer stays
the same.
To create keyframes:
1. In the Timeline view, select the cell on which you want to add a keyframe.

2. Add a keyframe by doing one of the following:
‣

From the top menu, select Insert > Keyframe.

‣

Right-click (Windows) or [Ctrl]+Click (Mac OS X) on the selection and select Add Keyframe.

‣

Press [F6].

‣

In the Timeline View toolbar, click the Add Keyframe

‣

If the Animate mode is enabled in the Camera view, a keyframe is automatically created on the current
frame.

button.

Adding a Keyframe and Duplicating a Drawing
Simultaneously
You may want to duplicate your drawing at the same time if you need to modify it and do not want to modify the
original.
To create a keyframe and duplicate your drawing at the same time:
1. In the Timeline view, select the cell containing the drawing where you want to add a keyframe and
duplicate.
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2. To add a keyframe and duplicate, do one of the following:
‣

From the top menu, select Insert > Keyframe and Duplicate Drawing.

‣

Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Insert Keyframe and
Duplicate Drawing.

‣

Press [F6].

Position Keyframe
You can also add a Position keyframe instead of a regular keyframe. When you add a Position keyframe,
keyframes will only be added on the X, Y and Z parameters of the selected layer. Keyframes are not added on the
Angle, Scale and Skew parameters.
To add a Position keyframe:
1. In the Timeline view, select the cell where you want to add a position keyframe.

2. In the top menu, select Insert > Position Keyframe.
‣

If you select a keyframe in the Timeline view and press the [Delete] key, you will also delete the drawing
exposure. To only delete the keyframe, you must use the Delete Keyframe command.

Deleting Keyframes
To delete a keyframe, do one of the following:
‣

Use the Transform

tool to select a keyframe to delete from the trajectory in the Camera view and

press [Delete].

‣

In the Timeline view, click a keyframe, right-click (Windows) or [Ctrl]+Click (Mac OS X) and select
Delete Keyframes, or press [F7].
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‣

From the top menu, select Animation > Delete Keyframe.

Related Topics
•

Modifying a Path in the Camera View on page 969

•

Modifying a Path in the Timeline View on page 981

•

Modifying a Path in the Function View on page 984
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Motion and Stop-motion Keyframes
Interpolation is the computer-generated motion between two keyframes. Some animators and compositors like
to create their own in-betweens, while others like to have the computer do it. Harmony lets you have stopmotion and motion keyframes.
•

Stop-motion Keyframes below

•

Motion Keyframes below

Stop-motion Keyframes
A stop-motion keyframe means there is no computer-generated motion between two keyframes. The segment is
constant or flat.

Motion Keyframes
A motion keyframe means that there is computer-generated motion between two keyframes. The segment has a
variation over time.

Related Topics
•

Switching between Motion and Stop-motion Keyframes on the next page

•

Constant Z on page 958
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Switching between Motion and Stop-motion
Keyframes
You can switch a keyframe from stop-motion to motion at any time in the Timeline view and Function Editor.
To switch between Motion and Stop-Motion in Timeline View:
1. On the right side of the Timeline, select one or more keyframes to be modified.

2. To switch between motion and stop-motion, do one of the following:
‣

Right-click (Windows) or [Ctrl]+Click (Mac OS X)) on the selected keyframes and select Set Motion
Keyframes or Set Stop-Motion Keyframes.

‣

Press [Ctrl] + [K] (Windows/Linux) or [⌘ ] + [K] (Mac OS X) or [Ctrl] + [L] (Windows/Linux) or [⌘ ] + [L]
(Mac OS X).

‣

In the Timeline View toolbar, click the Motion Keyframe

‣

In the Camera view, select the keyframe to convert. In the Coordinates and Control Point view,
select/deselect the Stop-Motion Keyframe option.

or Stop-Motion Keyframe

button.

To swtich between motion and stop-motion keyframes in the Function Editor:
1. Open the Function Editor.
2. In the Timeline view, double-on the layer that contains the keyframes that you want to convert.
The Layer Properties dialog box opens.

3. In the Transformation tab, click the Function Editor

button to display the Editor Window.

OR
1. In the Timeline view, click the Expand Function

button and double-click on the function to edit. Or

press [Alt] + [F].
2. Select one or more keyframes to modify on the Function Curve.
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3. Select or deselect the Stop-Motion Keyframe option to set a stop-motion or motion keyframe.

Setting a Different Colour for Stop-motion and Motion Keyframes
In the Preferences dialog box, you can set a different colour for your stop-motion keyframes in order to create a
greater visual difference in the Timeline view.

To set the stop-motion keyframe colour:
1. Open the Preferences dialog box by pressing [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).
2. Select the General tab.
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3. In the Colours section, click Edit Colours.
4. In the Colours window, select the Exposure Sheet tab.
5. In the Others section, click the Stop Motion Keyframe swatch.
6. In the Select Colour window, select a new colour.
7. Click OK to close the Select Colour window.
8. Click OK to close the Colours window.
9. Click OK to close the Preferences dialog box.

Related Topics
•

Motion and Stop-motion Keyframes on page 955

•

Constant Z below

Constant Z
The Constant Z is used when creating motion keyframes. The Z function will use stop-motion keyframes and will
not be interpolated, this can be very useful for cut-out animation. The Constant Z feature only works with
3Dpaths.
You can also enable the Constant Z option directly in the Function Editor or Function view for specific functions.
To enable the Constant Z option:
1. In the Timeline view, expand the function of the layer you want to set to Constant Z. Note that the 3D
Path option must be enabled for that particular layer.
2. Double-click on the Position function to open the Function Editor.
3. In the Function Editor window, select the Constant Z option.
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Related Topics
•

Switching between Motion and Stop-motion Keyframes on page 956

•

Motion and Stop-motion Keyframes on page 955
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Animating the Camera
Just as in a live-action film, scenes are not only composed of characters moving around in a static camera field,
but also of camera movements. Although it is not always something that we think about, often it is the exact
opposite—the character is static while the camera moves through elements on the stage. Camera pans, jumps,
cuts and zooms are as important to storytelling as the story itself.
Harmony has a camera that can move along the X, Y, and Z axes. Having the camera move on the Z-axis offers
the possibility to create truck in and truck out, as well as multiplane camera moves. The default camera position
is centred and backed up to 12 fields.

Related Topics
•

Basic Camera Move below

•

Animating a Camera Shake using the Quake Module on page 966

•

Camera Truck-ins and Line Thickness on page 967

Basic Camera Move
The camera is treated the same way as any other element. The same tools and selection modes are used to
offset or animate it. To animate the camera, you need to connect it to a peg element.

This means that you can animate the camera visually, with the function curve, or by typing values in the Xsheet
column.
To add a camera with a peg to your scene:
1. If you do not already have a camera layer, do one of the following:
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‣

From the top menu, select Insert > Camera.

‣

From the Timeline view layers toolbar, click the Add Layers

‣

In Harmony, select a Camera module from the Library view and drag it to the Network view.

button and select Camera.

A new camera layer is added to the scene and appears in the Timeline view.
2. From the Timeline View Layer toolbar, click the Add Peg

button.

A Peg layer appears directly above the Camera layer. The Camera layer is automatically attached to it.
The Peg layer automatically takes the name of the camera and adds the suffix -P to indicate that it is a
Peg layer, for example Camera-P.

If the new Peg layer did not appear directly above the camera, you may have clicked elsewhere in the
scene, which deactivated the layer on which you want to add the Peg layer.
‣

Select the Camera layer and drag and drop it under the new Peg layer. Or delete the misplaced Peg
layer, select the Camera layer and click the Add Peg
button again.

‣

In Harmony, you can select a Peg module from the Library view and drag it to the Network view. Then
you can connect the peg’s output port to the camera’s input port.

You are now ready to animate your camera.
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Make use of both the Top and Camera views while making camera moves. You can open this view is one of two
ways:
‣

From the top menu, select Windows > Top.

‣

From any existing window already open in your project, click the Arrow

button at the top-right

corner and select Top.
The Top view appears as a tab in that view.

To animate the camera:
1. Make sure both the Animate

button and the Transform

Tool are activated.

2. In the Top, Side or Camera view, select the camera (the large V-shape on the right side) and move it to the
desired position.
3. In the Camera view, the camera is represented by a thin frame. You need to click directly on one of the
edge.
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4. In the Timeline view, click on a cell in the Camera Peg layer where you would like the camera move to
begin.
5. Right-click (Windows) or [Ctrl]+Click (Mac OS X) and select Insert Keyframe.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera
position as in this keyframe.
6. Click on another cell a bit further down your scene’s Timeline. This is where the camera move will end.
7. Select the camera in the Top view and move it to the desired position.

A second keyframe appears and a line is created between the two frames to indicate that the subsequent
motion between the frames will be calculated and rendered by the program.
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8. Play back

your animation.

You are now ready to animate your camera.
It is recommended to use both the Top and Camera views while making camera moves. You can open this view is
one of two ways:
•

From the top menu, select Windows > Top.

•

From any existing window already open in your project, click the arrow

button in the top-right corner

and select Top.

To animate your camera:
1. Make sure that the Animate

button and Transform

tool are activated.

2. In the Top, Side or Camera view, select the camera and move it to the desired position.
‣

In the Top and Sive view, the camera is the large V cone. You need to click directly on one of the edge.
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‣

In the Camera view, the camera is represented by a thin frame. You need to click directly on one of the
edge.

3. In the Timeline view, click on a cell in the Camera Peg layer where you want the camera move to begin.
4. Right-click and select Insert Keyframe.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera
position as in this keyframe.
5. Click on another cell, further down your scene's Timeline, where you want the camera move to end.
6. Select the camera in the Top view and move it to the desired position.

A second keyframe appears and a line is created between the two frames to indicate that the subsequent
motion between the frames will be calculated and rendered by the program.
7. Play back

the camera move in the Camera view to watch the results.

Related Topics
•

Camera Truck-ins and Line Thickness on page 967

•

Animating a Camera Shake using the Quake Module on the next page
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Animating a Camera Shake using the Quake Module
One very common camera move you will do is a camera shake. You can use the Quake module to generate an
automated quake instead of manually entering random keyframes. This way, can simulate the shock of
something heavy falling on the ground, an earthquake or a strong vibration.
To use the Quake module:
1. From the Module Library view, drag a Quake module and drop it in the Network view.
2. If you do not have a Camera module already, from the Module Library view, select a Camera module and
drop it in the Network view.
3. Connect the Quake module to the Camera module.

4. Click on the Quake module's square yellow button to open the Quake Properties.

5. In the Quake Properties window, adjust the following parameters:
‣

Hold Time: Enter the number of frames you want one of the quake vibrations (position) to hold for.
Most camera shakes are done in a single frame (1) or double frame (2).

‣

Interpolate: When this option is enabled, the system will generate an interpolation between the
random values. Instead of jumping to the next position, it will slowly progress forwards to the next
position. It is the same principle as Stop-motion keyframes and Motion keyframes.

‣

Move Amplitude: This is the strength of the quake. The higher the value, the stronger the quake. If
the value is set to 0, there will not be any motion. To have the motion start and stop at a specific frame
during the scene, you can create a function curve and animate the amplitude over time. Simply click on
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the Function button to generate the function, then click on it again to open the Function Editor.

‣

Apply on X: When this option is enabled, the quake will be applied to the X-axis.

‣

Apply on Y: When this option is enabled, the quake will be applied to the Y-axis.

‣

Apply on Z: When this option is enabled, the quake will be applied to the Z-axis.

‣

Rotation Amplitude: When the value is higher than 0, a rotating quake will be applied. The higher the
value, the stronger the quake will be.

‣

Random Seed: Generates a different randomization pattern. If you cascade two Quake modules or
more to apply a different amplitude on different axis, you can change the Random Seed value to
generate a different randomization pattern. If your X quake has a strong amplitude and your Y quake a
weak amplitude and you don't want them to follow the same random pattern, then set the Random
Seed value of your Quake modules to different numbers.

Related Topics
•

Basic Camera Move on page 960

•

Camera Truck-ins and Line Thickness below

Camera Truck-ins and Line Thickness
As you move the camera into your scene along the Z-axis, you may notice that the lines of your elements which
were drawn with pencil lines instead of brush strokes appear too thick. There is a simple way to taper down the
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pencil line thickness while performing a camera zoom-in.
To adjust the pencil line thickness of a particular drawing in the Camera view:
1. In the Timeline view, double-click on a drawing layer to bring up the Layer Properties panel.
2. Select the Advanced tab.
3. Under the Line Thickness section, adjust some of the following parameters until you achieve the desired
effect.

‣

Adjust Pencil Lines Thickness: Checking this option allows for the adjustment of pencil lines thickness
and activates the adjustable parameters in this section.

‣

Normal Thickness: This is the default option and when it is the only selection, negates the adjustable
parameters and keeps the line thickness at their original proportions to the camera position. In
general, it is good to keep this option checked. If you uncheck this option, all your pencil lines will
disappear if you have nothing on the colour art layer. If you do have artwork on the colour art layer,
your lines will be replaced by the colour art.

‣

Zoom Independent Thickness: Checking this option will keep all lines at their default thickness
regardless of the camera zoom. This may create the illusion as the camera zooms-in that the lines
become thinner, when in fact they have remained the same thickness.

‣

Proportional : This parameter is set to 1 by default. All pencil line thickness in the scene will be
multiplied by the value entered in this field. For example, if the value entered is 2, then a pencil line
thickness of 5.5 will become 11, while a pencil line thickness of 21.7 will become 43.4.

‣

Constant: This parameter is set to 0 by default. Changing the value is this field will multiply the line
thickness by the pixel portion of the camera frame.

‣

Minimum: Enter a value into this field or use the arrows to set a minimum line thickness that cannot be
exceeded.

‣

Maximum: Enter a value into this field or use the arrows to set a maximum line thickness that cannot
be exceeded.

This feature can only be viewed in the Camera view's render mode.

Related Topics
•

Function Drop-down Menu on page 997

•

Function Types on page 998
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Modifying a Path in the Camera View
Although the example in the Animating the Camera section seems simple enough, camera moves and motion
paths can become complex, especially with moves through 3D space. That is why Toon Boom has developed a
way to view your camera’s path and make adjustments to it from both a 2D and 3D perspective.

Related Topics
•

Displaying a Path in the Camera View below

•

Shaping a Path on page 971

•

Offsetting a Trajectory on page 979

Displaying a Path in the Camera View
You can display the trajectory of a motion path when you select an object in the Timeline or Camera view.
If you want to see the trajectory, enable the Show Control Points on Selected Layers preference.
To enable the Show Control Points on Selected Layers preference:
1. In the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X) or press
[Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).
The Preferences dialog box opens.
2. Select the Camera tab.
3. In the Control Points section, enable the Show Control Points on Selected Layers preference.

4. Click OK.
If the trajectory is hidden when you select an element, you may want to display it using the Control command.
To view the layer’s trajectory using the Control command:
1. Verify that the Camera view (click its tab) is selected and that the layer whose trajectory you want to
display is selected in the Timeline view.
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2. From the top menu, select View > Show > Control or press [Shift] + [F11].

If nothing appears in the Camera view, you may not have animated or selected the layer.
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To hide the layer’s trajectory:
1. Verify that the Camera view (click on its tab) is selected and that the layer that you wish to hide the
trajectory of is selected in the Timeline or Camera view.

2. From the top menu, select View > Show > Control or press [Shift] + [F11].
3. If you want to hide all trajectories without selecting any layer, select View > Hide All Controls or press
[Shift] + [C].

Related Topics
•

Shaping a Path below

Shaping a Path
A motion path is as easy to manipulate as shaping the vector points of a drawing layer in the Camera view. One
important concept to understand is that a trajectory contains both keyframes and control points. Both can be
used to shape a path, each have their own significance and behaviour, however only keyframes appear in the
Timeline view.
•

Keyframe: A marker that signifies a change (size, position, direction, etc.) along the normal of a path or
function, and has an exact position and frame.

•

Control Point: Has a position but no fixed frame or timing. It is mainly used to deform a trajectory. There
are no velocity handles available on a control point. The velocity segments are set between keyframes
only, making curves and trajectories much smoother. Control points can only be added on a 3D path.

To resize an entire animation path so it fits into your scene's composition better, convert the
animation into a Symbol, then resize the Symbol itself.
Refer to the Library on page 625 chapter to learn how to create and import Symbols.

You can edit keyframes and control point parameters, such as the position, continuity, bias, tension and lock-intime using the Coordinates and Control Point view.
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Coordinates and Control Points View
Each time a keyframe or a control point is selected in the Camera, Timeline or Xsheet view, its parameters
appear in the Coordinates and Control Points view. You can also see the same information in the Coordinate and
Control Point toolbars.

Adding Control Points
A control point has a position but no fixed frame or timing. It is mainly used to deform a trajectory. There are no
velocity handles available on a control point. The velocity segments are set between keyframes only, making
curves and trajectories much smoother.
A control point will not show in the Timeline view because it has no precise frame on which to be displayed. It
appears on the function curve and in the Camera view. There are different ways to add control points:
•

Display the trajectory in the Camera view and press [P].

•

Add a keyframe on the function curve and deselect the Lock in Time option.

The control point is displayed as a circle.
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You can display your trajectories in the Camera, Top and Side views to better understand the way the elements
move in your scene. This also makes it easier to modify them. You can display a peg or layer’s controls to see
where your elements are going, modify the curve, and add keyframes and control points.
To add a control point on a trajectory:
1. In the Timeline or Camera view, select the peg or layer on which you want to add a control point.
2. If the selected element’s trajectory is not displayed, select View > Show > Control in the top menu or
press [Shift] + [F11].
The Trajectory appears in the Camera, Top, Side and Perspective views.

3. Add control points on a 3D path trajectory by placing the cursor where you want to add the point and
pressing [P].

Switching between Keyframe and Control Points
To switch between keyframe and control Points:
1. In the Camera view, using the Transform tool

to select a point to convert.

2. To convert the point:
‣

In the Coordinates and Control Point view, enable or disable the Locked in Time option.
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‣

In the top menu, select Animation > Lock in Time or press [Alt] + [L].

‣

In the Function view or Function editor, select the keyframe to convert and click the Lock in Time
button.

Related Topics
•

Adjusting the Tension, Bias and Continuity below

•

Modifying a Path in the Camera View on page 969

Adjusting the Tension, Bias and Continuity
You can edit keyframes and control point parameters, such as the position, continuity, bias, tension, and lock in
time using the Coordinates and Control Point view.
Each time a keyframe or control point is selected in the Camera, Timeline or Xsheet view, its parameters appear
in the Coordinates and Control Point view. You can also see the same information in the Coordinate and Control
Point toolbars.
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You can adjust these parameters on existing control points and keyframes by selecting the point in the Camera
view with the Transform
tool.
•

Continuity controls the smoothness of a transition between the segments joined by a point.

•

Tension controls how sharply the path bends as it passes through a control point or keyframe.
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•

Bias controls the slope of the path so that it flows towards one side of the motion point or the other.

To adjust the Continuity, Tension and Bias parameters:
1. In the Tools toolbar, select the Transform

tool.

2. In the Timeline view, select the layer that contains the parameters you want to adjust.

3. In the top menu, select View > Show > Control or press [Shift] + [F11] to display the trajectory.
4. In the Camera view, select a control point or keyframe.

5. In the Coordinates and Control Points view, adjust the Continuity, Tension and Bias parameters.
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If you find that you are using the same Continuity, Tension and Bias settings, you can set a preference to
remember your settings.
If you find that you are using the same Continuity, Tension and Bias settings, you can set a preference to
remember your settings.
To adjust the control point preferences:
1. From the top menu, select Edit > Preferences (Windows) or Harmony > Preferences (Mac OS X).
The Preferences dialog box opens.
2. Select the Camera tab and adjust the parameters in the Controls Points section.

Toggling between a Linear or Curved Motion
When you select a control point on a path, you can toggle between a rounded or square corner by using the
Linear/Curve command.
To toggle between a linear or curved corner:
1. In the Tools toolbar, select the Transform

tool.

2. In the Camera view, select the point to convert.
3. In the top menu, select Animation > Linear/Curve.
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Related Topics
•

Shaping a Path on page 971

Cumulative Z Value
You can see the cumulative Z Value information in the Coordinates and Control Points view. When you select a
drawing cell including a keyframe, it will display the Cumulative Z value.
When a layer is parented to other layers that are moved forward or backward on the Z-axis, the currently
selected layer's position Z value may not be accurate since its parent will also have an offset on the Z-axis. The
Cumulative Z value is a compilation of all the Z-axis offsets to give the real Z-axis offset value related to the (0,0)
centre.
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Related Topics
•

Shaping a Path on page 971

Offsetting a Trajectory
To reposition the visual trajectory to a more convenient location, you can use the Spline Offset tool.
Offsetting your trajectory will not offset or modify your animation. It will facilitate your work.
To offset a spline/trajectory:
1. In the Animation Tools toolbar, select the Spline Offset

tool or press [Alt] + [9].

2. In the Camera or Timeline view, select the layer to be offset.
3. In the top menu, select View > Show > Control to display the trajectory. If you do not display the
trajectory, the transformation done using the Spline Offset tool will be ignored.
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4. In the Camera view, move the trajectory to the proper position. You can move it on the X and Y axes, but
also on the Z-axis using the Top and Side views.

Related Topics
•

Modifying a Path in the Camera View on page 969
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Modifying a Path in the Timeline View
When you select a peg or drawing layer in the Camera view and move it around, Harmony will automatically
create the corresponding function curves. If you want to modify these curves, you can always do it through the
Peg or Layer parameters in the Timeline view.
•

Creating a Function below

•

Adding and Deleting Keyframes in the Timeline View below

•

Changing Keyframe Values on the next page

•

Flipping Between Keyframes on page 983

Creating a Function
To create the function curve in the Timeline view:
1. Double-click a drawing or peg layer.
The Layer Properties dialog box opens.
2. Identify the section of the type of function that you want to create.
3. Click the arrow at the end of the corresponding row and select Create Bézier or Create Ease.

Adding and Deleting Keyframes in the Timeline View
To add a keyframe:
1. On the right-hand side of the Timeline, select a cell on the layer’s function that you want to animate.

2. Right-click (Windows) or [Ctrl]+Click (Mac OS X) the selected cell and select Insert Keyframe or press
[F6].
To delete a Keyframe:
1. On the right side of the Timeline, select a cell that contains the keyframe you want to delete. You can
[Shift]+click several keyframes to select a group before deleting the keyframes.
2. Right-click (Windows) or [Ctrl]+Click (Mac OS X) on the selected keyframe and select Delete Keyframes.
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If you select a keyframe or group of keyframes and press [Delete], it will also delete the
corresponding drawings on that cell.

Changing Keyframe Values
To change the keyframe values in the Timeline:
1. Open the layer’s parameters by clicking the Expand

2. Click the Show/Hide Data view

button or press [Alt] + [F].

button at the top of the Timeline view, between the layer names and

timeline fields.

3. Select the parameter that you want to create a function curve for: Path, Velocity, Scale; x or y, Angle, or
Skew. For this example, we will use Velocity.
4. Pass the cursor over the blue number value of the parameter layer being modified.
‣

Wait until the cursor changes to a white hand with a two-way arrow and then drag the hand slightly to
the left or right to decrease or increase the value.

OR
‣

Click directly on the blue number and enter a value into the field that appears.
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‣

If you selected the keyframe in the Camera view, you can modify the values in the Coordinate and
Control Points view.

A function automatically is created as soon as the values have changed from zero.
In Harmony, you can see the same information in the Coordinates and Control Points view.
5. Play back

your animation.

Flipping Between Keyframes
Harmony lets you flip between the selected layer's keyframes.
To flip through your poses:
1. In the Camera or Timeline view, select the layer that contains the keyframes you want to see.

2. In the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe or press [;] and
['].

Related Topics
•

Function Types on page 998

983

Chapter 16: Animation Paths Modifying a Path in the Function View

Modifying a Path in the Function View
If you are used to graphs and function curves, you can use the Function view to define your trajectories.

Related Topics
•

Function View below

•

Editing a Function in the Function View on page 986

•

Adding and Deleting Keyframes in the Function View on page 986

•

Changing a Keyframe's Values on page 988

Function View
While editing the X function of this 3D motion path, you can see the graphs for the Y, Z and velocity.

The Function view allows you to display multiple functions in the background as a reference. While you are
editing one function, you can see other selected functions, this helps you synchronize changes in one function
with other functions.
You can set the orientation of the Function view to be vertical (portrait) or horizontal (landscape).

‣ In the Function View menu, select View > Set Vertical Layout/Set Horizontal Layout.

984

Toon Boom Harmony 10.3 Stage User Guide

To display a function in the Function view, click its name in the Timeline view. You can also display several
functions in the Function View.
To display functions in the Function view:
1. Open the Function view.
The Function view is blank until you select the functions you want to display.
2. Click on the Function

button and scroll down the list of available functions. Click the checkbox next

to the function name to display it in the view.

‣

To display a function in the Function view, click its name in the Timeline view.

3. To select the function you want to edit, select its name from the function drop-down menu.
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Related Topics
•

Editing a Function in the Function View below

Editing a Function in the Function View
The graph displays the motion over the first and last keyframes set in the scene, as well as any keyframes created
between. If the scene is 60 frames, but the character's motion ends at frame 40, then the editor will only display
up to frame 40.
To edit a function in the Function view:
1. In the graph of the Function editor, select one of the white keyframes. If selected properly, the keyframe
turns red and displays a pointed yellow handle.
2. Click and drag the point either up or down or click and pull one of the handles to adjust the curve of the
graph.

In this case, changing the velocity from a straight line (constant velocity) to a curved one, changes the
ease-in (where the curve shoots up and then flattens-out) and ease-out (where the curve flattens-out and
then shoots up) values.
The centre keyframe can not be dragged up or down because the velocity is set. Theoretically dragging it
downwards towards zero would put it back to a place of non-movement.
3. Press the [Enter/Return] key with the Parameter window still open to watch the result of your curve
adjustment in the Camera view.

Related Topics
•

Adding and Deleting Keyframes in the Function View below

Adding and Deleting Keyframes in the Function View
If you want to change a parameter between two motion keyframes in the Timeline view, such as the scale, you
can do so by adding keyframes in the Scale editor.
To add or remove keyframes in the parameter editor:
1. Open the layer parameters by clicking the Expand Function
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2. Select the parameter that you wish to create a function curve for: Path, Velocity, Scale: x or y, Angle or
Skew. For this example we will use Scale: x.
3. Double-click on the parameter layer name to open the Function editor window or click once on the
parameter layer to display it in the Function view.

4. In the graph section, click on the frame number where you would like to make changes or in the Point
section, enter the frame number directly into the Frame field.
In the graph section, a vertical blue line will indicate the frame number selected.
5. Click the Add/Remove Keyframes

button.

6. Click on the newly created keyframe and drag it up (to decrease the width of the object) or down (to
increase the width of the object) or pull on the handles to create a smooth fluctuation of the drawing
object's width.
7. If you do not like the changes made, you can delete the new keyframe by selecting the keyframe, if it is not
already selected, and press the [Delete] key, or by clicking on the Add/Remove Keyframes
button.
You can delete an already existing keyframe by using the same process.

Related Topics
•

Modifying a Path in the Function View on page 984

987

Chapter 16: Animation Paths Modifying a Path in the Function View

Changing a Keyframe's Values
In the example cited above, once a keyframe is created, it can be moved and its handles manipulated to change
the shape of the curve. Once a keyframe is manipulated it's value changes. This value is displayed in the Value
field of the Point section in the Function editor.
However, it is possible to work the other way around; it is possible to enter values into the Value field and watch
the keyframe change position and the curve along with it.
To change a keyframe's value:
1. Open the peg element's parameters by clicking on the Plus

sign next the peg layer's name.

2. Select the parameter that you wish to create a function curve for: Path, Velocity, Scale: x or y, Angle or
Skew. For this example we will use Scale: y.
3. Double-click on the parameter layer name to open the Editor window or click once on the parameter layer
to display it in the Function view.

4. In the Point section, enter a value in the Value field or drag up or down the keyframe you want to modify.
5. Press [Enter/Return] or click the Play

button to view the changes made in the Camera view.

6. Keep adjusting your values accordingly, until you are satisfied with what you see.
7. Click Close.
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Related Topics
•

Adding and Deleting Keyframes in the Function View on page 986

989

Chapter 16: Animation Paths Modifying a Path in the Xsheet View

Modifying a Path in the Xsheet View
If you are used to working with the Exposure Sheet, you can also create keyframes and type values in the Xsheet
view.
You cannot create function curves directly in the Xsheet view. You must do this in either the Layer Properties
editor or the Timeline view.
To edit a function column in the Xsheet view, you must first display the Functions section of the Xsheet view and
then select the layer you want to modify.
To display the function columns in the Xsheet view:
1. In the Xsheet view, click on the Expand Function Section button.
2. In the Timeline view, select the layer containing the parameters to modify.
The columns appear in the Xsheet view.

To add a keyframe in the Xsheet view:
1. In the Xsheet view, go to the function column where you want to add a keyframe.

2. Double-click on the cell where you want to add a keyframe and type a numeric value.
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3. Click on [Enter/Return] to continue to the next cell.
4. Click on [Esc] to exit the typing mode.

To convert a cell into a keyframe:
1. In the Xsheet view, go to the function column where you want to add a keyframe.
2. Select the cell to convert.

3. Right-click on the cell and select Set Selection As Keyframe or press [F6].

‣

If you want to remove a keyframe, select the keyframe,right-click on the cell and select Clear
Keyframe in Selection or press [F7].

If you double-click on a function column's header, you will display the corresponding function curve in the
Function editor.

Related Topics
•

Modifying a Path in the Timeline View on page 981
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Function Curves
By default, when a drawing or peg is added to the scene, no function curve is created. You will generally create
the ones needed to avoid having an overload of useless functions.
When you select an element in the Camera view and move it around, it will automatically create the
corresponding function curves.
If you need to create certain functions manually, you can always do it through the Layer Properties view or
editor.
You can also link a layer's parameter to an existing function curve.

Related Topics
•

Creating Function Curves below

•

Sharing Functions on page 994

•

Function Drop-down Menu on page 997

•

Function Types on page 998

Creating Function Curves
You can manually create a function in the Layer Properties view or the Layer Properties editor. You can either
share it with other layer's parameters or to set your keyframes directly on the function curve instead of the
Timeline or Camera view.
To create the function curves for your project:
1. To open the Layer Properties editor, in the Timeline view, double-click on the layer or click once to
display it in the Layer Properties view.

The Layer Properties editor opens.
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2. Select the Transformation tab.
3. Click the Function Arrow

button beside the local function information.

4. Create a 3D Path, Bezier, Ease or Velobased curve.
‣

You can also create an Expression column. Refer to the Expression Columns on page 1017 section to
learn more.

You can click on the Function

button to open the Function editor.

5. Click OK.

Related Topics
•

Function Types on page 998
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Sharing Functions

You can hook several parameters to the same function curve. For example, if you have an aircraft performing
loops between clouds, you may want the camera to follow the aircraft's motion path. If you attach the camera to
the aircraft's layer, the camera will also loop, but this may produce undesirable results and even induce a feeling
of motion sickness as you watch the final animation. Instead, what you can do is to share the X, Y and Z aircraft's
position with the camera's peg layer, but ignore the angle. scale and skew.
By default all the function curves you create are private. This means that the function curves can only be used and
modified using their original parameter. If you want another layer or parameter to use the same function curve,
you must make the function public.
There are two ways to share a function:
•

Share Functions command

•

Layer Properties Editor

To share a function using the Share Functions command:
1. In the Timeline view, select the function layer to share.

2. Right-click on the selection and select Share Functions.
The function now becomes public to the other layers and parameters and can be shared.
Public functions are visible in the main section of the Xsheet view.
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3. In the Timeline view, open the Layer Properties editor of the layer with the parameters you want to link
to the public function.
4. To open the Layer Properties editor, in the Timeline view, double-click on the layer containing the
function to share or click once to display it in the Layer Properties view.

The Layer Properties Editor opens.
5. Select the Transformation tab.
6. Click the Function Arrow

button beside the function you want to link to the function column.

7. In the drop-down menu, select the function you just turned public from either, the 3D Path, Bezier, Ease,
Velobased, Expression, 3D Path, Connected, Unconnected, All menu, and hook it to your parameter.

The two parameters are now both linked to the same function curve and should follow the same path. If
you modify the curve, both parameters will update.
To share function curves:
1. To open the Layer Properties editor, in the Timeline view, double-click on the layer containing the function
to share or click once to display it in the Layer Properties view.
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The Layer Properties Editor opens.
2. Go to the Transformation tab.
3. Click on the Function Arrow

button beside the function to share.

4. In the drop-down menu, select the Local option.
5. Click on the Function Arrow
drop-down list.

button beside the Function field and choose an existing function from the

The function now becomes public to the other layers and parameters and can be shared.
Public functions are visible in the main section of the Xsheet view.

6. In the same drop-down menu, where you choose the Local option, select the function you just turned
public from either the 3D Path, Bezier, Ease, Velobased, Expression, 3D Path, Connected, Unconnected,
All menu and hook it to your parameter.
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7. In the Timeline view, open the Layer Properties editor of the other layer you want to link its parameter to
the public function.
8. In the Layer Properties editor or view, hook the parameter to the public function the same way you did for
the first layer.
The two parameters are now both linked to the same function curve and should follow the same path. If
you modify the curve, both parameters will update.

Related Topics
•

Function Drop-down Menu below

Function Drop-down Menu
When you create a function curve in the Layer Properties view or editor, you have several choices available:
•

Create 3D Path: Creates a new 3D Path Column set

•

Create Bezier: Creates a new Bezier curve

•

Create Ease: Creates a new Ease curve

•

Local: Disconnects the parameter from any function and turns it public

•

3D Path: Displays the list of every public 3D Path function available

•

Bezier: Displays the list of every public Bezier curve available

•

Ease: Displays the list of every public Ease curve available

•

Velobased: Displays the list of every public velocity based curve available

•

Expression: Displays the list of every public Expression function available

•

3D Rotation: Displays the list of every public 3D Rotation function available

•

Connected: Displays the list of every public connected function curve

•

Unconnected: Displays the list of every public unconnected function curve

•

All: Displays the list of every public function curve

The user has the choice of creating a new function curve or linking it to an already existing public one. This way,
he can have two or more parameters following the same function.

Related Topics
•

Function Types on the next page
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Function Types
Depending of your favourite working method, you can create different types of function curves to suit your need.
You have several choices available:
•

Ease and Bezier Functions below

•

Velobased Functions below

•

Converting Ease and Bezier Functions on the facing page

Ease and Bezier Functions
When you create a function to control a parameter over time (Scale, X, Y, Z, Rotate), you have the choice of an
Ease or Bezier function.

These function editors present different ways of editing the values over time. The shape of the created graph
indicates the velocity of the function, regardless of the chosen editor. The type of function that you choose is
largely based on your own working preference.
With the Ease editor, you can edit the shape of the function curves using the ease-in and ease-out controls. You
may choose to use this type of function if you are used to working with ease-in and ease-out values.

Velobased Functions
You can also create Velobased functions for certain effects, like changes in rotation or size over time. In these
cases, the Velobased functions are linked to the velocity of a 3D path. You cannot change the shape of a
Velobased function to control its velocity.
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With Velobased functions, you can link changes in rotation or scaling to the velocity of a 3D path. This makes it
possible for changes in rotation or scaling to progress at the same speed as changes to the position of an
element.

Converting Ease and Bezier Functions
To convert Ease and Bezier functions so that you can edit them using the controls offered by that editor.
To convert Ease and Bezier functions:
1. In the Xsheet view, if not done yet, show the function columns.
2. In the Xsheet view, click on the Expand button located on the right side of the main section to show the
Functions section. Click on the same button to collapse it. You can also use the Show Column List
button in the Xsheet View toolbar.

3. Click the Expand button on the right side of the Functions section to display the Column List section.

4. In the Timeline view, click the layer you want to display the function columns from.
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5. In the Xsheet view,right-click the column's header and select one of the following from the Convert menu:
‣

Convert the column: The values of multiple effects may be linked to the original column. When you
use the Convert the Column command, all links to the original column will transfer to the new
converted column.

‣

Create a new column and update links: Creates a new function from the original. All links to the
original column will transfer to the new column. The original function column will remain in the
exposure sheet in case you decide you want to switch back to it.

‣

Create a new unused column: Creates a new column based on the values in the original column and
leaves all links pointing to the original column. You can use this command to experiment with various
functions and then link effect values to the new function curve column.

Related Topics
•

Function Curves on page 992
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Copying and Pasting a Motion
In the Timeline view, you can easily drag keyframes to change the animation timing, delete them, cycle them and
even copy them.
When you have position keyframes set in your drawing layer and you want to move them around with moving
your drawing's timing, you can use the Paste Special feature to only move the keyframes selected.
You can also use the Paste Cycle and Paste Reverse feature to cycle your selection including keyframes and
drawings.
•

Paste Special below

•

Paste Special Dialog Box on the next page

•

Pasting Cycles on page 1007

Paste Special
To copy and paste a motion:
1. In the Timeline view, select the keyframes, to copy and paste. If you want to move the keyframes, move on
to step 3.

2. In the top menu, select Edit > Copy.
3. To edit your selection:
‣

To paste the selection, in the Timeline view, select the first cell where you want to paste your
keyframes and in the top menu, select Edit > Paste Special.

‣

To move the selection, in the Timeline view, drag the selection and hold down [Alt] (Windows/Linux)
or [⌘ ] (Mac OS X). Drop the selection where you need it before releasing the hot key.

The Paste Special window opens.
4. Set the Drawing, Pegs and Functions, and Cycles parameters. and

5. Click OK.
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Paste Special Dialog Box
To open the Paste Special dialog box:
1. In the Library view, select the symbol or template to import.
2. While dragging the selection to the Timeline view, hold down the [Alt] (Windows/Linux) or [⌘ ] (Mac OS
X).

Drop the selection in the Timeline view before releasing the hot key.

The Paste Special window opens.
3. Set the parameters.
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Paste Special - Basic Tab

Drawings
•

Only create drawing files when they do not exist: When adding exposures to a drawing layer, new
drawings will be created only when drawings with the same name do not already exist in the destination.

•

Always create drawing files: When adding exposures to a drawing layer, new drawings will always be
created. If drawing files with the same name already exist, Harmony will create a new name for the
drawing.

•

Extend Exposure: Extends the exposure of drawings to fill the range of cells to the destination frame.

•

Paste all Frames of the Symbols (full movie): When enabled, the Paste Special command will expose all
the Symbol's frames instead of the first one only.

Cycle
•

Number of Cycles: Use the up and down arrows to increase or decrease the number of cycles you want to paste.
You can also type the value directly in the field.

•

Cycle Type
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•

Normal (forward): This pastes your selection as it is, starting with the first cell and ending with the last
one.

•

Reverse: This pastes your selection in reverse, starting with the last cell and ending with the first one.

•

Forward -> Reverse: This pastes your selection as a yo-yo, starting with the first cell, going to the last
one and ending with the first cell.

•

Reverse -> Forward: This pastes your selection as a reverse yo-yo, starting with the last cell, going to
the first one and ending with the last cell.

Paste Special - Advanced Tab

Drawings
•

Do Nothing: Does not create or overwrite drawings.

•

Update Drawing Pivot: Revises the drawing pivot in the destination to use the same drawing pivot as the
first drawing in the template. If you have a range of drawings selected in the destination, the pivot points
of all selected drawings will be updated.

•

Add/Remove Exposure: Creates/deletes exposure values in the selected layer.
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You have the following choices as to how to treat drawings that will be created when adding an exposure:
•

Never create drawing files: When adding exposures to a drawing layer, drawing files will not be
created.

•

Only create drawing files when they do not exist: When adding exposures to a drawing layer, new
drawings will be created only when drawings with the same name do not already exist in the
destination.

•

Always create drawing files: When adding exposures to a drawing layer, new drawings will always be
created. If drawing files with the same name already exist, Harmony will create a new name for the
drawing.

•

Extend Exposure: Extends the exposure of drawings to fill the range of cells to the destination frame.

•

Key Drawing Mode (Substitution): Pasting an exposure value replaces the cell value in the current
frame and in all frames following in sequence with the original cell value.

•

Paste all Frames of the Symbols (full movie): When enabled, the Paste Special command exposes all
the Symbol's frames instead of only the first one.

Add/Remove Keyframes
•

Motion: Copies the properties of the selected motion keyframe to the new frame.

•

Velocity: Copies the properties of the selected velocity keyframe to the new frame.

•

Rotation: Copies the properties of the selected rotation keyframe to the new frame.

•

Skew: Copies the properties of the selected skew keyframe to the new frame.

•

Scale: Copies the properties of the selected scale keyframe to the new frame.

•

Force Keyframes at Function's Beginning and End: Adds a keyframe to the beginning and end of the
pasted function, reproducing the source function.

•

Offset Keyframes: When pasting functions, this option offsets the keyframes from the function's last
value by the values in the pasted function. This will continue the progression of a function rather than
repeat the values.

Option
•

Palette Option
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•

Do nothing: Does not create, overwrite, merge or link palettes.

•

Reuse palettes. Copy palettes if they do not exist: Palettes in the destination drawings are left as
they are.

•

Copy and overwrite existing palettes: Overwrites destination palettes with the palettes from the
source drawings.

•

Copy and create new palette files: Creates new palette files, placing them at the same relative
environment and scene level as the source. If the palettes in the templates were stored at the
environment level of the source scene, the paste operation will place the palettes in the environment
level of the destination scene.

•

Copy and create new palette files in element folder: Creates new palette files in the element folders
of the destination scene, rather than in the same relative job or environment.

•

Copy palette and merge colours. Add new colours only: Adds new colours to the destination
palettes and ignores colours that are the same in the two palettes.

•

Copy palette and update existing colours only: Adds new colours to the destination palette and
updates duplicate colours in the destination with colour values from the source.

•

Link to original palettes (colour model): Links the colour palettes in the destination scene to the
palettes in the source. Use this to link drawings to the palettes in a colour model.

•

Copy scene palettes and merge colours. Add new colours only: Adds new colours to the
destination scene palettes and ignores colours that are the same in the two palettes.

•

Copy scene palettes and update existing colours: Adds new colours to the destination scene palette
and updates duplicate colours in the destination with the colour values from the source.

•

Duplicate All Symbol Content: Instead of linking the Symbol instance to the original one, the Symbol will
be duplicated. A new Symbol is created in the Library.

•

Symbols

•

•

•

Copy symbols if they do not exist: This is the default setting for this operation and will prevent
Symbols in a Action template from being copied.

•

Duplicate symbols: Creates a duplicate of the Symbol instead of linking the Symbol instance to the
original one. The new Symbol is created in the Library.

•

Overwrite symbols: If a modification was made to a Symbol that does not exist in the basic rig
template for a character, select this option to overwrite the previous Symbol.

Cycles:
•

Cycle Types:

•

Normal (forward): This pastes your selection as it is, starting with the first cell and ending with the last
one.

•

Reverse: This pastes your selection reversed, starting with the last cell and ending with the first one.

•

Forward -> Reverse: This pastes your selection as a yo-yo, starting with the first cell, going to the last
one and ending with the first cell.

•

Reverse -> Forward: This pastes your selection as a reverse yo-yo, starting with the last cell, going to
the first one and ending with the last cell.

•

Number of Cycles: Use the up and down arrows to increase or decrease the number of cycles you
want to paste. You can also type the value directly in the field.

Modules: Create New Columns: If you enable this option a new column will be created when you copy
and paste modules from the Network view or Layer in the Timeline view. If the layers are linked to function
curves, the function curves, the drawings and the timing will be duplicated.
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Related Topics
•

Pasting Cycles below

Paste Special
To copy and paste a motion:
1. In the Timeline view, select the keyframes, to copy and paste. If you want to move the keyframes, move on
to step 3.

2. In the top menu, select Edit > Copy.
3. To edit your selection:
‣

To paste the selection, in the Timeline view, select the first cell where you want to paste your
keyframes and in the top menu, select Edit > Paste Special.

‣

To move the selection, in the Timeline view, drag the selection and hold down [Alt] (Windows/Linux)
or [⌘ ] (Mac OS X). Drop the selection where you need it before releasing the hot key.

The Paste Special window opens.
4. Set the Drawing, Pegs and Functions, and Cycles parameters.

5. Click OK.

Related Topics
•

Pasting Cycles below

Pasting Cycles
If you want to cycle a portion of your animation, you can use the Paste Cycle command. You can also use the
Paste Reverse command to completely reverse the flow of your animation.
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To cycle a portion of an animation:
1. In the Xsheet or Timeline view, select the cell range and keyframes to loop.
2. From the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell on which you want your cycles to start.

4. From the top menu, select Edit > Paste Cycle or press [Ctrl] + [/] (Windows/Linux) or [⌘ ] + [/] (Mac OS X).
The Paste Cycle dialog box opens.

5. In the Number of Cycles field, increase or decrease the number of cycles you want to paste.
6. In the Cycle Type, select the type of cycle you want to paste.

‣

Normal (forward): Pastes your selection as it is, starting with the first cell and ending with the last.

‣

Reverse: Pastes your selection reversed, starting with the last cell and ending with the first.

‣

Forward > Reverse: Pastes your selection as a yo-yo, starting with the first cell, going to the last one
and ending with the first cell.

‣

Reverse > Forward: Pastes your selection as a reversed yo-yo, starting with the last cell, going to the
first one and ending with the last cell.

To reverse the animation flow:
1. In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.

2. From the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell on which you want your cycles to start.
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4. From the top menu, select Edit > Paste Reverse or press [Ctrl] + [.] (Windows/Linux) or [⌘ ] + [.] (Mac OS
X).

Related Topics
•

Copying and Pasting a Motion on page 1001
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Adjusting the Ease
To add ease in and ease out on your motion paths, you can display the function curve and modify the Bezier or
Ease curve. To apply an ease to multiple functions and keyframes, you can use the Set Ease For Multiple
Parameters script and set the amount desired.
The Velocity, or ease, is used on motion keyframes. The Velocity has to be adjusted directly on the function curve
in either the Function view or the Function editor. When a keyframe is selected, easing values appear in the right
handle and left handle fields, as well as Bezier handle or Ease wheel controls on each selected keyframe. Pull on
them to adjust the ease in and ease out, or type values in the fields.

Related Topics
•

Displaying the Velocity Curve below

•

Reshaping a Velocity Function using Bezier Controls on the facing page

•

Reshaping a Velocity Function using Ease Controls on page 1012

•

Creating a Stepped Velocity on page 1013

•

Adjusting the Velocity of Several Layers at the Same Time on page 1014

Displaying the Velocity Curve
To display the velocity curve:
1. In the Timeline view, click the Expand

button on a layer or press [Alt] + [F] to display the layer’s

functions.

2. Double-click the desired function.

The Function Editor opens.
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The editor will not be displayed if the function does not already exist. You can reshape the function using
either the Bézier or Ease controls.

Related Topics
•

Reshaping a Velocity Function using Bezier Controls below

•

Reshaping a Velocity Function using Ease Controls on the next page

•

Creating a Stepped Velocity on page 1013

•

Adjusting the Velocity of Several Layers at the Same Time on page 1014

Reshaping a Velocity Function using Bezier Controls
You can reshape the velocity function using Bezier controls.
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You can reshape the function using either the Bezier or Ease controls.
To reshape a function using Bézier controls:
1. Select a keyframe.
2. Drag the handles to modify the shape of the curve.
3. The Continuity options influence how you can move the handles:
‣

Straight: Lets you move the handles together, maintaining the same angle to the point.

‣

Corner: Lets you move the handles independently.

‣

Smooth: Lets you move the handles together, maintaining the same distance and angle to the point.

Related Topics
•

Displaying the Velocity Curve on page 1010

•

Reshaping a Velocity Function using Ease Controls below

•

Creating a Stepped Velocity on the facing page

•

Adjusting the Velocity of Several Layers at the Same Time on page 1014

Reshaping a Velocity Function using Ease Controls
You can reshape the velocity function using Ease controls.
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To reshape the function using Ease controls:
1. Click on the keyframe to select it.
2. To set the number of frames in the ease-in, press [Alt], click to the right of the keyframe and drag the
green line. The ease in slope is indicated in blue.
As you change the values visually, the value in the Ease In field is updated. This value represents the
number of frames in the ease-in.
3. To set the number of frames in the ease-out, press [Alt], click to the left of the keyframe and drag the
green line. The ease out slope is indicated in red.
As you change the values visually, the value in the Ease Out field is updated. This value represents the
number of frames in the ease-out.
4. To adjust the ease-in or ease-out, drag the handles around the keyframe.
The Continuity options, Corner and Straight, influence how you can move the handles:
‣

Straight: allows you to move the handles together, maintaining the same angle to the point.

‣

Corner: allows you to move the handles independently.

Related Topics
•

Reshaping a Velocity Function using Bezier Controls on page 1011

•

Creating a Stepped Velocity below

•

Adjusting the Velocity of Several Layers at the Same Time on the next page

Creating a Stepped Velocity
You can create a stepped curve to hold the same value over a selected number of frames. This works well when
you are animating drawings on 2's, for example, and you want to hold the same value for a function over those
two frames.
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To hold the same value over several frames:
1. Click the Hold Value Editor

button.

The Hold Value editor opens.

2. In the Hold Value Editor, enter the following values:
‣

Start: Enter the starting frame for the effect.

‣

Stop: Enter the last frame for the effect.

‣

Step: Enter the number of frames to hold the value.

The function curve is updated based on the values you entered.

You can reshape the curve to create a linear velocity, so that the values are interpolated (tweened)
consistently between keyframes. That is, there is no acceleration in the effect.

Related Topics
•

Adjusting the Ease on page 1010

Adjusting the Velocity of Several Layers at the Same
Time
If you have several functions you would like to adjust the velocity for at the same time, you can use the Set Ease
for Multiple Parameters dialog box. It allows you to apply the same velocity parameters to all the selected
keyframes in a same frame.
To set eases on multiple parameters:
1. In the Timeline view, select a keyframe on one or many layers.
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Only the first selected keyframe will be considered when using the Set Ease For Multiple Parameter
function. If many keyframes are selected on a same layer, the ease values will be applied only to the
first one and the rest will be ignored.

2. In the Timeline view,right-click and select Set Ease For Multiple Parameters. In the Timeline View
toolbar, you can click on the Set Ease For Multiple Parameters
button. This button is available in the
Timeline View toolbar's extra buttons. Refer to the chapter on Toolbar Manager on page 136 to learn
how to customize your toolbars.
The Set Ease For Multiple Parameters dialog box opens.

3. In the graph interface, pull on the Bezier handle to adjust the velocity for all the selected functions.

4. To apply these easing parameters to a specific type of function only, such as Rotation or Scale, go to the
Filters section and disable the function types you do not want to affect.
‣

Motion: If this option is enabled, the easing parameters will be applied to the selected Position X,
Position Y, Position Z and 3D Path functions

‣

Rotation: If this option is enabled, the easing parameters will be applied to the selected Angle
functions.

‣

Scale: If this option is enabled, the easing parameters will be applied to the selected Scale functions.

‣

Skew: If this option is enabled, the easing parameters will be applied to the selected Skew functions.
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‣

Morphing: If this option is enabled, the easing parameters will be applied to the selected Morphing
Velocity functions. Note that it applies to the Morphing velocity function found in the Layer
Properties dialog and not to the basic morphing ease in the Tool Properties view.

‣

Other: If this option is enabled, the easing parameters will be applied to all the other the selected
functions such as all functions created to animate effect parameters.

5. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values are
calculated in percentage.
‣

In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding to the
length of time you want the easing to last for. It is recommended to remain between 0% and 100%. If
you go beyond 100%, your motion will overshoot.

‣

In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong you
want the easing out to be. It is recommended to remain between 0% and 100%. If you go beyond
100%, your motion will overshoot.

‣

If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

6. Once done, click on one of the following button:
‣

Apply: This will apply the easing parameters to the selected keyframes.

‣

Apply/Previous: This will apply the easing parameters to the selected keyframes and then selects the
previous keyframe in the timeline.

‣

Apply/Next: This will apply the easing parameters to the selected keyframes and then selects the next
keyframe in the timeline.

‣

Close: This closes the dialog box. If you did not apply the modifications, they will be cancelled.

Related Topics
•

Adjusting the Ease on page 1010
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Expression Columns

In Harmony, you can use expressions to automate the calculation of effect values based on the values in another
function. An expression is a mathematical formula that allows you to manipulate the value in the source function
to create new values for the destination effect.
For example, there are two characters. One is walking across the stage and the other is following the same path
two steps behind. Without expressions, you would have to manually enter the values for the position of the peg
so it is one frame behind the original element. However, you can save time by building an expression that does
this for you. Then, if you change the position of the element in the original column, Harmony automatically
updates the Expression columns linked to it.

Related Topics
•

API on page 1019

•

Creating an Expression for an Effect on page 1021

Writing Expressions
Expressions are based on a JavaScript (JS) program. You can access to the full capability of the JS language and
write any type of program, as long as it executes relatively quickly.
The entire JavaScript must be defined within the expression code. There are no common repository of JS
functions and services available to the expression column scripting environment. However, with the Harmony
C++ SDK, you can extend the API of functions available to the expression scripting environment.
If you are working with an old project that contains expressions, they are converted to a JS program. Only
simple expressions are updated. Complex expression and expressions using non-ported services cannot be
converted. For these type of expressions, you must convert them manually.

Expression Editor
The Expression editor is where you write expressions. It is a simple text editor that can handle incomplete or
invalid JS programs although they will not be evaluated, Harmony can save and load invalid JS programs.
The Expression editor evaluates the current script at the current global frame and reports any error or returns
the numerical result of the program.
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Expression JavaScript Program
An expression JavaScript program can be any valid program. The only requirement is the last statement of the
script must leave a number on the stack. The “return” statement is NOT need as the script is not a function.

Valid expression column JS program
Example 1
10
This is a trivial program returning 10.
Example 2
currentFrame
This is another trivial program returning the current frame. The variable “currentFrame” is one of the predefined
variables and services available.
Example 3
value( “MyBezierFunction”, currentFrame - 1 );
A simple expression program the returns the value of the Bezier function “MyBezierFunction” at the previous
frame. If this function does not exist in the scene, the expression column will be blank in the XSheet. If this
function does exist, the expression column will show the value of that function at the frame.
Example 4

This is another not so trivial program that evaluates the fibonacci series starting at the current frame. The value
will be computed up to a certain current frame. After that frame, the program is too complex and will be
stopped by the engine before finishing.

Errors
Programs that take too long to execute, do not generate a numerical value, or has syntax errors will not be
compiled and will not compute a value. The scripting editor will show the condition that triggers this, but the
Xsheet will simply display a blank field.
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API
Using Column Names and Frame Numbers
To refer to the values in a column, use the column name and the frame number. If you do not state the frame
number, then Harmony uses the value of the current frame. You can refer to the frame numbers in the following
ways:
•

currentFrame: Refers to the current frame number.

•

numFrames: refers to the total number of frames in a scene.

Consider the expression: value ( ``peg_x”, currentFrame-1)
•

This expression says that the current frame value will be the same as the previous frame value of the
element peg_x.

Now consider this expression: value ( ``peg_angle”, currentFrame - 2] * 3
•

In this expression, Harmony is to look two frames before the current frame in the column "peg_angle"
and multiply the value by 3 to derive the value for the current frame of the expression column.

Predefined Functions
Most mathematic functions are obvious. They either take an angle or value or return an angle or a value. Angles
are always specified in degrees. If the input argument is not valid, the function will log an error (which is visible in
the script editor) and the Xsheet does not display anything.
The two variants of the function value() are used to get the value of 2D functions at the current frame or the
specified frame. The first argument is always a string that identifies the function. The optional second argument
is the frame to use.
For example: value( “myFavBezier”, currentFrame-1)
Function

Description

sin (angle)

Returns the sinus from angle specified in degrees

cos (cosine)

Returns the cosinus from the angle specified in degrees

tan (angle)

Returns the tangent from the angle specified in degrees

asin( v )

Returns the arcsin in degrees

acos( v )

Returns the arccos in degrees

atan( v )

Returns arctan as an angle in degrees from the first quadrant.

atan2( x, y )

Returns the arc tangent in degrees.

int

Returns the integer value of the “v”. Undefined behaviour for negative number.

ceil( v )

Returns the next integer greater or equal than “v”

floor( v )

Returns the integer value of v. Remove the fractional part.

abs( v )

Return the absolute value.

sqrt( v )

Returns the square root for v >= 0.
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exp( v )

Returns the “e” exponent v. (see c library exp( f ))

ln( v )

Returns the natural logarithmic of v for v > 0

ln

Logarithm of a value

value( columnName)

Value of the function specified by “columnName” at the current frame

value(columnName,frame)

the value of the function specified by “columnName” at the frame specified by
“frame”
Indentify the text wrapped by columnName to be renamed whenever the
column named “columnName” is renamed.

column( columnName )

column() is a keyword that does nothing at runtime, but, it helps Harmony
track which references to a function needs to be renamed in the script when a
function is renamed. For example, if you have a function named “B” and this
one gets renamed to “C” through some scripts or by the user, all expression
script referencing “B” will automatically be updated to refer to “C” if their call
was wrapped as column( “B” ).
Identifies a module/node that is in the same group as another module which is
using this expression column.

node( nodeName )
module( nodeName )

node( nodeName) and module( nodeName ) are two functions that return a
proxy to a module that must live in the same group as another module using
that expression column. For this method to work, the expression must be
connected to a module “A” and the script must refer to a module “B” in the
same group as module “A”. The resulting object is a proxy to a module and
cannot be converted to a number. This proxy object is only usable by an SDK
plugin.

numFrames

A constant that represents the number of frames in the current scene

currentFrame

A constant that represents the current frame (1 based)

Related Topics
•

Creating an Expression for an Effect on the facing page
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Creating an Expression for an Effect

To create an expression for an effect, you must add an Expression column to the Xsheet view, build the
expression and then link the Expression column to the parameter you want to control.
To build an expression for an effect:
1. In the Xsheet view menu, select Columns > Add Column or press [Shift] + [C].

2. In the Add Column dialog box, type a name for the column and select Expression from the Column Type
drop-down list and click OK.
3. Double-click on the column's header to open the Expression dialog box.

4. Type the expression in the dialog box.
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5. Click OK or Apply to activate the expression.
The cells in the expression column are filled with values based on the expression you created.

6. To apply the values in the expression column to an effect, you must link the expression column to the
parameter values. In the drawing layer's editor, link the function to the new expression column.
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Related Topics
•

Sharing Functions on page 994
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Animation Path Preferences
While creating motion paths and setting up your scenes, there are preferences you can set to make your work
more efficient.
To open the Preferences dialog box:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Select Stage> Preferences.

‣

Press [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).

Related Topics
•

General Preferences below

•

Camera Preferences on the facing page

•

Exposure Sheet Preferences on page 1026

•

Timeline Preferences on page 1027

General Preferences

Options
•

Snap Keyframe: If two keyframes have the same value, they will both update to the same new position
when the first of the two keyframes is modified. The previous keyframe has to be a Stop-Motion
keyframe.
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Settings
•

Stop-Motion Keyframes: New keyframes are created as stop-motion keyframes.

•

Default Separate Positions for Pegs: New pegs are created with separate position functions.

•

Default Separate Scale for Pegs: New pegs are created with separate scale functions.

•

Default Separate Positions for Elements: New elements are created with separate position functions.

•

Default Separate Scale for Elements: New elements are created with separate scale functions.

•

Default Bezier: New functions curves are created as Bezier Curves.

•

Default Bezier Velocity: New velocity curves are created as Bezier Curves.

Related Topics
•

Camera Preferences below

•

Exposure Sheet Preferences on the next page

•

Timeline Preferences on page 1027

Camera Preferences

Tools
•

Initial Animation Mode: Determines which animation mode are enabled when the scene is opened.

•

Set Keyframes on All Functions With the Transform tool: A keyframe is added by default on all the
functions of the selected layer when you perform a transformation with the transform tool. Disable this
option if you want the Transform tool to add a keyframe only on the transformation you are doing, such
as a rotation or scale.
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•

Set Keyframe At Frame One With First Application On the Transform Tool: When this preference is
enabled, wherever you set a keyframe on your layer, there will be a keyframe added on your frame 1. If the
preference is disabled, there will be only a keyframe added to the current frame. If later on, you add a
keyframe on your frame one, it may modify the first keyframe you added.

Control Points
•

Show Control Points On Selected Layer: By default, when you select an element with the Transform
tool, the motion path related to the object is displayed.

•

Control Point Tension: The default Tension value for new keyframes and Control Points.

•

Control Point Continuity: The default Continuity value for new keyframes and Control Points.

•

Control Point Bias: The default Bias value for new keyframes and Control Points.

Related Topics
•

General Preferences on page 1024

•

Exposure Sheet Preferences below

•

Timeline Preferences on the facing page

Exposure Sheet Preferences

Function Editors
•

Show Grid: When selected, the grid is displayed by default when opening the Function Editor.

•

Use Constant Z By Default: When selected, the Constant Z option will be enabled by default in the
Function Editor.

1026

Toon Boom Harmony 10.3 Stage User Guide

Constant Z means that even when creating Motion keyframes, the Z function will use Stop-Motion
keyframes and will not be interpolated, this can be very useful for cut-out animation. The Constant Z
feature only works with 3Dpaths.
You can also enable the Constant Z option directly in the Function Editor or Function view for specific
functions.

Related Topics
•

General Preferences on page 1024

•

Camera Preferences on page 1025

•

Timeline Preferences below

Timeline Preferences

Defaults
•

Reduce Indentation: When this option is enabled, the horizontal indentation for parented modules in the
Timeline is reduced to optimize the amount of space taken in the Timeline. When you have a cut-out
character and there is a long cascade of parented modules, you can enable this option so that the
Timeline left size does not required to be expanded too wide to see all of your modules.

Related Topics
•

General Preferences on page 1024

•

Camera Preferences on page 1025

•

Exposure Sheet Preferences on the previous page

1027

Toon Boom Harmony 10.3 Stage User Guide

1028

Toon Boom Harmony 10.3 Stage User Guide

Chapter 17: Cut-out Animation

Harmony provides you with some great tools to animate your puppets. You can create simple animation using
the Transform tool and you can make advanced animation using both forward and inverse kinematics. Harmony
has advanced onion skinning and image swapping features to help you animate efficiently and quickly. To give
you animation freedom you are able to mix several different techniques of animation such as simple rigging,
hierarchy and symbol animation.

Topics Covered
•

Getting the Character on page 1031

•

Keyframes and Drawing Blocks on page 1035

•

Creating a Simple Cut-out Animation on page 1037

•

Selecting Layers to Animate or Position on page 1040

•

Navigating the Hierarchy on page 1044

•

Animating Using the Transform Tool on page 1046

•

Animating using Inverse Kinematics on page 1049

•

Animating in Stop-motion on page 1069

•

Animating Using Computer-generated Interpolation on page 1071

•

Flipping through Poses on page 1076

•

Using the Onion Skin in Cut-out Animation on page 1078

•

Flipping Parts on page 1081

•

Animating Using Symbols on page 1083

•

Reusing Extra Drawings, Poses and Facial Expressions on page 1089

•

Swapping Images on page 1092

•

Adding a New Drawing on page 1096

•

Ordering Layers Over Time on page 1097

•

Resetting a Transformation on page 1099
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•

Creating Cycles on page 1101

•

Adding Pegs on page 1106

•

Offsetting Part of an Animation on page 1108

•

Cut-out Animation Preferences on page 1110
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Getting the Character
The first step in animating your character is to import a master template from the library.

If the template you are importing was created in the Network view, make sure to import it first and to
drop it into either the Network view or the left side of the Timeline view. If you don't do this you may
break some network connections.

•

Importing a Character from the Library below

•

Importing Network Templates on the next page

Importing a Character from the Library
To import a character from the library:
1. Create a new Harmony project.
2. In the Library view, select a character master template to animate.

3. Drag the selected template to the Camera or Timeline view’s left side.

4. In the Timeline view, drag the red scene length bracket to extend or shorten your scene length.
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Importing a Character from the Library

Importing Network Templates
In Harmony you can create your character template from the Network view.
To import a Network template:
1. Create your new Harmony project.
2. In the Library view, select the character's master template you want to animate.

3. Drag the selected template to the Network, Camera or Timeline view's left side.

4. In the Network view, connect the template's Group module to the Composite module, by clicking it's outport and dragging the connection to the Composite module until an in-port appears.
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5. In the Timeline view, extend or shorten the scene length by dragging the scene length bracket.

Related Topics
•

Selecting the Pose below

•

Extending the Exposure on the next page

Selecting the Pose

If the template you imported contains several poses, you must choose which pose you will use to start your
animation and remove the other ones.

If you created your different views in separated templates. you can import them on separated layers
and turn them on and off in the Timeline view depending on which one you need.

To select the character's pose:
1. In the Timeline view, collapse your character's layers.

2. In the Timeline view's right side, select the keyframe corresponding to the pose you want to keep.
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Importing a Character from the Library

3. Drag the selected keyframe to the first frame.

4. Select all of the extra drawings and keyframes that you do not need and press the [Delete] key.

Related Topics
•

Extending the Exposure below

Extending the Exposure
Once you have chosen a pose, all that is left to do is extend the exposure of your character to the end of the
scene.
To extend the exposure of the character:
1. In the Timeline view, collapse the character.

2. In the Timeline view’s right side, select the last cell of the character.

3. Right-click (Windows) or [Ctrl]+Click (Mac OS X) and select Extend Exposure or press [F5]. You can also
copy the first pose and paste it in the last cell.
The drawing exposure is extended to the end. You will not see any changes in the Timeline while the
Master peg is collapsed.

Related Topics
•

Getting the Character on page 1031
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Keyframes and Drawing Blocks
When you extend the exposure of a drawing, it is represented by a grey block in the Timeline view. When you
expose a second drawing, a second grey block is displayed.
You can consider these blocks as drawing blocks.

To animate the position of a block over time, you do not need to create a second block, you simply need to add
a position keyframe. The position keyframes are coordinates indicating the position of your drawing on a
particular frame. These appear as black squares in the Timeline view.
In the example below, you can see that the keyframes are positioned on frames independently from the
beginning and end of each drawing block.

You can keyframe three different positions for your drawing in the same drawing block and create a motion path
between them.

Timeline Behaviour
In the Timeline view, you can see how the Timeline behaves differently depending on whether you create a new
drawing, a new keyframe, or both at the same time.
•

Creating a Drawing in the Timeline View below

•

Creating a Keyframe in the Timeline View on the next page

•

Creating a Drawing and a Keyframe in the Timeline View at the Same Time on the next page

Creating a Drawing in the Timeline View
You can use the Create Empty Drawing command to add a new drawing in the Timeline view. This will
automatically insert a new drawing block.
•

Select Drawing > Create Empty Drawing.

•

You can also use the Create Empty Drawing

button in the Timeline View toolbar.
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Keyframes and Drawing Blocks

Creating a Keyframe in the Timeline View
You can use the Add Keyframe command to add a new keyframe in the Timeline view. This will automatically
create a keyframe in your layer.
•

Select Insert > Keyframe or press [F6].

•

In the Timeline View toolbar, click the Add Keyframe

button.

Creating a Drawing and a Keyframe in the Timeline View at the
Same Time
You can use the Insert Keyframe and Duplicate Drawing command to add a keyframe and a drawing at the same
time. This will create a drawing block containing copies of the selected drawing and a keyframe.
•

Select Insert > Keyframe and Duplicate Drawing.
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Creating a Simple Cut-out Animation

To create a simple cut-out animation, follow these steps so you can try out the animation tools you will learn in
the next topics.
To create a simple cut-out animation:
1. In the Tools toolbar, select the Transform
2. In the Tools toolbar, enable the Animate

tool. You can also press [Shift] + [T].
mode so that everything you move will be keyframed

automatically.
3. In the top menu, select Animation > Stop-Motion Keyframe so that the interpolation is not created
automatically between your keyframes.
4. In the Timeline view, collapse your character.

5. In the Timeline view, go to the frame where you want to set your first pose.
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Creating a Simple Cut-out Animation

6. In the Camera view, select the parts to animate.

7. Using the Transform

tool, rotate, skew, scale or translate the selection to its new position.

A new keyframe appears in the Timeline view.
8. If you want to make sure that nothing will move on your new pose, in the Timeline view, select the frame
corresponding to the pose,right-click and select Add Keyframe. You can also press [F6].
9. In the Tools toolbar, enable the Onion Skin

feature.

10.In the Timeline view, go to the frame where you want to set your second keyframe.

11. In the Camera view, animate your character.

12. Repeat this process until all your poses are done.
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Related Topics
•

Selecting Layers to Animate or Position on the next page

•

Animating Using the Transform Tool on page 1046

•

Animating Using Computer-generated Interpolation on page 1071

•

Using the Onion Skin in Cut-out Animation on page 1078
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Selecting Layers to Animate or Position

Selecting Layers to Animate or Position

When you are animating characters, it is important to understand how the Animate mode allows you to create
keyframes on the current frame or to reposition the entire layer.
This topic is divided as follows:
•

Animate Mode below

•

Selecting Drawing Layers using the Transform Tool on the facing page

Animate Mode
The Animate

button in the Tools toolbar, turns keyframing on or off. When you enable the Animate mode,

as soon as your move an element in the Camera view, a keyframe is positioned on the current frame in the
Timeline view to indicate the new position.

When you turn off the Animate mode, and you select and move an element, the entire animation in the layer will
be offset at once.
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This means that when you are animating a character, you must enable the Animate mode. If you are scaling down
your puppet to fit the scene composition and want to resize the entire animation, you must disable the Animate
mode.
To turn the Animate mode on or off:
‣

In the Tools toolbar, click the Animate

button or select Animation > Animate.

Selecting Drawing Layers using the Transform Tool
To manipulate your drawing layers in order to animate them, you must use the Transform

tool. The Select

tool is used to modify the drawing strokes and not the actual drawing layer.

When selecting your drawing layers with the Transform tool, make sure that the Peg Selection Mode
option is turned off in the Transform Tool Properties view. If this option is enabled, it will limit the
selection in the Camera view to pegs only.

This section is divided as follows:
•

Selecting an Element in the Camera View Using the Transform Tool on the next page

•

Selecting a Layer in the Timeline View on the next page

•

Selecting in the Network View on the next page

To select using the Transform tool:
1. Do one of the following:
‣

In the Tools toolbar, click the Transform

‣

From the top menu, select Animation > Tools > Transform.

‣

Press [Shift] + [T].

tool.

2. In the Transform Tool Properties view, make sure the Peg Selection
3. In the Camera view, select the element to animate.
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Selecting Layers to Animate or Position

Selecting an Element in the Camera View Using the Transform
Tool
When you select an element in the Camera view using the Transform tool, make sure that the Peg Selection
mode is disabled in the Transform Tool Properties view, the element selected is the actual drawing layer
corresponding to the selected element. If you have a peg parented to that layer, you must either use the
keyboard shortcuts to go up the hierarchy chain, select it in the Timeline view, or enable the Peg Selection
mode option in the Transform Tool Properties view, this will limit the selection in the Camera view to pegs only.

If the layer has child layers, they will also be highlighted.

Selecting a Layer in the Timeline View
When you select a layer in the Timeline view, the corresponding element is highlighted in the Camera view. If the
selected layer has child layers, they are also highlighted.

Selecting in the Network View
As with the Timeline view, when you select a module in the Network view, the corresponding element will be
highlighted in the Camera view. If the selected module has child layers, they will also be highlighted.
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Related Topics
•

Navigating the Hierarchy on the next page
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Navigating the Hierarchy

Navigating the Hierarchy
If you created a layer hierarchy when you built your puppet, you can use the keyboard shortcuts to travel up and
down the parent-child chain. You can also travel between the children in a layer.
To select the parent or child layer:
1. In the Tools toolbar, select the Transform

tool.

2. In the Transform Tool Properties view, make sure the Peg Selection

mode is deselected.

3. In the Camera or Timeline view, select a layer attached to a hierarchy.

4. Select Animation > Select Parent or press [B] to select the parent layer. Now select Animation > Select
Child or press [Shift]+[B] to select the child layer. The keyboard shortcuts are [B] and [Shift] + [B].

These keyboard shortcuts will ignore any effect module encountered in the Network or Timeline
view. Only drawing and peg modules will be considered. If you want to navigate the hierarchy
including the effect modules, you can create a custom keyboard shortcut in the Preferences dialog
box for the Select Parent Skipping Effects and Select Child Skipping Effects commands on the
General tab. Refer to the Harmony User Guide to learn how to create custom keyboard shortcuts.

To select the children layers:
1. In the Tools toolbar, select the Transform

tool.

2. In the Camera or Timeline view, a layer attached to a parent layer with several children or not parented at
all.
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3. Select Animation > Select Previous Brother or press [/] to select the previous child layer and select
Animation Select Next Brother or press [?] to select the next child layer. You can also select Animation
> Select Children to select all child layers at once.

Related Topics
•

Creating a Simple Cut-out Animation on page 1037

•

Selecting Layers to Animate or Position on page 1040

•

Animating Using the Transform Tool on the next page

•

Animating using Inverse Kinematics on page 1049

•

Flipping through Poses on page 1076

•

Flipping Parts on page 1081

•

Ordering Layers Over Time on page 1097

•

Resetting a Transformation on page 1099

•

Adding Pegs on page 1106

•

Offsetting Part of an Animation on page 1108
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Animating Using the Transform Tool

Animating Using the Transform Tool
The Transform tool is the main tool you use when working with a cut-out character. The Transform tool has many
useful functions:

Using the individual Rotate, Translate, Scale and Skew tools is not recommended, as they move each piece from
their own pivot point. They are compositing tools. The Transform tool will create a global selection, so when
many parts are selected, the Transform tool will move it as one. The Transform tool is highly recommended for
cut-out animation.

When animating with the Transform tool, make sure to select the right selection mode. In this
example, make sure that the Peg Selection Mode
is disabled in the Tool Properties view or it will
limit the selection in the Camera view to pegs only.
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If you have hierarchy connections in your cut-out character, the Transform tool will also be used as the Forward
Kinematics equivalent.
The Transform tool can be used on any kind of rigging.
When many parts are selected with the Transform tool, the first selected part's pivot will be used as the global
selection's pivot. This pivot can be moved temporarily for the animation. When you offset the pivot, the
permanent pivot is displayed as a ghost.

The interpolation of your animation poses is always calculated from the permanent pivot.

To use the Transform tool:
1. In the Tools toolbar, click the Transform

tool or press [Shift] + [T].

2. In the Camera view, select the element to animate and move it.

3. In the Timeline view, go to the frame where you want to set your next position.
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Animating Using the Transform Tool

4. In the Camera view, animate the character.

Related Topics
•

Positioning an Element Using the Transform Tool on page 777
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Animating using Inverse Kinematics

The Inverse Kinematics tool (IK) allows you to pull on your character's extremities, such as the hands and feet,
and have the rest of the body follow.
The Inverse Kinematics tool will animate from an extremity and make the rest of the hierarchy follow (called the IK
chain). It can be used on any piece connected in a hierarchy. However, you do not have to use IK every time that
you have a hierarchy rig. This tool is useful when you want to bend a character's knees, make him sit and move
the rest of the body, etc.
Inverse Kinematics helps a new animator to understand how a puppet should move. It will also help any animator
easily create difficult moves.
Inverse Kinematics will not work on basic rigs without hierarchy because there is no hierarchy chain present, IK
only works on hierarchy parenting when the pivots are properly set.
When animating a hierarchy puppet, an animator will use the Transform and Inverse Kinematics tools.

Topics Covered
•

IK Hierarchy Chains on the next page

•

Where to Start with Inverse Kinematics? on page 1051

•

Inverse Kinematics Tool Properties on page 1053

•

Setting up the Character to use IK on page 1057

•

Nails on page 1061

•

Minimum and Maximum Angle on page 1062

•

IK Keyframes on page 1064

•

When to use the Inverse Kinematics Tool on page 1065
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Animating using Inverse Kinematics

IK Hierarchy Chains
Before we go any further, a word about IK chains. There are three types of chains:
•

Single Chains below

•

Direct Chains below

•

All Chains

Single Chains

These are the most basic of chains. A single chain is a straight line with no secondary chain attached.

Direct Chains

These link directly to the core of the character rigging. A direct chain is a single chain which goes directly to the
core.
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All Chains

All chains are attached and move simultaneously when one part is moved.

Related Topics
•

Where to Start with Inverse Kinematics? below

•

Inverse Kinematics Tool Properties on page 1053

•

Setting up the Character to use IK on page 1057

•

Nails on page 1061

•

Minimum and Maximum Angle on page 1062

•

IK Keyframes on page 1064

•

When to use the Inverse Kinematics Tool on page 1065

Where to Start with Inverse Kinematics?
This section explains the basics of the Inverse Kinematics tool. IK works best when you lock a part of the
character to the spot, such as a foot on the floor, then select the entire body or another extremity and move it.
To lock a part in place, you use the IK Nail option.
To use the Inverse Kinematics tool:
1. In the Tools toolbar, select the Inverse Kinematics

tool or press [Alt] + [8].

2. In the Camera view, [Ctrl] + click (Windows/Linux) or [⌘ ] + click (Mac OS X) on a part of the body.
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Animating using Inverse Kinematics

The entire IK skeleton appears.

3. Click on a part of the body and pull on it to move the character.

4. Hold down the [Shift] key and click on the pivot belonging to the part you want to lock in place.

5. Click on another part of the character and pull on it. You can [Shift] + click on a bone to lock the
orientation of the bone.

Related Topics
•

IK Hierarchy Chains on page 1050

•

Inverse Kinematics Tool Properties on the facing page

•

Setting up the Character to use IK on page 1057

•

Nails on page 1061

•

Minimum and Maximum Angle on page 1062
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•

IK Keyframes on page 1064

•

When to use the Inverse Kinematics Tool on page 1065

Inverse Kinematics Tool Properties

•

IK Modes below

•

IK Tool Options on the next page

•

Selection on page 1055

IK Modes
The IK tool has six different modes that can be found in the Tool Properties view:
•

Bone Selection Mode below

•

Chain Menu on the next page

•

IK Manipulation Mode on the next page

•

Apply IK Constraints Mode on the next page

•

Edit Min/Max Angle Mode on the next page

•

Bone Editing Mode on the next page

Bone Selection Mode
The Bone Selection mode is enabled by default. This option allows you to click on any bone in your character and
move it without having to select the actual layer.
Once you disable this option, you can not move any bone except the selected one. This allows you to grab and
rotate the selected part from many angles and location. You can click completely outside the character and move
the pieces.
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Animating using Inverse Kinematics

Chain Menu
The Chain drop-down menu allows you to choose from three types of chain:
•

Simple Chain Mode: this is the default mode and will only allow for the movement of parts attached to a
single chain up to the point of intersection. A single chain is a straight line with no secondary chain
attached

•

Direct Chain Mode: this mode will allow the movement of parts up a simple secondary chain to a principle
chain as long as translation movement is possible (the principle chain is attached to its own peg), but will
ignore all secondary chains. A direct chain is a single chain which goes directly to the core.

•

All Chain Mode: this mode allows for the movement of all parts attached to all chains in the IK skeleton.
All chains are attached and move simultaneously when one part is moved.

IK Manipulation Mode
The IK Manipulation mode is the main working mode for the Inverse Kinematics tool. Enable this mode when you
want to animate and position your puppet.
[Ctrl] + click (Windows/Linux) or [⌘ ] + click (Mac OS X) on a body part to select it. You do not need to select a
part to be able to move it.

Apply IK Constraints Mode
The Apply IK Constraints mode is used to correct a part's position on a series of frames. For example, if the
character's foot seems to be sinking into the floor, you can correct its position and angle over a series of frames
using the IK Constrains mode.

Edit Min/Max Angle Mode
The Edit Min/Max Angle mode is used to set a rotation restriction on some of your parts, such as elbows, knees
and ankles.

Bone Editing Mode
The Bone Editing mode is used to fix the bone orientation on extremities such as hands and feet.

IK Tool Options
The IK tool has two special options that can be found in the Tool Properties view:
•

IK Keyframe below

•

Ease Shape on the facing page

IK Keyframe
The IK keyframe option is used in combination with the IK Constraints mode. It determines the starting frame of
the constraint you will apply.

1054

Toon Boom Harmony 10.3 Stage User Guide

Ease Shape

While you animate with the IK tool, prior to doing a movement you can set an easing preset so that your motion
is not so mechanical.
Before moving your part, select a preset from the list in the drop-down menu.

If you select a new preset in the list and move the part again on the same keyframe, the easing will be
automatically updated.

Selection
With the IK tool, you are able to do the following that can be found in the Tool Properties view:
•

Enable Translation If Top of Hierarchy on the next page

•

Enable Rotation on the next page
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Animating using Inverse Kinematics

•

Exclude From IK on the facing page

•

IK Nails on the facing page

•

Stiffness on the facing page

Enable Translation If Top of Hierarchy

This option is mainly used on master pegs. You will need to use the Enable Translation If Top of Hierarchy option
when you have a situation such as this; if you want your character to do a perfect split (sitting down with the legs
at right angles to the body or at the sides with the trunk facing forwards), then the hip will need to translate and
not just rotate on the spot. And since IK is all about rotation, you would select the hip layer and enable the
translation option.

Enable Rotation

The Enable Rotation option is enabled by default. If you disable this option, the selected part will not be able to
rotate anymore and will remain in the same position all the time. You can use this option to simulate an arm in a
plaster cast.
When you enable this option, the pivot will disappear but you will still see the bone.
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Exclude From IK
You can use the Exclude From IK option when you want certain parts of your puppet such as the eyes and mouth
to be excluded from the IK influence.

IK Nails

IK nails are used to temporarily fix a part of a character to a spot either in translation or rotation, or to enable
maximum and minimum angle usage.

Stiffness
When a certain part is selected, you can apply a stiffness value to it. A different stiffness value can be set to each
body part individually. The greater the Stiffness value applied, the more difficult it is to make that part rotate,
thereby rendering it stiff while the other parts continue to move freely on their joints.

Related Topics
•

Nails on page 1061

•

IK Hierarchy Chains on page 1050

•

Minimum and Maximum Angle on page 1062

Setting up the Character to use IK
The first time you display the character's skeleton, you will notice a series of bones on the extremities which are
out of place, and there may also be some elements that you would like to exclude from the Inverse Kinematics
chain.

1057

Chapter 17: Cut-out Animation
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You should setup the skeleton before starting your animation. There are three things to do to setup the
character:
•

Connecting any Hierarchy Chain below

•

Excluding Extra Elements from IK on the facing page

•

Setting Up the Bones for the Extremities on page 1060

Connecting any Hierarchy Chain
Before fixing any bones, or excluding layers from the IK, it is important that you make sure all the elements you
want to be parented in a chain are setup.
You do not need to have a chain all over the body. It can be on the legs and arms. If the body is not completely
rigged in hierarchy, the skeleton will look a bit more messy, but the IK tool will still work without any problem.
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Excluding Extra Elements from IK

When working with the IK tool, you will probably want to move the main parts around, but not necessarily the
small ones such as the nose or ears. In this case, you can select some elements on your character and exclude
them from the skeleton.
To exclude elements from the skeleton:
1. In the Tools toolbar, select the Inverse Kinematics

tool or press [Alt] + [8].

2. In the Tool Properties view, make sure the IK Manipulation Mode

is enabled.

3. In the Camera view, [Ctrl] + click (Windows/Linux) or [⌘ ] + click (Mac OS X) on the part to exclude from
the IK.

4. In the Tool Properties view, click on the Exclude from IK

5. Repeat the process for every part to be excluded from the IK.
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Setting Up the Bones for the Extremities
Once you remove the extra elements from your skeleton, you will want to set the bone orientation for the
extremity parts. By default they are oriented horizontally towards the right. This orientation often works for the
feet but not necessarily for the hair or hands,
To set the bone orientation:
1. In the Tools toolbar, select the Inverse Kinematics
2. In the Tool Properties view, enable the Bone Editing

tool or press [Alt] + [8].
mode.

3. In the Camera view, click on the pivot belonging to the part you whose bone you want to reposition, then
pull the pivot in the direction you want the bone to be.

4. Repeat this process for each bone you want to position.

This command will only work on the extremities.

Related Topics
•

Animating using Inverse Kinematics on page 1049
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Nails
Using the Inverse Kinematics tool, if you pull a hand the system will animate all of the character's parts included in
the hierarchy chain; the torso, the hips and the legs, depending on your rig. Often, you will only want to animate
part of a character, such as the arm and not the whole body. To do so, you need to make use of IK constraints
such as IK nails that are used to temporarily cut or constrain the chain. IK nails can be used to cut an IK chain or to
block a part on the spot. For example, you can fix a character's feet to the ground when he walks.
There are different types of constraints that can be placed on the chain:
•

IK Nail
Blocks the X, Y and Z positions.

•

Hold Orientation
Blocks the angle

•

Hold X
Blocks only the X position

•

Hold Y
Blocks only the Y position

•

Enable Maximum and Minimum angle
Sets limitations on the angle parameter to prevent the puppet from bending too far.

To set an IK nail:
1. In the Tools toolbar, select the Inverse Kinematics

tool or press [Alt] + [8].

2. In the Tool Properties view, make sure the IK Manipulation Mode

is enabled.

3. In the Camera view, [Ctrl] + click (Windows/Linux) or [⌘ ] + click (Mac OS X) on the part to set a nail on.
4. In the Tool Properties view, click on the type of nail you will use.

‣

You can also hold down the [Shift] key and click on any part's pivot to set a regular nail on it without
having to select it.

‣

You can hold down the [Shift] key and click on the bone to set a Hold Orientation nail.
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‣

You can select the nail type in the top menu by selecting Animation > IK Constraints > the desired
nail.

‣

You can remove the nail at anytime using the same technique you did to place the nail. It will not affect
the animation.

5. To remove every nail except the Enable Min/Max Angle ones, in the top menu select Animation > IK
Constraints > Remove All Constraints.

Related Topics
•

Animating using Inverse Kinematics on page 1049

Minimum and Maximum Angle

Harmony allows you to set a minimum and maximum angle constraint on certain joints such as the knees or
elbows.
When using the Inverse Kinematics tool or even the Forward Kinematics (Transform Tool), it is possible that
some joints will bend in the wrong direction.

It is recommended to use the minimum and maximum angles only if the character does not change
view. For example, if a character is facing the camera and has some angle limitations enabled, it
could be problematic if the character switches to side or quarter view since the joints won't bend the
same way.
You can use the minimum and maximum angle constraints if your character's views are in different
templates or layers. If the character's views are in the same layers, you are better off not using the
angle constraints.

1062

Toon Boom Harmony 10.3 Stage User Guide

If you plan to animate a lot with the Inverse Kinematics tool, it is a good idea to try the angle constraints. It
depends on your taste. The angle constraints can be set by the character builder or by the animator in some
particular scenes where it is needed.
To set the minimum and maximum angles:
1. In the Tools toolbar, select the Inverse Kinematics

tool or press [Alt] + [8].

2. In the Tool Properties view, in the Mode section, make sure the Edit Min/Max Angle Mode

is

enabled.
3. In the Camera view, [Ctrl] + click (Windows/Linux) or [⌘ ] + click (Mac OS X) on the piece to set the
minimum and maximum angle for.

4. In the Tool Properties view, in the Selection section, click on the Enable Min/Max Angle

option.

5. In the Camera view, rotate the Minimum and Maximum handles to set the angle.

6. Test your angles using the IK Manipulation Mode

.

7. For additional control over your Min/Max Angle go to Edit > Preferences > Camera > Inverse
Kinematics (Windows/Linux) or Stage > Preferences > Camera > Inverse Kinematics (Mac OS X) and
take a look at the Min/Max Angle Constraint Wight. Although the maximum value goes up to 1.0, in a
production setting, the most practical value would be closer to 0.1. This value acts similar to the Stiffness
setting in the Tool Properties view. The greater the value, the more difficult it becomes to approach the
minimum and maximum values.

Related Topics
•

Animating using Inverse Kinematics on page 1049
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IK Keyframes

When you animate a walking character and lock the feet down, the locked position will be perfect on the key
poses. However, when you use the Motion keyframes to auto in-between the animation, you will notice a
movement of feet. This motion is caused by the in-betweening of the rotations.
The nail holds in place the body part on the keyframe, but it will not hold it for the whole duration between
keyframes.
If you place a nail on the shoulder to move just the arm, you do not necessarily want to keep the shoulder in the
same place until the next key pose. You will probably want the shoulder, or any other part that is nailed, to have
a slight, natural motion following the main body action. Of course, this is not the case when you fix a hand or a
foot on the spot. If you have a fixed hand or foot, you will probably want it to stay exactly where you placed it.
That is why you can apply an IK constraint on a frame range and on selected body parts.
To fix the part on the same spot requires an angle (rotation) correction on the parts that are moving too much.
For example, to fix a foot that is moving too much, you will correct the angles on the foot, leg and thigh. To fix a
hand, you will correct the angles on the hand, forearm and upper arm.
To apply IK constraints on a frame range:
1. In the Tools toolbar, select the Inverse Kinematics

tool or press [Alt] + [8].

2. In the Camera view, click on the part you want to apply the constraint to.
3. In the Timeline view, set the cursor to the first frame where you want to start applying the constraint.

4. In the Tool Properties view, enable the Apply IK Constraints Mode
5. In the Tool Properties view, click on the IK Keyframe

.

button to enter the first frame number.

6. In the Timeline view, move the playhead to the last frame where you want to apply the constraint.
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The IK Keyframe field should now look like this:

7. In the Camera view, set a nail at the top of the limb you are correcting. In the case of a foot, set the nail on
the thigh by holding down the [Shift] key and clicking in its pivot.

8. In the Tool Properties view, select the type of constraint you want to apply to your piece.The most
common case is a combination of the regular Nail
and Hold Orientation
options.
9. In the Camera view, click on the bone of the part you want to apply a constraint to.
A warning message appears and requesting you to confirm that you want to add your constraint on that
particular piece and for that frame duration.

10. Click on the OK button.
Your constraint are now be applied.

Related Topics
•

Animating using Inverse Kinematics on page 1049

When to use the Inverse Kinematics Tool
This summarizes what you have read so far.
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Harmony provides different tools with which to animate cut-out characters and trajectories. The two main tools
used to animate characters are the Transform and the Inverse Kinematics tools.
Here, we will compare the usage of these tools and explain the Inverse Kinematics philosophy.
•

The Transform Tool

The Transform tool is also known as Forward Kinematics. This is the main tool to use for cut-out
animation. The Transform tool rotates, scales, moves and skews all the elements selected as one global
element.
Forward Kinematics means that the element will be animated from the parent element down to the last
child as a single piece. In other words, if the shoulder is animated, the arm, forearm and hand will follow
as a complete arm drawing.
•

The Inverse Kinematics Tool

The Inverse Kinematics tool (IK) is an assistance tool. This tool will help you to achieve complex motions
such as sitting down or knee bending. The Inverse Kinematics tool will move and rotate every selected
element as a chain.
Inverse Kinematics means that the element will be animated from the child element up to the parent
element. In other words, if the hand is animated, the forearm, arm and shoulder will follow the hand in a
fairly natural way in terms of the movement, rotation and bending.

Inverse Kinematics in Toon Boom Harmony
In most 3D animation software, Inverse Kinematics is implemented as a skeleton system. Harmony uses the
rigging hierarchy already created in the Timeline view, so there is no need to place bones in the character. Inverse
Kinematics in Harmony uses the connection between each of the parts' pivots.

IK Tool and Rigging
The IK tool can not be used on every type of cut-out character. It depends on the way the pieces and parts are
attached to one another. In other words, it depends on the rigging type.
There are several ways to rig a puppet. These are the three main rigging techniques:
•

•

•

The Basic Rig technique is the simplest.
•

There are no connections between the parts.

•

They are free to move, rotate and scale independently one from the other.

•

The Inverse Kinematics tool CANNOT be used on this type of rigging.

The Hierarchy Rig technique is the most complex.
•

All the parts are connected one to the other.

•

As they move, rotate and scale, they will influence all the other parts.

•

The Inverse Kinematics tool can be used on this type of rigging.

The Mix Rig technique is the best of the Basic and Hierarchy rig.

1066

Toon Boom Harmony 10.3 Stage User Guide

•

Some parts are independent such as the torso.

•

Some parts are setup into a hierarchy such as the arms and legs

•

The Inverse Kinematics tool can be used on this type of rigging.

Animating with the Tools
Puppets are animated by using a combination of Transform and Inverse Kinematics tools.
You will mainly use the Transform tool (Forward Kinematics) as it has all the main motions; rotate, scale, skew,
move and select. You can also control the exact position of the parts while using the Transform tool. As well, the
Transform tool creates a temporary global pivot on the selection that can be moved around for the animation
purpose.
To complete complex motions, such as bending the knees while keeping the feet on the ground, you will use
Inverse Kinematics tool as an assistance tool. By adding IK Constraints (Nails), it is possible to lock the feet or
any other parts on the spot and move the rest of the body, which will react to the constraints.

Inverse Kinematics Philosophy
It is important to keep in mind that the Inverse Kinematics tool is an assistance tool. You won't use it to animate
all the time.
Also, the Inverse Kinematics tool can be used to do the character's posing faster. Posing is a crucial part in the
animation process. The IK tool can be used to pose the character more naturally, depending on your own
preferences.
An IK Nail can be added anywhere on the character to animate only a small part of the hierarchy chain, such as an
arm or a portion or the arm.

Tips and Tricks for Inverse Kinematics
Here are some tips and tricks to help you to use the Inverse Kinematics tool.
•

IK on Mix Rigging
The Inverse Kinematics tool can be used on a full puppet's body even if it is connected as a mix rigging,
meaning some parts are rigged in a hierarchy and others not. For example, you can add IK Nails on the
puppet's feet, select the full body master peg and move the character as if it was connected in a full
hierarchy rig. This technique works on most of the mix rigging.

•

IK Constraints
It is important to remember that you can add and remove IK Constraints (Nails, Hold Orientation, etc.) at
anytime during the animation. They hold a certain part on the spot while you animate the rest of the body.
Because they are not constricting one part to another object, you can add or remove them without
affecting any of the animation you have already done.

•

Useful Shortcuts
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•

While using the IK tool, you can [Ctrl] + click (Windows/Linux) or [⌘ ] + click (Mac OS X) to select any
part.

•

You can hold down the [Alt] key to rotate the selected part without affecting the IK chain.

•

You can press the [Shift] key and click in a part's pivot to add or remove an IK Nail.

•

You can press the [Shift] key and click on a bone to add or remove and Hold Orientation constraint.

Related Topics
•

Where to Start with Inverse Kinematics? on page 1051
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Animating in Stop-motion
To start animating your character, start by doing your key poses. In fact, most of your time will be spent doing
key poses. It is better to work with Stop-Motion keyframes as Harmony will not automatically create the
interpolation between your keyframes.
When using Stop-Motion keyframes, also known as step keyframes, the segment between two keyframes is
constant. There is no animation generated by the computer between the poses. The drawing remains in position
until the next keyframe, then movies to its new position.

Creating a Stop-motion Keyframe
You can create a stop-motion keyframe in several different ways. You can have Harmony create it automatically,
transform a motion keyframe into a stop-motion keyframe, or even switch your preferences to get Harmony to
always create stop-motion keyframes by default.
To automatically create stop-motion keyframes:
1. In the top menu, make sure the Animation > Stop-motion Keyframe option is deselected.
2. In the Timeline view, select the cell where you want to add a keyframe.

3. Do one of the following:
‣

Right-click (Windows) or [Ctrl]+Click (Mac OS X)) on the selection and select Add Keyframe.

‣

Click the Add Keyframe

‣

Press [F6].

button in the Timeline View toolbar.

In the Camera view, if the Animate mode is enabled, as soon as you move the selected element, a
keyframe is automatically created on the current frame.

To convert a motion keyframe into a stop-motion keyframe:
1. In the Timeline view, select the motion keyframes to convert into stop-motion keyframes. The default
keyboard shortcut is [S].
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2. Do one of the following:
‣

Right-click (Windows) or [Ctrl]+Click (Mac OS X) on the selection and select Set Stop-Motion
Keyframes.

‣

Click Stop-Motion Keyframe

‣

Press [Ctrl] + [L] (Windows/Linux) or [⌘ ] + [L] (Mac OS X).

button in the Timeline View toolbar.

Related Topics
•

Animating Using Computer-generated Interpolation on the facing page
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Animating Using Computer-generated
Interpolation
After you have created the key poses, you can animate the in-between poses yourself or let Harmony do it using
motion keyframes. When you use motion keyframes, your drawings will gradually move to the next position
instead of staying on the spot until the next keyframe.

Creating a Motion Keyframe
You can create a motion keyframe in several different ways. You can have Harmony create it automatically,
transform a atop-motion keyframe into a motion keyframe and even switch your preferences to get Harmony to
always create motion keyframes by default.
To automatically create stop-motion keyframes:
1. In the top menu, make sure that the Animation > Stop-Motion Keyframe option is disabled.
2. In the Timeline view, select the cell where you want to add a keyframe.

3. Do one of the following:
‣

Right-click (Windows) or [Ctrl]+Click (Mac OS X)) on the selection and select Add Keyframe.

‣

Click the Add Keyframe

‣

Press [F6].

button in the Timeline View toolbar.

In the Camera view, if the Animate mode is enabled, as soon as you move the selected element, a
keyframe will be automatically created on the current frame.

To convert a stop-motion keyframe into a motion keyframe:
1. In the Timeline view, select the stop-motion keyframes to convert into motion keyframes.
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2. Do one of the following:
‣

Right-click (Windows) or [Ctrl]+Click (Mac OS X)) on the selection and select Set Motion Keyframes.

‣

Click the Motion Keyframe

‣

Press [Ctrl] + [K] (Windows/Linux) or [⌘ ] + [K] (Mac OS X).

button in the Timeline View toolbar.

Related Topics
•

Animating in Stop-motion on page 1069

Adjusting the Ease

To add ease in and ease out on your motion paths, you can display the function curve and modify the Bézier or
Ease curve. To apply an ease to multiple functions and keyframes, you can use the Set Ease for Multiple
Parameters feature and set the amount desired.
The velocity, or ease, is used on Motion keyframes. The velocity must be adjusted directly on the function curve
in the Function view or Function editor. When a keyframe is selected, easing values appear in the right handle
and left handle fields, as well as the Bézier handle or Ease wheel controls on each selected keyframe. You can pull
on them to adjust the ease in and ease out, or type values in the fields.
•

Adjusting the Velocity in the Function View below

•

Adjusting the Velocity on Multiple Elements Concurrently on page 1074

Adjusting the Velocity in the Function View
To adjust the velocity in the Function view:
1. In the Timeline View, click the Expand Function

button to display all of the layer’s functions.
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2. Double-click the desired function.

The Function Editor opens.

The Function Editor will not be displayed if the function does not already exist.

3. Select a keyframe and pull on its Bézier handles or Ease wheel to adjust the velocity.
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Adjusting the Velocity on Multiple Elements Concurrently
If you have several functions you would like to adjust the velocity for at the same time, such as the hand, forearm
and arm of a cut-out character, you can apply the same velocity parameters to all the selected keyframes in one
frame.
To set eases on multiple parameters:
1. In the Timeline view, select a keyframe from one or more layers.

Only the first keyframe selected on a given layer will be considered when using the Set Ease for
Multiple Parameter function. If many keyframes are selected on the same layer, the ease values will
be applied only to the first one and the rest will be ignored.

2. In the Timeline view,right-click (Windows) or [Ctrl]+Click (Mac OS X) and select Set Ease For Multiple
Parameters. In the Timeline View toolbar, you can click the Set Ease For Multiple Parameters
button.
If the button is not in the Timeline View menu, you can add it through the Toolbar Manager.
The Set Ease For Multiple Parameters dialog box opens.

3. In the graph interface, pull on the Bézier handle to adjust the velocity for all the selected functions.
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4. If you want to apply these easing parameters to a certain type of function only, such as Rotation or Scale,
in the Filters section, deselect the function types you do not want to affect.
‣

Motion: Applies the easing parameters to the selected Position X, Position Y, Position Z and 3D Path
functions

‣

Rotation: Applies the easing parameters to the selected Angle functions.

‣

Scale: Applies the easing parameters to the selected Scale functions.

‣

Skew: Applies the easing parameters to the selected Skew functions.

‣

Morphing: Applies the easing parameters to the selected Morphing Velocity functions. Note that it
applied to the Morphing velocity function in the Layer Properties dialog, not to the basic Morphing
ease in the Tool Properties view.

‣

Other: Applies the easing parameters to all the other selected functions, such as all functions created
to animate effect parameters.

5. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values are
calculated in percentage.
‣

In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding to the
length of time you want the easing to last. The value must be between 0% and 100%.

‣

In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong you want
the easing out. The value must be between 0% and 100%.

‣

If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

6. Once done, click one of the following button:
‣

Apply: Applies the easing parameters to the selected keyframes.

‣

Apply/Previous: Applies the easing parameters to the selected keyframes and then selects the
previous keyframe in the timeline.

‣

Apply/Next: Applies the easing parameters to the selected keyframes and then selects the next
keyframe in the timeline.

‣

Close: Closes the dialog box. If you did not apply the modifications, they will be cancelled.

Related Topics
•

Animating Using Computer-generated Interpolation on page 1071
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Flipping through Poses

When animating, it is useful to flip through your poses to see the flow of your animation without going through
each frame in the Timeline. Harmony lets you flip between the selected element’s keyframes.
To flip through poses:
1. In the Camera or Timeline view, select a layer that contains the poses you want to view.

2. From the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe or press [;]
and ['].

Related Topics
•

Keyframes and Drawing Blocks on page 1035

•

Creating a Simple Cut-out Animation on page 1037

•

Selecting Layers to Animate or Position on page 1040

•

Navigating the Hierarchy on page 1044
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•

Animating Using the Transform Tool on page 1046

•

Animating using Inverse Kinematics on page 1049

•

Animating in Stop-motion on page 1069

•

Animating Using Computer-generated Interpolation on page 1071

•

Using the Onion Skin in Cut-out Animation on the next page

•

Animating Using Symbols on page 1083

•

Reusing Extra Drawings, Poses and Facial Expressions on page 1089

•

Swapping Images on page 1092

•

Adding a New Drawing on page 1096

•

Ordering Layers Over Time on page 1097

•

Resetting a Transformation on page 1099

•

Offsetting Part of an Animation on page 1108
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Using the Onion Skin in Cut-out Animation

When animating cut-out characters, it is useful to see the previous and next frames on the animation. However, it
can sometimes be confusing to see the onion skin for every part of the character. You will often only want to see
the onion skin on a single part or a few parts, such as the arm, that are currently being animated. Harmony offers
that possibility.
While animating in the Camera view, there are four different onion skin options:
•

Add to Onion Skin on the facing page

•

Remove from Onion Skin on the facing page

•

Remove Unselected from Onion Skin on the facing page

•

Add All to Onion Skin on page 1080

•

Remove All from Onion Skin on page 1080

You can enable these options in the menu or manually in the Timeline view using the layer's Show Onion Skin
button. Unless you change the onion skin options when you display the onion skin, only the selected layers will be
displayed in the onion skin preview.
To use the onion skin options:
1. In the Tools toolbar, enable the Onion Skin

option or press [Alt] + [O].

2. In the Tools toolbar, click on the Transform

tool or press [Shift] + [T].

3. In the Camera view, select one or many elements.
4. In the top menu, select View > Onion Skin > Add to Onion Skin, Remove From Onion Skin, Remove
Unselected from Onion Skin, Add All to Onion Skin or Remove All from Onion Skin.
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Add to Onion Skin

The Add to Onion Skin command is used to add a series of selected elements to the onion skin preview. The
keyboard shortcut is [Shift] + [S].

Remove from Onion Skin

The Remove From Onion Skin command is used to remove a series of selected elements from the onion skin
preview.

Remove Unselected from Onion Skin
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The Remove Unselected from Onion Skin command is used to remove all elements except the ones selected from
the onion skin preview.

Add All to Onion Skin

The Add All to Onion Skin command is used to add all of the scene's elements to the onion skin preview. The
keyboard shortcut is [Alt] + [Shift] + [O].

Remove All from Onion Skin

The Remove All Onion Skin command is used to remove all of the scene's elements from the onion skin preview.
The keyboard shortcut is [Ctrl] + [Shift] + [O] (Windows/Linux) or [⌘ ] + [Shift] + [O] (Mac OS X).

Related Topics
•

Flipping through Poses on page 1076
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Flipping Parts

If you want to flip a part, a limb or a whole puppet, use the Transform tool and the Flip Horizontal and Flip
Vertical options.
To flip a selection
1. In the Animation Tools toolbar, select the Transform

tool or press [Shift] + [T].

2. In the Camera view, select the parts to be flipped.

3. In the Tool Properties view, click on the Flip Horizontal
shortcuts are [4] or [5] respectively.
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If the scaling parameter is not set to Separate Scale, the flip is not applied to the selection.

Related Topics
•

Keyframes and Drawing Blocks on page 1035

•

Creating a Simple Cut-out Animation on page 1037

•

Selecting Layers to Animate or Position on page 1040

•

Navigating the Hierarchy on page 1044

•

Animating Using the Transform Tool on page 1046

•

Animating using Inverse Kinematics on page 1049

•

Animating in Stop-motion on page 1069

•

Animating Using Computer-generated Interpolation on page 1071

•

Flipping through Poses on page 1076

•

Using the Onion Skin in Cut-out Animation on page 1078

•

Animating Using Symbols on the facing page

•

Reusing Extra Drawings, Poses and Facial Expressions on page 1089

•

Swapping Images on page 1092

•

Ordering Layers Over Time on page 1097

•

Resetting a Transformation on page 1099
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Animating Using Symbols

You can use symbols to animate your puppet. Symbols are boxes in which you can place whatever you feel like.
You can use the symbols to create reusable animations such as blinking.
A symbol combines animation, artwork or layers into a single object that you can control in one layer. You can
also create symbols out of each body part in your cut-out puppets.
To do so, you can either duplicate an existing symbol or create a new blank one in the Library. You can then drop
the symbol anywhere in your animation.

Related Topics
•

Creating a Blink Symbol below

•

Importing a Template with Symbols on page 1087

•

Duplicating a Symbol on page 1087

Creating a Blink Symbol
You can make an eye blink by creating a blink symbol. Here is an example of a blinking animation created in a
blink symbol.
To create a blink symbol:
1. In the Library view's right side,right-click and select New Symbol.

The new symbol appears in the Symbol library.
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2. Rename it Blink.
Harmony then automatically enters the symbol so you can edit it.
3. Drag the eyes, pupils and eyebrows symbols or template from the Library view to the Timeline view's left
side. If you do not already have your eyes, pupils and eyebrows in your library, you should create either
symbols or templates out of them.

4. In the Timeline and Camera view, animate the blink.

‣

If you enter the eyelid or eye symbol to add more drawings, they will be added into each instance of
that symbol. If you modify the exposure of the eye symbol within the Blink symbol, it will not be
modified in the other instances.

5. In the top menu, select File > Save.
6. In the Camera view's top area, click on the Top
7. In the Tools toolbar, select the Transform

button to go back to the scene's timeline.
tool or press [Shift] + [T].

8. If your head is a symbol containing all the facial feature symbols in the Camera view, double-click on the
head's symbol to edit it.

9. From the Library view, drag the new Blink Symbol and drop it into one of the eye feature layers. Before
dropping the symbol in the Timeline, hold down [Alt] (Windows/Linux) or [⌘ ] (Mac OS X).
10. Drop it into a series of blank frames. Do NOT drop it where there already is an exposure.
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The Paste Special dialog box opens.

11. In the Paste Special dialog box, enable the Paste All Frames of the Symbol (full movie) option.
12. Click on the OK button.
13. In the Timeline view, expose the other facial features and head drawings.

14. If you are editing the head symbol and not dropping the new symbol into the main timeline, click the Top
button to go back to the root timeline.
15. To expose the blink frames you just inserted inside the head symbol, in the Timeline view, select the head
layer's cell range where you want to expose the blink.
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16. In the top menu, select Animation > Cell > Sequence Fill or press [Ctrl] + [M] (Windows/Linux) or [⌘ ] +
[M] (Mac OS X).
The Sequence Fill dialog box opens.

17. In the Starting Value field, type the fist frame number where you exposed your blink inside the head
symbol.
18. In the Hold field and Increment field, type "1" .
19. If necessary, type the frame number on which your want the system to stop exposing the symbol.
20. Click on the OK button.

You can create walk cycle animation symbols or head turn animation symbols and drop them directly into your
main timeline in any drawing layer.
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Related Topics
•

Importing a Template with Symbols below

•

Duplicating a Symbol below

Importing a Template with Symbols
Sometimes a character's rig is not straightforward to do. Rigs, which are usually saved as templates, can contain
symbols, such as a leg that was made with a patch. However, a symbol does not work in the same way as an
Action template. When dropped on the right side of the Timeline layer and into a symbol of the exact same
structure, instead of adding itself to the previous symbol, the new symbol becomes a copy.
To take more control of how the Action template will behave when brought into the Timeline, bring it in using a
Paste Special.
To import a template with symbols:
1. Select the Action template containing symbols from the right side of the Library.
2. As you drag it from the Library to the right side of the Timeline to drop it next to a template with the
exact same rig, hold down [Alt] (Windows/Linux) or [⌘ ] (Mac OS X).
The Paste Special window appears.

3. Select one of the following options from the symbols drop-down menu:

‣

Copy symbols if they do not exist: This is the default setting for this operation and will prevent
symbols in a action template from being copied.

‣

Duplicate symbols: Select this option if you wish to make copies of the symbols in your template.

‣

Overwrite symbols: If for some reason, a modification was made to a symbol in the Action template
that does not exist in the basic rig template for a character, select this option to overwrite the
previous symbol.

Related Topics
•

Creating a Blink Symbol on page 1083

•

Duplicating a Symbol below

Duplicating a Symbol
You must duplicate a symbol if you want to modify a copy of it without altering the original symbol and the other
copies.

1087

Chapter 17: Cut-out Animation

Animating Using Symbols

To duplicate a symbol:
1. In the Timeline view, go to the frame where you want to duplicate the symbol.
2. Select the symbol's cell.

3. In the top menu, select Edit > Duplicate Selected Symbol.
In the Library view, the symbol is duplicated and in the Timeline view, the current cell is replaced with the
new symbol. You can now modify the symbol's content.

Symbols nested inside another symbol are not duplicated. If you modify them the original and other
instances will also be modified

If you created an animation inside the duplicated symbol, you can expose it using the Fill Sequence command as
shown previously in the new symbol creation process.

Related Topics
•

Creating a Blink Symbol on page 1083

•

Importing a Template with Symbols on the previous page
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Reusing Extra Drawings, Poses and Facial
Expressions

Reusing animation and assets is an important aspect of cut-out animation. This is why Harmony includes a library
for storing all of the reusable information. To save time, you can take an action which you have already animated
such as a walk-cycle or jump and use it again. You can store the initial animation in the Library view, then select
and drag it into a new scene as often as you need it.
You can import a master template into the Timeline view and start animating with it, then later on decide to
import an action template. You can import the template into the window on the right side of the Timeline view.
This is where all the keyframes are located. An action template is a template that allows you to store drawings
(like a blink) or keyframes (like a walk cycle) that you want to reuse in an animation sequence.
To insert a template into another one, the layer ordering has to be the same. If it is inconsistent, the system will
indicate that the templates cannot be combined. In that case, you could bring the action to the Timeline's left
window to create a new set of layers or convert it into a symbol and drop it into any layer.
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You can create a single keyframe action template of the different viewpoints (front, three-quarter or
side view). Then import and insert those action templates into the animation to turn the character.
The same pattern can be created for a head, arm, full upper body, etc.

If the master template you are importing was created in the Network view, make sure to import it first
and to drop it into either the Network view or the left side of the Timeline view. Failure to do this
may break some network connections.

If you created templates for different body parts you can reuse them in your scene by dragging them
in your layers. You can also open a template as a folder and select a particular drawing from it and
drag it into your drawing layer.
If your layers are symbols, you will need to drag the templates inside the symbols. When you import
extra drawings, such as different hand and mouth positions, use the pivot that was set on your
drawings and copy them to the symbol's cells. You can do this by using the Copy Pivot to Parent
Symbol command.
When you copy your pivots to the parent symbol, there is no link between the drawing's pivots and
the symbol's. It is simply a copying operation. If you modify the drawing pivot later, it will not be
copied to the symbol and you would need to perform the operation again. If you need to modify the
symbol's pivots, do it directly on the symbol's cells.

To import extra drawings and insert them into symbols:
1. In the Camera or Timeline view, double-click on the symbol you want to add new drawings in.

2. In the symbol's timeline, extend the length if necessary.

3. In the Library view, browse to the template containing the new drawings to import in your symbol.
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4. From the Library view, drag the select template and drop it into the Timeline view's right side into the
corresponding layer.

5. In the Tools toolbar, select the Pivot

tool.

6. In the Timeline view, select the new drawings you just imported.

7. In the Tool Properties view, click on the Copy Pivot to Parent Symbol
‣

If the pivots were not set on your drawings, use the Pivot
copy operation.

Related Topics
•

Opening a Template as a Folder on page 655

•

Templates on page 646
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Swapping Images

Cut-out animation is not only about moving parts around. It’s also about swapping drawings to give the
animation a more traditional animation look.
You can add as many new drawings as you want in your character Symbols and use them in your current
animation. You can also add new drawings directly in your scene or import them from the library.
You do not need to remember the frame on which you drew or imported the drawings as you can see them in the
Drawing Substitution’s interface.
You cannot swap one Symbol for another one—only the Symbol’s frames or layer’s drawings.
You can swap images in the Timeline or Library view. When you use the Drawing Substitution window in the
Library view, you are not selecting drawings from the Library but from drawings contained in your scene’s layers.
To swap images in the Library view:
1. Go to the Camera view and click the Transform
2. In the Camera view, use the Transform

tool.

tool to select the part you want to swap.

3. In the Library view, go to the Drawing Substitution panel.
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4. Scroll through the Symbol's frames or drawings by doing one of the following:
‣

From the top menu, select Animation > Substitute Drawing Previous or Substitute Drawing Next.

‣

Drag the slider left/right.

‣

Press [ [ ] + [ ] ].

The drawing or Symbol’s cell on the current frame is replaced by the selected one.

1. In the Timeline view, click the Show Data View

button to expand the Data view.

2. In the Timeline view’s right side, select the cell containing the drawing or Symbol’s cell to swap.

3. In the Data view, drag the pointer left or right to change the cell or drawing exposed for another one. You
can also directly type the drawing name or Symbol’s cell number if you know it.
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To swap images in the Timeline view:
1. In the Timeline view, click on the Show Data View

button to expand the Data view.

2. In the Timeline view's right side, select the cell containing the drawing or symbol's cell to swap.

3. In the Data view, drag the pointer left or right to change the cell or drawing exposed for another one. You
can also directly type the drawing name or symbol's cell number if you know it.

Related Topics
•

Keyframes and Drawing Blocks on page 1035

•

Creating a Simple Cut-out Animation on page 1037

•

Selecting Layers to Animate or Position on page 1040

•

Navigating the Hierarchy on page 1044

•

Animating Using the Transform Tool on page 1046

•

Animating using Inverse Kinematics on page 1049

•

Animating in Stop-motion on page 1069

•

Animating Using Computer-generated Interpolation on page 1071

•

Flipping through Poses on page 1076

•

Using the Onion Skin in Cut-out Animation on page 1078

•

Flipping Parts on page 1081

1094

Toon Boom Harmony 10.3 Stage User Guide

•

Animating Using Symbols on page 1083

•

Reusing Extra Drawings, Poses and Facial Expressions on page 1089

•

Adding a New Drawing on the next page

•

Ordering Layers Over Time on page 1097

•

Resetting a Transformation on page 1099
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Adding a New Drawing
If you need to add a new drawing in your scene, you can do it inside the body part’s Symbol or, if you do not use
Symbols, directly on the part’s layer by duplicating the existing drawing on the current frame.

Duplicating a Drawing
If your character does not use Symbols, you need to duplicate the drawing on the cell where you need to use a
new drawing. You could also create a new blank drawing, but duplicating the existing drawing allows you to
keep the pivot you previously set and you can also reuse a portion of the existing artwork. When you create a
new drawing, you get a blank cell with a pivot set at the centre of the Camera view.
To duplicate a drawing:
1. In the Timeline or Camera view, select the drawing to duplicate.

2. From the top menu, select Drawing > Duplicate Drawing or press [Alt] + [Shift] + [D].
The new drawing appears in the currently selected cell.

3. In the Camera view, draw the new piece.

Related Topics
•

Keyframes and Drawing Blocks on page 1035

•

Creating a Simple Cut-out Animation on page 1037

•

Flipping through Poses on page 1076

•

Using the Onion Skin in Cut-out Animation on page 1078

•

Flipping Parts on page 1081

•

Reusing Extra Drawings, Poses and Facial Expressions on page 1089

•

Swapping Images on page 1092
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Ordering Layers Over Time

The layer ordering system in Harmony saves time and simplifies your work. There is no need to create a new
layer or copy and paste artwork into other layers to change the order. The Z-axis (forward/backward) allows you
to create a multiplane and move elements closer or farther from the camera. This allows the puppet’s pieces to
be moved in front of or behind the other ones without physically changing the layer position.

Harmony provides you with a shortcut to move the piece with a micro nudge on the Z-axis. A keyframe is created
where different Z values can be entered. This allows for the piece to move forward and backwards in space
without you having to change the drawing’s original position or break the layer hierarchy.
This also means that the layer ordering is maintained throughout the scene. You can combine animation assets
so the system can interpolate them.
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To nudge elements on the Z-axis:
1. In the Tools toolbar, select the Transform
2. In the Tools toolbar, click the Animate

tool or press [Shift] + [T].
button.

3. In the Camera View, click on the part to be repositioned and hold down the [Alt] key. Using the [Up] or
[Down] arrow keys, nudge the part until it moves to the desired position.

Related Topics
•

Keyframes and Drawing Blocks on page 1035

•

Creating a Simple Cut-out Animation on page 1037

•

Animating in Stop-motion on page 1069

•

Animating Using Computer-generated Interpolation on page 1071

•

Flipping through Poses on page 1076

•

Using the Onion Skin in Cut-out Animation on page 1078

•

Flipping Parts on page 1081

•

Swapping Images on page 1092

•

Adding a New Drawing on page 1096

•

Resetting a Transformation on the facing page

•

Offsetting Part of an Animation on page 1108
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Resetting a Transformation
You may want to reset your character's position if you have made too many transformations and it is not going
where you want it to go, or simply because you want to reset a pose you are reusing from another animation.
Once your layers are positioned in the Camera view, you can easily reinstate them to their original position.

When using the Transform tool to select element in the Camera view, always make sure that the Peg
Selection Mode option in the Tool Properties view is disabled or else it will limit the selection to peg
only.

In the Timeline view, you can also use the Clear All Values command to reset all transformation
values on the selected layers. Right-click on the selected layers and select Layers > Clear All Values.

There are three different ways to reinstate a transformation:
•

Reset below

•

Reset All below

•

Reset All Except Z on the next page

Reset
Use the Reset command to reset the value of the selected element to the initial value of the active tool. For
example, if the Rotate
tool is active, the transformation angle will be reset to 0 and if the Transform
tool
is active, the entire transformation values will be reset.
To reset the transformation on the current frame:
1. In the Tools toolbar, select the Transform

tool or any Advanced Animation

tools.

2. In the Timeline or directly in the Camera view, select the drawing layers you wish to reset. You can select
more than one layer at a time.
3. Select Animation > Reset or press [Shift] + [R].
The selected layers will automatically return to their original position.

Reset All
The Reset All option will reset all transformations on the current frame in a selected layer. Your keyframe will
remain, but all the values will be reinstated to the default position. It will reset all the transformation regardless
of the tool you are using.
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To reset all transformations on the current frame:
1. In the Tools toolbar, select the Transform

tool or any Advanced Animation

tools.

2. In the Timeline or directly in the Camera view, select the drawing layers you wish to reset. You can select
more than one layer at a time.
3. Select Animation > Reset All.
The selected layers will automatically return to their original position.

Reset All Except Z
The Reset All Except Z option will reset all the transformations on the current frame except the Z position. This is
useful when doing cut-out animation. Cut-out puppets often have a particular Z ordering for the different views
of a character. You might want to reset the transformation, but not necessarily the Z position. To do so, you
need to use the Reset All Except Z option.
To reset all transformations except the Z position on the current frame:
1. In the Tools toolbar, select the Transform

tool or any Advanced Animation

tools.

2. In the Timeline or directly in the Camera view, select the drawing layers you wish to reset. You can select
more than one layer at a time.
3. Select Animation > Reset All Except Z.
The selected layers will automatically return to their original position, except for the Z values.

Related Topics
•

Creating a Simple Cut-out Animation on page 1037
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Creating Cycles
If you want to cycle a portion of your animation, you can use the Paste Cycle command. You can also use the
Paste Reverse command to completely reverse the flow of your animation.
To use the Paste Cycle command:
1. In the Xsheet or Timeline view, select the cell range (or symbol cells) and keyframes to loop.

2. In the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4. In the top menu, select Edit > Paste Cycle or press [Ctrl] + [/] (Windows/Linux) or [⌘ ] + [/] (Mac OS X).
The Paste Cycle dialog box opens.

5. In the Number of Cycles field, use the up or down arrows to increase or decrease the number of cycles you
want to paste. You can also type the value directly.
6. In the Cycle Type drop-down menu, select the type of cycle you want to paste.

‣

Normal (forward): Pastes your selection as it is, starting with the first cell and ending with the last
one.

‣

Reverse: Pastes your selection reversed, beginning with the last cell and ending with the first one.

‣

Forward -> Reverse: Pastes your selection as a yo-yo, starting with the first cell, going to the last one
and ending with the first cell.
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Creating Cycles

Reverse -> Forward: Pastes your selection as a reversed yo-yo, starting with the last cell, going to the
first one and ending with the last cell.

7. Click on the OK button to paste your cycles.

You can do the same operation using the Paste Special dialog box. To open the Paste Special dialog
box, select
Edit > Paste Special or press [Ctrl] + [B] (Windows/Linux) or [⌘] + [B] (Mac OS X).

To use the Paste Reverse command:
1. In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.

2. In the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.
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4. In the top menu, select Edit > Paste Reverse or press [Ctrl] + [.] (Windows/Linux) or [⌘ ] + [.] (Mac OS X).

Related Topics
•

Keyframes and Drawing Blocks on page 1035

•

Creating a Simple Cut-out Animation on page 1037

•

Navigating the Hierarchy on page 1044

•

Flipping through Poses on page 1076

•

Using the Onion Skin in Cut-out Animation on page 1078

•

Creating Cycles on page 1101

•

Cut-out Animation Preferences on page 1110
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Copying and Pasting Animation
As you animate you will find that you may reuse a lot of positions, drawings and keys. However, you may only
want to paste the drawings, or just the keys or maybe everything. There are different paste options available in
the Timeline view which will give you the maximum flexibility when reusing and pasting.
There are three different modes for pasting your selection:
•

Paste Mode: All Drawing Attributes
Pastes the drawing exposure and keyframes.

•

Paste Mode: Keyframes Only
Pastes only the keyframes.

•

Paste Mode: Exposures Only
Pastes only the drawing exposure.

To paste a selection using different modes
1. In the Timeline view, select the cells (or symbol cells) you want to copy and paste.

2. Select Edit > Copy cells from the Timeline.
3. In the Timeline view's left side, enable the desired Paste

mode.

4. In the Timeline view's right side, select the cell where you want to paste your selection.

5. Select Edit > Paste Cells in the Timeline.

Note these modes also apply when you use drag instead of copy/ paste.

Paste Mode: All Drawing Attributes
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Paste Mode: Keyframes Only

Paste Mode: Exposures Only

Related Topics
•

Keyframes and Drawing Blocks on page 1035

•

Creating a Simple Cut-out Animation on page 1037

•

Animating Using the Transform Tool on page 1046

•

Swapping Images on page 1092
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Adding Pegs
Now that you have your puppet on your stage, you probably need to resize and reposition it to fit your scene.
When you need to scale down or move your character it's a good idea to hook (attach) the whole puppet to a
trajectory.
In Harmony, there is a type of layer you can add to your timeline allowing you to create a motion path or
reposition drawings. This trajectory layer is called a Peg. Any drawing or layer you hook to a peg will follow the
defined motion path, rotation, scaling and skewing information.
Attaching your puppet to a peg will allow you to scale it and reposition it without having to do it on all of your
different parts and pieces. Only one layer will contain the position information, this makes your animation easier
to modify and control.
To add a repositioning peg:
1. In the Timeline view, click on the Add Peg

button.

2. In the Timeline view, select all of the layers you want to attach to your new peg.
3. Drag your selection right on the peg layer to parent all your character's pieces to the peg.

Next, you need to position your character on the stage by moving it and scaling it to the correct size. You will not
scale each layer individually. You either want to do it on the top symbol or top peg layer.
To reposition the character:
1. In the Timeline view, select the top peg layer (master peg).
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2. In the Tools toolbar, select the Transform

tool and disable the Animate

3. In the Camera view, position the character.

Related Topics
•

Creating a Simple Cut-out Animation on page 1037

•

Selecting Layers to Animate or Position on page 1040

•

Navigating the Hierarchy on page 1044
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Offsetting Part of an Animation
If there is a section of your animation that you want to reposition such as the head's height or the puppet's
position, you can do it using the function curve.
To reposition a portion of an animation:
1. In the Timeline view, click on the Expand Function

button of the body part layer to reposition. If you

want to reposition the entire body, expand the master peg's parameters.

2. Double-click on the layer's parameter controlling the keyframes you want to reposition.

The Function Editor opens.
3. In the Function editor, select the keyframes you want to reposition by tracing a selection box.

4. Enable the Show Current Frame option view the transformation results in the Camera view as you do
them.

5. Drag the keyframes selection up or down to reposition your sequence.
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6. Close the Function editor.

Related Topics
•

Keyframes and Drawing Blocks on page 1035

•

Creating a Simple Cut-out Animation on page 1037

•

Animating using Inverse Kinematics on page 1049

•

Animating in Stop-motion on page 1069

•

Animating Using Computer-generated Interpolation on page 1071
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Cut-out Animation Preferences
When looking for additional control over your Min/Max Angle when using Inverse Kinematics, you can find some
help in the preference panel.
You will find the preferences listed under the following tab:
•

Camera

To open the Preferences panel:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

The keyboard shortcut is [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).

Camera
Inverse Kinematics
•

Min/Max Angle Constraint Weight: This value acts similar to the Stiffness setting in the Inverse
Kinematics Properties panel. This preference only affects the minimum and maximum angle values set
using the Min/Max Angle Mode
. The greater the value is, the stronger your need to move the body
part to approach the minimum and maximum values set. Although the maximum value goes up to 1.0, in a
production setting, the most practical value to use would be closer to 0.1.

Advanced
When you want to set the default layer type to only accept motion information through the use of a peg, you can
find some help in the preference panel.

Animate Using Animation Tools
•

Element Module “Animate Using Animation Tools” Default Value: If you know that you prefer to work
in the style of version 7.3 or earlier, or if you intend to substitute many drawings throughout your
animation, you might wish to uncheck the Animate Using Animation Tools Default Value option. This
way, you will not have to do it every time (through the Layer Properties) for each new drawing layer that
you create.
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Chapter 18: Deformation

Harmony provides you with the deformation technology to deform bitmap and vector drawings over a period of
time. These deformers can be linked to create a hierarchy of deformation. This technology allows you to deform
a character made out of one, or many, drawing or image layers and make it move as if it were a cut-out puppet.
It also allows you to take an area in a single bitmap image and create animation by distortion.

Topics Covered
•

About the Deformation Effect on the next page

•

Creating a Basic Deformation Rig on page 1148

•

Manipulating a Deformer to Create Animation on page 1187

•

Deformation Basics on page 1136

•

Deformation Toolbar on page 1139

•

Storing the Character in the Library on page 1186

•

Creating a Full Character Turnaround Deformation Rig on page 1154

•

Optimizing the Skeleton on page 1169

•

Deformation Preferences on page 1195
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About the Deformation Effect

About the Deformation Effect
The Deformation effect can be used to animate bitmap or vector-based graphics – it even works on gradients
and textures. The Deformation effect acts as a skeleton in which you can maneuver different articulations or
bend it into a fluid curve. It can be useful in many situations including cut-out animation. When paired with your
creativity, the Deformation effect can produce some stunning results.

The Deform Group will be created automatically when using the Rigging tool. However if you want
to create a Deform manually, all the modules can be accessed from the Module Library, under the
Deformation tab.

Related Topics
•

Main Types of Deformer below

•

Deformer Effects on page 1115

Main Types of Deformer
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There are two main types of deformer:
•

Bone Deformer below

•

Curve Deformer below

Bone Deformer

The Bone Deformer allows you to create a basic or advanced skeleton structure in which the parent deformer will
move the child deformers. The Bone Deformer is mostly used when animating the extremities of a character,
such as the arms or legs, and will add fluidity and a natural feel to the animation. The Bone effect can be
manipulated to rotate a limb at an articulation joint and to shorten or elongate the extremities of a limb. Every
Bone module within a skeleton chain is linked by an Articulation module.

Curve Deformer

The Curve Deformer has a hierarchy similar to that of the Bones Deformer and provides you with complete
flexibility. For example, when editing curves, you can deform a straight line into an arc or a zigzag with only a few
clicks. Curve Deformers are mostly used to animate elements that do not have joints, such as hair or facial
features. However, in some cases they can be used to animate limbs to create a specific animation genre, similar
to the early rubber hose style of animation with typically simple, flowing curves without articulation (no hinged
wrists or elbows).

Related Topics
•

Articulation on page 1115
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•

Creating a Basic Deformation Rig on page 1148

•

Creating a Full Character Turnaround Deformation Rig on page 1154

•

About the Deformation Effect on page 1112

•

Deformer Effects on the facing page
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Deformer Effects
There are 13 deformer effects modules. These enhance the existing deformation by applying specific types of
effects to the Bone Deformer or the Curve Deformer. Secondary deformers must be used in conjunction with
either the Bone Deformer or the Curve Deformer to work:
•

Articulation below

•

AutoFold on page 1118

•

Auto-Muscle on page 1118

•

Deformation-Composite on page 1121

•

Deformation-Root on page 1123

•

Deformation-Scale on page 1123

•

Deformation-Switch on page 1126

•

Deformation-Uniform-Scale on page 1127

•

Deformation-Wave on page 1128

•

Fold on page 1131

•

Offset on page 1133

Articulation
The Articulation module is used between two bones to create a joint where the limb or element will rotate.
When you create a bone structure using the Rigging

tool, an Articulation module is automatically added

between every two bones that you create. You can also add an Articulation module to your Bone deformation
effect in the network to add a supplementary articulation to any existing limb previously built using the Rigging
tool and Setup Mode. This module can also be used to manually build a bone structure. The Articulation module
works best when inserted between two Bone modules.

If you adjust your rig in Setup Mode with the Transform tool, it will adjust these parameters for you. However,
you can manually set the Articulation effect module parameters in the Layer Properties dialog:
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•

Name: Use this field to rename the Articulation module.

•

Influence Type: Use the drop-down menu to choose between the different Zone of Influence types. This
is the area of the drawing surrounding the deformer which will be influenced by the deformation.

•

Influence Fade Radius: Enter the your Fade Radius value for the Zone of Influence. You can also use the
up and down arrow buttons to select a value.

•

Symmetric Ellipse of Influence: This option is enabled by default. When enabled, the shape of the ellipse
will be symmetrical on both transversal and longitudinal radius.
•

When Symmetric Ellipse of Influence is ENABLED: The value for Transversal Influence Radius Left will
define the value for the Transversal Influence Radius Right.

•

When Symmetric Ellipse of Influence is ENABLED: The Transversal Influence Radius End value will
define the value for the Transversal Influence Radius Begin.

If you want to define individual values for these, then disable the Symmetric Ellipse of Influence and
enter the values required for each.

•

Transversal Influence Radius Left: When the Symmetric Ellipse of Influence option is enabled, this field
controls both the Left and Right Transversal Radius values. When the option is disabled, enter the value in
this field to control the size of the Left Transversal Radius.

•

Transversal Influence Radius Right: When the Symmetric Ellipse of Influence option is enabled, the value
in this field will be unused. When the option is disabled, enter the value in this field to control the size of
the Right Transversal Radius.

•

Longitudinal Influence Radius Begin: When the Symmetric Ellipse of Influence option is enabled, the
value in this field will be unused. When the option is disabled, enter the value in this field to control the
size of the radius at the beginning of the deformer.

•

Longitudinal Influence Radius End: When the Symmetric Ellipse of Influence option is enabled, this field
controls both End and Begin longitudinal radius values. When the option is disabled, enter the value in
this field to control the size of the radius at the end of the deformer.

•

Rest Radius: This is the resting radius of the articulation (size of the circle). You can enter your own radius
value directly in this field or use the up and down arrow buttons to set the radius value.

•

Resting Orientation: This is the resting rotation angle value of the articulation. You can enter your own
angle degree value in this field or use the up and down arrow buttons to set the angle value.

•

Rest Bias: This is the resting bias value of the articulation, which can also be seen as the steepness of the
articulation. The smaller the bias value the smoother the articulation angle and the larger the bias value
the more angular the articulation is. You can enter the bias value in this field or use the up and down arrow
buttons to set the value.

•

Radius: This is the radius of the articulation (size of the circle). You can enter the radius value directly in
this field or use the up and down arrow buttons to set the radius value. When animated, this value will be
connected to a function.

•

Orientation: This is the rotation angle value of the articulation. You can enter the angle degree value in
this field or use the up and down arrow buttons to set the angle value of your choice. When animated, this
value will be connected to a function.
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•

Bias: This is the bias value, which can also be seen as the steepness of the articulation. You can enter the
bias value in this field or use the up and down arrow buttons to set the value of your choice. When
animated, this value will be connected to a function.

These settings can also be modified and set up in the Camera view. Refer to following topics to learn
how:
•

Optimizing the Skeleton on page 1169

•

Manipulating a Deformer to Create Animation on page 1187

Related Topics
•

Main Types of Deformer on page 1112

•

Deformer Effects on page 1115

•

AutoFold on the next page

•

Auto-Muscle on the next page

•

Deformation-Composite on page 1121

•

Deformation-Root on page 1123

•

Deformation-Scale on page 1123

•

Deformation-Switch on page 1126

•

Deformation-Uniform-Scale on page 1127

•

Deformation-Wave on page 1128

•

Fold on page 1131

•

Offset on page 1133
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AutoFold

The AutoFold module is used to automatically fix the folding area of a deformer so that no line overlap occurs.
The AutoFold module is similar to the Fold module, but since it is automated it is optimized to fit the most
standard folding point with less controls to set up.
This effect module is best used with Curve Deformers.
To use the AutoFold module:
1. In the Camera view, enable Render

mode to preview what the fold will finally look like.

2. In the Network view, navigate to the deformation effect module which is causing the unwanted overlap.
3. In the Module Library, select an AutoFold module and drag it to the Network view. Note that the
AutoFold module name changes to AutoFold as it enters the Network view.
4. Connect the AutoFold module directly under the deformation effect module which is causing the
unwanted line effect.
5. Click on the square yellow button to open the AutoFold Layers Properties dialog box. This is where you
can customize the AutoFold settings.

‣

In the Enable AutoFold field, type 1 to enable it or 0 to disable the effect. If you connect this option to
a function then you can enable or disable the effect at a specific point in your animation.

‣

In the Length field, use the up and down arrows to set the length of the fold axis line or directly type in
the desired value.

‣

Click on Close to close AutoFold Layer Properties dialog box.

Auto-Muscle
The Auto-Muscle module is used to simulate muscle movement, using this will allow your characters to flex their
muscles when they lift something or to create muscle-tone when they move. When the Auto-Muscle module is
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connected to a Bone Deformer and that deformer is rotated, the drawing is automatically inflated to simulate
muscle movement in the limb.
To use the Auto-Muscle module:
1. In the Network view, navigate inside the Deformation Group you want to add an Auto-Muscle effect to.
2. In the Module Library, select an Auto-Muscle module and drag it to the Network view. Note that the
Auto-Muscle module name changes to Auto-Muscle as it enters the Network view.
3. Connect the Auto-Muscle module directly under the Articulation and after the Bone you want the effect to
be applied to.

4. In the Network view, click on the Auto-Muscle module’s square yellow button to open the Layer
Properties dialog box.

5. You can set the following parameters in the Auto-Muscle Layer Properties dialog box:
‣

Name: Use this field to rename the module.

‣

Muscle Left: This option is enabled by default. When enabled, the left side of the Bone Deformer will
inflate as the articulation is rotated toward the direction of the Bone Deformer. Disable this option if
you do not want the left side of the bone to inflate.
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‣

Left Start: The default value of the starting position of the left-side muscle is set to -2. This means that
it will start at the deformer situated 2 steps before the position where the Auto-Muscle is connected.
In this case, you can change the starting point by typing the number corresponding to the deformer
module.

‣

Left Span: This parameter controls the length (muscle length) over which the effect module will be
applied to the left side of the deformer. By default the setting is 1, representing the length of the
deformer it is applied to.

‣

Left Amplitude: This parameter controls the physical size of the left muscle. Increase the value to
make the muscle bigger, decrease the value to make it smaller.

‣

Muscle Right: This option is enabled by default. When enabled, the right side of the Bone Deformer
will inflate as the articulation is rotated toward the direction of the Bone Deformer. Disable this option
if you do not want the right side of the bone to inflate.

‣

Same as Left: This option is enabled by default, allowing each side of the Bone Deformer to inflate to
follow the rotation of the articulation. Enable this option to synchronize the right muscle with the left
so that both muscles will inflate when the articulation is rotated to the left.
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‣

Right Start: The default value of the starting position of the right-side muscle is set to -2. This means
that it will start at the deformer situated 2 steps before where the Auto-Muscle is connected, in this
case, Bone. You can change the starting point by typing the number corresponding to the deformer
module.

‣

Right Span: This parameter controls the length (muscle length) over which the effect module will be
applied to the right side of the deformer. By default the setting is 1, representing the length of the
deformer it is applied to.

‣

Right Amplitude: This parameter controls the physical size of the right muscle. Increase the value to
make the muscle bigger, decrease the value to make it smaller.

Deformation-Composite
Just like a standard Composite module, the Deformation-Composite module is used to bring together all the
elements that are connected to it, allowing you to customize parameters that will influence the result of the
output.
The Deformation-Composite links the deformation chain to the graphic element it is related to. This is
automatically added to your Deformation Group when creating a deformer chain with the Rigging
tool.

You can set up the following parameters in the Deformation-Composite Layer Properties dialog box:
•

Name: Use this field to rename the module.

•

Output Kinematic Only: This option is disabled by default, allowing the deformation chain to be output
correctly. This option should be enabled in order to output the chain information position only. This will
allow you to connect a part to the hierarchy without it undergoing the deformation applied to the rest of
the chain. See Assembling the Parts on page 1161.

•

Output Selected Port Only: This option is important if you have several deformation chains for one
element, as in the case of a character with multiple poses.
•

If this option is disabled, all the different chains for this element will be used at once.

•

If this option is enabled, it will only use the selected chain, which you will be able to define in the
Output Kinematic Chain options of the Deformation-Composite.
In some situations, this option is enabled and setup automatically (For example, when you are working
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with the Create Posed Deformer in Create Deformation Above/Under enabled).
See Creating a Full Character Turnaround Deformation Rig on page 1154.
•

•

Output Kinematic Chain: This parameter is used when the Output Selected Port Only option is enabled.
This drop-down menu lets you select which deformation chain option to use.

•

Rightmost: If you select this option, only the first chain connected to the right of the composite
module will be used.

•

Leftmost: If you select this option, only the first chain connected to the left of the composite module
will be used.

•

Select: If you select this option, you can define which chain to output according to the order they are
connected from left to right.

•

Use First Connected Element’s Exposure as Key: This option allows the deformation effect to
automatically detect which deformation chain to use (subgroup), by detecting the exposure of the first
element connected to the deformation. This option is used in the case of a multiple pose rig. See
Creating a Full Character Turnaround Deformation Rig on page 1154.

•

Use Parent Composite’s Connected Element Exposure: This option is used with the Output
Kinematic Only option enabled. It uses the information from the parent element’s exposure to attach
the child to the correct chain, following which pose is exposed.
See Assembling the Parts on page 1161.

Output Kinematic Chain Selection: This option is used when the Output Selected Port Only option is
enabled AND the Select option is used as the Output Kinematic Chain setting. Use this field to define
which deformation chain you wish to use on your element. Select the number which corresponds to the
left to right order that the chains are connected to the Deformation-Composite module.

You can attach this value to a function and enable different chains over a period of time on specific frames.
This value can be modified in the Timeline view by using the Deformation-Switch layer. Since the
Deformation-Composite module is only visible in the Network view, the layer has a reference to this
parameter enabling you to easily edit the value when working in the Timeline view
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Note that if you are working with Create Posed Deformer in Create Deformation Above/Under
enabled, you will not need to setup this option. The settings in the Deformation-Composite module
will automatically be setup and the system will recognize which chain to use following the element’s
exposure. See Creating a Full Character Turnaround Deformation Rig on page 1154.

Deformation-Root
The Deformation-Root is the starting point and pivot for the deformer chain. When you use the Rigging

tool,

this module is automatically added to the top of your deformation chain in the Deformation Group.

You can modify the quality level of the deformation effect in the Deformation-Root Layer Properties dialog box:
•

Name: Use this field to rename the module.

•

Quality: The quality level decides the number of slices the graphic is split into and used when undergoing
a deformation. The higher the quality level, the more slices are created and the smoother the deformation
applied to the graphic. Use the drop-down menu to choose between 5 levels of quality:
•

Low

•

Medium

•

High

•

Very High

•

Extreme

Deformation-Scale
The deformers can only be scaled along the centre axis to adjust the length of the limb. The Deformation-Scale
can be used in combination with a Bone or Curve deformer to scale a drawing so it follows the opposite direction
of the deformer axis (the width). For example, when combined with function curves this can be used to create
advanced muscle effects. All these settings can be animated over time.
To set up the Deformation-Scale effect module:
1. In the Network view, navigate inside the Deformation Group to which you want to add a DeformationScale effect.
2. In the Module Library, select a Deformation-Scale module and drag it to the Network view. Note that the
Deformation-Scale module name changes to Deformation-Scale as it enters the Network view.

1123

Chapter 18: Deformation

Deformer Effects

3. Connect the Deformation-Scale module directly under the lower deformer module of your chain.

4. In the Network view, select the Deformation-Scale module and select View > Show > Control to display
its controls in the Camera view. Refer to Displaying the Deformation Controls on page 1136 for more
information about display options.

5. Click on the square yellow button of the Deformation-Scale module to open the Layer Properties dialog
box.

‣

Name: Use this field to rename the module.
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‣

Scale Left: This option is enabled by default. It allows the left side of the deformer to be scaled. In the
Camera view, the dark blue controls are used for the left side. If you disable this option, the controls
will be hidden and no scaling deformation will occur for this side.

‣

Left Fade In: The value is set to 0 no fade, by default. Increase the value to add a fade effect to
smoothen the transition between the starting point of the scale and the area situated before it.

‣

Left Fade Out: The value is set to 0 no fade, by default. Increase the value to add a fade effect to
smooth the transition between the Left Span point of the scale and the area situated after it.

‣

This series of options controls the left side scaling deformation.

‣

Scale Right: This option is enabled by default. It allows the right side of the deformer to be scaled. In
the Camera view, the light blue controls are used for the right side. If you disable this option, the
controls will be hidden and no scaling deformation will occur for this side.

‣

Same as Left: This option is disabled by default. It means that the left and right sides will use different
scaling parameters. If you enable this option, the right side controls will be hidden in the Camera view
and the left parameters will be used for both side for a symmetrical scaling effect.

‣

Right Fade In: The value is set to 0 no fade, by default. Increase the value to add a fade effect to
smoothen the transition between the starting point of the scale and the area situated before it.

‣

Right Fade Out: The value is set to 0 no fade, by default. Increase the value to add a fade effect to
smoothen the transition between the Right Span point of the scale and the area situated after it.

‣

This series of options controls the left side scaling deformation.

6. In the Layer Properties dialog box, you can set up all the parameters.
7. In the Tools toolbar, select the Transform

tool.

8. In the Camera view, setup the Deformation-Scale module (you can also setup these parameters directly in
the Layer Properties):
‣

To modify the scaling value of the curve, drag the two control handles away and forward from the
deformation axis.

‣

Move the first blue arrow along the deformer’s central axis to setup the starting point of the
Deformation-Scale and the last arrow to setup the length (span) of the transformation.

‣

Drag the square scaling curve control points away and forward the deformer axis to setup the scaling
value at the starting and ending point.
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Drag the two middle blue arrows along the deformer’s centre axis to setup the position of the curve
handles.

9. You can animate the different parameters of the Deformation-Scale module by enabling the Animate
mode in the Tools toolbar and adding keyframes. In this case, different values will be connected to
functions.

If you feel the controls are too far away from the deformer, you can change the default display of the
Deformation-Scale and Deformation-Uniform-Scale controls in the Preferences panel to bring them
closer. Refer to Deformation on page 1197 to learn more.

Deformation-Switch
The Deformation-Switch module acts as a On and Off switch for the deformation chain. It is also the module
which controls the Zone of Influence Fade area. The Deformation-Switch also displays a Kinematic Chain
Selection Reference option, this allows you to modify the chain selection directly in the Timeline view.

•

Name: Use this field to rename the module.
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•

•

Vector Quality: The quality level influences the quality of the deformation effect when your drawings are
stretched and deformed:
•

Low

•

Medium

•

High

•

Very High

•

Extreme

Influence Fade Exponent: Use the up and down arrows to modify the exponent value, or enter the exact
value in the field.
•

A value of 1 is similar to a linear curve.

•

A higher value will result in an ease-in type of curve.

•

A lower value will result in an ease-out type of curve.

•

Fade Inside Region: This option is disabled by default. The fade effect will occur outside of the Zone of
Influence. You can enable this option to have the fade effect inside the Zone of Influence.

•

Enable Deformation: This field acts as an On/Off switch for the deformation. The value of this field is set
to 1 by default, this means the deformation is enabled. You can enter a value of 0 to disable it.

•

Kinematic Chain Selection Reference: This parameter determines which chain is selected and used at a
specific frame. It is a reference to the option you can find in the Deformation-Composite module. Having
this reference in the Deformation-Switch module allows you to use and modify the chain selection value
directly in the Timeline view since the Deformation-Composite module is only visible in the Network view.

Refer to Optimizing the Skeleton on page 1169 > Zones of Influence on page 1176 to learn more
about Zones of Influence.

Deformation-Uniform-Scale
The Deformation-Uniform-Scale effect module is used to create the squash and stretch effect on your animated
deformation rig. It will let you scale the rigged element on the opposite axis of the deformer (width).
To use the Deformation-Uniform-Scale module:
1. In the Network view, navigate inside the Deformation Group to which you want to add a DeformationUniform-Scale module to.
2. In the Module Library, select an Deformation-Uniform-Scale module and drag it to the Network view.
Note that the Deformation-Uniform-Scale module name changes to Deformation-Uniform-Scale as it
enters the Network view.
3. Connect the Deformation-Uniform-Scale module directly below the lowest deformation module in your
chain.
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4. In the Network view, select the Deformation-Uniform-Scale module.
5. To display the Uniform Scale controls in the Camera view, or press [Shift] + [F11]. Refer to Displaying the
Deformation Controls on page 1136 for more display options.
6. In the Camera view, grab the handle and drag it to resize the width of the limb. You can also use the Scale
field to type in a specific value. This parameters can be animated over time.

If you feel the controls are too far away from the deformer, you can change the default display of the
Deformation-Scale and Deformation-Uniform-Scale controls in the Preferences panel to bring them
closer. Refer to Deformation Preferences on page 1195 > Deformation on page 1197 to learn
more.

Deformation-Wave
The Deformation-Wave effect deforms the chain by adjusting the scaling in a waveform style. It can be used to
animate a wave deformation effect on your deformation chain over a period of time.
To use the Deformation-Wave effect:
1. In the Network view, navigate inside the Deformation Group to which you want to add a DeformationWave effect to.
2. In the Module Library, select an Deformation-Wave module and drag it to the Network view. Note that
the Deformation-Wave module name changes to Deformation-Wave as it enters the Network view.
3. Connect the Deformation-Wave module to your deformation chain.
You will immediately notice that a wave deformation is applied to the limb or art connected to the
deformation chain.
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4. In the Network view, click on the Deformation-Wave module’s square yellow button to open the Layer
Properties dialog box.

5. You can set the following parameters in the Deformation-Wave Layer Properties dialog box:
‣

Name: Use this field to rename the module.

‣

Wave Left: This option is enabled by default, allowing the Deformation-Wave effect to be applied on
the left side of the deformer chain. Disable this option to prevent the effect from being applied.

‣

Left Start: This parameter defines the starting point of the left wave deformation. The default value is
0 and represents the Deformation-Root. Each main control point count for +1.

‣

Left Span: This parameter defines the length of the left wave effect.

‣

Left Offset Deformer: This is the parameter you may want to connect to a function. It controls the
offset of the deformation on the left side and allows you to create a fluid wave animation along the
deformer axis.

‣

Left Amplitude: This parameter controls the height of the left wave effect.

1129

Chapter 18: Deformation

Deformer Effects

‣

Left Offset Scaling: This parameter is used to apply an offset value to the amplitude of the left wave.
The wave will be lifted and become higher, or dropped and become lower, depending whether the
value is increased or decreased.

‣

Left Period: This value controls the interval of occurrence of the left waves. By default the value is 1,
meaning that a wave will occur for every deformer. If you decrease the value at 0.5 it will result in a
wave occurring every half deformer.

‣

Wave Right: By default this option is enabled, allowing the Deformation-Wave effect to be applied on
the right side of the deformer chain. Disable this option to prevent the effect from being applied.

‣

Same as Left: This this option is disabled by default. It allows the left and right size of the
Deformation-Wave to be controlled separately. Enable this option if you want the effect to be
symmetrical and controlled by the left side parameters.

‣

Right Start: This parameter defines the starting point of the right wave deformation. The default value
is 0 and represents the Deformation-Root. Each main control point count for +1.

•

Right Span: This parameter defines the length of the right wave effect.

•

Right Offset Deformer: This is the parameter you might want to connect to a function. It controls the offset of the
deformation on the right side, allowing you to create a fluid wave animation along the deformer axis.

•

Right Amplitude: This parameter controls the height of the right wave effect.

•

Right Offset Scaling: This parameter is used to apply an offset value to the amplitude of the right wave. The wave
will be lifted and become higher, or dropped and become lower, depending whether the value is increased or
decreased.
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•

Right Period: This value controls the interval of occurrence of the right side waves. By default the value is 1,
meaning that a wave will occur for every deformer. If you decrease the value at 0.5 it will result in a wave occurring
every half deformer.

Fold

The Fold is used when bending a deformation further than the drawing is able to take it. This may result in an
unwanted overlap of the line art at the junction of the articulation or deformation. The Fold will let you control
certain parameters that will help eliminate the unwanted line effect.

To set up the Deformation-Fold effect module:
1. In the Camera view, enable Render

mode to preview the fold. This will help you setup the

Deformation-Fold effect as accurately as possible.
2. In the Network view, navigate to the deformation effect module causing the unwanted overlap. (In this
case, an articulation)
3. In the Module Library, select a Fold module and drag it to the Network view. Note that the Fold module
name changes to Deformation-Fold as it enters the Network view.
4. Connect the Deformation-Fold module directly under the deformation effect module which is causing the
unwanted line effect.
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5. In the Network view, select the Deformation-Fold module and select View > Show > Control to display
its controls in the Camera view. Refer to Displaying the Deformation Controls on page 1136 for more
display options.
6. In the Tools toolbar, select the Transform

tool.

7. In the Camera view, setup the Deformation-Fold (you can also set these parameters directly in the
Deformation-Fold Layer Properties):
‣

Click on the fold axis and rotate it to match the angle of the bend articulation.

‣

Use the middle arrow to position the axis along the deformer’s central line. It should be in the corner
of the bending area.

‣

Use the right and left arrows to control the appearance of the two overlapping lines.
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‣

Use the axis’ square handle to elongate or shorten the length of the axis.

8. If your character moves a lot and you need to adjust the fold at different positions to follow the limb
animation, you can setup the Deformation-Fold effect in a different position over time. Do this by enabling
the Animation
mode in the Tools toolbar and adding keyframes. In this case, the different values will
be connected to functions.
9. You can also enable and disable the Deformation-Fold effect over time by connecting a function to the
Enable Fold parameter in the Layer Properties. A value of 1 enables the effect, a value of 0 disables the
effect.

Offset
The Offset module lets you position the root of your deformation chain. It is automatically added to your
Deformation Group when you create a deformation rig using the Rigging
tool.
When you move your chain using Setup Mode

, the values at the top section of Layer Properties will be

updated to follow the new resting position. If you move the chain without being in the Setup Mode, you will be
able to animate the active position of the chain over time, in that case the bottom values will be connected to
functions.
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•

Name: Use this field to rename the module.

•

(x) Axis: This value sets the resting position of the Deformation-Root on the X (east/west) axis. You can
enter the value, use the up and down arrow buttons to choose a value, or use the Transform
tool
while in Setup Mode

•

to reposition the deformation chain.

(y) Axis: This value sets the resting position of the Deformation-Root on the Y (north/south) axis. You can
enter the value, use the up and down arrow buttons to choose a value, or use the Transform
tool
while in Setup Mode

to reposition the deformation chain

•

Resting Orientation: This value sets the rotation angle of the resting position of the Deformation-Root.
You can enter the angle, use the up and down arrow buttons to choose the desired value, or use the
Transform
tool while in Setup Mode
to rotate the deformation chain.

•

Type: Use this drop-down menu to choose the type of coordinates you want to use:

•

•

Separate: The two coordinates are set separately. If they are connected to a function, each one will
have its own function curve. This is the default setting.

•

2D Path: The two coordinates are set together within a single 2D path function.

(x) Axis: This option is only available when the Type is set to Separate. It is used to set the active position
value of the Deformation-Root on the X (east/west) axis. You can enter the value, use the up and down
arrow buttons to choose a value, or use the Transform
tool when Setup Mode is NOT enabled to
move the deformation chain. Remember, that if you want to add a keyframe, you need to enable
Animation
mode from the Tools toolbar.

•

(y) Axis: This option is available when the Type is set to Separate. It is used to set the active position value
of the Deformation-Root on the Y (north/south) axis. You can enter the value, use the up and down arrow
buttons to choose a value or use the Transform
tool when Setup Mode is NOT enabled to move the
deformation chain. Remember, that if you want to add a keyframe, you need to enable Animation
mode from the Tools toolbar.

•

Path: This option is only available when the Type is set to 2D Path. It is used to set the active position
value of both Y and X axis. Use the Transform
tool when Setup Mode is NOT enabled to move the
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deformation chain along the 2D path. Remember, that if you want to add a keyframe, you need to enable
the Animation
mode from the Tools toolbar.
•

Orientation: This value sets the rotation angle of the active position of the Deformation-Root. You can
enter the angle, use the up and down arrow buttons to choose the desired value, or use the Transform
tool when Setup Mode is NOT enabled to rotate the deformation chain. Remember, that if you want
to add a keyframe, you need to enable Animation
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Deformation Basics
The following topics explain the essential items you need to know before starting to work with Deformation
effects:
•

Setting the Performance Preferences below

•

Displaying the Deformation Controls below

•

Deformation in the Network and Timeline Views on the facing page

Setting the Performance Preferences
There are some preferences that you must set in order to work efficiently with the Deformation effects. Do the
following:
Setting up the performance preferences:
1. Open the Preferences panel:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

Or press [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).

2. Choose the OpenGL tab.
3. In the Settings section:
‣

Enable the Use Hardware Vertex Texture Fetching if Available preference.
This preference is disabled by default, however it is strongly recommended that you enable it before
using the deformers. If your CPU and graphic card allow it, the system will use vertex shaders to
considerably help the process of deformation.

4. In the Real-Time Antialiasing section:

‣

Make sure the Real-Time Antialiasing options are disabled. Uncheck the Enable checkbox.

Related Topics
•

Displaying the Deformation Controls below

•

Deformation in the Network and Timeline Views on the facing page

Displaying the Deformation Controls
To be able to manipulate the deformer outside of the Setup Mode, you must enable the Deformation Controls.
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If you have just created the bone rig, the controls will still be showing. However, whenever you close
your project the deformers are turned off, so when you reopen the project you can show the ones
you need while you're animating.

You can also select all the modules from your Network view and select View > Show > Controls from the top
menu.
To display the selected deformation controls:
1. In the Network view, select the Deformation Group containing the deformation chain you want to display.
2. In the Camera View toolbar, click on the Show Control

button. You can also select View > Show >

Control from the top menu or press [Shift] + [F11].
To display the selected deformation controls and hide all the others:
1. In the Network view, select the Deformation Group containing the deformation chain you want to display.
2. In the Deformation toolbar, click on the Show Selected Deformers and Hide All Others

button.

The selected deformation controls will appear in the Camera view and all the others will be hidden.
To display all the deformer controls at the same time:
1. In the Top level of the Network view,select Edit > Select All from the top menu to select all the modules
or press [Ctrl] + [A] (Windows/Linux) or [⌘ ] + [A] (Mac OS X).
2. In the Camera View toolbar, select Show Control

or press [Shift] + [F11]. This will display all the

deformation controls in your scene.
To hide the deformer controls:

‣ In the Camera View toolbar, click on the Hide All Controls

button. You can also select View > Hide

All Controls from the top menu or press [Shift] + [C].

Related Topics
•

Setting the Performance Preferences on the previous page

•

Deformation in the Network and Timeline Views below

Deformation in the Network and Timeline Views
The deformation effect layers and modules are visible in the Network and Timeline views. You can modify the
value and set up the function curves using both views.

Refer to Animation Paths on page 937 to learn how to work with functions.
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Related Topics
•

Setting the Performance Preferences on page 1136

•

Displaying the Deformation Controls on page 1136
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Deformation Toolbar
The Deformation toolbar contains the various tools and options used to create the Deformation Effect, the
toolbar is displayed in the default interface.

Related Topics
•

Rigging Tool below

•

Setup Mode on page 1143

•

Show All Manipulators on page 1143

•

Show All Zones of Influence on page 1143

•

Show Simplified Manipulators on page 1144

•

Show Selected Manipulators and Hide All Others on page 1144

•

Insert Deformation Above on page 1145

•

Insert Deformation Under on page 1145

•

Create Kinematic Output on page 1145

•

Copy Resting Position to Current on page 1146

•

Convert Ellipse on page 1146

•

Convert to New Drawing and Add Pose

Rigging Tool
The Rigging Tool is used to create either a Bone or Curve Deformation Chain and automatically create a
Deformation Group on a selected element. Using this tool considerably speeds up the rigging process by
automatically creating all the necessary links and modules for your Deformation Chain.
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Rigging Tool Properties

In the Rigging Tool Properties dialog box, you can customize not only the behavior of the tool but also the
settings of the deformers that you will create:
•

Mode on the facing page

•

Options on the facing page

•

Operations on page 1142
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Mode
•

Automatic Mode: When the tools properties are set to Automatic mode, the Rigging tool will
automatically create either a Bone or Curve deformer, corresponding to the movement of the cursor in
the Camera view.

•

Bone Mode: When the tools properties are set to Bone mode, the Rigging tool will create Bone
deformers.

•

Curve Mode: When the tools properties are set to Curve mode, the Rigging tool will create Curve
deformers.

•

Show All Manipulators: The Show All Manipulators mode lets you immediately see the resting
position in red (Setup) and the animated position in green. Refer to the Show All Manipulators on
page 1143 section below to learn more.

•

Show All Zones of Influence: The Show All Zones of Influence lets you visualize the area within which
the art will be influenced by the deformation effect—see Show All Zones of Influence on page 1143.

Options
•

Articulation: You can choose which Zone of Influence setting will be used by default when creating an
articulation using the Rigging tool. You can choose between these 4 options:
•

Zero Influence: The Zone of Influence does not exist. No deformation will happen.

•

Infinite Influence: This is the default option and is the most commonly used. The Zone of Influence
has no boundary and covers the whole element to which the deformer is linked and its children,
excluding areas that are already part of another elliptic or shaped Zone of Influence. The Infinite
Influence zone will extend from the centre of your skeleton to infinity, working perpendicular to the
skeleton.

•

Elliptic Influence: The Zone of Influence boundary is defined by an elliptical shape which size can be
customized using the Bone, Articulation or Curve module properties or by using the Transform
tool. The Elliptic Influence will most likely be used on a bitmap picture you wish to deform.

•

Shaped Influence: The Zone of Influence boundary is defined by a shape which you can customize
using the Transform
tool. The Shaped Influence will most likely be used on a bitmap picture you
wish to deform.

•

Influence Radius: This value is the size of the influence zone. The default value is 2.

•

BoneRatio: This value sets the size of the articulation that will be created relative to the size of the bone
that precedes it.

•

Bone: You can choose which Zone of Influence setting will be used by default when creating a bone
deformer using the Rigging tool. You can choose between these 4 options:
•

Zero Influence: The Zone of Influence does not exist. No deformation will happen.

•

Infinite Influence: This is the default option and is the most commonly used. The Zone of Influence
has no boundary and covers the whole element which the deformer is linked to and its children,
excluding areas that are already part of another elliptic or shaped Zone of Influence. The Infinite
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Influence zone will extend from the centre of your skeleton to infinity, working perpendicular to the
skeleton.
•

Elliptic Influence: The Zone of Influence boundary is defined by an elliptical shape which size can be
customized using the Bone, Articulation or Curve module properties or by using the Transform
tool. The Elliptic Influence will most likely be used on a bitmap picture you wish to deform.

•

Shaped Influence: The Zone of Influence boundary is defined by a shape which you can customize
using the Transform
tool. The Shaped Influence will most likely be used on a bitmap picture you
wish to deform.

•

Influence Radius: This value is the size of the Zone of Influence. The default value is 2.

•

Curve: You can choose which Zone of Influence setting will be used by default when creating a curve
deformer using the Rigging tool. You can choose between these 4 options:
•

Zero Influence: The Zone of Influence does not exist. No deformation will happen.

•

Infinite Influence: This is the option selected by default and is the most commonly used. The Zone of
Influence has no boundary and covers the whole element which the deformer is linked to and its
children, excluding areas that are already part of another elliptic or shaped Zone of Influence. The
Infinite influence zone will from the centre of your skeleton, going toward infinity, working in
perpendicular with the skeleton.

•

Elliptic Influence: The Zone of Influence boundary is defined by an elliptical shape which size can be
customized using the Bone, Articulation or Curve module properties or by using the Transform
tool. The Elliptic Influence will most likely be used on a bitmap picture you wish to deform.

•

Shaped Influence: The Zone of Influence boundary is defined by a shape which you can customize
using the Transform
tool. The Shaped Influence will most likely be used on a bitmap picture you
wish to deform.

•

Influence Radius: This value is the size of the Zone of Influence. The default value is 2.

Refer to the section Optimizing the Skeleton on page 1169> Zones of Influence on page 1176 to
learn more about zones of influence and how to set them.

Operations
•

Convert Elliptic Zone of Influence to Shape: After you have created a deformation chain using Elliptic
as the Zone of Influence type, you can select your deformer and click on this button to convert it to a
Shape type. Control points will appear around the shape making it easy to customize.

•

Copy Resting Position to Current: Use this option to copy the resting position of the deformation
skeleton to the current frame.
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Setup Mode
When you are in Setup Mode

you can use the Transform

tool to adjust the position, resize and tweak the

Bone, Articulation and Curve deformers which you created using the Rigging tool. When in Setup Mode, the
manipulators appear in red in the Camera view.

Refer to Deformation Basics on page 1136 > Displaying the Deformation Controls on page 1136 to
learn how to make the manipulators visible in the Camera view.
Refer to Optimizing the Skeleton on page 1169> Setting Up The Resting Position on page 1169 to
learn how to use the Setup Mode to modify your deformation chain.

Show All Manipulators

The Show All Manipulators

option lets you visualize the resting position in red (Setup Mode) and the active

position in light green at the same time.

Refer to Deformation Basics on page 1136> Displaying the Deformation Controls on page 1136 to
learn how to make the manipulators visible in the Camera view.

Show All Zones of Influence
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This option will display the Zones of Influence

for all of the deformers in your project. Note that the

deformer’s controls must be visible in order for its Zone of Influence to show. Zones will not be displayed when a
deformer’s Zone of Influence is set to Infinite or Zero.

Refer to Deformation Basics on page 1136> Displaying the Deformation Controls on page 1136 to
learn how to make the manipulators visible in the Camera view.
Refer to Optimizing the Skeleton on page 1169 > Zones of Influence on page 1176 to learn more
about using the zones of influence.

Show Simplified Manipulators
Enabling the Show Simplified Manipulators

will hide some of the more advanced control handles that are

visible in the Camera view. This can prove useful when animating, as it prevents you from inadvertently moving
the handles.

Refer to the Deformation Basics on page 1136 > Displaying the Deformation Controls on page 1136
topic to learn how to make the manipulators visible in the Camera view.

Show Selected Manipulators and Hide All Others
When you click on this

button, all manipulators displayed in the Camera view will all be hidden and only the

manipulators for the selected deformation module will be displayed.

Refer to the Deformation Basics on page 1136 > Displaying the Deformation Controls on page 1136
topic to learn how to make the manipulators visible in the Camera view.
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Insert Deformation Above
This

option adds a Deformation Group above the selected element. This contains all the basic deformation

module that you need to begin the manual construction of a deformation chain, i.e. Deformation-Root,
Deformation-Composite and Deformation-Switch. If your preferences are set to create pose deformation, the
subgroups linking to each of the drawings of the selected elements will also be created. After which you can use
the various Deformation Effect modules from the Module Library and start rigging.

If you are planning to rig your element using the Rigging

tool, you will not need to use this

option, as the Rigging tool will do it automatically.

Insert Deformation Under
This

option adds a Deformation Group under the selected element. This contains all the basic deformation

module that you need to begin the manual construction of a deformation chain, i.e. Deformation-Root,
Deformation-Composite and Deformation-Switch. If your preferences are set to create pose deformation, the
subgroups linking to each of the drawings of the selected elements will also be created. After which you can use
the various Deformation Effect modules from the Module Library and start rigging.

If you are planning to rig your element using the Rigging

tool, you will not need to use this

option, as the Rigging tool will do it automatically.

Create Kinematic Output
This

option adds an output to your deformation which lets you hook a separate element that you want to be

linked to the deformation chain but not be part of the deformation. For example, a hand connected to a wrist or
when assembling different parts of a character without having the different deformation chains influencing one
another. These elements will follow movement of the chain just like a regular cut-out character hierarchy piece
without being influenced by the deformation of the arm.

Refer to the topic Assembling the Parts on page 1161 to learn more about the use of Kinematic
Output.
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Copy Resting Position to Current
The resting

position is the original setup of your skeleton, that is the position it has before undergoing any

deformation. Once you have created a deformation chain, you can use the Setup Mode to adjust the position
and appearance of the rig to fit the element. Once your skeleton is in place you can use the Copy Resting
Position to Current option, this will reset the current frame position to the resting position which you just
modified leaving everything in place once you exit the Setup Mode. If you do not use this option, the rig will
undergo a deformation and revert to the position it was before you set up your skeleton, in relation to the new
resting position.

Convert Ellipse
Once you have created a deformation chain using Elliptic as the Zone of Influence type, you can select your
deformer and click on this button to convert it to a Shape
type. Control points will appear around the shape
making it easy to customize. This option is also available in the Rigging tool Tool Properties view.

Refer to the Zones of Influence on page 1176 topic to learn more about using the zones of
influence.

You can also use the Convert Elliptic Deformation ROI to Shape function in order to convert your
Elliptic zone of influence to a shape. In the top menu, select Animation > Deformation > Convert
Elliptic Deformation ROI to Shape. This function will create a much smaller initial zone of influence
than if you were to convert it directly to a shape.

Convert to New Drawing and Add Pose
After creating your deformation rig, you may want to convert a pose and the deformer in the current frame to a
drawing with a duplicate deformer that you can animate. This task can be useful when you want to add a pose to
a turnaround deformation rig you have already spent time creating and manipulating.
The Convert to New Drawing and Add Pose

option will take the pose/drawing and the deformer of the

selected frame and convert it to a new pose/drawing with the corresponding deformer. This option works with
the default deformation preference settings. Go to Edit > Preferences > Deformation and make sure that
Create Posed Deformer in Create Deformation Above/Under is selected.

1146

Toon Boom Harmony 10.3 Stage User Guide

Keep the naming convention of the drawing consistent between all views or else the link of the
drawing will be broken.
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Creating a Basic Deformation Rig
This topic explains how you can quickly use the Rigging tool to create a basic Bone and Articulation or Curve rig.
Before you can create a Basic Deformation rig, you must set up the performance preferences which are necessary
to allow the system to process the deformation effect efficiently.

Refer to Setting the Performance Preferences on page 1136 to learn more.

To create a basic deformation rig:
1. You must set up the Performance Preferences. See note above. After you have done this continue to step
2.
2. In the Preferences panel, under the Deformation tab, disable the Create Posed Deformer in Create
Deformation Above/Under .
Disabling this preference will result in a simpler Network rigging structure.

But remember that this option must be re-enabled when rigging a multi pose (front, quarter, side and
back) character.
Refer to the Creating a Full Character Turnaround Deformation Rig on page 1154 to learn how to rig
a complete character.

3. From the Deformation toolbar, select the Rigging
4. In the Rigging Tool Properties, enable the Automatic

tool.
Mode.

5. In the Network or Timeline view, select the element that you want to add a deformation to.

6. In the Camera view, you can start to create a Bone or Curve rig.

‣ To create a Bone rig:
‣

Place the cursor at the far end of your element, click once and release. For example, on the shoulder.
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‣

Click again at the location where you want your first bone to finish and your second bone to start. An
articulation will automatically be inserted between each bones you create.

‣

Repeat this until you are finished creating the Bone chain.

‣ To create a Curve rig:
‣

Click at the far end of your element, for example, the shoulder and drag your cursor to extend the
control handle and release, just as you would do when using the Polyline tool.

‣

Click again at the location where you want the curve to end and drag your cursor to extend the second
control handle.

‣

Repeat this process until you have finished building the Curve chain.

This will automatically create a Deformation Group connected to the top node of the selected element. This
group includes all the necessary deformation modules as well as the Bones, Curves and Articulations you
created.
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Note that this Network structure is the result of a simple rigging which was a created with the Create
Posed Deformer in Create Deformation Above/Under preference disabled.

If you have just created the bone rig, the controls will still be showing. However, whenever you close
your project the deformers are turned off, so when you reopen the project you can show the ones
you need while you're animating.
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Modifying a Deform Rig

To setup a bone and articulation deformation chain:
1. In the Network view, select the Deformation Group you want to setup.

2. In the Deformation toolbar, click on the Show Selected Deformers and Hide All Others

button to

display the deformer controls in the Camera view. This also hides all the deformer controls that were
displayed.
3. In the Deformation toolbar, enable the Setup Mode

.

The chain will turn from light green to red. If the chain is displayed in green, it means the Setup Mode is
disabled. Click the button once more to enable it.

4. In the Tools toolbar, select the Transform

tool.

5. In the Camera view, setup the deformation chain.
•

Use the Pivot rotation handle to change the angle of the chain.
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•

Use the Pivot centre control point to reposition the entire chain.

•

Use the Articulation control point, the square at the bottom, to reposition the articulation. This will
elongate, shorten or change the direction of the first bone.

•

Use the Articulation, top diamond-shaped, control point to change the size of the articulation. For quality
purposes it is recommended to have an articulation which fits the diameter of the part it controls.
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•

In the Deformation toolbar, if desired, you can disable the Show Simplified Manipulators option to display
all the manipulators. You can choose to work with the simplified deformers, but if you need more finetune control you can also access the full deformers. You will notice two extra square control points
appearing in the middle of the articulation circle. Drag these up and down to modify the steepness (bias)
of the articulation.

6. Repeat until all the articulations and bones of the chain are correctly aligned to the element it is linked to.
7. With the Deformation Group still selected, click on the Copy Resting Position to Current

button. This

will make sure to set the current resting position as the current frame one.
8. In the Deformation toolbar, disable the Setup Mode

and test your modifications using the Transform

tool.

For optimal results, make sure the size of the articulation is about the same size as the drawing.

Related Topics
•

Creating a Full Character Turnaround Deformation Rig on the next page
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Creating a Full Character Turnaround
Deformation Rig

Creating and rigging a Full Character Turnaround is a complex process, but it can easily be achieved by following
the step-by-step process explained in this chapter.
For a more simplified process, you can keep each view of your character separate on the Timeline or in the
Network view. If you create separate rigs for each view, then you can simply turn on or off the exposure of each
view in the Timeline when needed. In this case, you can simplify the process by not having to create posed
deformers, or use drawing pivots.
However if you want to keep the entire character, with all views, in one group/rig on your Timeline, then you can
follow the process described here.

Related Topics
•

Preparing the Character below

•

Renaming the Drawings on page 1157

•

Rigging the Parts on page 1158

•

Assembling the Parts on page 1161

Preparing the Character
You need to prepare your character before building a puppet’s deformation skeleton. The best way to proceed
is to have the limbs on separate drawing layers, this is similar to a standard cut-out puppet preparation, but uses
less pieces. Since this is a more advanced type of puppet you should keep the character’s head, hands, feet and
facial features on a separate layer from the body, arms and legs. This will avoid the extremities from being
distorted if the limbs are stretched during an action. It will also let you use the drawing substitution to swap
hands, feet, eyes and mouth poses during animation.
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There are many ways to break down a cut-out puppet. The example described in this chapter uses these pieces:
•

Body

•

Left Ear

•

Right Ear

•

Head

•

Left Eye

•

Right Eye

•

Mouth

•

Left Eyebrow

•

Right Eyebrow

•

Nose

•

Left Arm

•

Right Arm

•

Left Hand

•

Right Hand

•

Left Leg

•

Right Leg

•

Left Foot

•

Right Foot

Refer to Swapping Images on page 1092 to learn more about drawing substitution.
Refer to the following topics to learn how to breakdown your character:
•

Importing a Model on page 667

•

Relative Sizes on page 669

•

Studying the Model on page 671

•

Breaking Down the Character on page 682

•

Adding Extra Drawings on page 714

Related Topics
•

Creating a Full Character Turnaround Deformation Rig on the previous page

•

Enabling the Posed Deformer Preference on the next page

•

Renaming the Drawings on page 1157

•

Rigging the Parts on page 1158
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Creating a Full Character Turnaround Deformation Rig

Assembling the Parts on page 1161

Enabling the Posed Deformer Preference
The first thing you should do when rigging your character turnaround is to make sure to enable the
Create Posed Deformer in Create Deformation Above/Under preference. This preference is located
in the Preferences panel, under the Deformation tab and is enabled by default.

When rigging with this preference enabled, you will notice that the structure of the deformation inside the
Deformation Group is slightly different than it is when executing a basic rig with the preference disabled.
Each pose you rig within the same element is part of a separate subgroup all of which are gathered together by a
Deformation-Composite module, each subgroup is called by its drawing number or name. These subgroups
cannot be renamed once the rig is complete, as the name of the group and drawing is the link between them. If
you kept the default drawing numbering 1, 2, 3, etc., your groups will be called 1, 2, 3, and so on. For this
reason, you might want to rename your drawing before you start rigging so that the names correspond to the
poses, for example: front, side, quarter, etc.

Refer to Deformation Preferences on page 1195 to know more about this preference.
Refer to the next topic Renaming the Drawings on the facing page to learn how to rename the
drawings.

Related Topics
•

Creating a Full Character Turnaround Deformation Rig on page 1154

•

Preparing the Character on page 1154

•

Renaming the Drawings on the facing page

•

Rigging the Parts on page 1158

•

Assembling the Parts on page 1161
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Renaming the Drawings
Although renaming your drawings is not mandatory, it can prove useful in maintaining a clear project Network
structure. If you leave your drawing as is and do not rename it, your deformation subgroups will be automatically
named according to the drawing numbering. However, you should consider renaming, especially if you have
several drawings using the same rig within an element.

If you plan to have several drawings using the same rig within an element, for instance, drawing
substitution, then it is recommended you rename these extra drawings before starting your rig, or
you will find that extra unused subgroups will be created automatically.

To rename drawings to link them to the same chain:
1. In the Xsheet view, locate the column corresponding to the element which includes several drawings that
will use the same chain, for example a character that has several costumes which you plan to swap by
using drawing substitution. In this case, the rabbit’s feet, which will all use the same deformation curve.

2. In the Xsheet view, select the first drawing of the column. This is the one that will be rigged.
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3. Select Drawing > Rename Drawing or press [Ctrl] + [D] (Windows/Linux) or [⌘ ] + [D] (Mac OS X).
4. In the Rename Drawing dialog box, type a relevant new name for the drawing and click OK to validate.

5. In the Xsheet view, select the next drawing in the column and select Rename > Rename Drawing.
6. In the Rename Drawing dialog box, type the same name that you gave the first drawing of the column,
exactly as it was written and add a plus sign and any number. For example, if the first drawing is named
front, the subsequent drawings will need to be named: front+1, front+2, front+3, etc.

You must strictly adhere to this rule, if you want the extra drawings to be linked to the deformation
chain of the main drawing.

7. Repeat step 5 and step 6 for each subsequent drawing that needs to be linked to the same deformation
chain.

Related Topics
•

Creating a Full Character Turnaround Deformation Rig on page 1154

•

Preparing the Character on page 1154

•

Enabling the Posed Deformer Preference on page 1156

•

Rigging the Parts below

•

Assembling the Parts on page 1161

Rigging the Parts
You can start your deformation rig by creating the Bones or Curves on the character’s arms and legs. The style of
animation you plan on producing, will influence the style of rig you will use. (Bones and Articulations or Curves)
To rig the arms and legs of the character turnaround:
1. In the Timeline view, make sure that the time marker is set to the frame displaying your first drawing.
2. In the Network view, select your character’s arm or leg.
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3. In the Deformation toolbar, select the Rigging

tool.

4. In the Rigging Tool Properties, set the mode to Automatic

.

5. To create a Bones and Articulations structure:
‣

Click on the extremity corresponding to the shoulder or hip of the limb and release to create the first
rotation point.

‣

Click again in the middle of the limb where the elbow or knee is located to create the first articulation.

‣

Click one last time at the end of the limb, where the wrist or ankle rests to create the second bone.

6. To create a Curve structure:
‣

Click on the extremity corresponding to the shoulder or hip of the limb and drag the cursor to extend
the first control handle.

‣

Click at the end of the limb, where the wrist or ankle rests and drag the cursor to extend the second
control handle.

7. In the Timeline view, move the time marker to display the frame with the next pose of that drawing
element.
8. Repeat the previous steps until all of the element‘s different poses are rigged, then begin the whole
process again for each limb. Although it is recommended to keep consistency in your rigging of different
poses in the same element, you can choose a different type of rig for each pose if necessary.
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Note that you can also set the Rigging Tool Properties mode to Curve

or Bone

. This will

prevent gesture mistakes leading to the creation of the wrong type of deformer.
Once you create a chain, you can modify it’s position and orientation using the Setup
Transform

Mode and

tool—see Optimizing the Skeleton on page 1169.

Related Topics
•

Creating a Full Character Turnaround Deformation Rig on page 1154

•

Preparing the Character on page 1154

•

Enabling the Posed Deformer Preference on page 1156

•

Renaming the Drawings on page 1157

•

Assembling the Parts on the facing page

Linking Extra Drawings to a Single Rig
When you have several drawings that will use exactly the same rig there is a special naming rule you need to
follow so that the same rig is linked to these different drawings. This can happen when you have drawing
substitution in this layer.

You should rename your extra drawings BEFORE rigging the main drawing of your element. If you do
not do this an unnecessary subgroup will be created for each extra drawing—see Renaming the
Drawings on page 1157.

Once your drawings are correctly named, you can start the rigging process.
To link extra drawings to a single rig:
1. In the Timeline view, make sure that the time marker is on the first frame, or the frame displaying the main
drawing.
2. In the Network view, select your element’s module.

3. In the Deformation toolbar, select the Rigging

tool.

4. In the Rigging tool Tool Properties, set the mode to either Automatic

, Curve

or Bone

.

5. In the Camera view, build your Curve or Bone deformation chain. Refer to Rigging the Parts on page 1158.
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6. To switch to the next drawing or press [G]. You will notice that the subsequent drawings that are part of
the link already have a deformation chain. This is the same as you just created for the main drawing.

7. If you look in the Deformation group of your element in the Network view, you will notice there are no
subgroups created for the extra drawings, they are all automatically linked to the main drawing’s
deformation chain.

Related Topics
•

Rigging the Parts on page 1158

Assembling the Parts
After you have created all the deformation chains for your character you will need to assemble these separate
body parts into a puppet.
To avoid problems such as having the head stretched by the neck deformers or a hand modified by the neck and
body deformers, it is recommended to put them on a separate layer. When they are on a separate layer, rig
them using a Kinematic output coming directly from your Deformation Group, instead of the normal hierarchy
connection between modules. This will let you connect a part directly to it, so it will only be influenced by the
position of its parent and will not undergo any deformation. This is recommended as a method of optimizing the
functionality of the puppet and also as a way of avoiding any unwanted distortion effects for any assembled
parts.
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To assemble the puppet’s parts:
1. In the Network view, locate the puppet’s head. You can also select the head in the Camera view using the
Transform tool and then use [O] in the Network view to use the Centre on Selection feature.

2. If you did not add a deformation effect to this module, you can connect all the facial feature modules as
it’s children, just as you would normally do with a typical cut-out character rig.

1. In the Network view, locate the body of your puppet. Select the Deformation Group linked to the
character’s body module.

2. In the Deformation toolbar, click on the Create Kinematic Output

button.

This will add a Deformation-Composite module inside your Deformation Group. This is setup to create a
special output which you can use to connect your modules and create the puppet’s hierarchy. It also
automatically creates the necessary connections, so that every pose is part of the setup. The deformation
will not influence the modules that are connected to this output.
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By default, the last deformer module of each deformation chain is connected to this new DeformationComposite. The extremity of this deformer is where the child element will be attached. In this case, the
last bone is the neck.

If your network becomes tangled, select the lower module of the tree and click on the Order
Network Up
button. Leave the settings to default and click OK.

3. As there are going to be several parts connected to this body Deformation Group we recommend that
you rename the new Composite module with a relevant name, Click on the module’s square yellow
button to display the Deformation-Composite module’s Layer Properties.

4. Rename the module using the Name field and click on Close to validate it.
5. In the Network view, exit the Deformation Group and go back to Top level.
6. Connect the new bottom port of the body Deformation Group module into the top port of the head
module.
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7. In the Network view, select the body Deformation Group module again and click on the Create Kinematic
Output
button to create another kinematic output.
8. Enter the Deformation Group and rename the newly created Deformation-Composite module. In this
example: body-shoulder.

By default, the last deformer of each subgroup is linked to this new Deformation-Composite module. In
this case, this Composite will act as the shoulder attachment for the two arms. If the connections are left
as is, the arms will follow the movements of the neck and the head. For this reason, it is important to
select the correct Bone or Articulation.
9. In the Network view, enter the first deformation subgroup.

10. Inside the first subgroup, locate the connection you have to break.

If you pause the cursor over the top of a node on the Multi-Port-Out module, a tool tip window will
pop up, displaying information about the module and port number it is connected to.

In this example, we need to break the connection to the Body-shoulder module. Click on the node and pull
out the cable to disconnect it.
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You will notice that the disconnected node will still be visible on the Multi-Port-Out module, this is
because a cable is still connected to the output port outside of the subgroup. This will be removed at a
later step.
11. Locate the Bone, Articulation or Curve which you want to connect the arms to and find it’s module in the
deformation chain. In this example, the arms should be connected to the previous bone in the chain. They
should not be connected to the articulation in between, because the arms would follow the rotation of the
articulation instead of following the steady position of the shoulders.

12. Click on the desired deformer module bottom node and drag the cable to the Multi-Port-Out module to
create a connection.

13. Exit the subgroup and go back to the body Deformation Group.
14. Disconnect the current unused connection between your first subgroup and the shoulder DeformationComposite module. This will also remove the empty node on the Multi-Port-Out module inside your
subgroup.
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15. Connect the remaining bottom node of your subgroup to the shoulder Deformation-Composite module.

16. Repeat Step 9 to Step 15 for each subgroup contained in your body Deformation Group.
17. In the Network view, go back to the Top level.
18. Connect the two arms to the available bottom node of the body Deformation Group.

19. Repeat Step 7 to Step 18 for the legs and any other parts that needs to be assembled. Remember to link
the deformer modules used for the hips to the Kinematic output.
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When you have completed this process the body Deformation Group should look similar to this.

And the final network should look similar to this.

Related Topics
•

Setting Up the Pivots on the next page

•

Creating a Full Character Turnaround Deformation Rig on page 1154

•

Preparing the Character on page 1154

•

Enabling the Posed Deformer Preference on page 1156

•

Renaming the Drawings on page 1157

•

Rigging the Parts on page 1158

1167

Chapter 18: Deformation

Creating a Full Character Turnaround Deformation Rig

Setting Up the Pivots
When building a cut-out puppet with deformation effects each part controlled by a deformation chain will
automatically rotate from the Deformation-Root point, which acts like a pivot. Because it is unlikely that every
piece of your character will be rigged with a deformation chain, you must set pivot points.

Refer to Setting the Pivots on page 716 to learn how to set pivot points.

Related Topics
•

Assembling the Parts on page 1161
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Optimizing the Skeleton
Once your character is rigged and assembled, you can modify the deformation chain’s position and shape in the
Camera view by using the Setup Mode
to optimize it.
You can also modify the area which will be influenced by the deformer by setting up the zones of influence.

You can modify the chains and zones of influence as you create each of them, but it can also be done
at any time.

Related Topics
•

Setting Up The Resting Position below

•

Zones of Influence on page 1176

Setting Up The Resting Position
Once you have a deformation chain created, you can optimize its positioning to fit the element it will deform.
This task is done in the Setup Mode
. The Setup Mode lets you set the resting position of the deformers to
make sure it is at the optimal position.
The Bone, Curve and Articulation deformers have different sets of controllers:
•

Setting up a Bone and Articulation Chain below

•

Setting Up a Curve Deformation Chain on page 1173

Related Topics
•

Optimizing the Skeleton above

Setting up a Bone and Articulation Chain

To setup a bone and articulation deformation chain:
1. In the Network view, select the Deformation Group you want to setup.
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2. In the Deformation toolbar, click on the Show Selected Deformers and Hide All Others

button to

display the deformer controls in the Camera view. This also hides all the deformer controls that were
displayed.
3. In the Deformation toolbar, enable the Setup Mode

.

The chain will turn from light green to red. If the chain is displayed in green, it means the Setup Mode is
disabled. Click the button once more to enable it.

4. In the Tools toolbar, select the Transform

tool.

5. In the Camera view, setup the deformation chain.
•

Use the Pivot rotation handle to change the angle of the chain.
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•

Use the Pivot centre control point to reposition the entire chain.

•

Use the Articulation control point, the square at the bottom, to reposition the articulation. This will
elongate, shorten or change the direction of the first bone.

•

Use the Articulation, top diamond-shaped, control point to change the size of the articulation. For quality
purposes it is recommended to have an articulation which fits the diameter of the part it controls.
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In the Deformation toolbar, if desired, you can disable the Show Simplified Manipulators option to display
all the manipulators. You can choose to work with the simplified deformers, but if you need more finetune control you can also access the full deformers. You will notice two extra square control points
appearing in the middle of the articulation circle. Drag these up and down to modify the steepness (bias)
of the articulation.

6. Repeat until all the articulations and bones of the chain are correctly aligned to the element it is linked to.
7. With the Deformation Group still selected, click on the Copy Resting Position to Current

button.

This will make sure to set the current resting position as the current frame one.
8. In the Deformation toolbar, disable the Setup Mode

and test your modifications using the Transform

tool.

For optimal results, make sure the size of the articulation is about the same size as the drawing.

You can also set up the resting position of the deformers by typing values directly into the Layer Properties of
the deformation effect modules.
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Refer to and Articulation on page 1115 to learn more.

Related Topics
•

Setting Up The Resting Position on page 1169

•

Setting Up a Curve Deformation Chain below

Setting Up a Curve Deformation Chain
To setup a curve deformation chain:
1. In the Network view, select the Deformation Group you want to setup.

2. In the Deformation toolbar, click on the Show Selected Deformers and Hide All Others

button to

display the deformer’s controls in the Camera view.
3. In the Deformation toolbar, enable the Setup Mode

.

You will notice the chain turning from light green to red. If the chain is displayed in green, it means the
Setup Mode is disabled, click on the button once more to enabled it.
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4. In the Tools toolbar, select the Transform

tool.

5. In the Camera view, setup the deformation chain.
•

Use the Pivot rotation handle to change the angle of the chain.

•

Use the Pivot centre control point to reposition the entire chain.

•

Use the curve handles to modify the shape of the curve.
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•

Use the curve’s square control points to resize and reposition each segment of the curve chain.

6. Repeat until all the curves of the chain are correctly aligned to the element it is linked to.
7. With the Deformation Group still selected, click on the Copy Resting Position to Current

button. This

will make sure to set the current resting position as the current frame one.
8. In the Deformation toolbar, disable Setup Mode

and test your modifications using the Transform

tool.
You can also set up the resting position of the deformers by typing values directly into the Layer Properties of
the deformation effect modules.

1175

Chapter 18: Deformation

Optimizing the Skeleton

Zones of Influence

To increase the quality of your animation and the accuracy of the deformation effect, you can modify the zones of
influence around the deformation chains. A Zone of Influence is the area around the deformer within which art will
be influenced by the deformation. The deformer has the power to shape all art contained within the influence
area on its own element or on its children elements.
Zones of Influence are different depending on the deformer type and zone type you selected:
•

Selecting the Zone Type on the facing page

•

Setting up the Elliptic Zone of Influence on page 1179

•

Converting an Elliptic Zone of Influence to Shaped on page 1181

•

Setting up a Shaped Zone of Influence on page 1182

•

Setting up the Zone of Influence Fade Radius on page 1184
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You can find the settings for the zones of influence in the Layer Properties of the Curve, Bone and Articulation
modules as well as in the Rigging Tools Properties.
When working on a cut-out puppet built on several element layers, the best choice is to keep the default Infinite
option as the Zone of Influence type. In the following examples, the zones of influence will be explained through
deformation chains on a single bitmap image. The image was previously imported and vectorized with colour.

Refer to Importing Bitmap Images on page 574 to learn more about importing and vectorizing
Bitmap images.

You can also prevent a child’s element from undergoing its parent deformation by connecting it
through a kinematic output. Refer to Assembling the Parts on page 1161 to learn how.

Related Topics
•

Optimizing the Skeleton on page 1169

•

Selecting the Zone Type below

•

Setting up the Elliptic Zone of Influence on page 1179

•

Converting an Elliptic Zone of Influence to Shaped on page 1181

•

Setting up a Shaped Zone of Influence on page 1182

•

Setting up the Zone of Influence Fade Radius on page 1184

Selecting the Zone Type
To select a zone type:
1. In the Deformation toolbar, enable the Setup Mode

.

2. Once you have created a Bone and Articulation or Curve deformation chain, in the Network view, navigate
to your deformer module, inside the element’s Deformation Group and inside the pose subgroup if
applicable.

3. Click on the deformer module’s square yellow button to open the Layer Properties dialog box.
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4. In the deformer Layer Properties, use the Influence Type drop-down menu to select the type of Zone of
Influence you want.

‣

Zero Influence: The Zone of Influence does not exist. No deformation will happen.

‣

Infinite Influence: This is the option selected by default and is the most commonly used. The Zone of
Influence has no boundary and covers the whole element to which the deformer is linked to and its
children, excluding areas that are already part of another elliptic or shaped Zone of Influence. The
Infinite influence zone will from the center of your skeleton, going toward infinity, working in
perpendicular with the skeleton. This is the recommended Zone type for a cut-out puppet assembled
from several element layers.

‣

Elliptic Influence: The Zone of Influence boundary is defined by an elliptical shape whose size can be
customized using the Bone, Articulation or Curve module properties or by using the Transform
tool. The Elliptic Influence will most likely be used on a bitmap picture you wish to deform.

‣

Shaped Influence: The Zone of Influence boundary is defined by a shape which you can customize
using the Transform
tool. The Elliptic Influence will most likely be used on a bitmap picture you
wish to deform.

5. When you select the Elliptic or Shaped type, the Zone of Influence appears in the Camera view where you
can customize the shape using the Transform tool and Layer Properties options.
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This example illustrates the Zones of Influence of a Curve deformer. Note that this example also
applies to the Bone and Articulation deformers.

You can also use the Convert Elliptic Deformation ROI to Shape function in order to convert your
Elliptic zone of influence to a shape. In the top menu, select Animation > Deformation > Convert
Elliptic Deformation ROI to Shape. This function will create a much smaller initial zone of influence
than if you were to convert it directly to a shape.

Related Topics
•

Zones of Influence on page 1176

Setting up the Elliptic Zone of Influence
When you set up the shape of your Elliptic Zone of Influence you should be as accurate as possible and make sure
that only the element that you want to follow the deformation is included inside the zone.
To set up the Elliptic Zone of Influence:
1. In the Deformation toolbar, enable the Setup Mode
2. In the Tools toolbar, select the Transform

.

tool.

3. In the Network view, select the deformer’s module to which you want to customize the Elliptic Zone of
Influence.
4. Click on the deformer module’s square yellow button to open the Layer Properties dialog box.

5. In the deformer Layer Properties, setup the ellipse shape by adding values to the various fields:
‣

Symmetric Ellipse Influence: This option is enabled by default. When enabled, the shape of the
ellipse will be symmetrical on both the transversal and longitudinal radii. In this case, use the
Transversal Influence Radius Left field to set the transversal radius value and use the Longitudinal
Influence Radius End field to set up the longitudinal radius value. The two other fields will remain
unused, unless you disable the Symmetric Ellipse Influence option. In that case, you can set up different
radii sizes for the four radii directions.

‣

Transversal Influence Radius Left: When the Symmetric Ellipse of Influence option is enabled, this
field controls both Left and Right transversal radius values. When the option is disabled, it controls the
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size of the left transversal radius. By default this value is set to 2, use the up and down arrow to select
a value or type the desired one directly in the field.

‣

Transversal Influence Radius Right: When the Symmetric Ellipse of Influence option is enabled this
field loses its influence and the Left Transversal radius value is automatically applied to the Right
Transversal. When the option is disabled, it controls the size of the Right Transversal radius. By default
this value is set at 2. Use the up and down arrows to select a value or type the desired one directly in
the field.

‣

Longitudinal Influence Radius Begin: When the Symmetric Ellipse of Influence option is enabled, this
field loses its influence, the End Longitudinal value is automatically applied to the Begin Longitudinal.
When the option is disabled, it controls the size of the Begin Longitudinal radius. By default this value
is set to 0.25, use the up and down arrows to select a value or type the desired one directly in the field.

‣

Longitudinal Influence Radius End: When the Symmetric Ellipse of Influence option is enabled, this
field controls both Begin and End Longitudinal radius values. When the option is disabled it controls
the size of the End Longitudinal radius. By default this value is set to 0.25, use the up and down arrows
to select a value or type the desired one directly in the field.

6. You can also modify the elliptic shape in the Camera view, using the Transform
‣

tool.

If the Symmetric Ellipse of Influence option is enabled, one control point will be available in the Camera
view. Drag this point in any direction to increase or decrease the size of the Zone. Dragging it
left/right will modify both longitudinal radius sizes. Dragging it up/down will modify both transversal
radius sizes.
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‣

If the Symmetric Ellipse of Influence is disabled, two control points will be available in the Camera view.
Drag the top corner point left/right to modify the end longitudinal radius size and up/down to modify
the left transversal radius size. Drag the bottom corner control point left/right to modify the
beginning longitudinal radius size and up/down to modify the right transversal radius size.

You can also select the Zone of Influence type in the Rigging Tool Properties to change the default
setting before creating a deformation chain. Refer to Rigging Tool Properties on page 1140.

Related Topics
•

Optimizing the Skeleton on page 1169

•

Zones of Influence on page 1176

•

Selecting the Zone Type on page 1177

•

Converting an Elliptic Zone of Influence to Shaped below

•

Setting up a Shaped Zone of Influence on the next page

•

Setting up the Zone of Influence Fade Radius on page 1184

Converting an Elliptic Zone of Influence to Shaped
When you have an Elliptic Zone of Influence selected in the Network view, you can convert it to a Shaped Zone
type using the option Convert Elliptic Zone of Influence to Shape
.
To convert an Elliptic Zone of Influence to a shape:
1. In the Deformation toolbar, enable the Setup Mode

.

2. In the Network view, select the deformer module that has an elliptic Zone of Influence type.

1181

Chapter 18: Deformation

Optimizing the Skeleton

3. In the Deformation toolbar or Rigging Tool Properties, click on the Convert Elliptic Zone of Influence to
Shape
button.
The Zone of Influence will automatically be converted to a shape. It will keep the shape it was when the
button was pressed except, control points will appear all around the zone to allow the shape to be
customized.

Refer to the section Setting up a Shaped Zone of Influence below below to learn how to customize a
shaped Zone of Influence.

Related Topics
•

Zones of Influence on page 1176

•

Selecting the Zone Type on page 1177

Setting up a Shaped Zone of Influence
When you set up the boundaries of your Shaped Zone of Influence, you should be as accurate as possible and
make sure that only the elements that you want to follow the deformation are included inside the zone.
To set up the Shaped Zone of Influence:
1. In the Deformation Toolbar, enable the Setup Mode
2. In the Tools toolbar, select the Transform

.

tool.

3. In the Network view, select the deformer module in which you want to customize the Shaped Zone of
Influence.
If you selected the Shaped option in the Layer Properties dialog box or in the Rigging Tool Properties
view, the Zone of Influence will be square. This square has control points on all four corners and each
control point as two control levers. If you converted an elliptic zone to a shape, the zone will have more
control points and handles.

1182

Toon Boom Harmony 10.3 Stage User Guide

‣

Click and drag a control point to redefine its position and the shape.

‣

Click and drag the control lever handle to modify the corners and redefine the shape.

‣

Hold [Alt] down while dragging the control lever handle to move one handle at a time.

Refer to the section Converting an Elliptic Zone of Influence to Shaped on page 1181 to learn how
to convert an elliptic zone to a shape.
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Related Topics
•

Optimizing the Skeleton on page 1169

•

Zones of Influence on page 1176

Setting up the Zone of Influence Fade Radius
To better illustrate the Zone of Influence Fade Radius and its effect, the bitmap picture will be swapped with a
grid pattern.

There is an area called the deformer Fade which surrounds the Zone of Influence, this is the link between the
strict boundaries of the Zone of Influence and the surrounding region. This area gradually stretches or squashes
following the deformation. You can edit the Fade Radius value to modify the size of this area and the exponent of
the deformation fade effect.

You can change the default behaviour so that the fading effect is inside the Zone of Influence instead of outside.
This is explained in this exercise.
To modify the Fade Radius and Exponent:
1. In the Network view, select the deformer module you want to modify. Note that this deformer needs to
have an Elliptic or Shaped Zone of Influence type.
2. Click on the square yellow button of the module to open the Layer Properties dialog box.
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3. Use the Influence Fade Radius field to modify size of the fading area. The default value is 0.5. You can use
the up and down arrows to increase of decrease the radius, or type a specific value directly in the field.
4. Click on Close to exit the Layer Properties dialog box.
5. In the Network view, locate the Deformation-Switch module situated just under the DeformationComposite module in your deformation chain.

6. Click on the square yellow button on the Deformation-Switch module to open the Layer Properties dialog
box.

7. In the Layer Properties dialog box:
‣

Influence Fade Exponent: Use the up and down arrow to modify the exponent value or type the
exact value in the field.

•

A value of 1 is similar to a linear curve.

•

A higher value will result in an ease-in type of curve.

•

A lower value will result in an ease-out type of curve.

‣

Fade Inside Region: By default this option is disabled, meaning that the Fade effect will occur outside
of the Zone of Influence. You can enable this option so that the fade effect is inside the Zone of
Influence.

Related Topics
•

Optimizing the Skeleton on page 1169
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Storing the Character in the Library
Once your character is rigged and all set, you can store it as a template in the Library and then reuse it in
different scenes. You can create different kinds of templates.

Refer to Storing the Character in the Library on page 726 to learn how to do it.

Related Topics
•

Creating a Basic Deformation Rig on page 1148

•

Creating a Full Character Turnaround Deformation Rig on page 1154
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Manipulating a Deformer to Create
Animation
The Bone, Articulation and Curve deformers have very different ways of being manipulated. When you are
choosing the type of deformation chain to use on each part, keep in mind the kind of animation movement they
can create.
This topic is divided as follows:
•

Manipulating a Bone and Articulation Deformer below

•

Manipulating a Curve Deformer on page 1190

You will learn how to manipulate the main types of deformer.

To learn how to manipulate secondary types of deformer, refer to the desired effect module:
•

AutoFold on page 1118

•

Auto-Muscle on page 1118

•

Deformation-Scale on page 1123

•

Deformation-Uniform-Scale on page 1127

•

Deformation-Uniform-Scale on page 1127

•

Deformation-Wave on page 1128

•

Fold on page 1131

Related Topics
•

Deformation on page 1111

•

Creating a Basic Deformation Rig on page 1148

•

Creating a Full Character Turnaround Deformation Rig on page 1154

Manipulating a Bone and Articulation Deformer
The Bone deformer operates the same as a human limb does and is composed of a pivot, as a starting point, and
bones and articulations.
To manipulate a Bone and Articulation deformer:
1. In the Deformation toolbar, disable Setup Mode

. When Setup Mode is disabled, the default colour of

the deformation control is light green.

If you leave Setup Mode on, you will modify the resting position of the deformer chain, instead of
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animating it.

If you had made changes to your rig in Setup mode, you can select the deform group and click on
Copy Resting Position to Current button. This resets the rig outside Setup mode to match what the
rig looks like in Setup mode.

2. In the Tools toolbar, if you want to create keyframes, enable the Animate
3. In the Tools toolbar, select the Transform

mode.

tool.

4. In the Top level of the Network view, press [Ctrl] + [A] (Windows/Linux) or [⌘ ] + [A] (Mac OS X) to select
all the modules, you can also select Edit > Select All from the top menu.
5. In the Camera View toolbar, select Show Control

or press [Shift] + [F11]. This will display all the

deformation controls in your scene.
Refer to Displaying the Deformation Controls on page 1136 to learn other control display option.
6. In the Camera view:

‣

Click on the centre of the Deformation-Root pivot and drag it around to reposition the entire limb.

‣

Use the first bone or the pivot square handle to rotate the entire limb.
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‣

Use the square control point located at the extremity of a bone to stretch or shorten its length.

‣

Use a bone next to an articulation to rotate it. You can also hold down the [Alt] key, this will lock all the
controls and movement and only allow the rotation of the articulation.

‣

Click and drag the articulation’s diamond-shaped control point to modify its radius.

7. If needed, in the Deformation toolbar, disable the Show Simplified Manipulators option to display the
advanced controls.
8. In the Camera view:

‣

Click and drag the round articulation control points to adjust the steepness (bias) of the articulation.

‣

Use the square articulation control point to rotate it.
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Manipulating a Deformer to Create Animation

You can also manipulate the deformer by typing values directly in the Layer Properties of the deformation effect
modules.

Related Topics
•

Articulation on page 1115

•

Manipulating a Deformer to Create Animation on page 1187

•

Manipulating a Curve Deformer below

Manipulating a Curve Deformer
The Curve Deformer distorts the element to follow an organic and fluid curve line.
To manipulate a Curve Deformer:
1. In the Deformation toolbar, disable Setup Mode

. If you leave Setup Mode on, you will modify the

resting position of the deformer chain instead of animating it. When Setup Mode is disabled, the default
colour of the deformation control is light green.
2. In the Tools toolbar, if you want to create keyframes, enable the Animate
3. In the Tools toolbar, select the Transform

mode.

tool.

4. In the top level of the Network view,or press [Ctrl] + [A] (Windows/Linux) or [⌘ ] + [A] (Mac OS X) to select
all the modules, you can also select Edit > Select All from the top menu.
In the Camera View toolbar, select Show Control

or press [Shift] + [F11]. This will display all the

deformation controls in your scene.
Refer to Displaying the Deformation Controls on page 1136to learn other control display option.
5. In the Camera view:
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‣

Click on the centre of the Deformation-Root pivot and drag it around to reposition the entire
deformation chain.

‣

Use the pivot’s square handle to rotate the entire chain.

‣

Use the square control point located at the extremity of the curve to stretch or shorten its length.
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‣

Manipulating a Deformer to Create Animation

Use the curve handles to modify to shape of the curve.

6. If you have a chain of several curves, you can get all the children of a curve to follow the movement of one
handle. This can prove useful when, for example, animating an arm and you do not want the fingers
sticking to their original place while moving the wrist.

‣

Select the handle you want to move. The handle’s colour will turn white once it is selected.

‣

Press and hold the [Ctrl] (Windows/Linux) or [⌘ ] (Mac OS X) and move the handle. All the children will
follow the movement.

7. If you have a double-sided handle, you can lock it, so only one side will move at a time.
‣

Select the handle you wish to move independently from the other. The handle’s colour will turn white
once it is selected.

‣

Press and hold the [Alt] key and move the handle.
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You can also manipulate the deformers by typing values directly in the Layer Properties of the deformation effect
modules.

Related Topics
•

Manipulating a Deformer to Create Animation on page 1187

•

Manipulating a Bone and Articulation Deformer on page 1187
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Converting your Deformation Animation to Drawings

Converting your Deformation Animation to
Drawings
You may at times want to adjust your deformation animation using the drawing tools in order to perfect
something, or add detail. You might also want to change the timing and set it on double frame, rather than
single frame. Harmony offers you the option to convert your deformation animation to an image sequence.
To convert your deformation animation to drawings:
1. In the Timeline view, select the deformation frame range for which you wish to convert to drawings.

2. In the top menu, select Animation > Deformation > Convert Deformed Drawing to Drawings.
The Baking Drawing process window opens. Wait for the baking to complete.

Related Topics
•

Creating a Basic Deformation Rig on page 1148
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Deformation Preferences

You can customize the display of deformation, its functionality, and the performance of the system by altering
the preferences.
You will find the preferences listed under the following tabs:
•

General below

•

OpenGL on page 1197

•

Deformation on page 1197

To open the Preferences dialog box:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

Press [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).

General

Colours
You can change the default colours of the deformation controls in the Preferences panel.
To change the deformation control colours:
1. In the Preferences Panel, under the General tab, click Edit Colours.
The Colours dialog box opens.

2. In the Colours dialog box, select the Deformation tab.
3. Click the colour pot of the control whose colour you want to change.
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Deformation Preferences

The Select Colour dialog box opens.

4. Select a new colour and click OK.
5. Click OK once again to exit the Colour dialog box.
You can click Restore All Defaults to go back to the default colours.

Related Topics
•

Deformation Preferences on the previous page

•

OpenGL on the facing page

•

Deformation on the facing page

•

Displaying the Deformation Controls on page 1136
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OpenGL

Settings
•

Use Hardware Vertex Texture Fetching if Available: This preference is disabled by default and it is
strongly recommended that you enable it before using the deformers. If your CPU and graphic card allow
it, the system will use vertex shaders to considerably help the process of deformation.

Related Topics
•

Deformation Preferences on page 1195

•

Deformation below

•

Setting the Performance Preferences on page 1136

Deformation
Scale Controls
The Scale Controls Preferences let you customize the appearance of the Deformation-Scale and DeformationUniform-Scale controls by setting the desired distance from the deformer axis.
•

Display Scaling Module in Pixel Size: This preference is disabled by default. The distance between the
controls and the deformer axis is calculated using fields as a value. You can enable this option to change
the value to pixels.
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Deformation Preferences

•

Scaling Field Size: The default value is 2 fields, meaning that the distance between the controls and the
deformer axis is 2 fields. You can enter any field value you want. When the Display Scaling Module in Pixel
Size preference is enabled, this option changes to Scaling Pixel Size.

•

Scaling Pixel Size: When the Display Scaling Module in Pixel Size is enabled, this option appears instead
of Scaling Field Size. The default value is 64 pixels, meaning that the distance between the controls and
the deformer axis is 64 pixels. You can enter any pixel value you want.

Deformation Creation
•

Create Posed Deformer in Create Deformation Above/Under: This preference is enabled by default.
When enabled, the Deformer groups will automatically be built using the more advanced structure, which
lets you rig and manipulate deformers for several views of a character turnaround within a single element.
When this preference is disabled, the structure within the Deformation Group will be simpler and will
disallow a different rig on each drawing of the same element.

Refer to the topic Creating a Full Character Turnaround Deformation Rig on page 1154 to learn more
about Posed deformer.
Refer to the topic Creating a Basic Deformation Rig on page 1148 to learn more about rigging with
this preference disabled.

Deformation Convert Deformed Drawings
•

Texture Resolution when Converting Gradient and Textures: This preference sets the size of the
bitmap texture used during the conversion of deformed drawings to drawings. The maximum value
accepted is 2048 pixels.

Related Topics
•

Deformation Preferences on page 1195
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Chapter 19: Effects

Once your animation is completed, you can add effects such as blurs and glows to make your project look even
better! Harmony provides you with a series of essential effects that you can add to your layers.

Topics Covered
•

Adding Effects on the next page

•

Animating an Effect Over Time on page 1213

•

How Does an Effect Work? on page 1216

•

Using Effects on page 1218

•

Particle Effects on page 1355

•

Extra Commands on page 1405

•

Effects Preferences on page 1406
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Adding Effects

In Harmony, to add an effect, you will have to use the Network view. You can add an effect module to your
network, you can drag modules from the Module Library view and connect them to the associated drawing
elements and adjust the parameters to your taste.

Related Topics
•

Network View below

•

Module Library View on page 1203

•

Importing a Module on page 1207

•

Adding Effects Through the Timeline View on page 1207

Network View
In the Network view, you can connect effects and compositing modules to form a network. The organization of
modules determines the flow of data during the compositing process and how your animation elements will be
composited.
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1. Drawing Module below
2. Write and Display Modules on the next page
3. Composite Module on the next page
4. Effect Module on the next page
5. Matte Drawing on page 1203
6. Position Ports on page 1203
7. Peg Module on page 1203

Drawing Module

This is an example of an average module, in this case a simple drawing module that represents a layer in the
Timeline view. This module has an input port (top) that allows information to flow through it. It has an output
port (bottom) that exports its information in a downward flow. On the left is a yellow box that displays the
module's Properties editor, where all its available parameters can be adjusted. Lastly, there is a dark arrow that
displays a thumbnail of what the module contains.
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Write and Display Modules

Both the Write and Display modules do not have output ports. This is because the information that flows into
them can go no further in the network. The Write module records the images and renders the final output. The
Display module captures the visual information and outputs it to the Camera view.

Composite Module

The Composite module combines multiple source images (Drawing modules), including all transformations and
effects, into a single bitmap or vector image for each frame.
The Composite module layers the images based on the composition order rule. First, the Z-value of the elements
are analyzed to determine depth. When multiple elements have the same Z-value, the Depth values in the
Drawing modules are consulted. If the Depth values are also the same between elements, the composition order
is determined by the cable order of modules on the Composite module. By default, modules connected to the
right are rendered below those connected to the left. You can override this default in the Composite module
editor. The Composite module is an example of a module that can have an infinite number of input ports that can
take in multiple, individual sources of information. The leftmost input port on the Composite module is always
green. This lets you know that, in terms of stacking order, whatever is plugged into this port will appear on top
of the composite after the Z-depth is taken into account.

Effect Module

An Effect module can often have two input ports. The rightmost input port is for the drawing layer that is to be
acted upon by this effect, while the left port is usually reserved for a matte. If an effect has a Matte port, it is
required and not to be considered optional.
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Matte Drawing
A matte, also called mask, is the shape that will be used by the effect module to modify the original image. The
effect will only be applied where the matte overlaps with the original image. Sometimes the matte will act as a
negative shape that the effect will exclude. This all depends on the nature and editing properties of the effect.

Position Ports
Some effects contain three input ports. If they are green, then they require a Peg module. In this case, the effect
can accommodate two pegs.

Peg Module
The Peg modules control the transformation of elements (position, scale, skewing and rotation) over time. The
green ports at the top and bottom of the module indicate that it accepts position information and can then pass
this information on.
One peg can be used to control many different modules or one module can accept more than one peg. In a
situation like the latter, one peg might be used to modify the rotation, while the other used to modify the
position of the effect and then animated differently over time.

Refer to Pegs on page 943 for further information about pegs.

Related Topics
•

Integrated Help View on page 1205

Module Library View
If you need to add new effects and other modules to the Network view, you will need to get them from the
Module Library.
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When you create a new project in Harmony, the default network that appears in the Network view looks similar
to the diagram below.

Module Library View Toolbar
In the Module Library View toolbar, you can switch the display mode of the effect icons:
•

View as Icons

•

View as List

•

View as Icons with Names

Module Tabs
The Module Library is conveniently broken up into several sections or tabs:
•

Favorites
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Includes the most common modules.
•

•

To add extra modules to the Favorites tab, select any module from any other section and drag it onto
the Favorites tab.

Filter
Includes effect modules, such as blurs.

•

Group
Includes modules used for grouping, like Group modules and Multi-Port modules.

•

IO
Includes Display, Drawing, Write and Note modules.

•

Move
Includes modules used to change elements over time, like Peg modules, as well as certain
transformations.

•

Plug-ins
Includes plug-in modules.

•

All modules
Lists all of the modules available.

Related Topics
•

Importing a Module on page 1207

Integrated Help View
As you work on your project in Harmony you might find that you need a little help identifying some different layer
types (module types in the Network view) or with immediate access to keyboard shortcuts.
Harmony has a view where you can access all this information, known as the Help view. In addition, you can use
the green forward and backward arrows, in the Help view, to review a history of the help information that you
called up during your session.
To access the Help View:
•

In the top menu, go to Windows > Integrated Help.

•

From any of the other views, click on the View Menu arrow

The Help view opens.
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To use the Help View to identify layer/module types:
•

In the top menu, go to Help > Modules, then select either Show Help on Selected Module or choose from
one of the listed module types.

•

In the Drawing or Camera view, use the Select

tool to make a selection and then click on the Show

Help on Selection button in the Help view.
•

In the Timeline view, click on the layer that you would like to identify.

•

In the Network view, click on the module that you would like to identify.

A description of the selected layer/module appears in the Help view.
To use the Help View to call up a list of all shortcuts:
•

In the top menu, go to Help > Show All Shortcuts.
A list of shortcuts appear in the Help view.

Related Topics
•

Adding Effects on page 1200
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Importing a Module
To bring a module into the Network view, drag it from the Module Library and drop it into the Network view.
Once in the Network view, you can click on the input or output port of a module and drag out a cable. You can
then connect this cable to the output port or input port of another module.

If you want to connect a module between two connected modules, you can use the [Alt] key as you drag the new
module over the existing cable connection. Using the same [Alt] key, you can also disconnect a module.

If you want to remove a module, select and press [Delete] to remove it from the Network view.

Related Topics
•

Adding Effects Through the Timeline View below

Adding Effects Through the Timeline View
Although all effects should be added through the Network view, there are two effects that can be quickly added
through the Timeline view. These effects, Colour Card and Quadmap, can also be added through the Network
view in the usual manner. In addition, there is a special way of grouping elements that can only be done through
the Timeline view.
To add effects in the Timeline view:
1. In the Timeline view, click on the Add Layers

button and from the Layers drop-down menu select the

desired effect that you would like to add.
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2. The effect appears in the Timeline view. The Colour-Card does not require to be parented to any layer.
3. For the Quadmap, drag the drawing layer onto the Quadmap layer to parent it.

4. In the Timeline view, double-click on the Quadmap layer to open the Layer Properties view.
5. In the Layer Properties view, adjust the parameters.

Once you have set the parameters for your effect, you can store it in the Library view as a template
so you can quickly reuse it later on without having to set the parameters again.
Refer to Creating a Template on page 646 to learn more about creating templates.
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Grouping from the Timeline View
There are several advantages to using the Group Selection With Composite command (only found through the
Timeline view) over the simple Group Selection (which references both the Group layer in the Timeline view and
the Group module in the Network view.
One of the advantages that this command has is that it groups all the selected elements into a neat module that
has a nested composite. This means that there is only one connection coming out of the Group module. With the
simple Group module or command, the Group displays the same number of connections as elements in the
group. Both grouping commands display the same structure in the Timeline view.

The Group Selection With Composite command should only be used before any work has been done in the
Network view and it recommended for objects whose stacking order is of no consequence.

Using the Group Selection from Composite command on elements that have effects, have been
tweaked in the Network view, or whose stacking order is of consequence, may cause the grouped
elements to lose their properties once grouped in this way. In addition, though you may only select a
few modules to group, if there are other layers in the timeline that exist between the selected layers,
they will automatically be grouped, even if not selected.

To group selected elements using the Group Selection With Composite command:
1. In the Timeline view, in the layers section, select the elements that you wish to group.
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Any layers between the selected layers will automatically get grouped as well, so if the stacking order is of
no consequence, move extra layers either above or below the layers that you wish to group.
2. Right-click on one of the highlighted layers and from the pop-up menu select Group Selection With
Composite.

3. The layers appear indented under a new Group layer in the Timeline view and in a new Group module in
the Network view.

Related Topics
•

Importing a Module on page 1207
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Previewing Effects
Most effects must be rendered so you can preview them properly. Some effects can be displayed in the OpenGL
view, but most of them must be rendered and previewed in the Render Mode of the Camera view.
To preview effects:
1. In the Camera view, click the Render Mode

button.

In the bottom-left corner of the Camera view , the Preview Update

button indicates the status of the

rendering. Depending on the size of the frame to render, it may take several seconds. When the rendering
is in progress, the progress wheel icon displays. When the render is complete, the Up-to-date Preview
icon displays.

Once you preview your effect, you may want to adjust it. By default, as soon as you modify a parameter,
Harmony will recalculate the preview image. If your scene is heavy and you do not want preview rendered
automatically, you can disable the Auto-Render option and request the preview update yourself.
To disable the Auto-Render option, do one of the following:
‣

In the bottom-left corner of the Camera view, hold down the Preview Update

button to open the

quick access menu. Deselect the Auto-Render option.

‣

In the Rendering toolbar, click the Cancel Preview button.

‣

From the top menu, select Scene > Render > Cancel Preview Render.

‣

Press [Shift] + [Esc].

Once the Auto-Render option is disabled, you must request the preview update by clicking the Preview Update
button.
To manually update the rendering preview:
‣

In the bottom-left corner of the Camera view, hold down the Preview Update
menu that appears, select Auto-Render.
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Note that you cannot play back your animation in Render mode. You must perform a render or a
preview render to see your animation with the final effects.

Related Topics
•

Previewing and Playing Back Effects on page 1403
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Animating an Effect Over Time
When compositing your scene, it will often happen that you want to animate the parameters of an effect over
time. You might want to have an object fading in or out by changing the transparency level over time or
increasing the colour contrast on one of your drawings over a certain frame range.
To animate an effect over time, create a function curve by adding keyframes to the parameters you want to
animate. To do this, you will use the Layer Properties view, the Network view and the Timeline view. You can fine
tune your animation using the Function view.
To animate an effect over time:
1. In the Network view, drag an effect module from the Module Library view and drop it into the Network
view.

2. Plug the effect element between the drawing element that you would like to apply the effect to and a
composite module. You can either do this manually by unplugging and plugging, or by holding down [Alt]
as you drag it through a connection.
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The effect should also appear in the Timeline view as well.

3. To animate the value of the parameter, you must create a function curve and add keyframes on it. For
example, you could get the Blur-Radial effect to have no blur on the first frame and become very blurry by
the end of the scene by animating its Radius parameter. To create the function curve:
‣

In the Layer Properties view, click on the Function

button you want to animate to create a function

curve.

‣
OR
‣

You can also expand the effect layer's parameters in the Timeline view by clicking on the Expand
Function
button and add a keyframe to the parameter you want to animate or press [F6].

‣
4. In the Timeline view, click on the Show Data View

button.

5. In the Timeline view, go to the frame where you want to start animating the effect.

6. In the Data view, click on the Add Keyframe

button.

7. In the Value field scroll to the keyframe value or type the value in the field.
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‣

If your keyframes are stop-motion keyframes, in the Timeline view, select the new keyframes. Rightclick on the selection and select Set Motion Keyframe.

8. Repeat this process for each keyframe to be added.

Refer to the Previewing and Playing Back Effects on page 1403 to learn how to preview animated
effects.

Related Topics
•

Particle Effects on page 1355

•

Modifying a Path in the Function View on page 984
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How Does an Effect Work?
An effect always needs a drawing connection and sometime a matte or shape connection. A matte provides
drawing information that will be used to determine the area where the effect will be applied on the drawing. The
details and colours within the matte drawing do not matter, as the system will only use the shape and
transparencies in it. A matte is also known as mask.
The matte principle can be demonstrated on the Tone effect.

The drawing layer is connected in the right port of the effect and the matte (mask) in the left port. The Tone
effect then applies darker colours where the matte overlaps the image, blurs the tone edge, and finally clips out
the extra tone zone outside of the drawing before outputting a final drawing with a tone.
The tone's parameters can be adjusted in the Layer Properties view and any of them can be linked to a function
column to be animated over time. This means that all of the effects can be customized.
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Related Topics
•

Using Effects on the next page
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Using Effects
Here is the list of the main effects available in Harmony. Each effect and how to use it is described in the
corresponding section.
•

Anti-Flicker on page 1220

•

•

•

Apply Peg Transformation on
page 1221

Contrast on
page 1287

Matte-Resize on
page 1325

•

•

Apply Image Transformation
on page 1226

Cutter on
page 1288

Motion-Blur on
page 1326

•

Dither on
page 1289

•

Multi-Port-In on
page 1328

•

External on
page 1290

•

Multi-Port-Out on
page 1328

•

Focus on
page 1293

•

Negate on page 1329

•

Note on page 1330

•

Focus Multiplier on
page 1295

•

Overlay Layer on
page 1331

•

Glow on page 1296

•

Pixelate on page 1333

•

Glue on page 1298

•

Placeholder on
page 1334

•

Quadmap on page 1334

•

Refract on page 1336

•
•

Auto Patch on page 1229

•

Blending on page 1231

•

Blur - Box on page 1237

•

Blur - Gaussian

•

Blur-Directional on page 1234

•

Blur - Radial on page 1242

•

Blur - Radial Zoom on
page 1244

•

Blur-Variable on page 1248

•

•

Brightness and Contrast on
page 1249

Gradient on
page 1300

•

Grain on page 1302

•

Channel Selector on
page 1251

•

Greyscale on
page 1304

•

Remove Transparency
on page 1338

•

Channel Swap on page 1253

•

•

Shadow on page 1339

•

Chroma-Keying on page 1254

Grid / Field Chart
on page 1306

•

Highlight on
page 1310

•

Sparkle on page 1342

•

Tone on page 1344

•

Colour-Art on page 1259

•

Colour Banding on page 1260

•

Colour-Card on page 1262

•

•

Hue-Saturation on
page 1313

•

Transparency on
page 1346

Colour-Override on
page 1263

•

Image Switch on
page 1316

•

Turbulence on
page 1348

•

Colour-Scale on page 1281

•

•

•

Composite-Generic on
page 1282

Layer Selector on
page 1317

Turbulent Noise on
page 1351

•

Lens Flare on
page 1319

•

Underlay Layer on
page 1353

•

Line Art on
page 1321

•

Underlay Layer on
page 1353

•

Matte-Blur on
page 1323
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To learn about the Deformation modules, see Deformer Effects on page 1115.

To learn about the Composite module, see Composite Module on page 805, Composite Layer
Properties on page 811 and Managing a Network with a 3D Scene Setup on page 871.

To learn about the Display module, see Display Concepts on page 825.

To learn about Crop, Scale-Output and Write modules, see Write Module on page 1421, ScaleOutput Module on page 1427, Crop Module on page 1429 and Connecting the Required Modules
on page 1433.

To learn about the Ortholock, refer to Locking Flat Drawings to the Camera Angle.

To learn about the Quake module, see Animating a Camera Shake using the Quake Module on
page 966.

To learn about Particles, see Particle Effects on page 1355

To learn more about rendering 3D models, see Rendering 3D Models.

Related Topics
•

How Does an Effect Work? on page 1216
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Anti-Flicker

Use the Anti-Flicker to compensate for flickering in your output to TV formats. The Anti-Flicker effect applies a
vertical blur to the rendered output. You should place the Anti-Flicker before a Write module in the Network
view.

Use the Anti-Flicker editor to control the amount of blur that is applied to rendered output. In the Radius field,
enter a value for the number of pixels to be considered in the blur.

Related Topics
•

Using Effects on page 1218
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Apply Peg Transformation

Use the Apply Peg Transformation module to apply a transformation coming from a Peg, Ortholock, or
Quadmap module on a single module or a group of modules. When using the drawing layer's No Clipping
option, you can use this module to apply all Camera and Peg transformations once all of the effects and modules
connected above the drawing module are calculated.
You can use this effect module to create a simple highlight on a cut-out puppet or use the No Clipping option
available in the drawing layer.
The No Clipping option, found under the drawing Layer Properties' Advanced tab is used when you do not want
to crop your images before all effects are applied to your drawing. No camera motion or peg transformation will
be applied to your drawing until you connect an Apply Peg Transformation.

Refer to Positioning an Element Using the Layer Properties on page 785 to learn more about the
drawing layer's Advanced tab.

The advantage of this module is that you can create a second output of your image or puppet and offset it, scale
it or apply any kind of transformation on it.
The transformations set in the Peg, Ortholock, or Quadmap module connected to the Apply Peg
Transformation module are applied BEFORE the image is composited.
Here is an example of how to connect the Apply Peg Transformation module:
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The transformation set in the Peg module from the example above is applied before the image is composited,
which is the equivalent of the following network:

In the following images you can see the result of the transformation without the Apply Peg Transformation
module and with it:
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Using the Apply Peg Transformation you can apply transformation on drawings that are outside the camera
frame and make them appear inside the frame.
If you are using the Apply Image Transformation module to create a drop-down shadow for a character, it will
work correctly so long as the character is not going outside of the camera frame or that the drawing connected
in it is a VECTOR drawing. The reason is the Apply Image Transformation module applies the transformation
once the drawing is rendered, moved by its own set of Pegs, motion paths and quadmap and cropped to the
camera frame size. This crop operation does not occur if the drawing is a vector drawing (*.TVG). Although, as
soon as the drawing is passed through an effect module or a bitmap type Composite module, the drawing is
turned into a bitmap image and gets cropped.
So, if you offset a bitmap half inside and half outside the camera frame, the outside part is cropped out and then
moved by the Apply Image Transformation module. A part of the original drawing is cut. You need to use the
Apply Peg Transformation module for the transformation to be applied before the image is processed and
cropped.
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Related Topics
•

Advanced Apply Peg Transformation on the facing page

•

Apply Image Transformation on page 1226
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Advanced Apply Peg Transformation
You can use the Apply Peg Transformation's middle port to apply the transformation you connected to the
module after one of the Peg or Quadmap connected above the drawing module.
In the following example, two pegs were added to control the different motions on independent trajectories:
•

Peg-Translation

•

Peg-Scale

When there is no Apply Peg Transformation module, the Peg-Translation is the first trajectory to affect the
drawing module. Then, once the translation is applied, the Scale trajectory affects the drawing module.
When using an Apply Peg Transformation module without using the middle port, the Peg-Rotation connected in
the APT module is applied at the top of everything. The order in which the trajectories are applied to the
drawing module is:
1. Peg-Rotation
2. Peg-Translation
3. Peg-Scale
When the Peg-Translation is connected in the Apply Peg Transformation's middle port, the Peg-Rotation is
applied after the Peg-Translation and before the Peg-Scale. This means that the translation is done before the
rotation instead of the rotation before the translation.
The order in which the trajectories are applied to the drawing module is:
1. Peg-Translation
2. Peg-Rotation
3. Peg-Scale
Use the Apply Peg Transformation editor to rename the module.
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Related Topics
•

Apply Peg Transformation on page 1221

Apply Image Transformation
The Apply Image Transformation effect is mainly used when you want to pan an object out of the camera frame
and that object has an effect such as a Glow or a Blur on it. When you use a peg or the Apply Peg Transformation
module to translate an object such as the sun out of the camera frame, as soon as the sun starts to go outside of
the camera frame, the sun's circle is cropped and the blur is applied on the shape left over. This also means that
when the sun is completely out of the frame, the Blur is not calculated anymore and the Blur pops out.
To prevent this from happening, you must use the Apply Image Transformation module to pan the sun out.
The Apply Image Transformation module applies the panning transformation once the full drawing of the sun is
blurred, once the image is composited. Here is an example of this network:

Here is how to connect the Blur effect for a sun panning out:
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Here is the visual result of the blurred sun:

Look at the following example to understand better why using the Apply Image Transformation instead of a
regular peg or the Apply Peg Transformation module.
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The normal rendering behaviour is to crop the image before applying the effects. When planning a sunset using
either a Peg or the Apply Peg Transformation module, as soon as the drawing of the sun is out of the camera
frame, the drawing is cropped and there is no image left to blur. This means that the glowing edge pops out of
the camera instead of panning out gradually. Using the Apply Image Transformation module, the image is
blurred before being panned out, so this means that even once the drawing is out of the camera frame, its
glowing edge will still show until the drawing is far enough from the camera border. This way, there is no pop
when panning out blurred objects.
Use the Apply Image Transformation editor to change the name of the module.
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Related Topics
•

Apply Peg Transformation on page 1221

Auto Patch

The Auto Patch module is used mainly when creating joint patches for cut-out puppet drawn with pencil lines and
painted in the Colour Art layer. Instead of removing a portion of the outline to attempt to create a seamless
joint, you can draw complete pieces and with the Auto Patch module, automatically create a perfect articulation.
The requirements for this effect to work are:
•

Drawing outlines must be drawn in pencil lines

•

Drawing outlines must be drawn in the Line Art layer

•

Drawing fill colours must be painted in the Colour Art layer

Pencil lines are central vector lines. The vector is located along the centre of the line. This means that when you
paint a zone delimited by a pencil line, the colour fill will expand to the centre of the pencil line.

When using the regular patch technique, recommended for the brush line, the result with pencil lines is very odd
looking because the colour fill zone is bigger than the pencil line inner contour.
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Instead of using the regular patch method, you can use the Auto Patch module. It will automatically extract the
Colour Art and clip it to the right size. Then, you can connect it in front of the piece to be covered.
The network connection for the Auto Patch is quite simple. Once your basic character rigging is done, you can
add the Auto Patch module to the joints you want to cover. There is no need to set any parameter.

Related Topics
•

Patch Articulation on page 749

•

Deformation on page 1111

•

Character Building on page 665
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Blending

Effects modules, like the Tone module and Highlight module, can control the colour and alpha composite
operations for you. These modules were created with pre-set colour and alpha composite operations to fit the
most frequently used, composite operations.
You might, however, still want to control the colour and alpha composite operation between two images using
the Blending module, to create a multiplicity of lighting, shadow, filter or ambient effects. The Blending module
combines two images into one output image, following the parameters you choose for your movie and images
sequence or SWF movie exports.
The drawing module connected to the Blending effect will act as the blending image and will be applied to all the
drawing layers situated under them in the Composite module or Timeline view order.
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Use the Blending editor to control the settings of the Blending effect.

•

Name: Use this field to rename the module.

•

Blend Mode: Choose the blending effect mode you wish to apply to your layer. The Blend Mode type will
only be visible when the Camera view is set to Render
mode and will only export to a bitmap movie
file or sequence of images.

•

SWF Blend Mode: Choose the blending effect mode you wish to apply to your layer. The SWF Blend
Mode result will only be visible when exported to a SWF movie.

Blend Mode and SWF Blend Mode
Both the Blending module and Composite-Generic module have regular blending modes and legacy blending
modes. The regular blending modes will take the source images and unmultiply them before blending the two
inputs together. The images will be remultiplied when being output from the module. The legacy blending
modes use the pre-multipled source images as is in order to apply the effect. Unmultiplying the images before
processing them will give a final result closer to what can be found in software such as Adobe Photoshop.
Here is a list of the available Blending modes:
•

Normal: The layer attached to the effect acts as a normal layer and will not create any blending mode
effect.
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•

Multiply: This operation multiplies the blending element colour with the output image. This will darken
the colour of the overlapping area.

•

Screen: This operation multiplies the inverted colour of the blending element with the image. This will
lighten the colour of the overlapping area.

•

Lighten (Lighten Legacy): This operation lightens the area of the output image which, is darker than the
blending element’s colours. The lighter colours will remain unchanged.

•

Darken: This operation darkens the area of the output image, which is lighter than the blending element’s
colours. The darker colours will remain unchanged.

•

Difference (Difference Legacy): This operation subtracts the blending elements colour from the output
image colours or vice-versa, depending on which of them has more bright colours. The final result will be
colours that are more vibrant.

•

Add (Add Legacy): This operation lightens the output image using the blending element.

•

Subtract (Subtract Legacy): This operation darkens the output image using the blending element.

•

Invert: This operation inverts the output image colours on the area overlapping the blending layer
colours.

•

Overlay (Overlay Legacy): This operation multiplies or screens the colours from the blending image, with
those of the output image, depending on the base colour. Colours from the blending element overlay the
colours of the drawing elements, while preserving the highlights and shadows of the base colour. The
base colour is not replaced, but mixed with the blend colour to reflect the lightness, or darkness, of the
original colour.

•

Hardlight (Hardlight Legacy): This operation multiplies, or screens, the colours of the blending layer with
those of the output image, depending on the blend colour. If the blend colour is lighter than 50% grey, the
image is lightened, as if it were screened. This is useful for adding highlights to an image. If the blend
colour is darker than 50% grey, the image is darkened, as if it were multiplied. This is useful for adding
shadows to an image. Painting with pure black or white results in pure black or white. Play with the
Opacity value to create a subtler look.

•

Alpha: This operation will blend the alpha value of the blending layer with the output image. This effect is
not available for SWF Blend Mode.

•

Erase: This operation produces a cutter effect using the blending element. This effect is not available for
SWF Blend Mode.

•

Divide (Divide Legacy): This operation divides the output image colour values by the blending layer
colour values. The blending image colour values are inverted, creating a negative image. The negative
image’s colour values are then multiplied by the right image colour values. This effect is not available for
SWF Blend Mode.

•

Replace: This operation replaces the output image by the blending layer. This effect is not available for
SWF Blend Mode.

•

Softlight: This operation darkens or lightens the colours in a soft and diffuse way, depending on the
blend colour (image in left port). If the blend colour is lighter than 50% grey, the image is lightened. If the
blend colour is darker than 50% grey, the image is darkened. Painting with pure black or white produces a
distinctly darker or lighter area, but does not result in pure black or white.
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It is possible to select two different blending modes in the same Blending effect layer, in the event
that you want to export your project to both a Bitmap and an SWF movie file with different results.

Related Topics
•

Using Effects on page 1218

Blur-Directional

The Blur-Directional effect creates the effect of a motion blur that pulls and smears the image from one contour
edge to a different direction or angle. This effect is useful in creating the impression of speed, such as the streaks
of colour that follow a car travelling at high speed.

Use the Blur-Directional editor to control the settings of the Blur-Directional effect.
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Blur-Directional Property Editor
Parameter

Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo
a change of depth or scale. When this option is deselected, the effect's values
remain unchanged regardless of any depth or scale changes. This option
should be deselected when multiple drawings are composited and attached to
this effect.

Radius

Size of the blur. The larger the value, the greater the strength or reach of the
blur. The blur radius is affected by the drawing scale and camera position. Click
the Edit Curve button to change these values over time by adjusting the function curve.

Falloff Rate

The distance where the blur fades from the edge of the image. Select a value
between 0 and 1. A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the character to the farthest edge of
the blur. A fall-off rate of 1 causes the blur to fade out quickly, so the blur is
heaviest closer to the edge of the image.
The direction of the blur. Enter a value from 0 to 360.
0: Blurs the image to the west.

Angle

90: Blurs the image to the south.
180: Blurs the image to the east.
270: Blurs the image to the north.

Direction of trail

If you do not set an Angle for the direction of the blur, you can select a direction (north, south, east, or west) from this menu. The calculations for this feature are faster than the calculations for the Angle setting.

Ignore Alpha

Controls the leading edge of the blur. Deselect this option for a solid or hard
leading edge on the blur.

Extra Final Blur

Adds a second blur after the Blur-Directional is created. If you have aBlur-Directional that begins at 0 and gradually gets stronger, deselect this option to
ensure a smooth progression.

Number of Iterations

The number of times the blur is applied to the image. A higher number of iterations creates smoother transitions between colours and increases the blur,
but also increases render time.
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Related Topics
•

Using Effects on page 1218
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Blur - Box

The Blur - Box effect is a quick and easy way to create a blurring effect. The Box blur changes the colour value of
each pixel based on the pixels next to it in the vertical and horizontal directions. The look of the blur is similar to
the look achieved using Gaussian blur, but renders much faster. This effect is useful when a faster rendering time
is important, and the quality of the blur is less important. Also, you can use a matte with this effect to isolate
areas of the image.
For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/videotutorials/chapter/adam-phillips-harmony-effects.
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Blur - Box Effect Properties
Parameter

Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo
a change of depth or scale. When this option is deselected, the effect's values
remain unchanged regardless of any depth or scale changes. This option
should be deselected when multiple drawings are composited and attached to
this effect.

Repeat Edge Pixels

Makes the blur algorithm operate as if the pixel values beyond the edge of the
layer are the same as the values of the edge pixels. This keeps edges sharp,
preventing them from darkening and becoming more transparent.

Blurriness

Amount of blur applied to the layer.
Blurs according to the length, width, and angle you specify. For example, if a
character is walking east, the blur may fall to the west.
Length: Length of the blur.

Directional
Width: Thickness of the blur.
Angle: The direction in which the blur is applied: sideways, up, down, 90
degrees, 45 degrees, and so on.

Radius

Size of the blur. The larger the value, the greater the strength or reach of the
blur. The blur radius is affected by the drawing scale and camera position. Click
the Edit Curve button to change these values over time by adjusting the function curve.

Bidirectional

Applies the blur on both sides of the pixel.

Fall Off

The distance where the blur fades from the edge of the image. Select a value
between 0 and 1. A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the character to the farthest edge of
the blur. A fall-off rate of 1 causes the blur to fade out quickly, so the blur is
heaviest closer to the edge of the image.

Number of Iterations

The number of times the blur is applied to the image. A higher number of iterations creates smoother transitions between colours and increases the blur,
but also increases render time.
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Blur - Gaussian

The Blur - Gaussian effect softens the image, reducing the amount of noise and detail. The look of the Gaussian
blur is smooth, but does take some rendering time. This effect is useful when rendering time is less important,
and quality is more important. Also, you can use a matte with this effect to isolate areas of the image.
For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/videotutorials/chapter/adam-phillips-harmony-effects.
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Blur - Gaussian Effect Properties
Parameter

Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo
a change of depth or scale. When this option is deselected, the effect's values
remain unchanged regardless of any depth or scale changes. This option
should be deselected when multiple drawings are composited and attached to
this effect.

Repeat Edge Pixels

Makes the blur algorithm operate as if the pixel values beyond the edge of the
layer are the same as the values of the edge pixels. This keeps edges sharp,
preventing them from darkening and becoming more transparent.

Blurriness

Amount of blur applied to the layer.
Blurs according to the length, width, and angle you specify. For example, if a
character is walking east, the blur may fall to the west.
Length: Length of the blur.

Directional
Width: Thickness of the blur.
Angle: The direction in which the blur is applied: sideways, up, down, 90
degrees, 45 degrees, and so on.
Blurriness

Amount of blur applied to the layer.

Bidirectional

Applies the blur on both sides of the pixel.
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Blur - Radial

The Blur-Radial effect creates an effect that softens, fogs or obscures the image evenly in all directions. This
effect is useful when you want to make cloudy images not realistically seen in detail, such as a drawing object that
is farther back or in the background of your scene, usually blurry due to the laws of atmospheric perspective.
Other uses include the general softening of objects such as snow, stars and shadows that do not naturally have a
hard outline.

Use the Blur-Radial editor to change the values of the Blur effect.
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Parameter

Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo
a change of depth or scale. When this option is deselected, the effect's values
remain unchanged regardless of any depth or scale changes. This option
should be deselected when multiple drawings are composited and attached to
this effect.

Radius

Size of the blur. The larger the value, the greater the strength or reach of the
blur. The blur radius is affected by the drawing scale and camera position. Click
the Edit Curve button to change these values over time by adjusting the function curve.

Quality

Select High for a slow and accurate operation or Low for a faster operation
with a more raw look.

Related Topics
•

Using Effects on page 1218
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Blur - Radial Zoom
The Blur - Radial Zoom effect creates blurs around a centre point, simulating the look of a zooming or rotating
camera. You can use a matte to isolate the area of the image from which you want the effect to radiate from. For
example, in the illustration below, a circular matte was created to mask the eyeball and a Negate effect was
applied so the blur is outside the matte. Then the centre point was positioned on the character's iris, which is the
centre of the matte.

For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/videotutorials/chapter/adam-phillips-harmony-effects.
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To create a radial-zoom blur around an isolated area:
1. Connect a drawing and a background image to a Composite module.
2. Connect the Composite module to the Blur-Radial Zoom module.

3. Connect a Blur-Radial-Zoom module to the Composite module and add the Write and Display modules.

4. Now you will need to create a matte to isolate an area of the image. In the Timeline view, click the Add
Layers
button and select Drawing. Give the layer a name, such as Mask.
5. In the Drawing view, draw a filled shape.
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6. The blur should radiate outward from the mask. To do this, connect a Negate module to the mask. In the
Negate properties, select the Negate Colour and Negate Alpha options. Deselect the Negate Colour
Clamp to Alpha option.

7. Connect these modules to the rest of the tree. Your Network view should look like this:

8. Open the Blur - Radial Zoom property editor.
9. From the Center section, select a type from the Type drop-down menu:

‣

2D Path: Lets you move the centre point visually in the Camera view.

‣

Separate: Lets you control the x and y axis by entering values in the fields or by moving the centre
point in the Camera view.

10. Set a value for the Blurriness.
11. With the Blur - Radial Zoom module selected in the Network view, select View > Show > Control or
press [Shift] + [F11].
The red centre point appears in the centre of the Camera view.
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12. In the Tools toolbar, select the Transform
13. Click the Animate Mode

tool.

button in the Tools toolbar if you want to create function curves to keyframe

over time. Otherwise, values will be created for the duration of the scene.
14. Move the centre point to the desired position. In our example, the centre was moved to the centre of the
mask.
15. In the Network view, select the mask you created.
16. In the Camera view, move the mask to the desired position.
17. Continue to adjust the blur values until you achieve the desired effect.

Blur - Radial Zoom Effect Properties
Parameter

Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo
a change of depth or scale. When this option is deselected, the effect's values
remain unchanged regardless of any depth or scale changes. This option
should be deselected when multiple drawings are composited and attached to
this effect.

Centre

Sets the point where the blur will apppear to be "zooming" out from. By
default, the centre appears in the middle of the Camera view.
2D Path: Lets you move the centre point visually in the Camera view.

Type

Separate: Lets you control the x and y axis by entering values in the fields or by
moving the centre point visually in the Camera view.

(x) and (y) Axis

When the Separate type of centre is selected, lets you individually set the x and
y coordinates for the centre.

Path

When 2D Path is selected, indicates that the coordinates are confined to the
image.

Blurriness

Amount of blur applied to the layer.

Variation

Constant: An equal, constant blur is applied on all pixels.
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Linear: A gradual blur is applied on all pixels.
Quadratic: An exponential blur is applied on all pixels.
Direction

Lets you select preset blur types or create a custom blur.

Presets

A set of preset radial, zoom, and spiral blurs to get you started. You can then
adjust the type to customize the blur.

Custom

Create your own blur by entering a value for the direction of the blur lines.

Fall Off

The distance where the blur fades from the edge of the image. Select a value
between 0 and 1. A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the character to the farthest edge of
the blur. A fall-off rate of 1 causes the blur to fade out quickly, so the blur is
heaviest closer to the edge of the image.

Bidirectional

Applies the blur on both sides of the pixel.

Angle Quality

Affects the quality of the blur by defining how fine the reference radial grid is
on the image. This determines the width of all the wedges. A higher quality
yields achieve better results, but will be slower to render.

Radius Quality

Controls the quality of the blur. A higher quality yields better results, but will
be slower to render.

Blur-Variable

Use the Blur-Variable effect to create a radial blur that varies within a single image based on the white and black
values in the matte you supply. You can set one blur value for the black regions in the matte, and another blur
value for the white regions. The blur value for each grey region is interpolated between your black and white blur
settings.
The following example is a network for a Variable Blur effect. A black and white copy of the character was used
to create the effect. Use the Blur-Variable editor to control the blur value for the white and black radius.
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Variable Blur Effect Properties

Black radius

The amount of blur to apply to the black (transparent) values in the matte.
Higher values create more blur in the colour image's regions that correspond
to the black matte region.

White radius

The amount of blur to apply to the white (opaque) values in the matte. Higher
values create more blur in the colour image's regions that correspond to the
white matte region.

Quality

Select High for a slow and accurate operation or Low for a faster operation
with a more raw look.

Keep inside source image

This option confines the blur to the source image.

Related Topics
•

Using Effects on page 1218

Brightness and Contrast
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The Brightness and Contrast effect is used to modify the brilliance or dullness of an image or to create a greater
difference between the lights and darks of an image by increasing their respective intensities. This effect can be
used when an image appears too flat. Increasing the brightness or contrast can give a drawing a more attractive
and 3D quality. This can be useful if you want to push your background to the rear by making it look dull and flat
and pulling your foreground elements to the front by giving them a higher contrast.

Use the Brightness and Contrast editor to change the values of the Brightness and Contrast effect.

Brightness and Contrast Effect Properties

Brightness

A value that is less than 0 will darken the image; a value greater than 0 will
brighten it. Attach a Bezier or Ease function to change the brightness over
time.

Contrast

A value that is less than 0 will reduce contrast; a value greater than 0 will
increase contrast. Attach a Bezier or Ease function to change the contrast over
time.

Related Topics
•

Using Effects on page 1218
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Channel Selector

Use the Channel Selector effect to isolate one of the four colour channels of an image:

Use the Channel Selector editor to choose which channel to isolate.
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Related Topics
•

Using Effects on page 1218
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Channel Swap

The Channel Swap effect lets you take the image information from one channel and use it in another channel to
achieve interesting effects. You can extract the following: red, green, blue, alpha values, hue, saturation,
lightness, and luminance, as well as turn the information on or off.
For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/videotutorials/chapter/adam-phillips-harmony-effects.
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Channel Swap Effect Properties
Parameter

Description

Red, Green, Blue, and Alpha
Channel From

Lets you select the image information you want to feed into the red, green,
blue, and alpha channels. Full On sets all values to 255 and Full Off sets all values to 0.

Chroma-Keying

The Chroma-Keying effect lets you create an alpha channel (transparency zone) for your bitmap image or image
sequence. For example, if you have a series of bitmap images with a character filmed on a green screen or blue
screen, you can use this module to create an alpha channel based on the screen colour and cut it out from your
image sequence.
The Chroma-Keying module MUST be connected to a bitmap image. The Chroma-Keying will create an alpha
channel that can be seen in the Camera view in the Matte Render Mode. To cut the background colour from your
image, you will need to use a Cutter module.
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To obtain a better result than just extracting the raw colour, you can adjust some parameters such as the
contour blurriness and the matte size. You can see all the options available in the Chroma-Keying Properties
window.

•

Red/Green/Blue/Alpha: In the Colour section, you can enter the RGB value for the colour to extract from
your image. You can also click on the colour swatch to open the Colour Picker window and select a new
window. To select the exact colour in your image, you can use the Eye Dropper found in the Colour Picker
window and pick it directly in your image.
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•

Black Point: The Black Point parameter will increase the transparent (black) portion of the Chroma Key
matte. This means that it will reduce the edge of the visible image.

1256

Toon Boom Harmony 10.3 Stage User Guide

•

Adjacent Pixels Per Pass: When blurring the matter edge's with the Blur Intensity parameter, the
Adjacent Pixel parameter will blur the matte border with the next few pixels (amount indicated in the
field) to create a nicer edge.
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•

Threshold Matte: This option will apply a threshold (tolerance) to the selected colour to be removed. The
Threshold amount is set in the Threshold field.

•

Threshold: The Threshold value will increase or decrease the tolerance for the selected colour to be
removed from the image. The higher the value is the more coloured pixels will be considered in the
Chroma-Keying matte. The pixel colour value will not have to be such a close RGB value to the one
selected in the colour swatch. The lower the Threshold value, the closer RGB value the pixels will have to
be to the selected colour to be part of the matte.

•

Cut Colour: If this option is enabled, the selected colour will be removed from the image and will leave a
transparent zone so that you can see the background and other layers behind the image. If the option is
disabled, the colour will remain, but an Alpha channel is created that can be used with any other modules
requesting a Matte input.

Related Topics
•

Using Effects on page 1218
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Colour-Art

Use the Colour-Art effect to isolate the Colour-Art in a layer. Placing a Colour-Art module after a drawing
module in the Network view only displays the Colour-Art output. The Colour-Art module can only be connected
after a vector drawing layer or a vector type Composite module. Any bitmap information will not be processed.
This effect will only work if the user drew or painted something into the Colour-Art layer of the drawing.

Use the Colour-Art editor to control how the module renders the Colour-Art.

Colour-Art Effect Properties
Antialiasing Quality

Smoothness setting applied to Colour-Art. Choose from Low (no antialiasing),
Medium Low, Medium and High (extensive antialiasing). The higher the set-
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ting, the greater the amount of antialiasing applied. Higher quality images
require more time to render and more memory from your system. Use a lower
quality when rendering a pencil test.

Antialiasing Exponent

Controls the extent of the area around the Colour-Art edges that is used in the
antialiasing process. A higher value uses less area, resulting in sharper edges,
while a lower value uses more area, resulting in softer edges. If the Antialiasing
Quality value is set to Low (no antialiasing), this value is ignored.

Related Topics
•

Using Effects on page 1218

Colour Banding

In this example, a Colour Banding module has been connected to a fire created with particle effects.
Use the Colour Banding effect to add a colour banding visual effect to your elements. The module will associate a
flat colour to the different regions of your element. These regions are delimited according the alpha values that
are set up in the effect module and which will be recognized on the original element. You can use this effect to
change the visual style of a particle module, for example, by giving it a more cartoonish look.

Use the Colour Banding layer properties dialog box to set up the colour banding effect.
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In the Colour Banding layer properties, you have four sections with which to set up the four different
regions alpha and colour override values.
This is how the regions range are calculated.
•

Region 1: Threshold 1 to Threshold 2

•

Region 2: Threshold 2 to Threshold 3

•

Region 3: Threshold 3 to Threshold 4

•

Region 4: Threshold 4 to 100% alpha

1. Threshold 1: Use this first threshold field to determine the first region outer limit. A value of 0 represent
an alpha of 0 which is completely transparent. A value of 100 represents an alpha of 255 which is
completely opaque. If for example, you enter a value of 5 for the first threshold, the region of your
element which is within the range of alpha going from 5% to the Threshold 2 value, will be coloured with
the Area 1 colour value.
2. Red: Use this field to manually enter the value of red for the first region colour.
3. Green: Use this field to manually enter the value of green for the first region colour.
4. Blue: Use this field to manually enter the value of blue for the first region colour.
5. Alpha: Use this field to manually enter the transparency value for the first region colour.
6. Colour: Click in this colour space to open the Colour Picker dialog box and select a colour for the first
region.
7. Blur 1: Use this field to add a blur effect to the edge of the first region.
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The three other sections will set up the regions two, three and four.

Related Topics
•

Using Effects on page 1218

Colour-Card

The Colour Card is a solid background the same size as the camera. The Colour Card lets you fill the scene's
background with a solid colour when there is no background image. If no background or colour card is added to
the scene, the resulting export will appear with a black background.
By default, the Colour Card has a Z ordering value of 12 Backward. This puts the Colour card behind all
elements that have a value lower than 12 Backward. Most of the time, the Colour card will appear
automatically behind all the scenes elements as they are all set to 0 Backward, unless you have changed the Z
ordering of the scene components. If so, the Colour Card will be in front of the elements that are pushed back to
more than 12 fields backward.
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Colour Card Effect Properties
Parameter

Description

Depth

The value used to determine composition order when the Z value of two elements is the same.

Offset Z

The front-back position of the Colour Card layer in 3D space. This value can be
verified in the Top view.

Red/Green/Blue/Alpha

The colour and transparency of the Colour Card. You can also attach these
parameters to function columns to change their values over time.
Click the colour swatch to open the Colour Picker window and select a colour.

Colour Swatch

Opens the Colour Picker where you can specify the colour.

Related Topics
•

Using Effects on page 1218

Colour-Override

The Colour-Override processes the colours in a drawing layer. The drawings in this layer must be TVG files.
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Using this effect you can change colours from the palette without affecting the actual palette, swap clone
palettes, replace a specific colour zone with a bitmap texture or hide and display selected colours.

Use the Colour-Override effect to:
•

Change colour values in drawings during the compositing process.

•

Use colour values from a specific colour palette in the palette list.

•

Establish the priority of override palettes in the palette list. For example, you may have different clones of
the same palette, for example a daytime and nighttime version.

•

Isolate specific areas of a drawing by selecting certain colours. For example, using specific colours to
generate a matte for a glow effect.

•

Hide certain colours.

Use the Colour-Override editor to set the colour override operations for TVG elements and their drawings.

Related Topics
•

Colour-Override Editor Interface on the facing page

•

Overriding a Colour on page 1267

•

Overriding a Colour With a Texture on page 1268

•

Rendering Selected Colours Only on page 1272

•

Modifying a Texture Fill's Transformation on page 1272

•

Overriding a Colour with a Bitmap Image Sequence on page 1274

•

Overriding a Texture on a Pencil Line on page 1276
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Colour-Override Editor Interface

The Colour-Override editor interface is comprised of four sections:
•

Palettes below

•

Colours on the next page

•

Palette Overrides on the next page

•

Colour Overrides on the next page

Palettes
This section displays the palettes in the palette list of the selected layer. Drag these palettes into the Palette
Overrides section to re-order them. You can load additional palettes in the palette list from either your project,
by clicking on The Palette
button, or your computer by clicking on the Browse
button.
•

The Palette

button allows you to load a palette contained within the project hierarchy (Environment,

Job, Scene and Elements).
•

The Browse

button allows you to load a palette located outside the project hierarchy, anywhere on

your system or server.
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Colours
This section displays the colours swatches of the selected palette. Drag a swatch into the Colour-Overrides
section to change its value or drag it into the Selected Colours section to render only that colour.

Palette Overrides
This section forces the use of a particular palette or palette list order, during the composition process. You must
drag palettes from the Palettes section to change their order. Harmony searches the palettes in the order that
they appear in the palette list to find the colour values associated with the colour IDs of each image. To apply a
different version of a colour palette, for example to switch from a day to a night palette, use the override section
to change the order of colour palettes (you must be working with cloned palettes).

Colour Overrides
Drag a swatch from the Colours section to this section to override its value. You can also override a colour with a
texture.
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Related Topics
•

Overriding a Colour below

•

Overriding a Colour With a Texture on the next page

•

Rendering Selected Colours Only on page 1272

•

Modifying a Texture Fill's Transformation on page 1272

•

Overriding a Colour with a Bitmap Image Sequence on page 1274

•

Overriding a Texture on a Pencil Line on page 1276

Overriding a Colour
With the Colour-Override module, you can change the colour of some swatches. To do so, from the Colours
section, you must drag the colour swatch to modify to the Colour-Overrides section.
Several options are available to modify your colours.

Once the swatch appears in the Colour-Overrides section, click on the Select Override Mode button to right-click
on the Override Colour word and select one of the following option in the drop-down menu:

•

Colour not visible: Renders the selected colour invisible in the Camera view.
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•

New RGB only: Overrides the colour swatch while maintaining its original alpha value. You can select a
new colour by pressing the eye dropper
button or clicking directly on the colour swatch and choosing
a new colour from the Colour Picker window.

•

New alpha only: Overrides the swatch's alpha channel while maintaining its original RGB values. You can
select a new alpha value by pressing the eye dropper
button or clicking directly on the colour swatch
and choosing an alpha value from the Colour Picker window.

•

New RGBA: Overrides the swatch's colour and alpha values. You can select a new colour by pressing the
eye dropper
button or clicking directly on the colour swatch and choosing an alpha value from the
Colour Picker window.

Related Topics
•

Overriding a Colour With a Texture below

Overriding a Colour With a Texture
With the Colour Override module, can apply a texture over a selected colour. Any zone painted with the selected
colour swatch will be overridden by the selected texture.
To apply a texture over a colour:

From the Colours section, select the colour swatch to override and drag it to the Colour Override section.
1. Once the swatch appears in the Colour Override section, select it and then click on the Select Override
Mode button to right-click on the Override Colour word and select one of the following option in the
drop-down menu:

‣

Texture - original matrix

‣

Texture - global bbox matrix

‣

Texture - global bbox centered

‣

Texture - contour bbox matrix

‣

Texture - scale to screen

‣

Override With This Texture Centered on Overridden Objects Centre

‣

Texture - Use Input Peg

2. In the Colour-Override section, under the Texture Filename section, click on "Click to select texture file".
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3. Browse for your texture file.

4. Click on the Open button.
There are different ways to apply the texture over your colour:

The result will only be visible in the Camera view while in Render mode. In OpenGL mode, you will
see your original colour.

The matrix position can be modified using the Edit Gradient and Texture
must be painted with a gradient swatch or texture swatch.
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Texture - Original matrix
Overrides the swatch's colour with a pattern or texture. You must right-click under the Texture header to bring
up the Browser window to search for your texture. The texture's default matrix (fixed proportion and
orientation) is mapped the full size of the bounding box of each colour area to be overridden.

Texture - Global bbox matrix
Overrides the colour with a texture that is scaled non-proportionally to the size of the bounding box
encompassing the colour areas to be overridden. With multiple objects, it will look as though their fills were all
traced and cut from the same piece of stretched or squashed fabric.

Texture - Global bbox centered
Overrides the colour with a texture that is scaled proportionally to the size of the bounding box encompassing
all colour areas to be overridden. With multiple objects, it will look as though their fills were all traced and cut
from the same piece of fabric.

Texture - Contour bbox matrix
Overrides the colour with a disproportionately scaled texture for each individual colour area. In other words,
each fill area will not only have the texture scaled to its individual proportions, but also stretched or squashed to
fit within its contours.

Texture - scale to screen
Disproportionately scales the texture to the output resolution before applying it as an override.

Override with this Texture Centered on Overridden Objects Centre
Overrides the colour with a texture that is centered in the bounding box encompassing all colour areas to be
overridden. With multiple objects, it will look as though their fills were all traced and cut from the same piece of
fabric. The texture will not be stretched or distorted. It will be tiled in proportion. The centre of the texture zone
will be centered in the middle of the bounding box's centre.
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With this option, you can connect a Peg in the middle port to apply a transformation on the texture's position.
Refer to Animating a Texture Override with a Peg below to learn how.

Texture - Use Input Peg
Overrides the colour with a texture that is scaled non-proportionally to the size of the bounding box
encompassing the colour areas to be overridden. With multiple objects, it will look as though their fills were all
traced and cut from the same piece of stretched or squashed fabric.
With this option, you can connect a Peg in the middle port to apply a transformation on the texture's position.
Refer to Animating a Texture Override with a Peg below to learn how.

Related Topics
•

Colour-Override Editor Interface on page 1265

•

Overriding a Colour on page 1267

Animating a Texture Override with a Peg
The advantage of being able to animate the texture is that it can be adjusted, scaled, rotated and translated to
follow the general motion of a character if you want the texture to follow instead of having the character moving
across the fixed texture.
1. From the Module Library view, drag a Peg module and drop it in the Network view.

2. Connect the Peg module in the Colour Override's middle port. The green port will take the
transformation of the Peg to modify the pencil texture's position.
3. In the Network view, select the Peg module.
4. In the Advanced Animation toolbar, select either the Translate
5. In the Camera view bottom toolbar, enable the Render
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6. In the Camera view, move the Peg's position. As you move it, you will see the texture getting modified.
You can animate the position by adding position keyframes in the Timeline view. You can use the Random
Fill function to quickly create a random shake. See Pegs on page 943.

Rendering Selected Colours Only
With the Colour-Override module, you can isolate some colours in your drawing and render those ones only.
To render selected colours:
1. From the Colours section, drag the colour swatches to render and drop them into the Render Selected
Colours section.

You have to enable the Render Selected Colours option for the module to proceed with the
operation.

Related Topics
•

Colour-Override Editor Interface on page 1265

•

Overriding a Colour on page 1267

Modifying a Texture Fill's Transformation
When you paint a zone with a bitmap texture swatch, you might want to modify the size or position of the
texture's matrix at the compositing level. Maybe for an effect purpose you need to animate the position of the
texture in a zone. With the Colour-Override module and a Peg, you can animate the texture.
To modify a texture fill's transformation:
1. From the Module Library view, drag a Colour-Override module and drop it in the Network view.
2. From the Module Library view, drag a Peg module and drop it in the Network view.
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3. In the Network view, connect the Colour-Override module under the drawing module you want to
animate the line for. Note that for a cut-out puppet, you would connect the Colour-Override under the
final Composite, set as Pass-Through.
4. Connect the Peg module in the Colour-Override's middle port. The green port will take the
transformation of the Peg to modify the pencil texture's position.
5. Click on the Colour-Override's yellow button to open the editor.
6. In the Colour-Override window, in the Palettes section, select the palette containing the bitmap texture
swatch.
7. In the Colours section, select the texture swatch you used to paint the drawing and drag it to the ColourOverride section.

8. Once the swatch appears in the Colour-Override section, select it and then click on the Select Override
Mode button to right-click on the New RGBA word and select one of the following option in the dropdown menu:

‣

Override the colour's transformation:This option will override the initial texture's transformation
(matrix) established when you painted the zones or modified with the Edit Gradient and Texture
tool. This transformation override will be done by modifying the Peg's position.
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‣

Combine the colour's transformation:This option will combine the initial texture's transformation
(matrix) established when you painted the zones or modified with the Edit Gradient and Texture
tool with the new position transformation you will create when modifying the Peg's position.

9. In the Network view, select the Peg module.
10. In the Advanced Animation toolbar, select either the Translate
11. In the Camera view bottom toolbar, enable the Render

, Rotate

or Scale

tool.

mode.

12. In the Camera view, move the Peg's position. As you move it, you will see the texture fills getting
modified. You can animate the position by adding position keyframes in the Timeline view.

Related Topics
•

Overriding a Colour With a Texture on page 1268

•

Rendering Selected Colours Only on page 1272

•

Overriding a Colour with a Bitmap Image Sequence below

•

Overriding a Texture on a Pencil Line on page 1276

Overriding a Colour with a Bitmap Image Sequence
In production, it will happen that you need to map a live action sequence or bitmap image sequence into a zone
or over several zone. For example, you could have a mirror shattered in several pieces and you want to map in it
the video or someone talking. You can paint the mirror pieces with a specific colour swatch and use the ColourOverride module to map the image sequence into the pieces. It can also be a single image without having to be
an image sequence.
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To override a colour with a bitmap image sequence:
1. From the Module Library view, drag a Colour-Override module and drop it in the Network view.

2. In the Network view, connect the Colour-Override module under the drawing module you want to
animate the line for.
3. Connect the Live Action or Bitmap Image Sequence module in the Colour-Override's left port. The left
blue port will input the images into the colour zones.
4. Click on the Colour-Override's yellow button to open the editor.
5. In the Colour-Override window, in the Palettes section, select the palette containing the colour to
override.
6. In the Colours section, select the pencil texture you used to draw your lines and drag it to the ColourOverride section.

7. Once the swatch appears in the Colour-Override section, select it and then click on the Select Override
Mode button to right-click on the New RGBA word and select Texture - Use Image Input.

8. In the Network view, select the bitmap image module.
9. In the Advanced Animation toolbar, select either the Translate
10. In the Camera view bottom toolbar, enable the Render

, Rotate

or Scale

tool.

mode.

11. In the Camera view, move the Bitmap Image position. As you move it, you will see the texture fills getting
modified. You can animate the position by adding position keyframes in the Timeline view.

Related Topics
•

Overriding a Colour With a Texture on page 1268
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•

Modifying a Texture Fill's Transformation on page 1272

•

Overriding a Texture on a Pencil Line below

Overriding a Texture on a Pencil Line
A pencil line can be drawn with a texture but also painted with a texture swatch. With the Colour-Override
module, you can either override either the pencil line's texture or texture fill and replace it by another one or you
can also animate the texture's position.
With the Edit Gradient and Texture

tool, you can modify the size and position for both types of texture on a

pencil line; the drawing texture and the filling texture. By doing that, you are actually modifying the texture's
matrix.

Related Topics
•

Modifying a Texture Fill on a Pencil Line below

•

Modifying a Pencil Texture on page 1279

Modifying a Texture Fill on a Pencil Line
When you paint a pencil line with a bitmap colour swatch, you can override the position of the texture fill using
the Colour-Override module and a Peg.
To modify the pencil line texture:
1. From the Module Library view, drag a Colour-Override module and drop it in the Network view.
2. From the Module Library view, drag a Peg module and drop it in the Network view.
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3. In the Network view, connect the Colour-Override module under the Drawing module you want to
animate the line for. Note that for a cut-out puppet, you would connect the Colour-Override under the
final Composite, set as Pass-Through.
4. Connect the Peg module in the Colour-Override's middle port. The green port will take the
transformation of the Peg to modify the pencil texture's position.
5. Click on the Colour-Override's yellow button to open the editor.
6. In the Colour-Override window, in the Palettes section, select the palette containing the colour to
override.
7. In the Colours section, select the bitmap texture swatch you used to paint your lines and drag it to the
Colour-Override section.

8. Once the swatch appears in the Colour-Override section, select it anMac OS Xd then click on the Select
Override Mode button to right-click on the New RGBA word and select one of the following option in the
drop-down menu:

‣

Modulate Pencil Texture Colour (replace transformation):This option will override the initial texture
fill's transformation (matrix) established when you painted the line or modified it with the Edit
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Gradient and Texture

tool. This transformation override will be done by modifying the Peg's

position.
‣

Modulate Pencil Texture Colour (combine transformation):This option will combine the initial
texture fill's transformation (matrix) established when you drew the line or modified it with the Edit
Gradient and Texture
tool with the new position transformation you will create when modifying
the Peg's position.

9. In the Network view, select the Peg module.
10. In the Advanced Animation toolbar, select either the Translate
11. In the Camera view bottom toolbar, enable the Render

, Rotate

or Scale

tool.

mode.

12. In the Camera view, move the Peg's position. As you move it, you will see the texture fill getting modified.
You can animate the position by adding position keyframes in the Timeline view.

Related Topics
•

Modifying a Pencil Texture on the facing page
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Modifying a Pencil Texture

You can modify and animate a pencil texture's position using the Colour-Override module and a Peg module.
This lets you create a shaky line style which is a very popular design style. The main issue with this style is that it
works well in traditional and tradigital animation, when the artist draws the line differently on each drawing, but
it does not work in cut-out animation where the same drawing is used for the entire animation. The same issue
happens when the same drawing is held for more than a few frames. The line moves during the animation, but
stops moving during the drawing hold, which looks bad.
With the Colour-Override module, you can animate the position of the pencil line texture independently from the
drawing exposure. Even if a drawing's exposure is held over several frames, the line will move.
To modify the pencil line texture:
1. From the Module Library view, drag a Colour-Override module and drop it in the Network view.
2. From the Module Library view, drag a Peg module and drop it in the Network view.

3. In the Network view, connect the Colour-Override module under the drawing module you want to
animate the line for. Note that for a cut-out puppet, you should connect the Colour-Override under the
final Composite, set as Pass-Through.
4. Connect the Peg module in the Colour-Override's middle port. The green port will take the
transformation of the Peg to modify the pencil texture's position.
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5. Click the Colour-Override's yellow button to open the editor.
6. In the Colour-Override window, in the Palettes section, select the penstyle_opacity palette.

7. In the Colours section, select the pencil texture you used to draw your lines and drag it to the Colour
Overrides section.

8. Once the swatch appears in the Colour-Override section, select it and click the
Select Override Mode button to right-click on the New RGBA word and select one of the following:

‣

Change Pencil Texture Transformation: Overrides the initial pencil texture's transformation (matrix)
established when you drew the line or modified with the Edit Gradient and Texture
tool. This
transformation override will be done by modifying the Peg's position.

‣

Modulate Pencil Texture Matrix: Combines the initial pencil texture's transformation (matrix) that
was established when you drew the line or modified with the Edit Gradient and Texture
tool with
the new position transformation you will create when modifying the Peg's position.

9. In the Network view, select the Peg module.
10. In the Advanced Animation toolbar, select the Translate
11. In the Camera view bottom toolbar, select the Render

, Rotate

or Scale

tool.

mode.

12. In the Camera view, move the Peg's position. As you move it, you will see the pencil texture getting
modified. You can animate the position by adding position keyframes in the Timeline view. You can use
the Random Fill function to quickly create a random shake.
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Related Topics
•

Modifying a Texture Fill on a Pencil Line on page 1276

Colour-Scale

The Colour-Scale effect offsets an images colours. This effect is useful in creating ambient transitions, such as
from daytime to nighttime.
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Use the Colour-Scale editor to set the colour scale effect by entering a value in the scale fields.

The actual colour values of the image are not changed; instead, the channels are multiplied by a selected
amount. For example:
•

If you enter a value of 1, the colour values do not change.

•

If you enter a value greater than 1, you increase the colour channel value closer to 255 (or white).

•

If you enter a value less than 1, you decrease the colour channel value closer to zero (0 or black).

You can set the colour scale value by entering a value in the field. You can also change the values of the colour
scale effect over time by attaching it to a Bezier or Ease function curve
and adding keyframes.

Related Topics
•

Using Effects on page 1218

Composite-Generic
During the composition of images, colour and alpha values of an input image are combined with the image
underneath to produce the output image.
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Effects modules, like Tone and Highlight, can control the colour and alpha composite operations for you. A
Composite module was created, in which the colour and alpha composite operation are preset to the standard,
and more frequently used, composite operations.
You may, however, still want to control the colour and alpha composite operation between two images using
the Composite-Generic Module which combines two images into one output image. The image linked to the left
port of the module is layered on top of the image in the right port based on the selected colour and alpha
composite operation.

Use the Composite-Generic editor to control the calculation of colour and alpha values during the composition
process.

The following abbreviations are used in the descriptions of composite operations:
•

ORGB: RGB values of the Output Image
The Output Image is the resulting image from a composite operation. In the formulas for the composite
operations, this image is also processed through a composite operation, representing the bottom layer
in the composited image.

•

LRGB: RGB values of the Left Image

•

RRGB: RGB values of the Right Image

•

LA: Alpha of the Left Image

•

RA: Alpha of the Right Image

•

OA: Alpha of the Output Image

Composite-Generic Effect Properties
Parameter

Description

Colour Operation

The colour values of the output image are determined based on the alpha and
colour values of the left and right image.
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Both the Blending module and Composite-Generic module have regular
blending modes and legacy blending modes. The regular blending modes will
take the source images and unmultiply them before blending the two inputs
together. The images will be remultiplied when being output from the module.
The legacy blending modes use the pre-multipled source images as is in order
to apply the effect. Unmultiplying the images before processing them will give
a final result closer to what can be found in software such as Adobe
Photoshop.
Right: The colour values in the output image are derived from the image in the
right port. Colour values in the left port are ignored.
Left: The colour values in the output image are derived from the image in the
left port. Colour values in the right port are ignored.
Apply With Alpha: ORGB=[RRGB*(1-LA)]+LRGB. This is a standard
composite operation called "alpha blending." During this operation, colour
values of the left and right images are combined based on the alpha value of
the left image. Where the left image is completely opaque (LA=1), the ORGB
will be replaced completely with LRGB. Where the left image is completely
transparent (LA=0), the ORGB is unaffected. Where the left image is partially
transparent, you get a blend of the RRGB and the LRGB, where the values are
added together and clipped to 255. The LA is the opacity of the left image.
This operation (1-LA) calculates the amount of opacity to retain in the output
image. The operation [RRGB*(1-LA)] removes as much of the output image as
you are about to add from the left image. Remember that LRGB has been premultiplied by the LA, so the equation is really ORGB=[RRGB*(1-LA)]+
(LRGB*LA), which is simply the weighted average of L and R, with LA supplying
the weight.
Apply Tone Highlight: ORGB=RRGB+(LRGB*RA). This operation restricts the
output of the tone to the region of the matte (RA), and uses the transparency
and colour value of the input image to determine the colour values of the
output. This is used to lighten or darken the output image. Darkening occurs
when RRGB contains negative values.
Apply Add (Apply Add Legacy): ORGB=RRGB+LRGB. This operation uses
the transparency and colour value of the left image to determine the output
values. Effects such as shadows and glows are calculated in this manner. Unlike
the Apply Tone Highlight operation, the result is not clipped to the matte (RA)
of the output image.
Apply Matte For Overlay: ORGB=RRGB*(1-LA).This operation prepares the
output image using the overlay's matte; the matte's RGB values are ignored.
This operation prepares the output image to receive the colour portion of the
overlay. It is typically used when an overlay and its matte are stored in separate
images.
Apply Overlay Into Matte: ORGB=RRGB+(LRGB*RA). This operation maps
an overlay into an area prepared by a matte. It is typically used when an overlay
and its matte are stored in separate images, and Apply Matte For Overlay has
been used to prepare the output image to receive the RGB portion of the
overlay.
Apply Transparency: ORGB=RRGB*(1-LA). This operation is used for a cutter
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matte to prepare the output image to receive the colour values of another
image. It has the effect of increasing the transparency of ORGB (but not OA),
based on the LA. This function is the equivalent to Apply Matte for Overlay. It
is almost always used with Apply Transparency Matte, an Alpha Composite
Operation.
Apply Multiplicative Tone: ORGB=RRGB*(LRGB+1-LA). This operation
multiplies the left and right images (see the Multiply colours selection), to be
combined with the right image colour, creating a darker output colour. This
effect created by this operation is identical to the Multiply Colour Blending
effect in Photoshop.
Multiply Colours: ORGB=RRGB*LRGB. This operation multiplies the left and
right image colours. Multiplying colours filters the colour values of the right
image from the output image. For instance, to make the left image less blue,
you can add a right image to this module with a blue colour value and select
this option.
Divide Colours (Divide Colours Legacy): ORGB=RRGB/LRGB. This operation
divides the right image colour values by the left colour values. The left image
colour values are inverted, creating a negative image (1/LRGB). The negative's
colour values are then multiplied by the right image colour values.
Lighten (Lighten Legacy): This operation looks at the colour information
coming from both the images in the left and right ports and selects the base or
blend colour - whichever is lighter - as the result colour. Pixels darker than the
blend colour are replaced, and pixels lighter than the blend colour do not
change.
Softlight (Softlight Legacy): This operation darkens or lightens the colours in
a soft and diffuse way, depending on the blend colour (image in left port). If the
blend colour is lighter than 50% grey, the image is lightened. If the blend colour
is darker than 50% grey, the image is darkened. Painting with pure black or
white produces a distinctly darker or lighter area, but does not result in pure
black or white.
Hardlight (Hardlight Legacy): This operation multiplies or screens the colours
of the image in the left port with those of the image in the right port,
depending on the blend colour. If the blend colour (left port image) is lighter
than 50% grey, the image is lightened, as if it were screened. This is useful for
adding highlights to an image. If the blend colour is darker than 50% grey, the
image is darkened, as if it were multiplied. This is useful for adding shadows to
an image. Painting with pure black or white results in pure black or white. Play
with the Opacity value to create a subtler look.
Overlay (Overlay Legacy): This operation multiplies or screens the colours
from the image connected to the left port, with those on the right, depending
on the base colour. Colours from the left-port element overlay the colours of
the drawing elements connected to the right, while preserving the highlights
and shadows of the base colour. The base colour is not replaced, but mixed
with the blend colour to reflect the lightness or darkness of the original colour.
Opacity

The level of transparency.

Alpha Operation

Right: The transparency of the output image is derived from the alpha values
of the image in the right port. The values in the left port are ignored.
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Left: The transparency of the output image is derived from the alpha values of
the image in the left port. The values in the right port are ignored.
Apply: OA=[RA*(1-LA)]+LA. This operation computes the output alpha of the
output image based on the alpha values of the left and right images. This is the
standard method of combining alpha channels. Notice its similarity to the
Apply With Alpha colour Composite Operation.
Add: OA=RA+LA. This operation adds the alpha values of the two images to
produce the alpha value of the output image.
Subtract: OA=RA-LA. This operation subtracts the alpha values of the input
image from the alpha values of the output image. It is useful in situations where
two tone levels have been drawn with overlap, but a double-darkening in the
overlap is not wanted. This operation will reduce the opacity of overlapping
regions.
Apply Transparent Matte: OA=RA*(1-LA). This operation is used to increase
the transparency of the output alpha in the final composited image.
Black: OA=0. Sets the matte of the entire output image to black, so that it is
transparent.
White: OA=1. Sets the matte of the entire output image to white, so that it is
opaque.
Leftmost: Indicates that the Z value for the output image will be taken from
the module in the left port.
Rightmost: Indicates that the Z value for the output image will be taken from
the module in the right port.
Output Z

Backmost: Indicates that the Z value for the output image will be taken from
the image that is the farthest back in the scene.
Frontmost: Indicates that the Z value for the output image will be taken from
the image that is closest to the front of the scene.
Portnumber: Indicates that the Z value for the output image will be taken from
the module in the selected port. Enter the appropriate port in the Port for
Output Z field.

Related Topics
•

Using Effects on page 1218
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Contrast

Use the Contrast effect to increase or decrease the level of contrast in an image. This is done by changing the
contrast in the dark and bright pixels and setting the transition point between dark and bright.

Contrast Effect Properties
Parameter

Description
The value that separates dark from bright colours. The midpoint is a value
between 0 and 1 that represents the percentage of the 0 to 255 RGB channel
range.

Mid Point

Pixels with colour values lower than the midpoint: These are considered
dark pixels.
Pixels with colour values higher than the midpoint: These are considered
bright pixels.

Dark Pixel Adjustment and
Bright Pixel Adjustment

The amount of contrast to be applied to pixels that fall on either side of the
Mid Point value.
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A value equal to 1: No change
A value less than 1: The module makes the pixel colours brighter
A value greater than 1: The module makes the pixel colours darker
You can enter static values in the dialog box fields or you can attach these values to function curves to change
over time.

Related Topics
•

Using Effects on page 1218

Cutter

The Cuttercuts out a portion of an image using a matte drawing. You can use the Cutter to allow a character to
disappear behind a background element or to cut a virtual hole into the layer itself. The Cutter requires a matte
input.
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Use the Cutter editor to invert the effect of the matte on an image. Instead of the object being hidden by the
mask, it will only be visible where it intersects with the matte shape area.

Related Topics
•

Using Effects on page 1218

Dither

Dithering is the process of approximating a higher number of colours in a low bit-depth colour system. Use the
Dither effect to give the appearance of greater colour variability in 8-bit per channel colour images.

The Dither effect is useful in the case of a gradient that varies between 100 and 105 in the blue channel, for
example. Since the difference in the colour values is not great, banding might appear in the image. In this case,
use the Dither module to give the impression of greater values of blue, decreasing the unwanted banding effect.
The results of the dither operation may be imperceptible.
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Dither Effect Properties
Parameter

Description

Magnitude

A magnitude of 1 performs a normal dithering operation, using all bands of colour. A magnitude greater than 1 introduces a bias towards brighter colours. A
magnitude of less than 1 creates a faster transition between bands of colour,
lessening the bias towards brighter colours.

Correlate

When selected, the three colour channels (RGB) are changed simultaneously,
for better colour accuracy. When this option is not selected, the three channels
are dithered separately, resulting in smoother transitions.

Random

The standard algorithm for the dithering operation.

Related Topics
•

Using Effects on page 1218

External

Use the External module to process images through external programs and input the resulting images back into
the network. Note that not all programs work with the External module.
Using the External module avoids you having to export your animation to another software to do some
processing over it and then bring it back to Harmony. This way, you can modify your scene and animation as
much as you want and still use the effects or render process from a third-party software.
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The External module writes input files to temporary files on the system. It then calls the external program, which
will process the input images. If two images are input into the module, the program must composite them
together to produce one output image. Finally, the file produced by the external program is read back into the
network.
The command is sent to the external program in the following format:
program_name file_1 file_2 output_file numerical_param extension
Use the External editor to control the program that is launched by the module, the files that it reads, and the file
that it outputs into the network.

In this example, the ImageMagick 6.3 software was used without a matte connection.
Use the External editor to write down the parameters matching the chosen external program.
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•

External Program: The name of the program launched by the External module. This field can include a full
or relative path to the executable file. If no path is entered, the user's path is searched to locate the
program.
Enter the command directly into this field.
For example:
mogrify -spread $NUM $IN1
Where:
•

mogrify: Is the name of the program,

•

spread: Is the option to be applied,

•

and $NUM and $IN1: Are the numerical parameter and first input file variable declared in the External
module.

•

Program First Input File ($IN1): The name and location of the temporary file that Harmony will write to
the file system for the external program to read. It must not include the dot or the extension; the External
module will add these based on the Extension field.

•

Program Second Input File ($IN2): When processing two files through this module (such as an image
and a matte), this is the name and location of the second temporary file that Harmony writes to the file
system for the external program to read. It must not include the dot or the extension; the External
module will add these based on the Extension field.

•

Program Output File ($OUT): The name and location of the temporary file that the external program will
write to the file system so that Harmony can read it back into the network.

•

Extension ($EXT): The file type that will be processed by the external program.

•

Numerical Parameter ($NUM): A value passed to the external program as a file processing option. It can
be attached to a function curve to change over time.
The program files are temporary files that are overwritten at each frame as the module is executed. They
are only meant to temporarily store the image that is being processed at each frame.

•

Generate Unique FileNames: If this option is enabled, the temporary output file will have a unique
identification number added to its name to avoid any file override if another scene or External script is
rendered at the same time. It could be possible to have an override when two scenes using the External
modules are rendered in batch processing.
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Related Topics
•

Using Effects on page 1218

Focus

Use the Focus effect to set up depth-of-field effects for your scene. The Focus module is used to determine how
much blur will be applied to images, based on their distance from the focal point.
The focal point can be the zero value of your scene or you can link the Focus module to another module, such as a
drawing or peg layer, to retrieve the focal point from the module's Z-axis position.

Use the Focus editor to determine how the focus will change as objects move farther from the focal point.

Focus Effect Properties
Parameter

Description
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Mirror

Select this option to also blur images in front of the focal point.

Mirror Front/Back Ratio

When the Mirror option is selected, this ratio is applied to the calculation of
the blur on images in front of the focal point. The default ratio of 1:2 produces
realistic results. Experiment with different values to create customized effects.

Radius

Controls the amount of blur applied to an element based on its distance from
the focal point. Click on the Edit Curve button to change these values by adjusting the function curve.

Quality

Controls the quality of the blur. A higher quality will achieve better results but
will be slower to render.

In the Side view window, you can see how the blur values change based on their distance from the focal point.
Select the Focus module in the Network view, then right-click on the Side view window and select Control from
the pop-up menu.

If you edited the function curve and adjusted the velocity, you can also adjust the Bezier handles in the Side view.

Related Topics
•

Using Effects on page 1218
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Focus Multiplier

The Focus Multiplier effect works with the Focus effect. This module applies a blur to the selected layer, based
on the blur radius in the Focus module.
Use the Focus Multiplier module when you want to apply the focus to selected elements or when you need to
apply the focus before doing more effects in a composite operation.

You must disable the Apply Focus option in the Composite module in order to apply the focus effect to the
selected module only. If you do not disable that option, the focus effect will be calculated twice on the selected
module.
Use the Focus Multiplier editor to multiply the Focus Radius by a selected value. You can enter a static value in
the Multiplier field or attach it to a function curve.
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Related Topics
•

Using Effects on page 1218

Glow

The Glow effect adds a bright soft-edged light or diffuse light region around an image. The Glow effect is useful
in creating a shining rim around objects such as the sun or stars.

Use the Glow editor to control the direction of the blur that creates the glow, as well as its colour.
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•

Truck Factor: Activated by default, this option readjusts the blur when the elements undergo a change of
depth or scale. When this option is disabled, the effect values remain unchanged regardless of any depth
or scale changes. It is recommended that this option be disabled when multiple drawings are composited
and attached to this effect.

•

Blur Type (Directional or Radial):
•

If Directional is selected, the software will blur the matte in the direction you select. For example, if a
character is walking east, the blur may fall to the west.

•

If Radial is selected, the software will blur the edges of the matte evenly around points that make up
its edge.

•

Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur
radius is affected by the drawing scale and camera position.

•

Directional Angle: If you select a Blur Directional Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.

•

•

0: blurs the image to the west.

•

90: blurs the image to the south.

•

180: blurs the image to the east.

•

270: blurs the image to the north.

Directional Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.
•

A fall-off rate of zero causes the blur to fade out slowly, distributing the blur evenly from the edge of
the character to the farthest edge of the blur.

•

A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.

•

Invert Matte: Activate this option to invert the matte used to create the glow. Your matte will become a
black silhouette while the glow will fill the background space.

•

Use Source Colour: Select this option to use the colours painted in the matte for the glow effect. If you
deselect this option, select a colour and alpha values in the Colour section.

•

Multiplicative: Select this option to create a more diffused glow.

•

Colour: Where you can choose the colour and alpha values for the glow effect.
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If this effect is connected below a Composite module set to Pass-Through, the effect will be applied
to each element connected in the Composite individually. If some of these elements are
overlapping, the effect will also overlap.

Related Topics
•

Using Effects on page 1218

Glue

Use the Glue effect to repair the cracks that appear between joints during animation.

The Glue module has three ports:
•

Left Port (Matte): Receives the matte.

•

Middle Port (Port A): Receives the element that will not be used to fill the joint.

•

Right Port (Port B): Receives the element that will be used to fill the joint.
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For most effects with the Glue module, the default options are sufficient. However, you can modify these options
using the Glue editor.

Glue Effect Properties
Parameter

Description

Bias

Indicates the tendency to favour the static or moving element. Set to 0, it
favours element A; set to 1 it favours element B; set to 0.5 it is in between A
and B.

Tension

Indicates how tight the joint will be. Set to 1, the tension has no effect; set less
than 1, the tension decreases; set greater than 1, the tension increases.

Type

From this menu, select the type of joint to create. You can choose from among
Curve (default), Line and Corner.

Use Z for Composition Order

You can use this option to choose the drawing with the higher front-back value
to create the joint.

A Over B

Indicates which image is rendered on top in the final image. By default, A is
rendered on top of B, which indicates that the image in the middle port (A) is
rendered on top of the image in the right port (B).

Spread A

By default, the image in port B is spread to fill the joint. You can use this option
to choose the image in the A port to create the joint. If you select this option,
the drawing module must receive position information from the "B" element.
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Thus, you must connect the Drawing module of the "B" element to the Drawing module of the matte.
Invert Matte

Activate this option to invert the matte used to fill the joint. If you want to use
the "B" element as the matte, you must select this element.

Related Topics
•

Using Effects on page 1218

Gradient

The Gradient effect lets you create a transition of colour or alpha values between two areas of colours. You can
create a linear or radial gradient. Use two points to indicate where those two coloured areas are. You can then
move these points to create the transition.

The Gradient module covers the entire camera frame and beyond. You do not need to scale it up or down. It will
automatically cover an infinite zone. You simply need to connect it behind your scene's elements. You can
connect it in front of some elements you want to cover. By default, the Gradient has a Z ordering value of 0.
When you select the Gradient module, the Camera view displays yellow triangles to indicate that it`s selected.
Use the Gradient editor to control the values of the gradient and the position of its output.
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Gradient Effect Properties
Parameter

Description

Gradient Type

Lets you select a linear or radial gradient.

Point 1, Point 1

These sections control the values of the first point (point 0) and the second
point (point 1) in the gradient.

Red, Green, Blue, Alpha

The colour and alpha values of the corresponding point. You can also click the
colour swatch to open the Colour Picker window and select a new colour.
These colours can be animated over time if the value parameter is hooked to a
function curve. Default values are 0,0,0 and 255, 255, 255.

(x) Axis

Sets the X coordinate for the corresponding point.

(z) Axis

Sets the Y coordinate for the corresponding point.

Offset Z

Enter the front-back position of the Gradient layer in 3D space. You can verify
this value in the Top view.

Depth

Determines the composition order when the Z value of two elements is the
same.
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Controlling the Gradient in the Camera View
If you want to control the gradient's orientation and points position in the Camera view, you can use the Control
command to display the points and move them.
To control the gradient in the Camera view:
1. In the Tools toolbar, select the Transform tool.
2. In the Network view, select the Gradient module.
3. Select View > Show > Control.
4. In the Camera view, click the Gradient's points and move them.

Related Topics
•

Using Effects on page 1218

Grain

Use the Grain effect to add a film grain to an image; the film grain looks like video noise.
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The Grain module has two input ports.
•

On the left port, attach the element that will act as the matte defining the grain area.

•

On the right port, attach the element on which you want to apply the grain effect.

Use the Grain editor to adjust the amount of grain to add to an image; you can also use it to adjust the
sharpness or softness of the grain.

•

Noise: The amount of grain to add to the image based on the percentage of pixels to alter. The larger
the value, the courser the grain. The smaller the value is to 0 (zero), the finer the grain.

•

Smooth: The amount of blending to apply to the grain effect, based on the blur radius, to make the effect
appear less pixelated. The larger the value, the greater the smoothing.

•

Random At Each Frame: Computes the colour shift in the grain using a different value at each composite.
This means that your images will look different each time you render them. Deselect this option and select
a Seed Value to ensure the same result every time you composite the grain effect.

•

Seed Value: This value corresponds to a unique pattern in the grain. If you want to retain this pattern in
other frames, you can reuse this value.

Related Topics
•

Using Effects on page 1218
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Greyscale

Use the Greyscale effect to convert a colour image to greyscale. This example demonstrates what happens when
you set the greyscale to 100% using the Greyscale module. The Contrast module can also be used to adjust the
darkness and lightness of the pixels in your element.

Use the Greyscale editor to enter the percentage of black and white to apply to the image. You can enter a static
value in the Percentage field or attach the value to a function curve to change over time.
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•

Matte Output: When this option is activated, the colour values do not change. However, alpha values are
read from the colours which you can see in the Camera view Matte View mode.

How to Use the Matte Output Option
You can see in this section a concrete example on how to use the Matte Output option of the Greyscale module.
We created a frosted window using a snowflake image over a blue rectangle and a colourful background.
Here are the three drawings used for the example:

When the snowflake image is connected into the Greyscale module, it turns into a greyscale image. There is no
transparency visible in the Camera view Matte View mode.

When the Matte Output option is enabled, the snowflake image colours are displayed as normal, but when the
Matte View mode of the Camera view is enabled, you can see the transparency levels generated from the colour
values.

When you connect the Snowflake images into a Cutter effect's Matte port along with the Window images, the
window will be semi-transparent, matching the alpha (transparency) channel generated by the Greyscale module.
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Related Topics
•

Using Effects on page 1218

Grid / Field Chart

The Grid module displays a grid, in field chart unit, which allows you to position elements in the Camera view
windows. The Grid is also referred to as the Field Chart.
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Use the Grid editor to control the quality and alignment of the field chart that appear in the Camera view.

Size

This parameter adjusts the amount of units in the grid (field chart). The grid size will always be a 4:3 ration, as
per traditional animation standards, but will adjust the camera frame width. You can change the grid to adjust to
the camera frame by disabling the Fit Vertical option.
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Display Text

Disable this option is you only want to see the grid but not the numbers. Enable this option to see the number
gradation.

Red/Green/Blue/Alpha

The colour and alpha values of the corresponding point. You can also click on the colour swatch to open the
Colour Picker window and select a grid colour. You can click on the second colour swatch to open the Colour
Picker window and select a background colour.

Fill

When selected, the grid's background becomes opaque. Nothing behind will be shown. You can also click on the
second colour swatch to open the Colour Picker window and select a background colour.
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Fit Vertical

The grid size will adjust the camera frame. You can change the grid to either adjust to the camera width or height
by disabling the Fit Vertical option.

Aspect Ratio

The grid size default format is 4:3 ratio, as per traditional animation standards, but will adjust the camera frame
width. You can change the grid ratio by entering a new ratio in the Aspect Ratio field. You can find your scene
ratio under Scene > Scene Settings.
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Related Topics
•

Using Effects on page 1218

Highlight

Use the Highlight effect to turn a drawing's area lighter to simulate a light source. To produce the highlight
effect, you must draw a shape to control where the highlight will appear on the original drawing.
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The Highlight effect uses a matte to determine the shape and position of the highlight on another element and
can blur the edges to create a softer effect. Use the Highlight editor to control the type and amount of blur, as
well as the colour of the highlight effect.

•

Truck Factor: Activated by default, this option readjusts the blur when the element undergoes a change
of depth or scale. When this option is disabled, the effect's values remain unchanged regardless of depth
or scale changes. It is recommended that this option be disabled when multiple drawings are composited
and attached this effect.

•

Blur Type (Directional or Radial):

•

•

If Directional is selected, Harmony will blur the matte in the direction you select.

•

If Radial is selected, Harmony will blur the edges of the matte evenly around points that make up the
edge of it.

Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur
radius is affected by the drawing scale and camera position.
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•

•

Directional Angle: If you select a Blur Directional Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.
•

0: blurs the image to the west.

•

90: blurs the image to the south.

•

180: blurs the image to the east.

•

270: blurs the image to the north.

Directional Fall-off Rate: The distance where the directional blur fades from the edge of the image. Select
a value between 0 and 1.
•

A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.

•

A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.

•

Invert Matte: Activate this option to invert the matte used to create the highlight.

•

Use Matte Colour: Select this option to use the colours in the matte for the highlight effect. If you
deselect it, use the Colour section to select colour and alpha values.

•

Multiplicative: Select this option to create a more diffused highlight.

•

Red/Green/Blue/Alpha: In the RGBA fields, enter the value that you want added to or subtracted from
the colour channels in the drawings. Alternatively, you can attach these values to function columns to
animate them over time.

Related Topics
•

Using Effects on page 1218

1312

Toon Boom Harmony 10.3 Stage User Guide

Hue-Saturation

The Hue-Saturation effect lets you adjust the hue, saturation and lightness values individually or by using the HLS
picker or Hue Range picker. You can achieve effects over the entire image, such as a sepia tone. Changes you
make to the values are additive to the final image.
For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/videotutorials/chapter/adam-phillips-harmony-effects.

1313

Chapter 19: Effects Hue-Saturation

Hue-Saturation Effect Properties
Parameter

Description
Allows you to remap all the colours at the same time using the Hue, Saturation
and Lightness fields.

Master
Note: When using the Master parameters, the Colorize parameters are
disabled.
Opens the Hue Range Picker which displays the original colour spectrum of the
image in the top bar and the new colour spectrum in the bottom bar. The
Saturation and Lightness in the upper bar can range from -100 to 100, allowing
you to decrease the original values.

Lets you set the hue, saturation, and lightness by entering values or by using
the HSL Picker. In the Colorize mode, Lightness can range from -100 to 100.

Colourize
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Select a colour by moving the colour picker.
Note: When using the Colourize parameters, the Master parameters and
other colour tabs are disabled.
Hue

The colour or hue of the image.

Saturation

The amount of colour in the image.

Lightness

The brightness of the image.

Colour Swatch

Opens the HLS Picker where you can specify the colour.

Tabs

Reds, Greens, Blues, Cyans, Magentas, Yellows
Opens the Hue Range Picker. The top bar displays the colour spectrum with
arrows for defining the colour range more precisely. The triangles indicate the
falloff of the effect, which you can also adjust.

Specify the hue as an angle from 0° to 360° that corresponds to a location on
the color wheel. Specify saturation and lightness (B) as percentages (0 to 100).
Reset Range

Resets only the range of hue values over which the effect is applied, i.e. the
arrows and triangles. The HSL adjustments are maintained.
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Image Switch

The Image Switch effect lets you use multiple effects, such as Colour Override, and choose which port will be sent
to rendering if you want to apply different variations of an effect that cannot be changed over time. You then
create multiple separate versions of the effect, connect them all to the Image Switch, and then if you want to
change to a different version of the effect at different points in your scene, you would add a curve and animate
the port number. Image Switch simply lets you change over time which port is being rendered.
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Image Switch Effect Properties
Parameter

Port Index

Description
Switches from one image to another. There is no gradual animation from one
colour to another as you are only changing (over time) which port will be
rendered. Use whole values.
Click the Function

button to open the Function editor to animate a

parameter over time—see Function Types on page 998.

Layer Selector

Use the Layer Selector effect to isolate and display one or several drawing layers:
•

Overlay

•

Line Art
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•

Colour Art

•

Underlay

Use the Layer Selector editor to select the desired layers.

•

Antialiasing Quality: Smoothness setting applied to the selected layers. Choose from Low (no
antialiasing), Medium Low, Medium and High (extensive antialiasing). The higher the quality of the chosen
setting, the greater the amount of antialiasing that is applied. Higher quality images require more time to
render and more memory from your system.

•

Antialiasing Exponent: Controls the amount of area around the selected layers edges that is used in the
antialiasing process. A higher value uses less area, resulting in sharper edges, while a lower value uses
more area, resulting in softer edges. If the Antialiasing Quality value is set to Low (no antialiasing), this
value is ignored.

Related Topics
•

Using Effects on page 1218
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Lens Flare

The Lens Flare effect simulates the refraction caused by shining a bright light into a camera lens. The shape of the
lens flare can be circular or hexagonal.
For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/videotutorials/chapter/adam-phillips-harmony-effects.

Here is how a typical lens flare can be set up:
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Lens Flare Effect Properties
Parameter

Description

Flares
Custom: Lets you use your own custom art or drawing.
Flare Type

Type 1: Circular lens flare.
Type 2: Hexagonal lens flare.
Lets you apply a normal or screen blending mode to the image.

Blend Mode: Normal/Screen

Normal: When selected, this operation will not create any blending mode
effect.
Screen: When deselected, this operation multiplies the inverted colour of the
blending element with the image. This lightens the colour of the overlapping
area. Screen is the default blending mode.
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Position X, Y, Z

Lets you precisely orient the flare in the x, y, and z axes.

Brightness
Intensity

The strength of the lens flare.

Red

Red values of the image.

Green

Green values of the image.

Blue

Blue values of the image.

Alpha

Alpha values of the image.

Colour Swatch

Opens the Colour Picker where you can specify the colour of the main flare.

Flare 1–10

Lets you create custom lens flares by associating them with specific drawings.
You can create up to 10 different flares.
Drawing: Lets you specify a drawing to use for the flare.
Position: The position of the flare.
Size: The size of the flare.
Blur Intensity: The strength of the flare.

Line Art

Use the Line Art effect to read only the Line Art in an element. Place a Line Art module after a drawing module in
the Network view to display only the module's Line Art output. The Line Art module can only be connected after
a vector Drawing layer or a vector type Composite module. Any bitmap information will not be processed.
This effect will only work if the user drew or painted something into the Line Art layer of the drawing.
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Use the Line Art editor to control how the Line Art is rendered by the module.

•

Antialiasing Quality: Smoothness setting applied to Line Art. Choose from Low (no antialiasing), Medium
Low, Medium and High (extensive antialiasing). The higher the quality of the chosen setting, the greater
the amount of antialiasing that is applied. Higher quality images require more time to render and more
memory from your system.

•

Antialiasing Exponent: Controls the amount of area around the Line Art edges that is used in the
antialiasing process. A higher value uses less area, resulting in sharper edges, while a lower value uses
more area, resulting in softer edges. If the Antialiasing Quality value is set to Low (no antialiasing), this
value is ignored.

Related Topics
•

Using Effects on page 1218
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Matte-Blur

Use the Matte-Blur effect to blur a matte or change its colour. Here is an example of a network with the result of
a Matte-Blur effect.

Use the Matte-Blur editor to control the output of the module.
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•

Truck Factor: Activated by default, this option readjusts the blur when the element undergoes a change
of depth or scale. When this option is disabled, the module's values remain unchanged regardless of
depth or scale changes. It is recommended that this option be disabled when multiple drawings are
composited and attached this module.

•

Blur Type (Directional or Radial): If Directional is selected, Harmony will blur the matte in the direction
you select. If Radial is selected, Harmony will blur the edges of the matte evenly around points that make
up the edge of the matte.

•

Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur
radius is affected by the drawing scale and camera position.

•

Directional Angle: If you select a Directional-Blur Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.

•

•

0: blurs the image to the west.

•

90: blurs the image to the south.

•

180: blurs the image to the east.

•

270: blurs the image to the north.

Directional Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.
•

A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.

•

A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.

•

Invert Matte: Activate this option to invert the matte used to create the blur.

•

Red/Green/Blue/Alpha: In the RGBA fields, you can enter the value you want added to or subtracted
from the colour channels in the drawings. Alternatively, you can attach these values to function columns.

If you select the Pass Through option in the Layer Properties of a Composite where this effect is
connected, the effect will be multiplied in areas where the drawing elements that the effect is acting
on overlap.
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Related Topics
•

Using Effects on page 1218

Matte-Resize

Use the Matte-Resize effect to evenly expand a matte outward in all directions. The Matt-Resize module
increases the size of a matte from its centre. Here is an example of a network with the result of a Matte-Resize
effect.

If you use the Matte-Resize module to create a pulsating glow you can enlarge the region without softening the
edges. Using the Blur-Radial effect, the effect may be softer than you intend. This module produces a limited
antialiased matte, which can have slightly jagged edges. You could use this module in combination with other
modules, such as:
•

Tone

•

Highlight

•

Glow

•

Shadow
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•

Matte-Blur

In the Layer Properties, you can enter a static value for the Radius of the resize operation. You can also attach
the Radius value to a function column to change the value over time.

Related Topics
•

Using Effects on page 1218

Motion-Blur

The Motion-Blur effect is used to create a faded trail behind objects animated on a motion path. You cannot
create a Motion-Blur on a hand-drawn animation. The layer must be moving along a trajectory (motion path) in
order to work properly.

1326

Toon Boom Harmony 10.3 Stage User Guide

The Motion- Blur effect automatically creates a matte for the drawing layer attached to it, so it is not necessary
to connect any matte into the Mask layer.
Use the Motion-Blur editor to modify the motion blur, crowd simulation or particle system effect.

•

Number of Frames in Trail: Number of frames before the current frame that will be used in the trail.

•

Number of Samples: Number of copies of each drawing used in the trail. The higher the number, the
more continuous the trail appears.

•

Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value between 0 and
1.
•

A fall-off rate of 0 causes the trail to fade out slowly, distributing the colour evenly from the edge of
the character to the farthest edge of the trail.

•

A fall-off rate of 1 causes the trail to fade out quickly so that the trail is more opaque closer to the
edge of the image and transparent at the end of the trail.

•

Intensity: Select a value to define the opacity of the trail between 0 and 10. A value of 10 will make the
trail very dark and almost opaque, where as a value of 0 will make the trail quite pale and ghostly
transparent.

•

Use Mirror on Edges: When enabled this option appear when the image is close to the edge of the
camera frame. It forces the software to use a mirror of the image to calculate the blur so that it appears
on both sides of the drawing object. Without this option once your drawing reaches the edge of the
Camera frame, it gets cropped so does the trail.
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Related Topics
•

Using Effects on page 1218

Multi-Port-In
A Multi-Port-In module is added by default in a new Group module. Use it to add one or more input ports to the
Group module so that you can process an image through the modules in the Group module.

When you plug an element to a Multi-Port-In module, an input port appears at the top of the Group module. You
can add additional ports to the modules as needed.
Pass your cursor over the Group module input port to see the name of the Port Image In module that it connects
to. You will notice that the Group module in these examples has no output port. It requires a Multi-Port-Out
module to output data from its network.
A Multi-Port-In is automatically added when you create a group.
Use the Multi-Port-In editor to rename the module.

Related Topics
•

Using Effects on page 1218

Multi-Port-Out
A Multi-Port-Out module is added in a new Group module by default. Use it to add output ports to the Group
module so that you can output the result of the group operation to the rest of the network. After you plug an
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element to a Multi-Port-Out module, an output port appears on the bottom of your Group module. You can add
additional output ports as needed.

A Multi-Port-Out is automatically added when you create a group.
Use the Multi-Port-Out editor to rename the module in the network.

Related Topics
•

Using Effects on page 1218

Negate
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Use the Negate effect to invert the colour and/or alpha values in the Colour Art and Line Art of an image. The
Negate module subtracts the original value of each channel (RGB or A) from the maximum value of that channel
(255 for 8-bit channels) to produce the negative image.

Use the Negate editor to select the colour and/or alpha values to invert.

•

Negate Colour: Inverts the values of the colour channels.

•

Negate Alpha: Inverts the transparency value (alpha channel).

•

Negate Colour Clamp to Alpha: Limits the negated area to the alpha channel.

Related Topics
•

Using Effects on page 1218

Note
The Note module allows you to record any textual information that is relevant to your project. Use its editor to
enter comments, suggestions or reminders. Note modules can be added anywhere in the network, including in
groups.
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Use the Note editor to add or update relevant notes with any textual information.

Related Topics
•

Using Effects on page 1218

Overlay Layer
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Use the Overlay Layer effect to read only the Overlay layer in an element. Place a Overlay Layer module after a
drawing module in the Network view to display only the module's Overlay layer output. The Overlay Layer
module can only be connected after a vector drawing layer or a vector type Composite module. Any bitmap
information will not be processed.
This effect will only work if the user drew or painted something into the Overlay layer of the drawing.

Use the Overlay Layer editor to control how the Overlay layer is rendered by the module.

•

Antialiasing Quality: Smoothness setting applied to the Overlay layer. Choose from Low (no antialiasing),
Medium Low, Medium and High (extensive antialiasing). The higher the quality of the chosen setting, the
greater the amount of antialiasing that is applied. Higher quality images require more time to render and
more memory from your system.

•

Antialiasing Exponent: Controls the amount of area around the Overlay layer edges that is used in the
antialiasing process. A higher value uses less area, resulting in sharper edges, while a lower value uses
more area, resulting in softer edges. If the Antialiasing Quality value is set to Low (no antialiasing), this
value is ignored.

Related Topics
•

Using Effects on page 1218
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Pixelate

Use the Pixelate effect to apply a mosaic effect to an image (and its matte) based on the matte you supply.
Pixelation makes the image look like it is made up of square tiles.

There are two input ports on the Pixelate module:
•

The left port receives the matte

•

The right port receives the image

Use the Pixelate editor to control the amount (Factor) the image is pixelated. You can attach the Factor value to
a function curve to change the value over time.
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Related Topics
•

Using Effects on page 1218

Placeholder
Use the Placeholder module in a network when you are either unsure of which module you will put in its place or if
you want to lay out a custom network for future use.

Use the Placeholder editor to rename the module.

Related Topics
•

Using Effects on page 1218

Quadmap
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Use the Quadmap transformation layer to deform the shape of an element. For example, you can use it to create
a drop-shadow effect on an element.
You can edit the Quadmap visually in the Camera view.
To edit the Quadmap the Camera view:
1. In the Timeline view, click on the Add Layer

button and select Quadmap from the drop-down menu.

2. Connect the Quadmap layer to the drawing layer that you want to deform, or in the Network view, drag
in the Quadmap module from the Module Library and connect it above the drawing element module that
you want the effect to act on.

3. In the Tools toolbar, disable the Animate mode to change the value for the Quadmap over the entire
duration of the element.
4. In the Timeline view, click on the Quadmap layer to select it.
5. Select View > Show > Control or press [Shift] + [F11].
The quadmap handles appear around the element in the window. There is also a pivot point at the centre
of the quadmap frame that can be repositioned.
6. In the Camera View window, use the Transform tool to move the points on the quadmap. [Shift] + click to
select multiple points.

The value of each point on the quadmap can be changed gradually. To do this, use the Quadmap module Layer
Properties to attach the points to function curves.
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Only the X and Y values of each point in the quadmap can be changed.
•

2D Path: change the X and Y values simultaneously and control the velocity of the change.

•

Separate: change the X and Y values separately. Each of these can be attached to separate function
curves.

Related Topics
•

Using Effects on page 1218

Refract

Use the Refract effect to create effects such as ripples and heat haze. This effect is based on the refraction of
light, which occurs when a beam of light passes through media of different density, causing the light to refract or
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change angles. This effect makes objects appear distorted or offset from their actual positions. If you imagine an
object in a pool of water the part beneath the surface of the water appears offset from its true position.

To create a refraction effect, you need a matte with alpha values. This creates the effect of a volume passing over
an image, refracting the light that bounces off the contents below. For a ripple effect moving across an image,
you must move the matte with a Peg layer.
If your matte is only black and white, meaning that there is no gradients and only solid colours in your matte
drawing, you will need to connect a Blur Radial module after your matte Drawing module to soften the edges
and get nicer waves.
Use the Refract editor to control the effect.

•

Intensity: The amount of refraction to apply to the image.

•

Height: The amount of depth to add to the refraction effect. When coupled with the Intensity effect, this
value can create the effect of bending the objects below the refraction matte.

Attaching the Intensity and Height values to function curves changes their values over time.

Related Topics
•

Using Effects on page 1218
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Remove Transparency

The Remove Transparency effect negates transparent values in an image. You can use the Remove Transparency
module to remove the result of antialiasing around an image.

Use the Remove Transparency editor to control the effects of the module.

•

Threshold: All values above the Threshold represent a transparent value. In this field, you must identify
the value above which all alpha values are considered transparent. Alpha is measured from 0 to 255.

•

Remove Colour Transparency: When selected, the Threshold value is used to determine which pixels in
the Colour-Art (RGB channels) to make fully opaque or fully transparent.
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•

Remove Alpha Transparency: When selected, the Threshold value is used to determine which pixels in
the alpha channel to make fully opaque or fully transparent.

Related Topics
•

Using Effects on page 1218

Shadow

With the Shadow effect, you can turn a drawing into a shadow. It does not matter if your drawing layer is a fully
coloured character, the Shadow effect will render it into a grey, semi-transparent, slightly blurry silhouette.

To add a shadow stretched out on the ground, simply add a Quadmap module to flip, stretch and skew the
matte. Attach the entire effect to the same trajectory as your drawing layer and watch the shadow move along
with your character.
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Do not forget that you need to connect your character in both the final Composite module and
the Shadow effect if you want to see your character and its shadow.

Use the Shadow editor to modify the way the Shadow effect is created.
The Shadow effect uses the shape of the drawing connected to create the shadow behind another element and
can blur the edges to create a softer effect. You can control the type and amount of blur, as well as the colour of
the shadow, in this dialog box.

•

Truck Factor: Activated by default, this option readjusts the blur when the elements undergo a change of
depth or scale. When this option is disabled, the effect's values remain unchanged regardless of any
depth or scale changes. It is recommended that this option be disabled when multiple drawings are
composited and attached to this effect.

•

Blur Type (Directional or Radial):
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•

If Directional is selected, Harmony will blur the matte in the direction you select.

•

If Radial is selected, Harmony will blur the edges of the matte evenly around points that make up the
edge of it.

•

Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur
radius is affected by the drawing scale and camera position.

•

Directional Angle: If you select a Directional Blur Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.

•

•

0: blurs the image to the west.

•

90: blurs the image to the south.

•

180: blurs the image to the east.

•

270: blurs the image to the north.

Directional Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.
•

A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.

•

A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.

•

Invert Matte: Activate this option to invert the matte used to create the shadow. In the render mode, the
background will appear grey, while a the matte shape will act as a cut-out window, allowing you to see
the original background colours beneath.

•

Use Source Colour: Create the shadow using the matte shape's colour. Be sure that you are in render
mode
to see this effect and that your background is NOT white and that you do NOT have a white
colour card module attached to the composite. As the shadow matte only gives colour information, but
no alpha, the matte is automatically multiplied with the background colours. If there is no colour card
attached and the background appears black, you will see the matte colour at full opacity. If it is multiplied
with a white background, the colours disappear into the full 255.

•

Multiplicative: Multiplies the shadow colours with the background.

•

Red/Green/Blue/Alpha: In the RGBA fields, you can enter the value to add or subtract from the colour
channels in the drawings or you can attach these values to function curves.

If this effect is connected below a Composite module set to Pass-Through, the effect will be applied
to each element connected in the Composite module individually. If some of these elements are
overlapping, the effect will also overlap.

Related Topics
•

Using Effects on page 1218
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Sparkle

The Sparkle effect transforms a vector drawing into sparkles. You have a high degree of control over the
appearance of the sparkles.
The sparkle effect can only be used with vector drawings. If the sparkle effect module is attached to a composite,
verify that the Composite editor is set to Vector Flatten Output.

Use the Sparkle editor to modify how the Sparkle module creates the sparkle effect. You can also use Bezier and
Ease function curves to change the values of factors over time.
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•

Start Angle: Enter a value between -360 and 360 to indicate the angle of rotation of each sparkle.

•

Scale: Sparkles are determined by the size of the bounding box of the coloured areas in the drawing.
Enter the multiple to use to scale the sparkle size.

•

Factor: Enter a value between 0.1 and 1 to determine how pointy the sparkle is. A value closer to 0 will
result in a more pointed sparkle. A value closer to 1 will result in a more rounded sparkle.

•

Density: Adjusts the density level.

•

Number of Points: Enter the number of points you want each sparkle to have.

•

Probability of Appearing: Enter the percentage of possibility that sparkles will be displayed. Enter 100 to
always show sparkles. Enter 0 to always hide sparkles.

•

Point Noise: Enter a value between 0.1 and 1 to indicate the amount by which points in a sparkle will
distort.

•

Centre Noise: Enter a value between 0.1 and 1 to indicate the amount by which the angles between each
point in a sparkle will distort.

•

Angle Noise: Enter a value between 0.1 and 1 to indicate the amount by which the Start Angle in a
sparkle will distort.

•

Random Seed: Enter a positive integer value that will be used to determine the sparkle pattern.

•

Use Drawing Colours: Select this option to use the colour attributes of the drawing for the sparkle
colour. When this selection is disabled (default setting), the colour values will be used as they are entered
in the editor.

•

Flatten Sparkles of Same Colour: Flatten all drawings of the same colour into a single layer.

•

Red/Green/Blue/Alpha: In the RGBA fields, enter the values to use for the sparkle colour.

Related Topics
•

Using Effects on page 1218
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Tone

Use a Tone effect to add a dark-coloured region to your drawing and simulate the shaded area away from a light
source. To produce the tone effect, create a drawing to control where the tone will appear. The Tone effect uses
a matte to determine the shape and position of the tone on your drawing and can be blurred at the edges to
create a softer effect.

For information on all effects, check out the Online Help. The Tone Effect is shown here as an
example.

Use the Tone editor to control the type and amount of blur, as well as the colour of the tone.
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•

Truck Factor: Activated by default, this option readjusts the blur when the elements undergo a change of
depth or scale. When this option is disabled, the effect's values will remain unchanged regardless of
depth or scale changes. It is recommended that this option be disabled when multiple drawings are
composited and attached this effect.

•

Blur Type (Directional or Radial):
•

If Directional is selected, Harmony will blur the matte in the direction you select.

•

If Radial is selected, Harmony will blur the edges of the matte evenly around points that make up the
edge of the matte.

•

Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur
radius is affected by the drawing scale and camera position.

•

Directional Angle: If you select a Directional Blur Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.

•

•

0: Blurs the image to the west.

•

90: Blurs the image to the south.

•

180: Blurs the image to the east.

•

270: Blurs the image to the north.

Directional Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.
•

A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.

•

A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.

•

Invert Matte: Activate this option to invert the matte used to create the tone.

•

Use Matte Colour: Uses the matte shape colour to create the tone.

•

Multiplicative: Multiplies the tone colours with the background.

•

Red/Green/Blue/Alpha: In the RGBA fields, you can enter the value you want added to or subtracted
from the colour channels in the drawings or you can attach these values to function curves.

1345

Chapter 19: Effects Lens Flare

Related Topics
•

Using Effects on page 1218

Transparency

The Transparency effect is used to make an image partially transparent. The Transparency effect is useful when
fading images in and out, such as a phantom or to make something partially see-through, such as a window.

Use the Transparency editor to control how translucent the element should be.
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You can enter a value in the Transparency field or change the transparency value over time by linking it to a
function curve. Entering a value of 100 in the Transparency field will make the element 100% transparent, in other
words, invisible. Entering a value of 0 will render the element completely opaque.

It is also possible to adjust a layer/module's transparency directly in the Layer Properties window
without using the Transparency module. In the layer's properties, go to the Drawing tab and adjust
the Opacity parameter. This parameter is visible in OpenGL mode.

Related Topics
•

Using Effects on page 1218
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Turbulence

The Turbulence effect is a mathematically generated effect that uses fractal noise to create turbulent distortions
in an image. You can see the effect when used with an image as the background. You can create flowing water,
funhouse mirrors, and waving flags.
For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/videotutorials/chapter/adam-phillips-harmony-effects.
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Turbulence Effect Properties
Parameter

Description
Lets you select a type of noise pattern.
Perlin: Creates pseudo random patterns. The greyscale contains a continuity
between different tones of grey.
Simplex: Creates a more contrasted noise pattern with more variation than
Perlin. There is a smooth variation of intensity.
Sinusoidal: Creates a repeated wavelike pattern.

Noise Type

Sub Scaling: Applies Perlin noise twice. The second noise is added where dark
areas appear in the original. The frequency of the second iteration is higher so
the noise is smaller.
Rocky: Uses the Perlin pattern but converts the very high and low values to
more moderate values. For example, the whites become light greys and the
blacks become dark greys.
Small Bumps: Uses the Perlin pattern. The transitional grey areas between
blacks and whites become inverted so they look like dark lines. The extremes,
black and white areas, become whitish.
Transforms the noise pattern, created by the Noise type and controls the way
layers are composited. These are variations of the basic noise.
Turbulent Twist: Applies a turbulent effect on the pattern so it changes the
transition between black and white by adding more modulation.

Fractal Type

Fractional Brownian: Applies a basic application of noise and composites by
adding subsequent layer with the Complexity parameter.
Threshold: Changes the dark greys into black values so there is more black in
the noise for higher contrast.
Invert Threshold: Inverts all the values of the Threshold type so a negative
image of it is created.
Terrain: Adds contrast and converts the dark greys into white or light greys.

Pinning

Constrains the effect within the image boundaries.
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Amount

Specifies the amplitude of displacement.

Frequency

The density of displacement appearing in the noise. A higher value produces a
greater amount of displacement in a given area; a lower value produces a smaller amount.

Offset

Moves the entire image.

Seed

This value determines the starting noise pattern on the first evolution of the
effect.

Locked

Applies parameter value while retaining the X and Y ratio.

Separate

Allows you to apply different parameter values to X and Y.

xy

When locked, applies parameter values to both X and Y. When separated,
allows you to apply different value to X and Y.

Evolution

Determines the displacement pattern over time.
Evolution Frequency: This factor makes the complexity iterations animate or
transform at a higher speed. In other words, the second, third, etc. passes,
controlled by the Complexity parameter, will mutate faster than the main one.

Complexity

Complexity: The number of noise layers that make up the noise. Each
successive layer has a higher frequency, resulting in a smaller noise effect. You
can have up to seven passes. Increasing this number increases the depth and
amount of detail in the noise. Use Complexity with Sub Scaling when the value
is 1 or greater. Note: Increasing the Complexity results in longer rendering
times.
Gain: Controls the amount of opacity present in the iteration of noise. This
also affects the layer when using Sub Scaling. With a value of 0, you will not see
the sub noise. A value of 1 will show the sub noise just as strong as the main
one. For example, with water ripples, a higher amount of Gain will reveal more
ripple or subripples.
Sub Scaling: The factor by which the main noise is modified at each iteration of
complexity. A value of 1 make the two noises identical. A value of 2 makes the
sub noise twice as small. The next iteration would be 4 times smaller. Values
must be greater than 1.
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Turbulent Noise

The Turbulent Noise effect uses Perlin noise to create greyscale noise for organic-looking backgrounds,
displacement maps, and textures, or to simulate clouds, fire, lava, steam, flowing water, or vapour. The
Turbulent Noise effect models turbulent systems with smaller noise features moving more quickly than larger
noise features. The Turbulent Noise effect creates smooth animations and takes less time to render than other
noise or grain effects.
For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/videotutorials/chapter/adam-phillips-harmony-effects.
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Turbulent-Noise Effect Properties
Parameter

Description
Perlin: Creates pseudo random patterns. The greyscale contains a continuity
between different tones of grey.
Simplex: Creates a more contrasted noise pattern with more variation than
Perlin. There is a smooth variation of intensity.
Sinusoidal: Creates a repeated wavelike pattern.

Noise Type

Sub Scaling: Applies Perlin noise twice. The second noise is added where dark
areas appear in the original. The frequency of the second iteration is higher so
the noise is smaller.
Rocky: Uses the Perlin pattern but converts the very high and low values to
more moderate values. For example, the whites become light greys and the
blacks become dark greys.
Small Bumps: Uses the Perlin pattern. The transitional grey areas between
blacks and whites become inverted so they look like dark lines. The extremes,
black and white areas, become whitish.
Transforms the noise pattern, created by the Noise type and controls the way
layers are composited. These are variations of the basic noise.
Turbulent Twist: Applies a turbulent effect on the pattern so it changes the
transition between black and white by adding more modulation.

Fractal Type

Fractional Brownian: Applies a basic application of noise and composites by
adding subsequent layer with the Complexity parameter.
Threshold: Changes the dark greys into black values so there is more black in
the noise for higher contrast.
Invert Threshold: Inverts all the values of the Threshold type so a negative
image of it is created.
Terrain: Adds contrast and converts the dark greys into white or light greys.

Frequency

The density of displacement appearing in the noise. A higher value produces a
greater amount of displacement in a given area; a lower value produces a smaller amount.

Offset

Moves the entire image.

Locked

Applies parameter value while retaining the X and Y ratio.
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Separate

Allows you to apply different parameter values to X and Y.

xy

When locked, applies parameter values to both X and Y. When separated,
allows you to apply different value to X and Y.

Evolution

Determines the displacement pattern over time.
Evolution Frequency: This factor makes the complexity iterations animate or
transform at a higher speed. In other words, the second, third, etc. passes,
controlled by the Complexity parameter, will mutate faster than the main one.

Complexity

Complexity: The number of noise layers that make up the noise. Each successive layer has a higher frequency, resulting in a smaller noise effect. You can
have up to seven passes. Increasing this number increases the depth and
amount of detail in the noise. Use Complexity with Sub Scaling when the value
is 1 or greater. Note: Increasing the Complexity results in longer rendering
times.
Gain: Controls the amount of opacity present in the iteration of noise. This
also affects the layer when using Sub Scaling. With a value of 0, you will not see
the sub noise. A value of 1 will show the sub noise just as strong as the main
one. For example, with water ripples, a higher amount of Gain will reveal more
ripple or subripples.
Sub Scaling: The factor by which the main noise is modified at each iteration of
complexity. A value of 1 make the two noises identical. A value of 2 makes the
sub noise twice as small. The next iteration would be 4 times smaller. Values
must be greater than 1.
Depth: This value determines the composition order when the Z value of two
elements is the same.

Underlay Layer

Use the Underlay Layer effect to read only the Underlay layer in an element. Place a Underlay Layer module after
a drawing module in the Network view to display only the module's Underlay layer output. The Underlay Layer
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module can only be connected after a vector drawing layer or a vector type Composite module. Any bitmap
information will not be processed.
This effect will only work if the user drew or painted something into the Underlay layer of the drawing.

Use the Underlay Layer editor to control how the Underlay layer is rendered by the module.

•

Antialiasing Quality: Smoothness setting applied to the Underlay layer. Choose from Low (no
antialiasing), Medium Low, Medium and High (extensive antialiasing). The higher the quality of the chosen
setting, the greater the amount of antialiasing that is applied. Higher quality images require more time to
render and more memory from your system.

•

Antialiasing Exponent: Controls the amount of area around the Underlay layer edges that is used in the
antialiasing process. A higher value uses less area, resulting in sharper edges, while a lower value uses
more area, resulting in softer edges. If the Antialiasing Quality value is set to Low (no antialiasing), this
value is ignored.

Related Topics
•

Using Effects on page 1218
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Particle Effects

Particle effects are both cool and a huge time saver. You can create atmospheric effects, such as rain, grass or
fire to more complex systems, such as swarms of animated insects and all in a fraction of the time it would usually
take.
Particle Effects act in the same way as all other effects in Harmony, except that they always work within their own
specifically structured system. You can attach a Blur effect module under a Drawing module and the image
contained in the Drawing module will become blurry. Particle effect set-ups are more complex than simply
adding a module and playing with its parameters. To keep things simple, just think of each Particle Effect as its
own group.

Related Topics
•

Basic Structure on the next page

•

Accessing Default Particle Effect Templates on page 1358

•

Creating a Custom Particle Effect on page 1359

•

Particle Effect Modules on page 1360
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Basic Structure

This is what a the basic structure of a Particle Effect looks like in the Network view. This structure can change
depending on the type of effect that you are trying to create.

Colour Coding

To make particle effects less confusing, the Particle Effects modules have been colour-coded. Each colour
represents a different function. For example, Action modules, such as Velocity, Move-Particles and the Sprite
Emitter are coloured bright purple. These colours, can be edited in the Preference panel by going to Edit/File >
Preferences > General (tab) > Edit Colours (button) > Particle (tab).
In addition to defining groups by colour, module in-ports and out-ports are also colour-coded. In the network
shown in the diagram above, the Particle-Baker is dark yellow and the Particle Visualizer purple. If you look
closely, you will notice that the in-port on the Particle Visualizer, where the Particle-Baker is connected, is also
dark yellow. Similarly, the out-port on the Particle-Baker, where the Particle Visualizer is connected, is purple.
This system gives you an idea, at the very least, of what type of module is needed to fill a specific port.
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•

Visualizer - This module assembles a particle system through its middle port. It can accept a Peg on either
side. The system is flattened at this module and generated as a single image. This is so you can move the
effect's position in your scene or change its render order.

•

Action - These modules affect the particles dynamics; they determine how they are created and moved
around in space. If there are multiple Action modules hooked to a composite, they are executed from
right to left. Due to this execution ordering, there should generally be an emitter on the right-most port.

•

System Composite - Unlike a regular composite that reads all the position information from its in-port
modules and combines them accordingly, a System Composite is specifically designed to handle Action
module information.

•

Baker - These modules allow you to make decisions about the particle systems position, angle, number, etc. the
same way that a baker would make decisions about the ingredients that go in a cake.

•

Region Composite - This module combines Region modules. In case you have more than one Region in
your effect, this composite will help define the position and render order of the different Regions.

•

Region - These modules are used to define the region from where the particles are emitted. These
regions can be Planar or 3D.

Help Notes
Double-clicking on any of the Particle Effects modules will bring up a small Help window. In this window, you will
find information relating to that specific module, often with explanations about the options found in the module
Layer Properties panel.
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Related Topics
•

Particle Effect Modules on page 1360

Accessing Default Particle Effect Templates
Harmony comes equipped with some basic Particle Effect templates. Change the effect's "sprite" with a
drawing, image or animated sequence of your own. Tweak its Layer Properties to adjust the effect more to your
liking. Or use these templates to analyze their structure so that you can build your own.
To access the Particle Effects Templates:
Go to the top menu and select Insert > Particle > and select the effect of your choice.
The default Particle Effects templates available are:
•

Basic Particle System - This effect template has the simplest structure and the parameters for all of its
modules are set to the default values. For example, the Planar-Region has not been rotated or re-sized,
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the particles have not been randomized in the Sprite-Emitter and the particles start their generation on
the first frame and die out at the maximum number allotted in the Particle-Baker.
•

Basic Gravity Based System - Simulates particles being generated from a source, with special emphasis
on adding gravity to the particle system.

•

Weather

•

•

•

•

Fire - Simulates a camp fire.

•

Rain - Simulates a fairly turbulent rainfall with 3 different coloured raindrops.

•

Toon Fire - Simulates a camp fire with a more cartoony look.

Replicators
•

Animated Grass - Simulates a patch of grass that is swaying in the wind. Uses an animated drawing
layer as a sprite.

•

Bees - Simulates a crowd of bees flying around. Uses an animated drawing layer as a sprite. Animate
the position of the bees using the Peg layer.

•

Confetti - Simulates confetti being thrown upward and falling back to the ground.

•

Grass - Simulates a static patch of grass at a fully grown state.

•

Lemmings - Simulates the classic game Lemmings. Uses an animated drawing layer as a sprite. This is
also a good example to use to learn how to use Bounce Planes, as the particles will fall until they hit a
bounce plane.

Fx
•

Fairies - A fun example of how you can have a particle (the Fairy) which generates particles (the Fairy
Dust).

•

Fairy - An example of how you can create a trail of Fairy Dust following an animated drawing layer.

•

Speed Lines - Simulates radial Speed Lines that will radiate outwards from a central point.

•

Horizontal Speed Lines - Simulates horizontal speed lines that will radiate in one direction from a
central point.

Fun
•

Bouncing Balls - Simulates the randomness of a set of bouncing tennis balls.

•

Bubble Vortex - Simulates a swarm of insects emerging from a single origin point (such as the opening
of a hive) and forming a tornado-shaped, tubular vortex.

Related Topics
•

Basic Structure on page 1356

Creating a Custom Particle Effect
There is a new tab in the Module Library view. It is called Particle and it contains all the modules specifically
needed to build various Particle effect systems.
To create a custom Particle effect, click and drag the Particle modules from the Module Library to the Network
view.
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Related Topics
•

Basic Structure on page 1356

•

Accessing Default Particle Effect Templates on page 1358

•

Particle Effect Modules below

Particle Effect Modules
This section explains the each module's purpose, its layer properties and how to adjust these properties.

Related Topics
•

3D Region on the facing page

•

Baker on page 1362

•

Baker Composite on page 1364

•

Bounce on page 1364

•

Explosion on page 1366

•

Gravity on page 1367

•

Image Fracture on page 1369

•

Kill on page 1374

•

Move Particles on page 1375

•

Orbit on page 1377

•

Planar Region on page 1379

•

Random on page 1381

•

Region Composite on page 1383

•

Repulse on page 1384

•

Rotation Velocity on page 1385

•

Sink on page 1387

•

Size on page 1387

•

Sprite Emitter on page 1388

•

System Composite on page 1395

•

Velocity on page 1396

•

Visualizer on page 1398

•

Vortex on page 1400

•

Wind-Friction on page 1401
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3D Region

This module defines 3D region. The region can take on many forms, such as a sphere, cone, cylinder or box. The
3D Region module acts in contrast to the Planer Region module, which generates and emits particles from a 2D
plane.
A 3D Region can be connected to a Sprite-Emitter, to define the region from which particles are generated. It
could also be connected to a Bounce module, to define a region against which particles will bounce. If connected
to a Sink, it will define a region where the particles will disappear.

Click on View > Show > Control in order to view a preview of what the 3D Region looks like.

Layer Properties
Use the 3D Region's Layer Properties to adjust the 3D region.
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•

Shape: Choose a shape for the 3D Region by clicking on the Type drop-down menu and selecting either
Box, Cylinder, Cones, Sphere or Image.
If you select Image, you must connect the module of a vector drawing or a vectorized bitmap image to the
left port (blue node) of the 3D Region module. The particles will then be emitted from that image' shape.
Don't forget that you can rotate your vector drawing in 3D space by enabling the 3D option in its Layer
Properties.

•

Size: Enter different values into the Width, Height and Depth fields to change the dimensions of the 3D
Region's selected shape. Depending on the shape selected, some fields may be greyed-out if they are not
applicable. You can also modify the shape with the Transform Tool by grabbing the control handles
(turquoise squares) in the Camera or Perspective views. You can also change the dimensions of the region
over time by click on the function button at the end of each field.

•

Radius: Enter different values into the Min or Max fields to change the inner or outer radius of applicable
shapes, such as a cylinder, cone or sphere. The radii can also be modified by grabbing the control handles
(turquoise squares) in the Camera or Perspective views. The radii of the region can be changed over time
by clicking on the function button at the end of each field.

Related Topics
•

Particle Effect Modules on page 1360

Baker

This module, also known as the Particle-Baker, allows you to make decisions about the particle systems position,
angle, number, etc. the same way that a baker would make decisions about the ingredients that go into baking a
cake. The Baker performs the particle simulation, combining together all the ingredients specified to get the final
result. The Baker must always be connected to the Particle-Visualizer.

Layer Properties
Use the Particle Baker's Layer Properties to adjust your particle system's various parameters.
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•

Seed: This value allows you to apply a random effect to the particle system. There may be times when you
want to copy the particle system to two different locations on your screen. You can take the out port of
the Particle System Composite module, and plug this into two separate Bakers and Visualizers. Then you
could move one system over by attaching a peg into the left side of one Visualizer. If you do this, the two
systems will look exactly the same. Add a random Seed to make them look different.

•

Simulation Quality: This option defines how many simulation steps per frame are performed. The lowest
quality creates one step per frame. Raising the quality will divide the simulation time and create two or
more steps of simulation for each frame. This increases the computation time, but also increases the
quality of the result.

•

Number of Pre-roll Frames: Allows you to select a start position in the particle effect sequence, other
than the start (generation) of the sequence. This essentially allows you to start the particle effect part-way
through its cycle, even if it starts on frame one of your project. An example of when this parameter might
come in handy is when you want it to be already raining at the start of your scene. If you don't change the
number of Pre-roll Frames, it will always start to rain at the beginning of your scene.

•

Maximum Number of Particles: Entering a value in this field puts a cap on the number of particles that
will be created; the software will stop generating particles once it reaches this number.

•

Age Particles: Check this option if you want the software to keep track of how long a particle has existed
in its cycle from the time of its inception. Knowing a particles "age" means that you can tack other
parameters onto its lifespan, such as having the particle start to disappear or change colour at a certain
age.

•

Move Position: Check this option to allow the particles to move position, otherwise the particles will not
be able to flow in a specified direction. This option also exists in the Move Particles module. You do not
always need a Move Particles module, hence why this option exists in the Baker. This option is also useful
for when your Move Particles module is cut-off by a sink, refer to Sink on page 1387 for information on
that particle effects module.

•

Move Angle: Check this option to allow the particles to flow from different angles. This option also exists
in the Move Particles module. You do not always need a Move Particles module, hence why this option
exists in the Baker. This option is also useful for when your Move Particles module is cut-off by a sink.
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Related Topics
•

Particle Effect Modules on page 1360

Baker Composite

The Baker Composite is used to composite more than one Particle-Baker, as well as any other elements that
need to be combined before they pass through the Particle Visualizer.

Related Topics
•

Particle Effect Modules on page 1360

Bounce

Use this module to make your particles bounce off a surface with realistic physical modeling. This module should
have a region connected to it, and that region will act as a bounce plane so that when any particle hits it, it will
bounce off at the correct angle.
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Layer Properties
Use the Bounce's Layer Properties panel to adjust the effect's parameters.

•

Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

•

Friction: Enter a value into this field to increase the amount of friction that each particle experiences as it
makes contact with the planar surface. A positive value creates more friction and therefore slows the
particle down. A negative value lessens the friction and therefore makes the surface appear more
slippery.

•

Resilience: Changing this value effectively increases or decreases the bounciness of the particle. A value of
zero causes the particle to hit the planar surface once and slide off any downward facing angle. A positive
value, even by decimal increments, causes the particle to become bouncy. A negative value deadens the
effect, the same way a lack of Region would.

•

Cutoff: Increasing this value widens the bounce arc. If the connected Planar Region is completely flat, a
value of zero will cause the particle to bounce up and down in place. A tilted plane in the direction of the
bounce will also widen the arc.

Related Topics
•

Particle Effect Modules on page 1360
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Explosion

Use this module to create an explosion. As it is an Action module, it should be connected to the Particle System
Composite after the Sprite Emitter. As the explosion occurs, the particles will burst rapidly away from the centre
of the explosion (the centre of the defined Region), then gradually slow down.

Layer Properties
Use the Explosion's Layer Properties panel to adjust the effect's parameters.
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•

Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

•

Coordinates: User the X, Y and Z fields to enter different position values, in order to move the particle
system around in 3D space. You can also connect a Peg module to the Explosion to manipulate its
position with the Transform tool or Move tool.

•

Radius: The radius defines the surface of an invisible sphere. As the explosion occurs, the exploded
particles inside the boundaries of this sphere will be effected by the force of the explosion, while the
particles that eventually pass through will remain unaffected.

•

Sigma: The higher the Sigma value, the longer it takes for the particles to completely disappear, even if
the initial explosion seems to occur just as rapidly.

•

Magnitude: This value defines the magnitude of the explosion. The greater the magnitude, the faster the
particles break-up.

•

Epsilon: This value works in opposition to the Sigma value. The higher the value, the slower the initial
explosion seems to occur. If the value is high (an integer value) then larger particles remain suspended for
longer from the initial explosion and take a while to gradually break down. A smaller (decimal) value
breaks the particles down to smaller forms more rapidly from the time of the initial explosion.

Related Topics
•

Particle Effect Modules on page 1360

Gravity

This module allows you to define the gravity of the particle system.

1367

Chapter 19: Effects Particle Effects

Layer Properties
Use the Gravity module's Layer Properties panel to adjust the effect's parameters.

•

Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

•

Apply Gravity: Enable this option to force the particle system to adhere to the force of gravity. Values
must be entered into the Direction fields, along with enabling this option, in order for it to work. If this
option is not enabled, the particle system will explode outwards from its origin point.

•

X Direction: Directs the particle stream either to the left or the right (along the x-axis). A value of 1 forces
the particle stream to the right, while a value of -1 forces the particle stream to the left.

•

Y Direction: Directs the particle stream either up or down (along the y-axis). A value of 1 forces the
particle stream to flow upwards, while a value of -1 forces the particle stream to flow downwards.

•

Z Direction: Directs the particle stream either forwards or backwards (along the z-axis). A value of 1
forces the particle stream to flow forwards, while a value of -1 forces the particle stream to flow
backwards.

•

Apply Gravity between Particles (Relative Gravity): Relative Gravity will apply gravity between each
particle taking their masses into account. The mass of the particle can be specified at emission time via
the Sprite or the Image Emitter.

•

Relative Gravity Magnitude: Adjust the amount of gravity that will be applied between particles.

•

Relative Gravity Epsilon: The acceleration falls off the further the particles get away from each other, but
when the particles are very close to each other, the acceleration becomes very high - so you should define
a small region around the particles so that they never actually touch.
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•

Relative Gravity Maximum Distance: Adjusts the radius beyond which particles don't affect each other.

Related Topics
•

Particle Effect Modules on page 1360

Image Fracture

Use the Image Fracture to break an image apart into pieces. This Effect module requires 2 image objects: the
image to be cut and the shape of the cut pieces (matte). The image to be cut can be anything from a vector
drawing to a bitmap image to an entire scene's composite, with effects and all. The image to be cut should be
hooked to the Image Fracture's fight port.
The matte should be a flattened if you want it to work like a cookie cutter (hollow shape with a frame) and can be
composed of either brush or pencil lines. It can also be a solid shape, may solid filled shapes and even many solid
filled overlapping shapes. When the matte is made up of overlapping pieces, the cut image will be multiplied at
those zones to break apart in multiple layers. The matte drawing should be hooked to the Image Fracture's left
port.
The 2 image objects overlap perfectly when they are combined in the Image Fracture. This means that you have
to take 12 by 12 field into account when judging the scale and proportion of these objects. If the matte does not
overlap at a part of the image, that part of the image will not get cut. The matte does not have to be a
continuous shape. It could be 3 separate circles, which would then be cut and pulled away from the image.
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You can turn on the grid and use the Light Table feature in the Drawing view while drawing or
scaling the Image and Matte, in order to ensure that they are the correct size relative to one another.

Look at an example of a Network that uses the Image Fracture:
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Layer Properties
Use the Image Fracture's Layer Properties panel to adjust the effect's parameters.

Generation Tab
•

Emission:
•

•

Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

Type: You may want to design a variety of different drawings that will vary up the appearance of your
particle system. In this case, you should put each drawing on its own cell in the drawing layer. Each
drawing will then be a new Type of particle.
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•

•

•

Type Generation Strategy: This allows you to choose between Sequentially assigning a type (moving
from one drawing to the next) or Randomly.

•

Particle Type 0: This is the frame number where the first drawing can be found. If you have a 5-frame
cycle that starts on frame 1, you would put a 1 here.

•

Particle Type 1: This is the frame number where the last drawing can be found. If you have a 5-frame
cycle that starts on frame 1, you would put 5 here.

Age:
•

Age at Birth: A different start frame number can be entered in this field. This means that a particle can
start with a different drawing than the drawing that you have on frame 1.

•

Age at Birth Standard Deviation: Allows a random deviation for the birth of the particles. If you have
a 5-frame cycle that starts on frame 1, but you want the particles to be of a random type, then you may
want to set the Age and Birth to 3 with a standard deviation of 2. That means that particles will
randomly be born at any frame from 1 to 5.

Advanced:
•

Particles Mass: Define a mass for the particles. This mass will affect how the particles interact with
gravity.

•

Align Initial Velocity: This aligns the initial velocity with the region from which the particles are being
emitted. If you are emitting from a sphere, then the particles will all start out moving away from the
centre of the sphere.

Rendering Tab
•

•

Transformation:
•

Size over Age: Use this value to set how you would like the size of the particle to change as it ages.
Attach a function to this attribute if you would like to, for example, have the particles get smaller as
time goes on.

•

Directional Scale: Check this checkbox if you would like to scale the particle in the direction of its
movement.

•

Directional Scale Exponent Factor: Set an exponent here for how much you would like that particle to
scale.

•

Align with Direction: Check this checkbox if you would like to align the particle in the direction of its
movement.

•

Axis to Align: Select the axis that you would like to align from the drop-down box. This axis refers to
the axis of the Drawing grid from the Drawing module plugged into the emitter

•

Flip X Axis to Match Direction: You might want to have the particle align to the X direction of
movement. You can see this property being used in the Lemmings example.

•

Flip Y Axis to Match Direction: Similar to flipping the X axis, you may wish to flip the Y axis of a
drawing to match the direction of the particle movement.

•

Use Rotation of Particle: Check this checkbox to enable rotation on the particle.

•

Keep Volume: When you choose to do a Directional Scale, then this will automatically maintain the
volume of the particle by squashing it proportionally to how much it stretches as a result of the
directional scale.

Colouring:
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•

•

Colouring Strategy: This drop-down box allows you to set how you would like to define the colour of
the particle.

•

Use Drawing Colour: In this case, the particle will remain the same colour as it was drawn with.

•

Map RGB Based on Age: Attach a function to this to vary the Red, Green, and Blue values of the
particle as it ages.

•

Map RGBA Based on Age: Attach a function to this to vary the Red, Green, Blue, and Alpha values of
the particle as it ages.

•

Apply Opacity Based on Age: Keep the original RGB values from the drawing, but vary the Alpha
(Opacity) according to a function that you define here.

•

Map RGB Based on Frame: Change the Red, Green, and Blue values of the particles based on the
frame. Changing based on the frame means that ALL particles will change colour on that frame,
regardless of their age.

•

Map RGBA Based on Frame: Change the Red, Green, Blue, and Alpha values of all particles on a
given frame by attaching a function.

•

Apply Opacity Based on Frame: Use the original RGB values from your drawing, but vary the Alpha
(Opacity) of the particles on a certain frame by attaching a function to this.

•

Red, Blue, Green: This is where you can attach functions to Red, Blue, and Green values. You can also
click on the colour swatch to adjust the colour.

•

Alpha: This is where you can attach a function to the Alpha (Opacity) of your particles.

Compositing:
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•

Blur: Define whether you would like to apply a Blur to the particles.

•

No Blur: No blur will be applied to the particles.

•

Directional Blur Based on Age: Attach a function to define how you would like the particles to blur
based on the age of each particle. The particle will blur in the direction of movement.

•

Directional Blur Based on Frame: Attach a function to define how all particles should be blurred at a
particular frame. The particle will blur in the direction of movement.

•

Low Quality Radial Blur Based on Age: Attach a function to define how you would like the particles to
blur based on the age of each particle. This will be a low quality blur.

•

Low Quality Radial Blur Based on Frame: Attach a function to define how all particles should be
blurred at a particular frame. This will be a low quality blur.

•

Low Quality Radial Blur Based on Camera Distance: Define how you would like the particles to blur
based on their distance from the camera. This is a low quality blur.

•

High Quality Radial Blur Based on Age: Attach a function to define how you would like the particles
to blur based on the age of each particle. This is a high quality blur.

•

High Quality Radial Blur Based on Frame: Attach a function to define how all particles should be
blurred at a particular frame. This is a high quality blur.

•

High Quality Radial Blur Based on Camera Distance: Define how you would like the particles to blur
based on their distance from the camera. This is a high quality blur.

•

Blur Intensity: This is where you can set a value, or attach a function to animate the blur according to
the type of blur that was defined from the drop-down list.

•

Falloff Rate: The distance where the blur fades from the edge of the image. Select a value between 0
and 1.

•

A falloff rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
drawing to the farthest edge of the blur.

•

A falloff rate of 1 causes the blur to fade out quickly so that the blur is heaviest at the edge of the
drawing.

•

Blend Mode: Define a blend mode for the particles to get cool effects.

•

Blend Intensity: This is a percentage of how opaque you would like the particles to be blended. A
value of 50 would be 50% transparent. A value of 100 would be fully opaque.

Related Topics
•

Particle Effect Modules on page 1360

Kill

This module determines when you want particles to disappear.
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Layer Properties
Use the Kill Module's Layer Properties panel to adjust the effect's parameters.

•

Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

•

Kill Younger: There are only a couple of specific scenarios where you might want to use this property. In
order to make use of Kill Younger, you would generally want to attach a function to this property. The
reason for this is, if you just turn on a "Kill Younger" right away at time 0, then you'll never see any
particles. For example say that you set Kill Younger to 10, at time 0, there will be no particles that are
older than 10, so you'll never see any particles. What you might want to do, however, is have your
particles animating over time, and at some point in time, you may suddenly want to kill all the younger
particles. Let's take the example of an animation where the particles change from blue to yellow. At every
frame, new particles are generated, and the particles that already exist age. There might come a point,
perhaps where you do something like an explosion, where you want to kill all the particles that are
younger than 10 frames old - so in my example it would kill all of the blue particles, leaving only the yellow
particles.

•

Kill Younger Than: This is where you could animate the effect for "Kill Younger."

•

Kill Older: When this option is checked, particles will disappear when they reach a certain level of
maturity.

•

Kill Older Than: Set the age at which particle will disappear.

Related Topics
•

Particle Effect Modules on page 1360

Move Particles
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This module allows you to determine whether the particles are stationary (like grass) or moving (like rain), and
you can animate this function on and off.

Layer Properties
Use the Move Module's Layer Properties panel to adjust the effect's parameters.

•

Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

•

Age Particles: Check this checkbox to age the particles. Be aware that if you check "Move Position" and "Move
Angle," then the particles will age implicitly. If you do not want the particles to move, however, and you do still
want them to age, then uncheck Move Position and Move Angle, and check Age Particles. The "Age Particles"
property also exists in the Baker, however whatever happens in the Baker happens after everything else in the
particle system. So, if for example you have a Kill module, it will kill the particles before it ages them, and you
probably want to age the particles before you determine whether to kill them. Therefore, if you have a Kill module,
make sure to age the particles in your Move module before you kill them. If you age the particles both in the Move
module as well as in the Baker, then the particles will age twice on that frame instead of once.

•

Move Position: Check this checkbox to enable movement on the particles. There is also a "Move
Particles" checkbox in the Baker. If it is disabled in the Baker and in the Move module, the particles will
not move, they will simply generate in place and stay there. If the checkbox is checked on the Baker, the
particles will move, but if you need the particles to interact with another Action, say a Sink, then you want
the Particles to move before they reach the sink. This is why you have a separate Move module, so that
you can place this Move before (to the right of) the Sink in your Particle System Composite.

•

Move Angle: Like the Move Position, this checkbox will enable the rotation of particles in the particle system.

•

Make Particles Follow each Other: This property allows one particle to follow another particle, through
an attraction between the particles. This is particularly useful when you want to create a snake-like effect,
where the particles are animating across the screen and following each other.

•

Follow Intensity: Adjust the strength of the attraction between particles that are following each other.

Related Topics
•

Particle Effect Modules on page 1360

1376

Toon Boom Harmony 10.3 Stage User Guide

Orbit

The Orbit module allows you to define an axis that the particles will be attracted to and orbit around. Plug a peg
layer into the orbit to move the position of the orbit without adjusting the parameters in the Layer Properties.
Fine-tuning the Orbit module can take a little finesse, because the orbit takes into account the velocity of the
particles, and uses this to determine whether the particle will orbit around the axis, whether it will be influenced
but eventually escape, or whether it will hardly be influenced at all. This is just like how Gravity between astral
bodies works in space.
See a couple of examples of how having the orbit in the wrong place can give some cool (but perhaps not useful)
effects:

You will also want to make sure that your initial velocity is varied, so use an interpolated speed and set two
different values, that way there will be a spread between them. If not, then you will get the effects as shown
above.
Also, you should use the peg layer to move the position of the Orbit module around until you find the right spot
to get the look you're trying to achieve. It also helps to set some Pre-Roll frames on your Baker to get things
ramped-up before you start to manipulate the position of the Orbit module.
See an example of what a typical Network involving an Orbit module looks like:

1377

Chapter 19: Effects Particle Effects

Layer Properties
Use the Orbit Module's Layer Properties panel to adjust the effect's parameters.

•

Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

•

Orbit Type: Select the type of Orbit you'd like to use from the drop-down list. For most scenarios, like
asteroids orbiting a planet, then a point will suffice for this. If you would like to rotate around an axis
instead, then choose between the X, Y, Z axes or set up your own custom axis.

•

Magnitude: Adjust the amount that the acceleration of each particle will be adjusted. The higher this
value, the more the particle will accelerate towards the orbit. A magnitude of 0.001 is a good number to
use for this. When the magnitude is set too high, the particles will simply fly out into space.

•

Point X: Defines the X position of the centre of the Orbit. You may also leave this at 0 and use a peg to
move the position of the Orbit module.

•

Point Y: Defines the Y position of the centre of the Orbit.

•

Point Z: Defines the Z position of the centre of the Orbit.

•

Direction X: Defines the X component of the axis of rotation for the orbit. This is only taken into account
if you choose to set up a custom axis. If this is set to 1, and Y and Z are set to 0, then the axis will be going
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in the same direction as the X axis. If the X component is set to 1, and the Y component is also set to 1,
then the axis will be at a 45 degree angle between the two.
•

Direction Y: Defines the Y component of the axis of rotation for the orbit.

•

Direction Z: Defines the Z component of the axis of rotation for the orbit.

Related Topics
•

Particle Effect Modules on page 1360

Planar Region

Like the 3D region, this determines a region that could be used as a source or as a bounce plane, but instead of a
3D region it's a 2D plane. Connect a peg to the right in-port to adjust the position of the plane.
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Layer Properties
Use the Planar Region's Layer Properties panel to adjust the effect's parameters.

•

General:
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•

•

•

•

•

•

Shape Type: This is where you can define the shape of the plane. The parameters that you can adjust
below will be greyed out depending on which shape type you choose. Each shape can be adjusted
from the Camera view using the Transform Tool by selecting the Planar Region and
then selecting View > Show > Control.

•

Rectangle: Adjust the width and height on a rectangle.

•

Disc: Adjust the point (the centre) of the disk. You may also adjust values for minimum and maximum
radius. A minimum radius of 0 will simply be a circle.

•

Triangle: Adjust the three points of the triangle independently.

•

Line: Adjust two points on a line.

•

Point: Adjust the position of one single point.

•

Image: If you choose to use the Image option, then you should make use of the left in-port of the
Planar-Region to connect a drawing layer that can be used as a mask.

Size:

•

Width: Adjust the width of a rectangular region.

•

Height: Adjust the height of a rectangular region.

Radius:

•

Minimum: Adjust the minimum radius on a disc region.

•

Maximum: Adjust the maximum radius on a disc region.

P1:

•

X: Adjust the X position of Point 1. Point 1 could refer to the point on a triangle, a line, or a point.

•

Y: Adjust the Y position of Point 1.

P2:

•

X: Adjust the X position of Point 2. Point 2 could refer to the point on a triangle or a line.

•

Y: Adjust the Y position of Point 2.

P3:

•

X: Adjust the X position of Point 3. Point 3 refers to a point on a triangle.

•

Y: Adjust the Y position of Point 3.

Related Topics
•

Particle Effect Modules on page 1360

Random
Allows you to put a random seed on some qualities like acceleration, speed, rotation speed, and position. There
is also a Seed value in the Baker, but you may only want to make one particular aspect of the system random.
This module gives the control over the randomness of a particular property.
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Layer Properties
Use the Random Module's Layer Properties panel to adjust the effect's parameters.

•

Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

•

Parameter: Allows you to choose which parameter you would like to make random.
•

None

•

Acceleration

•

Speed

•

Rotation Speed

•

Position

Related Topics
•

Particle Effect Modules on page 1360
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Region Composite

This module can composite together multiple regions, 3D Regions or Planar Regions. You may wish to emit
particles from multiple regions in the same particle system.

Related Topics
•

Particle Effect Modules on page 1360
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Repulse
This module will repulse a particle around a region, but different from bounce, it's repelled before it physically
hits the region.

Layer Properties
Use the Repulse Module's Layer Properties panel to adjust the effect's parameters.

•

Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

•

Magnitude: This value should be between 0 and 2. The higher the value, the more drastically the particles
will be repulsed.

•

Look Ahead: This value alters how far ahead of the particle's current position it will look to see whether
there's an obstacle coming ahead. This value should be between 0 and 100.

•

Epsilon: This value affects how quickly the effect of the repulse wears off. The smaller the number, the
longer the effect lasts. This value should be between 0.1 and 0.0001.

Related Topics
•

Particle Effect Modules on page 1360
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Rotation Velocity

This module allows you to define the initial rotational velocity of the particles. The values that you set up for this
module refer to each individual particle's drawing axes. This means that if you choose to rotate around the X
axis, it will rotate around each particle's local X axis as defined by its drawing plane.
The rotational velocity should be set before you emit the particles, i.e. to the right, so that the velocity is taken
into account when the particles are created.

Layer Properties
Use the Rotation Velocity's Layer Properties panel to adjust the effect's parameters.
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•

•

•

General:

•

Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

•

Axis Type: Select the type of axis you would like to use.

•

Constant Axis: If you choose to rotate the particles around a constant axis, then each particle will
rotate around the same axis. This axis will then be defined as Axis0.

•

Interpolated Axis: If you choose to rotate the particles around an interpolated axis, that means each
particle will have its own rotational velocity which lies somewhere between Axis0 and Axis1.

•

Use Input Shape: Use a region to define the rotation axis of the particles. The axis of each particle's
rotation will be perpendicular to the plane that particle is created on.

Axis:

•

Axis0 X: Define the X component of Axis0. If you set the X to 1, and the Y and Z to 0, then the particle
will rotate around its X axis as defined by its drawing plane. If you set X to 1 and also Y to 1, then it will
rotate around an axis that is 45 degrees between X and Y.

•

Axis0 Y: Define the Y component of Axis0.

•

Axis0 Z: Define the Z component of Axis0.

•

Axis1 X: Define the X component of Axis1. This applies only when you have selected an Interpolated
axis.

•

Axis1 Y: Define the Y component of Axis1.

•

Axis1 Z: Define the Z component of Axis1.

Speed (Degrees / Frame):

•

Minimum: Enter the minimum initial rotation that a particle can have, in degrees per frame.

•

Maximum: Enter the maximum initial rotation that a particle can have, in degrees per frame.

Related Topics
•

Particle Effect Modules on page 1360
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Sink
This module will cause the particles to disappear when outside of the region plugged into the sink. It can also be
inverted, so that the particles disappear when they enter the region instead.

Layer Properties
Use the Sink Module's Layer Properties panel to adjust the effect's parameters.

•

Invert: The default behaviour of the sink is for particles to disappear when they depart the region. When
inverted, the particles disappear when they enter the region instead.

Related Topics
•

Particle Effect Modules on page 1360

Size
This allows you to animate the size of the particles.
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Layer Properties
Use the Size Module's Layer Properties panel to adjust the effect's parameters.

•

Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

•

Size Type: If you choose Constant Size, then all particles will be animated to have the same size. If you
choose Input Shape instead, then you must input a Region into the in-port of the Size module. It will use
this region to determine the size of the particles.

•

Size: Change this value to adjust the size of the particles.

Related Topics
•

Particle Effect Modules on page 1360

Sprite Emitter
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This is your all-purpose emitter, that you can plug a drawing layer into, and it will generate particles that look like
your drawing layer. You could also just output dot particles if you have no image layer connected. There are
many parameters to determine how you would like to emit your particles.

Layer Properties
Use the Sprite Emitter's Layer Properties panel to adjust the effect's parameters.

Generation Tab
•

Emission:
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•

•

•

•

Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

•

Number of Particles: This is where you can define how many particles will be emitted on each frame.

•

Probability of Generating Any Particles: This is a probability percentage between 0 and 100. If the
probability is set to 100%, it will absolutely generate the Number of Particles specified. If you put the
percentage down to 50%, then there's only a 50% chance that it will generate the number of particles
set in Number of Particles. Play with this value to add random spacing to the generation of particles.

Type: You may want to design a variety of different drawings that will vary up the appearance of your
particle system. In this case, you should put each drawing on its own cell in the drawing layer. Each
drawing will then be a new Type of particle.
•

Type Generation Strategy: This allows you to choose between Sequentially assigning a type (moving
from one drawing to the next) or Randomly assigning a type.

•

Particle Type 0: This is the frame number where the first drawing can be found. If you have a 5-frame
cycle that starts on frame 1, you would put a 1 here.

•

Particle Type 1: This is the frame number where the last drawing can be found. If you have a 5-frame
cycle that starts on frame 1, you would put 5 here.

Age:
•

Age at Birth: A different start frame number can be entered in this field. This means that a particle can
start with a different drawing than the drawing that you have on frame 1.

•

Age at Birth Standard Deviation: Allows a random deviation for the birth of the particles. If you have
a 5-frame cycle that starts on frame 1, but you want the particles to be of a random type, then you may
want to set the Age and Birth to 3 with a standard deviation of 2. That means that particles will
randomly be born at any frame from 1 to 5.

Advanced:
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•

Particles Mass: Define a mass for the particles. This mass will affect how the particles interact with
gravity.

•

Region Size for Baked Particle Input: The Baked Particle Input property refers to when you use a
Baker as an input to a Sprite Emitter. You can do this when you want to generate particles from other
particles. When you do this, you have the option of setting a sphere around the source particle from
which the new particle system will generate particles. That is the region which is referred to in this
value. If you look at the following example, you'll see that the purple smiley faces are generating
smaller green, blue, and yellow smiley faces. This is done by plugging the Baker from the purple smiley
faces into the Sprite Emitter of the other smiley faces.
See the following images:

•

Copy Particle Velocity for Baked Particle Input: If you select this option, the velocity of the parent
system will be applied to the child system when a Baker is used as the region for a Sprite Emitter.

•

Add Particle Age for Baked Particle Input: If you select this option, the age of the parent system will
be inherited by the child system when a Baker is used as the region for a Sprite Emitter.

•

Align Initial Velocity: This aligns the initial velocity with the region from which the particles are being
emitted. If you are emitting from a sphere, then the particles will all start out moving away from the
centre of the sphere.

•

Minimum Initial Rotation: Define a minimum rotation in degrees that the particle can have when it is
generated. There is also a separate Rotation-Velocity module in which you can define this parameter.

•

Maximum Initial Rotation: Define a maximum rotation in degrees that the particle can have when it is
generated.

Rendering Tab
•

Sprite Selection:
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•

Rendering Strategy: Select a method to use to decide which particle type will be defined for each
particle that is created.
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•

Render as Dot: This will simply render each particle as a dot. This is useful mainly for previewing the
effects of your particle system without using the drawing layer (sprite)

•

Use Frame Number: As the frame number increases, the type of particle will change to match the
frame number. This means that ALL particles in the system will change together as the frame number
changes. If you only have a few drawings, then you may want to enable Cycling in order to cycle those
drawings.

•

Use Frame Number as Index in Selector: When you select this option, then you may use the Selector
option to animate the Frame Number that it uses over time. Meaning, instead of taking the current
frame as the Frame Number, you can write your own function instead. For example, if I were to
animate the selector so that at frame 1, it starts out at 2, then 8 frames later I add another keyframe to
set the value to 4, between the frame 1 and frame 8 the particles will all change type together from
what they look like on frame 2 to what they look like on frame 4.

•

Use Particle Type: Each particle that is generated will look like the Particle Type that was assigned
under the Generation tab. For example, if you put 1 for Particle Type 0, and then you put 6 for Particle
Type 1, then each particle will be assigned a type from 1 to 6. This type corresponds to the drawing
that appears on the sprite on that frame number. So if I have a drawing layer called Sprite that I have
plugged into the left in-port of my Emitter, it will look for the drawings in cells 1 to 6 of Sprite to assign
those drawings to each Particle.

•

Use Particle Type as Index in Selector: This option allows you to use the Selector to manually create
a function that assigns how many of which particle will be created. For example, we can set the Particle
Type to go from 1 to 100, in the Generation tab. Then we will use the Selector to remap the particle
types to a certain drawing. So for example I could create 5 drawings, labelled 1 to 5, and I can use my
selector to say I'd like to create mainly 1s, no 2s, a few 3s, 4s, and a very few 5s. What it's doing is, it is
looking at the x-axis to find what the particle "type" is, then it is looking at the y-axis to find out which
drawing to assign to that "type." When you use 1 to 100 as a type, then when you're setting the
values, they act in fact as a percentage. See the following images for further clarification:

•

Use Age: As the particle ages, it will change appearance from what appears on the Sprite's first
drawing to the subsequent drawings. This means that each particle can have its appearance animated
as it gets older.

•

Use Age as Index in Selector: You can animate the Selector in order to change how a particle ages
over time. For example, if I have a Sprite that has 6 drawings on it, I might want to animate it so that it
changes from drawing 1, on frame 1, to drawing 2, on frame 10, then drawing 3 on frame 14, drawing
4 on frame 16, drawing 5 on frame 17, etc. so that the particle rapidly ages. This allows me to change
the timing of the aging dynamically through the selector, instead of having to modify the exposure of
the cells on the Sprite.

•

Selector:Animate the Selector in conjunction with the Rendering Strategy to adjust the parameters
that control the particle’s appearance at birth and over time.

•

Cycling: If you're using rendering strategies like Frame Number or Age, you may want to cycle the
drawings. For example, if you are using Frame Number, but you've only got 5 frames worth of
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drawings in your Sprite, then if you use "No Cycle," your Particles will disappear after frame 5. You can
choose to cycle Normally, 1-2-3-4-5-1-2-3-4-5, or Back and Forth, 1-2-3-4-5-4-3-2-1.
•
•

•

•

Number of Drawings in Cycle: You should indicate how many frames from your Sprite you'd like to
cycle.

Transformation:
•

Size over Age: Use this value to set how you would like the size of the particle to change as it ages.
Attach a function to this attribute if you would like to, for example, have the particles get smaller as
time goes on.

•

Directional Scale: Click this checkbox if you'd like to scale the particle in the direction of its
movement.

•

Directional Scale Exponent Factor: Set an exponent here for how much you'd ike that particle to
scale.

•

Align with Direction: Check this checkbox if you'd like to align the particle in the direction of its
movement.

•

Axis to Align: Select the axis that you'd like to align from the drop-down box. This axis refers to the
axis of the Drawing grid from the Drawing module plugged into the emitter.

•

Flip X Axis to Match Direction: You might want to have the particle align to the X direction of
movement. You can see this property being used in the Lemmings example.

•

Flip Y Axis to Match Direction: Similar to flipping the X axis, you may wish to flip the Y axis of a
drawing to match the direction of the particle'd movement.

•

Use Rotation of Particle: Check this checkbox to enable rotation on the particle.

•

Keep Volume: If you choose the Directional Scale option, then Keep Volume will become available.
This option maintains the volume of the object by squashing it in one axis when it stretches it in
another.

Colouring:
•

Colouring Strategy: This drop-down box allows you to set how you would like to define the colour of
the particle.

•

Use Drawing Colour: In this case, the particle will remain the same colour as it was drawn with.

•

Map RGB Based on Age: Attach a function to this to vary the Red, Green, and Blue values of the
particle as it ages.

•

Map RGBA Based on Age: Attach a function to this to vary the Red, Green, Blue, and Alpha values of
the particle as it ages.

•

Apply Opacity Based on Age: Keep the original RGB values from the drawing, but vary the Alpha
(Opacity) according to a function that you define here.

•

Map RGB Based on Frame: Change the Red, Green, and Blue values of the particles based on the
frame. Changing based on the frame means that ALL particles will change colour on that frame,
regardless of their age.

•

Map RGBA Based on Frame: Change the Red, Green, Blue, and Alpha values of all particles on a
given frame by attaching a function.

•

Apply Opacity Based on Frame: Use the original RGB values from your drawing, but vary the Alpha
(Opacity) of the particles on a certain frame by attaching a function to this.

•

Red, Blue, Green: This is where you can attach functions to Red, Blue, and Green values. You can also
click on the colour swatch to adjust the colour.

•

Alpha: This is where you can attach a function to the Alpha (Opacity) of your particles.

Compositing:
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•

Blur: Define whether you'd like to apply a Blur to the particles.

•

No Blur: No blur will be applied to the particles.

•

Directional Blur Based on Age: Attach a function to define how you would like the particles to blur
based on the age of each particle. The particle will blur in the direction of movement.

•

Directional Blur Based on Frame: Attach a function to define how all particles should be blurred at a
particular frame. The particle will blur in the direction of movement.

•

Low Quality Radial Blur Based on Age: Attach a function to define how you would like the particles to
blur based on the age of each particle. This will be a low quality blur.

•

Low Quality Radial Blur Based on Frame: Attach a function to define how all particles should be
blurred at a particular frame. This will be a low quality blur.

•

Low Quality Radial Blur Based on Camera Distance: Define how you would like the particles to blur
based on their distance from the camera. This is a low quality blur.

•

High Quality Radial Blur Based on Age: Attach a function to define how you would like the particles
to blur based on the age of each particle. This is a high quality blur.

•

High Quality Radial Blur Based on Frame: Attach a function to define how all particles should be
blurred at a particular frame. This is a high quality blur.

•

High Quality Radial Blur Based on Camera Distance: Define how you would like the particles to blur
based on their distance from the camera. This is a high quality blur.

•

Blur Intensity: This is where you can set a value, or attach a function to animate the blur according to
the type of blur that was defined from the drop-down list.

•

Falloff Rate: The distance where the blur fades from the edge of the image. Select a value between 0
and 1.

•

A falloff rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
drawing to the farthest edge of the blur.

•

A falloff rate of 1 causes the blur to fade out quickly so that the blur is heaviest at the edge of the
drawing.

•

Blend Mode: Define a blend mode for the particles to get cool effects.

•

Blend Intensity: This is a percentage of how opaque you would like the particles to be blended. A
value of 50 would be 50% transparent. A value of 100 would be fully opaque.

Related Topics
•

Particle Effect Modules on page 1360

System Composite
This is where you connect together all of the "Actions" of your particle system. An action is any of the light
purple modules, like Gravity, Emitters, velocity parameters. All of the "Actions" help to define the behaviour of
the particle system.
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Related Topics
•

Particle Effect Modules on page 1360

Velocity
This defines the initial velocity of the particles that are emitted in the particle system. You may select this module
and select View > Show > Control to display manipulation handles to help you set the parameters of this
module. Use your Transform Tool to modify the manipulation handles in the Camera View or the Perspective
View.

Layer Properties
Use the Velocity Module's Layer Properties panel to adjust the effect's parameters.
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•

•

General:
•

Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

•

Bilateral: This option serves to generate positive and negative velocities in a given direction. For
example, you can generate particles with cone-shaped velocity, (e.g. a bazooka firing) going only in
the forward direction, but you can also generate velocities in the opposite direction.

•

Velocity Type:
•

Use Input Shape: If you plug a Region into the in-port of the Velocity module, it will take
the shape of this region to determine the initial velocity of the particles. They will take a
velocity that is perpendicular to the surface of the shape.

•

Constant Speed: Set a constant speed for the initial velocity of the particles.

•

Interpolated Speed: Each particle will be assigned an initial speed that is somewhere
between the two values set for Interpolated Speed.

•

Random in All Directions 2D: All particles will be assigned a random velocity in any
direction on a 2D plane.

•

Random in All Directions 3D: All particles will be assigned a random velocity in any
direction.

•

Random in Cone: Particles will be assigned an initial velocity anywhere in the shape of a
cone.

•

Random in 2D-Pie: Particles will be assigned an initial velocity anywhere in the shape of
a pie slice on a 2D plane.

Direction of Normal (for Random in All Directions 2D): Use these values to input the perpendicular
direction for the property Random in All Directions 2D.
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•

•

•

X: Set a value between 0 and 1 to determine how much influence the X axis has over the direction of
the normal. For example, if the X value is set to 1, and Y and Z are set to 0, then the perpendicular
(normal) will be going in the X direction. If X is set to 1, and Y is also set to 1, then the axis will be 45
degrees, halfway between X and Y. Feel free to use the Manipulation Handles for the velocity module
by selecting the Velocity module and then selecting View > Show > Control. This will allow you to use
the Transform tool in the Camera View or the Perspective View to set the appropriate values.

•

Y: Set a value between 0 and 1 to determine how much influence the Y axis has over the direction of
the normal.

•

Z: Set a value between 0 and 1 to determine how much influence the Z axis has over the direction of
the normal.

Speed:
•

Minimum: There are some speeds that are constant, and some that are a range of values between a
minimum and maximum. Set the minimum speed here.

•

Maximum: Set the maximum speed for interpolated speeds.

Deviation from Direction:
•

Minimum Angle: This is used for Cone and Pie shapes. Put a non-zero value here if you want there to
be a hole in the middle of your cone or pie.

•

Maximum Angle: Set the maximum angle for your cone or pie here.

Related Topics
•

Particle Effect Modules on page 1360

Visualizer
This module renders and flattens the particle system down to a single plane. You can plug a peg module into the
left-hand port here to animate the position of the whole particle system. Plugging a peg into the right-hand port
will move the depth where the flat plane is generated, so you could adjust to move it behind or in front of various
other drawing layers in your scene. You could even have two visualizers with pegs in the right in-ports that are at
different depths, to display some particles in front of and some particles behind a character or drawing in the
scene.

Layer Properties
Use the Visualizer's Properties panel to adjust the effect's parameters.
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•

Force Render as Dots: You may want to temporarily render your system as Dots when previewing a
simulation, so you can check this checkbox to ignore all drawings and force the whole system to render as
dots.

You may also use the option View > Particle > Show Particles as Dots in OpenGL. If this option is
enabled, the particles will always be displayed as dots in the OpenGL preview mode. This will make
the playback speed faster when running a heavy scene.

•

•

Rendering Order: This is where you can set the order that you want the particles to appear in the render.
•

Back to Front: Added particles will appear behind existing particles.

•

Front to Back: Added particles will appear in front of existing particles.

•

Oldest to Youngest: Older particles will appear behind younger particles.

•

Youngest to Oldest: Older particles will appear in front of younger particles.

•

Ascending Types: Lower types will appear behind higher types.

•

Descending Types: Lower types will appear in front of higher types.

Fix Output Alpha: This is an important checkbox to check when using some filters like Screen or Multiply
in the Blend Mode that can be specified in the Rendering tab of the Emitter. When working with premultiplied images, if the alpha is not fixed in the visualizer, you can get some strange artifacts.

Related Topics
•

Particle Effect Modules on page 1360
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Vortex

This particle allows you to define an axis as a vortex, so the particles will spin around this axis.

Layer Properties
Use the Vortex Module's Layer Properties panel to adjust the effect's parameters.
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•

Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

•

X Direction: Defines the X portion of the axis of rotation for the Vortex.

•

Y Direction: Defines the Y portion of the axis of rotation for the Vortex.

•

Z Direction: Defines the Z portion of the axis of rotation of the Vortex.

•

Radius: Defines the radius at the top of the vortex.

•

Exponent (1=cone): Defines a curve that gives the Vortex a certain silhouette. 1 forms a cone, greater
than 1 curves inward.

•

Up Acceleration: Defines the vertical acceleration of the particles that are inside the Vortex.

•

In Acceleration: Defines the inward acceleration of particles that are outside the Vortex.

•

Around Acceleration: Defines the acceleration around the vortex of particles that are inside the Vortex.

Related Topics
•

Particle Effect Modules on page 1360

Wind-Friction
This module allows you to define the amount of wind in the scene, and animate the wind over time.
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Layer Properties
Use the Wind Friction's Layer Properties panel to adjust the effect's parameters.

•

Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

•

Friction/Wind X: Defines the amount that the wind will dampen or increase the speed of the particles in
the X direction.

•

Friction/Wind Y: Defines the amount that the wind will dampen or increase the speed of the particles in
the Y direction.

•

Friction/Wind Z: Defines the amount that the wind will dampen or increase the speed of the particles in
the Z direction.

•

Min Speed: The minimum speed of particles that will be affected by the wind. Particles moving slower
than this will not be affected.

•

Max Speed: The maximum speed of particles that will be affected by the wind. Particles moving faster
than this will not be affected.

Related Topics
•

Particle Effect Modules on page 1360
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Previewing and Playing Back Effects
To preview your effects, you will have to perform a quick render. Effects must be calculated before they can be
viewed in real time.
To preview your effects:
1. In the Playback toolbar, press the Render and Play

button.

The Play module opens and loads the frames.

2. Once the frames are loaded, press the Play

button in the Play window.

Tip: While previewing effects, press [Spacebar] to stop and start playback.

Preview Resolution
To make your previews calculate faster, you may want to render them out at a smaller resolution. You can use
the Preview Resolution command so you will not have to modify the resolution of your scene every time you make
a check preview.
The Preview Resolution command allows you to quickly ask for a preview at either a quarter, half or threequarter of the scene resolution. You can even customize the preview resolution size.
To use the Preview Resolution command:
1. In the top menu, select View > Preview Resolution.
2. From the drop-down menu, select either Same as Scene Resolution, 3/4 of Scene Resolution, 1/2 of
Scene Resolution, 1/3 of Scene Resolution, 1/4 of Scene Resolution or Custom.
If you selected the Custom option, the Custom Preview Resolution dialog box opens.
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3. In the dialog box, select a resolution from the presets or type a new X-Y value.
4. Click on the OK button.
5. Preview your effects animation.

Related Topics
•

Previewing Effects on page 1211
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Extra Commands
These are some useful commands you can find only in Harmony.
Recalculate
All

Use the Recalculate All command to
refresh the network and re-render
the display when the Camera View
is in render mode.

In the select Network View menu,
select
Scene > Render > Recalculate All.

Recalculate
Selected

Use the Recalculate Selected
command to refresh the network
and re-render the display of
selected elements when the Camera
View is in render mode.

In the Network View menu, select
Scene > Render > Recalculate
Selected.

Auto Render
Write

Use the Auto Render Write
command to render a frame each
time the current frame is changed.

In the Network View menu, select
Scene > Render > Auto Render
Write.

You must have a Write module in
your network to use this command.
Print
Network

Use the Print Network command to
print the Network view.

Related Topics
•

Previewing and Playing Back Effects on page 1403
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Select File > Print > Network.
In the Network View menu, select
File> Print.
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Effects Preferences
Harmony has a series of preferences you can adjust to make you work more efficient.
•

General below

•

OpenGL on the facing page

•

Particles on page 1408

To open the Preferences panel:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

Press [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).

General

Options
•

Auto-Render: Automatically enables the Auto-Render option.
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OpenGL

Drawings
•

Enable Textures and Gradients in Drawings: Shows zones and lines painted with texture or gradient
colour pots. When disabled, zones and lines painted with textures and gradients will be filled with solid
colours. Enabling this option can slow performance as textures and gradients require more time and
memory to display.

•

Enable Stencil Buffer on Pencil Lines: When this option is selected, the pencil lines are displayed
normally. The lines will be opaque (unless there are transparencies). Disabling this option reduces
rendering times, but displays additive opacities for overlapping pencil lines and unevenly filled curved
pencil lines.

•

Enable Variable Line Thickness:

Effects
•

Enable Tone and Highlight: Turns the Tone and Highlight effects on and off in the Camera, Top and Side
views.

•

Enable Cutter: Turns the rendering of Cutter effects on and off in the Camera, Top and Side views.

•

Enable composite passthrough for all effects (requires relaunch): Control the behaviour of composite
passthrough in conjunction with effects that require a matte. This preference can be used in specific cases
where certain modules interfere with the OpenGL display of elements in the Camera view. This preference
is off by default.
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•

Enable Colour-Override: Turns the rendering of the Colour-Override effects on and off in the Camera,
Top and Side views.

•

Enable Glue: Turns the rendering of the Glue effects on and off in the Camera, Top and Side views.

Particles
You can find the following preferences for the Particle effects.

These preferences apply to the OpenGL preview.
•

Always Show Particles as Dots: If this preference is enabled, the particles will always be displayed as
dots in the OpenGL preview mode. This will make the playback speed faster when running a heavy scene.

•

Horizontal Resolution of Image Fracture Input: This is the size in pixels of the proxy bitmap image
rendered in OpenGL when using the Image Fracture particle. A smaller image size will increase the
playback speed when running a heavy scene.
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Chapter 20: Export

Now that you have finished your animation, it is time to render your movie. Depending on whether you plan to
further edit your movie in a third party software, composite the movie in a larger body of work or put it up
directly on the web, Toon Boom Harmony supports several formats for all your rendering needs.

Topics Covered
•

Exporting a QuickTime Movie on the next page

•

Exporting an SWF Movie (Flash) on page 1415

•

Exporting OpenGL Frames on page 1417

•

Exporting a Sound File on page 1419

•

Rendering Movies and Image Sequences on page 1421

•

Render Preferences on page 1444
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Exporting a QuickTime Movie
To export a QuickTime Movie:
1. From the top menu, select File > Export > Movie.
The Export to QuickTime Movie dialog box opens.

2. From the dialog box, click Browse and choose a destination path to where your movie will be saved and
an appropriate filename for the export.
3. Click Save when you are finished.
4. The Display Source section is where you can select which Display module you want to use to render out
your project. If there is no Display module in the scene, the drop-down list will indicate Display All and will
render out the scene in the same order as the Timeline view. It is always recommended to render out from
the Display module, located under the final Composite module, unless you want to render out a specific
section displayed by a particular Display module.
In the drop-down list, select the desired Display module.

Refer to Display Concepts on page 825 to learn more about Display modules.Select from the dropdown menu options for the type of streaming best suited for your needs.

5. From the Export Range section, decide whether you would like to export the entire scene (All) or just a
selected frame range. If you decide on the latter, be sure to enter in the frame range in the fields
provided.

6. In the Options section, click Movie Options.
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Parameter

Description

Video

Enables the customization of the video settings, filters and size

Settings

Opens the Standard Video Compression Settings dialog box (see below).

Filter

Opens the Choose Video Filter dialog box, where you can select from a range
of filters to apply to your video export.

Size

Opens the Export Size Settings dialog box. The size settings are overridden by
the Harmony's scene settings.

Sound

Check this box to enable the customization of the sound settings.

Settings

Opens the Sound Settings dialog box (see below).

Prepare for Internet Streaming

Check this box to enable the customization of the internet streaming options.

Internet Streaming dropdown

7. In the Video section, click Settings.
The Standard Video Compression Settings dialog box opens.
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8. From the Compression Type drop-down menu, select a codec.

The availability of certain Compression Settings depends on the Compression Type selected. For
example, Animation is the default compression type and as a result the Data Rate option is greyed
out.

9. In the Motion section, choose a Frame Rate from the list.
By default, it will be set to match the frames-per-second (fps) of your Harmony project. If you choose a
lower frame rate, your export play back will be faster than your actual project. The reverse is also true for
a higher frame rate.
10. From the same section decide whether you want key frames inserted by checking the Key frame every
box, and if so, the number per frame.
This is the option is recommended by QuickTime. A further description of this topic is cited below.
Many compressors use "frame differencing" to compress moving images.
Frame differencing is the process of determining what information has changed from a starting frame (called a
"key frame") to subsequent frames. The key frame contains all of the information for an image. Subsequent frames
contain only the information that has changed.
Depending on the compressor you use, you can specify how often you want key frames to occur. If you don't have
enough key frames, the quality of your movie might be lower because most frames are generated from others.
However, more key frames result in a larger movie with a higher data rate. With some compressors, an additional
key frame is inserted automatically if too much of the image has changed from one frame to the next.
A good rule of thumb for general use is to have one key frame every 5 seconds (multiply the frames per second by
5). If you are creating a file for RTSP streaming and have concerns about the reliability of the delivery network (as
with the public Internet), you may want to increase key frame frequency to one key frame every 1 or 2 seconds.

11. In the Compressor section, choose a Depth based on your movie’s needs, for example, Millions of
Colours+ houses an alpha channel.
12. In the Quality section, use the slider to choose a quality setting. Remember that the better the quality of
the export, the larger the file.
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13. From the Data Rate section, either choose to allow the program to automatically select the most optimal
bit rate, or enter in a Restricted rate to save space and allow for faster downloading at a cost to the
quality of your export.
14. In the same section, from the Optimized for drop-down list, select the intended viewing method for your
export.
15. Click OK.
16. From the Movie Settings dialog box, click Sound Settings.
The Sound Settings dialog box opens.

17. From the Compressor drop-down menu, select a compression type.
The default setting is None. This will preserve your original sound file, without the loss of information.
However, an uncompressed sound file will inevitably add “weight” to the overall size of your video
export.
18. Select a Rate by pressing the down arrow button next to kHz.
It is best to check and match the original properties of your sound file. For example, if your file has an
audio sample rate of 48 kHz and you choose a conversion rate of 22.05 kHz, the sound will play at the
same speed, but with higher frequencies missing.
For a standard film sound quality, choose 44.1 kHz, or 48 kHz for DVD quality. Anything less will make
the sound “dull” or less bright. For things like recorded voice this doesn't matter so much, but for music it
can make an audible difference.
If file size is a consideration, such as with videos for the internet, then a lower rate might be more
practical.
19. Next, choose the Size and the Use, which are related. Once again, it is advisable to check your original
sound file properties. If the file was recorded in one channel (mono), there is little point in choosing the
two channel (stereo) option.
Although Mono can support a 16-bit channel, the extra information is unnecessary. Mono is generally
paired with 8-bit and Stereo with 16-bit.
20. Click OK.
21. In the Export to QuickTime Movie dialog box, click OK.
A progress bar appears.

22. Browse to the location on your computer where you saved your QuickTime video and double-click on it to
view your export.
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If your exported video is too small or too large, you can change your project size from the top menu
(Scene > Scene Settings). This will change the size of the video output.

Related Topics
•

Exporting a QuickTime Movie with Transparency below

•

Export on page 1409

Exporting a QuickTime Movie with Transparency
To render out a QuickTime movie with transparency, you need to set the Depth to Millions of Colours +.
To set the depth to Millions of Colours:

‣ In the Standard Video Compression Settings dialog box, select Millions of Coulours from the Depth
drop-down menu.

Refer to Exporting a QuickTime Movie on page 1410 to learn how to access the Standard Video
Compression Settings dialog box.

Related Topics
•

Exporting a QuickTime Movie on page 1410

•

Export on page 1409
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Exporting an SWF Movie (Flash)
The SWF export supports both bitmap effects (which can be previewed in Render View
Blend Modes (vector effects which can be previewed in OpenGL View

mode) and SWF

mode).

The following are also supported:
•

Pencil line thickness: They are converted to brush strokes in the SWF file.

•

Auto Patch module for creating joint patches.

If you have not already done so, you should preview the SWF by using the SWF preview

button to see what

the two types of effects look like when blended together. Once you are satisfied with the results, go ahead and
export your movie.
To export a SWF movie:
1. From the top menu, select File > Export > SWF.
The Export to Flash Movie (SWF) dialog box opens.

2. To choose an appropriate file name and a destination path where your movie will be saved to, from the
dialog box, click Browse.
3. In the Display Source section, select which Display module to read from in the Export From Display
Module drop-down menu.
4. In the Export Range section, select one of the following options:
‣

All: To export all the frames of your movie.

‣

Frames: To export a frame range. Enter the frame range in the fields provided.
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5. In the Options section, enter your Frames rate (fps) into the field provided. By default, it will be set to
match the fps of your Harmony project. If you choose a lower frame rate, your export playback will be
faster than your actual project. The reverse is also true for a higher frame rate.
6. In the same section, select the JPEG quality.
‣

100 = Full quality

‣

50 = Average quality at about 1/5th of the size.

‣

25 = Medium quality where loss of high image resolution starts to occur.

‣

10 = Low quality where “macro-blocking” or large pixelation become obvious.

‣

1 = Lowest quality where there is extreme loss of colour and detail and where the image becomes
nearly unrecognizable.

7. If you want to prevent your movie from being imported in another application, select the Protect from
Import option.
8. Select the Compress Movie option if you want to get a lighter format. The movie may lose some quality,
but the file will be lighter.
9. In the Disabled Effects section, select the options of the vector-based effects that you do NOT want to
see in the SWF render.
Note that certain Harmony effects will not be listed in this section as they are not vector-based and
therefore not available for SWF export. These effects will not appear in the SWF render.
10. Click OK.
11. Browse to the location on your computer where you saved your Flash Movie and double-click on it to view
your export.

Related Topics
•

Export on page 1409
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Exporting OpenGL Frames
Use the Export OpenGL Frames dialog box to select the frames you want to render from the OpenGL Camera
view, then save the rendered frames as image files or as a QuickTime movie.

Frames saved from OpenGL view have neither anti-aliasing nor special effects. To render final frames
with effects, export Images or a Movie.

To export OpenGL Frames:
1. From the top menu, select File > Export > OpenGL Frames.

2. In the Output section, in the Location field, click Browse to select a folder for the frames.
3. In the Filename field, enter a name (prefix) for the frames or revert to the default name by clicking Default.
4. In the Format section, decide if you want to export individual image frames or a movie.
‣

Suffix: From the drop-down list, select the desired suffix. If you intend to render only a few frames, you
might decide to go with 1 or 01, whereas if you intend to render 1000 frames you might choose to
select 0001.

‣

Drawing Type: From the drop-down list, select the file type you want to render, such as TGA or SGI.

5. In the Movie section:
•

Movie options: Click on this button to customize the Audio and Video settings for the *.mov export.

Refer to Exporting a QuickTime Movie on page 1410 for a more detailed description of the Movie
options.
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6. From the Resolution section, select the resolution you would like for your export. If you are running some
quick tests, then you might want to cut down the resolution to save time and space. You also have the
option to set a Custom width and height to produce smaller or larger frames.
7. In the Range section, decide whether you want to render all your frames, a range of frames, the current
frame or selected frames.
8. Click OK.

Related Topics
•

Export on page 1409

•

Exporting a QuickTime Movie on page 1410
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Exporting a Sound File
At some point during the production, you might need to export your sound file to use it in another application
such as an editing software. Harmony allows you to export your sound files either as a merged soundtrack, or as
a series of individual files. The exported soundtracks are generated as *.wav files.

To export a soundtrack:
1. In the top menu, select File > Export > Soundtrack.
The Export Soundtracks dialog box opens.

2. In the Output section, click on the Browse button to select where you want to save the exported sound
file.
3. In the Export Range section, enable the All option if you want to export the sound over all the frames of
your scene, or enable the Frames option and set the start and end frames in the corresponding fields on
the right hand side.
4. In the Options drop-down menu, select one of the following options:
‣

Process Soundtracks Individually: Select this option if want each soundtrack from all layers to be
exported as individual files.

‣

Merge all Soundtracks: Select this option if you want Harmony to create one single sound file
combining all the sound files you imported in your scene. Note that it will only use the sound files used
in the selected frame range set in the Export Range section. If you selected to export all the frames, all
the sound files will be processed.

5. In the Sound Settings section, set the Rate, Size and Use parameters for the soundtracks to export. It is
a good idea to verify what is required by the software, or device, that you might next want to use the
sound file with.
6. Click on the OK button to export your sound file.
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The generated sound files appear in the selected directory and are named according to the scene name.
Individual files will keep their original name; only a prefix matching the scene name is added.

Related Topics
•

Importing a Sound File on page 905
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Rendering Movies and Image Sequences
The Network view allows you to make advanced connections and isolate certain portions of your project, it also
allows you to do multiple exports either from the entire network or specific sections.
For such a process, use the Write module in the Module Library view.

Related Topics
•

Write Module below

•

Multiple Renders on page 1426

•

Rendering Images and Movies from the Network on page 1436

•

Export on page 1409

Write Module

The Write module lets you render and output the connected image information.
To add a Write module:
1. In the Module Library, select the IO tab.
2. Select the Write module and drag it to the Network view.

3. In the Network view, connect either the final Composite module or any other module which outputs an
image you want to render to the Write module.
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Using the Write module, you can export your project in both QuickTime movie and image sequences. You can
export one format at a time, or both simultaneously.
•

Image Sequences below

•

QuickTime Movie on page 1424

Related Topics
•

Export on page 1409

•

Rendering Movies and Image Sequences on the previous page

•

Image Sequences below

•

QuickTime Movie on page 1424

Image Sequences
To export an image sequence, you need to adjust a few settings in the Write module’s properties.
You can export your image sequences as several different formats:
•

TVG
TVG (Toon Boom Vector Graphic) is the Toon Boom vector proprietary format.

•

TGA (TGA1, TGA3, TGA4)
Select TGA4 to export your sequence with an alpha channel (transparency).

•

SGI (SGI1, SGI3, SGI4)
Select SGI4 to export your sequence with an alpha channel (transparency).

•

SGIDP (SGIDP1, SGIDP3, SGIDP4)
Select SGIDP4 to export your sequence with an alpha channel (transparency).

•

OMFJPEG

•

PSD (PSD1, PSD3, PSD4)
Select PSD4 to export your sequence with an alpha channel (transparency).

•

PSDDP (PSDDP1, PSDDP3, PSDDP4)
Select PSDDP4 to export your sequence with an alpha channel (transparency).

•

YUV

•

PAL

•

SCAN

•

PNG (PNG4)
Select PNG4 to export your sequence with an alpha channel (transparency).

PNG4 is the recommended format to export an image sequence with transparency.
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•

JPG

•

BMP (BMP4)
Select BMP4 to export your sequence with an alpha channel (transparency).

•

IFF (IFF_16)

•

OPT (OPT1, OPT3,OPT4)
Select OPT4 to export your sequence with an alpha channel (transparency).

•

VAR

•

TIFF

•

DPX (DPX3_8, DPX3_10, DPX3_12, DPX3_16, DPX3_10_INVERTED_CHANNELS, DPX3_12_INVERTED_
CHANNELS)

•

PDF

The formats used if you need to output a vector format are TVG and PDF. You can also export a SWF
movie.

To set the Write Module to export an image sequence:
1. In the Network view, open the Write module’s editor by clicking its Properties button.

2. In the Output tab, select the Drawing option to create an image sequence.

3. Click Choose and browse to the directory where you want to save the output.
‣

You can also use the default directory to save in the default Frames folder included in the scene
directory.
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4. In the Filename field, type the image sequence’s name prefix. It is very important to leave the hyphen (-) at
the end of the name to separate the image name from the image number.

5. In the Start field, select the starting number for the image sequence.
6. In the Leading Zeros field, select the number of digits you want to see after the sequence prefix.

7. In the Drawing Type field, select the file format in which your project will output.

When the file format includes a "4" at the end of its name, it means that an alpha channel will be
created.

8. Click Close.
The project will not start rendering yet, since these are only the settings. You can still modify your scene.

Related Topics
•

Rendering Movies and Image Sequences on page 1421

•

Write Module on page 1421

•

QuickTime Movie below

QuickTime Movie
To export a QuickTime movie, you need to adjust few settings in the Write module’s Properties.
To export a QuickTime movie from a Write module:
1. In the Network view, open the Write module’s editor by clicking on its Properties button.

2. In the Output tab, select the Movie option to create a movie file.
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3. Click Choose and browse to the desired directory to save the output.
‣

You can also use the default directory to save in the default Frames folder included in the scene folder.

4. In the File name field, name the output file. You do not need to write the file format extension.

5. In the Movie Options field, click Customize to open the Movie Settings dialog box.

6. In the Movie Settings dialog box, in the Video section, click the Settings button to set your video options.
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7. Click OK.
8. In the Movie Settings dialog box, in the Sound section, click Settings to set your audio options.

9. Click OK and Close.
The project will not start rendering yet. These are only the settings. You can still modify your scene.

Related Topics
•

Rendering Movies and Image Sequences on page 1421

•

Write Module on page 1421

•

Image Sequences on page 1422

Multiple Renders
Harmony lets you simultaneously render many formats and resolutions for a scene. This saves a tremendous
amount of time as you do not have to return between each render to start a new one.
To use multiple renders, connect as many Write modules as needed to match the required number of exports.
Then, adjust each Write module’s settings to create image sequences or movies.

YOU MUST GIVE DIFFERENT NAMES TO EACH OUTPUT FILE. This is especially important if you save
them all in the same folder, so they do not overwrite each other.
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When you have multiple Write modules in a scene, it is useful to rename them according to their output settings
such as: low_resolution_movie or HDTV_sequence.

Related Topics
•

Modules Used to Export to Different Resolutions below

•

Connecting the Required Modules on page 1433

•

Rendering Movies and Image Sequences on page 1421

•

Write Module on page 1421

•

Rendering Images and Movies from the Network on page 1436

Modules Used to Export to Different Resolutions
To export different resolutions concurrently, you need to create a combination of:
•

Write Module below

•

Scale-Output Module below

•

Crop Module on page 1429

Write Module
To learn more about the Write module, refer to the following sections:
•

Write Module on page 1421

•

Multiple Renders on the previous page

Related Topics
•

Rendering Movies and Image Sequences on page 1421

•

Modules Used to Export to Different Resolutions above

•

Scale-Output Module below

•

Crop Module on page 1429

Scale-Output Module

Once your Write modules are connected, you need some Scale modules to change the resolution output of the
Write module. For example, if you export in a high resolution and a low resolution, you need one Scale-Output
module.
Set the project’s resolution to the highest resolution needed for this export and use the Scale-Output modules
to scale down the other outputs.
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DO NOT scale up the output size, that will not provide a good result. It is also better to use the ScaleOutput module to scale down in a same aspect ratio so that it does not distort the image.

To add a Scale-Output Module:
1. In the Module Library view, select a Scale-Output module and drag it to the Network view.

2. In the Network view, connect the Composite module to the Input port of the Scale-Output module.

3. In the Network view, connect the Scale-Output module to the input ports of both the Display module and
the Write module.
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To set the Scale Module:
1. In the Network view, open the Scale-Output module’s editor by clicking on its Properties button.

2. In the Layer Properties dialog box, select a resolution from the suggested Resolution Name list or type
new resolution values to indicate the resolution to scale to.

3. Click Close.

Related Topics
•

Rendering Movies and Image Sequences on page 1421

•

Multiple Renders on page 1426

•

Modules Used to Export to Different Resolutions on page 1427

•

Write Module on page 1427

•

Crop Module below

Crop Module
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To output two files with different aspect ratios, such as 16:9 and 4:3, you can use the Crop module. This module
is used to crop the final image in order to discard excess information without distorting the render.

If you start with a higher resolution and want to crop down to a lower resolution, such as HDTV to
NTSC, you will need to combine the Crop module with a Scale module.

To add a Crop Module:
1. In the Module Library view, select a Crop module and drag it to the Network view.

2. In the Network view, connect the Composite module to the Input port of the Crop module.

3. In the Network view, connect the Crop module to the input ports of both the Display module and the
Write module.
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To set the Crop Module:
1. In the Network view, open the Crop module’s editor by clicking on the module’s Properties button.

2. In the Layer Properties dialog box, type new resolution values to indicate the resolution to crop to.

3. You can manually enter the X -Y Offset, or move it in the Camera view. Select the right Display module in
the Display toolbar. In the Advanced Animation toolbar, select the Translate
tool and with the middle
mouse button, move the crop area. If the Animate

mode is enabled, the position of the crop area will

be animated over time.
4. If you want to create a Pan and Scan effect (panning the cropped selection over time to show more
information), you can create a function to animate the cropped selection. Click on the Function Arrow
button beside the Local dialog box to create a Bezier or ease curve.
5. If you created a function curve to animate the cropped selection, click again on the Function
and edit the curve by adding keyframes and moving the selection box in the Camera view.
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6. Enable the Draw Frame option if, instead of cropping the images, you prefer to have Harmony draw the
frame over the rendered scene.

7. Click in the colour rectangle to adjust the frame colour as desired if you have enabled the Draw Frame
option.

8. Click on the Close button.
The Crop module also has an advanced Enabling tab. Use the Enabling tab to determine when the Crop module
should be activated.

•

Always Enabled: Select this to have the Crop module always produce output.

•

Enabled when resolution name is: Select this to activate the Crop module only when the resolution of
the scene matches the value selected from the Filter Name menu. These listed resolutions come from the
Resolution/Frame Rate dialog box.

•

Enabled when resolution is: Select this to activate the Crop module whenever the scene’s resolution
matches the values entered in the X resolution and Y resolution fields.
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Related Topics
•

Rendering Movies and Image Sequences on page 1421

•

Multiple Renders on page 1426

•

Modules Used to Export to Different Resolutions on page 1427

•

Write Module on page 1427

•

Scale-Output Module on page 1427

Connecting the Required Modules
Once you know the type of render you want to do, you will need to retrieve your modules from the Module
Library and connect them to the scene’s network.
To connect multiple renders:
1. In the Module Library view, retrieve the necessary Write, Scale-Output and Crop modules.

2. Connect the final Composite module to the first Write module. (Make sure that you have a Display
module reading the same information.)
3. Open the Write module’s Editor by clicking on its Properties button.
4. Name the Write module according to the render type that you are planning to do.
5. Set the Write module parameters.
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6. Connect the other Write modules and repeat Step 2 to Step 5.

7. Using the [Alt] key, insert the Scale-Output modules between the final Composite module and their
corresponding Write module.

8. Using the [Alt] key, insert the Crop modules between the final Composite module and their corresponding
Write or Scale module.
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‣

If the output from the Crop module has to be scaled down, use a Scale-Output module.

9. Connect a Display module to each Scale-Output or Crop module to be able to see each final image in your
Camera view.
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Related Topics
•

Rendering Movies and Image Sequences on page 1421

•

Multiple Renders on page 1426

Rendering Images and Movies from the Network
If you want to render from your Write module, you will need to use the Render Network option found in the File
menu.
To render from the Write module:
1. Select File > Export > Render Network or press [Ctrl] + [Shift] + [Y] (Windows/Linux) or [⌘ ] + [Shift] + [Y]
(Mac OS X).

(Stand-alone mode)
2. In the Range section, select the frame range to render.
3. Select the Preview option if you want to automatically see the image sequence result once the render is
done. (The preview will not show up for a QuickTime movie.)
4. Select the Field Composite option if you want Harmony to render the final images as fields for display on
interlaced monitors.
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5. Click OK.
All renders start.

When working with Harmony in Database mode, you can send your scene to batch processing and to
a render farm, see Batch Rendering below

Related Topics
•

Rendering Movies and Image Sequences on page 1421

Batch Rendering
To render your scene you must first choose the type of rendering and then set the rendering parameters.
There are two ways to render out scenes using the Harmony Solution:
•

Local Rendering is is done directly on the user machine using its CPU. To perform local rendering you
must use Harmony Stage.

•

Batch Rendering lets you send a scene to render while you continue working in Harmony Stage. This way,
you do not have to wait for the application to complete the render process.

Batch rendering is a background process divided over several machines, or a render farm. Sending your scene to
batch render will share the rendering load with other machines in the render farm and lessen the amount of work
required by your computer.
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The parameters for the format and file type to render are set in the Write modules contained in your
scene's Network view. Before sending your scene to batch rendering, make sure to set the Write
modules to export in the proper location, and set the format parameters. Note that you can have
more than one Write modules in your scene if you require several exports.

Related Topics
•

Write Module on page 1421

•

Sending a Scene to Batch Render from Harmony Stage below

Sending a Scene to Batch Render from Harmony Stage
To send a scene to the batch rendering queue:
1. Save all of the contents of your scene, all drawings, colour palettes and the palette list. Select File > Save
. The [Ctrl] + [S] (Windows/Linux) or [⌘ ] + [S] (Mac OS X).
2. Select File > Export > Render Network. The [Ctrl] + [Shift] + [Y] (Windows/Linux) or [⌘ ] + [Shift] + [Y]
(Mac OS X).

If the System Administrator did not complete the resolution configuration tasks, a warning message
will open. This message notifies you that the resolution.conf file was not properly inserted in the
configuration folder.

3. Click on the OK button to continue. You will still be able to render your scene.
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The Render Network dialog box opens.

4. Select the frames you want to render:
‣

All Frames: send all the frames in the scene to be rendered

‣

Selected Frames: sends a range of frames to be rendered.

5. Enable the Batch Composite option.
‣

Select the Chunk checkbox if you want to split the frames into sets of frames, or QuickTime movie into
little chunks. Note that when the render farm (server) will be done rendering all of the little movie
chunks, it will put them all back together to create one single movie file.

‣

Enter the number of frames for each chunk in the Size (Frames) field. For example, if your scene is 100
frames long and you enter a value of 20, there would be five entries in the queue of 20 frames each.

‣

Select the camera you want to use to render the scene's images from the Camera drop-down list.
These are the Camera modules you created in your scene.

6. Enable the Field Composite Options checkbox if you want to create a field composite, to refine your
selection.
‣

Select the Add Pull-down option to use the 3:2 pull-down technique.

‣

Select the Automatic Combine option to combine even and odd fields on a scene's images.

‣

Select the Second Field First option to always start with the second field before combining with the
first.

7. Click OK to start the rendering process.
A confirmation dialog box opens to inform you that the frames have been sent to the render queue.

1439

Chapter 20: Export Rendering Movies and Image Sequences

‣

If the selected frames were already sent to the render queue, a notification dialog box opens to inform
you that these frames were already in the queue, but that they have been updated with the latest
rendering request.

You can also send scenes to batch rendering and check the status of the rendering queue from the Control
Center module.

Refer to the Control Center and Server Guide to learn how to send scene to batch render and how to
check the status of the rendering queue.
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Partitioning Your Renders
By partitioning renders, you can separate the elements of a scene or character, and render them separately
according to group and Z position. This is useful when you want to export part of a character or scene in
Harmony so you can add effects and create the final composite using a different software application.You can
export part of a character or scene in Harmony and then use other software applications to add

Groups and Partitions
Using the Write module, you can partition the rendering of images based on group and Z position. First, you
determine which groups you want to render. Groups are what you connect to a Composite module in the
Network view. Then you define the render by their Z position.
The Z position is based on fields. Each field is equal to one partition, which is centered on the absolute value of
the range you define. Each partition yields a separate folder that contains your exported, rendered image.
To export images based on group and Z position:
1. In the Module Library, select the IO tab.
2. Select the Write module and drag it to the Network view.
3. In the Network view, attach the groups you want to render to a Composite module.
In the following example, there are three groups connected one Composite module. They will be
rendered simultaneously, producing three separate folders to hold the renders. If you have more groups,
you can go ahead and connect them to them if you want to render them. Otherwise, disconnect the ones
you don't want to render.

4. Display the Write module properties. Select the Output tab and set the following:
‣

Drawing Folder: Type in a name for the folder that will hold the renders.

‣

Drawing Filename: Type in a prefix for the names of the subfolders.
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5. Select the Partitioning tab.

6. Set the following:
‣

Composite Partitioning: Select Group and Z Partitioning.

‣

Z Partition Range: Define the range of the partition. In our example, the range was set to 3. This will
create three folders for the renders.

‣

Clean up partition folders: Selected.

7. Start the render by selecting File > Export > Render Network or press [Ctrl] + [Shift] + [Y]
(Windows/Linux) or [⌘ ] + [Shift] + [Y] (Mac OS X).
8. To see your renders, navigate to the Drawing Folder you defined in step 4.

Write Module, Partitioning Tab Properties
Parameter

Description

Composite Partitioning

Off: Renders the entire network and places separate images of the composite
in the Drawing Folder.
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Group and Z Partitioning: Creates multiple renders and places them folders
that correspond to their group in the Network view.
Z Partition Range

Based on the Z position, defines the range of the partition, centered on the
absolute value.
When selected, removes the old folders from the Drawing Folder each time
you perform an export.

Clean up partition folders
When deselected, each time you render, more folders are added to the
existing ones.
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Render Preferences
In Harmony, you will find preferences related to the rendering under the Render tab.
To open the Preferences panel:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

Press [Ctrl] + [U] (Windows/Linux) or [⌘ ] + [U] (Mac OS X).

Preview Options
•

Enable Blur: Renders blur effects derived from the Blur-Directional Module, Blur-Radial Module, and the
Blur-Variable Module in the Render View window.

•

Enable Line Texture: Renders line texture in the Render View.

•

Enable Focus: Renders focus effects from the Focus-Apply and Focus-Set modules.

Image Management
•

Image Memory Limit (MB): During soft rendering, Harmony produces intermediate images. Roughly one
image per module per frame. This process is called rendering steps. These produced images can come to
hold considerable amount of memory and they are discarded once they are of no use in the rendering.
Specifying a maximum memory limit in this field will discard the image once it reaches this limit.

•

Enable Image Disk Caching: When this option is enabled, the images will be off-loaded to disk instead of
being erased from memory. The off-load process occurs as soon as the image is no longer used during
the current frame rendering, instead of waiting for the memory limit to be reached. This way, images do
not need to be recalculated and instead, they are automatically restored from disk, considerably
speeding up the interactive rendering process.
During batch rendering, off-loading the image to disk after each usage reduces the average memory
(RAM) usage.
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Cache Options
When the Enable Image Disk Caching option is enabled, the following becomes available:

•

•

Cache Path and Capacity in MB:
•

If this field is left empty, Harmony's temporary directory will be used to off-load intermediate images.
There is no disk usage limit for the temporary directory.

•

When you specify a folder, you must type in the capacity (in MB) inside the path. Use the following
method: path;capacity in MB;
ex: C:\user\tmp_image_folder;2000;
Note: The specified folder must already exist. If there is an error in the path, Harmony’s temporary
directory will be used. You can also specify a RAM drive in the path.

Proactively Cache Images When Unused For Subsequent __ Steps: This option will allow off-loading of
intermediate images if they are unused for the specified number of steps.
•

A value of 0 disables the option.

•

A value of 1 forces the off-load of all images immediately after their creation and usage.

•

The recommended value is 50.

•

If you are using a fine resolution of 2k pixels or more, the specified value should be smaller.

•

Small networks should not use this feature.

Multi Threading

The Multi Threading preference is used to specify the level of parallel processing done during the final image
calculation (soft-rendering). Allowing parallel processing speeds up the soft-render process. You can specify the
number of parallel processes in the Number of Rendering Threads field:
•

Entering a thread number value of 1 disables the multi threading process because it specifies that only
one rendering thread will be used during the process.

•

The maximum number of threads value is 64.

•

The recommended starting value is 2 threads per CPU core. Meaning that if you are using a 2 Quad Core
CPU, the preferences should initially be set to 16 threads.
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Related Topics
•

Export on page 1409
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Chapter 21: Keyboard Shortcuts for
Harmony
This document lists default keyboard shortcuts for Harmony.

The Harmony keyboard shortcuts set is used throughout the Harmony documentation.

To use a shortcut, press the key and the character simultaneously. The sign + sign is not part of the sequence. If
there is no shortcut allocated to a command it is left blank.

General
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D
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CUSTO
M
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Win/Linux
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Win/Linux

Mac OS X
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Auto
Render
Write

Ctrl+W

⌘ +W

Ctrl+W

⌘ +W

Boundin
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Selection

Ctrl+Alt+Shift+B

⌘ +Alt+Shift+B

Add
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Add
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Add
Frame At
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⌘ +Alt+,

Ctrl+Alt+,

⌘ +Alt+,

Shift Trace
Scale Tool
Shift Trace
Toggle
Manipulator
Shift Trace
Toggle View

Show Scan
Info Panel
Show
Strokes
Show
Symbol
Pivot

Smooth
Editor Tool
Snap and
Align
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Drawing Mode
COMMAND

FLASH

CUST
OM

HARMONY

Win/Linux

Mac OS X

Win/Linux

Mac OS X

Snap to
Contour

Ctrl+Alt+;

⌘ +Alt+;

Ctrl+Alt+;

⌘ +Alt+;

Snap to
Grid

Ctrl+Alt+'

⌘ +Alt+'

Ctrl+Alt+'

⌘ +Alt+'

Alt + Shift + K

Alt + Shift +
K

Split Pencil
Line
Stroke Tool

Alt+/

Alt+/

Alt+V

Alt+V

Switch to
Line
Art/Colour
Art

L

L

L

L

Switch To
Overlay/Un
derlay Layer

:

:

:

:

Text Tool

Alt+T

Alt+T

Alt+9

Alt+9

Toggle
Backlight

Ctrl+Shift+
C

⌘ +Shift+
C

Alt+Shift+B

Alt+Shift+B

Toggle
Morphing
Key
Drawings

F4

F4

F4

F4

Toggle
Protect
Colours

Shift+S

Shift+S

Shift+S

Shift+S

Ungroup

Ctrl+Shift+
G

⌘ +Shift+
G

Ctrl+Shift+G

⌘ +Shift+G

Alt+U

Alt+U

Suggest
Morphing
Hints

Toggle Line
Building
Mode

Unpaint
Tool
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Drawing Mode
COMMAND

Zoom Tool

FLASH

CUST
OM

HARMONY

Win/Linux

Mac OS X

Win/Linux

Mac OS X

Alt+Z

Alt+Z

Alt+Z

Alt+Z

Function Editor
COMMAND

FLASH

HARMONY

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

Edit Next
Function

PgDown

PgDown

PgDown

PgDown

Edit Previous
Function

PgUp

PgUp

PgUp

PgUp

Insert Point

I

I

I

I

Select Left
Handle

[

[

[

[

Select Right
Handle

]

]

]

]

Toggle Grid

G

G

G

G

Toggle StopMotion
Segment

S

S

S

S

Zoom In X

4

4

4

4

Zoom In Y

6

6

6

6

Zoom Out X

3

3

3

3

Zoom Out Y

5

5

5

5

Lock/Unlock
Point

1479

Chapter 21: Keyboard Shortcuts for Harmony

Library
COMMAND

FLASH

HARMONY

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

F5

F5

F5

F5

Details
List
Refresh
Rename
Thumbnails

Tagging
COMMAND

FLASH
Win/Linux

HARMONY
Mac OS X

Win/Linux

CUSTOM
Mac OS X

Tag Selection
Untag All
Untag All Others
Untag Selection

Tool Presets
COMMAND

FLASH
Win/Linux

HARMONY
Mac OS X

Win/Linux

Tool Preset
Shortcut #01
Tool Preset
Shortcut #02
Tool Preset
Shortcut #03
Tool Preset
Shortcut #04
Tool Preset
Shortcut #05
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Tool Presets
COMMAND

FLASH
Win/Linux

HARMONY
Mac OS X

Win/Linux

CUSTOM
Mac OS X

Tool Preset
Shortcut #06
Tool Preset
Shortcut #07
Tool Preset
Shortcut #08
Tool Preset
Shortcut #09
Tool Preset
Shortcut #10

Deformation
COMMAND

FLASH
Win/Linux

HARMONY
Mac OS X

Win/Linux

Add Articulation
Module
Add Bone
Module
Add Curve
Module
Add
Deformation
Composite
Module
Add Offset
Module
Add Root
Module
Convert Elliptic
ROI to Shape
Show Current
Deformers
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Particle
COMMAND

FLASH
Win/Linux

HARMONY
Mac OS X

Win/Linux

Show Particles
as Dots
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Index
2D
2D-3D Integration 875
Layer 2D Option 887
3D
2D-3D Integration 875
3D Model Project Directory 895
3D Object Animation 879
3D Object Rotation 889
3D Object Texturing 879
3D Option 888-890, 892
3D Rotate Tool 889
3D Scale Tool 890
3D Space 848, 887
3D Transform Tool 892
3D Translate Tool 888
Elements 885
Enable 3D 848, 887
Environment 884
Environment Variable 898
Exporting a 3D Object for Harmony 879
Import 3D Model 882
Importing a 3D Object from Autodesk Maya 882
Maya Script for Mac 898
Model 885
Network View Set Up 899
Parameter 894
Perspective View 889-890
Positioning 3D Object 883, 887
Preview 3D Model in Camera View 883
Shaders 879
Transformation Tool 888
About
computer generated interpolation 1071
importing master template 1031
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Index

swapping images 1092
Add
Create Drawing From Drawing Selection 730
adding
new drawing 1096
Adding
Add Colour 123
Add Drawing Layer 113
Add Layers 113
Add Peg 113
Adding a New View 130
Ghost Drawing 743
Hierarchy 707, 711
Keyframe 710
Peg 704
Pivot 717
Pivot on Frame Range 757
Symbol 748
adjusting
Pencil Line Thickness 229
velocity 1072
adjusting velocity
Function view 1072
Alignment
Model 667
Anchor
Direction Arrows 888
Rotation Ellipse 893
Scaling Rectangle 890
Animating
in stop-motion 1069
Animation
3D Object 879, 887
Advanced Animation Toolbar 100, 888
Animate Mode 888
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Mix Animation 673
Axis 890-891
Axes 888
Default Separate Position 675
Z axis 692
Batch Processing
Maya Batch 899
Bitmap
Breakdown 668
Image 667
Photo Puppet 668
Picture 667
Breakdown
Adding to Existing Layer 736
Brush
Auto-flatten 740
Brush Size 670
Convert Brush Strokes to Pencil Lines 751
Flatten 741
Set Current Brush Colour 124
Camera
Camera View 102, 884
Camera View Options Menu 105
Drawing Name 109
Editing Stack Menu 109
Frame Number 109
Matte View Mode 105
OpenGL Mode 884
OpenGL View Mode 104
Render Mode 885
Render View Mode 104
Toggle Quick Close-Up 108
Tool Name 109
Update Preview 103
Zoom Drop-down Menu 107
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Index

Camera View Toolbar 101
Preview 3D Model in Camera View 883
Render View Mode 899
Safe Area 667
Symbol Hierarchy 700
Camera View 102
Cell
Cut-out Model 668
Character
Breakdown 682, 733
Extra View 736
Building a Character 665
Classic Joint 686
Fixing Joint 686
Importing a Model 667
Joint 738
Line Up 669
Clean Up
Cut-out Puppet 739
Remove Extra Strokes 687, 741
Close
Closing a View 131
Colour
Alpha 744
Colour Art Module 754
Colour View 122
Add Colour 123
Add Texture 124
Colour Swatch 126
Colour Swatch Name 125
Colour View Menu 126
Link/Unlink Three Colours 125
Remove Colour 123
Set Current Brush Colour 124
Set Current Paint Colour 125
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set Current Pencil Colour 124
Show/Hide Palette List View 125
Current View Border 147
Current View Border in Template Edit 147
Colours
Camera 148
Drawing 148
Edit Colours Button 147
Exposure Sheet 148
Network 148
Composite
Rigging 706
Compositing
3D Model 895
Composite Module 693, 705-706
Pass Through 723
Composite Type 723
Module Library 706
Network View 895
Scene 899
Connecting
3D Object 883
Module 900
Contour
Show Stroke 687, 741
Control Point 891
Control Point Toolbar 100
Scaling Control Point 893
convert
motion keyframe to stop-motion 1069
pencil to brush 225
Coordinate
Coordinate Toolbar 100
Copying
Copying Pivot on Parent Symbol 287
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Index

Duplicate Drawing 715
creating
motion keyframes 1071
Cut-out
Breakdown 730, 733
Brush Size 670
Building a Character 665
Classic Joint 686
Eyelids and Pupils 671
Fixing Joint 686
Hand 672
Importing a Model 667
Line Up 669
Logo 674
Master Template 726
Model 671
Model Alignment 667
Mouth 672
Naming Convention 677
Photo Puppet 668
Piece Overlap 674
Relative Size 669
Separate Position Path 675
Cutting
Breakdown 730
Create Drawing From Drawing Selection 734, 737
Cut-out Piece Clean Up 739
Cut Artwork From Source 732, 737
Cutter Tool 731, 733, 736
Intersection 734
Deformation 1111
About 1112
creating full turnaround rig
preparation 1154
Deformation Toolbar 1139
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Module
Articulation 1115
Auto-muscle 1118
Bone 1113
Curve Deformer 1113
Deformation-autofold 1118
Deformation-composite 1121
Deformation-root 1123
Deformation-scale 1123
Deformation-switch 1126
Deformation-uniform-scale 1127
Deformation-wave 1128
Fold 1131
Offset 1133
Zones of Influence 1176
setup zone of influence fade radius 1184
Delete
Colour View 123
Delete Layers 113
Remove Extra Strokes 687
Deleting
Deleting a Workspace 141
Disable
Enable/Disable All 112
Display
Display Module 721
Display Toolbar 100
Global Display 721
Distribute to Layer 227
Drawing
Adding Extra Drawing to a Template 759
adding new 1096
Adding to Existing Layer 736
Create Drawing From Drawing Selection 730, 734, 737
Cut Artwork From Source 737
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Drawing Exposure 119
Drawing Substitution 117, 744
Drawing View 100
Drawing View Toolbar 101
Duplicate Drawing 715
duplicating 1096
Extra Drawing 714
Ghost Drawing 743
Naming 677
Pivot 716, 757
Rename Drawing 678
Rename Drawing with Prefix 678
Tools Toolbar 888
Drawing View 156
duplicating
drawing 1096
ease
setting on multiple parameters 1074
Editing
Bitmap 668
Edit Colours Button 147
Edit Toolbar 100
Editing Stack Menu 109
Scaling Cube 890
Scaling Rectangle 890
Transform Tool 892
Translate Tool 888
Effect
Filter 706
Module Library 706
Element
Folder 895
Elements
3D Elements 885
Ellipse 890
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Enable
Enable/Disable All 112
Environment
3D 884
Environment Variable 895
Windows Environment Variable 896
Exporting
3D Object for Harmony frommaya 879
exposure
extending 1034
Exposure 744
extend
exposure 1034
File
FBX 880
FileToolbar 100
Maya Binary 879
Maya Binary File 895
PSD 668
Flatten 715
Auto-flatten 740
Brush Tool 741
Composite Module 705
Pass Through 723
Remove Extra Strokes 741
Flip
Flip Toolbar 100
Logo 674
flipping
through poses 1076
Focus
Focus on Mouse Enter 146
Format
Multi-layer PSD 668
OSB 880
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Frame
Current Frame 114
Pivot on Frame Range 757
Safe Area 667
Set the Pivot for Symbol on All Frames 286, 756
Function
Function View 100
Show/Hide Functions 115
Function Curves
adjusting velocity 1072
set eases on multiple parameters 1074
Function view
adjusting velocity in 1072
Gap
Cut-out Piece 674
Exposure 744
Grid
Field Chart 670
Safe Area 667
Show Grid 670
Grouping
Group Module 724
Module 723
Handle
Direction Arrows 888
Rotation Ellipse 893
Scaling Control Point 893
Scaling Cube 893
Scaling Rectangle 890
Hide
Show Selection and Hide All Others 112
Show/Hide Children 115
Show/Hide Functions 115
Show/Hide Palette List View 125
Showing and Hiding a Workspace 141
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Showing or Hiding Toolbars 134
Hierarchy 697, 707, 711
Advanced 700
Parent Layer 697-698
Parenting in Maya 879
Image
Bitmap 667
Photo Puppet 668
Picture 667
import
characters from library 1031
importing
about 1031
Importing
3D Object from Maya 882
Model 669
Interface 99
Advanced Animation Toolbar 100, 888
ayer Properties View 848, 887
Camera view 884
Camera View 884
Camera View Toolbar 101
Colour View 122
Control Point Toolbar 100
Coordinate Toolbar 100
Creating a New Workspace 139
Deleting a Workspace 141
Display Toolbar 100
Drawing Name 109
Drawing View 100
Drawing View Toolbar 101
Easy Flipping Toolbar 100
Edit Toolbar 100
File Toolbar 100
Flat Tool Toolbar Preference 135
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Flip Toolbar 100
Function View 100
Integrated Help 100
Interface Navigation 143
Keyboard Shortcuts 95
Layer Properties View 100
Library View 100, 126
Managing the Toolbars 134
Moving Toolbars 135
Showing or Hiding Toolbars 134
Managing the Views 130
Adding a New View 130
Closing a View 131
Resizing a View 132
Swapping Views 131
Managing the Workspace 138
Loading the Workspace 138
Menu 120
Message Log 100
Model View 100
Model View Toolbar 101
Module Library 706
Module Library View 100, 899
Network View 100, 895
New Mark Drawing Toolbar 101
Onion Skin Toolbar 100
Perspective View 100, 884, 889-891
Playback Toolbar 100, 128
Preferences 92
Reordering the Workspace List 142
Restoring the Default Workspaces 142
Saving a Workspace 140
Scripting Toolbar 100
Showing and Hiding a Workspace 141
Side View 100, 884-885
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Side View Toolbar 101
Timeline View 100, 111
Timeline View Toolbar 101
Tool Properties View 100, 110
Toolbar 100
Toolbar Manager 136
Tools Toolbar 100, 109, 888
Top View 884-885
User Interface Preferences - General Tab 145
View 100
Workspace Toolbar 100
Xsheet View 100
interpolation
computer generated
about 1071
Intersection
Cutter Tool 734
Inverse Kinematics 744
Joint 738
Auto-Patch Module 752
Classic 686
Fixing 686
Light Table 687
Patch 749
Keyboard Shortcut
Reset Pan 143
Reset Rotation 143
Reset View 143
Reset Zoom 143
Rotate 90 CW 143
To Recentre the View 143
Toggle Full Screen 143
Zoom In 143
Zoom Out 143
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Index

Keyboard Shortcuts
Selecting a Keyboard Shortcut Set 95
Keyframe
Default Separate Position 675
Keyframe Value 118
Motion Keyframe 675
Rigging 710
Timeline View 119
Z-nudging 694
keyframes
motion
creating 1071
Layer
2D option 887
3D Option 888-890, 892
Add Drawing layer 113
Add Layers 113
Adding to Existing Layer 736
Convert to Symbol 747
Create Drawing From Drawing Selection 734, 737
Cut-out Naming Convetion 677
Cut Artwork From Source 732, 737
Delete Layer 113
Distribute to Layer 741
Enable 3D 848, 887
Layer Properties View 100, 848, 887
Lock 733
Lock/Unlock Layer 116
Multi-layer PSD 668
Ordering 692-693
Parent Layer 697-698
Prefix and Suffix 677
Transform Tab 848, 887
Z-nudging 694
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layers
ordering over time 1097
Layout
Lne Up 669
library
importing characters from 1031
Library
Library View 100, 126
Library Folder List 127
Library View Menu 127
Preview Playback 127
Template/Symbol List 128
Library View Menu 127
Preview Menu 127
Master Template 726
Puppet 726
Library View
swapping images 1092
Light Table
Classic Joint 687
Link
Link/Unlink Three Colours 125
Loading
Loading a Workspace 138
Lock
Lock/Unlock Layer 116
Locking 733
Mac
Environment Variable 898
Script 898
Maintain Size 859
Matte
Matte View Mode 105
Maya
3D Object Texturing 879
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Index

Bin 897
Binary File 879, 895
Environment Variable 897
Exporting a 3D Object for Harmony 879
Importing a 3D Object from Maya 882
Lights 879
Maya Batch 899
Rendering Utility 899
renderMayaBatch Script 899
renderMayaBatchServer Script 899
Shaders 879
Soft Render 895
Texture 896
Menu 120
Editing Stack Menu 109
Library View Menu 127
Play Menu 129
Quick Access Menu 122
Top Menu 120
View Menu 121
Mode
Lasso Selection Mode 731
Render View 899
Render View Mode 900
Model
3D 885
3D Model Set-up 884
Alignment 667
Compositing 3D Model 895
Cut-out 671
Cut-out Model 730
Eyelids and Pupils 671
Hand 672
Import 3D Model 882
Importing 667, 669
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Model View 100
Model View Toolbar 101
Relative Size 669
Scaling 667
Size 668
Tracing the Cut-out Model 682
Module
Articulation 1115
Auto-muscle 1118
Auto-Patch Module 752
Bone 1113
Colour Art Module 754
Composite 705-706
Composite Module 693
Composite Type 723
Connecting 900
Curve Deformer 1113
Deformation-autofold 1118
Deformation-composite 1121
Deformation-root 1123
Deformation-scale 1123
Deformation-switch 1126
Deformation-uniform-scale 1127
Deformation-wave 1128
Display Module 721
Fold 1131
Group Module 724
Grouping 723
Module Library 706
Module Library View 100, 899
Offset 1133
Peg 883
RenderMayaBatch 900
RenderMayaBatchServer 900
Script 885
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Write Module 721
Motion
Keyframe 675
motion keyframe
creating 1071
Motion keyframes
adjusting velocity 1072
Multiplane
3D Space 848, 887
Perspective View 889-891
Z-axis 888
Naming
Colour Swatch Name 125
Display Module 721
Drawing 677
Naming Convention 677
Prefix and Suffix 677
Rename Drawing 678
Rename Drawing with Prefix 678
Navigation
Interface Navigation 143
Network
Grouping 723
Module Library View 899
Network View 100, 895
Ordering 693
Project Network 899
Template 726
NetworkView
Set Up 899
Onion Skin 117
Onion Skin Toolbar 100
Open
Workspace Manager 138
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OpenGL
Full Scene Antialiasing Preference in the OpenGL tab 149
OpenGL Mode 884
OpenGL View Mode 104
Optimization
Skeleton 721
ordering
layers over time 1097
Ordering
Composite Module 693
Layer 692
Network 693
Z-nudging 694
Overlay
Classic Joint 687
Overlapping Piece 674
Paint
Set Current Paint Colour 125
Palette
Show/Hide Palette List View 125
Paperless
Mix with Cut-out Animation 673
Parameter
3D 848, 887
3D Parameter 894
Layer Properties View 848, 887
Position 894
Set Current Paint Colour 125
Set Current Pencil Colour 124
parameters
setting eases on multiple 1074
Parameters
Set Current Brush Colour 124
Path
Animating 3D Object 887
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Environment Variable 897
Separate Position 675
Peg
Adding 704
Connecting 3D Object 883
Master Peg 697, 705, 709
Master Peg Pivot 719
Positioning 3D Object 883
Rigging 700
Pencil
Convert Brush Strokes to Pencil Lines 751
Set Current Pencil Colour 124
Size 670
Pencil to Brush
convert 225
Pencil Tool options
smoothness 184
Perspective
Perspective View 100, 884, 889-891
Rotation 884
Side View 884
Top View 884-885
Pespective
Side View 885
Pivot 888-890
Copying Pivot on Parent Symbol 287
Drawing Pivot 716, 757
Frame Range 757
Master Peg 719
Pivot Tool 286
Rigging 716-717
Rotate Tool 719
Scale Tool 719
Set the Pivot for Symbol on All Frames 286, 756
Snapping 287

1502

Toon Boom Harmony 10.3 Stage User Guide

Symbol 755
Symbol Pivot 717
Temporary 719
Playback
Playback toolbar 100
Playback Toolbar 128
Play Menu 129
Preview Playback 127
Port
Ordering 693
poses
flipping through 1076
Positioning
3D Object 883, 887
3D Scale Tool 890
3D Transform Tool 892
Elements in the 3D Environment 885
Enable 3D 848, 887
Position Parameter 894
Rotate Tool 888-889, 893
Scale Tool 888, 890
Scaling Cube 890
Transform Tab 848, 887
Transform Tool 892
Transform Tool Rotation 893
Transform Tool Translation 892
Transformation Tool 888
Translate Tool 888, 892
positioning elements in 3D space 859
Preference
Advanced 93
Camera 93
Deformation 93
Drawing 93
Exposure Sheet 93
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Index

Full Scene Antialiasing Preference in the OpenGL tab 149
General 93
Interface 92
Network 93
OpenGL 93
Particle 93
Preference Highlights 93
Accessing the Preferences Panel 93
Automatically Save Workspace 145
Flat Tool Toolbar 146
Focus on Mouse Enter 146
Levels of Undo 147
User Interface Preferences - General Tab 145
Render 93
Shortcuts 93
Sound 93
Template 93
Timeline 93
User Interface Preferences - General Tab 149
Zoom Settings 149
Preferences
Separate Position 675
Preview
3D Model in Camera View 883
Position of 3D Model 884
Preview Playback 127
Preview Window 127
Render Mode 885
Render View Mode 900
Update Preview 103
Project
Project Network 899
Size Consistency 669
Properties
Lasso 731
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Tool Properties View 110
Puppet
Breakdown 682, 730, 733
Extra View 736
Building a Character 665
Classic Joint 686
Extra Drawing 714
Fixing Joint 686
Ghost Drawing 743
Importing a Model 667
Joint 738
Layer Ordering 692-693
Library 726
Line Up 669
Master Peg 709
Model Alignment 667
Patch 749
Photo Puppet 668
Relative Size 669
Rigging 682
Size 668
Skeleton 721
Z-nudging 694
Rectangle
Scaling Rectangle 890
Renaming
MB File 895
Renaming a Workspace 140
Render
3D Models 895
3D Rendering 895
Maya Rendering Utility 899
Maya renderMayaBatch Script 899
Maya renderMayaBatchServer Script 899
Maya Soft Render 895
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Render Mode 885
Render View Mode 899-900
Write Module 721
Rigging 682, 696
Advanced 700
Basics 697
Body 705
Breakdown 730, 733, 737
Extra View 736
Building a Character 665
Clean Up 739
Cutting 733
Display Module 721
Distribute to Layer 741
Extra Drawing 714, 759
Eyelids and Pupils 671
Ghost Drawing 743
Hand 672
Head 703
Hierarchy 707, 711
Keyframe 710
Logo 674
Master Peg 697, 705, 709
Master Peg Pivot 719
Master Template 726
Mix Animation 673
Model 671
Mouth 672
Naming Convention 677
Overlap 674
Patch 749
Peg 700
Photo Puppet 668
Pivot 716-717
Pivot on Frame Range 757
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Prefix and Suffix 677
Rename Drawing with Prefix 678
Skeleton Optimization 721
Symbol 747
Tracing the Cut-out Model 682
Write Module 721
Rotate 90 CCW 143
Rotation
3D Object 889
3D Rotate Tool 889
Arm Rotation 697
Perspective View 884
Pivot 716-717
Rotate Tool 719, 888-889, 893
Rotation Ellipse 893
Set the Pivot for Symbol on All Frames 756
Transform Tool 893
Scaling
3D Scale Tool 890
3D Transform Tool 892
Line Up 669
Model 667
Proportionally 891
Scale Tool 719, 888, 890
Scaling Cube 890, 893
Scaling Rectangle 890
Scene
Compositing 899
Script
3D Set Up 898
Mac 898
Module 885
renderMayaBatch 899
renderMayaBatchServer 899
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Scripting
Scripting Toolbar 100
Selecting
Create Drawing From Drawing Selection 730, 734, 737
Distribute to Layer 741
Flatten 741
Lasson Selection Mode 731
Select Tool 731
Selecting a Keyboard Shortcut Set 95
Show Selection and Hide All Others 112
Set-up
3D Model 884
Set Up
3D Rendering 895
Enviroment Variable on Windows 896
Maya Script for Mac 898
Network View 899
setting
eases
multiple parameters 1074
Show
Grid 670
Show Selection and Hide All Others 112
Show Stroke 741
Show Strokes 687
Show/Hide Children 115
Show/Hide Functions 115
Show/Hide Palette List View 125
Showing and Hiding a Workspace 141
Showing or Hiding Toolbars 134
show strokes
washed-out colours 260
Size
Brush Size 670
Character Line Up 669
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Cut-out Model 668
Cut-out Puppet Relaitve Size 669
Field Chart 670
Relative Size 669
Smoothness
Pencil tool option 184
Snapping
Pivot 287
Space
Z-axis 888
Stage 889-891
Stage Library 127
Stop-motion
animating in 1069
Stroke
Convert Brush Strokes to Pencil Lines 751
Remove Extra Strokes 687, 741
Show Stroke 741
Show Strokes 687
Swap
Drawing Substitution 673, 744
swapping images
about 1092
Library view 1092
Swatch
Colour Swatch 126
Colour Swatch Name 125
Transparency 744
Symbol 127
3D model 882
Copying Pivot on Parent Symbol 287
Create Symbol 748
Pivot 717, 755
Rigging 747
Set the Pivot for Symbol on All Frames 286, 756
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Symbol Exposure 119
Template/Symbol List 128
Symbols
Hierarchy 700
template
importing 1031
Template 667
Adding Extra Drawing 759
Current View Border in Template Edit 147
Master Template 726
Template/Symbol List 128
Timeline 726
Texture
3D Object Texturing 879
Add Texture 124
Maya 896
Timeline
Collapse 710
Ordering 692
Template 726
Timeline View 100, 111
Add Drawing layer 113
Add Layers 113
Add Peg 113
Change track Colour 116
Current Drawing Displayed in the Drawing View 114
Current Frame 114
Delete Layers 113
Drawing Exposure 119
Drawing Substitution 117
Enable/Disable All 112
Keyframe Value 118-119
Lock/Unlock Layer 116
Onion Skin 117
Show Selection and Hide All Others 112
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Show/Hide Children 115
Show/Hide Data View 114
Show/Hide Functions 115
Split 115
Symbol Exposure 119
Zoom 118
Timeline View Toolbar 101
Tool
3D Rotate Tool 889
3D Scale Tool 890
3D Transform Tool 892
Advanced Animation Toolbar 888
Cutter Tool 731, 733, 736, 739
Flat Tool Toolbar 146
Flat Tool Toolbar Preference 135
Pivot Tool 286
Rotate Tool 719, 888-889, 893
Scale Tool 719, 888, 890
Select Tool 731
Tool Properties View 100, 110
Toolbar 100
Tools Toolbar 100, 109, 888
Transform Tool 892-893
Translate Tool 888, 892
Toolbar 100
Advanced Animation Toolbar 100, 888
Animate Mode 888
Camera View Toolbar 101
Control Point Toolbar 100
Coordinate Toolbar 100
Deformation Toolbar 1139
Display Toolbar 100
Drawing View Toolbar 101
Easy Flipping Toolbar 100
Edit toolbar 100
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File Toolbar 100
Flat Tool Toolbar 146
Flat Tool Toolbar Preference 135
Flip Toolbar 100
Managing the Toolbars 134
Model View Toolbar 101
Moving Toolbars 135
New Mark Drawing Toolbar 101
Onion Skin Toolbar 100
Playback Toolbar 100, 128
Play Menu 129
Scripting Toolbar 100
Showing or Hiding Toolbars 134
Side View Toolbar 101
Timeline View Toolbar 101
Toolbar Manager 136
Tools Toolbar 100, 109, 888
Workspace Toolbar 100
Tracing
Cut-out Model 682
Transform
3D Transform Tool 892
Rotation with the Transform Tool 893
Transform Tool 892
Transformation Tool 888
Translation with the Transform Tool 892
Translation
3D Transform Tool 892
Transform Tool 892
Translate Tool 888, 892
Transparency
Colour 744
Unlink
Link/Unlink Three Colours 125
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Unlock
Lock/Unlock Layer 116
Utility
Maya Rendering 899
Variable
Environment Variable 895
Path 897
System Properties 896
Windows Environment Variable 896
Vector 667
Vectorization
Photo Puppet 668
velocity
adjusting 1072
Velocity
Default Separate Position 675
View
OpenGL Mode 884
Resizing a View 132
Swapping Views 131
Windows
Environment Variable 896
Preview Window 127
Workspace Manager
Creating a New Workspace 139
Renaming a Workspace 140
Saving a Workspace 140
Xsheet
Xsheet View 100
Z
Z-axis 888
Z-nudging 675, 692, 694
Zoom
Timeline View
Zoom Tool 118
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Zoom Settings 149
ZoomDrop-down Menu 107
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