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Chapter 1: Introduction
In the Scripting guide you will find information which helps you to understand how to useQt Script, the scripting
language supported by Toon BoomHarmony.

Toon BoomAnimation has changed the scripting language.

• Scripting language used in Harmony 10.3: Qt script

• Reason for changing the scripting language: better and faster scripting environment

Toon BoomAnimation has changed the scripting language to Qt Script fromQSA used in earlier versions.
Script's storage is now done as plain text, *.js instead of *.qsa format.

This change to the api was made in the interests of improving the software so that it could support 64-bit
platforms. As always, we havemade every effort to enable backward compatibility between this version and
earlier versions which used QSA script.

• Simple functions should port seamlessly.

• Class definitions must follow the new QT Script syntax, so that existing scripts may bemodified.

Detailed instructions on moving QSA script to Qt Script can be found in the "Moving fromQSA to
Qt Script" documentation at this link:

• http://qt-project.org/doc/qt-4.8/porting-qsa.html

For a general overview of the QT UI toolkit, refer to the following:

• http://qt-project.org/doc/qt-4.8/index.html

For a tutorial on coding in JavaScript, refer to the following:

• http://docs.oracle.com/javase/tutorial/java

Detailed Scripting Method
• Harmony Script Interface Documentation

• Script Module Documentation

• DbScript Documentation

http://qt-project.org/doc/qt-4.8/porting-qsa.html
http://qt-project.org/doc/qt-4.8/index.html
http://docs.oracle.com/javase/tutorial/java
http://docs.toonboom.com/help/scripting-10.3/script/
http://docs.toonboom.com/help/scripting-10.3/scriptmodule/
http://docs.toonboom.com/help/scripting-10.3/dbscript/
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Chapter 1: Scripting Overview
Qt Script provides access to many of the functions supported in the interface. WithQt Script, you can automate
a number of Harmony functions to speed the completion of various repetitive tasks.

To use scripts prepared by other users, youmust import those scripts into your preferences.

You can add buttons to the Scripting Tools toolbar so that you can access them easily. They will appear to the
right of the default Scripting Tools toolbar buttons.

If you are working in a network environment, refer to Harmony Server Network Environment on page
17.

Topics Covered

• Using Qt Script to Automate Toon BoomHarmony Functions on the next page

• Creating a Qt Script on page 7

• Using an External Script Editor on page 12

• Importing Scripts on page 13

• Linking a Script to a Toolbar Button on page 15
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Using Qt Script to Automate Toon Boom
Harmony Functions
Qt Script provides access to many of the functionalities supported in the Harmony interface.

Qt Script is an object-oriented scripting language based on the ECMAScript standard, like JavaScript and
JScript. However, there are some differences that distinguish it from these scripting languages, which are
familiar to web programmers.

If you are working in a network environment, refer to the topic Using Qt Script to Automate Toon
Boom Harmony Functions - server functions on page 17.

Related Topics

• Scripting Overview on the previous page
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Creating a Qt Script
Use the Script Editor to createQt scripts for Harmony.

This section is divided as follows:

• Creating a Script below

• Deleting a Script on page 9

• Troubleshooting a Script on page 10

Creating a Script
To create a script:

1. Open the Script Editor by going to the top menu and selectingWindows > Script Editor.

The Script Editor view opens listing all the JavaScript files.

2. From the View menu select File > New Script or from the Script Editor toolbar, click on theNew

Script button. (If you do not see the Script Editor toolbar, go to the top menu and selectWindows >

Toolbars > Script Editor).
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TheNew Script dialog box appears.

3. Enter a name in the Enter name of new script field and click onOK.

The name of your script appears in the File column of the Script Editor view.

4. Click in the right side of the Script Editor and start writing your script. Try typing in the following script:

function add3dPathCol()

{

column.add(“ColumnName”, “3DPATH”);

}

For a tutorial on coding in JavaScript, refer to the following:

• http://docs.oracle.com/javase/tutorial/java

For a detailed Harmony script interface documentation, refer to the following:

• Harmony Script Interface Documentation

5. To check your syntax, click on theVerify button.

A window opens with syntax information.

6. To test your script, select the function you would like to run from the File column, then, from the Script
Editor toolbar, click on the Run button, or from the View menu select Play/Debug > Run.

‣ Awindow opens to ask you for the target function to run. In the window, select which function you
want to execute. To avoid selecting the function every time youwant to run your script, you can set a

http://docs.oracle.com/javase/tutorial/java
http://docs.toonboom.com/help/scripting-10.3/script/
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target function. In the Script Editor toolbar, click on the Set Target button, or from the View menu

select Play/Debug > Set Target. In the Function column, select the function to target and press

OK.

‣ To stop the execution of your script, click on the Stop Execution button.

‣ Youmay receive themessage: Only functions that have been saved or are explicitly called will be
executed. This usually occurs if you did not select the function you wished to run from the File column
before running the script. In this case, click on the Save Changes button, then try running your script
again.

‣ Youmay also see this message on the right side of the Script Editor:

This is because the software jumped to the <<Sandbox>> item in the Function column. The
<<Sandbox>> is provided to test scripts without saving them. Simply click on your newly created
script and then try running it again.

A new 3Dpath column (or 3 separate x, y and z path columns and a velocity column) will appear in your
Xsheet view with the nameColumnName.

Deleting a Script
To delete a script:

1. In the Script Editor, in the File column, select the script that you would like to delete.
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2. From the Script Editor toolbar, click on theDelete Script button or from the View menu , select

File > Delete Script.

Troubleshooting a Script
To troubleshoot errors in your script:

1. Debug: In the File list, select the script containing the function to debug.From the Script Editor toolbar,
click on theDebug button, or from theViewmenu , select Play/Debug > Debug.

A window opens listing the scripts and functions available.

2. In the Functions column, select the function to debug.

3. Click on theOK button.
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TheQt Script Debugger opens.

If you are working in a Network Environment, refer to the topic Creating a Qt Script on page 17

Related Topics

• Scripting Overview on page 5
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Using an External Script Editor
If you aremore comfortable editing your scripts using another editor, Harmony allows you to set an external
script editor and use that one instead.

If you do not set an external editor, on Windows andMac OS X, when selecting the External Editor
option, it will launch the registered editor for JavaScript program. (e.g. Visual Studio , XCode or
Brackets).

Multiple files can be opened in the same editor, instead of starting a different copy of the editor
each time a *.js script is selected.

To set an external editor:

1. In the Script Editor view, in the View menu, select Editor > Set External Editor. In the Script Editor
window, click on the Set External Editor button.

The Set External Editor window opens.

2. In the External Editor Application, type or paste the complete path to the application, including its name
and extension.

‣ For example, if you want to set AdobeDreamweaver as your external editor, a Windows path would
look like this:
C:\Program Files (x86)\Adobe\Adobe Dreamweaver CS5\Dreamweaver.exe

‣ OnMacOS X, simply specify the application name, and if this application supports the Apple SCript
OpenDocument protocol, it will open in this app.

3. Click on theOK button.

To edit a script in an external editor:

1. In the Script Editor view, in the File list, select the script to edit.

2. In the View menu, select Editor > External Editor or in the Script Editor window, click on the External
Editor button.

The external editor opens.

3. In the external editor, edit the script and save the file.

4. In Harmony, refresh the Script Editor view by selecting another script and selecting your edited script
again to see themodifications.
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Importing Scripts
To use scripts prepared by other users, transfer the *.js files from the computer where the scripts were
created to the one that you intend to use. Then use the Script Editor to import the *.js files fromwhere they
are saved on your computer.

Scripts that you have created while working on a scene or project will be available for all other projects created
on the same computer, with no need for any kind of transfer or import.

To import a script:

1. On the computer that contains the *.js files, openMyComputer (Windows) or Finder (MacOS X), then
follow this path:

To the default scripts:

‣ Windows: C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony
10.3\resources\scripts

‣ MacOS X: Home > Library > Preferences > Toon Boom Animation > Toon Boom Harmony >
1030-scripts

‣ Linux: /Applications/Toon Boom Harmony 10.3/tba/resources/scripts

To your custom scripts:

‣ Windows: C:\Users\(User Name)\AppData\Roaming\Toon Boom Animation\Toon Boom
Harmony\1030-scripts

‣ MacOS X: /home/(User Name)/Toon Boom Animation/Toon Boom Harmony/1030-scripts

‣ Linux: /usr/local/ToonBoomAnimation/harmony_10.3/resources/scripts

2. Copy the *.js files that you would like to transfer to another computer onto a USB key, or use another
transfer method of your choice.

3. Transfer and save the *.js files onto the computer that you intend to use. Be sure that you save them in a
logical location. You can save them directly in the locations indicated in Step 1, in which case they will
automatically appear in the Script Editor. If for some reason you do not wish to mix them up with the
default scripts, save them to a different location and continue following the steps below.

4. Open a new, or existing, scene in Harmony.

5. In the Script Editor, click on the Import Scripts button, or from the View menu , select File >

Import Script.A browser window will open and allow you to browse to the location on the server where
the *.js files are saved.

To save time, you can copy all the files and icons located in the user's preferences and paste them
back in your own preferences to avoid having to import all scripts one by one.

• Windows: C:\Users\(User Name)\AppData\Roaming\Toon BoomAnimation\Toon Boom
Harmony\1030-scripts

• Mac OS X: /home/(User Name)/Toon BoomAnimation/Toon BoomHarmony/1030-scripts

• Linux: /usr/local/ToonBoomAnimation/harmony_10.3/resources/scripts

6. Select the *.js file and click on theOpen button.

The script is imported and appears in the File list of the Script Editor File list.
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If you are working in a network environment, refer to the topic Importing Scripts on page 22.

Related Topics

• Scripting Overview on page 5
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Linking a Script to a Toolbar Button
You can add buttons to the Scripting Tools toolbar so that you can access them easily. They will appear to the
right of the default Scripting Toolbar buttons.

To link a script to a toolbar button:

1. In the Scripting Tools toolbar, click on theManage Scripts button.

A dialog box containing all of the available scripts opens.

2. In the Files list, select the JavaScript file containing the function you want to add to the toolbar.

3. In the Functions list, select the function to add to the toolbar.

4. Click on the Right Arrow button to add the function to the In Toolbar list.

5. Click onOK to add the button and close the dialog box.

To execute a script:

1. Once the script is added to the Scripting toolbar, you can press on the corresponding script button to
execute the action—see Linking a Script to a Toolbar Button above.

2. You can press the [Esc] key to interrupt the execution of a script.

If you are working in a network environment, refer to the topic Linking a Script to a Toolbar Button
on page 23.



Chapter 1: Scripting Overview Linking a Script to a Toolbar Button

16

Related Topics

• Scripting Overview on page 5
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Harmony Server Network Environment
When you are working in a network environment, use these procedures:

• Using Qt Script to Automate Toon BoomHarmony Functions - server functions below

• Creating a Qt Script below

• Importing Scripts on page 22

• Linking a Script to a Toolbar Button on page 23

Related Topics

• Scripting Overview on page 5

Using Qt Script to Automate Toon Boom Harmony
Functions - server functions
Qt Script provides access to many of the functionalities supported in the Toon BoomHarmony interface.

Qt Script is an object-oriented scripting language based on the ECMAScript standard, like JavaScript and
JScript. However, there are some differences that distinguish it from these scripting languages, which are
familiar to web programmers.

Related Topics

• Harmony Server Network Environment above

• Creating a Qt Script below

• Importing Scripts on page 22

• Linking a Script to a Toolbar Button on page 23

Creating a Qt Script
Use the Script Editor to createQt scripts for Harmony.

This topic is divided as follows:

• Creating a Script below

• Deleting a Script on page 20

• Troubleshooting a Script on page 21

Creating a Script
To create a script:

1. Open the Script Editor by going to the top menu and selectingWindows > Script Editor.

The Script Editor view opens listing all the JavaScript files.



Chapter 1: Scripting Overview Harmony Server Network Environment

18

2. From the View menu select File > New Script or from the Script Editor toolbar, click on theNew

Script button. (If you do not see the Script Editor toolbar, go to the top menu and selectWindows >

Toolbars > Script Editor).

TheNew Script dialog box appears.

3. Enter a name in the Enter name of new script field and click onOK.

The Save Script window opens.

4. To save the script:

‣ Click on theUser button to store the script into the user profile so the user can always access the
script (/usa_db/users/user_name).

‣ Click on theGlobal button to make the script available to all users from any scene, job and
environment (/usa_db/scripts).

‣ Click on the Environment button to make the script available to all users whenworking in a scene
from this particular environment (/usa_db/environments/environments_name).
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‣ Click on the Job button to make the script available to all users whenworking on scenes from a
particular job (/usa_db/jobs/job_name).

The name of your script appears in the File column of the Script Editor view.

5. Click in the right side of the Script Editor and start writing your script. Try typing in the following script:

function add3dPathCol()

{

column.add(“ColumnName”, “3DPATH”);

}

For a tutorial on coding in JavaScript, refer to the following:

• http://docs.oracle.com/javase/tutorial/java

For a detailed Harmony script interface documentation, refer to the following:

• Harmony Script Interface Documentation

6. To check your syntax, click on theVerify button.

A window opens with syntax information.

7. To test your script, select the function you would like to run from the File column, then, from the Script
Editor toolbar, click on the Run button, or from the View menu select Play/Debug > Run.

‣ Awindow opens to ask you for the target function to run. In the window, select which function you
want to execute. To avoid selecting the function every time youwant to run your script, you can set a
target function. In the Script Editor toolbar, click on the Set Target button, or from the View menu

select Play/Debug > Set Target. In the Function column, select the function to target and press

OK.

http://docs.oracle.com/javase/tutorial/java
http://docs.toonboom.com/help/scripting-10.3/script/
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‣ To stop the execution of your script, click on the Stop Execution button.

‣ Youmay receive themessage: Only functions that have been saved or are explicitly called will be
executed. This usually occurs if you did not select the function you wished to run from the File column
before running the script. In this case, click on the Save Changes button, then try running your script
again.

‣ Youmay also see this message on the right side of the Script Editor:

This is because the software jumped to the <<Sandbox>> item in the Function column. The
<<Sandbox>> is provided to test scripts without saving them. Simply click on your newly created
script and then try running it again.

A new 3Dpath column (or 3 separate x, y and z path columns and a velocity column) will appear in your
Xsheet view with the nameColumnName.

You should back up your scripts if they are placed at the Global location because every user opening
a scene gets the rights to them and if a problem arises it can corrupt the saved scripts.

Deleting a Script
To delete a script:

1. In the Script Editor, in the File column, select the script that you would like to delete.
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2. From the Script Editor toolbar, click on theDelete Script button or from the View menu , select

File > Delete Script.

Troubleshooting a Script
To troubleshoot errors in your script:

1. Debug: In the File list, select the script containing the function to debug.From the Script Editor toolbar,
click on theDebug button, or from theViewmenu , select Play/Debug > Debug.

A window opens listing the scripts and functions available.

2. In the Functions column, select the function to debug.

3. Click on theOK button.
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TheQt Script Debugger opens.

Related Topics

• Harmony Server Network Environment on page 17

• Using Qt Script to Automate Toon BoomHarmony Functions - server functions on page 17

• Importing Scripts below

• Linking a Script to a Toolbar Button on the facing page

Importing Scripts
To use scripts prepared by other users, you can simply import the *.js fromwhere it is saved on the server.

To import a script:

1. In the Script Editor, click on the Import Scripts button, or from the View menu , select File >

Import Script.

A browser window will open and allow you to browse to the location on the server where the *.js files
are saved. You can choose either the User, Global, Environment, or Job folder.

Here is an example of where those scripts can be found:

‣ Global: \\(Server_Name)\USA_DB\scripts

‣ Environment: \\(Server_Name)\USA_DB\environments\(user name)

‣ Job: \\(Server_Name)\USA_DB\jobs\(user name)

‣ User: \\(Server_Name)\USA_DB\users\(user name)\stage\1030-scripts

2. Select the *.js file and click on theOpen button.

The script is imported and appears in the File list of the Script Editor.
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Related Topics

• Harmony Server Network Environment on page 17

• Using Qt Script to Automate Toon BoomHarmony Functions - server functions on page 17

• Creating a Qt Script on page 17

• Linking a Script to a Toolbar Button below

Linking a Script to a Toolbar Button
You can add buttons to the Scripting Tools toolbar so that you can access them easily. They will appear to the
right of the default Scripting Toolbar buttons.

To link a script to a toolbar button:

1. In the Scripting Tools toolbar, click on theManage Scripts button.

A dialog box containing all of the available scripts opens.

2. In the Files list, select the JavaScript file containing the function you want to add to the toolbar.

3. In the Functions list, select the function to add to the toolbar.

4. Click on the Right Arrow button to add the function to the In Toolbar list.

5. Click onOK to add the button and close the dialog box.

To execute a script:

1. Once the script is added to the Scripting toolbar, you can press on the corresponding script button to
execute the action—see Linking a Script to a Toolbar Button above.

2. You can press the [Esc] key to interrupt the execution of a script.
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Related Topics

• Harmony Server Network Environment on page 17

• Using Qt Script to Automate Toon BoomHarmony Functions - server functions on page 17

• Creating a Qt Script on page 17

• Importing Scripts on page 22
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