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Chapter 1: Introduction

Harmony Scan Module

Chapter 1: Introduction

Toon Boom Harmony is a complete animation solution that offers a variety of tools to suit the user’s needs from
pre-production steps to the end of production. Some of these tools are provided in specialized modules, such as
the Xsheet, Paint, Scan and Play modules, which are designed to help the user focus on a specific task to ensure
the efficiency of the whole production.
In this guide, you will learn the function of the Scan module so you can integrate it in your production workflow.

Harmony Scan Module

When working on a traditional animation production, in order to produce a scene, a large quantity of drawings
must be scanned in. In order to speed up the process, these productions require the use of automated scanners.
The Harmony Scan module is used to communicate with these scanners and set the parameters required to
create the vectorization style and correct registration of the scanned animation.
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Scanners and SCSI Adapters
The Harmony Scan module works with high-end scanners using SCSI adapters. The Harmony Scan module
supports our custom drivers and TWAIN devices.
SCSI adapters are not standard hardware in PC’s and Mac. If you plan to use a PC or Mac as a scanning station,
you can equip it with a supported SCSI adapter. We recommend that you dedicate a SCSI card exclusively for
scanners.
This is the list of supported scanners which use our custom drivers:
•

Epson 15000-GT Colour

•

Epson 1640XL Colour

•

Epson 836XL Colour

•

Fujitsu M4097Ddim B&W

•

Fujitsu M3096GX B&W

•

Fujitsu fi-6770 Colour

•

Fujitsu fi-5750C Colour

•

Fujitsu fi-4750C Colour

•

Fujitsu fi-4640S B&W

•

Microtek 9600XL Colour

•

Ricoh IS330DC Colour

•

Ricoh IS760 Colour

•

Ricoh IS420 B&W

•

Ricoh IS430 B&W

•

Ricoh IS450DE B&W

•

Sharp JX-610 Colour

•

Umax Mirage II Colour

Topics Covered
•

Interface on the next page

•

How to Scan on page 13

•

Scan Menu Commands on page 37

•

Configuring Scanners on page 43
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Scanners and SCSI Adapters

Chapter 1: Interface

It is important to become familiar with the following elements of the user interface, this will help you to start
using Toon Boom Harmony. You can learn more about the highlights described here, and how to use them in a
production context, throughout this guide.
When you start Toon Boom Harmony for the first time, the default workspace is displayed. It contains all of the
main elements you need to use.

Topics Covered
•

Interface Highlights on the facing page
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Interface Highlights
The Harmony Scan module is composed of five major sections.

•

Top Menu below

•

Control Panel on the next page

•

Drawing List on page 12

•

Frame Preview Panel on page 12

•

Image Panel on page 12

Top Menu
The top menu contains most of the commands available in the Harmony Scan module.
The menu categories are:
•

File

Use this menu to load drawings and manage exposure sheet elements.
•

Edit

Use this menu to modify the Drawing List, apply vectorization options and create a text file of scan details
for each scanned drawing.
•

Scanner
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Control Panel

Use this menu to eject a page from the scanner and display scanner information.
•

Help

Use this menu to access the integrated help system and Harmony Scan module version information.
In the Mac OS X version, there is a Scan category containing the following commands:
•

About

•

Quit

Control Panel
Located at the top left of the Scan module window directly below the menu bar, the buttons allow you to set up
the scan.

•

Feed
Press this button to display a menu. Use this menu to select how drawings will be fed through the scanner

•

•

Autofeed: Feed the drawings into the Automatic Document Feeder (ADF).

•

Autofeed (One): Set the scanner to accept one drawing from the ADF when the Scan button is
pressed.

•

Pegged: Set the scanner to scan a drawing from the flatbed each time the Scan button is pressed.

•

Pegged (Many): Set the scanner to automatically scan a drawing from the flatbed every five to ten
seconds (depending on the time required to process the drawings).

•

Pan Cel: Set the scanner to scan a drawing that is bigger than the scanner window in separate
sections.

Field Size
Press this button to display a menu. Use this menu to indicate the size of paper of the drawing you want
to scan.

•

Peg Position
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Press this button to display a menu. Use this menu to select the location of the peg or registration holes
on the paper you are scanning. The system rotates the images automatically based on your selection.

•

•

Bottom Peg: The peg holes appear below the drawing.

•

Top Peg: The peg holes appear above the drawing.

•

Left Peg: The peg holes appear to the left of the drawing.

•

Right Peg: The peg holes appear to the right of the drawing.

Preview
Press this button to test various exposures without saving the image.

•

Resolution
Press this button to display a menu. Use this menu to adjust the capture resolution, which determines the
quality and the size of scanned images. The resolutions that appear depend on the scanner that you
selected using the Scanner button.

•

Save
Save the previewed drawing to the file currently selected in the Drawing List.

•

Scan
Press this button to begin the scanning process.

•

Scan Type
Press this button to display a menu. Use the menu to select scan type that applies to your image. If you
have more than one scanner connected to your computer, only the scanners that support the selected
scan type will be active.

•

•

Black and White: Select this option if you are scanning a drawing that you will paint in the Stage or
Paint module.

•

Greyscale: Select this option to capture the shades of grey in the drawing.

•

Colour: Select this option to scan a pre-coloured drawing, such as a background or an overlay.

Scanner
Press this button to display a menu. Use the menu to select one of the scanners that is connected to the
host machine. The default model is the one that appears first in your scanner configuration file, scan.conf.

•

Stop
Press this button to interrupt a scan that is in progress.

Checkboxes

•

Flip Drawing: Select this option to flip the scanned image horizontally and realign the registration holes.

•

Optical Registration: Select this option to automate the alignment of your drawings using the
registration holes on your drawing paper.

•

Pencil Test: Select this option to create a black and white image with no paintable colour art regions.
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Drawing List

Scan Options
Located at the left of the Scan module directly below the button bar, the scan options allow you to control the
following:
•

Exposure

•

Contrast

•

Time required to scan a line, measured in lines per millisecond.

Drawing List
The drawing list displays the names of the drawings which are loaded for scanning. As each drawing is scanned
this is indicated.

Frame Preview Panel
This shows the upcoming frame to be scanned.

Image Panel
The current drawing which is being scanned is shown in this panel.

Refer to the How to Scan on the facing page and Scan Menu Commands on page 37 chapters to
learn more.
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Chapter 1: How to Scan

Scanning with the Harmony Scan Module
Toon Boom Harmony has a dedicated Scan module for fast scanning. It creates a drawing list out of the
previously created exposure sheet.
To use this module, you must create your exposure sheet in Stage prior to the scan process.

Related Topics
•

Launching the Harmony Scan Module and Loading Drawings on the next page

•

Setting up the Scanner on page 22

•

Performing a Trial Scan on page 24

•

Scanning Drawings on page 26

•

Advanced Scanning Techniques on page 33
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Launching the Harmony Scan Module and Loading Drawings

Launching the Harmony Scan Module and
Loading Drawings
Usually, when you are ready for the scanning process, a scene has been created containing the elements to be
scanned and the exposure sheet has been filled.

If you have not previously prepared your scene’s exposure sheet, created your elements or scenes,
you can always create drawing lists, elements or scenes directly from the scan module without having
to go through the Control Center.

To launch the Scan module and load your scene:
1. Launch the Harmony Scan module:
‣

Mac OS X: Double-click on the Harmony Scan module

icon or select:

Applications > Toon Boom Harmony10 > Scan.
‣

Windows: Double-click on the Harmony Scan module

icon or select:

Start > All Programs > Toon Boom Harmony10.0 > Scan.
‣

Linux: Double-click on the Harmony Scan module

icon or select:

/usr/local/ToonBoonAnimation/harmony_10.0/lnx86_64/bin > Scan.
If there is no scanner properly installed or connected to the computer you are using, the No Scanners
Present warning dialog box opens.

‣

Click on Continue to open the Scan module, note that you will not be able to scan.

‣

Click Exit Scan Program to quit the Scan module.

If you think that this message is incorrect and that the computer is supposed to be connected to a
scanner, contact your system administrator.
The database login dialog box opens.
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2. Enter your Harmony username in the User Name field.
3. Click on the OK button.
The Database Selector dialog box opens, displaying the Environments available from the Harmony
database.

4. Select the Environment, Job, Scene and then the Element you want to scan.

5. Click on Open.
The Drawing Selector dialog box opens listing all the drawings contained in the selected element.
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Launching the Harmony Scan Module and Loading Drawings

‣

The Drawing column lists the name of the drawings.

‣

The Scanned? column indicates if the drawing has been scanned (Yes) or not (No).

6. If need be, it is possible to add new drawings in the list:
‣

Type a drawing name in the Add Drawing field.

‣

Press on Add Drawing.

The new drawing appears in the list.
7. Select the drawings you want to scan.
‣

Select specific drawings from the list using your mouse pointer. You can select several drawing using
[Shift] + click.

‣

Press All to select all the drawings in the list.

‣

Press None to unselect all drawings.

‣

Press Scanned to select only the drawings that are stated as scanned (Yes) in the list.

‣

Press Unscanned to select only the drawings that are stated as not scanned (No) in the list.

8. Click OK.
The selected drawings appear in the Drawing List.
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Once your session is started, you can open the Database Selector window anytime to load other drawings.
To load drawings when the Scan module is already launched:
1. Select File > Open Drawings.
2. Follow from step 4 to step 8 the previous step by step: To launch the Scan module and load your scene:
on page 14.

Related Topics
•

Creating Scenes, Elements and Drawing Lists below

•

Creating Elements from the Scan Module on the next page

•

Creating and Editing a Drawing List on page 20

Creating Scenes, Elements and Drawing Lists
To be able to scan your drawing, you must have a scene, element and drawing list ready. You can create these
directly from the Harmony Scan module without having to go through the Control Center.
To create a scene from the Harmony Scan module:
1. Launch the Harmony Scan module and log in the database using your Harmony user name.
The Database Selector dialog box opens, displaying the Environments available from the Harmony
database.

2. Select the Environment and the Job in which you want to a Scene in.

3. Click on the Create Scene button
The Create Scene dialog box opens.
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Launching the Harmony Scan Module and Loading Drawings

4. In the Scene Name(s) field, type the new scene’s name.

‣

Press [Enter] after each scene’s name to create more than one scene.

5. Select the file system from the File System list.

‣

Click on the Other File System browse button to select another file system to use.

Refer to the Toon Boom Server Guide to learn more about creating project in the database.

6. Select where you want to position your new scenes in the database scene list using the Add Scenes dropdown menu.

‣

At Bottom: The new scenes will appear at the bottom of the scenes list.

‣

At Top: The new scenes will appear at the top of the scenes list.

‣

Name Sort: The new scenes will be sorted out in the scene list following their alphanumerical order.

7. Click on OK.
The new scenes appear in the Database Selector.

Creating Elements from the Scan Module
To create elements from the Scan module:
1. Launch the Harmony Scan module and log in to the database using your Harmony Scan user name.
The Database Selector dialog box opens, displaying the Environments available from the Harmony Stage
database.
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2. Select the Environment, Job and Scene in which you want to add elements.

3. Click on the Create Element button.

If the System Administrator did not complete the resolution configuration tasks, a warning message
will open. This message notifies you that the resolution.conf file was not properly inserted in the
configuration folder.

4. Click on the OK button to continue.
The Harmony Scan module interface and the Create Element dialog box open.

5. In the Name field, type the new element’s name.

6. Enable the Vector option if the element is to be vectorized.

7. Choose the Bitmap Format of your element from the drop-down list. This drop-down menu is only
available if you did not enable the Vector option.
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Launching the Harmony Scan Module and Loading Drawings

8. Select the Scan Type option from the drop-down menu.

‣

Colour: Select this option to create a colour bitmap element.

‣

Greyscale: Select this option to create a greyscale bitmap element.

‣

B&W: Select this to create a vector based element that is going to be painted using the Harmony
Stage or Harmony Paint module.

‣

None: Select this option if you want to create an element that is not destined to be scanned, but that
will be imported.

9. Select the field chart size of your element from the drop-down list.

10. When you are done:
‣

Click OK to add the element and return to the Database Selector.

‣

Click Add to add the element and keep the dialog box open to add more.

‣

Click Close to cancel and return to the Database Selector without adding an element.

Creating and Editing a Drawing List
There are two ways you can create and edit a drawing list from the Scan module.
•

Creating or Editing a Drawing List When Loading your Element.

•

Creating or Editing a Drawing List When your Element is Already Loaded.

To create or edit a drawing list when your element is already loaded:
1. In the Harmony Scan module, select Edit > Drawing List.
The Drawing Selector dialog box opens listing all the drawings contained in the loaded element.
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‣

The Drawing column lists the name of the drawings.

‣

The Scanned? column indicates if the drawing has been scanned (Yes) or not (No).

2. Type a drawing name in the Add Drawing field.

3. Press on Add Drawing.
The new drawing appears in the list.
4. Select the drawings you want to scan.
‣

Select specific drawings from the list using your mouse pointer. You can select several drawing using
[Shift] + click.

‣

Press All to select all the drawings in the list.

‣

Press None to unselect all drawings.

‣

Press Scanned to select only the drawings that are stated as scanned (Yes) in the list.

‣

Press Unscanned to select only the drawings that are stated as not scanned (No) in the list.

5. Click OK.
The selected drawings appear in the Harmony Scan module Drawing List.
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Setting up the Scanner

Setting up the Scanner
Once you launched the Harmony Scan module and loaded your drawing list, you can setup your scan session with
the different scanner option in the Scan module Control Panel.
To setup the scan session:
1. Launch the Harmony Scan module and load your drawing list.
2. In the Control Panel:

a From this drop-down menu, select one of the scanners that is connected to the host machine. The default
model is the one that appears first in your scanner configuration file, scan.conf.
You can find the scan.conf file under:
•

Linux: /usr/local/ToonBoomAnimation/harmony_10.0/lnx86_64/bin/ConfigEditor

•

Mac OS X: Applications > Toon Boom Harmony10 > Tools > Configuration Editor

•

Windows: All Programs > Toon Boom Harmony10.0 > Tools > Configuration Editor

b Select which type of scan you want to do from the drop-down list. If you have more than one scanner
connected to your computer, only the scanners that support the selected scan type will be active.
•

Black & White: Select this option if you are scanning a line art drawing that you will paint in the Paint
or Stage module.

•

Greyscale: Select this option to capture the shades of grey in your drawings.

•

Colour: Select this option to scan a pre-coloured drawing, such as a background or an overlay.

When you setup the type desired type of scan, additional and context sensitive options appear on the
lower part of the control panel. See step 3 to learn more about these option.
c Select the location of the pegs or registration holes on the paper you are scanning from the drop-down list.
The system will automatically rotate the images based on your selection.
•

Bottom Peg: The peg holes appear below the drawing.

•

Top Peg: The peg holes appear above the drawing.

•

Left Peg: The peg holes appear on the left of the drawing.

•

Right Peg: The peg holes appear on the right of the drawing.

d Select the desired resolution from the dpi drop-down list. This determines the quality and the size of scanned
images. The resolutions that appear in the list depend on the selected scanner.
e Select the size of the paper you are scanning from the drop-down list. The different choices appear in field
units. Note that the autofeed mode does not support paper larger than 12 field.
f Enable the Pencil Test option if you want to perform a line test. It will create a black and white image with no
paintable colour art regions. If you select this option the Scan: Pencil Test Confirmation dialog box opens.
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•

Press Yes to confirm.

•

Press No to cancel.

g Enable the Optical Registration option to automate the alignment of your drawings using the registration
holes on your drawing paper.
h Enable the Flip Drawing option to flip the scanned image horizontally and realign the registration holes.
Once you setup the main scanner options from the Control Panel, you are now ready to proceed to a test scan to
calibrate your scanned images.

Related Topics
•

Configuring Scanners on page 43

•

Scanner Information below

Scanner Information
You can display the scanner information, such as the scanner name, device, model and description with the Info
command.
To show the scanner information:
1. Select Scanner > Info.
The Scanner Information dialog box opens.

2. Click on the Close button to close the dialog box.
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Performing a Trial Scan

Performing a Trial Scan
The Harmony Scan module allows you to perform test scans to determine the proper threshold or gamma
setting for a drawing. This test scan allows you to preview the scanned image without saving it.
You can perform a trial scan by auto feeding the drawing through the scanner, or by pegging the drawing on the
scanner.

Refer to the Toon Boom Animation website for a complete list of the supported SCSI adapters,
scanners and auto-feeders. http://www.toonboom.com/products/harmony/ and click on Detailed
System Requirements.

To perform a trial scan:
1. Launch the Harmony Scan module and load your drawing list.
2. Place the drawing either on the scanner pegs or in the automatic document feeder (ADF).
3. Select the appropriate feeding type from the Control Panel:

‣

Autofeed: Select this option to feed the drawings through the automatic document feeder (ADF).

‣

Autofeed (One): Select this option to accept one drawing from the ADF when the Scan button is
being pressed.

‣

Pegged: Select this option to scan a drawing from the flatbed each time the Scan button is being
pressed.

‣

Pegged (Many): Select this option to automatically scan a drawing from the flatbed every five to ten
seconds (depending on the time required to process the drawings).

‣

Pan Cel: Select this option to scan a drawing that is bigger than the scanner window in separate
sections.

4. Click Preview.
‣

If you are manually pegging the drawing, make sure you close the scanner cover before you click the
Preview button.

When the scan is complete, the drawing appears in the Scan module preview area.
5. Adjust the image parameters. Different options appear on the Control Panel, depending on the Scan
Type you selected earlier. Refer to topic to learn how to set the Scan Type.
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‣

Threshold
When using a Black and White scan type, use this slider to adjust the exposure.

‣

Black Point
When using a Greyscale scan type, use this slider (in conjunction with the White Point Slider) to adjust
the contrast. Greyscale values that are less than the selected value will be converted to black.

‣

White Point
When using a Greyscale scan type, use this slider (in conjunction with the Black Point Slider) to adjust
the contrast. Greyscale values that are greater than the selected value will be converted to white.

‣

Gamma
When using a Colour scan type, use this slider to adjust the colour contrast.

‣

Speed
Use this slider to adjust the time required to scan a line (measured in lines per millisecond) at which to
scan drawings, if your scanner supports variable speeds. Use the drop-down menu to set predefined
speeds of Fast or Normal.
Use the drop-down menu to set a predefined or custom speed:

•

Fast: Set a predefined speed for fast scans.

•

Normal: Set a predefined speed for normal scans.

•

Custom: Set a custom speed for your scans. The slider will become active and you can use it to set the
required speed.

6. Click Preview to view the changes.
7. Keep adjusting these values until you get the effect you want. These values will be applied to all the
subsequent drawings you scan.

To keep the image from a trial scan without having to re-scan the drawing, press the Save button.
This assigns the image to the currently selected drawing name in the Drawing List and marks it as
Scanned.
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Scanning Drawings

Scanning Drawings
After building your exposure sheet, opening the cells in the Scan module, configuring your scanner, fine tuning
your scan settings and previewing your scanned drawings, you are now ready to begin the final scanning
process.
There are five ways in which you can feed your drawings through the scanner:
•

Autofeed: Scan the drawings in the automatic document feeder (ADF).

•

Autofeed (One): Scan the drawings in the ADF one at a time, and click Scan for each drawing.

•

Pegged: Scan a drawing on the scanner, and click Scan each time you change the drawing on the scanner.

•

Pegged (Many): Automatically scan the drawing in the scanner every five to ten seconds (depending on
the time required to process the drawings).
However, this mode does not scan each drawing automatically when you click the Preview button.

•

Pan Cel: Scan a drawing into the system in separate sections, because the drawing is bigger than the scan
window.

You may find that the Autofeed option is not available on your system, since your scanner may not support it.
The field size you select can also determine which mode is available.
•

All scanning modes support 12 field.

•

The Autofeed modes do not support 16 field or higher.

When you start scanning your drawings, the Scan module scans the drawings in the order in which they appear in
the Drawing List. After setting these options, you may only need to perform Previewing Scanned Drawings and
Scanning Drawings for future scans.

•

If you want to reverse the order of these drawings, select Edit > Reverse List Order.

•

If you want to make any other sorting changes, you can reselect the drawings from the
Drawing Selector dialog box.

•

You may need to re-enter your list of drawings using the File > Build Manual List command.

Related Topics
Advanced Scanning Techniques on page 33
•

Scanning by Placing the Drawings Manually on page 29

•

Pegging and Scanning a Pan Cel on page 30

•

Stopping the Scanning Process on page 31

Scanning with the Automatic Document Feeder
If the selected scanner supports an automatic document feeder (ADF), you can select Autofeed or Autofeed
(One) to scan the drawings.
•

Autofeed: Scans all the drawings in the ADF.
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•

Autofeed (One): Scan the drawings in the ADF one at a time, and click Scan for each drawing.

You can use the ADF to scan a stack of drawings continuously on a black and white scanner. Many scanner
models support up to A3-sized paper in the ADF (15 field). If you are scanning a 16 field drawing, you may have
to manually peg it on the scanner.
Since you must splice the multiple drawings in a pan cel together once you’ve scanned them all, you cannot feed
pan drawings through the ADF. When you use the black and white scanner’s ADF to scan a stack of drawings,
the scanner optically detects the peg holes on the drawing and registers the image accordingly.
To scan your drawing using the automatic document feeder (ADF):
1. Launch the Scan module and load your drawing list.
2. Select the appropriate feeding type from the Control Panel:

‣

Autofeed: Select this option to feed the drawings through the automatic document feeder (ADF).

‣

Autofeed (One): Select this option to accept one drawing from the ADF when the Scan button is
being pressed.

3. Sort the paper drawings in your scanner in the same order as they appear in the Drawing List.

The Scan module uses the Drawing List order to scan the drawings.
4. If need be, reorder the Drawing List:
‣

To reselect the drawings you want to scan, select Edit > Drawing List.

‣

To reverse the Drawing List order, select Reverse List Order

5. Before placing the drawings in the ADF paper chute, make sure you position the paper guide closest to
the back of the scanner as far out as it can go (towards the back of the scanner).
6. Place the drawings in the ADF paper chute (either face up or face down, depending on the type of scanner
you have).
‣

The first drawing to scan must be at the bottom of the stack once you put it on the scanner, with the
registration holes towards the back of the scanner (where the pegs are).

‣

When you place the drawings in the ADF paper chute, insert them so that they are slightly touching the
paper guide closest to the back of the scanner, and the edge of the drawings lightly touching the
inside of the ADF.
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Do not insert the drawing too tightly on the inside of the ADF or multiple drawings may feed through
at one time, causing registration errors.

7. Slide the other paper guide over (closest to the front of the scanner) so that it slightly touches the
drawings. You are now ready to scan your drawings.
8. Select a scanning mode from the Mode drop-list.
‣

If you want to scan the stack of drawings continuously without having to initiate the scan each time, set
the scan mode to Autofeed.

‣

If you want to scan the drawings one at a time from the ADF, set the scan mode to Autofeed (One).

9. Click on the Scan button.
The scanner begins to capture the drawings. Once you click Scan, this button and the Preview button
become inactive during the scanning process.
‣

You can click the Stop button to interrupt the scan. For more information on interrupting the scan, see
the topic .

As the scanner captures the drawings:
‣

The drawing appears in the Image panel.

‣

You should check the drawings as the scanner captures them to ensure that the line quality is
consistent from drawing to drawing. If necessary, you can adjust the threshold for a drawing.

‣

You can modify the scale to better view the drawings.

‣

If you select Autofeed from the Mode drop-list, the animator’s label for the drawing you just scanned
appears in Last Scanned panel. The Last Scanned panel appears only in Autofeed or Autofeed (One)
modes.
A portion of the entire scanned image appears in this window. Scroll to the animator’s label using the
scroll bars.

‣

The entire drawing appears in Frame Preview panel.

‣

When the scan is complete, the Drawing List tags the drawing as Scanned and highlights the next
drawing.

‣

If an Optical Registration Error occurs, an error dialog box appears.

•

Make sure that you place the drawing correctly in the ADF and that there are no tears or rips on the
drawing’s registration holes. You can try feeding and scanning the drawing again by clicking the Retry
button.

•

The size of the paper you used may not be close enough to a standard 12 field paper size. The Scan
module looks for the centre peg hole at a specific distance from the leading edge of the paper (give or
take an inch).

•

To correct this error, you must scan these drawings on a flatbed scanner instead of using an ADF
scanner.

•

To continue scanning and fix the drawing later, press the Skip Drawing button. The scanner marks the
drawing as Not Scanned and the autofeed takes the next drawing.

When the scanner captures the last drawing in the Drawing List, the Scan and Preview buttons become
active again.
10. If you want to re-scan a drawing, simply select the cell name from the Drawing List panel and click Scan.
‣

Remember to change the feeding mode you selected before clicking the Scan button. If you are
scanning one drawing, select Autofeed (One) from the Mode drop-down list.
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‣

If you are re-scanning more than one drawing, select Edit > Drawing List, type the names of the
drawings you want to re-scan, and click OK.

If a paper jam occurs in the automatic document feeder (with the compatible scanners) you can use
the Eject Page command to eject the jammed page. Select Scanner > Eject Page. If the option is not
compatible with your scanner, the command will be greyed out.

Scanning by Placing the Drawings Manually
You can scan a drawing by placing it on the scanner registration pegs yourself. If the drawings you want to scan
are too large to fit in the scanner’s automatic document feeder, or do not feed properly due to rips, wrinkles, or
folds in the drawing, you can manually peg the drawings.
To do this, you must set the scanner mode to Pegged or Pegged (Many).
•

Pegged: Scans the drawing from the flatbed. You must click Scan again each time you change the drawing
on the scanner.

•

Pegged (Many): scans the drawing fro the flatbed every five to ten seconds (depending on the time
required to process the drawings).

However, this mode does not scan each drawing automatically when you click the Preview button.
To scan by manually pegging drawings:
1. Select one of the following:
‣

Pegged: To place the drawing on the scanner’s pegs and click Scan for each drawing.

‣

Pegged (Many): To place the drawings on the scanner’s pegs yourself, but you want the scanner to
automatically scan whatever is on the scanner bed every five to ten seconds.

2. Check the Drawing List to see which drawing you are scanning next. It will appear highlighted.
‣

You can select the drawing you want to scan by pointing to the desired drawing in the Drawing List,
and clicking Scan.

‣

You can reverse the order of the Drawing List by selecting Edit > Reverse List Order.

The Drawing List sorts the cell names from your exposure sheet alphanumerically. Therefore, you should
keep this in mind when assigning names to these cells, otherwise, you may need to resort your drawings
so that the Scan module can assign them in the correct order.
3. Lift the scanner’s cover, and place the paper drawing face down on the scanner glass with the peg holes
of the drawing placed on the registration pegs bar placed on the scanner. This should be the paper
drawing that corresponds to the drawing highlighted in the Drawing List.
You can place both 12 field and 16 field paper on the same registration pegs on the scanner. The Field
Size drop-down menu in the scanner’s setup options defines the size of paper being scanned.
4. Close the scanner cover, making sure the paper is laying flat against the glass, free of wrinkles and folds.
You are now ready to scan the drawing.
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Never scan a drawing while the scanner cover is open. If you do, large black areas can appear around
the edges (similar to a photocopier with the lid open). The scanner interprets this extra black area as
part of the drawing, which drastically slows the vectorization process. If by mistake you do scan a
drawing with the cover open, you can go to the vectorize queue and delete the entry before it starts
processing. Refer to the Toon Boom Server Guide to learn more about this.

5. Click Scan.
‣

If you set the scan mode to Pegged, the scanner scans the drawing, then stops and waits for you to
change the drawing and click the Scan button again.

‣

If you set the scan mode to Pegged (Many), the scanner continues to capture a drawing every five to
ten seconds (depending on how long it takes to process each drawing).

While the scanner captures the drawing, the Scan button becomes inactive.
‣

You can use the Stop button to interrupt scanning at any time. For more information on interrupting
the scanning process, see .

When the scan is complete, the captured image appears in the Scan module. The Drawing List marks the
drawing as Scanned and the next drawing to scan appears highlighted.
6. If you set the scan mode to Pegged (Many), you must wait for the scanner to stop after each drawing and
place the next one before it starts again.

Pegging and Scanning a Pan Cel
Pan cels are drawings that contain more than one set of registration holes. Because pan cels are large, you
cannot scan the entire image with one pass on the scanner.
Therefore, you must scan pan cels one section at a time (one set of registration holes at a time). After you scan
each section of the pan cel, the application splices the sections together to create the original pan cel image.
There must be exactly eight inches between the centre peg holes (the round holes) for each pan cel and the peg
holes must all align exactly. This is important if the Scan module must make slight seaming adjustments to
compensate for angle differences when it joins all the pan cels to form one drawing.
To scan a pan:
1. Launch the Scan module and load your drawing.
2. Select the Pan Cel mode from the Control Panel:
The Peg Hole panel appears below the Image panel.

‣

By default, two pegs appear in the Peg Hole panel. If your pan cel has more than two peg holes, you
can use the New button to add more of them.
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‣

If you added too many peg holes, simply select a different format from the Mode button and reselect
Pan Cel again. The two peg holes reappear by default.

3. Determine where peg hole A appears on your pan cel.

The Harmony Scan module considers peg hole A to be the leftmost peg position on horizontal pan
cels, and the topmost peg position for vertical pan cels.

4. Place the pan cel face down on the scanner glass with the round A peg hole placed on the round
registration peg on the scanner or position it in the optical registration search area as defined earlier.
Close the scanner cover.
5. Select the peg hole you are scanning first from the Peg Hole panel.

‣

This procedure assumes you are scanning peg hole A first, then continuing scanning the rest of the
peg holes in sequence.

‣

You can actually scan the peg holes in any order, as long as you make sure to select the lettered
button in the Peg Hole panel that corresponds to the peg position you are scanning.

6. Click on the Scan (A) button.
‣

You can click on the Stop button to interrupt scanning at any time. For more information on
interrupting the scanning process, refer to the Scanning Drawings on page 26topic .

The scanner scans the first section of the pan cel and displays a preview of the scanned image above the A
button in the Peg Hole panel.
7. On the scanner, move the pan cel so that the peg hole B is on the round registration peg on the scanner
or position it in the optical registration search area as defined earlier and close the scanner cover.
8. Select the B radio button from the Peg Hole panel and click the Scan (B) button.
The scanner inputs the second section of the pan cel and displays a preview of the scanned image above
the B button in the Peg Hole panel.
9. Repeat these steps until you scanned all the panels of your pan cel.
10. Click on the Save button once you have scanned all the drawings for the pan cel to form a single drawing.

Stopping the Scanning Process
You can use the Stop button to interrupt scanning at any time. The scanner may not stop immediately since the
Scan module must finish its current process.
The Stop Scanning dialog box will appear, giving you two choices of action:
‣

Stop Immediately button: This option will stop the scanner from finishing the current drawing scan.
The Scan module will mark the drawing as Not Scanned.
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‣

Scanning Drawings

Finish This Drawing button: This option will continue scanning and will save the current drawing and
then stop the scan process.
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Advanced Scanning Techniques
In most cases, you only need to scan your drawings into empty cells in your exposure sheet. Harmony is flexible
enough to allow you to add drawings in other ways. These other methods include:
•

Scanning paper drawings without matching cells in the exposure sheet

•

Loading previously scanned images into matching cells in the exposure sheet

Scanning Drawings without Matching Frames
If you want to preview one or more drawings that don’t have a corresponding list of cells in the Control Center’s
database yet, you don’t have to go through the whole procedure of creating an environment, defining the jobs,
scenes, and elements, and then creating an exposure sheet. These would be a list of cells that were not entered
in the exposure sheet and do not appear in the Database Element Selector dialog box.
To be able to scan these new drawings, you must specify the path and file names for the drawings to be saved.

The Harmony Scan module does not vectorize these types of digital drawings and you cannot view
them in the Control Center. If you do decide to use these drawings, you must follow the standard
procedure for scanning drawings for a regular scene (with the Control Center and Harmony
Stage modules).

To manually build a list of drawings to Scan:
1. Select File > Build Manual List.
The Manual List dialog box appears.

2. In the Path field, type an existing directory path where you want to store the scanned drawings in the
Path field.

3. You can type a name in the Prefix field that appears at the beginning of the scanned files that correspond
to the drawing names you subsequently add to the manual list.
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For example, if you enter the name of the character joe in the Prefix field, then add the drawing names 01
and 02, the Drawing List would display 01 and 02, but once you scan the drawings, the files would appear
as follows:
‣

joe-01

‣

joe-02

The prefix and a dash automatically appear in front of the drawing names you add when the Scan
module creates the files of the scanned drawings.

4. Type the name of the drawing you want to scan in the Drawings field and click the Add button. The name
of your drawing appears in the Drawings panel. Repeat for every drawings you must add.

‣

For a quick way to create a series of drawings, you can type the first number and the last number with
a colon symbol (:) in between.

For example, if you want to create a series of drawings number one to six, you would type the following in
the Drawings field and click on the Add button:
•

1:6

5. Select the drawings you want to add to the Drawing List. By default, all the entries appear selected, but
you can select the drawing(s) you want to scan.

6. Click the OK button to close the Manual List dialog box.
The selected drawings appear in the Drawing List of the Scan module’s Control Panel.
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To modify the manual entries in the Drawing List, you must reopen the Manual List dialog box and go
through the process of building the manual entries again.

Loading Previously Scanned Drawings
The Load From File command allows you to load a previously scanned drawing into the Scan module. This is
useful if you want to view a drawing you already scanned.
To load a previously scanned drawing:
1. Select File > Load From File.
The Select File To View dialog box displays the directories and files in the current directory. You can load
graphics in any of the following bitmap formats:
‣

OMF: Open Media Framework image format. This format is compatible with Avid applications.

‣

OPT: An optimized version of the SCAN image format. This format retains the alpha channel
information for the image. It also preserves the quality of the image while keeping the file size low.

‣

RCI: The drawings are in Recognition Concepts Inc. image format.

‣

Scan: The scan image format. This format retains the scanning information about the image
(resolution in dpi, drawing registration), which the Stage Module uses.

‣

SGI: The drawings are in a Silicon Graphics Inc. image format. This format retains the alpha channel
information for the image.

‣

TGA: The drawings are in a Generic Targa image format. This format contains the alpha channel
information for the image and is widely compatible (cross-platform).

‣

VAR: The drawings are in a Variable header image format,

‣

YUV: The drawings are in a graphic type for animations that appear in National Television System
Committee (NTSC) image format,

‣

PAL: The drawings are in a graphic type for animations that appear in Phase Alternating Line (PAL)
image format.

2. Browse to the folder where your scanned drawings are saved.
3. Select the file you want to view.
4. Click OK.

Setting the Vectorization Style
You can set the vectorization style you want to apply to the subsequent drawings that will be sent to the
Vectorize Queue in the Control Centre, using the Vectorize Style command.
To set the vectorization style:
1. Select Edit >Vectorize Style.
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The Vectorization Styles dialog box opens.

2. Select the desired vectorization style from the list.
3. Click on the OK button.

Refer to the Harmony Stage User Guide to learn how to edit and setup the vectorization styles.

Refer to the Harmony Server User Guide to learn more about the Vectorize Queue and the Control
Centre.
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Chapter 1:
Scan Menu Commands

Topics Covered
•

Scan Commands on the next page

•

File Commands on page 39

•

Edit Commands on page 40

•

Scanner Commands on page 41

•

Help Commands on page 42
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Scan Commands
About Toon Boom Scan
If you are using Mac OS X, use the AboutScan command to display product and version information.
To activate this command:
‣

Select Scan > About Scan

Quit Toon Boom Scan
If you are using Mac OS X, use the Quit Scan command to close the Harmony Scan module window and end the
current session.
Use one of the following methods to activate this command:
‣

Select Scan > Quit Toon Boom Scan

‣

Press [⌘ ] + [Q].
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File Commands
Build Manual List
Use the Build Manual List command to open the Manual List dialog box and create a list of labelled cells.
To activate this command:
‣

Select File > Build Manual List

Exit
If you are using Windows or Linux, use this command to close the Scan Module and end your session.
Use one of the following methods to activate this command:
‣

Select File > Exit

Load From File
Use the command to open the dialog box and select a previously scanned drawing that you want to load into the
Harmony Scan module.
To activate this command:
‣

Select File > Load From File

Open Drawings
Use the command to open the Database Selector dialog box in which you will be able to select drawings to be
scanned in, or add new scenes and elements to a job.
Use one of the following methods to activate this command:
‣

Select File > Open Drawings

‣

Select File > Load From File
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Edit Commands
Drawing List
Use the command to open the Drawings Selector dialog box and label cells to accept drawings.
To activate this command:
‣

Select Edit > Drawing List

Create ScanInfo File
Use the Create ScanInfo File command to create a plaintext file for each subsequent scan. This file will contain
information such as the paper size and the DPI used when scanning. Each plaintext file is located in the same
directory and has the same filename as the scanned image with the file extension SI.
To activate this command:
‣

Select Edit > Create ScanInfo File

Reverse Drawing List
Use the Reverse Drawing List command to reverse the sequence of drawings in the Drawing List.
To activate this command:
‣

Select Edit > Reverse Drawing List

Vectorize Style
Use the Vectorize Style command to open the Vectorization Styles dialog box and select the vectorization style
you want to apply when you scan drawings.
To activate this command:
‣

Select Edit > Vectorize Style
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Scanner Commands
Eject Page
Use the Eject Page command to eject a page from a scanner’s automatic document feeder (ADF). This command
is only activated when a paper jam occurs.
This option is not available on all the scanners. If this option is not compatible with your scanner, the command
will be greyed out.
To activate this command:
‣

Select Scanner > Eject Page

Info
Use the command to open the Scanner Information dialog box to view scanner name, device, model and
description information.
To activate this command:
‣

Select Scanner > Info
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Help Commands
About
If you are using Windows or Linux, use the About command to display product and version information.
To activate this command:
‣

Select Help > About

Debug Mode
Use the Debug Mode command to access the Debug window which helps to identify a problem encountered in

the software.
To activate this command:
‣

Select Help > Debug Mode

Help
Use the Help command to view the integrated help system.
To activate this command:
‣

Select Help > Help
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Chapter 1: Configuring Scanners
This chapter explains how to connect, configure, and calibrate your scanner so that it will work with Harmony. It
is important that you install the scanner hardware according to the manufacturer's instructions.
Before you can configure your scanner, you should have the scanning machines themselves already configured,
switched on, and connected to your system.

Topics Covered
•

Configuring a Scanner for Harmony (Windows 7) on page 46)

•

Configuring Scanners for Harmony (Linux) on page 51

•

Configuring Scanners for Harmony (Mac OS X) on page 53

•

Configuring Scan.conf to Communicate with the Scanner on page 55

•

Adapting the Scanner Hardware on page 58

Configure the Scanner Using the Harmony
Configuration Wizard
After you upgrade your SCSI adapter and record information about the scanner attached to your computer, you
are ready to configure your scanner to communicate with Harmony.
Use the Harmony Configuration Wizard to configure your scanner.
To launch the Harmony Configuration Wizard:
‣

From the Start menu, select All Programs > Toon Boom Harmony 10.3 > Tools > Configuration
Wizard. The Harmony Configuration dialog box opens.

To configure your scanners:
1. In the Harmony Configuration dialog box, click Scanners Configuration.

The Scanner dialog box opens.
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2. In the Name field, type or select the scanner's name.
3. In the Model field, select the scanner model.
4. In the Interface drop-down menu, select the scanner interface type.
5. From the SCSI controller number drop-list, select the SCSI number that identifies your SCSI Adapter.
6. From the SCSI ID drop-list, select the SCSI number of the scanner.
7. From the Logical unit number (LUN) drop-list, select logical unit number. Due to a scanner's default
configuration and the nature of the device, the LUN should always be zero.
8. After you've completed all the fields in this dialog box, click on the Add button.
9. Repeat the previous steps in this procedure for each scanner you want to add.
To remove a scanner from your list, select the scanner from the Name field and click on the Remove
button.
10. After you've added all your scanners, click on the Next button.
The Review dialog box opens.
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11. Read the summary of how you've configured your scanner and decide if you want to continue.
•

If the summary is accurate, click Finish to complete the configuration.

•

If you want to change something about the configuration, click Back until you reach the dialog box where
you can change the option.
After you make your changes, click Next until you reach the Review dialog box again.
A confirmation message appears when the system updates your Scanner configuration file (Scan.conf).
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Configuring a Scanner for Harmony
(Windows 7)
After you have installed the hardware, you must perform the following tasks, outlined in this section:
•

Run the findscanner Utility below

•

Configure the Scanner Using the Harmony Configuration Editor on the facing page

Run the findscanner Utility
To configure your scanners using the Harmony Configuration Wizard, you need to know about the following
scanner information:
•

Adapter ID number

•

Path ID

•

Target ID

•

Logical unit number (LUN)

To get this information, run the findscanner utility we have provided with Harmony. findscanner issues a report
including all of this information.
To run the Findscanner utility:
1. Locate findscanner.exe. It is stored in
\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 10.0\win64\bin.
2. Double-click the file in a file browser to launch it.
The application opens a terminal or command prompt and displays a report.
In this example, the scanner is on the last line. The information you need is contained in this segment:
a6;p0;t6;l0.

‣

a6: this is the Adapter ID number and its value is 6.

‣

p0: this is the Path ID and the value is 0.

‣

t6: this is the Target ID and the value is 6.

‣

l0: this is the Logical unit number (LUN) and the value is 0.

3. Record this information so that you can enter it into the Harmony Configuration Wizard.
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Configure the Scanner Using the Harmony
Configuration Editor
Once you have recorded information about the scanner attached to your computer, you are ready to configure
your scanner to communicate with Harmony. Use the Harmony Configuration Editor to configure your scanner.
To launch the Toon Boom Harmony Configuration Editor:
1. From the Start menu, select All Programs >Toon Boom Harmony 10.0 >Tools > Configuration Editor.
The Configuration Editor dialog box opens.
To configure your scanners:
1. In the Configuration Editor dialog box, select the Scan.conf tab.

2. Scroll down the text until you reach the Examples for Windows 7section.
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3. Using the list, locate the model of scanner connected to your computer.
‣

When you find the models that matches, edit the file to remove the pound signs (#) in front of each
lines of that example.
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‣

If none of the models match the scanner connected to your computer, highlight all the lines of the
example that is the closest to your scanner model and paste them below that example. Once the lines
are pasted, edit the file by removing the pound signs (#) in front of each line of that new example.

Make sure that a pound sign (#) separates the pasted example from the one above and below it.

4. Edit the following lines of the example:
host: Enter the hostname of the computer the scanner is connected to.
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If you don't know the hostname of the computer, open a Command Prompt window, type the
"hostname" command and press the Enter key. This will give you the name of the computer.

name: Enter a name for the scanner configuration that will appear in the Scan module.
device: Enter the information returned by the Find Scanner utility. Ex.: a6;p0;t5;l0
‣

If the example you just edited matches the scanner model connected to your computer, read the
information entered for the host, name and device and decide if you want to continue.

‣

If the configuration is accurate, then go to the File menu, save the changes made and close the
Configuration Editor.

‣

If the example you've just edited did not match the scanner model connected to your computer, you
will need to edit the following lines as well:

model: Enter the model of the scanner connected to the computer.

Make sure that the scanner model is included in the supported scanner list found at the beginning of
the Scan.conf document and that the syntax is identical as well.

descr: Enter a short, but meaningful description of the scanner. Ex: B&W Ricoh or Colour Fujitsu.
5. If the information entered for the host, name, device, model and descr entry are accurate, then go to the
File menu, save the changes made to the file and close the Configuration Editor.

Other configurations, like the default Threshold, Gamma, Black&White point and Resolution can also
be edited later if need to.
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Configuring Scanners for Harmony (Linux)
After you have installed the hardware, you must perform the following tasks, outlined here:
•

Identify the Name of the Scanner Device Driver below

•

Set Permissions for the Scanner on the next page

Identify the Name of the Scanner Device Driver
You must identify the name of the SCSI device that is working with your scanner so that you can configure
Harmony to communicate with it.
Device drivers all have names starting with /dev/sg. If your scanner is the only generic SCSI device connected to
your system, it is likely that the name of its driver is
/dev/sga.
If you are uncertain about the device name, you can use the findscanner utility provided with Harmony. Use
the findscanner utility to probe your SCSI bus for devices. It will tell you the name of the device being used by
scanners attached to your system.

The device name of your scanner will change if you add, remove or swap other generic SCSI devices.

To use the findscanner utility to identify your scanner:
‣

Launch the findscanner utility. While in the bin folder of your Harmony installation, type the
following in a terminal or command prompt:
./findscanner

The findscanner utility is installed in /usr/localToonBoomAnimation/harmony_10/ln86_64/bin/
If you have scanners connected to your computer and they are properly installed, the findscanner utility will
return information like the following:
/dev/sga type=6: Scanner device RICOH IS450 Vers:1R04
/dev/sgb type=6: Scanner device FUJITSU fi-4750Cdm Vers:0G00
If findscanner cannot find SCSI scanners attached to your computer, it will return a statement like this:
No scsi devices attached
If you get this message, it may indicate that your system could not initialize your SCSI adapter at boot time.
To make sure your SCSI devices are initialized correctly when you boot Linux:
1. Change to the /boot directory and rename the initrd-[version].img file, where [version]
represents the version of your kernel. You can run the uname -r command to find out the version of
your kernel.
cd /boot
mv initrd-2.4.18-3.img noscsi-initrd-2.4.18-3.img
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2. Type the following command:
/sbin/mkinitrd initrd-2.4.18-3.img 2.4.18-3
This command will recreate a new "init ramdisk" image that will load your SCSI driver when your system
starts.
3. Reboot your system.

Set Permissions for the Scanner
If you want multiple user accounts to be able to access your scanner, you must modify the permissions on the
device driver.
To change the permissions on the scanner:
‣

Type the following on a command line:
chmod 666 /dev/sga

/dev/sga must represent the device driver for your scanner.
To set the permissions on the scanner each time you boot:
1. Open /etc/rc.d/rc.local in a text editor.
2. Add the following line:
chmod 666 /dev/sga
3. Save and close the file.
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Configuring Scanners for Harmony (Mac OS
X)
This chapter explains how to configure your scanner to work with Harmony on Mac OS X.
Before you can configure your scanner, you should have the scanning machines themselves already configured,
switched on, and connected to your system.
After you configure your scanner, you must modify the hardware so that Harmony can align images scanned
using autofeed.

Modifying the Scan.conf File
After you have installed your scanner hardware, you must configure your scanner to communicate with Harmony.
To do this, you must find the name of your scanner using the Find Scanner Utility. Then, you must add this name
to the Scan.conf file.
To modify the Scan.conf file:
1. Open a Terminal and type:
findscanner.

The path to Harmony's terminal applications must have been registered for this process to work.
Refer to the Mac OS X Installation chapter to learn how to register the path to the Terminal
application.

findscanner reports the following information:
Device found:
<FUJITSU/M4097Ddim>
The device foundmust be copied into the Scan.conf file, including the angle brackets.
2. Modify the Scan.conf file with the Harmony Configuration Editor. Open a Finder and select
Applications > Toon Boom Harmony 10 > Tools > Configuration Editor.
3. In the Harmony Configuration Editor, select the Scan.conf tab.
Here is an example of entries in a Scan.conf file for a Fujitsu scanner on Mac OS X.
host: scan1
name: Fujitsu BW
model: Fujitsu_M4097D
device: <FUJITSU/M4097Ddim>
descr: The scanner to use for black & white and greyscale scans.
defaultGamma: .89
defaultResolution: 200
The following options must be included in the Scan.conf file:
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•

host: [hostName]

where [hostName] is the name of the machine that the scanner is attached to.
•

name: [scannerName]

where [scannerName] is the name you want the scanner to be listed as in the scanner drop-list in the Scan
module.
•

device: <device name>

where <device name> is the name findscanner reports. You must include the angle brackets.
•

model:[modelName]

where [modelName] is the model name of your scanner (the name is case sensitive and there can be no
spaces separating the name and the number). Following is a list of supported scanners.
Epson_836XL
Epson_1640XL
Epson_GT-15000
Fujitsu_M3096G
Fujitsu_M4097D
Fujitsu_fi4750C
Fujitsu_fi5750C
Fujitsu_fi6770
Ricoh_IS330
Ricoh_IS420
Ricoh_IS430
Ricoh_IS450
Ricoh_IS760
TWAIN
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Configuring Scan.conf to Communicate with
the Scanner
Once your scanner is set up and you know the device driver name, brand and model, you are ready to configure
the Scan.conf file so that Harmony can communicate with it. The Scan.conf file contains a number of
configuration parameters you can use to control the communication between your scanner and Harmony.
The Harmony Configuration Wizard updates the Scan.conf file with the required information. If there are other
variables you want to modify in this file, use the Harmony Configuration Editor.

Related Topics
•

The Scan.conf file is found in: below

•

You can find a copy of the original default Scan.conf file in: below

The Scan.conf file is found in:
Windows 7:
C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 10.0\etc

Mac OS X:
1. Application > Toon Boom Harmony 10 > tba > etc
2. Hold down [CTRL], click Shared Modules and then select Show Packages Contents.
3. Open the etc folder.
Linux:
/usr/local/ToonBoomAnimation/harmony_10.0/etc

You can find a copy of the original default Scan.conf
file in:
Windows 7:
C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 10.0\resources\samples

Mac OS X:
1. Applications > Toon Boom Harmony 10 > tba > resources > samples

Linux:
/usr/local/ToonBoomAnimation/harmony_10.0/resources/samples
Here is an example of entries in a Scan.conf file for a Ricoh scanner on Linux.
host: scan-1
name: My_Ricoh_IS450DE_Scanner
descr: The scanner to use for black & white and greyscale scans.
device: /dev/sga
model: Ricoh_IS450DE
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defaultThreshold: 80
defaultResolution: 200
registrationStrictness: Loose
The following options must be included in the Scan.conf file:
•

host: [hostName]

where [hostName] is the name of the machine that the scanner is attached to.
•

name: [scannerName]

where [scannerName] is the name you want the scanner to be listed as in the scanner drop-list in the Scan
module.
•

device:
•

Linux: /dev/[filename]

where [filename] is the filename of the device driver for your scanner.
•

Windows: scX;dY;lZ

The SCSI identifier for the scanner.
X=controller number (normally 0)
Y= device number (as set on the scanner)
Z= The logical unit (normally 0)
ex: device: sc0;d5;l0 (if the scanner is set to scsi id 5)
•

Mac OS X: <device name>

where <device name> is the name findscanner reports. You must include the angle brackets.
•

model:[modelName]

where [modelName] is model name of your scanner (the name is case sensitive and there can be no spaces
separating the name and the number). Following is a list of supported scanners.
Epson_1640XL
Epson_GT-15000
Fujitsu_M3096G
Fujitsu_M4097D
Fujitsu_fi4750C
Fujitsu_fi5750C
Fujitsu_fi6770
Ricoh_IS330
Ricoh_IS420
Ricoh_IS430
Ricoh_IS450
Ricoh_IS760
TWAIN
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The following are optional additions to the scanner description.
•

descr: [scannerDescription]

Where [scannerDescription] is a description of the scanner, which appears to the user in the Scanner
Information dialog box in the Scan window. This text must be all on one line.
•

defaultThreshold: [value]

Where [value] is the default value for threshold for black and white scanning. The value should be an
integer (0
•

≤

[value]

≤ 255). The default threshold value at installation is 100 if no value is specified.

defaultBlackPoint: [value]

Where [value] is the color value (0 < [value] < 255) that the Scan module considers to be black. The Scan
module forces any color darker than this value to black. If no value is specified, it defaults to 20.
•

defaultWhitePoint: [value]

Where [value] defines the color value (0 < [value] < 255) that the Scan module considers white. The Scan
module forces any color lighter than this value to white. If no value is specified, it defaults to 235.
•

defaultGamma: [value]

Where [value] is the default value for color and grayscale gamma correction
(0.0 < [value]
specified.
•

≤ 2.55) on the scanner. The default gamma value at installation is 1.0 if no value is

defaultResolution: [value]

Where [value] is the default resolution in dpi (dots per inch) for the scanner. The value should be an integer
that is one of the scanner's legal resolutions. The default resolution value at installation is 300. For Fujitsu
and Ricoh scanners, 300 DPI is appropriate. For color scanners, like the Epson, 150 DPI is suggested.
•

defaultPegSide: [value]

Where [value] defines the default value in the Peg-Side menu when you select the scanner. You can choose
between Top, Right, Left or Bottom.
•

registrationStrictness: [level]

Where [level] defines how exact the location of the peg holes must be for the software to recognize them.
You have two values to choose from:

•

•

Strict: the peg holes must be in a tightly defined area to be recognized. This is the default setting.

•

Loose: the peg holes can be anywhere in a larger area to be recognized. This setting is
recommended.

pegPitch: [value]

Where [value] is the number of decimal places permitted when defining the distance in inches between
side pegs. The peg pitch can be defined to fix splicing problems when aligning pan cels. The default value
is 8 (e.g., a distance of 0.12345678 could be defined).
•

side0CleanSize: [value]
side1CleanSize: [value]
side2CleanSize: [value]
side3CleanSize: [value]

Where [value] is the distance in inches from the edge of the drawing that will not be included in the scan.
Including these values can save vectorization time and remove dirtiness at the edges of a drawing. Side
"0" is the side with peg holes. Remaining sides are numbered in clockwise fashion.
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Adapting the Scanner Hardware
Before you start using your scanner, you must make a few minor adjustments to make sure it can handle the
special types of animation paper you will be using.
These adjustments are described in the following tasks:
•

Modifying the ADF Paper Chute below

•

Installing a Strip of Black Tape on the ADF Paper Path on page 60

•

Mounting the Peg Bar and Calibrating the Scanner on page 63

Modifying the ADF Paper Chute
On the ADF paper chutes of supported Fujitsu scanners, the paper guides are connected to each other by a cog
wheel that keeps the paper guides and the drawings centred on the chute. Adjustments must be made to this
type of Fujitsu scanner to avoid problems during the scanning process.
To compensate for the centred scanning on the ADF chute of Fujitsu scanners, you must do one of the following
tasks:
•

Modifying the Scan.conf for Centred ADF Scanning below (requires no hardware modification)

•

Removing the Cog Wheel on Paper Chute on the facing page

•

Adding a Paper Guide to your ADF Scanner on the facing page

Modifying the Scan.conf for Centred ADF Scanning
We have added support for the leftOffset option to the Scan.conf file. Use this option if you don't want to
modify the ADF chute so that it is aligned towards the back of the scanner.
To calculate the leftOffset option, consider that the paper chute on all Fujitsu scanners we support is 12
inches wide. If your paper is 10.5 inches wide, the difference between the chute and the paper is 1.5 inches. Since
this difference is distributed on both sides of the paper chute, the offset from either edge is 0.75 inches.
Therefore, the leftOffset option would be 0.75.
We added the leftOffset option to this sample of the Scan.conf file:
host: scan-1
name: Fujitsu10.5
descr: The scanner to use for black & white and greyscale scans.
device: sc1;d5;l0
model: Fujitsu_fi4750C
defaultThreshold: 80
defaultResolution: 200
registrationStrictness: Loose
leftOffset: 0.75
You can add additional entries in the Scan.conf file to support paper of different sizes. For example:
host: scan-1
name: Fujitsu8
descr: The scanner to use for black & white and greyscale scans.
device: sc1;d5;l0
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model: Fujitsu_fi4750C
defaultThreshold: 80
defaultResolution: 200
registrationStrictness: Loose
leftOffset: 2

Removing the Cog Wheel on Paper Chute
If you don't want to modify the Scan.conf file, you can remove the cog wheel so that the paper guides can slide
independently.
This allows you to position the paper guide closest to the back of the scanner as far as it can go towards the
back of the scanner. You can then slide the other paper guide up to meet the bottom edge of the stack of
drawings to keep them aligned.

To remove the cog wheel, remove the paper chute from the scanner and remove the screw that attaches the cog
wheel to the paper chute. After you remove the cog, the paper guides should be able to slide independently of
each other.

Adding a Paper Guide to your ADF Scanner
Instead of removing the cog wheel on the ADF paper chute, you can make a paper guide to place between the
existing paper guides to keep the stack of drawings in the proper alignment in the paper chute.
To perform this procedure, you need the following materials:
•

A paper guide made out of cardboard, a block of wood, or similar material.

•

Adhesive tape to secure the paper guide to the paper chute.

To place a paper guide on your scanner:
1. Open the ADF paper guides to their widest position.
Place the paper guide closest to the back of the scanner as far out as it can go (toward the back of the
scanner).
If you did not remove the cog wheel, this will make for a very wide paper chute, wider than most of your
animation paper.
Now you must create an intermediate paper guide to hold your drawings in place.
2. Place a stack of drawings in the paper chute so that they are touching the back paper guide. Make sure
the back paper guide is as far back as it can go.
3. Position the paper guide you created to secure the other edge of the paper stack.
4. Secure the paper guide with tape.
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Installing a Strip of Black Tape on the ADF Paper Path
When you scan drawings with the Scan module, drawings on paper become digital images in the Harmony
system. These digital images must be properly aligned during the scan process to ensure that the animation
flows smoothly from frame to frame in the final output.

•

If you want to scan many drawings using the ADF chute on your scanner, you must use the Optical
Registration option in the Scan module to automate the alignment of your drawings.
When you enable Optical Registration, the Scan module tries to identify the peg holes to align the
drawings.
You can also use the Optical Registration option if you want to manually scan a drawing on the flatbed
part of the scanner.

•

If you have a peg bar attached to your scanner, you don't have to use optical registration because the
drawings will be aligned by the peg bar. However, you will have to scan your drawings one at a time.

Peg holes in your drawings must be filled with black in the final, scanned image for the optical registration to be
able to locate them. Your scanner must be modified prior to scanning to ensure black peg holes appear in the
scanned image.
For ADF Scanning
Tape a piece of dark paper to the ADF feeder in the position where the peg holes will pass as they are scanned.
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If you don't place the black tape on the ADF paper path, the peg holes in the drawing pass in front of a white
background. This does not provide enough contrast for the Scan module to distinguish where the peg holes are
and it will not be able to register and align the autofeed drawings.
For Manual Scanning
Tape a piece of dark paper to the scanner cover above the position of the peg holes.
RICOH Scanner

Fujitsu Scanner - ADF
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Fujitsu Scanner - Cover

Before you perform this procedure, you need the following materials:
•

A strip of black adhesive tape approximately 1.25 inches (3.5 cm) by 0.75 inches (2 cm). Black plastic
electrician's tape is fine.

•

A sheet of drawing paper with field size and peg hole locations identical to the type that you intend to
scan with the autofeeder.

To install the tape on the ADF paper path:
1. Turn off the scanner's power and open the ADF cover.

2. Place the paper guides in their scanning position. This will depend on your scanner and any modifications
you made to it.
3. Place the drawing paper in the paper chute with the peg holes toward the back of the scanner.
The top edge of the paper should touch the paper guide closest to the back of the scanner.
4. Slide the paper into ADF chute.
5. Place the strip of black tape across the width of the white strip on the inside of the ADF cover. Use the
peg holes in the drawing paper as a visual guide.
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6. Close the ADF cover and scan a few test drawings to see that the Scan module can identify the peg holes.

Mounting the Peg Bar and Calibrating the Scanner
Autofed and manually pegged drawings must register against each other if you intend to use both scanning
methods. Therefore, you must calibrate the scanner so that it can register the peg holes accurately using the Peg
Bar.
Before you perform this procedure, you need the following materials:
•

An ultra-thin peg bar.
Suggestion:- Audio-Visual Stainless Steel Pegbar (catalog number AP105)
•

Accurate ACME standard registration

•

3-peg, single-field length (0.05" x 1.5" x 12.0") (1.27mm x 38 mm x 304.7mm)

•

Low brass pegs (1/16" in height) (1.58 mm in height)

•

Lightweight sprung stainless steel base

•

Ideal for work requiring exposure on a process camera, print down frame or scanning bed

This is obtainable from Chromacolour International http://www.chromacolour.com
•

A drawing with field size and peg hole locations identical to the type you intend to scan.
Instead of using a drawing of a character or object, you may find it helpful to create a test "drawing" by
placing a sheet of drawing paper over a field chart and tracing several heavy line segments from the field
chart.
For more accurate calibration, draw lines from the centre to the edges of the paper. This will give more
reference points at various locations on the paper.
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Before calibrating the scanner:
‣

Create a small scene in Harmony using the test drawing.

‣

Using the Control Center module, create a Job that has one scene.

‣

Using the Harmony Stage, create an exposure sheet for the Job that has two drawing columns (one
for the drawing you will autofeed and one for the drawing you will manually peg before scanning).

To mount the peg bar and calibrate the scanner:
1. Create a test scene.
2. Open the Scan module and open the elements you created.
3. Perform an Autofeed scan of the test drawing in the autofeed element, with Optical Registration
enabled.
4. After the drawing has vectorized, load it in Stage by reopening the scene.
5. Loosely tape the peg bar to the scanner bed (centre the bar horizontally on the scanner bed; move the
bar vertically on the top of the scanner bed).
6. Scan the pegged drawing with the Autofeed feature off.
7. After the drawings has vectorized, load it in Stage by reopening the scene, and compare its alignment
with the drawing scanned in step 4.
‣
8. If the two images do not align, move the peg bar and re-scan the pegged drawing again.
9. Repeat these steps until you have aligned the drawings. When the peg bar is in the desired position,
securely attach the peg bar to the scanner bed.
You can keep the test drawing for future use.
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