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Chapter 1: Installing on Windows
This document explains how to install Toon Boom Harmony on Windows.
There are three stages required to install Toon Boom Harmony 10.3, these are covered in the following topics:
1. Pre-installation on the next page
2. Toon Boom Harmony Installation on page 13
3. Configuration on page 18
After completing these stages, you can verify the integrity of the installation and resolve any configuration issues.
•

Troubleshooting on page 40
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Pre-installation
Before installing Toon Boom Harmony, you must perform the following task:
•

Check Your Minimum Requirements below

•

Prerequisites for Harmony Installation below

•

Pre-installation Configuration on the facing page

Check Your Minimum Requirements
For the most current Toon Boom Harmony hardware requirements, refer to the white paper Harmony and Your
IT Department. This is available from:
•

Toon Boom Animation Sales Representative

•

Toon Boom Animation Support at: support@toonboom.com

Prerequisites for Harmony Installation
For a fast database connection, it is necessary to set up extra network settings so that the clients can perform a
fast Name Resolution of the server as well as the server to the clients.
•

Get the Product Activation Code below

•

Additional Network Settings below

•

Windows 2008 Server on the facing page

Get the Product Activation Code
You should obtain a Product Activation code from the Toon Boom licenser so that you can finish the installation
process without having to wait for the activation code to arrive.
To obtain a Harmony 10.3 activation code, please send the following information to: licensor@toonboom.com.
•

Your name and the name of your company

•

Email address where to send the license file

Additional Network Settings

These steps for editing the hosts file are only required if there are problems or slowness when a
computer is resolving names. DO NOT edit the hosts file unless there are problems resolving
names on the network.

1. Setup the server and clients' IP with a static (fixed) IP address.
2. Go to C:\WINDOWS\system32\drivers\etc\ folder and open the hosts file using a plain text editor.
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3. Go to the end of the file, on a new line add the static IP address and the machine name accordingly. If you
are using a domain, you need to use the fully qualified domain name (FQDN).
For example, if the server name is server.toonboom.com in the domain and the IP address of the
server is 192.168.1.1, the line should be:
192.168.1.1 server.toonboom.com
4. Add the rest of the client's IP and hostname on a new line and click Save.
5. Once the list is complete, you can copy and paste the hosts file to all of the machines including the server
under the C:\WINDOWS\system32\drivers\etc\ folder.

Windows 2008 Server
For a Windows 2008 server, you need to perform some additional steps to complete the task.
If you have a domain, you need to add a usabatch user on the global group where all the Harmony users are,
this user should have administrator account rights.
•

The user name is usabatch

•

The password is usabatch

If an error due to the password policy occurs, you can change the password policies for both Domain Controller
Security Policy and Domain Security Policy. You also need to do this from the Domain server if the Domain server
is different from the Harmony database server.
1. From the WindowsStart menu, select Control Panel.
2. In Control Panel, double-click on Administrative Tools.
3. In Administrative Tools, select Group Policy Management.
4. In the hierarchy view of the Group Policy Management, go into the Domain used by Harmony, right-click
on Default Domain Policy and click on Edit....
5. In the hierarchy view of the Group Policy Management Editor window, go in Computer Configuration>
Policies> Windows Settings> Security Settings> Account Policies> Password Policy.
6. In the right part of the Group Policy Management Editor window, double-click on Password must meet
complexity requirements.
7. Select Define this policy setting and the Disabled radio button.
8. Click OK.
Wait for the changes to take effect or restart the Server. It can take several minutes for the domain
controller to update and use the new settings.
Once this is done you will be able to create the user usabatch, this user should be inside of the Harmony
user group.

Pre-installation Configuration
Configure your computer before installation by performing the following tasks:
•

Turn off Anti-Virus Software on the next page

•

Turn off the Firewall on page 11

•

Turn Off Use Simple File Sharing on page 12
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Inform your System Administrator before proceeding with these tasks.

Turn off Anti-Virus Software

Inform your System Administrator before proceeding with this task.

To disable your anti-virus software:
1. Click the Start menu and select Settings > Control Panel. The Control Panel opens.
‣

Vista Users: Click the Start menu and select Control Panel.

2. Double-click the Security Center icon

in the Control Panel window. The Windows Security Center

dialog box opens.
‣

Vista users must turn off Malware Protection.

3. If your anti-virus software is not detected, open all anti-virus software applications on your computer and
disable each one manually.
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Turn off the Firewall

Inform your System Administrator before proceeding with this task.

To disable the Windows Firewall:
1. Open the Windows Firewall dialog box.
‣

Click the Start menu, and select Control Panel to open the Control Panel. Double-click the Windows
Firewall
icon.

‣

In the Windows Firewall window, click on the Turn Windows Firewall On or OffTurn Windows
Firewall On or Off link on the left side panel

2. Select the Turn off Windows Firewall option for both private and public network locations to turn the
firewall off.
3. Click OK to confirm your selection.
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Turn Off Use Simple File Sharing
1. Open Windows Explorer.
2. Select Organize > Folder and Search Options.
3. In the View tab, if the option Use Sharing Wizard (Recommended) is on, deselect it.

Related Topics
•

Toon Boom Harmony Installation on the facing page
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Toon Boom Harmony Installation
Now that you have verified your minimum requirements, and configured your hardware and software, you are
ready to install Toon Boom Harmony.
You will perform the following tasks:
1. Upgrading from a Previous Installation below
2. Installing Toon Boom Harmony on page 17

Upgrading from a Previous Installation
If you are not upgrading from a previous installation of Toon Boom Harmony, go directly to Installing Toon
Boom Harmony on page 17.
If you are performing an upgrade, you should pick a time when Toon Boom Harmony production is slow or
stopped. During the upgrade, no users can run any of the Toon Boom Harmony modules and all rendering jobs
must be stopped and complete.
Before you can update a previous installation of Toon Boom Harmony, you must stop all services, including:
•

The database server

•

Batch processing

•

The license server

Related Topics
•

Stop Services Affecting Harmony below

•

Stop the License Server on the next page

•

Removing Harmony Related Environment Variables on page 15

•

Backing up any Necessary Configuration Files: on page 16

•

Uninstalling the Previous Version of Toon Boom Harmony or Opus on page 16

Stop Services Affecting Harmony
To stop all services affecting Toon Boom Harmony:
1. Make sure that no one is running Toon Boom Harmony.
All Toon Boom Harmony modules must be closed on the server and on all of the clients.
2. Make sure that all batch rendering or vectorizing is complete or that the queues are empty.
You can check the status of the Vectorize and Render queues from the Control Center module.
3. In the Control Center module, use the Queue menu to open the Vectorize and Render Queue for all
environments. The queues should either be empty or the status of all jobs should be "Completed".
Upgrading from V7.2 or earlier:
‣

Click the Start menu, select All Programs > Toon Boom Harmony (or Opus) > Configuration Tools >
usa_cfg. The USAnimation Properties window opens.
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Upgrading from a previous version of V7.3:
‣

Click the Start menu, select All Programs > Toon Boom Animation > Toon Boom Harmony > Tools
> Harmony Control Panel. The HarmonyProperties window opens.

Upgrading from V7.8, V9.2 or a previous V10 version:
‣

Click the Start menu, select All Programs > Toon Boom Harmony > Tools > Control Panel. The
Harmony Control Panel window opens.

4. Select a process from the Process Starter drop-list and click Stop. Do this for every Toon Boom Harmony
related process running on the machine.
During this process, you will be able to stop the tbdbserver on the server and tbprocess on
workstations that are set as a batch render.

5. Turn off all of the client machines and the render farm.

Stop the License Server
6. On the License server computer:
‣

First, click the Start menu, and select All Programs > Harmony > Configuration Tools > FLEXlm lmtools.

The LMTOOLS window opens.

‣

•

If you are upgrading from version 7.3 click the Start menu, and select All Programs >
Toon Boom Animation > Harmony > Tools > Flexlm Tools.

•

If you are upgrading from version 7.8 click the Start menu, and select All Programs >
Toon Boom Harmony 7.8 > License Tools > Flexlm Tools.

Next, in the Start/Stop/Reread tab, select the license server in the Remote Server List.
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‣

Click the Stop Server button.

‣

In the Config Services tab, click the Remove Service button to remove the license service.

7. Close FLEXlm " lmtools".

Removing Harmony Related Environment Variables
To complete the installation, you need to remove some environment variables set by the previous installation.

Please do this with caution.

1. Click the Start menu and select Control Panel.
The Control Panel opens.
2. Double-click on System and select the Advanced system settings link in the left panel.
3. In the Advanced tab, click on the Environment Variables button.
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4. In the System Variables panel, select LM_LICENSE_FILE if it is listed, and then click Delete button to
delete LM_LICENSE_FILE.
5. Delete any of the following variables if they appear in the System or User variables lists: TOONBOOM_
LICENSE_FILE, USADB, USADIR or USAROOT.

Backing up any Necessary Configuration Files:
You also need to back up any necessary configuration files from the machine in case you want to reuse them. You
can also back up the license.dat during this procedure.
1. Do one of the following:
‣

For V7.8, go to \Program Files (x86)\Toon Boom Animation\Harmony 7.8\etc.

‣

For V7.3, go to \Program Files (x86)\Toon Boom Animation\Harmony\etc.

‣

For V7.2 and earlier, go to the \usa\etc folder.

2. Back up any necessary configuration files:
‣

Scan.conf if this workstation is to be configured as a scanning station.

‣

VectOptions.conf from any machine (including the server) that is doing a batch vectorization.

‣

Any other.conf file that is required to be used later.

You can back up the whole /usa or harmony folder to ensure all configuration file are backed up.

3. Go to the/usa/etc/flexlm folder and back up the license.dat

Uninstalling the Previous Version of Toon Boom Harmony or Opus
Once you finish all the steps above, you should uninstall the previous version of Harmony or Opus.
1. Click the Start menu and select Control Panel. The Control Panel opens.
2. Double-click Program and Features and choose Harmony or Opus from the program list. And then, click
Uninstall from the top menu.
3. Reboot the machine.
Backup the database

Backup the database
For the server upgrading process, please backup the database by exporting the whole database. This
will prevent you from losing any data during the upgrading process. You can, however, back up
current /usa_db and /usadata by renaming them (this procedure can only be used when installing
on the same server). But this will require extra caution, if you are at all unsure contact your system
administrator or Toon Boom Animation Support.
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Installing Toon Boom Harmony
To run the installation script:
1. Download the build of Harmony that you are going to install.
2. Double-click on the Harmony InstallShield executable.
3. Select the language in which you want the installer to execute and click OK. This will only affect the
installer and will not change the language of the actual software.
4. In the InstallShield Welcome window, click Next to continue with the installation. The License
Agreement dialog box appears.
5. Read the license agreement and decide if you accept its terms.
‣

If you accept the terms in the license agreement, select I accept the terms in the license agreement
then click the Next button.

‣

If you do not accept the terms in the license agreement, click I do not accept the terms in the license
agreement then click the Next button. The installation will stop immediately and Toon Boom
Harmony will not be installed on your computer.

The Destination Folder dialog box appears. You can click Cancel to interrupt the installation and then
click Yes to stop the installation completely.

You can install Toon Boom Harmony to any location. In this installation guide, it assumes that the
installation process is done to the default location.

6. Select the drive on which you want to install Toon Boom Harmony and click Next. The Setup Type dialog
box appears.
7. Select the type of installation you want to do. Click on the Complete radio button to install all of the
Harmony components.
When installing a server, it is possible to do a custom install and install only the server component.
However, it is recommended to always do a full install, this will give access to all the applications from the
server if need be.
8. Click the Next button. The Ready to Install the Program dialog appears.
9. Click Install again to begin the installation.
When this process is complete, click Finish.

Related Topics
•

Configuration on the next page
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Configuration
After installing Toon Boom Harmony, you need to configure database parameters depending on your machine's
setup and third-party software, and reinstate your anti-virus settings.
1. Configure Toon Boom Harmony below
2. Sharing Toon Boom Harmony Related Directories on page 22
3. Configure the License on page 26
4. Turning on the Anti-Virus Software on page 37

Configure Toon Boom Harmony
You can use the Toon Boom Harmony Installation Wizard at any time to:
•

Modify the Toon Boom Harmony server or client configuration

•

Configure batch processing

•

Configure scanners

•

Prepare a client to be the client of a Linux server

•

Add Harmony's path to the Path environment variable

After installation, you must set up the database configuration for computers running Toon Boom Harmony.
1. Set Up the Database Server on the facing page
2. Set Up the Database Client on page 21
To launch the Toon Boom Harmony Configuration Wizard:
‣

From the Start menu, select All Programs > Toon Boom Harmony 10.0 > Tools > Configuration
Wizard.

The Toon Boom Harmony Configuration dialog box opens.
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Set Up the Database Server
The Database Server controls all interactions with the contents of the Toon Boom Harmony database. It
processes all requests to open, read or update files, keeping track of files that are locked so that others cannot
edit them.
To set up the Database Server:
1. In the Toon Boom Harmony Configuration dialog box, click the Database button.

2. Select Server/Standalone and click Next.

3. Select the location of the database from the drop-list and select a username and a password for the user
that will be running the database services.
The default account is usabatch. If the account specified does not exist, it will be created by the wizard.
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Make sure to take note of the account name and password if an account other than the default one is
used. This information will be required later on for client workstations to connect to the server.

4. Click Next.
The configuration program creates the database, /USA_DB, in the location you select. The /USA_DB
tracks the location of the scene data on the file system. You can have multiple file systems, but only one
/USA_DB.

If you are upgrading from a previous version of Harmony or Opus and you have renamed /usa_db
for back-up, you need to create new usa_db at the same location where the previous /usa_db was
located.

5. In the Scene Data Location window, you create the storage locations for the database.
‣

From the File system drop-list, you select the file system you want to add. The first File system is
already created for you. If you want to create additional file systems, you must click Add. For example,
if you want to store scene data across multiple drives or computers, you can create them here.

‣

From the Drive drop-list, select the drive where you want to create the file system.

‣

In the Share field is the name of the file system that will be created. You can change this value.
However, it is recommended to leave the default name, which increments from usadata000.

‣

In the Host Computer field, enter the name of the computer on which this file system will be created.
By default, the current computer's name will appear here. You can create file systems on other
computers if necessary.

‣

Specify the username and the password that will be used to connect to that file system. It is
recommended to use the same username and password as the one used for the database, in the
previous step.

6. Click Next. The Toon Boom Harmony: Review window opens.
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7. Review the information in the window. If it is correct, click Finish.
When the configuration wizard is finished, a dialog box opens which indicates the success of the process.

Set Up the Database Client
After you have configured your server, you can configure all of the client machines that will connect to the server.
Use the Toon Boom Harmony Configuration Wizard to connect client computers to the database.
To set up the Database Client:
1. In the Harmony Configuration dialog box, click the Database button.

2. Select Client and click Next.
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3. Enter the name of the Toon Boom Harmony server and click Next. The Review window opens.
4. Verify the database changes and click Finish.
A message will appear when the client computer is successfully connected to the database server.

It is possible to change the user account used to connect to the USA_DB or the different file systems
using the Toon Boom Control Panel, which can be started from
Start > Programs > Toon Boom Harmony 10.0 > Tools > Control Panel.

Sharing Toon Boom Harmony Related Directories
These steps don't have to be done in a typical installation. This is required only when the shares were not
created correctly during the server configuration procedure. For example, this situation could happen when
Simple file sharing was not turned off before running the Configuration Wizard on the server . Other cases
would be when you have backed-up your USADB and usadata folders prior to installation, you may have to share
them when putting them back into place.

If you are upgrading from a previous version and you have changed the /usa_db and /usadata
during upgrade, please roll back to the normal name before continuing.

To activate file sharing for the Toon Boom Harmony folder:
1. Open Windows Explorer.
2. Locate the Toon Boom Harmony folder C:\Program Files (x86)\Toon Boom
Animation\Harmony10.0.
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3. Right-click the folder and select Properties from the pop-up menu to open the Properties dialog box.

4. Click the Sharing tab.
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5. Click on Advanced Sharing...
6. Type usa in the Share Name field.

Changing the name of the share to usa must only be done when sharing the Harmony folder. The
USA_DB and USADATA folders should keep their original name.

7. Click the Permissions button to display the Permissions dialog box.
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8. Set all permissions in the Everyone group to Allow and click OK to save the settings and close the dialog
box.
9. Back in the File Properties window, click the Security tab.
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‣

Click the Edit button to prompt the permissions window. Set all permissions in each group or user to
all.

10. Click OK to save the settings and close the dialog box.
11. Repeat Step 3 to Step 10 with the usa_db and usadata folders.

Configure the License
Configuring the license server
1. Launch the License Wizard from Windows Start menu > All Programs > Toon Boom Harmony 10.0 >
License Tools > LicenseWizard.
2. Depending on how the License Wizard was started, the first page of the License Wizard will be one of
the following:
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The Activation Options screen appears:

3. Click on Internet Activation
The Internet Activation Options screen appears:
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4. Click on Network License.
The Internet Activation - Network License screen appears:
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5. Type or copy/paste the Product Code and type in the number of licenses this product code grants you.
NOTE: Once activated, server license cannot be returned to the activation server. Make sure you are
activating the license on the correct computer with the proper license count.
6. Click on Next.
The Install License Server screen appears:
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7. Click on Install License Server.
This step will create the license.dat file and place it in /usr/local/flexlm/licenses/license.dat. The
license.dat created contains the following information:
SERVER this_host 0 ANY
VENDOR toonboom
USE_SERVER

It will also configure and start the License Server service.
The Activation Successful screen appears:
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8. Click on Finish to exit the wizard.
9. Once finished with the License Wizard, take a look at the lmgrd.log to make sure it was started
properly.
C:\flexlm\lmgrd.log
10. You can now go in LMTOOLS to verify that the License server has been configured properly and that it is
running.
Below are the default parameters for the license service.
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11. It is good practice to verify that the license service it properly running by going in the Server Status tab
and clicking Perform Status Enquiry.
•

Restore backed up data below

•

Setting up the License on Client Workstations on the facing page

Restore backed up data
1. Stop the tbdbserver by opening the Toon Boom Harmony Control Panel. There select the
HarmonyStart0-tbdbserver from the list and click the Stop button.
You can verify that the tbdbserver was properly stopped by looking to see if the service is gone in the
process tab of the task manager.
2. Open the File Explorer and rename the new empty USA_DB database folder to USA_DB_NEW .
3. Rename the USA_DB_BAK (the one that was backed up earlier) to USA_DB to restore the previous
database.
4. Copy the dicts files from the new database (USA_DB_NEW/dicts) to the one you have restored (USA_
DB/dicts).
NOTE: Dicts files can also be copied from C:\Program Files\Toon Boom Animation (x86)
\Harmony 10.0\etc\USADB_templates\dicts
5. Share the USA_DB folder giving full control every one. Make sure that simple file sharing is turned off
before doing this.
If you cannot set permissions per use for the share, it means that the simple file sharing is turned on.
6. Rename the new empty usadata000 folder (and any other file system folder) to usadata000_NEW.
7. Share the usadata000 folder (and any other folder you have restored) giving full control everyone.
8. Start the tbdbserver by opening the Toon Boom Harmony Control Panel. There select the
HarmonyStart0-tbdbserver from the list and click the Start button. After starting the tbdbserver,
look at the tbdbserver.log to make sure it was started properly.
C:\ProgramData\Toon Boom Animation\Toon Boom Harmony
9. Verify that you are able to open Harmony and scenes from the server.
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Setting up the License on Client Workstations
An Admin account is required to set this up. After activation you can login as client.
To set up the license on a client workstation do the following:
1. Open the License Wizard on the Client machine. The License Wizard appears.

2. Click on Activate License. The Activation Options screen appears.
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3. Click on Alternative Activation. The Alternative Activation screen appears.
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4. Click on Use License Server. The Server Activation screen appears.
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5. Click on Connect to Server. The Server Activation - Shared License dialog appears.
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6. Enter the hostname or the IP Address in the License Server address field.
7. Click Connect. You will be prompted for a password.
8. Enter the password and click ok. The Activation Successful screen appears.
9. Click Finish to close the License Wizard.

Turning on the Anti-Virus Software
Inform your System Administrator before proceeding with this task.
To turn the anti-virus software back on:

‣ Reactivate virus protection. If your anti-virus software is not detected, open any anti-virus software
applications on your computer and reactivate each one manually.
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Turning on the Firewall
The process to do this is basically the reverse of the procedure used to deactivate the firewall.
Inform your System Administrator before proceeding with this task.
Re-enabling the firewall
1. Click the Start menu, and select Control Panelto open the Control Panel. Click on Windows Firewall.
2. Click on Turn Windows Firewall on or off. The Windows Firewall Setting dialog box appears.

3. Click on the Turn on Windows Firewall radio buttons to turn the firewall back on.
4. Click on OK to activate the option.

Creating Inbound Rules
1. Back in the Windows Firewall window, click on the Advanced Settings link.
2. Click on Inbound Rules to display the list of Inbound Rules. Click on New Rule on the right side of the
window.
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3. Select the Program radio button and click Next.
4. Select the This Program Path radio button and click on the Browse button. Navigate to the Harmony
installation path and select tbdbserver.exe. Click Next.
5. Select the Allow the Connection radio button and click Next.
6. Select the appropriate profiles for which this rule will be applied according to your network configuration
and click Next.
7. Finish the Rule creation process by clicking Finish.
8. Repeat steps 1 to 7 for tbprocess.exe and toonboom.exe.
9. Repeat steps 1 to 7 for lmgrd.exe if this computer will be used as a License server.

Related Topics
•

Troubleshooting on the next page
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Troubleshooting
If you have any outstanding issues running Toon Boom Harmony after installation, review the installation and
configuration instructions to make sure you have followed them completely. If you continue to have problems,
consult the following list to troubleshoot common installation and configuration problems.
•

Problem: License Error When Starting Any Toon Boom Harmony Module below

•

Problem: Unable to Import Sample Scene (Errors with the tbdbserver) below

•

Problem: Unable to Open Sample Scene on Clients on page 42

•

Problem: resolution.conf Error Message on page 42

Problem: License Error When Starting Any Toon
Boom Harmony Module
If you are getting license errors when you start any Toon Boom Harmony module, check the set up and
configuration of the license service.
•

Make sure that the license.dat file is in the following directory:
C:\flexlm

•

Open the license.dat file.
The license.dat should contain the following information:
SERVER this_host 0 ANY
VENDOR toonboom
USE_SERVER

•

Make sure that the license service is running.

•

If you continue having problems with the license server, locate the file ToonBoomLicense.log and send
it to support@toonboom.com. In Windows, this file is usually in C:\flexlm;.

Problem: Unable to Import Sample Scene (Errors
with the tbdbserver)
Check the tbdbserver.log file. It is usually stored in C:\ProgramData\Toon Boom Animation\Toon
Boom Harmony.
If there is no log file, re-start the tbdbserver.
To restart the tbdbserver:
1. Open the Control Panel.
2. Double-click the Toon Boom Harmony Control Panel
Panel dialog box opens.
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3. From the Process Starter drop-down menu, select the tbdbserver entry.
4. Click Start.
If you continue to have problems with the database server, locate the tbdbserver.log file and send it to
support@toonboom.com. This file is usually in C:\ProgramData\Toon Boom Animation\Toon
Boom Harmony.
You can also run the Dbserver from the command shell in debug mode to receive additional information about
the process.
To run the tbdserver in debug mode:
1. Open Dbserver.conf.
2. Add the following line to the file:
debug_port 5681
3. Stop the tbdbserver service. Click the Start menu and select All Programs > Toon Boom Harmony 10.0
> Configuration Tools > Control Panel. When the Toon Boom Harmony Control Panel window opens,
select the tbdbserver from the Process Starter drop-list and then click Stop.
4. Open a command prompt by selecting Start > All Programs > Accessories > Command Prompt.
5. Type the following:
tbdbserver -debug

While you are running the tbdbserver in debug mode, messages will be written to the shell for each
operation the tbdbserver performs. This is additional information to what is written to the
tbdbserver.log file.

‣ To output this information to a new file, type the following:
tbdbserver -debug > "C:\ProgramData\Toon Boom Animation\Toon Boom
Harmony\tbdbserver_debug.log"
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If you still cannot determine the nature of the problem, send this file to support@toonboom.com with
a detailed description of the problem.

Problem: Unable to Open Sample Scene on Clients
If clients cannot open the sample scene, it is possible that they are not connected to the database server. Follow
the instructions in to connect to the server.

Problem: resolution.conf Error Message
When you open the sample scene, you might get an error message that says that the resolution.conf file
can't be opened. This file is usually stored in the environment or job directory of your database.
There is a sample resolution.conf file in:
\Program Files\Toon Boom Animation (x86)\Toon Boom Harmony 10.0\resources\samples
directory.
You can copy that into either of the following directories:
•

\USA_DB\environments\[environment_name]

•

\USA_DB\jobs\[job_name]

•

\USA_DB\resolution\
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Chapter 1: Installing on Mac OS X
This document explains how to install Toon Boom Harmony 10.3 on Mac OS X.
This document assumes that you are familiar with Mac OS X networking and are capable of working in a
command shell in the Terminal window.
Throughout this document, we will ask you to create files using a text editor. You can use TextEdit, but be sure
to convert your files to plain text before saving them in TextEdit.
There are three stages required to install Toon Boom Harmony 10.3, which are covered in the following topics:
1. Pre-installation on the next page
2. Harmony Installation on page 47
3. Configuration on page 51
4. Configuring Harmony to Share Scene Data on page 64
5. Configuring Harmony Clients on page 73
After completing these stages, you can verify the integrity of the installation and resolve any configuration issues.
•

Troubleshooting on page 77
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Pre-installation

Pre-installation
Before installing Toon Boom Harmony 10.3, you must perform the following task:
•

Check Your Minimum Requirements below

•

Get the Product Activation Code below

•

Prerequisites for Harmony Installation below

Check Your Minimum Requirements
For the most current Toon Boom Harmony 10.3 hardware requirements, refer to the white paper Harmony and
Your IT Department. This is available from:
•

Toon Boom Animation Sales Representative

•

Toon Boom Animation Support at: support@toonboom.com

Get the Product Activation Code
You should obtain a Product Activation code from the Toon Boom licenser so that you can finish the installation
process without having to wait for the activation code to arrive.
To obtain a Harmony 10.3 activation code, please send the following information to: licensor@toonboom.com.
•

Your name and the name of your company

•

Email address where to send the license file

Prerequisites for Harmony Installation
A DNS server must be configured on the network to be able to run Harmony. All the computers running
Harmony must be registered with this server or Harmony will not be able to run properly. If a DNS server is not
configured on the network or if Harmony workstations are having problems resolving the name of the server, the
name of the server and each client along with their IP address should be added to the /etc/hosts file on each
computer.
•

Editing the hosts File below

•

Editing the launchd.conf File on the facing page

Editing the hosts File
To edit the host file:
1. Make sure the server and all the client workstations are configured with a static (fixed) IP address.
2. Open the Terminal (/Application/Utilities/Terminal).
3. From Terminal go to /etc folder by typing the following:
cd /etc
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4. Create a backup copy of the hosts file. You need to be logged in using the root account to be able to do
this. If you are not logged in as the root user, you will need to type sudo before launching the command.
sudo cp hosts hosts.bak
5. Edit the /etc/hosts file using the vi text editor. To do this, you need to be logged in with the root
account. If not, you must type sudo before launching the command.
‣

For example: sudo vi hosts

6. Once the file is opened in the editor, press the [i] key to trigger the insert mode.
7. Go to the end of the file and add a new line. On this new line, type the static IP address and the machine
name (hostname) of the server.
For example, if the server name is server and the IP address is 192.168.1.1, type 192.168.1.1
server on this new line. Make sure there is a space between the IP address and the hostname.
If there is a domain configured on the network, you should also type the fully qualified domain name
(FQDN). Add the FQDN after the hostname separating them with a space.
For example, 192.168.1.1 server server.toonboom.com
To complete this step, add the IP address and the hostname of each of the workstation that will be a
client of the Harmony server. Each of them should be typed on a new line.
8. Once all the IP and hostnames have been typed, you will need to save the file. To do this, press [ESC] to
exit the insert mode.
9. Press the [:] button. The [:] should appear on the bottom of the Terminal, if it does not then you are still in
insert mode. Make sure you did not type the colon somewhere in the files and press the ESC key again
to exit insert mode.
10. Type the letter w. You should now have the following typed at the bottom of the Terminal:
:w
11. Press the return key. The file was written.
12. To exit vi type: followed by the letter q. You should now have the following at the bottom of the
Terminal:
:q
13. Press the return key to quit vi.
The system will return you to /etc in the Terminal.
14. Verify the content of the hosts file by typing:
more hosts
15. Once this is verified, copy and paste the hosts file to all of the client machines.

Editing the launchd.conf File
1. Open the Terminal (/Application/Utilities/Terminal).
2. From Terminal, go to /etc folder by typing the following:
cd /etc
3. If the /etc/launchd.conf file already exists, create a backup copy of it by typing:
cp launchd.conf launchd.conf.bak
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4. Edit the /etc/launchd.conf file using the vi text editor. To do this, you must be logged in with the root
account. If not, you must type sudo before launching the command.
‣

For example: sudo vi launchd.conf

5. Once the file is opened in the editor, press the [i] key to trigger the insert mode.
6. At the beginning of the file, add a line with the following text:
umask 0
7. Once finished, you will need to save the file. To do this, press [ESC] to exit the insert mode.
8. Press the [:] button. The : should appear on the bottom of the Terminal,: if it does not, then you are still in
insert mode. Make sure you did not type the colon anywhere in the file and press the [ESC] key again to
exit insert mode.
9. Type the letter w. You should now see the following at the bottom of the Terminal:
:w
10. Press the return key. The file is written.
11. To exit vi type :q. You should now see the following at the bottom of the Terminal:
:q
12. Press the return key to quit vi.
The system will return you to /etc in the Terminal.
13. Verify the content of the launchd.conf file by typing:
more launchd.conf

Related Topics
•

Harmony Installation on the facing page
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Harmony Installation
Now that you have verified your minimum requirements, and configured your hardware and software, you are
ready to install Toon Boom Harmony.
You will perform the following tasks:
1. Upgrade from a Previous Installation below
2. Creating the usabatch User on the next page
3. Install Harmony on page 50

Upgrade from a Previous Installation
When upgrading from a previous installation of Harmony or Opus, you should pick a time when Harmony or
Opus production is slow or stopped. During the upgrade, no users can run any of the Harmony or Opus modules
and all rendering jobs must be complete. To update previous installations:
1. Make sure that no one is running any versions of Harmony or Opus. All Harmony or Opus modules must
be closed on the server and on all of the clients.
2. Make sure that all batch rendering and vectorizing is complete or that the queues are empty. You can
check the status of the Vectorize and Render queues from the Control Center module.
‣

In the Control Center module, use the Queue menu to open the Vectorize and Render Queue for all
environments. The Queues should either be empty or the status of all jobs should be "Completed".

You must be sure to stop the queues on all rendering machines. If the queues are running, those binaries
will be locked and the installer won't be able to update them.
3. Stop all services running on the server and the clients.
‣

If you are upgrading from 7.3, 7.8, 9.2 or 10.0, type in the terminal:
sudo /sbin/SystemStarter stop ToonBoomQueueServer
sudo /sbin/SystemStarter stop ToonBoomLinkServer
sudo /sbin/SystemStarter stop ToonBoomDataBaseServer
sudo /sbin/SystemStarter stop ToonBoomLicense

‣

If you are upgrading from Harmony or Opus 7.2, type the following into the terminal:
sudo /sbin/SystemStarter stop USAnimation_queues
sudo /sbin/SystemStarter stop USAnimation_link_srv
sudo /sbin/SystemStarter stop USAnimation_dbserver
sudo /sbin/SystemStarter stop USAnimation_flexlm

4. Go to the applicable folder:
‣

10.0: /Applications/Toon Boom Harmony 10/tba/etc

‣

9.2: /Applications/Toon Boom Harmony 9.2/tba/etc

‣

7.8: /Applications/Toon Boom Harmony 7.8/tba/etc

‣

7.3: /Applications/Toon Boom Harmony/usa.bundle/etc

‣

7.2: /usa/etc

47

Chapter 1: Installing on Mac OS X

Creating the usabatch User

5. Backup any necessary configuration files.
‣

Manager.conf

‣

server.ini: if this server is configured to have Windows clients.

‣

Scan.conf: if this workstation is configured to be a scanning station.

‣

VectOptions.conf: from any machine (including the server) that is doing batch vectorization.

‣

Any other configuration file that is required to be used later.

‣

You can backup the whole /Harmony folder to ensure that no configuration file is missed.

6. Go to /usr/local/flexlm/licenses/ (/usa/etc/flexlm/ if you are upgrading from 7.2) folder
and back up the license.dat.
7. Then you can delete the /Applications/Toon Boom Harmony folder, or rename it to keep as a
backup.
8. If you are upgrading from a previous version of Harmony or Opus, you must delete Startup Items from the
previous installation.
From /Library/StartupItems/, delete any folders that begin with USAnimation if you are upgrading
from 7.2. For example, USAnimation_dbserver. Delete any folders that begin with ToonBoom if you
are upgrading from 7.3, 7.8,9.2 or 10.0. For example, ToonBoomDatabaseServer.

Depending on the server and client configuration, you may not see any folders starting with
Toonboom or USAnimation.

If you are upgrading from Harmony or Opus, you will also need to delete extra files that are located in each users
home.
1. Open the Terminal application (/Applications/Utilities/Terminal).
2. Go to a users' home that was configured to work with Harmony. We will use the usabatch account as an
example. To do so, type:
cd /Users/usabatch
3. List all the files in usabatch's home by typing:
ls -lsa
4. Look for a folder named .MacOSX in the list of files and folders that appear.
5. If the folder is there, delete it with the following command:
sudo rm -rf .MacOSX
6. Repeat these steps for each user that was configured to work with a previous version of Harmony.

Creating the usabatch User
Before you install Harmony you must create the usabatch user account on the server and on all the
workstations that will be doing batch processing (computers that will be part of the batch rendering or
vectorizing farm). A number of services, including the tbdbserver, license server and batch processing, are
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started using the usabatch account. In addition to the server, be sure to create the usabatch account on all
machines that may perform batch processing.
The usabatch account must have administrative rights on the computer.

If you are upgrading from a previous version of Harmony or Opus, you may not need to create the
usabatch account since you will use the same account that was created from the previous
installation.

To create the usabatch user account:
1. Open System Preferences. By default, there is a shortcut for System Preferences in the Dock.
2. In the System panel of the System Preferences dialog box:
‣

10.6 (Snow Leopard): Click Accounts.

‣

10.7 (Lion): Click Users & Groups.

The Password tab of the Accounts window opens.
3. To be able to make changes to the accounts on a Mac OS X, you must first click the lock at the bottom of
the window. A dialog box will appear asking you to type your username and password. Type the
username and the password of an account that has administrative privileges.
4. Click the + sign button to add a new user.
5. Give the new user the following name, account name and password:
usabatch
The usabatch account name and password must be in all lower-case letters.
6. Select Administrator from the drop-down menu next to New Account.
7. Create the account:
‣

10.6 (Snow Leopard): Click Create Account.

‣

10.7 (Lion): Click Create User.

8. Once the account is created, open the terminal and login as the usabatch user:
su -l usabatch
9. Make sure you are in usabatch's home folder, then edit or create the .profile for usabatch:
vi .profile
10. Make sure the file contains the following lines:
#!/bin/bash
umask 0
11. Once done, click on [ESC] to exit the insert mode, then type :wq to write the file and exit vi.
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Install Harmony
In a client-server network or in a stand-alone set up, you must install Harmony as well as the following services on
the server or the stand-alone computer:
•

tbdbserver: Controls access to the database.

•

License service: Controls the number of licenses and features available to Harmony users.

•

Batch Processing: Controls batch vectorizing and rendering queues.

•

Link server: If you are installing Harmony on a Mac OS X server that will support Windows clients, you
must install the Link server.

To install Harmony programs and services, you must run the installation package.
Before you start the installation, you need to make sure you are currently logged in the system with
administrative rights on this local computer. You can check it from System Preferences.
1. Open System Preferences. By default, there is a shortcut for System Preferences in the Dock.
2. In the System panel of the System Preferences dialog box:
‣

10.6 (Snow Leopard): Click Accounts.

‣

10.7 (Lion): Click Users & Groups .

The Password tab of the Accounts window opens.
3. Select your user login account and verify if Allow user to administer this computer is checked. If not,
please login to the system with an administrative account and do so.
To install Harmony:
1. Double-click the Harmony dmg file.
2. Drag the Toon Boom Harmony 10 folder from the dmg file to the Applications folder.

Related Topics
•

Configuration on the facing page
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Configuration
After installing Harmony, you must configure the database parameters and the third party software based on
the role this computer will have.
1. Configuring Harmony below
2. Configuring the Licensing on page 54

Configuring Harmony
Once Harmony is installed, additional steps are required to configure the database on the server and to setup
the Startup Items and register the application path for the Terminal.

Set Up the Database Server
The database server controls all interactions with the contents of the Toon Boom Harmony 10.3 database. It
processes all requests to open, read or update files, keeping track of files that are locked so that others cannot
edit them.
If you already have a database set up from a previous installation of Toon Boom Harmony 10.3 you DO NOT
need to set up the database server, startup items, or register console application in the path. However, if you
are upgrading from a previous version, you need to install the startup items and register console applications in
the path. For new installations of Harmony, you must install all of them.
The database server is configured using the Configuration Assistant:
1. From Finder, go to Applications > Toon Boom Harmony 10.3 > Tools.
2. Double-click Configuration Assistant.
3. For the server, select all three options if this is the first time you are installing on this machine.
‣

If you are upgrading from a previous version and a database (/USA_DB) already exists on the server,
unselect the Create a new Toon Boom Harmony database option.

‣

If you are upgrading from an earlier version of Toon Boom Harmony , you will need to update the dict
files in the USA_DB. The dict files need to be copied from /Applications/Toon Boom Harmony
10/tba/etc/USADB_templates/dicts/ to /USA_DB/dicts/.
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4. Click Continue.
The Create Harmony Database dialog box opens. The default values shown in this dialog box should be
correct and therefore accepted as is.

5. Click on the Create button in the Create Harmony Database dialog box.

You can always create the Toon Boom Harmony 10.3 file system manually later. To do so, open
terminal and type following:

cd / [Return]
mkdir usadata000 [Return]
chmod -R 777 usadata000 [Return]

Note that you need to be logged in using the root account to be able to do this. If you are not
logged in as the root user, you will need to type sudo before launching the command.

You can make as many data directories as you like. Name these directories using the following syntax, where
XXX represents the number of the data directory:
usadataXXX
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If you want to use a name other than usadataXXX for the Toon Boom Harmony 10.3 File System,
you will need to edit the Manager.conf file and add the name or search pattern for this new file
system. The Manager.conf file can be edited using the Configuration Editor that is found in the
Tools folder of your Toon Boom Harmony 10.3 installation. Open the Configuration Editor and
select the Manager.conf tab.

6. In the Create Startup Item page, select the Startup Items required.
7. Click Create to continue.

‣

Create Database Server Startup Item: It is mandatory to install the Database Server Startup Item on
the server.

‣

Create Link Server Startup Item: This Startup Item is required when there will be Windows clients
connecting to the Mac server. This service creates symbolic links when a scene is created from a
Windows client workstation.

‣

Create Queue Server Startup Item: This is for the batch rendering. Do not install this on the server,
as it will slow it down. Install this on a stand-alone machine that will be used for batch vectorizing or
rendering.

8. In the Register Path page, choose whether you want to register the path for the current user or for all
users.
‣

Register Path for all users

‣

Register Path for my user only
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This option appends the path of Harmony's applications to the PATH environment variable in order to run the
applications from the Terminal.
‣

Registration Path for all users: registers the path for all accounts on the computer. You only need to
run this once.

‣

Registration Path for my user only: This option registers the path to the current account only. You
need to run this for each user that will be using the Terminal and you need to run this each time you
create a new user.

9. Click Create to go to the next page.
10. Click Done to close the Configuration Assistant.

Configuring the Licensing
The licensing must be configured before running Toon Boom Harmony 10.3.
You must perform the following tasks on the server:
•

Setting Up the FlexLM License Server below

•

Setting up the License on Client Workstations on page 60

Setting Up the FlexLM License Server
To configure the license server:
1. Launch the License Wizard from Applications > Toon Boom Harmony 10.3 > Tools > LicenseWizard.
2. Depending on how the License Wizard was started, the first page of the License Wizard will be one of
the following:
‣

If this screen appears: Click on More Options.
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‣

If this screen appears: Click on Activate License.

The Activation Options screen appears:
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3. Click on Internet Activation
The Internet Activation Options screen appears:
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4. Click on Network License.
The Internet Activation - Network License screen appears:
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5. Type or copy/paste the Product Code and type in the number of licenses (License Count) this product
code grants you.

Once activated and returned to the activation server, a server license cannot be activated again.
Make sure you are activating the license on the correct computer with the proper license count.

6. Click on Activate.
The Install License Server screen appears:
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7. Click on Install License Server.
This step will create the license.dat file and place it in /usr/local/flexlm/licenses/license.dat. It will also
configure and start the License Server service.
The license.dat created contains the following information:
SERVER this_host 0 ANY
VENDOR toonboom
USE_SERVER

The Activation Successful screen appears:

59

Chapter 1: Installing on Mac OS X

Configuring the Licensing

8. Click on Finish to exit the wizard.
9. Verify that the FlexLM license is working properly by using the lmutil lmstat -a command.
lmutil lmstat -a
You can also look at the ToonBoomLicense.log that is located at:
/Library/Logs/ToonBoomLicense.log
10. If the FlexLM service needs to be restarted, use the following command:
sudo /sbin/SystemStarter restart ToonBoomLicense

Setting up the License on Client Workstations
An Admin account is required to set this up. After activation you can login as client.
To set up the license on a client workstation do the following:
1. Open the License Wizard on the Client machine.
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The Toon Boom Activation Wizard appears.

2. Click on Activate License.
The Activation Options screen appears.

3. Click on Use License Server.

61

Chapter 1: Installing on Mac OS X

Configuring the Licensing

The Server Activation screen appears.

4. Click on Connect to Server.
The Server Activation - Shared License dialog appears.

5. Enter the hostname or the IP Address in the License Server address field.
6. Click Connect. You will be prompted for a password.
7. Enter the password and click OK.
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8. The Activation Successful screen appears.
9. Click Finish to close the License Wizard.

Related Topics
•

Configuring Harmony to Share Scene Data on the next page
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Configuring Harmony to Share Scene Data
Before you can share scene data between a Mac OS X database and Mac OS X, Linux, and Windows clients, you
must configure the Mac OS X database server appropriately.
This section covers the following topics:
•

Sharing Harmony Directories for Mac OS X and Linux Clients below

•

Set Up the Server for Windows Clients on page 66

Sharing Harmony Directories for Mac OS X and Linux
Clients
To share scene data between the Mac OS X server and Mac OS X and Linux clients, you must export (using NFS)
the database and data directories from the server.
Toon Boom Harmony 10.3 uses NFS (Network File System) to share files between Mac OS X and Linux
computers. You must use NFS to export directories from the server so that clients can mount them and share the
contents.

Sharing the Database for Mac OS X and Linux Clients
If your Mac OS X server will have Mac OS X or Linux clients, you will need to export the USA_DB and USADATA
folders using NFS (network file server). The clients will then need to be configured to mount those exported
folders from the server.

Setting up NFS Exports on Mac OS X 10.7 and Mac OS X 10.6
The following procedure demonstrates how to export the /USADATA and the /USA_DB directories, on a Mac
OS X workstation, as NFS Shared points.
1. From Finder go to Application > Utilities and double-click Terminal.
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2. Create and edit the export file in the /etc directory, by typing the following:
sudo vi /etc/exports

3. Click on "i" to enter the 'insert" mode and type the following lines:
/USA_DB -maproot=nobody
/USADATA -maproot=nobody
4. Once done, click on [ESC] to exit the insert mode, then type :wq to write the file and exit vi.
5. Check that the file is correct by running:
sudo nfsd checkexports

If there is no return response, then all is correct.

6. Type the following command to start nfsd.
sudo nfsd enable
7. If nfsd was already started, you will need to type the following command to notify the nfsd daemon that
the
/etc/exports file has changed:
sudo kill -1 `cat /var/run/mountd.pid`
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The ` character is located on the top left side of the Mac OS X keyboard on the same key as the
tilde ~ character.

8. Once that is done, you can use the following command to see if the folders are exported correctly:
/usr/bin/showmount -e
The following should appear after running the command.
/USA_DB Everyone
/USADATA Everyone

Once the exports file is created, clients systems will be able to mount the
/USA_DB and /USADATA located on the Mac OS X server system.

Set Up the Server for Windows Clients
If Windows clients are going to access the Toon Boom Harmony 10.3 database on a Mac OS X server, you must
set up the Link Server, Samba and the server.ini file. These allow the server and clients to communicate and
share data.
To set up the server for Windows clients, you must:
1. Configure and Start the Link Server below.
2. Configure Samba on Mac OS X 10.6 and 10.7 on the facing page.
3. Configure the server.ini File on page 72.
4. Reboot on page 72

Configure and Start the Link Server
If you are running Toon Boom Harmony 10.3 in a mixed environment where the server is on Mac OS X and some
of the clients are running Windows, you must start the Link Server. The Link Server makes it possible for
Windows machines to communicate with the database.
To configure the link server on the server in a mixed network environment:
1. If you did not already install Link Server during the server installation, you must do it now. From the
Finder, go to Applications > Toon Boom Harmony 10.3 > Tools.
2. Double-click the Configuration Assistant.
3. Select Create the Startup Items and uncheck the other options.
4. Click on the Continue button.
5. In Create Startup Item, select Create Link Server Startup Item.
6. Click Create.
7. Type a user name and password of a user with administration rights.
8. Click OK to confirm.
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9. To start the Link Server, either restart the server or type the following in the Terminal. (Note: if you are
not a root, you need to use sudo command):
sudo /sbin/SystemStarter start ToonBoomLinkServer
A message will appear in the Terminal indicating that the script has been successful.
10. A log file will be generated in /Library/Logs/ToonBoomLinkServer.log. Check this file to make
sure there are no errors written to this file.

Configure Samba on Mac OS X 10.6 and 10.7
Do the following:
•

Configure the Samba Service below

•

Configure the Samba Shared Files on page 69

•

Configure the smb.conf File on page 70

Mac OS X 10.7 (Lion) no longer uses the open source Samba software to share folders for Windows
workstations. It has been replaced by Apple's own Windows file sharing software. This software does
not include some of the options required to support Windows Harmony clients.

We are seeking a solution to this problem. In the meantime, if you need to have Windows clients in
your environment, Mac OS X 10.6 or a Linux server can be used.

Configure the Samba Service
By default, Samba is not set up to run automatically on Mac OS X.
To start the Samba service:
1. Open System Preferences.
2. In the Internet & Wireless section, click on Sharing.
3. In the Services section, click in the File Sharing checkbox.
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4. Under the Shared Folders section, click on the plus + sign.
5. Browse and select the /USA_DB folder.

6. Repeat Step 4 and Step 5 for the /USADATA folder.
7. Make sure to give the usabatch account Read and Write permissions to the USA_DB and USADATA
folders.
8. Click on the Options button.
9. Enable the Share files and folders using SMB checkbox.
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10. Click the usabatch account checkbox in the account list and then click Done.
11. Close System Preferences.

Configure the Samba Shared Files
Next, modify the usa_db and the usadata shares in the /var/db/samba/smb.shares and add a
usasection to the file.
1. Open the Terminal.
2. In the Finder go to Application > Utilities and double-click Terminal.
3. Go to the samba shares directory:
cd /var/db/samba/
4. Open the smb.shares file in the vi text editor.
sudo vi smb.shares
5. Type "i" to enter the insert mode.
6. Add or modify options in the file.
This is an example of entries in the smb.shares shared file. You can add missing options at the end of
the list.
[USA_DB]
comment = Harmony database folder
path = /USA_DB
available = yes
guest ok = no
directory mask = 777
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create mask = 777
browseable=yes
read only=no
[USADATA]
comment = Harmony USADATA filesystem
path = /USADATA
available = yes
guest ok = no
directory mask = 777
create mask = 777
browseable=yes
read only=no
7. Create a usa share by making a copy of the [USA_DB] section and pasting it underneath.
8. Rename [USA_DB] for [USA].
9. Modify the following lines under [USA]:
path = /Applications/Toon Boom Harmony 10.3/tba
comment = Harmony binaries and configuration files
10. Verify that the [USA] section looks like the following:
[usa]
comment = Harmony binaries and configuration files
path = /Applications/Toon Boom Harmony 10/tba
available = yes
guest ok = no
directory mask = 777
create mask = 777
browseable = yes
read only = no
11. Type [ESC] and type :wq to save the changes and quit the vi editor.

Configure the smb.conf File
You must also either add or modify the following entries to the [global] section of /etc/smb.conf file.
12. Create a backup copy of your current /etc/smb.conf file:
cd /etc
sudo cp smb.conf smb.conf.bak
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13. Open the smb.conf file in the vi editor.
sudo vi /etc/smb.conf
14. Type "i" to enter the insert mode.
15. Add or modify options in the file:
[global]

map to guest = Never

dos charset = 437
unix charset = UTF-8-MAC
display charset = UTF-8-MAC

blocking locks = false
oplocks = false

mangled names = no

When set to no, the mangled name parameter will prevent older smb clients (DOS, Win9X and
Windows NT clients) to access files and folders that do not use a 8.3 file name.

16. Type [ESC] [escape] to quit the insert mode.
17. Type :wq to save the changes and quit the vi editor.
18. Once the file is saved, run the testparm command to check that you have not made any basic syntactic
errors.
testparm
19. Notify the smbd service of the changes by typing the following:
sudo kill -1 `cat /var/run/smbd.pid`

The ` character is located on the top left side of the Mac OS X keyboard on the same key as the
tilde ~ character. Or simply reboot the computer.
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Configure the server.ini File
Before you install Toon Boom Harmony 10.3 on Windows clients, you must create the server.ini file on the
server. The server.ini file provides information necessary in Windows for the Configuration Wizard to set
up a Windows client.

When creating the server.ini file, be attentive to spelling, character spacing and case.

To create the server.ini on the Mac server:
1. In Finder, go to Application > Toon Boom Harmony 10 > Tools and double-click the Configuration
Editor.
2. When the Configuration Editor opens, click on the server.ini tab.
3. Copy and paste this example and modify it accordingly:
This is an example of the server.ini file. In this example, the server name is harmonyserver and
there is one usadata directory named, USADATA.
[WizardConfig]
ServerName=harmonyserver
InstallationDrive=C
UsaShare=usa
UsadbDrive=C
UsadbShare=USA_DB
FileSystem0=C USADATA harmonyserver

The references to DriveC shown in this example are necessary for Windows clients and will be
ignored by Mac OS X.

4. Save the file using the Save command under the File menu and quit the Configuration Editor.

Reboot
At this point, you should reboot the server so that all of the services which you have just configured will start up.

Related Topics
•

Configuring Harmony Clients on the facing page
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Configuring Harmony Clients
The following procedure demonstrates how to mount the /USADATA and the /USA_DB server directories, on a
Mac OS X X 10.6 or 10.7 workstation, as NSF Shared points.
To mount NFS Export on Mac OS X 10.6 and 10.7 Clients do the following:
•

Renaming your existing /USA_DB and /USADATA directories below

•

Configuring the Mounts using the Disk Utility below

Renaming your existing /USA_DB and /USADATA
directories
This only applies if you already have a /USA_DB and a /USADATA local directory.

Before starting, you must rename these directories if you want to keep their contents.
To rename /USA_DB and /USADATA local directories:
1. Open the Terminal.
1. From the Finder go to Application > Utilities and double-click Terminal.
2. Rename the local USA_DB and USADATA directories, by typing the following:
sudo mv /USA_DB /USA_DB.BAK
sudo mv /USADATA /USADATA.BAK

Configuring the Mounts using the Disk Utility
1. In the Finder go to Application > Utilities and double-click on Disk Utility.
2. In Disk Utility, click on File > NFS Mounts.
The NFS Mounts window opens.

3. Press the [+] button in the toolbar below the panel.
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4. In the Remote NFS URL field type the following:
nfs://[server name]/USA_DB

Replace [server name] by the name of the server. For example, if the server name was jarjar, you
would type: nfs://jarjar/USA_DB.

5. In the Mount Location field type the following:
/Volumes/USA_DB

6. If the workstation is going to be connecting to a Linux server, you must edit the Advanced Mount
Parameters. In the Advanced Mount Parameters field, type:
resvport

7. Click on the Verify button.
8. Click on the OK button on the message that confirms that NFS server is functional.
9. Repeat Press the [+] button in the toolbar below the panel. through Click on the OK button on the
message that confirms that NFS server is functional., but enter the following for the Remote NFS URL
and Mount Location:
nfs://[server hostname]/USADATA
/Volumes/USADATA
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10. Press the Save button and enter your user password to confirm the changes. Note that on Mac OS X 10.7
there is no save button. Changes are automatically saved and applied when the NFS Mounts window is
closed.
11. Quit the Disk Utility.
12. Open a new Terminal window.
13. Verify that the /USA_DB and /USADATA shared points have been mounted properly:
ls /Volumes/USA_DB

and

ls /Volumes/USADATA

14. Create symbolic links to the USA_DB and USADATA directories at the root level /
sudo ln -s /Volumes/USA_DB /USA_DB
sudo ln -s /Volumes/USADATA /USADATA

15. Verify that the symbolic links are pointing to the right directories:
ls -l /
The symbolic links for the /USA_DB and /USADATA should look like the following:
USADATA -> /Volumes/USADATA
USA_DB -> /Volumes/USA_DB
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Related Topics
•

Troubleshooting on the facing page
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Troubleshooting
If you have any problems running Harmony after the installation, review the installation and configuration
instructions to make sure you have followed them completely. If you continue to have problems, consult the
following list to troubleshoot common installation and configuration problems.

Problem: Unable to Open Sample Scene on Clients
•

•

On the Toon Boom Harmony 10.3 server, verify:
•

The database and data directories were exported using NFS.

•

Link Server, Samba and server.ini configurations for Windows clients.

On Mac OS X Toon Boom Harmony 10.3 clients, check that the database and data directories were
mounted using NFS.

Problem: License Error When Starting any Harmony
Module
If you are getting license errors when you start a Toon Boom Harmony 10.3 module, check the set up and
configuration of the license service.
•

On the license server, make sure that the license.dat file is in the following directory:
/usr/local/flexlm/licenses

•

The license.dat should contain the following information:

SERVER this_host 0 ANY
VENDOR toonboom
USE_SERVER.

•

Open the Activity monitor and make sure that the lmgrd and toonboom processes are running. If both of
them are missing, you can start the license by typing the following in the Terminal:
sudo /sbin/SystemStarter start ToonBoomLicense
The following line should appear followed by messages from lmgrd:
Starting Toon Boom License Daemon...

•

If you get an error message when you try to start the license service, it is possible that you did not install
the license Startup Item. Use the LicenseWizard to install license server Startup Item. Refer to, .

•

If you continue having problems with the license server, locate the file ToonBoomLicense.log and
send it to support@toonboom.com. The file is located in: /Library/Logs and can be accessed from
the Console application.
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Problem: Unable to Import Sample Scene (Errors with the Dbserver)

Problem: Unable to Import Sample Scene (Errors
with the Dbserver)
•

Check the ToonBoomDatabaseServer.log file. The file is located in /Library/Logs and can be
accessed from the Console application.
•

If there is no log file, restart the Dbserver. Type the following in a Terminal window:
sudo /sbin/SystemStarter start ToonBoomDatabaseServer

If there is a log file, the last few lines in the log file will give you some indication as to the problem with the
Dbserver.
•

If you get an error in the log about the machine name, check the
/USA_DB/Dbserver.conf file and make sure the hostname matches the machine name of the Toon
Boom Harmony 10.3 server.

•

If you get errors about the port number, another service might be using port 5680. You can change the
port number in Dbserver.conf to any unused number above 5000.

•

Restart the Dbserver. Type the following in a shell:
sudo /sbin/SystemStarter start ToonBoomDatabaseServer

78

Toon Boom Harmony 10.3 Installation Guide

Chapter 1: Installing on Linux
This document explains how to install Toon Boom Harmony 10.3 on Linux Fedora.
This document assumes that you are familiar with Linux and are capable of working in a command shell.
Throughout this document, we will ask you to create files using a text editor. The console text editor vi is
commonly used and is part of the Fedora package. Another text editor you can use is nano. To launch them just
type their name on the command line.
NEdit is a graphical, user-friendly text editor, which may not be installed by default. You can download it from
http://www.nedit.org/. Other graphical text editors, such as kedit and gedit can also be used.
There are three stages required to install Harmony, which are covered in the following topics:
1. Pre-installation on the next page
2. Installing a New System on page 98
3. Configuration on page 101
After completing these stages, you can verify the integrity of the installation and resolve any configuration issues.
•

Troubleshooting on page 115

Topics Covered
•

Pre-installation on the next page

•

Upgrading From a Previous Version of Toon Boom Harmony on page 84

•

Installing a New System on page 98

•

Troubleshooting on page 115
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Pre-installation
Before installing Harmony, you must perform the following task:
•

Check Your Minimum Requirements below

•

Get the Product Activation Code below

•

Check Your Pre-installation Configuration below

Check Your Minimum Requirements
For the most current Harmony hardware requirements, refer to the white paper Harmony and Your IT
Department. This is available from:
•

Toon Boom Animation Sales Representative

•

Toon Boom Animation Support at: support@toonboom.com

Get the Product Activation Code
You should obtain a Product Activation code from the Toon Boom licenser so that you can finish the installation
process without having to wait for the activation code to arrive.
To obtain a Harmony 10.3 activation code, please send the following information to: licensor@toonboom.com.
•

Your name and the name of your company

•

Email address where to send the license file

Check Your Pre-installation Configuration
Configure your computer before installation by performing the following tasks:
1. Fedora Installation below
2. Disabling SELinux on the facing page
3. Update NVIDIA Drivers on the facing page
4. Resolve Keyboard Shortcut Conflicts and Tweak KDE on page 82

Fedora Installation
Following are some considerations for Fedora Linux installation. Explaining how to install Fedora Linux is
beyond the scope of this document. For detailed information on how to install Fedora Linux, see the Fedora
documentation.
Installing Fedora Linux:
•

Download the Fedora Linux documentation from:
http://docs.fedoraproject.org/

•

Before installing Linux, make sure the distribution you will be installing is 64-bit. Harmony 10 will not work
if the OS is not 64-bit.
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•

When installing Fedora Linux, perform a Custom installation and select to install Everything to ensure
that you get all packages necessary to run Harmony.

•

When asked, select Firewall as disabled. Your file server should be behind a firewall, but should not be
configured as one.

•

When asked, select SELinux as disabled.

•

Harmony has been tested and certified for use on the KDE windows manager.

•

Harmony works best with a minimum screen resolution of:
1280 pixels x1024 pixels x 24-bit.
If Fedora cannot detect your monitor, configure the monitor as a generic CRT or an LCD with this
resolution and a 60 Hz refresh rate. Alternatively, consult your monitor manufacturer's documentation.

•

If you're new to Linux, we recommend that you create a boot disk to facilitate recovery.

Disabling SELinux
1. Verify if SELinux is enabled by reading the content of the SELinux config file:
more /etc/selinux/config
2. Look for the line that starts with SELINUX= and ensure that the value is set to disabled:
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#
#
#

enforcing - SELinux security policy is enforced.
permissive - SELinux prints warnings instead of enforcing.
disabled - No SELinux policy is loaded.

SELINUX=disabled
# SELINUXTYPE= can take one of these two values:
#

targeted - Targeted processes are protected,

#

mls - Multi Level Security protection.

SELINUXTYPE=targeted

3. If the value is set to something other than disabled, you must open the file using a text editor to change
the value to disabled. Once the file is modified and saved, reboot the computer.

Update NVIDIA Drivers
You must install the recommended drivers for your NVIDIA video card. If you don't, Harmony will not function.
In general, you should use the latest drivers. New drivers tend to resolve past driver issues. If you already have
NVIDIA drivers installed, you can find out the version of the installation, by typing:
cat /var/log/Xorg.0.log | grep "X Driver"
To install the NVIDIA driver:
1. Download the Linux driver from the NVIDIA website:
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http://www.nvidia.com/object/unix.html

2. Switch to text mode when installing video card drivers. Type the following in a shell while logged in as the
root user:
/sbin/init 3
3. To install the NVIDIA kernel driver, type the following in a shell while logged in as the root user:
sh /[path_to_driver_file]/NVIDIA-Linux-x86_64-[driver_name].run
4. Once the NVIDIA driver installation is successful, revert to graphical mode by starting X. In a shell, type:
/sbin/init 5
OR
startx

Some recent Linux distributions include an open source driver for NVIDIA graphic cards called
"Nouveau". This driver must disabled in order to install the NVIDIA drivers. Please refer to the NVIDIA
documentation for more information on how to do this.

Resolve Keyboard Shortcut Conflicts and Tweak KDE
Some KDE default keyboard shortcuts conflict with the shortcuts in Harmony and can prevent normal user
operation.
To change the keyboard shortcuts and tweak KDE, follow these steps:
1. In the KDE menu, select Computer > System Settings. (In earlier versions of KDE, you may need to open
the KDE Control Center).
2. In the System Settings window, select Windows Behavior in the Desktop section (in earlier versions of
KDE, open the Look & Feel > Window Behavior menu instead).
3. Click the Window Actions tab.
4. In the Inner window, titlebar and frame section, do one of the following:
‣

Change your keyboard layout to choose Meta key from the Modifier Key option. The Meta key is the
Windows Start button on a 104-key keyboard. You must have this type of keyboard to use this option.
Go to Desktop > Window Behavior (in earlier versions, open the Look & Feel > Window Behavior
menu). Click the Actions tab. In the Inner window, titlebar and frame section, select Meta as the
Modifier Key.

•

If the Meta key is not available in the Modifier Key list, you will need to change your Keyboard Layout.
This is set in Control Center > Regional and Accessibility > Keyboard Layout (in earlier versions,
open the Control Center > Peripherals > Keyboard menu). Select the Enable keyboard layouts
option and then select a Keyboard Model that includes 104 keys.

‣

Set all of the Modifier Key + options to Nothing.

5. There are a few KDE preferences that you should update to optimize Harmony.
‣

In the KDE menu, select Computer > System Settings > Window Behavior. Click the Moving tab to
disable these two options. Harmony reacts better and faster when these are disabled:
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•

Display content in moving windows

•

Display content in resizing windows

‣

In the KDE menu, select Computer > System Settings > Appearance and select the Colors menu.
Under the Options tab, disable the following option:

•

Apply colours to non-KDE4 applications

NOTE: This option may cause Toon Boom Harmony to display incorrect colours in some of the interface
controls.
After you have completed all Fedora Linux configurations, you are ready to install Toon Boom Harmony.
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Harmony Installation
Now that you have verified your minimum requirements, and configured your hardware and software, you are
ready to install Toon Boom Harmony.
You will perform the following tasks:
•

Configuration on page 101

•

Configuring Harmony to Share Scene Data on page 108

Upgrading From a Previous Version of Toon Boom
Harmony
This procedure assumes that the USAnimation, Opus or Toon Boom Harmony binaries (program files) are
installed on the Toon Boom Harmony server and are mounted by all of the Linux clients. When you update the
installation on the server; all clients will load the new binaries from the central mount point
When upgrading previous installations of USAnimation, Opus or Toon Boom Harmony, you should pick a time
when Toon Boom Harmony production is slow or stopped. During the upgrade, no users can run any of the
USAnimation, Opus or Toon Boom Harmony modules and all rendering jobs must be complete.
•

Restore the files that were previously backed-up on page 86

•

Edit usabatch's .cshrc on page 86

•

Edit other users .cshrc on page 87

•

Edit the /etc/skel/.cshrc on page 88

•

Configuring the License Server on page 88

•

Restart the Harmony Services on page 93

•

Updating the nfs export on page 94

•

Updating the smb.conf on page 94

•

Verify the parameters required in the smb.conf on page 95

To update previous installations:
1. Make sure that no one is running any versions of USAnimation, Opus or Toon Boom Harmony. All
USAnimation, Opus or Toon Boom Harmony modules must be closed on the server and on all of the
clients.
2. Make sure that all batch rendering and vectorizing is complete or that the queues are empty. You can
check the status of Vectorize and Render queues from the Control Center module.
‣

In the Control Center module, use the Queue menu Environment > Vectorize Queue or Render
Queues to open the Vectorize and Rendering Queue for all environments. The queues should either
be empty or the status of all jobs should be Completed.

3. Stop all services running on the server and the clients. Depending on the services you have running, type
the following commands, in the order presented, in a shell while logged in as the root user:
/etc/init.d/USAnimation_queues stop
/etc/init.d/USAnimation_link_srv stop
/etc/init.d/USAnimation_dbserver stop
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/etc/init.d/USAnimation_flexlm stop
You must be sure to stop the queues on all rendering machines. If the queues are running, those binaries
will be locked and the installer won't be able to update them.
Note: It is not required to delete the startup scripts from /etc/init.d/ as the Harmony install script will
update them automatically.
You must be sure to stop the queues on all rendering machines. If the queues are running, those binaries will be
locked and the installer won't be able to update them.
4. Backing up configuration files:
Back up Harmony's configuration files by copying them to a location where you will be able to recover
them later on. Go to the folder where the previous version of Harmony is installed and backup
configuration files that are in the etc folder:
‣

7.5 and earlier: /usa/etc

‣

7.8: /usr/local/ToonBoomAnimation/harmony_7.8/etc

‣

9.2: /usr/local/ToonBoomAnimation/harmony_9.2/etc

‣

10.0: /usr/local/ToonBoomAnimation/harmony_10.0/etc

Back up the following configuration files:
Manager.conf
Scan.conf (If a scanner was configured to run with the Harmony Scan module on this computer)
server.ini (If the server is configure to receive connections from Windows clients)
VectOptions.conf (If vectorization preset had been added to it)
If any plug-ins have been added to the Harmony installation, backup these files as well. The plug-ins are
located in:
‣

7.5 and earlier: /usa/lnx86/plugins

‣

7.8: /usr/local/ToonBoomAnimation/harmony_7.8/lnx86/plugins

‣

9.2: /usr/local/ToonBoomAnimation/harmony_9.2/lnx86/plugins

‣

10.0: /usr/local/ToonBoomAnimation/harmony_10.0/lnx86_64/plugins

You can back up the entire Harmony folder by renaming it to make sure all config files are kept.
Delete or backup the Harmony Installation by renaming the folder where it is installed. Default install
location for 7.5 and earlier is /usa.
5. Cleaning the KDE menu.
Shortcut to launch the previous application should be removed from the KDE menu. There are two ways
of doing this:
Using the KDE Menu Editor that can be started from the KDE menu. The location will vary depending on
the version of Linux installed.
By deleting them from the command line. Change to /usr/share/applnk/
$ cd /usr/share/applnk/

Delete the old shortcuts:
•

Versions 7.8,9.2 and 10.0:
$ rm ToonBoom-Harmony_*

•

Earlier versions:
$ rm USAnimation-*
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The shortcuts will be removed from the KDE menu the next time you log in.
6. Uncompress the distribution file.
tar xvfz [path_to_distribution_file]/[filename].tar.gz
7. Change to the directory that was extracted from the tar.gz file.
8. While logged in as the root user, run the install script specifying the options required for your server.
$ ./install -b -d -l -p -u - kde
‣

-b: mandatory. This will install the binaries required to run Harmony.

‣

-d: configures the tbdbserver for auto startup. Required when installing a server.

‣

-l: configures the Link_srv for auto-startup. Required if the server has window clients.

‣

-p: Configures the tbprocess for auto-startup. Required if the server will be performing batch
processing.

‣

-u: Updates the dict files in the USA_DB/dicts. This is mandatory when upgrading a server from a
version previous to Harmony 10. This option will only work if -d is also selected.

‣

-kde: installs Harmony menu shortcuts in the KDE menu.

Restore the files that were previously backed-up
‣ Copy the server.ini, Manager.conf and any other files you must backup to the new installation.
From the backup location to /usr/local/ToonBoomAnimation/harmony_10.0/etc/.

Edit usabatch's .cshrc
Before being able to start the Harmony services, you will need to make modification to the .cshrc that is in
usabatch's home.
1. If you are not logged in as usabatch, do so by typing the following:
$ su - usabatch

2. Once logged in, open the .cshrc file in usabatch's home using your favourite text editor. I use vi:
$ vi .cshrc

The file used for Harmony 9.2 contains the following:
if ( -f /usr/local/ToonBoomAnimation/harmony_9.2/etc/usa_cshrc ) then
source /usr/local/ToonBoomAnimation/harmony_9.2/etc/usa_cshrc
endif

umask 0
The file used for Harmony 7.8 contains the following:
if ( -f /usr/local/ToonBoomAnimation/harmony_7.8/etc/usa_cshrc ) then
source /usr/local/ToonBoomAnimation/harmony_7.8/etc/usa_cshrc
endif
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umask 0
The file used for Harmony 7.3 contains the following:
if ( -f /usa/etc/usa_cshrc ) then
source /usa/etc/usa_cshrc
endif

umask 0

3. Change /usa/etc/usa_cshrc to /usr/local/ToonBoomAnimation/harmony_10.0/etc/usa_
cshrc, so that it looks like this:

if ( -f /usr/local/ToonBoomAnimation/harmony_10.0/etc/usa_cshrc ) then
source /usr/local/ToonBoomAnimation/harmony_10.0/etc/usa_cshrc
endif

umask 0

4. Save and quit.

Edit other users .cshrc
The.cshrc of the all other users of Harmony should be edited to remove the lines that are used to source the
usa_cshrc file. It is not required to source this file anymore as the path to the application is now added to the
PATH variable via the files in /etc/profile.d.
For version 9.2:

if ( -f /usr/local/ToonBoomAnimation/harmony_9.2/etc/usa_cshrc ) then
source /usr/local/ToonBoomAnimation/harmony_9.2/etc/usa_cshrc
endif

umask 0

For version 7.8:
if ( -f /usr/local/ToonBoomAnimation/harmony_7.8/etc/usa_cshrc ) then
source /usr/local/ToonBoomAnimation/harmony_7.8/etc/usa_cshrc
endif
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umask 0

For version 7.3:
if ( -f /usa/etc/usa_cshrc ) then
source /usa/etc/usa_cshrc
endif

umask 0

Edit the /etc/skel/.cshrc
‣ Open the files /etc/skel/.cshrc with your favourite text editor and remove the lines that source the
usa_cshrc file from it as well.

Configuring the License Server
1. To launch the License Wizard go to: /usr/local/ToonBoomAnimation/harmony_10.0/lnx86_
64/bin/ in the terminal.
cd /usr/local/ToonBoomAnimation/harmony_10.0/lnx86_64/bin/

Logged as root user, type:
./LicenseWizard.

2. Click on Activate License.

The Activation Options screen appears:

88

Toon Boom Harmony 10.3 Installation Guide

3. Click on Internet Activation.
The Internet Activation Options screen appears:
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4. Click on Network License.
The Internet Activation - Network License screen appears:
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5. Type or copy/paste the Product Code and type in the number of licenses this product code grants you.

Once activated, server licenses can only be returned to the activation server once. A previously
returned licensed cannot be re-activated. Make sure you are activating the license on the correct
computer.

6. Click on Next.
The Install License Server screen appears:
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7. Click on Install License Server.
This step will create the license.dat file and place it in
/usr/local/flexlm/licenses/license.dat
The license.dat created contains the following information:
SERVER this_host 0 ANY
VENDOR toonboom
USE_SERVER

Both these steps can be done manually if need be. To configure the License Server service to start
automatically at boot, use the following command:
$ /sbin/chkconfig USAnimation_flexlm on
To start the license server manually, type the following as the root user:
$ /etc/init.d/USAnimation_flexlm restart

The Activation Successful screen appears:
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8. Click on Finish to exit the wizard.
9. Verify that the FlexLM license is working properly by using the lmutil lmstat -a command.
$ lmutil lmstat -a

You can also look at the log:
$ less /tmp/lmgrd.log

If the FlexLM service needs to be restarted, use the following command:
$ /etc/init.d/USAnimation_flexlm restart

Restart the Harmony Services
10. Once the license is properly configured, and started, start the Harmony services that are required on your
server. They should be started in the following order:
$ /etc/init.d/USAnimation_dbserver restart

$ /etc/init.d/USAnimation_link_srv restart

$ /etc/init.d/USAnimation_queues restart

11. Once the services are started, check the logs to make sure that they have been started properly. Check all
the logs to see if the services are running properly. Logs are located in /tmp.
/tmp/lmgrd.log
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/tmp/tbdbserver.log

/tmp/tbprocess.log

/tmp/Link_srv.log

12. Start Harmony and open a scene to see if the server works properly.

Updating the nfs export
If the Linux server has Linux or Mac OS X clients, the nfs exports need to be updated with the path of the new
Harmony binaries.
$ vi /etc/exports

1. Change the path of /usa to /usr/local/ToonBoomAnimation/harmony_10.0
/USA_DB *(rw,sync)
/usadata000 *(rw,sync)
/usr/local/ToonBoomAnimation/harmony_10.0 *(rw,sync)

2. For this change to take effect, you will need to run the following command:
$ /usr/sbin/exportfs -r

3. You should then test the exports using the showmount command:
[root@chewy etc]$ /usr/sbin/showmount -e
Export list for chewy.toonboom.com:
/USA_DB *
/usadata000 *

/usr/local/ToonBoomAnimation/harmony_10.0 *

Updating the smb.conf
1. When upgrading a Linux server, a small modification must be made to the usa share path to point to the
new install. "vi /etc/samba/smb.conf" and change the path under the [usa] share to the path of the
new Harmony install.
[usa]
comment = Harmony binaries & stuff
browseable = yes
read only = no
guest ok = no
create mask = 0777
directory mask = 0777
path = /usr/local/ToonBoomAnimation/harmony_10.0
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2. Once the file is saved, run the "testparm" command to check that you have not made any basic syntactic
errors.
[root@chewy samba]$ testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[printers]"
Processing section "[USA_DB]"
Processing section "[usa]"
Processing section "[usadata000]"
Processing section "[tmp]"
Loaded services file OK.
Server role: ROLE_STANDALONE

3. Press Enter to see a dump of your service definitions.

If the smb.conf was configured according to the 7.3 documentation, the testparm command
might return the following error:
Level II oplocks can only be set if oplocks are also set.
To get rid of this error, you need to add the level2 oplocks = No parameter in the global section
of the smb.conf.
See the next section for all the parameters that are required in the smb.conf.

4. Then, restart smb:
$/etc/init.d/smb restart

Verify the parameters required in the smb.conf
1. Verify the configuration of the smb.conf.
It is always safe to verify the configuration of the smb.conf.
$ vi /etc/samba/smb.conf

Parameters needed in the [global] section.
encrypt passwords = no

blocking locks = no
oplocks = no
level2 oplocks = no

follow symlinks = yes
unix extensions = no
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wide links = yes

Default parameters for the shares.
[USA_DB]
comment = Harmony Database
browseable = yes
read only = no
guest ok = no
create mask = 0777
directory mask = 0777
path = /USA_DB

[usa]
comment = Harmony binaries & stuff
browseable = yes
read only = no
guest ok = no
create mask = 0777
directory mask = 0777
path = /usr/local/ToonBoomAnimation/harmony_10.0

[usadata000]
comment = Harmony data 000
browseable = yes
read only = no
guest ok = no
create mask = 0777
directory mask = 0777
path = /usadata000

2. Remember to always perform a testparm after making changes to the smb.conf.
$ testparm

3. Restart the smb service.
$ /sbin/service smb restart

4. Reboot the server.
If possible, reboot the server to verify that all the services are properly started.
5. Once the server is booted, check all the logs to see if the services are running properly. Logs are located
in /tmp.
/tmp/lmgrd.log
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/tmp/tbdbserver.log

/tmp/tbprocess.log

/tmp/Link_srv.log
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Installing a New System
Create the usabatch User
After you have installed Fedora Linux, you must create the usabatch user account. A number of Toon Boom
Harmony services run in the usabatch account.
You must also set the usabatch user to use the tcsh shell and you must create a .cshrc file to launch the
Toon Boom Harmony environment whenever the user logs on.
You must create user accounts for all Toon Boom Harmony family users. All user accounts you create on Fedora
Linux that will also run Harmony must be set up the same way as the usabatch account, except for the user
name and password.
To create user accounts:
1. In a shell, login as the "root" user.
2. Using a text editor, create the file /etc/skel/.cshrc. This file should contain the following line:
umask 0
Note that this character is a zero.

3. Create the user usabatch. In a shell, type:
useradd -m -s /bin/tcsh -r usabatch
4. Enter the password for user usabatch. In a shell, type:
passwd usabatch
Then, type usabatch as a password.
To create additional users repeat steps 3 and 4. Just replace usabatch with the user name and password of the
new user.

Setting umask to zero (0) ensures that Toon Boom Harmony users are able to read and write all files
in the database, which is essential for people to share their work.

5. If you are not logged in as usabatch, do so by typing the following:
su - usabatch
6. Once logged in, open the .cshrc file in usabatch's home. Using a text editor, add the following lines:
if ( -f /usr/local/ToonBoomAnimation/harmony_10.0/etc/usa_cshrc ) then
source /usr/local/ToonBoomAnimation/harmony_10.0/etc/usa_cshrc
endif
The .cshrc file should now contain the following:
if ( -f /usr/local/ToonBoomAnimation/harmony_10.0/etc/usa_cshrc ) then
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source /usr/local/ToonBoomAnimation/harmony_10.0/etc/usa_cshrc
endif

umask 0
7. Save and quit.
8. Log out of usabatch to return to the root user.

Install Harmony
In a client-server network or in a stand-alone set up, you must install Harmony binaries as well as the following
services:
•

Dbserver: Controls access to the Harmony database.

•

License service: Controls the number of licenses and features available to Harmony users.

•

Batch Processing: If you are setting up the machine for batch processing this controls batch vectorizing
and rendering queues.

•

Link Server: If you are installing Harmony on a Linux server that will support Windows clients.

To install Harmony binaries and services, you must run the installation script.
With the product activation code from the licenser, you are ready to install Harmony.
To run the installation script:
1. Decompress the distribution file.
tar xvfz [path_to_distribution_file]/[filename].tar.gz

2. Change to the directory that was extracted from the tar.gz file.
3. Run the install script as the root user, specifying the options required for your server. There are a number
of options that control the installation process. For a typical Harmony server or a stand-alone machine,
you would run the installation script with the following parameters:
./install -b -d -kde
With these options, the binaries are installed, and the database server is installed and set up to start
automatically. These options also add Harmony entries to the KDE application menu.
If your Linuxserver will be serving Windows clients, you must add the -l option.
If you are setting up the clients for the batch render, you will add the -p parameter. It is not
recommended to configure batch processing on the server, as it will slow it down.
Here is a description of all the installation options:
Option

Default Value

Details

binaries

Inactive

Installs binaries and configuration files required
to run Harmony applications.
You must include this option when doing a fresh
install or when you upgrade Harmony.

-b
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Option

Create the usabatch User

Default Value

Details

You must use this option when installing
Harmony on the server.
dbserver

Inactive

Installs the tbdbserver as a daemon. This is
the Harmony database server daemon. It
processes data requests from clients on the
network.

-d

This option also creates a fresh database when
there is no /USA_DB directory.
You must use this option when installing
Harmony on the server and on the stand-alone
machine.
Inactive

Displays script usage information.

-kde

Inactive

Adds Harmony entries to the KDE application
menu.

linkserv
er

Inactive

Installs the link_server daemon.

-help
-h

This daemon is required for Linux (or SGI)
servers to create symbolic links for Windows
clients.

-l

If you have Windows clients, you must install
this daemon on the server.
-process

Inactive

Installs the process daemon.
The process daemon manages batch
processing (vectorizing and rendering) for
Harmony. Usually several computers participate
in the batch processing pipeline.

-p

This parameter is required if this computer is
going to batch process any files for Harmony.
-quiet

Inactive

Does not output any information during
installation.

/
usr/local/ToonBoomAnimatio
n/harmony_10.0

Directory where the installer will install the
harmony_10.0 tree.

Inactive

Updates the dict files in the database. Needs

-q
-target
<DIRECTO
RY>
-t
<DIRECTO
RY>

-
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Option

Default Value

Details

to be specified when upgrading from a previous
version.

udatedic
t
-u

Related Topics
•

Configuration below

Configuration
After installing Harmony, configure database parameters depending on your machine's setup, and configure
third-party software.
1. Set Up Licensing below
2. Configure Harmony on page 106

Set Up Licensing
Now that you have installed Harmony, you must set up the licensing so that it can run on the server and client
machines.
Configuring the license server
1. As the root user, start the License Wizard by typing the following:
cd /usr/local/ToonBoomAnimation/harmony_10.0/lnx86_64/bin
Logged as root user, type:
./LicenseWizard.

2. Click on Activate License.
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The Activation Options screen appears:

3. Click on Internet Activation.
The Internet Activation Options screen appears:
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4. Click on Network License.
The Internet Activation - Network License screen appears:
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5. Type or copy/paste the Product Code and type in the number of licenses this product code grants you.

Once activated, server licenses can only be returned to the activation server once. A previously
returned licensed can not be re-activated. Make sure you are activating the license on the correct
computer.

6. Click on Next.
The Install License Server screen appears:
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7. Click on Install License Server.
This step will create the license.dat file and place it in
/usr/local/flexlm/licenses/license.dat. The license.dat created contains the following
information:
SERVER this_host 0 ANY
VENDOR toonboom
USE_SERVER

This step will also start the License Server service and will configure it to start automatically.

Both these steps can be done manually if need be. To configure the License Server service to start
automatically at boot, use the following command:
$ /sbin/chkconfig USAnimation_flexlm on
To start the license server manually, type the following as the root user:
$ /etc/init.d/USAnimation_flexlm restart
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The Activation Successful screen appears:

8. Click on Finish to exit the wizard.
9. Verify that the FlexLM license is working properly by using the lmutil lmstat -a command.
$ lmutil lmstat -a
You can also look at the log:
$ less /tmp/lmgrd.log
10. If the FlexLM service needs to be restarted, use the following command:
$ /etc/init.d/USAnimation_flexlm restart

Configure Harmony
After installation, you must set up the database configuration for computers running Harmony.
1. Set Up the Database Server below
2. Create the Toon Boom Harmony File System on the facing page

Set Up the Database Server
The Dbserver controls all interactions with the contents of the Toon Boom Harmony database. It processes all
requests to open, read or update files, keeping track of files that are locked so that others can not edit them.
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When installing Harmony on the server for he first time, the Harmony database folder is created automatically.
Verify that the folder was created correctly. Look for the USA_DB folder in the root folder (/USA_DB).
If you do not see the folder there, you will need to create it using the create_usa_db script. Type the following
command in a shell while logged in as root:
/usr/local/ToonBoomAnimation/harmony_10.0/lnx86_64/bin/create_usa_db
/USA_DB
Next you need to create and edit the Dbserver.conf file to set up the Dbserver. Then you have to run a script
that will start the Dbserver.
To set up the Dbserver:
1. Using a text editor, create the file Dbserver.conf in /USA_DB/.
2. Type the following in the Dbserver.conf file:
Assuming the machine name of the Dbserver is "harmonyserver" , the lines in Dbserver.conf would
look like this:
hostname harmonyserver
port 5678
debug_port 5680
Note: You can find the example of Dbserver.conf in
/usr/local/ToonBoomAnimation/harmony_10.0/resources/samples. You can copy and
paste it from there and change it accordingly.
3. Save and close the Dbserver.conf file.
4. Change the permissions on the Dbserver.conf file to 644.
‣

In a shell, type the following:
chmod 644 Dbserver.conf

5. You must now start the Dbserver service. In a shell, type the following command:
/sbin/service USAnimation_dbserver start
A message will appear in the shell indicating that the script has been successful.
6. A log file will be generated in /tmp/tbdbserver.log. Check this file to make sure there are no errors
written to the log.

Create the Toon Boom Harmony File System
After you set up and start the license and Dbserver, you are ready to create the file system for the Toon Boom
Harmony database.
To create the Toon Boom Harmony file system:
1. In a shell, change directories to the root. Type:
cd /
2. Make a directory named /usadata000. Type:
mkdir usadata000
Once you have finished creating usadata000, change the permission of:
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/usr/local/ToonBoomAnimation/harmony_10.0 /USA_DB and /usadata000 to
777.
chmod -R 777 /usr/local/ToonBoomAnimation/harmony_10.0 /USA_DB
/usadata000
Now you are ready to test your installation on the server/stand-alone machine.

Related Topics
•

Configuring Harmony to Share Scene Data below

Configuring Harmony to Share Scene Data
This section shows how to share the Harmony data for different network configuration.

Related Topics
•

Export Harmony Directories for Mac OS X and Linux Clients below

•

Configure the Link Server on the facing page

•

Configure Samba on page 110

Export Harmony Directories for Mac OS X and Linux Clients
Before you can install Harmony on Linux clients, you must export the Toon Boom Harmony directories from the
server. The NFS and NFS locking services must be running so that all machines can access the data directories
you export.
To start NFS services and export data directories from the server:
1. To share files with other Linux machines, you must start the NFS service. Type the following in a shell:
/etc/init.d/nfs restart
/sbin/chkconfig nfs on
‣

Note that if you are using Fedora 16, this would be:
systemctl start nfs-server.service
/sbin/chkconfig nfs-server on

2. The NFS lock manager must run on all Linux stations on your network. Without this service, they will not
be able to access the database without receiving numerous "read lock" error messages. Type the
following in a shell:
/etc/init.d/nfslock restart
/sbin/chkconfig nfslock on
‣

Note that if you are using Fedora 16, this would be:
systemctl start nfs-lock.service
/sbin/chkconfig nfs-lock on
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Now you are ready to export the Toon Boom Harmony directory.
3. Use a text editor to edit the /etc/exports file. Add the names of /USA_DB,
/usadata000 and /usr/local/ToonBoomAnimation/harmony_10.0 directories to the file, like
this: #
/USA_DB *(rw,sync)
/usadata000 *(rw,sync)
/usr/local/ToonBoomAnimation/harmony_10.0 *(rw,sync)
4. Run the export command to finalize the exports. In a shell, type:
/usr/sbin/exportfs -r
5. To check what is being exported from the server, type the following in a shell:
/usr/sbin/showmount --exports
A report appears listing all of the shares that are being exported from the server.

Configure the Link Server
If you are running Harmony in a mixed environment where the server is on Fedora Linux and some of the clients
are running Windows, you must start the Link Server.
The Link Server makes it possible for Windows machines to communicate with the database.
To configure the Link Server on the server in a mixed network environment:
1. Use a text editor to create the Link_srv.conf file in the /USA_DB directory. This file must contain the
following two lines:
hostname harmonyserver
port 5679
Replace harmonyserver with the name of the database server. You can find the name of a computer by
using the uname -n command.
Note: you can find the example of Link_srv.conf under
/usr/local/ToonBoomAnimation/harmony_10.0/resources/samples/. You can copy and
paste it from there and change it accordingly.
2. Change the permissions on the Dbserver.conf file to 644. In a shell, type the following:
chmod 644 Link_srv.conf
3. Start the Link Server. Type the following in a shell:
/etc/init.d/USAnimation_link_srv start
A message will appear in the shell indicating that the script has been successful.
4. A log file will be generated in /tmp/Link_srv.log. Check this file to make sure there are no errors
written to this file.
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Configure Samba
Finally, you must modify the /etc/samba/smb.conf file. To do this, add entries for each database directory
you want to share with Windows clients in the /etc/samba/smb.conf file. Then, you must add options to the
[Global] section of the file.
•

Configure the Samba Service to Start at Boot Time on the facing page

•

Configure the server.ini File on the facing page

•

Reboot on page 112

•

Set Up Linux Clients on page 112

•

Install Start Application Menu Entries and Batch Processing on Clients on page 114

Following is an example of entries in the smb.conf file. You can add these to the end of the smb.conf file.
[USA_DB]
comment = Toon Boom Harmony Database
browseable = yes
read only = no
guest ok = no
create mask = 0777
directory mask = 0777
path = /USA_DB
[usa]
comment = Toon Boom Harmony binaries & stuff
browseable = yes
read only = no
guest ok = no
create mask = 0777
directory mask = 0777
path = /usr/local/ToonBoomAnimation/harmony_10.0
[usadata000]
comment = Toon Boom Harmony data 000
browseable = yes
read only = no
guest ok = no
create mask = 0777
directory mask = 0777
path = /usadata000
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[usadata001]
comment = Toon Boom Harmony data 001
browseable = yes
read only = no
guest ok = no
create mask = 0777
directory mask = 0777
path = /usadata001/
You must also either add or modify the following entries to the [Global] section of smb.conf:
[global]
encrypt passwords = no

blocking locks = no
oplocks = no
level2 oplocks = no

follow symlinks = yes
unix extensions = no
wide links = yes
Once you have done all the changes and saved the smb.conf file, run the testparm command to validate the
smb.conf configuration file for internal correctness.
testparm

Configure the Samba Service to Start at Boot Time
By default, Samba is not set up to run automatically.
To start the Samba service:
1. To configure the Samba to run as a service at boot, type the following in a shell:
/sbin/chkconfig smb on
2. To start the Samba service immediately, type the following in a shell:
/sbin/service smb start

Configure the server.ini File
Before you install Harmony on Windows clients, you must create the
/usr/local/ToonBoomAnimation/harmony_10.0/etc/server.ini file on the database server. The
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server.ini file provides information necessary for the Windows configuration wizard to set up a Windows
client.
When creating the server.ini file, be attentive to spelling and character spacing and case.
The following is an example of the /usr/local/ToonBoomAnimation/harmony_10.0/etc/server.ini file. In this
example, the database server name is harmonyserver and there are two usadata directories, usadata000
and usadata001.
[WizardConfig]
ServerName=harmonyserver
InstallationDrive=C
UsaShare=usa
UsadbDrive=C
UsadbShare=USA_DB
FileSystem0=C usadata000 harmonyserver
FileSystem1=C usadata001 harmonyserver
Do not worry about the references to "Drive C". These references are necessary for Windows clients and will be
ignored by Linux.

You can find the example of server.ini under
/usr/local/ToonBoomAnimation/harmony_10.0/resources/samples.
You can copy and paste it from there and change it accordingly.
Any sharing folder name should be case sensitive.

Reboot
At this point, you should reboot the Toon Boom Harmony server to verify that all the Harmony services are
properly configured to start automatically.

Set Up Linux Clients
To run Toon Boom Harmony on Linux clients, you must mount the binaries and data directories stored on the
server. To access the directories exported from the server, the network file server (NFS) and NFS locking
services must be running.
To start NFS services and mount Toon Boom Harmony directories on clients:
1. To access the mounted directories, you must start the NFS service. Type the following in a shell:
/etc/init.d/nfs restart
/sbin/chkconfig nfs on
‣

Note that if you are using Fedora 16, this would be:
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systemctl start nfs-server.service
/sbin/chkconfig nfs-server on
2. The NFS lock manager must run on all Linux stations on your network. Without this service, they will not
be able to access the database without receiving numerous "read lock" error messages. Type the
following in a shell:
/etc/init.d/nfslock restart
/sbin/chkconfig nfslock on
‣

Note that if you are using Fedora 16, this would be:
systemctl start nfs-lock.service
/sbin/chkconfig nfs-lock on

Now you are ready to mount the directories from the server.
3. On each client computer, create directories for:
/usr/local/ToonBoomAnimation/harmony_10.0
/USA_DB
/usadata000.
The directory names must match the names on the Toon Boom Harmony server.
mkdir /usr/local/ToonBoomAnimation/harmony_10.0
mkdir /USA_DB
mkdir /usadata000
4. To mount the directories on the client machine edit the /etc/fstab file.
In the following example, the server is the machine name of the database server.
server:/USA_DB /USA_DB nfs rw,soft,intr,bg 0 0
server:/usadata000 /usadata000 nfs rw,soft,intr,bg 0 0
server:/usr/local/ToonBoomAnimation/harmony_10.0
/usr/local/ToonBoomAnimation/harmony_9.2 nfs rw,soft,intr,bg 0 0
This will cause the Toon Boom Harmony directories to mount with the default version of NFS on your
system.
If you encounter errors, you should try using NFS version 2. In this case, you should modify the fstab file to
match the following:
server:/USA_DB /USA_DB nfs rw,soft,intr,bg,vers=2 0 0
server:/usadata000 /usadata000 nfs rw,soft,intr,bg,vers=2 0 0
server:/usr/local/ToonBoomAnimation/harmony_10.0
/usr/local/ToonBoomAnimation/harmony_10.0 nfs rw,soft,intr,bg,vers=2 0
0
5. At a command line, type the mount all command.
mount -av
To verify that all of the shares are mounted, type the following in a shell:
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Configuration

mount
A report appears listing all of the shares mounted on the client.
6. To test that the mount has worked, you can open one of the mounted directories and list the contents.
You can also open the sample scene in Harmony Stage.
‣

To list the contents of the mounted directories, type the following in a shell:
cd /usr/local/ToonBoomAnimation/harmony_10.0
ls

A list appears of the directories in /harmony_10.0. They are:
etc help lang lnx86_64 Plugins resources
‣

To open the sample scene in the Harmony Stage type the following in a shell:
Stage

‣

Select the Connect to Database radio button and login using the usabatch user name.

‣

Open the sample scene.

If you have any problems opening the sample scene on a Linux client, see Troubleshooting on the
facing page.

Install Start Application Menu Entries and Batch Processing on Clients
To make it easier for users to start Toon Boom Harmony, you should install the application menu entries for
KDE. You should also include the -p installation option to start batch processing services on rendering machines.
To install menu entries and batch processing:
1. Go to the directory that contains the Linux installation files.
2. Run the install script with the -p and -kde options.
./install -p -kde

Related Topics
•

Troubleshooting on the facing page
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Troubleshooting
If you have any problems running Harmony after installation, review the installation and configuration
instructions to make sure you have followed them completely. If you continue to have problems, consult the
following list to troubleshoot common installation and configuration problems.
•

Problem: License Error When Starting Any Harmony Module below

•

Problem: Unable to Import Sample Scene (Errors with the Dbserver) on the next page

•

Problem: Exported Directories Not Mounting on Clients on the next page

•

Problem: Harmony Stage Will Not Open or Crashes on Startup on page 117

•

Problem: Unable to Display Images in Harmony Stage on page 117

•

Problem: Unable to Open Sample Scene on Linux Clients on page 117

Problem: License Error When Starting Any Harmony
Module
If you are getting license errors when you start a Toon Boom Harmony module, check the set up and
configuration of the license service.
•

Make sure that the license.dat file is in the following directory:
/usr/local/flexlm/licenses if you are using a license server.

•

Open the license.dat file.
The license.dat should contain the following information:
SERVER this_host 0 ANY
VENDOR toonboom
USE_SERVER
Note that on a client workstation, the hostname of the server should be listed on the
first line instead of this_host.

•

Make sure that the license service is running on the license server. To see if the service is running on the
server. In a shell type:
/sbin/service USAnimation_flexlm status

•

If it is not running, start the service with the following command:
/sbin/service USAnimation_flexlm start

•

You will have to re-start the Dbserver if the license server was not properly installed or activated. Type the
following in a shell:
/sbin/service USAnimation_dbserver restart

•

If you continue having problems with the license server, locate the file lmgrd.log and send it to
support@toonboom.com. This file is usually in
/tmp.
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Problem: Unable to Import Sample Scene (Errors with the Dbserver)

Problem: Unable to Import Sample Scene (Errors
with the Dbserver)
•

Check the Dbserver.log file. It is usually stored in /tmp.
•

If there is no log file, re-start the Dbserver. Type the following in a shell:
/sbin/service USAnimation_dbserver restart

If there is a log file, the last few lines in the log file will give you some indication as to the problem with the
Dbserver.
•

If you get an error in the log about the machine name, check the
/USA_DB/ Dbserver.conf file and make sure the hostname matches the machine name of the
Harmony server.

•

If you get errors about the port number, check that the port name in the Dbserver.conf file is not used
by another service. Type netstat -a in a shell to see a list of port numbers used by the machine. If
another service is using the port 5678, you can change the port number in Dbserver.conf to any
unused number above 5000.

•

Re-start the Dbserver. Type the following in a shell:
/sbin/service USAnimation_dbserver restart

Problem: Exported Directories Not Mounting on
Clients
On most Fedora Linux distributions, the ypbind service is started after nfs by default. This causes directory
mounting to fail when your system boots up. This will prevent Linux clients from mounting Toon Boom Harmony
directories from the server.
You must make sure the ypbind service is started before nfs.
To configure the start sequence of ypbind and nfs:
1. Turn the service off and remove it from the startup configuration. Type the following in a shell:
/sbin/service ypbind stop
/sbin/chkconfig ypbind off
2. Edit the ypbind startup script located in /etc/init.d/ypbind. Find the line reading:
chkconfig: 27 73
Change it for:
chkconfig: 24 73
3. Restart the service. Type the following in a shell:
/sbin/service ypbind start
/sbin/chkconfig ypbind on
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Problem: Harmony Stage Will Not Open or Crashes
on Startup
Periodically, the Harmony Stage refuses to open, printing an NVIDIA error message in the shell. This may not
happen all of the time. Users may report this error after running the application several times successfully.
The NVIDIA error message directs users to instructions in the Read Me file:
/usr/share/doc/NVIDIA_GLX-1.0/README.txt
Problems with the security module of the PAM system can cause these periodic problems. Follow the
instructions in the NVIDIA Read Me to resolve this error.
If you continue to experience problems, verify that the xorg.conf file (in /etc/X11/) contains the correct
driver information (the driver should be nvidia, not nv).
If this does not resolve the problem, reinstall your NVIDIA driver.

Problem: Unable to Display Images in Harmony
Stage
Your monitor's screen settings must be set to 24-bit per pixel.
Verify your current settings.
•

If you are using Fedora, verify the file /etc/X11/xorg.conf.

Problem: Unable to Open Sample Scene on Linux
Clients
•

On the Harmony server, check that all of the Harmony directories were exported. The /USA_DB,
/usr/local/ToonBoomAnimation/harmony_10.0, and /usadata directories must appear in the
/etc/exports file. Make sure that the entries in this file match the name of the directories you created
on the server.
In a shell, type the following to make sure the directories have been exported:
/usr/sbin/exportfs -r
For more information, .

•

On the Linux client, check that you created the data directories and mounted the server directories into
those directories. Check the /etc/fstab file to see that the data directories are listed and spelled the
same way as the directories on the client and on the server.
List the contents of the mounted directories to see that there are some contents.
cd /usr/local/ToonBoomAnimation/harmony_10.0
ls
A list appears of the directories in /usa. They are:
etc help lang lnx86_64Plugins resources
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•

Problem: Unable to Open Sample Scene on Linux Clients

If you do not see anything in the exported directories, type the following in a shell to make sure the server
directories have been mounted:
mount -a
If you are able to list the contents of the exported directories and open the sample scene after manually
mounting all shares, check the start up sequence of ypbind and nfs to make sure that nfs is started first.
For more information, Problem: Exported Directories Not Mounting on Clients on page 116.
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