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Chapter 1: Introduction
Toon Boom Animate is a complete animation software with advanced features for all your animation projects.
Animate is the ideal paperless animation solution when working with frame-by-frame animation with a drawing
tablet. Animate Pro is the ideal cut-out animation solution. Made specifically for creating and animating cut-out
characters.
No matter your preferred animation work-style, Animate manages your entire project, from importing assets
and content creation, all the way to animation, compositing and multi-platform rendering. Animate boasts a 64bit engine, allowing you to export content faster, including elaborate scenes, large bitmaps, gradients and
complex backgrounds. Output sophisticated scenes at full resolution with effects.

Animate works in conjunction with Toon Boom Storyboard Pro, which allows you to plan your project,
and time the scenes to audio before animating in Animate or Animate Pro.

To learn all about the features available in Toon Boom Animate and how to use them in a production context,
refer to the following chapters:
•

Getting Started on page 35

•

Interface on page 61

•

Drawing on page 111

•

Traditional Animation on page 237

•

Colour on page 273

•

Timing on page 339

•

Morphing on page 419

•

Import on page 457

•

Library on page 521

•

Character Building on page 553

•

Scene Setup on page 483

•

Sound on page 607

•

Animation Paths on page 637

•

Cut-out Animation on page 713

•

Effects on page 779

•

Export on page 831

In all Animate documentation, the default keyboard shortcuts used are the Toon Boom Animate set.
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Visual Markers

Visual Markers
Related Topics
The Related Topics sections, located at the end of each section, indicate that there is another section extent in
this guide, one that provides further information regarding the current topic. If you are reading the digital
version of this guide, you can click on the link to go directly to that section.

Note
This Note gives important information regarding the current topic.
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Chapter 2: Getting Started
Once the software is installed, you are ready to start the application and animate!

Topics Covered
•

Starting Toon Boom Animate on the facing page

•

Welcome Screen on page 38

•

Creating and Opening a Scene on page 40

•

Setting the Scene Length on page 44

•

Scene Settings on page 45

•

Adding a Drawing Layer on page 50

•

Basic Commands on page 51

•

Preferences on page 55
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Starting Toon Boom Animate
You can run the software on Mac OS X or Windows operating systems.
To start Animate, do one of the following:
‣

Windows: Double-click on the Animate

icon or select Start > Programs/All Programs > Toon

Boom Animation > Toon Boom Animate 3 .
‣

Mac OS X: Double-click on the Animate

icon or select Applications > Toon Boom Animate 3 >

Animate.
Toon Boom Animate opens.

Related Topics
•

Preference Style below

•

Welcome Screen on page 38

Preference Style
When you start Animate for the first time, the Preference Style dialog box will open. This is the only time you will
see this dialog box, however, you can change the styles later on if you like using the Preference panel.

You have two choices. Select the one which fits your work style:
•

Yes: Sets Animate’s default shortcut scheme and preferences to fit the Adobe® Flash® software
workflow style. For example, the Select tool is set to Marquee mode.

•

No : Sets Animate’s default shortcut scheme and preferences to fit the Toon Boom professional products
workflow style. The Select tool is set to Lasso selection mode.
Once your choice is made, the Welcome Screen is displayed

You can always return to the Preference Style window later on to change the shortcut style.

Refer to the following topics to learn more about preferences and customizing the shortcuts:
•

Preferences on page 55
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•

Keyboard Shortcuts on page 57

•

Preference Highlights on page 56

Related Topics
•

Starting Toon Boom Animate on the previous page

37

Chapter 2: Getting Started Welcome Screen

Welcome Screen
When you open Toon Boom Animate, the Welcome Screen appears. If a scene is already open, you
can display the Welcome Screen by selecting Help > Show Welcome Screen.

The Welcome Screen allows you to:
1. Create scenes.
2. Choose the scene resolution.
3. Add or delete a custom scene resolution.
4. Open recent scenes from a list.
5. Open scenes by browsing.
6. Open the Help documentation.

Accessing the Documentation
To access the Animate documentation:

‣ In the Documentation section, click Animate Documentation.
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All the Animate guides can also be opened directly in the software, from the top menu, by selecting Help
> Help or press [F1].

Related Topics
•

Starting Toon Boom Animate on page 36
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Creating and Opening a Scene
All scenes created via Animate are independent and local to the computer.
You can either create a new scene using the Welcome Screen or the File menu:
•

Creating a Scene Using the Welcome Screen below

•

Creating a Scene Using the File Menu on the next page

Creating a Scene Using the Welcome Screen
To create a scene from the Welcome screen:
1. To select the scene’s location, in the Project Directory section, browse the files by clicking Browse
button.

2. In the Project Name field, type the scene’s name.

The scene name cannot exceed 23 characters.

3. Set the scene resolution by doing one of the following:
‣

In the Resolution window, select the scene’s resolution and click Create.

Your new scene is created.
‣

Add a new resolution to list by clicking the Add

button.

In the New Resolution dialog box, fill in the following fields and click Create.
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Resolution Name: Name your new resolution.
Resolution: Set the width, height and aspect ratio of the resolution.
Field of View: Set the horizontal fit, vertical fit, or custom Fov.
Frame Rate: Type the scene's frame rate per second.

You can delete a custom resolution from the Resolution list by selecting it, and clicking the Delete
button under the Resolution window.

To open a scene from the Welcome screen:
1. In the Recent Scenes section, click Open Scene.
The Open Scene browser opens.
2. Browse and select the desired *.anim file.
3. Click Open to open the scene.
To open a recent scene from the Welcome screen:

‣ In the Recent Scenes section, select a scene from the list.

Creating a Scene Using the File Menu
If a scene is already open and you want to create a new one, you can use the File menu.
To create a scene from the File menu:
1. Do one of the following:
‣

From the top menu, select File > New.

‣

In the File toolbar, click the New

‣

Press [Ctrl] + [N] (Windows) or [⌘ ] + [N] (Mac OS X).

button.

The New Scene dialog box opens.
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2. Select a scene directory by clicking the Browse

button.

3. In the Project Name field, type the scene's name.

The scene name cannot exceed 23 characters.

4. Set the scene resolution by doing one of the following:
‣

In the Resolution window, select the scene’s resolution and click Create.

Your new scene is created.
‣

Add a new resolution to list by clicking the Add

button.

In the New Resolution dialog box, fill in the following fields and click Create.
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Resolution Name: Name your new resolution.
Resolution: Set the width, height and aspect ratio of the resolution.
Field of View: Set the horizontal fit, vertical fit, or custom Fov.
Frame Rate: Type the scene's frame rate per second.
To open a scene from the File menu:
1. Do one of the following:
‣

From the top menu, select File > Open.

‣

In the File toolbar, click the Browse

‣

Press [Ctrl] + [N] (Windows) or [⌘ ] + [N] (Mac OS X).

button.

The Open Scene browser opens.
2. Browse and select the desired *.anim file.
3. Click Open.

Saving a Scene
It is important to regularly save your scene. As you make changes to a scene, an asterisk (*) appears in the title
bar beside the scene name to indicate that the scene contains unsaved changes.
To save a scene, do one of the following:
‣

Select File > Save.

‣

Press [Ctrl] + [S] (Windows) or [⌘ ] + [S] (Mac OS X).

Related Topics
•

Welcome Screen on page 38
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Setting the Scene Length
Once you have created your scene, you can set its length.
To set the scene length from the top menu:
1. From the top menu, select Scene > Scene Length.
The Set Scene Length dialog box opens.

2. In the Number of Frames field, type the number of frames needed.
Refer to the following topics to learn more about adding and removing frames, and extending the scene’s
length:
•

Adding Frames on page 351

•

Deleting Frames on page 353

Related Topics
•

Getting Started on page 35

•

Creating and Opening a Scene on page 40
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Scene Settings
When you created your new scene, you set up the resolution and the alignment. However, if you want to change
these initial settings later, you can.
To change the scene settings:
From the top menu, select Scene > Scene Settings.
The Scene Settings dialog box opens.

The different Scene Settings options are separated into three tabs.
•

Resolution Tab below

•

Alignment Tab on page 47

•

Advanced Tab on page 49

Resolution Tab
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1. Project Resolution Type
2. Scene Resolution Setting
3. Pixel Dimensions
4. Save Custom Resolution
5. Aspect Ratio
6. Project Frame Rate
7. Field of View

Resolution
1. You can select your project’s resolution type from this area so it matches your intended output.
‣

HDTV: High definition television delivers a higher quality image than standard television does,
because it has a greater number of lines of resolution. To take advantage of the superior quality your
output device must be compatible with HDTV technology to make this resolution setting useful.

‣

HDTV_Vertical: The "vertical resolution" of HDTV_Vertical refers to how the drawing grid is fit into
the camera frame. When working with 12 or 16 field drawing grids, the grid is a different aspect ratio
from the camera frame. When you fit vertically, you fit the grid with the top and bottom of the camera
frame.

‣

film-1.33: Use this resolution setting for the academy film format that conforms to the standard 4:3
aspect ratio.

‣

film-1.66: Use this resolution setting for the widescreen film format that conforms to the 16:9 aspect
ratio.

‣

film-1.66_Vertical: This is essentially the same as film-1.66. Refers to how the drawing grid is fit into
the camera frame. When working with 12 or 16 field drawing grids, the grid is a different aspect ratio
from the camera frame. When you fit vertically, you fit the grid with the top and bottom of the camera
frame.

‣

NTSC: This is the standard analogue television broadcasting system used in North America and
conforms to the North American standards on how rectangular pixels are displayed for computer and
television screens.

‣

PAL: This resolution works best with the European format for television and computer screens, as the
rectangular pixels are displayed at a different orientation.

‣

Low: This format is ideal for videos destined for the web, where size and fast download of a video file
might take precedence over quality.

2. Displays the scene resolution setting selection.
3. Displays the pixel dimensions for your resolution selection.
If you decide to type in the pixel dimensions, or use the up and down arrows to change the pixel
increments, you will have to save your custom selection in order to make it active (4). It will then appear in
the resolution selection list (1).
4. Click Save to save and create your custom resolution as a setting. This button becomes active when you
create a custom resolution type (3).
5. The aspect ratio is the ratio between the horizontal and vertical dimensions of the Camera framing. Each
resolution setting has a preset aspect ratio that cannot be changed.
6. Select the frame rate for your project. The higher the frame rate, for example 30 fps, the smoother your
animation will look, but the heavier it will become, the lower the frame rate, for example 12 fps, the
choppier your animation may look, but the lighter it will be.
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7. Use these options to define the FOV of the camera and how the drawing elements (and drawing grid)
align to the camera. The drawing grid is always scaled proportionally to a 4:3 (1.33) ratio, therefore
changing the Field of View setting may not show a visible difference if your project resolution is also 4:3,
such as NTSC.
‣

Horizontal Fit: The drawing grid is fitted to the vertical (side) edges of the Camera view, so that the
width of the grid matches the width of your project resolution.

‣

Vertical Fit: The drawing grid is fitted to the horizontal (top and bottom) edges of the Camera view,
so that the height of the grid matches the height of your project resolution.

‣

Custom Fov: After selecting this option, use the now-active field to the right to enter in a value, in
degrees, of the angle that you want the camera cone to be. Increasing this value will make the camera
cone wider (the angle is more obtuse), widening the FOV and making the grid and all elements appear
farther away. Decreasing the default value will create the opposite effect.

Alignment Tab

1. Alignment Presets
2. Units Aspect Ratio
3. Number of Units
4. Coordinates at Centre
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Alignment Rules

1. The Alignment Presets give you two preset options:
‣

4:3 12 Fields: Defines the units of your project to have a 4:3 ratio and sets up 12 of these units to run
both vertically and horizontally in four cardinal quarters (NW, NE, SW, SE). This Alignment preset is
visible in the FOV and drawing grids.

‣

Square 12 Fields: Defines the units of your project to have a 1:1 or square ratio and sets up 12 units
to run both vertically and horizontally in four cardinal quarters (NW, NE, SW, SE). This Alignment
preset is NOT visible in the FOV and drawing grids.

2. In the Units Aspect Ratio fields, enter the aspect ratio of the grid you will use. The aspect ratio describes
the shape of the grid unit. A square grid unit would have the ratio 1:1, whereas a grid unit of aspect ratio
4:3 is a unit with one side 1.33 times as big as the other side.
‣

If the aspect ratio you want to use is 1:1, enter 1 in the Left/Right field (X-axis) and 1 in the Up/Down
field (Y-axis). The default Aspect Ratio is set to 4:3 as it is the one used by traditional animators, who
are accustomed to working with the grid system described above.

3. In the Number of Units fields, enter the number of horizontal, vertical and depth units for your scene’s
grid.
Animators who prefer to work traditionally will understand the default setting of 24 units horizontal by 24
units vertical as it, once again, corresponds to the grid above. Twelve is a common setting for the field
depth.
Those who prefer to work in pixels should enter the pixel dimensions (3) of their project. This way if you
want to move something over 600 pixels you just need to type in 600 units.
4. In the Coordinates at Centre, you can enter a new coordinate for the centre of your scene.
By default, the (0,0) centre is set in the middle of the grid as shown in the grid above. If you want to
change the centre of your grid, for example to the upper left corner, you would enter (-12, 12), -12 units
across and 12 units up. That is of course unless you changed the number of units to match the pixel
dimensions of your scene. Then you would enter negative half the width and positive half the height.
5. Click Save button to save your current Alignment settings and be able to select them later from the list.
The Choose Alignment Name dialog box opens.
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Type in a name for your new alignment settings and click OK.

If you change your scene‘s alignment from 4:3 12 Fields to Square 12 Fields part way though your
project, you may find that the Animation grid becomes offset. To correct this, choose the following
setting from the Layer Properties panel‘s Advanced tab: Alignment > Alignment Rule > Centre
First Page.

Advanced Tab

The Advanced tab contains an option for Toon Boom Digital Pro release 7.3 and Animate release 7.3.
Since version 7.8, the method in which Z-Ordering is calculated has been optimized. Enable this option if you
want to use the version 7.3 system.
Toon Boom Digital Pro and Toon Boom Animate 7.3 allowed smaller values on the Z-axis such as 0.0001. Since
version 7.8, the Z-ordering calculation is now optimized and allows only larger values such as 0.001.

Related Topics
•

Creating and Opening a Scene on page 40

•

Setting the Scene Length on page 44
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Adding a Drawing Layer
Now that your scene is set up, you can add drawing layers.
To add a drawing layer from the Timeline view:
1. In the Timeline view, click the Add Drawing Layer

button.

A new drawing layer is added to the Timeline view.

Refer to the following topics to learn more about layers and how to add them.
•

Layers and Columns on page 355

•

Layer and Column Concepts on page 355

•

Adding New Drawing Layers on page 360

•

Deleting Layers And Columns on page 363

•

Modifying Layers on page 365

•

Duplicating Layers and Columns on page 372

•

Cloning Layers And Columns on page 373

Related Topics
•

Getting Started on page 35
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Basic Commands
This table lists the most common commands used in Animate.
Command

Action

Access Methods

New

Starts a new scene while
closing any scene already
open. The New Scene dialog
box opens, asking for
directory, name, and
resolution information.

File > New

Displays the Open Scene
dialog box. Browse your file
system for a scene file.

File > Open

Open

The Open command is not
disabled when a scene is
opened. You can open a
new scene from the current
one and the previous scene
will be closed.

Press [Ctrl] + [N] (Windows)
or [⌘ ] + [N] (Mac OS X).

Press [[[Undefined variable
Keyboard_
Shortcuts.Open1]]].

Open Recent

Displays a quick access list
to view and open recently
used Animate files.

File > Open Recent

Open Recent > Clear

Clears the recently opened
Animate files list.

File > Open Recent > Clear

Close

Closes the currently opened
scene, but does not close
the Animate application.

File > Close

Save

Saves all changes made to
the opened scene,
drawings, palettes, and
palette lists.

File > Save

Saves the current state of a
scene as another scene. The
Save As window prompts
you to give a new name and
choose a different location
to this scene before saving
it. This will create a
complete scene directory for
the new scene.

File > Save As

Save As

The scene name cannot
exceed 23 characters.
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Command

Action

Access Methods

Closes AnimateHarmony
Stage.

Windows: File > Quit

Show Scan Information

Displays a status bar
showing the scanning
information at the bottom
of the Drawing and Camera
view.

Drawing View Menu >
View > Show > Show Scan
Information

Cut

Removes selected objects.
You can then paste the
object or its properties to
another object.

Edit > Cut

Copies selected objects and
properties.

Edit > Copy

Places an object you cut or
copied into the location you
select in the Camera,
Drawing and Timeline View.

Edit > Paste

Removes selected objects.

Edit > Delete

Removed Unused Files
Import and Export
Quit

Copy

Paste

Delete

Mac OS X: Animate> Quit

Press [Ctrl] + [X] (Windows)
or [⌘ ] + [X] (Mac OS X).

Press [Ctrl] + [C] (Windows)
or [⌘ ] + [C] (Mac OS X).

Press [Ctrl] + [V] (Windows)
or [⌘ ] + [V] (Mac OS X).

[Delete]
Select All

Deselect All

Undo

Redo

Selects all drawing objects in
the current drawing window
in the Drawing, Timeline and
Camera view. This helps you
manage multiple objects as
one when moving them.

Edit > Select All

Deselects all selected
objects in the Drawing and
Camer views.

Edit > Deselect All

Removes remove the last
change made to your
project. Animate supports
multiple undo, so you can
undo changes you made in
the order you made them.

Edit > Undo

Redoes and operation you

Edit > Redo
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[Esc]

Press [Ctrl] + [Z] (Windows)
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Command

Action

Access Methods

have undone that you later
decide to keep. This
command is active only after
you use the Undo command.

Press [Ctrl] + [Shift] + [Z]
(Windows) or [⌘ ] + [Shift] +
[Z] (Mac OS X).

Select Children

Lets you select all elements
parented to the selected
peg element in the Timeline
view.

Animation > Select
Children

Select Child

Lets you select the first
element parented to the
selected peg element in the
Timeline View.

Animation > Select Child

Lets you select the parent of
the selected element in the
Timeline view skipping
effects in the hierarchy.

Animation > Select Parent
Skipping Effects

Lets you select the parent of
the selected element in the
Timeline view.

Animation > Select Parent

Lets you select the next
element (above current
element) in the Timeline
view.

Animation > Select
Previous Brother

Lets you select the next
element (below current
element) in the Timeline
view.

Animation > Select Next
Brother

Use the Auto Render Write
command to render a frame
each time the current frame
is changed.

Scene > Render >Auto
Render Write

Select Parent Skipping
Effects

Select Parent

Select Previous Brother

Select Next Brother

Auto Render Write

Press [Shift] + [B].

Press [B].

Press [B].

Press [/].

Press [?].

You must have a Write
module in your network to
use this command.
Message Log

The Message log view
displays information
gathered during a render
task, like which frames and
at what time they were each
rendered.

Windows > Message Log

Debug Mode

Enable the Debug Mode
option to gather and display

Help > Debug Mode
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Command

Action

Access Methods

precise information about
each rendering frame such
as the modules encountered
and action taken.
Help

Launches the Toon Boom
Animate Help System PDF,
complete with instructions
on how to use the system.

Help > Help

Toon Boom Animate on the
Web

Launches the Toon Boom
Animate website, which
features a Support and
Community > Forum
section.

Help > Toon Boom
Animate on the Web

About

Use the About command to
access general information
about the software.

Windows: Help > About

Brings back the Welcome
screen—see Welcome
Screen on page 38

Help > Show Welcome
Screen

Show Welcome Screen

Related Topics
•

Getting Started on page 35
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Preferences
An important feature of Toon Boom Animate is the Preferences dialog box. From here you can customize your
interface, tool behaviour and shortcuts. Throughout this guide, you are often required to go to the Preferences
dialog box to set parameters and options.

In this section, you will learn how to access the Preferences panel and also find a general description of its
functionality.
To learn about the different preferences available and how they are used in a production context, refer to the
following topics:
•

Getting Started Preferences on page 57

•

Interface Preferences on page 105

•

Drawing Preferences on page 233

•

Traditional Animation Preferences on page 271

•

Colour Preferences on page 336

•

Timing Preferences on page 415

•

Morphing Preferences on page 455

•

Import Preferences on page 482

•

Library Preferences on page 1
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•

Scene Setup Preferences on page 516

•

Sound Preferences on page 636

•

Animation Path Preferences on page 708

•

Cut-out Animation Preferences on page 1

•

Deformation Preferences on page 1

•

Effects Preferences on page 828

•

Export Preferences on page 841

Related Topics
•

Preference Highlights below

•

Getting Started Preferences on the next page

•

Keyboard Shortcuts on the next page

Preference Highlights
You can set over 80 preferences in the Preferences dialog box. You will learn about them as you read through
this guide and find out how they apply in a production context.
The Preferences panel is divided into the following tabs:
•

Shortcuts

•

General

•

Camera

•

Exposure Sheet

•

Drawing

•

Sound

•

OpenGL

•

Render

•

Advanced

Some preferences require you to exit and restart the application or to close a view and reopen it.

To access the Preferences dialog box:
Do one of the following:
‣

From the top menu, select Edit > Preferences (Windows) or Animate > Preferences (Mac OS X).

‣

Press [Ctrl] + [U] (Windows) or [⌘ ] + [U] (Mac OS X).
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Related Topics
•

Preferences on page 55

•

Getting Started Preferences below

•

Keyboard Shortcuts below

Getting Started Preferences
In this section, you will find useful preferences to get you started in the General tab.
•

General Tab below

General Tab

Auto-Save
•

Interval (minutes): This is the frequency at which the auto-save takes place.

•

Inactivity Interval (seconds): When Auto-save is about to take place, it verify if you are drawing or doing
anything in the application. If so, Auto-save waits this number of seconds before attempting another save.

•

Ask Before Saving: Before performing an auto-save, the system will prompt you with a message to
confirm if you want to save or not. You can choose to turn off this option.

•

Enabled: This enables the Auto-save feature. If you do not want the system to automatically save your
work, deselect this option. The auto-save is off by default.

Timeline Tab
Related Topics
•

Keyboard Shortcuts below

Keyboard Shortcuts
To speed up your work, all of Toon Boom Animate’s keyboard shortcuts can be customized. You can even
choose other software keyboard shortcut sets.
•

Selecting a Keyboard Shortcut Set on the facing page

•

Customizing a Keyboard Shortcut on the facing page
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Selecting a Keyboard Shortcut Set
In Toon Boom Animate, you can choose a set of default keyboard shortcuts you are familiar with. You can choose
between the following:
•

Adobe Flash

•

Toon Boom Animate

•

Toon Boom Studio

To switch keyboard shortcut sets:
1. Select Edit > Preferences or press [Ctrl] + [U] (Windows) or [⌘ ] + [U] (Mac OS X).
2. In the Preferences dialog box, select the Shortcuts tab.
3. From the Shortcut Set list, select the desired set.

Customizing a Keyboard Shortcut
You can also customize most of the shortcuts.
To set a shortcut:
1. Select Edit > Preferences or press [Ctrl] + [U] (Windows) or [⌘ ] + [U] (Mac OS X).
2. In the Preferences dialog box, select the Shortcuts tab.
3. In the left pane, select a category and then select a command to modify.
4. Click on the shortcut rectangle (above the right pane).

5. On your keyboard, click the desired shortcut.
‣

To remove any keyboard shortcut associated to a command, click Clear.

‣

To reset a command’s default keyboard shortcut, click Default.

6. Click OK.
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If a keyboard shortcut is already in use, the Conflict Detected dialog box will appear notifying you of
the command to which it is already associated. You can continue to associate the shortcut or cancel
the operation and choose another command.

Related Topics
•

Preferences on page 55
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Chapter 3: Interface

Knowing how to manage the Toon Boom Animate interface helps you to work efficiently and organize your
workspace conveniently. There are a series of views and toolbars you can use as you perform different
operations. Each user has a preferred way of working in the interface and which views and toolbars they will use.
In this chapter, you will learn about the main elements of the interface and how to manage them.

Topics Covered
•

User Interface on the facing page

•

Managing the Views on page 90

•

Managing the Toolbars on page 94

•

Managing the Workspace on page 98

•

Interface Navigation on page 103

•

Preferences on page 55
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User Interface

User Interface

This section takes you through the most common elements of the User Interface. Throughout the user guide, you
will learn about each view and toolbar and how and where to use them:
•

Views and Toolbars below

•

Interface Highlights on the next page

Views and Toolbars
Toon Boom Animate has several views and toolbars. The Top toolbars are available at the top of the interface
and the View toolbars are in individual windows. View toolbars are only shown if the particular view is displayed
in the workspace.
This is a complete list of the views and toolbars available in Toon Boom Animate.

Views

Top Toolbars

Camera View on page 64

Advanced Animation Toolbar

Colour View on page 83

Control Point Toolbar

Coordinates and Control Points View on page 664

Coordinate Toolbar

Drawing View on page 115

Easy Flipping Toolbar

Function View on page 676

Edit Toolbar

Layer Properties View

File Toolbar

Library View on page 87

Flip Toolbar

62

Toon Boom Animate 3 User Guide

Message Log View

Library Toolbar

Model View

Mark Drawing Toolbar

Module Library View on page 1

Onion Skin Toolbar

Perspective View on page 510

Playback Toolbar on page 88

Script Editor View

Scripting Toolbar

Side View

Tools Toolbar

Timeline View on page 72

Tool Presets Toolbar

Tool Preset View

Workspace Toolbar

Tool Properties View on page 71
Top View
Xsheet View on page 342

View Toolbars
Camera View Toolbar
Colour View Toolbar
Drawing View Toolbar
Model View Toolbar
Timeline View Toolbar
Xsheet View Toolbar

Interface Highlights
It’s important that you become familiar with the following elements of the user interface, this will help you to
start using Toon Boom Animate. You can learn more about the highlights described here, and how to use them
in a production context, throughout this guide.
When you start Toon Boom Animate for the first time, the default workspace is displayed. It contains all of the
main elements you need to use.
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Interface Highlights

1. Camera View below
2. Tools Toolbar on page 71
3. Tool Properties View on page 71
4. Timeline View on page 72
5. Menus on page 81
6. Colour View on page 83
7. Library View on page 87
8. Playback Toolbar on page 88

Related Topics
•

Managing the Workspace on page 98

•

Managing the Views on page 90

Camera View
The Camera view is the centre of operations in Toon Boom Animate. It is in this view that you will draw, paint,
animate, create animation paths and see your results. You can also move through your symbol’s hierarchy.
The Camera view has a top and bottom toolbar that you can use to either navigate in the view, change the
display mode or go back up your symbols hierarchy.
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1. Update Preview below
2. OpenGL View Mode on the facing page
3. Render View Mode on the facing page and Matte View Mode on page 67
4. Camera View Options Menu on page 67
5. Zoom Drop-down Menu on page 69 and Toggle Quick Close-up on page 69
6. Drawing Name on page 70
7. Tool Name on page 70
8. Frame Number on page 70
9. Editing Stack Menu on page 70

Update Preview
The Update Preview

button lets you check the final look of your effects and fully antialiased image. When you

click the button, Toon Boom Animate calculates the current frame final image. It displays the result in the Render
View Mode of the Camera view, it does not output an image.
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OpenGL View Mode

The OpenGL View Mode

button switches the Camera view to fast display, letting you see your animation

play in real time. The OpenGL display requires less memory. The final look of your effects is not shown in the
OpenGL View Mode. Switch to the Render View Mode to see your effects.

Render View Mode

The Render View Mode

button switches the Camera view to a fully rendered display showing the final image

of the current frame. If a modification is done to your current frame or if you move to a different frame, click on
the Update Preview button to update the display.
Use the Render View Mode display to see the final look of your frames including effects and antialiasing. You
cannot play back your scene in Render View Mode. To see your scene fully rendered and play it back, you must
select File > Export > Render Network and enable the Preview option in the Render Network dialog box.
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Matte View Mode

The Matte View Mode

button switches the Camera view to a matte display showing the alpha channel of the

elements in your scene. The transparency level ranges from 0 to 100 percent. Zero percent is completely
transparent and represented by black and 100 percent is completely opaque and represented by white.
Everything in between these extremes has a transparency level somewhere between 1 and 99 percent and is
represented in various shades of grey.
‣

To access the Matte View mode, click on the Render View Mode

button and select Matte View

from the drop-down menu.

Camera View Options Menu
The Camera View Option

menu contains several options related to the camera view display modes. Here are

the options contained in the menu:
•

Safe Area

•

Camera Mask

•

Outline Locked Drawings

•

Current Drawing On Top

•

Show Strokes

•

Show Strokes with Colour Wash

•

Light Table

•

Reset View

•

Reset Rotation
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Safe Area

The Safe Area

button shows or hides the TV safety zone and the centre of the camera frame. The Safe Area

will adapt to the scene resolution as well as the safety zone and frame’s centre.
You can also access this feature from the top menu by selecting View > Show > Safe Area.

Camera Mask

The Camera Mask

button shows or hides a black mask around the scene’s frame to avoid seeing the

unnecessary artwork. This option is handy when you are animating and setting up the scene. It allows you to see
your scene’s composition better.
You can also access this feature from the top menu by selecting View > Show > Camera Mask.

Outline Locked Drawings
Drawings that are locked in the Timeline view (cannot be selected in the Camera view) will be displayed as wire
frames.

Current Drawing On Top
If this option is enabled, the drawing that is being currently edited with a drawing tool will be temporarily
displayed in front of all the other elements. The actual scene is not modified by this option.
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Show Strokes
When drawing with invisible lines such as with the Pencil tool and a line thickness with a value of “0”, the invisible
strokes will be displayed as thin blue lines and the tips of the strokes will be displayed as yellow squares which
helps indicating where the strokes end and where there are gaps in the outline.

Show Strokes with Colour Wash
When drawing with invisible lines such as with the Pencil tool and a line thickness with a value of “0”, the invisible
strokes will be displayed as thin blue lines and the tips of the strokes will be displayed as yellow squares which
helps indicating where there are gaps in the outline. The drawing colours will also be washed out to make the
invisible lines stick out better.

Light Table
By default, while using a drawing tool in the Camera view, the layers that are not being edited are washed out. If
the Light Table option is disabled, the drawings will all be displayed in normal colours even though they are not
being edited.

Reset View
The Reset View

button will reset any panning, zooming or rotation done in the Camera view and return the

display to the initial settings or press [Shift] + [M].

Reset Rotation
The Reset Rotation

button will reset any rotation done in the Camera view and return the display to the

initial rotation settings or press [Shift] + [X]].

Zoom Drop-down Menu
The Zoom menu lets you enlarge or reduce the Camera or Drawing view display.

To make the camera frame size always match the size of your view, select the Fit to View option.
Click the drop-down arrow and select a zoom level or press [1] and [2].

Toggle Quick Close-up
Use the Magnifier tool to quickly center on the mouse position and zoom in to a pre-defined value such as 4X.
Then you can zoom out again. Hold the shift key and press [Z] to zoom in and back out again. Replacing the
Reset Zoom by pressing [Shift] + [Z].
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The area where you zoom in or out is dependent on the cursor location in the Camera view. If you
zoom in and them move the cursor to a different location when you zoom out the mouse will be
centered on that location.

Overlay, Line Art, Colour Art, Underlay and Preview Mode
•

Line Art: Switches to the Line Art layer of the drawing. The default keyboard shortcut is [L].
You can display the Line Art view in the Preferences dialog box. Select Edit > Preferences ( Windows) or
Animate > Preferences ( Mac OS X). Select the General tab. In the Advanced box, select the Use
Advanced Art Mode option and restart the application.

•

Colour Art: Switches to the Colour Art layer of the drawing. The default keyboard shortcut is [L].

•

Preview mode: Switches to Preview mode, so you can see both Line Art and Colour Art layers
simultaneously. The default keyboard shortcut is [Shift] + [P].
You can display the Line Art view in the Preferences dialog box. Select Edit > Preferences ( Windows) or
Animate > Preferences ( Mac OS X). Select the General tab. In the Advanced box, select the Use
Advanced Art Mode option and restart the application.

Drawing Name
The Drawing Name field displays the name of the selected drawing, as well as the layer containing it. If the cell
does not contain any drawing, an Empty Cell text is shown in the field.

Tool Name
The Tool Name field displays the name of the selected tool. If you override a tool using an overriding keyboard
shortcut, the tool’s name will be highlighted in red letters—see Override Tool on page 224 to learn how to
temporarily override a tool.

Frame Number
The Frame Number field displays the number of the current frame.

Editing Stack Menu

The Editing Stack menu displays the names of the symbols and their hierarchy when you are editing a symbol.
You can click on the different names to go back up to the different parent symbols or the top/current project.

Related Topics
•

Interface Highlights on page 63
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Tools Toolbar

The Tools toolbar contains all of the main tools you will use while working in Toon Boom Animate. In the default
workspace, you will find this toolbar on the left-most side of the interface.

Related Topics
•

Drawing on page 111

•

Traditional Animation on page 237

•

Colour on page 273

•

Morphing on page 419

•

Character Building on page 553

•

Scene Setup on page 483

•

Animation Paths on page 637

•

Cut-out Animation on page 713

Tool Properties View
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The contextual Tool Properties view contains the most common options and operations related to the currently
selected tool. As soon as you select a tool from the Tools toolbar, the Tool Properties view will be updated.
For example, if you choose the Select

tool in the Tools toolbar, the Tool Properties view will display the

options and operations related to the Select tool such as Snap to Contour, Apply to All Drawings, Flip
Horizontal and Flatten.
To open the Tool Properties view:

‣ Select Windows > Tool Properties.

The content of the Tool Properties view is explained in detail in the following chapters:
•

Drawing on page 111

•

Traditional Animation on page 237

•

Colour on page 273

•

Scene Setup on page 483

•

Cut-out Animation on page 713

Timeline View

These are described later in this section.
1. Enable/Disable All on the next page
2. Show Selection and Hide All Others on page 74
3. Add Layers on page 74
4. Delete Layers on page 74
5. Add Drawing Layer on page 75
6. Add Peg on page 75
7. Show/Hide Data View on page 75
8. Current Drawing Displayed on page 75
9. Current Frame on page 76
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10. Split on page 76
11. Show/Hide Children on page 76
12. Show/Hide Functions on page 76
13. Change Track Colour on page 77
14. Lock/Unlock Layer on page 77
15. Onion Skin on page 78
16. Drawing Substitution on page 79
17. Keyframe Value on page 79
18. Zoom on page 80
19. Keyframe on page 80
20. Drawing Exposure on page 80
21. Symbol Exposure on page 80
22. Dragging and Pasting Modes on page 80

The Timeline view is the main view used when adjusting the timing of your drawings, connect effects and order
your layers. The Timeline view displays the following:
•

Layers

•

Effects

•

Sounds

•

Keyframe Values

•

Scene Length

•

Layer Names

•

Drawings

•

Keyframes

•

Timing

•

Frames

Enable/Disable All
The Enable/Disable All

button is used to show or hide all your layers simultaneously.

To disable a particular layer, uncheck the layer’s checkbox or press [D]

To enable a particular layer, place a checkmark (tick) the layer’s checkbox or press [A].
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When you disable a layer in the Timeline view, the corresponding column is hidden in the Xsheet
view. When a column is hidden in the Xsheet view, the corresponding layer is disabled in the
Timeline view.

Show Selection and Hide All Others

The Show Selection and Hide All Others

button is used to show only the currently selected layer in the

Timeline view and disable all the other layers.

Add Layers
The Add Layers

button is used to add new layers to the timeline. When you click on the Add Layers button, a

drop-down menu will appear displaying the layer types available. You can add several different types of layers:
•

Camera

•

Colour-Card

•

Drawing

•

Mask

•

Peg

•

Quadmap

•

Effect

Delete Layers
The Delete Layers

button is used to delete the currently selected layers in the Timeline view. When you click

on the Delete Layers button, a Confirm Delete dialog box appears. Click OK to delete the layers or Cancel to
stop the operation.
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Add Drawing Layer
The Add Drawing Layer

button is used to automatically add a new drawing layer to your timeline. By default,

the layer is named Drawing.

Add Peg
The Add Peg

button is used to add a peg layer to your timeline. There are several ways to use the Add Peg

button. Refer to Animation Paths on page 637 for more information about pegs and how to use them.

Show/Hide Data View
The Show/Hide Data View

button is used to display the current frame’s drawing exposure and keyframe

values corresponding to each individual layer.

Hidden Data View

Visible Data View

Current Drawing Displayed

The drawing selected in red represents the drawing currently displayed and is linked to play head position.
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Current Frame

The red play head represents the current frame displayed and marked in the Playback toolbar. If you slide the
play head to the left or the right it will scrub through your frames and update the Camera view display.

Split

The Split

button is used to split the Timeline view in two sections allowing you to see two different portions

of your Timeline view. This way, if your scene length is very long, you can see the beginning and the end at once.

Show/Hide Children

The Show/Hide Children

button is used to display the children layers of a parent layer. Once a layer is

parented to another layer, it is indented to the right and the Show/Hide Children button appears on the parent
layer allowing you to show or hide the child layer.

Show/Hide Functions

The Show/Hide Functions

button is used to display the functions embedded in each layer. The Functions are

the different position and intensity information used to remember a layer’s position, scale or rotation as well as

76

Toon Boom Animate 3 User Guide

an effect’s look on each frame. This information is stored on the function curves using keyframes. Refer to
Animation Paths on page 637 for more information about the function layers.

Change Track Colour

The Change Track Colour

button is used to change the colour of the exposed frames, this helps you to

quickly locate a layer in the Timeline view. Double-click on the swatch to open the picking window and choose a
new colour.

Lock/Unlock Layer

The Lock/Unlock Layer

button is used to prevent the selection or editing of a layer in the Camera view.

To select some of the layers without selecting others, in the Timeline view, lock the layers you do not want to
select.
In the top menu, there are a series of locking options. Select Animation > Lock > select one of the following
actions:
•

Lock
This option locks the currently selected element.

•

Unlock
This option unlocks the currently selected element.
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Lock All
This option locks all the elements in the Camera view.

•

Unlock All
This option unlocks all the elements in the Camera view.

•

Lock All Others
This option locks all the elements in the Camera view except the currently selected one.

You can display the locked drawings as outlines in the Camera view if you want to quickly find out which drawings
are locked.

To display locked drawings as outline:
1. In the top menu, select Edit > Preferences (Windows) or Animate > Preferences (Mac OS X).
2. In the Preferences panel, go to the Camera tab.
3. In the Tools section, enable the Show Locked Drawings As Outlines option.

Onion Skin

The Onion Skin

button is used to enable the Onion Skin option on a particular layer. If you want to see the

previous and next frames of a specific layer, go to the Timeline view and click on the Onion Skin button for that
particular layer. Blue arrows appear on both sides of the play head. Pull on these blue arrows to add more
frames to the onion skin display.
To activate the general Onion Skin preview, in the Tools toolbar, click on the Onion Skin
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Drawing Substitution
The Drawing Substitution

field is used to change the drawing exposed at the current frame. To access the

Drawing Substitution field, you must first expand the Data view by clicking on the Show/Hide Data View
button.

To change the current drawing either click and slide your cursor left or right when you see the hand

cursor,

or double-click on the drawing name and type a new value.

The drawing exposure will be changed for the entire block it is exposed, not just the current frame.

Keyframe Value

The Keyframe Value field is used to add, remove or modify a keyframe at the current frame. To access the
Keyframe Value field, you must first expand the Data view by clicking on the Show/Hide Data View
button.
•

To add a keyframe at the current frame, click on the Add Keyframe

button.

•

To remove an existing keyframe at the current frame, click on the Delete Keyframe

•

To change the current keyframe, either click and slide your cursor left or right when you see the hand

button.

cursor, or double-click on the keyframe value and directly type a new value.
•

To navigate through the existing keyframes, click on the Previous Keyframe

and the Next Keyframe

buttons.
•

To link your layer to an existing function or to create a new function, click on the Show Function Menu
button to display the drop-down Function menu.
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Refer to Modifying a Path in the Timeline View on page 672 to learn more about using the Data view
and the Keyframe Value field.

Zoom

The Zoom tool is used to increase or reduce the width of the frames in the Timeline view. Drag the cursor to the
right to increase the width or to the left to reduce it. You can also press [1] and [2].

Keyframe
A black square is displayed in the Timeline view when a keyframe exists. You are able to select these keyframes
and drag them wherever you want on the timeline. You can also copy, cut and delete them.
•

To delete a keyframe without deleting the drawing exposure, go to the Timeline view and select the
keyframe to be deleted and then select Animation > Delete Keyframes from the top menu.

When a parent layer is collapsed and a child layer contains a keyframe, a white square will be displayed.

Drawing Exposure

In the Timeline view, when a drawing is exposed, it is represented as a grey block. If the drawing is exposed for
several frames, the block is extended. When a second drawing is exposed, a new grey block is displayed.

‣ The exposure’s colour can be changed. To pick a new colour, double-click on the Change Track Colour
button in the corresponding layer.

Symbol Exposure

In the Timeline view, when a symbol is exposed it is represented as a small film frame. If the symbol is exposed
for several frames, the film frame is extended. When a second symbol’s frame is exposed, a new film frame is
displayed.

Dragging and Pasting Modes
As you animate you will find that you may reuse a lot of positions, drawings and keys. However, you may only
want to paste the drawings, or just the keys or maybe everything. There are different paste options available in
the Timeline view which will give you the maximum flexibility when reusing and pasting.
There are three different modes for pasting your selection:
•

Paste Mode: All Drawing Attributes
Pastes the drawing exposure and keyframes.
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•

Paste Mode: Keyframes Only
Pastes only the keyframes.

•

Paste Mode: Exposures Only
Pastes only the drawing exposure.

Refer to Copying and Pasting Animation on page 774

Related Topics
•

Timing on page 339

•

Character Building on page 553

•

Scene Setup on page 483

•

Animation Paths on page 637

•

Cut-out Animation on page 713

•

Effects on page 779

Menus
You can access the commands from the following menus:
•

Top Menu below

•

Quick Access Menu on the facing page

Top Menu

The top menu contains most of the commands. Depending on the view you are working in and the element,
some commands are available and others not. The top menu is always located at the very top of the user
interface.
The top menu contains the following categories:
•

File

•

Edit

•

View

•

Play

•

Insert

•

Scene

•

Drawing

•

Animation

•

Windows

•

Help
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In the Mac OS X version, there is a Animate category containing the following commands:
•

Preferences

•

About

•

Quit

Quick Access Menu

Each view has a Quick Access menu containing recurring actions. This menu is accessed by right-clicking
anywhere in the view.

Related Topics
•

Interface Highlights on page 63
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Colour View

1. Add Colour on the facing page
2. Remove Colour on the facing page
3. Add Texture on page 85
4. Set Current Brush Colour on page 85
5. Set Current Pencil Colour on page 85
6. Set Current Paint Colour on page 85
7. Link/Unlink Three Colours on page 85
8. Show/Hide Palette List View on page 86
9. Colour Swatch Name on page 86
10. Colour Swatch on page 86
11. Colour View Menu on page 87
The Colour View is where you create colours and palettes and import existing palettes into your project. The
Colour View is also necessary for drawing, painting and creating colour styling.
The Colour View has two display modes:
•

List Mode

•

Swatch Mode

To toggle between the display modes:
1. In the Colour View menu, select Colours > Swatch Mode.
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‣

Enable the option to display the swatches.

‣

Disable the option to display the colour list.

Interface Highlights

Add Colour
The Add Colour

button is used to add a colour swatch to your palette. Click on the Add Colour button to

add a new swatch to the bottom of your colour list.

Remove Colour
The Remove Colour

button is used to delete the currently selected colour swatches. If the colour swatch is

used in your project, the Delete Colour dialog box will pop and will ask you to confirm the operation.

‣ Click OK to confirm the operation or Cancel to cancel it.
Zones painted with colour swatches which have been deleted will turn red, easily identifying them so you can
repaint them with another colour swatch.
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Add Texture

The Add Texture

button is used to add a bitmap colour swatch to your palette. Use this to load photos and

textures and paint your drawings with it. The bitmap image must be a TGA or PSD file format.

Set Current Brush Colour
The Set Current Brush Colour
by the Brush

button is used to set the currently selected colour swatch as the colour used

tool. If you select a new colour in the Colour view while using the Brush tool, the Set Current

Brush Colour swatch will be updated.

Set Current Pencil Colour
The Set Current Pencil Colour
by the Pencil

, Polyline

button is used to set the currently selected colour swatch as the colour used
, Ellipse

, Rectangle

and Line

tools. If you select a new colour in the

Colour view while using any of these tools, the Set Current Pencil Colour swatch will be updated.

Set Current Paint Colour
The Set Current Paint Colour
the Brush

button is used to set the currently selected colour swatch as the colour used by

tool. If you select a new colour in the Colour view while using the Paint tool, the Set Current Paint

Colour swatch will be updated.

Link/Unlink Three Colours
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button is used to link the Set Current Brush Colour, Set Current Pencil

Colour and Set Current Paint Colour swatches to the currently selected colour swatches in the Colour view.

Show/Hide Palette List View

The Show/Hide Palette List View

button is used to display the Palette List view in the Colour view. This

option is for the advanced user who wants to create colour palettes for their props and characters.

Colour Swatch Name

Each colour swatch available in the Colour view can have its own name, making it easy to identify which colour is
used to paint what part of your character or background.

Two colours can have the same name.

Colour Swatch

A colour swatch is a specific colour used to paint a certain zone of a character or background. Colour palettes
are composed of colour swatches. They can also be called colour pots. When you paint a zone with a colour
swatch, the zone is linked to the swatch. So if you update the swatch’s tint, the zone will be updated along with
it. This allows you to modify your animation colours even after it is completely painted.
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Colour View Menu
The Colour View

menu allows you to access commands that are specifically related to the Colour view such

as creating new palettes, adding new colour swatches and displaying the Tint panel. The commands listed in the
Colour View menu can also be found following a similar path from the top menu categories Colours and Palettes.

Related Topics
•

Colours on page 276

Library View

1. Library View Menu on the facing page
2. Preview Window on the facing page
3. Preview Playback on the facing page
4. Library Folder List on the facing page
5. Template/Symbol List on the facing page
The Library view is used to store elements such as animation, drawings, backgrounds and puppets to reuse
them in your different projects. You also use the Library view to create and store your symbols.
To reuse an element in another project, you must create a template out of your drawings. A template is a mini
scene that you import in your other project. A template has no link to the original scene. When you create a
template, the full content of your selection is copied in the template.
When you are creating a series of layers all using the same drawings or building puppets, you will create
symbols. These can be used as drawing containers when you are creating puppets so that you can store different
mouth shapes or hands to use while animating. You can also use symbols when you are building props, such as a
skateboard and you want to use the same wheel drawing for the four skateboard wheels.

Refer to Library on page 521 to learn more about using the library, symbols and templates in context.
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Library View Menu
The Library View

menu allows you to access commands that are specifically related to the Library view such

as importing SWF movies and Illustrator files, adding a new folder and refreshing the library’s content.

Preview Window
The Preview window is used to see the content of the currently selected template or symbol in the
Template/Symbol list.

Preview Playback
The Preview Playback button is used to play back the content of the selected template or symbol if it contains
more than one frame. Press the Play
button to play back the preview.

Library Folder List
The Library Folder List displays all of the folders linked to the Library view. There are two default folders:
•

Symbols
The Symbols folder is the only folder containing symbols. The user can organize it by adding subfolders
inside.

•

Animate Library
The Animate Library folder is a default library found on the hard drive in the user’s documents. This folder
can contain templates, but no symbols.

The user can link new library folders to the Library view and organize them with subfolders.

Template/Symbol List
The Template/Symbol list displays the templates or symbols contained in the selected library folder. If you rightclick, you can display the templates and symbols’ thumbnails by selecting View > Thumbnails.

Related Topics
•

Library on page 521

Playback Toolbar

Use it to play back your animation and sound. Use it to scrub your sound to create your lip-sync, looping your
playback, navigating through your frames, change the playback range and speed.
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•

Click on the Play

button to play and stop the animation. You can also do this from the top menu by

selecting Play > Play Scene Forward or Stop.
•

Click on the Loop

button to repeat your playback indefinitely. Or do this from the top menu by

selecting Play > Loop.
•

Click on the Sound

button to enable sound in the playback. Or do this from the top menu by

selecting Play > Enable Sound.
•

Click on the Sound Scrubbing

button to enable sound scrubbing in the play back. Or do this from the

top menu by selecting Play > Enable Sound Scrubbing.
•

Click on the Render and Play

button to create a render of your scene to play back the final result

including the effects.
•

Scroll through the playback’s frames using the Jog Frames right and left arrows.

•

To change the playback frame range enter new values in the Start and Stop fields.

•

Enter a new value in the FPS field to change the speed of the playback.

Play Menu
Select any of the following from the top menu Play heading:
•

First Frame jumps to the first frame. You can also press [<].

•

Next Frame jumps to the frame after the currently selected frame in the Timeline view. You can also press
[.].

•

Last Frame jumps the last frame. You can also press [>].

•

Previous Frame jumps to the frame before the frame currently selected in the Timeline view. You can also
press [,].

•

Go to Frame or use the Go

button, which can be added to the Timeline View toolbar through the

Toolbar Manager. Open the Go to Frame dialog box so you can type in the frame number to jump to.
•

Enable Playback view from either the Top, Side or Perspective views.
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Managing the Views
The Toon Boom Animate user interface is composed of different views, each one designed for a specific
purpose. This section explains how you can modify the location and accessibility of the views by adding a new
view as a tab or as a window, you can also swap the view locations around.

Workspace modifications are automatically saved when you exit the application unless you disabled
the Automatically Save Workspace preference in the Preferences panel.

•

Adding a New View below

•

Closing a View on the next page

•

Swapping Views on the next page

•

Resizing a View on page 92

Adding a New View
To add a view:
1. Select the view you want to add from Windows > The desired view.

You can also use the Window drop-down menu button included in each view already available in the
workspace. Click on the button and select a view from the list. You can only open one instance of the
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same view. In other words, you cannot have two Camera views open at the same time.
You can open several instances of the same view except for the Timeline, Tool Properties, Colour and
Drawing views.

2. To dock a floating window in your workspace, drag the window’s tab onto one of the workspace’s views.

Closing a View
To close a view:
1. In the view to close, click on the Close View
‣

button.

If you have several tabs in the same window, hold [Shift] down and click on the Close View

button

to close all tabs together.

Swapping Views
With Animate, you can easily swap views around.
To swap views around:
1. Select the view tab and drag it onto one of the view’s separators, top area or onto another view’s tab.
2. When a rectangle outline appears showing an available location for the view, release the mouse button
and drop the view tab into position. One of three things will happen:
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•

1. The view becomes a tabbed window.

•

2. The view becomes a floating window.

•

3. The view becomes a new docked window.

Resizing a View

Resizing a View
To change the width and height of the views in the workspace, drag the side of the view.
To resize a view:
1. In the interface, position your cursor on the edge of the view you want to resize.
2. When you see the Resizing

cursor, click and drag the side of the window to the desired width or

height.

You can also temporarily hide a view to get more working space.
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To temporarily hide a view:
1. On the edge of the window you want to hide click on the Collapse/Expand button. The view is
compressed and only the Collapse/Expand button is visible.
2. Click on the same Collapse/Expand button to display the view again.

Related Topics
•

Managing the Toolbars on the facing page

•

Managing the Workspace on page 98
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Managing the Toolbars
The Toon Boom Animate user interface contains toolbars which, by default, are located at the top of the
interface. Some of the workspace’s views also have their own toolbars. These toolbars can be moved around.
You can reposition the toolbars to suit your work style or hide unused ones.
•

Showing or Hiding Toolbars below

•

Moving Toolbars on the next page

•

Flat Tool Toolbar Preference on the next page

•

Toolbar Manager on page 96

Showing or Hiding Toolbars
To show or hide a toolbar:

‣ Select Windows > Toolbars > the desired toolbar.
You may right-click anywhere in the toolbar area to access Toon Boom Animate toolbars. View toolbars,
however, are not available by right-clicking the toolbar area. You can access the toolbar of any open and active
view by right-clicking in the workspace area.

You may also hide a portion of a toolbar by dragging another open toolbar over its tail-end.
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The Toolbar menu only contains the View toolbars of the views that are open in the workspace. As
you show or hide views in your workspace, the Toolbar menu will update.

Moving Toolbars
To move a toolbar:
1. Select the toolbar you want to move by clicking on its anchor point

and dragging it into a view

toolbar area or another position in the top or side interface toolbar area.

2. When a rectangle outline appears showing an available location for the toolbar, release the mouse button
and drop the toolbar into position.

‣

1. Dock to the top toolbar area.

‣

2. Move a toolbar down a row.

‣

3. Dock to the left toolbar area.

Flat Tool Toolbar Preference
By checking on this option you can expand the toolbar so that there are no nested toolsets in the toolbar. When
you check this option you will need to close Animate and relaunch it for the new interface to be displayed. A
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default set of tools will appear in the toolbar. However, you can customize which tool icons appear in the toolbar
to fit your own work pattern.

To use the Flat Tool Toolbar:
1. Open the Preferences window, Edit > Preferences (Windows) or Animate > Preferences (Mac OS X)
and click on the General tab.
2. Enable the Flat Tool Toolbar preference by clicking on its checkbox.
3. Click on the OK button to apply the change.
4. Save your work and close Toon Boom Animate.
5. Relaunch Toon Boom Animate. You will notice that the Tools toolbar has changed and no longer contains
nested tools.
If the default toolbar does not contain the tools you require, you can custom-build the toolbar.
Once you have enabled the Flat Tool Toolbar preference, you can customize the tools which appear in the
toolbar. This means that you can change the default set of tools and replace the tools which you use less
frequently with ones which are used more often. This customizing is done through the Toolbar Manager.

Toolbar Manager
The View toolbars can be customized to contain your favourite tools and options. Use the Toolbar Manager
window to organize your different toolbars to suit your working preferences.
To customize your toolbars:
1. In the chosen view,right-click on any button in the toolbar where you wish to add or subtract a new
button.
2. From the pop-up menu, select Customize.

The Toolbar Manager window opens.
3. To add a new icon to your toolbar, select the tool or command from the Available Tools list and click on
the Right Arrow
button to switch it to the Toolbar list.
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4. To remove an icon from your toolbar, select the tool or command in the Toolbar list and click on the Left
Arrow
button to switch to the Available Tools list.

5. To reorder your icons in your toolbar, select the command to be moved in the Toolbar list and click on the
Up
or Down
buttons to move it to the correct location.

6. Click on the OK button when you are finished.

Related Topics
•

Managing the Workspace on the facing page

•

Managing the Views on page 90
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Managing the Workspace
Toon Boom Animate’s user interface is composed of several views. You can customize your workspace to suit
your working preferences, save it as a new workspace, and load it from the Workspace toolbar.
•

Loading a Workspace below

•

Workspace Manager below

•

Restoring the Default Workspaces on page 102

Loading a Workspace
The first time you open Toon Boom Animate, the default workspace is loaded. Other workspaces are available
such as the Hand-Drawn Animation and the Compositing workspaces, these display different views and
toolbars. You can access these workspaces and any you create, from the Windows menu and the Workspace
toolbar.
To load a workspace:
1. In the top menu, select Windows > Workspace > Workspace or click on the drop-down arrow in the
Workspace toolbar and select a workspace from the list.

Workspace Manager

To open the Workspace Manager:
‣

In the Workspace toolbar, click on the

‣

In the top menu select Windows > Workspace > Workspace Manager.

button.

The Workspace Manager allows you to modify, create, delete, rename and reorder you workspaces.
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•

Creating a New Workspace below

•

Renaming a Workspace on the facing page

•

Saving a Workspace on the facing page

•

Deleting a Workspace on page 101

•

Showing and Hiding a Workspace on page 101

•

Reordering the Workspace List on page 102

Creating a New Workspace
To create a new workspace:
1. Open the Workspace Manager.
2. In the Available Workspaces list, select an existing workspace.

3. At the bottom of the Available Workspaces list, click on the Add

button to add a workspace.

4. Select the new workspace option, then click on the Rename button and give it a new name.

5. Select the new workspace and click on the Right Arrow

6. Click on the OK button.
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Renaming a Workspace
To rename a workspace:
1. Open the Workspace Manager.
2. Choose the workspace to be renamed from the list.
3. Double-click on the workspace to be renamed or click on the Rename button. This allows you to edit the
name.

4. Type in the new name of the workspace.
5. Press the [Enter/Return] key to validate the name.
6. Click on the OK button.

Saving a Workspace
By default, when you modify the look of a workspace, it is automatically saved. If you prefer to keep your
workspaces as they are and only save the modifications when you really want to, you have to disable the
Automatically Save Workspace preference.
To disable the Automatically Save Workspace preference:
1. In the top menu, select Edit > Preferences (Windows) or Animate > Preferences (Mac OS X) to open
the Preferences panel.
2. Go to the General tab.
3. In the Save section, disable the Automatically Save Workspace preference.

4. Press the OK button.
The Save Workspace

button appears in the Workspace toolbar.

To save a workspace manually:
1. In the Workspace toolbar, click on the Save Workspace

button.

You can also select Windows > Workspace > Save Workspace.
You can save your workspace as a new version to avoid over-writing the current one.
To save your workspace as a new version:
1. Select Windows > Workspace > Save Workspace As.
The Save Workspace As dialog box opens.
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2. In the text field, enter the new workspace name.
3. Click on the OK button to validate.

Deleting a Workspace
To delete a workspace:
1. Open the Workspace Manager.
2. In the Workspace Manager, select the workspace to be deleted and click on the Left Arrow

button

to send it to the Available Workspaces list.

3. Select the workspace in the Available Workspaces list then click on the Delete

button to delete the

workspace.
4. Click on the OK button.

Showing and Hiding a Workspace
To show a workspace:
1. Open the Workspace Manager.
2. In the Available Workspaces list, select the workspace to be displayed and click on the Right Arrow
button to send it to the Workspace toolbar.
3. Click on the OK button.
To hide a workspace:
1. Open the Workspace Manager.
2. In the Workspace Manager, select the workspace to be hidden and click on the Left Arrow
send it to the Available Workspaces list.
3. Click on the OK button.
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If you do not want to modify the current workspace, use the Workspace Manager to create another one and
then modify that one.

Reordering the Workspace List
To reorder workspaces:
1. Open the Workspace Manager.
2. In the Workspace toolbar, select the workspace to be reordered and click on the Up
buttons to move it up or down.

3. Click on the OK button.

Restoring the Default Workspaces
You can restore modified workspaces to their original default layout.
To restore the default workspaces:

‣ In the top menu select Windows > Restore Default Workspace.
Related Topics
•

Managing the Views on page 90

•

Managing the Toolbars on page 94
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Interface Navigation
Toon Boom Animate supports zoom in, zoom out, rotate, pan and reset view position for easy interface
navigation.
•

Zoom In: Zooms into the view. From the top menu, select View > Zoom In or press [2].

•

Zoom Out: Zooms out of the view. From the top menu, select View > Zoom Out or press [1].

•

To zoom in and zoom out, hold down [Spacebar] and your middle mouse button while moving the mouse
up or down.

•

To pan the view, hold down the keyboard shortcut [Spacebar] and drag your mouse in the direction you
want to pan the view.

•

To Recentre the view: recentres the view on your mouse cursor or press [N].

•

Reset View: Resets the view to its default position. From the top menu, select View > Reset View or
press [Shift] + [M].

•

Reset Rotation: Resets the view’s rotation to its default position. From the top menu, select View >
Reset Rotationor press [Shift] + [X].

•

Reset Pan: Resets the view’s pan to its default position. From the top menu, select View > Reset Pan or
press [Shift] + [N].

•

Reset Zoom: Resets the view’s zoom to its default position. From the top menu, select View > Reset
Zoom.

•

Toggle Full Screen: Enlarges the selected view to full screen. The full screen process is done in three
stages. From the top menu, select View > Toggle Full Screen or press [Ctrl] + [F] (Windows) or [⌘ ] + [F]
(Mac OS X).
•

First, the selected view enlarges to the maximum width or height, but keeps the tool views such as
Colour or Tool Properties view.

•

Second, the view enlarges to full screen.

•

Third, the view returns to its original size.

•

Rotate 90 CW: Rotates the Camera view 90 degrees clockwise, like an animation table. From the top
menu, select View > Rotate View CW.

•

Rotate 90 CCW: Rotates the Camera view 90 degrees counter-clockwise, like an animation table. From
the top menu, select View > Rotate View CCW.

Related Topics
•

Zoom below

Zoom
From the Tools toolbar, use the Zoom

tool to zoom in and zoom out in the Camera or Drawing view.

•

The keyboard shortcuts are [1] and [2].

•

When the Zoom In mode is selected, hold [Alt] as you click to zoom out.
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Zoom Tool Properties
When you select the Zoom tool, its properties are displayed in the Tool Properties view.

Zoom In
Enable the Zoom In

mode in the Options section to zoom in when using the Zoom tool.

Zoom Out
Enable the Zoom Out

mode in the Options section to zoom out when using the Zoom tool.

Perform Zoom In
Use the Zoom In
•

operation to perform a zoom in the Camera or Drawing view.

The keyboard shortcut is [2].

Perform Zoom Out
Use the Zoom Out
•

operation to perform a zoom out in the Camera or Drawing view.

The keyboard shortcut is [1].

Reset Zoom
Use the Reset Zoom

operation to restore the current zoom level to 100%.

Reset View
The Reset View

restores the original display by resetting pan, rotation or zoom actions.

Related Topics
•

Interface Navigation on the previous page

•

Zoom on page 235
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Interface Preferences
Adjusting preferences to suit your work style allows you to work more efficiently.

To open the Preferences panel:
‣

Windows: Select Edit > Preferences.

‣

Mac OS X: Select Animate > Preferences.

‣

Press [Ctrl] + [U] (Windows) or [⌘ ] + [U] (Mac OS X).

In the Preferences panel, you will find the preference related to the interface in the Camera, OpenGL and General
tab.

Related Topics
•

User Interface Preferences - General Tab below

•

User Interface Preferences - Camera Tab on page 109

•

Full Scene Antialiasing Preference in the OpenGL tab on page 109

User Interface Preferences - General Tab
To customize your interface, you will use some of the preferences located in the General tab as well as the
Camera tab.

Automatically Save Workspace
The Automatically Save Workspace preference is enabled by default. Every time you add a view to your
workspace, remove a toolbar or change a view’s width, these modifications are saved when you quit the
application. If you do not want the system to save these modifications, disable the preference.
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This preference does not require you to restart the application.

Refer to the Managing the Workspace on page 98 section to learn more about this preference.

Focus on Mouse Enter
The Focus on Mouse Enter preference is disabled by default.
In Toon Boom Animate, for the operations or keyboard shortcuts to work in the view in which you are working,
the focus must be in that view. When the focus is on a particular view, a red rectangle appears around its frame.
You must click in the view or on the view’s header for the focus to be done.
If you enable the Focus on Mouse Enter preference, you will not need to click in the view to get the focus. It will
be done as soon as your mouse enters the view.
This preference does not require you to restart the application.

If you enable the Focus On Mouse Enter preference, certain operations from the top menu may not
be available since the view focus may change as you make your way to the top menu. In this case use
keyboard shortcuts and quick access menus (right-click menus).

Flat Tool Toolbar
By checking on this option you can expand the toolbar so that there are no nested toolsets in the toolbar. When
you check this option you will need to close Animate and relaunch it for the new interface to be displayed. A
default set of tools will appear in the toolbar. However, you can customize which tool icons appear in the toolbar
to fit your own work pattern.

Once you have enabled the Flat Tool Toolbar preference, you can customize the tools which appear in the
toolbar. This means that you can change the default set of tools and replace the tools which you use less
frequently with ones which are used more often. This customizing is done through the Toolbar Manager.
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To customize the toolbars refer to Toolbar Manager on page 96.

Levels of Undo
The Levels of Undo preference determines the number of actions retained by the Undo list. By default, 50 actions
are stored in the list. You can alter the number if you want to.
This preference does not require you to restart the application.

Colours
The Colours preference allows you to modify the colours of the different user interface views and elements. For
example, you can change the Camera view’s background colour from grey to white.
Altering these preferences requires you to restart the application or to close a view and reopen it for the
modifications to be applied.

Current View Border
The Current View Border preference sets the colour of the frame around the workspace view you are currently
using, also known as focus. By default, the colour is red. Click on the red colour swatch to select a new colour in
the Colour Picker window.

Current View Border in Template Edit
The Current View Border preference sets the colour of the frame around the workspace view you are currently
using when editing a template from your library view. By default, the colour is green. Click on the green colour
swatch to select a new colour in the Colour Picker window.

Edit Colours Button
Click on the Edit Colours button to open the Colours window.
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In the Colours window, you can modify any of the colours from the list. Most of the modifications will require you
to restart the application or close the view and reopen it to see them.
•

To restore all of the default interface’s colours, click on the Restore All Defaults button.

The Colours window is divided into the following categories:
•

Camera

•

Network

•

Exposure Sheet

•

Drawing

Click on any of the colour swatches and select a new colour from the Colour Picker window.
•

•

Onion Skin
•

Onion Skin After: Changes the colour display of the next drawing when using the Onion Skin feature.

•

Onion Skin Before: Changes the colour display of the previous drawing when using the Onion Skin
feature.

Others
•

Background: Changes the background colour of the Drawing and Model view.

•

Backlight: Changes the display colour of the Backlight option.

•

Grid: Changes the display colour of the grid when using the Show Grid option.

•

Colour View Background: Changes the background colour of the colour list area of the Colour view.

•

Colour Highlight Mode Opacity: Changes the opacity value of the washed out art when using the
Highlight Selected Colour option.

To restore all of the default interface’s colours, click on the Restore All Defaults button.
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Related Topics
•

User Interface Preferences - Camera Tab below

•

Full Scene Antialiasing Preference in the OpenGL tab below

User Interface Preferences - Camera Tab

Zoom Settings
In the Zoom Settings section, you can change the Camera View Default Zoom value from the drop-down menu.
This selection sets the Reset View value in the Camera, Top and Side views.

Related Topics
•

User Interface Preferences - General Tab on page 105

•

Full Scene Antialiasing Preference in the OpenGL tab below

Full Scene Antialiasing Preference in the OpenGL tab
The Full Scene Antialiasing is generated by your computer’s graphic card it provides a smooth line display in
OpenGL. This antialiasing will not only antialias your drawings but all your different views in the interface.
This preference can be turned on or off, Full Scene Antialiasing preference is disabled by default.
This option lets you see smooth lines as you draw as well as an antialiased drawing area. You can change the
value of the Full Scene Antialiasing using the Preferences dialog box to fit the current level used in the Camera or
Drawing view.
To use Full Scene Antialiasing do the following:
1. Full Scene Antialiasing is accessible from Edit > Preferences > OpenGL tab (Windows) or Animate >
Preferences > OpenGL tab (Mac OS X), go to the Full Scene Antialiasing section.
‣

Enable: Click on the Enable check box to turn on Full Scene Antialiasing. To disable it uncheck the box.

‣

Number or samples (For Mac OS): If you are using a Mac computer;

You must enter the number of samples you want to be used for the antialiasing process. the number of
samples is basically equivalent to the amount of time a pixel will be enlarged to calculate the antialiasing.
This technique is called supersampling. The higher the number of samples, the better the antialiasing
quality will be, but the longer it will take to calculate. The recommended value is 4.
2. Once done, you must restart Toon Boom Animate.
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If you are using Windows or Linux, you must enable your graphic card’s antialiasing parameter. Refer
to your graphics card manufacturers user guide to learn how to do so. For example, the parameters
for an NVIDIA GeForce card may look like this:

Related Topics
•

User Interface Preferences - Camera Tab on the previous page

•

User Interface Preferences - General Tab on page 105
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Chapter 4: Drawing

In Toon Boom Animate, many powerful tools, views and features are available so you can design, draw and
animate with ease. This chapter explains the main assets needed when drawing and animating in the software as
well as tips on how to start and use these tools efficiently.

Topics Covered
•

How to Draw on page 113

•

Tool Properties View on page 114

•

Drawing View on page 115

•

Camera View on page 118

•

Drawing with the Brush or the Pencil on page 123

•

Working with Tool Presets on page 125

•

Viewing the Final Lines as you Draw on page 128

•

Drawing Using the Pencil Tool on page 130

•

Drawing with the Brush Tool on page 146

•

Drawing with Line Texture on page 155

•

Selecting Drawing Objects on page 162

•

Erasing Parts of a Drawing on page 177

•

Reshaping a Drawing Using the Contour Editor Tool on page 181

•

Reshaping Pencil Lines with the Pencil Editor Tool on page 187

111

Chapter 4: Drawing

•

Drawing with Shapes on page 193

•

Drawing with the Polyline Tool on page 200

•

Drawing Using Invisible Lines on page 204

•

Deforming a Drawing Using the Perspective Tool on page 207

•

Cutting Drawing Parts on page 211

•

Smoothing Lines on page 215

•

Working With Text on page 219

•

Override Tool on page 224

•

More Drawing Tools on page 225

•

Drawing Pivot Tool on page 231

•

Drawing Preferences on page 233
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How to Draw
As soon as Toon Boom Animate is started, you can start to draw straight away using the default drawing layer.
How to draw:
1. In the Tools toolbar, select the Brush

tool or press [Alt] + [B].

2. In the Timeline or Xsheet view, click in the first cell of the drawing layer.

3. In the Drawing or Camera view, start drawing.

4. To select a different colour, in the Colour view, select the a different colour swatch. Double-click on the
colour swatch to open the Colour Picker window and modify the colour. Remember that anything already
painted with that colour swatch will update to the new colour.

Related Topics
•

Adding a Colour Swatch on page 276

•

Adding New Drawing Layers on page 360

•

Tool Properties View on the facing page
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Tool Properties View
The Tool Properties view is where you can customize the currently selected tool. The options and operations
displayed changes according to each tool you select.

Options
Options are different modes you can apply to a selected tool to modify its behaviour to fit the current task’s
needs.

Operations
Operations are actual actions you can perform while using the selected tool.

Related Topics
•

How to Draw on the previous page
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Drawing View
In Toon Boom Animate, you can draw in the Drawing or Camera view. Although the two views are similar, when
it comes to drawing, there are some differences.
Only the selected drawing is displayed by default in the Drawing view. You can use features, such as the light
table to display the current frame drawing of all the enabled layers of your scene in washed-out colours, or the
Onion Skin to display the previous and next drawings of the currently selected drawing layer.

1. Drawing Area below
2. Drawing Name on the facing page
3. Tool Name on the facing page
4. Current Frame on the facing page
5. Cursor Coordinates on the facing page
6. Colour Picker on page 117

Drawing Area
This is the Drawing view’s main space, it is where you draw, and where the drawings are displayed.

Zoom Drop-down Menu
The Zoom menu lets you enlarge or reduce the Camera or Drawing view display.
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To make the camera frame size always match the size of your view, select the Fit to View option.
Click the drop-down arrow and select a zoom level or press [1] and [2].

Overlay, Line Art, Colour Art, Underlay and Preview
Mode
•

Line Art: Switches to the Line Art layer of the drawing. The default keyboard shortcut is [L].
You can display the Line Art view in the Preferences dialog box. Select Edit > Preferences ( Windows) or
Animate > Preferences ( Mac OS X). Select the General tab. In the Advanced box, select the Use
Advanced Art Mode option and restart the application.

•

Colour Art: Switches to the Colour Art layer of the drawing. The default keyboard shortcut is [L].

•

Preview mode: Switches to Preview mode, so you can see both Line Art and Colour Art layers
simultaneously. The default keyboard shortcut is [Shift] + [P].
You can display the Line Art view in the Preferences dialog box. Select Edit > Preferences ( Windows) or
Animate > Preferences ( Mac OS X). Select the General tab. In the Advanced box, select the Use
Advanced Art Mode option and restart the application.

Drawing Name
The Drawing Name field displays the name of the selected drawing, as well as the layer containing it. If the cell
does not contain any drawing, an Empty Cell text is shown in the field.

Tool Name
The Tool Name field displays the name of the selected tool. If you override a tool using an overriding keyboard
shortcut, the tool’s name will be highlighted in red letters—see Override Tool on page 224 to learn how to
temporarily override a tool.

Current Frame
This field displays the current frame of the animation you are working on.

Cursor Coordinates
This indicates the position of your mouse cursor in the drawing area.

116

Toon Boom Animate 3 User Guide

Drawing Name
Displays the name of the currently selected drawing.

Colour Picker
The Colour Picker allows you to select a colour to draw with.

Related Topics
•

Camera View on the facing page
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Camera View
In Toon Boom Animate, you can draw in either the Drawing view or Camera view. Although the two views are
similar, when it comes to drawing, there are some differences.

1. Zoom Drop-down Menu on the next page
2. Overlay, Line Art, Colour Art, Underlay and Preview Mode on page 120
3. Drawing Name on page 120
4. Tool Name on page 120
5. Current Frame on page 120
6. Current Colour on page 121

For more details about the Camera view's interface, see Camera View on page 64

In the Camera view, you can use the Onion Skin feature to display previous and next drawings. By default, all the
enabled drawing layers in the selected frame are displayed, letting you edit them together. This way, you can use
the Select
tool to select many objects from individual layers at once.
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To make easier to select objects on a single drawing, you can set a preference. Select Edit >
Preferences and select the Camera tab, then select the Select tool Works on Single Drawing
option.

To enable the onion skin from the Timeline view:

‣ In the Timeline view, click the Onion Skin

icon of the desired layer.

By locking a layer, you can prevent yourself from being able to select it in the Camera view, while keeping the
drawing visible as a reference and disabling the layers you don’t want to display in the Camera view.
To lock a drawing layer:

‣ In the Timeline view, click the Lock

icon of the layer you don’t want to edit.

To hide a drawing layer:
1. In the Timeline view, click the check box corresponding to the layer you want to hide.

Zoom Drop-down Menu
The Zoom menu lets you enlarge or reduce the Camera or Drawing view display.

To make the camera frame size always match the size of your view, select the Fit to View option.
Click the drop-down arrow and select a zoom level or press [1] and [2].
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Overlay, Line Art, Colour Art, Underlay and Preview
Mode
•

Line Art: Switches to the Line Art layer of the drawing. The default keyboard shortcut is [L].
You can display the Line Art view in the Preferences dialog box. Select Edit > Preferences ( Windows) or
Animate > Preferences ( Mac OS X). Select the General tab. In the Advanced box, select the Use
Advanced Art Mode option and restart the application.

•

Colour Art: Switches to the Colour Art layer of the drawing. The default keyboard shortcut is [L].

•

Preview mode: Switches to Preview mode, so you can see both Line Art and Colour Art layers
simultaneously. The default keyboard shortcut is [Shift] + [P].
You can display the Line Art view in the Preferences dialog box. Select Edit > Preferences ( Windows) or
Animate > Preferences ( Mac OS X). Select the General tab. In the Advanced box, select the Use
Advanced Art Mode option and restart the application.

To activate the Preview Mode button in the Camera view bottom toolbar, you must enable the
Current Drawing on Top option.

To enable the Current Drawing On Top option:
1.

In the Camera bottom toolbar, click on the Camera Option button.

2.

In the drop-down menu, enable the Current Drawing on Top option.

See Show Current Drawing on Top on the next page.

Drawing Name
The Drawing Name field displays the name of the selected drawing, as well as the layer containing it. If the cell
does not contain any drawing, an Empty Cell text is shown in the field.

Tool Name
The Tool Name field displays the name of the selected tool. If you override a tool using an overriding keyboard
shortcut, the tool’s name will be highlighted in red letters—see Override Tool on page 224 to learn how to
temporarily override a tool.

Current Frame
This field displays the current displayed frame of the animation.
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Current Colour
This field displays the current colour name and its colour swatch. You can open the Colour Picker by doubleclicking the colour swatch—see Colour on page 273.

Related Topics
•

Show Current Drawing on Top below

•

Drawing View on page 115

Show Current Drawing on Top
In Toon Boom Animate, when you draw on a layer, the artwork is displayed in the correct order. For example, if
the layer on which you are drawing is located behind an object on another layer, the lines you are drawing will be
hidden behind that object.

This option lets you display the selected drawing on top of everything while your draw. By enabling this option,
each time you select a drawing tool, the selected drawing is displayed in front of everything in the Camera view.
The Timeline and Network view ordering remain unchanged.

The Show Current Drawing on Top status (enabled or disabled) is remembered when you exit
Animate. When you restart the application, the last status will be used.

To display your drawing on top:
1. Do one of the following:
2. From the top menu, select View > Show > Current Drawing on Top.
3. In the Camera toolbar, click the Camera Option button and select the Current Drawing on Top option.
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4. In the Tools toolbar, select a drawing tool.
5. In the Camera view, start drawing.

You only need to enable this option once, it is not necessary to do it each time you select a drawing
tool.

Related Topics
•

Camera View on page 118

•

How to Draw on page 113
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Drawing with the Brush or the Pencil

The Brush

and Pencil

tools are used to draw and sketch with. Both tools support pressure sensitivity,

allowing you to create lines with variable thickness. The Pencil and shape tools produce central vector lines. The
Brush tool produces contour vector lines. This means that a pencil line’s control points (used to deform its
shape) are located along the length of the central spine and the Brush line’s control points are located along the
contour.
•

If you draw with the Pencil tool and want to modify the thickness variation, use the Pencil Editor

•

If you draw with the Brush tool and want to modify the thickness, use the Contour Editor

•

You can also convert a brush zone into a pencil line with the Brush Stroke to Pencil Line

tool.

tool.
option.

If you sketch a drawing using a semi-transparent colour to get a paper-like feel, you should use the Brush tool as
it produces a more realistic and natural feel. The pencil line is very useful for tracing, clean or final drawings.

Also, it is recommended to use brush lines when designing cut-out puppets’ articulations which use patches.
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Related Topics
•

Drawing Using the Pencil Tool on page 130

•

Drawing with the Brush Tool on page 146

•

Reshaping a Drawing Using the Contour Editor Tool on page 181

•

Drawing with Shapes on page 193

•

How to Draw on page 113
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Working with Tool Presets
Tools presets let you saving a variety of settings and are very handy and efficient for accessing the tools you use
most often. That way, the tool is already set with the desired properties, such as colour, line thickness, whether
to enable Draw Behind or Auto Flatten mode, and so on. You can create presets for these tools and many more:
Brush, Pencil, Eraser, Rectangle, Ellipse, and Line. First, select a tool, adjust the properties, and then create a
tool preset for it. Once you have created a tool preset, you can always make adjustments to fine-tune it, as well
as create a keyboard shortcut for it.

The Tool Presets Toolbar
The Tool Presets toolbar lets you create new tool presets and manage them. There are four default brush
presets to get you started—Rough Brush, Clean Pencil, Fill Paint, and Inking Brush. Be default, this toolbar is not
displayed.
To display the Tool Presets toolbar:
‣

Select Windows > Toolbars > Tool Presets.

‣

Right-click an empty area below the top menu and select Tool Presets.

To create a tool preset:
1. In the Tools toolbar, select a tool.
2. In the Panel view, use the Tool Properties view and/or the Brush Properties window to customize the
tool.Use the Tool Properties view to customize the tool.
3. In the Tool Presets toolbar, click the New Tool Preset

button.

4. In the New Tool Preset dialog box, type a new name for your tool.
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5. From the Brush list, select an icon to quickly identify your preset or upload your own by clicking the File
button.

6. (Optional) Set a keyboard shortcut to quickly access your preset.
7. When you select any of the following options, they will take effect when you use the tool preset. If an
option is deselected, then using a tool preset will not override your current settings.
‣

Colour: Saves the current colour into the Tool Preset.

To delete a tool preset:
1. In the Tool Presets toolbar, click the Manage Tool Presets

button.

2. From the list of tool presets on the left, select a preset to delete and click the Trash
To import a tool preset:
1. In the Tool Presets toolbar, click the Manage Tool Presets

button.

2. In the Manage Tool Presets dialog box that opens, click Import.
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3. In the Import Brush Presets window that opens, locate and select the preset(s) to import and click
Open.In the Select Folder window that opens, locate and select the preset(s) to import and click Select
Folder.
To export a tool preset:
1. In the Tool Presets toolbar, click the Manage Tool Presets

button.

2. In the Manage Tool Presets dialog box that opens, click Export.

3. In the Export Brush Presets window that opens, click Export.
4. Select a folder and click Select Folder.
To update a tool preset:
1. In the Tool Presets toolbar, click the Manage Tool Presets

button.

2. In the Manage Tool Presets dialog box that opens, select the tool preset from the left side of the dialog
box.
3. Make any changes you would like to the preset.
4. Click Update.
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Viewing the Final Lines as you Draw

Everything you draw in Toon Boom Animate is vector-based. Although, when you draw in the Camera or
Drawing view, you will notice that your lines may be jagged, this is caused by the fast real-time display called
OpenGL.
If you prefer to see smooth lines as you draw, you can enable the antialiasing.

Full Scene Antialiasing
Not available in Harmony Paint.
The Full Scene Antialiasing is generated by your computer’s graphics card. This antialiasing will not only antialias
your drawings, but all your different views in the interface.
Full Scene Antialiasing is a preference you can turn on and off. By default, the Full Scene Antialiasing preference is
disabled.

Full Scene Antialiasing parameters are only valid while you work in your scene. The scene will be
rendered out to 100% of its resolution regardless of your settings in the preferences or graphic card
panel.

To customize the full scene antialiasing parameters:

This procedure requires that if you have a Mac OS you must restart the Animate after you have
changed the parameters.

1. If you are using Windows or Linux, you must enable your graphic card’s antialiasing parameter. Refer to
your graphics card manufacturers user guide to learn how to do so. For example, the parameters for an
NVIDIA GeForce card may look like this:
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2. In the Animate, do one of the following:
‣

Windows: Select Edit > Preferences.

‣

Mac OS X: Animate > Preferences.

‣

Press [Ctrl] + [U] (Windows) or [⌘ ] + [U] (Mac OS X).

The Preferences dialog box opens.
3. In the OpenGL tab, go to the Full Scene Antialiasing section.

‣

Enable: Select this option to enable/disable the Full Scene Antialiasing.

‣

Number or samples (For Mac OS): If you are using a Mac OS X computer, enter the number of
samples you want to be used for the antialiasing process. The number of samples is basically
equivalent to the amount of time a pixel will be enlarged to calculate the antialiasing. This technique is
called supersampling. The higher the number of samples, the better the antialiasing quality will be, but
the longer it will take to calculate.

4. Restart the Animate.
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Drawing Using the Pencil Tool

The Pencil

tool creates a centreline shape. Pencil lines now support pressure sensitivity and texture.

To draw with the Pencil tool:
In the Timeline or Xsheet view, select the cell on which you want to draw.
In Harmony Paint, select a drawing in the Drawing panel.

1. In the Tools toolbar, select the Pencil

tool or press [Alt] + [/].

2. In the Colour view, click a colour swatch to select a colour.

3. In the Drawing or Camera view, start drawing.
‣

When you get close to an existing pencil line, hold [Alt] to draw connect your stroke to the existing
one. Pencil lines are central vector lines and you might think your line is connected, but in fact, only the
contour is touching the other one. Also, make sure the central vector crosses the other one.
You can use the [Alt] key to connect the start of your stroke or the end of it by holding it when you
start drawing or when you finish your line.

‣

To draw a straight line, press [Shift] + [Alt] as you draw.
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Related Topics
•

Pencil Tool Options below

•

Drawing with the Brush or the Pencil on page 123

•

Drawing with Shapes on page 193

Pencil Tool Options
When you select the Pencil

tool, its properties and options appears in the Tool Properties view.

These are the options available for the Pencil tool:
•

Draw Behind on the facing page

•

Pencil Tool Options above
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•

Auto-Flatten Mode below

•

Auto-Close Gap on the next page

•

Line Building Mode on the next page

•

Auto Adjust Thickness on page 134

•

Line Pushing Mode on page 135

•

Pencil Thickness Stencils on page 135

•

Minimum and Maximum Size on page 135

•

Central Line Smoothness on page 136

•

Contour Optimization on page 136

•

Changing the Line Shape on page 136

•

Previewing the Stroke on page 137

•

Pencil Line Texture on page 137

Draw Behind

When drawing on vector layers, the Draw Behind mode lets you paint behind existing art. By default, strokes will
appear over your work until you release the tool. If you want to have live preview of your stroke in draw behind
mode, you must activate the Realistic Preview option.

Auto-Flatten Mode
When drawing on vector layers, lines do not usually become one object. The Auto-Flatten mode automatically
merges lines created with the existing ones into one single object as you draw.

Using the Select tool, you can use the middle mouse button to select a segment of a flattened pencil
line to create a nice finish on the lines and corners of your artwork.
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Auto-Close Gap

When using the pencil tool, you can automatically close strokes with an invisible stroke.
It is recommended to keep this option enabled when drawing with the Pencil tool.

Line Building Mode

The Line Building

mode is very useful when drawing long lines and curves in small increments with pencil

lines. As the pencil lines are central vector lines and it may be difficult to align the line tips perfectly to create a
uniform stroke and close all gaps.
In this mode, you can draw lines in small increments and the tip are merge into one single stroke.

This mode only works with pencil lines.
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Auto Adjust Thickness

The Auto Adjust Thickness

tool is useful when you want to render a portion of a line thicker. When tracing a

drawing on paper, you will often go back to a section of a curve to make it thicker to add dynamism to the line.
Using the Auto Adjust Thickness tool, you can draw highlight strokes over the section to make thicker. Once you
release the pen or the mouse, the line gets thicker following the shape and curve of the original stroke. This way
is much faster and smoother than using the Pencil Editor tool. You do not have to add extra points and adjust
the position and Bezier handles.
The default overlay colour is light yellow. If this colour is difficult to see because of your background or drawing
colour, you can adjust the colour.
To change the Auto Adjust Thickness Colour:
1. In the Tools toolbar, select the Pencil

tool.

2. In the Tool Properties view, select the Auto Adjust Thickness
3. Click the colour swatch.

The Colour Picker window opens.
4. In the Colour Picker window, select a new colour.
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Line Pushing Mode

The Line Pushing Mode

option lets you draw highlight strokes over your existing pencil lines. You can

reshape the curves. Depending how you draw the pushing stroke over your line, the highlighted section will be
reshaped in one direction or the other.
The default overlay colour is light yellow. If this colour is difficult to see because of your background or drawing
colour, you can adjust the colour.
To change the Line Pushing Mode colour:
1. In the Tools toolbar, select the Pencil

tool.

2. In the Tool Properties view, select the Line Pushing Mode

button.

3. Click the colour swatch.

The Colour Picker window opens.
4. In the Colour Picker window, select a new colour.

Pencil Thickness Stencils
Toon Boom Animate provides a variety of thickness stencils and also lets you create and save your own. It is a
good idea to create and save pencils with precise sizes and parameters when you draw and design.
A thickness stencil saves a preset of how the thickness information looks across the length of the line. When
drawing wtih a thickness stencil, the pressure sensitivity of the tablet is discarded in order to apply the thickness
stencil.
A thickness stencil can be used while drawing, or applied afterwards.
You also have the possibility to apply different textures to your lines by either using the preset ones or importing
your own—see Working with Thickness Stencils on page 137

Minimum and Maximum Size
This is where you set the minimum and maximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.
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1. Minimum Size field: Type a value in this field to set the minimum width of the line.
2. Maximum Size field: Type a value in this field to set the maximum width of the line.
3. Up/Down arrows: Use the up and down arrows to set the minimum size value.
4. Up/Down arrows: Use the up and down arrows to set the maximum size value.

Central Line Smoothness
You can modify the Central Line Smoothness

of your line using this option. This parameter smoothes the

initial movement of your line. Increasing the value will result in a smoother line with fewer control points.

Contour Optimization
You can optimize the Contour Line Smoothness of you line using this option. This parameter will smooth the
contour of your line once the line has been traced, the higher the value the less control points will compose your
line.

1. Smoothness field: Type a value to set the smoothness of the line.
2. Contour Optimization field: Type a value to set the contour optimization of the line.
3. Up/Down arrows: Use the up and down arrows to set smoothness value.
4. Up/Down arrows: Use the up and down arrows to set the contour optimization value.

Changing the Line Shape
There are several line shape to choose from. You can select how the start, end, and joints in the pencil line are
drawn.
To change the line shape:
In the Pencil Properties window, click a line shape in the Shape section and select a shape from the menu.

•

Start: Make the beginning of the line round or flat.

•

End: Make the end of the line round or flat.

•

Join: Make joints round, mitred, or bevelled.
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Previewing the Stroke
The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view.

Pencil Line Texture
You can apply a bitmap texture on your pencil line and adjust it as needed—see Pencil Line Texture on page 140

Related Topics
•

Drawing with Line Texture on page 155

•

Pencil Line Texture on page 140

•

Working with Thickness Stencils below

•

Drawing Using the Pencil Tool on page 130

Working with Thickness Stencils

A thickness stencil is a preset that already set with specific properties. There are two types of thickness stencils.
A Regular thickness stencils allow you to set the size and smoothing of the line or shape. As you draw, the
thickness of the line varies according the amount of pressure you use with a pen and tablet.
Thickness stencils that are indicated with this icon
are also set with specific properties but disregards the
pressure you use with your pen and tablet. The line thickness varies
You can access thickness stencils from the list of preset on the Tool Properties view, or create your own.
•

Selecting a Thickness Stencil on the facing page

•

Creating a Thickness Stencil on the facing page

•

Creating a Pencil Thickness Stencil with the Select Tool on page 139

•

Renaming a Thickness Stencil on page 139
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•

Deleting a Thickness Stencil on the next page

•

Locking a Thickness Stencil on page 140

•

Working with Thickness Stencils on the previous page

Selecting a Thickness Stencil
Using the drop-down menu, you can select an existing thickness stencil.
To select a pencil thickness stencil:
1. In the Tools toolbar, select the Pencil

, Line

, Ellipse

, or Rectangle

tool.

2. In the Tool Properties view, in the Presets drop-down menu, select the thickness stencil you want to use.

3. In the Drawing or Camera view, draw your pencil line or shape.

Creating a Thickness Stencil
To create a thickness stencil:
1. In the Tools toolbar, select the Pencil

, Line

, Ellipse

2. In the Tool Properties view, click the New Pencil or New Brush
The New Preset dialog box opens.
3. Enter a name for your new pencil thickness stencil and click OK.
4. Start drawing in the Camera or Drawing view.
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Creating a Pencil Thickness Stencil with the Select Tool
To create a pencil thickness stencil with the Select tool:
1. In the Tools toolbar, select the Select

tool.

2. In the Camera view, select the pencil line or shape you want to take the style from.

3. In the Tool Properties view, click the New Preset

button.

A new thickness stencil is added to the end of the list in the Presets drop-down menu.
4. In the Presets drop-down menu, select your new thickness stencil and click on a line or shape in the
Camera view to apply the thickness stencil you created.

Renaming a Thickness Stencil
To rename a thickness stencil:
1. In the Tools toolbar, select the Pencil

, Line

, Ellipse

, or Rectangle

tool.

2. In the Presets drop-down menu, select the thickness stencil you want to rename.
3. From the Brush menu, select Rename Pencil or Rename Brush, depending on the tool you selected.
The Rename Preset dialog box opens.

4. In the Name field, type in a name for the selected thickness stencil you are renaming.

Deleting a Thickness Stencil
To delete a thickness stencil:
1. In the Tools toolbar, select the Pencil

tool.

2. In the Presets drop-down menu, select the thickness stencil to delete.
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3. Click the Delete Preset

button.

Locking a Thickness Stencil
To avoid modifying your thickness stencil inadvertently, you can lock them by enabling the Lock Pen
To apply a thickness stencil to a pencil line or shape:
1. In the Tools toolbar, select the Select

tool.

2. In the Camera or Drawing view, select the pencil line or shape on which you want to apply a style.

3. In the Tool Properties view, select the style you want to apply from the Presets list.

The style you selected is applied to your selection.

Related Topics
•

Pencil Tool Options on page 131

•

Shape Tool Options on page 194

•

Select Tool Properties on page 165

Pencil Line Texture
You can apply a texture on a pencil line.
•

Applying Texture to a Pencil Line on the next page

•

Creating a Pencil Texture Template with the Pencil Tool on page 142
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•

Adding a Texture to the Preferences on page 144

•

Applying a Preset Texture to a Pencil Line on page 145

•

Creating a Pencil Texture Template with the Select Tool on page 143

Applying Texture to a Pencil Line
Pencil lines support texture. Before drawing, you can select or import a texture and apply it to your lines. You
can also change it afterwards using the Select tool. Textures are independent from pencil templates.
To apply a preset texture to a pencil line:
1. In the Tools toolbar, select the Pencil

tool.

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you
customize the different parameters in the Tool Properties view. Click the arrow button.

In the Pencil Properties property editor displays.
3. In the Texture section, select a texture for your pencil.
4. In the Camera or Drawing view, draw your pencil line.
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Creating a Pencil Texture Template with the Pencil Tool
To create a pencil texture template with the Pencil tool:
1. In the Tools toolbar, select the Pencil

tool.

2. In the Tool Properties view, click the arrow button beside the stroke preview area.

3. In the Pencil Properties property editor, click the New Texture

button or select New Texture from

the Texture menu.
‣

To delete a preset style, click the Delete Texture

button.

4. Browse for your bitmap texture file.

The file must be a TGA or PSD. Your texture MUST HAVE an alpha channel.

5. Click Open.
The imported texture is saved in your scene texture list.

6. In the Pencil Properties property editor, select your new texture.

7. In the Tool Properties view, click the Texture menu and select Rename Texture.
The Rename Opacity Texture dialog box opens.
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8. In the Name field, type the template name and click OK.
9. In the Camera or Drawing view, draw your pencil lines.

Creating a Pencil Texture Template with the Select Tool
To create a pencil texture template with the Select tool:
1. In the Tools toolbar, select the Select

tool.

2. In the Camera view, select a pencil line on which to apply a texture.
3. In the Pencil Properties property editor, click the New Texture

button or select New Texture from

the Texture menu.
‣

To delete a preset style, click on the Delete Texture

button. Note that you cannot delete the

textures stored in your preferences.
4. Browse for a bitmap texture file.

The file must be a TGA or PSD. Your texture MUST HAVE an alpha channel.

5. Click Open.
The imported texture is saved in your scene texture list.

6. In the Pencil Properties property editor, select your new texture template.
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7. In the Tool Properties view, click the Texture menu and select Rename Texture.
The Rename Opacity Texture dialog box opens.

8. In the Name field, type the template name and click OK.

Adding a Texture to the Preferences
When you import a texture in your pencil styles, it is saved in your scene. If you want to add that texture to a
bank that you will be able to reuse in different scenes, you can add that texture to your preferences.
To add a texture to your preferences:
1. In the Tools toolbar, select the Pencil

tool.

2. In the Tool Properties view, click the arrow button beside the stroke preview area.

3. In the Pencil Properties property editor, select a texture from the Textures area to add to your
preferences.
4. Click the Copy to Preference

button.
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Applying a Preset Texture to a Pencil Line
To apply a preset texture to a pencil line:
1. In the Tools toolbar, select the Select

tool.

2. In the Camera view, select a pencil line.

3. In the Tool Properties view, select a texture from the Textures area to apply to the selected stroke.

Related Topics
•

Pencil Tool Options on page 131

•

Select Tool Properties on page 165

•

Drawing with Line Texture on page 155

145

Chapter 4: Drawing Drawing with the Brush Tool

Drawing with the Brush Tool

The Brush

tool is pressure sensitive and can create a contour shape which gives a thick and thin line effect, as

if the drawing was made with a brush.
To draw with the Brush tool:
1. In the Timeline or Xsheet view, select the cell on which you want to draw.
In Harmony Paint, select a drawing in the Drawing panel.

2. In the Tools toolbar, select the Brush

tool or press [Alt] + [B].

3. In the Colour view, click a colour swatch to select a colour.

4. In the Drawing or Camera view, start drawing.
‣

Hold [Ctrl] (Windows) or [⌘ ] (Mac OS X) to force a line to join the end and start of your shape while
drawing.
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The last colour you select while using the Brush tool is recalled the next time you select the Brush
tool.

Related Topics
•

Brush Tool Options below

Brush Tool Options
When you select the Brush

tool, its properties and options appear in the Tool Properties view.

These are the options available for the Brush tool:
•

Normal Brush Mode on the facing page

•

Draw Behind on the facing page

•

Repaint Brush Mode on page 149

•

Auto-Flatten Mode on page 149

•

Respect Protected Colour on page 149

•

Use Stored Colour Gradient on page 149
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•

Brush Styles on page 150

•

Dynamic Brush on page 150

•

Brush Tool Options on the previous page

•

Brush Tool Options on the previous page

•

Brush Tool Options on the previous page

•

Brush Tips on page 150

•

Brush Tool Options on the previous page

•

Line Texture on page 150

Normal Brush Mode
The Normal Brush Mode

creates contour lines as you draw, adding each brush lines on top of the last ones.

Previewing the Stroke
The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view.

Maximum Size and Smoothing
This is where you set the minimum and maximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.
‣

Maximum and Minimum Size: Defines the maximum width of the stroke.

‣

Smoothing: Defines the number of control points added to the centre line.

Brush Presets
Brush presets are created by saving the properties of the current brush to a new preset, which you can reuse for
repeated tasks. You can create as many brush presets as you need.

Draw Behind

148

Toon Boom Animate 3 User Guide

When the Draw Behind

mode is enabled, the lines you draw will appear behind the art that already exists.

Repaint Brush Mode

The Repaint Brush

is used to repaint zones that have already been painted, it will not affect empty zones or

pencil lines. It also automatically flattens each of its brush lines so it does not add new brush lines on top of
existing ones. You can use this mode to paint tones or highlights onto your character.

Auto-Flatten Mode
When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing artwork as
you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes and pencil lines will flatten
with pencil lines.

Respect Protected Colour
The Respect Protected Colour

option prevent the colours you marked as protected in the Colour view to

be repainted using the Repaint Brush mode or any of the painting tools.

Refer to Protecting Colours on page 313 to learn how to use the Protect Colour feature.

Use Stored Colour Gradient
The Use Stored Colour Gradient

option makes your tool use the previously stored gradient position. This

way, every new brush line or colour fill will use the stored gradient position.
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Refer to Storing Your Favourite Gradient or Texture Settings on page 308 to learn how to use the
Store Colour Gradient option.

Brush Styles
A variety of brush styles are provided allowing you to create and save your own. This way you can create brushes
with precise sizes and parameters and save them so you can draw and design—see Brush Styles below

Dynamic Brush
A Dynamic Brush

can be created to allow you to draw using patterns created from your artwork—see

Dynamic Brush on page 152

Brush Tips

In this drop-down menu, you can find a variety of tip shapes from round and square ones to star shaped, select
the one you need.

Line Texture
In Toon Boom Animate, you can draw with a textured line. Textured lines are a mixed bitmap image contained in
a vector frame. This allows you to sketch as if you are drawing on paper.

Refer to the Drawing with Line Texture on page 155 topic to learn everything about line texture and
its parameters.

Related Topics
•

How to Draw on page 113

•

Drawing with the Brush Tool on page 146

•

Drawing with Line Texture on page 155

•

Working with Thickness Stencils

Brush Styles
You can create your own brush styles.
•

Selecting a Brush Style on the next page

•

Adding a Brush Style on the next page
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•

Brush Styles on the previous page

•

Deleting a Brush Style on the facing page

•

Brush Styles on the previous page

Selecting a Brush Style
A variety of brush styles are provided allowing you to create and save your own.This way you can create brushes
with precise sizes and parameters and save them so you can draw and design.

To select a brush style:
•

In the Tool Properties, select a brush style from the Brush Presets section.

Adding a Brush Style
To create a brush preset:

Make sure your current brush has the settings you would like in your preset.

1. Do one of the following:
‣

In the Brush view, click the New Brush

‣

From the Brush

‣

In the Properties window of the tool you are using, click the

button.

menu, select New Brush Preset.

Viewing Tool Properties on page 1.
2. In the New Preset window, type a name for your new brush preset.
The new brush is added to the end of the list of brush preset.
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Brush presets cannot be updated. However you can select a preset, which applies those properties
to the current brush. Then you can modify the properties, and create a new preset with the new
properties. If desired, you can delete the old preset.

Renaming a brush can make it easier to identify and access the brushes you use most frequently.
To rename a brush:
1. In the Tool Properties view, select a brush to rename.
2. From the Brush

menu, select Rename Brush.

3. Type in a new name for the brush.

Deleting a Brush Style
To delete a brush preset:
1. Select the brush preset you want to delete.
2. Do one of the following:
‣

In the Brush Preset view, click the Delete Brush

‣

From the Brush Preset

button.

menu , select Delete Brush.

Related Topics
•

Brush Tool Options on page 147

Dynamic Brush
A Dynamic Brush

can be created to allow you to draw using patterns created from your artwork. Create a

new Dynamic Brush to copy a pattern you have drawn to reproduce it quickly. You can create dynamic brushed
using either a single pattern or a multiple one that will automatically switch through the patterns as you draw.
To create a new dynamic brush:
1. In the Tools toolbar, select a drawing tool.
2. In the Drawing or Camera view, draw the pattern you want to use as your Dynamic Brush stamp.

3. In the Tools toolbar, click the Select

tool and select the parts of the drawing you want to repeat.
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4. In the Tools toolbar, select the Brush

tool.

5. In the Tool Properties view, click the Add Dynamic Brush

button to add your selection as a new

dynamic brush preset.
6. Click the Rename Brush Style

button.From the Brush menu, select Rename Brush.

The Rename Preset dialog box opens.
7. Type in a name for the new dynamic brush and click OK.
8. In the Camera or Drawing view, start drawing with your dynamic brush to quickly repeat a pattern.

To create a dynamic brush with multiple drawings:
1. In the Timeline view, click the Add Drawing Layers

button to create as many layers as patterns you

want in your dynamic brush. It is recommended to rename your layers.

2. In the Camera view, draw your individual pattern on a separated layer.

3. In the Tools toolbar, select the Select

tool.

4. In the Camera view, select all the drawings you want to add to your new dynamic brush.
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5. In the Tools toolbar, select the Brush

tool.

6. Click the Add Dynamic Brush

button to add your selection as a new Dynamic Brush preset.

7. Click the Rename Brush Style

button.From the Brush menu, select Rename Brush.

The Rename Preset dialog box opens.
8. Type in a name for the new dynamic brush and click OK.
9. In the Camera or Drawing view, start drawing with your dynamic brush to quickly repeat a pattern. When
you use this brush, you will cycle through the drawings.

Related Topics
•

Brush Tool Options on page 147
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Drawing with Line Texture

In Toon Boom Animate, you can use the Brush

tool to draw with bitmap textured lines.

In the Brush Tool Properties view, you will find a series of default textured brushes but you can also create your
own collection by importing either PSD or TGA files in the Pen list.

The textured brush only work with the Brush tool. It does not work with the Pencil, Line, Ellipse,
Polyline or Rectangle tools.

Related Topics
•

How to Draw with Texture below

•

Adjusting the Line Texture Parameters on page 1

•

Creating Texture Brushes on page 157

•

Erasing Textured Lines on page 158

•

Hiding the Line Texture on page 160

•

Adjusting the Line Texture Opacity on page 161

How to Draw with Texture
To draw with textured lines, use the Brush tool and the correct pen in the list. You can also draw with pencil line
texture—see Pencil Line Texture on page 140
To draw with textured lines:
1. In the Tools toolbar, select the Brush

tool or press [Alt]+[B].
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2. In the Tool Properties view, select a brush and click the Arrow button to open the Brush Properties view.

3. In the Texture section, select the Select Texture option.

4. Set the following parameters:
‣

Hardness: The hardness value corresponds to the smoothness of the line edge. The lower the value,
the more blurry and smooth the line edge will be. The higher the value, the sharper the line edge will
be.

‣

Minimum Opacity: This value corresponds to the transparency of the brush when the pressure is very
light. Values closer to 0 produce a more transparent line.

.
‣

Maximum Opacity: This value corresponds to the transparency of the brush when the pressure is
heavy. Values closer to 1 produce a more opaque line.

‣

Select Texture: Lets you use and select a texture for your brush. The thumbnail displays the texture
currently in use. You can also browse for a texture file to import. Browsing for a texture file in a brush
already using texture will replace the file currently in use, although it will not replace the texture in the
lines already drawn.
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‣

Texture Scale: Changes the size of the texture in the lines you draw. If you are using a plaid texture,
the squares will be larger if you increase the value and smaller if you decrease it.

5. In the Camera or Drawing view, start drawing.

Related Topics
•

Drawing with the Brush Tool on page 146

•

Pencil Line Texture on page 140

Creating Texture Brushes
To create your own texture brush, you must prepare your tiled texture file in a third-party software, such as
Adobe Photoshop. If your image has transparency in it, it will be supported. The texture file must be either a
.PSD or .TGA file.
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It is recommended that you maintain your texture resolution between 100 x 100 pixels and 400 x
400 pixels.

To create a texture brush:
1. In the Tools toolbar, select the Brush

tool or press [Alt]+[B].

2. In the Texture section, select the Select Texture option.
3. Click the Folder button and browse for a bitmap texture file.

4. In the Tool Properties view, click the New Brush

button to add a new brush to your list.

The colour of your texture will not be used. Instead, the dark and light areas will be used to
determine the alpha in your texture. The current colour swatch will be used in conjunction with the
pattern and alpha in your texture.

5. In the Camera or Drawing view, draw some lines and adjust the parameters to fit the style you are looking
for.

Related Topics
•

Drawing with Line Texture on page 155

Erasing Textured Lines
When you use the Eraser tool to erase a portion of a textured line, the vector frame is cut straight and you lose
the feather created while drawing with the Brush tool. In Toon Boom Animate, a special option in the Eraser
tool lets you create a soft edge on your textured lines. You can also cut or keep the vector frame as is.
1. In the Tools toolbar, select the Eraser

tool, press [Alt] + [E].

2. In the Tool Properties view, click the arrow button.

The Brush Properties panel opens.
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3. Adjust the following:
‣

Maximum/Minimum Size: Defines the minimum and maximum width of the stroke.

‣

Smoothing: Defines the number of control points added to the centre line.

‣

Contour Smoothing: Defines the number of control points added to the contour boundaries (around
the line). Lower values mean that the line will appear as you draw it (with more control points added
along the centre line). Higher values mean that the line will be smoothed out (removing control points
from the centre line).

‣

Tip Shape: Lets you select a shape for the tip of the eraser. There are a variety of tips to choose from:
round, square, oval, star-shaped and more.

‣

Soft Tip: Gives the tip of your stroke a soft edge.

‣

Keep Vectors: Keeps your vector frames and does not cut them.

‣

Hardness: The hardness value corresponds to the smoothness of the line edge. The lower the value,
the more blurry and smooth the line edge will be. The higher the value, the sharper the line edge will
be.

‣

Saturation: Corresponds to the intensity of line color.

‣

Maximum Opacity: Corresponds to the transparency of the brush when the pressure is heavy. Values
closer to 1 produce a more opaque line.

‣

Minimum Opacity: Corresponds to the transparency of the brush when the pressure is very light.
Values closer to 0 produce a more transparent line.
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4. In the Camera or Drawing view, erase your textures lines.

Related Topics
•

Drawing with Line Texture on page 155

Hiding the Line Texture

Sometimes you need to hide the line texture to see the complete vector frame around your lines. This is useful to
help you see any dirt floating around your drawing.

To hide the line texture in the Camera view, you must enable the Show Drawing on Top option. In
the top menu, select View > Show > Current Drawing on Top. Refer to the Show Current Drawing
on Top on page 121 section to learn more about this option.

To hide the line texture:
1. If you are in the Camera view, select the Show Current Drawing on Top option.
2. In the Camera or Drawing View

menu, select View > Show > Hide Line Texture or press [Ctrl] +

[Shift] + [H] (Windows) or [⌘ ] + [Shift] + [H] (Mac OS X).

Related Topics
•

Drawing with Line Texture on page 155
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Adjusting the Line Texture Opacity

At some point, you may want to modify the look of a textured drawing. Maybe you find that your line is too
smooth or too faint. You can adjust those parameters by using the Adjust Line Texture Opacity command.

To be able to adjust the line texture in the Camera view, you must select the Show Drawing on Top
option. In the top menu, select View > Show > Current Drawing on Top.
Refer to the Show Current Drawing on Top on page 121 section to learn more about this option.

To adjust the line texture opacity:
1. If you are in Camera view, select the Show Current Drawing on Top option.
2. In the Timeline or Xsheet view, select the drawing whose opacity you want to adjust.
3. In the Camera or Drawing view menu, select Drawing > Adjust Line Texture Opacity.
The Adjust Line Texture Opacity dialog box opens.

4. Drag the sliders toward the middle to increase the contrast and opacity of the textured lines.
5. If you want to apply the changes to all drawings exposed on the layer, select the Apply to All Drawings
option and click OK.

Related Topics
•

Drawing with Line Texture on page 155
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Selecting Drawing Objects

The Select

tool is used to select drawing strokes in both the Drawing and Camera views, and apply basic

transformations, such as repositioning, rotating, scaling or skewing, using the different handles of the bounding
box.
To select with the Select tool:
1. In the Timeline view, select the cell on which you want to select drawing objects.
In Harmony Paint, select a drawing in the Drawing panel.
2. In the Tools toolbar, select the Select

tool or press [Alt] + [S].

3. In the Camera or Drawing view, select the drawing objects.
‣

You can select all the drawing objects in a drawing by using the Select All command or press [Ctrl] +
[A] (Windows) or [⌘ ] + [A] (Mac OS X).

4. To deform or reposition a selection:
‣

To reposition, click on the selected drawing object and drag the selection to a new area.

‣

To rotate, grab the selection box handle and rotate it.
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‣

To scale, pull or push either on the top, side, bottom or corner control point. Hold down [Shift] to lock
the selection’s ratio.

‣

To skew, drag sideways or up and down the sides or top and bottom segments, between the control
points.

Inverting a Selection
Not available in Harmony Paint.
Sometimes, when you want to select multiple objects, while leaving one unselected, it can be handy to select only
the stroke, or line, that you do not want included in your selection. Then, you can invert that selection so that
everything else becomes selected. This can be quite a time saver.
To invert a selection:
1. From the top menu, select Edit > Invert Selection or press [Ctrl] + [Shift] + [I] (Windows) or [⌘ ] + [Shift] +
[I] (Mac OS X).
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You can also find the Invert Selection option in the Camera View or Drawing View menu by
selecting Edit > Invert Selection.

Related Topics
•

Repositioning a Pivot Point below

•

Selection on Single or Multiple Layers on the next page

•

Select Tool Properties on the next page

Repositioning a Pivot Point
Some of the transformations such as rotation, scale, skew and flip, are done relative to the position of the pivot
point. You can temporarily reposition this pivot point for a transformation using the Select
tool.
To temporarily reposition the pivot point:
1. In the Camera or Drawing view, select the drawing object you want to transform.
The pivot point appears in the middle of your selection.

2. Click the pivot point and drag it to a new position.
This becomes the new position of the pivot point for the current transformation and will remain there until
you make a new selection.
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Related Topics
•

Selecting Drawing Objects on page 162

•

Select Tool Properties below

Selection on Single or Multiple Layers

By default, when you draw a selection box in the Camera view, the Select tool will select all the drawing strokes
and symbols in its path. If you would prefer the Select tool to only select the current drawing and not the other
visible drawings, you can enable the Select Tool Works on Single Drawing preference.
To enable the Select Tool Works on Single Drawing preference:
1. In the top menu, select Edit > Preferences (Windows) or Animate > Preferences (Mac OS X).
The Preferences dialog box opens.
2. In the Camera tab, go to the Tools section and select the Select Tool Works on Single Drawing
preference and click OK.
3. In the Tools toolbar, select the Select

tool or select [Alt] + [S].

4. In the Camera view, select your drawing.

Related Topics
•

Selecting Drawing Objects on page 162

•

Select Tool Properties below

Select Tool Properties
When you choose the Select

tool, its properties and options appear in the Tool Properties view.
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Related Topics
•

Lasso and Marquee on the next page

•

Snap Options on the next page

•

Permanent Selection on page 168

•

Apply to All Drawings in Layer on page 168

•

Apply to All Visible Drawings on page 169

•

Apply to Line and Colour Art on page 169

•

Select by Colour on page 169

•

Flip Horizontal and Vertical on page 170

•

Rotate 90 Degrees CW and CCW on page 170

•

Pencil to Brush on page 171

•

Smooth on page 171

•

Flatten on page 171

•

Store Colour Gradient on page 171

•

Merge Pencil Lines on page 172

•

Reverse Pencil Thickness on page 172

•

Create Colour Art from Line Art on page 173
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•

Distribute to Layers on page 173

•

Width and Height on page 174

•

Offset X and Y on page 174

•

Angle on page 174

•

Adjusting the Pencil Line Thickness on page 175

•

Adjusting the Pencil Line Style on page 175

•

Pencil Stencils on page 175

•

Adding Texture to a Pencil Line on page 176

•

Adjusting the Text Selection on page 176

Lasso and Marquee
Choose between the Lasso
•

and Marquee

options to change the selection style of the tool.

Click and hold [Alt] to temporarily switch from the current mode to the other.

Snap Options
You can enable different snapping modes to help you when repositioning your drawings using the Select tool.
•

Snap to Contour: Snaps your selection or point to any line you position it on. As soon as you move it
close enough to another line, your point or selection will snap to it.

•

Snap and Align: Snaps the selected anchor point to any existing line while displaying temporary
rulers as a guide that you can also snap your anchor point to.

•

Snap to Grid: Snaps your selection following the currently enabled grid.

To snap to grid:
•

Select View > Grid > Show Grid to display the grid in the Camera or Drawing view or press [Ctrl] + [']
(Windows) or [⌘ ] + ['] (Mac OS X).

•

Select View > Grid > Square Grid, 12 Field Grid or 16 Field Grid for your current needs.

1. In the Tools toolbar, select the Contour Editor

tool or press [Alt] + [Q].

2. In the Contour Editor Tool Properties view, click the Snap to Grid
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3. In the Camera or Drawing view, click on an anchor point you want to snap following the grid, and drag it
to the desired position and release.

Refer to the Grid on page 229 topic to learn more about the Grid feature.

Permanent Selection

The Permanent Selection

option is used to maintain a selection over multiple drawings. Once this option is

enabled, the selection zone made using the Select tool will remain as you navigate through drawings from a
layer and drawings from other drawing layers. This option can be used to simultaneously delete artwork inside
or outside of the selection on several drawings when combined with the Apply to Multiple Drawings option.

Apply to All Drawings in Layer
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The Apply to All Drawings in Layer

option is used to perform an action on all the drawings contained in a

layer. For example, you could enable the option to paint a section on all the drawings simultaneously. The Apply
Tool to All Drawings option must be activated before performing the action and will stay enabled only for the
next action.

Apply to All Visible Drawings

The Apply to All Visible Drawings

option is used to perform an action on all the visible drawings in the

Camera view. This option is not available in the Drawing view.

Apply to Line and Colour Art
The Apply to Line and Colour Art

option uses the concept of Line Art and Colour Art layers. Use this option

to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art layers, as well as the
Overlay and Underlay layers.

To access the Apply to Line and Colour Art option, you must be in the Advanced Art mode—see
Overlay, Line Art, Colour Art, Underlay and Preview Mode on page 116.

Select by Colour

The Select by Colour mode lets you select all the zones in your drawing painted with the same colour.
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Only the zones painted with the SAME colour swatch will be selected. If another zone is coloured
with the exact same RGB value (same colour), but not painted with the same colour swatch, it will not
be selected.

To select areas by colour:
1. In the Tools toolbar, select the Select

tool or press [Alt] + [S].

2. In the Tool Properties view, click the Select by Colour

button.

3. In the view, click on any zone in your drawing.
All zones of the same colour are selected.
4. Click the Select tool again to return to the regular Select mode.

Flip Horizontal and Vertical

The Flip Horizontal

and Flip Vertical

operations flip the current selection horizontally or vertically.

From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW

and Rotate 90 Degrees CCW

operations rotate the current selection 90

degrees clockwise or counter-clockwise.
From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 Degrees CCW.
Or press [Ctrl] + [7] and [Ctrl] + [9] (Windows) or [⌘ ] + [7] and [⌘ ] + [9] (Mac OS X).
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Pencil to Brush

The Pencil to Brush

operation converts the selected centreline pencil strokes into contour strokes brush

lines.
From the top menu, select Drawing > Convert > Pencil Lines to Brush or press [&].

Smooth

The Smooth

operation lets you smooth out selected drawing strokes and remove extra points. You can also

access this feature through the top menu, by selecting Drawing > Optimize > Smooth or press [Alt] + [Shift] +
[S].

Flatten

The Flatten

operation is used to merge drawing objects and brush strokes into a single layer. If you draw

new lines to fix a drawing or a line with many brush strokes, it can be useful to flatten them all into a single shape.
By default, lines are drawn one on top of each other, if you intend repainting the lines or modifying their shape, it
will be easier if they are flattened.
You can also access this feature through the top menu, by selecting Drawing > Optimize > Flatten. The [Alt] +
[Shift] + [F].

Store Colour Gradient
Use the Store Colour Gradient

operation to record the selected gradient’s position. This reuses the stored

position of the gradient when drawing new brush lines or painting colour zones. Enable the Use Stored Colour
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Gradient

option in the Paint or Brush Tool Properties view to do this.

Refer to Drawing with the Brush Tool on page 146 or Painting Using the Paint Tool on page 290 to
learn how to use the Use Stored Colour Gradient option.

Merge Pencil Lines

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to align them and
make it look like it is one single line. With the Select tool, you can select several pencil lines and merge them as
one single object using the Merge Pencil Lines
option. It will take your lines and adjust the ends to form one
single line.

Points have to be close enough to be merge. If there is a big gap between the lines, they will not be
merged.

Reverse Pencil Thickness

The Reverse Pencil Thickness

option will invert the thick and thin section on a selected pencil line. This

option will take the thickest size on the line and apply it to the thinnest, and it will apply the thinnest to the
thickest.
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Create Colour Art from Line Art
You can configure the Create Colour Art from Line Art option to suit your requirements.

To access this option, you must be in the Advanced Art mode—see Overlay, Line Art, Colour Art,
Underlay and Preview Mode on page 116.

To configure the Create Colour Art from Line Art option:
1. In the Select tool Tool Properties view, [Shift] + click the Create Colour Art from Line Art

button.

The Configure Line Art to Colour Art dialog box opens.

‣

Use rendered version of the drawing: This option will render the drawing and vectorize it to
calculate the position of the centreline that will produce the colour art stroke.

‣

Maximum Resolution for rendered image: The size of the rendered image.

‣

Threshold for rendered image: The value of grey processed to create the rendered vectorized arts.

‣

Fitting error for rendered beziers: This value represents how precise the fitting of the colour art zone
in relation to the line art will be.

‣

Source layer: Select the layer (Line Art, Colour Art, Underlay or Overlay) you want the colour art to
be created from.

‣

Destination layer: Select the layer (Line Art, Colour Art, Underlay or Overlay) you want the colour
art to be created on.

‣

Clear Destination Art Layer First: Enable this option if you already have artwork on the destination
layer and you want the content to be deleted before the colour art is added into it.

‣

Perform Line Art to Colour Art Operation Immediately: Enable this option to perform the Create
Colour Art from Line Art command when you click OK.

Distribute to Layers
The Distribute to Layers

option is used to separate the selected art strokes and send them to new drawing

layers. In the Camera view, once you have drawn your artwork, you can select the strokes you want to distribute
using the Select
tool and click on the Distribute to Layer
button, you can also select Drawing >
Distribute to Layer. It will automatically take every stroke from the drawing selection made in the Camera view
and separate them into a different layer for each. If an artwork is composed of several strokes, you must group
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them using Edit > Group > Group before using the Distribute to Layer option. This option cannot be done from
the Drawing view.

Refer to Break Down: Distribute to Layers on page 600 to learn more about the Distribute to Layer
option.

Width and Height
Use the Width and Height operation fields to enter specific values to resize the selected shape with precision.

1. Width: Type a width value in this field to resize the width of your selection.
2. Height: Type a height value in this field to resize the height of your selection.
3. Up/Down arrows: Use the up and down arrows to modify the value contained in either the Width or
Height value field.
4. Lock icon: Click on the lock icon to lock or unlock the ratio between the width and height values.

Offset X and Y
Use the Offset X and Offset Y operation fields to enter specific values and precisely reposition the selected
shape.

1. X: Type an offset value in this field to reposition your selection along the X-axis.
2. Y: Type an offset value in this field to reposition your selection along the Y-axis.
3. Up/Down arrows: Use the up and down arrows to modify the value contained in either the X or Y value
field.

Angle
Use the Angle operation fields to enter specific values and accurately rotate the selected shape.

1. Angle: Type a degree value in this field to rotate your selection.
2. Up/Down arrows: Use the up and down arrows to modify the value contained in the Angle value field.
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Adjusting the Pencil Line Thickness
Use the Adjusting the Pencil Line Thickness operation field to resize the selected centreline strokes. This
operation is not permitted on contour line shapes, such as brush strokes or shape fills.

1. Minimum Size: Type a value in this field to set the minimum thickness of the selected centreline stroke.
2. Maximum Size: Type a value in this field to set the maximum thickness of the selected centreline stroke.
3. Up/Down arrows: Use the up and down arrows to modify the value contained in the Thickness value field.
4. Lock Proportions: Enable the Lock option for the minimum and maximum size to increase and decrease in
proportion.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.
•

Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between
Round or Flat style.

•

End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between
Round or Flat style.

•

Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define the
Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Pencil Stencils
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Toon Boom Animate gives you the flexibility to change the style and thickness of your pencil lines even after they
are drawn. You can apply preset pencil stencils or create your own.

Refer to Working with Thickness Stencils on page 137, Creating a Pencil Thickness Stencil with the
Select Tool on page 139 and Working with Thickness Stencils on page 137.

Adding Texture to a Pencil Line
Pencil lines support texture. Once a pencil line is drawn, you can apply a preset texture or load your own.
Textures are independent from pencil stencils.

Refer to Pencil Line Texture on page 140, Applying a Preset Texture to a Pencil Line on page 145
and Creating a Pencil Texture Template with the Select Tool on page 143.

Adjusting the Text Selection
When you select text with the Select tool, the tool properites will display the Text tool options on the bottom of
the view. You can also press [Alt] + [9] to display only the Text properties in the Tool Propertie view.

Refer to Formatting the Text on page 219 to learn more about the Text tool Tool Properties.

Related Topics
•

Drawing Using the Pencil Tool on page 130

•

Pencil Tool Options on page 131

•

Working with Thickness Stencils on page 137

•

Pencil Line Texture on page 140
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Erasing Parts of a Drawing

The Eraser tool is pressure sensitive, like the Brush tool, giving you more precision when erasing parts of a
drawing.
To erase with the Eraser tool:
1. In the Timeline or Xsheet view, select the cell where you want to erase.
In Harmony Paint, select a drawing in the Drawing panel.

2. In the Tools toolbar, select the Eraser

tool or press [Alt] + [E].

3. In the Camera or Drawing view, start erasing.

You can also use the Select tool to select drawing objects and delete them instead of erasing.

Related Topics
•

Eraser Tool Options below

•

Selecting Drawing Objects on page 162

Eraser Tool Options
When you select the Eraser

tool, its properties and options appear in the Tool Properties view.
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Related Topics
•

Tip Style below

•

Eraser Tool Options on the previous page

•

Eraser Tool Options on the previous page

•

Eraser Tool Options on the previous page

•

Eraser Tool Options on the previous page

•

Eraser Tool Options on the previous page

•

Eraser Styles on page 180

•

Eraser Blur Parameters on page 180

Tip Style

The Tip Style option affects the erased tip of pencil lines made with the Pencil, Ellipse, Rectangle, Line, and Polyline tools.
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Previewing the Stroke
The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view.

Maximum Size and Smoothing
This is where you set the minimum and maximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.
‣

Maximum/Minimum Size: Defines the minimum and maximum width of the stroke.

‣

Smoothing: Defines the number of control points added to the centre line.

‣

Contour Smoothing: Defines the number of control points added to the contour boundaries (around
the line). Lower values mean that the line will appear as you draw it (with more control points added
along the centre line). Higher values mean that the line will be smoothed out (removing control points
from the centre line).

‣

Tip Shape: Lets you select a shape for the tip of the eraser. There are a variety of tips to choose from:
round, square, oval, star-shaped and more.

‣

Soft Tip: Gives the tip of your stroke a soft edge.

‣

Keep Vectors: Keeps your vector frames and does not cut them.

‣

Hardness: The hardness value corresponds to the smoothness of the line edge. The lower the value,
the more blurry and smooth the line edge will be. The higher the value, the sharper the line edge will
be.

‣

Saturation: Corresponds to the intensity of line color.
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‣

Maximum Opacity: Corresponds to the transparency of the brush when the pressure is heavy. Values
closer to 1 produce a more opaque line.

‣

Minimum Opacity: Corresponds to the transparency of the brush when the pressure is very light.
Values closer to 0 produce a more transparent line.

Brush Presets
Brush presets are created by saving the properties of the current brush to a new preset, which you can reuse for
repeated tasks. You can create as many brush presets as you need.

Eraser Styles
The Eraser tool uses the same Brush Styles as the Brush tool. Toon Boom Animate provides a variety of eraser
styles and allows you to create and save your own. It is a good idea to create and save eraser brushes with
precise sizes and parameters to draw and design—see Brush Styles on page 150

Eraser Blur Parameters
Since Toon Boom Animate lets you draw with textured lines and create feathered edges on them, you may also
want to erase with smooth edges instead of the solid vector based eraser. The Eraser Blur Parameters allow you
to adjust the smoothness of your eraser for the textured lines—see Erasing Textured Lines on page 158

180

Toon Boom Animate 3 User Guide

Reshaping a Drawing Using the Contour
Editor Tool

The Contour Editor tool is powerful, it allows you to add, remove or modify points on a vector line and to
control them with Bezier handles. It is used to correct line shapes and to modify a single part of a colour zone. If a
line is too thin or has a gap in it, you can modify and correct it with the Contour Editor tool. This tool can also be
used to create elaborate shapes.
The Contour Editor displays vector points around a shape and the central vector points in a pencil line. Pulling or
pushing on these points adjusts the brush’s line thickness. Points can be selected and deleted. Each point has
two Bezier handles used to correct the curves between two points. Shapes can be modified by pulling and
pushing directly on the segment between the points. You can use it to perfect a central shape pencil line, a
contour shape brush line or even create an elaborate shape from a basic ellipse, or square.
To reshape with the Contour Editor tool:
1. In the Timeline or Xsheet view, select the cell in which you want to draw.
In Harmony Paint, select a drawing in the Drawing panel.
2. In the Tools toolbar, select a shape

tool.

3. In the Tool Properties view, click the Ellipse mode

button, click the Auto Fill mode

set the pencil size to 0.
4. In the Drawing or Camera view, draw a circle.

5. In the Tools toolbar, select the Contour Editor

tool or press [Alt] + [Q].
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6. In the Drawing or Camera view, click the line to reshape it.

7. Select one or several points by clicking on them or circling around.

8. Press [Delete] to delete a selected point.
Press [Ctrl] (Windows) or [⌘ ] (Mac OS X)and click on the contour to add a new point to adjust the
contour.
9. To modify the shape, you can:
‣

Pull on the Bezier handle. Both point’s handles will move as one.

‣

Hold down the [Alt] key and pull on one of the Bézier handles. The point’s handle will move
independently from the other one.

‣

Move the selected points to a new area.

‣

Pull directly on the line between two points. No selection is necessary. Holding down the [Shift] key will
limit the contour modification to the curve between the two first points.

‣

If an anchor point has no visible Bezier, hold down the [Alt] key to get them.
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To add control points, press [Ctrl] (Windows) or [⌘] (Mac OS X) and click the line.
To remove control points, select the control point and press [Delete].

Related Topics
•

Contour Editor Tool Properties below

Contour Editor Tool Properties
When you select the Contour Editor

tool, its properties and options appear in the Tool Properties view.

These are the options available for the Contour Editor tool:
•

Lasso and Marquee below

•

Show Contour Editor Controls on the facing page

•

Apply to Line and Colour Art on the facing page

•

Snap to Contour on the facing page

•

Snap and Align on page 185

•

Smooth Selection on page 185

Lasso and Marquee
Choose between the Lasso
•

and Marquee

options to change the selection style of the tool.

Click and hold [Alt] to temporarily switch from the current mode to the other.
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Show Contour Editor Controls

Use the Show Contour Editor Controls

option to show the contour editor controls. You can use these

controls to scale, reposition and rotate the selected anchor points.

Apply to Line and Colour Art
The Apply to Line and Colour Art

option uses the concept of Line Art and Colour Art layers. Use this option

to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art layers, as well as the
Overlay and Underlay layers.

To access this option, you must be in the Advanced Art mode—see Overlay, Line Art, Colour Art,
Underlay and Preview Mode on page 116.

Snap to Contour

The Snap to Contour

option will snap the selected anchor point to any line you position it on.

To snap two shapes together:
1. In the Tools toolbar, select the Contour Editor

tool or press [Alt] + [Q].

2. In the Tool Properties view, click the Snap to Contour
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3. In the Camera or Drawing view, click on an anchor point you want to snap to the other shape, drag it on
top of the contour line area and release it.

Snap and Align

The Snap and Align

option lets you snap the selected anchor point to any existing line while displaying

temporary rulers as a guide that you can also snap your anchor point to.
To snap and align:
1. In the Tools toolbar, select the Contour Editor

tool or press [Alt] + [Q].

2. In the Tool Properties view, click the Snap and Align

button.

3. In the Camera or Drawing view, click on an anchor point you want to snap, drag it until a ruler is displayed,
position it on the ruler or on the contour line and release.

Smooth Selection

The Smooth

operation lets you smooth out selected drawing strokes and remove extra points. You can also

access this feature through the top menu, by selecting Drawing > Optimize > Smooth or press [Alt] + [Shift] +
[S].
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Related Topics
•

Reshaping a Drawing Using the Contour Editor Tool on page 181
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Reshaping Pencil Lines with the Pencil Editor
Tool

The Pencil Editor

tool is used to modify the thick and thin contour of a pencil line. A pencil line is a central vec-

tor shape. The shape control points are located all along the central spine allowing to adjust the stroke curve
and position. When using the Contour Editor tool, you will be able to reposition the spine of the stroke. When
using the Pencil Editor tool, you will be able to adjust the thick and thin areas of the line.

To use the Pencil Editor tool:
1. In the Tools toolbar, select the Pencil Editor

tool located in the Contour Editor drop-down menu or

press [Alt] + [W].
2. In the Camera or Drawing view, select a pencil line and click the line to reshape it.

3. Select one or several points by clicking them or circling around.
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4. Press [Delete] to delete a selected point.
5. Press [Ctrl] (Windows) or [⌘ ] (Mac OS X) and click the central spine to add a set of points to adjust the
contour.
6. To modify the shape, you can:
‣

Move the selected points to a new area. If you select matching points on each side of the line, holding
the Shift key will move them both. This way you can thicken or thin a line from both side at the same
time.

‣

Pull on the Bezier handle. Both points’ handles will move as one.

‣

Hold [Alt] down and pull on one of the Bezier handles. The point’s handle will move independently
from the other one.
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‣

Pull directly on the line in-between two points. No selection is necessary. Holding down the [Shift] key
will limit the contour modification to the curve between the two first points.

‣

If an anchor point has no visible Bezier, hold down the [Alt] key to get them.

Related Topics
•

Pencil Editor Properties below

Pencil Editor Properties
When you select the Pencil Editor tool, its properties and options appear in the Tool Properties view.

These are the options available for the Pencil Editor tool:
•

Lasso and Marquee below

•

Smooth on the facing page

•

Pump Pencil Pressure on the facing page

•

Deflate Pencil Pressure on the facing page

•

Merge Pencil Lines on page 191

•

Reverse Pencil Thickness on page 191

•

Adjusting the Pencil Line Style on page 191

•

Working with Thickness Stencils on page 137

•

Adding Texture to a Pencil Line on page 192

Lasso and Marquee
Choose between the Lasso
•

and Marquee

options to change the selection style of the tool.

Click and hold [Alt] to temporarily switch from the current mode to the other.
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Smooth

The Smooth

operation lets you smooth out selected drawing strokes and remove extra points. You can also

access this feature through the top menu, by selecting Drawing > Optimize > Smooth or press [Alt] + [Shift] +
[S].

Pump Pencil Pressure

The Pump Pencil Pressure

option is used to increase the line thickness of a selected area on a pencil line.

Deflate Pencil Pressure

The Deflate Pencil Pressure

option is used to decrease the line thickness of a selected area on a pencil line.
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Merge Pencil Lines

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to align them and
make it look like it is one single line. With the Select tool, you can select several pencil lines and merge them as
one single object using the Merge Pencil Lines
option. It will take your lines and adjust the ends to form one
single line.

Reverse Pencil Thickness

The Reverse Pencil Thickness

option will invert the thick and thin section on a selected pencil line. This

option will take the thickest size on the line and apply it to the thinnest, and it will apply the thinnest to the
thickest.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.
•

Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between
Round or Flat style.
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•

End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between
Round or Flat style.

•

Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define the
Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Thickness Stencils

Toon Boom Animate gives you the flexibility to change the style and thickness of your lines even after they are
drawn. You can apply preset thickness stencils or create your own.

Refer to Working with Thickness Stencils on page 137, Creating a Pencil Thickness Stencil with the
Select Tool on page 139 and Working with Thickness Stencils on page 137.

Adding Texture to a Pencil Line
Pencil lines support texture. Once a pencil line is drawn, you can apply a preset texture or load your own.
Textures are independent from Pencil thickness stencils.

Refer to Pencil Line Texture on page 140, Applying a Preset Texture to a Pencil Line on page 145
and Creating a Pencil Texture Template with the Select Tool on page 143.

Related Topics
•

Reshaping Pencil Lines with the Pencil Editor Tool on page 187
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Drawing with Shapes

In Toon Boom Animate, you can use the shape tools to draw with circles, lines and squares. You can also easily
reshape a square or circle into a much more complex drawing such as these butterfly wings.

Refer to Reshaping a Drawing Using the Contour Editor Tool on page 181 and Reshaping Pencil Lines
with the Pencil Editor Tool on page 187 topics to learn more about the Contour Editor and Pencil
Editor tools.

To draw with a Shape tool:
1. In the Timeline or Xsheet view, select the cell where you want to draw.
2. In the Tools toolbar, select a shape

tool.

3. In the Tool Properties view, you can switch between the different shapes mode.. Select either the Ellipse
or Rectangle
tool.
4. In the Camera view, click and drag your mouse to draw the shape.

‣

Hold down [Shift] to lock the rectangle or the ellipse ratio to 1:1.

‣

Hold down [Alt] to draw the rectangle or ellipse from its centre.

‣

Hold down [Shift] to snap the line every 15 degrees.

‣

Hold down [Alt] to snap the starting or end point of the line to a close by stroke.
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5. Use the Contour Editor

tool to deform your shape and create your drawing.

Related Topics
•

Shape Tool Options below

Shape Tool Options
When you select a shape tool, its properties and options appear in the Tool Properties view.

These are the options available for the shape tools:
•

Line, Rectangle and Ellipse on the next page

•

Draw Behind on the next page

•

Snap Options on the next page

•

Line Building Mode on page 196
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•

Automatic Filling on the facing page

•

Create Colour Art Automatically on page 197

•

Auto-Flatten Mode on page 197

•

Auto-Close Gap on page 198

•

Use Stored Colour Gradient on page 198

•

Keep Proportion on page 198

•

Pencil Templates on page 198

•

Thickness Adjustment on page 199

•

Adjusting the Pencil Line Style on page 199

•

Applying Texture to a Pencil Line on page 199

Line, Rectangle and Ellipse

Click on the

button corresponding to the shape you want. Click and drag your mouse to draw the

selected shape. The shape tools create centre lines.
Using the Ellipse or Rectangle option, press [Shift] to create a perfect round or a perfect square and press [Alt]
to create the shape from its centre.
Using the Line tool, press [Shift] to create a line which snaps-to every 15 degrees and then press [Alt] to connect
the start or end point of that line to another nearby line. To create a curve in the line as you draw, hold down
[Ctrl] (Windows) or [⌘ ] (Mac OS X) and drag to create a bend in the line.

Draw Behind

When the Draw Behind

mode is enabled, the lines you draw will appear behind the art that already exists.

Snap Options
When drawing a shape, you can enable different snap modes to help you create your shape.
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•

The Snap to Contour

•

The Snap and Align

option snaps your shape to any line you position it on.
option snaps the selected anchor point to any existing line, while displaying

temporary rulers as a guide that you can also snap your anchor point to.
•

The Snap to Grid

snaps your shape to the currently enabled grid.

Refer to the topic to learn more about the Grid feature.

Line Building Mode

The Line Building

mode is very useful when drawing long lines and curves in small increments with pencil

lines. As the pencil lines are central vector lines and it may be difficult to align the line tips perfectly to create a
uniform stroke and close all gaps.
In this mode, you can draw lines in small increments and the tip are merge into one single stroke.

This mode only works with pencil lines.

Automatic Filling

Use the Automatic Filling

option to automatically fill your shape with the selected colour as you draw. By

default, the Shape tool creates the contour of an empty shape that you can later fill using the Paint tool.
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Refer to Selecting the Current Colour of a Tool on page 288to learn more about selecting a fill
colour.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically

automatically creates the

corresponding strokes in the Colour Art layer.

To access this option, you must be in the Advanced Art mode—see Overlay, Line Art, Colour Art,
Underlay and Preview Mode on page 116.

Auto-Flatten Mode
When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing artwork as
you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes and pencil lines will flatten
with pencil lines.
Using the Select tool, you can use the middle mouse button to select a segment of flattened pencil line. Use this
technique to create a nice finish to lines and corners in your artwork.
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Auto-Close Gap

When enabled, the Auto-Close Gap

mode automatically connects, with an invisible stroke, the pencil lines

you draw close to each other in the Camera or Drawing view.

It is recommended to leave this option ENABLED when drawing with the Pencil tool.

Use Stored Colour Gradient
The Use Stored Colour Gradient

option makes your tool use the previously stored gradient position. This

way, every new brush line or colour fill will use the stored gradient position.

Keep Proportion

When the Ellipse or Rectangle mode is enabled in the Tool Properties view, the Draw Circle or Draw Square
option appears. When selecting these options, the shape produced will either be a circle or a square. Holding
down the [Shift] key as you create your shape will maintain proportion.

Pencil Templates
Toon Boom Animate provides a variety of pencil templates and also lets you create and save your own. It is a
good idea to create and save pencils with precise sizes and parameters when you draw and design.
You also have the possibility to apply different textures to your lines by either using the preset ones or importing
your own—see Working with Thickness Stencils on page 137
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Thickness Adjustment
Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.
•

Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between
Round or Flat style.

•

End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between
Round or Flat style.

•

Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define the
Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Applying Texture to a Pencil Line
Pencil lines support texture. Once a pencil line is drawn, you can apply a preset texture or load your own.
Textures are independent from Pencil templates.

Refer to Pencil Line Texture on page 140, Applying a Preset Texture to a Pencil Line on page 145
and Creating a Pencil Texture Template with the Select Tool on page 143.

Related Topics
•

Working with Thickness Stencils
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Drawing with the Polyline Tool

The Polyline tool is used to draw shapes. It is a central vector type of line. To form a shape, you click to add a
point and then, without releasing the mouse, pull the handle in the desired direction before adding the next
point and repeat the operation. To edit the shape, you can use the Contour Editor tool.
To draw with the Polyline tool:
1. In the Timeline view, select the cell where you want to draw.
In Harmony Paint, select a drawing in the Drawing panel.
2. In the Tools toolbar, select the Polyline

tool or press [Alt] + [_].

3. In the Camera view, click and drag your mouse to create a point and a Bezier handle to shape your line.
‣

Press [Alt] to pull only one handle, instead of two.

‣

Press [Shift] to snap the handles to 45, 90, or 180 degrees.

4. Click again into a new area and drag the mouse to create a second point and Bezier handle.

5. Repeat the previous step until your shape is completed.
6. Press [Ctrl] (Windows) or [⌘ ] (Mac OS X) and click to release the Polyline tool from the current path or
shape that it is creating. Continue to use the tool to make multiple, independent paths or shapes.
7. If necessary, reshape the lines using the Contour Editor

tool.

Refer to Reshaping a Drawing Using the Contour Editor Tool on page 181 to learn more about the
Contour Editor tool.
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Related Topics
•

Polyline Tool Options below

Polyline Tool Options
When you select the Polyline tool, its properties and options appear in the Tool Properties view.

These are the options available for the Polyline tool:
•

Snap to Contour on page 203

•

Create Colour Art Automatically on page 203

•

Pencil Templates on page 203

Previewing the Stroke
The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view.
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Size
The Size parameter lets you set the size of the polyline that you will draw.

Polyline Presets
Polyline presets are created by saving the properties of the current tool to a new preset, which you can reuse for
repeated tasks. You can create as many presets as you need.

Size and Smoothness
This is where you set the minimum and maximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.
‣

Maximum/Minimum Size: Defines the minimum and maximum width of the stroke.

‣

Smoothing: Defines the number of control points added to the centre line.

‣

Contour Smoothing: Defines the number of control points added to the contour boundaries (around
the line). Lower values mean that the line will appear as you draw it (with more control points added
along the centre line). Higher values mean that the line will be smoothed out (removing control points
from the centre line).

Adjusting Polyline Style

You can adjust the start, end, and joint style of a selected pencil line.
•

Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between
Round or Flat style.

•

End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between
Round or Flat style.

•

Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define the
Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Working with Line Textures
Like pencil lines, polylines support texture. Before drawing, you can select or import a texture and apply it to
your lines. You can also change it afterwards using the Select tool. Textures are independent from pencil
templates—see Pencil Line Texture on page 140.
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Snap to Contour
The Snap to Contour

option will snap your selection to any line you position it on.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically

automatically creates the

corresponding strokes in the Colour Art layer.

To access this option, you must be in the Advanced Art mode—see Overlay, Line Art, Colour Art,
Underlay and Preview Mode on page 116.

Pencil Templates

Toon Boom Animate gives you the flexibility to change the style and thickness of your pencil lines even after they
are drawn. You can apply preset templates or create your own.

Refer to Working with Thickness Stencils on page 137, Creating a Pencil Thickness Stencil with the
Select Tool on page 139 and Working with Thickness Stencils on page 137.

Related Topics
•

Drawing with the Polyline Tool on page 200
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Drawing Using Invisible Lines

There are two different ways to draw invisible lines:
•

Pencil Tool below

•

Stroke Tool on the next page

Pencil Tool
Using the Pencil tool, you can draw as strokes only, meaning that the line will be invisible. This can be useful to
draw tones and highlights directly on the character.
To draw invisible lines with the Pencil tool:
1. In the Timeline or Xsheet view, select the cell where you want to draw.
In Harmony Paint, select a drawing in the Drawing panel.
2. In the Tools toolbar, select the Pencil

tool or press [Alt] + [/].

3. In the top menu, select View > Drawing > Show Strokes

or press [K].

In Harmony Paint, select View > Show Strokes.
4. In the Tool Properties view, set the Pen Style size to 0. You can also adjust the smoothness.
5. In the Camera or Drawing view, start drawing.
If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a
Message dialog box opens.

Select the Don’t Show This Message Again option if you do not want the dialog box to notify you about
the Show Strokes option. Click OK.
6. You can modify the stroke shape with the Contour Editor
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Stroke Tool
The Stroke

tool draws invisible lines only. You cannot add thickness to the line.

To draw invisible lines with the Stroke Pencil tool:
1. In the Timeline or Xsheet view, select the cell where you want to draw.
In Harmony Paint, select a drawing in the Drawing panel.
2. In the Tools toolbar, select the Stroke

tool or press [Alt] + [V].

3. In the top menu, select View > Show Drawing > Show Strokes

or press [K].

In Harmony Paint, select a drawing in the Drawing panel.
4. In the Tool Properties view, you can adjust the smoothness.
5. In the Camera or Drawing view, start drawing.
If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a
Message dialog box opens.

Select the Don’t Show This Message Again option if you do not want the dialog box to notify you about
the Show Strokes option. Click OK.
6. You can modify the stroke shape with the Contour Editor

tool.

Related Topics
•

Stroke Tool Options below

•

Show Strokes as Washed-out Colours

Stroke Tool Options
When you select the Stroke tool, its properties and options appears in the Tool Properties view.

Here are the options available for the Stroke tool:
•

Draw Stroke as Straight Lines on the facing page

•

Connect Line Ends on the facing page

•

Auto-Flatten Mode on the facing page
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•

Central Line Smoothness below

Draw Stroke as Straight Lines
Enable the Draw Stroke as Straight Lines

option if you want the new strokes that you will draw to be a

perfect straight line. Disable the option if you want the stroke to follow the mouse gesture.

Connect Line Ends
Enable the Connect Line Ends

option if you want the start or end point of your new stroke to connect to

your existing strokes to make sure no gaps are left in your drawing.

Auto-Flatten Mode
When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing artwork as
you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes and pencil lines will flatten
with pencil lines.

Central Line Smoothness
You can modify the Central Line Smoothness

of your line using this option. This parameter smoothes the

initial movement of your line. Increasing the value will result in a smoother line with fewer control points.

Related Topics
•

Drawing Using Invisible Lines on page 204

•

Show Strokes as Washed-out Colours
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Deforming a Drawing Using the Perspective
Tool

The Perspective tool lets you deform a drawing selection and alter its perspective.
To deform a drawing with the Perspective tool:
1. In the Tools toolbar, select the Perspective

tool or press [Alt] + [0].

2. In the Camera or Drawing view, select the drawing you want to deform.
3. Click and drag the different anchor points to deform the shape.
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Related Topics
•

Perspective Tool Properties below

Perspective Tool Properties
Selecting the Perspective tool displays its properties and options in the Tool Properties view.

•

Lasso and Marquee below

•

Apply to Line and Colour Art on the next page

•

Flip Horizontal and Vertical on the next page

•

Rotate 90 Degrees CW and CCW on page 210

Lasso and Marquee
Choose between the Lasso
•

and Marquee

options to change the selection style of the tool.

Click and hold [Alt] to temporarily switch from the current mode to the other.
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Snap to Contour
The Snap to Contour

option will snap the selected anchor point to any line you position it on—see Contour

Editor Tool Properties on page 183.

Snap and Align
The Snap and Align

option lets you snap the selected anchor point to any existing line while displaying

temporary rulers as a guide that you can also snap your anchor point to—see Contour Editor Tool Properties on
page 183.

Snap to Grid
The Snap to Grid

option snaps your selection according to the currently enabled grid.

Apply to Line and Colour Art
The Apply to Line and Colour Art

option uses the concept of Line Art and Colour Art layers. Use this option

to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art layers, as well as the
Overlay and Underlay layers.

To access this option, you must be in the Advanced Art mode—see Overlay, Line Art, Colour Art,
Underlay and Preview Mode on page 116.

Flip Horizontal and Vertical

The Flip Horizontal

and Flip Vertical

operations flip the current selection horizontally or vertically.

From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.
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Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW

and Rotate 90 Degrees CCW

operations rotate the current selection 90

degrees clockwise or counter-clockwise.
From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 Degrees CCW.
Or press [Ctrl] + [7] and [Ctrl] + [9] (Windows) or [⌘ ] + [7] and [⌘ ] + [9] (Mac OS X).

Related Topics
•

Deforming a Drawing Using the Perspective Tool on page 207
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Cutting Drawing Parts

The Cutter tool is used to cut a drawing area to move, copy, cut or delete it.
To cut with the Cutter tool:
1. In the Tools toolbar, select the Cutter

tool or press [Alt] + [T].

2. In the Camera view, trace a selection around the part to cut away.

‣

To delete the selected zone, press[Delete].

‣

To move the selection, click the selection and drag it to a new area.

‣

Use the bounding box controls to scale, skew, or rotate the cut piece.

Related Topics
•

Cutter Tool Options on the facing page
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Cutter Tool Options
When you select the Cutter

tool, its properties and options appear in the Tool Properties view.

Here are the options available for the Cutter tool:
•

Lasso and Marquee below

•

Apply to Line and Colour Art below

•

Use Mouse Gesture below

•

Use Mouse Gesture Breaker Mode on the next page

•

Tip Style on the next page

•

Flip Horizontal and Vertical on page 214

•

Rotate 90 Degrees CW and CCW on page 214

Lasso and Marquee
Choose between the Lasso
•

and Marquee

options to change the selection style of the tool.

Click and hold [Alt] to temporarily switch from the current mode to the other.

Apply to Line and Colour Art
The Apply to Line and Colour Art

option uses the concept of Line Art and Colour Art layers. Use this option

to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art layers, as well as the
Overlay and Underlay layers.

To access this option, you must be in the Advanced Art mode—see Overlay, Line Art, Colour Art,
Underlay and Preview Mode on page 116.

Use Mouse Gesture
When using the Lasso

selection type, the Use Mouse Gesture

option lets you automatically delete any

extra sections of line in your artwork by simply dragging your mouse over it.
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For this operation to work, you lines CANNOT be flattened.

Use Mouse Gesture Breaker Mode
When using the Lasso

selection type, the Use Mouse Gesture Breaker Mode

option lets you draw an

invisible stroke on a pencil line to cut it in two individual objects. Once a pencil line is cut with this option, you will
be able to select the two portions independently with either the Cutter tool, Pencil Editor tool or Select tool.

This option only works with pencil lines.

Tip Style

Use the Tip Style option to customize the tip of the pencil line you are cutting.
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Flip Horizontal and Vertical

The Flip Horizontal

and Flip Vertical

operations flip the current selection horizontally or vertically.

From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW

and Rotate 90 Degrees CCW

operations rotate the current selection 90

degrees clockwise or counter-clockwise.
From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 Degrees CCW.
Or press [Ctrl] + [7] and [Ctrl] + [9] (Windows) or [⌘ ] + [7] and [⌘ ] + [9] (Mac OS X).

Related Topics
•

Cutting Drawing Parts on page 211
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Smoothing Lines

When drawing in a digital application, it is not like drawing on a sheet of paper, sometimes the lines you draw
may look as if they were drawn with an unsteady hand. When this occurs, you may need to correct the look of
your lines.
Toon Boom Animate has a very powerful tool you can use to optimize contours and reduce the number of points
on the lines, the Smooth Editor
tool.
To optimize lines with the Smooth tool:
1. In the Tools toolbar, select the Smooth Editor

tool or select Drawing > Tools > Smooth Editor.

In Harmony Paint, select Tools > Smooth Editor.
2. In the Camera or Drawing view, place your pointer over the lines to smooth. You may need to pass over
the same line several times to remove more points and make the line smoother.

Related Topics
•

Smooth Editor Tool Options on the facing page
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Smooth Editor Tool Options
When you select the Smooth Editor tool, its properties and options appear in the Tool Properties view.

Here are the options available for the Smooth Editor tool:
•

Brush, Marquee and Lasso Smoothing Style below

•

Show Control Points below

•

Minimum Size and Maximum Size below

•

Smoothness on the next page

•

Colour on the next page

Brush, Marquee and Lasso Smoothing Style
The Smoothing Style options allows you to smooth a portion of your drawing either by tracing a smoothing
stroke over the zone to optimize or by selecting an area of the drawing with the Marquee or the Lasso.

Show Control Points
The Show Control Points

option allows you to show or hide the Bezier points around your lines. When the

Bezier points are displayed, you can see the result of your smoothing and the number of points left on your
curve. When it is turned off, you will only see the original artwork.

Minimum Size and Maximum Size
This is where you set the minimum and maximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.
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1. Minimum Size field: Type a value in this field to set the minimum width of the line.
2. Maximum Size field: Type a value in this field to set the maximum width of the line.
3. Up/Down arrows: Use the up and down arrows to set the minimum size value.
4. Up/Down arrows: Use the up and down arrows to set the maximum size value.
This options is available while using the Brush Smoothing

style.

Smoothness
The Smoothness

impacts the strength of the smoothing result. The higher the value, the more points are

removed and the smoother the curve is. The Smoothness range is from 0 to 100; the default value is 20.

Colour

You can modify the colour of the control points displayed on the artwork while working with the Smooth Editor
tool by double-clicking on the colour swatch.
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Related Topics
•

Smoothing Lines on page 215
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Working With Text
With the Text tool, you can type text in your project, using various fonts and texts attributes. Text objects are
part of a drawing, so you can manipulate them the same way.
To add text to your drawings:
1. Do one of the following:
‣

In the Tools toolbar, select the Text

‣

Select Drawing > Tools > Text.

‣

Press [Alt] + [9].
In Harmony Paint, select a Tools > Text.

tool.

2. In the Timeline view, select the cell containing the drawing you want to add text to.
3. In the Drawing or Camera view, click on the location you want your text to begin.

4. You can use the Tool Properties view to select the font, font size and format the text you will type—see
Formatting the Text below.
5. Type in the desired text.

6. Click outside the text box to exit the typing mode.
If you want to create another text object, click outside the currently active text box. You can always return
to edit the text by selecting the Text
tool and clicking in the text.

Related Topics
•

Formatting the Text below

Formatting the Text
Use the Text tool Tool Properties view to select the font type and other formatting options you want to apply to
the text.
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1. Font Type below
2. Font Style below
3. Alignment on the next page
4. Font Size on the next page
5. Kerning on the next page
6. Indent on page 222
7. Line Spacing on page 222

•

Resizing the Text Box on page 222

•

Converting Text into Separate Objects on page 223

If you already wrote your text, you must first use the Text tool and select the text portion you want to
format.

Font Type
Use this drop-down menu to select the desired font, from the list of fonts available in your system.

Font Style
Use these buttons to select a desired style for your text:
•

Bold

•

Italic
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Alignment
Use these buttons to align the paragraph.
Left

Right

Centred

Justified

Font Size
Type the desired size for the text in this field. You can also use the up and down arrow buttons to set the desired
value.

Kerning
Use the kerning field to modify the spacing between letters and characters. You can select the Auto Kern option
to set the kerning automatically, based on the font’s predefined standard. A negative value decreases spacing
between each character creating a letter overlap and a positive value increases it.
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Indent
Enter a value in the Indent field to increase or decrease the indentation on the first line of your text. A positive
value sets the first line of your paragraph farther to the right and a negative value sets it farther to the left.

Line Spacing
Enter a value in the Line Spacing field to decrease or increase the space between each line of text.

Resizing the Text Box
You can resize the text box by selecting your text box with the Text
or left.
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Using the Select tool will distort and scale your text itself rather than changing the width and height of your text
box.

Converting Text into Separate Objects
Text contained in a text field is treated as a single drawing object. You can easily separate the text so that each
character becomes an individual drawing object that you can select and modify independently.
To break a text object:
1. In the Tools toolbar, click on the Select

tool or press [Alt] + [S].

2. In the Drawing or Camera view, select the text object you want to break.

3. Select Drawing > Convert > Break Apart Text Layers.
In Harmony Paint, select Selected > Convert > Break Apart Text Layers.

Each character is now surrounded by its own bounding box that you can modify, they remain text objects
that you can edit.
4. If you want to convert your independent letter to a complete vector object that you can deform, using the
Select tool, select the letters to convert.
5. Select Drawing > Convert > Break Apart Text Layers to break the selection into a regular drawing
object, with no more text attributes.
In Harmony Paint, select Selected > Convert > Break Apart Text Layers.

Related Topics
•

Working With Text on page 219
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Override Tool
The Override Tool lets you increase productivity by rapidly switching between tools used for short tasks and
your previous tool. Most drawing tool shortcuts are accessed using the [Alt] key followed by another key, such as
the Eraser tool which is accessed by pressing [Alt] + [E].
If you are drawing with the Brush tool and need to briefly switch to the Eraser before continuing, hold down the
[E] key while you are erasing. Once done, release [E] to return to the previous tool, in this case, the Brush tool.
You can do the same for most drawing tools that have a shortcut composed of [Alt] followed by another key.

Related Topics
•

Keyboard Shortcuts on page 57

•

Tools Toolbar on page 71
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More Drawing Tools
Animate offers a wide variety of useful tools to optimze your drawings and work more efficiently; tools such as
Group, Arrange, and the animation disk to rotate your workspace.

Related Topics
•

Arrange below

•

Convert Brush Strokes to Pencil Lines on the facing page

•

Pencil Lines to Brush Strokes on the facing page

•

Strokes to Pencil Lines on the facing page

•

Optimize on page 227

•

Remove Extra Strokes on page 227

•

Reduce Drawing Texture Resolution on page 227

•

Crop Brush Textures on page 228

•

Create Contour Stroke on page 229

•

Remove Contour Stroke on page 229

•

Grid on page 229

•

Group/Ungroup on page 230

•

Hand on page 230

•

Rotate View on page 230

Arrange
Use the different Arrange options to reorder drawing objects inside a single layer in the Drawing or Camera
view.
•

Bring to Front button or select Drawing > Arrange > Bring to Front or press [Ctrl] + [Shift] + [PgUp]
(Windows) or [⌘ ] + [Shift] + [PgUp] (Mac OS X).
The selected art is moved to the top.

•

Bring Forward button or select Drawing > Arrange > Bring Forward or press [Ctrl] + [PgUp]
(Windows) or [⌘ ] + [PgUp] (Mac OS X).
The selected art is moved one level higher.

•

Send Backward button or select Drawing > Arrange > Send Backward or press [Ctrl] + [PgDown]
(Windows) or [⌘ ] + [PgDown] (Mac OS X).
The selected art is moved one level lower.

•

Send to Back button or select Drawing > Arrange > Send to Back or press [Ctrl] + [Shift] +
[PgDown] (Windows) or [⌘ ] + [Shift] + [PgDown] (Mac OS X).
The selected art is moved to the bottom.

225

Chapter 4: Drawing More Drawing Tools

Convert Brush Strokes to Pencil Lines

The Brushes Strokes to Pencil Lines

operation converts the selected contour strokes into centreline pencil

strokes. This command is only available from the top menu.
Select Drawing > Convert > Brush Strokes to Pencil Lines.
In Harmony Paint, this options is found in the Selected menu rather than the Drawing menu.
The [^].

Pencil Lines to Brush Strokes

The Pencil Lines to Brush Strokes

operation converts the selected centreline pencil strokes into contour

strokes brush lines.
From the top menu, select Drawing > Convert > Pencil Lines to Brush Strokes.
In Harmony Paint, this options is found in the Selected menu rather than the Drawing menu.
The [&].

Strokes to Pencil Lines

The Strokes to Pencil Lines

operation converts the selected invisible line to a pencil line.

Select Drawing > Convert > Strokes to Pencil Lines.
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In Harmony Paint, this options is found in the Selected menu rather than the Drawing menu.
The [Shift] + [F12] (Windows only).

Optimize

The Optimize command reduces the number of layers, such as overlapping brush strokes, in the selected
drawing objects. Drawing objects will only be flattened and optimized if the selected objects will not change the
appearance of the final image when they are merged.
For example, if you have selected a number of partially transparent objects, which you layered to create an
additive colour effect, the selected transparent drawing objects will not be merged. This is because merging the
transparent drawing objects will cause them to lose the effect of the layered transparent colours.
•

Use the Select tool to select the drawing objects you want to optimize.

•

Select Drawing > Optimize > Optimize.
In Harmony Paint, this options is found in the Selected menu rather than the Drawing menu.

Remove Extra Strokes
The Remove Extra Strokes option is used to remove the invisible lines in your selection.
•

Use the Select tool to select the drawing objects you want to remove invisible lines from.

•

Select Drawing > Optimize > Remove Extra Strokes.
In Harmony Paint, this options is found in the Selected menu rather than the Drawing menu.

Reduce Drawing Texture Resolution
If you import and vectorize as texture (colour) a high resolution image, the size of your drawing can be heavy.
This option is used to reduce the size and resolution of the textures in your drawing. When you import and
vectorize drawings using the grey or colour preset styles, you don't have control on the size of the bitmap
texture. This tool allows you to reduce that bitmap texture.
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To reduce the drawing texture resolution:
•

In the Timeline or Xsheet view, Select tool to select the drawing objects you want to reduce the texture
resolution for.remove invisible lines from.

•

Select Drawing > Optimize > Reduce Drawing Texture Resolution.
In Harmony Paint, this options is found in the Selected menu rather than the Drawing menu.

1. In the dialog box, drag the slider toward the left to reduce the texture resolution.
2. Enable the Apply to All Drawings option if you want the modification to be applied to all the drawings in
your layer.
3. Click OK.

Crop Brush Textures

The Crop Brush Textures option is used to crop an unnecessarily large texture bitmap that lies, unseen,
beneath the vector contour of a textured line. This often occurs when you cut and paste textured lines from one
drawing into another. If you cut a portion from a textured line and paste it into a different drawing, Toon Boom
Animate pastes the entire unseen texture bitmap from the source drawing into the new one, even if you only
took a small portion of the source drawing. Using the Crop Brush Texture command will crop away extraneous
texture that does not touch the vector area. If there are many textured lines in your scene, this will greatly reduce
the file size.
In the example shown above, a textured line is cut from a drawing and pasted into a new drawing. At first
glance, it appears as if only a cropped section of the underlying texture bitmap was cut and pasted as well.
However, using the Contour Editor tool to expand the vector envelope of the textured line, it is revealed that
more texture bitmap exists beyond the cropped boundary. If you use the Crop Brush Texture command the
bitmap texture is cropped to the boundaries of the textured line’s vector contour (as seen in the fourth image
where the vector envelope has been pulled out to reveal empty space).
To crop the brush texture:
1. In the Timeline or Xsheet view, select the drawing you want to crop the texture for.
2. Select Drawing > Optimize > Crop Brush Textures.
In Harmony Paint, this options is found in the Selected menu rather than the Drawing menu.
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Create Contour Stroke
The Create Contour Stroke

option is used to add a permanent invisible line around a shape that was drawn

directly in the application. This allows you to unpaint your lines with the Paint

tool but to maintain the shape

of the lines should you need to repaint later.
This command is useful when inking and painting and using the Apply to All Drawings in Layer

option.

In Harmony Paint, this options is found in the Selected menu rather than the Drawing menu.

Remove Contour Stroke
The Remove Contour Stroke option is used to remove any permanently invisible lines that were either created
while scanning and vectorizing drawings or manually adding contour strokes. This is useful if you want to remove
the intersection triangles created during vectorization.
In Harmony Paint, this options is found in the Selected menu rather than the Drawing menu.

Grid

Use the Show Grid option to display a grid in the Drawing or Camera view.
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•

Select View > Grid > Show Grid. The [Ctrl] + ['] (Windows) or [⌘ ] + ['] (Mac OS X).

•

Select View > Grid > Square to display a standard square grid.

•

Select View > Grid > 12 Field Grid to display a 12 field size grid.

•

Select View > Grid > 16 Field Grid to display a 16 field size grid.

•

Select View > Grid > Underlay to display the grid behind the drawing elements.

•

Select View > Grid > Overlay to display the grid over the drawing elements.

Group/Ungroup
Use the Group

option to group the selected drawing objects. This can help in the selection, repositioning,

re-scaling and other transformations to be applied to multiple objects of a drawing.
In Harmony Paint, this options is found in the Selected menu rather than the Edit menu.
•

Select Edit > Group > Group or Edit > Group > Ungroup.

•

Press [Ctrl] + [G] and [Ctrl] + [Shift] + [G] (Windows) or [⌘ ] + [G] and [⌘ ] + [Shift] + [G] (Mac OS X).

Hand
Use the Hand tool to pan through the Drawing and Camera view.
•

In the Tools toolbar, select the Hand

tool, click in the Drawing or Camera view and drag your cursor.

•

You can also Hold down the keyboard shortcut [Spacebar], click in the Drawing or Camera view and
move your mouse in the direction you want to pan the view.

Rotate View
Use the Rotate View

tool to rotate the Drawing or Camera view, the same way as you would do with a real

animation disc.
•

Select Drawing > Tools > Rotate View.
In Harmony Paint, this options is found in the Tools menu rather than the Drawing menu.

•

Press [Ctrl] + [Alt] (Windows) or [⌘ ] + [Alt] (Mac OS X).
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This tool can also be used in the Perspective view.

Related Topics
•

How to Draw on page 113

Drawing Pivot Tool
The Drawing Pivot

tool lets you set the pivots on your character. You can set the drawing pivots on

drawings and symbols.

•

Setting the Drawing Pivot for Symbols on All Frames below

•

Snapping on the facing page

•

Reset Pivot on the facing page

•

Copying Pivot on Parent Symbol on the facing page

Setting the Drawing Pivot for Symbols on All Frames
The Set the Pivot for Symbol on All Frames

option is enabled by default. When you set a drawing pivot on a

symbol, all of its cells use the same drawing pivot. This means you do not have to set a drawing pivot on all
frames. Once you set it, it is done.
If you prefer to set a different drawing pivot for a series of cells, you can deselect the option and set your pivots
on each cell or cell range.
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If you have already set several different pivots on your symbol's cells and selected the Set the Pivot
for Symbol on All Frames option, once you set a new pivot on the same symbol, all of its pivots will be
reset and will use your new pivot.

Snapping

When you drag the drawing pivot around, you can enable a snap option so that when the drawing pivot is
released, it either snaps to the reference grid, drawing's contour, or aligns with an existing drawing stroke.

Refer to Snap Options on page 167.

Reset Pivot
When you click the Reset Pivot

option, the drawing pivot of the selected drawing or symbol is reset to the

centre of the Camera view (stage).

Copying Pivot on Parent Symbol
When you import new extra drawings, such as hands and mouths, you can use the drawing pivot that was set on
your drawings and report them to the symbol's cells. Use the Copy Pivot to Parent Symbol
command for
this.

When you copy drawing pivots to the parent symbol, there is no link between the drawings' pivots
and the symbol's pivots. If you modify the drawing pivot later, it will not link to the symbol. You would
need to do the operation again. If you need to modify the symbol's pivots, you can do it directly on
the symbol's cells.

Related Topics
•

Setting the Pivots on page 581

•

Setting Pivots on a Frame Range on page 603
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Drawing Preferences
When drawing or animating traditionally in Toon Boom Animate, there are preferences you can set to help you
work more efficiently.
To open the Preferences dialog box:
‣

Windows: Select Edit > Preferences.

‣

Mac OS X: Select Animate > Preferences.

‣

Press [Ctrl] + [U] (Windows) or [⌘ ] + [U] (Mac OS X).

Related Topics
•

OpenGL Drawing Preferences below

•

Drawing on the facing page

•

Advanced Tab Preferences on page 235

OpenGL Drawing Preferences

Full Scene Antialiasing
By default, the Full Scene Antialiasing preference is disabled. This option lets you see smooth lines as you draw
as swell as an antialiased drawing area. You can change the value of the Full Scene Antialiasing using the
Preferences dialog box, to fit the current level used in the Camera or Drawing view.

Refer to the Viewing the Final Lines as you Draw on page 128.

233

Chapter 4: Drawing Drawing Preferences

Support Transparency in Pencil Lines
When the option is enabled, the pencil lines are displayed normally. The lines will be opaque (unless there are
transparencies). Disabling this option will reduce rendering times, but will display additive opacities for
overlapping pencil lines and unevenly filled curved pencil lines.

Drawing
These are the preferences you can find in the Drawing tab.

Light Table
•

Onion Skin Render Style:
•

Normal: The onion skinned drawings is displayed in washed out colours.

•

Enable Shade: The previous onion skinned drawings are displayed in washed out red shades and the
next onion skinned drawings are displayed in washed out green shades.

•

Outlines Only: The onion skinned drawings are displayed as outlines only.

•

Light Table: Enable Shade: When enabled, the drawings appearing in the Light Table are displayed in
washed out colours in the Drawing view. When this option is disabled, the drawings appearing in the
Light Table are displayed using normal colours. This option is for the Drawing view only.

•

Light Table: Shade in Camera View: When enabled, the drawings appearing on other layers are
displayed in washed-out colours in the Camera view. When this option is disabled, the drawings
appearing on other layers are displayed using normal colours. This option is for the Camera view only.
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•

Enable Onion Skin for Other Elements: When both Onion Skin and Light Table options are enabled, the
drawings appearing in the Light Table also display their previous and next onion skinned drawings. This
option is for the Drawing view only.

•

Onion Skin: Maximum Wash Value (0,0-1,0): The maximum washed-out value for onion skinned
drawings.

•

Onion Skin: Minimum Wash Value (0,0-1,0): The minimum washed-out value for onion skinned
drawings.

•

Onion Skin: Maximum Opacity (0,0-1,0): The maximum opacity value for onion skinned drawings. (0 =
transparent).

•

Onion Skin: Minimum Opacity (0,0-1,0): The minimum opacity value for onion skinned drawings. (0 =
transparent).

•

Light Table: Wash (0,0-1,0): The washed-out value for the light table display.

•

Light Table: Opacity (0,0-1,0): The opacity value for the light table display. (0 = transparent).

Options
•

Grid On By Default: When opening the Drawing view, the grid displays automatically.

•

Select Tool is Lasso: When this option is enabled, the Select tool behaves as a lasso selector. When this
option is disabled, the Select tool behaves as a rectangle selector.

•

Brush Size Cursor: When this option is enabled, the brush tool displays the brush size as a circle around
the cursor.

•

Auto Save Pen Styles: When this option is enabled, new pens and pen styles are automatically saved.

•

Thumbnails View location: When sending a series of drawings to the Drawing view, the drawing list
appears in a Side panel. This preference changes the location of the Side panel in the Drawing view. By
default, the panel is displayed on the right-hand side of the Drawing view. You must restart the
application for this change to be applied.

•

Default Pencil Line Tip: Sets the default pencil line tip to either Round, Flat, or Bevel.

Zoom
•

Enable Paper Zoom: Enabling this option allows you to set the 100% Zoom level onscreen, in order to
physically match the measurements of your paper drawing.
•

Number of Pixels per Inch: Enter the PPI for your monitor. To obtain the PPI of your screen, divide
the height or width of your monitor's resolution setting by the corresponding physical height or width
of your monitor screen (resolution height divided by physical height, or resolution width divided by
physical width) in inches.

•

Maximum Zoom Factor: Sets the maximum zoom level for the paper zoom.

Advanced Tab Preferences
These are the related preferences you can find in the Advanced tab.
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Advanced Options
•

Restore Current Selected Drawing On Undo: If a drawing other than the current one is being affected
by an Undo command, the affected affected drawing is displayed.
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Topics Covered
•

Traditional Animation Tools on the facing page

•

Basic Traditional Animation on page 247

•

Advanced Traditional Animation on page 254

•

Cleaning Scanned Drawings on page 1
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Traditional Animation Tools

Traditional Animation Tools

When you animate digitally using traditional techniques, there are certain tools you require in order to work
efficiently, as you would do with an animation table, paper and pencils. These tools are described in this section:
•

Onion Skin below

•

Light Table on page 240

•

Drawing Identification on page 241

•

Create Empty Drawing on page 244

•

Reposition All Drawings on page 244

Onion Skin

The Onion Skin

tool is used to preview the previous and subsequent drawings. When designing or

animating, it is useful to be able to see your previous drawings. By default, the previous drawings will appear
with a shade or red and the next drawings will be displayed with a shade of green but you can change the display
options in the Preferences panel.

Refer to the Drawing Preferences on page 233 topic to learn about the Onion Skin preferences.
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To use the Onion Skin feature:
1. Enable the Onion Skin feature:
‣

In the Tools toolbar, click on the Show Onion Skin

‣

In the Timeline view, click on the Onion Skin

‣

From the top menu, select View > Onion Skin > Show Onion Skin.

‣

Or press [Alt] + [O].

button.

icon. When enabled, the icon will turn red

.

2. You can select the number of previous and next drawings you want to show:
‣

In the Timeline view, click and drag the Onion Skin blue markers to choose how many previous and
next drawings will be displayed.

‣

Select View > Onion Skin > No Previous Drawing or press [~].

‣

Select View > Onion Skin > Previous Drawing or press[!].

‣

Select View > Onion Skin > Previous Two Drawings or press [@].

‣

Select View > Onion Skin > Previous Three Drawings or press [#].

‣

Select View > Onion Skin > No Next Drawing or press [Ctrl] + [`] (Windows) or [⌘ ] + [`] (Mac OS
X).

‣

Select View > Onion Skin > Next Drawing or press [Ctrl] + [1] (Windows) or [⌘ ] + [1] (Mac OS X).

‣

Select View > Onion Skin > Next Two Drawings or press [Ctrl] + [2] (Windows) or [⌘ ] + [2] (Mac
OS X).

‣

Select View > Onion Skin > Next Three Drawings or press [Ctrl] + [3] (Windows) or [⌘ ] + [3]
(Mac OS X).

3. The previous and next drawings will appear in both the Camera and Drawing view.
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Traditional Animation Tools

Related Topics
•

Traditional Animation Tools on page 238

Light Table

The Light Table

is used to preview the previous and subsequent active layers in washed-out colours. It is

useful to be able to see the other layers when designing, animating or cleaning up your animation.
In the Camera view, when the Light Table is activated all layers apart from the currently selected one are shown
washed-out. The display returns to the normal mode when the Select tool or a scene setup tool is selected.
Only the currently selected drawing is displayed by default in the Drawing view. When enabling the Light Table,
the other layers appear as a washed-out display and are used as a reference. You can not select or manipulate
them.
To use the Light Table feature:
1. Enable the Light Table feature:
‣

In the top menu, select View > Light Table.

‣

In the Drawing View toolbar, click on the Light Table

‣

Or press [Shift] + [L].

button.

2. The drawings for the other layers are displayed as washed-out colours in the Camera and Drawing view.
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3. In the Timeline view, you can disable the layers you wish to hide from the Light Table.

Refer to the Drawing Preferences on page 233 topic to learn about the Light Table preferences.

Related Topics
•

Traditional Animation Tools on page 238

Drawing Identification
In the Xsheet view, you can identify your drawings as Key, Breakdown or In-between. This helps to keep your
Xsheet well organized while animating.
When working with several animators, directors, or even other studios, the necessity for retakes will often arise.
Animate also gives you the possibility to mark your new drawings as either Retake Key, Retake Breakdown, or
Retake Inbetweens.
If your production requires you to mark your drawing with a custom marker, you also have the option to create
your own.
To mark a drawing as Key, Breakdown or In-between:
1. In the top menu, select Windows > Toolbars > Mark Drawing to display the Mark Drawing toolbar.

2. In the Xsheet view, select the cell you want to identify. This option is not available in the Timeline view.
3. In the Mark Drawing toolbar, press on the Mark as Key Drawing
Mark as In-between Drawing

, Mark as Breakdown Drawing

or

buttons. In the Xsheet View menu, you can also select Drawing > Mark

Drawing As > Key Drawing, Breakdown Drawing, In-between Drawing, Retake Key, Retake BD and
Retake IB.
‣

If you select Mark as Key Drawing, a

icon appears in the cell.
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‣

If you select Mark as Breakdown Drawing, a

‣

If you select Mark as In-Between Drawing, there is no icon displayed in the cell since it is used to
remove a Key or Breakdown marker.

icon appears in the cell.

You can create your own custom shortcuts for the Drawing Identification options by going in the
Preferences panel. Refer to Customizing a Keyboard Shortcut on page 58 to learn how to customize
keyboard shortcuts.

Custom Marks in the Xsheet View
Make custom marks for the Xsheet by creating your own icons, then cutting, pasting and changing a bit of code.
Not only is it possible to have your custom mark appear in the Xsheet and Mark Drawing toolbar, but also in the
Onion Skin and Flip toolbars.
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To create your custom markers:
1. With a bitmap editing software, create the following icons in PNG format:
‣

Mark Drawing Toolbar icon (24 x 24 pixel)

‣

Onion Skin Toolbar icon (24 x 24 pixel)

‣

Flip Toolbar icon (24 x 24 pixel)

‣

Xsheet Column icon (16 x 16 pixel)

2. Close Animate.
3. Once your icons are ready, go to the Toon Boom Animate resources/drawingTypes.d directory:
•

Stand-alone
‣

Mac OS X: /Applications/Toon Boom Animate 3/resources/drawingTypes.d

‣

Windows: C:/Program Files (x86)/Toon Boom Animation/Toon Boom Harmony
10.0/resources/drawingTypes.d

4. Paste your icons it the resources/drawingTypes.ddirectory.
5. In that same directory, open the drawingTypes.xml file in a text editor.
6. For each custom icon you want to create, add the following line. Make sure it is placed before the closing
</DrawingTypes> tag.
‣

<DrawingType text="NewButtonName" pixmapFile="XsheetIcon.png"
commandIcon="MarkDrawingIcon.png" flipIcon="FlipIcon.png" onionIcon="OnionIcon.png" />

7. In that line, replace the following information with your new icon information:
‣

NewButtonName: Write the name of your new marker. This name will appear in the button tooltip.

‣

XsheetIcon.png: Write the name of the icon that you created to appear in the Xsheet column. Include
the file extension.

‣

MarkDrawingIcon.png: Write the name of the icon that you created to appear in the Mark Drawing
toolbar. Include the file extension.

‣

FlipIcon.png: Write the name of the icon that you created to appear in the Flip toolbar. Include the file
extension.

‣

OnionIcon.png: Write the name of the icon that you created to appear in the Onion Skin toolbar.
Include the file extension.

8. Save the file and close it.
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9. Launch Animate.

Related Topics
•

Traditional Animation Tools on page 238

Create Empty Drawing
The Create Empty Drawing

command automatically creates a drawing in the selected cell of the Timeline

and Xsheet view, replacing any drawing that may already be exposed in that cell and the following ones until it
meets another drawing.
To create an Empty Drawing:
1. In the Timeline or Xsheet view, select the cell you want to create an empty drawing in.
2. In the Xsheet View toolbar, click on the Create Empty Drawing

button or select

Animation > Create Empty Drawing or press [Alt] + [Shift] + [R].
3. The new drawing will be created in the Xsheet and Timeline views.

Related Topics
•

Traditional Animation Tools on page 238

Reposition All Drawings

The Reposition All Drawings

option is used to reposition, scale, rotate or skew all drawing strokes on every

drawing included in a layer.
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To reposition all drawings:
1. In the Tools toolbar, select the Reposition All Drawings

tool. This also automatically selects every

stroke in your drawing in the Drawing and Camera view.

2. To deform or reposition a selection:
‣

To reposition, click and drag your selection to a new area.

‣

To rotate, rotate the selection box handle.

‣

To scale, pull or push either on the top, side, bottom or corner control points. Hold down [Shift] to
lock the selection’s ratio.

245

Chapter 5: Traditional Animation

‣

Traditional Animation Tools

To skew, drag the sides or top and bottom segments, between the control points.

3. When you release your cursor, every drawing contained in the drawing layer you repositioned, scaled,
rotated or skewed will follow the same transformation.

Related Topics
•

Traditional Animation Tools on page 238
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Basic Traditional Animation

Toon Boom Animate lets you animate traditionally, but work entirely digitally. Many tools and features are
supplied to help you achieve that traditional animation look easily and efficiently.

Related Topics
•

Animating below

•

Cleaning Up on page 251

•

Setting the Timing on page 253

Animating

Now that you know about the existing tools, you can start your animation.
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Basic Traditional Animation

The first step to complete is the rough animation, which is the skeleton of your animation. You would usually
start with the main action. For example, to animate a walk-cycle, you will start with the torso moves and the legs.
Head, arms and clothes will be added later, during the secondary animation.
For a satisfactory animation, complete the main action before adding all of the details. If you start animating all
of the details right away, you will lose a lot of time if you have to do corrections, and your animation will often
look too rigid.
To animate:
1. In the Preferences panel, you can set your preferences to Use Current Frame as Drawing Name. Refer to
Exposure Sheet on page 272 to learn more about this preference.
2. In the Tools toolbar, select the Brush

tool or press [Alt] + [B].

3. In the Colour view, select the colour you will use to draw. It is a good idea to choose a light colour for your
rough animation to help for the following task, the clean up process.

4. In the Timeline or Xsheet view, select the cell where the first drawing will appear.
5. In the Camera or Drawing view, draw the first key drawing.

6. Make sure your first key drawing is still selected, and in the Mark Drawing toolbar, click on the Mark
Selected Drawings as Key button.
‣

In the Xsheet view, you can also select Animation > Mark Drawing As > Key Drawing to identify your
drawing.
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7. In the Tools toolbar, click on the Enable Onion Skin

button.

8. In the Timeline view, click and drag the onion skin blue markers to extend the number of previous and
next visible drawings to fit your need.

9. In the Timeline or Xsheet view, select the cell where your next key drawing will appear.

10. In the Camera or Drawing view, draw your second key drawing.

11. In the Xsheet view, identify the drawing as a key drawing.

12. In the Xsheet view, select a cell between your two key drawings.
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13. From the Timeline View toolbar, click
‣

Basic Traditional Animation

to create an empty drawing or press [Alt] + [Shift] + [R].

In the Xsheet view, right-click and select Drawings > Create Empty Drawing or press [Alt] + [Shift] +
[R].

14. Draw your new drawing.

15. If necessary, in the Xsheet view, identify the new drawing as a Key, Breakdown or In-between drawing.

16. In the Timeline or Xsheet view, select a new cell and repeat step 9 to step 15 for each new drawing.
17. In the Timeline view, disable the layers you do not want to show during playback.
18. In the Playback toolbar, click on the Loop
19. In the Playback toolbar, click on the Play

button if you want the playback to loop.
button to start the animation.

Related Topics
•

Cleaning Up on the next page

•

Setting the Timing on page 253
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Cleaning Up

When your rough animation is ready, it is time to clean it up and ink it. The clean-up is also called tracing. It
consists of tracing solid and clean lines over the rough animation to get closed zones. This is the final paperless
animation step before the ink and paint step.
You will need to add a new drawing layer to draw your clean. This is the equivalent of adding a sheet of paper
and tracing the rough using the animation disk.

If you plan on tracing your animation in the Drawing view, you will need to enable the Light Table
feature in order to display all the layers of your project.

To trace your animation in a new layer:
1. In the Timeline View toolbar, click on the Add Drawing Layer

button.

2. In the Timeline view, click the lock icon of the layer containing your rough animation to prevent selecting
the layer in the Camera view.

3. In the Timeline or Xsheet view, select the new layer’s cell corresponding to the first key drawing of your
rough animation.
4. In the Tools toolbar, select the drawing tool of your choice. We recommend the Pencil

tool.

5. In the Colour view, select the colour you will use to trace your animation. Pick a dark bold colour such as
black to make sure it contrasts well with the light colour of your rough animation.
6. In the Camera or Drawing view, start tracing the first key drawing.
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7. If you have some other layers in the way, you can disable them temporarily from the Timeline view so that
only your rough animation and your clean up layer are displayed in the Camera view.
8. In the Tools toolbar, click on the Enable Onion Skin

button and extend the Onion Skin In the Timeline

view.

9. In the Timeline or Xsheet view, select the next cell corresponding to a rough drawing.
10. In the Camera view, trace your next drawing.

11. Repeat the previous steps for each drawing.

This method allows you to keep the roughs and the cleans intact. You only need to disable the rough
layer to prevent it from appearing in the scene.
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Related Topics
•

Animating on page 247

•

Setting the Timing below

Setting the Timing
Refer to the following topics in the Timing on page 339 chapter to learn how to set the timing of
your animation:

•

Filling Exposure on page 379

•

Filling Exposure Mode on page 379

•

Typing Exposure on page 380

•

Extending a Single Exposure on page 382

•

Extending an Exposure Sequence on page 382

•

Dragging Cells on page 384

•

Increasing and Decreasing Exposure on page 386

•

Deleting Exposure on page 389

•

Inserting Blank Cells on page 390

•

Setting the Exposure on page 391

•

Filling a Selection with a Single Exposure on page 392

•

Filling a Selection with a Sequence on page 393

•

Filling a Selection Randomly on page 395

•

Creating Cycles on page 396

Related Topics
•

Animating on page 247

•

Cleaning Up on page 251
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Advanced Traditional Animation

Toon Boom Animate has many useful features such as the Flipping toolbar, enhanced Onion Skin, extra drawing
layers, automated matte and more.

Related Topics
•

Flip and Easy Flipping Toolbars below

•

Onion Skin Toolbar on page 256

•

Shift and Trace on page 258

•

Drawing Layers on page 268

•

Multiple Drawings in the Drawing View on page 269

Flip and Easy Flipping Toolbars
Toon Boom Animate provides a Flip feature which allows you to rapidly flip through the drawings as one would
with paper drawings. You can flip through the Key, Breakdown or In-between drawings individually, or view a
combination.

The Flipping features only work in the Drawing view.

To flip through your drawings:
1. In the top menu, select Window > Toolbars > Easy Flipping and Flip.

254

Toon Boom Animate 3 User Guide

2. In the Easy Flipping toolbar, click on the Previous

or Next

button to see the previous or next

drawing of your animation.
3. Enable the Loop option to loop your animation during the flip. This way, when you reach the end of your
animation, the first drawings will show up again.

4. Move the slider to the right to flip forward and to the left to flip backward through your drawings.

‣

The more that you move the slider to the left or the right, the faster the drawings will flip.

5. If you marked some of your drawings as Key, Breakdown or In-between, you can flip through the markers
and avoid seeing all the in-betweens. Enable the Flip Key, Breakdown or In-between option in the Flip
toolbar, to see only one type or a combination. See Drawing Identification on page 241.

Related Topics
•

Drawing Identification on page 241

•

Advanced Traditional Animation on the previous page
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Onion Skin Toolbar

You can setup your onion skin to display only the marked drawings, in the same way that you flip through your
drawings marked as Key, Breakdown or Inbetween drawings. See Drawing Identification on page 241.

This Onion Skin feature only operates in the Drawing view.

To display the marked drawings in the onion skin:
1. In the top menu, select Window > Toolbars > Onion Skin.

2. In the Tools toolbar, enable the Onion Skin

feature.

3. In the Timeline view, pull on the blue arrows to extend the number of drawings displayed in the onion skin
preview.

4. In the Onion Skin toolbar, enable the markers you want to see in your Onion Skin preview.
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Related Topics
•

Drawing Identification on page 241

•

Enabling the Onion Skin in Other Layers below

•

Advanced Traditional Animation on page 254

•

Flip and Easy Flipping Toolbars on page 254

Enabling the Onion Skin in Other Layers
Sometime, you might need to refer to previous and next drawings in other layers than the current one. You can
activate the Enable Onion Skin in Other Elements option to see the previous and next drawings of the layers
visible in Light Table mode.

This Onion Skin feature only operates in the Drawing view.

To enable the onion skin in other layers:
1. In the top menu, select Window > Toolbars > Onion Skin.

2. In the Tools toolbar, enable the Onion Skin

feature.

3. In the Drawing view, enable the Light Table

option. This option is not available in the Camera view.

4. In the Timeline view, pull on the blue arrows to extend the number of drawings displayed in the onion skin
preview.
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5. In the Onion Skin toolbar, enable the Enable Onion Skin in Other Elements option.

‣

By default, layers located on top (in the Timeline view) of the current layer will be displayed as shades
of blue.

‣

By default, layers located below (in the Timeline view) of the current layer will be displayed as shades
of yellow.

‣

By default, the current layer will be displayed in shades of green and red.

You can change the Onion Skin display default colours in the Preferences panel. See General > Edit
Colours on page 271.

Related Topics
•

Advanced Traditional Animation on page 254

•

Flip and Easy Flipping Toolbars on page 254

•

Onion Skin Toolbar on page 256

Shift and Trace
When animating traditionally, it is very important to stay on model. Losing the proportions or features of a
character is easy to do. The Shift and Trace feature makes it possible to temporarily move a drawing so that you
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can trace it on another one. This is similar to animators working on an animation light table and using cut-out
pieces of a character to move it underneath the new drawing and trace it.
The Shift and Trace option will not modify your drawing, it will only allow it to be moved, rotated or scaled in the
Shift and Trace mode. As soon as you disable the Shift and Trace option, the repositioned drawing returns to its
normal state.

If you use the Shift and Trace feature a lot, you can assign custom shortcuts to the following
operations:
•

Shift and Trace Drawing Move Down

•

Shift and Trace Drawing Move Up

•

Shift and Trace Drawing Reset Position

•

Shift and Trace Drawing Toggle Peg State

•

Shift and Trace Drawing Toggle Visibility

•

Shift and Trace Move Tool

•

Shift and Trace Rotate Tool

•

Shift and Trace Scale Tool

•

Shift and Trace Toggle Manipulator

•

Shift and Trace Toggle View

Refer to Customizing a Keyboard Shortcut on page 58 to learn how to customize keyboard shortcuts.

To shift and trace:
1. In the Tools toolbar, enable the Onion Skin

feature.

2. Open a Drawing view.
3. In the Xsheet view, select the range of drawings you need to shift and trace. This selection should include
at least the layer containing the piece you need to trace and the new drawing in which you will trace.

4. In the Xsheet view, right-click on your drawing selection and select Drawings > Send to Drawing view.
The selected drawings are sent to the Thumbnail view which appears in the Drawing view.
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The Thumbnail view is situated by default on the right side of the Drawing view. You can change its
positioning via the Preferences panel.

5. Press on the Shift and Trace Enable

button to enable the option.

Registration holes appears at the bottom of your drawings.

At the bottom of the Drawing view, a close up window appears to display the registration marks up close
to be able to move and reposition them easier if you are zoomed out quite a bit while working on your
drawings.

260

Toon Boom Animate 3 User Guide

6. Select the Shift and Trace

tool.

7. Enable the Onion Skin. Select View > Onion Skin > Show Onion Skin or press [Alt] + [O].
8. If not done already, enable the check box corresponding to the drawing you want to allow to be
transformed temporarily. All drawings are enabled for Shift and Trace operations by default.

9. Select the drawing you want to move.

10. If you want to draw more than one drawing at once, you can link them together. In the Shift and Trace
panel, select several drawings and click on the Link Drawings and Unlink Drawings buttons to lock their
position together.

11. In the Drawing view, transform the drawing as needed, to position it between you two key poses:
‣

To reposition, click and drag the drawing to a new area.

‣

To rotate from the centre peg, click on the flat peg hole and rotate.
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‣

To scale, pull or push on the triangle control.

‣

Hold [Alt] to show the pivot point. The pivot point is situated in the middle of your current drawing
view. To rotate from the pivot point. Hold [Alt] and rotate
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‣

To scale from the pivot point, hold [Shift] and move your cursor.

‣

Click and drag the pivot point to move it to a new position. Once the pivot point have been moved,
you need to hold [Alt] and move your drawing in order to show it again.
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12. Once your drawing is repositioned, select the drawing into which you want to trace.

13. Select the drawing tool of your choice.
14. In the Drawing view, trace your drawing.

15. If you want to select another drawing and reposition it, you can hold down [Ctrl] (Windows) or [⌘ ] (Mac
OS X) and click on the Shift and Trace Registration marks (Peg holes).

16. If necessary, click on the Shift and Trace Reset

button to reset the position of the modified drawing.

17. Right-click in the drawing list column and select Remove All Drawings to close the drawing list.
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‣

To remove one, or several, drawings from your selection without clearing the entire list, select the
drawings you want to remove using [Ctrl] (Windows) or [⌘ ] (Mac OS X), right-click in the drawing list
column and select Remove Selected Drawing.

Related Topics
•

Shift and Trace Linked Drawings below

•

Enabling and Disabling Individual Drawing Shift and Trace Onion Skin on page 267

Shift and Trace Linked Drawings
When using the Shift and Trace feature, you can link different drawings from the Drawing List so that they move
together when dragging or scaling. These drawings can be from different columns in the Xsheet view. Bars in
differing colours will appear beside the chain link icon to easily identify different linked groups.
To link your Shift and Trace Drawings:
1. In the Drawing view's Thumbnail area, display the drawings you want to use to perform your Shift and
Trace operation.
2. In the Thumbnail area, hold down [Ctrl] (Windows) or [⌘ ] (Mac OS X) and select the drawings your want
to link together.
3. In the Thumbnail area's toolbar, click on the Link Drawings button to link your selection.

A coloured bar and a link icon appear beside the linked drawings.
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4. Enabling the Shift and Trace feature, move your linked drawings.

5. If you want to unlink your drawings, in the Thumbnails area, select one of the linked drawings and click on
the Unlink Drawing button.

6. You can now move your drawings independently.
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Related Topics
•

Shift and Trace on page 258

Enabling and Disabling Individual Drawing Shift and Trace Onion
Skin
It is possible that you would end up with a lot of drawings in your onion skin display while working with the Shift
and Trace feature. You can disable individual drawings from the Onion Skin display without deactivating them.
To enable and disable individual drawing shift and trace onion skin display:
1. In the Tools toolbar, enable the Onion Skin

feature.

2. In the Drawing view’s Shift and Trace panel, click on the drawing’s onion skin icon to enable or disable it.

Related Topics
•

Shift and Trace on page 258
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Drawing Layers
Toon Boom Animate has two layers included in its drawings that is only available in the Advanced
Art Mode:
•

Line Art below

•

Colour Art below

1. In the Camera or Drawing view bottom toolbar, click on either the
Line Art
and Colour Art
buttons.
2. Click on the Preview

button to display all the layers together.

Line Art
In traditional animation, you mainly use the Line Art layer to trace and clean up your animation. The outline is
drawn in the Line Art layer and you paint in the Colour Art layer.

Colour Art
In traditional animation, you use the Colour Art layer to paint your animation. The outline is drawn in the Line Art
layer and you paint in the Colour Art layer. You need to generate invisible lines out of your Line Art to be able to
do so.
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Multiple Drawings in the Drawing View
If you only want to work on a portion of an animation sequence or many drawings from different layers, you can.
To do this, select the segment needed in one or more layers in the Xsheet or Timeline view and then, use the
Send to Drawing View and Add Drawings to Drawing View options to send the selection to the Drawing view
and allow you to work only on these drawings.
To send several drawings to the Drawing View:
1. In the Xsheet or Timeline view, select a consecutive cell range from one or several layers. In the Xsheet
view, using [Ctrl] (Windows) or [⌘ ] (Mac OS X), you can click on any cell to add it on the selection, even if it
is not consecutive.

2. In the Timeline View or Xsheet View menu, select Drawings > Send to Drawing View. In the Xsheet view,
you can also hold down the [Alt] key and click on the selection.
The drawings appear at the side of the Drawing view.

3. If the Drawing view side panel is hidden, click on the Arrow button, located to the right side of the view.
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4. If you want to add some extra drawings to the Drawing view without having to start over, in the Xsheet
view, select the desired drawings to be added.
5. In the Xsheet View menu, select Drawings > Add Drawings to Drawing View or press [Alt] + click.
6. If you want to send a new drawing selection to the Drawing view and remove the current one, select a new
range of drawings in the Timeline or Xsheet view.
7. In the Timeline View or Xsheet View menu, select Drawings > Send to Drawing View.
8. To change the size of the thumbnails displayed in the side panel, right-click in the side panel and select No
Thumbnail, Small Thumbnail, Medium Thumbnail or Large Thumbnail.
9. To empty the drawing list accumulated in the Drawing view, right-click in the side panel and select
Remove Selected Drawings or Remove All Drawings.

Related Topics
•

Advanced Traditional Animation on page 254
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Traditional Animation Preferences
When animating traditionally in Toon Boom Animate, there are preferences you can set to help you work more
efficiently.
To open the Preferences panel:
‣

Windows: Select Edit > Preferences.

‣

Mac OS X: Select Animate > Preferences.

‣

Or press [Ctrl] + [U] (Windows) or [⌘ ] + [U] (Mac OS X).

Related Topics
•

General > Edit Colours below

•

Exposure Sheet on the facing page

General > Edit Colours
You can change the colours for the Onion Skin for Other Elements option.

Edit Colours for Onion Skin in Other Elements
To change the onion skin display colour:
1. In the Preferences panel, go to the General tab.
2. In the General tab, click on the Edit Colours button.
3. In the Edit Colours window, go to the Drawing tab.
4. In the Drawing tab, in the Onion Skin section, click on the colour swatch of the onion skin display you want
to change.
5. In the Colour Picker window, select the colour.
6. Click OK to confirm the colour.
7. Click OK to confirm and close the Edit Colours window.
8. Click OK to confirm the changes and close the Preferences panel.
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Refer to Enabling the Onion Skin in Other Layers on page 257 to learn more about the Onion Skin
for other Layers option.

Related Topics
•

Exposure Sheet below

Exposure Sheet

Current Frame as Drawing Name
The Current Frame as Drawing Name option can be enabled in the Preferences panel, under the Exposure Sheet
tab. Use this preference to automatically name the drawing corresponding to the frame position, this avoids
numbering conflicts while animating.

For example, using the default preferences, you start with the first drawing on frame 1, this drawing is called 1.
You then draw the extreme position drawing on frame 10, this drawing is called 2. Next, the in-between pose is
drawn on frame 5, this drawing is called 3 and so on.
At the end, you have a sequence like this: 1-9-4-6-3-8-5-7-10-2.

Instead, using the Use Current Frame as Drawing Name preference, each drawing is automatically named by its
frame number and the sequence looks like: 1-2-3-4-5-6-7-8-9-10.

Related Topics
•

General > Edit Colours on the previous page
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Chapter 6: Colour

With Toon Boom Animate, you can add colour to your projects and even create sets of colours for your
characters. With Toon Boom Animate’s colour palette concept, painting and colour styling has never been
easier!

Topics Covered
•

How to Paint on the facing page

•

Colours on page 276

•

Colour Display Modes on page 286

•

Selecting the Current Colour of a Tool on page 288

•

Painting Using the Paint Tool on page 290

•

Painting Pencil Lines with the Ink Tool on page 298

•

Selecting a Colour in a Drawing on page 302

•

Editing Gradients and Textures on page 304

•

Closing Gaps Manually on page 310

•

Protecting Colours on page 313

•

Line Art and Colour Art Layers on page 314

•

Verifying Zones are Painted on page 318

•

Palettes on page 319

•

Colour Model on page 331

•

Colour Preferences on page 336
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How to Paint
Learn how to paint your drawings by following these instructions.
To paint your drawings:
1. In the Tools toolbar, select the Paint

tool or press [Alt] + [I].

2. In the Colour view, select a colour from the palette.
‣

Double-click on a colour swatch to open the Colour Picker window and modify the colour.

The colour palette will only appear in the Colour view once a drawing element has been selected.

3. In the Camera or Drawing view, start painting the colours on your drawing.
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Related Topics
•

Colours on the facing page

•

Colour View on page 83
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Colours
Toon Boom Animate has some very powerful colouring features when it comes to painting. To paint your
drawings you will use different colour swatches, unlike some paint programs where you modify one swatch each
time you want to paint with a different colour.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You
can add as many swatches as you want. You can also rename them and modify existing ones.

When you modify the colour of an existing swatch it automatically updates all the zones painted with this swatch
throughout the entire project. The colour swatch has a unique ID number that associates it with the painted
zones. This way, you can change the look of your character at anytime without having to repaint it!

Related Topics
•

Adding a Colour Swatch below

•

Deleting a Colour Swatch on page 284

Adding a Colour Swatch
You can use three different types of colour swatches, these are described in the following sections:
•

Solid Colour Swatch on the next page
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•

Default Colour Swatch on page 279

•

Gradient Colour Swatch on page 280

•

Bitmap Texture Swatch on page 282

Solid Colour Swatch

To add or modify a solid colour swatch:
1. In the Colour view, click on the New Colour

button.

2. In the Colour View menu, select Colours > Edit. You can also double-click on the colour pot.
The Colour Picker window opens.

3. To set your colour:
‣

In the colour wheel, select the desired colour.

OR
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‣

Type in the HSV or RGB values in the corresponding fields. Click on the R,G,B,H,S or V radio buttons
to change the look of the colour picking area.

OR
‣

Click on the Dropper
button to select any colour on your screen. It can be from the Toon Boom
Animate’s interface, your Operating System or any other open application.

You can also click on the Multi Wheel Mode button to open the Multiwheel Colour dialog box. This
displays all the picking area styles together and also contains a picking undo list. Click on the Single
Wheel Mode button to go back to the regular Colour Picker window.
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4. If needed, click on the Shade Scale’s swatches to modify the shade of the selected colour.

5. If necessary, adjust the desired level of transparency with the Alpha slider, or type the value directly in the
Alpha field.

6. If necessary, click on the Add button to add the current selected colour to the Colour Storage Library, so
you can quickly access it later.

7. You can rename the colour swatch in the Colour Picker window or directly in the colour list by doubleclicking on its name.

Default Colour Swatch
In Toon Boom Animate, when you click on the Add Colour

button, a new colour swatch is created using the

colour of the currently selected swatch from your palette. However, you can set a Default colour to be used
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every time you create a new colour in your colour palette. This might be useful if you want to create different
shades of the same basic colour.
To change the default swatch colour for all your colour palettes:
1. In the top menu, go to Edit > Preferences (Windows) or Animate > Preferences (Mac OS X).
2. In the Preferences panel, under the Drawing tab, enable the Create New Colour Pot Using the Default
Colour option. In addition, You can click on the colour swatch, located just beside, to change the Default
colour.
The default colour is also the colour used when you choose to vectorize images that you are scanning into your
scene, however you add the Default colour swatch to your palette in a different way, so that it is unique. It has a
unique ID number that makes it recognizable from all the other colours in your colour palettes. Being able to
change this colour allows you to change the basic colour of all scanned drawings. This can be useful on more than
just an aesthetic level as sometimes when you go to NTSC or PAL, pure colours, such as pure black, can create
problems.

To add a new colour swatch using the default colour:
1. In the Colour View menu, select Colours > New.
A new swatch will be added to your palette using the default colour pot colour. The new swatch created
with the New command will be named New 0.

Refer to Colour Preferences on page 336 to learn more on the Create New Colour Pot Using The
Default Colour preference and how to customize the default colour pot colour.

Gradient Colour Swatch
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To create a gradient colour swatch:
1. In the Colour view, select the colour to be modified.

2. In the Colour View menu, select Colours > Edit. You can also double-click on the colour pot.
The Colour Picker window opens.

3. Enable the Gradient option.

4. Select the Linear or Radial option.
5. Select the Gradient arrows to modify the colours.

‣

Click between the arrows to add extra colours.

281

Chapter 6: Colour Colours

‣

Pull down the arrows to remove them.

‣

Move the arrows left and right to modify the gradient distance.

Refer to the Editing Gradients and Textures on page 304 topic to learn how to reposition your
gradient zones in your drawings.

Bitmap Texture Swatch

To create a texture colour:
1. In the Colour View menu, select Colours > New Texture or click on the New Texture
The Browser window opens.
2. Browse for a PSD or TGA bitmap file created in a third party software.

3. Click on the Open button to create the colour swatch.

282

button.

Toon Boom Animate 3 User Guide

Refer to the Editing Gradients and Textures on page 304 topic to learn how to reposition your
textured zones in your drawings.

You can also replace a texture once it is painted. If you decide to make the character’s shirt wool instead of
plaid, just update the texture file in the swatch and the entire project updates. Any transformation previously
applied to the texture’s position in your drawings will be kept.

To replace a texture swatch:
1. In the Colour view, select the texture swatch you want to change the embedded bitmap texture file in.

2. In the Colour View menu, select Colours > Edit Texture. You can also double-click on the swatch.
The Browser window opens.
3. Browse for the new PSD or TGA bitmap file created in a third party software.
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4. Click on the Open button to update the colour swatch.

Related Topics
•

How to Paint on page 274

•

Deleting a Colour Swatch below

Deleting a Colour Swatch
To delete a colour swatch:
1. In the Colour view, select the colour swatches to delete.

2. In the Colour View menu, select Colours > Delete. You can also click on the Delete Colour

button.

The default keyboard shortcut is [Delete].
If the colour swatch is used in a drawing, the Delete Colour dialog box opens.

3. Click OK to delete the colours or click Cancel to abort the operation.
‣

If you delete colour swatches already in use, the zones painted with them turn red so you can easily
identify them.
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Related Topics
•

Adding a Colour Swatch on page 276
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Colour Display Modes
This section describes the colour modes.
•

Switching Between Thumbnails and List Display modes below

•

Displaying Colour Values below

Switching Between Thumbnails and List Display
modes
The Colour view has two display modes:
•

List Mode

•

Swatch Mode

To toggle between the display modes:
1. In the Colour View menu, select Colours > Swatch Mode.
‣

Enable the option to display the swatches.

‣

Disable the option to display the colour list.

Displaying Colour Values
When using Toon Boom Animate, you can display the RGB values and names of your solid colour swatches.

This option is not available when displaying the colours in Swatch mode.
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To display the swatch colour values:

‣ In the Colour View menu, select Palettes > Display Colour Values.
The solid colour swatches’ RGB values will be displayed between the colour swatch and its name. The
gradient colour swatches will be identified as (gradient).

Related Topics
•

Colour View on page 83
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Selecting the Current Colour of a Tool

While drawing and painting, you can let Animate retain the last colour you selected for each one of the following
tools:
•

Brush

•

Paint

•

Pencil, Ellipse, Line, Rectangle, Polyline

The Colour view has three swatches where you can set a colour for the Brush

, Paint

and Pencil

tools.
To unlink the storage swatches:
1. In the Colour view, if the storage swatches are linked, click on the Linking

s
2. Click on the Brush

storage swatch.

3. In the Colour list, select the desired colour.
4. Click on the Pencil

storage swatch.

5. In the Colour list, select the desired colour.
6. Click on the Paint

storage swatch.
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7. In the Colour list, select the desired colour.

If you prefer not to use this behaviour and have Toon Boom Animate use the same colour swatches regardless of
the selected tool, you can link the three swatches together.
To link the storage swatches:
1. In the Tools toolbar, select one of the following tool:
‣

Brush tool

‣

Paint tool

‣

Pencil tools:
•

Pencil tool

•

Polyline tool

•

Line tool

•

Ellipse tool

•

Rectangle tool

2. In the Colour view, if the storage swatches are linked, click on the Linking

button to link them.

Each time you select a new colour for your current tool, all the storage swatches are updated.

Related Topics
•

How to Paint on page 274
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Painting Using the Paint Tool

The main tool you will use to paint your drawings with is the Paint

tool. The Paint tool can be used in several

different modes, these can be customized in the Tool Properties view.
The Paint tool paints closed zones, this includes brush strokes, as well as pencil lines. If you have gaps in the lines
defining a zone, you will have to close them using either the Brush, Pencil, Close Gap tools or the Automatic
Close Gap option.
To paint with the Paint tool:
1. In the Timeline or Xsheet view, select the cell where you want to paint.

2. In the Tools toolbar, click on the Paint

tool or press [Alt] + [I]. You can also select the Paint tool in the

top menu under Drawing > Tools > Paint.
3. In the Colour view, select a colour.

4. In the Camera view, start painting. You can click on a zone or pencil line to paint it, or you can trace a lasso
or marquee selection to paint several zones or pencil lines at once.

The last colour you select while using the Paint tool will be remembered the next time you select the
Paint tool.
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Related Topics
•

Paint Tool Properties on the facing page

Create Breaking Triangles to Paint Brush Strokes
The Brush tool is often the most intuitive and rapid tool for creating rough sketches and clean lines. A single
colour, such as black, is often used when tracing a clean version of a rough sketch. However, when it comes time
to soft trace the lines in different colours, the flattened or unflattened clean brush strokes can suddenly become
time consuming to ink.
Toon Boom Animate provides a solution by creating triangular breaks at natural line intersections. These
intersections are the probable locations of where colour line breaks may occur, such as where a sleeve meets a
hand.
To create breaking triangles on a drawing:
1. In the Camera or Drawing view, use the Select tool to select part or all of the drawing to be broken.

2. In the top menu, select Drawing > Create Breaking Triangles. If your brush strokes are not flattened,
they will be flattened automatically before the breaking occurs.

3. Use the Repaint tool

to paint the outline of different colour zones with different colours.
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Paint Tool Properties
When you select the Paint tool, its properties and options appears in the Tools Properties view.

•

Lasso and Marquee below

•

Painting Mode on the next page

•

Automatic Close Gap on page 294

•

Paint and Remove Texture on page 295

•

Apply to Multiple Drawings on page 295

•

Apply to All Visible Drawings on page 296

•

Respect Protected Colour on page 296

•

Use Stored Colour Gradient on page 297

•

Select Newly Painted/Repainted/Unpainted Contours/Lines on page 297

Lasso and Marquee
The Lasso and Marquee options let you choose what type of selection the Paint tool will do when you will click
and drag your cursor to paint your drawings. The default selection mode is Marquee.
•

The Marquee

option makes a rectangle selection box. Everything inside the selection will be painted

according to the painting mode you selected.
•

The Lasso

option lets you draw a custom selection box around the zones to be painted. Everything

inside the selection will be painted according to the painting mode you selected.
Hold down the [Alt] key to switch to the opposite mode of your selection.
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Painting Mode
The Paint tool has four different modes available:

Paint Mode
Paint Unpainted Mode
Repaint Mode
Unpaint Mode
You can also find these tools directly in the Tools toolbar and in the Drawing Tools menu.

Paint Mode

The Paint

mode paints everything it touches, including empty and filled zones.

Paint Unpainted Mode

The Paint Unpainted

mode paints only empty zones. Any line or filled zone will remain unchanged.
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Repaint Mode

The Repaint

mode paints everything it touches except empty zones. Any zone that is not painted will remain

intact.

Unpaint Mode

The Unpaint

mode unpaints everything it touches, including empty and filled zones.

Automatic Close Gap
The Automatic Close Gap option has four modes available:

The Automatic Close Gap

option is used while painting drawings with small gaps. Instead of having to close

them manually either with the Brush tool or Close Gap tool, Toon Boom Animate will analyze the drawing and
close the gaps while you paint according to the selected mode.
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The automated gap closing should be done using the zoom function setting of your Camera or Drawing view. If
your eye does not see the gap, Toon Boom Animate won’t either.

Paint and Remove Texture

The Paint and Remove Texture

option is used when you vectorized some images as greyscale texture style.

An image vectorized as texture is a mix of bitmap filling encapsulated in a vector based frame. Painting a
textured zones with the Paint tool will change the tint of the textured lines. Painting the textured zones using the
Paint and Remove Texture option transforms the bitmap filling into a 100% vector based zone and fills it with a
solid colour.

Apply to Multiple Drawings
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The Apply to Multiple Drawings

option is used for hand-drawn animation fast painting. When you want to

paint several drawings in a same layer at once, such as a walk cycle, you can enable this option and make a
selection in your Camera or Drawing view. All the closed zones located within your Paint tool selection are
painted with the selected colour swatch.
You do not need to enable the Onion Skin preview to use this option. The option will stay enabled only for the
next action. If you want to use it again, you must click on the Apply to Multiple Drawings button again, or press
[Alt] + [A].

Apply to All Visible Drawings

The Apply to All Visible Drawings

option is used to paint several drawings on separated layers on the

current frames. If you have a character broken in several layers, you can enable this option to paint all your layers
at once. The operation is only applied on the current frame.
The option will stay enabled only for the next action. If you want to use it again, you must click on the Apply to
All Visible Drawings button again.
This option is only available in the Camera view and does not affect symbols.

Respect Protected Colour
The Respect Protected Colour

option is enabled by default. In your Colour view, you can protect some

colour swatches to avoid repainting or unpainting the zones linked to that swatch.
If you disable this option the Paint tool will not follow the protect colour rule and will repaint or unpaint the
protected colours on your drawings until you enable the option again.

Refer to the Protecting Colours on page 313 topic to learn how to lock your colours.
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Use Stored Colour Gradient

When you paint a zone with a gradient or textured colour swatch, the gradient or texture’s position is set
relative to the size of the zone your are painting. If you want the Paint tool to use a particular size and position,
you must first store your desired position and size using the Select
tool and then enable the Use Stored
Colour Gradient

option in the Paint tool Tool Properties view.

Refer to the Storing Your Favourite Gradient or Texture Settings on page 308 topics to learn how to
store your gradient or texture position.

Select Newly Painted/Repainted/Unpainted Contours/Lines

In the Paint

tool Tool Properties view, engaging this option will keep a selection highlighted around the

latest painted zone after using either the Paint, Repaint, Unpaint, or Paint Unpainted tool.

Related Topics
•

Painting Using the Paint Tool on page 290
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Painting Pencil Lines with the Ink Tool
Although pencil lines can be painted in much the same way as closed zones, you can use the Paint, Repaint,
Repaint Brush, and Ink tools to make painting segmented lines easier.
Normally when you have a drawing, such as the one below, and you use the Paint tool to paint one of the lines,
the entire line is painted.

However, if you select the Ink

tool instead and click on the same pencil line, only the segment that you

clicked on between two intersections will be painted.

The newly inked segment will always be moved to the front of all other pencil strokes, even if it was behind all
other pencil strokes before it was inked.

That is, unless you hold down [Alt] while clicking a segment. Then the opposite becomes true. The inked segment
will be sent to the back, even if it was in front of all other segments to begin with.
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Painting and Inking can be used in combination depending on what it is that you need to paint. If you need to ink
a character’s outline in black, it might be easier to use the Paint tool. If you need to paint the outline of a
character’s neck with a tan colour and its shirt outline blue and both the neck and shirt belong to the same
continuous outline, then the Ink tool might prove more useful.

Related Topics
•

Ink Tool Properties below

Ink Tool Properties
When you select the Ink tool, its properties and options appears in the Tools Properties view.

•

Lasso and Marquee below

•

Show Inkable Lines on the facing page

•

Be Smart on Connecting Lines on the facing page

•

Select Mode on the facing page

•

Arrange Ink Lines on the facing page

•

Mitre on the facing page

•

Tip Style on the facing page

Lasso and Marquee
The Lasso and Marquee options let you choose what type of selection the Paint tool will do when you will click
and drag your cursor to paint your drawings. The default selection mode is Marquee.
•

The Marquee

option makes a rectangle selection box. Everything inside the selection will be painted

according to the painting mode you selected.
•

The Lasso

option lets you draw a custom selection box around the zones to be painted. Everything

inside the selection will be painted according to the painting mode you selected.
Hold down the [Alt] key to switch to the opposite mode of your selection.
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Show Inkable Lines
The Show Inkable Lines

option highlights all pencil lines (so no brush strokes) on the selected layer. Pencil

line segments that are already inked with the selected swatch colour from the colour palette are also not
highlighted.

Be Smart on Connecting Lines
With this

option selected, as you hover and move the cursor across intersecting pencil lines, the path that

you create will get highlighted. When you click on your mouse or stylus the highlighted segments will get inked.
With this option disabled, all the intersecting segments that your cursor comes near will get highlighted and
become part of the selection, even if they were not situated in the direction of the chosen path.
This option only works if the Ink tool is in Hover Mode and not Select Mode.

Select Mode
Use this

mode instead of the Hover Mode. In the Hover Mode, any potentially inkable pencil line will have

its central vector line highlighted as the Ink tool’s cursor hovers over it. Use [Ctrl] (Windows) or [⌘ ] (Mac OS X)
to toggle between the two modes.

Arrange Ink Lines
Use this

option to have every newly inked line be brought to the front. Disable this option to have every

newly inked line be sent to the back. Use [Alt] to toggle between the two options.

Mitre
As you hover over two perpendicular or nearly perpendicular segments a highlighted path with a corner is
created. Clicking on these highlighted segments inks both segments and makes them appear as a single stroke
with a corner or bend.
Click on the Mitre

button to reveal four options from its drop down menu. Select either Round, Mitre,

Bevel or As Is before creating corner selections to make a bend in the path either round, sharp, bevelled or
gapped.

Tip Style

Use the Tip Style option to customize the edge of the Ink tool.
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Related Topics
•

Painting Pencil Lines with the Ink Tool on page 298
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Selecting a Colour in a Drawing

While working in your Camera or Drawing view, you can use the Dropper

tool to pick a colour from your

drawing without going to the Colour view.
To use the Dropper tool:
1. In the Tools toolbar, select the Dropper

tool or press [Alt] + [D]. You can also select the Dropper tool

from Drawing > Tools > Dropper in the top menu.
2. In the Camera or Drawing view, click on the desired colour.
‣

If you are using another drawing tool such as the Paint tool, you can temporarily hold down the [D] key
and click in your drawing before releasing the key to pick your colour. Once you let go the hot key,
Toon Boom Animate will go back to your previous tool.

You may also want to select the zones painted with the colour currently selected in the Colour view. This can be
useful to remove rough lines from a clean drawing.
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To select the zones painted with the current colour:
1. In the Colour view, select the colour you want to select the corresponding zones from.

2. Select Drawing > Select Strokes with Current Colour.
Or press [Ctrl] + [Shift] + [A] (Windows) or [⌘ ] + [Shift] + [A] (Mac OS X).

Related Topics
•

How to Paint on page 274
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Editing Gradients and Textures

If you paint a zone or pencil line with a gradient or texture you can use the Edit Gradient/Texture

tool to

modify its position in the zone. You can move, scale, rotate and skew. If you have to match the transformations
performed on a gradient or texture from one zone or pencil line to many others, you can copy and paste the Edit
Gradient/Texture position. When moving to the next drawing, you can select the next texture and paste the
previous position to continue the modifications.
To use Edit Gradient/Texture tool on a zone:
1. In the Tools toolbar, select the Edit Gradient/Texture

tool. You can also select this tool from the top

menu under Drawing> Tools > Edit Gradient/Texture or press [Shift] + [F3].
2. Click on the Gradient or Texture zone to be modified.

‣

If you want to modify several areas at once, hold down the [Shift] key and click on the zones to be
modified.
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3. Move the edit texture’s anchor points to the desired result.
‣

If the same modification needs to be applied to another gradient in another drawing or texture zone,
you can select the modified zone and select Edit > Copy. Select the zone to be modified in the other
drawing and select Edit > Paste.

A pencil line can have its gradient, texture or texture’s gradient edited in two different ways, either with the
Pencil Editor
or with the Edit Gradient/Texture
tool.
To use Pencil Editor tool to edit the texture or gradient on a pencil line:
1. In the Tools toolbar, select the Pencil Editor

tool. You can also select this tool from the top menu

under Drawing > Tools > Pencil Editor or press [Alt] + [W].
2. Click on the pencil line to be modified to bring up its contour envelope.

3. Select one of the contour points around the envelope and move its position to change the size of the tiled
texture or gradient. You can also pull directly on the lines of the contour envelope or play with the bezier
handles of any given point in order to continue to modify the envelope form.
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Expanding the width of the envelope parallel to the pencil line’s central vector will cause the tiled texture
to be stretched. Conversely, reducing the envelope’s width will cause the tiled texture to look squashed.
Reducing the contour’s width perpendicular to the pencil line’s central vector will reduce the number of
tiles, while expanding it will increase the number of tiled images.

This editing technique does not just work on texture fills, but can also be applied to pencil lines drawn
with a textured “brush”.
To use Edit Gradient/Texture tool to edit the texture or gradient on a pencil line:
1. In the Tools toolbar, select the Edit Gradient/Texture

tool. You can also select this tool from the top

menu under Drawing > Tools > Edit Gradient/Texture or press [Shift] + [F3].
2. Click on the pencil line to be modified to bring up the editor controls.

3. The editor controls delineate a single tile in the texture. For gradients, this is less applicable. Pull on the
top of the editor controls to stretch the tiled texture throughout the length of the stroke.
As gradients are parallel to the stroke’s central vector, this will stretch the way that the gradient is
distributed in the pencil line’s envelope. The envelope still acts as a boundary for the texture or gradient.
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4. Drag the editor control perpendicular to the stroke. You will feel it glide along the strokes central vector
line. This is another way to resize the texture tile. Instead of stretching or shrinking it vertically, this
motion stretches or shrinks it vertically. As gradients are parallel to the pencil line’s central vector,
stretching them vertically gives no visual result.

This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawn with
textured “brushes”. If you then paint your textured pencil line with a gradient, you can do so and then edit both
elements independently at the same time.
To use Edit Gradient/Texture tool to edit both the texture and the gradient of a pencil line:
1. In the Tools toolbar, select the Edit Gradient/Texture

tool. You can also select this tool from the top

menu under Drawing > Tools > Edit Gradient/Texture or press [Shift] + [F3].
2. Click on the pencil line to be modified to bring up the editor controls.

3. Use the top editor controls edit the gradient.
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4. Use the bottom controls edit the “brush” texture.

Related Topics
•

Drawing Using the Pencil Tool on page 130

•

Storing Your Favourite Gradient or Texture Settings below

Storing Your Favourite Gradient or Texture Settings
If you are painting a hand-drawn animation or if your want the Brush tool and Paint tool to use your gradient’s
position, angle and scale settings instead of the default ones, you can store your own settings and reuse them
afterward.
To store your gradient and texture settings:
1. In the Tools toolbar, select the Select

tool or press [Alt] + [S].

2. In the Camera or Drawing view, select the gradient or texture zone to store.
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3. In the Tool Properties view, click on the Store Colour Gradient

button.

To use the stored gradient and texture settings:
1. In the Tools toolbar, select the Brush

or Paint

tool.

2. In the Tool Properties view enable the Use Stored Colour Gradient
3. In the Camera or Drawing view, draw and paint.

Related Topics
•

Editing Gradients and Textures on page 304
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Closing Gaps Manually

When painting, you will notice that some of your drawing areas are not closed. To close the zone you can either
draw the missing line with the Brush or Pencil tool, but you can also close the gap with an invisible line. To do so,
you will use the Close Gap
tool.
The Close Gap tool is used to close small gaps in a drawing. The Paint tool only paints closed areas. The Close
Gap tool will create a small, invisible stroke between the two closest points to close the colour zone. You do not
need to trace directly over the gap. You can draw it a few millimetres away and the Close Gap will automatically
choose the two closest points and close the gap.
To use the Close Gap tool:
1. In the Tools toolbar, select the Close Gap

tool. You can also select the Close Gap tool from the top

menu under Drawing> Tools > Close Gap or press [Alt] + [C].
‣

Enable the Auto-Flatten

option in the Tool Properties view if you want the stroke you will draw to

be flattened in your drawing instead to be on top.
‣

You can display the invisible lines with the Show Strokes option under View > Show Strokes or press
[K].

‣

If you do not display the strokes, a Message dialog box will appear.

Enabling the Don’t Show This Message Again option prevents this Message dialog box from appearing.
2. In the Camera or Drawing view, trace an invisible line near to the gap to be closed. The gap will
automatically close.
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Related Topics
•

Close Gaps below

•

How to Paint on page 274

Close Gaps
When you have too many gaps in your drawings, you can use the Close Gaps feature in Toon Boom Animate

1. Close Gaps slider: Use this slider to determine the size of the gap you want to be closed. Move the slider
to the left for smaller gaps and move it to the right for bigger gaps.
2. Apply to all drawings: Enable this option so that the Close Gaps feature is applied to all the drawings of
the selected layer.
To use the Close Gaps feature:
1. Select the Show Strokes option to see a preview of the result.
2. Select View > Show Strokes or press [K].
3. Select Drawing > Clean Up > Close Gaps or press[Shift] + [F10] (Windows only).
The Close Gaps dialog box opens.
4. Adjust the slider.

5. Select the Apply to all drawings option if needed.
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6. Click OK.

Refer to Colour Preferences on page 336 at the end of this chapter to learn more about the Close
Gap options.

Related Topics
•

Closing Gaps Manually on page 310
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Protecting Colours
When you are finished painting some zones, you can protect the colour swatch they are associated with so the
work cannot be accidentally painted over.
To use Protect Colour:
1. In the Colour view, select the colour to be protected.

2. In the Colour view menu, select Colours > Protect Colour. You can also right-click on the selected colour
and select Protect Colour.
A red bar will appear on the side of the colour, notifying you that it is locked.

Related Topics
•

Respect Protected Colour on page 296
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Line Art and Colour Art Layers
Toon Boom Animate has an option allowing you to paint the lines and the colour fills separately.
In Toon Boom Animate, a drawing is composed of two embedded layers:
•

Line Art Layer

•

Colour Art Layer

The Line Art and Colour Art layers are only available in the Advanced Art Mode.

You can draw and paint in all layers, but if you prefer working in a single layer, you can do everything in Line Art.
The main advantage of using the Line Art and Colour Art option is so you can repaint the lines easily. If your
colour fills are separated from the lines, it allows you to use the repaint tool and paint the lines without affecting
the colour zones. Also, it allows you to paint tones and highlights in line art and then add some transparency to
see the Colour Art through it.
To toggle between Line Art and Colour Art and enable the Preview mode:
1. In the Tools toolbar, select any drawing tool.
2. To toggle between Line Art and Colour Art:
‣

In the Drawing view,right-click and select Switch to Colour Art/Switch to Line Art or s[L].

‣

In the Drawing or Camera bottom toolbar, click on the Colour Art

‣

In the Drawing or Camera bottom toolbar, click on the Line Art

button.
button.

3. To preview the Line Art and Colour Art at the same time:
‣

In the Drawing view,right-click and select Preview Line Art and Colour Art. While using the Preview
mode, you still edit one mode at a time or press [Shift] + [P].

‣

In the Drawing or Camera bottom toolbar, click on the Preview

button. To be able to see only

one of the layers at a time in the Camera view, you must enable the Current Drawing on Top option,
available from the Camera bottom toolbar drop-down menu. If this option is not enabled, you will see
the final composition of all four layers.

Related Topics
•

Generating a Matte for Your Animation

•

Creating Strokes to Paint Your Drawings on a Separated Layer on the next page

•

Drawing Layers on page 268
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Creating Strokes to Paint Your Drawings on a
Separated Layer
You can use the outline you traced on one of the four embedded layers and create invisible strokes to paint your
drawings on separate layers, this provides more inking and painting flexibility.
To do so, you must use the Create Colour Art from Line Art option. You can also configure the option to create
the invisible strokes on any of the four embedded layers.

Make sure to enable the Advanced Art Mode in the Preferences panel in order to be able to use this
feature.

To create Colour Art zones out of the Line Art content:
1. In the Tools toolbar, select the Select

tool or press [Alt] + [S].

2. In the Camera or Drawing view, select the artwork to transfer to the Colour Art.

3. In the Drawing View toolbar, click on the Create Colour Art from Line Art
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To Configure the Line Art to Colour Art command settings:
1. In the Tools toolbar, select the Select

tool or press [Alt] + [S].

2. In the Tool Properties view, hold down the [Shift] key and click on the Create Colour Art from Line Art
button to open the Configure Line Art to Colour Art dialog box and modify the default settings of
this command.
The Configure Line Art to Colour Art dialog box opens.

3. Use rendered version of the drawing: This option will render the drawing and vectorize it to calculate the
position of the centreline that will produce the colour art stroke.
4. Maximum Resolution for rendered image: This is the size of the rendered image.
5. Threshold for rendered image: The value of grey processed to create the rendered vectorized arts.
6. Fitting error for generated Beziers: This value represents how precise the fitting of the colour art zone in
relation of the line art will be.
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7. Source Layer: In the Source Layer drop-down menu, select the layer (Line Art, Colour Art, Underlay or
Overlay) you want the strokes to be created from.
8. Destination Layer: In the Destination Layer drop-down menu, select the layer (Line Art, Colour Art,
Underlay or Overlay) you want the strokes to be created on.
9. Clear Destination Art Layer First: If you already have artwork on the destination layer and you want the
content to be deleted before the strokes are added into it, enable this option.
10. Perform Line Art to Colour Art Operation Immediately: Enable this check box to perform the Create
Colour Art from Line Art command when you click on the OK button of this window.

Related Topics
•

Line Art and Colour Art Layers on page 314
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Verifying Zones are Painted
When the painting process is completed, you should verify that each zone was painted correctly.
The Backlight feature produces a silhouette effect by changing the drawing’s coloured areas into a single dark,
solid colour use this to verify the completeness of the ink and paint process. Any unpainted zones can be seen as
the light shows through the unpainted areas of the silhouetted drawing.
To use the Backlight:

This feature is only available in the Drawing view.

1. In the top menu, select View > Backlight or press [Alt] + [Shift] + [B]. You can also click on the Backlight
button available in the Drawing View toolbar.
2. Verify the drawings in the Drawing view.

Related Topics
•

How to Paint on page 274

•

Painting Using the Paint Tool on page 290
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Palettes

In colour animation, specific colours are used to paint each particular character. In order to maintain absolute
consistency, a colour palette is created for each character, prop and effect throughout the production. These are
referred to as master palettes.
Master palettes contain a colour swatch for each zone to colour with a precise RGBA colour value.
Using a master colour palette has many benefits, including:
•

Each character consistently retains their dedicated colours.

•

You cannot accidentally use a colour which is not in the master palette.

•

Standardization and colour consistency throughout the production

•

Multiple artists can use the same colour palette and produce the same results.

Toon Boom Animate uses palettes to hold all of the colours needed to paint your elements, allowing complete
control and consistency in your painting process.
A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette
and add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, tongue,
shirt, pants, etc.
This topic is divided as follows:
•

Displaying the Palette List on the facing page

•

Creating a Colour Palette on page 321

•

Copying and Pasting Colours on page 322

•

Removing a Colour Palette on page 323

•

Duplicating a Colour Palette on page 324

•

Cloning a Colour Palette on page 325
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•

Mixing the Colours on page 327

•

Importing a Colour Palette on page 329

•

Ordering the Palette List on page 330

Displaying the Palette List
The Colour view has two modes: basic and advanced.

Basic Mode
The Colour view’s basic mode only shows the Colour list. When you open Toon Boom Animate, you only see the
colours available in the default palette. This default palette contains six basic colour swatches and is
automatically named the same as your scene. For simple projects, you can manage with the default palette, but
for movies, series or shorts it is recommended that you create palettes for your characters. To create a palette,
you have to switch to the advanced display of the Colour view and show the Palette list.

Advanced Mode
To create palettes for your characters, you must display the Palette list. Once you display the Palette list area, a
series of new buttons appear.
To show or hide the Palette List area:
1. In the Colour view, click on the Show/Hide Palette List View
Palette List area.
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•

Each palette you add in your scene will appear in the Palette list.

•

You can add, delete, import and order palettes in your scene using the Palette menu buttons.

Related Topics
•

Creating a Colour Palette below

Creating a Colour Palette
You can create a palette in either basic or advanced mode:
•

Basic Palette Lists Mode below

•

Creating a Colour Palette above

•

Renaming a Colour Palette on the facing page

By default, Toon Boom Animate is set on basic mode. For simple productions, it is recommended to use the
basic mode. For more advanced productions, it is a good idea to explore the possibilities of the advanced
mode.

If you are using Animate Network, refer to Managing Palettes.

Basic Palette Lists Mode
To create a new palette (Basic Palette Lists mode):
1. In the Colour View menu, select Palettes > New or click on the New Palette
The Create Palette window opens.
2. Enter the palette name according to the model.

3. Click on OK.
The palette appears in the drawing element’s palette list.
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Renaming a Colour Palette
To rename a palette:
1. In the Colour view, select the palette to rename.

2. In the Colour View menu, select Palettes > Rename.
3. In the Rename dialog box, rename the palette.

4. Click OK.

Related Topics
•

Copying and Pasting Colours below

•

Removing a Colour Palette on the next page

•

Duplicating a Colour Palette on page 324

•

Cloning a Colour Palette on page 325

Copying and Pasting Colours
When you are creating palettes, you may want to copy colour swatches or their values and paste them in other
palettes to save time.
To copy and paste colours
1. In the Colour view, select the colour to copy.

2. In the Colour View menu, select Colours > Copy or press [Ctrl] + [C] (Windows) or [⌘ ] + [C] (Mac OS X).
3. In the Palette list, select the palette in which you want to paste the colours.

4. In the Colour View menu, select Colours > Paste as New Colours or press [Ctrl] + [V] (Windows) or [⌘ ] +
[V] (Mac OS X).
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‣

If you want to paste the colour values of the copied swatch over an existing colour swatch,
select Colours > Paste as Values.

Copying Colours from Another Palette
In Toon Boom Animate you can quickly copy a colour value from a palette in your scene to a selected colour
swatch in a different palette.
To use Copy Colour From:
1. In the Colour view, select the colour swatch you want to copy the colour into.
2. In the Colour View menu, select Colour > Copy Colour From, then select the palette where the colour you
want to copy is listed and finally select the colour.
The selected colour swatch will immediately change to this new colour.

Related Topics
•

Adding a Colour Swatch on page 276

Removing a Colour Palette
You can remove palettes from your Palette list if they are not needed in your scene. The actual palette file will not
be deleted and you will be able to reimport it in your Palette list later on.
To remove a palette:
1. In the Colour view, select the palette to remove.

2. In the Colour View menu, select Palettes > Remove or click on the Remove Palette
‣

If the palette was in use in your scene, the zones painted with its colours will turn red.

Related Topics
•

Creating a Colour Palette on page 321

•

Duplicating a Colour Palette on the facing page
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•

Cloning a Colour Palette on the next page

Duplicating a Colour Palette
A duplicate palette uses the same names, colour values, but has a different ID and is independent from the
original palette. This ensures that both palettes are completely independent.
This option is used when there are similar models and you want to avoid recreating and naming all of the colours.
You can change the values and the names afterward. You can also keep some RGBA values, such as the eyes,
teeth, tongue, inside mouth, etc.
To duplicate a palette:
1. In the Colour view, select the palette to be duplicated.

2. In the Colour View menu, select Palettes > Duplicate.
The Palette Browser: Duplicate Palette window opens.

3. Name the palette appropriately.
4. Click OK to create the palette.
The palette appears in the palette list.

Related Topics
•

Cloning a Colour Palette on the next page
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Cloning a Colour Palette

A character usually has only one master palette, although there are times when the characters are placed in
different lighting conditions and require a different colour shading. The night palette is a popular choice when a
scene or sequence changes from day to night. It can be difficult and time-consuming to repaint everything and
creating two independent palettes can be quite complex. As an alternative, Toon Boom Animate provides clone
palettes.
The clone palette is a copy of the master palette. The colours in each palette have the same properties. The
colours have the same identification number pointing to the same colour zones, but they can have different
names and RGBA values. Depending on the activated palette (night or day), the painted drawing will update. So
there is no need to repaint the animation, but to create or import a clone palette (palette style).
To clone a palette:
1. In the Colour view, select the palette to be cloned.

2. In the Colour View menu, select Palettes > Clone.
The Palette Browser: Clone Palette window opens.

3. Name the palette. (It is recommended to keep the suffix“-clone” in the name.)
4. Click OK to create the palette.
The clone appears in the palette list.
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In the Colour view, you can also modify the colours individually by using the Colour Picker window or all at once
using the Tint Panel window.

If there is more than one clone palette loaded, the system will use the one highest in the palette list.

When you want to see through painted drawings, but still see the outlines, you can create a clone
palette where you set a lower alpha value on all of the filling colours. This trick can be handy when
setting pivot points on cut-out puppets.

Cloning a Colour Swatch
In Toon Boom Animate, you can copy a selected colour swatch and paste it as a clone.
To clone a colour swatch:
1. In the Colour view, select the colour swatch you want to clone.
2. In the Colour View menu, select Colours > Copy. The [Ctrl] + [C] (Windows) or [⌘ ] + [C] (Mac OS X).
3. In the Colour view, select the colour palette you want to paste the clone into, or create a new palette.
4. In the Colour View menu, select Colours > Paste as Clone.
The cloned colour swatch appears in the palette.
Since it produces a clone colour swatch, it is impossible to use the Paste as Clone command in the same palette
as you copied the original colour swatch from. If you try to do it, a Message dialog box will open as a reminder.
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Related Topics
•

Mixing the Colours below

•

Duplicating a Colour Palette on page 324

Mixing the Colours
If you want to modify a series of colour at once to blend a tint in them or offset their RGBA values, you can use
the Tint panel. The Tint panel is quite useful when creating palette styles such as night and day styles.
To mix colours:
1. In the palette list, select the palette to offset or blend colours in it.

2. In the Colour View menu, select Palettes > Tint Panel.
The Blend/Offset Tint panel opens.

3. Select one or more colours to be modified in the colour list. To select all your colours, press [Ctrl] + [A]
(Windows) or [⌘ ] + [A] (Mac OS X).
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4. Check Preview.

5. Offset, Blend or Mix the selected colours.

‣

Offset

Use this option to simply offset the selected colours by the adjustments made using the HSB and RGB
sliders. Use the Amount slider to adjust the degree of offset. Use the Alpha slider to adjust the opacity of
the selected colour.
‣

Blend

Use this option to blend the selected colours with the colour swatch in the top right corner. Use the
Amount slider to adjust the degree of blend. A blend of 100% would turn the selected colours into the
same colour as the swatch. Adjusting the HSB and RGB sliders affect the swatch colour, which in turn
affects the selected colours on the left. Use the Alpha slider to adjust the opacity of the swatch.
‣

Mixer
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Select a Base and Tint colour to form a third colour swatch. Use the slider just beneath to mix the Base
and Tint colours by different amounts. This will affect the mixed swatch whether it is selected or not.
Select either the Tint or Base swatch and use the HSB and RGB sliders to adjust its colour. This will affect
the mixed swatch colour, which in turn affects the selected colours on the left.

6. Click on the Apply button.
7. Close the Tint Offset/Blend Panel window.

Related Topics
•

Cloning a Colour Palette on page 325

•

Adding a Colour Swatch on page 276

Importing Palettes
•

Importing a Colour Palette below

•

Importing Palettes above

•

Importing Palettes above

•

Importing Palettes above

Importing a Colour Palette
If you created a palette in another project and you would like to import it in your current project, you can browse
for the palette file on your computer and add it to your project. When the palette is imported in your scene, the
file is copied in the project’s directory. It is not linked to the original file.
To import a palette into your project:
1. In the Colour View menu, select Palettes > Import or click on the Import Palette

button.

The Browser window opens.
2. Browse for a palette file located on your hard-drive. You will generally find the palettes in your projects’
Palette-Library directory.
3. Click on the Open button.
The palette appears in the Palette list.
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Ordering the Palette List
When you are using several cloned palettes that are related to the same original palette, Toon Boom
Animateuses the highest palette in the list to determine the colour of the painted zones.
To reorder palettes in the Palette list:
1. In the Colour View menu, select Palettes > Move Up or Move Down. You can also use the Up
Down

icons.

Related Topics
•

Cloning a Colour Palette on page 325
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Colour Model

Once you have a fully painted drawing, you can use it as a colour model and load it in the Model view. That
drawing can be used and loaded in any of your Animate scenes.
Once a drawing is loaded in the Model view, you can click on the Dropper

, select a colour from the model

and use it to paint in your Camera or Drawing view without having to pick the colour from the colour palette.
•

Loading a Colour Model below

•

Cutting, Copying and Pasting from a Colour Model on page 334

Loading a Colour Model
To load a colour model from your Timeline or Xsheet view:
1. In the Timeline or Xsheet view, select the desired drawing (*.tvg).

2. Bring the model into the Model view by doing one of the following:
‣

In the Timeline view, click and drag the selected drawing and drop it directly in the Model view.

‣

In the Model View menu, select Use Current Drawing as Model.
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‣

Use Current Drawing

button in the Model View toolbar’s extra buttons.

The model appears in the Model view.
To browse for a colour model drawing on your hard drive:
1. Do one of the following:
‣

In the Model View menu, select Import Model.

‣

Click the Import Model

‣

Select File > Import > Colour Model.

button or from the Model View’s toolbar.

2. In the Browser window, browse for any *.tvg drawing file on your hard drive.
3. Click Open.
The model appears in the Model view.
To load the Default models:
1. In your scene’s folder, create a new folder and name it models.
2. On your hard drive copy the *.tvg drawing file you want to use as colour models in your scene.
3. In the Model View menu, select Load Default Model. You can also click on the Load Default Model
button available in the Model View toolbar’s extra buttons.
To load a single drawing from the Library view:
1. In the Library view, click the template containing the drawing to import in the Model view.
2. Right-click on the template and select Open As Folder.
3. In the Library view’s left side, select the template’s folder and continuing expanding its sub-folders until
*.tvg files appear on the right side.

4. In the Library view’s right side, select the TVG drawing to import and drag it into the Model view.
To load a template with multiple drawings from the Library view:
1. In the Library view, find the template you want to import in the Model view.
2. In the Library view’s right side, click and drag the template (*.tpl file) and drop it directly in the Model
view.
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3. Use the Scroll Backward

and Scroll Forward

buttons, found in the Model view’s toolbar, to view

all the drawings contained in the template. This can often be the front, profile and 3/4 views of a
character.

To load a symbol from the Library view:
1. In the Library view’s left side, click on the Symbols folder.
2. In the Library view’s right side, select the symbol that you would like to use as a model and drag and drop
it directly into the Model view.

3. Use the Scroll Backward

and Scroll Forward

buttons, found in the Model view’s toolbar, to view

all the drawings contained in the symbol. This can often be the front, profile and 3/4 views of a character.
To clear a colour model:
1. In the Model View menu, select Clear Model or press [Delete].
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Cutting, Copying and Pasting from a Colour Model
You can do more than just copy colours from a colour model. Animate gives you the ability to copy parts of the
character directly from its colour model and paste these elements into the Drawing or Camera views.
To copy the entire model from the Model view:
1. In the Model view’s toolbar, select the Select

tool.

2. In the Model view, select your model.

3. In the top menu, select Edit > Copy Drawing Object or press [Ctrl] + [C] (Windows) or [⌘ ] + [C] (Mac OS
X).
4. In the Timeline view, make sure that you have the correct layer and frame selected.
5. Select either the Drawing or Camera views then go to the top menu and select Edit > Paste Drawing
Object, or select the Timeline view and from the top men select Edit > Paste cells in the Timeline or
press [Ctrl] + [V] (Windows) or [⌘ ] + [V] (Mac OS X).
The model now appears in the selected view.
To copy part of the model from the Model view:
1. In the Model view’s toolbar, select the Cutter

tool or press [Alt] + [T].

2. In the Model view, use the Cutter tool to create a selection around the part of your model that you would
like to copy.
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3. In the top menu, select Edit > Copy Drawing Object or press [Ctrl] + [C] (Windows) or [⌘ ] + [C] (Mac OS
X).
4. In the Timeline view, make sure you have the correct layer and frame selected.
5. Do one of the following:
‣

Select the Drawing or Camera view and select Edit > Paste Drawing Object.

‣

Select the Timeline view and select Edit > Paste cells in the Timeline or press [Ctrl] + [V] (Windows) or
[⌘ ] + [V] (Mac OS X).

The model appears in the selected view.
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Colour Preferences
Adjusting preferences to suit your techniques allows you to paint your drawings more efficiently.
To open the Preferences panel:
‣

Windows: Select Edit > Preferences.

‣

Mac OS X: Select Animate > Preferences.

‣

Or press [Ctrl] + [U] (Windows) or [⌘ ] + [U] (Mac OS X).

In the Preferences panel, you will find the following preferences that are related to adding colours to your
project.

Drawing Tab

Default Multiwheel Colour Picker
Enable this option to display the Mutliwheel Colour Picker window instead of the regular Colour Picker.

Sticky Eye Dropper
Enable this option to keep the Colour Picker’s Dropper tool active until it is released by clicking on the Dropper
icon again.
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Create New Colour Pots Using Default Colour
Set the default colour for creating a new colour swatch. Enable the option so that this default colour is used each
time you add a new colour in your palettes. This option is useful for when you create new colour pots so that a
more recognizable colour is created and not just a duplicate of the currently selected colour. Choosing a colour
that is the opposite of your intended colour palette is recommended, such as grey if your palette will be filled
with bright, primary colours.

Auto Gap Closing on Startup
The values for automatic gap closing while painting drawings are:
•

0 = Disabled

•

1 = Small

•

2 = Medium

•

3 = Big

Auto Gap Closing in Pixel Units
Disabling this option will cause your gap to be zoom dependant. Zoom dependent means that the more you
zoom in, the smaller the gap you can close with the Close Gap tools. By enabling this option, you choose to
make the gap display available in pixel units, which is not zoom dependant.

General Tab
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Colour Management
In the General tab of the Preference panel, you will find the following options:
•

Default to Element Palette Lists: When this option is enabled the new, cloned, duplicated, imported and
linked palettes will be stored in the Element Palette list instead of the Scene Palette List.

•

Interactive Colour Recovery: If a colour palette for your scene is deleted or cannot be found, you will be
asked if you want to recover colours from the program’s memory. If this option is unchecked, the
program recovers missing colours without displaying a dialog box for your input.

•

Colour Recovery: If this option is unchecked, colour recovery will not occur.

•

Replacement Colours: If colours are no longer available for your scene, these colours are automatically
replaced with the ones indicated by the Replacement Colour swatch. The default colour is red, as it acts
as a missing colour warning device.

Shortcuts Tab

Go to Next/Previous Colour in the Colour Palette
Under the Colour Management section, you can set two new possible shortcuts. You can set a shortcut to Go to
the Next Colour in the Colour Palette or to Go to the Previous Colour.
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Chapter 7: Timing

When you create hand-drawn animation, it is important to know how to set and modify the timing of your
drawings. You can adjust the timing in both the Timeline and Xsheet views, depending on which technique you
are used to working with. If you are a digital animator, you will probably use the Timeline view. If you are more of
a traditional animator, you will probably work with the Xsheet view (exposure sheet). Animate offers you both.
In this topic, you will learn how to work on your drawing’s exposure and length. The exposure and animation
paths for symbols are covered in separate chapters.

Topics Covered
•

Understanding the Timeline View on the facing page

•

Xsheet View on page 342

•

Frames on page 351

•

Layers and Columns on page 355

•

Filling Exposure on page 379

•

Navigating between Frames and Columns on page 400

•

Managing Drawings on page 402

•

Tempo Markers on page 408

•

Annotation Columns on page 410

•

Printing the Xsheet on page 1

•

Element Manager on page 1

•

Timing Preferences on page 415
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Understanding the Timeline View
To set your animation timing, you will mostly work with the Timeline and Xsheet views. This section will help you
become familiar with these views, how they work and the differences between them.
•

Timeline View below

•

Layer Section below

•

Timing Selection on the next page

•

Data View Section on the next page

Timeline View

The Timeline view allows you to read your timing from left to right. It represents the scene’s elements in their
simplest form.
In the Timeline view you can see your layers and their names as well as the drawing’s exposure. The drawing
name is displayed when you place your cursor above the drawing’s exposure.

You can also see the drawing name when you display the Data view. The name of the drawing folder to which the
layer is linked is displayed in the Data view.

Layer Section

The Layer section is located to the left of the Timeline view. This is where you add, delete, rename, reorder, and
parent layers. Any operation you do that affects the layer globally is done here.
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Timing Selection

The Timing section is located on the right side of the Timeline view. This is where you can increase and decrease
a drawing’s exposure, duplicate drawings, add blank cells, etc. Any operation you do that affects a drawing or
its timing is done in this section.

Data View Section

The Data view section is part of the Layer section. By default, the Data view is hidden.
The Data view allows you create new drawings by typing a new name in the Drawing Substitution field. You can
also swap between existing drawings by sliding your cursor
to the left or right.
To display the Data view:
‣

Click the Show Data View

button.

Related Topics
•

Swapping Images on page 763
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Xsheet View

1. Xsheet Main Section on the next page
2. Functions Section on page 344
3. Column List Section on page 345
4. Xsheet View Toolbar on page 346
5. Column Header on page 346
6. Current Drawing on page 347
7. Current Frame on page 347
8. Frame Numbers on page 348
9. Drawing Exposure on page 349
10. Current Frame Display on page 349
11. Function Column on page 349
12. Increase/Decrease Exposure on page 350
13. Overwrite/Insert Modes on page 350
In Animate, you will also find the Xsheet View menu

button in the top-left corner. This button allows you to

access commands related to the Xsheet view.
The Xsheet view lets you read your timing vertically, displays the drawing layers as columns and shows the
drawing’s name. You also see the functions and keyframes of the motion paths in the Xsheet’s function columns.
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The value of each keyframe is shown in the Xsheet view, these are black squares in the Timeline view. The Xsheet
view contains details than the Timeline view, and is faster and easier to read.

Related Topics
•

Adding and Deleting Keyframes on page 650

Xsheet Main Section

The Xsheet view has three sections. By default, only the main section is visible. It displays the drawing layers, also
known as drawing columns.
When using advanced compositing and animation techniques, unconnected functions (motion paths) also appear
in the main section. Unconnected functions mean that some motion paths are not attached to any particular
layer.

When you reconnect functions to a layer they are still visible in the main section.
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Refer to Sharing Functions on page 685 to learn about the unconnected functions.
Refer to the topic Showing and Hiding Columns on page 368 to learn how to temporarily hide
unconnected functions from the main section.

Related Topics
•

Xsheet View on page 342

Functions Section

The Functions section is used for more advanced techniques. This section displays the functions (paths) related
to the selected layer in the Timeline view. By default, the Functions section is hidden.
To display the Functions section:
1. In the Xsheet view, click on the Expand button located on the right side of the main section. Click on the
same button to collapse it. You can also use the Show Column List
button in the Xsheet View toolbar.
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If you select a drawing column in the main section of the Xsheet view, the function columns will not
be displayed. You must select the layer from the Timeline view.

Related Topics
•

Xsheet View on page 342

•

Animation Paths on page 637

Column List Section

The Column List section allows you to show and hide columns from your Xsheet view. When you hide a layer
using your Xsheet view, it is also disabled in the Timeline view.
You can use the Column List to hide individual columns or hide an entire column type (drawing or function) from
your Xsheet view. By default, the Functions section is hidden.
To display the Column List section:
1. In the Xsheet view, click the Expand button located on the right side of the main section to show the
Functions section. Click on the same button to collapse it. You can also use the Show Column List
button in the Xsheet View toolbar.
‣

In Animate, you can also go to the Xsheet View menu and select View > Show Column List.

2. Click the Expand button on the right side of the Functions section to display the Column List section.
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Related Topics
•

Xsheet View on page 342

Xsheet View Toolbar

The Xsheet view has its own toolbar where you can find the most common features. This toolbar is displayed by
default. If you do not see it, select Windows > Toolbars > Xsheet View.
The Xsheet view must be part of your workspace in order to display its toolbar.

Refer to Toolbar Manager on page 96 to learn how to organize the buttons available in the Xsheet
View toolbar.

Related Topics
•

Xsheet View on page 342

Column Header

Each column available in the Xsheet view has a header displaying the column’s name. The column’s name is the
same as the corresponding timeline layer. If you rename one or the other, they will both be renamed.
A quick access menu is available when you right-click. This menu contains the command affecting an entire
column such as renaming, changing the default colour or deleting a column.
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In Animate, the column header shows the layer’s name and the name of the drawing folder to which it is linked. If
the name of the layer is the same as the drawing folder, the drawing folder’s name will not be displayed. For
example; when you link a Timing column to a certain element (and thereby the Element’s folder).

The tooltip that appears when you hover your cursor at the top of each Xsheet column shows the absolute folder
path to the source drawings for that column.

Related Topics
•

Xsheet View on page 342

Current Drawing

A drawing selected in dark red indicates that the drawing is currently displayed in the Drawing view. The current
drawing selection is not linked to the drawing displayed in the Camera view since drawings from each visible
layer are displayed at once.

Related Topics
•

Xsheet View on page 342

Current Frame

The darker frame appearing in the Xsheet view represents the current frame displayed in the Camera view. It
does not necessarily correspond to the current drawing displayed in the Drawing view.
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Tip: To show the real time updated of the selected frame, click the Xsheet menu and select View >
Enable Playbackright-click the Xsheet view and select View > Enable Playback.

There is a new option in the Xsheet to Enable Playback. This shows the real time update of what frame is
selected. You can turn this off or on view the View menu in Animate Pro, and I think by right-clicking in Animate
LB

Related Topics
•

Xsheet View on page 342

Frame Numbers

On the left side of the Xsheet view, the frame numbers are shown indicating where you are. These read vertically
instead of being displayed horizontally as they are in the Timeline view.
•

To go to a particular frame, click the frame number.

•

To select an entire range of frames, click and drag a selection downwards.

Related Topics
•

Xsheet View on page 342
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Drawing Exposure

In the drawing columns, you can see the drawing names and their exposure. You can use any alphanumeric
symbol to name your drawing. When a drawing is exposed over more than one cell, a vertical black line is
displayed to indicate the continuity of the exposure. When there is no drawing in a cell, the cell will be blank.

Related Topics
•

Xsheet View on page 342

Current Frame Display

At the bottom of the Xsheet view, you can see the current frame number as well as the column containing the
drawing currently displayed in the Drawing view

Related Topics
•

Xsheet View on page 342

Function Column
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The function columns are displayed in the Functions section of the Xsheet view. They represent the motion and
rotation you applied to your drawing layer. Only the function columns related to the selected layer are displayed.
A function column can also be related to an effect. Selecting your effect layer shows you the corresponding
function column in the Xsheet view.
The function columns display the position value or effect value on each cell. If there is a keyframe on a cell, a black
square is displayed. Holding the same value for several frames displays a vertical black line.
Holding the same value for several frames displays a vertical black line.

Related Topics
•

Xsheet View on page 342

Increase/Decrease Exposure

You can quickly increase or decrease the exposure of the selected cell by clicking on the up and down arrows in
the Increase/Decrease Exposure field.

Refer to the Increase/Decrease Exposure Field on page 388 topic to learn more about this feature.

Related Topics
•

Xsheet View on page 342

Overwrite/Insert Modes
The Overwrite/Insert button allows you to decide the way the values are inserted into your Xsheet.

Related Topics
•

Xsheet View on page 342
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Frames
One of the first things to learn in Toon Boom Animate is how to add or delete frames in your scene.

Related Topics
•

Adding Frames below

•

Deleting Frames on page 353

Adding Frames
There are several ways to add frames to your scene using Toon Boom Animate.

Related Topics
•

Setting the Scene Length below

•

Extending the Timeline View below

•

Adding Frames Before or After a Selection on the facing page

•

Adding Frames to the Beginning or at the End of a Scene on the facing page

Setting the Scene Length
You can set the global scene length from the top menu.
To set the set scene length:
1. Select Scene > Set Scene Length.
The Set Scene Length dialog box opens.

2. In the Number of Frames field, type how many frames are needed.

Extending the Timeline View
You can quickly extend your scene length in the Timeline view.
To extend your scene in the Timeline view:
1. In the Timeline view, drag the scene length bracket to the right to add more frames to your scene.
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Adding Frames Before or After a Selection
You can add frames anywhere in the middle of the scene. If you select a frame row in the Xsheet view, the system
will add the new frames before or after the selection, depending on your choice.
To add frames before or after selection:
1. In the Xsheet view, select a frame row.

2. Do one of the following:
‣

Select Scene >Frame >Add Frames Before Selection or Add Frames After Selection.

‣

Press [Ctrl] + [G] and [Ctrl] + [H] (Windows) or [⌘ ] + [G] and [Ctrl] + [H] (Mac OS X).

In Harmony Xsheet, select Frame >Add Frames Before Selection or Add Frames After Selection.
The Add Frames dialog box opens.

3. In the Number of Frames to Add field, enter the amount of frames needed in the scene.

To add new frames after your selection, you can also use the Add Frames

button in the Xsheet

View toolbar.

Adding Frames to the Beginning or at the End of a Scene
You can add some frames to the beginning or at the end of the scene.
To add frames at start or at end:
1. Select Scene > Frame > Add Frames at Start or Add Frames at End.
In Harmony Xsheet, select Frame > Add Frames at Start or Add Frames at End.
The Add Frames dialog box opens.

2. In the Number of Frames to Add field, enter the number of frames needed in the scene.
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To add new frames at the end of your scene, you can also use the Add Frames

button found in

the Xsheet View toolbar.

Related Topics
•

Deleting Frames below

Deleting Frames
There are three ways to delete frames from your scene:
•

Reducing the Timeline Length below

•

Removing Selected Frames below

•

Deleting a Selected Frame Range on the facing page

When you remove frames from the end of your scene, the exposed drawings and symbols are not
deleted. If you extend your scene afterwards, these drawings and symbols are still available.

Reducing the Timeline Length
You can quickly reduce your scene length in the Timeline view.
To reduce your scene in the Timeline view:
1. In the Timeline view, drag the scene length bracket to the left to remove frames from your scene.

Removing Selected Frames
You can remove any selected frame in your Xsheet view, such as the last frame of your scene.
To remove a selected frame:
1. In the Xsheet view, select a frame in a given column.
2. In the Xsheet View toolbar, click the Remove Frames

button. To remove several frames, click the

button repeatedly.
You can also select Scene > Frame > Remove Selected Frames from the top menu.
In Harmony Xsheet, select Frame > Remove Selected Frames from the top menu.
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Deleting a Selected Frame Range
In the Xsheet view, you can remove any selected frame range.
To delete a frame range:
1. In the Xsheet view, select a frame range by clicking the first frame’s number and then dragging the
selection highlight down to the last frame to delete.

2. Do one of the following:
‣

Press [Delete] to delete the selection.

‣

From the top menu, select Scene > Frame > Remove Selected Frames.

‣

Click Remove Frames

button.

In Harmony Xsheet, go to Frame > Remove Selected Frames.
The Warning dialog box opens.

3. To complete the operation:
‣

Click Yes to delete the selection.

‣

Click No to only delete the exposure in the cell and not the frames.

‣

Select the Don’t Show This Message Again option to prevent the warning message from being
displayed each time you delete a frame range.

Related Topics
•

Adding Frames on page 351
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Layers and Columns
In Toon Boom Animate there are two ways to see your layers:
•

As horizontal layers in the Timeline view

•

As vertical columns in the Xsheet view

In Animate, you can also see your layers displayed in the Network view as modules.
Whether you work in the Timeline or Xsheet view, they are the same and any modification you do to one or the
other will be applied to both.

Related Topics
•

Layer and Column Concepts below

•

Adding New Drawing Layers on page 360

•

Deleting Layers And Columns on page 363

•

Modifying Layers on page 365

•

Duplicating Layers and Columns on page 372

•

Cloning Layers And Columns on page 373

•

Xsheet Thumbnails on page 374

•

Changing the Colour of a Layer or Column on page 374

•

Expanding and Collapsing Layers and Columns on page 377

•

Modifying the Look of the Column

When working in Harmony Xsheet, only the Xsheet view and its functionalities are available.

Layer and Column Concepts
In order to understand what happens when you duplicate a drawing, extend an exposure, create cycles or delete
a drawing, it is important to know how a layer works.
Each layer is linked to a directory, this is the location where all of that layers' drawings are saved. This directory
has the same name as the layer. When a value or drawing name is typed in a layer’s cell, the system looks in the
layer’s directory for the corresponding drawing to display. If there is no corresponding drawing, a new one is
created.
The layer’s cells are not used for storage, but are linked to the drawings contained in the layer’s directory. If you
remove a drawing from the layer exposure, it is not deleted, but is simply not displayed.
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When you create a drawing cycle, all of the repeated drawings are linked to the same original files. This means
that when you modify, repaint or correct a drawing named “1,” all drawings named “1” are updated
simultaneously. In order to modify a drawing independently from its other exposures, you must duplicate the
drawing.

Related Topics
•

Layers and Columns on the previous page

•

Layer Types below

•

Advanced Column Types on page 1

•

Layer Content on page 359

•

Adding New Drawing Layers on page 360

•

Deleting Layers And Columns on page 363

•

Modifying Layers on page 365

•

Duplicating Layers and Columns on page 372

•

Cloning Layers And Columns on page 373

•

Xsheet Thumbnails on page 374

•

Changing the Colour of a Layer or Column on page 374

•

Expanding and Collapsing Layers and Columns on page 377

•

Modifying the Look of the Column on page 1

•

Duplicating a Drawing on page 405

Layer Types
There are several types of layers that you can add in the Timeline view. Some layers are not represented the
same way in the Xsheet view.
•

Drawing Layer on the next page
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•

Bitmap Layer below

•

Camera Layer below

•

Effect Layer on the facing page

•

Colour-Card Layer on the facing page

•

Peg Layer on the facing page

•

Quadmap Layer on page 359

•

Sound Layer on page 359

Drawing Layer

The most common layer type is the Drawing layer. Any time you need to create a vector drawing or import a
symbol, you can use a Drawing layer. In the Timeline view, the drawing layer is tagged with the Drawing
icon.

Bitmap images are contained in Bitmap layers.

Bitmap Layer

If you import picture or bitmap images in your project, they are inserted in a Bitmap layer. If you choose to
vectorize your image when you import, the Bitmap object will be placed on a Drawing layer. This way, you can
have bitmap images mixed with vector drawings on a Drawing layer.
When importing a bitmap image, you have the option of encapsulating the image in a symbol. If you place a nonvectorized bitmap into a symbol, you still will not be able to mix vector drawings with it on the same layer. If you
place a vectorized bitmap in a symbol, you must enter the symbol to be able to mix it with vector artwork.
In the Timeline view, the Bitmap layer is tagged with the Bitmap

icon.

Camera Layer
You can only have one Camera layer at a time in your timeline. By default, there is no Camera layer when you
create a scene. You need to add a Camera layer when you want to create a camera motion.
In the Timeline view, the camera layer is tagged with the Camera
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The Camera layer is not visible in the Xsheet view.

Effect Layer

To enhance the look of your scene, you can add effect layers and attach your drawings to them. In Toon Boom
Animate, there is a series of effect modules in the Module Library view.
In the Timeline view, the Effect layer is tagged with the Effect

icon.

In the Xsheet view, you can see the Effect’s parameter columns in the Functions section when you select the
Effect layer in the Timeline view.

If you want to have several cameras with different settings, you can keep adding Camera layers in
your Timeline view (however, only one will ever be visible at a time as you can only have one Camera
at a time in your timeline). To switch between the camera available, select Scene > Camera > select
the desired camera.

Colour-Card Layer

The Colour-Card layer is used to add plain colour background to your scene. By default, your scene has no
background colour and if you render it out as a QuickTime movie or image sequence it will have a black
background.
In the Timeline view, the Colour-Card layer is tagged with the Effect
The Colour-Card layer is not visible in the Xsheet view.

Peg Layer
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A Peg layer can be described as a trajectory or motion path layer that does not contain drawings. This can be
attached to any drawing layer, cut-out puppet or other peg layers, they will all follow the trajectory you set in the
Peg layer.
In the Timeline view, the Peg layer is tagged with the Peg

icon.

In the Xsheet view, you can see the Peg’s function columns in the Functions section when you select the Peg layer
in the Timeline view.

Quadmap Layer

A Quadmap layer can be described as a deformation transformation layer that does not contain drawings. This
can be attached to any drawing layer, cut-out puppet or even other peg layers they will all follow the
deformation you set in the Quadmap layer.
In the Timeline view, the Quadmap layer is tagged with the Quadmap

icon.

In the Xsheet view, you can see the Quadmap’s function columns in the Functions section when you select the
Quadmap layer in the Timeline view.

Sound Layer

You can import sound files to add dialog and sound effects to your project. The sound layer will be added to
your Timeline and Xsheet view when you import a sound file in your scene.
In the Timeline view, the Sound layer is tagged with the Sound

icon.

In the Xsheet view, the Sound layer is a dark grey colour.

Related Topics
•

Layers and Columns on page 355

•

Layer and Column Concepts on page 355

•

Advanced Column Types on page 1

Layer Content
There are two types of elements that can be inserted in a drawing layer’s cell:
•

Vector drawings

359

Chapter 7: Timing Layers and Columns

•

Symbols

A layer can contain the two different elements, but only in different cells. You cannot put two symbols or a
drawing and a symbol into the same cell.

If you want to mix bitmap images in your Drawing layers, you must first import your bitmap image as a symbol or
turn it into a symbol and insert it in your Drawing layer by dragging the symbol cell there through the Timeline.

Refer to What is a Symbol? to learn more about symbols.

Related Topics
•

Layers and Columns on page 355

•

Layer and Column Concepts on page 355

•

Timing Columns on page 1

•

Advanced Column Types on page 1

•

Symbols on page 532

Adding New Drawing Layers
In this section, you will learn the different ways to add a drawing layer to your project. By default, when you
create a new scene there is one Drawing layer included in your Timeline view.
This topic is divided as follows:
•

Adding Drawing Layers in the Timeline View below

•

Adding a Drawing Layer from the Top Menu on the next page

•

Adding Drawing Columns in the Xsheet View on page 362

Adding Drawing Layers in the Timeline View
You can add a new layer in the Timeline view in several different ways:
•

Using the Layer toolbar

•

Using the Add Layers dialog box

•

Go to the Timeline view menu and select Insert > Drawing.
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To add a Drawing layer using the Timeline’s Layer toolbar:
1. In the Timeline’s Layer toolbar, click the Add Layers

button or press [Ctrl] + [R] (Windows) or [⌘ ] +

[R] (Mac OS X).
2. In the drop-down menu, select the Drawing option.

A new layer appears in the Timeline and Xsheet views.

You can also click on the Add Drawing Layer button in the Timeline’s Layer toolbar or press [Ctrl] + [R]
(Windows) or [⌘] + [R] (Mac OS X).

To add drawing layers using the Add Layers dialog box:
1. In the Timeline view’s layer section,right-click and select Insert > Add Layer(s).
The Add Layers dialog box opens.

2. In the Type drop-down menu, select the Drawing option.
3. In the Number field, use the up and down arrows or type the number of layers you want to add at once.
4. In the Name field, type the name of the layer you want to add. If you are adding more than one layer at
once, all of the layers use that name with a numerical suffix added.
5. To complete the operation:
‣

Click OK to add your new layers and close the dialog box.

‣

Click Apply to add your new layers and keep the dialog box open to add another layer.

‣

Click Close to cancel the operation.

Adding a Drawing Layer from the Top Menu
You can add a new layer from the top menu.
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To add a new layer from the top menu:
1. In the top menu, select Insert > Drawing.
A new layer appears in the Timeline and Xsheet views.

Adding Drawing Columns in the Xsheet View
To add a drawing column:
1. Do one of the following:
‣

In the Xsheet view, right-click and select Columns > Add Column.

‣

In the Xsheet View toolbar, click the Add Columns

‣

To quickly add a Drawing column, press [Ctrl] + [R] (Windows) or [⌘ ] + [R] (Mac OS X).

button or press [Shift] + [C]].

The Add Columns dialog box opens.

2. In the Column Name field, name your column accordingly.
3. In the Column Type field, select Drawing.

Refer to the topic Layer Types on page 356 to know more about the different column types available.

4. To complete the operation:
‣

Click OK to add your new layers and close the dialog box.

‣

Click Apply to add your new layers and keep the dialog box open to add column.

‣

Click Close to cancel the operation.

In Animate, you can use the advanced Add Column dialog box, with more file format and field size options, to
insert the column.

Related Topics
•

Layers and Columns on page 355

•

Layer and Column Concepts on page 355

•

Advanced Column Types on page 1

•

Layer Content on page 359

•

Adding New Drawing Layers on page 360

•

Deleting Layers And Columns on the next page

•

Modifying Layers on page 365
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•

Duplicating Layers and Columns on page 372

•

Cloning Layers And Columns on page 373

•

Xsheet Thumbnails on page 374

•

Changing the Colour of a Layer or Column on page 374

•

Expanding and Collapsing Layers and Columns on page 377

•

Modifying the Look of the Column on page 1

Deleting Layers And Columns
You can delete layers from your projects in two different locations:
•

Deleting a layer from the Timeline view

•

Deleting a column from the Xsheet view

Deleting a Layer from the Timeline View
There are two ways to delete a layer in the Timeline view, using the Delete Layers

button and via the quick

access menu. This will also delete the associated modules from the Network view.
To delete layers in the Timeline view:
1. In the Timeline view, select the layers to be deleted.

2. In the Timeline’s Layer toolbar, click the Delete Layers

button.

You can also right-click on the selection and select Delete.
The Confirm Delete dialog box opens.

‣

Select the Delete Drawing Files and Element Folders option to delete all drawings and folder linked
to this layer.

3. Select the Delete Xsheet Columns option if you also want to delete the existing column in the Xsheet
view.

Deleting a Column from the Xsheet View
There are two ways to delete a layer in the Xsheet view, using the Delete Columns
access menu.
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To delete layers in the Xsheet view:
1. In the Xsheet view, select the columns to be deleted by clicking on their header.

2. In the Xsheet View toolbar, click the Delete Columns

button. You can also right-click on the selection

and select Delete Columns or press [Delete].
The Confirm Delete dialog box opens.

‣

Select the Delete Drawing Files and Element Folder option if you want to delete the drawings and
folders linked to the selected column.

3. To complete the operation:
‣

Click OK to delete the selected layers.

‣

Click Cancel cancel the operation.

‣

Click Yes button delete all the frames from your scene.

‣

Click No button to keep the frames in your scene.

‣

Select the Don’t Show This Message Again option if you do not want the dialog box to pop again in
the future.

Related Topics
•

Layers and Columns on page 355

•

Layer and Column Concepts on page 355

•

Advanced Column Types on page 1

•

Layer Content on page 359

•

Adding New Drawing Layers on page 360

•

Deleting Layers And Columns on the previous page

•

Modifying Layers on the next page

•

Duplicating Layers and Columns on page 372
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•

Cloning Layers And Columns on page 373

•

Xsheet Thumbnails on page 374

•

Changing the Colour of a Layer or Column on page 374

•

Expanding and Collapsing Layers and Columns on page 377

•

Modifying the Look of the Column on page 1

Modifying Layers
Once you added layers to your project, you can modify their properties, name or ordering.

Related Topics
•

Ordering Layers and Columns below

•

Showing and Hiding Layers From the Timeline View on the facing page

•

Showing and Hiding Columns on page 368

•

Layer Properties on page 370

•

Renaming Layers and Columns on page 371

Ordering Layers and Columns
You can change the order of your layers in the Timeline and Xsheet views. When you change the order of your
layers in one of these views, the other one is updated.

Reordering Layers in the Timeline View
To reorder layers in the Timeline view:
1. In the Timeline view, select the layers to move.
2. Drag the selection to the new location and drop it in between the existing layers. Dropping the selection
on an existing layer would create a hierarchy. Layers located on top of the Timeline view are displayed in
front of the other ones. Layers located at the bottom are displayed behind.

Reordering Columns in the Xsheet View
You can reorder columns in the Xsheet view using the mouse’s middle button.
To reorder columns in the Xsheet view:

‣ In the Xsheet view, click on the column’s header with the middle mouse button and drag the column to its
new position.
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Related Topics
•

Layers and Columns on page 355

•

Modifying Layers on the previous page

•

Showing and Hiding Layers From the Timeline View below

•

Showing and Hiding Columns on page 368

•

Layer Properties on page 370

•

Renaming Layers and Columns on page 371

Showing and Hiding Layers From the Timeline View
As you work in the Drawing or Camera view, some layers may be in the way or are used as references. You can
hide these layers to make your work area easier and less cluttered. You can show and hide layers in the Timeline
view in several different ways.
To show or hide all layers in the Timeline view:

‣ In the Timeline’s Layer toolbar, click the Enable/Disable All
also click the Enable All

button to show or hide all layers. You can

button located in the Timeline view toolbar’s extra buttons.

To show or hide individual layers in the Timeline view:

‣ In the Timeline’s Layer toolbar, deselect the layer’s checkbox to disable a particular layer. Select the
layer’s checkbox to enable a particular layer. You can also click the Enable/Disable

button located in

the Timeline View toolbar’s extra buttons.

When you disable a layer in the Timeline view, the corresponding column is hidden in the Xsheet view.
To disable all layers but the selected one:

‣ In the Timeline’s Layer toolbar, click the Show Selection and Hide All Others

button to show only

the currently selected layer and disable all the other layers. You can also click the Disable All Others
button located in the Timeline View toolbar’s extra buttons.
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In the Timeline view, you can hide or show certain types of layers such as Group and Effect.
To show and hide layer types in the Timeline view:
1. In the Timeline View menu, select View > Show > Show Manager.
‣

You can also select View > Show > Show Sounds, Show Effects or Show Groups to immediately
show or hide the selected type. This option will remain only for the current session. Once the
application is closed and reopened, the default settings will return.

The Show Manager dialog box opens.

2. Select the types of layers you want to display and deselect the ones you want to turn off.
3. Click Set As Default to make these new settings the default ones that will be used each time to start the
application. Click Restore Default to restore the settings used when installing the application.
In the Xsheet view, you have the choice of hiding or showing certain types of columns such as Annotation
and Functions.
To show and hide layer types in the Timeline view:
1. In the Xsheet View menu, select View > Column Types Manager.
The Column Types dialog box opens.

2. Select the types of columns you want to display and disable the ones you want to hide.
3. Click Set As Default to make these new settings the default ones that will be used each time to start he
application. Click Restore Default to restore the settings used when installing the application.
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Related Topics
•

Layers and Columns on page 355

•

Modifying Layers on page 365

•

Showing and Hiding Columns below

•

Layer Properties on page 370

•

Renaming Layers and Columns on page 371

Showing and Hiding Columns
The Xsheet view has a Column List section that shows all the columns contained in the exposure sheet. It can be
used to hide indivisdual columns.
If you need to see a column after it has been hidden, you can display it directly from the Xsheet view without
using the Column List section.
You can also hide an entire column type, such as Drawing or Sound.
When a column is hidden in the Xsheet view, the corresponding layer is disabled in the Timeline view.
To show and hide columns in the Xsheet view:
1. In the Xsheet View toolbar, click the Show Column List

button.

2. Click the Expand button located on the right side of the Functions section to display the Column List
section.
3. In the Column List section, show or hide the columns by clicking in the column checkbox to add or remove
the check mark. You can also click the Hide Selected Column
button located in the Xsheet View
toolbar’s extra buttons.

To show a hidden column from the Xsheet view:
1. In the Xsheet view, click on the thick grey line that appeared in place of the hidden column. You can also
right-click on the column header and select Show Hidden Columns.

The Show Hidden Columns dialog box opens.
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2. In the Show column, enable the hidden columns you want to display in the Xsheet view.
‣

Click Check to check all the selected columns.

‣

Click Uncheck to uncheck all the selected columns.

In Toon Boom Animate, in the Xsheet view menu, you can select View > Unhide All Columns.
To hide and entire column type:
1. In the Column List section, click the Column Type button corresponding to the type you want to show or
hide.

‣

The Show/Hide All Columns

button shows or hides every column available in the Xsheet view.

‣

The Show Drawing Columns

button shows the Drawing columns.

‣

The Show Function Columns

button shows the Bezier and Ease function columns.

‣

The Show 3D Path Columns

‣

The Show Sound Columns

‣

The Show 3D Rotation Columns

button shows the 3D Rotation columns.

‣

The Show Annotation Columns

button shows the Annotation columns.

button shows the 3D Path function columns.
button shows the Drawing columns.

Related Topics
•

Layers and Columns on page 355

•

Modifying Layers on page 365

•

Showing and Hiding Layers From the Timeline View on page 366

•

Layer Properties on the facing page

•

Renaming Layers and Columns on page 371
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Layer Properties

Each layer has its own set of properties that can be modified, including effect and peg layers.
Display the Layer Properties editor if you want to modify some of the layer’s properties such as the name or the
antialiasing quality. You can display the editor from the Timeline or Network view or open the Layer Properties
as a view of its own.
The Xsheet column will not open the Layer Properties dialog box, it will show the Column Properties allowing
you to modify settings related to the Xsheet column.

The Drawing Layer Properties editor allows you to:
•

Rename the layer

•

Enable or disable the layer

•

Lock the layer

•

Change the track colour

•

Activate the onion skin preview
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•

Adjust the positioning and animation parameters

•

Adjust many other advanced parameters

To display the Layer Properties editor:
1. Do one of the following:
‣

In the Timeline view, double-click on a layer or press [Shift] + [E].

‣

In the Network view, click on the module’s yellow properties button.

‣

In the top menu, select Windows > Layer Properties.

2. In the Timeline or Xsheet view, select the layer whose properties you want to view.
To display the Column Properties Editor from the Xsheet view:
1. In the Xsheet view, double-click on a column’s header or press [Shift] + [E].

Related Topics
•

Layers and Columns on page 355

•

Modifying Layers on page 365

•

Showing and Hiding Layers From the Timeline View on page 366

•

Showing and Hiding Columns on page 368

•

Renaming Layers and Columns below

•

Adding New Drawing Layers on page 360

Renaming Layers and Columns
You can rename a layer in two different ways; in the Layer Properties editor or directly on the Timeline’s layer.
To rename a layer in the Timeline view:
1. In the Timeline view, double-click on the name of the layer to rename.
2. In the Name field, rename the layer and press [Enter/Return] to validate the modifications.

To rename a layer in the Layer Properties editor:
1. In the Timeline view, double-click on the layer to rename.
The Layer Properties editor opens.
2. In the Name field, rename the layer.

3. Click Close.
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To rename a column:
1. In the Xsheet view, double-click on the column name to rename. Do not click on the drawing folder name
that the column is linked to (this also appears in the column header just below the column name).
The Column Editor dialog box opens.

2. In the Name field, rename the column.
3. Click OK.
4. Click Apply/Next to apply the new name and open the editor for the following column.

Related Topics
•

Layers and Columns on page 355

•

Modifying Layers on page 365

•

Showing and Hiding Columns on page 368

Duplicating Layers and Columns
Duplicating a layer provides you with an independent copy of the drawings and their exposure. You can modify
anything you want in the duplicated layer without affecting the original one. In the Network view, you can
duplicate the selected modules in the same way.
To duplicate a layer:
1. In the Timeline or Xsheet view, click the layer you want to duplicate.

2. Select Edit > Duplicate or click the Duplicate Layer

button in the Xsheet View toolbar and

TimelineView toolbar.
In Harmony Xsheet, select Edit > Duplicate Selected Element.
The new duplicated layer or column appears.

Related Topics
•

Layers and Columns on page 355

•

Layer and Column Concepts on page 355

•

Advanced Column Types on page 1

•

Layer Content on page 359

•

Adding New Drawing Layers on page 360
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•

Deleting Layers And Columns on page 363

•

Modifying Layers on page 365

•

Cloning Layers And Columns below

•

Xsheet Thumbnails on the facing page

•

Changing the Colour of a Layer or Column on the facing page

•

Expanding and Collapsing Layers and Columns on page 377

•

Modifying the Look of the Column on page 1

Cloning Layers And Columns
Cloning a layer provides you with a copy of the selected layer that uses the same drawings as the original. If you
modify a drawing in the cloned or original layer it is updated in both layers. You can modify the layers’ timing
independently one from the other, but the drawings remain linked. You can clone selected modules from the
Network view in the same way.
This feature is useful when you want to reuse a hand-drawn animation but have different timings.
To clone a layer:
1. In the Timeline or Xsheet view, click on the layer you want to clone.

2. Select Edit > Clone or click the Clone Layer

button in the Xsheet View toolbar and Timeline View

toolbar.
In Harmony Xsheet, select Edit > Clone Selected Columns.
The new cloned layer or column appears.

Related Topics
•

Layers and Columns on page 355

•

Layer and Column Concepts on page 355

•

Advanced Column Types on page 1

•

Layer Content on page 359

•

Adding New Drawing Layers on page 360

•

Deleting Layers And Columns on page 363

•

Modifying Layers on page 365

•

Duplicating Layers and Columns on the previous page

•

Xsheet Thumbnails on the facing page

•

Changing the Colour of a Layer or Column on the facing page

•

Expanding and Collapsing Layers and Columns on page 377
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•

Modifying the Look of the Column on page 1

Xsheet Thumbnails
When there are a large number of columns in the exposure sheet, it is not always easy to quickly identify a
particular column. Displaying the column thumbnails makes this easier. This option displays a small thumbnail
picture of the current frame below the column header.
To display the thumbnails:
1. In the Xsheet view, click the Show Thumbnails

button.

The thumbnails appear.

Related Topics
•

Layers and Columns on page 355

•

Layer and Column Concepts on page 355

•

Advanced Column Types on page 1

•

Layer Content on page 359

•

Adding New Drawing Layers on page 360

•

Deleting Layers And Columns on page 363

•

Modifying Layers on page 365

•

Duplicating Layers and Columns on page 372

•

Cloning Layers And Columns on the previous page

•

Changing the Colour of a Layer or Column below

•

Expanding and Collapsing Layers and Columns on page 377

•

Modifying the Look of the Column on page 1

Changing the Colour of a Layer or Column
To easily identify layers in your Timeline and Xsheet views, you can change their colour.
To change the layer’s colour in the Timeline view:
1. Do one of the following:
‣

In the Timeline view, click the colour swatch of the layer you want to modify.
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‣

Select a layer and click the Change Track Colour

button in the Timeline View toolbar’s extra

buttons.

2. In the Colour Picker window, select a new colour for your layer and click OK.

The layer’s colour is updated.

To reset a layer’s colour in the Timeline view:
1. In the Timeline view, select the layers to reset and click the Default Track Colour
Timeline View toolbar’s extra buttons.
To change a column’s colour in the Xsheet view:
1. In the Xsheet view, select one or more columns to modify.
2. Right-click on the column’s header and select Colour > Change Columns Colour.
3. In the Colour Picker window, select a new colour for your columns and click OK.
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The column’s colour is updated.

To reset the column’s colour in the Xsheet view:
1. In the Xsheet view, select the columns to reset and right-click on the column’s header and select Colour >
Default Columns Colour.

Related Topics
•

Layers and Columns on page 355

•

Layer and Column Concepts on page 355

•

Advanced Column Types on page 1

•

Layer Content on page 359

•

Adding New Drawing Layers on page 360

•

Deleting Layers And Columns on page 363

•

Modifying Layers on page 365

•

Duplicating Layers and Columns on page 372

•

Cloning Layers And Columns on page 373

•

Xsheet Thumbnails on page 374

•

Expanding and Collapsing Layers and Columns on the next page

•

Modifying the Look of the Column on page 1
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Expanding and Collapsing Layers and Columns
To simplify the look of your Timeline and Xsheet view, you can collapse and expand your layers. If some layers are
parented to other ones, you can collapse the parent layer to hide all of its children. You can also collapse 3D Path
columns in the Xsheet view.
To collapse/expand a layer selection in the Timeline view:
1. In the Timeline view, select the layer(s) to collapse or expand.
2. Do one of the following:
‣

Right-click on the selection and select Collapse/Expand > Collapse/Expand.

‣

Click the Expand Children Arrow

‣

Press [Ctrl] + [I] (Windows) or [⌘ ] + [I] (Mac OS X).

‣

Click the Collapse/Expand

button on the parent layer.

button in the Timeline View toolbar’s extra buttons.

To collapse or expand all layers in the Timeline view:
Do one of the following:
‣

Right-click on the layers and select Collapse/Expand > Expand All or Collapse All.

‣

Press [0] and [9].

‣

Click the Collapse All

or Expand All

buttons in the Timeline View toolbar’s extra buttons.

To collapse and expand 3D Path columns in the Xsheet view:
1. In the Xsheet view, display the Functions section by clicking the Show Column List

button.

2. In the Functions section, select the header of the 3D Path column to collapse.
3. Do one of the following:
‣

Right-click on the column’s header and select Expand/Collapse > Collapse Selection.

‣

To expand a collapsed column, select the column’s header, right-click on the selection and select
Expand/Collapse > Expand Selection.

‣

Click the Collapse Selection

or Expand Selection

buttons in the Xsheet View toolbar’s

extra buttons.
To collapse or expand all 3D Path columns in the Xsheet view:
Do one of the following:
‣

Right-click on any column’s header and select Collapse/Expand > Expand All or Collapse All.

‣

The [0] and [9].

‣

Click the Collapse All

or Expand All

buttons in the Xsheet View toolbar’s extra buttons.
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Related Topics
•

Layers and Columns on page 355

•

Layer and Column Concepts on page 355

•

Advanced Column Types on page 1

•

Layer Content on page 359

•

Adding New Drawing Layers on page 360

•

Deleting Layers And Columns on page 363

•

Modifying Layers on page 365

•

Duplicating Layers and Columns on page 372

•

Cloning Layers And Columns on page 373

•

Xsheet Thumbnails on page 374

•

Changing the Colour of a Layer or Column on page 374

•

Modifying the Look of the Column on page 1

•
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Filling Exposure
Toon Boom Animate provides different tools to fill-in exposures and values, create cycles, and set increments.

Related Topics
•

Filling Exposure Mode below

•

Typing Exposure on the facing page

•

Holding Exposure on page 1

•

Extending a Single Exposure on page 382

•

Extending an Exposure Sequence on page 382

•

Dragging Cells on page 384

•

Increasing and Decreasing Exposure on page 386

•

Inserting Blank Cells on page 390

•

Setting the Exposure on page 391

•

Filling a Selection with a Single Exposure on page 392

•

Filling a Selection with a Sequence on page 393

•

Filling a Selection Randomly on page 395

•

Creating Cycles on page 396

Filling Exposure Mode
In the Xsheet view, you can fill columns using two different filling modes: Overwrite or Insert. These modes
control the filling behaviour. The Timeline view only uses the Overwrite mode.
To toggle between Overwrite and Insert modes:

‣ In the Xsheet view’s right bottom corner, click the Overwrite/Insert button or press [I].

Overwrite Mode
By default, the Xsheet view is set to Overwrite mode. Add a new value or a new value sequence overwrites
existing ones. The existing timing sequence remains in the same place and is not pushed further down the
column.
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Insert Mode
The Insert mode is the opposite of the Overwrite mode. When you add a new value or a new value sequence over
existing ones, the new values are inserted between the old ones. The existing timing sequence is pushed down
the column.

Related Topics
•

Filling Exposure on the previous page

•

Filling Exposure Mode on the previous page

Typing Exposure
To fill in your exposure, you can directly type the values in the Xsheet and Timeline views.
•

Typing a Value in the Timeline View below

•

Typing a Value in the Xsheet View on the next page

Typing a Value in the Timeline View
If you want to type an exact drawing name or value into the Timeline view, you must use the Data view section of
the Timeline.
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You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).

To type a value in the Timeline view:
1. In the Timeline view, click the Show Data View

button.

2. In the Drawing Substitution field, type the name of the drawing you want to create, and press
[Enter/Return].

Typing a Value in the Xsheet View
To enter a value in a column’s cell, double-click in the cell and type the numbers or letters.

You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).

•

Press [Enter/Return] to move on to the next cell.

•

Press [Esc] to exit the typing mode and return to normal mode.

To type values in the Xsheet view:
1. In an Xsheet column, double-click on one cell.

2. Type a value or drawing name in the cell.

3. Press [Enter/Return] to move on to the next cell.

4. Press [Esc] to quit the typing mode.
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Related Topics
•

Filling Exposure on page 379

Extending a Single Exposure
The Extend Exposure feature allows you to select an Xsheet’s cell containing a value and to pull it down to the
desired frame.
To extend a cell exposure:
1. In the Xsheet view, select the red arrow

in the cell’s right side. Make sure to see the drag down

cursor.

2. Pull down the selected cell to the desired frame.

The red selection box must be visible when releasing the mouse button. If it is not visible, the action
is considered cancelled.

Related Topics
•

Filling Exposure on page 379

Extending an Exposure Sequence
You can extend and create a sequence using almost the same procedure as you would when you extend a single
exposure. The only differences being that the selected cell must only contain numbers and that you need to press
the [Shift] key while pulling down on the selection.
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The creation of the sequence only works with numbers in the selected cell, not letters.

To create a sequence:
1. In the Xsheet view, select a cell containing a number.
2. In the selected cell, click on the red arrow on the cell’s right side. Make sure to see the drag down
cursor.

3. Hold down the [Shift] key. Make sure a plus (+) sign appears.
4. Pull down the selection box to the desired frame.

The red selection box must be visible when releasing the mouse button. If it is not visible, the action
is considered as cancelled.

5. First release the [Shift] key, then release the mouse button.

You can also select a cell and select Animation > Cell > Extend Exposure or press [F5]. In the dialog
box, type the frame number you want to extend the cell to.

Related Topics
•

Filling Exposure on page 379
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Dragging Cells
To readjust your timing, you can drag one or several cells to a new location in both the Timeline and Xsheet
views.
You can drag a cell to any other frame in the same column or into another column.
To drag a cell to another location in the Timeline view:
1. In the Timeline view, select one or several cells to move.

2. Click on the cells selection and drag it to the new location.

‣

If you drop the selection, it overwrites the existing cells.

‣

If you hold [Ctrl] (Windows) or [⌘ ] (Mac OS X) while dropping the selection, the cells are copied and
not moved.

‣

If your press [Shift] while dropping, the selection is inserted between the existing frames.

To drag a cell to another location in the Xsheet view:
1. In the Xsheet view, select one or more cells.

2. In the Xsheet view, select the small dotted area

on the left side of the selected cells.
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3. Drag the selection to any other cell in the same column or in another column.

‣

If you drop the selection, it overwrites the existing cells.

‣

If you hold [Ctrl] (Windows) or [⌘ ] (Mac OS X)while dropping the selection, the cells are copied and
not moved.

‣

If your press [Shift] while dropping, the selection is inserted between the existing frames.
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You can turn off the Gestural Drag Mode for the Xsheet view to prevent drawings from being dragged from one
location to another. A Toggle Gestural Drag Mode button is available for this feature, accessible by customizing
the Xsheet View toolbar. Otherwise, access it by right-clicking on a cell or the Xsheet's Edit menu.
To turn off the Gestural Drag mode:

‣ In the Xsheet view, right-click and deselect the Gestural Drag Mode option.
‣ You can also customize the Xsheet View toolbar and display the Toggle Gestural Drag mode button to
enable and disable this option.

The dragging pad disappears when the Gestural Drag mode is off.

This feature does not apply for Annotation columns.

Related Topics
•

Filling Exposure on page 379

Increasing and Decreasing Exposure
Once a value is entered in the Timeline or Xsheet view, you can increase and decrease its exposure.

Related Topics
•

Increasing Exposure below

•

Decreasing Exposure on the next page

•

Increase/Decrease Exposure Field on page 388

•

Clear Exposure and Pull on page 388

Increasing Exposure
Increasing the exposure adds one more exposure to a selected cell, repeating this action adds an extra cell every
time. This is a quick way of extending a drawing exposure and is always set in the Insert mode. Increasing an
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exposure always pushes the existing exposure down.
To use Increase Exposure:
1. In the Timeline or Xsheet view, select a cell.

2. Do one of the following:
‣

In the top menu, select Animation > Cell > Increase Exposure.

‣

Right-click on the selected cell and select Exposure > Increase Exposure.

‣

Press [+].

‣

In Harmony Xsheet,select Selected > Increase Exposure.

‣

Click the Increase Exposure

button in the Xsheet View and Timeline View toolbars’ extra buttons.

3. Repeat this action to add more cells to your drawing’s exposure.

Related Topics
•

Decreasing Exposure below

•

Increase/Decrease Exposure Field on the facing page

Decreasing Exposure
Decreasing the exposure removes one exposure from a selected cell. Repeating this action removes an extra cell
every time. This is a rapid way to reduce a drawing exposure and remove the exposed drawing.
To decrease exposure:
1. In the Timeline or Xsheet view, select a cell.

2. Do one of the following:
‣

In the top menu, select Animation > Cell > Decrease Exposure.

‣

Right-click on the selected cell and select Exposure > Decrease Exposure.

‣

Press [-].

In Harmony Xsheet,select Selected > Decrease Exposure.
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‣

Click the Increase Exposure

button in the Xsheet View and Timeline View toolbars’ extra buttons.

3. Repeat this action to decrease more cells to your drawing’s exposure.

Related Topics
•

Increasing and Decreasing Exposure on page 386

•

Clear Exposure and Pull below

Increase/Decrease Exposure Field
Another technique you can use to quickly increase or decrease the exposure of a selected drawing is by making
use of the Increase/Decrease Exposure field available in the Xsheet view.
To increase and decrease exposure using the Increase/Decrease Exposure field:
1. In the Xsheet view, select the cell to modify.

2. In the Xsheet’s bottom-right corner, increase or decrease the drawing’s exposure by clicking the up or
down arrows. To increase the exposure, press [+]. To decrease the exposure, press [-].

Related Topics
•

Increasing and Decreasing Exposure on page 386

•

Decreasing Exposure on the previous page

•

Clear Exposure and Pull below

Clear Exposure and Pull
You can reduce a drawing’s exposure using the Clear Exposure and Pull option.
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To use the Clear Exposure and Pull feature:
1. In the Timeline or Xsheet view, select a cell.

2. Do one of the following:
‣

In the top menu, select Animation > Cell > Clear Exposure and Pull.

‣

Right-click on the selected cell and select Exposure > Clear Exposure and Pull.

‣

In Harmony Xsheet, select Selected > Clear Exposure and Pull.

‣

Click the Clear Exposure

‣

Press [Z].

button in the Xsheet View and Timeline View toolbars’ extra buttons.

Related Topics
•

Increasing and Decreasing Exposure on page 386

Deleting Exposure
You can delete a drawing’s exposure in several simple ways. Note that when you delete a drawing’s exposure
from the Timeline or Xsheet view, you are not deleting the actual drawing file. You can always bring it back by
typing its name again in a cell.
You can delete the exposure contained in a selected cell range or delete the entire exposure of a drawing
exposed over several cells. Note that you can also delete the exposure for drawings contained inside a collapsed
group.
To delete selected exposures:
1. In the Timeline or Xsheet view, select the exposure you want to delete.
2. Right-click on the selection and select Delete or press [Delete].
To completely clear the exposure of a drawing:
1. In the Timeline or Xsheet view, select a cell of a drawing exposed over several cells.
2. Do one of the following:
‣

In the top menu, select Animation > Cell > Clear Exposure.

‣

In the Timeline view, right-click on the selection and select Exposure > Clear Exposure.

‣

Click the Clear Exposure

button in the Timeline View toolbar’s extra buttons.
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Related Topics
•

Filling Exposure on page 379

•

Layer and Column Concepts on page 355

Inserting Blank Cells
Use the Insert Blank Cell option to place an empty cell between other cells. This is always done in Insert mode
and pushes down existing exposure, even if you are set to Overwrite mode.
To insert blank cells:
1. In the Xsheet or Timeline view, select the cell where you want to insert a blank cell.

2. Do one of the following:
‣

In the top menu, select Animation > Cell > Insert Blank Cell.

‣

In Harmony Xsheet, select Selected > Insert Blank Cell.

‣

Right-click on the selected cell and select Exposure > Insert Blank Cell.

‣

Press [Shift] + [J].

‣

Click the Insert Blank Cell

button in the Timeline View and Xsheet View toolbars’ extra buttons.

The blank cell is inserted.

To clear a selected cell range without changing the exposure and timing:
1. In the Xsheet view, select the frame range to clear.
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2. Right-click on the selected cells and select Clear.

Related Topics
•

Filling Exposure on page 379

Setting the Exposure
You can easily increase or decrease the exposure for a selected cell range by using the Set Exposure options.
To use the Set Exposure options:
1. In the Timeline or Xsheet view, select the cell range that you want to set the exposure for.

2. In the top menu, select one of the following:
‣

Animation > Cell > Set Exposure > Set Exposure to 1

‣

Animation > Cell > Set Exposure > Set Exposure to 2

‣

Animation > Cell > Set Exposure > Set Exposure to 3

‣

Animation > Cell > Set Exposure
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You can also click the Set Exposure

buttons in the Timeline View toolbar’s extra buttons.

3. In Harmony Xsheet, right-click and select Exposure > Set Exposure to and then select one of the
following:

‣ Set Exposure to 1
‣ Set Exposure to 2
‣ Set Exposure to 3
‣ Set Exposure
If you choose the Set Exposure option, the Set Exposure dialog box opens.

4. Type the amount of frames you want the drawings to be displayed and click OK.
The new timing is displayed in the Xsheet view.

Related Topics
•

Filling Exposure on page 379

Filling a Selection with a Single Exposure
The Fill Selection option is used to fill the same value all over a selection. The selection can be over one cell, a cell
range in one column, a cell range over many columns, an entire column or many entire columns. You can use
numbers, words, letters or any alphanumeric value.
To use Fill Selection:
1. In the Xsheet or Timeline view, select a cell range.

2. Do one of the following:
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‣

Select Animation > Cell >Fill Selection.

‣

Press [Ctrl] + [T] (Windows) or [⌘ ] + [T] (Mac OS X)).

‣

In Harmony Xsheet, select Selected>Fill Selection.

‣

Click the Fill Selection

button in the Xsheet View and Timeline View toolbars’ extra buttons.

The Fill Selection dialog box opens.

3. In the Value field, type the desired value and click OK.

Related Topics
•

Filling Exposure on page 379

Filling a Selection with a Sequence
The Sequence Fill option is used to create a number sequence over a selection. The sequence can be forward,
backward, single, double or higher increment, as a cycle, etc. The selection can be over one cell, a cell range in
one or more columns, an entire column, or several entire columns.
To fill a selection with a sequence:
1. In the Xsheet or the Timeline view, select a cell range.

2. If you are working in the Xsheet view, select Animation > Cell > Sequence Fill. Click the Sequence Fill
button in the Xsheet View toolbar's extra buttons.
In Harmony Xsheet, select Selected > Sequence Fill. You can also click on the Sequence Fill
available in the Xsheet View toolbar's extra buttons.
OR
If you are working in the Timeline view, right-click and select Exposure > Sequence Fill.
‣

Press [Ctrl] + [M] (Windows) or [⌘ ] + [M] (Mac OS X).

The Sequence Fill dialog box opens.
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3. In the Starting Value field, type the starting number for the number sequence.
4. In the Increment field, type the increment to which the number will change from frame to frame.
(1-2-3-4, 1-3-5-7, 10-9-8-7-6-5-4-3-2-1). The value can be positive or negative.
5. In the Hold field, choose an exposure holding value.
6. Select the Cycle option if you want a cycle; type the number of cells for this cycle’s duration.

If you choose a two cell hold, a cycle of three drawings will last for six cells.

7. If you selected a larger range than the amount of frames needed, select the End Frame option and type
the last frame needed.

8. If you want to have more than one digit in your numbers such as “001” instead of “1”, select the Padding
option and add as many pound signs (#) as digits needed. Also, you can type a letter or word in the field
for it to be added in front of the drawing number.

9. Click OK.
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Related Topics
•

Filling Exposure on page 379

Filling a Selection Randomly
The Fill Cells Randomly option is used to fill in random values over a selection. You can give a maximum and a
minimum value and create a range for the system to choose the random values from. The selection can be over
one cell, a cell range in one column, a cell range over many columns or an entire column or several entire columns.
To use Fill Cells Randomly:
1. In the Xsheet view, select a cell range.

2. Select Animation > Cell > Fill Cells Randomly.
In Harmony Xsheet, select Selected > Cell > Fill Cells Randomly.
‣

You can also click on the Fill Cells Randomly

button available in the Xsheet View toolbar’s extra

buttons.
The Fill Cells Randomly dialog box opens.

3. In the Minimum Value field, type a minimum value.
4. In the Maximum Value field, type a maximum value.
5. In the Hold field, choose an exposure holding value.
6. If you are applying this option to a drawing column, enable the Whole Numbers option to avoid decimal
points.
7. Click OK.
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Related Topics
•

Filling Exposure on page 379

Creating Cycles
Once you have entered a series of drawings and exposures, you can create cycles out of them in several ways.
You can loop your drawings using the following commands:
•

Paste Cycle

•

Paste Reverse

•

Create Cycle

When you create a drawing cycle, all of the repeated drawings are linked to the same original files. This means
that when you modify, repaint or correct a drawing named “1” all drawings named “1” are updated
simultaneously. In order to modify a drawing independently from its other exposures, you must duplicate the
drawing.

To use the Paste Cycle command:
1. In the Xsheet or Timeline view, select the cell range to loop.

2. In the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.
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4. In the top menu, select Edit > Paste Cycle.
In Harmony Xsheet, right-click and select Paste Cycle.
‣

The [Ctrl] + [/] (Windows) or [⌘ ] + [/] (Mac OS X).

The Paste Cycle dialog box opens.

5. In the Number of Cycles field, use the up and down arrow to increase or decrease the amount of cycles
you want to paste. You can also directly type the value.
6. In the Cycle Type drop-down menu, select the type of cycle you want to paste.

‣

Normal (forward): Pastes your selection as it is, starting with the first cell and ending with the last
one.

‣

Reverse: Pastes your selection reversed, starting with the last cell and ending with the first one.

‣

Forward -> Reverse: Pastes your selection as a yo-yo, starting with the first cell, going to the last one
and ending with the first cell.

‣

Reverse -> Forward: Pastes your selection as a reversed yo-yo, starting with the last cell, going to the
first one and ending with the last cell.

7. Click OK.
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You can do the same operation using the Paste Special dialog box. To open the Paste Special dialog
box, select Edit > Paste Special or press [Ctrl] + [B] (Windows) or [⌘] + [B] (Mac OS X).

To use the Paste Reverse command:
1. In the Xsheet or Timeline view, select the cell range to paste inverted.

2. In the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4. In the top menu, select Edit > Paste Reverse.
In Harmony Xsheet, right-click and select Paste Reverse.
‣

Press [Ctrl] + [.] (Windows) or [⌘ ] + [.] (Mac OS X).
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To use the Create Cycle command:
1. In the Timeline view, select the cell range to loop.

2. In the Timeline View toolbar, click on the Create Cycle

button located in the toolbar’s extra buttons.

The Create Cycle dialog box opens.

3. Enter the number of cycles you want, including the current selection.

Related Topics
•

Filling Exposure on page 379
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Navigating between Frames and Columns
Once a cell is selected in the Timeline or Xsheet view, you can navigate between the layers, frames and drawings
using keyboard shortcuts that are effective in the Camera, Drawing, Timeline and Xsheet view.
You can navigate through:
•

Columns

•

Drawings

•

Frames

To navigate through the drawings, frames and columns:
1. In the Timeline or Xsheet view, select a cell.

2. Once the cell is selected, you can navigate between:
‣

Previous and next layers from the top menu, you can select Edit > Previous Layer and Next Layer.
You can also press [H] and [J].

‣

Previous and next drawings, from the top menu, select Edit > Previous Drawing and Next Drawing
or Drawing > Previous Drawing and Next Drawing. You can also press [F] and [G].
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‣

Previous and next frames, from the top menu, select Play > Previous Frame and Next Frame. You
can also press [,] and [.].
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Managing Drawings
Drawings that are created in Toon Boom Animate are not encapsulated in their cells. They are actual files stored
in the project’s folder. If you want to rename a drawing or delete a drawing from your project, you need to edit
the file and not the cells.

You also have the option of marking your drawing as Key, Breakdown and In-betweens—see
Drawing Identification on page 241 to learn more about this feature.

Related Topics
•

Renaming a Drawing below

•

Renaming Drawings by Frame Position on the next page

•

Deleting a Drawing on page 404

•

Duplicating a Drawing on page 405

•

Copying and Pasting Drawings on page 406

•

Drawing Identification on page 241

Renaming a Drawing
To rename a drawing, you do not type the new name in the cell. You need to select the cell containing the
drawing and use the Rename Drawing command.
To rename a drawing:
1. In the Timeline or Xsheet view, select the drawing to rename.

2. Do one of the following:
‣

In Harmony Stage's top menu, select Drawing > Rename Drawing or press [Ctrl] + [D] (Windows) or
[⌘ ] + [D] (Mac OS X).

‣

Click the Rename Drawing

button in the Timeline View or Xsheet View toolbars’ extra buttons.

‣ In Harmony Xsheet, use the Rename Drawing
buttons.
The Rename Drawing dialog box opens.
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3. In the New Name field, type the new drawing name.

Related Topics
•

Managing Drawings on the previous page

•

Renaming Drawings with a Prefix below

•

Renaming Drawings by Frame Position below

•

Deleting a Drawing on the facing page

•

Duplicating a Drawing on page 405

•

Copying and Pasting Drawings on page 406

Renaming Drawings with a Prefix
You have a the possibility to rename a drawing sequence with a prefix. This option can be quite useful for cut-out
puppet breakdown and deformation animation.
To rename a drawing sequence with a prefix:
1. In the Xsheet or Timeline view, select your drawing sequence. Note that you can only select a drawing
range in one column or layer at the time.
2. Right-click and select Drawings > Rename Drawing with Prefix.
The Rename Drawing with Prefix dialog box opens.

3. In the Prefix to Add field, type the prefix you want to add before your drawing name.

Related Topics
•

Managing Drawings on the previous page

•

Renaming a Drawing on the previous page

•

Renaming Drawings by Frame Position below

•

Deleting a Drawing on the facing page

•

Duplicating a Drawing on page 405

•

Copying and Pasting Drawings on page 406

•

Deformation

•

Character Building on page 553

Renaming Drawings by Frame Position
You can rename a series of drawings relative to their frame position. This is useful in hand-drawn animation.

403

Chapter 7: Timing Managing Drawings

To rename drawings by their frame position:
1. In the Xsheet or Timeline view, select the drawing sequence to be renamed.

2. In the top menu, select Drawing > Rename by Frame.

Related Topics
•

Managing Drawings on page 402

•

Renaming a Drawing on page 402

•

Renaming Drawings with a Prefix on the previous page

•

Deleting a Drawing below

•

Duplicating a Drawing on the next page

•

Copying and Pasting Drawings on page 406

Deleting a Drawing
To permanently delete a drawing file, select the drawing you want to delete and use the Delete Selected
Drawings command.

Deleting a drawing file is an operation that cannot be undone.

To delete a drawing:
1. In the Timeline or Xsheet view, select the drawings to delete.

404

Toon Boom Animate 3 User Guide

2. In the top menu, select Drawing > Delete Selected Drawings.

Related Topics
•

Managing Drawings on page 402

•

Renaming a Drawing on page 402

•

Renaming Drawings with a Prefix on page 403

•

Renaming Drawings by Frame Position on page 403

•

Duplicating a Drawing below

•

Copying and Pasting Drawings on the facing page

Duplicating a Drawing
If you want to modify a drawing that already exists, but keep the original drawing intact, you can duplicate the
drawing and work on the copy. When duplicating a drawing, the selected cell is replaced with the new drawing.
The exposure of the original drawing that was on the current cell is removed. The drawing is not deleted.
To duplicate a drawing:
1. In the Timeline or Xsheet view, select the drawing to duplicate.

2. In the Xsheet View toolbar, cilck the Duplicate Drawing

button.

3. In Harmony Stage's top menu, select Drawing > Duplicate Drawing or press [Alt] + [Shift] + [D].

With Toon Boom Animate you can create a keyframe at the same time as you duplicate your drawing. This way
you can modify and reposition your drawings without affecting the original drawing.

Related Topics
•

Managing Drawings on page 402

•

Renaming a Drawing on page 402

•

Renaming Drawings by Frame Position on page 403
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•

Deleting a Drawing on page 404

•

Duplicating a Drawing on the previous page

•

Copying and Pasting Drawings below

Copying and Pasting Drawings
When you copy and paste a selection in the Timeline or Xsheet view, you are not copying and pasting the actual
drawings, you are pasting the exposure.
If you want to copy and paste the selected drawings into a different layer or paste the selection in the same layer
to duplicate the drawings, you must use the Paste Special feature.
There are two main ways to paste your selected drawings with the Paste Special dialog box:
•

Always Create Drawings
This option pastes all of your drawings as they are. If a drawing has the same name as an existing one, it is
renamed and duplicated.

•

Only Create Drawings When They Do Not Exist
This option only pastes only the drawings that are named differently from existing drawings. If a drawing
has the same name as an existing one, it is ignored and not pasted. This avoids duplicating drawings in
your layers.
This option is useful when you are pasting cut-out character templates containing drawings you may
already have in your scene and some new ones. Using this option, you only paste the new drawings and
are not duplicating all of the other parts you already have.

To paste drawings with the Paste Special command:
1. In the Timeline or Xsheet view, select the drawings to copy.

2. In the Timeline or Xsheet view, select the cell where you want your pasted selection to start.

3. In the top menu, select Edit > Paste Special or press [Ctrl] + [B] (Windows) or [⌘ ] + [B] (Mac OS X). You
can also click the Paste Special
button in theTimeline View andXsheet View toolbars’ extra buttons.
The Paste Special dialog box opens.
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4. Select the Basic tab.
5. In the Drawings section, select the Always Create Drawings or the Only Create Drawings When They
Do Not Exist option depending on what you need.

If you want to perform another paste special operation using the same settings you used previously,
you can use the Paste Special Again command instead of the Paste Special command. This feature
paste your selection using the same settings you used in your last paste special without opening the
Paste Special dialog box.
To use the Paste Special Again command, select Edit > Paste Special Again or press [Ctrl] + [Shift] +
[B] (Windows) or [⌘] + [Shift] + [B] (Mac OS X). You can also click the Paste Special Again
button
in theTimeline View andXsheet View toolbars’ extra buttons.

Related Topics
•

Managing Drawings on page 402

•

Renaming a Drawing on page 402

•

Renaming Drawings with a Prefix on page 403

•

Renaming Drawings by Frame Position on page 403

•

Deleting a Drawing on page 404

•

Duplicating a Drawing on page 405
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Tempo Markers
Tempo markers are used to synchronize your animation with a musical score. Using this feature, you can
reproduce the FPB (Frames Per Beat) and the tempo signature as Tempo markers. The Xsheet view allows you
to pace your animation according to the tempo or beat of your soundtrack music or to any rhythmical sound,
such as the ticking of a clock or water leaking from a spout.

To set the Tempo Markers:
1. In the Xsheet view, right-click and select View > Set Tempo Marker.
The Tempo Marker dialog box opens.

2. Reproduce the tempo and beat value of your music or sound for the Xsheet view marker display.
‣

Starting Frame: Type the number of the frame where you want the tempo markers to begin.

‣

Frames/Beat: Set the Frames Per Beat value. This will determine the frequency (in frames) a beat
marker will appear. Keep in mind that, by default, 24 frames represent 1 second.

‣

Beat/Bar: Set the Tempo of your music or sound. This will determine the frequency (in beats) a tempo
marker will appear in the Xsheet view.

3. Click OK.
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Related Topics
•

Timing on page 339
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Annotation Columns
The Annotation columns are a more than just a useful tool. They allow you to mark actions, corrections or any
other information related to your animation that you would like to draw or write. This way, you can print your
Xsheet, take it back to your animation table and work with the annotations.

Related Topics
•

Adding an Annotation Column below

•

Drawing and Typing in the Annotation Column on the next page

•

Changing the Drawing Settings on page 1

•

Importing an Annotation File on page 1

Adding an Annotation Column
To add an annotation column:
1. Do one of the following:
‣

In the Xsheet View menu, select Columns > Add Columns.

‣

In the Xsheet View toolbar, click the Add Columns

‣

Press [Shift] + [C].

button.

The Add Columns dialog box opens.

2. In the Column Name field, name your column accordingly.
3. In the Column Type field, select Annotation.
4. Click OK.
The new column appears.

Related Topics
•

Annotation Columns above

•

Drawing and Typing in the Annotation Column on the next page

•

Changing the Drawing Settings on page 1

•

Importing an Annotation File on page 1
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Drawing and Typing in the Annotation Column

In the annotation column, you can not only type in your notes and relevant information, but also draw sketches
and ideas which will be useful in producing your animation.
•

Drawing in the Annotation Column below

•

Typing in the Annotation Column on the facing page

•

Erasing Annotation Column Content on the facing page

Drawing in the Annotation Column
Before you can draw in the annotation column, you must first activate the Enable Drawing option. Once this is
done, you can start drawing using the mouse or the pen tablet.

Pen tablet pressure sensitivity is not supported in the annotation column.

To enable drawing in the annotation column:
1. In the Xsheet View menu, select Annotation > Enable Drawing. You can also click on the column’s header
icon to toggle the Drawing, Selection and Erasing modes.
‣

The Select

icon indicates that the Select mode is enabled.

‣

The Brush

icon indicates that the Drawing mode is enabled.

‣

The Eraser

icon indicates that the Erasing mode is enabled.

To draw in the annotation column:

‣ To draw in an annotation column, simply use your mouse or pen tablet.
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Typing in the Annotation Column
Typing in an annotation column is independent from the Drawing mode. You can be in either mode and the
typing will work.
To type in an annotation column:
1. In the annotation column, press [Ctrl] (Windows) or [⌘ ] (Mac OS X) on the cell where you want to write. By
pressing [Ctrl] + [Shift] + click (Windows) or [⌘ ] + [Shift] + click (Mac OS X) in the annotation column, you
will enter the editing mode in the cell at the current frame.

2. In the selected cell, type the desired text.

Refer to the topic Typing Exposure on page 380 to get more information about typing values in the
Xsheet view.

Erasing Annotation Column Content
You can erase part or all of the annotation column’s content.
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To erase the annotation content:
1. In the Xsheet view, enable the Erasing mode by clicking on the mode icons.

2. In the Xsheet view, select the cell range you want to clear from text or images. Do not select any cells if
you plan to clear everything.

3. In the Xsheet view, right-click in the annotation column and select:
‣

Annotation > Erase All to erase completely the content of the column.

‣

Annotation > Erase Selected Images to erase the images contained in the selected cell range. Make
sure to disable the Drawing mode to do so.

‣

Annotation > Erase Selected Texts to erase the text contained in the selected cell range. Make sure
to disable the Drawing mode to do so.

Tip: You can also use the Erasing mode to erase part of a drawn annotation.

To erase part of a drawn annotation using Erasing mode:
1. In the Annotation column’s header, enable the Erasing mode.

2. In the column, click and drag the cursor on top of the drawn annotation to erase parts of it.
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Annotations that you type in are not erased using this method.
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Timing Preferences
When adjusting your timing in the Timeline andXsheet view, you may want to set some preferences.
This section covers the preferences related to timing, Timeline and Xsheet view.

The preferences related to Harmony Xsheet can be found under the Exposure Sheet tab only.

You will find the preferences listed under the following tabs:
•

Exposure Sheet

•

Timeline

•

Advanced

To open the Preferences panel:
‣

Windows: Select Edit > Preferences.

‣

Mac OS X: Select Animate> Preferences.

‣

The [Ctrl] + [U] (Windows) or [⌘ ] + [U] (Mac OS X).

Related Topics
•

Exposure Sheet Preferences below

•

Timeline Preferences on page 417

•

Advanced Preferences on page 418

Exposure Sheet Preferences
This is the Exposure Sheet preferences tab.
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Filtering
These preferences are used to display or hide certain layer types in the Xsheet view.
•

Show Drawing Columns: Displays the Drawing layers in the Xsheet view.

•

Show Function Columns: Displays the Function columns layers in the Xsheet view.

•

Show Annotation Columns: Displays the Annotation columns layers in the Xsheet view.

•

Show 3D Path Columns: Displays the 3D Path columns in the Xsheet view.

•

Show Sound Columns: Displays the Sound columns in the Xsheet view.

Options
•

Default Add Columns: The default position where the new column will be added.

•

Default Column Width: The default width value for the new column being created.

New Element
•

Bitmap Format: By default, when you create a new empty bitmap column, it will use the file format
indicated in the field as the new column format. The default value is SCAN, which means that it is set for
scanned-in drawings.

•

Scan Type: By default, the Scan Type is set to 2 which equals vector import. This means that the imported bitmap
images will be placed into a Drawing layer. Scan type 1 is bitmap import.

Apply/Next
•

From Left to Right: When clicking on the Apply/Next button in the Xsheet view Column Properties, the
next column to be displayed in the Column Properties will be the one on the right.
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•

From Right to Left: When clicking on the Apply/Next button in the Xsheet view Column Properties, the
next column to be displayed in the Column Properties will be the one on the left.

Related Topics
•

Timing Preferences on page 415

•

Timeline Preferences below

•

Advanced Preferences on the facing page

Timeline Preferences

Defaults
•

Show Groups: Displays the Group layers in the Timeline.

•

Show Effects: Displays the Effect layers in the Timeline.

•

Show Sound: Displays the Sound layers in the Timeline.

Paste/Drag & Drop
•

Add keyframes at beginning and end: Select this option to copy and paste a set of frames that includes
an interpolated sequence between two keyframes, but only extracts a partial section. Under normal
circumstances, cutting and pasting a function without either the start or end keyframe would render the
function null. This option caps the partial function with a new keyframe when you perform the paste.

Related Topics
•

Timing Preferences on page 415

•

Exposure Sheet Preferences on page 415

•

Advanced Preferences on the facing page
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Advanced Preferences

•

Advanced Element Mode: Displays more options in the Add Column dialog box and the Column
Properties dialog box.
•

Auto-rename Elements: Controls whether to rename the element whenever the corresponding
module name in the Network view or layer name in the Timeline view is changed.

Related Topics
•

Timing Preferences on page 415

•

Exposure Sheet Preferences on page 415

•

Timeline Preferences on the previous page
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Chapter 8: Morphing

Hand-drawn animation requires you to spend a lot of time tracing in-between drawings. Animate speeds up the
process using its helpful Morphing feature. This powerful and useful feature creates computer generated
drawings and places them between vector drawings to save time and increase quality. Animation created with
the Morphing feature can be reused in different projects. You can easily modify the timing and velocity (ease in
and ease out).
One of the main uses of the Morphing feature is in effect animation. For example, animating smoke or water can
be time-consuming because these types of effects are usually slow moving requiring a large number of closely
placed in-betweens.

Topics Covered
•

Understanding Morphing on the facing page

•

Source and Destination Drawings on page 421

•

Morphing Rules on page 422

•

Creating a Basic Morphing Sequence on page 426

•

Tool Properties View on page 429

•

Adjusting the Velocity and Timing on page 433

•

Morphing Tool and Hints on page 437

•

Morphing Two Sequences in a Row on page 446

•

Inserting a Morphing Key Drawing on page 447

•

Converting Morphing In-betweens to Drawings on page 449

•

Morphing Holes and Transparencies on page 450

•

Adjusting the Morphing Quality on page 453

•

Tips and Tricks on page 454

•

Morphing Preferences on page 455
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Understanding Morphing
The Morphing feature is used to animate similar and simple shapes such as hair or smoke. It helps you by saving
time when you are working on tedious in-betweening and tracing tasks This, in turn, provides you with more time
to spend on complex animation tasks such as walk-cycles or acrobatic sequences.

Ideas Behind Morphing
To learn how to morph drawings, it is better to start with basic shapes such as circles and rectangles. Once you
are more familiar with the tool, you can increase your knowledge and expertise. In a very short time you will be
producing some remarkable effects.
It is helpful to know the pros and cons of morphing before you start. Understanding what you can do and which
drawing lines can give you a problem will enable you to design your key drawings so they morph efficiently.

The more complex the shape is, the longer it takes to morph. If it takes more time to morph a drawing
than to hand draw it, then it is better to animate it instead of morphing. However, if you spot an
occasion when you can morph your drawings, do it! It allows you to fix your timing and velocity in no
time without having to create any extra drawings!

Related Topics
•

Source and Destination Drawings on the next page
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Source and Destination Drawings

The Morphing feature matches similar shapes in two drawings. These are the source and destination drawings.
Animate evaluates the source's shape properties and matches them to the most similar one in the destination
drawing.
Morphing works between similar shapes, which are drawings that have the same palette, colours and number of
shapes. You can even change a rabbit into an elephant, as long as source and destination keep the same colours
and number of shapes.

Related Topics
•

Creating a Basic Morphing Sequence on page 426

•

Morphing Rules on the facing page
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Morphing Rules
Animate follows a set of rules as it evaluates the shapes. Familiarize yourself with these basic morphing rules
before you start morphing.

Related Topics
•

Closest Similar Shape below

•

Pencil Line to Pencil Line below

•

Fill Shape to Fill Shape on the next page

•

Colour Swatch to Same Colour Swatch on page 424

•

Vanishing and Appearing on page 424

•

Colour Art to Colour Art and Line Art to Line Art on page 425

Closest Similar Shape
A colour, line shape or zone will morph with the closest similar one in the destination drawing. This means it will
morph with the zone nearest to it, as long as that zone uses the same palette's colour swatch (Colour ID) and
has the same vector properties (Central or Contour).

Pencil Line to Pencil Line
If you trace a shape using a pencil line such as the Ellipse

, Rectangle

, Polyline

, Line

or Pencil

tool, you have to morph it with another pencil line. Make sure that both drawings are pencil shapes (central
vector).

422

Toon Boom Animate 3 User Guide

A pencil line will never morph with a brush stroke.
Pencil lines with thickness ARE SUPPORTED in morphing sequences. The thickness will morph according to the
thickest and thinnest areas in the source and destination drawings.

If you have pencil lines in your source drawing, the same number of pencil lines must be present in
the destination drawings. A pencil line will appear if it is not found in the destination drawing. It will
pop out on the first or last frame depending on which one it is drawn.

When two pencil lines cross one another, they are considered to be two lines and not four lines
anymore (as it was in previous versions of the application). In this case, you must have two pencil lines
in your destination drawing for your morphing to work correctly.

Fill Shape to Fill Shape
If you have a brush line or a colour fill zone which are contour vectors, make sure that you morph it with another
fill or brush line. Contour vectors will not morph with pencil lines (central vectors). A brush line can morph into a
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colour fill zone and vice versa.

Colour Swatch to Same Colour Swatch
Animate does not morph colours. If you want to perform a colour transition, you have to create the effect at the
compositing level. A colour palette is composed of colour swatches. Each colour swatch has its own unique
identification number, even if two colours pots are the same shade of red, they are identified independently. A
colour zone or shape will morph with another one painted with the same colour swatch.

Vanishing and Appearing
If a colour zone does not find a match in the first or the second drawing, it will progressively appear or
disappear.
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Colour Art to Colour Art and Line Art to Line Art
In Animate, there is an advanced concept for painting your drawings called Line Art and Colour Art. Basically, an
extra layer is added in your drawings so that you can fill the colour zones on a separate layer. The regular layer
on which you are drawing is called Line Art and the extra layer under the Line Art is the Colour Art.
•

A shape drawn in Colour Art can only be morphed with another shape existing in the Colour Art.

•

A shape drawn in Line Art can only be morphed with another shape existing in the Line Art.

•

A shape created in Colour Art can never morph with a shape created in Line Art.

Related Topics
•

Drawing with the Brush or the Pencil on page 123

•

Line Art and Colour Art Layers on page 314
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Creating a Basic Morphing Sequence

Once you are familiar with the basic rules, you can start creating morphing sequences. You need to practice and
become at ease with the Morphing feature. To begin, start with simple elements, once you become confident
with the morphing process you can move on to complex and advanced morphing techniques, such as head
rotation or full characters.
To create a basic morphing:
1. In the Timeline view, click on the Add Drawing Layer

button to add a new layer to your project.

2. Rename the new layer Morphing.
3. In the Timeline or Xsheet view, select the first cell in your layer.

4. In the Tools toolbar, select the Rectangle

tool or press [Alt] + [7].

5. In the Tool Properties view, enable the Auto Fill

option.

6. In the Colour view, click on the Set Paint Current Colour

button.

7. In the Colour list, select a colour to fill your rectangle with.

8. In the Colour view, click on the Set Pencil Current Colour
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9. In the Colour list, select a colour to trace your rectangle's outline with.

10. In the Camera or Drawing view, draw a rectangle.
‣

Hold down the [Shift] key if you want to draw a square.

‣

Hold down the [Alt] key if you want to draw the rectangle from its centre.

11.In the Xsheet or Timeline view, select the last cell.

12. Repeat Step 5 to Step 10 using the Ellipse

tool instead of the Rectangle tool or press [Alt] + [=].

‣

Draw an ellipse using the same outline colour as the rectangle ("Outline").

‣

Paint the ellipse with the same fill colour as the rectangle ("Fill").

13. In the Xsheet or Timeline view, select your first drawing's cell, the rectangle drawing.

14. In the Xsheet or Timeline view, right-click on the selection and select Morphing > Create Morphing or
press [Alt] + [M].
‣

In the top menu, you can also select Animation > Morphing > Create Morphing.

427

Chapter 8: Morphing Creating a Basic Morphing Sequence

Arrows appear between the two key drawings to show they are computer generated.

15. Use the Playback toolbar to play the morphing sequence. To flip through the in-betweens toggle between
[,] and [.] or press [F4] to toggle between the two key drawings.

Related Topics
•

Deleting a Morphing Sequence below

Deleting a Morphing Sequence
You may want to delete an entire morphing sequence in order to redo a sequence from scratch.
To delete an entire Morphing sequence:
1. In the Xsheet or Timeline view,right-click on a cell between two keyframes.
2. Select Morphing > Delete Morphing or from the top menu, select Animation > Morphing > Delete
Morphing.
The entire sequence between the two keyframes is removed.

Related Topics
•

Creating a Basic Morphing Sequence on page 426
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Tool Properties View

As you create and adjust your morphing sequences, you will often use the Tool Properties view. Using this view
allows you do things such as toggling between your key drawings, adjusting the easing or selecting a hint type.
To access the content of the Tool Properties view:

‣ Select the Morphing

tool in the Tools toolbar or press [F3].

Related Topics
•

Hint Type below

•

Hide Hints on the facing page

•

Show Morphing in Place on the facing page

•

Suggest Hints on the facing page

•

Switch Between Drawings on page 431

•

Flatten on page 431

•

Quality on page 431

•

Easing on page 431

•

Convert Hints on page 432

•

Time on page 432

Hint Type
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The Hint Type drop-down menu allows you to select the correct hint to remedy any problem areas in your
drawing.

You can have more than one hint type in your drawings. You can mix all of the hint types in your
morphing sequence.

Refer to:
•

Contour Hint on page 441

•

Morphing Tool and Hints on page 437

Hide Hints

The Hide Hints

button temporarily hides the hint points from the key drawings. Use this option when you

have a series of hint points hiding some lines you would like to see.

Show Morphing in Place
The Show Morphing In Place

option is used with morphing layers. Enabling this option prevents the currently

selected morphing layer from being shown on top of the others and maintains the correct layer ordering.

Refer to Morphing Layers.

Suggest Hints
The Suggest Hints

option is used to automatically set hint points on your key drawings as a help tool. If you

are not sure where to set your hints, you can use this option. It will set the main hints which you can then fine
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tune.

Switch Between Drawings
The Switch Between Drawings

button is used to toggle between the two key drawings in your morphing

sequence. This option is useful while setting hints or press [F4].

Flatten
The Flatten

option is used when you have to morph a sequence with a semi-transparent or transparent

colour in it.

Refer to Morphing Holes and Transparencies on page 450.

Quality
The Quality setting is used to make the lines of the morphed drawings smoother. Adjust this parameter when
you are doing an extreme close up of your animation.

Refer to Adjusting the Morphing Quality on page 453

Easing

The Easing option is used to adjust the starting and ending velocity of your morphing sequence so that the
motion is smooth and not mechanical.
You can adjust the Ease In and Ease Out value by dragging your cursor up and down or typing a new value. The
values go from -1.0 to 1.0.

Refer to Adjusting the Velocity and Timing on page 433
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Convert Hints

The Convert Hints

option is used to switch the type of the current selecting hint points. This option is useful

when you position hints and then realize they are not the right type. You can select them and convert them to the
correct type instead of deleting them and setting new ones.
Use the Morphing tool to select the hints and then convert them by going to the Tool Properties view and
selecting the new hint type from the Convert Hints drop-down menu.

Time
The Time parameter is used to set the timing on Appearing Point and Vanishing Point hints. These hints are used
to set the trajectory of appearing and vanishing objects, they do not have to appear or disappear from the first
frame to the last frame of the morphing sequence. With the Time parameter, select your Appearing Point or
Vanishing Point hint and type the frame number on which the object will start its animation.

Refer to the Appearing Point Hint topic to learn more.

Related Topics
•

Morphing Tool and Hints on page 437
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Adjusting the Velocity and Timing

Once you have established a morphing sequence, you can control its timing and velocity. When you look at your
animation you will notice that the morphing motion is constant. To produce a less mechanical motion, you will
probably want to create some ease in or ease out.
If you did not place your source and destination drawings on the correct frames you may need to extend or
shrink the sequence length.
•

Changing the Morphing Sequence Length below

•

Adjusting the Velocity in the Layer Properties Editor below

Changing the Morphing Sequence Length
To extend or shrink a morphing sequence length:
1. In the Timeline view, select the source or destination drawing.
2. Click on your selection and drag the drawing to its new frame.

Adjusting the Velocity in the Layer Properties Editor
If you have several morphing sequences on a single layer, you may find it easier to adjust their velocities on one
function curve rather than several separate ones. Having all of your velocity parameters in one place is more
efficient and easier to modify.
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Adjusting the velocity in the Layer Properties editor also allows you to reverse a section of the morphing
sequence. The sequence will always start with the source drawing and end at the destination. You can play the
morphing sequence backwards or forwards during the animation.
You can have two levels of easing. It is possible to adjust the velocity of each sequence in your layer
independently using the Tool Properties view and then adjust the morphing velocity function in the Layer
Properties editor to control the entire layer's easing.
To adjust the velocity in the layer editor:
1. In the Timeline view, double-click on the drawing element module to open the Layer Properties editor.

2. In the Layer Properties editor, go to the Drawing tab and click on the Function

button to create a

function curve.

3. In the Layer Properties editor, click on the Function
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4. Add a keyframe at the first frame of the morphing (Source) and one at the end (Destination) by clicking on
the Add/Remove Keyframe
button.

5. Move the end keyframe up.

It is important that the last keyframe remains above the first one.

6. Make sure that the first keyframe is NOT a Stop-motion keyframe. To do this, uncheck the Stop-motion
Keyframe option to disable it. To use the Toggle Stop-Motion Segment feature, press [S].
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7. Click on the keyframes and pull the Bezier handles to create ease in and ease out. If you make the curve go
downward instead of upward, the animation will play backward until the curve starts to go upward again.

If you have more than one morphing sequence in the same layer, you need to add a keyframe on the
velocity curve for each source and destination drawings.

If you want your morphing to play back on a double frame exposure rather than single frame, you can
use the Hold Value editor and set the velocity to change every second frame, instead of every frame.
In the Morphing Function editor, click on the Hold Value Editor
hold the value for two frames.

Related Topics
•

Function Curves on page 683

•

Adjusting the Ease on page 701
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Morphing Tool and Hints

Animate provides the Morphing

tool to control your morphing sequence, this works by placing different

types of hints to help the system morph the animation the way that you want it.
Hints are points which are placed in both the source and destination drawings, they associate zones and lines
between the two drawings. Hints are used to fix problem zones, such as a line that is not following the colour fill
zone.

Corners and points generally give the most problems. The software does not necessarily understand the
animation curves and may be unable to match corners. It will generally associate a corner with the nearest one,
this is not always correct and it is why we use hint points to determine what goes with what.

Related Topics
•

Using the Morphing Tool on the facing page

•

Hints on page 440

•

Copying Hint Points from One Drawing to Another on page 443
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Using the Morphing Tool
Hints are identification points existing in both the source and destination drawings to create associations
between the two of them.
To correct morphing distortions, Animate has different types of hints available for controlling different types of
problems:
•

Contour Hint on page 441

•

Zone Hint on page 441

•

Pencil Hint on page 442

•

Vanishing Point Hint on page 442

•

Appearing Point Hint on page 443

Each type of hint has a different purpose and they can all be used in the same drawing.
Use the Morphing tool to add hints to your morphing sequences. You can add different hints to your source and
destination drawings and combine all types of hints in the same drawing.
A hint will automatically appear in both the source and destination drawings when it is added. A hint cannot exist
in a single drawing. If you delete a hint from one drawing, it will be also deleted from the other.
The key to placing your hints is to put them where the biggest problem is. Fix the largest distortions first, this
may also fix the smaller ones at the same time.

Do not add too many hints, this is a common mistake when morphing, it takes some practice to learn how to
correctly use and place hints.
To add and remove hints:
1. In the Timeline or Xsheet view, select the source or destination drawing of your morphing sequence.

2. In the Tools toolbar, select the Morphing

tool or press [F3].
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Use your other morphing key drawing, shown in the Drawing view's bottom right corner, as a reference.

3. In the Tool Properties view, select the type of hint you want to use.

‣

Select Contour Hint to correct a brush line or colour zone's contour (Contour vector).
Contour Hint points will behave similar to Pencil Hint points when used on a pencil line. Note that you
obtain better results using the Pencil Hint point.

‣

Select Pencil Hint to correct a pencil line (Central vector).

‣

Select Zone Hint to correct a colour zone morphing match.

‣

Select Vanishing Point Hint to correct a vanishing shape's trajectory.

‣

Select Appearing Point Hint to correct an appearing shape's trajectory.

4. In the Camera or Drawing view, click on the drawing near the area to add a hint.
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5. Select the hint's point and move it to its correct position.

6. Select one or many hints and press [Delete] to remove extra or unused hints.
‣

To delete all of the hint points at once, press [Shift] + [Delete].

7. In the Playback toolbar, press the Play

button to see the result.

Related Topics
‣

Hints below

Hints
Here are the available hint points:
•

Contour Hint on the next page

•

Zone Hint on the next page

•

Pencil Hint on page 442

•

Vanishing Point Hint on page 442

•

Appearing Point Hint on page 443
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Contour Hint

The Contour Hint

point is used on the colour fill zone and brush lines; in other words, on Contour vectors. It

allows the control of line thickness and contour position. Also, if a contour is not animated the way that it should
be you can use hints to correct the animation. For example, if a flag is not waving properly.
When adding a Contour Hint point, make sure that you place it far enough away from the contour so that you
can see it snap to the contour.
The Contour Hint points are yellow.

Do not place the Contour Hint directly on the line as it may look like it has snapped to the contour,
when in fact, it has not and the morphing will remain unchanged.

To correct a brush stroke, place a hint on both sides of the line to indicate its thickness variations
over time.

Zone Hint
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The Zone Hint

point is used on a colour zone to control the proximity rule. The Zone Hint is placed in the

centre of the colour zone. Sometimes a colour zone is not associated with the corresponding one by default. For
example, in a splash animation there are many water droplets that are the same colour. The system
automatically morphs the droplet to the nearest one. This is not always correct. A Zone Hint will force a colour
zone to morph with another one.
Zone Hint points are cyan in colour so you can easily see them.

Pencil Hint

A Pencil Hint

point is used to control a pencil line, also known as central vector. It can be used on drawings

that were done using the Pencil, Polyline, Ellipse, Line and Rectangle tools. Like the Contour Hint, the Pencil Hint
snaps to the central vector. Make sure to place it far enough away from the line so you will see it snap when you
move it.
Pencil Hint points are magenta in colour so you can easily see them.

Vanishing Point Hint

A Vanishing Point Hint

is used to control the trajectory of a vanishing shape. A shape will vanish from the

source drawing when there is no corresponding shape in the destination drawing. If you do not place a Vanishing
Hint to control the point of disappearance, the shape will vanish into its centre.
Vanishing Point Hint points are green in colour so you can easily see them.
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Appearing Point Hint

An Appearing Point Hint

is used to control the trajectory of an appearing shape. A shape will appear in the

destination drawing when there is no corresponding shape in the source drawing. If you do not place an
Appearing Point Hint to control the point of appearance, the shape will appear from its centre and expand
outwards.
Appearing Point Hint points are violet in colour so you can easily see them.

Related Topics
•

Morphing Tool and Hints on page 437

Copying Hint Points from One Drawing to Another

If you have two morphing sequences that use the same drawing and you would like to copy it and its hint points,
you can do so in the Drawing view.
To copy a drawing and its hints:
1. In the Tools toolbar, select the Select

tool or press [Alt] + [S].
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2. In the Drawing view, select the drawing you will reuse in your second morphing sequence. In the top
menu, select Edit > Copy or press [Ctrl] + [C] (Windows) or [⌘ ] + [C] (Mac OS X).

3. In the Timeline view, select the cell where the new drawing will be.

4. In the Drawing view, paste your selection. In the top menu, select Edit > Paste or press [Ctrl] + [V]
(Windows) or [⌘ ] + [V] (Mac OS X).
5. In the Timeline view, select the cell where the second drawing will be.

6. In the Drawing or Camera view, draw your second drawing.

7. In the Timeline view, create the morphing sequence for the new drawings or press [Alt] + [M].

8. In the Tools toolbar, select the Morphing

tool or press [F3].
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9. In the Drawing or Camera view, position your hint points.

Related Topics
•

Morphing Tool and Hints on page 437
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Morphing Two Sequences in a Row

If you are morphing two sequences in a row, you will have to create a different set of hint points for each
sequence.
Morphing two sequences in a row requires three drawings: 1, 2 and 3. Using these three drawings you create
two morphing sequences; one sequence between drawings 1 and 2, and a second sequence between drawings 2
and 3.

Each morphing sequence has its own set of parameters and hints. This means that Drawing 2 will
have a set of hints for the first sequence and another set for the second sequence. The two sets of
hints will not show at the same time. Each set of hints that appears always corresponds to the
morphing sequence you are working on.

Related Topics
•

Creating a Basic Morphing Sequence on page 426
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Inserting a Morphing Key Drawing

Once you have a morphing sequence, you can add a Morphing Key drawing.
A Morphing Key drawing allows you to insert extra details into a morphing sequence. For example, during a
morphing sequence you may need to insert a detail such as teeth or a mouth, this is easy to do when you use a
Morphing Key drawing. Instead of creating an entirely new drawing, convert a computer generated in-between
to a Morphing Key drawing and add your extra details to it and the next key drawing.
A Morphing Key drawing converts a computer generated morphing frame into a real drawing that you can edit.
It splits the morphing sequence into two sequences, retaining any previous modifications.
To insert a Morphing Key drawing:
1. In the Timeline or Xsheet view, select the morphing frame you want to transform into a morphing
keyframe.

2. Right-click on your selection and select Morphing > Insert Morphing Key Drawing.
‣

In the top menu, you can also select Animation > Morphing > Insert Morphing Key Drawing.

The new Morphing Key drawing appears.

3. In the Drawing or Camera view, draw your new details on the Morphing Key drawing.
4. In the Playback toolbar, press the Play

button to see the result.
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Related Topics
•

Creating a Basic Morphing Sequence on page 426
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Converting Morphing In-betweens to
Drawings

Animate lets you convert your morphing in-betweens to real drawings that you can edit.
This is useful when you manually edit your morphing sequence or if you prefer to have your animation timing in
double frame instead of single frame.
To convert morphing in-betweens to drawings
1. In the Timeline or Xsheet view, select a morphed drawing in the morphing sequence you want to convert
to real drawing.

2. Right-click on your selection and select Morphing > Convert Morphing to Drawings.
‣

In the top menu, you can also select Animation > Morphing > Convert Morphing to Drawings.

The Converting Morph dialog box opens.

3. Type the drawing basename you want to give to your new drawings. In this case, you could type circle.
4. Click on the OK button.

Related Topics
•

Creating a Basic Morphing Sequence on page 426
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Morphing Holes and Transparencies
To be able to morph shapes with holes or transparent colours, it is important to understand the process of
analyzing and morphing a shape. Animate begins the process by reading the exterior outline of the entire shape.
So if you are morphing a doughnut, it will first read the entire circular shape and ignore the central hole.

Once the general morphing shape is analyzed, the system will carry on analyzing the interior details such as
colour zones and holes.

As you can see, because the hole was placed on top after the main shape was morphed, the centre is filled with
an opaque brown colour. In order to avoid opaque holes, you have to paint the zone with a transparent colour
so that you can control it and flatten the transparency to cut a hole through the main shape.
The same thing happens when you have holes painted with semi-transparent colours. To see through your
shapes, you have to follow the same process as morphing shapes with holes.
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To morph a shape with a hole:
1. In your Colour view, select an unused colour swatch and set its alpha (transparency) to 0.

2. Paint both holes on the source and destination drawings.

3. In the Timeline or Xsheet view, click on a cell in your morphing sequence.

4. In the Tools toolbar, select the Morphing

tool or press [F3].

5. In the Tool Properties view, enable the Flatten

option.

A hole appears in the shape.
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Related Topics
•

Creating a Basic Morphing Sequence on page 426
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Adjusting the Morphing Quality
To improve the morphing quality, zoom in close to a morphing animation when compositing.

Increasing the quality improves the line shape between vector points. It also creates a larger file, so only increase
quality when you are zooming in close.
To set a morphing sequence's quality level:
1. In the Timeline or Xsheet view, click on a cell in your morphing sequence.

2. In the Tools toolbar, select the Morphing

tool or press [F3].

3. In the Tool Properties view, increase or decrease the quality level by dragging your cursor up or down.
You can also type a new value directly in the text field.

Related Topics
•

Creating a Basic Morphing Sequence on page 426
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Tips and Tricks
This section provides a list of easy tips and tricks to help you morph your drawings more efficiently.

Morphing Similar Shapes
Similar shapes have the same number of colour zones. This only applies to the number of zones and lines and not
the number of points on a curve.

Avoiding Crossing Zones During Morphing
If a zone inside a larger zone on the source drawing ends up outside on the destination drawing, the morphing
will fail.
A line cannot cross another line during a morphing sequence.
For example, if you are morphing a face so it turns from the front to the side, the nose is located in the middle of
the face on the source drawing. However if after morphing, the nose ends up outside or merged with the face
profile line on the destination drawing, this will give undesirable results. You can avoid this by using morphing
layers and splitting the nose on a separate layer.

Using the Brush Tool as a Beginner
When learning about morphing, it is recommended that you use the Brush tool. You can use the Pencil line for
simple closed shapes.

Flattening Drawings
Flatten your drawing before starting a morphing sequence.

Cleaning-up your Drawings
If you leave a dot, even the smallest one, it is possible that your morphing will create odd shapes. If the source
line is closer to the dot than the destination line, the source line will morph into the dot and the destination line
will disappear.

Using the Same Colour Swatch
Use the same colour swatch between two drawings. You cannot morph between two different colour swatches
even if they have the same RGB values. This can be turned to your advantage for complex morphing.

Related Topics
•

Creating a Basic Morphing Sequence on page 426

•

Understanding Morphing on page 420
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Morphing Preferences
To open the Preferences panel:
‣

Windows: Select Edit > Preferences.

‣

Mac OS X: Select Animate > Preferences.

‣

Or press [Ctrl] + [U] (Windows) or [⌘ ] + [U] (Mac OS X).

Drawing Tab

Morphing Quality
The Morphing Quality preference is used to set the default quality value for the morphing sequences. If you
change this value, it will not affect the morphing sequence which was created previously.
After a morphing sequence has been created using this default quality value, it's quality can be changed manually
by using the Morphing Tool Properties.

Related Topics
•

Adjusting the Morphing Quality on page 453
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Chapter 9: Import

Toon Boom Animate allows you to import external content as well as being able to draw directly in the software.
This means that characters, backgrounds and videos created in other drawing, painting and multi-media
programs can be brought in and animated. You can import QuickTime videos, pictures, multi-layered PSD files,
as well as AI, SWF and PDF files. You can also scan your images in with a scanner and either import them as
bitmap or vectorize them.

Topics Covered
•

Importing Bitmap Images on the facing page

•

Importing PSD Files as Separate Layers on page 467

•

Exporting and Re-Importing a PSD Layout on page 1

•

Scanning Images on page 470

•

Importing AI and PDF Files on page 473

•

Scanning Images on page 470

•

Importing from Adobe Flash on page 476

•

Importing QuickTime Movies on page 480

•

on page 1

•

Import Preferences on page 482

For sound import, refer to Importing a Sound File on page 608.
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Importing Bitmap Images

Images can come in many different file formats and are usually saved in a format that retains the original
specifications set by the image creator. Some formats are able to preserve transparency or transparent layers,
while others are not resolution dependent due to their vector nature. Toon Boom Animatesupports the
following formats: JPEG, BMP, PNG, TGA, PSD, TIFF, SGI, TVG, OMF, PAL, SCAN.
In this section, you will cover the following topics:
•

Importing a Bitmap Image without Vectorization below

•

Importing and Vectorizing Images on page 463

•

on page 1

Importing a Bitmap Image without Vectorization
A bitmap image is an image composed of pixels that is both size and resolution-dependant.
To import a bitmap image:
1. From the top menu select File > Import > Images. You can also click on the Import Images

button in

the File toolbar.
‣

In the Xsheet view, you can right-click anywhere in the frame area and select Import > Drawings.

The Import Images dialog box opens.
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2. In the Files section, click Browse to find and select one or several images on your computer.
3. In the Layer section, you have the option of creating a whole new layer for your image or adding the image
to an existing layer.
‣

To create a new layer, select Layer > Create Layer(s) > Create Single Layer Named and name your
layer accordingly.

OR
‣

To create a new layer using the file name, select Layer > Create Layer(s) > Create Layer(s) Based on
Filenames.

OR
‣

To add the image to an existing layer, select Layer > Add to Existing Layer and select the layer
already created in your Animate file from the drop-down menu. If only vector
layers are available in
your scene (and therefore the drop-down menu), you will either have to Vectorize Imported Items,
Create Symbols for imported Items or check both options to put your bitmap image on a vector layer.

Refer to Adding Images to a Bitmap Layer on page 462 for more information.

If you vectorize your image usring the Vectorize as Colour option, you can import it on a vector layer,
and use vector tools on it.

4. In this case, uncheck the Vectorize Imported Items option.
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The vectorization options are hidden and the Transparency section appears.

5. In Toon Boom Animate, if you want your bitmap images to be encapsulated in a symbol, enable the
Create Symbol for Imported Items option. If not, disable the option. If you chose to add your image to
an existing vector layer then the Create Symbol for Imported Items will automatically be checked and
greyed out.

To learn more about Symbols, refer to Library on page 521.

6. Next, in the Alignment section, you must decide on the size and placement of your image within the
camera frame. Depending on the Scene Settings (the height and width in pixels that you chose for your
project), an image that you import may get scaled to the point where all its individual pixels become
visible.

Be sure that you are in the Camera view’s Render Mode when judging an imported image, otherwise
it may appear blurry.when judging an imported image, otherwise it may appear blurry.

The following three options are available
•

•

Alignment > Rules > Fit
•

If your image orientation is portrait format, this selection will enlarge or shrink (but not distort) to your
image height to match the full height of the camera frame.

•

If your image orientation is landscape format, this selection will enlarge or shrink (but not distort) your
image width matches that of the camera frame.

Alignment > Rules > Pan
This selection achieves the opposite result of the Fit command.

•

•

If your image orientation is portrait, its width will be made to match the width of the camera frame. As
a result, part of the image’s height will extend beyond the height of the frame.

•

This can be useful if you want to make your background move up and down, or from left to right to
make it appear as if the camera is panning, or to actually perform a camera pan.

Alignment > Rules > Project Resolution
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This selection will scale the image in proportion to the scene's resolution. The system looks at the
resolution of the bitmap image, for example 4000 x 2000, then compares it to the scene's resolution, for
example 1920 x 1080, and adjusts the scale factor in proportion. So in this example the bitmap would
appear at 208% (4000/1920). If you import a bitmap that is 960 x 540 it will be displayed at 50% (960/1920)
of the size of the project resolution.
7. The last step is to decide on the image’s transparency from the Alpha drop-down menu. For this, there
are four options available. These options deal with the way that the bitmap image will be antialiased,
more specifically the way that the pixels along the edge are blended in the RGBA (red, green, blue, alpha
(transparent)) channels.

The options are:
‣

Premultiplied with White

Individual pixels at the edge of an image are blended with white.
‣

Premultiplied with Black

Pixels at the edge of an image are blended with black.
‣

Straight

Pixels at the edge of an image are blended with black, white and greys.
‣

Clamp Colour to Alpha

Select this option if you want to premultiply the colour value with the alpha value. When the colour is
clamped to the alpha, the colour value cannot be higher than the alpha value. If you have a pixel of value
R=247, G=188, B=29 and the alpha is 50% (the image is 50% transparent, then the actual RGB value
output would be half of the amounts listed above.
8. Click OK.
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Related Topics
•

Adding Images to a Bitmap Layer below

•

Importing and Vectorizing Images on the next page

Adding Images to a Bitmap Layer
If you want to add more bitmap images to an existing bitmap layer:
1. In the Timeline view, if the bitmap image is contained in a Symbol, double-click on the bitmap symbol cell
to edit the symbol. Otherwise, if the bitmap image is on a bitmap
layer, leave it as is.

2. If necessary, in the Timeline view, pull on the red bracket to extend the exposure.
3. From the top menu, select File > Import > Images. You can also click on the Import Image

button.

The Import Images dialog box opens.

4. Click on the Browse button to find and select one or several images on your computer.
5. In the Layer section, choose Layer > Add to Existing Layer and select the bitmap layer already created in
your Toon Boom Animate file from the drop-down menu.
6. Uncheck the Vectorize Imported Items option.
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7. Disable the Create Symbol for Imported Items option.
8. Click on the OK button.

Related Topics
•

Importing a Bitmap Image without Vectorization on page 458

•

Bitmap Image Quality below

Bitmap Image Quality
If the bitmap images that you have imported look blurry or slightly pixelated, follow the steps below to clean-up
the image. These steps will effect the quality of the preview in Camera view, but will have no effect on the final
render.
1. In the Camera view, double-click on the bitmap image to enter its symbol if the image is encapsulated or
simply select the bitmap image layer in the Timeline view if it isn’t.
2. In the top menu, select View > Bitmap Image Quality or press [Ctrl] + [Q] (All Platforms).
3. The Bitmap Image Quality dialog box opens.

4. Click and drag the Bitmap Image Quality slider to the right to improve the quality.
5. Click on the OK button.
6. If you are inside a symbol, go to the top of the Camera view and click on Top to exit the symbol and return
to your scene.

Related Topics
•

Importing a Bitmap Image without Vectorization on page 458

Importing and Vectorizing Images

You can turn your images into 100% vector drawings, while still maintaining the sketchiness of a pencil line or into
vector images with a bitmap fill. Both of these options can add “life” to an animation, which straight
vectorization with smoothing does not.
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To import and vectorize a bitmap image:
1. In the top menu, select File > Import > Images. Or click on the Import Image

button in the File

toolbar.
The Import Images dialog box opens.

2. Click on the Browse button to find and select one or several images on your computer.
3. You now have the option of creating a whole new layer for your image or adding the image to an existing
layer.
‣

To create a new layer, select Layer > Create Layer(s) > Create Single Layer Named and name your
layer accordingly.

OR
‣

To create a new layer using the file name, select Layer > Create Layer(s) > Create Layer(s) Based on
Filenames.

OR
‣

To add the image to an existing layer, select Layer > Add to Existing Layer and select the layer
already created in your Toon Boom Animate scene from the drop-down menu. If only vector
layers
are available in your scene (and therefore the drop-down menu), you will either have to Vectorize
Imported Items, Create Symbols for imported Items or check both options to put your bitmap image
on a vector layer.

To mix bitmap images with vector drawings on the same layer, the bitmap image must be
encapsulated in a symbol and vice versa. When you check the option Create Symbol for Imported
Items, these symbols will also automatically be added to your Symbol Library.
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4. In this case, enable the Vectorize Imported Items option.

5. Under the Vectorization section, decide whether you would like to import your image in colour or black
and white, or if you would like to add a new preset.

‣ Colour: this style vectorizes your image as a colourful bitmap texture within a vector frame.
‣

Black and White: this style vectorizes your drawings as a solid black line. This creates a 100% vectorbased drawing. You can customize the different settings levels:
‣

Threshold%: The Threshold value filters out noise in your images. Noise can be dirt or faint smudges
on your scanned images. For example, if your value is set to 70%, all colour values below 70% are
converted to white and ignored in the final image. If your value is set to 100%, only completely black
lines will be kept.

‣

Expand: Enter a value between 1 and 100 to thicken lines or the outer edges of the bitmap. Use this
option if your line art is too fine or pale so that their visibility is increased in the software.

‣

Smooth: Enter a value between 1 and 5 to set the smoothness level. Greater smoothness equals less
jaggedness and imperfections, but at a greater loss to detail.

6. Press Apply to make the current settings visible on your image in the Preview section. You can also check
the Auto Apply option to automatically apply the changes as you edit the vectorization parameters.
7. Click Vectorized to switch to the source version of the selected image in the Preview section and click
Source to switch to the vectorized version of the image in the Preview section.
8. Use the Scale slider to zoom in or out of your preview images.

The vectorized images are painted with the Vectorize Line colour swatch from the colour palette.

9. Click OK.
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You should now have a symbol or new layer that contains the vector drawing. If your image is contained into a
symbol, in order to edit the image, you must double-click on the image’s first cell in the Timeline view to enter
the symbol.

Related Topics
•

Importing a Bitmap Image without Vectorization on page 458
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Importing PSD Files as Separate Layers
The Adobe Photoshop PSD file format is unique in that they are able to retain multiple layers. This format has the
advantage of the image remaining fully editable, in terms of any colour correction, effects, masking,
transparency or compositing that was made to the PSD file in Adobe Photoshop.
To import the separated layers of a PSD file:
1. Organize your Adobe Photoshop file so that all your layers are “grouped” into individual folders, or that
all of the elements you want to import as a single layer in Toon Boom Animateare grouped together in
their own folder. Any layer that is not in a folder group, by itself or otherwise, will not be imported.

2. In Animate, go to the top menu and select File > Import > Images. You can also click on the Import
Image
button.
The Import Images dialog box opens.

3. Click Browse to find and select the image on your computer.
4. Select Layer > Create Layer(s) > Create Single Layer Named or Create Layer(s) Based on Filenames.
5. Decide whether to check or uncheck the Vectorize Imported Items option.
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If you decide to use the Vectorize Imported Items option, please refer to Importing and Vectorizing
Images on page 463 to learn more about vectorization settings.

If you decide to disable the Vectorize Imported Items options the Transparency and Alignment
settings will appear in place of the Vectorization settings. Please refer to Importing a Bitmap Image
without Vectorization on page 458 to learn more about these settings.

6. Enable or disable the Create Symbol for Imported Items if you want your layers to be contained in
symbols or not.
7. Click OK.
The Multilayer Image Import Settings dialog box opens.

8. In the Image to Load field, select
‣

Composite Image to flatten your layers.

‣

All Layers Image to keep your layers separated.

9. Select the Transparency Type if applicable. Refer to the Importing a Bitmap Image without Vectorization
on page 458 section to learn more the different Transparency Type options.
10. Click on the OK button.
Your image should appear as separate layers in the Timeline view, corresponding to the PSD layer group folders.

As a result of a multilayer PSD file import, artwork displayed in each of your layers is linked to the
same source image. This means that if you use the command Drawing > Delete Selected Drawings
to physically delete the drawing from the project folder, the exposed drawing will be deleted in all of
the layers simultaneously. Once deleted from the project folder, the image can not be retrieved
unless you re-import your psd file.
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Related Topics
•

Exporting and Re-Importing a PSD Layout
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Scanning Images

Toon Boom Animate can receive images from any TWAIN device such as scanners and digital cameras. These
images can either be loaded into your scene as bitmaps or converted into vector- based images that can be
edited using Toon Boom Animate.
If your operating system does not automatically recognize your device after it has been connected, you must
install the correct TWAIN drivers in order to access its contents. You can usually download the drivers from the
device manufacturer’s website.

TWAIN drivers are not always created for every model of scanner or digital camera. If TWAIN drivers
do not exist for your device, you will not be able to use it with Toon Boom Animate.

You can scan in a single image or multiple images in the same session. Before you begin scanning, you need to
select your scanning device.
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To scan drawings from a TWAIN device:

1. In the Top Menu, select File > Acquire > From TWAIN or press [Ctrl]+[Shift]+[A] (Windows) or +[Shift]+
[A] (Mac OS X).
The Scan Drawings window opens.
2. Select your scanner or other supported TWAIN device from the drop-down menu. If none are available,
check your device to ensure that it is properly connected to your computer. If your device still does not
appear in the drop-down menu, you may have to shut down and relaunch the software.
3. You can import the images to scan into an existing layer or create a new one.

‣

To import the image into a new layer, enable the Create Layer option. In the Name field, type a name
for the layer.

‣

To import the image into an existing layer, select Add to Existing Layer and select the layer from the
drop-down list.

4. Decide if you want to vectorize or not the scanned images. If you want to vectorize the scanned images,
select the Vectorize Acquired Items option and choose the parameters from the Vectorization section:

‣
‣

Colour: this style vectorizes your image as a colourful bitmap texture within a vector frame.
Black and White: this style vectorizes your drawings as solid black lines and shapes. This creates a 100%
vector-based drawing. Use the filters listed below to transform the bitmap into vector art.
If you select this option customize the parameters below:
‣

Threshold percentage: The Threshold value filters out noise in your images. Noise can be dirt or faint
smudges on your scanned images. For example, if your value is set to 70%, all colour values below 70%
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are converted to white and ignored in the final image. If your value is set to 100%, only completely
black lines will be kept.
‣

Expand: Enter a value between 1 and 100 to thicken lines or the outer edges of the bitmap. Use this
option if your line art is too fine or pale so that their visibility is increased in the software.

‣

Smooth: Enter a value between 1 and 100 to set the smoothness level. Greater smoothness equals
less jaggedness and imperfections, but at a greater loss to detail.

5. Decide if you would like to encapsulate the scanned drawings into individual Symbols. These Symbols will
also appear in your Symbols Library. If not, uncheck the Create Symbol for Acquired Items option.
6. Click Apply. Check the Auto Apply box to continually and automatically update your most current
settings at the Preview level. The auto-apply is simply for preview purposes. If you do multiple scans, the
vectorization parameters used on the first scan in the set are the ones that will be applied throughout,
even if the preview does not show the image vectorized.
7. Click Preview.
The scanning dialog box for your TWAIN device opens. To do a preview inside the Animate interface you
will need to do an actual scan in the TWAIN device’s interface. Previewing in just the TWAIN does not
send any information to Animate. Use the settings in that box to launch a scan. When the scan is
complete, if the device’s window does not close automatically, close it. The image preview now appears
in the preview area of the Acquire from TWAIN dialog box in Animate.
8. If you chose the Vectorize option, the Source/Vectorize toggle now becomes active. Use this button to
toggle between the image as it has been vectorized using the settings in the Parameters section and the
original, source image. Use the slider to increase or decrease the preview size in order to check and
compare the two images for accuracy.
9. Click Scan to open the scanning dialog box for your TWAIN device.
10. Use the settings from your scanner to scan your drawings. You can close the TWAIN device’s scanning
dialog box at any time and readjust your vectorization parameters in Animate’s Acquire from TWAIN
dialog box. You can also scan multiple images with your device before closing the Acquire from TWAIN
dialog box.
11. To automatically import the scanned images into your scene, exit the TWAIN device scanning interface.
12. Click Close to close the Acquire from TWAIN dialog box.
The scanned image(s) appears in the centre of your camera frame and fitted with the height of the camera
frame.

Related Topics
•

Cleaning Scanned Drawings
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Importing AI and PDF Files

You can import AI and PDF files into Toon Boom Animate, it will convert your files to the Toon Boom format
(TVG) and create a colour palette based on the colour settings of the original file.

Only Legacy versions of Adobe Illustrator are supported. SWF's exported, including Actionscript 2
and Actionscript 3, cannot be imported.

To import an AI or PDF file:
Go to the Library view andright-click on the Stage Library folder. Choose Right to Modify to unlock the library
folder. Make sure the Lock icon disappears from the folder to unlock it, otherwise your library will remain locked
and not editable.

The option to import will not be available until this step is completed successfully
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For more information about the Library, see the Library on page 521 chapter.

1. In the top menu, select File > Import > SWF, Illustrator Files to Library. Orright-click on any unlocked
folder and select Import Fi les.
The browser window opens.
2. Find and select your AI file in the Import Files dialog box and click on Open.
The Rename dialog box opens.

3. Enter a name for the new template or keep the name of the original AI or PDF file.
4. Click OK.
5. Click and drag the new template folder from the Library view to the left side of the Timeline view; wait
until the copy cursor

appears before releasing the mouse button.

6. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before clicking
on the Yes button, you have the option to select the Do Not Ask Again For This Session option. This
might be useful if you plan to import multiple AI drawings.
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This process will import the colour palette used to create the Illustrator file and create a new palette in
Toon Boom Animate under the imported file’s name.

Refer to the Import Preferences on page 482 section to learn about the Support CMYK in
PDF/Illustrator Import preferences.

When importing an Illustrator or PDF file in Toon Boom Animate, by default the file will be imported
as separate layers. The import will use the Illustrator file's top level groups as seperate layer names.
However, you can change this behaviour by disabling the PDF/Illustrator Import as Separate Layers,
to import your file as a single layer. Refer to Import Preferences on page 482to learn more.

Related Topics
•

Importing and Vectorizing Images on page 463

•

Importing from Adobe Flash on the facing page

•

Import Preferences on page 482
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Importing from Adobe Flash

If a projects was started in Adobe Flash and it needs a more professional boost, such as camera movements or
multiplaning it can easily be imported into Toon Boom Animate. The actual *.fla file is not supportable, so you
have to export your project to an *.swf movie.
To import a Flash file:
1. Go to the Library view and right-click on the Stage Library folder. Choose Right to Modify to unlock the
library folder. Make sure the Lock icon disappears from the folder to unlock it, otherwise your library is
locked and not editable.

The option to import will not be available until this step is completed successfully.

For more information about the Library, see the Library on page 521 chapter.

2. In the top menu, select File > Import > SWF, Illustrator Files to Library.
You can also right-click on any unlocked folder and
select Import Files.
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The browser window opens.
3. Find and select your .swf file in the Import Files dialog box and click on Open.
The Rename dialog box opens.

4. Enter a name for the new template or keep the name of the original *.swf file.
5. Click on the OK button.
6. Click and drag the new template folder from the Library view to the left side of the Timeline view; wait
until the copy cursor
appears before releasing the mouse button.

7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before clicking
on the Yes button, you have the option of selecting the Do Not Ask Again For This Session option. This
might be useful if you plan to import multiple *.swf movies.

This process will import the colour palette used to create the Flash file and create a new palette in Toon
Boom Animate under the imported file’s name.
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All the Flash layers are automatically attached to a parent peg called GlobalFlashPeg.
DO NOT DELETE THIS PEG. To maintain the look of your movie, it is important that this peg is not
deleted, nor its child layers detached.

The Adobe Flash file layers should now appear in the Timeline view. Symbols that were created in Flash become
regular drawing layers, but can be reconverted into Symbols in Toon Boom Animate. Symbols within symbols or
drawings within symbols collapse into their corresponding parent symbol.

Some of the layers contained in your SWF movie could end up being combined in a single layer as a
result of optimization enhancement in your movie file. You can easily bring these elements back on
separate layers. Refer to the Distribute To Layers below section to learn how.

In addition, all drawing elements that are dynamically linked to the Toon Boom Animate file are grouped
together in one folder. This means that when you scroll through the Drawing Substitution preview in the Library
view, the different hand, leg, tentacles, antennae, torso and facial positions are all organized together.

Related Topics
•

Distribute To Layers below

•

Importing AI and PDF Files on page 473

Distribute To Layers
In some instances, due to an optimization enhancement in the exported SWF file (CS4), some of the layers might
be combined as a single layer. In that case, use the Distribute to Layers feature to quickly redistribute these
elements onto individual layers again.
To distribute to layer:
1. In the Tools toolbar, click on the Select

tool.

2. In the Camera view, select the drawing you want to redistribute the elements from. To select the all the
elements of the selected drawing layer, press [Ctrl] + [A] (Windows) or [⌘ ] + [A] (Mac OS X).
3. From the top menu, select Drawing > Distribute to Layers. You can also click on the Distribute to Layers
button in the Select tool’s Tool Properties view.
The number of drawing layers corresponding to the different grouped elements are created in the
Timeline view.
‣

The selected elements in the original drawing layer will be removed.

‣

Each element will be distributed into each new drawing layer.

4. Repeat the process for every drawing you need to distribute the element from.

Related Topics
•

Importing from Adobe Flash on page 476
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•

Select Tool Properties on page 165
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Importing QuickTime Movies

When creating an animation, it is not unusual to embed moving elements saved as videos within the animation.
Toon Boom Animate allows you to import QuickTime movies into your project.
To Import a QuickTime movie:
1. In the top menu, select File > Import > Movie.
2. Browse for the QuickTime movie to import and click Open.
A progress bar appears.

The Import Drawings dialog box opens.

Do not browse for the movie file again; leave the automatically generated field text as “many files
selected”.

3. Make your decisions for the Layer, Alignment and Transparency.
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Refer to the Importing a Bitmap Image without Vectorization on page 458 section for further details
about the Import Drawings dialog box.

4. Click OK.
The QuickTime video appears in the Timeline view as an image sequence. You should be able to scroll through
the film frame-by-frame, just as you would scroll through your animation drawing-by-drawing.

Related Topics
•

Importing a Bitmap Image without Vectorization on page 458
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Import Preferences
In the Preferences panel, you will find the following preference that is related to importing PDF and Illustrator
files in your project.

Advanced Option
•

Support CMYK in PDF/Illustrator Import: When this preference is enabled, you will be able to
successfully import PDF and AI files that were created or exported in CMYK mode. The colours of the
resulting imported image may still not look 100% faithful to its CMYK original due to the RGB conversion.
It is recommended that you convert these files to RGB images before importing them into Toon Boom
Animate. Disabling this function will cause all the colours of the imported image to be displayed as red to
indicate that the file was not converted to RBG prior to import.

•

PDF/Illustrator Import as Separate Layers: When this preference is enabled, the different
groups/elements of the PDF or Illustrator file will be imported as separate layers. For Illustrator files, the
import will use the top level group as separate layer names. Disable this preference to import your PDF or
Illustrator file as a single layer.
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Chapter 10: Scene Setup

Setting up your scene can be compared to building a set for a television show. This is the point when you
position each scene element such as the camera frame, the background elements and the characters.

Topics Covered
•

Importing the Scene Components on the facing page

•

Setting the Camera Frame on page 485

•

Positioning the Scene Components on page 490

•

Cloning and Duplicating Layers on page 1

•

Setting Up the Network on page 1

•

Display Concepts on page 1

•

Creating a Multiplane on page 509

•

Scene Setup Preferences on page 516
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Importing the Scene Components
The first step in the scene setup task is gathering up the scene’s different components and then importing them
into your project.

Refer to the Setting Up the Network on page 1 and Display Concepts on page 1 sections to learn
more about the Network view connections and display concepts.

Backgrounds, Sounds and Movie
•

Importing Bitmap Images on page 458

•

Importing QuickTime Movies on page 480

•

Importing a Sound File on page 608

Templates and Symbols
Refer to Importing Symbols and Templates on page 543 to learn more.

Related Topics
•

Setting the Camera Frame on the next page
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Setting the Camera Frame
The scene action occurs inside the camera frame, so it’s really important to set it up correctly.
•

Adding a Camera Layer below

•

Setting the Camera Using the Translate and Rotate Tools on the facing page

•

Setting the Camera using the Camera Layer Properties on page 487

•

Resetting the Camera Position on page 489

•

Camera List on page 489

The Camera layer is static which means that if you need to animate it, you must add a peg.

Refer to the Animation Paths on page 637 chapter to learn how to animate layers using pegs.

Refer to 3D Camera Motion to learn more about setting and moving the camera in the 3D space.

Adding a Camera Layer
To set the camera frame, add a Camera layer into your scene so you can edit the default camera frame.
To add a Camera layer in the Timeline view:
1. In the Timeline view, click the Add Layer

button or select Insert > Camera from the top menu.

2. Select Camera from the drop-down menu.
A new camera layer is added to your scene and appears in the Timeline view.

You cannot add a camera inside a symbol. If you try to do so, a warning message will pop-up and
inform you that this operation is not possible.
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If you've added more than one camera to your scene, you can switch the active camera by going to
Scene > Camera and selecting the camera you want to use.

Setting the Camera Using the Translate and Rotate
Tools
You can reposition your camera frame directly in the Camera view, using the Translate

and Rotate

tools.

To reposition the camera frame directly in the Camera view:
1. Select Animation > Tools > Translate or press [Alt] + [2].
2. In the Camera view, click on the camera frame to select it. You can also select the camera layer from the
Timeline view.
The selected camera frame is highlighted in purple.

3. Drag the camera frame to a new position.

4. To tilt the camera frame, select Animation > Tools > Rotate or press [Alt] + [3].
5. In the Camera view, click on the camera frame to select it and rotate the camera frame until it reaches the
desired rotation angle.
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The Translate and Rotate tools can also be found in the Advanced Animation toolbar.

Refer to the Managing the Toolbars on page 94 to learn how to display the Advanced Animation
toolbar.

Setting the Camera using the Camera Layer
Properties
One way to set up your camera frame is to type the coordinates directly in the Camera Properties dialog box.
Doing this positions the camera precisely where you want it.

Refer to 3D Camera Motion on page 1 to learn more about setting the camera in the 3D space.

To set up the camera frame using the camera Layer Properties:

‣ In the Timeline view, double-click on the Camera layer.
The camera Layer Properties dialog box opens.
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The legend below explains each of the Layer Properties:
1. Use the Enable/Disable check box to enable or disable the camera layer.
2. The Lock
‣

and Onion Skin

buttons.

Once you are satisfied of the camera frame position, you can use the Lock

button to lock the

camera layer and prevent changes on the camera frame position.
‣

The Onion Skin

button is used to enable the Onion Skin feature in the Camera and Drawing

view.
3. The Name field displays the current layer name and is used to rename it. Type in the new layer name.
4. The Position section displays the current position of the camera layer using X-axis (East, West), Y-axis
(North, South) and Z-axis (Forward, Backward) coordinates. To reposition your camera frame, type in the
new values corresponding to the desired position coordinates. You can also use the up and down arrows
to set the value of each field.
5. The Angle field displays the current rotation value. To set a new rotation position, type in a new angle
value. You can also use the up and down arrows to set the new angle value.
6. The Pivot field displays the current position of the rotation pivot of the camera layer. The camera will
perform a rotation taking the position of the pivot as its angle centre. By default, the pivot is set at the
centre of the camera frame. To reposition the pivot point, type in new X and Y coordinates values in the
appropriate field. You can also use the up and down arrows to set the position values.
In order to see the pivot's position you will need to have the Rotate tool selected.
7. Enable the Override Scene FOV check box to enable the FOV field in which you can type in a new fieldof-view value.
8. The FOV field displays the current field-of-view default value. When enabled, you can type in a new zoom
value for your camera frame. You can also use the up and down arrows to set the new zoom value.
9. Use the Set Default FOV to reset the custom zoom value to its default value.
10. The Function button is used when animating the camera zoom value—see the Animation Paths on page
637 chapter to learn more about creating functions.
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Resetting the Camera Position
Once you set up your camera frame, you can always easily reset it to its original position. Use the Reset
command to reset the value of the selected element to the initial value of the active tool. For example, if the
Rotate
tool is active, the transformation angle will be reset to 0 and if the Transform
tool is active, then
the entire transformation values will be reset.
To reset the camera position:
1. In the Tools toolbar, select the Transform

tool or press [Shift] + [T].

2. In the Timeline or directly in the Camera view, select the camera layer.
3. Select Animation > Reset or press [Shift] + [R].
The camera automatically returns to its original position.

Camera List
You can only see one camera at the time in the Timeline view. If you add several cameras to your scene and you
want different settings on each, you can use the Camera List to display each of them. You can use this feature if
you are still working on your scene composition and you have different camera setups to choose from.
To select a camera from the Camera list:
1. In the top menu, select Scene > Camera > the desired camera.
‣

If you only add one camera to your scene, you will only see Default Camera in your list.

Related Topics
•

Positioning the Scene Components on the facing page
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Positioning the Scene Components
Setting up the scene also involves positioning the different scene elements within the camera frame.
•

Animate Mode below

•

Selecting a Layer below

•

Positioning an Element using the Transform Tool on page 498

•

Using Advanced Animation Tools to Position a Layer on page 501

•

Flipping an Element on page 504

•

Positioning an Element Using the Layer Properties

•

Resetting a Transformation on page 506

Animate Mode
When positioning elements, make sure that the Animate Mode is disabled, or it will create a keyframe within the
drawing layer.
To disable Animate Mode:

‣ In the Tools toolbar, click the Animate Mode

button.

Related Topics
•

Selecting a Layer below

Selecting a Layer
There are different ways of selecting the layers you want to reposition in the Camera view.
The topic is divided as follows:
•

Selecting a Layer from the Camera View using the Transform Tool on the next page

•

Bounding Box Selection Style on the next page

•

Finding the Selected Layer in the Timeline View on page 492

•

Selecting a Layer above

•

Selecting an Element from the Timeline or Xsheet View on page 492

•

Selecting a Layer above
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Selecting a Layer from the Camera View using the Transform Tool
You can select your elements directly in the Camera view using the Transform
Transform

tool. When you select the

tool, its properties and options appear in the Tool Properties view.

When using the Transform
Peg Selection Mode

tool to select element in the Camera view, always make sure that the

option in the Transform tool Tool Properties view is disabled or else it will

limit the selection to peg only.

To select from the Camera view:
1. In the Tools toolbar, select the Transform

tool or press [Shift] + [T].

2. In the Transform tool Tool Properties view, make sure the Peg Selection Mode

is deselected.

3. In the Camera view, select the element to be repositioned. You can select more than one element at a
time.
The corresponding layers and columns will be highlighted in the Timeline and Xsheet views.

Bounding Box Selection Style
You can change the display style of selected elements to Bounding Box. This will remove the normal selection
coloured highlight and leave only the bounding box around your selected element.

To set the bounding box selection style:
1. Select View > Show > BBox Selection Style.
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Finding the Selected Layer in the Timeline View

When you have several layers in your Timeline view, you may find it hard to locate which one is selected. Toon
Boom Animate has an easy solution to this problem, you can use the Centre on Selection feature to display the
selected layer in the Timeline view.
To centre on the selected layer in the Timeline:
1. In the Camera view, select the desired layer.
2. Make the Timeline view the current active view.
3. From the Timeline menu, select View > Centre on Selection or press [O]. If your selected layer is in a
group, or a child of one or more elements, continue to press [O] to expand the layers in the Timeline until
your selected layer becomes visible.
4. You can also click the Centre On on Selection

button in the Timeline View toolbar.

Refer to the Managing the Toolbars on page 94 to find out more about customizing the toolbars.

Selecting an Element from the Timeline or Xsheet View
You can also select your elements from the Timeline or Xsheet view. This can be useful when there are too many
objects in the scene or when an object is hard to grab.
To select from the Timeline or Xsheet view:
‣

In the Timeline view, click the layer corresponding to the element you want to reposition.

‣

In the Xsheet view, click the column header corresponding to the element you want to reposition.

The selected element will be highlighted in the Camera view.

Related Topics
•

Transform Tool Properties on the next page
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Transform Tool Properties

•

Lasso and Marquee below

•

Peg Selection Mode below

•

Snap Option on the facing page

•

Hide Manipulator Controls on the facing page

•

Flip Horizontal and Flip Vertical on the facing page

•

Width and Height on the facing page

•

Offset X and Y on page 495

•

Angle on page 495

Lasso and Marquee
Choose between the Lasso

and the Marquee

modes to change the selection style of the Transform

tool.
•

Click and hold [Alt] to temporarily switch from the current selected mode to the other.

To invert a selection:
•

From the top menu, select Edit > Invert Selection, or press [Ctrl] + [Shift] + [I] (Windows) or [⌘ ] + [Shift] +
[I] (Mac OS X).

You may also find the Invert Selection option from the Camera View or Drawing View menu by selecting Edit >
Invert Selection.

Peg Selection Mode
Click the Peg Selection Mode
Transform

button to limit the selection in the Camera view to pegs. When disabled, the

tool selects the drawing layers.
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This mode can be useful when you have created your character rig using peg layers for each
drawing. That way, you don't accidentally select the drawing layer, when you want to animate on the
peg.

Snap Option
When transforming or repositioning your layer using the Transform tool, you can enable different snap options
to help you.
•

Snap and Align: Snaps the selected layer to any existing line, while automatically displaying
temporary rulers that guide you and that you can also snap your object to.

•

Snap to Grid: Snaps your selection according to the currently enabled grid.

Hide Manipulator Controls
Enable the Hide Manipulator Controls

option to hide the bounding box and manipulator controls from the

Camera view when an element is selected.

Refer to following topics to learn more about the Snapping option utilities and the Grid feature:

•

Contour Editor Tool Properties on page 183 (Snap to Contour and Snap and Align)

•

More Drawing Tools on page 225 (Grid)

Flip Horizontal and Flip Vertical
Use these buttons to flip the selected element horizontally or vertically.
•

You can also select Animation > Flip > Flip Horizontal

and Flip Vertical

or press [4] and [5].

Width and Height
Use the Width

and Height

fields to enter specific values when you want to accurately resize the selected

layer.

1. Width: type a width value in this field to resize the width of your selection.
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2. Height: type a height value in this field to resize the height of your selection.
3. Use the up and down arrows to modify the value contained in either the Width or Height value field.
4. Lock icon: Click on the lock icon to either lock or unlock the ratio between the width and height values.

Offset X and Y
Use the Offset X

and Offset Y

fields to enter specific values to reposition the selected layer accurately.

1. X: type an offset value in this field to reposition the selected layer along the X-axis.
2. Y: type an offset value in this field to reposition the selected layer along the Y-axis.
3. Use the up and down arrows to modify the value contained in either the X or Y value field.

Angle
Use the Angle

field to enter specific values to rotate the selected layer accurately. A positive value will

rotate the layer counter-clockwise and a negative value will rotate the layer clockwise.

1. Angle: type a degree value in this field to rotate the selected layer.
2. Use the up and down arrows to modify the value contained in the Angle value field.

Related Topics
•

Selecting a Layer on page 490

Locking Layers in the Timeline View
You can prevent correctly positioned layers from being selected by locking them in the Timeline view. This is
useful for making a multiple selection inside the Camera view and leaving them visible. Once a layer has been
locked, its locked state will be remembered next time you open your saved project.
You can perform five types of locking actions on your layers:
•

Lock on the facing page

•

Unlock on the facing page

•

Lock All on page 497

•

Unlock All on page 497

•

Lock All Others on page 497
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Lock
The Lock

option let you lock one or a multiple selection of layers.

To lock a layer or a selection of layers:
1. In the Timeline view, select one or many layers.

2. Do one of the following:
‣

From the top menu, select Animation > Lock > Lock.

‣

Click one of the selected layer’s Lock

‣

Press [Ctrl] + [Alt] + [L] (Windows) or [⌘ ] + [Alt] + [L] (Mac OS X).

icon.

All selected layers are locked.

Unlock
The Unlock

button lets you unlock one or a multiple selection of locked layers.

To unlock a locked layer or a selection of locked layers:
1. In the Timeline view, select one or many locked layers.

2. Do one of the following:
‣

Select Animation > Lock > Unlock.

‣

Click one of the selected layer’s Lock

‣

Press [Ctrl] + [Shift] + [K] (Windows) or [⌘ ] + [Shift] + [K] (Mac OS X).

icon.

All selected layers are unlocked.
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Lock All
The Lock All option lets you lock all the layers in the Timeline view at once.
To lock all layers:

‣ In the top menu, select Animation > Lock > Lock All.
‣ Click one of the selected layer’s Lock

icon.

‣ Press [Ctrl] + [Shift] + [L] (Windows) or [⌘ ] + [Shift] + [L] (Mac OS X).
All layers are locked.

Unlock All
The Unlock All

button lets you unlock all the layers in the Timeline view at once.

To unlock all layers:

‣ In the top menu, select Animation > Lock > Unlock All.
‣ Press [Ctrl] + [Alt] + [Shift] + [L] (Windows) or [⌘ ] + [Alt] + [Shift] + [L] (Mac OS X).
All layers are unlocked.

Lock All Others
The Lock All Others

button lets you lock every layer except the selected ones.

To lock all other layers:
1. In the Timeline view, select the layers that you do not want to lock.
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2. Do one of the following:
‣

In the top menu, select Animation > Lock > Lock All Others.

‣

Press [Ctrl] + [Alt] + [Shift] + [O] (Windows) or [⌘ ] + [Alt] + [Shift] + [O] (Mac OS X).

All layes are locked except the selected ones.

Related Topics
•

Selecting a Layer on page 490

Positioning an Element using the Transform Tool
Using the Transform tool, you can easily reposition, scale, rotate and even skew the layers directly in the Camera
view.

When positioning a drawing layer using the Transform tool, always make sure that the Peg Selection
Mode is disabled in the Transform tool Tool Properties view, or it will limit the selection to pegs in
the Camera view.

Refer to Positioning Elements in 3D Space to learn about the 3D Transform tool and how to position
your elements in the 3D space.

•

Repositioning the Pivot Point Temporarily below

•

Panning a Drawing Layer on the next page

•

Rotating a Drawing Layer on page 500

•

Scaling an Element on page 500

•

Skewing an Element on page 501

Repositioning the Pivot Point Temporarily
Some transformations, such as rotation, scale, skew and flip, are made relative to the pivot point position. You
can temporarily reposition this pivot point for each transformation using the Transform
tool.
To temporarily reposition the pivot point:
1. In the Tools toolbar, select the Transform

tool.
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2. In the Transform tool Tool Properties view, make sure that the Peg Selection Mode

is disabled.

3. In the Camera view, click on your element to select it.
The pivot point will appear in the Camera view.

4. Click on the pivot point and drag it to a new position.
This will be the new position of the pivot point for the current transformation. It will remain in this new
position as long as you do not deselect the drawing.

Using the Transform tool to reposition your pivot will temporarily override the existing pivot point
position until you complete the current transformation, it then returns automatically to its original
position.

When you translate the pivot using the Transform tool, the permanent pivot will appear as a ghost so
you know where it is and also from where the animation will be interpolated when you create motion
paths. The animation is always interpolated from the original pivot and not the temporary pivot.

Panning a Drawing Layer
To pan a layer using the Transform tool:

1. In the Tools toolbar, select the Transform

tool.
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2. In the Transform tool Tool Properties view, make sure that the Peg Selection Mode

is disabled.

3. In the Camera view, select a drawing layer and drag the selection to a new area.

Rotating a Drawing Layer
To rotate a layer using the Transform tool:

1. In the Tools toolbar, select the Transform

tool.

2. In the Transform tool Tool Properties view, make sure that the Peg Selection Mode

is disabled.

3. In the Camera view, select the drawing layer and rotate the transform bonding box handle.

A preference found in the Camera tab will add a rotation handle to your object’s bounding box.This preference
is off by default.

Scaling an Element
To scale a layer using the Transform tool:

1. In the Tools toolbar, select the Transform

tool or press [Shift] + [T]

2. In the Transform tool Tool Properties view, make sure the Peg Selection Mode
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3. In the Camera view, select the drawing layer and then pull or push either on the size, top or corner control
point. Hold down [Shift] to lock the selection’s ratio.

Skewing an Element
To skew a layer using the Transform tool:

1. In the Tools toolbar, select the Transform

tool.

2. In the Transform tool Tool Properties view, make sure that the Peg Selection Mode

is disabled.

3. In the Camera view, select the drawing layer and drag sideway or up and down the sides or top and
bottom segments, between the control points.

Related Topics
•

Using Advanced Animation Tools to Position a Layer below

Using Advanced Animation Tools to Position a Layer
You can also use the advanced animation tools to position your layers.
•

Permanently Repositioning the Pivot Point below

•

Panning an Element using the Translate Tool on the facing page

•

Rotating an Element using the Rotate Tool on page 503

•

Scaling an Element using the Scale Tool on page 503

•

Skewing an Element using the Skew Tool on page 504

Permanently Repositioning the Pivot Point
Some transformations, such as the rotation, scale, skew and flip, are made relative to the pivot point position.
Reposition this pivot point anywhere using the current Advanced Animation tool.
To permanently reposition the pivot point:
1. In the Advanced Animation toolbar, select the Rotate

, Scale

or Skew

tool.

2. In the Camera view, [Ctrl] + click (Windows) or [⌘ ] + click (Mac OS X) to select your element.
The pivot point appears in the Camera view.
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3. Click the pivot point and drag it to a new position.

This is the new position of the pivot point for future transformations until you reposition it.

Using the Advanced Animation tools to reposition your pivot permanently overrides the existing
pivot point position until you change its position again.

Panning an Element using the Translate Tool

To pan a layer using the Translate tool:
1. Do one of the following:
‣

In the top menu, select Animation > Tools > Translate.

‣

In the Advanced Animation toolbar, click the Translate

‣

Press [Alt] + [2].

tool.

2. In the Camera view, [Ctrl] + click (Windows) or [⌘ ] + click (Mac OS X) on the element to select it and drag
the selection to a new area.
You can select multiple layers to reposition them at the same time. Press [Ctrl] + [Shift] + click (Windows)
or [⌘ ] + [Shift] + click (Mac OS X) on each element to select them.
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Rotating an Element using the Rotate Tool

To rotate a layer using the Rotate tool:
1. Do one of the following:
‣

Select Animation > Tools > Rotate.

‣

In the Advanced Animation toolbar, click the Rotate

‣

Press the [Alt] + [3].

tool.

2. In the Camera view, [Ctrl] + click (Windows) or [⌘ ] + click (Mac OS X) on the element to select it and
rotate the layer.
You can select multiple layers to rotate them at the same time. Press [Ctrl] + [Shift] + click (Windows) or
[⌘ ] + [Shift] + click (Mac OS X) on each element to select them.

Scaling an Element using the Scale Tool

To scale a layer using the Scale tool:
1. Do one of the following:
‣

Select Animation > Tools > Scale.

‣

In the Advanced Animation toolbar, click the Scale

‣

Press [Alt] + [4].

tool.

2. In the Camera view, [Ctrl] + click (Windows) or [⌘ ] + click (Mac OS X) on the element to select it and pull
or push either on the side, top or corner control point. Hold down [Shift] to lock the selection’s ratio when
using the corner control points.
You can select multiple layers to scale them at the same time. Press [Ctrl] + [Shift] + click (Windows) or [⌘ ]
+ [Shift] + click (Mac OS X) on each element to select them.
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Skewing an Element using the Skew Tool

To scale a layer using the Skew tool:
1. Do one of the following:
‣

Select Animation > Tools > Skew.

‣

In the Advanced Animation toolbar, click the Skew

‣

Press [Alt] + [5].

tool.

2. In the Camera view, [Ctrl] + click (Windows) or [⌘ ] + click (Mac OS X) on the element to select it and drag
a side of the bounding box up, down or sideways.
You can select multiple layers to skew them at the same time. Press [Ctrl] + [Shift] + click (Windows) or [⌘ ]
+ [Shift] + click (Mac OS X) on each element to select them.

Refer to the Interface on page 61 chapter to learn how to display the Advanced Animation toolbar.

Related Topics
•

Positioning an Element using the Transform Tool on page 498

Flipping an Element
There are two different options you can use when you want to flip your element.
•

Flip Horizontal and Flip Vertical below

•

Flip Scale X and Flip Scale Y on the next page

Flip Horizontal and Flip Vertical
The Flip Horizontal and Flip Vertical options flip your drawing layer along Camera view’s horizontal and vertical
axis.
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To flip a layer:
1. In the Tools toolbar, select the Transform

tool or press [Shift] + [T]

2. In Tool Properties view, make sure the Peg Selection Mode

is disabled.

3. In the Camera view, select the drawing layer you want to flip using the Transform

tool.

4. Select Animation > Flip > Flip Horizontal or Flip Vertical or press [4] and [5].

Flip Scale X and Flip Scale Y
Once your drawing layer has been rotated, the original horizontal and vertical axes change. The Flip Scale X and
Flip Scale Y will perform a flip on your drawing layer following its original axis.

To flip an element following its original axis:
1. In the Transform tool Tool Properties view, make sure that the Peg Selection Mode
2. In the Camera view, using the Transform

is disabled.

tool, select your element that has already been

transformed.
3. Select Animation > Flip > Flip Scale X or Flip Scale Y.
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Related Topics
•

Positioning an Element using the Transform Tool on page 498

Resetting a Transformation
Once your layers are positioned in the Camera view, you can easily reset them to their original position. Use the
Reset command to reset the value of the selected element to the initial value of the active tool. For example, if
the Rotate
tool is active, the transformation angle will be reset to 0 and if the Transform
tool is active,
the entire transformation values will be reset.

When using the Transform
Peg Selection Mode

tool to select element in the Camera view, always make sure that the

option in the Tool Properties view is disabled or else it will limit the

selection to peg only.

To reset the layers position:
1. In the Tools toolbar, select the Transform

tool or press [Shift] + [T].

2. In the Timeline or directly in the Camera view, select the drawing layers you wish to reset. You can select
more than one layer at a time.
3. Select Animation > Reset or press [Shift] + [R].
The selected layers will automatically return to their original position.
You may also choose to reset all values of your selected element, except for its position in Z space.
To reset all except Z:
1. In the Tools toolbar, select the Transform

tool or press [Shift] + [T].

2. In the Timeline or directly in the Camera view, select the drawing layers you wish to reset. You can select
more than one layer at a time.
3. Select Animation > Reset All Except Z.
All values, except for those set on the Z axis, will be reset.

In the Timeline view, you can also use the Clear All Values command to reset all transformation
values on the selected layers. Right-click on the selected layers and select Clear All Values.

Related Topics
•

Positioning the Scene Components on page 490
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Clone Layer
A cloned layer is linked to the original element directory. If a drawing is modified in the original or cloned layer,
both will be updated. However, clone layers can have different timings.
For example, if you make a walk-cycle for a soldier and want to use it for a whole army, you may want to have
fifty layers with fifty different drawing exposures to produce a slight difference in the timing. You don’t
necessarily want the same drawing fifty times. If you copy your layers and their drawings fifty times over, it will
create a very heavy scene. It is better to clone the fifty layers from the same initial layer to have them all linked to
the same walk cycle drawings, producing fifty layers but one drawing directory. This will also allow you to correct
the drawings in one layer and have all of the other ones updated simultaneously.

When you clone a layer that is already linked to a function, the cloned layers are automatically linked
to the same function, so if you reposition the layers while in Animate
mode, they are all
repositioned to the same place because a keyframe is added to this function. If you want the layers to
move on a trajectory that is independent, make sure to unlink the function before cloning.

To clone a layer:
1. In the Timeline view, select the layer to clone.
‣

In the Network view, select the module you want to clone.

2. In the Timeline View menu, select Layers > Clone Selected Layers.
‣

In the Network View menu, select Modules > Clone Selected Modules.

Note that the module will not appear in the Timeline view if it is not connected to the Composite module
or if the Display mode is not set on Display All.
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Related Topics
•

Duplicate Layer

•

Animation Paths on page 637

•

Setting Up the Network on page 1
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Creating a Multiplane

One of the most exciting features in Toon Boom Animate is the multiplane, or Z-depth. In the multiplane you can
create backgrounds in several layers, spread them on the Z-axis, add depth, and then move the camera through
this environment to create an impressive perspective illusion. You can create backgrounds, use a layered PSD file
or use a project from the sample material package.

Related Topics
•

Top View and Side View below

•

Perspective View on the facing page

•

Setting Up the Multiplane on page 512

•

Distributing Elements on the Z-Axis on page 513

•

Positioning Elements in 3D Space on page 1

•

3D Camera Motion on page 1

Top View and Side View
The Top and Side views are used mainly for multiplane scenes and to position elements in 3D Space. They let the
scene’s stage to be seen from the top or the side. This lets the camera cone and the spacing between the
elements to be seen.

Refer to the following sections of the 3D Space chapter to learn more about positioning elements in
3D space and creating 3D Camera moves:
•

Positioning Elements in 3D Space

•

3D Camera Motion

509

Chapter 10: Scene Setup Creating a Multiplane

1. The camera cone represents the camera’s field-of-view (FOV).
2. A thumbnail of each drawing layer in your scene. The order of the thumbnail images is based on each
element’s FB position in the scene space. You can see a representation of the FB position of each layer in
the camera cone.

Refer to the Animation Paths on page 637 chapter to learn about keyframes, control points and
animation paths. Refer to the Creating a Multiplane on the previous page topic to learn how to
position your elements in the Top and Side view.

Related Topics
•

Perspective View below

•

Creating a Multiplane on the previous page

Perspective View
The Perspective view is used during scene setup. Its main use is to allow you to see your multiplane scene’s
orientation. The Perspective view is similar to a 3D display, as it lets you rotate your scene through all possible
angles to understand the spacing between the elements. You can also position and rotate your layers and the
camera inside the 3D display to achieve some 3D setup and camera moves.

Refer to the following sections of the 3D Space chapter to learn more about positioning elements in
3D space and creating 3D camera moves:
•

Positioning Elements in 3D Space

•

3D Camera Motion
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1. The blue circle represents a rotation of the X and Y axis plane.
2. The red circle represents the rotation of the Y and Z axis plane.
3. The green circle represents the rotation of the X and Z axis plane.
4. This is a perspective grid reference.
5. The axis reference arrows let you maintain your orientation when navigating in the Perspective view.
6. There are three view option buttons displayed in the lower-left corner of the view.
‣

Show/Hide Camera: Shows or hides camera frame in the Perspective view.

‣

Reset View: Resets the Pan, Rotation and Zoom of the Perspective view.

‣

Reset Rotation: Resets the rotation of the Perspective view.

7. This field displays the current zoom level in the Perspective view. You can use the Zoom level drop-down
menu to select a specific zoom level from the list. Zoom levels from 2.5% to 6400% are available, you can
also select Fit To View to automatically use a zoom level that lets you see all of your scene layers and
information in the Perspective view at once.

8. This field displays the currently selected layer and drawing name.
9. This field displays the currently selected tool.
10. This field displays the currently selected frame of your animation.
11. This field displays the current position of your cursor inside the Perspective view.
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To rotate a scene in the Perspective view:
1. In the Tools toolbar, select the Rotate View

tool.

‣

Click in the view, and drag your cursor around to rotate the view.

‣

Press and hold [Alt] + [Shift] and click and drag to rotate the view one axis at a time.

Related Topics
•

Creating a Multiplane on page 509

•

Top View and Side View on page 509

Setting Up the Multiplane
To construct a multiplane, you must imagine what a real environment is like. Take a look at your background
picture and imagine a camera moving across the space. You will notice that objects in the picture would move at
different speeds depending on where they are in relation to the camera lens.
Building a multiplane requires an understanding of the scene's background as well as the positioning of the
elements on different layers.

For example, in this background, the main objects to be separated are:
1. Fern
2. Front tower
3. Second tower
4. Moon
5. Stars
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6. Sky

Although the bottom of the tower is hidden behind the plant and the ladder, each of your multiplane
layers should be a complete drawing. This is because hidden portions may show up during a camera
movement later on in the scene

Related Topics
•

Distributing Elements on the Z-Axis below

Distributing Elements on the Z-Axis
Now is the time to distribute the layers composing your multiplane along the Z-axis, maintaining their distance.
You can position your layers on the Z-axis in the Side and Top view.
Positioning your element toward the camera will make your element bigger. Using the Maintain Size

tool,

you will be able to drag your element toward the camera while keeping the same size aspect in the Camera view.
This tool is available in the Advanced Animation toolbar.

It is a good idea to keep a Camera view opened to see what your scene looks like while positioning
your element in the Top or Side view.

Positioning Elements in the Top and Side Views

To be able to distribute the layers along the Z-axis using the Top and Side views, disable the No Z
Dragging option by selecting Animation > No Z Dragging.
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To position your element in the Top and Side views:
1. In the Advanced Animation toolbar, click the Maintain Size

tool or press [Alt] + [6].

2. In the Side view, select one of the layers in the thumbnails section of the Top or Side view. You can also
select your layer from the Timeline view.
The selected layer will be highlighted in the camera cone.

3. Click and drag the layer to the correct depth position in the camera cone. Your element aspect will remain
the same in the Camera view.

4. In the Tools toolbar, click the Transform

tool, or select the Translate

tool in the Advanced

Animation toolbar and select a layer from the thumbnails section of the Top or Side view. You can also
select your layer from the Timeline view.
‣

If you choose the Transform

tool, make sure that the Peg Selection Mode

the Transform tool's Tool Properties view.
The selected layer will be highlighted in the camera cone.
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5. In the T O P view, drag the element sideways to position horizontally. You can press and hold [Shift] while
dragging the element to make sure it only moves along the X-axis.
6. In the Side view, drag the selected element up or down to position it vertically. You can press and hold
[Shift] while dragging the element to make sure it only moves along the Y-axis.

Related Topics
•

Creating a Multiplane on page 509

•

Top View and Side View on page 509

•

Perspective View on page 510

•

Setting Up the Multiplane on page 512
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Scene Setup Preferences
When setting up your scene in Animate, some preferences can help you work more efficiently.
•

General Tab Preferences below

•

Camera Tab Preferences on the next page

•

Scene Setup Preferences above

•

Scene Setup Preferences above

•

OpenGL Tab Preferences on page 519

•

Scene Setup Preferences above

To open the Preferences dialog box:
‣

Windows: Select Edit > Preferences.

‣

Mac OS X: Select Animate > Preferences.

‣

Press [Ctrl] + [U] (Windows) or [⌘ ] + [U] (Mac OS X).

General Tab Preferences
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Camera Tab Preferences

Tools

•

Show Locked Drawings As Outlines: In the Camera view, locked elements are displayed as outlines only.

•

Bounding Box Selection Style: In the Camera view, selected elements are not highlighted in colour but
are displayed with the bounding box only.

•

Nudging Factor: The nudging increment value.

•

Use Rotation Lever with transformation tools: Enable this preference if you prefer to see the rotation
lever when using the transformation tools. Without this preference enabled, hovering your cursor of the
corner of an element’s bounding box is sufficient to rotate it.

Zoom Settings

•

Camera View Default Zoom: The default zoom value for the Camera view.
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Settings

•

Thumbnail Size: The thumbnail size, in pixels, that appears in the Top and Side views.

•

Small Bitmap Resolution: The size, in pixels, of the smaller bitmap version of your image. When you
import a bitmap image into a scene, a smaller version of it is created by the system in order to accelerate
the compositing and playback processes.

•

Override Small Bitmap Files: Enable this option if you want the system to generate new versions of the
already existing smaller bitmap files, every time you modify the Small Bitmap Resolution value. When the
option is disabled, the already existing smaller bitmap versions will not be regenerated and will keep the
same resolution as when they were created.

Wash Background

•

Enable in Camera: Dulls background bitmaps in Camera view. This allows you to see other elements
clearly, such as the ones that have not yet been painted.

•

Enable in Camera Drawing Mode: Dulls background bitmaps in Camera view while using drawing tools.
This allows you to see other elements clearly, such as the ones that have not yet been painted.

•

Wash Background Percentage: The Wash Percentage value.
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OpenGL Tab Preferences

Settings

•

Conservative Texture Management: Turns on and off conservative memory management for bitmap
texture files. Performance will improve when this is enabled. If disabled, you will have a better on-screen
rendering of bitmap files at the expense of slower performance.

•

Smooth Textures: Smooths out the pixels of bitmap images when zooming in; this improves bitmap
image quality.

•

Alternate Gradient and Cutter: This is an alternative way to disable write in the OpenGL Backbuffer,
required for some video cards (i.e. GeForce FX5200). Do not enable this option unless you are
experiencing problems with gradients and cutters in OpenGL.

•

Use PBuffer for Picking: This will use an off-screen buffer for picking, resulting in a quicker response. This
option should not be enabled if using a small capacity video card (32MB).

•

Support Triple Buffer: Enable this option for a better compatibility with Windows Vista if your video card
driver does not allow to disable the triple buffering option. Not enabling this option may result in a
dashing line when drawing a brush stroke.

•

Support Desktop Effects: Enable this option for better compatibility with Windows 7, Windows Vista
and Mac OS X desktop effects. This will prevent graphic compositing problems from happening when the
full-scene anti-aliasing option is enabled.

•

Maximum Texture Size: The size that the bitmap file will be reduced to when using the Conservative
Texture Management

•

Texture Memory: The amount of temporary memory used to store bitmap texture files.
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•

Vector Drawing Maximum Texture Size: This is the size that the .tvg file will be reduced to for better
performance when in OpenGL render mode.
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Chapter 11: Library

You can share and reuse any elements you create in Toon Boom Animate using symbols and Templates. Animate
has a library where you can store several different elements such as puppets, backgrounds, animations and
keyposes. In fact, anything you create in Animate can be stored in the library.

Topics Covered
•

Understanding the Library Concept on the facing page

•

Library View on page 524

•

Structuring the Library on page 527

•

Symbols on page 532

•

Templates on page 540

•

Importing Symbols and Templates on page 543

•

Preferences on page 1
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Understanding the Library Concept

Understanding the Library Concept
Use the Library view to reuse your artwork and animation in other scenes or to build props and puppets.
•

What is a Library? below

•

What is a Symbol? below

•

What is a Template? on the next page

•

Understanding the Library Concept above

What is a Library?
A library is a folder where you store your templates and symbols. You can access these folders from different
projects. Using the library is easy, just drag the content into the library to store your artwork and then drag it
into your Timeline or Camera view when you want to reuse it.
Organize your library using subfolders. You can keep several different library folders on your hard drive or
network.

What is a Symbol?

A symbol is a container or construction block used to build your props, puppets and looping clips. Use symbols
to contain artwork and animation, to manipulate them as a single object, or as a case holder where you will put a
series of different drawings for each body part of your puppets.
To create a symbol, drag your artwork to the Symbol library. When you drag a symbol from the Symbol library
into your scene, it will be linked to the original one. If you drag a symbol into your scene several times in the
Timeline view, they will all be linked to the original one. If you modify one, they will all be modified.
A symbol is local to the project and cannot be accessed directly from other scenes. To reuse a symbol's content
into another scene, you must create a template out of it.
When a symbol is exposed in the Timeline view, the symbol's cells are represented as a movie strip.
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What is a Template?

A template is an individual copy of the artwork stored in the library. This package can be reused in different
scenes. Once a template is stored in the library it can be accessed from any project.
Dragging a template into your scene copies the content in your Timeline and does not link it to the original. This
individual copy can be modified at will.

Related Topics
•

Library View on the facing page
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Library View

Library View

You use the Library view to create and manage your symbols and templates, display the folders and manage and
all of the content.
1. Library View Menu below
2. Preview and Drawing Substitution below
3. Library Search Tool on the next page
4. Library List on the next page
5. Templates and Symbols List on page 526

Library View Menu
The Library View menu lets you access commands specific to the Library view such as opening a Library or
getting the rights to modify a library folder.

Preview and Drawing Substitution

The Preview window, allows you to preview the content of a symbol or template and to swap between drawings
and symbol cells in your Timeline view. This window is also used as the Drawing Substitution window.
To preview a template or symbol's content:
1. In the Library view's right side, click or double-click on the symbol or template to preview.
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2. In the Preview window, click on the Play

button or drag the slider to scrub through the frames.

Library Search Tool
When working on a movie or series, you will most likely end up with a lot of templates and symbols in your
library. You have access to a Search tool to help you find templates and symbols in your folders.
To use the Library Search tool:
1. In the Library view, in the left side, select the library you wish to search in.

2. In the Search field, type the name or partial name of the symbol or template you are looking for.

3. Click on the left

and right

arrows to see the previous and next results. The Search engine will

look for result within the library master folder and its subfolders. It will not look in other libraries.

Library List
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Templates and Symbols List

The Library List is used to navigate through the different libraries and subfolders. You can also open, close and
create new libraries from here.
The Library has two default folders:
•

Symbols
The only library folder containing symbols for your project. You can organize the symbols library folder
using subfolders, but you cannot create a second Library for your symbols. This library is local to your
project.

•

Animate Library
This folder contains templates and is stored on your hard drive. You can share the contents of this Library
between different projects. You can organize the Animate library folder using subfolders. This folder does
not contain symbols.

Templates and Symbols List

The symbols and templates contained in the selected Library list can be displayed on the right side of the Library
view as thumbnails, in a list or as details.
To access the templates and symbols list display options:

‣ In the Library view's right side,right-click and select View > List, Thumbnails or Details.
‣ In the Library View toolbar, you can click on the following buttons:
•

Thumbnails

•

List

•

Details

Related Topics
•

Understanding the Library Concept on page 522
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Structuring the Library
As you will probably create a large number of symbols and templates you will soon realize that they need to be
organized. You can create different libraries and subfolders so that you can gain easy access to your assets. For
example, create a different library for each project and divide it into several categories, such as:
•

Characters

•

Props

•

Backgrounds

Although you can only have one symbol library folder, you can organize it by creating subfolders.
•

Creating a Library below

•

Opening a Library on the facing page

•

Closing a Library on page 529

•

Creating a Folder on page 529

•

Deleting a Folder on page 530

•

Renaming a Folder on page 530

•

Refreshing the Library on page 530

•

Generating Thumbnails on page 531

Creating a Library
There are two ways to create Library folders.
•

Using Animate's interface.

•

Directly through your operating system.

To create a library using your operating system, create a new folder with a relevant name in the location where
you want the library to be stored. This can be opened in Animate when you require it. .
To create a library from Animate:
1. In the Library view click on the Menu

button and select Folders > Open Library.

The Browser window opens.
2. Browse for the location where you want to store your new library.
3. Click on the Make New Folder button.
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Opening a Library

The new folder appears.

4. Name the new library with a relevant name.

5. Click on the OK button.
The new library appears in the Library List section.

Opening a Library
You can open any folder on your hard drive or network as a library. Opening a library means linking the folder to
your Library view. You only need to open the library once. The library folder is available every time you open the
application until you decide to close the library and unlink it.
To open a library:
1. In the Library View menu, select Folders > Open Library.
The Browser window opens.
2. Browse to the location of the library folder.
3. Select the folder.
4. Click on the OK button.
The new library appears in the Library Folders section.

528

Toon Boom Animate 3 User Guide

Closing a Library
You may not always require all of the library folders in the Library List, if this is the case you can close the ones
you do not need. Closing it does not delete the folder, it only unlinks it from the Library view. If you want to
reopen in later, you only need to locate it on your hard drive or network and open it in the Library view.
To close a library:
1. In the Library view's right side, select the library folder to close.
2. In the Library View menu, select Folders > Close Library.
The library closes.

Creating a Folder
Symbols and Template libraries need to be well organized. You can create different subfolders on your hard
drive or in the Library view so that you can gain easy access to your assets. By default, any new library you link to
your Library view is locked, this prevents the accidental deletion or modification of templates and symbols. You
must obtain the right to modify a locked folder before being able to create subfolders for it.
To create a folder:
1. In the Library view's left side, select a library folder that you would like to make subfolders for.
2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and select
Right to Modify.
3. In the Library View menu, select Folders > New Folder.
The new subfolder is added to the Library view (although not immediately visible as it is collapsed in its
parent folder). Click on the root library folder containing the new folder and click on the "+" sign to
expand it.
The new subfolder appears.
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Deleting a Folder
You can delete a folder from the library if its contents are no longer needed.

ALL THE TEMPLATES OR SYMBOLS CONTAINED IN THE FOLDER WILL BE DELETED FROM YOUR
HARD DRIVE. ONCE DELETED THE DATA CAN NOT BE RETRIEVED.

To delete a folder:
1. In the Library view's left side, select the folder to delete.
2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and select
Right to Modify.
3. In the Library View menu, select Folders > Delete Folder or press [Delete].

Renaming a Folder
Once you add a folder, you can rename it, this also renames the folder on your hard drive.
To rename a folder:
1. In the Library view's left side, select the folder to rename.
2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and select
Right to Modify.
3. In the Library View menu, select Folders > Rename Folder.
4. Rename the selected folder.

5. Press [Enter/Return] to validate the operation.

Refreshing the Library
If you update the content of your libraries through your operating system, you will need to refresh your library
folders in the Library view.
To refresh a library:
1. In the Library view's left side, select the folder to refresh.
2. In the Library View menu, select Folders > Refresh or press [F5].
The library now displays the new content.
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Generating Thumbnails
When you display thumbnails in the Library view, the system generates a series of small images (thumbnails) for
you. You can generate template thumbnails yourself, if they do not display or if the process has been stopped.
To generate thumbnails:
1. In the Library view's right side, select the template you want to generate thumbnails for.

2. In the Library View menu, select View > Generate Thumbnails.
The progress bar appears.
You can also delete thumbnails if you want to send a template to another user or studio and keep your packages
small.
To delete thumbnails:
1. In the Library View menu, select Edit > Delete Thumbnails.
All the thumbnails contained in the library are removed.

Related Topics
•

Understanding the Library Concept on page 522
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Symbols

A symbol combines animation, artwork or layers into a single object that you can control in one layer. You can
also create symbols out of each body part in your cut-out puppets.

You do not need to create Symbols in order to create drawings or characters in Toon Boom Animate.

Related Topics
•

Creating a Symbol below

•

Deleting a Symbol on page 535

•

Editing a Symbol on page 536

•

Duplicating a Symbol on page 538

•

Sharing a Symbol on page 538

Creating a Symbol
You can create symbols in several ways:
•

Creating a Symbol from a Drawing Selection below

•

Creating a Symbol from the Timeline View on page 534

•

Creating a Symbol above

•

Creating an Empty Symbol on page 535

Creating a Symbol from a Drawing Selection
To create a symbol from a drawing selection:
1. In the Tools toolbar, select the Select

or Cutter
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2. In the Camera view, select the drawing objects which you want to create a symbol out of.

3. In the top menu, select Edit > Create Symbol or press [F8]. You can also click on the Create Symbol
button in the Edit toolbar.
The Create Symbol from Drawing Selection dialog box opens

4. In the Symbol Name field, type the name of the symbol.
‣

You can also select an existing layer from the Symbol Name drop-down menu. It will add your symbol
on the layer's current cell. If there is already an exposure on that cell a warning message will appear
stating, "Layer Head already has an exposure on current frame. Can't perform operation."

‣

If you want to rename a symbol,right-click on the symbol and select Rename.

5. You can choose to leave the current selected artwork in the drawing or not:
‣

To remove currently selected artwork from the drawing and leave it in the new symbol, enable (place a
checkmark in the checkbox) the Cut Artwork From Source Drawing option.

‣

To keep currently selected artwork in both the drawing and in the new symbol, disable (remove the
checkmark from the checkbox) the Cut Artwork From Source Drawing option.

6. Click OK.
The new symbol appears in the Library view's symbol folder and in the Timeline view as a new layer.
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Creating a Symbol from the Timeline View
To create a symbol from the Timeline view:
1. In the Timeline view, select the layer or the cells from which your want to create a symbol.
2. In the top menu, select Edit > Create Symbol or press [F8]. You can also click on the Create Symbol
button in the Edit toolbar.
‣

Another way to create a symbol is to select the layer or cells from the Timeline view and to drag them
on the Symbol folder in the Library view.

The Create Symbol dialog box opens

3. In the Enter Symbol's Name field, type the new symbol's name.
‣

To rename a symbol once it is created, right-click on the symbol and select Rename.

4. Click OK.
The new symbol appears in the Library view's symbol folder.

The current selection is not replaced by the new symbol. The new symbol only appears in the library.
You must drag it into your scene to use it.
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Creating an Empty Symbol
To create an empty symbol:
1. In the Library view, select the Symbol folder.
2. In the Library view's right side,right-click and select New Symbol. You can also select Insert > Create
Empty Symbol in Library from the top menu.
The new empty symbol appears in the Library view.

‣

The symbol is ready for you to edit (add content to). To go back to the root timeline, click on the Top
button in the Camera view.

‣

To rename a symbol once it is created,right-click on the symbol and select Rename.

Related Topics
•

Importing Symbols and Templates on page 543

Deleting a Symbol
Deleting a symbol is easy.

WARNING: THE SYMBOL WILL BE DELETED FROM YOUR HARD DRIVE. USE UNDO TO RETRIEVE
THE DATA. THE DATA CANNOT BE RETRIEVED ONCE YOU CLOSE THE APPLICATION.

To delete a symbol:
1. In the Library view, select the symbols to be deleted.
2. Right-click on the selection and select Delete or press [Delete].

535

Chapter 11: Library

‣

Symbols

If the symbol is currently in use in the scene, a warning message will pop up and the symbol will not be
deleted.

Related Topics
•

Creating a Symbol on page 532

Editing a Symbol
When you import a symbol from the library to the Timeline view it is linked to the original symbol in the library. If
you import a symbol into your scene several times in the Timeline view, they will all be linked to the original
symbol. If you modify one, they will all be modified.
If you want to edit a symbol without modifying the other instances, you must duplicate the symbol first, See
Duplicating a Symbol on page 538.
You can either edit a symbol from the Timeline view or from the Library view.
When you edit a symbol, the drawings contained in it are not placed at the centre of the stage, but are located in
the position where they were created. The pivot is translated at the centre of the symbol.
To edit a symbol from the Timeline view:
1. In the Timeline view, double-click on the symbol's cell to edit the symbol. You can also double-click on the
symbol in the Camera View or press [Ctrl] + [E] (Windows) or [⌘ ] + [E] (Mac OS X)). You can also click on
the Edit Selected Symbol
button, available in the Camera View toolbar's extra buttons.

You are now inside the symbol and you are able to edit it.
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2. Click on the Top

button in the Camera view's top left corner to return to the project's timeline or

press [Ctrl] + [Shift] + [E] (Windows) or [⌘ ] + [Shift] + [E] (Mac OS X). In the Timeline view's right side,
right-click and select Symbols >Leave Current Symbol.
To edit a symbol from the Library view:
1. In the Library view, select the symbol to edit.
2. Right-click and select Edit > Edit Symbol. You can also double-click on the symbol.
You are now inside the symbol and you are able to edit it.

3. Click on the Top

button in the Camera view's top left corner to go back to the project's timeline or

press [Ctrl] + [Shift] + [E] (Windows) or [⌘ ] + [Shift] + [E] (Mac OS X).

Related Topics
•

Creating a Symbol on page 532

Symbol Hierarchy
When you enter a symbol to edit it, you are entering another scene where you have an independent timeline for
your symbol. You can nest many symbols one inside the other. To help you follow the hierarchy of your nested
symbol, take note of the Editing stack at the top of the Camera view which displays the path to your symbol's
location. You can click on the symbols' name to move up the chain.
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Symbols

Related Topics
•

Editing a Symbol on page 536

Duplicating a Symbol
You must duplicate a symbol if you want to modify a copy of it without altering the original symbol and the other
copies.
To duplicate a symbol:
1. In the Timeline view, go to the frame where you want to duplicate the symbol.
2. Select the symbol's cell.

3. In the top menu, select Edit > Duplicate Selected Symbol.
In the Library view, the symbol is duplicated and in the Timeline view, the current cell is replaced with the
new symbol. You can now modify the symbol's content.

If other symbols are nested inside the new symbol, those ones are not duplicated. If you modify
them, the original and other instances will also be modified.

Related Topics
•

Creating a Symbol on page 532

Sharing a Symbol
You can share a symbol and use its contents (the drawing or drawings that it contains) in another scene. To do
this, you must first convert your symbol into a template. This conversion breaks the drawing's link with both the
original scene and symbol. It then becomes a separate entity that you can import into your other projects.
To convert a symbol into a template:
1. From the Library view, select the symbol to convert into a template and drag it to the Camera or Timeline
view.

If you drop your symbol into the Camera view instead of the Timeline view, it will not be placed in
the centre of your camera frame, but rather wherever your cursor drops it within the camera frame.
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2. In the Timeline view, select the symbol's cells or layer and drag it to the Stage Library folder or to any
other library folder. Make sure you have the right to modify the library folder.

3. In the Rename dialog box, rename the new template.

4. Click on the OK button.

Related Topics
•

Creating a Symbol on page 532
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Templates

If you want to reuse artwork and animation from your project into other scenes, you need to create a template
out of it. A template can be seen as a portable scene or package that you can drag inside your project.

Related Topics
•

Creating a Template below

•

Deleting a Template on the next page

•

Editing a Template on page 542

Creating a Template
You can create a template from both the Timeline and the Network views:
•

Creating a Template

•

Creating a Template from the Timeline View below

Creating a Template from the Timeline View
You can create a template out of a layer or cells. You can store anything available in the Timeline view as a
template.

Creating a template selecting a layer will incorporate the layer and all the drawings that were created
in it, even if they're not exposed in the Timeline view. Selecting cells will only save those specific
drawings in the template.

To create a template from the Timeline view:
1. In the Timeline view, select some cells or layers.
2. In the Library view, select the folder in which you want to store the template.
3. If the library folder is locked,right-click and select Right to Modify.
4. Drag the selection to the Animate Library folder or to any other library folder.
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5. In the Rename dialog box, rename the new template.

If you want to rename a template once it is created,right-click on it and select Rename.
6. Click OK.

Related Topics
•

Importing Symbols and Templates on page 543

Deleting a Template
To delete templates from your library, use the Library view. Animate lets you undo the action if necessary.

Do not delete them using the operating system.

To delete a template:
1. In the Library view, select the folder containing the template to delete.
‣

If the library folder is locked,right-click on the folder and select Right to Modify.

2. Right-click on the selection and select Delete or press [Delete].
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Related Topics
•

Creating a Template on page 540

Editing a Template
A template is like a scene, you can open it and edit it as any regular project. If you want to do some modifications
in your templates, you can edit them using the Edit Template command.
To edit a template
1. In the Library view, select the folder containing the template to edit.
‣

If the library folder is locked,right-click on the folder and select Right to Modify.

2. Right-click on the selection and select Edit Template.
A new Animate application opens.
3. Edit the template.
4. In the top menu, select File > Save.
5. In the top menu, select File > Quit (Windows) or Animate > Quit (Mac OS X).

Related Topics
•

Creating a Template on page 540

542

Toon Boom Animate 3 User Guide

Importing Symbols and Templates
There are several ways you can import templates and symbols in your scene.

Related Topics
•

Importing a Template below

•

Importing a Symbol on the facing page

•

Opening a Template as a Folder on page 545

•

Using Paste Special on page 546

•

Expanding a Symbol on page 551

•

Animating Using Symbols

Importing a Template
To import a template in the Timeline view:
1. In the Library view, select the template you want to import.
2. Drag the selected template to the Camera view or Timeline view's left side.
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3. You can also drag a template to the Timeline view's right side into existing layers if the layer structure is
the same as the existing one.

Related Topics
•

Importing Symbols and Templates on the previous page

Importing a Symbol
To import a symbol in the Timeline view:
1. In the Library view, select the symbol you want to import.
2. Drag the selected symbol to:
‣

The Timeline view's left side if you want to import it into the centre of the camera frame.

OR
‣

The Camera view if you want to place it where ever your mouse releases it.

This may be useful if you have saved a character's body parts as separate symbols. If you dropped
them into the timeline then they would all appear in the centre, haphazardly one on top of the other.
It would be more efficient to arrange them into their correct places as you bring them into the scene.

Related Topics
•

Importing Symbols and Templates on the previous page

Importing a Template with Symbols
Sometimes a characters rig is not a straightforward matter. Rigs, which are usually saved as templates, can
contain symbols, such as a leg that was made with a patch. However, a symbol does not work in the same way as
an action template. In the Timeline view, you can add an Action template into another template of the same
structure. When a symbol is dropped into the right side of the timeline layer into a symbol of the same structure,
instead of adding itself onto the previous symbol, the new symbol becomes a copy.
To take more control of how the action template will behave when brought into the Timeline view, bring it in
using a Paste Special.
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To import a template with symbols:
1. Select the action template containing symbols from the right side of the Library view.
2. As you drag it from the Library view to the right side of the Timeline view to drop it next to a template
with the exact same rig, hold down [Alt] (Windows) or [⌘ ] (Mac OS X).
The Paste Special window appears.

3. Click on the Advanced tab.
4. Select one of the following options from the Symbols drop-down menu:

‣

Copy symbols if they do not exist: This is the default setting for this operation and will prevent
symbols in an action template from being copied.

‣

Duplicate symbols: Select this option if you wish to make copies of the symbols in your template.

‣

Overwrite symbols: If for some reason, a modification was made to a symbol in the action template
that does not exist in the basic rig template for a character, select this option to overwrite the
previous symbol.

Related Topics
•

Using Paste Special on the facing page

Opening a Template as a Folder
Since a template is like a scene, you can open the template's folder and select elements inside it such as
drawings.
Instead of importing the entire contents of a template you may only want to import a few drawings or a palette.
In this case, use the Open As Folder command to import the items you want.
If you want to import a palette, drag the palette file into the Palette List section of the Colour view.
To open a template as a folder:
1. In the Library view, select the folder containing the template to open.
‣

If the library folder is locked,right-click on the folder and select Right to Modify.

2. Right-click on the selection and select Open As Folder.
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3. In the library list section, click on the template's folder to display its content.

4. Drag the content to the Timeline or Colour view.

Related Topics
•

Creating a Template on page 540

Using Paste Special
When you import a symbol in your scene, by default its full length is exposed. If you import your symbol in the
Timeline view's left side all the frames will be exposed, but if you import it into an existing layer, you can use the
Paste Special command to adjust the import behaviour to fit your requirements.
When you import a template in the Timeline view, all layers are created as well as drawings and keyframes. It is
possible that you will want to import only the keyframes without the drawings or import only the drawings that
are not already in your layers. You can adjust the behaviour using the Paste Special command.
Once you set the parameters, Animate will reuse them each time you import a symbol in the Timeline view's right
side until you set new parameters.
To open the Paste Special dialog box:
1. In the Library view, select the symbol or template to import.
2. While dragging the selection to the Timeline view, hold down [Alt] (Windows) or [⌘ ] (Mac OS X).

Drop the selection in the Timeline view BEFORE releasing the hot key.

The Paste Special window opens.
3. Set the parameters.
4. Click OK.
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Paste Special - Basic Tab
Drawings
•

Only create drawing files when they do not exist: When adding exposures to a drawing layer, new
drawings will be created only when drawings with the same name do not already exist in the destination.
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Paste Special - Advanced Tab

•

Always create drawing files: When adding exposures to a drawing layer, new drawings will always be
created. If drawing files with the same name already exist, Animate will create a new name for the
drawing.

•

Extend Exposure: Extends the exposure of drawings to fill the range of cells to the destination frame.

•

Paste all Frames of the Symbols (full movie): When enabled, the Paste Special command will expose all
the symbol's frames instead of the first one only.

Cycle
•

Number of Cycles: Use the up and down arrows to increase or decrease the number of cycles you want
to paste. You can also type the value directly in the field.

•

Cycle Type

•

Normal (forward): This pastes your selection as it is, starting with the first cell and ending with the last
one.

•

Reverse: This pastes your selection in reverse, starting with the last cell and ending with the first one.

•

Forward -> Reverse: This pastes your selection as a yo-yo, starting with the first cell, going to the last
one and ending with the first cell.

•

Reverse -> Forward: This pastes your selection as a reverse yo-yo, starting with the last cell, going to
the first one and ending with the last cell.

Paste Special - Advanced Tab
Drawings
•

Do Nothing: Does not create or overwrite drawings.

•

Update Drawing Pivot: Revises the drawing pivot in the destination to use the same drawing pivot as the
first drawing in the template. If you have a range of drawings selected in the destination, the pivot points
of all selected drawings will be updated.

•

Add/Remove Exposure: Creates/deletes exposure values in the selected layer.
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You have the following choices as to how to treat drawings that will be created when adding an exposure:
•

Never create drawing files: When adding exposures to a drawing layer, drawing files will not be
created.

•

Only create drawing files when they do not exist: When adding exposures to a drawing layer, new
drawings will be created only when drawings with the same name do not already exist in the
destination.

•

Always create drawing files: When adding exposures to a drawing layer, new drawings will always be
created. If drawing files with the same name already exist, Animate will create a new name for the
drawing.

•

Extend Exposure: Extends the exposure of drawings to fill the range of cells to the destination frame.

•

Key Drawing Mode (Substitution): Pasting an exposure value replaces the cell value in the current
frame and in all frames following in sequence with the original cell value.

•

Paste all Frames of the Symbols (full movie): When enabled, the Paste Special command exposes all
the symbol's frames instead of only the first one.

Add/Remove Keyframes
•

Motion: Copies the properties of the selected motion keyframe to the new frame.

•

Velocity: Copies the properties of the selected velocity keyframe to the new frame.

•

Rotation: Copies the properties of the selected rotation keyframe to the new frame.

•

Skew: Copies the properties of the selected skew keyframe to the new frame.

•

Scale: Copies the properties of the selected scale keyframe to the new frame.

•

Force Keyframes at Function's Beginning and End: Adds a keyframe to the beginning and end of the
pasted function, reproducing the source function.

•

Offset Keyframes: When pasting functions, this option offsets the keyframes from the function's last
value by the values in the pasted function. This will continue the progression of a function rather than
repeat the values.

Option
•

Palette Option
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•

Do nothing: Does not create, overwrite, merge or link palettes.

•

Reuse palettes. Copy palettes if they do not exist: Palettes in the destination drawings are left as
they are.

•

Copy and overwrite existing palettes: Overwrites destination palettes with the palettes from the
source drawings.

•

Copy and create new palette files: Creates new palette files, placing them at the same relative
environment and scene level as the source. If the palettes in the templates were stored at the
environment level of the source scene, the paste operation will place the palettes in the environment
level of the destination scene.

•

Copy and create new palette files in element folder: Creates new palette files in the element folders
of the destination scene, rather than in the same relative job or environment.

•

Copy palette and merge colours. Add new colours only: Adds new colours to the destination
palettes and ignores colours that are the same in the two palettes.

•

Copy palette and update existing colours only: Adds new colours to the destination palette and
updates duplicate colours in the destination with colour values from the source.

•

Link to original palettes (colour model): Links the colour palettes in the destination scene to the
palettes in the source. Use this to link drawings to the palettes in a colour model.

•

Copy scene palettes and merge colours. Add new colours only: Adds new colours to the
destination scene palettes and ignores colours that are the same in the two palettes.

•

Copy scene palettes and update existing colours: Adds new colours to the destination scene palette
and updates duplicate colours in the destination with the colour values from the source.

•

Duplicate All Symbol Content: Instead of linking the symbol instance to the original one, the symbol will
be duplicated. A new symbol is created in the Library.

•

Symbols

•

•

•

Copy symbols if they do not exist: This is the default setting for this operation and will prevent
symbols in a Action template from being copied.

•

Duplicate symbols: Creates a duplicate of the symbol instead of linking the symbol instance to the
original one. The new symbol is created in the Library.

•

Overwrite symbols: If a modification was made to a symbol that does not exist in the basic rig
template for a character, select this option to overwrite the previous symbol.

Cycles:
•

Cycle Types:

•

Normal (forward): This pastes your selection as it is, starting with the first cell and ending with the last
one.

•

Reverse: This pastes your selection reversed, starting with the last cell and ending with the first one.

•

Forward -> Reverse: This pastes your selection as a yo-yo, starting with the first cell, going to the last
one and ending with the first cell.

•

Reverse -> Forward: This pastes your selection as a reverse yo-yo, starting with the last cell, going to
the first one and ending with the last cell.

•

Number of Cycles: Use the up and down arrows to increase or decrease the number of cycles you
want to paste. You can also type the value directly in the field.

Modules: Create New Columns: If you enable this option a new column will be created when you copy
and paste modules from the Network view or Layer in the Timeline view. If the layers are linked to function
curves, the function curves, the drawings and the timing will be duplicated.
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Related Topics
•

Importing Symbols and Templates on page 543

Expanding a Symbol
You can use the Expand Symbol command to extract a symbol's content and place it on the root timeline. The
symbol will not be removed from the Timeline view. Its content will be copied and inserted into the root timeline.
The symbol's layers will be parented to it in case you created motions and transformation on the drawing layer
that is containing the symbol. Breaking the hierarchy could result in loosing any scaling and animation you may
have done.
You can also expand a symbol within a group to avoid crowding your Timeline with a series of layers. When you
will expand the symbols, the layers will be contained in a Group module which you can expand to see the
content.
To expand a symbol:
1. In the Timeline view, select the symbol to expand.

2. In the top menu, select Edit > Expand Symbol or press [Shift] + [F8].

To expand a symbol in a group:
1. In the Timeline or Network view, select the symbol module or symbol cell you want to expand.

2. In the top menu, select Edit > Expand Selected Symbol in a Group.
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Paste Special - Advanced Tab

3. In the Timeline view, click on the Plus sign to see the Group content. In the Network view, click on the
Expand Arrow to enter the group.
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Chapter 12: Character Building

Toon Boom Animate is a great tool for building your characters. You can make use of different techniques and
features to break down your puppets.

Topics Covered
•

Setting the Default Separate Position Preference on the facing page

•

Breaking Down the Character on page 556

•

Ordering the Layers on page 563

•

Rigging on page 566

•

Adding Extra Drawings on page 579

•

Setting the Pivots on page 581

•

Storing the Character in the Library on page 586

•

Appendix on page 588
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Setting the Default Separate Position
Preference
Before you start adding layers to your puppets, you should enable the Default Separate Positions preference if it
is not already done.

If you enable the Default Separate Positions preference, when you create new layers, their X, Y and Z axes will be
independent one from the other.
By default, this preference is disabled, so when you animate your layers, the three directions are locked together
to form long and smooth trajectories controlled by a single easing parameter. However, when you do cut-out
animation, you will probably prefer to have three independent axes so that you can control them individually.

When you lock the three positions together, each time you add a keyframe, it is added on all three positions at
once.

When you separate the three positions, when you add a keyframe on one axis, it is not added on the other two.
This gives you more freedom when animating with motion keyframes and nudging parts forward and backward
over time.
To enable the Default Separate Positions preference:
1. In the top menu, select Edit > Preferences (Windows) or Animate > Preferences (Mac OS X). The
keyboard shorcut is [Ctrl] + [U] (Windows) or [⌘ ] + [U] (Mac OS X).
2. In the Preferences panel, go to the General tab.
3. In the Settings section, enable the Default Separate Positions option.
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4. Click on the OK button.

Related Topics
•

Breaking Down the Character on the facing page
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Breaking Down the Character

There are many techniques you can use to break down a puppet. In this section, you will learn about one of the
most common and simplest method. For your first character break down, follow these instructions to get an
idea of the way Animate works. Once you are used to the software and understand its basic functions and
commands, you will be able to create your own techniques to satisfy the needs of your production.

Refer to Appendix on page 588 at the end of the chapter for alternate technique tips.

Related Topics
•

Tracing the Model below

•

Articulations on page 560

Tracing the Model
The main break down technique shown here is to trace your model, completing the hidden lines and filling the
gaps. See the Appendix on page 588 to learn about more techniques.
To trace over your model:
1. In the Timeline view, add a new drawing layer for each body part to separate. You can press [Ctrl] + [R]
(Windows) or [⌘ ] + [R] (Mac OS X).

2. In the Timeline view, select the layer's first cell in which you want to draw the part.
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3. In the Tools toolbar, select the drawing tool needed.

4. In the Colour view, select the desired colour swatch.

5. In the Camera or Drawing view, draw the new part.

If you are working in the Drawing view, click on the Light Table button located in the Drawing View
toolbar to display the other layers as washed out colours. You can also press [Shift] + [L].

6. In the Tool Properties view, you can set the Pencil tool width to 0 to create invisible hairline if you want to
close a shape without drawing an actual stroke.
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7. In the Tools toolbar, select the Paint or Paint Unpainted tool to colour your drawing.
8. In the Colour view, select the corresponding colour.
9. In the Camera or Drawing view, paint your drawing.

10. Using the Select tool, select your drawing and flatten your lines by clicking on the Flatten

button

located in the Tool Properties view.
11. If your lines are composed of several pencil strokes, you might want to combine them into one single
smooth pencil line using the Merge Pencil Lines option. Using the Select tool, select the pencil lines to be
merged and in the Tool Properties view, click on the Merge Pencil Lines
button.
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12.Repeat the entire process until the breakdown is completed.

Related Topics
•

Drawing Using the Pencil Tool on page 130
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Articulations

Once your pieces are traced, you can proceed to the completion of the articulations.
Articulations are an important aspect of any cut-out break down, without them a puppet cannot move properly
and will not look good.
This topic is divided as follows:
•

Classical Articulation below

Classical Articulation
In this section, you will learn about classical articulation.
Classical articulation is the most popular technique for basic characters. It is quite simple and produces excellent
results, but it is not the most efficient method. In many instances, it causes limitations and extra drawing
corrections. For example, there may be a gap in the articulation if the part is bent too far. Joint design is usually
designed as a circle; the overlapping part cannot be sent behind without showing the joint.

Classical articulation is done by erasing a part of the line from the overlay layer, leaving the colour overlapping
the bottom one.
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Repeat the following instructions for all the articulations on your puppet.
To create a classical articulation:
1. In the Timeline view, select the cell containing the first part to modify, such as the upper arm.

2. In the Tools toolbar, select the Pencil, Polyline, Ellipse, or Contour Editor tool.
3. In the Colour view, select the outline colour.

4. In the Drawing or Camera view, use your drawing tool to make sure that the joint is overlapping the other
part in a half-circle shape.

‣

If you are working in the Drawing view, click on the Light Table

button located in the Drawing

View toolbar or press [Shift] + [L].
5. In the top menu, select View > Show > Show Strokes to display the invisible lines that could be present
in your drawing. You can also press [K].
6. In the Drawing or Camera view, select all the strokes in your drawing.
7. In the Tools Properties view, click on the Flatten button.
8. In the Drawing or Camera view, select all the strokes in your drawing.
9. In the top menu, select Drawing > Optimize > Remove Extra Strokes. This operation will remove any
unnecessary invisible lines in your drawing.
10. Repeat Step 1 to Step 9 for the other part of the joint.
11. In the Timeline view, select the cell of the part that will be on top of the joint.
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12. In the Tools toolbar, choose the Select, Cutter or Eraser tool.
13. In the Drawing or Camera view, remove a part of the overlapping outline in order to have only the filling
colour overlapping the joint.

14. In the Tools toolbar, select the Contour Editor tool.
15. In the Drawing or Camera view, adjust the colour fill so that the pencil outline does not overlap it. Be
careful not to leave a gap between the line and the fill.

When placing rotation pivots later on, make sure they are positioned at the centre of the articulation.
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Ordering the Layers

At this point, it is possible that your character's pieces may show up in the wrong order.
There are several ways to fix this. First, you can reorder your layers by dragging them to a higher or lower level in
the Timeline view. The top layer is displayed in front of the others and the bottom one is displayed behind.
Second, you can use the Z-axis nudging (forward and backward) if you have extra views included in the same
layers (front, three-quarter, back, etc.).
This topic is divided as follows:
•

Ordering the Timeline Layers below

•

Nudging Parts Backwards and Forwards on the facing page

Ordering the Timeline Layers
In the Timeline view, the layer positioned at the top will be displayed in front and the ones below will be
displayed behind. If you have multiple views, you should order your layers based on the most common view,
which is generally the three-quarter front.
To order the layers:
‣

In the Timeline view, drag a layer to reorder it and drop it between the other layers.
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If you drop it on a layer, it will create a parent hierarchy, so make sure to drop it between layers.

Nudging Parts Backwards and Forwards
If you created a hierarchy on your arms, legs or other body parts, it is possible that you will want a part, such as
the hand, to appear in front of its parent. Yet, if you move the hand layer above the arm layer, you will break the
hierarchy. To reorder a layer rigged in a hierarchy, nudge it backwards or forwards on the z-axis.

Animate allows you to move your elements in three dimensions:
•

Up and Down (Y-axis)

•

Left and Right (X-axis)

•

Backwards and Forwards (Z-axis)

In the same way you create multiplane backgrounds (depth), you can do a micro nudge of the part to be
reordered and see it in front of the other elements, even if its layer is actually behind the other ones in the
Timeline view. The Forward-Backward position can also be animated over time.
Repeat the following instructions for all the views.
To nudge your parts backward and forward:
1. In the Tools toolbar, select the Transform

tool. Make sure to enable the Animate

564

mode.

Toon Boom Animate 3 User Guide

2. In the Camera view, select the element that you want to reorder. Make sure that the focus (red outline) is
around the Camera view before selecting the element.
3. To move the element forward, press [Alt] + [Down Arrow] and to move the element backward, press [Alt]
+ [Up Arrow].

Related Topics
•

Adding the Master Peg on page 575

•

Creating a Hierarchy on page 572
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Rigging

The rigging process is where building a puppet can take several different directions.

Related Topics
•

About Rigging below

•

Rigging the Head on page 570

•

Rigging the Body on page 571

•

Creating a Hierarchy on page 572

•

Ordering the Layers on page 563

•

Adding the Master Peg on page 575

•

Creating the Keyframes on page 576

•

Masking on page 577

About Rigging
There are few basic concepts to know about rigging and layer parenting:
•

Simple Rigging on the next page

•

Parenting Layers on page 568
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•

Rigging Using Pegs on page 569

Simple Rigging
Simple rigging is very fast and easy to do. It is built as follows:
•

All the body parts are independent

•

All the timeline's layers are attached to a master peg layer (trajectory layer)

The advantage of using this technique is that you are free to move any part around without being influenced by
any parent layer.

However, since the parts are not parented to each other, the parts will move from point A to point B along a
straight trajectory. The hand will not follow the arm's rotation. You will have to set more keyframes for the hand
to move along a curved path.
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Parenting Layers

When you want a part to follow another one, such as the forearm following the arm, you can attach the layers
one to the other. For example, you can attach the forearm layer to the arm layer without having to encapsulate
the forearm into the arm layer. They will still be parented, but you will be able to access the forearm directly
without having to enter the arm layer.

The advantage of parenting layers is that the child layers will follow the parent smoothly without having to select
them or create a series of keyframes.

The disadvantage of parenting layers is that you are not able to move the parent independently of its children,
since the child layers receive all the transformation information from their parent.
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Parenting layers such as the arms and legs and letting the torso and hips independent from those is often a good
solution.

To attach one layer to another, you have to drag the desired layer onto the other one in the Timeline
view.
Animate offers powerful techniques to create hierarchies between your layers without having to
encapsulate layers into each other. These techniques are a great improvement over the less efficient
and time consuming method of creating parenting between your layers by inserting symbols into
other symbols. Therefore, rigging with symbols inside symbols is NOT recommended.
This method is not recommended. For efficiency in your production, do not encapsulate symbols
inside symbols.

Rigging Using Pegs
When you are doing more advanced puppet rigging, you can use peg layers. Peg layers are trajectory layers that
do not contain drawings. They are motion paths that you can use to control your entire puppet or advanced
hierarchies.
Parenting a drawing layer to a peg layer allows you to divide your motions on two separated levels. You can
scale your body part directly on the drawing layer. This way, you do not affect any child layers that could be
attached to that part. Then, you can perform your translation and rotation on the peg layer so that all the parts
attached to that peg layer will follow the same trajectory.

569

Chapter 12: Character Building Rigging

Related Topics
•

Rigging the Head below

•

Rigging the Body on the next page

•

Creating a Hierarchy on page 572

Rigging the Head
You will start by attaching the facial features to the head.
The advantage of parenting the head and the facial features to the same peg is that you can easily animate each
facial feature, and they will all follow the head motion.

To parent the facial features to the head:
1. In the Timeline view, deselect any layer that could be selected.
2. Select the head layer.
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3. In the Timeline View Layer toolbar, click on the Add Parent Peg

button to add a new peg layer to

your timeline. You can rename the peg to keep your work organized.

A new peg is added and parented to the head layer.
4. Select all the remaining head and facial features layer and drag them ONTO the peg layer or BETWEEN
the head layer and the new head peg to parent them.

Related Topics
•

Rigging the Body below

Rigging the Body
Now that the character's head is ready, you can move on to the body. You can do a simple rigging where all of
the body parts are independent one from the other, or create some parenting between some of the layers. Refer
to Creating a Hierarchy on the facing page to learn how to parent your layers.
Simple rigging consists of leaving the layers in the Timeline view without doing any kind of parenting. Later on,
you will attach those layers to a master peg and organize them in the correct order.
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Related Topics
•

Rigging the Head on page 570

•

Creating a Hierarchy below

Creating a Hierarchy
Animate lets you extend your rigging techniques beyond normal boundaries and sets new standards. You can
create hierarchies without encapsulating pieces inside each other by creating a linked structure between your
layers.
You should create a hierarchy on your arms and legs and keep the arms and legs separated from the body. This
gives you more animation freedom. This way, when you need to scale or skew the torso, it will not affect the
entire body.
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To create a hierarchy in the Timeline view:

‣ Drag the child piece (hand) and drop it ON the parent piece (forearm). Then, you can drag the parent
(forearm) piece onto another parent piece (arm).

‣ See Nudging Parts Backwards and Forwards to reorder parts that should be in front of their parents.

Here is an example of a rig with a simple hierarchy:
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Related Topics
•

Masking on page 577

•

Adding the Master Peg on the next page
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Adding the Master Peg

When you animate your character, you will probably need to resize and reposition it to fit your scene. When you
need to scale down or move your character, it is a good idea to hook (attach) the whole puppet to a trajectory.
Attaching your puppet to a peg will allow you to scale it and reposition it without having to do this to your
different parts and pieces. Only one layer will contain the position information, this makes your animation easier
to modify and control.
To add a Master peg:
1. In the Timeline view, deselect any selected layers and click on the Add Peg

button located in the

Timeline Layers toolbar.
2. Name the new peg Master plus the character's name.
3. In the Timeline view, select all of the layers you want to attach to your new peg.
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4. Drag your selection ON the peg layer to parent all your character's pieces to the peg.

Related Topics
•

Pegs on page 643

Creating the Keyframes
Once all of your drawings are ordered and your master peg is added, you need to insert keyframes on each cell
to create all of the function curves and block your pose in place.
To create the keyframes:
1. In the Timeline view, collapse the master peg by clicking on the Expand

arrow.

2. In the Timeline view, select the first cell.

3. In the top menu, select Insert > Keyframe or press [F6]. You can also click on the Add Keyframe
button located in the Timeline View toolbar.

Note: If you use [F6] when working the Flash flavour keyboard shortcuts, this not only creates a
keyframe but also duplicates a drawing.
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Related Topics
•

Adding and Deleting Keyframes on page 650

Masking

When rigging a character, there will be cases where you will want to be able to move some pieces to give the
illusion of a rotation or move the pupil within the white of the eye without having the extra bit of the drawing
sticking out of the character or eyeball. To do so, you can use masks to cut anything you do not want to be
visible.
To mask an object:
1. In the Timeline view, make sure the keyframe is added on the object that will be masking the piece to cut.

2. Select the layer that will be masking the piece you want to cut.
3. In the Timeline view, right-click on the layer and select Clone Selected Layers.

4. In the Timeline Layer toolbar, click on the Add Layer button and from the drop-down menu, click on Mask.
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5. Drag the object to be masked ONTO the Mask effect layer to connect it to the effect and drag the cloned
layer ONTO the masking group layer to cut the object.

6. Your masking effect is most likely inverted and what you want to cut is probably showing. Double-click on
the Mask layer to open the Layer Properties window. In the Layer Properties window, enable the
Inverted option.

7. Using the Transform tool, you can now move the cut object within the masking zone.

Related Topics
•

Adding the Master Peg on page 575
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Adding Extra Drawings

Your break down is now complete. You can move on to adding extra drawings your character needs, such as
principal hand positions and mouth shapes. If ever you forget to add extra drawings in your main character's
template, you will easily be able to add them later.

Add your extra drawings in the layer corresponding to the part which you are drawing. You should
see the layers as containers for the different pieces. Each part of the body has its own container
where you can add more drawings of the same part.

To add extra drawings:
1. In the Timeline view, expand the master peg by clicking on the Expand
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2. In the Timeline view, select the cell where you want to add your new drawing. If you want to duplicate the
current drawing and work from it, you can select Drawing > Duplicate Drawings or press [Alt] + [Shift] +
[D].
This creates a new drawing in the selected cell, automatically extended to the next one. This new drawing
is a duplicate of the one that was selected so it contains a duplicate of the art. You can modify it to create
your new drawing or delete its contents in the Camera or Drawing view and start from scratch.
3. In the Tools toolbar, select the drawing tool you need to draw your extra part.
4. In the Camera or Drawing view, draw your new drawing.

5. Using the Select

tool, select your drawing and flatten your lines by clicking on the Flatten

located in the Tool Properties view.
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Setting the Pivots

The last step before storing the character in the library is to set the pivots for the different parts.
Animate has three types of pivots:
•

Peg Pivot
The Peg pivot is a permanent pivot that is applied to the entire drawing layer. If you modify its position, it
will be changed for the whole layer and will therefore modify the animation, scale and rotation
interpolation. the Peg pivot is set using either the Rotate, Translate or Scale tool. The Transform tool will
only move that pivot temporarily for positioning purpose, but the animation interpolation will be done
from the original Peg pivot's position.

•

Drawing Pivot
The Drawing pivot is contained within each drawing. In one layer, each drawing can have its own pivot. If
you have many different views of a character within one layer, the pivot can be different and the animation
will adjust to the pivot. The Drawing pivot can also be referred to as embedded pivot. If you are not
mixing different views within the same layers or are using pegs to animate your layers, it is recommended
to use the Peg pivot. See Drawing Pivot Tool on page 231.

•

Symbol Pivot
The Symbol pivot is similar to the Drawing pivot. Each symbol cell can have its own pivot and act the same
as the Drawing pivot. The Symbol pivot can also be referred to as embedded pivot. Inside a symbol, each
drawing can have its own pivot. If you are not mixing different views within the same layers or are using
pegs to animate your layers, it is recommended to use the Peg pivot. See Setting Different Pivots for a
Puppet Using Symbols on page 601.

For a simple character rig, it is recommended to set the Peg pivot (even on drawing layers) using the Rotate tool.
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You can set a different pivot for each one of your drawings. For example, if you have a series of
drawings from different views, they are not likely to rotate from the same location. In that case, you
can set a different pivot for these drawings by using the Drawing Pivot tool.

This topics is divided as follows:
•

Setting the Pivots Using the Rotate Tool below

•

Setting the Master Peg Pivot on page 584

Setting the Pivots Using the Rotate Tool
If you want your puppet's pieces to rotate correctly, you need to set the pivot points right in the middle of an
articulation such as an elbow or a knee.
Do the following steps for each layer in the Timeline view.
To set the pivots:
1. In the top menu, select Windows > Toolbars > Advanced Animation to display the Advanced Animation
toolbar.
2. In the Advanced Animation toolbar, select the Rotate

tool.

3. In the Camera or Timeline view, select the layer you want to set the pivot for. In the Camera view, you can
also hold down [Ctrl] (Windows) or [⌘ ] (Mac OS X) and click on the piece you want to set the pivot for.
4. In the Camera view, drag the blue pivot where you want to the pivot to be. You can also drag the pivot
marker to the desired location.
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5. Repeat the previous steps for all the pieces, including the eyes, mouth and nose.
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Setting the Master Peg Pivot

By default, your master peg pivot is placed at the centre of the Camera view, which generally equates to your
character's hips. A good way to set your peg's pivot is to move it between your character's feet.
To permanently move a peg pivot, use the Rotate

or Scale

tool. While animating, you are easily able to

temporarily move this pivot to another location with the Transform tool.
The Transform tool is designed to move the pivot temporarily during the animation process. It also permits you
to select multiple pegs and apply a common temporary pivot.
To set the peg pivot:
1. In the Advanced Animation toolbar, select the Rotate
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2. In the Timeline view, select the master peg layer.

3. In the Camera view, click on the peg pivot and move it to its new location.

If you added other pegs to your rig, you must set their pivot following the same method.
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Storing the Character in the Library
To be able to reuse your character in different scenes, you have to store a template in the Library view. You can
create different kinds of templates. You can create templates with all layers are included, a template for a body
key pose or even some containing only the head.
This topic is divided as follows:
•

Timeline Template below

•

Key Pose Template on the next page

Timeline Template
To create a template from the Timeline view:
1. In the Library view,right-click on the desired library folder and select Right To Modify.
2. In the Timeline view, collapse the master peg layer.

3. If your scene has a series of blank cells, they will also be included in the template if you drag the layer to
the Library view. Reduce the scene length to have no empty cells before creating your template.
4. In the Timeline view, select your master peg and drag it to the Library view.

The Rename dialog box opens.

5. In the Name field, name the new template.
6. Click on the OK button.
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Key Pose Template
To create a key pose template:
1. In the Library view,right-click on the desired library folder and select Right To Modify.
2. In the Timeline view, collapse the master peg layer.

3. Select the cell containing the desired view and drag it into the desired library folder.

The Rename dialog box opens.

4. In the Name field, name the new template.
5. Click on the OK button.

When you create a template from the Timeline view, for everything to work properly when you re
import it into a scene, you must first import your master template. Once the master template is
imported, you can import the key pose template's content into the right hand side of the Timeline
view.

Related Topics
•

Library on page 521
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Appendix

There are many options and animation techniques available when building a puppet, it is impossible to
determine only one method to break down a character. Here are some advanced tips on breaking down
puppets. As you become more familiar with the software, you will find more ways to improve the construction of
your puppet.

Related Topics
•

Break Down: Cutting the Character in Pieces on the next page

•

Break Down: Distribute to Layers on page 600

•

Setting Different Pivots for a Puppet Using Symbols on page 601

•

Setting Pivots on a Frame Range on page 603

588

Toon Boom Animate 3 User Guide

Break Down: Cutting the Character in Pieces

If you do not want to redraw all the artwork for your character, you can use the cut away technique where, with
the Cutter tool, you select and send pieces of the model on a new layer.
The first step in breaking down your character is to do a rough cut down of the main parts such as the body,
arms, legs and head. Use the Create Drawing from Drawing Selection feature to automatically create your layers
and copy your selection in it.
This section is divided as follows:
•

Breaking Down the Main Parts below

•

Breaking Down the Secondary Parts on page 592

•

Selecting and Incorporating to an Existing Layer

•

Breaking Down the Extra View Main Parts on page 595

•

Breaking Down Secondary Parts in the Extra Views on page 596

Breaking Down the Main Parts
To break down the main body parts, you will use the Create Drawing From Drawing Selection feature. There is
no need to create any layers prior to this process, you need to have your model well centred and sized in the
Camera view.
You do not need to make clean cuts around your parts; a rough one is quite sufficient as long as it includes all of
the artwork of the part you want to break down. You will clean the extra bits and pieces later.
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You will use the Cutter

tool to roughly cut the main sections. You can also use the Select

tool to select

precise lines and colour zones.
To break down the main parts:
1. In the Timeline view, select the model's cell that corresponds to the first view to break down.

2. In the Tools toolbar, select the Cutter
‣

tool.

If you prefer to use the Select tool, choose the Select

tool from the Tools toolbar or press [Alt] +

[S].
‣

In the Tool Properties view, you can switch to the Lasso

selection mode.

3. In the Camera view, create a selection around the first part to break down. If you click on a zone, the
Cutter tool will select the zone. It will end the selection at the first point of intersection that it meets.

‣

If you hold down [Shift], you can create a new lasso selection around another zone and add it to your
previous selection.
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4. In the top menu, select Edit > Create Drawing From Drawing Selection or press [F9].
The Create Drawing From Drawing Selection dialog box opens.

5. In the Layer Name field, type the name of the layer you want to create following the naming convention
you established previously.
6. Make sure to disable the Cut Artwork From Source option in order to keep the selected artwork on your
original drawing. You do not want to cut the artwork from your colour model.
7. Click on the OK button to complete the operation.
The new layer is created and your selection is copied in it. The drawing is created in the same frame
number as the cell it was taken from.

8. Repeat Step 1 to Step 7 for each main body part.
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Breaking Down the Secondary Parts

You should now have a layer for each main part of the character for the first view to break down. You are now
ready to break down those main pieces into smaller ones.
Breaking down the secondary parts is similar to the main part break down process except that this time you will
cut away the artwork from the layer it has been selected from.
To break down the secondary parts:
1. In the Timeline view, lock your model layer by clicking on its Lock

button.

2. In the Timeline view, select the cell that corresponds to the main part you want to break down.

3. In the Tools toolbar, select the Cutter

tool.

592

Toon Boom Animate 3 User Guide

‣

If you prefer to use the Select tool, choose the Select

tool from the Tools toolbar or press [Alt] +

[S].
4. In the Camera view, create a selection around the part to break down.

‣

If you click on a zone, the Cutter

tool will select the zone. It will end the selection at the first point

of intersection that it meets.

5. In the top menu, select Edit > Create Drawing From Drawing Selection or press [F9].
The Create Drawing From Drawing Selection dialog box opens.

6. In the Layer Name field, enter the name of the layer you want to create, following the naming convention
you established previously.
7. Enable the Cut Artwork From Source option in order to remove the selected artwork from your original
drawing. In this case, you want to cut the artwork from your colour model.
8. Click on the OK button to complete the operation.
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The new layer is created and your selection is copied in it. The drawing is created in the same frame
number as the cell it was taken from.

9. Repeat Step 2 to Step 8 for each body part.
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If you forgot to add some artwork to a layer you previously created, you can always add it later.
In the Camera view, select the artwork to send to the existing layer. Open the Create Drawing from
Drawing Selection dialog box. The [F9]. In the dialog box, select an existing layer from the dropdown list instead of typing a new name. When you click on the OK button, the artwork will be added
to the existing drawing in the layer you selected.

Selecting and Incorporating to an Existing Layer
Your first view should now be completely broken down. If your articulations are still rough and bits and pieces
are missing you will fix those in the next step.
If your character model has more than one view, now is the time to break them down.
The process is very similar to breaking down the first view. You have two choices:
•

Breaking down the new view in a net set of layers

•

Braking down the new views in the same existing layers
If your layers are not in the correct order, you can reorder them later. Simply add the part that you are
breaking down to the layer you previously created for the same body part.

Start by breaking down the main pieces, as you did before. The secondary parts will be broken down later on.

Breaking Down the Extra View Main Parts
Repeat the following steps for each extra view you have to break down.
To break down the other views:
1. In the Timeline view, selected the model's cell corresponding to the view to break down.

2. In the Tools toolbar, select the Cutter
‣

tool.

If you prefer to use the Select tool, in the Tools toolbar select the Select
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3. In the Camera view, create a selection around the first part to break down.

4. In the top menu, select Edit > Create Drawing From Drawing Selection or press [F9].
The Create Drawing From Drawing Selection dialog box opens.

5. In the Layer Name field, select the corresponding layer from the drop-down list if you want to use the
same layers or type a new name if you want to create a new layer.
6. Make sure to disable the Cut Artwork From Source option in order to keep the selected artwork on your
original drawing. You do not want to cut the artwork from your colour model.
7. Click on the OK button to complete the operation.
The artwork is inserted into the existing layer. The drawing is created in the same frame number as the
cell it was taken from. It is not incorporated in the other view's drawings.

8. Repeat Step 1 to Step 7 for each main body part.

Breaking Down Secondary Parts in the Extra Views
To break down the secondary parts for your extra views you will follow the exact same process as you did for the
first view you broke down, but you will incorporate the new parts in the already existing layers. See Breaking
Down the Secondary Parts on page 592.
This is an example of how your timeline should look at this stage:
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Completing the Parts and Articulation

Now that all of your layers are created and your parts are basically broken down, it is time to clean up your parts
and complete the articulation.
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Cleaning the Parts
You will need to use a series of drawing tools to clean the parts:
•

Brush Tool

•

Eraser Tool

•

Select Tool

•

Cutter Tool

•

Contour Editor Tool

•

Paint Tool

•

Close Gap Tool

To clean your drawings:
1. In the Tools toolbar, select the drawing tool you need to fix your drawings.

2. In the Timeline view, select the cell containing the drawing to fix.

3. In the Camera view, delete the extra bits using the Select
Eraser

tool.
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4. Draw the missing lines using the Brush
enable the Auto-Flatten

5. Using the Paint

tool. If you use the Brush tool, it is recommended that you

option in the Tool Properties view.

tool, paint the gaps. You can close some gaps with invisible lines using the Close Gap

tool. The keyboard shortcut is [Alt] + [C].

6. Reshape your lines using the Contour Editor

tool. The keyboard shortcut is [Alt] + [Q].

7. Using the Select tool, select your entire drawing and click on the Flatten
Properties view to flatten your drawings.
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8. In the top menu, select View > Show > Show Strokes to display the invisible lines that could be present
in your drawing or press [K].

9. In the top menu, select Drawing > Optimize > Remove Extra Strokes. This operation will remove any
unnecessary invisible lines in your drawing.
10. Repeat this entire process for each drawing to fix.

Related Topics
•

Drawing Using the Pencil Tool on page 130

•

Drawing with the Brush Tool on page 146

•

Erasing Parts of a Drawing on page 177

•

Drawing with Shapes on page 193

•

Cutting Drawing Parts on page 211

•

Reshaping a Drawing Using the Contour Editor Tool on page 181

•

Painting Using the Paint Tool on page 290

Break Down: Distribute to Layers
When breaking down your character, you can use the Distribute to Layers option to distribute the selected art
strokes to a new layer each.

This feature will automatically take each stroke from the drawing selection made in the Camera view
and separate them into different layers. If one of your puppet's part is composed of several strokes,
you must group them using Edit > Group > Group before using the Distribute to Layers option. This
option cannot be done in the Drawing view. It must be done from the Camera view.

To distribute to layers:
1. In the Tools toolbar, click on the Select

tool.
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2. In the Camera view, select the art strokes you want to distribute to different layers.

3. Select Drawing > Distribute to Layers. You can also click on the Distribute to Layers

button in the

Tool Properties view.
The number of drawing layers corresponding to different strokes or groups of strokes are created in the
Timeline view.

‣

The selected strokes in the original drawing layer will be removed.

‣

Each stroke or group of strokes will be distributed into each new Drawing layer.

Related Topics
•

Breaking Down the Character on page 556

Setting Different Pivots for a Puppet Using Symbols
If you want your puppet's pieces to rotate correctly, you need to set the pivot points onto the articulations. You
can either set the pivots using the Rotate tool and have it set for the whole layer or you can set the pivots directly
on your symbol and have a different pivot for each symbol cell. By default, when you create your symbols, the
symbol pivot is located at the centre of your drawing. You will need to move it onto the shoulder or elbow.
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You will set the pivot on the symbol's cells, not directly on the drawings. To set your pivots, you have to be at the
top level of your character building scene and not inside the symbols.
By default, when you set your pivot onto your symbol, all the cells use the same pivot. If you need different pivots
for your different cells, refer to the following procedure.
Do the following steps for each layer in the Timeline view.
To set the pivots for the body parts:
1. In the Tools toolbar, select the Drawing Pivot

tool. You can also select Drawing > Tools > Drawing

Pivot.
2. In the Camera or Timeline view, select the symbol you want to set the pivot for.

3. In the Tool Properties view, if you only want to set one pivot for your symbol, make sure that the Set the
Pivot for Symbol on All Frames
option is enabled.

‣

Disable this option if you want to set a series of different pivots for your symbol's cells.

4. In the Camera view, click where you want the pivot to be. You can also drag the pivot marker to the
desired location.

5. If you want to set a different pivot for another drawing or symbol cell, select the drawing or cell and in the
Camera view, set the new pivot.
Make sure that the Set the Pivot for Symbol on All Frames option is DISABLED.
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Related Topics
•

Setting Pivots on a Frame Range below

Setting Pivots on a Frame Range
If you are using the drawing pivots rather than the Rotate tool pivot and if some elements need the same
drawing pivot, such as all of the three-quarter hands, you can select all of these hands cells and set the pivot all at
once. If your pivot is already correctly set on your first drawing, copy and paste that pivot onto the other
drawings in the Timeline or Xsheet view.

You must have the same drawing pivots on the extra parts from the same angle. If you substitute a drawing while
the part is rotating, the animation risks popping out of place if the pivot is uneven.
To set the pivot on a frame range:
1. In the Timeline view, select the cell where you want to set the same pivot. The cells have to be part of the
same layer.

2. In the Camera view, click where you want to the pivot to be. You can also drag the pivot marker to the
desired location.
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To copy and paste drawing pivots:
1. In the Drawing or Camera view, set the first drawing pivot of the series. For example, set it on hand-1.
2. In the Timeline view, select the cell that contains the correct pivot.

3. In the top menu, select Edit > Copy.
4. In the Timeline view, select the cell range that requires the same pivot.

5. In the top menu, select Edit > Paste Special or press [Ctrl] + [B] (Windows) or [⌘ ] + [B] (Mac OS X).
The Paste Special dialog box opens.

6. In the Paste Special dialog box, go to the Advanced tab.
7. In the Drawings section, enable the Update Drawing Pivot option.
8. Click on the OK button.

604

Toon Boom Animate 3 User Guide

You can also copy and paste the pivot from one drawing to another using the keyboard shortcuts
[Ctrl] + [C] and [Ctrl] + [V] (Windows) or [⌘] + [C] and [⌘] + [V] (Mac OS X) when the Drawing Pivot
tool is active and the focus is around the Camera view.

Related Topics
•

Setting the Pivots on page 581

605

Chapter 12: Character Building Appendix

606

Toon Boom Animate 3 User Guide

Chapter 13: Sound

With Animate, you can import soundtracks and dialogue into your animation to make it more engaging and
entertaining.There are several sound editing features that can be used to synchronize sounds to individual
frames or moments in time. You can also use them to trim unwanted seconds from the beginning and end of your
sound files, as well as to loop sounds that you want to continue throughout your animation.
Your ability to add dialogue to animation is greatly enhanced with the Animate lip-sync tools. Animate can
analyze voice tracks to determine which of the eight animation phonemes (lip positions) would best apply to
each frame of sound. With the mouth chart that the software generates, you can easily draw lip positions for
your character. Furthermore, Animate can automatically apply drawings of lip positions to each frame of your
animation based on the mouth chart.

You can also synchronize your animation to a music score, refer to Tempo Markers on page 408 to
learn more.

Topics Covered
•

Importing a Sound File on the facing page

•

Sound Layer Properties on page 610

•

Sound Displays on page 612

•

Sound Playback on page 613

•

Sound Scrubbing on page 614

•

Editing a Sound File on page 617

•

Add Empty Sound Layer on page 626

•

Lip-sync on page 628

•

Sound Preferences on page 636
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Importing a Sound File
If you decide to add sound to your movie, you must first prepare this sound outside of Animate. When this is
done you must add a sound element in Animate to the organize sound files in your animation. Sound will play in
the movie until it reaches the end of the file or a stop frame that you have created in the Sound Element Editor.

If you first create your project in Toon Boom Storyboard Pro, the sound will be cut up into the
different scenes for you automatically.

You can import WAV, AIFF or MP3 sound files using any of the methods listed below.
To import a sound file:
1. Select File > Import > Sound
‣

Right-click anywhere in the frame zone of the Xsheet view.

‣

From the Top menu

‣

From the Xsheet View menu

‣

From the Timeline View menu

The Select Sound File dialog box opens.

2. From the Select Sound File dialog box find and select your sound file from your computer.
Your sound file appears as a layer in both the Timeline and Xsheet view.
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Related Topics
•

Sound Layer Properties on the facing page

•

Sound Displays on page 612

•

Sound Playback on page 613

•

Sound Scrubbing on page 614

•

Editing a Sound File on page 617

•

Add Empty Sound Layer on page 626

•

Lip-sync on page 628
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Sound Layer Properties
When you select a sound layer in the Timeline view, the options related to that layer appear in the Layer
Properties view.

•

Mute/Unmute

This button mutes and unmutes the sound layer during the scene play back.
•

Layer Name

This field displays the layer's name.
•

Sound Editor

This button opens the Sound editor.
•

Start Frame/End Frame

These fields determine the start and end frame of the sound file.
•

Detect

This button launches the automated lip-sync detection.
•

Map

This button opens the Map Lip-sync dialog box.
•

Mouth Shapes

This section shows the automated lip-sync detection during the scene play back. Click on the thumbnail
image of each mouth to change the phoneme assigned to the current frame.

Related Topics
•

Importing a Sound File on page 608

•

Sound Displays on page 612

•

Sound Playback on page 613

•

Sound Scrubbing on page 614
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•

Editing a Sound File on page 617

•

Add Empty Sound Layer on page 626

•

Lip-sync on page 628
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Sound Displays
Within the Xsheet view, the sound file can be displayed in different ways, depending on your sound editing
needs.
To change the sound display:
1. Right-click in the sound column or on the sound column header, choose
Sound Display > and one of the following:
‣

Sound Name: Shows the name of the sound file, as well as the file format. The line running vertically
through the column frames between the same file name indicates a continuity of the same sound file in
these frames.

‣

Mouth Shapes: Show the letter (or name depending on the way you named your character's different
mouth positions) in the column's frames. There is only one mouth position allotted per frame and this
position should correspond to the sound file after performing a lip-sync.

‣

Waveform: Shows a vertical display of the sound file's actual waveform. In the column header, in the
field under the column name, you can type in a percentage to zoom-in or zoom-out on the waveform,
or pass the scroll cursor
over the Zoom Waveform
icon.

You can show/hide the waveform in the Timeline view by pressing the Waveform button in the
Timeline View toolbar.

Related Topics
•

Lip-sync on page 628

•

Sound Preferences on page 636
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Sound Playback
Before playing back any sound, click on the Enable Sound

button in the Playback toolbar or enable it

through the Play menu in the top menu. This will make sure that you can hear the sound layers in your scene, even
the ones included within symbols.
To play back your sound sample:
1. To select a starting point:
‣

In the Xsheet view, click on a cell in the sound column.

‣

In the Timeline view, click on a cell in the sound layer. You can also slide the red playhead to the correct
cell.

2. Click on the Play

button in the Playback toolbar or in the top menu select

Play > Play Scene Forward or click on the [Enter/Return] key.
3. If you would like to hear your sound sample played back again and again, click the Loop

button in the

Playback toolbar or the Loop option from the Play menu.

Mute
If you have two or more sound layers and would like listen to them independently, you can disable the unwanted
sound by clicking on the Mute Sound
icon located on the sound name layer in the Timeline view.

Related Topics
•

Importing a Sound File on page 608

•

Sound Layer Properties on page 610

•

Sound Displays on the previous page

•

Sound Scrubbing on the facing page

•

Editing a Sound File on page 617

•

Add Empty Sound Layer on page 626

•

Lip-sync on page 628
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Sound Scrubbing
Animate uses a process known as Sound Scrubbing to let you hear sound in real-time while you move the
playback pointer forward or backward. This is very useful for finely-tuned lip-synching. You can scrub sounds
from the Timeline view.
To scrub a sound from the Timeline view:
1. In the Playback toolbar, click on the Sound Scrubbing

button or from the top menu, select

Play > Enable Sound Scrubbing. You can also activate Sound Scrubbing by right-clicking in the Timeline
view's frame bar.

2. At the top of the Timeline view, drag the red frame marker along to hear the sound at each frame. The
[Ctrl] + [Up Arrow] and [Ctrl] + [Down Arrow] (Windows) and [⌘ ] + [Up Arrow] and [⌘ ] + [Down Arrow]
(Mac OS X).

Related Topics
•

Analog Sound Scrubbing below

Analog Sound Scrubbing
Animate is set to the digital sound scrubbing mode by default. This means that all sounds are played in real time.
It also means that as you scrub over a frame you will hear the section of your sound file that is allotted to that
frame. As you are scrubbing, although it is accurate, the sound can sound clipped. It can also be difficult to hear
nuances in pitch and tone.
Animate has an analog sound scrubbing option. When sound scrubbing in this mode, the sound is played back
according to the speed that the playhead or jog is manually adjusted. Animate's interface offers shuttle and jog
sliders to perform analog sound scrubbing, however, external hardware and their corresponding software can
be used in conjunction with Animate for improved analog sound scrubbing results.
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Please refer to the device's manual to configure its functionality with Animate.

Performing an Analog Sound Scrub in Animate
Before you can perform an analog sound scrub in Animate, you have to learn about the Shuttle and Jog.

•

Shuttle: Pull the Shuttle backward or forward to make the red playhead, in the Timeline view, jump by
large increments in the direction you are moving the shuttle.

•

Jog: Click and drag along the Jog to make the "dial" rotate. The Jog controls finer incremental
movements along the soundwave. Use the Frame field to see the frame number which you are on. As you
rotate the dial, your speed in fps appears directly after the FPS field.

To perform an analog sound scrub:
1. In the Playback toolbar, click on the Sound Scrubbing

button or from the top menu, select Play >

Enable Sound Scrubbing. You can also activate Sound Scrubbing by right-clicking in the Timeline view's
frame bar.
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2. In the top menu, go to Edit > Preferences (Windows) or Animate> Preferences (Mac OS X).
3. In the Sound tab enable the Analog Sound Scrubbing option.
4. Click on the OK button.
5. In the Playback toolbar, use the Shuttle to find the general location of where you would like to start your
sound scrub, or in the Timeline view, drag the red playhead to the desired location.
6. In the Playback toolbar, use the Jog to fine tune your scrub to just a few frames.

Related Topics
•

Sound Scrubbing on page 614
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Editing a Sound File
Now that you have successfully imported your sound file into Animate, it is time to familiarize yourself with the
sound editing interface. The Sound Element editor makes it possible to edit sounds that were created outside of
Animate and imported into your scene.
To open the Sound Element editor:
1. Either double-click the sound layer name in the Timeline view or the sound column header in the Xsheet
view.
The Sound Element Editor dialog box opens.

The Sound Element editor consists of three main parts.
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1. Sound Element - The wave form seen in the top Sound Element window is the actual sample that will
be heard when the final movie is rendered. It may be shorter than the original sound sample due to length
of the scene. If any edits are made to the sound sample, they can be heard here.
In the Sound Element panel you will see some coloured tabs, these tabs represent the frames. The frame
number is shown inside the tab flag marker. Note that these tabs indicate the start and end frames of a
sound segment.
2. Current Sound - The Current Sound window displays the original sound file in its entirety and is where
you can edit its properties. This window remains empty until you click inside the Sound Element window.
3. Lip-sync Preview - Is used to preview the automated detection and to manually insert different mouth
positions to correspond with the sound sample.
You can accomplish the following in the Sound Element editor:
•

Changing the Start or End Frame of a Sound on the next page

•

Trimming the Start and End of a Sound File on page 621

•

Looping a Sound on page 622

•

Mixing the Sound Volume on page 623

•

Customizing the Playback Range on page 624

•

Recomputing the Mouth Chart on page 634

Related Topics
•

Lip-sync on page 628
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Changing the Start or End Frame of a Sound
To synchronize the sound with specific images in your scene, you must set a start frame for your sound. To make
sure the sound ends by a certain frame, you must set an end frame.

In the Sound Element panel you will see some coloured tabs, these tabs represent the frames. The
frame number is shown inside the tab flag marker. These tabs indicate the start and end frames of a
sound segment.

To change start or end frame of a sound:
1. Either double-click the sound layer name in the Timeline view or the sound column header in the Xsheet
view to open the Sound Element editor.
2. Select the sound sample you want from the Sound Element panel. To distinguish one sound section from
another on the same sound layer, check the frame numbers that appear on tabs flanking the start and
stop lines of each waveform section.

Click on the Play

button in the Current Sound panel (only the selected sound plays).

3. Within the Sound Element panel, click and drag the selected clip to the frame number where you want it
to start playing.
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You can only move the clip to a section that does not already contain a clip; you cannot overlap two clips in the
same element.
4. To change the end frame, drag the yellow marker at the end of the waveform to the frame position.

5. To hear how all of the clips fit together in the element, click on the Play

button in the Sound Element

panel.

If you only want to hear the selected clip, click on the Play

button in the Current Sound panel.

6. Click Apply/Next when done.
The Xsheet and Timeline views display the sound clip at the start frame you selected.

Related Topics
•

Trimming the Start and End of a Sound File on the next page
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•

Looping a Sound on the facing page

•

Mixing the Sound Volume on page 623

•

Customizing the Playback Range on page 624

Trimming the Start and End of a Sound File
To play only a section of a sound file, use the Sound Element Editor to select the exact part you want to use. For
example, if there is a bit of noise at the start of the sound, use the Sound Element Editor to cut the noise.
The Sound Element Editor does not change the original sound file; it only plays a section of it, ignoring the rest.
This means that the entire sound file is included on export. If you need to be mindful of file size, it is better to edit
sound files completely in a sound editor before bringing them into Animate.
To trim the start and end of a sound file:
1. Either double-click the sound layer name in the Timeline view or the sound column header in the Xsheet
view to open the Sound Element editor.
2. Select the sound you want to work on from the Sound Element panel.
3. Select the sound sample you want from the Sound Element panel. To distinguish one sound section from
another on the same sound layer, check the frame numbers that appear on tabs flanking the start and
stop lines of each waveform section. Or select a soundwave and click on the Play
button in the
Current Sound panel (only the selected sound will play).
4. Using the Current Sound panel, you can decide which part of the file you want to play by dragging the left
and right boundaries of the selection area.

5. Click on the Play

button in the Current Sound panel to check that you have trimmed the desired

sections. Use the Zoom slider at the bottom of the panel to zoom in on the wave form so that you can
trim it more accurately.

6. Click on the Apply/Next button.
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The trimmed sound sample should now appear in both the Timeline and Xsheet views at the start and end
positions that you selected.

Related Topics
•

Changing the Start or End Frame of a Sound on page 619

•

Looping a Sound below

•

Mixing the Sound Volume on the next page

•

Customizing the Playback Range on page 624

Looping a Sound
To repeat a sound, specify the number of times that you want it to loop in the Sound Element editor.
To loop a sound sample:
1. Either double-click the sound layer name in the Timeline view or the sound column header in the Xsheet
view to open the Sound Element editor.
2. From the Sound Element panel, select the sound section that you want to loop.
3. In the Current Sound panel, type the number of times you want the sound to play in the Number of Loops
field.

4. Press on the [Enter/Return] key. The looped sound appears after the current sound. They are indicated by
their grey waveforms, as opposed to black.
When you loop a sound, the looped sections fill the cells in the sound element (column or layer) until the next
sound sample starts or until the scene ends. This means that the looping could effectively get cut if the next
sound sample starts too soon, or if the scene ends too quickly.

Related Topics
•

Changing the Start or End Frame of a Sound on page 619

•

Trimming the Start and End of a Sound File on the previous page

•

Mixing the Sound Volume on the next page

•

Customizing the Playback Range on page 624

622

Toon Boom Animate 3 User Guide

Mixing the Sound Volume
You can adjust the volume of an entire sound clip or modify the volume in increments by adjusting the fade-in and
fade-out times, otherwise known as sound envelopes. The fade edit only affects the play back; the original sound
file is not affected.
To adjust the overall volume of the entire sound clip:
1.

Either double-click the sound layer name in the Timeline view or the sound column header in the Xsheet view to
open the Sound Element editor.

2. In the Sound Element panel, select the sound that you want to work on. A more detailed version of the
selected sound appears in the Current Sound panel.
3. In the Current Sound panel, use the Volume slider to adjust the volume.

4. Click on the Play

button in the Current Sound panel to verify the volume.

To create the fade in/out effect on a sound clip:
1. Either double-click the sound layer name in the Timeline view or the sound column header in the Xsheet
view to open the Sound Element editor.
2. In the Sound Element panel, select the sound you want to work on.
3. In the Current Sound panel, click on the thin blue line above waveform to add an envelope marker.

4. Drag the envelope markers to adjust the volume at that frame and to create the time of the transition.
The line from the edge of the clip to the envelope marker identifies how the volume either increases
(fades-in) or decreases (fades-out) over time.
Dragging the marker to the bottom of the channel will mute the volume, while dragging it upwards will
increase the volume.

To create an even effect, be sure to adjust the envelope markers uniformly in both the left and right
(bottom and top) channels.
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5. Click on the Play

button in the Current Sound panel to check the fade envelopes.

Related Topics
•

Changing the Start or End Frame of a Sound on page 619

•

Trimming the Start and End of a Sound File on page 621

•

Looping a Sound on page 622

•

Customizing the Playback Range below

Customizing the Playback Range
To hear a specific section of the sound element, adjust the playback range in the Sound Element Editor to start
or stop at specific frames. This customized playback range does not affect the actual sound in the Sound
element.
To change the playback range in the Sound Element Editor dialog box:
1. Drag the start or end range markers in the Sound Element panel to the boundary frames you want.

2. When you click on the Play

button to play back your sound in the Sound Element editor, it only plays

the sound which exists between the two markers.
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Related Topics
•

Changing the Start or End Frame of a Sound on page 619

•

Trimming the Start and End of a Sound File on page 621

•

Looping a Sound on page 622

•

Mixing the Sound Volume on page 623
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Add Empty Sound Layer
When performing sound editing tasks, it can be useful to chop up a sound sample into different layers. For
example, when performing a lip-sync, only a single view of the various mouth positions for a character can exist
on one layer. Therefore, if you would like to have your character turn its head from a profile view to a threequarter view and have mouth position changes to fit with the sound sample from these two different views, you
would need to cut-up the sound samples needed for the profile view mouth positions on one layer and the sound
samples needed for the three-quarter view on another.
For this task, you will need an empty sound layer.
To add an empty sound layer:
1. In the top menu, select Windows > Toolbars > Timeline View.
The Timeline view toolbar appears at the top of the Timeline view.

2. Right-click on the Timeline View toolbar and choose Customize.
3. Choose the Add Sound

button from the Available Tools column on the left and add it to the Toolbar

column on the right. Click Ok to accept the change.

4. Click on the Add Sound

button.

An empty (silent) sound layer should appear in both your Timeline and Xsheetviews.

5. Rename your layers accordingly.
6. Click the cell where you wish to start the cut and [Shift] + click on the final cell of the cut. The sample to be
cut becomes highlighted.
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7. Drag the selection into the empty sound layer below.

8. You can now continue to cut-up and distribute the sound sample between the two layers or carry on to
the lip-synching process for each layer and its corresponding facial view.

If you need to duplicate your sound layer to keep an unedited copy for safety, you can click on the
Duplicate Selected Layers button, located in the Timeline View toolbar.

Related Topics
•

Importing a Sound File on page 608

•

Sound Layer Properties on page 610

•

Sound Displays on page 612

•

Sound Playback on page 613

•

Sound Scrubbing on page 614

•

Editing a Sound File on page 617

•

Lip-sync on the facing page
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Lip-sync

Adding a lip-sync to a project can really enhance its quality and storytelling. However, it can be difficult to shape a
character's mouth so that it matches the sound at the precise frame.

To solve this problem Animate provides a lip-sync feature which analyzes the contents of a sound element and
generates a mouth chart (see below) based on the eight animation phonemes (A, B, C, D, E, F, G, and X, which is
used to represent silence).
The mouth shapes used by Animate are based on the conventional mouth chart used in the animation industry.

The letters used to represent the shapes do NOT correspond to an actual sound.

If you are doing cut-out animation, refer to Adding Extra Drawings on page 579 to learn how to add
extra drawings to your character.

628

Toon Boom Animate 3 User Guide

Here is an approximation of which sound each mouth shape can produce:
•

A: m, b, p, h

•

B: s, d, j, i, k, t

•

C: e, a

•

D: A, E

•

E: o

•

F: u, oo

•

G: f, ph

•

X: Silence, undetermined sound

You can lip-sync the traditional way or let the system automatically create the basic detection.
You can refer to the mouth chart positions as you draw the shape of your character's mouth.

Related Topics
•

Generating a Lip-sync Detection on the facing page

•

Mapping the Lip-Sync Detection on page 631
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•

Modifying the Lip-sync Detection on page 633

•

Manual Lip-sync on page 635

Generating a Lip-sync Detection
There are three places where you can perform a lip-sync detection:
•

Timeline and Xsheet Views below

•

Generating a Lip-sync Detection above

•

Layer Properties View on the next page

Timeline and Xsheet Views
To generate a sound detection for your lip-sync using the Xsheet or Timeline view:
1. To show the mouth chart letters, if they are not already present in the Xsheet view,right-click on the sound
column and select Lip-Sync > Sound Display > Mouth Shapes from the pop-up menu.
2. In the Xsheet view or Timeline view, right-click on the sound layer's cells and select Lip-Sync > Auto LipSync Detection from the pop-up menu. You can also select Animation > Lip-Sync > Auto Lip-Sync
Detection from the top menu.

Animate analyzes the selected sound clips and assigns a lip-sync letter to each frame. The X markers in the
frame are replaced by these designated letters.

Sound Element Editor
To generate a sound detection for your lip-sync using the Sound Element Editor:
1. Either double-click the sound layer name in the Timeline view or the sound column header in the Xsheet
view to open the Sound Element editor.
2. In Sound Element panel, select the waveform you want to generate the mouth chart for.
3. Right-click on the sound file and select Auto Lip-Sync Detection from the pop-up menu.

A progress bar appears while Animate analyzes the selected sound clips and assigns a lip-sync letter to
each sound cell.
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Layer Properties View
To generate a sound detection for your lip-sync using the Layer Properties view:
1. In the Timeline or Xsheet view, select your sound layer.
2. In the Layer Properties, click on the Detect button.

A progress bar appears while Animate analyzes the selected sound clips and assigns a lip-sync letter to
each sound cell.

Related Topics
•

Manual Lip-sync on page 635

•

Mapping the Lip-Sync Detection below

•

Modifying the Lip-sync Detection on page 633

Mapping the Lip-Sync Detection
Animate can automatically map drawings in an element to the mouth chart you have generated for a sound. This
can save time when you are lip-synching a voice track.
In the Lip-Sync Mapping dialog box, you can identify each lip drawing of a character. Animate then automatically
labels all of the cells in the character's element with the appropriate name.
To automatically map lip-sync drawings to a mouth layer:
1. To open the Lip-Sync Mapping dialog box:
‣

In the Timeline view,right-click on any cell in the sound sample layer. From the pop-up menu, select LipSync > Map Lip-Sync. You can also select Animation > Lip-Sync > Map Lip-Sync from the top menu.
OR

‣

In the Timeline view, select your sound layer and in the Layer Properties view, click on the Map button.
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The Lip-Sync Mapping dialog box opens.

2. From the Destination Layer drop-down list, select the layer that contains the mouth positions for the
character's voice track.

3. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on the
layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to
use the drawings or select the desired symbol from the drop-down menu.
4. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the phoneme
it represents. If your drawings are already named with the phoneme letters, you do not have to do
anything.
5. Click on the OK button.
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6. Press the Play

button in the Playback toolbar to see and hear the results in the Camera view. To play

back your scene with sound, enable the Sound

button in the Playback toolbar.

Related Topics
•

Generating a Lip-sync Detection on page 630

•

Manual Lip-sync on page 635

•

Modifying the Lip-sync Detection below

Modifying the Lip-sync Detection
You can change the mouth position that has been assigned to a frame if you think that another position would be
more appropriate.
For example, you may have a character who says nothing for ten frames, in between two speeches. Animate
would normally assign an X image for the silence period. However, if you want your character's mouth to hang
open in astonishment for these ten frames, you can change the lip assignment for these frames from an X to an F.
To change the lip assignment of a sound in the Xsheet:
1. Right-click in the cell that contains the mouth position that you want to change.
2. From the pop-up menu, select Lip-Sync > Change Mouth Shape to and choose the letter that reflects
the mouth position that you want to use for that sound. You can also select Animation > Lip-Sync > LipSync > the desired mouth shape from the top menu.
The drawing will automatically be updated in the Camera view.
You can also change the mouth assignment of a sound in the Sound Element editor.
To change the mouth position assignment of a sound from the Sound Element editor:
1. Either double-click the sound layer name in the Timeline view or the sound column header in the Xsheet
View to open the Sound Element editor.
2. In the Sound Element panel, drag the frame slider to the frame you want to change the mouth position
assignment on.
In the Lip-sync image area, the image on top represents the lip position assigned to the current frame.
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3. To change the image assigned to the frame, click on the image of the mouth position you want from
below the preview image. The preview image changes to the mouth position image you select. You can
perform the same operation in the Layer Properties view.

The position will also be updated in the Timeline and Xsheet views.

Note that if you modify the lip-sync detection you must remap the detection to your mouth latyer.
See Mapping the Lip-Sync Detection

Related Topics
•

Recomputing the Mouth Chart below

Recomputing the Mouth Chart
When you generate the mouth chart for a sound in a sound element, you can either accept the mouth positions
assigned by Animate or assign your own lip-sync images.
However, if you change the sound's start frame or reassign its mouth position, you must reanalyze the sound
and regenerate the mouth chart for it. This erases any manual modifications you may have made to the mouth
assignments in the mouth chart.
To recompute the mouth chart for a selected sound from the Sound column:
1. In a Sound column in the Xsheet or Timeline view,right-click on a cell that contains the sound file you want
to recompute the lip-sync for. Select Lip-Sync > Auto Lip-Sync Detection from the pop-up menu. The
mouth position assignment for each frame is recomputed, erasing any modifications you have made.
To recompute the mouth chart for a selected sound from the Sound Element Editor:
1. Either double-click the sound layer name in the Timeline view or the sound column header in the Xsheet
view to open the Sound Element editor.
2. Click on the waveform in the Sound Element section in the Sound Element editor.
3. Right-click and select Auto-Lip Sync Detection from the pop-up menu.

Related Topics
•

Generating a Lip-sync Detection on page 630
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Manual Lip-sync
Animate allows for the manual swapping of mouth position drawings to match a voice track. For this process,
both sound scrubbing (listening to a soundwave broken up frame-by-frame) and drawing substitutions from the
Library View are used.
To perform a manual lip-sync:
1. In the Playback toolbar, enable the Sound Scrubbing

button.

2. In the Timeline view, drag the red position indicator along the sound layer waveform.
3. When you reach a frame where a mouth position should go, for example, an open mouth with rounded
lips for an "oh" sound, click on that frame on your mouth shapes layer.
4. In the Timeline view, click on the Expand

button to display the Data view.

5. Staying on your mouth shapes layer, place your cursor on top of the drawing name (often a letter) until it
changes to the swapping
pointer.
6. Pull the cursor to see the list of mouth shape names and choose the one you want. The current drawing
automatically changes to the new selection.

You can also use the Library view to swap drawings.
To perform a manual lip-sync using the Library view:
1. In the Playback toolbar, enable the Sound Scrubbing

button.

2. In the Timeline view, drag the red playhead along the waveform of your sound layer.
3. When you reach a frame where a mouth position should go, for example, an open mouth with rounded
lips for an "oh" sound, click on that frame on your mouth shapes layer.
4. In the Drawing Substitution window of the Library view, click and drag the slider to choose a mouth
shape. The current drawing is swapped for the one in the preview window.

Related Topics
•

Preview and Drawing Substitution on page 524

•

Sound Scrubbing on page 614
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Sound Preferences
When working with sound in Animate, you can set some preferences to help you work more efficiently.

Timeline Tab

Show Sound Waveform
Enable this option if you would like to see your imported sound's waveform in the Timeline view.

You can always toggle the visibility of the waveform in the Timeline view by adding the Show Sound
Waveform button from the Toolbar Manager. This button will work whether you have the Show
Sound Waveform option enabled or disabled in the Preferences panel.

Sound Tab

Analog Sound Scrubbing
Enable this option to switch from digital to analog sound scrubbing.

Analog Jog Speed
Choose a value between 1-20 for the Analog Jog Speed. The greater the jog speed value, the slower you can
scrub to have the sound play at an average pace. This controls how sensitive you would like the jog slider or dial
to be.

Analog Jog Dampening
Choose a value between 1-100 for the Analog Jog Dampening. The greater the value, the less precise the
software is at responding to the jog's changes in speed. However, he greater the value, the more smooth the
play back is using the job slider or dial.
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Movement is the essence of creating an animation; it is essentially what animation is: bringing drawings to life.
Sometimes this movement comes from the characters or objects themselves, while other times, it is the camera
moving through elements set-up on the camera "stage". Often these movements can be complex, such as a
helicopter moving across the screen with its rotor blades rotating, as the helicopter disappears into the
distance, it appears to get smaller in size as it recedes in space. Although this seems like a simple motion, you
must coordinate three movements to produce the correct effect.
The sophisticated systems integrated in Toon Boom Animate have been specifically developed to accommodate
the your complex motion needs.

Topics Covered
•

Animating a Layer on page 639

•

Differences between Pegs and Animated Layers on page 642

•

Adding and Deleting Keyframes on page 650

•

Stop-motion and Motion Keyframes on page 653

•

Animating the Camera on page 658

•

Modifying a Path in the Camera View on page 662

•

Modifying a Path in the Timeline View on page 672

•

Modifying a Path in the Function View on page 676

•

Modifying a Path in the Xsheet View on page 681

•

Function Curves on page 683

•

Copying and Pasting a Motion on page 692

•

Adjusting the Ease on page 701

•

Expression Columns on page 1
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•

Animation Path Preferences on page 708
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Animating a Layer
This section describes the basics of animating a layer. Animate's wide range of features let you produce accurate
trajectories. However, before reaching this level you must learn how to create a simple motion and practice
everything you learn in this chapter.
In this topic, you will find out about the two key elements in creating a motion:
•

Animate Mode below

•

Animating a Layer below

•

Enabling the Playback on page 641

Animate Mode
If you enable this mode when you animate layers, Animate will apply a transformation to the current frame. If you
don't, it will apply a transformation on the entire layer instead of only the current frame.
To enable the Animate Mode:

‣ In the Tools toolbar, click the Animate Mode

button.

The Animate Mode button is highlighted.

Animating a Layer
Follow these simple steps to perform a basic layer animation.
To animate a layer:
1. In the Tools toolbar, select the Transform
‣

tool or press [Shift] + [T].

In the Tool Properties view, make sure the Peg Selection Mode

button is disabled so you can

select your drawing layer directly and not the pegs. Refer to the section to learn more about this
option.
2. In the Tools toolbar, enable the Animate

mode .

3. In the Timeline view, go to the first frame.

4. In the Camera view, select the element to animate and move it to its first position.
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5. In the Timeline view, go to the frame where you would like to set the second position.

6. In the Camera view, move the selected element to its new position.

Refer to Displaying a Path in the Camera View on page 662 to learn how to display the trajectory.

7. In the Playback toolbar, click the Play

button to view your work.
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Enabling the Playback
To see your motion animations in the Top, Side or Perspective views while you play back, you must enable the
Playback option.
To enable the Playback option:
1. In the top menu, select Play > Enable Playback > Top View, Side View or Perspective View.

Related Topics
•

Stop-motion and Motion Keyframes on page 653
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Differences between Pegs and Animated
Layers

To animate the position of your drawings you need to create motion paths. Motion paths are trajectories on
which you can hook your drawing objects to. You will use keyframes to record the key positions along this
trajectory.
There are two ways in which to create motion paths:
•

Animated Layers below

•

Pegs on the next page

Animated drawing layers and pegs have different purposes which you will discover in the following topics.

Animated Layers
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You can create a motion path directly on your layers.
Drawing layers can house drawings and symbols. Also, in that same layer you can create a motion path using
keyframes and all the artwork contained in the layer will follow.

You can control and define your trajectory using several different parameters. These parameters are:
•

X, Y and Z positions

•

Angle (rotation)

•

Skew

•

X and Y scales

Each parameter has its own function curve where you can add keyframes and control the easing.
Do not worry about using graphs and function curves if you are not familiar with this concept. Animate has a
series of easy-to-use tools for visually controlling your trajectories in the Camera view.
To animate a simple object such as an arrow in flight or a wheel spinning, you can use the integrated trajectory.
Also, each part of a cut-out puppet will be animated directly on the drawing layer.

Related Topics
•

Pegs below

•

Layer Parameters on page 645

Pegs
A Peg layer is a trajectory that contains no drawings on which you can hook your drawings.

Related Topics
•

Why Use a Peg Layer? below

•

The Origins of the Peg on the facing page

•

Adding a Peg to the Timeline View on page 645

•

Pegs above

Why Use a Peg Layer?
A peg is composed of many customizable parameters including:
•

X, Y and Z positions

•

Angle (rotation)
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•

Skew

•

X and Y scales

•

3D Rotation (when the 3D option is enabled)

You can control a peg's trajectory the same way as the animated drawing layer.
Peg layers are mainly used to control a series of drawing layers together. If you have several drawing layers such
as clouds or a character split into many parts, you can hook those to a peg layer and have them follow a
trajectory as one unit. When building a puppet, most of the time you will add a master peg to control your
puppet as one object.

The Origins of the Peg

Pegs have been used for a long time in the traditional animation process, mainly for registration purposes. Peg
holes at the bottom (or top) of animation paper are used to keep all of the sheets even and at the same
registration.
There are three peg holes in regular animation paper. The centre peg hole is circular while the left and right ones
are rectangular. These rectangular peg holes are situated, one on each side and four inches away from the centre
peg hole.
To keep the drawings together, the animator uses a peg bar. This peg bar has three pins corresponding to the
shape and location of the peg holes. Peg bars are normally found at the bottom and top of animation discs.
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Before digital compositing, the peg bars were also used to move levels under the camera stand. They were the
equivalent of digital trajectories. Animate makes use of these concepts to create animation and camera moves.

Adding a Peg to the Timeline View
To add a peg:
1. Select the layer on which you want to attach to the peg.

2. Add the peg by doing one of the following:
‣

From the Timeline View layers' toolbar, click the Add Peg

‣

From the top menu, select Insert > Peg.

‣

Right-click on the layer and select Add > Peg.

button.

The layer that was originally selected becomes a child of the new parent peg layer.
The new peg layer automatically takes the name of its child layer, with the addition of the suffix -P.
The indentation of the layer, along with the L-shaped line indicates hierarchy and that the layer is attached
to the Peg layer. Their relationship is known as parent-child.

If you intend adding multiple pegs, or if the layer name that was added to the peg does not accurately represent
the content of the peg layer, you can rename it. You can do this by clicking on the layer name and typing in the
editable field, or double-clicking on the layer and entering the new name into the dialog box.

If you did not create your peg layer directly above the layer you intended on parenting it to, then click and drag
the layer you want to attach to the peg and drop it directly below the peg layer. The indentation of the layer
below the Peg layer will be an indication of whether it was correctly attached or not.

Related Topics
•

Layer Parameters below

Layer Parameters
A layer is composed of many customizable parameters, such as the X, Y and Z positions, angle (rotation), skew
and scales. Each parameter has its own function. A function is a mathematical formula expressing a relation
between position values. You can view each function on a graph as a simple curve such as this one.
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Learn more:
•

3D Path on the next page

•

Separate Positions on page 648

•

Locked Scales and Separated Scales on page 648

•

Setting the Parameters on page 648

To display the Layer parameters in the Timeline View:
‣

In the Timeline's left-hand side, click on the Expand Function

button or press [Alt] + [F].

OR

‣

Select the layer whose functions you want to display, go to the Timeline View menu and select View >
Show Functions.

There are six options available for setting up the function parameters:
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•

Locked Positions (3D Path)

•

Separate Positions

•

Locked Scales

•

Separate Scales

•

Quaternion (3D Rotation)

•

Euler Angles (3D Rotation)

You can set the preferences to suit your way of working. In your general preferences, enable Default
Separate Positions to get separate X, Y and Z positions, or disable it to get a 3D path. The 3D path is
set by default.
Enable the Default Separate Scale to get separate X and Y scales. It is highly recommended that you
use default separate scales.

You must lock or unlock your functions before starting the animation. When you lock or unlock
parameters, this does not convert the functions from one to the other, but creates new ones.

3D Path
In a 3D Path, the X, Y and Z curves are locked together and controlled by a single velocity function. When you
add a keyframe, it is added on all three trajectories at once, as is the velocity. This is very useful for long, smooth
trajectories.
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Separate Positions
When the Separate Positions option is used, the X, Y and Z curves are independent and have velocity controls
directly on their function curve. This is useful when you want to set keyframes on one of the curves without
affecting the others.

Locked Scales and Separated Scales
When using the scale function, you can have a single function curve controlling both the vertical and horizontal
scale, or have the two scales separate. This means that when using the single function, the values will be the
same for the X (horizontal) and the Y (vertical) axes, enabling a uniform size change without distortion. However,
if you separate the scale functions, you will be able to squash, stretch and skew your elements.

Setting the Parameters
This topic will cover the 2D motion parameters.
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To set the parameters:
1. In the Timeline view, double-click the layer on which you want to set the parameter.
The Layer Properties editor opens.

2. Select the Transformation tab.
3. In the Position section, select the 3D Path or Separate option.
4. In the Scale section, select the Locked or Separate option.
5. Click Close.

Related Topics
•

3D Parameters

•

3D Space
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Adding and Deleting Keyframes
You can create a keyframe in several different ways. You can add a coordinate keyframe, position keyframe or a
keyframe along with your drawing duplication.

Related Topics
•

Coordinate Keyframe below

•

Add Keyframe and Duplicate Drawing below

•

Position Keyframe on the next page

•

Delete Keyframe on the next page

Coordinate Keyframe
To create keyframes:
1. In the Timeline view, select the cell where you want to add a keyframe.

2. Do one of the following:
‣

In the top menu, select Insert > Keyframe.

‣

Right-click on the selection and select Add Keyframe.

‣

Click the Add Keyframe

‣

In the Camera view, if the Animate mode is enabled, as soon as you move the selected element, a
keyframe will be automatically created on the current frame.

button in the Timeline View toolbar.

Add Keyframe and Duplicate Drawing
The method described previously only creates a keyframe without a drawing. It adds a new coordinate points
but the drawing in the layer stays the same. You may want to duplicate your drawing at the same time if you
need to modify it and do not want to modify the original one. In this case, you can use the Add Keyframe and
Duplicate Drawing function.
To create a keyframe and duplicate your drawing at once:
1. In the Timeline view, select the cell containing the drawing where you want to add a keyframe and
duplicate.

2. Here are the different ways to add a keyframe and duplicate:
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‣

In the top menu, select Insert > Keyframe and Duplicate Drawing.

‣

Right-click on the selection and select Insert Keyframe and Duplicate Drawing.

Position Keyframe
You can also add a Position keyframe instead of a regular keyframe. When you add a Position keyframe,
keyframes will only be added on the X, Y and Z parameters of the selected layer. Keyframes are not added on the
Angle, Scale and Skew parameters.
To add a Position keyframe:
1. In the Timeline view, select the cell where you want to add a position keyframe.

2. In the top menu, select Insert > Position Keyframe.
‣

If you select a keyframe in the Timeline view and press the [Delete] key, you will also delete the drawing
exposure. To only delete the keyframe, you must use the Delete Keyframe command.

Delete Keyframe
To delete a keyframe:

‣ With the Transform

tool selected, choose the keyframe to be deleted from the trajectory in the

Camera view and press the [Delete] key.

OR

‣ In the Timeline view, click on the keyframe to be deleted, right-click and select Delete Keyframes or
press [F7]. You can also select Animation > Delete Keyframe from the top menu.
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Related Topics
•

Modifying a Path in the Camera View on page 662

•

Modifying a Path in the Timeline View on page 672

•

Modifying a Path in the Function View on page 676
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Stop-motion and Motion Keyframes
Interpolation is the computer-generated motion between two keyframes. Some animators and compositors
create their own in-betweens, others have the computer do it. Animate gives you stop-motion and motion
keyframes.
•

Stop-motion Keyframes below

•

Motion Keyframes below

Stop-motion Keyframes
A stop-motion keyframe means that there is no computer-generated motion between two keyframes. The
segment is constant or flat.

Motion Keyframes
A motion keyframe means that there is computer-generated motion between two keyframes. The segment has a
variation over time.
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Related Topics
•

Toggling between Motion and Stop-motion Keyframes below

•

Constant Z on page 657

Toggling between Motion and Stop-motion
Keyframes
You can switch a keyframe between stop-motion and motion at any time in the Timeline view and Function
Editor.
To toggle between motion and stop-motion in Timeline view:
1. On the right side of the Timeline view, select one or more keyframes to be modified.

2. To toggle between motion and stop-motion:
‣

Right-click on the selected keyframes and select Set Motion Keyframes or Set Stop-Motion
Keyframes.

‣

Press [Ctrl] + [L] and [Ctrl] + [K] (Windows) or [⌘ ] + [L] and [⌘ ] + [K] (Mac OS X).

‣

In the Timeline View toolbar, click the Motion Keyframe

and Stop-Motion Keyframe

buttons.
‣

In the Camera view, select the keyframe to convert. In the Coordinates and Control Point view,
select/deselect the Stop-Motion Keyframe option.

-
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To toggle between motion and stop-motion keyframes in the Function Editor:
1. Open the Function Editor:
‣

In the Timeline view, double-click on the layer that contains the keyframes you want to convert.

The Layer Properties dialog box opens.

In the Transformation tab, click the Function Editor

button to display the Editor window.

OR

‣

In the Timeline view, click the Expand Function

button and double-click on the function to edit.

You can also press [Alt] + [F].
2. Select one or more keyframes to be modified on the function curve.

3. Select/deselect the Stop-Motion Keyframe option to set a stop-motion or motion keyframe.
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Setting a Different Colour for Stop-motion and Motion Keyframes
In the Preferences dialog box, you can set a different colour for your stop-motion keyframes in order to create a
greater visual difference in the Timeline view.

To set the stop-motion keyframe colour:
1. Open the Preferences dialog box by pressing [Ctrl] + [U] (Windows) or [⌘ ] + [U] (Mac OS X).
2. In the General tab, in the Colours section, click on the Edit Colours section.
3. In the Colours window, select the Exposure Sheet tab.
4. In the Others section, click the Stop Motion Keyframe swatch.
5. In the Select Colour window, select a new colour.
6. Click OK to close the Select Colour window.
7. Click OK to close the Colours window.
8. Click OK to close the Preferences dialog box.

Related Topics
•

Stop-motion and Motion Keyframes on page 653

•

Constant Z on the next page
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Constant Z
The Constant Z is used when creating motion keyframes. The Z function will use stop-motion keyframes and will
not be interpolated, this can be very useful for cut-out animation. The Constant Z feature only works with
3Dpaths.
You can also enable the Constant Z option directly in the Function Editor or Function view for specific functions.
To enable the Constant Z option:
1. In the Timeline view, expand the function of the layer you want to set to Constant Z. Note that the 3D
Path option must be enabled for that particular layer.
2. Double-click on the Position function to open the Function Editor.
3. In the Function Editor window, select the Constant Z option.

Related Topics
•

Toggling between Motion and Stop-motion Keyframes on page 654

•

Stop-motion and Motion Keyframes on page 653
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Animating the Camera
Just as in a live-action film, scenes are not only composed of characters moving around in a static camera field,
but also of camera movements. Although it is not always something that we think about, often it is the exact
opposite—the character is static while the camera moves through elements on the stage. Camera pans, jumps,
cuts and zooms are as important to storytelling as the story itself.
Animate has a camera that can move along the X, Y, and Z axes. Having the camera move on the Z-axis offers the
possibility to create truck in and truck out, as well as multiplane camera moves. The default camera position is
centred and backed up to 12 fields.

Related Topics
•

Basic Camera Move below

Basic Camera Move
The camera is treated the same way as any other element. The same tools and selection modes are used to
offset or animate it. To animate the camera, you need to connect it to a peg element.

This means that you can animate the camera visually, with the function curve, or by typing values in the Xsheet
column.
To add a camera with a peg to your scene:
1. If you do not already have a camera layer, add one in one of two ways:
‣

From the top menu, select Insert > Camera

‣

From the Timeline View Layers toolbar, click the Add Layers

‣

From the Library view, select a Camera module and drag it to the Network view.

button and select Camera.

A new camera layer is added to your scene and appears in the Timeline view.
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2. From the Timeline View Layer toolbar, click the Add Peg

button.

A peg layer appears directly above the camera layer so that the camera layer is automatically attached to
it. The peg layer automatically takes on the name of the camera and adds the suffix -P to indicate that it is
a peg layer, for example Camera-P.

If the new peg layer did not appear directly above the camera, you may have clicked elsewhere in the
scene, deactivating the layer on which you want to add the peg layer.
‣

Select the camera layer and drag and drop in under the new peg layer.

OR
‣

Delete the misplaced peg layer, select the camera layer and click the Add Peg

button again.

You are now ready to animate your camera.
It is recommended to use both the Top and Camera views while making camera moves. You can open this view is
one of two ways:
•

From the top menu, select Windows > Top.

•

From any existing window already open in your project, click the arrow
and select Top.
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To animate your camera:
1. Make sure that the Animate

button and Transform

tool are activated.

2. In the Top, Side or Camera view, select the camera and move it to the desired position.
‣

In the Top and Sive view, the camera is the large V cone. You need to click directly on one of the edge.

‣

In the Camera view, the camera is represented by a thin frame. You need to click directly on one of the
edge.

3. In the Timeline view, click on a cell in the Camera Peg layer where you want the camera move to begin.
4. Right-click and select Insert Keyframe.
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A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera
position as in this keyframe.
5. Click on another cell, further down your scene's Timeline, where you want the camera move to end.
6. Select the camera in the Top view and move it to the desired position.

A second keyframe appears and a line is created between the two frames to indicate that the subsequent
motion between the frames will be calculated and rendered by the program.
7. Play back

the camera move in the Camera view to watch the results.

Related Topics
•

Camera Truck-ins and Line Thickness
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Modifying a Path in the Camera View
Although the example cited in the Animating the Camera on page 658 section seems simple enough, camera
moves and motion paths can become complex, especially with moves through 3D space. That is why Toon Boom
has developed a way to view your camera's path and make adjustments to it from both a 2D and 3D perspective.

Related Topics
•

Displaying a Path in the Camera View below

•

Shaping a Path on page 664

•

Offsetting a Trajectory on page 670

Displaying a Path in the Camera View
You can display the trajectory for your motion path when you select an object in the Timeline or Camera view.
If you want to see the trajectory, enable the Show Control Points on Selected Layers preference.
To enable the Show Control Points on Selected Layers preference:
1. In the top menu, select Edit > Preferences (Windows) or Animate > Preferences (Mac OS X). The [Ctrl]
+ [U] (Windows) or [⌘ ] + [U] (Mac OS X).
The Preferences dialog box opens.
2. Select the Camera tab.
3. In the Control Points section, enable the Show Control Points on Selected Layers preference.

4. Click OK.
If the trajectory is hidden when you select an element, you may want to display it using the Control command.
To view your layer's trajectory using the Control command:
1. Verify that the Camera view (click on its tab) is selected and that the layer that you wish to display the
trajectory of is selected in the Timeline view.

‣

From the top menu, select View > Show > Control.

‣

Press [Shift] + [F11].
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If nothing appears in the Camera view, you may not have animated or selected the layer.

To hide your layer's trajectory:
1. Verify that the Camera view (click on its tab) is selected and that the layer that you want to hide the
trajectory of is selected in the Timeline or Camera view.

‣

From the top menu, select View > Show > Control.

‣

Press [Shift] + [F11].

‣

If you want to hide all of your trajectories at once without selecting any layer, select View > Hide All
Controls or press [Shift] + [C].

Related Topics
•

Shaping a Path on the facing page
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Shaping a Path
A motion path is as easy to manipulate as shaping the vector points of a drawing layer in the Camera view. One
important concept to understand is that a trajectory contains both keyframes and control points. Both can be
used to shape a path, each have their own significance and behaviours, however only keyframes appear in the
Timeline view. Their descriptions, in terms of their use along a path, are listed below:
•

Keyframe: A marker that signifies a change (size, position, direction, etc.) along the normal of a path or
function and has a precise position and frame.

•

Control Point: Has a position but no fixed frame or timing. It is mainly used to deform a trajectory. There
are no velocity handles available on a control point. The velocity segments are set between keyframes
only, making curves and trajectories much smoother.
Control points can only be added on 3D Path.

To resize an entire animation path so it fits into your scene's composition better, convert the
animation into a Symbol, then resize the Symbol itself.
Refer to the Library on page 521 chapter to learn how to create and import Symbols.

You can edit keyframes and control point parameters, such as the position, continuity, bias, tension and lock-intime using the Coordinates and Control Point view.

Coordinates and Control Points View
Each time a keyframe or a control point is selected in the Camera, Timeline or Xsheet view, its parameters
appear in the Coordinates and Control Points view. You can also see the same information in the Coordinate and
Control Point toolbars.
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Adding Control Points
A control point has a position but no fixed frame or timing. It is mainly used to deform a trajectory. There are no
velocity handles available on a control point. The velocity segments are set between keyframes only, making
curves and trajectories much smoother.
A control point will not show in the Timeline view because it has no precise frame to be displayed on. It will
appear on the function curve and in the Camera view. There are different ways to add control points:
•

Displaying the trajectory in the Camera view, the [P].

•

Add a keyframe on the function curve and disabling the Lock in Time option.

The control point is displayed as a circle.
You can display your trajectories in the Camera, Top and Side views to better understand the way that your
elements move in your scene. This also makes it easier to modify them. You can display a peg or layer's control
to be able to see where your elements are going, modify the curve and add keyframes and control points.
To add a Control Point on a trajectory:
1. In the Timeline or Camera view, select the peg or layer you want to add the control point on.
2. If the selected element's trajectory is not displayed, select View > Show > Control in the top menu. The
[Shift] + [F11].
The trajectory appears in the Camera, Top, Side and Perspective views.

3. You can add control points on a 3D path trajectory by placing your mouse where you want to add the
point. The [P].

665

Chapter 14: Animation Paths Modifying a Path in the Camera View

Toggling Between Keyframe and Control Points
To toggle between Keyframe and Control Points:
1. In the Camera view, using the Transform tool select the point you want to convert.
2. To convert the point:
‣

In the Coordinates and Control Point view, enable or disable the Locked in Time option.

‣

In the top menu, select Animation > Lock in Time. The [Alt] + [L].

‣

In the Function view or Function editor, select the keyframe to convert and click on the Lock in Time
button.
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Related Topics
•

Adjusting the Tension, Bias and Continuity below

•

Modifying a Path in the Camera View on page 662

Adjusting the Tension, Bias and Continuity
You can edit keyframes and control point parameters, such as the position, continuity, bias, tension and lock in
time using the Coordinates and Control Point view.
Each time a keyframe or a control point is selected in the Camera, Timeline or Xsheet view, its parameters
appear in the Coordinates and Control Point view. You can also see the same information in the Coordinate
and Control Point toolbars.

You can adjust the Tension, Bias and Continuity parameters on existing control points and keyframes by
selecting the point in the Camera view with the Transform
tool.
•

Continuity controls the smoothness of a transition between the segments joined by a point.
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•

Tension controls how sharply the path bends as it passes through a control point or keyframe.

•

Bias controls the slope of the path so that it flows towards one side of the motion point or the other.

To adjust the Continuity, Tension and Bias parameters:
1. In the Tools toolbar, select the Transform

tool.

2. In the Timeline view, select the layer that you want to adjust the parameters for.

3. In the top menu, select View > Show > Control or press [Shift] + [F11] to display the trajectory.
4. In the Camera view, select the control point or keyframe you want to adjust.

5. In the Coordinates and Control Points view, adjust the Continuity, Tension and Bias parameters.
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If you find that you are using the same Continuity, Tension and Bias settings, you can set a preference to
remember your settings.
To adjust the Point Setting Preferences:
1. From the top menu, select Edit > Preferences (Windows) or Animate > Preferences (Mac OS X).
The Preferences dialog box opens.
2. Select the Camera tab and look at the entire right section.

Toggling between a Linear or Curved Motion
When you select a control point on a path, you can toggle between a rounded or square corner by using the
Linear/Curve command.
To toggle between a linear or curved corner:
1. In the Tools toolbar, select the Transform

tool.

2. In the Camera view, select the point to convert.
3. In the top menu, select Animation > Linear/Curve.
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Related Topics
•

Shaping a Path on page 664

Cumulative Z Value
You can see the cumulative Z Value information in the Coordinates and Control Points view. When you select a
drawing cell including a keyframe, it will display the Cumulative Z value.
When a layer is parented to other layers that are moved forward or backward on the Z-axis, the currently
selected layer's position Z value may not be accurate since its parent will also have an offset on the Z-axis. The
Cumulative Z value is a compilation of all the Z-axis offsets to give the real Z-axis offset value related to the (0,0)
centre.

Related Topics
•

Shaping a Path on page 664

Offsetting a Trajectory
To reposition the visual trajectory to a more convenient location, you can use the Spline Offset tool.
Offsetting your trajectory will not offset or modify your animation. It will facilitate your work.
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To offset a spline/trajectory:
1. In the Animation Tools toolbar, select the Spline Offset

tool or press [Alt] + [9].

2. In the Camera or Timeline view, select the layer to be offset.
3. In the top menu, select View > Show > Control to display the trajectory. If you do not display the
trajectory, the transformation done using the Spline Offset tool will be ignored.

4. In the Camera view, move the trajectory to the proper position. You can move it on the X and Y axes, but
also on the Z-axis using the Top and Side views.

Related Topics
•

Modifying a Path in the Camera View on page 662
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Modifying a Path in the Timeline View
When you select a peg or drawing layer in the Camera view and move it around, Animate will automatically
create the corresponding function curves.
If you would then like to modify these functions, you can always do it through the peg's or layer's parameters in
the Timeline view.
•

Creating a Function below

•

Adding and Deleting Keyframes in the Timeline View on the next page

•

Changing Keyframe Values on the next page

•

Flipping Between Keyframes on page 675

Creating a Function
To create the function curve in the Timeline view:
1. Double-click on a Drawing or Peg layer.
The Layer Properties panel opens.

2. Identify the section of the type of function that you want to create.
3. Click the Function Arrow button at the end of the corresponding row.
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4. Select Create Bezier or Create Ease.

Adding and Deleting Keyframes in the Timeline View
To insert a Keyframe:
1. On the right side of the Timeline view, select a cell on the layer's function that you want to animate.

2. Right-click the selected cell and select Insert Keyframe or press [F6].
To delete a keyframe:
1. On the right-hand side of the Timeline view, select a cell with the keyframe that you want to delete.
2. Right-click on the selected keyframe and select Delete Keyframes from the menu that appears.
You can [Shift] + click on several keyframes to select a group before selected the Delete Keyframes
option.

If you select a keyframe or group of keyframes and press [Delete], it will also delete the
corresponding drawings on that cell.

Changing Keyframe Values
To change the keyframe values in the Timeline:
1. Open the layer's parameters by clicking the Expand Function
[Alt] + [F].
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2. Click the Show/Hide Data View

button at the top of the Timeline view, between the layer names

and the timeline fields.

3. Select the parameter that you wish to create a function curve for: Path, Velocity, Scale: x or y, Angle or
Skew. For this example we will use Velocity.
4. Pass the cursor over the blue number value of the parameter layer that you wish to modify.
‣

Wait until the cursor becomes a white hand with a two-way arrow

and then click and drag the

hand slightly to the left or right to decrease or increase the value.

OR
‣

Click directly on the blue number and enter a value into the white field that appears.

‣

If you selected the keyframe in the Camera view, you can modify the values in the Coordinate and
Control Points view.
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A function is automatically created as soon as the values are no longer zero.
5. Press [Enter/Return] or click on the Play

button to view the changes you have made in the Camera

view.

Flipping Between Keyframes
Animate lets you flip between the selected layer's keyframes.
To flip through your poses:
1. In the Camera or Timeline view, select the layer you want to see the keyframes for.

2. In the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe. The [;] and ['].

Related Topics
•

Function Types on page 689
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Modifying a Path in the Function View
If you are used to graphs and function curves, you can use the Function view to define your trajectories.

Related Topics
•

Function View below

•

Editing a Function in the Function View on page 678

•

Adding and Deleting Keyframes in the Function View on page 678

•

Changing a Keyframe's Values on page 680

Function View
While editing the X function of this 3D motion path, you can see the graphs for the Y, Z and velocity.

The Function view allows you to display multiple functions in the background as a reference. While you are
editing one function, you can see other selected functions, this helps you synchronize changes in one function
with other functions.
You can set the orientation of the Function view to be vertical (portrait) or horizontal (landscape).

‣ In the Function View menu, select View > Set Vertical Layout/Set Horizontal Layout.
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To display a function in the Function view, click its name in the Timeline view. You can also display several
functions in the Function View.
To display functions in the Function view:
1. Open the Function view.
The Function view is blank until you select the functions you want to display.
2. Click on the Function

button and scroll down the list of available functions. Click the checkbox next

to the function name to display it in the view.

‣

To display a function in the Function view, click its name in the Timeline view.

3. To select the function you want to edit, select its name from the function drop-down menu.
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Related Topics
•

Editing a Function in the Function View below

Editing a Function in the Function View
The graph displays the motion over the first and last keyframes set in the scene, as well as any keyframes created
between. If the scene is 60 frames, but the character's motion ends at frame 40, then the editor will only display
up to frame 40.
To edit a function in the Function view:
1. In the graph of the Function editor, select one of the white keyframes. If selected properly, the keyframe
turns red and displays a pointed yellow handle.
2. Click and drag the point either up or down or click and pull one of the handles to adjust the curve of the
graph.

In this case, changing the velocity from a straight line (constant velocity) to a curved one, changes the
ease-in (where the curve shoots up and then flattens-out) and ease-out (where the curve flattens-out and
then shoots up) values.
The centre keyframe can not be dragged up or down because the velocity is set. Theoretically dragging it
downwards towards zero would put it back to a place of non-movement.
3. Press the [Enter/Return] key with the Parameter window still open to watch the result of your curve
adjustment in the Camera view.

Related Topics
•

Adding and Deleting Keyframes in the Function View below

Adding and Deleting Keyframes in the Function View
If you want to change a parameter between two motion keyframes in the Timeline view, such as the scale, you
can do so by adding keyframes in the Scale editor.
To add or remove keyframes in the parameter editor:
1. Open the layer parameters by clicking the Expand Function
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2. Select the parameter that you wish to create a function curve for: Path, Velocity, Scale: x or y, Angle or
Skew. For this example we will use Scale: x.
3. Double-click on the parameter layer name to open the Function editor window or click once on the
parameter layer to display it in the Function view.

4. In the graph section, click on the frame number where you would like to make changes or in the Point
section, enter the frame number directly into the Frame field.
In the graph section, a vertical blue line will indicate the frame number selected.
5. Click the Add/Remove Keyframes

button.

6. Click on the newly created keyframe and drag it up (to decrease the width of the object) or down (to
increase the width of the object) or pull on the handles to create a smooth fluctuation of the drawing
object's width.
7. If you do not like the changes made, you can delete the new keyframe by selecting the keyframe, if it is not
already selected, and press the [Delete] key, or by clicking on the Add/Remove Keyframes
button.
You can delete an already existing keyframe by using the same process.

Related Topics
•

Modifying a Path in the Function View on page 676
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Changing a Keyframe's Values
In the example cited above, once a keyframe is created, it can be moved and its handles manipulated to change
the shape of the curve. Once a keyframe is manipulated it's value changes. This value is displayed in the Value
field of the Point section in the Function editor.
However, it is possible to work the other way around; it is possible to enter values into the Value field and watch
the keyframe change position and the curve along with it.
To change a keyframe's value:
1. Open the peg element's parameters by clicking on the Plus

sign next the peg layer's name.

2. Select the parameter that you wish to create a function curve for: Path, Velocity, Scale: x or y, Angle or
Skew. For this example we will use Scale: y.
3. Double-click on the parameter layer name to open the Editor window or click once on the parameter layer
to display it in the Function view.

4. In the Point section, enter a value in the Value field or drag up or down the keyframe you want to modify.
5. Press [Enter/Return] or click the Play

button to view the changes made in the Camera view.

6. Keep adjusting your values accordingly, until you are satisfied with what you see.
7. Click Close.

Related Topics
•

Adding and Deleting Keyframes in the Function View on page 678
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Modifying a Path in the Xsheet View
If you are used to working with the Exposure Sheet, you can also create keyframes and type values in the Xsheet
view.
You cannot create function curves directly in the Xsheet view. You must do this in either the Layer Properties
editor or the Timeline view.
To edit a function column in the Xsheet view, you must first display the Functions section of the Xsheet view and
then select the layer you want to modify.
To display the function columns in the Xsheet view:
1. In the Xsheet view, click on the Expand Function Section button.
2. In the Timeline view, select the layer containing the parameters to modify.
The columns appear in the Xsheet view.

To add a keyframe in the Xsheet view:
1. In the Xsheet view, go to the function column where you want to add a keyframe.

2. Double-click on the cell where you want to add a keyframe and type a numeric value.
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3. Click on [Enter/Return] to continue to the next cell.
4. Click on [Esc] to exit the typing mode.

To convert a cell into a keyframe:
1. In the Xsheet view, go to the function column where you want to add a keyframe.
2. Select the cell to convert.

3. Right-click on the cell and select Set Selection As Keyframe or press [F6].

‣

If you want to remove a keyframe, select the keyframe,right-click on the cell and select Clear
Keyframe in Selection or press [F7].

If you double-click on a function column's header, you will display the corresponding function curve in the
Function editor.

Related Topics
•

Modifying a Path in the Timeline View on page 672
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Function Curves
By default, when a drawing or peg is added to the scene, no function curve is created. You will generally create
the ones needed to avoid having an overload of useless functions.
When you select an element in the Camera view and move it around, it will automatically create the
corresponding function curves.
If you need to create certain functions manually, you can always do it through the Layer Properties view or
editor.
You can also link a layer's parameter to an existing function curve.

Related Topics
•

Creating Function Curves below

•

Sharing Functions on page 685

•

Function Drop-down Menu on page 688

•

Function Types on page 689

Creating Function Curves
You can manually create a function in the Layer Properties view or the Layer Properties editor. You can either
share it with other layer's parameters or to set your keyframes directly on the function curve instead of the
Timeline or Camera view.
To create the function curves for your project:
1. To open the Layer Properties editor, in the Timeline view, double-click on the layer or click once to
display it in the Layer Properties view.

The Layer Properties editor opens.
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2. Select the Transformation tab.
3. Click the Function Arrow

button beside the local function information.

4. Create a 3D Path, Bezier, Ease or Velobased curve.
‣

You can also create an Expression column. Refer to the Expression Columns on page 1 section to
learn more.

You can click on the Function

button to open the Function editor.

5. Click OK.

Related Topics
•

Function Types on page 689
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Sharing Functions

You can hook several parameters to the same function curve. For example, if you have an aircraft performing
loops between clouds, you may want the camera to follow the aircraft's motion path. If you attach the camera to
the aircraft's layer, the camera will also loop, but this may produce undesirable results and even induce a feeling
of motion sickness as you watch the final animation. Instead, what you can do is to share the X, Y and Z aircraft's
position with the camera's peg layer, but ignore the angle. scale and skew.
By default all the function curves you create are private. This means that the function curves can only be used and
modified using their original parameter. If you want another layer or parameter to use the same function curve,
you must make the function public.
There are two ways to share a function:
•

Share Functions command

•

Layer Properties Editor

To share a function using the Share Functions command:
1. In the Timeline view, select the function layer to share.

2. Right-click on the selection and select Share Functions.
The function now becomes public to the other layers and parameters and can be shared.
Public functions are visible in the main section of the Xsheet view.
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3. In the Timeline view, open the Layer Properties editor of the layer you want to link its parameter to the
public function.
4. To open the Layer Properties editor, in the Timeline view, double-click on the layer containing the
function to share or click once to display it in the Layer Properties view.

The Layer Properties Editor opens.
5. Go to the Transformation tab.
6. Click on the Function Arrow

button beside the function you want to link to the function column.

7. In the drop-down menu, select the function you just turned public from either, the 3D Path, Bezier, Ease,
Velobased, Expression, 3D Path, Connected, Unconnected, All menu, and hook it to your parameter.

The two parameters are now both linked to the same function curve and should follow the same path. If
you modify the curve, both parameters will update.
To share function curves:
1. To open the Layer Properties editor, in the Timeline View, double-click on the layer containing the
function to share or click once to display it in the Layer Properties view.
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The Layer Properties Editor opens.
2. Go to the Transformation tab.
3. Click on the Function Arrow

button beside the function to share.

4. In the drop-down menu, select the Local option.
5. Click on the Function Arrow
drop-down list.

button beside the Function field and choose an existing function from the

The function now becomes public to the other layers and parameters and can be shared.
Public functions are visible in the main section of the Xsheet view.

6. In the same drop-down menu, where you choose the Local option, select the function you just turned
public from either the 3D Path, Bezier, Ease, Velobased, Expression, 3D Path, Connected, Unconnected,
All menu and hook it to your parameter.
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7. In the Timeline view, open the Layer Properties editor of the other layer you want to link its parameter to
the public function.
8. In the Layer Properties editor or view, hook the parameter to the public function the same way you did
for the first layer.
The two parameters are now both linked to the same function curve and should follow the same path. If
you modify the curve, both parameters will update.

Related Topics
•

Function Drop-down Menu below

Function Drop-down Menu
When you create a function curve in the Layer Properties view or editor, you have several choices available:
•

Create 3D Path:
Creates a new 3D Path Column set.

•

Create Bezier
Creates a new Bezier curve.

•

Create Ease
Creates a new Ease curve.

•

Local
Disconnects the parameter from any function and turns it public.

•

3D Path
Displays the list of every public 3D Path function available.

•

Bezier
Displays the list of every public Bezier curve available.

•

Ease
Displays the list of every public Ease curve available.

•

Velobased
Displays the list of every public velocity based curve available.

•

Expression
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Displays the list of every public Expression function available.
•

3D Rotation
Displays the list of every public 3D Rotation function available.

•

Connected
Displays the list of every public connected function curve.

•

Unconnected
Displays the list of every public unconnected function curve.

•

All
Displays the list of every public function curve.

The user has the choice of creating a new function curve or linking it to an already existing public one. This way,
he can have two or more parameters following the same function.

Related Topics
•

Function Types below

Function Types
Depending of your favourite working method, you can create different types of function curves to suit your need.
You have several choices available:
•

Ease and Bezier Functions below

•

Velobased Functions on the facing page

•

Converting Ease and Bezier Functions on the facing page

Ease and Bezier Functions
When you create a function to control a parameter over time (Scale, X, Y, Z, Rotate), you have the choice of an
Ease or Bezier function.
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These function editors present different ways of editing the values over time. The shape of the created graph
indicates the velocity of the function, regardless of the chosen editor. The type of function that you choose is
largely based on your own working preference.
With the Ease editor, you can edit the shape of the function curves using the ease-in and ease-out controls. You
may choose to use this type of function if you are used to working with ease-in and ease-out values.

Velobased Functions
You can also create Velobased functions for certain effects, like changes in rotation or size over time. In these
cases, the Velobased functions are linked to the velocity of a 3D path. You cannot change the shape of a
Velobased function to control its velocity.
With Velobased functions, you can link changes in rotation or scaling to the velocity of a 3D path. This makes it
possible for changes in rotation or scaling to progress at the same speed as changes to the position of an
element.

Converting Ease and Bezier Functions
To convert Ease and Bezier functions so that you can edit them using the controls offered by that editor.
To convert Ease and Bezier functions:
1. In the Xsheet view, if not done yet, show the function columns.
2. In the Xsheet view, click on the Expand button located on the right side of the main section to show the
Functions section. Click on the same button to collapse it. You can also use the Show Column List
button in the Xsheet View toolbar.
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3. Click the Expand button on the right side of the Functions section to display the Column List section.

4. In the Timeline view, click the layer you want to display the function columns from.

5. In the Xsheet view,right-click the column's header and select one of the following from the Convert menu:
‣

Convert the column: The values of multiple effects may be linked to the original column. When you
use the Convert the Column command, all links to the original column will transfer to the new
converted column.

‣

Create a new column and update links: Creates a new function from the original. All links to the
original column will transfer to the new column. The original function column will remain in the
exposure sheet in case you decide you want to switch back to it.

‣

Create a new unused column: Creates a new column based on the values in the original column and
leaves all links pointing to the original column. You can use this command to experiment with various
functions and then link effect values to the new function curve column.

Related Topics
•

Function Curves on page 683
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Copying and Pasting a Motion
In the Timeline view, you can easily drag keyframes to change the animation timing, delete them, cycle them and
even copy them.
When you have position keyframes set in your drawing layer and you want to move them around with moving
your drawing's timing, you can use the Paste Special feature to only move the keyframes selected.
You can also use the Paste Cycle and Paste Reverse feature to cycle your selection including keyframes and
drawings.
•

Paste Special below

•

Paste Special Dialog Box on the next page

•

Pasting Cycles on page 698

Paste Special
To copy and paste a motion:
1. In the Timeline view, select the keyframes, to copy and paste. If you want to move the keyframes, move on
to step 3.

2. In the top menu, select Edit > Copy.
3. To edit your selection:
‣

To paste the selection, in the Timeline view, select the first cell where you want to paste your
keyframes and in the top menu, select Edit > Paste Special.

‣

To move the selection, in the Timeline view, drag the selection and hold down [Alt] (Windows) or [⌘ ]
(Mac OS X). Drop the selection where you need it before releasing the hot key.

The Paste Special window opens.
4. Set the Drawing, Pegs and Functions, and Cycles parameters. and

5. Click OK.
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Paste Special Dialog Box
To open the Paste Special dialog box:
1. In the Library view, select the symbol or template to import.
2. While dragging the selection to the Timeline view, hold down the [Alt] (Windows) or [⌘ ] (Mac OS X).

Drop the selection in the Timeline view before releasing the hot key.

The Paste Special window opens.
3. Set the parameters.
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Paste Special - Basic Tab

Drawings
•

Only create drawing files when they do not exist: When adding exposures to a drawing layer, new
drawings will be created only when drawings with the same name do not already exist in the destination.

•

Always create drawing files: When adding exposures to a drawing layer, new drawings will always be
created. If drawing files with the same name already exist, Animate will create a new name for the
drawing.

•

Extend Exposure: Extends the exposure of drawings to fill the range of cells to the destination frame.

•

Paste all Frames of the Symbols (full movie): When enabled, the Paste Special command will expose all
the Symbol's frames instead of the first one only.

Cycle
•

Number of Cycles: Use the up and down arrows to increase or decrease the number of cycles you want to paste.
You can also type the value directly in the field.

•

Cycle Type
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•

Normal (forward): This pastes your selection as it is, starting with the first cell and ending with the last
one.

•

Reverse: This pastes your selection in reverse, starting with the last cell and ending with the first one.

•

Forward -> Reverse: This pastes your selection as a yo-yo, starting with the first cell, going to the last
one and ending with the first cell.

•

Reverse -> Forward: This pastes your selection as a reverse yo-yo, starting with the last cell, going to
the first one and ending with the last cell.

Paste Special - Advanced Tab

Drawings
•

Do Nothing: Does not create or overwrite drawings.

•

Update Drawing Pivot: Revises the drawing pivot in the destination to use the same drawing pivot as the
first drawing in the template. If you have a range of drawings selected in the destination, the pivot points
of all selected drawings will be updated.

•

Add/Remove Exposure: Creates/deletes exposure values in the selected layer.
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You have the following choices as to how to treat drawings that will be created when adding an exposure:
•

Never create drawing files: When adding exposures to a drawing layer, drawing files will not be
created.

•

Only create drawing files when they do not exist: When adding exposures to a drawing layer, new
drawings will be created only when drawings with the same name do not already exist in the
destination.

•

Always create drawing files: When adding exposures to a drawing layer, new drawings will always be
created. If drawing files with the same name already exist, Animate will create a new name for the
drawing.

•

Extend Exposure: Extends the exposure of drawings to fill the range of cells to the destination frame.

•

Key Drawing Mode (Substitution): Pasting an exposure value replaces the cell value in the current
frame and in all frames following in sequence with the original cell value.

•

Paste all Frames of the Symbols (full movie): When enabled, the Paste Special command exposes all
the Symbol's frames instead of only the first one.

Add/Remove Keyframes
•

Motion: Copies the properties of the selected motion keyframe to the new frame.

•

Velocity: Copies the properties of the selected velocity keyframe to the new frame.

•

Rotation: Copies the properties of the selected rotation keyframe to the new frame.

•

Skew: Copies the properties of the selected skew keyframe to the new frame.

•

Scale: Copies the properties of the selected scale keyframe to the new frame.

•

Force Keyframes at Function's Beginning and End: Adds a keyframe to the beginning and end of the
pasted function, reproducing the source function.

•

Offset Keyframes: When pasting functions, this option offsets the keyframes from the function's last
value by the values in the pasted function. This will continue the progression of a function rather than
repeat the values.

Option
•

Palette Option
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•

Do nothing: Does not create, overwrite, merge or link palettes.

•

Reuse palettes. Copy palettes if they do not exist: Palettes in the destination drawings are left as
they are.

•

Copy and overwrite existing palettes: Overwrites destination palettes with the palettes from the
source drawings.

•

Copy and create new palette files: Creates new palette files, placing them at the same relative
environment and scene level as the source. If the palettes in the templates were stored at the
environment level of the source scene, the paste operation will place the palettes in the environment
level of the destination scene.

•

Copy and create new palette files in element folder: Creates new palette files in the element folders
of the destination scene, rather than in the same relative job or environment.

•

Copy palette and merge colours. Add new colours only: Adds new colours to the destination
palettes and ignores colours that are the same in the two palettes.

•

Copy palette and update existing colours only: Adds new colours to the destination palette and
updates duplicate colours in the destination with colour values from the source.

•

Link to original palettes (colour model): Links the colour palettes in the destination scene to the
palettes in the source. Use this to link drawings to the palettes in a colour model.

•

Copy scene palettes and merge colours. Add new colours only: Adds new colours to the
destination scene palettes and ignores colours that are the same in the two palettes.

•

Copy scene palettes and update existing colours: Adds new colours to the destination scene palette
and updates duplicate colours in the destination with the colour values from the source.

•

Duplicate All Symbol Content: Instead of linking the Symbol instance to the original one, the Symbol will
be duplicated. A new Symbol is created in the Library.

•

Symbols

•

•

•

Copy symbols if they do not exist: This is the default setting for this operation and will prevent
Symbols in a Action template from being copied.

•

Duplicate symbols: Creates a duplicate of the Symbol instead of linking the Symbol instance to the
original one. The new Symbol is created in the Library.

•

Overwrite symbols: If a modification was made to a Symbol that does not exist in the basic rig
template for a character, select this option to overwrite the previous Symbol.

Cycles:
•

Cycle Types:

•

Normal (forward): This pastes your selection as it is, starting with the first cell and ending with the last
one.

•

Reverse: This pastes your selection reversed, starting with the last cell and ending with the first one.

•

Forward -> Reverse: This pastes your selection as a yo-yo, starting with the first cell, going to the last
one and ending with the first cell.

•

Reverse -> Forward: This pastes your selection as a reverse yo-yo, starting with the last cell, going to
the first one and ending with the last cell.

•

Number of Cycles: Use the up and down arrows to increase or decrease the number of cycles you
want to paste. You can also type the value directly in the field.

Modules: Create New Columns: If you enable this option a new column will be created when you copy
and paste modules from the Network view or Layer in the Timeline view. If the layers are linked to function
curves, the function curves, the drawings and the timing will be duplicated.
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Related Topics
•

Pasting Cycles below

Paste Special
To copy and paste a motion:
1. In the Timeline view, select the keyframes, to copy and paste. If you want to move the keyframes, move on
to step 3.

2. In the top menu, select Edit > Copy.
3. To edit your selection:
‣

To paste the selection, in the Timeline view, select the first cell where you want to paste your
keyframes and in the top menu, select Edit > Paste Special.

‣

To move the selection, in the Timeline view, drag the selection and hold down [Alt] (Windows) or [⌘ ]
(Mac OS X). Drop the selection where you need it before releasing the hot key.

The Paste Special window opens.
4. Set the Drawing, Pegs and Functions, and Cycles parameters.

5. Click OK.

Related Topics
•

Pasting Cycles below

Pasting Cycles
If you want to cycle a portion of your animation, you can use the Paste Cycle command. You can also use the
Paste Reverse command to completely reverse the flow of your animation.
To use the Paste Cycle command:
1. In the Xsheet or Timeline view, select the cell range and keyframes to loop.
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2. In the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4. In the top menu, select Edit > Paste Cycle or press [Ctrl] + [/] (Windows) or [⌘ ] + [/] (Mac OS X).
The Paste Cycle dialog box opens.

5. In the Number of Cycles field, use the up and down arrow to increase or decrease the amount of cycles
you want to paste. You can also directly type the value.
6. In the Cycle Type drop-down menu, select the type of cycle you want to paste.

‣

Normal (forward): Pastes your selection as it is, starting with the first cell and ending with the last
one.

‣

Reverse: Pastes your selection reversed, starting with the last cell and ending with the first one.

‣

Forward -> Reverse: pastes your selection as a yo-yo, starting with the first cell, going to the last one
and ending with the first cell.

‣

Reverse -> Forward: pastes your selection as a reversed yo-yo, starting with the last cell, going to the
first one and ending with the last cell.

7. Click OK.
To use the Paste Reverse command:
1. In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.

2. In the top menu, select Edit > Copy or press [Ctrl] + [C] (Windows) or [⌘ ] + [C] (Mac OS X).
3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.
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4. In the top menu, select Edit > Paste Reverse or press [Ctrl] + [.] (Windows) or [⌘ ] + [.] (Mac OS X).

Related Topics
•

Copying and Pasting a Motion on page 692
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Adjusting the Ease
To add ease in and ease out on your motion paths, you can display the function curve and modify the Bezier or
Ease curve. To apply an ease to multiple functions and keyframes, you can use the Set Ease For Multiple
Parameters script and set the amount desired.
The Velocity, or ease, is used on motion keyframes. The velocity has to be adjusted directly on the function curve
in either the Function view or the Function editor. When a keyframe is selected, easing values appear in the right
handle and left handle fields, as well as Bezier handle or Ease wheel controls on each selected keyframe. Pull on
them to adjust the ease in and ease out, or type values in the fields.

Related Topics
•

Displaying the Velocity Curve below

•

Reshaping a Velocity Function using Bezier Controls on the facing page

•

Reshaping a Velocity Function using Ease Controls on page 703

•

Creating a Stepped Velocity on page 704

•

Adjusting the Velocity of Several Layers at the Same Time on page 705

Displaying the Velocity Curve
To display the velocity curve:
1. In the Timeline view, click on the Expand Function

2. Double-click on the desired function.

The Function Editor opens.
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The editor will not be displayed if the function does not already exist.

Related Topics
•

Reshaping a Velocity Function using Bezier Controls below

•

Reshaping a Velocity Function using Ease Controls on the next page

•

Creating a Stepped Velocity on page 704

•

Adjusting the Velocity of Several Layers at the Same Time on page 705

Reshaping a Velocity Function using Bezier Controls
You can reshape the velocity function using Bezier controls.
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You can reshape the function using either the Bezier or Ease controls.
To reshape a function using Bezier controls:
1. Click on the keyframe to select it.
2. Drag the handles to modify the shape of the curve.
The Continuity options, Corner, Straight and Smooth, influence how you can move the handles.
‣

Straight: allows you to move the handles together, maintaining the same angle to the point.

‣

Corner: allows you to move the handles independently.

‣

Smooth: allows you to move the handles together, maintaining the same distance and angle to the
point.

Related Topics
•

Displaying the Velocity Curve on page 701

•

Reshaping a Velocity Function using Ease Controls below

•

Creating a Stepped Velocity on the facing page

•

Adjusting the Velocity of Several Layers at the Same Time on page 705

Reshaping a Velocity Function using Ease Controls
You can reshape the velocity function using Ease controls.
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To reshape the function using Ease controls:
1. Click on the keyframe to select it.
2. To set the number of frames in the ease-in, press [Alt], click to the right of the keyframe and drag the
green line. The ease in slope is indicated in blue.
As you change the values visually, the value in the Ease In field is updated. This value represents the
number of frames in the ease-in.
3. To set the number of frames in the ease-out, press [Alt], click to the left of the keyframe and drag the
green line. The ease out slope is indicated in red.
As you change the values visually, the value in the Ease Out field is updated. This value represents the
number of frames in the ease-out.
4. To adjust the ease-in or ease-out, drag the handles around the keyframe.
The Continuity options, Corner and Straight, influence how you can move the handles:
‣

Straight: allows you to move the handles together, maintaining the same angle to the point.

‣

Corner: allows you to move the handles independently.

Related Topics
•

Reshaping a Velocity Function using Bezier Controls on page 702

•

Creating a Stepped Velocity below

•

Adjusting the Velocity of Several Layers at the Same Time on the next page

Creating a Stepped Velocity
You can create a stepped curve to hold the same value over a selected number of frames. This works well when
you are animating drawings on 2's, for example, and you want to hold the same value for a function over those
two frames.
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To hold the same value over several frames:
1. Click the Hold Value Editor

button.

The Hold Value editor opens.

2. In the Hold Value editor, enter the following values:
‣

In the Start field, enter the starting frame for the effect.

‣

In the Stop field, enter the last frame for the effect.

‣

In the Step field, enter the number of frames that you want to hold the value for.

3. Click Apply.
4. Click OK.
The function curve is updated based on the values you entered.

You can reshape the curve to create a linear velocity so that the values are interpolated (tweened) consistently
between keyframes (that is, there is no acceleration in the effect).
To create a linear velocity between two keyframes:

‣ Click the keyframe to select it and then click the Linear Velocity

button. This command resets the

handles on the Ease or Bezier function so that the velocity is linear.

Related Topics
•

Adjusting the Ease on page 701

Adjusting the Velocity of Several Layers at the Same
Time
If you have several functions you would like to adjust the velocity for at the same time, you can use the Set Ease
for Multiple Parameters dialog box. It allows you to apply the same velocity parameters to all the selected
keyframes in a same frame.
To set eases on multiple parameters:
1. In the Timeline view, select a keyframe on one or many layers.
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Only the first selected keyframe will be considered when using the Set Ease For Multiple Parameter
function. If many keyframes are selected on a same layer, the ease values will be applied only to the
first one and the rest will be ignored.

2. In the Timeline view,right-click and select Set Ease For Multiple Parameters. In the Timeline View
toolbar, you can click on the Set Ease For Multiple Parameters
button. This button is available in the
Timeline View toolbar's extra buttons. Refer to the chapter on Toolbar Manager on page 96 to learn
how to customize your toolbars.
The Set Ease For Multiple Parameters dialog box opens.

3. In the graph interface, pull on the Bezier handle to adjust the velocity for all the selected functions.

4. To apply these easing parameters to a specific type of function only, such as Rotation or Scale, go to the
Filters section and disable the function types you do not want to affect.
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‣

Motion: If this option is enabled, the easing parameters will be applied to the selected Position X,
Position Y, Position Z and 3D Path functions

‣

Rotation: If this option is enabled, the easing parameters will be applied to the selected Angle
functions.

‣

Scale: If this option is enabled, the easing parameters will be applied to the selected Scale functions.

‣

Skew: If this option is enabled, the easing parameters will be applied to the selected Skew functions.

‣

Morphing: If this option is enabled, the easing parameters will be applied to the selected Morphing
Velocity functions. Note that it applies to the Morphing velocity function found in the Layer
Properties dialog and not to the basic morphing ease in the Tool Properties view.

‣

Other: If this option is enabled, the easing parameters will be applied to all the other the selected
functions such as all functions created to animate effect parameters.

5. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values are
calculated in percentage.
‣

In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding to the
length of time you want the easing to last for. It is recommended to remain between 0% and 100%. If
you go beyond 100%, your motion will overshoot.

‣

In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong you
want the easing out to be. It is recommended to remain between 0% and 100%. If you go beyond
100%, your motion will overshoot.

‣

If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

6. Once done, click on one of the following button:
‣

Apply: This will apply the easing parameters to the selected keyframes.

‣

Apply/Previous: This will apply the easing parameters to the selected keyframes and then selects the
previous keyframe in the timeline.

‣

Apply/Next: This will apply the easing parameters to the selected keyframes and then selects the next
keyframe in the timeline.

‣

Close: This closes the dialog box. If you did not apply the modifications, they will be cancelled.

Related Topics
•

Adjusting the Ease on page 701
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Animation Path Preferences
While creating motion paths and setting up your scenes, there are preferences you can set to make your work
more efficient.
To open the Preferences panel:
‣

Windows: Select Edit > Preferences.

‣

Mac OS X: Select Animate > Preferences.

‣

Press [Ctrl] + [U] (Windows) or [⌘ ] + [U] (Mac OS X).

Related Topics
•

General Preferences below

•

Camera Preferences on the next page

•

Exposure Sheet Preferences on page 710

•

Timeline on page 1

General Preferences

Options
•

Snap Keyframe: If two keyframes have the same value, they will both update to the same new position
when the first of the two keyframes is modified. The previous keyframe has to be a Stop-Motion
keyframe.

Settings
•

Stop-Motion Keyframes: New keyframes are created as stop-motion keyframes.
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•

Default Separate Positions: New pegs are created with separate position functions.

•

Default Separate Scale: New pegs are created with separate scale functions.

•

Default Bezier: New functions curves are created as Bezier Curves.

•

Default Bezier Velocity: New velocity curves are created as Bezier Curves.

Related Topics
•

Camera Preferences below

•

Exposure Sheet Preferences on the facing page

•

Timeline on page 1

Camera Preferences

Tools
•

Initial Animation Mode: Determines which animation mode are enabled when the scene is opened.

•

Set Keyframes on All Functions With the Transform tool: A keyframe is added by default on all the
functions of the selected layer when you perform a transformation with the transform tool. Disable this
option if you want the Transform tool to add a keyframe only on the transformation you are doing, such
as a rotation or scale.

•

Set Keyframe At Frame One With First Application On the Transform Tool: When this preference is
enabled, wherever you set a keyframe on your layer, there will be a keyframe added on your frame 1. If the
preference is disabled, there will be only a keyframe added to the current frame. If later on, you add a
keyframe on your frame one, it may modify the first keyframe you added.
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Control Points
•

Show Control Points On Selected Layer: By default, when you select an element with the Transform
tool, the motion path related to the object is displayed.

•

Control Point Tension: The default Tension value for new keyframes and Control Points.

•

Control Point Continuity: The default Continuity value for new keyframes and Control Points.

•

Control Point Bias: The default Bias value for new keyframes and Control Points.

Related Topics
•

General Preferences on page 708

•

Exposure Sheet Preferences below

•

Timeline on page 1

Exposure Sheet Preferences

Function Editors
•

Show Grid: When selected, the grid is displayed by default when opening the Function Editor.

•

Use Constant Z By Default: When selected, the Constant Z option will be enabled by default in the
Function Editor.
Constant Z means that even when creating Motion keyframes, the Z function will use Stop-Motion
keyframes and will not be interpolated, this can be very useful for cut-out animation. The Constant Z
feature only works with 3Dpaths.
You can also enable the Constant Z option directly in the Function Editor or Function view for specific
functions.

Related Topics
•

General Preferences on page 708
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•

Camera Preferences on page 709

•

Timeline on page 1
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Chapter 15: Cut-out Animation

Animate provides you with some great tools to animate your puppets. You can create simple animation using
the Transform tool and you can make advanced animation using both forward and inverse kinematics. Animate
has advanced onion skinning and image swapping features to help you animate efficiently and quickly. To give
you animation freedom you are able to mix several different techniques of animation such as simple rigging,
hierarchy and symbol animation.

Topics Covered
•

Getting the Character on page 715

•

Keyframes and Drawing Blocks on page 716

•

Creating a Simple Cut-out Animation on page 718

•

Selecting Layers to Animate or Position on page 721

•

Navigating the Hierarchy on page 725

•

Animating using the Transform Tool on page 727

•

Animating using Inverse Kinematics on page 730

•

Animating in Stop-motion on page 748

•

Animating using Computer Generated Interpolation on page 750

•

Flipping Through Poses on page 756

•

Using the Onion Skin in Cut-out Animation on page 758

•

Flipping Parts on page 761

•

Reusing Extra Drawings, Poses and Facial Expressions on page 1

•

Swapping Images on page 763

•

Adding a New Drawing on page 766

•

Ordering Layers Over Time on page 767

•

Resetting a Transformation on page 769

•

Creating Cycles on page 771
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•

Adding Pegs on page 776

•

Offsetting Part of an Animation on page 1

•

Preferences on page 1
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Getting the Character
The first step in animating your character is to import a master template from the library.
•

Importing a Character from the Library below

Importing a Character from the Library
To import your character from the library:
1. Create your new Animate project.
2. In the Library view, select the character's master template you want to animate.

3. Drag the selected template to the Camera or Timeline view's left side.

4. In the Timeline view, drag the scene length bracket to extend or shorten your scene length.

Related Topics
•

Selecting the Pose on page 1

•

Extending the Exposure on page 1
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Keyframes and Drawing Blocks
When you extend the exposure of a drawing it is represented by a grey block in the Timeline view. When you
expose a second drawing, a second grey block is displayed.
You can consider these blocks as drawing blocks.

To animate the position of a block over time, you do not need to create a second block, you simply need to add
a position keyframe. The position keyframes are coordinates indicating the position of your drawing on a
particular frame. These appear as black squares in the Timeline view. If you refer to the example below, you can
see that the keyframes are positioned on frames independently from the beginning and end of each drawing
block.

You can keyframe three different positions for your drawing in the same drawing block and create a motion path
between them.

Timeline Behaviour
In the Timeline view, you can see how the Timeline behaves differently depending on whether you either create a
new drawing, a new keyframe, or both at the same time.
•

Creating a Drawing in the Timeline View below

•

Creating a Keyframe in the Timeline View on the next page

•

Creating a Drawing and a Keyframe in the Timeline View at the Same Time on the next page

Creating a Drawing in the Timeline View
You can use the Create Empty Drawing command to add a new drawing in the Timeline view. This will
automatically insert a new drawing block.

‣ Select Drawing > Create Empty Drawing. You can also use the Create Empty Drawing
the Timeline View toolbar.
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Creating a Keyframe in the Timeline View
You can use the Add Keyframe command to add a new keyframe in the Timeline view. This will automatically
create a keyframe in your layer.

‣ Select Insert > Keyframe . You can also press [F6].
‣

You can also use the Add Keyframe

button from the Timeline View toolbar.

Creating a Drawing and a Keyframe in the Timeline View at the
Same Time
You can use the Insert Keyframe and Duplicate Drawing command to add a keyframe and a drawing at the same
time. This will create a drawing block containing copies of the selected drawing and a keyframe.

‣ Select Insert > Keyframe and Duplicate Drawing.
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Creating a Simple Cut-out Animation

To create a simple cut-out animation, follow these steps so you can try out the animation tools you will learn in
the next topics.
To create a simple cut-out animation:
1. In the Tools toolbar, select the Transform

tool. You can also press [Shift] + [T].

2. In the Tool Properties view, make sure that the Peg Selection Mode
3. In the Tools toolbar, enable the Animate

option is disabled.

mode so that everything you move will be keyframed

automatically.
4. In the top menu, select Animation > Stop-Motion Keyframe so that the interpolation is not created
automatically between your keyframes.
5. In the Timeline view, collapse your character.

6. In the Timeline view, go to the frame where you want to set your first pose.
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7. In the Camera view, select the parts to animate.

8. Using the Transform

tool, rotate, skew, scale or translate the selection to its new position.

A new keyframe appears in the Timeline view.
9. If you want to make sure that nothing will move on your new pose, in the Timeline view, select the frame
corresponding to the pose,right-click and select Add Keyframe. You can also press [F6].
10. In the Tools toolbar, enable the Onion Skin

feature.

11.In the Timeline view, go to the frame where you want to set your second keyframe.

12. In the Camera view, animate your character.

13. Repeat this process until all your poses are done.
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Related Topics
•

Selecting Layers to Animate or Position on the next page

•

Animating using the Transform Tool on page 727

•

Animating using Computer Generated Interpolation on page 750

•

Using the Onion Skin in Cut-out Animation on page 758
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Selecting Layers to Animate or Position

When you are animating characters, it is important to understand how the Animate mode allows you to create
keyframes on the current frame or to reposition the entire layer.
This topic is divided as follows:
•

Animate Mode below

•

Selecting Drawing Layers using the Transform Tool on the facing page

Animate Mode
The Animate

button, in the Tools toolbar, toggles the keyframing option on or off.

When you enable the Animate mode, as soon as your move an element in your Camera view, a keyframe is
positioned on the current frame in the Timeline view to indicate the new position.

When you disable the Animate mode, and you select and move an element, the entire animation in the layer will
be offset at once.
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This means that when you are animating your character, you must enable the Animate mode.
If you are scaling down your puppet to fit the scene composition and want to resize the entire animation, you
must disable the Animate mode.
To enable and disable the Animate mode:

‣ In the Tools toolbar, click on the Animate

button. You can also enable and disable the Animate mode

in the top menu under Animation > Animate.

Selecting Drawing Layers using the Transform Tool
To manipulate your drawing layers in order to animate them, you must use the Transform

tool. The Select

tool is used to modify the drawing strokes and not the actual drawing layer.

When selecting your drawing layers with the Transform tool, make sure that the Peg Selection Mode
option is disabled in the Transform Tool Properties view. If this option is enabled it will limit the
selection in the Camera view to pegs only.

This section is divided as follows:
•

Selecting an element in the Camera View using the Transform Tool on the next page

•

Selecting a Layer in the Timeline View on the next page

•

Selecting in the Network View on page 724

To select using the Transform tool:
1. In the Tools toolbar, click on the Transform

tool or press [Shift] + [T]. You can also select the

Transform tool in the top menu under Animation > Tools > Transform.
2. In the Tool Properties view, make sure that the Peg Selection Mode
3. In the Camera view, select the element to animate.
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Selecting an element in the Camera View using the Transform
Tool
When you select an element in the Camera view using the Transform tool, make sure that the Peg Selection
Mode
is disabled in the Transform Tool Properties view, the element selected is the actual drawing layer
corresponding to the selected element. If you have a peg parented to that layer, you must either use the
keyboard shortcuts to go up the hierarchy chain, select it in the Timeline view, or enable the Peg Selection Mode
option in the Transform Tool Properties view, this will limit the selection in the Camera view to pegs only.

If the layer has child layers, they will also be highlighted.

Selecting a Layer in the Timeline View
When you select a layer in the Timeline view, the corresponding element will be highlighted in the Camera view. If
the selected layer has child layers, they will also be highlighted.
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Selecting in the Network View
As with the Timeline view, when you select a module in the Network view, the corresponding element will be
highlighted in the Camera view. If the selected module has child layers, they will also be highlighted.

Related Topics
•

Navigating the Hierarchy on the next page
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Navigating the Hierarchy
If you created a layer hierarchy when you built your puppet, you can use the keyboard shortcuts to travel up and
down the parent-child chain. You can also travel between the children in a layer.
To select the parent or child layer:
1. In the Tools toolbar, select the Transform

tool.

2. In the Tool Properties view, make sure that the Peg Selection Mode

is disabled.

3. In the Camera or Timeline view, select a layer attached to a hierarchy.

4. Select Animation > Select Parent Skipping Effects to select the parent layer and select Animation >
Select Child Skipping Effects to select the child layer. The keyboard shortcuts are [B] and [Shift] + [B].

That these keyboard shortcuts will ignore any effect module encountered in the Network or Timeline
view. Only drawing and peg modules will be considered. If you would like to navigate the hierarchy
including the effect modules, you create a custom keyboard shortcut in the Preferences panel for
the Select Parent Skipping Effects and Select Child Skipping Effects commands under the General
category. Refer to Customizing a Keyboard Shortcut on page 58 to learn how to create custom
keyboard shortcuts.

To select the children layers:
1. In the Tools toolbar, select the Transform

tool.
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Navigating the Hierarchy

2. In the Camera or Timeline view, select a layer attached to a parent layer with several children or not
parented at all.

3. Select Animation > Select Previous Brother to select the previous child layer and select Animation >
Select Next Brother to select the next child layer. You can also select Animation > Select Children to
select all child layers at once. The keyboard shortcuts are [/] and [?].

Related Topics
•

Creating a Simple Cut-out Animation on page 718

•

Selecting Layers to Animate or Position on page 721

•

Animating using the Transform Tool on the next page

•

Animating using Inverse Kinematics on page 730

•

Flipping Through Poses on page 756

•

Flipping Parts on page 761

•

Ordering Layers Over Time on page 767

•

Resetting a Transformation on page 769

•

Adding Pegs on page 776

•

Offsetting Part of an Animation on page 1
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Animating using the Transform Tool
The Transform tool is the main tool you use when working with a cut-out character. The Transform tool has many
useful functions:

Using the individual Rotate, Translate, Scale and Skew tools is not recommended, as they move each piece from
their own pivot point. They are compositing tools. The Transform tool will create a global selection, so when
many parts are selected, the Transform tool will move it as one. The Transform tool is highly recommended for
cut-out animation.

When animating with the Transform tool, make sure to select the right selection mode. In this
example, make sure that the Peg Selection Mode
is disabled in the Tool Properties view or it will
limit the selection in the Camera view to pegs only.
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Animating using the Transform Tool

If you have hierarchy connections in your cut-out character, the Transform tool will also be used as the Forward
Kinematics equivalent.
The Transform tool can be used on any kind of rigging.
When many parts are selected with the Transform tool, the first selected part's pivot will be used as the global
selection's pivot. This pivot can be moved temporarily for the animation. When you offset the pivot, the
permanent pivot is displayed as a ghost.

The interpolation of your animation poses is always calculated from the permanent pivot.

To use the Transform tool:
1. In the Tools toolbar, click on the Transform

tool or press [Shift] + [T].

2. In the Tool Properties view, make sure that the Peg Selection Mode
3. In the Camera view, select the element to animate and move it.
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4. In the Timeline view, go to the frame where you want to set your next position.

5. In the Camera view, animate the character.

Related Topics
•

Positioning an Element using the Transform Tool on page 498
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Animating using Inverse Kinematics

The Inverse Kinematics tool (IK) allows you to pull on your character's extremities, such as the hands and feet,
and have the rest of the body follow.
The Inverse Kinematics tool will animate from an extremity and make the rest of the hierarchy follow (called the IK
chain). It can be used on any piece connected in a hierarchy. However, you do not have to use IK every time that
you have a hierarchy rig. This tool is useful when you want to bend a character's knees, make him sit and move
the rest of the body, etc.
Inverse Kinematics helps a new animator to understand how a puppet should move. It will also help any animator
easily create difficult moves.
Inverse Kinematics will not work on basic rigs without hierarchy because there is no hierarchy chain present, IK
only works on hierarchy parenting when the pivots are properly set.
When animating a hierarchy puppet, an animator will use the Transform and Inverse Kinematics tools.

Topics Covered
•

IK Hierarchy Chains on the next page

•

Where to Start with Inverse Kinematics? on page 732

•

Inverse Kinematics Tool Properties on page 734

•

Setting up the Character to use IK on page 738

•

Nails on page 742

•

Minimum and Maximum Angle on page 1

•

IK Keyframes on page 743

•

When to use the Inverse Kinematics Tool on page 745
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IK Hierarchy Chains
Before we go any further, a word about IK chains. There are three types of chains:
•

Single Chains below

•

Direct Chains below

•

All Chains

Single Chains

These are the most basic of chains. A single chain is a straight line with no secondary chain attached.

Direct Chains

These link directly to the core of the character rigging. A direct chain is a single chain which goes directly to the
core.
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All Chains

All chains are attached and move simultaneously when one part is moved.

Related Topics
•

Where to Start with Inverse Kinematics? below

•

Inverse Kinematics Tool Properties on page 734

•

Setting up the Character to use IK on page 738

•

Nails on page 742

•

Minimum and Maximum Angle on page 1

•

IK Keyframes on page 743

•

When to use the Inverse Kinematics Tool on page 745

Where to Start with Inverse Kinematics?
This section explains the basics of the Inverse Kinematics tool. IK works best when you lock a part of the
character to the spot, such as a foot on the floor, then select the entire body or another extremity and move it.
To lock a part in place, you use the IK Nail option.
To use the Inverse Kinematics tool:
1. In the Tools toolbar, select the Inverse Kinematics

tool or press [Alt] + [8].

2. In the Camera view, [Ctrl] + click (Windows) or [⌘ ] + click (Mac OS X) on a part of the body.
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The entire IK skeleton appears.

3. Click on a part of the body and pull on it to move the character.

4. Hold down the [Shift] key and click on the pivot belonging to the part you want to lock in place.

5. Click on another part of the character and pull on it. You can [Shift] + click on a bone to lock the
orientation of the bone.

Related Topics
•

IK Hierarchy Chains on page 731

•

Inverse Kinematics Tool Properties on the facing page

•

Setting up the Character to use IK on page 738

•

Nails on page 742

•

Minimum and Maximum Angle on page 1
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•

IK Keyframes on page 743

•

When to use the Inverse Kinematics Tool on page 745

Animating using Inverse Kinematics

Inverse Kinematics Tool Properties

•

IK Modes below

•

IK Tool Options on the next page

•

Selection on page 736

IK Modes
The IK tool has six different modes that can be found in the Tool Properties view:
•

Bone Selection Mode below

•

Chain Menu on the next page

•

IK Manipulation Mode on the next page

•

Apply IK Constraints Mode on the next page

•

Bone Editing Mode on the next page

Bone Selection Mode
The Bone Selection mode is enabled by default. This option allows you to click on any bone in your character and
move it without having to select the actual layer.
Once you disable this option, you can not move any bone except the selected one. This allows you to grab and
rotate the selected part from many angles and location. You can click completely outside the character and move
the pieces.
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Chain Menu
The Chain drop-down menu allows you to choose from three types of chain:
•

Simple Chain Mode: this is the default mode and will only allow for the movement of parts attached to a
single chain up to the point of intersection. A single chain is a straight line with no secondary chain
attached

•

Direct Chain Mode: this mode will allow the movement of parts up a simple secondary chain to a principle
chain as long as translation movement is possible (the principle chain is attached to its own peg), but will
ignore all secondary chains. A direct chain is a single chain which goes directly to the core.

•

All Chain Mode: this mode allows for the movement of all parts attached to all chains in the IK skeleton.
All chains are attached and move simultaneously when one part is moved.

IK Manipulation Mode
The IK Manipulation mode is the main working mode for the Inverse Kinematics tool. Enable this mode when you
want to animate and position your puppet.
[Ctrl] + click (Windows) or [⌘ ] + click (Mac OS X) on a body part to select it. You do not need to select a part to
be able to move it.

Apply IK Constraints Mode
The Apply IK Constraints mode is used to correct a part's position on a series of frames. For example, if the
character's foot seems to be sinking into the floor, you can correct its position and angle over a series of frames
using the IK Constrains mode.

Bone Editing Mode
The Bone Editing mode is used to fix the bone orientation on extremities such as hands and feet.

IK Tool Options
The IK tool has two special options that can be found in the Tool Properties view:
•

IK Keyframe below

•

Ease Shape on the facing page

IK Keyframe
The IK keyframe option is used in combination with the IK Constraints mode. It determines the starting frame of
the constraint you will apply.
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Ease Shape

While you animate with the IK tool, prior to doing a movement you can set an easing preset so that your motion
is not so mechanical.
Before moving your part, select a preset from the list in the drop-down menu.

If you select a new preset in the list and move the part again on the same keyframe, the easing will be
automatically updated.

Selection
With the IK tool, you are able to do the following that can be found in the Tool Properties view:
•

Enable Translation If Top of Hierarchy on the next page

•

Enable Rotation on the next page
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•

Exclude From IK below

•

IK Nails on the facing page

•

Stiffness on the facing page

Enable Translation If Top of Hierarchy

This option is mainly used on master pegs. You will need to use the Enable Translation If Top of Hierarchy option
when you have a situation such as this; if you want your character to do a perfect split (sitting down with the legs
at right angles to the body or at the sides with the trunk facing forwards), then the hip will need to translate and
not just rotate on the spot. And since IK is all about rotation, you would select the hip layer and enable the
translation option.

Enable Rotation

The Enable Rotation option is enabled by default. If you disable this option, the selected part will not be able to
rotate anymore and will remain in the same position all the time. You can use this option to simulate an arm in a
plaster cast.
When you enable this option, the pivot will disappear but you will still see the bone.

Exclude From IK
You can use the Exclude From IK option when you want certain parts of your puppet such as the eyes and mouth
to be excluded from the IK influence.
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IK Nails

IK nails are used to temporarily fix a part of a character to a spot either in translation or rotation, or to enable
maximum and minimum angle usage.

Stiffness
When a certain part is selected, you can apply a stiffness value to it. A different stiffness value can be set to each
body part individually. The greater the Stiffness value applied, the more difficult it is to make that part rotate,
thereby rendering it stiff while the other parts continue to move freely on their joints.

Related Topics
•

Nails on page 742

•

IK Hierarchy Chains on page 731

•

Minimum and Maximum Angle on page 1

Setting up the Character to use IK
The first time you display the character's skeleton, you will notice a series of bones on the extremities which are
out of place, and there may also be some elements that you would like to exclude from the Inverse Kinematics
chain.
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You should setup the skeleton before starting your animation. There are three things to do to setup the
character:
•

Connecting any Hierarchy Chain below

•

Excluding Extra Elements from IK on the facing page

•

Setting Up the Bones for the Extremities on the facing page

Connecting any Hierarchy Chain
Before fixing any bones, or excluding layers from the IK, it is important that you make sure all the elements you
want to be parented in a chain are setup.
You do not need to have a chain all over the body. It can be on the legs and arms. If the body is not completely
rigged in hierarchy, the skeleton will look a bit more messy, but the IK tool will still work without any problem.
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Excluding Extra Elements from IK

When working with the IK tool, you will probably want to move the main parts around, but not necessarily the
small ones such as the nose or ears. In this case, you can select some elements on your character and exclude
them from the skeleton.
To exclude elements from the skeleton:
1. In the Tools toolbar, select the Inverse Kinematics

tool or press [Alt] + [8].

2. In the Tool Properties view, make sure the IK Manipulation Mode

is enabled.

3. In the Camera view, [Ctrl] + click (Windows) or [⌘ ] + click (Mac OS X) on the part to exclude from the IK.

4. In the Tool Properties view, click on the Exclude from IK

button.

5. Repeat the process for every part to be excluded from the IK.

Setting Up the Bones for the Extremities
Once you remove the extra elements from your skeleton, you will want to set the bone orientation for the
extremity parts. By default they are oriented horizontally towards the right. This orientation often works for the
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feet but not necessarily for the hair or hands,
To set the bone orientation:
1. In the Tools toolbar, select the Inverse Kinematics
2. In the Tool Properties view, enable the Bone Editing

tool or press [Alt] + [8].
mode.

3. In the Camera view, click on the pivot belonging to the part you whose bone you want to reposition, then
pull the pivot in the direction you want the bone to be.

4. Repeat this process for each bone you want to position.

This command will only work on the extremities.

Related Topics
•

Animating using Inverse Kinematics on page 730
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Nails
Using the Inverse Kinematics tool, if you pull a hand the system will animate all of the character's parts included in
the hierarchy chain; the torso, the hips and the legs, depending on your rig. Often, you will only want to animate
part of a character, such as the arm and not the whole body. To do so, you need to make use of IK constraints
such as IK nails that are used to temporarily cut or constrain the chain. IK nails can be used to cut an IK chain or to
block a part on the spot. For example, you can fix a character's feet to the ground when he walks.
There are different types of constraints that can be placed on the chain:
•

IK Nail
Blocks the X, Y and Z positions.

•

Hold Orientation
Blocks the angle

•

Hold X
Blocks only the X position

•

Hold Y
Blocks only the Y position

To set an IK nail:
1. In the Tools toolbar, select the Inverse Kinematics

tool or press [Alt] + [8].

2. In the Tool Properties view, make sure the IK Manipulation Mode

is enabled.

3. In the Camera view, [Ctrl] + click (Windows) or [⌘ ] + click (Mac OS X) on the part to set a nail on.
4. In the Tool Properties view, click on the type of nail you will use.

‣

You can also hold down the [Shift] key and click on any part's pivot to set a regular nail on it without
having to select it.

‣

You can hold down the [Shift] key and click on the bone to set a Hold Orientation nail.

‣

You can select the nail type in the top menu by selecting Animation > IK Constraints > the desired
nail.
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‣

You can remove the nail at anytime using the same technique you did to place the nail. It will not affect
the animation.

5. To remove every nail except the Enable Min/Max Angle ones, in the top menu select Animation > IK
Constraints > Remove All Constraints.

Related Topics
•

Animating using Inverse Kinematics on page 730

IK Keyframes

When you animate a walking character and lock the feet down, the locked position will be perfect on the key
poses. However, when you use the Motion keyframes to auto in-between the animation, you will notice a
movement of feet. This motion is caused by the in-betweening of the rotations.
The nail holds in place the body part on the keyframe, but it will not hold it for the whole duration between
keyframes.
If you place a nail on the shoulder to move just the arm, you do not necessarily want to keep the shoulder in the
same place until the next key pose. You will probably want the shoulder, or any other part that is nailed, to have
a slight, natural motion following the main body action. Of course, this is not the case when you fix a hand or a
foot on the spot. If you have a fixed hand or foot, you will probably want it to stay exactly where you placed it.
That is why you can apply an IK constraint on a frame range and on selected body parts.
To fix the part on the same spot requires an angle (rotation) correction on the parts that are moving too much.
For example, to fix a foot that is moving too much, you will correct the angles on the foot, leg and thigh. To fix a
hand, you will correct the angles on the hand, forearm and upper arm.
To apply IK constraints on a frame range:
1. In the Tools toolbar, select the Inverse Kinematics

tool or press [Alt] + [8].

2. In the Camera view, click on the part you want to apply the constraint to.
3. In the Timeline view, set the cursor to the first frame where you want to start applying the constraint.

4. In the Tool Properties view, enable the Apply IK Constraints Mode
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5. In the Tool Properties view, click on the IK Keyframe

Animating using Inverse Kinematics

button to enter the first frame number.

6. In the Timeline view, move the playhead to the last frame where you want to apply the constraint.

The IK Keyframe field should now look like this:

7. In the Camera view, set a nail at the top of the limb you are correcting. In the case of a foot, set the nail on
the thigh by holding down the [Shift] key and clicking in its pivot.

8. In the Tool Properties view, select the type of constraint you want to apply to your piece.The most
common case is a combination of the regular Nail
and Hold Orientation
options.
9. In the Camera view, click on the bone of the part you want to apply a constraint to.
A warning message appears and requesting you to confirm that you want to add your constraint on that
particular piece and for that frame duration.

10. Click on the OK button.
Your constraint are now be applied.
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Related Topics
•

Animating using Inverse Kinematics on page 730

When to use the Inverse Kinematics Tool
This summarizes what you have read so far.
Animate provides different tools with which to animate cut-out characters and trajectories. The two main tools
used to animate characters are the Transform and the Inverse Kinematics tools.
Here, we will compare the usage of these tools and explain the Inverse Kinematics philosophy.
•

The Transform Tool

The Transform tool is also known as Forward Kinematics. This is the main tool to use for cut-out
animation. The Transform tool rotates, scales, moves and skews all the elements selected as one global
element.
Forward Kinematics means that the element will be animated from the parent element down to the last
child as a single piece. In other words, if the shoulder is animated, the arm, forearm and hand will follow
as a complete arm drawing.
•

The Inverse Kinematics Tool

The Inverse Kinematics tool (IK) is an assistance tool. This tool will help you to achieve complex motions
such as sitting down or knee bending. The Inverse Kinematics tool will move and rotate every selected
element as a chain.
Inverse Kinematics means that the element will be animated from the child element up to the parent
element. In other words, if the hand is animated, the forearm, arm and shoulder will follow the hand in a
fairly natural way in terms of the movement, rotation and bending.

Inverse Kinematics in Toon Boom Animate
In most 3D animation software, Inverse Kinematics is implemented as a skeleton system. Animate uses the
rigging hierarchy already created in the Timeline view, so there is no need to place bones in the character. Inverse
Kinematics in Animate uses the connection between each of the parts' pivots.

IK Tool and Rigging
The IK tool can not be used on every type of cut-out character. It depends on the way the pieces and parts are
attached to one another. In other words, it depends on the rigging type.
There are several ways to rig a puppet. These are the three main rigging techniques:
•

•

The Basic Rig technique is the simplest.
•

There are no connections between the parts.

•

They are free to move, rotate and scale independently one from the other.

•

The Inverse Kinematics tool CANNOT be used on this type of rigging.

The Hierarchy Rig technique is the most complex.
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•

•

All the parts are connected one to the other.

•

As they move, rotate and scale, they will influence all the other parts.

•

The Inverse Kinematics tool can be used on this type of rigging.

Animating using Inverse Kinematics

The Mix Rig technique is the best of the Basic and Hierarchy rig.
•

Some parts are independent such as the torso.

•

Some parts are setup into a hierarchy such as the arms and legs

•

The Inverse Kinematics tool can be used on this type of rigging.

Animating with the Tools
Puppets are animated by using a combination of Transform and Inverse Kinematics tools.
You will mainly use the Transform tool (Forward Kinematics) as it has all the main motions; rotate, scale, skew,
move and select. You can also control the exact position of the parts while using the Transform tool. As well, the
Transform tool creates a temporary global pivot on the selection that can be moved around for the animation
purpose.
To complete complex motions, such as bending the knees while keeping the feet on the ground, you will use
Inverse Kinematics tool as an assistance tool. By adding IK Constraints (Nails), it is possible to lock the feet or
any other parts on the spot and move the rest of the body, which will react to the constraints.

Inverse Kinematics Philosophy
It is important to keep in mind that the Inverse Kinematics tool is an assistance tool. You won't use it to animate
all the time.
Also, the Inverse Kinematics tool can be used to do the character's posing faster. Posing is a crucial part in the
animation process. The IK tool can be used to pose the character more naturally, depending on your own
preferences.
An IK Nail can be added anywhere on the character to animate only a small part of the hierarchy chain, such as an
arm or a portion or the arm.

Tips and Tricks for Inverse Kinematics
Here are some tips and tricks to help you to use the Inverse Kinematics tool.
•

IK on Mix Rigging
The Inverse Kinematics tool can be used on a full puppet's body even if it is connected as a mix rigging,
meaning some parts are rigged in a hierarchy and others not. For example, you can add IK Nails on the
puppet's feet, select the full body master peg and move the character as if it was connected in a full
hierarchy rig. This technique works on most of the mix rigging.

•

IK Constraints
It is important to remember that you can add and remove IK Constraints (Nails, Hold Orientation, etc.) at
anytime during the animation. They hold a certain part on the spot while you animate the rest of the body.
Because they are not constricting one part to another object, you can add or remove them without
affecting any of the animation you have already done.

•

Useful Shortcuts
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•

While using the IK tool, you can [Ctrl] + click (Windows) or [⌘ ] + click (Mac OS X) to select any part.

•

You can hold down the [Alt] key to rotate the selected part without affecting the IK chain.

•

You can press the [Shift] key and click in a part's pivot to add or remove an IK Nail.

•

You can press the [Shift] key and click on a bone to add or remove and Hold Orientation constraint.

Related Topics
•

Where to Start with Inverse Kinematics? on page 732
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Animating in Stop-motion

Animating in Stop-motion
To start animating your character, start by doing your key poses. In fact, most of your time will be spent doing
your key poses. It is better to work with Stop-motion keyframes as Animate will not automatically create the
interpolation between your keyframes.
When using Stop-motion keyframes, also known as step keyframes, the segment between two keyframes is
constant. There is no animation generated by the computer between the poses. The drawing will remain in
position until the next keyframe, then pops to its new position.

Creating a Stop-motion Keyframe
You can create a stop-motion keyframe in several different ways. You can have Animate create it automatically,
transform a motion keyframe into a stop-motion keyframe, or even switch your preferences to get Animate to
always create stop-motion keyframes by default.
To automatically create stop-motion keyframes:
1. In the top menu, make sure that the Animation > Stop-Motion Keyframe option is enabled.
2. In the Timeline view, select the cell where you want to add a keyframe.

3. Right-click on the selection and select Add Keyframe or press [F6]. You can also click on the
Add Keyframe
button available in the Timeline View toolbar.
‣

In the Camera view, if the Animate mode is enabled, as soon as you move the selected element, a
keyframe is automatically created on the current frame.
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To convert a Motion keyframe into a Stop-Motion keyframe:
1. In the Timeline view, select the motion keyframes to convert into stop-motion keyframes or press [S].

2. Right-click on the selection and select Set Stop-Motion Keyframes or press [Ctrl] + [L] (Windows) or [⌘ ]
+ [L] (Mac OS X). You can also click on the Stop-motion Keyframe
button available in the Timeline
View toolbar.

Related Topics
•

Animating using Computer Generated Interpolation on the facing page
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Animating using Computer Generated Interpolation

Animating using Computer Generated
Interpolation
After you have created the key poses you can animate the in-between poses yourself or let Animate do it using
motion keyframes. When you use motion keyframes, your drawings will gradually move to the next position
instead of staying on the spot until the next keyframe.

Creating a Motion Keyframe
You can create a motion keyframe in several different ways. You can have Animate create it automatically,
transform a stop-motion keyframe into a motion keyframe and even switch your preferences to get Animate to
always create Motion keyframes by default.
To automatically create motion keyframes:
1. In the top menu, select Animation > Motion Keyframe. Make sure the option is disabled.
2. In the Timeline view, select the cell where you want to add a keyframe.

3. Right-click on the selection and select Add Keyframe or press [F6]. You can also click on the
Add Keyframe
button available in the Timeline View toolbar.
‣

In the Camera view, if the Animate mode is enabled, as soon as you move the selected element, a
keyframe will be automatically created on the current frame.

To convert a stop-motion keyframe into a motion keyframe:
1. In the Timeline view, select the stop-motion keyframes to convert into motion keyframes.
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2. Right-click on the selection and select Set Motion Keyframes or press [Ctrl] + [K] (Windows) or [⌘ ] + [K]
(Mac OS X). You can also click on the Motion Keyframe
button available in the Timeline View toolbar

Related Topics
•

Animating in Stop-motion on page 748

Adjusting the Ease

To add ease in and ease out on your motion paths, you can display the function curve and modify the Bezier or
Ease curve. To apply an ease to multiple functions and keyframes, you can use the Set Ease for Multiple
Parameters feature and set the amount which you want.
The Velocity, or ease, is used on motion keyframes. The Velocity has to be adjusted directly on the function curve
in either the Function view or the Function editor. When a keyframe is selected, easing values appear in the right
handle and left handle fields, as well as Bezier handle or Ease wheel controls on each selected keyframe. Pull on
them to adjust the ease in and ease out, or type values in the fields.
•

Adjusting the Velocity in the Function View on the facing page

•

Adjusting the Velocity on Multiple Elements Concurrently on page 753
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Creating a Motion Keyframe

Adjusting the Velocity in the Function View
To adjust the velocity in the Function view:
1. In the Timeline view, click on the Expand Function

button to display all of the layer's functions.

2. Double-click on the desired function.

The Function Editor opens.

Note that the Function Editor will not be displayed if the function does not already exist.

3. Select a keyframe and pull on its Bezier handles or Ease wheel to adjust the velocity.
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Adjusting the Velocity on Multiple Elements Concurrently
If you have several functions you would like to adjust the velocity for at the same time, such as the hand, forearm
and arm of a cut-out character, you can use the Set Ease for Multiple Parameters dialog box. It allows you to
apply the same velocity parameters to all the selected keyframes in one frame.
To set an ease for multiple parameters:
1. In the Timeline view, select a keyframe from one or many layers.
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Creating a Motion Keyframe

Only the first keyframe selected on a given layer will be considered when using the Set Ease For
Multiple Parameter function. If many keyframes are selected on the same layer, the ease values will
only be applied to the first one, the rest will be ignored.

2. In the Timeline view,right-click and select Set Ease For Multiple Parameters. In the Timeline View
toolbar, you can click on the Set Ease For Multiple Parameters
button. If the button is not in the
Timeline View menu by default, you can add it through the Toolbar Manager (Customize).
The Set Ease For Multiple Parameters dialog box opens.

3. In the graph interface, pull on the Bezier handle to adjust the velocity for all the selected functions.

4. If you want to apply these easing parameters to a certain type of function only, such as Rotation or Scale,
in the Filters section, disable the function types you do not want to affect.
‣

Motion: If this option is enabled, the easing parameters will be applied to the selected Position X,
Position Y, Position Z and 3D Path functions

‣

Rotation: If this option is enabled, the easing parameters will be applied to the selected Angle
functions.

‣

Scale: If this option is enabled, the easing parameters will be applied to the selected Scale functions.

‣

Skew: If this option is enabled, the easing parameters will be applied to the selected Skew functions.

‣

Morphing: If this option is enabled, the easing parameters will be applied to the selected Morphing
Velocity functions. Note that it applied to the Morphing velocity function found in the Layer Properties
dialog and not to the basic morphing ease in the Tool Properties view.
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‣

Other: If this option is enabled, the easing parameters will be applied to all the other selected
functions such as all functions created to animate effect parameters.

5. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values are
calculated in percentage.
‣

In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding to the
length of time you want the easing to last for. The value must be between 0% and 100%.

‣

In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong you want
the easing out to be. The value must be between 0% and 100%.

‣

If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

6. Once done, click on one of the following button:
‣

Apply: This will apply the easing parameters to the selected keyframes.

‣

Apply/Previous: This will apply the easing parameters to the selected keyframes and then selects the
previous keyframe in the timeline.

‣

Apply/Next: This will apply the easing parameters to the selected keyframes and then selects the next
keyframe in the timeline.

‣

Close: This closes the dialog box. If you did not apply the modifications, they will be cancelled.

Related Topics
•

Animating using Computer Generated Interpolation on page 750

755

Chapter 15: Cut-out Animation
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Flipping Through Poses

When animating, it is useful to flip through your poses to see the flow of your animation without going through
each frame in your Timeline. Animate lets you flip between the selected element's keyframes.
To flip through your poses:
1. In the Camera or Timeline view, select the layer you want to see the poses for.

2. In the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe. The keyboard
shortcuts are [;] and ['].

Related Topics
•

Keyframes and Drawing Blocks on page 716

•

Creating a Simple Cut-out Animation on page 718
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•

Selecting Layers to Animate or Position on page 721

•

Navigating the Hierarchy on page 725

•

Animating using the Transform Tool on page 727

•

Animating using Inverse Kinematics on page 730

•

Animating in Stop-motion on page 748

•

Animating using Computer Generated Interpolation on page 750

•

Using the Onion Skin in Cut-out Animation on the facing page

•

Animating Using Symbols on page 1

•

Reusing Extra Drawings, Poses and Facial Expressions on page 1

•

Swapping Images on page 763

•

Adding a New Drawing on page 766

•

Ordering Layers Over Time on page 767

•

Resetting a Transformation on page 769

•

Offsetting Part of an Animation on page 1

757

Chapter 15: Cut-out Animation

Using the Onion Skin in Cut-out Animation

Using the Onion Skin in Cut-out Animation

When animating cut-out characters, it is useful to see the previous and next frames on the animation. However, it
can sometimes be confusing to see the onion skin for every part of the character. You will often only want to see
the onion skin on a single part or a few parts, such as the arm, that are currently being animated. Animate offers
that possibility.
While animating in the Camera view, there are four different onion skin options:
•

Add to Onion Skin on the next page

•

Remove from Onion Skin on the next page

•

Remove Unselected from Onion Skin on the next page

•

Add All to Onion Skin on page 760

•

Remove All from Onion Skin on page 760

You can enable these options in the menu or manually in the Timeline view using the layer's Show Onion Skin
button. Unless you change the onion skin options when you display the onion skin, only the selected layers will be
displayed in the onion skin preview.
To use the onion skin options:
1. In the Tools toolbar, enable the Onion Skin

option or press [Alt] + [O].

2. In the Tools toolbar, click on the Transform

tool or press [Shift] + [T].

3. In the Camera view, select one or many elements.
4. In the top menu, select View > Onion Skin > Add to Onion Skin, Remove From Onion Skin, Remove
Unselected from Onion Skin, Add All to Onion Skin or Remove All from Onion Skin.
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Add to Onion Skin

The Add to Onion Skin command is used to add a series of selected elements to the onion skin preview. The
keyboard shortcut is [Shift] + [S].

Remove from Onion Skin

The Remove From Onion Skin command is used to remove a series of selected elements from the onion skin
preview.

Remove Unselected from Onion Skin
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Add All to Onion Skin

The Remove Unselected from Onion Skin command is used to remove all elements except the ones selected from
the onion skin preview.

Add All to Onion Skin

The Add All to Onion Skin command is used to add all of the scene's elements to the onion skin preview. The
keyboard shortcut is [Alt] + [Shift] + [O].

Remove All from Onion Skin

The Remove All Onion Skin command is used to remove all of the scene's elements from the onion skin preview.
The keyboard shortcut is [Ctrl] + [Shift] + [O] (Windows) or [⌘ ] + [Shift] + [O] (Mac OS X).

Related Topics
•

Flipping Through Poses on page 756
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Flipping Parts

If you want to flip a part, a limb or a whole puppet, use the Transform tool and the Flip Horizontal and Flip
Vertical options.
To flip a selection
1. In the Animation Tools toolbar, select the Transform

tool or press [Shift] + [T].

2. In the Tool Properties view, make sure that the Peg Selection Mode

is disabled.

3. In the Camera view, select the parts to be flipped.

4. In the Tool Properties view, click on the Flip Horizontal
shortcuts are [4] and [5] respectively.
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Flipping Parts

If the scaling parameter is not set to Separate Scale, the flip is not applied to the selection.

Related Topics
•

Keyframes and Drawing Blocks on page 716

•

Creating a Simple Cut-out Animation on page 718

•

Selecting Layers to Animate or Position on page 721

•

Navigating the Hierarchy on page 725

•

Animating using the Transform Tool on page 727

•

Animating using Inverse Kinematics on page 730

•

Animating in Stop-motion on page 748

•

Animating using Computer Generated Interpolation on page 750

•

Flipping Through Poses on page 756

•

Using the Onion Skin in Cut-out Animation on page 758

•

Animating Using Symbols on page 1

•

Reusing Extra Drawings, Poses and Facial Expressions on page 1

•

Swapping Images on the next page

•

Ordering Layers Over Time on page 767

•

Resetting a Transformation on page 769
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Swapping Images

Cut-out animation is not only about moving parts around, it's also about swapping drawings to give the
animation a more traditional animation look.
You can add as many new drawings as you want in your character parts symbols and use them in your current
animation. You can also add new drawings directly in your scene or import them from the library.
You do not need to remember the frame on which you drew or imported the drawings as you will be able to see
them in the Drawing Substitution's interface.
You cannot swap a symbol for another one, only the symbol's frames or layer's drawings.
You can swap images in the Timeline or Library view. When you use the Drawing Substitution window in the
Library view, you are not selecting drawings from the Library but from drawings contained in your scene's layers.
To swap images in the Library view:
1. In the Camera view, with the Transform

tool.

2. In the Tool Properties view, make sure that the Peg Selection Mode

option is disabled.

3. In the Camera view, select the part you want to swap using the Transform

4. In the Library view, go to the Drawing Substitution panel.
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Swapping Images

5. Move the substitution slider to the right or left to scroll through the symbol's frames or drawings. The
keyboard shortcuts are [ [ ] + [ ] ] to perform the scroll, or from the top menu select Animation >
Substitute Drawing Previous or Substitute Drawing Next.

The drawing or symbol's cell on the current frame is replaced by the selected one.

To swap images in the Timeline view:
1. In the Timeline view, click on the Show Data View

button to expand the Data view.

2. In the Timeline view's right side, select the cell containing the drawing or symbol's cell to swap.

3. In the Data view, drag the pointer left or right to change the cell or drawing exposed for another one. You
can also directly type the drawing name or symbol's cell number if you know it.
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Related Topics
•

Keyframes and Drawing Blocks on page 716

•

Creating a Simple Cut-out Animation on page 718

•

Selecting Layers to Animate or Position on page 721

•

Navigating the Hierarchy on page 725

•

Animating using the Transform Tool on page 727

•

Animating using Inverse Kinematics on page 730

•

Animating in Stop-motion on page 748

•

Animating using Computer Generated Interpolation on page 750

•

Flipping Through Poses on page 756

•

Using the Onion Skin in Cut-out Animation on page 758

•

Flipping Parts on page 761

•

Animating Using Symbols on page 1

•

Reusing Extra Drawings, Poses and Facial Expressions on page 1

•

Adding a New Drawing on the facing page

•

Ordering Layers Over Time on page 767

•

Resetting a Transformation on page 769

765

Chapter 15: Cut-out Animation

Adding a New Drawing

Adding a New Drawing
If you need to add a new drawing in your scene, you can either do it inside the body part's symbol or, if you do
not use symbols, directly on the part's layer by duplicating the existing drawing on the current frame.

Duplicating a Drawing
If your character does not use symbols, you need to duplicate the drawing on the cell where you need to use a
new drawing. You could also create a new blank drawing, but duplicating the existing drawing allows you to
keep the pivot you previously set and you can also reuse a portion of the existing artwork. When you create a
new drawing, you get a blank cell with a pivot set at the centre of the Camera view.
To duplicate a drawing:
1. In the Timeline or Camera view, select the drawing to duplicate.

2. In the top menu, select Drawing > Duplicate Drawing or press [Alt] + [Shift] + [D].
The new drawing appears in the currently selected cell.

3. In the Camera view, draw the new piece.

Related Topics
•

Keyframes and Drawing Blocks on page 716

•

Creating a Simple Cut-out Animation on page 718

•

Flipping Through Poses on page 756

•

Using the Onion Skin in Cut-out Animation on page 758

•

Flipping Parts on page 761

•

Reusing Extra Drawings, Poses and Facial Expressions on page 1

•

Swapping Images on page 763
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Ordering Layers Over Time

The layer ordering system in Animate saves time and simplifies your work. There is no need to create a new layer
or to copy and paste artwork into other layers to change the order. The Z-axis (forward - backward) allows the
user to create a multiplane and move elements closer to or further away from the camera. This allows the
puppet's pieces to be moved in front or behind the other ones without physically changing the layer position.

Animate provides you with a shortcut to move the piece with a micro nudge on the Z-axis. The program creates
a keyframe where different Z values can be entered. This allows for the piece to move forward and backwards in
space without having to change the drawing's original position or break the layer hierarchy.
This also means that the layer ordering is maintained throughout the whole scene. You can combine animation
assets so that the system can interpolate them.
To nudge elements on the Z-axis:
1. In the Tools toolbar, select the Transform
2. In the Tools toolbar, enable the Animate

tool or press [Shift] + [T].
mode.
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3. In the Camera view, click on the part to be repositioned and hold down the [Alt] key. Using the [Up] or
[Down] arrow keys, nudge the part until it moves to the desired position. Make sure that the Camera view
has a red outline around it.

Related Topics
•

Keyframes and Drawing Blocks on page 716

•

Creating a Simple Cut-out Animation on page 718

•

Animating in Stop-motion on page 748

•

Animating using Computer Generated Interpolation on page 750

•

Flipping Through Poses on page 756

•

Using the Onion Skin in Cut-out Animation on page 758

•

Flipping Parts on page 761

•

Swapping Images on page 763

•

Adding a New Drawing on page 766

•

Resetting a Transformation on the next page

•

Offsetting Part of an Animation on page 1
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Resetting a Transformation
You may want to reset your character's position if you have made too many transformations and it is not going
where you want it to go, or simply because you want to reset a pose you are reusing from another animation.
Once your layers are positioned in the Camera view, you can easily reinstate them to their original position.

When using the Transform tool to select element in the Camera view, always make sure that the Peg
Selection Mode option in the Tool Properties view is disabled or else it will limit the selection to peg
only.

In the Timeline view, you can also use the Clear All Values command to reset all transformation
values on the selected layers. Right-click on the selected layers and select Layers > Clear All Values.

There are three different ways to reinstate a transformation:
•

Reset below

•

Reset All below

•

Reset All Except Z on the facing page

Reset
Use the Reset command to reset the value of the selected element to the initial value of the active tool. For
example, if the Rotate
tool is active, the transformation angle will be reset to 0 and if the Transform
tool
is active, the entire transformation values will be reset.
To reset the transformation on the current frame:
1. In the Tools toolbar, select the Transform

tool or any Advanced Animation

tools.

2. In the Timeline or directly in the Camera view, select the drawing layers you wish to reset. You can select
more than one layer at a time.
3. Select Animation > Reset or press [Shift] + [R].
The selected layers will automatically return to their original position.

Reset All
The Reset All option will reset all transformations on the current frame in a selected layer. Your keyframe will
remain, but all the values will be reinstated to the default position. It will reset all the transformation regardless
of the tool you are using.
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To reset all transformations on the current frame:
1. In the Tools toolbar, select the Transform

tool or any Advanced Animation

tools.

2. In the Timeline or directly in the Camera view, select the drawing layers you wish to reset. You can select
more than one layer at a time.
3. Select Animation > Reset All.
The selected layers will automatically return to their original position.

Reset All Except Z
The Reset All Except Z option will reset all the transformations on the current frame except the Z position. This is
useful when doing cut-out animation. Cut-out puppets often have a particular Z ordering for the different views
of a character. You might want to reset the transformation, but not necessarily the Z position. To do so, you
need to use the Reset All Except Z option.
To reset all transformations except the Z position on the current frame:
1. In the Tools toolbar, select the Transform

tool or any Advanced Animation

tools.

2. In the Timeline or directly in the Camera view, select the drawing layers you wish to reset. You can select
more than one layer at a time.
3. Select Animation > Reset All Except Z.
The selected layers will automatically return to their original position, except for the Z values.

Related Topics
•

Creating a Simple Cut-out Animation on page 718
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Creating Cycles
If you want to cycle a portion of your animation, you can use the Paste Cycle command. You can also use the
Paste Reverse command to completely reverse the flow of your animation.
To use the Paste Cycle command:
1. In the Xsheet or Timeline view, select the cell range (or symbol cells) and keyframes to loop.

2. In the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4. In the top menu, select Edit > Paste Cycle or press [Ctrl] + [/] (Windows) or [⌘ ] + [/] (Mac OS X).
The Paste Cycle dialog box opens.

5. In the Number of Cycles field, use the up or down arrows to increase or decrease the number of cycles you
want to paste. You can also type the value directly.
6. In the Cycle Type drop-down menu, select the type of cycle you want to paste.

‣

Normal (forward): Pastes your selection as it is, starting with the first cell and ending with the last
one.

‣

Reverse: Pastes your selection reversed, beginning with the last cell and ending with the first one.

‣

Forward -> Reverse: Pastes your selection as a yo-yo, starting with the first cell, going to the last one
and ending with the first cell.
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‣

Creating Cycles

Reverse -> Forward: Pastes your selection as a reversed yo-yo, starting with the last cell, going to the
first one and ending with the last cell.

7. Click on the OK button to paste your cycles.

You can do the same operation using the Paste Special dialog box. To open the Paste Special dialog
box, select
Edit > Paste Special or press [Ctrl] + [B] (Windows) or [⌘] + [B] (Mac OS X).

To use the Paste Reverse command:
1. In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.

2. In the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.
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4. In the top menu, select Edit > Paste Reverse or press [Ctrl] + [.] (Windows) or [⌘ ] + [.] (Mac OS X).

Related Topics
•

Keyframes and Drawing Blocks on page 716

•

Creating a Simple Cut-out Animation on page 718

•

Navigating the Hierarchy on page 725

•

Flipping Through Poses on page 756

•

Using the Onion Skin in Cut-out Animation on page 758

•

Creating Cycles on page 771

•

Preferences on page 1
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Copying and Pasting Animation
As you animate you will find that you may reuse a lot of positions, drawings and keys. However, you may only
want to paste the drawings, or just the keys or maybe everything. There are different paste options available in
the Timeline view which will give you the maximum flexibility when reusing and pasting.
There are three different modes for pasting your selection:
•

Paste Mode: All Drawing Attributes
Pastes the drawing exposure and keyframes.

•

Paste Mode: Keyframes Only
Pastes only the keyframes.

•

Paste Mode: Exposures Only
Pastes only the drawing exposure.

To paste a selection using different modes
1. In the Timeline view, select the cells (or symbol cells) you want to copy and paste.

2. Select Edit > Copy cells from the Timeline.
3. In the Timeline view's left side, enable the desired Paste

mode.

4. In the Timeline view's right side, select the cell where you want to paste your selection.

5. Select Edit > Paste Cells in the Timeline.

Note these modes also apply when you use drag instead of copy/ paste.

Paste Mode: All Drawing Attributes
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Paste Mode: Keyframes Only

Paste Mode: Exposures Only

Related Topics
•

Keyframes and Drawing Blocks on page 716

•

Creating a Simple Cut-out Animation on page 718

•

Animating using the Transform Tool on page 727

•

Swapping Images on page 763
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Adding Pegs

Adding Pegs
Now that you have your puppet on your stage, you probably need to resize and reposition it to fit your scene.
When you need to scale down or move your character it's a good idea to hook (attach) the whole puppet to a
trajectory.
In Animate, there is a type of layer you can add to your timeline allowing you to create a motion path or
reposition drawings. This trajectory layer is called a Peg. Any drawing or layer you hook to a peg will follow the
defined motion path, rotation, scaling and skewing information.
Attaching your puppet to a peg will allow you to scale it and reposition it without having to do it on all of your
different parts and pieces. Only one layer will contain the position information, this makes your animation easier
to modify and control.
To add a repositioning peg:
1. In the Timeline view, click on the Add Peg

button.

2. In the Timeline view, select all of the layers you want to attach to your new peg.
3. Drag your selection right on the peg layer to parent all your character's pieces to the peg.

Next, you need to position your character on the stage by moving it and scaling it to the correct size. You will not
scale each layer individually. You either want to do it on the top symbol or top peg layer.
To reposition the character:
1. In the Timeline view, select the top peg layer (master peg).
2. In the Tools toolbar, select the Transform

tool and disable the Animate
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3. In the Camera view, position the character.

Related Topics
•

Creating a Simple Cut-out Animation on page 718

•

Selecting Layers to Animate or Position on page 721

•

Navigating the Hierarchy on page 725
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Chapter 16: Effects

Once your animation is completed, you can add effects such as blurs and glows to make your project look even
better! Animate provides you with a series of essential effects that you can add to your layers.

Topics Covered
•

Adding Effects on the facing page

•

Animating an Effect Over Time on page 784

•

How Does an Effect Work? on page 786

•

Using Effects on page 788

•

Extra Commands on page 1

•

Effects Preferences on page 828
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Adding Effects

In Animate, to add an effect to your Timeline view, add an effect layer, connect the desired layer to it and adjust
the parameters until you get the look you want.
•

Adding Effects Through the Timeline View below

Adding Effects Through the Timeline View
To add effect in the Timeline view:
1. In the Timeline view, click on the Add Layers button and from the Layers drop-down menu, select Effects
> the desired effect. You can also select Insert > Effects > the desired effect from the top menu.

2. The effect appears in the Timeline view.
3. Drag the drawing layer on the new effect layer to parent them.
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4. In the Camera view, click on the Render View Mode

button to see the result of rendering the scene's

current frame and the effect .
5. In the Timeline view, double-click on the effect layer to open the Layer Properties view.
The Layer Properties view opens, displaying the parameters available for the selected effect.

6. In the Layer Properties view, adjust the effect’s parameters.
7. In the Camera view, click on the Update Preview

button to update the rendered preview.

8. To play back your scene with the final effects, in the Playback toolbar, click on the Render and Play
button.

Once you have set the parameters for your effect, you can store it in the Library view as a template
so you can quickly reuse it later on without having to set the parameters again.
Refer to Creating a Template on page 540 to learn more about creating templates.
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Previewing Effects
Most effects need to be rendered in order to be previewed properly. Some effects can be displayed in the
OpenGL view, but most of them have to be rendered and previewed in the Render Mode of the Camera view.
To preview your effects:
1. In the Camera view, click on the Render Mode

button.

In the Camera view bottom left corner, the Preview Update

button indicates the status of the

rendering. Depending on the size of the frame to render, it might take several seconds.
When the rendering is in progress, you will see the progress wheel icon, and once the progress is
completed, you will see the Up-to-date Preview icon.

Once you preview your effect, you might want to adjust it. By default, as soon as you modify a parameter,
Animate will recalculate the preview image. If your scene is rather heavy and you do not want the system to
perform the render preview automatically, you can disable the Auto-Render option and request the preview
update yourself.
To disable the Auto-Render option:
1. In the Camera view bottom left corner, click on the Preview Update

button to open the quick access

menu.
2. Disable the Auto-Render option.

‣

In the Rendering toolbar,

Once the Auto-Render option is disabled, you will need to request the preview update. You can do so by either
clicking on the Preview Update
button, or by using the Rendering toolbar.
To update the rendering preview:
1. In the Camera view's bottom left corner, click on the Preview Update
menu.
2. Click on the Auto-Render option.
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Note that you cannot playback your animation in Render mode. You need to actually perform a
render, or preview render, to see your animation with the final effects. See Previewing and Playing
Back Effects on page 826.

Related Topics
•

Previewing and Playing Back Effects on page 826

783

Chapter 16: Effects Animating an Effect Over Time

Animating an Effect Over Time
In Animate, to animate an effect over time, create a function curve by adding keyframes to the parameters you
want to animate. To do this, you will use the Layer Properties view and the Timeline view. You can fine tune your
animation using the Function view.
To animate an effect over time:
1. In the Timeline view, add the effect and connect the layers to it. See Adding Effects Through the Timeline
View on page 780.

2. Select the Effect layer.

3. To create the function curve:
‣

In the Layer Properties view, click on the Function

button you want to animate to create a

function curve.

OR
‣

You can also expand the effect layer's parameters in the Timeline view by clicking on the Expand
Function button and add a keyframe using the [F6] key to the parameter you want to animate.

4. In the Timeline view, click on the Show Data View

button.

5. In the Timeline view, go to the frame where you want to start animating the effect.

6. In the Data view, click on the Add Keyframe

button.

7. In the Value field scroll to the keyframe value or type the value in the field.
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‣

If your keyframes are stop-motion keyframes, in the Timeline view, select the new keyframes. Rightclick on the selection and select Set Motion Keyframe.

8. Repeat this process for each keyframe to be added.

Refer to the Previewing and Playing Back Effects on page 826 to learn how to preview animated
effects.
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How Does an Effect Work?
An effect always needs a drawing connection and sometime a matte or shape connection. A matte provides
drawing information that will be used to determine the area where the effect will be applied on the drawing. The
details and colours within the matte drawing do not matter, as the system will only use the shape and
transparencies in it. A matte is also known as mask.
The matte principle can be demonstrated on the Tone effect.

The drawing layer is connected in the right port of the effect and the matte (mask) in the left port. The Tone
effect then applies darker colours where the matte overlaps the image, blurs the tone edge, and finally clips out
the extra tone zone outside of the drawing before outputting a final drawing with a tone.
The tone's parameters can be adjusted in the Layer Properties view and any of them can be linked to a function
column to be animated over time. This means that all of the effects can be customized.
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Related Topics
•

Using Effects on the facing page
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Using Effects
Here is the list of the main effects available in Animate. Each effect and how to use it is described in the
corresponding section.
•

Blending on the next page

•

on page 792

•

Blur on page 793

•

Brightness and Contrast on page
794

•

Colour-Card on page 795

•

Colour-Override on page 796

•

Colour-Scale on page 813

•

Mask on page
814

•

Glow on page
815

•

Highlight on
page 817

Related Topics
•

How Does an Effect Work? on page 786

788

•

Motion Blur

•

Quadmap on page
819

•

Shadow on page 820

•

Tone on page 822

•

Transparency on page
824
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Blending

Effects modules, like the Tone module and Highlight module, can control the colour and alpha composite
operations for you. These modules were created with pre-set colour and alpha composite operations to fit the
most frequently used, composite operations.
You might, however, still want to control the colour and alpha composite operation between two images using
the Blending module, to create a multiplicity of lighting, shadow, filter or ambient effects. The Blending module
combines two images into one output image, following the parameters you choose for your movie and images
sequence or SWF movie exports.
The drawing module connected to the Blending effect will act as the blending image and will be applied to all the
drawing layers situated under them in the Timeline view order.

Use the Blending editor to control the settings of the Blending effect.

•

Name: Use this field to rename the module.

789

Chapter 16: Effects Blend Mode and SWF Blend Mode

•

Blend Mode: Choose the blending effect mode you wish to apply to your layer. The Blend Mode type will
only be visible when the Camera view is set to Render
mode and will only export to a bitmap movie
file or sequence of images.

•

SWF Blend Mode: Choose the blending effect mode you wish to apply to your layer. The SWF Blend
Mode result will only be visible when exported to a SWF movie.

Blend Mode and SWF Blend Mode
Both the Blending module and Composite-Generic module have regular blending modes and legacy blending
modes. The regular blending modes will take the source images and unmultiply them before blending the two
inputs together. The images will be remultiplied when being output from the module. The legacy blending
modes use the pre-multipled source images as is in order to apply the effect. Unmultiplying the images before
processing them will give a final result closer to what can be found in software such as Adobe Photoshop.
Here is a list of the available Blending modes:
•

Normal: The layer attached to the effect acts as a normal layer and will not create any blending mode
effect.

•

Multiply: This operation multiplies the blending element colour with the output image. This will darken
the colour of the overlapping area.

•

Screen: This operation multiplies the inverted colour of the blending element with the image. This will
lighten the colour of the overlapping area.

•

Lighten (Lighten Legacy): This operation lightens the area of the output image which, is darker than the
blending element’s colours. The lighter colours will remain unchanged.

•

Darken: This operation darkens the area of the output image, which is lighter than the blending element’s
colours. The darker colours will remain unchanged.

•

Difference (Difference Legacy): This operation subtracts the blending elements colour from the output
image colours or vice-versa, depending on which of them has more bright colours. The final result will be
colours that are more vibrant.

•

Add (Add Legacy): This operation lightens the output image using the blending element.

•

Subtract (Subtract Legacy): This operation darkens the output image using the blending element.

•

Invert: This operation inverts the output image colours on the area overlapping the blending layer
colours.

•

Overlay (Overlay Legacy): This operation multiplies or screens the colours from the blending image, with
those of the output image, depending on the base colour. Colours from the blending element overlay the
colours of the drawing elements, while preserving the highlights and shadows of the base colour. The
base colour is not replaced, but mixed with the blend colour to reflect the lightness, or darkness, of the
original colour.

•

Hardlight (Hardlight Legacy): This operation multiplies, or screens, the colours of the blending layer with
those of the output image, depending on the blend colour. If the blend colour is lighter than 50% grey, the
image is lightened, as if it were screened. This is useful for adding highlights to an image. If the blend
colour is darker than 50% grey, the image is darkened, as if it were multiplied. This is useful for adding
shadows to an image. Painting with pure black or white results in pure black or white. Play with the
Opacity value to create a subtler look.
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•

Alpha: This operation will blend the alpha value of the blending layer with the output image. This effect is
not available for SWF Blend Mode.

•

Erase: This operation produces a cutter effect using the blending element. This effect is not available for
SWF Blend Mode.

•

Divide (Divide Legacy): This operation divides the output image colour values by the blending layer
colour values. The blending image colour values are inverted, creating a negative image. The negative
image’s colour values are then multiplied by the right image colour values. This effect is not available for
SWF Blend Mode.

•

Replace: This operation replaces the output image by the blending layer. This effect is not available for
SWF Blend Mode.

•

Softlight: This operation darkens or lightens the colours in a soft and diffuse way, depending on the
blend colour (image in left port). If the blend colour is lighter than 50% grey, the image is lightened. If the
blend colour is darker than 50% grey, the image is darkened. Painting with pure black or white produces a
distinctly darker or lighter area, but does not result in pure black or white.

•

Linear Light: This operation burns or dodges the colours by decreasing or increasing the brightness
depending on the colour of the underlying colour. If the blend colour is lighter than 50% grey, the colour is
lightened because the brightness is increased. If the blend colour is darker than 50% grey, the colour is
darkened because the brightness is decreased.

•

Pin Light: This operation will replace the colours, depending on the underlying colour . If the blend colour
is lighter than 50% grey, pixels darker than the underlying colour are replaced, and pixels lighter than the
underlying colour do not change. If the blend colour is darker than 50% grey, pixels lighter than the
underlying colour are replaced, and pixels darker than the underlying colour do not change.

•

Vivid Light: This operation burns or dodges the colours by decreasing or increasing the brightness
depending on the colour of the underlying colour. If the colour is lighter than 50% grey, the blend colour is
lightened because the contrast is decreased. If the colour is darker than 50% grey, the blend colour is
darkened because the contrast is increased.

•

Exclusion: This operation produces a similar result to the Difference mode, but with a lower contrast.

•

Dodge: This operation will lighten the colour.

•

Burn: This operation will darken the colour.

•

Hue: This operation will result in a colour that will take the luminosity and saturation of the underlying
colour, and the hue of the source colour.

•

Saturation: This operation will result in a colour that will have the same luminosity and hue of the
underlying colour, and the saturation of the source colour.

•

Colour: This operation will result in a colour that will have the luminosity of the underlying colour, and the
hue and saturation of the source colour.

•

Luminosity: This operation will result in a colour which has the hue and saturation of the underlying
colour, and the luminosity of the source colour. This mode is opposite to the Colour mode.

It is possible to select two different blending modes in the same Blending effect layer, in the event
that you want to export your project to both a Bitmap and an SWF movie file with different results.
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Related Topics
•

Using Effects on page 788

The Directional-Blur effect creates the effect of a motion blur that pulls and smears the image from one contour
edge to a different direction or angle. This effect is useful in creating the impression of speed, such as the streaks
of colour that follow a car travelling at high speed.

Use the Directional-Blur editor to control the settings of the Directional-Blur effect.

•

Truck Factor: Activated by default, this option readjusts the blur when the elements undergo a change of
depth or scale. When this option is disabled, the effect's values will remain unchanged regardless of any
depth or scale changes. We recommended that this option be disabled when multiple drawings are
composited and attached to this effect. You can attach these values to function curves
to change
them over time.

•

Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur
radius is affected by the drawing scale and camera position.
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•

•

Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value between 0 and
1.
•

A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.

•

A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.

Angle: The direction of the blur. Enter a value from 0 to 360.
•

0: blurs the image to the west.

•

90: blurs the image to the south.

•

180: blurs the image to the east.

•

270: blurs the image to the north.

•

Direction of trail: If you do not set an Angle for the direction of the blur, you can select a direction (north,
south, east, or west) from this menu. The calculations for this feature are faster than the calculations for
the Angle setting.

•

Ignore Alpha: This option controls the leading edge of the blur. Deselect this option for a solid or hard
leading edge on the blur.

•

Extra Final Blur: This option causes the software to apply a second blur after the Directional-Blur is
created. If you have aDirectional-Blur that begins at 0 and gradually gets stronger, disable this option to
ensure a smooth progression.

Related Topics
•

Using Effects on page 788

Blur

The Blur effect creates an effect that softens, fogs or obscures the image evenly in all directions. This effect is
useful when you want to make cloudy images not realistically seen in detail, such as a drawing object that is
farther back or in the background of your scene, usually blurry due to the laws of atmospheric perspective. Other
uses include the general softening of objects such as snow, stars and shadows that do not naturally have a hard
outline.
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Use the Blur editor to change the values of the Blur effect.

•

Truck Factor: Activated by default, this option reads only the blur when the elements undergo a change
of depth or scale. When this option is disabled, the layer's values will remain unchanged regardless of any
depth or scale changes. It is recommended that this option be disabled when multiple drawings are
composited and attached to this effect.

•

Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur
radius is affected by the drawing scale and camera position.

•

Quality: Select High for a slow and accurate operation or Low for a faster operation with a more raw
look.

Related Topics
•

Using Effects on page 788

Brightness and Contrast

The Brightness and Contrast effect is used to modify the brilliance or dullness of an image or to create a greater
difference between the lights and darks of an image by increasing their respective intensities. This effect can be
used when an image appears too flat. Increasing the brightness or contrast can give a drawing a more attractive
and 3D quality. This can be useful if you want to push your background to the rear by making it look dull and flat
and pulling your foreground elements to the front by giving them a higher contrast.
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Use the Brightness and Contrast editor to change the values of the Brightness and Contrast effect.

•

Brightness: A value that is less than 0 will darken the image; a value greater than 0 will brighten it. Attach
a Bezier or Ease function to change the brightness over time.

•

Contrast: A value that is less than 0 will reduce contrast; a value greater than 0 will increase contrast.
Attach a Bezier or Ease function to change the contrast over time.

Related Topics
•

Using Effects on page 788

Colour-Card

The Colour Card is a solid background the same size as the camera. The Colour Card can be used to fill the
scene's background with a solid colour when there is no background image. If no background or colour card is
added to the scene, the resulting export will appear with a black background.
By default, the Colour Card has a Z ordering value of 12 Backward. This will cause the Colour card to be
behind all elements that have a value lower than 12 Backward. Most of the time, the Colour card will appear
automatically behind all of your scenes elements as they are all set to 0 Backward, except is you started playing
with the Z ordering of your scene components. At that point, the Colour Card will be in front of the elements
that are pushed back to more than 12 fields backward.
Use the Colour Card editor to change the colour values.
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•

Depth: Animate uses the Depth value to determine composition order when the Z value of two elements
is the same.

•

Offset Z: Enter the front-back position of the Colour Card layer in 3D space. This value can be verified in
the Top view.

•

Red/Green/Blue/Alpha: In these fields you can enter a static value for a colour and transparency of the
Colour Card or you can attach these parameters to function columns to change their values over time.
Click on the Colour rectangle to open the Colour Picker window and select a colour.

Related Topics
•

Using Effects on page 788

Colour-Override

The Colour-Override processes the colours in a drawing layer. The drawings in this layer must be TVG files.
Using this effect you can change colours from the palette without affecting the actual palette, swap clone
palettes, replace a specific colour zone with a bitmap texture or hide and display selected colours.

Use the Colour-Override effect to:
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•

Change colour values in drawings during the compositing process.

•

Use colour values from a specific colour palette in the palette list.

•

Establish the priority of override palettes in the palette list. For example, you may have different clones of
the same palette, for example a daytime and nighttime version.

•

Isolate specific areas of a drawing by selecting certain colours. For example, using specific colours to
generate a matte for a glow effect.

•

Hide certain colours.

Use the Colour-Override editor to set the colour override operations for TVG elements and their drawings.

Colour-Override Editor Interface

The Colour-Override editor interface is comprised of four sections:
•

Palettes below

•

Colours on the facing page

•

Palette Overrides on the facing page

•

Colour Overrides on page 799

Palettes
This section displays the palettes in the palette list of the selected layer. Drag these palettes into the Palette
Overrides section to re-order them. You can load additional palettes in the palette list from either your project,
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by clicking on The Palette
•

The Palette

button, or your computer by clicking on the Browse

button.

button allows you to load a palette contained within the project hierarchy (Environment,

Job, Scene and Elements).
•

The Browse

button allows you to load a palette located outside the project hierarchy, anywhere on

your system or server.

Colours
This section displays the colours swatches of the selected palette. Drag a swatch into the Colour-Overrides
section to change its value or drag it into the Selected Colours section to render only that colour.

Palette Overrides
This section forces the use of a particular palette or palette list order, during the composition process. You must
drag palettes from the Palettes section to change their order. Animate searches the palettes in the order that
they appear in the palette list to find the colour values associated with the colour IDs of each image. To apply a
different version of a colour palette, for example to switch from a day to a night palette, use the override section
to change the order of colour palettes (you must be working with cloned palettes).
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Colour Overrides
Drag a swatch from the Colours section to this section to override its value. You can also override a colour with a
texture.

Related Topics
•

Overriding a Colour below

•

Overriding a Colour With a Texture on the facing page

•

Rendering Selected Colours Only on page 804

•

Modifying a Texture Fill's Transformation on page 804

•

Overriding a Colour with a Bitmap Image Sequence on page 806

•

Overriding a Texture on a Pencil Line on page 808

Overriding a Colour
With the Colour-Override module, you can change the colour of some swatches. To do so, from the Colours
section, you must drag the colour swatch to modify to the Colour-Overrides section.
Several options are available to modify your colours.

Once the swatch appears in the Colour-Overrides section, click on the Select Override Mode button to right-click
on the Override Colour word and select one of the following option in the drop-down menu:
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•

Colour not visible: Renders the selected colour invisible in the Camera view.

•

New RGB only: Overrides the colour swatch while maintaining its original alpha value. You can select a
new colour by pressing the eye dropper
button or clicking directly on the colour swatch and choosing
a new colour from the Colour Picker window.

•

New alpha only: Overrides the swatch's alpha channel while maintaining its original RGB values. You can
select a new alpha value by pressing the eye dropper
button or clicking directly on the colour swatch
and choosing an alpha value from the Colour Picker window.

•

New RGBA: Overrides the swatch's colour and alpha values. You can select a new colour by pressing the
eye dropper
button or clicking directly on the colour swatch and choosing an alpha value from the
Colour Picker window.

Related Topics
•

Overriding a Colour With a Texture below

Overriding a Colour With a Texture
With the Colour Override module, can apply a texture over a selected colour. Any zone painted with the selected
colour swatch will be overridden by the selected texture.
To apply a texture over a colour:

From the Colours section, select the colour swatch to override and drag it to the Colour Override section.
1. Once the swatch appears in the Colour Override section, select it and then click on the Select Override
Mode button to right-click on the Override Colour word and select one of the following option in the
drop-down menu:

‣

Texture - original matrix

‣

Texture - global bbox matrix

‣

Texture - global bbox centered

‣

Texture - contour bbox matrix

‣

Texture - scale to screen

‣

Override With This Texture Centered on Overridden Objects Centre

‣

Texture - Use Input Peg
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2. In the Colour-Override section, under the Texture Filename section, click on "Click to select texture file".

3. Browse for your texture file.

4. Click on the Open button.
There are different ways to apply the texture over your colour:

The result will only be visible in the Camera view while in Render mode. In OpenGL mode, you will
see your original colour.

The matrix position can be modified using the Edit Gradient and Texture
must be painted with a gradient swatch or texture swatch.
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Texture - Original matrix
Overrides the swatch's colour with a pattern or texture. You must right-click under the Texture header to bring
up the Browser window to search for your texture. The texture's default matrix (fixed proportion and
orientation) is mapped the full size of the bounding box of each colour area to be overridden.

Texture - Global bbox matrix
Overrides the colour with a texture that is scaled non-proportionally to the size of the bounding box
encompassing the colour areas to be overridden. With multiple objects, it will look as though their fills were all
traced and cut from the same piece of stretched or squashed fabric.

Texture - Global bbox centered
Overrides the colour with a texture that is scaled proportionally to the size of the bounding box encompassing
all colour areas to be overridden. With multiple objects, it will look as though their fills were all traced and cut
from the same piece of fabric.

Texture - Contour bbox matrix
Overrides the colour with a disproportionately scaled texture for each individual colour area. In other words,
each fill area will not only have the texture scaled to its individual proportions, but also stretched or squashed to
fit within its contours.

Texture - scale to screen
Disproportionately scales the texture to the output resolution before applying it as an override.

Override with this Texture Centered on Overridden Objects Centre
Overrides the colour with a texture that is centered in the bounding box encompassing all colour areas to be
overridden. With multiple objects, it will look as though their fills were all traced and cut from the same piece of
fabric. The texture will not be stretched or distorted. It will be tiled in proportion. The centre of the texture zone
will be centered in the middle of the bounding box's centre.
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With this option, you can connect a Peg in the middle port to apply a transformation on the texture's position.
Refer to Animating a Texture Override with a Peg below to learn how.

Texture - Use Input Peg
Overrides the colour with a texture that is scaled non-proportionally to the size of the bounding box
encompassing the colour areas to be overridden. With multiple objects, it will look as though their fills were all
traced and cut from the same piece of stretched or squashed fabric.
With this option, you can connect a Peg in the middle port to apply a transformation on the texture's position.
Refer to Animating a Texture Override with a Peg below to learn how.

Related Topics
•

Colour-Override Editor Interface on page 797

•

Overriding a Colour on page 799

Animating a Texture Override with a Peg
The advantage of being able to animate the texture is that it can be adjusted, scaled, rotated and translated to
follow the general motion of a character if you want the texture to follow instead of having the character moving
across the fixed texture.
1. From the Module Library view, drag a Peg module and drop it in the Network view.

2. Connect the Peg module in the Colour Override's middle port. The green port will take the
transformation of the Peg to modify the pencil texture's position.
3. In the Network view, select the Peg module.
4. In the Advanced Animation toolbar, select either the Translate
5. In the Camera view bottom toolbar, enable the Render
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or Scale
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6. In the Camera view, move the Peg's position. As you move it, you will see the texture getting modified.
You can animate the position by adding position keyframes in the Timeline view. You can use the Random
Fill function to quickly create a random shake. See Pegs on page 643.

Rendering Selected Colours Only
With the Colour-Override module, you can isolate some colours in your drawing and render those ones only.
To render selected colours:
1. From the Colours section, drag the colour swatches to render and drop them into the Render Selected
Colours section.

You have to enable the Render Selected Colours option for the module to proceed with the
operation.

Related Topics
•

Colour-Override Editor Interface on page 797

•

Overriding a Colour on page 799

Modifying a Texture Fill's Transformation
When you paint a zone with a bitmap texture swatch, you might want to modify the size or position of the
texture's matrix at the compositing level. Maybe for an effect purpose you need to animate the position of the
texture in a zone. With the Colour-Override module and a Peg, you can animate the texture.
To modify a texture fill's transformation:
1. From the Module Library view, drag a Colour-Override module and drop it in the Network view.
2. From the Module Library view, drag a Peg module and drop it in the Network view.
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3. In the Network view, connect the Colour-Override module under the drawing module you want to
animate the line for. Note that for a cut-out puppet, you would connect the Colour-Override under the
final Composite, set as Pass-Through.
4. Connect the Peg module in the Colour-Override's middle port. The green port will take the
transformation of the Peg to modify the pencil texture's position.
5. Click on the Colour-Override's yellow button to open the editor.
6. In the Colour-Override window, in the Palettes section, select the palette containing the bitmap texture
swatch.
7. In the Colours section, select the texture swatch you used to paint the drawing and drag it to the ColourOverride section.

8. Once the swatch appears in the Colour-Override section, select it and then click on the Select Override
Mode button to right-click on the New RGBA word and select one of the following option in the dropdown menu:

‣

Override the colour's transformation:This option will override the initial texture's transformation
(matrix) established when you painted the zones or modified with the Edit Gradient and Texture
tool. This transformation override will be done by modifying the Peg's position.
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‣

Combine the colour's transformation:This option will combine the initial texture's transformation
(matrix) established when you painted the zones or modified with the Edit Gradient and Texture
tool with the new position transformation you will create when modifying the Peg's position.

9. In the Network view, select the Peg module.
10. In the Advanced Animation toolbar, select either the Translate
11. In the Camera view bottom toolbar, enable the Render

, Rotate

or Scale

tool.

mode.

12. In the Camera view, move the Peg's position. As you move it, you will see the texture fills getting
modified. You can animate the position by adding position keyframes in the Timeline view.

Related Topics
•

Overriding a Colour With a Texture on page 800

•

Rendering Selected Colours Only on page 804

•

Overriding a Colour with a Bitmap Image Sequence below

•

Overriding a Texture on a Pencil Line on page 808

Overriding a Colour with a Bitmap Image Sequence
In production, it will happen that you need to map a live action sequence or bitmap image sequence into a zone
or over several zone. For example, you could have a mirror shattered in several pieces and you want to map in it
the video or someone talking. You can paint the mirror pieces with a specific colour swatch and use the ColourOverride module to map the image sequence into the pieces. It can also be a single image without having to be
an image sequence.
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To override a colour with a bitmap image sequence:
1. From the Module Library view, drag a Colour-Override module and drop it in the Network view.

2. In the Network view, connect the Colour-Override module under the drawing module you want to
animate the line for.
3. Connect the Live Action or Bitmap Image Sequence module in the Colour-Override's left port. The left
blue port will input the images into the colour zones.
4. Click on the Colour-Override's yellow button to open the editor.
5. In the Colour-Override window, in the Palettes section, select the palette containing the colour to
override.
6. In the Colours section, select the pencil texture you used to draw your lines and drag it to the ColourOverride section.

7. Once the swatch appears in the Colour-Override section, select it and then click on the Select Override
Mode button to right-click on the New RGBA word and select Texture - Use Image Input.

8. In the Network view, select the bitmap image module.
9. In the Advanced Animation toolbar, select either the Translate
10. In the Camera view bottom toolbar, enable the Render

, Rotate

or Scale

tool.

mode.

11. In the Camera view, move the Bitmap Image position. As you move it, you will see the texture fills getting
modified. You can animate the position by adding position keyframes in the Timeline view.

Related Topics
•

Overriding a Colour With a Texture on page 800

•

Modifying a Texture Fill's Transformation on page 804
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•

Overriding a Texture on a Pencil Line below

Overriding a Texture on a Pencil Line
A pencil line can be drawn with a texture but also painted with a texture swatch. With the Colour-Override
module, you can either override either the pencil line's texture or texture fill and replace it by another one or you
can also animate the texture's position.
With the Edit Gradient and Texture

tool, you can modify the size and position for both types of texture on a

pencil line; the drawing texture and the filling texture. By doing that, you are actually modifying the texture's
matrix.

Related Topics
•

Modifying a Texture Fill on a Pencil Line below

•

Modifying a Pencil Texture on page 811

Modifying a Texture Fill on a Pencil Line
When you paint a pencil line with a bitmap colour swatch, you can override the position of the texture fill using
the Colour-Override module and a Peg.
To modify the pencil line texture:
1. From the Module Library view, drag a Colour-Override module and drop it in the Network view.
2. From the Module Library view, drag a Peg module and drop it in the Network view.
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3. In the Network view, connect the Colour-Override module under the Drawing module you want to
animate the line for. Note that for a cut-out puppet, you would connect the Colour-Override under the
final Composite, set as Pass-Through.
4. Connect the Peg module in the Colour-Override's middle port. The green port will take the
transformation of the Peg to modify the pencil texture's position.
5. Click on the Colour-Override's yellow button to open the editor.
6. In the Colour-Override window, in the Palettes section, select the palette containing the colour to
override.
7. In the Colours section, select the bitmap texture swatch you used to paint your lines and drag it to the
Colour-Override section.

8. Once the swatch appears in the Colour-Override section, select it anMac OS Xd then click on the Select
Override Mode button to right-click on the New RGBA word and select one of the following option in the
drop-down menu:

‣

Modulate Pencil Texture Colour (replace transformation):This option will override the initial texture
fill's transformation (matrix) established when you painted the line or modified it with the Edit
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Gradient and Texture

tool. This transformation override will be done by modifying the Peg's

position.
‣

Modulate Pencil Texture Colour (combine transformation):This option will combine the initial
texture fill's transformation (matrix) established when you drew the line or modified it with the Edit
Gradient and Texture
tool with the new position transformation you will create when modifying
the Peg's position.

9. In the Network view, select the Peg module.
10. In the Advanced Animation toolbar, select either the Translate
11. In the Camera view bottom toolbar, enable the Render

, Rotate

or Scale

tool.

mode.

12. In the Camera view, move the Peg's position. As you move it, you will see the texture fill getting modified.
You can animate the position by adding position keyframes in the Timeline view.

Related Topics
•

Modifying a Pencil Texture on the next page
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Modifying a Pencil Texture

You can modify and animate a pencil texture's position using the Colour-Override module and a Peg module.
This lets you create a shaky line style which is a very popular design style. The main issue with this style is that it
works well in traditional and tradigital animation, when the artist draws the line differently on each drawing, but
it does not work in cut-out animation where the same drawing is used for the entire animation. The same issue
happens when the same drawing is held for more than a few frames. The line moves during the animation, but
stops moving during the drawing hold, which looks bad.
With the Colour-Override module, you can animate the position of the pencil line texture independently from the
drawing exposure. Even if a drawing's exposure is held over several frames, the line will move.
To modify the pencil line texture:
1. From the Module Library view, drag a Colour-Override module and drop it in the Network view.
2. From the Module Library view, drag a Peg module and drop it in the Network view.

3. In the Network view, connect the Colour-Override module under the drawing module you want to
animate the line for. Note that for a cut-out puppet, you should connect the Colour-Override under the
final Composite, set as Pass-Through.
4. Connect the Peg module in the Colour-Override's middle port. The green port will take the
transformation of the Peg to modify the pencil texture's position.
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5. Click the Colour-Override's yellow button to open the editor.
6. In the Colour-Override window, in the Palettes section, select the penstyle_opacity palette.

7. In the Colours section, select the pencil texture you used to draw your lines and drag it to the Colour
Overrides section.

8. Once the swatch appears in the Colour-Override section, select it and click the
Select Override Mode button to right-click on the New RGBA word and select one of the following:

‣

Change Pencil Texture Transformation: Overrides the initial pencil texture's transformation (matrix)
established when you drew the line or modified with the Edit Gradient and Texture
tool. This
transformation override will be done by modifying the Peg's position.

‣

Modulate Pencil Texture Matrix: Combines the initial pencil texture's transformation (matrix) that
was established when you drew the line or modified with the Edit Gradient and Texture
tool with
the new position transformation you will create when modifying the Peg's position.

9. In the Network view, select the Peg module.
10. In the Advanced Animation toolbar, select the Translate
11. In the Camera view bottom toolbar, select the Render

, Rotate

or Scale

tool.

mode.

12. In the Camera view, move the Peg's position. As you move it, you will see the pencil texture getting
modified. You can animate the position by adding position keyframes in the Timeline view. You can use
the Random Fill function to quickly create a random shake.
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Related Topics
•

Modifying a Texture Fill on a Pencil Line on page 808

Colour-Scale

The Colour-Scale effect offsets an images colours. This effect is useful in creating ambient transitions, such as
from daytime to nighttime.

Use the Colour-Scale editor to set the colour scale effect by entering a value in the scale fields.
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The actual colour values of the image are not changed; instead, the channels are multiplied by a selected
amount. For example:
•

If you enter a value of 1, the colour values do not change.

•

If you enter a value greater than 1, you increase the colour channel value closer to 255 (or white).

•

If you enter a value less than 1, you decrease the colour channel value closer to zero (0 or black).

You can set the colour scale value by entering a value in the field. You can also change the values of the colour
scale effect over time by attaching it to a Bezier or Ease function curve
and adding keyframes.

Related Topics
•

Using Effects on page 788

Mask

TheMask cuts out a portion of an image using a matte drawing. You can use the Mask to allow a character to
disappear behind a background element or to cut a virtual hole into the layer itself. The Mask requires a matte
input.
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Use the Mask editor to invert the effect of the matte on an image. Instead of the object being hidden by the
mask, it will only be visible where it intersects with the matte shape area.

Related Topics
•

Using Effects on page 788

Glow

The Glow effect adds a bright soft-edged light or diffuse light region around an image. The Glow effect is useful
in creating a shining rim around objects such as the sun or stars.

Use the Glow editor to control the direction of the blur that creates the glow, as well as its colour.
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•

Truck Factor: Activated by default, this option readjusts the blur when the elements undergo a change of
depth or scale. When this option is disabled, the effect values remain unchanged regardless of any depth
or scale changes. It is recommended that this option be disabled when multiple drawings are composited
and attached to this effect.

•

Blur Type (Directional or Radial):
•

If Directional is selected, the software will blur the matte in the direction you select. For example, if a
character is walking east, the blur may fall to the west.

•

If Radial is selected, the software will blur the edges of the matte evenly around points that make up
its edge.

•

Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur
radius is affected by the drawing scale and camera position.

•

Directional Angle: If you select a Blur Directional Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.

•

•

0: blurs the image to the west.

•

90: blurs the image to the south.

•

180: blurs the image to the east.

•

270: blurs the image to the north.

Directional Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.
•

A fall-off rate of zero causes the blur to fade out slowly, distributing the blur evenly from the edge of
the character to the farthest edge of the blur.

•

A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.

•

Invert Matte: Activate this option to invert the matte used to create the glow. Your matte will become a
black silhouette while the glow will fill the background space.

•

Use Source Colour: Select this option to use the colours painted in the matte for the glow effect. If you
deselect this option, select a colour and alpha values in the Colour section.

•

Multiplicative: Select this option to create a more diffused glow.

•

Colour: Where you can choose the colour and alpha values for the glow effect.
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If this effect is connected below a Composite module set to Pass-Through, the effect will be applied
to each element connected in the Composite individually. If some of these elements are
overlapping, the effect will also overlap.

Related Topics
•

Using Effects on page 788

Highlight

Use the Highlight effect to turn a drawing's area lighter to simulate a light source. To produce the highlight
effect, you must draw a shape to control where the highlight will appear on the original drawing.

The Highlight effect uses a matte to determine the shape and position of the highlight on another element and
can blur the edges to create a softer effect. Use the Highlight editor to control the type and amount of blur, as
well as the colour of the highlight effect.
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•

Truck Factor: Activated by default, this option readjusts the blur when the element undergoes a change
of depth or scale. When this option is disabled, the effect's values remain unchanged regardless of depth
or scale changes. It is recommended that this option be disabled when multiple drawings are composited
and attached this effect.

•

Blur Type (Directional or Radial):
•

If Directional is selected, Animate will blur the matte in the direction you select.

•

If Radial is selected, Animate will blur the edges of the matte evenly around points that make up the
edge of it.

•

Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur
radius is affected by the drawing scale and camera position.

•

Directional Angle: If you select a Blur Directional Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.

•

•

0: blurs the image to the west.

•

90: blurs the image to the south.

•

180: blurs the image to the east.

•

270: blurs the image to the north.

Directional Fall-off Rate: The distance where the directional blur fades from the edge of the image. Select
a value between 0 and 1.
•

A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.

•

A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.

•

Invert Matte: Activate this option to invert the matte used to create the highlight.

•

Use Matte Colour: Select this option to use the colours in the matte for the highlight effect. If you
deselect it, use the Colour section to select colour and alpha values.

•

Multiplicative: Select this option to create a more diffused highlight.

•

Red/Green/Blue/Alpha: In the RGBA fields, enter the value that you want added to or subtracted from
the colour channels in the drawings. Alternatively, you can attach these values to function columns to
animate them over time.

Related Topics
•

Using Effects on page 788
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Quadmap

Use the Quadmap transformation layer to deform the shape of an element. For example, you can use it to create
a drop-shadow effect on an element.
You can edit the Quadmap visually in the Camera view.
To edit the Quadmap the Camera view:
1. In the Timeline view, click on the Add Layer

button and select Quadmap from the drop-down menu.

2. Connect the Quadmap layer to the drawing layer that you want to deform, or in the Network view, drag
in the Quadmap module from the Module Library and connect it above the drawing element module that
you want the effect to act on.

3. In the Tools toolbar, disable the Animate mode to change the value for the Quadmap over the entire
duration of the element.
4. In the Timeline view, click on the Quadmap layer to select it.
5. Select View > Show > Control or press [Shift] + [F11].
The quadmap handles appear around the element in the window. There is also a pivot point at the centre
of the quadmap frame that can be repositioned.
6. In the Camera View window, use the Transform tool to move the points on the quadmap. [Shift] + click to
select multiple points.

The value of each point on the quadmap can be changed gradually. To do this, use the Quadmap module Layer
Properties to attach the points to function curves.
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Only the X and Y values of each point in the quadmap can be changed.
•

2D Path: change the X and Y values simultaneously and control the velocity of the change.

•

Separate: change the X and Y values separately. Each of these can be attached to separate function
curves.

Related Topics
•

Using Effects on page 788

Shadow

With the Shadow effect, you can turn a drawing into a shadow. It does not matter if your drawing layer is a fully
coloured character, the Shadow effect will render it into a grey, semi-transparent, slightly blurry silhouette.
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To add a shadow stretched out on the ground, simply add a Quadmap module to flip, stretch and skew the
matte. Attach the entire effect to the same trajectory as your drawing layer and watch the shadow move along
with your character.

Do not forget that you need to connect your character in both the final Composite module and
the Shadow effect if you want to see your character and its shadow.

Use the Shadow editor to modify the way the Shadow effect is created.
The Shadow effect uses the shape of the drawing connected to create the shadow behind another element and
can blur the edges to create a softer effect. You can control the type and amount of blur, as well as the colour of
the shadow, in this dialog box.

•

Truck Factor: Activated by default, this option readjusts the blur when the elements undergo a change of
depth or scale. When this option is disabled, the effect's values remain unchanged regardless of any
depth or scale changes. It is recommended that this option be disabled when multiple drawings are
composited and attached to this effect.

•

Blur Type (Directional or Radial):
•

If Directional is selected, Animate will blur the matte in the direction you select.

•

If Radial is selected, Animate will blur the edges of the matte evenly around points that make up the
edge of it.

•

Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur
radius is affected by the drawing scale and camera position.

•

Directional Angle: If you select a Directional Blur Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.
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•

•

0: blurs the image to the west.

•

90: blurs the image to the south.

•

180: blurs the image to the east.

•

270: blurs the image to the north.

Directional Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.
•

A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.

•

A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.

•

Invert Matte: Activate this option to invert the matte used to create the shadow. In the render mode, the
background will appear grey, while a the matte shape will act as a cut-out window, allowing you to see
the original background colours beneath.

•

Use Source Colour: Create the shadow using the matte shape's colour. Be sure that you are in render
mode
to see this effect and that your background is NOT white and that you do NOT have a white
colour card module attached to the composite. As the shadow matte only gives colour information, but
no alpha, the matte is automatically multiplied with the background colours. If there is no colour card
attached and the background appears black, you will see the matte colour at full opacity. If it is multiplied
with a white background, the colours disappear into the full 255.

•

Multiplicative: Multiplies the shadow colours with the background.

•

Red/Green/Blue/Alpha: In the RGBA fields, you can enter the value to add or subtract from the colour
channels in the drawings or you can attach these values to function curves.

If this effect is connected below a Composite module set to Pass-Through, the effect will be applied
to each element connected in the Composite module individually. If some of these elements are
overlapping, the effect will also overlap.

Related Topics
•

Using Effects on page 788

Tone
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Use a Tone effect to add a dark-coloured region to your drawing and simulate the shaded area away from a light
source. To produce the tone effect, create a drawing to control where the tone will appear. The Tone effect uses
a matte to determine the shape and position of the tone on your drawing and can be blurred at the edges to
create a softer effect.

Use the Tone editor to control the type and amount of blur, as well as the colour of the tone.

•

Truck Factor: Activated by default, this option readjusts the blur when the elements undergo a change of
depth or scale. When this option is disabled, the effect's values will remain unchanged regardless of
depth or scale changes. It is recommended that this option be disabled when multiple drawings are
composited and attached this effect.

•

Blur Type (Directional or Radial):
•

If Directional is selected, Animate will blur the matte in the direction you select.

•

If Radial is selected, Animate will blur the edges of the matte evenly around points that make up the
edge of the matte.

•

Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur
radius is affected by the drawing scale and camera position.

•

Directional Angle: If you select a Directional Blur Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.

•

•

0: Blurs the image to the west.

•

90: Blurs the image to the south.

•

180: Blurs the image to the east.

•

270: Blurs the image to the north.

Directional Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.
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•

A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.

•

A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.

•

Invert Matte: Activate this option to invert the matte used to create the tone.

•

Use Matte Colour: Uses the matte shape colour to create the tone.

•

Multiplicative: Multiplies the tone colours with the background.

•

Red/Green/Blue/Alpha: In the RGBA fields, you can enter the value you want added to or subtracted
from the colour channels in the drawings or you can attach these values to function curves.

Related Topics
•

Using Effects on page 788

Transparency

The Transparency effect is used to make an image partially transparent. The Transparency effect is useful when
fading images in and out, such as a phantom or to make something partially see-through, such as a window.

Use the Transparency editor to control how translucent the element should be.
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You can enter a value in the Transparency field or change the transparency value over time by linking it to a
function curve. Entering a value of one hundred into the Transparency field will make the element 100%
transparent, in other words, invisible. Entering a value of 0 will render the element completely opaque.

It is also possible to adjust a layer/module's transparency directly in the Layer Properties window
without using the Transparency module. In the layer's properties, go to the Drawing tab and adjust
the Opacity parameter. This parameter is visible in OpenGL mode.

Related Topics
•

Using Effects on page 788
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Previewing and Playing Back Effects
To preview your effects, you will have to perform a quick render. Effects must be calculated before they can be
viewed in real time.
To preview your effects:
1. In the Playback toolbar, press the Render and Play

button.

The Play module opens and loads the frames.

2. Once the frames are loaded, press the Play

button in the Play window.

Preview Resolution
To make your previews calculate faster, you may want to render them out at a smaller resolution. You can use
the Preview Resolution command so you will not have to modify the resolution of your scene every time you make
a check preview.
The Preview Resolution command allows you to quickly ask for a preview at either a quarter, half or threequarter of the scene resolution. You can even customize the preview resolution size.
To use the Preview Resolution command:
1. In the top menu, select View > Preview Resolution.
2. From the drop-down menu, select either Same as Scene Resolution, 3/4 of Scene Resolution, 1/2 of
Scene Resolution, 1/3 of Scene Resolution, 1/4 of Scene Resolution or Custom.
If you selected the Custom option, the Custom Preview Resolution dialog box opens.

3. In the dialog box, select a resolution from the presets or type a new X-Y value.
4. Click on the OK button.
5. Preview your effects animation.
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Related Topics
•

Previewing Effects on page 782
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Effects Preferences
Animate has a series of preferences you can adjust to make you work more efficient.
•

General below

•

OpenGL on the next page

To open the Preferences panel:
‣

Windows: Select Edit > Preferences.

‣

Mac OS X: Select Animate > Preferences.

‣

Press [Ctrl] + [U] (Windows) or [⌘ ] + [U] (Mac OS X).

General

Options
•

Auto-Render: Automatically enables the Auto-Render option.
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OpenGL

Performance Optimizations
•

Enable Tone and Highlight: Turns the Tone and Highlight effects on and off in the Camera, Top and Side
views.

•

Enable Cutter: Turns the rendering of Cutter effects on and off in the Camera, Top and Side views.

•

Enable Colour-Override: Turns the rendering of the Colour-Override effects on and off in the Camera,
Top and Side views.
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Chapter 17: Export

Now that you have finished your animation, it is time to render your movie. Depending on whether you plan to
further edit your movie in a third party software, composite the movie in a larger body of work or put it up
directly on the web, Toon Boom Animate supports several formats for all your rendering needs.

Topics Covered
•

Exporting a QuickTime Movie on the facing page

•

Exporting an SWF Movie (Flash) on page 837

•

on page 1

•

on page 1

•

Export Preferences on page 841
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Exporting a QuickTime Movie
To export a QuickTime Movie:
1. From the top menu, select File > Export > Movie.
The Export to QuickTime Movie dialog box opens.

2. From the dialog box, click Browse to choose a destination path to where your movie will be saved and an
appropriate filename for the export.
3. Click Save when you are finished.
4. From the Export Range section, decide whether you would like to export the entire scene (All) or just a
selected frame range. If you decide on the latter, be sure to enter in the frame range in the fields
provided.

5. In the Resolution section, choose a preferred resolution ratio from the drop-down menu or select Custom
to enable the custom Width and Height fields and type a specific size.

6. In the Options section, click on the Movie Options button.
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•

•

1. Video: Check this box to enable the customization of the video settings, filters and size.
•

2. Settings: Opens the Standard Video Compression Settings dialog box (see below).

•

3. Filter: Opens the Choose Video Filter dialog box, where you can select from a range of filters to
apply to your video export.

•

4. Size: Opens the Export Size Settings dialog box. The size settings are overridden by the Animate's
scene settings.

5. Sound: Check this box to enable the customization of the sound settings.
•

•

6. Settings: Opens the Sound Settings dialog box (see below).

7. Prepare for Internet Streaming: Check this box to enable the customization of the internet streaming
options.
•

8. Internet Streaming drop-down: Select from the drop-down menu options for the type of
streaming best suited for your needs.

7. In the Video section, click on the Settings button.
The Standard Video Compression Settings dialog box opens.
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8. From the Compression Type drop-down menu, select a codec.

The availability of certain Compression Settings depends on the Compression Type selected. For
example, Animation is the default compression type and as a result the Data Rate option is greyed
out.

9. In the Motion section, choose your Frames per second from the drop-down menu.
By default, it will be set to match the frames-per-second (fps) of your Animate project. If you choose a
lower frame rate, your export play back will be faster than your actual project. The reverse is also true for
a higher frame rate.
10. From the same section decide whether you would like key frames inserted by checking the Key frame
every box, and if so, the number per frame.
This is the option is recommended by QuickTime. A further description of this topic is cited below.
Many compressors use "frame differencing" to compress moving images.
Frame differencing is the process of determining what information has changed from a starting frame (called a
"key frame") to subsequent frames. The key frame contains all of the information for an image. Subsequent frames
contain only the information that has changed.
Depending on the compressor you use, you can specify how often you want key frames to occur. If you don't have
enough key frames, the quality of your movie might be lower because most frames are generated from others.
However, more key frames result in a larger movie with a higher data rate. With some compressors, an additional
key frame is inserted automatically if too much of the image has changed from one frame to the next.
A good rule of thumb for general use is to have one key frame every 5 seconds (multiply the frames per second by
5). If you are creating a file for RTSP streaming and have concerns about the reliability of the delivery network (as
with the public Internet), you may want to increase key frame frequency to one key frame every 1 or 2 seconds.

11. From the Compressor section, choose a Depth based on your movie’s needs, for example, Millions of
Colours+ houses an alpha channel.
12. In the Quality section, use the slider to choose a quality setting. Remember that the better the quality of
the export, the larger the file.

13. From the Data Rate section, either choose to allow the program to automatically select the most optimal
bit rate, or enter in a Restricted rate to save space and allow for faster downloading at a cost to the
quality of your export.
14. In the same section, from the Optimized for drop-down list, select the intended viewing method for your
export.
15. Click the OK button when you are finished.
16. From the Movie Settings dialog box, click-on the Sound Settings button.
The Sound Settings dialog box opens.

17. From the Compressor drop-down menu, choose a compression type.
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The default setting is None. This will preserve your original sound file, without the loss of information.
However, an uncompressed sound file will inevitably add “weight” to the overall size of your video
export.
18. Select a Rate by pressing the down arrow button next to kHz.
It is best to check and match the original properties of your sound file. For example, if your file has an
audio sample rate of 48 kHz and you choose a conversion rate of 22.05 kHz, the sound will play at the
same speed, but with higher frequencies missing.
For a standard film sound quality, choose 44.1 kHz, or 48 kHz for DVD quality. Anything less will make
the sound “dull” or less bright. For things like recorded voice this doesn't matter so much, but for music it
can make an audible difference.
If file size is a consideration, such as with videos for the internet, then a lower rate might be more
practical.
19. Next, choose the Size and the Use, which are related. Once again, it is advisable to check your original
sound file properties. If the file was recorded in one channel (mono), there is little point in choosing the
two channel (stereo) option.
Although Mono can support a 16-bit channel, the extra information is unnecessary. Mono is generally
paired with 8-bit and Stereo with 16-bit.
20. Click OK when you are done.
21. In the Export to QuickTime Movie dialog box, click OK.
A progress bar appears.

22. Browse to the location on your computer where you saved your QuickTime video and double-click on it to
view your export.

If you feel that your exported video is either to small or too large, change your project size from the
top menu under Scene > Scene Settings. This will change the size of the video output.

Related Topics
•

Exporting a QuickTime Movie with Transparency below

•

Export on page 831

Exporting a QuickTime Movie with Transparency
To render out a QuickTime movie with transparency, you need to set the Depth to Millions of Colours +.
To set the depth to Millions of Colours:

‣ In the Standard Video Compression Settings dialog box, select Millions of Coulours from the Depth
drop-down menu.
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Refer to Exporting a QuickTime Movie on page 832 to learn how to access the Standard Video
Compression Settings dialog box.

Related Topics
•

Exporting a QuickTime Movie on page 832

•

Export on page 831
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Exporting an SWF Movie (Flash)
The SWF export now supports both bitmap effects (which can be previewed in Render View
Blend Modes (vector effects which can be previewed in OpenGL View
so, you should preview the SWF by using the SWF preview

mode) and SWF

mode). If you have not already done

button to see what the two types of effects look

like when blended together. Once you are satisfied with the results, continue to the Export to SWF Movie
procedure.
To export an SWF movie:
1. From the top menu, select File > Export > SWF.
The Export to Flash Movie (SWF) dialog box opens.

2. To choose an appropriate filename and a destination path where your movie will be saved to, from the
dialog box, click Browse.
3. From the Export Range section, decide whether you would like to export all the frames of your movie or
just a selected frame range. If you decide on the latter, be sure to enter in the frame range in the fields
provided.

4. In the Options section, enter your Frames rate (fps) into the field provided. By default, it will be set to
match the fps of your Animate project. If you choose a lower frame rate, your export play back will be
faster than your actual project. The reverse is also true for a higher frame rate.
5. In the same section, select the JPEG quality.
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‣

100 = full quality

‣

50 = average quality at about 1/5th of the size.

‣

25 = medium quality where loss of high image resolution starts to occur.

‣

10 = low quality where “macro-blocking” or large pixelation become obvious.

‣

1 = lowest quality where there is extreme loss of colour and detail and where the image becomes
nearly unrecognizable.

6. If you want to protect your movie to be imported in another application, enable the Protect from Import
option.
7. Enable the Compress Movie option if you want to get a lighter format. The movie may lose some quality,
but in turn create a lighter file.
8. In the Disabled Effects section, check the boxes of the vector-based effects that you would NOT like to
see in the SWF render.
Note that certain Animate effects will not be listed in this section as they are not vector-based and
therefore not available for SWF export. These effects will not appear in the SWF render.
9. In the Disabled Effects section, enable the Convert Pencils option to avoid transforming your pencil lines
to fills. If this option is enabled, the pencil lines will remain pencil lines.
10. Press OK when you are finished.
11. Browse to the location on your computer where you saved your Flash Movie and double-click on it to view
your export.

Related Topics
•

Export on page 831

Exporting an Image Sequence
In Toon Boom Animate you can export your scene as a bitmap image sequence. If you have sound in your scene,
the sound will not be exported with the images.
To render an Image Sequence:
1. Select File > Export > Images or press [Ctrl] + [Shift] + [Y] (Windows) or [⌘ ] + [Shift] + [Y] (Mac OS X).
The Export Images dialog box opens.
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2. In the Output section, choose a prefix. The prefix is the file name. Each image in the sequence will have
this name, plus a sequence number, plus the file format extension, for example final-0001.jpg.
3. From the same section, click Browse to choose a destination path to where your movie will be saved. The
default location is in the file directory’s frames folder.

4. In the Format section, choose the File Type, Colour Mode and Colour Depth from their respective dropdown menus.
5. In the Range section, select the Frame Range to render.
‣

All Frames: Select this option to export the entire scene.

‣

Selected Frames: Type the first and last frame of the frame range you want to export.

6. Check the Preview box if you wish to see the images being rendered.
7. Click OK.
If you checked off the preview box, a generic player opens so you can watch the image sequence strung
together as a video. The image sequence is now available in the scene’s frames directory. You should be
able to preview each frame as an individual image.
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Exporting an Image Sequence with Transparency
If you would like to export images with transparency you need to select the file type that supports this option,
such as TGA, PSD or PNG. The Colour Mode menu adjusts according to the File Type selected. For example,
selecting TIF will result in only having "Colour" as a Colour Mode option, whereas PNG will have "Colour" and
"Colour with Transparency."
To render out an Image Sequence with transparency:
1. Bring up the Export Images dialog box and select Format > Colour Mode > Colour with Transparency
from the drop-down menu.
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Export Preferences
In Animate, you will find preferences related to the rendering under the Render tab.
To open the Preferences panel:
‣

Windows: Select Edit > Preferences.

‣

Mac OS X: Select Animate > Preferences.

‣

The [Ctrl] + [U] (Windows) or [⌘ ] + [U] (Mac OS X).

Preview Options
•

Enable Blur: Renders blur effects derived from the Blur-Directional Module, Blur-Radial Module, and the
Blur-Variable Module in the Render View window.

•

Enable Line Texture: Renders line texture in the Render View.

Related Topics
•

Export on page 831
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Chapter 18: Scripting
Qt Script provides access to many of the functions supported in the interface. With Qt Script, you can automate
a number of Animate functions to speed the completion of various repetitive tasks.
To use scripts prepared by other users or for other scenes, you must first export the scripts from the originating
scene and then import the scripts into a target scene.
You can add buttons to the Scripting Tools toolbar so that you can access them easily. They will appear to the
right of the default Scripting Toolbar buttons.

To find more information about methods and functions for writing your own script, refer to the
scripting help included in the software:
•

Windows: C:\Program Files (x86)\Toon Boom Animation\Toon Boom Animate
3\help\en\script\index.html

•

Mac OS X: /Applications/Toon Boom Animate 3/Documentation.localized/script/index.html

Topics Covered
•

Creating a Qt Script on page 1

•

Importing Scripts on page 1

•

Linking a Script to a Toolbar Button on page 1
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Creating a Qt Script
Use the Script Editor to create Qt scripts for Animate.
To create a script:
1. Open the Script Editor window by going to the top menu and selecting Windows > Script Editor.
The Script Editor view opens.

2. From the Script Editor toolbar, click on the New Script

button. (If you do not see the Script Editor

toolbar, go to the top menu and select Windows > Toolbars > Script Editor).
The New Script dialog box appears.

3. Enter a name in the Enter name of new script field, along with the file extension *.js and click on OK.
The name of your script appears in the File column of the Script Editor view.

4. Click in the right side of the Script Editor and start writing your script. Try the following script:
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function add3dPathCol()
{
column.add(“ColumnName”, “3DPATH”);
}
5. To test your script, select the function your would like to run from the File column, then, from the Script
Editor toolbar, click on the Run
button, or from the View menu
select Play/Debug > Run.
‣

You may receive the message: Only functions that have been saved or are
explicitly called will be executed. This usually occurs if you did not select the function
you wished to run from the File column before running the script. In this case, click on the Save
Changes button, then try running your script again.

‣

You may also see this message on the right side of the Script Editor:

This is because the software jumped to the <<Sandbox>> item in the Function column. The
<<Sandbox>> is provided to test scripts without saving them. Simply click on your newly created
script and then try running it again.
A new 3Dpath column (or 3 separate x, y and z path columns and a velocity column) will appear in your
Xsheet view with the name ColumnName.
To delete a script:
1. In the Script Editor, in the File column, select the script that you would like to delete.
2. From the Script Editor toolbar, click on the Delete Script

button.

To troubleshoot errors in your script:
•

Debug: Select the function first, then from the Script Editor toolbar, click on the Debug
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The Qt Script Debugger opens.

•

Syntax Check: Click on the Syntax Check button.
A window will pop-up with syntax information.
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Importing Scripts
To use scripts prepared by other users, transfer the *.js files from the computer where the scripts were
created to the one that you intend to use. Then use the Script Editor to import the *.js files from where they
are saved on your computer.
Scripts that you have created for one scene or project will be available for all other projects created on the same
computer, with no need for any kind of transfer or import.
To import a script:
1. On the computer that contains the *.js files, open My Computer (Windows) or Finder (Mac OS X), then
follow this path:
‣

Windows: C:\Program Files (x86)\Toon Boom Animation\Toon Boom Animate 3\resources\scripts

‣

Mac OS X: Home > Library > Preferences > Toon Boom Animation > Toon Boom Animate 3 >
1000-scripts

2. Copy the *.js files that you would like to transfer to another computer onto a USB key, or use another
transfer method of your choice.
3. Transfer and save the *.js files onto the computer that you intend to use. Be sure that you save them in a
logical location. You can save them directly in the locations indicated in Step 1, in which case they will
automatically appear in the Script Editor. If for some reason you do not wishto mix them up with the
default scripts, save them to a different location and continue following the steps below.
4. Open a new, or existing, scene in Animate.
5. In the Script Editor, click on the Import Scripts

button.

A browser window will open and allow you to browse to the location on the server where the *.js files
are saved.
6. Select the *.js file and click on the Open button.
The script is imported and appears in the File list of the Script Editor.

Linking a Script to a Toolbar Button
You can add buttons to the Scripting Tools toolbar so that you can access them easily. They will appear to the
right of the default Scripting Toolbar buttons.
To link a script to a toolbar button:
1. In the Scripting Tools toolbar, click on the Manage Scripts
A dialog box containing all of the available scripts opens.
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2. In the Available Scripts list, select the script you want to link to a toolbar button.
3. Click on the Right Arrow

button to add the script to the In Toolbar list.

4. Click on OK to add the button and close the dialog box.
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Chapter 19: Keyboard Shortcuts for
Animate
This document lists default keyboard shortcuts for Animate.

The Animate keyboard shortcuts set is used throughout the Animate documentation.

To use a shortcut, press the key and the character simultaneously. The sign + sign is not part of the sequence. If
there is no shortcut allocated to a command it is left blank.

General
COMMAND

FLASH

Animate

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

Ctrl+H

^+H

Ctrl+H

^+H

Add Frame Before
Selection

Ctrl+G

⌘ +G

Ctrl+G

⌘ +G

Auto Render

Ctrl+Alt+R

⌘ +Alt+R

Ctrl+Alt+R

⌘ +Alt+
R

Copy

Ctrl+C

⌘ +C

Ctrl+C

⌘ +C

Create Empty
Drawing

Alt+Shift+R

Alt+Shift+R

Alt+Shift+R

Alt+Shift
+R

Cut

Ctrl+X

⌘ +X

Ctrl+X

⌘ +X

Delete

Del

Del

Del

Del

Delete (secondary
key)

Backspace

Backspace

Backspace

Backspa
ce

Deselect All

Esc

Esc

Esc

Esc

Duplicate Drawings

Alt+Shift+D

Alt+Shift+D

Alt+Shift+D

Alt+Shift
+D

Add Frame After
Selection
Add Frame At End
Add Frame At Start
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General
COMMAND

FLASH

Animate

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

First Frame

Home

Home

<

<

Free Pan And Zoom

Space

Space

Space

Space

Go to Next Column

J

J

J

J

Go to Next Drawing

G

G

G

G

Go to Previous
Column

H

H

H

H

Go to Previous
Drawing

F

F

F

F

Export Layout

Go to the Eighth
Drawing in Drawing
View
Go to the Fifth
Drawing in Drawing
View
Go to the First
Drawing in Drawing
View
Go to the Fourth
Drawing in Drawing
View
Go to the Second
Drawing in Drawing
View
Go to the Seventh
Drawing in Drawing
View
Go to the Sixth
Drawing in Drawing
View
Go to the Tenth
Drawing in Drawing
View
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General
COMMAND

FLASH

Animate

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

F1

F1

F1

F1

Ctrl+Shift+I

⌘ +Shift+I

⌘ +Shift
+I

End

End

>

>

New

Ctrl+N

⌘ +N

Ctrl+N

⌘ +N

Next Frame

.

.

.

.

Open

Ctrl+O

⌘ +O

Ctrl+O

⌘ +O

Paste

Ctrl+V

⌘ +V

Ctrl+V

⌘ +V

Paste Special

Ctrl+Shift+B

⌘ +Shift+B

Ctrl+B

⌘ +B

Paste Special Again

Ctrl+Alt+B

⌘ +Alt+B

Ctrl+Shift+B

⌘ +Shift
+B

Preferences

Ctrl+U

⌘ +U

Ctrl+U

⌘ +U

Previous Frame

,

,

,

,

Quick Close-up

Shift+Z

Shift+Z

Shift+Z

Shift+Z

Recentre

F12

⌘ +F12

N

N

Redo

Ctrl+Y

⌘ +Y

Ctrl+Shift+Z

⌘ +Shift
+Z

Rename Drawings

Ctrl+Shift+D

⌘ +Shift+D

Ctrl+D

⌘ +D

Help
Import Movie
Invert Selection

Jog Backward
Jog Forward
Last Frame
Look at Selected
Move Backward
Move Forward

Rename Drawings
with Prefix
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General
COMMAND

FLASH

Animate

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

Reset Pan

Shift+N

Shift+N

Shift+N

Shift+N

Reset Rotation

Shift+X

Shift+X

Shift+X

Shift+X

Reset View

Shift+M

Shift+M

Shift+M

Shift+M

Save

Ctrl+S

⌘ +S

Ctrl+S

⌘ +S

Select All

Ctrl+A

⌘ +A

Ctrl+A

⌘ +A

?

?

?

?

/

/

/

/

Toggle Editor

Shift+E

Shift+E

Shift+E

Shift+E

Toggle Full Screen

Ctrl+F

⌘ +F

Ctrl+F

⌘ +F

Toggle Playback

Return

Return

Shift+Return

Shift+Re
turn

Toggle Velocity
Editor

Shift+V

Shift+V

Shift+V

Shift+V

Undo

Ctrl+Z

⌘ +Z

Ctrl+Z

⌘ +Z

Unload Model

Del

Del

Del

Del

Zoom In

Ctrl+=

⌘ +=

2

2

Zoom Out

Ctrl+-

⌘ +-

1

1

Render and Play

Reset Zoom
Rotate View CCW
Rotate View CW

Select Child
Select Next Brother
Select Parent
Select Previous
Brother
Shuttle Backward
Shuttle Forward
Shuttle Reset
Test SWF Movie
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Camera
COMMAND

FLASH

HARMONY

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

Add all to
Onion Skin

Alt+Shift+
O

Alt+Shift+
O

Alt+Shift+
O

Alt+Shift+
O

Add to
Onion Skin

Shift+S

Shift+S

Shift+S

Shift+S

Bitmap
Image
Quality

Ctrl+Q

^+Q

Ctrl+Q

^+Q

Camera
Show
hidden

Alt+Shift+H

Alt+Shift+
H

Alt+Shift+H

Alt+Shift+
H

Centre On
Selection

Shift+O

Shift+O

Shift+O

Shift+O

Create
Drawing
from
Drawing
Selection

F9

⌘ +F9

F9

⌘ +F9

Create
Symbol

F8

F8

F8

F8

Enable/Dis
able
Playback

Alt+P

Alt+P

Alt+P

Alt+P

Enter
Selected
Symbol

Ctrl+E

⌘ +E

Ctrl+E

⌘ +E

Expand
Symbol

Ctrl+B

⌘ +B

Shift+F8

Shift+F8

Ctrl + Shift
+Y

⌘ +Y

Animate

Distribute
to Layers
Duplicate
Symbol

Export
Images
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Camera
COMMAND

FLASH

HARMONY

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

4

4

4

4

Flip
Vertical

5

5

5

5

Hide All
Control
Parameter
s

Shift+C

Shift+C

Shift+C

Shift+C

Insert
Control
Point

P

P

P

P

Insert
Keyframe

Ctrl+F6

⌘ +F6

F6

F6

Insert
Keyframe
and
Duplicate
Drawings

F6

F6

Inverse
Kinematics
Tool

Alt+8

Alt+8

Shift+I

Shift+I

Lock All

Ctrl+Shift+
L

⌘ +Shift+L

Ctrl+Shift+
L

⌘ +Shift+L

Lock All
Others

Ctrl+Alt+Sh
ift+O

⌘ +Alt+Sh
ift+O

Ctrl+Alt+Sh
ift+O

⌘ +Alt+Sh
ift+O

Lock
Selection

Ctrl+Alt+L

⌘ +Alt+L

Ctrl+Alt+L

⌘ +Alt+L

Maintain
Size Tool

Alt+6

Alt+6

Alt+6

Alt+6

Remove all

Ctrl+Shift+

⌘ +Shift+

Ctrl+Shift+

⌘ +Shift+

Flip
Horizontal
Flip Scale X
Flip Scale Y

Insert
Position
Keyframe

854

Toon Boom Animate 3 User Guide

Camera
COMMAND

FLASH

HARMONY

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

O

O

O

O

Reset All
Transform
ations

Ctrl+Alt+Z

⌘ +Alt+Z

Shift+R

Shift+R

Reset
Transform
ation

Ctrl+Shift+
Z

⌘ +Shift+
Z

R

R

Return To
Parent
Symbol

Ctrl+Shift+
E

⌘ +Shift+
E

Ctrl+Shift+
E

⌘ +Shift+
E

Rotate
Tool

Alt+3

Alt+3

Alt+3

Alt+3

Scale Tool

Alt+4

Alt+4

Alt+4

Alt+4

Select
Control
Point

T

T

T

T

Select Next
Control
Point

'

'

'

'

Select
Previous
Control
Point

;

;

;

;

Show/Hide
Control
Parameter
s

Shift+F11

⌘ +F11

Shift+F11

⌘ +F11

Onion Skin
Remove
Selection
from Onion
Skin
Remove
Unselected
from Onion
Skin

Show/Hide
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Camera
COMMAND

FLASH

HARMONY

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

Skew Tool

Alt+5

Alt+5

Alt+5

Alt+5

Spline
Offset Tool

Alt+9

Alt+9

Alt+8

Alt+8

Substitute
Drawing
Next

]

]

]

]

Substitute
Drawing
Prev

[

[

[

[

Toggle
Lock In
Time

Alt+L

Alt+L

Alt+L

Alt+L

Transform
Tool

Alt+Q

Alt+Q

Shift+T

Shift+T

Translate
Tool

Alt+2

Alt+2

Alt+2

Alt+2

Unlock All

Ctrl+Alt+Sh
ift+L

⌘ +Alt+Sh
ift+L

Ctrl+Alt+Sh
ift+L

⌘ +Alt+Sh
ift+L

Unlock
Selection

Ctrl+Shift+
K

⌘ +Shift+
K

Ctrl+Shift+
K

⌘ +Shift+
K

Transform
Tool
Controls

Toggle
Between
Line and
Curve

Timeline
COMMAND

Centre On

FLASH

HARMONY

CUSTOM

Win/Lin
ux

Mac OS
X

Win/Linux

Mac OS X

O

O

O

O
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Timeline
COMMAND

FLASH

HARMONY

CUSTOM

Win/Lin
ux

Mac OS
X

Win/Linux

Mac OS X

Clear
Exposure
and Pull

Z

Z

Z

Z

Collapse All
Layers

0

0

0

0

Collapse or
Expand an
Layer

Ctrl+I

⌘ +I

Ctrl+I

⌘ +I

Create
Morphing

Alt+M

Alt+M

Alt+M

Alt+M

Decrease
Exposure

-

-

-

-

Delete
Keyframe

Shift+
F6

Shift+
F6

F7

F7

D

D

D

D

Enable
Layers

A

A

A

A

Expand All
Layers

9

9

9

9

Selection
Clear
Exposure

Convert
Morphing
to
Drawings

Delete
Morphing
Disable All
Other
Layers
Disable
Layers
Enable All
Elements
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Timeline
COMMAND

FLASH

HARMONY

CUSTOM

Win/Lin
ux

Mac OS
X

Win/Linux

Mac OS X

F5

F5

F5

F5

Go to Next
Global
Frame

Alt+.

Alt+.

Ctrl+Shift+C

⌘ +Shift+C

Go to Next
Keyframe

'

'

'

'

Go to
Previous
Global
Frame

Alt+,

Alt+,

Ctrl+Shift+X

⌘ +Shift+X

Go to
Previous
Keyframe

;

;

;

;

Insert Blank
Frame

X

X

Shift+J

Shift+J

Insert
Drawing

Ctrl+R

⌘ +R

Ctrl+R

⌘ +R

Insert
Group

Alt+G

Alt+G

Alt+G

Alt+G

Insert
Keyframe

Ctrl+F
6

⌘ +F6

F6

F6

Insert
Keyframe
and
Duplicate
Drawings

F6

F6

Insert Peg

Ctrl+P

⌘ +P

Ctrl+P

⌘ +P

Extend
Exposure
Flip
Horizontal
Flip Vertical

Insert
Camera

Insert
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Timeline
COMMAND

FLASH
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HARMONY
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X

CUSTOM

Win/Linux

Mac OS X

Lock All

Ctrl+Shift+L

⌘ +Shift+L

Lock All
Others

Ctrl+Alt+Shift
+O

⌘ +Alt+Shift
+O

Lock
Selection

Ctrl+Alt+L

⌘ +Alt+L

Quadmap
Insert
Sound

Paste Cycle

Ctrl+/

⌘ +/

Ctrl+/

⌘ +/

Ctrl+.

⌘ +.

Ctrl+.

⌘ +.

Paste
mode:
Cycle
through
presets
Paste
mode: Set
all
Paste
mode: Set
exposures
only
Paste
mode: Set
key frames
only
Paste
Reverse
Select
Children
Set
Exposure
Set
Exposure
to 1
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Timeline
COMMAND

FLASH

HARMONY

CUSTOM

Win/Lin
ux

Mac OS
X

Win/Linux

Mac OS X

Set Motion
Keyframe

Ctrl+K

⌘ +K

Ctrl+K

⌘ +K

Set StopMotion
Keyframe

Ctrl+L

⌘ +L

Ctrl+L

⌘ +L

Show/Hide
Functions

Alt+F

Alt+F

Alt+F

Alt+F

Substitute
Drawing
Next

]

]

]

]

Substitute
Drawing
Previous

[

[

[

[

Unlock All

Ctrl+Alt+Shift
+L

⌘ +Alt+Shift
+L

Unlock
Selection

Ctrl+Shift+K

⌘ +Shift+K

Set
Exposure
to 2
Set
Exposure
to 3

Xsheet
COMMAND

FLASH

HARMONY

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

Add Columns

Shift+C

Shift+C

Shift+C

Shift+C

Add Drawing
Column

Ctrl+R

⌘ +R

Ctrl+R

⌘ +R
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Xsheet
COMMAND

FLASH

HARMONY

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

Z

Z

Z

Z

Collapse All

0

0

0

0

Decrease
Exposure

-

-

-

-

Ctrl+D

⌘ +D

9

9

9

9

Ctrl+T

⌘ +T

Ctrl+T

⌘ +T

Hide Selected
Column

Alt+H

Alt+H

Alt+H

Alt+H

Increase
Exposure

+

+

+

+

Insert Blank Cell

X

X

Shift+J

Shift+J

Insert Keyframe

Ctrl+F6

⌘ +F6

F6

F6

Clear Exposure
and Pull
Clear Selected
Cells
Clone Selected
Columns
Collapse

Delete Selected
Columns
Delete Selected
Drawings
Duplicate
Selected
Columns
Enable/Disable
Playback
Expand
Expand All
Fill Randomly
Fill Selection
Gestural Drag
Mode
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Xsheet
COMMAND

FLASH

HARMONY

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

I

I

I

I

Paste Cycle

Ctrl+/

⌘ +/

Ctrl+/

⌘ +/

Paste Reverse

Ctrl+.

⌘ +.

Ctrl+.

⌘ +.

Ctrl+M

⌘ +M

Ctrl+M

⌘ +M

Set Custom
Hold 1 Cell

Ctrl+1

⌘ +1

Ctrl+1

⌘ +1

Set Custom
Hold 2 Cells

Ctrl+2

⌘ +2

Ctrl+2

⌘ +2

Set Custom
Hold 3 Cells

Ctrl+3

⌘ +3

Ctrl+3

⌘ +3

Set Custom
Hold 4 Cells

Ctrl+4

⌘ +4

Ctrl+4

⌘ +4

Alt+Shift+
H

Alt+Shift+
H

Alt+Shift+
H

Alt+Shift+
H

Insert/Overwrit
e Mode
Mark As
Breakdown
Mark As Inbetween
Mark As Key

Remove Frames
Sequence Fill
Set Custom
Hold Cell

Show Column
Types
Show Hidden
Columns
Thumbnails
Zoom Extents
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Drawing Mode
COMMAND

FLASH

HARMONY

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

Apply Tool
to All
Drawings

Ctrl+Alt+A

⌘ +Alt+A

Alt+A

Alt+A

AutoCreate
Colour Art
from Brush

Shift+F2

Shift+F2

Shift+F2

Shift+F2

Shift + Q

⌘+ Q

Activate
Magnifier

Apply Tool
to Line and
Colour Art
AutoMatte
Automatic
ally Fill
Inside
Regions

Ctrl+Shift+
R

⌘ +Shift+
R

Ctrl+Shift+R

⌘ +Shift+R

Bring
Forward

Ctrl+Up

⌘ +Up

Ctrl+PgUp

⌘ +PgUp

Bring To
Front

Ctrl+Shift+
Up

⌘ +Shift+
Up

Ctrl+Shift+P
gUp

⌘ +Shift+P
gUp

Alt+B

Alt+B

Brush Tool
Brush Tool
(General)

Alt+B

Alt+B

Close Gap
Tool

Alt+C

Alt+C

Alt+C

Alt+C

Contour
Editor Tool

Alt+A

Alt+A

Alt+Q

Alt+Q

Convert
Brush
Strokes to
Pencil Lines

^

^

^

^

Convert
Pencil Lines

&

&

&

&
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Drawing Mode
COMMAND

FLASH
Win/Linux

HARMONY
Mac OS X

Win/Linux

CUSTOM
Mac OS X

to Brush
Strokes
Convert
Strokes to
Pencil Lines

Shift+F12

Shift+F12

Create
Breaking
Triangles
Create
Colour Art
from Line
Art

*

*

*

*

Cutter Tool

Alt+T

Alt+T

Decrement
Brush Size

Shift+ P

⌘ +P

Shift+Del

Shift+Del

Crop Brush
Textures

Delete All
Morphing
Hints

Shift+Del

Shift+Del

Drawing
Pivot Tool

Shift + P

Dropper
Tool

Alt+I

Alt+I

Alt+D

Alt+D

Edit
Texture/Gr
adient Tool

Shift+F3

Shift+F3

Shift+F3

Shift+F3

Ellipse Tool

Alt+O

Alt+O

Alt+=

Alt+=

Alt+E

Alt+E

Alt+E

Alt+E

Enable
Morphing
Pencil Hint
Mode
Eraser Tool
First Frame

864

Toon Boom Animate 3 User Guide

Drawing Mode
COMMAND

FLASH

HARMONY

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

Flatten

Alt+Shift+
F

Alt+Shift+
F

Alt+Shift+F

Alt+Shift+F

Flatten and
Remove
Extra
Strokes

Ctrl+Shift+
F

⌘ +Shift+
F

Ctrl+Shift+F

⌘ +Shift+F

Flatten
Latest

F2

F2

F2

F2

Ctrl+G

⌘ +G

Ctrl+G

⌘ +G

Alt + Shift +
J

Alt + Shift +
J

Flip
Horizontal
Flip Vertical
Go to Next
Morphing
Frame
Go to
Previous
Morphing
Frame
Group
Hand Tool
Increment
Brush Size
Ink Tool
Join Pencil
Lines
Light Table

Shift+L

Shift+L

Shift+L

Shift+L

Line Tool

Alt+N

Alt+N

Alt+\

Alt+\

Morphing
Tool

F3

F3

F3

F3

Onion Skin:
1 Next

Ctrl+1

⌘ +1

Ctrl+1

⌘ +1

Merge
Pencil Lines
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Drawing Mode
COMMAND

FLASH

HARMONY

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

Onion Skin:
1 Previous

!

!

!

!

Onion Skin:
2 Next

Ctrl+2

⌘ +2

Ctrl+2

⌘ +2

Onion Skin:
2 Previous

@

@

@

@

Onion Skin:
3 Next

Ctrl+3

⌘ +3

Ctrl+3

⌘ +3

Onion Skin:
3 Previous

#

#

#

#

Onion Skin:
No Next

Ctrl+`

⌘ +`

Ctrl+`

⌘ +`

Onion Skin:
No
Previous

~

~

~

~

Optimize

Ctrl+Alt+S
hift+C

⌘ +Alt+S
hift+C

Ctrl+Alt+Shif
t+C

⌘ +Alt+Shif
t+C

Paint and
Remove
Texture

Ctrl+Shift+
F6

⌘ +Shift+
F6

Shift+F6

Shift+F6

Alt+I

Alt+I

Onion Skin:
Add 1 next
Onion Skin:
Add 1
Previous

Onion Skin:
Reduce 1
Next
Onion Skin:
Reduce 1
Previous

Paint Tool
Paint Tool
(General)

Alt+K

Alt+K
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Drawing Mode
COMMAND

FLASH
Win/Linux

HARMONY
Mac OS X

CUSTOM

Win/Linux

Mac OS X

Paint
Unpainted
Tool

Alt+Y

Alt+Y

Pencil
Editor Tool

Alt+W

Alt+W

Pencil Tool

Alt+Y

Alt+Y

Alt+/

Alt+/

Permanent
Selection

Ctrl+Shift+
P

⌘ +Shift+
P

Ctrl+Shift+P

⌘ +Shift+P

Perspective
Tool

Alt+0

Alt+0

Alt+0

Alt+0

Polyline
Tool

Alt+P

Alt+P

Alt+_

Alt+_

Preview
Line and
Colour Arts

Shift+P

Shift+P

P

P

Real-Time
Antialiasing

Ctrl+Alt+S
hift+A

⌘ +Alt+S
hift+A

Ctrl+Alt+A

⌘ +Alt+A

Rectangle
Tool

Alt+R

Alt+R

Alt+7

Alt+7

Repaint
Brush Tool

Alt+X

Alt+X

Repaint
Tool

Alt+R

Alt+R

O

O

Reduce
Drawing
Texture
Resolution
Remove
Selected
Drawing

Resize
Pencil Style
Tool

O

O

Rotate 180
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Drawing Mode
COMMAND

FLASH

HARMONY

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

Rotate 90
CCW

Ctrl+7

⌘ +7

Ctrl+7

⌘ +7

Rotate 90
CW

Ctrl+9

⌘ +9

Ctrl+9

⌘ +9

Del

Del

Del

Del

Select
Morphing
Contour
Hint Mode

Ctrl+Shift+
H

⌘ +Shift+
H

F7

F7

Select
Morphing
Vanishing
Point
Mode

F10

Rotate
View Tool
Select
Delete
Morphing
Hint Mode
Select
Morphing
Appearing
Point
Mode

F10

Select
Morphing
Zone Hint
Mode
Select
Strokes
With
Current
Colour

Ctrl+Shift+
A

⌘ +Shift+
A

Ctrl+Shift+A

⌘ +Shift+A

Select Tool

Alt+V

Alt+V

Alt+S

Alt+S

Send
Backward

Ctrl+Down

⌘ +Down

Ctrl+PgDow
n

⌘ +PgDow
n

Send To

Ctrl+Shift+

⌘ +Shift+

Ctrl+Shift+P

⌘ +Shift+P
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Drawing Mode
COMMAND

FLASH

HARMONY

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

Down

Down

gDown

gDown

Show Grid

Ctrl+'

⌘ +'

Ctrl+'

⌘ +'

Show Grid

Ctrl+Alt+

⌘ +Alt+G

Back
Shift Trace
Drawing
Move
Down
Shift Trace
Drawing
Move Up
Shift Trace
Drawing
Reset
Position
Shift Trace
Drawing
Toggle Peg
State
Shift Trace
Drawing
Toggle
Visibility
Shift Trace
Move Tool
Shift Trace
Rotate
Tool
Shift Trace
Scale Tool
Shift Trace
Toggle
Manipulato
r
Shift Trace
Toggle
View
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Drawing Mode
COMMAND

FLASH
Win/Linux

HARMONY

CUSTOM

Mac OS X

Win/Linux

Mac OS X

Outiline
Only

G

Show
Other
Morphing
Key
Drawing

=

=

Ctrl+Shift+M

⌘ +Shift+M

Show
Strokes

D

D

K

K

Show/Hide
Contour
Editor
Controls

Alt+F5

Alt+F5

Alt+F5

Alt+F5

Show/Hide
Onion Skin

Ctrl+Alt+
O

⌘ +Alt+O

Alt+O

Alt+O

Smooth

Alt+Shift+
S

Alt+Shift+
S

Alt+Shift+S

Alt+Shift+S

Snap and
Align

Ctrl+Alt+,

⌘ +Alt+,

Ctrl+Alt+,

⌘ +Alt+,

Snap to
Contour

Ctrl+Alt+;

⌘ +Alt+;

Ctrl+Alt+;

⌘ +Alt+;

Snap to
Grid

Ctrl+Alt+'

⌘ +Alt+'

Ctrl+Alt+'

⌘ +Alt+'

Alt + Shift +
K

Alt + Shift +
K

Alt+V

Alt+V

Show
Symbol
Pivot

Smooth
Editor Tool

Split Pencil
Line
Stroke
Tool

Alt+/

Alt+/

Suggest
Morphing
Hints
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Drawing Mode
COMMAND

FLASH

HARMONY

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

Switch to
Line
Art/Colour
Art

L

L

L

L

Text Tool

Alt+T

Alt+T

Alt+9

Alt+9

Toggle
Backlight

Ctrl+Shift+
C

⌘ +Shift+
C

Alt+Shift+B

Alt+Shift+B

Toggle
Morphing
Key
Drawings

F4

F4

F4

F4

Toggle
Protect
Colours

Shift+S

Shift+S

Shift+S

Shift+S

Ungroup

Ctrl+Shift+
G

⌘ +Shift+
G

Ctrl+Shift+G

⌘ +Shift+G

Alt+U

Alt+U

Alt+Z

Alt+Z

Toggle
Line
Building
Mode

Unpaint
Tool
Zoom Tool

Alt+Z

Alt+Z

Function Editor
COMMAND

FLASH

HARMONY

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

Edit Next
Function

PgDown

PgDown

PgDown

PgDown

Edit Previous
Function

PgUp

PgUp

PgUp

PgUp

Insert Point

I

I

I

I
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Function Editor
COMMAND

FLASH

HARMONY

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

Select Left
Handle

[

[

[

[

Select Right
Handle

]

]

]

]

Toggle Grid

G

G

G

G

Toggle StopMotion Segment

S

S

S

S

Zoom In X

4

4

4

4

Zoom In Y

6

6

6

6

Zoom Out X

3

3

3

3

Zoom Out Y

5

5

5

5

Lock/Unlock
Point

Library
COMMAND

FLASH

HARMONY

CUSTOM

Win/Linux

Mac OS X

Win/Linux

Mac OS X

F5

F5

F5

F5

Details
List
Refresh
Rename
Thumbnails
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Tagging
COMMAND

FLASH
Win/Linux

HARMONY
Mac OS X

Win/Linux

CUSTOM
Mac OS X

Tag Selection
Untag All
Untag All Others
Untag Selection

Deformation
COMMAND

FLASH
Win/Linux

HARMONY
Mac OS X

Win/Linux

Add Articulation
Module
Add Bone
Module
Add Curve
Module
Add
Deformation
Composite
Module
Add Offset
Module
Add Root
Module
Convert Elliptic
ROI to Shape
Show Current
Deformers
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Particle
COMMAND

FLASH
Win/Linux

HARMONY
Mac OS X

Win/Linux

Show Particles as
Dots

874

CUSTOM
Mac OS X

Index

Index
About
scripting 843
Add
Create Drawing From Drawing Selection 589
Adding
Add Colour 84
Add Drawing Layer 75
Add Layers 74
Add Peg 75
Adding a New View 90
Hierarchy 572, 577
Keyframe 576
Peg 571
Pivot 582
Pivot on Frame Range 603
adjusting
Pencil Line Thickness 175
Animation
Advanced Animation Toolbar 62
Axis
Default Separate Position 554
Z axis 563
Breakdown
Adding to Existing Layer 595
Brush
Auto-flatten 599
Flatten 599
Set Current Brush Colour 85
brush styles
renaming 152
Camera
Camera View 64
Camera View Options Menu 67
Drawing Name 70
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Editing Stack Menu 70
Frame Number 70
Matte View Mode 67
OpenGL View Mode 66
Render View Mode 66
Toggle Quick Close-Up 69
Tool Name 70
Update Preview 65
Zoom Drop-down Menu 69
Camera View Toolbar 63
Symbol Hierarchy 569
Camera View 64
Character
Breakdown 556, 592
Extra View 595
Building a Character 553
Classic Joint 560
Fixing Joint 560
Joint 597
Clean Up
Cut-out Puppet 598
Remove Extra Strokes 561, 600
Close
Closing a View 91
Colour
Colour View 83
Add Colour 84
Add Texture 85
Colour Swatch 86
Colour Swatch Name 86
Colour View Menu 87
Link/Unlink Three Colours 85
Remove Colour 84
Set Current Brush Colour 85
Set Current Paint Colour 85
set Current Pencil Colour 85
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Index

Show/Hide Palette List View 86
Current View Border 107
Current View Border in Template Edit 107
Colours
Camera 108
Drawing 108
Edit Colours Button 107
Exposure Sheet 108
Network 108
Contour
Show Stroke 561, 600
Control Point
Control Point Toolbar 62
convert
pencil to brush 171
Coordinate
Coordinate Toolbar 62
Copying
Copying Pivot on Parent Symbol 232
Duplicate Drawing 580
creating
Qt scripts 844
Cut-out
Breakdown 589, 592
Building a Character 553
Classic Joint 560
Fixing Joint 560
Master Template 586
Separate Position Path 554
Cutting
Breakdown 589
Create Drawing From Drawing Selection 593, 596
Cut-out Piece Clean Up 598
Cut Artwork From Source 591, 596
Cutter Tool 590, 592, 595
Intersection 593
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Delete
Colour View 84
Delete Layers 74
Remove Extra Strokes 561
Deleting
Deleting a Workspace 101
Disable
Enable/Disable All 73
Display
Display Toolbar 62
Distribute to Layer 173
Drawing
Adding to Existing Layer 595
Brush Styles
renaming 152
Create Drawing From Drawing Selection 589, 593, 596
Cut Artwork From Source 596
Drawing Exposure 80
Drawing Substitution 79
Drawing View 62
Drawing View Toolbar 63
Duplicate Drawing 580
Extra Drawing 579
Pivot 581, 603
preview
brush line 137, 148, 179, 201
Drawing View 115
Editing
Edit Colours Button 107
Edit Toolbar 62
Editing Stack Menu 70
Enable
Enable/Disable All 73
export
scripts 847
Exporting and Importing Scripts 847
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Index

File
FileToolbar 62
Flatten 580
Auto-flatten 599
Brush Tool 599
Remove Extra Strokes 600
Flip
Flip Toolbar 62
Focus
Focus on Mouse Enter 106
Frame
Current Frame 76
Pivot on Frame Range 603
Set the Pivot for Symbol on All Frames 231, 602
Function
Function View 62
Show/Hide Functions 76
Hide
Show Selection and Hide All Others 74
Show/Hide Children 76
Show/Hide Functions 76
Show/Hide Palette List View 86
Showing and Hiding a Workspace 101
Showing or Hiding Toolbars 94
Hierarchy 567, 572, 577
Advanced 569
Parent Layer 567-568
import
scripts 847
Interface 61
Advanced Animation Toolbar 62
Camera View Toolbar 63
Colour View 83
Control Point Toolbar 62
Coordinate Toolbar 62
Creating a New Workspace 99
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Deleting a Workspace 101
Display Toolbar 62
Drawing Name 70
Drawing View 62
Drawing View Toolbar 63
Easy Flipping Toolbar 62
Edit Toolbar 62
File Toolbar 62
Flat Tool Toolbar Preference 95
Flip Toolbar 62
Function View 62
Integrated Help 62
Interface Navigation 103
Keyboard Shortcuts 57
Layer Properties View 62
Library View 62, 87
Managing the Toolbars 94
Moving Toolbars 95
Showing or Hiding Toolbars 94
Managing the Views 90
Adding a New View 90
Closing a View 91
Resizing a View 92
Swapping Views 91
Managing the Workspace 98
Loading the Workspace 98
Menu 81
Message Log 62
Model View 62
Model View Toolbar 63
Module Library View 62
Network View 62
New Mark Drawing Toolbar 63
Onion Skin Toolbar 62
Perspective View 62
Playback Toolbar 62, 88
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Index

Preferences 55
Reordering the Workspace List 102
Restoring the Default Workspaces 102
Saving a Workspace 100
Scripting Toolbar 62
Showing and Hiding a Workspace 101
Side View 62
Side View Toolbar 63
Timeline View 62, 72
Timeline View Toolbar 63
Tool Properties View 62, 71
Toolbar 62
Toolbar Manager 96
Tools Toolbar 62, 71
User Interface Preferences - General Tab 105
View 62
Workspace Toolbar 62
Xsheet View 62
Intersection
Cutter Tool 593
Joint 597
Classic 560
Fixing 560
Light Table 561
Keyboard Shortcut
Reset Pan 103
Reset Rotation 103
Reset View 103
Reset Zoom 103
Rotate 90 CW 103
To Recentre the View 103
Toggle Full Screen 103
Zoom In 103
Zoom Out 103
Keyboard Shortcuts
Selecting a Keyboard Shortcut Set 58
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Keyframe
Default Separate Position 554
Keyframe Value 79
Motion Keyframe 554
Rigging 576
Timeline View 80
Z-nudging 564
Layer
Add Drawing layer 75
Add Layers 74
Adding to Existing Layer 595
Create Drawing From Drawing Selection 593, 596
Cut Artwork From Source 591, 596
Delete Layer 74
Distribute to Layer 600
Layer Properties View 62
Lock 592
Lock/Unlock Layer 77
Ordering 563
Parent Layer 567-568
Z-nudging 564
Library
Library View 62, 87
Library Folder List 88
Library View Menu 88
Preview Playback 88
Template/Symbol List 88
Library View Menu 88
Preview Menu 88
Master Template 586
Puppet 586
Light Table
Classic Joint 561
line texture parameters
Hardness 156
Maximum Opacity 156
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Index

Minimum Opacity 156
Texture File 156
Texture Scale 157
Link
Link/Unlink Three Colours 85
Linking a Script to a Toolbar Button 847
Loading
Loading a Workspace 98
Lock
Lock/Unlock Layer 77
Locking 592
Matte
Matte View Mode 67
Menu 81
Editing Stack Menu 70
Library View Menu 88
Play Menu 89
Quick Access Menu 82
Top Menu 81
Mode
Lasso Selection Mode 590
Model
Cut-out Model 589
Model View 62
Model View Toolbar 63
Tracing the Cut-out Model 556
Module
Module Library View 62
Motion
Keyframe 554
Naming
Colour Swatch Name 86
Navigation
Interface Navigation 103
Network
Network View 62
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Onion Skin 78
Onion Skin Toolbar 62
Open
Workspace Manager 98
OpenGL
Full Scene Antialiasing Preference in the OpenGL tab 109
OpenGL View Mode 66
Ordering
Layer 563
Z-nudging 564
Overlay
Classic Joint 560
Paint
Set Current Paint Colour 85
Palette
Show/Hide Palette List View 86
Parameter
Set Current Paint Colour 85
Set Current Pencil Colour 85
Parameters
Set Current Brush Colour 85
Path
Separate Position 554
Peg
Adding 571
Master Peg 567, 571, 575
Master Peg Pivot 584
Rigging 569
Pencil
Set Current Pencil Colour 85
Pencil to Brush
convert 171
Pencil Tool options
smoothness 136
Perspective
Perspective View 62
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Index

Pivot
Copying Pivot on Parent Symbol 232
Drawing Pivot 581, 603
Frame Range 603
Master Peg 584
Pivot Tool 231
Rigging 581-582
Rotate Tool 584
Scale Tool 584
Set the Pivot for Symbol on All Frames 231, 602
Snapping 232
Symbol 601
Symbol Pivot 581
Temporary 584
Playback
Playback toolbar 62
Playback Toolbar 88
Play Menu 89
Preview Playback 88
Preference
Advanced 56
Camera 56
Deformation 56
Drawing 56
Exposure Sheet 56
Full Scene Antialiasing Preference in the OpenGL tab 109
General 56
Interface 55
Network 56
OpenGL 56
Particle 56
Preference Highlights 56
Accessing the Preferences Panel 56
Automatically Save Workspace 105
Flat Tool Toolbar 106
Focus on Mouse Enter 106
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Levels of Undo 107
User Interface Preferences - General Tab 105
Render 56
Shortcuts 56
Sound 56
Template 56
Timeline 56
User Interface Preferences - General Tab 109
Zoom Settings 109
Preferences
Separate Position 554
Preview
Preview Playback 88
Preview Window 88
Update Preview 65
Properties
Lasso 590
Tool Properties View 71
Puppet
Breakdown 556, 589, 592
Extra View 595
Building a Character 553
Classic Joint 560
Extra Drawing 579
Fixing Joint 560
Joint 597
Layer Ordering 563
Library 586
Master Peg 575
Rigging 556
Z-nudging 564
Qt scripts
creating 844
renaming
brush styles 152
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Index

Renaming
Renaming a Workspace 100
Rigging 556, 566
Advanced 569
Basics 567
Body 571
Breakdown 589, 592, 596
Extra View 595
Building a Character 553
Clean Up 598
Cutting 592
Distribute to Layer 600
Extra Drawing 579
Head 570
Hierarchy 572, 577
Keyframe 576
Master Peg 567, 571, 575
Master Peg Pivot 584
Master Template 586
Peg 569
Pivot 581-582
Pivot on Frame Range 603
Tracing the Cut-out Model 556
Rotate 90 CCW 103
Rotation
Arm Rotation 567
Pivot 581-582
Rotate Tool 584
Set the Pivot for Symbol on All Frames 602
Scaling
Scale Tool 584
script
link to toolbar button 847
scripting
about 843
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Scripting
Scripting Toolbar 62
Selecting
Create Drawing From Drawing Selection 589, 593, 596
Distribute to Layer 600
Flatten 599
Lasson Selection Mode 590
Select Tool 590
Selecting a Keyboard Shortcut Set 58
Show Selection and Hide All Others 74
Show
Show Selection and Hide All Others 74
Show Stroke 600
Show Strokes 561
Show/Hide Children 76
Show/Hide Functions 76
Show/Hide Palette List View 86
Showing and Hiding a Workspace 101
Showing or Hiding Toolbars 94
Smoothness
Pencil tool option 136
Snapping
Pivot 232
Stage
Stage Library 88
Stroke
Remove Extra Strokes 561, 600
Show Stroke 600
Show Strokes 561
Swatch
Colour Swatch 86
Colour Swatch Name 86
Symbol 88
Copying Pivot on Parent Symbol 232
Pivot 581, 601
Set the Pivot for Symbol on All Frames 231, 602
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Index

Symbol Exposure 80
Template/Symbol List 88
Symbols
Hierarchy 569
Template
Current View Border in Template Edit 107
Master Template 586
Template/Symbol List 88
Texture
Add Texture 85
Timeline
Collapse 576
Ordering 563
Timeline View 62, 72
Add Drawing layer 75
Add Layers 74
Add Peg 75
Change track Colour 77
Current Drawing Displayed in the Drawing View 75
Current Frame 76
Delete Layers 74
Drawing Exposure 80
Drawing Substitution 79
Enable/Disable All 73
Keyframe Value 79-80
Lock/Unlock Layer 77
Onion Skin 78
Show Selection and Hide All Others 74
Show/Hide Children 76
Show/Hide Data View 75
Show/Hide Functions 76
Split 76
Symbol Exposure 80
Zoom 80
Timeline View Toolbar 63
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Tool
Cutter Tool 590, 592, 595, 598
Flat Tool Toolbar 106
Flat Tool Toolbar Preference 95
Pivot Tool 231
Rotate Tool 584
Scale Tool 584
Select Tool 590
Tool Properties View 62, 71
Toolbar 62
Tools Toolbar 62, 71
Toolbar 62
Advanced Animation Toolbar 62
Camera View Toolbar 63
Control Point Toolbar 62
Coordinate Toolbar 62
Display Toolbar 62
Drawing View Toolbar 63
Easy Flipping Toolbar 62
Edit toolbar 62
File Toolbar 62
Flat Tool Toolbar 106
Flat Tool Toolbar Preference 95
Flip Toolbar 62
Managing the Toolbars 94
Model View Toolbar 63
Moving Toolbars 95
New Mark Drawing Toolbar 63
Onion Skin Toolbar 62
Playback Toolbar 62, 88
Play Menu 89
Scripting Toolbar 62
Showing or Hiding Toolbars 94
Side View Toolbar 63
Timeline View Toolbar 63
Toolbar Manager 96
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Tools Toolbar 62, 71
Workspace Toolbar 62
Tracing
Cut-out Model 556
Unlink
Link/Unlink Three Colours 85
Unlock
Lock/Unlock Layer 77
Velocity
Default Separate Position 554
View
Resizing a View 92
Swapping Views 91
Windows
Preview Window 88
Workspace Manager
Creating a New Workspace 99
Renaming a Workspace 100
Saving a Workspace 100
Xsheet
Xsheet View 62
Z
Z-nudging 554, 563-564
Zoom
Timeline View
Zoom Tool 80
Zoom Settings 109
ZoomDrop-down Menu 69

891

Toon Boom Animate 3 User Guide

892

