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Chapter 1: Introduction
Animate is a complete animation software allowing you to do endless creative projects. It comes with a very wide
variety of tools and features. In the Getting Started guide, you will learn about the main top features allowing
you to cover the basic concepts and features found in Toon Boom Animate to quickly bring you up to speed with
the software. Refer to the complete Toon Boom Animate User Guide to learn about all the tools and options as
well as advanced techniques.
This guide is divided as follows:
•

Interface on page 5

•

How to Draw on page 9

•

How to Animate on page 11

•

How to Paint on page 17

•

How to Morph Drawings on page 21

•

How to Import Bitmap Images on page 25

•

How to Create Templates on page 29

•

How to Setup a Scene on page 31

•

How to Create a Multiplane on page 43

•

How to Animate Objects and the Camera on page 37

•

How to Import Sound and Add Lip-Sync on page 47

•

How to Add Effects to your Scene on page 53

•

How to Export a Movie on page 59
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Chapter 2: Interface
It’s important that you become familiar with the following elements of the user interface, this will help you to
start using Toon Boom Animate. You can learn more about the highlights described here, and how to use them
in a production context, throughout this guide.
When you start Toon Boom Animate for the first time, the default workspace is displayed. It contains all of the
main elements you need to use.

1. Camera View
2. Tools Toolbar
3. Tool Properties View
4. Timeline View
5. Menus
6. Colour View
7. Library View
8. Playback Toolbar

Adding a View
To add a view:
1. Select the view you want to add from Windows > The desired view.
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You can also use the Window drop-down menu button included in each view already available in the
workspace. Click on the button and select a view from the list. You can only open one instance of the
same view. In other words, you cannot have two Camera views open at the same time.
You can open several instances of the same view except for the Timeline, Tool Properties, Colour and
Drawing views.

2. To dock a floating window in your workspace, drag the window’s tab onto one of the workspace’s views.

When a view is undocked, the view toolbar will automatically be displayed.
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Tool Properties View

The contextual Tool Properties view contains the most common options and operations related to the currently
selected tool. As soon as you select a tool from the Tools toolbar, the Tool Properties view will be updated.
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For example, if you choose the Select

tool in the Tools toolbar, the Tool Properties view will display the

options and operations related to the Select tool such as Snap to Contour, Apply to All Drawings, Flip
Horizontal and Flatten.

Interface Navigation
Toon Boom Animate supports zoom in, zoom out, rotate, pan and reset view position for easy interface
navigation.
•

Zoom In: Zooms into the view. From the top menu, select View > Zoom In or press [2].

•

Zoom Out: Zooms out of the view. From the top menu, select View > Zoom Out or press [1].

•

To zoom in and zoom out, hold down [Spacebar] and your middle mouse button while moving the mouse
up or down.

•

To pan the view, hold down the keyboard shortcut [Spacebar] and drag your mouse in the direction you
want to pan the view.

•

To Recentre the view: recentres the view on your mouse cursor or press [N].

•

Reset View: Resets the view to its default position. From the top menu, select View > Reset View or
press [Shift] + [M].

•

Reset Rotation: Resets the view’s rotation to its default position. From the top menu, select View >
Reset Rotationor press [Shift] + [X].

•

Reset Pan: Resets the view’s pan to its default position. From the top menu, select View > Reset Pan or
press [Shift] + [N].

•

Reset Zoom: Resets the view’s zoom to its default position. From the top menu, select View > Reset
Zoom.

•

Toggle Full Screen: Enlarges the selected view to full screen. The full screen process is done in three
stages. From the top menu, select View > Toggle Full Screen or press [Ctrl] + [F] (Windows/Linux) or [⌘ ]
+ [F] (Mac OS X).
•

First, the selected view enlarges to the maximum width or height, but keeps the tool views such as
Colour or Tool Properties view.

•

Second, the view enlarges to full screen.

•

Third, the view returns to its original size.

•

Rotate 90 CW: Rotates the Camera view 90 degrees clockwise, like an animation table. From the top
menu, select View > Rotate View CW.

•

Rotate 90 CCW: Rotates the Camera view 90 degrees counter-clockwise, like an animation table. From
the top menu, select View > Rotate View CCW.

If you're using a tablet or trackpad that supports touch, then you can also use standard two-finger
gestures for zoom, rotate, and pan of the canvas.
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Chapter 3: How to Draw
As soon as Toon Boom Animate is started, you can start to draw straight away using the default drawing layer.
How to draw:
1. In the Tools toolbar, select the Brush

tool or press [Alt] + [B].

2. In the Timeline orXsheet view, click in the first cell of the drawing layer.

3. In the Drawing or Camera view, start drawing.

4. To select a different colour, in the Colour view, select the a different colour swatch. Double-click on the
colour swatch to open the Colour Picker window and modify the colour. Remember that anything already
painted with that colour swatch will update to the new colour.
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Chapter 4: How to Animate

Now that you know about the existing tools, you can start your animation.
The first step to complete is the rough animation, which is the skeleton of your animation. You would usually
start with the main action. For example, to animate a walk-cycle, you will start with the torso moves and the legs.
Head, arms and clothes will be added later, during the secondary animation.
For a satisfactory animation, complete the main action before adding all of the details. If you start animating all
of the details right away, you will lose a lot of time if you have to do corrections, and your animation will often
look too rigid.
To animate:
1. In the Preferences panel, you can set your preferences to Use Current Frame as Drawing Name.
2. In the Tools toolbar, select the Brush

tool or press [Alt] + [B].

3. In the Colour view, select the colour you will use to draw. It is a good idea to choose a light colour for your
rough animation to help for the following task, the clean up process.

4. In the Timeline or Xsheet view, select the cell where the first drawing will appear.
5. In the Camera or Drawing view, draw the first key drawing.
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6. Make sure your first key drawing is still selected, and in the Mark Drawing toolbar, click on the Mark
Selected Drawings as Key button.
‣

In the Xsheet view, you can also select Animation > Mark Drawing As > Key Drawing to identify your
drawing.

7. In the Tools toolbar, click on the Enable Onion Skin

button.

8. In the Timeline view, click and drag the onion skin blue markers to extend the number of previous and
next visible drawings to fit your need.

9. In the Timeline or Xsheet view, select the cell where your next key drawing will appear.

10. In the Camera or Drawing view, draw your second key drawing.
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11. In the Xsheet view, identify the drawing as a key drawing.

12. In the Xsheet view, select a cell between your two key drawings.

13. From the Timeline View toolbar, click
‣

to create an empty drawing or press [Alt] + [Shift] + [R].

In the Xsheet view, right-click and select Drawings > Create Empty Drawing or press [Alt] + [Shift] +
[R].

14. Draw your new drawing.
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15. If necessary, in the Xsheet view, identify the new drawing as a Key, Breakdown or In-between drawing.

16. In the Timeline or Xsheet view, select a new cell and repeat step 9 to step 15 for each new drawing.
17. In the Timeline view, disable the layers you do not want to show during playback.
18. In the Playback toolbar, click on the Loop
19. In the Playback toolbar, click on the Play

button if you want the playback to loop.
button to start the animation.

Cleaning Up
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When your rough animation is ready, it is time to clean it up and ink it. The clean-up is also called tracing. It
consists of tracing solid and clean lines over the rough animation to get closed zones. This is the final paperless
animation step before the ink and paint step.
You will need to add a new drawing layer to draw your clean. This is the equivalent of adding a sheet of paper
and tracing the rough using the animation disk.

If you plan on tracing your animation in the Drawing view, you will need to enable the Light Table
feature in order to display all the layers of your project.

To trace your animation in a new layer:
1. In the Timeline View toolbar, click on the Add Drawing Layer

button.

2. In the Timeline view, click on the lock icon of the layer containing your rough animation to prevent any
accidental changes.

3. In the Timeline or Xsheet view, select the new layer’s cell corresponding to the first key drawing of your
rough animation.
4. In the Tools toolbar, select the drawing tool of your choice. We recommend the Pencil

tool.

5. In the Colour view, select the colour you will use to trace your animation. Pick a dark bold colour such as
black to make sure it contrasts well with the light colour of your rough animation.
6. In the Camera or Drawing view, start tracing the first key drawing.

7. If you have some other layers in the way, you can disable them temporarily from the Timeline view so that
only your rough animation and your clean up layer are displayed in the Camera view.
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8. In the Tools toolbar, click on the Enable Onion Skin

button and extend the Onion Skin In the Timeline

view.

9. In the Timeline or Xsheet view, select the next cell corresponding to a rough drawing.
10. In the Camera view, trace your next drawing.

11. Repeat the previous steps for each drawing.

This method allows you to keep the roughs and the cleans intact. You only need to disable the rough
layer to prevent it from appearing in the scene.
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Chapter 5: How to Paint
Toon Boom Animate has some very powerful colouring features when it comes to painting. To paint your
drawings you will use different colour swatches, unlike some paint programs where you modify one swatch each
time you want to paint with a different colour.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You
can add as many swatches as you want. You can also rename them and modify existing ones.

When you modify the colour of an existing swatch it automatically updates all the zones painted with this swatch
throughout the entire project. The colour swatch has a unique ID number that associates it with the painted
zones. This way, you can change the look of your character at anytime without having to repaint it!
In colour animation, specific colours are used to paint each particular character. In order to maintain absolute
consistency, a colour palette is created for each character, prop and effect throughout the production. These are
referred to as master palettes.
Master palettes contain a colour swatch for each zone to colour with a precise RGBA colour value.
Using a master colour palette has many benefits, including:
•

Each character consistently retains their dedicated colours.

•

You cannot accidentally use a colour which is not in the master palette.

•

Standardization and colour consistency throughout the production
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•

Multiple artists can use the same colour palette and produce the same results.

Toon Boom Animate uses palettes to hold all of the colours needed to paint your elements, allowing complete
control and consistency in your painting process.
A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette
and add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, tongue,
shirt, pants, etc.
Learn how to paint your drawings by following these instructions.
To paint your drawings:
1. In the Tools toolbar, select the Paint

tool or press [Alt] + [I].

2. In the Colour view, select a colour from the palette.
‣

Double-click on a colour swatch to open the Colour Picker window and modify the colour.

The colour palette will only appear in the Colour view once a drawing element has been selected.

3. In the Camera or Drawing view, start painting the colours on your drawing.

18

Toon Boom Animate 3 Getting Started Guide

Closing Gaps

When painting, you will notice that some of your drawing areas are not closed. To close the zone you can either
draw the missing line with the Brush or Pencil tool, but you can also close the gap with an invisible line. To do so,
you will use the Close Gap
tool.
The Close Gap tool is used to close small gaps in a drawing. The Paint tool only paints closed areas. The Close
Gap tool will create a small, invisible stroke between the two closest points to close the colour zone. You do not
need to trace directly over the gap. You can draw it a few millimetres away and the Close Gap will automatically
choose the two closest points and close the gap.
To use the Close Gap tool:
1. In the Tools toolbar, select the Close Gap

tool. You can also select the Close Gap tool from the top

menu under Drawing> Tools > Close Gap or press [Alt] + [C].
‣

Enable the Auto-Flatten

option in the Tool Properties view if you want the stroke you will draw to

be flattened in your drawing instead to be on top.
‣

You can display the invisible lines with the Show Strokes option under View > Show Strokes or press
[K].

‣

If you do not display the strokes, a Message dialog box will appear.
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Enabling the Don’t Show This Message Again option prevents this Message dialog box from appearing.
2. In the Camera or Drawing view, trace an invisible line near to the gap to be closed. The gap will
automatically close.
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Chapter 6: How to Morph Drawings

Once you are familiar with the basic rules, you can start creating morphing sequences. You need to practice and
become at ease with the Morphing feature. To begin, start with simple elements, once you become confident
with the morphing process you can move on to complex and advanced morphing techniques, such as head
rotation or full characters.
To create a basic morphing:
1. In the Timeline view, click on the Add Drawing Layer

button to add a new layer to your project.

2. Rename the new layer Morphing.
3. In the Timeline or Xsheet view, select the first cell in your layer.

4. In the Tools toolbar, select the Rectangle

tool or press [Alt] + [7].

5. In the Tool Properties view, enable the Auto Fill

option.

6. In the Colour view, click on the Set Paint Current Colour

button.

7. In the Colour list, select a colour to fill your rectangle with.

8. In the Colour view, click on the Set Pencil Current Colour
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9. In the Colour list, select a colour to trace your rectangle's outline with.

10. In the Camera or Drawing view, draw a rectangle.
‣

Hold down the [Shift] key if you want to draw a square.

‣

Hold down the [Alt] key if you want to draw the rectangle from its centre.

11.In the Xsheet or Timeline view, select the last cell.

12. Repeat Step 5 to Step 10 using the Ellipse

tool instead of the Rectangle tool or press [Alt] + [=].

‣

Draw an ellipse using the same outline colour as the rectangle ("Outline").

‣

Paint the ellipse with the same fill colour as the rectangle ("Fill").

13. In the Xsheet or Timeline view, select your first drawing's cell, the rectangle drawing.

14. In the Xsheet or Timeline view, right-click on the selection and select Morphing > Create Morphing or
press [Alt] + [M].
‣

In the top menu, you can also select Animation > Morphing > Create Morphing.
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Arrows appear between the two key drawings to show they are computer generated.

15. Use the Playback toolbar to play the morphing sequence. To flip through the in-betweens toggle between
[,] and [.] or press [F4] to toggle between the two key drawings.

23

Chapter 6: How to Morph Drawings

24

Toon Boom Animate 3 Getting Started Guide

Chapter 7: How to Import Bitmap
Images
A bitmap image is an image composed of pixels that is both size and resolution-dependant.
To import a bitmap image:
1. From the top menu select File > Import > Images. You can also click on the Import Images

button in

the File toolbar.
‣

In the Xsheet view, you can right-click anywhere in the frame area and select Import > Drawings.

The Import Images dialog box opens.

2. In the Files section, click Browse to find and select one or several images on your computer.
3. In the Layer section, you have the option of creating a whole new layer for your image or adding the image
to an existing layer.
‣

To create a new layer, select Layer > Create Layer(s) > Create Single Layer Named and name your
layer accordingly.

OR
‣

To create a new layer using the file name, select Layer > Create Layer(s) > Create Layer(s) Based on
Filenames.

OR
‣

To add the image to an existing layer, select Layer > Add to Existing Layer and select the layer
already created in your Animate file from the drop-down menu. If only vector
layers are available in
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your scene (and therefore the drop-down menu), you will either have to Vectorize Imported Items,
Create Symbols for imported Items or check both options to put your bitmap image on a vector layer.

If you vectorize your image usring the Vectorize as Colour option, you can import it on a vector layer,
and use vector tools on it.

4. In this case, uncheck the Vectorize Imported Items option.
The vectorization options are hidden and the Transparency section appears.

5. In Toon Boom Animate, if you want your bitmap images to be encapsulated in a symbol, enable the
Create Symbol for Imported Items option. If not, disable the option. If you chose to add your image to
an existing vector layer then the Create Symbol for Imported Items will automatically be checked and
greyed out.
6. Next, in the Alignment section, you must decide on the size and placement of your image within the
camera frame. Depending on the Scene Settings (the height and width in pixels that you chose for your
project), an image that you import may get scaled to the point where all its individual pixels become
visible.

Be sure that you are in the Camera view’s Render Mode when judging an imported image, otherwise
it may appear blurry.when judging an imported image, otherwise it may appear blurry.

The following three options are available
•

•

Alignment > Rules > Fit
•

If your image orientation is portrait format, this selection will enlarge or shrink (but not distort) to your
image height to match the full height of the camera frame.

•

If your image orientation is landscape format, this selection will enlarge or shrink (but not distort) your
image width matches that of the camera frame.

Alignment > Rules > Pan
This selection achieves the opposite result of the Fit command.

•

•

If your image orientation is portrait, its width will be made to match the width of the camera frame. As
a result, part of the image’s height will extend beyond the height of the frame.

•

This can be useful if you want to make your background move up and down, or from left to right to
make it appear as if the camera is panning, or to actually perform a camera pan.

Alignment > Rules > Project Resolution
This selection will scale the image in proportion to the scene's resolution. The system looks at the
resolution of the bitmap image, for example 4000 x 2000, then compares it to the scene's resolution, for
example 1920 x 1080, and adjusts the scale factor in proportion. So in this example the bitmap would
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appear at 208% (4000/1920). If you import a bitmap that is 960 x 540 it will be displayed at 50% (960/1920)
of the size of the project resolution.
7. The last step is to decide on the image’s transparency from the Alpha drop-down menu. For this, there
are four options available. These options deal with the way that the bitmap image will be antialiased,
more specifically the way that the pixels along the edge are blended in the RGBA (red, green, blue, alpha
(transparent)) channels.

The options are:
‣

Premultiplied with White

Individual pixels at the edge of an image are blended with white.
‣

Premultiplied with Black

Pixels at the edge of an image are blended with black.
‣

Straight

Pixels at the edge of an image are blended with black, white and greys.
‣

Clamp Colour to Alpha

Select this option if you want to premultiply the colour value with the alpha value. When the colour is
clamped to the alpha, the colour value cannot be higher than the alpha value. If you have a pixel of value
R=247, G=188, B=29 and the alpha is 50% (the image is 50% transparent, then the actual RGB value
output would be half of the amounts listed above.
8. Click OK.
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Chapter 8: How to Create Templates
You can create a template out of a layer or cells. You can store anything available in the Timeline view as a
template.

Creating a template selecting a layer will incorporate the layer and all the drawings that were created
in it, even if they're not exposed in the Timeline view. Selecting cells will only save those specific
drawings in the template.

To create a template from the Timeline view:
1. In the Timeline view, select some cells or layers.
2. In the Library view, select the folder in which you want to store the template.
3. If the library folder is locked,right-click and select Right to Modify.
4. Drag the selection to the Animate Library folder or to any other library folder.

5. In the Rename dialog box, rename the new template.

If you want to rename a template once it is created,right-click on it and select Rename.
6. Click OK.
To import a template in the Timeline view:
1. In the Library view, select the template you want to import.
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2. Drag the selected template to the Camera view or Timeline view's left side.

3. You can also drag a template to the Timeline view's right side into existing layers if the layer structure is
the same as the existing one.
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Chapter 9: How to Setup a Scene
This chapter is divided as follows:
•

Positioning the Camera below

•

Positioning Objects on the facing page

•

Repositioning the Pivot on page 34

Positioning the Camera
Refer to How to Animate Objects and the Camera on page 37 to learn how to animate the camera.

To set the camera frame, add a Camera layer into your scene so you can edit the default camera frame.
To add a Camera layer in the Timeline view:
1. In the Timeline view, click the Add Layer

button or select Insert > Camera from the top menu.

2. Select Camera from the drop-down menu.
A new camera layer is added to your scene and appears in the Timeline view.

You cannot add a camera inside a symbol. If you try to do so, a warning message will pop-up and
inform you that this operation is not possible.

If you've added more than one camera to your scene, you can switch the active camera by going to
Scene > Camera and selecting the camera you want to use.

You can reposition your camera frame directly in the Camera view, using the Translate

and Rotate

tools.

To reposition the camera frame directly in the Camera view:
1. Select Animation > Tools > Translate or press [Alt] + [2].
2. In the Camera view, click on the camera frame to select it. You can also select the camera layer from the
Timeline view.
The selected camera frame is highlighted in purple.
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3. Drag the camera frame to a new position.

4. To tilt the camera frame, select Animation > Tools > Rotate or press [Alt] + [3].
5. In the Camera view, click on the camera frame to select it and rotate the camera frame until it reaches the
desired rotation angle.

The Translate and Rotate tools can also be found in the Advanced Animation toolbar.

Positioning Objects
Refer to How to Animate Objects and the Camera on page 37 to learn how to animate objects.
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To pan a layer using the Transform tool:

1. In the Tools toolbar, select the Transform

tool.

2. In the Transform tool Tool Properties view, make sure that the Peg Selection Mode

is disabled.

3. In the Camera view, select a drawing layer and drag the selection to a new area.
To rotate a layer using the Transform tool:

1. In the Tools toolbar, select the Transform

tool.

2. In the Transform tool Tool Properties view, make sure that the Peg Selection Mode

is disabled.

3. In the Camera view, select the drawing layer and rotate the transform bonding box handle.

A preference found in the Camera tab will add a rotation handle to your object’s bounding box.This preference
is off by default.
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To scale a layer using the Transform tool:

1. In the Tools toolbar, select the Transform

tool or press [Shift] + [T]

2. In the Transform tool Tool Properties view, make sure the Peg Selection Mode

is disabled.

3. In the Camera view, select the drawing layer and then pull or push either on the size, top or corner control
point. Hold down [Shift] to lock the selection’s ratio.
To skew a layer using the Transform tool:

1. In the Tools toolbar, select the Transform

tool.

2. In the Transform tool Tool Properties view, make sure that the Peg Selection Mode

is disabled.

3. In the Camera view, select the drawing layer and drag sideway or up and down the sides or top and
bottom segments, between the control points.

Repositioning the Pivot
Some transformations, such as the rotation, scale, skew and flip, are made relative to the pivot point position.
Reposition this pivot point anywhere using the current Advanced Animation tool.
To permanently reposition the pivot point:
1. In the Advanced Animation toolbar, select the Rotate

, Scale

or Skew

tool.

2. In the Camera view, [Ctrl] + click (Windows/Linux) or [⌘ ] + click (Mac OS X) to select your element.
The pivot point appears in the Camera view.
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3. Click the pivot point and drag it to a new position.

This is the new position of the pivot point for future transformations until you reposition it.

Using the Advanced Animation tools to reposition your pivot permanently overrides the existing
pivot point position until you change its position again.
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Chapter 10: How to Animate Objects
and the Camera
This topic is divided as follows:
•

Animating a Layer below

•

Animating the Camera on page 39

Animating a Layer

You can create a motion path directly on your layers.
Drawing layers can house drawings and symbols. Also, in that same layer you can create a motion path using
keyframes and all the artwork contained in the layer will follow.

You can control and define your trajectory using several different parameters. These parameters are:
•

X, Y and Z positions

•

Angle (rotation)

•

Skew

•

X and Y scales

Each parameter has its own function curve where you can add keyframes and control the easing.
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Do not worry about using graphs and function curves if you are not familiar with this concept. Animate has a
series of easy-to-use tools for visually controlling your trajectories in the Camera view.
To animate a simple object such as an arrow in flight or a wheel spinning, you can use the integrated trajectory.
Also, each part of a cut-out puppet will be animated directly on the drawing layer.
Follow these simple steps to perform a basic layer animation.
To animate a layer:
1. In the Tools toolbar, select the Transform
‣

tool or press [Shift] + [T].

In the Tool Properties view, make sure the Peg Selection Mode

button is disabled so you can

select your drawing layer directly and not the pegs. Refer to the section to learn more about this
option.
2. In the Tools toolbar, enable the Animate

mode .

3. In the Timeline view, go to the first frame.

4. In the Camera view, select the element to animate and move it to its first position.

5. In the Timeline view, go to the frame where you would like to set the second position.

6. In the Camera view, move the selected element to its new position.
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7. In the Playback toolbar, click the Play

button to view your work.

Animating the Camera
The camera is treated the same way as any other element. The same tools and selection modes are used to
offset or animate it. To animate the camera, you need to connect it to a peg element.

This means that you can animate the camera visually, with the function curve, or by typing values in the Xsheet
column.
To add a camera with a peg to your scene:
1. If you do not already have a camera layer, add one in one of two ways:
‣

From the top menu, select Insert > Camera

‣

From the Timeline View Layers toolbar, click the Add Layers

‣

From the Library view, select a Camera module and drag it to the Network view.

button and select Camera.

A new camera layer is added to your scene and appears in the Timeline view.
2. From the Timeline View Layer toolbar, click the Add Peg

button.

A peg layer appears directly above the camera layer so that the camera layer is automatically attached to
it. The peg layer automatically takes on the name of the camera and adds the suffix -P to indicate that it is
a peg layer, for example Camera-P.
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If the new peg layer did not appear directly above the camera, you may have clicked elsewhere in the
scene, deactivating the layer on which you want to add the peg layer.
‣

Select the camera layer and drag and drop in under the new peg layer.

OR
‣

Delete the misplaced peg layer, select the camera layer and click the Add Peg

button again.

You are now ready to animate your camera.
It is recommended to use both the Top and Camera views while making camera moves. You can open this view is
one of two ways:
•

From the top menu, select Windows > Top.

•

From any existing window already open in your project, click the arrow

button in the top-right corner

and select Top.

To animate your camera:
1. Make sure that the Animate

button and Transform

tool are activated.

2. In the Top, Side or Camera view, select the camera and move it to the desired position.
‣

In the Top and Sive view, the camera is the large V cone. You need to click directly on one of the edge.

40

Toon Boom Animate 3 Getting Started Guide

‣

In the Camera view, the camera is represented by a thin frame. You need to click directly on one of the
edge.

3. In the Timeline view, click on a cell in the Camera Peg layer where you want the camera move to begin.
4. Right-click and select Insert Keyframe.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera
position as in this keyframe.
5. Click on another cell, further down your scene's Timeline, where you want the camera move to end.
6. Select the camera in the Top view and move it to the desired position.

A second keyframe appears and a line is created between the two frames to indicate that the subsequent
motion between the frames will be calculated and rendered by the program.
7. Play back

the camera move in the Camera view to watch the results.
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Chapter 11: How to Create a Multiplane

To construct a multiplane, you must imagine what a real environment is like. Take a look at your background
picture and imagine a camera moving across the space. You will notice that objects in the picture would move at
different speeds depending on where they are in relation to the camera lens.
Building a multiplane requires an understanding of the scene's background as well as the positioning of the
elements on different layers.

For example, in this background, the main objects to be separated are:
1. Fern
2. Front tower
3. Second tower
4. Moon
5. Stars
6. Sky
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Although the bottom of the tower is hidden behind the plant and the ladder, each of your multiplane
layers should be a complete drawing. This is because hidden portions may show up during a camera
movement later on in the scene

Now is the time to distribute the layers composing your multiplane along the Z-axis, maintaining their distance.
You can position your layers on the Z-axis in the Side and Top view.
Positioning your element toward the camera will make your element bigger. Using the Maintain Size

tool,

you will be able to drag your element toward the camera while keeping the same size aspect in the Camera view.
This tool is available in the Advanced Animation toolbar.

It is a good idea to keep a Camera view opened to see what your scene looks like while positioning
your element in the Top or Side view.

Positioning Elements in the Top and Side Views

To be able to distribute the layers along the Z-axis using the Top and Side views, disable the No Z
Dragging option by selecting Animation > No Z Dragging.

To position your element in the Top and Side views:
1. In the Advanced Animation toolbar, click the Maintain Size

tool or press [Alt] + [6].

2. In the Side view, select one of the layers in the thumbnails section of the Top or Side view. You can also
select your layer from the Timeline view.
The selected layer will be highlighted in the camera cone.
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3. Click and drag the layer to the correct depth position in the camera cone. Your element aspect will remain
the same in the Camera view.

4. In the Tools toolbar, click the Transform

tool, or select the Translate

tool in the Advanced

Animation toolbar and select a layer from the thumbnails section of the Top or Side view. You can also
select your layer from the Timeline view.
‣

If you choose the Transform

tool, make sure that the Peg Selection Mode

option is disabled in

the Transform tool's Tool Properties view.
The selected layer will be highlighted in the camera cone.

5. In the T O P view, drag the element sideways to position horizontally. You can press and hold [Shift] while
dragging the element to make sure it only moves along the X-axis.
6. In the Side view, drag the selected element up or down to position it vertically. You can press and hold
[Shift] while dragging the element to make sure it only moves along the Y-axis.
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Chapter 12: How to Import Sound and
Add Lip-Sync
If you decide to add sound to your movie, you must first prepare this sound outside of Animate. When this is
done you must add a sound element in Animate to the organize sound files in your animation. Sound will play in
the movie until it reaches the end of the file or a stop frame that you have created in the Sound Element Editor.

If you first create your project in Toon Boom Storyboard Pro, the sound will be cut up into the
different scenes for you automatically.

You can import WAV, AIFF or MP3 sound files using any of the methods listed below.
To import a sound file:
1. Select File > Import > Sound
‣

Right-click anywhere in the frame zone of the Xsheet view.

‣

From the Top menu

‣

From the Xsheet View menu

‣

From the Timeline View menu

The Select Sound File dialog box opens.

2. From the Select Sound File dialog box find and select your sound file from your computer.
Your sound file appears as a layer in both the Timeline and Xsheet view.
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Lip-Sync

Adding a lip-sync to a project can really enhance its quality and storytelling. However, it can be difficult to shape a
character's mouth so that it matches the sound at the precise frame.

To solve this problem Animate provides a lip-sync feature which analyzes the contents of a sound element and
generates a mouth chart (see below) based on the eight animation phonemes (A, B, C, D, E, F, G, and X, which is
used to represent silence).
The mouth shapes used by Animate are based on the conventional mouth chart used in the animation industry.

The letters used to represent the shapes do NOT correspond to an actual sound.
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Here is an approximation of which sound each mouth shape can produce:
•

A: m, b, p, h

•

B: s, d, j, i, k, t

•

C: e, a

•

D: A, E

•

E: o

•

F: u, oo

•

G: f, ph

•

X: Silence, undetermined sound

You can lip-sync the traditional way or let the system automatically create the basic detection.
You can refer to the mouth chart positions as you draw the shape of your character's mouth.

Automatic Lip-Sync Detection
To generate a sound detection for your lip-sync using the Layer Properties view:
1. In the Timeline or Xsheet view, select your sound layer.
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2. In the Layer Properties, click on the Detect button.

A progress bar appears while Animate analyzes the selected sound clips and assigns a lip-sync letter to
each sound cell.
Animate can automatically map drawings in an element to the mouth chart you have generated for a sound. This
can save time when you are lip-synching a voice track.
In the Lip-Sync Mapping dialog box, you can identify each lip drawing of a character. Animate then automatically
labels all of the cells in the character's element with the appropriate name.
To automatically map lip-sync drawings to a mouth layer:
1. To open the Lip-Sync Mapping dialog box:
‣

In the Timeline view,right-click on any cell in the sound sample layer. From the pop-up menu, select LipSync > Map Lip-Sync. You can also select Animation > Lip-Sync > Map Lip-Sync from the top menu.
OR

‣

In the Timeline view, select your sound layer and in the Layer Properties view, click on the Map button.

The Lip-Sync Mapping dialog box opens.
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2. From the Destination Layer drop-down list, select the layer that contains the mouth positions for the
character's voice track.

3. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on the
layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to
use the drawings or select the desired symbol from the drop-down menu.
4. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the phoneme
it represents. If your drawings are already named with the phoneme letters, you do not have to do
anything.
5. Click on the OK button.
6. Press the Play

button in the Playback toolbar to see and hear the results in the Camera view. To play

back your scene with sound, enable the Sound

button in the Playback toolbar.
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Chapter 13: How to Add Effects to your
Scene

Once your animation is completed, you can add effects such as blurs and glows to make your project look even
better! Animate provides you with a series of essential effects that you can add to your layers.
This chapter is divided as follows:
•

About Effects below

•

Adding Effects on the facing page

•

Tone Effect on page 56

•

Animating an Effect Over Time on page 57

About Effects
An effect always needs a drawing connection and sometime a matte or shape connection. A matte provides
drawing information that will be used to determine the area where the effect will be applied on the drawing. The
details and colours within the matte drawing do not matter, as the system will only use the shape and
transparencies in it. A matte is also known as mask.
The matte principle can be demonstrated on the Tone effect.
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The drawing layer is connected in the right port of the effect and the matte (mask) in the left port. The Tone
effect then applies darker colours where the matte overlaps the image, blurs the tone edge, and finally clips out
the extra tone zone outside of the drawing before outputting a final drawing with a tone.
The tone's parameters can be adjusted in the Layer Properties view and any of them can be linked to a function
column to be animated over time. This means that all of the effects can be customized.

Adding Effects
To add effect in the Timeline view:
1. In the Timeline view, click on the Add Layers button and from the Layers drop-down menu, select Effects
> the desired effect. You can also select Insert > Effects > the desired effect from the top menu.
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2. The effect appears in the Timeline view.
3. Drag the drawing layer on the new effect layer to parent them.

4. In the Camera view, click on the Render View Mode

button to see the result of rendering the scene's

current frame and the effect .
5. In the Timeline view, double-click on the effect layer to open the Layer Properties view.
The Layer Properties view opens, displaying the parameters available for the selected effect.

6. In the Layer Properties view, adjust the effect’s parameters.
7. In the Camera view, click on the Update Preview

button to update the rendered preview.

8. To play back your scene with the final effects, in the Playback toolbar, click on the Render and Play
button.
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Tone Effect

Use a Tone effect to add a dark-coloured region to your drawing and simulate the shaded area away from a light
source. To produce the tone effect, create a drawing to control where the tone will appear. The Tone effect uses
a matte to determine the shape and position of the tone on your drawing and can be blurred at the edges to
create a softer effect.

For information on all effects, check out the Online Help. The Tone Effect is shown here as an
example.

Use the Tone editor to control the type and amount of blur, as well as the colour of the tone.

•

Truck Factor: Activated by default, this option readjusts the blur when the elements undergo a change of
depth or scale. When this option is disabled, the effect's values will remain unchanged regardless of
depth or scale changes. It is recommended that this option be disabled when multiple drawings are
composited and attached this effect.
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•

Blur Type (Directional or Radial):
•

If Directional is selected, Animate will blur the matte in the direction you select.

•

If Radial is selected, Animate will blur the edges of the matte evenly around points that make up the
edge of the matte.

•

Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur
radius is affected by the drawing scale and camera position.

•

Directional Angle: If you select a Directional Blur Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.

•

•

0: Blurs the image to the west.

•

90: Blurs the image to the south.

•

180: Blurs the image to the east.

•

270: Blurs the image to the north.

Directional Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.
•

A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.

•

A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.

•

Invert Matte: Activate this option to invert the matte used to create the tone.

•

Use Matte Colour: Uses the matte shape colour to create the tone.

•

Multiplicative: Multiplies the tone colours with the background.

•

Red/Green/Blue/Alpha: In the RGBA fields, you can enter the value you want added to or subtracted
from the colour channels in the drawings or you can attach these values to function curves.

Animating an Effect Over Time
In Animate, to animate an effect over time, create a function curve by adding keyframes to the parameters you
want to animate. To do this, you will use the Layer Properties view and the Timeline view. You can fine tune your
animation using the Function view.
To animate an effect over time:
9. In the Timeline view, add the effect and connect the layers to it.

10. Select the Effect layer.

11. To create the function curve:
‣

In the Layer Properties view, click on the Function
function curve.
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OR
‣

You can also expand the effect layer's parameters in the Timeline view by clicking on the Expand
Function button and add a keyframe using the [F6] key to the parameter you want to animate.

12. In the Timeline view, click on the Show Data View

button.

13. In the Timeline view, go to the frame where you want to start animating the effect.

14. In the Data view, click on the Add Keyframe

button.

15. In the Value field scroll to the keyframe value or type the value in the field.

‣

If your keyframes are stop-motion keyframes, in the Timeline view, select the new keyframes. Rightclick on the selection and select Set Motion Keyframe.

16. Repeat this process for each keyframe to be added.
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Chapter 14: How to Export a Movie
To export a QuickTime Movie:
1. From the top menu, select File > Export > Movie.
The Export to QuickTime Movie dialog box opens.

2. From the dialog box, click Browse to choose a destination path to where your movie will be saved and an
appropriate filename for the export.
3. Click Save when you are finished.
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