User Guide

Legal Notices
Published by Toon Boom Animation Inc.
Corporate Headquarters
7 Laurier Avenue East
Montreal, Quebec
Canada H2T 1E4
Tel: (514) 278-8666
Fax: (514) 278-2666
toonboom.com

Disclaimer
The content of this manual is covered by a specific limited warranty and exclusions and limit of liability under the
applicable License Agreement as supplemented by the special terms and conditions for Adobe® Flash® File Format
(SWF). Please refer to the License Agreement and to those special terms and conditions for details.
The content of this manual is the property of Toon Boom Animation Inc. and is copyrighted. Any reproduction in whole
or in part is strictly prohibited.
For additional copies of this manual, please contact Toon Boom Animation Inc. at the Corporate Headquarters
address.
Copyright © 2010 by Toon Boom Animation Inc. All rights reserved.

Trademarks
Toon Boom Animate and Toon Boom Animate PRO are trademarks owned by Toon Boom Animation Inc. All other
trademarks are the property of their respective owners.

Credits
Documentation Development: Peter Cawthorne
Content Development: Marie-Eve Chartrand, Anouk Whissell, Shabana Ali
Art Development: Marie-Eve Chartrand, Anouk Whissell, Shabana Ali, Tania Gray, Annie Rodrigue

Publication Date
April 2010

Contents
Chapter 1: Introduction .......................................................................................................................................... 21

Visual Markers ........................................................................................................................................................... 22
Product Icons ........................................................................................................................................................ 22
Animate Only .................................................................................................................................................... 22
Animate Pro Only ............................................................................................................................................. 22
Information Icons .................................................................................................................................................. 22
Reference .......................................................................................................................................................... 22
Important Note ................................................................................................................................................. 22
Tip ..................................................................................................................................................................... 22
Tool ................................................................................................................................................................... 22

Chapter 2: Getting Started ................................................................................................................................... 23

Launching Toon Boom Animate ............................................................................................................................... 23
Preference Styles ................................................................................................................................................. 24
Welcome Screen ...................................................................................................................................................... 25
Accessing Tutorials and Documentation .............................................................................................................. 25
Creating and Opening a Scene ............................................................................................................................... 26
Using the Welcome Screen .................................................................................................................................. 26
Using the File Menu .............................................................................................................................................. 27
New Scene Startup Script .................................................................................................................................... 28
Setting the Scene Length ........................................................................................................................................ 29
Scene Settings ......................................................................................................................................................... 29
Resolution Tab ..................................................................................................................................................... 30
Alignment Tab ..................................................................................................................................................... 31
Alignment Rules ................................................................................................................................................ 32
Advanced Tab ...................................................................................................................................................... 33
Adding a Drawing Layer .......................................................................................................................................... 33
Verifying Project Integrity (PRO) ............................................................................................................................... 34
Check Files (PRO) ................................................................................................................................................ 34
Check Colours (PRO) ........................................................................................................................................... 34
Basic Commands ...................................................................................................................................................... 35

Chapter 3: Discovering the Interface ................................................................................................................ 39

User Interface ............................................................................................................................................................ 40
Views and Toolbars ............................................................................................................................................... 40
Views: Animate ................................................................................................................................................. 40
Views: Animate Pro .......................................................................................................................................... 40
Top Toolbars: Animate ..................................................................................................................................... 40
Top Toolbars: Animate Pro .............................................................................................................................. 40
View Toolbars: Animate .................................................................................................................................... 40
View Toolbars: Animate Pro ............................................................................................................................. 40
Interface Highlights ............................................................................................................................................... 41
Camera View ..................................................................................................................................................... 42
Tools Toolbar .................................................................................................................................................... 45
Tool Properties View ........................................................................................................................................ 45
Timeline View .................................................................................................................................................... 46
Menus ............................................................................................................................................................... 53
Colour View ...................................................................................................................................................... 54
Library View ...................................................................................................................................................... 57
Playback Toolbar .............................................................................................................................................. 58
Managing the Views ................................................................................................................................................. 60
Adding a New View .............................................................................................................................................. 60
Closing a View ...................................................................................................................................................... 61
Swapping Views .................................................................................................................................................... 61
Resizing a View ..................................................................................................................................................... 61
Managing the Toolbars ............................................................................................................................................. 62
Showing or Hiding Toolbars ................................................................................................................................. 62
Moving Toolbars ................................................................................................................................................... 62
1

Animate Pro 2 User Guide

Toolbar Manager .................................................................................................................................................. 63
Managing the Workspace ......................................................................................................................................... 64
Loading a Workspace ........................................................................................................................................... 64
Workspace Manager ............................................................................................................................................ 64
Creating a New Workspace .............................................................................................................................. 64
Renaming a Workspace .................................................................................................................................... 65
Saving a Workspace ......................................................................................................................................... 65
Deleting a Workspace ...................................................................................................................................... 66
Showing and Hiding a Workspace ................................................................................................................... 66
Reordering the Workspace List ........................................................................................................................ 67
Restoring the Default Workspaces ....................................................................................................................... 67
Interface Navigation ................................................................................................................................................. 68
Preferences ............................................................................................................................................................... 69
Preference Highlights ........................................................................................................................................... 70
Accessing the Preferences Panel ...................................................................................................................... 70
User Interface Preferences - General Tab ........................................................................................................ 70
Automatically Save Workspace ........................................................................................................................ 71
Focus On Mouse Enter ..................................................................................................................................... 71
Levels Of Undo ................................................................................................................................................. 71
Colours ............................................................................................................................................................. 71
User Interface Preferences - Camera Tab ............................................................................................................ 73
Zoom Settings .................................................................................................................................................. 73
Keyboard Shortcuts .............................................................................................................................................. 73
Selecting a Keyboard Shortcut Set ................................................................................................................. 73
Customizing a Keyboard Shortcut .................................................................................................................... 74

Chapter 4: Drawing and Animating................................................................................................................... 75

How to Draw ............................................................................................................................................................. 76
Tool Properties View ................................................................................................................................................ 77
Manipulators ......................................................................................................................................................... 77
Options ................................................................................................................................................................. 77
Operations ............................................................................................................................................................ 77
Drawing in the Camera or Drawing View ................................................................................................................. 78
Drawing View ........................................................................................................................................................ 78
Drawing View Toolbar ...................................................................................................................................... 78
Drawing Area .................................................................................................................................................... 79
Line Art, Colour Art, and Preview Mode .......................................................................................................... 79
Drawing Name .................................................................................................................................................. 79
Tool Name ........................................................................................................................................................ 79
Current Frame .................................................................................................................................................. 80
Camera View ......................................................................................................................................................... 80
Line Art, Colour Art and Preview Mode ........................................................................................................... 81
Drawing Name .................................................................................................................................................. 82
Tool Name ........................................................................................................................................................ 82
Current Frame .................................................................................................................................................. 82
Show Current Drawing on Top ............................................................................................................................. 83
Drawing with the Brush or the Pencil ....................................................................................................................... 84
Viewing the Final Lines as you Draw ........................................................................................................................ 85
Real-Time Antialiasing ......................................................................................................................................... 85
Full Scene Antialiasing ......................................................................................................................................... 86
Drawing with the Brush Tool .................................................................................................................................... 87
Brush Tool Options ............................................................................................................................................... 88
Regular Brush Mode ......................................................................................................................................... 88
Draw Behind Mode .......................................................................................................................................... 88
Repaint Brush Mode ......................................................................................................................................... 88
Use Stored Colour Gradient ............................................................................................................................. 89
Auto-Flatten Mode ........................................................................................................................................... 89
Respect Protected Colour ................................................................................................................................ 89
Create Colour Art Automatically ...................................................................................................................... 89
Brush Styles ...................................................................................................................................................... 89
Minimum and Maximum Size ........................................................................................................................... 90
Smoothness and Contour Optimization ........................................................................................................... 91

2

Contents

Brush Tips ......................................................................................................................................................... 91
Preview ............................................................................................................................................................. 91
Line Texture (PRO) ........................................................................................................................................... 91
Drawing with Line Texture (PRO) ............................................................................................................................. 92
How to Draw with Texture (PRO) ........................................................................................................................ 93
Adjusting the Line Texture Parameters (PRO) ..................................................................................................... 94
Creating Texture Brushes (PRO) .......................................................................................................................... 95
Erasing Textured Lines (PRO) .............................................................................................................................. 95
Hiding the Line Texture (PRO) ............................................................................................................................. 96
Adjusting the Line Texture Opacity (PRO) .......................................................................................................... 97
Drawing using the Pencil Tool .................................................................................................................................. 98
Pencil Tool Options .............................................................................................................................................. 99
Draw Behind ..................................................................................................................................................... 99
Auto-Close Gap ............................................................................................................................................... 99
Auto-Flatten Mode ........................................................................................................................................... 99
Create Colour Art Automatically .................................................................................................................... 100
Pencil Styles .................................................................................................................................................... 100
Pen Size .......................................................................................................................................................... 101
Smoothness .................................................................................................................................................... 101
Drawing using Invisible Lines .................................................................................................................................. 102
Pencil Tool ......................................................................................................................................................... 102
Stroke Tool ........................................................................................................................................................ 102
Stroke Tool Options ...................................................................................................................................... 103
Show Strokes as Washed-out Colours (PRO) .................................................................................................... 104
Erasing Parts of a Drawing ...................................................................................................................................... 105
Eraser Tool Options ............................................................................................................................................ 105
Minimum and Maximum Size ......................................................................................................................... 105
Smoothness and Contour Optimization ......................................................................................................... 106
Eraser Tips ...................................................................................................................................................... 106
Preview ........................................................................................................................................................... 106
Eraser Styles .................................................................................................................................................... 106
Eraser Blur Parameters (PRO) ........................................................................................................................ 107
Reshaping a Drawing Using the Contour Editor Tool ............................................................................................ 108
Contour Editor Tool Properties .......................................................................................................................... 109
Lasso and Marquee ........................................................................................................................................ 109
Show Contour Editor Controls ....................................................................................................................... 110
Snap Options .................................................................................................................................................. 110
Selecting Drawing Objects ..................................................................................................................................... 113
Repositioning a Pivot Point ................................................................................................................................ 114
Selection on Single or Multiple Layers .............................................................................................................. 115
Select Tool Properties ........................................................................................................................................ 116
Manipulators .................................................................................................................................................. 116
Lasso and Marquee ........................................................................................................................................ 116
Snap Options .................................................................................................................................................. 116
Permanent Selection ....................................................................................................................................... 117
Apply to All Drawings in Layer ...................................................................................................................... 117
Apply to All Visible Drawings ........................................................................................................................ 117
Flip Horizontal and Vertical ............................................................................................................................ 117
Rotate 90 Degrees CW and CCW .................................................................................................................. 117
Pencil to Brush ................................................................................................................................................ 118
Smooth ........................................................................................................................................................... 118
Flatten ............................................................................................................................................................. 118
Store Colour Gradient ................................................................................................................................... 118
Apply to Line and Colour Art ......................................................................................................................... 118
Create Colour Art from Line Art ..................................................................................................................... 119
Distribute to Layer ........................................................................................................................................ 119
Width and Height .......................................................................................................................................... 120
Offset X and Y ................................................................................................................................................ 120
Angle .............................................................................................................................................................. 120
Adjusting the Pencil Line Thickness ................................................................................................................ 120
Drawing With Shapes ............................................................................................................................................. 121
Shape Tool Options ............................................................................................................................................ 122
3

Animate Pro 2 User Guide

Line, Rectangle and Ellipse ............................................................................................................................ 122
Draw Behind ................................................................................................................................................... 122
Snap options ................................................................................................................................................... 122
Automatic Filling ............................................................................................................................................ 123
Create Colour Art Automatically .................................................................................................................... 123
Auto-Flatten Mode ......................................................................................................................................... 123
Auto-Close Gap ............................................................................................................................................. 123
Use Stored Colour Gradient ........................................................................................................................... 123
Keep Proportion ............................................................................................................................................. 123
Pencil Styles .................................................................................................................................................... 124
Size Adjustment .............................................................................................................................................. 125
Drawing Using the Polyline Tool ............................................................................................................................ 126
Polyline Tool Options ......................................................................................................................................... 126
Draw Behind ................................................................................................................................................... 127
Snap to Contour ............................................................................................................................................. 127
Create Colour Art Automatically .................................................................................................................... 127
Pencil Styles .................................................................................................................................................... 127
Size Adjustment .............................................................................................................................................. 128
Deforming a Drawing Using the Perspective Tool ................................................................................................. 129
Perspective Tool Properties ............................................................................................................................... 129
Lasso and Marquee ........................................................................................................................................ 129
Apply to Line and Colour Art ......................................................................................................................... 130
Flip Horizontal and Vertical ............................................................................................................................ 130
Rotate 90 Degrees CW and CCW .................................................................................................................. 130
Cutting Drawing Parts ............................................................................................................................................ 131
Cutter Tool Options ........................................................................................................................................... 131
Lasso and Marquee ........................................................................................................................................ 131
Use Mouse Gesture ....................................................................................................................................... 132
Apply to Line and Colour Art ......................................................................................................................... 132
Smoothing Lines .................................................................................................................................................... 133
Smooth Editor Tool Options ............................................................................................................................. 133
Brush, Marquee and Lasso Smoothing Style ................................................................................................. 134
Show Control Points ...................................................................................................................................... 134
Minimum Size and Maximum Size ................................................................................................................. 134
Smoothness ................................................................................................................................................... 134
Colour ............................................................................................................................................................ 135
Working With Text ................................................................................................................................................. 136
Creating Text ...................................................................................................................................................... 136
Formatting the Text ........................................................................................................................................... 137
Font Type ...................................................................................................................................................... 137
Font Style ....................................................................................................................................................... 137
Alignment ...................................................................................................................................................... 138
Font Size ......................................................................................................................................................... 138
Kerning .......................................................................................................................................................... 138
Indent ............................................................................................................................................................ 138
Line Spacing .................................................................................................................................................. 139
Resizing the Text Box ........................................................................................................................................ 139
Converting Text into Separate Objects ............................................................................................................. 139
Override Tool .......................................................................................................................................................... 140
More Drawing Tools ............................................................................................................................................... 141
Arrange ............................................................................................................................................................... 141
Convert ............................................................................................................................................................... 141
Brush Strokes to Pencil Lines .......................................................................................................................... 141
Pencil Lines to Brush Strokes .......................................................................................................................... 141
Strokes to Pencil Lines ................................................................................................................................... 142
Optimize ............................................................................................................................................................. 142
Optimize ......................................................................................................................................................... 142
Remove Extra Strokes .................................................................................................................................... 142
Crop Brush Textures (PRO) ........................................................................................................................... 143
Reduce Drawing Texture Resolution (PRO) .................................................................................................. 143
Create Contour Stroke (PRO) ........................................................................................................................ 144
Remove Contour Stroke (PRO) ...................................................................................................................... 144
4

Contents

Show Grid ........................................................................................................................................................... 145
Group/Ungroup .................................................................................................................................................. 145
Rotate 180 ......................................................................................................................................................... 145
Hand ................................................................................................................................................................... 145
Rotate View ......................................................................................................................................................... 146
Zoom ................................................................................................................................................................... 146
Zoom Tool Properties ..................................................................................................................................... 146
Traditional Animation Tools .................................................................................................................................... 148
Onion Skin .......................................................................................................................................................... 148
Light Table .......................................................................................................................................................... 150
Drawing Identification ........................................................................................................................................ 151
Create Empty Drawing ....................................................................................................................................... 151
Reposition All Drawings ...................................................................................................................................... 152
Basic Traditional Animation .................................................................................................................................... 154
Animating ........................................................................................................................................................... 154
Cleaning Up ........................................................................................................................................................ 156
Setting the Timing .............................................................................................................................................. 158
Playing Back Your Animation .............................................................................................................................. 158
Advanced Traditional Animation (PRO) ................................................................................................................. 159
Flip and Easy Flipping Toolbars (PRO) ............................................................................................................... 159
Onion Skin Toolbar (PRO) .................................................................................................................................. 160
Shift and Trace (PRO) ......................................................................................................................................... 161
More Drawing Layers (PRO) .............................................................................................................................. 165
Overlay (PRO) ................................................................................................................................................ 166
Line Art (PRO) ................................................................................................................................................ 166
Colour Art (PRO) ............................................................................................................................................ 167
Underlay (PRO) .............................................................................................................................................. 167
Generating a Matte for Your Animation (PRO) ............................................................................................. 167
Multiple Drawings in the Drawing View (PRO) .................................................................................................. 169
Preview Selected Drawings (PRO) ..................................................................................................................... 170
Cleaning Scanned Drawings (PRO) ........................................................................................................................ 171
Remove Dirt (PRO) ............................................................................................................................................. 171
Remove Art Outside Selection (PRO) ................................................................................................................ 172
Remove Art Inside Selection (PRO) ................................................................................................................... 173
Remove Hair (PRO) ............................................................................................................................................. 173
Drawing and Traditional Animation Preferences .................................................................................................... 175
General .............................................................................................................................................................. 175
Use Advanced Art Mode (Animate) ............................................................................................................... 175
OpenGL ............................................................................................................................................................. 176
Real-Time Antialiasing .................................................................................................................................... 176
Full Scene Antialiasing .................................................................................................................................... 177
Exposure Sheet .................................................................................................................................................. 177
Current Frame as Drawing Name ................................................................................................................... 177
Drawing ............................................................................................................................................................... 178
Light Table ...................................................................................................................................................... 178
Options ........................................................................................................................................................... 179
Advanced (PRO) ................................................................................................................................................. 179
Advanced Options .......................................................................................................................................... 179

Chapter 5: Adding Colour ................................................................................................................................... 181

How to Paint ........................................................................................................................................................... 182
Colours .................................................................................................................................................................... 183
Adding a Colour Swatch .................................................................................................................................... 184
Solid Colour Swatch ...................................................................................................................................... 184
Gradient Colour Swatch ................................................................................................................................ 186
Bitmap Texture Swatch .................................................................................................................................. 188
Deleting a Colour Swatch .................................................................................................................................. 190
Colour Display Modes ........................................................................................................................................... 191
Switching Between Thumbnails and List Display modes ................................................................................... 191
Displaying Colour Values (PRO) ......................................................................................................................... 191
5

Animate Pro 2 User Guide

Selecting the Current Colour of a Tool ................................................................................................................. 192
Painting Using the Paint Tool ................................................................................................................................. 194
Paint Tool Properties ......................................................................................................................................... 194
Lasso and Marquee ...................................................................................................................................... 195
Painting Mode .............................................................................................................................................. 195
Automatic Close Gap ................................................................................................................................... 196
Paint and Remove Texture ........................................................................................................................... 197
Apply to Multiple Drawings .......................................................................................................................... 197
Apply to Visible Drawings ............................................................................................................................ 198
Respect Protected Colour ............................................................................................................................ 198
Use Stored Colour Gradient ......................................................................................................................... 198
Advanced Painting Features (PRO) ................................................................................................................... 199
Repaint Selection (PRO) ................................................................................................................................ 199
Repaint Selection On All Drawings (PRO) ..................................................................................................... 200
Repaint Outside Selection (PRO) .................................................................................................................. 200
Repaint Outside Selection On All Drawings (PRO) ....................................................................................... 201
Unpaint Selection (PRO) ................................................................................................................................ 201
Unpaint Selection On All Drawings (PRO) ..................................................................................................... 202
Unpaint Outside Selection (PRO) .................................................................................................................. 202
Unpaint Outside Selection On All Drawings (PRO) ....................................................................................... 203
Selecting a Colour in a Drawing ............................................................................................................................ 204
Editing Gradients and Textures ............................................................................................................................. 205
Storing your Favourite Gradient or Texture Settings ........................................................................................ 206
Closing Gaps Manually .......................................................................................................................................... 207
Close Gaps (PRO) .............................................................................................................................................. 208
Protecting Colours ................................................................................................................................................. 209
Highlighting the Selected Colour (PRO) ................................................................................................................ 209
Line Art and Colour Art Layers .............................................................................................................................. 210
Creating Strokes to Paint Your Drawings on a Separate Layer ......................................................................... 211
Underlay and Overlay Layers (PRO) .................................................................................................................. 213
Underlay ......................................................................................................................................................... 213
Overlay ........................................................................................................................................................... 213
Verifying Zones are Painted ................................................................................................................................... 214
Palettes .................................................................................................................................................................. 215
Displaying the Palette List .................................................................................................................................. 216
Basic Mode .................................................................................................................................................... 216
Advanced Mode ............................................................................................................................................ 216
Palette File Storage ........................................................................................................................................... 217
Element Level ................................................................................................................................................ 217
Scene Level .................................................................................................................................................... 217
Drawing Layer’s Palette List .............................................................................................................................. 218
Scene Palette List and Element Palette List .................................................................................................. 218
Creating a Colour Palette .................................................................................................................................. 219
Basic Palette Lists Mode ................................................................................................................................ 219
Advanced Palette Lists Mode (PRO) ............................................................................................................ 220
Renaming a Colour Palette ........................................................................................................................... 221
Copying and Pasting Colours ............................................................................................................................ 221
Copying Colours from Another Palette (PRO) .............................................................................................. 221
Removing a Colour Palette ................................................................................................................................ 222
Duplicating a Colour Palette ............................................................................................................................. 222
Cloning a Colour Palette ................................................................................................................................... 223
Cloning a Colour Swatch (PRO) ...................................................................................................................... 224
Mixing the Colours ............................................................................................................................................ 224
Importing a Colour Palette ................................................................................................................................ 226
Linking a Colour Palette (PRO) .......................................................................................................................... 227
Linking your Master Palette (PRO) .................................................................................................................... 228
Palette Linkage Status Icons .......................................................................................................................... 230
Ordering the Palette List ................................................................................................................................... 230
Colour Model ......................................................................................................................................................... 231
Loading a Colour Model .................................................................................................................................... 231
Preferences ............................................................................................................................................................ 232
6

Contents

Drawing Tab ...................................................................................................................................................... 232
Default Multiwheel Colour Picker .................................................................................................................. 232
Multi-Click (or Sticky) Eye Dropper ............................................................................................................... 232
Create New Colour Pots Using Default Colour ............................................................................................. 232
Auto Gap Closing .......................................................................................................................................... 232
General Tab ....................................................................................................................................................... 233
Colour Management ...................................................................................................................................... 233
Advanced Tab (PRO) ......................................................................................................................................... 234
Advanced Palette Lists .................................................................................................................................. 234

Chapter 6: Layers and Timing ............................................................................................................................ 235

Understanding the Timeline and Xsheet View ....................................................................................................... 236
Timeline View ..................................................................................................................................................... 236
Layer Section .................................................................................................................................................. 236
Timing Section ................................................................................................................................................ 237
Data View Section ........................................................................................................................................... 237
Xsheet View ........................................................................................................................................................ 238
Xsheet Main Section ....................................................................................................................................... 239
Functions Section ........................................................................................................................................... 239
Column List Section ........................................................................................................................................ 240
Xsheet View Toolbar ....................................................................................................................................... 241
Column Header .............................................................................................................................................. 241
Current Drawing ............................................................................................................................................. 242
Current Frame ................................................................................................................................................ 242
Frame Numbers .............................................................................................................................................. 242
Drawing Exposure .......................................................................................................................................... 242
Current Frame Display .................................................................................................................................... 242
Function Column ............................................................................................................................................ 243
Increase/Decrease Exposure .......................................................................................................................... 243
Overwrite/Insert Modes .................................................................................................................................. 243
Frames .................................................................................................................................................................... 244
Adding Frames ................................................................................................................................................... 244
Setting the Scene Length ............................................................................................................................... 244
Extending the Timeline View .......................................................................................................................... 244
Adding Frames Before or After a Selection ................................................................................................... 244
Adding Frames to the Beginning or at the End of a Scene ........................................................................... 245
Deleting Frames .................................................................................................................................................. 245
Reducing the Timeline Length ........................................................................................................................ 245
Remove Selected Frames ............................................................................................................................... 245
Delete Selected Frame Range ........................................................................................................................ 246
Layers ...................................................................................................................................................................... 247
Layer Concepts ................................................................................................................................................... 247
Layer Types ..................................................................................................................................................... 248
Layer Content ................................................................................................................................................. 251
Adding New Drawing Layers .............................................................................................................................. 251
Adding Drawing Layers in the Timeline View ................................................................................................. 251
Adding a Drawing Layer From the Top Menu ................................................................................................ 252
Adding Drawing Columns in the Xsheet View ............................................................................................... 252
Deleting Layers ................................................................................................................................................... 255
Deleting a Layer From the Timeline View ...................................................................................................... 255
Deleting a Layer from the Xsheet View .......................................................................................................... 255
Modifying Layers ................................................................................................................................................. 256
Ordering Layers .............................................................................................................................................. 256
Show and Hide Layers .................................................................................................................................... 257
Layer Properties .............................................................................................................................................. 261
Renaming a Layer ........................................................................................................................................... 262
Duplicating Layers .............................................................................................................................................. 263
Cloning Layers .................................................................................................................................................... 263
Xsheet Thumbnails .............................................................................................................................................. 263
Changing the Colour of a Column or Layer ....................................................................................................... 264
Expanding and Collapsing Layers ....................................................................................................................... 265
Modifying the Look of the Column (PRO) .......................................................................................................... 266
7

Animate Pro 2 User Guide

Exposure ................................................................................................................................................................ 268
Filling Mode ........................................................................................................................................................ 268
Overwrite Mode ............................................................................................................................................. 268
Insert Mode .................................................................................................................................................... 269
Typing Exposure ................................................................................................................................................. 269
Typing a Value in the Timeline View .............................................................................................................. 269
Typing a Value in the Xsheet View ................................................................................................................. 269
Holding an Exposure .......................................................................................................................................... 270
Extending a Single Exposure .............................................................................................................................. 271
Extending an Exposure Sequence ...................................................................................................................... 271
Dragging Cells .................................................................................................................................................... 272
Increasing and Decreasing Exposure ................................................................................................................. 274
Increase Exposure .......................................................................................................................................... 274
Decrease Exposure ......................................................................................................................................... 274
Increase/Decrease Exposure Field ................................................................................................................. 275
Clear Exposure and Pull ................................................................................................................................. 275
Deleting Exposure .............................................................................................................................................. 276
Inserting Blank Cells ........................................................................................................................................... 276
Setting the Exposure .......................................................................................................................................... 277
Filling a Selection with a Single Exposure .......................................................................................................... 278
Filling a Selection with a Sequence .................................................................................................................... 279
Filling a Selection Randomly .............................................................................................................................. 280
Creating Cycles ................................................................................................................................................... 281
Navigating Between Frames and Columns ........................................................................................................... 284
Managing Drawings ................................................................................................................................................ 285
Renaming a Drawing .......................................................................................................................................... 285
Renaming Drawings by Frame Position .............................................................................................................. 286
Deleting a Drawing ............................................................................................................................................. 286
Duplicating a Drawing ........................................................................................................................................ 287
Copying and Pasting Drawings .......................................................................................................................... 287
Tempo Markers (PRO) ........................................................................................................................................... 289
Annotation Columns (PRO) .................................................................................................................................... 290
Adding an Annotation Column (PRO) ............................................................................................................... 290
Drawing and Typing in the Annotation Column (PRO) ..................................................................................... 290
Drawing in the Annotation Column (PRO) .................................................................................................... 290
Typing in the Annotation Column (PRO) ....................................................................................................... 291
Erasing Annotation Column Content (PRO) .................................................................................................. 291
Changing the Drawing Settings (PRO) .............................................................................................................. 292
Importing an Annotation File (PRO) .................................................................................................................. 293
Printing the Xsheet (PRO) ...................................................................................................................................... 294
Element Manager (PRO) ........................................................................................................................................ 296
Preferences ............................................................................................................................................................. 297
Exposure Sheet .................................................................................................................................................. 297
Filtering ........................................................................................................................................................... 297
Options ........................................................................................................................................................... 298
New Element (PRO) ....................................................................................................................................... 298
Apply/Next (PRO) .......................................................................................................................................... 298
Timeline Preferences (PRO) ............................................................................................................................... 298
Defaults ........................................................................................................................................................... 298
Paste/Drag & Drop ......................................................................................................................................... 298
Advanced Preferences (PRO) ............................................................................................................................ 299

Chapter 7: Morphing Drawings......................................................................................................................... 301

Understanding Morphing ....................................................................................................................................... 302
Ideas Behind Morphing ..................................................................................................................................... 302
Source and Destination Drawings .......................................................................................................................... 302
Morphing Rules ....................................................................................................................................................... 303
Closest Similar Shape ......................................................................................................................................... 303
Pencil Line to Pencil Line .................................................................................................................................... 303
Fill Shape to Fill Shape ....................................................................................................................................... 304

8

Contents

Colour Swatch to Same Colour Swatch .............................................................................................................. 304
Vanishing and Appearing ................................................................................................................................... 305
Colour Art to Colour Art and Line Art to Line Art .............................................................................................. 305
Creating a Basic Morphing Sequence .................................................................................................................... 306
Deleting a Morphing Sequence ......................................................................................................................... 308
Tool Properties View ............................................................................................................................................... 309
Hint Type ............................................................................................................................................................ 310
Hide Hints ........................................................................................................................................................... 310
Show Morphing in Place .................................................................................................................................... 310
Suggest Hints ...................................................................................................................................................... 310
Switch Between Drawings .................................................................................................................................. 310
Flatten ................................................................................................................................................................. 311
Quality ................................................................................................................................................................. 311
Morphing Layers ................................................................................................................................................ 311
Easing .................................................................................................................................................................. 311
Convert Hints ...................................................................................................................................................... 311
Time .................................................................................................................................................................... 311
Adjusting the Velocity and Timing .......................................................................................................................... 312
Changing the Morphing Sequence Length ........................................................................................................ 312
Adjusting the Velocity ......................................................................................................................................... 312
Adjusting the Velocity in the Tool Properties View ........................................................................................ 312
Adjusting the Velocity in the Layer Properties Editor .................................................................................... 313
Morphing Tool and Hints ........................................................................................................................................ 316
Using the Morphing Tool .................................................................................................................................... 317
Contour Hint ....................................................................................................................................................... 319
Zone Hint ............................................................................................................................................................ 320
Pencil Hint ........................................................................................................................................................... 320
Vanishing Point Hint ........................................................................................................................................... 321
Appearing Point Hint .......................................................................................................................................... 321
Copying Hint Points from One Drawing to Another .......................................................................................... 322
Morphing Layers (PRO) ........................................................................................................................................... 324
Identifying Problem Zones (PRO) ....................................................................................................................... 324
Morphing Layer Properties (PRO) ...................................................................................................................... 325
Creating a Morph with Morphing Layers (PRO) ................................................................................................ 326
Morphing Two Sequences in a Row ....................................................................................................................... 329
Inserting a Morphing Key Drawing (PRO) .............................................................................................................. 330
Converting Morphing In-betweens to Drawings .................................................................................................... 331
Morphing Holes and Transparencies ...................................................................................................................... 332
Adjusting the Morphing Quality ............................................................................................................................. 334
Tips and Tricks ....................................................................................................................................................... 335
Morphing Similar Shapes .................................................................................................................................... 335
Avoiding Crossing Zones During Morphing ....................................................................................................... 335
Using the Brush Tool as a beginner .................................................................................................................... 335
Using the Contour Hint on Pencil Lines .............................................................................................................. 335
Flattening Drawings ............................................................................................................................................ 335
Cleaning-up your Drawings ................................................................................................................................ 335
Using the Same Colour Swatch .......................................................................................................................... 335
Preferences (PRO) .................................................................................................................................................. 336
Drawing Tab (PRO) ............................................................................................................................................. 336
Morphing Quality (PRO) ................................................................................................................................ 336

Chapter 8: Gathering Content........................................................................................................................... 337

Importing Bitmap Images in Animate .................................................................................................................... 338
Importing a Bitmap Image without Vectorization ............................................................................................. 338
Adding Images to a Bitmap Layer ................................................................................................................. 340
Bitmap Image Quality ........................................................................................................................................ 341
Importing and Vectorizing Images .................................................................................................................... 342
Importing Bitmap Images in Animate Pro ............................................................................................................. 344
Importing a Bitmap Image without Vectorization (PRO) ................................................................................... 344
9

Animate Pro 2 User Guide

Adding Images to a Bitmap Layer (PRO) ...................................................................................................... 346
Bitmap Image Quality (PRO) ............................................................................................................................. 347
Importing and Vectorizing Images (PRO) .......................................................................................................... 348
Importing PSD Files as Separate Layers in Animate .............................................................................................. 350
Importing PSD Files as Separate Layers in Animate Pro ....................................................................................... 353
Scanning Images in Animate ................................................................................................................................. 355
Scanning Images in Animate Pro ........................................................................................................................... 357
Importing AI and PDF Files .................................................................................................................................... 361
Importing from Adobe® Flash® ........................................................................................................................... 363
Distribute To Layers ............................................................................................................................................ 365
Importing QuickTime Movies in Animate ............................................................................................................... 366
Importing QuickTime Movies in Animate Pro ....................................................................................................... 368
Custom Vectorization Parameters (PRO) ............................................................................................................ 368
Options Tab ....................................................................................................................................................... 369
Input .............................................................................................................................................................. 369
Output ........................................................................................................................................................... 370
Optical Registration ....................................................................................................................................... 370
Post Processing ............................................................................................................................................. 370
Miscellaneous ................................................................................................................................................ 370
Preview .......................................................................................................................................................... 370
Help Tab ............................................................................................................................................................ 371
File IO Options .............................................................................................................................................. 371
Registration Options ..................................................................................................................................... 371
Filtering Options ............................................................................................................................................ 372
Options for bitmap that has no registration information .............................................................................. 373
RGB Keying Options ...................................................................................................................................... 373
Colour Vectorization Options ........................................................................................................................ 374
Bubble Usage (implemented only for colour vectorization's line art) ........................................................... 374
Creating a Vectorization Style ........................................................................................................................... 375
Preferences (PRO) .................................................................................................................................................. 376
Advanced Option (PRO) .................................................................................................................................... 376

Chapter 9: Libraries, Symbols and Templates............................................................................................. 377

Understanding the Library Concept ...................................................................................................................... 378
What is a Library? ............................................................................................................................................... 378
What is a Symbol? ............................................................................................................................................. 378
What is a Template? .......................................................................................................................................... 378
Library View ........................................................................................................................................................... 379
Library View Menu ............................................................................................................................................. 379
Preview and Drawing Substitution .................................................................................................................... 379
Library List ......................................................................................................................................................... 380
Templates and Symbols List .............................................................................................................................. 380
Structuring the Library ........................................................................................................................................... 381
Creating a Library .............................................................................................................................................. 381
Opening a Library .............................................................................................................................................. 382
Closing a Library ................................................................................................................................................ 382
Creating a Folder ............................................................................................................................................... 382
Deleting a Folder ........................................................................................................................................... 383
Renaming a Folder ........................................................................................................................................ 383
Refreshing the Library ....................................................................................................................................... 384
Generating Thumbnails ..................................................................................................................................... 384
Symbols .................................................................................................................................................................. 385
Creating a Symbol ............................................................................................................................................. 385
Creating a Symbol from a Drawing Selection ................................................................................................ 385
Creating a Symbol from the Timeline View .................................................................................................... 386
Creating a Symbol from the Network View (PRO) ........................................................................................ 387
Creating an Empty Symbol ............................................................................................................................ 388
Deleting a Symbol ............................................................................................................................................. 388
Editing a Symbol ................................................................................................................................................ 389
Symbol Hierarchy ........................................................................................................................................... 390

10

Contents

Duplicating a Symbol ......................................................................................................................................... 390
Sharing a Symbol ............................................................................................................................................... 391
Templates .............................................................................................................................................................. 392
Creating a Template from the Timeline View .................................................................................................... 392
Timeline Template .......................................................................................................................................... 392
Creating a Template from the Network View (PRO) ......................................................................................... 393
Network Template (PRO) ............................................................................................................................... 393
Deleting a Template .......................................................................................................................................... 394
Editing a Template ............................................................................................................................................ 394
Importing Symbols and Templates ........................................................................................................................ 395
Importing a Template ........................................................................................................................................ 395
Importing a Symbol ........................................................................................................................................... 396
Importing a Template with Symbols .................................................................................................................. 396
Importing a Network Template (PRO) ............................................................................................................... 397
Previewing a Symbol in the Network View (PRO) ............................................................................................. 398
Opening a Template as a Folder ....................................................................................................................... 398
Using Paste Special ............................................................................................................................................ 399
Paste Special - Basic Tab ............................................................................................................................... 400
Paste Special - Advanced Tab ....................................................................................................................... 401
Expanding a Symbol .......................................................................................................................................... 403
Preferences (PRO) .................................................................................................................................................. 404
Paste/Drag and Drop ......................................................................................................................................... 404
Editing a Template ............................................................................................................................................ 404

Chapter 10: Building a Character ..................................................................................................................... 405

Importing a Model ................................................................................................................................................. 406
Model Alignment ............................................................................................................................................... 406
Photo Puppets ................................................................................................................................................... 407
Relative Sizes ......................................................................................................................................................... 408
Line Up ............................................................................................................................................................... 408
Field Chart ......................................................................................................................................................... 409
Brush Size ........................................................................................................................................................... 409
Studying the Model ................................................................................................................................................ 410
Eyelids and Pupils .............................................................................................................................................. 410
Creating Mouth Shapes Directly on the Head .................................................................................................. 411
Keeping Fingers Attached to the Hand ............................................................................................................. 411
Mixing Hand-Drawn Animation ......................................................................................................................... 411
Flipping Logos .................................................................................................................................................... 412
Complete and Overlapping Pieces .................................................................................................................... 412
Setting the Default Separate Position Preference ................................................................................................. 413
Breaking Down ...................................................................................................................................................... 414
Selecting and Creating a New Layer ................................................................................................................. 414
Naming Conventions ..................................................................................................................................... 415
Breaking Down the Main Parts ...................................................................................................................... 415
Breaking Down the Secondary Parts ............................................................................................................. 417
Selecting and Incorporating an Existing Layer .................................................................................................. 420
Breaking Down the Extra View Main Parts .................................................................................................... 420
Breaking Down Secondary Parts in the Extra Views ...................................................................................... 421
Completing the Parts and Articulation .............................................................................................................. 422
Cleaning the Parts ......................................................................................................................................... 422
Fixing the Articulations .................................................................................................................................. 424
Creating Ghost Drawings (Optional) ................................................................................................................. 426
Adding a Ghost Drawing ............................................................................................................................... 426
Rigging ................................................................................................................................................................... 430
Rigging Basics .................................................................................................................................................... 430
Simple Rigging ............................................................................................................................................... 430
Parenting Layers ............................................................................................................................................ 431
Rigging using Pegs ........................................................................................................................................ 433
Rigging the Head ........................................................................................................................................... 434
Rigging the Body ............................................................................................................................................... 436
11

Animate Pro 2 User Guide

Simple Body Rigging ..................................................................................................................................... 436
Creating Hierarchy ............................................................................................................................................. 437
Ordering the Layers ........................................................................................................................................... 439
Ordering the Timeline Layers ........................................................................................................................ 439
Ordering Layers in the Network View (PRO) ................................................................................................. 440
Nudging Parts Backwards and Forwards ...................................................................................................... 441
Adding the Master Peg ..................................................................................................................................... 442
Creating the Keyframes ..................................................................................................................................... 443
Adding the Main Extra Drawings .......................................................................................................................... 444
Setting the Pivots ................................................................................................................................................... 446
Pivot Tool ........................................................................................................................................................... 447
Set the Pivot for Symbol on All Frames ......................................................................................................... 447
Snapping ........................................................................................................................................................ 447
Reset Pivot ..................................................................................................................................................... 447
Copying Pivot on Parent Symbol .................................................................................................................. 447
Setting the Pivots .............................................................................................................................................. 448
Setting Pivots on a Frame Range ....................................................................................................................... 448
Setting the Master Peg’s Pivot .......................................................................................................................... 450
Skeleton Optimization (PRO) ................................................................................................................................. 451
Deleting the Write Module (PRO) ..................................................................................................................... 451
Renaming the Display Module (PRO) ................................................................................................................ 451
Changing the Composite Type (PRO) ............................................................................................................... 453
Grouping your Modules (PRO) .......................................................................................................................... 454
Storing the Character in the Library ...................................................................................................................... 456
Appendix ............................................................................................................................................................... 460
Break Down: Tracing the Model ........................................................................................................................ 460
Break Down: Distribute to Layer ....................................................................................................................... 461
Converting the Layers into Symbols (Optional) ................................................................................................ 462
Clearing the Main Timeline ........................................................................................................................... 463
Patch Articulation .............................................................................................................................................. 464
Prefix and Suffix Script (PRO) ............................................................................................................................ 469
Setting the Symbols Pivot ................................................................................................................................. 470
Creating Extra Drawings .................................................................................................................................... 471
Storing Extra Drawings in the Library ............................................................................................................ 472

Chapter 11: Setting Up the Scene ................................................................................................................... 475

Importing the Scene Components ........................................................................................................................ 476
Backgrounds, Sounds and Movie ...................................................................................................................... 476
Templates and Symbols .................................................................................................................................... 476
Setting the Camera Frame .................................................................................................................................... 477
Adding a Camera Layer ..................................................................................................................................... 477
Setting the Camera Using the Translate and Rotate Tools ............................................................................... 478
Setting the Camera using the Camera Layer Properties ................................................................................... 479
Resetting the Camera Position .......................................................................................................................... 480
Camera List ........................................................................................................................................................ 480
Positioning the Scene Components ...................................................................................................................... 481
Animate Mode .................................................................................................................................................... 481
Selecting a Layer ............................................................................................................................................... 481
Selecting a Layer from the Camera View using the Transform Tool ............................................................. 481
Bounding Box Selection Style (PRO) ............................................................................................................. 482
Finding the Selected Layer in the Timeline View .......................................................................................... 482
Finding the Selected Layer in the Network View (PRO) ................................................................................ 483
Transform Tool Properties ............................................................................................................................. 483
Locking Layers in the Timeline View .............................................................................................................. 485
Selecting an Element from the Timeline or Xsheet View .............................................................................. 487
Positioning an Element using the Transform Tool ............................................................................................ 487
Repositioning the Pivot Point Temporarily ................................................................................................... 487
Panning a Drawing Layer ............................................................................................................................... 488
Rotating a Drawing Layer .............................................................................................................................. 488
Scaling an Element ........................................................................................................................................ 489

12

Contents

Skewing an Element ...................................................................................................................................... 489
Using Advanced Animation Tools to Position a Layer ....................................................................................... 489
Permanently Repositioning the Pivot Point ................................................................................................... 489
Panning an Element using the Translate Tool ............................................................................................... 490
Rotating an Element using the Rotate Tool .................................................................................................. 490
Scaling an Element using the Scale Tool ....................................................................................................... 490
Skewing an Element using the Skew Tool ..................................................................................................... 490
Flipping an Element ............................................................................................................................................ 491
Flip Horizontal and Flip Vertical .................................................................................................................... 491
Flip Scale X and Flip Scale Y .......................................................................................................................... 491
Positioning an Element Using the Layer Properties .......................................................................................... 492
Drawing Layer Properties Advanced Tab ...................................................................................................... 494
Drawing Layer Properties Drawing Tab (PRO) .............................................................................................. 497
Auto-Apply Option (PRO) .................................................................................................................................. 499
Resetting a Transformation ............................................................................................................................... 500
Cloning and Duplicating Layers ............................................................................................................................. 501
Clone Layer ........................................................................................................................................................ 501
Duplicate Layer .................................................................................................................................................. 502
Setting Up the Network (PRO) ............................................................................................................................... 503
Network View (PRO) .......................................................................................................................................... 503
Network Navigation and Basic Rules (PRO) ...................................................................................................... 504
Modules (PRO) ............................................................................................................................................... 504
Input and Output Ports (PRO) ....................................................................................................................... 505
Modules: Adding (PRO) ................................................................................................................................. 506
Modules: About the Composite Module (PRO) ............................................................................................ 506
Modules: Organizing (PRO) ........................................................................................................................... 509
Modules: Connecting and Disconnecting (PRO) ........................................................................................... 510
Modules: Grouping (PRO) ............................................................................................................................. 510
Modules: Enabling and Disabling (PRO) ....................................................................................................... 516
Modules: Thumbnails (PRO) .......................................................................................................................... 518
Navigator Display (PRO) ................................................................................................................................ 520
Cable Styles (PRO) ......................................................................................................................................... 521
Display Concepts (PRO) .......................................................................................................................................... 522
Display Modules (PRO) ...................................................................................................................................... 522
Global Display (PRO) ..................................................................................................................................... 523
Display All (PRO) ............................................................................................................................................ 523
Display Modes (PRO) ......................................................................................................................................... 524
Basic Display (PRO) ........................................................................................................................................ 524
Advanced Display (PRO) ................................................................................................................................ 524
Creating a Multiplane ............................................................................................................................................ 525
Top View and Side View .................................................................................................................................... 525
Perspective View ................................................................................................................................................ 526
Setting Up the Multiplane ................................................................................................................................. 527
Distributing Elements on the Z-Axis .................................................................................................................. 528
Positioning Elements in the Top and Side Views .......................................................................................... 528
Scene Setup Preferences ....................................................................................................................................... 530
General Tab Preferences (PRO) ......................................................................................................................... 530
Options (PRO) ................................................................................................................................................ 530
Settings (PRO) ................................................................................................................................................ 531
Camera Tab Preferences ................................................................................................................................... 531
Tools ............................................................................................................................................................... 532
Zoom Settings ................................................................................................................................................ 532
Settings ........................................................................................................................................................... 532
Control Size ................................................................................................................................................... 533
Wash Background .......................................................................................................................................... 533
Network Tab Preferences (PRO) ........................................................................................................................ 533
Navigator (PRO) ............................................................................................................................................. 533
Options (PRO) ................................................................................................................................................ 533
Element Module Drawing Options (PRO) ..................................................................................................... 534
OpenGL Tab Preferences .................................................................................................................................. 535
Settings .......................................................................................................................................................... 535
13

Animate Pro 2 User Guide

Other Views/Drawings (PRO) ........................................................................................................................ 536
Advanced Tab Preferences (PRO) ..................................................................................................................... 536
Advanced Options (PRO) ............................................................................................................................... 536

Chapter 12: Working in a True 3D Space (PRO) ........................................................................................ 537

Enabling the 3D Option (PRO) ............................................................................................................................... 538
3D Parameters (PRO) ......................................................................................................................................... 539
Scale (PRO) .................................................................................................................................................... 540
Rotation (PRO) ............................................................................................................................................... 541
Pivot (PRO) .................................................................................................................................................... 542
3D Tools (PRO) ...................................................................................................................................................... 543
3D Translate Tool (PRO) .................................................................................................................................... 544
3D Rotate Tool (PRO) ........................................................................................................................................ 545
3D Scale Tool (PRO) ......................................................................................................................................... 546
3D Transform Tool (PRO) ................................................................................................................................. 547
Positioning Elements in 3D Space (PRO) ............................................................................................................... 549
Planning Your Pieces (PRO) ............................................................................................................................... 550
Using Complex Sets in Production Scenes (PRO) ............................................................................................. 552
Positioning the Layers (PRO) ............................................................................................................................. 553
3D Camera Motion (PRO) ...................................................................................................................................... 556
Playing Back Your 3D Camera Moves (PRO) ...................................................................................................... 558
Locking Flat Drawings to the Camera Angle (PRO) .......................................................................................... 559
Managing a Network with a 3D Scene Setup (PRO) .............................................................................................. 560
Input and Output Options (PRO) ...................................................................................................................... 560
3D Input Ordering option (PRO) ................................................................................................................... 561
2D Input Ordering option (PRO) ................................................................................................................... 561
How to Organize Your 3D Composite Modules (PRO) ..................................................................................... 562

Chapter 13: Working With Sound .................................................................................................................... 563

Importing a Sound File .......................................................................................................................................... 564
Sound Layer Properties ......................................................................................................................................... 565
Sound Displays ....................................................................................................................................................... 566
Sound Playback ...................................................................................................................................................... 567
Sound Scrubbing ................................................................................................................................................... 568
Editing a Sound File ............................................................................................................................................... 569
Changing the Start or End Frame of a Sound ............................................................................................... 570
Trimming the Start and End of a Sound File ................................................................................................. 572
Looping a Sound ........................................................................................................................................... 573
Mixing the Sound Volume ............................................................................................................................. 573
Customizing the Playback Range .................................................................................................................. 574
Add Empty Sound Layer ........................................................................................................................................ 575
Lip-sync .................................................................................................................................................................. 576
Creating a Mouth Shapes Chart ........................................................................................................................ 578
Manual Lip-sync Detection ................................................................................................................................ 579
Automatic Lip-sync Detection ........................................................................................................................... 580
Modifying the Lip-sync Detection ..................................................................................................................... 581
Recomputing the Mouth Chart ..................................................................................................................... 581

Chapter 14: Creating Animation Paths .......................................................................................................... 583

Animating a Layer ................................................................................................................................................... 584
Animate Mode .................................................................................................................................................... 584
Animating a Layer ............................................................................................................................................... 584
Enabling the Playback .................................................................................................................................... 585
Differences Between Pegs and Animated Layers ................................................................................................... 586
Animated Layers ................................................................................................................................................ 586
Pegs .................................................................................................................................................................... 587
Why Use a Peg Layer? ................................................................................................................................... 587
The Origins of the Peg .................................................................................................................................. 587
Adding a Peg to the Timeline ........................................................................................................................ 588
Adding a Peg to the Network (PRO) ............................................................................................................. 589
Peg Selection Mode ...................................................................................................................................... 590

14

Contents

Layer Parameters ................................................................................................................................................ 590
3D Path ........................................................................................................................................................... 592
Separate Positions .......................................................................................................................................... 592
Locked Scales and Separated Scales .............................................................................................................. 592
Setting the Parameters .................................................................................................................................. 593
Adding and Deleting Keyframes ............................................................................................................................ 594
Coordinate Keyframe ......................................................................................................................................... 594
Add Keyframe and Duplicate Drawing .............................................................................................................. 594
Position Keyframe .............................................................................................................................................. 595
Delete Keyframe ................................................................................................................................................. 595
Stop-Motion and Motion Keyframes ...................................................................................................................... 596
Stop-Motion Keyframes ................................................................................................................................. 596
Motion Keyframes .......................................................................................................................................... 596
Toggling Between Motion and Stop-Motion Keyframes ............................................................................... 596
Constant Z ...................................................................................................................................................... 598
Animating the Camera ............................................................................................................................................ 599
Camera truck-ins and Line Thickness .................................................................................................................. 601
Modifying a Path in the Camera View .................................................................................................................... 603
Displaying a Path in the Camera View ............................................................................................................... 603
Shaping a Path ................................................................................................................................................... 604
Adding Control Points ................................................................................................................................... 605
Toggling Between Keyframe and Control Points .......................................................................................... 606
Adjusting the Tension, Bias and Continuity .................................................................................................. 607
Toggling Between a Linear or Curved Motion ............................................................................................... 608
Cumulative Z Value ......................................................................................................................................... 609
Offsetting a Trajectory ........................................................................................................................................ 610
Modifying a Path in the Timeline View ................................................................................................................... 611
Creating a Function ............................................................................................................................................ 611
Adding and Deleting Keyframes in the Timeline View ...................................................................................... 612
Changing Keyframe Values ................................................................................................................................. 612
Flipping Between Keyframes .............................................................................................................................. 613
Modifying a Path in the Function View ................................................................................................................... 614
Function View ..................................................................................................................................................... 614
Editing a Function in the Function View ............................................................................................................. 615
Adding and Deleting Keyframes in the Function View ...................................................................................... 616
Changing a Keyframe’s Values ........................................................................................................................... 617
Modifying a Path in the Xsheet View ..................................................................................................................... 618
Function Curves ...................................................................................................................................................... 620
Creating Function Curves ................................................................................................................................... 620
Sharing Functions ............................................................................................................................................... 621
Function Drop-down Menu ................................................................................................................................ 624
Function Types .................................................................................................................................................... 625
Ease and Bezier Functions .............................................................................................................................. 625
Velobased Functions ..................................................................................................................................... 626
Copying and Pasting a Motion ............................................................................................................................... 627
Paste Special ....................................................................................................................................................... 627
Paste Special Dialog Box ................................................................................................................................ 627
Paste Cycle ......................................................................................................................................................... 631
Adjusting the Velocity ............................................................................................................................................. 633
Displaying the Velocity Curve ............................................................................................................................ 633
Reshaping a Velocity Function with Bezier Controls .......................................................................................... 634
Reshaping a Velocity Function with Ease Controls ............................................................................................. 634
Creating a Stepped Velocity ............................................................................................................................... 635
Adjusting the Velocity On Several Layers At Once ............................................................................................ 636
Expression Columns (PRO) .................................................................................................................................... 638
Operators and Operands (PRO) ......................................................................................................................... 638
Creating an Expression for an Effect (PRO) ....................................................................................................... 640
Preferences ............................................................................................................................................................. 642
General Preferences .......................................................................................................................................... 642
Settings .......................................................................................................................................................... 643
15

Animate Pro 2 User Guide

Options .......................................................................................................................................................... 643
Timeline (Animate) .......................................................................................................................................... 643
Camera Preferences .......................................................................................................................................... 643
Tools .............................................................................................................................................................. 643
Control Points ................................................................................................................................................ 644
Exposure Sheet .................................................................................................................................................. 644
Function Editors ............................................................................................................................................ 644

Chapter 15: Animating Your Puppets ............................................................................................................ 645

Getting the Character ............................................................................................................................................. 646
Importing a Character from the Library ............................................................................................................. 646
Importing Network Templates (PRO) ................................................................................................................ 647
Backwards Compatibility for Templates Created in 7.3 or Earlier (PRO) ...................................................... 648
Selecting the Pose .............................................................................................................................................. 649
Extending the Exposure ..................................................................................................................................... 650
Understanding Drawings and Keyframes ............................................................................................................... 651
Keyframes and Drawing Blocks ......................................................................................................................... 651
Timeline Behaviour ........................................................................................................................................ 651
Creating a Simple Cut-out Animation .................................................................................................................... 653
Selecting Layers to Animate or Position ................................................................................................................. 655
Animate Mode ................................................................................................................................................... 655
Selecting Drawing Layers using the Transform Tool ......................................................................................... 656
Selecting an element in the Camera View using the Transform Tool ........................................................... 656
Selecting a Layer in the Timeline View .......................................................................................................... 657
Selecting in the Network View (PRO) ............................................................................................................ 657
Navigating the Hierarchy ........................................................................................................................................ 658
Animating using the Transform Tool ..................................................................................................................... 659
Animating using Inverse Kinematics ...................................................................................................................... 661
Where to Start with Inverse Kinematics? ........................................................................................................... 662
Inverse Kinematics Tool Properties ................................................................................................................... 663
IK Modes ........................................................................................................................................................ 663
IK Tool Options ............................................................................................................................................. 664
Selection ........................................................................................................................................................ 665
Setting up the Character to use IK .................................................................................................................... 667
Connecting any Hierarchy Chain ................................................................................................................... 667
Excluding Extra Elements from IK ................................................................................................................. 668
Setting Up the Bones for the Extremities ..................................................................................................... 669
Nails ................................................................................................................................................................... 669
Minimum and Maximum Angle (PRO) ............................................................................................................... 671
IK Keyframes ...................................................................................................................................................... 673
When to use the Inverse Kinematics Tool ......................................................................................................... 675
Inverse Kinematics in Toon Boom Animate .................................................................................................... 675
IK Tool and Rigging ........................................................................................................................................ 675
Animating with the Tools .............................................................................................................................. 675
The Inverse Kinematics Philosophy ............................................................................................................... 676
Tips and Tricks for Inverse Kinematics .......................................................................................................... 676
Animating in Stop-Motion ...................................................................................................................................... 677
Creating a Stop-Motion Keyframe ..................................................................................................................... 677
Animating using Computer Generated Interpolation ............................................................................................ 679
Creating a Motion Keyframe .............................................................................................................................. 679
Adjusting the Velocity ........................................................................................................................................ 680
Adjusting the Velocity in the Function View .................................................................................................. 680
Adjusting the Velocity on Multiple Elements Concurrently ........................................................................... 681
Flipping Through Poses .......................................................................................................................................... 683
Using the Onion Skin in Cut-out Animation ........................................................................................................... 684
Add to Onion Skin .............................................................................................................................................. 684
Remove from Onion Skin .................................................................................................................................... 685
Remove Unselected from Onion Skin ................................................................................................................ 685
Add All to Onion Skin ......................................................................................................................................... 685
Remove All from Onion Skin .............................................................................................................................. 685
Flipping Parts .......................................................................................................................................................... 686

16

Contents

Animating Using Symbols ....................................................................................................................................... 687
Creating a Blink Symbol ..................................................................................................................................... 687
Importing a Template with Symbols .................................................................................................................. 690
Duplicating a Symbol ......................................................................................................................................... 691
Reusing Extra Drawings, Poses and Facial Expressions ........................................................................................ 692
Swapping Images .................................................................................................................................................... 695
Adding a New Drawing .......................................................................................................................................... 697
Duplicating a Drawing ........................................................................................................................................ 697
Ordering Layers Over Time .................................................................................................................................... 698
Creating Cycles ....................................................................................................................................................... 699
Adding Pegs ........................................................................................................................................................... 701
Offsetting Part of an Animation .............................................................................................................................. 703
Preferences ............................................................................................................................................................ 704
Camera ............................................................................................................................................................... 704
Inverse Kinematics (PRO) ............................................................................................................................... 704
Advanced (PRO) ................................................................................................................................................. 705
Animate Using Animation Tools (PRO) .......................................................................................................... 705

Chapter 16: Enhancing With Effects ............................................................................................................... 707

Adding Effects in Animate ...................................................................................................................................... 708
Adding Effects in Animate Pro (PRO) .................................................................................................................... 709
About the Network View (PRO) .......................................................................................................................... 709
Drawing Module (PRO) ................................................................................................................................... 710
Write and Display Modules (PRO) ................................................................................................................. 710
Composite Module (PRO) .............................................................................................................................. 710
Effect Module (PRO) ...................................................................................................................................... 710
Matte Drawing (PRO) ..................................................................................................................................... 711
Position Ports (PRO) ...................................................................................................................................... 711
Peg Module (PRO) ......................................................................................................................................... 711
About the Module Library (PRO) ....................................................................................................................... 712
Module Library View Toolbar (PRO) .............................................................................................................. 712
Module Tabs (PRO) ........................................................................................................................................ 713
Importing a Module (PRO) ................................................................................................................................. 713
Adding Effects Through the Timeline (PRO) ...................................................................................................... 714
Working with Effects that were created in Animate (PRO) ................................................................................ 715
Animating an Effect Over Time ............................................................................................................................. 716
Animating an Effect in Animate .......................................................................................................................... 716
Animating an Effect in Animate Pro (PRO) ......................................................................................................... 718
How Does An Effect Work? ................................................................................................................................... 720
Using Effects in Animate ......................................................................................................................................... 722
Effect Layers ....................................................................................................................................................... 722
Blending Effects ............................................................................................................................................. 722
Blur ................................................................................................................................................................. 724
Brightness and Contrast ................................................................................................................................ 725
Colour Card ................................................................................................................................................... 726
Colour Override ............................................................................................................................................. 727
Colour Scale ................................................................................................................................................... 729
Directional Blur .............................................................................................................................................. 730
Glow ............................................................................................................................................................... 731
Highlight ........................................................................................................................................................ 732
Mask ............................................................................................................................................................... 734
Motion Blur .................................................................................................................................................... 735
Particle Effect, Crowd Simulation and More ................................................................................................. 736
Quadmap ....................................................................................................................................................... 737
Shadow .......................................................................................................................................................... 739
Tone ............................................................................................................................................................... 740
Transparency ................................................................................................................................................. 742
Using Effects in Animate Pro (PRO) ....................................................................................................................... 743
Effect Modules (PRO) ......................................................................................................................................... 744
Anti Flicker (PRO) ........................................................................................................................................... 744
Apply Image Transformation (PRO) ................................................................................................................ 745
17

Animate Pro 2 User Guide

Apply Peg Transformation (PRO) ................................................................................................................... 747
Blending (PRO) ............................................................................................................................................... 751
Blur Directional (PRO) .................................................................................................................................... 753
Blur Radial (PRO) ........................................................................................................................................... 754
Blur Variable (PRO) ........................................................................................................................................ 755
Brightness and Contrast (PRO) ...................................................................................................................... 756
Channel Selector (PRO) ................................................................................................................................. 757
Colour Art (PRO) ............................................................................................................................................ 758
Colour Card (PRO) .......................................................................................................................................... 759
Colour Override (PRO) .................................................................................................................................. 760
Colour Scale (PRO) ........................................................................................................................................ 762
Colour Screen (PRO) ...................................................................................................................................... 763
Composite-Generic (PRO) ............................................................................................................................. 764
Contrast (PRO) ............................................................................................................................................... 767
Cutter (PRO) .................................................................................................................................................. 768
Dither (PRO) .................................................................................................................................................. 769
External (PRO) ............................................................................................................................................... 770
Field Chart (PRO) ........................................................................................................................................... 772
Focus (PRO) ................................................................................................................................................... 774
Focus Multiplier (PRO) ................................................................................................................................... 775
Glow (PRO) .................................................................................................................................................... 776
Glue (PRO) ..................................................................................................................................................... 777
Gradient (PRO) .............................................................................................................................................. 781
Grain (PRO) .................................................................................................................................................... 782
Greyscale (PRO) ............................................................................................................................................. 783
Highlight (PRO) .............................................................................................................................................. 785
Layer Selector (PRO) ...................................................................................................................................... 787
Line Art (PRO) ................................................................................................................................................ 788
Matte Blur (PRO) ........................................................................................................................................... 789
Matte Resize (PRO) ........................................................................................................................................ 791
Motion Blur (PRO) ......................................................................................................................................... 792
Multi-Port-In (PRO) ........................................................................................................................................ 793
Multi-Port-Out (PRO) ..................................................................................................................................... 794
Negate Module (PRO) ................................................................................................................................... 794
Note (PRO) .................................................................................................................................................... 795
Overlay Layer (PRO) ...................................................................................................................................... 796
Particle Effect, Crowd Simulation and More (PRO) ....................................................................................... 797
Pixelate (PRO) ................................................................................................................................................ 798
Placeholder (PRO) ......................................................................................................................................... 799
Quadmap (PRO) ............................................................................................................................................ 799
Refract (PRO) ................................................................................................................................................. 801
Remove Transparency (PRO) ......................................................................................................................... 802
Shadow (PRO) ................................................................................................................................................ 803
Sparkle (PRO) ................................................................................................................................................. 805
Tone (PRO) .................................................................................................................................................... 806
Transparency (PRO) ....................................................................................................................................... 808
Underlay Layer (PRO) .................................................................................................................................... 809
Previewing and Playing Back Effects ..................................................................................................................... 810
Playing Back your Effects with a Bitmap Images Sequence ............................................................................... 810
Preview Resolution ........................................................................................................................................ 810
Playing Back your Effects in an SWF Movie ....................................................................................................... 812
Exporting Effects to SWF ............................................................................................................................... 813
Extra Commands (PRO) .......................................................................................................................................... 815
Preferences (PRO) .................................................................................................................................................. 816
General (PRO) .................................................................................................................................................... 816
Options (PRO) ................................................................................................................................................ 816
OpenGL (PRO) ................................................................................................................................................... 817
Drawings (PRO) ............................................................................................................................................. 817
Effects (PRO) .................................................................................................................................................. 817

Chapter 17: Exporting Your Movie .................................................................................................................. 819

Exporting a QuickTime Movie ............................................................................................................................... 820
Exporting a QuickTime Movie with Transparency ............................................................................................. 823

18

Contents

Exporting an SWF Movie (Flash) ............................................................................................................................ 824
Exporting an FLV Movie ........................................................................................................................................ 825
Exporting OpenGL Frames .................................................................................................................................... 827
Exporting an Image Sequence in Animate ............................................................................................................ 828
Exporting an Image Sequence With Transparency (Animate) ........................................................................... 829
Rendering Movies and Image Sequences in Animate Pro .................................................................................... 830
Write Module (PRO) .......................................................................................................................................... 830
Image Sequences (PRO) ................................................................................................................................ 831
QuickTime Movie (PRO) ................................................................................................................................ 832
Multiple Renders (PRO) ..................................................................................................................................... 834
Modules Used to Export to Different Resolutions (PRO) .............................................................................. 834
Connecting the Required Modules (PRO) ..................................................................................................... 839
Rendering Images and Movies from the Network (PRO) .................................................................................. 842
Preferences ............................................................................................................................................................. 843
Animate Render Preferences ............................................................................................................................. 843
Animate Pro Render Preferences ...................................................................................................................... 843
Preview Options (PRO) .................................................................................................................................. 843
Image Management (PRO) ............................................................................................................................ 844
Multi-Threading (PRO) ................................................................................................................................... 844

INDEX .......................................................................................................................................................................... 845

19

Animate Pro 2 User Guide

20

Chapter 1
Introduction
Toon Boom Animate is a complete animation software with advanced features for all your animation projects.
No matter what your animation workstyles are, Animate takes care of your entire project, from importing your assets
and creating your content, all the way to animation and compositing. Animate combines vector, bitmap, Symbols and
pegs for maximum freedom and performance.
Animate’s features and shortcut sets fit so neatly into your circle of Adobe® or Toon Boom products and your
animation techniques that you will feel at home in minutes.
This guide describes both Animate Family products:

•
•

Toon Boom Animate
Toon Boom Animate Pro

It explains all of the features available for both products and documents their use in a production context.
Features that are exclusive to one product or the other are marked with an icon specifying which product. Other icons
are provided to bring your attention to important items or information which are necessary for you to know. These
icons are explained in Visual Markers, on page 22.
To learn all about the features available in Toon Boom Animate and how to use them in a production context, read
the following chapters:

•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Getting Started, on page 23
Discovering the Interface, on page 39
Drawing and Animating, on page 75
Adding Colour, on page 181
Layers and Timing, on page 235
Morphing Drawings, on page 301
Gathering Content, on page 337
Libraries, Symbols and Templates, on page 377
Building a Character, on page 405
Setting Up the Scene, on page 475
Working in a True 3D Space (PRO), on page 537
Working With Sound, on page 563
Creating Animation Paths, on page 583
Animating Your Puppets, on page 645
Enhancing With Effects, on page 707
Exporting Your Movie, on page 819

A comprehensive index is also included to enhance your learning experience:

•

INDEX, on page 843
Adobe® Flash® keyboard shortcuts are used by default throughout the Toon Boom Animate documentation set.
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Visual Markers
In this guide, you will find several icons which focus your attention on certain sections and notes:

Product Icons
Animate Only
When a topic is ONLY used in Toon Boom Animate and NOT used in Animate Pro, the section is placed between the
following banners.
Start of section
End of section

Animate Pro Only
When a topic is ONLY used in Toon Boom Animate Pro and NOT used in Animate, the section is placed between the
following banners:
Start of section

End of section
OR marked with the PRO icon:

Also, every time a short piece of information only relates to Animate Pro, the section’s title contains the following text:
(PRO). For example; Verifying Project Integrity (PRO).

Information Icons
Reference
The Reference icon indicates that another section in this guide provides more information regarding the current topic.
If you are reading the digital version of this guide, you can click on the link to go directly to that section.

Important Note
The Important Note icon is placed before crucial information that you should know, this information will help you to
avoid issues and use the software more efficiently.

Tip
The Tip icon is placed before a short bit of information which will help you improve your work technique.

Tool
The Tool icon is placed beside a list of tools you should become familiar with before starting a hands-on step-by-step
procedure.
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Getting Started
Once the software is installed, you are ready to launch the application and animate!
In this chapter, you will learn about:

•
•
•
•
•
•
•
•
•

Launching Toon Boom Animate, on page 23
Preference Styles, on page 24
Welcome Screen, on page 25
Creating and Opening a Scene, on page 26
Setting the Scene Length, on page 29
Scene Settings, on page 29
Adding a Drawing Layer, on page 33
Verifying Project Integrity (PRO), on page 34
Basic Commands, on page 35

Launching Toon Boom Animate
You can run the software on Mac OS X or Windows operating systems.

To open Toon Boom Animate, do one of the following:



Mac OS X: Double-click on the Toon Boom Animate
Applications > Toon Boom Animate 2 > Animate.

icon or select



Windows: Double-click on the Toon Boom Animate
icon or select
Start > Programs > Toon Boom Animation > Toon Boom Animate 2 > Animate.

Toon Boom Animate opens, displaying the Welcome Screen.
If it is the first time that you are launching the application, the Preference Styles dialog box opens.

To open Toon Boom Animate Pro, do one of the following:



Mac OS X: Double-click on the Toon Boom Animate Pro
Applications > Toon Boom Animate Pro 2 > AnimatePro.

icon or select



Windows: Double-click on the Toon Boom Animate Pro
icon or select
Start > Programs > Toon Boom Animation > Toon Boom Animate Pro 2 > Animate Pro.

Toon Boom Animate Pro opens, displaying the Welcome Screen.
The Animate Pro Welcome Screen has the same options as the one used in Animate.
If it is the first time that you are launching the application, the Preference Styles dialog box opens.
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Preference Styles
When you start Animate for the first time the Preference Styles dialog box will open. This is the only time you will see
this dialog box, however, you can change the styles later on if you like using the Preference panel.

You have two choices, click on the one which fits your work style:

•
•

Yes
Sets Animate’s default shortcut scheme and preferences to fit the Adobe® Flash® software workflow style.
The Select tool is set to Marquee Selection mode.
No
Sets Animate’s default shortcut scheme and preferences to fit the Toon Boom professional products
workflow style.
The Select tool will be set in Lasso selection mode.

You can always return to the Preferences panel later on to change the preferences settings.
Refer to the following topics in the Discovering the Interface chapter to learn more about preferences and
customizing the shortcuts:

•
•
•

Preferences, on page 69
Keyboard Shortcuts, on page 73
Preference Highlights, on page 70

Once your choice is made, the Welcome Screen will be displayed.
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Welcome Screen
When you open Toon Boom Animate, the Welcome Screen appears. If a scene is already open, you can display the
Welcome Screen by selecting Help > Show Welcome Screen.

1

4

2

3
5
6

The Welcome Screen allows you to:
1.
2.
3.
4.
5.
6.

Create scenes
Choose the scene resolution
Add or Delete a custom scene resolution
Open recent scenes from a list
Open scenes by browsing
Open the help documentation

Accessing Tutorials and Documentation
To access the tutorials:

 In the Documentation section, click on the desired document.

The Animate Pro 2 User Guide can also be opened directly in the software, from the top menu, by selecting
Help > Help.
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Creating and Opening a Scene
All scenes created via Animate are independent and local to the computer.
There are two ways to create a new scene:

•
•

Welcome Screen, on page 25
Using the File Menu, on page 27

Using the Welcome Screen
To create a scene from the Welcome Screen:
1.

To select the scene’s location, in the Project Directory section, browse the files by clicking on the Choose button.

2.

In the Project Name field, type the scene’s name.

3.

In the Resolution window, select the scene’s resolution or move on to the following step to create a new one.

4.

You can click on the Add

button to add a new resolution to the list.

The New Resolution dialog box opens.







In the Resolution Name field, name your new resolution.
In the Width field, type the resolution width in pixels.
In the Height field, type the resolution height in pixels.
In the Frame Rate field, type the scene’s frame rate per second.
Click on the Create button.

You can delete a custom resolution from the Resolution List by selecting it and clicking on the Delete
under the Resolution window.
To open a scene from the Welcome Screen:
1.
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In the Recent Scenes section, click on the Open Scene option.

button
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2.
3.

The Open Scene browser opens.
Browse and select the desired *.digital file.
Click on the Open button to open the scene.

To open a recent scene from the Welcome Screen:

 In the Recent Scenes section, select a scene from the list.

Using the File Menu
If a scene is already open and you want to create a new one, you can use the File menu.
To create a scene from the File menu:
1.

Select File > New. You can also click on the New
button in the File toolbar or use the default keyboard
shortcut [Ctrl]+[N] (Windows) or [a]+[N] (Mac OS X).
The New Scene dialog box opens.

2.

Select a scene directory by clicking on the Choose button.

3.

In the Project Name field, name the new project or move on to the following step to create a new one.

4.

In the Resolution window, select the scene’s resolution or click on the Add
to the list.

button to add a new resolution
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5.

You can click on the Add

button to add a new resolution to the list.

The New Resolution dialog box opens.

In the Resolution Name field, name your new resolution.
In the Width field, type the resolution width in pixels.
In the Height field, type the resolution height in pixels.
In the Frame Rate field, type the scene’s frame rate per second.
Click on the Create button.





6.

You can delete a custom resolution from the Resolution List by selecting it and clicking on the Delete
under the Resolution window.

button

To open a scene from the File menu:
1.

2.
3.

Select File > Open. You can also click on the Open
shortcut [Ctrl]+[O] (Windows) or [a]+[O] (Mac OS X).

button in the File toolbar or use the default keyboard

The Open Scene browser opens.
Browse and select the desired *.digital file.
Click on the Open button to open the scene.

New Scene Startup Script
When you create a new scene, the TB_sceneCreated script will automatically set the scene length to 60 frames and
add one of each of the following modules: drawing element, composite, display and write.
You can customize this script to fit your current project needs. This way, you can set the default scene length to any
number of frames you want or even decide which types of elements and modules you wish to be in your scene when
you create it.
Refer to Animate Scripting Guide to learn more about using, creating and customizing scripts.
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Setting the Scene Length
Once you created your scene, you can set its length.
To set the scene length from the top menu:
1.

Select Scene > Scene Length.
The Set Scene Length dialog box opens.

2.
3.

In the Number of Frames field, type the number of frames needed, you can also use the up and down arrows to
set the number of frames.
Click on the OK button.

Refer to the following topics in the Layers and Timing chapter to learn more about adding and removing frames
and extending the scene’s length:

•
•

Adding Frames, on page 244
Deleting Frames, on page 245

Scene Settings
When you created your new scene, you set up the resolution and the alignment, however, if you want to change these
initial settings later, you can. You can do this by going to the top menu and selecting Scene > Scene Settings.
The Scene Settings dialog box opens.

The different Scene Settings options are separated into three tabs:
• Resolution Tab
• Alignment Tab
• Advanced Tab
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Resolution Tab

1
2

6

3

7

4
5
1.

2.
3.

4.

5.

30

Project Resolution Type
You can select your project’s resolution type from this area so it matches your intended output.
 HDTV
High definition television delivers a higher quality image than standard television does, because it has twice
the standard number of scanning lines per frame. To take advantage of the superior quality your output
device must be compatible with HDTV technology to make this resolution setting useful.
 film-1.33
Use this resolution setting for the widescreen film format that conforms to the standard 4:3 pixel aspect
ratio.
 film-1.66
Use this resolution setting for the widescreen film format that conforms to the 16:9 pixel aspect ratio,
(where the pixel's width is greater than its height).
 NTSC
This is the standard analog television broadcasting system used in most of the Americas, Japan, South
Korea, Taiwan, Burma, and some Pacific island nations and territories. It conforms to the North American
standards on how rectangular pixels are displayed for computer and television screens.
 PAL
This is an analog television encoding system used in broadcast television systems in large parts of the world
(i.e. western Europe, Asia, Australia, most of Africa and some North American countries). This resolution
works best with the European format for television and computer screens, as the rectangular pixels are
displayed at a different orientation.
 low
This format is ideal for videos destined for the web, where size and fast download of a video file might take
precedence over quality.
Scene Resolution Setting
Displays the scene resolution setting selection.
Pixel Dimensions
Displays the pixel dimensions for your resolution selection.
If you decide to type in the pixel dimensions, or use the up and down arrows to change the pixel increments,
you will have to save your custom selection in order to make it active (6). It will then appear in the resolution
selection list (1).
Aspect Ratio
The aspect ratio describes the shape of the pixel. A square pixel would have the ratio 1:1, where as a pixel of
aspect ratio 4:3 is a unit with one side 1.33 times as big as the other side. Each resolution setting has a preset
aspect ratio that can not be changed.
Project Frame Rate
Select the frame rate for your project. The higher the frame rate, for example 30 fps, the smoother your
animation will look, but the heavier it will be. The lower the frame rate, for example 12 fps, the choppier your
animation may look, but the lighter it will be.

Chapter 2: Getting Started Scene Settings
6.

Save Custom Resolution
Click on the Save button to save and create your custom resolution as a setting. This button becomes active
when you create a custom resolution type (3).
7. Field of View
This will define the FOV of the camera and how the drawing elements (and drawing grid) aligns to the camera.
The drawing grid is always scaled proportionally to a 4:3 (1.33) ratio, therefore changing the Field of View
setting may not show a visible difference if your project resolution is also 4:3, such as NTSC.
 Horizontal Fit
The drawing grid is fitted to the vertical (side) edges of the Camera view, so that the width of the grid
matches the width of your project resolution.
 Vertical Fit
The drawing grid is fitted to the horizontal (top and bottom) edges of the Camera view, so that the height
of the grid matches the height of your project resolution.
 Custom Fov
After selecting this option, use the now active field to the right to enter in a value, in degrees, of the angle
that you would like the camera cone to be. Increasing this value would make the camera cone wider (the
angle more obtuse), widening the FOV and making the grid and all elements appear farther away.
Decreasing the default value would create the opposite effect.

Alignment Tab

1

2
3
4

1.
2.
3.
4.

Alignment Presets
Units Aspect Ratio
Number of Units
Coordinates at Centre
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Alignment Rules
N
one unit
3
4
(0,0)

W

E
Traditional
Animation Grid

S
1.

The Alignment Presets give you two preset options to choose from.
4:3 12 Fields
Defines the units of your project to have a 4:3 ratio and sets up 12 of these units to run both vertically and
horizontally in four cardinal quarters (NW, NE, SW and SE). This Alignment preset is visible in the FOV and
drawing grids.
 Square 12 Fields
Defines the units of your project to have a 1:1 or square ratio and sets up 12 of these units to run both
vertically and horizontally in four cardinal quarters (NW, NE, SW and SE). This Alignment preset is NOT
visible in the FOV and drawing grids.



If you change your scene‘s alignment from 4:3 12 Fields to Square 12 Fields part way though your project, you
may find that the Animation grid becomes offset. To correct this problem choose the following setting from the Layer
Properties panel‘s Advanced tab: Alignment > Alignment Rule > Centre First Page.
2.

In the Units Aspect Ratio fields, enter the aspect ratio of the grid you will use. The aspect ratio describes the
shape of the grid unit. A square grid unit would have the ratio 1:1, where as a grid unit of aspect ratio 4:3 is a
unit with one side 1.33 times as big as the other side.
 If the aspect ratio you want to use is 1:1, enter 1 in the Left/Right field (X-axis) and 1 in the Up/Down field
(Y-axis). The default Aspect Ratio is set to 4:3 as it is the one used by traditional animators, who are
accustomed to working with the grid system described above.
3. In the Number of Units fields, enter the number of horizontal, vertical and depth units for your scene’s grid.
Animators who prefer to work traditionally will understand the default setting of 24 units horizontal by 24 units
vertical as it, once again, corresponds to the grid above. Twelve is a common setting for the field depth.

4.

Those who prefer to work in pixels should enter the pixel dimensions (3) of their project. This way if you want to
move something over 600 pixels you just need to type in 600 units.
In the Coordinates at Centre, you can enter a new coordinate for the centre of your scene.

5.

By default, the (0,0) centre is set in the middle of the grid as shown in the grid above. If you want to change the
centre of your grid, for example to the upper left corner, you would enter (-12, 12), -12 units across and 12 units
up. That is of course unless you changed the number of units to match the pixel dimensions of your scene. Then
you would enter negative half the width and positive half the height.
Click on the Save button to save your current Alignment settings and be able to select them later from the list.
The Choose Alignment Name dialog box opens

Type in a name for your new alignment settings and press on the OK button.
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Advanced Tab

•

Backward Z Order Compatibility with Toon Boom Digital Pro (v.7.3)
This refers to Toon Boom Digital Pro release 7.3 and Harmony release 7.3.
In version 7.8, the method in which Z-Ordering is calculated has been optimized. Enable this option if you
want to use the version 7.3 system.
Toon Boom Digital Pro and Toon Boom Harmony 7.3 allowed smaller values on the Z-axis such as 0.0001.
In the new version 7.8, the Z-ordering calculation is now optimized and allows only larger values such as
0.001.

Adding a Drawing Layer
Now that your scene is set up, you can add drawing layers.
To add a drawing layer from the Timeline view:
1.

In the Timeline view, click on the Add Drawing Layer

button.

A new drawing layer is added to the Timeline view.

Refer to the following topics in the Layers and Timing chapter to learn more about Layers and how to add them.

•
•
•
•
•
•
•

Layers, on page 247
Layer Concepts, on page 247
Adding New Drawing Layers, on page 251
Deleting Layers, on page 255
Modifying Layers, on page 256
Duplicating Layers, on page 263
Cloning Layers, on page 263
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Verifying Project Integrity (PRO)
The Check Files command verifies the integrity of the drawing and palette files in your project.
To open the Check Files dialog box:

 In the top menu, select File > Check Files.

Check Files (PRO)
Use the Check Files dialog box to verify that the data is consistent, correct, and accessible.

•

Check Colours button:
Click on the Check Colours button to open the Check Colours dialog box.

Check Colours (PRO)
The Check Colours dialog box checks the palette integrity and displays the colour recovery data.
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Basic Commands
This table lists the most common commands used in Animate.

Command

Action

Access Methods

New

Starts a new scene while closing any
scene already open. The New Scene
dialog box appears, asking for
directory, name and resolution
information.

File > New
[Ctrl]+[N] (Windows)
[a]+[N] (Mac OS X)

Open

Use the Open command to bring up
the Open Scene file dialog. Browse
your file system for a scene file.
The Open command is not disabled
when a scene is opened. You can open
a new scene from the current one and
the previous scene will be closed.

File > Open
[Ctrl]+[O] (Windows)
[a]+[O] (Mac OS X)

Open Recent

Displays a quick access list to view and
open recently used Animate files.

File > Open Recent

Open Recent > Clear

Clears the recently opened Animate
files list.

File > Open Recent > Clear

Close

Use the Close command to close the
scene that is currently opened, but
does not close the Animate application.

File > Close

Save

Use the Save command to save all
changes made to the opened scene,
drawings, palettes, and palette lists.

File > Save
[Ctrl]+[S] (Windows)
[a]+[S] (Mac OS X)

Save As

Use the Save As command to save the
current state of a scene as another
scene. The Save As window prompts
you to give a new name and choose a
different location to this scene before
saving it. This will create a complete
scene directory for the new scene.

File > Save As

Use the Save As New Version
command to save the current scene as
another version. The Save Version
window prompts you to give a name for
this new version. This will create a new
.digital file in your current project
directory.

File > Save As New Version

Use the Quit command to close Toon
Boom Animate. If the current scene has
changes, it asks if you want to save
them before closing.

Windows: File > Quit
Mac OS X: Animate > Quit Toon Boom
Animate

Use the Show Scan Information
command to display a status bar
showing scanning information at the
bottom of the Drawing and Camera
view.

Drawing View Menu > View > Show >
Show Scan Information

Cut

Use the Cut command to remove
selected objects. You can then paste
the object or its properties to another
object.

Edit > Cut
[Ctrl]+[X] (Windows)
[a]+[X] (Mac OS X)

Copy

Use the Copy command to copy
selected objects and properties.

Edit > Copy
[Ctrl]+[C] (Windows)
[a]+[C] (Mac OS X)

Save As New Version (PRO)

Quit

Show Scan Information
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Command

Action

Access Methods

Paste

Use the Paste command to place an
object you cut or copied into the
location you select in the Camera,
Drawing and Timeline View.

Edit > Paste
[Ctrl]+[V] (Windows)
[a]+[V] (Mac OS X)

Delete

Use the Delete command to remove
selected objects.

Edit > Delete

Select All

Use the Select All command to select
all drawing objects in the current
drawing window in the Drawing,
Timeline and Camera View. This helps
you manage the objects as one body
when moving them.

Edit > Select All
[Ctrl]+[A] (Windows)
[a]+[A] (Mac OS X)

Deselect All

Use the Deselect All command to
remove the selection from the selected
objects in the Drawing and Camera
View.

Edit > Deselect All

Undo

Use the Undo command to remove the
last change made to your animation
project. Animate supports multiple
undo, so you can revert changes you
have made in the order you made them.

Edit > Undo
[Ctrl]+[Z] (Windows)
[a]+[Z] (Mac OS X)

Redo

Use the Redo command when you have
undone an operation that you decide to
keep. The Redo command becomes
active only after you use the Undo
command.

Edit > Redo
[Ctrl]+[Y] (Windows)
[a]+[Y] (Mac OS X)

Select Child

Use the Select Child command to
select the first element parented to the
selected peg element in the Timeline
View.

Edit > Select Child
[Shift]+[B]

Select Children

Use the Select Children command to
select all elements parented to the
selected peg element in the Timeline
view.

Animation > Select Children

Select Parent

Use the Select Parent command to
select parent of the selected element in
the Timeline view.

Animation > Select Parent
[B]

Select Previous Brother

Use the Select Previous Brother
command to select the next element
(above current element) in the Timeline
view.

Animation > Select Previous Brother
[/]

Select Next Brother

Use the Select Next Brother command
to select the next element (below
current element) in the Timeline View.

Animation > Select Next Brother
[?]

Auto Render Write

Use the Auto Render Write command
to render a frame each time the current
frame is changed.
You must have a Write module in your
network to use this command.

Scene > Render >Auto Render Write

The Message log view displays
information gathered during a render
task, like which frames and at what time
they were each rendered.

Windows > Message Log

Message Log
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Command

Action

Access Methods

Enable the Debug Mode option to
gather and display precise information
about each rendering frame such as the
modules encountered and action taken.

Help > Debug Mode

Help

Launches the Toon Boom Animate Help
System PDF, complete with instructions
on how to use the system.

Help > Help

Toon Boom Animate on the Web

Launches the Toon Boom Animate
website, which features a Support and
Community > Forum section.

Help > Toon Boom Animate on the
Web

About

Use the About command to access
general information about the software.

Windows: Help > About

Debug Mode

Mac OS X: Animate > About Toon
Boom Animate
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Discovering the Interface

Knowing how to manage the Animate interface helps you to work efficiently and organize your workspace
conveniently. There are a series of views and toolbars you can use as you perform different operations. Each user has
a preferred way of working in the interface and which views and toolbars they will use. In this chapter, you will learn
about the main elements of the interface and how to manage them.
In this chapter, you will learn about the following topics:

•
•
•
•
•
•

User Interface, on page 40
Managing the Views, on page 60
Managing the Toolbars, on page 62
Managing the Workspace, on page 64
Interface Navigation, on page 68
Preferences, on page 69
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User Interface
This section takes you through the most common elements of the User Interface. Throughout the user guide, you will
learn about each view and toolbar and how and where to use them.

Views and Toolbars
Toon Boom Animate has several views and toolbars. The Top toolbars are available at the top of the interface and the
View toolbars are in individual windows. View toolbars are only shown if the particular view is displayed in the
workspace.
This is a complete list of the views and toolbars available in Animate and Animate Pro.

Views: Animate
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Camera View
Colour View
Coordinates and Control Points
View
Drawing View
Function View
Layer Properties View
Library View
Model View
Perspective View
Side View
Timeline View
Tool Properties View
Top View
Xsheet View

Top Toolbars: Animate
•
•
•
•
•
•
•
•
•

Advanced Animation Toolbar
Control Point Toolbar
Coordinate Toolbar
Edit Toolbar
File Toolbar
Playback Toolbar
Scripting Toolbar
Tools Toolbar
Workspace Toolbar

View Toolbars: Animate
•
•
•
•
•
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Camera View Toolbar
Drawing View Toolbar
Model View Toolbar
Timeline View Toolbar
Xsheet View Toolbar

Views: Animate Pro
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Camera View
Colour View
Coordinates and Control Points
View
Drawing View
Function View
Layer Properties View
Library View
Message Log
Model View
Module Library View
Network View
Perspective View
Side View
Timeline View
Tool Properties View
Top View
Xsheet View

Top Toolbars: Animate Pro
•
•
•
•
•
•
•
•
•
•
•
•
•

Advanced Animation Toolbar
Control Point Toolbar
Coordinate Toolbar
Display Toolbar
Edit Toolbar
File Toolbar
Playback Toolbar
Scripting Toolbar
Tools Toolbar
Workspace Toolbar
Easy Flipping Toolbar
Flip Toolbar
Onion Skin Toolbar

View Toolbars: Animate Pro
•
•
•
•
•
•

Camera View Toolbar
Drawing View Toolbar
Model View Toolbar
Timeline View Toolbar
Xsheet View Toolbar
Network View Toolbar

Chapter 3: Discovering the Interface User Interface

Interface Highlights
It’s important that you become familiar with the following elements of the user interface, this will help you to start
using Animate. You can learn more about the highlights described here, and how to use them in a production context,
throughout this guide.
When you start Animate for the first time, the default workspace is displayed. It contains all of the main elements you
need to use.

5

8
6
1

3
7

2
4
1.
2.
3.
4.
5.
6.
7.
8.

Camera View, on page 42
Tools Toolbar, on page 45
Tool Properties View, on page 45
Timeline View, on page 46
Menus, on page 53
Colour View, on page 54
Library View, on page 57
Playback Toolbar, on page 58
To learn how to modify the workspace and add more views and toolbars, refer to the following sections:

•
•

Managing the Workspace, on page 64
Managing the Views, on page 60
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Camera View
9

1 2 3 4

5

6

1. Update Preview
2. OpenGL View Mode
3. Render View Mode/Matte View Mode
4. Camera View Options Menu
5. Zoom Drop-down Menu

7

8

6. Drawing Name
7. Tool Name
8. Frame Number
9. Editing Stack Menu

The Camera view is the centre of operations in Animate. It is in this view that you will draw, paint, animate, create
animation paths and see your results. You can also move through your Symbol’s hierarchy.
The Camera view has a top and bottom toolbar that you can use to either navigate in the view, change the display
mode or go back up your Symbols hierarchy.

Update Preview
The Update Preview button lets you check the final look of your effects and fully antialiased image. When you click
the button, Animate calculates the current frame final image. It displays the result in the Render View Mode of the
Camera view, it does not output an image.

OpenGL View Mode
The OpenGL View Mode button switches the Camera view to fast display, letting you see
your animation play in real time. The OpenGL display requires less memory. The final look
of your effects is not shown in the OpenGL View Mode. Switch to the Render View Mode
to see your effects.
Refer to Render View Mode for more details.
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Render View Mode
The Render View Mode button switches the Camera view to a fully rendered display
showing the final image of the current frame. If a modification is done to your current frame
or if you move to a different frame, click on the Update Preview button to update the
display.
Use the Render View Mode display to see the final look of your frames including effects
and antialiasing. You cannot play back your scene in Render View Mode. To see your scene
fully rendered and play it back, you must select File > Export > Render Network and
enable the Preview option in the Render Network dialog box.

Matte View Mode
The Matte View Mode button switches the Camera view to a matte display showing the
alpha channel of the elements in your scene. The transparency level ranges from 0 to 100
percent. Zero percent is completely transparent and represented by black and 100 percent
is completely opaque and represented by white. Everything in between these extremes has
a transparency level somewhere between 1 and 99 percent and is represented in various
shades of grey.

To access the Matte mode, click on the Render View

Mode button and select

Matte View from the drop-down menu.

Camera View Options Menu
This menu contains several options related to the camera view display modes. Here are the options contained in the
menu:

•

Safe Area
The Safe Area button shows or hides the TV safety zone and the centre of the
camera frame.
The Safe Area will adapt to the scene resolution as well as the safety zone and
frame’s centre.
You can also access this feature from the top menu by selecting
View > Show > Safe Area.

•

Camera Mask
The Camera Mask button shows or hides a black mask around the scene’s
frame to avoid seeing the unnecessary artwork.
This option is handy when you are animating and setting up the scene. It allows
you to see your scene’s composition better.
You can also access this feature from the top menu by selecting
View > Show > Camera Mask.

•

•
•

BBox Selection Style
Selecting an object in the Camera view with the Transform tool will make a bounding box appear around
the object rather than causing the selected object to be tinted in fuchsia, red or yellow along with the
bounding box.
Outline Locked Drawings
Drawings that are locked in the Timeline view (cannot be selected in the Camera view) will be displayed as
wire frames.
Current Drawing On Top
If this option is enabled, the drawing that is being currently edited with a drawing tool will be temporarily
displayed in front of all the other elements. The actual scene is not modified by this option.
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•

•

•

•

•

Show Strokes
When drawing with invisible lines such as with the Pencil tool and a line thickness with a value of “0”, the
invisible strokes will be displayed as thin blue lines and the tips of the strokes will be displayed as yellow
squares which helps indicating where there are gaps in the outline.
Show Strokes with Colour Wash
When drawing with invisible lines such as with the Pencil tool and a line thickness with a value of “0”, the
invisible strokes will be displayed as thin blue lines and the tips of the strokes will be displayed as yellow
squares which helps indicating where there are gaps in the outline. The drawing colours will also be washed
out to make the invisible lines stick out better.
Light Table
By default, while using a drawing tool in the Camera view, the layers that are not being edited are washed
out. If the Light Table option is disabled, the drawings will all be displayed in normal colours even though
they are not being edited.
Reset View
The Reset View button will reset any panning, zooming or rotation done in the Camera view and return the
display to the initial settings. You can also use the default keyboard shortcut [Shift]+[M].
Reset Rotation
The Reset Rotation button will reset any rotation done in the Camera view and return the display to the
initial rotation settings. You can also use the default keyboard shortcut [Shift]+[X].

Zoom Drop-down Menu
The Zoom Drop-down menu is used to enlarge or reduce the Camera view display. If you want the
camera frame size to always match the size of your Camera view, select the Fit to View option. Click
on the drop-down arrow and select a zoom level. You can also use the default keyboard shortcuts
[Ctrl]+[-] (Windows) or [a]+[-] (Mac OS X) to zoom out and [Ctrl]+[=] (Windows)
or [a]+[=] (Mac OS X) to zoom in.

Drawing Name
The Drawing Name field displays the name of the selected drawing as well as the layer containing it. If the cell does
not contain any drawing, an Empty Cell text is shown in the field.

Tool Name
The Tool Name field displays the name of the selected tool. If you override a tool using an overriding keyboard
shortcut, the tool’s name will be highlighted in red letters.
Refer to Drawing and Animating > Override Tool, on page 140 to learn how to temporarily override a tool.

Frame Number
The Frame Number field displays the number of the current frame.

Editing Stack Menu
The Editing Stack Menu displays the names of the Symbols and their hierarchy when you are editing a Symbol. You
can click on the different names to go back up to the different parent Symbols or the top/current project.
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Tools Toolbar

The Tools toolbar contains all of the main tools you will use while working in Animate. In the default workspace, you
will find this toolbar on the left-most side of the interface.
Each tool is explained in detail in the following chapters:

•
•
•
•
•
•
•

Drawing and Animating, on page 75
Adding Colour, on page 181
Morphing Drawings, on page 301
Building a Character, on page 405
Setting Up the Scene, on page 475
Creating Animation Paths, on page 583
Animating Your Puppets, on page 645

Tool Properties View

The contextual Properties View contains the most common options and
operations related to the currently selected tool. As soon as you select a tool
from the Tools toolbar, the Tool Properties view will be updated.
For example, if you choose the Select

tool in the Tools toolbar, the Tool

Properties view will display the options and operations related to the Select
tool such as Snap to Contour, Apply to All Drawings, Flip Horizontal and
Flatten.
The content of the Tool Properties view is explained in detail in the
following chapters:

•
•
•
•

Drawing and Animating, on page 75
Adding Colour, on page 181
Setting Up the Scene, on page 475
Animating Your Puppets, on page 645
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Timeline View
1 2 3 4 5 6

12

11

7

14 16
13 15

8

17

These are described later in this section.
1.
2.
3.
4.
5.
6.
7.
8.
9.

Enable/Disable All
Show Selection and Hide All
Others
Add Layers
Delete Layers
Add Drawing Layer
Add Peg
Show/Hide Data View
Current Drawing Displayed
in the Drawing View
Current Frame

18

9

19
10.
11.
12.
13.
14.
15.
16.
17.
18.
19.
20.
21.

10

20

21

Split
Show/Hide Children
Show/Hide Functions
Change Track Colour
Lock/Unlock Layer
Onion Skin
Drawing Substitution
Keyframe Value
Zoom
Keyframe
Drawing Exposure
Symbol Exposure

The Timeline view is the main view used when adjusting the timing of your drawings, connect effects and order your
layers. The Timeline view displays the following:

•
•
•
•
•
•
•
•
•
•

Layers
Effects
Sounds
Keyframe Values
Scene Length
Layer Names
Drawings
Keyframes
Timing
Frames
Refer to the following chapters for more information about using the Timeline view:

•
•
•
•
•
•
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Layers and Timing, on page 235
Building a Character, on page 405
Setting Up the Scene, on page 475
Creating Animation Paths, on page 583
Animating Your Puppets, on page 645
Enhancing With Effects, on page 707
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Enable/Disable All
The Enable/Disable All button is used to show or hide all your layers simultaneously.
To disable a particular layer, uncheck the layer’s checkbox. The default keyboard shortcut is [D].

To enable a particular layer, place a checkmark (tick) the layer’s checkbox. The default keyboard shortcut is [A].

NOTE:
When you disable a layer in the Timeline view, the corresponding column is hidden in the Xsheet view. When a
column is hidden in the Xsheet view, the corresponding layer is disabled in the Timeline view.

Show Selection and Hide All Others
The Show Selection and Hide All Others button is used to show only the currently
selected layer in the Timeline view and disable all the other layers.

Add Layers
The Add Layers button is used to add new layers to the timeline. When you click on the Add Layers button, a dropdown menu will appear displaying the layer types available. You can add several different types of layers:

•

Drawing

•

Peg

•

Mask

•

Camera

•

Effect

•

Sound

•

Bitmap

NOTE:
An effect layer made in Animate will appear with this symbol

when opened in Animate Pro.

Delete Layers
The Delete Layers button is used to delete the currently selected layers in the Timeline
view. When you click on the Delete Layers button, a Confirm Delete dialog box appears.
Click OK to delete the layers or Cancel to stop the operation.

Add Drawing Layer
The Add Drawing Layer button is used to automatically add a new Drawing layer to your timeline. By default, the layer
is named Drawing.

47

Animate Pro 2 User Guide

Add Peg
The Add Peg button is used to add a Peg layer to your timeline. There are several ways to use the Add Peg button.

• If there is no layer selected in the Timeline view, the Peg is added at the bottom
of the timeline.

• If there is a layer selected, the Peg is added as a parent of the selected layer. It
will also be named the same way as the layer plus the -P mention.

• If several layers are selected, an individual peg is added to each layer selected.
Refer to the following sections in the Creating Animation Paths chapter for more information about pegs and
how to use them:

•
•
•
•
•
•
•
•
•

Differences Between Pegs and Animated Layers, on page 586
Pegs, on page 587
Why Use a Peg Layer?, on page 587
The Origins of the Peg, on page 587
Adding a Peg to the Timeline, on page 588
Adding a Peg to the Network (PRO), on page 589
Peg Selection Mode, on page 590
Layer Parameters, on page 590
Displaying a Path in the Camera View, on page 603

Show/Hide Data View
Hidden Data View

Visible Data View

The Show/Hide Data View button is used to display the current frame’s drawing exposure and keyframe values
corresponding to each individual layer.

Current Drawing Displayed in the Drawing View
The drawing selected in red represents the drawing currently displayed in the Drawing view.
The Drawing view’s current drawing does not correspond to the current frame displayed in the
Camera view.

Refer to Drawing and Animating > Drawing in the Camera or Drawing View, on page 78 for more information
about the differences between the Camera and Drawing views.

Current Frame

The red play head represents the current frame displayed in the Camera view and marked in the Playback toolbar. If
you slide the play head to the left or the right it will scrub through your frames and update the Camera view display.
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Split

The Split button is used to split the Timeline in two sections allowing you to see two different portions of your Timeline
view. This way, if your scene length is very long, you can see the beginning and the end at once.

Show/Hide Children
Parent Layer
Child Layer

The Show/Hide Children button is used to display the children layers of a parent layer. Once a layer is parented to
another layer, it is indented to the right and the Show/Hide Children button appears on the parent layer allowing you
to show or hide the child layer.

Show/Hide Functions

Drawing Layer
Functions

The Show/Hide Functions button is used to display the functions embedded in each layer. The Functions are the
different position and intensity information used to remember a layer’s position, scale or rotation as well as an effect’s
look on each frame. This information is stored on the function curves using keyframes.
Refer to the following sections in the Creating Animation Paths chapter for more information about the function
layers:

•
•
•
•
•

Adding and Deleting Keyframes, on page 594
Stop-Motion and Motion Keyframes, on page 596
Modifying a Path in the Function View, on page 614
Function Curves, on page 620
Adjusting the Velocity, on page 633
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Change Track Colour

The Change Track Colour button is used to change the colour of the exposed frames, this helps you to quickly locate
a layer in the Timeline view. Double-click on the swatch to open the picking window and choose a new colour.

Lock/Unlock Layer

The Lock/Unlock Layer button is used to prevent the selection or editing of a layer in the Camera view. To select some
of the layers without selecting others, in the Timeline view, lock the layers you do not want to select.
In the top menu, you there are a series of locking options.
In the top menu select Animation > Lock > select one of the following actions:

•

Lock
This option locks the currently selected element.

•

Unlock
This option unlocks the currently selected element.

•

Lock All
This option locks all the elements in the Camera view.

•

Unlock All
This option unlocks all the elements in the Camera view.

•

Lock All Others
This option locks all the elements in the Camera view except the currently selected one.
You can display the locked drawings as outlines in the Camera view if you want to quickly find
out which drawings are locked.
1. In the top menu, select Edit > Preferences (Windows) or
Animate > Preferences (Mac OS X).
2. In the Preferences panel, go to the Camera tab.
3. In the Tools section, enable the Show Locked Drawings As Outlines option.
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Onion Skin

The Onion Skin button is used to enable the Onion Skin option on a particular layer. If you want to see the previous
and next frames of a specific layer, go to the Timeline view and click on the Onion Skin button for that particular layer.
Blue arrows appear on both sides of the play head. Pull on these blue arrows to add more frames to the onion skin
display.
To activate the general Onion Skin preview, in the Tools toolbar, click on the Onion Skin

button.

Refer to the following chapters and topics for more information about the Onion Skin:

•

•

Drawing and Animating, on page 75
D Onion Skin, on page 148
D Onion Skin Toolbar (PRO), on page 160
D Drawing, on page 178
Animating Your Puppets, on page 645
D Using the Onion Skin in Cut-out Animation, on page 684

Drawing Substitution
The Drawing Substitution field is used to change the drawing exposed at the current frame. To access the Drawing
Substitution field, you must first expand the Data view by clicking on the Show/Hide Data View

button.

To change the current drawing, either click and slide your cursor left
or right when you see the hand
cursor, or, double-click on the
drawing name and type a new value.
The drawing exposure will be changed for the entire block
it is exposed, not just the current frame.

Keyframe Value

The Keyframe Value field is used to add, remove or modify a keyframe at the current frame. To access the Keyframe
Value field, you must first expand the Data view by clicking on the Show/Hide Data View

button.

•

To add a keyframe at the current frame, click on the Add Keyframe

button.

•

To remove an existing keyframe at the current frame, click on the Delete Keyframe

•

To change the current keyframe, either click and slide your cursor left or right when you see the hand
cursor, or, double-click on the keyframe value and directly type a new value.

button.
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•

To navigate through the existing keyframes, click on the Previous Keyframe

and the Next Keyframe

buttons.

•

To link your layer to an existing function or to create a new function, click on the Show Function Menu
button to display the drop-down Function menu.

Refer to the following topics in the Creating Animation Paths to learn more about using the Data view and the
Keyframe Value field:

•
•
•
•

Modifying a Path in the Timeline View, on page 611
Adding and Deleting Keyframes in the Timeline View, on page 612
Changing Keyframe Values, on page 612
Flipping Between Keyframes, on page 613

Zoom
The Zoom tool is used to increase or reduce the width of the frames in the Timeline view. Drag the
cursor to the right to increase the width or to the left to reduce it. You can also use the default
keyboard shortcuts:
[Ctrl]+[-] (Windows) or [a]+[-] (Mac OS X) to zoom out and
[Ctrl]+[=] (Windows) or [a]+[=] (Mac OS X) to zoom in.

Keyframe
Keyframe
Keyframe on Child Layer
A black square is displayed in the Timeline view when a keyframe exists. You are able to select these keyframes and
drag them wherever you want on the timeline. You can also copy, cut and delete them.

•

To delete a keyframe without deleting the drawing exposure, go to the Timeline view and select the
keyframe to be deleted and then select Animation > Delete Keyframes from the top menu.

When a parent layer is collapsed and a child layer contains a keyframe, a white square will be displayed.

Drawing Exposure

In the Timeline view, when a drawing is exposed, it is represented as a grey block. If the drawing is exposed for several
frames, the block is extended. When a second drawing is exposed, a new grey block is displayed.
The exposure’s colour can be changed. To pick anew colour, double-click on the Change Track Colour
button in the corresponding layer.

Symbol Exposure

In the Timeline view, when a Symbol is exposed it is represented as a small film frame. If the Symbol is exposed for
several frames, the film frame is extended. When a second Symbol’s frame is exposed, a new film frame is displayed.

52

Chapter 3: Discovering the Interface User Interface

Menus
You can access the commands from the following three menus:

•
•
•

Top Menu, on page 53
View Menu, on page 53
Quick Access Menu, on page 54

Top Menu

The top menu contains most of the commands. Depending on the view you are working in and the element, some
commands are available and others not. The top menu is always located at the very top of the user interface.
The top menu contains the following categories:

•
•
•
•
•
•
•
•
•
•

File
Edit
View
Play
Insert
Scene
Drawing
Animation
Windows
Help

In the Mac OS X version, there is a Toon Boom Animate category containing the following commands:

•
•
•

Preferences
About
Quit

View Menu
Some views have their own menu. These menus contain commands specifically
related to that view.
You can find a View Menu in the following views:

•Colour View
•Library View
•Model View

•Camera View
•Drawing View
•Function View
•Module Library View
•Network View
•Perspective View
•Side View
•Top View
•Xsheet View
To access the view menu, click on the Menu

button in the view’s top left corner.
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Quick Access Menu
Each view has a Quick Access Menu containing recurring actions. This
menu is accessed by right-clicking (Windows)
or [Ctrl]+click (Mac OS X) anywhere in the view.

Colour View
1 2 3

4

5

6

7 8

11

List Mode
display

10

9

Swatch Mode
display

1.
2.
3.
4.
5.
6.

Add Colour
Remove Colour
Add Texture
Set Current Brush Colour
Set Current Pencil Colour
Set Current Paint Colour

7. Link/Unlink Three Colours
8. Show/Hide Palette List View
9. Colour Swatch Name
10. Colour Swatch
11. Colour View Menu
These are described later in this section.

The Colour View is where you create colours and palettes and import existing palettes into your project. The Colour
View is also necessary for drawing, painting and creating colour styling.
The Colour View has two display modes:

•
•
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List Mode
Swatch Mode
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To toggle between the display modes:
1.

In the Colour View menu, select Colours > Swatch Mode.
Enable the option to display the swatches.
Disable the option to display the colour list.




The Colour View has its own toolbar. Refer to the list below to learn more about its basic functionality.
Refer to Adding Colour > Colours, on page 183 to get more information about the Colour view and its advanced
features.

Add Colour
The Add Colour button is used to add a colour swatch to your palette. lick on the Add Colour button to add a new
swatch to the bottom of your colour list.

Remove Colour
The Remove Colour button is used to delete the currently selected colour
swatches. If the colour swatch is used in your project, the Delete Colour dialog box
will pop and will ask you to confirm the operation.
Click OK to confirm the operation or Cancel to cancel it.

Zones painted with colour swatches which have been deleted will turn red, easily
identifying them so you can repaint them with another colour swatch.

Add Texture
The Add Texture button is used to add a bitmap colour swatch to your palette. Use this to
load photos and textures and paint your drawings with it. The bitmap image must be a TGA
or PSD file format.

Set Current Brush Colour
The Set Current Brush Colour button is used to set the currently selected colour swatch as the colour used by the
Brush
tool. If you select a new colour in the Colour view while using the Brush tool, the Set Current Brush Colour
swatch will be updated.

Set Current Pencil Colour
The Set Current Pencil Colour button is used to set the currently selected colour swatch as the colour used by the
Pencil
, Polyline
, Ellipse
, Rectangle
and Line
tools. If you select a new colour in the Colour view
while using any of these tools, the Set Current Pencil Colour swatch will be updated.
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Set Current Paint Colour
The Set Current Paint Colour button is used to set the currently selected colour swatch as the colour used by the Brush
tool. If you select a new colour in the Colour view while using the Paint tool, the Set Current Paint Colour swatch
will be updated.

Link/Unlink Three Colours
The Link/Unlink Three Colours button is used to link the Set Current Brush
Colour, Set Current Pencil Colour and Set Current Paint Colour swatches to the
currently selected colour swatches in the Colour view.

Show/Hide Palette List View
The Show/Hide Palette List View button is used to display the Palette List view
in the Colour view. This option is for the advanced user who wants to create
colour palettes for their props and characters.
Refer to Adding Colour > Palettes, on page 215 to learn more about the
Palette List view and creating palettes.

Colour Swatch Name
Each colour swatch available in the Colour view can have its own name, making it easy to identify
which colour is used to paint what part of your character or background.
NOTE: Two colours can have the same name.

Colour Swatch
A colour swatch is a specific colour used to paint a certain zone of a character or background.
Colour palettes are composed of colour swatches. They can also be called colour pots. When you
paint a zone with a colour swatch, the zone is linked to the swatch. So if you update the swatch’s
tint, the zone will be updated along with it. This allows you to modify your animation colours even
after it is completely painted.

Colour View Menu
The Colour View menu allows you to access commands that are specifically related to the Colour view such as creating
new palettes, adding new colour swatches and displaying the Tint panel.
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Library View
1

2

5

3

4

1.
2.
3.

Library View Menu
Preview Window
Preview Playback

4. Library Folder List
5. Template/Symbol List
These are described later in this section.

The Library view is used to store elements such as animation, drawings, backgrounds and puppets to reuse them in
your different projects. You also use the Library view to create and store your Symbols.
To reuse an element in another project, you must create a template out of your drawings. A template is a mini scene
that you import in your other project. A template has no link to the original scene. When you create a template, the
full content of your selection is copied in the template.
When you are creating a series of layers all using the same drawings or building puppets, you will create Symbols.
These can be used as drawing containers when you are creating puppets so that you can store different mouth shapes
or hands to use while animating. You can also use Symbols when you are building props, such as a skateboard and
you want to use the same wheel drawing for the four skateboard wheels.
Refer to the Libraries, Symbols and Templates chapter to learn more about using the Library, Symbols and
templates in context.

Library View Menu
The Library View menu allows you to access commands that are specifically related to the Library view such as
importing SWF movies and Illustrator files, adding a new folder and refreshing the library’s content.

Preview Window
The Preview window is used to see the content of the currently selected template or Symbol in the Template/Symbol
list.

Preview Playback
The Preview Playback button is used to play back the content of the selected Template/Symbol if it contains more
than one frame. Press the Play

button to play back the preview.
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Library Folder List
The Library Folder List displays all of the folders linked to the Library view. There are two default folders:

•
•

Symbols
The Symbols folder is the only folder containing Symbols. The user can organize it by adding subfolders
inside.
Animate Library
The Animate Library folder is a default library found on the hard drive in the user’s documents. This folder
can contain templates, but no Symbols.

The user can link new library folders to his Library view and organize them with subfolders.
Refer to the following topics in the Libraries, Symbols and Templates chapter to learn more adding new libraries
and subfolders:

•
•

Creating a Library, on page 381
Creating a Folder, on page 382

Template/Symbol List
The Template/Symbol List displays the templates or Symbols contained in the selected library folder. If you right-click
(Windows) or [Ctrl]+click (Mac OS X), you can display the templates and Symbols’ thumbnails by selecting
View > Thumbnails.

Playback Toolbar

Use it to play back your animation and sound. Use it to scrub your sound to create your lip-sync, looping your
playback, navigating through your frames, change the playback range and speed.

58

•

Click on the Play
button to play and stop the animation. You can also do this from the top menu by
selecting Play > Play Scene Forward or Stop.

•

Click on the Loop
button to repeat your playback indefinitely. Or do this from the top menu by
selecting Play > Loop.

•

Click on the Sound
button to enable sound in the playback. Or do this from the top menu by selecting
Play > Enable Sound.

•

Click on the Sound Scrubbing
button to enable sound scrubbing in the playback. Or do this from the
top menu by selecting Play > Enable Sound Scrubbing.

•

Click on the Render and Play
including the effects.

•
•

Click on the Test SWF Movie
button to create a SWF render (vector-based) to play back the final result,
including effects, but no anti-aliasing.
Scroll through the playback’s frames using the Jog Frames right and left arrows.

•

To change the playback frame range enter new values in the Start and Stop fields.

•

Enter a new value in the fps field to change the speed of the playback.

button to create a render of your scene to play back the final result
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Play Menu
Select any of the following from the top menu Play heading:

•
•
•
•

First Frame or use the shortcut [Home] to jump to and play the first frame.
Next Frame or use the shortcut [.] to play the frame after the currently selected frame in the Timeline View.
Last Frame or use the shortcut [End] to jump to and play the last frame animation.
Previous Frame or use the shortcut [,] to play the frame before the frame currently selected in the Timeline
View.

•

Go to Frame or use the Go
button, which can be added to the Timeline View toolbar through the
Toolbar Manager. Open the Go to Frame dialog box so you can type in the frame number to jump to
Enable Playback view from either the Top, Side or Perspective Views.

•
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Managing the Views
The Animate user interface is composed of different views, each one designed for a specific purpose. This section
explains how you can modify the location and accessibility of the views by adding a new view as a tab or as a window,
you can also swap the view locations around.
This section covers the following topics:

•
•
•
•

Adding a New View, on page 60
Closing a View, on page 61
Swapping Views, on page 61
Resizing a View, on page 61

Workspace modifications are automatically saved when you exit the application unless you disabled the
Automatically Save Workspace preference in the Preferences panel.

Adding a New View
To add a view:
1.

Select the view you want to add from Window > The desired view.

By default, the new
view appears tabbed.

You can also use the Window drop-down menu button included in each view
already available in the workspace. Click on the button and select a view from the
list. You can only open one instance of the same view. In other words, you cannot
have two Camera views open at the same time.
In Animate Pro, you can open several instances of the same view except
for the Timeline, Tool Properties, Colour and Drawing views.
2.
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Closing a View
To close a view:
1.

In the view to close, click on the Close View



button.

If you have several tabs in the same window, hold [Shift] down and click on the Close View
close all tabs together.

button to

Swapping Views
To swap views around:
1.
2.

Select the view tab and drag it onto one of the view’s separators, top area or onto another view’s tab.
When a rectangle outline appears showing an available location for the view, release the mouse button and drop
the view tab into position. One of three things will happen:

1

2

3

D 1. The view becomes a tabbed window.
D 2. The view becomes a floating window.
D 3. The view becomes a new docked window.

Resizing a View
To change the width and height of the views in the workspace, drag the side of the view.
To resize a view:
1.

In the interface, position your cursor on the edge of the view you want to resize.

2.

When you see the Resizing

cursor, click and drag the side of the window to the desired width or height.

You can also temporarily hide a view to get more working space.
To temporarily hide a view:
1.
2.

On the edge of the window you want to hide click on the Collapse/Expand button. The view is compressed and
only the Collapse/Expand button is visible.
Click on the same Collapse/Expand button to display the view again.
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Managing the Toolbars
The Animate user interface contains toolbars which, by default, are located at the top of the interface. Some of the
workspace’s views also have their own toolbars. These toolbars can be moved around. You can reposition the toolbars
to suit your work style or hide unused ones.
This section covers the following topics:

•
•
•

Showing or Hiding Toolbars, on page 62
Moving Toolbars, on page 62
Toolbar Manager, on page 63

Showing or Hiding Toolbars
To show or hide a toolbar:
1.
2.

Select Windows > Toolbars > the desired toolbar.
Select Windows > Toolbars > Line Up to align all of your toolbars.

NOTE:
The Toolbar menu only contains the View toolbars of the views contained in the workspace. As you show or hide
views in your workspace, the Toolbar menu will update.

Moving Toolbars
To move a toolbar:
1.

Select the toolbar you want to move by clicking on its anchor point
another position in the top or side interface toolbar area.

2.

When a rectangle outline appears showing an available location for the toolbar, release the mouse button and
drop the toolbar into position.
2

3

4
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Toolbar Manager
The View toolbars can be customized to contain your favourite tools and options. Use the Toolbar Manager window
to organize your different toolbars to suit your working preferences.
To customize your toolbars:
1.
2.

In the chosen view, right-click (Windows) or [Ctrl]+click (Mac OS X) on any button in the toolbar where you wish
to add or subtract a new button.
From the pop-up menu select Customize.

3.

The Toolbar Manager window opens
To add a new icon to your toolbar, select the tool or command from the Available Tools list and click on the Right
Arrow button to switch it to the Toolbar list.

4.

To remove an icon from your toolbar, select the tool or command in the Toolbar list and click on the Left
Arrow button to switch to the Available Tools list.

5.

To reorder your icons in your Toolbar, select the command to be moved in the Toolbar list and click on the Up
or Down

6.

Arrow buttons to move it to the correct location.

Click on the OK button when you are finished.
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Managing the Workspace
Animate’s user interface is composed of several views. You can customize your workspace to suit your working
preferences, save it as a new workspace, and load it from the Workspace toolbar.
This section covers the following topics:

•
•
•

Loading a Workspace, on page 64
Workspace Manager, on page 64
Restoring the Default Workspaces, on page 67

Loading a Workspace
The first time you open Animate, the default workspace is loaded. Other workspaces are available such as the HandDrawn Animation and the Compositing workspaces, these display different views and toolbars. You can access these
workspaces and any you create, from the Windows menu and the Workspace toolbar.
To load a workspace:
1.

In the top menu, select Windows > Workspace > Workspace or click on the drop-down arrow in the Workspace
toolbar and select a workspace from the list.

Workspace Manager
The Workspace Manager allows you to modify, create, delete, rename and reorder you workspaces.
To open the Workspace Manager:




In the Workspace Tools toolbar, click on the Workspace Manager
button.
In the top menu select Windows > Workspace > Workspace Manager.

Creating a New Workspace
To create a new workspace:
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1.
2.

Open the Workspace Manager.
In the Available Workspaces list, select an existing workspace.

3.

At the bottom of the Available Workspaces list, click on the Add

4.

Select the new workspace option, then click on the Rename button and give it a new name.

button to add a workspace.
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5.

Select the new workspace and click on the Right Arrow

6.

Click on the OK button.

button to send it to the Workspace Toolbar.

Renaming a Workspace
To rename a workspace:
1.
2.
3.

Open the Workspace Manager.
Choose the workspace to be renamed from the list.
Double-click on the workspace to be renamed or click on the Rename button. This allows you to edit the name.

4.
5.
6.

Type in the new name of the workspace.
Press the [Return] key to validate the name.
Click on the OK button.

Saving a Workspace
By default, when you modify the look of a workspace, it is automatically saved. If you prefer to keep your workspaces
as they are and only save the modifications when you really want to, you have to disable the Automatically Save
Workspace preference.
To disable the Automatically Save Workspace preference:
1.
2.
3.

In the top menu, select Edit > Preferences (Windows) or Animate > Preferences (Mac OS X) to open the
Preferences panel.
Go to the General tab.
In the Save section, disable the Automatically Save Workspace preference.

4.

Press the OK button.
The Save Workspace

button appears in the Workspace toolbar.

To save a workspace manually:



In the Workspace toolbar, click on the Save Workspace

button.

In Animate Pro, you can select Windows > Workspace > Save Workspace.
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In Animate Pro, you can save your workspace as a new version to avoid over-writing the current one.
To save your workspace as a new version:
1.

Select Windows > Workspace > Save Workspace As.
The Save Workspace As dialog box opens.

2.
3.

In the text field, enter the new workspace name.
Click on the OK button to validate.

Deleting a Workspace
To delete a workspace:
1.

Open the Workspace Manager.

2.

In the Workspace Manager, select the workspace to be deleted and click on the Left Arrow
it to the Available Workspaces list.

3.

Select the workspace in the Available Workspaces list then click on the Delete
workspace.
Click on the OK button.

4.

button to send

button to delete the

Showing and Hiding a Workspace
To show a workspace:
1.

Open the Workspace Manager.

2.

In the Available Workspaces list, select the workspace to be displayed and click on the Right
to send it to the Workspace Toolbar.
Click on the OK button.

3.

Arrow button

To hide a workspace:
1.

Open the Workspace Manager.

2.

In the Workspace Manager, select the workspace to be hidden and click on the Left
to the Available Workspaces List.
Click on the OK button.

3.

Arrow button to send it

If you do not want to modify the current workspace, use the Workspace Manager to create another one and then
modify that one.
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Reordering the Workspace List
To reorder workspaces:
1.

Open the Workspace Manager.

2.

In the Workspace Toolbar, select the workspace to be reordered and click on the Up
buttons to move it up or down.

3.

Click on the OK button.

or Down

Arrow

Restoring the Default Workspaces
You can restore modified workspaces to their original default layout.
To restore the default workspaces:

 In the top menu select Windows > Restore Default Workspace.
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Interface Navigation
Animate supports Zoom In, Zoom Out, Rotate, Pan and Reset View Position for easy interface navigation.

•
•
•
•
•
•
•
•
•
•

•
•
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Zoom In: Zooms into the view. Use the keyboard shortcut [Ctrl]+[=] (Windows) or [a]+[=] (Mac OS X) or
from the top menu, select View > Zoom In.
Zoom Out: Zooms out of the view. Use the keyboard shortcut [Ctrl]+[-] (Windows) or [a]+[-] (Mac OS X) or
from the top menu, select View > Zoom Out.
To Zoom In and Zoom Out: Hold down [Spacebar] and your middle mouse button while moving the mouse
up or down.
To Pan the view: Hold down the keyboard shortcut
[Spacebar] and drag your mouse in the direction you want to pan the view.
To Recentre the view: Click on the keyboard shortcut [F12] (Windows) or [a]+[F12] (Mac OS X) to recentre
the view on your mouse cursor.
Reset View: Resets the view to its default position. Use the keyboard shortcut [Shift]+[M] or from the top
menu, select View > Reset View.
Reset Rotation: Resets the view’s rotation to its default position. Use the keyboard shortcut [Shift]+[X] or
from the top menu, select View > Reset Rotation.
Reset Pan: Resets the view’s pan to its default position. Use the keyboard shortcut [Shift]+[N] or from the
top menu, select View > Reset Pan.
Reset Zoom: Resets the view’s zoom to its default position. Use the keyboard shortcut [Shift]+[Z] or from
the top menu, select View > Reset Zoom.
Toggle Full Screen: Enlarges the selected view to full screen. The full screen process is done in three
stages. Use the keyboard shortcut [Ctrl]+[F] (Windows)
or [a]+[F] (Mac OS X) or from the top menu, select View > Toggle Full Screen.
D First, the selected view enlarges to the maximum width or height, but keeps the tool views such as
Colour or Pen.
D Second, the view enlarges to full screen.
D Third, the view returns to its original size.
Rotate 90 CW: Rotates the Camera View 90 degrees clockwise, like an animation table,. From the top
menu, select View > Rotate View CW.
Rotate 90 CCW: Rotates the Camera View 90 degrees counter-clockwise, like an animation table. From the
top menu, select View > Rotate View CCW.
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Preferences
An important feature of Toon Boom Animate is the Preferences panel. From here you can customize your interface,
tool behaviour and shortcuts. Throughout this guide, you are often required to go to the Preferences panel to set
parameters and options.

In this section you will learn how to access the Preferences panel and also find a general description of its functionality.
To learn about the different preferences available, refer to the following chapters:

•
•
•
•
•
•
•
•
•

Drawing and Animating > Drawing and Traditional Animation Preferences, on page 175
Adding Colour > Preferences, on page 232
Layers and Timing > Preferences, on page 297
Gathering Content > Preferences (PRO), on page 376
Libraries, Symbols and Templates > Preferences (PRO), on page 404
Setting Up the Scene > Scene Setup Preferences, on page 530
Creating Animation Paths > Preferences, on page 642
Animating Your Puppets > Preferences, on page 704
Enhancing With Effects > Preferences (PRO), on page 816

This section covers the following topics:

•
•

Preference Highlights, on page 70
Keyboard Shortcuts, on page 73
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Preference Highlights
You can set over 80 preferences in the Preferences panel. You will learn about them as you read through this guide.
The Preferences panel is divided into the following tabbed sections:

•
•
•
•
•
•
•

Shortcuts
General
Camera
Exposure Sheet
Drawing
OpenGL
Render

•

Network

•

Template

•

Timeline

•

Advanced
Some preferences require you to exit and restart the application or to close a view and reopen it.

Accessing the Preferences Panel
To access the Preferences panel:
1.

In the top menu, select Edit > Preferences (Windows) or Animate > Preferences (Mac OS X). You can also use
the default keyboard shortcut [Ctrl]+[U] (Windows) or [a]+[U] (Mac OS X).

User Interface Preferences - General Tab
To customize your interface, you will use some of the preferences located in the General as well as the Camera
category.
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Automatically Save Workspace
The Automatically Save Workspace preference is enabled by default. Every time you add a view to your workspace,
remove a toolbar or change a view’s width, these modifications are saved when you quit the application. If you do not
want the system to save these modifications, disable the preference.
This preference does not require you to restart the application.
Refer to the Saving a Workspace section to learn more about this preference.

Focus On Mouse Enter
The Focus On Mouse Enter preference is disabled by default.
In Animate, for the operations or keyboard shortcuts to work in the view in which you are working, the focus must be
in that view. When the focus is on a particular view, a red rectangle appears around its frame. You must click in the
view or on the view’s header for the focus to be done.
If you enable the Focus on Mouse Enter preference, you will not need to click in the view to get the focus. It will be
done as soon as your mouse enters the view.
This preference does not require you to restart the application.
NOTE:
If you enable the Focus On Mouse Enter preference, certain operations from the top menu may not be available
since the view focus may change as you make your way to the top menu. In this case use keyboard shortcuts and
quick access menus (right-click menus (Windows) or [Ctrl]+click menus (Mac OS X)).

Levels Of Undo
The Levels Of Undo preference determines the number of actions retained by the Undo List. By default, the system
stores 50 actions in the list. You can alter the number if you want to.
This preference does not require you to restart the application.

Colours
The Colours preference allows you to modify the colours of the different User Interface views and elements. For
example, you can change the Camera view’s background colour from grey to white.
Altering these preferences requires you to restart the application or to close a view and reopen it for the modifications
to be applied.

Current View Border
The Current View Border preference sets the colour of the frame around the workspace view you are currently using,
also known as focus. By default, the colour is red. Click on the red colour swatch to select a new colour in the Colour
Picker window.

Current View Border in Template Edit
The Current View Border preference sets the colour of the frame around the workspace view you are currently using
when editing a template from your library view. By default, the colour is green. Click on the green colour swatch to
select a new colour in the Colour Picker window.
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Edit Colours Button
Click on the Edit Colours button to open the Colours window.

In the Colours window, you can modify any of the colours from the list. Most of the modifications will require you to
restart the application or close the view and reopen it to see them.

•

To restore all of the default interface’s colours, click on the Restore All Defaults button.

The Colours window is divided into the following categories:

•

Camera

•
•
•

Network
Exposure Sheet
Drawing

Click on any of the colour swatches and select a new colour from the Colour Picker window.
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User Interface Preferences - Camera Tab

Zoom Settings
In the Zoom Settings section, you can change the Camera View Default Zoom value from the drop-down menu. This
selection sets the Reset View value in the Camera, Top and Side views.

Keyboard Shortcuts
To speed up your work, all of Toon Boom Animate’s keyboard shortcuts can be customized and you can even choose
other software keyboard shortcut sets.
This section covers the following topics:

•
•

Selecting a Keyboard Shortcut Set, on page 73
Customizing a Keyboard Shortcut, on page 74

Selecting a Keyboard Shortcut Set
In Animate, you can choose a set of default keyboard shortcuts you are familiar with. You can choose between the
following:

•
•
•

Adobe® Flash® (Default)
Toon Boom Animate
Toon Boom Studio

To switch keyboard shortcut sets:
1.
2.
3.

Open the Preferences panel.
Use the default keyboard shortcut [Ctrl]+[U] (Windows) or [a]+[U] (Mac OS X).
In the Preferences panel, go to the Shortcuts tab.
In the Shortcut Set drop-down menu, select the desired set.
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Customizing a Keyboard Shortcut
You can also customize most of the shortcuts by opening the Preferences panel and going to the Shortcuts tab.
To set a shortcut:
1.
2.
3.
4.

Open the Preferences panel.
Use the default keyboard shortcut [Ctrl]+[U] (Windows) or [a]+[U] (Mac OS X).
In the Preferences panel, go to the Shortcuts tab.
In the left window, select the command to modify.
Click on the shortcut rectangle (above the right window).

Current keyboard shortcut.
Clears the current keyboard shortcut.
Resets the keyboard shortcut to its default value.
5.

On your keyboard, click on the desired shortcut.
To reset a command’s default keyboard shortcut, click on the Default button.
To remove any keyboard shortcut associated to a command, click on the Clear button.
Click on the OK button.



6.

NOTE:
If a keyboard shortcut is already in use, the Conflict Detected dialog box will appear notifying you of the command
to which it is already associated. You can continue to associate the shortcut or cancel the operation and choose
another command.

The Replace button
associates the
selected keyboard
shortcut and
removes it from any
commands already
using it.

The Cancel button stops the
operation and lets you
select another keyboard
shortcut.

The Duplicate button associates the selected
keyboard shortcut with the command and allows
other commands in the list to use the same one.
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In Toon Boom Animate, many powerful tools, views and features are available so you can design, draw and animate
with ease. This chapter explains the main assets needed when drawing and animating in the software as well as tips
on how to start and use these tools efficiently.
In this chapter, you will learn about the following:

•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

How to Draw, on page 76
Tool Properties View, on page 77
Drawing in the Camera or Drawing View, on page 78
Drawing with the Brush or the Pencil, on page 84
Viewing the Final Lines as you Draw, on page 85
Drawing with the Brush Tool, on page 87
Drawing with Line Texture (PRO), on page 92
Drawing using the Pencil Tool, on page 98
Drawing using Invisible Lines, on page 102
Erasing Parts of a Drawing, on page 105
Reshaping a Drawing Using the Contour Editor Tool, on page 108
Selecting Drawing Objects, on page 113
Drawing With Shapes, on page 121
Drawing Using the Polyline Tool, on page 126
Deforming a Drawing Using the Perspective Tool, on page 129
Cutting Drawing Parts, on page 131
Smoothing Lines, on page 133
Working With Text, on page 136
Override Tool, on page 140
More Drawing Tools, on page 141
Traditional Animation Tools, on page 148
Basic Traditional Animation, on page 154
Advanced Traditional Animation (PRO), on page 159
Cleaning Scanned Drawings (PRO), on page 171
Drawing and Traditional Animation Preferences, on page 175
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How to Draw
As soon as Animate is launched, you can start to draw straight away using the default Drawing layer.
If you need to add a new drawing layer, refer to Layers and Timing > Adding New Drawing Layers, on page 251.
How to draw:
1.

In the Tools toolbar, select the Brush

2.

In the Timeline or Xsheet view, click in the first cell of the drawing layer.

tool, you can also use the default keyboard shortcut [Alt]+[B].

3.
4.

In the Drawing or Camera view, start drawing.
You can change the colour of the Brush in the Colour view, using the default colour palette swatches. Click on
the desired colour.

Refer to Adding Colour > Adding a Colour Swatch, on page 184 if you want to use more colours.
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Tool Properties View
The Tool Properties view is where you can customize the currently selected tool. The options and operations displayed
changes according to each tool you select.

1
2
3

4

1.
2.
3.
4.

The icon displayed here shows the currently selected tool.
The Manipulators section contains shortcuts to similar tools.
The Options section contains the possible actions for the current tool.
The Operations section contains the possible operations for the current tool.

Manipulators
Manipulators are buttons which let you switch quickly between similar tools such as the Select tool and the Transform
tool or the Line, Rectangle and Ellipse tools.

Options
Options are different modes you can apply to a selected tool to modify its behaviour to fit the current task’s needs.

Operations
Operations are actual actions you can perform while using the selected tool.
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Drawing in the Camera or Drawing View
In Toon Boom Animate, you can draw in either the Drawing view or the Camera view. Even though the two views are
similar, when it comes to drawing, there are some differences.

Drawing View
1

2

3
4

1.
2.
3.

Drawing View Toolbar
Drawing Area
Line Art, Colour Art, and Preview Mode
Animate Pro also has Underlay
and Overlay layers.

5

6

4. Drawing Name
5. Tool Name
6. Current Frame
These are described later in this section.

Only the selected drawing is displayed by default in the Drawing view. Use features such as the Light Table, which
displays the current frame drawing of all the enabled layers of your scene in washed-out colours, or the Onion Skin
which displays the previous and next drawings of the currently selected drawing layer.

Drawing View Toolbar
This toolbar gives you fast access to many features that are helpful when using the Drawing view. You can customize
this toolbar to display your favourite commands.
Refer to Discovering the Interface > Toolbar Manager, on page 63 to learn more about customizing the toolbars.
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Drawing Area
This is the Drawing view’s main space, it is where you draw, and where the drawings are displayed.

Line Art, Colour Art, and Preview Mode

In Animate, these buttons are only displayed when the Use Advanced Art Mode preference is enabled. Select
Edit > Preferences > General (Windows) or Animate > Preferences > General (Mac OS X). You will need to restart
the application for this option to work.
Refer to Use Advanced Art Mode (Animate), on page 175 topic to learn more about the Line Art and Colour Art
concept.



Line Art:
Click on this button to switch to the Line Art layer of the drawing. You can also use the default keyboard
shortcut [L].



Colour Art:
Click on this button to switch to the Colour Art layer of the drawing. You can also use the default keyboard
shortcut [L].



Preview mode:
Click on this button to switch to Preview mode, this will let you see both Line Art and Colour Art layers
simultaneously. You can also use the default keyboard shortcut [Shift]+[P].

In Animate Pro, you can display the Preview mode drop-down menu and select the Underlay and Overlay layers if you
want to show all four of them at the same time.



Overlay:
Click on this button to switch to the drawing’s Overlay layer. This layer is located above the Line Art layer.
You can also use the default keyboard shortcut [:].



Underlay:
Click on this button to switch to the drawing’s Underlay layer. This layer is located under the Colour Art
layer. You can also use the default keyboard shortcut [:].



Preview mode:
Click on this button to switch to Preview mode, this will let you see both Line Art and Colour Art layers
simultaneously. You can use the default keyboard shortcut [Shift]+[P]. You can also select Underlay and
Overlay from the drop-down menu to see them.

Drawing Name
This field displays the name of the layer and the drawing name you are currently working on.

Tool Name
This field displays the current tool selected.
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Current Frame
This field displays the current frame of the animation you are working on.

Camera View

1
1.
2.
3.
4.

2

3

4

Line Art, Colour Art and Preview Mode
Drawing Name
Tool Name
Current Frame

In the Camera view, you can also use the Onion Skin feature to display previous and next drawings. By default, all the
enabled drawing layers in the selected frame are displayed, letting you edit them together. This way, you can use the
Select

tool to select many objects from individual layers at once.

From the Timeline view, you can avoid making mistakes by locking the layers containing the drawings you don’t want
to modify, while keeping the drawing visible as a reference and disabling the layers you don’t want to display in the
Camera view.
To enable the onion skin from the Timeline view:

 In the Timeline view, click on the Onion Skin
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To lock a drawing layer:

 In the Timeline view, click on the Lock

icon of the layer you don’t want to edit.

To hide a drawing layer:
1.

In the Timeline view, click in the check box corresponding to the layer you want to hide.

Refer to the Selecting Drawing Objects topic to learn more on how to use the Select Tool.
Refer to the More Drawing Tools topic to learn more about the Onion Skin and Light Table features.

Line Art, Colour Art and Preview Mode
In Animate, these buttons are only displayed when the Use Advanced Art Mode preference is enabled. Select
Edit > Preferences > General (Windows) or Animate > Preferences > General (Mac OS X). You will need to restart
the application for this option to work.
Refer to Use Advanced Art Mode (Animate), on page 175 topic to learn more about the Line Art and Colour Art
concept.



Line Art:
Click on this button to switch to the Line Art layer of the drawing. You can also use the default keyboard
shortcut [L].



Colour Art:
Click on this button to switch to the Colour Art layer of the drawing. You can also use the default keyboard
shortcut [L].



Preview mode:
Click on this button to switch to Preview mode, this will let you see both Line Art and Colour Art layers
simultaneously. You can also use the default keyboard shortcut [Shift]+[P].
To activate the Preview Mode button in the Camera view bottom toolbar, you must enable the
Current Drawing on Top option.

To enable the Current Drawing On Top option:
1.
2.

In the Camera bottom toolbar, click on the Camera Option button.
In the drop-down menu, enable the Current Drawing on Top option.
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In Animate Pro, you can display the Preview mode drop-down menu and select the Underlay and Overlay layers if you
want to show all four of them at the same time.



Overlay:
Click on this button to switch to the drawing’s Overlay layer. This layer is located above the Line Art layer.
You can also use the default keyboard shortcut [:].



Underlay:
Click on this button to switch to the drawing’s Underlay layer. This layer is located under the Colour Art
layer. You can also use the default keyboard shortcut [:].



Preview mode:
Click on this button to switch to Preview mode, this will let you see both Line Art and Colour Art layers
simultaneously. You can use the default keyboard shortcut [Shift]+[P]. You can also select Underlay and
Overlay from the drop-down menu to see them.

Drawing Name
This field displays the name of the layer and the name of the drawing currently selected in the Timeline or Xsheet view.

Tool Name
This field displays the current tool selected.

Current Frame
This field displays the current displayed frame of the animation.
Refer to Discovering the Interface > Camera View, on page 42 to learn more about the Camera view.
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Show Current Drawing on Top
In Animate, when you draw on a layer, the artwork is displayed in the correct order, for example, if the layer on which
you are drawing is located behind an object on another layer, the lines you are drawing will be hidden behind that
object.

This option lets you display the selected drawing on top of everything while your draw. By enabling this option, each
time you select a drawing tool, the selected drawing will be displayed in front of everything in your Camera view.
Note: the Timeline and Network view ordering will not be changed.
To display your drawing on top:
1.

In the top menu, select View > Show > Current Drawing on Top. You can also, in the Camera bottom toolbar,
click on the Camera Option button.

In the drop-down menu, enable the Current Drawing on Top option.
In the Tools toolbar, select a drawing tool.
In the Camera view, start drawing.


2.
3.

NOTE: you only need to enable this option once, it is not necessary to do it each time you select a drawing tool.
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Drawing with the Brush or the Pencil

The Brush

and Pencil

tools are used to draw and sketch with.

The Brush tool has pressure sensitivity, allowing you to create lines with variable thicknesses. The Pencil and Shape
tools produce a uniform thickness as they use a central vector. If you draw with the Pencil tool and want to modify the
thickness you can convert the pencil to a Brush with the Pencil Lines to Brush option.
To adjust the thickness, use the Contour Editor

tool. You can also convert a brush zone into a pencil line with the

Brush to Pencil
option. The brush line will lose its thick and thin characteristics as it changes from a contour vector
to a central vector type.
Refer to the Reshaping a Drawing Using the Contour Editor Tool topic to learn more about adjusting the Brush
line’s thickness.
Refer to the Selecting Drawing Objects topic to learn more about the Brush line to Pencil Line option.
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Viewing the Final Lines as you Draw

Real-Time Antialiasing Disabled

Real-Time Antialiasing Enabled

Everything you draw in Animate is vector-based. Although, when you draw in the Camera or Drawing view, you will
notice that your lines may be jagged. This is the fast real-time display called OpenGL.
If you prefer to see smooth lines as you draw, you can enable the antialiasing. There are two types of antialiasing in
Animate:

•
•

Real-Time Antialiasing, on page 85
Full Scene Antialiasing, on page 86

Real-Time Antialiasing
The Real-Time Antialiasing is generated by Animate. This means that when you draw your lines, the preview becomes
antialiased as you go. If you zoom in more than 100% in the Camera view, pixels will start to appear. Your elements
are still fully vector based. Only the preview becomes pixelated. Your drawings are antialiased to the scene’s
resolution.
Antialiasing is a preference you can turn on and off. By default, the Real-Time Antialiasing preference is disabled.
This option lets you see the final result of your scene as you draw. You can change the value of the antialiasing through
the Preferences dialog box, to fit to the current zoom level used in the Camera or Drawing view or to disable it.
NOTE:
Real-Time Antialiasing parameters are only valid while you work in your scene. The scene will be rendered out to
100% of its resolution regardless of your settings in the Preferences panel.
To customize the antialiasing parameters:
1.

2.

Select Edit > Preferences (Windows) or Animate > Preferences (Mac OS X).
You can also use the default keyboard shortcut [Ctrl]+[U] (Windows) or [a]+[U] (Mac OS X).
The Preferences dialog box opens.
In the OpenGL tab, go to the Real-Time Antialiasing section.







Enable check box: Click on the Enable check box to enable or disable the Real-Time Antialiasing. You can
also use the keyboard shortcut [Ctrl]+[Shift]+[Alt]+[A] (Windows) or [a]+[Shift]+[Alt]+[A] (Mac OS X) to
enable and disable the antialiasing while working in the Camera or Drawing view.
Render at this Factor Times the Scene Resolution: The default value is 1. This value corresponds to how
many times larger than the scene’s resolution you want your drawings to be antialiased. If you zoom into
your drawings to 200% you should set the value to 2.
Tile Size: When the drawing is antialiased, the whole is broken into small tiles to make the process faster.
Only the tiles with artwork on are rendered out. When you modify a zone on your drawing, only the
modified tiles are updated.
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•
•

Making the tiles too small results in sending more tiles to be rendered out, which makes the process longer.
Making the tiles too large results in sending bigger tiles out to be rendered out which is more of a strain on
the video card. Since the tiles are larger, they get updated more often because the artwork you modify may
be one of these tiles.

Full Scene Antialiasing

The Full Scene antialiasing is generated by your computer’s graphic card. This antialiasing will not only antialias your
drawings but all your different views in the interface.
Full Scene Antialiasing is a preference you can turn on and off. By default, the Full Scene Antialiasing preference is
disabled.
NOTE:
Full Scene Antialiasing parameters are only valid while you work in your scene. The scene will be rendered out to
100% of its resolution regardless of your settings in the Preferences or graphic card panel.
To customize the full scene antialiasing parameters:

1.

2.
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NOTE: This procedure requires that if you have a Mac OS you must restart Toon Boom Animate after you
have changed the parameters.
If you are using Windows, you must enable your graphic card’s antialiasing parameter. Refer to your graphic card
manufacturers user guide to learn how to do so.
For example, the parameters for an NVIDIA GeForce card may look like this:

In Animate, select Edit > Preferences (Windows) or Animate > Preferences (Mac OS X).
You can also use the default keyboard shortcut [Ctrl]+[U] (Windows) or [a]+[,] (Mac OS X).
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3.

The Preferences dialog box opens.
In the OpenGL tab, go to the Full Scene Antialiasing section.




Enable check box: Click on the Enable check box to enable or disable the Full Scene Antialiasing.
Number or samples (For Mac OS): If you are using a Mac computer;
D You must enter the number of samples you want to be used for the antialiasing process.
the number of samples is basically equivalent to the number of time a pixel will be enlarged to calculate
the antialiasing. This technique is called supersampling.
The higher the number of samples, the better the antialiasing quality will be, but the longer it will take
to calculate.
D Once done, you must restart Toon Boom Animate.

Drawing with the Brush Tool

The Brush tool is pressure sensitive and can create a contour shape which gives a thick and thin line effect, as if the
drawing was made with a brush.
To draw with the Brush tool:
1.

In the Timeline or Xsheet view, select the cell where you want to draw.

2.

In the Tools toolbar, select the Brush

3.

In the Colour View, click on a colour swatch to select a colour.

4.

tool, you can also use the default keyboard shortcut [Alt]+[B].

In the Drawing or Camera view, start drawing.
Hold [Ctrl] (Windows) or [a] (Mac OS X) to force a line to join the end and start of your shape while drawing.



[Ctrl] (Windows)
[a] (Mac OS X)

NOTE: The last colour you select while using the Brush tool is recalled the next time you select the Brush tool.
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Brush Tool Options
When you select the Brush tool, its properties and options appear in the Tool Properties view.
Animate

Animate Pro

Regular Brush Mode
The Regular Brush tool creates contour lines as you draw, adding each brush lines on top of the last ones.

Draw Behind Mode
The Draw Behind mode is used to paint behind the existing art.

Repaint Brush Mode
The Repaint Brush is used to repaint zones that have already been painted, it will not
affect empty zones or pencil lines. It also automatically flattens each of its brush lines
so it does not add new brush lines on top of existing ones. You can use this mode to
paint tones or highlights onto your character.
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Use Stored Colour Gradient
The Use Stored Colour Gradient option makes the Brush tool use the previously stored gradient position. This way,
every new brush line fits with the stored gradient position.
Refer to Selecting Drawing Objects to learn how to use the Store Colour Gradient option.

Auto-Flatten Mode
When enabled, the Auto-Flatten mode will automatically flatten the new brush lines created with the existing artwork
as you draw in the Drawing or Camera view.

Respect Protected Colour
The Respect Protected Colour option prevent the colours you marked as protected in the Colour view to be repainted
using the Repaint Brush mode.
Refer to Adding Colour > Protecting Colours, on page 209 to learn how to use the Protect Colour feature.

Create Colour Art Automatically
The Create Colour Art Automatically option is only available in Advanced Art Mode because
it uses the Line and Colour Art concepts. As you draw in Line Art, this option automatically
creates the corresponding strokes in Colour Art.
In Animate Pro, the Create Colour Art Automatically option is available by default.
Refer to the Use Advanced Art Mode (Animate) topic to learn more about the Line Art
and Colour Art concept.

Brush Styles
A variety of brush styles are provided allowing you to create and save your own. This way you can create brushes with
precise sizes and parameters and save them so you can draw and design.

Selecting a Brush Style

To select a brush style:
1.
2.

Click on the arrow button to get the Brush Style drop-down menu.
Select a brush style from the list.
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Adding a Brush Style

To add a Brush Style:

 Click on the Add Brush Style

button.

The new brush style will appear at the end of the Brush Styles drop-down menu list.

Renaming a Brush Style

To rename a Brush Style:
1.
2.
3.

Click on the arrow button of the Brush Style drop-down menu.
Select the brush style you want to rename.
Click on the Rename Brush Style

button.

The Rename Pen dialog box opens.

4.
5.

Type in a name for the selected Brush Style.
Click on the OK button.

Deleting a Brush Style

To delete a Brush Style:
1.
2.

Click on the arrow button of the Brush Style drop-down menu.
Select the brush style you want to delete from the Brush Style list.

3.

Click on the Delete Brush Style

button.

Minimum and Maximum Size
This is where you set the minimum and maximum sizes of the Brush tool which will produce the thick and thin effect
on your brush line. This works with the pressure sensitivity of a pen tablet. You can see a preview of this effect in the
Preview space.

1
2
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1.Minimum Size field: Type a value in this field to set the minimum width of the brush.
3 2.Maximum Size field: Type a value in this field to set the maximum width of the brush.
4 3.Up/Down arrows: Use the up and down arrows to set the minimum size value.
4.Up/Down arrows: Use the up and down arrows to set the maximum size value.
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Smoothness and Contour Optimization
Smoothness
You can modify the central line smoothness of your line using this option. This parameter smoothes the initial
movement of your line. Increasing the value will result in a smoother line with less control points.

Contour Optimization
You can optimize the contour line smoothness of you brush line using this option. This parameter will smooth the
contour of your line once the line has been traced, the higher the value the less control points will compose your line.

1
2

3
4

1.Smoothness field: Type a value to set the smoothness of the line.
2.Contour Optimization field: Type a value to set the contour optimization of the line.
3.Up/Down arrows: Use the up and down arrows to set smoothness value.
4.Up/Down arrows: Use the up and down arrows to set the contour optimization value.

Brush Tips

In this drop-down menu, you can find a variety of brush shapes from round and square ones to star shaped, select the
one you need.

Preview
The Preview field lets you see a preview of the brush line that will be produced after you customize the different
parameters in the Tool Properties view.

1
2
1.
2.

The Arrow button lets you show or hide the Preview.
The Preview field is where the brush line is displayed.

Line Texture (PRO)
In Animate Pro, you can draw with a textured line. Textured lines are a mixed bitmap image contained in a vector
frame. This allows you to sketch as if you are drawing on paper.
Refer to the Drawing with Line Texture (PRO) topic to learn everything about line texture and its parameters.
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Drawing with Line Texture (PRO)

In Animate Pro, using the Brush

tool, you can enable the texture option and draw with bitmap textured lines.

In the Brush Tool Properties view, you will find a series of default textured brushes but you can also create your own
collection by importing either PSD or TGA files in the Pen list.
NOTE: the textured brush only work with the Brush tool. It does not work with the Pencil, Line, Ellipse, Polyline
or Rectangle tools.
This topic is divided as follows:

•
•
•
•
•
•
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How to Draw with Texture (PRO), on page 93
Adjusting the Line Texture Parameters (PRO), on page 94
Creating Texture Brushes (PRO), on page 95
Erasing Textured Lines (PRO), on page 95
Hiding the Line Texture (PRO), on page 96
Adjusting the Line Texture Opacity (PRO), on page 97
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How to Draw with Texture (PRO)
To draw with textured lines, use the Brush tool and the correct pen in the list.
To draw with textured lines:
1.

In the Tool toolbar, select the Brush

tool. The default keyboard shortcut is [Alt]+[B].

2.

In the Tool Properties view, select a textured brush from the Pen drop-down list.

3.

In the Camera or Drawing view, start drawing

Refer to the Drawing with the Brush Tool section to learn more about drawing with the Brush tool.
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Adjusting the Line Texture Parameters (PRO)
In the Brush Tool Properties view, there are a number of parameters you can use to adjust the look and feel of your
textured brush.
4

1
2

5

3

6

•
•

•
•
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1. Enable Texture:
Enable this option to allow your brush to draw with texture. If you disable this option, the brush will trace
fully vector based lines.
2. Minimum Opacity:
This value corresponds to the opacity of the brush when the pressure is very light. The closer to zero the
value is, the more transparent the line will be.
.

3. Maximum Opacity:
This value corresponds to the opacity of the brush when the pressure is heavy. The closer to 1 the value is
the more opaque the line will be.
4. Hardness:
The hardness value corresponds to the smoothness of the line edge. The lower the value, the more blurry
and smooth the line edge will be. The higher the value, the sharper the line edge will be.

•

5. Texture File:
The Texture File button displays the texture currently in use or allows you to browse for a texture file to
import. Browsing for a texture file in a brush already using texture will replace the file currently in use,
although it will not replace the texture in the lines already drawn.

•

6. Texture Scale:
The Texture Scale value changes the size of the texture file in the line. If you are using a plaid texture, the
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squares will be larger if you increase the value and smaller if you decrease it.

Creating Texture Brushes (PRO)
To create your own texture brush, you must prepare your texture file in a third-party software such as Adobe®
Photoshop®. If your image has transparency in it, it will be supported. The texture file must be either a PSD or TGA file.
It is recommended to maintain your texture resolution between 100x100 pixels and 400x400 pixels.
To create your own texture brush:
1.

In the Tools toolbar, select the Brush

tool. The default keyboard shortcut is [Alt]+[B].

2.

In the Tool Properties view, click on the New Brush

3.

In the Texture section, check the Enable Texture option.

4.

Click on the Texture File button and browse for your bitmap texture file. Note: the image colour will not be
used, only the pattern in it.

5.

In the Camera view, draw some lines and adjust the parameters to fit the style you are looking for. Note: your
pen list will be automatically saved.

button to add a new brush to your list.

Erasing Textured Lines (PRO)
When you use the Eraser tool to erase a portion of a textured line, the vector frame is cut straight and you lose the
feather created while drawing with the Brush tool.
In Animate Pro, a special option in the Eraser
cut or keep the vector frame as is.

tool lets you create a soft edge on your textured lines. You can also

To erase textured lines:
1.

In the Tools toolbar, select the Eraser

2.

In the Tool Properties view, enable the Use Blur Parameters option.

tool. The default keyboard shortcut is [Alt]+[E].

3.

While erasing, enable the Keep Vectors option to keep your vector frames and not cut them.
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4.

You can adjust Minimum Opacity and Maximum Opacity parameters of the eraser to change the transparency of
the erasing trail as you press harder on the pen tablet.

5.

You can adjust the Hardness and Eraser Saturation parameters of the eraser to control the amount of
smoothness and the size of the feather edge.

6.

In the Camera or Drawing view, erase your textures lines.

Erased with the Blur parameters

Erased without the Blur parameters

Hiding the Line Texture (PRO)

Sometimes you need to hide the line texture to see the complete vector frame around your lines. This command is
useful to help you see any dirt floating around your drawing.
To hide the line texture, you must disable the Real-Time Antialiasing option. In the top menu, select
Edit > Preferences (Windows) or Animate Pro > Preferences (Mac OS X) and in the OpenGL tab, uncheck the Enable
option in the Real-Time Antialiasing section. The default keyboard shortcut is [Ctrl]+[Alt]+[Shift]+[A] (Windows) or
[a]+[Alt]+[Shift]+[A] (Mac OS X).
To be able to hide the line texture in the Camera view, you must enable the Show Drawing on Top option. In the
top menu, select View > Show > Current Drawing on Top. Refer to the Show Current Drawing on Top section to
learn more about this option.
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To hide the line texture:
1.

Make sure the real-time antialiasing is disabled and if you are in Camera view, enable the Show Current Drawing
on Top option.

2.

In the Camera or Drawing View
menu, select View > Show > Hide Line Texture. The default keyboard
shortcut is [Ctrl]+[Alt]+[H] (Windows) or [a]+[Alt]+[H] (Mac OS X).

Adjusting the Line Texture Opacity (PRO)

At some point, you may want to modify the look of a textured drawing. Maybe you find that your line is too smooth
or too faint. You can adjust those parameters by using the Adjust Line Texture Opacity command.
To be able to adjust the line texture, you must disable the Real-Time Antialiasing option. In the top menu, select
Edit > Preferences (Windows) or Animate Pro > Preferences (Mac OS X) and in the OpenGL tab, uncheck the Enable
option in the Real-Time Antialiasing section. The default keyboard shortcut is [Ctrl]+[Alt]+[Shift]+[A] (Windows)
or [a]+[Alt]+[Shift]+[A] (Mac OS X).
To be able to adjust the line texture in the Camera view, you must enable the Show Drawing on Top option. In
the top menu, select View > Show > Current Drawing on Top.
Refer to the Show Current Drawing on Top section to learn more about this option.
To adjust the line texture opacity:
1.
2.
3.

Make sure the real-time antialiasing is disabled and if you are in Camera view, enable the Show Current Drawing
on Top option.
In the Timeline or Xsheet view, select the drawing you want to adjust the opacity for.
In the Camera or Drawing view menu, select Drawing > Adjust Line Texture Opacity.
The Adjust Line Texture Opacity dialog box opens.

4.
5.
6.

Drag the sliders toward the middle to increase the contrast and opacity of the textured lines.
If you want to apply the changes to all drawings exposed on the layer, enable the Apply to All Drawings option.
Click on the OK button.
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Drawing using the Pencil Tool

The Pencil tool creates a centreline shape of constant width, making a clean line.
To draw with the Pencil tool:
1.

In the Timeline or Xsheet view, select the cell where you want to draw.

2.

In the Tools toolbar, select the Pencil

3.

In the Colour View, click on a colour swatch to select a colour.

4.

tool, you can also use the default keyboard shortcut [Alt]+[Y].

In the Drawing or Camera view, start drawing.
Hold [Alt] to draw a straight line.
Hold [Ctrl] (Windows) or [a] (Mac OS X) to keep a line joining the end and start of your shape while
drawing.




[Ctrl] (Windows)
[a] (Mac OS X)

NOTE: The last colour which you selected while using the Pencil tool will be remembered the next time you select it.
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Pencil Tool Options
When you select the Pencil tool, its properties and options appears in the Tool Properties view.

Draw Behind
When the Draw Behind mode is enabled, the lines you draw will appear behind the art
that already exists.

Auto-Close Gap
When enabled, the Auto-Close Gap mode will automatically connect with an invisible stroke, the pencil lines you draw
close to each other in the Camera or Drawing view.

Auto-Flatten Mode
When enabled, the Auto-Flatten mode will automatically flatten the pencil lines created with the existing ones as you
draw in the Drawing or Camera view.
Using the Select tool, you can use the middle mouse button to select a segment of flattened pencil line. Use this
technique to create a nice finish to lines and corners in your artwork.
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Create Colour Art Automatically
The Create Colour Art Automatically option is only available in Advanced Art Mode because
it uses the Line and Colour Art concepts. As you draw in Line Art, this option automatically
creates the corresponding strokes in Colour Art.
In Animate Pro, this Create Colour Art Automatically option is available by default.

Refer to the Use Advanced Art Mode (Animate) topic to learn more about the Line Art and Colour Art concept.

Pencil Styles
Animate provides a variety of pencil styles and also lets you create and save your own. It is a good idea to create and
save pencils with precise sizes and parameters when you draw and design.

Selecting a Pen Style

To select a pen style:
1.
2.

Click on the arrow button of the Pen Style drop-down menu.
Select a pen style from the list.

Adding a Pen Style

To add a Pen Style:

 Click on the Add Pen Style

button. The new pen style will appear in the Pen Styles drop-down menu list.

Renaming a Pen Style

To rename a pen style:
1.
2.
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Click on the arrow button of the Pen Style drop-down menu.
Select the pen style you want to rename.
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3.

Click on the Rename Pen Style

button. The Rename Pen dialog box opens.

4.
5.

Type in a name for the selected pen style.
Click on the OK button.

Deleting a Pen Style

To delete a pen style:
1.
2.

Click on the arrow button of the Pen Style drop-down menu.
Select the pen style you want to delete from the Pen Style list.

3.

Click on the Delete Pen Style

button.

Pen Size
This is where you set the pencil size value. The Pencil tool is not pressure sensitive, it creates a line of constant width
with no thick and thin effect.
1

1. Size: Type a value in this field to set the Shape’s line size.
2 2.Up/Down arrows: Use the up and down arrows to modify the value contained in the
Thickness value field.

Smoothness
You can modify the central line smoothness of your line using this option. This parameter smoothes the initial
movement of your line. Increasing the value will result in a smoother line with less control points.
1

2

1.Size: Type a value in this field to set the smoothness of the line.
2.Up/Down arrows: Use the up and down arrows to modify the value in the
Smoothness value field.
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Drawing using Invisible Lines

There are two different ways to draw invisible lines:

•
•

Pencil Tool, on page 102
Stroke Tool, on page 102

Pencil Tool
Using the Pencil Tool, you can draw as strokes only, meaning that the line will be invisible. This can be useful to draw
tones and highlights directly on the character.
To draw invisible lines with the Pencil tool:
1.

In the Timeline or Xsheet view, select the cell where you want to draw.

2.

In the Tools toolbar, select the Pencil

tool, you can also use the default keyboard shortcut [Alt]+[Y].

3.
4.
5.

In the Top menu, select View > Show > Show Strokes
. The default keyboard shortcut is [D].
In the Tool Properties view, set the Pen Style size to “0”. You can also adjust the smoothness.
In the Camera or Drawing view, start drawing.
 If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a Message
dialog box opens.



6.

Enable the Don’t Show This Message Again check box if you don’t want the dialog box to pop up and notify
you about the Show Strokes option.
Click on the OK button to close the dialog box.

You can modify the stroke shape with the Contour Editor

tool.

Stroke Tool
The Stroke tool draws invisible lines only. You cannot add thickness to the line.
To draw invisible lines with the Stroke tool:
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1.

In the Timeline or Xsheet view, select the cell where you want to draw.

2.

In the Tools toolbar, select the Stroke

3.
4.

In the Top menu, select View > Show > Show Strokes
In the Tool Properties view, adjust the smoothness.

tool, you can also use the default keyboard shortcut [Alt]+[/].
. The default keyboard shortcut is [D].
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5.

In the Camera or Drawing view, start drawing.

 If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a Message
dialog box opens.



6.

Enable the Don’t Show This Message Again check box if you don’t want the dialog box to pop up and notify
you about the Show Strokes option.
Click on the OK button to close the dialog box.

You can modify the stroke shape with the Contour Editor

tool.

Stroke Tool Options
When you select the Stroke tool, its properties and options appears in the Tool Properties view.

Draw Stroke as Straight Lines
Enable the Draw Stroke as Straight Lines option if you want the new strokes that you will draw to be a perfect straight
line. Disable the option if you want the stroke to follow the mouse gesture.

Connect Line Ends
Enable the Connect Line Ends option if you want the start or end point of your new stroke to connect to your existing
strokes to make sure no gaps are left in your drawing.

Auto-Flatten Mode
When enabled, the Auto-Flatten mode will automatically flatten the strokes you create with the existing ones as you
draw in the Drawing or Camera view.

Smoothness
Increase the Smoothness option’s value if you want the lines that you draw to be smooth and minimize the contour
points as you draw. The higher the value is the less fidelity to the mouse gesture you will get, the less points you will
have and the smoother the line will be.
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Show Strokes as Washed-out Colours (PRO)

Sometimes, it may be difficult to see your strokes, especially if your colours are similar to the blue stroke colour. In
Animate Pro, you can display the strokes and washed-out the colours of your drawings so that the invisible lines stand
out.
To show the strokes with washed-out colours:

 In the top menu, select View > Show > Show Stroke With Colour Wash.
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Erasing Parts of a Drawing

The Eraser tool is pressure sensitive, like the Brush tool, giving you more precision when erasing parts of a drawing.
To erase with the Eraser tool:
1.

In the Timeline or Xsheet view, select the cell where you want to erase.

2.
3.

In the Tools toolbar, select the Eraser
tool, you can also use the default keyboard shortcut [Alt]+[E].
In the Camera or Drawing view, start erasing.
You can also use the select tool to select drawing objects and delete them instead of erasing.

Eraser Tool Options
When you select the Eraser tool, its properties and options appear in the Tool Properties view.

Minimum and Maximum Size
This is where you set the minimum and maximum sizes of the Eraser tool which will produce the thick and thin effect
when you erase. This works with the pressure sensitivity of a pen tablet.
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Smoothness and Contour Optimization

Smoothness
You can modify the central line smoothness of your Eraser line using this option. This parameter smoothes the initial
movement of your line. Increasing the value will result in a smoother line with less control points.

Contour Optimization
You can modify the contour line smoothness of you eraser line using this option. This parameter will smooth the
contour of your line once the line has been traced, the higher the value the less control points will compose your line.

Eraser Tips

In this drop-down menu, you can find a variety of eraser shapes from round and square ones to star shaped, select
the one you need.

Preview
The Preview field lets you see a preview of the eraser line that will be produced after you customized the different
parameters in the Tool Properties view.

1
2

D 1. The Arrow button lets you show or hide the Preview.
D 2. The Preview field displays the eraser style.

Eraser Styles
The Eraser tool uses the same Brush Styles as the Brush tool. Animate provides a variety of eraser styles and allows
you to create and save your own. It is a good idea to create and save eraser brushes with precise sizes and parameters
to draw and design.

Selecting a Brush Style

To select a brush style:
1.
2.
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Click on the arrow button of the Brush Style drop-down menu.
Select a brush style from the list.
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Adding a Brush Style

To add a Brush Style:

 Click on the Add Brush Style

button.

The new brush style will appear at the end of the Brush Styles drop-down menu list.

Renaming a Brush Style

To rename a brush style:
1.
2.
3.

Click on the arrow button of the Brush Style drop-down menu.
Select the brush style you want to rename.
Click on the Rename Brush Style

button.

The Rename Pen dialog box opens.

4.
5.

Type in a name for the selected Brush Style.
Click on the OK button.

Deleting a Brush Style

To delete a brush style:
1.
2.

Click on the arrow button of the Brush Style drop-down menu.
Select the brush style you want to delete from the Brush Style list.

3.

Click on the Delete Brush Style

button.

Eraser Blur Parameters (PRO)
Since Animate Pro lets you draw with textured lines and create feathered edges on them, you may also want to erase
with smooth edges instead of the solid vector based eraser. The Eraser Blur Parameters allow you to adjust the
smoothness of your eraser for the textured lines.
Refer to the Erasing Textured Lines (PRO) topic to learn more about using the blur eraser.
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Reshaping a Drawing Using the Contour Editor Tool

The Contour Editor Tool is powerful, it allows you to add, remove or modify points on a vector line and to control
them with Bezier handles. It is used to correct line shapes and to modify a single part of a colour zone. If a line is too
thin or has a gap in it, you can modify and correct it with the Contour Editor tool. This tool can also be used to create
elaborate shapes.
The Contour Editor displays vector points around a shape and the central vector points in a pencil line. Pulling or
pushing on these points adjusts the brush’s line thickness. Points can be selected and deleted. Each point has two
Bezier handles used to correct the curves between two points. Shapes can be modified by pulling and pushing directly
on the segment between the points. You can use it to perfect a central shape pencil line, a contour shape brush line
or even create an elaborate shape from a basic ellipse, or square.
To reshape with the Contour Editor tool:
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1.

In the Timeline or Xsheet view, select the cell in which you want to draw.

2.

In the Tools toolbar, select a Shape

3.
4.

In the Tool Properties view, click on the Ellipse mode
the pencil size to 0.
In the Drawing or Camera view, draw a circle.

5.
6.

In the Tools toolbar, select the Contour Editor
tool, you can also use the default keyboard shortcut [Alt]+[A].
In the Drawing or Camera view, click on the line to reshape it.

7.

Select one or several points by clicking on them or circling around.

tool.
button, click on the Auto Fill mode

button and set
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8.

To modify the shape, you can:
Pull on the Bezier handle. Both point’s handles will move as one.





Hold [Alt] down and pull on one of the Bezier handles. The point’s handle will move independently from the
other one.



Move the selected points to a new area.



Pull directly on the line in-between two points. No selection is necessary. Holding down the [Shift] key will
limit the contour modification to the curve between the two first points.



If an anchor point has no visible bezier, hold down the [Alt] key to get them.

Contour Editor Tool Properties
When you select the Contour Editor tool, its properties and options appear in the Tool Properties view.

Lasso and Marquee
Choose between the Lasso and the Marquee, to change the style of the Select tool.

•

Click and hold [Alt] to temporarily switch from the current mode to the other.
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Show Contour Editor Controls

Use the Show Contour Editor Controls option to show the contour editor controls. You can use these controls to scale,
reposition and rotate the selected anchor points.

Snap Options
When reshaping your drawings using the Contour Editor tool, you can enable different snap modes to help you fine
tune your shape.

Snap to Contour

The Snap to Contour option will snap the selected anchor point to any line you position it on.
To snap two shapes together:
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1.

In the Tools toolbar, select the Contour Editor

tool, you can also use the default keyboard shortcut [Alt]+[A].

2.

In the Contour Editor Tool Properties view, click on the Snap to Contour

3.

In the Camera or Drawing view, click on an anchor point you want to snap to the other shape, drag it on top of
the contour line area and release it.

button.
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Snap and Align

The Snap and Align option lets you snap the selected anchor point to any existing line while displaying temporary
rulers as a guide that you can also snap your anchor point to.
To snap and align:
1.

In the Tools toolbar, select the Contour Editor

tool, you can also use the default keyboard shortcut [Alt]+[A].

2.
3.

In the Contour Editor Tool Properties view, click on the Snap and Align
button.
In the Camera or Drawing view, click on an anchor point you want to snap, drag it until a ruler is displayed,
position it on the ruler or on the contour line and release.

Snap to Grid

The Snap to Grid will snap your selection following the currently enabled grid.
To snap to grid:

•
•

Select View > Grid > Show Grid to display the grid in the Camera or Drawing view.
Select View > Grid > Square Grid, 12 Field Grid or 16 Field Gird for your current needs.

1.

In the Tools toolbar, select the Contour Editor

tool, you can also use the default keyboard shortcut [Alt]+[A].

2.

In the Contour Editor Tool Properties view, click on the Snap to Grid

button.
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3.

In the Camera or Drawing view, click on an anchor point you want to snap following the grid, drag it to the
desired position and release.

Refer to the Show Grid topic to learn more about the Grid feature.

Smooth Selection
The Smooth Selection operation is used to smooth out selected drawing strokes and
remove extra points. Smoothing is applied to the entire stroke.
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Selecting Drawing Objects
Pivot Point

Scale
Scale

Skew

Rotate
Skew
The is used to select drawing strokes in both the Drawing view and Camera view, and apply basic transformations such
as repositioning, rotating, scaling or skewing, using the different handles of the bounding box.
To select with the Select tool:
1.

In the Timeline view, select the cell where you want to select drawing objects.

2.
3.

In the Tools toolbar, select the Select
tool, you can also use the default keyboard shortcut [Alt]+[V].
In the Camera or Drawing view, select the drawing objects.
 You can select all the drawing objects in a drawing by using the default keyboard shortcut [Ctrl]+[A] on
(Windows) or [a]+[A] on (Mac OS X).
4. To deform or reposition a selection:
 To reposition, click on the selected drawing object and drag the selection to a new area.



To rotate, rotate the selection box handle.
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To scale, pull or push either on the top, side, bottom or corner control point. Hold down [Shift] to lock the
selection’s ratio.



To skew, drag sideway or up and down the sides or top and bottom segments, between the control points.

Repositioning a Pivot Point
Some of the transformations such as rotation, scale, skew and flip, are done relative to the position of the pivot point.
You can temporarily reposition this pivot point for a transformation using the Select
To temporarily reposition the pivot point:
1.

In the Camera or Drawing view, select the drawing object you want to transform.
The pivot point will appear in the middle of your selection.

2.
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Click on the pivot point and drag it to a new position.

tool.
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This becomes the new position of the pivot point for the current transformation and will remain there until you
make a new selection.

Selection on Single or Multiple Layers

By default, when you draw a selection box in the Camera view, the Select tool will select all the drawing strokes and
Symbols in its path. If you would prefer the Select tool to only select the current drawing and not the other visible
drawings, you can enable the Select Tool Works on Single Drawing preference.
To enable the Select Tool Works on Single Drawing preference:
1.

In the top menu, select Edit > Preferences (Windows)
or Animate 2 > Preferences (Mac OS X).

2.
3.

The Preferences panel opens.
In the Camera tab, go to the Camera section and enable the Select Tool Works on Single Drawing preference.
Click on the OK button.

4.

In the Tools toolbar, select the Select

5.

In the Camera view, select your drawing.

tool. The default keyboard shortcut is [Alt]+[V].
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Select Tool Properties
When you choose the Select tool, its properties and options appear in the Tool Properties view.

Manipulators
Choose between the Select tool and the Transform tool. This is a fast way to switch between the Select tool and
Transform tool selection mode.

Lasso and Marquee
Choose between the Lasso and the Marquee, to change the style of the Select tool.

•

Click and hold [Alt] to temporarily switch from the current mode to the other.

Snap Options
You can enable different snapping modes to help you when repositioning your drawings using the Select tool.

Snap to Contour
The Snap to Contour option will snap your selection to any line you position it on.

Snap and Align
The Snap and Align option lets you snap the selected anchor point to any existing line while displaying temporary
rulers as a guide that you can also snap your anchor point to.

Snap to Grid
The Snap to Grid will snap your selection following the currently enabled grid.
Refer to the Show Grid topic to learn more about the Grid feature.
Refer to the Reshaping a Drawing Using the Contour Editor Tool topic to learn more about the Snap Options
utility.
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Permanent Selection
The Permanent Selection option is used to maintain a selection over multiple drawings.
Once this option is enabled, the selection zone made using the Select tool will remain as
you navigate through drawings from a layer and drawings from other drawing layers. This
option can be used to simultaneously delete artwork inside or outside of the selection on
several drawings when combined with the Apply To Multiple Drawings option.

Apply to All Drawings in Layer
The Apply to All Drawings in Layer option is used to perform an action on all the
drawings contained in a layer. For example, you could enable the option to paint a
section on all the drawings simultaneously. The Apply Tool to All Drawings option must
be activated before performing the action and will stay enabled only for the next
action.

Apply to All Visible Drawings
The Apply to All Visible Drawings option is used to perform an action on all
the visible drawings in the Camera view. This option is not available in the
Drawing view.

Flip Horizontal and Vertical
The Flip Horizontal and Flip Vertical operations flip the current selection Horizontally or
Vertically.
From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW and CCW
The Rotate 90 Degrees CW and Rotate 90 Degrees CCW operations rotate the current
selection 90 degrees clockwise or counter-clockwise.
From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate
90 Degrees CCW.
You can also use the default keyboard shortcuts [Ctrl]+[9] and [Ctrl]+ [7] (Windows) or
[a]+[9] and [a]+[7] (Mac OS X).
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Pencil to Brush
The Pencil to Brush operation converts the selected centreline pencil strokes
into contour strokes brush lines.
From the top menu,
select Drawing > Convert > Pencil Lines to Brush.
You can also use the default keyboard shortcut [&].

Smooth
The Smooth operation is used to smooth out selected drawing strokes and remove extra
points.
You can also access this feature through the top menu, by selecting Drawing > Optimize
> Smooth or by using the keyboard shortcut [Alt]+[Shift]+[S].

Flatten
The Flatten operation is used to merge drawing objects and brush
strokes into a single layer. If you draw new lines to fix a drawing or a
line with many brush strokes, it can be useful to flatten them all into a
single shape. By default, lines are drawn one on top of each other, if
you intend repainting the lines or modifying their shape, it will be
easier if they are flattened.
You can also access this feature through the top menu, by selecting
Drawing > Optimize > Flatten or by using the default keyboard
shortcut [Alt]+[Shift]+[F].

Store Colour Gradient
Use the Store Colour Gradient operation to record the selected gradient’s position. This reuses the stored position of
the gradient when drawing new brush lines or painting colour zones. Enable the Use Stored Colour Gradient
option in the Paint or Brush Tool Properties view to do this.
Refer to the Drawing with the Brush Tool or Painting Using the Paint Tool topics to learn how to use the Use
Stored Colour Gradient option.

Apply to Line and Colour Art
The Apply to Line and Colour Art option uses the concept of Line and Colour Art layers. Use this option to apply an
action such as selecting or resizing a drawing on both Line and Colour Art layers.
In Animate Pro, this option is available by default.
Refer to the Use Advanced Art Mode (Animate) topic to learn more about the Line Art and Colour Art concept.
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Create Colour Art from Line Art
The Create Colour Art from Line Art option can only be enabled in Advance Art mode; it uses the concept of Line and
Colour Art layers. Use this option to create invisible lines in the Colour Art based on the selected artwork in the Line
Art layer.
In Animate Pro, this option is available by default.
Refer to the Use Advanced Art Mode (Animate) topic to learn more about the Line Art and Colour Art concept.
You can configure the Colour Art from Line Art option to suit your requirements.
To configure the Create Colour Art from Line Art option:
1.

In the Select tool Tool Properties view, [Shift]+click on the Create Colour Art from Line Art

button.

The Configure Line Art to Colour Art dialog box opens.

Use rendered version of the drawing: This option will render the drawing and vectorize it to calculate the
position of the centreline that will produce the colour art stroke.
• Maximum Resolution for rendered image: This is the size of the rendered image.
• Threshold for rendered image: The value of grey processed to create the rendered vectorized arts.
• Fitting error for rendered beziers: This value represents how precise the fitting of the colour art zone in
relation to the line art will be.
• Source layer: Select the layer (Line Art, Colour Art, Underlay or Overlay) you want the colour art to be
created from.
• Destination layer: Select the layer (Line Art, Colour Art, Underlay or Overlay) you want the colour art to be
created on.
• Clear Destination Art Layer First: Enable this option if you already have artwork on the destination layer
and you want the content to be deleted before the colour art is added into it.
• Perform Line Art to Colour Art Operation Immediately: Enable this check box to perform the Create
Colour Art from Line Art command when you click on the OK button of this dialog box.
Click on OK.

•

2.

Refer to Adding Colour > Line Art and Colour Art Layers, on page 210 to learn more about the Line Art and
Colour Art concept.

Distribute to Layer
The Distribute to Layer option is used to separate the selected art strokes and send them to new drawing layers. In
the Camera view, once you have drawn your artwork, you can select the strokes you want to distribute using the
Select
tool and click on the Distribute to Layer
button, you can also select Drawing > Distribute to Layer.
It will automatically take every stroke from the drawing selection made in the Camera view and separate them into a
different layer for each. If an artwork is composed of several strokes, you must group them using Edit > Group >
Group before using the Distribute to Layer option. This option cannot be done from the Drawing or Camera view.
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Refer to Building a Character > Break Down: Distribute to Layer, on page 461 to learn more about the Distribute
to Layer option.

Width and Height
Use the Width and Height operation fields to enter specific values to resize the selected shape with precision.
3
1

4

2

1. Width: Type a width value in this field to resize the width of your selection.
2. Height: Type a height value in this field to resize the height of your selection.
3. Up/Down arrows: Use the up and down arrows to modify the value
contained in either the Width or Height value field.
4. Lock icon: Click on the lock icon to lock or unlock the ratio between the
width and height values.

Offset X and Y
Use the Offset X and Offset Y operation fields to enter specific values and precisely reposition the selected shape.
1
2

1. X: Type an offset value in this field to reposition your selection along the X-axis.
3 2. Y: Type an offset value in this field to reposition your selection along the Y-axis.
3. Up/Down arrows: Use the up and down arrows to modify the value contained in
either the X or Y value field.

Angle
Use the Angle operation fields to enter specific values and accurately rotate the selected shape.
1

1. Angle: Type a degree value in this field to rotate your selection.
2 2. Up/Down arrows: Use the up and down arrows to modify the value contained in
the Angle value field.

Adjusting the Pencil Line Thickness
Use the Adjusting the Pencil Line Thickness operation field to resize the selected centreline strokes. This operation is
not permitted on contour line shapes such as brush strokes or shape fills.
1

1. Thickness: Type a value in this field to increase or decrease the thickness of the
2 selected centreline stroke.
2. Up/Down arrows: Use the up and down arrows to modify the value contained in the
Thickness value field.

Note that when you select text with the Select tool, the Select Tool Properties will display the Text tool options
on the bottom of the view. You can also use the Text tool keyboard shortcut [Alt]+[T].

Refer to Working With Text > Formatting the Text to learn more about the Text Tool Properties.
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Drawing With Shapes

In Animate, you can use the Shape tool to draw with circles, lines and squares. You can also easily reshape a square
or circle into a much more complex drawing such as these butterfly wings.
Refer to Reshaping a Drawing Using the Contour Editor Tool topic to learn more about the Contour Editor tool.
To draw with a Shape tool:
1.

In the Timeline or Xsheet view, select the cell where you want to draw.

2.
3.

In the Tools toolbar, select a Shape
tool or the keyboard shortcuts [Alt]+[N] (Line Tool), [Alt]+[O]
(Ellipse Tool), [Alt]+[R] (Rectangle Tool).
In the Shape Tool Properties view, you can switch between the different shapes mode. Select either the Ellipse

4.

In the Camera view, click and drag your mouse to draw the shape.

or Square





5.

tool.

Hold down [Shift] to lock the rectangle or the ellipse ratio to 1:1.
Hold down [Alt] to draw the rectangle or ellipse from its centre.
Hold down [Shift] to snap the line every 15 degrees.
Hold down [Alt] to snap the starting or end point of the line to a close by stroke.

Use the Contour Editor

tool to deform your shape and create your drawing.

Refer to the Reshaping a Drawing Using the Contour Editor Tool topic to learn more about using the Contour
Editor to deform a shape.
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Shape Tool Options
When you select the Shape tool, its properties and options appear in the Tool Properties view.

Line, Rectangle and Ellipse
Click on the button corresponding to the shape you want. Click and drag your mouse to draw
the selected shape. The Shape tool creates centrelines.
Using the Ellipse or Rectangle option, press [Shift] to create a perfect round or a perfect
square and press [Alt] to create the shape from its centre.
Using the Line option, press [Shift] to create a line which snaps-to every 15 degrees and
then press [Alt] to connect the start or end point of that line to another nearby line.

Draw Behind
When the Draw Behind mode is enabled, whichever shape you draw appears behind
existing art.

Snap options
When drawing a shape, you can enable different snap modes to help you create your shape.

Snap to Contour
The Snap to Contour option snaps your shape to any line you position it on.

Snap and Align
The Snap and Align option snaps the selected anchor point to any existing line, while displaying temporary rulers as
a guide that you can also snap your anchor point to.

Snap to Grid
The Snap to Grid snaps your shape to the currently enabled grid.
Refer to the Show Grid topic to learn more about the Grid feature.
Refer to the Reshaping a Drawing Using the Contour Editor Tool topic to learn more about the Snapping options
utilities.
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Automatic Filling
Use the Automatic Filling option to automatically fill your shape with the selected colour as you draw it.
By default the Shape tool creates the contour of an empty shape that you can later fill using the Paint tool.

Refer to Adding Colour > Selecting the Current Colour of a Tool, on page 192 to learn more about selecting a
fill colour.

Create Colour Art Automatically
The Create Colour Art Automatically option, which makes use of Line and Colour Art
concepts, is only available in Advanced Art Mode. As you draw in the Line Art, corresponding
strokes are automatically created in the Colour Art.
Refer to the Use Advanced Art Mode (Animate) topic to learn more about the Line Art
and Colour Art concept.
In Animate Pro, the Create Colour Art Automatically option is available by default.

Auto-Flatten Mode
When enabled, the Auto-Flatten mode automatically flattens the created shape with the existing artwork in the
Drawing or Camera view.

Auto-Close Gap
When enabled, the Auto-Close Gap mode will automatically connect with an invisible stroke, the lines you draw close
to each other in the Camera or Drawing view.

Use Stored Colour Gradient
The Use Stored Colour Gradient option forces the Brush tool to use previously stored gradient position. This way,
every new brush line fits with the stored gradient position.
Refer to Selecting Drawing Objects to learn how to use the Store Colour Gradient option.

Keep Proportion
When the Ellipse or Square mode is enabled in the Shape tool’s Tool Properties view, the Draw Circle or
Draw Square check box appears. When enabling these check boxes, the shape produced will either be
a circle or a square. Holding down the [Shift] key as you create your shape will maintain proportion.
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Pencil Styles
Animate provides a variety of pencil styles and allows you to create and save your own. This way, you can create and
save pencils with precise sizes and parameters to draw and design. The Pencil Styles of the Pencil and Shape tools are
interconnected.

Selecting a Pen Style

To select a pen style:
1.
2.

Click on the arrow button of the Pen Style drop-down menu.
Select a pen style from the list.

Adding a Pen Style

To add a Pen Style:

 Click on the Add Pen Style

button. The new pen style will appear in the Pen Styles drop-down menu list.

Renaming a Pen Style

To rename a pen style:
1.
2.

Click on the arrow button of the Pen Style drop-down menu.
Select the pen style you want to rename.

3.

Click on the Rename Pen Style

button.

The Rename Pen dialog box opens.

4.
5.
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Type in a name for the selected pen style.
Click on the OK button.
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Deleting a Pen Style

To delete a pen style:
1.
2.

Click on the arrow button of the Pen Style drop-down menu.
Select the pen style you want to delete from the Pen Style list.

3.

Click on the Delete Pen Style

button.

Size Adjustment
Use the Size Adjustment field to set the size of the shape’s line.
1

1.Size: Type a value in this field to set the Shape’s line size.
2 2.Up/Down arrows: Use the up and down arrows to modify the value contained in the
Thickness value field.
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Drawing Using the Polyline Tool

The Polyline tool is used to draw shapes. It is a central vector type of line. To form a shape, the user needs to click to
add a point and then, without releasing the mouse, pull the handle in the desired direction before adding the next
point and repeat the operation. The Contour Editor tool can be used later to correct the shape if need be.
To draw with the Polyline tool:
1.

In the Timeline view, select the cell where you want to draw.

2.
3.

In the Tools toolbar, select the Polyline
tool, you can also use the default keyboard shortcut [Alt]+[P].
In the Camera view, click and drag your mouse to create a point and a Bezier handle to shape your line.
 Press [Alt] to pull only one handle, instead of two.
 Press [Shift] to snap the handles to 45, 90, or 180 degrees.
4. Click again into a new area and drag the mouse to create a second point and Bezier handle.

5.
6.

Repeat the previous step until your shape is completed.
Press [Ctrl] + click to release the Polyline tool from the current path or shape that it is creating. Continue to use
the tool to make multiple, independant paths or shapes.

7.

If necessary, reshape the lines using the Contour Editor

tool.

Refer to Reshaping a Drawing Using the Contour Editor Tool to learn more about the Contour Editor tool.

Polyline Tool Options
When you select the Polyline tool, its properties and options appear in the Tool Properties view.
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Draw Behind
When the Draw Behind mode is enabled, the lines you draw appear behind existing art.

Snap to Contour
The Snap to Contour option snaps your polyline point to any line you position it on.

Create Colour Art Automatically
The Create Colour Art Automatically option is only available in Advanced Art Mode because
it uses the Line and Colour Art concepts. As you draw in Line Art, this option automatically
creates the corresponding strokes in Colour Art.
Refer to the Use Advanced Art Mode (Animate) topic to learn more about the Line Art
and Colour Art concept.
In Animate Pro, the Create Colour Art Automatically option is available by default.

Pencil Styles
Animate provides a variety of pencil styles and allows you to create and save your own. This way, you can create and
save pencils with precise sizes and parameters to draw and design.

Selecting a Pen Style

To select a Pen Style:
1.
2.

Click on the arrow button of the Pen Style drop-down menu.
Select a Pen Style from the list.

Adding a Pen Style

To add a Pen Style:

 Click on the Add Pen Style

button.

The new pen style will appear at the end of the Pen Styles drop-down menu list.

127

Animate Pro 2 User Guide

Renaming a Pen Style

To rename a Pen Style:
1.
2.

Click on the arrow button of the Pen Style drop-down menu.
Select the Pen Style you want to rename.

3.

Click on the Rename Pen Style

button.

The Rename Pen dialog box opens.

4.
5.

Type in a name for the selected Pen Style.
Click on the OK button.

Deleting a Pen Style

To delete a Pen Style:
1.
2.

Click on the arrow button of the Pen Style drop-down menu.
Select the pen style you want to delete from the Pen Style list.

3.

Click on the Delete Pen Style

button.

Size Adjustment
This is where you set the size value. The Polyline tool is not pressure sensitive, it creates a centreline of constant width
with no thick and thin effect.
1
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1. Size: Type a value in this field to set the shape’s line size.
2. Up/Down arrows: Use these to modify the value contained in the Thickness value
field.
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Deforming a Drawing Using the Perspective Tool

The Perspective tool is used to deform a drawing selection and alter its perspective.
To deform a drawing with the Perspective tool:
1.

In the Tools toolbar, select the Perspective

tool, you can also use the default keyboard shortcut [Alt]+[0].

2.
3.

In the Camera or Drawing view, select the drawing you want to deform.
Click and drag the different anchor points to deform the shape.

Perspective Tool Properties
Selecting the Perspective tool, displays its properties and options in the Tool Properties view.

Lasso and Marquee
Select the desired mode between the Lasso and the Marquee, to change the selection style of the Perspective tool.

•

Click and hold [Alt] to temporarily switch from the current selected mode to the other.
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Apply to Line and Colour Art
The Apply to Line and Colour Art option can only be enabled in Advance Art mode because it uses the concept of
Line and Colour Art layers. This option is used to apply the Cutter tool’s action on both Line and Colour Art layers of
the drawing.

Flip Horizontal and Vertical
The Flip Horizontal and Flip Vertical operations flips the current selection Horizontally or
Vertically.
From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW and CCW
The Rotate 90 Degrees CW and Rotate 90 Degrees CCW operations rotate the current
selection 90 degrees clockwise or counter-clockwise.
From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate
90 Degrees CCW.
You can also use the default keyboard shortcuts [Ctrl]+[9] and [Ctrl]+[7] (Windows) or
[a]+[9] and [a]+[7] (Mac OS X).
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Cutting Drawing Parts

The Cutter tool is used to cut a drawing area to move, copy, cut or delete it.
To cut with the Cutter tool:
1.

In the Tools toolbar, select the Cutter

2.

In the Camera view, trace a selection around the part to cut away.





tool.

To delete the selected zone, press [Delete].
To move the selection, click on the selection and drag it to a new area.
Use the bounding box controls to scale, skew or rotate the cut piece.
Resize

Skew

Rotate

Cutter Tool Options
When you select the Cutter tool, its properties and options appear in the Tool Properties view.

Lasso and Marquee
Select Lasso or Marquee mode to change the selection style of the Cutter tool.

•

Click and hold [Alt] to temporarily switch from the selected mode to the other.
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Use Mouse Gesture
When using the Lasso

selection type, the Use Mouse Gesture option lets you automatically delete any extra

sections of line in your artwork by simply dragging your mouse over it.
NOTE For this operation to work, you lines can not be flattened.

Apply to Line and Colour Art
The Apply to Line and Colour Art option can only be enabled in Advance Art mode because it uses the concept of
Line and Colour Art layers. This option is used to apply the Cutter tool’s action on both Line and Colour Art layers of
the drawing.
In Animate Pro, the Apply to Line and Colour Art option is available by default.
Refer to the Use Advanced Art Mode (Animate) topic to learn more about the Line Art and Colour Art concept.
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Smoothing Lines

When drawing in a digital application, it is not like drawing on a sheet of paper, sometimes the lines you draw may
look as if they were drawn with an unsteady hand. When this occurs, you may need to correct the look of your lines.
Animate has a very powerful tool you can use to optimize your contours and reduce the number of points on the lines.
Animate provides you with the Smooth Editor

tool to perform these tasks.

To optimize your lines with the Smooth tool:
1.
2.

In the Tools toolbar, select the Smooth Editor
tool. You can also select it in the top menu under
Drawing > Tools > Smooth Editor.
In the Camera or Drawing view, move your cursor over the lines to smooth. You may need to pass over the same
line several times to remove more points and make the line smoother.

Smooth Editor Tool Options
When you select the Smooth Editor tool, its properties and options appear in the Tool Properties view.
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Brush, Marquee and Lasso Smoothing Style
The Smoothing Style options allows you to smooth a portion of your drawing either by tracing a smoothing stroke
over the zone to optimize or by selecting an area of the drawing with the Marquee or the Lasso.

Show Control Points
The Show Control Points option allows you to show or hide the Bezier points around your lines. When the Bezier points
are displayed, you can see the result of your smoothing and the number of points left on your curve. When it is turned
off, you will only see the original artwork.

Minimum Size and Maximum Size
The Minimum Size and Maximum Size option lets you control the thickness of your smoothing stroke while using the
Brush

Smoothing style.

Smoothness
The Smoothness value impacts the strength of the smoothing result. The higher the value, the more points are
removed and the smoother the curve is.

Smoothness = 2
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Colour

You can modify the colour of the control points displayed on the artwork while working with the Smooth Editor tool
by double-clicking on the Colour swatch.
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Working With Text
With the Text tool, you can type text in your project, using various fonts and texts attributes. Text objects are part of
a drawing, so you can manipulate them the same way.
This topic is divided as follows:

•
•
•
•

Creating Text, on page 136
Formatting the Text, on page 137
Resizing the Text Box, on page 139
Converting Text into Separate Objects, on page 139

Creating Text
To add text to your drawings:
1.

2.
3.

4.
5.

6.

In the Drawing Tools toolbar, select the Text
tool or use the keyboard shortcut [Alt]+[T].You can also select it
in the top menu under
Drawing > Tools > Text. The default keyboard shortcut is [Alt]+[T].
In the Timeline view, select the cell containing the drawing you want to add text to.
In the Drawing or Camera view, click on the location you want your text to begin.

You can use the Text view to select the font, font size and format the text you will type. To learn more see the
next topic Formatting the Text, on page 137.
Type in the desired text.

Click outside the text box to exit the typing mode.
If you want to create another text object, click outside the currently active text box. You can always return to



edit the text by selecting the Text
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Formatting the Text
Use the Text Tool Properties view to select the font type and other formatting options you want to apply to the text.

2

1
3

4
5
6

7

1.
2.
3.
4.
5.
6.
7.

Font Type, on page 137
Font Style, on page 137
Alignment, on page 138
Font Size, on page 138
Kerning, on page 138
Indent, on page 138
Line Spacing, on page 139
If you already wrote your text, you must first use the Text tool and select the text portion you want to format.

Font Type
Use this drop-down menu to select the desired font, from the list of fonts available in your system.
Vivaldi font

Copperplate Gothic Light

Font Style
Use these buttons to select a desired style for your text:

•

Bold

•

Italic
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Alignment
Use these buttons to align the paragraph.

Left

Centred

Right

Justified

Font Size
Type the desired size for the text in this field. You can also use the up and down arrow buttons to set the desired value.

Kerning
Use the kerning field to modify the spacing between letters and characters. You can select the Auto Kern option to
set the kerning automatically, based on the font’s predefined standard. A negative value decreases spacing between
each character creating a letter overlap and a positive value increases it.

Indent
Enter a value in the Indent field to increase or decrease the indentation on the first line of your text. A positive value
sets the first line of your paragraph farther to the right and a negative value sets it farther to the left.
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Line Spacing
Enter a value in the Line Spacing field to decrease or increase the space between each line of text.

Resizing the Text Box
You can resize the text box by selecting your text box with the Text
and moving the anchor point right or left.

tool or by using the keyboard shortcut [Alt]+[T]

Using the Select tool will distort and scale your text itself rather than changing the width and height of your text box.

Converting Text into Separate Objects
Text contained in a text field is treated as a single drawing object. You can easily separate the text so that each
character becomes an individual drawing object that you can select and modify independently.

To break a text object:
1.
2.

In the Drawing Tools toolbar, click on the Select
tool. You can also use the default keyboard shortcut
[Alt]+[V].
In the Drawing or Camera view, select the text object you want to break.

3.

Select Drawing > Convert > Break Apart Text Layers.

4.

Each character is now surrounded by its own bounding box that you can modify, they remain text objects that
you can edit.
If you want to convert your independent letter to a complete vector object that you can deform, using the
Select tool, select the letters to convert.
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5.

Select Drawing > Convert > Break Apart Text Layers to break the selection into a regular drawing object, with
no more text attributes.

Override Tool
The Override Tool feature allows you to increase productivity by rapidly switching between tools used for short tasks
and your previous tool. Most drawing tool shortcuts are accessed using the [Alt] key followed by another key, such as
the Eraser tool which is accessed by pressing [Alt]+[E]. If you are drawing with the Brush tool and need to briefly switch
to the Eraser before continuing, hold down the [E] key while you are erasing. Once done, release [E] to return to the
previous tool, in this case, the Brush. You can do the same for most drawing tools that have a shortcut composed of
[Alt] followed by another key.
Selected tool

Overriding tool
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More Drawing Tools
•
•
•
•
•
•
•
•

Arrange
Convert
Optimize
Show Grid
Group/Ungroup
Hand
Rotate View
Zoom

Arrange
Use the different Arrange options to reorder drawing objects inside a single layer in the Drawing or Camera view.

•

Bring to Front button or from the top menu,
select Drawing > Arrange > Bring to Front or the keyboard shortcut [Ctrl]+[Shift]+[Up] (Windows) or
[a]+[Shift]+[Up] (Mac OS X).
Using this option brings the selected art on top.

•

Bring Forward button or from the top menu,
select Drawing > Arrange > Bring Forward or the keyboard shortcut
[Ctrl]+[Up] (Windows) or [a]+[Up] (Mac OS X).
Using this option brings the selected art one level higher.

•

Send Backward button or from the top menu,
select Drawing > Arrange > Send Backward or the keyboard shortcut
[Ctrl]+[Down] (Windows) or [a]+[Down] (Mac OS X).
Using this option sends the selected art one level lower.

•

Send to Back button or from the top menu,
select Drawing > Arrange > Send to Back or the keyboard shortcut [Ctrl]+[Shift]+[Down] (Windows) or
[a]+[Shift]+[Down] (Mac OS X).
Using this option sends the selected art to the bottom.

Convert
Brush Strokes to Pencil Lines
The Brushes Strokes to Pencil Lines operation converts the selected contour
strokes into centreline pencil strokes. This command is only available from
the top menu.
Select Drawing > Convert > Brush Strokes to Pencil Lines.
You can also use the default keyboard shortcut [^].

Pencil Lines to Brush Strokes
The Pencil Lines to Brush Strokes operation converts the selected centreline
pencil strokes into contour strokes brush lines.
From the top menu, select Drawing > Convert > Pencil Lines to Brush
Strokes.
You can also use the default keyboard shortcut [&].
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Strokes to Pencil Lines
The Strokes to Pencil Lines operation converts the selected invisible line to a
Pencil Line.
Select Drawing > Convert > Strokes to Pencil Lines.
You can also use the default keyboard shortcut [Shift]+[F12].

Optimize
There are several advanced options to optimize your drawings:

•
•
•
•
•
•

Optimize, on page 142
Remove Extra Strokes, on page 142
Crop Brush Textures (PRO), on page 143
Reduce Drawing Texture Resolution (PRO), on page 143
Create Contour Stroke (PRO), on page 144
Remove Contour Stroke (PRO), on page 144

Optimize

The Optimize command reduces the number of layers, such as overlapping brush strokes, in the selected drawing
objects. Drawing objects will only be flattened and optimized if the selected objects will not change the appearance
of the final image when they are merged.
For example, if you have selected a number of partially transparent objects, which you layered to create an additive
colour effect, the selected transparent drawing objects will not be merged. This is because merging the transparent
drawing objects will cause them to lose the effect of the layered transparent colours.

•
•

Use the Select tool to select the drawing objects you want to optimize.
Select Drawing > Optimize > Optimize.

Remove Extra Strokes
The Remove Extra Strokes option is used to remove the invisible lines in your selection.

•
•
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Select Drawing > Optimize > Remove Extra Strokes.
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Crop Brush Textures (PRO)

Original Drawing

New Drawing

Before Cropping

After Cropping

The Crop Brush Textures option is used to crop an unnecessarily large texture bitmap that lies, but is unseen, beneath
the vector contour of a textured line. This often occurs when you cut and paste textured lines from one drawing into
another. If you cut a portion from a textured line and paste it into a different drawing, Animate pastes the entire
unseen texture bitmap from the source drawing into the new one, even if you only took a small portion of the source
drawing. Using the Crop Brush Texture command will crop away extraneous texture that does not touch the vector
area. If there are many textured lines in your scene, this will greatly reduce the file size.
In the example shown above, a textured line is cut from a drawing and pasted into a new drawing. At first glance, it
appears as if only a cropped section of the underlying texture bitmap was cut and pasted as well. However, using the
Contour Editor tool to expand the vector envelope of the textured line, it is revealed that more texture bitmap exists
beyond the cropped boundary. If you use the Crop Brush Texture command the bitmap texture is cropped to the
boundaries of the textured line’s vector contour (as evidenced in the fourth image where the vector envelope has
been pulled out to reveal empty space).
To crop the brush texture:
1.
2.

In the Timeline or Xsheet view, select the drawing you want to crop the texture for.
Select Drawing > Optimize > Crop Brush Textures.

Reduce Drawing Texture Resolution (PRO)
If you import and vectorize as texture (colour) a high resolution image, the size of your drawing can be heavy. This
option is used to reduce the size and resolution of the textures in your drawing. When you import and vectorize
drawings using the grey or colour preset styles, you don't have control on the size of the bitmap texture. This tool
allows you to reduce that bitmap texture.
To reduce the drawing texture resolution:
1.
2.

In the Timeline or Xsheet view, select the drawing you want to reduce the texture resolution for.
Select Drawing > Optimize > Reduce Drawing Texture Resolution.

3.
4.

In the dialog box, drag the slider toward the left to reduce the texture resolution.
Enable the Apply to All Drawings option if you want the modification to be applied to all the drawings in your
layer.
Click on the OK button.

5.
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Create Contour Stroke (PRO)
Before Unpainting

The Create Contour Stroke

Unpainting Without Strokes

Unpainting With Contour Strokes

option is used to add a permanent invisible line around a shape that was drawn

directly in the application. This allows you to unpaint your lines with the Paint
the lines should you need to repaint later.

tool but to maintain the shape of

This command is useful when inking and painting and using the Apply to All Drawings in Layer

option.

Remove Contour Stroke (PRO)
The Remove Contour Stroke option is used to remove any permanently invisible lines that were either created while
scanning and vectorizing drawings or manually adding contour strokes. This is useful if you want to remove the
intersection triangles created during vectorization.
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Show Grid

Use the Show Grid option to display a grid in the Drawing or Camera view.
Select View > Grid > Show Grid. You can also press the keyboard shortcut [Ctrl]+[‘] (Windows) or

•

[a]+[‘] (Mac OS X).

•

Select View > Grid > Square to display a standard square grid.

•

Select View > Grid > 12 Field Grid to display a 12 field size grid.

•

Select View > Grid > 16 Field Grid to display a 16 field size grid.

•

Select View > Grid > Underlay to display the grid behind the drawing elements.

•

Select View > Grid > Overlay to display the grid over the drawing elements.

Group/Ungroup
Use the Group option to group selected drawing objects. This can help in the selection, repositioning, re-scaling and
other transformations to be applied to multiple objects of a drawing.

•
•

Select Edit > Group > Group or Edit > Group > Ungroup.
You can also use the keyboard shortcuts [Ctrl]+[G] and [Shift]+[Ctrl]+[G] (Windows)
or [a]+[G] and [Shift]+[a]+[G] (Mac OS X).

Rotate 180
Use this option to accurately flip a drawing object in your scene by rotating it 180 degrees. Use this to produce a
mirror-image of the effect.

•

Select Drawing > Transform > Rotate 180.

Hand
Use the Hand tool to pan through the Drawing and Camera view.

•
•

In the Tools toolbar, select the Hand

tool, click in the Drawing or Camera view and drag your cursor.

You can also Hold down the keyboard shortcut [Spacebar], click in the Drawing or Camera view and move
your mouse in the direction you want to pan the view.
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Rotate View
Use the Rotate View tool to rotate the Drawing or Camera view, the same way as you would do with a real animation
disc.

•
•

Select Drawing > Tools > Rotate View.
You can also hold down the keyboard shortcut [Ctrl]+[Alt] (Windows)
or [a]+[Alt] (Mac OS X).

NOTE:
This tool can also be used in the Perspective view.

Zoom
Use the Zoom tool to zoom in and zoom out in the Camera or Drawing view.

•
•

The default keyboard shortcut is [Ctrl]+[=] (Windows) or [a]+[=] (Mac OS X) and [Ctrl]+[-] (Windows)
or [a]+[-] (Mac OS X).
When the Zoom In mode is selected, hold [Alt] as you click to zoom out.

Zoom Tool Properties
When you select the Zoom tool, its properties are displayed in the Tool Properties view.

Zoom In
Enable the Zoom In mode in the Options field to zoom in when using the Zoom tool.

Zoom Out
Enable the Zoom Out mode in the Options field to zoom out when using the Zoom tool.

Perform Zoom In
Use the Zoom In operation to perform a Zoom in the Camera or Drawing view.

•
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Perform Zoom Out
Use the Zoom Out operation to perform a Zoom out in the Camera or Drawing view.

•

The default keyboard shortcut [Ctrl]+[-] (Windows) or [a]+[-] (Mac OS X).

Reset Zoom
Use the Reset Zoom operation to restore the current zoom level to 100%.

•

You can also use the default keyboard shortcut [Shift]+[Z].

Reset View
The Reset View restores the original display by resetting pan, rotation or zoom actions.
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Traditional Animation Tools
When you animate digitally using traditional techniques, there are certain tools you require in order to work efficiently,
as you would do with an animation table, paper and pencils. These tools are described in this section:
Onion Skin
Light Table
Drawing Identification
Create Empty Drawing
Reposition All Drawings

•
•
•
•
•

Onion Skin

The Onion Skin is used to preview the previous and subsequent drawings. When designing or animating, it is useful
to be able to see your previous drawings. By default, the previous drawings will appear with a shade of red and the
next drawings will be displayed with a shade of green but you can change the display options in the Preferences panel.
Refer to the Drawing and Traditional Animation Preferences topic to learn about the Onion Skin preferences.
To use the Onion Skin feature:
1.
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Enable the Onion Skin feature:



In the Tools toolbar, click on the Show Onion Skin

button.



In the Timeline view, click on the Onion Skin



You can also use the default keyboard shortcut [Ctrl]+[Alt]+[O] (Windows) or [a]+[Alt]+[O] (Mac OS X) or
from the top menu,
select View > Onion Skin > Show Onion Skin.

icon. When enabled, the icon will turn red

.
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2.

You can select the number of previous and next drawings you want to show:
In the Timeline view, click and drag the Onion Skin blue markers to choose how many previous and next
drawings will be displayed.





Select View > Onion Skin > No Previous Drawing
The default keyboard shortcut is [~].



Select View > Onion Skin > Previous Drawing
The default keyboard shortcut is [!].



Select View > Onion Skin > Previous Two Drawings
The default keyboard shortcut is [@].



Select View > Onion Skin > Previous Three Drawings
The default keyboard shortcut is [#].



Select View > Onion Skin > No Next Drawing
The default keyboard shortcut is [Ctrl]+[‘] (Windows) or [a]+[‘] (Mac OS X).



Select View > Onion Skin > Next Drawing
The default keyboard shortcut is [Ctrl]+[1] (Windows) or [a]+[1] (Mac OS X).



Select View > Onion Skin > Next Two Drawings
The default keyboard shortcut is [Ctrl]+[2] (Windows) or [a]+[2] (Mac OS X).

Select View > Onion Skin > Next Three Drawings
The default keyboard shortcut is [Ctrl]+[3] (Windows) or [a]+[3] (Mac OS X).
The previous and next drawings will appear in both the Camera and Drawing view.


3.
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Light Table

The Light Table is used to preview the previous and subsequent active layers in washed-out colours. It is useful to be
able to see the other layers when designing, animating or cleaning up your animation.
In the Camera view, when the Light Table is activated all layers apart from the currently selected one are shown
washed-out. The display returns to the normal mode when the Select tool or a Scene Setup tool is selected.
Only the currently selected drawing is displayed by default in the Drawing view. When enabling the Light Table, the
other layers appear as a washed-out display and are used as a reference. You can not select or manipulate them.
To use the Light Table feature:
1.

Enable the Light Table feature:
In the top menu, select View > Light Table.





In the Drawing View toolbar, click on the Light Table

button.

2.

You can also use the default keyboard shortcut [Shift]+[L].
The drawings for the other layers are displayed as washed-out colours in the Camera and Drawing view.

3.

In the Timeline view, you can disable the layers you wish to hide from the Light Table.

Refer to the Drawing and Traditional Animation Preferences topic to learn about the Light Table preferences.
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Drawing Identification
In the Xsheet view, you can identify your drawings as Key, Breakdown or In-between. This helps to keep your Xsheet
well organized while animating.
To mark a drawing as Key, Breakdown or In-between:
1.

In the Xsheet view, select the cell you want to identify.

2.

In the Xsheet Tools toolbar, press on the Mark as Key Drawing

, Mark as Breakdown Drawing

or Mark as

In-between Drawing
buttons. You can also select
Drawing > Mark Drawing As > Key Drawing, Breakdown Drawing and
In-between Drawing.



If you select Mark as Key Drawing, a

icon appears in the cell.




If you select Mark as Breakdown Drawing, a
icon appears in the cell.
If you select the Mark as In-between Drawing option there is no icon is displayed in the cell, as it is used to
remove a Key or Breakdown an identified drawing to a normal in-between drawing.

Create Empty Drawing
The Create Empty Drawing command automatically creates a drawing in the selected cell of the Timeline and Xsheet
view, replacing any drawing that may already be exposed in that cell and the following ones until it meets another
drawing.
To create an Empty Drawing:
1.

In the Timeline or Xsheet view, select the cell you want to create an empty drawing in.

2.

In the Xsheet View toolbar, click on the Create Empty Drawing
button or select
Animation > Create Empty Drawing. You can also use the default keyboard shortcut [Alt]+[Shift]+[R].
The new drawing will be created in the Xsheet and Timeline views.

3.
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Reposition All Drawings

The Reposition All Drawings option is used to reposition, scale, rotate or skew all drawing strokes on every drawing
included in a layer.
To reposition all drawings:
1.
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In the Tools toolbar, select the Reposition All Drawings
your drawing in the Drawing view.

tool. This also automatically selects every stroke in
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2.

To deform or reposition a selection:
To reposition, click and drag your selection to a new area.





To rotate, rotate the selection box handle.



To scale, pull or push either on the side, top, bottom or corner control points. Hold down [Shift] to lock the
selection’s ratio.



To skew, drag the sides or top and bottom segments, between the control points.
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3.

When you release your cursor, every drawing contained in the drawing layer you repositioned, scaled, rotated or
skewed will follow the same transformation.

Basic Traditional Animation
Animate lets you animate traditionally, but work entirely digitally. Many tools and features are supplied to help you
achieve that traditional animation look easily and efficiently.

Animating

Now that you know about the existing tools, you can start your animation.
The first step to complete is the rough animation, which is the skeleton of your animation. You would usually start with
the main action. For example, to animate a walk-cycle, you will start with the torso moves and the legs. Head, arms
and clothes will be added later, during the secondary animation.
For a satisfactory animation, complete the main action before adding all of the details. If you start animating all of the
details right away, you will lose a lot of time if you have to do corrections, and your animation will often look too rigid.
To animate:
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1.

In the Preferences panel, you can set your Preferences to Use Current Frame as Drawing Name. Refer to the
Current Frame as Drawing Name topic to learn more about this preference.

2.

In the Tools toolbar, select the Brush

3.

In the Colour view, select the colour you will use to draw. It is a good idea to choose a light colour for your rough
animation to help for the following task, the Clean Up process.

4.

In the Timeline or Xsheet view, select the cell where the first drawing will appear.

tool, you can also use the default keyboard shortcut [Alt]+[B].
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5.

In the Camera view, draw the first key drawing.

6.

Make sure your first key drawing is still selected in the Xsheet view and select
Animation > Mark Drawing As > Key Drawing to identify your drawing.

7.

In the Tools toolbar, click on the Enable Onion Skin

8.

In the Timeline view, click and drag the onion skin blue markers to extend the number of previous and next
visible drawings to fit your need.

9.

In the Timeline or Xsheet view, select the cell where your next key drawing will appear.

button.

10. In the Camera view, draw your second key drawing.
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11. In the Xsheet view, identify the drawing as a key drawing.

12. In the Xsheet View, select a cell between your two key drawings.

13. In the Timeline or Xsheet view, right-click (Windows) or [Ctrl]+click (Mac OS X) and select Create Empty Drawing
or use the keyboard shortcut [Alt]+[Shift]+[R].

14. Draw your new drawing.

15. If necessary, in the Xsheet view, identify the new drawing as a Key, Breakdown or In-between drawing.

16. In the Timeline or Xsheet view, select a new cell and repeat Step 13 to Step 15 for each new drawing.

Cleaning Up

When your rough animation is ready, it is time to clean it up and ink it. The clean-up is also called tracing. It consists
of tracing solid and clean lines over the rough animation to get closed zones. This is the final paperless animation step
before the ink and paint step.
You will need to add a new drawing layer to draw your clean. This is the equivalent of adding a sheet of paper and
tracing the rough using the animation disk.
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NOTE:
If you plan on tracing your animation in the Drawing view, you will need to enable the Light Table feature in order to
display all the layers of your project.
To trace your animation in a new layer:
1.
2.

In the Timeline view toolbar, click on the Add Drawing Layer
button.
In the Timeline view, click on the lock icon of the layer containing your rough animation to prevent any
accidental changes.

3.

In the Timeline or Xsheet view, select the new layer’s cell corresponding to the first key drawing of your rough
animation.
In the Tools toolbar, select the drawing tool of your choice.
In the Colour view, select the colour you will use to trace your animation. Pick a dark bold colour such as black to
make sure it contrasts well with the light colour of your rough animation.
In the Camera view, start tracing the first key drawing.

4.
5.
6.

7.

If you have some other layers in the way, you can disable them temporarily from the Timeline view so that only
your rough animation and your clean up layer are displayed in the Camera view.

8.

In the Tools toolbar, click on the Enable Onion Skin

button and extend the Onion Skin In the Timeline view.

9. In the Timeline or Xsheet view, select the next cell corresponding to a rough drawing.
10. In the Camera view, trace your next drawing.

11. Repeat Step 9 and Step 10 for each drawing.
NOTE:
This method allows you to keep the roughs and the cleans intact. You only need to disable the rough layer to prevent
it from appearing in the scene.
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Setting the Timing
Refer to the following topics in the Layers and Timing chapter to learn how to set the timing of your animation:

•
•
•
•
•
•
•
•
•
•
•
•
•
•

Exposure, on page 268
Filling Mode, on page 268
Typing Exposure, on page 269
Holding an Exposure, on page 270
Extending a Single Exposure, on page 271
Extending an Exposure Sequence, on page 271
Dragging Cells, on page 272
Deleting Exposure, on page 276
Inserting Blank Cells, on page 276
Setting the Exposure, on page 277
Filling a Selection with a Single Exposure, on page 278
Filling a Selection with a Sequence, on page 279
Filling a Selection Randomly, on page 280
Creating Cycles, on page 281

Playing Back Your Animation
You can play back your animation in the Camera view using the Playback toolbar.
To play back your animation:
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1.
2.

Be sure you are currently using the Camera view, as this feature is not available in the Drawing view.
In the Timeline view, disable the layers you do not want to show during playback.

3.

In the Playback toolbar, click on the Loop

4.

In the Playback toolbar, click on the Play

button if you want the playback to loop.
button to start the animation.

Chapter 4: Drawing and Animating Advanced Traditional Animation (PRO)

Advanced Traditional Animation (PRO)
Animate Pro has even more animation tools. There are many useful features such as the Flipping tool, enhanced Onion
Skin, extra drawing layers, automated matte and more.
This topic is divided as follows:
Flip and Easy Flipping Toolbars (PRO), on page 159
Onion Skin Toolbar (PRO), on page 160
Shift and Trace (PRO), on page 161
More Drawing Layers (PRO), on page 165
Multiple Drawings in the Drawing View (PRO), on page 169
Preview Selected Drawings (PRO), on page 170

•
•
•
•
•
•

Flip and Easy Flipping Toolbars (PRO)
Animate Pro provides a Flip feature which allows you to rapidly flip through the drawings as one would with paper
drawings. You can flip through the Key, Breakdown or In-between drawings individually, or view a combination.
NOTE: the flipping features only work in the Drawing view.
Refer to the Drawing Identification topic above to learn about the Key, Breakdown and In-between drawings.
To flip through your drawings:
1.

In the top menu, select Window > Toolbars > Easy Flipping and Flip.

2.

In the Easy Flipping toolbar, click on the Previous
or Next
button to see the previous or next drawing of
your animation.
Enable the Loop option to loop your animation during the flip. This way, when you reach the end of your
animation, the first drawings will show up again.

3.

4.

Move the slider to the right to flip forward and to the left to flip backward through your drawings.



The more that you move the slider to the left or the right, the faster the drawings will flip.
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5.

If you marked some of your drawings as Key, Breakdown or In-between, you can flip through the markers and
avoid seeing all the in-betweens. Enable the Flip Key, Breakdown or In-between option in the Flip toolbar, to see
only one type or a combination.

Onion Skin Toolbar (PRO)

You can setup your onion skin to display only the marked drawings, in the same way that you flip through your
drawings marked as Key, Breakdown or Inbetween drawings.
NOTE that this Onion Skin feature only operates in the Drawing view.
Refer to the Drawing Identification topic to learn about the Key, Breakdown and In-between drawings.
To display the marked drawings in the onion skin:
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1.

In the top menu, select Window > Toolbars > Onion Skin.

2.

In the Tools toolbar, enable the Onion Skin

3.

In the Timeline view, pull on the blue arrows to extend the number of drawings displayed in the onion skin
preview.

4.

In the Onion Skin toolbar, enable the markers you want to see in your Onion Skin preview.

feature.
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Shift and Trace (PRO)
When animating traditionally, it is very important to stay on model. Losing the proportions or features of a character
is easy to do. The Shift and Trace feature makes it possible to temporarily move a drawing so that you can trace it on
another one. This is similar to animators working on an animation light table and using cut-out pieces of a character
to move it underneath the new drawing and trace it.
The Shift and Trace option will not modify your drawing, it will only allow it to be moved, rotated or scaled in the Shift
and Trace mode. As soon as you disable the Shift and Trace option, the repositioned drawing returns to it’s normal
state.
To shift and trace:
1.
2.

Open a Drawing view.
In the Xsheet view, select the range of drawings you need to shift and trace. This selection should include at
least the layer containing the piece you need to trace and the new drawing into which you will trace.

3.

In the Xsheet View

menu, select Drawings > Send to Drawing view.

The selected drawings are sent to the Thumbnail view which appears in the Drawing view.

The Thumbnail view is situated by default on the right side of the Camera view. You can change its
positioning via the Preferences panel. Refer to the Drawing and Traditional Animation Preferences topic to learn
how.
4.

Press on the Shift and Trace Enable

button to enable the option.

Registration holes appears at the bottom of your drawings.

5.

Select the Shift and Trace

6.

Enable the onion skin. Select View > Onion Skin > Show Onion Skin. The default keyboard shortcut is [Alt]+[O].

tool.
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7.

Enable the check box corresponding to the drawing you want to allow to be transformed temporary.

8.

Select the drawing you want to move.

9.

In the Drawing view, transform the drawing as needed, to position it inbetween you two key poses:
To reposition, click and drag the drawing to a new area.



162



To rotate from the centre peg, click on the flat peg hole and rotate.



To scale, pull or push on the triangle control.
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Hold [Alt] to show the pivot point. The pivot point is situated in the middle of your current drawing view.



To rotate from the pivot point. Hold [Alt] and rotate.



To scale from the pivot point, hold [Shift] and move your cursor.



Click and drag the pivot point to move it to a new position. Once the pivot point have been moved, you
need to hold [Alt] and move your drawing in order to show it again.
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10. Once your drawing is repositioned, select the drawing into which you want to trace.

11. Select the drawing tool of your choice.
12. In the Drawing view, trace your drawing.

13. If necessary, click on the Shift and Trace Reset

button to reset the position of the modified drawing.

14. Right-click (Windows) or [Ctrl]+click (Mac OS X) in the drawing list column and select
Remove All Drawings to close the drawing list.
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More Drawing Layers (PRO)

Animate Pro has four layers included in its drawings:

•

Overlay (PRO)

•

Line Art (PRO)

•

Colour Art (PRO)

•

Underlay (PRO)

Each layer can be used for a traditional animation task, this helps to organize your work and make things easier.
To switch between the drawing layers:
1.

In the Camera or Drawing view bottom toolbar, click on either the Overlay

,

Line Art
, Colour Art
or Underlay
buttons.
You can also use the toggle keyboard shortcuts [L] and [:].
2.

Click on the Preview
button to display all the layers together. Select Overlay and Underlay, in the Preview
button’s drop-down menu, to display all four layers.
Refer to Adding Colour > Line Art and Colour Art Layers, on page 210 to learn more about this topic.

The Line Art and Colour Art layers are also available in Animate when the Advanced Drawing Mode is enabled
via the Preferences Panel. Refer to the Use Advanced Art Mode (Animate) topic to learn more.
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Overlay (PRO)
The Overlay layer can be used for a lot of different things:

Highlights and Tones (PRO) Highlights and Tones

Annotations and Corrections (PRO)

Sketching (PRO)

You can also simply draw in the Overlay layer as it is a regular layer.

Line Art (PRO)
In traditional animation, you mainly use the Line Art layer to trace and clean up your animation. The outline is drawn
in the Line Art layer and you paint in the Colour Art layer.

Refer to Adding Colour > Line Art and Colour Art Layers, on page 210 to learn more about inking and painting
your drawings on different drawing layers.
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Colour Art (PRO)
In traditional animation, you use the Colour Art layer to paint your animation. The outline is drawn in the Line Art layer
and you paint in the Colour Art layer. You need to generate invisible lines out of your Line Art to be able to do so.

Refer to Adding Colour > Creating Strokes to Paint Your Drawings on a Separate Layer, on page 211 to learn
more about creating invisible lines in the Colour Art layer.

Underlay (PRO)

The Underlay layer can be used for several things but mainly for sketching your rough animation or generating a matte
colour when doing line testing.

Generating a Matte for Your Animation (PRO)

When you are doing rough animation, you may want to send a clip to somebody for feedback or approval before
carrying on with your work. If you have several characters in your project that are overlapping, it may be difficult to
understand what is going on as you can see though the characters. Animate Pro can generate a matte automatically
in the Underlay, or even in the Colour Art layer, and fill all the zones inside your characters making them opaque. This
process is fast and easy and allows you to send easy to understand movies.
To generate a matte:
1.

In the Tools toolbar, select the Select

2.

In the Camera or Drawing view, select the drawing you want to create a matte for. Note: you will also be able to
apply the operation to all the drawings in the layer at the same time.

tool. The default keyboard shortcut is [Alt]+[V].
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3.

In the top menu, select Drawing > Generate Auto-Matte. You can also select the option in the Camera or
Drawing view menu under Drawing > Generate Auto-Matte.
The Auto-Matte dialog box opens.

4
6
8

5
7
9

10
4.
5.

If you want to create a matte for all the drawings included in your layer, enable the Apply to All Drawings option.
Depending on how precise or rough your line is, you will need to increase or decrease the radius value. The
lower the value is, the closer to your lines’ contours the matte will be shaped and the higher the value is, the
looser the matte will be shaped.

Radius: 20
6.

Radius: 100

Radius: 300

In the Source Art drop-down menu, select the layer (Line Art, Colour Art, Underlay or Overlay) you want the
matte to be created from.
7. In the Destination Art drop-down menu, select the layer (Line Art, Colour Art, Underlay or Overlay) you want the
matte to be created on.
8. If you already have artwork on the destination layer and you want the content to be deleted before the matte is
added into it, enable the Clear Destination Art First option.
9. If you want the contour of your lines to be also copied as invisible lines in your matte drawing in case you ever
need to keep them for later, enable the Copy Stroke in Destination option.
10. Click on the OK button to validate the operation.
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Multiple Drawings in the Drawing View (PRO)
If you only want to work on a portion of an animation sequence or many drawings from different layers, you can. To
do this, select the segment needed in one or more layers in the Xsheet or Timeline view and then, use the Send to
Drawing View and Add Drawings to Drawing View options to send the selection to the Drawing view and allow you
to work only on these drawings.
To send several drawings to the Drawing View:
1.

In the Xsheet or Timeline view, select a consecutive cell range from one or several layers. In the Xsheet view,
using the [Ctrl] key (Windows) or [a] key (Mac OS X), you can click on any cell to add it on the selection, even if
it is not consecutive.

2.

In the Timeline View or Xsheet View menu, select Drawings > Send to Drawing View. In the Xsheet view, you
can also hold down the [Alt] key and click on the selection.
The drawings appear at the side of the Drawing view.

3.

If the Drawing view side panel is hidden, click on the Arrow button, located to the right side of the view.

4.

If you want to add some extra drawings to the Drawing view without having to start over, in the Xsheet view,
select the desired drawings to be added.
In the Xsheet View menu, select Drawings > Add Drawings to Drawing View. The default keyboard shortcut is
[Alt]+click.
If you want to send a new drawing selection to the Drawing view and remove the current one, select a new
range of drawings in the Timeline or Xsheet view.

5.
6.
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7.
8.
9.

In the Timeline View or Xsheet View menu, select Drawings > Send to Drawing View.
To change the size of the thumbnails displayed in the side panel, right-click (Windows) or [Ctrl]+click (Mac OS X)
in the side panel and select No Thumbnail, Small Thumbnail, Medium Thumbnail or Large Thumbnail.
To empty the drawing list accumulated in the Drawing view, right-click (Windows) or [Ctrl]+click (Mac OS X) in
the side panel and select Remove Selected Drawings or Remove All Drawings.

Preview Selected Drawings (PRO)
To check your animation ink and paint, to verify that there are no colour mistakes or to see your animation in real time,
you can use the [F] and [G] keyboard shortcuts to scroll through your drawings. You may also use the Preview option
available in the Xsheet view.
To preview drawings from the Xsheet view:
1.
2.
3.

Save your scene. In the top menu select File > Save or click on the Save
button.The default keyboard
shortcut is [Ctrl]+[S] (Windows) or [a]+[S] (Mac OS X).
In the Xsheet view, select the range of drawings or the whole column to preview.
In the Xsheet View menu, select View > Preview Selected Drawings.
The Play window opens.
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4.

In the Play window, press the Play

button to play back your drawings.

5.

Enable the Preroll option to see blank frames at the beginning and at the end of the animation sequence while
looping the playback.
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Cleaning Scanned Drawings (PRO)

As paper drawings are passed through a scanner they may pick up dirt, hairs or dust. These foreign bodies register as
part of the drawing and will appear as unwanted marks on the scanned drawing. These marks need to be cleaned.
Animate Pro provides different features to remove them quickly.
Each of the removal features are described in the following sections:

•
•
•
•

Remove Dirt (PRO), on page 171
Remove Art Outside Selection (PRO), on page 172
Remove Art Inside Selection (PRO), on page 173
Remove Hair (PRO), on page 173

Remove Dirt (PRO)

The Remove Dirt tool selects small dots and hairs on the drawing. Increasing the Remove Dirt level selects larger dots
for removal, but be careful not to lose small details like pupils and nostrils. Once the removal level is chosen, you can
apply it to either the current drawing or to the whole animation sequence.
This is a fast way to get rid of most dirt and dust.
To use the Remove Dirt tool:
1.
2.

In the Timeline or Xsheet view, select the drawing to clean.
In the top menu, select Drawing > Clean Up > Remove Dirt. The default keyboard shortcut is [Shift]+[D].
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The Remove Dirt dialog box opens.

3.
4.
5.

Increase the Remove Dirt value by moving the slider to the right. As you increase the tolerance, larger speckles
will become highlighted to indicate that they have been included in the selection.
Enable the Apply to All Drawings option if you want to apply the operation to all the drawings in the layer.
Click on the OK button.

Remove Art Outside Selection (PRO)

The Remove Art Outside Selection option is used to delete any art existing outside a selection. If you have an
accumulation of strokes (almost invisible, accidental or leftover marks) in your Colour Art, it can result in large output
files, especially if you work in high definition resolution. Simultaneously apply this operation to all of your drawings in
the layer by using the Remove Art Outside Selection On All Drawings command.

To clean dirt with the Remove Art Outside Selection:
1.
2.

In the Tools toolbar, select the Select

tool. The default keyboard shortcut is [Alt]+[V].

If you want to apply the action to your entire animation, enable the Permanent Selection
option in the Tool
Properties view.
3. In the Camera or Drawing view, draw a selection around the animation. (Make the area large enough to include
the whole animation sequence).
4. In the top menu, select Drawing > Clean up > Remove Art Outside Selection option to delete artwork outside
your selection on one single drawing.
 To apply the action to all the drawings contained in the layer, select the
Drawing > Clean up > Remove Art Outside Selection on All Drawings option from the top menu.
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Remove Art Inside Selection (PRO)

The Remove Art Inside Selection option is used to delete any art inside a selection.
We recommend that you clean your Colour Art level as well. If you have an accumulation of strokes (almost invisible,
accidental or leftover marks) in your Colour Art, it can result in large output files, especially if you work in high
definition resolutions.
You can simultaneously apply this operation to all of your drawings in the layer by using the Remove Art Inside
Selection On All Drawings command.
To clean dirt with Remove Art Inside Selection:
1.

In the Tools toolbar, select the Select

2.

If you want to apply the action to your entire animation, in the Tool Properties view, enable the Permanent
Selection

tool. The default keyboard shortcut is [Alt]+[V].

option in the Tool Properties view.

3.

In the Camera or Drawing view, draw a selection around the animation. (Make sure to make the area large
enough to include all the zones to be cleaned up on all drawings).
4. In the top menu, select Drawing > Clean up > Remove Art Inside Selection option to delete artwork inside
your selection on one single drawing.
 To apply the action on all your drawings contained in the layer, in the top menu, select
Drawing > Clean up > Remove Art Inside Selection on All Drawings option to delete artwork inside your
selection on all the drawings.

Remove Hair (PRO)

The Remove Hair command is used to remove any small strokes created in the Colour Art from very thick lines or filled
zones.
Increasing the Remove Hair level value will select larger strokes for removal from the drawing. You can also select the
Apply to All Drawings option to remove them on all drawings.
To use the Remove Hair tool:
1.
2.

In the Timeline or Xsheet view, select the drawing containing the drawing to clean.
In the top menu, select View > Show > Show Strokes to display the invisible lines. The default keyboard
shortcut is [D].
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3.

In the top menu, select Drawing > Clean Up > Remove Hair.
The Remove Hair dialog box opens.

4.
5.
6.
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Move the Hair Selection slider to the right to increase the number and length of hairs to be selected.
Enable the Apply to All Drawings option if you want to apply the operation to all the drawings in the layer.
Click on the OK button.
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Drawing and Traditional Animation Preferences
When drawing or animating traditionally in Animate, there are preferences you can set to help you work more
efficiently.
To open the Preferences panel:





Windows: Select Edit > Preferences.
Mac OS X: Select Animate > Preferences.
You can also use the default keyboard shortcut [Ctrl]+[U] (Windows) or [a]+[,] (Mac OS X).

This topic is divided as follows:

•
•
•
•
•

General, on page 175
OpenGL, on page 176
Exposure Sheet, on page 177
Drawing, on page 178
Advanced (PRO), on page 179

General

Use Advanced Art Mode (Animate)
The Use Advance Art Mode can be enabled in the Preferences panel, under the General tab. Once enabled, you need
to restart Animate in order for the preference to take effect.
Enable the Use Advanced Art Mode option to enable the Line Art / Colour Art concept in the Drawing view.
When in Advanced Art Mode, a drawing is composed of two layers, a line layer and a colour layer. The colour layer is
always placed under the line layer. These layers are accessible in the Drawing or Camera view. When you look at your
final drawing, you will not see two layers; instead you will see the final composition of the lines and colours.
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The main advantage of using the Advanced Art Mode is so you can repaint the lines easily. If your colour fills are
separated from the lines, it allows you to use the repaint tool and paint the lines without affecting the colour zones.
Also, it allows you to paint tones and highlights in line art and then add some transparency to see the Colour Art
through it.
To enable the Advance Art Mode:
1.
2.

Open the Preferences panel. You can also use the default keyboard shortcut [Ctrl]+[U] (Windows) or
[a]+[,] (Mac OS X).
In the General tab, go to the Advanced section.

3.
4.
5.

Enable the Use Advance Art Mode option.
Click on the OK button.
Restart Toon Boom Animate.

OpenGL

Real-Time Antialiasing
By default, the Real-Time Antialiasing preference is disabled. This option lets you see smooth lines as you draw. You
can change the value of the Antialiasing using the Preferences dialog box, to fit the current level used in the Camera
or Drawing view.
Refer to the Viewing the Final Lines as you Draw to learn more about the Real-Time Antialiasing, on page 85.
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Full Scene Antialiasing
By default, the Full Scene Antialiasing preference is disabled. This option lets you see smooth lines as you draw as
swell as an antialiased drawing area. You can change the value of the Full Scene Antialiasing using the Preferences
dialog box, to fit the current level used in the Camera or Drawing view.
Refer to the Viewing the Final Lines as you Draw to learn more about the Full Scene Antialiasing, on page 86.

Exposure Sheet

Current Frame as Drawing Name
The Current Frame as Drawing Name option can be enabled in the Preferences panel, under the Exposure Sheet tab.
Use this preference to automatically name the drawing corresponding to the frame position, this avoids numbering
conflicts while animating.
For example, using the default preferences, you start with the first drawing on frame 1, this drawing
is called 1. You then draw the extreme position drawing on frame 10, this drawing is called 2. Next,
the inbetween pose is drawn on frame 5, this drawing is called 3 and so on.
At the end, you have a sequence like this: 1-9-4-6-3-8-5-7-10-2.

Instead, using the Use Current Frame as Drawing Name preference, each drawing is automatically
named by its frame number and the sequence looks like: 1-2-3-4-5-6-7-8-9-10.
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Drawing
These are the preferences you can find in the Drawing tab.

Light Table
•

•

•

Light Table: Shade in Camera View: When enabled, the drawings appearing on other layers are displayed
in washed-out colours in the Camera view. When this option is disabled, the drawings appearing on other
layers are displayed using normal colours. This option is for the Camera view only.

•

Enable Onion Skin for Other Layers: When both Onion Skin and Light Table options are enabled, the
drawings appearing in the Light Table also display their previous and next onion skinned drawings. This
option is for the Drawing view only.
Onion Skin: Maximum Wash Value (0,0-1,0): The maximum washed-out value for onion skinned drawings.
Onion Skin: Minimum Wash Value (0,0-1,0): The minimum washed-out value for onion skinned drawings.
Onion Skin: Maximum Opacity (0,0-1,0): The maximum opacity value for onion skinned drawings,
(0 = transparent).
Onion Skin: Minimum Opacity (0,0-1,0): The minimum opacity value for onion skinned drawings,
(0 = transparent).
Light Table: Wash (0,0-1,0): The washed-out value for the light table display.
Light Table: Opacity (0,0-1,0): The opacity value for the light table display, (0 = transparent).

•
•
•
•
•
•
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Onion Skin Render Style:
D Normal: The onion skinned drawings is displayed in washed out colours.
D Enable Shade: The previous onion skinned drawings are displayed in washed out red shades and the
next onion skinned drawings are displayed in washed out green shades.
D Outlines Only: The onion skinned drawings are displayed as outlines only.
Light Table: Enable Shade: When enabled, the drawings appearing in the Light Table are displayed in
washed out colours in the Drawing view. When this option is disabled, the drawings appearing in the Light
Table are displayed using normal colours. This option is for the Drawing view only.
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Options
•
•
•
•

•

Grid On By Default: When opening the Drawing View, the grid displays automatically.
Select Tool is Lasso: When this option is enabled, the Select tool behaves as a lasso selector. When this
option is disabled, the Select tool behaves as a rectangle selector.
Brush Size Cursor: When this option is enabled, the brush tool displays the brush size as a circle around the
cursor.
Auto Save Pen Styles: When this option is enabled, new pens and pen styles are automatically saved.

Thumbnails View location: When sending a series of drawings to the Drawing view, the drawing list
appears in a Side panel. This preference changes the location of the Side panel in the Drawing view. By
default, the panel is displayed on the right-hand side of the Drawing view. You must restart the application
for this change to be applied.

Advanced (PRO)

These are the preferences you can find in the Advanced tab.

Advanced Options
•

Restore Current Selected Drawing On Undo: If a drawing other than the current one is being affected by
an Undo command, the system will display the affected drawing when this is enabled.
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With Animate, you can add colour to your projects and even create sets of colours for your characters. With Animate’s
colour palette concept, painting and colour styling has never been easier!
In this chapter, you will learn about the following:

•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

How to Paint, on page 182
Colours, on page 183
Colour Display Modes, on page 191
Selecting the Current Colour of a Tool, on page 192
Painting Using the Paint Tool, on page 194
Selecting a Colour in a Drawing, on page 204
Editing Gradients and Textures, on page 205
Closing Gaps Manually, on page 207
Protecting Colours, on page 209
Highlighting the Selected Colour (PRO), on page 209
Line Art and Colour Art Layers, on page 210
Underlay and Overlay Layers (PRO), on page 213
Verifying Zones are Painted, on page 214
Palettes, on page 215
Colour Model, on page 231
Preferences, on page 232
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How to Paint
Learn how to paint your drawings by following these instructions.
To paint your drawings:
1.
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2.

In the Tools toolbar, select the Paint
tool. The default keyboard shortcut is [Alt]+[K]. You can also select the
Paint tool using Drawing > Tools > Paint in the top menu.
In the Colour view, select a colour from the palette.

3.

In the Camera or Drawing view, start painting the colours on your drawing.
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Colours
Animate has some very powerful colouring features when it comes to painting. To paint your drawings you will use
different colour swatches, unlike some paint programs where you modify one swatch each time you want to paint with
a different colour.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You can
add as many swatches as you want. You can also rename them and modify existing ones.

When you modify the colour of an existing swatch it automatically updates all the zones painted with this swatch
throughout the entire project. The colour swatch has a unique ID number that associates it with the painted zones.
This way, you can change the look of your character at anytime without having to repaint it!
This topic is divided as follows:

•
•

Adding a Colour Swatch, on page 184
Deleting a Colour Swatch, on page 190
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Adding a Colour Swatch
You can use three different types of colour swatches, these are described in the following sections:

•
•
•

Solid Colour Swatch, on page 184
Gradient Colour Swatch, on page 186
Bitmap Texture Swatch, on page 188

Solid Colour Swatch

To add or modify a solid colour swatch:
1.

In the Colour view, click on the New Colour

2.

In the Colour View menu, select Colours > Edit. You can also double-click on the colour pot.

button.

The Colour Picker window opens.

3.

To set your colour:
In the colour wheel, select the desired colour.



OR



OR
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Type in the HSV or RGB values in the corresponding fields. Click on the R,G,B,H,S or V radio buttons to
change the look of the colour picking area.
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Click on the Dropper
button to select any colour on your screen. It can be from the Animate interface,
your Operating System or any other open application.

You can also click on the Multi Wheel Mode button to open the Multiwheel Colour dialog box. This displays all
the picking area styles together and also contains a picking undo list. Click on the Single Wheel Mode button to
go back to the regular Colour Picker window.

Picking Areas
Display
Options

Picking Undo List
4.

If needed, click on the Shade Scale’s swatches to modify the shade of the selected colour.

5.

If necessary, adjust the desired level of transparency with the Alpha slider, or type the value directly in the Alpha
field.

6.

If necessary, click on the Add button to add the current selected colour to the Colour Storage Library, so you can
quickly access it later.

7.

You can rename the colour swatch in the Colour Picker window or directly in the colour list by double-clicking on
its name.
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Adding Default Colour Swatch (PRO)
The New Default Colour is the colour used when you choose to vectorize images that you are scanning into your
scene. This allows you to change the basic colour of all scanned drawings. It has a unique ID number that makes it
recognizable from all the other colours in your colour palettes. This can be useful on more than just an aesthetic level
as sometimes when you go to NTSC or Pal, pure colours, such as pure black, can create problems.

To add a Default Vectorized Line colour:
1.

In the Colour View menu, select Colours > New Default Colour.
A new swatch will be added to your palette using the default colour pot colour. The new swatch created with the
New Default Colour command will be named Default. You can double-click on the swatch and change its
colour at any time.

Refer to Preferences, on page 232 to learn more about the Create New Colour Pot Using the Default Colour
preference and how to customize the default colour pot colour.

Gradient Colour Swatch

To create a gradient colour swatch:
1.
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In the Colour View, select the colour to be modified.
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2.

In the Colour View menu, select Colours > Edit. You can also double-click on the colour pot.
The Colour Picker window opens.

3.

Enable the Gradient option.

4.
5.

Select the Linear or Radial option.
Select the Gradient arrows to modify the colours.



Click between the arrows to add extra colours.



Pull down the arrows to remove them.



Move the arrows left and right to modify the gradient distance.

Refer to the Editing Gradients and Textures topic to learn how to reposition your gradient zones in your
drawings.
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Bitmap Texture Swatch

To create a texture colour:
1.

In the Colour View menu, select Colours > New Texture or click on the New Texture

2.

The Browser window opens.
Browse for a PSD or TGA bitmap file created in a third party software.

3.

Click on the Open button to create the colour swatch.

button.

Refer to the Editing Gradients and Textures topic to learn how to reposition your textured zones in your
drawings.
You can also replace a texture once it is painted. If you decide to make the character’s shirt wool instead of plaid, just
update the texture file in the swatch and the entire project updates. Any transformation previously applied to the
texture’s position in your drawings will be kept.
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To replace a texture swatch:
1.

In the Colour view, select the texture swatch you want to change the embedded bitmap texture file in.

2.

In the Colour View menu, select Colours > Edit Texture. You can also double-click on the swatch.

3.

The Browser window opens.
Browse for the new PSD or TGA bitmap file created in a third party software.

4.

Click on the Open button to update the colour swatch.
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Deleting a Colour Swatch
To delete a colour swatch:
1.

In the Colour view, select the colour swatches to delete.

2.

In the Colour View menu, select Colours > Delete. You can also click on the Delete Colour
default keyboard shortcut is [Delete].

button. The

If the colour swatch is used in a drawing, the Delete Colour dialog box opens.

3.

Click on the OK button to delete the colours or click on the Cancel button to abort the operation.
If you delete colour swatches already in use, the zones painted with them turn red so you can easily identify
them.



190

Chapter 5: Adding Colour Colour Display Modes

Colour Display Modes
Switching Between Thumbnails and List Display modes
The Colour view has two display modes:
List Mode
Swatch Mode

•
•

To toggle between the display modes:
1.

In the Colour View menu, select Colours > Swatch Mode.
Enable the option to display the swatches.
Disable the option to display the colour list.




List Mode

Swatch Mode

Displaying Colour Values (PRO)
When using Animate Pro, you can display the RGB values and names of your solid colour swatches.
Note: This option is not available when displaying the colours in Swatch mode.

To display the swatch colour values:

 In the Colour View menu, select Palettes > Display Colour Values.
The solid colour swatches’ RGB values will be displayed between the colour swatch and its name. The gradient
colour swatches will be identified as (gradient).
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Selecting the Current Colour of a Tool

While drawing and painting, you can let Animate retain the last colour you selected for each one of the following tools:

•
•
•

Brush
Paint
Pencil, Ellipse, Line, Rectangle, Polylines

The Colour view has three swatches where you can set a colour for the Brush

, Paint

and Pencil

tools.

To unlink the storage swatches:
1.

In the Colour view, if the storage swatches are linked, click on the Linking

2.

Click on the Brush

3.

In the Colour list, select the desired colour.

4.

Click on the Pencil

5.

In the Colour list, select the desired colour.

6.

Click on the Paint

7.

In the Colour list, select the desired colour.

button to unlink them.

storage swatch.

storage swatch.

storage swatch.

If you prefer not to use this behaviour and have Animate use the same colour swatches regardless of the selected tool,
you can link the three swatches together.
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To link the storage swatches:
1.

2.

In the Tools toolbar, select one of the following tool:



Brush tool




Paint tool
Pencil tools:

D

Pencil tool

D

Polyline tool

D

Line tool

D

Ellipse tool

D

Rectangle tool

In the Colour view, if the storage swatches are linked, click on the Linking

button to link them.

Each time you select a new colour for your current tool, all the storage swatches are updated.
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Painting Using the Paint Tool

The main tool you will use to paint your drawings with is the Paint
tool. The Paint tool can be used in several
different modes, these can be customized in the Tool Properties view.
The Paint tool only paints closed zones. If you have gaps in your lines, you will have to close them using either the
Brush, Pencil, Close Gap tools or the Automatic Close Gap option.
To paint with the Paint tool:
1.

In the Timeline or Xsheet view, select the cell where you want to paint.

2.

In the Tools toolbar, click on the Paint
tool. The default keyboard shortcut is [Alt]+[K]. You can also select
the Paint tool in the top menu under Drawing > Tools > Paint.
In the Colour view, select a colour.

3.

4.

In the Camera view, start painting. You can either point and click to paint a zone or trace a lasso or marquee
selection to paint several zones at once.

NOTE:
The last colour you select while using the Paint tool will be remembered the next time you select the Paint tool.

Paint Tool Properties
When you select the Paint tool, its properties and options appears in the Tools Properties view.
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Lasso and Marquee
The Lasso and Marquee options let you choose what type of selection the Paint tool will do when you will click and
drag your cursor to paint your drawings. The default selection mode is Marquee.
The Marquee option makes a rectangle selection box. Everything inside the selection will be painted according
to the painting mode you selected.
The Lasso option lets you draw a custom selection box around the zones to be painted. Everything inside the
selection will be painted according to the painting mode you selected.
Hold down the [Alt] key to switch to the opposite mode of your selection.

Painting Mode
The Paint tool has four different modes available:

Paint Mode
Paint Unpainted Mode
Repaint Mode
Unpaint Mode
You can also find these tools directly in the Drawing Tools toolbar and in the Drawing Tools menu.

Paint Mode

The Paint mode paints everything it touches, including empty and filled zones.

Paint Unpainted Mode

The Paint Unpainted mode paints only empty zones. Any line or filled zone will remain unchanged.
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Repaint Mode

The Repaint mode paints everything it touches except empty zones. Any zone that is not painted will remain intact.

Unpaint Mode

The Unpaint mode unpaints everything it touches, including empty and filled zones.

Automatic Close Gap
The Automatic Close Gap option has four modes available:

No Close Gap
Close Small Gap
Close Medium Gap
Close Large Gap
The Automatic Close Gap option is used while painting drawings with small gaps. Instead of having to close them
manually either with the Brush tool or Close Gap tool, Animate will analyze the drawing and close the gaps while you
paint according to the selected mode.

The automated gap closing should be done using the zoom function setting of your Camera or Drawing view. If your
eye does not see the gap, Animate won’t either.

196

Chapter 5: Adding Colour Painting Using the Paint Tool

Paint and Remove Texture

The Paint and Remove Texture option is used when you vectorized some images as greyscale texture style. An image
vectorized as textures is a mix of bitmap filling encapsulated in a vector based frame. Painting a textured zones with
the Paint tool will change the tint of the textured lines. Painting the textured zones using the Paint and Remove
Texture option transforms the bitmap filling into a 100% vector based zone and fills it with a solid colour.

Apply to Multiple Drawings

The Apply to Multiple Drawings option is used for hand-drawn animation fast painting. When you want to paint
several drawings in a same layer at once, such as a walk cycle, you can enable this option and make a selection in your
Camera or Drawing view. All the closed zones located within your Paint tool selection are painted with the selected
colour swatch.
You do not need to enable the Onion Skin preview to use this option. The option will stay enabled only for the next
action. If you want to use it again, you must click on the Apply to Multiple Drawings button again.
The default keyboard shortcut to use this option is: [Ctrl]+[Alt]+[A] for (Windows) or [a]+[Alt]+[A] for (Mac OS X).
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Apply to Visible Drawings

The Apply to Visible Drawings option is used to paint several drawings on separate layers on the current frame. If you
have a character broken into several layers, you can enable this option to paint all your layers at once. The operation
is only applied on the current frame.
The option will stay enabled only for the next action. If you want to use it again, you must click on the Apply to Visible
Drawings button again.
This option is only available in the Camera view and does not affect Symbols.

Respect Protected Colour
The Respect Protected Colour option is enabled by default. In your Colour view, you can protect some colour
swatches to avoid repainting or unpainting the zones linked to that swatch.
If you disable this option the Paint tool will not follow the protect colour rule and will repaint or unpaint the protected
colours on your drawings until you enable the option again.
Refer to the Protecting Colours topic to learn how to lock your colours.

Use Stored Colour Gradient

When you paint a zone with a gradient or textured colour swatch, the gradient or texture’s position is set relative to
the size of the zone your are painting. If you want the Paint tool to use a particular size and position, you must first
store your desired position and size using the Select

tool and then enable the Use Stored Colour Gradient option

in the Paint Tool Properties view.
Refer to the Storing your Favourite Gradient or Texture Settings topics to learn how to store your gradient or
texture position.
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Advanced Painting Features (PRO)
The following advanced painting features are available in Animate Pro and are described in this section:

•
•
•
•
•
•
•
•

Repaint Selection (PRO), on page 199
Repaint Selection On All Drawings (PRO), on page 200
Repaint Outside Selection (PRO), on page 200
Repaint Outside Selection On All Drawings (PRO), on page 201
Unpaint Selection (PRO), on page 201
Unpaint Selection On All Drawings (PRO), on page 202
Unpaint Outside Selection (PRO), on page 202
Unpaint Outside Selection On All Drawings (PRO), on page 203

Repaint Selection (PRO)

The Repaint Selection command is used to repaint any art inside a selection. You must first draw a selection using the
Select

tool in order for this command to be available.

To use the Repaint Selection command:



Select Drawing > Paint > Repaint Selection.

Refer to Drawing and Animating > Selecting Drawing Objects, on page 113 to learn more about selecting
drawing objects.

199

Animate Pro 2 User Guide

Repaint Selection On All Drawings (PRO)

The Repaint Selection On All Drawings command is used to repaint any art inside a selection on all the drawings
contained within the same layer. You must enable the Permanent Selection

option in the Select tool Tool

Properties view and then draw a selection in your drawing using the Select
tool in order for this command to be
available. The Permanent Selection option is used to maintain the same selection throughout the drawings of a same
layer.
To use the Repaint Selection On All Drawings command:



Select Drawing > Paint > Repaint Selection On All Drawings.

Refer to Drawing and Animating > Selecting Drawing Objects, on page 113 to learn more about selecting
drawing objects and using the Permanent Selection option.

Repaint Outside Selection (PRO)

The Repaint Outside Selection command is used to repaint any art outside a selection. If no selection has been drawn
using the Select

tool, the entire drawing will be repainted.

To use the Repaint Outside Selection command:



Select Drawing > Paint > Repaint Outside Selection.

Refer to Drawing and Animating > Selecting Drawing Objects, on page 113 to learn more about selecting
drawing objects.
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Repaint Outside Selection On All Drawings (PRO)

The Repaint Outside Selection On All Drawings command is used to repaint any art outside a selection on all the
drawings contained within the same layer. You must enable the Permanent Selection

option in the Select tool Tool

Properties view and then draw a selection in your drawing using the Select
tool in order for this command to be
available. The Permanent Selection option is used to maintain the same selection throughout the drawings of a same
layer.
To use the Repaint Outside Selection On All Drawings command:



Select Drawing > Paint > Repaint Outside Selection On All Drawings.

Refer to Drawing and Animating > Selecting Drawing Objects, on page 113 to learn more about selecting
drawing objects and using the Permanent Selection option.

Unpaint Selection (PRO)

The Unpaint Selection command is used to unpaint any art existing inside a selection. You must first draw a selection
using the Select

tool in order for this command to be available.

To use the Unpaint Selection command:



Select Drawing > Paint > Unpaint Selection.

Refer to the Drawing and Animating > Selecting Drawing Objects, on page 113 to learn more about selecting
drawing objects.
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Unpaint Selection On All Drawings (PRO)

The Unpaint Selection on All Drawings command is used to unpaint all art contained inside a selection on all the
drawings within the same layer. You must enable the Permanent Selection

option in the Select tool Tool Properties

view and then draw a selection in your drawing using the Select
tool in order for this command to be available.
The Permanent Selection option is used to maintain the same selection throughout the drawings of a same layer.
To use the Unpaint Selection On All Drawings command:



Select Drawing > Paint > Unpaint Selection On All Drawings.

Refer to Drawing and Animating > Selecting Drawing Objects, on page 113 to learn more about selecting
drawing objects and using the Permanent Selection option.

Unpaint Outside Selection (PRO)

The Unpaint Outside Selection command is used to unpaint any art existing outside a selection. If no selection has
been drawn using the Select

tool, the entire drawing will be unpainted.

To use the Unpaint Selection command:



Select Drawing > Paint > Unpaint Outside Selection.

Refer to Drawing and Animating > Selecting Drawing Objects, on page 113 to learn more about selecting
drawing objects.
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Unpaint Outside Selection On All Drawings (PRO)

The Unpaint Outside Selection on All Drawings command is used to unpaint all art outside a selection on all the
drawings within the same layer. You must enable the Permanent Selection

option in the Select tool Tool Properties

view and then draw a selection in your drawing using the Select
tool in order for this command to be available.
The Permanent Selection option is used to maintain the same selection throughout the drawings of a same layer.
To use the Unpaint Outside Selection On All Drawings command:



Select Drawing > Paint > Unpaint Outside Selection On All Drawings.

Refer to Drawing and Animating > Selecting Drawing Objects, on page 113 to learn more about selecting
drawing objects and using the Permanent Selection option.
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Selecting a Colour in a Drawing

While working in your Camera or Drawing view, you can use the Dropper

tool to pick a colour from your drawing

without going to the Colour view.
To use the Dropper tool:
1.
2.

In the Tools toolbar, select the Dropper

tool. The default keyboard shortcut is [Alt]+[I]. You can also select

the Dropper tool from Drawing > Tools > Dropper in the top menu.
In the Camera or Drawing view, click on the desired colour.
 If you are using another drawing tool such as the Paint tool, you can temporarily hold down the [I] key and
click in your drawing before releasing the key to pick your colour. Once you let go of the hot key, Animate
will go back to your previous tool.

You may also want to select the zones painted with the colour currently selected in the Colour view. This can be useful
to remove rough lines from a clean drawing.

To select the zones painted with the current colour:

204

1.

In the Colour view, select the colour you want to select the corresponding zones from.

2.

Select Drawing > Select Strokes with Current Colour. The default keyboard shortcut is [Ctrl]+[Shift]+[A] for
(Windows) or [a]+[Shift]+[A] for (Mac OS X).
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Editing Gradients and Textures

If you paint a zone with a gradient or texture colour you can use the Edit Gradient/Texture
tool to modify its
position in the zone. You can move, scale, rotate and skew. If you have to match the colour to the animation, you can
set the first texture position and copy the Edit Gradient/Texture position. When moving to the next drawing, you can
select the next texture and paste the previous position to continue the modifications.
To use Edit Gradient/Texture tool:
1.

In the Tools toolbar, select the Edit Gradient/Texture

2.

under Drawing > Tools > Edit Gradient/Texture. The default keyboard shortcut is [Shift]+[F].
Click on the Gradient or Texture zone to be modified.

Linear Gradient

tool. You can also select this tool from the top menu

Radial Gradient

If you want to modify several areas at once, hold down the [Shift] key and click in the zones to be modified.



2
1

3.

Move the edit texture’s anchor points to the desired result.
If the same modification needs to be applied to another gradient in another drawing or texture zone, you
can select the modified zone and select Edit > Copy. Select the zone to be modified in the other drawing
and select Edit > Paste.
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Storing your Favourite Gradient or Texture Settings
If you are painting a hand-drawn animation or if your want the Brush tool and Paint tool to use your gradient’s position,
angle and scale settings instead of the default ones, you can store your own settings and reuse them afterward.
To store your gradient and texture settings:
1.

In the Tools toolbar, select the Select

tool. The default keyboard shortcut is [Alt]+[V].

2.

In the Camera or Drawing view, select the Gradient or Texture zone to store.

3.

In the Tool Properties view, click on the Store Colour Gradient

button.

To use the stored gradient and texture settings:
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1.

In the Tools toolbar, select the Brush

or Paint

tool.

2.

In the Tool Properties view enable the Use Stored Colour Gradient

3.

In the Camera or drawing view, draw and paint.

button.

Chapter 5: Adding Colour Closing Gaps Manually

Closing Gaps Manually

When painting, you will notice that some of your drawing areas are not closed. To close the zone you can either draw
the missing line with the Brush or Pencil tool, but you can also close the gap with an invisible line. To do so, you will
use the Close Gap

tool.

The Close Gap tool is used to close small gaps in a drawing. The Paint tool only paints closed areas. The Close Gap
tool will create a small, invisible stroke between the two closest points to close the colour zone. You do not need to
trace directly over the gap. You can draw it a few millimetres away and the Close Gap will automatically choose the
two closest points and close the gap.
To use the Close Gap tool:
1.

In the Tools toolbar, select the Close Gap

tool. You can also select the Close Gap tool from the top menu

under Drawing > Tools > Close Gap. The default keyboard shortcut is [Alt]+[C].





2.

Enable the Auto-Flatten
option in the Tool Properties view if you want the stroke you will draw to be
flattened in your drawing instead to be on top.
You can display the invisible lines with the Show Strokes option under View > Show Strokes. The default
shortcut is [D].
If you do not display the strokes, a Message dialog box will appear.

Enabling the Don’t Show This Message Again option prevents this Message dialog box from appearing.
In the Camera or Drawing view, trace an invisible line near to the gap to be closed. The gap will automatically
close.
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Close Gaps (PRO)
When you have too many gaps in your drawings you can use the Close Gaps feature in Animate Pro.

1
2

•
•

1. Close Gaps slider: Use this slider to determine the size of the gap you want to be closed. Move the slider
to the left for smaller gaps and move it to the right for bigger gaps.
2. Apply to all drawings: Enable this option so that the Close Gaps feature is applied to all the drawings of
the selected layer.

To use the Close Gaps feature:
1.
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2.

Enable the Show Strokes option so that you can preview the result as you select the Close Gaps settings, select
View > Show Strokes or use the default keyboard shortcut [D].
Select Drawing > Clean Up > Close Gaps or use the default keyboard shortcut [Shift]+[F10].

3.

The Close Gaps dialog box opens.
Move the slider until you reach the desired result.

4.

Enable the Apply to all drawings option if need be.

5.

Click on the OK button.
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Protecting Colours
When you are finished painting some zones, you can protect the colour swatch they are associated with so the work
cannot be accidentally painted over.
To use Protect Colour:
1.

In the Colour view, select the colour to be protected.

2.

In the Colour View menu, select Colours > Protect Colour. You can also right-click (Windows) or [Ctrl]+click
(Mac OS X) on the selected colour and select Protect Colour.
A red bar will appear on the side of the colour, notifying you that it is locked.

Highlighting the Selected Colour (PRO)
The Highlight Selected Colour option is used to identify colour pots used in a drawing. For example, if you have
unnamed colours in your palette and you want to find out if a particular colour pot was used on the current model or
drawing, you can select the colour pot and use the Highlight Selected Colour option. The system will wash out all the
colours in the drawing except the selected one so that it stands out and can be identified. You can rename it
accordingly.

To use the Highlight Selected Colour option:
1.
2.

In the Colour view, select the colour you want to highlight.
In the Drawing or Camera View menu, select View > Show > Highlight Selected Colour.
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Line Art and Colour Art Layers
Animate has an option allowing you to paint the lines and the colour fills separately.

In Animate, a drawing is composed of two embedded layers:

•
•

Line Art Layer
Colour Art Layer

In Animate, this option is only available in advanced mode.
Refer to the Drawing and Animating > Line Art, Colour Art, and Preview Mode, on page 79 topic to learn more
about the Line Art and Colour Art mode and how to toggle between basic and advanced mode.

In Animate Pro, a drawing is composed of four embedded layers:

•
•
•
•

Overlay Layer
Line Art Layer
Colour Art Layer
Underlay Layer

In Animate Pro, the Line Art and Colour Art Layers are always available.
In general, you will use the Line Art and Colour Art layers. The Underlay and Overlay layers are used for advanced
purposes.

Refer to the Underlay and Overlay Layers (PRO) topic to learn more about these layers.

By default, you draw on the Line Art layer. The colour layer is always placed under the Line Art layer. These layers are
accessible in the Drawing or Camera View (using drawing tools). When you look at your final drawing in the Timeline,
Xsheet or Network view, you will not see four layers; instead you will see the final composition of the lines and colours.

+

=

You can draw and paint in all layers, but if you prefer working in a single layer, you can do everything in Line Art.
The main advantage of using the Line Art and Colour Art option is so you can repaint the lines easily. If your colour
fills are separated from the lines, it allows you to use the repaint tool and paint the lines without affecting the colour
zones. Also, it allows you to paint tones and highlights in line art and then add some transparency to see the Colour
Art through it.
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In order to paint in the Colour Art, you must first use the Create Colour Art from Line Art
option to create
colour zones in the Colour Art. You will need to use this option if you want to paint drawings that were vectorized as
greyscale texture style.
NOTE: In Animate, you must be in Advanced mode for this option to be available. In Animate Pro, this option is always
available.
To toggle between Line Art and Colour Art and enable the Preview mode:
1.
2.

3.

In the Drawing Tools toolbar, select any drawing tool.
To toggle between Line Art and Colour Art:
 In the Drawing view, right-click (Windows) or [Ctrl]+click (Mac OS X) and select
Switch to Colour Art/Switch to Line Art. The default keyboard shortcut is [L].



In the Drawing or Camera bottom toolbar, click on the Colour Art



In the Drawing or Camera bottom toolbar, click on the Line Art

button.
button.

To preview the Line and Colour Art at the same time:
In the Drawing view, right-click (Windows) or [Ctrl]+click (Mac OS X) and select Preview Line Art and
Colour Art. While using the Preview mode, you still edit one mode at a time. The default keyboard shortcut
is [Shift]+[P].





In the Drawing or Camera bottom toolbar, click on the Preview

button. To be able to see only one of

the layers at a time in the Camera view, you must enable the Current Drawing on Top option, available from
the Camera bottom toolbar drop-down menu. If this option is not enabled, you will see the final
composition of all four layers.
In order to edit both Line Art and Colour Art at the same time, you must enable the Apply to Line Art and Colour
Art

button in the Tool Properties of the tools supporting the operation.

NOTE: In Animate, you must be in Advanced mode for this option to be available. In Animate Pro, this option is always
available.

Creating Strokes to Paint Your Drawings on a Separate Layer
You can use the outline you traced on one of the embedded layers and create invisible strokes to paint your drawings
on separate layers, this provides more inking and painting flexibility.
To do so, you must use the Create Colour Art from Line Art option. You can also configure the option to create the
invisible strokes on any of the four embedded layers.
To create Colour Art zones out of the Line Art content:
1.

If you are using Animate (not Animate Pro), you must first enable the Advanced Art mode. Refer to Drawing and
Animating > Use Advanced Art Mode (Animate), on page 175.

2.

In the Tools toolbar, select the Select

tool. The default keyboard shortcut is [Alt]+[V].
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3.

In the Camera or Drawing view, select the artwork to transfer to the Colour Art.

4.

In the Drawing View toolbar, click on the Create Colour Art from Line Art
shortcut is [*].

button. The default keyboard

To Configure the Line Art to Colour Art command settings:
1.

In the Tools toolbar, select the Select

tool. The default keyboard shortcut is [Alt]+[V].

2.

In the Tool Properties view, hold down the [Shift] key and click on the Create Colour Art from Line Art
button to open the Configure Line Art to Colour Art dialog box and modify the default settings of this
command.
The Configure Line Art to Colour Art dialog box opens.
3

4
5
6
7
8

9
10

3.
4.
5.
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Use rendered version of the drawing: This option will render the drawing and vectorize it to calculate the
position of the centreline that will produce the colour art stroke.
Maximum Resolution for rendered image: This is the size of the rendered image.
Threshold for rendered image: The value of grey processed to create the rendered vectorized arts.
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6.

Fitting error for generated Beziers: This value represents how precise the fitting of the colour art zone in
relation of the line art will be.
7. Source Layer: In the Source Layer drop-down menu, select the layer (Line Art, Colour Art, Underlay or Overlay)
you want the strokes to be created from.
8. Destination Layer: In the Destination Layer drop-down menu, select the layer (Line Art, Colour Art, Underlay or
Overlay) you want the strokes to be created on.
9. Clear Destination Art Layer First: If you already have artwork on the destination layer and you want the content
to be deleted before the strokes are added into it, enable this option.
10. Perform Line Art to Colour Art Operation Immediately: Enable this check box to perform the Create Colour
Art from Line Art command when you click on the Ok button of this window.

Underlay and Overlay Layers (PRO)
In Animate Pro, you have two extra art layers available beside the Line Art and the Colour Art, the Underlay and the
Overlay layers. The Underlay is situated at the very bottom and the Overlay at the very top.
Refer to Drawing and Animating > More Drawing Layers (PRO), on page 165 to learn more about the Underlay
and Overlay layers and the Auto-Matte feature.

Underlay
The Underlay layer can be used like any other of the art layers available in the drawing, but since it is situated behind
everything else, you can use it to create a matte for a quick line-test, write notes or store your rough animation.

Overlay
The Overlay layer can be used as any other of the art layers available in the drawing, but since it is situated on top of
every other, it can be useful for writing notes about the colour model or animation or to draw the highlight and tone
shapes.

213

Animate Pro 2 User Guide

Verifying Zones are Painted
When the painting process is completed, you should verify that each zone was painted correctly.
The Backlight feature produces a silhouette effect by changing the drawing’s coloured areas into a single dark, solid
colour use this to verify the completeness of the ink and paint process. Any unpainted zones can be seen as the light
shows through the unpainted areas of the silhouetted drawing.
To use the Backlight:
This feature is only available in the Drawing View.
1.

In the top menu, select View > Backlight. The default keyboard shortcut is [Ctrl]+[Shift]+[C] (Windows) or
[a]+[Shift]+[C] (Mac OS X). You can also click on the Backlight

2.
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Verify the drawings in the Drawing view.

button available in the Drawing View toolbar.
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Palettes

In colour animation, specific colours are used to paint each particular character. In order to maintain absolute
consistency, a colour palette is created for each character, prop and effect throughout the production. These are
referred to as master palettes.
Master palettes contain a colour pot for each zone to colour with a precise RGBA colour value.
Using a master colour palette has many benefits, including:

•
•
•
•

Each character consistently retains their dedicated colours.
You cannot accidentally use a colour which is not in the master palette.
Standardization and colour consistency throughout the production
Multiple artists can use the same colour palette and produce the same results.

Animate uses palettes to hold all of the colours needed to paint your elements, allowing complete control and
consistency in your painting process.
A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette and
add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, tongue, shirt, pants,
etc.
This topic is divided as follows:

•
•
•
•
•
•
•
•
•
•
•
•

Displaying the Palette List, on page 216
Creating a Colour Palette, on page 219
Copying and Pasting Colours, on page 221
Removing a Colour Palette, on page 222
Duplicating a Colour Palette, on page 222
Cloning a Colour Palette, on page 223
Mixing the Colours, on page 224
Importing a Colour Palette, on page 226
Linking a Colour Palette (PRO), on page 227
Linking your Master Palette (PRO), on page 228
Palette Linkage Status Icons , on page 230
Ordering the Palette List, on page 230
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Displaying the Palette List
The Colour view has two modes: basic and advanced.

Basic Mode

Advanced Mode

Basic Mode
The Colour view’s basic mode only shows the Colour list. When you open Animate, you only see the colours available
in the default palette. This default palette contains six basic colour swatches and is automatically named the same as
your scene. For simple projects, you can manage with the default palette, but for movies, series or shorts it is
recommended that you create palettes for your characters. To create a palette, you have to switch to the advanced
display of the Colour view and show the Palette list.

Advanced Mode
To create palettes for your characters, you must display the Palette list. Once you display the Palette list area, a series
of new buttons appear.
To show or hide the Palette List area:
1.

In the Colour view, click on the Show/Hide Palette List View
area.

Palette Menu

•
•
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button to expand or collapse the Palette List

Palette List Window

Each palette you add in your scene will appear in the Palette list.
You can add, delete, import and order palettes in your scene using the Palette menu buttons.
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Palette File Storage
In Animate, palettes are individual *.plt files that can be copied, transferred and stored. When a palette is created,
it needs to be stored somewhere. Animate is set on Basic Palette Lists mode which saves the palette at the Scene
level.

In Animate Pro, you can switch from Basic Palette Lists mode to Advanced Palette Lists mode which will allow you to
choose the folder level you want to save your palette files to.
Refer to the Creating a Colour Palette section to learn more on how to access these options.

There are four locations where you can put Palette Library folders: Environment, Job, Scene and, Element folders.

•
•
•
•

Environment: The Palette Library folder is stored in an Environment folder contained in the Scene
folder.
Job: The Palette Library folder is stored in a Job folder contained within the Scene folder.
Scene: The Palette Library folder is stored directly in the Scene folder.
Element: The Palette Library folder is stored directly in the Drawing Element (Layer) folder.

Element Level
The Element level is very useful when there are a lot of different palettes. When a colour model drawing is created, it
is stored in its element folder. By storing the corresponding palette file with the colour model, the colourist is able to
load them both from the same location. This also creates a more organized structure.

Scene Level
A palette file can also be saved at the scene level so that all of the palettes from the scene are stored together. The
palette naming will have to be structured so that the colourist or character builders can find the correct one. Saving
the palettes at the scene level makes it very easy to backup the palettes and retrieve their location.
The scene level can also be useful for Cut-out animation. Instead of creating a colour model scene that includes all of
the characters, props, effects, and location, the colour palette or model will often be directly imported to, or created
in, the character building scene. Just as with a Cut-out character building scene, each element uses the same palette
so it would not be efficient to save the palette inside one element. Instead, it is saved at the scene level. This prevents
a palette overload because all of the models are in different scenes. It also allows each scene its own set of palettes
corresponding to its model.
When working on a cut-out animation production, it is highly recommended to work with the Scene level.
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Drawing Layer’s Palette List
Each Drawing Element (Layer) has a palette list.
Each Drawing Element can contain several characters; some may have props. To paint these, the colourist will need
the characters’ and props’ palettes. Instead of copying the required palette each time it is needed, you can simply link
it to the appropriate Drawing elements. The palette list is the connection between the Drawing element and the
different palettes.

Scene Palette List and Element Palette List
There are two types of palette lists:

•
•

Scene Palette List
Element Palette List (PRO)
Refer to the Preferences topic in this chapter to learn how to enable and disable the Element Palette List mode.

Scene Palette List
The Scene Palette List is mainly used with Cut-out animation. A cut-out character will often be divided in twenty to
thirty different drawing elements that use the character’s master palette.
The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to this list will
appear in every drawing element created in the scene. There is no need to manually load the palette in each element.
The Scene Palette List is the simplest one to use. By default, Animate is set to use only Scene Palette Lists.

Element Palette List (PRO)
In Animate Pro, you can switch to Advanced Palette Lists mode and choose to save your Palette at an element’s level.
The Element Palette List is mainly used with Traditional and Paperless animation. Unlike Cut-out animation, all columns
(drawing elements) contain different characters, props, backgrounds and effects. The Element Palette List is used
because you do not necessarily want all of the palettes for all of your elements linked in every column.
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The palette list is stored in the drawing element’s directory instead of directly in the Scene level. This ensures that the
links to the palettes appear only in the appropriate element. If you prefer to access a global palette list, link your
palettes to the Scene Palette List.

Refer to the Creating a Colour Palette topic to learn how to create an element palette using the Advanced
Palette Lists mode.

Creating a Colour Palette
You can create a palette in either basic or advanced mode:

•
•

Basic Palette Lists Mode
Advanced Palette Lists Mode (PRO)

By default, Animate is set on basic mode. For simple productions, it is recommended to use the basic mode. For more
advanced productions, it is a good idea to explore the possibilities of the advanced mode.

Basic Palette Lists Mode
To create a new palette (Basic Palette Lists mode):
1.

In the Colour View menu, select Palettes > New or click on the New Palette

2.

The Create Palette window opens.
Enter the Palette Name according to the model.

3.

Click on the OK button.

button.

The palette appears in the drawing element’s palette list.
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Advanced Palette Lists Mode (PRO)
To use this method, you first need to set your preferences to Advanced Palette Lists mode in the Preferences Panel.
To set the Advanced Palette Lists mode:
1.
2.

Select Edit > Preferences (Windows) or Animate Pro > Preferences (Mac OS X) to open the Preferences panel.
You can also use the default keyboard shortcut [Ctrl]+[U] (Windows) or [a]+[U] (Mac OS X).
In the Advanced tab, enable the Advanced Palette Lists option.

3.

Click on the OK button.

To create a new palette (Advanced Palette Lists mode):
1.

In the Timeline or Xsheet View, select the drawing that requires the palette.

2.

In the Colour View menu, select Palettes > New or click on the Create Palette

button.

The Palette Browser: Create Palette window opens.

 Palette Location: Select which location to store the palette file to.
 Element: Displays the drawing layers in your scene.
 Palette: Displays the palettes available in the currently chosen storage folder.
 Palette Name: Name the new palette.
 Palette List: Select either Scene or Element Palette List.
3.

Click on the OK button.
The palette is created.

Refer to the Palette File Storage and Drawing Layer’s Palette List topics to learn more about palette storage
location as well as scene and element palette lists.
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Renaming a Colour Palette
To rename a palette:
1.

In the Colour view, select the palette to rename.

2.
3.

In the Colour View menu, select Palettes > Rename.
In the Rename dialog box, rename the palette.

4.

Click on the OK button.

Copying and Pasting Colours
When you are creating palettes, you may want to copy colour swatches or their values and paste them in other
palettes to save time.
To copy and paste colours
1.

In the Colour view, select the colour to copy.

2.

In the Colour View menu, select Colours > Copy. The default keyboard shortcut is [Ctrl]+[C] (Windows) or
[a]+[V] (Mac OS X).
In the Palette list, select the palette in which you want to paste the colours.

3.

4.

In the Colour View menu, select Colours > Paste as New Colours. The default keyboard shortcut is
[Ctrl]+[V] (Windows) or [a]+[V] (Mac OS X).
 If you want to paste the colour values of the copied swatch over an existing colour swatch,
select Colours > Paste as Values.

Copying Colours from Another Palette (PRO)
In Animate Pro you can quickly copy a colour value from a palette in your scene to a selected colour swatch in a
different palette.
To use Copy Colour From:
1.
2.

In the Colour view, select the colour swatch you want to copy the colour into.
In the Colour View menu, select Colour > Copy Colour From, then select the palette where the colour you want
to copy is listed and finally select the colour.
The selected colour swatch will immediately change to this new colour.
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Removing a Colour Palette
You can remove palettes from your Palette list if they are not needed in your scene. The actual palette file will not be
deleted and you will be able to reimport it in your Palette list later on.
To remove a palette:
1.

2.

In the Colour view, select the palette to remove.

In the Colour View menu, select Palettes > Remove or click on the Remove Palette
button.
If the palette was in use in your scene, the zones painted with its colours will turn red.



Duplicating a Colour Palette
A duplicate palette uses the same names, colour values, but has a different ID and is independent from the original
palette. This ensures that both palettes are completely independent.
This option is used when there are similar models and you want to avoid recreating and naming all of the colours. You
can change the values and the names afterward. You can also keep some RGBA values, such as the eyes, teeth,
tongue, inside mouth, etc.
To duplicate a palette:
1.

2.

In the Colour view, select the palette to be duplicated.

In the Colour View menu, select Palettes > Duplicate.
The Palette Browser: Duplicate Palette window opens.

3.
4.

Name the palette appropriately.
Click on the OK button to create the palette.
The palette appears in the palette list.
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Cloning a Colour Palette

A character usually has only one master palette, although there are times when the characters are placed in different
lighting conditions and require a different colour shading. The night palette is a popular choice when a scene or
sequence changes from day to night. It can be difficult and time-consuming to repaint everything and creating two
independent palettes can be quite complex. As an alternative, Animate provides Clone palettes.
The clone palette is a copy of the master palette. The colours in each palette have the same properties. The colours
have the same identification number pointing to the same colour zones, but they can have different names and RGBA
values. Depending on the activated palette (night or day), the painted drawing will update. So there is no need to
repaint the animation, but to create or import a clone palette (palette style).
To clone a palette:
1.

2.

In the Colour view, select the palette to be cloned.

In the Colour View menu, select Palettes > Clone.
The Palette Browser: Clone Palette window opens.

3.
4.

Name the palette. (It is recommended to keep the suffix“-clone” in the name.)
Click on the OK button to create the palette.
The clone appears in the palette list.

In the Colour View, you can also modify the colours individually by using the Colour Picker window or all at once using
the Tint Panel window.
Refer to the Mixing the Colours topic to learn how to offset your cloned palette’s colours.
If there is more than one clone palette loaded, the system will use the one highest in the palette list.
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When you want to see through painted drawings, but still see the outlines, you can create a clone palette where
you set a lower alpha value on all of the filling colours. This trick can be handy when setting pivot points on cut-out
puppets.

Cloning a Colour Swatch (PRO)

In Animate Pro, you can copy a selected colour swatch and paste it as a clone.
To clone a colour swatch:
1.
2.
3.
4.

In the Colour view, select the colour swatch you want to clone.
In the Colour View menu, select Colours > Copy. You can also use the default keyboard shortcut
[Ctrl]+[C] (Windows) or [a]+[C] (Mac OS X).
In the Colour view, select the colour palette you want to paste the clone into, or create a new palette.
In the Colour View menu, select Colours > Paste as Clone.
The cloned colour swatch appears in the palette.

Since it produces a clone colour swatch, it is impossible to use the Paste as Clone command in the same palette as
you copied the original colour swatch from. If you try to do it, a Message dialog box will open as a reminder.

Mixing the Colours
If you want to modify a series of colour at once to blend a tint in them or offset their RGBA values, you can use the
Tint panel. The Tint panel is quite useful when creating palette styles such as night and day styles.
To mix colours:
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1.

In the palette list, select the palette to offset or blend colours in it.

2.

In the Colour View menu, select Palettes > Tint Panel.
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The Tint Offset/Blend panel opens.

3.

Select one or more colours to be modified in the colour list. You can select all your colours by pressing
[Ctrl]+[A] (Windows) or [a]+[A] (Mac OS X).

4.

Check the Preview option.
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5.

Offset, Blend or Mix the selected colours.
Click on any colour swatch to
change its colour in the Colour
Picker window.

Click on the Reset button to
reset the transformation.
Click on the Apply button to
implement the modification to
your palette.







6.
7.

Offset
Use this option to simply offset the selected colours by the adjustments made using the HSB and RGB
sliders. Use the Amount slider to adjust the degree of offset. Use the Alpha slider to adjust the opacity of
the selected colour.
Blend
Use this option to blend the selected colours with the colour swatch in the top right corner. Use the Amount
slider to adjust the degree of blend. A Blend of 100% would turn the selected colours into the same colour
as the swatch. Adjusting the HSB and RGB sliders affect the swatch colour, which in turn affects the selected
colours on the left. Use the Alpha slider to adjust the opacity of the swatch.
Mixer
Select a Base and Tint colour to form a third colour swatch. Use the slider just beneath to mix the Base and
Tint colours by different amounts. This will affect the mixed swatch whether it is selected or not. Select
either the Tint or Base swatch and use the HSB and RGB sliders to adjust its colour. This will affect the mixed
swatch colour, which in turn affects the selected colours on the left.

Click on the Apply button.
Close the Tint Offset/Blend Panel window.

Importing a Colour Palette
If you created a palette in another project and you would like to import it into your current project, you can browse
for the palette file on your computer and add it to your project. When the palette is imported in your scene, the file
is copied in the project’s directory. It is not linked to the original file.
To import a palette into your project:
1.
2.
3.
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In the Colour View menu, select Palettes > Import.
The Browser window opens.
Browse for a palette file located on your hard-drive. You will generally find the palettes in your projects’ PaletteLibrary directory.
Click on the Open button.
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The palette appears in the Palette list.

Linking a Colour Palette (PRO)
You may encounter a scene where only the colour palette created for a certain layer is visible when that layer is
selected. A good example would be a scene where there is a character on one layer and the background on another
and each has its own custom colour palette. In order to see both colour palettes, independent of what element is
selected, you must link your palette list to another palette file within the scene’s structure.
To link a colour palette:
1.

In the Colour View menu, select Palette > Link.
The Palette Browser window opens.

2.
3.

Select the level where the palette file is stored, (usually Scene or Element).
Select the Scene or Element palette List.
The palette appears in the Colour view.

See Scene Palette List and Element Palette List topic for more information.
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Linking your Master Palette (PRO)
Since Animate Pro is a stand-alone application, every scene is local to the machine. This means that all of the scene’s
data is only accessible from that particular scene. Palettes are also local to the scene: they can be shared between all
drawing layers, but not between scenes.
However, some users may want to share their palettes across a whole project. Animate Pro offers that ability.
By default, a palette is an independent file stored in your Animate Pro scene. This file can be copied, moved or
deleted.
To fully link a palette throughout an entire project, you need to create a central directory where you can copy all of
the palettes you have created. Every time you link a palette in an element, it is linked to this folder. If you modify the
palette, it will be updated throughout the whole project.
To link your master palette:
1.

In the Colour view, click on the Create Palette

2.

Save your scene by selecting File > Save from the top menu or by clicking on the Save
button. The default
keyboard shortcut is [Ctrl] +[S] (Windows) or [a]+[S] (Mac OS X).
In your operating system, create a master directory. Ideally, this should be created in your Root folder to keep it
within the project directory. You could also place it inside your Colour Model’s subdirectory.

3.

4.
5.
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button to create your master palette.

Name the folder appropriately, for example: Joe’s_master_palettes.
From your operating system, browse to your Animate scene and open the palette-library folder.
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6.

Select and copy your palette.plt file to copy it to the master palette directory.

7.
8.

Create a new Animate Pro scene or open the scene where you will link this palette.
In the Timeline or Xsheet view, select the element to link the palette to.

9.

In the Colour View menu, select Palettes > Link to External.
The Link to External Palette dialog box opens.

Files: Click on the button to browse to your master palettes folder and select the palette.plt file you want to
link.
 Palette List: Select either you want to load this palette at scene or element level.
10. Click on the OK button.



The linked palette appears in your Colour view.

If a palette is outside the scene, the External

icon appears beside the palette name.
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To link an element (such as a colour model) to the palette that is stored in the external Palette directory, you must
remove the original palette from the element’s palette list. You will then load the duplicated palette into the palette
list using the Link to External command, like you did for the other elements.

Palette Linkage Status Icons
You will also notice that when you create or link a palette, a small icon will appear on its left. These icons represent
the palette linkage status.

•

Indicates a potentially dangerous situation.
Problems may occur when trying to export or link to the palette file. For example, a palette file is stored
into the element folder and is linked to the Scene Palette list. The issue in this case is that if you decide to
delete the layer containing the palette, you will loose it from your scene.

•

Indicates that the palette is safe.
There won’t be any trouble once the scene will be exported. For example, the palette file is stored in the
scene folder and is linked to the Scene Palette List.

•

Indicates that the palette file is stored in a directory external to the scene’s structure.
The palette file is probably stored in a Master Palette directory on a hard drive external to the palettelibraries planned for the palette storage. The warning in this case is that if you move your Master Palette
directory to another location, you may loose the palette in your scene.

•

Indicates that a palette file stored in a level such as Element, Scene, Job or Environment is linked to a
Palette list that is not on the same level.
For example, a palette file is stored into the Environment folder and is linked to the Element Palette list.
The palette is shared.

Ordering the Palette List
When you are using several cloned palettes that are related to the same original palette, Animate uses the highest
palette in the list to determine the colour of the painted zones.
To reorder palettes in the Palette list:
1.

In the Colour View menu, select Palettes > Move Up or Move Down. You can also use the Up
icons.
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Colour Model

Once you have a fully painted drawing, you are able to use it as a colour model and load it in the Model view. That
drawing can be used and loaded in any of your scenes.
Once a drawing is loaded in the Model view, you can click on the colours and directly paint in your Camera or Drawing
view without having to pick the colours in the Colour view.

Loading a Colour Model
To load a colour model from your Timeline or Xsheet view:
1.

2.

In the Timeline or Xsheet view, select the desired drawing.

In the Model View menu, select Use Current Drawing. You can also click on the Use Current Drawing
button available in the Model View toolbar’s extra buttons. The model appears in the Model view.

To browse for a colour model drawing on your hard drive:
1.

In the Model View menu, select Import. You can also click on the Import Model

2.
3.

menu, select File > Import > Model.
In the Browser window, browse for any *.tvg drawing file available on your hard drive.
Click on the Open button. The model appears in the Model view.

button or from the top

NOTE: The palette needs to be loaded separately from the model. When you import a model, there is no colour
recovery message, it will simply come out red if the colours or the palette is not available.
To load the Default models:
1.
2.

In your scene’s folder, create a new folder and name it models.
On your hard drive copy the *.tvg drawing file you want to use as colour models in your scene.

3.

In the Model View menu, select Load Default Model. You can also click on the Load Default Model

button.

To load a model from the Library view:
1.
2.
3.
4.

In the Library view, click on the template containing the drawing to import in the Model view.
Right-click (Windows) or [Ctrl]+click (Mac OS X) on the template and select Open As Folder.
In the Library view’s left side, select the template’s folder.
In the Library view’s right side, select the TVG drawing to import and drag it into the Model view.

To clear a colour model:
1.

In the Model View menu, select Clear Model or use the keyboard shortcut [Delete].
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Preferences
Adjusting preferences to suit your techniques allows you to paint your drawings more efficiently.
To open the Preferences panel:





Windows: Select Edit > Preferences.
Mac OS X: Select Animate > Preferences.
You can also use the default keyboard shortcut
[Ctrl]+[U] (Windows) or [a]+[U] (Mac OS X).

In the Preferences panel, you will find the following preferences that are related to adding colours to your project.

Drawing Tab

Default Multiwheel Colour Picker
Enable this option to display the Mutliwheel Colour Picker window instead of the regular Colour Picker.

Multi-Click (or Sticky) Eye Dropper
Enable this option to keep the Colour Picker’s Dropper tool active until it is released by clicking on the Dropper icon
again.

Create New Colour Pots Using Default Colour
Set the default colour for creating a new colour swatch. Enable the option so that this default colour is used each time
you add a new colour in your palettes. This option is useful for when you create new colour pots so that a more
recognizable colour is created and not just a duplicate of the currently selected colour. Choosing a colour that is the
opposite of your intended colour palette is recommended, such as grey if your palette will be filled with bright,
primary colours.

Auto Gap Closing
The values for automatic gap closing while painting drawings are:

•
•
•
•
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0 = Disabled
1 = Small
2 = Medium
3 = Big
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General Tab

Colour Management
In the General tab of the Preference panel, you will find the following options:

•
•

•
•

Default to Element Palette Lists: When this option is enabled the new, cloned, duplicated,
imported and linked palettes will be stored in the Element Palette list instead of the Scene Palette List.
Interactive Colour Recovery: If a colour palette for your scene is deleted or cannot be found, you will be
asked if you want to recover colours from the program’s memory. If this option is unchecked, the program
recovers missing colours without displaying a dialog box for your input.

Colour Recovery: If this option is unchecked, colour recovery will not occur.
Replacement Colours: If colours are no longer available for your scene, these colours are automatically
replaced with the ones indicated by the Replacement Colour swatch. The default colour is red, as it acts as
a missing colour warning device.
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Advanced Tab (PRO)

Advanced Palette Lists
In the Advanced section, you will find the Advanced Palette Lists option. Enable this feature to switch your palette list
to advanced mode. The Advanced Palette Lists mode is used to create and store palettes in the Scene or Element
Palette List.
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When you create hand-drawn animation, it is important to know how to set and modify the timing of your drawings.
You can adjust the timing in both the Timeline and Xsheet views, depending on which technique you are used to
working with. If you are a digital animator, you will probably use the Timeline view, if you are more of a traditional
animator, you will probably work with the Xsheet view (exposure sheet). Toon Boom Animate offers you both.
In this chapter, you will learn how to work on your drawing’s exposure and length. The exposure and animation paths
for Symbols are covered in separate chapters.
This chapter covers the following topics:

•
•
•
•
•
•
•
•
•
•
•

Understanding the Timeline and Xsheet View, on page 236
Frames, on page 244
Layers, on page 247
Exposure, on page 268
Navigating Between Frames and Columns, on page 284
Managing Drawings, on page 285
Tempo Markers (PRO), on page 289
Annotation Columns (PRO), on page 290
Printing the Xsheet (PRO), on page 294
Element Manager (PRO), on page 296
Preferences, on page 297

Refer to the following topics in the Creating Animation Paths chapter to animate with motion paths (pegs) and
keyframes:

•
•
•

Animating a Layer, on page 584
Adding and Deleting Keyframes, on page 594
Stop-Motion and Motion Keyframes, on page 596

Refer to the following topics in the Libraries, Symbols and Templates chapter to change or duplicate a Symbol’s
timing:

•
•
•
•
•

Editing a Symbol, on page 389
Duplicating a Symbol, on page 390
Using Paste Special, on page 399
Expanding a Symbol, on page 403
Paste/Drag and Drop, on page 404
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Understanding the Timeline and Xsheet View
To set your animation timing, you will mostly work with the Timeline and Xsheet views. This section will help you
become familiar with these views, how they work and the differences between them.

Timeline View

The Timeline view allows you to read your timing from left to right. It represents the scene’s elements in their simplest
form.
In the Timeline view you can see your layers and their names as well as the drawing’s exposure. The drawing name is
displayed when you place your cursor above the drawing’s exposure.

In Animate, you can also see the name of the selected drawing once you display the Data view.

In Animate Pro, the name of the drawing folder to which the layer is linked is displayed in the Data view.

Refer to the Animate Pro only section of the Column Header topic to learn more about the difference between
the drawing layer name and the linked drawing folder name.
The Timeline view has three main sections:

•
•
•

Layer Section, on page 236
Timing Section, on page 237
Data View Section, on page 237

Layer Section

The Layer section is located to the left of the Timeline view. This is where you can add, delete, rename, reorder and
parent layers. Any operation you do that affects the layer globally is done in this section.
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Timing Section

The Timing section is located on the right side of the Timeline view. This is where you can increase and decrease a
drawing’s exposure, duplicate drawings, add blank cells, etc. Any operation you do that affects a drawing or its timing
is done in this section.

Data View Section

The Data View section is part of the Layer section. By default, the Data view is hidden. You need to press the Show
Data View

button to display it.

The Data view allows you create new drawings by typing a new name in the Drawing Substitution field. You can also
swap between existing drawings by sliding your cursor

to the left or right.

Refer to Animating Your Puppets > Swapping Images, on page 695 to learn more of the Drawing Substitution's
functionality.
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Xsheet View
4
5

6

7
1

8
1.
2.
3.
4.
5.
6.
7.

9
Xsheet Main Section
Functions Section
Column List Section
Xsheet View Toolbar
Column Header
Current Drawing
Current Frame

2

10

3

11

12

13

8. Frame Numbers
9. Drawing Exposure
10. Current Frame Display
11. Function Column
12. Increase/Decrease Exposure
13. Overwrite/Insert Modes
These are described later in this section.

In Animate Pro, you will also find the Xsheet View menu
access commands related to the Xsheet view.

button in the top left corner. This button allows you to

The Xsheet view lets you read your timing vertically, displays the drawing layers as columns and shows the drawing’s
name. You also see the functions and keyframes of the motion paths in the Xsheet’s function columns. The value of
each keyframe is shown in the Xsheet view, these are black squares in the Timeline view. The Xsheet view has more
details than the Timeline view, which is faster and easier to read.
Refer to the following topics in the Creating Animation Paths chapter to learn about keyframes and function columns:

•
•
•
•
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Adding and Deleting Keyframes, on page 594
Stop-Motion and Motion Keyframes, on page 596
Function Curves, on page 620
Adjusting the Velocity, on page 633
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Xsheet Main Section

The Xsheet view has three sections. By default, only the main section is visible. It displays the drawing layers, also
known as drawing columns.
When using advanced compositing and animation techniques, unconnected functions (motion paths) also appear in
the main section. Unconnected functions mean that some motion paths are not attached to any particular layer.

NOTE:
When you reconnect functions to a layer they are still visible in the main section.
Refer to Creating Animation Paths > Sharing Functions, on page 621 to learn about the unconnected functions.
Refer to the Show and Hide Layers topic to learn how to temporarily hide unconnected functions from the main
section.

Functions Section

The Functions section is used for more advanced techniques. This section displays the functions (paths) related to the
selected layer in the Timeline view.
By default, the Functions section is hidden.
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To display the Functions section:
1.

In the Xsheet view, click on the Expand button located on the right side of the main section. Click on the same
button to collapse it. You can also use the Show Column List

button in the Xsheet View toolbar.

NOTE:
If you select a drawing column in the main section of the Xsheet view, the function columns will not be displayed. You
must select the layer from the Timeline view.
Refer to the Creating Animation Paths chapter to learn more about the Functions section and function columns.

Column List Section

The Column List section allows you to show and hide columns from your Xsheet view. When you hide a layer using
your Xsheet view, it is also disabled in the Timeline view.
You can use the Column List to hide individual columns or hide an entire column type (drawing or function) from your
Xsheet view. By default, the Functions section is hidden.
To display the Column List section:
1.

In the Xsheet view, click on the Expand button located on the right side of the main section to show the
Functions section. Click on the same button to collapse it. You can also use the Show Column List
button in
the Xsheet View toolbar.

In Animate Pro, you can also go to the Xsheet View menu and select View > Show Column List.
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2.

Click on the Expand button on the right side of the Functions section to display the Column List section.

Refer to the Show and Hide Layers topic to learn to show and hide columns and layers.

Xsheet View Toolbar

The Xsheet view has its own toolbar where you can find the most common features. This toolbar is displayed by
default. If you do not see it, select Windows > Toolbars > Xsheet View. The Xsheet view must be part of your
workspace in order to display its toolbar.
Refer to Discovering the Interface > Toolbar Manager, on page 63 to learn how to organize the buttons available
in the Xsheet View toolbar.

Column Header

Each column available in the Xsheet view has a header displaying the column’s name. The
column’s name is the same as the corresponding timeline layer. If you rename one or the other,
they will both be renamed.
A quick access menu is available when you right-click (Windows) or [Ctrl]+click (Mac OS X). This
menu contains the command affecting an entire column such as renaming, changing the default
colour or deleting a column.

In Animate Pro, the Column header shows the layer’s name and the name of the drawing folder to which it is linked.
If the name of the layer is the same as the drawing folder, the drawing folder’s name will not be displayed. For
example; when you link a Timing Column to a certain Element (and thereby the Element’s folder).
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Current Drawing

A drawing selected in dark red indicates that the drawing is currently displayed in the Drawing view.
The current drawing selection is not linked to the drawing displayed in the Camera view since
drawings from each visible layer are displayed at once.

Current Frame
The darker frame appearing in the Xsheet view represents the current
frame displayed in the Camera view. It does not necessarily correspond
to the current drawing displayed in the Drawing view.

Frame Numbers
On the left side of the Xsheet view, the frame numbers are shown indicating where you are. They read vertically
instead of horizontally, as in the Timeline view.

• To go to a particular frame, you can click on the frame number.

• If you click and drag a selection downwards, you will select an entire range of frames.

Drawing Exposure
Drawing
Exposure

Drawing exposed
over 3 cells

In the drawing columns (layers), you can see your drawing names
and their exposure. You can use any alphanumeric Symbol to name
your drawing.
When a drawing is exposed over more than one cell, a vertical
black line is displayed to indicate the continuity of the exposure.
When there is no drawing in a cell, the cell will be blank.

Blank cell

Current Frame Display
At the bottom of the Xsheet view, you can see the current frame number as well as the column
containing the drawing currently displayed in the Drawing view.
Current Current
Frame Drawing
Column
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Function Column
Keyframe
Interpolation

The function columns are displayed in the Functions section of the Xsheet
view. They represent the motion and rotation you applied to your
drawing layer. Only the function columns related to the selected layer are
displayed.
A function column can also be related to an effect. Selecting your effect
layer shows you the corresponding function column in the Xsheet view.
The function columns display the position value or effect value on each
cell. If there is a keyframe on a cell, a black square is displayed.
Holding the same value for several frames displays a vertical black line.

Held Value

Refer to the Creating Animation Paths chapter to learn more about the Functions section and function columns.

Increase/Decrease Exposure
You can quickly increase or decrease the exposure of the selected cell by clicking on the up and down
arrows in the Increase/Decrease Exposure field.
Refer to the Increase/Decrease Exposure Field topic to learn more about this feature.

Overwrite/Insert Modes
The Overwrite/Insert button allows you to decide the way the values are inserted into your Xsheet.
Refer to the section Filling Mode, on page 268 to learn more about this feature.
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Frames
One of the first things to learn to do in Toon Boom Animate is how to add or delete frames in your scene.
This topic is divided as follows:

•
•

Adding Frames, on page 244
Deleting Frames, on page 245

Adding Frames
There are several ways to add frames to your scene:

•
•
•
•

Setting the Scene Length, on page 244
Extending the Timeline View, on page 244
Adding Frames Before or After a Selection, on page 244
Adding Frames to the Beginning or at the End of a Scene, on page 245

Setting the Scene Length
You can set the global scene length from the top menu.
To set the scene length:
1.

Select Scene > Scene Length.
The Set Scene Length dialog box opens.

2.
3.

In the Number of Frames field, type how many frames are needed.
Click on the OK button.

Extending the Timeline View
You can quickly extend your scene length in the Timeline view.
To extend your scene in the Timeline view:
1.

In the Timeline view, drag the scene length bracket to the right to add more frames to your scene.

Adding Frames Before or After a Selection
You can add frames anywhere in the middle of the scene. If you select a frame row in the Xsheet view, the system will
add the new frames before or after the selection, depending on your choice.
To add frames before or after selection:

244

1.

In the Xsheet view, select a frame row.

2.

Select Scene > Frame > Add Frames Before Selection or Add Frames After Selection. The default keyboard
shortcuts are [Ctrl]+[G] and [Ctrl]+[H] (Windows) or [a]+[G] and [Ctrl]+[H] (Mac OS X).
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The Add Frames dialog box opens.

3.
4.

In the Number of Frames to Add field, enter the amount of frames needed in the scene.
Click on the OK button.

To add new frames after your selection, you can also use the Add Frames

button in the Xsheet View toolbar.

Adding Frames to the Beginning or at the End of a Scene
You can add some frames to the beginning or at the end of the scene.
To add frames at start or at end:
1.

Select Scene > Frame > Add Frames at Start or Add Frames at End.
The Add Frames dialog box opens.

2.
3.

In the Number of Frames to Add field, enter the number of frames needed in the scene.
Click on the OK button.

Deleting Frames
There are three ways to delete frames from your scene:

•
•
•

Reducing the Timeline Length, on page 245
Remove Selected Frames, on page 245
Delete Selected Frame Range, on page 246

NOTE:
When you remove frames from the end of your scene, the exposed drawings and Symbols are not deleted. If you
extend your scene afterwards, these drawings and Symbols are still available.

Reducing the Timeline Length
You can quickly reduce your scene length in the Timeline view.
To reduce your scene in the Timeline view:
1.

In the Timeline view, drag the scene length bracket to the left to remove frames from your scene.

Remove Selected Frames
You can remove any selected frame, such as the last frame of your scene, by clicking on the Remove Frames button
in your Xsheet view.
To remove the selected frame:
1.

In the Xsheet view, select a frame in a given column.
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2.

In the Xsheet View toolbar, click on the Remove Frames
button. You can also select
Scene > Frame > Remove Selected Frames from the top menu.
 If you want to remove several frames, click the button repeatedly.

Delete Selected Frame Range
In the Xsheet view, you can remove any selected frame range by pressing the [Delete] key.
To delete a frame range:
1.

In the Xsheet view, select a frame range by clicking on the first frame’s number and then by dragging the
selection highlight down to the last frame to delete.

2.

Press the keyboard shortcut [Delete] to delete the selection or from the top menu, go to
Scene > Frame > Remove Selected Frames. You can also click on the Remove Frames

button.

The Warning dialog box opens.
The warning states:
You have selected a range containing all of the columns.
This could also remove the frames. Do you also want to
remove these frames?

3.

To complete the operation:
Press the Yes button to delete the selection.
Press the No button to only delete the exposure in the cell and not the frames.
Enable the Don’t Show This Message Again option to prevent the warning message from being displayed
each time you delete a frame range.
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Layers
In Toon Boom Animate there are two ways to see your layers:

•
•

As horizontal layers in the Timeline view
As vertical columns in the Xsheet view.

In Animate Pro, you can also see your layers displayed in the Network view as modules.

Whether you work in the Timeline or Xsheet view, they are the same and any modification you do to one or the other
will be applied to both.
This topic is divided as follows:

•
•
•
•
•
•
•
•
•

Layer Concepts, on page 247
Adding New Drawing Layers, on page 251
Deleting Layers, on page 255
Modifying Layers, on page 256
Duplicating Layers, on page 263
Cloning Layers, on page 263
Xsheet Thumbnails, on page 263
Changing the Colour of a Column or Layer, on page 264
Expanding and Collapsing Layers, on page 265

Layer Concepts
In order to understand what happens when you duplicate a drawing, extend an exposure, create cycles or delete a
drawing, it is important to know how a layer works.
Each layer is linked to a directory, this is the location where all of that layers' drawings are saved. This directory has
the same name as the layer. When a value or drawing name is typed in a layer’s cell, the system looks in the layer’s
directory for the corresponding drawing to display. If there is no corresponding drawing, a new one is created.
The layer’s cells are not used for storage, but are linked to the drawings contained in the layer’s directory. If you
remove a drawing from the layer exposure, it is not deleted, but is simply not displayed.
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When you create a drawing cycle, all of the repeated drawings are linked to the same original files. This means that
when you modify, repaint or correct a drawing named “1,” all drawings named “1” are updated simultaneously. In
order to modify a drawing independently from its other exposures, you must duplicate the drawing.
Refer to the Duplicating a Drawing topic to learn how to duplicate a drawing.

Layer Types
There are several types of layers that you can add in the Timeline view. Some layers are not represented the same way
in the Xsheet view.

Drawing Layer
The most common layer type is the Drawing layer. Anytime you need to create a vector drawing or import a Symbol
use a Drawing layer.
NOTE: bitmap images are contained in Bitmap layers.
In the Timeline view, the drawing layer is tagged with the Drawing

icon.

Bitmap Layer
If you import picture or bitmap images in your project, they are inserted in a Bitmap layer. If you choose to vectorize
your image when you import, the Bitmap object will be placed on a Drawing layer. This way you can have bitmap
images mixed with vector drawings on a Drawing layer.
In the Timeline view, the Bitmap layer is tagged with the Bitmap

icon.

When importing a bitmap image, you have the option of encapsulating the image in a Symbol. If you place a
non-vectorized bitmap into a Symbol, you still will not be able to mix vector drawings with it on the same layer. If you
place a vectorized bitmap in a Symbol, you must enter the Symbol to be able to mix it with vector artwork.
Refer to Gathering Content > Importing a Bitmap Image without Vectorization, on page 338 to learn how to
import images.

Camera Layer
You can only have one Camera layer at a time in your timeline. By default, there is no Camera layer when you create
a scene. You need to add a Camera layer when you want to create a camera motion.
In the Timeline view, the camera layer is tagged with the Camera

icon.

The Camera layer is not visible in the Xsheet view.
If you want to have several cameras with different settings, you can keep adding Camera layers in your Timeline view
(however, only one will ever be visible at a time as you can only have one Camera at a time in your timeline). To switch
between the camera available, select Scene > Camera > select the desired camera.
Refer to Creating Animation Paths > Animating the Camera, on page 599 to learn how to animate the camera.

Effect Layer
In Animate, to enhance the look of your scene, you can add effects layers and attach your drawings to them.
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In Animate Pro, the effects are located in the Module Library view and are added to the scene using the Network view.
Refer to Enhancing With Effects > Adding Effects in Animate Pro (PRO), on page 709 to learn how to add effects
to your project.

In the Timeline view, the Effect layer is tagged with the Effect

icon.

In the event when an effect created using Animate, is opened in Animate Pro, the Effect layer will be tagged
with the purple Effect

icon.

In the Xsheet view, you can see the Effect’s parameter columns in the Functions section when you select the Effect
layer in the Timeline view.
Refer to the Functions Section topic to learn about the Functions section and function columns.
Refer to Enhancing With Effects > Adding Effects in Animate, on page 708 or Enhancing With Effects > Adding
Effects in Animate Pro (PRO), on page 709 to learn how to add effects to your project.

Colour-Card Layer
The Colour-Card layer is used to add plain colour background to your scene. By default, your scene has no background
colour and if you render it out as a QuickTime movie or image sequence it will have a black background.
In the Timeline view, the effect layer is tagged with the Effect

icon.

The Colour-Card layer is not visible in the Xsheet view.

Group Layer
A Group layer can be used to better organize both the Timeline and Network views. You can drag and drop other
layers onto a Group layer and then collapse the Group layer to hide these other layers from view.
If you create the Group layer in the Timeline, a corresponding module will appear in the Network view. Any layers that
you hook to the Group layer will appear in Group module hooked to an Input and Output port.
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Peg Layer
A Peg layer can be described as a trajectory or motion path layer that does not contain drawings. This can be attached
to any drawing layer, cut-out puppet or other peg layers, they will all follow the trajectory you set in the Peg layer.
In the Timeline view, the Peg layer is tagged with the Peg

icon.

In the Xsheet view, you can see the Peg’s function columns in the Functions section when you select the Peg layer in
the Timeline view.
Refer to Creating Animation Paths > Differences Between Pegs and Animated Layers, on page 586 to learn more
about pegs.

Quadmap Layer
A Quadmap layer can be described as a deformation transformation layer that does not contain drawings. This can
be attached to any drawing layer, cut-out puppet or even other peg layers they will all follow the deformation you set
in the Quadmap layer.
In the Timeline view, the Quadmap layer is tagged with the Quadmap

icon.

In the Xsheet view, you can see the Quadmap’s function columns in the Functions section when you select the
Quadmap layer in the Timeline view.
Refer to Enhancing With Effects > Quadmap (PRO), on page 799 to learn more about quadmaps.

Sound Layer
You can import sound files to add dialog and sound effects to your project. The sound layer will be added to your
Timeline and Xsheet view when you import a sound file in your scene.
In the Timeline view, the Sound layer is tagged with the Sound

icon.

In the Xsheet view, the Sound layer is a dark grey colour.
Refer to the Working With Sound chapter to learn how to import and play sound.

Advanced Column Types
In the Xsheet view, you can add several advanced column types:

•
•
•

3D Path Column
Bezier Curve Column
Ease Curve Column

In Animate Pro, you can also add three more column types:

•
•
•

3D Rotation Column
Annotation Column
Expression Column

These columns are used to create particular animation paths. When you create those columns, they are not linked to
any particular drawing layer. You can create a motion path using these column and then attach several drawing or peg
layers to it.
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Refer to the following topics in the Creating Animation Paths chapter to learn more about these columns:

•
•
•
•
•
•

Layer Parameters, on page 590
Function Curves, on page 620
Creating Function Curves, on page 620
Function Drop-down Menu, on page 624
Function Types, on page 625
Expression Columns (PRO), on page 638
Refer to the Annotation Columns (PRO) section to learn about annotation columns.

Layer Content
There are two types of element that can be inserted in a drawing layer’s cell:

•
•

Vector drawings
Symbols

A layer can contain the two different elements, but only in different cells. You cannot put two Symbols or a drawing
and a Symbol into the same cell.

Symbol Drawing
If you want to mix bitmap images in your Drawing layers, you must first import your Bitmap image as a Symbol or turn
it into a Symbol and insert it in your Drawing layer by dragging the Symbol cell there through the Timeline.
Refer to Libraries, Symbols and Templates > What is a Symbol?, on page 378 to learn more about Symbols.

Adding New Drawing Layers
In this section you will learn the different ways to add a drawing layer to your project. By default, when you create a
new scene there is one Drawing layer included in your Timeline view.
This topic is divided as follows:

•
•
•

Adding Drawing Layers in the Timeline View, on page 251
Adding a Drawing Layer From the Top Menu, on page 252
Adding Drawing Columns in the Xsheet View, on page 252

Adding Drawing Layers in the Timeline View
You can add a new layer in the Timeline view in several different ways:

•
•
•

Using the Layer toolbar
Using the Add Layers dialog box
In Animate Pro, you can simply go to the Timeline view menu and select Insert > Drawing.

To add a Drawing layer using the Timeline’s Layer toolbar:
1.

In the Timeline’s Layer toolbar, click on the Add Layers

button. The default keyboard shortcut is

[Ctrl]+[R] (Windows) or [a]+[R] (Mac OS X).

251

Animate Pro 2 User Guide
2.

In the drop-down menu, select the Drawing option.

A new layer appears in the Timeline and Xsheet view.
You can also click on the Add Drawing Layer
button in the Timeline’s Layer toolbar. The default keyboard
shortcut is [Ctrl]+[R] (Windows) or [a]+[R] (Mac OS X).
To add Drawing layers using the Add Layers dialog box:
1.

In the Timeline view’s layer section, right-click (Windows) or [Ctrl]+click (Mac OS X) and select
Insert > Add Layer(s).
The Add Layers dialog box opens.

2.
3.
4.

In the Type drop-down menu, select the Drawing option.
In the Number field, use the up and down arrows or type the number of layers you want to add at once.
In the Name field, type the name of the layer you want to add. If you are adding more than one layer at once, all
of the layers use that name with a numerical suffix added.
5. To complete the operation:
 Click on the OK button to add your new layers and close the dialog box.
 Click on the Apply button to add your new layers and keep the dialog box open to add another layer.
 Click on the Close button to cancel the operation.

Adding a Drawing Layer From the Top Menu
You can add a new layer from the top menu.
To add a new layer from the top menu:

 In the top menu, select Insert > Drawing.
A new layer appears in the Timeline and Xsheet view.

Adding Drawing Columns in the Xsheet View
To add a Drawing column:
1.

In the Xsheet view, right-click (Windows) or [Ctrl]+click (Mac OS X) and select Columns > Add Column or you
can click on the Add Columns
[Shift]+[C].

button in the Xsheet View toolbar. The default keyboard shortcut is

To quickly add a Drawing column, use the default keyboard shortcut [Ctrl]+[R] (Windows) or [a]+[R] (Mac OS X).
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The Add Columns dialog box opens.

2.
3.

In the Column Name field, name your column accordingly.
In the Column Type field, select Drawing.

Refer to the Layer Types topic to know more about the different column types available.
4.

To complete the operation:
Click on the OK button to add your new column and close the dialog box.
Click on the Apply button to add your new column and keep the dialog box open to add another column.
Click on the Close button to cancel the operation.





In Animate Pro, you can use the basic Add Column dialog box or the advanced Add Column dialog box, with more
file format and field size options, to insert the column.
To create a column in Animate Pro using the advanced Add Column dialog box:
1.
2.

Select Edit > Preferences (Windows) or Animate Pro > Preferences (Mac OS X) and go to the Advanced tab.
In the Advanced Options section, enable the Advanced Element Mode to access the advanced Add Column
dialog box.

3.

Click on the OK button.

4.

In the Xsheet View menu, select Columns > Add Column or click on the Add Column
Xsheet View toolbar. The default keyboard shortcut is [Shift]+[C].

button from the
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The Add Column dialog box opens.
5
6
7
8

9
10
5.
6.
7.

In the Name field, type the new column’s name.
In the Type drop-down menu, select the Drawing type.
In the Element section select if you either want to create a new column or link the new column to an existing
one:
 Create New Element: Select this option if you want your column to be an independent column with its own
drawing folder.
 Use Existing Element: Select this option if you want your column to be using drawings from an existing
column.
Both columns will be attached to the same set of drawings but their timing will be independent one from
the other. If you modify one of the drawings, it will be modified in both columns. This is the same principle
as the Clone column.
8. If you select the Create New Element option:
 Disable the Vector option if you want your layer to contain bitmap images or enable it if you want the layer
to contain vector drawings. Most of the time, the Vector option will be enabled.
 If you disabled the Vector option, from the Bitmap Format drop-down list, select which type of bitmap
image you wish to insert in the column.
 In the Field Chart field, when importing traditional animation, indicate the size of paper on which the
animation or background was drawn. If you are not using perforated animation paper, leave the 12 field
default value as is.
9. If you selected the Use Existing Element option, in the Name drop-down field select the column to which you
want to link your new column.
When a column is linked
to an existing layer
10. Click on the OK button to create the new column and close the dialog box or click on the Apply button to create
the new column but keep the dialog box opened to create other new columns.
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Deleting Layers
You can delete layers from your projects in two different locations:

•
•

Deleting a Layer From the Timeline View, on page 255
Deleting a Layer from the Xsheet View, on page 255

Deleting a Layer From the Timeline View
There are two ways to delete a layer in the Timeline view, using the Delete Layers
access menu.

button or through the quick

In Animate Pro, this will also delete the associated modules from the Network view.
To delete layers in the Timeline view:
1.

In the Timeline view, select the layers to be deleted.

2.

In the Timeline’s Layer toolbar, click on the Delete Layers
button.
You can also right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Delete.
The Confirm Delete dialog box opens.

In Animate Pro, enable the Delete Drawing Files and Element Folders option to delete all drawings
and folder linked to this layer.
3. To complete the operation:
 Click on the OK button to delete the selected layers.
 Click on the Cancel button to cancel the operation.



Deleting a Layer from the Xsheet View
There are two ways to delete a layer in the Xsheet view, using the Delete Columns
menu.

button and via the quick access

To delete layers in the Xsheet view:
1.

In the Xsheet view, select the columns to be deleted by clicking on their header.

2.

In the Xsheet View toolbar, click on the Delete Columns
button. You can also right-click (Windows) or
[Ctrl]+click (Mac OS X) on the selection and select Delete Columns. The default keyboard shortcut is [Delete].
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The Confirm Delete dialog box opens.

In Animate Pro, enable the Delete Drawing Files and Element Folders option to delete all drawings
and folders linked to this layer.
3. To complete the operation:
 Click on the OK button to delete the selected layers.
 Click on the Cancel button to cancel the operation.



NOTE: if you delete the last column of your Xsheet using the [Delete] shortcut, a Warning dialog box opens
asking you if you also want to delete the selected frames.





Click on the Yes button if you also want to delete all the frames from your scene.
Click on the No button if you want to keep the frames in your scene.
Enable the Don’t Show This Message Again option if you do not want the dialog box to pop again in the
future.

Modifying Layers
Once you added layers to your project, you can modify their properties, name or ordering.
This topic is divided as follows:

•
•
•
•

Ordering Layers, on page 256
Show and Hide Layers, on page 257
Layer Properties, on page 261
Renaming a Layer, on page 262

Ordering Layers
You can change the order of your layers in the Timeline and Xsheet view. When you change the order of your layers
in one of these views, the other one is updated.

Reordering Layers in the Timeline View
To reorder layers in the Timeline view:
1.
2.
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In the Timeline view, select the layers to move.
Drag the selection to the new location and drop it in between the existing layers. Dropping the selection on an
existing layer would create a hierarchy. Layers located on top of the Timeline view are displayed in front of the
other ones. Layers located at the bottom are displayed behind.
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Reordering Layers in the Xsheet View
You can reorder columns in the Xsheet view using the mouse’s middle button.
To reorder columns in the Xsheet view:
1.

In the Xsheet view, click on the column’s header with the middle mouse button and drag the column to its new
position.

Show and Hide Layers
As you work in the Drawing or Camera view, some layers may be in the way or are used as references. You can hide
these layers to make your work area easier and less cluttered.

Showing and Hiding Layers From the Timeline View
You can show and hide layers in the Timeline view in several different ways.
To show or hide all layers at once in the Timeline view:

 In the Timeline’s Layer toolbar, click on the Enable/Disable All
You can also click on the Enable All

button to show or hide all your layers at once.

button located in the Timeline View toolbar’s extra buttons.

To show or hide individual layers in the Timeline view:

 In the Timeline’s Layer toolbar, uncheck the layer’s checkbox to disable a particular layer. Check the layer’s
checkbox to enable a particular layer. You can also click on the Enable/Disable
Timeline View toolbar’s extra buttons.

button located in the

When you disable a layer in the Timeline view, the corresponding column is hidden in the Xsheet view.
To disable all layers but the selected one:

 In the Timeline’s Layer toolbar, click on the Show Selection and Hide All Others

button to show only the

currently selected layer and disable all the other layers. You can also click on the Disable All Others
located in the Timeline View toolbar’s extra buttons.

button

257

Animate Pro 2 User Guide

In Animate Pro’s Timeline view, you can hide or show certain types of layers such as Group and Effect.
To show and hide layer types in the Timeline view:
1.

In the Timeline View menu, select View > Show > Show Manager.
You can also select View > Show > Show Sounds, Show Effects or Show Groups to immediately show or
hide the selected type. This option will remain only for the current session. Once the application is closed
and reopened, the default settings will return.



The Show Manager dialog box opens.

2.
3.
4.

Select the types of layers you want to display and disable the ones you don’t.
Click on the Set As Default button to make these new settings the default ones that will be used each time to
start he application. Click on the Restore Default to restore the settings used when installing the application.
Click on the OK button to apply the new settings or on the Close button to cancel the changes.

Showing and Hiding Columns From the Xsheet View
The Xsheet view has a Column List section that shows all the columns contained in the exposure sheet. It can be used
to hide individual columns.
If you need to see a column after it has been hidden, you can display it directly from the Xsheet view without using
the Column List section.
You can also hide an entire column type such as Drawing or Sound.
When a column is hidden in the Xsheet view, the corresponding layer is disabled in the Timeline view.
To show and hide columns in the Xsheet view:
1.

In the Xsheet View toolbar, click on the Show Column List

2.

Click on the Expand button located on the right side of the Functions section to display the Column List
section.
In the Column List section, show or hide the columns by clicking in the column checkbox to add or remove the

3.

check mark. You can also click on the Hide Selected Column
extra buttons.
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To show a hidden column from the Xsheet view:
1.

In the Xsheet view, click on the thick grey line that appeared in place of the hidden column. You can also rightclick (Windows) or [Ctrl]+click (Mac OS X) on the column header and select Show Hidden Columns.

The Show Hidden Columns dialog box opens.

2.

In the Show column, enable the hidden columns you want to display in the Xsheet view.
Click on the Check button to check all the selected columns.
Click on the Uncheck button to uncheck all the selected columns.
Click on the Close button to cancel the operation.
Click on the OK button to complete the operation.






In Animate Pro, in the Xsheet view menu, you can select View > Unhide All Columns.

To hide and entire column type:
1.

In the Column List section, click on the Column Type button corresponding to the type you want to show or
hide.

Animate

Animate Pro



The Show/Hide All Columns

button shows or hides every column available in the Xsheet view.



The Show Drawing Columns

button shows the Drawing columns.



The Show Function Columns

button shows the Bezier and Ease function columns.



The Show 3D Path Columns

button shows the 3D Path function columns.



The Show Sound Columns

button shows the Drawing columns.

259

Animate Pro 2 User Guide



The Show 3D Rotation Columns



The Show Annotation Columns

button shows the 3D Rotation columns.
button shows the Annotation columns.

In Animate Pro’s Xsheet view, you have the choice of hiding or showing certain types of columns such as Annotation
and Functions.
To show and hide layer types in the Timeline view:
1.

In the Xsheet View menu, select View > Column Types Manager.
The Column Types dialog box opens.

2.
3.
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Select the types of columns you want to display and disable the ones you want to hide.
Click on the Set As Default button to make these new settings the default ones that will be used each time to
start he application. Click on the Restore Default to restore the settings used when installing the application.
 Click on the OK button to apply the new settings or on the Close button to cancel the changes.

Chapter 6: Layers and Timing Layers

Layer Properties

Each layer has its own set of properties that can be modified. including effect and peg layers.
Display the Layer Properties editor if you want to modify some of the layer’s properties such as the name or the
antialiasing quality. You can display the editor from the Timeline or Network view or open the Layer Properties as a
view of its own.

In Animate Pro, the Xsheet column will not open the Layer Properties dialog box, it will show the Column Properties
allowing you to modify settings related to the Xsheet column.

Default Mode

Advanced Element Mode

Refer to the Animate Pro only section of Layers > Adding Drawing Columns in the Xsheet View, on page 252 to
learn more about the Advanced Element mode.

Refer to the Adding New Drawing Layers section and Setting Up the Scene > Positioning an Element Using the
Layer Properties, on page 492 to learn more about these parameters.
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The Drawing Layer Properties editor allows you to:

•
•
•
•
•
•
•

Rename the layer
Enable or disable the layer
Lock the layer
Change the track colour
Activate the onion skin preview
Adjust the positioning and animation parameters
Adjust many other advanced parameters
Refer to the following chapters to learn more about the parameters available in the Layer Properties editor:

•
•
•

Setting Up the Scene, on page 475
Creating Animation Paths, on page 583
Enhancing With Effects, on page 707

To display the Layer Properties Editor from the Timeline view:

 In the Timeline view, double-click on the layer you want to edit the parameters of. You can also right-click
(Windows) or [Ctrl]+click (Mac OS X) and select Editor. The default keyboard shortcut is [Shift]+[E].

To display the Layer Properties Editor in the Layer Properties view:
1.
2.

In the top menu, select Windows > Layer Properties.
In the Timeline or Xsheet view, select the layer your want to see the properties of.

To display the Column Properties Editor from the Xsheet view:

 In the Xsheet view, double-click on the column’s header you want to edit the parameters of. The default
keyboard shortcut is [Shift]+[E].

To display the Layer Properties Editor in the Network view:

 In the Network view, click on the module’s yellow properties button.

Renaming a Layer
You can rename a layer in two different ways; in the Layer Properties editor or directly on the Timeline’s layer.
To rename a layer in the Timeline view:
1.
2.

In the Timeline view, double-click on the name of the layer to rename.
In the Name field rename the layer and press [Return] to validate the modifications.

To rename a layer in the Layer Properties editor:
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1.

In the Timeline view, double-click on the layer to rename.

2.

The Layer Properties editor opens.
In the Name field, rename the layer.

3.

Click on the Close button.
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Duplicating Layers
Duplicating a layer provides you with an independent copy of the drawings and their exposure. You can modify
anything you want in the duplicated layer without affecting the original one.
For Animate Pro, in the Network view, you can duplicate the selected modules in the same way.
To duplicate a layer:
1.

In the Timeline or Xsheet view, click on the layer you want to duplicate.

2.

Select Edit > Duplicate. You can also click on the Duplicate Layer
button situated in the Xsheet View
toolbar and Timeline View toolbar. The default keyboard shortcut is [Ctrl]+[D] (Windows) or [a]+[D] (Mac OS X).
The new duplicated layer appears.

Cloning Layers
Cloning a layer provides you with a copy of the selected layer that uses the same drawings as the original. If you
modify a drawing in the cloned or original layer it is updated in both layers. You can modify the layers’ timing
independently one from the other, but the drawings remain linked.
For Animate Pro, in the Network view, you can clone the selected modules in the same way.
This feature is useful when you want to reuse a hand-drawn animation but have different timings.
To clone a layer:
1.

2.

In the Timeline or Xsheet view, click on the layer you want to clone.

Select Edit > Clone. You can also click on the Clone Layer

button situated in the Xsheet View toolbar and

Timeline View toolbar.
The new cloned layer appears.

Xsheet Thumbnails
When there are a large number of columns in the exposure sheet, it is not always easy to quickly identify a particular
column. Displaying the column thumbnails makes this easier. This option displays a small thumbnail picture of the
current frame below the column header.
To display the thumbnails:
1.

In the Xsheet view, click on the Show Thumbnails

button.

The thumbnails appear.
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Changing the Colour of a Column or Layer
To easily identify layers in your Timeline and Xsheet view you can change their colour.
To change the layer’s colour in the Timeline view:
1.

In the Timeline view, click on the colour swatch of the layer you want to modify. You can also select the layer and
click on the Change Track Colour

button located in the Timeline View toolbar’s extra buttons.

2.

In the Colour Picker window, select the new colour for your layer.

3.

Close the Colour Picker window.
The layer’s colour is updated.

To reset a layer’s colour in the Timeline view:
1.

In the Timeline view, select the layers to reset and click on the Default Track Colour
Timeline View toolbar’s extra buttons.

To change a column’s colour in the Xsheet view:
1.
2.
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3.

In the Xsheet view, select one or more columns to modify.
Right-click (Windows) or [Ctrl]+click (Mac OS X) on the column’s header and select
Colour > Change Columns Colour.
In the Colour Picker window, select the new colour for your columns.

4.

Close the Colour Picker window.

button located in the
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The column’s colour is updated.

To reset the column’s colour in the Xsheet view:
1.

In the Xsheet view, select the columns to reset and right-click (Windows) or [Ctrl]+click (Mac OS X) on the
column’s header and select Colour > Default Columns Colour.

Expanding and Collapsing Layers
To simplify the look of your Timeline and Xsheet view, you can collapse and expand your layers. If some layers are
parented to other ones, you can collapse the parent layer to hide all of its children. You can also collapse 3D Path
columns in the Xsheet view.
To collapse a layer selection in the Timeline view:
1.
2.

In the Timeline view, select the layers to collapse.
Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select
Collapse/Expand > Collapse/Expand. You can also click on the Expand Children Arrow
parent layer.
 The default keyboard shortcut is [Ctrl]+[I] (Windows) or [a]+[I] (Mac OS X).



You can click on the Collapse/Expand

located on the

button available in the Timeline View toolbar’s extra buttons.

To expand a layer selection in the Timeline view:
1.
2.

In the Timeline view, select the layer to expand.
Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select
Collapse/Expand > Collapse/Expand. You can also click on the Expand Children Arrow
parent layer.
 The default keyboard shortcut is [Ctrl]+[I] (Windows) or [a]+[I] (Mac OS X).



You can click on the Collapse/Expand

located on the

button available in the Timeline View toolbar’s extra buttons.

To collapse or expand all layers in the Timeline view:
1.

Right-click (Windows) or [Ctrl]+click (Mac OS X) on the layers and select Collapse/Expand > Expand All or
Collapse All.
 The default keyboard shortcuts are [0] to collapse and [9] to expand.

You can click on the Collapse All

or Expand All

buttons available in the Timeline View toolbar’s extra buttons.

To collapse and expand 3D Path columns in the Xsheet view:
1.
2.

In the Xsheet view, display the Functions section by clicking on the Show Column List
In the Functions section, select the header of the 3D Path column to collapse.

button.
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3.

Right-click (Windows) or [Ctrl]+click (Mac OS X) on the column’s header and select
Expand/Collapse > Collapse Selection.
 To expand a collapsed column, select the column’s header, right-click (Windows) or [Ctrl]+click (Mac OS X)
on the selection and select Expand/Collapse > Expand Selection.

You can click on the Collapse Selection
extra buttons.

or Expand Selection

buttons available in the Xsheet View toolbar’s

To collapse or expand all 3D Path columns in the Xsheet view:

 Right-click (Windows) or [Ctrl]+click (Mac OS X) on any column’s header and select
Collapse/Expand > Expand All or Collapse All.

The default keyboard shortcuts are: [0] to collapse and [9] to expand.
You can click on the Collapse All

or Expand All

buttons available in the Xsheet View toolbar’s extra buttons.

Refer to Creating Animation Paths > 3D Path, on page 592 to learn how to use 3D Path columns.

Modifying the Look of the Column (PRO)
In Animate Pro, you can modify the way the column displays drawings, empty cells and the column width.
You can modify the following elements:

•
•
•
•

Empty Cells
Row Units
Held Exposure
Column Width

To modify the look of an empty cells:

 In the Xsheet View menu, select View > Empty Cells > With an “X” or Blank.

Blank

With An “X”

To modify the row units:

 In the Xsheet View menu, select View > Row Units > Frames or Feet.

Frames
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To modify the held exposure’s look:

 In the Xsheet View menu, select View > Held Exposures > Line or Value.

Line

Value

To modify the column’s width:
1.
2.

In the Xsheet view, select any column to modify the width.
In the Xsheet view menu, select View > Set Columns Width.
The Xsheet Column Width dialog box opens.

3.
4.

In the Column Width field, type the desired width in pixel.
To end the operation:
 Click on the OK button to validate and close the dialog box.
 Click on the Apply button to validate the operation and keep the dialog box opened to adjust the next
column’s width.
 Click on the Set As Default to create all the new columns to this width.
 Click on the Close button to cancel the operation.
5. To restore all columns to the default value, in the Xsheet view menu, select All Columns to Default Width.
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Exposure
Toon Boom Animate provides different tools to fill-in exposures and values, create cycles, set increments.
This topic is divided as follows:

•
•
•
•
•
•
•
•
•
•
•
•
•

Filling Mode, on page 268
Typing Exposure, on page 269
Holding an Exposure, on page 270
Extending a Single Exposure, on page 271
Extending an Exposure Sequence, on page 271
Dragging Cells, on page 272
Increasing and Decreasing Exposure, on page 274
Inserting Blank Cells, on page 276
Setting the Exposure, on page 277
Filling a Selection with a Single Exposure, on page 278
Filling a Selection with a Sequence, on page 279
Filling a Selection Randomly, on page 280
Creating Cycles, on page 281

Filling Mode
In the Xsheet view, you can fill columns using two different filling modes: Overwrite or Insert. These modes control
the filling behaviour. The Timeline view only uses the Overwrite mode.
To toggle between Overwrite and Insert modes:

 In the Xsheet view’s right bottom corner, click on the Overwrite/Insert button. The default keyboard shortcut is
[I].

This section is divided as follows:

•
•

Overwrite Mode, on page 268
Insert Mode, on page 269

Overwrite Mode
By default, the Xsheet view is set to Overwrite mode. Add a new value or a new value sequence overwrites existing
ones. The existing timing sequence remains in the same place and is not pushed further down the column.
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Insert Mode
The Insert mode is the opposite of the Overwrite mode. When you add a new value or a new value sequence over
existing ones, the new values are inserted between the old ones. The existing timing sequence is pushed down the
column.

Typing Exposure
To fill in your exposure, you can directly type the values into the Xsheet and Timeline view.
This section is divided as follows:

•
•

Typing a Value in the Timeline View, on page 269
Typing a Value in the Xsheet View, on page 269

Typing a Value in the Timeline View
If you want to type an exact drawing name or value in the Timeline view, you must use the Data view section of the
Timeline.
NOTE:
You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).
To type a value in the Timeline view:
1.

In the Timeline view, click on the Show Data View

button.

2.

In the Drawing Substitution field, type the name of the drawing you want to create.

3.

Press [Return] to validate the entry

Typing a Value in the Xsheet View
To enter a value in a column’s cell, double-click in the cell and type the numbers or letters.
NOTE:
You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).

•
•

If you press the keyboard shortcut [Return], you move on to the next cell.
If you press the keyboard shortcut [ESC], you exit the typing mode to return to normal mode.
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To type values in the Xsheet view:
1.

In an Xsheet column, double-click on one cell.

2.

Type a value or drawing name in the cell.

3.

Press [Return] to move on to the next cell.

4.

Press [ESC] to quit the typing mode.

Holding an Exposure
Drawings in an animation are not always exposed on a single frame, they are often exposed for more than one frame.
The most common exposure of a drawing is two frames. In the industry, this type of exposure is known as animation
in double frames. A drawing can also be exposed for three, four, five cells and so on. To prevent mistakes and to save
time, the Animate Xsheet Module lets you hold your cells automatically as you type.
The Xsheet’s Hold Exposure option allows you to choose how many frames you want to hold your exposure for.
NOTE: This option is only available in the Xsheet view.
To hold exposure:
1.
2.

In the top menu, select Animation > Cell > Hold Exposure > Hold 2 Cells.
Type a value or drawing name in the cell.
 Press [Return] to move on to the next cell.
 Press [ESC] to quit the typing mode.
3. Try the same action with Hold 3 Cells, Hold 4 Cells and Hold.
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The Hold Value dialog box opens when you select the Hold option and allows you to hold as many cells as
needed. You can type in any amount.
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Extending a Single Exposure
The Extend Exposure feature allows you to select an Xsheet’s cell containing a value and to pull it down to the desired
frame.
To extend a cell exposure:
1.

In the Xsheet view, select the red arrow
cursor.

2.

Pull down the selected cell to the desired frame.

in the cell’s right side. Make sure to see the drag down

NOTE: The red selection box must be visible when releasing the mouse button. If it is not visible, the action is
considered cancelled.

Extending an Exposure Sequence
You can extend and create a sequence using almost the same procedure as you would when you extend a single
exposure. The only differences being that the selected cell must only contain numbers and that you need to press the
[Shift] key while pulling down on the selection.
NOTE: The creation of the sequence only works with numbers in the selected cell, not letters.
To create a sequence:
1.

In the Xsheet view, select a cell containing a number.

2.

In the selected cell, click on the red arrow
down

3.
4.

on the cell’s right-hand side. Make sure to see the drag

cursor.

Press the [Shift] key and hold it down. Make sure a [+] sign appears.
Pull down the selection box to the desired frame.

NOTE: The red selection box must be visible when releasing the mouse button. If it is not visible, the action is
considered as cancelled.
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5.

First release the [Shift] key, then release the mouse button.

NOTE: You can also select a cell and select Animation > Cell > Extend Exposure. In the dialog box, type the frame
number you want to extend the cell to. The default keyboard shortcut is [F5].

Dragging Cells
To readjust your timing, you can drag one or several cells to a new location in both Timeline and Xsheet view.
You can drag a cell to any other frame in the same column or into another column.
To drag a cell to another location in the Timeline view:
1.

In the Timeline view, select one or several cells to move.

2.

Click on the cells selection and drag it to the new location.



If you drop the selection, it overwrites the existing cells.



If you hold [Ctrl] (Windows) or [a] (Mac OS X) while dropping the selection, the cells are copied and not
moved.



If your press [Shift] while dropping, the selection is inserted between the existing frames.

To drag a cell to another location in the Xsheet view:
1.
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In the Xsheet view, select one or more cells.
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2.

In the Xsheet view, select the small dotted area

on the left-hand side of the selected cells.

3.

Drag the selection to any other cell in the same column or in another column.



If you drop the selection, it overwrites the existing cells.



If you hold [Ctrl] (Windows) or [a] (Mac OS X) while dropping the selection, the cells are copied and not
moved.



If your press [Shift] while dropping, the selection is inserted between the existing frames.
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Increasing and Decreasing Exposure
Once a value is entered in the Timeline or Xsheet view, you can increase and decrease its exposure.
This topic is divided as follows:

•
•
•
•

Increase Exposure, on page 274
Decrease Exposure, on page 274
Increase/Decrease Exposure Field, on page 275
Clear Exposure and Pull, on page 275

Increase Exposure
Increasing the exposure adds one more exposure to a selected cell, repeating this action adds an extra cell every time.
This is a quick way of extending a drawing exposure and is always set in the Insert mode. Increasing an exposure
always pushes the existing exposure down.
To use Increase Exposure:
1.

In the Timeline or Xsheet view, select a cell.

2.

In the top menu, select Animation > Cell > Increase Exposure. You can also right-click (Windows) or
[Ctrl]+click (Mac OS X) on the selected cell and select
Exposure > Increase Exposure. The default keyboard shortcut is [+].




You can click on the Increase Exposure
button available in the Xsheet View and Timeline View toolbars’
extra buttons.
Repeat this action to add more cells to your drawing’s exposure.

Decrease Exposure
Decreasing the exposure removes one exposure from a selected cell, repeating this action removes an extra cell every
time. This is a rapid way to reduce a drawing exposure and remove the exposed drawing.
To use Decrease Exposure:
1.

In the Timeline or Xsheet view, select a cell.

2.

In the top menu, select Animation > Cell > Decrease Exposure. You can also right-click (Windows)
or [Ctrl]+click (Mac OS X) on the selected cell and select
Exposure > Decrease Exposure. The default keyboard shortcut is [-].
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You can click on the Increase Exposure
button available in the Timeline View toolbar’s extra buttons.
Repeat this action to remove more cells from your drawing’s exposure.
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Increase/Decrease Exposure Field
Another technique you can use to quickly increase or decrease the exposure of a selected drawing is by making use
of the Increase/Decrease Exposure field available in the Xsheet view.
To increase and decrease exposure using the Increase/Decrease Exposure field:
1.

In the Xsheet view, select the cell to modify.

2.

In the Xsheet’s bottom right-hand corner, increase or decrease the drawing’s exposure by clicking on the up or
down arrows. You can also use the keyboard shortcut [+] to increase or [-] to decrease the selected drawing’s
exposure.

Click on the small arrows
here to increase or
decrease the drawing’s
exposure

Clear Exposure and Pull
You can reduce a drawing’s exposure using the Clear Exposure and Pull option.
To use the Clear Exposure and Pull feature:
1.

In the Timeline or Xsheet view, select a cell.

2.

In the top menu, select Animation > Cell > Clear Exposure and Pull. You can also right-click (Windows) or
[Ctrl]+click (Mac OS X) on the selected cell and select Exposure > Clear Exposure and Pull.




You can click on the Clear Exposure
extra buttons.
The default keyboard shortcut is [Z].

button available in the Xsheet View and Timeline View toolbars’
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Deleting Exposure
You can delete a drawing’s exposure in several simple ways. Note that when you delete a drawing’s exposure from
the Timeline or Xsheet view, you are not deleting the actual drawing file. You can always bring it back by typing its
name again in a cell.
You can delete the exposure contained in a selected cell range or delete the entire exposure of a drawing exposed
over several cells.
Refer to the Layer Concepts topic to learn more about the drawing concept.
To delete selected exposures:
1.
2.

In the Timeline or Xsheet view, select the exposure you want to delete.
Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Delete. The default keyboard
shortcut is [Delete].

To entirely clear the exposure of a drawing:
1.
2.

In the Timeline or Xsheet view, select a cell of a drawing exposed over several cells.
In the top menu, select Animation > Cell > Clear Exposure.
 In the Timeline view, you can also right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select
Exposure > Clear Exposure.



You can click on the Clear Exposure

button available in the Timeline View toolbar’s extra buttons.

Inserting Blank Cells
Use the Insert Blank Cell option to place an empty cell between other cells. This is always done in Insert mode and
pushes down existing exposure, even if you are set to Overwrite mode.
To use Insert Blank Cell:
1.

2.

In the Xsheet or Timeline view, select the cell where you want to insert a blank cell.

In the top menu, select Animation > Cell > Insert Blank Cell. You can also right-click (Windows)
or [Ctrl]+click (Mac OS X) on the selected cell and select Exposure > Insert Blank Cell.
 The default keyboard shortcut is [X].



You can click on the Insert Blank Cell
buttons.

The blank cell is inserted.

276

button available in the Timeline View and Xsheet toolbars’ extra

Chapter 6: Layers and Timing Exposure
To clear a selected cell range without deleting the exposure:
1.

In the Xsheet view, select the frame range to clear.

2.

Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selected cells and select Clear.

Setting the Exposure
You can easily increase or decrease the exposure for a selected cell range by using the Set Exposure options.
To use the Set Exposure options:
1.

In the Timeline or Xsheet view, select the cell range that you want to set the exposure for.
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2.

In the top menu, select one of the following:
Animation > Cell > Set Exposure > Set Exposure to 1
Animation > Cell > Set Exposure > Set Exposure to 2
Animation > Cell > Set Exposure > Set Exposure to 3
Animation > Cell > Set Exposure

•
•
•
•



You can also click on the Set Exposure
buttons located in the Timeline View toolbar’s
extra buttons.
If you choose the Set Exposure option, the Set Exposure dialog box opens.




Type the amount of frames you want the drawings to be displayed.
Click on the OK button



The new timing is displayed in the Xsheet view.

Filling a Selection with a Single Exposure
The Fill Selection option is used to fill the same value all over a selection. The selection can be over one cell, a cell
range in one column, a cell range over many columns, an entire column or many entire columns. You can use numbers,
words, letters or any alphanumeric value.
To use Fill Selection:
1.

In the Xsheet or Timeline view, select a cell range.

2.

Select Animation > Cell > Fill Selection. The default keyboard shortcut is [Ctrl]+[T] (Windows)
or [a]+[T] (Mac OS X).
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You can also click on the Fill Selection
extra buttons.

button available in the Xsheet View and Timeline View toolbars’
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The Fill Selection dialog box opens.

3.
4.

In the Value field, type the desired value.
Click on the OK button.

Filling a Selection with a Sequence
The Sequence Fill option is used to create a number sequence over a selection. The sequence can be forward,
backward, single, double or higher increment, as a cycle, etc. The selection can be over one cell, a cell range in one
column, a cell range over many columns, an entire column or several entire columns.
To use Sequence Fill:
1.

In the Xsheet, select a cell range.

2.

Select Animation > Cell > Sequence Fill. The default keyboard shortcut is [Ctrl]+[M] (Windows) or
[a]+[M] (Mac OS X).



You can also click on the Sequence Fill
extra buttons.

button available in the Xsheet View and Timeline View toolbars’

The Sequence Fill dialog box opens.

3.
4.
5.
6.

In the Starting Value field, type the starting number for the number sequence.
In the Increment field, type the increment to which the number will change from frame to frame
(1-2-3-4, 1-3-5-7, 10-9-8-7-6-5-4-3-2-1). The value can be positive or negative.
In the Hold field, choose an exposure holding value.
Enable the Cycle option if you want a cycle; type the number of cells for this cycle’s duration.

NOTE:
If you choose a two cell hold, a cycle of three drawings lasts six cells
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7.

If you selected a larger range than the amount of frames needed, enable the End Frame and type the last frame
needed.

8.

If you want to have more than one digit in your numbers such as “001” instead of “1”, enable the Padding
option and add as many pound signs “#” as digits needed. Also, you can type a letter or word in the field for it
to be added in front of the drawing number.

9.

Click on the OK button.

Filling a Selection Randomly
The Fill Cells Randomly option is used to fill in random values over a selection. You can give a maximum and a
minimum value and create a range for the system to choose the random values from. The selection can be over one
cell, a cell range in one column, a cell range over many columns or an entire column or several entire columns.
To use Fill Cells Randomly:
1.

In the Xsheet view, select a cell range.

2.

Select Animation > Cell > Fill Cells Randomly.



You can also click on the Fill Cells Randomly
toolbars’ extra buttons.

The Fill Cells Randomly dialog box opens.

3.
4.
280

In the Minimum Value field, type a minimum value.
In the Maximum Value field, type a maximum value.

button available in the Xsheet View and Timeline View
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5.
6.
7.

In the Hold field, choose an exposure holding value.
If you are applying this option to a drawing column, enable the Whole Numbers option to avoid decimal points.
Click on the OK button.

Creating Cycles
Once you have entered a series of drawings and exposures, you can create cycles out of them in several ways.
You can loop your drawings using the following commands:

•
•
•

Paste Cycle
Paste Reverse
Create Cycle

When you paste your selection, you are not duplicating the drawings. If you have a drawing “1” in your cycle, when
you modify this drawing, it is updated in all the cycles simultaneously.
To use the Paste Cycle command:
1.

In the Xsheet or Timeline view, select the cell range to loop.

2.
3.

In the top menu, select Edit > Copy.
In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4.

In the top menu, select Edit > Paste Cycle. The default keyboard shortcut is [Ctrl]+[/] (Windows) or
[a]+[/] (Mac OS X).
The Paste Cycle dialog box opens.

5.

In the Number of Cycles field, use the up and down arrow to increase or decrease the amount of cycles you want
to paste. You can also directly type the value.
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6.

In the Cycle Type drop-down menu, select the type of cycle you want to paste.

Normal (forward): This pastes your selection as it is, starting with the first cell and ending with the last one.
Reverse: This pastes your selection reversed, starting with the last cell and ending with the first one.
Forward -> Reverse: This pastes your selection as a yo-yo, starting with the first cell, going to the last one
and ending with the first cell.
 Reverse -> Forward: This pastes your selection as a reversed yo-yo, starting with the last cell, going to the
first one and ending with the last cell.
7. Click on the OK button to paste your cycles.





NOTE: You can do the same operation using the Paste Special dialog box. To open the Paste Special dialog box,
select Edit > Paste Special. or use the keyboard shortcut [Ctrl]+[Shift]+[B] (Windows) or[a]+[Shift]+[B] (Mac OS X).

To use the Paste Reverse command:
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1.

In the Xsheet or Timeline view, select the cell range to paste inverted.

2.
3.

In the top menu, select Edit > Copy.
In the Xsheet or Timeline view, select the cell where you want your cycles to start.
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4.

In the top menu, select Edit > Paste Reverse. The default keyboard shortcut is [Ctrl]+[.] (Windows)
or [a]+[.] (Mac OS X).

To use the Create Cycle command:
1.

In the Timeline view, select the cell range to loop.

2.

In the Timeline View toolbar, click on the Create Cycle

button located in the toolbar’s extra buttons.

The Create Cycle dialog box opens.

3.
4.

Enter the number of cycles you want, including the current selection.
Click on the OK button.
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Navigating Between Frames and Columns
Once a cell is selected in the Timeline or Xsheet view, you can navigate between the layers, frames and drawings using
keyboard shortcuts that are effective in the Camera, Drawing, Timeline and Xsheet view.
You can navigate through:

•
•
•

Columns
Drawings
Frames

To navigate through the drawings, frames and columns:
1.

2.

In the Timeline or Xsheet view, select a cell.

Once the cell is selected, you can navigate between:
Previous and next layers using the keyboard shortcut [H] and [J] or from the top menu, you can select
Edit > Previous Layer and Next Layer.



H



J

Previous and next drawings using the keyboard shortcut [F] and [G] or from the top menu, select
Edit > Previous Drawing and Next Drawing or Drawing > Previous Drawing and Next Drawing.
F
G
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Previous and next frames using the keyboard shortcut [,] and [.] or from the top menu, select
Play > Previous Frame and Next Frame.
[,]
[.]

Managing Drawings
Drawings that are created in Animate are not encapsulated in their cells. They are actual files stored in the project’s
folder. If you want to rename a drawing or delete a drawing from your project, you need to edit the file and not the
cells.
This topic is divided as follows:

•
•
•
•
•

Renaming a Drawing, on page 285
Renaming Drawings by Frame Position, on page 286
Deleting a Drawing, on page 286
Duplicating a Drawing, on page 287
Copying and Pasting Drawings, on page 287

Renaming a Drawing
To rename a drawing, you do not type the new name in the cell. You need to select the cell containing the drawing
and use the Rename Drawing command.
To rename a drawing:
1.

In the Timeline or Xsheet view, select the drawing to rename.

2.

In the top menu, select Drawing > Rename Drawing. The default keyboard shortcut is
[Ctrl]+[Alt]+[D] (Windows) or [a]+[Alt]+[D] (Mac OS X).



You can also use the Rename Drawing
extra buttons.

button located in the Timeline View or Xsheet View toolbars’

The Rename Drawing dialog box opens.

3.
4.

In the New Name field, type the new drawing name.
Click on the OK button.
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Renaming Drawings by Frame Position
You can rename a series of drawings relative to their frame position. This is useful in hand-drawn animation.
To rename drawings by their frame position:
1.

In the Xsheet or Timeline view, select the drawing sequence to be renamed.

2.

In the top menu, select Drawing > Rename by Frame.

Deleting a Drawing
To permanently delete a drawing file, select the drawing you want to delete and use the Delete Selected Drawings
command.
Delete a drawing file is an operation that cannot be undone.
To delete a drawing:
1.

2.

In the Timeline or Xsheet view, select the drawings to delete.

In the top menu, select Drawing > Delete Selected Drawings.
The Delete Drawings dialog box opens.
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Click on the Yes button to delete the drawing files from the project but retain the values in the cells.
Click on the Yes - Clear Cells button to delete the drawing files from the project and delete the values from
the selected cells.
Click on the No button to cancel the operation.
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Duplicating a Drawing
If you want to modify a drawing that already exists, but keep the original drawing intact, you can duplicate the drawing
and work on the copy. When duplicating a drawing, the selected cell is replaced with the new drawing. The exposure
of the original drawing that was on the current cell is removed. The drawing is not deleted.
To duplicate a drawing:
1.

In the Timeline or Xsheet view, select the drawing to duplicate.

2.

In the top menu, select Drawing > Duplicate Drawing or use the keyboard shortcut [Alt]+[Shift]+[D].

With Animate you can create a keyframe at the same time as you duplicate your drawing. This way you can modify
and reposition your drawings without affecting the original drawing.

Copying and Pasting Drawings
When you copy and paste a selection in the Timeline or Xsheet view, you are not copying and pasting the actual
drawings, you are pasting the exposure.
If you want to copy and paste the selected drawings into a different layer or paste the selection in the same layer to
duplicate the drawings, you must use the Paste Special feature.
There are two main ways to paste your selected drawings with the Paste Special dialog box:

•
•

Always Create Drawings
This option pastes all of your drawings as they are. If a drawing has the same name as an existing one, it is
renamed and duplicated.
Only Create Drawings When They Do Not Exist
This option only pastes the drawings that are named differently from existing drawings. If a drawing has the
same name as an existing one, it is ignored and not pasted. This avoids duplicating drawings in your layers.
This option is useful when you are pasting cut-out character templates containing drawings you may already
have in your scene and some new ones. Using this option, you only paste the new drawings and are not
duplicating all of the other parts you already have.

To paste drawings with the Paste Special command:
1.

In the Timeline or Xsheet view, select the drawings to copy.

2.

In the Timeline or Xsheet view, select the cell where you want your pasted selection to start.
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3.

In the top menu, select Edit > Paste Special. The default keyboard shortcut is [Ctrl]+[Shift]+[B] (Windows) or
[a]+[Shift]+[B] (Mac OS X). You can also click on the Paste Special

button located in the Timeline View and

Xsheet View toolbars’ extra buttons.
The Paste Special dialog box opens.

4.
5.
6.

Go to the Basic tab.
In the Drawings section, enable the Always Create Drawings or the Only Create Drawings When They Do Not
Exist option depending on what you need.
Click on the OK button.

If you want to perform another paste special operation using the same settings you used previously, you can use
the Paste Special Again command instead of the Paste Special command. This feature paste your selection using the
same settings you used in your last paste special without opening the Paste Special dialog box.
To use the Paste Special Again command, select Edit > Paste Special Again. The default keyboard shortcut is
[Ctrl]+[Alt]+[B] (Windows) or [a]+[Alt]+[B] (Mac OS X).
You can also click on the Paste Special Again
buttons.
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Tempo Markers (PRO)
Tempo markers are used to synchronise your animation with a musical score. Using this feature, you can reproduce
the FPB (Frames Per Beat) and the tempo signature as Tempo markers. The Xsheet view allows you to pace your
animation according to the tempo or beat of your soundtrack music or to any rhythmical sound such as the ticking of
a clock or water leaking from a spout.

To set the Tempo Markers:
1.

In the Xsheet view menu, select View > Set Tempo Marker.
The Set Tempo Marker dialog box opens.

2.

Reproduce the tempo and beat value of your music or sound for the Xsheet view marker display.
Starting Frame:
Type the number of the frame where you want the tempo markers to begin.
 Frames/Beat:
Set the Frames Per Beat value. This will determine the frequency (in frames) a beat marker will appear. Keep
in mind that, by default, 24 frames represent 1 second.
 Beat/Bar:
Set the Tempo of your music or sound. This will determine the frequency (in beats) a tempo marker will
appear in the Xsheet view.
3. Click on the OK button.
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Annotation Columns (PRO)
The Annotation Columns are a more than just a useful tool. They allow you to mark actions, corrections or any other
information related to your animation that you would like to draw or write. This way, you can print your Xsheet, take
it back to your animation table and work with the annotations.
This section is divided in the following topics:

•
•
•
•

Adding an Annotation Column (PRO), on page 290
Drawing and Typing in the Annotation Column (PRO), on page 290
Changing the Drawing Settings (PRO), on page 292
Importing an Annotation File (PRO), on page 293

Adding an Annotation Column (PRO)
To add an annotation column:
1.

In the Xsheet View menu, select Columns > Add Columns or you can click on the Add Columns
the Xsheet View toolbar. The default keyboard shortcut is [Shift]+[C].

button in

The Add Columns dialog box opens.

2.
3.
4.

In the Column Name field, name your column accordingly.
In the Column Type field, select Annotation.
Click on the OK button.
The new column appears.

Drawing and Typing in the Annotation Column (PRO)
In the annotation column, you can not only type in your notes and relevant information, but also draw sketches and
ideas which will be useful in producing your animation.

Drawing in the Annotation Column (PRO)
Before you can draw in the annotation column, you must first activate the Enable Drawing option. Once this is done,
you can start drawing using the mouse or the pen tablet.
NOTE:
Pen tablet pressure sensitivity is not supported in the annotation column.
To enable drawing in the annotation column:
1.
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In the Xsheet View menu, select Annotation > Enable Drawing. You can also click on the column’s header icon
to toggle the Drawing mode.



The Select

icon indicates that the Drawing mode is disabled.



The Brush

icon indicates that the Drawing mode is enabled.
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To draw in the annotation column:

 To draw in an annotation column, simply use your mouse or pen tablet.

Typing in the Annotation Column (PRO)
Typing in an annotation column is independent from the Drawing mode. You can be in either mode and the typing
will work.
To type in an annotation column:
1.

In the annotation column, double-click on the cell where you want to write.

2.

In the selected cell, type the desired text.

Refer to the Typing Exposure section to get more information about typing values in the Xsheet.

Erasing Annotation Column Content (PRO)
You can erase part or all of the annotation column’s content.
To erase the annotation content:
1.

In the Xsheet view, disable the Drawing mode.
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2.

3.

In the Xsheet view, select the cell range you want to clear from text or images. Do not select any cells if you plan
to clear everything.

In the Xsheet view, right-click (Windows) or [Ctrl]+click (Mac OS X) in the annotation column and select:
Annotation > Erase All to erase completely the content of the column.
Annotation > Erase Selected Images to erase the images contained in the selected cell range. Make sure
to disable the Drawing mode to do so.
 Annotation > Erase Selected Texts to erase the text contained in the selected cell range. Make sure to
disable the Drawing mode to do so.




Changing the Drawing Settings (PRO)
You can change the pen size and colour when you draw in the annotation column.
To change the pen width:
1.

In the Xsheet View menu, select Annotation > Change Pen Width > 1, 2, 3, 4 or Custom.
If you selected the Custom option, the Pen Width dialog box opens.

2.
3.

In the Pen Width field, type the amount of pixel you want the pen size to be.
Click on the OK button.

To change the pen colour:
1.

In the Xsheet View menu, select Annotation > Change Pen Colour.
The Select Colour dialog box opens.

2.
3.
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Choose the new colour.
Click on the OK button.
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Importing an Annotation File (PRO)
If you scanned your paper exposure sheet’s annotations or if you need to place some pictures or drawings in your
annotation columns, you can easily import them.
To import annotation files:
1.

In the Xsheet view, select the first cell in the annotation column where you want the imported image to start.

2.
3.
4.

In the Xsheet View menu, select Annotation > Import Files.
Browse for the bitmap image to import.
Click on the Open button.
The image appears in the annotation column.
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Printing the Xsheet (PRO)
Once your line test is completed and you have marked all the information, corrections and timing you want in your
Xsheet view, you can print out your exposure sheet. Printing out the Xsheet allows you to take it with you to your
animation table or to give a copy to the animator.
To print your exposure sheet:
1.

Select File > Print > Xsheet.
The Print dialog box opens.
Windows

2.

Mac OS X

To setup your print:
Windows: In the Select Printer section, select your printer and adjust the rest of the printing settings.
Refer to your printer’s user guide to learn more about its options.
 Mac OS X: In the Printer section, select your printer and adjust the rest of the settings by clicking on the



Parameters
button. You can also click on the PDF button and select an option from the drop-down
menu if you want to save a PDF version of your exposure sheet.
Refer to your printer’s user guide to learn more about its options.
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3.

Click on the Print button.
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Element Manager (PRO)
Use the Element Manager to add, delete or modify elements (drawing folders) in your scene. If you have drawing
folders that are not linked to a column in your scene, use the Element Manager to delete them if need be.
To open the Element Manager dialog box:

 Select Scene > Element Manager.

•
•
•
•

•
•
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Elements: Displays a list of the elements contained in your scene.
Delete Elements: Press this button to delete the selected elements.
Delete Elements and Directories: Press this button to delete the selected layer, as well as its directories
(drawing folder).
Add/Modify Element: Use the options contained in this area to add or modify an element.
D Name: Type a New name in this field to create an element or to rename the selected element.
D Vector: Check this box if the new element is a vector drawing or if you want to enable the parameters
on the selected element in the Elements list.
D Bitmap Format: Select the file format of the bitmap layer from the drop-down list.
D Field Chart: If you are importing traditional animation, select the size of the paper on which the
animation was drawn.
Add: Press this button to create a new element with the current parameters entered in the Add/Modify
Element section.
Modify: Press this button to apply the parameter changes made to the selected element.
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Preferences
When adjusting your timing in the Timeline and Xsheet view, you may want to set some preferences.
This section covers the preferences related to the timing, Timeline and Xsheet view.
You will find the preferences listed under the following tabs:

•
•
•

Exposure Sheet
Timeline Preferences (PRO)
Advanced Preferences (PRO)

To open the Preferences panel:






Windows: Select Edit > Preferences
Mac OS X: Select Animate > Preferences
Mac OS X: Select Animate Pro > Preferences
You can also use the default keyboard shortcut [Ctrl]+[U] (Windows) or [a]+[U] (Mac OS X).

Exposure Sheet

This section is divided as follows:

•
•
•
•

Filtering, on page 297
Options, on page 298
New Element, on page 272
Apply/Next (PRO), on page 298

Filtering
These preferences are used to display or hide certain layer types in the Xsheet view.

•
•
•
•
•

Show Drawing Columns
If enabled, the Xsheet view displays the Drawing layers.
Show Function Columns
If enabled, the Xsheet view displays the Function columns.
Show Annotation Columns
In Animate Pro, if enabled, the Xsheet view displays the Annotation columns.
Show 3D Path Columns
If enabled, the Xsheet view displays the 3D Path columns.
Show Sound Columns
If enabled, the Xsheet view displays the Sound columns.
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Options
•
•

Default Add Columns
The default position where the new column will be added.
Default Column Width
The default width value for the new column being created.

New Element (PRO)
•

Bitmap Format:
By default, when you create a new empty bitmap column, it will use the file format indicated in the field as
the new column format. The default value is SCAN, which means that it is set for scanned-in drawings.

Apply/Next (PRO)
•
•

From Left to Right: When clicking on the Apply/Next button in the Xsheet view Column Properties, the
next column to be displayed in the Column Properties will be the one on the right.
From Right to Left: When clicking on the Apply/Next button in the Xsheet view Column Properties, the
next column to be displayed in the Column Properties will be the one on the left.

Timeline Preferences (PRO)

This section is divided as follows:

•
•

Defaults, on page 298
Paste/Drag & Drop, on page 298

Defaults
•
•
•

Show Groups: If enabled, the Timeline view will show the Group layers.
Show Effects: If enabled, the Timeline view will show the Effect layers.
Show Sound: If enabled, the Timeline view will show the Sound layers.

Paste/Drag & Drop
•
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Add keyframes at beginning and end: You should activate this option if you want to copy and paste a set
of frames that include an interpolated sequence between two keyframes, but need to extract only a partial
section. Under normal circumstances, cutting and pasting a function without either the start or end
keyframe would render the function null. Using this option will cap the partial function with a new keyframe
when you perform the paste.
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Advanced Preferences (PRO)

•

Advanced Element Mode: This preference is used to display more options in the Add Column dialog box
and the Column Properties dialog box.
D Auto-rename Elements: this controls whether to rename the element whenever the corresponding
module name in the Network view or layer name in the Timeline view is changed.
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Morphing Drawings

Hand-drawn animation requires you to spend a lot of time tracing in-between drawings. Animate speeds up the
process using its helpful Morphing feature. This powerful and useful feature creates computer generated drawings
and places them between vector drawings to save time and increase quality. Animation created with the Morphing
feature can be reused in different projects. You can easily modify the timing and velocity (ease in and ease out).
One of the main uses of the Morphing feature is in effect animation. For example, animating smoke or water can be
time-consuming because these types of effects are usually slow moving requiring a large number of closely placed inbetweens.
In this chapter, you will learn about the following:

•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Understanding Morphing, on page 302
Source and Destination Drawings, on page 302
Morphing Rules, on page 303
Creating a Basic Morphing Sequence, on page 306
Tool Properties View, on page 309
Adjusting the Velocity and Timing, on page 312
Morphing Tool and Hints, on page 316
Morphing Layers (PRO), on page 324
Morphing Two Sequences in a Row, on page 329
Inserting a Morphing Key Drawing (PRO), on page 330
Converting Morphing In-betweens to Drawings, on page 331
Morphing Holes and Transparencies, on page 332
Adjusting the Morphing Quality, on page 334
Tips and Tricks, on page 335
Preferences (PRO), on page 336
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Understanding Morphing
The Morphing feature is used to animate similar and simple shapes such as hair or smoke. It helps you by saving time
when you are working on tedious in-betweening and tracing tasks This, in turn, provides you with more time to spend
on complex animation tasks such as walk-cycles or acrobatic sequences.

Ideas Behind Morphing
To learn how to morph drawings, it is better to start with basic shapes such as circles and rectangles. Once you are
more familiar with the tool, you can increase your knowledge and expertise. In a very short time you will be producing
some remarkable effects.
It is helpful to know the pros and cons of morphing before you start. Understanding what you can do and which
drawing lines can give you a problem will enable you to design your key drawings so they morph efficiently.
The more complex the shape is, the longer it takes to morph. If it takes more time to morph a drawing than to
hand draw it, then it is better to animate it instead of morphing. However, if you spot an occasion when you can morph
your drawings, do it! It allows you to fix your timing and velocity in no time without having to create any extra
drawings!

Source and Destination Drawings

Source Drawing

Destination Drawing

The Morphing feature matches similar shapes in two drawings. These are the source and destination drawings.
Animate evaluates the source’s shape properties and matches them to the most similar one in the destination drawing.
Morphing works between similar shapes, which are drawings that have the same palette, colours and number of
shapes. You can even change a rabbit into an elephant, as long as source and destination keep the same colours and
number of shapes.
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Morphing Rules
Animate follows a set of rules as it evaluates the shapes. Familiarize yourself with these basic morphing rules before
you start morphing.

•
•
•
•
•
•

Closest Similar Shape, on page 303
Pencil Line to Pencil Line, on page 303
Fill Shape to Fill Shape, on page 304
Colour Swatch to Same Colour Swatch, on page 304
Vanishing and Appearing, on page 305
Colour Art to Colour Art and Line Art to Line Art, on page 305

Closest Similar Shape
A colour, line shape or zone will morph with the closest similar one in the destination drawing. This means it will morph
with the zone nearest to it, as long as that zone uses the same palette’s colour swatch (Colour ID) and has the same
vector properties (Central or Contour).

Refer to Drawing and Animating > Drawing with the Brush or the Pencil, on page 84 to learn more about the
difference between central and contour lines.

Pencil Line to Pencil Line
If you trace a shape using a pencil line such as the Ellipse

, Rectangle

, Polyline

, Line

or Pencil

tool, you have to morph it with another pencil line. Make sure that both drawings are pencil shapes (central vector).

A pencil line will never morph with a brush stroke.
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If you have pencil lines in your source drawing, the same number of pencil lines must be present in the
destination drawings. A pencil line will appear if it is not found in the destination drawing. It will pop out on the last
frame.
If two pencil lines cross one another, they are considered to be four lines and not two lines
anymore. In this case, you must have four pencil lines in your destination drawing for your
morphing to work correctly.

1
2

Refer to Drawing and Animating > Drawing with the Brush or the Pencil, on page 84
to learn more about the pencil (central) lines.

4
3

Fill Shape to Fill Shape
If you have a Brush line or a Colour fill zone which are contour vectors, make sure that you morph it with another Fill
or Brush line. Contour vectors will not morph with pencil lines (central vectors). A Brush line can morph into a colour
fill zone and vice versa.

Colour Swatch to Same Colour Swatch
Animate does not morph colours. If you want to perform a colour transition, you have to create the effect at the
compositing level. A colour palette is composed of colour swatches. Each colour swatch has its own unique
identification number, even if two colours pots are the same shade of red, they are identified independently. A colour
zone or shape will morph with another one painted with the same colour swatch.

Refer to Adding Colour > Colours, on page 183 to learn more about colour swatches.
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Vanishing and Appearing
If a colour zone does not find a match in the first or the second drawing, it will progressively appear or disappear.

Colour Art to Colour Art and Line Art to Line Art
In Animate, there is an advanced concept for painting your drawings called Line Art and Colour Art. Basically, an extra
layer is added in your drawings so that you can fill the colour zones on a separate layer. The regular layer on which
you are drawing is called Line Art and the extra layer under the Line Art is the Colour Art.

•
•
•

Art.

A shape drawn in Colour Art can only be morphed with another shape existing in the Colour Art.
A shape drawn in Line Art can only be morphed with another shape existing in the Line Art.
A shape created in Colour Art can never morph with a shape created in Line Art.
Refer to Adding Colour > Line Art and Colour Art Layers, on page 210 to learn move about Line Art and Colour
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Creating a Basic Morphing Sequence

Once you are familiar with the basic rules, you can start creating morphing sequences. You need to practice and
become at ease with the Morphing feature. To begin, start with simple elements, once you become confident with
the morphing process you can move on to complex and advanced morphing techniques, such as head rotation or full
characters.
To create a basic morphing:
1.
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2.

In the Timeline view, click on the Add Drawing Layer
button to add a new layer to your project. Rename the
new layer Morphing.
In the Timeline or Xsheet View, select the first cell in your layer.

3.

In the Tools toolbar, select the Rectangle

4.

In the Tool Properties view, enable the Auto Fill

5.
6.

In the Colour view, click on the Set Paint Current Colour
In the Colour list, select a colour to fill your rectangle with.

7.

In the Colour view, click on the Set Pencil Current Colour

tool. The default keyboard shortcut is [Alt]+[R].
option.

button.

button.
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8.

9.

In the Colour list, select a colour to trace your rectangle’s outline with.

In the Camera or Drawing View, draw a rectangle.
Hold down the [Shift] key if you want to draw a square.
Hold down the [Alt] key if you want to draw the rectangle from its centre.




10. In the Xsheet or Timeline View, select the last cell.

11. Repeat Step 5 to Step 10 using the Ellipse
tool instead of the Rectangle tool. The default keyboard shortcut
is [Alt]+[O].
 Draw an ellipse using the same outline colour as the rectangle (“Outline”). Paint the ellipse with the same
fill colour as the rectangle (“Fill”).

12. In the Xsheet or Timeline View, select your first drawing’s cell, the rectangle drawing.
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13. In the Xsheet or Timeline View, right-click (Windows) or [Ctrl]-click (Mac OS X) on the selection and select
Morphing > Create Morphing. The default keyboard shortcut is [Alt]+[M].
 In the top menu, you can also select Animation > Morphing > Create Morphing
Arrows appear between the two key drawings to show they are computer generated.

14. Use the Playback toolbar to play the morphing sequence. You can also use the [,] and [.] keyboard shortcuts to
flip through the in-betweens. The [F4] keyboard shortcut will toggle between the two key drawings.

Deleting a Morphing Sequence
You may want to delete an entire morphing sequence in order redo the sequence from scratch.
To delete an entire Morphing sequence:

 In the Xsheet or Timeline View, right-click (Windows) or [Ctrl]-click (Mac OS X) on a cell between two keyframes
and select Morphing > Delete Morphing or from the top menu, select
Animation > Morphing > Delete Morphing.
The entire sequence between the two keyframes is removed.
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Tool Properties View

As you create and adjust your morphing sequences, you will often use the Tool Properties view. Using this view allows
you do things such as toggling between your key drawings, adjusting the easing or selecting a hint type.
To access the content of the Tool Properties view, you must select the Morphing
default keyboard shortcut is [F3].

tool in the Tools toolbar. The

Refer to the following list to learn more about the options available in the Tool Properties view:

•
•
•
•
•
•
•
•
•
•
•

Hint Type, on page 310
Hide Hints, on page 310
Show Morphing in Place, on page 310
Suggest Hints, on page 310
Switch Between Drawings, on page 310
Flatten, on page 311
Quality, on page 311
Morphing Layers, on page 311
Easing, on page 311
Convert Hints, on page 311
Time, on page 311
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Hint Type
The Hint Type drop-down menu allows you to select the correct hint to remedy any problem
areas in your drawing.
NOTE:
You can have more than one hint type in your drawings. You can mix all of the hint types in
your morphing sequence.
Refer to the Morphing Tool and Hints topic to learn more about hint types.

•
•
•
•
•

The types of hints available in the menu are:
Contour Hint, on page 319
Zone Hint, on page 320
Pencil Hint, on page 320
Appearing Point Hint, on page 321
Vanishing Point Hint, on page 321

Hide Hints
The Hide Hints button temporarily hides the hint points from the key
drawings.
Use this option when you have a series of hint points hiding some lines you
would like to see.

Show Morphing in Place
The Show Morphing In Place option is used with Morphing Layers. Enabling this option prevents the currently selected
morphing layer from being shown on top of the others and maintains the correct layer ordering.
Refer to the Morphing Layers topic to learn more.

Suggest Hints
The Suggest Hints option is used to automatically set hint points on your key drawings as a help tool. If you are not
sure where to set your hints, you can use this option. It will set the main hints which you can then fine tune.

Switch Between Drawings
The Switch Between Drawings button is used to toggle between the two key drawings in your morphing sequence.
This option is useful while setting hints.
The default keyboard shortcut is [F4].
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Flatten
The Flatten option is used when you have to morph a sequence with a semi-transparent or transparent colour in it.
Refer to the Morphing Holes and Transparencies topic to know more about this option.

Quality
The Quality setting is used to make the lines of the morphed drawings smoother. Adjust this
parameter when you are doing an extreme close up of your animation.
Refer to the Adjusting the Morphing Quality topic to learn more.

Morphing Layers
The Morphing Layers option is used when working with Morphing Layers. You can
add, remove and manage your different morphing layers in this space.

Refer to the Morphing Layers (PRO) topic to learn more.

Easing
The Easing option is used to adjust the starting and ending velocity of your morphing
sequence so that the motion is smooth and not mechanical. You can adjust the Ease In and
Ease Out value by dragging your cursor up and down or typing a new value. The values go
from -1.0 to 1.0.
Refer to the Adjusting the Velocity and Timing topic to learn more.

Convert Hints
The Convert Hints option is used to switch the type of the current selecting hint points. This
option is useful when you position hints and then realize they are not the right type. You can
select them and convert them to the correct type instead of deleting them and setting new
ones.
Use the Morphing tool to select the hints and then convert them by going to the Tool Properties
and selecting the new hint type from the Convert Hints drop-down menu.

Time
The Time parameter is used to set the timing on Appearing Point and Vanishing Point hints. These
hints are used to set the trajectory of appearing and vanishing objects, they do not have to appear
or disappear from the first frame to the last frame of the morphing sequence. With the Time
parameter, select your Appearing Point or Vanishing Point hint and type the frame number on which
the object will start its animation.
Refer to the Appearing Point Hint topic to learn more.
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Adjusting the Velocity and Timing

Once you have established a morphing sequence, you can control its timing and velocity. When you look at your
animation you will notice that the morphing motion is constant. To produce a less mechanical motion, you will
probably want to create some ease in or ease out.
If you did not place your source and destination drawings on the correct frames you may need to extend or shrink the
sequence length.
This section covers the following topics:

•
•

Changing the Morphing Sequence Length, on page 312
Adjusting the Velocity, on page 312

Changing the Morphing Sequence Length
To extend or shrink a morphing sequence length:
1.
2.

In the Timeline View, select the source or destination drawing.
Click on your selection and drag the drawing to its new frame.

Adjusting the Velocity
Once the morphing length is correct, you can adjust the velocity in the Tool Properties view or in the layer’s editor.
This section is divided as follows:

•
•

Adjusting the Velocity in the Tool Properties View, on page 312
Adjusting the Velocity in the Layer Properties Editor, on page 313

Adjusting the Velocity in the Tool Properties View
To adjust the velocity in the Tool Properties view, you must first select the Morphing

tool.

Refer to the Morphing Tool and Hints topic to learn more.
To adjust the velocity in the Tool Properties View:
1.
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In the Tools toolbar, select the Morphing

tool. The default keyboard shortcut is [F3].
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2.

In the Timeline view, select one cell in your morphing sequence.

3.

In the Tool Properties view, click on the Ease In or Ease Out up or down arrows to adjust the velocity. You can
also enter values from -1.0 to 1.0 in the corresponding text field.

A real-time representation of the ease curve velocity is shown beside the text fields displaying the ease in and
ease out.

4.

In the Playback toolbar, click on the Play

button to preview the result.

Adjusting the Velocity in the Layer Properties Editor
If you have several morphing sequences on a single layer, you may find it easier to adjust their velocities on one
function curve rather than several separate ones. Having all of your velocity parameters in one place is more efficient
and easier to modify.
Adjusting the velocity in the Layer Properties Editor also allows you to reverse a section of the morphing sequence.
The sequence will always start with the source drawing and end at the destination. You can play the morphing
sequence backwards or forwards during the animation.
You can have two levels of easing. It is possible to adjust the velocity of each sequence in your layer independently
using the Tool Properties view and then adjust the morphing velocity function in the Layer Properties Editor to control
the entire layer’s easing.
To adjust the velocity in the layer’s editor:
1.

In the Timeline View, double-click on the drawing element module to open the Layer Properties Editor.

2.

In the Layer Properties Editor:



In Animate, go to the Advanced tab and click on the Function



In Animate Pro, go to the Drawing tab and click on the Function

button to create a function curve.
button to create a function curve.
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Refer to the following sections in the Creating Animation Paths chapter to learn more about creating
functions and the Function menu:
 Function Curves, on page 620
 Creating Function Curves, on page 620
 Sharing Functions, on page 621
 Function Drop-down Menu, on page 624
 Function Types, on page 625
3.

In the Layer Properties editor, click on the Function

4.

Add a keyframe at the first frame of the morphing (Source) and one at the end (Destination) by clicking on the
Add/Remove Keyframe

5.

button once more to open the velocity curve.

button.

Move the end keyframe up.
NOTE: It is important that the last keyframe remains above the first one.

6.
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Make sure that the first keyframe is NOT a Stop-Motion keyframe. To do this, uncheck the Stop-Motion
keyframe option to disable it. You can also select the last keyframe and use the keyboard shortcut [S] to use the
Toggle Stop-Motion Segment feature.
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7.

Click on the keyframes and pull the Bezier handles to create Ease in and Ease out. If you make the curve go
downward instead of upward, the animation will play backward until the curve starts to go upward again.

If you have more than one morphing sequence in the same layer, you need to add a keyframe on the velocity
curve for each source and destination drawings.
If you want your morphing to play back on a double frame exposure rather than single frame, you can use the
Hold Value editor and set the velocity to change every second frame instead of every frame.
In the Morphing Function editor, click on the Hold Value Editor
for two frames.

button and set the parameters to hold the value

Refer to Creating Animation Paths > Adjusting the Velocity, on page 633 to learn more about the Hold Value
option.
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Morphing Tool and Hints

Animate provides the Morphing
tool to control your morphing sequence, this works by placing different types of
hints to help the system morph the animation the way that you want it.
Hints are points which are placed in both the source and destination drawings, they associate zones and lines between
the two drawings. Hints are used to fix problem zones, such as a line that is not following the colour fill zone.

Corners and points generally give the most problems. The software does not necessarily understand the animation
curves and may be unable to match corners. It will generally associate a corner with the nearest one, this is not always
correct and it is why we use hint points to determine what goes with what.
This topic is divided as follows:

•
•
•
•
•
•
•
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Using the Morphing Tool, on page 317
Contour Hint, on page 319
Zone Hint, on page 320
Pencil Hint, on page 320
Appearing Point Hint, on page 321
Vanishing Point Hint, on page 321
Copying Hint Points from One Drawing to Another, on page 322
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Using the Morphing Tool
Hints are identification points existing in both the source and destination drawings to create associations between the
two of them.
To correct morphing distortions, Animate has different types of hints available for controlling different types of
problems:

•
•
•
•
•

Contour Hint
Zone Hint
Pencil Hint
Appearing Point Hint
Vanishing Point Hint

Each type of hint has a different purpose and they can all be used in the same drawing.
Use the Morphing tool to add hints to your morphing sequences. You can add different hints to your source and
destination drawings and combine all types of hints in the same drawing.
A hint will automatically appear in both the source and destination drawings when it is added. A hint cannot exist in
a single drawing. If you delete a hint from one drawing, it will be also deleted from the other.
The key to placing your hints is to put them where the biggest problem is. Fix the largest distortions first, this may
also fix the smaller ones at the same time.
Small bumps and distortions
are fixed at the same time
that zones 1 and 2 are fixed.

1
2
Do not add too many hints, this is a common mistake when morphing, it takes some practice to learn how to correctly
use and place hints.
To add and remove hints:
1.

In the Timeline or Xsheet View, select the source or destination drawing of your morphing sequence.

2.

In the Tools toolbar, select the Morphing

tool. The default keyboard shortcut is [F3].
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Use your other morphing key drawing, shown in the Drawing view’s bottom right corner, as a reference.

3.

In the Tool Properties view, select the type of hint you want to use.







Select Contour Hint to correct a brush line or colour zone’s contour (Contour vector).
Select Pencil Hint to correct a pencil line (Central vector).
Select Zone Hint to correct a colour zone morphing match.
Select Vanishing Point Hint to correct a vanishing shape’s trajectory.
Select Appearing Point Hint to correct an appearing shape’s trajectory.

Refer to the following topics to learn more about hint points:
Contour Hint, on page 319
Zone Hint, on page 320
Pencil Hint, on page 320
Appearing Point Hint, on page 321
Vanishing Point Hint, on page 321
In the Camera or Drawing View, click on the drawing near the area to add a hint.






4.
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5.

6.

Select the hint’s point and move it to its correct position.

Select one or many hints and press [Delete] to remove extra or unused hints.
To delete all of the hint points at once, use the default keyboard shortcut [Shift]+[Delete].



7.

In the Playback toolbar, press the Play

button to see the result.

Contour Hint

The Contour Hint is used on the colour fill zone and brush lines; in other words, on Contour vectors. It allows the
control of line thickness and contour position. Also, if a contour is not animated the way that it should be you can use
hints to correct the animation. For example, if a flag is not waving properly.
When adding a Contour Hint, make sure that you place it far enough away from the contour so that you can see it
snap to the contour.
NOTE: Do not place the Contour Hint directly on the line as it may look like it has snapped to the contour, when in
fact, it has not and the morphing will remain unchanged.
The Contour Hint points are yellow.
To correct a brush stroke, place a hint on both sides of the line to indicate its thickness variations over time.
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Zone Hint

The Zone Hint is used on a colour zone to control the proximity rule. The Zone Hint is placed in the centre of the colour
zone. Sometimes a colour zone is not associated with the corresponding one by default. For example, in a splash
animation there are many water droplets that are the same colour. The system automatically morphs the droplet to
the nearest one. This is not always correct. A Zone Hint will force a colour zone to morph with another one.
Zone Hint points are cyan in colour so you can easily see them.

Pencil Hint

A Pencil Hint is used to control a pencil line, also known as central vector. It can be used on drawings that were done
using the Pencil, Polyline, Ellipse, Line and Rectangle tools. Like the Contour Hint, the Pencil Hint snaps to the central
vector. Make sure to place it far enough away from the line so you will see it snap when you move it.
Pencil Hint points are magenta in colour so you can easily see them.
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Vanishing Point Hint

A Vanishing Point Hint is used to control the trajectory of a vanishing shape. A shape will vanish from the source
drawing when there is no corresponding shape in the destination drawing. If you do not place a Vanishing Hint to
control the point of disappearance, the shape will vanish into its centre.
Vanishing Hint points are green in colour so you can easily see them.

Appearing Point Hint

An Appearing Point Hint is used to control the trajectory of an appearing shape. A shape will appear in the destination
drawing when there is no corresponding shape in the source drawing. If you do not place an Appearing Hint to control
the point of appearance, the shape will appear from its centre and expand outwards.
Appearing Hint points are violet in colour so you can easily see them.
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Copying Hint Points from One Drawing to Another

If you have two morphing sequences that use the same drawing and you would like to copy it and its hint points, you
can do so in the Drawing view.
To copy a drawing and its hints:
1.

In the Tools toolbar, select the Select

2.

In the Drawing view, select the drawing you will reuse in your second morphing sequence. In the top menu,
select Edit > Copy.
The default keyboard shortcut is [Ctrl]+[C] (Windows) or [a]+[C] (Mac OS X).

3.

In the Timeline view, select the cell where the new drawing will be.

4.

In the Drawing view, paste your selection. In the top menu, select Edit > Paste. The default keyboard shortcut is
[Ctrl]+[V] (Windows) or [a]+[V] (Mac OS X).
In the Timeline view, select the cell where the second drawing will be.

5.
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tool. The default keyboard shortcut is [Alt]+[V].
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6.

In the Drawing or Camera view, draw your second drawing.

7.

In the Timeline view, create the morphing sequence for the new drawings. The default keyboard shortcut is
[Alt]+[M].

8.

In the Tools toolbar, select the Morphing

9.

In the Drawing or Camera view, position your hint points.

tool. The default keyboard shortcut is [F3].
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Morphing Layers (PRO)
Morphing layers simplify the morphing animation. Complex shapes are often too difficult to control and may not work
properly, by dividing the drawings into Morphing layers, the task becomes much easier.
The major points used in controlling a morphing sequence are the intersections. If there are many lines intersecting
within a drawing, the system will require more control. (Refer to the Morphing Hints section.)
An important aspect of morphing is to identify possible problem zones in order to fix them and avoid potentially
frustrating situations.

Identifying Problem Zones (PRO)

Simple details that look easy to morph can sometimes be more difficult than they may initially appear to be. For
example, you may find that the nose becomes problem when performing a head rotation. As explained earlier, the
drawings need to be similar in their amount of shapes. Generally, on a head rotation, the source nose is in the centre
of the face, but on the destination, the nose line is part of the face outline. This means that on the source drawing,
the nose and the face outline are two separate shapes, whereas they are combined into one shape on the destination
drawing.
Morphing a full face as demonstrated on the figure below will cause the source nose to slowly vanish as the destination
nose grows from the character’s cheek.
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Any shape that is contained inside another one and has to morph out of that shape will be a problem for the same
reasons as the nose is. At some point during the morphing sequence, the shape contained inside the face will merge
with the face outline, and then become a separate shape again.

Morphing Layer Properties (PRO)

It is because of these reasons, explained in the Identifying Problem Zones (PRO) section, that Morphing layers exist.
Morphing layers are all contained in the same Drawing layer. It is like having a mini Timeline within a Timeline layer,
or a mini Xsheet within an Xsheet column.
Each Morphing layer can have its own duration and velocity. Also, because you only have a single element to handle
in your Timeline or Xsheet View, it will be treated as one element for the Compositing process, making the
compositors work easier.
You could separate all of your elements into different actual drawing elements and have many layers, but you would
have to create a large number of morphing sequences and make sure that you modify all of their timings properly.
Both solutions are correct, but morphing layers makes it easier to handle and does not change the scene
structure by adding more elements which can be very important for Cut-out animation puppets. For example if you
need to morph a front head to a three-quarter head where the ear needs to be separated, you do not want to add a
new ear layer at the same time and have to worry about connecting it inside the puppet’s construction. Instead, simply
create an ear morphing layer within the head layer.
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Creating a Morph with Morphing Layers (PRO)
When you click on a Morphing layer drawing, it automatically appears on top of the other ones. If you want it to stay
in place, for example the wing behind the body, enable the Show Morphing in Place
Properties view.

option in the Morphing tool

Use a naming convention for each morphing layer such as ear_1, ear_2 or head_1, head_2. You can also use the
numbers 1 to 9 for the first layer, 10 to 19 for the second one, 20 to 29 for the third one and so one. This technique
is useful if you plan to do more than one morphing sequence in the same column. For example, front head to threequarter head to side head. The three-quarter drawings will be used in both morphing sequences.
To create a morph with morphing layers:
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1.
2.

In the Timeline, add a new drawing element and name it properly.
In the first cell, draw the main source shape such as the head shape or body shape. Do not add details like eyes.

3.

In the Timeline View, select the destination cell, then enable and extend the Onion Skin.
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4.

In the destination cell, draw the second drawing.

5.

In the Timeline view, select the in-between cells, right-click (Windows) or [Ctrl]-click (Mac OS X) and select
Morphing > Create Morphing. You can also use the keyboard shortcut [Alt]+[M].

6.

Select the Morphing

7.

In the Morphing Tools Properties view, click on the Add Layer

8.

Double-click on the new layer’s name and name it appropriately. Press [Enter].

9.

tool from the Animation tools toolbar.
button to add a new morphing layer.

Use the Up
and Down
arrow buttons to move the new layer above or below the Main layer.
If placed above the Main layer, it will be displayed in front. If it is placed below, it will be displayed behind.
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10. To create new drawings, double-click on the blank area under the From section to create the Source drawing
and the To section for the Destination drawing and type a value different than the ones used for the main layer.
Press [Enter].
 You do not need to type any value for the Main layer as it uses the one from the Xsheet column.

11. Click on the new Source drawing to start drawing the new part. Make sure that you are working on the proper
drawing by verifying the name in the Camera or Drawing View’s bottom left corner.

12. In the Camera or Drawing View, draw the Source drawing.

13. Once the Source drawing is done, use the Morphing tool Properties view and click on the Destination drawing’s
name and draw it in the Camera or Drawing View.
14. Repeat steps Step 7 to Step 13 for each layer needed. You can add as many layers as you want.
15. Enable or disable the layers that you want to display or hide while drawing.

16. If you want to change the layer duration, click on the layer and change the start and stop numbers.

The length indicator changes according to the new values.
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Morphing Two Sequences in a Row
1

2

If you are morphing two sequences in a row, you will have to create a different set of hint points for each sequence.
Morphing two sequences in a row requires three drawings: 1, 2 and 3. Using these three drawings you create two
morphing sequences; one sequence between drawings 1 and 2, and a second sequence between drawings 2 and 3.
Drawing 1

Drawing 2

Drawing 2

Drawing 3

Morphing Sequence 1

Morphing Sequence 2

NOTE: Each morphing sequence has its own set of parameters and hints. This means that Drawing 2 will have a
set of hints for the first sequence and another set for the second sequence. The two sets of hints will not show at the
same time. Each set of hints that appears always corresponds to the morphing sequence you are working on.
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Inserting a Morphing Key Drawing (PRO)
Original Morphing Sequence

Details are added on the second
morphing sequence

In-between drawing transformed into a Key Drawing

Once you have a morphing sequence, you can add a Morphing Key Drawing.
A Morphing Key Drawing allows you to insert extra details into a morphing sequence. For example, during a morphing
sequence you may need to insert a detail such as teeth or a mouth, which is easy to do when you use a Morphing Key
Drawing. Instead of creating an entirely new drawing, convert a computer generated in-between to a Morphing Key
Drawing and add your extra details to it and the next key drawing. A Morphing Key Drawing converts a computer
generated morphing frame into a real drawing that you can edit. It splits the morphing sequence into two sequences,
keeping your previous modifications.
To insert a morphing key drawing:
1.

2.

In the Timeline or Xsheet View, select the morphing frame you want to transform into a morphing keyframe.

Right-click (Windows) or [Ctrl]-click (Mac OS X) on your selection and select
Morphing > Insert Morphing Key Drawing.
 In the top menu, you can also select Animation > Morphing > Insert Morphing Key Drawing.
The new Morphing Key Drawing appears.
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3.

In the Drawing or Camera View, draw your new details on the Morphing Key Drawing.

4.

In the Playback toolbar, press the Play

button to see the result.
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Converting Morphing In-betweens to Drawings

Animate lets you convert your morphing in-betweens to real drawings that you can edit.
This is useful when you manually edit your morphing sequence or if you prefer to have your animation timing in double
frame instead of single frame.
To convert morphing in-betweens to drawings
1.

2.

In the Timeline or Xsheet View, select a morphed drawing in the morphing sequence you want to convert to real
drawing.

Right-click (Windows) or [Ctrl]-click (Mac OS X) on your selection and select
Morphing > Convert Morphing to Drawings.
 In the top menu, you can also select Animation > Morphing > Convert Morphing to Drawings.
The Converting Morph dialog box opens.

3.
4.

Type the drawing basename you want to give to your new drawings. In this case, you could type circle.
Click on the OK button.
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Morphing Holes and Transparencies
To be able to morph shapes with holes or transparent colours, it is important to understand the process of analyzing
and morphing a shape. Animate begins the process by reading the exterior outline of the entire shape. So if you are
morphing a doughnut, it will first read the entire circular shape and ignore the central hole.

Once the general morphing shape is analyzed, the system will carry on analyzing the interior details such as colour
zones and holes.

As you can see, because the hole was placed on top after the main shape was morphed, the centre is filled with an
opaque brown colour. In order to avoid opaque holes, you have to paint the zone with a transparent colour so that
you can control it and flatten the transparency to cut a hole through the main shape.
The same thing happens when you have holes painted with semi-transparent colours. To see through your shapes, you
have to follow the same process as morphing shapes with holes.
To morph a shape with a hole:
1.
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In your Colour View, select an unused colour swatch and set its alpha (transparency) to 0.
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2.

Paint both holes on the source and destination drawings.

Drawing 1

Drawing 2

3.

In the Timeline or Xsheet View, click on a cell in your morphing sequence.

4.

In the Tools toolbar, select the Morphing

5.

In the Tool Properties view, enable the Flatten

tool. The default keyboard shortcut is [F3].
option.

A hole appears in the shape.
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Adjusting the Morphing Quality
To improve the morphing quality, zoom in close to a morphing animation when compositing,.

Quality = 0.2

Quality = 6.0

Increasing the quality improves the line shape between vector points. It also creates a larger file, so only increase
quality when you are zooming in close.
To set a morphing sequence’s quality level:
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1.

In the Timeline or Xsheet View, click on a cell in your morphing sequence.

2.
3.

In the Tools toolbar, select the Morphing
tool. The default keyboard shortcut is [F3].
In the Tool Properties view, increase or decrease the quality level by dragging your cursor up or down. You can
also type a new value directly in the text field.
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Tips and Tricks
This section provides a list of easy tips and tricks to help you morph your drawings more efficiently.
This section is divided as follows:

•
•
•
•
•
•
•

Morphing Similar Shapes, on page 335
Avoiding Crossing Zones During Morphing, on page 335
Using the Brush Tool as a beginner, on page 335
Using the Contour Hint on Pencil Lines, on page 335
Flattening Drawings, on page 335
Cleaning-up your Drawings, on page 335
Using the Same Colour Swatch, on page 335

Morphing Similar Shapes
Similar shapes have the same number of colour zones. This only applies to the number of zones and lines and not the
number of points on a curve.

Avoiding Crossing Zones During Morphing
If a zone inside a larger zone on the source drawing ends up outside on the destination drawing, the morphing will fail.
A line cannot cross another line during a morphing sequence.
For example, if you are morphing a face so it turns from the front to the side, the nose is located in the middle of the
face on the source drawing. However if after morphing, the nose ends up outside or merged with the face profile line
on the destination drawing, this will give undesirable results.
In Animate Pro, you can avoid this by using morphing layers and splitting the nose on a separate layer.

Using the Brush Tool as a beginner
When learning morphing, it is recommended that you use the brush tool. You can use the pencil line for simple closed
shapes.

Using the Contour Hint on Pencil Lines
If you are using pencil lines, use the Contour Hints instead of the Pencil Hints. Use the Pencil Hint if you want the Pencil
line to switch direction such as upside-down.

Flattening Drawings
Flatten your drawing before starting a morphing sequence.

Cleaning-up your Drawings
If you leave a dot, even the smallest one, it is possible that your morphing will create odd shapes. If the source line is
closer to the dot than the destination line, the source line will morph into the dot and the destination line will
disappear.

Using the Same Colour Swatch
Use the same colour swatch between two drawings. You cannot morph between two different colour swatches even
if they have the same RGB values. This can be turned to your advantage for complex morphings.

335

Animate Pro 2 User Guide

Preferences (PRO)
To open the Preferences panel:





Windows: Select Edit > Preferences.
Mac OS X: Select Animate Pro > Preferences.
You can also use the default keyboard shortcut
[Ctrl]+[U] (Windows) or [a]+[U] (Mac OS X).

Drawing Tab (PRO)

Morphing Quality (PRO)
The Morphing Quality preference is used to set the default quality value for the morphing sequences. If this value is
changed, it will not affect the previously created morphing sequence.
Once a morphing sequence is created using this default value, it can be manually changed in the Morphing Tool
Properties.
Refer to Adjusting the Morphing Quality, on page 334 to learn more about morphing quality.
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Animate allows you to import external content as well as being able to draw directly in the software. This means that
characters, backgrounds and videos created in other drawing, painting and multi-media programs can be brought in
and animated. You can import QuickTime videos, pictures, multi-layered PSD files, as well as AI, SWF and PDF files.
You can also scan your images in with a scanner and either import them as bitmap or vectorize them.
In this chapter, you will learn about the following:

•
•
•
•
•
•
•
•
•
•
•
•

Importing Bitmap Images in Animate, on page 338
Importing Bitmap Images in Animate Pro, on page 344
Importing PSD Files as Separate Layers in Animate, on page 350
Importing PSD Files as Separate Layers in Animate Pro, on page 353
Importing AI and PDF Files, on page 361
Scanning Images in Animate, on page 355
Scanning Images in Animate Pro, on page 357
Importing from Adobe® Flash®, on page 363
Importing QuickTime Movies in Animate, on page 366
Importing QuickTime Movies in Animate Pro, on page 368
Custom Vectorization Parameters (PRO), on page 368
Preferences (PRO), on page 376
For sound import, refer to Working With Sound > Importing a Sound File, on page 564.
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Importing Bitmap Images in Animate

Images can come in many different file formats and are usually saved in a format that retains the original specifications
set by the image creator. Some formats are able to preserve transparency or transparent layers, while others are not
resolution dependent due to their vector nature. Animate supports the following formats: JPEG, BMP, PNG, TGA,
PSD, TIFF, SGI, TVG, OMF, PAL, SCAN, YUV.
In this section, you will cover the following topics:
Importing a Bitmap Image without Vectorization, on page 338
Importing and Vectorizing Images, on page 342

•
•

Importing a Bitmap Image without Vectorization
A bitmap image is an image composed of pixels that is both size and resolution-dependant.
To import a bitmap image:
1.

From the top menu select File > Import > Images. You can also click on the Import Images
button in the
File toolbar.
 In the Xsheet view, you can right-click (Windows) or [Ctrl]+click (Mac OS X) anywhere in the frame area and
select Import > Images.
The Import Drawings dialog box opens.
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2.
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In the Files section, click on the Browse button to find and select one or several images on your computer.
The selected image appears in the Preview space.
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3.

In the Layer section, you have the option of creating a new layer for your image or adding the image to an
existing layer.
 To create a new layer, select Layer > Create Layer(s) > Create Single Layer Named and name your layer
accordingly.
OR


OR



To create a new layer using the file name, select Layer > Create Layer(s) > Create Layer(s) Based on
Filenames.
To add the image to an existing layer, select Layer > Add to Existing Layer and select the layer already
created in your Animate scene from the drop-down menu. If only vector
layers are available in your
scene (and therefore the drop-down menu), you will either have to Vectorize Imported Items, Create
Symbols for imported Items or check both options to put your bitmap image on a vector layer.

Refer to Adding Images to a Bitmap Layer for more information.
NOTE: To mix bitmap images with vector drawings on the same layer, the bitmap image must be encapsulated
in a Symbol and vice versa. When you check the option Create Symbol for Imported Items, these Symbols will also
automatically be added to your Symbol Library.
4.

In this case, uncheck the Vectorize Imported Items option.
The Vectorization options are hidden and the Transparency section appears.

5.

In Animate, if you want your bitmap images to be encapsulated in a Symbol, enable the Create Symbol for
Imported Items option. If not, disable the option. If you chose to add your image to an existing vector layer
then the Create Symbol for Imported Items will automatically be checked and greyed out.
To learn more about Symbols, refer to the Libraries, Symbols and Templates chapter.

6.

Next, in the Alignment section, you must decide on the size and placement of your image within the camera
frame. Depending on the Scene Settings (the height and width in pixels that you chose for your project), an
image that you import may get scaled to the point where all its individual pixels become visible.

Be sure that you are in the Camera view’s Render Mode
appear blurry.

when judging an imported image, otherwise it may

The following three options are available:
Alignment > Rules > Fit
D If your image orientation is portrait format, this selection will enlarge or shrink (but not distort) to your
image’s height to match the full height of the camera frame.
D If your image orientation is landscape format, this selection will enlarge or shrink (but not distort) your
image’s size so that its width matches that of the camera frame.
 Alignment > Rules > Pan
This selection achieves the opposite result of the Fit command.
D If your image orientation is portrait, its width will be made to match the width of the camera frame. As
a result, part of the image’s height will extend beyond the height of the frame.
D If your image orientation is landscape, the image will extend beyond the width of the camera frame.
This can be useful if you want to make your background move up and down, or from left to right to make it
appear as if the camera is panning, or to actually perform a camera pan.
 Alignment > Rules > Project Resolution
This selection will scale the image up or down in proportion to the scene's resolution. It looks at the
resolution of the bitmap image, for example 4000 x 2000, then compares it to the scene's resolution, for
example 1920 x 1080 and adjusts the scale factor in proportion. So in this example the bitmap would
appear at 208% (4000/1920). If you import a bitmap that is 960 x 540 it will be displayed at 50% (960/1920)
of the size of the project resolution.
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7.

The last step is to decide on the image’s Transparency from the Alpha drop-down. For this, there are four
options available. These options deal with the way that the bitmap image will be antialiased, more specifically
the way that the pixels along the edge are blended in the RGBA (red, green, blue, alpha (transparent)) channels.

The options are:
Premultiplied with White
Individual pixels at the edge of an image are blended with white.
 Premultiplied with Black
Pixels at the edge of an image are blended with black.
 Straight
Pixels at the edge of an image are blended with black, white and greys.
 Clamp Colour to Alpha
Select this option if you want to premultiply the colour value with the alpha value. When the colour is
clamped to the alpha, the colour value cannot be higher than the alpha value. If you have a pixel of value
R=247, G=188, B=29 and the alpha is 50% (the image is 50% transparent), then the actual RGB value
outputs would be half of the amounts listed above.
8. Click on the OK button.



Adding Images to a Bitmap Layer
If you want to add more bitmap images to an existing bitmap layer:
1.

In the Timeline view, if the bitmap image is contained in a Symbol, double-click on the bitmap Symbol cell to
edit the Symbol. Otherwise, if the bitmap image is on a bitmap
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layer, leave it as is.

2.

If necessary, in the Timeline view, pull on the red bracket to extend the exposure.

3.

From the top menu, select File > Import > Images. You can also click on the Import Image

button.
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The Import Images dialog box opens.

4

5
6

4.
5.
6.
7.

Click on the Browse button to find and select one or several images on your computer.
The selected image appears in the Preview space.
In the Layer section, choose Layer > Add to Existing Layer and select the bitmap layer already created in your
Animate file from the drop-down menu.
Uncheck the Vectorize Imported Items option.
Click on the OK button.

Bitmap Image Quality
If the bitmap images that you have imported look blurry or slightly pixelated, follow the steps below to clean-up the
image. These steps will effect the quality of the preview in Camera view, but will have no effect on the final render.
1.
2.
3.

4.
5.
6.

In the Camera view, double-click on the bitmap image to enter its Symbol if the image is encapsulated or simply
select the bitmap image layer in the Timeline if it isn’t.
In the top menu, select View > Bitmap Image Quality or use the keyboard shortcut [Ctrl]+[Q] (Windows)
or [Alt]+[Q] (Mac OS X).
The Bitmap Image Quality dialog box opens.

Click and drag the Bitmap Image Quality slider to the right to improve the quality.
Click on the OK button.
If you are inside a Symbol, go to the top of the Camera View and click on “Top” to exit the Symbol and return to
your scene.
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Importing and Vectorizing Images

You can turn your images into vector drawings, while still maintaining the sketchiness of a pencil line or into vector
images with a bitmap fill. Both of these options can add life to an animation, which straight vectorization with
smoothing does not usually afford.
To import and vectorize a bitmap image:
1.

In the top menu, select File > Import > Images. Or click on the Import Image

button in the File toolbar.

The Import Images dialog box opens.
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2.

Click on the Browse button to find and select one or several images on your computer.
The selected image appears in the Preview space.
3. You now have the option of creating a whole new layer for your image or adding the image to an existing layer.
 To create a new layer, select Layer > Create Layer(s) > Create Single Layer Named and name your layer
accordingly.
OR


OR



To create a new layer using the file name, select Layer > Create Layer(s) > Create Layer(s) Based on
Filenames.
To add the image to an existing layer, select Layer > Add to Existing Layer and select the layer already
created in your Animate scene from the drop-down menu. If only vector
layers are available in your
scene (and therefore the drop-down menu), you will either have to Vectorize Imported Items, Create
Symbols for imported Items or check both options to put your bitmap image on a vector layer.
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NOTE: To mix bitmap images with vector drawings on the same layer, the bitmap image must be encapsulated
in a Symbol and vice versa. When you check the option Create Symbol for Imported Items, these Symbols will also
automatically be added to your Symbol Library.
4.

In this case, enable the Vectorize Imported Items option.

5.

Under the Vectorization section, decide whether you would like to import your image in colour or black and
white, or if you would like to add a new preset.
 Colour: this style vectorizes your image as a colourful bitmap texture within a vector frame.
 Black and White: this style vectorizes your drawings as a solid black line. This creates a 100% vector-based
drawing. You can customize the different settings levels:
D Threshold%: The Threshold value filters out noise in your images. Noise can be dirt or faint smudges
on your scanned images. For example, if your value is set to 70%, all colour values below 70% are
converted to white and ignored in the final image. If your value is set to 100%, only completely black
lines will be kept.
D Expand: Enter a value between 1 and 100 to thicken lines or the outer edges of the bitmap. Use this
option if your line art is too fine or pale so that their visibility is increased in the software.
D Smooth: Enter a value between 1 and 5 to set the smoothness level. Greater smoothness equals less
jaggedness and imperfections, but at a greater loss to detail.
6. Press Apply to make the current settings visible on your image in the Preview section. You can also check the
Auto Apply option to automatically apply the changes as you edit the vectorization parameters.

7.

Click on the Vectorized button to switch to the source version of the selected image in the preview section and
click on the Source button to switch to the vectorized version of the image in the preview section.

8.

Use the Scale slider to zoom in or out of your preview image.

The vectorized images are painted with the Vectorize Line colour swatch from the Colour Palette.
9.

Click on the OK button.

Black and White Preset

Colour Preset

You should now have a Symbol or new layer that contains the vector drawing. If your image is contained in a Symbol,
in order to edit the image, you must double-click on the image’s first cell in the Timeline view to enter the Symbol.
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Importing Bitmap Images in Animate Pro

Images can come in many different file formats and are usually saved in a format that retains the original specifications
set by the image creator. Some formats are able to preserve transparency or transparent layers, while others are not
resolution dependent due to their vector nature. Animate Pro supports the following formats: JPEG, BMP, PNG, TGA,
PSD, TIFF, SGI, TVG, OMF, PAL, SCAN, YUV.
In this section, you will cover the following topics:
Importing a Bitmap Image without Vectorization (PRO), on page 344
Importing and Vectorizing Images (PRO), on page 348

•
•

Importing a Bitmap Image without Vectorization (PRO)
A bitmap image is an image composed of pixels that is both size and resolution-dependant.
To import a bitmap image:
1.

From the top menu select File > Import > Images. You can also click on the Import Images
button in the
File toolbar.
 In the Xsheet view, you can right-click (Windows) or [Ctrl]+click (Mac OS X) anywhere in the frame area and
select Import > Images.
The Import Drawings dialog box opens.

2
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4
5
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2.
3.

In the Files section, click on the Browse button to find and select one or several images on your computer.
In the Layer section, you now have the option of creating a new layer for your image or adding the image to an
existing layer.
 To create a new layer, select Layer > Create Layer(s) > Create Single Layer Named and name your layer
accordingly.
OR


OR



To create a new layer using the file name, select Layer > Create Layer(s) > Create Layer(s) Based on
Filenames.
To add the image to an existing layer, select Layer > Add to Existing Layer and select the layer already
created in your Animate Pro scene from the drop-down menu. If only vector
layers are available in your
scene (and therefore the drop-down menu), you will either have to Vectorize Imported Items, Create
Symbols for imported Items or check both options to put your bitmap image on a vector layer.

Refer to Adding Images to a Bitmap Layer (PRO) for more information.
NOTE: To mix bitmap images with vector drawings on the same layer, the bitmap image must be encapsulated
in a Symbol and vice versa. When you check the option Create Symbol for Imported Items, these Symbols will also
automatically be added to your Symbol Library.
4.

In this case, uncheck the Vectorize Imported Items option.
The Vectorization options are hidden and the Transparency section appears.

5.

In Animate Pro, if you want your bitmap images to be encapsulated in a Symbol, enable the Create Symbol for
Imported Items option. If not, disable the option. If you chose to add your image to an existing vector layer
then the Create Symbol for Imported Items will automatically be checked and greyed out.

6.

Next, in the Alignment section, you must decide on the size and placement of your image within the camera
frame. Depending on the Scene Settings (the height and width in pixels that you chose for your project), an
image that you import may get scaled to the point where all its individual pixels become visible.

To learn more about Symbols, refer to the Libraries, Symbols and Templates chapter.

Be sure that you are in the Camera view’s Render Mode
appear blurry.

when judging an imported image, otherwise it may

The following three options are available:
Alignment > Rules > Fit
D If your image orientation is portrait format, this selection will enlarge or shrink (but not distort) to your
image’s height to match the full height of the camera frame.
D If your image orientation is landscape format, this selection will enlarge or shrink (but not distort) your
image’s size so that its width matches that of the camera frame.
 Alignment > Rules > Pan
This selection achieves the opposite result of the Fit command.
D If your image orientation is portrait, its width will be made to match the width of the camera frame. As
a result, part of the image’s height will extend beyond the height of the frame.
D If your image orientation is landscape, the image will extend beyond the width of the camera frame.
This can be useful if you want to make your background move up and down, or from left to right to make it
appear as if the camera is panning, or to actually perform a camera pan.
 Alignment > Rules > Project Resolution
This selection will scale the image up or down in proportion to the scene's resolution. It looks at the
resolution of the bitmap image, for example 4000 x 2000, then compares it to the scene's resolution, for
example 1920 x 1080 and adjusts the scale factor in proportion. So in this example the bitmap would
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7.

appear at 208% (4000/1920). If you import a bitmap that is 960 x 540 it will be displayed at 50% (960/1920)
of the size of the project resolution.
The last step is to decide on the image’s Transparency from the Alpha drop-down. For this, there are four
options available. These options deal with the way that the bitmap image will be antialiased, more specifically
the way that the pixels along the edge are blended in the RGBA (red, green, blue, alpha (transparent)) channels.

The options are:
Premultiplied with White
Individual pixels at the edge of an image are blended with white.
 Premultiplied with Black
Pixels at the edge of an image are blended with black.
 Straight
Pixels at the edge of an image are blended with black, white and greys.
 Clamp Colour to Alpha
Select this option if you want to premultiply the colour value with the alpha value. When the colour is
clamped to the alpha, the colour value cannot be higher than the alpha value. If you have a pixel of value
R=247, G=188, B=29 and the alpha is 50% (the image is 50% transparent), then the actual RGB value
outputs would be half of the amounts listed above.
8. Click on the OK button.



Adding Images to a Bitmap Layer (PRO)
If you want to add more bitmap images to an existing bitmap layer:
1.

In the Timeline view, if the bitmap image is contained in a Symbol, double-click on the bitmap Symbol cell to
edit the Symbol. Otherwise, if the bitmap image is on a bitmap
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layer, leave it as is.

2.

If necessary, in the Timeline view, pull on the red bracket to extend the exposure.

3.

From the top menu, select File > Import > Images. You can also click on the Import Image

button.
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The Import Images dialog box opens.
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4.
5.
6.
7.

Click on the Browse button to find and select one or several images on your computer.
In the Layer section, choose Layer > Add to Existing Layer and select the bitmap layer already created in your
Animate Pro file from the drop-down menu.
Uncheck the Vectorize Imported Items option.
Uncheck the Create Symbol for Imported Items option.

8.

Click on the OK button.

Bitmap Image Quality (PRO)
If the bitmap images that you have imported look blurry or slightly pixelated, follow the steps below to clean-up the
image. These steps effect the quality of the preview in Camera view, but have no effect on the final render.
1.

3.

In the Camera view, double-click on the bitmap image to enter its Symbol if the image is encapsulated or simply
select the bitmap image layer in the Timeline if it isn’t.
In the top menu, select View > Bitmap Image Quality or use the keyboard shortcut [Ctrl]+[Q] (Windows)
or [Alt]+[Q] (Mac OS X).
The Bitmap Image Quality dialog box opens.

4.
5.

Click and drag the Bitmap Image Quality slider to the right to improve the quality.
Click on the OK button.

2.
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6.

If you are inside a Symbol, go to the top of the Camera View and click on “Top” to exit the Symbol and return to
your scene.

Importing and Vectorizing Images (PRO)

You can turn your images into vector drawings, while still maintaining the sketchiness of a pencil line or into vector
images with a bitmap fill. Both of these options can add life to an animation, which straight vectorization with
smoothing does not usually afford.
To import and vectorize a bitmap image:
1.

In the top menu, select File > Import > Images. Or click on the Import Image

button in the File toolbar.

The Import Images dialog box opens.

2
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2.
3.

Click on the Browse button to find and select one or several images on your computer.
You now have the option of creating a whole new layer for your image or adding the image to an existing layer.
 To create a new layer, select Layer > Create Layer(s) > Create Single Layer Named and name your layer
accordingly.
OR


OR



To create a new layer using the file name, select Layer > Create Layer(s) > Create Layer(s) Based on
Filenames.
To add the image to an existing layer, select Layer > Add to Existing Layer and select the layer already
created in your Animate Pro scene from the drop-down menu. If only vector
layers are available in your
scene (and therefore the drop-down menu), you will either have to Vectorize Imported Items, Create
Symbols for imported Items or check both options to put your bitmap image on a vector layer.
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NOTE: To mix bitmap images with vector drawings on the same layer, the bitmap image must be encapsulated
in a Symbol and vice versa. When you check the option Create Symbol for Imported Items, these Symbols will also
automatically be added to your Symbol Library.
4.

In this case, enable the Vectorize Imported Items option.

5.

Under the Vectorization section, decide whether you would like to import your image in colour or black and
white, or if you would like to add a new preset.

OR




Black and White: this style vectorizes your drawings as a solid black line. This creates a 100% vector-based
drawing.
Colour: this style vectorizes your image as a colourful bitmap texture within a vector frame.



New Preset: the New Preset option or button allows you to create your own custom vectorization
parameters via the Vectorization Parameters interface.
The Vectorization Parameters dialog box will open automatically once you click on this button.



Delete Preset: the Delete Preset button allows you to delete any preset available in the list.

You can double-click on any of the presets at any time to open the Vectorization Parameters dialog box to
customize your option.
The vectorized images are painted with the Vectorize Line colour swatch from the Colour Palette.
Refer to the Custom Vectorization Parameters (PRO) section to learn more about the custom parameters.
6.

Click on the OK button.

Black and White Preset

Colour Preset

You should now have a Symbol or new layer that contains the vector drawing. If your image is contained in a Symbol,
in order to edit the image, you must double-click on the image’s first cell in the Timeline view to enter the Symbol.
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Importing PSD Files as Separate Layers in Animate

PSD files (a format exportable exclusively from Adobe® Photoshop®) are unique in that they are able to retain multiple
layers. This is advantageous as the image remains fully editable in terms of any colour correction, effects, masking,
transparency or compositing that were made to the PSD file in Adobe® Photoshop®.
To import the separated layers of a PSD file:
1.

Organize your Adobe® Photoshop® file so that all your layers are “grouped” into individual folders, or that all
the elements you want to import as a single layer in Animate Pro are grouped together in their own folder. Any
layer that is not in a folder group, by itself or otherwise, will not be imported into Animate Pro.

2.

In Animate Pro, go to the top menu and select File > Import > Images. You can also click on the Import Image
button.
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The Import Drawings dialog box opens.
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3.
4.
5.

Click on the Browse button to find and select the PSD image on your computer.
The selected image appears in the Preview space.
Select Layer > Create Layer(s) > Create Single Layer Named or Create Layer(s) Based on Filenames.
Decide whether to check or uncheck the Vectorize Imported Items option.
If you decide to Vectorize Imported Items, please refer to Importing and Vectorizing Images to learn more
about Vectorization settings.

6.
7.

If you decide to disable the Vectorize Imported Items options the Transparency and Alignment settings will
appear in place of the Vectorization settings. Please refer to Importing a Bitmap Image without Vectorization to
learn more about these settings.
Enable or disable the Create Symbol for Imported Items if you want your layers to be contained in Symbols or
not.
Click on the OK button.
The Multilayer Image Import Settings dialog box opens.

8.

In the Image to Load field, select
Composite Image to flatten your layers.
All Layers Image to keep your layers separated.
9. Select the Transparency Type if applicable. Refer to the Importing a Bitmap Image without Vectorization section
to learn more the different Transparency Type options.
10. Click on the OK button.




Your image should appear as separate layers in the Timeline view, corresponding to the PSD layer group folders.
The artwork displayed in every one of your layers as a result of a multilayer PSD file import, are linked to the
same source image. This means that if you use the command Drawing > Delete Selected Drawings to physically
351
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delete the drawing from the project folder, the exposed drawing will be deleted in every of the layers at once. Once
deleted from the project folder, the image can not be retrieved unless you re-import your PSD file.
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Importing PSD Files as Separate Layers in Animate Pro

PSD files (a format exportable exclusively from Adobe® Photoshop®) are unique in that they are able to retain multiple
layers. This is advantageous as the image remains fully editable in terms of any colour correction, effects, masking,
transparency or compositing that were made to the PSD file in Adobe® Photoshop®.
To import the separated layers of a PSD file:
1.

Organize your Adobe® Photoshop® file so that all your layers are “grouped” into individual folders, or that all
the elements you want to import as a single layer in Animate are grouped together in their own folder. Any layer
that is not in a folder group, by itself or otherwise, will not be imported into Animate.

2.

In Animate, go to the top menu and select File > Import > Images or click on the Import Image

button.

The Import Drawings dialog box opens.
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3.
4.
5.

Click on the Browse button to find and select the PSD image on your computer.
Select Layer > Create Layer(s) > Create Single Layer Named or Create Layer(s) Based on Filenames.
Decide whether to check or uncheck the Vectorize Imported Items option.
If you decide to Vectorize Imported Items, please refer to Importing and Vectorizing Images (PRO) to learn
more about Vectorization settings.

6.
7.

If you decide to disable the Vectorize Imported Items options the Transparency and Alignment settings will
appear in place of the Vectorization settings. Please refer to Importing a Bitmap Image without Vectorization
(PRO) to learn more about these settings.
Enable or disable the Create Symbol for Imported Items if you want your layers to be contained in Symbols or
not.
Click on the OK button.
The Multilayer Image Import Settings dialog box opens.

8.

In the Image to Load field, select
Composite Image to flatten your layers.
All Layers Image to keep your layers separated.
9. Select the Transparency Type if applicable. Refer to the Importing a Bitmap Image without Vectorization (PRO)
section to learn more the different Transparency Type options.
10. Click on the OK button.




Your image should appear as separate layers in the Timeline view, corresponding to the PSD layer group folders.
The artwork displayed in every one of your layers as a result of a multilayer PSD file import, are linked to the
same source image. This means that if you use the command Drawing > Delete Selected Drawings to physically
delete the drawing from the project folder, the exposed drawing will be deleted in every of the layers at once. Once
deleted from the project folder, the image can not be retrieved unless you re-import your psd file.
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Scanning Images in Animate

Animate can receive images from any TWAIN device, such as scanners and digital cameras. These images can either
be loaded as bitmaps into your scene or converted into vector-based images that can be edited using Animate.
If your operating system does not automatically recognize your device after it has been plugged in, you must install
the TWAIN drivers in order to access its contents. You can usually download the drivers from the device manufacturer’s
website.
NOTE: TWAIN drivers are not always created for every model of scanner or digital camera. If TWAIN drivers do
not exist for your device, you will not be able to use it with Animate.
You can scan in a single image or multiple images in the same session. Before you begin scanning, you need to select
your scanning device.
To scan drawings from a TWAIN device:
1.

In the Top Menu, select File > Acquire > From TWAIN or use the keyboard shortcut [Ctrl]+[Shift]+[A] (Windows)
or a+[Shift]+[A] (Mac OS X).
The Acquire from TWAIN dialog box opens.
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2.
3.

4.

5.
6.

7.

8.

9.

Select a device from the list.
You can import the scanned images into an existing layer or create a new one.
 To import the image into a new layer, enable the Create Layer option. In the Name field, type a name for
the layer.
 To import the image into an existing layer, select Add to Existing Layer and select the layer from the dropdown list.
Decide if you want to Vectorize or not the scanned images. If you want to vectorize the scanned images, select
the Vectorize Acquired Items option and choose the parameters from the Vectorization section:
 Colour: this style vectorizes your image as a colourful bitmap texture within a vector frame.
 Black and White: this style vectorizes your drawings as solid black lines and shapes. This creates a 100%
vector-based drawing. Use the filters listed below to transform the bitmap into vector art.
If you select this option customize the parameters below:
D Threshold percentage: The Threshold value filters out noise in your images. Noise can be dirt or faint
smudges on your scanned images. For example, if your value is set to 70%, all colour values below 70%
are converted to white and ignored in the final image. If your value is set to 100%, only completely
black lines will be kept.
D Expand: Enter a value between 1 and 100 to thicken lines or the outer edges of the bitmap. Use this
option if your line art is too fine or pale so that their visibility is increased in the software.
D Smooth: Enter a value between 1 and 100 to set the smoothness level. Greater smoothness equals less
jaggedness and imperfections, but at a greater loss to detail.
Decide if you would like to encapsulate the scanned drawings into individual Symbols. These Symbols will also
appear in your Symbols Library. If not, uncheck the Create Symbol for Acquired Items option.
Click on the Apply button. Check the Auto Apply box to continually and automatically update your most current
settings at the Preview level. The auto-apply is simply for preview purposes. If you do multiple scans, the
vectorization parameters used on the first scan in the set are the ones that will be applied throughout, even if
the preview does not show the image vectorized.
Click on the Preview button.
The scanning dialog box for your TWAIN device opens. To do a preview inside the Animate interface you will
need to do an actual scan in the TWAIN device’s interface. Previewing in just the TWAIN does not send any
information to Animate. Use the settings in that box to launch a scan. When the scan is complete, if the device’s
window does not close automatically, close it. The image preview now appears in the preview area of the
Acquire from TWAIN dialog box in Animate.
If you chose the Vectorize option, the Source/Vectorize toggle now becomes active. Use this button to toggle
between the image as it has been vectorized using the settings in the Parameters section and the original,
source image. Use the slider to increase or decrease the preview size in order to check and compare the two
images for accuracy.
Click on the Scan button to open the scanning dialog box for your TWAIN device.

10. Use the settings from your scanner to scan your drawings. You can close the TWAIN device’s scanning dialog
box at any time and readjust your vectorization parameters in Animate’s Acquire from TWAIN dialog box. You
can also scan multiple images with your device before closing the Acquire from TWAIN dialog box.
11. To automatically import the scanned images into your scene, exit the TWAIN device scanning interface.
12. Click on the Close button to close the Acquire from TWAIN dialog box.
13. The scanned image(s) appears in the centre of your camera frame and fitted with the height of the camera
frame.
Once all the animation layers have been scanned in, you can proceed to set the timing for these scanned images in
the Timeline or Xsheet view.
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Scanning Images in Animate Pro

Animate Pro can receive images from any TWAIN device, such as scanners or digital cameras. These images can either
be loaded as bitmaps into your scene or converted into vector-based images that can be edited using Animate Pro.
If your operating system does not automatically recognize your device after it has been plugged in, you must install
the TWAIN drivers in order to access its contents. You can usually download the drivers from the device manufacturer’s
website.
NOTE: TWAIN drivers are not always manufactured for every model of scanner or digital camera. If TWAIN
drivers do not exist for your device, you will not be able to use it with Animate.
Once all the animation layers are scanned in, you can proceed to set the timing in the Timeline or Xsheet view.
You can scan in a single image or multiple images in the same session. Before you begin scanning, you need to set all
your scanning parameters.
To scan drawings from a TWAIN device:
1.

In the Top Menu, select File > Import > From Scanner.
The Scan Drawings window opens.
4
2

3
9
10
11

12

13
14

2.

Select your scanner or other supported TWAIN device from the drop-down menu. If none are available, check
your device to ensure that it is properly connected to your computer. If your device still does not appear in the
drop-down menu, you may have to shut down and relaunch the software.
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3.

You can import the images to scan into an existing layer or create a new one.

To import the image into a new layer, enable the Create Layer option. In the Name field, type a name for
the layer.
 To import the image into an existing layer, select Add to Existing Layer and select the layer from the
drop-down list.
4. In the Scanner section, click on the Scan button to open the scanning dialog box for your scanner.



5.

Use the settings from your scanner to scan your drawings.
NOTE: You must scan in colour if you want to import your images as vectorized textures (mix of vector and
bitmap) and in black and white if you want a solid black outline.

6.

You can scan multiple drawings with your scanner before returning to the Scan Drawings dialog box.
Close the scanner dialog box when you are done.
The Scanner Album opens.

7.
8.

Use the Scanner Album to preview the scanned drawings, remove drawings from the list or change their order.
Animate Pro will load the drawings based on their order in the Scanner Album.
Click on the Close button to close the Scanner Album when you are done.

You will return to the Scan Drawings dialog box.
9. If you want to vectorize the images you import, select the Vectorize Imported Items option.
10. If you want the imported images to be encapsulated in a Symbol, enable the Create Symbol for Imported Items
option.
11. In the File Format drop-down list, select the file format in which you want to scan your drawings. If you chose to
vectorize the images as black and white, SCAN is the best file format to choose.
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12. If you chose to Vectorize your images, in the Vectorization section, decide whether you would like to import
your image in colour, black and white, or if you would like to add a new preset.

OR




Black and White: this style vectorizes your drawings as a solid black line. This creates a 100% vector-based
drawing.
Colour: this style vectorizes your image as a colourful bitmap texture within a vector frame.



New Preset: the New Preset option or button allows you to create your own custom vectorization
parameters via the Vectorization Parameters interface.
The Vectorization Parameters dialog box will open automatically once you click on this button.



Delete Preset: the Delete Preset button allows you to delete any preset available in the list.

Refer to the Custom Vectorization Parameters (PRO) section to learn more about the custom parameters.
13. If you choose NOT to Vectorize your images, then you must decide on the size and placement of your image
within the camera frame.
NOTE: Depending on the Scene Settings (the height and width in pixels that you chose for your project), any
image that you import may be scaled to the point where all its individual pixels become visible.

The following three options are available:
Alignment > Rules > Fit
D If your image orientation is portrait, this selection will scale up or shrink (but not distort) your image’s
height to match the full height of the camera frame.
D If your image orientation is landscape, this selection will scale up or shrink (but not distort) your image’s
size so that it’s width matches that of the camera frame.
 Alignment > Rules > Pan
This choice will perform the opposite operation of the Fit command.
D If your image orientation is portrait, its width will be made to match the width of the camera frame. As
a result, part of the image’s height will extend beyond the height of the frame.
D If your image orientation is landscape, the image will extend beyond the width of the camera frame.
This can be useful if you want to make your background move up and down, or from left to right to make it
appear as if the camera is panning, or to actually perform a camera pan.
 Alignment > Rules > Project Resolution
This selection will scale the image up or down in proportion to the scene's resolution. It looks at the
resolution of the bitmap image, for example 4000 x 2000, then compares it to the scene's resolution, for
example 1920 x 1080 and adjusts the scale factor in proportion. So in this example the bitmap would
appear at 208% (4000/1920). If you import a bitmap that is 960 x 540 it will be displayed at 50% (960/1920)
of the size of the project resolution.
14. The last step is to decide on the image’s transparency. For this, there are four options available. These options
deal with the way that the bitmap image has been antialiased; in other words, the edge blending that has been
used to transitions between RGBA (red, green, blue, alpha (transparent)) channels.
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The options are:
Premultiplied with White
Individual pixels at the edge of an image are blended with white.
 Premultiplied with Black
Pixels at the edge of an image are blended with black.
 Straight
Pixels at the edge of an image are blended with black, white and greys.
 Clamp Colour to Alpha
Select this option when you want to premultiply the colour value with the alpha value. When the colour is
clamped to the alpha, the colour value cannot be higher than the alpha value. It calculates the real colour
value faster. When the RGB values are multiplied with the alpha value, that is to say, if you have a pixel of
value R=247, G=188, B=29 and the alpha is 50% or the image has a 50% transparency, then the actual RGB
values output would be half of the amounts listed above.
15. Click on the OK button to import the images into your scene.



Refer to Drawing and Animating > Cleaning Scanned Drawings (PRO), on page 171 to learn more about cleaning
scanned drawings.
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Importing AI and PDF Files

You can import AI and PDF files into Animate, it will convert your files to the Toon Boom format (TVG) and create a
colour palette based on the colour settings of the original file.
To import an AI or PDF file:
1.

Go to the Library view and right-click (Windows) or [Ctrl]+click (Mac OS X) on the Animate Library folder. Choose
Right to Modify to unlock the library folder. Make sure the Lock icon disappears from the folder to unlock it,
otherwise your library will remain locked and not editable.
NOTE: the option to import will not be available until this step is completed successfully.

For more information about the Library, see the Libraries, Symbols and Templates chapter.
2.

3.

In the top menu, select File > Import > SWF, Illustrator Files to Library. Or right-click (Windows) or [Ctrl]+click
(Mac OS X) on any unlocked folder and select Import FIles.
The browser window opens.
Find and select your AI file in the Import Files dialog box and click on Open.
The Rename dialog box opens.

4.
5.

Enter a name for the new template or keep the name of the original AI or PDF file.
Click on the OK button.
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6.

Click and drag the new template folder from the Library view to the left side of the Timeline view; wait until the
copy cursor

7.

appears before releasing the mouse button.

The colour recovery dialog box appears, requesting that a colour recovery should occur. Before clicking on the
Yes button, you have the option to select the Do Not Ask Again For This Session option. This might be useful if
you plan to import multiple AI drawings.

This process will import the colour palette used to create the Illustrator file and create a new palette in Animate
under the imported file’s name.
For Animate Pro, refer to the Preferences (PRO) section to learn about the Support CMYK in
PDF/Illustrator Import preferences.
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Importing from Adobe® Flash®

Projects started in Adobe® Flash® that might need a more professional boost, such as camera movements or
multiplaning, can easily be imported into Animate. The actual *.fla file is not supportable, so you have to export
your project to an *.swf movie.
To import a Flash file:
1.

Go to the Library view and right-click (Windows) or [Ctrl]+ click (Mac OS X) on the Animate Library folder.
Choose Right to Modify to unlock the library folder. Make sure the Lock icon disappears from the folder to
unlock it, otherwise your library is locked and not editable.
NOTE: the option to import will not be available until this step is completed successfully.

For more information about the Library, see the Libraries, Symbols and Templates chapter.
2.

3.

In the top menu, select File > Import > SWF, Illustrator Files to Library.
You can also right-click (Windows) or [Ctrl]+click (Mac OS X) on any unlocked folder and
select Import FIles.
The browser window opens.
Find and select your .swf file in the Import Files dialog box and click on Open.
The Rename dialog box opens.

4.
5.

Enter a name for the new template or keep the name of the original *.swf file.
Click on the OK button.
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6.

Click and drag the new template folder from the Library view to the left side of the Timeline view; wait until the
copy cursor

7.

appears before releasing the mouse button.

The colour recovery dialog box appears, requesting that a colour recovery should occur. Before clicking on the
Yes button, you have the option of selecting the Do Not Ask Again For This Session option. This might be useful
if you plan to import multiple *.swf movies.

This process will import the colour palette used to create the Flash file and create a new palette in Animate under
the imported file’s name.
NOTE: All the Flash layers are automatically attached to a parent peg called GlobalFlashPeg.
DO NOT DELETE THIS PEG. To maintain the look of your movie, it is important that this peg is not deleted, nor
its child layers detached.
The layers of your Flash file should now appear in the Timeline view. Symbols that were created in Adobe® Flash®
become regular drawing layers, but can be reconverted into Symbols in Animate. Symbols within Symbols or drawings
within Symbols collapse into their corresponding parent Symbol.
NOTE: Some of the layers contained in your SWF movie could end up being combined in one single layer as a
result of optimization enhancement in your movie file. You can easily bring back these elements on separate layers.
Refer to the Distribute To Layers section to learn how.
In addition, all drawing elements that are dynamically linked to the Animate file are grouped together in one folder.
This means that when you scroll through the Drawing Substitution preview in the Library view, the different hand, leg,
tentacles, antennae, torso and facial positions are all organized together.
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Distribute To Layers
In some instances, due to an optimization enhancement in the exported SWF file (CS4), some of the layers might be
combined together as a single layer. In that case, use the Distribute to Layers feature to quickly redistribute these
elements onto individual layers again.
To distribute to layer:
1.

In the Tools toolbar, click on the Select

2.

In the Camera view, select the drawing you want to redistribute the elements from. Use the keyboard shortcut
[Ctrl]+[A] (Windows) or [a]+[A] (Mac OS X) to select the all the elements of the selected drawing layer.

tool.

3.

From the top menu, select Drawing > Distribute to Layers. You can also click on the Distribute to Layers
button in the Select tool’s Tool Properties view.

The number of drawing layers corresponding to the different grouped elements are created in the Timeline
view.
 The selected elements in the original drawing layer will be removed.
 Each element will be distributed into each new Drawing layer.
4. Repeat the process for every drawing you need to distribute the element from.
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Importing QuickTime Movies in Animate

When creating an animation, it is not unusual to embed moving elements saved as videos within the animation.
Animate allows you to import QuickTime movies into your project.
To Import a QuickTime movie:
1.
2.

In the top menu, select File > Import > Movie.
Browse for the QuickTime movie to import and click on the Open button.
A progress bar appears.

The Import Drawings dialog box opens.
Do not browse for the movie file again; leave the automatically generated field text as “many files selected.”
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Note that no preview appears in the Preview space of the Import Images dialog box when you import a movie.
3.

If you decide not to vectorize the images sequence, make your decisions for the Layer, Alignment and
Transparency.

Refer to the Importing a Bitmap Image without Vectorization section for further details about the Import
Drawings dialog box.
4.

If you decide to vectorize the images sequence, make your decisions for the Layer, vectorization type and
parameters.

5.

Click on the OK button.

Refer to the Importing and Vectorizing Images section for further details about the Import Drawings dialog box.
The QuickTime video appears in the Timeline view as an image sequence. You should be able to scroll through the
film frame-by-frame, just as you would scroll through your animation drawing-by-drawing.
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Importing QuickTime Movies in Animate Pro

When creating an animation, it is not unusual to embed moving elements saved as videos within the animation.
Animate allows you to import QuickTime movies into your project.
To Import a QuickTime movie:
1.
2.

In the top menu, select File > Import > Movie.
Browse for the QuickTime movie to import and click on the Open button.
A progress bar appears.

The Import Drawings dialog box opens.
Do not browse for the movie file again; leave the automatically generated field text as “many files selected.”

3.

Make your decisions for the Layer, Alignment and Transparency.

Refer to the Importing a Bitmap Image without Vectorization (PRO) section for further details about the Import
Drawings dialog box.
4.

Click on the OK button.

The QuickTime video appears in the Timeline view as an image sequence. You should be able to scroll through the
film frame-by-frame, just as you would scroll through your animation drawing-by-drawing.

Custom Vectorization Parameters (PRO)
You can create your own vectorization settings with Animate. The vectorization parameters you will create here can
be saved and shared.
You can use an interface to select and test the different options and you can also type in some advanced settings.
To open the Vectorization Parameters dialog box:
1.
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Select File > Import > Images.
You can also open it from any other Import option that allows you customization of the vectorization parameters
(i.e. From Scanner).
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2.

Browse for and select your file and decide on your Layer options.

3.

In the Vectorization section, click on the

Add New Preset button.

The Vectorization Parameters dialog box appears.
Refer to the Options Tab and Help Tab sections to find out more about the settings contained in this
window.
Refer to the Creating a Vectorization Style section to learn more about creating a style with this window.

Options Tab
The options tab contains the main vectorization settings. More settings are available in the Help tab.

Input
The input filters are applied to the bitmap image before it is vectorized.

•

One Pass and Two Passes:
D If you select one pass, one threshold value will be applied to both the Line and Colour Art.
• For drawings with distinct vector-style lines of mattes, you only need one pass.
D If you select two passes, you can apply a different threshold value to each layer.
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•

•
•
•

For greyscale drawings, you may want to pass through the vectorization process twice to apply
different threshold values to the Line and Colour Art layers.
Threshold: Determines which values in the scanned image are considered part of the Line or Colour Art
layer and what will be eliminated from the vectorized drawing, 0% (zero) is white and 100% is black. The
threshold is between those two values.
Expand Bitmap: Enter a value to scale the bitmap to detect small variations in the line. Use this option if
you scanned a greyscale image and want to preserve small variations in the texture that will be applied to
the line art.
Jag Filter: Enter a value to scale back the bitmap to remove some of the line’s roughness. If you have a
drawing that appears quite rough, use the jag filter to eliminate excess strokes in the final drawing.

Output
The output filters are applied during the vectorization process.

•
•
•
•

No Colour Art: Does not generate filling zones in the Colour Art layer.
No Texture: Does not generate texture in the Line Art in the final images. Select this option to create solid
lines in the final Line Art.
Generate Matte in Underlay Layer: Creates an opaque zone behind your drawing’s lines to avoid seeing
through the layers.
Colour as Texture: Converts colour values into a texture layer.

Optical Registration
The optical registration options are used to automatically align drawings based on the position of peg holes on the
animation paper. The peg holes must appear in the scanned drawings for the optical registration to work.

•
•
•
•

•

Optical Registration: Use peg holes to align drawings optically.
DPI: Type the dots-per-inch value of your image.
Peg Side: Select the position of the peg holes on your drawings. Identify whether they are on the top,
bottom, left or right.
Strictness: Determine how exact the location of the peg holes must be for the software to recognize them.
You have two values to choose from:
D Strict: The peg holes must be in a tightly defined area to be recognized.
D Loose: The peg holes can be recognized somewhere in a larger area. This is the recommended setting.
Field Chart: Select 12 or 16 to indicate the size of your animation paper.

Post Processing
The Post Processing filters are applied to the final vector images.

•
•
•
•

Remove Holes: Removes holes of a specified value that might make painting difficult.
Remove Dirt: Removes stray marks and dirt of a specified value. Try a value around 500.
Remove Hair: Removes small strokes that have no line art.
Remove Hair: Number of Passes: The number of times the drawing will be analyzed to identify hair marks.

Miscellaneous
•
•
•

Close gaps: Closes gaps in the Colour Art so that you can paint it.
Smooth passes for Line Art before breaking triangles: The number of times the smoothing operation runs
before creating the triangles that break lines in your drawing. If unnecessary triangles are appearing in your
drawing, increase this value.
Smooth passes for Line Art: The number of times the smoothing operation is performed after the triangles
have been created. This further smooths the Line Art.

Preview
•
•
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Show strokes: Shows the strokes in the Vectorized Image panel.
Stroke thickness: Shows the size of the strokes.
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Help Tab
The Help tab contains the most advanced vectorization settings. You must type those in the Advanced Option fields
located at the bottom of the Options tab.

File IO Options
-file <filename (including extension)> [ options ]
-infile <filename (including extension)>; same as -file
-outfile <filename>; alternate output file
-informat <format>; the input format. Used if reading from stdin
-debug; turn on debug mode
-noforce; don't force output if image is inconsistent
-version; print version information and quit
-output_version <version>; output files of this version. Valid versions can be: 0 or 604
-----------------------------------------------------------------------

Registration Options
-register <dpi side strictness>; perform optical registration.

•
•

Side can be one of left, right, top, bottom or l, r, t, b.
Strictness can be either loose, strict or l, s.

-registration_looseness_factor <factor>; registration looseness factor (default 2.000000)
-rlf; short form of registration_looseness_factor
-rdebug; output registration debug messages
-pegpitch <inch (default 8.000000)>; distance between peg bars
-threshr < (default 0.500000)>; threshold for optical registration; range 0.0 to 1.0
-rmargin <inch (default 1)>; region size where to look for peg bars
-peg_distance_from_center <inch (default 5.25)>; peg distance from centre of the image
-pdfc; short form of -peg_distance_from_center
-out_peg_position <side (default same)>; wanted position of the peg on the drawing.

•
•

Can be one of right, left, top, bottom (or r, l, t, b) or same.
A rotation will be performed if it is different from the side passed to -register.

-output_peg_matrix; output the peg transformation matrix on standard output.
-scanner_calibrate; < (default 1.0000 1.0000) > x and y scale factors to be applied to scanner image.
----------------------------------------------------------------------371
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Filtering Options
-pixel <pixel_shape (default '4x3')>; Valid values: 4x3
-gap <worldUnits (default 10)>; close gaps up to this big
-pencil; generate line art only
-keep_dirt; don't filter out dirt
-thresh <threshold (default 0.2)>; range 0.0 to 1.0
-rmv_hairs <worldUnits (default 1)> <passes (default 1)>

•

remove hairs of size smaller than "size" in "passes" passes

-rmv_holes <area (default 7)>; remove holes smaller than "area"
-rmv_dirt <area (default 1)>; remove dirt smaller than "area"

•

try values between 100 and 500 for rmv_holes and rmv_dirt. The area is in world units squared

-rmv_triangles <worldUnits (default 30.000000)>; remove triangles at "pixels"

•

distance from each other. Use -no_break to remove all triangles

-no_texture; don't generate textured strokes
-color_as_texture; will vectorize the alpha channel and put the RGB colour in a textured colour
-noclosegap; disable all gap closing algorithms
-no_break; disable the breaking of line art
-jag_filter <pixels (default 0>; expand the pixels in the vectorization bitmap
-expand_bitmap <pixels (default 0>; expand the pixels in the vectorization bitmap
-fit_errorc <error (default 1.000000>; fitting error for the colour art
-fit_errorl <error (default 1.000000>; fitting error for the line art
-smoothl <passes (default 1>; number of smooth passes for line art
-smoothc <passes (default 1>; number of smooth passes for colour art
-first_smooth <passes (default 0>; number of smooth passes for line art before breaking triangles
-first_smoothl <passes (default 0>; number of smooth passes for line art before breaking triangles
-first_smoothc <passes (default 0>; number of smooth passes for line art in colour art pass (needs -2pass)
-2pass; specify two sets of parameters; one for line art "l", one for colour art "c"
(-thresh, -rmv_holes and -rmv_dirt will be overridden by -threshl, threshc, -rmv_holesl,
-rmv_holesc, -rmv_dirtl and -rmv_dirtc)
-threshl <threshold for line art (default 0.5)>; range 0.0 to 1.0
-threshc <threshold for color art (default 0.5)>; range 0.0 to 1.0
-jag_filterl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art
-jag_filterc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art
-expand_bitmapl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art
-expand_bitmapc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art
-rmv_holesl <area (default 7)>; remove line art holes smaller than "area"
-rmv_holesc <area (default 7)>; remove colour art holes smaller than "area"
-rmv_dirtl <area (default 1)>; remove line art dirt smaller than "area"
-rmv_dirtc <area (default 1)>; remove colour art dirt smaller than "area"

•

try values between 100 and 500 for rmv_holesl, rmv_holesc, rmv_dirtl and rmv_dirtc. The values are in world
units squared

-margins <inch (default 0.25)>; remove margin around bitmap
-top_margin <inch (default 0.25)>; remove margin at top of bitmap
-bottom_margin <inch (default 0.25)>; remove margin at bottom of bitmap
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-left_margin <inch (default 0.25)>; remove margin at left of bitmap
-right_margin <inch (default 0.25)>; remove margin at right of bitmap
-remove_peg_bars; remove the peg bar holes
-field_size <fields (default 12 or use value in scan file)>; set the drawing to this field size
-fs; short hand for -field_size
-peg_bar_size <inch (default 1)>; the size of the peg bar region
-noframe; do not put a frame around the colour art
-frame_fields <default -1.000000>; put a frame of the specified dimension around the colour art
-downscale_input <default 1>; downscale the raw input by this integer factor
-downscale_texture <default 1>; downscale the output texture by this integer factor
-buildmatte; generate a matte on underlay for line test
-buildmatte_colourart; generate a matte on colour art for line test
Note: -buildmatte and -buildmatte_colourart are mutually exclusive
-copystrokes; copy original strokes when building matte.
-----------------------------------------------------------------------

Options for bitmap that has no registration information
-pixel_margins <inch (default 0)>; remove margin around bitmap
-top_pixel_margin <inch (default 0)>; remove margin at top of bitmap
-bottom_pixel_margin <inch (default 0)>; remove margin at bottom of bitmap
-left_pixel_margin <inch (default 0)>; remove margin at left of bitmap
-right_pixel_margin <inch (default 0)>; remove margin at right of bitmap
-dpi <(default -1)>; dpi information of input bitmap
-----------------------------------------------------------------------

RGB Keying Options
-rgb; generate separate zones for red, green and blue lines
-rgb_alpha <value (default 255)>; generate red, green and blue colour with alpha of this value
-no_red; ignore red colour in vectorization
-no_green; ignore green colour in vectorization
-no_blue; ignore blue colour in vectorization
-flatten; flatten the drawing after generating colours
-rmv_rgb_dirt <threshold area default 0.0>;
remove red, green and blue regions smaller than area
-expand_bitmap_rgb <pixels (default 0>; expand the pixels in the vectorization bitmap for rgb
-threshrgb <value> <threshold for rgb vectorization default 0.200000>;
-threshsv <saturation threshold default 0.500000> <value threshold default 0.500000>;
thresholds on saturation and value to consider a pixel to be grey
-----------------------------------------------------------------------
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Colour Vectorization Options
-color_vectorize; perform a colour vectorization
-file2 <colour art filename>; specify the colour art bitmap
-penstyle <center alpha (0.0-20.0)> <edge alpha (0.0-20.0)> <gamma (0-10)>
<centre pressure effect (0.0-1.0)> <edge pressure effect (0.0-1.0)>
<texture bitmap downscaling (0.2-20)> <texture bitmap file (valid filename or "" if no file)>;

•

generate brush texture for the line art

-pressure_variation <strategy (0, 1 or 2)> <min pressure (0.0-1.0)> <max pressure (0.0-1.0)> <max variation (0.01.0)>;

•

specify a pressure strategy for the centre line.

-blur_radius <pixels (default 0)>; blur the penstyle texture generated
-color_contour_smooth_passes <times (default 3)>; perform number of smooth passes on contour before computing
texture
-ccsp <times (default 3)>; short for -color_contour_smooth_passes
-color_rmv_holesl <world units (default 0.000000)>; remove holes of this size when computing texture
-color_fill_holesl <world units (default 0.000000)>; fill holes of this size for colour line art
-----------------------------------------------------------------------

Bubble Usage (implemented only for colour vectorization's line art)
-create_bubbles; add bubbles into the LineArt. Implemented for colour vectorization only
-bubble_gap <value (default 3)>; max number of colour art points between 2 bubbles
-bubble_length <value (default 10)>; max number of circles in a bubble
-min_radius <value (default 1.5000)>; min radius of a circle in a bubble relative to the line thickness (must be >= 1.0)
-max_radius <value (default 3.5000)>; max radius of a circle in a bubble relative to the line thickness (must be >= 1.0)
-uniform_gap; the space between bubbles is constant
-----------------------------------------------------------------------
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Creating a Vectorization Style
To create or modify the vectorization parameters:
1.

Enable or disable the different options available in the Vectorization Parameters interface.

2.

Click on the Vectorize

button to update the Vectorized Image preview.

The vectorized image is just a preview. The actual vectorization occurs when you click on the OK button in the
Import Drawings dialog box.

3.
4.

5.

There are a number of options to try in the Vectorization Options dialog box. These are applied during the
vectorization process.
If you want to set advanced parameters, read the information located in the Help tab, then type in the
Advanced Options field located at the bottom of the Options tab.
If you want to save your vectorization parameters to either reuse them later, share them or use them to set your
Scan module vectorization style list, click on the Save button. In the Browser window, name are save the file.

If you want to save the current settings as your Default settings, click on the Save As Default button.
If you want to restore the original Animate default settings, click on the Restore Defaults button.
If you want to load a vectorization style, click on the Load button and locate the existing *.vof file.
Click on the OK button to finish the vectorization setup.


6.
7.
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Preferences (PRO)
In the Preferences panel, you will find the following preference that is related to importing PDF and Illustrator files in
your project.

Advanced Option (PRO)
•
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Support CMYK in PDF/Illustrator Import: When this preference is enabled, you will be able to successfully
import PDF and AI files that were created or exported in CMYK mode. The colours of the resulting
imported image may still not look 100% faithful to its CMYK original due to the RGB conversion. It is
recommended that you convert these files to RGB images before importing them into Animate Pro.
Disabling this function will cause all the colours of the imported image to be displayed as red to indicate
that the file was not converted to RBG prior to import.

Chapter 9
Libraries, Symbols and Templates

You can share and reuse any elements you create in Animate using Symbols and Templates. Animate has a library
where you can store several different elements such as puppets, backgrounds, animations and keyposes. In fact,
anything you create in Animate can be stored in the library.
In this chapter, you will learn about the following:

•
•
•
•
•
•
•

Understanding the Library Concept, on page 378
Library View, on page 379
Structuring the Library, on page 381
Symbols, on page 385
Templates, on page 392
Importing Symbols and Templates, on page 395
Preferences (PRO), on page 404

377

Animate Pro 2 User Guide

Understanding the Library Concept
Use the Library view to reuse your artwork and animation in other scenes or to build props and puppets.
This topic is divided as follows:

•
•
•

What is a Library?, on page 378
What is a Symbol?, on page 378
What is a Template?, on page 378

What is a Library?
A library is a folder where you store your Templates and Symbols. You can access these folders from different projects.
Using the library is easy, just drag the content into the library to store your artwork and then drag it into your Timeline
or Camera view when you want to reuse it. Organize your library using subfolders. You can keep several different
library folders on your hard drive or network.

What is a Symbol?

A Symbol is a container or construction block used to build your props, puppets and looping clips. Use Symbols to
contain artwork and animation, to manipulate them as a single object, or as a case holder where you will put a series
of different drawings for each body part of your puppets.
To create a Symbol, drag your artwork to the Symbol library. When you drag a Symbol from the Symbol Library into
your scene, it will be linked to the original one. If you drag a Symbol into your scene several times in the Timeline view,
they will all be linked to the original one. If you modify one, they will all be modified. A Symbol is local to the project
and cannot be accessed directly from other scenes. To reuse a Symbol’s content into another scene, you must create
a template out of it.
When a Symbol is exposed in the Timeline view, the Symbol’s cells are represented as a movie strip.
Regular Drawing Cells
Symbol Cells

What is a Template?

A template is an individual copy of the artwork stored in the library. This package can be reused in different scenes.
Once a template is stored in the library it can be accessed from any project.
Dragging a template into your scene copies the content in your Timeline and does not link it to the original. This
individual copy can be modified at will.
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Library View
1

2

3

4
You use the Library view to create and manage your Symbols and templates, display the folders and manage and all
of the content.
1.
2.
3.
4.

Library View Menu
Preview and Drawing Substitution
Library List
Templates and Symbols List

Library View Menu
The Library View menu lets you access commands specific to the Library view such as opening a Library or getting the
rights to modify a library folder.

Preview and Drawing Substitution

The Preview window, allows you to preview the content of a Symbol or template and to swap between drawings and
Symbol cells in your Timeline view. This window is also used as the Drawing Substitution window.
To preview a template or Symbol’s content:
1.

In the Library view’s right side, click or double-click on the Symbol or template to preview.

2.

In the Preview window, click on the Play

button or drag the slider to scrub through the frames.
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Library List

The Library List is used to navigate through the different libraries and subfolders. You can also open, close and create
new libraries from here.
The Library has two default Library folders:

•

•

Symbols
The only library folder containing Symbols for your project. You can organize the Symbols library folder
using subfolders, but you cannot create a second Library for your Symbols. This library is local to your
project.
Animate Library
This folder contains templates and is stored on your hard drive. You can share the contents of this Library
between different projects. You can organize the Animate library folder using subfolders. This folder does
not contain Symbols.

Templates and Symbols List

The Symbols and templates contained in the selected Library list can be displayed on the right side of the Library view
as thumbnails, in a list or as details.
To access the Template and Symbol display options:

 In the Library view’s right side, right-click (Windows) or [Ctrl]+click (Mac OS X) and select
View > List, Thumbnails or Details.

In the Library View toolbar, you can click on the following buttons:
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•

Thumbnails

•

List

•

Details
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Structuring the Library
As you will probably create a large number of Symbols and templates you will soon realize that they need to be
organized. You can create different libraries and subfolders so that you can gain easy access to your assets. For
example, create a different library for each project and divide it into several categories, such as:

•
•
•

Characters
Props
Backgrounds

Although you can only have one Symbol library folder, you can organize it by creating subfolders.
This topic is divided as follows:

•
•
•
•
•

Creating a Library, on page 381
Opening a Library, on page 382
Closing a Library, on page 382
Creating a Folder, on page 382
Refreshing the Library, on page 384

Creating a Library
There are two ways to create Library folders.

•
•

Using Animate’s interface.
Directly through your operating system.

To create a library using your operating system, create a new folder with a relevant name in the location where you
want the library to be stored. This can be opened in Animate when you require it, see Opening a Library, on page 382
to find out how.
To create a library from Animate:
1.

In the Library view click on the Menu

button and select Folders > Open Library.

2.
3.

The Browser window opens.
Browse for the location where you want to store your new library.
Click on the Make New Folder button.
The new folder appears.

4.

Name the new library with a relevant name.
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5.

Click on the OK button.
The new library appears in the Library List section.

Opening a Library
You can open any folder on your hard drive or network as a library. Opening a library means linking the folder to your
Library view. You only need to open the library once. The library folder is available every time you open the application
until you decide to close the library and unlink it.
To open a library:
1.

In the Library View menu, select Folders > Open Library.

2.
3.
4.

The Browser window opens.
Browse to the location of the library folder.
Select the folder.
Click on the OK button.
The new library appears in the Library Folders section.

Closing a Library
You may not always require all of the library folders in the Library List, if this is the case you can close the ones you do
not need. Closing it does not delete the folder, it only unlinks it from the Library view. If you want to reopen in later,
you only need to locate it on your hard drive or network and open it in the Library view.
To close a library:
1.
2.

In the Library view’s right side, select the library folder to close.
In the Library View menu, select Folders > Close Library.
The library closes.

Creating a Folder
Symbols and templates libraries need to be organized, you can create different subfolders on your hard drive or in
the Library view so that you can gain easy access to your assets. By default, any new library you link to your Library
view is locked, this prevents the accidental deletion or modification of templates and Symbols. You must obtain the
right to modify a locked folder before being able to create subfolders for it.
To create a folder:
1.
2.
3.
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In the Library view’s left side, select a library folder that you would like to make subfolders for.
In the Library View menu, select Edit > Right to Modify or right-click (Windows) or [Ctrl]+click (Mac OS X) on
the selected library and select Right to Modify.
In the Library View menu, select Folders > New Folder.
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The new subfolder is added to the Library (although not immediately visible as it is collapsed in its parent
folder). Click on the root library folder containing the new folder and click on the [+] sign to expand it. The new
subfolder appears.

Deleting a Folder
You can delete a folder from the library if its contents are no longer needed.
WARNING: ALL THE TEMPLATES OR SYMBOLS CONTAINED IN THE FOLDER WILL BE DELETED FROM YOUR
HARD DRIVE. ONCE DELETED THE DATA CAN NOT BE RETRIEVED.
To delete a folder:
1.
2.
3.

In the Library view’s left side, select the folder to delete.
In the Library View menu, select Edit > Right to Modify or right-click (Windows) or [Ctrl]+click (Mac OS X) on
the selected library and select Right to Modify.
In the Library View menu, select Folders > Delete Folder. The default keyboard shortcut is [Delete].

Renaming a Folder
Once you add a folder, you can rename it, this also renames the folder on your hard drive.
To rename a folder:
1.
2.
3.
4.

In the Library view’s left side, select the folder to rename.
In the Library View menu, select Edit > Right to Modify or right-click (Windows) or [Ctrl]+click (Mac OS X) on
the selected library and select Right to Modify.
In the Library View menu, select Folders > Rename Folder.
Rename the selected folder.

5.

Press [Return] to validate the operation.
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Refreshing the Library
If you update the content of your libraries through your operating system, you will need to refresh your library folders
in the Library view.
To refresh a library:
1.
2.

In the Library view’s left side, select the folder to refresh.
In the Library View menu, select Folders > Refresh. The default keyboard shortcut is [F5]. The library should now
display the new content.

Generating Thumbnails
When you display thumbnails in the Library view, the system generates a series of small images (thumbnails) for you.
You can generate template thumbnails yourself, if they do not display or if the process has been stopped.
To generate thumbnails:
1.

2.

In the Library view’s right side, select the template you want to generate thumbnails for.

In the Library View menu, select View > Generate Thumbnails.
The progress bar appears.

You can also delete thumbnails if you want to send a template to another user or studio and keep your packages small.
To delete thumbnails:
1.

In the Library View menu, select Edit > Delete Thumbnails.
All the thumbnails contained in the library are removed.
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Symbols
A Symbol combines animation, artwork or layers into a single object that you can control in one layer. You can also
create Symbols out of each body part in your cut-out puppets.
This topic is divided as follows:

•
•
•
•
•

Creating a Symbol, on page 385
Deleting a Symbol, on page 388
Editing a Symbol, on page 389
Duplicating a Symbol, on page 390
Sharing a Symbol, on page 391

Creating a Symbol
You can create Symbols in several ways:

•
•
•
•

Creating a Symbol from a Drawing Selection, on page 385
Creating a Symbol from the Timeline View, on page 386
Creating a Symbol from the Network View (PRO), on page 387
Creating an Empty Symbol, on page 388
Refer to the Importing Symbols and Templates topic to learn how to import a Symbol in your scene.

Creating a Symbol from a Drawing Selection
To create a Symbol from a drawing selection:
1.

In the Tools toolbar, select the Select

2.

In the Camera view, select the drawing objects which you want to create a Symbol out of.

3.

In the top menu, select Edit > Create Symbol. The default keyboard shortcut is [F8]. You can also click on the
Create Symbol

or Cutter

tool.

button in the Edit toolbar.

The Create Symbol from Drawing Selection dialog box opens
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4.

In the Symbol Name field, type the name of the Symbol.
You can also select an existing layer from the Symbol Name drop-down menu. It will add your Symbol on
the layer’s current cell. If there is already an exposure on that cell a warning message will appear stating,
“Layer Head already has an exposure on current frame. Can’t perform operation.”



If you want to rename a Symbol, right-click (Windows) or [Ctrl]+click (Mac OS X) on the Symbol and select
Rename.
5. You can choose to leave the current selected artwork in the drawing or not:
 To remove currently selected artwork from the drawing and leave it in the new Symbol, enable (place a
checkmark in the checkbox) the Cut Artwork From Source Drawing option.
 To keep currently selected artwork in both the drawing and in the new Symbol, disable (remove the
checkmark from the checkbox) the Cut Artwork From Source Drawing option.
6. Click on the OK button.



The new Symbol appears in the Library view’s Symbol folder and in the Timeline view as a new layer.

Creating a Symbol from the Timeline View
To create a Symbol from the Timeline view:
1.
2.

In the Timeline view, select the layer or the cells from which your want to create a Symbol.
In the top menu, select Edit > Create Symbol. The default keyboard shortcut is [F8]. You can also click on the
Create Symbol



button in the Edit toolbar.

Another way to create a Symbol is to select the layer or cells from the Timeline view and to drag them on
the Symbol folder in the Library view.

OR
The Create Symbol dialog box opens
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3.

In the Enter Symbol’s Name field, type the new Symbol’s name.
To rename a Symbol once it is created, right-click (Windows) or [Ctrl]+click (Mac OS X) on the Symbol and
select Rename.
Click on the OK button.


4.

The new Symbol appears in the Library view’s Symbol folder.
NOTE: The current selection is not replaced by the new Symbol. The new Symbol only appears in the library. You
must drag it into your scene to use it.

Creating a Symbol from the Network View (PRO)
In Animate Pro, you can create Symbols from the Network view.
To create a Symbol from the Network view:
1.
2.

In the Network view, select the modules from which you want to create a Symbol.
In the top menu, select Edit > Create Symbol. The default keyboard shortcut is [F8]. You can also click on the
Create Symbol
button in the Edit toolbar.
Another way to create a Symbol is to select the modules from the Network view and copy and paste them
inside the Symbol folder in the Library view using the keyboard shortcuts
[Ctrl]+[C] and [Ctrl]+[V] (Windows) or [a]+[C] and [a]+[V] (Mac OS X).



[Ctrl]+[C] (Windows)
[a]+[C] (Mac OS X)

[Ctrl]+[V] (Windows)
[a]+[V] (Mac OS X)

The Create Symbol dialog box opens

3.

In the Enter Symbol’s Name field, type the new Symbol’s name.
To rename a Symbol once it is created, right-click (Windows) or [Ctrl]+click (Mac OS X) on the Symbol and
select Rename.
Click on the OK button.


4.

The new Symbol appears in the Library view’s Symbol folder.
NOTE: The current selection is not replaced by the new Symbol. The new Symbol only appears in the
library. You must drag it into your scene to use it.
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Creating an Empty Symbol
To create an Empty Symbol:
1.
2.

In the Library view, select the Symbol folder.
In the Library view’s right side, right-click (Windows) or [Ctrl]+click (Mac OS X) and select New Symbol. You can
also select Insert > Create Empty Symbol in Library from the top menu.
The new empty Symbol appears in the Library view.




The Symbol is ready for you to edit (add content to). To go back to the root timeline, click on the Top
button in the Camera view.
To rename a Symbol once it is created, right-click (Windows) or [Ctrl]+click (Mac OS X) on the Symbol and
select Rename.

Deleting a Symbol
Deleting a Symbol is easy.
WARNING: THE SYMBOL WILL BE DELETED FROM YOUR HARD DRIVE. USE UNDO TO RETRIEVE THE DATA.
THE DATA CANNOT BE RETRIEVED ONCE YOU CLOSE THE APPLICATION.
To delete a Symbol:
1.
2.
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In the Library, select the Symbols to be deleted.
Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Delete. The default keyboard
shortcut is [Delete].
 If the Symbol is currently in use in the scene, a warning message will pop up and the Symbol will not be
deleted.
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Editing a Symbol
When you import a Symbol from the library to the Timeline view it is linked to the original Symbol in the library. If you
import a Symbol into your scene several times in the Timeline view, they will all be linked to the original Symbol. If you
modify one, they will all be modified.
If you want to edit a Symbol without modifying the other instances, you must duplicate the Symbol first, see
Duplicating a Symbol, on page 390 to find out how.
You can either edit a Symbol from the Timeline view or from the Library view.
When you edit a Symbol, the drawings contained in it are not placed at the centre of the stage, but are located in the
position where they were created. The pivot is translated at the centre of the Symbol.
To edit a Symbol from the Timeline view:
1.

In the Timeline view, double-click on the Symbol’s cell to edit the Symbol. You can also double-click on the
Symbol in the Camera view. The default keyboard shortcut is [Ctrl]+[E] (Windows) or [a]+[E] (Mac OS X). You can
also click on the Edit Selected Symbol

button available in the Camera View toolbar’s extra buttons.

You are now inside the Symbol and you are able to edit it.

2.

Click on the Top
button in the Camera view’s top left corner to return to the project’s timeline. The default
keyboard shortcut to go back up one level is [Ctrl]+[Shift]+[E] (Windows) or [a]+[Shift]+[E] (Mac OS X). In the
Timeline view’s right side, right-click (Windows) or [Ctrl]+click (Mac OS X) and select
Symbols > Leave Current Symbol.

To edit a Symbol from the Library view:
1.
2.

In the Library view, select the Symbol to edit.
Right-click (Windows) or [Ctrl]+click (Mac OS X) and select Edit > Edit Symbol. You can also double-click on the
Symbol.
You are now inside the Symbol and you are able to edit it.

3.

Click on the Top
button in the Camera view’s top left corner to go back to the project’s timeline. The default
keyboard shortcut is [Ctrl]+[Shift]+[E] (Windows) or [a]+[Shift]+[E] (Mac OS X).
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Symbol Hierarchy
When you enter a Symbol to edit it, you are entering another scene where you have an independent timeline for your
Symbol. You can nest many Symbols one inside the other. To help you follow the hierarchy of your nested Symbol,
take note of the Editing stack at the top of the Camera view which displays the path to your Symbol’s location. You
can click on the Symbols’ name to move up the chain.

Duplicating a Symbol
You must duplicate a Symbol if you want to modify a copy of it without altering the original Symbol and the other
copies.
To duplicate a Symbol:
1.
2.

In the Timeline view, go to the frame where you want to duplicate the Symbol.
Select the Symbol’s cell.

3.

In the top menu, select Edit > Duplicate Selected Symbol.
In the Library view, the Symbol is duplicated and in the Timeline view, the current cell is replaced with the new
Symbol. You can now modify the Symbol’s content.

NOTE: If other Symbols are nested inside the new Symbol, those ones are not duplicated. If you modify them,
the original and other instances will also be modified.
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Sharing a Symbol
You can share a Symbol and use its contents (the drawing or drawings that it contains) in another scene. To do this,
you must first convert your Symbol into a template. This conversion breaks the drawing’s link with both the original
scene and Symbol. It then becomes a separate entity that you can import into your other projects.
To convert a Symbol into a template:
1.

From the Library view, select the Symbol to convert into a template and drag it to the Camera or Timeline view.
NOTE: If you drop your Symbol into the Camera view instead of the Timeline, it will not be placed in the
centre of your Camera frame, but rather wherever your cursor drops it within the Camera frame.

OR

2.

In the Timeline view, select the Symbol’s cells or layer and drag it to the Animate Library folder or to any other
library folder. Make sure you have the right to modify the library folder.

3.

In the Rename dialog box, rename the new template.

4.

Click on the OK button.
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Templates
If you want to reuse artwork and animation from your project into other scenes, you need to create a template out of
it. A template can be seen as a portable scene or package that you can drag inside your project.
This topic is divided as follows:

•
•
•
•

Creating a Template from the Timeline View, on page 392
Creating a Template from the Network View (PRO), on page 393
Deleting a Template, on page 394
Editing a Template, on page 394

Creating a Template from the Timeline View
You can create a template out of a layer or cells. You can store anything available in the Timeline view as a template.

Timeline Template
Timeline templates are designed to allow you to reuse animations, key poses and part of an animation. For example,
you can reuse head positions or a leg animation from a walk-cycle and place them inside other animations. An
Animation template, also known as an Action template, is created from the Timeline View. This template mainly
contains keyframes and drawing exposures.

NOTE: When creating a template from the Timeline View, it will lose the extra connections, effects and
groupings from the Network View.

Refer to the Importing Symbols and Templates topic to learn how to import a template in your scene.
To create a template from the Timeline view:
1.
2.
3.
4.
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In the Timeline view, select some cells or layers.
In the Library view, select the folder in which you want to store the template.
If the Library folder is locked, right-click (Windows) or [Ctrl]+click (Mac OS X) and select Right to Modify.
Drag the selection to the Animate Library folder or to any other library folder.
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5.

In the Rename dialog box, rename the new template.

6.

If you want to rename a template once it is created, right-click (Windows) or [Ctrl]+click (Mac OS X) on the Symbol
to rename and select Rename.
Click on the OK button.

Creating a Template from the Network View (PRO)
The Timeline and the Network Views have different ways to display the scene, each view displaying different
information.

Network Template (PRO)
A main character’s template can be created from the Network View. This template contains all of the connections,
effects, composites, modules, pegs, advanced groupings, function columns, scene lengths, drawings, timings, etc.
The template is saved in the Library and must be imported back into the scene for use, either into the Network view
or into the left side of the Timeline view.
To create a template from the Network view:
1.
2.
3.

In the Library view, select the folder in which you want to store the template.
If the Library folder is locked, right-click (Windows) or [Ctrl]+click (Mac OS X) and select Right to Modify.
In the Network view, select the modules you want to create a template with and group them.
Select Edit > Group > Group Selected Layers or use the default keyboard shortcut [Ctrl]+[G] (Windows) or
[a]+[G] (Mac OS X).

4.

In the Network view, click on the group module’s yellow button to rename it.
The Layer Properties dialog box opens.
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5.

In the Network view, select your group module and copy and paste it inside the Template folder in the Library
view using the keyboard shortcuts [Ctrl]+[C] and [Ctrl]+[V] (Windows) or [a]+[C] and [a]+[V] (Mac OS X).
[Ctrl]+[C] (Windows)
[a]+[C] (Mac OS X)

[Ctrl]+[V] (Windows)
[a]+[V] (Mac OS X)

6.

In the Rename dialog box, rename the new template.

7.

To rename a template, right-click (Windows) or [Ctrl]+click (Mac OS X) on the Symbol to rename and select
Rename.
Click on the OK button.
Refer to the Importing Symbols and Templates topic to learn how to import a Network template in your scene.

Deleting a Template
To delete templates from your library, use the Library view. Animate lets you undo the action if necessary. Do not
delete them using the operating system.
To delete a template:
1.

In the Library view, select the folder containing the template to delete.
If the Library folder is locked, right-click (Windows) or [Ctrl]+click (Mac OS X) on the folder and select Right
to Modify.
Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Delete. The default keyboard
shortcut is [Delete].


2.

Editing a Template
A template is like a scene, you can open it and edit it as any regular project. If you want to do some modifications in
your templates, you can edit them using the Edit Template command.
To edit a template
1.

In the Library view, select the folder containing the template to edit.
If the Library folder is locked, right-click (Windows) or [Ctrl]+click (Mac OS X) on the folder and select Right
to Modify.
Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Edit Template. A new Animate
application opens.
Edit the template.
In the top menu, select File > Save.
In the top menu, select File > Quit (Windows) or Animate > Quit Toon Boom Animate (Mac OS X).


2.
3.
4.
5.

394

Chapter 9: Libraries, Symbols and Templates Importing Symbols and Templates

Importing Symbols and Templates
There are several ways you can import templates and Symbols in your scene.

•
•
•
•
•
•
•

Importing a Template, on page 395
Importing a Symbol, on page 396
Importing a Network Template (PRO), on page 397
Previewing a Symbol in the Network View (PRO), on page 398
Opening a Template as a Folder, on page 398
Using Paste Special, on page 399
Expanding a Symbol, on page 403

Refer to Animating Your Puppets > Animating Using Symbols, on page 687 to learn how to cycle and manipulate
a Symbol’s timing.

Importing a Template
To import a template in the Timeline view:
1.
2.

In the Library view, select the template you want to import.
Drag the selected template to the Camera view or Timeline view’s left side.



You can also drag a template to the Timeline view’s right side into existing layers if the layer structure is the
same as the existing one.
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Importing a Symbol
To import a Symbol in the Timeline view:
1.
2.

In the Library view, select the Symbol you want to import.
Drag the selected Symbol to:

The Timeline view’s left side if you want to import it into the centre of the Camera frame.
OR



The Camera view if you want to place it where ever your mouse releases it.

This may be useful if you have saved a character’s body parts as separate Symbols. If you dropped them into the
timeline then they would all appear in the centre, haphazardly one on top of the other! It would be more
efficient to arrange them into their correct places as you bring them into the scene.

Importing a Template with Symbols
Sometimes a character’s rig is not a cut-and-dry matter. Rigs, which are usually saved as templates, can contain
Symbols, such as a leg that was made with a patch. However, a Symbol does not work in the same way as an Action
template. In the Timeline view, you can add an Action template into another Template of the exact same structure.
When a Symbol is dropped into the right side of the Timeline layer of a Symbol of the exact same structure, instead
of adding itself onto the previous Symbol, the new Symbol becomes a copy.
To take more control of how the Action template will behave when brought into the Timeline, bring it in using a Paste
Special.
To import a template with Symbols:
1.
2.

Select the Action template containing Symbols from the right side of the Library.
As you drag it from the Library to the right side of the Timeline to drop it next to a template with the exact same
rig, hold down the [Alt] button (Windows) or the [Option] button (Mac OS X).
The Paste Special window appears.
Refer to the Using Paste Special section to learn more about the Paste Special options.

3.
4.

Click on the Advanced tab.
Select one of the following options from the Symbols drop-down menu:
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Copy symbols if they do not exist: This is the default setting for this operation and will prevent Symbols in
a Action template from being copied.
Duplicate symbols: Select this option if you wish to make copies of the Symbols in your template.
Overwrite symbols: If for some reason, a modification was made to a Symbol in the Action template that
does not exist in the basic rig template for a character, select this option to overwrite the previous Symbol.
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Importing a Network Template (PRO)
To import a network template:
1.
2.

In the Library view, select the template or Symbol you want to import.
Drag the selected template to the Network, Camera or Timeline view’s left side.

3.

If necessary, in the Network view, connect your template into the Composite module. Do this by clicking it’s Out
Port and dragging the connection to the Composite module until an In Port appears.

If the template you are importing was created in the Network view, make sure to drop it in the Network view
or in the Timeline left side or some network connections could be broken. If you are importing a template containing
the exact same connections as a template you imported previously, you can drop it in the Timeline view’s right side
over the existing layer. This will combine both templates and keep the same existing layers.

397

Animate Pro 2 User Guide

Previewing a Symbol in the Network View (PRO)
In Animate Pro, when you import a Symbol in your scene, you can navigate through it in the Network view.
To navigate in your Symbol:
1.

In the Network view, select the Symbol you want to open and press the default keyboard shortcut [Ctrl]+[E]
(Windows) or [a]+[E] (Mac OS X) to use the Edit Selected Symbol command.

2.

In the Network view, inside the Symbol’s top module you will find the composition of your Symbol. In this
example, a group module was turned into a Symbol.
1

2

3

D 1. Symbol Content Modules
D 2. Composite Module set on pass through
D 3. Display Module
3.

Click on the Top
button in the Network view’s top left corner to return to the top module. You can also use
the Leave Current Symbol command’s default keyboard shortcut [Ctrl]+[Shift]+[E] (Windows) or [a]+[Shift]+[E]
(Mac OS X).

Opening a Template as a Folder
Since a template is like a scene, you can open the template’s folder and select elements inside it such as drawings.
You may only want to import a few drawings or a palette instead of importing the entire contents of a template. In
this case, use the Open As Folder command to import the items you want.
If you want to import a palette, drag the palette file into the Palette List of the Colour view.
To open a template as a folder:
1.

In the Library view, select the folder containing the template to open.
If the Library folder is locked, right-click (Windows) or [Ctrl]+click (Mac OS X) on the folder and select Right
to Modify.
Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Open As Folder.


2.
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3.

In the Library list, click on the template’s folder to display its content.

4.

Drag the content to the Timeline or Colour view.

Using Paste Special
When you import a Symbol in your scene, by default its full length is exposed. If you import your Symbol in the
Timeline view’s left side all the frames will be exposed, but if you import it into an existing layer, you can use the Paste
Special command to adjust the import behaviour to fit your requirements.
When you import a template in the Timeline view, all layers are created as well as drawings and keyframes. It is
possible that you will want to import only the keyframes without the drawings or import only the drawings that are
not already in your layers. You can adjust the behaviour using the Paste Special command.
Once you set the parameters, Animate will reuse them each time you import a Symbol in the Timeline view’s right side
until you set new parameters.
To open the Paste Special dialog box:
1.
2.

3.

In the Library view, select the Symbol or template to import.
While dragging the selection to the Timeline view, hold down the [Alt] key (Windows) or [Option] key (Mac OS
X). Note: Drop the selection in the Timeline view before releasing the hot key.
The Paste Special window opens.
Set the parameters.
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4.

Click on the OK button.

Basic tab
Advanced tab

Paste Special - Basic Tab
Drawings

•
•
•
•
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Only create drawing files when they do not exist: When adding exposures to a drawing layer, new
drawings will be created only when drawings with the same name do not already exist in the destination.
Always create drawing files: When adding exposures to a drawing layer, new drawings will always be
created. If drawing files with the same name already exist, Animate will create a new name for the drawing.
Extend Exposure: Extends the exposure of drawings to fill the range of cells to the destination frame.
Paste all Frames of the Symbols (full movie): When enabled, the Paste Special command will expose all
the Symbol’s frames instead of the first one only.
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Cycle

•
•

Number of Cycles: Use the up and down arrows to increase or decrease the number of cycles you want to
paste. You can also type the value directly in the field.
Cycle Type
D Normal (forward): This pastes your selection as it is, starting with the first cell and ending with the last
one.
D Reverse: This pastes your selection in reverse, starting with the last cell and ending with the first one.
D Forward -> Reverse: This pastes your selection as a yo-yo, starting with the first cell, going to the last
one and ending with the first cell.
D Reverse -> Forward: This pastes your selection as a reverse yo-yo, starting with the last cell, going to
the first one and ending with the last cell.

Paste Special - Advanced Tab
Drawings

•
•

•
•

Do Nothing: Does not create or overwrite drawings.
Add/Remove Exposure: Creates/deletes exposure values in the selected layer.
You have the following choices as to how to treat drawings that will be created when adding an exposure:
D Never create drawing files: When adding exposures to a drawing layer, drawing files will not be
created.
D Only create drawing files when they do not exist: When adding exposures to a drawing layer, new
drawings will be created only when drawings with the same name do not already exist in the
destination.
D Always create drawing files: When adding exposures to a drawing layer, new drawings will always be
created. If drawing files with the same name already exist, Animate will create a new name for the
drawing.
D Extend Exposure: Extends the exposure of drawings to fill the range of cells to the destination frame.
D Key Drawing Mode (Substitution): Pasting an exposure value replaces the cell value in the current
frame and in all frames following in sequence with the original cell value.
Paste all Frames of the Symbols (full movie): When enabled, the Paste Special command exposes all the
Symbol’s frames instead of only the first one.
Update Drawing Pivot: Revises the drawing pivot in the destination to use the same drawing pivot as the
first drawing in the template. If you have a range of drawings selected in the destination, the pivot points of
all selected drawings will be updated.

Symbols

•
•
•

Copy symbols if they do not exist: This is the default setting for this operation and will prevent Symbols in
a Action template from being copied.
Duplicate symbols: Creates a duplicate of the Symbol instead of linking the Symbol instance to the original
one. The new Symbol is created in the Library.
Overwrite symbols: If a modification was made to a Symbol that does not exist in the basic rig template for
a character, select this option to overwrite the previous Symbol.

Add/Remove Keyframes

•
•
•
•
•
•
•

Motion: Copies the properties of the selected motion keyframe to the new frame.
Velocity: Copies the properties of the selected velocity keyframe to the new frame.
Rotation: Copies the properties of the selected rotation keyframe to the new frame.
Skew: Copies the properties of the selected skew keyframe to the new frame.
Scale: Copies the properties of the selected scale keyframe to the new frame.
Force Keyframes at Function’s Beginning and End: Adds a keyframe to the beginning and end of the
pasted function, reproducing the source function.
Offset Keyframes: When pasting functions, this option offsets the keyframes from the function’s last value
by the values in the pasted function. This will continue the progression of a function rather than repeat the
values.
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Cycle

•
•

Number of Cycles: Use the up and down arrows to increase or decrease the number of cycles you want to
paste. You can also type the value directly in the field.
Cycle Type
D Normal (forward): This pastes your selection as it is, starting with the first cell and ending with the last
one.
D Reverse: This pastes your selection reversed, starting with the last cell and ending with the first one.
D Forward -> Reverse: This pastes your selection as a yo-yo, starting with the first cell, going to the last
one and ending with the first cell.
D Reverse -> Forward: This pastes your selection as a reverse yo-yo, starting with the last cell, going to
the first one and ending with the last cell.

Option (PRO)

•

Palette Option

D Do nothing: Does not create, overwrite, merge or link palettes.
D Reuse palettes. Copy palettes if they do not exist: Palettes in the destination drawings are left as
they are.

D Copy and overwrite existing palettes: Overwrites destination palettes with the palettes from the
source drawings.

D Copy and create new palette files: Creates new palette files, placing them at the same relative

•
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environment and scene level as the source. If the palettes in the templates were stored at the
environment level of the source scene, the paste operation will place the palettes in the environment
level of the destination scene.
D Copy and create new palette files in element folder: Creates new palette files in the element folders
of the destination scene, rather than in the same relative job or environment.
D Copy palette and merge colours. Add new colours only: Adds new colours to the destination
palettes and ignores colours that are the same in the two palettes.
D Copy palette and update existing colours only: Adds new colours to the destination palette and
updates duplicate colours in the destination with colour values from the source.
D Link to original palettes (colour model): Links the colour palettes in the destination scene to the
palettes in the source. Use this to link drawings to the palettes in a colour model.
D Copy scene palettes and merge colours. Add new colours only: Adds new colours to the destination
scene palettes and ignores colours that are the same in the two palettes.
D Copy scene palettes and update existing colours: Adds new colours to the destination scene palette
and updates duplicate colours in the destination with the colour values from the source.
Modules: Create New Columns: If you enable this option a new column will be created when you copy
and paste modules from the Network view or Layer in the Timeline view. If the layers are linked to function
curves, the function curves, the drawings and the timing will be duplicated.
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Expanding a Symbol
You can use the Expand Symbol command to extract a Symbol’s content and place it on the root timeline. The Symbol
will not be removed from the Timeline view. Its content will be copied and inserted into the root timeline. The Symbol’s
layers will be parented to it in case you created motions and transformation on the drawing layer that is containing
the Symbol. Breaking the hierarchy could result in loosing any scaling and animation you may have done.
To expand a Symbol:
1.

In the Timeline view, select the Symbol to expand.

2.

In the top menu, select Edit > Expand Symbol. The default keyboard shortcut is [Ctrl]+[B] (Windows) or [a]+[B]
(Mac OS X).
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Preferences (PRO)
Adjusting preferences to suit your workflow allows you to work more efficiently.
To open the Preferences panel:





Windows: Select Edit > Preferences.
Mac OS X: Select Animate Pro > Preferences.
You can also use the default keyboard shortcut [Ctrl]+[U] (Windows) or [a]+[,] (Mac OS X).

In the Preferences panel Template tab you will find the following preferences that are related to managing templates
and Symbols.

Paste/Drag and Drop
•

•

Always Create New Drawings: By default, when you import timeline templates in the right section of the
Timeline view, to stack them, the system will analyze and create only the non-existing drawings and only
expose the already existing ones. When enabled, this option will automatically create new drawings for
every one of them that is exposed.
Palettes:
D Ask User: When dropping a template into a scene, the system will ask if you want to link the palette to
the original or create a local copy in the scene.
D Use Original Palette: The system will automatically link drawing elements to the original palette file. If
the original palette is not encountered a local copy will be created.
D Use Copy of Palettes: The system will automatically create a local copy of the palette in the scene.

Editing a Template
•
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Generate Thumbnails Automatically: When this option is enabled, the system will automatically create
thumbnails for the template when the user wants to see the thumbnails in the Template Library or when
saving a template modification.

Chapter 10
Building a Character

Toon Boom Animate is a great tool for building your characters. You can make use of different techniques and features
to break down your puppets.
In this chapter, you will learn about:

•
•
•
•
•
•
•
•
•
•
•

Importing a Model, on page 406
Relative Sizes, on page 408
Studying the Model, on page 410
Setting the Default Separate Position Preference, on page 413
Breaking Down, on page 414
Rigging, on page 430
Adding the Main Extra Drawings, on page 444
Setting the Pivots, on page 446
Skeleton Optimization (PRO), on page 451
Storing the Character in the Library, on page 456
Appendix, on page 460
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Importing a Model

To begin breaking down your puppet, you must first import your character into a new project.
You can import your character in several different formats:

•
•
•

Library Template
Bitmap Image or Picture
External Vector Format

If you previously created a template out of your character model, refer to Libraries, Symbols and Templates >
Importing a Template, on page 395 to learn how to import your character’s template into your building scene.
If your character model is a bitmap image or picture, refer to Gathering Content > Importing Bitmap Images in
Animate, on page 338 to learn how to import your image into your building scene.
If your character model is an AI, PDF or SWF file, refer to the following sections in the Gathering Content chapter
to learn how to import your vector based image:

•
•

Importing AI and PDF Files, on page 361
Importing from Adobe® Flash®, on page 363

Refer to Gathering Content > Importing PSD Files as Separate Layers in Animate, on page 350 to learn how to
import your bitmap images and multi-layered PSD files.

Model Alignment

When setting your character’s model in your scene, we recommend that you to centre it in the Camera view and scale
it to fit inside the Safe Area’s frame.
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If you have several views of your character, place each view in a separate cell and centre them one on top of another.
This will facilitate the break down process and will ensure that all of your puppets are aligned and the same size.

Photo Puppets

If you are creating a cut-out puppet out of photos, break down the different parts in a bitmap editing software. Then,
import your parts and vectorize them as textured images.
A good way to set and import your bitmap parts is to organize them in a multi-layered PSD file.
Refer to Gathering Content > Importing PSD Files as Separate Layers in Animate, on page 350 to learn more
about importing bitmap images and multi-layered PSD files.
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Relative Sizes
It is important to understand the relative size of every character and prop in order to maintain consistency and
structure throughout the project.
A production may contain many characters and props. It is not unusual for these to have been created by different
people. If there is no size control implemented, the characters and elements created by different artists can vary
greatly in size. When this occurs, the characters that are put together in a scene will be out of proportion. The animator
or person doing the scene setup will then have to scale them to the correct size.
When a character or a prop is scaled down, the outline will get increasingly thinner. By the time that the element is
scaled to its proper size, the outline may be so thin that the difference between one character’s outline and another’s
will not look very good.
These tips can be used to create a determine the correct relative sizes for each puppet:

•
•
•

Line Up, on page 408
Field Chart, on page 409
Brush Size, on page 409

Line Up

A line up consists of copying and pasting all of your character designs into the same drawing and then scaling them
so they are in proportion with each other. This line up is very important and should be handed to any animator, layout
and posing artist, or scene set up person working on the project.
For the prop design, it is recommended that you paste one of the main character’s hands or even the full body beside
the prop. This enables the animator to know what size to draw or set the prop.
In your character design scene, it is a good idea to create a column for the character line up. The line up is usually
done during the Character Design step. When the character builder imports the model to the break down scene, the
size relation should be correct.
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Field Chart

Animate has a field chart included in its Camera and Drawing views. This tool is very useful in setting the characters’
and props’ heights. You can display the field chart using the Show Grid option.
To display the field chart:

 In the top menu, select View > Grid > Show Grid. The default keyboard shortcut is
[Ctrl]+[‘] (Windows) or [a]+[‘] (Mac OS X). You can also click on the Show Grid
Camera view and Drawing view toolbars.

button available in the

Brush Size
Animate provides a variety of pens and brushes and also allows you to create and save your own. It is a good idea to
create and save pens with precise sizes and parameters to trace and design your models and break downs.
Refer to Drawing and Animating > Brush Styles, on page 89 to learn more about creating and saving brushes.
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Studying the Model

Now that you have imported or designed your colour model, the next step is to observe the model. This is done to
determine what parts will be broken apart and how they will be divided. Will the hair be separated into one, two or
three sections? Will the hand be separated from the sleeve? To determine what is best for your character, observe the
model in the Camera or Drawing view.
To help you improve the quality of your break down, here are some tips and tricks. The following examples are from
“Grossology”, a production by Nelvana Limited:

•
•
•
•
•
•

Eyelids and Pupils, on page 410
Creating Mouth Shapes Directly on the Head, on page 411
Keeping Fingers Attached to the Hand, on page 411
Mixing Hand-Drawn Animation, on page 411
Flipping Logos, on page 412
Complete and Overlapping Pieces, on page 412

Eyelids and Pupils

For increased flexibility when animating the eyes, you can split them into three layers: the eyeball, the pupil and the
eyelid. The eyelid layer is used for the blink and to cut the pupil when it gets too close to the side of the eyeball. For
a more advanced break down, the two eyes are separated on their own individual three-layer sets.
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Creating Mouth Shapes Directly on the Head

To animate more realistic lip syncing and facial expressions, you can create the mouth shapes on the head layer. Just
deform the jaw to match the mouth opening.

Keeping Fingers Attached to the Hand

To avoid needlessly complicating the break down, the fingers are not usually separated from the hand. The full hand
is a single layer with a bank of different hands stored inside. This technique is easy to work with and produces a less
mechanical effect.

Mixing Hand-Drawn Animation

For more advanced cut-out animation and a more traditional animation look, some users will keep full arms and full
legs. This means that only hands and feet are separated from the limbs. The animator will create extra drawing shapes
and substitute them during the animation.

The animator may temporarily combine some parts to facilitate the work and produce a higher quality animation. For
example, combining both full legs and hips into a single drawing to create poses that would be difficult using cut-out
pieces. Both full legs could be drawn on the hip level and legs and feet exposure removed. This technique is a mix of
cut-out and hand-drawn animation.
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Flipping Logos

You can separate logos and letters that appear on a character or a prop. This allows you to flip and reuse a character’s
puppet.

Complete and Overlapping Pieces

For a better result with animated parts, it is important to understand that they have to be properly overlapping and
complete. A common mistake is to trace the part just as it appears on the model.
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Setting the Default Separate Position Preference
Before you start adding layers to your puppets, there is a preference you should adjust:

•

Default Separate Positions
X (Left - Right)
Y (Up - Down)
Z (Forward - Backward)

If you enable the Default Separate Positions preference, when you create new layers, their X, Y and Z axes will be
independent one from the other.
By default, this preference is disabled, so when you animate your layers, the three directions are locked together to
form long and smooth trajectories controlled by a single easing parameter. However, when you do cut-out animation,
you will probably prefer to have three independent axes so that you can control them individually.
X, Y, Z axes
Velocity (Ease)

When you lock the three positions together, each time you add a keyframe, it is added on all three positions at once.
Left - Right (X) motion not
affected by the Z nudge.

Body part pushed backward
When you separate the three positions, when you add a keyframe on one axis, it is not added on the other two. This
gives you more freedom when animating with Motion keyframes and nudging parts forward and backward over time.
To enable the Default Separate Positions preference:
1.
2.
3.

In the top menu, select Edit > Preferences (Windows) or Animate > Preferences (Mac OS X). The default
keyboard shortcut is [Ctrl]+[U] (Windows) or [a]+[U] (Mac OS X).
In the Preferences panel, go to the General tab.
In the Settings section, enable the Default Separate Positions option.

4.

Click on the OK button.
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Breaking Down

There are many techniques you can use to break down a puppet. In this section, you will learn about one of the most
common methods. For your first character break down, follow these instructions so that you can get an idea of the
way Animate works. Once you are used to the software and understand its basic functions and commands, you will
be able to create your own techniques to satisfy the needs of your production.
If your drawing is not a vector based format or a bitmap photo puppet, you will need to use the Tracing Over the
Model technique to break down your character, available in the Appendix section.
Refer to the Appendix section at the end of the chapter for alternate technique tips.
This topic is divided as follows:

•
•
•
•

Selecting and Creating a New Layer, on page 414
Selecting and Incorporating an Existing Layer, on page 420
Completing the Parts and Articulation, on page 422
Creating Ghost Drawings (Optional), on page 426

Selecting and Creating a New Layer
Head
Left Arm

Right Arm
Body

Right Leg

414

Left Leg

Chapter 10: Building a Character Breaking Down
The first step in breaking down your character is to do a rough cut down of the main parts such as the body, arms,
legs and head. Use the Create Drawing from Drawing Selection feature to automatically create your layers and copy
your selection in it.
Refer to the Appendix section at the end of the chapter to learn about the Break Down: Tracing the Model
technique and the Break Down: Distribute to Layer, on page 461.
This section is divided as follows:
Naming Conventions, on page 415
Breaking Down the Main Parts, on page 415
Breaking Down the Secondary Parts, on page 417

•
•
•

Naming Conventions
Before breaking down your pieces, you should think of a naming convention for your layers in order to keep your work
organized.
When naming your layers, you should include the following information:
Character’s name
Right or left side
Part’s name

•
•
•

An example of that naming convention for a character named Mark is:

•

mk_r_arm
This would be the layer name for his right arm.

Breaking Down the Main Parts
To break down the main body parts, you will use the Create Drawing From Drawing Selection feature. There is no need
to create any layers prior to this process, you need to have your model well centred and sized in the Camera view.
You do not need to make clean cuts around your parts; a rough one is quite sufficient as long as it includes all of the
artwork of the part you want to break down. You will clean the extra bits and pieces later.
You will use the Cutter
lines and colour zones.

tools:

tool to roughly cut the main sections. You can also use the Select

tool to select precise

Refer to the following sections in the Drawing and Animating chapter to learn how to use the Cutter and Select

•
•

Cutting Drawing Parts, on page 131
Selecting Drawing Objects, on page 113

To break down the main parts:
1.

In the Timeline view, select the model’s cell that corresponds to the first view to break down.

2.

In the Tools toolbar, select the Cutter

tool.



If you prefer to use the Select
shortcut is [Alt]+[V].

tool, choose the Select tool from the Tools toolbar. The default keyboard



In the Cutter’s Tool Properties view, you can switch to the Lasso

selection mode.
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3.

In the Camera view, create a selection around the first part to break down. If you click on a zone, the Cutter tool
will select the zone. It will end the selection at the first point of intersection that it meets.

Cut the entire arm, not just the hand or
forearm.



If you hold down [Shift], you can create a new lasso selection around another zone and add it to your
previous selection.

[Shift]

4.

In the top menu, select Edit > Create Drawing From Drawing Selection. The default keyboard shortcut is [F9]
(Windows).
The Create Drawing From Drawing Selection dialog box opens.

5.
6.
7.
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In the Layer Name field, type the name of the layer you want to create following the naming convention you
established previously.
Make sure to disable the Cut Artwork From Source option in order to keep the selected artwork on your original
drawing. You do not want to cut the artwork from your colour model.
Click on the OK button to complete the operation.
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The new layer is created and your selection is copied in it. The drawing is created in the same frame number as
the cell it was taken from.

bl_l_arm

8.

Repeat Step 1 to Step 7 for each main body part.

Breaking Down the Secondary Parts

Arm

Forearm

Hand

You should now have a layer for each main part of the character for the first view to break down. You are now ready
to break down those main pieces into smaller ones.
Breaking down the secondary parts is similar to the main part break down process except that this time you will cut
away the artwork from the layer it has been selected from.
To break down the secondary parts:
1.

In the Timeline view, lock your model layer by clicking on its Lock

button.
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2.

In the Timeline view, select the cell that corresponds to the main part you want to break down.

3.

In the Tools toolbar, select the Cutter

tool.

If you prefer to use the Select
tool, choose the Select tool from the Tools toolbar. The default keyboard
shortcut is [Alt]+[V].
In the Camera view, create a selection around the part to break down.


4.

Cut the forearm from the
arm layer.



If you click on a zone, the Cutter
intersection that it meets.

tool will select the zone. It will end the selection at the first point of

Click on a line with the
Cutter tool to select it
up to the next
intersection.

5.

In the top menu, select Edit > Create Drawing From Drawing Selection. The default keyboard shortcut is [F9]
(Windows).
The Create Drawing From Drawing Selection dialog box opens.

6.
7.
8.

In the Layer Name field, enter the name of the layer you want to create, following the naming convention you
established previously.
Enable the Cut Artwork From Source option in order to remove the selected artwork from your original drawing.
In this case, you want to cut the artwork from your colour model.
Click on the OK button to complete the operation.
The new layer is created and your selection is copied in it. The drawing is created in the same frame number as
the cell it was taken from.
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bl_l_forearm

9.

Repeat Step 2 to Step 8 for each body part.
Cut the hand from the
Forearm layer.

If you forgot to add some artwork to a layer you previously created, you can always add it later.
In the Camera view, select the artwork to send to the existing layer and press [F9] (Windows) to open the Create
Drawing from Drawing Selection dialog box. In the dialog box, select an existing layer from the drop-down list instead
of typing a new name. When you click on the OK button, the artwork will be added to the existing drawing in the layer
you selected.
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Selecting and Incorporating an Existing Layer
Your first view should now be completely broken down. If your articulations are still rough and bits and pieces are
missing you will fix those in the next step.
If your character model has more than one view, now is the time to break them down. The process is very similar to
breaking down the first view, except that you do not have to create layers this time.
If your layers are not in the correct order, you can reorder them later. Simply add the part that you are breaking down
to the layer you previously created for the same body part.
Start by breaking down the main pieces, as you did before. The secondary parts will be broken down later on.

•
•

Breaking Down the Extra View Main Parts, on page 420
Breaking Down Secondary Parts in the Extra Views, on page 421

Breaking Down the Extra View Main Parts
Repeat the following steps for each extra view you have to break down.
To break down the other views:
1.

In the Timeline view, selected the model’s cell corresponding to the view to break down.

2.

In the Tools toolbar, select the Cutter

tool.

If you prefer to use the Select
tool, in the Tools toolbar select the Select tool. The default keyboard
shortcut is [Alt]+[V].
In the Camera view, create a selection around the first part to break down.


3.

4.

In the top menu, select Edit > Create Drawing From Drawing Selection. The default keyboard shortcut is [F9]
(Windows).
The Create Drawing From Drawing Selection dialog box opens.

5.
6.
7.
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In the Layer Name field, select the corresponding layer from the drop-down list.
Make sure to disable the Cut Artwork From Source option in order to keep the selected artwork on your original
drawing. You do not want to cut the artwork from your colour model.
Click on the OK button to complete the operation.
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The artwork is inserted into the existing layer. The drawing is created in the same frame number as the cell it was
taken from. It is not incorporated in the other view’s drawings.

8.

Repeat Step 1 to Step 7 for each main body part.

Breaking Down Secondary Parts in the Extra Views
To break down the secondary parts for your extra views you will follow the exact same process as you did for the first
view you broke down, but you will incorporate the new parts in the already existing layers.
Refer to Breaking Down the Secondary Parts topic to repeat the secondary part break down process.
This is an example of how your timeline should look at this stage:
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Completing the Parts and Articulation

Now that all of your layers are created and your parts are basically broken down, it is time to clean up your parts and
complete the articulation.
This topic is divided as follows:

•
•

Cleaning the Parts, on page 422
Fixing the Articulations, on page 424

Cleaning the Parts
You will need to use a series of drawing tools to clean the parts:

•

Brush Tool

•

Eraser Tool

•

Select Tool

•

Cutter Tool

•

Contour Editor Tool

•

Paint Tool

•

Close Gap Tool
Refer to the following sections to learn how to use these drawing tools to fix your drawings:

•

•

422

Drawing and Animating
D Drawing with the Brush Tool, on page 87
D Erasing Parts of a Drawing, on page 105
D Selecting Drawing Objects, on page 113
D Cutting Drawing Parts, on page 131
D Reshaping a Drawing Using the Contour Editor Tool, on page 108
D Drawing using Invisible Lines, on page 102
Adding Colour
D Painting Using the Paint Tool, on page 194
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To clean your drawings:
1.

In the Tools toolbar, select the drawing tool you need to fix your drawings.

2.

In the Timeline or Xsheet view, select the cell containing the drawing to fix.

3.

In the Camera view, delete the extra bits using the Select or Cutter tool. You can also use the Eraser tool.

4.

Draw the missing lines using the Brush tool. If you use the Brush tool, it is recommended that you enable the
Auto-Flatten

5.

option in the Tool Properties view.

Using the Paint tool, paint the gaps. You can close some gaps with invisible lines using the Close Gap tool.
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6.

Reshape your lines using the Contour Editor tool.

7.

Using the Select tool, select your entire drawing and click on the Flatten
button in the Tool Properties view
to flatten your drawings.
In the top menu, select View > Show > Show Strokes to display the invisible lines that could be present in your
drawing. The default keyboard shortcut is [D].

8.

9.

In the top menu, select Drawing > Optimize > Remove Extra Strokes. This operation will remove any
unnecessary invisible lines in your drawing.
10. Repeat this entire process for each drawing to fix.

Fixing the Articulations

Once your pieces are cleaned up, you can proceed to the completion of the articulations.
Articulations are an important aspect of any cut-out break down, without them a puppet cannot move properly and
will not look good.
Animate offers two different ways of completing articulations:

•
•

Classical Articulation
Patch Articulation
Refer to the Appendix section at the end of the chapter to learn about Patch Articulation.
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Classical Articulation
In this section, you will learn about classical articulation.
The classical articulation is the most popular technique. It is quite simple and produces excellent results, but it is not
the most efficient method. In many instances, it causes limitations and extra drawing corrections. For example, there
may be a gap in the articulation if the part is bent too far. Joint design is usually designed as a circle; the overlapping
part cannot be sent behind without showing the joint.

The classical articulation is done by erasing a part of the line from the overlay layer, leaving the colour overlapping the
bottom one.
Repeat the following instructions for all the articulations on your puppet.
To create a classical articulation:
1.

In the Xsheet or Timeline view, select the cell containing the first part to modify, such as the arm.

2.
3.

In the Tools toolbar, select the Polyline, Brush, Pencil, Ellipse, or Contour Editor tool.
In the Colour view, select the outline colour.

4.

In the Drawing or Camera view, use your drawing tool to make sure that the joint is overlapping the other part in
a half-circle shape.


5.
6.
7.
8.

If you are working in the Drawing view, click on the Light Table
toolbar. The default keyboard shortcut is [Shift]+[L].

button located in the Drawing View

Using the Select tool, select your entire drawing and click on the Flatten
button in the Tool Properties view
to flatten your drawings.
In the top menu, select View > Show > Show Strokes to display the invisible lines that could be present in your
drawing. The default keyboard shortcut is [D].
In the top menu, select Drawing > Optimize > Remove Extra Strokes. This operation will remove any
unnecessary invisible lines in your drawing.
Repeat Step 1 to Step 7 for the other part of the joint.
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9.

In the Timeline or Xsheet view, select the cell of the part that will be on top of the joint.

10. In the Tools toolbar, choose the Select, Cutter or Eraser tool.
11. In the Drawing or Camera view, remove a part of the overlapping outline in order to have only the filling colour
overlapping the joint.

[Delete]

NOTE: When placing rotation pivots later on, make sure they are positioned at the centre of the articulation.

Creating Ghost Drawings (Optional)

At this point your basic break down should be almost complete. There is one optional step you can do before moving
on, adding extra drawings and expressions to your character:

•

Adding Ghost Drawings

Adding a Ghost Drawing
Right now, your timeline looks like this:
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Some parts have no drawings in certain views. For example, the left eye has no drawing available for the Side view.
To make your puppet more efficient when you will animate, a good trick is too add invisible drawings that you can
select even when no image is necessary.

If you need to select a part of your character to use the Drawing Substitution feature or Inverse Kinematics tool, or to
avoid having the system automatically fill in the exposure gaps when swapping images, then creating ghost or invisible
drawings can be very useful.
To create ghost drawings, copy one of the existing drawings, paste it in the empty cell and repaint it with a fully
transparent colour.
To create ghost drawings:
1.

In the Colour view, add a fully transparent colour to your character’s palette.

2.

In the Timeline or Xsheet view, select the cell containing the drawing you want to copy to create your invisible
drawing.

3.

In the Tools toolbar, select the Select

tool. The default keyboard shortcut is [Alt]+[V].
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4.

In the Camera or Drawing view, select the drawing to copy.

5.

In the top menu, select Edit > Copy. The default keyboard shortcut is [Ctrl]+[C] (Windows)
or [a]+[C] (Mac OS X).
In the Timeline or Xsheet view, select the empty cell where you want to create your ghost.

6.

7.
8.

Click on the Camera or Drawing view and in the top menu select Edit > Paste. The default keyboard shortcut is
[Ctrl]+[V] (Windows) or [a]+[V] (Mac OS X).
In the Colour view, select the transparent colour.

9.

In the Tools toolbar, select the Select

10. In the Tools toolbar, select the Paint
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tool and offset the drawing outside the body’s area.
tool. The default keyboard shortcut is [Alt]+[K].
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11. In the Camera or Drawing view, repaint the drawing to make it invisible.

At this point, your timeline should look like this:

At this point, you could decide to convert your layers to Symbols. Refer to Appendix, on page 460 to learn about
this alternative technique.
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Rigging

The rigging process is where building a puppet can take several different directions.
In this section, you will learn how to create a simple rig. Afterward, you will learn how to add pegs and create a
hierarchy. You can also see more advanced tricks in the Appendix section of this chapter.
This section is divided as follows:

•
•
•
•
•
•
•

Rigging Basics, on page 430
Rigging the Head, on page 434
Rigging the Body, on page 436
Creating Hierarchy, on page 437
Ordering the Layers, on page 439
Adding the Master Peg, on page 442
Creating the Keyframes, on page 443

Rigging Basics
The Rigging Basics topic is divided as follows:

•
•
•
•

Simple Rigging, on page 430
Parenting Layers, on page 431
Rigging using Pegs, on page 433
Rigging the Head, on page 434

Simple Rigging
Simple rigging is very fast and easy to do. It is built as follows:

•
•
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All the body parts are independent
All the timeline’s layers are attached to a master peg layer (trajectory layer)
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The advantage of using this technique is that you are free to move any part around without being influenced by any
parent layer.

However, since the parts are not parented to each other, the parts will move from point A to point B along a straight
trajectory. The hand will not follow the arm’s rotation. You will have to set more keyframes for the hand to move along
a curved path.

A

A

B

B

Parenting Layers

When you want a part to follow another one, such as the forearm following the arm, you can attach the layers one to
the other. For example, you can attach the forearm layer to the arm layer without having to encapsulate the forearm
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into the arm layer. They will still be parented, but you will be able to access the forearm directly without having to
enter the arm layer.

The advantage of parenting layers is that the child layers will follow the parent smoothly without having to select them
or create a series of keyframes.

A
B
A
B

The disadvantage of parenting layers is that you are not able to move the parent independently of its children, since
the child layers receive all the transformation information from their parent.

Parenting layers such as the arms and legs and letting the torso and hips independent from those is often a good
solution.
To attach one layer to another, you have to drag the desired layer onto the other one in the Timeline view.
Animate offers powerful techniques to create hierarchies between your layers without having to encapsulate Symbols
into each other. These techniques are a great improvement over the less efficient and time consuming method of
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creating parenting between your layers by inserting Symbols into other Symbols. Therefore, rigging with Symbols
inside Symbols is NOT recommended.
Symbols Hierarchy

Up to Arm
Up to Forearm

This method is NOT
recommended.
For efficiency in your production, do
not encapsulate Symbols inside
Symbols.

Rigging using Pegs
When you are doing more advanced puppet rigging, you can use peg layers. Peg layers are trajectory layers that do
not contain drawings. They are motion paths that you can use to control your entire puppet or advanced hierarchies.
Parenting a drawing layer to a peg layer allows you to divide your motions on two separated levels. You can scale your
body part directly on the drawing layer. This way, you do not affect any child layers that could be attached to that part.
Then, you can perform your translation and rotation on the peg layer so that all the parts attached to that peg layer
will follow the same trajectory.

Translation and Rotation on
the forearm and hand

Scale, Squash and Stretch on
the forearm, independently
from the hand
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Rigging the Head
You will start by attaching the facial features to the head.
The advantage of parenting the features to the head layer is that you can easily animate each facial feature, and they
will all follow the head motion.

To parent the facial features to the head:
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1.

In the Timeline view, undo the parenting to the Head layer to have all of your head layers at the same parenting
level.

2.

In the Timeline view, unselect any layer that could be selected.

3.

In the Timeline View Layer toolbar, click on the Add Peg

4.

You can rename the Peg to keep your work organized.
Select all the head and facial features layer and drag them ONTO the peg layer to parent them.

button to add a new peg layer to your timeline.
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5.

Select the Head layer and drag it below all the facial feature layers. Make sure it stays connected to the peg.

Changing the Layer Order in the Network View (PRO)
You can help yourself with the Network view which is useful when it is time to do advanced ordering and hierarchy.
If your modules are not connected to a Composite module, refer to the section Connecting Modules to a
Composite Module (PRO) to learn how to automatically do it.
To order your head layers in the Network view:
1.

In the Network view, select the Head module’s connection connected to the Composite module located at the
left of all your facial feature modules.

2.

Drag the connection to the right of all your facial feature modules’ connections.
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Rigging the Body
Now that the character’s head is ready, you can move on to the body. You can do a simple rigging where all of the
body parts are independent one from the other, or create some parenting between some of the layers.

Simple Body Rigging
Simple rigging consists of leaving the layers in the Timeline view without doing any kind of parenting. Later on, you
will attach those layers to a master peg and organize them in the correct order.

In Animate Pro, your drawings must be connected to a Composite module. A Composite module takes all the drawing
layers connected in it and flattens them into a single image which allows you to organize your network and manipulate
your puppet easily. It also allows you to apply effects on your complete character. The Composite module is useful
when you have to deal with a lot of modules in the Network view.
If you import your layers into the Timeline view, they will automatically be connected to the Composite module
available in the Network view.

Connecting Modules to a Composite Module (PRO)
In Animate Pro, if your modules are not connected to your Composite module in the Network view, you can connect
them all at once following the Timeline order.
To connect your modules to a Composite module:
1.
2.
3.
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If you do not have a Composite module, open a Module Library view. In the top menu, select
Window > Module Library.
In the Module Library view, go to the Filters tab and select a Composite module.
Drag the Composite module to the Network view. You can also use the keyboard shortcut [Ctrl]+[H].
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4.

In the Timeline view, select all the modules you can to connect to your Composite module.

5.

Right-click (Windows) or [Ctrl]+click (Mac OS X) on your selection and select
Connect To Composite > select the desired Composite module.
You modules are now connected to your Composite module in the same order as the Timeline.

Creating Hierarchy
Animate lets you extend your rigging techniques beyond normal boundaries and sets new standards. You can create
hierarchies without encapsulating your Symbols inside each other by creating a linked structure between your layers.
You should create a hierarchy on your arms and legs and keep the arms and legs separated from the body. This gives
you more animation freedom. This way, when you need to scale or skew the torso, it will not affect the entire body.
Head Hierarchy

Right Arm Hierarchy

Left Arm Hierarchy

Independent Torso
and Hips

Right Leg Hierarchy

Left Leg Hierarchy

437

Animate Pro 2 User Guide
To create a hierarchy in the Timeline view:

 Drag the child piece (hand) and drop it ON the parent piece (forearm). Then, you can drag the parent (forearm)
piece onto another parent piece (arm).

To create a hierarchy in the Network view:

 From the parent part, drag a new cable connection out of the module’s Output port (bottom) and connect it to
the child part module’s Input port (top).

1
2
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Ordering the Layers

At this point, it is possible that your character’s pieces may show up in the wrong order.
There are two ways to fix this. First, you can reorder your layers by dragging them to a higher or lower level in the
Timeline view. The top layer is displayed in front of the others and the bottom one is displayed behind. Second, you
can use the Z-axis nudging (forward and backward) for the extra views.

•
•
•

Ordering the Timeline Layers, on page 439
Ordering the Layers, on page 439
Nudging Parts Backwards and Forwards, on page 441

Ordering the Timeline Layers
The layers should be ordered to match the view you will use the most often, generally the three-quarter front. Do not
worry if the other views are still in the wrong order, you will order them in the next step. Do not move the drawings
to other layers.
To order the layers:

 In the Timeline view, drag a layer to reorder it and drop it between the other layers.

NOTE:
If you drop it on a layer, it will create a parent hierarchy, so make sure to drop it between layers.
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Ordering Layers in the Network View (PRO)

The Network view allows you to reorder your layers without breaking any hierarchy. For example, if you want the Head
layer to appear behind all of the facial features, in the Timeline view, you cannot simply move the layer down because
you will break the parenting between the head layers. In the Network view, since you have a set of flexible
connections, you can change the Composite module ordering without breaking the parenting between the modules.

Top

Bottom

The Composite module ordering corresponds to your Timeline ordering unless the Network’s organization is too
complex for the Timeline. The element connected in the left-most port in the Composite module is displayed in front
in the Camera view and the one connected in the right-most port is displayed behind.
To order your layers in the Network view:
1.
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In the Network view, select the module’s output cable connected to the Composite module and drag it to its
new position.
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Nudging Parts Backwards and Forwards
If you created a hierarchy on your arms, legs or other body parts, it is possible that you will want a part, such as the
hand, to appear in front of its parent. Yet, if you move the hand layer above the arm layer, you will break the hierarchy.
To reorder a layer rigged in a hierarchy, nudge it backwards or forwards.

You will do the same for the layers that are not in the right order on the extra views. Do not place the drawing on
another layer. You want to keep all your drawings of the body parts in the same layers like a box containing all of the
hands or all of the shoes.
Animate allows you to move your elements in three dimensions:

•
•
•

Up and Down (Y-axis)
Left and Right (X-axis)
Backwards and Forwards (Z-axis)

In the same way you create multiplane backgrounds (depth), you can do a micro nudge of the part to be reordered
and see it in front of the other elements, even if its layer is actually behind the other ones in the Timeline view. The
Forward-Backward position can also be animated over time.
Repeat the following instructions for all the views.
To nudge your parts backward and forward:
1.

In the Tools toolbar, select the Transform

tool. Make sure to enable the Animate

2.

In the Camera view, select the element that you want to reorder.

mode.
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3.

To move the element forward, use the default keyboard shortcut [Alt]+[Down Arrow] and to move the element
backward, use the default keyboard shortcut [Alt]+[Up Arrow].

Adding the Master Peg

When you animate your character, you will probably need to resize and reposition it to fit your scene. When you need
to scale down or move your character, it is a good idea to hook (attach) the whole puppet to a trajectory.
Attaching your puppet to a peg will allow you to scale it and reposition it without having to do this to your different
parts and pieces. Only one layer will contain the position information, this makes your animation easier to modify and
control.
To add a Master peg:
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1.

In the Timeline view, click on the Add Peg

button. Name the new peg Master plus the character’s name.

2.

In the Timeline view, select all of the layers you want to attach to your new peg.
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3.

Drag your selection ON the peg layer to parent all your character’s pieces to the peg.

Creating the Keyframes
Once all of your drawings are ordered and your master peg is added, you need to insert keyframes on each cell to
create all of the function curves and block your pose in place.
To create the keyframes:
1.

In the Timeline view, collapse the master peg by clicking on the Expand

arrow.

2.

In the Timeline view, select the first cell.

3.

In the top menu, select Insert > Keyframe. The default keyboard shortcut is [Ctrl]+[F6] (Windows)
or [a]+[F6] (Mac OS X).You can also click on the Add Keyframe
button located in the Timeline view toolbar.
Note: If you use the [F6] shortcut when working the Flash keyboard shortcuts, this not only creates a keyframe
but also duplicates a drawing.
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Adding the Main Extra Drawings

Your break down is now complete. You can move on to adding the main extra drawings your character needs, such as
principal hand positions and mouth shapes.
If ever you forget to add extra drawings in your main character’s template, you will easily be able to add them later.
Add your extra drawings in the layer corresponding to the part which you are drawing. You should see the layers
as containers for the different pieces. Each part of the body has its own container where you can add more drawings
of the same part.
Refer to the Working With Sound chapter to learn how to create mouth shapes for your character and use the
Auto Lip-Sync Detection feature.
To add the main extra drawings:
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1.

In the Timeline view, collapse the master peg by clicking on the Expand

arrow.

2.

In the Timeline view, select all the keyposes following the one you need to extend.

3.

Click and drag your selection to extend the keypose.

4.

Repeat the last operation for each keypose.

5.

Click on the Expand

6.

In the Timeline view, select the cell where you want to add your new drawing

7.

Select Drawing > Duplicate Drawings, you can also use the keyboard shortcut [Alt]+[Shift]+[D].

arrow to expand the master peg.
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This creates a new drawing in the selected cell, automatically extended to the next one. This new drawing is a
duplicate of the one that was selected so it contains a duplicate of the art. You can modify it to create your new
drawing or delete its contents in the Camera or Drawing view and start from scratch.

8.

In the Tools toolbar, select the drawing tool you need to draw your extra part.

9.

In the Camera or Drawing view, draw your new drawing.

10. Using the Select

tool, select your drawing and flatten your lines by clicking on the Flatten

button

located in the Tool Properties view.
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Setting the Pivots

The last step before storing the character in the library is to set the pivots for the different parts.
Animate has two types of pivots:

•
•

Drawing Pivot
Symbol Pivot

You can set a different pivot for each one of your drawings. For example, if you have a series of drawings from different
views, they are not likely to rotate from the same location. In that case, you can set a different pivot for these drawings.

This topic is divided as follows:

•
•
•
•
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Pivot Tool, on page 447
Setting the Pivots, on page 448
Setting Pivots on a Frame Range, on page 448
Setting the Master Peg’s Pivot, on page 450
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Pivot Tool
Use the Pivot
Symbols.

tool to set the pivots on your character. This can be used to set the pivots on the drawings and

In the Pivot’s Tool Properties view, you will find a series of options.

Set the Pivot for Symbol on All Frames
This option is enabled by default. When you set a pivot on a Symbol, all of its cells will use the same pivot. This means
you do not have to set a pivot on all frames. You set it once, and it is done.
If you prefer to set a different pivot for a series of cells, you can disable the option and set your pivots on each cell or
cell range.
If you have already set several different pivots on your Symbol’s cells and enabled the Set the Pivot for Symbol
on All Frames option, once you set a new pivot on the same Symbol, all of its pivots will be reset and will use your
new pivot.

Snapping
When you drag the pivot around, you can enable a snap option when the pivot is released it either snaps to the
reference grid, drawing’s contour or aligns with an existing drawing stroke.
Refer to Drawing and Animating > Snap Options, on page 110 to learn more about the snapping options.

Reset Pivot
When you click on the Reset Pivot option, the pivot of the selected drawing or Symbol is reset to the centre of the
Camera view (stage).

Copying Pivot on Parent Symbol
When you import new extra drawings such as hands and mouths, use the pivot that was set on your drawings and
report them to the Symbol’s cells. Use the Copy Pivot to Parent Symbol command for this.
NOTE:
When you copy your pivots to the parent Symbol, there is no link between the drawings’ pivots and the Symbol’s
pivots. If you modify the drawing pivot later, it will not link to the Symbol. You would need to do the operation again.
If you need to modify the Symbol’s pivots, do it directly on the Symbol’s cells.
Refer to the Animating Your Puppets chapter to learn more about this tool.
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Setting the Pivots
If you want your puppet’s pieces to rotate correctly, you need to set the pivot points right in the middle of an
articulation such as an elbow or a knee.
Do the following steps for each layer in the Timeline view.
To set the pivots:
1.

In the Tools toolbar, select the Pivot

2.

In the Camera or Timeline view, select the drawing you want to set the pivot for.

3.

In the Camera view, click where you want to the pivot to be. You can also drag the pivot marker to the desired
location.

4.

If you want to set a different pivot for another drawing, select the drawing or cell and in the Camera view, set
the new pivot.

once.

tool.

Refer to the Setting Pivots on a Frame Range topic to learn how to set a pivot for a frame range selection all at

Setting Pivots on a Frame Range
If some elements need the same drawing pivot, such as all of the three-quarter hands, you can select all of these hands
cells and set the pivot all at once. If your pivot is already correctly set on your first drawing, copy and paste that pivot
onto the other drawings in the Timeline or Xsheet view.
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You must have the same drawing pivots on the extra parts from the same angle. If you substitute a drawing while the
part is rotating, the animation risks popping out of place if the pivot is uneven.
To set the pivot on a frame range:
1.

In the Timeline view, select the cell where you want to set the same pivot. The cells have to be part of the same
layer.

2.

In the Camera view, click where you want to the pivot to be. You can also drag the pivot marker to the desired
location.

To copy and paste drawing pivots:
1.
2.

In the Drawing or Camera view, set the first drawing pivot of the series. For example, set it on hand-1.
In the Timeline view, select the cell that contains the correct pivot.

3.
4.

In the top menu, select Edit > Copy.
In the Timeline view, select the cell range that requires the same pivot.

5.

In the top menu, select Edit > Paste Special. The default keyboard shortcut is
[Ctrl]+[Shift]+[B] (Windows) or [a]+[Shift]+[B] (Mac OS X).
The Paste Special dialog box opens.

6.
7.
8.

In the Paste Special dialog box, go to the Advanced tab.
In the Drawings section, enable the Update Drawing Pivot option.
Click on the OK button.
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Setting the Master Peg’s Pivot

By default, your Master peg pivot is placed at the centre of the Camera view, which generally equates to your
character’s hips. A good way to set your peg’s pivot is to move it between your character’s feet.
To permanently move a peg pivot, use the Rotation or Scale tool. While animating, you are easily able to temporarily
move this pivot to another location with the Transform tool.
The Transform tool is designed to move the pivot temporarily during the animation process. It also permits you to
select multiple pegs and apply a common temporary pivot.
To set the peg pivot:
1.
2.

In the Advanced Animation toolbar, select the Rotate
[Alt]+[3] and [Alt]+[4].
In the Timeline view, select the Master peg layer.

or Scale

tool. The default keyboard shortcuts are

3.

In the Camera view, click on the peg pivot and move it to its new location.

If you added other pegs to your rig, you must set their pivot following the same method.
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Skeleton Optimization (PRO)
In the Network view, you can add extra modules, such as a Display, and group all of your modules to keep your work
organized.
There are four steps to make sure your puppet can be reused efficiently:

•
•
•
•

Deleting the Write Module (PRO), on page 451
Renaming the Display Module (PRO), on page 451
Changing the Composite Type (PRO), on page 453
Grouping your Modules (PRO), on page 454

Deleting the Write Module (PRO)
The first step in optimizing your network is to delete the Write module. The Write module is used to render certain
portions of your Network view.
If you have three or four characters in your scene and they each have a Write module in their skeleton, when you
render your scene, a render for each one of them is created and they overwrite each other.
To delete your Write module:
1.

In the Network view, select your Write module.

2.

In the top menu, select Edit > Delete. The default keyboard shortcut is [Delete].

Renaming the Display Module (PRO)

A Display module allows you to see a section of your Network in your Camera view. By renaming your Display module
with your character’s name, you will be able to quickly identify its Display in the Global Display toolbar and isolate
your character to see it better while working on it.
To rename your Display module:
1.

In the Network view, click on the Display module’s Properties button to open the editor.
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2.

In the Layer Properties window, rename the Display module with your character’s name.

3.

Click on the Close button.

If you do not have a Display module in your network, you can add one by selecting one from the Module Library view
and dragging it into your Network view.
To add a Display module:
1.
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2.
3.

If you do not have a Module Library view opened, in the top menu,
select Window > Module Library.
In the Module Library, go to the IO tab and select the Display module.
Drag the module to your Network view.

4.

Connect the Composite module’s Output port into the Display module’s Input port.
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Changing the Composite Type (PRO)
When you create a character with Animate Pro, you have to connect all your modules in the Composite module. The
Composite module takes all the different images coming out of your drawing modules and flattens them into one
single image.
This is useful when it is time to apply an effect to your entire character or group your layers for a more organized
network.
The regular Composite module will flatten all the pieces into one image preventing interaction with props or
characters connected to a different Composite module. That is why you have to change the Composite module’s type
to a special one that will still output one single image but will not flatten the drawings together. This will allow you to
nudge your drawings on the Z-axis so that parts of you characters can pass in front and behind other characters and
objects. This Composite type is called Pass Through.
To change your Composite module to a Pass Through type:
1.

In the Network view, click on your Composite module’s properties button.

2.

The Composite Layer Properties dialog box opens.
Select the Pass Through type.

3.

Click on the Close button.
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Grouping your Modules (PRO)
Once your rigging is completed, you must group the puppet’s skeleton. This helps you to organize large and complex
networks. This way, once you have imported two or three characters into the scene, three Group modules will be
displayed instead of all of the rigging connections of three puppets.

To group your modules:
1.
2.

3.

4.

In the Network view, select all your modules.
In the top menu, select Edit > Group > Group. The default keyboard shortcut is
[Ctrl]+[G] (Windows) or [a]+[G] (Mac OS X).
Your modules are now grouped.
Click on the Group module’s right arrow to enter the group.

If you do not have a Multi-Port Out module inside your group, in the Module Library, go to the Group tab and
select a Multi-Port Out module.

2

5.
454

Drag the Multi-Port to the Network view.

1
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6.
7.

8.

Connect the Composite module’s Output port into the Multi-Port Out module. This creates an output port on
your Group module.
In the bottom left corner of the Network view, click on the Top word to go back to your network’s root. You
should now see an output port on your Group module.

Click on the Group’s properties button to open the Editor.

9. In the Layer Properties window, rename your Group module with your character’s name.
10. Click on the Close button.
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Storing the Character in the Library
To be able to reuse your character in different scenes, you have to store a template in the Library. You can create
different kinds of templates. You can create templates with all the views included, a template for each view or even
some containing only the head.

Animate Pro has a Timeline and a Network view. The Timeline view represents the layers in a linear and simple way.
The Network view allows you to create all sorts of complex connections that the Timeline view cannot display.
It is highly recommended that you create a cut-out puppet‘s main template from the Network view since it
contains advanced connections, Display modules and Composite modules.

To create a template containing all the character’s views:
1.

In the Library view, right-click (Windows) or [Ctrl]+click (Mac OS X) on the desired library folder and
select Right To Modify.

2.

In the Timeline view, collapse the Master peg layer.

3.

If your scene has a series of blank cells, they will also be included in the template if you drag the layer to the
library. Reduce the scene length to have no empty cells before creating your template.
4. To create your template:
 In Animate, select the collapsed layers from the Timeline view’s left side and drag them into the Library
view.

456

Chapter 10: Building a Character Storing the Character in the Library



In Animate Pro, in the Network view, select your character’s group and in the top menu,
select Edit > Copy. In the Library view, select the folder where you want to store the template and in the
top menu, select Edit > Paste.

Paste the selection

Copy the selection

The Rename dialog box opens.

5.
6.

In the Name field, name the new template.
Click on the OK button.

To create a template containing a single character’s views:
1.

In the Library view, right-click (Windows) or [Ctrl]+click (Mac OS X) on the desired library folder and
select Right To Modify.

2.

In the Timeline view, collapse the Master peg layer.
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3.

Select the cell containing the desired view and drag it into the desired library folder.

The Rename dialog box opens.

4.
5.

In the Name field, name the new template.
Click on the OK button.

In Animate Pro, when you create a template from the Timeline view, for everything to work properly when
you reimport it into a scene, you must first import your template created from the Network view. Once the Network
template is imported, you can import the Timeline template’s content into the right hand side of the Timeline view.
Refer to the Animating Your Puppets chapter to learn more on this subject.
When you create a template from a keyframe in the Timeline view’s right side, it only copies the drawings and
keyframes. It does not copy all of the network advanced connections and composites. If you import your Timeline
template in the Network view or in the Timeline view’s left side, your layers will be in the wrong order and will not be
connected to a composite.
To create a template containing only the character’s head:
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1.

In the Library view, right-click (Windows) or [Ctrl]+click (Mac OS X) on the desired library folder and
select Right To Modify.

2.

In the Timeline view, expand the Master peg layer.
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3.

In the Timeline view, collapse the head layer if it has any child layers.

4.

Select the head cell containing the desired view and drag it into the desired library folder.

The Rename dialog box opens.

5.
6.

In the Name field, name the new template.
Click on the OK button.
Refer to the Libraries, Symbols and Templates chapter to learn more about libraries and templates.
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Appendix
There are many options and animation techniques available when building a puppet, it is impossible to determine only
one method to break down a character. Here are some advanced tips on breaking down puppets. As you become
more familiar with the software, you will find more ways to improve your puppet builds.
This section is divided as follows:

•
•
•
•
•
•
•

Break Down: Tracing the Model, on page 460
Break Down: Distribute to Layer, on page 461
Converting the Layers into Symbols (Optional), on page 462
Patch Articulation, on page 464
Prefix and Suffix Script (PRO), on page 469
Setting the Symbols Pivot, on page 470
Creating Extra Drawings, on page 471

Break Down: Tracing the Model
The main break down technique shown here is to cut away your model, complete the missing parts and fill the gaps.
If your character model is a bitmap image or if it is faster to trace over your character, you can use the Tracing Over
the Model technique instead of the main method
To trace over your model:
1. In the Xsheet or Timeline view, add a new drawing layer for each body part to
separate. The default keyboard shortcut is [Ctrl]+[R] (Windows) or
[a]+[R] (Mac OS X).
2. In the Xsheet or Timeline view, select the layer’s cell in which you want to draw the
part.
3. In the Tools toolbar, select the drawing tool needed.
4. In the Colour view, select the desired colour swatch.
5. In the Camera or Drawing view, draw the new part.

If you are working in the Drawing view, click on the Light Table

button located in
the Drawing view toolbar to display the other layers as washed out colours. The default
keyboard shortcut is [Shift]+[L].
6. Using the Select tool, select your drawing and flatten your lines by clicking on the
Flatten

button located in the Tool Properties view.

7. Repeat the entire process until the breakdown is completed.
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Break Down: Distribute to Layer
When breaking down your character, you can use the Distribute to Layer option to distribute the selected art strokes
to a new layer each.
This feature will automatically take each stroke from the drawing selection made in the Camera view and
separate them into different layers. If one of your puppet’s parts is composed of several strokes, you must group them
using Edit > Group > Group before using the Distribute to Layer option. This option cannot be done in the Drawing
view. It must be done from the Drawing view.
To distribute to layer:
1.

In the Tools toolbar, click on the Select

2.

In the Camera view, select the art strokes you want to distribute to different layers.

tool.

3.

Select Drawing > Distribute to Layers. You can also click on the Distribute to Layers
tool’s Tool Properties view.

button in the Select

The number of drawing layers corresponding to different strokes or groups of strokes are created in the
Timeline view.




The selected strokes in the original drawing layer will be removed.
Each stroke or group of strokes will be distributed into each new Drawing layer.
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Converting the Layers into Symbols (Optional)

Converting your layers into Symbols is optional. When animating, you will need to enter the symbol to
create a new drawing. If you want to use morphing when animating, it is highly recommended that you keep
your layers as drawings and do NOT use Symbols.
Once the breakdown is completed, you can create Symbols out of each drawing. The Symbol will encapsulate each
drawing of the layer. Later on, even if you only expose the first frame, such as the front head, you will still have access
to all of the head drawings you placed in the Symbol. This will also allow you to add more drawings, as your characters’
master templates will evolve throughout the production of your movie or series.
To create a Symbol:
1.

To create a Symbol:
From the Timeline view, drag the layer to the Symbol library.



OR



In the Timeline view, select the layer to convert to Symbol and in the top menu select
Edit > Create Symbol. The default keyboard shortcut is [F8]. You can also click on the Create Symbol
button available in the Edit toolbar.
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The Create Symbol dialog box opens.

2.
3.
4.

In the Enter Symbol’s Name field, type the new Symbol’s name. It is recommended that you keep your original
layer’s name.
Click on the OK button.
Repeat this process for each layer in your Timeline view.
NOTE: Make sure that all of your layers are stored in the Symbol library.

Clearing the Main Timeline
At this point, all your layers should be stored in the library as Symbols. Before building your puppet, you will need to
remove all of the current layers in your scene. All of your work is saved in the library.
If you are not sure that you put everything in your library, you can always perform a Save As on your scene and work
on a new version.
To save your scene as a new version:

 In the top menu, select File > Save As. You can also click on the Save As

button available in the File toolbar.

To clean your Timeline:
1.

In the Timeline view, select all of your layers.

2.

In the Timeline's Layer toolbar, click on the Delete Layers

3.

In the Confirm Delete dialog box, click on the OK button to complete the operation.

button.

Your timeline is now ready to receive the body part Symbols for the rigging process.
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Your Network view should look like this:

Patch Articulation

Wrist Patch
Elbow Patch

Animate‘s advanced rigging can employ an articulation fixing technique called Patch Articulation. This technique is a
colour fill patch that is drawn onto a third layer and is used to cover the joint lines. It is a simple, yet powerful method.

Using this technique, you avoid having to create a correction layer at the end of the animation to fill the gaps in the
joints. You do not need to worry about the articulations at all. Once a patch is set, the articulation is fixed for the entire
length of the animation.
The main technique to create patches is done using Symbols but, for Animate Pro, you can also use the
advanced connections in the Network view.
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To create a Patch Articulation with Symbols:
1.

In the Camera view, double-click on the part you want to create a patch for. For example, if you are fixing the
elbow articulation, double-click on the arm or forearm Symbol to edit it. You have to edit the Symbol of the part
that will be behind. For example, if the forearm is placed under the arm layer, edit the forearm Symbol.

2.
3.

In the Timeline view, add a new drawing layer by clicking on the Add Drawing Layer
keyboard shortcut is [Ctrl]+[R] (Windows) or [a]+[R] (Mac OS X).
Rename the new layer patch.

4.

In the Camera view, select the fill zone of the part’s drawing.

5.
6.

In the Camera view, right-click (Windows) or [Ctrl]+click (Mac OS X) and select Copy.
In the Timeline view, select the cell in which you want to create the patch.

7.

In the Camera view, right-click (Windows) or [Ctrl]+click (Mac OS X) and select Paste.

8.

In the Tools toolbar, select the Cutter

button. The default

tool.
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9.

In the Camera view, make a selection around the pasted zone to cut everything out but a small overlapping zone
to cover the articulation.

10. In the Tools toolbar, select the Transform

tool. The default keyboard shortcut is [Alt]+[Q].

11. In the Camera view, select the patch drawing.

12. Nudge the patch forward using the default keyboard shortcut [Alt]+[Down Arrow] to slightly move it on the Zaxis. One or two nudges should be sufficient.
13. In the Camera view’s top area, click on the Top

button to go back up to the root’s timeline.

14. Repeat the process for each articulation which requires fixing.
Refer to the Classical Articulation section in this chapter to learn more about joints and articulations.

In Animate Pro, if your drawings are not encapsulated in Symbols, you can use the Network view to create your
patches.
To create a patch joint using the Network view (PRO):
1.
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In the Tools toolbar, select the Transform
[Alt]+[Q].

tool. The default keyboard shortcut is
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2.
3.

In the Timeline view, add a new drawing layer by clicking on the Add Drawing Layer
keyboard shortcut is [Ctrl]+[R] (Windows) or [a]+[R] (Mac OS X).
Rename the new layer patch or elbow.

button. The default

4.

In the Camera view, select the part you want to create a patch for. For example, if you are fixing the elbow
articulation, select the arm or forearm drawing to edit it.

5.
6.

In the Tools toolbar, select the Select
tool. The default keyboard shortcut is
[Alt]+[V].
In the Camera view, select the fill zone of the part’s drawing.

7.
8.

In the Camera view, right-click (Windows) or [Ctrl]+click (Mac OS X) and select Copy.
In the Timeline view, select the cell in which you want to create the patch.

9.

In the Camera view, right-click (Windows) or [Ctrl]+click (Mac OS X) and select Paste.

10. In the Tools toolbar, select the Cutter

tool.
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11. In the Camera view, make a selection around the pasted zone to cut everything out but a small overlapping zone
to cover the articulation.

12. In the Network view, connect the main part you create the patch from and parent it to the patch module.

13. Select the patch module’s connection to the Composite module and drag it in front of the piece to be covered.
In this case, the elbow patch is parented to the arm and connected in front of the forearm.
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14. Repeat the process for each articulation which requires fixing.

Prefix and Suffix Script (PRO)
Animate Pro provides you with a script called Add Prefix or Suffix that allows you to simultaneously add a prefix or a
suffix to a series of selected layers.
To add a prefix to a series of modules:
1.
2.
3.

In the Timeline View, select all of the layers. The default keyboard shortcut is
[Ctrl]+[A] (Windows) or [a]+[A] (Mac OS X).
In the top menu, select Windows > Toolbars > Scripting to display the Scripting toolbar.
In the Scripting toolbar, click on the Add Prefix or Suffix script button.
The Add Prefix or Suffix dialog box opens.

4.
5.
6.

Enable the Prefix or Suffix option, depending on what you want to add to the element’s name.
Type the prefix or suffix information to be added to the module name.
Click on the OK button.
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Setting the Symbols Pivot
If you want your puppet’s pieces to rotate correctly, you need to set the pivot points onto the articulations. By default,
when you create your Symbols, the pivot is located at the centre of your drawing. You will need to move it onto the
shoulder or elbow.
You will set the pivot on the Symbol’s cells, not directly on the drawings. To set your pivots, you have to be at the Top
level of your character building scene and not inside the Symbols.
By default, when you set your pivot onto your Symbol, all the cells use the same pivot. If you need different pivots for
your different cells, refer to the following procedure.
NOTE:
If you are rigging your character without using any Symbols, set your pivots directly on the drawings instead of the
Symbol’s cells. You need to set a pivot for each individual drawing.
To do this, follow the same process as setting the pivots on the Symbol’s cells but select the drawing cells directly
instead.
Do the following steps for each layer in the Timeline view.
To set the pivots for the Body parts:
1.

In the Tools toolbar, select the Pivot

tool. You can also select Drawing > Tools > Pivot.

2.

In the Camera or Timeline view, select the Symbol you want to set the pivot for.

3.

In the Pivot’s Tool Properties view, make sure the Set the Pivot for Symbol on All Frames
if you only want to set one pivot for your Symbol.

option is enabled

Disable this option if you want to set a series of different pivots for your Symbol’s cells.
In the Camera view, click where you want to the pivot to be. You can also drag the pivot marker to the desired
location.


4.

5.

If you want to set a different pivot for another drawing or Symbol cell, select the drawing or cell and in the
Camera view, set the new pivot.
Make sure that the Set the Pivot for Symbol on All Frames option is disabled.

once.
470
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Creating Extra Drawings

If you want to add extra facial expressions and drawings, you can store them as separate templates in the library. This
way, the animator can easily scroll through them and import them in his scene. Also, it avoids overloading the master
template.
To create facial expressions and be able to swap them without having to switch each facial feature one-by-one,
you should create a head template containing the desired expression. The animator can then scroll through the facial
expressions in the library and import the necessary ones.
To add your new drawings, create a temporary scene where you will import the master template and work from there.
Do not work directly in the master template since you do not want to add them to the drawings in it.
To create extra drawings for your parts:
1.
2.

Create a new project that you will use as a working scene to create extra drawings.
In the Library view, browse and select your character’s master template.

3.
4.
5.
6.

Drag the master template to the Timeline view’s left side.
In the Tools toolbar, select the desired drawing tool to draw your new piece.
In the Colour view, select the colour needed.
In the Timeline view, select the cell where you want to add the new drawing.



If necessary, extend the scene length by pulling on the red scene length bracket.
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7.

In the Camera view, draw the new drawings you want to add to the body part.

8.

In the Tools toolbar, select the Pivot

9.

tool.

In the Camera view, set the pivot directly on the new drawing’s cell.
If you are using Symbols, when you add an extra drawing, the pivot used by the last cell of your Symbol will
be kept in the new drawing. You do not need to set a new pivot for your drawing unless it needs a different
one or if it is not contained inside a Symbol.
 If you are using Symbols, in this case, you will not set the pivot on the Symbol’s cell. You will set the pivot on
the drawing INSIDE the Symbol.



Later on, once the new drawings are stored as a template in the Library, you will be able to add other new
drawings directly in the existing template.

Storing Extra Drawings in the Library
To store the extra drawings in the Library, you can select the cells inside the body part Symbol containing the new
drawings and drag them to the Library view to create new templates.
To store facial expressions and extra drawings in the Library:
1.
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In the Library view, right-click (Windows) or [Ctrl]+click (Mac OS X) on the desired library folder and select Right
To Modify.
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2.

In the Timeline view, select the cells containing the new extra drawings.

OR

3.

Drag the selection onto the desired Library’s folder.
The Rename dialog box opens.

4.
5.

In the Name field, name the new template.
Click on the OK button.

To add new drawings to existing extra drawing templates:
1.

In the Library view, right-click (Windows) or [Ctrl]+click (Mac OS X) on the library folder containing the template
to modify and select Right To Modify.

2.

In the Library view’s right side, right-click (Windows) or [Ctrl]+click (Mac OS X) on the template to modify and
select Edit Template.

3.

A new Animate application opens.
In the template’s timeline, add the new drawings.
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4.
5.
6.

In the Tools toolbar, select the Pivot
tool and in the Camera view, set the pivot directly on the new drawing’s
cell. In this case, you do not set the pivot on the Symbol’s cell.
In the top menu, select File > Save. The default keyboard shortcut is [Ctrl]+[S] (Windows) or [a]+[S] (Mac OS X).
In the top menu, select File > Quit (Windows) or Animate > Quit Toon Boom Animate (Mac OS X).

Refer to Libraries, Symbols and Templates > Editing a Template, on page 394 to learn more about editing
templates.

474

Chapter 11
Setting Up the Scene

Setting up your scene can be compared to building a set for a television show. This is the point when you position
each scene element such as the Camera frame, the background elements and the characters.
In this chapter, you will learn about the following:

•
•
•
•
•
•
•
•

Importing the Scene Components, on page 476
Setting the Camera Frame, on page 477
Positioning the Scene Components, on page 481
Cloning and Duplicating Layers, on page 501
Setting Up the Network (PRO), on page 503
Display Concepts (PRO), on page 522
Creating a Multiplane, on page 525
Scene Setup Preferences, on page 530
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Importing the Scene Components
The first step in the scene setup task is gathering up the scene’s different components and then importing them into
your project.
Refer to the Setting Up the Network (PRO) and Display Concepts (PRO) sections to learn more about the
Network view connections and display concepts.

Backgrounds, Sounds and Movie
Refer to the following sections of the Gathering Content chapter to learn more about importing backgrounds
and movies:

•
•

Importing Bitmap Images in Animate, on page 338
Importing QuickTime Movies in Animate, on page 366
Refer to Working With Sound chapter > Importing a Sound File, on page 564 to learn more.

Templates and Symbols
Refer to Libraries, Symbols and Templates > Importing Symbols and Templates, on page 395 to learn more.
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Setting the Camera Frame
The scene action occurs inside the camera frame, so it’s really important to set it up correctly.
Adding a Camera Layer, on page 477
Setting the Camera Using the Translate and Rotate Tools, on page 478
Setting the Camera using the Camera Layer Properties, on page 479
Resetting the Camera Position, on page 480
Camera List, on page 480

•
•
•
•
•
NOTE:

The Camera layer is static which means that if you need to animate it, you will have to add a peg.
Refer to the Creating Animation Paths chapter to learn how to animate layers using pegs.
Refer to Working in a True 3D Space (PRO) > 3D Camera Motion (PRO), on page 556 to learn more about
setting and moving the camera in the 3D space.

Adding a Camera Layer
To set the camera frame, you need to add a Camera layer into your scene so that you can edit the default camera
frame.
To add a Camera layer in the Timeline view:
1.
2.

In the Timeline view, click on the Add Layer
Insert > Camera from the top menu.
Select Camera from the drop-down menu.

button. You can also select

A new Camera layer will be added to your scene and will appear in the Timeline view.

NOTE: You cannot add a camera inside a Symbol. If you try to do so, a warning message will pop-up and inform
you that this operation is not possible.

In Animate Pro, you can also use the Network and Module Library views to add a Camera layer into your scene.
To add a Camera module in the Network view:
1.
2.

Display the Network view.
In the Module Library view, select a Camera module from the Favorites, Move or All Modules tab.
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3.

Drag the Camera module into the Network view.

Setting the Camera Using the Translate and Rotate Tools
You can reposition your camera frame directly in the Camera view, using the Translate

and Rotate

tools.

To reposition the camera frame directly in the Camera view:
1.
2.

Select Animation > Tools > Translate, or use the default keyboard shortcut [Alt]+[2].
In the Camera view, click on the camera frame to select it. You can also select the Camera layer from the
Timeline view.
When selected, the camera frame will be highlighted in purple.
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3.

Drag the camera frame to a new position.

4.

If you want to tilt the camera frame, select Animation > Tools > Rotate, you can also use the default keyboard
shortcut [Alt]+[3].
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5.

In the Camera view, click on the camera frame to select it and rotate the camera frame until it reaches the
desired rotation angle.

NOTE: The Translate and Rotate tools can also be found in the Advanced Animation toolbar.
Refer to the Discovering the Interface > Managing the Toolbars, on page 62 to learn how to display the
Advanced Animation toolbar.

Setting the Camera using the Camera Layer Properties
One way to set up your camera frame is to type the coordinates directly in the Camera Properties dialog box. Doing
this positions the camera precisely where you want it.

In Animate Pro, you can also position your Camera in the true 3D space and create 3D camera movements.
Refer to Working in a True 3D Space (PRO) > 3D Camera Motion (PRO), on page 556 to learn more about setting
the camera in the 3D space.

To set up the camera frame using the camera Layer Properties:

 In the Timeline view, double-click (Windows) or [Ctrl]+click (Mac OS X) on the Camera layer.
The camera Layer Properties dialog box opens.
1

2

3
4

5
6

7
8
9

10

The legend below explains each of the Layer Properties:
1.

Use the Enable/Disable check box to enable or disable the Camera layer.
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2.

The Lock

and Onion Skin

buttons.



Once you are satisfied of the camera frame position, you can use the Lock
layer and prevent changes on the Camera frame position.



The Onion Skin

button to lock the Camera

button is used to enable the Onion Skin feature in the Camera and Drawing view.

3.
4.

The Name field displays the current layer name and is used to rename it. Type in the new layer name.
The Position section displays the current position of the Camera layer using X-axis (East, West), Y-axis (North,
South) and Z-axis (Forward, Backward) coordinates. To reposition your camera frame, type in the new values
corresponding to the desired position coordinates. You can also use the up and down arrows to set the value of
each field.
5. The Angle field displays the current rotation value. To set a new rotation position, type in a new angle value. You
can also use the up and down arrows to set the new angle value.
6. The Pivot field displays the current position of the rotation pivot of the Camera layer. The Camera will perform a
rotation taking the position of the pivot as its angle centre. By default, the pivot is set at the centre of the
camera frame. To reposition the pivot point, type in new X and Y coordinates values in the appropriate field. You
can also use the up and down arrows to set the position values.
In order to see the pivot's position you will need to have the Rotate tool selected.
7. Enable the Override Scene FOV check box to enable the FOV field in which you can type in a new field-of-view
value.
8. The FOV field displays the current field-of-view default value. When enabled, you can type in a new zoom value
for your camera frame. You can also use the up and down arrows to set the new zoom value.
9. Use the Set Default FOV to reset the custom zoom value to its default value.
10. The Function button is used when animating the camera zoom value. Refer to the Creating Animation Paths
chapter to learn more about creating functions.

Resetting the Camera Position
Once you set up your camera frame, you can always easily reset it to its original position. Use the Reset command to
reset the value of the selected element to the initial value of the active tool. For example, if the Rotate
active, the transformation angle will be reset to 0 and if the Transform
values will be reset.

tool is

tool is active, then the entire transformation

To reset the camera position:
1.

In the Tools toolbar, select the Transform

tool. The default keyboard shortcut is [Alt]+[Q].

2.
3.

In the Timeline or directly in the Camera view, select the Camera layer.
Select Animation > Reset. You can also use the default keyboard shortcut [Ctrl]+[Shift]+[Z] (Windows) or
[a]+[Shift]+[Z] (Mac OS X).
The camera will automatically return to its original position.

Camera List
You can only see one camera at the time in the Timeline view. If you add several cameras to your scene and you want
different settings on each, you can use the Camera List to display each of them. You can use this feature if you are still
working on your scene composition and you have different camera setups to choose from.
To select a camera from the Camera list:
1.

In the top menu, select Scene > Camera > the desired camera.
If you only add one camera to your scene, you will only see Default Camera in your list.
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Positioning the Scene Components
Setting up the scene also involves positioning the different scene elements within the camera frame.

Animate Mode
When positioning elements, make sure that the Animate mode is disabled, or it will create a keyframe within the
drawing layer.
To disable Animate Mode:

 In the Tools toolbar, click on the Animate Mode

button.



When the Animate Mode button looks pushed in and highlighted it means it is enabled.



When the Animate Mode button looks popped up it means it is disabled.

Selecting a Layer
There are different ways of selecting the layers you want to reposition in the Camera view.
The topic is divided as follows:

•
•
•
•
•

Selecting a Layer from the Camera View using the Transform Tool, on page 481
Bounding Box Selection Style (PRO), on page 482
Finding the Selected Layer in the Timeline View, on page 482
Finding the Selected Layer in the Network View (PRO), on page 483
Transform Tool Properties, on page 483

Selecting a Layer from the Camera View using the Transform Tool
You can select your elements directly in the Camera view using the Transform

tool. When you select the Transform

tool, its properties and options appear in the Tool Properties view.
When using the Transform
Selection Mode
only.

tool to select element in the Camera view, always make sure that the Peg

option in the Transform Tool Properties view is disabled or else it will limit the selection to peg

To select from the Camera view:
1.

In the Tools toolbar, select the Transform

tool. The default keyboard shortcut is [Alt]+[Q].

2.

In the Transform Tool Properties view, make sure that the Peg Selection Mode

3.

In the Camera view, select the element to be repositioned. You can select more than one element at a time.

is disabled.

The corresponding layers and columns will be highlighted in the Timeline and Xsheet views.
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Bounding Box Selection Style (PRO)
You can change the display style of selected elements to Bounding Box. This will remove the normal selection
coloured highlight and leave only the bounding box around your selected element.

Normal Selection Style

Bounding Box Selection Style

To set the bounding box selection style:
1.

Select View > Show > BBox Selection Style.

Finding the Selected Layer in the Timeline View

When you have several layers in your Timeline view, you may find it hard to locate which one is selected. Animate has
an easy solution to this problem, you can use the Centre on Selection feature to display the selected layer in the
Timeline view.
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To centre on the selected layer:
1.
2.

In the Camera view, select the desired layer.
Make the Timeline view the current active view.

3.

Press the default keyboard shortcut [Shift]+[O] or press the Centre On Selection
Timeline View toolbar’s extra buttons.

button available in the

Refer to the Discovering the Interface > Managing the Toolbars, on page 62 to find out more about customizing
the toolbars.

Finding the Selected Layer in the Network View (PRO)
Just as with the Timeline view and the many layers contained in it, when you have several modules in your Network
view, you may find it hard to locate which one is selected. You can also use the Centre on Selection feature to focus
on the selected module in the Network view.
To centre on the selected layer:
1.
2.

In the Camera view, select the desired layer.
Enable the focus in the Network view.

3.

In the Network View menu, select View > Centre on Selection. You can also press the Centre On Selection
button available in the Network View toolbar’s extra button.

Transform Tool Properties

Select and Transform tool
Switch between the Transform and Select tools directly from the Transform or Select Tool Properties views.

Lasso and Marquee
Choose between the Lasso and the Marquee mode to change the selection style of the Transform tool.

•

Click and hold [Alt] to temporarily switch from the current selected mode to the other.
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Peg Selection Mode
Enable this option to limit the selection in the Camera view to pegs. When disabled, the Transform
the drawing layers.

tool selects

Snap Option
When transforming or repositioning your layer using the Transform tool, you can enable different snap options to help
you.

•

Snap and Align
Snaps the selected layer to any existing line, while automatically displaying temporary rulers that guide you
and that you can also snap your object to.

•

Snap to Grid
Snaps your selection according to the currently enabled grid.

Hide Manipulator Controls
Enable this option to hide the bounding box and manipulator controls from the Camera view when an element is
selected.
Refer to following topics from the Drawing and Animating chapter to learn more about the Snapping options
utilities and the Grid feature:
Reshaping a Drawing Using the Contour Editor Tool > Contour Editor Tool Properties > Snap Options, on
page 116
More Drawing Tools > Show Grid, on page 145

•
•

Flip Horizontal and Flip Vertical
Use these buttons to flip the selected element horizontally or vertically.
You can also select Animation > Flip > Flip Horizontal and Flip Vertical or use the default keyboard
shortcut [4] and [5].

•

Rotate 90 Degrees Clockwise and Rotate 90 Degrees Counter-clockwise
Use these buttons to rotate the selected element 90 degrees clockwise or counter-clockwise.

Width and Height
Use these fields to enter specific values when you want to accurately resize the selected layer.
3
1
2
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1. Width: type a width value in this field to resize the width of your selection.
2. Height: type a height value in this field to resize the height of your selection.
3. Use the up and down arrows to modify the value contained in either the
Width or Height value field.
4. Lock icon: Click on the lock icon to either lock or unlock the ratio between
the width and height values.
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Offset X and Y
Use these fields to enter specific values to reposition the selected layer accurately.
1. X: type an offset value in this field to reposition the selected layer along the X-axis.
2. Y: type an offset value in this field to reposition the selected layer along the Y-axis.
3 3. Use the up and down arrows to modify the value contained in either the X or Y value
field.

1
2

Angle
Use this field to enter specific values to rotate the selected layer accurately. A positive value will rotate the layer
counter-clockwise and a negative value will rotate the layer clockwise.
1. Angle: type a degree value in this field to rotate the selected layer.
2 2. Use the up and down arrows to modify the value contained in the Angle value field.

1

Locking Layers in the Timeline View
You can prevent correctly positioned layers from being selected by locking them in the Timeline view. Useful for
making a multiple selection inside the Camera view and leaving them visible.
You can perform five types of locking actions on your layers:

•
•
•
•
•

Lock
Unlock
Lock All
Unlock All
Lock All Others

Lock
Use the Lock option to lock one or a multiple selection of layers.
To lock a layer or a selection of layers:
1.

In the Timeline view, select one or many layers.

2.

In the top menu, select Animation > Lock > Lock. You can also click on one of the selected layer’s Lock
or use the default keyboard shortcut [Ctrl]+[Alt]+[L] (Windows) or [a]+[Alt]+[L] (Mac OS X).

icon

This will automatically lock all the selected layers.

485

Animate Pro 2 User Guide

Unlock
Use the Unlock option to unlock one or a multiple selection of locked layers.
To unlock a locked layer or a selection of locked layers:
1.

In the Timeline view, select one or many locked layers.

2.

In the top menu, select Animation > Lock > Unlock. You can also click on one of the selected layer’s Lock
icon or use the default keyboard shortcut is [Ctrl]+[Shift]+[K] (Windows) or [a]+[Shift]+[K] (Mac OS X).
This will automatically unlock all the selected locked layers.

Lock All
Use the Lock All option to lock all the layers in the Timeline view at once.
To lock all layers:

 In the top menu, select Animation > Lock > Lock All. You can also click on one of the selected layer’s Lock
icon or use the default keyboard shortcut [Ctrl]+[Shift]+[L] (Windows) or [a]+[Shift]+[L] (Mac OS X).
This will automatically lock all the layers.

Unlock All
Use the Unlock All option to unlock all the layers in the Timeline view at once.
To unlock all layers:

 In the top menu, select Animation > Lock > Unlock All. You can also use the default keyboard shortcut
[Ctrl]+[Alt]+[Shift]+[L] (Windows) or [a]+[Alt]+[Shift]+[L] (Mac OS X).
This will automatically unlock all the layers.

Lock All Others
Use the Lock All Others option to lock every layer except the selected ones.
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To lock all other layers:
1.

In the Timeline view, select the layers that you do not want to lock.

2.

In the top menu, select Animation > Lock > Lock All Others. You can also use the default keyboard shortcut
[Ctrl]+[Alt]+[Shift]+[O] (Windows) or [a]+[Alt]+[Shift]+[O] (Mac OS X).
This will automatically lock all the layers except the selected ones.

Selecting an Element from the Timeline or Xsheet View
You can also select your elements from the Timeline or Xsheet view. This can be useful when there are too many
objects in the scene or when an object is hard to grab.
To select from the Timeline or Xsheet view:




In the Timeline view, click on the layer corresponding to the element you want to reposition.
In the Xsheet view, click on the column header corresponding to the element you want to reposition.

The selected element will be highlighted in the Camera view.

Positioning an Element using the Transform Tool
Using the Transform tool, you can easily reposition, scale, rotate and even skew the layers directly in the Camera view.
When positioning a drawing layer using the Transform tool, always make sure that the Peg Selection Mode
is disabled in the Transform Tool Properties view, or it will limit the selection to pegs in the Camera view.
Refer to Working in a True 3D Space (PRO) > Positioning the Scene Components, on page 481 to learn about
the 3D Transform tool and how to position your elements in the 3D space.

Repositioning the Pivot Point Temporarily
Some transformations, such as rotation, scale, skew and flip, are made relative to the pivot point position. You can
temporarily reposition this pivot point for each transformation using the Transform

tool.

To temporarily reposition the pivot point:
1.

In the Tools toolbar, select the Transform

tool.

2.
3.

In the Transform Tool Properties view, make sure that the Peg Selection Mode
In the Camera view, click on your element to select it.

is disabled.

The pivot point will appear in the Camera view.
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4.

Click on the pivot point and drag it to a new position.
This will be the new position of the pivot point for the current transformation. It will remain in this new position
as long as you do not deselect the drawing.

NOTE: Using the Transform
tool to reposition your pivot will temporarily override the existing pivot point
position until you complete the current transformation, it then returns automatically to its original position.
When you translate the pivot using the Transform tool, the permanent pivot will appear as a ghost so you know
where it is and also from where the animation will be interpolated when you create motion paths. The animation is
always interpolated from the original pivot and not the temporary pivot.

Panning a Drawing Layer
To pan a layer using the Transform tool:
1. In the Tools toolbar, select the Transform

tool.

2.In the Transform Tool Properties view, make sure that the Peg Selection Mode
is disabled.
3. In the Camera view, select a drawing layer and drag the selection to a new
area.

Rotating a Drawing Layer
To rotate a layer using the Transform tool:
1. In the Tools toolbar, select the Transform

tool.

2.In the Transform Tool Properties view, make sure that the Peg Selection Mode
is disabled.
3. In the Camera view, select the drawing layer and rotate the transform
bonding box handle.
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Scaling an Element
To scale a layer using the Transform tool:
1. In the Tools toolbar, select the Transform

tool.

2.In the Transform Tool Properties view, make sure that the Peg Selection Mode
is disabled.
3. In the Camera view, select the drawing layer and then pull or push either on
the size, top or corner control point. Hold down [Shift] to lock the selection’s
ratio.

Skewing an Element
To skew a layer using the Transform tool:
1. In the Tools toolbar, select the Transform

tool.

2. In the Transform Tool Properties view, make sure that the Peg Selection
Mode
is disabled.
3. In the Camera view, select the drawing layer and drag sideway or up and
down the sides or top and bottom segments, between the control points.

Using Advanced Animation Tools to Position a Layer
You can also use the advanced animation tools to position your layers.

Permanently Repositioning the Pivot Point
Some transformations, such as the rotation, scale, skew and flip, are made relative to the pivot point position.
Reposition this pivot point anywhere using the current advanced animation tool.
To permanently reposition the pivot point:
1.

In the Advanced Animation toolbar, select the Rotate

2.

In the Camera view, [Ctrl]+click (Windows) or [a]+click (Mac OS X) to select your element. The pivot point will
appear in the Camera view.

, Scale

or Skew

tool.

3.

Click on the pivot point and drag it to a new position.

This is the new position of the pivot point for future transformations until you reposition it.
NOTE: Using the Advanced Animation tools to reposition your pivot permanently overrides the existing pivot point
position until you change its position again.

489

Animate Pro 2 User Guide

Panning an Element using the Translate Tool
To pan a layer using the Translate tool:
1. Select Animation > Tools > Translate. You can also use the default
keyboard shortcut [Alt]+[2].
2. In the Camera view, [Ctrl]+click (Windows) or [a]+click (Mac OS X) on the
element to select it and drag the selection to a new area.
You can select multiple layers to reposition them at the same time.
[Ctrl]+[Shift]+click (Windows) or [Ctrl]+[Shift]+click (Mac OS X) on each
element to select them.

Rotating an Element using the Rotate Tool
To rotate a layer using the Rotate tool:
1. Select Animation > Tools > Rotate. You can also use the default keyboard
shortcut [Alt]+[3].
2. In the Camera view, [Ctrl]+click (Windows) or [a]+click (Mac OS X) on the
element to select it and rotate the layer.
You can select multiple layers to rotate them at the same time.
[Ctrl]+[Shift]+click (Windows) or [a]+[Shift]+click (Mac OS X) on each
element to select them.

Scaling an Element using the Scale Tool
To scale a layer using the Scale tool:
1. Select Animation > Tools > Scale. You can also use the default keyboard
shortcut [Alt]+[4].
2. In the Camera view, [Ctrl]+click (Windows) or [a]+click (Mac OS X) on the
element to select it and pull or push either on the side, top or corner control
point. Hold down [Shift] to lock the selection’s ratio when using the corner
control points.
You can select multiple layers to scale them at the same time.
[Ctrl]+[Shift]+click (Windows) or [a]+[Shift]+click (Mac OS X) on each
element to select them.

Skewing an Element using the Skew Tool
To scale a layer using the Skew tool:
1. Select Animation > Tools > Skew. You can also use the default keyboard
shortcut [Alt]+[5].
2. In the Camera view, [Ctrl]+click (Windows) or [a]+click (Mac OS X) on the
element to select it and drag a side of the bounding box up, down or
sideways.
You can select multiple layers to skew them at the same time.
[Ctrl]+[Shift]+click (Windows) or [a]+[Shift]+click (Mac OS X) on each
element to select them.
NOTE: The Translate, Rotate, Scale and Skew tools can also be found in the Advanced Animation toolbar.
Refer to the Discovering the Interface chapter to learn how to display the Advanced Animation toolbar.
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Flipping an Element
There are two different options you can use when you want to flip your element.

Flip Horizontal and Flip Vertical
The Flip Horizontal and Flip Vertical options flip your drawing layer along Camera view’s horizontal and vertical axis.
To flip a layer:
1.In the Transform Tool Properties view, make sure that the Peg Selection Mode
is disabled.
2.In the Camera view, select the drawing layer you want to flip using the
Transform

tool.

3. Select Animation > Flip > Flip Horizontal or Flip Vertical. You can also use
the default keyboard shortcuts [4] and [5].

Flip Scale X and Flip Scale Y
Once your drawing layer has been rotated, the original horizontal and vertical axes change. The Flip Scale X and
Flip Scale Y will perform a flip on your drawing layer following its original axis.
The red bar represents the
original X-axis

Flip Horizontal
The Flip Horizontal command flips the Layer
following the Camera view X-axis.

Flip Scale X
The Flip Scale X command remembers the original X-axis
of the layer and flips the element following it.
To flip an element following its original axis:
1.

In the Transform Tool Properties view, make sure that the Peg Selection Mode

2.

In the Camera view, using the Transform

3.

Select Animation > Flip > Flip Scale X or Flip Scale Y.

is disabled.

tool, select your element that has already been transformed.
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Positioning an Element Using the Layer Properties
To position an element using its Layer Properties dialog box:
1.

In the Timeline view, right-click (Windows) or [Ctrl]+click (Mac OS X) on the Drawing layer and select Layer
Properties. The default keyboard shortcut is [Shift]+[E]. You can also double-click on the layer, or click once and
see the properties in the Layer Properties view.



In Animate Pro, you can also open the Layer Properties dialog box from the Network view by clicking
on the module’s square yellow button.

The drawing Layer Properties dialog box opens.

In Animate Pro, you can position an element in the true 3D space.

•

The Enable 3D check box displays the 3D parameters in the Layer Properties.

Refer to Working in a True 3D Space (PRO) > Positioning the Scene Components, on page 481 to learn more
about the 3D parameters and how to use them to position your element in the 3D space.
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2.

In the Position section, type in the desired value of the new element position.

 Enable the Separate check box option to enable the edit of the different coordinate fields.
 Enable the 3D Path check box option to enable the use of a 3D path function when animating your element.
Refer to the Creating Animation Paths chapter to learn more about 3D paths and Velocity.
In the (x) Axis field, type in a new East/West coordinate corresponding to the desired position.
In the (y) Axis field, type in a new North/South coordinate corresponding to the desired position.
In the (z) Axis field, type in a new Forward/Backward coordinate corresponding to the desired position.
Refer to the Creating a Multiplane topic to learn more about positioning layers on the Z-axis.





3.

The Function

buttons are used to create function curves when animating.

In the Scale section, type in the desired value to set the new element size.

 Enable the Separate check box to be able to resize your element with independent X and Y scales. This allows
you to squash and stretch.
(xy) Axis: Type in the horizontal and vertical scales value.
 Enable the Locked check box to resize your element while keeping its ratio.
 (x) Axis: Type in the horizontal scale value.
 (y) Axis: Type in the vertical scale value.
4. In the Angle Z field, type in a degree value between -360 to 360 for the rotation angle.



5.

In the Skew field, type in a degree value between -90 to 90 for the skew angle.

6.

In the Pivot section, type in the desired coordinate value to reposition the transformation pivot. This will change
the permanent position of the pivot.




In the (x) Axis field, type in a new East/West coordinate corresponding to the desired position.
In the (y) Axis field, type in a new North/South coordinate corresponding to the desired position.

As you type in the new values, the element’s position is updated in the Camera view.

pegs.

Refer to the Creating Animation Paths chapter to learn more about function curves and animating elements on
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Drawing Layer Properties Advanced Tab
In the Drawing Layer Properties dialog box, you will find an advanced tab containing some very useful options:

Animation (PRO)

•

Animate Using Animation Tools: By default, a Drawing layer can be animated, but Animate Pro gives
you the ability to disable this feature. Being able to switch your drawings so they can no longer be animated
without a peg has certain advantages. It means that you can have access to the drawing substitution feature
for this Drawing layer, while being able to create keyframes on it’s parent peg. This feature is also available
for backward compatibility when bringing in templates created in older versions of the software, so as not
to lose their offset keyframes or drawing substitution keyframes.
Refer to Chapter 15: Animating Your Puppets to learn more about the Animate Using Animation Tools option.

Vector Options
In Animate Pro, the following options as well as exclusive ones are available in the Drawing tab of the Layer
Properties view. Refer to Drawing Layer Properties Drawing Tab (PRO), on page 497 to see the complete list of
options available.

•
•
•
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Read Line Art: Enable this option to display and render the Line Art layer of this drawing layer in your scene
and final export. Disabling it will hide it.
Read Colour Art: Enable this option to display and render the Colour Art layer of this drawing layer in your
scene and final export. Disabling it will hide it.
Antialiasing Quality: Smoothness setting applied to Colour Art.
D Low: No antialiasing
D Medium Low: Some antialiasing
D Medium: Medium antialiasing
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D High: Extensive antialiasing

•

•

•

The higher the chosen setting, the greater the amount of antialiasing that is applied. Higher quality images
require more time to render and more system memory. Choose a lower quality if you are rendering a Pencil
Test.
Antialiasing Exponent: Controls the size of the area around the Line and Colour Art edges that is used in
the antialiasing process. A higher value uses less area, resulting in sharper edges, while a lower value uses a
larger area, resulting in softer edges. If the Antialiasing Quality value is set to Low (no antialiasing), this
value is ignored.
Texture Filter: This option changes the way coloured pixels of TVG textures are calculated when rendered
for different degrees of accuracy.
D Bilinear: This option takes the four pixels around each point and makes a bilinear interpolation
between them. (Medium Quality)
D Nearest: This option chooses the colour of the closest pixel to a point. (Lower Quality)
D Nearest (Filtered): This option is an improved version of Bilinear and improves the quality when
zooming on a texture. (Best Quality)
Morphing Velocity: Attaches a function curve to interpolate the morphing velocity between two frames.
The morphing velocity at a specific frame is the ratio of the difference between the current frame in relation
to the first and last frames of the morphing.

To learn about the Morphing Velocity option, refer to Morphing Drawings > Adjusting the Velocity and
Timing, on page 312.

Angle Limit Value (PRO)
Use this section to set a maximum and minimum rotation angle for your drawing. You will mainly use the option for a
cut-out character when you do not want an elbow to bend too far in or too far out.

•
•
•

Enable Min/Max Angle: Enable this option if you want to activate the minimum and maximum angle
constraints.
Min Angle: Type the minimum angle you want the drawing to rotate too.
Max Angle: Type the maximum angle you want the drawing to rotate too.

Spline Offset (PRO)
In the X Y and Z axis fields, type the coordinated to where you want to offset the visual trajectory. By the default, the
trajectory is displayed at the centre of the Camera view. If you want to move it so it corresponds better to your
drawing, either type new coordinates of use the Spline Offset tool available in the Advanced Animation toolbar.
To display the trajectory in the Camera view, select your drawing and select View > Show > Control.

Alignment (PRO)

•

Alignment Rule: The alignment rule selections are intended to deal with drawings that were created on
paper of a different size or orientation from the default alignment rule (set up in the Scene Setting dialog
box). If you select Turn Before Alignment, the drawings are rotated and then scaled, based on the option
selected from the drop-down list. The drawings are then scaled to match Animate alignment rectangle.
D Left: The default alignment for drawings; aligns the drawings on the left side of the scene’s alignment
rectangle. Animate Pro scales the drawings to match their height to the alignment rectangle of the
scene.
D Right: Aligns the drawings on the right side of the alignment rectangle. Animate Pro scales the
drawings to match their height to the height of the alignment rectangle of the scene.
D Top: Aligns the drawings on the top of the alignment rectangle. Animate Pro scales the drawings to
match their widths to the width of the alignment rectangle of the scene.
D Bottom: Aligns the drawings on the bottom of the alignment rectangle. Animate Pro scales the
drawings to match their widths to the width of the alignment rectangle of the scene.
D Centre Fit: Centres the drawings.
D Centre Fill: Centres the drawings and then scales them so that the width or height fills the available
space.
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D Centre LR: Aligns the drawings in the left-right centre of the alignment rectangle. Animate Pro scales
the drawings to match their height to the height of the alignment rectangle of the scene.

D Centre TB: Aligns the drawings in the top-bottom centre of the alignment rectangle. Animate Pro
scales the drawings to match their widths to the width of the alignment rectangle of the scene.

D Stretch: Scales the drawings so that they fit within the alignment rectangle of the scene. This is

•

•
•

particularly useful for images that you will manipulate with a Quadmap Module. If the drawings in the
Quadmap Module do not have the same aspect ratio as the alignment rectangle of the scene (from the
Scene Settings dialog box), the handles on the quadmap will not appear on the corners of the image,
making it difficult to manipulate the quadmap. In this case, you would set the Drawing Layer of the
quadmap images to “Stretch” so that the handles appear on the corner of the image. This can have the
effect of distorting the images, but this is not an issue with images that will be distorted through the
Quadmap Module anyway.
D As Is: Leaves the drawings aligned as they are.
D Centre First Page: Aligns the centre of the first part of a standard pan cel with the centre of the field
chart.
Turn Before Alignment: This option rotates the drawings in the selected element 90 degrees to the left
before scaling and aligning them according to the alignment rule, and before performing any offset,
rotation or scaling for the element or the peg. This and the Alignment Rule are intended for drawings that
were created on paper of a different size or orientation than the other paper in the scene, and requires
alignment so as to be able to accurately treat them.
Flip Horizontal: Flips the drawing on the X-axis.
Flip Vertical: Flips the drawing on the Y-axis.

Clipping (PRO)

•
•

No Clipping: Select this option if you do not want to clip the images in this module before an effect is
applied to it.
Clipping Factor (X)/(Y): This is an option for rendering images that are larger than the final frame. With this
option enabled, images can be moved by a PApply Peg Transformation module without black entering into
the composite as a result of early clipping. In addition, this option is useful for images that have a blur that
should appear in the frame even though the image itself is not in frame.

Line Thickness (PRO)

•
•
•
•
•
•

Normal Thickness: Disables all overrides on the Line Art thickness.
Zoom Independent Thickness: Select this if you do not want to display Line Art thickness in proportion the
amount of zoom in the view window. Everything else will increase in size, but the Line Art thickness will stay
the same.
Proportional: Enter a multiple by which you want to increase the Line Art thickness. Entering 1 will result in
no change; entering 0 (zero) will hide Line Art.
Constant: Enter a value in pixels (based on a 740x540 screen resolution) at which to maintain the Line Art
thickness.
Minimum: Enter a value in pixels (based on a 74 x540 screen resolution) for the minimum Line Art thickness
allowed.
Maximum: Enter a value in pixels (based on a 740x540 screen resolution) for the maximum Line Art
thickness allowed.

To modify the Line Art thickness:

•
•
•
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The Line Art must be created with a brush stroke (Select Drawing > Convert > Convert Pencil Lines to
Brush Strokes).
The Line Art must be converted to Colour Art (Select Drawing > Create Colour Art from Line Art).
To view this feature in the Camera view, you must first activate the Enable Variable Line Thickness option,
found in the OpenGL tab in the Preferences Panel. Refer to the OpenGL Tab Preferences topic to learn
more about this option.
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Drawing Layer Properties Drawing Tab (PRO)

•
•
•

Full Name: Select which element to connect to the module from the drop-down list of elements that
already exist in your scene.
Drawing Path: Displays the full path to the current drawing.
Use Embedded Pivots: By default, this option is set to Apply Embedded Pivot on Drawing Layer.
D Don’t Use Embedded Pivot: When this option is selected, the layer will not use the pivot set on the
drawing or Symbol. The pivot will be located at the centre of the Camera view, meaning (0,0,0). If there
is a transformation applied on the layer, the pivot will be offset following the transformation.
D Apply Embedded Pivot on Parent Peg: When this option is selected, the pivot set on the drawing or
Symbol will automatically be applied to the first Peg layer the drawing layer is connected to. When
selecting the element in the Camera view using the Transform tool, the Peg layer will be selected. Even
when the Drawing layer is selected in the Camera view, the transformation will be applied on the
parent Peg.
D Apply Embedded Pivot on Drawing Layer: This is the most common behavior a user will use.
Automatically, the layer will use the pivot that was set on the drawing or Symbol’s frame using the Pivot
tool.
Refer to the Building a Character > Setting the Pivots, on page 446 to learn about using embedded pivots.

Vector Options (PRO)

•
•
•
•
•

Read Overlay: Enable this option to display and render the Overlay layer of this drawing layer in your scene
and final export. Disabling it will hide it.
Read Line Art: Enable this option to display and render the Line Art layer of this drawing layer in your scene
and final export. Disabling it will hide it.
Read Colour Art: Enable this option to display and render the Colour Art layer of this drawing layer in your
scene and final export. Disabling it will hide it.
Read Underlay: Enable this option to display and render the Underlay layer of this drawing layer in your
scene and final export. Disabling it will hide it.
Antialiasing Quality: A smoothness setting applied to Colour Art.
D Low: No antialiasing
D Medium Low: Some antialiasing
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D Medium: Medium antialiasing
D High: Extensive antialiasing

•

•

The higher the chosen setting, the greater the amount of antialiasing that is applied. Higher quality images
require more time to render and more system memory. Choose a lower quality if you are rendering a Pencil
Test.
Antialiasing Exponent: Controls the size of the area around the Line and Colour Art edges that is used in
the antialiasing process. A higher value uses less area, resulting in sharper edges, while a lower value uses
more area, resulting in softer edges. If the Antialiasing Quality value is set to Low (no antialiasing), this value
is ignored.
Texture Filter: This option changes the way coloured pixels of TVG textures are calculated when rendered
for different degrees of accuracy.
D Bilinear: This option takes the four pixels around each point and makes a bilinear interpolation
between them. (Medium Quality)
D Nearest: This option chooses the colour of the closest pixel to a point. (Lower Quality)
D Nearest (Filtered): This option is an improved version of Bilinear and improves the quality when
zooming on a texture. (Best Quality)

Bitmap Options (PRO)

•

•
•

•
•

Read Colour: Controls the production of colour information from bitmap images. If this module reads 3 or
4-channel bitmaps, this selection determines whether the colour should be read or ignored. If this module
reads 1-channel bitmaps, this selection determines whether the channel should be read as colour. When this
option is selected with 1-channel images, the resulting image will be a greyscale image.
Read Transparency: Controls the production of alpha information from bitmap images. If this module reads
a 1 or 3-channel image, this option will create a matte from the colour values in the image. If the module
reads a 4-channel image and this option is not selected, the alpha information in the image will be ignored.
Transparency Type:
D Premultiplied with Black: Pixels at the edge of an image are blended with black.
D Premultiplied with White: Pixels at the edge of an image are blended with white.
D Straight: Pixels at the edge of an image are blended with black, white and greys.
D Clamp Colour to Alpha: Select this option when you want to pre-multiply the colour value with the
alpha value. When the colour is clamped to the alpha, the colour value cannot be higher than the alpha
value. It calculates the real colour value faster. When the RGB values are multiplied with the alpha
value, that is to say, if you have a pixel of value R=247, G=188, B=29 and the alpha is 50% or the image
has a 50% transparency, then the actual RGB values output would be half of the amounts listed above.
Depth: Overrides the order of cables in the network to determine how this element is rendered.
Morphing Velocity: Attaches a function curve to interpolate the morphing velocity between two frames.
The morphing velocity at a specific frame is the ratio of the difference between the current frame and the
first and last frames of the morphing.

To learn about the Morphing Velocity option, refer to Morphing Drawings > Adjusting the Velocity and
Timing, on page 312.
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Auto-Apply Option (PRO)
When you modify a parameter in a property dialog box, Animate Pro calculates the modification automatically and
displays the result immediately in the Camera view. If you do not want to immediately display every change made to
your scene, you can turn off this default setting by disabling the Auto-Apply option. For example, when you are
working on a very heavy scene.
Disabling this function will result in adding Apply and OK buttons at the bottom of your Layer Properties view and any
other parameter dialog box.

•
•

Click on the Apply button to apply the current change.
Click on the OK button to apply the current change and close the Layer Properties.

Auto-Apply is ON

Auto-Apply is OFF
No modifications in the editor

Auto-Apply is OFF
Modifications in the editor

To disable and enable the Auto-Apply option:

 In the top menu, select Edit > Auto-Apply.
If you wish to always work in Auto-Apply mode, you can disable the Auto-Apply preference.
When the preference is disabled, each time you launch the application, your Auto-Apply mode will be set to OFF. You
will need to click on the Apply button to see the modifications.
To disable and enable the Auto-Apply preference:
1.

2.
3.

In the top menu, select Edit > Preferences (Windows) or
Animate Pro > Preferences (Mac OS X).
The Preferences panel opens.
In the Preferences panel, go to the General tab.
In the Options section, disable or enable the Auto Apply preference.
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Resetting a Transformation
Once your layers are positioned in the Camera view, you can easily reset them to their original position. Use the Select
command to reset the value of the selected element to the initial value of the active tool. For example, if the Rotate
tool is active, the transformation angle will be reset to 0 and if the Transform
transformation values will be reset.
When using the Transform
Selection Mode
only.

tool is active, the entire

tool to select element in the Camera view, always make sure that the Peg

option in the Transform Tool Properties view is disabled or else it will limit the selection to peg

To reset the layers position:
1.

In the Tools toolbar, select the Transform

2.

In the Timeline or directly in the Camera view, select the drawing layers you wish to reset. You can select more
than one layer at a time.
Select Animation > Reset. You can also use the default keyboard shortcut [Ctrl]+[Shift]+[Z] (Windows) or
[a]+[Shift]+[Z] (Mac OS X).

3.

tool. The default keyboard shortcut is [Alt]+[Q].

The selected layers will automatically return to their original position.
In the Timeline view, you can also use the Clear All Values command to reset all transformation values on the
selected layers. Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selected layers and select Clear All Values.
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Cloning and Duplicating Layers
You may need to clone or duplicate a layer during a production. This allows you to modify the layers’s drawings or the
timing independently from the original column.

Clone Layer
A cloned layer is linked to the original element directory. If a drawing is modified in the original or cloned layer, both
will be updated. However, clone layers can have different timings.
For example, if you make a walk-cycle for a soldier and want to use it for a whole army, you may want to have fifty
layers with fifty different drawing exposures to produce a slight difference in the timing. You don’t necessarily want
the same drawing fifty times. If you copy your layers and their drawings fifty times over, it will create a very heavy
scene. It is better to clone the fifty layers from the same initial layer to have them all linked to the same walk cycle
drawings, producing fifty layers but one drawing directory. This will also allow you to correct the drawings in one layer
and have all of the other ones updated simultaneously.
When you clone a layer that is already linked to a function, the cloned layers are automatically linked to the same
function, so if you reposition the layers while in Animate
mode, they are all repositioned to the same place
because a keyframe is added to this function. If you want the layers to move on a trajectory that is independent, make
sure to unlink the function before cloning.
Refer to the Creating Animation Paths chapter to learn more about functions and trajectories.

To clone a layer:
1.

In the Timeline view, select the layer to clone.



2.

In the Network view, select the module you want to clone.

Select Edit > Clone from the top menu or you can also Right-Click (Windows) or [Ctrl]+click (Mac OS X) on the
selected layer and choose Clone Selected Layers from the pop up menu.



In Animate Pro:

D In the Timeline View menu, select Layers > Clone Selected Layers.
D In the Network View menu, select Modules > Clone Selected Modules.
Note that the module will not appear in the Timeline view if it is not connected to the Composite module
or if the Display mode is not set to Display All.

Refer to the Setting Up the Network (PRO) topic to learn more about modules and network connections.
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Duplicate Layer
You can duplicate a layer to have a copy of the drawings that are independent from the original column, as well as an
independent timing (exposure). When you need the drawings to be modified independently, you will want to
duplicate the layer instead of cloning it.

To duplicate a layer:
1.

In the Timeline view, select the layer to duplicate.



2.

In the Network view, select the module you want to duplicate.

Select Edit > Duplicate from the top menu or you can also Right-Click (Windows) or [Ctrl]+click (Mac OS X) on
the selected layer and choose Duplicate Selected Layers from the pop up menu.



In Animate Pro:

D In the Timeline View menu, select Layers > Duplicate Selected Layers.
D In the Network View menu, select Modules > Duplicate Selected Modules. When you duplicate a
module, it does not automatically connect itself to the composite module of your scene.

The duplicated layer appears.

Refer to the Setting Up the Network (PRO) topic to learn more about modules and network connections.
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Setting Up the Network (PRO)

The Network view uses a visual set of connections to show how each element in the scene is brought to the final
image. It allows you to add extra elements and effects, and to move beyond the possibilities offered by the Timeline
and Xsheet.
The following topics are explained here:

•
•

Network View (PRO)
Network Navigation and Basic Rules (PRO)

Network View (PRO)
6
4

5

1

2
3
1.
2.
3.

Modules
Navigator
Group Hierarchy Menu

4.
5.
6.

Editing Stack Menu
Network View Toolbar
Network View Menu

503

Animate Pro 2 User Guide

Network Navigation and Basic Rules (PRO)
The basic rules of the Network View are quite simple. Once they are understood, a lot can be accomplished. In this
section we discuss:

•
•
•
•
•
•
•
•
•
•

Modules (PRO)
Input and Output Ports (PRO)
Modules: Adding (PRO)
Modules: Organizing (PRO)
Modules: Connecting and Disconnecting (PRO)
Modules: Grouping (PRO)
Modules: Enabling and Disabling (PRO)
Modules: Thumbnails (PRO)
Navigator Display (PRO)
Cable Styles (PRO)

Modules (PRO)

Each element in the Network View is called a module. There are different types of modules:

•
•
•
•
•

Drawing Element Modules
Effect Modules
Input/Output Modules
Move Modules
Compositing Modules.

This is what they look like:
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•

Drawing Element modules transfer drawing information.

•

Effect modules process effects on drawings and transfer drawing information.

•

Input/Output modules are the interface between each module and network.
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•

Move modules control the camera and element transformations over time.

•

Composite modules combine multiple source images.

Input and Output Ports (PRO)
Each module carries an Input port at the top and an Output port, placed at the bottom. Some are blue while others
are light green or bright green.

•

Blue denotes drawing information

•

Light Green denotes position and movement

•

Bright Green shows the element on top of the composition and outputs that element’s Z position to the
Composite module. When many elements have different Z positions (multiplane, different distances from
the camera) and are placed through a Composite module that flattens them together (producing one image
with one Z value), the system needs to give a Z position to this new image. It uses the bright green port
element information.

Finally, some modules contain more than one Input port. These are usually Effects modules needing different drawing
or position information in order to perform their calculation.
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When the two ports are blue, the Drawing is on the right and Matte is on the left. If it is light green, the drawing needs
extra position information.

Modules: Adding (PRO)
Each module used to build a network is available in the Module Library view. In addition, each time you create a layer
from the Timeline or Xsheet views, the corresponding module is created in the Network view.
To import modules from the Module Library:

 In the Module Library, select the desired module and drag it in the Network View.

Modules: About the Composite Module (PRO)

All individual images
composited together

Final output
sent to rendering
module
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Individual Image used
for final output

Final output displayed
in the Camera view
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The Composite module is used to take several images and output a single image. You can compare that to doing precompositions in some editing software. You connect several drawing modules in your Composite module and one
bitmap comes out of it.
By default, the image coming out of the Composite module is a bitmap. The layers are composited together
depending on their position on the Z-axis (forward-backward) first, then their order in the Composite module. If two
images are at the same position on the Z-axis, their order in the Composite will determine which one is displayed in
front and which one is displayed behind.

Composite Layer Properties (PRO)

For more information about the Composite module options in a 3D environment context, refer to Working in a
True 3D Space (PRO) > Managing a Network with a 3D Scene Setup (PRO), on page 560.
Composite Options

•
•
•

As Bitmap: when selected, it composites all of the images into a single, flat bitmap image. The Z value of
the final image will be based on the Output Z selection.
As Vector: when selected, it composites all of the images as a single vector image. The Z value of the final
image will be based on the Output Z selection.
Pass Through: when selected, no compositing operations occur. No image will be merged or flattened.
Each individual image will keep its own properties. The compositing operations will happen only in the next
Composite module connected below. In this case, the Input Ordering options are ignored.
If a Composite set to Pass Through it is the last one in the compositing chain, it will act the same as the As
Bitmap option. At that point, the Input Ordering options will be considered.

Input Ordering Options

•

2D: when selected, elements connected in the module are composited based on their port ordering. The Zaxis (forward-backward) values are ignored. The scaling value will be correct, but the actual position on the
Z-axis will be ignored.
You can use the 2D composite type to create effects such as a camera recording overlay on your scene.
Since you always want this element to be in front regardless of the other elements Z-axis position, you can
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set the option to 2D.

•

3D Flat: when selected, the Z-axis value of the elements connected in the composite module are
considered, so the visual representation is correct in the Camera view. The output will be a flat image.

Seen in Perspective view

•

3D Flat Input

2D Input

3D: when selected, the Z-axis value of the elements connected in the composite module are considered, so
the visual representation is correct in the Camera view. The image will not be flattened. The 3D aspect of
the elements will be kept. For example, if you rotated elements on the three axes, the information will be
retained and elements composited in lower levels will be able to intersect with the elements coming from a
3D composite module.
The 3D Composite module should only be used in advanced cases. It is better to use a Pass Through
composite type than a 3D composite type. This way, all the elements are composited together in the final
Composite module.

Output Options

•

Output Z: use this selection to identify which element’s front-back value from the current composition will
be applied to the entire composited image in the next operation. If you select Portnumber, identify the
appropriate port by its position using the Port For Output Z menu. The port used appears in a bright green
the other ports on the Composite module. By default, the leftmost port is displayed in front and the
rightmost one is displayed behind.

Bitmap Options
These options are active when you select the As Bitmap option.

•
•

Apply Focus: this activates the Focus effect for this module in the composite operation.
Focus Multiplier: the value entered in this field is used as a multiplier for the radius value specified in the
Focus or Focus-Multiplier modules.

Vector Options
These options are active when you select the As Vector option.

•
•

508

Palette Name: when you render files, you can use this field to set the name of the palette files that Animate
will create for them.
Flatten: selecting this option will flatten the vector drawings into one vector drawing file. Any transparency
will be lost in the process. This creates smaller vector files, but might increase the time required to
composite the drawings. This can be useful when reusing drawings. Because they will be vector files, you
will still be able to apply vector-based transformations and effects.
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Modules: Organizing (PRO)
When you are working in the Network view, and adding many modules, your scene might look a bit messy and be
hard to follow. To fix this, Animate Pro provides the Order Network script which organizes and displays the modules
in a more orderly fashion.
To use the Order Network script to organize your network:
1.

In the Network View, select some or all of your modules.

2.

In the top menu, select Window > Toolbars > Scripting to display the Scripting toolbar and click on the
TB_orderNetworkUp

or TB_orderNetworkDown

button.

Refer to the following sections of the Discovering the Interface chapter to learn how to display toolbars and
customize your workspace:

D Managing the Views, on page 60
D Managing the Toolbars, on page 62
D Managing the Workspace, on page 64
The Order Network dialog box opens.

3.
4.
5.
6.

Set an X Overlap% value.
Set a Layer Spacing value.
Set a Vertical Spacing value.
Click on the OK button to reorder the network with the specified parameters.
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Modules: Connecting and Disconnecting (PRO)
Making and removing connections between the modules is as easy as a click and drag.
To connect modules:
1.

In the Network view, extend a cable from the first module’s output port and connect it in the second module’s
input port.
 You can also select the module to connect, hold down the [Alt] key and drag the module on an existing
cable.

[Alt]

To disconnect modules:
1.

In the Network view, pull a cable away from the module’s input port.
You can also select the module to disconnect, hold down the [Alt] key and drag the module away.



[Alt]
[Alt]

Modules: Grouping (PRO)
With so many connections and modules possible, the network can quickly become overcrowded. Grouping your
modules will help to keep things organized.

Grouping a Selection (PRO)
To group selected modules:
1.
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In the Network view, drag a selection around the modules you want to group.
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2.

Select Edit > Group > Group Selected Layers. You can also use the default keyboard shortcut [Ctrl]+[G]
(Windows) or [a]+[G] (Mac OS X).
Your modules are grouped.

To ensure that your group remains connected to the main Composite module through only one Output port it is
recommended that you include a Composite module into your selection before grouping it.

Grouping a Selection with Composite (PRO)
There are several advantages to using the Group Selection With Composite command over the simple Group
Selection (which references both the Group layer in the Timeline and the Group module in the Network view.
One of the advantages of using this command is that it groups all the selected elements into a neat module that has
a nested composite. This means that there is only one connection coming out of the Group module. With the simple
Group module or command, the Group displays the same number of connections as elements in the group. Both
grouping commands display the same structure in the Timeline view.
Group Selection

Each wire represents
a connection to an
element in the group
Timeline view Structure

Group Selection With Composite
Inside the Drawing-G module
single
connection

nested
composite

The Group Selection With Composite command should only be used before any work has been done in the Network
view and it recommended for objects whose stacking order is of no consequence.
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NOTE: Using the Group Selection from Composite command on elements that have effects, have been tweaked
in the Network view, or whose stacking order is of consequence, may cause the grouped elements to lose their
properties once grouped in this way. In addition, though you may only select a few modules to group, if there are
other layers in the timeline that exist between the selected layers, they will automatically be grouped, even if not
selected.
To group selected elements using the Group Selection With Composite command in the Network view:
1.

In the Network view, select the elements that you wish to group.

2.

Right-click (Windows) or [Ctrl]+click (Mac OS X) in the Network view and select Group > Group Selection With
Composite from the pop-up menu.
The selected modules will be grouped.

To group selected elements using the Group Selection With Composite command in the Timeline view:
1.

2.

In the Timeline view, in the layers section, select the elements that you wish to group.
Any layers between the selected layers will automatically get grouped as well, so if the stacking order is of no
consequence, move extra layers either above or below the layers that you wish to group.
Right-click (Windows) or [Ctrl]+click (Mac OS X) on one of the highlighted layers and from the pop-up menu
select Group Selection With Composite.

The layers appear indented under a new Group layer in the Timeline view and in a new Group module in the Network
view.
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Ungrouping a Selected Group (PRO)
To ungroup a selected group:
1.

2.

In the Network view, select the group module you want to ungroup.

Select Edit > Group > Ungroup.
Your modules are ungrouped.

Entering and Exiting a Group Module (PRO)
Once you create a group module, it is easy to enter into or exit from it.
To enter a Group module:
1.

In the Network view, click on the dark arrow on the right-hand end of the group module you want to enter.
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You will enter the group module.



Inside the group module, the Multi-Port-In and Multi-Port-Out modules ensure that your connections
continue beyond the group.

To exit a Group module:
1.

In the Network view, click on the destination in the Group Hierarchy Menu at the bottom left corner of the
Network view. You can also select Modules > Exit Group from the Network View menu or hold down the [Shift]
key and click on the Multi-Port-Out module. The default keyboard shortcut is [Backspace].



When you enter a group, the Group Hierarchy Menu displays the path to your current location within the
network. In this particular example, the Network view displays the modules inside the group "group". To
exit this group, click on Top.

Moving a Selected Module to its Parent Group (PRO)
Using the Move to Parent Group command allows you to move the selected module to the parent level, maintaining
all connections.
If the operation cannot maintain the connections between the modules, you will be notified and the operation
will be terminated.
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To move a selected module to its parent group:
1.

In the Network view, go inside the group and select the modules you wish to move up to the parent group level.

2.

In the Network View Menu, select Modules > Move to Parent Group. You can also use the default keyboard
shortcut [Ctrl]+[Shift]+[U] (Windows) or [a]+[Shift]+[U] (Mac OS X).
The selected modules are moved to the parent group level.
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Modules: Enabling and Disabling (PRO)
As with the Timeline layers, you can enable and disable the Network view modules. Disabling a module in the Network
view will also disable its corresponding layer in the Timeline view. Disabled modules are displayed in red.

Enabling a Module (PRO)
To enable modules:
1.

In the Network view, select the disabled module(s) you want to enable.

2.

In the Network View menu, select Modules > Enable. You can also use the default keyboard shortcut [A]. This
keyboard shortcut is also valid in the Timeline view.
You can also select the module(s), right-click on it and select Enable from the menu or simply use the Enable
button in the Network View toolbar.

Enabling All Modules (PRO)
To enable all modules:
1.

In the Network View menu, select Modules > Enable All.

When enabling a group using Modules > Enable All only the parent group layer is enabled. The modules inside
the group remain disabled. In the Timeline the nested modules also remain deselected.

Disabling a Module (PRO)
To disable modules:
1.
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In the Network view, select the module(s) you want to disable.
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2.

In the Network View menu, select Modules > Disable. You can also click on the Disable
button from the
Network View toolbar. The default keyboard shortcut [D]. This keyboard shortcut is also valid in the Timeline
view.

The Disable operation only affects the current level layer. It does not affect the nested modules within a group.

Disabling All Other Modules (PRO)
To disable all others:
1.

In the Network view, select the module(s) to remain enabled.

2.

In the Network View menu, select Modules > Disable All Others.
All modules are disabled except for those selected.

The Disable All Others operation only affects the current level layers. It does not affect the nested modules within
a group.
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Modules: Thumbnails (PRO)
In the Network view, some modules have a thumbnail option, identified by an arrow next to the square yellow button.

Show Thumbnails (PRO)
To show a module’s thumbnail:

 In the Network view, click on the arrow in the module.
The thumbnail opens.



If no thumbnail appears, click on the Render View Mode
generate them.

button in the Camera view bottom toolbar to

To show thumbnails of selected modules:
1.

In the Network view, select the module(s) you want to display the thumbnail for.

2.

In the Network View menu, select View > Show Selected Thumbnails. The default keyboard shortcut is [T].
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If no thumbnail appears, click on the Render View Mode
generate them.

button in the Camera view bottom toolbar to
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Hide Thumbnails (PRO)
To hide a module’s thumbnail:

 In the Network view, click on the arrow in the module.
The thumbnail closes and the module returns to its closed state.

To hide thumbnails for the selected modules:
1.

In the Network view, select the module(s) you want to hide the thumbnail display for.

2.

In the Network View menu, select View > Hide Selected Thumbnails. The default keyboard shortcut is [T].

Hide All Thumbnails. (PRO)
To hide all modules thumbnails:
1.

In the Network View menu, select View > Hide All Thumbnails. This hides all the thumbnails.
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Navigator Display (PRO)
The Navigator is a small square window inside the Network view that displays a thumbnail of your current network.
The current view displayed in the Network window is shown framed in the Navigator display. You can drag this frame
to pan your current Network view display.

The Navigator display
shows a miniature
version of the entire
Network, including any
parts not shown in the
Network window.

Showing and Hiding the Navigator (PRO)
You can show or hide the Navigator from the Network view.
To show and hide the navigator:

 In the Network View menu, select View > Navigator > Hide Navigator

or Show Navigator. You can also use the default keyboard shortcut [Ctrl]+[Shift]+[W] (Windows) or
[a]+[Shift]+[W] (Mac OS X).

Positioning the Navigator (PRO)
The Navigator display can be placed in any corner of the Network view.
To position the navigator:

 In the Network View menu, select View > Navigator > and choose from Top Left, Top Right, Bottom Left,
Bottom Right.

Refer to the Scene Setup Preferences topic to learn how to set the Navigator display options in the Preferences
panel.
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Cable Styles (PRO)
You can customize the look of the cables in the Network view to fit your style of working.

Bezier (PRO)
The Bezier cable style displays the cables as curved lines.

To switch to Bezier cable style:

 In the Network View menu, select View > Cable Style > Bezier.

Line (PRO)
The Line cable style will display the cables as straight lines.

To switch to Line cable style:

 In the Network View menu, select View > Cable Style > Line.
Refer to the Scene Setup Preferences topic to learn how to set the cable style in the Preferences panel.
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Display Concepts (PRO)
Display Modules (PRO)
The Display Module is an important element as it displays its content in the other views, primarily the Camera,
Timeline and Playback views. It is located in the Module Library and imported in the Network view and can be
connected to any module that outputs drawing images, such as drawing elements, effects or composite modules. You
can have more than one Display Module in a network allowing you to visualize different sections of the scenes without
disabling or disconnecting elements that could be in the way. This technique is useful in Cut-out animation as it allows
you to see one puppet without having all of the other characters in the way. It is also useful during compositing and
helps you visualize effects individually.
You can add a Display to your Network view by dragging one from the Module Library view.

To use this display concept, you must first show the Display toolbar.
Refer to the following sections of the Discovering the Interface chapter to learn how to display toolbars and
customize your workspace:

•
•
•
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Managing the Views, on page 60
Managing the Toolbars, on page 62
Managing the Workspace, on page 64
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Global Display (PRO)

Animate Pro uses a Display toolbar to select the different display modules available in the network.
When selecting a new display, all of the views will update to show the content of the new display module. The Display
toolbar is called the Global Display.
To select a different display module as a global display:

 Open the Display toolbar drop down menu and select the desired display module from the list.
Every view display will be updated in sequence.

Refer to the following sections of the Discovering the Interface chapter to learn how to display toolbars and
customize your workspace:

•
•
•

Managing the Views, on page 60
Managing the Toolbars, on page 62
Managing the Workspace, on page 64

Display All (PRO)
When your scene does not have a Display module, it is automatically set to Display All. This mode will set the display
to the same order as the Timeline view.
You can also set your display to Display All with the Display toolbar.
Refer to the following sections of the Discovering the Interface chapter to learn how to display toolbars and
customize your workspace:

•
•
•

Managing the Views, on page 60
Managing the Toolbars, on page 62
Managing the Workspace, on page 64
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Display Modes (PRO)
Animate Pro has two display modes. By default, it is set on Basic Display mode.

•
•

Basic Display (PRO)
Advanced Display (PRO)

Basic Display (PRO)
When creating a scene in Basic Display mode, a display module is automatically added to the network and connected
to the final composite module. All of the views are set to display this module. This means that only the elements
connected in that composite module will show in the Camera View.
You can add and connect more display modules to your network and select the one you want using the Global Display
drop-down menu. In Basic mode, every view is set to the same Display module.

Advanced Display (PRO)
In Advanced Display mode, every view has its own Display drop down menu and each can be set to a different Display
module. To switch from Basic to Advanced Display mode, you need to enable the Advanced Display preference.
To enable the Advanced Display preference:
1.
2.

Select Edit > Preferences (Windows) or Animate Pro > Preferences (Mac OS X) to open the Preferences panel.
You can also use the default keyboard shortcut [Ctrl]+[U] (Windows) or [a]+[U] (Mac OS X).
In the Preferences panel, under the Advanced tab, enable the Advanced Display option.

A Display drop down menu will appear in the top left corner of the Camera, Timeline, Perspective, Top and Side
views.
When Animate Pro is set on Advanced Display mode, a Display drop-down menu appears in each View. These menus
allow you to set the views for different displays. By default, all views are set on Global Display to follow the Global
Display toolbar selection. However, you may want different views set on different displays. For example, a user can
have one Camera view to display the full scene and another Camera view to only display the character being
animated. In this case, the user will set the first Camera view on the final display and the second on the character’s
display module.

If you want the views to follow the Global Display toolbar selection, set the view display menu to Global display.
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Creating a Multiplane
One of the most exciting features in Animate is the Multiplane, or Z-depth. In the Multiplane you can create
backgrounds in several layers, spread them on the Z-axis, add depth, and then move the camera through this
environment to create an impressive perspective illusion. You can create backgrounds, use a layered PSD file or use a
project from the sample material package.
The topics are:

•
•
•
•

Top View and Side View
Perspective View
Setting Up the Multiplane
Distributing Elements on the Z-Axis

In Animate Pro, you can position element in the true 3D space and create 3D Camera moves.
Refer to the following sections of the Working in a True 3D Space (PRO) chapter to learn more about positioning
elements in 3D space and creating 3D Camera moves:

•
•

Positioning Elements in 3D Space (PRO), on page 549
3D Camera Motion (PRO), on page 556

Top View and Side View
The Top and Side views are used mainly for multiplane scenes and to position elements in 3D Space. They allow the
scene’s stage to be seen from the top or the side. This allows the camera cone and the spacing between the different
elements to be seen.

2

1

1.
2.

The camera cone represents the camera’s field-of-view (FOV).
A thumbnail of each drawing layer in your scene. The order of the thumbnail images is based on each element’s
FB position in the scene space. You can see a representation of the Forward Backward position of each layers
within the camera cone.
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Refer to the Creating Animation Paths chapter to learn more about keyframes, control points and animation
paths.
Refer to the Creating a Multiplane topic to learn how to position your elements in the Top and Side view.

Perspective View
The Perspective view is used during scene setup. Its main use is to allow you to see your multiplane scene’s
orientation. The Perspective view is similar to a 3D display, as it lets you rotate your scene through all possible angles
to understand the spacing between the elements. You can also position and rotate your layers and the camera inside
the 3D display to achieve some 3D setup and camera moves.

1

2
3
4

5

6
1.
2.
3.
4.
5.
6.

7

8

9

10

11

The blue circle represents a rotation of the X and Y axis plane.
The red circle represents the rotation of the Y and Z axis plane.
The green circle represents the rotation of the X and Z axis plane.
This is a perspective grid reference.
The axis reference arrows let you maintain your orientation when navigating inside the Perspective view.
There are three view option buttons displayed in the lower left corner of the view.



Show/Hide Camera: Use this button to show or hide the camera frame in the Perspective view.



Reset View: Use this button to reset the Pan, Rotation and Zoom of the Perspective view.

Reset Rotation: Use this button to reset the rotation of the Perspective view.
This field displays the current zoom level in the Perspective view. You can use the Zoom level drop-down menu
to select a specific zoom level from the list. Zoom levels from 2.5% to 6400% are available, you can also select
Fit To View to automatically use a zoom level that lets you see all of your scene layers and information in the
Perspective view at once.


7.

8.
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This field displays the currently selected layer and drawing name.
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9. This field displays the currently selected tool.
10. This field displays the currently selected frame of your animation.
11. This field displays the current position of your cursor inside the Perspective view.
To rotate a scene in the Perspective view:
1.

In the Tools toolbar, select the Rotate View




tool.

Click in the view, and drag your cursor around to rotate the view.
Press and hold [Alt]+[Shift] and click and drag to rotate the view one axis at a time.

Setting Up the Multiplane
To construct a multiplane, you must imagine what a real environment is like. Take a look at your background picture
and imagine a camera moving across the space. You will notice that objects in the picture would move at different
speeds depending on where they are in relation to the camera lens.
Building a multiplane requires an understanding of the scene's background as well as the positioning of the elements
on different layers.
For example, in this background, the main objects to be separated are:

1

2

3

4

5

6

1. Fern
2. Front tower
3. Second tower
4. Moon
5. Stars
6. Sky

Although the bottom of the tower is hidden behind the plant and the ladder, each of your multiplane layers
should be a complete drawing. This is because hidden portions may show up during a camera movement later on in
the scene.
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Distributing Elements on the Z-Axis
Now is the time to distribute the layers composing your multiplane along the Z-axis, maintaining their distance. You
can position your layers on the Z-axis in the Side and Top view.
Positioning your element toward the camera will make your element bigger. Using the Maintain Size

tool, you will

be able to drag your element toward the camera while keeping the same size aspect in the Camera view. This tool is
available in the Advanced Animation toolbar.
Refer to Chapter 3: Discovering the Interface > Managing the Toolbars, to learn how to show and hide toolbars.
NOTE:
It is a good idea to keep a Camera view opened to see what your scene looks like while positioning your element in
the Top or Side view.

Positioning Elements in the Top and Side Views

To be able to distribute the layers along the Z-axis using the Top and Side views, make sure that the No Z
Dragging option is disabled.
To position your element in the Top and Side views:
1.

In the Advanced Animation toolbar, select the Maintain Size

2.

In the Side view, select one of the layers in the thumbnails section of the Top or Side view. You can also select
your layer from the Timeline view.
The selected layer will be highlighted in the camera cone.
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tool. The default keyboard shortcut is [Alt]+[6].
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3.

Click and drag the layer to the correct depth position in the camera cone. Your element aspect will remain the
same in the Camera view.

4.

In the Tools toolbar, select the Transform
tool, or select the Translate
tool in the Advanced Animation
toolbar and select a layer from the thumbnails section of the Top or Side view. You can also select your layer
from the Timeline view.



If you choose the Transform
tool, make sure that the Peg Selection Mode
Transform Tool Properties view.

option is disabled in the

The selected layer will be highlighted in the camera cone.

5.
6.

In the Top view, drag the element sideways to position horizontally. You can press and hold [Shift] while dragging
the element to make sure it only moves along the X-axis.
In the Side view, drag the selected element up or down to position it vertically. You can press and hold [Shift]
while dragging the element to make sure it only moves along the Y-axis.
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Scene Setup Preferences
When setting up your scene in Animate, some preferences can help you work more efficiently.
To open the Preferences panel:





Windows: Select Edit > Preferences.
Mac OS X: Select Animate > Preferences or Animate Pro > Preferences.
You can also use the default keyboard shortcut [Ctrl]+[U] (Windows) or [a]+[U] (Mac OS X).

General Tab Preferences (PRO)

Options (PRO)

•
•
•
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Auto Apply: When enabled, values entered or options selected in module editors are automatically applied
to elements in your scene. The Apply and OK buttons are hidden in the Layer Properties when this feature
is enabled.
Native Windows Playback: When enabled, the native Windows functions are used for play back in Enable
Cache mode.
Editor Always on Top: When enabled, the Layers and Function Editors are on top of the main window.
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Settings (PRO)

•
•

Minimum FOV: This is the minimum field-of-view value of the camera.
Maximum FOV: This is the maximum field-of-view value of the camera.

Camera Tab Preferences
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Tools

•

Show Locked Drawings As Outlines: In the Camera view, locked elements are displayed as outlines only.

•

Bounding Box Selection Style: In the Camera view, selected elements are not highlighted in colour
but are displayed with the bounding box only.
Nudging Factor: The nudging increment value.

•

Zoom Settings

•
•

Camera View Default Zoom: The default zoom value for the Camera view.
Top/Side View Default Zoom: The default zoom value for the Top/Side views.

Settings

•
•

Thumbnail Size: The thumbnail size, in pixels, that appears in the Top and Side views.
Small Bitmap Resolution: The size, in pixels, of the smaller bitmap version of your image. When you import
a bitmap image into a scene, a smaller version of it is created by the system in order to accelerate the
compositing and playback processes.

•

Override Small Bitmap Files: Enable this option if you want the system to generate new versions of
the already existing smaller bitmap files, every time you modify the Small Bitmap Resolution value. When
the option is disabled, the already existing smaller bitmap versions will not be regenerated and will keep
the same resolution as when they were created.
TV Safety: The ratio value for the TV Safety frame in proportion to the regular camera frame.

•
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Control Size

•
•
•
•
•

Rotation: The Rotation Bounding Box size.
Skew: The Skew Bounding Box size.
Scale: The Scale Bounding Box size.
Min. Max.: The Bezier handle size.
Pivots and Control Points: The Pivots and Control Points size.

Wash Background

•
•
•

Enable in Camera: Dulls background bitmaps in Camera view. This allows you to see other elements clearly,
such as the ones that have not yet been painted.
Enable in Camera Drawing Mode: Dulls background bitmaps in Camera view while using drawing tools.
This allows you to see other elements clearly, such as the ones that have not yet been painted.
Wash Background Percentage: The Wash Percentage value.

Network Tab Preferences (PRO)

Navigator (PRO)
•
•

Show Navigator: Enable or disable the display of the Navigator in the Network view when starting up
Animate Pro.
Navigator Starting Corner: Indicates which corner is the default Navigator’s position.

Options (PRO)
•
•
•
•

Cable Type: Displays Network connections as Lines (straight) or Beziers (curves).
Image Caching: Selects which module’s image will be cached.
Port Output Ordering: Orders the Output Port Right to Left or Left to Right.
Port Input Ordering: Orders the Input Port Right to Left or Left to Right.
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Element Module Drawing Options (PRO)
•

•

•

•

•
•
•
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Anti-aliasing Quality: Smoothness setting applied to Colour Art.
D Low: No antialiasing
D Medium Low: Some antialiasing
D Medium: Medium antialiasing
D High: Extensive antialiasing
The higher the chosen setting, the greater the amount of antialiasing that is applied. Higher quality images
require more time to render and more system memory. Choose a lower quality if you are rendering a Pencil
Test.
Anti-aliasing Exponent: Controls the amount of area around the Line and Colour Art edges that is used in
the antialiasing process. A higher value uses less area, resulting in sharper edges, while a lower value uses
more area, resulting in softer edges. If the Antialiasing Quality value is set to Low (no antialiasing), this value
is ignored.
Enable External Read If Image Is Bigger Than: If the image to render out is larger than the value entered
in the box, the system will create an external render for that special image. It will open a second copy of
Animate Pro in the background (not visible to the user), cut and set the image to the scene format and
finally send it back to the original scene.
Read Colour: Controls the production of colour information from bitmap images. If this module reads 3 or
4-channel bitmaps, this selection determines whether the colour should be read or ignored. If this module
reads 1-channel bitmaps, this selection determines whether the channel should be read as colour. When this
option is selected with 1-channel images, the result will be a greyscale image.
Read Transparency: Controls the production of alpha information from bitmap images. If this module reads
a 1 or 3-channel image, this option will create a matte from the colour values in the image. If the module
reads a 4-channel image and this option is not selected, the alpha information in the image will be ignored.
Alignment Rule: The Alignment position for the element module. The new element module will be created
following this default rule of alignment.
Transparency Type:
D Premultiplied with Black: Pixels at the edge of an image are blended with black.
D Premultiplied with White: Pixels at the edge of an image are blended with white.
D Straight: Pixels at the edge of an image are blended with black, white and greys.
D Clamp Colour to Alpha: Select this option when you want to premultiply the colour value with the
alpha value.
When the colour is clamped to the alpha, the colour value cannot be higher than the alpha value. It
calculates the real colour value faster.
When the RGB values are multiplied with the alpha value, that is to say, if you have a pixel of value
R=247, G=188, B=29 and the alpha is 50% or the image has a 50% transparency, then the actual RGB
values output would be half of the amounts listed above.
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OpenGL Tab Preferences

Settings

•
•
•
•
•

Conservative Texture Management: Turns on and off conservative memory management for bitmap
texture files. Performance will improve when this is enabled. If disabled, you will have a better on-screen
rendering of bitmap files at the expense of slower performance.
Smooth Textures: Smooths out the pixels of bitmap images when zooming in. This improves bitmap image
quality.
Alternate Gradient and Cutter: This is an alternative way to disable write in the OpenGL Backbuffer,
required for some video cards (i.e. GeForce FX5200). Do not enable this option unless you are experiencing
problems with gradients and cutters in OpenGL.
Use PBuffer for Picking: This will use an off-screen buffer for picking, resulting in a quicker response. This
option should not be enabled if using a small capacity video card (32MB).
Support Triple Buffer: Enable this option for a better compatibility with Windows Vista if your video card
driver does not allow to disable the triple buffering option. Not enabling this option may result in a dashing
line when drawing a brush stroke.
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•
•
•
•

Support Desktop Effects: Enable this option for a better compatibility with Windows 7, Windows Vista and
Mac OS X desktop effects. This will prevent graphic compositing problems from happening when the fullscene antialiasing option is enabled.
Maximum Texture Size: This is the size that the bitmap file will be reduced to when using the Conservative
Texture Management
Texture Memory: The amount of temporary memory used to store bitmap texture files.
Vector Drawing Maximum Texture Size: This is the size that the tvg file will be reduced to for better
performance when in OpenGL render mode.

Other Views/Drawings (PRO)

•

•

•

Enable Textures, Gradients in Drawings: Shows zones and lines painted with texture or gradient colour
pots. When disabled, zones and lines painted with textures and gradients will be filled with solid colours.
Textures and gradients require more time and memory to display, so enabling this effect module can slow
the performance of Animate.
Support Transparency in Pencil Lines: When the option is enabled, the pencil lines are displayed normally.
The lines will be opaque (unless there are transparencies). Disabling this option will reduce rendering times,
but will display additive opacities for overlapping pencil lines and unevenly filled curved pencil lines.
Enable Variable Line Thickness: Turns on and off the rendering of the variable line thickness option of
the Element Module.

Advanced Tab Preferences (PRO)

Advanced Options (PRO)
•
•
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Advanced Display: Enable or disable the Advanced Display mode.
Refer to the Display Concepts (PRO) topic to learn more about the functionality of Advanced Display.
Restore Current Selected Drawing On Undo: If a drawing other than the current one is being affected by
an Undo command, the system will display the affected drawing when this is enabled.

Chapter 12
Working in a True 3D Space (PRO)

Toon Boom is well known for its multiplane space where you can move your layers forward and backward on the
Z-axis. Animate Pro now brings you a true three-dimensional space where you can actually rotate your camera and
layers on all axes. This permits you to perform a 360 degree rotation around your elements, create a floor and even
build sets!
If you use 3D effects in your animation, it is recommended not to render your project as an SWF as these effects
are not supported by that format.
This chapter is divided as follows:

•
•
•
•

Enabling the 3D Option (PRO), on page 538
3D Tools (PRO), on page 543
Positioning Elements in 3D Space (PRO), on page 549
3D Camera Motion (PRO), on page 556
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Enabling the 3D Option (PRO)

To rotate layers in three axes instead of two, you must enable the 3D option in the layer properties. By default, when
you create layers in Animate Pro, you can only move them as flat layers.
To enable the 3D option:
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1.

In the Timeline view, select the layer you want to move in the 3D space.

2.
3.

Click on the selected layer once to display its properties in the Layer Properties view or double-click on it to
open properties in a dialog box.
In the Layer Properties dialog box, click on the Transform tab.

4.
5.

Click on the Enable 3D option checkbox to display the 3D parameters for that particular layer.
Click on the Close button.
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New parameters appear in the Layer Properties window.
Layer Properties window
showing the 3D parameters

3D Parameters (PRO)
When you enable the 3D option, you will notice that three sets of parameters are modified:

•
•
•

Scale (PRO), on page 540
Rotation (PRO), on page 541
Pivot (PRO), on page 542

Refer to the following topics in the Creating Animation Paths chapter to learn more about managing, setting
and animating parameters and function curves:

•
•
•
•
•
•
•

Function Curves, on page 620
Layer Parameters, on page 590
Creating a Function, on page 611
Function View, on page 614
Creating Function Curves, on page 620
Function Drop-down Menu, on page 624
Function Types, on page 625
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Scale (PRO)

Locked 3D Scale

Separate 3D Scale

When the 3D option is enabled, the Z-axis parameter is added to the list of settings. You can either have the Scale to
be locked or separated.
When the Scale is locked, the object you are scaling is uniformly resized in three directions.
When the Scale is separated, the object you are scaling can be squashed and stretched in any direction without
affecting the other ones.

Two-dimensional Scale
Note: You cannot add thickness to an object by scaling it in the third dimension. Three-dimensional scaling is used to
scale objects that were rotated on their axes or to scale a group of objects laid out in three-dimensions.

Three-dimensional Scale
540
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Rotation (PRO)

The main parameter you will use when working in three-dimensions is rotation. Without using the 3D rotation, you are
simply working using the multiplane technique.
3D rotation can be used in two different ways:

•
•

Quaternion Rotation (PRO)
Euler Angles Rotation (PRO)

Refer to Creating Animation Paths > 3D Path, on page 592 and Separate Positions, on page 592 to learn more
about 3D Paths and Separate Positions.

Quaternion Rotation (PRO)

Quaternion Rotation is very similar to the 3D path position parameters. A Quaternion is composed of three rotation
functions: X, Y and Z to control the rotation on three axes, and a velocity function to control the velocity of the three
rotation functions simultaneously.
The X, Y and Z functions are linked together, when you add a keyframe on one of them, it also adds it on the two
others.
If you are planning to animate an element such as the camera, you should use the Quaternion rather than the Euler
Angles. Quaternion creates smooth trajectory and interpolation since the path is controlled by the same keyframes
and a single velocity.

Euler Angles Rotation (PRO)

The Euler Angles Rotation is very similar to the Separate position parameters. The Euler Angles parameter is
composed of three functions: X, Y and Z to control the rotation on three axes. These three functions are independent
from one another, each having its own velocity.
When you add a keyframe on one function, the other ones do not receive it, allowing you to control each axis
independently.
Euler Angles are mainly used to position elements with exact coordinates and rotating elements on a single axis. The
interpolation between the keyframes will not be as smooth as the Quaternion one since each function works
individually.
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Pivot (PRO)

When you enable the 3D option, the drawing or layer pivot becomes a location that can move on three axes. When
you work in two-dimensions, the pivot is mainly an anchor point somewhere in the drawing from where the
transformations will be performed. Once you switch to the 3D mode, the transformations are made on three axes, so
the centre of rotation and scaling also becomes three-dimensional.

By default, the pivot is positioned at the centre of the stage: (0,0,0). When you use the Pivot
tool to reposition
the centre of transformation, the pivot position is changed on the X and Y axes, but the Z-axis remains at zero until
you change it in the Top, Side or Perspective view using the transformation tools.
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3D Tools (PRO)

Once the 3D option is enabled, your transformation tools become 3D transformation tools. These tools are found in
the Advanced Animation toolbars as well as the Transform
X and Y axes, you can also manipulate them on the Z-axis.

tool. Instead of letting you move elements only on the

Refer to Setting Up the Scene > Positioning the Scene Components, on page 481 to learn more about
transformation tools.
You will see here how the following tools behave in 3D mode:

•
•
•
•

3D Translate Tool (PRO), on page 544
3D Rotate Tool (PRO), on page 545
3D Scale Tool (PRO), on page 546
3D Transform Tool (PRO), on page 547
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3D Translate Tool (PRO)
Once you enable the 3D option, the 3D Translate tool becomes available and you will see direction arrows appear
around the pivot points to indicate the different axes.

You can click on the direction arrows to move your layer on only one axis. If you click anywhere else, the layer can
move freely on two axes at once. Once the arrow is selected, it will turn pink.
Note: If you move the layers in the Perspective view, it may be difficult to control the motion since you may not have
the optimum point of view on your stage to understand the setup. In this case it is best to use the direction arrows.
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3D Rotate Tool (PRO)
Once you enable the 3D option, the 3D Rotate tool becomes available and you will see a rotation sphere appear
around the pivot points indicating the different axes.

You can click on the direction ellipses to rotate your layer on one axis only. If you click anywhere else, the layer rotates
freely on two axes at once. Once the ellipse is selected, it will turn pink.
Note: If you move the layers in the Perspective view, it may be difficult to control the motion since you may not have
the optimum point of view on your stage to understand the setup. In this case it is best to use the direction ellipses.
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3D Scale Tool (PRO)
Once you enable the 3D option, the 3D Scale tool is available. You will see one of two things:

•
•

A scaling rectangle that appears if your drawing is flat.
A scaling cube that appears if your object has some rotated layers around the pivot points, indicating the
different axes.

Click on one of the three control points to scale the shape on one axis. Hold down the [Shift] key to scale the object
proportionally. Once the control point is selected, it will turn pink.
Note: If you move the layers in the Perspective view, it may be difficult to control the motion since you may not have
the optimum point of view on your stage to understand the setup.

546

Chapter 12: Working in a True 3D Space (PRO) 3D Tools (PRO)

3D Transform Tool (PRO)

Once you enable the 3D option, the 3D Transform tool become available. This tool is a combination of the 3D
Translate, 3D Rotate and 3D Scale tools.
To translate an element, grab the direction arrows in the same way that you would with the Translate

tool.
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To rotate an element, grab the rotation ellipses in the same way that you would with the Rotate

To scale an element, grab the scaling control points in the same way that you would with the Scale
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tool.

tool.
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Positioning Elements in 3D Space (PRO)

To position elements in 3D space, you need to understand what you want to build and what is involved in building it.
Simple sets like the above one are easy to build, light to manage and probably what you will use 3D staging for most
often.
If you have a project based in a room, it can be useful to build it in 3D. This saves you having to redraw the background
for each scene and it will be entirely vector based.
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Here, you can see a couple of different backgrounds you can get in only three seconds from this set.

Planning Your Pieces (PRO)
When you are building a room, there are only a few pieces to prepare. Before starting to build your set, map out the
parts you need.

A complex set, that is more intricate in its design, will require more careful planning. Not only will you have to list the
pieces you'll need, but you will also have to think about what can be reused. If you have a series of windows in your
set, you would create a Symbol out of the drawing, rather than copy paste it several times all over your set. This way,
if you need to make any correction to its design, you will only need to do it once and all the instances of your Symbol
throughout your set will be corrected. The same can be done for each of the pieces of your set.
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Here is an example of all the source drawings required to build the castle.

Those are the only drawings required to build the entire castle. As you can see there are not that many considering
the final result. The rest is constructed by assembling Symbols and through reuse. However, keep in mind that
although you are using simple drawings and Symbols to optimize your set, the more your add to your project, the
heavier the toll it takes on your machine’s RAM. While the scene’s package itself is really light, running the scene places
heavy demands on your RAM and video card.
Using the drawings shown previously, here are a couple of pieces that were put together.
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Here is the final result, a large and impressive fortress.

Refer to the following topics in the Libraries, Symbols and Templates chapter to learn more about creating and
reusing Symbols:

•
•
•

Creating a Symbol, on page 385
Importing a Symbol, on page 396
Sharing a Symbol, on page 391

Using Complex Sets in Production Scenes (PRO)

When your main set is built, you will want to store it in the Library. It is important to know that when you import such
a large structure in one of your production scenes, the set may be slow to run. To avoid long rendering sessions or
slow manipulation, remove all faces and planes that are not visible in your scene.
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Positioning the Layers (PRO)
Once you have your drawings and Symbols assembled, it is time to position them. This section explains how this is
done using the simple room shown previously.
To position your layers, you require the following elements:

•
•
•
•
•
•
•
•

Camera View
Top View
Side View
Perspective View
Library View
Timeline View
3D Transformation Tools
Layer Properties View or dialog box
Refer to the 3D Tools (PRO) section to learn more about 3D transformation tools.
Refer to the following topics in the Setting Up the Scene chapter to learn more about the 3D scene setup views:

•
•

Top View and Side View, on page 525
Perspective View, on page 526

To position layers in the 3D space:
1.

From the Library view, import the first Symbol to position into your Timeline view’s left side.

2.
3.

In the Timeline view, double-click on the new layer to open the Layer Properties dialog box.
In the Transformation tab, check the Enable 3D option.

4.

In the Rotation section, enable the Euler Angle option.
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5.

Type 90 in the Rotation’s (x) Axis field to flip the floor so that it is flat on the ground.

6.

To position the height of the floor, you can either type values in the Position section of the Layer Properties, use
the 3D Translate

7.
8.
9.

tool or the 3D Transform

tool.

Repeat the process for the other pieces to import.
If you have parallel walls, once you have positioned one, select the Wall layer in the Timeline view.
In the top menu, select Edit > Duplicate to duplicate the layer.
NOTE: If the drawing is contained inside a Symbol, the Symbol will not be duplicated, only the layer containing
the Symbol. This way you are still using the same drawing.

10. Once the layer is duplicated, use either the Layer Properties window to type the positioning values, or use the
3D transformation tools.
11. When you are using the transformation tools, use the Camera, Top or Side view to position the elements instead
of the Perspective view to position your layers precisely.
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12. If your walls are touching each others, you should have them intersect by extending one end of the wall through
the other wall. This prevents seeing a small gap in-between them.

There you go, you now have a complete 3D room.
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3D Camera Motion (PRO)
Once you have a 3D set, the exciting part is to do a camera motion in it. This section teaches you the main steps
required to perform a 3D camera motion. Once you know how to do this you can enjoy the delights of working in 3D
space and travelling through your creations!
Refer to Creating Animation Paths > Animating the Camera, on page 599 to learn more about camera moves.
To create a 3D camera motion:

556

1.

In the Tool toolbar, enable the Animate

mode.

2.

In the Timeline view, click on the Add Layers

3.

In the Timeline view, select the new camera layer.

4.

In the Timeline Layer toolbar, click on the Add Peg

5.

In the Timeline view, double-click on the new Peg layer to open the Layer Properties dialog box.

6.

In the Layer Properties dialog box, go to the Transformation tab and check off the Enable 3D option.

7.
8.

In the Rotation section, enable the Quaternion option.
In the Perspective view, click on the Show/Hide Camera button to see your camera cone.

button and select Camera to add a camera to your scene.

button to add a parent peg to the camera.
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9.

Setup your workspace to display the Camera view and Perspective view at the same time so you can compare
the results.

10. In the Tools toolbar, select the Transform

tool.

11. In the Timeline view, select the Camera-Peg layer first frame and
select Insert > Keyframe.

12. In the Timeline view, select the Camera-Peg layer.

13. In the Timeline view, go to the last frame.
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14. In the Perspective view, grab one of the rotation ellipses and rotate the camera on one axis only.
Always do one axis at a time, this keeps control of the positioning.

15. Once the camera is rotated in the correct angle, grab one of the direction arrows to move the camera to the
correct position.

Playing Back Your 3D Camera Moves (PRO)
In order to see a playback of your 3D camera moves, you must be in the Perspective view.
To enable the playback mode in 3D:
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1.

In the top menu, select Play > Enable Playback > Perspective View.

2.

In the Playback toolbar, press the Play

button to see the results.
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Locking Flat Drawings to the Camera Angle (PRO)

When you create a 3D camera motion in your scene, you will notice that layers are treated as flat objects, animation
layers that are supposed to face the camera at all times will look like a flat sheet of rotating paper. Use the Ortholock
layer when mixing flat animation layers with a set built in 3D. Ortholock forces your drawing layer to always follow the
Camera angle. It does not follow its position or zooming level, only the rotation. This prevents drawings from being
distorted by the camera motion.
Note: Adding an Ortholock layer in a Symbol will not give the correct result. The Ortholock contained inside a
Symbol does not consider the position of the camera contained in the root scene. Keep your Ortholock layers in the
root scene.
To add an Ortholock layer:
1.
2.
3.

In the Module Library view, go to the Move tab.
Select an Ortholock module and drag it to the Network view.
In the Network view, drag an output cable from the Ortholock module and connect it to the module you want to
keep facing the camera.
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Managing a Network with a 3D Scene Setup (PRO)
In Animate Pro, you can create very advanced networks using effects, complex connections and multiple-level
compositing.
The Composite module’s main task takes all of your image’s output and converts it into a single flat image that you
can render out. You can alter it further by manipulating a three dimensional scene setup. You can also modify a
Composite’s behaviour as seen in the Setting Up the Scene chapter.

Input and Output Options (PRO)

The default options combination is:

•
•

As Bitmap, for the output behaviour
3D flat, for the input ordering

By default, a Composite module is set to output a flat bitmap image and to correctly composite elements positioned
in the 3D space.
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For example, if you have two intersecting walls, and use the default combination, you will see the following result:

This image is correctly represented in the Camera view and is output from the Composite module as a flat drawing.
The Z-axis value of your elements are not retained, it becomes an independent composition with only one forwardbackward value.

3D Input Ordering option (PRO)
The visual result for the 3D Input Ordering option is the same as the 3D Flat option. The visual result in the Camera
view will be correct, but the elements will not be converted into a flat image. The 3D position of your images will be
remembered until the next Composite module. This mode is quite advanced and should only be used in very
advanced cases. Most of the time you will use the 3D Flat Input ordering option.

2D Input Ordering option (PRO)
If you switch the Input Ordering option to 2D, the walls will be calculated as flat 2D objects and not as 3D objects.
The perspective caused by the 3D rotation will be correctly represented, but the elements will not intersect. The result
will be similar to the following:
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How to Organize Your 3D Composite Modules (PRO)
If you start combining several composite modules in your Network view, you must understand the way they work if
you want to get the desired result.
There is a specific order in which you should set your Composite modules.
In most of the cases, you should use the 3D Flat Input Ordering option, which is the default setting. You can stack as
many of them in a row as you want.
It is important to understand that each time you process images through a 3D Flat composite module, the images will
be merged together and the 3D ordering will also become a flat image. Images processed in later Composite modules
will not be inserted between the images of that previous composite since it is a flat image. Although, since the image
coming out of a Composite module has a Z-axis value, it may happen that it will intersect with 3D objects processed
in a lower Composite module.

3D Flat

3D Flat

3D Flat

If you place any Pass-Through type Composite modules in your network, the images will not be processed before the
final Composite. It is important to keep your final Composite as a 3D Flat composite to read the layer ordering
correctly.
The most efficient networking system to use so that you obtain the desired result is probably to use mainly PassThrough type composite throughout the whole network and only set the last one as a 3D Flat composite. This way,
you can create individual compositions to keep your network clean and organized, but process everything together
at the end only. This way, all the 3D rotations and positions are calculated together. The drawback of this technique
is that it may take longer to render out your frames when the project is completed.

Pass-Through

Pass-Through

3D FLat
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With Toon Boom Animate, you can import soundtracks and dialogue into your animation to make it more engaging
and entertaining. There are several sound editing features that can be used to synchronize sounds to individual frames
or moments in time. You can also use them to trim unwanted seconds from the beginning and end of your sound files,
as well as to loop sounds that you want to continue throughout your animation.
Your ability to add dialogue to animation is greatly enhanced with the Animate lip-sync tools. Animate can analyze
voice tracks to determine which of the eight animation phonemes (lip positions) would best apply to each frame of
sound. With the mouth chart that the software generates, you can easily draw lip positions for your character.
Furthermore, Animate can automatically apply drawings of lip positions to each frame of your animation based on the
mouth chart.
In this chapter, you will learn about the following:

•
•
•
•
•
•
•

Importing a Sound File, on page 564
Sound Displays, on page 566
Sound Playback, on page 567
Sound Scrubbing, on page 568
Editing a Sound File, on page 569
Add Empty Sound Layer, on page 575
Lip-sync, on page 576

You can also synchronize your animation to a music score, refer to Layers and Timing > Tempo Markers (PRO), on
page 289 to learn more.
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Importing a Sound File
If you decide to add sound to your movie, you must first prepare this sound outside Animate. Then you must add a
Sound element in Animate to organize sound files in your animation. Sound will play in the movie until it reaches the
end of the file or a stop frame that you have created in the Sound Element Editor.
You can import WAV, AIFF or MP3 sound files using any of the methods listed below.
To import a sound file:
1.

Select File > Import > Sound
right-click (Windows) or [Ctrl]+click (Mac OS X) anywhere in the frame zone of the Xsheet View.
from the Top menu





from the Xsheet view menu



from the Timeline view menu

The Select Sound File dialog box opens.

2.

From the Select Sound File dialog box find and select your sound file from your computer.
Your sound file should now appear as a layer in both the Timeline and Xsheet View.

Timeline View

Xsheet View
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Sound Layer Properties
When you select a Sound layer in the Timeline view, the options related to that layer appear in the Layer Properties
view.
Mute/Unmute
Layer Name
Sound Editor
Start Frame/End Frame
Detect

Map

Mouth Shapes

•
•
•
•
•
•
•

Mute/Unmute
This button mutes and unmutes the sound layer during the scene play back.
Layer Name
This field displays the layer’s name.
Sound Editor
This button opens the Sound editor.
Start Frame/End Frame
These fields determine the start and end frame of the sound file.
Detect
This button launches the automated lip-sync detection.
Map
This button opens the Map Lip-sync dialog box.
Mouth Shapes
This section shows the automated lip-sync detection during the scene play back. Click on the thumbnail of
each mouth to change the phoneme assigned to the current frame.
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Sound Displays
Within the Xsheet View, the sound file can be displayed in different ways, depending on your sound editing needs.
To change the sound display:
1.

Right-click (Windows) or [Ctrl]+click (Mac OS X) in the sound column or on the sound column header, choose
Sound Display > and one of the following:
 Sound Name: Shows the name of the sound file, as well as the file format. The line running vertically
through the column frames between the same file name indicates a continuity of the same sound file in
these frames.
 Mouth Shapes: Show the letter (or name depending on the way you named your character’s different
mouth positions) in the column’s frames. There is only one mouth position allotted per frame and this
position should correspond to the sound file after performing a lip-sync.
 Waveform: Shows a vertical display of the sound file’s actual waveform. In the column header, in the field
under the column name, you can type in a percentage to zoom-in or zoom-out on the waveform, or pass the
scroll cursor

over the Zoom Waveform icon

.

Refer to the Lip-sync section of this chapter for more details.
You can show/hide the waveform in the Timeline View by clicking the Waveform
toolbar.
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button in the Timeline View
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Sound Playback
Before playing back any sound, click on the Enable Sound
button in the Playback toolbar or enable it through
the Play menu in the top menu. This will make sure that you can hear the sound layers in your scene, even the ones
included within symbols.
To play back your sound sample:
1.

To select a starting point:
In the Xsheet view, click on a cell in the sound column.
In the Timeline view, click on a cell in the sound layer. You can also slide the red playhead to the correct cell.




2.

Click on the Play
button in the Playback toolbar or in the top menu select
Play > Play Scene Forward or click on the [Enter] key.

3.

If you would like to hear your sound sample played back again and again, click the Loop

button in the

Playback toolbar or the Loop option from the Play menu.
If you have two or more sound layers and would like listen to them independently, you can disable the unwanted
sound by clicking on the Mute Sound

icon located on the sound name layer in the Timeline View.
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Sound Scrubbing
Animate uses a process known as Sound Scrubbing to let you hear sound in real-time while you move the playback
pointer forward or backward. This is very useful for finely-tuned lip-synching. You can scrub sounds from the Timeline
view.
To scrub a sound from the Timeline view:
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1.

In the Playback toolbar, click on the Sound Scrubbing
button or from the top menu, select
Play > Enable Sound Scrubbing. You can also activate Sound Scrubbing by right-clicking in the Timeline view's
frame bar.

2.

At the top of the Timeline view, drag the red frame marker along to hear the sound at each frame.
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Editing a Sound File
Now that you have successfully imported your sound file into Animate, it is time to familiarize yourself with the sound
editing interface. The Sound Element Editor makes it possible to edit sounds that were created outside of Animate
and imported into your scene.
To open the Sound Element Editor:
1.

Either double-click the sound layer name in the Timeline view or the sound column header in the Xsheet view.
The Sound Element Editor dialog box opens.
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The Sound Element Editor consists of three main parts.

3

1

2

1. Sound Element - The wave form seen in the top Sound Element window is the actual sample that will be
heard when the final movie is rendered. It may be shorter than the original sound sample due to length of
the scene. If any edits are made to the sound sample, they can be heard here.
2. Current Sound - The Current Sound window displays the original sound file in its entirety and is where
you can edit its properties. This window remains empty until you click inside the Sound Element window.
3. Lip-sync Preview - Is used to preview the automated detection and to manually insert different mouth
positions to correspond with the sound sample.
To learn more about Lip-sync, refer to the Lip-sync section in this chapter.
You can accomplish the following in the Sound Element Editor:

•
•
•
•
•
•

Changing the Start or End Frame of a Sound, on page 570
Trimming the Start and End of a Sound File, on page 572
Looping a Sound, on page 573
Mixing the Sound Volume, on page 573
Customizing the Playback Range, on page 574
Recomputing the Mouth Chart, on page 581

Changing the Start or End Frame of a Sound
To synchronize the sound with specific images in your scene, you must set a start frame for your sound. To make sure
the sound ends by a certain frame, you must set an end frame.
To change start or end frame of a sound:
1.
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Either double-click the sound layer name in the Timeline View or the sound column header in the Xsheet View to
open the Sound Element Editor.
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2.

Select the sound sample you want from the Sound Element panel. To distinguish one sound section from
another on the same sound layer, check the frame numbers that appear on tabs flanking the start and stop lines
of each waveform section.

Click on the Play
3.

button in the Current Sound panel (only the selected sound plays).

Within the Sound Element panel, click and drag the selected clip to the frame number where you want it to start
playing.

You can only move the clip to a section that does not already contain a clip; you cannot overlap two clips in the same
element.
4.

To change the end frame, drag the yellow marker at the end of the waveform to the frame position.

5.

To hear how all of the clips fit together in the element, click on the Play button

in the Sound Element panel.
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If you only want to hear the selected clip, click on the Play button

6.

in the Current Sound panel.

Click Apply/Next when done. The Xsheet and Timeline View should now display the sound clip at the start frame
you selected.

Trimming the Start and End of a Sound File
To play only a section of a sound file, use the Sound Element Editor to select the exact part you want to use. For
example, if there is a bit of noise at the start of the sound, use the Sound Element Editor to cut the noise.
The Sound Element Editor does not change the original sound file; it only plays a section of it, ignoring the rest. This
means that the entire sound file is included on export. If you need to be mindful of file size, it is better to edit sound
files completely in a sound editor before bringing them into Animate.
To trim the start and end of a sound file:
1.
2.
3.

4.

5.
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Either double-click the sound layer name in the Timeline View or the sound column header in the Xsheet View to
open the Sound Element Editor.
Select the sound you want to work on from the Sound Element panel.
Select the sound sample you want from the Sound Element panel. To distinguish one sound section from
another on the same sound layer, check the frame numbers that appear on tabs flanking the start and stop lines
button in the Current Sound panel
of each waveform section. Or select a sound wave and click on the Play
(only the selected sound will play).
Using the Current Sound panel, you can decide which part of the file you want to play by dragging the left and
right boundaries of the selection area.

Click on the Play
button in the Current Sound panel to check that you have trimmed the desired sections.
Use the Zoom slider at the bottom of the panel to zoom in on the wave form so that you can trim it more
accurately.

Chapter 13: Working With Sound Editing a Sound File
6.

Click on the Apply/Next button.

The trimmed sound sample should now appear in both the Timeline and Xsheet Views at the start and end positions
that you selected.

Looping a Sound
To repeat a sound, specify the number of times that you want it to loop in the Sound Element Editor.
To loop a sound sample:
1.
2.
3.

4.

Either double-click the sound layer name in the Timeline View or the sound column header in the Xsheet View to
open the Sound Element Editor.
From the Sound Element panel, select the sound section that you want to loop.
In the Current Sound panel, type the number of times you want the sound to play in the Number of Loops field.

Press on the [Return] key. The looped sound appears after the current sound. They are indicated by their grey
waveforms, as opposed to black.

When you loop a sound, the looped sections fill the cells in the Sound element (column or layer) until the next sound
sample starts or until the scene ends. This means that the looping could effectively get cut if the next sound sample
starts too soon, or if the scene ends too quickly.

Mixing the Sound Volume
You can adjust the volume of an entire sound clip or modify the volume in increments by adjusting the fade-in and
fade-out times, otherwise known as sound envelopes. The fade edit only affects the play back; the original sound file
is not affected.
To adjust the overall volume of the entire sound clip:
1.

3.

Either double-click the sound layer name in the Timeline View or the sound column header in the Xsheet View to
open the Sound Element Editor.
In the Sound Element panel, select the sound that you want to work on. A more detailed version of the selected
sound appears in the Current Sound panel.
In the Current Sound panel, use the Volume slider to adjust the volume.

4.

Click on the Play

2.

button in the Current Sound panel to verify the volume.

To create the fade in/out effect on a sound clip:
1.
2.

Either double-click the sound layer name in the Timeline View or the sound column header in the Xsheet View to
open the Sound Element Editor.
In the Sound Element panel, select the sound you want to work on.
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3.

In the Current Sound panel, click on the thin blue line above waveform to add an envelope marker.

4.

Drag the envelope markers to adjust the volume at that frame and to create the time of the transition. The line
from the edge of the clip to the envelope marker identifies how the volume either increases (fades-in) or
decreases (fades-out) over time.
Dragging the marker to the bottom of the channel will mute the volume, while dragging it upwards will increase
the volume.

To create an even effect, be sure to adjust the envelope markers uniformly in both the left and right (bottom and
top) channels.

5.

Click on the Play

button in the Current Sound panel to check the fade envelopes.

Customizing the Playback Range
To hear a specific section of the sound element, adjust the playback range in the Sound Element Editor to start or stop
at specific frames. This customized playback range does not affect the actual sound in the Sound element.
To change the playback range in the Sound Element Editor dialog box:
1.

2.

Drag the start or end range markers in the Sound Element panel to the boundary frames you want.

When you click on the Play

button to play back your sound in the Sound Element Editor, it only plays the

sound existing between the two markers.
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Add Empty Sound Layer
When performing sound editing tasks, it can be useful to chop up a sound sample into different layers. For example,
when performing a lip-sync, only a single view of the various mouth positions for a character can exist on one layer.
Therefore, if you would like to have your character turn its head from a profile view to a three-quarter view and have
mouth position changes to fit with the sound sample from these two different views, you would need to cut-up the
sound samples needed for the profile view mouth positions on one layer and the sound samples needed for the threequarter view on another.
For this task, you will need an empty sound layer.
To add an empty sound layer:
1.

In the top menu, select Windows > Toolbars > Timeline View.
The Timeline View toolbar should appear at the top of the Timeline View.

2.

Click on the Add Sound

button.

If the Add Sound button does not appear in the Timeline View toolbar, refer to the Discovering the Interface
chapter to add it.
An empty (silent) sound layer should appear in both your Timeline and Xsheet View.

3.
4.

Rename your layers accordingly.
Click the cell where you wish to start the cut and [Shift]+click the final cell of the cut. The sample to be cut
becomes highlighted.

5.

Drag the selection into the empty sound layer below.

6.

You can now continue to cut-up and distribute the sound sample between the two layers or carry on to the lipsynching process for each layer and its corresponding facial view.
If you need to duplicate your sound layer to keep an unedited copy for safety, you can click on the Duplicate

Selected Layers button

, located in the Timeline View toolbar.
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Lip-sync

Adding a lip-sync to a project can really enhance its quality and storytelling. However, it can be difficult to shape a
character’s mouth so that it matches the sound at the precise frame.
To solve this problem Animate provides a lip-sync feature which analyses the contents of a sound element and
generates a mouth chart (see below) based on the eight animation phonemes (A, B, C, D, E, F, G, and X, which is used
to represent silence).
The mouth shapes used by Animate are based on the conventional mouth chart used in the animation industry. The
letters used to represent the shapes do NOT correspond to an actual sound.
If you are doing cut-out animation, refer to Building a Character > Adding the Main Extra Drawings, on page 444
to learn how to add extra drawings to your character.

A

B

C

D

E

F

Here is an approximation of which sound each mouth shape can produce:

•
•
•
•
•
•
•
•
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A: m, b, p, h
B: s, d, j, i, k, t
C: e, a
D: A, E
E: o
F: u, oo
G: f, ph
X: Silence, undetermined sound

G

X
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You can lip-sync the traditional way or let the system automatically create the basic detection.

You can refer to the mouth chart positions as you draw the shape of your character’s mouth.
This section explains:

•
•
•
•

Creating a Mouth Shapes Chart, on page 578
Manual Lip-sync Detection, on page 579
Automatic Lip-sync Detection, on page 580
Modifying the Lip-sync Detection, on page 581
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Creating a Mouth Shapes Chart
To generate a mouth shapes chart for a sound from in the Xsheet or Timeline view:
1.

2.

To show the mouth chart letters, if they are not already present in the Xsheet, right-click (Windows) or
[Ctrl]+click (Mac OS X) on the sound column and select Lip-Sync > Sound Display > Mouth Shapes from the
pop-up menu.
In the Xsheet view or Timeline view, right-click (Windows) or [Ctrl]-click (Mac OS X) the sound layer’s cells and
select Lip-Sync > Auto Lip-Sync Detection from the pop-up menu. You can also select
Animation > Lip-Sync > Auto Lip-Sync Detection from the top menu.

Animate analyzes the selected sound clips and assigns a lip-sync letter to each frame. The X markers in the
frame are replaced by these designated letters.
To generate a mouth shapes chart for a sound using the Sound Element Editor:
1.
2.
3.

4.
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Either double-click the sound layer name in the Timeline View or the sound column header in the Xsheet View to
open the Sound Element Editor.
In Sound Element panel, select the waveform you want to generate the mouth chart for.
Right-click (Windows) or [Ctrl]+click (Mac OS X) on the sound file and select Auto Lip-Sync Detection from the
pop-up menu.

A progress bar appears while Animate analyzes the selected sound clips and assigns a lip-sync letter to each
sound cell.
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Manual Lip-sync Detection
Animate allows for the manual swapping of mouth position drawings to match a voice track. For this process, both
sound scrubbing (listening to a sound wave broken up frame-by-frame) and drawing substitutions from the Library
View are used.
Refer to Libraries, Symbols and Templates > Preview and Drawing Substitution, on page 379 and the Sound
Scrubbing section in this chapter for more details.
To perform a manual lip-sync:
1.

In the Playback toolbar, enable the Sound Scrubbing

2.
3.

In the Timeline View, drag the red position indicator along the sound layer waveform.
When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips for
an “oh” sound, click on that frame on your mouth shapes layer.

4.

In the Timeline view, click on the Expand

5.

Staying on your mouth shapes layer, place your cursor on top of the drawing name (often a letter) until it
changes to the swapping pointer

6.

button.

button to display the Data View.

.

Pull the cursor to see the list of mouth shape names and choose the one you want. The current drawing
automatically changes to the new selection.

You can also use the Timeline View to swap drawings:
To perform a manual lip-sync in the Timeline View:
1.

In the Playback toolbar, enable the Sound Scrubbing

2.
3.

In the Timeline View, drag the red playhead along the waveform of your sound layer.
When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips for
an “oh” sound, click on that frame on your mouth shapes layer.
In the Drawing Substitution window of the Library view, click and drag the slider to choose a mouth shape. The
current drawing is swapped for the one in the preview window.

4.

button.
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Automatic Lip-sync Detection
Animate can automatically map drawings in an element to the mouth chart you have generated for a sound. This can
save time when you are lip-synching a voice track.
In the Lip-Sync Mapping dialog box, you can identify each lip drawing of a character. Animate then automatically
labels all of the cells in the character’s element with the appropriate name.
To automatically map lip-sync drawings to a mouth chart:
1.
2.

In the Timeline View, right-click (Windows) or [Ctrl]+click (Mac OS X) on any cell in the sound sample layer.
From the pop-up menu, select Lip-Sync > Map Lip-Sync. You can also select
Animation > Lip-Sync > Map Lip-Sync from the top menu.
The Lip-Sync Mapping dialog box opens.

3.

From the Destination Layer drop-down list, select the layer that contains the mouth positions for the character’s
voice track.

4.

6.

If the selected layer contains Symbols, you can map the lip-sync using drawings located directly on the layer or
use the Symbol’s frames. In the Symbol Layer field select Don’t Use Any Symbol if you want to use the drawings
or select the desired Symbol from the drop-down menu.
In the Mapping section, type the drawing name or Symbol frames in the field to the right of the phoneme it
represents. If your drawings are already named with the phoneme letters, you do not have to do anything.
Click on the OK button.

7.

Press the Play

5.

button in the Playback toolbar to see and hear the results in the camera view.

To play back your scene with sound, enable the Sound
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button in the Playback toolbar.
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Modifying the Lip-sync Detection
You can change the mouth position that has been assigned to a frame if you think that another position would be more
appropriate.
For example, you may have a character who says nothing for ten frames, in between two speeches. Animate would
normally assign an X image for the silence period. However, if you want your character’s mouth to hang open in
astonishment for these ten frames, you can change the lip assignment for these frames from an X to an F.
To change the lip assignment of a sound in the Xsheet:
1.
2.

Right-click (Windows) or [Ctrl]+click (Mac OS X) in the cell that contains the mouth position that you want to
change.
From the pop-up menu, select Lip-Sync > Change Mouth Shape to and choose the letter that reflects the
mouth position that you want to use for that sound. You can also select
Animation > Lip-Sync > Lip-Sync > the desired mouth shape from the top menu.
The drawing will automatically be updated in the Camera View.

You can also change the mouth assignment of a sound in the Sound Element Editor.
To change the mouth position assignment of a sound from the Sound Element Editor:
1.
2.

Either double-click the sound layer name in the Timeline View or the sound column header in the Xsheet View to
open the Sound Element Editor.
In the Sound Element panel, drag the frame slider to the frame you want to change the mouth position
assignment on.
In the Lip-sync image area, the image on top represents the lip position assigned to the current frame.

3.

To change the image assigned to the frame, click on the image of the mouth position you want from below the
preview image. The preview image changes to the mouth position image you select.

The position will also be updated in the Timeline and Xsheet Views.

Recomputing the Mouth Chart
When you generate the mouth chart for a sound in a sound element, you can either accept the mouth positions
assigned by Animate or assign your own lip-sync images.
However, if you change the sound’s start frame or reassign its mouth position, you must reanalyze the sound and
regenerate the mouth chart for it. This erases any manual modifications you may have made to the mouth assignments
in the mouth chart.
To recompute the mouth chart for a selected sound from the Sound column:
1.

In a Sound column in the Xsheet or Timeline view, right-click (Windows) or [Ctrl]+click (Mac OS X) on a cell that
contains the sound file you want to recompute the lip-sync for. Select Lip-Sync > Auto Lip-Sync Detection from
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the pop-up menu. The mouth position assignment for each frame is recomputed, erasing any modifications you
have made.
To recompute the mouth chart for a selected sound from the Sound Element Editor:
1.
2.
3.
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Either double-click the sound layer name in the Timeline View or the sound column header in the Xsheet View to
open the Sound Element Editor.
Click on the waveform in the Sound Element section in the Sound Element Editor.
Right-click (Windows) or [Ctrl]+click (Mac OS X) and select Auto-Lip Sync Detection from the pop-up menu.

Chapter 14
Creating Animation Paths

Movement is the essence of creating an animation; it is essentially what animation is: bringing drawings to life.
Sometimes this movement comes from the characters or objects themselves, while other times, it is the camera
moving through elements set-up on the camera “stage”. Often these movements can be complex, such as a
helicopter moving across the screen with its rotor blades rotating, as the helicopter disappears into the distance, it
appears to get smaller in size as it recedes in space. Although this seems like a simple motion, you must coordinate
three movements to produce the correct effect.
The sophisticated systems integrated in Animate have been specifically developed to accommodate your complex
motion needs.In this chapter the following topics will be covered:

•
•
•
•
•
•
•
•
•
•
•
•
•

Animating a Layer, on page 584
Differences Between Pegs and Animated Layers, on page 586
Adding and Deleting Keyframes, on page 594
Stop-Motion and Motion Keyframes, on page 596
Animating the Camera, on page 599
Modifying a Path in the Camera View, on page 603
Modifying a Path in the Timeline View, on page 611
Modifying a Path in the Function View, on page 614
Modifying a Path in the Xsheet View, on page 618
Function Curves, on page 620
Copying and Pasting a Motion, on page 627
Adjusting the Velocity, on page 633
Preferences, on page 642
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Animating a Layer
This section describes the basics of animating a layer. Animate’s wide range of features will let you produce accurate
trajectories. However, before reaching this level you must learn how to create a simple motion and practice everything
you learn in this chapter.
In this topic, you will find out about the two key elements in creating a motion:

•
•

Animate Mode
Animating the layer

Animate Mode
If you enable this mode when you animate layers, Animate will apply a transformation to the current frame. If you
don’t, it will apply a transformation on the entire layer instead of only the current frame.
To enable the Animate Mode:

 In the Tools toolbar, click on the Animate Mode
button.
 When the Animate Mode button looks pushed in and highlighted it is enabled.


When the Animate Mode button is not highlighted it is disabled.

Animating a Layer
Follow these simple steps to perform a basic layer animation.
To animate a layer:
1.

In the Tools toolbar, select the Transform
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tool. The default keyboard shortcut is [Alt]+[Q].

In the Tool Properties view, make sure the Peg Selection Mode
button is disabled so you can select
your drawing layer directly and not the pegs. Refer to the Peg Selection Mode section to learn more about
this option.

2.

In the Tools toolbar, enable the Animate Mode

.

3.

In the Timeline view, go to the first frame.

4.

In the Camera view, select the element to animate and move it to its first position.

5.

In the Timeline view, go to the frame where you would like to set the second position.
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6.

In the Camera view, move the selected element to its new position.

7.

In the Playback toolbar, press on the Play

button to view your work.

Refer to Setting Up the Scene > Positioning the Scene Components, on page 481 to learn more about the
repositioning tools.
Refer to the Stop-Motion and Motion Keyframes topic to learn how to have automated interpolation or do step
keyframe animation.

Enabling the Playback
To see your motion animations in the Top, Side or Perspective views while you play back, you must enable the Playback
option.
To enable the Playback option:
1.

In the top menu, select Play > Enable Playback > Top View, Side View or Perspective View.
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Differences Between Pegs and Animated Layers
To animate the position of your drawings you need to create motion paths. Motion paths are trajectories on which
you can hook your drawing objects to. You will use keyframes to record the key positions along this trajectory.
There are two ways in which to create motion paths:

•
•

Animated Layers, on page 586
Pegs, on page 587

Animated drawing layers and pegs have different purposes which you will discover in the following topics.

Animated Layers

You can create your motion path directly on your layers.
Drawing layers can house drawings and Symbols. Also, in that same layer you can create a motion path using
keyframes and all the artwork contained in the layer will follow.

You can control and define your trajectory using several different parameters. These parameters are:

•
•
•
•

X, Y and Z positions
Angle (rotation)
Skew
X and Y scales

Each parameter has its own function curve where you can add keyframes and control the easing.
Do not worry about using graphs and function curves if you are not familiar with this concept. Animate has a series of
easy-to-use tools for visually controlling your trajectories in the Camera view.
Refer to the Layer Parameters section of this chapter to learn more about function curves.
To animate a simple object such as an arrow in flight or a wheel spinning, you will use the integrated trajectory. Also,
each part of a cut-out puppet will be animated directly on the drawing layer.
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Pegs
A Peg layer is a trajectory that contains no drawings, on which you can hook your drawings to.
This topic is divided as follows:

•
•
•
•
•

Why Use a Peg Layer?, on page 587
The Origins of the Peg, on page 587
Adding a Peg to the Timeline, on page 588
Adding a Peg to the Network (PRO), on page 589
Peg Selection Mode, on page 590

Why Use a Peg Layer?
A Peg is composed of many customizable parameters. These parameters are:

•
•
•
•
•

X, Y and Z positions
Angle (rotation)
Skew
X and Y scales
3D Rotation (When the 3D option is enabled)

You can control a Peg’s trajectory the same way as the animated drawing layer.
Refer to the Layer Parameters topic to learn more about the parameters.
Peg layers are mainly used to control a series of drawing layers together. If you have several drawing layers such as
clouds or a character split into many parts, you can hook those to a peg layer and have them follow a trajectory as
one unit. When building a puppet, most of the time you will add a master peg to control your puppet as one object.

The Origins of the Peg

Pegs have been used for a long time in the traditional animation process, mainly for registration purposes. Peg holes
at the bottom (or top) of animation paper are used to keep all of the sheets even and at the same registration.
There are three peg holes in regular animation paper. The centre peg hole is circular while the the left and right ones
are rectangular. These rectangular peg holes are situated, one on each side and four inches away from the centre peg
hole.
To keep the drawings together, the animator uses a peg bar. This peg bar has three pins corresponding to the shape
and location of the peg holes. Peg bars are normally found at the bottom and top of animation discs.
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Before digital compositing, the peg bars were also used to move levels under the camera stand. They were the
equivalent of digital trajectories. Animate makes use of these concepts to create animation and camera moves.

Adding a Peg to the Timeline
To add a Peg:
1.

Select the layer which you intend to attach to the peg.

2.

Add the peg in one of three ways:
From the Timeline View layers’ toolbar, click on the Add Peg
button.
From the top menu, select Insert > Peg.
Right-click (Windows) or [Ctrl]+click (Mac OS X) on the layer and from the pop-up menu, select
Add > Peg.
The layer that was originally selected will become a child of the new parent Peg layer.
The new Peg layer will automatically take the name of its child layer, with the addition of the suffix -P.




3.

The indentation of the layer, along with the L-shaped line
indicates hierarchy and that the layer is attached to the Peg layer.
Their relationship is known as Parent-Child
If you intend adding multiple pegs, or if the layer name that was added to the Peg does not accurately represent the
content of the Peg layer, you can rename it. You can do this by clicking on the layer name and typing in the editable
field, or double-clicking on the layer and entering the new name into the dialog box.

If you didn’t create your peg layer directly above the layer you intended on parenting it to, then click and drag the
layer you want to attach to the peg and drop it directly below the Peg layer. The indentation of the layer below the
Peg layer will be an indication of whether it was correctly attached or not.
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Adding a Peg to the Network (PRO)
In Animate Pro, you can add Pegs to your Network view using the Module Library and they will instantly appear in the
Timeline view. The modules you add to your Network view will be synchronized with the ones appearing in the
Timeline view.
To add a peg in your Network view:
1.
2.

In the Module Library, go to the Move tab.
Select a Peg module and drag it to your Network view.

3.

In the Network view, select the Peg module’s Out Port and connect it to either a Drawing module or a Camera
module.

The advanced connections in the Network view are shown in the Timeline view, unless they cannot be
reproduced in a timeline layout.
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Peg Selection Mode
In the Transform Tool Properties view, there is the Peg Selection Mode
Peg layers in the Camera view instead of the drawing layers.

allowing you to automatically select the

If you animate with Pegs instead of animating the Drawing layers directly, enable the Peg Selection Mode to avoid
having to select in the Timeline view or use the Select Parent command.
To enable the Peg Selection Mode:
1.

In the Tools toolbar, select the Transform

tool.

2.

In the Tool Properties view, enable the Peg Selection Mode

3.

In the Camera view, select an element parented to a peg.

button.

Layer Parameters
A layer is composed of many customizable parameters, such as the X, Y and Z positions, angle (rotation), skew and
scales. Each parameter has its own function. A function is a mathematical formula expressing a relation between
position values. You can view each function on a graph as a simple curve such as this one.
Frame

Easing
Keyframe
Value

Easing
Keyframe
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To display the Layer parameters in the Timeline View:



In the Timeline’s left-hand side, click on the Expand Function
The default keyboard shortcut is [Alt]+[F].
OR

button.



In Animate Pro, you can select the layer you want to display the functions for, go to the Timeline View
menu and select View > Show Functions.

There are six options available for setting up your function parameters:

Locked Positions

Locked Scale

Separate Positions

Separate Scale

• Locked Positions (3D Path)
• Separate Positions
• Locked Scales
• Separate Scales
• Quaternion (3D Rotation)
• Euler Angles (3D Rotation)
You can set the preferences to suit your way of working. In
your general preferences, enable Default Separate Positions to
get separate X, Y and Z positions, or disable it to get a 3D path.
The 3D path is set by default.
Enable the Default Separate Scale to get separate X and Y
scales. It is highly recommended that you use default separate
scales.
You have to lock or unlock your functions before starting
the animation. When you lock or unlock parameters, this does
not convert the functions from one to the other, but creates new
ones.

Quaternion
(Locked 3DRtation)

Euler Angles
(Separate 3D Rotation)

This topic is divided as follows:

• 3D Path, on page 592
• Separate Positions, on page 592
• Locked Scales and Separated Scales, on page 592
• Setting the Parameters, on page 593

Refer to the Working in a True 3D Space (PRO) chapter to learn about moving your elements in three dimensions.
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3D Path
In a 3D Path, the X, Y and Z curves are locked together and controlled by a single velocity function. When you add a
keyframe, it is added on all three trajectories at once, as is the velocity. This is very useful for long, smooth trajectories.

Separate Positions
When the Separate Positions option is used, the X, Y and Z curves are independent and have velocity controls directly
on their function curve. This is useful when you want to set keyframes on one of the curves without affecting the
others.

Locked Scales and Separated Scales
When using the scale function, you can have a single function curve controlling both the vertical and horizontal scale,
or have the two scales separate. This means that when using the single function, the values will be the same for the X
(horizontal) and the Y (vertical) axes, enabling a uniform size change without distortion. However, if you separate the
scale functions, you will be able to squash, stretch and skew your elements.
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Setting the Parameters
This topic will cover the 2D motion parameters.
Refer to the Working in a True 3D Space (PRO) chapter to learn about moving your elements in three dimensions.
To set the parameters:
1.

In the Timeline view, double-click on the layer that you want to set the parameter for.
The Layer Properties editor opens.
Animate

2.
3.
4.
5.

Animate Pro

Go to the Transformation tab.
In the Position section, enable either the 3D Path or the Separate options.
In the Scale section, enable either the Locked or the Separate options.
Click on the Close button.
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Adding and Deleting Keyframes
You can create a keyframe in several different ways.
You can add a coordinate keyframe, position keyframe or a keyframe along with your drawing duplication.

•
•
•
•

Coordinate Keyframe, on page 594
Add Keyframe and Duplicate Drawing, on page 594
Position Keyframe, on page 595
Delete Keyframe, on page 595

Coordinate Keyframe
To create keyframes:
1.

2.

In the Timeline view, select the cell where you want to add a keyframe.

Here are the different ways to add a keyframe to your timeline:
In the top menu, select Insert > Keyframe.
Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Add Keyframe.
The default keyboard shortcut is [Ctrl]+[F6] (Windows) or [a]+[F6] (Mac OS X).







You can also click on the Add Keyframe

button available in the Timeline View toolbar.

In the Camera view, if the Animate mode is enabled, as soon as you move the selected element, a keyframe
will be automatically created on the current frame.

Add Keyframe and Duplicate Drawing
The method described previously only creates a keyframe without a drawing. It adds a new coordinate points but the
drawing in the layer stays the same. You may want to duplicate your drawing at the same time if you need to modify
it and do not want to modify the original one. In this case, you can use the Add Keyframe and Duplicate Drawing
function.
To create a keyframe and duplicate your drawing at once:
1.

2.

In the Timeline view, select the cell containing the drawing where you want to add a keyframe and duplicate.

Here are the different ways to add a keyframe and duplicate:
In the top menu, select Insert > Keyframe and Duplicate Drawing.
Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Insert Keyframe and Duplicate
Drawing.
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Position Keyframe
You can also add a Position Keyframe instead of a regular keyframe. When you add a Position keyframe, keyframes
will only be added on the X, Y and Z parameters of the selected layer. Keyframes are not added on the Angle, Scale
and Skew parameters.
To add a Position keyframe:
1.

In the Timeline view, select the cell where you want to add a position keyframe.

2.

In the top menu, select Insert > Position Keyframe.

If you select a keyframe in the Timeline view and press the [Delete] key, you will also delete the drawing exposure. To
only delete the keyframe, you must use the Delete Keyframe command.

Delete Keyframe
To delete a keyframe:

 With the Transform Tool

selected, choose the Keyframe to be deleted from the trajectory in the Camera
View and press the [Delete] key.

OR

 In the Timeline view, click on the keyframe to be deleted, right-click (Windows) or [Ctrl]+click (Mac OS X) and
select Delete Keyframes. The default shortcut is [Shift]+[F6]. You can also select
Animation > Delete Keyframe from the top menu.
Refer to the following sections for more information about adding keyframes:

•
•
•

Modifying a Path in the Camera View, on page 603
Modifying a Path in the Timeline View, on page 611
Modifying a Path in the Function View, on page 614
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Stop-Motion and Motion Keyframes
Interpolation is the computer-generated motion between two keyframes. Some animators and compositors create
their own inbetweens, others have the computer do it. Animate gives you Stop-Motion and Motion keyframes.
This topic is divided as follows:

•
•
•

Stop-Motion Keyframes, on page 596
Motion Keyframes, on page 596
Toggling Between Motion and Stop-Motion Keyframes, on page 596

Stop-Motion Keyframes
A Stop-Motion keyframe means that there is no computer-generated motion between two keyframes. The segment
is constant or flat.

Constant Segment
Keyframe
Pops to next
position

Keyframe

Motion Keyframes
A Motion keyframe means that there is computer-generated motion between two keyframes. The segment has a
variation over time.

Keyframe
Gradually moves to
the next position

Keyframe

Keyframe

Toggling Between Motion and Stop-Motion Keyframes
You can switch a keyframe between Stop-Motion and Motion at any time in the Timeline view and Function Editor.
To toggle between Motion and Stop-Motion in Timeline View:
1.
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On the right-hand side of the Timeline, select one or more keyframes to be modified.
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2.

To toggle between Motion and Stop-Motion:
Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selected keyframes and select Set Motion
Keyframes or Set Stop-Motion Keyframes.
 The default keyboard shortcuts are [Ctrl]+[K] (Windows) or [a]+[K] (Mac OS X) and [Ctrl]+[L] (Windows) or
[a]+[L] (Mac OS X).






You can also click on the Motion Keyframe
and Stop-Motion Keyframe
buttons available in the
Timeline View toolbar.
In the Camera view, select the keyframe to convert and in the Coordinates and Control Point view, enable
or disable the Stop-Motion Keyframe option.

To toggle between Motion and Stop-Motion keyframes in the Function Editor:
1.

Open the function editor:
In the Timeline view, double-click on the layer that contains the keyframes that you wish to convert.



The Layer Properties dialog box opens.

In the Transformation tab, click on the Function Editor

button to bring up the Editor Window.

OR
In the Timeline view, click on the Expand Function
button and double-click on the function to edit. The
default keyboard shortcut is [Alt]+[F].
Select one or more keyframes to be modified on the Function Curve.


2.
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3.

Enable or disable the Stop-Motion Keyframe option to set a Stop-Motion or Motion keyframe.

Constant Z
The Constant Z is used when creating Motion keyframes. The Z function will use Stop-Motion keyframes and will not
be interpolated, this can be very useful for cut-out animation. The Constant Z feature only works with 3Dpaths.
You can also enable the Constant Z option directly in the Function Editor or Function view for specific functions.
To enable the Constant Z option:
1.
2.
3.

In the Timeline view, expand the function of the layer you want to set to Constant Z. Note that the 3D Path
option has to be enabled for that particular layer.
Double-click on the Position function to open the Function Editor.
In the Function Editor window, enable the Constant Z option.

Stop-Motion Segment

598

Chapter 14: Creating Animation Paths Animating the Camera

Animating the Camera
Just as in a live-action film, scenes are not only composed of characters moving around in a static camera field, but
also of camera movements. Although it is not always something that we think about, often it is the exact opposite,
the character is static while the camera moves through elements on the stage. Camera pans, jumps, cuts and zooms
are as important to storytelling as the story itself.
Animate has a camera that can move along the X, Y and Z axes. Having the camera move on the Z-axis offers the
possibility to create truck in and truck out, as well as multiplane camera moves. The default camera position is centred
and backed up to 12 fields.

The camera is treated the same way as any other element. The same tools and selection modes are used to offset or
animate it. To animate the camera, you need to connect it to a peg element.

This means that you can animate the camera visually, with the function curve, or by typing values in the Xsheet column.
To add a camera with a peg to your scene:
1.

If you do not already have a camera layer, add one in one of two ways:
From the top menu, select Insert > Camera





From the Timeline view layers toolbar, click on the Add Layers
menu that appears.

button and select Camera from the

In Animate Pro, from the Library, select a Camera module and drag it to your Network view.

A new camera layer will be added to your scene and will appear in the Timeline view.
2.

From the Timeline View Layer toolbar, click on the Add Peg

button.

A Peg layer appears directly above the Camera layer so that the Camera layer is automatically attached to it.
The Peg layer automatically takes on the name of the camera and adds the suffix -P to indicate that it is a peg
layer, for example Camera-P.
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If the new Peg layer did not appear directly above the camera, you may have clicked elsewhere in the scene,
deactivating the layer you wanted to add the Peg layer to.
• Select the Camera layer and drag and drop in under the new Peg layer.
OR
Delete the misplaced Peg layer, select the Camera layer and re-click on the Add Peg

•



button.

Select a Peg module from the Library view and drag it to your Network view and then you can connect the
Peg’s Out Port to the Camera’s Input port.

You are now ready to animate your camera.
It is recommended to use both the Top and Camera Views while making camera moves. You can open this view is one
of two ways:

•

From the top menu, select Windows > Top.

•

From any existing window already open in your project, click on the Drop-Down Arrow
top right-hand corner and select Top from the menu.
The Top view now appears as a tab in that view.

button from the

Camera

Refer to the Working in a True 3D Space (PRO) chapter to learn about moving your elements in three dimensions.
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To animate your camera:
1.

Make sure that both the Animate

button and the Transform Tool

are activated.

2.

In the Top view, select the camera (the large V-shape on the right-hand side) and move it to the desired position.

3.
4.

In the Timeline view, click on a cell in the Camera Peg layer where you would like the camera move to begin.
Right-click (Windows) or [Ctrl]+click (Mac OS X) and select Insert Keyframe from the menu that appears.

5.
6.

A keyframe now appears in that cell. Any frames preceding this keyframe cell will hold the same camera position
as in this keyframe.
Click on another cell, further down your scene’s Timeline, where you would like the camera move to end.
Select the camera in the Top View and move it to the position you desire.

A second keyframe appears and a line is created between the two frames to indicate that the subsequent
motion between the frames will be calculated and rendered by the program.
7.

Play back

the camera move in the Camera view to watch the results.

For more information about the Camera positioning tools, refer to Setting Up the Scene > Setting the Camera
Frame, on page 477.
For more information on animating with a Peg, refer to Animating Your Puppets > Adding Pegs, on page 701.

Camera truck-ins and Line Thickness
As you move the camera into your scene along the z-axis, you may notice that the lines of your elements drawn with
pencil lines instead of brush strokes appear too thick. There is a simple way to taper down the pencil line thickness
while preforming a camera zoom-in.
To adjust the pencil line thickness of a particular drawing in the Camera View:
1.
2.
3.

In the Timeline view, double-click on the drawing layer in question to bring up the Layer Properties panel.
Click on the Advanced tab.
Under the Line Thickness section, adjust some of the following parameters until you achieve the desired effect.
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1
2
3
4
5
6
7














(1) Adjust Pencil Lines Thickness
Checking this option allows for the adjustment of pencil lines thicknesses and activates the adjustable
parameters in this section.
(2) Normal Thickness
This is the default option and when it is the only selection, negates the adjustable parameters and keeps the
line thicknesses at their original proportions to the camera position. In general, it is good to keep this
option checked. If you uncheck this option, all your pencil lines will disappear if you have nothing on the
colour art layer. If you do have artwork on the colour art layer, your lines will be replaced by the colour art.
(3) Zoom Independent Thickness
Checking this option will keep all lines at their default thickness regardless of the camera zoom. This may
create the illusion that as the camera zooms-in the lines become thinner, when in fact they have remained
the same thickness.
(4) Proportional
By default, this parameter is set to 1. All pencil line thicknesses in the scene will be multiplied by the value
entered in this field. For example, if the value entered is 2, then a pencil line thickness of 5.5 will become
11, while a pencil line thickness of 21.7 will become 43.4.
(5) Constant
By default, this parameter is set to 0. Changing the value is this field will multiply the line thickness by the
pixel portion of the camera frame.
(6) Minimum
Enter a value into this field or use the arrows to set a minimum line thickness that cannot be exceeded.
(7) Maximum
Enter a value into this field or use the arrows to set a maximum line thickness that cannot be exceeded.

NOTE: This feature can only be viewed in the Camera view’s render mode.
Refer to the section Function Drop-down Menu and Function Types to learn more about linking parameters to
different types of dynamic functions.
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Modifying a Path in the Camera View
Although the example cited in the Animating the Camera section seems simple enough, camera moves and motion
paths can become complex, especially with moves through 3D space. That is why Toon Boom has developed a way
to view your camera’s path and make adjustments to it from both a 2D and 3D perspective.
This topic is divided as follows:

•
•
•

Displaying a Path in the Camera View, on page 603
Shaping a Path, on page 604
Offsetting a Trajectory, on page 610

Displaying a Path in the Camera View
You can display the trajectory for your motion path when you select an object in the Timeline or Camera view.
If you want to see the trajectory, enable the Show Control Points on Selected Layers preference.
To enable the Show Control Points on Selected Layers preference:
1.
2.
3.
4.

In the top menu, select Edit > Preferences (Windows) or Animate > Preferences (Mac OS X). The default
keyboard shortcut is [Ctrl]+[U] (Windows) or [a]+[,] (Mac OS X).
The Preferences panel opens.
Go to the Camera tab.
In the Control Points, section enable the Show Control Points on Selected Layers preference.

5.

Click on the OK button.

If your trajectory is hidden when you select an element, you may want to display it using the Control command.
To view your layer’s trajectory using the Control command:
1.

Verify that the Camera view (click on its tab) is selected and that the layer that you wish to display the trajectory
of is selected in the Timeline view.




From the Top menu, select View > Show > Control.
The default keyboard shortcut is [Shift]+F11.
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NOTE: If nothing appears in the Camera view, you may not have animated or selected the layer.
To hide your layer’s trajectory:
1.

Verify that the Camera view (click on its tab) is selected and that the layer that you wish to hide the trajectory of
is selected in the Timeline or Camera view.





From the top menu, select View > Show > Control.
The default keyboard shortcut is [Shift]+F11.
If you want to hide all of your trajectories at once without selecting any layer, select View > Hide All
Controls. The default keyboard shortcut is [Shift]+[C].

Shaping a Path
A motion path is as easy to manipulate as shaping the vector points of a drawing layer in the Camera view. One
important concept to understand is that a trajectory contains both Keyframes and Control points. Both can be used
to shape a path, each have their own significance and behaviours, however only keyframes appear in the Timeline
view. Their descriptions, in terms of their use along a path, are listed below:

•
•

Keyframe: a marker that signifies a change (size, position, direction, etc.) along the normal of a path or
function and has a precise position and frame.
Control Point: has a position but no fixed frame or timing. It is mainly used to deform a trajectory. There are
no velocity handles available on a control point. The velocity segments are set between keyframes only,
making curves and trajectories much smoother.
Control Points can only be added on 3D Path.

To resize an entire animation path so it fits into your scene’s composition better, convert the animation into a
Symbol, then resize the Symbol itself.
Refer to the Libraries, Symbols and Templates chapter to learn how to create and import Symbols.
You can edit keyframes and control point parameters, such as the position, continuity, bias, tension and lock in time
using the Coordinates and Control Point view.
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Each time a keyframe or a control point is selected in the Camera, Timeline or Xsheet view, its parameters appear in
the Coordinates and Control Point view. You can also see the same information in the Coordinate and Control Point
toolbars.

Adding Control Points
A Control Point has a position but no fixed frame or timing. It is mainly used to deform a trajectory. There are no
velocity handles available on a control point. The velocity segments are set between keyframes only, making curves
and trajectories much smoother.
A Control Point will not show in the Timeline view because it has no precise frame to be displayed on. It will appear
on the function curve and in the Camera view. There are different ways to add control points:

•
•

Display the trajectory in the Camera view and pressing the keyboard shortcut [P].
Add a keyframe on the function curve and disabling the Lock in Time option.

The Control Point is displayed as a circle.
You can display your trajectories in the Camera, Top and Side views to better understand the way that your elements
move in your scene. This also makes it easier to modify them. You can display a peg or layer’s control to be able to
see where your elements are going, modify the curve and add keyframes and control points.
To add a Control Point on a trajectory:
1.
2.

In the Timeline or Camera view, select the peg or layer you want to add the control point on.
If the selected element’s trajectory is not displayed, select View > Show > Control in the top menu. The default
keyboard shortcut is [Shift]+[F11] (Windows).
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The Trajectory appears in the Camera, Top, Side and Perspective views.

3.

You can add control points on a 3D path trajectory by placing your mouse where you want to add the point and
pressing the keyboard shortcut [P].

Toggling Between Keyframe and Control Points
To toggle between Keyframe and Control Points:
1.
2.
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In the Camera view, using the Transform tool select the point you want to convert.
To convert the point:
 In the Coordinates and Control Point view, enable or disable the Locked in Time option.



In the top menu, select Animation > Lock in Time. The default keyboard shortcut is [Alt]+[L].



In the Function view or Function editor, select the keyframe to convert and click on the Lock in Time
button.
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Adjusting the Tension, Bias and Continuity
You can adjust the Tension, Bias and Continuity parameters on an already existing Control Points and Keyframes by
selecting the point in the Camera View with the Transform Tool

.

•

Continuity controls the smoothness of a transition between the segments joined by a point.

•

Tension controls how sharply the path bends as it passes through a control point or keyframe.

•

Bias controls the slope of the path so that it flows towards one side of the motion point or the other.

To adjust the Continuity, Tension and Bias parameters:
1.

In the Tools toolbar, select the Transform tool

.

2.

In the Timeline view, select the layer that you want to adjust the parameters for.

3.

In the top menu, select View > Show > Control to display the trajectory. The default shortcut is [Shift]+[F11]
(Windows).
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4.

In the Camera view, select the Control Point or Keyframe you want to adjust.

5.

In the Coordinates and Control Points view, adjust the Continuity, Tension and Bias parameters.

If you find that you are using the same Continuity, Tension and Bias settings, you can set a preference to remember
your settings.
To adjust the Point Setting Preferences:
1.

2.

From the top menu, select Edit > Preferences (Windows)
or Animate > Preferences (Mac OS X).
The Preferences window opens.
From the top of the Preferences window, select the Camera tab and look to the entire right-hand section of that
panel.

Toggling Between a Linear or Curved Motion
When you select a control point on a path, you can toggle between a rounded or square corner by using the Linear/
Curve command.
To toggle between a linear or curved corner:
1.
2.
3.
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In the Tools toolbar, select the Transform tool. The default keyboard shortcut is [Alt]+[Q].
In the Camera view, select the point to convert.
In the top menu, select Animation > Linear/Curve. The default keyboard shortcut is [O].
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Cumulative Z Value
You can see the cumulative Z Value information in the Coordinates and Control Points view. When you select a drawing
cell including a keyframe, it will display the Cumulative Z value.
When a layer is parented to other layers that are moved forward or backward on the Z-axis, the currently selected
layer’s position Z value may not be accurate since its parent will also have an offset on the Z-axis. The Cumulative Z
value is a compilation of all the Z-axis offsets to give the real Z-axis offset value related to the (0,0) centre.
Z = 2F
Z = 4B
Z = 6F
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Offsetting a Trajectory
To reposition the visual trajectory to a more convenient location, you can use the Spline Offset tool.
Offsetting your trajectory will not offset or modify your animation. It will facilitate your work.
To offset a spline/trajectory:
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1.

In your Animation Tools toolbar, select the Spline Offset

tool. The default keyboard shortcut is [Alt]+[9].

2.
3.

In the Camera or Timeline view, select the layer to be offset.
In the top menu, select View > Show > Control to display the trajectory. If you do not display the trajectory, the
transformation done using the Spline Offset tool will be ignored.

4.

In the Camera view, move the trajectory to the proper position. You can move it on the x and y axes, but also on
the Z-axis using the Top and Side views.
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Modifying a Path in the Timeline View
When you select a peg or drawing layer in the Camera view and move it around, Animate will automatically create the
corresponding function curves.
If you would then like to modify these functions, you can always do it through the Peg’s or Layer’s parameters in the
Timeline view.
This topic is divided as follows:

•
•
•
•

Creating a Function, on page 611
Adding and Deleting Keyframes in the Timeline View, on page 612
Changing Keyframe Values, on page 612
Flipping Between Keyframes, on page 613

Creating a Function
To create the function curve in the Timeline view:
1.

Double-click on ether a drawing or peg layer.
The Layer Properties dialog box appears.

2.
3.

Identify the section of the type of function that you want to create.
Click on the Function Arrow button at the end of the corresponding row.

4.

Choose Create a Bezier or Ease curve from the menu.
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Refer to the Function Types section of this chapter to gain a greater understanding of this subject and the menu
options listed above.

Adding and Deleting Keyframes in the Timeline View
To insert a Keyframe:
1.

On the right-hand side of the Timeline, select a cell on the layer’s function that you want to animate.

2.

Right-click (Windows) or [Ctrl]+click (Mac OS X) the selected cell and select Insert Keyframe. The default
keyboard shortcut is [Ctrl]+[F6] (Windows) or [a]+[F6] (Mac OS X).

To delete a Keyframe:
1.
2.

On the right-hand side of the Timeline, select a cell with the Keyframe that you want to delete.
Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selected Keyframe and select Delete Keyframes from
the menu that appears.
You can [Shift]+click on several keyframes to select a group before selected the Delete Keyframes option.
If you select a Keyframe or group of Keyframes and press [Delete], it will also delete the corresponding
drawings on that cell.

Changing Keyframe Values
To change the keyframe values in the Timeline:
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1.

Open the layer’s parameters by clicking on the Expand Function
keyboard shortcut is [Alt]+[F].

2.

Click on the Show/Hide Data View
timeline fields.

button next the layer’s name. The default

button at the top of the Timeline view, between the layer names and the
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3.
4.

Select the parameter that you wish to create a function curve for: Path, Velocity, Scale: x or y, Angle or Skew. For
this example we will use Velocity.
Pass the cursor over the blue number value of the parameter layer that you wish to modify.






Wait until the cursor becomes a white hand with a two-way arrow
slightly to the left or right to decrease or increase the value.

and then click and drag the hand

OR
Click directly on the blue number and enter a value into the white field that appears.
If you selected the keyframe in the Camera view, you can modify the values in the Coordinate and Control
Points view.

A function is automatically created as soon as the values change from zero.
5.

Press [Enter] or click on the Play

button to view the changes you have made in the Camera View.

Flipping Between Keyframes
Animate lets you flip between the selected layer’s keyframes.
To flip through your poses:
1.

In the Camera or Timeline view, select the layer you want to see the keyframes for.

2.

In the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe. The default keyboard
shortcuts are; [‘] Go to Previous Keyframe and [;] Go to Next Keyframe.
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Modifying a Path in the Function View
If you are used to graphs and function curves, you can use the Function view to define your trajectories.
This topic is divided as follows:

•
•
•
•

Function View, on page 614
Editing a Function in the Function View, on page 615
Adding and Deleting Keyframes in the Function View, on page 616
Changing a Keyframe’s Values, on page 617

Function View

While editing the X function
of this 3D motion path, you
can see the graphs for the Y,
Z and velocity.

The Function view allows you to display multiple functions in the background as a reference. While you are editing
one function, you can see other selected functions, this helps you synchronize changes in one function with other
functions.
You can set the orientation of the Function view to be vertical (portrait) or horizontal (landscape).

 In the Function View
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menu, select View > Set Vertical Layout/Set Horizontal Layout.
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To display a function in the Function view, click its name in the Timeline view. You can also display several functions in
the Function View.
To display functions in the Function view:
1.

Open the Function view.
The Function view is blank until you select the functions you want to display.

2.

Click on the Function
button and scroll down the list of available functions. Click the checkbox next to the
function name to display it in the view.

To display a function in the Function view, click its name in the Timeline view.
To select the function you want to edit, select its name from the function drop-list.


3.

Editing a Function in the Function View
The graph displays the motion over the first and last keyframes set in the scene, as well as any keyframes created
between. If the scene is 60 frames, but the character’s motion ends at frame 40, then the editor will only display up
to frame 40.
To edit a function in the Function view:
1.
2.

In the graph of the Parameter Editor, select one of the white keyframes. If selected properly, the keyframe turns
red and displays a pointed yellow handle.
Click and drag the point either up or down or click and pull one of the handles to adjust the curve of the graph.

In this case, changing the Velocity from a straight line (constant velocity) to a curved one, changes the ease-in
(where the curve shoots up and then flattens-out) and ease-out (where the curve flattens-out and then shoots up)
values.
The centre keyframe can not be dragged up or down because the velocity is set. Theoretically dragging it
downwards towards zero would put it back to a place of non-movement.
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3.

Press the [Enter] key with the Parameter window still open to watch the result of your curve adjustment in the
Camera view.

Adding and Deleting Keyframes in the Function View
If you want to change a parameter between two Motion Keyframes in the Timeline View, such as the scale, you can
do so by adding keyframes in the Scale Editor.
To add or remove keyframes in the parameter Editor:
1.

Open the layer parameters by clicking on the Expand Function

2.

Select the parameter that you wish to create a function curve for: Path, Velocity, Scale: x or y, Angle or Skew. For
this example we will use Scale: x.
Double-click on the parameter layer name to open the Function editor window or click once on the parameter
layer to display it in the Function view.

3.

4.

button next the layer’s name.

In the graph section, click on the frame number where you would like to make changes or in the Point section,
enter the frame number directly into the Frame field.
In the graph section, a vertical blue line will indicate the frame number selected.

5.

Click on the Add/Remove Keyframes

6.

Click on the newly created keyframe and drag it up (to decrease the width of the object) or down (to increase
the width of the object) or pull on the handles to create a smooth fluctuation of the drawing object’s width.
If you do not like the changes made, you can delete the new keyframe by selecting the keyframe, if it is not

7.

button.

already selected, and press the [Delete] key, or by clicking on the Add/Remove Keyframes
You can delete an already existing keyframe by using the same process.
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Changing a Keyframe’s Values
In the example cited above, once a keyframe is created, it can be moved and its handles manipulated to change the
shape of the curve. Once a keyframe is manipulated it’s value changes. This value is displayed in the Value field of the
Point section in the Parameter Editor.
However, it is possible to work the other way around; it is possible to enter values into the Value field and watch the
keyframe change position and the curve along with it
To change a keyframe's value:
1.

Open the Peg element’s parameters by clicking on the Plus

2.

4.

Select the parameter that you wish to create a function curve for: Path, Velocity, Scale: x or y, Angle or Skew. For
this example we will use Scale: y.
Double-click on the parameter layer name to open the Editor window or click once on the parameter layer to
display it in the Function view.
In the Point section, enter a value in the Value field or drag up or down the keyframe you want to modify.

5.
6.
7.

Click [Enter] or click on the Play
button to view the changes made in the Camera View.
Keep adjusting your values accordingly, until you are satisfied with what you see.
Click on the Close button.

3.

Sign next the Peg layer’s name.
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Modifying a Path in the Xsheet View
If you are used to working with the Exposure Sheet, you can also create keyframes and type values in the Xsheet view.
You cannot create function curves directly in the Xsheet view. You must do this in either the Layer Properties editor or
the Timeline view.
To edit a function column in the Xsheet view, you must first display the Functions section of the Xsheet view and then
select the layer you want to modify.
To display the function columns in the Xsheet view:
1.
2.

In the Xsheet view, click on the Expand Function Section button.
In the Timeline view, select the layer containing the parameters to modify.
The columns appear in the Xsheet view.

To add a keyframe in the Xsheet View:
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1.

In the Xsheet View, go to the function column where you want to add a keyframe.

2.

Double-click on the cell where you want to add a keyframe and type a numeric value.

3.

Click on [Return] to continue to the next cell.
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4.

Click on [Esc] to exit the typing mode.

To convert a cell into a keyframe:
1.
2.

In the Xsheet View, go to the function column where you want to add a keyframe.
Select the cell to convert.

3.

Right-click (Windows) or [Ctrl]+click (Mac OS X) on the cell and select Set Selection As Keyframe. The default
keyboard shortcut is [Ctrl]+[F6] (Windows) or [a]+[F6] (Mac OS X).



If you want to remove a keyframe, select the keyframe, right-click (Windows) or [Ctrl]+click (Mac OS X) on
the cell and select Clear Keyframe in Selection. The default keyboard shortcut is [F7].

If you double-click on a function column’s header, you will display the corresponding function curve in the Function
editor.
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Function Curves
By default, when a drawing or peg is added to the scene, no function curve is created. You will generally create the
ones needed to avoid having an overload of useless functions.
When you select an element in the Camera View and move it around, it will automatically create the corresponding
function curves.
If you need to create certain functions manually, you can always do it through the Layer Properties view or editor.
You can also link a layer’s parameter to an existing function curve.
This topic is divided as follows:

•
•
•
•

Creating Function Curves, on page 620
Sharing Functions, on page 621
Function Drop-down Menu, on page 624
Function Types, on page 625

Creating Function Curves
You can manually create a function in the Layer Properties View or the Layer Properties Editor. You can either share it
with other layer’s parameters or to set your keyframes directly on the function curve instead of the Timeline or Camera
view.
To create the function curves for your project:
1.

To open the Layer Properties editor, in the Timeline View, double-click on the layer or click once to display it in
the Layer Properties view.

The Layer Properties editor opens.
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2.

Go to the Transformation tab.

3.

Click on the Function Arrow

button beside the local function information.
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4.

Create a 3D Path, Bezier, Ease or Velobased curve.



In Animate Pro you can also create an Expression column. Refer to the Expression Columns (PRO)
section to learn more.

Refer to the Function Types topic to know more about function types.

5.

You can click on the Function
Click on the OK button.

button to open the Function Editor.

Sharing Functions

You can hook several parameters to the same function curve. For example, if you have an aircraft performing loops
between clouds, you may want the camera to follow the aircraft’s motion path. If you attach the camera to the aircraft’s
layer, the camera will also loop, but this may produce undesirable results and even induce a feeling of motion sickness
as you watch the final animation. Instead, what you can do is to share the X, Y and Z aircraft’s position with the
Camera’s peg layer, but ignore the angle. scale and skew.
By default all the function curves you create are private. This means that the function curves can only be used and
modified using their original parameter. If you want another layer or parameter to use the same function curve, you
must make the function public.
There are two ways to share a function:

•
•

Share Functions command
Layer Properties Editor
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To share a function using the Share Functions command:
1.

2.

In the Timeline view, select the function layer to share.

Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Share Functions.
The function now becomes public to the other layers and parameters and can be shared.
Public functions are visible in the main section of the Xsheet view.

3.
4.

5.
6.
7.
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In the Timeline view, open the Layer Properties editor of the layer you want to link its parameter to the public
function.
To open the Layer Properties editor, in the Timeline view, double-click on the layer containing the function to
share or click once to display it in the Layer Properties view.

The Layer Properties Editor opens.
Go to the Transformation tab.
Click on the Function Arrow
button beside the function you want to link to the function column.
In the drop-down menu, select the function you just turned public from either, the 3D Path, Bezier, Ease,
Velobased, Expression, 3D Path, Connected, Unconnected, All menu, and hook it to your parameter.
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Refer to the Function Drop-down Menu topic to know more about the Function drop-down menu.
The two parameters are now both linked to the same function curve and should follow the same path. If you
modify the curve, both parameters will update.
To share function curves:
1.

To open the Layer Properties editor, in the Timeline View, double-click on the layer containing the function to
share or click once to display it in the Layer Properties view.

2.

The Layer Properties Editor opens.
Go to the Transformation tab.

3.
4.

Click on the Function Arrow
button beside the function to share.
In the drop-down menu, select the Local option.

5.

Click on the Function Arrow
drop-down list.

button beside the Function field and choose an existing function from the

The function now becomes public to the other layers and parameters and can be shared.
Public functions are visible in the main section of the Xsheet view.
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6.

In the same drop-down menu, where you choose the Local option, select the function you just turned public
from either the 3D Path, Bezier, Ease, Velobased, Expression, 3D Path, Connected, Unconnected, All menu and
hook it to your parameter.

7.

In the Timeline view, open the Layer Properties editor of the other layer you want to link its parameter to the
public function.
In the Layer Properties editor or view, hook the parameter to the public function the same way you did for the
first layer.

Refer to the Function Drop-down Menu topic to know more about the Function drop-down menu.

8.

The two parameters are now both linked to the same function curve and should follow the same path. If you
modify the curve, both parameters will update.

Function Drop-down Menu
When you create a function curve in the Layer Properties view or editor, you have several choices available:

•
•
•
•
•
•
•
•

Create 3D Path
Creates a new 3D Path Column set.
Create Bezier
Creates a new Bezier curve.
Create Ease
Creates a new Ease curve.
Local
Disconnects the parameter from any function and turns it public.
3D Path
Displays the list of every public 3D Path function available.
Bezier
Displays the list of every public Bezier curve available.
Ease
Displays the list of every public Ease curve available.
Velobased
Displays the list of every public velocity based curve available.

•

Expression
Displays the list of every public Expression function available.

•

3D Rotation
Displays the list of every public 3D Rotation function available.
Connected
Displays the list of every public connected function curve.
Unconnected
Displays the list of every public unconnected function curve.
All
Displays the list of every public function curve.

•
•
•

The user has the choice of creating a new function curve or linking it to an already existing public one. This way, he
can have two or more parameters following the same function.
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Function Types
Depending of your favorite working method, you can create different types of function curves to suit your need.
You have several choices available:

•
•

Ease and Bezier Functions, on page 625
Velobased Functions, on page 626

Ease and Bezier Functions
When you create a function to control a parameter over time (Scale, X, Y, Z, Rotate), you have the choice of an Ease
or Bezier Function.

Ease Function

Bezier Function

These function editors present different ways of editing the values over time. The shape of the created graph indicates
the velocity of the function, regardless of the chosen editor. The type of function that you choose is largely based on
your own working preference.
With the Ease Editor, you can edit the shape of the function curves using the ease-in and ease-out controls. You may
choose to use this type of function if you are used to working with ease-in and ease-out values.

Converting Ease and Bezier functions
To convert Ease and Bezier functions so that you can edit them using the controls offered by that editor.
To convert Ease and Bezier functions:
1.
2.

In the Xsheet View, if not done yet, show the function columns.
In the Xsheet view, click on the Expand button located on the right side of the main section to show the
Functions section. Click on the same button to collapse it. You can also use the Show Column List
the Xsheet View toolbar.

button in
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3.

Click on the Expand button located on the right side of the Functions section to display the Column List section.

4.

In the Timeline view, click on the layer you want to display the function columns from.

5.

In the Xsheet view, right-click (Windows) or [Ctrl]+click (Mac OS X) the column’s header and select one of the
following from the Convert menu:
 Convert the column: the values of multiple effects may be linked to the original column. When you use the
Convert the Column command, all links to the original column will transfer to the new converted column.
 Create a new column and update links: creates a new function from the original. All links to the original
column will transfer to the new column. The original function column will remain in the exposure sheet in
case you decide you want to switch back to it.
 Create a new unused column: creates a new column based on the values in the original column and leaves
all links pointing to the original column. You can use this command to experiment with various functions and
then link effect values to the new function curve column.

Velobased Functions
You can also create Velobased functions for certain effects, like changes in rotation or size over time. In these cases,
the Velobased functions are linked to the velocity of a 3D path. You cannot change the shape of a Velobased function
to control its velocity.
With Velobased functions, you can link changes in rotation or scaling to the velocity of a 3D path. This makes it
possible for changes in rotation or scaling to progress at the same speed as changes to the position of an element.
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Copying and Pasting a Motion
In the Timeline view, you can easily drag keyframes to change the animation timing, delete them, cycle them and even
copy them.
When you have position keyframes set in your drawing layer and you want to move them around with moving your
drawing’s timing, you can use the Paste Special feature to only move the keyframes selected.
You can also use the Paste Cycle and Paste Reverse feature to cycle your selection including keyframes and drawings.

•
•

Paste Special, on page 627
Paste Cycle, on page 631

Paste Special
To copy and paste a motion:
1.

In the Timeline view, select the keyframes, to copy and paste. If you want to move the keyframes, move on to
step 3.

2.
3.

In the top menu, select Edit > Copy.
To edit your selection:
 To paste the selection, in the Timeline view, select the first cell where you want to paste your keyframes and
in the top menu, select Edit > Paste Special.
 To move the selection, in the Timeline view, drag the selection and hold down the [Alt] key (Windows) or [a]
key (Mac OS X). Drop the selection where you need it before releasing the hot key.

4.

The Paste Special window opens.
Set the Drawing, Pegs and Functions, and Cycles parameters described below.

5.

Click on the OK button.

Paste Special Dialog Box
To open the Paste Special dialog box:
1.
2.

3.

In the Library view, select the Symbol or template to import.
While dragging the selection to the Timeline view, hold down the [Alt] key (Windows) or [Ctrl] key (Mac OS X).
Note: Drop the selection in the Timeline view before releasing the hot key.
The Paste Special window opens.
Set the parameters.

627

Animate Pro 2 User Guide
4.

Click on the OK button.

Basic tab
Advanced tab

Paste Special - Basic Tab
Drawings

•
•
•
•

Only create drawing files when they do not exist: When adding exposures to a drawing layer, new
drawings will be created only when drawings with the same name do not already exist in the destination.
Always create drawing files: When adding exposures to a drawing layer, new drawings will always be
created. If drawing files with the same name already exist, Animate will create a new name for the drawing.
Extend Exposure: Extends the exposure of drawings to fill the range of cells to the destination frame.
Paste all Frames of the Symbols (full movie): When enabled, the Paste Special command will expose all
the Symbol’s frames instead of only the first one.

Cycle

•
•
628

Number of Cycles: Use the up and down arrows to increase or decrease the number of cycles you want to
paste. You can also type the value directly in the field.
Cycle Type: Use the drop-down menu to choose the type of cycle you want to paste.
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D Normal (forward): This pastes your selection as it is, starting with the first cell and ending with the last
one.

D Reverse: This pastes your selection in reverse, starting with the last cell and ending with the first one.
D Forward -> Reverse: This pastes your selection as a yo-yo, starting with the first cell, going to the last
one and ending with the first cell.

D Reverse -> Forward: This pastes your selection as a reverse yo-yo, starting with the last cell, going to
the first one and ending with the last cell.

Paste Special - Advanced Tab
Drawings

•
•

•
•

Do Nothing: Does not create or overwrite drawings.
Add/Remove Exposure: Creates/deletes exposure values in the selected layer.
You have the following choices as to how to treat drawings that will be created when adding an exposure:
D Never create drawing files: When adding exposures to a drawing layer, drawing files will not be
created.
D Only create drawing files when they do not exist: When adding exposures to a drawing layer, new
drawings will be created only when drawings with the same name do not already exist in the
destination.
D Always create drawing files: When adding exposures to a drawing layer, new drawings will always be
created. If drawing files with the same name already exist, Animate will create a new name for the
drawing.
D Extend Exposure: Extends the exposure of drawings to fill the range of cells to the destination frame.
D Key Drawing Mode (Substitution): Pasting an exposure value replaces the cell value in the current
frame and in all frames following in sequence with the original cell value.
Paste all Frames of the Symbols (full movie): When enabled, the Paste Special command exposes all the
Symbol’s frames instead of only the first one.
Update Drawing Pivot: Revises the drawing pivot in the destination to use the same drawing pivot as the
first drawing in the template. If you have a range of drawings selected in the destination, the pivot points of
all selected drawings will be updated.

Add/Remove Keyframes

•
•
•
•
•
•
•
•

Motion: Copies the properties of the selected motion keyframe to the new frame.
Velocity: Copies the properties of the selected velocity keyframe to the new frame.
Rotation: Copies the properties of the selected rotation keyframe to the new frame.
Skew: Copies the properties of the selected skew keyframe to the new frame.
Scaling: Copies the properties of the selected scale keyframe to the new frame.
Force Keyframes at Function’s Beginning and End: Adds a keyframe to the beginning and end of the
pasted function, reproducing the source function.
Offset Keyframes: When pasting functions, this option offsets the keyframes from the function’s last value
by the values in the pasted function. This will continue the progression of a function rather than repeat the
values.
Replace Expression Columns: Replaces the destination function with the formula from the source column.

Cycles

•

•

Cycle Type
D Normal (forward): This pastes your selection as it is, starting with the first cell and ending with the last
one.
D Reverse: This pastes your selection reversed, starting with the last cell and ending with the first one.
D Forward -> Reverse: This pastes your selection as a yo-yo, starting with the first cell, going to the last
one and ending with the first cell.
D Reverse -> Forward: This pastes your selection as a reverse yo-yo, starting with the last cell, going to
the first one and ending with the last cell.
Number of Cycles: Use the up and down arrows to increase or decrease the number of cycles you want to
paste. You can also type the value directly in the field.
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Symbols

•
•
•

Copy symbols if they do not exist: This is the default setting for this operation and will prevent Symbols in
a Action template from being copied.
Duplicate symbols: Creates a duplicate of the Symbol instead of linking the Symbol instance to the original
one. The new Symbol is created in the Library.
Overwrite symbols: If a modification was made to a Symbol that does not exist in the basic rig template for
a character, select this option to overwrite the previous Symbol.

Option (PRO)

•

Palette Option

D Do nothing: Does not create, overwrite, merge or link palettes.
D Reuse palettes. Copy palettes if they do not exist: Palettes in the destination drawings are left as
they are.

D Copy and overwrite existing palettes: Overwrites destination palettes with the palettes from the
source drawings.

D Copy and create new palette files: Creates new palette files, placing them at the same relative

•
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environment and scene level as the source. If the palettes in the templates were stored at the
environment level of the source scene, the paste operation will place the palettes in the environment
level of the destination scene.
D Copy and create new palette files in element folder: Creates new palette files in the element folders
of the destination scene, rather than in the same relative job or environment.
D Copy palette and merge colours. Add new colours only: Adds new colours to the destination
palettes and ignores colours that are the same in the two palettes.
D Copy palette and update existing colours only: Adds new colours to the destination palette and
updates duplicate colours in the destination with colour values from the source.
D Link to original palettes (colour model): Links the colour palettes in the destination scene to the
palettes in the source. Use this to link drawings to the palettes in a colour model.
D Copy scene palettes and merge colours. Add new colours only: Adds new colours to the destination
scene palettes and ignores colours that are the same in the two palettes.
D Copy scene palettes and update existing colours: Adds new colours to the destination scene palette
and updates duplicate colours in the destination with the colour values from the source.
Modules: Create New Columns: If you enable this option a new column will be created when you copy
and paste modules from the Network view or Layer in the Timeline view. If the layers are linked to function
curves, the function curves, the drawings and the timing will be duplicated.
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Paste Cycle
If you want to cycle a portion of your animation, you can use the Paste Cycle command. You can also use the Paste
Reverse command to completely reverse the flow of your animation.
To use the Paste Cycle command:
1.
2.
3.

In the Xsheet or Timeline view, select the cell range and keyframes to loop.
In the top menu, select Edit > Copy.
In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4.

In the top menu, select Edit > Paste Cycle. The default keyboard shortcut is [Ctrl]+[/] (Windows)
or [a]+[/] (Mac OS X).
The Paste Cycle dialog box opens.

5.
6.

In the Number of Cycles field, use the up and down arrow to increase or decrease the amount of cycles you want
to paste. You can also directly type the value.
In the Cycle Type drop-down menu, select the type of cycle you want to paste.

Normal (forward): This pastes your selection as it is, starting with the first cell and ending with the last one.
Reverse: This pastes your selection reversed, starting with the last cell and ending with the first one.
Forward -> Reverse: This pastes your selection as a yo-yo, starting with the first cell, going to the last one
and ending with the first cell.
 Reverse -> Forward: This pastes your selection as a reversed yo-yo, starting with the last cell, going to the
first one and ending with the last cell.
7. Click on the OK button to paste your cycles.





To use the Paste Reverse command:
1.

In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.

2.
3.

In the top menu, select Edit > Copy.
In the Xsheet or Timeline view, select the cell where you want your cycles to start.
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In the top menu, select Edit > Paste Reverse. The default keyboard shortcut is [Ctrl]+[.] (Windows)
or [a]+[.] (Mac OS X).
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Adjusting the Velocity
To add ease in and ease out on your motion paths, you can display the function curve and modify the Bezier or Ease
curve. To apply an ease to multiple functions and keyframes, you can use the Set Ease For Multiple Parameters script
and set the amount desired.
The Velocity, or ease, is used on motion keyframes. The Velocity has to be adjusted directly on the function curve in
either the Function view or the Function editor. When a keyframe is selected, easing values appear in the right handle
and left handle fields, as well as Bezier handle or Ease wheel controls on each selected keyframe. Pull on them to
adjust the ease in and ease out, or type values in the fields.

•
•
•
•
•

Displaying the Velocity Curve, on page 633
Reshaping a Velocity Function with Bezier Controls, on page 634
Reshaping a Velocity Function with Ease Controls, on page 634
Creating a Stepped Velocity, on page 635
Adjusting the Velocity On Several Layers At Once, on page 636

Displaying the Velocity Curve
To display the velocity curve:
1.

In the Timeline View, click on the Expand Function

2.

Double-click on the desired function.

button to display the layer’s functions.

The Function Editor opens.

The editor will not be displayed if the function does not already exist.
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Reshaping a Velocity Function with Bezier Controls
You can reshape the velocity function using Bezier controls.

To reshape a function using Bezier controls:
1.
2.

Click on the keyframe to select it.
Drag the handles to modify the shape of the curve.
The Continuity options, Corner, Straight and Smooth, influence how you can move the handles.
• Straight: allows you to move the handles together, maintaining the same angle to the point.
• Corner: allows you to move the handles independently.
• Smooth: allows you to move the handles together, maintaining the same distance and angle to the point.

Reshaping a Velocity Function with Ease Controls
You can reshape the velocity function using Ease controls.

To reshape the function using Ease controls:
1.
2.

3.

Click on the keyframe to select it.
To set the number of frames in the ease-in, press [Alt], click to the right of the keyframe and drag the green line.
The ease in slope is indicated in blue.
As you change the values visually, the value in the Ease In field is updated. This value represents the number of
frames in the ease-in.
To set the number of frames in the ease-out, press [Alt], click to the left of the keyframe and drag the green line.
The ease out slope is indicated in red.
As you change the values visually, the value in the Ease Out field is updated. This value represents the number of
frames in the ease-out.
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4.

To adjust the ease-in or ease-out, drag the handles around the keyframe.
The Continuity options, Corner and Straight, influence how you can move the handles:
• Straight: allows you to move the handles together, maintaining the same angle to the point.
• Corner: allows you to move the handles independently.

Creating a Stepped Velocity
You can create a stepped curve to hold the same value over a selected number of frames. This works well when you
are animating drawings on 2’s, for example, and you want to hold the same value for a function over those two frames.
To hold the same value over several frames:
1.

Click the Hold Value Editor

button.

The Hold Value editor opens.

2.

In the Hold Value Editor, enter the following values:
In the Start field, enter the starting frame for the effect.
In the Stop field, enter the last frame for the effect.
In the Step field, enter the number of frames that you want to hold the value for.





The function curve is updated based on the values you entered.

You can reshape the curve to create a linear velocity so that the values are interpolated (tweened) consistently
between keyframes (that is, there is no acceleration in the effect).
To create a linear velocity between two keyframes:

 Click the keyframe to select it and then click the Linear Velocity
on the Ease or Bezier function so that the velocity is linear.

button. This command resets the handles
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Adjusting the Velocity On Several Layers At Once
If you have several functions you would like to adjust the velocity for at the same time, you can use the Set Ease for
Multiple Parameters dialog box. It allows you to apply the same velocity parameters to all the selected keyframes in
a same frame.
To set eases on multiple parameters:
1.

In the Timeline View, select a keyframe on one or many layers.

NOTE: only the first selected keyframe will be considered when using the Set Ease For Multiple Parameter
function. If many keyframes are selected on a same layer, the ease values will be applied only to the first one and the
rest will be ignored.
2.

In the Timeline view, right-click (Windows) or [Ctrl]+click (Mac OS X) and select Set Ease For Multiple
Parameters. In the Timeline View toolbar, you can click on the Set Ease For Multiple Parameters
button.
This button is available in the Timeline View toolbar’s extra buttons. Refer to Chapter 3: Discovering the
Interface > Managing the Toolbars to learn how to customize your toolbars.
The Set Ease For Multiple Parameters dialog box opens.

4
3

5
6
3.
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In the graph interface, pull on the Bezier handle to adjust the velocity for all the selected functions.
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4.

If you want to apply these easing parameters to a certain type of function only, such as Rotation or Scale, in the
Filters section, disable the function types you do not want to affect.
 Motion: If this option is enabled, the easing parameters will be applied to the selected Position X, Position
Y, Position Z and 3D Path functions
 Rotation: If this option is enabled, the easing parameters will be applied to the selected Angle functions.
 Scale: If this option is enabled, the easing parameters will be applied to the selected Scale functions.
 Skew: If this option is enabled, the easing parameters will be applied to the selected Skew functions.
 Morphing: If this option is enabled, the easing parameters will be applied to the selected Morphing
Velocity functions. Note that it applies to the Morphing velocity function found in the Layer Properties
dialog and not to the basic Morphing ease in the Tool Properties view.
 Other: If this option is enabled, the easing parameters will be applied to all the other the selected functions
such as all functions created to animate effect parameters.
5. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values are
calculated in percentage.
 In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding to the length of
time you want the easing to last for. If you go over 100%, your motion will overshoot. It is recommended to
remain between 0% and 100%.
 In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong you want the
easing out to be. If you go over 100%, your motion will over shoot. It is recommended to remain between
0% and 100%.
 If your Time Ratio and Value Ratio values are equal, you will have a linear motion.
6. Once done, click on one of the following button:
 Apply: This will apply the easing parameters to the selected keyframes.
 Apply/Previous: This will apply the easing parameters to the selected keyframes and then selects the
previous keyframe in the timeline.
 Apply/Next: This will apply the easing parameters to the selected keyframes and then selects the next
keyframe in the timeline.
 Close: This closes the dialog box. If you did not apply the modifications, they will be cancelled.
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Expression Columns (PRO)

In Animate Pro, you can use expressions to automate the calculation of effect values based on the values in another
function. An expression is a mathematical formula that allows you to manipulate the value in the source function to
create new values for the destination effect.
For example, if you take two characters and one is walking across the stage and the other is following the same path
two steps behind. Without expressions, you would have to manually enter the values for the position of the peg so
that it was one frame behind the original element. However, you can save time by building an expression that does
this process for you. Then, if you change the position of the element in the original column, Animate Pro automatically
updates the Expression columns linked to it.
This topic is divided as follows:

•
•

Operators and Operands (PRO), on page 638
Creating an Expression for an Effect (PRO), on page 640

Operators and Operands (PRO)
Expressions include operators and operands.

•
•

Operators are symbols that represent an action, like + for addition.
Operands are values that are manipulated by the operators.

In the expression (10 + 5), 10 and 5 are the operands and + is the operator.
In Animate Pro, you build expressions with following operators:

•
•

•
•
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+ (addition)
- (subtraction)
You must include spaces around the minus sign when it is part of a mathematical expression because “-” is
also a valid character in element names. Further, you can also use “-” as a unary minus sign, meaning that
you can negate entire operations with the minus sign. For example, - (5-3) would result in the value -2.
* (multiplication)
/ (division)
Multiplication and division are performed before addition and subtraction. You can use parentheses ( ) to
enclose discreet operations.
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To refer to the values in a column, you use the column name and the frame number. If you do not state the frame
number, then Animate Pro assumes you want the value of the current frame. You can refer to the frame numbers in
the following ways:

•
•
•
•

frame: refers to the current frame number.
previous: refers to the frame before the current frame.
You must provide an argument in parentheses () to get a value. The argument is the name of the column
whose previous frame values you want to retrieve.
Nframe: refers to the total number of frames in a scene.
[ ], in the square brackets you can refer to specific frame numbers.
For example [frame - 2] refers to the frame before the previous frame. You must put space between frame,
the minus sign and the number for the expression to be valid.

Consider the expression: previous(peg_x)

•

This expression says that the current frame value will be the same as the previous frame value of the
element peg_x.

Now consider this expression: peg_angle[frame - 2] * 3

•

In this expression, we are telling the Animate Pro to look two frames before the current frame in the column
“peg_angle” and multiply the value by 3 to derive the value for the current frame of the Expression column.

There are also a number of predefined functions that you can use:

•
•
•
•
•

•
•
•
•
•

•
•

sum: adds all previous frames to create the value at the current frame).
tan (tangent), cos (cosine), sin (sine), atan (arc tangent), acos (arc cosine) and asin (arcsine).
These functions are useful in calculating camera angles and angles of rotation.
round: rounds a number with digits after the decimal to the nearest whole number.
int: removes the values after the decimal point to make a whole number.
atan2(y, x): unlike the other arc tangent function (atan), this function gives you a value between -180 and
180. In the other arc tangent function you would loose the positive/negative signs that indicate which
quadrant the value would be in. With the atan2 function, the resulting quadrant is preserved. You would use
this function when working with a directional blur where the direction of the blur is important to preserve.
ceil: rounds the value to the next integer. For example:
D If the value is 3.7, the ceil value is 4.
D If the value is 3, then the ceil value is 3.
floor: rounds the value to the lower integer. For example:
D If the value is 3.7, the floor value is 3.
D If the value is 3, then the floor value is 3.
abs: the absolute value of the number. For example:
D If the number is -2, then the result of this function would be 2.
D If the number is 2, the result of the function would be 2.
sqrt: square root of the value.
Comparison functions (=, ==, !=, <, <=, >, >=): these functions compare arguments. When the function is
true, the result is 1. When the function is false, the result of the function is 0 (zero). You can use these
functions with the conditional (if) function.
D =, == : compares the two arguments to find out if they are equal
D !=: compares the two arguments to find out if they are NOT equal
D < : less than
D <= : less than or equal to
D > : greater than
D >= : greater than or equal to
exp: indicates that the argument is an exponent of e (2.71828).
For example: exp(5) = 148.413
ln: logarithm of a value
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•

Conditional function (if, then, else): use this function to execute calculations conditionally.
You can use conditional expressions with the comparison functions. The value 0, is considered false. Any
value not 0 is considered true.
For example: if (peg_x >= pegant_x) then (peg_x * 2) else pegant_x * 2
This conditional expression says that if the peg_x column is greater than or equal to the value in the
pegant_x column, then the value of the function is peg_x multiplied by 2, otherwise the value of the
function is pegant_x multiplied by 2.

Creating an Expression for an Effect (PRO)
To create an expression for an effect, you must add an Expression column to the Xsheet view, build the expression
and then link the Expression column to the parameter you want to control.
To build an expression for an effect:
1.

In the Xsheet View menu, select Columns > Add Columns. The default keyboard shortcut is [Shift]+[C].

2.
3.
4.

In the Add Columns dialog box, type a name for the column and select Expression from the Column Type dropdown list.
Click on the OK button.
Double-click on the column’s header to open the Expression dialog box.

5.

Type the expression in the dialog box.

6.

Click OK or Apply to activate the expression.
The cells in the Expression column are populated with values based on the expression you created.
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7.

To apply the values in the Expression column to an effect, you must link the Expression column to the parameter
values. In the Drawing layer’s editor, link the function to the new Expression column.

Refer to the Sharing Functions section to learn more about linking parameters.
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Preferences
While creating motion paths and setting up your scenes, there are preferences you can set to make your work more
efficient.
This topic is divided as follows:

•
•
•

General Preferences, on page 642
Camera Preferences, on page 643
Exposure Sheet, on page 644

To open the Preferences panel:





Windows: Select Edit > Preferences.
Mac OS X: Select Animate > Preferences.
You can also use the default keyboard shortcut
[Ctrl]+[U] (Windows) or [a]+[U] (Mac OS X).

General Preferences
Animate Pro

Animate
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Settings
•
•
•
•
•
•

Stop-Motion Keyframes: New keyframes are created as Stop-Motion keyframes.
Default Separate Positions for Pegs: New pegs are created with separate position functions.
Default Separate Scale for Pegs: New pegs are created with separate scale functions.
Default Bezier: New functions curves are created as Bezier Curves.
Default Bezier Velocity: New velocity curves are created as Bezier Curves.
Default Separate Positions for Elements: New elements are created with separate position
functions.
Default Separate Scale for Elements: New elements are created with separate scale functions.

•

Options
•

Snap Keyframe: If two keyframes have the same value, they will both update to the same new position
when the first of the two keyframes is modified. The previous keyframe has to be a Stop-Motion keyframe.

Timeline (Animate)
•

Add Keyframe At Beginning and End: Adds a keyframe to the beginning and end of the pasted function,
reproducing the source function.

Camera Preferences

Tools
•
•

•

•

Initial Animation Mode: Determines which animation mode are enabled when the scene is opened.
Set Keyframes on All Functions With the Transform tool: A keyframe is added by default on all the
functions of the selected layer when you perform a transformation with the transform tool. Disable this
option if you want the Transform tool to add a keyframe only on the transformation you are doing, such as a
rotation or scale.
Set Keyframe At Frame One With First Application On the Transform Tool: When this preference is
enabled, wherever you set a keyframe on your layer, there will be a keyframe added on your frame 1. If the
preference is disabled, there will be only a keyframe added to the current frame. If later on, you add a
keyframe on your frame one, it may modify the first keyframe you added.
Paste/Drag & Drop Adds Keyframe At Beginning and End: Adds a keyframe to the beginning and end of
the pasted function, reproducing the source function.
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Control Points
•
•
•
•

Show Control Points On Selected Layer: By default, when you select an element with the Transform tool,
the motion path related to the object is displayed. Disable this option to turn off the behaviour.
Control Point Tension: The default Tension value for new keyframes and Control Points.
Control Point Continuity: The default Continuity value for new keyframes and Control Points.
Control Point Bias: The default Bias value for new keyframes and Control Points.

Exposure Sheet

Function Editors
•
•
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Show Grid: When selected, the grid is displayed by default when opening the Function Editor.
Use Constant Z By Default: When selected, the Constant Z option will be enabled by default in the
Function Editor.
Constant Z means that even when creating Motion keyframes, the Z function will use Stop-Motion
keyframes and will not be interpolated, this can be very useful for cut-out animation. The Constant Z feature
only works with 3Dpaths.
You can also enable the Constant Z option directly in the Function Editor or Function view for specific
functions.

Chapter 15
Animating Your Puppets

Animate provides you with some great tools to animate your puppets. You can create simple animation using the
Transform tool and you can make advanced animation using both Forward and Inverse Kinematics! Animate has
advanced onion skinning and image swapping features to help you animate efficiently and quickly. To give you
animation freedom you are able to mix several different techniques of animation such as simple rigging, hierarchy and
Symbol animation.
In this chapter, you will learn about the following:

•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Getting the Character, on page 646
Understanding Drawings and Keyframes, on page 651
Creating a Simple Cut-out Animation, on page 653
Selecting Layers to Animate or Position, on page 655
Navigating the Hierarchy, on page 658
Animating using the Transform Tool, on page 659
Animating using Inverse Kinematics, on page 661
Animating in Stop-Motion, on page 677
Animating using Computer Generated Interpolation, on page 679
Flipping Through Poses, on page 683
Using the Onion Skin in Cut-out Animation, on page 684
Flipping Parts, on page 686
Animating Using Symbols, on page 687
Reusing Extra Drawings, Poses and Facial Expressions, on page 692
Swapping Images, on page 695
Adding a New Drawing, on page 697
Ordering Layers Over Time, on page 698
Creating Cycles, on page 699
Adding Pegs, on page 701
Offsetting Part of an Animation, on page 703
Preferences, on page 704
645

Animate Pro 2 User Guide

Getting the Character
The first step in animating your character is to import a master template from the library.
This topic is divided as follows:

•
•
•
•

Importing a Character from the Library, on page 646
Importing Network Templates (PRO), on page 647,
Selecting the Pose, on page 649
Extending the Exposure, on page 650

If the template you are importing was created in the Network view, make sure to import it first and to drop it
into either the Network view or the left side of the Timeline view. If you don’t do this you may break some network
connections.

Importing a Character from the Library
To import your character from the library:
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1.
2.

Create your new Animate project.
In the Library view, select the character’s master template you want to animate.

3.

Drag the selected template to the Camera or Timeline view’s left side.

4.

In the Timeline view, drag the scene length bracket to extend or shorten your scene length.
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Importing Network Templates (PRO)
In Animate Pro you can create your character template from the Network view.
To import a Network template:
1.
2.

Create your new Animate Pro project.
In the Library view, select the character’s master template you want to animate.

3.

Drag the selected template to the Network, Camera or Timeline view’s left side.

4.

In the Network view, connect the template’s Group module to the Composite module, by clicking it’s Out Port
and dragging the connection to the Composite module until an In Port appears.

5.

In the Timeline view, extend or shorten the scene length by dragging the scene length bracket.
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Backwards Compatibility for Templates Created in 7.3 or Earlier (PRO)
By default, a Drawing layer can be animated, but Animate Pro gives you the ability to disable this feature. Being able
to switch your drawings so they can no longer be animated without a peg has certain advantages. It means that you
can have access to the drawing substitution feature for this Drawing layer, while being able to create keyframes on it’s
parent peg. This feature is also available for backward compatibility when bringing in templates created in older
versions of the software, so as not to lose their offset keyframes or drawing substitution keyframes.
When selecting the element in the Camera view, the actual Drawing layer is selected, but the motion you will create
will automatically be transposed to the Peg layer. You cannot animate (add keyframes) directly onto a drawing. You
will still be able to preform certain offset movements in the Layer Properties > Transformation tab, but not using any
of the animation tools in the Animation Tools toolbar.
To disable the Animate Using Animation Tools feature:
1.

In the Timeline view, double-click on the layer that you want to set the parameter for.
The Layer Properties editor opens.

2.

In the Advanced tab, disable the Animate Using Animation Tools option.
Notice how the availability of the layer functions disappear in the Timeline.

Layer with functions available
3.

Layer without functions

Click the Close button.

If you know that you prefer this style of animation and you would like every Drawing element that you create not
to be animated, refer to Preferences > Advanced (PRO), on page 705.
Refer to the following topics to learn more about the drawing substitution feature.

•
•
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Libraries, Symbols and Templates > Preview and Drawing Substitution, on page 379
Animating Your Puppets > Swapping Images, on page 695
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Selecting the Pose

If the template you imported contains several poses, you must choose which pose you will use to start your animation
and remove the other ones.
To select the character’s pose:
1.

In the Timeline view, collapse your character’s layers.

2.

In the Timeline view’s right side, select the keyframe corresponding to the pose you want to keep.

3.

Drag the selected keyframe to the first frame.

4.

Select all of the extra drawings and keyframes that you do not need and press the [Delete] key.
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Extending the Exposure
Once your pose is chosen, all that is left to do is to extend the exposure of your character to the end of your scene.
To extend the exposure of your character:
1.

In the Timeline view, collapse your character.

2.

In the Timeline view’s right side, select the last cell of your character.

3.

Right-click (Windows) or [Ctrl]+click (Mac OS X) on the select and select Extend Exposure. The default keyboard
shortcut is [F5]. You can also copy the first pose and paste it in the last cell.
The drawing exposure is extended to the end. You will not see any changes in your timeline while the master
peg is collapsed.
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Understanding Drawings and Keyframes
In Animate, the drawings and keyframes are separate items. You can manipulate the exposure of the drawings
independently from the position keyframes.

Keyframes and Drawing Blocks
When you extend the exposure of a drawing it is represented by a grey block in the Timeline view. When you expose
a second drawing, a second grey block is displayed.
You can consider these blocks as Drawing Blocks.

To animate the position of a block over time, you do not need to create a second block, you simply need to add a
position keyframe.
The position keyframes are coordinates indicating the position of your drawing on a particular frame. These appear
as black squares in the Timeline view.
If you refer to the example below, you can see that the keyframes are positioned on frames independently from the
beginning and end of each Drawing Block.

Kf 1

Dr 1

Kf 2

Dr 2

Kf 3

Dr 3

Dr 4

Kf 4

Dr 5

Kf 5

Dr 6

You can keyframe three different positions for your drawing in the same Drawing Block and create a motion path
between them.

Timeline Behaviour
In the Timeline view, you can see how the Timeline behaves differently depending on whether you either create a new
drawing, a new keyframe, or both at the same time.

Creating a Drawing in the Timeline view
You can use the Create Empty Drawing command to add a new drawing in the Timeline view. This will automatically
insert a new drawing block.

•

Select Drawing > Create Empty Drawing.

•

You can also use the Create Empty Drawing

button from the Timeline View toolbar.
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Creating a Keyframe in the Timeline view
You can use the Add Keyframe command to add a new keyframe in the Timeline view. This will automatically create a
keyframe in your layer.

•

Select Insert > Keyframe or use the default keyboard shortcut [Ctrl]+[F6] (Windows) or
[a]+[F6] (Mac OS X).

•

You can also use the Add Keyframe

button from the Timeline View toolbar.

Creating a Drawing and a Keyframe in the Timeline view at the same time
You can use the Insert Keyframe and Duplicate Drawing command to add a keyframe and a drawing at the same time.
This will create a drawing block containing copies of the selected drawing and a keyframe.

•
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Select Insert > Keyframe and Duplicate Drawing or use the default keyboard shortcut [F6].
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Creating a Simple Cut-out Animation

To create a simple cut-out animation, follow these steps so you can try out the animation tools you will learn in the
next topics.
By default, when you select an object in the Timeline or Camera view, the trajectory for your motion path is displayed.
If you do not want to see the trajectory by default, you can disable the Show Control Points on Selected Layers
preference.
To disable the Show Control Points on Selected Layers preference:
1.
2.
3.
4.

In the top menu, select Edit > Preferences (Windows) or Animate > Preferences (Mac OS X). The default
keyboard shortcut is [Ctrl]+[U] (Windows) or [a]+[,] (Mac OS X). The Preferences panel opens.
Go to the Camera tab in the Preferences panel.
In the Control Points section disable the Show Control Points on Selected Layers preference.
Click on the OK button.

To create a simple cut-out animation:
1.

In the Tools toolbar, select the Transform

2.

In the Transform tool Properties view, make sure that the Peg Selection Mode

3.

5.

In the Tools toolbar, enable the Animation
mode so that everything you move will be keyframed
automatically.
In the top menu, select Animation > Stop-Motion Keyframe so that the interpolation is not created
automatically between your keyframes.
In the Timeline view, collapse your character.

6.

In the Timeline view, go to the frame where you want to set your first pose.

4.

tool. The default keyboard shortcut is [Alt]+[Q].
is disabled.
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7.

In the Camera view, select the parts to animate.

8.

Using the Transform

9.

A new keyframe appears in the Timeline view.
If you want to make sure that nothing will move on your new pose, in the Timeline view, select the frame
corresponding to the pose, right-click (Windows) or [Ctrl]+click (Mac OS X) and select Insert Keyframe. The
default keyboard shortcut is [Ctrl]+[F6] (Windows) or [a]+[F6] (Mac OS X).

tool, rotate, skew, scale or translate the selection to its new position.

10. In the Tools toolbar, enable the Onion Skin
feature.
11. In the Timeline view, go to the frame where you want to set your second keyframe.

12. In the Camera view, animate your character.

13. Repeat this process until all your poses are done.
Refer to the following topics to get more information to learn about Motion Keyframes, Transform tool and learn
more about the animation basics:

•
•
•
•
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Selecting Layers to Animate or Position, on page 655
Animating using the Transform Tool, on page 659
Animating using Computer Generated Interpolation, on page 679
Using the Onion Skin in Cut-out Animation, on page 684
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Selecting Layers to Animate or Position
When you are animating characters, it is important to understand how the Animate mode allows you to create
keyframes on the current frame or to reposition the entire layer.
This topic is divided as follows:

•
•

Animate Mode, on page 655
Selecting Drawing Layers using the Transform Tool, on page 656

Animate Mode
The Animate

button, in the Tools toolbar, toggles the keyframing option on or off.

When you enable the Animate mode, as soon as your move an element in your Camera view, a keyframe is positioned
on the current frame in the Timeline view to indicate the new position.

When you disable the Animate mode, and you select and move an element, the entire animation in the layer will be
offset at once.

This means that when you are animating your character, you must enable the Animate mode.
If you are scaling down your puppet to fit the scene composition and want to resize the entire animation, you must
disable the Animate mode.
To enable and disable the Animate mode:

 In the Tools toolbar, click on the Animate

button. You can also enable and disable the Animate mode in the

top menu under Animation > Animate.

655

Animate Pro 2 User Guide

Selecting Drawing Layers using the Transform Tool
To manipulate your drawing layers in order to animate them, you must use the Transform
used to modify the drawing strokes and not the actual drawing layer.

tool. The Select tool is

When selecting your drawing layers with the Transform tool, make sure that the Peg Selection Mode option is
disabled in the Transform Tool Properties view. If this option is enabled it will limit the selection in the Camera view
to pegs only.
To select using the Transform tool:
1.

In the Tools toolbar, click on the Transform
tool. The default keyboard shortcut is [Alt]+[Q]. You can also
select the Transform tool in the top menu under Animation > Tools > Transform.

2.

In the Transform Tool Properties view, make sure that the Peg Selection Mode

3.

In the Camera view, select the element to animate.

is disabled.

Selecting an element in the Camera View using the Transform Tool
When you select an element in the Camera view using the Transform tool, make sure that the Peg Selection Mode
is disabled in the Transform Tool Properties view, the element selected is the actual drawing layer corresponding
to the selected element. If you have a peg parented to that layer, you must either use the keyboard shortcuts to go
up the hierarchy chain, select it in the Timeline view, or enable the Peg Selection Mode
Tool Properties view, this will limit the selection in the Camera view to pegs only.

option in the Transform

If the layer has child layers, they will also be highlighted.
child
selected
parent

Refer to the Navigating the Hierarchy topic to learn how to go up or down the layer hierarchy.
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Selecting a Layer in the Timeline View
When you select a layer in the Timeline view, the corresponding element will be highlighted in the Camera view. If the
selected layer has child layers, they will also be highlighted.

Selecting in the Network View (PRO)
As with the Timeline view, when you select a module in the Network view, the corresponding element will be
highlighted in the Camera view. If the selected module has child layers, they will also be highlighted.
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Navigating the Hierarchy
If you created a layer hierarchy when you built your puppet, you can use the keyboard shortcuts to travel up and down
the parent-child chain. You can also travel between the children in a layer.
To select the parent or child layer:
1.

In the Tools toolbar, select the Transform

tool.

2.
3.

In the Transform Tool Properties view, make sure that the Peg Selection Mode
In the Camera or Timeline view, select a layer attached to a hierarchy.

4.

Select Animation > Select Parent or press the keyboard shortcut [B] to select the parent layer and select
Animation > Select Child or press the keyboard shortcut [Shift]+[B] to select the child layer.

is disabled.

[B]

[B]

To select the children layers:
1.

In the Tools toolbar, select the Transform

2.

In the Camera or Timeline view, a layer attached to a parent layer with several children or not parented at all.

3.

Select Animation > Select Previous Brother or press the keyboard shortcut [/] to select the previous child layer
and select Animation Select Next Brother or press the keyboard shortcut [?] to select the next child layer. You
can also select Animation > Select Children, to select all child layers at once.

[/]

[?]
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Animating using the Transform Tool
The transform tool is the main tool you use when working with a Cut-out character. The Transform tool has many useful
functions:
Horizontal Skew

Vertical and Horizontal
Scale
Vertical Skew

Horizontal Scale

Temporary
Pivot Offset

Angle Rotation
Vertical Scale
Using the individual Rotate, Translate, Scale and Skew tools is not recommended, as they move each piece from their
own pivot point. They are compositing tools. The Transform tool will create a global selection, so when many parts
are selected, the Transform tool will move it as one. The Transform tool is highly recommended for Cut-out.
When animating with the Transform tool, make sure to select the right selection mode. In this example, make
sure that the Peg Selection Mode
the Camera view to pegs only.

is disabled in the Transform Tool Properties view or it will limit the selection in

Transform Tool
Rotate Tool
If you have hierarchy connections in your cut-out character, the Transform tool will also be used as the Forward
Kinematics equivalent.
The Transform tool can be used on any kind of rigging.
When many parts are selected with the Transform tool, the first selected part’s pivot will be used as the global
selection’s pivot. This pivot can be moved temporarily for the animation. When you offset the pivot, the permanent
pivot is displayed as a ghost.
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NOTE:
The interpolation of your animation poses is always calculated from the permanent pivot.
To use the Transform tool:
1.

In the Tools toolbar, click on the Transform

tool. The default keyboard shortcut is [Alt]+[Q].

2.

In the Transform Tool Properties view, make sure that the Peg Selection Mode

3.

In the Camera view, select the element to animate and move it.

4.

In the Timeline view, go to the frame where you want to set your next position.

5.

In the Camera view, animate the character.

is disabled.

Refer to Setting Up the Scene > Positioning an Element using the Transform Tool, on page 487 to learn more
about the Transform tool.
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Animating using Inverse Kinematics

The Inverse Kinematics tool (IK) allows you to pull on your character’s extremities, such as the hands and feet, and
have the rest of the body follow.
The Inverse Kinematics tool will animate from an extremity and make the rest of the hierarchy follow (called the IK
chain). It can be used on any piece connected in a hierarchy. However, you do not have to use IK every time that you
have a hierarchy rig. This tool is useful when you want to bend a character’s knees, make him sit and move the rest of
the body, etc.
Inverse Kinematics helps a new animator to understand how a puppet should move. It will also help any animator
create difficult moves easily. Inverse Kinematics will not work on basic rigs without hierarchy because there is no
hierarchy chain present. IK only works on hierarchy parenting when the pivots are properly set.
When animating a hierarchy puppet, an animator will use the Transform and Inverse Kinematics tools.
This topic is divided as follows:

•
•
•
•
•
•
•

Where to Start with Inverse Kinematics?, on page 662
Inverse Kinematics Tool Properties, on page 663
Setting up the Character to use IK, on page 667
Nails, on page 669
Minimum and Maximum Angle (PRO), on page 671
IK Keyframes, on page 673
When to use the Inverse Kinematics Tool, on page 675
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Where to Start with Inverse Kinematics?
This section explains the basics of the Inverse Kinematics tool. IK works best when you lock a part of the character to
the spot, such as a foot on the floor, then select the entire body or another extremity and move it.
To lock a part in place, you use the IK Nail option.
To use the Inverse Kinematics tool:
1.

In the Tools toolbar, select the Inverse Kinematics

tool. The default keyboard shortcut is [Alt]+[8].

2.

In the Camera view, hold down the [Ctrl] key (Windows) or [a] key (Mac OS X) and click on a part of the body.
The entire IK skeleton appears.

3.

Click on a part of the body and pull on it to move the character.

4.

Hold down the [Shift] key and click on the pivot belonging to the part you want to lock in place.

[Shift]+Click

5.
662

Click on another part of the character and pull on it.
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Inverse Kinematics Tool Properties

IK Modes
The IK tool has six different modes:

•

Bone Selection Mode

•

Simple Chain Mode

•

IK Manipulation Mode

•

Apply IK Constraints Mode

•

Edit Min/Max Angle Mode (PRO)

•

Bone Editing Mode

Bone Selection Mode
The Bone Selection mode is enabled by default. This option allows you to click on any bone in your character and
move it without having to select the actual layer.
Once you disable this option, you can not move any bone except the selected one. This allows you to grab and rotate
the selected part from many angles and location. You can click completely outside the character and move the pieces.

Simple Chain Mode
The Chain Type mode allows you to select from one of three chain types:

•
•
•

Simple chain mode: this is the default mode and will only allow for the movement of parts attached to
single chain up to the point of intersection.
Direct chain mode: this mode will allow the movement of parts up a simple secondary chain to a principle
chain as long as translational movement is possible (the principle chain is attached to its own peg), but will
ignore all secondary chains.
All chain mode: this mode allows for the movement of all parts attached to all chains in the IK skeleton.

IK Manipulation Mode
The IK Manipulation mode is the main working mode for the Inverse Kinematics tool. Enable this mode when you want
to animate and position your puppet.
Hold down the [Ctrl] key (Windows) or [a] key (Mac OS X) and click on a body part to select it. You do not need to
select a part to be able to move it.
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Apply IK Constraints Mode
The Apply IK Constraints mode is used to correct a part’s position on a series of frames. For example, if the character’s
foot seems to be sinking into the floor, you can correct its position and angle over a series of frames using the IK
Constrains mode.
Refer to Nails, on page 669 to learn how to use this mode.

Edit Min/Max Angle Mode (PRO)
The Edit Min/Max Angle mode is used to set a rotation restriction on some of your parts, such as elbows, knees and
ankles.
Refer to Minimum and Maximum Angle (PRO), on page 671 to learn how to use this mode.

Bone Editing Mode
The Bone Editing mode is used to fix the bone orientation on extremities such as hands and feet.
Refer to Setting Up the Bones for the Extremities, on page 669 to learn how to use this mode.

IK Tool Options
The IK tool has two special options:

•
•

IK Keyframe
Ease Shape

IK Keyframe
The IK keyframe option is used in combination with the IK Constraints mode. It determines the starting frame of the
constraint you will apply.
Refer to Nails, on page 669 to learn how to use this option.

Ease Shape

While you animate with the IK tool, prior to doing a movement you can set an easing preset so that your motion is
not so mechanical.
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Before moving your part, select a preset from the list in the drop-down menu.

If you select a new preset in the list and move the part again on the same keyframe, the easing will be automatically
updated.

Selection
With the IK tool, you are able to do the following:

•

Enable Translation If Top of Hierarchy

•

Enable Rotation

•
•
•

Exclude From IK
IK Nails
Stiffness

Enable Translation If Top of Hierarchy

This option is mainly used on master pegs. Since IK is all about rotation, when you pull on a foot to get the character
to do a perfect split, at some point, the hip will need to translate and not just rotate on the spot. In this case, you
would select the hip layer and enable the translation option.
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Enable Rotation

The Enable Rotation option is enabled by default. If you disable this option, the selected part will not be able to rotate
anymore and will remain in the same position all the time. You can use this option to simulate an arm in a plaster cast.
When you enable this option, the pivot will disappear but you will still see the bone.

Exclude From IK
You can use the Exclude From IK option when you want certain parts of your puppet such as the eyes and mouth to
be excluded from the IK influence.
Refer to Excluding Extra Elements from IK, on page 668 to learn how to use this option.

IK Nails

The IK nails are used to temporarily fix a part of a character to a spot either in translation or rotation, or to enable
maximum and minimum angle usage.
Refer to Nails, on page 669 to learn how to use this option.

Stiffness
When a certain part is selected, you can apply a stiffness value to it. A different stiffness value can be set to each body
part individually. The greater the Stiffness value applied, the more difficult it is to make that part rotate, thereby
rendering it stiff while the other parts continue to move freely on their joints.
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Setting up the Character to use IK
The first time you display the character’s skeleton, you will notice a series of bones on the extremities which are out
of place, and there may also be some elements that you would like to exclude from the Inverse Kinematics chain.

You should setup the skeleton before starting your animation. There are three things to do to setup the character:

•
•
•

Connecting any Hierarchy Chain, on page 667
Excluding Extra Elements from IK, on page 668
Setting Up the Bones for the Extremities, on page 669

Connecting any Hierarchy Chain
Before fixing any bones, or excluding layers from the IK, it is important that you make sure all the elements you want
to be parented in a chain are setup.
You do not need to have a chain all over the body. It can be on the legs and arms. If the body is not completely rigged
in hierarchy, the skeleton will look a bit more messy, but the IK tool will still work without any problem.
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Excluding Extra Elements from IK

When working with the IK tool, you will probably want to move the main parts around, but not necessarily the small
ones such as the nose or ears. In this case, you can select some elements on your character and exclude them from
the skeleton.
To exclude elements from the skeleton:
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1.

In the Tools toolbar, select the Inverse Kinematics

tool. The default keyboard shortcut is [Alt]+[8].

2.

In the Tool Properties view, make sure the IK Manipulation Mode

3.

In the Camera view, hold down the [Ctrl] key (Windows) or [a] key (Mac OS X) and click on the part to exclude
from the IK.

4.

In the Tool Properties view, click on the Exclude from IK

5.

Repeat the process for every part to be excluded from the IK.

button.

is enabled.
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Setting Up the Bones for the Extremities
Once you remove the extra elements from your skeleton, you will want to set the bone orientation for the extremity
parts. By default they are oriented horizontally towards the right. This orientation often works for the feet but not
necessarily for the hair or hands,
To set the bone orientation:
1.

In the Tools toolbar, select the Inverse Kinematics

tool. The default keyboard shortcut is [Alt]+[8].

2.

In the Tool Properties view, enable the Bone Editing

3.

In the Camera view, click on the pivot belonging to the part you whose bone you want to reposition, then pull
the pivot in the direction you want the bone to be.

4.

Repeat this process for each bone you want to position. NOTE: this command will only work on the extremities.

mode.

Nails
Using the Inverse Kinematics tool, if you pull a hand the system will animate all of the parts included in the hierarchy
chain, the torso, the hips and the legs, depending on your rig. Often, you will only want to animate a character’s part,
such as the arm and not the whole body. To do so, there are IK constraints such as IK nails that are used to temporarily
cut or constrain the chain. IK nails can be used to cut an IK chain or to block a part on the spot. For example, you can
fix a character’s feet to the ground when he walks.
There are different types of constraints that can be placed on the chain:

•

Nail
Blocks the X, Y and Z positions.

•

Hold Orientation
Blocks the angle

•

Hold X
Blocks only the X position

•

Hold Y
Blocks only the Y position

•

Enable Maximum and Minimum angle (PRO)
Sets limitations on the angle parameter to prevent the puppet from bending too far.
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To set an IK nail:
1.

In the Tools toolbar, select the Inverse Kinematics

2.

In the Tool Properties view, make sure the IK Manipulation Mode

3.

In the Camera view, hold down the [Ctrl] key (Windows) or [a] key (Mac OS X) and click on the part to set a nail
on.
In the Tool Properties view, click on the type of nail you will use.

4.
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is enabled.

You can also hold down the [Shift] key and click on any part’s pivot to set a regular nail on it without having
to select it.
You can hold down the [Shift] key and click on the bone to set a Hold Orientation nail.
You can select the nail type in the top menu by selecting
Animation > IK Constraints > the desired nail.

You can remove the nail at anytime using the same technique you did to place the nail. It will not affect the
animation.
To remove every nail except the Enable Min/Max Angle ones, in the top menu select Animation > IK
Constraints > Remove All Constraints.


5.

tool. The default keyboard shortcut is [Alt]+[8].
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Minimum and Maximum Angle (PRO)

Animate Pro allows you to set a minimum and maximum angle constraint on certain joints such as the knees or elbows.
When using the Inverse Kinematics tool or even the Forward Kinematics (Transform Tool), it is possible that some joints
will bend in the wrong direction.
It is recommended to use the minimum and maximum angles only if the character does not change view. For
example, if a character is facing the camera and has some angle limitations enabled, it could be problematic if the
character switches to side or quarter view since the joints won’t bend the same way.
You can use the minimum and maximum angle constraints if your character’s views are in different templates or layers.
If the character’s views are in the same layers, you are better off not using the angle constraints.
If you plan to animate a lot with the Inverse Kinematics tool, it is a good idea to try the angle constraints. It depends
on your taste. The angle constraints can be set by the character builder or by the animator in some particular scenes
where it is needed.
To set the minimum and maximum angles:
1.

In the Tools toolbar, select the Inverse Kinematics

tool. The default keyboard shortcut is [Alt]+[8].

2.

In the Tool Properties view, in the Mode section, make sure the Edit Min/Max Angle Mode

3.

In the Camera view, hold down the [Ctrl] key (Windows) or [a] key (Mac OS X) and click on the piece to set the
minimum and maximum angle for.

4.

In the Tool Properties view, in the Selection section, click on the Enable Min/Max Angle

is enabled.

option.
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5.

In the Camera view, rotate the Minimum and Maximum handles to set the angle.
Minimum Angle Handle
If the Minimum or Maximum Angle
handles meet the same angle value, they
will start rotating together.
NOTE: The minimum value does not get
bigger than the maximum value and the
maximum value does not get smaller
than the minimum value

Maximum Angle Handle
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6.

Test your angles using the IK Manipulation Mode

.

7.

For additional control over your Min/Max Angle go to Edit > Preferences > Camera > Inverse Kinematics
(Windows) or Animate Pro > Preferences > Camera > Inverse Kinematics (Mac OS X) and take a look at the
Min/Max Angle Constraint Weight. Although the maximum value goes up to 1.0, in a production setting, the
most practical value would be closer to 0.1. This value acts similar to the Stiffness setting in the Inverse
Kinematics Properties panel. The greater the value, the more difficult it becomes to approach the minimum and
maximum values.
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IK Keyframes

When you animate a walking character and lock the feet down, the locked position will be perfect on the key poses.
However, when you use the Motion keyframes to auto in-between the animation, you will notice a movement of feet.
This motion is caused by the in-betweening of the rotations.
The nail holds in place the body part on the keyframe, but it will not hold it for the whole duration between keyframes.
If you place a nail on the shoulder to move just the arm, you do not necessarily want to keep the shoulder in the same
place until the next key pose. You will probably want the shoulder, or any other part that is nailed, to have a slight,
natural motion following the main body action. Of course, this is not the case when you fix a hand or a foot on the
spot. If you have a fixed hand or foot, you will probably want it to stay exactly where you placed it. That is why you
can apply an IK constraint on a frame range and on selected body parts.
To fix the part on the same spot requires an angle (rotation) correction on the parts that are moving too much. For
example, to fix a foot that is moving too much, you will correct the angles on the foot, leg and thigh. To fix a hand,
you will correct the angles on the hand, forearm and upper arm.
To apply IK constraints on a frame range:
1.

In the Tools toolbar, select the Inverse Kinematics

tool. The default keyboard shortcut is [Alt]+[8].

2.
3.

In the Camera view, click on the part you want to apply the constraint to.
In the Timeline View, set the cursor to the first frame where you want to start applying the constraint.

4.

In the Tool Properties view, enable the Apply IK Constraints mode

5.

In the Tool Properties view, click on the IK Keyframe

6.

In the Timeline view, move the playhead to the last frame where you want to apply the constraint.

.

button to enter the first frame number.

The IK Keyframe field should now look like this:
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7.

In the Camera view, set a nail at the top of the limb you are correcting. In the case of a foot, set the nail on the
thigh by holding down the [Shift] key and clicking in its pivot.

8.

In the Tool Properties, select the type of constraint you want to apply to your piece.The most common case is a
combination of the regular nail

9.

and Hold Orientation

.

In the Camera View, click on the bone of the part you want to apply a constraint to.
A warning message appears and requesting you to confirm that you want to add your constraint on that
particular piece and for that frame duration.

10. Click on the OK button.
Your constraint should now be applied.
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When to use the Inverse Kinematics Tool
This summarizes what you have read so far.
Animate provides different tools with which to animate cut-out characters and trajectories. The two main tools used
to animate characters are the Transform and the Inverse Kinematics tools.
Here, we will compare the usage of these tools and explain the Inverse Kinematics philosophy.

•

•

The Transform Tool
The Transform tool is also known as Forward Kinematics. This is the main tool to use for cut-out animation.
The Transform tool rotates, scales, moves and skews all the elements selected as one global element.
Forward Kinematics means that the element will be animated from the parent element down to the last
child as a single piece. In other words, if the shoulder is animated, the arm, forearm and hand will follow as
a complete arm drawing.
The Inverse Kinematics Tool
The Inverse Kinematics tool (IK) is an assistance tool. This tool will help you to achieve complex motions
such as sitting down or knee bending. The Inverse Kinematics tool will move and rotate every selected
element as a chain.
Inverse Kinematics means that the element will be animated from the child element up to the parent
element. In other words, if the hand is animated, the forearm, arm and shoulder will follow the hand in a
fairly natural way in terms of the movement, rotation and bending.

Inverse Kinematics in Toon Boom Animate
In most 3D animation software, Inverse Kinematics is implemented as a skeleton system. Animate uses the rigging
hierarchy already created in the Timeline view, so there is no need to place bones in the character. Inverse Kinematics
in Animate uses the connection between each of the parts’ pivots.

IK Tool and Rigging
The IK tool can not be used on every type of cut-out character. It depends on the way the pieces and parts are
attached to one another. In other words, it depends on the rigging type.
There are several ways to rig a puppet. These are the three main rigging techniques:

•

•

•

The Basic Rig technique is the simplest.
D There are no connections between the parts.
D They are free to move, rotate and scale independently one from the other.
D The Inverse Kinematics tool cannot be used on this type of rigging.
The Hierarchy Rig technique is the most complex.
D All the parts are connected one to the other.
D As they move, rotate and scale, they will influence all the other parts.
D The Inverse Kinematics tool can be used on this type of rigging.
The Mix Rig technique is the best of the Basic and Hierarchy rig.
D Some parts are independent such as the torso.
D Some parts are setup into a hierarchy such as the arms and legs
D The Inverse Kinematics tool can be used on this type of rigging.

Animating with the Tools
Puppets are animated by using a combination of Transform and Inverse Kinematics tools.
You will mainly use the Transform tool (Forward Kinematics) as it has all the main motions; rotate, scale, skew, move
and select. You can also control the exact position of the parts while using the Transform tool. As well, the Transform
tool creates a temporary global pivot on the selection that can be moved around for the animation purpose.
To complete complex motions, such as bending the knees while keeping the feet on the ground, you will use Inverse
Kinematics tool as an assistance tool. By adding IK Constraints (Nails), it is possible to lock the feet or any other parts
on the spot and move the rest of the body, which will react to the constraints.
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The Inverse Kinematics Philosophy
It is important to keep in mind that the Inverse Kinematics tool is an assistance tool. You won’t use it to animate all
the time.
Also, the Inverse Kinematics tool can be used to do the character’s posing faster. Posing is a crucial part in the
animation process. The IK tool can be used to pose the character more naturally, depending on your own preferences.
An IK Nail can be added anywhere on the character to animate only a small part of the hierarchy chain, such as an arm
or a portion or the arm.

Tips and Tricks for Inverse Kinematics
Here are some tips and tricks to help you to use the Inverse Kinematics tool.

•

•

•

676

IK on Mix Rigging
The Inverse Kinematics tool can be used on a full puppet’s body even if it is connected as a mix rigging,
meaning some parts are rigged in a hierarchy and others not. For example, you can add IK Nails on the
puppet’s feet, select the full body master peg and move the character as if it was connected in a full
hierarchy rig. This technique works on most of the mix rigging.
IK Constraints
It is important to remember that you can add and remove IK Constraints (Nails, Hold Orientation, etc.) at
anytime during the animation. They hold a certain part on the spot while you animate the rest of the body.
Because they are not constricting one part to another object, you can add or remove them without affecting
any of the animation you have already done.
Useful Shortcuts
D While using the IK tool, you can hold down the [Ctrl] key to select any part.
D You can hold down the [Alt] key to rotate the selected part without affecting the IK chain.
D You can press the [Shift] key and click in a part’s pivot to add or remove an IK Nail.
D You can press the [Shift] key and click on a bone to add or remove and Hold Orientation constraint.

Chapter 15: Animating Your Puppets Animating using Inverse Kinematics

Animating in Stop-Motion
To start animating your character, start by doing your key poses. In fact, most of your time will be spent doing your
key poses. It is better to work with Stop-Motion keyframes as Animate will not automatically create the interpolation
between your keyframes.
When using Stop-Motion keyframes, also known as Step keyframes, the segment between two keyframes is constant.
There is no animation generated by the computer between the poses. The drawing will remain in position until the
next keyframe, then pops to its new position.

Constant Segment
Keyframe
Pops to next
position

Keyframe

Creating a Stop-Motion Keyframe
You can create a Stop-Motion keyframe in several different ways. You can have Animate create it automatically,
transform a Motion keyframe into a Stop-Motion keyframe, or even switch your preferences to get Animate to always
create Stop-Motion keyframes by default.
To automatically create Stop-Motion keyframes:
1.
2.

In the top menu, make sure that the Animation > Stop-Motion Keyframe option is disabled.
In the Timeline view, select the cell where you want to add a keyframe.

3.

Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Add Keyframe. The default
keyboard shortcut is [Ctrl]+[F6] (Windows) or [a]+[F6] (Mac OS X). You can also click on the
button available in the Timeline View toolbar.
Add Keyframe
In the Camera view, if the Animate mode is enabled, as soon as you move the selected element, a keyframe
is automatically created on the current frame.
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To convert a Motion keyframe into a Stop-Motion keyframe:
1.

In the Timeline view, select the Motion keyframes to convert into Stop-Motion keyframes. The default keyboard
shortcut is [S].

2.

Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Set Stop-Motion Keyframes. The
default keyboard shortcut is [Ctrl]+[L] (Windows) or [a]+[L] (Mac OS X). You can also click on the StopMotion Keyframe

button available in the Timeline View toolbar.

Refer to Creating Animation Paths > Stop-Motion and Motion Keyframes, on page 596 to learn more about
Stop-Motion Keyframes.
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Animating using Computer Generated Interpolation
After you have created the key poses you can animate the in-between poses yourself or let Animate do it using Motion
keyframes. When you use Motion keyframes, your drawings will gradually move to the next position instead of staying
on the spot until the next keyframe.

Keyframe
Gradually moves to
the next position

Keyframe

Keyframe

Creating a Motion Keyframe
You can create a Motion keyframe in several different ways. You can have Animate create it automatically, transform
a Stop-Motion keyframe into a Motion keyframe and even switch your preferences to get Animate to always create
Motion keyframes by default.
To automatically create Stop-Motion keyframes:
1.
2.

In the top menu, make sure that the Animation > Stop-Motion Keyframe option is disabled.
In the Timeline view, select the cell where you want to add a keyframe.

3.

Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Add Keyframe. The default
keyboard shortcut is [Ctrl]+[F6] (Windows) or [a]+[F6] (Mac OS X). You can also click on the
Add Keyframe



button available in the Timeline View toolbar.

In the Camera view, if the Animate mode is enabled, as soon as you move the selected element, a keyframe
will be automatically created on the current frame.

To convert a Stop-Motion keyframe into a Motion keyframe:
1.

In the Timeline view, select the Stop-Motion keyframes to convert into Motion keyframes.

2.

Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Set Motion Keyframes. The default
keyboard shortcut is [Ctrl]+[K] (Windows) or [a]+[K] (Mac OS X). You can also click on the
Motion Keyframe

button available in the Timeline View toolbar.

Refer to Creating Animation Paths > Stop-Motion and Motion Keyframes, on page 596 to learn more about
Motion Keyframes.
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Adjusting the Velocity

To add ease in and ease out on your motion paths, you can display the function curve and modify the Bezier or Ease
curve. To apply an ease to multiple functions and keyframes, you can use the Set Ease for Multiple Parameters feature
and set the amount desired.
The Velocity, or ease, is used on motion keyframes. The Velocity has to be adjusted directly on the function curve in
either the Function view or the Function editor. When a keyframe is selected, easing values appear in the right handle
and left handle fields, as well as Bezier handle or Ease wheel controls on each selected keyframe. Pull on them to
adjust the ease in and ease out, or type values in the fields.

Adjusting the Velocity in the Function View
To adjust the velocity in the Function view:
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1.

In the Timeline View, click on the Expand Function

2.

Double-click on the desired function.

button to display all of the layer’s functions.
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The Function Editor opens.

NOTE that the Function Editor will not be displayed if the function does not already exist.
3.

Select a keyframe and pull on its Bezier handles or Ease wheel to adjust the velocity.

Adjusting the Velocity on Multiple Elements Concurrently
If you have several functions you would like to adjust the velocity for at the same time, such as the hand, forearm
and arm of a cut-out character, you can use the Set Ease for Multiple Parameters dialog box. It allows you to
apply the same velocity parameters to all the selected keyframes in one frame.
To set eases on multiple parameters:
1.

In the Timeline View, select a keyframe from one or many layers.

NOTE: only the first keyframe selected on a given layer will be considered when using the Set Ease For Multiple
Parameter function. If many keyframes are selected on the same layer, the ease values will be applied only to the first
one and the rest will be ignored.
1.

In the Timeline view, right-click (Windows) or [Ctrl]+click (Mac OS X) and select Set Ease For Multiple
Parameters. In the Timeline View toolbar, you can click on the Set Ease For Multiple Parameters
button. If
the button is not in the Timeline View menu by default, you can add it through the Toolbar Manager.
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The Set Ease For Multiple Parameters dialog box opens.

4
3

5
6
2.

3.

In the graph interface, pull on the Bezier handle to adjust the velocity for all the selected functions.

If you want to apply these easing parameters to a certain type of function only, such as Rotation or Scale, in the
Filters section, disable the function types you do not want to affect.
 Motion: If this option is enabled, the easing parameters will be applied to the selected Position X, Position
Y, Position Z and 3D Path functions
 Rotation: If this option is enabled, the easing parameters will be applied to the selected Angle functions.
 Scale: If this option is enabled, the easing parameters will be applied to the selected Scale functions.
 Skew: If this option is enabled, the easing parameters will be applied to the selected Skew functions.
 Morphing: If this option is enabled, the easing parameters will be applied to the selected Morphing
Velocity functions. Note that it applied to the Morphing velocity function found in the Layer Properties
dialog and not to the basic Morphing ease in the Tool Properties view.
 Other: If this option is enabled, the easing parameters will be applied to all the other selected functions
such as all functions created to animate effect parameters.
4. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values are
calculated in percentage.
 In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding to the length of
time you want the easing to last for. The value must be between 0% and 100%.
 In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong you want the
easing out to be. The value must be between 0% and 100%.
 If your Time Ratio and Value Ratio values are equal, you will have a linear motion.
5. Once done, click on one of the following button:
 Apply: This will apply the easing parameters to the selected keyframes.
 Apply/Previous: This will apply the easing parameters to the selected keyframes and then selects the
previous keyframe in the timeline.
 Apply/Next: This will apply the easing parameters to the selected keyframes and then selects the next
keyframe in the timeline.
 Close: This closes the dialog box. If you did not apply the modifications, they will be cancelled.
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Flipping Through Poses

When animating, it is useful to flip through your poses to see the flow of your animation without going through each
frame in your Timeline. Animate lets you flip between the selected element’s keyframes.
To flip through your poses:
1.

In the Camera or Timeline view, select the layer you want to see the poses for.

2.

In the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe. The default keyboard
shortcuts are; [‘] Go to Previous Keyframe and [;] Go to Next Keyframe.
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Using the Onion Skin in Cut-out Animation

When animating cut-out characters, it is useful to see the previous and next frames on the animation. However, it can
sometimes be confusing to see the onion skin for every part of the character.You will often only want to see the onion
skin on a single part or a few parts, such as the arm, that are currently being animated. Animate offers that possibility.
While animating in the Camera View, there are four different onion skin options:

•
•
•
•
•

Add to Onion Skin, on page 684
Remove from Onion Skin, on page 685
Remove Unselected from Onion Skin, on page 685
Add All to Onion Skin, on page 685
Remove All from Onion Skin, on page 685

You can enable these options in the menu or manually in the Timeline view using the layer’s Show Onion Skin
button. Unless you change the onion skin options when you display the onion skin, only the selected layers will be
displayed in the onion skin preview.
To use the onion skin options:
1.

In the Tools toolbar, enable the Onion Skin
(Windows) or [a]+[Alt]+[O] (Mac OS X)

option. The default keyboard shortcut is [Ctrl]+[Alt]+[O]

2.

In the Tools toolbar, click on the Transform

tool. The default keyboard shortcut is [Alt]+[Q].

3.

In the Camera View, select one or many elements.

4.

In the top menu, select View > Onion Skin > Add to Onion Skin, Remove From Onion Skin, Remove
Unselected from Onion Skin, Add All to Onion Skin or Remove All from Onion Skin.

Add to Onion Skin

The Add to Onion Skin command is used to add a series of selected elements to the onion skin preview. The default
keyboard shortcut is [Shift]+[S].
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Remove from Onion Skin

The Remove From Onion Skin command is used to remove a series of selected elements from the onion skin preview.

Remove Unselected from Onion Skin

The Remove Unselected from Onion Skin command is used to remove all elements except the ones selected from the
onion skin preview.

Add All to Onion Skin

The Add All to Onion Skin command is used to add all of the scene’s elements to the onion skin preview. The default
keyboard shortcut is [Alt]+[Shift]+[O].

Remove All from Onion Skin

The Remove All Onion Skin command is used to remove all of the scene’s elements from the onion skin preview. The
default keyboard shortcut is [Ctrl]+[Shift]+[O] (Windows) or [a]+[Shift]+[O] (Mac OS X).
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Flipping Parts

If you want to flip a part, a limb or a whole puppet, use the Transform tool and the Flip Horizontal and Flip Vertical
options.
To flip a selection
1.

In the Animation Tools toolbar, select the Transform

2.
3.

In the Transform Tool Properties view, make sure that the Peg Selection Mode
In the Camera View, select the parts to be flipped.

4.

tool. The default keyboard shortcut is [Alt]+[Q].

In the Transform’s Tool Properties view, click on the Flip Horizontal

is disabled.

or Flip Vertical

option. The default

keyboard shortcuts are [4] and [5] respectively.

If the scaling parameter is not set to Separate Scale, the flip is not applied to the selection.
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Animating Using Symbols

You can use Symbols to animate your puppet. Symbols are boxes in which you can place whatever you feel like. You
can use the Symbols to create reusable animations such as blinking.
A Symbol combines animation, artwork or layers into a single object that you can control in one layer. You can also
create Symbols out of each body part in your cut-out puppets.
To do so, you can either duplicate an existing Symbol or create a new blank one in the Library. You can then drop the
Symbol anywhere in your animation.

Creating a Blink Symbol
You can make an eye blink by creating a blink Symbol. Here is an example of a blinking animation created in a blink
Symbol.
To create a blink Symbol:
1.

In the Library view’s right side, right-click (Windows) or [Ctrl]+click (Mac OS X) and select New Symbol.

The new Symbol appears in the Symbol library. Rename it Blink.
2.

Animate then automatically enters the Symbol so you can edit it.
From the Library view, drag the eyes, pupils and eyebrows Symbols or templates to the Timeline view’s left side.
If you do not already have your eyes, pupils and eyebrows in your library, you should create either Symbols or
templates out of them.
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3.

In the Timeline and Camera view, animate the blink.

4.

If you enter the eyelid or eye Symbol to add more drawings, they will be added into each instance of that
Symbol. If you modify the exposure of the eye Symbol within the Blink Symbol, it will not be modified in the
other instances.
In the top menu, select File > Save.

5.

In the Camera view’s top area, click on the Top

6.

In the Tools toolbar, select the Transform

7.

In the Transform Tool Properties view, make sure that the Peg Selection Mode

8.

If your Head is a Symbol containing all the facial feature Symbols in the Camera view, double-click on the Head’s
Symbol to edit it.



button to go back to the scene’s timeline.

tool. The default keyboard shortcut is [Alt]+[Q].
option is disabled.

9.

From the Library view, drag the new Blink Symbol and drop it into one of the eye feature layers. Before dropping
the Symbol in the Timeline, hold down the [Alt] key (Windows) or [a] key (Mac OS X).
10. Drop it into a series of blank frames. Do not drop it where there already is an exposure.

The Paste Special dialog box opens.

11. In the Paste Special dialog box, enable the Paste All Frames of the Symbol (full movie) option.
12. Click on the OK button.
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13. In the Timeline view, expose the other facial features and head drawings.

14. If you are editing the Head Symbol and not dropping the new Symbol into the main timeline, click the Top
button to go back to the root timeline.
15. To expose the blink frames you just inserted inside the Head Symbol, in the Timeline view, select the Head
layer’s cell range where you want to expose the blink.

16. In the Top menu, select Animation > Cell > Sequence Fill. The default keyboard shortcut is [Ctrl]+[M]
(Windows) or [a]+[M] (Mac OS X).
The Sequence Fill dialog box opens.

17. In the Starting Value field, type the fist frame number where you exposed your blink inside the Head Symbol.
18. In the Hold field and Increment field, type “1”.
19. If necessary, type the frame number on which your want the system to stop exposing the Symbol.
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20. Click on the OK button.

You can create walk cycle animation Symbols or Head turn animation Symbols and drop them directly into your main
timeline in any drawing layer.

Importing a Template with Symbols
Sometimes a character’s rig is not a cut and dry matter. Rigs, which are usually saved as templates, can contain
Symbols, such as a leg that was made with a patch. However, a Symbol does not work in the same way as an Action
template. When dropped into the right side of the Timeline layer, into a Symbol of the exact same structure, instead
of adding itself to the previous Symbol, the new Symbol becomes a copy.
To take more control of how the Action template will behave when brought into the Timeline, bring it in using a Paste
Special.
To import a template with Symbols:
1.
2.

3.

Select the Action template containing Symbols from the right side of the Library.
As you drag it from the Library to the right side of the Timeline to drop it next to a template with the exact same
rig, hold down the [Alt] button (Windows) or the [Ctrl] button (Mac OS X).
The Paste Special window appears.
Select one of the following options from the Symbols drop-down menu:
 In Animate, the Symbols drop-down menu is found under the Advanced tab.

Animate
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Copy symbols if they do not exist: This is the default setting for this operation and will prevent symbols in
a Action template from being copied.
Duplicate symbols: Select this option if you wish to make copies of the Symbols in your template.
Overwrite symbols: If for some reason, a modification was made to a Symbol in the Action template that
does not exist in the basic rig template for a character, select this option to overwrite the previous symbol.
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Duplicating a Symbol
You must duplicate a Symbol if you want to modify a copy of it without altering the original Symbol and the other
copies.
To duplicate a Symbol:
1.
2.

In the Timeline view, go to the frame where you want to duplicate the Symbol.
Select the Symbol’s cell.

3.

In the top menu, select Edit > Duplicate Selected Symbol.
In the Library view, the Symbol is duplicated and in the Timeline view, the current cell is replaced with the new
Symbol. You can now modify the Symbol’s content.

Symbols nested inside another symbol are not duplicated. If you modify them the original and other instances
will also be modified.
If you created an animation inside the duplicated Symbol, you can expose it using the Fill Sequence command as
shown previously in the new Symbol creation process.
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Reusing Extra Drawings, Poses and Facial Expressions

Reusing animation and assets is an important aspect of cut-out animation. This is why Animate offers a library to store
all of the reusable information. At some point, you will not want to animate the same action twice, such as a walk-cycle
or jump. You can store the initial animation in the Library view, then select and drag it into a new scene as needed.
Refer to Libraries, Symbols and Templates > Templates, on page 392 to learn more about creating and importing
templates.
You can import a master template into his Timeline view and start animating with it, then later on decide to import an
action template. You can import the template into the Timeline view’s right window where all the keyframes are
located.
To insert a template into another one, the layer ordering has to be the same. If it is inconsistent, the system will
indicate that the templates cannot be combined. In that case, you could bring the action to the Timeline’s left window
to create a new set of layers or convert it into a Symbol and drop it into any layer.

You can create a single keyframe action template of the different angles (front, three-quarter or side view). Then
import and insert those action templates into the animation to turn the character will turn. The same pattern can be
created for a head, arm, full upper body, etc.
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If the master template you are importing was created in the Network view, make sure to import it first and to
drop it into either the Network view or the left side of the Timeline view. If you don’t do this you may break some
network connections.
Refer to Importing Network Templates (PRO) section to learn how to import your templates created in the
Network view without breaking the network connections.

If you created templates for different body parts you can reuse them in your scene by dragging them in your layers.
You can also open a template as a folder and select a particular drawing from it and drag it in your drawing layer.
If your layers are Symbols, you will need to drag the templates inside the Symbols. When you import extra
drawings, such as different hand and mouth positions, use the pivot that was set on your drawings and copy them to
the Symbol’s cells. You can do this by using the Copy Pivot to Parent Symbol command.
When you copy your pivots to the parent Symbol, there is no link between the drawings’ pivots and the Symbol’s. It
is simply a copying operation. If you modify the drawing pivot later, it will not be copied to the Symbol. You would
need to perform the operation again. If you need to modify the Symbol’s pivots, do it directly on the Symbol’s cells.
To import extra drawings and insert them into Symbols:
1.

In the Camera or Timeline view, double-click on the Symbol you want to add new drawings in.

2.

In the Symbol’s timeline, extend the length if necessary.

3.

In the Library view, browse to the template containing the new drawings to import in your Symbol.

4.

From the Library view, drag the select template and drop it into the Timeline view’s right side into the
corresponding layer.
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5.

In the Tools toolbar, select the Pivot

6.

In the Timeline view, select the new drawings you just imported.

7.

In the Tool Properties view, click on the Copy Pivot to Parent Symbol



tool.

If the pivots were not set on your drawings, use the Pivot

button.

tool to set them before performing the copy

operation.
Refer to the following topics in the Libraries, Symbols and Templates chapter to learn more about importing
templates and opening templates as folders:

•
•
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Importing a Template, on page 395
Opening a Template as a Folder, on page 398
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Swapping Images

Cut-out animation is not only about moving parts around, it’s also about swapping drawings to give the animation a
more traditional animation look.
You can add as many new drawings as you want in your character parts Symbols and use them in your current
animation. You can also add new drawings directly in your scene or import them from the library.
You do not need to remember the frame on which you drew or imported the drawings as you will be able to see them
in the Drawing Substitution’s interface.
You cannot swap a Symbol for another one, only the Symbol’s frames or layer’s drawings.
You can swap images in the Timeline or Library view. When you use the Drawing Substitution window in the Library
view, you are not selecting drawings from the Library but from drawings contained in your scene’s layers.
To swap images in the Library view:
1.

In the Camera view, with the Transform

tool.

2.

In the Transform Tool Properties view, make sure that the Peg Selection Mode

3.

In the Camera view, select the part you want to swap using the Transform

4.

In the Library view, go to the Drawing Substitution panel.

option is disabled.
tool.
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5.

Move the substitution slider to the right or left to scroll through the Symbol’s frames or drawings. You can also
use the keyboard shortcuts [ [ ] and [ ] ] to perform the scroll, or from the top menu select
Animation > Substitute Drawing Previous or Substitute Drawing Next.

The drawing or Symbol’s cell on the current frame is replaced by the selected one.

To swap images in the Timeline view:
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1.

In the Timeline view, click on the Show Data View

button to expand the Data view.

2.

In the Timeline view’s right side, select the cell containing the drawing or Symbol’s cell to swap.

3.

In the Data view, drag the pointer left or right to change the cell or drawing exposed for another one. You can
also directly type the drawing name or Symbol’s cell number if you know it.
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Adding a New Drawing
If you need to add a new drawing in your scene, you can either do it inside the body part’s Symbol or, if you do not
use Symbols, directly on the part’s layer by duplicating the existing drawing on the current frame.

Duplicating a Drawing
If your character does not use Symbols, you need to duplicate the drawing on the cell where you need to use a new
drawing. You could also create a new blank drawing, but duplicating the existing drawing allows you to keep the pivot
you previously set and you can also reuse a portion of the existing artwork. When you create a new drawing, you get
a blank cell with a pivot set at the centre of the Camera view.
To duplicate a drawing:
1.

2.

In the Timeline or Camera view, select the drawing to duplicate.

In the top menu, select Drawing > Duplicate Drawing. The default keyboard shortcut is [Alt]+[Shift]+[D].
The new drawing appears in the currently selected cell.

3.

In the Camera view, draw the new piece.
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Ordering Layers Over Time

The layer ordering system in Animate saves time and simplifies your work. There is no need to create a new layer or
to copy and paste artwork into other layers to change the order. The Z-axis (forward - backward) allows the user to
create a multiplane and move elements closer or farther from the camera. This allows the puppet’s pieces to be moved
in front or behind the other ones without physically changing the layer position.

Animate provides you with a shortcut to move the piece with a micro nudge on the Z-axis. The program creates a
keyframe where different Z values can be entered. This allows for the piece to move forward and backwards in space
without you having to change the drawing’s original position or break the layer hierarchy.
This also means that the layer ordering is maintained throughout the whole scene. You can combine animation assets
so that the system can interpolate them.
To nudge elements on the Z-axis:
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1.

In the Tools toolbar, select the Transform

tool. The default keyboard shortcut is [Alt]+[Q].

2.

In the Tools toolbar, enable the Animate

Mode.

3.

In the Camera View, click on the part to be repositioned and hold down the [Alt] key. Using the [Up] or [Down]
arrow keys, nudge the part until it moves to the desired position.
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Creating Cycles
If you want to cycle a portion of your animation, you can use the Paste Cycle command. You can also use the Paste
Reverse command to completely reverse the flow of your animation.
To use the Paste Cycle command:
1.

In the Xsheet or Timeline view, select the cell range and keyframes to loop.

2.
3.

In the top menu, select Edit > Copy.
In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4.

In the top menu, select Edit > Paste Cycle. The default keyboard shortcut is [Ctrl]+[/] (Windows) or
[a]+[/] (Mac OS X).
The Paste Cycle dialog box opens.

5.
6.

In the Number of Cycles field, use the up or down arrows to increase or decrease the number of cycles you want
to paste. You can also type the value directly.
In the Cycle Type drop-down menu, select the type of cycle you want to paste.






Normal (forward): Pastes your selection as it is, starting with the first cell and ending with the last one.
Reverse: Pastes your selection reversed, beginning with the last cell and ending with the first one.
Forward -> Reverse: Pastes your selection as a yo-yo, starting with the first cell, going to the last one and
ending with the first cell.
Reverse -> Forward: Pastes your selection as a reversed yo-yo, starting with the last cell, going to the first
one and ending with the last cell.
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7.

Click on the OK button to paste your cycles.

NOTE:
You can do the same operation using the Paste Special dialog box. To open the Paste Special dialog box, select
Edit > Paste Special or use the shortcut [Ctrl]+[Shift]+[B] (Windows) or [a]+[Shift]+[B] (Mac OS X).

To use the Paste Reverse command:
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1.

In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.

2.
3.

In the top menu, select Edit > Copy.
In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4.

In the top menu, select Edit > Paste Reverse. The default keyboard shortcut is [Ctrl]+[.] (Windows) or [a]+[.]
(Mac OS X).
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Adding Pegs
Now that you have your puppet on your stage, you probably need to resize and reposition it to fit your scene. When
you need to scale down or move your character it’s a good idea to hook (attach) the whole puppet to a trajectory.
In Animate, there is a type of layer you can add to your timeline allowing you to create a motion path or reposition
drawings. This trajectory layer is called a Peg. Any drawing or layer you hook to a peg will follow the defined motion
path, rotation, scaling and skewing information.
Attaching your puppet to a peg will allow you to scale it and reposition it without having to do it on all of your different
parts and pieces. Only one layer will contain the position information, this makes your animation easier to modify and
control.
To add a repositioning peg:
1.

In the Timeline view, click on the Add Peg

button.

2.
3.

In the Timeline view, select all of the layers you want to attach to your new peg.
Drag your selection right on the peg layer to parent all your character’s pieces to the peg.

Next, you need to position your character on the stage by moving it and scaling it to the correct size. You will not scale
each layer individually. You either want to do it on the top symbol or top peg layer.
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To reposition the character:
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1.

In the Timeline view, select the top peg layer (master peg).

2.

In the Tools toolbar, select the Transform

3.

In the Camera view, position the character.

tool and disable the Animate

mode.
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Offsetting Part of an Animation
If there is a section of your animation you want to reposition such as the head’s height or the puppet’s position, you
can do it using the function curve.
To reposition a portion of an animation:
1.

In the Timeline view, click on the Expand Function
button of the body part layer to reposition. If you want to
reposition the entire body, expand the master peg’s parameters.

2.

Double-click on the layer’s parameter controlling the keyframes you want to reposition.

3.

The Function editor opens.
In the Function editor, select the keyframes you want to reposition by tracing a selection box.

4.

Enable the Show Current Frame option view the transformation results in the Camera view as you do them.

5.

Drag the keyframes selection up or down to reposition your sequence.

6.

Close the Function editor.
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Preferences
When looking for additional control over your Min/Max Angle when using Inverse Kinematics, you can find some help
in the preference panel.
You will find the preferences listed under the following tab:

•

Camera

To open the Preferences panel:





Windows: Select Edit > Preferences.
Mac OS X: Select Animate Pro > Preferences.
You can also use the default keyboard shortcut [Ctrl]+[U] (Windows) or [a]+[,] (Mac OS X).

Camera

Inverse Kinematics (PRO)
•

Min/Max Angle Constraint Weight: This value acts similar to the Stiffness setting in the Inverse Kinematics
Properties panel. This preference only affects the minimum and maximum angle values set using the Min/
. The greater the value is, the stronger your need to move the body part to approach
Max Angle Mode
the minimum and maximum values set. Although the maximum value goes up to 1.0, in a production
setting, the most practical value to use would be closer to 0.1.
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Advanced (PRO)
When looking to set the default layer type to only accept motion information through the use of a peg, you can find
some help in the preference panel.
You will find the preferences listed under the following tab:

•

Advanced

To open the Preferences panel:





Windows: Select Edit > Preferences.
Mac OS X: Select Animate Pro > Preferences.
You can also use the default keyboard shortcut [Ctrl]+[U] (Windows) or [a]+[,] (Mac OS X).

Animate Using Animation Tools (PRO)
Element Module “Animate Using Animation Tools” Default Value: If you know that you prefer to work in the style
of version 7.3 or earlier, or if you intend to substitute many drawings throughout your animation, you might wish to
uncheck the Animate Using Animation Tools Default Value option. This way, you will not have to do it every time
(through the Layer Properties) for each new drawing layer that you create.
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Chapter 16
Enhancing With Effects

Once your animation is completed, you can add effects such as blurs and glows to make your project look even better!
Animate provides you with a series of essential effects that you can add to your layers.
In this chapter, you will learn the following:

•
•
•
•
•
•
•
•
•

Adding Effects in Animate, on page 708
Adding Effects in Animate Pro (PRO), on page 709
Animating an Effect Over Time, on page 716
How Does An Effect Work?, on page 720
Using Effects in Animate, on page 722
Using Effects in Animate Pro (PRO), on page 743
Previewing and Playing Back Effects, on page 810
Extra Commands (PRO), on page 815
Preferences (PRO), on page 816
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Adding Effects in Animate
In Animate, to add an effect to your Timeline view, add an effect layer, connect the desired layer to it and adjust the
parameters until you get the look you want.
In Animate Pro you must add effects using the Network view. You cannot do this using the Timeline view. Refer
to Adding Effects in Animate Pro (PRO), on page 709 to learn how to add effects using Animate Pro.
To add effects in the Timeline view:
1.

In the Timeline view, click on the Add Layers
button and from the Layers drop-down menu, select
Effects > the desired effect. You can also select Insert > Effects > the desired effect from the top menu.

2.
3.

The effect appears in the Timeline view.
Drag the drawing layer on the new effect layer to parent them.

4.

In the Camera view, click on the Render View Mode
frame and the effect.
In the Timeline view, click on the effect layer.

5.

6.

button to see the result of rendering the scene’s current

Click on the Star icon of the effect layer to open the Layer Properties view.
The Layer Properties view opens, displaying the parameters available for the selected effect.

7.

In the Layer Properties view, adjust the effect’s parameters.

8.

In the Camera view, click on the Update Preview

9.

To play back your scene with the final effects, in the Playback toolbar, click on the Render and Play

button to update the rendered preview.
button.

NOTE: Once you have set the parameters for your effect, you can store it in the Library as a template so that
you can quickly reuse it later on without having to set the parameters again.
Refer to Chapter 9 Libraries, Symbols and Templates to learn more about creating templates.
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Adding Effects in Animate Pro (PRO)
There are several differences between Animate and Animate Pro, how you add effects is one of those differences. In
Animate Pro, effects are added using the Network view and the Module Library. You cannot add effects through the
Timeline view.
This topic is divided as follows:
About the Network View (PRO), on page 709
About the Module Library (PRO), on page 712
Importing a Module (PRO), on page 713
Adding Effects Through the Timeline (PRO), on page 714

•
•
•
•

About the Network View (PRO)
In the Network view, you can connect effects and compositing modules to form a network. The organization of
modules determines the flow of data during the compositing process and how your animation elements will be
composited.

view.

Refer to Setting Up the Scene > Setting Up the Network (PRO), on page 503 to learn more about the Network

Editor

7

Input Port

5
6
1

Thumbnail

4
3

Output Port
2

1.
2.
3.
4.
5.
6.
7.

Drawing Module (PRO), on page 710
Write and Display Modules (PRO), on page 710
Composite Module (PRO), on page 710
Effect Module (PRO), on page 710
Matte Drawing (PRO), on page 711
Position Ports (PRO), on page 711
Peg Module (PRO), on page 711
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Drawing Module (PRO)
Input Port
Click to view
Properties Editor

Click to view thumbnail display

Output Port

This is an example of an average module, in this case a simple drawing module that represents a layer in the Timeline
view. This module has an Input Port (top) that allows information to flow through it. It has an Output Port (bottom)
that exports its information in a downward flow. On the left side, there is a yellow box that brings up the module’s
Properties Editor, where all its available parameters can be adjusted. Lastly, there is a dark arrow that displays a
Thumbnail of what the module contains.

Write and Display Modules (PRO)
In this instance, both the Write and Display modules do not have output ports. This is because the information that
flows into them can go no further in the network.

Composite Module (PRO)
The Composite module combines multiple source images (Drawing modules), including all transformations and
effects, into a single bitmap or vector image for each frame.
The Composite module layers the images based on the composition order rule. First, the Z-value of the elements are
analyzed to determine depth. When multiple elements have the same Z-value, the Depth values in the Drawing
modules are consulted. If the Depth values are also the same between elements, the composition order is determined
by the cable order of modules on the Composite module. By default, modules connected to the right are rendered
below those connected to the left. You can override this default in the Composite module editor. The Composite
module is an example of a module that can have an infinite number of Input Ports that can take-in multiple, individual
sources of information. The left most Input Port on the Composite module is always green. This lets the user know
that, in terms of stacking order, whatever is plugged into this port will appear on top of the composite after the zdepth is taken into account.

Effect Module (PRO)
An Effect module can often be found with two Input Ports. The right-most Input Port is for the drawing layer that is
to be acted upon by this effect, while the left port is usually reserved for a matte. If an effect has a Matte port, it is
required and not to be considered optional.
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Matte Drawing (PRO)
A matte, also called mask, is the shape that will be used by the effect module to modify the original image. The effect
will only be applied where the matte overlaps with the original image. Sometimes the matte will act as a negative
shape that the effect will exclude. This all depends on the nature and editing properties of the effect in question.

Position Ports (PRO)
Some Effects contain three Input Ports. If the Input Ports are green, then they require a Peg module. In this case, the
Effect can accommodate two pegs.

Peg Module (PRO)
The Peg modules control the transformation of elements (position, scale, skewing and rotation) over time. The green
ports at the top and bottom of the module indicate that it accepts position information and can then pass this
information on.
One Peg can be used to control many different modules or one module can accept more than one Peg. In a situation
like the latter, one Peg might be used to modify the rotation, while the other used to modify the position of the effect
and then animated differently over time.

Refer to Creating Animation Paths > Pegs, on page 587 for further information about Pegs.
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About the Module Library (PRO)
If you need to add new modules to the Network view, you will need to get them from the Module Library.

2

1

1. Module Library View Toolbar
2. Module Tabs

When you create a new project in Animate Pro, the default network that appears in the Network view looks similar to
the diagram below.

Module Library View Toolbar (PRO)
In the Module Library View toolbar, you can switch the display mode of the effect icons:

712

•

View as Icons

•

View as List

•

View as Icons with Names
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Module Tabs (PRO)
The Module Library is conveniently broken up into several sections or tabs:

•

Favorites
Includes the most common modules.
D To add extra modules to the Favorites tab, select any module from any other section and drag it onto
the Favorites tab.

•

Filter
Includes effect modules, such as blurs.
Group
Includes modules used for grouping, like Group Modules and Port-Image-In and -Out Modules.
IO
Includes Display, Drawing, Write and Note modules.
Move
Includes modules used to change elements over time, like Peg modules, as well as certain transformations.
Plug-ins
Includes plug-in modules.
All modules
Lists all of the modules available.

•
•
•
•
•

Importing a Module (PRO)
To bring a module into your Network view, just drag it from the Module Library and drop it into the Network view.
Once in the Network view, you can click on either the Input Port or Output Port of a module and drag out a cable.
You can then connect this cable to either the Output Port or Input Port of another module.

If you would like to connect a module between two connected modules, you can use the [Alt] key as you drag the new
module over the existing cable connection. Using the same [Alt] key, you can also disconnect a module.

If you want to remove a module you can click on it to select it and press [Delete] to remove it from the Network view.
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Adding Effects Through the Timeline (PRO)
Although all effects are added through the Network view, there are two effects that can be quickly added through the
Timeline view. These effects: Colour Card and Quadmap, can be added through the Network view in the usual way.
To add effects in the Timeline view:
1.

In the Timeline view, click on the Add Layers
desired effect that you would like to add.

button and from the Layers drop-down menu select the

2.
3.

The effect appears in the Timeline view.
Drag the drawing layer to place the effect onto the new effect layer and parent them.

4.
5.

In the Camera view, click on the Render View Mode
frame and the effect.
In the Timeline view, click on the effect layer.

6.
7.

Open the Layer Properties view.
In the Layer Properties view, adjust the effect’s parameters.

8.

If you disabled the Auto Render option in the Camera view bottom toolbar, click on the Update Preview
button to update the rendered preview.

button to see the result of rendering the scene’s current

NOTE: Once you have set the parameters for your effect, you can store it in the Library view as a template so
you can quickly reuse it later on without having to set the parameters again. Refer to Libraries, Symbols and Templates
> Creating a Template from the Network View (PRO), on page 393 to learn more about creating templates.
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Working with Effects that were created in Animate (PRO)
In Animate Pro, if you open a scene in the Network view and the effects were created in Animate they are displayed
as orange groups. In fact, the drawing layer is contained inside the effect group.

In the Timeline view, the effects are connected to the drawing layer, instead of the drawing layer being connected to
the effect layer. The icon identifying the effect is a purple star

Animate Effect

.

Animate Pro Effect
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Animating an Effect Over Time

Animating an Effect in Animate
In Animate, to animate an effect over time, create a function curve by adding keyframes to the parameters you want
to animate. To do this, you will use the Layer Properties view and the Timeline view. You can fine tune your animation
using the Function view.
In Animate Pro, the Timeline view’s effect hierarchy is displayed differently than in Animate because the effects
are created in the Network view. Refer to Animating an Effect in Animate Pro (PRO), on page 718.
To animate an effect over time:
1.

In the Timeline view, add the effect and connect the layers to it.

Animate Effect
2.

Select the Effect layer.

Animate Effect
3.

To create the function curve:



OR



In the Layer Properties view, click on the Function
curve.

button you want to animate to create a function

You can also expand the effect layer’s parameters in the Timeline view by clicking on the Expand Function
button and add a keyframe using the [F6] key to the parameter you want to animate.

Animate Effect
4.

In the Timeline view, click on the Show Data

5.

In the Timeline view, go to the frame where you want to start animating the effect.

Animate Effect
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view button.
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6.

In the Data view, click on the Add Keyframe

button.

Animate Effect
7.

In the Value field scroll to the keyframe value or type the value in the field.

Animate Effect
If your keyframes are Stop-Motion keyframes, In the Timeline view, select the new keyframes. Right-click
(Windows) or [Ctrl]+click(Mac OS X) on the selection and select Set Motion Keyframe.
Repeat this process for each keyframe to be added.


8.

Refer to the Previewing and Playing Back Effects topic to learn how to preview animated effects.
Refer to Chapter 15 Animating Your Puppets to learn how to adjust your function curves in the Function view.
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Animating an Effect in Animate Pro (PRO)
In Animate Pro, to animate an effect over time, create a function curve by adding keyframes to the parameters you
want to animate. To do this, you will use the Layer Properties view, the Network view and the Timeline view. You can
fine tune your animation using the Function view.
To animate an effect over time:
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1.

In the Network view, drag an Effect module from the Module Library and drop it into the Network view.

2.

Plug the effect element between the drawing element that you would like to apply the effect to and a
composite module. You can either do this manually by unplugging and plugging, or by holding down [Alt] as you
drag it through a connection.
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The Effect should also appear in the Timeline view as well.

3.

To create the function curve:



OR



In the Layer Properties view, click on the Function
curve.

button you want to animate to create a function

You can also expand the effect layer’s parameters in the Timeline view by clicking on the Expand Function
button and add a keyframe using the [Ctrl]+[F6] (Windows) or [a]+[F6] (Mac OS X) key to the
parameter you want to animate.

4.

In the Timeline view, click on the Show Data

view button.

5.

In the Timeline view, go to the frame where you want to start animating the effect.

6.

In the Data view, click on the Add Keyframe

7.

In the Value field scroll to the keyframe value or type the value in the field.

button.

If your keyframes are Stop-Motion keyframes, In the Timeline view, select the new keyframes. Right-click
(Windows) or [Ctrl]+click (Mac OS X) on the selection and select Set Motion Keyframe.
Repeat this process for each keyframe to be added.


8.

Refer to the Previewing and Playing Back Effects topic to learn how to preview animated effects.
Refer to Creating Animation Paths > Modifying a Path in the Function View, on page 614 to learn how to adjust
your function curves in the Function view.
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How Does An Effect Work?
An effect module always needs a drawing connection and sometimes a matte or shape connection. A matte provides
drawing information that will be used to determine the area where the effect will be applied on the drawing. The
details and colours within the matte drawing do not matter, as the system will only use the shape and transparencies
in it. A matte is also known as mask.
The matte principle can be demonstrated with the Tone effect.

©Nelvana Limited
The drawing layer is connected in the right port of the effect module and the matte (mask) in the left port. The Tone
effect then applies darker colours where the matte overlaps the image, blurs the tone edge, and finally clips out the
extra tone zone outside of the drawing before outputting a final drawing with a tone.
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The tone’s parameters can be adjusted in the module editor and any of them can be linked to a function column to
be animated over time. This means that all of the effects can be customized.
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Using Effects in Animate
Here is the list of the effects available in Toon Boom Animate. Each effect and how to use it is described in the
corresponding section.

•
•
•
•
•
•

Blending Effects
Blur
Brightness and Contrast
Colour Card
Colour Override
Colour Scale

•
•
•
•
•

Directional Blur
Glow
Highlight
Mask
Motion Blur

• Particle Effect, Crowd Simulation
and More

•
•
•
•

Quadmap
Shadow
Tone
Transparency

Effect Layers
Blending Effects

Effects modules, like the Tone Module and Highlight Module, can control the colour and alpha composite operations
for you. These modules were created with pre-set colour and alpha composite operations to fit the standard and more
frequently used, composite operations.
You might, however, still want to control the colour and alpha composite operation between two images using the
Blending layer, to create a multiplicity of lighting, shadow, filter or ambiance effects. The Blending layer combines two
images into one output image, following the parameters you chose for your bitmap movie and Images Sequence or
SWF movie exports.

The drawing layer connected to the Blending effect layer will act as the blending image and will be applied to all the
drawing layers situated under them in the Timeline view order.
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Use the Blending editor to control the settings of the Blending effect.

•
•

•

Name: Use this field to rename the module.
Blend Mode: Choose the blending effect mode you wish to apply to your layer. The Blend Mode type will
only be visible when the Camera view is set to Render
mode and will only export to a bitmap movie file
or sequence of images.
SWF Blend Mode: Choose the blending effect mode you wish to apply to your layer. The SWF Blend Mode
result will only be visible when exported to a SWF movie.

Blend Mode and SWF Blend Mode drop-down menu options
Here is a list of the available Blending modes:

•
•
•
•
•
•
•
•
•
•

•

•
•
•
•

Normal: The layer attached to the effect acts as a normal layer and will not create any blending mode
effect.
Multiply: This operation multiplies the blending element colour with the output image. This will darken the
colour of the overlapping area.
Screen: This operation multiplies the inverted colour of the blending element with the image. This will
lighten the colour of the overlapping area.
Lighten: This operation lightens the area of the output image which are darker than the blending element’s
colours. The lighter colours will remain unchanged.
Darken: This operation darkens the area of the output image which are lighter than the blending element’s
colours. The darker colours will remain unchanged.
Difference: This operation subtracts the blending elements colour from the output image colours or viceversa, depending on which of them has more bright colours. Resulting in a more vibrant colours result.
Add: This operation lightens the output image using the blending element.
Subtract: This operation darkens the output image using the blending element.
Invert: This operation inverts the output image colours on the area overlapping the blending layer colours.
Overlay: This operation multiplies or screens the colours from the blending image, with those of the output
image, depending on the base colour. Colours from the blending element overlay the colours of the
drawing elements, while preserving the highlights and shadows of the base colour. The base colour is not
replaced, but mixed with the blend colour to reflect the lightness or darkness of the original colour.
Hardlight: This operation multiplies or screens the colours of the blending layer with those of the output
image, depending on the blend colour. If the blend colour is lighter than 50% grey, the image is lightened,
as if it were screened. This is useful for adding highlights to an image. If the blend colour is darker than 50%
grey, the image is darkened, as if it were multiplied. This is useful for adding shadows to an image. Painting
with pure black or white results in pure black or white. Play with the Opacity value to create a subtler look.
Alpha: This operation will blend the alpha value of the blending layer with the output image. This effect is
not available for SWF Blend Mode.
Erase: This operation produces a cutter effect using the blending element. This effect is not available for
SWF Blend Mode.
Divide: This operation divides the output image colour values by the blending layer colour values. The
blending image colour values are inverted, creating a negative image. The negative image’s colour values
are then multiplied by the right image colour values. This effect is not available for SWF Blend Mode.
Replace: This operation replace the output image by the blending layer. This effect is not available for SWF
Blend Mode.

It is possible to select two different blending modes in the same Blending effect layer if you want to export your
project to both a Bitmap and an SWF movie file with different results.
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Blur

The Blur effect creates an effect that softens, fogs or obscures the image evenly in all directions. This effect is useful
when you want to make cloudy images without much detail. An example would be a drawing object that is farther
back or in the background of your scene, usually blurry due to the laws of atmospheric perspective. Other uses include
the general softening of objects such as snow, stars and shadows that do not naturally have a hard outline.

Use the Blur editor to change the values of the Blur effect.

•

•
•
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Truck Factor: Activated by default, this option reads only the blur when the elements undergo a change of
depth or scale. When this option is disabled, the layer’s values will remain unchanged regardless of any
depth or scale changes. It is recommended that this option be disabled when multiple drawings are
composited and attached to this effect.
Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur radius
is affected by the drawing scale and camera position. Attach a Bezier or Ease function to change the
contrast over time.
Quality: Select High for a slow and accurate operation or Low for a faster operation with a more raw look.
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Brightness and Contrast

The Brightness and Contrast effect is used to modify the brilliance or dullness of an image or to create a greater
difference between the lights and darks of an image by increasing their respective intensity. This effect can be used
when an image appears to flat. Pumping up the brightness or contrast can give a drawing a more attractive and 3D
quality. This can be useful if you want to push your background to the rear by making it look dull and flat and pulling
your foreground elements to the front by giving them a higher contrast.

Use the Brightness and Contrast editor to change the values of the Brightness and Contrast effect.

•
•

Brightness: A value that is less than 0 will darken the image; a value greater than 0 will brighten it. Attach a
Bezier or Ease function to change the brightness over time.
Contrast: A value that is less than 0 will reduce contrast; a value greater than 0 will increase contrast. Attach
a Bezier or Ease function to change the contrast over time.
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Colour Card

The Colour Card is a solid background the same size as the camera. The Colour Card can be used to fill the scene’s
background with a solid colour when there is no background image. If no background or colour card is added to the
scene, the resulting export will appear with a black background.

Use the Colour Card editor to change the colour values.

This bar indicates the card
colour. Click on the bar to
change colour.

•
•
•
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Depth: Animate uses the Depth value to determine composition order when the Z value of two elements is
the same.
Offset Z: Enter the front-back position of the Colour Card layer in 3D space. This value can be verified in
the Top view.
Red/Green/Blue/Alpha: In these fields you can enter a static value for a colour and transparency of the
Colour Card or you can attach these parameters to function columns to change their values over time.
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Colour Override

The Colour Override processes the colours in a drawing layer. The drawings in this layer must be TVG files.
Using this effect you can change colours from the palette without affecting the actual palette, swap clone palettes,
replace a specific colour zone with a bitmap texture, or hide and display selected colours.

Use the Colour Override effect to:

•
•
•
•
•

Change colour values in drawings during the compositing process.
Use colour values from a specific colour palette in the palette list.
Establish the priority of override palettes in the palette list. For example, you may have different clones of
the same palette, for example a daytime and nighttime version.
Isolate specific areas of a drawing by selecting certain colours. For example, using specific colours to
generate a matte for a glow effect.
Hide certain colours.
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Use the Colour Override editor to set the colour override operations for TVG elements and their drawings.

•
•
•

•

Palettes: This section displays the palettes in the selected layer’s palette list. Select and drag these palettes
into the Palette Overrides section to re-order them. You can load additional palettes in the palette list from
either your project, by clicking on the Palette button, or your computer by clicking on the Browse button.
Colours: This section displays the colours swatches of the selected palette. Drag a swatch into the Colour
Overrides section to change its value or drag it into the Selected Colours section to render only that colour.
Palette Overrides: This section forces the use of a particular palette or palette list order, during the
composition process. You must drag palettes from the Palettes section to change their order. Animate
searches the palettes in the order that they appear in the palette list to find the colour values associated
with the colour IDs of each image. To apply a different version of a colour palette, for example to switch
from a day to a night palette, use the override section to change the order of colour palettes (you must be
working with cloned palettes).
Colour Overrides: Drag a swatch from the Colours section to this section to override its value. You can also
override a colour with a texture.
Once the swatch appears in the Colour Overrides section, right-click (Windows) or [Ctrl]+click (Mac OS X)
on the Override Colour text and select one of the following options in the drop-down menu:
D Colour not visible: renders the selected colour invisible in the Camera view.
D New RGB only: Overrides the colour swatch while maintaining its original alpha value. You can select a

D

button and choosing a new colour from the Colour Picker
new colour by pressing the eye dropper
window. The new colour swatch will appear under the newRGBA column.
New alpha only: Overrides the swatch’s alpha channel while maintaining its original RGB values. You
can select a new alpha value by pressing the eye dropper
button and choosing a value from the
Colour Picker window. The new colour swatch will appear under the newRGBA column.

D New RGBA: Overrides the swatch’s colour and alpha values and uses the eye dropper
D

D
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button to
pick a modified selection from the Colour Picker window.
Texture – original matrix: Overrides the swatch’s colour with a pattern or texture. You must right-click
(Windows) or [Ctrl]+click (Mac OS X) under the Texture header to bring up the Browser window to
search for your texture. The texture’s default matrix (fixed proportion and orientation) is mapped the
full size of the bounding box of each colour area to be overridden.
Texture – global bbox matrix: Overrides the colour with a texture that is scaled non-proportionally to
the size of the bounding box encompassing the colour areas to be overridden. With multiple objects, it
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•

will look as though their fills were all traced and cut from the same piece of stretched or squashed
fabric.
D Texture – global bbox centred: Overrides the colour with a texture that is scaled proportionally to the
size of the bounding box encompassing all colour areas to be overridden. With multiple objects, it will
look as though their fills were all traced and cut from the same piece of fabric.
D Texture – contour bbox matrix: Overrides the colour with a disproportionally scaled texture for each
individual colour area. In other words, each fill area will not only have the texture scaled to its individual
proportions, but also stretched or squashed to fit within its contours.
D Texture – scale to screen: Disproportionally scales the texture to the output resolution before applying
it as an override.
Selected colours: Use this section to select swatches to render.
D Render selected only: Use this option to render only the colours you select in this section.

Colour Scale

The Colour Scale effect offsets an images colours. This effect is useful in creating ambient transitions, such as from
daytime to nighttime.

Use the Colour Scale editor to set the colour scale effect by entering a value in the scale fields.

The actual colour values of the image are not changed; instead, the channels are multiplied by a selected amount. For
example:

•
•
•

If you enter a value of 1, the colour values do not change.
If you enter a value greater than 1, you increase the colour channel value closer to 255 (or white).
If you enter a value less than 1, you decrease the colour channel value closer to zero (0 or black).

You can set the colour scale value by entering a value in the field. You can also change the values of the colour scale
effect over time by attaching it to a Bezier or Ease function curve

and adding keyframes.
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Directional Blur

The Directional Blur effect creates the effect of a motion blur that pulls and smears the image from one contour edge
to a different direction or angle. This effect is useful in creating the impression of speed, such as the streaks of colour
that follow a car travelling at high speed.

Use the Directional Blur editor to control the settings of the Directional Blur effect.

•

•
•

•
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Truck Factor: Activated by default, this option readjusts the blur when the elements undergo a change of
depth or scale. When this option is disabled, the effect’s values will remain unchanged regardless of any
depth or scale changes. We recommended that this option be disabled when multiple drawings are
composited and attached to this effect.
Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur radius
is affected by the drawing scale and camera position. This function can be animated over time.
Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value between 0 and
1. This function can be animated over time.
D A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.
D A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.
Angle: The direction of the blur. Enter a value from 0 to 360. This function can be animated over time
D 0: blurs the image to the west.
D 90: blurs the image to the south.
D 180: blurs the image to the east.
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D 270: blurs the image to the north.

•
•
•

Direction of trail: If you do not set an Angle for the direction of the blur, you can select a direction (north,
south, east, or west) from this menu. The calculations for this feature are faster than the calculations for the
Angle setting.
Ignore Alpha: This option controls the leading edge of the blur. Deselect this option for a solid or hard
leading edge on the blur.
Extra Final Blur: This option causes the software to apply a second blur after the Directional Blur is created.
If you have a Directional Blur that begins at 0 and gradually gets stronger, disable this option to ensure a
smooth progression.

Glow

The Glow effect transforms your drawing into a glow shape.

The Glow effect is useful in creating a shining rim around objects such as the Sun or stars. If you would like to have a
shining rim around your drawing, you will need to duplicate your drawing layer and place it on top of your glow shape.
Use the Glow editor to control the direction of the blur that creates the glow, as well as its colour.

•

Truck Factor: Activated by default, this option readjusts the blur when the elements undergo a change of
depth or scale. When this option is disabled, the effect values remain unchanged regardless of any depth or
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•

•
•

•

•
•
•
•

scale changes. It is recommended that this option be disabled when multiple drawings are composited and
attached to this effect.
Blur Type (Directional or Radial):
D If Directional is selected, the software will blur the matte in the direction you select. For example, if a
character is walking east, the blur may fall to the west.
D If Radial is selected, the software will blur the edges of the matte evenly around points that make up its
edge.
Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur radius
is affected by the drawing scale and camera position.
Directional Angle: If you select a Blur Directional Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.
D 0: blurs the image to the west.
D 90: blurs the image to the south.
D 180: blurs the image to the east.
D 270: blurs the image to the north.
Directional Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.
D A fall-off rate of zero causes the blur to fade out slowly, distributing the blur evenly from the edge of
the character to the farthest edge of the blur.
D A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.
Invert Matte: Activate this option to invert the matte used to create the glow. Your matte will become a
black silhouette while the glow will fill the background space.
Use Source Colour: Select this option to use the colours painted in the matte for the glow effect. If you
deselect this option, select a colour and alpha values in the Colour section.
Multiplicative: Select this option to multiply the glow colour to the drawings and background behind rather
than blending it. Each zone will react differently to the glow colour rather than becoming uniformly brighter.
Colour: Where you can choose the colour and alpha values for the glow effect.

Highlight

Use the Highlight effect to make an area of a drawing lighter, to simulate a light source. To produce the highlight
effect, you must draw a shape to control where the highlight will appear on the original drawing.

The Highlight effect uses a matte to determine the shape and position of the highlight on another element and can
blur the edges to create a softer effect. The layer containing the shape of the highlight should be parented to the
Mask and the drawing layer, to which the highlight should be applied to, should be parented to the Highlight effect
layer.
Use the Highlight editor to control the type and amount of blur, as well as the colour of the highlight effect.
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•

•

•
•

•

•
•
•
•

Truck Factor: Activated by default, this option readjusts the blur when the element undergoes a change of
depth or scale. When this option is disabled, the effect’s values remain unchanged regardless of depth or
scale changes. It is recommended that this option be disabled when multiple drawings are composited and
attached to this effect.
Blur Type (Directional or Radial):
D If Directional is selected, Animate will blur the matte in the direction you select.
D If Radial is selected, Animate will blur the edges of the matte evenly around points that make up the
edge of it.
Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur radius
is affected by the drawing scale and camera position.
Directional Angle: If you select a Directional Blur Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.
D 0: blurs the image to the west.
D 90: blurs the image to the south.
D 180: blurs the image to the east.
D 270: blurs the image to the north.
Directional Fall-off Rate: The distance where the directional blur fades from the edge of the image. Select
a value between 0 and 1.
D A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.
D A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.
Invert Matte: Activate this option to invert the matte used to create the highlight.
Use Matte Colour: Select this option to use the colours in the matte for the highlight effect. If you deselect
it, use the Colour section to select colour and alpha values.
Multiplicative: Select this option to multiply the highlight colour to your original drawing rather than
blending it. Each zone on the drawing will react differently to the highlight colour rather than becoming
uniformly lighter.
Red/Green/Blue/Alpha: In the RGBA fields, enter the value that you want added to or subtracted from the
colour channels in the drawings. Alternatively, you can attach these values to function columns to animate
them over time.
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Mask

The Mask cuts out a portion of an image using a matte drawing. You can use the Mask to allow a character to
disappear behind a background element or to cut a virtual hole into the layer itself. The Mask requires a matte input.

Use the Mask editor to invert the effect of the matte on an image. Instead of the object being hidden by the mask, it
will only be visible where it intersects with the matte shape area.
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Motion Blur

The Motion Blur effect is used to create a faded trail behind objects animated on a motion path. The layer must be
moving along a trajectory (motion path) in order to work properly.

The Motion Blur effect automatically creates a matte for the Drawing layer attached to it, so it is not necessary to
connect any matte to the Mask layer.
Use the Motion Blur editor to modify the motion blur. You can also use the Motion Blur parameters to create a crowd
simulation or particle system effect. Refer to the Particle Effect, Crowd Simulation and More topic to learn how.

•
•
•

•
•

Number of Frames in Trail: Number of frames before the current frame that will be used in the trail.
Number of Samples: Number of copies of each drawing used in the trail. The higher the number, the more
continuous the trail appears.
Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value between 0 and
1.
D A fall-off rate of 0 causes the trail to fade out slowly, distributing the colour evenly from the edge of the
character to the farthest edge of the trail.
D A fall-off rate of 1 causes the trail to fade out quickly so that the trail is more opaque closer to the edge
of the image and transparent at the end of the trail.
Intensity: Select a value to define the opacity of the trail between 0 and 10. A value of 10 will make the trail
very dark and almost opaque, where as a value of 0 will make the trail quite pale and ghostly transparent.
Use Mirror on Edges: When enabled, this option appears when the image is close to the edge of the
camera frame. It forces the software to use a mirror of the image to calculate the blur so that it appears on
both sides of the drawing object. Without this option once your drawing reaches the edge of the Camera
frame, it gets cropped so does the trail.
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Particle Effect, Crowd Simulation and More

The Motion Blur effect includes a Matte layer allowing you to do advanced effects such as particles. For example, you
could create a snow fall using a snowflake drawing and an animated matte. The matte only has to be composed of a
series of dots that you can animate with a motion path.

Matte

Drawing

Result
The matte operates such that:

•

•

Any point created on the matte that is bigger than one pixel will increase the blur amount of the final
composite as the drawing layer is actually being rendered once for every pixel that exists in an area. As no
pixel exists one on top of another, these drawings are also being slightly offset from one another, which
gives the final result of a blurred effect.
The mask’s alpha of 255 is divided by the number of dots you draw. Therefore if you make nine dots, which
will represent nine different offset positions for your drawing, then the final output’s opacity is being
divided by nine. This means that the more dots you have, the paler they will all appear in the final render. To
compensate, you can increase the Intensity parameter by the number of dots squared, in this case it would
be 23 x 23 or a value of 529.

To create a Particle Effect using the Motion Blur, create a drawing that has different sized dots randomly distributed
over the drawing space. Create the drawing to multiply, such as a snowflake or star, but be sure to draw it in the centre
of the drawing plane. The Motion Blur effect will blur and filter this shape into the size, colour and location of the dots
drawn in the original image. The matte can change form over time to bring the particles to life, or the dot drawing
can be animated, such as in the example of snow, to make it look like it is falling.
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Quadmap

Use the Quadmap transformation layer to deform the shape of an element. For example, you can use it to create a
drop-shadow effect for an element.
You can edit the Quadmap visually in the Camera view.
To edit the Quadmap in the Camera view:
1.

In the Timeline view, click on the Add Layer

2.

Connect the Quadmap layer to the Drawing layer that you want to deform

3.

In the Tools toolbar, disable the Animate Mode to change the value for the Quadmap over the entire duration of
the element.
In the Timeline view, click on the Quadmap layer to select it.
Select View > Show > Control. The default keyboard shortcut is [Shift]+[F11] (Windows).

4.
5.

button and select Quadmap from the drop-down menu.

The quadmap handles appear around the element in the window. There is also a pivot point at the centre of the
quadmap frame that can be repositioned.
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6.

In the Camera View view, use the Transform tool to move the points on the quadmap. [Shift]-click to select
multiple points.

The value of each point on the quadmap can be changed gradually. To do this, use the Quadmap Layer Properties to
attach the points to function curves.

Only the X and Y values of each point in the quadmap can be changed.

•
•
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2D Path: change the X and Y values simultaneously and control the velocity of the change.
Separate: change the X and Y values separately. Each of these can be attached to separate function curves.
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Shadow

With the Shadow effect, you can turn a drawing into a shadow. It does not matter if your drawing layer is a fully
coloured character, the Shadow effect default parameters will render it into a grey, semi-transparent, slightly blurry
silhouette.
To add a shadow stretched out on the ground, simply add a Quadmap module to flip, stretch and skew the matte.
Attach the entire effect to the same trajectory as your drawing layer and watch the shadow move along with your
character.

Use the Shadow editor to modify the way the Shadow effect is created.
The Shadow effect uses the shape of the drawing connected to create the shadow behind another element and can
blur the edges to create a softer effect. You can control the type and amount of blur, as well as the colour of the
shadow, in this dialog box.

•

•

•
•

Truck Factor: Activated by default, this option readjusts the blur when the elements undergo a change of
depth or scale. When this option is disabled, the effect’s values remain unchanged regardless of any depth
or scale changes. It is recommended that this option be disabled when multiple drawings are composited
and attached to this effect.
Blur Type (Directional or Radial):
D If Directional is selected, Animate will blur the matte in the direction you select.
D If Radial is selected, Animate will blur the edges of the matte evenly around points that make up the
edge of it.
Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur radius
is affected by the drawing scale and camera position.
Directional Angle: If you select a Directional Blur Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.
D 0: blurs the image to the west.
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D 90: blurs the image to the south.
D 180: blurs the image to the east.
D 270: blurs the image to the north.

•

•
•

•
•

Directional Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.
D A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.
D A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.
Invert Matte: Activate this option to invert the matte used to create the shadow. In the render mode, the
background will appear grey, while a the matte shape will act as a cut-out window, allowing you to see the
original background colours beneath.
Use Source Colour: Create the shadow using the matte shape’s colour. Be sure that you are in render mode
to see this effect and that your background is NOT white and that you do NOT have a white colour
card module attached to the composite. As the shadow matte only gives colour information, but no alpha,
the matte is automatically multiplied with the background colours. If there is no colour card attached,
therefore the background appears black, you will see the matte colour at full opacity. If it is multiplied with
a white background, the colours disappear into the full 255.
Multiplicative: Select this option to multiply the shadow colour to the drawings and background behind
rather than blending it. Each zone will react differently to the shadow colour rather than becoming
uniformly darker.
Red/Green/Blue/Alpha: In the RGBA fields, you can enter the value to add or subtract from the colour
channels in the drawings or you can attach these values to function curves.

Tone

Use a Tone effect to add a dark coloured region to your drawing and simulate the shaded area away from a light
source. To produce the tone effect, create a drawing to control where the tone will appear. The Tone effect uses a
matte to determine the shape and position of the tone on your drawing and can be blurred at the edges to create a
softer effect.

Use the Tone editor to control the type and amount of blur, as well as the colour of the tone.
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•

•

•
•

•

•
•
•
•

Truck Factor: Activated by default, this option readjusts the blur when the elements undergo a change of
depth or scale. When this option is disabled, the effect’s values will remain unchanged regardless of depth
or scale changes. It is recommended that this option be disabled when multiple drawings are composited
and attached this effect.
Blur Type (Directional or Radial):
D If Directional is selected, Animate will blur the matte in the direction you select.
D If Radial is selected, Animate will blur the edges of the matte evenly around points that make up the
edge of the matte.
Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur radius
is affected by the drawing scale and camera position.
Directional Angle: If you select a Directional Blur Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.
D 0: Blurs the image to the west.
D 90: Blurs the image to the south.
D 180: Blurs the image to the east.
D 270: Blurs the image to the north.
Directional Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.
D A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.
D A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.
Invert Matte: Activate this option to invert the matte used to create the tone.
Use Matte Colour: Uses the matte shape colour to create the tone.
Multiplicative: Select this option to multiply the tone colour to your original drawing rather than blending
it. Each zone on the drawing will react differently to the tone colour rather than becoming uniformly darker.
Red/Green/Blue/Alpha: In the RGBA fields, you can enter the value you want added to or subtracted from
the colour channels in the drawings or you can attach these values to function curves.
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Transparency

The Transparency effect is used to make an image partially transparent. The Transparency effect is useful when fading
images in and out, such as a phantom or to make something partially see-through, such as a window.

Use the Transparency editor to control how transparent the element should be.

You can enter a value in the Transparency field or change the transparency value over time by linking it to a function
curve. Entering a value of one hundred into the Transparency field will make the element 100% transparent, in other
words, invisible. Entering a value of 0 will render the element completely opaque.
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Using Effects in Animate Pro (PRO)
Here is the list of the effects available in Toon Boom Animate Pro. Each effect and how to use it is described in the
corresponding section.

•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Anti Flicker (PRO)
Apply Image Transformation (PRO)
Apply Peg Transformation (PRO)
Blending (PRO)
Blur Directional (PRO)
Blur Radial (PRO)
Blur Variable (PRO)
Brightness and Contrast (PRO)
Channel Selector (PRO)
Colour Art (PRO)
Colour Card (PRO)
Colour Override (PRO)
Colour Scale (PRO)
Colour Screen (PRO)
Composite-Generic (PRO)
Contrast (PRO)
Cutter (PRO)
Dither (PRO)
External (PRO)
Field Chart (PRO)
Focus (PRO)
Focus Multiplier (PRO)
Glow (PRO)
Glue (PRO)

•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Grain (PRO)
Greyscale (PRO)
Highlight (PRO)
Layer Selector (PRO)
Line Art (PRO)
Matte Blur (PRO)
Matte Resize (PRO)
Motion Blur (PRO)
Multi-Port-In (PRO)
Multi-Port-Out (PRO)
Negate Module (PRO)
Note (PRO)
Overlay Layer (PRO)
Particle Effect, Crowd Simulation and More (PRO)
Pixelate (PRO)
Placeholder (PRO)
Quadmap (PRO)
Refract (PRO)
Remove Transparency (PRO)
Shadow (PRO)
Sparkle (PRO)
Tone (PRO)
Transparency (PRO)
Underlay Layer (PRO)

Gradient (PRO)
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Effect Modules (PRO)
Anti Flicker (PRO)

Use the Anti Flicker to compensate for flickering in your output to TV formats. The Anti Flicker effect applies a vertical
blur to the rendered output. You should place the Anti Flicker before a Write module in the Network view.

Use the Anti Flicker editor to control the amount of blur that is applied to rendered output. In the Radius field, enter
a value for the number of pixels to be considered in the blur.
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Apply Image Transformation (PRO)
The Apply Image Transformation effect is mainly used when you want to pan an object out of the Camera frame and
that object has an effect such as a Glow or a Blur on it. When you use a Peg or the Apply Peg Transformation module
to translate an object such as the Sun out of the camera frame, as soon as the Sun starts to go outside of the camera
frame, the Sun’s circle is cropped and the blur is applied on the shape left over. This also means that when the Sun is
completely out of the frame, the Blur is not calculated anymore and the Blur pops out.
To prevent this from happening, you must use the Apply Image Transformation module to pan the Sun out.
The Apply Image Transformation module applies the panning transformation after the full drawing of the Sun is
blurred, then the image is composited. Here is an example of this network:

Here is how to connect the Blur effect for a Sun panning out:
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Here is the visual result of the blurred Sun:

Look at the following example to understand better why using the Apply Image Transformation instead of a regular
peg or the Apply Peg Transformation module.

Original Image

Apply Image Transformation

Peg or
Apply Peg Transformation

The normal rendering behaviour is to crop the image before applying the effects. When planning a sunset using either
a Peg or the Apply Peg Transformation module, as soon as the drawing of the sun is out of the camera frame, the
drawing is cropped and there is no image left to blur. This means that the glowing edge pops out of the camera
instead of panning out gradually. Using the Apply Image Transformation module, the image is blurred before being
panned out, so this means that even once the drawing is out of the camera frame, its glowing edge will still show until
the drawing is far enough from the camera border. This way, there is no pop when panning out blurred objects.
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Refer to the Apply Peg Transformation (PRO) topic to learn more.
Use the Apply Image Transformation editor to change the name of the module.

Apply Peg Transformation (PRO)

Use the Apply Peg Transformation module to apply a transformation coming from a Peg, Ortholock or Quadmap
module on a single module or a group of modules. When using the drawing layer’s No Clipping option, you can use
this module to apply all Camera and Peg transformations once all of the effects and modules connected above the
drawing module are calculated.
You can use this effect module to create a simple highlight on a cut-out puppet or use the No Clipping option available
in the Drawing layer.
The No Clipping option, found under the Drawing Layer Properties’ Advanced tab is used when you do not want to
crop your images before all effects are applied to your drawing. No Camera motion or peg transformation will be
applied to your drawing until you connect an Apply Peg Transformation.
Refer to Setting Up the Scene > Positioning an Element Using the Layer Properties to learn more about the
Drawing Layer’s Advanced tab.
The advantage of this module is that you can create a second output of your image or puppet and offset it, scale it or
apply any kind of transformation on it.
The transformations set in the Peg, Ortholock or Quadmap module connected to the Apply Peg Transformation
module are applied BEFORE the image is composited.

747

Animate Pro 2 User Guide
Here is an example of how to connect the Apply Peg Transformation module:

The transformation set in the Peg module from the example above is applied before the image is composited, which
is the equivalent of the following network:

In the following images you can see the result of the transformation without the Apply Peg Transformation module
and with it:

Original Drawing (Outside the Camera frame)
Without an Apply Peg Transformation

Drawing With an Apply Peg Transformation
(Appears within the Camera Frame)
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Using the Apply Peg Transformation you can apply transformation on drawings that are outside the Camera frame and
make them appear inside the frame.
If you are using the Apply Image Transformation module to create a drop-down shadow for a character, it will work
correctly so long as the character is not going outside of the camera frame or that the drawing connected in it is a
VECTOR drawing. The reason is the Apply Image Transformation module applies the transformation once the drawing
is rendered, moved by its own set of Pegs, motion paths and quadmap and cropped to the camera frame size. This
crop operation does not occur if the drawing is a vector drawing (*.TVG). Although, as soon as the drawing is passed
through an effect module or a bitmap type Composite module, the drawing is turned into a bitmap image and gets
cropped.
So, if you offset a bitmap half inside and half outside the camera frame, the outside part is cropped out and then
moved by the Apply Image Transformation module. A part of the original drawing is cut. You need to use the Apply
Peg Transformation module for the transformation to be applied before the image is processed and cropped.

Original Drawing

Apply Image Transformation

Apply Image Transformation

Apply Peg Transformation

Apply Peg Transformation

Refer to the Apply Image Transformation (PRO) topic to learn more about that effect.
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Advanced Apply Peg Transformation
You can use the Apply Peg Transformation’s middle port to apply the transformation you connected to the module
after one of the Peg or Quadmap connected above the drawing module.
In the following example, two pegs were added to control the different motions on independent trajectories:

•
•

Peg-Translation
Peg-Scale

When there is no Apply Peg Transformation module, the Peg-Translation is the first trajectory to affect the Drawing
module. Then, once the translation is applied, the Scale trajectory affects the Drawing module.
When using an Apply Peg Transformation module without using the middle port, the Peg-Rotation connected in the
APT module is applied at the top of everything. The order in which the trajectories are applied to the Drawing module
is:
1.
2.
3.

Peg-Rotation
Peg-Translation
Peg-Scale

When the Peg-Translation is connected in the Apply Peg Transformation’s middle port, the Peg-Rotation is applied
after the Peg-Translation and before the Peg-Scale. This means that the translation is done before the rotation instead
of the rotation before the translation.
The order in which the trajectories are applied to the Drawing module is:
1.
2.
3.

Peg-Translation
Peg-Rotation
Peg-Scale

Use the Apply Peg Transformation editor to rename the module.
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Blending (PRO)

Effects modules, like the Tone Module and Highlight Module, can control the colour and alpha composite operations
for you. These modules were created, with pre-set colour and alpha composite operations to fit the standard, and
more frequently used, composite operations.
You might, however, still want to control the colour and alpha composite operation between two images using the
Blending effect, to create a multiplicity of lighting, shadow, filter or ambiance effects. This effect combines two images
into one output image, following the parameters you chose for your bitmap movie and Image Sequence or SWF movie
exports.

The drawing module connected to the Blending effect module will act as the blending image and will be applied to
all the drawing modules situated to their right on the same Composite module.
Use the Blending Mode editor to control the settings of the blending effect.

•
•

•

Name: Use this field to rename the module.
Blend Mode: Choose the blending effect mode you wish to apply to your layer. The Blend Mode type will
mode and will only export to a bitmap movie file
only be visible when the Camera view is set to Render
or sequence of images.
SWF Blend Mode: Choose the blending effect mode you wish to apply to your layer. The SWF Blend Mode
result will only be visible when exported to a SWF movie.
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Blend Mode and SWF Blend Mode drop-down menu options
Here is a list of the Blending modes available:

•
•
•
•
•
•
•
•
•
•

•

•
•
•
•

Normal: The layer attached to the effect acts as a normal layer and will not create any blending mode
effect.
Multiply: This operation multiplies the blending element colour with the output image. This will darken the
colour of the overlapping area.
Screen: This operation multiplies the inverted colour of the blending element with the image. This will
lighten the colour of the overlapping area.
Lighten: This operation lightens the area of the output image which are darker than the blending element’s
colours. The lighter colours will remain unchanged.
Darken: This operation darkens the area of the output image which are lighter than the blending element’s
colours. The darker colours will remain unchanged.
Difference: This operation subtracts the blending elements colour from the output image colours or viceversa, depending on which of them has more bright colours. Resulting in a more vibrant colours result.
Add: This operation lightens the output image using the blending element.
Subtract: This operation darkens the output image using the blending element.
Invert: This operation inverts the output image colours on the area overlapping the blending layer colours.
Overlay: This operation multiplies or screens the colours from the blending image, with those of the output
image, depending on the base colour. Colours from the blending element overlay the colours of the
drawing elements, while preserving the highlights and shadows of the base colour. The base colour is not
replaced, but mixed with the blend colour to reflect the lightness or darkness of the original colour.
Hardlight: This operation multiplies or screens the colours of the blending layer with those of the output
image, depending on the blend colour. If the blend colour is lighter than 50% grey, the image is lightened,
as if it were screened. This is useful for adding highlights to an image. If the blend colour is darker than 50%
grey, the image is darkened, as if it were multiplied. This is useful for adding shadows to an image. Painting
with pure black or white results in pure black or white. Play with the Opacity value to create a subtler look.
Alpha: This operation will blend the alpha value of the blending layer with the output image. This effect is
not available for SWF Blend Mode.
Erase: This operation produces a cutter effect using the blending element. This effect is not available for
SWF Blend Mode.
Divide: This operation divides the output image colour values by the blending layer colour values. The
blending image colour values are inverted, creating a negative image. The negative image’s colour values
are then multiplied by the right image colour values. This effect is not available for SWF Blend Mode.
Replace: This operation replaces the output image with the blending layer. This effect is not available for
the SWF Blend Mode.

It is possible to select two different blending modes in the same Blending effect module if you want to export your
project to both a Bitmap or a SWF movie with different results.
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Blur Directional (PRO)

The Blur Directional effect creates the effect of a motion blur that pulls and smears the image from one contour edge
to a different direction or angle. This effect is useful in creating the impression of speed, such as the streaks of colour
that follow a car traveling at high speed.

Use the Blur Directional editor to control the settings of the Blur Directional effect.

•

•
•

•

Truck Factor: Activated by default, this option readjusts the blur when the elements undergo a change of
depth or scale. When this option is disabled, the effect’s values will remain unchanged regardless of any
depth or scale changes. We recommended that this option be disabled when multiple drawings are
composited and attached to this effect.
Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur radius
is affected by the drawing scale and camera position.
Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value between 0 and
1.
D A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.
D A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.
Angle: The direction of the blur. Enter a value from 0 to 360.
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D
D
D
D

•
•
•

0: blurs the image to the west.
90: blurs the image to the south.
180: blurs the image to the east.
270: blurs the image to the north.
Direction of trail: If you do not set an Angle for the direction of the blur, you can select a direction (north,
south, east, or west) from this menu. The calculations for this feature are faster than the calculations for the
Angle setting.
Ignore Alpha: This option controls the leading edge of the blur. Deselect this option for a solid or hard
leading edge on the blur.
Extra Final Blur: This option causes the software to apply a second blur after the Blur Directional is created.
If you have a Blur Directional that begins at 0 and gradually gets stronger, disable this option to ensure a
smooth progression.

Blur Radial (PRO)

The Blur effect creates an effect that softens, fogs or obscures the image evenly in all directions. This effect is useful
when you want to make cloudy images not realistically seen in detail. An example would be a drawing object that is
farther back or in the background of your scene, usually blurry due to the laws of atmospheric perspective. Other uses
include the general softening of objects such as snow, stars and shadows that do not naturally have a hard outline.

Use the Blur editor to change the values of the Blur effect.

•
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Truck Factor: Activated by default, this option reads only the blur when the elements undergo a change of
depth or scale. When this option is disabled, the layer’s values will remain unchanged regardless of any
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•
•

depth or scale changes. It is recommended that this option be disabled when multiple drawings are
composited and attached to this effect.
Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur radius
is affected by the drawing scale and camera position.
Quality: Select High for a slow and accurate operation or Low for a faster operation with a more raw look.

Blur Variable (PRO)

Use the Blur Variable to create a radial blur that varies within a single image based on the white and black values in
the matte you supply. You can set one blur value for the black regions in the matte, and another blur value for the
white regions. The blur value for each grey region is interpolated between your black and white blur settings.
The following example is a network for a variable blur effect. A black and white copy of the character was used to
create the effect you see.

Use the Blur Variable editor to control the blur value for the white and black radius.

•
•
•
•

Black radius: The amount of blur to apply to the black (transparent) values in the matte. Higher values
create more blur in the colour image’s regions that correspond to the black matte region.
White radius: The amount of blur to apply to the white (opaque) values in the matte. Higher values create
more blur in the colour image’s regions that correspond to the white matte region.
Quality: Select High for a slow and accurate operation or Low for a faster operation with a more raw look.
Keep inside source image: This option confines the blur to the source image.
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Brightness and Contrast (PRO)

The Brightness and Contrast effect is used to modify the brilliance or dullness of an image or to create a greater
difference between the lights and darks of an image by increasing their respective intensities. This effect can be used
when an image appears to flat. Pumping up the brightness or contrast can give a drawing a more attractive and 3D
quality. This can be useful if you want to push your background to the rear by making it look dull and flat and pulling
your foreground elements to the front by giving them a higher contrast.

Use the Brightness and Contrast editor to change the values of the Brightness and Contrast effect.

•
•
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Brightness: A value that is less than 0 will darken the image; a value greater than 0 will brighten it. Attach a
Bezier or Ease function to change the brightness over time.
Contrast: A value that is less than 0 will reduce contrast; a value greater than 0 will increase contrast. Attach
a Bezier or Ease function to change the contrast over time.
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Channel Selector (PRO)

Use the Channel Selector effect to isolate one of the four colour channels of an image:

RED

GREEN

BLUE

ALPHA

Use the Channel Selector editor to choose which channel to isolate.
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Colour Art (PRO)

Use the Colour Art effect to isolate the Colour Art in a layer. Placing a Colour Art module after a Drawing module in
the Network view only displays the Colour Art output. The Colour Art module can only be connected after a vector
Drawing layer or a vector type Composite module. Any bitmap information will not be processed.
This effect will only work if the user drew or painted something into the Colour Art layer of the drawing.

Use the Colour Art editor to control how the module renders the Colour Art.

•

•
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Antialiasing Quality: Smoothness setting applied to Colour Art. Choose from Low (no antialiasing),
Medium Low, Medium and High (extensive antialiasing). The higher the setting, the greater the amount of
antialiasing applied. Higher quality images require more time to render and more memory from your
system. Use a lower quality when rendering a pencil test.
Antialiasing Exponent: Controls the extent of the area around the Colour Art edges that is used in the
antialiasing process. A higher value uses less area, resulting in sharper edges, while a lower value uses more
area, resulting in softer edges. If the Antialiasing Quality value is set to Low (no antialiasing), this value is
ignored.
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Colour Card (PRO)

The Colour Card is a solid background the same size as the camera. The Colour Card can be used to fill the scene’s
background with a solid colour when there is no background image. If no background or colour card is added to the
scene, the resulting export will appear with a black background.

Use the Colour Card editor to change the colour values.

This bar indicates the card
colour. Click on the bar to
change colour.

•
•
•

Depth: Animate Pro uses the Depth value to determine composition order when the Z value of two
elements is the same.
Offset Z: Enter the front-back position of the Colour Card layer in 3D space. This value can be verified in
the Top view.
Red/Green/Blue/Alpha: In these fields you can enter a static value for a colour and transparency of the
Colour Card or you can attach these parameters to function columns to change their values over time.
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Colour Override (PRO)

The Colour Override processes the colours in a drawing layer. The drawings in this layer must be TVG files.
Using this effect you can change colours from the palette without affecting the actual palette, swap clone palettes,
replace a specific colour zone with a bitmap texture or hide and display selected colours.

Use the Colour Override effect to:

•
•
•
•
•
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Change colour values in drawings during the compositing process.
Use colour values from a specific colour palette in the palette list.
Establish the priority of override palettes in the palette list. For example, you may have different clones of
the same palette, for example a daytime and nighttime version.
Isolate specific areas of a drawing by selecting certain colours. For example, using specific colours to
generate a matte for a glow effect.
Hide certain colours.
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Use the Colour Override editor to set the colour override operations for TVG elements and their drawings.

•

Palettes: This section displays the palettes in the palette list of the layer connected to the effect. Select and
drag these palettes into the Palette Overrides section to re-order them. You can load additional palettes in
the palette list from either your project, by clicking on the Palette

•
•

•

button, or your computer by clicking

on the Browse
button.
Colours: This section displays the colours swatches of the selected palette. Drag a swatch into the Colour
Overrides section to change its value or drag it into the Selected Colours section to render only that colour.
Palette Overrides: This section forces the use of a particular palette or palette list order, during the
composition process. You must drag palettes from the Palettes section to change their order. Animate Pro
searches the palettes in the order that they appear in the palette list to find the colour values associated
with the colour IDs of each image. To apply a different version of a colour palette, for example to switch
from a day to a night palette, use the override section to change the order of colour palettes (you must be
working with cloned palettes).
Colour Overrides: Drag a swatch from the Colours section to this section to override its value. You can also
override a colour with a texture.
Once the swatch appears in the Colour Overrides section, right-click (Windows) or [Ctrl]+click (Mac OS X)
on the Override Colour word and select one of the following options in the drop-down menu:
D Colour not visible: renders the selected colour invisible in the Camera view.
D New RGB only: Overrides the colour swatch while maintaining its original alpha value. You can select a

D

new colour by pressing the eye dropper
button and choosing a new colour from the Colour Picker
window. The new colour swatch will appear under the newRGBA column.
New alpha only: Overrides the swatch’s alpha channel while maintaining its original RGB values. You
can select a new alpha value by pressing the eye dropper
button and choosing a value from the
Colour Picker window. The new colour swatch will appear under the newRGBA column.

D New RGBA: Overrides the swatch’s colour and alpha values and uses the eye dropper
D

button to
pick a modified selection from the Colour Picker window.
Texture – original matrix: Overrides the swatch’s colour with a pattern or texture. You must right-click
(Windows) or [Ctrl]+click (Mac OS X) under the Texture header to bring up the Browser window to
search for your texture. The texture’s default matrix (fixed proportion and orientation) is mapped the
full size of the bounding box of each colour area to be overridden.
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D Texture – global bbox matrix: Overrides the colour with a texture that is scaled non-proportionally to

•

the size of the bounding box encompassing the colour areas to be overridden. With multiple objects, it
will look as though their fills were all traced and cut from the same piece of stretched or squashed
fabric.
D Texture – global bbox centred: Overrides the colour with a texture that is scaled proportionally to the
size of the bounding box encompassing all colour areas to be overridden. With multiple objects, it will
look as though their fills were all traced and cut from the same piece of fabric.
D Texture – contour bbox matrix: Overrides the colour with a disproportionally scaled texture for each
individual colour area. In other words, each fill area will not only have the texture scaled to its individual
proportions, but also stretched or squashed to fit within its contours.
D Texture – scale to screen: Disproportionally scales the texture to the output resolution before applying
it as an override.
Selected colours: Use this section to select swatches to render.
D Render selected only: Use this option to render only the colours you select in this section.

Colour Scale (PRO)

The Colour Scale effect offsets an images colours. This effect is useful in creating ambient transitions, such as from
daytime to nighttime.

Use the Colour Scale editor to set the colour scale effect by entering a value in the scale fields.
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The actual colour values of the image are not changed; instead, the channels are multiplied by a selected amount. For
example:

•
•
•

If you enter a value of 1, the colour values do not change.
If you enter a value greater than 1, you increase the colour channel value closer to 255 (or white).
If you enter a value less than 1, you decrease the colour channel value closer to zero (0 or black).

You can set the colour scale value by entering a value in the field. You can also change the values of the colour scale
effect over time by attaching it to a Bezier or Ease function curve

and adding keyframes.

Colour Screen (PRO)

You can filter out specific colours from a bitmap image by using the Colour Screen effect. This module is usually used
to matte out a particular colour from a three-channel image.
For example, use the module to make a blue screen background transparent behind a live-action element or to create
transparency around an overlay. You will not use the Colour Screen module to screen out colours in vector images.
The colours can be screened-out based on their colour palette values by using the Colour Override effect.

Use the Colour Screen editor to set the RGB of the colour to cut out.

In the Colour Screen editor, set the minimum and maximum values that will be screened out of each channel in a colour
image. The minimum and maximum values range from 0 to 1.
For values ranging from 0 to 255, divide the value by 255 to convert it to a value between 0 and 1. For example, to
screen out the colour value 160, divide this by 255, resulting in a value of 0.6274.
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Composite-Generic (PRO)
During the composition of images, colour and alpha values of an input image are combined with the image
underneath to produce the output image.
Effects modules, like the Tone Module and Highlight Module, can control the colour and alpha composite operations
for you. A Composite Module was created, in which the colour and alpha composite operation are pre-set to the
standard, and more frequently used, composite operations.
You might, however, still want to control the colour and alpha composite operation between two images using the
Composite-Generic Module. The Composite-Generic Module combines two images into one output image. The
image linked to the left port of the module is layered on top of the image in the right port based on the selected
colour and alpha composite operation.

Use the Composite-Generic Module Editor to control the calculation of colour and alpha values during the
composition process.

The following abbreviations are used in the descriptions of composite operations:

•

•
•
•
•
•
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ORGB: RGB values of the Output Image
The Output Image is the resulting image from a composite operation. In the formulas for the composite
operations, this image is also processed through a composite operation, representing the bottom layer in
the composited image.
LRGB: RGB values of the Left Image
RRGB: RGB values of the Right Image
LA: Alpha of the Left Image
RA: Alpha of the Right Image
OA: Alpha of the Output Image
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Colour Operation
During this operation, the colour values of the output image are determined based on the alpha and colour values of
the left and right image.

•
•
•
•

•
•

•

•

•

•

•
•
•

•

Left: The colour values in the output image are derived from the image in the left port. Colour values in the
right port are ignored.
Right: The colour values in the output image are derived from the image in the right port. Colour values in
the left port are ignored.
Apply Add: ORGB=RRGB+LRGB. This operation uses the transparency and colour value of the left image
to determine the output values. Effects such as shadows and glows are calculated in this manner. Unlike the
Apply Tone Highlight operation, the result is not clipped to the matte (RA) of the output image.
Apply Matte For Overlay: ORGB=RRGB*(1-LA).This operation prepares the output image using the
overlay’s matte; the matte’s RGB values are ignored. This operation prepares the output image to receive
the colour portion of the overlay. It is typically used when an overlay and its matte are stored in separate
images.
Apply Multiplicative Tone: ORGB=RRGB*(LRGB+1-LA). This operation multiplies the left and right images
(see the Multiply colours selection), to be combined with the right image colour, creating a darker output
colour.
Apply Overlay Into Matte: ORGB=RRGB+(LRGB*RA). This operation maps an overlay into an area
prepared by a matte. It is typically used when an overlay and its matte are stored in separate images, and
Apply Matte For Overlay has been used to prepare the output image to receive the RGB portion of the
overlay.
Apply Tone Highlight: ORGB=RRGB+(LRGB*RA). This operation restricts the output of the tone to the
region of the matte (RA), and uses the transparency and colour value of the input image to determine the
colour values of the output. This is used to lighten or darken the output image. Darkening occurs when
RRGB contains negative values.
Apply Transparency: ORGB=RRGB*(1-LA). This operation is used for a cutter matte to prepare the output
image to receive the colour values of another image. It has the effect of increasing the transparency of
ORGB (but not OA), based on the LA. This function is the equivalent to Apply Matte for Overlay. It is almost
always used with Apply Transparency Matte, an Alpha Composite Operation.
Apply With Alpha: ORGB=[RRGB*(1-LA)]+LRGB. This is a standard composite operation called “alpha
blending”. During this operation, colour values of the left and right images are combined based on the
alpha value of the left image. Where the left image is completely opaque (LA=1), the ORGB will be
replaced completely with LRGB. Where the left image is completely transparent (LA=0), the ORGB is
unaffected. Where the left image is partially transparent, you get a blend of the RRGB and the LRGB, where
the values are added together and clipped to 255. The LA is the opacity of the left image. This operation (1LA) calculates the amount of opacity to retain in the output image. The operation [RRGB*(1-LA)] removes
as much of the output image as you are about to add from the left image. Remember that LRGB has been
pre-multiplied by the LA, so the equation is really ORGB=[RRGB*(1-LA)]+(LRGB*LA), which is simply the
weighted average of L and R, with LA supplying the weight.
Multiply Colours: ORGB=RRGB*LRGB. This operation multiplies the left and right image colours.
Multiplying colours filters the colour values of the right image from the output image. For instance, to make
the left image less blue, you can add a right image to this module with a blue colour value and select this
option. This effect created by this operation is identical to the Multiply Colour Blending effect in
Photoshop.
Divide Colours: ORGB=RRGB/LRGB. This operation divides the right image colour values by the left colour
values. The left image colour values are inverted, creating a negative image (1/LRGB). The negative’s colour
values are then multiplied by the right image colour values.
Lighten: This operation looks at the colour information coming from both the images in the left and right
ports and selects the base or blend colour—whichever is lighter—as the result colour. Pixels darker than the
blend colour are replaced, and pixels lighter than the blend colour do not change.
Softlight: This operation darkens or lightens the colours in a soft and diffuse way, depending on the blend
colour (image in left port). If the blend colour is lighter than 50% grey, the image is lightened. If the blend
colour is darker than 50% grey, the image is darkened. Painting with pure black or white produces a
distinctly darker or lighter area, but does not result in pure black or white.
Hardlight: This operation multiplies or screens the colours of the image in the left port with those of the
image in the right port, depending on the blend colour. If the blend color (left port image) is lighter than
50% grey, the image is lightened, as if it were screened. This is useful for adding highlights to an image. If
the blend colour is darker than 50% grey, the image is darkened, as if it were multiplied. This is useful for
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•

adding shadows to an image. Painting with pure black or white results in pure black or white. Play with the
Opacity value to create a subtler look.
Overlay: This operation multiplies or screens the colours from the image connected to the left port, with
those on the right, depending on the base colour. Colours from the left-port element overlay the colours of
the drawing elements connected to the right, while preserving the highlights and shadows of the base
colour. The base colour is not replaced, but mixed with the blend colour to reflect the lightness or darkness
of the original colour.

Alpha Operation

•
•
•
•
•

•
•
•

Right: The transparency of the output image is derived from the alpha values of the image in the right port.
The values in the left port are ignored.
Left: The transparency of the output image is derived from the alpha values of the image in the left port.
The values in the right port are ignored.
Apply: OA=[RA*(1-LA)]+LA. This operation computes the output alpha of the output image based on the
alpha values of the left and right images. This is the standard method of combining alpha channels. Notice
its similarity to the Apply With Alpha colour Composite Operation.
Add: OA=RA+LA. This operation adds the alpha values of the two images to produce the alpha value of
the output image.
Subtract: OA=RA-LA. This operation subtracts the alpha values of the input image from the alpha values of
the output image. It is useful in situations where two tone levels have been drawn with overlap, but a
double-darkening in the overlap is not wanted. This operation will reduce the opacity of overlapping
regions.
Apply Transparent Matte: OA=RA*(1-LA). This operation is used to increase the transparency of the
output alpha in the final composited image.
Black: OA=0. Sets the matte of the entire output image to black, so that it is transparent.
White: OA=1. Sets the matte of the entire output image to white, so that it is opaque.

Output Z

•
•
•
•
•
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Leftmost: Indicates that the Z value for the output image will be taken from the module in the left port.
Rightmost: Indicates that the Z value for the output image will be taken from the module in the right port.
Backmost: Indicates that the Z value for the output image will be taken from the image that is the farthest
back in the scene.
Frontmost: Indicates that the Z value for the output image will be taken from the image that is closest to
the front of the scene.
Portnumber: Indicates that the Z value for the output image will be taken from the module in the selected
port. Enter the appropriate port in the Port For Output Z field.
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Contrast (PRO)

Use the Contrast effect to increase or decrease the level of contrast in an image. This is done by changing the contrast
in the dark and bright pixels and setting the transition point between dark and bright.

Use the Contrast editor to control the output of the module.

•

•

Mid Point: The value that separates dark from bright colours. The midpoint is a value between 0 and 1 that
represents the percentage of the 0 to 255 RGB channel range.
D Pixels with colour values lower than the midpoint: These are considered dark pixels.
D Pixels with colour values higher than the midpoint: These are considered bright pixels.
Dark Pixel Adjustment and Bright Pixel Adjustment: The amount of contrast to be applied to pixels that
fall on either side of the Mid Point value.
D A value equal to 1: No change
D A value less than 1: The module makes the pixel colours brighter
D A value greater than 1: The module makes the pixel colours darker

You can enter static values in the dialog box fields or you can attach these values to function curves to change over
time.
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Cutter (PRO)

The Cutter cuts out a portion of an image using a matte drawing. You can use the Cutter to allow a character to
disappear behind a background element or to cut a virtual hole into the layer itself. The Cutter requires a matte input.

Use the Cutter editor to invert the effect of the matte on an image. Instead of the object being hidden by the mask,
it will only be visible where it intersects with the matte shape area.
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Dither (PRO)

Dithering is the process of approximating a higher number of colours in a low bit-depth colour system. Use the Dither
effect to give the appearance of greater colour variability in 8-bit per channel colour images.

The Dither effect is useful in the case of a gradient that varies between 100 and 105 in the blue channel, for example.
Since the difference in the colour values is not great, banding might appear in the image. In this case, use the Dither
module to give the impression of greater values of blue, decreasing the unwanted banding effect.
The results of the dither operation may be imperceptible.
Use the Dither editor to control the dithering effect.

•
•
•

Magnitude: A magnitude of 1 performs a normal dithering operation, using all bands of colour. A
magnitude greater than 1 introduces a bias towards brighter colours. A magnitude of less than 1 creates a
faster transition between bands of colour, lessening the bias towards brighter colours.
Correlate: When selected, the three colour channels (RGB) are changed simultaneously, for better colour
accuracy. When this option is not selected, the three channels are dithered separately, resulting in smoother
transitions.
Random: The standard algorithm for the dithering operation.
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External (PRO)

Use the External module to process images through external programs and input the resulting images back into the
network.

The External Module writes input files to temporary files on the system. It then calls the external program, which will
process the input images. If two images are input into the module, the program must composite them together to
produce one output image. Finally, the file produced by the external program is read back into the network.
The command is sent to the external program in the following format:
program_name file_1 file_2 output_file numerical_param extension
Use the External editor to control the program that is launched by the module, the files that it reads, and the file that
it outputs into the network.

In this example, the ImageMagick 6.3 software was used without a matte connection.
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Use the External editor to write down the parameters matching the chosen external program.

•

•
•

•
•
•

External Program: The name of the program launched by the External module. This field can include a full
or relative path to the executable file. If no path is entered, the user’s path is searched to locate the
program.
Enter the command directly into this field.
For example:
mogrify -spread $NUM $IN1
Where:
D mogrify: Is the name of the program,
D spread: Is the option to be applied,
D and $NUM and $IN1: Are the numerical parameter and first input file variable declared in the External
module.
Program First Input File ($IN1): The name and location of the temporary file that Animate Pro will write
to the file system for the external program to read. It must not include the dot or the extension; the External
module will add these based on the Extension field.
Program Second Input File ($IN2): When processing two files through this module (such as an image and
a matte), this is the name and location of the second temporary file that Animate Pro writes to the file
system for the external program to read. It must not include the dot or the extension; the External module
will add these based on the Extension field.
Program Output File ($OUT): The name and location of the temporary file that the external program will
write to the file system so that Animate Pro can read it back into the network.
Extension ($EXT): The file type that will be processed by the external program.
Numerical Parameter ($NUM): A value passed to the external program as a file processing option. It can
be attached to a function curve to change over time.
The program files are temporary files that are overwritten at each frame as the module is executed. They
are only meant to temporarily store the image that is being processed at each frame.
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Field Chart (PRO)

The Field Chart module displays a field chart which allows you to position elements in the Camera view windows.

Use the Field Chart editor to control the quality and alignment of the field chart that appear in the Camera view.

Drawing

•
•
•
•
•
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Size: The size of the field chart. You can choose either 12 or 16 fields.
Opaque: When selected, the field chart is not transparent. When not selected, the field chart is transparent.
Antialiasing Quality: Smoothness of the field chart image. Choose from Low (no antialiasing), Medium Low,
Medium and High (extensive antialiasing).
Antialiasing Exponent: Controls the amount of area used in the antialiasing process. If the Antialiasing
Quality is set to Low, this value is ignored.
Alignment Rule: The alignment rule selections determine how the field chart is positioned. If you select
Turn Before Alignment, the field chart is first rotated, then scaled based on the option selected from the
drop-down list. The field chart is then scaled to match the alignment rectangle.
D Left: Aligns the field chart on the left side of the scene’s alignment rectangle. Animate Pro scales the
field chart’s height to match the height of the alignment rectangle of the scene.
D Right: Aligns the field chart on the right side of the alignment rectangle. Animate Pro scales the field
chart’s height to match the height of the alignment rectangle of the scene.
D Top: Aligns The field chart on the top of the alignment rectangle. Animate Pro scales the field chart’s
width to match the width of the alignment rectangle of the scene.
D Bottom: Aligns the field chart on the bottom of the alignment rectangle. Animate Pro scales the field
chart’s width to match the width of the alignment rectangle of the scene.
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D Centre Fit: Centres the field chart.
D Centre Fill: Centres the field chart and then scales it so that the width or height fills the available space.
D Centre LR: Animate Pro scales the field chart’s height to match the height of the alignment rectangle of
the scene.

D Centre TB: Animate Pro scales the field chart’s width to match the width of the alignment rectangle of
the scene.

D Stretch: Scales the field chart so that it fits within the alignment rectangle of the scene. This setting
may distort the field chart.

D As Is: Leaves the field chart aligned as it is.
D Centre First Page: Scales the field chart to match the centre of the first part of a standard pan cel with

•
•

the centre of the field chart.
Turn Before Alignment: Rotates the field chart 90 degrees left before scaling and aligning it according to
the alignment rule, and before performing any offset, rotation or scaling on the field chart or the peg.
Depth: Use this value to override the order of cables in the network to determine how this element is
rendered.

The Position tab is used to position and animate the Field Chart. You can create a function curve and add keyframes
on it to animate the grid over time.
Refer to Creating Animation Paths > Layer Parameters, on page 590 to learn more about these parameters and
how to animate your Field Chart.
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Focus (PRO)

Use the Focus effect to set up depth-of-field effects for your scene. The Focus module is used to determine how much
blur will be applied to images, based on their distance from the focal point.
The focal point can be the zero value of your scene or you can link the Focus module to another module, such as a
Drawing or Peg layer, to retrieve the focal point from the module’s Z-axis position.

Use the Focus editor to determine how the focus will change as objects move farther from the focal point.

•
•
•
•

Mirror: Select this option to also blur images in front of the focal point.
Mirror Front/Back Ratio: When the Mirror option is selected, this ratio is applied to the calculation of the
blur on images in front of the focal point. The default ratio of 1:2 produces realistic results. Experiment with
different values to create customized effects.
Radius: Controls the amount of blur applied to an element based on its distance from the focal point. Click
on the Edit Curve button to change these values.
Quality: Controls the quality of the blur. A higher quality will achieve better results but will be slower to
render.

In the Side view window, you can see how the blur values change based on their distance from the focal point. Select
the Focus module in the Network view, then right-click on the Side view window and select Control from the pop-up
menu.
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Focus Multiplier (PRO)

The Focus Multiplier effect works with the Focus effect. This module applies a blur to the selected layer, based on the
blur radius in the Focus module.
Use the Focus Multiplier module when you want to apply the focus to selected elements or when you need to apply
the focus before doing more effects in a composite operation.

You must disable the Apply Focus option in the Composite module in order to apply the focus effect to the selected
module only. If you do not disable that option, the focus effect will be calculated twice on the selected module.
Use the Focus Multiplier editor to multiply the Focus Radius by a selected value. You can enter a static value in the
Multiplier field or attach it to a function curve.
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Glow (PRO)

The Glow effect adds a soft-edged bright light or diffused light region around an image. The Glow effect is useful in
creating a shining rim around objects such as the sun or stars.

Use the Glow editor to control the direction of the blur that creates the glow, as well as its colour.

•

•

•
•
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Truck Factor: Activated by default, this option readjusts the blur when the elements undergo a change of
depth or scale. When this option is disabled, the effect values remain unchanged regardless of any depth or
scale changes. It is recommended that this option be disabled when multiple drawings are composited and
attached to this effect.
Blur Type (Directional or Radial):
D If Directional is selected, the software will blur the matte in the direction you select. For example, if a
character is walking east, the blur may fall to the west.
D If Radial is selected, the software will blur the edges of the matte evenly around points that make up its
edge.
Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur radius
is affected by the drawing scale and camera position.
Directional Angle: If you select a Blur Directional Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.
D 0: blurs the image to the west.
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D 90: blurs the image to the south.
D 180: blurs the image to the east.
D 270: blurs the image to the north.

•

•
•
•
•

Directional Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.
D A fall-off rate of zero causes the blur to fade out slowly, distributing the blur evenly from the edge of
the character to the farthest edge of the blur.
D A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.
Invert Matte: Activate this option to invert the matte used to create the glow. Your matte will become a
black silhouette while the glow will fill the background space.
Use Source Colour: Select this option to use the colours painted in the matte for the glow effect. If you
deselect this option, select a colour and alpha values in the Colour section.
Multiplicative: Select this option to multiply the glow colour to the drawings and background behind rather
than blending it. Each zone will react differently to the highlight colour rather than becoming uniformly
brighter.
Colour: Where you can choose the colour and alpha values for the glow effect.

NOTE: If this effect is connected below a Composite module set to Pass-Through, the effect will be applied to
each element connected in the Composite individually. If some of these elements are overlapping, the effect will also
overlap.

Glue (PRO)

Toon Boom Animate Pro uses the glue effect to fill in the missing artwork in a joint between two vector drawings. The
glue joint is done in two steps. The first is to prepare the artwork and the second is to add the Glue effect.
NOTE: The glue effect is really useful and avoids losing time creating perfect joints or extra patches, but this can
produce a large file during the animation process. Since it is an effect, the system needs to continually perform
calculations. Also, as it produces computer generated artwork, the user has less control over the final result.
For some designs, the pencil line gives a better result for glue joints, but generally the brush lines and colour fills done
in Line Art mode work very well.
Before starting your glue joint, we recommend that you put all of the part’s artwork in the same drawing. In other
words, the upper arm and the forearm should be in the same drawing and flattened. It is very important to have a
perfect straight cut between the two parts of the joint.
To create a glue joint:
1.
2.

In the Camera view, create your drawing.
In the Tools toolbar, select the Select tool. The default keyboard shortcut is [Alt]+[V].
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3.

4.
5.
6.

7.
8.
9.

In the Camera or Drawing view, select your drawing.

In the Tools Properties view, click on the Flatten button.
In the Tools toolbar, select the Cutter tool.
In the Drawing or Camera view, cut the part in two pieces at the joint height.
 Using the Cutter tool, select the piece to cut (the one that was previously copied and pasted in the drawing)
click on one side of the joint and drag the tool across the area that you want to select. This will create a
straight cut.

Select Edit > Cut Drawing Object. The default keyboard shortcut is [Ctrl]+[X] (Windows) or [a]+[X] (Mac OS X).
In the Timeline view, select the cell in which you want to paste your selection.(For example: Upper arm)
Select Edit > Paste Drawing Object. The default keyboard shortcut is [Ctrl]+[V] (Windows) or [a]+[V] (Mac OS
X).
10. In the Module Library, select a Glue module and drag it to the Network View.
11. In the Network View, connect both joint parts in the Glue's right ports. Using the [Alt] key, slide the Glue module
between the first part and the Composite module and connect the drawing module in the Glue module's right
port.
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12. Disconnect the second part from the composite module and connect it to the Glue's middle port.

The Glue module should now be connected to the Composite module. The two drawing elements should be
connected in the Glue and not in the Composite module.
13. If the Glue result creates awkward shapes, load one of the parts in the Drawing or Camera View.

14.
15.
16.
17.

Select View > Light Table.
In the Tools toolbar, choose the Select tool.
Select Edit > Select All. The default keyboard shortcut is [Ctrl]+[A] (Windows) or [a]+[A] (Mac OS X).
In the Drawing or Camera View, use the keyboard's arrow keys to nudge the artwork to match it perfectly with
the other joint section.

You can also modify the rotation pivot for a better result.
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For most effects with the Glue module, the default options are sufficient. However, you can modify these options using
the Glue editor.

The Glue editor includes the following options:

•
•
•
•
•
•

•
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Bias: Indicates the tendency to favour the static or moving element. Set to 0, it favours element A; set to 1
it favours element B; set to 0.5 it is in between A and B.
Tension: Indicates how tight the joint will be. Set to 1, the tension has no effect; set less than 1, the tension
decreases; set greater than 1, the tension increases.
Type: From this menu, select the type of joint to create. You can choose from among Curve (default), Line
and Corner.
Use Z for Composition Order: You can use this option to choose the drawing with the higher front-back
value to create the joint.
A Over B: Indicates which image is rendered on top in the final image. By default, A is rendered on top of
B, which indicates that the image in the middle port (A) is rendered on top of the image in the right port (B).
Spread A: By default, the image in port B is spread to fill the joint. You can use this option to choose the
image in the A port to create the joint. If you select this option, the Drawing module must receive position
information from the “B” element. Thus, you must connect the Drawing module of the “B” element to the
Drawing module of the matte.
Invert Matte: Activate this option to invert the matte used to fill the joint. If you want to use the “B”
element as the matte, you must select this element.
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Gradient (PRO)

Use a Gradient effect to create a transition of colour or alpha values between two areas of colours. Use two points to
indicate where those two coloured areas are. You can then move these points to create the transition.

Use the Gradient editor to control the values of the gradient and the position of its output.

•

•
•
•

Point 0, Point 1: These sections control the values of the first point (point 0) and the second point (point 1)
in the gradient.
D 2D Path: Change the position of the point by attaching it to a 2D path, which can also be used to affect
how quickly the position of the point changes.
D Separate: Change the X and Y values of the point on independent function curves.
Red/Green/Blue/Alpha: The colour and alpha values of the selected point.
Offset Z: This value determines the position of the gradient on the Z-axis. Positive values will move the
gradient forward and negative values will move it backward.
Depth: Enter a value to control the composition order of the output.

You can also use control points to distort and reposition the gradient manually in the Camera view.
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To edit the Gradient in the Camera view:
1.
2.

In the Timeline view, click on the Gradient layer to select it.
Select View > Show > Control. The default keyboard shortcut is [Shift]+[F11] (Windows).

3.

The gradient handles appear as two red squares.
In the Camera View, use the Transform tool to move the points on the gradient effect. [Shift]-click to select
multiple points.

Grain (PRO)

Use the Grain effect to add a film grain to an image; the film grain looks like video noise.

The Grain module has two input ports.

•
•

On the left port, attach the element that will act as the matte defining the grain area.
On the right port, attach the element on which you want to apply the grain effect.

Use the Grain editor to adjust the amount of grain to add to an image; you can also use it to adjust the sharpness or
softness of the grain.
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•
•
•
•

Noise: The amount of grain to add to the image based on the percentage of pixels to alter. The larger the
value, the courser the grain. The smaller the value is to 0 (zero), the finer the grain.
Smooth: The amount of blending to apply to the grain effect, based on the blur radius, to make the effect
appear less pixelated. The larger the value, the greater the smoothing.
Random At Each Frame: Computes the colour shift in the grain using a different value at each composite.
This means that your images will look different each time you render them. Deselect this option and select a
Seed Value to ensure the same result every time you composite the grain effect.
Seed Value: This value corresponds to a unique pattern in the grain. If you want to retain this pattern in
other frames, you can reuse this value.

Greyscale (PRO)

Use the Greyscale effect to convert a colour image to greyscale. This example demonstrates what happens when you
set the greyscale to 100% using the Greyscale module. The Contrast module can also be used to adjust the darkness
and lightness of the pixels in your element.

Use the Greyscale editor to enter the percentage of black and white to apply to the image. You can enter a static value
in the Percentage field or attach the value to a function curve to change over time.
Use these menus to create a function
curve and attach the Greyscale values
to a function curve.

•

Matte Output: When this option is activated, the colour values do not change. However, alpha values are
read from the colours which you can see in the Camera view Matte View mode.
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How to use the Matte Output Option
You can see in this section a concrete example on how to use the Matte Output option of the Greyscale module. We
created a frosted window using a snowflake image over a blue rectangle and a colourful background.
Here are the three drawings used for the example:

When the snowflake image is connected into the Greyscale module, it turns into a greyscale image. There is no
transparency visible in the Camera view Matte View mode.

Camera View Render Mode

Camera View Matte Mode

When the Matte Output option is enabled, the snowflake image colours are displayed as normal, but when the Matte
View mode of the Camera view is enabled, you can see the transparency levels generated from the colour values.

Camera View Render Mode

Camera View Matte Mode

When you connect the Snowflake images into a Cutter effect’s Matte port along with the Window images, the Window
will be semi-transparent, matching the alpha (transparency) channel generated by the Greyscale module.
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Highlight (PRO)

Use the Highlight effect to simulate a light source by making an area of a drawing lighter. To produce the highlight
effect, you must draw a shape to control where the highlight will appear on the original drawing.

The Highlight effect uses a matte to determine the shape and position of the highlight on another element and can
blur the edges to create a softer effect. Use the Highlight editor to control the type and amount of blur, as well as the
colour of the highlight effect.
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•

•

•
•

•

•
•
•
•
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Truck Factor: Activated by default, this option readjusts the blur when the element undergoes a change of
depth or scale. When this option is disabled, the effect’s values remain unchanged regardless of depth or
scale changes. It is recommended that this option be disabled when multiple drawings are composited and
attached to this effect.
Blur Type (Directional or Radial):
D If Directional is selected, Animate Pro will blur the matte in the direction you select.
D If Radial is selected, Animate Pro will blur the edges of the matte evenly around points that make up
the edge of it.
Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur radius
is affected by the drawing scale and camera position.
Directional Angle: If you select a Blur Directional Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.
D 0: blurs the image to the west.
D 90: blurs the image to the south.
D 180: blurs the image to the east.
D 270: blurs the image to the north.
Directional Fall-off Rate: The distance where the directional blur fades from the edge of the image. Select
a value between 0 and 1.
D A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.
D A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.
Invert Matte: Activate this option to invert the matte used to create the highlight.
Use Matte Colour: Select this option to use the colours in the matte for the highlight effect. If you deselect
it, use the Colour section to select colour and alpha values.
Multiplicative: Select this option to multiply the highlight colour to your original drawing rather than
blending it. Each zone on the drawing will react differently to the highlight colour rather than becoming
uniformly lighter.
Red/Green/Blue/Alpha: In the RGBA fields, enter the value that you want added to or subtracted from the
colour channels in the drawings. Alternatively, you can attach these values to function columns to animate
them over time.
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Layer Selector (PRO)

Use the Layer Selector effect to isolate and display one or several drawing layers:

•
•
•
•

Overlay
Line Art
Colour Art
Underlay

Use the Layer Selector editor to select the desired layers.

•

•

Antialiasing Quality: Smoothness setting applied to the selected layers. Choose from Low (no antialiasing),
Medium Low, Medium and High (extensive antialiasing). The higher the quality of the chosen setting, the
greater the amount of antialiasing that is applied. Higher quality images require more time to render and
more memory from your system.
Antialiasing Exponent: Controls the amount of area around the selected layers edges that is used in the
antialiasing process. A higher value uses less area, resulting in sharper edges, while a lower value uses more
area, resulting in softer edges. If the Antialiasing Quality value is set to Low (no antialiasing), this value is
ignored.
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Line Art (PRO)

Use the Line Art effect to read only the Line Art in an element. Place a Line Art module after a Drawing module in the
Network view to display only the module’s Line Art output. The Line Art module can only be connected after a vector
Drawing layer or a vector type Composite module. Any bitmap information will not be processed.
This effect will only work if the user drew or painted something into the Line Art layer of the drawing.

Use the Line Art editor to control how the Line Art is rendered by the module.

•

•
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Antialiasing Quality: Smoothness setting applied to Line Art. Choose from Low (no antialiasing), Medium
Low, Medium and High (extensive antialiasing). The higher the quality of the chosen setting, the greater the
amount of antialiasing that is applied. Higher quality images require more time to render and more memory
from your system.
Antialiasing Exponent: Controls the amount of area around the Line Art edges that is used in the
antialiasing process. A higher value uses less area, resulting in sharper edges, while a lower value uses more
area, resulting in softer edges. If the Antialiasing Quality value is set to Low (no antialiasing), this value is
ignored.
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Matte Blur (PRO)

Use the Matte Blur effect to blur a matte or change its colour. Here is an example of a network with the result of a
Matte Blur effect.

Use the Matte Blur editor to control the output of the module.

•

•

Truck Factor: Activated by default, this option readjusts the blur when the element undergoes a change of
depth or scale. When this option is disabled, the module’s values remain unchanged regardless of depth or
scale changes. It is recommended that this option be disabled when multiple drawings are composited and
attached this module.
Blur Type (Directional or Radial): If Directional is selected, Animate Pro will blur the matte in the direction
you select. If Radial is selected, Animate Pro will blur the edges of the matte evenly around points that
make up the edge of the matte.
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•
•

•

•
•

Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur radius
is affected by the drawing scale and camera position.
Directional Angle: If you select a Directional Blur Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.
D 0: blurs the image to the west.
D 90: blurs the image to the south.
D 180: blurs the image to the east.
D 270: blurs the image to the north.
Directional Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.
D A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.
D A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.
Invert Matte: Activate this option to invert the matte used to create the blur.
Red/Green/Blue/Alpha: In the RGBA fields, you can enter the value you want added to or subtracted from
the colour channels in the drawings. Alternatively, you can attach these values to function columns.

NOTE: If you select the Pass Through option in the Layer Properties of a Composite where this effect is
connected, the effect will be multiplied in areas where the drawing elements that the effect is acting on overlap.
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Matte Resize (PRO)

Use the Matte Resize effect to evenly expand a matte outward in all directions. The Matte Resize module increases
the size of a matte from its centre. Here is an example of a network with the result of a Matte Resize effect.

If you use the Matte-Resize module to create a pulsating glow you can enlarge the region without softening the edges.
Using the Blur Radial effect, the effect may be softer than you intend. This module produces a limited antialiased
matte, which can have slightly jagged edges. You could use this module in combination with other modules, such as:

•
•
•
•
•

Tone
Highlight
Glow
Shadow
Matte Blur

In the Matte Resize editor, you can enter a static value for the Radius of the resize operation. You can also attach the
Radius value to a function column to change the value over time.
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Motion Blur (PRO)

The Motion Blur effect is used to create a faded trail behind objects animated on a motion path. The layer must be
moving along a trajectory (motion path) in order to work properly.

The Motion Blur effect automatically creates a matte for the Drawing layer attached to it, so it is not necessary to
connect any matte into the Mask layer.
Use the Motion Blur editor to modify the motion blur. You can also use the Motion Blur parameters to create a crowd
simulation or particle system effect. Refer to the Particle Effect, Crowd Simulation and More (PRO) topic to learn how.

•
•
•
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Number of Frames in Trail: Number of frames before the current frame that will be used in the trail.
Number of Samples: Number of copies of each drawing used in the trail. The higher the number, the more
continuous the trail appears.
Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value between 0 and
1.
D A fall-off rate of 0 causes the trail to fade out slowly, distributing the colour evenly from the edge of the
character to the farthest edge of the trail.
D A fall-off rate of 1 causes the trail to fade out quickly so that the trail is more opaque closer to the edge
of the image and transparent at the end of the trail.
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•
•

Intensity: Select a value to define the opacity of the trail between 0 and 10. A value of 10 will make the trail
very dark and almost opaque, where as a value of 0 will make the trail quite pale and ghostly transparent.
Use Mirror on Edges: When enabled, this option appears when the image is close to the edge of the
camera frame. It forces the software to use a mirror of the image to calculate the blur so that it appears on
both sides of the drawing object. Without this option once your drawing reaches the edge of the Camera
frame, it gets cropped so does the trail.

Multi-Port-In (PRO)
A Multi-Port-In module is added by default in a new Group module. Use it to add one or more input ports to the Group
module so that you can process an image through the modules in the Group module.

When you plug an element to a Multi-Port-In Module, an input port appears at the top of the Group module. You can
add additional ports to the modules as needed.
Pass your cursor over the Group module input port to see the name of the Port Image In module that it connects to.
You will notice that the Group module in these examples has no output port. It requires a Multi-Port-Out module to
output data from its network.
A Multi-Port-In is automatically added when you create a group.
Use the Multi-Port-In Module editor to rename the module.
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Multi-Port-Out (PRO)
A Multi-Port-Out module is added in a new Group module by default. Use it to add output ports to the Group Module
so that you can output the result of the group operation to the rest of the network. After you plug an element to a
Multi-Port-Out module, an output port appears on the bottom of your Group module. You can add additional output
ports as needed.

A Multi-Port-Out is automatically added when you create a group.
Use the Multi-Port-Out editor to rename the module in the network.

Negate Module (PRO)

Use the Negate effect to invert the colour and/or alpha values in the Colour Art and Line Art of an image. The Negate
module subtracts the original value of each channel (RGB or A) from the maximum value of that channel (255 for 8-bit
channels) to produce the negative image.
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Use the Negate editor to select the colour and/or alpha values to invert.

•
•
•

Negate Colour: Inverts the values of the colour channels.
Negate Alpha: Inverts the transparency value (alpha channel).
Negate Colour Clamp to Alpha: Limits the negated area to the alpha channel.

Note (PRO)
The Note module allows you to record any textual information that is relevant to your project. Use its editor to enter
comments, suggestions or reminders. Note modules can be added anywhere in the network, including in groups.

Use the Note editor to add or update relevant notes with any textual information.
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Overlay Layer (PRO)

Use the Overlay Layer effect to read only the Overlay layer in an element. Place a Overlay Layer module after a
Drawing module in the Network view to display only the module’s Overlay layer output. The Overlay Layer module
can only be connected after a vector Drawing layer or a vector type Composite module. Any bitmap information will
not be processed.
This effect will only work if the user drew or painted something into the Overlay layer of the drawing.

Use the Overlay Layer editor to control how the Overlay layer is rendered by the module.

•

•
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Antialiasing Quality: Smoothness setting applied to the Overlay layer. Choose from Low (no antialiasing),
Medium Low, Medium and High (extensive antialiasing). The higher the quality of the chosen setting, the
greater the amount of antialiasing that is applied. Higher quality images require more time to render and
more memory from your system.
Antialiasing Exponent: Controls the amount of area around the Overlay layer edges that is used in the
antialiasing process. A higher value uses less area, resulting in sharper edges, while a lower value uses more
area, resulting in softer edges. If the Antialiasing Quality value is set to Low (no antialiasing), this value is
ignored.
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Particle Effect, Crowd Simulation and More (PRO)

The Motion Blur effect includes a Matte layer allowing you to do advanced effects such as particles. For example, you
could create a snow fall using a snowflake drawing and an animated matte. The matte only has to be composed of a
series of dots that you can animate with a motion path.

Matte

Drawing

Result
The matte operates such that:

•

•

Any point created on the matte that is bigger than one pixel will increase the blur amount of the final
composite as the drawing layer is actually being rendered once for every pixel that exists in an area. As no
pixel exists one on top of another, these drawings are also being slightly offset from one another, which
gives the final result of a blurred effect.
The mask’s alpha of 255 is divided by the number of dots you draw. Therefore if you make nine dots, which
will represent nine different offset positions for your drawing, then the final output’s opacity is being
divided by nine. This means that the more dots you have, the paler they will all appear in the final render. To
compensate, you can increase the Intensity parameter by the number of dots squared, in this case it would
be 23 x 23 or a value of 529.

To create a Particle Effect using the Motion Blur, create a drawing that has different sized dots randomly distributed
over the drawing space. Create the drawing to multiply, such as a snowflake or star, but be sure to draw it in the centre
of the drawing plane. The Motion Blur effect will blur and filter this shape into the size, colour and location of the dots
drawn in the original image. The matte can change form over time to bring the particles to life, or the dot drawing
can be animated, such as in the example of snow, to make it look like it is falling.
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Pixelate (PRO)

Use the Pixelate effect to apply a mosaic effect to an image (and its matte) based on the matte you supply. Pixelation
makes the image look like it is made up of square tiles.

There are two input ports on the Pixelate module:

•
•

The left port receives the matte
The right port receives the image

Use the Pixelate editor to control the amount (Factor) the image is pixelated. You can attach the Factor value to a
function curve to change the value over time.
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Placeholder (PRO)
Use the Placeholder module in a network when you are either unsure of which module you will put in its place or if
you want to lay out a custom network for future use.

Use the Placeholder editor to rename the module.

Quadmap (PRO)

Use the Quadmap transformation layer to deform the shape of an element. For example, you can use it to create a
drop-shadow effect for an element.
You can edit the Quadmap visually in the Camera view.
To edit the Quadmap in the Camera view:
1.

In the Timeline view, click on the Add Layer

button and select Quadmap from the drop-down menu.
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2.

Connect the Quadmap layer to the Drawing layer that you want to deform
In Animate Pro, in the Network view, drag in the Quadmap module from the Module Library and connect it
above the drawing element module that you want the effect to act on.



3.
4.
5.

6.
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In the Tools toolbar, disable the Animate Mode to change the value for the Quadmap over the entire duration of
the element.
In the Timeline view, click on the Quadmap layer to select it.
Select View > Show > Control. The default keyboard shortcut is [Shift]+[F11] (Windows).
The quadmap handles appear around the element in the window. There is also a pivot point at the centre of the
quadmap frame that can be repositioned.
In the Camera View window, use the Transform tool to move the points on the quadmap. [Shift]-click to select
multiple points.
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The value of each point on the quadmap can be changed gradually. To do this, use the Quadmap Layer Properties to
attach the points to function curves.

Only the X and Y values of each point in the quadmap can be changed.

•
•

2D Path: change the X and Y values simultaneously and control the velocity of the change.
Separate: change the X and Y values separately. Each of these can be attached to separate function curves.

Refract (PRO)

Use the Refract effect to create effects such as ripples and heat haze. This effect is based on the refraction of light,
which occurs when a beam of light passes through media of different density, causing the light to refract or change
angles. This effect makes objects appear distorted or offset from their actual positions. If you imagine an object in a
pool of water the part beneath the surface of the water appears offset from its true position.
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To create a refraction effect, you need a matte with alpha values. This creates the effect of a volume passing over an
image, refracting the light that bounces off the contents below. For a ripple effect moving across an image, you must
move the matte with a Peg layer.
If your matte is only black and white, meaning that there is no gradients and only solid colours in your matte drawing,
you will need to connect a Blur Radial module after your matte Drawing module to soften the edges and get nicer
waves.
Use the Refract editor to control the effect.

•
•

Intensity: The amount of refraction to apply to the image.
Height: The amount of depth to add to the refraction effect. When coupled with the Intensity effect, this
value can create the effect of bending the objects below the refraction matte.

Attaching the Intensity and Height values to function curves changes their values over time.

Remove Transparency (PRO)

The Remove Transparency effect negates transparent values in an image. You can use the Remove Transparency
module to remove the result of antialiasing around an image.
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Use the Remove Transparency editor to control the effects of the module.

•
•
•

Threshold: All values above the Threshold represent a transparent value. In this field, you must identify the
value above which all alpha values are considered transparent. Alpha is measured from 0 to 255.
Remove Colour Transparency: When selected, the Threshold value is used to determine which pixels in the
Colour Art (RGB channels) to make fully opaque or fully transparent.
Remove Alpha Transparency: When selected, the Threshold value is used to determine which pixels in the
Alpha channel to make fully opaque or fully transparent.

Shadow (PRO)

With the Shadow effect, you can turn a drawing into a shadow. It does not matter if your drawing layer is a fully
coloured character, the Shadow effect default parameters will render it into a grey, semi-transparent, slightly blurry
silhouette.
To add a shadow stretched out on the ground, simply add a Quadmap module to flip, stretch and skew the matte.
Attach the entire effect to the same trajectory as your drawing layer and watch the shadow move along with your
character.

Use the Shadow editor to modify the way the Shadow effect is created.
The Shadow effect uses the shape of the drawing connected to create the shadow behind another element and can
blur the edges to create a softer effect. You can control the type and amount of blur, as well as the colour of the
shadow, in this dialog box.
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•

•

•
•

•

•
•

•
•

Truck Factor: Activated by default, this option readjusts the blur when the elements undergo a change of
depth or scale. When this option is disabled, the effect’s values remain unchanged regardless of any depth
or scale changes. It is recommended that this option be disabled when multiple drawings are composited
and attached to this effect.
Blur Type (Directional or Radial):
D If Directional is selected, Animate Pro will blur the matte in the direction you select.
D If Radial is selected, Animate Pro will blur the edges of the matte evenly around points that make up
the edge of it.
Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur radius
is affected by the drawing scale and camera position.
Directional Angle: If you select a Directional Blur Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.
D 0: blurs the image to the west.
D 90: blurs the image to the south.
D 180: blurs the image to the east.
D 270: blurs the image to the north.
Directional Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.
D A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.
D A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.
Invert Matte: Activate this option to invert the matte used to create the shadow. In the render mode, the
background will appear grey, while a the matte shape will act as a cut-out window, allowing you to see the
original background colours beneath.
Use Source Colour: Create the shadow using the matte shape’s colour. Be sure that you are in render mode
to see this effect and that your background is NOT white and that you do NOT have a white colour
card module attached to the composite. As the shadow matte only gives colour information, but no alpha,
the matte is automatically multiplied with the background colours. If there is no colour card attached,
therefore the background appears black, you will see the matte colour at full opacity. If it is multiplied with
a white background, the colours disappear into the full 255.
Multiplicative: Select this option to multiply the shadow colour to the drawings and background behind
rather than blending it. Each zone on the drawing will react differently to the shadow colour rather than
becoming uniformly darker.
Red/Green/Blue/Alpha: In the RGBA fields, you can enter the value to add or subtract from the colour
channels in the drawings or you can attach these values to function curves.

NOTE: If this effect is connected below a Composite module set to Pass-Through, the effect will be applied to
each element connected in the Composite individually. If some of these elements overlap, the effect will also overlap.
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Sparkle (PRO)

The Sparkle effect transforms a vector drawing into sparkles. You have a high degree of control over the appearance
of the sparkles.
The sparkle effect can only be used with vector drawings. If the sparkle effect module is attached to a composite,
verify that the Composite editor is set to Vector Flatten Output.

Use the Sparkle editor to modify how the Sparkle module creates the sparkle effect. You can also use Bezier and Ease
function curves to change the values of factors over time.

•
•

Start Angle: Enter a value between -360 and 360 to indicate the angle of rotation of each sparkle.
Scale: Sparkles are determined by the size of the bounding box of the coloured areas in the drawing. Enter
the multiple to use to scale the sparkle size.
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•
•
•
•
•
•
•
•
•
•
•

Factor: Enter a value between 0.1 and 1 to determine how pointy the sparkle is. A value closer to 0 will
result in a more pointed sparkle. A value closer to 1 will result in a more rounded sparkle.
Density: Adjusts the density level.
Number of Points: Enter the number of points you want each sparkle to have.
Probability of Appearing: Enter the percentage of possibility that sparkles will be displayed. Enter 100 to
always show sparkles. Enter 0 to always hide sparkles.
Point Noise: Enter a value between 0.1 and 1 to indicate the amount by which points in a sparkle will
distort.
Centre Noise: Enter a value between 0.1 and 1 to indicate the amount by which the angles between each
point in a sparkle will distort.
Angle Noise: Enter a value between 0.1 and 1 to indicate the amount by which the Start Angle in a sparkle
will distort.
Random Seed: Enter a positive integer value that will be used to determine the sparkle pattern.
Use Drawing Colours: Select this option to use the colour attributes of the drawing for the sparkle colour.
When this selection is disabled (default setting), the colour values will be used as they are entered in the
editor.
Flatten Sparkles of Same Colour: Flatten all drawings of the same colour into a single layer.
Red/Green/Blue/Alpha: In the RGBA fields, enter the values to use for the sparkle colour.

Tone (PRO)

Use a Tone effect to add a dark coloured region to your drawing and simulate the shaded area away from a light
source. To produce the tone effect, create a drawing to control where the tone will appear. The Tone effect uses a
matte to determine the shape and position of the tone on your drawing and can be blurred at the edges to create a
softer effect.

Use the Tone editor to control the type and amount of blur, as well as the colour of the tone.

806

Chapter 16: Enhancing With Effects Using Effects in Animate Pro (PRO)

•

•

•
•

•

•
•
•
•

Truck Factor: Activated by default, this option readjusts the blur when the elements undergo a change of
depth or scale. When this option is disabled, the effect’s values will remain unchanged regardless of depth
or scale changes. It is recommended that this option be disabled when multiple drawings are composited
and attached this effect.
Blur Type (Directional or Radial):
D If Directional is selected, Animate Pro will blur the matte in the direction you select.
D If Radial is selected, Animate Pro will blur the edges of the matte evenly around points that make up
the edge of the matte.
Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur radius
is affected by the drawing scale and camera position.
Directional Angle: If you select a Directional Blur Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.
D 0: Blurs the image to the west.
D 90: Blurs the image to the south.
D 180: Blurs the image to the east.
D 270: Blurs the image to the north.
Directional Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.
D A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.
D A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.
Invert Matte: Activate this option to invert the matte used to create the tone.
Use Matte Colour: Uses the matte shape colour to create the tone.
Multiplicative: Select this option to multiply the tone colour to your original drawing rather than blending
it. Each zone on the drawing will react differently to the tone colour rather than becoming uniformly darker.
Red/Green/Blue/Alpha: In the RGBA fields, you can enter the value you want added to or subtracted from
the colour channels in the drawings or you can attach these values to function curves.
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Transparency (PRO)

The Transparency effect is used to make an image partially transparent. The Transparency effect is useful when fading
images in and out, such as a phantom or to make something partially see-through, such as a window.

Use the Transparency editor to control how transparent the element should be.

You can enter a value in the Transparency field or change the transparency value over time by linking it to a function
curve. Entering a value of one hundred into the Transparency field will make the element 100% transparent, in other
words, invisible. Entering a value of 0 will render the element completely opaque.
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Underlay Layer (PRO)

Use the Underlay Layer effect to read only the Underlay layer in an element. Place a Underlay Layer module after a
Drawing module in the Network view to display only the module’s Underlay layer output. The Underlay Layer module
can only be connected after a vector Drawing layer or a vector type Composite module. Any bitmap information will
not be processed.
This effect will only work if the user drew or painted something into the Underlay layer of the drawing.

Use the Underlay Layer editor to control how the Underlay layer is rendered by the module.

•

•

Antialiasing Quality: Smoothness setting applied to the Underlay layer. Choose from Low (no antialiasing),
Medium Low, Medium and High (extensive antialiasing). The higher the quality of the chosen setting, the
greater the amount of antialiasing that is applied. Higher quality images require more time to render and
more memory from your system.
Antialiasing Exponent: Controls the amount of area around the Underlay layer edges that is used in the
antialiasing process. A higher value uses less area, resulting in sharper edges, while a lower value uses more
area, resulting in softer edges. If the Antialiasing Quality value is set to Low (no antialiasing), this value is
ignored.
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Previewing and Playing Back Effects
To preview your effects, you will have to perform a quick render. Effects must be calculated before they can be viewed
in real-time. You can preview your project either with a bitmap Images Sequence or an SWF quick render.

•
•

Playing Back your Effects with a Bitmap Images Sequence, on page 810
Playing Back your Effects in an SWF Movie, on page 812

Playing Back your Effects with a Bitmap Images Sequence
If you are planning to export your project as a bitmap movie file, you can use the Render and Play feature to preview
the effect as they will appear in the final render.
To preview your effects:
1.

In the Playback toolbar, press the Render and Play

button.

The Play module opens and loads the frames.

2.

Once the frames are loaded, press the Play

button in the Play window.

Preview Resolution
To make your previews calculate faster, you may want to render them out at a smaller resolution. You can use the
Preview Resolution command so you will not have to modify the resolution of your scene every time you make a check
preview.
The Preview Resolution command allows you to quickly ask for a preview at either a quarter, half or three-quarter of
the scene resolution. You can even customize the preview resolution size.
To use the Preview Resolution command:
1.
2.
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In the top menu, select View > Preview Resolution.
From the drop-down menu, select either Same as Scene Resolution, 3/4 of Scene Resolution, 1/2 of Scene
Resolution, 1/3 of Scene Resolution, 1/4 of Scene Resolution or Custom.
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If you selected the Custom option, the Custom Preview Resolution dialog box opens.

3.
4.
5.

In the dialog box, select a resolution from the presets or type a new X-Y value.
Click on the OK button.
Preview your effects animation.
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Playing Back your Effects in an SWF Movie
If you are planning to export your project as a vector-based SWF movie file, you can use the Test SWF Movie feature
to preview the effect as it will appear at the final render.
To preview your effects:
1.

In the Playback toolbar, press the Test SWF Movie

button.

The SWF Export Progress dialog box opens and exports the drawings.

Once the drawing export is completed, the SWF Export dialog box opens.




Click OK to continue and launch the SWF player.
Click Report for more information.

If you clicked on Report, the Export to Flash Movie (SWF) Report dialog box appears displaying information
about the exported video, such as the path, name, size, ratio, frame rate and the status of the SWF effects.

•

Click OK to launch the SWF Player.

If you clicked on OK, the SWF Player is launched and automatically plays your movie.

2.

Use the different buttons to control the play back of the movie.

Note that only the effects which are compatible with SWF will be visible in the preview movie. Refer to the
Exporting Effects to SWF section for a list of these effects.
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Exporting Effects to SWF
Animate offers a lot of possibilities when it come to exporting your projects, such as exporting SWF movies. As SWF
movies are vector based, not all of Animate’s effects are exportable in this format. Here is the list of effects that can
be exported to an SWF movie file along with specifications for some of their parameters.

•
•
•
•
•
•
•
•
•
•
•
•
•
•

•
•

•
•
•
•

Apply Image Transformation
Apply Peg Transformation
SWF Blending
SWF Blending parameters are all supported.
Blur
Camera
Colour Art
Colour Card
Colour Override
Note that the use of textures is not supported for SWF export.
Colour Scale
Note that the HSV values are not supported for SWF export.
Composite
Composite Generic - Blending Modes
Note that some colour overlapping could occur with some of the blending modes effects when
transparency is used.
Directional Blur
Note that the result may differ. The alpha is ignored.
Display
Glow
The following parameters of the Glow effect are NOT supported for SWF export:
D Directional Blur
D Directional Angle
D Invert Matte
D Multiplicative
Group
Highlight
The following parameters of the Highlight effect are NOT supported for SWF export:
D Directional Blur
D Directional Angle
D Invert Matte
D Multiplicative
The following parameter of the Highlight effect ARE supported for SWF export with limitations:
D RGB
Supports RGB positive values.
Note that the cutter effect of the highlight is not supported for SWF export. For this reason, the matte
region of the highlight should not exceed the shape of the drawing it is applied to.
You can edit the RGB colour selection parameter using negative values.
Line-Art
Peg
Quadmap
Note that the result may differ.
Shadow
The following parameters of the Shadow effect are NOT supported for SWF export:
D Directional Blur
D Directional Angle
D Invert Matte
D Use Source Colour
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•

•

The following RGB parameter of the Shadow effect IS supported for SWF export with limitations:
D Supports RGB positive and negative values
D Multiplicative
Note that when no properties are selected, the result will be the same as the OpenGL preview and close to
the SoftRender. You can edit the RGB colour selection parameter using negatives values.
Tone
The following parameters of the Tone effect are NOT supported for SWF export with limitations:
D Directional Blur
D Directional Angle
D Invert Matte
The following parameter of the Tone effect ARE supported for SWF export with limitations:
D RGB
Supports RGB positive and negative values.
D Multiplicative
Multiplicative works, but only with negative RGB values.
Multiplicative works with Use Source Colour activated.
Note that the cutter effect of the tone is not supported for SWF export. For this reason, the matte region of
the highlight should not exceed the shape of the drawing it is applied to.
You can edit the RGB colour selection parameter using negative values.
Transparency
Refer to Chapter 17: Exporting Your Movie to learn more about the different exporting options.
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Extra Commands (PRO)
These are some useful commands you can find only in Animate Pro.
Recalculate all

Use the Recalculate All command to refresh
the network and re-render the display when
the Camera View is in render mode.

• In the Network View menu, select

Recalculate
selected

Use the Recalculate Selected command to
refresh the network and re-render the display
of selected elements when the Camera View is
in render mode.

• In the Network View menu, select

Auto Render write

Use the Auto Render Write command to
render a frame each time the current frame is
changed.
You must have a Write module in your
network to use this command.

• In the Network View menu, select

Print Network

Use the Print Network command to print the
Network view.

• Select File > Print > Network.
• In the Network view menu, select

Edit > Recalculate All.

Edit > Recalculate Selected.

Edit > Auto Render Write.

File> Print.
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Preferences (PRO)
Animate Pro has a several preferences you can adjust to make you work more efficiently.
This topic is divided as follows:

•
•

General (PRO), on page 816
OpenGL (PRO), on page 817

To open the Preferences panel:





Windows: Select Edit > Preferences.
Mac OS X: Select Animate Pro > Preferences.
You can also use the default keyboard shortcut [Ctrl]+[U] (Windows) or [a]+[U] (Mac OS X).

General (PRO)

Options (PRO)
•

816

Auto-Render: Automatically enables the Auto-Render option.
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OpenGL (PRO)

Drawings (PRO)
•

•
•

Enable Textures and Gradients in Drawings: Shows zones and lines painted with texture or gradient colour
pots. When disabled, zones and lines painted with textures and gradients will be filled with solid colours.
Textures and gradients require more time and memory to display, so enabling this effect module can slow
the performance of Animate Pro.
Support Transparency in Pencil Lines: When this option is enabled, the pencil lines are displayed normally.
The lines will be opaque (unless there are transparencies). Disabling this option will reduce rendering times,
but will display additive opacities for overlapping pencil lines and unevenly filled curved pencil lines.
Enable Variable Line Thickness: Turns on and off the rendering of the variable line thickness option of the
Element Module.

Effects (PRO)
•
•
•
•

Enable Tone and Highlight: Turns the Tone and Highlight effects on and off in the Camera, Top and Side
views.
Enable Cutter: Turns the rendering of Cutter effects on and off in the Camera, Top and Side views.
Enable Colour Override: Turns the rendering of the Colour-Override effects on and off in the Camera, Top
and Side views.
Enable Glue Module: Turns the rendering of the Glue effects on and off in the Camera, Top and Side views.
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Chapter 17
Exporting Your Movie

Now that you have finished your animation, it is time to render your movie. Depending on whether you plan to further
edit your movie in a third party software, composite the movie in a larger body of work or put it up directly on the
web, Toon Boom Animate supports several formats for all your rendering needs.
In this chapter, you will learn how to do the following:

•
•
•
•
•
•
•

Exporting a QuickTime Movie, on page 820
Exporting an SWF Movie (Flash), on page 824
Exporting an FLV Movie, on page 825
Exporting OpenGL Frames, on page 827
Exporting an Image Sequence in Animate, on page 828
Rendering Movies and Image Sequences in Animate Pro, on page 830
Preferences, on page 843

Refer to Enhancing With Effects > Playing Back your Effects in an SWF Movie > Exporting Effects to SWF, on
page 813 to view a table with all available effects and which formats they can be rendered in.
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Exporting a QuickTime Movie
To export a QuickTime Movie:
1.

From the top menu, select File > Export > Movie.
The Export to QuickTime Movie dialog box opens.

2.
3.
4.

From the dialog box, click on the Browse button to choose a destination path to where your movie will be saved
and an appropriate filename for the export.
Click on the Save button when you are finished.
In Animate Pro, the Display Source section is where you can select which Display module you want to use
to render out your project. If there is no Display module in the scene, the drop-down list will indicate Display All
and will render out the scene in the same order as the Timeline view. It is always recommended to render out
from the Display module, located under the final Composite module, unless you want to render out a specific
section displayed by a particular Display module.
In the drop-down list, select the desired Display module.
Refer to Setting Up the Scene > Display Modules (PRO), on page 522 to learn more about Display modules.

5.
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From the Export Range section, decide whether you would like to export the entire scene (All) or just a selected
frame range. If you decide on the latter, be sure to enter in the frame range in the fields provided.
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6.

In the Options section, click on the Movie Options button.
1
2
3
4

5
6

7
8

1. Video: Check this box to enable the customization of the video settings, filters and size.
D 2. Settings: Opens the Standard Video Compression Settings dialog box (see below).
D 3. Filter: Opens the Choose Video Filter dialog box, where you can select from a range of filters to
apply to your video export.
D 4. Size: Opens the Export Size Settings dialog box, where you can choose a different export size from
the settings predefined for your project.
• 5. Sound: Check this box to enable the customization of the sound settings.
D 6. Settings: Opens the Sound Settings dialog box (see below).
• 7. Prepare for Internet Streaming: Check this box to enable the customization of the internet streaming
options.
D 8. Internet Streaming drop-down: Select from the drop-down menu options for the type of streaming
best suited for your needs.
In the Video section, click on the Settings button.

•

7.

The Standard Video Compression Settings dialog box opens.

8.

From the Compression Type drop-down menu, select a codec.
The availability of certain Compression Settings depends on the Compression Type selected. For example,
Animation is the default compression type and as a result the Data Rate option is greyed out.
821

Animate Pro 2 User Guide
9.

In the Motion section, choose your Frames per second from the drop-down menu.

By default, it will be set to match the frames-per-second (fps) of your Animate project. If you choose a lower
frame rate, your export play back will be faster than your actual project. The reverse is also true for a higher
frame rate.
10. From the same section decide whether you would like key frames inserted by checking the Key frame every
box, and if so, the number per frame.
This is the option is recommended by QuickTime. A further description of this topic is cited below.
Many compressors use "frame differencing" to compress moving images.
Frame differencing is the process of determining what information has changed from a starting frame (called a
"key frame") to subsequent frames. The key frame contains all of the information for an image. Subsequent
frames contain only the information that has changed.
Depending on the compressor you use, you can specify how often you want key frames to occur. If you don't
have enough key frames, the quality of your movie might be lower because most frames are generated from
others. However, more key frames result in a larger movie with a higher data rate. With some compressors, an
additional key frame is inserted automatically if too much of the image has changed from one frame to the next.
A good rule of thumb for general use is to have one key frame every 5 seconds (multiply the frames per second
by 5). If you are creating a file for RTSP streaming and have concerns about the reliability of the delivery network
(as with the public Internet), you may want to increase key frame frequency to one key frame every 1 or 2
seconds.
11. From the Compressor section, choose a Depth based on your movie’s needs, for example, Millions of Colours+
houses an alpha channel.
12. In the Quality section, use the slider to choose a quality setting. Remember that the better the quality of the
export, the larger the file.

13. From the Data Rate section, either choose to allow the program to automatically select the most optimal bit
rate, or enter in a Restricted rate to save space and allow for faster downloading at a cost to the quality of your
export.
14. In the same section, from the Optimized for drop-down list, select the intended viewing method for your export.
15. Click the OK button when you are finished.
16. From the Movie Settings dialog box, click-on the Sound Settings button.
The Sound Settings dialog box opens.

17. From the Compressor drop-down menu, choose a compression type.
The default setting is None. This will preserve your original sound file, without the loss of information. However,
an uncompressed sound file will inevitably add “weight” to the overall size of your video export.
18. Select a Rate by pressing the down arrow button next to kHz.
It is best to check and match the original properties of your sound file. For example, if your file has an audio
sample rate of 48 kHz and you choose a conversion rate of 22.05 kHz, the sound will play at the same speed, but
with higher frequencies missing.
For a standard film sound quality, choose 44.1 kHz, or 48 kHz for DVD quality. Anything less will make the sound
“dull” or less bright. For things like recorded voice this doesn't matter so much, but for music it can make an
audible difference.
If file size is a consideration, such as with videos for the internet, then a lower rate might be more practical.
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19. Next, choose the Size and the Use, which are related. Once again, it is advisable to check your original sound file
properties. If the file was recorded in one channel (mono), there is little point in choosing the two channel
(stereo) option.
Although Mono can support a 16-bit channel, the extra information is unnecessary. Mono is generally paired
with 8-bit and Stereo with 16-bit.
20. Click on the OK button when you are done.
21. In the Export to QuickTime Movie dialog box, click the OK button.
A progress bar appears.

22. Browse to the location on your computer where you saved your QuickTime video and double-click on it to view
your export.
If you feel that your exported video is either to small or too large, change the your project size from the top
menu under Scene > Scene Settings. This will change the size of the video output.

Exporting a QuickTime Movie with Transparency
To render out a QuickTime movie with transparency, you need to set the Depth to Millions of Colours +.
To select Millions of Colours +, do the following: Movie Options > (Video) Settings > (Compressor) Depth and select
Millions of Colours +.
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Exporting an SWF Movie (Flash)
The SWF export now supports both bitmap effects (which can be previewed in Render View
Blend Modes (vector effects which can be previewed in OpenGL View
you should preview the SWF by using the SWF preview

mode) and SWF

mode). If you have not already done so,

button to see what the two types of effects look like when

blended together. Once you are satisfied with the results, continue to the Export to SWF Movie procedure.
Refer to Enhancing With Effects > Blending Effects, on page 722 to learn more about the SWF Blend Modes.
To export a SWF Movie:
1.

From the top menu, select File > Export > SWF.
The Export to Flash Movie (SWF) dialog box opens.

2.
3.

4.

To choose an appropriate filename and a destination path where your movie will be saved to, from the dialog
box, click on the Browse button.
From the Export Range section, decide whether you would like to export all the frames of your movie or just a
selected frame range. If you decide on the latter, be sure to enter in the frame range in the fields provided.

In the Options section, enter your Frames rate (fps) into the field provided. By default, it will be set to match the
fps of your Animate project. If you choose a lower frame rate, your export play back will be faster than your
actual project. The reverse is also true for a higher frame rate.
5. In the same section, select the JPEG quality.
 100 = full quality
 50 = average quality at about 1/5th of the size.
 25 = medium quality where loss of high image resolution starts to occur.
 10 = low quality where “macro-blocking” or large pixelation become obvious.
 1 = lowest quality where there is extreme loss of colour and detail and where the image becomes nearly
unrecognizable.
6. If you want to protect your movie to be imported in another application, enable the Protect from Import
option.
7. Enable the Compress Movie option if you want to get a lighter format. The movie may lose some quality, but in
turn create a lighter file.
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8.

In the Disabled Effects section, check the boxes of the vector-based effects that you would NOT like to see in
the SWF render.

Note that certain Animate effects will not be listed in this section as they are not vector-based and therefore not
available for SWF export. These effects will not appear in the SWF render.
9. Press the OK button when you are finished.
10. Browse to the location on your computer where you saved your Flash Movie and double-click on it to view your
export.

Exporting an FLV Movie
Animate can also export FLV movie files, this is an Adobe®Flash® format.
To export a Flash Video:
1.

From the top menu, select File > Export > Flash Video.
The Export to Flash Video dialog box opens.

2.
3.
4.

To choose an appropriate filename and a destination path where your movie will be saved to, from the dialog
box, click on the Browse button.
Click on the Save button when you are finished.
In Animate Pro, the Display Source section is where you can select which Display module you want to use
to render out your project. If there is no Display module is the scene, the drop-down list will indicate Display All
and will render out the scene in the same order as the Timeline view. It is always recommended to render out
from the Display module, located under the final Composite module, unless you want to render out a specific
section displayed by a particular Display module.
In the drop-down list, select the desired Display module.
Refer to Setting Up the Scene > Display Modules (PRO), on page 522 to learn more about Display modules.

5.

From the Export Range section, decide whether you would like to export the entire scene (All) or just a selected
frame range. If you decide on the latter, be sure to enter the frame range in the fields provided.

6.

In the Options section, click on the Video Options button.
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The Video Options dialog box opens.

7.

Select the Bit Rate (compression) in Kbits/sec.
Between 400 to 900 is the optimal range. For Flash Videos, which are primarily used for the web, 500 or 512
is considered standard.
Enter the Frames per Second in the field provided. It is advised that you check the frame rate of your project
and try to match it.


8.

If you choose a lower frame rate, your export will appear faster than your project and vice versa is true for a
higher frame rate.
9. Click on the OK button.
10. In the Options section, click on the Sound Options button.
The Sound Options dialog box opens.

11. Select the Sample Rate in kHz from the drop-down menu.
It is best to check and match the original properties of your sound file. For example, if your file has an audio
sample rate of 44.1 kHz and you choose a conversion rate of 22.05 kHz, the sound will play at the same speed,
but with higher frequencies missing.
For a standard film sound quality, choose 44.1 kHz. Anything less will make the sound “dull” or less bright. For
things like recorded voice this doesn't matter so much, but for music it can make an audible difference.
If file size is a consideration, such as with videos for the internet, than a lower rate might be more practical.
12. Select the Channel size, either 8 or 16-bit.
16-bit can store more sound information than 8-bit, however, if your original sound sample was recorded on a
mono channel, then this extra space is unnecessary. Once again, it is best to refer to the properties of your
sound file.
13. Select a Channel Count, either mono or stereo.
Stereo supports two channels and therefore requires at least 16-bits. However, if your original sound sample was
recorded on a mono channel, then this option is moot. It is best to refer to the properties of your sound file.
14. Click the OK button.
15. In the Export to Flash Video dialog box, press OK.
A progress bar will appear.
16. Browse to the location on your computer where you saved your Flash Video and double-click on it to view your
export.
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Exporting OpenGL Frames
Use the Export OpenGL Frames dialog box to select the frames you want to render from the OpenGL Camera
view, then save the rendered frames as image files or as a QuickTime movie.
Note: Frames saved from OpenGL Views have neither anti-aliasing nor special effects. To render final frames with
effects, export Images or a Movie.
To export OpenGL Frames:
1.

From the top menu, select File > Export > OpenGL Frames.

2.
3.

In the Output section, in the Location field, click on the Browse button to select a folder for the frames.
In the Filename field, enter a name (prefix) for the frames or revert to the default name by clicking on the
Default button.
4. In the Format section, decide if you want to export individual image frames or a movie.
 Frames:
D Suffix: From the drop-down list, select the desired suffix. If you intend to render only a few frames, you
might decide to go with 1 or 01, whereas if you intend to render 1000 frames you might choose to
select 0001.
D Drawing Type: From the drop-down list, select the file type you want to render, such as TGA or SGI.
 Movie:
D Movie options: Click on this button to customize the Audio and Video settings for the *.mov export.
Refer to Exporting a QuickTime Movie, on page 820 for a more detailed description of the Movie options.
5.

6.
7.

From the Resolution section, select the resolution you would like for your export. If you are running some quick
tests, then you might want to cut down the resolution to save time and space. You also have the option to set a
Custom width and height to produce smaller or larger frames.
In the Range section, decide whether you want to render all your frames, a range of frames, the current frame or
selected frames.
Click on the OK button.
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Exporting an Image Sequence in Animate
In Toon Boom Animate you can export your scene as a bitmap image sequence. If you have sound in your scene, the
sound will not be exported with the images.
The following technique applies only to Toon Boom Animate. If you are using Toon Boom Animate Pro,
refer to the Rendering Movies and Image Sequences in Animate Pro section to learn how to render out your network
as an image sequence.
To render an Image Sequence in Animate:
1.

Select File > Export > Images or use the keyboard shortcut [Ctrl]+[Shift]+[Y] (Windows) or
[a]+[Shift]+[Y] (Mac OS X).
The Export Images dialog box opens.

2.
3.

4.

In the Output section, choose a prefix. The prefix is the file name. Each image in the sequence will have this
name, plus a sequence number, plus the file format extension, for example final-0001.jpg.
From the same section, click on the Browse button to choose a destination path to where your movie will be
saved. The default location is in the file directory’s frames folder.

In the Format section, choose the File Type, Colour Mode and Colour Depth from their respective drop-down
menus.
5. In the Range section, select the Frame Range to render.
 All Frames: Select this option to export the entire scene.
 Selected Frames: Type the first and last frame of the frame range you want to export.
6. Check the Preview box if you wish to see the images being rendered.
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7.
8.

Click on the OK button.
If you checked off the preview box, a generic player opens so you can watch the image sequence strung
together as a video.

The image sequence is now available in the scene’s frames directory. You should be able to preview each frame as an
individual image.

Exporting an Image Sequence With Transparency (Animate)
If you would like to export images with transparency you need to select the file type that supports this option, such
as TGA, PSD or PNG. The Colour Mode menu adjusts according to the File Type selected. For example, selecting TIF
will result in only having "Colour" as a Colour Mode option, whereas PNG will have "Colour" and "Colour with
Transparency."
To render out an Image Sequence with transparency:
1.

Bring up the Export Images dialog box and select Format > Colour Mode > Colour with Transparency from
the drop-down menu.
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Rendering Movies and Image Sequences in Animate Pro
In Animate Pro, the Network view allows you to make advanced connections and isolate certain portions of your
project, it also allows you to do multiple exports either from the entire network or specific sections.
For such a process, use the Write module in the Module Library view.
This topic is divided as follows:

•
•
•

Write Module (PRO), on page 830
Multiple Renders (PRO), on page 834
Rendering Images and Movies from the Network (PRO), on page 842

Write Module (PRO)

The Write module is used to record and output the connected image information.
To add a Write module:
1.
2.

In the Module Library, go to the Favorites tab.
Select the Write module and drag it to your Network view.

3.

In the Network view, connect either the final Composite module or any other module which outputs images you
want to render out to the Write module.

Using the Write module, you can export your project as:

•
•
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Image Sequences (PRO)
QuickTime Movie (PRO)
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Image Sequences (PRO)
To export an image sequence, you need to adjust a few settings in the Write Module’s Properties.
To set the Write Module to export an image sequence:
1.

In the Network view, open the Write Module’s editor by clicking on its Properties button.

2.

In the Output tab, select the Drawings option to create an image sequence.

3.

Click on the Choose button and browse to the directory where you will save the output.



You can also use the default directory to save in the default Frames folder included in the scene directory.

4.

In the Start field, select the starting number for the image sequence.

5.

In the Filename field, type the image sequence’s name prefix. It is very important to leave the hyphen (-) symbol
at the end of the name to separate the image name from the image number.

6.

In the Leading Zeros field, select the number of digits you want to see after the sequence prefix.
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7.

In the Drawing Type field, select the file format you want to output your project to. When the file format includes
a “4” at the end of its name, it means that an alpha channel will be created.

8.

Click on the Close button.
The project will not start rendering yet. These are only the settings. You can still modify your scene.

QuickTime Movie (PRO)
To export a QuickTime movie, you need to adjust few settings in the Write Module’s Properties.
To export a QuickTime movie from a Write Module:
1.

In the Network view, open the Write Module’s editor by clicking on its Properties button.

2.

In the Output tab, select the Movie option to create a movie file.

3.

Click on the Choose button and browse to the desired directory to save the output.



4.
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You can also use the default directory to save in the default Frames folder included in the scene folder.

In the Filename field, name the output file. You do not need to write the file format extension.
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5.

In the Video Options field, click on the Customize button to open the Movie Settings dialog box.

6.

In the Movie Settings dialog box, in the Video section, click on the Settings button to set your video options.

7.
8.

Click on the OK button.
In the Movie Settings dialog box, in the Sound section, click on the Settings button to set your audio options.

9.

Click on the OK and the Close buttons.
The project will not start rendering yet. These are only the settings. You can still modify your scene.
Refer to the Exporting a QuickTime Movie section to learn more about Audio and Video settings.
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Multiple Renders (PRO)
Animate Pro allows you to simultaneously render many formats and resolutions for a scene. This saves a tremendous
amount of time as you do not have to return between each render to start a new one.
Using Multiple Renders is easy. Connect as many Write Modules as are needed to match the required number of
exports. Then adjust each Write Module’s settings to create image sequences or movies.
YOU MUST GIVE DIFFERENT NAMES TO EACH OUTPUT FILE. This is especially important if you save them all
in the same directory, so that they do not overwrite each other.
When you have multiple Write Modules in a scene, it is useful to rename them according to their output settings such
as: low_resolution_movie or HDTV_sequence.
This topic is divided as follows:

•
•

Modules Used to Export to Different Resolutions (PRO), on page 834
Connecting the Required Modules (PRO), on page 839

Modules Used to Export to Different Resolutions (PRO)
To export different resolutions concurrently, you need to create a combination of:

•
•
•

Write Module (PRO), on page 834
Scale-Output Module (PRO), on page 834
Crop Module (PRO), on page 836

Write Module (PRO)
To learn more about the Write module, refer to the following sections:

•
•

Write Module (PRO), on page 830
Multiple Renders (PRO), on page 834

Scale-Output Module (PRO)

Once your Write modules are connected, you need some Scale modules to change the resolution output of the Write
module. For example, if you export in a high resolution and a low resolution, you need one Scale-Output module.
Set the project’s resolution to the highest resolution needed for this export and use the Scale-Output modules to scale
down the other outputs. DO NOT scale up the output size, that will not provide a good result. It is also better to use
the Scale-Output module to scale down in a same aspect ratio so that it does not distort the image.
To add a Scale-Output Module:
1.
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In the Module Library view, select a Scale-Output module and drag it to the Network view.
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2.

In the Network view, connect the Composite module to the Input port of the Scale-Output module.

3.

In the Network view, connect the Scale-Output module to the input ports of both the Display module and the
Write module.

To set the Scale Module:
1.

In the Network view, open the Scale-Output module’s editor by clicking on its Properties button.

2.

In the Layer Properties dialog box, select a resolution from the suggested Resolution Name list or type new
resolution values to indicate the resolution to scale to.

3.

Click on the Close button.
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Crop Module (PRO)

To output two files with different aspect ratios, such as 16:9 and 4:3, you can use the Crop module. This module is
used to crop the final image in order to discard excess information without distorting the render.
If you start with a higher resolution and want to crop down to a lower resolution, such as HDTV to NTSC, you
will need to combine the Crop module with a Scale module.
To add a Crop Module:
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1.

In the Module Library view, select a Crop module and drag it to the Network view.

2.

In the Network view, connect the Composite module to the Input port of the Crop module.
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3.

In the Network view, connect the Crop module to the input ports of both the Display module and the Write
module.

To set the Crop Module:
1.

In the Network view, open the Crop Module’s editor by clicking on the module’s Properties button.

2.

In the Layer Properties dialog box, type new resolution values to indicate the resolution to crop to.

3.

You can manually enter the X -Y Offset, or move it in the Camera view. Select the right Display module in the
Display toolbar. In the Advanced Animation toolbar, select the Translate

4.

tool and with the middle mouse

button, move the crop area. If the Animate
mode is enabled, the position of the crop area will be animated
over time.
If you want to create a Pan and Scan effect (panning the cropped selection over time to show more information),
you can create a function to animate the cropped selection. Click on the Function Arrow
Local dialog box to create a Bezier or ease curve.

button beside the
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5.

If you created a function curve to animate the cropped selection, click again on the Function
button and
edit the curve by adding keyframes and moving the selection box in the Camera View. (Refer to the Creating
Animation Paths chapter for more information about function curves.)

6.

Enable the Draw Frame option if, instead of cropping the images, you prefer to have Animate Pro draw the
frame over the rendered scene.

7.

Click in the colour rectangle to adjust the frame colour as desired if you have enabled the Draw Frame option.

8.

Click on the Close button.

The Crop module also has an advanced Enable tab. Use the Enabling tab to determine when the Crop module should
be activated.

•
•
•
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Always Enabled: Select this to have the Crop Module always produce output.
Enabled when resolution name is: Select this to activate the Crop Module only when the resolution of the
scene matches the value selected from the Filter Name menu. These listed resolutions come from the
Resolution/Frame Rate dialog box.
Enabled when resolution is: Select this to activate the Crop Module whenever the scene’s resolution
matches the values entered in the X resolution and Y resolution fields.
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Connecting the Required Modules (PRO)
Once you know the type of render you want to do, you will need to retrieve your modules from the Module Library
and connect them to the scene’s network.
To connect multiple renders:
1.

In the Module Library view, retrieve the necessary Write, Scale-Output and Crop modules.

2.

Connect the final Composite module to the first Write Module. (Make sure that you have a Display module
reading the same information.)
Open the Write module’s Editor by clicking on its Properties button.
Name the Write module according to the render type that you are planning to do.
Set the Write module parameters.

3.
4.
5.
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6.

Connect the other Write modules and repeat Step 2 to Step 5.

7.

Using the [ALT] key, insert the Scale-Output modules between the final Composite module and their
corresponding Write module.

[Alt]
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8.

Using the [ALT] key, insert the Crop modules between the final Composite Module and their corresponding
Write or Scale module.

[Alt]



If the output from the Crop module has to be scaled down, use a Scale-Output module.
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9.

Connect a Display module to each Scale-Output or Crop module to be able to see each final image in your
Camera view.

Rendering Images and Movies from the Network (PRO)
If you want to render from your Write Module, you will need to use the Render Network option found in the File menu.
To render from the Write module:
1.

Select File > Export > Render Network. The default keyboard shortcut is [Ctrl]+[Shift]+[Y] (Windows) or
[a]+[Shift]+[Y] (Mac OS X).

2.
3.

In the Range section, select the Frame Range to render.
Enable the Preview option if you want to automatically see the image sequence result once the render is done.
(The preview will not show up for a QuickTime movie.)
Select Field Composite if you want Animate Pro to render the final images as fields for display on interlaced
monitors.
Click on the OK button.

4.
5.

All renders start.
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Preferences
In Animate, you will find preferences related to the rendering under the Render tab.
To open the Preferences panel:





Windows: Select Edit > Preferences.
Mac OS X: Select Animate > Preferences.
You can also use the default keyboard shortcut
[Ctrl]+[U] (Windows) or [a]+[U] (Mac OS X).

Animate Render Preferences

•
•

Enable Blur: Renders blur effects derived from the Blur, Directional-Blur or Motion-Blur effects in the
Render View window.
Enable External Read If Image Is Bigger Than: If the image to render out is larger than the value entered
in the box, the system will create an external render for that special image. It will open a second Animate in
the background (not visible to the user), cut and set the image to the scene format and finally send it back
to the original scene.

Animate Pro Render Preferences

Preview Options (PRO)
•
•
•

Enable Blur: Renders blur effects derived from the Blur-Directional Module, Blur-Radial Module, and the
Blur-Variable Module in the Render View window.
Enable Line Texture: Renders line texture in the Render View.
Enable Focus: Renders focus effects from the Focus-Apply and Focus-Set modules.
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Image Management (PRO)
•

•

Image Memory Limit (MB): During soft rendering, Animate produces intermediate images. Roughly one
image per module per frame. This process is called rendering steps. These produced images can come to
hold considerable amount of memory and they are discarded once they are of no use in the rendering.
Specifying a maximum memory limit in this field will discard the image once it reaches this limit.
Enable Image Disk Caching: When this option is enabled, the images will be off-loaded to disk instead of
being erased from memory. The off-load process occurs as soon as the image is no longer used during the
current frame rendering, instead of waiting for the memory limit to be reached. This way, images do not
need to be recalculated and instead, they are automatically restored from disk, considerably speeding up
the interactive rendering process.
During batch rendering, off-loading the image to disk after each usage reduces the average memory (RAM)
usage.

Cache Options (PRO)
When the Enable Image Disk Caching option is enabled, the following becomes available:

•

•

Cache Path and Capacity in MB:
D If this field is left empty, the Animate Pro temporary directory will be used to off-load intermediate
images. There is no disk usage limit for the temporary directory.
D When you specify a folder, you must type in the capacity (in MB) inside the path. Use the following
method: path;capacity in MB;
ex: C:\user\tmp_image_folder;2000;
Note: The specified folder must already exist. If there is an error in the path, Animate Pro’s temporary
directory will be used. You can also specify a RAM drive in the path.
Proactively Cache Images When Unused For Subsequent __ Steps: This option will allow off-loading of
intermediate images if they are unused for the specified number of steps.
D A value of 0 disables the option.
D A value of 1 forces the off-load of all images immediately after their creation and usage.
D The recommended value is 50.
D If you are using a fine resolution of 2k pixels or more, the specified value should be smaller.
D Small networks should not use this feature.

Multi-Threading (PRO)

The multi-threading preference is used to specify the level of parallel processing done during the final image
calculation (soft-rendering). Allowing parallel processing speeds up the soft-render process. You can specify the
number of parallel processes in the Number of Rendering Threads field:

•
•
•
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Entering a thread number value of 1 disables the multi threading process because it specifies that only one
rendering thread will be used during the process.
The maximum number of threads value is 64.
The recommended starting value is 2 threads per CPU core. Meaning that if you are using a 2 Quad Core
CPU, the preferences should initially be set to 16 threads.
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enable 584
selecting
Transform tool 656
selecting layers 655
Animate Pro
list of
Top toolbars 40
View toolbars 40
Animate Pro only
3D
parameters
pivot 542
rotation 541
Scale 540
3D Camera motion 556
3D rotation
Euler Angles 541
Quaternion 541
3D Scene setup
managing network
2Dinput ordering 561
3Dinput ordering 561
input output options 560
module organization 562
3D Space
layer parameters 539
positioning
planning 550
positioning in 549
positioning layers in 553
3D Tools
Rotate tool
about 545
Scale tool
about 546
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Transform tool
about 547
Translate tool
about 544
using 543
add Camera module in Network view 477
adding
effects 709
effects through timeline 714
pegs to network 589
adjusting line texture opacity 97
Advanced Options 536
Advanced Painting Features 199
Repaint Outside Selection 200
Repaint Outside Selection all drawings 201
Repaint Selection 199
Repaint Selection all drawings 200
Unpaint Outside Selection 202
Unpaint Outside Selection on all drawings 203
Unpaint Selection 201
Unpaint Selection on all drawings 202
Advanced Palette Lists Mode 220
Advanced Preferences 705
advanced traditional animation 159
alignment
properties 495
Angle Limit Value
properties 495
Animate Using Animation Tools
layer properties 494
Annotation Columns 290
adding 290
drawing in 290
drawing settings 292
erasing content of 291
importing file 293
typing in 291
Apply to Line and Colour Art
cutter tool option 132
Auto apply option 499
Auto Render write 36
bounding box selection style 482
camera
locking flat drawings to 559
check colours 34
check files 34
cleaning scanned drawings 171
clipping
properties 496
close gaps 208
colour
adding
swatches 186
copying
from other palette 221
colour art layer 167
colour display modes
displaying colour values 191
colour palette
linking 227
colours
highlighting 209
colour swatch
cloning 224
Column
modifying 266
Column types 250

Index
commands
extra 815
complex sets in production scenes 552
composite
layer properties 507
composite module 710
connecting other modules to 436
contour stroke
create 144
remove 144
create
template from Network view 393
Create colour art automatically 89
create hierarchy in Network view 438
create patch joint using Network view 466
Creating a Morph with Morphing Layers 326
creating texture brushes 95
crop brush textures 143
Debug Mode 37
Display All 523
display concepts 522
display modes 524
advanced 524
basic 524
display modules 522
drawing layer properties 497
bitmap options 498
vector options 497
drawing module 710
editing a template 404
effect module 710
effects
anti-flicker 744
apply image transformation 745
apply peg transformation 747
blending 751
blur radial 754
blur variable 755
brightness and contrast 756
channel selector 757
colour art 758
colour card 759
colour override 760
colour scale 762
colour screen 763
composite-generic 764
contrast 767
crowd simulation 797
directional blur 753
dither 769
external 770
field chart module 772
focus 774
focus multiplier 775
glow 776
glue 777
gradient 781
grain 782
greyscale 783
highlight 785
layer selector 787
line art 788
mask-cutter 768
matte blur 789
matte resize 791
motion blur 792
multi-port-in 793

multi-port-out 794
negate module 794
note module 795
overlay layer 796
particle effects 797
pixelate 798
placeholder module 799
quadmap module 799
refract 801
remove transparency 802
shadow 803
sparkle 805
tone 806
transparency 808
underlay layer 809
using 743
effects modules available in 743
Element Manager 296
Enabling the 3D Option 538
eraser blur parameters 107
erasing textured lines 95
expression columns 638
expressions
creating for effects 640
global display 523
grouping selection with composite 511
hiding textured lines 96
Identifying Problem Zones 324
IK
tool properties
maximum angle 671
minimum angle 671
IK Modes
Edit Min/Max Angle 664
image sequences
rendering 830
importing network template 397
Inserting a Morphing Key Drawing 330
launching 23
layer properties
enable 3D check box 492
layers
overlay 213
Layer types
group 249
line art layer 166
line texture 91
drawing with 92
line texture parameters 94
line thickness
properties 496
Linking your Master Palette 228
matte drawing 711
matte generation 167
Message Log 36
module
composite
about 506
importing 713
module library
about 712
tabs
about 713
module library toolbar
about 712
modules
adding 506

847

Animate Pro 2 User Guide
cable styles
bezier 521
custom 521
line 521
connecting 510
disable all others 517
disabling 516
disconnecting 510
enable all 516
enabling 516
enabling and disabling 516
enter group 513
exiting group 514
explode selected group 513
grouping 510
grouping selected 510
input and output 505
move selected to parent 514
organizing 509
thumbnails 518
hide 519
hide all 519
show 518
more drawing layers 165
Morphing Layer Properties 325
morphing layers 311, 324
movies
rendering 830
multiple drawings in drawing view 169
multiple renders 834
Navigator display
positioning 520
showing
hiding 520
using 520
Network Connection
managing network
3D Scene setup 560
Network navigation
modules 504
network navigation and basic rules 504
Network template
importing 647
Network view 503
locate selected layer in 483
network view
about 709
change layer order in 435
ordering layers in 440
selecting a module in 657
OpenGL
preferences
drawings 536
optimization
change composite type 453
delete write module 451
modules
grouping 454
renaming
display module 451
options
Shift and Trace 161
Overlay layer 166
166
Annotations and Corrections 166
Sketching 166
palette list
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Element 218
palette option 630
paste special
palette options 402
peg module 711
position ports 711
preferences 336, 404
advanced 299, 536
advanced tab 234
Camera
Bounding Box Selection Style 532
Override Small Bitmap Files 532
camera 704
drawing 336
general 530, 816
auto apply 530
editor always on top 530
Maximum FOV setting 531
Minimum FOV setting 531
native windows playback 530
options 530, 816
settings 531
Inverse Kinematics 704
Morphing Quality 336
Network 533
drawing options 534
options 533
Network Navigator 533
OpenGL 817
drawings 817
effects 817
paste drag drop 404
render
image management 844
multi threading 844
preview options 843
Timeline 298
previewing
symbol
in Network view 398
preview selected drawings 170
reduce drawing texture resolution 143
remove art inside selection
scanned drawings 173
remove art outside selection 172
remove hair
scanned drawings 173
removing dirt
scanned drawings 171
rendering
connecting modules 839
from network 842
image sequences 830
movies 830
multiple render 834
resolutions
crop module 836
modules for 834
scale output module 834
Write module 830
export QuickTime movie 832
reset rotation button 44
Save as New Version 35
scripts
prefixes and suffixes 469
Select Child 36
Select Children 36

Index
Select Next Brother 36
Select Parent 36
Select Previous Brother 36
show morphing in place 310
Show Scan Information 35
show strokes
washed-out colours 104
Skeleton optimization
network 451
Spline Offset
properties 495
Symbols
creating from Network view 387
templates
backward compatibility 648
Tempo Markers 289
toolbars
flipping 159
onion skin 160
underlay layer 167
using effects
created in Animate 715
Vector Options
layer properties 494
verify project integrity 34
workspace
save manually 66
write and display modules 710
Write module
export image sequences 831
Xsheet
printing 294

IK Mode 664
Apply to All Drawings in Layer 117
Apply to All Visible Drawings 117
Apply to Line and Colour Art 118, 130
cutter tool option 132
apply to multiple drawings
option 197
apply to visible drawings
option 198
Arrange tool
options 141
Articuation
completing an 422
articulations
fixing 424
classical 425
patch 464
Auto apply option 499
Auto-Close gap 123
Auto-Close Gap Mode
Pencil tool option 99
Auto Flatten Mode 89
Auto-Flatten Mode
Pencil tool option 99
shape 123
Auto gap closing 232
automatic close gap
option 196
Automatic Filling
shape tool 123

Animating
traditionally using digital 154

B

animating
camera 599
effects
over time 716
in stop-motion 677
layers 584
using IK 661
using Inverse Kinematics 661
using Symbols 687
using Transform tool 659

basic display mode 524
Basic Palette Lists Mode 219
basics
rigging 430
BBox
selection style 482

animating puppets
about 645

Bezier controls
reshaping a function 634

animation
offsetting part of 703
playback 158
Animation disc
Rotate View tool 146
Annotation Columns 290
adding 290
drawing 290
drawing settings 292
erasing content of 291
importing file 293
antialiasing
full scene 86
real-time 85
anti-flicker effect 744
Appearing Point Hint
morphing 321
Appendix
Character Building 460
Apply IK Constraints

BBox Selection Style
Camera view 43
BBox Selection StyleCamera View
BBox Selection Style 43

Bezier function 625
bias
adjusting 604, 607
bitmap
image quality
changing 341, 347
layer 248, 340, 346
bitmap images
importing 338, 344
importing, without vectorization 338, 344
bitmap image sequence
exporting as 828
bitmap options 498
bitmap texture swatches 188
blank cells
insert 276
blinking
creating a Symbol 687
Blur effect 724
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body
rigging 436
simple rigging 436
body parts
breaking down
main 415, 420
secondary 417, 421
Bone Editing
IK Mode 664
Bone Selection
IK Mode 663
Bounding Box
display style 482
break down
distribute to layer 461
layer
incorporating into existing 420
main body parts 415, 420
secondary body parts 417, 421
tracing 460
breaking down
characters 414
new layer
creating 414
selecting 414
brush size
puppets
relative size 409
Brush Strokes to Pencil Lines
convert 141
brush styles 89
adding 90
deleting 90
renaming 90
selecting 89
Brush Tips 91
Brush tool
drawing with 84, 87
options 88
regular brush mode 88
button
camera mask 43
edit colour 72
matte view mode 43
OpenGL view mode 42
render view mode 43
reset rotation 44
reset view 44
safe area 43
update preview 42

C

cable styles
bezier 521
custom 521
line 521
camera
3D motion
how to 556
animating 599
List 480
motion path preferences 643
preferences 531, 704
Bounding Box Selection Style 532
Camera View Default Zoom 532
control size 533

850

min max 533
Nudging Factor 532
pivots and control points 533
rotation 533
scale 533
Show Locked Drawings As Outlines 532
skew 533
Small Bitmap Resolution 532
Thumbnail Size 532
tools 532
Top/Side View Default Zoom 532
TV Safety 532
wash background 533
resetting position of 480
setting 478, 479
camera frame
setting 477
camera layer 248
adding 477
Camera layer properties
setting camera using 479
camera mask button
Camera view 43
Camera View 80
about 42
adding control points 605
camera mask 43
Colour Art 81
Current Drawing On Top 43
Current Frame 82
display path in 603
Drawing name 82
drawing name 44
editing stack menu 44
frame number 44
Light Table 44
Line Art 81
Matte view mode 43
modify path in 603
OpenGL view mode 42
Outline Locked Drawings 43
Preview Mode 81
Render view mode 43
reset rotation 44
reset view 44
safe area 43
shaping path in 604
Show Strokes 44
Show Strokes with Colour Wash 44
Tool Name 82
tool name 44
transform tool
Animate Mode 656
update preview 42
zoom drop-down menu 44
Camera view
options menu 43
cells
dragging 272
change
bitmap image quality 341, 347
keyframe values in Function view 617
keyframe values in Timeline view 612
sound display 566
change track colour
Timeline view 50

Index
changing
initial scene settings 29
character
breakdown 414
preferences 413
setting up for IK 667
Character Building
appendix 460
Check Files
verify project integrity 34
child layer
hierarchy 49
children
show/hide 49
Clean Up 156, 422
bitmap images 341, 347
Clear Exposure and Pull option 275
clone
layers 501
clone layer 501
cloning
colour swatch 224
layers 263
Close Gaps 208
close gaps
manually 207
closing
library 382
Closing a View 61
collapse
layers 265
colour
about 183
adding 181
swatches 184
copying 221
edit 72
how to paint 182
mixing 224
modifying 71
pasting 221
preferences 232
auto gap closing 232
colour pots 232
default multiwheel colour picker 232
drawing mode tab 232
Multi-click eye dropper 232
selecting in a drawing 204
using swatches 183
Colour Art 210
camera view 81
drawing view 79
colour card layer 249
colour display modes 191
switching between 191
colour management
preferences 233
general tab 233
Colour Model 231
loading 231
colour palette
cloning 223
duplicating 222
importing 226
removing 222

renaming 221
Colour Picker 184
colour pots 232
Colours
highlighting 209
protecting 209
colour swatch
colour view 56
colour swatch name
colour view 56
Colour View
about 54
add colour 55
add texture 55
colour swatch 56
colour swatch name 56
colour view menu 56
link/unlink three colours 56
remove colour 55
set current brush colour 55
set current paint colour 56
set current pencil colour 55
show/hide palette list view 56
colour view menu
colour view 56
Column
modifying 266
Column Header
Xsheet view 241
Column List Section
Xsheet view 240
Columns
expression 638
columns
changing colour 264
navigating between frames 284
Command
create empty drawing 151
optimize
options 142
commands
About
about 37
Auto Render write
about 36
basic
list of 35
check files 34
Clear
about 35
Close
about 35
commonly used 35
compositing
auto render write 815
recalculate all 815
recalculate selected 815
Copy
about 35
Cut
about 35
Debug Mode
about 37
Delete
about 36
Deselect All
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about 36
Help
about 37
Message Log
about 36
New
about 35
Open
about 35
Open Recent
about 35
other 815
Paste
about 36
print out network 815
Quit
about 35
Redo
about 36
Save
about 35
Save As
about 35
Save as New Version
about 35
Select All
about 36
Select Child
about 36
Select Children
about 36
Select Next Brother
about 36
Select Parent
about 36
Select Previous Brother
about 36
Show Scan Information
about 35
Toon Boom Harmony on the Web
about 37
Undo
about 36
composite module
about 506
connecting other modules to 436
layer properties 507
concepts
layers 247
connect hierarchy chain
setting up for IK 667
connecting modules
rendering 839
constraints
IK 669
continuity
adjusting 604, 607
Contour Editor
show controls 110
smooth selection 112
Contour Editor Tool
lasso 109
marquee 109
Properties 109
snap options 110
using 108
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Contour Hint
morphing 319
contour stroke
create 144
remove 144
control points
adding
Camera view 605
trajectory view 605
toggle
keyframe 606
control points options
motion path preferences 644
convert
Bezier function 625
Ease function 625
motion keyframe to stop-motion 678
pencil to brush 118
Convert Hints
morphing 311
convert in-betweens to drawings
morphing 331
Convert tool
options 141
Coordinate keyframes 594
copy
a motion 627
drawing 287
Copying Hint points
morphing 322
create
symbol from Network view 387
template from Network view 393
Create Colour Art Automatically
Pencil tool option 100
Polyline option 127
Create Colour Art From Line Art 119
Create Empty Drawing
command 151
creating
3D camera motion 556
blink Symbol 687
colour palette 219
cut-out animation 653
cycles 281, 699
drawing
in timeline view 651
drawing and keyframe
in timeline view 652
extra drawings 471
facial expressions 471
folder 382
function curve, Timeline view 611
Function Curves 620
ghost drawings 426
keyframe
in timeline view 652
library 381
motion keyframes 679
mouth shapes chart, sound 578
multiplane 525
rigging hierarchy 437
scene using Welcome Screen 26
stop-motion keyframe 677
Symbols 385
empty 388

Index
from timeline 386
Symbols from drawing selection 385
Templates
from timeline view 392
workspace 64
Creating a Morph with Morphing Layers 326
creating animation paths
about 583
creating expressions for effects 640
creating keyframes
rigging 443
Cumulative Z value 609
Current Drawing
Xsheet view 242
current drawing displayed in drawing view
Timeline view 48
Current Drawing On Top
Camera view 43
Current Frame
as Drawing Name 177
camera view 82
drawing view 80
Timeline view 48
Xsheet view 242
Current Frame Display
Xsheet view 242
current view border 71
preference 71
curved motion
toggle between linear 608
customize 574
alignment values 32
Keyboard shortcuts 74
unit aspect ratio 32
vectorization parameters 368
cut-out
create from photo 407
cut-out animation
creating 653
Cutter
mouse gesture 132
Cutter Tool
using 131
Cutter Tool Options 131
Cutting Drawing Parts 131
cycle parameters
paste special 401, 402, 628, 629
cycles
creating 281, 699
Paste Cycle 699
Paste Reverse 700

D

Data View Section
Timeline view 237
decrease
exposure 274
default
keyboard shortcuts
choosing 73
default multiwheel colour picker 232
default separate positions
character preferences 413
Deforming

using Perspective Tool 129
delete layers
Timeline view 47
deleting
brush styles 90
colour swatches 190
drawing 286
exposure 276
folder 383
Warning 383
frames 245
keyframes 595
keyframes in Timeline view 612
layer from the Xsheet view 255
layer from timeline view 255
layers 255
morphing sequence
entire 308
Symbols 388
Warning 388
Templates 394
workspace 66
Deleting frames
delete selected frame range 246
reducing timeline length 245
remove frames button 245
destination drawings
morphing 302
detecting
lip-sync
automatically 580
manually 579
modification 581
dialog box
check colours 34
check files 34
dialogue
working with text 136
disable
Animate mode, when positioning elements 481
display
functions
Function view 615
Display All 523
display concepts 522
displaying
palette list 216
sound 566
display modes 524
display modules 522
distortion
preventing
using Ortholock layer 559
Distribute to Layer 119
dragging cells 272
Draw Behind 122
Pencil tool option 99
Polyline option 127
Draw Behind Mode 88
Drawing
adding new 697
Auto-Flatten Mode 89
Brush Styles 89
adding 90
deleting 90
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renaming 90
selecting 89
brush tool options 88
Camera view 78
Contour Optimization 91
copy 287
Create Colour Art Automatically 89, 123
delete 286
Draw Behind Mode 88
Drawing View 78
duplicating 287, 697
line texture parameters 94
managing 285
maximum brush size 90
minimum brush size 90
paste 287
Perspective tool 129
preview 91
Regular Brush Mode 88
renaming 285
renaming by frame position 286
Repaint Brush Mode 88
Respect Protected Colour 89
rotating 146
selecting colour in 204
Smoothness and Contour Optimization 91
Smoothness Optimization 91
Use Stored Colour Gradient 89, 123
using brush tool 84, 87
using invisible lines 102
using pencil tool 84
using Pencil Tool 98
using Polyline Tool 126
using Shapes 121
view final lines 85
drawing
about
Timeline behaviour 651
adding duplicate and keyframe 594
add text in 136
Annotation Columns 290
creating in timeline view 651
substitution 379
drawing and keyframe
creating in timeline view 652

vector options 497
Drawing layers 248
adding 33, 251
panning 488
rotating 488
Drawing name
camera view 82
drawing view 79
drawing name field
Camera view 44
drawing objects
selecting 113
drawing parameters
paste special 400, 401, 628, 629
Drawings
adding 444
adding ghost 426
creating ghost 426
locking to camera angle 559
drawings
cleaning scanned 171
painting 182
drawing substitution
Timeline view 51
Drawing Tab
preferences 178
Drawing View 78
Colour Art 79
Current Frame 80
Drawing Area 79
Drawing Name 79
Drawing View Toolbar 78
Line Art 79
Preview Mode 79
Tool Name 79
Drawing View Toolbar 78
duplicate drawing
adding with keyframe 594
Duplicate Layer 502
duplicating
drawing 287, 697
layers 263, 501
Symbols 390, 691

Drawing and Traditional Animation Preferences 175
Drawing Area
Drawing view 79

E

drawing blocks
about 651

Ease controls
reshaping a function 634

Drawing Exposure
Xsheet view 242
drawing exposure
Timeline view 52
Drawing Identification 151
drawing layer
more 165
Drawing Layer Properties 497
Advanced 494
alignment 495
Angle Limit Value 495
clipping 496
line thickness 496
Spline Offset 495
drawing layer properties
bitmap options 498
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ease
setting on multiple parameters 636, 681

Ease function 625
Easing
morphing 311
easy flipping
toolbar 159
Easy Shape, IK option 664
edit colours button 72
Editing
gradients 205
sound file 569
textures 205
editing
functions
Function view 615
Symbols 389
Templates 394

Index
editing stack menu
Camera view 44
Edit Min/Max Angle
IK Mode 664
effect layer 248
effectlayers
using 720
effects
adding 708
animating over time 716
anti-flicker 744
apply image transformation 745
apply peg transformation 747
advanced 750
blending 722
blur 724
blur radial 754
blur variable 755
brightness and contrast 725, 756
channel selector 757
colour art 758
colour card 726, 759
colour override 727, 760
colour scale 729, 762
colour screen 763
composite-generic 764
contrast 767
crowd simulation effect 736, 797
Directional Blur 730
directional blur 753
dither 769
external 770
field chart module 772
focus 774
focus multiplier 775
glow 731, 776
glue 777
gradient 781
grain 782
greyscale 783
highlight 732, 785
layer selector 787
line art 788
mask 734
mask-cutter 768
matte blur 789
matte resize 791
motion blur 735, 792
multi-port-in 793
multi-port-out 794
negate module 794
note module 795
overlay layer 796
particle effects 736, 797
pixelate 798
placeholder module 799
playing back 810
previewing 810
preview resolution 810
quadmap module 737, 799
refract 801
remove transparency 802
shadow 739, 803
sparkle 805
tone 740, 806
transparency 742, 808
underlay layer 809

effects modules available in 722
element
flip horizontal 491
flip scale X 491
flip vertical 491
panning 490
positioning in Side view 528
positioning in Top view 528
positioning using layer properties 492
position with Transform tool 487
rotating 490
scaling 489, 490
skewing 489, 490
sound,adding 564
Z-axis 528
Element Manager 296
elements
selecting
Timeline view 487
Xsheet view 487
ellipse
shape option 122
enable
3D option 538
3D parameters 539
Animate Mode 584
enable/disable all
Timeline view 47
Enable rotation
IK tool selection option 666
Enable Translation
IK tool selection option 665
enter
value in timeline view 269
value in xsheet view 269
eraser
contour optimization 106
smoothness optimization 106
eraser blur parameters 107
Eraser Styles 106
brush 106
adding 107
deleting 107
renaming 107
eraser tips 106
Eraser Tool
options 105
Erasing
drawing parts 105
erasing
textures
line 95
Euler Angles
3D rotation 541
exclude extra elements
setting up for IK 668
Exclude from IK
IK tool selection option 666
expand
layers 265
Symbols 403
export
FLV movie 825
image sequence
transparency 829
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image sequence movie 828
movie
about 819
OpenGL frames 827
QuickTime movie 820
transparency 823
SWF movie 824
exposure
about 268
decrease 274
delete 276
extend 271
extending 650
extend sequence 271
hold 270
increase 274
setting 277
single 278
typing values into 269
Exposure Sheet
preferences 644
function editors 644
Tempo Markers 289
Expression Columns 638
operators and operands 638
Expressions
creating for effects 640
extend
exposure 650
exposure sequence 271
single exposure 271
Extending Timeline View
adding frames 244
extra drawings
creating 471
storing 472
extremety bones
setting up for IK 669
eyelids
model 410
eyes
blinking 687

F

facial expressions
creating 471
storing 472
field
drawing name 44
frame number 44
tool name 44
field chart
puppets
relative size 409
Field of View
FOV
custom fit
selecting 31
vertical fit
selecting 31
HDTV 31
File Menu
using 27
Filling Exposure Mode 268
filling selection
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single exposure 278
film-1.33
resolution
selecting 30
film-1.66
resolution
selecting 30
fixing
articulations 424
classical 425
patch 464
joints 424
classical articulation 425
patch articulation 464
Flash
importing 363
layers
about 364
Flatten 118
morphing 311
flip horizontal 117, 130
element 491
flipping
through poses 683
flipping parts
about 686
flip scale Y
element 491
Flip toolbar 159
flip vertical 117, 130
element 491
floating windows 60
FLV
exporting movies 825
folder
creating 382
deleting 383
Warning 383
renaming 383
font
alignment 138
indent 138
kerning 138
size 138
style 137
type 137, 139
formatting
font kerning 138
font size 138
font style 137
font type 137, 139
indent 138
text 137
text alignment 138
frame number field
Camera view 44
frame numbers
Xsheet view 242
frames 244
adding 244
deleting 245
navigating between columns 284
Full Scene antialiasing 86
Function
convert Bezier 625

Index
convert Ease 625
reshaping using Bezier controls 634
reshaping using Ease controls 634
Velobased
about 626
function
types of function 625
Function Column
Xsheet view 243
Function Curves
about 620
adjusting velocity 633, 680
Bezier 625
creating 620
creating in Timeline view 611
creating linear velocity 635
creating stepped curve 635
display velocity curve 633
Ease 625
menu 624
set eases on multiple parameters 636, 681
sharing 621
types of 625
function editor
preferences 644
Functions Section
Xsheet view 239
Function view
adding
keyframes 616
adjusting velocity in 680
display
functions 615
editing
functions 615
modify
path 614

G

general
motion path preferences 642
generating
mattes 167
Getting started 23
ghost drawings
adding 426
creating 426
global display 523
gradient
store colour gradient 118
gradient colour swatches 186
gradients
editing 205
storing 206
Group
option 145
group layer 249

H

hand-drawn animation
mixing 411
hands
attaching fingers to 411
Hand tool 145
HDTV

resolution
selecting 30, 31
head
rigging character 434
height
select shape 120
help tab
vectorization parameters 371
bitmap options 373
bubble usage 374
colour vectorization options 374
File IO options 371
Filtering options 372
registration options 371
RGB keying options 373
hide all others
Timeline view 47
Hide Hints
morphing 310
hide manipulator controls 484
hiding 66
toolbars 62
hierarchy
navigating 658
rigging
parenting layers 431
show/hide children
Timeline view 49
Symbols 390
highlights
preferences panel 70
user interface 41
Hints
Appearing Point 321
Contour 319
copying hint points 322
morphing 316
Pencil 320
Vanishing Point 321
Zone 320
Hint Type 310
holding exposure 270
Hold Value Editor
creating stepped curve 635
using 635
Holes
morphing 332
How to
adjust line texture opacity 97
clean scanned drawings 171
create texture brushes 95
draw 76
draw with line texture 93
erase textured lines 95
hide textured lines 96
use Inverse Kinematics 662
how to
create3D camera motion 556
enable
3D option 538
plan in 3D space 550
position in 3D space 549
position layers in 3D space 553
use 3D space 537
use Navigator display 520
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PSD as layers 350, 353
QuickTime movie 366, 368
scene components 476
sound 564
Symbols 395
Timeline view 395
Templates 395
Timeline view 395
template with Symbols 690

use Ortholock layers 559

I

Identifying Problem Zones 324
IK
about 676
animating with 661
animating with tools 675
connect hierarchy chain 667
exclude extra elements from 668
extremety bones
setting up 669
setting up character for 667
skeleton 667
tips and tricks 676
tool properties 663
Keyframes 673
maximum angle 671
minimum angle 671
Nails 669
using 675
IK constraints
Nails 669
IK Keyframe option 664
IK Manipulation
IK Mode 663
IK Modes
Apply IK Constraints 664
Bone Editing 664
Bone Selection 663
Edit Min/Max Angle 664
IK Manipulation 663
Simple Chain Mode 663
using 663
IK Nails
IK tool selection option 666
IK Tool 675
options 664
Easy Shape 664
IK Keyframe 664
Selection options 665
Enable rotation 666
Enable Translation 665
Exclude from IK 666
IK Nails 666
Stiffness 666
using 675
IK Tool and Rigging
using 675
images
import and vectorize 342, 348
Image Sequence
exporting 828
export with transparency 829
import
Adobe Flash 363
AI files 361
bitmap images 338, 344
no vectorization 338, 344
characters from library 646
colour palette 226
images 342, 348
model 406
model formats 406
module 713
PDF files 361
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import and vectorize images 342, 348
Importing
Network template 647
importing
about 646
importing network template 397
increase
exposure 274
Increase/Decrease Exposure Field 275
Xsheet View 243
inital settings
changing 29
insert
blank cells 276
Inserting a Morphing Key Drawing 330
Insert Mode 269
integrity
verify
project 34
integrity verification
Check Colours 34
Check Files 34
project 34
interface
Library view 379
Interface Navigation 68
interpolation
computer generated
about 679
Inverse Kinematics 675
about 676
animating with 661
animating with tools 675
basics 662
preferences 704, 705
tips and tricks 676
tool properties 663
using 675
Inverse Kinematics Tool 675
using 675
invisible lines
drawing using 102

J

joints
fixing 424
classical articulation 425
patch articulation 464

K

Keep Proportion
shape 123
Keyboard shortcuts
choosing 73
choosing a default set of 73
customizing 74

Index
keyboard shortcuts
commands 35
keyframe
creating in timeline view 652
toggle
control points 606
Keyframes
IK
tool properties 673
Timeline view 52
keyframes
about 651
Timeline behaviour 651
adding 594
adding in Timeline view 612
adding with duplicate drawing 594
change values in Function view 617
change values in Timeline view 612
coordinate 594
creating
Stop-motion 677
creating when rigging 443
delete 595
deleting in Timeline view 612
flip between 613
Motion 596
motion
creating 679
position 595
Stop-motion 596
toggle between 596, 597
keyframe value
Timeline view 51

L

lasso
cutter tool option 131
perspective tool option 129
select tool 116
Lasso and Marquee 109
layer
Ortholock
using 559
parameters 590, 591
setting parameters 593
layer order
changing
in network view 435
layer properties
sound 565
Layers
3D parameters 539
about 247
layers
Add empty sound layer 575
adding images 340, 346
animating 584
changing colour 264
cloning 263, 501
collapse 265
concepts 247
content 251
converting into Symbols 462
creating strokes to paint on separate layer 211
deleting 255
drawing

adding 33
duplicating 263, 501
effect
using 720
enabling
playback 585
expand 265
Flash
about 364
incorporating into existing 420
lock all option
Timeline view 486
lock all others option
Timeline view 486
locking in Timeline view 485
lock option
Timeline view 485
modifying 256
moving with advanced animation tools 489
naming conventions
prior to break down 415
Network view
locate selected 483
ordering 256
rigging 439
ordering over time 698
overlay 213
panning 488
positioning elements 492
properties 261
renaming 262
rigging
parenting 431
rotating 488
selecting
from camera view 481
multiple 115
single 115
selecting in Animate Mode 655
Transform tool 656
selecting to reposition
ways of 481
setting 593
show/hide 257
sound 250
Timeline view
locate selected 482
underlay 213
unlock all option
Timeline view 486
unlock option
Timeline view 486
layers and pegs
about 586
Layer Section
Timeline view 236
layers ordering
in network view 440
Layer types 248
bitmap 248
camera 248
colour card 249
drawing 248
effect 248
group 249
peg 250
quadmap 250
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letters and logos
moving around 412
Library
closing 382
creating 381
generating
thumbnals 384
opening 382
refresh 384
Right to Modify 392, 393
structuring 381
understanding 378
library
importing characters from 646
storing characters in 456
library folders list
library view 58
Library list 380
Library View
about 57
interface 379
library folders list 58
menu 379
preview playback 57
preview window 57
swapping images 695
template/symbols list 58
Library View menu 57
Light Table 150, 178
Camera view 44
line
shape option 122
Line Art 210
drawing view 79, 81
linear velocity
creating 635
Lines
smoothing 133
line texture 91, 94
creating texture brushes 95
drawing with 92
erasing 95
hiding 96
how to draw with 93
opacity
adjusting 97
parameters 94
line texture parameters
Enable Texture 94
Hardness 94
Maximum Opacity 94
Minimum Opacity 94
Texture File 94
Texture Scale 94
line up
puppets
relative size 408
linking status
palettepalette
linking status 230
link/unlink three colours
colour view 56
Lip-sync
about 576
auto detection 580
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manual detection 579
modifying detection 581
mouth chart positions 577
mouth shapes 411
phonemes 576
lip-sync
sound 576
list of
Animate Pro
views 40
basic commands 35
Top toolbars 40
views 40
View toolbars 40
loading
workspace 64
lock
layers in Timeline view 485
locked 3D scale parameters 540
lock scales 592
lock/unlock layer
Timeline view 50
looping
sounds 573
low
resolution
selecting 30

M

managing
drawings 285
toolbars 62, 63
views 60
workspace 64
Manipulators
Select Tool Properties View 116
Tool Properties View 77
marquee
cutter tool option 131
perspective tool option 129
select tool 116
master peg
adding when rigging 442
setting pivot 450
matte view mode button
Camera view 43
maximum
eraser size 105
maximum size
Smooth Tool 134
menu
camera view options 43
editing stack menu 44
function drop-down 624
library view 379
zoom drop-down 44
menus
about 53
Play menu 59
Quick Access Menu 54
Top Menu 53
View Menu 53
minimum
eraser size 105
minimum size

Index
Smooth Tool 134
miscellaneous
vectorization parameters 370
mixing
sound 573
model
aligning 406
eyelids 410
importing 406
importing formats 406
mouth shapes 411
pupils 410
studying 410
tracing 460
modifying
colour 71
layers 256
module
composite
about 506
layer properties 507
importing 713
module library
tabs
about 713
module library toolbar
about 712
modules
adding 506
cable styles
bezier 521
custom 521
line 521
connect 510
connect to composite module 436
disable 516
disable all other 517
disconnect 510
display 522
effects 722
enable 516
enable all 516
enter group 513
exit group 514
explode selected group 513
grouping 510
grouping selected 510
group selection with composite 511
hide all thumbnails 519
hide thumbnails 519
input and output 505
move selected to parent 514
organizing 509
show thumbnails 518
thumbnails 518
more drawing layers 165
More Drawing Tools 141
morphing
aboutmorphing
about 302
adjusting quality 334
adjusting velocity 312
adjusting velocity and timing 312
adjusting velocity in layer properties editor 313
Appearing Point Hint 321
changing sequence length 312

closest similar shape 303
colour art to colour art 305
colour swatch to same colour swatch 304
Contour Hint 319
Convert Hints option 311
convert in-betweens to drawings 331
copying hint points between drawings 322
create basic sequence 306
deleting
entire sequence 308
deleting a sequence 308
Easing option 311
fill shape to fill shape 304
Flatten option 311
Hide hints 310
Hint Types 310
line art to line art 305
morphing holes and transparencies 332
Pencil Hint 320
pencil line to pencil line 303
principles 302
quality setting 311
rules 303
sequences 329
source and destination drawings 302
Suggest Hints option 310
Switch Between Drawings 310
Time parameter 311
tips and tricks
avoiding crossing zones 335
cleaning up drawings 335
flattening drawings 335
morphing similar shapes 335
using Contour Hint On Pencil Lines 335
using same colour swatch 335
using the brush tool to start 335
Tool Properties View 309
using Morphing Tool 317
vanishing and appearing 305
Vanishing Point Hint 321
Zone Hint 320
Morphing Layer Properties 325
morphing layers 311, 324
Morphing Tool and Hints 316
motion
copying 627
linear and curved
toggle between 608
pasting 627
motion keyframe
creating 679
Motion keyframes 596
adjusting velocity 633, 680
motion path
preferences
about 642
camera 643
control points options 644
general 642
settings options 643
snap keyframe options 643
tools options 643
mouse gesture
using 132
mouth chart
phonemes 576
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positions 577
recomputing 581
mouth shapes
model 411
mouth shapes chart
creating 578
movie
adding sound 564
moving
toolbars 62
Multi-click eye dropper 232
multiplane
creating 525
see also 3D Space 537
setting up 527
side view 525
top view 525

animation 703
trajectory 610
Offset X and Y 120
Onion Skin 148
Onion skin
Add All to Onion skin 685
Add to Onion skin 684
cut-out animation
using 684
Remove All from Onion skin 685
Remove from Onion skin 685
Remove unselected from Onion skin 685
onion skin
Timeline view 51

multiple drawings
in drawing view 169

Onion skin toolbar 160
OpenGL
preferences 535
drawings 536
settings 535

multiple layers
selecting 115

OpenGL frames
exporting 827

multiple renders
connecting modules 839

OpenGL view mode button
Camera view 42

music
sound synchronisation 289

opening
Animate 23
library 382

N

naming conventions
layers
prior to break down 415

Opening a scene
using Welcome Screen 26
opening a scene
ways to 26

navigating
between frames and columns 284
hierarchy 658

opening template as folder 398
Operations
Tool Properties View 77

Navigator display
positioning 520
showing
hiding 520
using 520

Operators and Operands
Animate Pro only
expression columns
operators and operands 638

network
rendering from 842
Network navigation 504
modules 504
Network setup 503
Network template
importing 647
Network view 503
basic rules view 504
locate selected layer in 483
navigator display 520
network view
change layer order in 435
ordering layers in 440
selecting a module in 657
NTSC
resolution
selecting 30
nudging
when rigging 441

O

object
text
breaking 139
offsetting

862

optical registration
vectorization parameters 370
optimization
change composite type 453
delete write module 451
modules
grouping 454
renaming
display module 451
Optimize command
options 142
Optimizing
change composite type 453
delete write module 451
display module
renaming 451
network 451
Options
3D
enabling 538
layer parameters 539
apply to multiple drawings 197
apply to visible drawings 198
ArrangeTool 141
automatic close gap 196
ConvertTool 141
Copying Pivot on Parent Symbol 447
Current Frame as Drawing Name 177

Index
eraser tool 105
group 145
IK tool 664
Easy Shape 664
IK Keyframe 664
paint and remove texture 197
pencil tool 99
Remove Extra Strokes 142
Reset pivot 447
respect protected colour 198
Set the Pivot for Symbol on all Frames 447
Show Grid 145
Snap 447
Thumbnail Location option 179
Tool Properties View 77
ungroup 145
use stored colout gradient 198
vectorization parameters 369
options
separate positions 592
Shift and Trace 161
ordering
layers 256
rigging 439
layers over time 698
timeline layers
rigging 439
Order Network script 509
organizing 3Dcomposite modules 562
Ortholock layer
using 559
Outline Locked Drawings
Camera view 43
overlay 81
Override Tool 140
Overwrite/Insert Modes
Xsheet view 243
Overwrite Mode 268

P

paint and remove texture
option 197
painting
drawings,how to 182
painting features
advanced 199
repaint outside selection 200
repaint outside selection all drawings 201
repaint selection 199
repaint selection all drawings 200
unpaint outside selection 202
unpaint outside selection on all drawings 203
unpaint selection 201
unpaint selection on all drawings 202
Paint Mode 195
Paint tool
properties 194
Lasso and Marquee 195
painting mode 195
using 194
Paint Unpainted Mode 195
PAL
resolution
selecting 30
palette

create 219
file storage 217
element level 217
scene level 217
palette list
advanced mode 216
basic mode 216
displaying 216
Drawing Element 218
Element 218
ordering 230
Scene 218
palette lists
advanced
preferences 234
palette option
paste special 402, 630
palettes
about 215
Panning
user interface 68
panning
drawing layers 488
element 490
parameters
3D pivot 542
3D rotation 541
Bezier function 625
Ease function 625
eraser blur 107
layer 590, 591
setting eases on multiple 636, 681
parenting layers
rigging 431
parent layer
hierarchy 49
show/hide children 49
parts
completing 422
paste
a motion 627
drawings 287
Paste Cycle 699
Paste Reverse 700
Paste Special
cycle palette option 630
cycle parameters 401, 402, 628, 629
drawing parameters 400, 401, 628, 629
palette option 402
parameters
advanced tab 401, 629
basic tab 400, 628
Symbols 401
Pegs and functions parameters 401, 629
Symbols 399
patch articulation 424
path
display in Camera view 603
modify
Function view 614
Timeline view 611
modify in Camera view 603
shaping in Camera view 604
PDF
import files 361
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peg
layers
using 587
peg layer 250
Pegs
adding to network 589
selection mode 590
pegs
about 587
about pegs 587
adding 701
adding to timeline 588
rigging with 433

move 489
reposition 114
temporary move 487
pivots
setting 446
copy 448
master peg 450
symbol frames 448
Pivot tool
using 447
planning pieces
in 3D space 550

pegs and functions parameters
paste special 401, 629

playback
enabling 585
sound 567

Pencil Hint
morphing 320

Playback range
customize 574

Pencil Styles
124
adding 124, 127
deleting 125, 128
Pencil tool option 100
Polyline option 127
renaming 124, 128
selecting 127
shapes 124

Playback Toolbar
about 58
Play menu 59

Pencil to Brush
convert 118, 141

Play menu
playback toolbar 59

Pencil tool
drawing with 84
using 102
Pencil Tool options 99
auto-close gap mode 99
auto-flatten mode 99
create colour art automatically 100
Draw Behind 99
pencil styles 100
adding 100
deleting 101
renaming 100
selecting 100
pen size 101
smoothness 101
Pen Size
Pencil tool option 101
perform zoom in
Zoom tool properties 146
perform zoom out
Zoom tool properties 147
Permanent Selection option 117
Perspective tool
using 129
Perspective Tool Properties 129
Perspective view
scene setup 526
phonemes
lip-sync 576
photo
puppets 407
photograph
creating
cut-out puppet from 407
pivot
3D 542
pivot point
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Playing Back
animation 158
effects 810
preview resolution 810
Playing back
sound 567

Polyline tool
drawing using 126
options 126
pose
selecting 649
poses
flipping through 683
positioning
in 3D space 549
scene components 481
positioning elements
using layer properties 492
positioning layers
in 3D space 553
Position keyframe 595
post processing
vectorization parameters 370
preferences 69, 297, 376, 404, 704
Advanced 299
advanced 536
Advanced Tab 179
advanced tab 234
apply next 298
auto save 71
bitmap format 298
Camera 531
Bounding Box Selection Style 532
Camera View Default Zoom 532
control size 533
min/ max 533
Nudging Factor 532
pivots and control points 533
rotation 533
scale 533
Show Locked Drawings As Outlines 532
skew 533
Small Bitmap Resolution 532

Index
Thumbnail Size 532
tools 532
Top/Side View Default Zoom 532
TV Safety 532
wash background 533
camera 704
character 413
colour 232
auto gap closing 232
default multiwheel colour picker 232
drawing mode tab 232
management 233
Multi-click eye dropper 232
new colour pots 232
current view border 71
template edit 71
drawing tab 178
edit colours 72
editing a template 404
Exposure Sheet 644
Exposure sheet 177
Current Frame as Drawing Name 177
exposure sheet tab 297
filtering 297
focus on mouse enter 71
function editors 644
General 816
general 175, 530, 816
editor always on top 530
Maximum FOV setting 531
Minimum FOV setting 531
native windows playback 530
options 530, 816
settings 531
general tab
colour management 233
highlights 70
Inverse Kinematics 704
Animate Pro only
preferences
Inverse Kinematics 705
levels of undo 71
modifying colours 71
motion path 642
camera 643
control points options 644
general 642
settings options 643
snap keyframe options 643
tools options 643
Network 533
drawing options 534
options 533
Network Navigator 533
new elementAnimate Pro only
preferences
new element 298
OpenGL 176, 535, 817
drawings 536, 817
effects 817
enable variable line thickness 536, 817
full scene antialiasing 177
real-time antialiasing 176
settings 535
options 298
panel
accessing 70

paste drag drop 404
render 843
Animate 843
Animate Pro 843
image management 844
cache options 844
multi threading 844
preview options 843
scene setup 530
Support CMYK in PDF/Illustrator Import 376
Timeline 298
UI 70
use advanced art mode 175
Xsheet 644
Preference Styles 24
Preview
eraser 106
preview
vectorization parameters 370
Previewing
effects 810
previewing
symbol
in Network view 398
preview mode
camera view 81
drawing view 79
preview playback
library view 57
preview resolution
effects 810
preview window
library view 57
Symbol 379
Printing
Xsheet 294
project
verify integrity 34
properties
IK tool 663
Inverse Kinematics tool 663
layers 261
Paint tool 194
Lasso and Marquee 195
painting mode 195
Transform tool 483
PSD
import as separate layers 350, 353
pupils
model 410
puppets
brush size
relative size 409
field chart
relative size 409
flipping parts of 686
line up
relative size 408
overlapping pieces 412
relative size of 408

Q

quadmap layer 250
quality
adjusting
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morphing 334
Quaternion
3D rotation 541
Quick Access Menu
about 54
QuickTime
exporting movies 820
importing movies 366, 368
QuickTime movie
export with transparency 823

R

Real-time antialiasing 85
Recentre view
user interface 68
rectangle
shape option 122
refresh
library 384
Remove All from Onion skin 685
remove art inside selection
scanned drawings 173
remove art outside selection
scanned drawings 172
remove colour
colour view 55
remove dirt
scanned drawings 171
Remove Extra Strokes
option 142
Remove from Onion skin 685
remove hair
scanned drawings 173
Remove unselected from Onion skin 685
rename
drawings 285
drawings by frame position 286
renaming
brush styles 90
folder 383
layers 262
Renaming a Workspace 65
render view mode button
Camera view 43
reordering
workspace list 67
Repaint Brush Mode 88
Repaint Mode 196
reposition
pivot point permanently 489
pivot points 114
pivot point temporarily 487
Reposition All Drawings 152
Reset pan
user interface 68
Reset rotation
user interface 68
reset rotation button
Camera view 44
resetting
transformation 500
Reset view
user interface 68

866

reset view
Zoom tool properties 147
reset view button
Camera view 44
Reset zoom
user interface 68
reset zoom
Zoom tool properties 147
Resizing a View 61
resolution
film-1.33 30
film-1.66 30
HDTV 30
low 30
NTSC 30
PAL 30
resolution tab 30
scene settings 30
respect protected colour
option 198
restoring
default workspace 67
Reuse
Extra Drawings 692
facial expressions 692
poses 692
rigging
about 430
basics 430
body 436
character’s head 434
hierarchy
creating 437
keyframes
creating 443
layer ordering 439
master peg
adding 442
nudging body parts 441
parenting layers 431
simple 430
simple body 436
timeline layer ordering 439
with pegs 433
Right to Modify
library 392, 393
Rotate 130
rotate
in 3D space 537
rotate 180 145
Rotate 90 CCW
user interface 68
Rotate 90 CW
user interface 68
Rotate operation 117
Rotate tool
3D
about 545
element 490
rotate tools
setting camera using 478
Rotate View tool 146
rotating
angle 120
drawing layers 488

Index
drawings
animation disc 146
element 490
rotation
3D 541
Euler Angles 541
Quaternion 541

S

safe area button
Camera view 43
save
workspace
automatically 71
saving
workspace 65
scales
locked 592
separate 592
Scale tool
3D
about 546
element 490
scaling
an element 489
element 490
scanned drawings
cleaning 171
remove art inside selection 173
remove art outside selection 172
remove dirt 171
remove hair 173
Scanning
images 355, 357
scene
backgrounds, importing 476
creating using Welcome Screen 26
import components 476
movie,importing 476
opening using welcome screen 26
positioning, components 481
settings 29
setup preferences 530
sounds, importing 476
startup script
new scene 28
symbols, importing 476
templates, importing 476
ways to open 26
scene length
setting 29, 244
scene setup
Perspective view 526
script
startup new scene 28
scripts
prefixes and suffixes 469
selecting
brush styles 89
character pose 649
current tool colour 192
drawing objects 113
film-1.33 resolution 30
film-1.66 resolution 30
FOV custom

resolution 31
FOV vertical fit
resolution 31
HDTV resolution 30, 31
keyboard shortcuts 73
layer for repositions
ways of 481
low resolution 30
NTSC resolution 30
PAL resolution 30
Transform tool
Camera view 656
Timeline view 657
selection
add frames after 244
add frames before 244
fill randomly 280
fill with sequence 279
Select Tool
switch to Transform tool 483
select tool
lasso 116
marquee 116
snap options 116
Select Tool Properties 116
Select Tool Properties View
manipulators 116
separate 3D scale parameters 540
separate scales 592
sequence length
changing in morphing 312
sequences
morphing 329
set current brush colour
colour view 55
set current paint colour
colour view 56
set current pencil colour
colour view 55
setting
eases
multiple parameters 636, 681
exposure 277
parameters 593
pivots 446
copy paste 448
master peg 450
scene length 29
symbol frames pivots 448
timing 158
setting quality
morphing 311
settings
scene 29, 30, 31, 33
Setting Scene Length
adding frames 244
settings options
motion path preferences 643
setting up
multiplane 527
Network 503
scene preferences 530
shapes
drawing using 121
shape tool
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automatic fill options 123
draw behind option 122
options 122
snap options 122
Shaping
using Contour Editor Tool 108
sharing
Function Curves 621
Symbols 391
Shift and Trace
option 161
shortcut
customize 74
selecting a default set of 73
Show Contour Editor Controls 110
show current drawing on top 83
Show Grid
option 145
show/hide
layers 257
show/hide children
Timeline view 49
show/hide data view
Timeline view 48, 51
show/hide functions
Timeline view 49

smoothing styles 134
Smoothness
Pencil tool option 101
Smoothness and Contour Optimization 106
smooth selection
Contour Editor 112
Smooth Tool
control point colours 135
control points 134
maximum size 134
minimum size 134
options 133
smoothness 134
style options 134
snap keyframe options
motion path preferences 643
Snap Options 122
Contour Editor tool 110
select tool 116
Snap options
Snap and Align 111, 116, 122
Snap to Contour 110, 116, 122
Snap to Grid 111, 116, 122
Snap to Contour
Polyline option 127

skewing
an element 489
element 490

solid colour swatches 184
Sound
about 563
about lip-sync 576
Add empty sound layer 575
displays 566
editing 569
editor, using 569
Element Editor 570
end frame
changing 570
trimming 572
importing 564
layer
properties 565
lip-sync 576
auto detection 580
manual detection 579
modifying detection 581
phonemes 576
looping 573
mixing 573
mouth chart
positions 577
recomputing 581
mouth shapes chart creating 578
music
synchronisation 289
playback 567
playback range 574
scrubbing 568
start frame
changing 570
trimming 572
tempo markers
music sync 289

Skew tool
element 490

sound display
changing 566

show/hide palette list view
colour view 56
showing 66
toolbars 62
show morphing in place 310
show selection
Timeline view 47
Show Strokes
Camera view 44
show strokes
washed-out colours 104
Show Strokes with Colour Wash
Camera view 44
Side view
element, positioning 528
multiplane 525
Simple Chain Mode
IK Mode 663
simple rigging 430
single layers
selecting 115
size
relative to characters 408
Size Adjustment
Polyline option 128
shape 125
skeleton
IK 667
Skeleton optimization
network 451

smooth 118
Smoothing
lines 133
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Sound editing 569
Sound Element Editor 570
sound layer 250

Index
sound playback range 574
Sound scrubbing 568
source drawings
morphing 302

about 385
animating using 687
clearing main timeline 463
convert layers into 462
creating 385
empty 388
form timeline 386
from draing selection 385
creating from Network view 387
deleting 388
Warning 388
duplicating 390, 691
editing 389
expanding 403
exposure
Timeline view 52
hierarchy 390
importing 395, 396
Timeline view 395
importing templates with 396
import template with 690
paste special 399
previewing in Network view 398
preview window 379
setting pivot 470
sharing 391
understanding 378

split
Timeline view 49
starting
Animate 23
startup script
new scene 28
stepped curve
creating 635
Stiffness
IK tool selection option 666
Stop-motion
animating in 677
keyframe
creating 677
keyframes 596
Store Colour Gradient 118
storing
extra drawings 472
facial expressions 472
gradients 206
in library 456
textures 206
Strokes to Pencil Lines
convert 142

symbols
importing 476

Stroke tool
using 102

Symbols list 380
synchronisation
music 289

Stroke tool options 103
connect line ends 103
draw stroke as straight lines 103
smoothness 103

T

Styles
preference 24

Template
create from Network view 393
importing Network template 397
opening
as folder 398

styles
smoothing 134

template
importing 646

structing
library 381

Suggest Hints
morphing 310
Support CMYK in PDF/Illustrator Import 376
swapping images
about 695
Library view 695
Timeline view 696
Swapping Views 61
swatches
adding colour 184, 186
bitmap texture 188
colour
using 183
deleting colour 190
gradient colour 186
solid colour 184
SWF
exporting movies 824
Switch Between Drawings
morphing 310
switching
between colour display modes 191
Symbols
3D
using in 550

template edit
preference 71
Templates
creating
from timeline view 392
deleting 394
editing 394
importing 395
Timeline view 395
using 392
templates
backward compatibility 648
importing 476
understanding 378
Templates list 380
template/symbols list
library view 58
Tempo Markers 289
Tempo markers
music
synchronisation 289
tension
adjusting 604, 607
text

869

Animate Pro 2 User Guide
alignment 138
breaking an object 139
creating in drawings 136
font size 138
font style 137
font type 137, 139
formatting 137
indent 138
kerning 138
resizing box 139
working with 136
texture brushes
creating 95
textures
editing 205
line 91
drawing with 92
hiding 96
parameters 94
storing 206
three-dimension
using 3D space 537
thumbnails
generating
library 384
Xsheet 263
time
effects over time 716
timeline
clearing in Symbols 463
timeline layers
ordering
rigging 439
Timeline View
about 46, 236
add drawing layer 47
add layers 47
add peg 48
change track colour 50
create function curve in 611
current drawing displayed in drawing view 48
current frame 48
data view section 237
delete layers 47
drawing exposure 52
drawing substitution 51
enable/disable all 47
enter value in 269
hide all others 47
keyframe 52
keyframe value 51
layer section 236
locking layers 485
lock/unlock layer 50
modify
path 611
onion skin 51
show/hide children 49
show/hide data view 48, 51
show/hide functions 49
show selection 47
sound scrubbing 568
split timeline view 49
Symbol exposure 52
timing section 237
transform tool
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Animate Mode 657
zoom 52
Timeline view 49
adding effects in 708, 714
locate selected layer in 482
swapping images 696
Time parameter
morphing 311
timing
setting 158
Timing Section
Timeline view 237
tips and tricks
IK 676
Inverse Kinematics 676
morphing 335
avoiding crossing zones 335
brush tool 335
cleaning drawings 335
contour hint on pencil lines 335
flattening drawings 335
same colour swatch 335
similar shapes 335
toggle
between keyframe and control points 606
motion, stop motion keyframes 596
motion,stop motion keyframes 597
stop motion, motion keyframes 596, 597
Toggle full screen
user interface 68
toolbar
Xsheet view 241
Toolbar Manager 63
toolbars
easy flipping 159
flip 159
hiding 62
managing 62
moving 62
onion skin 160
showing 62
Tool Name
drawing view 79
Tool name
camera view 82
tool name field
Camera view 44
Tool Properties View 77
about 45
manipulators 77
morphing 309
operations 77
options 77
tools 483
3D 543
Rotate tool 545
Scale tool 546
Transform tool 547
Translate tool 544
Rotate View 146
tools options
motion path preferences 643
Tools Toolbar
about 45
Top Menu

Index
about 53
Top Toolbars
Animate Pro
list of 40
list of 40
Top view
element, positioning 528
multiplane 525
Traditional Animation
advanced 159
Traditional Animation Tools
in digital animation 148
create empty drawing 151
drawing identification 151
light table 150
onion skin 148
reposition all drawings 152
Traditional animation with digital software 154
trajectory
adding control points 605
offfsetting 610
transformation
resetting 500
Transform/Select
switching between 483
Transform tool
3D
about 547
angle 485
animating with 659
Flip Horizontal 484
Flip Vertical 484
height 484
Lasso mode 483
Marquee mode 483
Peg Selection mode 484
Properties 483
Rotate 90 clockwise 484
Rotate 90 counter clockwise 484
selecting
Animate Mode 656
snap and align 484
snap options 484
snap to grid 484
switch to Select tool 483
using to position element 487
width 484
XY offset 485
Translate tool
3D
about 544
element 490
translate tools
setting camera using 478
Transparencies
morphing 332
transparency
exporting image sequence with 829
exporting QuickTime movies with 823
trimming
sound files 572
tutorials
Animate 25
TWAIN
using 355

types of 722
Typing Exposure 269

U

underlay 81
undo list
preferences 71
Ungroup
option 145
unit aspect ratio
customize 32
Unpaint Mode 196
update preview button
Camera view 42
User interface 40
highlights 41
pan view 68
Preferences 70
recentre view 68
Reset pan 68
Reset rotation 68
Reset view 68
Reset zoom 68
Rotate 90 CCW 68
Rotate 90 CW 68
Toggle full screen 68
views and toolbars, list of 40
zoom in 68
zoom in and out 68
zoom out 68
Use Stored Colour Gradient 89, 123
use stored colour gradient
option 198
using 675
File Menu 27
Hold Value editor 635
IK 675
IK modes 663
IK Tool and Rigging 675
pivot tool 447
Using effect layers 720
using Onion Skin
cut-out animation 684

V

Vanishing Point Hint
morphing 321
vectorization parameters
bitmap options 373
bubble usage 374
colour vectorization options 374
custom 368
help 371
File IO options 371
Filtering options 372
registration options 371
options 369
input 369
miscellaneous 370
optical registration 370
output 370
post processing 370
preview 370
RGB keying options 373
vectorization style

871

Animate Pro 2 User Guide
create 375
vectorizing
images 342, 348
vector options 497
Velobased
function
about 626
velocity
adjusting 633, 680
adjusting morphing 312
creating
linear 635
view
Rotate drawing 146
Viewing
Final Lines 85
View Menu
about 53
Views
Animate Pro
list of 40
list of 40
views
adding 60
closing 61
managing 60
resizing 61
swapping 61
views and toolbars
list of 40
View Toolbars
Animate Pro
list of 40
list of 40

X

Xsheet
Preferences 644
printing 294
Tempo Markers 289
thumbnails 263
Xsheet Main Section
Xsheet view 239
Xsheet View 238
about 236
column header 241
column list section 240
current drawing 242
current frame 242
current frame display 242
drawing exposure 242
enter value in 269
frame numbers 242
function column 243
functions section 239
increase/decrease exposure field 243
overwrite/insert modes 243
Xsheet main section 239
Xsheet view toolbar 241
Xsheet view
modifying paths in 618
Xsheet View Toolbar
Xsheet view 241

Z

Z-axis
elements, distributing 528
Zone Hint
morphing 320

volume
mixing sound 573

zones
verify painted 214

W

zoom
Timeline view 52

Warning
deleting a folder 383
deleting Symbols 388
Welcome Screen
about 25
create scene from 26
open scene from 26
using 25
width
select shape 120
windows
adding floating 60
workspace 66
auto save 71
creating 64
delete 66
hiding 66
loading a 64
managing 64
renaming 65
restoring default 67
saving 65
showing 66
workspace list
reorder 67
Workspace Manager 64
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zoom drop-down menu
Camera view 44
Zoom in
user interface 68
Zoom in and out
user interface 68
Zoom out
user interface 68
Zoom tool 146
Zoom Tool Properties 146
Zoom tool properties
perform zoom in 146
perform zoom out 147
reset view 147
reset zoom 147
zoom in 146
zoom out 146

