User Guide > Drawing > Drawing with the Brush Tool

Drawing with the Brush Tool

The Brush tool is used to draw and sketch on vector and bitmap layers.

If you want sketch a drawing using a semi-transparent colour to get a paper-like feel, then use the Brush tool as it produces a more realistic and natural feel.

The Brush tool is pressure sensitive and lets you create a contour shape with a thick and thin line effect, as if the drawing was made with a brush.

To draw with the Brush tool:

  1. In the Thumbnails or Timeline view, select the panel on which you want to draw.

  1. In the Thumbnails or Stage view, select a layer to draw on.

  1. In the Tools toolbar, select the Brush tool or press [Alt]+[B].
  1. You can change the current colour by adjusting the sliders in the Colour view, or click a swatch to use that colour. To add colour swatches—see Adding a Colour Swatch.

  1. In the Stage view, start drawing.
Hold [Ctrl] (Windows) or [z] (Mac OS X) to force a line to join the start and end of the stroke while drawing.

Hold [Shift] to force the brush to draw a straight line at any angle.
Hold [Shift]+[Alt]to force the brush to draw a straight line in 15 degree increments.
Press []](close bracket) to increase the brush tip size by 5.
Press [[](open bracket) to decrease the brush tip size by 5.
Hold the [O] key, click and drag to resize your brush dynamically, then release the mouse when the desired maximum thickness is reached.

Changing the Brush Tool Cursor Display

By default, the Brush tool cursor is displayed as a crosshair cursor, you can change the behavior to display the cursor as a shape of the current brush size.

To change the Brush tool cursor display:

  1. Open the Preferences dialog box:
Select Edit > Preferences (Windows) or Storyboard Pro> Preferences (Mac OS X).
Press [Ctrl] + [U] (Windows) or [⌘] + [,] (Mac OS X).
  1. Select the Tools tab.
  1. In the Drawing section, select the Brush Size Cursor option.

  1. Click OK.

The cursor displays the current brush size.

Changing the Brush Mode

When you select the Brush tool, the Tool Properties view displays the different Brush modes that control how the Brush line is drawn: Regular, Draw Behind, and Auto Flatten.

Regular Brush Mode

The Brush tool creates contour lines as you draw on vector layers, adding each brush line on top of the previous ones. On bitmap layers, the Brush tool creates 2D graphics, laying down individual pixels.

Draw Behind

When drawing on vector layers, the Draw Behind mode lets you paint behind existing art. By default, strokes appear over your work until you release the tool. If you want a live preview of your stroke in draw behind mode, you must activate the Realistic Preview option.

To activate Realistic Preview:

From the top menu, select View > Realistic Preview.

Auto Flatten Mode

When drawing on vector layers, lines do not usually become one object. The Auto-Flatten mode automatically merges lines created with the existing ones into one single object as you draw.

When drawing on a bitmap layer, you are laying down the bare pixels, so they are always flattened. You can no longer access the individual stroke after you draw it.

NOTE:

Using the Select tool, you can use select and remove a segment of flattened pencil lines. Overlapping pencil lines drawn with the Auto-Flatten mode enabled are essentially cut into segments by the overlap and can therefore be treated as individual lines.

 

Selecting a Brush Style

A variety of brush styles are provided allowing you to create and save your own.This way you can create brushes with precise sizes and parameters and save them so you can draw and design.

To select a brush style:

In the Tool Properties, select a brush style from the Brush Presets section.

The Brush properties are displayed. What you see depends on whether you are drawing on a vector or bitmap layer.

Changing the Brush Display

There are several ways to display the available brushes: small or large thumbnails, or strokes.

To change the brush display:

In the Tool Properties view, click the Brush menu, and select Small Thumbnail, Large Thumbnail, or Stroke View.

Adding Customized Brush Patterns with the Dynamic Brush

When creating drawings for a panel, there may be a specific object that is repeated many times to create a bigger picture, such as a landscape. The object can be a blade of grass, tree, or rock. Instead of creating this drawing and then copy/pasting it over and over again, you can create a pattern and assign it as its own brush.

You can create your pattern, select it, and add it to your brush styles using the Dynamic brush.

To add a pattern to your brush styles using the Dynamic brush:

  1. Use the Brush drawing tool to create a small drawing.
NOTE: If you are drawing on a vector layer, you may want to select Auto Flatten mode to help create a single object.

  1. Use the Select tool to choose the parts of the drawing you want to use as the pattern.
  1. In the Tool Properties view, click the New Dynamic Brush button to use the current layer as a new brush pattern.

If you do not want to use the entire layer as the brush pattern, select the parts of the drawing you want to use as the pattern. If you do this, you must reselect the Brush tool before you click the New Dynamic Brush button.

When you add the Dynamic Brush to your brush styles list, it is given a default name and a preview appears in the Tool Properties view. You can use the Rename Brush button to give the Dynamic Brush a more meaningful name.

  1. Use the new Dynamic Brush to quickly repeat a pattern.

To create a Dynamic Brush with multiple drawings:

  1. Create drawings on the same layer of multiple panels or multiple layers of the same panel.

  1. In the Thumbnails, Timeline, or Stage view, [Shift]+click to multiselect all the layers you want to use to create the Dynamic brush. If you are creating your brush with panels, [Ctrl]+[Shift]+click (Windows) or [⌘]+[Shift]+click (Mac OS X)) the panels to use to create the Dynamic brush.
  1. Select the Brush tool and click the Add Dynamic Brush button.
  1. In the Tool Properties view, adjust the slider to see the properties of the Dynamic brush.

Your new Dynamic brush will contain all the selected drawings. When you use this brush, you will cycle through the drawings.

Renaming a Brush

Deleting a Brush

You can delete the brushes you no longer use.

To delete a brush:

  1. In the Tool Properties view, select a brush to delete.
  1. Do one of the following:
Click the Delete Brush button.
From the Brush menu, select Delete Brush.

Adjusting the Brush Properties

The brush properties available depend on whether you are drawing on a vector or bitmap layer. On both layers, you can set the minimum and maximum sizes of your tool, which produces the thick and thin effect on your line. This works with the pressure sensitivity of a pen tablet.

On vector layers, you can modify the central line smoothness of your line, as well as smooth the initial movement of your line. Increasing the value will result in a smoother line with fewer control points.

On bitmap layers, you can optimize the flow of lines and set the rate at which colour is applied as you draw. As you draw over an area, the amount of colour builds up based on the flow rate, up to the maximum flow rate you set.

To adjust the brush properties:

In the Tool Properties view, click the arrow button.

The Properties window of the Brush tool opens.

To adjust brush properties on bitmap layers:

  1. Do the following:
Maximum/Minimum Size: Defines the minimum and maximum width of the stroke.
Maximum/Minimum Flow: Sets the rate at which colour is applied as you draw a stroke. As you draw over an area, the amount of colour builds up based on the flow rate, up to the maximum flow rate you set.
Spacing: Controls the spacing between the brush marks of a stroke.
Hardness: Controls the size of the brush's hard centre.
Select Texture: Uses a pattern to make strokes—see Drawing with Textured Brushes.
Texture Scale: Determines the size of the texture used in strokes.

To adjust brush properties on vector layers:

  1. Do the following:
Maximum/Minimum Size: Defines the minimum and maximum width of the stroke.
Smoothing: Defines the number of control points added to the centre line.
Contour Smoothing: Defines the number of control points added to the contour boundaries (around the line). Lower values mean that the line will appear as you draw it (with more control points added along the centre line). Higher values mean that the line will be smoothed out (removing control points from the centre line).
Shape: Lets you select a shape for the tip of the brush. There are a variety of brush tips to choose from: round, square, oval, star-shaped, and more.

Textured Tip: Uses a pattern to make strokes.
Hardness: Controls the size of the brush's hard centre.
Opacity: Sets the minimum and maximum transparency of strokes.
Select Texture: Uses a pattern to make strokes—see Drawing with Textured Brushes.
Texture Scale: Determines the size of the texture used in strokes.

Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the different parameters in the Tool Properties view.

  1. Select a brush style from the Presets section. It's a good idea to choose a brush preset that is closest to the style you want to create.
  1. Click on the Show Extended Properties arrow to display advanced customization parameters.

Preview Stroke

Changing the Line Texture

In Storyboard Pro, you can draw with a textured line. When drawing on vector layers, textured lines are a mixed bitmap image contained in a vector frame. This allows you to sketch as if you are drawing on paper. When drawing on bitmap layers, there is no vector frame. There is only one big rectangular canvas that you are drawing on—see Drawing with Textured Brushes.

Converting Brush Strokes to Pencil Lines

When drawing on vector layers, you may want to change brush strokes to pencil lines to convert contour strokes into centre line pencil strokes.

NOTE: Any line thickness information is lost upon conversion from brush to pencil

To convert brush strokes to pencil lines:

  1. Select the strokes you want to convert.
  1. Right-click and select Convert > Brush Strokes to Pencil Lines.

Working with Brush Presets

Brush presets are created by saving the properties of the current brush to a new preset, which you can reuse for repeated tasks. You can create as many brush presets as you need.

To access the brush presets:

From the Panel view, click the View menu and select Tool Properties.

Working with Tool Presets

Tool presets let you save a variety of settings and are very handy and efficient for accessing the tools you use most often. That way, the tool is already set with the desired properties, such as colour, line thickness, whether to enable Draw Behind or Auto Flatten mode, and so on. You can create presets for these tools and many more: Brush, Pencil, Eraser, Rectangle, Ellipse, and Line. First, select a tool, adjust the properties, and then create a tool preset for it. Once you have created a tool preset, you can always make adjustments to fine-tune it, as well as create a keyboard shortcut for it.

What's the difference between a tool preset and a brush preset? When you save a tool preset, you have the option of saving the colour, which you cannot do with brush presets.

The Tool Presets Toolbar

The Tool Presets toolbar lets you create new tool presets and manage them. There are four default brush presets to get you started—Rough, Clean, Shading, and Revision. By default, this toolbar is not displayed.

Assigning Keyboard Shortcuts to Tool Presets

Assigning a keyboard shortcut to tool presets lets you quickly access them—see Customizing a Keyboard Shortcut.

Preventing the Selection of a Random Layer with a Tool Preset

When using presets, it is possible to assign a layer so a tool specifically draws on that layer. When the preset is selected, it will verify if the layer exists. If so, the layer will be selected and if not, it will be created. When changing panel, depending on your global navigation setting, the normal behaviour is that Storyboard Pro name will look for the same layer and if it does not exists, it will select the first layer available. To prevent Storyboard Pro to select a random layer and not have it select any layer, you can enable the Enable Brush Preset Layer Selection Lock preference. This way, you will avoid to draw your artwork on the wrong layer and your project will remain even cleaner and organized.

To assign a layer to a tool preset:

  1. Open the Preferences dialog box:
Windows: Select Edit > Preferences or press [Ctrl] + [U].
Mac OS X: Select Storyboard Pro > Preferences or press[⌘] + [,].
  1. Select the General tab.
  1. In the Layers section, select the Enable Brush Preset Layer Selection Lock option.