User Guide > Layers > About Layers

About Layers

In animation, a layer is an individual column, level, or character. The scene’s layers are superposed to form the final image. When you import an image or draw in a panel, you are actually adding artwork to one of its layers. By default, each panel has two layers, a background (BG) and a foreground layer (A). As you add layers, they are automatically assigned subsequent letters in alphabetical order, but you can rename them. They are also placed on top of the selected layer or at the very top of other layers if there is no layer selected in the panel.

This section includes the following topics:

Drawing on a Layer
Types of Layers
Viewing Layers
Selecting Layers
Identifying Layers

Drawing on a Layer

When you open a project, the Stage view is displayed by default in the Storyboard Pro window. In the Stage view, tabs are always displayed, allowing you to navigate between layers. If the Thumbnails view is large enough, layer tabs are displayed for each pane there as well. By default, an empty layer will have the closed eyes icon to indicate that it is empty. As soon as you draw or paste anything on an empty layer, the eyes icon will open.

To draw on a layer:

  1. Select a layer by clicking it.

The active layer is highlighted in blue.

  1. Choose a drawing tool and begin drawing in the Stage view.

Types of Layers

There are three types of layers you can use depending on the type of graphics and artwork you are aiming to achieve: bitmap, vector, and 3D.

Bitmap Layers: Allow you to create 2D graphics that are resolution independent. Bitmap graphics are made of pixels on a grid that resemble tiny dots, which altogether make up the drawing you are creating or artwork you are importing. Bitmap graphics impart a more natural and soft look to your work. The colour is defined on a pixel-by-pixel basis.

Vector Layers: Allow you to create 2D graphics that are made of many individual, scalable objects. Each object is created by a mathematical equation rather than pixels, so they always display at the highest quality. Because they are scalable, vector objects are resolution independent. You can increase and decrease the size of vector objects and your lines remain crisp and sharp, which is ideal for cartoons! On vector layers, the colour is defined for the whole stroke.

Vector objects can consist of lines, curves, and shapes that you can edit and transform using control handles. Vector graphics are not restricted to rectangular shapes like bitmap graphics. You can place vector objects over other objects, and the object below will show through.

3D Layers: Allow you to import 3D objects into layers, creating a project that mixes 2D and 3D styles—see Adding 3D Objects to the Storyboard.

Viewing Layers

There are several ways to display layers in Storyboard Pro: in the Stage view or Layers panel. In both, thumbnails are displayed on each layer, so you can easily identify its contents.

To view layers in the Stage view:

In the Stage view, click the arrow button to expand the layer tabs.

To view layers in the Layers panel:

  1. Do one of the following:
From the View menu, select Layers.
From the top menu, select Windows > Layers.

The Layers panel displays all the layers in the selected panel.

Selecting Layers

You can select any layer from the Stage view, Layers panel, or Thumbnails view. Selected layers turn blue.

To select a layer, do one of the following:

Stage view: Click the layer tab of the layer you want to select.
Layers panel: Click the layer you want to select.
Thumbnails view: Click the layer tabs of the layer you want to select. Arrows above and below the layer tabs indicate additional layers.
To select multiple layers, press [Ctrl] (Windows) or [⌘] (Mac OS X) and click each layer you want to select. Also, press Shift and click one layer and then another to select a sequence of layers.

To select the next and previous layers:

  1. Select a layer.
  1. From the top menu, select one of the following:
Layer > Select Next Layer to select the next layer up the layer stack, stopping at the top of the stack.
Layer > Select Previous Layer to select the next layer down the layer stack, stopping at the bottom of the stack.

Identifying Layers

Each type of layer is indicated by a different colour and icon to help you clearly identify the type of layer you are working on. The default colours of the layers can be changed in the Global UI tab of the Preferences dialog box—see Preferences.