User Guide > Script and Panels > Scenes and Panels

Scenes and Panels

To build and organize your storyboard project, you will use panels, scenes, sequences, and acts. You have many options to customize these project elements in order to keep things clear and organized.

This section includes the following topics:

What are the Differences between Sequences, Scenes, Panels and Acts?
Sequences
Scenes
Panels
Acts

What are the Differences between Sequences, Scenes, Panels and Acts?

  1. A panel represents an action and is the smallest element of the three. You should use multiple panels whenever you need more than one drawing to clearly express the acting within a scene. It is the white rectangle representing the camera view. By default the current panel will be highlighted in red in the Thumbnails view.
  1. A scene is composed of one or several panels. In animation, whenever the camera angle changes, you should create a new scene. In live action, this is called a shot.In other words, if your action goes from a mid shot to a close shot, each of these shot should be a different scene. By default, a grey rectangle connects the different panels of a scene together.
  1. A sequence is a series of scenes that should be grouped together. Usually, scenes are grouped together by location. For example, all the scenes that are taking place in one location, should be in the same sequence and as soon as there is a change of location, it should be a new sequence. by default, a blue line connects the different scenes of a sequence together.
  1. An act is composed of one or several scenes and sequences. An act usually represents a story arc. It can be a certain time lapse in the story. For example, all the scenes in the first half of a TV series are one act, and the second act is after the commercial break. As for movies, live action, or even video games, there could have several different story arcs. In Storyboard Pro, a purple flag shows the beginning of a new act.

Scenes

In Storyboard Pro, you can easily create, import, rename, split and delete scenes.

This section contains the following topics:

Creating Scenes
Create Scene Before
Creating a Scene from Selected Panels
Selecting All Panels in a Scene
Import Images as Scenes
Automatic Insertion
Deleting Scenes
Renaming Scenes
Locking and Unlocking Sequence, Scene and Panel NamesLocking and Unlocking Sequence, Scene and Panel Names
Splitting or Breaking the Current Scene

Creating Scenes

To create a scene:

In the Storyboard toolbar, click the New Scene button or select Storyboard > New > New Scene.

A new scene, containing one blank panel, is added after the current scene.

Create Scene Before

You can also create a scene that will appear before the current scene.

To create a scene before current scene:

Select Storyboard > New > New Scene Before.

A new scene containing a blank panel is added before the current scene.

Creating a Scene from Selected Panels

A scene can be created from a selection of panels.

To create a scene from a selection of panels:

1. In the Thumbnails or Timeline view, select one or more consecutive panels.

2. Select Storyboard > New > New Scene from Selected Panels.

The selected panels are joined together within the scene.

Selecting All Panels in a Scene

You can select all the panels in a scene, using the Select All Panels in Scene command.

To select all the panels of a scene:

  1. In the Thumbnails or Timeline view, select one panel inside the scene you want to select all panels from.
  1. Select Edit > Select All Panels in Scene.

Import Images as Scenes

You can import one or several images and have Storyboard Pro automatically create a new scene for each. Use this option if you have a series of bitmap images that you need to include, such as backgrounds or scanned storyboards.

The supported image formats include: *.bmp, *.jpg, *.omf, *.opt, *.pal, *.png, *.psd, *.scan, *.sgi, *.tga, *.tif, *.tvg, and *.yuv.

To import images as scenes:

  1. Select File > Import > Images as Scenes.

The Choose Image Files browser opens.

  1. Browse to the desired images, select one or more images, and click Open.

The images are imported and a new scene is created for one.

NOTE: By default, when importing images in Storyboard Pro, the images are vectorized in colour and imported in vector layers. You can have access to more vectorization options by enabling the Display Vectorize Options Dialog preferences. Refer to Importing Images as Layers to learn more.

Automatic Insertion

When using the Import Images as Scenes function, you can save a little time by using the following naming convention for your bitmap images when you scan. Having your bitmap images named in the following manner, will allow acts, scenes, panels and layers to be created upon import into Storyboard Pro.

To use Automatic Insertion:

  1. When scanning your images, name them according to the following example:

<name>-A#-S#-E#-P#-L<layer name>.<extension>

Name: This is the name of the project. This string will not be inserted into the Storyboard Pro project, but it is mandatory.
A: Indicates the act the image will be placed in. Replace the # with the number of the act.
S: Indicates the first (or only) scene the image will be placed in. Replace the # with the number of the first scene this image will be used in.
E: (Optional attribute) Use this attribute along with the S attribute if you want the image to be included in multiple scenes. Replace the # with the number of the last scene this image will be used in.
P: (Optional attribute) This attribute is to indicate which panel the image will be placed in. Replace the # with the number of the panel in the scene.
L: (Optional string) This string is to indicate the name of the layer where the image will be placed. Replace the # with the number of the layer in the scene.
  1. Select File> Import >Images as Scenes, and browse to the location on your computer where your images are saved.

The following are two examples of how the Automatic Insertion could be used:

To use the Automatic Insertion:

  1. The drawings are scanned and named as such:
LittlePigs-A1-S1-P1-LBackground.jpeg
LittlePigs-A1-S1-P2-LBackground.jpeg
LittlePigs-A1-S1-P3-LBackground.jpeg
LittlePigs-A1-S2-P1-LBackground.jpeg
  1. Then, imported using the File > Import > Images as Scenes command, they are imported in the following order in the Storyboard Pro project:

To use the Automatic Insertion using the E parameter:

  1. A drawing is scanned and named like this: LittlePigs-A1-S5-E7-P1-LBackground.jpeg
  1. Then, imported using theFile > Import > Images as Scenes command, the image is placed in act 1, in scenes 5 through 7, on panel 1 on a layer called Background:

Deleting Scenes

If you have one or more scenes that you need to remove, you can easily do so.

To delete one scene:

  1. In the Thumbnails view, select a scene to delete. If it is composed of more than one panels, select them all. You can also click on the minus sign in the top-left corner of the scene to collapse the scene as one panel and select it all as once.

 

  1. Select Edit > Delete Selected Panels/Transitions or press [Delete].

The selected scene is deleted from your storyboard.

NOTE:

When a scene is deleted, or a new scene is inserted between two existing scenes, the numbering of the scenes will be out of order. By default, there is no automatic renaming of scenes. You can change this in the Preferences dialog box—see Preferencesand Renaming Scenes.

Renaming Scenes

When you start moving scenes and panels around, the Rename Scene dialog box automatically opens and prompts you to rename every time. You can also rename selected scenes as needed, using the Rename Scene command or the Panel view.

Renaming Scenes Using the Rename Scene Command
Renaming a Scene Using the Panel view

Renaming Scenes Using the Rename Scene Command

This command lets you rename a selected scene, as well as all the other scenes following it to make sure they are in order.

To rename scenes with the Rename Scene command:

  1. In the Thumbnails view, select a scene to rename.
  1. Select Storyboard > Rename Scene.

The Rename Scene dialog box opens.

  1. In the New name field, type the new name for the selected scene. You can type either a number or a name.
  1. You can use the Renaming Rule for Subsequent Scene menu and determine if the next scenes should be renamed. The Renumbered Scene Names section displays the current and new names for all the scenes that will be affected by the renaming process.
Current Scene Only: Renames only the selected scene.
Renumber Scenes: Renumbers the current scene, as well as all the scenes that follow.
Renumber Selected Scenes: Renumbers the first selected scene of a multiselection, as well as all the following scenes that are part of the multiselection.
Renumber Prefix Only: Renumbers the scenes numerical prefixes beginning at the selected scene. The new name must be a numerical value.
Renumber Subsequent Scenes in Current Sequence: Renames the selected scene, as well as all subsequent scenes in the same sequence.
Renumber All Scenes in Current Sequence: Renames all the scenes contained in the selected sequence.
  1. Select the Reset Panel Name option to reset all panel names according to the current panel time automatic increment rule—see Preferences section to learn how to define the auto-increment rule.
  1. Select the Do not show this dialog automatically option to prevent it from automatically opening every time you move scenes around—see Show Rename Dialog Automatically
Renaming a Scene Using the Panel view

You can rename scenes one at a time using the Panel view.

To rename a scene using the Panel view:

  1. In the Thumbnails view, select a scene to rename.
  1. In the Panel view, type the new name or number for your scene in the Scene field.

  1. Press [Enter} to validate.

A warning message appears if the name is invalid or already used by another scene. If this happens, it is recommended to use the rename command and rename all subsequent scenes.

Locking and Unlocking Sequence, Scene and Panel Names

It is possible to lock sequence, scene and panel names to prevent any unwanted modification.

Locking Scene and Panel Names
Unlock Sequence, Scene and Panel Names
Locking Scene and Panel Names

To lock scene and panel names:

  1. Select Storyboard > Lock Sequence, Scene and Panel Names.

The Scene and Panel fields become deactivated.

The Thumbnail view displays a locked icon in the header.

Unlocking Scene and Panel Names

To unlock scene and panel names:

  1. Select Storyboard > Unlock Sequence, Scene and Panel Names .

The names are unlocked and can be edited if necessary.

NOTE: To type custom panel names, you must enable the Allow Custom Panel Names preferences—see Renaming Panels

Splitting or Breaking the Current Scene

Using Storyboard Pro, you can split the current scene in two or break it into three parts. By default, the preferences are set so that the Split Current Scene command divides the scene before the current panel. You can change this so that the same command breaks the scene into three parts by isolating the selected panel.

To split the current scene:

  1. In the Thumbnails view, select a scene to split. The current scene must contain two or more panels. The split will occur before the current panel.

  1. Select Storyboard > Split Current Scene.

The scene is split into two scenes.

To break the current scene:

  1. In the Preferences dialox box, select the General tab, and then select the Break Scene when performing the “Split Current Scene” command option.

  1. In the Thumbnails view, select a scene to break. The current scene must contain two or more panels.

  1. Select Storyboard > Split Current Scene.

The scene is divided in three.

Panels

Your scenes should comprise as many panels as needed to show the actions taking place. With Storyboard Pro, you can easily create different panels for your project.

By default, you can find this information on the top of each panel:

This section includes the following topics:

Creating Panels
Create Panel Before
Smart Add Panel
Renaming Panels
Locking and Unlocking Sequence, Scene and Panel Names
Deleting Panels
Duplicating Panels
Moving Panels Around

Creating Panels

When you are creating a panel, the new panel is added after the current panel.

To create panels:

  1. In the Thumbnails view, select the panel to which you want to add a panel.

  1. Do one of the following:
In the Storyboard toolbar, click the Create Panel button.
Select Storyboard > Create Panel.
Press [P].

A new panel is added to the storyboard, and is part of the same scene as the current panel.

Create Panel Before

You can also create a new panel before the current panel.

To create a panel before:

  1. In the Thumbnails view, select a panel.

  1. Select Storyboard > Create Panel Before.

A new panel is added before the current panel and inside the same scene.

Smart Add Panel

You can create a new panel that contains elements from another panel.

To smart add a panel:

  1. In the Thumbnails view, select the panel that contains the elements you want to be duplicated into your new panel.

  1. In the Storyboard toolbar, click the Smart Add Panel button or select Storyboard > Smart Add Panel.

The Smart Add Panel dialog box opens.

  1. Select the layers that contain material you want to copy into the new panel.
  1. Select the Add default layer if missing option to create the default layers of the new panel if they are not part of the Smart Add Panel selection list.

A new panel is created next to the selected panel. All layers are copied into the new panel, but only the layers you chose contain artwork.

Renaming Panels

By default, the rename panels option is locked. You must unlock this option in the Preferences dialog box before you can rename panels.

To enable the Allow Custom Panel Name preferences:

  1. Open the Preferences dialog box:
Select Edit > Preferences (Windows) or Storyboard Pro > Preferences (Mac OS X).
Press [Ctrl] + [U] (Windows) or [⌘] + [,] (Mac OS X).
  1. In the Preferences dialog box, select the Naming tab.
  1. In the Panel section, select the Allow Custom Panel Names option.

The Panel field in the Panel view can be now edited.

Renaming Panels Using the Panel View

You can rename one panel at a time using the Panel view—Panel Information

To rename a panel from the Panel view:

  1. In the Thumbnails view, select the panel you want to rename.

  1. In the Panel view, type a new name in the Panel field and press [Enter}.

The panel is renamed.

Renaming Panels Using the Rename Panels Command

You can rename one or more panels simultaneously using the Rename Panel command.

To rename panels using the Rename Panels command:

  1. In the Thumbnails view, select the panel you want to rename.

  1. Select Storyboard > Rename Panel.

The Rename Panel dialog box opens.

  1. Type a new name in the New name field.
  1. You can use the Renaming Rule for Subsequent Panel menu to determine if the next scenes should be renamed:
Current Panel Only: Renames only the selected panel.
Renumber Panels: Renumbers the current panel, as well as all panels that follow.
Renumber Selected Panels: Renumbers the first selected panel of a multiselection, as well as all following panels that are part of the multiselection.
Renumber Prefix Only: Renumbers the panels’ numerical prefixes beginning at the selected scene. The new name must be a numerical value.

The Renumbered Panel Names section displays a list of the panels that will be renamed, their old names and the new names.

Locking and Unlocking Sequence, Scene and Panel Names

It is possible to lock sequence, scene and panel names to prevent any unwanted modification.

Locking Sequence, Scene and Panel Names

To lock sequence, scene and panel names:

  1. Select Storyboard > Lock Sequence, Scene and Panel Names.
The Sequence, Scene and Panel fields become deactivated.

The Thumbnail view displays a Locked icon in the header.

Unlock Sequence, Scene and Panel Names

To unlock sequence, scene, and panel names:

Select Storyboard > Unlock Sequence, Scene and Panel Names.

The names are unlocked and can be edited if necessary.

Deleting Panels

Once you start adding panels, you can also delete some. Note that it is impossible to have an empty project, there is a minimum of one panel.

To delete panels:

  1. In the Thumbnails view, select one or more panels to delete.

  1. In the Storyboard toolbar, click the Delete Selected Panels button. You can also select
    Edit > Delete Selected Panels/Transitions from the top menu or press [Delete].

The selected panels are deleted from your storyboard.

Duplicating Panels

You can duplicate panels when you need to create an exact copy of an already existing one.

To duplicate panels:

  1. In the Thumbnails view, select the panel or range of panels to duplicate.

  1. In the Storyboard toolbar, click the Duplicate Selected Panels button or select
    Storyboard > Duplicate Selected Panels.

The duplicated panels are added at the end of the current scene. If the selection included panels from different scenes, new scenes are created for them.

Moving Panels Around

You can easily move panels around in the Thumbnails and Timeline views using drag and drop. You can use drag and drop to reorder, separate or join selected panels. Joining selected panels will make them part of the same scene.

Selecting Panels
Reordering Panels in the Thumbnails view
Joining Panels
Reordering Panels in the Timeline view
Joining Selected Panels Using the Top Menu
Selecting Panels

To drag and drop panels:

  1. In the Thumbnails or Timeline view, select one or more panels to move around.

 

  1. Click the header of the current panel and drag it to the new location.

When you move your cursor around, a smaller version of the first selected panel with a number in it. The number represents how many panels are selected and being moved around.
In the Thumbnails view, a straight blue line or a blue bracket represents what the movement will do.
In the Timeline view, a green bracket or a green shape represents what the movement will do.
Reordering Panels in the Thumbnails view

To reorder panels, drag and drop your selection where you see a blue straight line. You can drop your selection between two scenes or in the middle of a scene. Dropping a panel in the middle of a scene will include it in the scene; it will not split it.

Remember that if you select more than one panel to move, you must drag them by clicking the current panel in the selection. Clicking any other panel in the selection will deselect the rest.

You can drag and drop a selection to remove it from a scene. Just drag the selection out and drop it between two scenes when you see a straight blue line appear.

Joining Panels

You can drag and drop a selection so it joins another scene. Just drag the panel onto the edge of the scene you want it to attach to, and drop it when you see a right-facing or left-facing bracket appear.

Reordering Panels in the Timeline view

To reorder panels in the Timeline view, drag and drop your selection when you see a green bracket or a green shape. You can drop your selection between two scenes or in the middle of a scene. Dropping a panel in the middle of a scene will include it in the scene, it will not split it. Remember that if you select more than one panel to move, you must drag them by clicking on the current panel in the selection. Clicking any other panels in the selection will deselect the rest.

You can drag and drop a selection to remove it from a scene. Just drag the selection out and drop it between two scenes when you see a green rounded rectangle shape appearing.

Joining Selected Panels Using the Top Menu

You can also use the top menu to join panels together.

To join selected panels:

  1. In the Thumbnails view, select two or more panels that are not part of the same scene.

  1. Select Storyboard > Join Selected Panels.

The selected panels are joined in the same scene.

Marking Panels with Custom Colours

It is possible to mark panels with a custom colour to manage them and to quickly be able to identify them. This option is also available for audio clips--refer to Sound to learn more about audio.

To mark a sound clip with colour:

  1. In the Timeline view, select the panel you want to mark with colour. You can also make a multiple selection.

  1. Right-click on your selection and select one of the following option: Set Colour > Red, Orange, Yellow, Green, Blue, Purple or Custom. Choosing custom, will open a Colour Picker dialog box, in which you can select the colour of your choice.

The selected panel will change to the colour you have chosen.

To reset the panel colour:

  1. In the Timeline view, select the panel you want to reset the colour to default. You can also make a multiple selection.
  1. Right-click on your selection and select Set Colour > Default Colour.

The selected panel colour will reset to the default colour.

NOTE: The default colour of panels is grey. However, you can change this value from the Preferences panel--refer to Preferences, in the Discovering the Interface chapter to learn how.

Sequences

A sequence is a particular section of the story composed by one or several scenes that has a unity in either time or its location. Scenes that are contained in different sequences can have the same name. Like scenes, panels, and acts, you can manipulate the sequences of your story while you are building your storyboard.

This section contains the following information:

Creating a Sequence
Creating Sequences Automatically
Selecting All Panels in a Sequence
Renaming a Sequence
Joining Selected Sequences
Splitting the Current Sequence
Removing All Sequences from Project

Creating a Sequence

By default, when you start building your storyboard using the New Scene button or command, the scenes that are created are not part of a sequence. If you want to start adding sequences to your project, you must use the New Sequence button for every new scene beginning a new sequence. This will add a new scene to your project and show the sequence markers in the Thumbnails and Timeline views.

You can also start adding sequences to your project at anytime, using the New Sequence from Selection command, and manipulate them using the different commands in the following topics.

NOTE: When you add a new scene using the New Sequence button or command for the first time in your project, all scenes that are prior to it will be combined as a sequence. For this reason, you should use New Sequence button when starting the first scene of your second sequence.

To create a new sequence:

In the Storyboard toolbar, click the New Sequence button or select Storyboard > New > New Sequence.

A new scene is added to your project and is now the starting point of a new sequence. If this is the first sequence you add to a project, all scenes prior to it will be combined as a sequence as well. The sequence markers will also become visible in both the Thumbnails and Timeline views.

To create a new sequence from a selection:

1. In the Thumbnails or Timeline view, select one or many scenes to combine as a sequence.

  1. Select Storyboard > New > New Sequence from Selection.

Your selection becomes a new sequence. If this is the first sequence you add to your project, all scenes that are prior or next to it will be combined as sequences as well and the sequence markers will become visible in both the Thumbnails or Timeline views. If your selection was part of an already existing sequence, it will be split accordingly.

NOTE: A single scene cannot be split into two or more different sequences, unless you split the scene prior to the operation.

Creating Sequences Automatically

By default, new storyboard projects are created without sequence. You can change this, so that new projects are automatically created with a sequence.

To enable the Automatically Create New Sequence preference:

  1. Open the Preferences dialog box by doing one of the following:
Select Edit > Preferences (Windows) or Storyboard Pro > Preferences (Mac OS X).
Press [Ctrl] + [U] (Windows) or [⌘] + [,] (Mac OS X).
  1. In the Preferences panel, click the General tab.
  1. In the General section, select the Automatically Create New Sequence option.

Selecting All Panels in a Sequence

You can select all the panels of a sequence at once, using the Select All Panels in Sequence command.

To select all the panels of a sequence:

  1. In the Thumbnails or Timeline view, select a panel in the sequence you want to select all panels from.
  1. Select Edit > Select All Panels in Sequence.

Renaming a Sequence

Once you start adding sequences to your project, the Sequence field will become visible in the Panel view, allowing you to view the selected sequence's name as well as editing it. You can rename a selected sequence using either the Panel view or the Rename Sequence command.

To rename a sequence using the Panel view:

  1. In the Thumbnails view, select a sequence to rename.
  1. In the Panel view, type the new name or number for the selected sequence in the Sequence field and press Enter/Return.

To rename sequences with the Rename Sequence command:

  1. In the Thumbnails view, select a sequence to rename.
  1. Select Storyboard > Rename Sequence.

The Rename Sequence dialog box opens.

  1. In the New name field, type the new name for the selected sequence. You can type either a number or a name. If you type a name or a number that is already used by another sequence, a warning message will appear.

  1. You can use the Renaming Rule for Subsequent Sequence menu to determine how the next sequences should be renamed. The Renumbered Sequence Names section displays the current and new names for all the sequences that will be affected by the renaming process.
Current Sequence Only: Renames only the selected sequence.
Renumber Sequences: Renumbers the current sequence, and the ones that follow.
Renumber Selected Sequences: Renumbers the first selected sequence of a multiselection, as well as all the following sequences that are part of the multiselection.
Renumber Prefix Only: Renumbers renumbers the sequence numerical prefixes beginning at the selected sequence. Note that the new name must be a numerical value.

Joining Selected Sequences

Two sequences can be joined together using the Join Selected Sequences command.

To join two sequences together:

1. In the Thumbnails or Timeline view, select two consecutive sequences.

  1. Select Storyboard > Join Selected Sequences.

The selected sequences are joined as one.

Splitting the Current Sequence

A sequence can be split in two.

To split a sequence in two:

1. In the Thumbnails or Timeline view, select the scene before the sequence to be split.

  1. Select Storyboard > Split Current Sequence.

The sequence is split in two and the Rename Sequence dialog box opens, prompting you to rename the second portion of the split sequence—see Renaming a Sequence

Removing All Sequences from Project

The sequences in your project can all be removed at once.

To remove all sequences:

Select Storyboard > Remove All Sequences from Project.

This clears all sequences in your project.

Acts

An act is a particular section of the story delimited by a particular event or mood.

For example, a story could be constructed in three acts:

Act 1: The initial situation, character introduction.
Act 2: The journey.
Act 3: The resolution.

Like scenes, panels and sequences, you can manipulate acts when building your storyboard. To add acts to your storyboard, you must first enable the option.

Enabling Acts
Starting New Acts
Joining Selected Acts
Selecting All Panels in an Act

Enabling Acts

By default, the acts are disabled, you need to enable them in the Preferences dialog box.

To enable acts:

  1. Open the Preferences dialog box:
Select Edit > Preferences (Windows) or Storyboard Pro> Preferences (Mac OS X).
Press [Ctrl] + [U] (Windows) or [⌘] + [,] (Mac OS X)
  1. In the Preferences panel, select the General tab.
  1. In the General section, select the Enable Acts option.

A purple flag appears at the beginning of your project, defining the start of Act 1.

Starting New Acts

Once you have enabled acts in your storyboard project, it indicates that your storyboard is made of a single long act. You need to break it in several smaller acts. To split your project into acts, you need to define the starting panel for each act in your story.

To start new acts:

  1. In the Thumbnails view, click the panel where you want to create a new act.

  1. Do one of the following:
Select Storyboard > Start New Act.
Right-click the selected panel and select Start New Act.

The act is divided in two at the point you selected.

Joining Selected Acts

Once an act has been split, it is possible to join acts at any time.

To join selected acts:

  1. In the Thumbnails view, select the last panel and first panel of the acts you want to join.

You can also join more than two sections by selecting the last panel of the first section until the first panel of the last section you want to join.

  1. Do one of the following:
Select Storyboard > Join Selected Acts
Right-click the selected panel and select Join Selected Acts.

Selecting All Panels in an Act

You can select all the panels of an act simultaneously.

To select all the panels of an act:

  1. In the Thumbnails or Timeline view, select a panel contained in the act in which you want to select all the panels.
  1. Select Edit > Select All Panels in Act.