What's New > Storyboard Pro 4.1 (10.2.2.8608)

Storyboard Pro 4.1 (10.2.2.8608)

Here are the new features and improvements in Storyboard Pro 4.1 (10.2.2.8608).

General
Tools
Timeline
Bug Fixes

General

The Replace button highlights in the window that appears when dragging a layer to another panel that contains a layer with the same name.
Improved the Remove unused elements from the project option in the Optimize Project dialog box (File > Optimize Project) to prevent the deletion of drawings from a project that was saved inside the structure of the current project.
The Thumbnail display mode in the Stage view is back. The button is located on the leftmost side of the Stage view status bar.

When turning on the Light Table, the transparency of layers is preserved.
Caption height is now saved in the project.

Preferences

A new preference lets you display a dialog box when using the Flatten command to prevent the accidental flattening of a drawing. The preference is called Warn When Flattening Drawings and is located on the Tools tab.
New preferences were added to improve naming rules when adding a panel if the scene and panel names are locked and there is a name conflict. The naming rule applies when inserting panels and copying/duplicating panels. The preferences are located on Naming tab in the Panel section.

You can specify the type of separator (an underscore or a period) to place before the suffix and whether the suffix is a number or letter. The default is set to "_" and "Auto". With the preferences set to these values, an underscore and a upper case letter will be added to the panel name when adding or duplicating and there is a name conflict.

A new preference called Track Scene Names in a Log File allows a log file to be created in the log folder of the opened project. This log file has the same name as the project folder. This option is located on the General tab, Scenes section.

A new line is created in this log for the following operations: ADD_SCENE, DELETE_SCENE, RENAME_SCENE, OPEN_PROJECT, SAVE_PROJECT, CLOSE_PROJECT. Syntax: <timestamp>';'<operation name>';'<operation argument>';'

Example:

2013-10-04 16:14:53;ADD_SCENE;001;

2013-10-04 16:15:08;ADD_SCENE;002;

2013-10-04 16:15:09;ADD_SCENE;003;

2013-10-04 16:15:15;RENAME_SCENE;002;002b;

2013-10-04 16:15:21;DELETE_SCENE;003;

2013-10-04 16:15:23;SAVE_PROJECT;trackSceneName;

2013-10-04 16:15:24;CLOSE_PROJECT;trackSceneName;

Tools

Improvements/Modifications

A preview of the brush is now generated when creating a tool preset from the Tool Preset toolbar. This preview is available at the top of the icon list when creating a new tool preset.
Modifications to the brush tool properties:
The selected brush preset name is displayed above the brush preview.

The brush preset is deselected when changing a brush tool property and its name is not displayed above the brush preview.

Timeline

Fixed the Fill Next Available Frames option for multiple sound import which was not working properly.
When moving sounds in the Timeline view, the start time and offset are displayed.
The Timeline display was modified so you can see volume keyframes without showing the sound`s waveform.
A new option in the Timeline view lets you overwrite sound clips during drag and drop operations. This option is available: as a button at the bottom-left of the Timeline view, in the small menu, and in the sound menus.
A new option in the Timeline view lets you determine whether the playhead changes frame when clicking in the sound track area. The option is called Change Frame when Clicking on Audio Tracks and is available in the sound menu and in the small menu at the bottom of the Timeline view.

Bug Fixes

General

When pasting a layer or dropping a template in a project, the project's field chart is always used. This prevents the creation of a project that contains drawings using different field charts. Layers could be created with the wrong field chart when a new drawing element (folder) is created by pasting a layer and the current drawing element contains 200 drawings.
Fixed crash that can occur during playback when a project contains large FBX 3D models.
Fixed performance issue with the camera tool when a scene contains hundreds of panels and each panel contains camera keyframes.
Fix performance problem with projects created in version 2.1 of Storyboard Pro and in which a Final Draft script had been imported.
Fixed the camera tool that was not working properly with projects using 16-field drawings. It was not possible to zoom past four fields.
Fixed a rare crash that could happen while drawing.
Updated License Wizard to work with Mac OS X Mavericks (10.9).

Conform Fixes

Fixed conform of projects from FCP that was not working if the pivot of a drawing layer was moved.
Fixed default file pattern (file name) when exporting to XML from File > Conformation when the One Image Per Layer option is enabled. Exported files were missing the project name and the layer name was at the start.
Fixed burn-in position when exporting to XML for conform in projects using HDTV Horizontal.

PDF

PDF Profiles: Fixed margin edit box that did not allow you to type decimal values when units were set to inches.