What's New > Storyboard Pro 4.0

Storyboard Pro 4.0

Here are the new features and improvements in Storyboard Pro 4.0.

64-bit
Bitmap Drawing Tools and Bitmap Layers
Brush Presets
Tool Presets
Colour View Enhancements
Picking Composite Colours
Sequences
Playback Enhancements
Collaboration Tools
Integrated 3D Technology
Paste and Spread Camera
Export to Toon Boom
Timeline View Interface Enhancements
Pitch Mode
Clock Wipe Transition
Edge Transition
Compatability
General Improvements
Moved, Removed and Renamed Features

64-bit

Storyboard Pro technology is now supercharged on a 64-bit core. This gives you the freedom to use more of the computer’s resources, and allows the use of the new bitmap technology. You’ll also see improvements on the number and size of images that can be imported into a project.

Bitmap Drawing Tools and Bitmap Layers

Adding Bitmap Layers
Converting Layers
Drawing Tools Available
Blurring Bitmap Layers

In Storyboard Pro, you now have the ability to draw directly in the software using bitmap drawing tools. In addition to the time-proven vector tools, you can draw with different styles and textures for full artistic freedom.

Create brushes with imported textures, and adjust a variety of parameters like flow, hardness, spacing, and many others to get a custom look.

When you create a bitmap drawing layer and use the bitmap tools on this layer, you are drawing with the raw pixels instead of drawing with vector strokes. This behaves more like when you draw with a pencil on paper. If you want to erase part of the drawing, just use the eraser tool.

Bitmap layers allow you to create 2D graphics. The bitmap lines you create are made of pixels on a grid that resemble tiny dots, which altogether make up the drawing you are creating or artwork you are importing. Bitmap graphics impart a more natural and soft look to your work. The colour is defined on a pixel-by-pixel basis.

Drawing on a bitmap layer allows you to draw in a similar way to how you would in a bitmap tool like Photoshop or Painter. Although you cannot modify the position of the lines after you draw them, you can draw and erase. Instead of drawing lines, you are laying down the individual pixels. This gives you finer control over the brush itself, as well as the shading and colour of the drawing. However, the strokes cannot be edited with the Contour Editor or Perspective tool. It is more efficient for storing texture information than a textured brush on a vector layer, so if you are creating drawings with a lot of texture, this may be a better option.

Advantage: File sizes are not as heavy as when you use textured brushes on a vector layer, since each stroke does not have to be remembered individually. Also, you have full artistic control over the style of the drawing.
Disadvantage: You cannot modify the lines after you draw them. Simply draw and erase, like you would on paper. Also, it can be difficult to reuse the drawing at multiple distances.
Recommended Use: When creating drawings with a lot of texture, for a natural media feel. Particularly when you want a wide variety in colour and shading, this is where you will see the real advantage.
NOTE: Images are now imported in bitmap layers.

Adding Bitmap Layers

You can add an unlimited number of layers to a panel.

To add a layer to a panel:

  1. From the Thumbnails view, select the panel to which you want to add a new layer.
  1. Do one of the following:
Select Layer > New Vector Layer or New Bitmap Layer.
Click the New Vector Layer or New Bitmap Layer button in one of these areas: Layers toolbar, Stage view, or Layers panel.

Converting Layers

If you started with one type of layer, such as vector, you can always switch it to use a bitmap layer and vice versa.

NOTE: When you convert from vector to bitmap, the vector data is lost, so if you convert back to vector, what you get is a vector region with a bitmap inside of it

To convert a layer:

  1. Select one or more layers to convert.
  1. Do one of the following:
Right-click the selected layer and select Convert Vector Layer, Convert to Bitmap Layer or Convert to Drawing Layer.
Select Layer > Convert Vector Layer, Convert to Bitmap Layer or Convert to Drawing Layer.

The layer is converted as indicated by the layer indicated colour and icon.

Drawing Tools Available

Depending on the type of layer you select, here are the tools available:

Tool

Vector Layer

Bitmap Layer

Select
Select By Colour  
Cutter
Contour Editor  
Perspective  
Edit Gradient/Texture  
Brush
Pencil  
Text
Eraser
Rectangle
Paint  
Paint Unpainted  
Unpaint  
Close Gap  
Ellipse
Line
Dropper

Blurring Bitmap Layers

If the layer you want to blur is on a vector layer, you must first convert it to a bitmap layer—see Converting Layers.

To blur a bitmap layer:

  1. Select the layer(s) to blur.
  1. Right-click the layer(s) and select Blur Bitmap Layer, or select Layer > Blur Bitmap Layer from the top menu.

The Blur Bitmap Layer dialog box opens.

  1. Enter a value from 0 to 100 to blur the contents of the layer.

Brush Presets

The brush properties available depend on whether you are drawing on a vector or bitmap layer. On both layers, you can set the minimum and maximum sizes of your tool, which produces the thick and thin effect on your line. This works with the pressure sensitivity of a pen tablet.

On vector layers, you can modify the central line smoothness of your line, as well as smooth the initial movement of your line. Increasing the value will result in a smoother line with fewer control points.

On bitmap layers, you can optimize the flow of lines and set the rate at which colour is applied as you draw. As you draw over an area, the amount of colour builds up based on the flow rate, up to the maximum flow rate you set.

To adjust the brush properties:

In the Tool Properties view, click the arrow button.

The Properties window of the Brush tool opens.

To adjust brush properties on bitmap layers:

  1. Do the following:
Maximum/Minimum Size: Defines the minimum and maximum width of the stroke.
Maximum/Minimum Flow: Sets the rate at which colour is applied as you draw a stroke. As you draw over an area, the amount of colour builds up based on the flow rate, up to the maximum flow rate you set.
Spacing: Controls the spacing between the brush marks of a stroke.
Hardness: Controls the size of the brush's hard centre.
Select Texture: Uses a pattern to make strokes—see Drawing with Textured Brushes.
Texture Scale: Determines the size of the texture used in strokes.

To adjust brush properties on vector layers:

  1. Do the following:
Maximum/Minimum Size: Defines the minimum and maximum width of the stroke.
Smoothing: Defines the number of control points added to the centre line.
Contour Smoothing: Defines the number of control points added to the contour boundaries (around the line). Lower values mean that the line will appear as you draw it (with more control points added along the centre line). Higher values mean that the line will be smoothed out (removing control points from the centre line).
Shape: Lets you select a shape for the tip of the brush. There are a variety of brush tips to choose from: round, square, oval, star-shaped, and more.

Textured Tip: Uses a pattern to make strokes.
Hardness: Controls the size of the brush's hard centre.
Opacity: Sets the minimum and maximum transparency of strokes.
Select Texture: Uses a pattern to make strokes—see Drawing with Textured Brushes.
Texture Scale: Determines the size of the texture used in strokes.

Brush presets are created by saving the properties of the current brush to a new preset, which you can reuse for repeated tasks. You can create as many brush presets as you need.

To access the brush presets:

From the Panel view, click the View menu and select Tool Properties.

Brush Display

There are several ways to display the available brushes: small or large thumbnails, or strokes.

To change the brush display:

In the Tool Properties view, click the Brush menu, and select Small Thumbnail, Large Thumbnail, or Stroke View.

Tool Presets

Tool presets let you save a variety of settings and are very handy and efficient for accessing the tools you use most often. That way, the tool is already set with the desired properties, such as colour, line thickness, whether to enable Draw Behind or Auto Flatten mode, and so on. You can create presets for these tools and many more: Brush, Pencil, Eraser, Rectangle, Ellipse, and Line. First, select a tool, adjust the properties, and then create a tool preset for it. Once you have created a tool preset, you can always make adjustments to fine-tune it, as well as create a keyboard shortcut for it.

What's the difference between a tool preset and a brush preset? When you save a tool preset, you have the option of saving the colour, which you cannot do with brush presets.

The Tool Presets Toolbar

The Tool Presets toolbar lets you create new tool presets and manage them. There are four default brush presets to get you started—Rough, Clean, Shading, and Revision. By default, this toolbar is not displayed.

Colour View Enhancements

To paint drawings and select colours, you will use the Colour view. There is an active colour swatch at the top, that indicates the current colour. You can modify the colour and opacity using the sliders beneath. If you are going to frequently use a colour, then you can save this colour for reuse by creating a colour swatch out of it.

Like other views, you can dock and undock the Colour view. When you first open the Colour view in the Panel view, it is docked. You can undock it so that it becomes its own window which you can move around freely.

Views contain specific groupings of tools that are displayed in the Panel view or as windows that you can position anywhere on your screen. However, you can undock a view that is displayed in the Panel view. When you do this, it becomes a window.To add a view, do one of the following:Select Windows > desired view.In a Panel view, click the View Menu button and select a view from the menu.To dock a window in the Panel view: Drag the window’s tab onto the Panel view and dropping it in the tab area.The view is added to the Panel view.To undock a view:In the Panel view, drag a view by the tab, moving away from the Panel view. The view turns into a window.

NOTE: Once added, a colour swatch can no longer be modified. You will have to delete the swatch and add a new one.

Default Colour Palette

Once you have established the colours to be used throughout your storyboard, you can save it as your default colour palette for the project. You can also import and export colour palettes so that everyone on your team is consistently used the same colours.

NOTE: Toon Boom colour palettes are appended with a .plt extension.

To save a default colour palette:

In the Colour View, click the Colour Swatch menu and choose Save as Default Palette.

To export a colour palette:

  1. From the Colour Swatch menu, select Export Colours.
  1. In the Export Colours window, give your palette a name and click Save.

To import a colour palette:

  1. From the Colour Swatch menu, choose Import Colours.
  1. In the Import Colours window, select a colour palette and click Open.

Picking Composite Colours

To select a composite colour:

1. In the Tools toolbar, select the Dropper tool, press [Alt] +[D] or select Tools > Dropper from the top menu. When enabled, the dropper picks the RGBA values of all the layers combined. When disabled, the dropper picks the RGBA value from just one layer at a time.
  1. In the Tool Properties view, click the Sample All Layers button.
  1. In the Stage view, position the dropper tip over overlapping strokes and click to select the colour.

The new colour is displayed in the Colour view and becomes the current colour.

To select colours with/without transparency:

1. In the Tools toolbar, select the Dropper tool, press [Alt] +[D] or select Tools > Dropper from the top menu.
  1. In the Tool Properties view, do one of the following:
Click the Do Not Pick Transparency button to select colours at 100% opacity, ignoring the alpha value.
Do not click the Do Not Pick Transparency button to select colours and retain the alpha value of the stroke.
  1. In the Stage view, position the dropper tip over a stroke and click to select the colour.

The new colour is displayed in the Colour view and becomes the current colour.

Sequences

Storyboard Pro now allows you to organize your project into four divisions: Acts, Sequences, Scenes, and Panels. The addition of the Sequence level allows you to gather scenes that take place at the same location. For Live Action terminology, this breaks down into Acts, Scenes, Shots, and Panels. Storyboard Pro allows you to define whether you prefer to use Animation terminology or Live Action terminology. This information is included when you export to PDF or CSV.

  1. A panel represents an action and is the smallest element of the three. You should use multiple panels whenever you need more than one drawing to clearly express the acting within a scene. It is the white rectangle representing the camera view. By default the current panel will be highlighted in red in the Thumbnails view.
  1. A scene is composed of one or several panels. In animation, whenever the camera angle changes, you should create a new scene. In live action, this is called a shot.In other words, if your action goes from a mid shot to a close shot, each of these shot should be a different scene. By default, a grey rectangle connects the different panels of a scene together.
  1. A sequence is a series of scenes that should be grouped together. Usually, scenes are grouped together by location. For example, all the scenes that are taking place in one location, should be in the same sequence and as soon as there is a change of location, it should be a new sequence. by default, a blue line connects the different scenes of a sequence together.
  1. An act is composed of one or several scenes and sequences. An act usually represents a story arc. It can be a certain time lapse in the story. For example, all the scenes in the first half of a TV series are one act, and the second act is after the commercial break. As for movies, live action, or even video games, there could have several different story arcs. In Storyboard Pro, a purple flag shows the beginning of a new act.

Playback Enhancements

Storyboard Pro has made significant improvements in playback in this newer, faster version. New playback preferences allow you to play back smoothly and without hitching when a complex panel is encountered. This means when you play back, you hear the sound at the right timing, and the panels play back at the correct speed.

Collaboration Tools

Storyboard Pro has integrated new collaboration tools which allow multiple users working on a project to collaborate. A master project can be split into separate smaller projects, worked on individually, and then merged back together again. A new Advanced Merge feature replaces the existing scenes in the master project with the new, merged scenes. Storyboard Pro allows you to:

Split a Storyboard
Extract a Storyboard
Merge a Storyboard
Inserte a Storyboard
Merge and Replace Scenes

Integrated 3D Technology

Storyboard Pro gives you the ability to work in a 3D space, directly integrated. Enable this feature to work in a 3D space, import 3D models, and export to FBX. You can always keep working in Storyboard Pro as before or turn on the 3D tools when you’re ready to experiment with the 3D technology.

When you export a 3D element in FBX format, the export includes any textures you applied to it, so those textures will appear in the Shaded view. When you import the 3D element in Storyboard Pro and drag it into your scene. Also, if your 3D elements have pivot points, you can manipulate the objects using pivot points

Paste and Spread Camera

When the Camera > Camera by Panel Compatibility Mode preference is enabled, alternative commands become available in the Camera menu:

Paste and Repeat Camera on Selected Panels: Pastes the copied keyframes and fits them into the selected panel. If multiple panels are selected, the keyframes repeated in each of them.
Paste and Spread Camera on Selected Panels: Pastes the copied keyframes and spread them across all the panels of the selected scene.

Export to Toon Boom

Storyboard Pro allows to export to Toon Boom Harmony, Animate 2 and Animate Pro 2.

To export to Toon Boom:

  1. Select File > Export > Export to Toon Boom.

The Export to Toon Boom dialog box opens.

  1. In the Export Target section, select the Toon Boom animation software you want to export to:
Export to Animate/Animate Pro: Select this option to export to either Animate or Animate Pro.
Export to Harmony: Enable this option to either export to Harmony Server or Harmony Stand-alone.
To determine if your export will be created for Harmony Server or Stand-alone, in the Format menu, select the Offline option for a Stand-alone export or To Database for a Network format.
Depending on which Harmony version you have, select either 7.8 or 9.2 or higher.
Select Original Scene to export your storyboard in a project where the vector drawings, layers and camera settings are kept as is. For each shot scene in your storyboard, a Harmony/Animate scene is created.
Nest Panels in Symbols: Upon export to Harmony or Animate, your panel's content will be nested inside symbols. Instead of having several layers in your root timeline, you will have a single one. You will need to enter the symbol to edit its content.
Add a Camera Reference Layer: When enabled, a layer containing the different camera frames will be added on top of the other layers to use as a reference in Harmony and Animate.
Apply Transformation on Drawings: When enabled, transformation will be applied on the first and last position of each panel. Note that the in-between animation will be lost.

Timeline View Interface Enhancements

To enable the Timeline view, do one of the following:

Select Windows > Timeline.
In Workspace toolbar, select Timeline.
Press [4].

  1. The current timecode (time marker's position) is always displayed in the top-left corner of the Timeline view. Under the current timecode, the total duration of the project is displayed. You can click and drag the timecode to scroll through your project.
  1. The names and beginnings of the different acts are displayed as little flags at the top of the Timeline view.
  1. Sequences contained in your project are displayed as blue bars.
  1. The different scenes of your project are represented by grey frames at the top and bottom of the panels.
  1. The different panel blocks display a thumbnail at their centre.
  1. Transitions are displayed as green rectangles between scenes.
  1. Camera movements are displayed as grey bars in the Camera row and keyframes as darker grey diamond shapes.
  1. The audio blocks are below the scenes.
  1. The current sequence, scene, and panel names are displayed at the beginning of the panels' row. You can click the names and drag the cursor left or right to scroll through your project.
  1. The soundtracks names as well as Mute and Lock icons are displayed at the beginning of the Timeline view.
  1. Sound options are available at the bottom of the Timeline view for easy access.

Pitch Mode

When pitching your storyboard, it is helpful to use Storyboard Pro to visually present your story or concepts. Storyboard Pro provides a workspace designed specifically for this called the Pitch Mode workspace.

The Pitch Mode workspace can be accessed in the same way as other default workspaces, but you must exit the mode in a different way —see Storyboard Pro 4.0 .

To load the Pitch Mode workspace, do one of the following:

From the View toolbar, click the Pitch Mode button.

From the Workspace toolbar, select Pitch Mode.
From the top menu, select Windows > Workspace > Workspace > Pitch Mode.
Press [8].

Clock Wipe Transition

By default, the Clock wipe will pass from one scene to the other with a circular clockwise wiping motion. It is possible to customize the direction of the wipe as well as the starting angle.

Edge Transition

By default, the Edge Wipe will pass from one scene to the other with a wiping motion from left to right. It is possible to customize the effect to change the direction of the wiping motion.

Compatability

Storyboard Pro 4.2 can open files created with previous versions of Storyboard Pro. However, once the files are saved in Storyboard Pro 4.2, they can no longer be opened in Storyboard Pro 1.5, 2, and Storyboard Pro 3D.

General Improvements

Select tool now remembers the selection when switching between layer or panel and coming back
New keyboard shortcut to increase [ ] ] and decrease [ [ ] the Brush and Pencil size
General Tool Properties view behaviour has been reviewed for the following tools: Brush, Pencil, Eraser, Ellipse, Rectangle and Line
Cutter tool now has an option to turn aliasing on or off while cutting drawing strokes on bitmap layers
Stage scenes can be imported via the File menu to create Storyboard Pro projects
New Camera menu
New Camera toolbar
While moving the camera frame, its direction can be constrained when holding Shift down
Panels can now have more than four snapshots
Sound tracks can now have an unlimited amount of volume keyframes
Volume keyframes can be deleted by holding down the Alt key and clicking
Volume can now be increase using the volumne keys
New tab in Preferences dialog box called Naming
New option to set the DPI when rendering panels in the PDF export
Mouse scroll wheel can now be used to zoom in the Stage view
Contextual menu when right-clicking in the Thumbnails view
New Bitmap Resolution tab in the Project Properties dialog box
New submenu in the View menu called Extras

Moved, Removed and Renamed Features

Brush Preset toolbar has been renamed Tool Preset
Brush Preset view has been removed
Pencil Editor tool has been removed
Overlay tab in Export dialog boxes has been renamed Burn-in
Storyboard menu has been rearranged
Storyboard toolbar has been rearranged
Import commands have been moved to the File menu