What's New > Storyboard Pro 4.1 (10.2.2.8451)

Storyboard Pro 4.1 (10.2.1.8451)

Here are the new features and improvements in Storyboard Pro 4.1.

Improvements
Editing in Storyboard Pro
3D Workflow Improvements
Other Features and Changes

Improvements

Touch Gestures
Changing the Brush Tool Cursor Display
Reframe Tool
Vectorization Options
Merging and Replacing Scenes
Importing and Exporting
Export to EDL/AAF/XML

General

The Go to Scene command has this shortcut assigned: [Ctrl]+[F] (Windows) or [⌘]+[F] (Mac OS X).
Changed full screen mode shortcut from [CTRL]+[F] to [Ctrl]+[Shift]+[F] (Windows) or [⌘]+[Shift]+[F] (Mac OS X).
Changing a 3D layer display option is now undoable.
The layer name is now highlighted in the Rename Layer dialog to allow for quicker edits.
Added the following commands to the layer menu, layer toolbar and layer category in shortcut list:

Layer > Pivot > Center Pivot to Selection

Layer > Pivot > Reset Pivot

Touch Gestures

Toon Boom Storyboard Pro supports touch gestures. When enabled, you can use the main gestures to navigate in the interface using a supported touch device.

To enable touch gesture:

  1. Open the Preferences dialog box by pressing [Ctrl] + [U] (Windows) or [⌘] + [,] (Mac OS X)
  1. In the General tab, from the Touch Interface section, select the Support Gestures option.

  1. If needed:
Select the Invert Scroll Direction option to invert the touch motion used to scroll up and down.
Set the Gesture Sensitivity value.
  1. Click OK to close the Preferences dialog box.

Once touch gesture is enabled in your project, you can use the main gestures:

Use a two-finger pinch to zoom.
Use two fingers to rotate and pan.
Touch Gesture Preferences

The preferences for touch gestures is on the General tab of the Preferences dialog box.

This preference is disabled by default. When enabled,you can use the main gestures to navigate in the interface using a supported touch device.

Support Gesture: Enables touch gesture.
Invert Scroll Direction: Inverts the touch motion used to scroll up and down.
Gesture Sensitivity: Defines the level of sensitivity recognized.

Changing the Brush Tool Cursor Display

By default, the Brush tool cursor is displayed as a crosshair cursor, you can change the behavior to display the cursor as a shape of the current brush size.

To change the Brush tool cursor display:

  1. Open the Preferences dialog box:
Select Edit > Preferences (Windows) or Storyboard Pro> Preferences (Mac OS X).
Press [Ctrl] + [U] (Windows) or [⌘] + [,] (Mac OS X).
  1. Select the Tools tab.
  1. In the Drawing section, select the Brush Size Cursor option.

  1. Click OK.

The cursor displays the current brush size.

Reframe Tool

The Reframe tool allows you to set the position of the content of the panels for the entire scene so it fits the camera frame you define.

NOTE: Note that when setting the camera frame using the Reframe tool, it is not possible to reset it to its former position.

To position the camera frame using the Reframe tool:

  1. In the Timeline view, select a panel within the scene in which you want to adjust the camera.
  1. From the Camera toolbar or the Tools menu, select the Reframe tool.

The camera frame switches to an orange bounding box .

  1. Do one of the following to modify the frame:
To rotate the camera frame, drag the top-left corner of the bounding box when you see the Rotation icon. Hold down the Shift key while rotating the camera frame to constrain the rotation to 15-degree increments.
To move the camera frame, drag the bounding box from the centre pivot point or the outer edge when you see the Drag icon. Hold down the Shift key while dragging the camera frame to constrain the movement horizontally or vertically.

  1. From the Reframe Tool Properties view, click the Apply button to apply the modification or click the Cancel button to cancel the modification.

If you applied the modification, the position of the content of the panels for the entire scene will be set to fit the new camera frame.

Vectorization Options

By default, when you import an image into your project using either the Import Image as Layers or Import Images as Scenes commands, the imported images will be vectorized in colour and fit the camera frame. The image resulting from a colour vectorization will appear exactly as the original picture.

With the Storyboard Pro, more options are available which give you better control over the vectorization of imported images. To access these options, you must first select the Display Vectorize Options Dialog option in the Preferences dialog box.

  1. Do one of the following:
Select Edit > Preferences (Windows) or Storyboard Pro > Preferences (Mac OS X).
Press [Ctrl] + [U] (Windows) or [⌘] + [,] (Mac OS X).

  1. In the browser that opens, select the image to import.

The Import Images dialog box opens.

  1. The preview area displays the original image on the left and the resulting image on the right. The preview of the resulting image automatically updates each time you modify a parameter.

Merging and Replacing Scenes

NOTE: When merging projects, the sounds in the master project will now move in order to sync with the panels.The sounds will follow panels based on their name, therefore, it is important to lock scenes and panels names prior to distributing the different scene's extracts, in order to preserve them.

There are two new options in the Advanced Merge Storyboard dialog box:

The Respect locked audio track option ensuresthat the locked audio tracks will not be synced during the merge and replace. When deselected, audio tracks will be synched regardless if they were locked or not.
The Import audio changes from source project option allowsthe modifications done in the audio to be applied to the scenes that are replaced.

 

Tools

Options were added to the Transform tool properties to turn the translation, scale and rotation controls on or off.
Added gesture support in the Cutter tool for deleting stubs.

Timeline and Animatic

While changing the duration of a sound clip or panel, you can see the difference between the original length and what is to be set. This is displayed as a positive (or negative) value in brackets while the clip is being resized. You can see this value in timecode or in frames by modifying your preferences.
Multiple sound clips on multiple sound tracks can now be selected at the same time by drawing a selection marquee around the clips in the Timeline. Using the Shift key while selecting in this way to add your selection to the current selection.

Library

Sounds can be played from the library in the same way that templates and swf files can be played. Double-click the sound, then click the Play button in the preview section.

Importing and Exporting

Change default encoding for text caption when export to PDF to prevent having special characters replaced with question marks.
Improved multithreading support to reduce time required to render movies. Depending on the hardware, movies are now two to six times faster to render.
Export Volume Keyframes to XML for Final Cut Pro.
Added file name pattern field when exporting to FCP conformation.

File name pattern field was added to the XML conformation export. This pattern is used for the name of the images exported. The following variables can be used:

%t : Project Title.

%a : Act name. When acts are enabled.

%q : Sequence name. When project contains sequences.

%s : Scene name.

%p : Panel name.

%l : Layer name. When exporting one image per layer.

A number can be typed between the % and the letter to define the minimum number of characters used.

Added option to export camera frame when exporting an XML for Final Cut Pro conform. (File > Conformation > Export Project).
Added scene name pattern field to define scene names when exporting to Harmony.

A field has been added in the Export to Toon Boom dialog that can be used to define the pattern used to name the Harmony scenes created. When left blank, the default pattern is used. The default pattern is different base on the selected export type (One scene per scene, sequence, act). Default patterns are as before.

The following variables can be used to define the scene name pattern:

%t : Project Title

%a : Act name. When acts are enabled.

%q : Sequence name. When project contains sequences.

%s : Scene name.

A number can be typed between the % and the letter to define the minimum number of characters used. For example, for a scene named 16:

MYPROJECT_SC%4s : This will create a scene using the MYPROJECT_SC prefix + scene name using 4 characters, padding with zeros = MYPROJECT_SC0016.

Export to EDL/AAF/XML

To export a storyboard to EDL or AAF or XML:

  1. Select File > Export > EDL/AAF/XML.

The Export to EDL/AAF/XML dialog box opens.

  1. In the Destination Path, select a folder in which to save your storyboard project. You can type in the exact path or use the Browse button to browse to a specific folder on your system. You should create a folder for your exported project since Storyboard Pro will generate several files during the export.
  1. In the File Pattern field, you can set your own pattern which will be used to name the files created from the export. Leave this field blank to use the default pattern. The following variables can be used to define the file name pattern:
%t = Project title
%a = Act name (when acts are enabled)
%q = Sequence name (when project contains sequences)
%s = Scene name
%p = Panel name
%l = Layer name (when exporting one image per layer)

You can add a number between the % sign and the letter of the variable to define a minimum number of characters to use.

  1. In Export Type, select the format in which to store the timing information (timecode for panels and audio tracks). The format will be chosen depending on the destination application:
Application Format Notes:
Apple Final Cut Pro EDL: In EDL, if you are using audio elements more than once in the timeline, FCP will not be able to reconnect the media. AAF is supported in FCP with a plug-in from Automatic Duck. Final Cut Pro also supports XML.
Adobe Premiere Pro AAF (Windows)
EDL (Mac OS X) With EDL, media will have to be linked manually one by one. Premiere Pro on Windows cannot open AAF coming from Windows (and AAF is not supported on the Mac OS X version of Premiere Pro).
Avid Xpress AAF
NOTE: If your editing system is not in the list, check its specifications to verify which format can be imported.
  1. In the Options section:
Use the resolution drop-down menu to define the output resolution since you might not always need to export the storyboard at full resolution (you can select Full, Half or Quarter of a project’s resolution).
The One Movie Clip Per Panel option is useful if you want to export more than one QuickTime movie clip per scene (which might contain more than one panel) e.g. to obtain better granularity during editing since the storyboard will have smaller movie clips.
The storyboard scenes are exported in QuickTime format. Click Video Config. to configure the video settings (codecs, quality)—see Exporting a QuickTime Movie to learn more about the option available via the Video Config. button.
Generate Video Files: If you only need the EDL, AAF or XML files to be generated, you can deselect this option and no video files will be rendered.
Copy Audio Files: By default, during the export to EDL/AAF, the original sound elements used are copied to the same location as the QuickTime movie clip’s and the EDL or AAF file. If sound elements in the timeline are used more than once, the elements are not duplicated. The EDL/AAF refers to the same sound elements. You can deselect this option if needed.
  1. In the Export Range tab:

Decide whether you want to export the entire project (All), just a selected frame range, a selected scene, a selected panel, or tracked panels. If you decide on the latter, be sure to enter in the frame range in the fields provided. In the Scene Picker dialog box, you can select your scenes by sequence if your project contains sequences—see Tracking Changes.
  1. In the Burn-in tab:

Print Time Code: Prints the project timecode on the video as an overlay on your video.
Print Scene Names and Panel Numbers: Prints the scene names and panel numbers as an overlay on your video.
Print Panel Time Code: Prints each panel’s timecode on the video as an overlay on your video.
Print Additional Duration: Prints an additional duration on your video, defined by the Units and Repeat drop-down menu.
Units: Choose either you want the additional duration information to be displayed using Time Code or Frames units.
Repeat: Choose either you want the additional duration information to be the duration per Panel, per Scene or per Sequence.
NOTE: You can customize the font type, size, colour and location of the printed time code using the Preferences panel—see Burn-In.
  1. In the Camera Grids tab, do the following:

Project Safety: Prints the safe area on your video—see Safe Area.
4:3 Safety: Prints the 4:3 safe area on each panel of your storyboard that has a camera movement—see 4:3 Safety.
4:3 References: Prints the 4:3 area on each panel of your storyboard that has a camera movement—see 4:3 Safety.
  1. Select the Open document/folder after export option to view the file when it is ready.

Editing in Storyboard Pro

Setting the Panel's In or Out to the Current Frame
Locking the Scene Duration
Selecting Panels and Sound Clips Forward
Marking Sound Clips with Custom Colours
Setting the Panel's In or Out to the Current Frame
Recording a Sound Guide
Displaying and Adjusting the Volume Envelope
Slide Transition
Other Features and Changes

Setting the Panel's In or Out to the Current Frame

You can adjust the duration and position of a panel by moving its in and out points to a specific frame determined by the current position of the playhead.

NOTE: Note that the frame you specify must be contained within the current position of the panel you want to change the in or out point of.

To set the panel's in point to the current frame:

  1. In the Timeline view, drag the red playhead to the position where you want the panel to start.

  1. Select Storyboard > Move Panel In to Current Frame. You can also right-click on the selected panel and select Move Panel In to Current Frame.

The selected panel's in point is pushed to the new position, resulting in the previous panel being extended to this point.

To set the panel's out point to the current frame:

  1. In the Timeline view, drag the red playhead to the position where you want the panel to end.

  1. Select Storyboard > Move Panel Out to Current Frame. You can also right-click on the selected panel and select Move Panel Out to Current Frame.

The selected panel's out point is pushed to the new position, shortening its duration.

Locking the Scene Duration

You can lock the duration of all scenes in your project with the Lock Scene Duration command. This ensures that the current length of every scene is preserved when adding, duplicating, or deleting panels.

To lock the scene duration:

  1. Select Storyboard > Lock Scene Duration.
NOTE: You can add a custom keyboard shortcut to this option through the Preferences dialog box or use the Lock Scene Duration button in the Storyboard toolbar extra buttons.
  1. Once your scene duration is locked:
Adding a panel using the New Panel or Smart Add Panel command reduces the size of the selected panel to make room for the new one. If the selected panel's length is one frame, the panel length cannot be reduced and therefore the new panel cannot be inserted in the scene.

Deleting or cutting one or more panels causes the preceding panel's length to extend to fill the gap and preserve the scene's duration. Cutting or deleting a scene or all the panels on a scene will not let you preserve the scene's duration.

Duplicating a single panel using the Duplicate Panel command will reduce the length of the selected panel to make room for the duplicated one. Duplicating multiple panels will not keep the scene's duration.

Copying and pasting panels, adding a scene or a sequence, or deleting an entire scene will not preserve scene duration.
Manually changing the duration of a panel is still permitted and will modify the scene duration.

Selecting Panels and Sound Clips Forward

By using a series of keyboard shortcuts, you can:

Select all panels forward.
Select all panels and all sound clips forward.
Select all sound clips on a single sound track forward.
Select all sound clips and all sound tracks forward.

To select all panels forward:

  1. In the Timeline view, click the leftmost panel to select it.

  1. Hold [Ctrl]+[Alt]+[Shift] (Windows) or [⌘]+[Alt] (Mac OS X) and click the panel from which you want the selection to start.

The panel, and all the panels following it, up until the end of the storyboard project are selected at once.

If you drag the selection forward, the panel preceding the selection will be extended.
If you drag the selection backward, the panel preceding the selection will be reduced until it reaches the minimum length allowed (one frame). Then the second panel preceding it will be reduced.

To select all panels and all sound clips forward:

  1. In the Timeline view, press [Ctrl]+[Alt]+[Shift] (Windows) or [⌘]+[Alt] (Mac OS X) and click the panel from which you want the selection to start.

The panel and all the panels following it, up until the end of the storyboard project, as well as all the sound clips in all audio tracks starting from where the play head is positioned are selected at once and can be moved together.

If you drag the selection forward, the panel preceding the selection will be extended.
If you drag the selection backward, the panel preceding the selection will be reduced until it reaches the minimum length allowed (one frame), then the second panel preceding it will be reduced. Overlapping audio clips will be overwritten by the ones that are selected.

To select all sound clips on a single sound track forward:

  1. In the Timeline view, hold [Ctrl]+[Alt] and click the audio clip from which you want the selection to start.

The audio clip and all the audio clips following it on the same audio track, up until the end of the storyboard project, are selected at once.

To select all sound clips on all sound tracks forward:

  1. In the Timeline view, hold [Ctrl]+[Shift]+[Alt] and click the audio clip from which you want the selection to start.

The audio clip and all the audio clips following it on all audio tracks, up until the end of the storyboard project, are selected at once.

Marking Sound Clips with Custom Colours

Marking sound clips with a custom colour allows you manage them and quickly identify them. This option is also available for marking panels—see Scenes and Panels.

To mark a sound clip with colour:

  1. In the Timeline view, select one or more sound clips to mark with a colour.

  1. Right-click on the selection and select one of the following: Set Colour > Red, Orange, Yellow, Green, Blue, Purple or Custom. If you choose custom, the Colour Picker dialog box opens from which you can select a colour.

The selected audio clip changes to the colour you chose.

To reset the sound clip colour:

  1. In the Timeline view, select the sound clip you want to reset the colour to default. You can also make a multiple selection.

  1. Right-click on the selection and select Set Colour > Default Colour.

The selected clip colour resets to the default colour.

NOTE: The default colour of sound clips is beige. However, you can change this in the Preferences dialog box—see Preferences.

Setting the Soundtrack Size

By default the size of the soundtracks is set to small, but you can modify the size of the different soundtracks of your project individually to increase or decrease their heights.

To set the soundtrack size:

In the Timeline view, right-click a soundtrack and select Track Size > Mini, Small, Medium or Large.

The soundtrack is resized.

Recording a Sound Guide

You can record sound directly from Storyboard Pro and insert them in the timeline.

To record sound in Storyboard Pro:

  1. In the Timeline view, add a new audio track if need be.
  1. Place the play head at the frame you want your recording to begin and click select the audio track you want to record your sound guide in.
  1. Select File > Import > Record Sound.

The Record Sound dialog box opens.

  1. In the Target Sound Track section:
Select the New Sound Tracks option to create a new audio track for the recording.
Select the Current Sound Track option to record in the selected audio track.
  1. In the Target Frame section:
Select the First Frame option to start the recording on the first frame of the project.
Select the Current Frame option to start the recording on the current frame.
  1. In the Import Rule section:
Select the Overwrite Existing Sound Clips option so that the resulting audio clip will be position in its entire length, overwriting any existing clip positioned in its way.
Select the Fill Next Available Frames option so that the recording do not overwrite the position of existing audio clips that are on the same audio track.
  1. In the Record Sound Clip section:
Name the audio clip.
Click the Record button to start the recording.
Click the Stop button to stop the recording.
Click the Play button to preview the recording.
  1. Click OK.

The recording is imported in the selected audio track of your project.

Displaying and Adjusting the Volume Envelope

Volume keyframes are no longer added automatically while clicking on a sound clip. To add or remove a volume keyframe, hold [Alt] and click. The pointer changes to indicate if a keyframe will be added or removed. This prevents you from the accidentally adding or removing volume keyframes while dragging sound clips.

Slide Transition

By default, the Slide transition will pass from one scene to the other by translating the next scene panel from the right side of the camera frame. It is possible to customize the angle and direction.

Other Features and Changes

In the Timeline view, the total duration of the project is now displayed under the current timecode.
The Timeline playhead no longer changes frames when clicking on sound tracks.
Fixed problem with sound clips on new tracks not syncing after merging.

3D Workflow Improvements

Replacing a 3D Model in the Library
Align Camera Key with Stage View Position
Coordinate Toolbar
Exporting to FBX
Additional 3D Improvements

Replacing a 3D Model in the Library

Once you have imported a 3D model in the Library, you can easily replace it with a new one using the Replace 3D Model command. This will update all instances of the model used in the project.

To replace a 3D model:

  1. In the Library view, click the 3D Models folder to display its contents.
  1. From the 3D Models folder, select the model you want to replace.
  1. Right-click on the selected model and select Replace 3D Model.

A browser window opens.

  1. In the browser, locate the 3D model file you want to replace the selected model with, and click Open.

The Rename Node dialog box opens.

Click Yes to rename the replaced model using the new model name.
Click No to preserve the replaced model name.
Enable the Don't show this message again check box to prevent this dialog box from opening again, and use the same behavior as you choose now for future use of the Replace 3D Model command.

The 3D model view is updated in the Library view and in your project at once.

 

Align Camera Key with Stage View Position

This button fits the camera frame to the current space available in the Stage view while retaining its original ratio, which is very useful in 3D scenes. This command is also available from the top menu, Camera > Align Camera Key with Stage View Position.

Coordinate Toolbar

You can also use the Coordinate Toolbar, which displays the current translation, scale and rotation values of a selected layer, as well as allowing you to type specific values for each of these parameters. This toolbar is available from the top menu by selecting: Windows > Toolbars > Coordinate.

Translation

The translation field displays the X, Y and Z translation values of the selected layer. You can use these fields to type in precise values to set the first frame and last frame position of a layer. By default the Z value field is disabled, it will automatically become active when the 3D option is enabled.

Scale

The scale field displays the X, Y and Z scaling values of the selected layer. You can use these fields to type in precise values to set the first frame and last frame size of a layer. By default the Z value field is disabled, it will automatically become active when the 3D option is enabled.

Rotation

The rotation field displays the X, Y and Z rotation values of the selected layer. You can use these fields to type in precise values to set the first frame and last frame rotation of a layer. By default the X and Y value fields are disabled, it will automatically become active when the 3D option is enabled.

Exporting to FBX

When exporting your storyboard to FBX:

You can now export one clip per scene, export one clip for the entire project, or export one clip per sequence (this option is only available in there sequences in your project).
You can include only the scenes from the sequence you selected when you opened this dialog box. This option will only be visible if your project contains sequences.

Additional 3D Improvements

When animating a 3D element in the 3D space, you can also make a multiple selection to move multiple 3D layers at once.
When deleting a 3D model from the 3D Models folder of the Library, every instances of the model used in the project will be deleted at once. A warning message will prompt you to confirm or cancel the action.

Other Features and Changes

Interface
Layers
Drawing
Exporting Your Storyboard

Interface

The Pivot tool has been removed. The pivot can now be moved using the First Transform and Last Frame Transform tools.

Layers

There are two new options for displaying objects on 3D layers:

Wireframe on Shaded: The 3D objects displays the textures with its wireframe on top.
Wireframe on Flat: The 3D objects displays the surface with its wireframe on top.

Drawing

When the light table is activated, all layers apart from the currently selected one are shown washed-out in the Stage and Camera views and when using the layer tools.

Exporting Your Storyboard

When exporting your storyboard to PDF, there are two new layouts in the Export to PDF dialog box:

Alternate Vertical Layout: This layout consists of a total of 5 panels per page, aligned on the left side of the page. Captions are organized on the right size of each panel. This export also includes a cut and a duration column, and displays the duration of each scene at the beginning of every new one.
Overview 8x10: This layout consists of a total of 80 panels per page, organized in ten rows of four. No caption is included.

When exporting your entire storyboard project to Final Cut Pro:

You can now export the camera frame's black border.
You can include additional burn-in information including:
Print Additional Duration: Prints an additional duration on your video, defined by the Units and Repeat drop-down menu.
Units: Choose either you want the additional duration information to be displayed using Time Code or Frames units.
Repeat: Choose either you want the additional duration information to be the duration per Panel, per Scene or per Sequence.

Bug Fixes

Fixed the Select tool that was not allowing you to select drawings on layers from multiple panels.
Fixed double-click on project file that was opening the Welcome screen and not the actual project.
Fixed crash when converting a vector layer to bitmap when there is a perspective selection.
Fixed case that was causing the undo queue to stop working after right-clicking in the Timeline view.
Fixed undo that was selecting the first panel in the project.
Properly remember when "Per Act" is selected in the Export to Toon Boom window.
Fixed Paste Layer Special that was pasting layers in the reverse order.
Fixed Timeline view that was scrolling too fast when moving the playhead to the left edge.
Fixed crash when using Cutter tool on flattened brush strokes.
Fixed ALT+SHIFT modifier using the Brush tool that was not drawing a straight line in increments of 15 degrees.
Fixed potential freeze when exporting to FBX.
Fixed AFF export on Windows that was not working.
Fixed a problem that caused sound layer to not synch with panels when moving them in the Timeline.
Fixed image preview that was distorted in the Import Images window.
Fixed XML export (File > Export > EDL/AAF/XML) that was causing problems connecting movies in Final Cut Pro.