Stage Guide > Toon Boom Harmony 10 Stage User Guide > Chapter 19: Effects > Particle Effects > Particle Effect Modules > 3D Region

3D Region

This module defines 3D region. The region can take on many forms, such as a sphere, cone, cylinder or box. The 3D Region module acts in contrast to the Planer Region module, which generates and emits particles from a 2D plane.

A 3D Region can be connected to a Sprite-Emitter, to define the region from which particles are generated. It could also be connected to a Bounce module, to define a region against which particles will bounce. If connected to a Sink, it will define a region where the particles will disappear.

Click on View > Show > Control in order to view a preview of what the 3D Region looks like.

Layer Properties

Use the 3D Region's Layer Properties to adjust the 3D region.

Shape: Choose a shape for the 3D Region by clicking on the Type drop-down menu and selecting either Box, Cylinder, Cones, Sphere or Image.

If you select Image, you must connect the module of a vector drawing or a vectorized bitmap image to the left port (blue node) of the 3D Region module. The particles will then be emitted from that image' shape. Don't forget that you can rotate your vector drawing in 3D space by enabling the 3D option in its Layer Properties.

Size: Enter different values into the Width, Height and Depth fields to change the dimensions of the 3D Region's selected shape. Depending on the shape selected, some fields may be greyed-out if they are not applicable. You can also modify the shape with the Transform Tool by grabbing the control handles (turquoise squares) in the Camera or Perspective views. You can also change the dimensions of the region over time by click on the function button at the end of each field.
Radius: Enter different values into the Min or Max fields to change the inner or outer radius of applicable shapes, such as a cylinder, cone or sphere. The radii can also be modified by grabbing the control handles (turquoise squares) in the Camera or Perspective views. The radii of the region can be changed over time by clicking on the function button at the end of each field.

Related Topics 

Particle Effect Modules