Stage Guide > Toon Boom Harmony 10 Stage User Guide > Chapter 19: Effects > Using Effects > Gradient

Gradient

Use a Gradient effect to create a transition of colour or alpha values between two areas of colours. You can either create a linear or radial gradient. Use two points to indicate where those two coloured areas are. You can then move these points to create the transition.

The Gradient module covers the entire camera frame and beyond. You do not need to scale it up or down. It will automatically cover an infinite zone. You simply need to connect it behind your scene's elements. You can connect it in front of some elements you would like to cover. By default, the Gradient has a Z ordering value of 0.

Use the Gradient editor to control the values of the gradient and the position of its output.

Gradient Type: In the drop-down menu, select if you want your gradient to be linear or radial.
Point 0, Point 1: These sections control the values of the first point (point 0) and the second point (point 1) in the gradient.
Red/Green/Blue/Alpha: These are the colour and alpha values of the corresponding point. You can also click on the colour swatch to open the Colour Picker window and select a new colour. These colours can be animated over time if the value parameter is hooked to a function curve.
(x) Axis: This sets the X coordinate for the corresponding point.
(z) Axis: This sets the Y coordinate for the corresponding point.

Controlling the Gradient in the Camera View

If you want to control the gradient's orientation and points position in the Camera view, you can use the Control command to display the points and move them.

To control the gradient in the Camera view:

1. In the Tools toolbar, select the Transform tool.
2. In the Network view, select your Gradient module.
3. Select View > Show > Control.
4. In the Camera view, click on the Gradient's points and move them.

Related Topics 

Using Effects