Stage Guide > Toon Boom Harmony 10 Stage User Guide > Chapter 16: Animation Paths > Modifying a Path in the Camera View > Shaping a Path > Adjusting the Tension, Bias and Continuity

Adjusting the Tension, Bias and Continuity

You can edit keyframes and control point parameters, such as the position, continuity, bias, tension, and lock in time using the Coordinates and Control Point view.

Each time a keyframe or control point is selected in the Camera, Timeline or Xsheet view, its parameters appear in the Coordinates and Control Point view. You can also see the same information in the Coordinate and Control Point toolbars.

You can adjust these parameters on existing control points and keyframes by selecting the point in the Camera view with the Transform tool.

Continuity controls the smoothness of a transition between the segments joined by a point.

Tension controls how sharply the path bends as it passes through a control point or keyframe.

Bias controls the slope of the path so that it flows towards one side of the motion point or the other.

To adjust the Continuity, Tension and Bias parameters:

1. In the Tools toolbar, select the Transform tool.
2. In the Timeline view, select the layer that contains the parameters you want to adjust.

3. In the top menu, select View > Show > Control or press [Shift] + [F11] to display the trajectory.
4. In the Camera view, select a control point or keyframe.

5. In the Coordinates and Control Points view, adjust the Continuity, Tension and Bias parameters.

If you find that you are using the same Continuity, Tension and Bias settings, you can set a preference to remember your settings.

If you find that you are using the same Continuity, Tension and Bias settings, you can set a preference to remember your settings.

To adjust the control point preferences:

1. From the top menu, select Edit > Preferences (Windows) or Harmony > Preferences (Mac OS X).

The Preferences dialog box opens.

2. Select the Camera tab and adjust the parameters in the Controls Points section.

Toggling between a Linear or Curved Motion

When you select a control point on a path, you can toggle between a rounded or square corner by using the Linear/Curve command.

To toggle between a linear or curved corner:

1. In the Tools toolbar, select the Transform tool.
2. In the Camera view, select the point to convert.
3. In the top menu, select Animation > Linear/Curve.

Related Topics 

Shaping a Path