Stage Guide > Toon Boom Harmony 10 Stage User Guide > Chapter 12: Scene Setup > Setting Up the Network > Network Navigation and Basic Rules > Grouping Modules

Grouping Modules

With so many connections and modules possible, the network can quickly become overcrowded. Keep things organized by grouping your modules.

Grouping a Selection
Grouping a Selection with Composite
Ungrouping a Selection
Entering and Exiting a Group Module
Moving a Selected Module to its Parent Group

Grouping a Selection

To group selected modules:

1. In the Network view, drag a selection around the modules you want to group.

2. In the Network View menu, select Edit > Group > Group Selected Layers or [Ctrl] + [G] (Windows/Linux) or [⌘] + [G] (Mac OS X).

The modules are grouped.

To ensure that you have a Multi-Port Out Module in your group and that your group remains connected, include a Composite module in your selection and make sure it is connected to the main Composite module of the scene before grouping.

Grouping a Selection with Composite

There are several advantages to using the Group Selection With Composite command over the simple Group Selection (which references both the Group layer in the Timeline and the Group module in the Network view.

One of the advantages of using this command is that it groups all the selected elements into a neat module that has a nested composite. This means that there is only one connection coming out of the Group module. With the simple Group module or command, the Group displays the same number of connections as elements in the group. Both grouping commands display the same structure in the Timeline view.

 

Group Selection

Group Selection With Composite

The Group Selection With Composite command should only be used before any work has been done in the Network view and it recommended for objects whose stacking order is of no consequence.

Using the Group Selection from Composite command on elements that have effects, have been tweaked in the Network view, or whose stacking order is of consequence, may cause the grouped elements to lose their properties once grouped in this way. In addition, though you may only select a few modules to group, if there are other layers in the timeline that exist between the selected layers, they will automatically be grouped, even if not selected.

To group selected elements using the Group Selection With Composite command in the Network view:

1. In the Network view, select the elements that you wish to group.

2. Right-click in the Network view and select Group > Group Selection With Composite from the menu.

The selected modules will be grouped.

To group selected elements using the Group Selection With Composite command in the Timeline view:

1. In the Timeline view, in the layers section, select the elements that you wish to group.

Any layers between the selected layers will automatically get grouped as well, so if the stacking order is of no consequence, move extra layers either above or below the layers that you wish to group.

2. right-click on one of the highlighted layers and from the pop-up menu select Group Selection With Composite.

The layers appear indented under a new Group layer in the Timeline view and in a new Group module in the Network view.

Ungrouping a Selection

To ungroup a group:

1. In the Network view, select the group of modules you want to ungroup.

2. In the Network View menu, select Edit > Group > Ungroup or press [Ctrl] + [Shift] + [G] (Windows/Linux) or [⌘] + [Shift] + [G] (Mac OS X).

The selected group is ungrouped.

Entering and Exiting a Group Module

Once you create a group module, it is easy to enter into or exit from it.

To enter a group module:

In the Network view, click the arrow on the right side of the group module you want to enter.

Inside the group module, the Multi-Port In and Multi-Port Out modules ensure that your connections continue beyond the group.

To exit a group module:

1. In the Network view, click the destination in the Group Hierarchy menu. You can also select Modules > Exit Group from the Network View menu or press [Backspace].

When you enter a group, the Group Hierarchy Menu displays the path to where you are. In this example, we are inside the group named group. To exit this group, click on Top Group.

Moving a Selected Module to its Parent Group

Using the Move to Parent Group command allows you to move the selected module to the parent level, maintaining all connections.

If the operation cannot maintain the connections between the modules, you will be notified and the operation will be terminated.

To move a selected module to its parent group:

1. In the Network view, go inside the group and select the modules you wish to move up to the parent group level.

2. In the Network View menu, select Modules > Move to Parent Group or press [Ctrl] + [Shift] + [U] (Windows/Linux) or [⌘] + [Shift] + [U] (Mac OS X).

The selected modules are moved to the parent group level.

Related Topics 

Network Navigation and Basic Rules