Stage Guide > Toon Boom Harmony 10 Stage User Guide > Chapter 9: Import > Custom Vectorization Parameters > Setting the VectOptions.conf File

Setting the VectOptions.conf File

Toon Boom HarmonyServer uses a file called VectOptions.conf to get the vectorization style when batch vectorizing a series of drawings. A series of default styles are available in this file, but you will certainly want to create your own to fit your production style.

This section deals with setting the VectOptions.conf file on:

Setting the VectOptions.conf File on Windows and Mac OS X
Setting the VectOptions.conf File on Linux

Setting the VectOptions.conf File on Windows and Mac OS X

To set your VectOptions.conf file on Windows or Mac OS X:

1. Open the vectOptions.conf file:
Windows: Select Programs / All Programs > Harmony 10 > Tools > Configuration Editor.
Mac OS X: Select Applications > Harmony 10 > Tools > Configuration Editor.

The Configuration Editor window opens.

2. In the bottom section of the window, select the VectOptions.conf tab.
3. Scroll down the VectOptions.conf file. You will see all the different options available to create your custom vectorization style. These options are the same as in the Vectorization Parameters dialog box. It is recommended to create your vectorization style using Toon Boom Harmony and the Vectorization Parameters window and copy the result parameters in this file.
Refer to the Creating a Vectorization Style topic to learn more about creating a style using the Vectorization Parameters dialog box.
4. Scroll down toward the bottom of the file to see the default styles. You can modify them or add new ones to the list using the parameters you got using the Vectorization Parameters window.
You will notice that some of the lines have a “#” sign at the beginning. This means that the line is a comment and will not appear in your style list. The lines that have no sign at the beginning appear in the style list.

5. To create a new style, below the existing ones, type style_name: and the name of your new style, for example: style_name: Black Lines.
6. Under the style name line, type options: and copy and paste the information you got in your *.vof style when saving your settings in the Vectorization Parameters window.
To open the *.vof file, use any plain text editor application.

7. In the Configuration Editor’s top menu, select File > Save.
8. If you have Toon Boom Harmony Scan on your computer, you can launch the application and verify that the new style appears in the Vectorization Style list under Edit > Vectorization Style.
Note: If you are using the batch processing method available with Toon Boom Harmony Server to scan and vectorize your drawings, the select style must be available on all the machines included in the batch processing list.
Refer to the Control Center and Server User Guide to learn more about setting up and using batch processing.

Setting the VectOptions.conf File on Linux

These are the two methods used to edit the VectOptions.conf file on Linux.

Using the “vi” text editor
Using the “gedit” text editor

To set your VectOptions.conf file on Linux using the “vi” text editor:

1. Open a Terminal window:
Menu: Applications> System Tools> Terminal
2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_10.0/etc

3. Change your user to "root":

$ su

If your user is part of the sudoers list, enter the following command and go to Open the 'VectOptions.conf using the "vi" text editor::

$ sudo vi VectOptions.conf

4. Enter the "root" password.
5. Open the 'VectOptions.conf using the "vi" text editor:

$ vi VectOptions.conf

6. To start editing, press the [i] key on your keyboard to enter Insert mode.
7. Once you're done editing the file, press the escape [Esc] key to exit Insert mode.
8. To save the changes made to the file, type the following and press [Enter/Return]:

$ :w!

9. To exit the "vi" editor and return to the Terminal, type the following and press [Enter/Return]:

$ :q

10. If you have Toon Boom Harmony Scan on your computer, you can launch the application and verify that the new style appears in the Vectorization Style list under Edit > Vectorization Style.
Note that if you are using the batch processing method available with Toon Boom Harmony Server to scan and vectorize your drawings, the select style must be available on all the machines included in the batch processing list.

Refer to the Control Center and Server Guide to learn more about setting up and using batch processing.

To set your VectOptions.conf file on Linux using the “vi” text editor:

1. Open a Terminal window:
Menu: Applications> System Tools> Terminal
2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_10.0/etc

3. Change your user to "root":

$ su

If your user is part of the sudoers list, enter the following command and go to Open the 'VectorOptions.conf using the "gedit" text editor::
$ sudo gedit VectOptions.conf
4. Enter the root password.
5. Open the 'VectorOptions.conf using the "gedit" text editor:

$ gedit VectOptions.conf

6. Edit the parameters of the VectOptions.conf file like you would do in most text editor application.
7. To save your changes, select File> Save.
8. To exit the editor, select File> Quit.
If you have Harmony Scan on your computer, you can launch the application and verify that the new style appears in the Vectorization Style list under Edit > Vectorization Style.
Note that if you are using the batch processing method available with Toon Boom Harmony Server to scan and vectorize your drawings, the select style must be available on all the machines included in the batch processing list.
Refer to the Control Center and Server Guide to learn more about setting up and using batch processing.

Related Topics 

Creating a Vectorization Style
Custom Vectorization Parameters