Xsheet Guide > Toon Boom Xsheet User Guide > Chapter 4: Timing > Layers and Columns > Adding New Drawing Layers

Adding New Drawing Layers

In this section, you will learn the different ways to add a drawing layer to your project. By default, when you create a new scene there is one Drawing layer included in your Timeline view.

This topic is divided as follows:

Adding Drawing Layers in the Timeline View
Adding a Drawing Layer from the Top Menu
Adding Drawing Columns in the Xsheet View

Adding Drawing Layers in the Timeline View

You can add a new layer in the Timeline view in several different ways:

Using the Layer toolbar
Using the Add Layers dialog box
Go to the Timeline view menu and select Insert > Drawing.

To add a Drawing layer using the Timeline’s Layer toolbar:

1. In the Timeline’s Layer toolbar, click the Add Layers button or press [Ctrl] + [R] (Windows/Linux) or [⌘] + [R] (Mac OS X).
2. In the drop-down menu, select the Drawing option.

A new layer appears in the Timeline and Xsheet views.

You can also click on the Add Drawing Layer button in the Timeline’s Layer toolbar or press [Ctrl] + [R] (Windows/Linux) or [⌘] + [R] (Mac OS X).

To add drawing layers using the Add Layers dialog box:

1. In the Timeline view’s layer section,right-click and select Insert > Add Layer(s).

The Add Layers dialog box opens.

2. In the Type drop-down menu, select the Drawing option.
3. In the Number field, use the up and down arrows or type the number of layers you want to add at once.
4. In the Name field, type the name of the layer you want to add. If you are adding more than one layer at once, all of the layers use that name with a numerical suffix added.
5. To complete the operation:
Click OK to add your new layers and close the dialog box.
Click Apply to add your new layers and keep the dialog box open to add another layer.
Click Close to cancel the operation.

Adding a Drawing Layer from the Top Menu

You can add a new layer from the top menu.

To add a new layer from the top menu:

1. In the top menu, select Insert > Drawing.

A new layer appears in the Timeline and Xsheet views.

Adding Drawing Columns in the Xsheet View

To add a drawing column:

1. Do one of the following:
In the Xsheet view, right-click and select Columns > Add Column.
In the Xsheet View toolbar, click the Add Columns button or press [Shift] + [C]].
To quickly add a Drawing column, press [Ctrl] + [R] (Windows/Linux) or [⌘] + [R] (Mac OS X).

The Add Columns dialog box opens.

2. In the Column Name field, name your column accordingly.
3. In the Column Type field, select Drawing.
Refer to the topic Layer Types to know more about the different column types available.
4. To complete the operation:
Click OK to add your new layers and close the dialog box.
Click Apply to add your new layers and keep the dialog box open to add column.
Click Close to cancel the operation.

In Harmony, you can use the advanced Add Column dialog box, with more file format and field size options, to insert the column.

To create a column in Toon Boom Harmony using the advanced Add Column dialog box:

1. Select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X) and select the Advanced tab.
2. In the Advanced Options section, select the Advanced Element Mode option to access the advanced Add Column dialog box.

3. Click OK.
4. In the Xsheet View menu, select Columns > Add Column or press [Shift] + [C].

The Add Column dialog box opens.

5. In the Name field, type the new column’s name.
6. In the Type drop-down menu, select the Drawing type.
7. In the Element section select if you either want to create a new column or link the new column to an existing one:
Create New Element: Select this option if you want your column to be an independent column with its own drawing folder.
Reuse Existing Folder: Select this option if you want to link your column to an existing folder within the Element folder of your scene.

If you select the Reuse Existing Folder option, in the Folder drop-down field, select the folder to which you want to link your new column.

Use Existing Element: Select this option if you want your column to use drawings from an existing column. Both columns will be attached to the same set of drawings, but their timing will remain independent from one another. If you modify one of the drawings, it will be modified in both columns. This is the same principle as the Clone column.

If you select the Use Existing Element option, in the Name drop-down field, select the column to which you want to link your new column.

8. If you select the Create New Element option:
Deselect the Vector option if you want your layer to contain bitmap images or enable it if you want the layer to contain vector drawings. Most of the time, the Vector option will be enabled.
If you deselected the Vector option, from the Bitmap Format drop-down list, select which type of bitmap image you wish to insert in the column. Select the SCAN type if you are planning to scan drawings using Toon Boom Harmony’s scan module.
If you deselected the Vector option and you chose the SCAN type, from the Scan Type drop-down, select what kind of scanning you wish to achieve.
In the Field Chart field, when importing traditional animation, indicate the size of paper on which the animation or background was drawn. If you are not using perforated animation paper, leave the 12 field default value as is.
9. Do one of the following:
Click OK button to create the new column and close the dialog box.
Click Apply to create the new column but keep the dialog box opened to create other new columns.

Related Topics 

Layers and Columns
Layer and Column Concepts
Advanced Column Types
Layer Content
Adding New Drawing Layers
Deleting Layers and Columns
Modifying Layers
Duplicating Layers and Columns
Cloning Layers And Columns
Xsheet Thumbnails
Changing the Colour of a Layer or Column
Expanding and Collapsing Layers and Columns
Modifying the Look of the Column