Paint Guide > Toon Boom Harmony 10 Paint User Guide > Chapter 5: Colour > Colours > Adding a Colour Swatch

Adding a Colour Swatch

You can use three different types of colour swatches, these are described in the following sections:

Solid Colour Swatch
Default Colour Swatch
Gradient Colour Swatch
Bitmap Texture Swatch

Solid Colour Swatch

To add or modify a solid colour swatch:

1. In the Colour view, click on the New Colour button.
2. In the Colour View menu, select Colours > Edit. You can also double-click on the colour pot.

The Colour Picker window opens.

3. To set your colour:
In the colour wheel, select the desired colour.

OR

Type in the HSV or RGB values in the corresponding fields. Click on the R,G,B,H,S or V radio buttons to change the look of the colour picking area.

OR

Click on the Dropper button to select any colour on your screen. It can be from the Toon Boom Harmony’s interface, your Operating System or any other open application.

You can also click on the Multi Wheel Mode button to open the Multiwheel Colour dialog box. This displays all the picking area styles together and also contains a picking undo list. Click on the Single Wheel Mode button to go back to the regular Colour Picker window.

4. If needed, click on the Shade Scale’s swatches to modify the shade of the selected colour.

5. If necessary, adjust the desired level of transparency with the Alpha slider, or type the value directly in the Alpha field.

6. If necessary, click on the Add button to add the current selected colour to the Colour Storage Library, so you can quickly access it later.

7. You can rename the colour swatch in the Colour Picker window or directly in the colour list by double-clicking on its name.

 

Default Colour Swatch

In Toon Boom Harmony, when you click on the Add Colour button, a new colour swatch is created using the colour of the currently selected swatch from your palette. However, you can set a Default colour to be used every time you create a new colour in your colour palette. This might be useful if you want to create different shades of the same basic colour.

To change the default swatch colour for all your colour palettes:

1. In the top menu, go to Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X).
2. In the Preferences panel, under the Drawing tab, enable the Create New Colour Pot Using the Default Colour option. In addition, You can click on the colour swatch, located just beside, to change the Default colour.

The default colour is also the colour used when you choose to vectorize images that you are scanning into your scene, however you add the Default colour swatch to your palette in a different way, so that it is unique. It has a unique ID number that makes it recognizable from all the other colours in your colour palettes. Being able to change this colour allows you to change the basic colour of all scanned drawings. This can be useful on more than just an aesthetic level as sometimes when you go to NTSC or PAL, pure colours, such as pure black, can create problems.

To add a new colour swatch using the default colour:

1. In the Colour View menu, select Colours > New.

A new swatch will be added to your palette using the default colour pot colour. The new swatch created with the New command will be named New 0.

Refer to Colour Preferences to learn more on the Create New Colour Pot Using The Default Colour preference and how to customize the default colour pot colour.

Gradient Colour Swatch

To create a gradient colour swatch:

1. In the Colour view, select the colour to be modified.

2. In the Colour View menu, select Colours > Edit. You can also double-click on the colour pot.

The Colour Picker window opens.

3. Enable the Gradient option.

4. Select the Linear or Radial option.
5. Select the Gradient arrows to modify the colours.

Click between the arrows to add extra colours.

Pull down the arrows to remove them.

Move the arrows left and right to modify the gradient distance.

Refer to the Editing Gradients and Textures topic to learn how to reposition your gradient zones in your drawings.

Bitmap Texture Swatch

To create a texture colour:

1. In the Colour View menu, select Colours > New Texture or click on the New Texture button.

The Browser window opens.

2. Browse for a PSD or TGA bitmap file created in a third party software.

3. Click on the Open button to create the colour swatch.

Refer to the Editing Gradients and Textures topic to learn how to reposition your textured zones in your drawings.

You can also replace a texture once it is painted. If you decide to make the character’s shirt wool instead of plaid, just update the texture file in the swatch and the entire project updates. Any transformation previously applied to the texture’s position in your drawings will be kept.

To replace a texture swatch:

1. In the Colour view, select the texture swatch you want to change the embedded bitmap texture file in.

2. In the Colour View menu, select Colours > Edit Texture. You can also double-click on the swatch.

The Browser window opens.

3. Browse for the new PSD or TGA bitmap file created in a third party software.

4. Click on the Open button to update the colour swatch.

Related Topics 

How to Paint
Deleting a Colour Swatch