Intro > Release Notes > Toon Boom Harmony 11.1 Release Notes

Toon Boom Harmony 11.1 Release Notes

Version 11.1

 

Here are the new features, changes, improvements, and bug fixes in Toon Boom Harmony 11.1:

Features
Changes and Improvements
What's Fixed?

 

Features

Feature Description
New and Updated Icons There are improved icons for the Transform and Skew tools, as well as the Art Layers toolbar. New icons are also available in the Script Editor.
Games

When exporting sprite sheets for games, the following is now supported:

Deformation: Harmony can export deformation networks to the game engine XML format (bones and articulations only).
Cutter: Both cutters and inverted cutters are supported.
Transparency Nodes: The Transparency parameter attached to an element module is exported along with animation. You can set the transparency through the Layer Properties window.

Also, colliders were improved to provide different types of colliders for use with Unity.

Plugins When one or more plugins are missing, Stage will prevent the scene from being saved. There is a new option in the General tab of the Preferences dialog box called: Open in Read Only mode if plugin syntax errors are detected. When you select this option, scenes that load with plugin module errors will open in read-only mode. This prevents you from losing plugin information on subsequent saves.
New scene marker method When marking a current frame, a single-frame length note is created at the current active frame.

Support for Non-exposed Drawings

You can import SWF files through the Swf2tvg utility which now supports non-exposed drawings in symbols from Flash.
Resolution.conf File There is a new resolution.xml file to store the resolutions of Harmony 11 productions. Previous versions of Harmony, such as 10.3, still use the resolution.conf file, but version 11.1 uses the .xml file. Since they don't have the same options written in their respective files, there were warning messages when going back to 10.3 scenes.
Export Images to Render Farm In database mode, the Sketch and Draw modules offer an Export Images to Render Farm option. This option was removed from the Export Images and placed in a separate window.
Harmony Cloud
A Log View tab was added to HarmonyCloud.
You can now insert new scene(s) before/after a selected item.
The following were added: Add Send to Render, Send to Vectorize, Render and Vectorize Queues.
OTF Fonts The font manager can now load OTF fonts for Japanese or Chinese for example. You can use the Text tool with these fonts.
Deformation Keyboard Shortcut In the Shortcuts tab of the Preferences dialog box, you can now add your own keyboard shortcut for the Copy Resting Position to Current feature.

Changes and Improvements

Change and Improvement Description
Adjustments to the Interface
Shadows no longer appear on icons.
Icons that are selected appear with darker backgrounds.
When using the dark themed interface, the backgrounds of the icons are now lighter.
Workspace When moving a view to create a new subdivision, the destination where you can position the view appears highlighted in a light-blue colour.
Performance Improved performance when pasting a heavy template into the scene.
Optimizations
Bitmap deformation is optimized.
Optimization when rendering blurs by using the GPU's acceleration capabilities. There is a new option in the Render tab of the Preferences dialog box to turn this option on or off; it is called Enable Graphic Card Acceleration. This option is on by default. Not all cards support this acceleration.

No Re-rendering

Simply selecting a different module in the Network view no longer starts a re-render.
Antialiasing On Windows and Linux, you can enable antialiasing from the Render tab in the Preferences dialog box without having to change the settings in the graphic card itself. Previously this was available only on the Mac, but now all platforms support this OpenGL option.
Expression Columns Correction to expression columns so they can be attached to 3D paths. Note that the correct syntax is: value(column("Peg x")).
Removed
Script Help view: Information contained in the Script Help view is now available in the Scripting Guide.
Rename Drawings with Prefix command in the Drawing and Camera view menu.
Message about deleting sound files when you are only editing them.
Menu Commands
In the Sketch module, the Save menu command was changed to: Advanced Save.
The Select Previous/Next Brother menu command was changed to: Select Previous/Next Sibling.
Eraser Presets

A separate list was brought back for the Eraser presets. It was previously combined with the Brush tool list for vector tools.

What's Fixed?

Item Fixed Description
Fixed Crash

When video card has no OpenGL platforms.

When creating a scene in offline mode. Harmony would crash before the scene can load and open. This was associated with the timeline paste modes.

Doing skews and rotations of a bitmap.

For thumbnails of certain templates in the Library.

When opening an element from a scene in the Scan module.

When playing back a deformation-heavy scene.

When creating elements via the database selector in the Scan module.

When moving the centre control on a 3D Region module that is attached to a Bounce particle module.

When filling cells in sound columns.

In the Colour Override module when selecting multiple colour swatches from the Selected Colours area and dragging them to the Colour Overrides area.

Potential crash when exiting application while a module editor is still open.
Fixed Various Items

Export to QuickTime of a scene with Glue that didn't render properly.

Bug with Glue module that caused a duplication of one of the drawings in the render.

Links in documents in the Help system for Particles.

Issue when sliding a keyframe away from a following keyframe that would mess up the second one.

Issue where copying symbols into the Library would not bring all the frames of the symbol. It would copy only the frames selected from the selected layers.

Issue when scanning images that it would create new layers for each images instead of adding them to the just created new layer.

Deadlock when rendering scenes with Colour Override using textures, especially in batch render.

Situation where you can't select and delete a stroke with the Contour Editor tool.

Render progress bar that went backwards on very long scenes.

Issue where sliding 3D path keyframes left an overlapping highlight in the Xsheet

Aspect ratio issue when rendering a bitmap file with single-point deformation. We would have the aspect ratio result.

Pasting to the Library of symbols that did not bring all the frames of the symbol. It pasted only the frames selected from the selected layers instead of all the content of the symbol.

Deleting a js script that you just created or imported.

Transform tool bounding box that did not display properly with bitmap tvgs that are combined with deformation.

Pose Copier script that could not see the thumbnails of some templates or open the Exceptions window.

Import image that would not let you see the .xli file created when using Export layout.

(Mavericks) Font errors when you start Stage from a shell.

Adding texture to a pencil preset. It will no longer change your current colour selection.

Display of Red, Green, Blue and Alpha functions in the Timeline view.

Turbulence module did not render anything when a Gradient or Colour Card is connected to it.

Database error preventing batch render from working.

Issue with closed shape pencil lines while morphing. For example, a square to a circle shape.

TB_ExportToEaselJS script to deal with mismatching resolution so it doesn't cut parts of a character.

Issue when rendering a bitmap tilted at 45 degrees. The resulting image is offset by about 1 pixel to the left.

Relative path to the scene in templates. Drawings linked using timing were not loaded when relative path has local timing.

Loss of colour information when exporting to PNG4. Fixed by unmultiplying to keep the colour information but scraping the alpha channel.

Soft trace legacy plugin.

Issues with importing offline scenes into database through Control Center where renamed, duplicated elements would have ID collision. The drawings would not appear in the scene because of these element conflicts. Fix in Control center and Cloud.

Issue where we couldn't run dbu utility from non /USA_DB paths.

Remove Unused Files menu item didn't recognize a Pencil Texture Palette in use and offered wrongly to remove and delete it.

When using the Create Colour art from Line Art on scanned drawings, the resulting colour art had a centre stroke and a contour stroke. It should have only the centre one.