Stage Guide > Toon Boom Harmony 10 Stage User Guide > Chapter 19: Effects > Using Effects > Gradient
Download Toon Boom DocumentationDownload Documentation

Gradient

The Gradient effect lets you create a transition of colour or alpha values between two areas of colours. You can create a linear or radial gradient. Use two points to indicate where those two coloured areas are. You can then move these points to create the transition.

The Gradient module covers the entire camera frame and beyond. You do not need to scale it up or down. It will automatically cover an infinite zone. You simply need to connect it behind your scene's elements. You can connect it in front of some elements you want to cover. By default, the Gradient has a Z ordering value of 0. When you select the Gradient module, the Camera view displays yellow triangles to indicate that it`s selected.

Use the Gradient editor to control the values of the gradient and the position of its output.

Gradient Effect Properties

Parameter Description
Gradient Type Lets you select a linear or radial gradient.
Point 1, Point 1 These sections control the values of the first point (point 0) and the second point (point 1) in the gradient.
Red, Green, Blue, Alpha The colour and alpha values of the corresponding point. You can also click the colour swatch to open the Colour Picker window and select a new colour. These colours can be animated over time if the value parameter is hooked to a function curve. Default values are 0,0,0 and 255, 255, 255.
(x) Axis Sets the X coordinate for the corresponding point.
(z) Axis Sets the Y coordinate for the corresponding point.
Offset Z Enter the front-back position of the Gradient layer in 3D space. You can verify this value in the Top view.
Depth Determines the composition order when the Z value of two elements is the same.

Controlling the Gradient in the Camera View

If you want to control the gradient's orientation and points position in the Camera view, you can use the Control command to display the points and move them.

To control the gradient in the Camera view:

1. In the Tools toolbar, select the Transform tool.
2. In the Network view, select the Gradient module.
3. Select View > Show > Control.
4. In the Camera view, click the Gradient's points and move them.

Related Topics 

Using Effects