Stage Guide > Toon Boom Harmony 10 Stage User Guide > Chapter 10: Library > Symbols > Creating a Symbol
Download Toon Boom DocumentationDownload Documentation

Creating a Symbol

You can create symbols in several ways:

Creating a Symbol from a Drawing Selection
Creating a Symbol from the Timeline View
Creating a Symbol from the Network View
Creating an Empty Symbol

Creating a Symbol from a Drawing Selection

To create a symbol from a drawing selection:

1. In the Tools toolbar, select the Select or Cutter tool.
2. In the Camera view, select the drawing objects which you want to create a symbol out of.

3. In the top menu, select Edit > Create Symbol or press [F8]. You can also click on the Create Symbol button in the Edit toolbar.

The Create Symbol from Drawing Selection dialog box opens

4. In the Symbol Name field, type the name of the symbol.
You can also select an existing layer from the Symbol Name drop-down menu. It will add your symbol on the layer's current cell. If there is already an exposure on that cell a warning message will appear stating, "Layer Head already has an exposure on current frame. Can't perform operation."

If you want to rename a symbol,right-click on the symbol and select Rename.
5. You can choose to leave the current selected artwork in the drawing or not:
To remove currently selected artwork from the drawing and leave it in the new symbol, enable (place a checkmark in the checkbox) the Cut Artwork From Source Drawing option.
To keep currently selected artwork in both the drawing and in the new symbol, disable (remove the checkmark from the checkbox) the Cut Artwork From Source Drawing option.
6. Click OK.

The new symbol appears in the Library view's symbol folder and in the Timeline view as a new layer.

Creating a Symbol from the Timeline View

To create a symbol from the Timeline view:

1. In the Timeline view, select the layer or the cells from which your want to create a symbol.
2. In the top menu, select Edit > Create Symbol or press [F8]. You can also click on the Create Symbol button in the Edit toolbar.
Another way to create a symbol is to select the layer or cells from the Timeline view and to drag them on the Symbol folder in the Library view.

The Create Symbol dialog box opens

3. In the Enter Symbol's Name field, type the new symbol's name.
To rename a symbol once it is created, right-click on the symbol and select Rename.
4. Click OK.

The new symbol appears in the Library view's symbol folder.

The current selection is not replaced by the new symbol. The new symbol only appears in the library. You must drag it into your scene to use it.

Creating a Symbol from the Network View

In Harmony, you can create symbols from the Network view.

To create a symbol from the Network view:

1. In the Network view, select the modules from which you want to create a symbol.
2. In the top menu, select Edit > Create Symbol or press [F8]. You can also click on the Create Symbol button in the Edit toolbar.
Another way to create a symbol is to select the modules from the Network view and copy and paste them inside the Symbol folder in the Library view or press [Ctrl] + [C] and [Ctrl] + [V] (Windows/Linux) or [⌘] + [C] and [⌘] + [V] (Mac OS X).

The Create Symbol dialog box opens

3. In the Enter Symbol's Name field, type the new symbol's name.
To rename a symbol once it is created,right-click on the symbol and select Rename.
4. Click OK.

The new symbol appears in the Library view's Symbol folder.

The current selection is not replaced by the new symbol. The new symbol only appears in the library. You must drag it into your scene to use it.

Creating an Empty Symbol

To create an empty symbol:

1. In the Library view, select the Symbol folder.
2. In the Library view's right side,right-click and select New Symbol. You can also select Insert > Create Empty Symbol in Library from the top menu.

The new empty symbol appears in the Library view.

The symbol is ready for you to edit (add content to). To go back to the root timeline, click on the Top button in the Camera view.
To rename a symbol once it is created,right-click on the symbol and select Rename.

Related Topics 

Importing Symbols and Templates