Stage Guide > Toon Boom Harmony 10 Stage User Guide > Chapter 10: Library > Structuring the Library
Download Toon Boom DocumentationDownload Documentation

Structuring the Library

As you will probably create a large number of Symbols and templates, you will soon realize that they need to be organized. You can create different libraries and subfolders so you can easily access your assets. For example, create a different library for each project and divide it into several categories, such as:

Characters
Props
Backgrounds

Although you can only have one Symbol library folder, you can organize it by creating subfolders.

Creating a Library
Opening a Library
Closing a Library
Creating a Folder
Deleting a Folder
Renaming a Folder
Refreshing the Library
Generating Thumbnails

There are two ways to create Library folders.

Using Harmony's interface.
Directly through your operating system.

To create a library using your operating system, create a new folder with a relevant name in the location where you want the library to be stored. This can be opened in Harmony when you require it. .

To create a library from Harmony:

1. In the Library view click on the Menu button and select Folders > Open Library.

The Browser window opens.

2. Browse for the location where you want to store your new library.
3. Click the New Folder button.

A new folder appears.

4. Name the new library with a relevant name and click OK.

The new library appears in the Library List section.

You can open any folder on your hard drive or network as a library. Opening a library means linking the folder to your Library view. You only need to open the library once. The library folder is available every time you open the application until you decide to close the library and unlink it.

To open a library:

1. In the Library View menu, select Folders > Open Library.

The Browser window opens.

2. Browse to the location of the library folder.
3. Select the folder and click OK.

The new library appears in the Library Folders section.

You may not always require all of the library folders in the Library List. If this is the case, you can close the ones you do not need. Closing a folder does not delete it, but unlinks it from the Library view. If you want to reopen it, locate it on your hard drive or network and open it in the Library view.

To close a library:

1. On the right side of the Library view, select the library folder to close.
2. In the Library View menu, select Folders > Close Library.

The library closes.

Symbol and template libraries need to be organized. You can create different subfolders on your hard drive or in the Library view, so you can easily access your assets. By default, any new library you link to your Library view is locked to prevent accidental deletion or modification of templates and Symbols. You must obtain the right to modify it before being able to add a new folder to it.

To create a folder:

1. On the left side of the Library view, select the library folder to which you want to add a subfolder.
2. In the Library View menu, select Edit > Right to Modify.
3. In the Library View menu, select Folders > New Folder.

The new folder appears in the Library. Click on the library containing the new folder and click the plus [+] sign to expand it.

You can delete a folder from the library if its contents are no longer needed.

Warning: All templates and Symbols in the folder will be deleted from your hard drive. Once deleted, the data cannot be retrieved.

To delete a folder:

1. In the Library view's left side, select the folder to delete.
2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and select Right to Modify.
3. In the Library View menu, select Folders > Delete Folder or press [Delete].

Once you add a folder, you can rename it. This also renames the folder on your hard drive.

To rename a folder:

1. In the Library view's left side, select the folder to rename.
2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and select Right to Modify.
3. In the Library View menu, select Folders > Rename Folder.
4. Rename the selected folder.

5. Press [Enter/Return] to validate the operation.

If you update the content of your libraries through your operating system, you will need to refresh your library folders in the Library view.

To refresh a library:

1. In the Library view's left side, select the folder to refresh.
2. In the Library View menu, select Folders > Refresh or press [F5].

The library displays the new content.

When you display thumbnails in the Library view, the system generates a series of small images (thumbnails) for you. You can generate template thumbnails yourself, if they do not display or if the process has been stopped.

To generate thumbnails:

1. In the Library view's right side, select the template you want to generate thumbnails for.

2. In the Library View menu, select View > Generate Thumbnails.

The progress bar appears.

You can also delete thumbnails if you want to send a template to another user or studio and keep your packages small.

To delete thumbnails:

1. In the Library View menu, select Edit > Delete Thumbnails.

All the thumbnails contained in the library are removed.

Related Topics 

Understanding the Library Concept