Paint Guide > Toon Boom Harmony 10.3 Paint User Guide > Chapter 5: Colour > Palettes > Importing Palettes
Download Toon Boom DocumentationDownload Documentation

Importing Palettes

Importing a Colour Palette
Linking a Colour Palette
Linking your Master Palette
Palette Linkage Status Icons

Importing a Colour Palette

If you created a palette in another project and you would like to import it in your current project, you can browse for the palette file on your computer and add it to your project. When the palette is imported in your scene, the file is copied in the project’s directory. It is not linked to the original file.

To import a palette into your project:

1. In the Colour View menu, select Palettes > Import or click on the Import Palette button.

The Browser window opens.

2. Browse for a palette file located on your hard-drive. You will generally find the palettes in your projects’ Palette-Library directory.
3. Click on the Open button.

The palette appears in the Palette list.

Linking a Colour Palette

You may encounter a scene where only the colour palette created for a certain layer is visible when that layer is selected. A good example would be a scene where there is a character on one layer and the background on another and each has its own custom colour palette. In order to see both colour palettes, independent of what element is selected, you must link your palette list to another palette file within the Harmony structure.

To link a colour palette:

1. In the Colour View menu, select Palette > Link.

The Palette Browser window opens.

2. Select the level where the palette file is stored. (Usually Scene or Element)
3. Select the Scene or Element Palette list. See Scene Palette List and Element Palette List topic for more information.

The palette appears in the Colour view.

See Scene Palette List and Element Palette List topic for more information.

Linking your Master Palette

With Toon Boom Harmony as a stand-alone application, every scene is local to the machine. This means that all of the scene’s data is only accessible from that particular scene. Palettes are also local to the scene: they can be shared between all drawing layers, but not between scenes.

However, some users may want to share their palettes across a whole project. Toon Boom Harmony offers that possibility.

By default, a palette is an independent file stored in your Toon Boom Harmony scene. This file can be copied, moved or deleted.

To fully link a palette throughout an entire project, you need to create a central directory where you can copy all of the palettes you have created. Every time you link a palette in an element, it is linked to this folder. If you modify the palette, it will be updated throughout the whole project.

To link your master palette:

1. In the Colour view, click on the Create Palette button to create your master palette.
2. Save your scene by selecting File > Save from the top menu or by clicking on the Save button or press [Ctrl] + [S] (Windows/Linux) or [⌘] + [S] (Mac OS X).
3. In your operating system, create a master directory. Ideally, this should be created in your Root folder to keep it within the project directory. You could also place it inside your Colour Model’s subdirectory.

4. Name the folder appropriately, for example: Joe’s_master_palettes.
5. From your operating system, browse to your Toon Boom Harmony scene and open the palette-library folder.

6. Select and copy your palette.plt file to copy it to the master palette directory.

7. Create a new Toon Boom Harmony scene or open the scene where you will link this palette.
8. In the Timeline or Xsheet view, select the element to link the palette to.

9. In the Colour View menu, select Palettes > Link to External.

The Link to External Palette dialog box opens.

Files: Click on the button to browse to your master palettes folder and select the palette *.plt file you want to link.
Palette List: Select either you want to load this palette at scene or element level.
10. Click OK.

The linked palette appears in your Colour view.

If a palette is outside the scene, the External icon appears beside the palette name.

To link an element (such as a colour model) to the palette that is stored in the external palette directory, you must remove the original palette from the element’s palette list. You will then load the duplicated palette into the palette list using the Link to External command, like you did for the other elements.

Palette Linkage Status Icons

You will also notice that when you create or link a palette, a small icon will appear on its left. These icons represent the palette linkage status.

Indicates a potentially dangerous situation.

Problems may occur when trying to export or link to the palette file. For example, a palette file is stored into the element folder and is linked to the Scene Palette list. The issue in this case is that if you decide to delete the layer containing the palette, you will loose it from your scene.

Indicates that the palette is safe.

There won’t be any trouble once the scene will be exported. For example, the palette file is stored in the scene folder and is linked to the Scene Palette List.

Indicates that the palette file is stored in a directory external to the scene’s structure.

The palette file is probably stored in a Master Palette directory on a hard drive external to the palette-libraries planned for the palette storage. The warning in this case is that if you move your Master Palette directory to another location, you may loose the palette in your scene.

Indicates that a palette file stored in a level such as Element, Scene, Job or Environment is linked to a Palette list that is not on the same level.

For example, a palette file is stored into the Environment folder and is linked to the Element Palette list. The palette is shared.