Paint Guide > Toon Boom Harmony 10.3 Paint User Guide > Chapter 4: Clean Up and Drawing Tools > Selecting Drawing Objects > Select Tool Properties
Download Toon Boom DocumentationDownload Documentation

Select Tool Properties

When you choose the Select tool, its properties and options appear in the Tool Properties view.

Related Topics 

Manipulators
Snap Options
Permanent Selection
Apply to All Drawings in Layer
Apply to All Visible Drawings
Apply to Line and Colour Art
Select by Colour
Flip Horizontal and Vertical
Rotate 90 Degrees CW and CCW
Pencil to Brush
Smooth
Flatten
Store Colour Gradient
Merge Pencil Lines
Reverse Pencil Thickness
Create Colour Art from Line Art
Distribute to Layers
Width and Height
Offset X and Y
Angle
Adjusting the Pencil Line Thickness
Adjusting the Pencil Line Style
Pencil Stencils
Adding Texture to a Pencil Line
Adjusting the Text Selection

Manipulators

Choose between the Select tool and the Transform tool. This is a fast way to switch between the Select tool and Transform tool selection mode.

Snap Options

You can enable different snapping modes to help you when repositioning your drawings using the Select tool.

Snap to Contour: Snaps your selection or point to any line you position it on. As soon as you move it close enough to another line, your point or selection will snap to it.
Snap and Align: Snaps the selected anchor point to any existing line while displaying temporary rulers as a guide that you can also snap your anchor point to.
Snap to Grid: Snaps your selection following the currently enabled grid.

To snap to grid:

Select View > Grid > Show Grid to display the grid in the Camera or Drawing view or press [Ctrl] + ['] (Windows/Linux) or [⌘] + ['] (Mac OS X).
Select View > Grid > Square Grid, 12 Field Grid or 16 Field Grid for your current needs.
1. In the Tools toolbar, select the Contour Editor tool or press [Alt] + [Q].
2. In the Contour Editor Tool Properties view, click the Snap to Grid button.
3. In the Camera or Drawing view, click on an anchor point you want to snap following the grid, and drag it to the desired position and release.

Refer to the Grid topic to learn more about the Grid feature.

Permanent Selection

The Permanent Selection option is used to maintain a selection over multiple drawings. Once this option is enabled, the selection zone made using the Select tool will remain as you navigate through drawings from a layer and drawings from other drawing layers. This option can be used to simultaneously delete artwork inside or outside of the selection on several drawings when combined with the Apply to Multiple Drawings option.

Apply to All Drawings in Layer

The Apply to All Drawings in Layer option is used to perform an action on all the drawings contained in a layer. For example, you could enable the option to paint a section on all the drawings simultaneously. The Apply Tool to All Drawings option must be activated before performing the action and will stay enabled only for the next action.

Apply to All Visible Drawings

The Apply to All Visible Drawings option is used to perform an action on all the visible drawings in the Camera view. This option is not available in the Drawing view.

Apply to Line and Colour Art

The Apply to Line and Colour Art option uses the concept of Line Art and Colour Art layers. Use this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art layers, as well as the Overlay and Underlay layers.

Select by Colour

The Select by Colour mode lets you select all the zones in your drawing painted with the same colour.

Only the zones painted with the SAME colour swatch will be selected. If another zone is coloured with the exact same RGB value (same colour), but not painted with the same colour swatch, it will not be selected.

To select areas by colour:

1. In the Tools toolbar, select the Select tool or press [Alt] + [S].
2. In the Tool Properties view, click the Select by Colour button.
3. In the view, click on any zone in your drawing.

All zones of the same colour are selected.

4. Click the Select tool again to return to the regular Select mode.

Flip Horizontal and Vertical

The Flip Horizontal and Flip Vertical operations flip the current selection horizontally or vertically.

From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW and Rotate 90 Degrees CCW operations rotate the current selection 90 degrees clockwise or counter-clockwise.

From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 Degrees CCW.

Or press [Ctrl] + [7] and [Ctrl] + [9] (Windows/Linux) or [⌘] + [7] and [⌘] + [9] (Mac OS X).

Pencil to Brush

The Pencil to Brush operation converts the selected centreline pencil strokes into contour strokes brush lines.

From the top menu, select Drawing > Convert > Pencil Lines to Brush or press [&].

Smooth

The Smooth operation lets you smooth out selected drawing strokes and remove extra points. You can also access this feature through the top menu, by selecting Drawing > Optimize > Smooth or press [Alt] + [Shift] + [S].

Flatten

The Flatten operation is used to merge drawing objects and brush strokes into a single layer. If you draw new lines to fix a drawing or a line with many brush strokes, it can be useful to flatten them all into a single shape. By default, lines are drawn one on top of each other, if you intend repainting the lines or modifying their shape, it will be easier if they are flattened.

You can also access this feature through the top menu, by selecting Drawing > Optimize > Flatten. The [Alt] + [Shift] + [F].

Store Colour Gradient

Use the Store Colour Gradient operation to record the selected gradient’s position. This reuses the stored position of the gradient when drawing new brush lines or painting colour zones. Enable the Use Stored Colour Gradient option in the Paint or Brush Tool Properties view to do this.

Refer to Drawing with the Brush Tool or Painting Using the Paint Tool to learn how to use the Use Stored Colour Gradient option.

Merge Pencil Lines

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to align them and make it look like it is one single line. With the Select tool, you can select several pencil lines and merge them as one single object using the Merge Pencil Lines option. It will take your lines and adjust the ends to form one single line.

Points have to be close enough to be merge. If there is a big gap between the lines, they will not be merged.

Reverse Pencil Thickness

The Reverse Pencil Thickness option will invert the thick and thin section on a selected pencil line. This option will take the thickest size on the line and apply it to the thinnest, and it will apply the thinnest to the thickest.

Create Colour Art from Line Art

You can configure the Create Colour Art from Line Art option to suit your requirements.

To configure the Create Colour Art from Line Art option:

1. In the Select tool Tool Properties view, [Shift] + click the Create Colour Art from Line Art button.

The Configure Line Art to Colour Art dialog box opens.

Use rendered version of the drawing: This option will render the drawing and vectorize it to calculate the position of the centreline that will produce the colour art stroke.
Maximum Resolution for rendered image: The size of the rendered image.
Threshold for rendered image: The value of grey processed to create the rendered vectorized arts.
Fitting error for rendered beziers: This value represents how precise the fitting of the colour art zone in relation to the line art will be.
Source layer: Select the layer (Line Art, Colour Art, Underlay or Overlay) you want the colour art to be created from.
Destination layer: Select the layer (Line Art, Colour Art, Underlay or Overlay) you want the colour art to be created on.
Clear Destination Art Layer First: Enable this option if you already have artwork on the destination layer and you want the content to be deleted before the colour art is added into it.
Perform Line Art to Colour Art Operation Immediately: Enable this option to perform the Create Colour Art from Line Art command when you click OK.
Refer to Line Art and Colour Art Layers to learn more about the Line Art and Colour Art concept.

Distribute to Layers

The Distribute to Layers option is used to separate the selected art strokes and send them to new drawing layers. In the Camera view, once you have drawn your artwork, you can select the strokes you want to distribute using the Select tool and click on the Distribute to Layer button, you can also select Drawing > Distribute to Layer. It will automatically take every stroke from the drawing selection made in the Camera view and separate them into a different layer for each. If an artwork is composed of several strokes, you must group them using Edit > Group > Group before using the Distribute to Layer option. This option cannot be done from the Drawing view.

Refer to Break Down: Distribute to Layers to learn more about the Distribute to Layer option.

Width and Height

Use the Width and Height operation fields to enter specific values to resize the selected shape with precision.

1. Width: Type a width value in this field to resize the width of your selection.
2. Height: Type a height value in this field to resize the height of your selection.
3. Up/Down arrows: Use the up and down arrows to modify the value contained in either the Width or Height value field.
4. Lock icon: Click on the lock icon to lock or unlock the ratio between the width and height values.

Offset X and Y

Use the Offset X and Offset Y operation fields to enter specific values and precisely reposition the selected shape.

1. X: Type an offset value in this field to reposition your selection along the X-axis.
2. Y: Type an offset value in this field to reposition your selection along the Y-axis.
3. Up/Down arrows: Use the up and down arrows to modify the value contained in either the X or Y value field.

Angle

Use the Angle operation fields to enter specific values and accurately rotate the selected shape.

1. Angle: Type a degree value in this field to rotate your selection.
2. Up/Down arrows: Use the up and down arrows to modify the value contained in the Angle value field.

Adjusting the Pencil Line Thickness

Use the Adjusting the Pencil Line Thickness operation field to resize the selected centreline strokes. This operation is not permitted on contour line shapes, such as brush strokes or shape fills.

1. Minimum Size: Type a value in this field to set the minimum thickness of the selected centreline stroke.
2. Maximum Size: Type a value in this field to set the maximum thickness of the selected centreline stroke.
3. Up/Down arrows: Use the up and down arrows to modify the value contained in the Thickness value field.
4. Lock Proportions: Enable the Lock option for the minimum and maximum size to increase and decrease in proportion.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.

Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between Round or Flat style.
End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between Round or Flat style.
Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define the Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Pencil Stencils

Toon Boom Harmony gives you the flexibility to change the style and thickness of your pencil lines even after they are drawn. You can apply preset pencil stencils or create your own.

Refer to Working with Templates, Creating a Pencil Templatewith the Select Tool and Working with Templates.

Adding Texture to a Pencil Line

Pencil lines support texture. Once a pencil line is drawn, you can apply a preset texture or load your own. Textures are independent from pencil stencils.

Refer to Pencil Line Texture, Applying a Preset Texture to a Pencil Line and Creating a Pencil Texture Template with the Select Tool.

Adjusting the Text Selection

When you select text with the Select tool, the tool properites will display the Text tool options on the bottom of the view. You can also press [Alt] + [9] to display only the Text properties in the Tool Propertie view.

Refer to Formatting the Text to learn more about the Text tool Tool Properties.

Related Topics 

Drawing Using the Pencil Tool
Pencil Tool Options
Working with Templates
Pencil Line Texture