Stage Guide > Toon Boom Harmony 10 Stage User Guide > Chapter 4: Drawing > Tool Preset View
Download Toon Boom DocumentationDownload Documentation

Working with Tool Presets

Create tool presets for 20 different tools, including the Paint, Polyline, Transform, Brush and Select tools. Define the colour, size and tool properties for the preset. Import a preset, or add a script, to have it perform specified actions. In addition, assign shortcuts for up to 10 of these presets.

To create a Tool Preset:

1. From the Tools toolbar, select a drawing tool.
2. In the Tool Properties panel, customize the selected tool. For example, if you have the Brush tool selected, you can tailor its maximum and minimum thickness, as well as assign a texture to it.
3. In the Colour view, create, or select, a colour.
4. In the Tool Presets view, click on the Create New Preset button, or from the View menu, select New Preset.

The new preset appears in the swatch section of the Tool Presets view with much of its details filled in based on the information provided in the Tool Properties panel.

To delete a Tool Preset:

1. In the Tool Presets view, select the preset that you would like to delete.
2. Click on the Delete Preset button, or from the View menu, select Delete Preset.

To save a Tool Preset:

1. In the Tool Presets view, select the preset that you would like to save.
2. Be sure that the Store in Preferences option is enabled (checked).
3. Either save your entire project, or from the View menu, select Save Presets.

Customizing a Tool Preset

To customize a Tool Preset icon:

1. In the software, create an icon for your new tool preset. You can either export this icon as a *.png, or simply save your scene.
2. In the Details section of the Tool Presets view, click on the Assigning icon to preset button to bring up the browser window.
3. Browse to and select the *.png that you just created, or browse to your current project folder and select the *.tvg from your project's elements folder.
4. Click on the Open button.

The icon appears in both the Details section, and on the swatch of your new tool preset.

5. From the View menu, select Icon Mode to view just the icons of your tool presets, instead of the large swatches.

To customize a Tool Preset name:

1. In the Tool Presets swatch window, select the tool preset that you would like to rename.
2. In the Details section, delete the text "New Preset" and enter in the name of your choice.

The new name is automatically saved.

3. From the View menu, select Swatch Mode to display just the name of your tool preset, as well as a small sample of the preset's properties.

To assign a shortcut for the Tool Preset:

1. In the top menu, go to Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X).
2. In the Preferences panel, in the Shortcuts tab, select Tool Presets and then the Tool Preset Shortcut number.
3. In the field beside the Clear button, enter the new keyboard shortcut.
4. If you have more than one tool preset shortcut to create, continue selecting the Tool Preset Shortcut number, and then enter the new keyboard shortcut.
5. When you are through, click on the OK button.

The shortcut is now displayed in the Tool Presets window, in the Shortcut drop-down menu next to its Tool Preset Shortcut number. It is also displayed in the top, right corner of the large tool preset swatch.

All new tool presets will be assigned the shortcut for Tool Preset Shortcut, which is 0. In order to change this, you will need to select another shortcut number from the Shortcut drop-down menu.

To customize the Tool Preset tool:

1. Before creating a new tool preset, from the Tools toolbar, select the drawing tool that you would like to create the new preset for. This is the tool that automatically appears in the Tool drop-down list, in the Tool Presets view, for a new preset.

The icon of the selected tool will appear in the upper, left corner of the large swatch of the tool preset.

2. If you would like to change the currently selected tool for one of your presets, select another drawing tool from the Tool drop-down menu.
3. If you would like to make your preset properties universally applicable to any drawing tool, uncheck the Tool option box.

The tool icon will disappear from the large tool preset swatch.

To customize the size of the Tool Preset:

1. In the Tool Presets view, select the tool preset that you would like the modify.
2. In the Tool Properties panel, note that a new pen style called PRESET has automatically been created and selected. This style is linked to the selected tool preset; any changes made in the Tool Properties panel will directly affect the selected tool preset.

3. In the Tool Properties panel, adjust the minimum and maximum size values.
4. In the Tool Presets view, click on the pen size swatch to update it, or click on the Refresh button.

The large tool preset swatch updates automatically.

5. If you would like to see just the maximum tip size of your tools in the swatch section, from the View menu, select Swatch Mode (Small).

To customize the colour of the Tool Preset:

1. In the Tool Presets view, select the tool preset that you would like to modify.
2. In the Colour view, select, or create, a new colour swatch.
3. In the Tool Presets view, click on the colour swatch to update it, or on the Refresh button.
4. If you would like to make your preset properties universally applicable for any colour selected in the Colour view, uncheck the Colour option box.

The colour swatch will disappear from the Details section.

If you have the Colour option checked in the Tool Presets view, and then you click on a different colour swatch in the Colour view, you will end up colouring with the newly selected colour swatch. To ensure that you are using the colour assigned to the tool preset, click on the tool preset immediately before beginning to use it.

To customize a Tool Preset using a script:

1. In the Tool Preset view, click on the Script button.

The Script to Execute dialog box opens.

2. In the Enter new script field, enter the script string that will be used to modify your preset.
3. Click on the OK button.
For information concerning scripts, please refer to the Harmony Scripting Guide and the Script Editor view.

Importing, Exporting and Sharing Tool Presets

Once you have created several tool presets, you might decide that you would like them to be available for another project, either on your computer, or elsewhere for other users.

To make a Tool Preset available for multiple projects on the same computer:

Be sure that the Store in Preferences option box is checked before you save and close your project. If you do not have this box checked for each tool preset, not only will the tool preset not be available in other projects, but it will also not be saved between sessions on the same project.

To share a Tool Preset with other users:

1. In the Tool Presets view, from the View menu, select Export Presets.

A browser window opens asking you to select a folder where it can save the *.xml file.

2. Click on the Choose button.
3. Transfer the folder containing the toolPresets.xml file to another computer, then launch Harmony 10.3.
4. On the second computer, in the Tool Presets view, from the View menu , select Import Presets.

A browser window opens asking you to select the folder where the toolPresets.xml file exists.

5. Click on the Choose button.

The tool presets from the first computer now appear in Tool Presetsthe view of the second.

The toolPresets.xml file will appear as a greyed out file, or may not appear at all, if the Show Hidden Files option is disabled on your computer. It is important to realize that the software is looking for the location (folder) of the *.xml file and not the file itself.
When you import the tool presets from another source, all those presets automatically have the Store in Preferences option box unchecked. To ensure that these imported presets are saved for the next session, be sure to check the Store in Preferences option box for each tool preset.

It may happen that when you open the Tool Presets view, all the tool presets that have a colour element will appear in red, and the Colour swatch will show the error message: Lost Colour. This may occur for any number of reasons, the most likely being that the new project is missing the necessary colour palette.

To recover lost colours:

1. In the Tool Presets view, from the View menu , select Recover Lost Colours.

The colours are restored to the tool presets, and if the original palette was missing, a new recovered palette will be created.

To remove temporary Tool Presets:

1. In the Tool Presets view, select a tool preset that you would like to delete.
2. Uncheck the Store in Preferences box for this preset.
3. Continue selecting and disabling this option box for any other preset that you would like to delete.
4. Be sure that no preset that you would like to save has the Store in Preferences option box disabled. For example, if you imported presets from another source, all those presets have the Store in Preferences option box automatically disabled by default. Once you remove a preset, this action is not undoable.
5. From the View menu , select Purge non Savable Presets.

The unwanted presets are removed from the Tool Presets view.

Related Topics 

Drawing with the Brush Tool
Drawing Using the Pencil Tool
Adding a Colour Swatch
Tool Properties View