Getting Started Guide > Toon Boom Harmony 10.3 Getting Started Guide > How to Import Sound and Add Lip-Sync
Download Toon Boom DocumentationDownload Documentation

Chapter 16: How to Import Sound and Add Lip-Sync

If you decide to add sound to your movie, you must first prepare this sound outside of Harmony. When this is done you must add a sound element in Harmony to the organize sound files in your animation. Sound will play in the movie until it reaches the end of the file or a stop frame that you have created in the Sound Element Editor.

If you first create your project in Toon Boom Storyboard Pro, the sound will be cut up into the different scenes for you automatically.

You can import WAV, AIFF or MP3 sound files using any of the methods listed below.

To import a sound file:

1. Select File > Import > Sound
Right-click anywhere in the frame zone of the Xsheet view.
From the Top menu
From the Xsheet View menu
From the Timeline View menu

The Select Sound File dialog box opens.

2. From the Select Sound File dialog box find and select your sound file from your computer.

Your sound file appears as a layer in both the Timeline and Xsheet view.

Lip-Sync

Adding a lip-sync to a project can really enhance its quality and storytelling. However, it can be difficult to shape a character's mouth so that it matches the sound at the precise frame.

To solve this problem Harmony provides a lip-sync feature which analyzes the contents of a sound element and generates a mouth chart (see below) based on the eight animation phonemes (A, B, C, D, E, F, G, and X, which is used to represent silence).

The mouth shapes used by Harmony are based on the conventional mouth chart used in the animation industry.

The letters used to represent the shapes do NOT correspond to an actual sound.
If you are doing cut-out animation, refer to the Harmony User Guide, Character Buidling chapter, "Adding Extra Drawings" topic to learn how to add extra drawings to your character.

Here is an approximation of which sound each mouth shape can produce:

A: m, b, p, h
B: s, d, j, i, k, t
C: e, a
D: A, E
E: o
F: u, oo
G: f, ph
X: Silence, undetermined sound

You can lip-sync the traditional way or let the system automatically create the basic detection.

You can refer to the mouth chart positions as you draw the shape of your character's mouth.

Automatic Lip-Sync Detection

To generate a sound detection for your lip-sync using the Layer Properties view:

1. In the Timeline or Xsheet view, select your sound layer.
2. In the Layer Properties, click Detect.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to each sound cell.

Harmony can automatically map drawings in an element to the mouth chart you have generated for a sound. This can save time when you are lip-synching a voice track.

In the Lip-Sync Mapping dialog box, you can identify each lip drawing of a character. Harmony then automatically labels all of the cells in the character's element with the appropriate name.

To automatically map lip-sync drawings to a mouth layer:

1. To open the Lip-Sync Mapping dialog box, do one of the following:
In the Timeline view,right-click on any cell in the sound sample layer and select Lip-Sync > Map Lip-Sync.
From the top menu, select Animation > Lip-Sync > Map Lip-Sync.
In the Timeline view, select your sound layer and in the Layer Properties view, click Map.

The Lip-Sync Mapping dialog box opens.

2. From the Destination Layer drop-down list, select the layer that contains the mouth positions for the character's voice track.

3. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on the layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to use the drawings or select the desired symbol from the drop-down menu.
4. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the phoneme it represents. If your drawings are already named with the phoneme letters, you do not have to do anything.
5. Click OK.
6. Press the Play  button in the Playback toolbar to see and hear the results in the Camera view. To play back your scene with sound, enable the Sound  button in the Playback toolbar.