
User Guide 



Legal Notices 

Corporate Headquarters
5530 St. Patrick

Suite 2210,
Montreal, Quebec
Canada H4E 1A8
Tel: (514) 278-8666
Fax: (514) 278-2666

toonboom.com

Disclaimer
The content of this manual is covered by a specific limited warranty and exclusions and limit of liability under the 
applicable License Agreement as supplemented by the special terms and conditions for Adobe®Flash® File Format 
(SWF). Please refer to the License Agreement and to those special terms and conditions for details.

The content of this manual is the property of Toon Boom Animation Inc. and is copyrighted. 

Any reproduction in whole or in part is strictly prohibited. 
For additional copies of this manual, please contact Toon Boom Animation Inc. at the Corporate Headquarters 
address.

Trademarks
Toon Boom® and Toon Boom Studio® are trademarks owned by Toon Boom Animation Inc. All other trademarks are 
the property of their respective owners. 

Credits
Technical Writer: Shabana Ali, Marie-Eve Chartrand, Pamela Grimaud, Annie Rodrigue, Anouk Whissell

Technical Editor: Peter Cawthorne, Christopher Diaz, Pamela Grimaud

Art Development: Marie-Eve Chartrand, Anouk Whissell, Shabana Ali, Tania Gray, Annie Rodrigue

Technical Reviewer: Lindsay Brown, John Payne, Natalia Solari

Publication Date
August 2012 

Copyright © 2012 by Toon Boom Animation Inc. All rights reserved.

Published by Toon Boom Animation Inc.

OUSG101TBS71EN



Contents

Chapter 1: Introduction .......................................................................................................................................... 11
Documentation ......................................................................................................................................................... 15

Toon Boom Studio - Resources ............................................................................................................................ 15
Workout Series ................................................................................................................................................. 15
Video Lessons ................................................................................................................................................... 15
Tutorials ............................................................................................................................................................ 15
Tips and Tricks .................................................................................................................................................. 16

Templates ............................................................................................................................................................. 16
Remember to Register Toon Boom Studio .......................................................................................................... 16
Get Help and Hone Your Skills! ............................................................................................................................ 17

Knowledge Base ............................................................................................................................................... 17
User Forum ....................................................................................................................................................... 17
Animation Glossary ........................................................................................................................................... 17

Chapter 2: Starting Your Project......................................................................................................................... 19
Launching Toon Boom Studio .................................................................................................................................. 20
Welcome Screen  ...................................................................................................................................................... 21
Creating and Opening a Project  .............................................................................................................................. 22

What are Frame Rate and Format?  ..................................................................................................................... 22
Selecting a Preset Format and Frame Rate  ......................................................................................................... 23
Creating and Opening Projects from the Welcome Screen  ................................................................................ 24

Creating a New Project from the Welcome Screen  ........................................................................................ 24
Opening a Project from the Welcome Screen  ................................................................................................ 25

Creating and Opening a Project from the File Menu  .......................................................................................... 25
Creating a New Project from the File Menu  ................................................................................................... 25
Opening a Project from the File Menu  ............................................................................................................ 25

Opening a Flip Boom Cartoon or Flip Boom All-Star Project  ............................................................................. 26
Opening an Animation-ish Project  ...................................................................................................................... 26

Changing Your Project’s Format  ............................................................................................................................. 27
Organizing Your Work  ............................................................................................................................................. 28

Naming Your Files  ................................................................................................................................................ 28
Saving Files and Structuring a Project  ................................................................................................................. 28

User Interface Language  .......................................................................................................................................... 30
Windows  .............................................................................................................................................................. 30
Mac OS® X  ........................................................................................................................................................... 30

Adding Template Copyright and User Name Information  ...................................................................................... 31
Setting the Location of Global Library  ..................................................................................................................... 32
Some Basic Animation Concepts  ............................................................................................................................. 33

Bitmap and Vector Graphics  ................................................................................................................................ 33
Bitmap Image Types  ........................................................................................................................................ 33
Vector Image Types  ......................................................................................................................................... 33
Advantages and Disadvantages of Bitmap and Vector Images  ...................................................................... 34

Palettes  ................................................................................................................................................................ 34
Advantages of Using a Colour Palette  ............................................................................................................ 34

Xsheet and Timeline ............................................................................................................................................. 35
Xsheet  .............................................................................................................................................................. 35
Timeline  ........................................................................................................................................................... 35
Xsheet and Timeline Usage  ............................................................................................................................. 36

Pegs  ..................................................................................................................................................................... 36
Multiplane Camera  .............................................................................................................................................. 37

Multiplane Usage  ............................................................................................................................................. 37
Planning Your Project  .............................................................................................................................................. 38

What is a Scene?  .................................................................................................................................................. 38
Planning Your Scenes  .......................................................................................................................................... 38

Creating Scenes in Toon Boom Studio Project  ............................................................................................... 39
1



Toon Boom Studio User Guide
Help Tools  ................................................................................................................................................................ 40
Toon Boom Studio 7.1 User Guide ...................................................................................................................... 40
Context Sensitive Help ......................................................................................................................................... 40

Preferences  .............................................................................................................................................................. 41
Preference Highlights ........................................................................................................................................... 41
Accessing the Preferences Panel  ......................................................................................................................... 41
Display  ................................................................................................................................................................. 41

Renderer  .......................................................................................................................................................... 42
Rendering Options  .......................................................................................................................................... 42
Tablet Support  ................................................................................................................................................. 43

What’s Next? ............................................................................................................................................................ 44

Chapter 3: Discovering the Interface................................................................................................................ 45
Interface Components  ............................................................................................................................................. 46

Menus  .................................................................................................................................................................. 47
Top Menu  ........................................................................................................................................................ 47
Quick Access Menu  ......................................................................................................................................... 47

Toolbars  ............................................................................................................................................................... 48
Views  .................................................................................................................................................................... 48

Interface Highlights  ................................................................................................................................................. 49
Camera View  ........................................................................................................................................................ 49

View Navigation Toolbar  ................................................................................................................................. 50
Switch View Toolbar  ........................................................................................................................................ 50

Drawing Tools Toolbar  ........................................................................................................................................ 51
Sceneplanning Tools Toolbar  .............................................................................................................................. 51
Timeline View  ...................................................................................................................................................... 52

Timeline View Toolbar ...................................................................................................................................... 52
Interactive Playback Toolbar and Play Menu ....................................................................................................... 53

Interactive Playback Toolbar ............................................................................................................................ 53
Play Menu  ........................................................................................................................................................ 53

Managing Views  ....................................................................................................................................................... 55
Adding a New View  ............................................................................................................................................. 55
Closing a View  ..................................................................................................................................................... 55
Undocking and Docking Windows and Views  ..................................................................................................... 56

Undocking  ....................................................................................................................................................... 56
Docking  ........................................................................................................................................................... 57
Moving the Floating Window Around the Desktop  ........................................................................................ 57

Swapping Views  ................................................................................................................................................... 57
Resizing a View  .................................................................................................................................................... 58
Showing and Hiding the Status Bar  ..................................................................................................................... 58
Extending the Side Panel  .................................................................................................................................... 58

Managing Toolbars  .................................................................................................................................................. 59
Showing or Hiding Toolbars  ................................................................................................................................ 59
Moving Toolbars  .................................................................................................................................................. 59
Customizing Toolbars on Mac OS X  .................................................................................................................... 59

Workspaces  .............................................................................................................................................................. 60
Loading a Workspace  .......................................................................................................................................... 60
Creating a Workspace  ......................................................................................................................................... 60
Renaming a Workspace  ....................................................................................................................................... 61
Saving a Workspace  ............................................................................................................................................ 61
Deleting a Workspace  ......................................................................................................................................... 61
Restoring the Default Workspaces  ...................................................................................................................... 61

Interface Navigation  ................................................................................................................................................ 62
Preferences  .............................................................................................................................................................. 63

Interface Preferences  ........................................................................................................................................... 63
Element Colours  .............................................................................................................................................. 63
Window Background Colours  .......................................................................................................................... 63
Workspace System  .......................................................................................................................................... 63
2 



Contents   
Show All Tips Again  ......................................................................................................................................... 63
Keyboard Shortcuts  ............................................................................................................................................. 64

What’s Next? ............................................................................................................................................................ 65

Chapter 4: Drawing and Design.......................................................................................................................... 67
Drawing Basics .......................................................................................................................................................... 68
Drawing in the Drawing or Camera View ................................................................................................................. 69

 Drawing View  ...................................................................................................................................................... 69
 Camera View ........................................................................................................................................................ 69

Drawing Using the Brush or Pencil Tool  .................................................................................................................. 70
 Brush Tool  ........................................................................................................................................................... 70
 Pencil Tool  .......................................................................................................................................................... 70
Converting Lines  .................................................................................................................................................. 71

Convert Lines to Brush  .................................................................................................................................... 71
Extract Centre Line - Converting a Brush shape to a Pencil line  ..................................................................... 71

Relative Sizes of Characters and Props  ................................................................................................................... 72
Sketching  ................................................................................................................................................................. 74
Tracing  ..................................................................................................................................................................... 76
Erasing Part of a Drawing  ........................................................................................................................................ 78
Selecting Drawing Objects  ...................................................................................................................................... 79

Repositioning a Pivot Point  ................................................................................................................................. 80
Pen View  .................................................................................................................................................................. 81

Setting Up the Brush and Eraser Tools ................................................................................................................. 81
Eraser and Brush Styles  ................................................................................................................................... 82

Setting Up the Pencil Tool .................................................................................................................................... 82
Setting Up the Shape Tools and Polyline Tool ..................................................................................................... 83

Changing the Thickness of a Centreline Object ............................................................................................... 83
Managing Pen Styles ............................................................................................................................................ 84

Adding a Pen Style ........................................................................................................................................... 84
Editing a Pen Style ............................................................................................................................................ 84
Removing a Pen Style ....................................................................................................................................... 84

Drawing Invisible Lines .............................................................................................................................................. 85
Working With Text  ................................................................................................................................................... 86

Creating Text ........................................................................................................................................................ 86
Formatting the Text .............................................................................................................................................. 87
Converting Text into Separate Objects  ............................................................................................................... 88

More Drawing Tools ................................................................................................................................................. 89
Shape Tools  ......................................................................................................................................................... 89
 Polyline Tool ........................................................................................................................................................ 90
 Contour Editor Tool ............................................................................................................................................. 91

Snap to Contour ............................................................................................................................................... 92
 Perspective Tool .................................................................................................................................................. 93
 Cutter Tool ........................................................................................................................................................... 94
 Scissor Tool .......................................................................................................................................................... 95

More Drawing Options ............................................................................................................................................. 96
Group and Ungroup ............................................................................................................................................. 96
Smooth .................................................................................................................................................................. 97
Flatten and Optimize ............................................................................................................................................ 97

Flatten ............................................................................................................................................................... 97
Optimize ........................................................................................................................................................... 98

Transform .............................................................................................................................................................. 99
Arrange ............................................................................................................................................................... 100
Show Current Drawing on Top ........................................................................................................................... 100

Preferences ............................................................................................................................................................. 101
Window Background Colours  ............................................................................................................................ 101
Light Table  ......................................................................................................................................................... 102

What’s Next? .......................................................................................................................................................... 103
3



Toon Boom Studio User Guide
Chapter 5: Adding Colours................................................................................................................................. 105
How to Paint  .......................................................................................................................................................... 106
Colours  ................................................................................................................................................................... 107

Adding a Colour Swatch  .................................................................................................................................... 108
Solid Colour Swatch ....................................................................................................................................... 108
Gradient Colour Swatch ................................................................................................................................. 113
Bitmap Texture Swatch  ................................................................................................................................. 117

Deleting a Colour Swatch ................................................................................................................................... 119
Colour Display Modes  ........................................................................................................................................... 120
Using the Painting Tools  ........................................................................................................................................ 121

Painting with the Paint Tool ............................................................................................................................... 122
Painting with the Paint Unpainted Tool ............................................................................................................. 123
Unpainting Areas with the Unpaint Tool ............................................................................................................ 124

Closing Gaps  .......................................................................................................................................................... 125
What is a Gap? ................................................................................................................................................... 125
Closing Holes with the Close Gap Tool ............................................................................................................. 125
Closing Holes using Automatic Close Gap  ....................................................................................................... 127

Selecting a Colour in a Drawing  ............................................................................................................................ 128
Editing Gradients and Textures  ............................................................................................................................. 129

Setting a Gradient or Texture with the Paint Tool ............................................................................................. 129
Palettes  .................................................................................................................................................................. 132

Creating a Colour Palette ................................................................................................................................... 133
Deleting a Colour Palette ................................................................................................................................... 134
Duplicating a Colour Palette .............................................................................................................................. 135
Creating a Palette Style  ..................................................................................................................................... 136
Assigning a Style  ............................................................................................................................................... 137
Deleting a Style .................................................................................................................................................. 137
Mixing the Colours  ............................................................................................................................................ 137
Exporting a Colour Palette ................................................................................................................................. 139
Importing a Colour Palette ................................................................................................................................. 139

What’s Next? .......................................................................................................................................................... 140

Chapter 6: Importing Artwork ........................................................................................................................... 141
Importing Bitmaps Images  .................................................................................................................................... 142

Importing Bitmaps Without Vectorizing  ............................................................................................................ 142
Adding Images to a Bitmap Layer .................................................................................................................. 143

Vectorization of an Image Element or Image Cell ............................................................................................. 144
Importing and Vectorizing Images  .................................................................................................................... 145

Import Images With Keying  ................................................................................................................................... 147
Importing Multi-layered PSD files  .......................................................................................................................... 150
Importing AI and PDF files  .................................................................................................................................... 152
Importing from Adobe Flash  ................................................................................................................................. 154
Importing a Movie  ................................................................................................................................................. 155

Importing a Bitmap Movie File ........................................................................................................................... 155
Importing a Movie in an Existing Image Layer ............................................................................................... 156

Scanning Images  .................................................................................................................................................... 157
Capture  .................................................................................................................................................................. 159
Library  .................................................................................................................................................................... 160

Understanding the Library Concept ................................................................................................................... 160
What is a Library? ........................................................................................................................................... 160
What is a Template? ....................................................................................................................................... 160

Library View  ....................................................................................................................................................... 161
Preview ........................................................................................................................................................... 161
Library List ...................................................................................................................................................... 162
Template List .................................................................................................................................................. 162

Structuring the Library  ....................................................................................................................................... 163
4 



Contents   
Creating a Library ........................................................................................................................................... 163
Opening and Closing a Library ....................................................................................................................... 164
Creating a Catalog  ........................................................................................................................................ 164
Renaming a Catalog ....................................................................................................................................... 165
Deleting a Catalog .......................................................................................................................................... 165
Refreshing the Library ..................................................................................................................................... 165
Reloading Default Templates ......................................................................................................................... 165
Saving the Library ........................................................................................................................................... 165

Templates  .......................................................................................................................................................... 165
Creating a Template  ...................................................................................................................................... 166
Deleting a Template ....................................................................................................................................... 167
Editing a Template  ........................................................................................................................................ 167
Template Properties  ...................................................................................................................................... 169
Importing Multimedia files into the Library view ............................................................................................ 169
Importing a Template in Your Scene .............................................................................................................. 170
Linking Templates to Media Elements ........................................................................................................... 170
Copying Selected Template Contents into Your Animation .......................................................................... 171
Using Paste Special to Update Content from a Template ............................................................................. 172

What’s Next? .......................................................................................................................................................... 173

Chapter 7: Layers and Timing ............................................................................................................................ 175
Understanding the Timeline and Exposure Sheet Views ........................................................................................ 176

Timeline View ...................................................................................................................................................... 176
Timeline View Toolbar .................................................................................................................................... 177
Layer Section .................................................................................................................................................. 178
Timing Section ................................................................................................................................................ 178

Exposure Sheet View  ......................................................................................................................................... 179
Main Section  .................................................................................................................................................. 179
Element List Section  ...................................................................................................................................... 180
Exposure Sheet Toolbar  ................................................................................................................................ 180
Column Header  ............................................................................................................................................. 180
Drawing  ......................................................................................................................................................... 180
Frame Numbers  ............................................................................................................................................. 181

Layers and Columns ................................................................................................................................................ 182
Layer Concepts  .................................................................................................................................................. 182
Layer Types  ........................................................................................................................................................ 183

 Drawing Element  .......................................................................................................................................... 183
 Image Element  .............................................................................................................................................. 183
 Camera Element  ........................................................................................................................................... 183
 Effect Element  .............................................................................................................................................. 183
 Peg Element  ................................................................................................................................................. 183
 Sound Element  ............................................................................................................................................. 184
Annotation Element  ....................................................................................................................................... 184
 Media Element  .............................................................................................................................................. 184

Adding New Elements  ....................................................................................................................................... 184
Adding Layers in the Timeline View  .............................................................................................................. 184
Adding an Element From the Top Menu  ...................................................................................................... 185
Adding New Columns in the Exposure Sheet View  ...................................................................................... 185

Deleting Elements .............................................................................................................................................. 186
Deleting a Layer From the Timeline View  ..................................................................................................... 186
Deleting Columns from the Exposure Sheet View  ........................................................................................ 186

Modifying Elements ............................................................................................................................................ 187
Ordering Elements  ........................................................................................................................................ 187
Show and Hide Elements  ............................................................................................................................... 188
Renaming an Element  .................................................................................................................................... 189
Exposure Sheet Thumbnails  .......................................................................................................................... 190
Changing the Colour of a Column or Layer  .................................................................................................. 190

Expanding and Collapsing Layers  ...................................................................................................................... 192
Modifying the Column Width  ............................................................................................................................ 192

Filling Exposure ...................................................................................................................................................... 193
Typing Exposure  ................................................................................................................................................ 193
Extending Exposure  ........................................................................................................................................... 194
5



Toon Boom Studio User Guide
Dragging Cells  ................................................................................................................................................... 195
Increasing and Decreasing Exposure ................................................................................................................. 196

Add Exposure  ................................................................................................................................................ 196
Remove Exposure  .......................................................................................................................................... 197

Deleting Exposure .............................................................................................................................................. 198
Inserting Blank Cells  .......................................................................................................................................... 198
Setting the Exposure  ......................................................................................................................................... 199
Filling a Selection with a Sequence .................................................................................................................... 200
Creating Cycles ................................................................................................................................................... 201

Navigating Between Frames and Columns ............................................................................................................ 204
Managing Drawings ................................................................................................................................................ 206

Renaming a Drawing .......................................................................................................................................... 206
Duplicating a Drawing ........................................................................................................................................ 206
Copying and Pasting Drawings .......................................................................................................................... 207

Preferences  ............................................................................................................................................................ 208
Time Measurement  ............................................................................................................................................ 208

What’s Next? .......................................................................................................................................................... 209

Chapter 8: Traditional Digital Animation ...................................................................................................... 211
Traditional Animation Tools ................................................................................................................................... 212

 Onion Skin ......................................................................................................................................................... 212
Auto Light Table  ................................................................................................................................................ 213
Static Light Table  ............................................................................................................................................... 214
Reposition All Drawings ..................................................................................................................................... 215
Lock Drawing  ..................................................................................................................................................... 217
Clear Drawing  .................................................................................................................................................... 217

Animating Traditionally ........................................................................................................................................... 218
Animating  .......................................................................................................................................................... 218
Cleaning Up  ....................................................................................................................................................... 220
Power Painting .................................................................................................................................................... 222
Setting the Timing .............................................................................................................................................. 223
Playing Back Your Animation ............................................................................................................................. 223

Rotoscoping  ........................................................................................................................................................... 224
What is Rotoscoping? ......................................................................................................................................... 224

Reasons for Rotoscoping ................................................................................................................................ 224
Selecting a Video  ............................................................................................................................................... 225

Importing a Video  .......................................................................................................................................... 225
Tracing the Character  ........................................................................................................................................ 226

Tracing ............................................................................................................................................................ 226
Fine Tuning the Animation  ............................................................................................................................ 226

Painting the Animation  ...................................................................................................................................... 227
Marking Corrections and Notes  ............................................................................................................................ 228

Annotation Elements  ......................................................................................................................................... 228
Working with Notes ............................................................................................................................................ 229

Layer Notes  ................................................................................................................................................... 229
Cell Notes  ...................................................................................................................................................... 229

Preferences ............................................................................................................................................................. 230
Onion Skin .......................................................................................................................................................... 230
Static Light Table ................................................................................................................................................ 230

What’s Next? .......................................................................................................................................................... 231

Chapter 9: Creating a Cut-out Puppet........................................................................................................... 233
About Building a Cut-out Puppet  .......................................................................................................................... 234
Choosing Your Character  ...................................................................................................................................... 235

Creating a New Project and Importing a Character ........................................................................................... 236
Creating a Colour Palette ................................................................................................................................... 236

Cutting the Character into Pieces  ......................................................................................................................... 237
How to Cut the Pieces  ....................................................................................................................................... 238
6 



Contents   
Cutting out your Pieces .................................................................................................................................. 238
Drawing your Pieces ....................................................................................................................................... 240

Attaching the Pieces ............................................................................................................................................... 242
Ordering Your Layers  ......................................................................................................................................... 242
Attaching the Layers  .......................................................................................................................................... 243
Adding a Master Peg  ......................................................................................................................................... 245
Setting the Pivots  ............................................................................................................................................... 247

Storing the Character in the Library ....................................................................................................................... 249
What’s Next? .......................................................................................................................................................... 250

Chapter 10: Bones .................................................................................................................................................. 251
About the Skeleton Effect  ..................................................................................................................................... 252

Bone Tools Toolbar  ........................................................................................................................................... 253
Setup Mode  ................................................................................................................................................... 253
Animation Mode  ............................................................................................................................................ 254

Choosing Your Character  ...................................................................................................................................... 256
Planning and Preparing Your Character  ............................................................................................................ 256

Adding the Skeleton ............................................................................................................................................... 258
Robo-Skeleton Templates .................................................................................................................................. 258

Choosing Your Robo-Skeleton Template from the Library ............................................................................ 258
Importing Your Robo-Skeleton into Your Scene ............................................................................................ 260
Adding Your Own Character to the Robo-Skeleton Template ...................................................................... 261

Building the Skeleton .......................................................................................................................................... 265
Adding Bones  ................................................................................................................................................ 266
Setting Up the Bones  .................................................................................................................................... 269
 Setting the Influence Area  ............................................................................................................................ 272
Parenting Bone Chains  .................................................................................................................................. 275
Unparenting Bone Chains ............................................................................................................................... 277

Animating the Skeleton  ......................................................................................................................................... 278
Reassembling the Character  .............................................................................................................................. 278
Ordering Limbs  .................................................................................................................................................. 280

Character on a Single Drawing Layer  ............................................................................................................ 280
Character with Limbs on Different Drawing Layers  ....................................................................................... 280

Hiding Bones  ..................................................................................................................................................... 281
Animating Bones  ................................................................................................................................................ 282

Onion Skin Toolbar  ........................................................................................................................................ 284
Blocking the Body’s Position  ......................................................................................................................... 284
Deleting Keyframes  ....................................................................................................................................... 285
Removing All Keyframes ................................................................................................................................. 285

Adjusting the Velocity and Functions  ................................................................................................................ 285
Disabling a Bone Animation  .............................................................................................................................. 286

Skeleton Effect Properties  ..................................................................................................................................... 287
Preferences  ............................................................................................................................................................ 289
What’s Next? .......................................................................................................................................................... 290

Chapter 11: Animating a Puppet...................................................................................................................... 291
Getting the Character From the Library  ................................................................................................................ 292

Extending the Exposure ................................................................................................................................. 293
Extending the Children’s Exposure ................................................................................................................ 293

Understanding Keyframes and Drawings ............................................................................................................... 294
Keyframes and Drawing Blocks  ......................................................................................................................... 294

Creating a Simple Cut-out Animation .................................................................................................................... 295
Animating the Parts ............................................................................................................................................ 295

Blocking the Body’s Position  ......................................................................................................................... 296
Deleting Keyframes  ....................................................................................................................................... 296
Copying and Pasting Keyframes  .................................................................................................................... 297

Constant and Non-Constant Segments  ............................................................................................................. 298
Non-Constant Segment .................................................................................................................................. 298
Constant Segment .......................................................................................................................................... 299
7



Toon Boom Studio User Guide
Navigating Inside a Hierarchy ............................................................................................................................. 299
Selecting a Parent or Child Element .............................................................................................................. 299
Selecting Brother Elements ............................................................................................................................ 301

Using the Different Sceneplanning Tools  .......................................................................................................... 302
Using the Transform Tool  .............................................................................................................................. 302
Using the Motion Tool  ................................................................................................................................... 303
Using the Rotate Tool  .................................................................................................................................... 303
Using the Skew Tool  ...................................................................................................................................... 304
Using the Scale Tool  ...................................................................................................................................... 305
Using the Select Tool  .................................................................................................................................... 305

Adjusting the Velocity  ....................................................................................................................................... 306
Using the Onion Skin in Cut-out Animation  ...................................................................................................... 309
Swapping Images  .............................................................................................................................................. 310

Preferences ............................................................................................................................................................. 311
Sceneplanning Tab Preferences  ........................................................................................................................ 311

Create Linear Spline  ...................................................................................................................................... 311
Create Constant Keyframes  .......................................................................................................................... 311

What’s Next? .......................................................................................................................................................... 312

Chapter 12: Sound and Lip-sync....................................................................................................................... 313
Importing a Sound File  .......................................................................................................................................... 314
Sound Display  ........................................................................................................................................................ 315

Sound Display - Exposure Sheet View  ............................................................................................................... 315
Sound Name  .................................................................................................................................................. 315
Waveform  ...................................................................................................................................................... 315
Lip-sync Mouth Shapes - Name  ..................................................................................................................... 315
Lip-sync Mouth - Thumbnails  ........................................................................................................................ 316

Sound Display - Timeline View  .......................................................................................................................... 316
Sound Playback  ...................................................................................................................................................... 317

Playing the Sound and the Animation  ............................................................................................................... 317
Playing Only the Sound ...................................................................................................................................... 317

Sound Scrubbing in the Timeline View  .................................................................................................................. 317
Editing a Sound File  ............................................................................................................................................... 318

Changing the Start or End Frame of a Sound  ................................................................................................... 319
Trimming a Sound File  ....................................................................................................................................... 321
Looping a Sound  ............................................................................................................................................... 322
Mixing the Sound Volume  ................................................................................................................................. 323
Custom Playback Range  .................................................................................................................................... 324
Changing from Event to Streamed Sounds  ....................................................................................................... 325
Sound Scrubbing in the Sound Element Editor  ................................................................................................ 326
Deleting a Sound  ............................................................................................................................................... 327

Adding an Empty Sound Layer  .............................................................................................................................. 328
Lip-sync  .................................................................................................................................................................. 329

Creating a Mouth Chart  .................................................................................................................................... 330
Automatic Lip-sync Detection  ........................................................................................................................... 331
Modifying the Lip-sync Detection  ..................................................................................................................... 332

Modifying the lip-sync from the Exposure Sheet view  .................................................................................. 332
Modifying the lip-sync from the Sound Element Editor  ................................................................................ 332

What’s Next? .......................................................................................................................................................... 333

Chapter 13: Stop-motion Animation............................................................................................................... 335
Characters and Stage ............................................................................................................................................. 336

Gathering Your Characters  ................................................................................................................................ 336
Setting Up Your Background  ............................................................................................................................. 336

Image Capture Settings  ......................................................................................................................................... 337
Setting-Up the Image Capture Options  ............................................................................................................ 337
Light Table and Onion Skin  ............................................................................................................................... 339
Capture Features  ............................................................................................................................................... 340
8 



Contents   
Auto Capture .................................................................................................................................................. 340
Preview Window  ............................................................................................................................................ 340

Colour Keying  ........................................................................................................................................................ 341
Image Capture  ....................................................................................................................................................... 343

Capturing Images in an Existing Layer ............................................................................................................... 344
Vectorization and Clean-Up  ................................................................................................................................... 344
What’s Next? .......................................................................................................................................................... 345

Chapter 14: Scene Setup ..................................................................................................................................... 347
Importing the Scene Elements  .............................................................................................................................. 348

Background, Sound or Movie ............................................................................................................................. 348
Show Scene Background Colour .................................................................................................................... 348

Templates ........................................................................................................................................................... 348
Ordering the Element Layers  ................................................................................................................................. 349

Ordering Layer in the Timeline View .................................................................................................................. 349
Ordering Layers Using the Arrange Command .................................................................................................. 350
Ordering Layer Types ......................................................................................................................................... 350

Positioning the Scene Elements  ............................................................................................................................ 351
Positioning the Elements Using the Select Tool ................................................................................................. 351
Position the Elements Using the Properties View .............................................................................................. 352
Flipping Elements  .............................................................................................................................................. 353
Show Outline Selection  ..................................................................................................................................... 353
Locking Elements  ............................................................................................................................................... 353

Locking and Unlocking a Layer ....................................................................................................................... 353
Locking and Unlocking All Layers ................................................................................................................... 354
Locking All Other Layers ................................................................................................................................. 354

Cloning and Duplicating Elements  ........................................................................................................................ 355
Cloning Layers  ................................................................................................................................................... 355
Duplicating Layers  ............................................................................................................................................. 356

Setting the Camera Frame ...................................................................................................................................... 358
Adding a Camera Layer  ..................................................................................................................................... 358
Choosing the Active Camera Layer  ................................................................................................................... 359
Setting the Camera Frame Position  ................................................................................................................... 359

Setting the Frame Using the Select Tool ........................................................................................................ 359
Setting the Frame Using the Properties View ................................................................................................ 361

Creating a Multiplane ............................................................................................................................................. 362
Distributing the Elements on the Z-axis ............................................................................................................. 362

Top and Side Views ........................................................................................................................................ 362
Camera View ................................................................................................................................................... 364
Properties View ............................................................................................................................................... 365

Creating a Motion Path  ......................................................................................................................................... 366
Pegs .................................................................................................................................................................... 366

Adding a Peg .................................................................................................................................................. 366
Adding a Parent Peg ...................................................................................................................................... 367
Parenting Elements to a Peg .......................................................................................................................... 367
Expanding and Collapsing Layers .................................................................................................................. 368
Peg Only Mode .............................................................................................................................................. 368
Peg Toolbar .................................................................................................................................................... 369

Motion Path ........................................................................................................................................................ 370
Creating a Basic Motion Path ......................................................................................................................... 370
Displaying and Hiding a Motion Path ............................................................................................................. 371
Adding and Controlling Motion Points .......................................................................................................... 372
Switching Between Keyframe and Control Point ........................................................................................... 375
Adjusting the Tension, Bias and Continuity ................................................................................................... 375
Previous and Next Control Point .................................................................................................................... 377
Orient to Path ................................................................................................................................................. 377
Constant Z ...................................................................................................................................................... 378
Snap Last Keyframe ........................................................................................................................................ 378

Animating the Camera ............................................................................................................................................ 379
9



Toon Boom Studio User Guide
Adding a Peg to Your Camera ........................................................................................................................... 379
Making a Basic Camera Move ............................................................................................................................ 379

Function Editor View .............................................................................................................................................. 381
Function Editor View - Overview ........................................................................................................................ 381
Adjusting the Velocity ........................................................................................................................................ 383
Adding and Deleting Motion Points in the Function Editor View ...................................................................... 385

Adding Motion Points .................................................................................................................................... 385
Delete Motion Points ..................................................................................................................................... 386

Changing the Values of a Motion Point ............................................................................................................. 387
Other Options ......................................................................................................................................................... 389

Attach to Next Object ........................................................................................................................................ 389
Detach from Parent ............................................................................................................................................ 389
Change Start Frame ........................................................................................................................................... 390
Change Duration ................................................................................................................................................ 390
Change Loops ..................................................................................................................................................... 391
Element Notes .................................................................................................................................................... 392
Show Timeline Selection ..................................................................................................................................... 393
Paste Special ....................................................................................................................................................... 394

Paste Special Again ........................................................................................................................................ 395
Preferences ............................................................................................................................................................. 396

Sceneplanning Preferences ................................................................................................................................ 396
Motion Points ................................................................................................................................................. 396
Coordinate Units ............................................................................................................................................ 396
Camera View ................................................................................................................................................... 397
Pegs ................................................................................................................................................................ 398
Timeline .......................................................................................................................................................... 398

What’s Next? .......................................................................................................................................................... 399

Chapter 15:      Enhancing With Effects......................................................................................................... 401
Special Effects ......................................................................................................................................................... 402

Clipping Effect  ................................................................................................................................................... 403
Feather Edge Effect  ........................................................................................................................................... 408
Drop Shadow Effect  .......................................................................................................................................... 410
Colour Transform Effect  .................................................................................................................................... 415
Blur Effect ........................................................................................................................................................... 420
Shake Effect ........................................................................................................................................................ 424

Forces of Nature Effects ......................................................................................................................................... 427
Customizing Your Forces of Nature Effect ......................................................................................................... 428
Moving an Effect in the Camera View ................................................................................................................ 431
Rain Effect ........................................................................................................................................................... 432
Snow Effect ......................................................................................................................................................... 433
Hail Effect ........................................................................................................................................................... 434
Fog Effect ........................................................................................................................................................... 435
Cloud Effect ........................................................................................................................................................ 436
Volcano Effect ..................................................................................................................................................... 437

Disabling All Effects ................................................................................................................................................ 438
What’s Next? .......................................................................................................................................................... 439

Chapter 16: Exporting Your Project................................................................................................................ 441
Export Drawing to PDF ........................................................................................................................................... 442
Export Movie .......................................................................................................................................................... 443
Export to YouTube and Facebook ......................................................................................................................... 445

Exporting to YouTube ........................................................................................................................................ 445
Exporting to Facebook ....................................................................................................................................... 447

Export Snapshot ..................................................................................................................................................... 450
Print ......................................................................................................................................................................... 451
10 



Chapter 1: Introduction   
Chapter 1  Introduction
Toon Boom Studio is a multi-technique, vector-based software that is suitable for all your animation projects, be they 
clean and classic, to futuristic and cutting-edge. It possesses leading edge features based on industry proven 
technology, making it the most dynamic and exciting software on the market. Further, between the step-by-step 
instruction contained in this guide, the software’s user-friendly interface and a handful of helpful online resources, 
you’ll find that Toon Boom Studio is also ideal for simply learning how to animate.

Toon Boom Studio allows you to produce at least six different styles of animation:

• Traditional Animation
• Traditional Digital Animation, also known as Tradigital Animation
• Cut-out Animation
• Bone Animation
• Stop-motion Animation
• Rotoscoping 

The following chapters will give a greater insight into how Toon Boom Studio works and what you can do to produce 
some great animation:

• Starting Your Project, on page 19
• Discovering the Interface, on page 45
• Drawing and Design, on page 67
• Adding Colours, on page 105
• Importing Artwork, on page 141
• Layers and Timing, on page 175
• Traditional Digital Animation, on page 211
• Creating a Cut-out Puppet, on page 233
• Bones, on page 251
• Animating a Puppet, on page 291
• Sound and Lip-sync, on page 313
• Stop-motion Animation, on page 335
• Scene Setup, on page 347
• Enhancing With Effects, on page 401
• Exporting Your Project, on page 441
11
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Animation Techniques in a Nutshell
With Studio you can still animate traditionally, much the way animators have done for decades by simply putting pen 
to paper. Traditional animation methods can be used with Toon Boom Studio, from drawing your rough animation (the 
underlying structure of your animation), to cleaning it up, tracing solid and clean lines over the rough to achieve closed 
zones, and last, but not least, inking it.

For example, to animate a walk-cycle, you will begin with the torso movements and the legs. Head, arms and clothes 
are added later, during the secondary phase.

You can also work in a traditional fashion, but animate digitally. Traditional digital animation, also known as hand-
drawn or tradigital animation, is the process of drawing every frame of an animation directly in Toon Boom Studio 
without the use of paper or scanner.

With Toon Boom Studio’s extensive set of tools, you are able to create animated puppets from your drawings or 
photographs. This technique is known as cut-out animation because of the way you move cut-out pieces around 
instead of drawing.
12 
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The Toon Boom Studio cut-out puppet principle is very similar to cutting up a character drawn on a sheet of paper 
and assembling the pieces using little brass fasteners. You create a drawing for each of your character's body parts 
and then attach them in the Timeline view. Next, you can articulate the character and animate it by giving it a slightly 
different pose on each frame.

Toon Boom Studio has stop-motion animation capabilities, and its intuitive and easy to use image capture window 
allows you to set-up and capture all your images. Stop-motion animation has been around since animators first 
realized that all it took to produce the illusion of motion was to nudge a clay figure, puppet or object and then 
document it in a series of snapshots. In this digital age, the process has only become simpler and more fun, as it is 
now possible to mix stop-motion animation with numerous other animation techniques. It is as easy as plugging in 
your recording device, be it a digital camera, video camera or webcam, followed by adjusting the focus in the 
software, keying out the background and taking the snapshots. In short: endless possibilities. 

Toon Boom Studio also has  rotoscoping capabilities for those of you who want to experiment or produce realistic 
movement in your characters.

This technique requires the animator to trace over each frame of a live-action movie, a process that results in some 
very realistic movement. This rotoscoping technique was invented by the animation pioneer Max Fleischer in 1915 
and involved projecting a movie frame-by-frame onto a optically correct glass surface. The animator would then trace 
over the character projected on the glass to produce a cel. The equipment used in this process is called a Rotoscope, 
an ingenious invention that has now been replaced by the computer. Toon Boom Studio’s rotoscoping capabilities 
allows you to import a video clip and trace over it directly in the software.

Mastering the fundamentals of animation is not only important in and of itself, it also affords you the necessary 
foundation from which you can grow to master both the nuances and ever-evolving techniques of this dynamic art 
form. This is the beauty of Toon Boom Studio; within it are the tools required to create, experiment with and finally 
master your technique, along with some exciting bells and whistles. Nothing beats seeing your first animated 
character spring to life, even if it lasts but a few seconds. But there are also thrills to be had in taking things further; 
applying sophisticated colour-schemes to your scene or overall project, for example, or by incorporating sound effects 
and dialogue into your narrative. With the introduction of its new and improved Bone tools, Toon Boom has expanded 
upon, yet simplified, the unlimited options inherent in an animated character. Unlimited options leading to endless 
story possibilities, that is!
13
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Toon Boom has also taken the ability to enhance your work to a whole new level by introducing effects based on the 
natural world, from volcanic eruptions, to earth quakes, rain showers, hail, snow and fog. Blurring the edges of a 
candle can add a little extra atmosphere to a dimly-lit room, while casting a very long shadow may serve to add a note 
of realism or mood to an out-of-doors encounter. Master the basics, indeed, but how wonderful that when even in 
mastering the basics, the sky is the limit!
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Documentation
In addition to this user guide, there are other useful documents at your disposal. Learn how to get the most out of 
Toon Boom Studio with our easy-to-use documentation package:

• Integrated Help
In Toon Boom Studio, select Help > Toon Boom Studio Help to open the help system in your default 
browser.

• Tooltips
To view a short description of a menu command or toolbar button, known as a tooltip, simply hover over a 
button with your mouse.

• Context-Sensitive Help
To view a brief, but somewhat more detailed description of a menu command or toolbar button, select 
Help > What’s This and then click on the item. A pop-up window opens, displaying pertinent information 
regarding the item you clicked on.

Toon Boom Studio - Resources
Toon Boom’s Resources tools, available at toonboom.com/home-users/toon-boom-studio/resources., will help 
you to broaden your Toon Boom Studio and general animating skills. Choose from basic to advanced tools to take 
your animation know-how to the next level. You can also open the Resources page from Toon Boom Studio:

Select Help > Toon Boom on the Web to open the Toon Boom website in your default Web browser. Select Home 
Users > Toon Boom Studio > Resources.

Workout Series

The Toon Boom Animation Workout Series is a dedicated program of exercises designed to help you develop the skills 
and techniques necessary to get the most out of Toon Boom Studio. Sharpen your skills while raising your endorphins!

Video Lessons

Toon Boom Studio Training Videos are the perfect way to gain first-hand instruction on how to use the software.

Tutorials

Video and print tutorials will get you started and introduce you to the application one step at a time.
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Tips and Tricks

From bitmaps to going bananas (with rotoscoping), from model sheets to motion points, visit the Tips and Tricks 
resource section on the Toon Boom Animation website for nifty pointers on how to get the most - and the most fun - 
from your animation projects.

Templates

Use the ready-made templates to create an animation quickly and easily, while learning how to draw and animate in 
the Cut-out style!

A wide variety of character and prop collections are available in our online store.

Remember to Register Toon Boom Studio
Register now! Become a member of the Toon Boom community!

As a registered member you can:

• Easily recover your activation key 24/7
• Reinstall your product anytime, anywhere
• Get info on software updates and upgrades
• Subscribe to exclusive announcements
16 
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Get Help and Hone Your Skills!

Knowledge Base
Find answers to your Toon Boom Studio questions in the Knowledge Base, located on our website at: 
http://www.toonboom.com/support/kb/categories/Toon-Boom-Studio.

User Forum
Registered Toon Boom Studio members can access and post questions, queries and comments on the User Forum. 
Share your thoughts and learn what others in the Toon Boom community are up to, or simply view the Forum content 
as a guest.

Animation Glossary
A comprehensive glossary of terms is available on the Toon Boom website. Access it through the Knowledge Base at:

http://www.toonboom.com/support/kb/glossary.php
17
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Chapter 2  Starting Your Project
Toon Boom Studio is a great tool for learning animation with, it is both easy to use and powerful, just what you need 
when you are starting out! Using Studio, you can easily create a project and see it through to the finished output.

In this chapter, you will learn the following:

• Launching Toon Boom Studio, on page 20
• Welcome Screen, on page 21
• Creating and Opening a Project, on page 22
• Changing Your Project’s Format, on page 27
• Organizing Your Work, on page 28
• Adding Template Copyright and User Name Information, on page 31
• Setting the Location of Global Library, on page 32
• Some Basic Animation Concepts, on page 33
• Planning Your Project, on page 38
• Help Tools, on page 40
• Preferences, on page 41
• What’s Next?, on page 44
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Launching Toon Boom Studio
To use Toon Boom Studio you have to start it, this is called launching the application. It’s easy to do, just follow the 
steps below. And remember, you can use Toon Boom Studio on Mac OS X or Windows operating systems.

To launch Toon Boom Studio, do one of the following:

 Mac OS X: Double-click on the Toon Boom Studio  icon or select
Applications > Toon Boom Studio 7.1

 Windows: Double-click on the Toon Boom Studio 
  icon or select

Start > Programs > Toon Boom Studio 7.1 > Toon Boom Studio 7.1 . 

 Windows Vista: Double-click on the Toon Boom Studio  icon or select
Start > All Programs > Toon Boom Animation > Toon Boom Studio 7.1 >Toon Boom Studio 7.1 

Toon Boom Studio opens, displaying the Welcome Screen.
20 
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Welcome Screen 
When Toon Boom Studio launches, the Welcome Screen appears. This screen is also accessible once you are inside a 
project. To display the Welcome Screen from within the application you need to close the current project by selecting 
File > Close. You can also use the default keyboard shortcut [Ctrl]+[W] (Windows) or []+[W]. 

NOTE: This command closes the scene which is currently open.

The Welcome Screen allows you to:

• Create new projects
• Select the format, frame rate and camera size of your project
• Access the User Guide
• Work on a sample project
• View your Toon Boom Studio account
• Access the Learn Toon Boom Studio area
• View the Showcase and User Stories area
• Access Support
21



Toon Boom Studio User Guide
Creating and Opening a Project 
As you start your project in Toon Boom Studio, you need to understand about the format and the frame rate you will use. -

• What are Frame Rate and Format?, on page 22
• Selecting a Preset Format and Frame Rate, on page 23
• Creating a New Project from the Welcome Screen, on page 24
• Creating a New Project from the File Menu, on page 25

What are Frame Rate and Format? 
When you create an animation the images you animate must move fluidly to produce the correct effect. If 
they don’t you will have a jumpy animation which won’t look good. To get a fluid movement between the 

drawings you need several images per second. You need a minimum of 12 images per second, any slower than that 
and the animation becomes jumpy. An image can also be called a frame. So the Frame Rate is the number of frames 
you play per second in your animation.

Next, we will talk about the format of your project.

The format of your project is the size of your camera frame in pixels. 

Ok, so what is a pixel? You may not be familiar with this term, but you have probably seen it when you magnify a digital 
photograph. A pixel is the smallest element of an image displayed on a monitor or TV screen. “Pixel”, short for Picture 
Element, is a single point in a graphic image. It is a small sample of an image, a dot, a square or a very small section 
made out of smooth filtering. If you zoom-in close enough on a digital image, you will see the pixels, they look like 
small squares of different colours and intensity.

Depending on the type of project you want to do, you will need a different image size. For example, if you want to 
put your project on the web, you will probably export your movie as a small size so that it is light to playback once on 
the web. The larger the images are, the heavier the project is, but also, the better the quality is. If you want to export 
your project for the theatre, you will need to create your project using a large format so that the image is of a high 
quality and looks good on the big screen.

Also, some display media such as iPod, TV or theatre have an exact 
format requirement. For example, the standard TV format has a 4:3 size 
ratio, meaning that the width of your scene has to be an equivalent of 
4 units compared to 3 units for the height. You can find most of them 
in the presets list provided in the Welcome Screen.

So, just to recap the Format is the size of your camera frame in pixels 
and matches the width and height required for the medium you want 
to show your final movie in.

720 px

540 p
x

North American TV Format
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Selecting a Preset Format and Frame Rate 
Preset formats are available within Toon Boom Studio and are listed by name when creating a new animation 
project.This table shows the animation properties which are available using Toon Boom Studio. You can also set the 
properties manually. 

FORMAT CAMERA SIZE (pixels) REAL FRAME SIZE (pixels) FRAME RATE (fps) PREFERRED OUTPUT
Web Use
Small Web Animation 160 x 120 160 x 120 12 QuickTime or Flash

Medium Web Animation 320 x 240 320 x 240 12 QuickTime or Flash

Large Web Animation 480 x 360 480 x 360 12 QuickTime or Flash

iPod and PodCasting 320 x 240 320 x 240 12 QuickTime or Flash

Windows Mobile Full 
Screen

240 x 320 240 x 320 12 Flash

Windows Mobile Browser 240 x 268 240 x 268 12 Flash

PC Video
VGA 640 x 480 640 x 480 24 QuickTime or Flash

SGA 800 x 600 800 x 600 24 QuickTime or Flash

XVGA 1024 x 768 1024 x 768 24 QuickTime or Flash

SXGA 1280 x 1024 1280 x 1024 24 QuickTime or Flash

UXGA 1600 x 1200 1600 x 1200 24 QuickTime or Flash

DVD and Broadcasting (note the difference between the camera size and the size of the frame shown on screen).
DV NTSC 720 x 540 720 x 480 29.97 DV/DVCPRO NTSC

DV NTSC Anamorphic 853 x 480 720 x 480 29.97 DV/DVCPRO NTSC

DV PAL 768 x 576 720 x 576 25 DV/DVCPRO PAL

DV PAL Anamorphic 1024 x 576 720 x 576 25 DV/DVCPRO PAL

HDTV monitors:
HDTV 720 24p 1280 x 720 1280 x 720  24 QuickTime h.264

HDTV 1080 24p 1920 x 1080 1280 x 720 24 QuickTime h.264

HDTV 1080 25p 1920 x 1080 1280 x 720 25 QuickTime h.264

Film
2K Film 4:3 2048 x 1536 24

Custom
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Creating and Opening Projects from the Welcome Screen 
Using the Welcome Screen, you can create new projects and open existing ones.

Creating a New Project from the Welcome Screen 
To create a project from the Welcome Screen:

1. In the Name field, type the name for your new project. Make sure to give it a name which easily identifies the 
project, such as JumpingFrog. That way when you have several projects you can locate specific ones more easily. 

2. In the Format drop-down menu, select the format in which you want to produce your project. 

You can choose from a wide variety of presets such as Web, iPod and DV. By default, the option selected is Most 
Recent. This means that it will use the last settings you chose when creating your last project. 

When you create a project for the first time, it will use the settings marked in the Frame Rate and Camera Size 
field. By selecting any of the presets, the Frame Rate and Camera Size fields will be automatically populated 
with the corresponding values.

3. If you prefer to use your own settings, you can type the Frame Rate and the Camera Size directly in the fields.

 
4. Once the information is in place, click on the Create button to make your project.

The new project opens.

Now that you have created a new project, the next step is to save it to the correct location. 

It is a good idea to follow a structure when saving your work so that your files are not scattered all over your computer.

 Refer to the Organizing Your Work topic to learn more about structuring your files.

To save your project for the first time:

1. Select File > Save As. The default keyboard shortcut is [Ctrl]+[Shift]+[S] (Windows) or []+[Shift]+[S] (Mac OS X).

The Save As dialog box opens.
2. In the Save As window, browse to the location where you want to save your project. If need be, rename it in the 

File Name field. Remember to give the project a name you can identify easily.
3. Click on the Save button to complete the operation.
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Opening a Project from the Welcome Screen 
When you already have a project you may find that you want to reopen it to work on it some more or to make some 
adjustments. You can do that by using the Welcome Screen.

To open a project from the Welcome Screen:

1. In the Open Recent section, click on the Browse option.

The Open window appears.
2. Browse and select the file for the project you want to open.

  *.tbp (Toon Boom Project) (Windows) 
OR 
 *.tbpd (Toon Boom Studio Document) (Mac OS® X)

NOTE: This is why it is important to give each project a name you can identify it by. If you have several projects 
called project1.tbp, project2.tbp and project3.tbp it would be difficult to remember what was in each. 

3. Click on the Open button to open the project.

If your project is already open and you want to work on a specific scene in that project you can also do that from the 
Welcome Screen.

To open a recent project from the Welcome Screen:

1. In the Open Recent section, select a project from the list.

2. Click on the project name to open the project.

Creating and Opening a Project from the File Menu 
If a project is already open and you want to create a new one, you can use the File menu. 

Creating a New Project from the File Menu 
To create a project from the File menu:

1. Select File > New. You can also click on the New  button in the Main toolbar or use the default keyboard 
shortcut [Ctrl]+[N] (Windows) or []+[N] (Mac OS X).

The new project is created from the currently open project’s settings.

Opening a Project from the File Menu 
To open a project from the File menu:

1. Select File > Open. You can also click on the Open  button in the Main toolbar or use the default keyboard 
shortcut [Ctrl]+[O] (Windows) or []+[O] (Mac OS X). 

The Open Project browser opens.
2. Browse and select the  *.tbp (Toon Boom Project) file you want to open.
3. Click on the Open button to open the project.

To open a recent project from the File menu:

1. Select File > Open Recent.
2. In the Open Recent drop-down menu, select the project you want to open.
3. Click on the project name to open the project.
 Select the Clear Menu command to remove all projects from the Open Recent list. 
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Opening a Flip Boom Cartoon or Flip Boom All-Star Project 
It is possible to open a Flip Boom (*.fbp) or Flip Boom All-Star (*.fba) project in Toon Boom Studio.

If you have another project open, you will be prompted to save it, and it will close after you confirm your choice.

To open an existing Flip Boom Cartoon or Flip Boom All-Star Project:

1. Launch Toon Boom Studio to display the Welcome Screen.
2. Click on the Browse button to open the Open window.

The Open dialog box appears.
3. In the Files of Type field, select Flip Boom Documents from the drop-down list.
4. Browse to the folder where your project is located.
5. Select the file with the FBP format.
6. Click on the Open button to open it.

The project opens in the Toon Boom Studio window.

Opening an Animation-ish Project 
It is possible to open an Animation-ish (.ish1, .ish2, .ish3) project in Toon Boom Studio.

If you have another project open, you will be prompted to save it, and it will close after you confirm your choice.

To Open an existing Animation-ish Project:

1. Launch Toon Boom Studio to display the Welcome Screen.
2. Click on the Browse button to open the Open window.

The Open dialog box appears.
3. In the Files of Type field, select Animation-ish Documents from the drop-down list.
4. Browse to the folder where your project is located.
5. Select the file with the ISH1, ISH2 or ISH3 format.
6. Click on the Open button to open it.

The project opens in the Toon Boom Studio window.
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Changing Your Project’s Format 
You can change your project’s format or frame rate from the file menu. 

NOTE: When you change the format of your project, if the size ratio is not the same, you may have to reposition some 
elements.

For example, if you change from a square format to a rectangular format, you will need to fill the sides of the screen.

To change your project’s format:

1. Select File > Animation Properties.

The Animation Properties dialog box opens.

2. In the Frame Rate field, type the new frame rate for your project.
3. In the Camera Size field, type the new format for your project.
4. If you want this format to be used each time you create a new project, click on the Set As Default button.
5. Click on the OK button to complete the operation.
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Organizing Your Work 
In order to start your project on the right track, it is a good idea to organize your files and directories properly.

In this section you will learn tips which will help you organize your work:

• Naming Your Files, on page 28
• Saving Files and Structuring a Project, on page 28

Naming Your Files 
In order for you to make it easier to remember what each project, layer, drawing or colour palette is, name your file 
with a relevant name representing the content of your project.

Make sure to give it a name which easily identifies the project, such as JumpingFrog. That way when you have several 
projects you can locate specific ones more easily. 

We recommend that you name your scene using alphanumeric characters: a to z, 0 to 9 and underscore ( _ ). Avoid 
spaces in the file names. Try to provide the maximum amount of information for future identification, which helps 
ensure that you do not mix up elements and lose information.

Here are some typical examples of project names:

• AdventureProject
• TurtleAdventure_Episode001
• Turtle_PuppetConstruction

Saving Files and Structuring a Project 
When you create your project, you must save it somewhere. It is a good idea to create a folder on your hard drive to 
contain all the elements of your project. Keeping everything together in one place is always useful for retrieving 
scenes, sounds, artwork or reference material.

There are many ways to structure your project folder, but here is an example you could use to start.

Before you save any elements in your production, you should decide on a project name, which should reflect the 
content or title. Use the name to create your main folder on your local hard drive, where you will save all of your 
production elements.

For example, the main directory could be called SuperTurtleAdventure_Project.

Once your main folder is created, you should create a sub folder to contain the different categories of material you 
will store in it. For example, you could have categories such as: 

• Studio Project
In this folder, you can store the actual Toon Boom Studio projects.

• Design
In this folder, you can store designs or any development drawings you have done for your project either on 
paper or in another software. You can scan your drawings and store them here.
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• Background
If you drew some backgrounds and painted them in a third party software or took some photographs to use 
as backgrounds in your scene, store them here.

• Reference Material
To get inspiration for your project or to design your characters, you can search the internet to find pictures 
related to your project and store them here. You could also take photos with a camera and store them in 
this folder.

• Audio Files
Store any music or dialogue tracks you will use in your movie, in this folder.

• Export
Once a scene or your project is ready, you will export it into a movie format or image sequence. You can 
store all your exported material in this folder.

• Colour Palette Backup
When you create characters and background, you will create a colour palette for each one of them. It is a 
good idea to export them from your project and store them in this folder as a backup in case you modify 
the colours by accident.
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User Interface Language 
Toon Boom Studio’s user interface is available in both English and Français. You can toggle between both languages 
at any time.

Windows 
To change the user interface language using Windows:

1. In the top menu, select Edit > Preferences (Windows).

The Preferences panel opens.

2. Go to the General tab.
3. In the Language drop-down menu, select either English or Français.
4. Click on the OK button.
5. Close the Toon Boom Studio application and restart it for the modification to take effect.

Mac OS® X 
To change the software’s language when using Mac OS® X, you need to change your operating system’s language 
preferences.

You can open the System Preferences option by selecting System Preferences from the Apple menu.

 Refer to the Mac OS® X’s documentation to learn how to setup your applications language preferences list. In 
this list, you need to make sure Français is a higher priority than English.

If Toon Boom Studio was already launched when you made the changes, you need to restart it in order for the new 
language settings to take effect.
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Adding Template Copyright and User Name Information 
Toon Boom Studio allows you to set author and copyright information for the templates. A template is an asset that 
you can share are reuse. It can be anything from a drawing to a complete animation. When you store artwork in your 
Library, it is converted to a template and an author and copyright owner is assigned to it at the same time.

In order to set the author and the legally entitled copyright owner information, you must set your preferences prior 
to creating your templates. It is a good idea to set them as you start your project.

By default, the names assigned are the User Name and Copyright values entered while installing Toon Boom Studio 
on your machine.

NOTE: If you are unsure about entering the copyright information, contact your manager or company administrator 
for this information.

To set the author and copyright owner:

1. In the top menu, select Edit > Preferences (Windows) or Toon Boom Studio 7.1 > Preferences (Mac OS X).

The Preferences panel opens.

2. Go to the General tab.
3. In the User Name field, type the author’s name.
4. In the Copyright field, type the owner or company name legally entitled to the copyright.
5. Click on the OK button.
31



Toon Boom Studio User Guide
Setting the Location of Global Library 
By default, when you install Toon Boom Studio, a main library folder is created. This library is called Global Library. 
You can store any kind of artwork as a template in this folder and you will be able to access it from any of your projects.

By default, the Global Library is installed in:

• Windows: C:\Documents and Settings\userName\My Documents\Toon Boom Studio - Global Library 7.1
• Mac OS X: /users/userName/Documents/Toon Boom Library 7.1

If you prefer to place the Global Library in another location, you can change it though the Preferences panel.

To set the Global Library’s location:

1. In the top menu, select Edit > Preferences (Windows) or 
Toon Boom Studio 7.1  > Preferences (Mac OS X).

The Preferences panel opens.

2. Go to the General tab.
3. Beside the Global Library field, click on the Browse button.
4. Browse for the Global Library’s new location.
5. Click on the OK button to close the Browse window.
6. Click on the OK button to close the Preferences panel.
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Some Basic Animation Concepts 
In Toon Boom Studio, you will find several concepts based on traditional animation. Whether you are new to animation 
or an existing animator who wants to understand Toon Boom Studio, this section is for you.

You will learn about:

• Bitmap and Vector Graphics, on page 33
• Palettes, on page 34
• Xsheet and Timeline, on page 35
• Pegs, on page 36
• Multiplane Camera, on page 37

Bitmap and Vector Graphics 
There are two types of digital images:

• Bitmap Image Types, on page 33
Bitmap images consist of pixels and have a fixed size.

• Vector Image Types, on page 33
Vector Image Types are composed of points and Bezier curves and have no fixed size.

Bitmap Image Types 

A bitmap image consists of pixels and has a fixed size. “Pixel”, short for Picture Element, a pixel is a single point in a 
graphic image. It is a small sample of an image, a dot, a square or a very small section made out of smooth filtering. 
If you zoom in close enough on a digital image, you will see the pixels. They look like small squares of different colours 
and intensity. So, a bitmap image is composed of pixels and has a single resolution (size); if it is enlarged too much, it 
will start losing definition and pixels will start to appear. This is known as pixelation.

Vector Image Types 

A vector-based image is composed of points and Bezier curves. The computer reads the points and traces the 
segments linking them to reproduce the image shape. There is no fixed size or resolution in a vector image. The 
graphic can be enlarged and distorted as much as desired and the system will simply recalculate the segments and 
rebuild the shapes. The segment’s shape can be controlled with Bezier handles to curve and smooth it. Vector images 
are translated and displayed in pixels once the calculation is done.
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Advantages and Disadvantages of Bitmap and Vector Images 
Bitmap images allow a more structured style. Since everything has a fixed size and is already made out of pixels, more 
effects are possible, such as blur, painting look, texturing, shading, etc. The bitmap format is excellent for creating 
backgrounds and overlay elements. However, because of the specific resolution, in order to zoom in on or to work in 
high resolution such as HDTV, the created file must be large.

Vector-based graphics can be very useful in creating large illustrations, as these graphics are resolution independent. 
The images can be enlarged significantly without losing definition. A vector-based image generally has a smaller file 
size than a bitmap, as it is a set of mathematical points. However, if there are many vectors composing the graphic, 
the result can be larger than a bitmap file. A vector shape can always be modified. It also creates very crisp images.

Palettes 

In colour animation, exact colours are used to paint each particular character. In order to maintain consistency 
between the scenes and episodes, a colour palette is created for each character, prop and effect throughout the 
project.

Before computers, painters used real colour pots mixed by a colour palette artist. Now, using computers, a digital 
colour palette is created. This allows consistent colour accuracy by always having the same group of colours 
associated with each character.

Advantages of Using a Colour Palette 
Using a colour palette has many benefits, including:

• Each character consistently retains their dedicated colours.
• You cannot accidentally use a colour which is not related to the character.
• Standardization and colour consistency throughout the project.
• Multiple artists can use the same colour palette and produce the same results.
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Xsheet and Timeline
The Xsheet or exposure sheet and the Timeline will be used a lot as you work on your project. This section explains 
what they are and how you can make use of them.

Xsheet 

The Xsheet, also known as the Exposure Sheet or Dope Sheet, is used when an animator is planning a scene: the 
animator enters the layers, the name of the drawings and their exposure into the Xsheet. The Xsheet allows the user 
to see the timing in detail.

The Xsheet is composed of columns corresponding to the different layers. Each column is split into rows representing 
the frames in the scene. A paper Xsheet usually has eighty rows and ten columns. This enables the animator to 
associate a layer with a certain element and record at which frame each of drawing appears.

The traditional paper Xsheet was mainly created for the animator to write down the drawings timing and main actions. 
Toon Boom Studio uses a digital exposure sheet for the same purpose.

Timeline 
A Timeline is a horizontal and chronological representation of events occurring within a particular period.

In animation or digital process, the timeline is quite similar. The timeline is read from left to right and helps you to 
understand the scene and its timing. The frames or time codes are placed at the top and the elements or layers on 
the left. There is no drawing name or value information. The timeline displays the timing and elements in a simplified 
and systematic manner, making it easy to read globally. The timeline can be considered to be a quick overview of the 
whole scene.
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Xsheet and Timeline Usage 
Xsheets and Timelines are used for different tasks. When you do hand-drawn animation, the Xsheet is useful in 
keeping track of the drawings’ ordering, names and timings. The Xsheet is used to reproduce the animator’s work in 
the digital software or the camera.

For puppet animation, computer generated trajectories and distortions, there is a lot of extra information involved, 
including keyframes, velocities, function curves, etc. A keyframe is a computer generated key pose that contains 
values for the element’s on-screen positioning; keyframes can be displayed in the exposure sheet as values. If there 
are too many keyframes, modifying one can be difficult due to all of the values present. This is why there are digital 
timelines. Their simplified version of the timing is quite useful in these situations. The timeline does not display 
drawing names or keyframe values, but instead it represents them as symbols, making it much easier for the eye to 
detect the desired element for modification. Although the name and value information is not directly displayed, the 
Xsheet is still very valuable when retrieving this type of information.

Pegs 

Pegs have been used for a long time in the animation process, mainly for registration purposes. Peg holes at the 
bottom or top of animation paper are used to keep all of the sheets even and at the same registration.

There are three peg holes in regular animation paper. The centre one is circular and the left and right ones are 
rectangular and situated 4 inches on either side of the centre one.

To keep the drawings together, we use a peg bar. This bar has three pins shaped exactly like the peg holes. Peg bars 
are normally found at the bottom and top of animation discs.

Before computers, the peg bars were also used to move layers under the camera stand. They were the equivalent of 
the digital trajectories. Toon Boom Studio makes use of these concepts to create animation and camera moves.
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Multiplane Camera 

In an animation context, multiplaning is used to create a scene with a multiple amount of planes placed at different 
distances from the camera to recreate a perspective illusion. A plane is a layer or an element. In regular flat 2D scenes, 
all the elements are at the same distance superposed one on top of each other. So, when the camera moves, all the 
elements are moving at the same speed. In real life, all objects and elements are placed at different distances from 
our eyes so when we walk past, the closest objects appear to be moving away faster. The farthest ones, like mountains, 
are barely moving. In animation, that perspective effect has to be reproduced manually.

In 1933, the Walt Disney Company invented the multiplane camera. They got the idea from looking at methods used 
in the theatre to introduce perspective into a space with limited depth. In the theatre, cutouts and flat pieces were 
placed in a variety of layers in front of a backdrop which allowed actors to move through the various sets while giving 
the illusion of depth. Walt Disney’s final design for the multiplane camera used this same concept. The multiplane 
camera which was set up vertically, much like a photographic enlarger, would shoot down through as many as five 
planes attached to vertical posts that allowed four of the planes to move independently of one another. The first two 
planes were used for animation, the next two were for backgrounds, and the fifth was fixed and used for sky 
backgrounds. The finished result produced a depth of perspective which had not previously been seen in animated 
film.

Multiplane Usage 
Multiplane camera effects can be created digitally. There is no longer a need to use the big multiplane camera. 
Multiplane shots are normally used to add depth to a scene to reproduce perspective effect more easily. They can also 
be used on smaller scale to make elements pass in front of and behind certain objects like trees or chair.
37



Toon Boom Studio User Guide
Planning Your Project 
Planning is an important step in creating your animation project. This involves listing the scenes that you need to 
animate, the characters you have to design and the different backgrounds to incorporate.

First of all, you need an idea. It does not need to be complicated at all. It can be a very simple idea such as a butterfly 
flying in a field of flowers. In this example, you would need to design a butterfly, a field full of flowers and a sky. Then 
you could compose a movie of two or three scenes.

What is a Scene? 

In animation, a scene is the action happening in front of the camera while the camera does not change angle. As long 
as the camera does not stop “filming”, you are in the same scene. A good example would be two characters talking. 
When the camera is facing the first character, this is one scene. When the camera cuts and film the second character, 
you have a second scene. When the camera returns to the first character, you have a third scene, etc.

A group of scenes occurring in the same location about the same action or event is called a sequence. When there is 
a change of location or subject, it becomes a second sequence.

Planning Your Scenes 

To plan your scenes, you can create a simple list of the different scenes you would like to animate in your project, but 
if you want to take it further, you create a drawing representing each scene with a short action description. This 
concept is called storyboarding. You can create a simple storyboard on paper or you can use another Toon Boom 
software called Toon Boom Storyboard.

Once you know which scenes you need in your project, you use Toon Boom Studio to create your scene list based on 
your plan.

Scene 1 Scene 2 Scene 3

Sequence

Scene 1 Scene 2 Scene 3
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Creating Scenes in Toon Boom Studio Project 
To create scenes in a Toon Boom Studio project, you need to use the Scene Manager window. Once your scenes are 
created, you will be able to move on to learn more about Toon Boom Studio and its interface, drawing tools and 
animation features.

To create scenes in Toon Boom Studio:

1. Select Window > Scene Manager or use the default keyboard shortcut [Ctrl]+[Shift]+[M] (Windows) or 
[]+[Shift]+[M] (Mac OS X).

The Scene Manager dialog box opens.

By default, there is a scene created called Scene-1.

2. In the top area, click on the New Scene  button to add a new scene to your project. You can also click on the 

Menu  button and select New Scene.

 Click on the Delete Scene  button to remove a scene from your list. You can also click on the Menu  
button and select Delete Scene.

The new scene appears in your list.

3. To open a scene from the list, double-click on the scene’s name. You can also click on the Menu  button and 
select Make Current.

4. To rename the scene or change its properties, select the scene from the list, click on the Menu  button and 
select Properties.

The Properties dialog box opens.

5. In the Scene Name field, type the new name for your scene.
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6. To change the colour of the scene’s background, click on the colour swatch.

The Colour Picker panel opens.

7. Select the desired colour and click on the OK button.
8. Click on the OK button to close the Properties panel.
9. Repeat the same process for all the scenes you want to add to your project.
10. In the top menu, select File > Save. The default keyboard shortcut is 

[Ctrl] + [S] (Windows) or [] + [S] (Mac OS X). You can also click on the Save  button in the Main toolbar.

Help Tools 
While learning and working with Toon Boom Studio, you have access to the following learning tools included with the 
application.

Toon Boom Studio 7.1 User Guide 
The User Guide explains in details each command and feature included in the application. It is available through the 
Help > Help menu, as PDF file and as a hard copy available for purchase. The User Guide can be prompted using the 
[F1] keyboard shortcut.

Context Sensitive Help
The Context Sensitive Help is a built in help system prompting a short description of the selected tool or command. 
It is available in both French and English.

To prompt the Context Sensitive Help:

1. Press the [Shift] + [F1] keyboard shortcut.
2. Once you get the Question Mark logo, click on the button or menu item you want to learn about.

3. A short description is displayed in the bottom Status bar and a longer description appears on mouse-over.
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Preferences 
An important feature of Toon Boom Studio is the Preferences panel. From here you can customize your interface, tool 
behaviour and shortcuts. Throughout this guide, you are often required to go to the Preferences panel to set 
parameters and options.

In this section you will learn how to access the Preferences panel and also find a general description of its functionality.

This section covers the following topics:

• Preference Highlights, on page 41
• Accessing the Preferences Panel, on page 41

 To learn about the different preferences available, refer to the following chapters:

• Starting Your Project, on page 19
• Drawing and Design, on page 67
• Importing Artwork, on page 141
• Adding Colours, on page 105
• Layers and Timing, on page 175
• Animating a Puppet, on page 291
• Scene Setup, on page 347

Preference Highlights
You can set over 40 preferences in the Preferences panel. You will learn about them as you read through this guide.

The Preferences panel is divided into the following tabbed sections:

• General
• Shortcuts
• Interface
• Light Table
• Display
• Sceneplanning

Some preferences require you to exit and restart the application or to close a view and reopen it.

Accessing the Preferences Panel 
To access the Preferences panel:

1. In the top menu, select Edit > Preferences (Windows) orToon Boom Studio 7.1 > Preferences (Mac OS X).

Display 
You can optimize the display performance of the software, by using the preferences available to you. Optimization of 
the display performance is dependant on the task you are doing and your graphic card and system. These preferences 
can be found via the Preferences panel.

To open the Preferences panel:

 Windows: Select Edit > Preferences.
 Mac OS X: Select Toon Boom Studio 7.1  > Preferences.
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You can find the display performance preferences under the Display tab.

Renderer 
• OpenGL: By default, Toon Boom Studio uses OpenGL for rendering images in the Camera and Drawing 

views, but you can change this preference to use Direct3D (Windows).
• Disable Hardware Acceleration: Select this option if you are having problems with your display and you 

suspect they may be related to your video card features. This preference is only available in Windows.
• Improve Pencil Rendering Performance: Select this option if you are having problems with centreline 

strokes slowing down the software.
• Use Hardware Shaders: Disable this option if you experience display issues that might be caused by the 

graphic card.

 Note that you need to restart the application in order for the Renderer settings to take effect.

Rendering Options 
• Smooth Textures & Bitmaps: Improves bitmap image quality by smoothing-out the pixels of bitmap images 

when zooming in. 
• Smooth Tools: This option is enabled by default, it increases the display quality of tools. Disabling it will 

lower the display quality but increase the display speed.
• Smooth Pegs: This option increases the display quality of pegs and is enabled by default. Disabling it will 

lower the display quality of the peg but increase the display speed.
• OpenGL Full Scene Anti-Aliasing: Full Scene antialiasing is generated by your computer’s graphic card. 

This antialiasing will not only antialias your drawings but all your different views in the interface. You can turn 
the Full Scene Antialiasing preference on and off. Full Scene Antialiasing parameters are only valid while 
you work in your scene. The scene will be rendered out to 100% of its resolution regardless of your settings 
in the Preferences or graphic card panel.

• Texture & Images resolution: You can change the bitmap quality of your images while working on your 
project in the Drawing or Camera views. This helps lower the memory usage while working, but does not 
affect the final render quality of your project. Depending on whether you want a faster display or better 
quality, you should drag the slider to the left or to the right.

• System Memory Usage: You can change the amount of system memory allocated to bitmap files included 
in your animation project. This does not affect the quality of your work. Depending on whether you want 
the system to use more or less memory for bitmap material, you should drag the slider to the left or to the 
right.
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Tablet Support 
These options are used to fix issues you may have using a tablet and are very technical.

• Handle Tablet Events With Qt: This option changes the way the events are treated within the system and 
this might be needed to allow the drawing functionality of a tablet that is not a Wacom tablet.This 
preference is only used with Mac OS X.

• Ignore All Tablet Events: This option is used to deactivate all events from a tablet that is not a Wacom 
tablet. This will allow the tablet to work as a mouse. It will deactivate the pressure sensitivity but allow 
drawing just like a mouse.

• Enable Tablet PC Portrait Mode Correction: This preference is used to fix a past issue with a Wacom 
Tablet PC driver. When in portrait mode, the cursor would not correctly follow the pen movement. This 
preference is only available using Windows and a Tablet PC.

• Use Qt Wintab Support (Need Relaunch): This preference is used to fix other possible issue with a Tablet 
PC by changing the protocol used to manage the tablet events. This preference is only available using 
Windows and a Tablet PC.
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What’s Next?
So far, you have learned about:

• Launching Toon Boom Studio
• Using the Welcome Screen
• Creating and Opening Projects
• Setting Authors and Copyright Owners
• Setting the Global Library’s Location
• Some Animation Basics
• Planning Your Project
• Creating Scenes in a Project
• Help Tools
• Preferences

It is now time to learn about Studio’s user interface (UI). Knowing about the UI will let you work easily as you create 
content for your project.
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Toon Boom Studio has a very user friendly interface, easy to manage and understand. In this chapter, you will discover 
the main interface’s highlights and how to organize your workspace.

This chapter is divided as follows:

• Interface Components, on page 46
• Interface Highlights, on page 49
• Managing Views, on page 55
• Managing Toolbars, on page 59
• Workspaces, on page 60
• Interface Navigation, on page 62
• Preferences, on page 63
• What’s Next?, on page 65
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Interface Components 
Toon Boom Studio’s user interface has three main components that you will use all the time while creating your 
animation:

• Menus, on page 47
• Toolbars, on page 48
• Views, on page 48

Menu

Toolbars

Toolbars

Views
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Menus 
Toon Boom Studio has two kinds of menus:

• Top Menu, on page 47
• Quick Access Menu, on page 47

Top Menu 
The top menu is always located at the top left corner of the interface. On Windows, it is part of the user interface and 
on Mac OS X, it is located at the very top of the screen.

In the top menu, you will find most of the commands you will use throughout your whole project.

Quick Access Menu 

The Quick Access menu is a contextual menu containing only the commands relative to the view and area in which 
you are working. Instead of going all the way to the top menu, just right-click (Windows) or [Ctrl]+click (Mac OS X) in 
the view in which you are working to display it.

You will find a series of Quick Access menus throughout the interface. Here is a list of the main ones:

• Camera View
• Drawing View
• Timeline Layers (Timeline’s left side)
• Timeline Frame (Timeline’s right side)
• Xsheet Column Header
• Xsheet Column Cells
• Colour Palette View
• Library Folders (Library’s left side)
• Library Templates (Library’s right side)
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Toolbars 

Instead of selecting a command in a menu, you can click on the buttons in the toolbars. You will mainly find toolbars 
at the top and left side of the interface, but also within certain views such as the Timeline view.

It may be more visual and easier to find a feature if you browse through the different toolbars.

The main toolbars you will encounter in the software are:

• Main Toolbar
• Drawing Tools Toolbar
• Sceneplanning Tools Toolbar
• Bone Tools Toolbar
• Effects Toolbar
• Interactive Playback Toolbar
• Grid Control Toolbar
• Onion Skin Toolbar
• Peg Toolbar
• Scene View Toolbar
• Workspace Toolbar
• Exposure Sheet Toolbar
• Timeline View Toolbar

Views 
Toon Boom Studio’s interface is composed of several different views that you will use to perform different actions. The 
main view you will use for your project is the Camera view assisted by the Timeline view.

Each view specializes in one or two aspects of the production. For example, the Camera view is used for motion path 
animation and scene setup. The Drawing view is used for drawing and the Timeline view for setting timing and 
creating simple effects.

Here are the different views available in the software:

• Camera View
• Cell View
• Colour Palette View
• Drawing View
• Exposure Sheet View
• Function View
• Library View
• Pen View
• Properties View
• Scene Manager View
• Side View
• Text View
• Timeline View
• Top View
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Interface Highlights 
In Toon Boom Studio, you will find several different views and toolbars. In this section, you will learn about the main 
ones that you will use frequently. All others are described in context in other chapters.

In this topic, you will learn about the followings:

• Camera View, on page 49
• Drawing Tools Toolbar, on page 51
• Sceneplanning Tools Toolbar, on page 51
• Timeline View, on page 52
• Interactive Playback Toolbar and Play Menu, on page 53

Camera View 

The Camera view is the main view you will use to create your artwork and animate it. In the Camera view, you will find 
the camera frame in which you have to position your elements if you want them to be part of your final movie. 
Anything outside the camera frame will not appear in your final export.

In the Camera view, you will also find two toolbars:

• View Navigation Toolbar, on page 50
• Switch View Toolbar, on page 50

Switch View Toolbar

View Navigation Toolbar

Camera Frame
49



Toon Boom Studio User Guide
View Navigation Toolbar 
In the View Navigation toolbar, you will find five buttons allowing you to zoom, pan and rotate the Camera view.

•  Switch Between Two Views
Click on this button to toggle between the two last zoom levels you used. For example, if you zoom in very 
close on a drawing and then zoom out to a global view, clicking on this button will toggle between the close 
up and the global zoom levels.
The default keyboard shortcut is [B].

•  Reset Zooming and Panning
Click on this button to reset any zoom, rotation and pan action you did while navigating in the Camera view 
working area. The camera frame will be recentred in the Camera view. Note that it does not reset the 
positioning you may have done on your drawings and images.
The default keyboard shortcut is [Shift]+[V].

•  Recentre the Active View
Click on this button to centre the camera frame in the Camera view. Any rotation or zoom action will remain 
the same.
The default keyboard shortcut is [Shift]+[Space].

•  Reset the Rotation of the Window
Click on this button to reset any rotation you did on the Camera view working area. The pan and zoom 
levels will remain the same. Note that it does not reset the positioning you may have done on your drawings 
and images.
The default keyboard shortcut is [Shift]+[C].

•  Reset the Zoom Level of the Window
Click on this button to reset any zoom action you did on the Camera view working area. The pan and 
rotation will remain the same. Note that it does not reset the positioning you may have done on your 
drawings and images.
The default keyboard shortcut is [Shift]+[Z].

Switch View Toolbar 
In the Switch View toolbar, you will find four buttons allowing you to toggle between the following views:

•  Drawing View

•  Camera View

•  Side View

•  Top View

This toolbar is useful when switching between these views to save room in your workspace. You can also have these 
views separately by selecting them in the top Window menu.
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Drawing Tools Toolbar 

The Drawing Tools toolbar contains all of the different tools you will need to draw and design your artwork. Some 
extra commands can be found in the top Tools menu.

Some of the buttons in the toolbar have a black drop-down arrow, this lets you open a menu with extra drawing tools.

 Refer to the Drawing and Design chapter to learn more about the drawing tools.

Sceneplanning Tools Toolbar 

The Sceneplanning Tools toolbar contains all of the different tools you will need to position and animate your layers. 
Some extra command can be found in the top Element menu.

Some of the buttons in the toolbar have a black drop-down arrow, this lets you open a menu with extra sceneplanning 
tools.

 Refer to the Scene Setup chapter to learn more about the sceneplanning tools.
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Timeline View 

The Timeline view is the main view used to create layers, set your timing and create simple effects.

The Timeline view is divided in three sections:

• Timeline View Toolbar
• Layers Section
• Timing Section

Timeline View Toolbar
The Timeline View toolbar is composed of nine different buttons allowing you to add, enable and disable layers as 
well as switching between the different scenes of a same project.

•  Show/Hide All
Click on this button to show or hide all the layers in your timeline. This button will toggle between the two 
states.

•  Solo Mode

Click on this button to toggle between the Solo Mode On  and Off  states. The Solo mode allows 
you to see only the currently selected layer as well as the layer that was selected when you enabled the Solo 
Mode to use it as a reference without having to disable all the other layers.

•  Add New Elements
Click on this button to add a new element (layer) to your timeline. When you click on this button, the New 
Element dialog box opens and lets you choose which type of element you want, how many and how you 
want to name it.

•  Delete Element
Click on this button to delete the selected layers in your timeline. Note that if you delete a layer with other 
layers connected to it, all the layers connected will be deleted at the same time. Also, if you only have one 
layer in your timeline, you will not be able to delete it. The Toon Boom Studio Timeline view must always 
have at least one drawing layer in it.

•  Add Drawing Element
Click on this button to add a drawing layer in your timeline without having to go through the Add New 
Element dialog box. Simply click on the button and a new drawing layer will appear in the Timeline view. 
You can then double-click on the new layer to rename it.

Timeline View Toolbar

Layers Timing
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•  Add Peg Element
Click on this button to add a peg layer in your timeline without having to go through the Add New Element 
dialog box. Simply click on the button and a new peg layer will appear in the Timeline view. You can then 
double-click on the new layer to rename it.

•  Add Parent Peg
Click on this button to add a peg layer in your timeline and connect it to any selected layer without having 
to go through the Add New Element dialog box. Simply click on the button and a new peg layer will appear 
in the Timeline view and the selected layer will be connected to it. You can then double-click on the new 
layer to rename it.

•  Scene Menu
Click on this button to travel between the different scenes in your project.

•  Timeline View Contextual Menu
Click on this button to display a drop-down menu containing commands related only to the Timeline view.

Interactive Playback Toolbar and Play Menu
Use the Interactive Playback toolbar and the Play menu to play back your animation and sound.

Interactive Playback Toolbar

• Click on the Play  and Stop  buttons to play and stop the animation. You can also do this from the 
top menu by selecting Play > Play or Stop. The default keyboard shortcut is [P].

• Click on the Loop  button to repeat your playback indefinitely. Or do this from the top menu by 
selecting Play > Loop. 

• Click on the Previous Frame  button to go to the previous frame of your animation. Or do this from the 
top menu by selecting Play > Previous Frame.

• Click on the Next Frame  button to go to the next frame of your animation. Or do this from the top 
menu by selecting Play > Next Frame. 

• Click on the First Frame  button to go to the first frame of your animation. Or do this from the top menu 
by selecting Play > First Frame. 

• Click on the Last Frame  button to go to the last frame of your animation. Or do this from the top menu 
by selecting Play > Last Frame. 

Play Menu 
Select any of the following from the top menu Play heading:

• Frame Rate: to choose the playback speed of your animation. By default, the option is set to use the same 
playback speed you set in your Animation Properties when you created the project. In the drop-down 
menu, you can change it to 1, 2, 12, 24 or 30 frame per second.

• Force Frame Rate: to force Toon Boom Studio to play the right playback speed. If a scene is too heavy to 
be played back in real time, Toon Boom Studio will drop images rather than playing back all images at a 
slower pace.

• Playback Range: to specify the range of frames to be played back. By default, the option is set to 
Automatic Fit allowing you to play the full scene length. If you set the option to Free, black markers appear 
in the Timeline view.
You can drag these markers to the first and last frames you want to be played back. 
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You can also select the Change the Playback Start Frame option to type the number of the first frame of 
the playback range.

You can also select the Change the Playback End Frame option to type the number of the last frame of the 
playback range.

• Preview Movie: to export a QuickTime movie of the entire animation project including all its scenes.
• Preview Scene: to export a QuickTime movie of your current scene, ignoring the other scenes in the 

project.
• Preview Exposure Sheet: to export a QuickTime movie of the drawings in the exposure sheet of the 

current scene only. This type of render ignores all the motion path and scene planning done in the Camera 
view.

• Preview Exposure Sheet Selection: to export a QuickTime movie of the selected drawings in the exposure 
sheet of the current scene only. This type of render ignores all the motion path and scene planning done in 
the Camera view.

• Turn Off/On Sound Playback: to enable or disable the sound while playing back the scene.
• Turn Off/On Sound Scrubbing: to enable or disable the sound scrubbing effect while changing frames in 

the Timeline view. The sound scrubbing option is mainly used to do lip-sync decoding.
• Quick Preview: to export a Flash SWF movie of your current scene ignoring the other scenes in the project.
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Managing Views 
The Toon Boom Studio user interface is composed of different views, each one designed for a specific purpose. 

This section explains how you can modify the location and accessibility of the views by adding a new view as a tab or 
as a window, you can also swap the view locations around.

This section covers the following topics:

• Adding a New View, on page 55
• Closing a View, on page 55
• Swapping Views, on page 57
• Resizing a View, on page 58
• Showing and Hiding the Status Bar, on page 58
• Extending the Side Panel, on page 58

Adding a New View 
To add a view:

1. Select the view you want to add from Window > The desired view.
2. If your view appears as a floating window and you want to dock it to your workspace, drag the window’s tab 

onto one of the workspace’s views. 
 To insert your view into an existing area, wait until the zone is highlighted before dropping it.
 To insert your window between existing views, drag your window to the border of an existing view and wait 

for a new space to slide open before dropping it.

Closing a View 
To close a view:

1. Click on the Close View button.
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Undocking and Docking Windows and Views 
In Studio you can rapidly dock, undock or move windows and views around the interface and your desktop. This will 
make it easy for you to organise your workspace and obtain the maximum use from the available desktop real estate. 

In fact, if you have a dual monitor setup, you can drag it away from the Studio interface and place it on the second 
monitor’s desktop.

NOTE:

By default, all windows and views are docked into the interface. You can change this default to floating, by choosing 
Floating Windows from the drop list options in the Edit > Preferences > Interface tab > Workspace Mode section 
(Windows) and Toon Boom Studio 7.1 > Preferences > Interface tab > Workspace Mode section (Mac OS X).

Undocking 
To undock a window or view from the Studio interface, do the following:

1. Double-click on the window or view’s name tab. 

The window will automatically detach from its docked position and appear floating in the interface.

2. Once you have detached the window, you can resize it to fit your work needs.

p

Click on the name tab here. 
In this case we are going to 
undock the Colour Palette 
from the interface.

The Colour Palette 
window is now detached 
from the interface, it is 
floating.
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Docking 
To return the floating window to its docked location, do the following:

1. Double-click on the floating window’s title bar. The window will automatically return to the docked location.

NOTE:

Next time you double click on that window’s name tab, it will undock and return to its last location on your desktop.

Moving the Floating Window Around the Desktop 
After the window is undocked you can move it around and position it anywhere on your desktop. 

1. Click on the window’s title bar, hold the mouse button down and drag the window to the new location. 

NOTE:

Next time you double click on that window’s name tab, it will undock and return to the location where you last had 
that floating window on your desktop.

Swapping Views 
To swap views around:

1. Select the view tab and drag it onto one of the view’s separators, top area or onto another view.
2. When a darker zone appears showing an available location for the view, release the mouse button and drop the 

view into position. 

Double-click on the title 
bar, the window will 
return to its docked 
location.

Click here and drag it 
anywhere on your 
desktop.
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Resizing a View 
To change the width and height of the views in the workspace, drag the side of the view.

To resize a view:

1. In the interface, position your cursor on the edge of the view you want to resize.
2. When you see the Resizing cursor, click and drag the side of the window to the desired width or height.

Showing and Hiding the Status Bar 
Toon Boom Studio has a Status bar located at the bottom of its user interface. This displays information related to the 
tool or feature the mouse is passing over. You can show and hide this bar.

To show or hide the Status bar:

1. Select Window > Show/Hide Status Bar.

Extending the Side Panel 
In Toon Boom Studio’s Default workspace, the utility views such as the Colour Palette and the Pen views are located 
to the right side of the interface. At the bottom of the workspace, there is the Timeline. Some users prefer to have 
their timeline taking the full width of the workspace and some other prefer to have the utility views take the full height. 
You can toggle between the two options using the Extend Side Panel option.

To extend the side panel:

1. Select Window > Extend Side Panel.
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Managing Toolbars 
The Toon Boom Studio user interface contains toolbars which, by default, are located at the top or side of the 
interface. You can reposition the toolbars to suit your work style or hide unused ones.

This section covers the following topics:

• Showing or Hiding Toolbars, on page 59
• Moving Toolbars, on page 59
• Customizing Toolbars on Mac OS X, on page 59

Showing or Hiding Toolbars 
To show or hide a toolbar:

1. Select Window > Toolbar > the desired toolbar.

Moving Toolbars 
To move a toolbar:

1. Select the toolbar you want to move by clicking on its anchor point  and dragging it to another position in 

the top or side interface toolbar area.
2. When a rectangle outline appears showing an available location for the toolbar, release the mouse button and 

drop the toolbar into position.

Customizing Toolbars on Mac OS X 
On Mac OS X, you can customize toolbars to display buttons that access the commands that you use the most.

To customize toolbars in Mac OS X:

1. Select View > Customize Toolbar. 

A window opens displaying all of the buttons available for the view you are currently working in.

2. Drag the buttons you want to the toolbar in the current view. 
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3. You can also use the Show drop-down list and decide to show:
• Icon and Text
• Icon Only
• Text Only

4. By default, the software displays large buttons, you can enable the Use Small Icon options to switch to smaller 
buttons.

5. Click on Done when you are finished making your changes.
6. To remove buttons, drag them away from the toolbar.

Workspaces 
Toon Boom Studio’s user interface is composed of several views. You can customize your workspace to suit your 
working preferences, then save it as a new workspace and load it from the Window menu.

This section covers the following topics:

• Loading a Workspace, on page 60
• Creating a Workspace, on page 60
• Renaming a Workspace, on page 61
• Saving a Workspace, on page 61
• Deleting a Workspace, on page 61

Loading a Workspace 
The first time you open Toon Boom Studio, the default workspace is loaded. Other available workspaces are; the 
Drawing, Full Screen Drawing and the Scene Planning workspaces, these display different views and toolbars. You can 
access these workspaces and the ones you created from the Window menu.

To load a workspace:

1. In the top menu, select Window > Workspaces > New Workspace and select a workspace from the list. You 
can also select the same option in the Workspace toolbar.

 There are several useful workspaces available in the list. One of them, the Full Screen Drawing is automatically 
set to Full Screen to allow a larger drawing space, to exit the Full Screen mode, select View > Turn Off Full Screen 
or use the default keyboard shortcut [Ctrl]+[F] (Windows) or []+[F] (Mac OS X).

Creating a Workspace 
To create a workspace:

1. Reposition the views and toolbars the way you want them to be in your new workspace.

2. Select Window > Workspaces > New Workspace. You can also select the same option in the Workspace 
toolbar.

The workspace dialog box opens.

3. Rename your new workspace.
4. Click on the OK button.

The new workspace is created and can be loaded from the Window > Workspaces menu.
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Renaming a Workspace 
You can only rename a custom workspace. You cannot rename workspaces provided with Toon Boom Studio.

To rename a workspace:

1. Select Window > Workspaces > and select the workspace you want to rename. You can also select the same 
option in the Workspace toolbar.

2. Select Window > Workspaces > Rename “current workspace’s name”. You can also select the same option in 
the Workspace toolbar.

The Rename Workspace dialog box opens.

3. Rename the workspace.
4. Click on the OK button.

Saving a Workspace 
You cannot save modifications in the Default workspace. You can save modification in the Drawing, Full Screen 
Drawing and Scene Planning workspaces.

To save a workspace:

1. Select Window > Workspaces > Save “current workspace’s name”. You can also select the same option in 
the Workspace toolbar.

Deleting a Workspace 
You can only delete a custom workspace. You cannot delete workspaces provided with Toon Boom Studio.

To delete a workspace:

1. Select Window > Workspaces > Delete “current workspace’s name”. You can also select the same option in 
the Workspace toolbar.

Restoring the Default Workspaces 
You can restore modified workspaces to their default layout if you saved the modifications.

To restore the default workspaces:

1. Select Window > Workspaces > Restore “current workspace’s name”. You can also select the same option in 
the Workspace toolbar.
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Interface Navigation 
Toon Boom Studio supports Zoom In, Zoom Out, Rotate, Pan and Reset View Position for easy interface navigation.

• Zoom In: Zooms into the view. Use the keyboard shortcut [X] or from the top menu, select View > Zoom In.
• Zoom Out: Zooms out of the view. Use the keyboard shortcut [Z] or from the top menu, select 

View > Zoom Out. 
• To Pan the view: Hold down the keyboard shortcut [Spacebar] and drag your mouse in the direction you 

want to pan the view. 
• To Rotate Clockwise: Use the keyboard shortcut [V] or for the top menu select View > Rotate Clockwise. 
• To Rotate Counter Clockwise: Use the keyboard shortcut [C] or for the top menu select View > Rotate 

Counter Clockwise. 
• To Recentre the view: Click on the keyboard shortcut [Shift] + [Spacebar] or from the top menu, select 

View > Recentre. 
• Reset View: Resets the view to its default position. Use the keyboard shortcut [Shift]+[V] or from the top 

menu, select View > Reset View.
• Reset Rotation: Resets the view’s rotation to its default position. Use the keyboard shortcut [Shift]+[C] or 

from the top menu, select View > Reset Rotation. 
• Reset Zoom: Resets the view’s zoom to its default position. Use the keyboard shortcut [Shift]+[Z] or from 

the top menu, select View > Reset Zoom. 
• Turn On/Off Full Screen: Enlarges the selected view to full screen, keeping the side panel. Use the 

keyboard shortcut [Ctrl]+[F] (Windows) or []+[F] (Mac OS X) or from the top menu, select
View > Turn On/Off Full Screen.
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Preferences 

Interface Preferences 
To customize your interface, you will use some of the preferences located in the Interface category.

Element Colours 
Double-click on the colour swatches to modify the colour of the different elements listed in the section. For example, 
change the colour of the Camera option to modify the colour of the Camera in the Timeline view.

Window Background Colours 
Double-click on the Drawing or Timeline colour swatch to modify the colour of the background in the Drawing or 
Timeline view. If you do not like to have white as a background colour and would prefer to use a grey colour, change 
the colour swatch to grey.

Workspace System 
In the Workspace Mode drop-down menu, select one of the following option:

• Docking Windows: Select this option if you want the new views you add from the Window menu to 
automatically be docked to your interface.

• Floating Windows: Select this option if you want the new views you add from the Window menu to be 
added as floating windows and not be docked to your interface.

Show All Tips Again 
Toon Boom Studio prompts the user to inform about certain situations. Often the user can select the Do Not Show 
This Message Again option to avoid getting message prompts.

If you want to see these messages, click on the Show All Tips Again button.
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Keyboard Shortcuts 
To speed up your work, all of Toon Boom Studio’s keyboard shortcuts can be customized.

You can customize most of the shortcuts by opening the Preferences panel and going to the Shortcuts tab.

To set a shortcut:

1. Open the Preferences panel.
2. In the Preferences panel, go to the Shortcuts tab.
3. In the Category drop-down menu, select the menu containing the command you want to modify.
4. In the left window, select the command to modify.
5. Click on the shortcut button to modify the shortcut. 

The current assigned shortcut is displayed on this button. If no shortcut is currently assigned for the selected 
command, the word None will be displayed instead.

6. On your keyboard, press on the desired key for the new shortcut.
 To remove any keyboard shortcut associated to a command, click on the Remove button.
 To reset all the keyboard shortcuts to their default values, click on the Reset All button.

7. If a keyboard shortcut is already in use, a message will appear in the Currently Assigned To window notifying you 
of the command to which it is already associated.

 Click on the Override button to ignore the previous association and assign the shortcut to the selected 
command. The other command’s shortcut will be set to none.

 If you click on the OK button before overriding the shortcut assignation, the action will be cancelled.

8. Click on the OK button.

Click on this button to
assign a new shortcut
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What’s Next?
So far, you have learned about:

• Interface Highlights
• Views
• Toolbars
• Workspace
• Preferences
• Customizing Keyboard Shortcuts

It is now time to learn about Studio’s wide variety of drawing and design tools.
65



Toon Boom Studio User Guide
66 



Chapter 4  Drawing and Design

This chapter explains the main options, features and tools you will need when drawing and designing in Studio.

In this chapter, you will learn about the following:

• Drawing Basics, on page 68
• Drawing in the Drawing or Camera View, on page 69
• Drawing Using the Brush or Pencil Tool, on page 70
• Relative Sizes of Characters and Props, on page 72
• Sketching, on page 74
• Tracing, on page 76
• Erasing Part of a Drawing, on page 78
• Selecting Drawing Objects, on page 79
• Pen View, on page 81
• Drawing Invisible Lines, on page 85
• Working With Text, on page 86
• More Drawing Tools, on page 89
• More Drawing Options, on page 96
• Preferences, on page 101
• What’s Next?, on page 103
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Drawing Basics 
As soon as Studio is launched, you can immediately start drawing using the drawing layer which is already available. 

How to Draw:

1. Click on the Drawing View  button to switch to the Drawing view. You’ll find it in the top right corner of the 
main window.

2. In the Drawing Tools toolbar, select the Brush  tool. You can also press the [@] default keyboard shortcut.

3. In the Timeline or Xsheet view, select the first cell in the drawing layer.

4. In the Drawing view, start drawing.

Note that you can also draw directly in the Camera view without switching to the Drawing 
view.
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Drawing in the Drawing or Camera View
In Toon Boom Studio, you can either draw in the Drawing view or the Camera view. Although the views look similar 
there are some differences when it comes to drawing.

 Drawing View 
By default, only the selected cell drawing is displayed in the Drawing view. You can use tools such as the Light Table 

, which will display the current frame drawing of all the visible layers of your scene in washed out colours, or the 

Onion Skin  option which displays the previous and next drawing of the currently selected drawing layer.

To switch to the Drawing view:

 Click on the Drawing View  button on the top right corner of the main window to switch to the Drawing 
view.

 Refer to the More Drawing Tools topic to learn more about the Light Table option.

 Camera View
By default, all the visible layers drawing of the selected frame will be displayed in the Camera view. The selected 
drawing will automatically be displayed on top when you are using a Drawing tool to facilitate the edition of the 

drawing. You can also use the Onion Skin  option to display previous and next drawings of the selected drawing 
layer.

To switch to the Camera view:

 Press on the Camera View  button to switch to the Camera view. You’ll find it in the top right corner of the 
main window.

To hide and show layers in the Timeline view:

1. In the Timeline view, click in the checkbox corresponding to the layer you want to hide.

  An enabled checkbox means that the layer is visible

  A disabled checkbox means that the layer is hidden.

To show or hide all layers at once in the Timeline view:

1. In the Timeline view, click on the Show/Hide All  button.

 Refer to the Traditional Digital Animation chapter to learn more about the Onion Skin feature.
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Drawing Using the Brush or Pencil Tool 

The Brush  and Pencil  tools are used to draw and sketch with.

 Brush Tool 
The Brush tool takes account of pressure sensitivity, allowing you to create lines with variable thicknesses when using 
a pen tablet, creating a contour vector shape.

You can set different parameters, such as the size and smoothness of the Brush tool in the Pen view.

Refer to the Pen View topic to learn more about setting the Brush tool parameters.

To select the Brush tool: 

 In the Drawing Tools toolbar, select the Brush  tool.
 In the top menu, select Tools > Drawing Tools > Brush.
 Press [@], the default keyboard shortcut.

 Pencil Tool 

The Pencil , Polyline  and Shape  tools create a central vector line of uniform thickness. 

You can set different parameters, such as the size and smoothness of the Pencil tool in the Pen view.

Refer to the Pen View topic to learn more about setting the Pencil tool parameters.

To select the Pencil tool:

 In the Drawing Tools toolbar, select the Pencil  tool.
 In the top menu, select Tools > Drawing Tools > Pencil.
 Press the keyboard shortcut [2], to cycle through tools.

Central

Contour

Pencil tool

Brush tool
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Converting Lines 
You can easily convert your pencil lines to brush shapes and your brush shapes to pencil lines using these features:

• Convert Lines to Brush
• Extract Centre Line

Convert Lines to Brush 

You can draw with a Pencil  tool and then convert it to a Brush line using the Convert Lines to Brush option, and 

then you can modify its thickness using the Contour Editor  tool. 

To convert a pencil line to a brush zone: 

1. Select the Select  tool from the Drawing Tools toolbar. 
You can also select Tools > Drawing Tools > Select from the top menu or use the [!] default keyboard shortcut.

2. In the Drawing or Camera view, select the pencil line to convert and select Tools > Convert Lines to Brush from 
the top menu.

Refer to the More Drawing Tools topic to learn more about the Contour Editor  tool.

Extract Centre Line - Converting a Brush shape to a Pencil line 
You can also convert a brush shape into a pencil line using the Extract Centre Line option. 

NOTE: The brush line loses its thick and thin characteristics when is converted from a contour vector to a central vector 
type.

To convert a brush zone to a pencil line: 

1. Select the Select  tool from the Drawing Tools toolbar. 
You can also select Tools > Drawing Tools > Select from the top menu or use the [!] default keyboard shortcut.

2. In the Drawing or Camera view, select the brush zone you want to convert and select Tools > Extract Centre 
Line from the top menu.
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Relative Sizes of Characters and Props 

Your project can contain many characters and props. When characters are placed together in a scene you will notice 
that they may be of various sizes, some will be too tall or too small, the character’s size may vary from one scene to 
the next. You may also find that when a character is scaled down using the Scene Planning tools, its outline is thinner. 
Sometimes, the outline may be so thin that the difference between the resized character’s outline and the outline of 
one which was not resized is quite noticeable.

When you design characters or props keep in mind how they will look together. The grid can be displayed in the 
Camera or the Drawing view. This is useful when determining the proportions between characters and props in your 
scene.

To display the Grid when working in either the Camera or the Drawing view: 

 Click on the Show Grid  button in the Grid Control toolbar. You can also select View > Grid > Show 
Grid from the top menu.

Scaled down character Original size character
72 



Chapter 4: Drawing and Design   
To select the Grid units when working in either the Camera or the Drawing view: 

 With the grid showing, click and hold the grid unit button in the Grid Control toolbar to display the other 
grid unit options and choose from the following:

  Normal: Sets the grid units to squares. You can also select 
View > Grid > Normal from the top menu.

  12 Field: Sets the grid units to rectangles forming a 12 field grid. You can also select 
View > Grid > 12 Field from the top menu.

  16 Field: Sets the grid units to rectangles forming a 16 field grid. You can also select 
View > Grid > 16 Field from the top menu.

By default, the grid is displayed as an underlay so that it appears behind the drawings. If you prefer it to appear in 
front of the drawings, change this option to display it as an overlay.

To display the Grid as an overlay:

1. In the Grid Control toolbar, click on the Overlay  button. When the button is pushed in, the grid will be 
displayed as an overlay.  You can also select View > Grid > Overlay from the top menu.

2. In the Grid Control toolbar, click on the pushed-n Overlay  button to switch back to the underlay grid 
display mode.  You can also select View > Grid > Underlay from the top menu.

You must be working in the Camera or Drawing view when setting the grid options, otherwise the Grid 
Control toolbar and the related top menu commands will be greyed out. NOTE: when working in the 
Camera view, the grid is only displayed if a Drawing tool is selected.
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Sketching 

A sketch is a rough version of your design. When you sketch a rough of a new design for a character you can produce 
whatever you imagine without being concerned about the final look of your lines. Making a rough version of your 
character helps you build a solid base shape and come up with some new design ideas. Studio has many tools 
available for sketching.

To make a sketch:

1. In the Drawing Tools toolbar, select the Brush  tool. You can also press the [@] default keyboard shortcut.

2. In the Pen view, set the look of your Brush:
 Click on the Brush Preview area and select the brush shape you want.

 Use the sliders to set the Minimum and Maximum brush sizes.

As you set your brush size, the Brush Preview area will display the Minimum size of your brush in black and the 
Maximum size in dark grey.
 You can also set the Smoothness value of the Brush tool. Use this option to smooth out the brush stroke 

after you trace it. The higher the value, the more smoothness will be applied to your line.

3. In the Colour view, click on a default colour swatch you want to draw with to change the colour of the Brush  
tool. 
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4. In the Timeline or Xsheet view, select the first cell of the drawing layer.

5. In the Drawing view, sketch your character.

Refer to the Adding Colours chapter to learn more about adding colours to your project and using the Colour 
view.

Refer to the Pen View topic to learn more about how the Pen view functions.
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Tracing 

Once you have sketched a rough version of your design, the next step is to trace it. Tracing lets you determine the 
final look and line style of your drawing. Studio has many tools available for you to trace and perfect your drawing line.

To trace a drawing: 

1. Open the project containing the sketch to be traced.

2. In the Drawing Tools toolbar, select the Brush  tool. You can also press the [@,]  default keyboard shortcut.

3. In the Pen view, set the look of your brush:
 Click on the Brush Preview area and select the brush shape you want.

 Use the Maximum Size and Minimum Size slides to set the brush size variation. As you set your brush size, 
the Brush Preview area will display the minimum size of your brush in black and the maximum size in dark 
grey.

 You can also set the Smoothness value of the Brush tool. This option will smooth your brush stroke after you 
traced it. The higher the value, the more smoothness will be applied to your line.

4. In the Colour view, click on a default colour swatch you want to draw with. This will change the colour of the 
Brush  tool.

5. In the Timeline or Xsheet view, click on the Add Drawing Element  button to add a new drawing layer.
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6. In the Timeline or Xsheet view, select the cell of the new drawing layer corresponding to the frame your sketch 
is in.

7. In the Onion Skin toolbar, click on the Auto Light Table  button to see your sketch as a reference. You can 
also select View > Turn Auto Light Table On from the top menu. The default keyboard shortcut is [L].

Your sketch drawing layer will appear washed-out in the Drawing view.

8. Sometimes it helps to hide elements, specially when having many drawing layers. You can hide elements in the 
Drawing View, using the Exposure Sheet view, so that you can focus on a specific layer.
 In the Exposure Sheet view, select the column containing the drawing you want to hide and select 

Element > Display > Exposure Sheet > Hide from the top menu.
 To hide all the drawing columns except the currently selected ones, select 

Element > Display > Exposure Sheet > Hide All Others from the top menu.
 To show again the hidden columns, select 

Element > Display > Exposure Sheet > Show All Exposure Sheet Elements from the top menu.
9. In the Drawing view, trace your character.

10. You can use the Rotary Table to rotate your workspace in the same way as you would rotate a sheet of paper you 
were tracing on: 

 Press and hold [Ctrl]+[Alt] (Windows) or [Ctrl]+[] (Mac OS X) to display the rotary table and then click 
and drag inside the drawing view to rotate the workspace. 

 Select View > Reset Rotation or press [Shift]+[C], the default keyboard shortcut, to reset the rotation 
of the view.

Once you are comfortable using the Drawing tools, you can improve your line art using the Contour Editor 
tool.

Refer to the Adding Colours chapter to learn more about adding colours. 

Refer to the Pen View topic to learn more about how the Pen view functions.

Refer to the More Drawing Tools topic to learn more about the Contour Editor tool.
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Erasing Part of a Drawing 

The Eraser  tool is used to change part or all of your drawing. It is pressure sensitive, just like the Brush tool. 
Pressure sensitivity provides more precision if you have to erase parts of a drawing. Its parameters can be set in the 
Pen view, such as size, smoothness and eraser shape. 

To erase with the Eraser tool: 

1. In the Drawing Tools toolbar, select the Eraser  tool. 
You can also select Tools > Drawing Tools > Eraser from the top menu. 
 The default keyboard shortcut is [$].

2. In the Drawing or Camera view, erase parts of the drawing.

 You can also delete drawing objects by selecting them with the Select  tool and pressing [Delete].

 For further information on how to resize the Eraser tool, please refer to Setting Up the Brush and Eraser 
Tools, on page 81
78 



Chapter 4: Drawing and Design   
Selecting Drawing Objects 

The Select  tool is used to select drawing objects in the Drawing or Camera view and to apply basic 
transformations such as repositioning, rotating or scaling, using the different handles of the bounding box.

To select with the Select tool: 

1. In the Drawing Tools toolbar, select the Select  tool, you can also use the default keyboard shortcut [!].

2. In the Drawing or Camera view, select the drawing objects.
 You can select all the drawing objects in a drawing by using the default keyboard shortcut [Ctrl]+[A] 

(Windows) or []+[A] (Mac OS X).

To deform or reposition selected drawing objects:

 To reposition, click on the selected drawing object and drag the selection to a new area.

 To rotate, rotate the selection box handle.

Diagonal Scale

Vertical Scale

Horizontal Scale

Rotate
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 To scale, pull or push either on the size, top or corner control point. 
Hold down [Shift] to lock the scaling ratio.

While working with the Select tool, you can press and hold [Ctrl] (Windows) or [Alt] (Mac OS X) to temporarily 
switch to the Perspective tool, allowing further transformations. Refer to the Perspective Tool description in 
the More Drawing Tools topic to learn more.

Repositioning a Pivot Point 

Some of the transformations such as rotation, scale and flip, are done using the position of the pivot point as the 
central point. By default, this pivot point is situated in the centre of your selection. You can temporarily reposition this 

pivot point for a transformation using the Select  tool.

To temporarily reposition the pivot point: 

1. In the Drawing or Camera view, select the drawing object you want to transform.

The pivot point will appear in the middle of your selection.

2. Click on the pivot point and drag it to a new position.

This becomes the new position of the pivot point for the current transformation and will remain there until you 
make a new selection.

Pivot Point
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Pen View 

The Pen view lets you customize the size, smoothness or tip shape of the Brush , Eraser , Pencil , Shapes 

 and Polyline  tools.

Setting Up the Brush and Eraser Tools

The Brush  and Eraser  tools become pressure sensitive when using a pen tablet, meaning they will produce 
a thick and thin effect when drawing or erasing, depending on how hard you press on your pen. Therefore, unlike the 
Pencil tool, you can set a minimum and maximum brush size for this effect.

To set up the Brush or Eraser tool: 

1. In the Drawing Tools toolbar, select the Brush  or Eraser  tool.

2. In the Pen view, you can select a pen style from the Pen Style list. Refer to Managing Pen Styles to learn more 
about Pen Styles.

3. Use the Minimum Size and Maximum Size sliders to set the Minimum and Maximum brush sizes for the thick and 
thin effect. 

As you set your brush size, the Brush Preview area will display the Minimum size of your brush in black and the 
Maximum size in dark grey.

4. Use the Smoothness slider to set the smoothness value for your line. When you draw, Studio makes an 
adjustment to the line based on this value, it smooths out any sharp edges or jagged peaks in the line.
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5. Click on the Preview area and select a Brush tip shape from the selection of tip shapes in the pop-up menu.

Eraser and Brush Styles 

In the Pen Style list of the Pen view, there is a Brush  and Eraser  marker.

These markers show the active pen style linked to the Eraser tool, and the active pen style linked to the Brush, Pencil, 
Shapes and Polyline tools. When you switch from one type of tool to the other, the active pen style linked to it is 
automatically selected. This way you can quickly switch from the Eraser to the Drawing tool without having to change 
the settings in between. 

Setting Up the Pencil Tool

The Pencil  tool is not pressure sensitive and only has one value to set, unlike the Brush or Eraser tools which are 
pressure sensitive.

To set up the Pencil tool: 

1. In the Drawing Tools toolbar, select the Pencil  tool.

2. In the Pen view, you can select a pen style from the Pen Style list. Refer to Managing Pen Styles to learn more 
about Pen Styles.

3. Use the Maximum Size slider to set the Maximum brush size. 

As you set your brush size, the Brush Preview area will display a preview of your pencil.

4. Use the Smoothness slider to set the smoothness value for your line. When you draw, Studio makes an 
adjustment to the line based on this value, it smooths out any sharp edges or jagged peaks in the line.
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5. Click on the Preview area and select a Pencil tip shape from the pop-up shape menu.

Setting Up the Shape Tools and Polyline Tool
To customize the Shapes and Polyline tools size you only have to set one value.

To set the shapes and Polyline tools size: 

1. In the Drawing Tools toolbar, select the Line , Ellipse , Rectangle  or Polyline  tool.

2. In the Pen view, use the Maximum Size slider to set the size of your tool.

Changing the Thickness of a Centreline Object
You can use the Pen view to resize the thickness of existing centreline drawing objects, such as a Pencil lines, Shapes 
or Polylines.

To resize a centreline object stroke: 

1. In the Drawing Tools toolbar, select the Select  tool. You can also press the [!] default keyboard shortcut.

2. In the Drawing or Camera view, select the centreline drawing object you want to change the thickness of.

3. In the Pen view, use the Maximum Size slider to set the new thickness of your lines.
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Managing Pen Styles

There are five default Pen Styles that you can use, each of these styles can be edited. You can also add your own 
custom pen styles to the Pen Style list.

Adding a Pen Style
To Create a Pen Style: 

1. In the Pen view, click on the Add Pen Style  button. A new Pen Style is added at the end of the pen style list, 
this new pen style is based on the previously selected style.

2. Double-click on your new pen style to rename it.

3. Set the desired values for your new pen style, such as Minimum and Maximum Sizes, Smoothness and Brush tip 
shape.

Editing a Pen Style
To edit a pen style: 

1. In the Pen view, select the pen style you want to edit.

2. In the Pen Style list, you can double-click on a pen style to rename it.

3. Set the values you want for the pen style, such as Minimum or Maximum size, Smoothness and Brush tip shape.

Removing a Pen Style
1. In the Pen view, select the pen style you want to remove.

2. Click on the Remove Pen Style  button to delete it from the list.
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Drawing Invisible Lines

Using the Pencil tool, you can also draw as strokes only, meaning that the line will be invisible. This can be useful to 
draw tones and highlights directly on the character. 

To draw invisible lines with the Pencil tool:

1. In the Timeline or Exposure Sheet view, select the cell where you want to draw.

2. In the Drawing Tools toolbar, click on the Pencil  tool. You can also access the Pencil tool by going to 
Tools > Drawing Tools > Pencil. You can also use the default keyboard shortcut [2], to cycle through tools.

3. In the Top menu, select View > Show Strokes. The default keyboard shortcut is [K]. This makes the lines visible 
enabling you to see them as you draw.

4. In the Pen Style view, set the Pen tool maximum size to “0”. You can also adjust the smoothness.

5. In the Camera or Drawing view, start drawing.

 You can modify the stroke shape with the Contour Editor  tool. Refer to the More Drawing Tools topic 
to learn how to use the Contour Editor tool.

 You can also draw with invisible lines using the Stroke  tool. However, you will not be able to control the 
smoothness value for your line.

To select the Stroke tool:

 In the Drawing Tools toolbar, click on the Stroke  tool. You can also access the Pencil tool by going 
to Tools > Drawing Tools > Stroke. You can also use the default keyboard shortcut [3], to cycle through 
tools.
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Working With Text 
With the Text tool, you can type text in your project, using various fonts and texts attributes. Text objects are part of 
a drawing, so you can manipulate them the same way.

Creating Text 
To add text to your drawings: 

1. In the Drawing Tools toolbar, select the Text  tool. You can also select 
Tools > Drawing Tools > Text from the top menu or press the [T] default keyboard shortcut.

2. In the Timeline view, select the cell containing the drawing you want to add text to.
3. In the Drawing or Camera view, click on the location you want your text to begin.

4. You can use the Text view to select the font, font size and format the text you will type. To learn more see the 
next topic Formatting the Text. 

5. Type in the desired text.

6. If you want to create another text object, click outside the currently active text box. You can always return to edit 

the text by selecting the Text  tool and clicking in the text.
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Formatting the Text
Use the Text view to select the font type and other formatting options you want to apply to the text.

1. Font Type 
Use this drop-down menu to select the desired font, from the list of font available in your system.

2. Font Size 
Type the desired size for the text in this field. You can also use the up and down arrow buttons to set the desired 
value.

3. Font Style 
Use these buttons to select a desired style for your text:

  Bold

  Italic

4. Kerning 
Use the kerning field to modify the spacing between characters. You can select the Auto Kern option to set the 
kerning automatically, based on the font’s predefined standard. A negative value decreases spacing between 
each character and a positive value increases it.

5. Alignment 
Use these buttons to align the paragraph.

  Left

  Centred 

  Right

  Justified

6. Indent 
Enter a value in the Indent field to increase or decrease the indentation on the first line of your text. A positive 
value sets the first line of your paragraph farther to the right and a negative value sets it farther to the left. 

7. Line Spacing 
Enter a value in the Line Spacing field to decrease or increase the space between each line of text.

1

32

4

5
6
7
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Converting Text into Separate Objects 
Text contained in a text field is treated as a single drawing object. You can easily separate the text so that each 
character becomes an individual drawing object that you can select and modify independently.

To break a text object: 

1. In the Drawing Tools toolbar, click on the Select  tool. You can also use the [!] default keyboard shortcut.

2. In the Drawing or Camera view, select the text object you want to break.

3. Select Tools > Break Text Apart.

Each character is now surrounded by its own bounding box that you can modify, they remain text objects that 
you can edit.

4. Select Tools > Break Text Apart, once more, on a single character text to break it into a regular drawing object, 
with no more text attributes. 
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More Drawing Tools
Toon Boom Studio provides some other useful drawing tools:

• Shape Tools, on page 89
• Polyline Tool, on page 90
• Contour Editor Tool, on page 91
• Perspective Tool, on page 93
• Cutter Tool, on page 94
• Scissor Tool, on page 95

Shape Tools 
In Toon Boom Studio, you can use the shape tools to draw with circles, squares or lines. 

To draw with a shape tool: 

1. In the Timeline view, select the cell you want to draw in.
2. In the Drawing Tools toolbar, select one of the Shapes tool:

  Ellipse tool: You can also select Tools > Drawing Tools > Ellipse from the top menu or press [2], the 

default keyboard shortcut, to cycle through the tools. 

  Rectangle tool: You can also select Tools > Drawing Tools > Rectangle from the top menu or press 

[2], the default keyboard shortcut, to cycle through the tools.

  Line tool: You can also select Tools > Drawing Tools > Line from the top menu, or press [2], the 

default keyboard shortcut, to cycle through the tools.
3. In the Pen view, set the size of your shape’s line using the Maximum slider.

4. You can change the colour of the shape’s line using the default colour swatches in the Colour view.

5. In the Drawing or Camera view, click and drag to draw your shape.

 Hold down [Shift] to lock the rectangle or the ellipse ratio to 1:1, this will create a square or circle.
 Hold down [Alt] to draw the rectangle or ellipse from its centre.
 Hold down [Shift] to snap the line at 15 degree increments.
 Hold down [Alt] to connect the starting point of the line you are drawing to the ending point of the previous 

one.

Refer to the Pen View topic to learn more about Pen view.

Refer to the Adding Colours chapter to learn more about adding colour and using the Colour view. 
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 Polyline Tool
The Polyline tool is used to draw shapes. Just like the Pencil and Shape tools it is a central vector type of line. To form 
a shape, you need to click to add a point and then, without releasing the mouse, drag to pull the handle in the desired 
direction before adding the next point and repeating the same operation.

To use the Polyline tool: 

1. In the Timeline view, select the cell where you want to draw your polyline shape.
1. In Drawing Tools toolbar, select the Polyline tool. 

You can also select Tools > Drawing Tools > Polyline from the top menu or press [1], the default keyboard 
shortcut, to cycle through the tools.

2. In the Pen view, set the size of the polyline using the Maximum slider.

3. You can change the colour of the polyline using the default colour swatches in the Colour view.

4. In the Drawing or Camera view, click and drag to create a starting point and a Bezier handle to shape your line.
 Press [Alt] to pull only one handle, instead of two.
 Press [Shift] to lock the handles to 45, 90, or 180 degrees.

5. Click again in a new area and drag the mouse to create a second point and Bezier handle. 

6. Repeat the previous step until the shape is completed.
7. To close a shape so that there are no gaps:

• Place your pointer over a point and click. 
An “o” appears when you are adding a point that will close a shape.

• Place your pointer over any location on the shape you are drawing and click.
A “+” will appear when your pointer is over a spot you can use to close the shape.
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8. To remove a control point on the line, press [Shift] and click on the point.
A “-” will appear when your pointer is over a point to delete.

9. If necessary, you can use the Contour Editor  tool to reshape the line.

 Refer to the Contour Editor Tool to learn more about this tool.

 Contour Editor Tool
The Contour Editor tool is used to correct line shapes and to modify part of a colour zone. If a line is too thin or has 
a gap in it, you can modify and correct it with this tool. This tool can also be used to create elaborate shapes from a 
simple one.

The Contour Editor displays the vector points around a shape and the central vector point in a pencil line. Pulling or 
Pushing on these points adjusts a brush line’s thickness or a central vector shape. 

To use the Contour Editor tool: 

1. In the Drawing Tools toolbar, select the Contour Editor  tool. You can also select 
Tools > Drawing Tools > Contour Editor from the top menu or press [1], the default keyboard shortcut, to cycle 
through the tools.

2. In the Drawing or Camera view, click on the shape’s line or on a pencil line to edit it.

3. Select one point or several points by clicking on them or circling around them.

4. To modify the shape, you can:
 Pull on the Bezier handle. Both point’s handles will move as one.

 Hold down [Alt] (Windows) or [] (Mac OS X) and pull on one of the Bezier handles. The point’s handles will 
move independently from the other one.
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 Move the selected points to a new area.

 Pull directly on the line in-between two points. No selection is necessary.

 Hold down [Ctrl] (Windows) or [Alt] (Mac OS X) and click on the line to add a new control point.

 Select a control point and press [Delete] to delete it.

Snap to Contour

When using the Contour Editor  tool, you can enable the Snap to Contour option to snap the selected control 

point to the vector line.

To enable and use the Snap to Contour option: 

1. In the Drawing Tools toolbar, select the Contour Editor tool.
2. Select Tools > Snap to Contour to enable the option. A check will appear beside the enabled command.
3. Select a Control Point and as you move it you will feel it is attracted to the contour lines. Releasing the point on 

the line snaps it to it.
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 Perspective Tool

The Perspective tool is used to deform a selection and alter its perspective.

To deform a drawing object:

1. In the Drawing Tools toolbar, select the Perspective  tool. You can also select 
Tools > Drawing Tools > Perspective or press [1], the default keyboard shortcut to cycle through the tools.

2. In the Drawing or Camera view, select the drawing objects you want to deform.
3. Click and drag the bounding box’s anchored points to deform it.

You can press and hold [Ctrl] (Windows) or [] (Mac OS X) while using the Select  tool to temporarily 

switch to the Perspective  tool. Refer to Selecting Drawing Objects topic to learn more about the Select 

tool.
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 Cutter Tool

The Cutter tool is used to cut a part of your drawing and separate it from the rest, it does this by creating a vector 
stroke that lets you split the shape. You can show the vector strokes which make up your drawing and visualize the 
vector line drawn by the Cutter tool as you draw it. 

To use the Cutter tool: 

1. In the Drawing Tools toolbar, select the Cutter  tool. 
You can also select Tools > Drawing Tools > Cutter from the top menu or press [4], the default keyboard 
shortcut, to cycle through the tools.

2. Select View > Show Strokes from the top menu or press [K], the default keyboard shortcut to display the vector 
lines composing your drawing.

3. In the Drawing or Camera view, draw the separation line on your drawing.

4. Once you split your drawing, you can use the Select  tool to select the separated part and reposition or 

transform it.

Refer to the Selecting Drawing Objects topic to learn more about the Select  tool.
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 Scissor Tool

The Scissor tool is used to cut a selection inside a drawing object and reposition or transform it right-away without 
switching tool.

To cut parts from a drawing using the Scissor tool: 

1. In the Drawing Tools toolbar, select the Scissor  tool. 
You can also select Tools > Drawing Tools > Scissor from the top menu or press [4], the default keyboard 
shortcut, to cycle through the tools.

2. In the Drawing or Camera view, click and drag to create a square selection to cut inside your drawing. You can 
press and hold [Alt] (Windows) or [] (Mac OS X), the default keyboard shortcut, to make a lasso selection.

3. Use the Scissor tool to move, scale, rotate or translate the drawing piece. If you deselect the cut piece, or the 
Scissor tool, the cut area will disappear and the object will remain whole.
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More Drawing Options
Toon Boom Studio provides many useful drawing and design options.

• Group and Ungroup, on page 96
• Smooth, on page 97
• Optimize, on page 98
• Flatten and Optimize, on page 97
• Transform, on page 99
• Arrange, on page 100
• Show Current Drawing on Top, on page 100

Group and Ungroup

In Toon Boom Studio, each stroke in a drawing can be selected independently until they are flattened, but then each 
different colour shapes still remain independent from one another. It is useful to be able to edit your drawing one 
shape at a time, but depending on the current task, it might be useful to be able to quickly select a grouping of these 
strokes.For example, when you need to reposition or transform the entire head of a character, you do not want to 
drop the nose or an eye.

To group drawing objects: 

1. In the Drawing Tools toolbar, click on the Select  tool. You can also access this Select tool by going to 
Tools > Drawing Tools > Select or press the [!] default keyboard shortcut.

2. In the Drawing or Camera view, select the drawing objects you want to group together. If you want to select all 
the shapes contained in your drawing, you can use the default keyboard shortcut [Ctrl]+[A] (Windows) or []+[A] 
(Mac OS X).

3. Select Tools > Group or you can press [Ctrl]+[G] (Windows) or []+[G] (Mac OS X). 

Now your drawing objects are grouped and will be all selected with a single click.

NOTE: Grouping is reversible, you can always ungroup selected drawing objects and select the shapes independently.
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To ungroup drawing objects: 

1. In the Drawing Tools toolbar, click on the Select  tool. You can also access the Select tool by going to 
Tools > Drawing Tools > Select or press the [!] default keyboard shortcut.

2. In the Drawing or Camera view, select the grouped drawing objects you want to ungroup and select 
Tools > Ungroup or you can press [Ctrl]+[Shift]+[G] (Windows) or []+[Shift]+[G] (Mac OS X).

Smooth
The Smooth operation is used to smooth out a selected drawing object and remove extra vector points.

To use the Smooth operation: 

1. In the Drawing or Camera view, select your drawing object you wish to smooth using the Select  tool.

2. Select Tools > Smooth from the top menu.

Flatten and Optimize
The Flatten and Optimize operation acts similar one to another. They are used to merge shapes and brush strokes of 
a same drawing into a single flat layer. If you draw lines to fix a drawing or a line with many brush strokes, or draw a 
complex shape from many different shapes superposed, it can be useful to flatten them all into a single shape because 
lines are drawn one of top of each other, if you intend on repainting the shape or line or modifying it, it will be easier 
if they are merged together as one.

Flatten
The Flatten operation is used to merge shapes and brush strokes of a drawing into a single flat layer.

This means that if you have shapes or strokes of a transparent colour, you will lose the overlapping effect.

To use the Flatten operation: 

1. In the Drawing or Camera view, select the drawing objects you wish to flatten using the Select  tool. If you 

want to select every shape in your drawing, you can press [Ctrl]+[A] (Windows) or []+[A] (Mac OS X), the 
default keyboard shortcut to select all.

2. Select Tools > Flatten from the top menu.
 Shapes of the same colour will be merged together. In this example, the two circles overlapping one 

another were painted using a transparent colour.

 Shapes of different colours will remain separate. In this example, the two circles overlapping one another 
were painted using two different transparent colours. The green circle on the right was painted on top of 
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the blue circle on the left. When they are flattened, the parts overlapped by a higher level layer shape are 
removed, in this case, leaving the blue circle cropped.

When drawing with the Brush  tool, you can also decide to instantly flatten the strokes as you draw them using 
the Draw Top Layer option.

To enable the Draw Top Layer option: 

 Select Tools > Draw Top Layer from the top menu. A check appears next to the command when it is 
enabled. 

To disable the Draw Top Layer option:

 When the option is enabled, select Tools > Draw Top Layer from the top menu.

Optimize
The Optimize operation is used to merge shapes and brush strokes of a same drawing into a single flat layer. Unlike 
the Flatten option, the Optimize command will merge the selected drawing shapes or strokes only if merging them 
will not change the appearance of the final image. 

If you have transparent shapes overlapping one another, they will not be merged or flattened preserving the 
transparent overlapping effect. 

To use the Optimize operation: 

1. In the Drawing or Camera view, select the drawing objects you want to optimize using the Select  tool. To 

select every shape in your drawing, you can press [Ctrl]+[A] (Windows) or []+[A] (Mac OS X), the default 
keyboard shortcut to select all.

2. Select Tools > Optimize from the top menu.
 Every overlapping shape of the same non-transparent colour will be merged together.
 Every overlapping shape of different non-transparent colours will be merged and cropped.
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Transform
Use the different Transform operations to apply a specific transformation such as a flip or a rotation to a drawing shape 
selection.

To use the Transform options: 

1. In the Drawing or Camera view, select the drawing object you wish to flip using the Select  tool. If you want 

to select every shape in your drawing, you can press [Ctrl]+[A] (Windows) or []+[A] (Mac OS X), the default 
keyboard shortcut to select all.

2. Select Tools > Transform > Flip Vertical or Flip Horizontal from the top menu.
 Flip Horizontal 

This will horizontally flip the currently selected shape.

 Flip Vertical 
This will vertically flip the currently selected shape.

 Rotate 90 CW 
This will rotate the currently selected shape clockwise 90 degrees.

 Rotate 90 CCW 
This will rotate the currently selected shape anti-clockwise 90 degrees.

 Rotate 180 
This will rotate the currently selected shape 180 degrees.
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Arrange

Use the various Arrange options to reorder the shapes and strokes of a drawing.

To reorder shapes in your drawing: 

1. In the Drawing or Camera view, use the Select  tool to select the drawing objects you want to reorder.

2. Select Tools > Arrange > Bring to Front, Bring Forward, Send to Back or Send Backward from the top menu.
 Bring to Front

Brings the currently selected shape on top of all the others.
 Bring Forward

Brings the currently selected shape one level higher.
 Send to Back

Sends the currently selected shape under all the others.
 Send Backward

Sends the currently selected shape one level lower.

Show Current Drawing on Top
By default, the Show Current Drawing on Top option is enabled. This means that when you are working in the Camera 
view with a drawing tool, the selected drawing is automatically displayed on top of all the others. This facilitates 
editing. 

If you need to work on the selected drawing while seeing the final composition of your scene, it is necessary to place 
the drawing in the correct order compared to all of the others in the scene. You can do this by enabling the Show 
Current Drawing on Top option. 

In the following example the belly of the turtle was selected.

To enable and disable the Show Current Drawing on Top:

 When the option is enabled, select View > Show Current Drawing on Top to disable it.
 When the option is disabled, select View > Show Current Drawing on Top to enable it.

Enabled Disabled
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Preferences
You can customize some options in the Toon Boom Studio Preferences panel. Here are the options related to Drawing 
and Designing:

• Window Background Colours, on page 101
• Light Table, on page 102

To open the Preferences panel:

 Windows:
Select Edit > Preferences from the top menu.

 Mac OS X:
Select Toon Boom Studio 7.1 > Preferences from the top menu. 

Window Background Colours 
You can change the background colour of the Drawing view. You may want to do this if you are drawing with very light 
colours.

To change the colour of the Drawing view:

1. In the Preferences panel, click on the Interface tab.

2. In the Window Background Colours section, click on the square beside Drawing.
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The Select Colour dialog box opens.

3. Choose a colour.
4. Click OK in the Select Colour dialog box, 
5. Click OK in the Preferences panel.

The Drawing view background colour will change to the selected colour. 

Light Table 
You can change the way the drawings are displayed when using the Autoight Table option.

To choose the Automatic Light Table option:

1. In the Preferences panel, click on the LightTable tab.

2. In the Automatic LightTable section:

 Click in the Enable Shade check box to enable this option and display the other columns drawings as 
washed out colours when you are using the Automatic Light Table.

 Disable the Enable Shade check box to display the other columns drawings with their real colours when you 
are using the Automatic Light Table.

3. Click on the OK button.
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What’s Next?
So far you have learned about:

• Drawing in Toon Boom Studio
• Sketching in Toon Boom Studio
• Tracing in Toon Boom Studio
• Some designing basics
• Using various drawing tools and drawing options in Toon Boom Studio.

It is now time to learn about importing artwork, so you can start to gather up elements for your project.
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Chapter 5  Adding Colours

With Toon Boom Studio, you can add colour to your projects and even create sets of colours for your characters. These 
sets of colours are called colour palettes. With these palettes, you will discover that adding colours to your movie is 
one of the easiest and useful steps in the process!

In this chapter, you will learn about the following:

• How to Paint, on page 106
• Colours, on page 107
• Colour Display Modes, on page 120
• Using the Painting Tools, on page 121
• Closing Gaps, on page 125
• Selecting a Colour in a Drawing, on page 128
• Editing Gradients and Textures, on page 129
• Palettes, on page 132
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How to Paint 
Follow these very simple instructions to learn how to paint your drawings. Once you master this operation you will be 
able to try all the tools and features explained below.

To paint your drawings: 

1. In the Drawing Tools toolbar, select the Paint  tool. The default keyboard shortcut is [#]. You can also select 
the Paint tool from the top menu Tools > Drawing Tools > Paint.

2. In the Colour Palette view, select a colour from the palette.

3. In the Camera or Drawing view, start painting the colours on your drawing.
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Colours 

In Toon Boom Studio, you use different colour swatches to paint your drawings, not just one swatch that you modify 
the tint of each time you want to paint a zone with a different colour. A colour swatch can also be called a colour pot.

In the Colour Palette view, you choose a different colour swatch for each colour you want to paint in your drawing. 
You can add as many swatches as you want. You can also rename them or modify existing ones.

When you modify the colour of an existing swatch, it automatically updates all the zones painted with this swatch 
throughout the entire project. The colour swatch has a unique identification number that associates it with the painted 
zones. This way, you can change the look of your character at anytime without having to repaint it!

This topic is divided as follows:

• Adding a Colour Swatch, on page 108
• Deleting a Colour Swatch, on page 119

Grey Bear Blue Bear
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Adding a Colour Swatch 
You can create three different types of colour swatches:

• Solid Colour Swatch, on page 108
• Gradient Colour Swatch, on page 113
• Bitmap Texture Swatch, on page 117

Solid Colour Swatch

To add or modify a solid colour swatch using Windows: 

1. In the Colour Palette view, click on the Add Colour  button. You can also click on the Menu  button and 
select Colour > Add Colour.

2. To edit your colour, click on the Menu  button and select Colour > Edit Colour. You can also double-click on 

the colour pot or click on the Edit Colour  button.

The Colour Picker window opens.

3. To set your colour:
 Select the colour you want from the colour wheel.

OR
 Type in the HSV or RGB value in the value fields. Click on the R,G,B,H,S or V radio buttons to change the 

look of the colour picking area.
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OR

 Click on the Dropper  button to select any colour on your screen. It can be from the Studio’s interface, 
your Operating System or any other opened application. 

4. If needed, click on the Shade Scale’s swatches to modify the shade of the selected colour. 

5. If necessary, adjust the level of transparency with the Alpha slider, or type the value directly in the Alpha field. 
The value “0” will give you a completely transparent colour and the value “255” will give a completely opaque 
colour. Anything in-between these two values will give you a more or less semi-transparent colour.

6. If necessary, select the new colour from the Colour Display area and drag it to the Colour Storage Library, so you 
can quickly access it later.

7. You can rename the colour swatch in the Colour Picker window or directly in the colour list by double-clicking on 
its name.
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To add or modify a solid colour swatch using Mac OS® X: 

1. In the Colour Palette view, click on the Add Colour  button. You can also click on the Menu  button and 
select Colour > Add Colour.

2. To edit your colour, click on the Menu  button and select Colour > Edit Colour. You can also double-click on 

the colour pot or click on the Edit Colour  button.

The Colors window opens.

3. Use the top buttons to select one of the five colour picker display modes:

  Colour Wheel

  Colour Slider

  Colour Palettes

  Image Palettes

  Crayons

4. To select a colour from the Colour Wheel display mode:

 Pick the colour you want from the colour wheel.
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 If needed, use the Shade Scale’s slider to modify the shade of the selected colour. 

5. To select a colour from the Colour Slider display mode:

 From the slider type drop-down list, select which type of slider you want to use:

 Gray Scale Slider

 RGB Sliders

 HSB Sliders

 Use the sliders to select a colour. You can also type in the values directly into the fields.
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6. To select a colour from the Colour Palettes display mode:

 Using the palette drop-down list, select a system palette you want to display. These are system palettes, 
they are not linked to Toon Boom Studio.

 From the Palette Menu  button:
 Select New to create a new system palette.
 Select Open to open a system palette stored on your computer.
 Select Rename to rename to current palette. Note that you can not rename an apple default palette.
 Select Remove to delette the current palette. Note that you can not remove an apple default palette.

 Use the + button to Add a new colour swatch to a palette you created. Note that you can not add colours 
to one of apple’s default palettes.

 Use the - button to Remove a colour swatch from a palette you created. Note that you can not remove  
colours from one of apple’s default palettes.

 Type a letter in the search field to narrow down the list to only swatch name containing this letter to help 
you find a particular colour from the current palette colour list.

7. To select a colour from the Image Palettes display mode:

 From the Image drop-down list, you can select the image you wish to display in the main space. By default 
only the Spectrum image is available. Once you start adding pictures, they will be added up to the list.

 From the Palette drop-down menu:
 Select New from File to browse to a picture of your choice to be displayed in the main space.
 Select Rename to rename the current picture. This is the name that will appear in the Image drop-list. 

Note that you can not rename an Apple default picture.
 Select Remove to remove the current picture. Note that you can not remove an Apple default picture.
 Select Copy to add the current image to your clipboard.
 Select New from Clipboard to use a copied image file or a selection within an image, still stored in your 

clipboard.
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8. To select a colour from the Crayons display mode:

 Click on a crayon from the image to select that colour.

9. In all of the colour picker display mode, you can also:
 Click on the Magnifier to select any colour on your screen. It can be from the Studio’s interface, your 

Operating System or any other opened application.

 If necessary, adjust the level of transparency with the Opacity slider, or type the value directly in the 
pourcentage field. The value “0” will give you a completely transparent colour and the value “100” will give 
a completely opaque colour. Anything in-between these two values will give you a more or less semi-
transparent colour.

10. You can rename the colour swatch in the Colour Palette view colour list by double-clicking on its name.

Gradient Colour Swatch

To create a gradient colour swatch using Windows: 

1. In the Colour Palette view, select the colour to be modified.
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2. Click on the Colour Palette Menu button and select Colour > Edit Colour. You can also double-click on the 
colour swatch.

The Colour Picker window opens.

3. Enable the Gradient option.

4. Select the Linear or Radial option.
5. Select the Gradient arrows to modify the colours.

 Click between the arrows to add extra colours.

 Pull down the arrows to remove them.

 Move the arrows left and right to modify the gradient distance.

To create a gradient colour swatch using Mac OS X.  

1. In the Colour Palette view, select the colour to be modified.
2. Click on the Colour Palette Menu button and select Colour > Edit Colour. You can also double-click on the 

colour swatch.
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The Colours window opens.

3. Enable the Gradient option.

4. Select the Linear or Radial option.
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5. Select the Gradient arrows to modify the colours.

 Click between the arrows to add extra colours.

 Pull up the arrows to remove them.

 Move the arrows left and right to modify the gradient distance.

6. By default the Deformable by Skeleton option is enabled. This means that when creating a skeleton puppet 
animation, the gradient will be deformed following the bones. You can disable this option is you want the 
gradient to stay as it is. Refer to Chapter 10: Bones, on page 251 to learn more about Skeletons and Bones.
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Bitmap Texture Swatch 

To create and edit a texture colour: 

1. In the Colour Palette view, click on the Menu  button and select Colour > Add Texture.

2. Browse for any bitmap file created in a third party software.

3. Click on the Open button to create the colour swatch.

4. In the Colour Palette view, select the texture swatch that you want to modify the texture of.
5. Double-click on the colour swatch to edit.

The Texture Properties dialog box opens.

6. To rename the colour swatch, type a new name in the Name field.
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7. Disable the Tile option if you want the texture to automatically scale up to the size of the painted zone. Enable 
the Tile option if you want your image to repeat over and over inside the drawing zone.

8. Click on the OK button once the operation is completed.

 Refer to the Editing Gradients and Textures topic to learn how to reposition textured zones in your drawings.

You can also replace a texture once it is painted. For instance, if you decide to make the character’s suit a dark 
granite colour instead of pink cotton, just update the texture file in the swatch and the entire project updates. 

Any transformation previously applied to the texture’s position in your drawings will be kept.

To replace a texture swatch: 

1. In the Colour Palette view, select the texture swatch you want to modify the texture of.

2. Double-click on the colour swatch to edit.

The Texture Properties dialog box opens.

3. Click on the Browse button.

The Browse window opens.

Tile Option Disabled Tile Option Enabled
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4. Browse for any bitmap file created in a third party software.

5. Click on the Open button to update the colour swatch.
6. Click on the OK button to complete the operation.

Deleting a Colour Swatch
If a colour is not needed in a project, you can delete it from the list to avoid having too many colour swatches in your 
Colour Palette view.

To delete a colour swatch: 

1. In the Colour view, select the colour swatches to delete.

2. In the Colour Palette view, click on the Delete Colour  button. You can also click on the Menu  button 
and select Colour > Delete Colour.
 If you delete colour swatches already in use, the zones painted with them turn red so you can easily identify 

them.

Deleted Colour
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Colour Display Modes 
The Colour Palette view can display the colour swatches in two different ways:

• List Mode
• Swatch Mode

To toggle between the display modes: 

 In the Colour Palette view, click on the Show/Hide Colour Names  button to toggle between the two modes. 

You can also click on the Menu  button and select
Show/Hide Colour Names.

List Mode Swatch Mode
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Using the Painting Tools 
The main tool you will use to paint your drawings with is the Paint  tool. Other painting tools are also available to 
make your painting process easier and faster.

The painting tools only paint closed zones. If you have gaps in your lines, you will have to close them using either the 
Brush, Pencil, Close Gap tools or the Automatic Close Gap option.

This topic is divided as follows:

• Painting with the Paint Tool, on page 122
• Painting with the Paint Unpainted Tool, on page 123
• Unpainting Areas with the Unpaint Tool, on page 124

Opened gap. The zone cannot be painted.Closed area. The zone can be painted
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Painting with the Paint Tool
To paint with the Paint tool: 

1. In the Timeline or Xsheet view, select the drawing you want to paint.

2. In the Drawing Tools toolbar, select the Paint  tool. The default keyboard shortcut is [#]. You can also select 
the Paint tool in the top menu under
Tools > Drawing Tools > Paint.

3. In the Colour Palette view, select a colour.

4. In the Drawing or Camera view, start painting by clicking in the different closed zones.
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Painting with the Paint Unpainted Tool

The Paint Unpainted tool only paints empty zones. Any line or filled zone will remain unchanged. For example, if you 
are painting a cow or a leopard, this tool is very useful when it is time to paint all the spots on the body. Instead of 
trying to click in each one of them, you can draw a large selection around the body to paint all the spots at once. All 
the empty zones will be painted and all the filled zones will remain untouched.

To paint with the Paint Unpainted tool: 

1. In the Timeline or Xsheet view, select the drawing you want to paint.

2. In the Drawing Tools toolbar, select the Paint Unpainted  tool, under the Paint tool category. You can also 

select the Paint Unpainted tool from the top menu under Tools > Drawing Tools > Paint Unpainted.
3. In the Drawing or Camera view, draw a wide selection containing all the zones to paint.
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Unpainting Areas with the Unpaint Tool

The Unpaint tool unpaints everything it touches. You can use it to unpaint zones you have painted by mistake, or to 
simply unpaint a drawing.

To unpaint a drawing with the Unpaint tool: 

1. In the Timeline or Xsheet view, select the drawing you want to unpaint.

2. In the Drawing Tools toolbar, select the Unpaint  tool, under the Paint tool category. You can also select the 

Unpaint tool from the top menu Tools > Drawing Tools > Unpaint.
3. In the Drawing or Camera view, click on the zones to unpaint.
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Closing Gaps 

When painting, you will notice that some of your drawing areas are not closed. To close the zone, you can draw the 
missing line with the Brush or Pencil tool. You can also close the gap with an invisible line. To do so, you can use the 

Close Gap  tool or the automatic close gap feature.

What is a Gap?

A gap is a hole or break in your lines causing a zone to be opened, therefore not paintable. You can often find gaps 
where lines intersect or if you erased a portion of the line accidently.

Closing Holes with the Close Gap Tool
The Close Gap tool is used to close small gaps in a drawing. The Paint tool only paints closed areas. The Close Gap 
tool will create a small, invisible stroke between the two closest points to close the colour zone. You do not need to 
trace directly over the gap. You can draw it a few millimetres away and the Close Gap will automatically choose the 
two closest points and close the gap.

To use the Close Gap tool: 

1. In the Drawing Tools toolbar, select the Close Gap  tool under the Paint tool category. You can also select 

the Close Gap tool from the top menu under Tools > Drawing Tools > Close Gap.
 You can display the invisible lines with the Show Strokes option under View > Show Strokes. The default 

shortcut is [K].
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2. In the Camera or Drawing view, draw an invisible line near to the gap to be closed. The gap will automatically 
close.

The new invisible line closing the gap appears.

3. In the Drawing or Camera view, paint the newly closed zone.

Invisible lines (strokes) are only visible when you
enable the Show Strokes option from the View menu.
When you disable the option, you cannot see the strokes,
but the lines are still there, so you can still paint your drawing.
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Closing Holes using Automatic Close Gap 
The Auto Gap option is used while painting drawings with small gaps. Instead of having to close them manually either 
with the Brush tool or Close Gap tool, Studio will analyze the drawing and close the gaps while you paint according 
to the selected mode.

The Auto Gap option has four modes available:

• No Close Gap 
No opened zones, regardless of the zoom level, will be painted.

• Close Small Gap 
Only the zones with very small gaps in the lines will be painted. Larger gaps will not be painted.

• Close Medium Gap 
Zones with small and medium gaps will be painted. The zones with larger gaps will not be painted.

• Close Large Gap 
Zones with small, medium and large gaps will be painted. Although, zones with very wide gaps will not be 
painted.

The automated gap closing is done using the zoom level of your Camera or Drawing view. If your eye does not see 
the gap, Studio won’t either. If the gap is too big in the Camera or Drawing view, Studio will not close it and the zone 
will not be painted.

Zooming out in your Camera or
Drawing view makes the gap appear
smaller and the Auto Gap option
will help you paint the zone without having
to close it manually.
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Selecting a Colour in a Drawing 
While working in your Camera or Drawing view, you may need to pick a colour from your drawing without going to 
the Colour Palette view, especially if you do not know which colour swatch it is. To do so, you will use the Dropper 

 tool.

Once you select your colour on your drawing using the Dropper tool, the colour swatch will be automatically selected 
in the Colour Palette view.

To use the Dropper tool: 

1. In the Drawing Tools toolbar, select the Dropper  tool, under the Paint tool category. You can also select the 
Dropper tool from the top menu under Tools > Drawing Tools > Dropper.

2. In the Camera or Drawing view, click on the colour zone you want to select the colour from.
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Editing Gradients and Textures 

There are two ways to position your gradient and textures when you paint a drawing. You can do it when you paint 

with the Paint tool or afterwards using the Edit Texture  tool.

Setting a Gradient or Texture with the Paint Tool
When you paint a zone with a gradient or bitmap texture colour swatch, you can position and orient the colour in the 
zone directly with the Paint tool by tracing a selection in the direction you want the gradient or texture to be.

To set a gradient or texture with the Paint tool: 

1. In the Drawing Tools toolbar, select the Paint  tool. The default keyboard shortcut is [#]. You can also select 
the Paint tool in the top menu under Tools > Drawing Tools > Paint.

2. In the Colour Palette view, select a gradient or texture swatch.
3. In the Drawing or Camera view, click in the zone to be painted and drag a selection in the direction you want the 

gradient or texture to be. The length of your selection will also determine the size and centre of your texture or 
gradient.
129



Toon Boom Studio User Guide
Setting a Gradient or Texture with the Edit Texture Tool 
If you paint a zone with a gradient or texture colour you can use the Edit Texture tool to modify its position in the 
zone. You can move, scale, rotate and skew. If you have to match the colour to the animation, you can set the first 
texture position and copy the Edit Texture’s position. When moving to the next drawing, you can select the next 
texture and paste the previous position to continue the modifications.

To use Edit Texture tool:

1. In the Drawing Tools toolbar, select the Edit Texture  tool under the Paint category. You can also select this 
tool from the top menu under Tools > Drawing Tools > Edit Texture.

2. Click on the Gradient or Texture zone to be modified.

Texture

Radial GradientLinear Gradient
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3. Move the edit texture’s anchor points to obtain the look you want.

 If the same modification needs to be applied to another gradient in another drawing or texture zone, you 
can select the modified zone and select Edit > Copy. 

 Select the zone to be modified in the other drawing and select Edit > Paste. 

Rotation

Position

Scale

Copied zones

Original zone
131



Toon Boom Studio User Guide
Palettes 

Toon Boom Studio uses colour palettes to add colour to your project.

The idea behind a colour palette is to create a set of colours for each character, object or background that you will 
reuse each time you have a new drawing to paint. If you create a teddy bear character, you will create a teddy bear 
colour palette that you will use each time that character appears in your project. 

You will not use that teddy bear palette to paint a bedroom background or a doll. You would create new palettes 
specifically for each of those. This way, colours never get mixed up and your character is always the same colour 
scheme. It also makes your work more organized.

Using a colour palette has many benefits, including:

• Characters consistently retain dedicated colours
• You cannot accidentally use a colour which is not in the palette
• Standardization and colour consistency throughout the project
• The results are repeatable, no matter who uses the colour palette

A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette and 
add a new colour, known as a colour swatch, for each zone on the character, such as the skin, hair, tongue, shirt, pants, 
etc.

This topic is divided as follows:

• Creating a Colour Palette, on page 133
• Deleting a Colour Palette, on page 134
• Duplicating a Colour Palette, on page 135
• Creating a Palette Style, on page 136
• Assigning a Style, on page 137
• Deleting a Style, on page 137
• Mixing the Colours, on page 137
• Exporting a Colour Palette, on page 139
• Importing a Colour Palette, on page 139
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Creating a Colour Palette
The first step in the palette process is to create a new palette. This way, you will not be using the default palette to 
paint all of your drawings.

To create a new palette: 

1. In the Colour Palette view, click on the Menu  button and select Palette > New Palette. 

The new palette appears in the Colour Palette view.

2. In the Colour Palette view, click on the Menu  button and select Palette > Rename Palette.

The Rename Palette dialog box opens.

3. In the Palette Name field, type the new palette’s name.
4. Click on the OK button.
5. Analyze the character or background you want to create this palette for and list all the colour swatches you will 

need to paint it.

6. Add the colour swatches needed.

 Refer to the Adding a Colour Swatch topic to learn more about adding colour swatches.

Ears

Eye Patch

Iris

Hand

Foot

Belly

Face

Suit

Eye
Nose

Zipper
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Deleting a Colour Palette
You can remove palettes from your Palette list if they are not needed in your scene.

To delete a palette: 

1. In the Colour Palette view, select the palette to remove.

2. In the Colour Palette view, click on the Menu  button and select Palette > Delete Palette. 

A Warning dialog box opens to confirm the operation.

3. Click on the OK button to delete the palette.
 If the palette was in use in your scene, the zones painted with its colours will turn red.
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Duplicating a Colour Palette
If you have two characters using similar colours and colour pots, you can use the Duplicate palette option to copy the 
existing palette and modify the new one instead of creating a new palette from scratch. This saves time creating new 
colour swatches and renaming them. 

NOTE: The original and the duplicate palettes are completely independent.Once a palette is duplicated, you can 
change whatever you want in it without affecting the first one and vice-versa.

To duplicate a palette: 

1. In the Colour view, select the palette to be duplicated.

2. In the Colour Palette view, click on the Menu  button and select Palette > Duplicate Palette. 

The new palette appears in the Colour Palette view.

3. In the Colour Palette view, click on the Menu  button and select Palette > Rename Palette.

The Rename Palette dialog box opens.

4. In the Palette Name field, type the new palette’s name.
5. Click on the OK button.
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Creating a Palette Style 

A character usually has one colour palette, although there are times when the characters are placed in different 
lighting conditions and require a different colour shading. The night palette is a popular choice when a scene or 
sequence changes from day to night. It can be difficult and time-consuming to repaint everything and creating two 
independent palettes can be quite complex. As an alternative, you can create a palette style.

The palette style is a copy of the main palette. The colours in each palette have the same properties. The colours have 
the same identification number pointing to the same colour painted zones, the same names, but the swatches can be 
different colours. Depending on the selected style (night or day), the painted drawing will update. There is no need 
to repaint the animation, only to create or import a clone palette (palette style).

To create a palette style:

1. In the Colour Palette view, select the palette you want to create a new style for.

2. In the Colour Palette view, click on the Menu  button and select Style > Duplicate Style.

The new style appears in the Style list.

3. In the Colour Palette view, click on the Menu  button and select Style > Rename Style.

The Rename Style dialog box opens.

4. In the Palette Name field, type the new palette’s name.
5. Click on the OK button.

In the Colour Palette view, you can modify the colours individually by using the Colour Picker window or all at once 
using the Tint Panel window.

 Refer to the Mixing the Colours topic to learn how to modify your palette style’s colours.

Default Style Night Style
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Assigning a Style 
Once you paint a character with a palette, you may want to assign a different style to it. NOTE: The style will be used 
for the entire length of the scene. You cannot use two different styles in one scene. Although, you can use a different 
style for each scene in the project.

 Refer to the Planning Your Project topic in the Starting Your Project chapter to learn how to create scenes.



To select a palette style: 

1. In the Colour Palette view, open the Style drop-down menu and select the palette style to use for the current 
scene.

Deleting a Style
If a style is not needed anymore, you can delete it from the Style list.

To delete a palette style: 

1. In the Colour Palette view, select the palette you want to delete a style from.

2. In the Colour Palette view, click on the Menu  button and select Style > Delete Style.

The zones painted with the current styles will now be painted with the default style.

Mixing the Colours 
If you want to modify a series of colours at once to blend a tint in them or offset their colour, you can use the Tint 
Blend or the Tint Offset panels. These panels are quite useful when creating palette styles such as “night” and “day” 
styles.

The Tint Offset panel will take all the current colours in your palette and change their tints. The Tint Blend panel will 
take a selected colour and will apply it over your current colours.

To mix colours:

1. In the Colour Palette view, select the palette and the style to offset or blend the colours for.
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2. In the Colour Palette view, click on the Menu  button and select Style > Tint Offset or Tint Blend.
The Tint Offset or the Tint Blend panel opens.

3. To modify your colours:
 In the Tint Offset panel, slide the Red (R) slider to the right to increase the amount of red in your palette. 

Slide it to the left to remove the amount of red in your palette. You can do the same with the Green (G) and 
Blue (B) sliders.

 In the Tint Blend panel, slide the Red (R) slider to the right to increase the amount of red in the colour to 
blend in your palette. Slide it to the left to remove the amount of red in the colour to blend in your palette. 
You can do the same with the Green (G) and Blue (B) sliders.

 If you select the HSB mode rather than the RGB mode to modify your colours, you can modify the colour 
the same way by sliding left or right the Hue (H), Saturation (S) and Brightness (B) sliders. Those are simply 
two different ways of selecting a colour. Some people are more comfortable modifying colours by changing 
the Red, Green and Blue amounts and others are more comfortable changing the Hue, Saturation and 
Brightness values.

 If you want your colours to become semi-transparent or your semi-transparent colours to become opaque, 
slide the Alpha (Transparency) slider left or right to increase or decrease the transparency level.

 Finally, increase or decrease the Blending amount to indicate how strong the blending or offset of the 
colours should be.

If you blend a colour in your palette, the blending amount will progressively turn all your colours into that same 
colour. If you offset your colours, all the colours will progressively change to another tint, but they will not 
necessarily end up all the same colour.

4. Click on the OK button.

Colour to
blend in your
palette

Black colour blending Offset toward red tints
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Exporting a Colour Palette
When you work on a project, you should create a backup for your palettes. Since you can modify all the colours 
throughout the whole project, exporting your palettes once they are final and keeping them in an external folder.

Also, it is quite possible that you will reuse your characters in other projects and you will want to reuse the colour 
palettes you already created instead of recreating them. You simply need to export your palette from the previous 
project and import it in the new one.

To export a palette: 

1. In the Colour Palette view, click on the Menu  button and select Palette > Export Palette.

The Export Palette dialog box opens.

2. In the Palette Selection section, select the palettes you want to export.
3. In the File section click on the Browse button and select the location where to save your backup palettes.
4. Click on the Export button.

Importing a Colour Palette
If you created a palette in another project and you would like to import it in your current project, you can browse for 
the palette file on your computer and add it to your project. When the palette is imported in your scene, the file is 
copied in the project’s directory. It is not linked to the original file.

To import a palette into your project: 

1. In the Colour Palette view, click on the Menu  button and select Palette > Import Palette.

The Browser window opens.
2. Browse for a palette file located on your hard-drive.
3. Click on the Open button.

The palette appears in the Palette list.
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What’s Next?
So far, you have learned about:

• Creating Colours
• Painting a Drawing
• Creating Palettes
• Creating Palette Styles
• Importing and Exporting Palettes

Next, you will learn about hand-drawn animation and the exposure sheet. You will also learn how to paint a series of 
drawings using most of the skills you learned in this chapter.
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With Toon Boom Studio, you can import visual content such as images and movies that were created outside of the 
software.

In this chapter, you will learn about the following:

• Importing Bitmaps Images, on page 142
• Import Images With Keying, on page 147
• Importing Multi-layered PSD files, on page 150
• Importing AI and PDF files, on page 152
• Importing from Adobe Flash, on page 154
• Importing a Movie, on page 155
• Scanning Images, on page 157
• Capture, on page 159
• Library, on page 160
• What’s Next?, on page 173
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Importing Bitmaps Images 

Images can come in many different file formats. Some formats are able to preserve transparency or transparent layers. 
Toon Boom Studio supports the following formats: GIF, JPEG, JPEG 2000, PICT, SGI, BMP, PNG, PSD, TIFF, TGA, 
MacPaint, QuickTime, FlashPix.

In this section, you will cover the following topics:

• Importing Bitmaps Without Vectorizing, on page 142
• Vectorization of an Image Element or Image Cell, on page 144
• Importing and Vectorizing Images, on page 145

Importing Bitmaps Without Vectorizing 
To import bitmaps:

1. Select File > Import File.

The Open browser opens.
2. Browse for your bitmap image file and click on the Open button.

The Import Options dialog box opens.

3. In the Import Options dialog box, set the Image Import Option:
 Fit Image to Camera Width

By default this option is enabled, meaning that your image will be resized as to fit the width of the camera 
frame. You can disable this option to import the image at its original size.

Enabled Disabled
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4. Click on the OK button.

You can also select a bitmap file directly from your operating system browser and drag it in the Camera, 
Drawing, Top, Side, Timeline or Exposure Sheet view.

Follow step 3 and 4 from the To import bitmaps: step by step. 

Adding Images to a Bitmap Layer
Once you created a bitmap layer, it is possible to add more images inside it.

To add an image element from the top menu:

1. Select Element > Add > Image.

The new image column is added to your scene.

To add an image layer from the Timeline view:

1. In the Timeline View toolbar, click on the Add Layer  button.

The New Elements dialog box opens.

2. Choose Image from the Type drop-down menu.

3. Enter a name for your new image layer in the Name field.

4. Choose how many image layers you want to add to your scene using the Number field.

5. Click on the OK button.
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To add an image element from the Exposure Sheet view:

1. In the Exposure Sheet View toolbar, click on the New Image button.

The new image element will be added to your scene.

To add images to a bitmap layer:

1. In the Timeline or Exposure Sheet view, select the cell into which you want to import the image.
2. Right-click (Windows) or [Ctrl]+click (Mac OS X) in the selected cell and select:
 In the Timeline view: Import Images > Import Images.
 In the Exposure Sheet view: Import Images > From File. 

The Open browser opens.
3. Select the desired bitmap image file. You can select multiple image files if needed.
4. Click on the OK button.

The image will be imported in the selected cell.

Vectorization of an Image Element or Image Cell
You can vectorize a bitmap after it has been imported to your project. You can either do this by using the Convert 
Element to Vector option or a regular Copy/Paste command. 

To vectorize bitmaps using the Convert Element to Vector option:

1. In the Timeline view, select the cells containing the images you wish to convert into vectors:
 Select specific cells in the right side of the Timeline view.

OR
 Select the full Image element by clicking on it in the left side of the Timeline view.

2. Right-click (Windows) or [Ctrl]+click (Mac OS X) on a selected cell and select Convert Element to Vector from 
the pop-up menu.

The files are converted and a new Drawing element containing the vectorized files is created.

To vectorize bitmaps using copy/paste command:

1. In the Timeline view, select the cells containing the images you wish to convert into vectors:
 Select specific cells in the right side of the Timeline view.

OR
 Select the full Image element by clicking on it in the left side of the Timeline view.

2. Select Edit > Copy or use the keyboard shortcut [Ctrl]+[C] (Windows) or []+[C] (Mac OS X) to copy the cells.
3. In the Timeline view, select the destination of your copied image element or cells:
 Select a cell in the Drawing element in which you want to paste your copied cels into.

OR
 Select the entire Drawing element in which you want to paste your Image element into.

4. Select Edit > Paste or use the keyboard shortcut [Ctrl]+[V] (Windows) or []+[V] (Mac OS X).

Your cells will be copied and simultaneously converted into vectors.
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Importing and Vectorizing Images 
In Toon Boom Studio, you can import bitmap images and vectorize them.

To import and vectorize bitmap images:

1. In the Timeline or Exposure Sheet view, click on the Add Drawing Element  button if you do not already have 
an empty drawing element in your scene.

The new drawing element is added to your scene.
2. In the Timeline or Exposure Sheet view, select an empty cell.

3. Right-click (Windows) or [Ctrl]+click (Mac OS X) in the empty cell and select Import and Vectorize > From File 
from the pop-up menu.

OR

From the top menu, select File > Import and Vectorize > From File. 

The Open browser opens.
4. Browse for and select the bitmap image file(s) you want to import and vectorize, and then click on the Open 

button. You can select multiple files if necessary.

The Import and Vectorize Options dialog box opens.

5. Press on the Preview button to display your image in the preview space. Click on the Preview button every time 
you change the settings to update the result.

6. Click on the + and - buttons to zoom in and out in the preview space.

7. Set up the desired parameters:
 Files

This field will display the image you selected to browse. You can click on the browse button to change your 
selection. 

 

Browse button
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 Vectorization Types

 Black and White 
This option will vectorize the images in black and white. This is used when vectorizing line art that can 
be coloured in Toon Boom Studio later. This makes use of the Filters options described later in this 
section. 

 With Texture
When the Vectorization type is set to With Texture, Toon Boom Studio imports the bitmap and applies 
it as a texture on a vector shape. This allows for direct manipulation of bitmap images within Studio.

 Filters

 No Filter
This option vectorizes without applying a filter.

 Smoothing + Loss Of Sharpness
This option smooths the image, this process will cause a loss of sharpness of the original image.

 Smoothing + Greater Loss Of Sharpness
This option smooths the image, this process will cause a greater loss of sharpness of the original image 
than the option above.

 Edge Enhancement
This option enhances the edge of the image, this will result in a more precise result.

 Sharpening With Clearness
This options sharpens the images resulting in a more precise and clear result.

 Threshold%
Adjust the threshold value. The greater the percentage, the more grey pixels will be allowed into the 
final vectorization of the line.
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Import Images With Keying 

Keying is a concept used in animation but also in live action movies. Keying is the process of picking a precise colour 
value and removing it from the image to isolate a character or object. The more common use of keying is when filming 
actors against a green screen in cinema.

In Toon Boom Studio, you can import your images with the keying option, this lets you isolate an element in an image 
with a single coloured background.

To import images with keying:

1. In the Timeline view, select an empty cell in a bitmap image layer.
2. Right-click (Windows) or [Ctrl]+click (Mac OS X) and select Import Images > Import Images With Keying.

The Open Browser opens.
3. Browse to select the images you want to import and key. Hold down the [Shift] key while selecting your images 

to make a multiple selection. 

The Import Images With Keying dialog box opens.

 In the Files section, click on the Browse button if you want to change the selected images.
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 If you selected many image files, you can use the Previous and Next button to display the other drawings. 
The name of the currently selected drawing is displayed above the buttons.

 Use the + and - buttons to zoom in or out of the Preview area. Above the buttons is displayed the total 
number of drawings loaded in the Import Images With Keying dialog box.

4. In the Keying Options section, set the keying parameters:
 In the Keying Type drop-down menu, select the keying type you want to use.

 None
Selecting the None option means that there will be no keying on this drawing. Selecting None will 
render the other parameters grayed out.

 Chroma Keying (YUV)
This option will make the pixels corresponding to the selected colour transparent, using the YUV 
channels. 

 Chroma Keying (RGB)
This option will make the pixels corresponding to the selected colour transparent, using the RGB 
channels.

 Luma Keying (YUV)
With this option, you can set different levels of transparency on your drawing. The level of transparency 
will be determined by the different levels of colours, where white colour will be completely transparent 
and black colour completely opaque.

• Pick Colour


When you select one of the two Chroma Keying types from the drop-down menu, this option becomes 
available. 
 Click on the Pick Colour button to change your cursor to a dropper and select the background colour 

of your picture you want to illuminate from the preview area. As soon as you click on a colour, this 
colour will be displayed in the colour swatch and will be removed from the preview area. A grey 
checkerboard will be displayed to represent the transparent area. 

 You can also click on the colour swatch to open the Select Colour dialog box and select a precise 
colour from there.

Resulting Matte Resulting Matte
Chroma Keying Luma Keying
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• Matte, Luma Correction and Hide Checkerboard 

 Matte
Click on this option to display the matte in the preview area.

 Luma Correction
Click on this option to apply a luma correction filter on your image.

 Hide Checkerboard 
By default Studio displays a checkerboard pattern in the preview area to represent the transparent 
zones. You can enable the Hide Checkerboard option to conceal the checkerboard pattern and display 
the zone as white. 

• Minimum, Maximum sliders


Use these sliders to adjust the minimum and maximum level values to be considered in the keying process 
following your parameters set above. You can see the result in the preview area.

• Filter drop-down menu
Use this drop-down menu to select an effect to be applied on your keying selection to make it more precise 
and use the Effect Intensity drop-down menu to choose the level of intensity desired.

 None: No filter will be applied to your keying selection.
 Gaussian: A gaussian blur effect will be applied to your selection to soften the edge of the keyed 

selection.
 Mean: A mean filter will be applied to your selection to soften the edge of the keyed selection with a 

minimum of blurry result.
 Erode: The edge of the keyed selection will be cropped following the effect intensity level chosen 

below.
 Dilate: The edge of the keyed selection will be increased following the effect intensity level chosen 

below.
 Distance: The edge of the keyed selection will be increased with a blur following the effect intensity 

level chosen below.

• Apply button 
Click on the Apply button if you need to apply multiple passes of keying. Once you set up your first keying 
pass values and options, press on the Apply button. You are now ready to set up your next keying pass.

5. Click on the OK button.

Disabled Enabled
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Importing Multi-layered PSD files 

In Toon Boom Studio you can import bitmap images. You can also import multi-layered Adobe Photoshop *.psd 
(version 4 or higher) file and retain their layering. When you enable the option during the import, Studio creates an 
image element for every layer contained in the PSD file.

To import multi-layered PSD files:

1. Select File > Import File.

The Open browser opens.
2. Browse for your multi-layered PSD image file and click on the Open button.

The Import Options dialog box opens.

3. In the Import Options dialog box, set the Image Import Option:
 Image Import Options

 Fit image to camera width
By default this option is enabled, meaning that your image will be resized to fit the camera width 
frame. You can disable this option to import the image at its original size.

Enabled Disabled
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 Photoshop Import Options

 Preserve original layers of Photoshop files
By default this option is disabled, which means that when you import the PSD file, the layers will be 
flattened to create a single image element in your scene.

 You can enable this option to preserve the PSD file layering, which will create a different image element 
for each layers contained in your Adobe Photoshop file.

4. Click on the OK button.

You can also select a PSD file directly from your operating system browser and drag it in the Camera, 
Drawing, Top, Side, Timeline or Exposure Sheet view.

Then, follow step 3 and 4 from the To import multi-layered PSD files: step by step. 
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Importing AI and PDF files 

In Toon Boom Studio as well as being able to import bitmap images, you can also import a vector-based Adobe 
Illustrator or PDF file and preserve its layering. When you enable the option during the import, Studio will create a 
drawing layer for every layer contained in the AI file or create a drawing layer and separate drawing frames for each 
page contained in the PDF file.

Toon Boom Studio supports Adobe Illustrator files from version 5. You must create a PDF compatible file when you 
save Adobe Illustrator CS files to be able to import them into Toon Boom Studio. 

When you import an Adobe Illustrator or PDF file, Toon Boom Studio:

• Converts CMYK colours to RGB.
You can convert the colour space of your Adobe Illustrator or PDF files when you save them. See 
Adobe Illustrator documentation for instructions. However, to ensure the colour results you want, 
you should develop your web colours in the web-safe RGB palette.

•Displays objects that were hidden in the Adobe Illustrator file.
•Does not import text. You must convert text to outlines to import it.

• Does not import global colour swatches from V8 and under. 
• Does not convert transparent objects drawn with the Brush tool.

If your Adobe Illustrator file contains bitmaps, be sure those bitmaps are copied into the file. If 
they are linked, Toon Boom Studio can not import them.

To import multi-layered AI or PDF files:

1. Select File > Import File.

The Open browser opens.
2. Browse for your AI or PDF image file and click on the Open button.

The Import Options dialog box opens.

3. In the Import Options dialog box, set the Image Import Option:
 Preserve original layers of illustrator documents

 By default this option is disabled, which means that when you import the AI or PDF file, the layers and 
the pages will be flattened.

 Enable this option to preserve the Adobe Illustrator file layering, which will create a different drawing 
for each layer contained in your AI file.

4. Click on the OK button.
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To import an AI or PDF file in an already existing drawing layer:

1. In the Timeline or Exposure Sheet view, select a cell in the drawing layer into which you want to import the 
image.

2. Right-click (Windows) or [Ctrl]+click (Mac OS X) in the selected cell and select Import Illustrator.

The Open browser opens.
3. Select the desired AI or PDF file. You can select multiple image files if needed.
4. Click on the OK button.

An information dialog box opens, notifying you that the layers will not be preserved but that you can use the 
File > Import File command to import your files and preserve its layers.

5. Click on the OK button.

The image will be imported in the selected cell.
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Importing from Adobe Flash 

If a project was started in Adobe Flash you can add more dimension to it by adding multiplane camera movements 
or effects to it. Although *.fla files are not supported, you can export your Flash project to *.swf movies and 
imported them into Studio.

When you import an SWF file into your scene, its contents are expanded and laid out as a collection of elements. Pegs 
are automatically created to manage any scaling, rotation or motion animated in the file.

A new palette is automatically created, it is given a name corresponding to the movie file. This palette contains all the 
colours in the movie. 

To Import an SWF movie:

1. Select File > Import File. The Open browser opens.
2. Browse for your video file and click on the Open button.

The video appears in the Timeline view. Each of the SWF elements has its own drawing layer which is connected 
to pegs if there is a motion. A palette is also created in the Colour Palette view.

You can import SWF files as template from the Library view and link SWF files into Media Elements. Refer to 
the Importing Multimedia files into the Library view and Linking Templates to Media Elements topics to learn 
more.
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Importing a Movie 

There are several reasons why you might need to import a movie into your animation project, to create a rotoscope 
animation, to add 2D animation to a live video or to incorporate a television showing a program inside your scene. 

Toon Boom Studio allows you to import several movie types into your project:

• AVI
• MP4
• MPG
• QuickTime

 You can also import a SWF movie file. Refer to the Importing from Adobe Flash topic to learn how. 

Importing a Bitmap Movie File
AVI, MP4, MPG and QuickTime movies have one thing in common, they are all bitmap movie files. When they are 
imported inside Studio, a bitmap image sequence is created.

To import a AVI, MP4, MPG or QuickTime movie:

1. Select File > Import File.

The Open browser opens.
2. Browse for your video file and click on the Open button.

The Import Options dialog box opens.

3. In the Import Options dialog box, set the Movie Import Options:
 Set Opacity Value

Sometimes you want to import a movie as a reference and you would like it to have a specific transparency 
value. Enable this option to edit the opacity value of the movie.

 Opacity% (1-100%):
When the Set Opacity Value option is enabled, the Opacity% field becomes available. Type in the desired 
Opacity% value from 1 to 100.

4. Click on the OK button.

The video will appear on its own image layer in the Timeline and Exposure Sheet view as a bitmap image 
sequence.
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Importing a Movie in an Existing Image Layer
You can import a bitmap movie file in an already existing image layer.

To import a movie as an image sequence:

1. In the Timeline or Exposure Sheet view, select the cell at which you want your movie to start playing.
2. Right-click (Windows) or [Ctrl]+click (Mac OS X) in the cell and select Import Movie File as Image Sequence from 

the pop-up menu.

The Open browser opens.
3. Browse for your movie file and press on the Open button.

The Import Options dialog box opens.

 
4. In the Import Options dialog box, set the Movie Import Options:
 Set Opacity Value

Sometimes you want to import a movie as a reference and you would like it to have a specific transparency 
value. Enable this option to edit the opacity value of the movie.

 Opacity% (1-100%):
When the Set Opacity Value option is enabled, the Opacity% field becomes available. Type in the desired 
Opacity% value from 1 to 100.

5. Click on the OK button.

The image sequence will appear in the image layer at the selected starting cell.
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Scanning Images 

Rather than importing images from files, you can use Toon Boom Studio to get images from any TWAIN device (such 
as scanners and cameras). You can either load them as bitmaps into your scene or convert them into vector images 
that you can edit in Toon Boom Studio. 

You must install the TWAIN driver in order to access its contents. To get the latest TWAIN driver for your 
particular device you should refer to that manufacturer’s website.

To select the device you want to use:

1. Do one of the following:
 Right-click (Windows) or [Ctrl]-click (Mac OS X) a cell in an Image element in the Exposure Sheet or Timeline 

view and select Import Images > Select TWAIN Source.
 Right-click (Windows) or [Ctrl]-click (Mac OS X) a cell in a Drawing element and select 

Import and Vectorize > Select TWAIN Source.

The Select Source dialog box opens.
2. Use the Select Source dialog box to select the device you want to acquire content from.
3. Click on the OK button.

To scan or get a bitmap from a TWAIN device:

1. Select a cell in an Image element.
2. Right-click (Windows) or [Ctrl]-click (Mac OS X) in the cell and select 

Import Images > From TWAIN.

A dialog box with your device’s options appears.
3. Use the options in this dialog box to set your parameters and then scan or load the drawings into Toon Boom 

Studio.
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To vectorize a bitmap retrieved from a TWAIN device: 

1. Select a cell in a Drawing element in the Exposure Sheet or Timeline view.
2. Right-click (Windows) or [Ctrl]-click (Mac OS X) the cell and select Import and Vectorize > From TWAIN.

The Import and Vectorize Settings dialog box opens.

3. Set your vectorization settings:
 Vectorization with texture applies the bitmap as a texture on the drawing shape. 
 Black and white vectorization uses the filters listed below to transform the bitmap into vector art. 

4. Select a filter. You may have to experiment with these settings based on the qualities of the images you are 
vectorizing. 
 If the lines in your image are thin, select Smoothing + Loss of Sharpness. This filter blurs the lines in the 

image slightly so that thin lines are picked up in the vectorization process.
 If the lines in your image are very fine, select Smoothing + Greater Loss of Sharpness. This filter blurs the 

lines in your image more so that more lines are transformed in the vectorization process.
 If the lines in your image are thick, select Edge Enhancement. This filter merges fine lines (noise) into larger 

lines to create cleaner objects.
 If the lines in your images are thick and include a lot of fine detail, select Sharpening With Clearness. This 

filter sharpens edges to enhance details in your images.
5. Select a Threshold percentage. The Threshold value filters out noise in your images. Noise can be dirt or faint 

smudges on your scanned images. For example, if your value is set to 70%, all colour values below 70% are 
converted to white and ignored in the final image.

6. Click on OK to close the dialog box and continue the process. 

A dialog box with your device’s options appears.
7. Use the options here to select your parameters and then load and vectorize the drawings into Toon Boom 

Studio. 

Refer to the Importing and Vectorizing Images topic to learn more about vectorization options.
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Capture 

In Toon Boom Studio, you can capture from a device such as a digital camera to create original stop-motion animation. 
Toon Boom Studio 6 has an integrated image capture feature. An intuitive and easy to use image capture window 
allows you to set up and capture all your images.

Refer to the Stop-motion Animation chapter to learn how to capture images and create your own stop-
motion animation project.
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Library 

You can share and reuse any elements you create in Toon Boom Studio templates. Studio has a library providing ready 
to use templates and where you can store several different elements you created such as puppets, backgrounds or 
animations. In fact, almost anything you create or use in Studio can be stored in the library.

In this chapter, you will learn about the following:

• Understanding the Library Concept, on page 160
• Library View, on page 161
• Structuring the Library, on page 163
• Templates, on page 165

Understanding the Library Concept 
Use the Library view to reuse your artwork and animation in other scenes.

This topic is divided as follows:

• What is a Library?
• What is a Template?

What is a Library?
A library is a folder where you can store your Templates. You can access these folders from your different projects. To 
store your artwork in the Library, drag the content into the library and to reuse it, you will drag it into your Timeline 
view.

A library can be organized using subfolders, you can have several different library folders on your hard drive.

What is a Template? 
A template is a copy of the artwork stored in the library, this package can be reused in different scenes. Once a 
template is stored in the library it can be accessed from any project. Dragging a template into your scene copies the 
content in your Timeline and does not create a link it to the original. This individual copy can be modified at will. 

You can create a template out of pieces of animation content, such as elements, drawings, images, or sounds or even 
collections of animation content such as drawings, images and sounds in one single template.
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Library View 
The Library window is the centre for managing re-usable content in Toon Boom Studio.

The Library view is used to create and manage your templates, display the folders and manage all of the content. 

1. Preview
2. Library List
3. Templates List

Preview

You can use the Preview area to check the contents of the Library. You can preview any type of template. However, if 
your template consists of a peg or a camera element only, nothing is going to show in the preview window. 

To preview content in the library:

1. In the Library view, make sure that the preview checkbox is enabled.

2. Select the template you want to preview:
 In the Library list, select a Scene folder to display the entire scene in the preview area.

OR
 In the Template list, double-click on the template you want to preview.

The preview will appear in the Preview area.
3. If there are multiple frames in the selected template or scene, click on the Play button to play it back. You can 

also use the slider to select the frame you want to see.

1

2

3
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Library List 

The Library List is used to navigate through the different libraries and subfolders. You can also open, close and create 
new libraries from here. 

The Library list contains four default Libraries:

• Animation
In this library is stored all the elements and drawings contained in your project. This library is organized by 
scene and is constantly updated as you work in your project.

• Local
In this library, you can store templates that you want to use in the current animation project. In your system, 
this library is stored in the Template folder inside of your project main folder.

• Global
In this library, you can store templates that you want to be able to use in any project animation that you 
create on your computer.

• Toon Boom Templates
This library stores templates provided by Toon Boom Studio. Here you can find a lot of interesting artwork 
organized in subfolders, also called catalogs, by categories such as Backgrounds, Storyboarding, Props, 
Characters, Cut-out Characters, Clip Arts and Special Events. You can not edit this library.

Template List

The templates contained in the selected Library list are displayed on the right side of the Library view as thumbnails, 
as a list or as details.

To change the templates list display: 

1. In the Library view’s right side, right-click (Windows) or [Ctrl]+click (Mac OS X) and select 
View > List, Thumbnails or Details.
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Structuring the Library 
As you might need to create many templates you will soon realize that they need to be organized. You can create 
different libraries and catalogs so that you can have easy access to your assets. 

For example, in your global library, you can create a different library for each project and divide it into several 
categories, such as:

• Characters
• Props
• Backgrounds

This topic is divided as follows:

• Creating a Library, on page 163
• Opening and Closing a Library, on page 164
• Creating a Catalog, on page 164
• Renaming a Catalog, on page 165
• Deleting a Catalog, on page 165
• Refreshing the Library, on page 165
• Reloading Default Templates, on page 165
• Saving the Library, on page 165

Creating a Library 
You can create libraries in the Library view. 

To create a library:

1. In the Library list, right-click (Windows) or [Ctrl]+click (Mac OS X) and select Create Library.

The Browser window opens.
2. Browse for the location where you want your new library to be stored. 
3. Click on the Make New Folder button.

4. Give a relevant name to your new library and click on the OK button.

The new library appears in the Library list area.

To rename a library:

1. In the Library list, select the library you want to rename, right-click (Windows) or [Ctrl]+click (Mac OS X) and 
select Rename Library.

The library name will become an editable field.
2. Rename the Library and press [Enter] to validate.
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Opening and Closing a Library
You can load libraries of templates that are stored on your computer or on another computer available through your 
network.

Libraries make it easier for you to work on productions with other users that will share the same templates. Toon Boom 
Studio identifies libraries with the extension *.tbc. To load a library, the folder must have a file with the *.tbc 
extension inside of it.

To load and close a library:

1. Right-click (Windows) or [Ctrl]-click (Mac OS X) in the library list and select Open Library from the pop-up menu.

A browser dialog box opens.
2. Locate the library you want to open and click the Open button.
3. The selected library appears in the library list.

To close a library:

1. Select the library you want to close and right-click (Windows) or [Ctrl]-click (Mac OS X) the library and select 
Close Library.

If you have made changes to the library since you last saved the global library, a message appears asking you to 
confirm your desire to close the library.

• Click Yes to close the library without saving changes.
• Click No to keep the library open so that you can save changes.

 Select File > Save Global Library to save changes to the library.

Creating a Catalog 
Symbols and templates libraries need to be organized, you can create different subfolders in the Library view so that 
you can gain easy access to your assets. These subfolders are called catalogs. 

To create a catalog:

1. In the Library view’s left side, select the library to which you want to add a catalog.
2. Right-click (Windows) or [Ctrl]-click (Mac OS X) on the selected library and select New Catalog from the pop-up 

menu.

The new folder appears in the Library. When you have a library with catalogs, click on the [+] sign to expand it to 
make the catalogs visible.

3. Name the new catalog and press [Enter] to validate.
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Renaming a Catalog
To rename a catalog:

1. In the Library list, select the catalog you want to rename, right-click (Windows) or [Ctrl]+click (Mac OS X) and 
select Rename Catalog.

The catalog name will become an editable field.
2. Rename the catalog and press [Enter] to validate.

Deleting a Catalog
To delete a catalog:

1. In the Library list, select the catalog you no longer need, right-click (Windows) or [Ctrl]+click (Mac OS X) and 
select Delete.

The catalog will be deleted.

Refreshing the Library
Sometimes you might need to refresh the Template list to see the latest changes.

To refresh the library:

1. In the Template list, right-click (Windows) or [Ctrl]+click (Mac OS X) and select Refresh from the pop-up menu. 
You can also use the default keyboard shortcut [F5].

The Template list will be refreshed.

Reloading Default Templates
If you close the Toon Boom Templates library, you can always quickly bring it back to the library list.

To reload the default Templates:

1. In the Library list, right-click (Windows) or [Ctrl]+click (Mac OS X) and select Reload Default Templates.

The Toon Boom Templates library will be reopened.

Saving the Library
When you save your Toon Boom Studio project, the library is automatically saved. You can also save only the changes 
made to the library without saving your Studio project.

To save the library:

1. Select File > Save Global Library.

Templates 
If you want to reuse artwork and animation from your project into other scenes, you need to create a template out of it.

This topic is divided as follows:

• Creating a Template, on page 166
• Deleting a Template, on page 167
• Editing a Template, on page 167
• Template Properties, on page 169
• Importing Multimedia files into the Library view, on page 169
• Importing a Template in Your Scene, on page 170
• Linking Templates to Media Elements, on page 170
• Copying Selected Template Contents into Your Animation, on page 171
• Using Paste Special to Update Content from a Template, on page 172
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Creating a Template 
In Toon Boom Studio, creating a template is as easy as selecting what you want from the Exposure Sheet or Timeline 
view and dragging your selection into the Library view. 

You can create templates from any piece of animation content:

• From the Exposure Sheet view, you can create templates from single or multiple images and drawings, or 
sounds. 

• From the Timeline view, you can create templates from single or multiple layers, or from a selection of 
frames across multiple layers. You can store anything available in the Timeline view as a template. 

To create a template:

1. Make a selection of what you want to include in the template:
 In the Timeline view, select some cells or layers.

OR
 In the Exposure Sheet view, select some cells from one or multiple columns.

2. In the Library view, select the destination library or catalog from the library list.
3. Drag the current selection to the template list in the Library view.

You can drag a selection to any library or catalog folder icon in the library list and the template will be 
added to this library or catalog.

The template will be added to the template list.
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4. The name of the template will be shown as an active text field, type the desired name for your template and 
press [Enter] to validate.

To rename a template:

1. In the Library view, select the folder containing the template to rename.
2. Select the template you want to rename from the template list.
3. Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selected template and select Rename Template from the 

pop-up menu.
4. Enter the new name in the active text field and press [Enter] to validate.

The template will be renamed.

Deleting a Template
You can easily delete templates from the Library view if you do not need them anymore. This action can be undone if 
necessary.

To delete a template:

1. In the Library view, select the folder containing the template to delete.
2. Select the template you want to delete from the template list.
3. Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selected template and select Delete Template from the 

pop-up menu. The default keyboard shortcut is [Delete].

The template will be removed from the library.

Editing a Template 
You can modify the templates contained in the Global, Local and any Library you created. A template is like a scene, 
you can open it and edit it as any regular project. 

If you want to do some modifications in your templates, you can edit them using the Edit Template command.

To edit templates:

1. In the Library view, select the folder containing the template to modify.
2. Select the template you want to edit from the template list.

3. In the Library window, right-click (Windows) or [Ctrl]-click (Mac OS X) on the selected template you want to edit 
and select Edit Template from the pop-up menu. 

The identification of the active scene changes in the Scene Manager view.
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The contents of the template you are editing appear in all views and the title bar on the Exposure Sheet and 
Timeline views changes to indicate that you are currently editing a template.

4. Now that you are in template editing mode, you can make any change you want to the contents of the template 
in any the views. You can adjust timing, add drawings, edit existing drawings or even add layers.

5. Save your template.
 Select File > Save to save the changes to the local and global template, as well as the animation project.
 Select File > Save Global Library to save the contents of the Library view only and not the animation 

project.
6. To exit the edit template mode, in the template list of the Library view, right-click (Windows) or [Ctrl]-click (Mac 

OS X) on the selected template and select Return to Scene. You can also double-click on the scene name in the 
Scene Manager view.

7. In the Library view, right-click (Windows) or [Ctrl]-click (Mac OS X) in the template list and select Refresh from the 
pop-up menu, or you can also press [F5], the default keyboard shortcut, to refresh the templates so that the 
thumbnail displays the latest changes.

 Refer to the Refreshing the Library topic to learn how to display your template as thumbnails.
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Template Properties 
If you need more information about a template, you can view the template’s properties. The template’s properties 
shows the following information:

1. The name and a preview thumbnail of the template.
2. The template’s type and version of Toon Boom Studio that was used.
3. The name of the artist who created the template and copyright information. 
4. The size of the template and the date of the latest modification.
5. The contents of the template and their duration.

To display a template’s properties:

1. Right-click (Windows) or [Control]-click (Mac OS X) on a template and select Template Properties from the pop-
up menu. 

The Properties dialog box opens. 

 Refer to the Starting Your Project chapter to learn how to set up your artist name and copyright info.

Importing Multimedia files into the Library view
If you have a SWF file, a QuickTime file, a sound file, an image, or even another template that is not currently in your 
animation set, you can import it into the Library view to gain quick access to them. 

To create templates from multimedia files:

1. In the Library view, select the library into which you want to import the multimedia file.
2. Right-click (Windows) or [Ctrl]+click (Mac OS X) in the template list and select

Import > one of the following choices from the pop-up menu:
 Import Image File: import a bitmap image.
 Import Movie File: import a movie file. 
 Import Sound File: import a sound file.
 Import Template File: import a template created in Toon Boom Studio.

A browser opens.
3. Browse and select the file you want to import and click on the OK button.

The file will be added in the library.

5

2

3

4

1
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Importing a Template in Your Scene
You can drag a template from the Library view to the Exposure Sheet or Timeline view to add its contents to your 
animation. 

Copying templates into your animation will increase the file size of your movies. You can link templates to your 
animation to keep the file size of your animation small. Refer to the Linking Templates to Media Elements topic 
to learn more about template linking.

To import a template into your scene:

1. In the Library view, select the template you want to import.
2. Drag the selected template to the Camera view or Timeline view’s left side.

 You can also drag a template to the Timeline view’s right side into existing layers if the layer structure is the 
same as the existing one.

Linking Templates to Media Elements
You must use media elements to link templates to your animations. Media elements identify the contents they contain 
as references to a centrally stored file. If the template you link contains multiple elements, all of those elements are 
composited into one element, the media element. 

Linking templates has two advantages: 

• It helps you keep the file size of your SWF animations small.
• It helps you update and manage frequently used material in a central location.

If the contents of the template are updated, Toon Boom Studio updates all animation which uses that 
template.
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To link a template to a media element:

1. Select Element > Add > Media. 

A new element appears in the Timeline view.

2. In the Library view, select the template you want to link and drag it to the media element you created in the 
Timeline view’s right side.

 You can also create a media element as you link a template, by pressing [Alt] (Windows) or [Alt]+[] (Mac 
OS X) as you drag the template to the Timeline view’s left side.

Toon Boom Studio links to the original file.

Copying Selected Template Contents into Your Animation
When you drag templates from the Library window, you can open the Timeline Drag & Drop Preferences to select 
the template contents that you want to copy into your animation.

To copy selected template contents into your animation:

1. In the Library view, select the template you want to copy.
2. Drag the template to the Timeline view and place the template on top of the elements where you want to place 

it.

You must select the same number and hierarchy of elements as there are in the template. Otherwise you will not 
be able to complete the drag operation. Refer to the Template Properties topic to learn how to open the 
Template properties.

3. Press and hold [Alt] (Windows) or [Ctrl]+[Alt] (Mac OS X) and then release the mouse button. 

The Timeline Drag & Drop Preferences dialog box opens.

4. Select the properties you want to copy to the animation.
5. Click on OK. 

 Refer to the Animating a Puppet chapter to learn more about the Paste Special options.
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Using Paste Special to Update Content from a Template
You can use the Paste Special command to update selected content with material stored in a template file. You can 
use this command to update drawings, timing, layout, as well as palettes. 

To use paste special to update content:

1. Select the template in the Library and select Edit > Copy Template.
2. In the Timeline, select the elements you want to paste the template onto. 

You must select the same number and hierarchy of elements as are in the template. Otherwise you won’t be able 
to complete the paste operation. Refer to the Template Properties topic to learn how to open the Template 
properties.

3. Select Edit > Paste Special. You can also use the default keyboard shortcut [Ctrl]+[B] (Windows) or []+[B] (Mac 
OS X).

The Paste Special dialog box opens.

4. Select the options from the Paste Special dialog box.
5. Click on OK. 

Refer to the Animating a Puppet chapter to learn more about the Paste Special options.
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What’s Next?
So far you have learned about:

• Importing artwork and media in Toon Boom Studio
• Importing and vectorizing bitmaps in Toon Boom Studio
• Importing artwork using a TWAIN device
• Using the Library view to store and reuse animation assets

It is now time to learn how to add colour to your animation and artwork.
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Chapter 7  Layers and Timing

When you create animation, it is important to know how to set and modify the timing of your drawings. You can adjust 
the timing in both the Timeline and Exposure Sheet views, depending on which one you prefer.

In this chapter, you will learn how to work on your drawing’s exposure and length. The keyframes and motion paths 
are covered in a separate chapter.

 To animate with motion paths (pegs) and keyframes, refer to the Scene Setup chapter.

In this chapter, you will learn about the following:

• Understanding the Timeline and Exposure Sheet Views, on page 176
• Layers and Columns, on page 182
• Filling Exposure, on page 193
• Navigating Between Frames and Columns, on page 204
• Managing Drawings, on page 206
• Preferences, on page 208

1 3 5 7 9 11 13 15 17 19 21 23 25
175



Toon Boom Studio User Guide
Understanding the Timeline and Exposure Sheet Views
To set your animation timing, you will work mostly with the Timeline and Exposure Sheet views. This section will help 
you become familiar with these views, how they work and the differences between them.

Timeline View 

The Timeline view allows you to read your drawings and timing from left to right. It represents the scene’s elements 
in their simplest form.

In the Timeline view, you can see your layers and their names as well as the drawing timing. The drawing name is 
displayed when you place your cursor above the drawing’s exposure. 

The Timeline view has three main sections:

• Timeline View Toolbar, on page 177
• Layer Section, on page 178
• Timing Section, on page 178

Timeline View Toolbar

Timing SectionLayer Section
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Timeline View Toolbar
The Timeline View toolbar is composed of nine different buttons allowing you to add, enable and disable layers as 
well as switching between the different scenes of a same project.

•  Show/Hide All
Click on this button to show or hide all the layers in your timeline. This button will toggle between the two 
states.

•  Solo Mode

Click on this button to toggle between the Solo Mode On  and Off  states. The Solo mode allows 
you to see only the currently selected layer as well as the layer that was selected when you enabled the Solo 
Mode to use it as a reference without having to disable all the other layers.

•  Add New Elements
Click on this button to add a new element (layer) to your timeline. When you click on this button, the New 
Element dialog box opens and lets you choose which type of element you want, how many and how you 
want to name it.

•  Delete Element
Click on this button to delete the selected layers in your timeline. Note that if you delete a layer with other 
layers connected to it, all the layers connected will be deleted at the same time. Also, if you only have one 
layer in your timeline, you will not be able to delete it. Toon Boom Studio’s Timeline view must always have 
at least one drawing layer in it.

•  Add Drawing Element
Click on this button to add a drawing layer in your timeline without having to go through the Add New 
Element dialog box. Simply click on the button and a new drawing layer will appear in the Timeline view. 
You can then double-click on the new layer to rename it.

•  Add Peg Element
Click on this button to add a peg layer in your timeline without having to go through the Add New Element 
dialog box. Simply click on the button and a new peg layer will appear in the Timeline view. You can then 
double-click on the new layer to rename it.

•  Add Parent Peg
Click on this button to add a peg layer in your timeline and connect it to any selected layer without having 
to go through the Add New Element dialog box. Simply click on the button and a new peg layer will appear 
in the Timeline view and the selected layer will be connected to it. You can then double-click on the new 
layer to rename it.

•  Scene Menu
Click on this button to travel between the different scenes in your project.

•  Timeline View Contextual Menu
Click on this button to display a drop-down menu containing commands related only to the Timeline view.
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Layer Section

The Layer section is located to the left of the Timeline view. This is where you can add, delete, rename, reorder and 
attach layers.

Timing Section

The Timing section is located on the right side of the Timeline view. This is where you can increase and decrease a 
drawing’s exposure, duplicate drawings, add blank cells, etc. Any operation you do that affects a drawing or its timing 
is done in this section.
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Exposure Sheet View 

The Exposure Sheet view lets you read your timing vertically where the columns represent drawing layers.

The Exposure Sheet view has two main sections and several other components:

• Main Section, on page 179
• Element List Section, on page 180
• Exposure Sheet Toolbar, on page 180
• Column Header, on page 180
• Drawing, on page 180
• Frame Numbers, on page 181

Main Section 

The Main section shows the Drawing, Image, Sound and Media columns. You can see the drawing timing and names.

Exposure Sheet
Toolbar

Column
Header

Drawing

Frame Numbers

(Cell)
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Element List Section 

The Element List section allows you to show and hide columns from your Exposure Sheet view. When you hide a 
column using your Exposure Sheet view, it is NOT disabled in the Timeline view. When you hide a column in your 
Exposure Sheet, the artwork is hidden from the Drawing view, but not from the Camera view. To hide elements in the 
Camera view, disable the layers in the Timeline view.

To display the Element List section:

1. In the Exposure Sheet toolbar, click on the Toggle Element List  button.

Exposure Sheet Toolbar 

The Exposure Sheet view has its own toolbar where you can find the most common features. This toolbar is displayed 
by default. If you do not see it, select Windows > Toolbar > Exposure Sheet. The Exposure Sheet view must be part 
of your workspace in order to display its toolbar.

Column Header 
Each column available in the Exposure Sheet view has a header displaying the column’s name. The 
column’s name is the same as the corresponding timeline layer. If you rename one or the other, they will 
both be renamed.

A quick access menu is available when you right-click (Windows) or [Ctrl]+click (Mac OS X). This menu 
contains the command that affect an entire column such as renaming, changing the default colour or 
deleting a column.

Drawing 
When you see a cell containing a name or number, it represent the drawing you created in the Drawing 
or Camera view.
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Frame Numbers 
On the left side of the Exposure Sheet view, the frame numbers. They read vertically instead of left to right, as 
in the Timeline view.

• To go to a particular frame, you can click on the frame number.

• If you click and drag a selection downwards, you will select an entire frame range. 

In the Xsheet view, you can remove any selected frame range by pressing the [Delete] key.

To delete a frame range:

1. In the Exposure Sheet view, select a frame range by clicking on the first frame’s number to delete and dragging 
down to the last frame to delete.

2. Press the keyboard shortcut [Delete] to delete the selection.
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Layers and Columns 
In Toon Boom Studio there are two ways to see your layers: 

• As horizontal layers in the Timeline view 
• As vertical columns in the Exposure Sheet view. 

Whether you work in the Timeline or Exposure Sheet view, they are the same and any modification you do to one or 
the other will be applied to both.

This topic is divided as follows:

• Layer Concepts, on page 182
• Layer Types, on page 183
• Adding New Elements, on page 184
• Deleting Elements, on page 186
• Modifying Elements, on page 187
• Expanding and Collapsing Layers, on page 192

Layer Concepts 
In order to understand what happens when you duplicate a drawing, extend an exposure, create cycles or delete a 
drawing, it is important to know how layers and columns work. 

The layers are linked to a folder containing all the drawings you create. This folder is contained inside your Toon Boom 
Studio project’s folder.

When you create a new drawing in your Camera view, a drawing file is created inside the Drawing folder.

When you type a drawing name in a Exposure Sheet cell or Timeline frame, the system looks in the Drawing folder for 
the corresponding drawing to display. If there is no corresponding drawing, a new one is created. 

.

When you create a drawing cycle, all of the repeated drawings are linked to the same original drawing. This means 
that when you modify, repaint or correct a drawing named “1,” all drawings named “1” are updated simultaneously. 
In order to modify a drawing independently from its other exposures, you must duplicate the drawing.

Refer to the Duplicating a Drawing topic to learn how to duplicate a drawing.
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Layer Types 
There are several types of layers you can add in the Timeline and Exposure Sheet views.

 Drawing Element 
The most common layer type is the Drawing Element. Anytime you need to create a vector drawing use a Drawing 
element. NOTE: bitmap images are contained in Image Element layers.

The Drawing layer is tagged with the Drawing  icon.

 Image Element 
If you import picture or bitmap images into your project, they are inserted in an Image element.

The Image layer is tagged with the Image  icon.

Refer to the Importing Artwork chapter to learn how to import images.

 Camera Element 
The Camera element represents the camera filming your stage. You must position it if you want to change the camera 
frame in your scene or animate it with a Peg layer if you want to create a camera motion.

• The Camera layer is tagged with the Camera  icon.
• The Camera layer is not visible in the Exposure Sheet view.

If you want to have several cameras with different settings, you can keep adding Camera layers in your Timeline view. 
To switch between available cameras, select the desired camera from the Camera drop-down list located in the Scene 
toolbar.

Refer to the Scene Setup chapter to learn how to animate the camera.

 Effect Element 
To enhance the look of your scene, you can add effect layers and attach your drawings to them. In Toon Boom Studio, 
there are three effects.

In the Timeline view, the Effect element is tagged with the Effect  icon.

The Effect layers are not visible in the Exposure Sheet view.

Refer to the Enhancing With Effects chapter to learn how to add effects to your project.

 Peg Element 
A Peg Element can be described as a trajectory or motion path layer that does not contain drawings. It can be 
attached to any drawing layer, cut-out puppet or other peg layers. The layers attached to the Peg layer will follow the 
trajectory you set in this Peg layer.

In the Timeline view, the Peg element is tagged with the Peg  icon.

The Peg layers are not visible in the Exposure Sheet view.

Refer to the Scene Setup chapter to learn more about pegs.
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 Sound Element 
You can import sound files to add dialog and sound effects to your project. The sound layer will be added to your 
Timeline and Exposure Sheet view when you import a sound file in your scene.

The Sound element is tagged with the Sound  icon.

Refer to the Sound and Lip-sync chapter to learn how to import and play sound.

Annotation Element 
An Annotation Element is mainly used for educational purpose. The teacher can use these layers to draw and mark 
comments and corrections over an animation.

In the Timeline view, the Annotation element is tagged with the Annotation  icon.

Refer to the Traditional Digital Animation chapter to learn more about annotation elements. 

 Media Element 
A Media Element is used in different ways. The main way is to import an SWF movie in your project and keep it in one 
single layer instead of it being spread on several layers. The second way is to link a media element to your scene 
instead of importing templates from the Library directly in your scene. This way you can connect several scenes to the 
same template. If you modify the original template, it will be altered in all the scenes simultaneously.

The Media element is tagged with the Media  icon.

Refer to the Scene Setup chapter to learn more about media elements.

Adding New Elements 
In this section you will learn the different ways to add elements to your project. By default, when you create a new 
scene there is one Drawing layer included in your Timeline and Exposure Sheet views.

This section is divided as follows:

• Adding Layers in the Timeline View, on page 184
• Adding an Element From the Top Menu, on page 185
• Adding New Columns in the Exposure Sheet View, on page 185

Adding Layers in the Timeline View 
You can add a new layer in the Timeline view in two different ways; using the Layer toolbar or using the New Elements 
dialog box.

To add a Drawing layer using the Timeline’s Layer toolbar:

1. In the Timeline’s Layer toolbar, click on the Add Drawing Elements  button.

A new layer appears in the Timeline and Exposure Sheet view.
2. Double-click on the layer to rename it.
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To add layers using the New Elements dialog box:

1. In the Timeline’s Layer toolbar, click on the Add Elements  button.

The New Elements dialog box opens.

2. In the Type drop-down menu, select the element type you want to add.
3. In the Name field, type the name of the layer you want to add. If you are adding more than one layer at the 

same time, all of these layers are given that layer’s name and a numerical suffix.
4. In the Number field, use the up and down arrows or type the number of layers you want to add at once.
5. To complete the operation:
 Click on the OK button to add your new layers and close the dialog box.
 Click on the Cancel button to cancel the operation.

Adding an Element From the Top Menu 
To add a new element from the top menu:

1. In the top menu, select Element > Add > Element Type.

A new element appears in the Timeline and Exposure Sheet view.

Adding New Columns in the Exposure Sheet View 
To add a new column:

1. In the Exposure Sheet toolbar, click on one of the following buttons:

•  Add Drawing Element

•  Add Image Element

•  Add Sound Element

•  Add Media Element

•  Add Annotation Element

A new element appears in the Timeline and Exposure Sheet view.
2. Double-click on the Column header to rename the new column.
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Deleting Elements
You can delete elements from your scene in two different locations:

• Deleting a Layer From the Timeline View, on page 186
• Deleting Columns from the Exposure Sheet View, on page 186

Deleting a Layer From the Timeline View 
There are two ways to delete a layer in the Timeline view, 

• using the Delete Layers  button 
• using the quick access menu.

To delete layers in the Timeline view:

1. In the Timeline view, select the layers to be deleted.

2. In the Timeline’s Layer toolbar, click on the Delete Layers  button. 
You can also right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Delete Element.

Deleting Columns from the Exposure Sheet View 
You can delete columns in the Exposure Sheet view by using the quick access menu.

To delete layers in the Xsheet view:

1. In the Exposure Sheet view, select the columns to be deleted by clicking on their header.

2. From the top menu, select Element > Delete Element.
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Modifying Elements
Once you add elements to your project, you can modify their properties, name or ordering.

This section is divided as follows:

• Ordering Elements, on page 187
• Show and Hide Elements, on page 188
• Renaming an Element, on page 189
• Exposure Sheet Thumbnails, on page 190
• Changing the Colour of a Column or Layer, on page 190

Ordering Elements 
You can change the order of your layers in the Timeline and Exposure Sheet view. When you change the order of your 
layers in one of these views, the other one is updated automatically.

To reorder layers in the Timeline view:

1. In the Timeline view, select the layers to move.
2. Drag the selection to the new location and drop it in between the existing layers. Dropping the selection on an 

existing layer would create a hierarchy.
 Layers located on top of the Timeline view are displayed in front of the other ones.
 Layers located at the bottom are displayed behind.

To reorder columns in the Xsheet view:

1. In the Exposure Sheet toolbar, click on the Show Element List  button to display the Element List panel.

2. In the Element List panel, drag up or down the columns to reorder. Layers located on top of the Element List are 
displayed in front of the other ones. Layers located at the bottom are displayed behind.
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Show and Hide Elements 
As you work in the Drawing or Camera view, some elements may be in the way or are used as references. You can hide 
these layers to make your work area easier and less cluttered.

The show/hide operation in the Timeline and Exposure Sheet views are independent from each other and will 
not affect the other view. For example, hiding the layers in the Timeline will not affect the layer's availability 
in the Exposure Sheet view and vice versa.

To show or hide all layers at once in the Timeline view:

 In the Timeline’s Layer toolbar, click on the Enable/Disable All  button to show or hide all your layers at 
once. In the top menu, you can also select  Element > Display > Timeline > Show All.

To show or hide individual layers in the Timeline view:

 In the Timeline view, uncheck the layer’s checkbox to disable a particular layer. You can also select the layer 
to show or hide and select  Element > Display > Timeline > Show/Hide from the top menu.

To disable all layers but the selected one:

 In the top menu, select Element > Display > Timeline > Hide All Others to show only the currently 
selected layer and disable all the other layers. 

You can also select Display > Hide All Others in the Timeline contextual  menu.

To show and hide columns in the Exposure Sheet view:

1. In the Exposure Sheet toolbar, click on the Show Element List  button.

2. In the Element List section, show or hide the columns by clicking in the column checkbox to add or remove the 
check mark.

 You can also select the column you want to hide and, from the top menu, select 
Element > Display > Exposure Sheet > Hide.
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To disable all columns except the selected one:

 In the top menu, select Element > Display > Exposure Sheet > Hide All Others to show only the currently 
selected layer and disable all the other layers.

To show all hidden Exposure Sheet columns:

1. In the top menu, select Element > Display > Show All Exposure Sheet Elements.

Renaming an Element 
You can rename an element in three different ways; directly in the column header, in the timeline layer or in the 
Rename dialog box.

To rename a layer in the Timeline view:

1. In the Timeline view, double-click on the name of the layer to rename.
2. In the Name field rename the layer and press [Return] to validate the modifications.

To rename a layer in the Exposure Sheet view:

1. In the Exposure Sheet view, double-click on the column header of the layer to rename.
2. In the Name field rename the column and press [Return] to validate the modifications.

To rename a layer in the Rename Element dialog box:

1. In the Timeline or Exposure Sheet view, select the layer to rename.
2. In the top menu select Element > Rename Element. You can also right-click (Windows) or [Ctrl]+click (Mac OS 

X) and select Rename Element.

The Rename Element dialog box opens.
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3. In the Name field, rename the layer.

4. Click on the OK button.

Exposure Sheet Thumbnails 

When there are a large number of columns and drawings in the exposure sheet, it is not always easy to quickly identify 
a particular column. Displaying the column thumbnails makes this easier. This option displays a small thumbnail picture 
in each cell where there is a drawing.

To display the thumbnails:

1. In the Exposure Sheet toolbar, click on the Thumbnails  button. You can also select View > Thumbnails 

from the Exposure Sheet contextual  menu.

The thumbnails appear.

Changing the Colour of a Column or Layer 
To easily identify layers in your Timeline and Exposure Sheet views, you can change their colour. You can change the 
drawing exposure colour and track background independently.

To change the drawing exposure colour:

1. In the Timeline or Exposure Sheet view, select the layer you want to change the colour for.
2. In the top menu, select Element > Display > Change Colour.
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3. In the Select Colour window, select the new colour for your layer.

 
4. Close the Select Colour window.

The layer’s colour is updated.

To change the timeline layer’s background colour:

1. In the Timeline view, select the layer you want to change the background colour for.
2. In the top menu, select Element > Display > Background Colour.

3. In the Select Colour window, select the new colour for your layer.

4. Close the Select Colour window.

The layer’s background colour is updated.

To reset a layer’s colour in the Timeline view:

1. In the Timeline or Exposure Sheet view, select the layers to reset the colour of and select 
Element > Display > Default Colour.
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Expanding and Collapsing Layers 
To simplify the look of your Timeline view, you can collapse and expand your layers. If some layers are attached, you 
can collapse the top layer to hide all of the layers attached to it.

To collapse a layer selection in the Timeline view:

1. In the Timeline view, click on the Expand Arrow  button located on the layer you want to collapse.

Modifying the Column Width 
In the Exposure Sheet view, you can change the width of a column. If the name of your column is too long and does 
not fit in the column header, make the column wider to see it all.

To modify the column’s width:

1. In the Exposure Sheet view, place your cursor on the edge of the column header you wish to adjust.

2. Once you see the Extend cursor appear, adjust the column width by dragging the Extend cursor.

3. To restore all columns to their default width, in the Exposure Sheet contextual  menu, select 
View > Reset Column Width.
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Filling Exposure
Toon Boom Studio provides different tools to fill-in exposures and values, create cycles, set increments. 

This section is divided as follows:

• Typing Exposure, on page 193
• Extending Exposure, on page 194
• Dragging Cells, on page 195
• Increasing and Decreasing Exposure, on page 196
• Deleting Exposure, on page 198
• Inserting Blank Cells, on page 198
• Setting the Exposure, on page 199
• Filling a Selection with a Sequence, on page 200
• Creating Cycles, on page 201

Typing Exposure 
To fill-in your exposure, you can directly type the values in the Exposure Sheet view.

To enter a value in a column’s cell, you have to either double-click in the cell or use the Change Label command and 
type in the numbers or letters.

NOTE:

You can only use alphanumeric values (0-9, a-z, underscore (_) and dash (-)).

The following shortcuts can be helpful when editing the exposure values:

• [Return], you move on to the next cell.
• [ESC], you exit the typing mode to return to normal mode.

To type values in the Exposure Sheet view:

1. In a column, double-click on one cell. You can also right-click (Windows) or
[Ctrl]+click (Mac OS X) on the selected cell and select Change Label.

2. Type a value in the cell.

3. Press [Return] to move on to the next cell.

4. Press [ESC] to quit the edit mode.
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Extending Exposure 
The Extend Exposure feature allows you to select a drawing exposure to make it appear longer in the scene.

To extend a drawing exposure:

1. In the Exposure Sheet or Timeline view, select the drawing (cell) to extend.

 You can also select the last cell of the area where you want the drawing exposure to end, as opposed to 
selecting the drawing cell directly. The cell must be an empty cell.

2. In the top menu, select Element > Cell > Extend Exposure or use the keyboard shortcut [Ctrl]+[Shift]+1 
(Windows) or []+[Shift]+1 (Mac OS X).
 If you selected the drawing cell, the Extend Exposure dialog box opens.
 If you selected the last cell where you want the exposure to end, the exposure is automatically extended.

3. In the Extend to Frame field, type the frame number you want to extend the cell to.
4. Click on the OK button.
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Dragging Cells 
To readjust your timing, you can drag one or several cells to a new location in both Timeline and Exposure Sheet view.

You can only drag a cell in the same column or layer.

To drag a cell to another location:

1. In the Timeline or Exposure Sheet view, select one or several cells to move.

2. Click on the cells selection and drag it to the new location.

 If you drop the selection, it overwrites the existing cells.

 If you hold [Ctrl] (Windows) or [] (Mac OS X) while dropping the selection, the cells are copied and not 
moved.

 To change the starting frame of an element, you can also use the Change Start Frame command.
 In the top menu, select Element > Change Start Frame.

 Type the frame number where you want the selected layer to start.
 Click on the OK button.
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Increasing and Decreasing Exposure
Once a value is entered in the Timeline or Exposure Sheet view, you can increase and decrease its exposure.

This section is divided as follows:

• Add Exposure, on page 196
• Remove Exposure, on page 197

Add Exposure 
Increasing the exposure adds one more exposure to a selected cell, repeating this action adds an extra cell every time. 
This is a quick way of extending a drawing exposure. Increasing an exposure always pushes the existing exposure 
down.

To add exposure to a drawing:

1. In the Timeline or Exposure Sheet view, select a cell.

 
2. In the top menu, select Element > Cell > Add Exposure. 

You can also right-click (Windows) or [Ctrl]+click (Mac OS X) on the selected cell and select:
 From the Timeline view, Exposure > Add Exposure.
 From the Exposure Sheet view, Add Exposure.
 The default keyboard shortcut is [R].
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Remove Exposure 
Decreasing the exposure removes one exposure from a selected cell, repeating this action removes an extra cell every 
time. This is a rapid way to reduce a drawing exposure and remove the exposed drawing.

To use Decrease Exposure:

1. In the Timeline or Exposure Sheet view, select a cell.

2. In the top menu, select Element > Cell > Remove Exposure.                       
You can also right-click (Windows) or [Ctrl]+click (Mac OS X) on the selected cell and select:
 From the Timeline view, Exposure > Remove Exposure.
 From the Exposure Sheet view, Remove Exposure.
 The default keyboard shortcut is [E].
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Deleting Exposure
You can delete a drawing’s exposure and blank cells in several simple ways. Note that when you delete a drawing’s 
exposure from the Timeline or Exposure Sheet view, you are not deleting the actual drawing file. You can always bring 
it back by typing its name again in a cell.

Refer to the Layer Concepts topic to learn more about the drawing concept.

To delete selected exposures:

1. In the Timeline or Exposure Sheet view, select all the exposure you want to delete.
2. Press the default keyboard shortcut [Delete].
 You can also right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Delete Cell.

To delete blank cells:

1. In the Timeline or Exposure Sheet view, select a blank cell.
2. In the top menu, select Element > Cell > Delete Blank Cell.

 You can also right-click (Windows) or [Ctrl]+click (Mac OS X) on the selected cell and select Delete Blank 
Cell.

 The default keyboard shortcut is [Shift] + [E].

Inserting Blank Cells 
Use the Insert Blank Cell option to place an empty cell between other cells. This pushes down existing exposure.

To use Insert Blank Cell:

1. In the Exposure Sheet or Timeline view, select the cell where you want to insert a blank cell.

 
2. In the top menu, select Element > Cell > Insert Blank Cell. You can also right-click (Windows) or [Ctrl]+click 

(Mac OS X) on the selected cell and select Insert Blank Cell.
 The default keyboard shortcut is [Shift] + [R].

The blank cell is inserted.
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Setting the Exposure 
You can easily increase or decrease the exposure for a selected cell range by using the Set Exposure options.

To use the Set Exposure options:

1. In the Timeline or Exposure Sheet view, select the cell range that you want to set the exposure for.

2. In the top menu, select one of the following:
• Element > Cell > Set Exposure to 1 
• Element > Cell > Set Exposure to 2 
• Element > Cell > Set Exposure to 3 
• Element > Cell > Set Exposure
 If you choose the Set Exposure option, the Set Exposure dialog box opens.

 Type the number of frames you want each of the drawings to be displayed.
 Click on the OK button

The new timing is displayed.
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Filling a Selection with a Sequence
The Insert Cell option is used to create a numbered sequence over a selection.

To fill a selection with a sequence:

1. In the Exposure Sheet or Timeline view, select one cell or a cell range.

 
2. Select Element > Cell > Insert Cell.
 If you selected only one cell, the Insert Cell dialog box opens.
 If you selected a frame range, the timing sequence appears.
 If you select multiple cells across different layers (i.e. one cell on each layer), the behavior is that Insert Cell 

will add an extra row of blank cells before the selected cells.

3. In the Number field, type the number of cells.
4. If you want to insert cells with numbers in it, enable the Named Cells option. If you want to insert blank cells, 

disable the Named Cells option.
5. If you want to insert these new cells in all the layers, enable the In All Elements option. If you want the new cells 

to be added only in the currently selected layer, disable the In All Elements option.
NOTE: Selecting in All Elements disables the Named Cells option and the cells added to all the elements are 
blank.

6. If you want the new cells to be inserted before the currently selected cell, enable the Before option. If you want 
the new cells to be inserted after the currently selected cell, enable the After option.

7. Click on the OK button.
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Creating Cycles
Once you have entered a series of drawings and exposures, you can create cycles out of them in several ways.

You can loop your drawings using the following commands:

• Create Cycle
• Create Advanced Cycle

The Create Cycle command is used to do simple cycles on your selected drawings. The Create Advanced Cycle 
command is used to create more complex cycles including reversed cycle.

For example, a bouncing ball cycle where the sequence of drawings goes backwards and forwards during the cycle 
(1-2-3-4-3-2-1).

You can use the Advanced Cycle dialog box to automate the process of creating complex cycles.

When you cycle your selection, you are not duplicating the drawings. If you have a drawing named “1” in your cycle, 
when you modify that drawing, it is updated in all the cycles at once.

To use the Create Cycle command:

1. In the Timeline or Exposure Sheet view, select the cell range to cycle.

2. In the top menu, select Element > Cell > Create Cycle.

The Create Cycle dialog box opens.

3. Enter the number of cycles you want, including the current selection.
4. Click on the OK button.

To use the Create Advanced Cycle command:

1. Select the element where you want to create the cycle.
2. Select Element > Cell > Create Advanced Cycle.
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The Advanced Cycle dialog box opens.

3. In the First Drawing and Last Drawing panels, select the drawings that you want in the first and last position of 
the cycle. You can type the drawing name in the Name fields or use the slider to select the drawings.

4. In the Exposure panel, set the number of cells you want each drawing to be exposed for during the cycle. You 
can set a different exposure for the last drawing in the cycle to stay on-screen by typing the amount of cell you 
want it to be exposed in the Exposed Last Drawing For field.

5. In the Loops panel, select the number of times you want the cycle to repeat.
• Select None if you don’t want the cycle to repeat.
• Select Continuous if you want the cycle to restart with the first drawing on each loop. 

For example, if you created 2 continuous loops of drawings 1-2-3, the resulting loop would be: 1-2-3-1-2-3.
• Select Forward-Backward if you want the loop to contain the specified drawings in continuous order (first to 

last) followed by a backward order (last to first). In the Forward-Backward loop the last frame is only 
displayed once. Every consecutive loop starts with the second frame so that the first frame is not repeated. 
For example, if you created 2 forward-backward loops with drawings 1-2-3, the resulting loop would be: 1-
2-3-2-1-2-3-2-1.

• Loops field: type the number of times you want the cycle to repeat. 
• Frames field: type the number of frames. By default the Frames field is set to the number of number of 

frames.
6. Select how you want to insert the cycle.

• Select Insert Frames to add the cycle in the current location.
• Select Overwrite Frames to delete frames that overlap the cycle.
202 



Chapter 7: Layers and Timing   
7. Click on the OK button.
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Navigating Between Frames and Columns 
Once a cell is selected in the Timeline or Exposure Sheet view, you can navigate between the layers and drawings 
using keyboard shortcuts that are effective in the Camera, Drawing, Timeline and Exposure Sheet views.

You can navigate through:

• Columns
• Drawings
• Frames
• Elements

To navigate through the drawings, frames and elements:

1. In the Timeline or Exposure Sheet view, select a cell.

2. Once the cell is selected, you can navigate between:
 Previous and next Timeline layers: by using the keyboard shortcuts [D] and [F].

 Previous and next Exposure Sheet column: by using the keyboard shortcuts
[Shift]+[D] and [Shift]+[F].

D

F

[Shift]+[D] [Shift]+[F]
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 Previous and next drawings: by using the keyboard shortcuts
[Shift]+[A] and [Shift]+[S]. 

 Previous and next frames: by using the keyboard shortcut [A] and [S].

[Shift]+[A]

[Shift]+[S]

[A]

[S]
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Managing Drawings
Drawings that are created in Toon Boom Studio are not encapsulated in their cells. They are actual files stored in the 
project’s Drawing folder. If you want to rename a drawing, you need to use the Rename Drawing command, instead 
of typing in the cell.

This section is divided as follows:

• Renaming a Drawing, on page 206
• Duplicating a Drawing, on page 206
• Copying and Pasting Drawings, on page 207

Renaming a Drawing
To rename a drawing select the cell containing the drawing and use the Rename Drawing command from the Exposure 

Sheet contextual  menu.

NOTE: Do not type the new name in the cell as this will create a new drawing instead of renaming the existing one.

To rename a drawing:

1. In the Exposure Sheet view, select the drawing to rename.

2. Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select
Rename Drawing.

The Rename Drawing dialog box opens.

3. In the Drawing Name field, type the new drawing name.
4. Click on the OK button.

Duplicating a Drawing
If you want to modify an existing drawing, but keep the original drawing intact, you can duplicate the drawing and 
work on the copy. When duplicating a drawing, the selected cell is replaced with the new drawing. The original 
drawing is not deleted and can still be accessed from the Drawing folder.
To duplicate a drawing:

1. In the Timeline or Exposure Sheet view, select the drawing to duplicate.
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2. Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Duplicate Drawing.

Copying and Pasting Drawings
When you copy and paste a selection in the Timeline or Exposure Sheet view, you are not copying and pasting the 
actual drawings, you are pasting the exposure.

If you want to copy and paste the selected drawings into a different layer or paste the selection in the same layer to 
duplicate the drawings, you must use the Paste New Object command.

To paste drawings as new objects:

1. In the Timeline or Exposure Sheet view, select the drawings to copy.

2. In the top menu, select Edit > Copy/Copy Cell. The default keyboard shortcut is [Ctrl]+[C] (Windows) or []+[C] 
(Mac OS X).

3. In the Timeline or Exposure Sheet view, select the cell where you want your pasted selection to start.

4. In the top menu, select Edit > Paste New Object. The default keyboard shortcut is [Ctrl]+[Shift]+[V] (Windows) 
or []+[Shift]+[V] (Mac OS X).
207



Toon Boom Studio User Guide
Preferences 
When adjusting your timing in the Timeline and Exposure Sheet views, you may want to set some preferences.

This section covers the preference related to the timing measurement.

To open the Preferences panel:

 Windows: Select Edit > Preferences.
 Mac OS X: Select Toon Boom Studio 7.1 > Preferences.

Time Measurement 
The Time Measurement preference is located in the Interface tab. It is used to change the way the timing 
measurement is displayed in the Timeline and Exposure Sheet view.

 In the Time Measurement drop-down menu, select either the Frames or the Feet and Frames option and 
click on the OK button.

There are two ways of measuring an animation timing: 

• Frames: 
The animation timing is measured in frames per second. To get a fluid animation, you need a minimum of 12 
frames per second. This technique is frequently used when working with a software.

• Feet and Frames:
This technique is mainly used when shooting the animation frame-by-frame directly on film. The length of 
the animation is calculated in length of film rather than frames per second.
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What’s Next?
So far, you have learned about:

• The Timeline and Exposure Sheet Views
• Layers and Columns
• Filling Exposure
• Navigating Between Frames and Columns
• Managing Drawings

It is now time to learn about Studio’s hand-drawn animation features.
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Chapter 8  Traditional Digital 
Animation

Traditional digital animation, also known as hand-drawn animation, is the process of drawing every frame of an 
animation. This is very different from using cut-out puppets, where body parts drawn at different angles are stored in 
a bank and are swapped. These drawings do not use motion paths; everything is hand-drawn.

With the advent of digital animation, much has changed in the way that animation is done. However, there are still 
tried and true animation tools and techniques that every animator may still find useful. Most of these techniques are 
derived from the classic method of traditional animation.

The following sections will be covered in this chapter:

• Traditional Animation Tools, on page 212
• Animating Traditionally, on page 218
• Rotoscoping, on page 224
• Marking Corrections and Notes, on page 228
• Preferences, on page 230
• What’s Next?, on page 231
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Traditional Animation Tools
When you animate digitally using traditional techniques, certain tools are needed to work effectively. Just as an 
animation table, paper and pencils are essential to the traditional animator, the tools listed here are needed for 
traditional animation when it is done digitally. 

• Onion Skin, on page 212
• Auto Light Table, on page 213
• Static Light Table, on page 214
• Reposition All Drawings, on page 215
• Lock Drawing, on page 217
• Clear Drawing, on page 217

 Onion Skin

The Onion Skin is used to preview the previous and next drawings. This feature comes in handy when animating 
because it allows you to see the flow of a movement and lays it out in visible steps. By default, the previous drawings 
will appear with a shade of red and the next drawings will be displayed with a shade of green but you can change the 
display options in the Preferences panel.

Refer to the Preferences topic to learn about the Onion Skin preferences.

To use the Onion Skin feature:

1. Enable the Onion Skin feature:

 Using Windows, in the Onion Skin toolbar, click on the Show Onion Skin  button.

OR

 Using Windows and Mac OS® X, from the top menu, select View > Onion Skin > Turn On Onion Skin.
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2. You can select the number of previous and next drawings you want to show either by clicking on the button from 
the Onion Skin toolbar or by following any of the menu paths listed below:

  Select View > Onion Skin > No Previous Drawing
The default keyboard shortcut is [Shift]+[Q].

  Select View > Onion Skin > Previous Drawing

  Select View > Onion Skin > Previous Two Drawings

  Select View > Onion Skin > Previous Three Drawings

  Select View > Onion Skin > No Next Drawing
The default keyboard shortcut is [Shift]+[W].

  Select View > Onion Skin > Next Drawing

  Select View > Onion Skin > Next Two Drawings

  Select View > Onion Skin > Next Three Drawings
3. The previous and next drawings will appear in both the Drawing and Camera view.

Auto Light Table 

The Light Table is used to preview the active layers above and beneath the selected layer. It is useful to be able to see 
the other layers when designing, animating or cleaning up your animation.

The Light Table feature is only available in the Drawing view.

To use the Light Table feature:

4. Enable the Light Table feature:
 When working in the Drawing view, select View > Turn On Auto LightTable. 

 In the Onion Skin toolbar, click on the Light Table  button.
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5. The drawings are displayed in the Exposure Sheet view.

6. In the Exposure Sheet view, you can disable the layers you wish to hide from the Light Table for the Drawing 
view.

Static Light Table 

The Static Light Table works differently than the Auto Light Table and can only be accessed from the Exposure Sheet 
view. By using this feature, you can lock one drawing and have it appear in washed out colours behind every drawing, 
existing on any frame, belonging to any layer.

To use the Static Light Table feature:

1. Go to the Exposure Sheet view.
2. Right-click on the cell that contains the drawing that you wish to lock onto the Static Light Table.
 From the pop-up menu select Send to Static Light Table.

Click on another cell where you would like to work with the aid of the drawing locked on the Static Light Table, then 
proceed to draw in the Drawing or Camera view. 
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To display the elements on the Static Light Table:

1. From the Exposure Sheet toolbars, click on the Toggle Static Light Table  button.

 

Thumbnails of the drawing appear under the Exposure Sheet columns.

2. Send more than one cell containing drawings to the Static Light Table.
3. Use the checkmark boxes to show or hide the drawings sent to the Static Light Table.
4. Use the foreground/background swatches button to toggle the drawings sent to the Static Light Table either 

behind or in front of your other drawings seen in the drawing view. 

To clear a cell from the Static Light Table:

1. Right-click on the thumbnail that you wish to delete.
2. From the pop-up menu select either Delete to remove that particular cell, or Delete All to remove all cells from 

the Static Light Table.

Reposition All Drawings

The Reposition All Drawings tool is used to change the position, scale, rotate or skew all the drawing strokes on every 
frame belonging to the same layer. 

To reposition all drawings:

1. In the Drawing Tools toolbar, select the Reposition All Drawings  tool. This also automatically selects every 
stroke that composes your drawing in the Drawing view.
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To deform or reposition a selection:

 To reposition, click and drag your selection to a new area.

 
 To rotate, move the selection box handle in a circular motion.

 To scale, pull or push either on the side, top or corner control point. Hold down [Shift] to lock the selection’s 
ratio.

 To skew, drag the sides or top and bottom segments, between the control points.
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2. When you release your cursor, every drawing contained in the drawing layer you repositioned, scaled, rotated or 
skewed will follow the same transformation.

Lock Drawing 
Although the Reposition All Drawings tool can be quite useful, sometimes you might need to reposition all but a few 
drawings. Or in general, there might one or two elements, such as a background or point of reference that must 
absolutely remain fixed. The Lock Cell option is an good way to keep certain individual frames from moving, or from 
accidentally being drawn on.

To use the Lock Drawing option:

1. In the Exposure Sheet view, select the cell that contains the drawing that you want to lock.
2. Right-click on this cell and from the pop-up menu select Lock Drawing.

The cell containing the drawing should now be locked as indicated by the lock icon beside the cell name.

Clear Drawing 
Another feature to make drawing by hand much easier is the clear drawings feature from the Exposure Sheet view. 
Often when you are drawing with your Wacom tablet directly in the software, you might decide that you would like 
to start a particular drawing in an action sequence from scratch. 

If you delete the frame from the Timeline view, there will be a gap in your timeline. If you use the Select tool to select 
all your drawing strokes and delete them you might risk missing a few strokes, as well as taking three steps to do what 
you could do in one.

To use the Clear Drawing command:

1. In the Exposure Sheet view, right click on the cell that contains the drawing strokes that you wish to delete.
2. From the pop-up menu, select the Clear Drawing command.

The Clear Drawing command does not work on Image layers or on extended exposure cells; the command 
only works on Drawing layers.
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Animating Traditionally
In Toon Boom Studio, you can easily animate traditionally and work entirely digitally. The process of hand-drawn 
animation through traditional animation procedures has been divided to lead you easily through the process.

• Animating , on page 218
• Cleaning Up, on page 220
• Power Painting, on page 222
• Setting the Timing, on page 223
• Playing Back Your Animation, on page 223

Animating 

Now that you are aware of the existing tools, you can start your animation.

The first step to complete is the rough animation, which is the skeleton of your animation. You would usually start with 
the main action. For example, to animate a walk-cycle, you will start with the torso moves and the legs. Head, arms 
and clothes will be added later, during the secondary animation.

For a satisfactory animation, complete the main action before adding all of the details. If you start animating all of the 
details right away, you will lose a lot of time if you have to do corrections, and your animation will often look too rigid.

To animate:

1. In the Timeline view, create a new drawing layer and name it Rough.

2. In the Tools toolbar, select the Brush  tool, you can also use the default keyboard shortcut [@].
3. In the Colour view, select the colour you will use to draw. It is a good idea to choose a light colour for your rough 

animation to help for the following task, the Clean Up process.

4. In the Timeline or Exposure Sheet view, select the cell where the first drawing will appear.
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5. In the Drawing or Camera view, draw the first Key drawing.

6. In the Tools toolbar, click on the Enable Onion Skin  button.

7. From the Onion Skin toolbar, click on the onion skin’s previous  or next  drawing buttons and from their 
drop-downs, select the number of previous and next visible drawings that you think you will need.

8. In the Timeline or Exposure Sheet view, select the cell where your next key drawing will appear.

 
9. In the Camera view, draw your second key drawing.

10. In the Exposure Sheet View, select a cell between your two key drawings.

 

219



Toon Boom Studio User Guide
11. Draw your new drawing.

12. In the Timeline or Exposure Sheet view, select a new cell and repeat these steps for the new drawings.

Cleaning Up 

When your rough animation is ready, it is time to clean it up and ink it. The clean-up is also called tracing. It consists 
of tracing solid and clean lines over the rough animation to get closed zones. This is the final paperless animation step 
before the ink and paint step.

You will need to add a new drawing layer to draw your clean drawings. This is the equivalent of adding a sheet of 
paper and tracing over the rough using the animation disk.

NOTE:

If you plan on tracing your animation in the Drawing view, you will need to enable the 

Light Table  feature in order to display all the layers of your project.

To trace your animation in a new layer:

1. In the Timeline view toolbar, click on the Add Drawing Layer  button.
2. Rename your new layer Clean.

3. In the Timeline view, select your rough layer and then click on the menu  button.
4.  From the pop-up menu select Lock > Lock.

This is to prevent any accidental changes.

5. In the Timeline or Exposure Sheet view, select the cell on the clean layer corresponding to the first key drawing 
of your rough animation.

6. In the Drawing Tools toolbar, select the drawing tool of your choice.
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7. In the Colour view, select the colour you will use to trace your animation. Pick a bold dark colour such as black to 
make sure it contrasts well with the light colour of your rough animation.

8. In the Camera view, start tracing the first key drawing.

9. If you have some other layers in the way, you can disable (uncheck) them temporarily so that only your rough 
animation and your clean-up layer are displayed. You can do this in two ways, either by unchecking these layers 
in the Timeline to affect what is seen in the Camera view, or disable them in the Exposure Sheet view to affect 
the Drawing view.

10. In the Tools toolbar, click on the Enable Onion Skin  button and extend the previous and next drawing 
numbers.

11. In the Timeline or Exposure Sheet view, select the next cell corresponding to a rough drawing.
12. In the Drawing or Camera view, trace your next drawing.

13. Repeat these steps for the rest of your rough drawings until you have a full set of clean ones.

NOTE:

This method allows you to keep the roughs and the cleans intact. You only need to disable the rough layer to prevent 
it from appearing in the scene. 
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Power Painting
When you create a traditional digital animation, you need to paint each drawing one at a time. But you can use the 
Paint All tool to automatically paint closed zones in the same location within an element. To use the Paint All tool, you 
click a zone in a drawing object. Toon Boom Studio then flips through all of the drawings in the element to see if there 
is a closed zone in the location you clicked. If there is, it fills the zone with the same colour. This can save you a lot of 
time when painting your animation.

 You can use the onion skin to select a location to click.

 To learn more about painting, colour palettes and Onion Skin, refer to:

• Chapter 5: Adding Colours, on page 105
• Onion Skin, on page 212

To power paint drawings in an element:

1. Enable the Onion Skin feature:

 Using Windows, in the Onion Skin toolbar, click on the Show Onion Skin  button.

OR
 Using Windows and Mac OS® X, from the top menu, select View > Onion Skin > Turn On Onion Skin.

2. You can select the number of previous and next drawings you want to show either by clicking on the button from 
the Onion Skin toolbar or by using the View > Onion Skin menu.

The previous and next drawings will appear in both the Drawing and Camera view.
3. From the Colour Palette view, select the swatch you want to use to paint the zone.

4. Select the Paint  tool from the Drawing Tools toolbar, or select Tools > Drawing Tools > Paint from the top 
menu. 

5. Press [Shift]+[Alt] (Windows) or [Shift]+[Option] (Mac OS X) and click a zone that many drawings in the element 
share.

6. Toon Boom Studio evaluates all of the drawings in the element to determine if there is a closed zone beneath 
where you clicked.
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Setting the Timing
To learn how to set the timing of your animation, refer to the Layers and Timing chapter.

Playing Back Your Animation
You can playback your animation in the Camera view using the Playback toolbar.

To play back your animation:

1. Be sure you are currently using the Camera view, as this feature is not available in the Drawing view.
2. In the Timeline view, disable the layers you do not want to show during playback.

3. In the Playback toolbar, click on the Loop  button if you want the playback to loop.

4. In the Playback toolbar, click on the Play  button to start the animation.
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Rotoscoping 
Maybe you’ve heard about this process, but are not sure about how it can help you with your own animation. Perhaps 
you have an idea of how this technique can work with your project, but don’t know where to begin. This section will 
help you get started.

• What is Rotoscoping?, on page 224
• Selecting a Video, on page 225
• Tracing the Character, on page 226
• Painting the Animation, on page 227

What is Rotoscoping?

Rotoscoping is an animation technique where the animator traces over each frame of a live-action movie to reproduce 
a realistic movement. This technique was invented by Max Fleischer in 1915. The movie was projected frame by frame 
onto a piece of glass that the animator could trace over. The piece of equipment used in this process is called a 
Rotoscope. Today, the Rotoscope has been replaced by the computer.

Reasons for Rotoscoping
Some of the reasons that some people may chose to use this process are listed below:

• The motion is very realistic
• The timing is accurate
• The characters or other elements retain their proportions and volume
• It helps you learn how to animate
• It helps you to understand how to break down a movement
• It teaches you how to animate very subtle motions, like a slight head turn or a slow raise of the hand

You can also superimpose your character design and only use the motion but not the actual object, person or animal 
from the video.

Due to the fact that rotoscoping is so realistic, it leaves little room for exaggeration, movement, squash and stretch, 
or a very cartoony look, so you have to be aware if this process suits your project.
224 



Chapter 8: Traditional Digital Animation   
Selecting a Video 

Selecting a video to rotoscope is simple, either:

• Film the actions you need to animate yourself. For example, you could film a dog playing with a ball or a 
person running.

• Find a free movie clip on the web.
• Purchase a royalty-free movie clip from a website.

Your movie format can be any of the following:

• AVI (*.avi)
• QuickTime (*.mov)
• MPEG (*.mpg)
• iPod (*.m4v)

If you find a movie clip that is not in any of the formats listed above, you can easily convert it in an editing software.

Your clip doesn’t need to have a very high resolution, however the higher the resolution, the more detail you will be 
able to see. A minimum resolution of 300x200 is recommended.

Importing a Video 
When you create your Toon Boom Studio project, you can avoid having too many drawings to trace over by creating 
the project with a rate of 12 frames per second instead of 24 FPS. 

To import your video:

1. In the top menu, select File > Import File.
2. Browse for your clip.
3. Click on the Open button.
4. In the Import Options dialog box, do NOT set an opacity value.

5. Click on the OK button.
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Tracing the Character 
Before you start tracing your movie, setup your brush with a low smoothness and a lively tracing colour. This is so that 
your lines will be more faithful to the video still and so that you will be able to see your lines clearly.

Tracing

When you trace over your imported movie, you should concentrate on one element at a time. For example, if there 
is a boy running with a balloon, we would trace the boy first and then move on to the balloon. This helps when trying 
to create separate movements. The boy would move differently than a balloon, even if they were moving at the same 
speed and in the same direction.

If the two objects or characters are interacting, it is best to draw them on the same layer.

Remember, when you trace over the character, try to close your zones for fast and efficient painting later on.

To trace your animation:

1. In the Timeline view, add a new layer to trace your animation.

2. If you work in the Drawing view, enable the Light Table  to see the live-action frames.
3. In the Camera/Drawing view, zoom into your image to see the details better.
4. Trace your first frame.

5. In the Timeline view, select the second cell and trace your second image.

6. In necessary enable to Onion Skin  to see your previous drawings.
7. Repeat the process until the animation is entirely traced.

Fine Tuning the Animation 
Once your animation is traced, it is a good idea to disable (uncheck) the live-action clip layer or turn off the Light Table 
and then go over your animation to fix the little details, such as open zones and uncompleted lines.

 To learn more about closing gaps and making invisible strokes, refer to the Drawing chapter.

If you want your final project to be lighter once you are done tracing, it is recommended that you select your lines and 
flatten them.

To flatten your drawings:

1. In the Drawing Tools toolbar, click on the Select  tool.

2. In the Timeline view, select the first frame of the tracing layer.
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3. In the Camera/Drawing view, select your entire drawing.

4. From the top menu, select Tools > Flatten.
5. Repeat this process for all your drawings.

Painting the Animation 

 

To create your colour palette, use Toon Boom Studio’s special dropper to pick colours from your live-action movie and 
paint your animation in the same colours as the clip.

To create your colour palette:

1. In the Colour view, create and rename your new palette.

2. In the Colour list section, add a new colour swatch by clicking on the Add Colour  button.
3. In the Camera view, display your live action movie.
4. Double-click on the new colour swatch to display the Colour Picker window.
5. In the Colour picker window, click on the Eye Dropper button.
6. In the Camera view, pick the desired colour.
7. Repeat this process until the colour palette is entirely finished.

Your animation is now ready for painting. 

When you are ready to publish your animation, refer to the chapter Exporting Your Project.
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Marking Corrections and Notes 
For the first time, Toon Boom Studio has integrated several features to make adding notes and making visual 
corrections easy.

• Annotation Elements
• Notes

Annotation Elements 
It doesn’t matter if you want to place notes, suggestions or corrections to the anatomy of a drawing, you will find the 
annotation levels are invaluable.

To create an annotation element:

1. From the Timeline view’s the contextual  menu, select New > Annotation or select 

Element > Add > Annotation from the top menu. You can also click on the Add Annotation  button in the 
Exposure Sheet View toolbar.

The Annotation element appears in the Timeline and Exposure Sheet view.

2. Draw or make notes on this layer.

You can also select an existing Drawing element and convert it to an Annotation element.

To set a Drawing element as an Annotation element:

1. In the Timeline view, select a Drawing element.

2. From the Timeline view’s the contextual  menu, select Annotation Elements > Set As Annotation Element 
or select View > Annotation Elements > Set As Annotation Element from the top menu.

The colour of the element name will change from black to blue and the prefix Annotation will be added to it.

After the animator has made all the requested changes, it is possible to view the full animation without seeing all the 
red marks and arrows.

To hide an annotation element:

1. In the Timeline view, select the annotation element.

2. Click on the Timeline view’s contextual  menu and select 
Annotation Elements > Hide All Annotation Elements. 
You can also select View > Annotation Elements > Hide All Annotation Elements from the top menu.
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Working with Notes

Layer Notes 
Another way to write small reminders, either to yourself or for others, is by writing a layer/element note.

To write a layer/element note:

1. In the Timeline view, right-click on the layer in question and select Add Element Note or from the top menu, 
select Element > Add Element Note.

The Note dialog box appears.
2. Type in a message, either to remind yourself about something concerning this layer, or for the next person you 

are passing this project on to.

3. When you are finished typing your message, click OK.

The existence of the message will be indicated by a small note icon on the respective element in both the 
Timeline and Exposure Sheet views.

 

Later on, if you want to edit or reread your own message, or access the message of another person, simply double-
click on the icon or from the top menu, select Element > Update Element Note and the Note box will reappear.

Cell Notes 
To go into greater detail, or to make notes more specific, you can also create notes for an individual cell or frame. 

To create a cell note:

1. In the Exposure Sheet view, select the cell that you would like to make notes on.
2. Right-click and select Add Cell Note or from the top menu select Element > Cell > Add Cell Note.

The Note dialog box appears.
3. Compose a message about that specific cell or a drawing on that cell.
4. When you are finished composing your message, click OK.

The existence of the cell note will be indicated by a small note icon on the respective cell only in the Exposure 
Sheet view.

Later on, if you want to edit or reread your own message, or access the message of another person, simply right-click 
on the cell and select Update Cell Note or from the top menu, select Element > Cell > Update Cell Note and the 
Note box should reappear.
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Preferences
When doing traditional digital animation, you work with features and options which default behaviour can be 
customized via the Preferences panel. 

To open the Preferences panel:

 Windows: Select Edit > Preferences.
 Mac OS X: Select Toon Boom Studio 7.1 > Preferences.

You can find the preferences relating to the Onion Skin and Static Light Table features under the Light Table tab of 
the Preferences panel.

Onion Skin

By default the onion skin is displayed as the element’s shape in washed-out colours. Green represents the previous 
frames and red represents the next frames. But you can use the Preferences to customize the onion skin display.

• Enable Transparency
By default the onion skin is displayed with transparency. You can change this behavious so that the onion 
skin drawing shows as opaque by disabling this option.

• Enable Colour Shading
By default the onion skin’s previous and next drawing are displayed in red and green washed out colour. You 
can disable the Enbale Colour Shading to use the current drawing’s colours washed out as the onion skin 
display.

• Previous Drawing Colour
Click on the red colour swatch to display the colour picker in which you can select a new colour for the 
previous drawings displayed in the Camera view.

• Next Drawing Colour
Click on the green colour swatch to display the colour picker in which you can select a new colour for the 
next drawings displayed in the Camera view.

Static Light Table

• Enable Shade
By default the Static Light Table will display the other drawings as washed out colours. You can disabled this 
option to display the other drawings with their real colours.
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What’s Next?
So far, you have learned about:

• Traditional Animation Tools
• Animating Traditionally
• Rotoscoping
• Marking Corrections and Notes

It is now time to learn about creating animated puppets from your drawings or photographs.
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Chapter 9  Creating a Cut-out Puppet

With Toon Boom Studio’s extensive set of tools, you are able to create animated puppets from your drawings or 
photographs. This technique is known as cut-out animation because of the way you move cut-out pieces around 
instead of drawing.

This chapter is divided as follows:

• About Building a Cut-out Puppet, on page 234
• Choosing Your Character, on page 235
• Cutting the Character into Pieces, on page 237
• Attaching the Pieces, on page 242
• Storing the Character in the Library, on page 249
• What’s Next?, on page 250
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About Building a Cut-out Puppet 
The Toon Boom Studio cut-out puppet principle is very similar to cutting up a character drawn on a sheet of paper 
and assembling the pieces using little brass fasteners. You create a drawing for each your character's body parts and 
attach them in the Timeline view. Then, you can articulate the character and animate it by giving it a slightly different 
pose on each frame.
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Choosing Your Character 
As you start building your puppet, the first thing you need to do is to select your character. If this is your first puppet 
it is always better to choose a simple character. A simple character is a character with two legs, two arms, a head and 
torso. To start with you should avoid a character with too many loose clothes such as a cloak or baggy pants. Once 
you are used to constructing puppets, you will understand how to cut them apart and loose clothing won’t be as much 
of a challenge for you.

The character we chose to demonstrate how to cut apart a character is a turtle.

You could also create your character from a picture. Instead of drawing a turtle, you could use a photograph of a turtle 
and break it apart in Toon Boom Studio or another third party software such as Adobe Photoshop.
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Creating a New Project and Importing a Character
The best way to break down your character is to create a new scene and import the character into the scene. There 
are several ways to import your character in a scene: 

• You can create a template using the Library and import it in your new scene
• Import a bitmap image
• Scan a drawing
• Import a picture, etc.

If you import a picture, make sure to import it in a Vector element and not an Image element so that you can erase 
portions and cut pieces.

Refer to the following chapters to learn more about creating projects, scanning your drawings, importing bitmap 
images and photos, creating templates and importing templates:

• Starting Your Project - Creating and Opening a Project, on page 22
• Importing Artwork - Scanning Images, on page 157
• Importing Artwork - Importing Bitmaps Images, on page 142
• Importing Artwork - Library, on page 160

Creating a Colour Palette
Once your drawing is imported into your new scene you will need to create a new colour palette for your puppet, 
unless, of course, you are using a photograph.

Refer to the following chapter to discover how to create a colour palette for your character:

• Adding Colours - Palettes, on page 132
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Cutting the Character into Pieces 
To cut up your character into pieces, you must first decide which parts of the final character will move. 

If you are building your first puppet, start with a very simple breakdown. Most of the time, you will want to animate 
the arms, legs and head. It is not necessary to separate all the facial features from the head or to break down the knees 
and elbows to get a working puppet. You can break the character into six pieces and it will still be enough to produce 
a nice animation.

If you feel like extending the amount of articulation the puppet has it’s up to you. You can bend the arms and legs, 
and separate the head into several different pieces to animate the eyebrows and make the eyes blink.

Head

Left Arm

Body

Right Arm

Left Leg
Right Leg
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How to Cut the Pieces 
Once you know what you want to animate, it is time to cut the different pieces required for the animation. There are 
two ways to do so. First, you can use the Cutter and Scissor tools to cut the portion needed and use the drawing tools 
to complete the missing portion or, if you are not using a photo, you can trace the new pieces using the drawing tools.

Cutting out your Pieces
You will now learn about cutting parts of your character and completing any missing areas. If you are using a picture, 
and since Toon Boom Studio mainly edits vector images, you may want to do this process in a bitmap editing software 
such as Adobe Photoshop. 

 You can use the Show Strokes feature to help you see more clearly the region you will be cutting using the Cutter 
tool.

• You can display the strokes from the top menu, select View > Show Strokes. The default keyboard shortcut 
is [K]. 

To cut your pieces:

1. In the Tools toolbar, select the Cutter  tool.

2. In the Drawing view, trace a selection around the part to cut.

3. In the Tools toolbar, select the Drawing Select  tool.

4. In the Drawing view, select the cut zone.

5. In the top menu, select Edit > Copy Drawing Object.
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6. In the Timeline view, click on the Add Drawing Element  button and rename the new layer corresponding to 
the new piece you want to create.

7. On the right side of the Timeline view, select the new layer’s first cell.
8. Click on the Drawing view, to activate it.
9. In the top menu, select Edit > Paste Drawing Object.

10. In the Tools toolbar, select a drawing tool to clean and complete your new drawing. We recommend that you 

use the Brush  and the Eraser  tools.

11. In the Onion Skin toolbar, enable the Light Table  button so you can see your original drawing while you 

draw. 
12. In the Drawing view, clean and complete your new drawing. Make sure to draw a complete shape that overlaps 

the other body parts.

13. In the Tools toolbar, select the Paint  tool.
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14. In the Colour Palette view, select the colour needed.

15. In the Drawing view, paint your new drawing.

16. Save your project.
17. Repeat the same process for each new piece to create.

Drawing your Pieces
To draw your pieces:

1. In the Timeline view, click on the Add Drawing Element  button and rename the new layer corresponding to 
the new piece you want to create.

2. On the right side of the Timeline view, select the new layer’s first cell.

3. In the Tools toolbar, select the drawing tool of your choice. We recommend that you use the Brush  tool.

4. In the Onion Skin toolbar, enable the Light Table  button to see your original drawing while you draw.
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5. In the Drawing view, trace the new piece. Make sure to draw a complete shape overlapping with the other body 
parts.

6. In the Tools toolbar, select the Paint  tool.

7. In the Colour Palette view, select the colour needed.

8. In the Drawing view, paint your new drawing.

9. Save your project.
10. Repeat the same process for each new piece to create.
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Attaching the Pieces

Once all your pieces are completed, it is now time to attach them to each other, the same as you would do with the 
brass fasteners. To do so, you will connect your layers one to another in the Timeline view.

This process is divided in the following steps:

• Ordering Your Layers, on page 242
• Attaching the Layers, on page 243
• Adding a Master Peg, on page 245
• Setting the Pivots, on page 247

Ordering Your Layers 

Once you have finished drawing all of your pieces, you may find that your drawings are in the wrong order. Place these 
pieces in the correct order before attaching your pieces to each other.
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To reorder your layers:

1. In the Timeline view, select the drawing to bring in front of the others.

2. Drag the selected layer and drop it BETWEEN the existing layers. Do NOT drop it onto a layer because it will 
connected them. In this case you do not want to connect them.

3. Repeat the whole process until the whole character is in the correct order.

Attaching the Layers 
When you animate, you will often want the forearm and hand to follow the upper arm when you select and move it. 
To do this you must attach the forearm to the upper arm and the hand to the forearm.

To attach a layer to another one, simply drag the layers one onto the other in the Timeline view.

To attach a layer to another one:

1. In the Timeline view, select the layer you want to attach to another one. For example, select the forearm layer to 
attach it to the upper arm.

Hand to
Forearm

Forearm to
Upper Arm
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2. Drag the selected layer ONTO the one you want to attach it to.

Once the layer is attached to another one, it gets pushed to the right and a Collapsing arrow appears.

3. If the piece you connected is supposed to be in front of the layer it is attached to, you can push it in front using 
a keyboard shortcut.

 In the Tools toolbar, select the Transform  tool.

 In the Camera view, select the part to bring in front.

 Hold down the [Alt] key and press the [Down Arrow] key to nudge the drawing forward. Doing so moves the 
drawing very slightly forward. If you press on the key several times the drawing will move forward even 
more. You can also use the [Up Arrow] key to send the drawing backward.

4. Repeat the whole process until every piece is connected.
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Adding a Master Peg 

A good element to add to your puppet is a Master Peg. This is a trajectory on which you attach your puppet to make 
it travel through your scene, It is also used when you want to scale the entire character up or down without doing it 
on each individual piece. For example, you could animate your puppet walking on the spot then use the Master Peg 
to get it to move from left to right.

To add a Master Peg:

1. In the Timeline view, click on the Add Peg  button.

2. Double-click on the new Peg to rename it. Name it myCharacterName-Peg.
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3. In the Timeline view, select all your puppet’s layers.

4. Drag the selection ONTO the new Peg.

All the layers are connected to the peg and moved slightly to the right.
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Setting the Pivots 

In order for your pieces to rotate properly, it is important to set the pivots at the right location. The pivot is the point 
from where the body part will rotate, they generally correspond to an articulation. To know where to position a pivot 
point, think of your own body. If you are moving an arm you will notice that your own arm rotates from the shoulder 
So, the pivot point for the puppet arm has to be located at the shoulder. The pivot point for the forearm will be the 
elbow, etc.

You can apply this technique to anything you want to animate that contains a joint or pivot. For example, if you are 
animating a spider, study a real spider or a film of a spider moving to determine where you should place the pivot 
points correctly in your animation. 

To position the pivots:

1. In the Sceneplanning Tools toolbar, select the Rotate  tool.

2. In the Timeline or Camera view, select the first layer to set the pivot for.
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3. In the Camera view, grab the green pivot point and drag it to its new position.

4. In the Camera view, rotate the part to see if the point is well positioned. If not, relocate it.

5. Repeat the whole process for each piece. Do not forget to set a pivot for the eyes and mouth. This is generally 
located at the centre of the drawing.

Do not forget to do this for your master peg. Positioning the pivot between the feet is often a good option.
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Storing the Character in the Library
Your puppet is now ready and can be imported into your different scenes to be animated. The best way to reuse your 
puppet is to store it in the Library as a template. From there, you can open a different scene or project and drag it 
from the Library into your scene.

Refer to the Importing Artwork chapter to learn more about creating templates and organizing your library.



To store your puppet in the library:

1. In the Timeline view, click on the Master Peg’s collapsing Arrow button to collapse your puppet.

2. In the left side of the Timeline view, select the puppet’s master peg.
3. Drag your selection to the Global Library folder or any other one you may have created for your project.

4. Double-click on the template and rename it with your character’s name.
5. Select File > Save Global Library.

Your puppet is now completed.
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What’s Next?
So far, you have learned about:

• Choosing a Character
• Breaking Down a Character
• Rigging a Character
• Adding a Master Peg
• Setting the Pivots
• Storing the Character in the Library

Next, you will learn how to animate the puppet you just created.
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Chapter 10  Bones

s

The Bones feature in Toon Boom Studio allows you to create a skeleton over your character by using the different 
Bone tools and then animate it as if it were a body with the Skeleton effect. The skeleton can be used to not only 
animate vector-based drawings, but also bitmaps.

This chapter is divided as follows:

• About the Skeleton Effect, on page 252
• Choosing Your Character, on page 256
• Adding the Skeleton, on page 258
• Animating the Skeleton, on page 278
• Skeleton Effect Properties, on page 287
• Preferences, on page 289
• What’s Next?, on page 290

 You can follow the different exercises of this chapter using the different bones templates provided within the 
software’s library!

You can find these templates inside the Library view by following this structure:

• Toon Boom Templates > Bones
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About the Skeleton Effect 

  

The Toon Boom Studio Skeleton effect is used to create an animatable bone structure in a character or design. The 
structure will let you bend a limb, automatically creating a joint with a distortion of the artwork such as the arm 
example above. The arm is drawn straight on a single flattened drawing, the skeleton effect automatically creates the 
elbow joint.

When you animate the arm bending, a keyframe will be created in the Timeline view and the motion will be 
automatically interpolated (all the drawings between the two keyframes will be created for you) if your keyframes are 
set to non-constant.

 Refer to the following topics of the Animating a Puppet chapter to learn more about peg animation concepts:

• Understanding Keyframes and Drawings, on page 294
• Constant and Non-Constant Segments, on page 298
• Adjusting the Velocity, on page 306
• Using the Onion Skin in Cut-out Animation, on page 309

 Once you gain confidence, you can also use your creativity and try the Skeleton effect on other animatable 
designs other than limbs to create some interesting distortion effects, like this animated smiling fish!
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Bone Tools Toolbar 

By default, the Bone Tools toolbar is located just below the Sceneplanning Tools toolbar on the left side of the 
application. Use these tools to create, set up and animate your bone structure. You have two types of tools, setup 
mode tools and an animation mode tool.

It is very important to understand that when selecting a Bone tool, the camera display and Skeleton Effect will 
automatically switch to either setup mode or animation mode.

Setup Mode 
The setup mode is active when you are using tools to set up the initial bone structure of the skeleton. Moving bones 
around with these tools will not create keyframes or animation in the Timeline.

When in setup mode, a large circle appears at the base of your bones.

These are the setup bone tools, selecting any of these will switch the Skeleton Effect to setup mode:

•  Bone Setup tool 
This tool is used to position the selected bones on your drawing. Use this tool to drag, rotate and scale a 
bone or a hierarchy of bones. 
You can also select this tool using the top menu, select Tools > Bone Tools > Bone Setup or use the default 
keyboard shortcut [J].

•  Bone Creator tool 
This tool is used to create individual bones. Once a bone is created, it is automatically selected. When a 
bone is selected, the next bone created will automatically be parented to it, creating a chain. If you want to 
break the chain in order to create a free-standing bone, or to start a new chain, hold down the [Shift] key as 
you create.
You can also select this tool using the top menu, select Tools > Bone Tools > Bone Creator or use the 
default keyboard shortcut [U].

•  Bone Influence tool 
The zone of influence is the area around the selected bone that determines what part of the underlying 
drawing will be influenced by it. This tool is used to modify the size and shape of that area. By default, the 
zone of influence remains invisible, as the Influence type is set to Infinite in the Tool Properties panel. If the 
Influence type is changed to Elliptical, the zone of influence will appear as a large ellipse, surrounded by a 

This circle is only visible when 
in setup mode. 
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bounding box, around the selected bone. The Bone Influence tool can be used to move the square points 
on the bounding box in order to reshape the elliptical zone of influence.


You can also select this tool using the top menu; select Tools > Bone Tools > Bone Influence.

•  Bone Parent tool 
This tool is used to parent different bone chains to one another.
You can also select this tool using the top menu, select Tools > Bone Tools > Bone Parent.

•  Connect character setup mode
This tool is primarily used with the Robo-Skeleton templates. Each template has a layer named “Envelope” 
in its Skin Group. Click the Connect character set-up mode button to see the envelope zones appear and to 
see the character revert to Set-up mode, where its body parts are typically separated and spread apart.
To have this command work with your own creations, create your own templates and set the layer type of 
your envelope drawing to Envelope in the Layer Properties panel. 

You can also select this tool from the top menu by selecting Tools > Bone Tools > Show-Hide.

 Refer to the Adding the Skeleton topic to learn how to use these tools.

Animation Mode 

The animation mode is automatically active when you select the Bone Manipulator  tool. This means that the 
Camera view will display the current pose of the bone structure at the selected frame and any manipulation you make 
will create a keyframe in your Timeline and be animated. 

When in animation mode, you will notice that the large circle seen at the base of the bones in setup mode disappears.

•  Bone Manipulator tool 
This tool is used to animate your bone structure. You can drag, squash, stretch, rotate or scale a selected 
bone chain, creating an animation keyframe in your Timeline.

Layer name

There is no circle displayed when 
in animation mode.
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You can also select this tool from the top menu, select Tools > Bone Tools > Bone Manipulator or use the 
default keyboard shortcut [H].

 Refer to the Animating the Skeleton topic to learn more about this tool.
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Choosing Your Character 
Before building your skeleton, the first thing you need to do is to select and prepare your character. If this is your first 
puppet, then it is best to choose a simple character. A simple character has two legs, two arms, a head and torso. To 
begin with, you should avoid a character with loose clothing such as a cloak or baggy pants. As you progress and gain 
experience creating and animating skeleton puppets, you will learn what to do to optimize your animation and 
workflow.

We chose a skeleton pirate character to demonstrate how to use the Skeleton effect and Bone tools.

You can also create your character from a picture or a bitmap image, however be sure to vectorize the image when 
importing, otherwise it will not be editable.

 For more information on importing and vectorizing bitmaps images, please refer to the section Importing and 
Vectorizing Images, on page 145. 

 If you plan to use one of Studio’s Robo-Skeleton templates, go to the section Robo-Skeleton Templates, on 
page 258 to select a template first, then follow the remaining steps to prepare your character.

Planning and Preparing Your Character 
When choosing and preparing your character, it is recommended that all parts of the character be separated in space. 
This is to ensure the cleanest movement between character pieces when animating bones affected by elliptical 
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influence areas. It is also recommended that you group each of the separate parts and properly arrange the ordering 
of these limbs and body groups inside the drawing.

 Refer to Chapter 4: Drawing and Design, on page 67 to learn about the Drawing tools and options.

This is an example of what could happen if a character's limbs are overlapping during setup (Figure A), versus one 
whose limbs were separated from the body during setup (Figure B).

 

 Since the Skeleton effect will be applied to any art contained inside a bone’s influence area in setup mode, the 
following happens:

 FIGURE A. The character's shoulder in this example was overlapping the body at setup. Therefore 
animating the shoulder will also move any part of the torso that was included in the influence area. 

 FIGURE B. The character's shoulder was not overlapping the torso during setup, so no part of the torso 
will be influenced by the animation of this bone.

You can have all your character’s parts drawn on the same drawing element, or you could also separate the different 
parts so that each is on a different drawing layer. For example you could have five drawing elements for your character; 
one for the body and head combined and one for each of the four limbs. Drawing each part on a separate element 
simplifies the process of ordering the limbs later.

 Refer to the Adding the Skeleton and Animating the Skeleton topics to learn more.

GoodBad

FIGURE A FIGURE B

Note the distortion here... ..but not here
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Adding the Skeleton
When it comes to adding bones to your drawing or drawings, you have two options to choose from. You can choose 
one of Studio’s pre-made Robo-Skeleton templates that has an animated sequence built-in, or you can build your own 
skeleton. If you choose to create your own skeleton, you will have the freedom to make your own animated sequences.

• Robo-Skeleton Templates, on page 258
• Building the Skeleton, on page 265

Robo-Skeleton Templates

Although creating a character can be fun, the process of animating it with Bones can be a little daunting. Take away 
some of the work—the setup and animation—by using Studio’s pre-made Robo-Skeleton templates. You can easily 
add your own character artwork to the template and watch it move within minutes.

Choosing Your Robo-Skeleton Template from the Library
All the Robo-Skeletons are available from the Library. To access the templates, follow the path Toon Boom Templates 
> Robo-Skeleton.

 If you do not see the folder Toon Boom Templates in the Library, right-click under the Local and Global library 
folders and select Reload Default Templates from the pop-up menu.
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Inside the Robo-Skeleton folder, you will find Robo-Skeleton templates of both human and animal characters. Each 
character has its own sub-folder containing templates grouped into front, side and 3/4 poses. See the list below for 
a more detailed description of the templates:

Human:

• Front
 Jumping
 Jumping Jacks
 Stretching
 Waving
 Dance Move 01
 Dance Move 02
 Dance Move 03

• Side
 Jumping
 Running
 Squat
 Walking
 Dance Move 01
 Dance Move 02
 Dance Move 03

• 3/4 View
 Jumping
 Running
 Squat
 Walking
 Waving
 Dance Move 01
 Dance Move 02
 Dance Move 03
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Animal:

• Front
 Sitting
 Stretching
 Tilting Head
 Walking

• Side
 Jumping
 Running
 Sitting
 Sniffing
 Stretching
 Walking

• 3/4 View
 Jumping
 Running
 Sitting
 Stretching
 Tilting Head
 Walking

To see a thumbnail of the template, right-click in the right section of the Library view and select View > Thumbnails.

Importing Your Robo-Skeleton into Your Scene
You can drag a template from the Library view to the Camera view or Timeline view in order to add it to your 
animation. 

To import a template into your scene:

1. In the Library view, select the template you want to import.
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2. Drag and drop the selected template in the Camera view or Timeline view’s left side.

Adding Your Own Character to the Robo-Skeleton Template

Now that your Robo-Skeleton appears in the Camera view, you have all the pieces necessary to create your own 
humanoid or four-legged character. This means that you need not use this template as is, but that you can use 
elements of the template, such as the animation, for your own purposes.

The first thing you need to do is examine the layers included in your Robo-Skeleton template, specifically the Skin 
Group.

Notice how there are two drawing layers attached to the Skin Group. The first layer, in this case called dog_side, 
contains all the artwork for the dog that you currently see in the Camera view. The envelope layer, which is hidden by 
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default, contains drawings of zones surrounding each body part of the character. To view the envelope layer, click on 

the Connect character set-up mode  button. The envelope zones appear and the character is split apart as you 
would see it in Setup Mode.

In order to have your character move with the pre-made animation of the Robo-Skeleton template, you need to add 
your own artwork to the Skin Group to replace the dog_side layer. You can do this in several ways, either by creating 
a new drawing layer, using the envelope zones as guidelines and then creating your own artwork, or by erasing the 
artwork from the dog_side layer and drawing your own artwork directly in that layer.

To add your own character to the Robo-Skeleton template:

1. In the Timeline view, click on the Add New Drawing Layer  button to create a new Drawing layer.

2. Go to the Drawing view by clicking on the Drawing view button on the upper-right side of the Camera view.

OR

If you would like to continue working in the Camera view, click on the Connect character set-up mode  
button. This option will also automatically display the envelope zones.

Use either the Erase  tool or the Select  tool in combination with the [Delete] key to get rid of the current 
artwork on that layer.

3. If you are working in the Drawing view, turn on the Light Table by clicking on the Auto Light Table  button, 
found in the Onionskin toolbar located at the top of the application.

Result in the Camera view
when using the Connect
character set-up mode button
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You should now see the envelope image in washed out colours in the Drawing view. You might notice that it 
does not look as it did in the Camera view; some of the limbs of the character may be detached and spread out.

As is the case with the dog, when the character is whole, two of the legs are partially hidden behind the rest of 
the body. This would also happen to the image of a human character in profile; one arm and one leg would be 
hidden. In order to fix problems like this, all the limbs are separated and then reattached to the body in the Bone 
setup stage (which is already done for the Robo-Skeleton templates), so that all the body parts can move 
independently.

4. If you are working in the Camera view, in the Timeline view, hide (uncheck) the current Skin Group art layer. In 
this case, it is the dog_side layer. Leave the envelope layer enabled.

OR

If you are working in the Drawing view, in the Exposure Sheet view, click on the Toggle Element List button and 
then hide (uncheck) the current Skin Group art layer. In this case, it is the dog_side layer. Leave the envelope 
layer enabled

 Instead of hiding the Skin Group art layer, you could simply delete its contents and then create your own 
artwork directly on it.

5. In the Drawing or Camera view, import and vectorize an image, or use the drawing tools to create your own 
version of the chosen character type on the new layer. If you import an image, you can use the drawing tools to 
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cut it up, as long as it is vectorized. You must also scale the pieces and place them in the correct location, over 
their corresponding envelope zone. In either case, be sure to stay within the envelope zone limits.

 For more information on how to create your own artwork, please refer to the chapter Drawing and Design, on 
page 67.

 For more information on how to import bitmap images, please refer to the section Importing and Vectorizing 
Images, on page 145.

6. In the Timeline view, rename the drawing layer to something appropriate and extend the exposure of the 
drawing for the total length of the animated sequence. You can do this either by:
 Right-clicking on the frame that you want to extend the exposure to and selecting Extend Exposure from 

the pop-up menu.
OR

 Clicking on the frame that you want to extend the exposure to and using the keyboard shortcut 
[Ctrl]+[Shift]+1 (Windows) or []+[Shift]+1 (Mac OS X). 

7. If you are not already there, return to the Camera view by clicking on the Camera view button on the right side 
of the Drawing view.

8. If you did not draw directly on the old Skin Group art layer, then in the Timeline view, select your character 
artwork layer and drag and drop it over the Skin Group layer.

Envelope zone

Custom image within
the envelope zone
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9. If you did not create your new character artwork on the old Skin Group art layer, either hide the old Skin Group 
art layer or delete it from the Timeline view entirely.

10. Hide the envelope by disabling the Connect character set-up mode  button from the Bones toolbar. The 
envelope disappears and the Robo-Skeleton character appears reassembled. If it does not reassemble 
automatically, you may have one of the Bone setup tools selected. In this case, click on the Bone Manipulator 

 tool.

As a test, click on the envelope layer and then take a look at the Layer Properties panel. You will notice that the 
Type is set to the Envelope state. Any layer that is set to the Envelope state through the Properties panel can be 
controlled by the Connect character set-up mode button.

 If your envelope layer is selected in the Timeline view, then you will see it in the Camera view, even if the 
Connect character set-up mode button is disabled.

Your character is now connected to the Robo-Skeleton template and appears in place of the generic envelope.

11. In the Playback toolbar, click on the Play  button to watch the pre-made animation as it now appears, 
connected with your character artwork.

 If your artwork appears warped when animated, you may need to tweak the Zones of Influence or the Bone 
Setup. For further information on Zones of Influence, please refer to Setting the Influence Area, on page 272. For 
further information on bone setup, please refer to Setting Up the Bones, on page 269.

Building the Skeleton
Once your character design is ready, you can start building the structure of the puppet’s skeleton. Here are the 
different steps and tools:

• Adding Bones, on page 266
• Setting Up the Bones, on page 269
• Setting the Influence Area, on page 272
• Parenting Bone Chains, on page 275

Layer name
265



Toon Boom Studio User Guide
Adding Bones 
There are two different ways that you can add bones to your artwork. The fastest and easiest way is to select the layer 
with your artwork, and then select the Bone Creator tool. Your last step will be to simply create bones on top of your 
artwork. You can also add bones through the Timeline. The two methods are described below.

To add bones to your character:

1. Make sure you are working in the Camera  view.
2. In the Timeline view, select the layer with your artwork on it.

3. From the Bone Tools toolbar, select the Bone Creator  tool. You can also use the keyboard shortcut [U].
4. Take a look at your character or object and try to decide which parts will be at the back, in other words, hidden 

behind other parts. Those are the parts that you should start creating bones for first.

The bones and bone chains that are created first will be at the bottom of the Timeline layer stack when you are 
finished; therefore, they will be located at the bottom of the visibility hierarchy.

5. In the Camera view, click and drag to create the first bone, following your design.

When creating your bone structure, think about where you want the image to bend. In this example, we would 
like two bends (one at the elbow and one at the wrist), therefore we should create three bones (the arm, forearm 
and hand).

 If you do not position the bone perfectly the first time, you can fix it later using the Bone Setup tool. Refer to 
the Setting Up the Bones topic to learn how.

Arm Forearm Hand

Wrist

Elbow
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6. Once you have created a bone, it automatically becomes selected. A selected bone appears red in colour. The 
next bone you will create will automatically be linked and parented to the currently selected bone. This creates 
a chain linked by a joint.

7. Once you have created a full bone chain for one limb, for example, hold down the [Shift] key to start a new free-
standing bone or bone chain for a different part of your character or object.

 Be sure to let go of the [Shift] key if you want to create a connected chain, otherwise, you will 
accidentally create a series of unconnected bones.

8. Take a look at the Timeline view. As you create a bone chain, you will notice that a new bone layer is 
automatically added for each bone in the chain under the Bone Group. The bones in a chain are organized in a 
hierarchy, while free-standing bones are found just below the main Bone Group.

You will also notice that the drawing layer with your character or object artwork has automatically been connected 
to the Skin Group of your new Skeleton effect group. This auto-parenting occurs because you started creating 
your bones with this layer selected.

 Refer to the Layers and Timing chapter to learn more about layers.

 You must create your first bone by clicking to 
determine its start position, dragging the mouse to extend 
the bone length and releasing the mouse at the desired end 
point. Every subsequent bone can be created by clicking the 
mouse at the next end point. In this example, we clicked at 
the wrist to create the second bone.
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Your character’s bone structure is now complete. Notice how the bones of the body parts, including the body of the 
character, are independent from each other. They are all separate bone chains, totally unconnected.

Adding Bones from the Timeline View
Another way to add bones to your artwork is to add a Skeleton Effect to your Timeline view and then connect your 
character’s artwork to it.

To add a Skeleton effect:

1. In the Timeline view, click on the Add New Elements  button. 

The New Elements dialog box opens.

2. From the Type drop-down menu, select Skeleton Effect.

3. In the Name field, give a name to the Skeleton Effect element.

4. Click on the OK button.

The Skeleton Effect appears in your Timeline view.
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5. Select and drag the drawing layer containing your character onto the Skin Group. This is where you connect any 
art layer that you want to be influenced by the bones. 
Make sure to drop the drawing layer directly on the Skin Group to parent it to the Skin Group.

If your character’s parts are drawn on different elements, make sure to parent all the drawing elements to the Skin 
Group.

Once layers are parented in the Timeline view, you can click on the blue triangle icon at the head of a group to collapse 
or expand the group. This is useful when the Timeline view becomes filled with layers.

 You can add any drawing layer to the Skin Group or remove any drawing layer from it at any time. You can also 
save a bone structure in your library as a template and then reuse it with other character designs! Refer to Chapter 6, 
Importing Artwork - Library, on page 160 to learn more about using the Library view.

6. From the Bone Tools toolbar, select the Bone Creator  tool. You can also use the keyboard shortcut [U].
7. Take a look at your character or object and try to decide which parts will be at the back, in other words, hidden 

behind other parts. Those are the parts that you should start creating bones for first.

The bones and bone chains that are created first will be located at the bottom of the Timeline layer stack when 
you are finished, and therefore will be at the bottom of the visibility hierarchy.

8. In the Camera view, click and drag to create the first bone, following your design.
9. Once you have created a bone, it automatically becomes selected. A selected bone appears red in colour. The 

next bone you will create will automatically be linked and parented to the currently selected bone. This creates 
a chain linked by a joint.

10. Once you have finished creating the bone structure on a first limb, in the Timeline view, select the top layer of 
the Skeleton Effect; this will let you start the bone structure for the next limb. Then, repeat steps 8 and 9 until a 
bone structure is created for each of the body parts.

Setting Up the Bones 
Once you start creating bones you can, at any time, modify them in setup mode to optimize their positioning without 
creating an animation. 

To modify bones using the Bone Setup tool:

1. From the Bones Tools toolbar, select the Bone Setup  tool. You can also use the keyboard shortcut [J].
2. In the Camera view, select the bone you want to modify. 

Expanded Collapsed
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The selected bone becomes red and two control handles appear.

 To rotate the bone, place your cursor over the bone until you see the rotation cursor. Click and drag to 
rotate the selected bone. You can change the rotation angle of any bone in the chain.

 To shorten or lengthen the bone, click on the round handle at the tip of the bone and either drag it towards 
or away from the root of the bone. You can lengthen or shorten any bone in your chain. You can also rotate 
as you scale, creating two transformations in one step.

Original bone chain

Note how the scaled
bone affects the length
of the bone directly
connected to it, but not
any subsequent bones
further down the chain
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 To reposition the bone, click on the square handle and drag it to the desired position.

 You should only reposition the first parent of the bone chain to avoid creating gaps in your joints that could 
result in an unwanted distortion of the art.

Note how the scaled and
rotated bone affects the
length and rotation of the
bone directly connected to
it, but not any subsequent
bones further down the chain
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You can also use the Properties view to define the position of a selected bone.

To modify bones using the Properties view:

1. In the Camera view or Timeline view, select the bone you want to modify.

Its position values appear in the Properties view.

2. In the Properties view:
 Position: Enter the E/W and N/S values to set the position of the selected bone.

You should not reposition a bone that is not the first parent. This will prevent gaps from forming at the joint 
area, creating an unwanted distortion of the art.

 Length: Enter a value to set the length of the selected bone. You can resize any bone from the chain.
 Rotation: Enter the number of degrees to modify the rotation angle of the selected bone. You can change 

the rotation angle of any bone from the chain.

Resetting the Position of a Bone
You can reset the position of a selected bone at any time using the Properties view. You can also reset the selected 
bone’s position and rotation values to default.

To reset the position of bones:

1. In the Timeline view, select the bone you want to reset.
2. In the Properties view, set the Position and Rotation values to 0.
3. Repeat these steps for any other bones which you need to reset the position of.

You can also use the Reset option to reset both the bone positions and keyframes simultaneously.

To reset the position of bones and clear keyframes:

1. In the Timeline view, select the bone element you want to reset. You can perform a multi selection and reset the 
position of multiple bones at the same time.

2. In the Timeline View  menu, select Reset. You can also right-click (Windows) or [Ctrl] + click (Mac OS® X) in 
the right or left section of the Timeline view and select Reset from the pop-up menu.

 Setting the Influence Area 
The influence area is the zone that defines which art will be included in the Skeleton effect and will be distorted when 
animated. 

Once you setup the bone structure, you need to adjust the influence area of your bones. 

This topic is divided as follow:

• Influence Area, on page 273
• Elliptical or Infinite Influence Areas, on page 273
• Modifying the Size and Shape of the Influence Area, on page 274
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Influence Area
By default, the influence area is set to Infinite. An Infinite zone of influence does not have a visual representation in 
the Camera view, therefor it appears to be invisible. To give you a general idea about an influence area, let’s talk about 
it in terms of an Elliptical zone of influence, which appears as a large ellipse surrounding the length of each bone.

The influence area determines the boundaries of the effect that a bone will have over artwork that lies within those 
boundaries. 

Any art on a drawing layer that is connected to the Skin Group and appears inside the bone influence area, will follow 
the movement of that animated bone.

When setting the influence area around your bones, you must make sure that no unwanted art is included in the area. 
Any unwanted art included in a bone influence area will follow the animated bone and become distorted.

Elliptical or Infinite Influence Areas 
There are two types of influence area possible for a selected bone; the Elliptical and the Infinite.
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Infinite

By default, the influence area is set to Infinite. The entire art which is part of the Skin Group and which is not contained 
inside the Elliptical influence area of another bone, will move with the selected bone. If two bones have an Infinite 
influence type, then they will influence the artwork up to where they meet, in other words, up to the joint.

Elliptical

You can set the influence area type for a selected bone to Elliptical using the Properties view. When set to Elliptical, 
an ellipse appears in the Camera view around the selected bone. An Elliptical influence type means that an ellipse 
shape determines the boundaries inside which art will be influenced by the selected bone animation. This area can be 

redefined using the Bone Influence  tool or Properties view. 

 Note that if two influence areas overlap, the bone which is situated lower in the Timeline view’s ordering is the 
one that will take precedence over the other. Therefore, the influence area of the bone which is situated higher in the 
Timeline view’s layer stack, will have no influence over the overlapping area.

 Refer to Modifying the Size and Shape of the Influence Area to learn how.

Modifying the Size and Shape of the Influence Area  
If you set the influence area of a bone to Elliptical, meaning it is bound within an ellipse shape, you can modify that 
shape. To modify the size and form of the ellipse, simply manipulate the square points around its bounding box.

To modify the influence area using the Bone Influence tool:

1. From the Bone Tools toolbar, select the Bone Influence  tool.
2. In the Camera view, select the bone whose influence area you want to modify.

The selected bone appears as red and a black bounding box is displayed around the influence area. 

Elliptical Influence Areas

Infinite Influence Area
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3. Click and drag the square points to resize or reshape the influence area.

Parenting Bone Chains 
Once you create the several bone chains for your character’s limbs and body, you can connect them all by parenting 
them. This unifies the character and, if you want to, allows the limbs to follow the movements of your character’s body.

This step is very simple, as you only use a single tool, the Bone Parent  tool.

To parent bone chains:

1. From the Bone Tools toolbar, select the Bone Parent  tool.
2. In the Camera view, locate the bone which is the starting point of the limb you want to parent to another chain. 

In this example, the arm will be parented to the body of the Skeleton.
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3. Click on the base of the limb bone and then drag the cursor to the bone you want to parent it to. You will notice 
a red arrow pointing in the direction you drag it. When a straight line appears beside it, it means that it is ready 
to connect to the selected bone.

4. Release the mouse to complete the connection.

5. Repeat Step 2 to Step 4 until all your limbs are parented to the body.
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Unparenting Bone Chains 
If for some reason you decide that you no longer want a bone or chain parented to another bone or chain, you can 
easily unparent.

To unparent a bone or bone chain:

1. From the Bone Tools toolbar, select the Bone Parent  tool.
2. In the Camera view, locate the bone you want to separate from another bone or bone chain. If you want to 

separate part of a chain from a larger chain, find the bone that would represent the head of the new chain.

3. With your mouse, click on the selected bone, then rapidly pull away from the parent bone or bone chain.

The selected bone and any of its children are now separated from its parent bone or bone chain.

Bone that you
want to unparent

Unparented
bone chain
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Animating the Skeleton 
Once you have finished creating your character’s skeleton, it is time to switch to the Bone Manipulator tool, reconnect 
the limbs to the body and animate it.

• Reassembling the Character, on page 278
• Ordering Limbs, on page 280
• Hiding Bones, on page 281
• Animating Bones, on page 282
• Disabling a Bone Animation, on page 286

Reassembling the Character 
The first step is to reassemble the character so that the limbs do not appear spread apart, as in Setup mode.

To reassemble the character:

1. From the Bone Tools toolbar, select the Bone Manipulator  tool.

You will notice the Camera view changing to animation mode display.
2. In the Timeline view, make sure that the red marker is at the first frame.
3. In the Camera view, select the main bone of one of the limbs.

4. Use the square handle to drag the bone chain to the desired position.

A keyframe will be added to the limb’s bone layer on the first frame, locking its position in time.
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5. Repeat Step 3 and Step 4 for each of the limbs you need to assemble to the body.

 When your character is assembled and ready for animation, you should save it in the Library view for future 
reference, and easy reuse between projects. Refer to Chapter 6: Importing Artwork - Library, on page 160.
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Ordering Limbs 
When reassembling your character, you might find a limb that does not appear in the correct order, for example, this 
arm appears under the body.

The ordering method will differ, depending if your entire character is from a single drawing layer, or if your character’s 
pieces are separated on several drawing layers:

• Character on a Single Drawing Layer
• Character with Limbs on Different Drawing Layers

Character on a Single Drawing Layer 
When this occurs, it is because the ordering of the bones will determine the ordering of the drawing art that is 
included in its influence area. 

To reorder the bone elements:

1. In the Timeline view, select the layer you need to reorder.
2. Drag the Bone element to the desired position within the Bone Group. Be careful to drop it in-between existing 

bone element hierarchies and not drop it on one, this would parent them.

 Note that the ordering of the Bone elements in the Timeline view is the opposite of the other elements. The 
higher the bone element is in the Timeline ordering, the further back it will appear in the Camera view. 

Character with Limbs on Different Drawing Layers 
When this occurs it is simply because the Drawing layer containing the limb in question is poorly ordered in the 
Timeline view. Simply reorder the Drawing layers from the Skin Group to fix the order.

To reorder layers in the Timeline view:

1. In the Timeline view, select the layer you need to reorder.
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2. Drag the layer to the desired position within the Skin Group. Be careful to drop it in-between layers and not 
drop it on a layer, this would parent them.

 Remember that the ordering of the Drawing elements in the Timeline view works as follows: The higher the 
drawing element is in the Timeline ordering, the closer to the front it will appear in the Camera view.

 Refer to Chapter 14: Scene Setup - Ordering the Element Layers - Ordering Layer in the Timeline View, on 

page 349 to learn more about layer ordering.

Hiding Bones 
You might need to hide the bones from the Camera view. If this is the case, simply disable the Bone Group.

To disable the Bone Group:

1. In the Timeline view, locate the Bone Group you need to hide.

2. Click in the layer’s check box to disable it.

 Note that disabling the Bone Group will only hide the bones and will not disable the Skeleton Animation. Refer 
to Disabling a Bone Animation, on page 286 to learn more.
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Animating Bones 
Now that the Skeleton puppet is ready, you can start animating it.

To animate bones:

1. From the Bone Tools toolbar, select the Bone Manipulator  tool.
2. In the Timeline view, go to the frame where you want to set the first pose of your puppet.

3. In the Camera view, select the bone you want to animate.
4. When a bone is selected you can:
 Use the square handle to drag the selected bone to a new position. Note that this handle is only available 

on the parent bone of a chain.

Repositioning a bone will create a square black keyframe marker in the Timeline view, on the layer of the 
selected bone.

 Use the circle handle to squash and stretch the bone. In the example below, notice how the parent bone is 
unaffected, but how the child bone becomes squashed and stretched in turn.

Scaling a bone with the Bone Manipulator tool will create up and down arrow-shaped keyframe markers in 
the Timeline view, on the layer of the selected bone, as well as on the layer of the child bone. The reason 
this manipulation produces the same types of keyframe markers that you would typically see for a scale and 
a rotation, is because the Bone Manipulator tool allows you to scale and rotate in the same movement.

 You can also use the Scale  tool from the Animation tools toolbar to perform a different type of scaling. 
Grab the tip of the bone to squash and stretch it. In the example below, notice that the parent and child 

keyframe marker
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bones are unaffected by the scaling, but that the child’s position changes relative to the scaling of the 
selected bone. 

Scaling a bone with the Scale tool will create a down arrow keyframe marker in the Timeline view, on the 
layer of the selected bone.

 Click directly on the bone and drag the cursor to rotate it.

Rotating a bone will create a tiny up arrow keyframe marker in the Timeline view, on the layer of the 
selected bone.

 If the Skeleton Effect is collapsed, note that you will not see the keyframe marker. If you expand the 
puppet’s elements by clicking on the arrow next to the master peg element, you will notice a red square on 
the parent element of the bone you moved. This indicates that a child of this bone has a keyframe. 

5. In the Timeline view, go to the frame where you want to set your second keyframe.

6. In the Camera view, animate your character.

7. Repeat this process until all your poses are done.
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 By default, Toon Boom Studio is set to create non-constant keyframes. This means that the software will 
automatically create the movement between two keyframes. This can prove to be very handy when animating your 
skeleton puppet. If in some situations you would rather create each keyframe in the interpolation of your movement, 
you can set your keyframe to be non-constant.

Refer to Chapter 11: Animating a Puppet - Creating a Simple Cut-out Animation - Constant and Non-Constant 

Segments, on page 298 to learn more!

Onion Skin Toolbar 
You can use the Onion Skin toolbar to help you create your animation. It will let you see the previous and next drawings 
of your animation as a handy reference while animating. 

 Refer to Chapter 11: Animating a Puppet - Creating a Simple Cut-out Animation - Using the Onion Skin in Cut-

out Animation, on page 309

Blocking the Body’s Position 
Once you position your puppet, you can create a keyframe for all the bone elements of your collapsed skeleton and 
block the complete body at a specific frame.

To block the entire body position:

1. In the Timeline view, select the frame at which you want to block your puppet’s position.
2. Select Element > Peg > Add Keyframe. The default keyboard shortcut is [I].
284 



Chapter 10: Bones   
Deleting Keyframes 
To delete keyframes:

1. In the Timeline view, select the keyframe you want to remove.
2. Select Element > Peg > Remove Keyframe. The default keyboard shortcut is [Ctrl]+[R] (Windows) or []+[R] 

(Mac OS X).

The selected keyframe will be deleted.

If you select a keyframe on a collapsed layer, all the keyframes for all of that frame’s collapsed elements will 
be removed.

Removing All Keyframes
You can use the Remove All Keyframes option if you need to delete all the keyframes on one or many selected bone 
elements.

To remove all keyframes:

1. In the Timeline view, select the bone elements you wish to remove all the keyframes from. You can select many 
elements at once.

2. In the Timeline View  menu, select Remove All Keyframes. You can also right-click (Windows) or [Ctrl] + click 
(Mac OS® X) in the right side of the Timeline view, and select Remove All Keyframes from the pop-up menu.

Adjusting the Velocity and Functions 
You can adjust the velocity to create ease-in and ease out motions or edit the movement Functions using the Function 
Editor view. This greatly improves the quality and look of an animation, giving a more organic feel to the movement. 
You can edit the velocity and function of your skeleton or bones in the Function Editor view.

To display the selected bone or skeleton in the Function Editor view:

1. In the Timeline view, select either your Skeleton Effect master element or the bone element you wish to edit the 
velocity of.

2. In the Properties view, click on the Function Edit or Edit Velocity button.

The Function Editor view will be displayed and the select bone or skeleton function will be selected.
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To learn how to adjust the velocity and functions, refer to:

• Chapter 11: Animating a Puppet - Creating a Simple Cut-out Animation - Adjusting the Velocity, on 
page 306

• Chapter 14: Scene Setup - Function Editor View, on page 381 

To learn more about the Skeleton Effect Properties view options, refer to:

•  Skeleton Effect Properties, on page 287

To learn more about the Bone element Properties view options, refer to:

•  Setting Up the Bones, on page 269
• Setting the Influence Area, on page 272

Disabling a Bone Animation 
You might need to disable the Bone Animation. If this is the case, simply disable the Skeleton Effect.

To disable the Skeleton Effect:

1. In the Timeline view, locate the Skeleton Effect top layer, it is the one with a bone icon.

2. Click in the layer’s check box to disable it.

 You will notice that the Camera view will automatically switch to Setup mode display.
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Skeleton Effect Properties 
When the Skeleton Effect master element is selected, many options are made available to you in the Properties view. 

Because you can animate the master element of the Skeleton Effect just like the master Peg element of a puppet, 
many options refer to motion paths. 

 To learn more about animating trajectories and motion paths, refer to Chapter 14: Scene Setup, on page 347. 

You can animate this element using the Sceneplanning tools available in the Sceneplanning Tools toolbar.

 Refer to Chapter 11: Animating a Puppet - Creating a Simple Cut-out Animation - Using the Different 
Sceneplanning Tools, on page 302

• Name: Displays the name of the selected Skeleton Effect element.
• Start: Displays the first frame number to which a keyframe is inserted on the Skeleton Effect element.
• Duration: Displays the duration of the animation of the Skeleton Effect element.
• Loop Mode: Displays if the layer is looped.

Refer to Chapter 14: Scene Setup - Other Options - Change Loops, on page 391 to learn more about 
looping a peg movement.

• Edit Velocity: Click on this button to display the Skeleton Element in the Function Editor view. To learn how 
to adjust the velocity. 
Refer to:
 Animating the Skeleton - Adjusting the Velocity and Functions, on page 285 
 Chapter 11: Animating a Puppet - Creating a Simple Cut-out Animation - Adjusting the Velocity, on 

page 306
• Skeleton Colour: Click in the colour square to open the Select Colour dialog box. Pick a colour to instantly 

change the colour of the selected Skeleton Effect elements. The colour will change in both the Timeline and 
Camera view. You can also change the default colour for each new Skeleton Effect you will add to your 
project using the Preferences panel. Refer to Preferences, on page 289 to learn how.
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• Show Track: Enable this option to display the motion path of your animation in the Camera view. 
Refer to Chapter 14: Scene Setup - Creating a Motion Path - Motion Path, on page 370 to learn how to 
create a motion path.

• Show Root: Enable this option to display the root, which is the centre point of the bone structure. Before 
the master element of the Skeleton Effect is animated, the center point is situated in the centre of the 
Camera view.

• Show Influence: By default this option is enable, it lets you see the influence areas of the skeleton’s bones 
in the Camera view. You can disable this option to hide the influence areas.

• Vector Quality: Choosing the vector quality level of your skeleton will either improve or depreciate the 
result of the bone distortion effect.
 Highest
 High
 Medium
 Low

• Scale: Type in the desired width and height scaling values: 1 = 100%. You can also use the Scale  tool 
from the Sceneplanning toolbar.

• Keep Proportions: Enable this option to keep proportions when scaling the skeleton.

• Skewing: Type in the desired skewing angle value. You can also use the Skew  tool from the 
Sceneplanning Tools toolbar.

• Rotation: Type in the desired rotation angle value. You can also use the Rotate  tool from the 
Sceneplanning Tools toolbar.

• Apply Pivot to: Select to which transformation you want to apply the pivot to.
 Rotation
 Scaling

• Constant Z: This option is disabled by default, which means that when you create a motion path along the 
Z-axis, the automatic interpolation calculates the X, Y and Z axis values. When it is enabled, the 
interpolation calculates the X and Y axis values and will keep the Z-axis value as constant. 
Refer to Chapter 14: Scene Setup - Creating a Motion Path - Motion Path - Constant Z, on page 378

• Orient to Path: Enable this option to force the element connected to the path to follow the motion path. 
Refer to Chapter 14: Scene Setup - Creating a Motion Path - Motion Path - Orient to Path, on page 377

•  Copy Resting Position to Current Frame - use this button to bring the skeleton and artwork back to 
the set-up position only on the currently selected frame. You can then reparent and setup the bones and 
their corresponding artwork in a new formation.

•  Copy Resting Position to All Key Frames - use this button to maintain all the position information in 
the keyframes that are part of an animated sequence, while restoring the puppet’s bones to the set-up 
position and resetting all the transformation information back to zero.

Original keyframed 
position at frame 1

Set-up position at

Notice how the keyframes remain in the Timeline
even after either of the Reset buttons have been used.
This is because they still contain position information.
This means that the Pirate Skeleton still moves across
the Camera view, even while in the Set-up position.

frame 1 after a Reset
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Preferences 
When working with the bones feature, you can set the colour preference of the bone display from the Preferences 
panel.

To open the Preferences panel:

 Windows: Select Edit > Preferences.
 Mac OS X: Select Toon Boom Studio 7 1.0 > Preferences.

To change the bones colour display:

1. In the Preferences panel, click on the Interface tab.

2. In the Element Colours section, double click on the Skeletons and Bones colour square to display the 
Select Colour dialog box.

3. Pick a colour in the Select Colour dialog box and click on the Ok button.
4. In the Preferences Panel, click on the OK button.
5. Every new Skeleton Effect that you create will use this colour as its default display in the Timeline and Camera 

view.

 You can also change the colour of an already created Skeleton Effect by using its Properties view. Refer to 
Skeleton Effect Properties, on page 287 to learn how.
289



Toon Boom Studio User Guide
What’s Next?
So far, you have learned about:

• About the Skeleton Effect
• Choosing Your Character
• Building the Skeleton
• Animating the Skeleton
• Skeleton Effect Properties
• Preferences

Next, you will learn how to animate a cut-out puppet.
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Chapter 11  Animating a Puppet

Start animating your characters with Toon Boom Studio’s easy to use tools.

In this chapter, you will learn about the following:

• Getting the Character From the Library, on page 292
• Understanding Keyframes and Drawings, on page 294
• Creating a Simple Cut-out Animation, on page 295
• Preferences, on page 311
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Getting the Character From the Library 
To use a character that was previously created and stored in the Library, you need to import it into your scene.

To import your character from the library: 

1. Create your new Studio project .

2. In the Library view, select the template of the character you want to animate.

3. Drag the selected template to the Camera or Timeline view’s left side.

The puppet will appear in the Timeline view.

Refer to the Library section in the Animating a Puppet chapter to learn more about the Library view.
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Extending the Exposure
To extend the puppet exposure:

1. In the Timeline view, click on the arrow beside the top layer of your puppet to collapse it.

In the Timeline view, select your puppet main layer and 
select Element > Cell > Extend Exposure or use the keyboard shortcut [Ctrl]+[Shift]+1 (Windows) or []+[Shift]+1 
(Mac OS X).

The Extend Exposure dialog box opens.

2. In the Extend to Frame field, enter the planned final frame of your animation and click on the OK button. This 
will extend the exposure of every element contained in your puppet.

 Refer to the Traditional Digital Animation chapter to learn more about exposure and timing.

Extending the Children’s Exposure
To extend the exposure of a puppet’s children:

1. In the Timeline view, in the puppet layer’s row, select the frame where you would like to extend the exposure to.

2. Right-click on the frame and from the pop-up menu, select Extend Children Exposure.

The children’s exposure is indicated by a thin bar.

When you uncollapse the Puppet Peg layer, the children’s extended exposures are revealed.
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Understanding Keyframes and Drawings
Before starting to animate it is important to understand the difference between drawings and keyframes. 

Keyframes lock a change in position, rotation or scale to a specific frame and store the value for that transformation. 
When you add a keyframe to define the values for one or more transformations, such as motion, scale, skew or 
rotation, you can use the features in Toon Boom Studio to animate the changes between them.

Just as creating a drawing element and selecting a new position over 20 frames is faster than creating 20 drawings for 
20 frames, adding keyframes for a peg’s transformations and letting Toon Boom Studio animate the rest saves even 
more time.

Keyframes and Drawing Blocks 
In the Timeline view, if you extend the exposure of a drawing, it will be represented as a green block. A new green 
block is displayed for every new drawing you create.

These are called Drawing Blocks.

To change the position of a drawing over time, you do not need to create a second drawing block, you simply need 
to add a position keyframe.

The position keyframes record the position of your drawing on a particular frame. They appear as black squares in the 
Timeline view. Notice that the keyframes are positioned on frames independent of the beginning and end of each 
Drawing Block.

Kf.1 Kf.2 Kf.3 Kf.4 Kf.5 Kf.6 Kf.7

Dr.1 Dr.2 Dr.3 Dr.4
294 



Chapter 11: Animating a Puppet   
Creating a Simple Cut-out Animation
In this section, you will learn about different tools and features available in Toon Boom Studio to help you animate 
your cut-out puppet.

This topic is divided as follow:

• Animating the Parts, on page 295
• Constant and Non-Constant Segments, on page 298
• Navigating Inside a Hierarchy, on page 299
• Using the Different Sceneplanning Tools, on page 302
• Adjusting the Velocity, on page 306
• Using the Onion Skin in Cut-out Animation, on page 309
• Swapping Images, on page 310

Animating the Parts
Once you import your cut-out puppet into your Studio project, you can start animating it.

To animate a puppet:

1. In the Sceneplanning Tools toolbar, select the Transform  tool. 
You can also select Tools > Sceneplanning Tools > Transform. The default keyboard shortcut is [7].

2. In the Timeline view, go to the frame where you want to set the first pose of your puppet.

3. In the Camera or Timeline view, select the parts to animate.
 If your puppet is collapsed, click on the top layer arrow to expand it.

4. Using the Transform tool, rotate, skew, scale or translate the selection to its new position.
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A keyframe is created in the Timeline view. If your puppet is collapsed, note that you will not see the keyframe 
on the master peg layer.

 If you expand the elements of your puppet by clicking on the arrow next to the master peg element, you 
will notice a red square on the parent element of the element you moved, this is an indication that a child of 
this element has a keyframe. 

 A black square on the element you moved represents the keyframe.

5. In the Timeline view, go to the frame where you want to set your second keyframe.

6. In the Camera view, animate your character.

7. Repeat this process until all your poses are done.

Blocking the Body’s Position 
Once you position your puppet, you can create a keyframe for all the elements of your collapsed puppet and block 
the complete body at a specific frame.

To block the entire body position:

1. In the Timeline view, select the frame at which you want to block your puppet’s position.
2. Select Element > Peg > Add Keyframe. The default keyboard shortcut is [I].

Deleting Keyframes 
To delete keyframes:

1. In the Timeline view, select the keyframe you want to remove.
2. Select Element > Peg > Remove Keyframe. The default keyboard shortcut is [Ctrl]+[R] (Windows) or 

[]+[R] (Mac OS X).

The selected keyframe will be deleted.

If you select a keyframe on a collapsed layer, all the keyframes for all of that frame’s collapsed elements will 
be removed.
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Copying and Pasting Keyframes 
If you want to copy the value of a keyframe without copying the entire drawing contained in the selected cell, you will 
need to use the Paste Special command.

To copy and paste keyframes:

1. In the Timeline view, select the keyframe you want to copy the position values from.

2. Select Edit > Copy Cell. The default keyboard shortcut is [Ctrl]+[C] (Windows) or []+[C] (Mac OS X).
3. In the Timeline view, select the cell in which you want to paste the copied position values.
4. Select Edit > Paste Special. The default keyboard shortcut is [Ctrl]+[B] (Windows) or []+[B] (Mac OS X).

The Timeline Paste Special Preferences dialog box opens.

5. In the Pegs section, enable or disable the following options to choose which values of the keyframe you want to 
paste:
• Create/Delete Motion Key Frames

Enable this option to paste the translation value of the copied keyframe.
• Create/Delete Rotation Key Frames

Enable this option to paste the rotation value of the copied keyframe.
• Create/Delete Scale Key Frames

Enable this option to paste the scale value of the copied keyframe.
• Create/Delete Pivot Key Frames

Enable this option to paste the pivot position value of the copied keyframe.
• Create/Delete Velocity Key Frames

Enable this option to paste the velocity value of the copied keyframe.
• Create/Delete Skew Key Frames

Enable this option to paste the skew value of the copied keyframe.
• Create additional key frames at beginning and end of selection

This option will create an additional keyframe at the beginning and at the end of your pasted selection to 
block the copied values between them.

6. In the Drawings section, disable the Create/Delete Exposure option, this will grey out the rest of the Drawings 
options. If this option is enabled, the drawing exposure will be copied at the same time as the position value.
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Constant and Non-Constant Segments 
By default, when you add keyframes, non-constant segments are created between them. You can change this option 
to create constant segments.

Refer to the Preferences topic to learn how you can change the default behaviour of Studio so it creates 
constant segments by default.

Non-Constant Segment
A non-constant segment means that Studio will automatically create the interpolation between the 2 keyframes, 
creating a motion.

A non-constant segment is represented as grey lines going from one keyframe to the other.

To switch from a constant to a non-constant segment:

1. In the Timeline view, select the first keyframe of the constant segment you wish to turn to non-constant.

2. From the top menu, select Element > Peg > Set Non-Constant Segment. The keyboard shortcut is 
[Ctrl]+[Shift]+[L] (Windows) or []+[Shift]+[L] (Mac OS X).

The segment will turn to a non-constant segment.

Kf.1

Kf.2
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Constant Segment
A constant segment means that the drawing will automatically jump from one position to the other without creating 
any motion in between.

A constant segment is represented as a blank gap between the two keyframes.

To switch from a non-constant to a constant segment:

1. In the Timeline view, select the first keyframe of the non-constant segment you wish to turn to constant.

2. From the top menu, select Element > Peg > Set Constant Segment. The keyboard shortcut is [Ctrl]+[L] 
(Windows) or []+[L] (Mac OS X).

The segment will turn to a constant segment.

Navigating Inside a Hierarchy
If you create a layer hierarchy when you build your puppet you can use the hierarchy navigation commands to travel 
up and down the parent-children chain, and to move between the children. This is useful if you want to select small 
parts that are difficult to reach. You can also select different parts from the Timeline or Camera view.

Selecting a Parent or Child Element
In a hierarchy, elements connected to one another are called parent and child.

To select the parent or child element:

1. In the Sceneplanning Tools toolbar, select the Transform  tool. 
You can also select Tools > Sceneplanning Tools > Transform. The default keyboard shortcut is [7].

2. In the Camera or Timeline view, select an element that is attached to a hierarchy.

Kf.1

Kf.2

Parent
Child
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3. Select Element > Arrange > Select Parent.

The selection will change to the parent of the selected element.

4. Once a parent peg is selected, you can select Element > Arrange > Select Child, to select its child.

To select all children of an element:

1. In the Sceneplanning Tools toolbar, select the Transform  tool. 
You can also select Tools > Sceneplanning Tools > Transform. The default keyboard shortcut is [7].

2. In the Camera or Timeline view, select an element which is part of a hierarchy and is a parent of other elements.

3. Select Element > Arrange > Select Children.

The selection will change to select all the elements that are attached to the selected parent element.
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Selecting Brother Elements
Elements that are on the same hierarchy level are called brothers.

To select previous and next brother:

1. In the Sceneplanning Tools toolbar, select the Transform  tool. You can also select 
Tools > Sceneplanning Tools > Transform. The default keyboard shortcut is [7].

2. In the Camera or Timeline view, select an element that is part of a hierarchy.

3. Select Element > Arrange > Select Previous Brother or Select Next Brother.

The selects either the previous or next brother of the selected element. Previous brother is the one situated a 
level higher, while the next brother is the one situated a level lower in the Timeline view order.

Brothers
Brothers

Selected element

Previous brother

Next brother
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Using the Different Sceneplanning Tools 
The animation tool you use determines the kind of keyframe you create. In the Timeline view, each of these keyframe 
types are displayed differently.

•  Transform tool 
Creates a keyframe for motion, scale, rotation and skew values at once.

•  Motion tool
Creates a keyframe for the position values only.

•  Rotate tool
Creates a keyframe for the angle values only.

•  Skew tool
Creates a keyframe for the skew values only.

•  Scale tool
Creates a keyframe for the horizontal and vertical scale values only.

Using the Transform Tool 
Use the Transform tool to create a keyframes for position, scale, rotation and skew values simultaneously.

To use the Transform tool:

1. In the Sceneplanning Tools toolbar, select the Transform  tool. You can also select 
Tools > Sceneplanning Tools > Transform. The default keyboard shortcut is [7].

2. In the Camera or Timeline view, select the element you wish to transform.
3. Use one of the bounding box handles to transform your element.
 Hold down the [Shift] key as you scale to keep the ratio when using the corner handles.
 Holding down the [Shift] key as you rotate, locks the rotation every 15 degrees.

Rotation

Vertical Skew

Horizontal Skew

Horizontal Scale

Vertical Scale Vertical and Horizontal Scale

Temporary Pivot Offset

Position
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Using the Motion Tool 
Use the Motion tool to create a keyframe for the position value.

To use the Motion tool:

1. In the Sceneplanning Tools toolbar, select the Motion  tool. You can also select 
Tools > Sceneplanning Tools > Motion. The default keyboard shortcut is [0].

2. In the Camera or Timeline view, select the element you wish to reposition and drag it to the new position.
 Hold down the [Shift] key as you reposition your element to temporarily display a guide showing you the 

starting position and the path of the motion you are creating.

Using the Rotate Tool 
Use the Rotate tool to create a keyframe for the rotation angle value.

To use the Rotate tool:

1. In the Sceneplanning Tools toolbar, select the Rotate  tool. You can also select 
Tools > Sceneplanning Tools > Rotate. 

2. In the Camera or Timeline view, select the element you wish to rotate.
3. Use the rotation handle to rotate your element.

As you rotate your element an angle guide will appear, displaying the rotation angle you are creating.

 Holding down the [Shift] key as you rotate, locks the rotation every 15 degrees.

Rotate

Position Pivot
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Using the Skew Tool 
Use the Skew tool to create a keyframe for the skew value.

To use the Skew tool:

1. In the Sceneplanning Tools toolbar, select the Skew  tool. You can also select
 Tools > Sceneplanning Tools > Skew. 

2. In the Camera or Timeline view, select the element you wish to skew.
3. Use the handles to skew your element.

Skew Position Pivot
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Using the Scale Tool 
Use the Scale tool to create a keyframe for the scaling value.

To use the Scale tool:

1. In the Sceneplanning Tools toolbar, select the Scale  tool. You can also select 
Tools > Sceneplanning Tools > Scale. The default keyboard shortcut is [9].

2. In the Camera or Timeline view, select the element you wish to resize.
3. Use the handles to resize your element.
 Hold down the [Shift] key as you scale to keep the ratio when using the corner handles.

Using the Select Tool 
Use the Select tool to position, scale, rotate and skew your elements without creating a keyframe.

To use the Select tool:

1. In the Sceneplanning Tools toolbar, select the Select  tool. You can also select 
Tools > Sceneplanning Tools > Select. The default keyboard shortcut is [6].

2. In the Camera or Timeline view, select the element you wish to transform without creating a keyframe.
3. Use one of the bounding box handles to transform your element.
 Hold down the [Shift] key as you scale to keep the ratio when using the corner handles.
 Holding down the [Shift] key as you rotate, locks the rotation every 15 degrees.

Horizontal Scale

Horizontal and Vertical
Scale

Vertical Scale

Position Scale
Pivot

Rotation

Vertical Skew

Horizontal Skew

Horizontal Scale

Vertical Scale Vertical and Horizontal Scale

Temporary Pivot Offset

Position
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Adjusting the Velocity 
The velocity, or ease-in ease-out, is used on non-constant segments to create a more natural movement.

Ease-in and ease-out is the acceleration and deceleration of the movement. The speed of the motion is 
adjusted between two keyframes so that the movement will start slowly, speed up and then slow down again as it 
reaches the second keyframe. Adjusting the velocity will create a more natural feel to the movement.

To adjust the velocity of a movement:

1. In the Sceneplanning Tools toolbar, select one of the sceneplanning tools. You can also select 
Tools > Sceneplanning Tools > the desired tool, or use the desired tool keyboard shortcut.

1. In the Camera or Timeline view, select the animated element of which you want to adjust the velocity.

The selected element properties will appear in the Properties view.

2. In the Properties view, click on the Edit Velocity  button.

The Function Editor view opens.

Linear Ease-in Ease-out Curve
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3. In the drop-down menu, select the movement for which you want to adjust the velocity.

The curve corresponding to the selected movement will be displayed.

4. Adjust your curve:
 Click on a keyframe to select it.
 Drag the handle to adjust the curve.

 Repeat Step 3 and Step 4 for each keyframe.

You can also use the default curve options to quickly adjust your velocity.
 Click on the Curve icon to open the drop-down menu and select the desired velocity option.

  Constant
This option will change a non-constant segment to a constant segment. Removing the automatic 
motion tweening created by Studio.

  Linear
This option will create a straight line of constant speed for a more automated animation look.

  Ease in/out
This option will create an acceleration effect at the beginning of the curve, speeding up middle and 
slowing down at the end of the curve. This creates a more natural animation look.

  Fast in/out
This option will create a curve that starts quickly, slows down in the middle and ends with a final 
acceleration.

  Extreme ease in/out
This option will create a more dramatic ease in, ease out effect.

Keyframe
Selected

Keyframe

Handle
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  Extreme fast in/out
This option will create a more dramatic fast in, fast out effect.

  Slow acceleration
This option will create a curve that starts slowly to smoothly accelerate over time.

  Slow deceleration
This option will create a curve that starts quickly to smoothly decelerate over time.
Refer to the Discovering the Interface chapter to learn more about customizing your workspace and 
adding views.
Refer to the Scene Setup chapter to learn more about the Function Editor view.
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Using the Onion Skin in Cut-out Animation 

You can use the Onion Skin option to display the 3 previous and the 3 next drawings of your character as you animate 
your puppet. Being able to refer to these poses helps you accurately determine the size, angle or position of the 
drawing you are working on. 

By default the onion skin is displayed as the element’s shape in washed-out colours. Green represents the previous 
frames and red represents the next frames.

To enable the Onion Skin option:

1. In the Onion Skin toolbar, enable the Onion Skin  option. You can also select 
View > Onion Skin > Turn On Onion Skin.

2. Select the range of previous and next frames to be displayed in the Onion Skin. Click and hold the Previous and 
the Next onion skin buttons to open each drop-down menu and select the desired option.
You can also select View > Onion Skin > and one of the following choices:

  No Previous Drawing
This option does not display the content of the previous frames.

  Previous Drawing
This option displays the content of the previous frame.

  Previous Two Drawings
This option displays the content of the two previous frames.

  Previous Three Drawings
This option displays the content of the three previous frames.

  No Next Drawing
This option does not display the content of the previous frames.

  Next Drawing
This option displays the content of the next frame.

  Next Two Drawings
This option displays the content of the two previous frames.

  Next Three Drawings
This option displays the content of the three previous frames.

Refer to Chapter 8: Traditional Digital Animation - Preferences, on page 230 topic to know how to customize 
the display options of the Onion Skin.
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Swapping Images 

If your puppet contains extra drawings, such as extra heads, mouths, eyes or hands, you can use the image swapping 
trick to animate your puppet.

For example, if your puppet contains extra drawings of eyes, such as an open eye, a half-closed eye and a closed eye, 
you can easily animate a blink.

To create a blinking eye with image swapping:

1. Select sceneplanning tool from the Sceneplanning toolbar. You can also select 
Tools > Sceneplanning Tools > the desired tool.

2. In the Camera or Timeline view, select the eye.

3. In the Timeline view, select the frame at which you want the puppet to start closing its eye.

4. In the Cells view, use the swapper slider to select the half-closed eye drawing.

The selected drawing will be displayed in the preview area, and the exposure will automatically be updated in 
the Timeline view.

5. In the Timeline view, select two frames later.

6. In the Cells view, use the swapper slider to select the closed eye drawing.
7. To change back to the open eye, repeat Step 5  and Step 6.

Preview Area

Swapper Slider

Currently Exposed

Selected
Element

Drawing

Starting and Ending Frames
Exposed Drawing
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Preferences
In Toon Boom Studio, you can set your own preferences to fit your cut-out animation work style.

To open the Preferences panel:

 Windows: Select Edit > Preferences.
 Mac OS X: Select Toon Boom Studio 7.1 > Preferences.

Sceneplanning Tab Preferences 
Select the Sceneplanning tab to customize the preferences relative to cut-out animation.

Create Linear Spline 
By default, the Create Linear Spline option is enabled. This means that when you animate an element with a motion, 
rotation or scaling, the velocity will be set to Linear. This means that the motion tweening executed by Toon Boom 
Studio will be straight with no variation in the speed.

You can disable this option, by unchecking the box, so that every time you create a motion, rotation or scaling, the 
velocity will be set to the default ease-in, ease-out curve.

Refer to the Adjusting the Velocity topic to learn more about velocity and ease-in, ease-out concept.

Create Constant Keyframes 
By default, the Create Constant Keyframes is disabled. This means that every time you create a motion, a non-constant 
segment is created between every two keyframes and the motion tweening is automatically calculated by Studio.

You can enable the Create Constant Keyframes, by checking-off the box, so that every time you create a motion, the 
segments in between the keyframes will automatically be constant segment. No motion tweening is calculated and 
the position jumps from one to another at each keyframes.

Uncheck this box to 
disable this option

Check off this box to 
enable this option
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What’s Next?
So far you have learned about:

• Using a character that was previously created and stored in the Library
• The difference between drawings and keyframes
• The different tools and features available to help you animate your cut-out puppet
• Setting your own preferences to fit your cut-out animation work style

It is now time to learn how you can import soundtracks and dialogue into your animation to make it more engaging 
and entertaining.
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Chapter 12  Sound and Lip-sync

With Toon Boom Studio, you can import soundtracks and dialogue into your animation to make it more engaging and 
entertaining. Studio has many sound editing features to help you work with your soundtracks and dialogue.

Studio can automatically analyze voice tracks to determine which of the eight animation phonemes (mouth shapes) 
would best apply to each frame of the sound. You can then easily draw mouth shapes for your character following the 
useful mouth chart that the software automatically generates. Furthermore, Toon Boom Studio can also automatically 
apply drawings of mouth shapes to each frame of your animation based on the mouth chart.

In this chapter, you will learn about the following:

• Importing a Sound File, on page 314
• Sound Display, on page 315
• Sound Playback, on page 317
• Sound Scrubbing in the Timeline View, on page 317
• Editing a Sound File, on page 318
• Adding an Empty Sound Layer, on page 328
• Lip-sync, on page 329
• What’s Next?, on page 333
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Importing a Sound File 
When you decide that you want to add sound to your movie, you must prepare this sound outside of Toon Boom 
Studio. Then, in Toon Boom Studio, you add a Sound element to organize sound files in your animation. 

A sound will play in the movie until it reaches the end of the file or a stop frame, created in the Sound Element Editor. 
If the sound extends into multiple scenes it will continue to play. 

You can import as many sound files as you like. However, if you will be delivering your movies over the Internet, the 
more sounds you add, the larger the file size of your final movie.

Toon Boom Studio imports, exports and plays sounds using QuickTime. Toon Boom Studio only supports the sound 
formats recognized by Qt®, with one exception: Flash ADPCM format, which is supported natively. 

To import a sound file: 

1. Select File > Import File.
You can also right-click (Windows) or [Ctrl]+click (Mac OS X) anywhere in the frame zone of the Xsheet View and 
select Import File from the pop-up menu.

The Open dialog box opens.
2. From the Open dialog box find and select your sound file from your computer.

Your sound file should now appear as a layer in both the Timeline and Xsheet View.

Exposure Sheet view Timeline view
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Sound Display 
Once you import a sound file into your project, there are many ways to display it in the Exposure Sheet or Timeline 
view. You can use the waveform, as a guide to synchronise a certain sound peak to an action in your animation, or the 
Lip-sync mouth display to help you with your lip-sync animation.

Sound Display - Exposure Sheet View 
The sound file can be displayed in four different ways in the Exposure Sheet view.

Sound Name 
By default, the sound is displayed showing the name of the sound file, and the file format. For 
example, Line 1.wav.

A numbered exposure appears in each frame for the entire length of the sound file. Whenever there 
are no other sound display options enabled, this is how the sound column will look.

Waveform 
This option shows a vertical display of the sound file’s waveform, divided into cells. A waveform 
represents the sound as it rises and falls in volume, silence is shown as a straight line. Notice that 
the volume increases as the size of the waveform increases, you can use the size of the waveform as 
a guide to sync the sound effect with the action in your scene.

To turn on the waveform display:

In the Exposure Sheet View toolbar, click on the Thumbnail  button.

Lip-sync Mouth Shapes - Name 
This option will show the letter or name, depending on the way you label the character’s mouth 
positions, in the column’s frames. Only one mouth position is allotted per frame and this position 
should correspond to the sound file after lip-sync detection is performed.

To turn on the mouth shapes display:

In the Exposure Sheet view, right-click (Windows) or [Ctrl]+click (Mac OS X) on a cell of the sound 
column and select Show Lip-sync from the pop-up menu.
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Lip-sync Mouth - Thumbnails 
This option will show the letter or name, depending on the way you label your character’s mouth 
positions, in the column’s frames, and as a thumbnail of the mouth shape.

To turn on the mouth shapes thumbnails display:

click on the Thumbnail  button.You must have already enabled the Show Lip-sync option, in 
the Exposure Sheet View toolbar. 



 Refer to the Lip-sync topic to learn more about the lip-sync detection.

Sound Display - Timeline View 
By default, the waveform of your sound file is displayed in the Timeline view, but you can choose to show or hide it.

To show or hide the waveform: 

1. If the waveform is visible, select View > Hide Waveform from the top menu.
2. If the waveform is hidden, select View > Show Waveform from the top menu.

Show Waveform

Hide Waveform
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Sound Playback 
There are two ways you can play back sound in a project. You can either play your animation and the sound or play 
only the sound.

Playing the Sound and the Animation 
Before attempting to play back a sound, makes sure the Sound Playback option is enabled. 

To enable or disable the Sound Playback option:

 In the top menu, select Play > Turn Sound Playback On to enable the option.
 In the top menu, select Play > Turn Sound Playback Off to disable the option.

You can then play your scene as usual using the Playback toolbar controls and the sound will play as well.

Playing Only the Sound 
When you only play the sound, it is played for the entire length of the currently exposed sound. Unlike the regular 
playback option, playing only the sound does not restrict your playback to exposed drawing cells.

To play back only the sound sample: 

1. In the Exposure Sheet view, right-click (Windows) or [Ctrl]+click (Mac OS X) in the sound column’s cell at the 
point you want to start the playback.

2. Select Play from the pop-up menu and the sound plays.

Sound Scrubbing in the Timeline View 
Toon Boom Studio uses a process known as Sound Scrubbing. This lets you hear the sound in real-time as you move 
the playback pointer forward or backward along the waveform. This is extremely useful if you have to fine tune the 
lip-synching or sound synchronisation. You can scrub sounds in the Timeline view. 

To scrub a sound in the Timeline view: 

1. Enable the sound for play back. In the top menu, select Play > Turn Sound Playback On.
2. In the top menu, select Play > Turn Sound Scrubbing On.
3. At the top of the Timeline view, drag the red frame marker left or right along the waveform to hear the sound at 

each frame.

If you require finer control over the sound scrubbing, you can also enable Sound Scrubbing in the Sound 
Element Editor. Refer to the Editing a Sound File topic to learn more about the Sound Element Editor.
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Editing a Sound File 
Now that you have successfully imported your sound file into Studio, it is time to familiarize yourself with the sound 
editing interface. The Sound Element Editor makes it possible to edit sounds that were created outside of Toon Boom 
Studio and imported into your scene.

The Sound Element Editor consists of three main parts. 

1. Sound Element - The waveform seen in the top Sound Element window is the actual sample that will be heard 
when the final movie is rendered. It may be shorter than the original sound sample due to length of the scene. If 
any edits are made to the sound sample, they can be heard here. 

2. Current Sound - The Current Sound window displays the original sound file in its entirety. This is also where you 
can edit its properties. This window remains empty until you click inside the Sound Element window. 

3. Lip-sync Preview - Is used to preview the automated detection and to manually insert different mouth positions 
to correspond with the sound sample. 

To learn more about lip-sync, refer to Lip-sync, on page 329 in this chapter. 

You can do the following in the Sound Element Editor:

• Changing the Start or End Frame of a Sound, on page 319
• Trimming a Sound File, on page 321
• Looping a Sound, on page 322
• Mixing the Sound Volume, on page 323
• Custom Playback Range, on page 324
• Changing from Event to Streamed Sounds, on page 325
• Sound Scrubbing in the Sound Element Editor, on page 326
• Deleting a Sound, on page 327
• Recomputing the Mouth Chart

1
3

2
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To open the Sound Element Editor: 

1. In the Timeline or Exposure Sheet view, select the Sound element you wish to edit and select Edit Sound from 

the contextual  menu or Element > Edit Sound from the top menu. You can also Right-click (Windows) or 
[Ctrl]+click (Mac OS X) in the Timeline Sound layer or on the Exposure Sheet view Sound Column and select Edit 
Sound from the pop-up menu. 

The Sound Element Editor opens.

Changing the Start or End Frame of a Sound 
To synchronize the sound with specific images in your scene, you must set a start frame for your sound. To make sure 
the sound ends at a specific frame, you must set an end frame.

To change the start frame or the end frame of a sound:

1. In the Timeline or Exposure Sheet view, select the Sound element you wish to edit and select Edit Sound from 

the contextual  menu. 

The Sound Element Editor opens.
2. Select the sound sample you want from the Sound Element panel. To distinguish one sound section from 

another on the same sound layer, check the frame numbers that appear on tabs flanking the start and stop lines 
of each waveform section. 
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3. Click on the Play  button in the Current Sound panel (only the selected sound plays).

4. In the Sound Element panel, click and drag the selected clip to the frame number where you want it to start 
playing.

NOTE: You can only move the clip to a section that does not already contain a clip; you cannot overlap two clips 
in the same element.

5. To change the end frame, drag the yellow marker at the end of the waveform to the frame position where you 
want it to stop playing.

6. To hear how all of the clips fit together in the element, click on the Play  button in the Sound Element panel.

7. If you want to hear only the selected clip, click on the Play  button in the Current Sound panel.

8. Click OK when done. 

The Exposure Sheet and Timeline views should now display the sound clip at the start frame you selected
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Trimming a Sound File 
To play only a section of a sound file, use the Sound Element Editor to select the part you want to use. For example, 
if there is a bit of extraneous noise at the start of the sound, use the Sound Element Editor to edit out the noise. 

The Sound Element Editor does not change the original sound file; it only plays a section of it, ignoring the rest, the 
complete sound file is still kept in the project. This means that the entire sound file is included on export. If you need 
to consider restrictions in file size, it is better to completely edit the sound files in a third party sound editor before 
bringing them into Toon Boom Studio.

To trim the start and end of a sound file:

1. In the Timeline or Exposure Sheet view, select the Sound element you wish to edit and select Edit Sound from 

the contextual  menu.

The Sound Element Editor opens.
2. Select the sound you want to work on from the Sound Element panel. To distinguish one sound section from 

another on the same sound layer, check the frame numbers that appear on tabs flanking the start and stop lines 
of each waveform section.

 

3. Click on the Play  button in the Current Sound panel (only the selected sound plays).

4. Using the Current Sound panel, you can decide which part of the file you want to play by dragging the left and 
right boundaries of the selection area.
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5. Click on the Play  button in the Current Sound panel to play the trimmed sound and check that you have 
trimmed the sections correctly. Use the Zoom slider at the bottom of the panel to zoom in on the waveform so 
that you can trim it more accurately.

6. Once you are sure that the sound is trimmed correctly, click on the OK button. 

The trimmed sound sample should now appear in both the Timeline and Xsheet Views at the start and end 
positions that you selected.

Looping a Sound 
To repeat a sound, you need to specify, in the Sound Element Editor, the number of times that you want it to loop. 

To loop a sound sample:

1. In the Timeline or Exposure Sheet view, select the Sound element you wish to loop and select Edit Sound from 

the contextual  menu.

The Sound Element Editor opens.
2. From the Sound Element panel, select the sound section that you want to loop.
3. In the Current Sound panel, type the number of times you want the sound to play in the Number of Loops field.

4. Press on the [Return] key. The looped sound appears after the current sound. They are indicated by their grey 
waveforms, as opposed to black.

When you loop a sound, the looped sections fill the cells in the Sound element (column or layer) until the next sound 
sample starts or until the scene ends. This means that the looping could effectively get cut if the next sound sample 
starts too soon, or if the scene ends too quickly.

Looped SoundNormal Sound
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Mixing the Sound Volume 
You can adjust the volume of an entire sound clip or modify the volume in increments by adjusting the fade-in and 
fade-out times. The fade edit only affects the playback; the original sound file is not affected.

To adjust the overall volume of the entire sound clip:

1. In the Timeline or Exposure Sheet view, select the Sound element you wish to edit and select Edit Sound from 

the contextual  menu. 

The Sound Element Editor opens.
2. In the Sound Element panel, select the sound that you want to work on. An expanded version of the selected 

sound showing more detail appears in the Current Sound panel. 

3. In the Current Sound panel, use the Volume slider to adjust the volume.

4. Click on the Play  button in the Current Sound panel to verify the volume.

To create a fade in/out effect on a sound clip:

1. In the Timeline or Exposure Sheet view, select the Sound element you wish to edit and select Edit Sound from 

the contextual  menu.
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The Sound Element Editor opens.
2. In the Sound Element panel, select the sound you want to work on.
3. In the Current Sound panel, click on the thin blue line above the waveform to add a volume control point.

4. Drag the control point to adjust the volume and to create the time of the transition. The line from the edge of 
the clip to the control point identifies how the volume either increases (fades-in) or decreases (fades-out) over 
time.

Dragging the control point to the bottom of the channel will mute the volume, while dragging it upwards will 
increase the volume. To create an even effect, be sure to adjust the control points uniformly in both the left and 
right (bottom and top) channels. 

5. Click on the Play  button in the Current Sound panel to check the fade.

Custom Playback Range 
To hear a specific section of the sound element, adjust the playback range in the Sound Element Editor to start or stop 
at specific frames. This custom playback range does not affect the actual sound in the Sound element. 

To change the playback range in the Sound Element Editor dialog box: 

1. In the Sound Element Editor, drag the start or end range markers in the Sound Element panel to the boundary 
frames you want.

2. When you click on the Play  button to playback your sound in the Sound Element Editor, it only plays the 
sound existing between the two markers.
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Changing from Event to Streamed Sounds 
You can set up your sounds to be either streamed or event sounds when they are exported to the Adobe®Flash® 
format.

Refer to the Exporting Your Project chapter to learn more about exporting your movie and export formats.

There are two major distinctions between event and stream sounds in the Adobe®Flash® file:

• Downloading 
 Event sounds are downloaded by the Adobe®Flash® player before they play.
 Event sounds are reusable. Once downloaded, the Adobe®Flash® player can play the sound repeatedly 

without downloading it again. This is not possible with streamed sound.
 Streamed sound plays as it arrives. 
 Streamed sound samples are broken into small bits and inserted between the video frame. This allows 

the Adobe®Flash® player to start to play before receiving the full sound track which is helpful for a long 
sound track (like background music).

• Synchronization 
 Streamed sounds are kept synchronized with the video by the Adobe®Flash® player. The player drops 

frames if necessary to keep up with the sound.
 Event sounds are not synchronized with video. After a while, an event sound may fall out of sync with 

the video.

By default, the sounds are set to Event, But because streamed sounds are more likely to be synchronized with the 
images in your animation, lip sync sounds and sound effects should be set to stream. If you set more than one sound 
to stream, they will be mixed together and exported as one streamed sound.

To stream the sounds in an element: 

1. In the Timeline or Exposure Sheet view, select the Sound element you wish to edit and select Edit Sound from 

the contextual  menu.

The Sound Element Editor opens.

2. Enable the Streamed checkbox.

This toggles on and off the streaming sound option. If the option is not selected, the sound is set as an event 
sound.
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Sound Scrubbing in the Sound Element Editor 
Toon Boom Studio uses a process known as Sound Scrubbing. This lets you hear the sound in real-time as you move 
the playback pointer forward or backward along the waveform. This is extremely useful if you have to fine tune the 
lip-synching or sound synchronisation You can scrub sounds in the Sound Element Editor.

To scrub a sound from the Sound Element Editor: 

1. In the Timeline or Exposure Sheet view, select the Sound element and select Edit Sound from the contextual  
menu.

The Sound Element Editor opens.
2. In the Sound Element panel, select the waveform you want to scrub.

3. Below the Current Sound panel, select the Enable Scrubbing option. This option sets the red markers in scrub 
mode.

4. Drag the red playback marker left and right to hear the sound in sound scrubbing
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Deleting a Sound 
You can delete a sound in the Sound Element Editor.

To delete a sound: 

1. In the Timeline or Exposure Sheet view, select the Sound element you wish to remove the sound file from and 

select Edit Sound from the contextual  menu.

The Sound Element Editor opens.
2. Select the sound you want to delete from the Sound Element panel. To distinguish one sound section from 

another on the same sound layer, check the frame numbers that appear on tabs flanking the start and stop lines 
of each waveform section. 

3. Click on the Delete button located just below the Sound Element panel.

The Sound will be removed from the Exposure Sheet and Timeline view. 
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Adding an Empty Sound Layer 
When performing sound editing tasks, it can be useful to chop up a sound sample into different layers. For example, 
when performing a lip-sync, only a single view of the various mouth positions for a character can exist on one layer. 
Therefore, if you would like to have your character turn its head from a profile view to a three-quarter view and have 
mouth position changes to fit with the sound sample from these two different views, you would need to cut-up the 
sound samples needed for the profile view mouth positions on one layer and the sound samples needed for the three-
quarter view on another.For this task, you will need an empty sound layer.

To add an empty sound layer: 

 In the Exposure Sheet view, click on the Add Sound  button in the Exposure Sheet View toolbar or 

select Add > Sound from the Exposure Sheet view contextual  menu.

 In the Timeline view, select New > Sound from the Timeline view contextual  menu.
 You can also select Element > Add > Sound from the top menu. 

An empty sound element appears in the Exposure Sheet and Timeline view.

Exposure Sheet view Timeline view
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Lip-sync 

Adding a lip-sync to a project can really enhance its quality and storytelling. However, it can be difficult to shape a 
character’s mouth so that it matches the sound at the precise frame.  To solve this problem Toon Boom Studio provides 
a lip-sync feature which analyses the content of a sound element and generates a mouth chart based (see below) on 
the eight animation phonemes (A, B, C, D, E, F, G, and X, which is used to represent silence).

The mouth shapes used by Toon Boom Studio are based on the conventional mouth chart used in the animation 
industry. The letters used to represent the shapes do NOT correspond to an actual sound.

Here is an approximation of which sound each mouth shape can produce:

You can lip-sync the traditional way or let the system automatically create the basic detection. 

You can refer to the mouth chart positions as you draw 
the shape of your character’s mouth. 

This section explains:

• Creating a Mouth Chart, on page 330
• Automatic Lip-sync Detection, on page 331
• Modifying the Lip-sync Detection, on page 332

Mouth Shape Approximate sound the 
mouth shape matches to

A b, m, p
B d, h, i, j, k, s
C a, e
D A, E
E o
F oo, u
G f, ph
X Silence, undetermined sound
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Creating a Mouth Chart 
To generate a mouth shapes chart for a sound from the Exposure Sheet view:

1. In the Exposure Sheet view, right-click (Windows) or [Ctrl]+click (Mac OS X) on a cell of the sound column and 
select Show Lip-sync from the pop-up menu. 

Toon Boom Studio analyzes the selected sound clips and assigns a lip-sync letter to each sound cell.

You can enable the Thumbnails display option to show a preview image of the mouth shape. Once you enable 

the Show Lip-sync option, in the Exposure Sheet View toolbar, click on the Thumbnail  button.

Toon Boom Studio analyzes the selected sound clips and assigns a lip-sync letter to each frame. The 
numbered exposition in the frame are replaced by these designated letters.

To generate a mouth shapes chart for a sound using the Sound Element Editor: 

1. In the Timeline or Exposure Sheet view, select the Sound element you wish to generate a mouth shapes chart 

from and select Edit Sound from the contextual  menu.

The Sound Element Editor opens.
2. In the Sound Element panel, select the waveform you want to generate the mouth chart for and then click on 

the Lip-sync button.

 

A progress bar appears as Toon Boom Studio analyzes the selected sound clips and assigns a lip-sync letter to 
each sound cell.

3. You can playback your sound and the Lip-sync Image area will show a preview of the result of the detection.
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Automatic Lip-sync Detection 
Toon Boom Studio can automatically map drawings in an element to the mouth chart you have generated for a sound 
using the Lip-sync button in the Sound Element Editor dialog box. This can save time when you are lip-synching a 
voice track.

This means that in the Lip-Sync Mapping dialog box, you can identify each lip drawing of a character mouth element. 
Studio then automatically labels all of the cells in the character’s element with the appropriate name.

To automatically map lip-sync drawings to a mouth chart: 

1. In the Exposure Sheet view, right-click (Windows) or [Ctrl]+click (Mac OS X) on header of the sound element that 
has already been lip-synced and select Modify Lip-Sync Mapping. 

The Lip-Sync Mapping dialog box opens.

 Source element 
This field shows the Sound element from which the Lip-sync mapping will be based.

 Destination element 
Use this drop-down menu to select the element that contains the mouth shapes of your character.

 Mapping 
In this section, type the destination drawing name in each field corresponding to the mouth phoneme the 
thumbnail on the left represents. If your drawings are already named using the standard phoneme letters, 
you do not need to change anything.

2. Click on the OK button. 

3. Press the Play  button in the Playback toolbar to see and hear the results in the Camera view. 

4. To playback your scene with sound, enable the sound if it is not already done. In the top menu, select 
Play > Turn Sound Playback On.
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Modifying the Lip-sync Detection 
If you think that another position would be more appropriate, you can change the mouth position that has been 
assigned to a frame. 

For example, you may have a character who remains silent for ten frames, in between two speeches.Toon Boom Studio 
would normally assigns an X image to the silence. However, if you want your character’s mouth to hang open in 
astonishment for these ten frames, you can change the lip assignment for these frames from an X to an E.

You can modify the lip-sync from the Exposure Sheet view and from the Sound Element Editor.

Modifying the lip-sync from the Exposure Sheet view 
To change the lip assignment of a sound in the Xsheet:

1. In the Exposure Sheet view, right-click (Windows) or [Ctrl]+click (Mac OS X) in the cell that contains the mouth 
position that you want to change.

2. From the pop-up menu, select Lip-sync > A, B, C, D, E, F, G or X. Choose the letter that reflects the mouth 
position that you want to use for that sound. 

The drawing will automatically be updated in the Exposure Sheet and Timeline view.

Modifying the lip-sync from the Sound Element Editor 
To change the mouth position assignment of a sound from the Sound Element Editor:

1. In the Timeline or Exposure Sheet view, select the Sound element you wish to modify the lip-sync of and select 

Edit Sound from the contextual  menu.

2. In the Sound Element panel, drag the frame slider to the frame you want to change the mouth position on.

In the Lip-sync image area, the image on top represents the lip position assigned to the current frame.

EX
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3. To change the image assigned to the frame, click on the image of the mouth position you want from below the 
preview image. The preview image changes to the mouth position image you select. 

The position will also be updated in the Exposure Sheet and Timeline views.

Recomputing the Mouth Chart   
Recomputing the mouth chart erases any manual modifications you may have made to the mouth 
assignments in the mouth chart.



When you generate the mouth chart for a sound in a sound element, you can either accept the mouth positions 
assigned by Toon Boom Studio or assign your own lip-sync images.

However, if you change the sound’s start frame, edit it or reassign its mouth position afterward, you must reanalyze 
the sound and regenerate the mouth chart for it.

To recompute the mouth chart for a selected sound from the Sound column:

 NOTE: Recomputing erases modifications, see warning above.

1. In a Sound column in the Exposure Sheet, right-click (Windows) or [Ctrl]+click (Mac OS X) on a cell that contains 
the sound file you want to recompute the lip-sync for and select Recompute Lip-sync from the pop-up menu.

The mouth position assignment for each frame is recomputed, erasing any modifications you have made.

To recompute the mouth chart for a selected sound from the Sound Element Editor:

NOTE: Recomputing erases modifications, see warning above.

1. In the Timeline or Exposure Sheet view, select the Sound element and select Edit Sound from the contextual  
menu.

The Sound Element Editor opens.
2. In the Sound Element panel, select the waveform you want to recompute the mouth chart for. And click on the 

Lip-sync button.

What’s Next?
So far, you have learned about:

• Importing a Sound File
• Displaying Sound
• Playing Back Sound
• Using the Sound Element Editor
• Editing Sound
• Lip-synching

Is it now time to learn about using Toon Boom Studio to create a stop-motion animation project.
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Chapter 13  Stop-motion Animation

Stop-motion animation has been around since animators first realized that all it took was to nudge a clay figure, 
puppet or object and take a series of snapshots to produce the illusion of motion. In this digital age, the process has 
only become easier and more fun as it is now possible to mix in 2D animation. 

Toon Boom Studio has an integrated image capture feature. An intuitive and easy to use image capture window allows 
you to set up and capture all your images. It is as easy as plugging in your recording device, be it a digital, video or 
web camera, fixing the settings in the software, keying out the background and taking the snapshots.

This chapter is divided into the following sections:

• Characters and Stage, on page 336
• Image Capture Settings, on page 337
• Light Table and Onion Skin, on page 339
• Colour Keying, on page 341
• Image Capture, on page 343
• Vectorization and Clean-Up, on page 344
• What’s Next?, on page 345
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Characters and Stage 
Before you begin, it is important to gather the characters that you intend to use and to set up a stage on which to 
record your stop-motion animation. 

Gathering Your Characters 

When deciding on characters, it is best to look for or create figures that have ball and socket joints for full rotary 
movement. Just like a cut-out puppet, you want to be able to move your principal character at the shoulders, legs, 
knees and elbows if possible. If you choose to create or use characters that have less mobility, your animation might 
look a little stiff, which is not necessarily a bad thing if this is the look you are going for.

Setting Up Your Background 

Depending on whether you would like a 2D or 3D environment, you will have to set up your background accordingly. 
If you prefer a 3D background, then you would treat the elements in the same manner that you treat your stop-motion 
characters. If you would like a 2D cartoon background, then you will need to set up what is known as either a blue or 
green screen.

A blue or green screen is a solid coloured piece of fabric that can easily be selected and blocked out in the software. 
This process is known as colour keying. You can then superimpose another background, be it a 2D drawing created 
in Studio, a 3D photograph or a piece of video footage.

An important element to consider when setting up either a green screen backdrop or a stop-motion setting, is the 
lighting. In the case of a green screen, soft, flat lighting can be the key to making the material look smooth and 
shadowless. The fewer variations in tone, the easier it will be to key out the colour later on. Lighting does not 
necessarily mean a multi-lamp setup; a well lit room with natural daylight can often work best.
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Image Capture Settings 
Before you start, be sure that your image recording device is plugged into your computer and turned on. Follow the 
camera manufacturers instructions on how to connect the camera to a computer. It is recommended for the stop-
motion image capture process that you support your camera in a fixed position by either using a tripod or some other 
mounting system. The camera must be rigidly fixed, any movement of the camera, shaking, vibration etc. will affect 
the captured images, the only items which should move are the items on the stage. 

Setting-Up the Image Capture Options 
To set up the software for image capture:

1. From the File menu, select Acquire > From Capture Device.

The Image Capture window appears.
2. In the Options section, under the Source tab, find and select your recording device from the Device drop-down 

menu.
3. From the Source drop-down menu, select Full-Resolution Photo, if it is available for your recording device (some 

devices, such as webcams may not allow for this option). Otherwise, if you would prefer to take faster, lighter 
images for a rough test, select Live Preview.

 The Capture window can be used to capture more than just live physical models with a recording device. You 
can also “capture” hand-drawn images with the use of a scanner.

 To learn more about scanning from TWAIN, refer to the Importing Images chapter.

4. If you are using a scanner with a WIA driver (Windows Image Acquisition), the Resolution drop-down will be 
enabled. From the list, select the resolution at which you would like to scan your images.

5. If you wish to smooth out some of your colours, check the Noise Reduction option. If you wish to capture more 
detail, leave this option unchecked.

6. Click on the Properties button.

The Camera Properties window appears.

This is an example of a typical Camera Properties window.

4
3
2

5 6
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NOTE: The Camera Properties page is different for every capture device. The information displayed on that 
page comes from the device itself and will therefore contain different options for each device. 

7. Most of the settings that you see in the Exposure section are set manually on your camera. If you change a 
setting in the software, such as the ISO, it will be changed on your camera. If you change a setting on your 
camera, it in turn will be changed in the software.

8. In the White Balance section, play with the options from the Mode drop-down and select the one relating to 
your lighting set up, or until the colours in the preview window displays evenly balanced colours. Make fine tune 
adjustments with the colour sliders.

9. In the Focus section, use the Near and Far increments to bring the preview image into focus. For greater focal 
detail, use the Left, Right, Up and Down buttons to move around the Zoom Preview rectangle in the preview 
window. When you find a good section to examine, such as an area of high-contrast, press on the Zoom Preview 
button to view that section in detail. Use the Near and Far increments to make finer adjustments.

10. Click on the Close button.

7

8

9
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Light Table and Onion Skin 
The Light Table feature for stop-motion image capture can be used in two different ways: as a light table or as an onion 
skin option. As a light table, it can be used to display a series of images, such as JPEGs of a walk-cycle, behind the 
live image in the preview window. This can be useful if you wish to use a template for the stop-motion poses that you 
need. As an onion skin option, the preview window would display the live image with the one that was captured just 
moments before.

The different uses of the light table are based on the layer selected in the Layer drop-down menu. Choosing the same 
layer as the one you are capturing the images on will enable the Onion Skin option. Selecting any other layer will serve 
as a reference when capturing images for the stop-motion. Only image (bitmap) layers, as opposed to drawing (vector) 
layers, will appear in the drop-down.

To use the Light Table feature:

1. From the Layer drop-down menu, select the layer that you wish to see in the preview window. 

2. If the images that you are capturing do not have the same ratio as your TBS project (for example 16:9 instead of 
3:4) the Aspect Ratio drop-down menu will be enabled. Select the ratio option that suits your needs. 

3. Use the Opacity slider to control the transparency of the image being seen through the light table or onion skin.

To use the Light Table feature as an Onion Skin option:

1. Capture the first image without specifying the Layer to be used as a reference (i.e. in the Light Table section, the 
Layer drop-down menu is set to Disabled).

2. Once the first image is captured, go to the Layer drop-down menu and select the layer that the image has been 
captured on.

3. If the images that you are capturing do not have the same ratio as your TBS project (for example 16:9 instead of 
3:4) the Aspect Ratio drop-down menu will be enabled. Select the ratio option that suits your needs.

4. Use the Opacity slider to control the transparency of the image being seen through the light table or onion skin.

Use a video as a template to
mimic the poses for a walk-cycle

Selecting the layer on which the 
stop-motion images are being
recorded creates an onion skin
effect in the preview window
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Capture Features 

Auto Capture

Although some motions are easy to record by posing and reposing a figure while taking snapshots in between each 
movement, others are not. The Auto Capture feature allows you to automatically record movement when it is not 
practical to manually press the record button in succession. For example, capturing a ball dropping, or an event which 
takes place over an extended period of time, such as a time-lapse recording of a sunset.

To use the Auto Capture feature:

1. In the Auto Capture section, select a number of increments from the first drop-list.
2. From the second drop-list, select the units (msec, sec, min, hour, day).
3. When ready, click on the Start button.

Preview Window 
You can expand the preview window in the Image Capture window if it is not large enough for you to see all the details 

of the elements in your scene. Click on the Show/Hide Capture Options  button to expand this window.
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Colour Keying 

One of the ways that Toon Boom has ensured greater flexibility for your stop-motion projects, is by including the 
Colour Keying feature. With this feature, you can easily remove the background around your character and replace it 
with an hand-drawn background instead.

In order for the Colour Keying feature to work, it is essential that you place a solid coloured fabric behind your 
character so that it hides anything else that might appear in the camera frame.

To key out your coloured background:

1. If it is not already open, from the File menu, select Acquire > From Capture Device to open the Image Capture 
window.

2. Click on the Keying tab.

3. From the first drop-down menu, select the Keying type. It is recommended that you select the type that shows 
the most sensitivity to your background. This might not be obvious until you pick the colour that you wish to key 
out. You can gauge sensitivity by the amount of dancing pixels seen in the preview window.
 Chroma Keying (YUV) - YUV is a colour model (like RGB or CMYK) that encodes a colour image or video 

taking human perception into consideration. It allows transmission and compression errors to be more 
efficiently masked by the human perception than when using an RGB-representation. Mainly choose YUV if 
your recording device conforms to certain YUV standards.

 Chroma Keying (RGB) - The RGB colour model is an additive colour model in which red, green, and blue 
light are added together in various ways to reproduce a broad array of colours. RGB is a device-dependent 
color space: different devices detect or reproduce a given RGB value differently. Thus an RGB value does 
not define the same color across devices without some kind of colour management.

 Luma Keying - Luma corresponds to the brightness in an image i.e. the "black and white" portion. Luma is 
typically paired with chroma. Luma represents the achromatic image without any colour, while the chroma 
represents the colour information. Converting the output of a camera into luma and chroma allows a video 
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The numbers in this 
diagram refer to the 
steps shown below.
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system to optimize its performance for the human visual system, since human vision is more sensitive to 
luminance ("black and white") detail than colour detail.

4. Click on the Pick Colour button.
5. Use the eye dropper to select your background in the preview window. If there are some unavoidable highlights 

and shadows on your green screen, try to select a mid-tone area. The selected colour will appear in the swatch 
area beside the Pick Colour button.

Your preview window should come alive with dancing pixels.
6. If you selected Luma Keying as the keying type, you can also check Luma correction to help even out the image 

so that it is easier to extract a drawing from the background. 
7. If you selected either of the chroma keying types, check the Matte option if you wish to render the preview 

window achromatic. This option can make the keying process visually easier by seeing the selected portion 
being reduced to black and the keyed out portion being reduced to white.

8. Check the Hide Background option, if you wish to see which part of the image will be rendered transparent.
9. Play with the Minimum and Maximum sliders until your background disappears into a solid white (or transparent 

depending on which options were selected).
10. If there are still green areas remaining, try selecting one of the effects from the drop-down menu and chose the 

degree of Effect Intensity until you see a clean white or near clean white background in the preview field.

You should now be ready to capture images for you stop-motion animation. 
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Image Capture 

This is the easiest part of the stop-motion animation process. Click on the Capture button and watch your images 
being recorded as a string of frames along the timeline, on an Image Capture layer that was automatically created.

NOTE: if you are using a video camera, it will act as a still-frame camera; it will only capture the single images within 
its field of view. 

To perform an image capture:

1. Set up your first pose. Use the preview window and the recording device viewfinder to make sure that it is 
correctely framed. 

2. When you are ready, click on the Capture button.

3. Reposition your character and/or other elements on your stage. The smaller the movement, the smoother your 
animation will be.

4. When you are ready, click on the Capture button.

At this point, your Timeline should look something like this. Each frame represents an image capture.

5. Repeat this process until you have completed your motion sequence.
6. When you are finished, click the on the Close button. 
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Capturing Images in an Existing Layer
Instead of recording all the images that you need in one go, you may decide to chop up the action sequences into 
different recording sessions. However, if you do this you may notice that each time you close the Capture window and 
then start up again, the software automatically creates a new Image Capture layer. 

To add image captures onto an existing layer:

1. In the Timeline or Xsheet view, right-click (Windows) or [Ctrl] + click (Mac) on the empty cell where you would 
like the new captures to begin.

2. From the pop-up menu select Import Images > From Capture Device.

The Capture window appears.
3. Continue with the capture process as detailed above.

Vectorization and Clean-Up 
After finishing recording your stop-motion animation, you may notice that your character was not as cleanly keyed-
out as you would have liked. The fastest way to resolve this problem is to perform a clean-up. However, you cannot 
execute a clean-up without first converting your bitmap image sequence into vectors with a bitmap texture fill.

To vectorize and clean up your image sequence:

1. In the Timeline view, select and right-click (Windows) or [Ctrl] + click (Mac) on one of the cells in the Image 
Capture layer.

2. From the pop-up menu, select Convert Element to Vector.

A new Drawing layer should appear above your original layer with the same number of cells now converted into 
vectors.

3. In the Timeline view, select the first cell of the Image Capture layer. 

4. In the Drawing view, use the Contour Editor  tool to delete or move vector points until you have a clean 
outline around your bitmap fill.

5. Scrub through your animation to check for any anomalies in the contour of your character. 

Vectorized drawing layer

Original image layer
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What’s Next?
So far, you have learned about:

• Choosing a Character
• Setting Up a Stage
• Properties of the Image Capture feature
• Using the Light Table
• Creating an Onion Skin Effect
• Colour Keying
• Image Capture
• Vectorization and Clean-Up

Next you will learn all about how to set up a scene.
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Chapter 14  Scene Setup

Setting up your scene can be compared to building a set for a television show. This is the point where you position 
each scene element such as the Camera frame, the background elements and the characters.

In this chapter, you will learn about the following:

• Importing the Scene Elements, on page 348
• Ordering the Element Layers, on page 349
• Positioning the Scene Elements, on page 351
• Cloning and Duplicating Elements, on page 355
• Setting the Camera Frame, on page 358
• Creating a Multiplane, on page 362
• Creating a Motion Path, on page 366
• Animating the Camera, on page 379
• Function Editor View, on page 381
• Other Options, on page 389
• Preferences, on page 396
• What’s Next?, on page 399
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Importing the Scene Elements 
The first step when building your set, is to gather up the scene’s elements and import them into your Toon Boom 
Studio project.

Background, Sound or Movie
Refer to the Importing Artwork chapter to learn how to import different types of elements inside your scene.

Refer to the Sound and Lip-sync chapter to learn how to import sound files.

Show Scene Background Colour
If you have no background and want to use your Scene Background Colour as a colour card, enable the Show Scene 
Background Colour option. A colour card has no boundary.

By default the Scene Background Colour is set to white. To learn how to set your own colour card colour, refer 
to the Starting Your Project chapter.

To enable the Show Scene Background Colour option:

 Select View > Show Scene Background Colour.

To disable the Show Scene Background Colour option:

 Select View > Hide Scene Background Colour.

Templates
Refer to the Importing Artwork chapter to learn how to import elements from the Library view.

Disabled Enabled
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Ordering the Element Layers 

When you import the elements of your scene, they might not appear in the right order in which case, you need to 
reorder your layers. This can be easily done in the Timeline view or by using the Arrange commands from the Top 
Menu. You can also use the Ordering Layer Types in the Properties view.

• Ordering Layer in the Timeline View, on page 349
• Ordering Layers Using the Arrange Command, on page 350
• Ordering Layer Types, on page 350

Ordering Layer in the Timeline View
Ordering your layers in Toon Boom Studio is as easy as a drag and drop.

The order in the Timeline view will determine the way the layers appear in the Camera View. 

• The layer on top of the Timeline view will appear in front of all the other elements in the Camera view. 
• The layer on the bottom of the Timeline view will appear behind every other elements in the Camera view.

To order layers in the Timeline view:

1. In the Timeline view, select the layers to move.
2. Drag the selection to the new location and drop it in between the layers. Be careful not to drop your selection 

on a layer, this would create hierarchy. 
349



Toon Boom Studio User Guide
Ordering Layers Using the Arrange Command
You can also reorder the layers in your scene by using the Arrange menu command.

To arrange the layers:

1. In the Timeline view, select the layer you wish to reorder.
2. Select Arrange > the desired option from the Timeline View menu. You can also select Element > Arrange > 

the desired option.:
 Bring to Front

Select this option if you want to bring your layer on top of the Timeline view order. This will display your 
element in front of everything else in the Camera view.

 Bring Forward
Select this option if you want to bring your layer one step higher in the Timeline view order. This will display 
your element on one level higher in the Camera view.

 Send to Back
Select this option if you want to send your layer to the bottom of the Timeline view order. This will display 
your element behind everything else in the Camera view.

 Send Backward
Select this option if you want to send your layer one step lower in the Timeline view order. This will display 
your element one level lower in the Camera view.

Ordering Layer Types
In the Properties view, you can also set a layer ordering type for your elements.

• Background
Setting your layer as a Background type layer will automatically order this element behind all others in the 
Camera view. When it is set to Background, the Timeline ordering will have no effect on this layer.

• Normal
By default all layers are set as a Normal type layer. A layer set to Normal type will be affected by their 
ordering level in the Timeline view.

• Foreground
Setting your layer as a Foreground type layer will automatically order this element in front of all others in 
the Camera view. When it is set to Foreground, the Timeline ordering will have no effect on this layer.

To set the ordering layer type of an element:

1. In the Timeline or Camera view, select the element for which you wish to set the ordering type.

The selected layer parameters appear in the Properties view.

2. Click on the drop-down arrow button to open the Type menu and select the desired layer type for your element.

Your element will be ordered in the Camera view to fit the option you selected.
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Positioning the Scene Elements 
In Toon Boom Studio it is easy to position your elements. You can do this either by using the sceneplanning Select 

 tool or the Properties view. 

This topic is divided as follow:

• Positioning the Elements Using the Select Tool, on page 351
• Position the Elements Using the Properties View, on page 352
• Flipping Elements, on page 353
• Show Outline Selection, on page 353
• Locking Elements, on page 353

Positioning the Elements Using the Select Tool

Use the Sceneplanning Select  tool to position, scale, rotate and skew your elements directly in the Camera view, 
without creating a keyframe.

To use the Select tool:

1. In the Sceneplanning Tools toolbar, click on the Select  tool. You can also access the Select tool by going to 
Tools > Sceneplanning Tools > Select. The default keyboard shortcut is [6].

2. In the Camera or Timeline view, select the element you wish to position.
3. Use one of the bounding box handles to position and transform your element.
 Hold down the [Shift] key as you scale to keep the ratio when using the corner handles.
 Hold down the [Shift] key as you rotate to lock the rotation every 15 degrees.

Rotation

Vertical Skew

Horizontal Skew

Horizontal Scale

Vertical Scale

Temporary Pivot Offset

Position

Horizontal and Vertical
Scale
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Position the Elements Using the Properties View
Use the Properties view to position, scale, rotate and skew your elements using exact values.

To use the Properties view:

1. In the Timeline view, select the layer of the element you wish to position.

The layer is displayed in the Properties view.

2. In the Properties view, set the desired positioning values:
 Rotation

Enter a rotation angle value for the position of your element.
 Skew

Enter a skew angle value for the position of your element.
 Offset

Enter the South/North, East/West values for the position of your element.
 Rotation Pivot

Enter the South/North, East/West values for the position of the Rotation Pivot of your element. This is the 
central point to which your rotation angle will be calculated.

 Scale Pivot
Enter the South/North, East/West values for the position of the Scale Pivot of your element. This is the 
central point to which the scaling will be calculated. 

 Scale
Enter the scaling value for the position of your element. 1 = 100%.

 Keep Proportions
Enable this option if you want to keep the proportions of your original element when scaling it down or up.

You can change the type of unit to be displayed and used in the Properties view to inches or centimetres 
instead of the default Field values. Refer to the Preferences section to learn how to set the default unit type.
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Flipping Elements 
Sometimes you may need to flip a character element when you are positioning it. For example, if you want a face to 
look in the opposite direction. This can be easily done using the flipping command. This command produces a 
horizontal or vertical mirror image of your element. Using the flipping command eliminates any distortion you would 
have got if you had used the Sceneplanning tool to produce the mirror image instead. 

To flip an element:

1. In the Camera or Timeline view, select the element you need to flip.
2. Select Element > Transform > Flip Horizontal or Flip Vertical.

Show Outline Selection 
When you position many overlapping elements, use the Show Outline Selection option. This is very useful and once 
enabled it displays the outline of the selected element as blue lines that appear on top of everything else. 

To enable the Show Outline Selection option:

1. Select View > Show Outline Selection.

Locking Elements 
When you are positioning your elements in the Camera view you can lock the layers so that they will not move. Locking 
layers prevents them from being accidentally selected or moved.

Locking and Unlocking a Layer
To lock a layer:

1. In the Timeline view, select the element you wish to lock.

2. In the Timeline View Menu, select Lock > Lock.

Flip HorizontalFlip Vertical

Disabled Enabled
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The name of locked layers appears in red.

To unlock a layer:

1. In the Timeline view, select the locked element you wish to unlock.

2. In the Timeline View Menu, select Lock > Unlock.

Locking and Unlocking All Layers
To lock all layers:

1. In the Timeline view, select any layer.
2. In the Timeline View menu, select Lock > Lock All.

Every layer in the Timeline view is locked.

To unlock all layers:

1. In the Timeline view, select any layer.
2. In the Timeline View menu, select Lock > Unlock All.

Every layer in the Timeline view is unlocked.

Locking All Other Layers
To lock all other layers:

1. In the Timeline view, select the element you wish to keep unlocked.

2. In the Timeline View menu, select Lock > Lock All Others.

Every layer, except the selected one is locked.
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Cloning and Duplicating Elements 

It’s easy to create crowd scenes or reuse animation in your scene by making use of the clone and duplicate options. 
The example we use here is the creation of a school of fish swimming in the sea.

Cloning Layers 

Cloning a layer provides you with a copy of the selected layer that uses the same drawings as the original. If you 
modify a drawing in the cloned or original layer it is updated in both layers. You can modify the layers’ timing 
independently one from the other, but the drawings remain linked.

This feature is useful when you want to reuse an animation but have different timings.

To clone a layer:

1. In the Timeline or Xsheet view, click on the layer you want to clone. 

2. In the Timeline View menu, select Clone Element. 
The cloned layer will appear in the Timeline view. In the Camera view, an identical element will appear at the same 
place as the original one.
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3. Repeat step 2 until you have all the cloned layers you need.

4. In the Camera view, you can reposition and transform your duplicated layers if you need by using the 

Sceneplanning Select  tool. Refer to the Positioning the Scene Elements topic to learn more about the 
Sceneplanning Select tool.

Duplicating Layers 

Duplicating a layer provides you with an independent copy of the drawings and their exposure. You can modify 
anything you want in the duplicated layer without affecting the original one.

You can use duplicated layers if, for example, you want to reuse an animation of a fish to create a school of fish but 
you still want to modify some of them to give them their own personality.

To duplicate a layer:

1. In the Timeline view, click on the layer you want to duplicate.
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2. In the Timeline View menu, select Duplicate Element. 
The duplicated layer will appear in the Timeline view. In the Camera view, an identical element will appear at the 
same exact emplacement as the original one.

3. Repeat step 2 until you have all the duplicated layers you need.

4. In the Camera view, you can reposition and transform your duplicated layers if you need by using the 

Sceneplanning Select  tool. 
Refer to the Positioning the Scene Elements topic to learn more about the Sceneplanning Select tool.

5. In the Drawing view, modify your drawings if need be. 
Refer to the Drawing and Design chapter to learn how to draw in Toon Boom Studio.

Refer to the Creating a Motion Path topic to learn how to use cloned or duplicated fish to create a school of 
fish swimming along a defined trajectory.
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Setting the Camera Frame
The scene action occurs inside the camera frame, so it is really important to set it up correctly.

• Adding a Camera Layer, on page 358
• Choosing the Active Camera Layer, on page 359
• Setting the Camera Frame Position, on page 359

Adding a Camera Layer 
By default, Toon Boom Studio automatically add a camera to every new project your create, but you can also add your 
own camera layer if need be.

 NOTE: Unlike any other additional Camera layers, the default Camera layer can not be deleted. 

To add a Camera layer from the Timeline view:

1. In the Timeline view, click on the Add Element  button.
2. The New Elements dialog box opens.

 In the Type drop-down menu, select Camera.
 In the Name field, type in a name for your Camera layer. By default, the name of your Studio project 

appears in this field.
 In the Number field, type in the number of Camera layer you wish to add. You can also use the up and down 

arrow buttons to change the numbers.
 Click on the OK button.

The new Camera layer appears in the Timeline view.

You can also use the Scene View toolbar to add a new Camera layer into your scene.

To add a Camera layer from the Scene View toolbar:

1. In the Scene View toolbar, click on the Camera drop-down menu button.

2. Select Add Camera from the drop-down menu.

A new Camera layer will appear in the Timeline view.

Refer to the Discovering the Interface chapter to learn how to customize your workspace and display the 
different toolbars.
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Choosing the Active Camera Layer 
The Camera layer provided in your scene is the active camera by default. If you add several cameras to your scene 
and you want to have different settings on each, you can use the Scene View toolbar camera list to switch from one 
camera to another. You can use this feature if you are still working on your scene composition and you have different 
camera setups to choose from.

To select an camera:

1. In the Scene View toolbar, click on the Camera drop-down menu button.

2. Select the desired Camera from the drop-down menu.

A checkmark identifies the current active camera in the list.

In the Timeline view, the active Camera layer is displayed in italics.

 Refer to the Discovering the Interface chapter to learn how to customize your workspace and display the 
different toolbars.

Setting the Camera Frame Position 

You can set the Camera Frame position by using the sceneplanning Select  tool or the Properties view.

Setting the Frame Using the Select Tool
First, you can set the position of the camera frame.

To set up the camera frame using the Select tool:

1. In the Sceneplanning Tools toolbar, click on the Select  tool. You can also access the Select tool by going to 
Tools > Sceneplanning Tools > Select. The default keyboard shortcut is [6].

2. In the Camera or Timeline view, select the camera. Once it is selected, the frame will become red in the Camera 
view.

3. In the Camera view, grab the camera frame and drag to move it to the desired position.

 

As you position your camera, you might notice that the camera frame is moving slightly slower then your mouse cursor. 
This is due to the perspective effect because the Camera is not situated at the same depth level as the elements. 
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You can set your Active Camera to the Default Camera using the Scene View toolbar. This will enable a default camera 
frame in which you can position your Camera frame without experiencing the perspective illusion. Note that you can 
not move the default camera, it is only an indication of the default camera space. 

To enable the Default camera:

1. In the Scene View toolbar, click on the Camera drop-down menu button.

2. Select Default from the drop-down menu.

A checkmark identifies the current active camera in the list and a grey camera frame appears in the Camera 
view.

 Refer to the Discovering the Interface chapter to learn how to customize your workspace and display the 
different toolbars.

You can also set the Field of View, which is also called the Zoom level of the camera frame.

NOTE: If the default camera is enabled, you can not set the Field of View angle with the Select tool.

To set the Field of View angle using the Select tool:

1. In the Camera or Timeline view, select the camera. Once it is selected, the frame will become red in the Camera 
view.

2. In the Camera view, grab the FOV square situated on the bottom of the frame and drag it to change the zoom 
level.

 

Default Camera

Camera Element
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Setting the Frame Using the Properties View
You can also set the camera position and field of view with exact values using the Properties view.

 Refer to the Discovering the Interface chapter to learn how to customize your workspace and display the 
different toolbars.

To use the Properties view:

1. In the Camera or Timeline view, select your Camera.

The Camera information will be displayed in the Properties view.

2. In the Properties view, set the desired positioning values:
 Offset

Type in the North/South and East/West position values.
 FOV Type

Static Field: By default the Static Field of View type is enabled, this means that the zoom value will not be 
animated, it will stay the same throughout the scene. Type in the desired Field of View angle value.
Dynamic: Enable this option to animate the zooming value over time. Refer to Animating the Camera topic 
to learn more about animating the Field of View.

You can change the type of unit to be displayed and used in the Properties view to inches or centimetres 
instead of the default Field values. Refer to the Preferences section to learn how to set the default unit type.
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Creating a Multiplane

One of the exciting features in Toon Boom Studio is the Multiplane. In the Multiplane you can create backgrounds in 
several layers and spread them in depth along the Z-axis. This way you add depth to your project, and when you move 
the camera through this environment, it creates an impressive perspective illusion.

Distributing the Elements on the Z-axis
When it is time to position elements along the Z-axis you can do it via the Top, Side, Camera or Properties view

• Top and Side Views, on page 362
• Camera View, on page 364
• Properties View, on page 365

Top and Side Views

The Top and Side views are representations of your scene’s space viewed from the top and side.

When you move your element along the Z-axis, you will notice that it seems they are getting smaller or larger. This is 
because of the perspective effect, the elements that are closer to the camera appear larger and the elements that are 
far away, appear smaller. Because of this, once they are positioned you might need to resize your elements using the 

Sceneplanning Select  tool.

Camera Cone

Elements

Z-axis

O F/B
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To position elements in the Top view:

1. In the Sceneplanning Tools toolbar, select the proper tool:

 Select the Sceneplanning Select  tool if you want to set the static position of your element. The element 
will be positioned without creating a keyframe.

 Select the Transform  tool if you want to animate the element along the Z-axis, this will create a 
keyframe.

2. In the Timeline or Camera view, select the elements you want to reorder.

In the Top view, the selected element is represented by a darker green line.

3. In the Top view, grab your element and drag it to a new position:
 A vertical drag will position it along the Z-axis, (Forward or Backward).

 An horizontal drag will position it on the X-axis (East or West).

As you position your elements in the Top view, you can see the position update simultaneously in the Camera 
view.

To position elements in the Side view:

1. In the Sceneplanning Tools toolbar, select the proper tool:

 Select the Sceneplanning Select  tool if you want to set the static position of your element. The element 
will be positioned without creating a keyframe.

 Select the Transform  tool if you want to animate the element along the 
Z-axis, this will create a keyframe.

2. In the Timeline or Camera view, select the element you want to reorder.

In the Side view, the selected element is represented by a darker green line.

Forward

Backward

EstWest
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3. In the Side view, grab your element and drag it to a new position:
 A vertical drag will position it along the Y-axis, (North or South).

 An horizontal drag will position it on the Z-axis (Forward or Backward).

As you position your elements in the Side view, you can see the position updating simultaneously in the Camera 
view.

Camera View
You can order your elements along the Z-axis directly in the Camera view.

To distribute elements in the Camera view:

1. In the Sceneplanning Tools toolbar, select the proper tool:

 Select the sceneplanning Select  tool if you want to set the static position of your element. The element 
will be positioned without creating a keyframe.

 Select the Transform  tool if you want to animate the element along the Z-axis, this will create a 
keyframe.

2. In the Camera view, select the element you want, then to reorder it press and hold the [Alt] key. 
3. Next, press the [Up] arrow key to nudge the element backward or the [Down] arrow key to nudge the element 

forward. As you send your element backward or forward, you can see the result in the Top or Side view.

Forward Backward

North

South
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Properties View
You can use the Properties view to order your elements along the Z-axis using accurate Forward, Backward values.

To order elements using the Properties view:

1. In the Timeline view, select the layer of the element you wish to order.

The layer will be displayed in the Properties view.

2. In the Properties view, set the desired values:
• In the F/B Offset field (Forward/Backward), type in the desired value for the 

Z-axis Forward/Backward position.
• In the Scale fields, type in the desired value to resize your element following the Forward/Backward position 

of your element.
• Enable the Keep Proportions option to lock the ratio to resize the element proportionally.

You can change the type of unit to be displayed and used in the Properties view for inches or centimetres 
instead of the default Field values. Refer to the Preferences section to learn how to set the default unit type.
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Creating a Motion Path 

Another step in the scene setup task is to create motion path when needed. Once you set up your space and your 
camera frame, you can connect your elements to a peg to animate them on a trajectory.

In this topic you will learn about the following:

• Pegs, on page 366
• Motion Path, on page 370

Pegs
When creating a motion path for your element you need to add Peg layers in your scene and parent your elements 
to them.

This topic includes the following:

• Adding a Peg, on page 366
• Adding a Parent Peg, on page 367
• Parenting Elements to a Peg, on page 367
• Expanding and Collapsing Layers, on page 368
• Peg Only Mode, on page 368
• Peg Toolbar, on page 369

Adding a Peg
A Peg layer is a trajectory that contains no drawing, onto which you can hook your drawings. 

To add a Peg:

1. In the Timeline View toolbar, click on the Add Peg Element  button. You can also select Element > Add > 
Peg.

The Peg layer will appear in the Timeline view, on top of the selected element.
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Adding a Parent Peg
Adding a Parent Peg will automatically parent the new peg with the selected element as it is created.

To add a Parent Peg:

1. In the Timeline view, select the element you want to parent to a peg.

2. In the Timeline View toolbar, click on the Add Parent Peg Element  button. You can also select Element > 
Add > Parent Peg.

The Parent Peg layer will appear in the Timeline view with the selected element already connected to it.

Parenting Elements to a Peg
If you want to connect an element to an already existing peg or if you need to connect several layers to a peg at once 
here is how you can do it. 

If we come back to our school of fish example in the Cloning and Duplicating Elements topic, in order to make them 
swim together as a team, we will need to parent them all to the same peg.

To parent elements to a peg:

1. In the Timeline view, select the elements you want to connect to a peg. You can make a multiple selection with 
[Shift]+click.

2. Click and drag your selection on the desired peg.

You can also use the Attach to Next Object and Detach from Parent commands to connect and disconnect elements 
from a peg or from one another. Refer to the Other Options topic to learn more about these.
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Expanding and Collapsing Layers
To simplify the look of your Timeline view, you can collapse and expand your layers. If some layers are parented to 
other ones, you can collapse the parent layer to hide all of its children.

To collapse a layer selection in the Timeline view:

1. In the Timeline view, select the layers to collapse.

2. Select Arrange > Collapse/Expand from the Timeline View menu. You can also click on the Expand Children 
Arrow located on the parent layer.

To expand a layer selection in the Timeline view:

1. In the Timeline view, select the layers to expand.

2. Select Arrange > Collapse/Expand from the Timeline View menu. You can also click on the Expand Children 
Arrow located on the parent layer.

Peg Only Mode
Once you start to add Peg elements in your scene you can change the selection mode in the Camera view so that you 
can only select pegs. This can be useful when you are working on your motion paths and you want to prevent the 
selection of elements in the Camera view.

To enable Peg Only Mode:

• Select Tools > Turn On Peg-Only Mode. The default keyboard shortcut is [M].

To disable Peg Only Mode:

• Select Tools > Turn Off Peg-Only Mode. The default keyboard shortcut is [M].
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Peg Toolbar
The Peg Toolbar provides useful peg display options.

•  Show All Pegs
Enable or disable this option to display or hide all the pegs of your scene. If you have hidden pegs, you can 
show them without changing their show/hide status in the element list in the Timeline window. 
You can also select View > Pegs > Show All Pegs.

•  Show Peg Ghosts
When you are creating motion paths, elements linked to a Peg element may be offset from the motion 
path. This can make it difficult to visualize how an element will change position as it follows the peg. You can 
display peg ghosts in the Camera view to see the path that an element linked to a peg will follow. 
You can also select View > Pegs > Show Peg Ghosts.

•  Show Pivot Path
When you animated a peg pivot, you can display the resulting path in the Camera view. 
You can also select View > Pegs > Show Pivot Path.

Refer to the Function Editor View topic to learn how to animate a peg pivot.


•  Show Element Arms
You can show element arms when you are rotating a peg that you have attached multiple elements to. 
When you show element arms, a rotation handle appears on each element attached to the peg. 
You can also select View > Pegs > Show Element Arms.

EnabledDisabled

EnabledDisabled

EnabledDisabled

EnabledDisabled
369



Toon Boom Studio User Guide
Motion Path

Once you have hooked your elements to a peg, you can start adding keyframes to create a motion path. This way you 
can make an animation, such as an on-the-spot walk cycle or swimming cycle cross the screen.

This topic includes the following:

• Creating a Basic Motion Path, on page 370
• Displaying and Hiding a Motion Path, on page 371
• Adding and Controlling Motion Points, on page 372
• Switching Between Keyframe and Control Point
• Adjusting the Tension, Bias and Continuity, on page 375
• Previous and Next Control Point, on page 377
• Orient to Path, on page 377
• Constant Z, on page 378
• Snap Last Keyframe, on page 378

Creating a Basic Motion Path
To create a basic motion path:

1. In the Sceneplanning Tools toolbar, select the Motion  tool. It is also possible to create your motion path with 

the Transform  tool.

2. Select Tools > Turn On Peg-Only Mode to turn on the Peg-only mode, this will limit selection in the Camera 
view to pegs only. The default keyboard is [M].

3. In the Timeline view, go to the frame you want the motion path to start at.

4. In the Camera view, select the elements that you want to follow a motion path. Their parent peg will 
automatically be selected because of the Peg-only mode.

5. In the Camera view, click and drag your selection to the first position of the motion path trajectory.
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A keyframe will automatically be created in the Timeline view. This keyframe will also be displayed in the 
Camera, Top and Side views as a red square with an arrow.

6. In the Timeline view, go to the last frame of your trajectory.
7. In the Camera view, drag your selection to the last position of the motion path trajectory.

The trajectory will appear in the Camera view and the new keyframe will be created in the Timeline view.

When you create a motion path with non-constant segments, you will see a series of tick marks that represent the 
position of the element for each frame.

A basic motion path has been created and your animation should now follow the trajectory you created. In this 
example, the fish will swim across the screen in a straight line.

You can also modify the velocity of the motion path using the Function Editor view.

 Refer to the Function Editor View topic to learn more about velocity.

 You can set your preferences so that when you create a motion path, a default velocity is automatically applied. 
Refer to the Preferences topic to learn how to set your preferences.

Displaying and Hiding a Motion Path
By default, when you select a peg, its motion path is automatically displayed in the Camera view but as soon as you 
select an element that is not related to this peg, the motion path is hidden. You can enable the peg layer to allow the 
motion path to be displayed at anytime in the Camera view, even when it is not selected.

To display a motion path:

1. In the Timeline view, click on the peg layer arrow button to expand it.
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2. In the Timeline view, enable the peg layer.

The motion path will now be displayed in the Camera view even when the peg is not selected.

It is important that the peg layer is NOT collapsed when enabling or disabling it or else all of the parented 
layers would also be enabled and disabled at the same time.

Adding and Controlling Motion Points
If you want to create a motion path that is not straight, you must add motion points to the trajectory.  Motion points 
can be either keyframes or control points. Keyframes are locked to a specific frame and control points are not locked. 

• Add keyframes when you want your element to reach a specific position on a specific frame number.  A 
keyframe is displayed as a red square.

• Add control points when you want your element to reach a specific position, but not at a specific frame 
number. A control point is displayed as a green circle.

With the Motion  tool, you can modify motion paths by adding and moving keyframes on the peg. 

When used simultaneously, the Camera, Top and Side views allow you to create motion paths that go from East to 
West, North to South, or Front to Back. 

• In the Camera view, you can control the east, west, north and south positions of the motion path.

• In the Top view, you can control the forward, backward, east and west positions of the motion path.

• In the Side view, you can control the forward, backward, north and south positions of the motion path.

To add motion point:

1. In the Sceneplanning Tools toolbar, select the Motion  tool.

2. In the Timeline view, select the peg layer.

The motion path trajectory will appear in the Camera, Top and Side views.
372 



Chapter 14: Scene Setup   
3. In the Camera, Top or Side view, place the pointer over the trajectory while holding one these two keys:
 [Alt]

Hold the [Alt] key if you want to add a keyframe. The pointer will change to a black square. 

 [Shift]
Hold the [Shift] key if you want to add a control point. The pointer will change to a black diamond.

4. In the Camera, Top or Side view, place the black square where you want your motion point to be added and 
click the mouse.

A keyframe or a control point will be added exactly at that place.

5. In the Camera view, click and drag the new control points to control the motion path.
 The keyframe is locked to a specific frame. Repositioning the new keyframe along the path will modify the 

speed of the two segments.

 The control point is not locked to a specific frame. Repositioning the new control point will not affect the 
speed of the two segment, it will remain constant throughout the motion path.

6. To delete a control point, select it on the motion path and press [Del].

Keyframe

Control Point

Faster Slower 

Constant Speed
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To add and remove control points from the Properties view:

1. In the Sceneplanning Tools toolbar, select the Motion  tool.

2. In the Timeline view, select the motion path peg to display it in the Camera view.
3. In the Camera view, select one of the control points on your motion path.

The control point properties are displayed in the Properties view.

4. In the bottom of the properties view, click on the Add  button.

The Add Motion Point dialog box opens.

5. Use the Point Type drop down menu to select between Control Point and Keyframe.

6. In the Frame field, enter the frame number where you want the new motion point to be added.

7. Click on the OK button.

The new motion point will be added to your motion path.
8. To delete a selected motion point using the Properties view, click on the Delete button.

You can also modify the velocity between the different control points using the Function Editor view.

 Refer to the Function Editor View topic to learn more about velocity.
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Switching Between Keyframe and Control Point
You can easily switch from a keyframe to a control point or the opposite using the Properties view.

To switch between keyframe and control point using the Properties view:

1. In the Sceneplanning Tools toolbar, select the Motion  tool.

2. In the Timeline view, select the motion path peg to display it in the Camera view.
3. In the Camera view, select one of the control points on your motion path.

The control point properties are displayed in the Properties view.

4. Enable or disable the Lock in Time option:
 If you selected a control point, the Lock in Time option is disabled. Enable it to turn your control point into 

a keyframe.
 If you selected a keyframe, the Lock in Time option is enabled. Disable it to turn your keyframe into a 

control point.
5. You can also enable or disable the Constant Segment option:
 By default, the Constant Segment is disabled because Toon Boom Studio automatically creates non-

constant segments between keyframes. Enable it to turn your segment to a constant segment.
 If the motion point you selected precedes a constant segment, the option will be enabled. Disable it to 

change your segment to a non-constant segment.

 Refer to the Animating a Puppet chapter to learn more about keyframes and constant vs. non-constant 
segments.

Adjusting the Tension, Bias and Continuity
You can use the Tool Properties view to edit keyframes and control point parameters such as position, continuity, bias, 
tension and lock in time. 

Each time a Keyframe or a Control Point is selected in the Camera, Top or Side view, its parameters appear in the 
Properties view.
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You can adjust these parameters on existing Control Points and Keyframes by selecting the point in the Camera View 

with the Motion  tool and using the Continuity, Tension and Bias sliders in the Properties view.

• Continuity
 This controls the smoothness of a transition between the segments joined by a point.

• Tension
This controls how sharply the path bends as it passes through a control point or keyframe.

• Bias
This controls the path slope so that it flows towards one side of the motion point or the other.

You can customize the default Tension, Continuity and Bias values in your preferences. Refer to the Preferences 
topic to learn how to set your preferences.

A Continuity of -1 sharpens 
the transition on either side of 
the control point.

A Continuity of +1 rounds out the 
transition, creating gentle curves on 
either side of the control point.

A Tension of -1 increases the 
curve on either side of the 
control point.

A Tension of +1 sharpens the curve 
on either side of the control point.

A Bias of -1 favours the right 
side of the control point.

A Bias of +1 favours the left side 
of the control point.
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Previous and Next Control Point
In Toon Boom Studio, there are shortcuts and options available for navigating between control points on a motion 
path.

To navigate between control points using shortcuts and menu option:

1. In the Sceneplanning Tools toolbar, select the Motion  tool.

2. In the Timeline view, select the motion path peg to display it in the Camera view.
3. In the Camera view, select one of the control points on your motion path.
 To go to the previous control point, select Element > Arrange > Previous Control Point. You can also use 

[,] the default keyboard shortcut in the Camera view.
 To go to the next control point, select Element > Arrange > Next Control Point. You can also use [.] the 

default keyboard shortcut in the Camera view.

To navigate between control points using the Properties view:

1. In the Sceneplanning Tools toolbar, select the Motion  tool.

2. In the Timeline view, select the motion path peg to display it in the Camera view.
3. In the Camera view, select one of the control points on your motion path.

The control point properties are displayed in the Properties view.
4. In the bottom of the Properties view, click on the Previous and Next buttons to navigate through the control 

points.

Orient to Path
Toon Boom Studio has an option which forces the element connected to the path to follow the motion path.The 
Orient to Path option is available in the Peg layer Properties view. 

In this example, the default setting shows the fish keeping its original orientation throughout the motion path. 
However, when the Orient to Path option is enabled, the fish follows the motion path. You could use this option if you 
wanted to make the fish leap out of the water and back in again. 

To enable the Orient to Path option:

1. In the Timeline view, select the parent peg of the element you wish to follow the motion path.

The properties of the selected peg will be displayed in the Properties view.
2. In the Properties view, enable the Orient to Path check box.

Disabled Enabled
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Constant Z
In the Properties view of a peg layer, you have the Constant Z option. This option is disabled by default, which means 
that when you create a motion path along the Z-axis, the automatic interpolation calculates the X, Y and Z axis values. 
When it is enabled, the interpolation calculates the X and Y axis values and will keep the Z-axis value as constant.

To enable the Constant Z option:

1. In the Timeline view, select the peg you want to enable the constant Z option for.

The properties of the selected peg will appear in the Properties view.
2. In the Properties view, enable the Constant Z check box.

Snap Last Keyframe
The Snap Last Keyframe command forces the last keyframe and the keyframe before it to retain the same position 
values.

To enable the Snap Last Keyframe option:

1. Select Tools > Snap Last Keyframe.

EnabledDisabled
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Animating the Camera
In Toon Boom Studio you can connect a peg to your Camera and create a camera move in much the same way that 
you can animate motion paths for your elements. This means that you can animate the camera visually in the Camera, 
Top and Side views, with the function curve, or by typing values in the Properties view. 

Scenes are not only composed of characters moving around in a static camera field, they are also composed of camera 
movements. Although it is not always something that we think about, often it is the exact opposite, the character is 
static while the camera moves through elements on the stage. Camera pans, jumps, cuts and zooms are as important 
to storytelling as the story itself.

Toon Boom Studio has a camera that can move along the X, Y and Z axes. Having the camera move on the Z-axis 
allows you to create truck in and truck out, as well as multiplane camera moves. 

This topic is divided as follow:

• Adding a Peg to Your Camera, on page 379
• Making a Basic Camera Move, on page 379

Adding a Peg to Your Camera
To add a parent peg to your camera:

1. In the Timeline view, select the Camera layer.

2. In the Timeline view, click on the Add Parent Peg  button.

A Peg layer appears directly above the Camera layer so that the Camera layer is automatically attached to it. 
The Peg layer automatically takes on the name of the camera and adds the suffix -P to indicate that it is a peg 
layer, for example Camera-P.

Making a Basic Camera Move
Once you added a peg to your Camera, you are now ready to animate your camera.

To animate your camera:

1. In the Sceneplanning Tools toolbar, select the Motion  tool.

2. In the Timeline view, select the camera peg layer on the first frame of the scene.

3. In the Top view, select the camera and move it to the desired position. You can refer back to the Camera view to 
see how this camera moves the frames in your scene.

4. In the Timeline view, click on a cell in the Camera Peg layer where you would like the camera move to begin. 
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5. Right-click (Windows) or [Ctrl]+click (Mac OS X) and select Add Keyframe from the menu that appears. You can 
also use [I], the default keyboard shortcut.

A keyframe now appears in that cell. Any frames preceding this keyframe cell will hold the same camera position 
as in this keyframe.

6. Click on another cell where you would like the camera move to end.

7. In the Top view, select the camera and move it to the desired position.

A second keyframe appears and a line is created between the two frames to indicate that Toon Boom Studio 
created a non-constant segment, meaning that it will automatically interpolate the movement.

To learn more about the Camera positioning tools, refer to the Setting the Camera Frame topic. To learn 
more about animating with a Peg, refer to the Creating a Motion Path topic.
380 



Chapter 14: Scene Setup   
Function Editor View
The graph in the Function Editor View displays the motion over the first and last keyframes set in the scene, as well 
as any motion points created in between. 

NOTE: If the scene is 60 frames, but the motion path ends at frame 40, then the editor will only display up to frame 40.

You can use the Function Editor View to create and edit motion paths and movements as well as edit velocity.

This topic is divided as follows:

• Function Editor View - Overview, on page 381
• Adjusting the Velocity, on page 383
• Adding and Deleting Motion Points in the Function Editor View, on page 385
• Changing the Values of a Motion Point, on page 387

Function Editor View - Overview

1. Function Editor View toolbar:

•  Select: Use this to manipulate the motion point and velocity Bezier handles.

•  Grabber: Use this tool to pan in the Function Editor View.

•  Zoom: Use this tool to zoom in and zoom out (hold [Alt]) in the Function Editor View.

•  Show Grid: Shows or hides the grid.

•  Reset: Resets the pan and zoom in the Function Editor View. 

•  Add Keyframe: Use this tool to add a keyframe on the curve.

•  Remove Keyframe: Use this tool to delete a keyframe on the curve.

•  Lock In Time: Use this option to toggle the selected motion point between a keyframe or a control 
point.

•  Function Drop-down menu: Choose the function you want to display and edit from this drop-
down menu.

1

2

3

4

5

6
7
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•  North/South: Click on this button to display the North/South values in the Fields scale of the graph.

•  East/West: Click on this button to display the East/West values in the Fields scale of the graph.

•  Forward/Backward: Click on this button to display the Forward/Backward values in the Fields scale of 
the graph.

2. Graph
The graph area displays a Fields scale vertically on the left, a Frame scale on the top and the selected function 
curves and motion points.

3. Function Editor View Status Bar
This displays the values, frame and fields, for the currently selected motion point.

4. Editing Panel
The Editing Panel is contextual, the fields displayed there are relative to the type of function you selected in the 
function drop-down menu. Enter specific values in these fields to edit the motion points on the curve.

5. Function Curve
The function curve displays the selected movement of a peg as an editable curve with visible motion points.

6. Frames and Fields Scales Zoom
Use these sliders to increase or decrease the spacing between each value on the Frames or Fields scale.

7. Function Editor View bottom toolbar:

•  Sync Current Frame: When this option is enabled, when you select frames in the Function 
Editor view, the entire scene’s views (Camera, Timeline, etc) will be in-sync and follow. When this option is 
disabled and you select frames in the Function Editor view, the other scene views stay at the current frame.

•  Show/Hide toolbars: Click on this button to show or hide the Function Editor View toolbar.

•  Show/Hide Editing Panel: Click on this button to show or hide the Editing Panel.
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Adjusting the Velocity
The velocity, or ease-in ease-out, is used on non-constant segments to give a more natural feeling to the movement.

Ease-in and ease-out is the acceleration and deceleration of the movement. The speed of the motion 
is adjusted between two keyframes so that the movement will start slowly, speed up and then slow 
down again as it reaches the second keyframe. Adjusting the velocity will create a more natural feel to 
the movement.

You can set your preferences so that when you create a motion path, a default velocity is automatically applied. 
Refer to the Preferences topic to learn how to set your preferences.

To adjust the velocity of a movement:

1. In the Sceneplanning Tools toolbar, select the Motion  tool.

2. In the Camera or Timeline view, select the motion path peg of which you want to adjust the velocity.

The selected peg properties will appear in the Properties view.

3. In the Properties view, click on the Edit Velocity  button.

The Function Editor view opens.
4. In the drop-down menu, select Velocity-based, to edit the velocity of the motion path.
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5. In the Function Editor view, click on the Curve  button and adjust your curve:

 Click on a keyframe to select it.
 Drag the handle to adjust the curve.

6. You can also use the default curve options to quickly adjust your velocity.
 Click on the Curve icon to open the drop-down menu and select the desired velocity option.

  Constant
This option will change a non-constant segment to a constant segment removing the automatic motion 
tweening created by Toon Boom Studio.

  Linear
This option will create a straight line of constant speed for a more automated animation look.

  Ease in/out
This option will create a gradual acceleration at the beginning and a gradual deceleration at the end of 
the curve. This creates a more natural animation look.

  Fast in/out
This option will create a curve that starts quickly, slows down in the middle and ends with a final 
acceleration.

  Extreme ease in/out
This option will create a more dramatic ease in, ease out effect.

  Extreme fast in/out
This option will create a more dramatic fast in, fast out effect.

  Slow acceleration
This option will create a curve that starts slowly to smoothly accelerate over time.

  Slow deceleration
This option will create a curve that starts quickly to smoothly decelerate over time.

Keyframe
Selected

Keyframe

Handle
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Adding and Deleting Motion Points in the Function Editor View
Modifications can be made to a motion path and any peg or element movement by adding and deleting motion points 
in the function curve. This is done in the Function Editor View.

Adding Motion Points
To add motion points in the Function Editor View:

1. In the Sceneplanning Tools toolbar, select the Motion  tool.

2. In the Camera or Timeline view, select the peg of the motion path you want to edit.

The selected peg’s function curve will appear in the Function Editor View.
3. In the graph section, click on the frame number where you would like to add a motion point. You can also type 

in the desired frame in the Editing Panel.

In the graph section, the selected frame number is indicated by a blue vertical line.

4. Click on the Add Keyframes  button.

A keyframe will appear on the function curve at the selected frame. This new keyframe will also be visible on 
your motion path in the Camera, Top and Side views as well as on your peg layer in the Timeline view.

 If you want the new motion point to be a control point rather than a keyframe, click on the Lock In Time  
button to disable it.

The selected keyframe will change into a control point.

 To change a control point into a keyframe, select the control point on the function curve and click on the 

Lock In Time  button to enable it. The selected control point will change into a keyframe.

Graph

Edition Panel
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Delete Motion Points
To remove motion points from the Function Editor View:

1. In the Sceneplanning Tools toolbar, select the Motion  tool.

2. In the Camera or Timeline view, select the peg of the motion path you want to edit.

The selected peg’s function curve will appear in the Function Editor view.
3. In the graph section, click on the motion point you want to delete. You can also type in the desired frame in the 

Edition Panel.

The selected motion point will be highlighted in the function curve.

 If the selected motion point is a control point, you first need to change it to a keyframe by clicking on the 

Lock In Time  button to enable it.

4. Click on the Remove Keyframe  button.

The selected keyframe is deleted from the function curve. It will also be deleted from your motion path in the 
Camera, Top and Side views as well as on your peg layer in the Timeline view.

Graph

Edition Panel
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Changing the Values of a Motion Point
You can modify your motion paths and movements by positioning the motion points directly in the Camera, Top or 
Side view, but you can also modify the value of the motion points from the Function Editor View.

To modify a motion path motion point’s values:

1. In the Sceneplanning Tools toolbar, select the Motion  tool.

2. In the Camera or Timeline view, select the peg of the motion path you want to edit.

The selected peg’s function curve will appear in the Function Editor view.
3. In the graph section, click on the motion point you want to reposition.

The selected motion point will be highlighted in the function curve.

4. Choose with the Field Values    buttons which values; North/South, East/West or Forward/
Backward you want to edit and display in the vertical value scale of the graph.

5. Position your motion point:
 Keyframe:

 Drag your keyframe up and down to modify the Fields value of the keyframe. Since a keyframe is 
locked in time you can not modify the Frame value. A red guide appears to help you align the keyframe 
to the right value.

 You can also type in the desired value in the Editing Panel.

 Enable the Constant Segment option if you want to change the non-constant segment following the 
selected keyframe to constant.
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 Control Point
 Drag your control point along the curve to modify the Fields value. A control point is not locked in time 

but is constrained by the curve. The frame value will automatically be changed in relation to the fields 
value you are giving it. A red guide appears to help you align the keyframe to the right value.

 You can also type in the desired value in the Editing Panel.
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Other Options 
Many features, options and tools are available to help you learn, create and optimize your projects. Here are some 
which are useful when setting up your scene and creating motion paths:

• Attach to Next Object, on page 389
• Detach from Parent, on page 389
• Change Start Frame, on page 390
• Change Duration, on page 390
• Change Loops, on page 391
• Element Notes, on page 392
• Show Timeline Selection, on page 393
• Paste Special, on page 394

Attach to Next Object
You can easily connect elements to one another using drag and drops in the Timeline view. If you prefer, you can also 
use the Attach to Next Object when it is time to create a hierarchy.

The Attach to Next Object command will connect the selected element to the one situated one level lower in the 
Timeline view order making it its child.

To attach elements using the Attach to Next Object command:

1. In the Timeline view, select the element you want to attach to the element situated immediately below it.
 You can also use a sceneplanning tool and select the element directly in the Camera, Top or Side view.

2. Select Element > Arrange > Attach to Next Object.

The selected element will become the child of the element that was situated under it.

Detach from Parent
You can easily manipulate hierarchy connections using drag and drops in the Timeline view. If you prefer, you can also 
use the Detach from Parent command to disconnect a child element from its parent from the Camera, Top or Side 
view.

To detach a child element from its parent:

1. In the Sceneplanning Tools toolbar, click on the Select  tool. You can also access the Select tool by going to 
Tools > Sceneplanning Tools > Select.

2. In the Camera, Top or Side view, select the element you wish to detach from its parent. You can also select the 
element directly in the Timeline view.

3. Select Element > Arrange > Detach from Parent.

The selected element will be detached from its parent.
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Change Start Frame
You can quickly offset the timing of elements in your scene. This can be useful if for instance, you realize that the 
planned action would be better occurring at a later moment or if you inserted new elements or action at the beginning 
of your Timeline.

To change the starting frame of an element or peg’s motion:

1. In the Timeline view, select the element you want to offset.

2. Select Element > Change Start Frame from the top menu.

The Change Start Frame dialog box opens.

3. In the Change Start Frame dialog box, type in the frame number where you want your element to start.

The starting frame of the selected element will be changed to the one you typed in the Change Start Frame 
dialog box.

Change Duration
You may need to extend the duration of a peg, for example if you add content or change the exposure of the element 
that is attached to it.

To change the duration of a motion:

1. In the Timeline view, select the peg element of which you want to change the duration.

2. Select Element > Change Duration from the top menu.

The Change Duration dialog box opens.

The Enter the New Duration field displays the current duration of your element.
3. In the Change Duration dialog box, type in the desired duration.

The duration of the selected element will be updated.

The duration of a peg element can also be changed by stretching the peg’s motion block in the Timeline view.
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To stretch a Peg element:

1. In the Timeline view, move the pointer to the edge of the peg element’s motion block and drag it right or left to 
increase or decrease the length of the motion.

 NOTE: Stretching a peg moves all of the keyframes proportionally.

Change Loops
If you want a Peg element to repeat a motion, you can loop it.

Note that each time the loop restarts, it skips the first frame of the peg. This is similar to a walk-cycle where the last 
step leads naturally to the first step in the cycle, this ensures the logical continuation of the looped action. Therefore, 
if you loop a 10 frame peg action three times, the entire length of the peg will be 28 frames.

To loop a peg motion using the Change Loops command:

1. In the Timeline view, click on the Peg element’s motion segment you wish to loop. 

 
1. Select Element > Change Loops from the top menu. You can also right-click (Windows) or [Ctrl]-click (Mac OS X) 

directly on the Peg element’s motion segment you wish to loop and select Change Loops from the pop up 
menu.

The Change Loops dialog box opens.

2. In the Change Loops dialog box, type the number of times you want to repeat the selected motion segment and 
click OK.

The peg now repeats itself for the number of loops you selected. After the first segment, the peg motion bar 
representing the looped segment is displayed in light gray.

 To remove the loop, go through the previous step by step once again and type the value 0 in the Change 
Loops dialog box.

You can also loop a motion with a click and drag.

Original motion Looped segment
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To loop a peg motion by dragging the motion segment:

1. In the Timeline view, hold [Ctrl] (Windows) or [] (Mac OS X) and drag the end of the peg’s motion segment to 
the desired position.

2. Release to create a loop that will repeat until the destination frame.

Element Notes
The Element Notes option lets you write notes or comments in a layer for future reference.

To create an element note:

1. In the Timeline view, select the layer in which you want to include a note or a comment.

2. In the Timeline menu, select Add Element Note. You can also Right-click (Windows) or [Ctrl]+click (Mac OS X) 
on the layer and select Add Element Note from the pop-up menu.

The Note dialog box opens.

3. In the empty text field, type in your note or comment.

4. Press on the OK button.

The Note icon will appear on the Selected Layer.

To open and edit an element note:

1. In the Timeline view, select the layer containing the element note. 
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2. In the Timeline menu, select Update Element Note. You can also Right-click (Windows) or [Ctrl]+click (Mac OS 
X) on the layer and select Update Element Note from the pop up menu or double-click on the Note icon of the 
layer.

The Note dialog opens, displaying the element’s note previously entered.

3. You can edit the note if you need to and press on the OK button to close it.

Show Timeline Selection
Use this option if your scene becomes crowded and you want to quickly find the layer in the Timeline view that 
corresponds to the selected element in the Camera view.

To show the timeline selection:

1. In the Camera view, select the element you want to find in the Timeline view.

2. Select View > Show Timeline Selection. The default keyboard shortcut is [O].

The Timeline view automatically sets its focus so that the selected layer appears on top of the view.
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Paste Special
Use the Paste Special command to paste a copied selection of frames in the Timeline view and to define which 
properties you want to paste.

To use the Paste Special command:

1. In the Timeline view, select the frames to copy. This selection can include single or multiple frames, drawings 
and keyframes.

2. Select Edit > Copy Cell. The default keyboard shortcut is [Ctrl]+[C] (Windows)
or []+[C] (Mac OS X).

3. In the Timeline view, select the cell in which you want to paste the copied values.
4. Select Edit > Paste Special. The default keyboard shortcut is [Ctrl]+[B] (Windows) 

or []+[B] (Mac OS X).

The Timeline Paste Special Preferences dialog box opens.

5. In the Pegs section enable or disable the options to choose the values of the keyframe you want to paste:
• Create/Delete Motion Key Frames

Enable this option to paste the translation value of the copied keyframe.
• Create/Delete Rotation Key Frames

Enable this option to paste the rotation value of the copied keyframe.
• Create/Delete Scale Key Frames

Enable this option to paste the scale value of the copied keyframe.
• Create/Delete Pivot Key Frames

Enable this option to paste the pivot position value of the copied keyframe.
• Create/Delete Velocity Key Frames

Enable this option to paste the velocity value of the copied keyframe.
• Create/Delete Skew Key Frames

Enable this option to paste the skew value of the copied keyframe.
• Create additional key frames at beginning and end of selection

This option will create an additional keyframe at the beginning and at the end of your pasted selection to 
block the copied values between them.
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6. In the Drawings section enable or disable the desired options. 

• Create/Delete Exposure
Enable this option to paste the drawing exposure. Disabling this option will grey out the rest of the 
Drawings options, as it will mean that you only wish to paste position and peg values.

• Overwrite existing drawings
Enabling this option will overwrite existing drawings in the destination layer if they have the same name as 
the copied ones. When this option is disabled, new drawings will be created instead.

• Automatically extend the exposure
This option will automatically extend the exposure of the last copied frame to the last frame of the 
destination layer, overwriting the existing exposure. Disabling this option will grey out the Keyframe Mode 
(substitution) option.

• Keyframe Mode (substitution)
This option is used with the Automatically extend the exposure option. It will paste and extend the 
keyframe information of the copied element in the destination layer following the same rules as the 
Automatically extend the exposure option.

• Update Colours
When pasting templates, this option updates the current animation colours to those used in the templates.

 Refer to the Animating a Puppet chapter to learn how to copy and paste keyframes only from an element 
using the Paste Special command.

Paste Special Again
Once you set up the proper option in the Paste Special dialog box, you can use the Paste Special Again command to 
quickly paste the parameters using the same options without going through the Paste Special dialog box.

To use Paste Special Again:

1. In the Timeline view, select the frames you wish to copy. This selection can include single or multiple frames, 
drawings and keyframes.

2. Select Edit > Copy Cell. The default keyboard shortcut is [Ctrl]+[C] (Windows) 
or []+[C] (Mac OS X).

3. In the Timeline view, select the cell in which you want to paste the copied values.
4. Select Edit > Paste Special Again. The default keyboard shortcut is 

[Ctrl]+[Shift]+[B] (Windows) or []+[Shift]+[B] (Mac OS X).

Your copied selection will be pasted using the same options as the last time you used the Paste Special 
command.
395



Toon Boom Studio User Guide
Preferences
You can set preferences that can help you be more efficient and comfortable when you work on your scene setup:

In Toon Boom Studio, you can set your own preferences to fit your work style and needs when setting up your scene 
and creating motion paths.

To open the preferences panel:

 Windows
Select Edit > Preferences.

 Mac OS X
Select Toon Boom Studio 7.1 > Preferences.

Sceneplanning Preferences

Motion Points
In this section, you can set the default Tension, Continuity and Bias values when adding motion points to your motion 
paths.

 Refer to the Adjusting the Tension, Bias and Continuity topic to learn more about these values.

Coordinate Units
You can choose the coordinate units used in the scene’s Properties view. 
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Show Units

Enable or Disable this option to show or hide the unit type in the Properties view. Note that the unit type can only be 
hidden when the unit type is set to fields.

Coordinate Units

Use this drop-down menu to choose between the three available unit types.

Camera View
This section is where you set the selection display preferences for the Camera view.

Use Box Highlighting

When this option is enabled, the bounding box of a selected item in the Camera view is highlighted. When it is 
disabled, the bounding box is a regular thin grey line box and the element itself is highlighted.

Selection Always Visible
When this option is enabled, even when a layer is hidden in the Timeline view, it will remain visible in the Camera view 
when it is selected. When the option is disabled, a hidden layer in the Timeline view will remain hidden in the Camera 
view when it is selected.

Enabled Disabled

Centimetres Inches Fields (default)

Enabled Disabled

Enabled Disabled
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Pegs
Use the Pegs section options to set your preferences related to motion paths creation.

Create Linear Spline

By default, the Create Linear Spline option is enabled, so when you animate an element with a motion, rotation or 
scaling, the velocity will be set to Linear. This means that the motion tweening executed by Toon Boom Studio will be 
straight with no variation in the speed. You can disable this option so that every time you create a motion, rotation or 
scaling, the velocity will be set to the default ease-in, ease-out curve.

 Refer to the Adjusting the Velocity topic to learn more about velocity and ease-in, ease-out concept.

Create Constant Keyframes

By default, the Create Constant Keyframes is disabled so every time you create a motion, a non-constant segment is 
created between every two keyframes and the motion tweening is automatically calculated by Studio.

You can enable the Create Constant Keyframes so that every time you create a motion, the segments in between the 
keyframes will automatically be constant. No motion tweening is calculated and the position jumps from one to 
another at each keyframe.

 Refer to the Animating a Puppet chapter to learn more about constant and non-constant segments.

Timeline

Single Cell Selection
This option is enabled by default. This means that when you select a cell in the Timeline view, only this cell is selected. 
You can disable this option so that when you select a cell in the Timeline view, the entire exposure block of this layer 
is selected at once.

Enabled

Disabled
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What’s Next?
In this chapter, you learned about the following:

• Ordering Elements
• Positioning Scene Elements
• Duplicating and Cloning Elements
• Setting the Camera Frame
• Creating a Multiplane
• Creating a Motion Path
• Animating a Camera
• Using Paste Special

Is it now time to learn about using Toon Boom Studio’s effects to enhance your animation project.
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Chapter 15       Enhancing With Effects

The most important part of animation is creating life-like movement, followed by telling a good story and the creation 
of memorable characters. However, when all that is done, it is nice to add a little icing on the cake. Enhance your 
animation by giving it some subtle atmosphere, or by turning up the wow factor. Toon Boom Studio offers eleven 
different pre-installed effects to choose from.

• Special Effects, on page 402
• Forces of Nature Effects, on page 427
• Disabling All Effects, on page 438
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Special Effects
Use Toon Boom Studio’s special effects to add a shadow to your character that follows its every movement, to 
softening the edges of atmospheric elements, such as the sun and clouds, as well as to create a beautiful sunset and 
much, much more.

• Clipping Effect, on page 403
• Feather Edge Effect, on page 408
• Drop Shadow Effect, on page 410
• Colour Transform Effect, on page 415
• Blur Effect, on page 420
• Shake Effect, on page 424
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Clipping Effect 

The Clipping effect can also be called Mask effect. This effect allows you to cut and hide part of your animation. For 
example, if your background is a picture of the seabed with seaweed in front, you may want your animation to pass 
between the seaweed and the rest of the images instead of passing in front.

To do so, you will need to create a drawing of the zone where you want your animation to appear and connect it to a 
Clipping effect. This drawing is called a Mask. The Clipping effect will hide any portion of your animation outside of 
the mask drawing you did. It will hide it not delete it. Your animation remains intact.
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To create a Clipping effect:

1. In the Timeline view, click on the Add Drawing Element  button to add a new layer for your mask drawing.

2. Double-click on the new layer and rename it Mask Drawing.

3. In the Tools toolbar, select the Brush  tool.

4. In the Colour Palette view, select any bright colour.

5. In the Camera view, trace the section that you want to remain visible in your animation.

6. In the Tools toolbar, select the Paint  tool.

7. In the Camera view, paint the closed zones of your mask drawing.

8. In the Effects toolbar, click on the Clipping effect  button.

You can also add the Clipping effect from the Timeline view.

 In the Timeline view, click on the Add Element  button.
 The New Elements dialog box opens.
 In the Type drop-down menu, select the Clipping Effect layer.
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 In the Name field, rename the effect appropriately.

 Click on the OK button.

9. In the Timeline view, select your Mask drawing and drag it ONTO the Clipping’s Mask layer.

10. Select your image or animation and drag it ONTO the Clipping Effect layer.
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11. Playback your animation. You should now see only the portion you want to be visible.

If you feel that your Timeline view is too crowded with the effects that you are adding, you can hide the mask elements 
of your Clipping effects. This will hide the mask layers in the Timeline view without disabling the effect.

To hide the mask elements of a selected Clipping effect:

1. In the Timeline view, select the Clipping effect.

2. From the Timeline view’s contextual  menu, select
Display > Hide Effect Parameters. 
You can also select View > Effects > Hide Effect Parameters from the top menu.

To hide the mask elements of all Clipping effects:

1. From the Timeline view’s contextual  menu, select
Display > Hide All Effects Parameters. 
You can also select View > Effects > Hide All Effects Parameters from the top menu.

Once you chose to hide the effect parameters, you can easily display them again.

To show the hidden mask elements of a selected Clipping effect:

1. In the Timeline view, select the Clipping effect whose mask elements are hidden.

2. From the Timeline view’s contextual  menu, select 
Display > Show Effect Parameters. 
You can also select View > Effects > Show Effect Parameters from the top menu.
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To show the hidden mask elements of all Clipping effects:

1. From the Timeline view’s contextual  menu, select
Display > Show All Effects Parameters. 
You can also select View > Effects > Show All Effects Parameters from the top menu.
407



Toon Boom Studio User Guide
Feather Edge Effect 

If you have a drawing of something such as the sun or a flame, you may want to soften or blur the edges. Toon Boom 
Studio has a Feather Edge effect that you can use for this. This effect is not done in the Timeline view; rather a 
transformation is applied directly onto your drawing. If you decide to add feather edges to your drawing, it will most 
certainly appear transformed.

The Feather Edge effect is different from the Blur effect. A Blur effect transforms your image into a bitmap image. The 
Feather Edge effect remains vector-based.
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If you zoom in very close to your drawing, you will see that several rims of different transparency are added around 
your drawing, creating the soft edge illusion.

It is not recommended to apply the Feather Edge effect on an entire animation sequence because it can be heavy to 
handle and export. Apply this effect on single drawings such as the Sun or a cloud.

To create a feather edge:

1. In the Timeline view, select the cell containing the drawing on which you want to apply a feather edge on.

2. In the Drawing Tools toolbar, select the Select  tool.

3. In the Camera or Drawing view, select the drawing area you want to apply a feather edge on.

4. In the top menu, select Tools > Feather Edges.

The Feather Edges dialog box opens.

5. In the Width of Each Step field, indicate how wide each rim around the drawing edge should be.
6. In the Number of Steps field, indicate how many rims you want around the edge of your drawing.
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7. Click on the OK button.

Drop Shadow Effect 

To really improve the look of your scene, you can use the Drop Shadow effect. It is easy and efficient to use. If you 
have a light source such as the sun or a lamp in a scene, use the Drop Shadow effect to give a more convincing look 
to your scene. The shadow you create will follow your animation, even if you do some modifications afterward.

To create a Drop Shadow effect:

1. In the Special Effects toolbar, click on the Drop Shadow effect  button.
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You can also add the Drop Shadow effect from the Timeline toolbar.

 In the Timeline view, click on the Add Element  button.
 The New Elements dialog box opens.
 In the Type drop-down menu, select the Drop Shadow Effect layer.
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 In the Name field, rename the effect appropriately.

 Click on the OK button.
2. Drag the selected layer ONTO the Drop Shadow layer.

The shadow appears in the Camera view.

3. In the Timeline view, select the Drop Shadow effect.
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4. In the Camera view, click on the shadow’s anchor points and position the drop shadow properly.

5. In the Properties view, double-click on the Colour swatch to adjust the shadow colour.

6. In the Properties view, move the Opacity slider left or right to adjust the shadow’s transparency.

Move Scale

Skew
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7. In the Properties view, enable the Hide Elements option if you want to temporarily hide the original drawing 
while you reposition its shadow.

8. In the Properties view, click on the Reset Position button if you want to cancel any position modifications you did 
to the shadow.
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Colour Transform Effect 

If you animate a sunrise, a distant object moving closer to the camera or something appearing and disappearing etc., 
you can use the Colour Transform effect to animate a colour or transparency change.

With the Colour Transform effect, you can change the overall colour or transparency of an element and set keys on 
different frames. Toon Boom Studio will animate the colour change between these frames. This way, while the sun 
rises, you can change the colour of the sky from apple green to azure blue, or change a ghost transparency level from 
fully transparent to completely opaque.

To create a Colour Transform effect:

1. In the Special Effects tool bar, click on the Colour Transform  button.

You can also add the Colour Transform effect from the Timeline toolbar.

 In the Timeline view, click on the Add Element  button.
 The New Elements dialog box opens.
 In the Type drop-down menu, select the Colour Transform Effect layer.

 In the Name field, rename the effect appropriately.

 Click on the OK button.

A new Colour Transform layer appears in the Timeline view. By default, the effect has a 20 frame  transition with 
two keyframes, one at the beginning and one at the end. No values are entered in these keyframes.
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2. In the Timeline view, select the layers you want to apply the colour transformation on and drag them ONTO the 
Colour Transformation layer.

3. If you do not want the colour transformation to start at the first frame, you can select the transition cells and 
drag them to the starting frame you want.

4. If you want the transition to be shorter or longer, select the end of the transition, wait until you get the double 
arrow cursor and pull or push on it.

5. In the Timeline view, go to the frame containing your transition first keyframe and select the Colour Transform 
layer.

6. In the Properties view, adjust the colour parameters either using the Additive or the Multiplicative settings. You 
can adjust the red (R), green (G), blue (B) and alpha (transparency) parameters.
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 The more you increase the Multiplicative values, the more washed-out your colours will be. The more you 
decrease it, the darker your colours will be.

 The more you increase the Additive values, the more red, green or blue will be mixed in your original 
colours. The more you decrease the Additive values the more red, green or blue will be removed from your 
colours. You can end up with a white, black, red, green, yellow or blue drawing using these parameters.

7. In the Timeline view, go to the last frame of your transition and select the Colour Transform layer.

8. In the Properties view, adjust the colour parameters for your second colour keyframe.
9. If you want to add a new keyframe in your Colour Transformation effect, in the Timeline view, go to the desired 

frame and select the Colour Transform layer.
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10. In the Properties view, click on the Add Keyframe  button.

 You can use the Delete Keyframe  button to remove a keyframe you may have added earlier. Note that 
you cannot delete the first and last keyframe.

In the Properties view, adjust the colour parameters.
11. If you are creating your own custom drop shadow effect or any other effect involving transparency and several 

drawing layers, you may want to flatten the final result.
12. Because the shapes become semi-transparent, the zone becomes darker when two drawings overlap.

 In the Properties view, enable the Flatten option to get a uniform result.
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13. Play back your scene to see the final result.
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Blur Effect

If you are animating an image that is visible from a great distance, or through adverse weather conditions such as fog, 
you can use the Blur effect to give a soft-focus look to your image. With the Blur effect, you can alter the overall 
blurriness of an element and then set keyframes to animate the blurriness over time. In this way, you can both increase 
and decrease the level of blurriness throughout the animation.

To create a Blur effect:

1. In the Special Effects toolbar, click on the Blur effect  button.
2. In the Timeline view, select the drawing layer that you would like to attach to the Blur effect and drag it onto the 

Blur effect layer.

3. Double-click on your Blur effect layer to rename it in accordance with the Drawing layer that is attached to it. 
This is good practice, as you may want to add more than one Blur effect to your Timeline. You may want to add 
more than one Blur effect because as the camera approaches different elements, those elements in front will 
come into focus before those farther back. In order to create different timing sequences, you need multiple 
versions of the same effect.

4. If you do not want the Blur effect to start at the first frame, you can select the effect‘s cells and drag them to the 
starting frame that you prefer.

You can also right-click anywhere on the effect’s cells and select Change Start Frame from the pop-up menu.

Enter the start frame that you would like into the Enter the New Start Frame field and click OK. The entire row of 
effect cells will be shifted down the Timeline.
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5. If you want the transition to be shorter or longer, select the end of the group of frames, wait until you get the 
double arrow cursor and then pull towards the left or right.

You can also right-click anywhere on the effect’s cells and select Change Duration from the pop-up menu.

Enter the duration that you would like the effect to last for in the Enter the New Duration field and click OK. The 
exposure of the effect will be extended or shortened depending on the value entered.

6. In the Timeline view, drag the red playhead to the frame on your effect layer where you would like to add a 
keyframe.

In the Tool Properties panel for the Blur effect, click on the Add Keyframe  button.

A new keyframe is added to the chosen location.
7. In the Timeline view, drag the red playhead to a frame on your effect layer where you would like to delete a 

keyframe.

In the Tool Properties panel for the Blur effect, click on the Delete Keyframe  button.

The keyframe is deleted from the chosen location.
8. In the Timeline view, go to the frame containing your first keyframe and select the Blur effect layer.

9. In the Properties view, move the Radius slider to increase or decrease the Blur Radius, or simply enter a value 
directly into the field. You can enter decimal increments for more precision.
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10. Uncheck the Radial check box if you want to create a Motion Blur. The Angle slider will automatically become 
active. You can still modify the blur intensity with the Radius slider and the angle of the blur with the Angle slider.

Choose a large Radius value, such as 200. You can enter different radius values for the start and end keyframes 
of your effect to see the blur trail either increase or decrease in length. You can also enter a different Angle value 
for the start and end keyframes to have the direction of the Motion Blur rotate around the object. Obviously, the 
Motion Blur will look more natural if you apply this effect to a moving object.

It is important to play with and animate the effect to ensure a convincing result. For example, in this example, the 
school of fish flip abruptly and start swimming upwards in the opposite direction. Now the 30 degree angle no 
longer looks good. It would be better to key a new angle at the point of the flip in the Timeline. Also, as the fish 
slow down before the flip, their motion blur would inevitably shorten, then lengthen again when they speed up. 

 
A trick that you could do is to create a solid version of your object over a blurred version. You can achieve this 
effect by duplicating the original object. If the object contains multiple drawings and keyframes, then you could 

Radius = 200, Angle = 0 Radius = 200, Angle = 30

0° 0°

30°
90°
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create a template of it in the Library first. Be sure that the timing is aligned in the Timeline, as templates often 
start at frame 0. Add a Motion Blur to the version lower in the Timeline layer stack.

 NOTE: The only way to preview the Blur effect is to export a render of your scene. To minimize render 
time, export only the frames that contain the effect and not the entire scene. For more information on rendering, 
please refer to Export Movie, on page 441.
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Shake Effect

With the Shake effect, an animated drawing or static element, such as a character or landscape, can be made to shake. 
This effect can be used to imitate earthquakes, camera shakes, or a character who is freezing on a cold winter day.

In the image above, the hula girl and air freshener were animated in the cut-out style because their shaking involves 
rotating from a pivot. However, the entire car, including the dashboard, windshield, hula girl and air freshener, all shake 
up and down and side to side together, due to the bumps on the road.

To create a Shake effect:

1. In the Effects toolbar, click on the Shake  effect button.
2. In the Timeline view, select the Drawing or Peg layer that you would like to attach to the Shake effect and drag 

it onto the Shake effect layer.

3. Double-click on your Shake effect layer to rename in accordance with the Drawing or Peg layer that is attached 
to it. This is good practice, as you may want to add more than one Shake effect to your Timeline. You may want 
to add more than one Shake effect in order to have a shake occur on the x-axis and another on the y-axis. In 
order to create different timing sequences, you need multiple versions of the same effect.

4. If you do not want the Shake effect to start at the first frame, you can select the effect‘s cells and drag them to 
the starting frame that you prefer.

You can also right-click anywhere on the effect’s cells and select Change Start Frame from the pop-up menu.

Enter the start frame that you would like into the Enter the New Start Frame field and click OK. The entire row 
of effect cells will be shifted down the Timeline.
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5. If you want the transition to be shorter or longer, select the end of the group of frames, wait until you get the 
double arrow cursor and then pull towards the left or right.

You can also right-click anywhere on the effect’s cells and select Change Duration from the pop-up menu.

Enter the duration that you would like the effect to last for in the Enter the New Duration field and click OK. The 
exposure of the effect will be extended or shortened depending on the value entered.

6. In the Timeline view, drag the red playhead to a frame on your effect layer where you would like to add a 
keyframe.

In the Tool Properties panel for the Shake effect, in the Dynamic Parameters tab, click on the Add Keyframe  
button.

A new keyframe is added to the chosen location.
7. In the Timeline view, drag the red playhead to a frame on your effect layer where you would like to delete a 

keyframe.

In the Tool Properties panel for the Shake effect, in the Dynamic Parameters tab, click on the Delete Keyframe 

 button.

The keyframe is deleted from the chosen location.
8. In the Timeline view, go to the frame containing your first keyframe and select the Shake effect layer.
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9. In the Properties view, adjust some of the following parameters, according to your preferences.

 Shake effect icon (drop-down menu)
 Mini Shake: Default Amplitude of 0.1
 Great Earthquake: Default Amplitude of 2

 Static Parameters
 Axis: Decide whether you would like your object to shake from left to right (X), up and down (Y) or 

forward and backward (Z). You can parent an x-axis Shake effect, along with its Drawing/Peg layer, to 
another Shake effect whose Axis is set to Y. This way, your object can shake from both side to side and 
up and down.

 Wave Time: This indicates the length of a cycle. The smaller the number is, the shakier the effect will 
be, as the effect needs to reach a certain amplitude in a smaller time frame, but could reach this 
amplitude more often as its cycle length is so short.

 Half Life: This refers to the number of frames for the movement to be half its amplitude. If you enter a 
value of 0 for the half-life, the amplitude will be cut to half right away and the shake will be less intense. 
If you want to keep the full intensity of the shake for the complete duration of the effect, make the half-
life the duration of the Shake effect, that way, the amplitude drops to half when the effect is finished. If 
you want the shake to gradually taper off, then make the half-life smaller than half the duration (in 
number of frames) that your shake effect lasts in the Timeline. For example, if your Shake effect lasts for 
30 frames, make the half-life less than 15 frames.

 Dynamic Parameters
 Amplitude: The maximum displacement from a zero value during one shake cycle. This value is 

measured in fields.

 You can always turn on the 12 x 12 field grid  to gain a better understanding of the system of 
measurement. Remember that the grid is only visible in the Camera view if both a Drawing layer and a 
Drawing tool is selected.

Shake Effect icon

Static Parameters

Dynamic Parameters
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Forces of Nature Effects
Effects that are the result of natural phenomenon can be among the hardest things to create in an animation, as they 
involve drawing and animating hundreds of tiny particles or fluctuating organic shapes. Toon Boom Studio helps you 
bypass this labour-intensive process by providing six Forces of Nature Effects.

• Rain Effect, on page 432
• Snow Effect, on page 433
• Hail Effect, on page 434
• Fog Effect, on page 435
• Cloud Effect, on page 436
• Volcano Effect, on page 437

To add a Forces of Nature effect:

1. In the Special Effect toolbar, click on the Forces of Nature effect  button.

A Forces of Nature effect layer, as well as its child, a Sprite-Drawing layer, is added to the Timeline view. A Sprite 
is the particle multiplied and generated by the Forces of Nature effect. In the example below, a drawing of a 
raindrop is being used as the Sprite.

By default, the Rain effect is selected and visible in the Camera view.

2. Create your own Sprite on a Drawing layer, or import an image to use as a Sprite. In the case of the Forces of 
Nature effects, Sprites animated using keyframes and/or pegs will lose their animation. Only the original image 
will be used. 

Traditionally animated drawings will be treated as multiple versions of the same particle type. For example, a 
traditionally drawn walk cycle appears as a series of frames on the same layer. Each frame contains a slightly 
modified version of a character’s legs and arms moving. If this layer were to be used as a Sprite, all those 
different drawings would be randomized and appear as non-sequential, static, singular particles in the effect.

You can use this behaviour to your advantage; for example, in the event that you want to create five types of 
snowflakes to be multiplied and generated. Simply create five different drawings on the same layer, but drawing 
each on their own frame.

This part will
be ignored

Only the drawing
will be used
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3. Drag your newly created Sprite layer onto the Sprite-Drawings layer to parent it. The Forces of Nature effect 
Sprite (unseen in the Timeline view) is automatically overridden by your custom Sprite.

If no Sprite is created for a Forces of Nature effect, the default Sprite will be visible.

Customizing Your Forces of Nature Effect
In order to customize and animate your Forces of Nature effect, you have to adjust the parameters in the Properties 
panel. Use the Static Parameters to customize the general settings for the effect. Any frame of the effect layer can be 
selected in the Timeline view when modifying values in this tab. If you want to animate the properties of the effect, 
add keyframes accordingly, then change the keyframe values in the Dynamic Parameters tab.

Forces of Nature Effects
From the top row of icons, click on the button corresponding to the Forces of Nature effect that you wish to use. It 
will turn dark grey to indicate that it is selected. If you are unsure as to which Forces of Nature effect is depicted on a 
given button, use your mouse to hover over the button in order to make its name appear in the tool tip.

The Forces of Nature effect will change in the Camera view depending on which effect you choose. Click on the effect 
you wish to use; the corresponding sub-menu appears, featuring the various effect options that fall under that 
particular Forces of Nature effect. 
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In the above example, Cloud is the general option that has been selected. Every effect has a sub-menu featuring 
numerous options, ones that vary in density, shape and character. To determine what each effect does, hover your 
mouse over the effect icon. The tool tip appears, indicating the name of this particular effect. To activate the effect, 
click on the icon. A dark grey box surrounds the icon, indicating that it is activated. 

 The six different Nature effects are discussed in more detail in their own individual sections below.

General Forces of Nature Properties Buttons

 Reset to Default Values: After you have made adjustments to the parameters in either the Static or Dynamic 
Parameters tab, click on this button to reset the default values in both tabs.

 Add Fill: Use this button to divide a Forces of Nature effect in the Timeline. Once divided, a different Forces 
of Nature effect can be applied to one of the two halves. Fundamentally, this allows for two different effects to 
exist on the same layer in the Timeline.

 Delete Fill: Use this button to delete all the cells of a single Forces of Nature effect, in a layer where multiple 
effects exist.

Static Parameters Tab

• Background: Use the drop-down to choose from one of three background colour options: Dark Gradient 
Blue Sky, Light Gradient Blue Sky, or Transparent. 

• Start of Simulation: The frame number of where you would like the generation of particles to start. If you 
would like the effect to be in progress beginning at the start of your scene, keep the default value of -1. This 
number is relative to the First Frame value.

• First Frame: The frame number where you would like the effect to start. You could have your effect start on 
frame 20, but not have the particle generation start until four frames in.

• Duration: The number of frames that you would like the effect to last.
• Max Amount of Objects: The maximum number of particles (copy of the sprite) that can be generated at 

one time in the Camera view. These particles are not all created at the same time, but will eventually fill the 
Camera view with their number. For example, if a value of 2 is entered, then only two particles will be 
generated until they disappear from the Camera view (finish their lifespan). At that time, another two or less 
particles can be generated to replace the two that disappeared from view.

• Max Visibility: The maximum number of frames that a particle will exist for in the Camera view, otherwise 
known as the particle life span. For example, even if the Max Amount of Objects is set to 3000, if the Max 
Visibility is set to 10, then most particles with disappear before anywhere near 3000 particles can be 
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created. In addition, if it takes 60 frames for a particle to fall from sky to ground, then most of these 
particles will never touch the ground, as they will “die” or disappear before the 10th frame.

• Fade: Check this box if you would like the particles to slowly fade-out as they reach the end of their life 
span instead of disappearing abruptly.

• Region: Think of the region where the particles are generated, live and die as a 3D cube. User the sliders to 
select a value between 0-36 for the Width, Height and Depth of this 3D region. Although you cannot see 
the depth of the region, you may notice that some particles appear larger or smaller than others, even 
though they are all generated from the same sprite. This is because some are closer or further back in 
depth.

• Floor Height: The value in this field represents the height of an invisible floor. This floor is where the 
simulation ends. With the example of snow, if you would like to see snow hitting and covering the ground, 
you would raise the height of the floor to be visible in the Camera view.

Dynamic Parameters Tab
The parameters in this tab only become active when a frame with a keyframe is selected in the Timeline view.

• Intensity: This value determines the strength of the simulation. For example, if the first keyframe has an 
Intensity of 1 and the second keyframe has an Intensity of 25, then only a few particles will be produced at 
the start of the animation, producing progressively more and more.

• Scale: This value determines the size of the particles as a percentage. For example, a value of 1.5 would be 
1.5 times the size of the original particle or Sprite. Remember that all the particles are the same size; it is 
just that some are further back or closer in space.

• Bounciness: This value determines the height of a particle’s bounce, or in other words, how bouncy the 
particle is. The greater the value, the higher the bounce, hence the more bouncy the particle. This 
parameter is important for the Hail effect. 

• Min Speed: The minimum speed at which the particles can move.
• Max Speed: The maximum speed at which the particles can move.
• Direction: These parameters can be used to push the particle movement at an angle, giving the illusion that 

they are being blown in a certain direction by the wind. Use the sliders in this section to manipulate the 
following:

 East-West: direction along the x-axis

 North-South: direction along the y-axis

 Back-Front: direction along the z-axis
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• You can use both positive and negative values, as well as decimal increments. Add Keframe : Use this 
button to add a keyframe on the Forces of Nature layer in the Timeline view. The keyframe will be added to 
whichever frame is selected in the Timeline view, indicated by the position of the red playhead. Once the 
keyframe is created, modify the values in the Dynamic Parameters tab to have those parameters recorded in 
the keyframe.

• Delete Keyframe : Use this button to delete a selected keyframe from the Forces of Nature layer in the 
Timeline view.

Moving an Effect in the Camera View
In order to move an effect in the camera or to give an effect a trajectory, you must attach a peg layer to it. Refer to 
the following chapter to learn more about moving an effect:

• Scene Setup - Creating a Motion Path, on page 366
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Rain Effect

The Rain effect produces a simulation of water droplets falling from the sky in nine various presets:

• Rain - this is the default setting
• Tropical Storm - the rain drops are bigger and greater in number, thereby producing a more intense effect
• Mist - the rain drops are smaller and fewer, thereby producing a less intense effect
• Straight - the rain falls on a diagonal, suggesting a driving rain shower
• Bubble - the rain falls in large, rounded drops of water
• Droplets - the rain falls in droplets of water
• Gummy Bears - a sweet shower of red and yellow gummy bears
• Rays - sun rays caught by particles of light illuminate your scene
• Stars - your scene is showered by stars, both near and far

Parameters such as Bounciness and Floor Height are less applicable to this effect. However, Max Amount of Objects 
and Direction are good parameters to modify and animate for the Rain effect.
432 



Chapter 15: Enhancing With Effects   
Snow Effect

The Snow effect produces a simulation of snowflakes falling from the sky in ten various presets:

• Snow - this is the default setting
• Snow Flurries - fewer snowflakes produced than with snow, therefore creating a less intense effect
• Snow Storm - the snowflakes are bigger, falling faster and are greater in number, thereby creating a more 

intense effect
• Simple Snowflakes - these are soft, light “paper cut-out” snowflakes
• Shiny Snowflakes - large, shiny snowflakes, great for an icy winter scene
• Sun Dust - soft snow raised by a gust of wind and lit by a bright winter’s sun
• Ashes - light ashes fall, gently filling your scene
• Leaves - brown, last-to-fall autumn leaves float gently downwards
• Cotton Candy - fluffy pink cotton candy for a sweet, playful scene
• Dandelion Puffs - fluffy dandelions, ideal for lazy summer scenes and making wishes

In the case of the Snow Effect, the Floor Height can play a role as snow can land and accumulate on the ground. While 
Bounciness does little to change this effect, as it is not a natural property of snow, the Intensity and Min Speed can 
make the difference between Snow Flurries and a Snow Storm. If you are looking to produce an effect where the snow 
melts before it hits the ground, you can lower the Floor Height so that it is not visible in the Camera, as well as check 
off the Fade box to have your snowflakes lightly melt away.
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Hail Effect

The Hail effect produces a simulation of ice pellets falling from the sky in nine various presets:

• Hail - this is the default setting
• Light Hail - there are fewer ice pellets produced, thereby creating a less intense effect
• Hail Storm - the ice pellets are bigger, falling faster and in greater in number, thereby creating a more 

intense effect
• Crystallized Hail - sparse, gentle flecks of crystal fall steadily throughout your scene
• Baseball Hail - heavy, large, quick-falling hailstones, to be avoided by all windshields
• Diamonds - a different kind of ice, these yellow, pink and blue diamonds fall hard and fast
• Candy - colourful bonbons populate your scene to create a candyland effect
• Coins - bright pennies (and more) from heaven enrich your scene with a little fun
• Gears - rust, gold and grey gears tumble from top to bottom; great for gear heads

In the case of the Hail Effect, the Floor Height and Bounciness play a big role in identifying the effect, as ice pellets 
bounce when they hit a surface or ground. Subtle differences in the Dynamic Parameters values determine the 
difference between a Light Hail and a Hail Storm, as well as the Max Amount of Objects and Max Visibility values.
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Fog Effect

The Fog effect produces a simulation of a gaseous vapour hanging in the air in nine various presets:

• Fog - this is the default setting
• Misty - there are fewer particles produced in a smaller region, thereby creating a less intense effect
• Thick Fog - There are a greater number of particles in a larger region, thereby creating a more intense effect
• Curly Fog - a cluster of fog tendrils floats and expands to cover the majority of your scene
• Smokey Fog - a dark fog that expands ominously across your scene
• Sumi-e Fog - in various shades of grey, this fog has a classic Japanese ink wash sensibility
• Balloons - red, yellow and blue balloons radiate, then float, from the center of your scene
• Fireflies - growing green fireflies evoke a balmy summer evening
• Bushes - a row of lush bushes rises, gently expanding and rustling, from the bottom of the screen

The Region dimensions, including the Floor Height, plays a role in the intensity of this effect. The smaller the region, 
the less intense the effect, as we are able to see some sky in the background. The Max Amount of Objects contributes 
to the fog’s density, which can also make it more, or less intense. It is recommended that you really explore the 
parameters for this effect, as they are a little less obvious than for the other effects.
435



Toon Boom Studio User Guide
Cloud Effect

The Cloud effect produces a simulation of a condensed gaseous vapour floating through the sky in nine various 
presets:

• Cloud - this is the default setting
• Fluffy Clouds - there are fewer particles produced, with lower visibility at a slower speed, thereby creating a 

less intense effect
• Storm Clouds - there are a greater number of particles produced, with higher visibility, thereby creating a 

more intense effect
• 2D Puffy Clouds - dense fairweather clouds in various shades of blue
• 2D Stylized Clouds - swirling, curly-Q clouds in shades of blue and cafe au lait
• Shape Clouds - fluffy clouds in the shape of a duck , a dragon and an elephant. Perfect for daydreaming
• Forest - a dense forest of trees and foliage sweeps through your scene
• 2D Storm Clouds - enormous, ominous clouds sweep past, filling your scene from front to back
• Candy Clouds - swirling clouds in shades of candy pink 

The Cloud effect is one of the most complicated Forces of Nature effects, due to the number of parameters that need 
to be adjusted in order to make both subtle and dramatic differences to this effect. Some of the key parameters to 
look out for are Start of Simulation, Max Amount of Objects, Max Visibility (including Fade), as well as Intensity and 
Speed.
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Volcano Effect

The Volcano effect produces a simulation of flowing lava bubbles from a single source in nine various presets:

• Volcano - this is the default setting
• Puff - there are fewer particles produced, with a lower intensity, thereby creating a less intense effect
• Volcano Eruption - there are a greater number of particles produced, with higher intensity, thereby creating 

a more intense effect
• Deformed Lava - lava flows, radiating outward towards the floor of your scene
• Popcorn - popped kernels of corn bubble from the center of your scene
• Petroleum - dark petroleum gushes and oozes outward from the center of your scene
• Fountain - a fountain of water emanates up and out in a wash of blues
• Colour Candy - pink, gold and blue candies spring up and out for a visual sugar rush
• Steam - droplets of steam and wispy vapour rise from the bottom of your scene, emanating outwards

The Volcano effect is a unique effect in that it is the only effect that is produced from a single source. You can move 
the position of the source by changing the value of the Floor Height. The number of particles (Max Amount of 
Objects), as well as the size of the particles (Scale) are important factors. The Start of Simulation value will determine 
whether you see the lava erupt from the source (either 0, or a positive value), or if it will already be flowing when the 
scene starts.
437



Toon Boom Studio User Guide
Disabling All Effects
You can disable all the effects in your scene in order to preview it without them. Doing so will hide all effects from the 
Camera view, but the effects elements will remain visible in the Timeline view.

To disable all effects:

1. Select View > Disable All Effects from the top menu.

Once you have disabled the effects in your scene, you can easily re-enable them.

To enable all effects:

1. Select View > Enable All Effects from the top menu.

 Your project will be exported with the effects visible, regardless if the Disable All Effects option is on.
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What’s Next?
So far, you have learned about:

• Clipping Effect
• Feather Edge Effect
• Drop Shadow Effect
• Colour Transform Effect
• Shake Effect
• Rain Effect
• Snow Effect
• Hail Effect
• Fog Effect
• Cloud Effect
• Volcano Effect

It is now time to learn about exporting your project to a movie or image sequence format.
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Chapter 16  Exporting Your Project

Toon Boom Studio supports several formats for all your rendering needs, it all depends on what you want to do with 
your final output. You could, for instance, create a flip book or produce a video to post directly to the Web or iPod. 

In this chapter, you will learn how to do the following:

• Export Drawing to PDF, on page 442
• Export Movie, on page 443
• Export to YouTube and Facebook, on page 445
• Export Snapshot, on page 450
• Print, on page 451
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Export Drawing to PDF
Exporting one frame of your animation to PDF can be of use if you need a vector-based image from your movie. 

To export a drawing to PDF:

1. Select the frame of your project that you would like to render. It must be from a drawing (vector based) layer and 
not an image (bitmap) layer.

2. From the top menu select File > Export Drawing to PDF.

The Save As dialog box appears.
3. Browse to the location where you would like to save your file.
4. In the File name field, enter a name for your file.
5. Click on the Save button.
6. Browse to the location where you saved your file and double-click on it to view the results. You may also choose 

to open this file in a vector-based, third-party software, such as Adobe Illustrator.
442 



Chapter 16: Exporting Your Project   
Export Movie
The format and settings that you decide upon when wanting to export your animation often depends on what you 
intend to do with it next. Do you plan to bring your project into a third-party software for post-production editing or 
put it up on the web? 

To export your movie:

1. From the top menu select File > Export to Movie.

The Export dialog box appears.

2. In the Save As section, click on the Browse button at the end of the path field and browse for the location where 
you intend to save your rendering.

3. In the Export Format drop-down menu, select the format that you desire. The Export Settings Options will 
change depending on the format selected from this section.

4. Click on the Options button to customize the format settings.
5. In the Export Type section, choose from the following options:
 Full Movie: Renders out all scenes and all layers that are enabled, from the first to last frame, including all 

effects.
 Current Scene: Camera View - renders out all layers that are enabled in that specific scene that can be seen 

in the Camera view with the option to choose a frame range.
 Current Scene: Drawing View - renders only what exists on a single layer in that specific scene. This can be 

a good option for running tests on a specific character or object’s motion, or to bring one animated 
element into a third party software.

6. From the Export Range Section, choose from the following options:
 All - renders out your entire project.
 Frame Range - allows you to select a specific section of your project to render by frame number.
 Selector - renders out whichever layer or element that you selected prior to launching the export process.
 Free Playback Range - in the Timeline view, right-click on the timeline ruler (top) and from the pop-up 

menu select Playback Range > Free. Two black diamonds should appear at the start and finish of your 
project. Drag these markers to select the range that you desire. 

7. Check or uncheck the Launch Player After Export option.
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8. Click on the Publishing Options button.

The Publishing dialog box appears.

9. From the Publishing dialog box, select the option to Export to HTML if your project is destined for the web and/
or if you would like to send a copy to your iTunes Library.

10. When you are finished, click OK.
11. In the Export dialog box, when you are through, click OK.

A progress bar appears.

12. Browse to the location on your computer where you saved your movie and double-click on the file to view your 
export.
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Export to YouTube and Facebook

Toon Boom Studio simplifies the upload of your animated projects to these two popular websites: YouTube and 
Facebook. Using the Export Movie command, you can choose an option to export your movie directly to one of these 
sites. Toon Boom Studio will then automatically redirect you to your YouTube or Facebook profile where your video 
will automatically be uploaded. 

NOTE: You require an active account on YouTube or Facebook before you can upload your videos.

Exporting to YouTube
To be able to export your movie to YouTube, you will first need to have a YouTube account. If you do not already have 
one, you can go to www.youtube.com to create your own.

To export your movie to your YouTube account: 

1. From the top menu select File > Export to Movie.

The Export dialog box appears.

2. In the Save As section, click on the Browse button at the end of the path field and browse for the location where 
your render will be saved.

3. In the Export Format drop-down menu, select YouTube. Doing so will grey out certain options.

4. In the Export Type section, choose from the following options:
 Full Movie - Renders out all scenes and all layers that are enabled, from the first to last frame, including all 

effects.
 Current Scene: Camera View - Renders out all layers that are enabled in that specific scene that can be 

seen in the Camera view with the option to choose a frame range.
 Current Scene: Drawing View - Renders only what exists on a single layer in that specific scene.
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5. From the Export Range Section, choose from the following options:
 All - Renders out your entire project.
 Frame Range - Allows you to select a specific section of your project to render by frame number.
 Selector - Renders out whichever layer or element that you selected prior to launching the export process.
 Free Playback Range - In the Timeline view, right-click on the timeline ruler (top) and from the pop-up 

menu select Playback Range > Free. Two black diamonds should appear at the start and finish of your 
project. Drag these markers to select the range that you desire. 

6. When you are finished, click OK.

A progress bar appears, showing you the rendering process, followed by the YouTube upload information 
dialog box.

7. Fill in the information.
• General Information

The informations that will appear on your YouTube account.
 Title: Type in the name of your video
 Category: Use the drop-down menu to select the category that best fits your video.
 Description: Type in a description of your video.

• Login Information
Fill in this information to automatically login to your YouTube account.
 Login: Type in your YouTube account username.
 Password: Type in your YouTube account password.

8. Click on the OK button.

A progress bar appears, showing you the uploading process, followed by a dialog box notifying you that your 
video has been successfully uploaded.

9. Click on the OK button.
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Exporting to Facebook
To export your movie to Facebook, you will first need to have a Facebook profile. If you do not already have one, go 
to www.facebook.com to create your own. Once it is done, you can now start to upload your creations to your profile 
to share with your friends on Facebook.

To export your movie to your Facebook profile: 

1. From the top menu select File > Export to Movie.

The Export dialog box appears.

2. In the Save As section, click on the Browse button at the end of the path field and browse for the location where 
your render will be saved.

3. In the Export Format drop-down menu, select Facebook. Doing so will grey out certain options.

4. In the Export Type section, choose from the following options:
 Full Movie - Renders out all scenes and all layers that are enabled, from the first to last frame, including all 

effects.
 Current Scene: Camera View - Renders out all layers that are enabled in that specific scene that can be 

seen in the Camera view with the option to choose a frame range.
 Current Scene: Drawing View - Renders only what exists on a single layer in that specific scene.

5. From the Export Range Section, choose from the following options:
 All - Renders out your entire project.
 Frame Range - Allows you to select a specific section of your project to render by frame number.
 Selector - Renders out whichever layer or element that you selected prior to launching the export process.
 Free Playback Range - In the Timeline view, right-click on the timeline ruler (top) and from the pop-up 

menu select Playback Range > Free. Two black diamonds should appear at the start and finish of your 
project. Drag these markers to select the range that you desire. 

6. When you are finished, click OK.

A progress bar appears, showing you the rendering process, followed by the Facebook upload information 
dialog box.
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7. Fill in the information that will appear on your Facebook account.
• Title: Type in the name of your video
• Description: Type in a description of your video.

8. Click on the OK button.

The Facebook wizard dialog box opens and your internet browser is launched and automatically directed on 
the Facebook login page.

9. In your internet browser, log in to your Facebook account.
NOTE: Although you are not on the Facebook website you are now logged in to Facebook. To logout you will 
need to go onto your account on the Facebook website.

10. In the Facebook wizard, click on the Next button.

The Facebook wizard checks for permissions.

11. The first time you go through these steps, when the Facebook wizard will ask for permissions, the internet 
browser will automatically be directed to the Facebook confirmation page, where you will need to give your 
authorization. 
The next time you will export a video to your Facebook account, the wizard will automatically continue to 
upload the video to your account.

• In the Internet browser, click on the Allow Video Uploads button.
The Facebook page notifies you that the permissions have been saved.

• In the Facebook wizard dialog box, click on the Next button.
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The wizard finishes the upload and a dialog box opens notifying you that your video has been successfully 
uploaded

12. Click on the OK button.
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Export Snapshot
Sometimes you might find that you would like to digitally save one specific shot of your animation, perhaps rough 
sketches for your workflow or a polished scene for promotional purposes. The best way to produce this render is by 
exporting a snapshot. 

To export a snapshot:

1. In the Timeline view, select the location in your animation where you are able to frame the image that you would 
like to render perfectly in the Camera view.

2. From the top menu, select File > Export Snapshot.

The Snapshot dialog box appears.

3. From the Snapshot dialog box, browse to the location on your computer where you would like to save your work 
and rename your image accordingly.

4. Click on the Save button.
5. In the Snapshot dialog box, click on the Options button.

The Export Image Sequence Settings dialog box appears.

 

This is the same dialog box that would appear if you were rendering an Image Sequence through the Export 
Movie process, however only the format option applies in this case as you are only rendering one image.

6. From the Format drop-down menu, select the format type.
7. Click OK.
8. Browse to the location on your computer where you saved your snapshot and double-click to view it.
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Print
Although there are many reasons why you might want to print out part or all or your finished or unfinished animation, 
such as for a model sheet or storyboarding, a fun project you could make with this feature is a flip book. 

To print a flip book or a from your project: 

1. From the top menu, select File > Print.

The Printing dialog box appears.

2. From the Printer section, look through the Name list to select a printer which is connected to your computer.
3. Click on the Page Setup button.

The Page Setup dialog box appears.

4. Customize your page setup and then click on the OK button.
5. In the Printer section, if you want to print your file digitally and have it saved somewhere on your computer, 

select the Print to File option and browse to the location where you would like to save this file on your computer. 
Select the As PDF if you so desire.

As you want to print a flip book, do not select this section.
6. In the Copies section, select the number of copies of each individual page from the drop-down. For example, if 

you chose the number two, the printer will print two copies of page 1, two copies of page 2, etc.

2
3

5

6
7

8 9

11
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7. In the Layout section, decide how many frames you would like per page. Selecting the Flip book option will 
automatically place either 6 to 8 frames per page and leave a margin for binding purposes.
Once the images will be printed, you will have to cut your images to create your flip book. If you put only one 
image per page, it will be difficult to quickly flip through the drawings as the pages will be too big to handle. 
Smaller sheets are much easier to flip.

8. In the Export Type section, decide on one of the following options:
 Full Movie - by default prints the entire frame range of your project, including all scenes and all enabled 

layers. 
 Current Scene: Camera View - prints all elements, from all enabled layers, for a specific scene, including all 

transformations visible in the Camera view and allows for the selection of a frame range.
 Current Scene: Drawing View - prints all elements on a selected layer visible through the Drawing view, as 

well as other layers visible with the aid of the Light Table tool.
 Selected Level: Drawing View - prints all elements on only one selected layer and offers the option of 

printing individual drawings only.
9. In the Export Range section, decide on one of the following options:
 All - renders out your entire project.
 Frame Range - allows you to select a specific section of your project to render by frame number.
 Selector - renders out whichever layer or element that you selected prior to launching the printing process.
 Free Playback Range - in the Timeline view, right-click on the timeline ruler (top) and from the pop-up 

menu select Playback Range > Free. Two black diamonds should appear at the start and finish of your 
project. Drag these markers to select the range that you desire. 

10. In the same section, decide on one, both or none of the following options:
 Keyframes only - prints out drawings on a frame with a keyframe in the Timeline view.
 Individual drawings only - prints out the first instance of a drawing. For example, if a drawing on a cell or 

frame is extended for 10 exposures in either the Xsheet or Timeline view, these extended exposures will not 
be printed. In other words, you will receive only one printout of this drawing instead of ten. 

11. From the Decoration section, decide whether or not you would like to select the Print Camera Frame option.
12. Click on the OK button.

You now have a frame-by-frame printed copy of your animation that is ready to be cut and bound into a flip book.
452 



C DKSC101TBS70EN  1

  

K
+” sign, is not part of the sequence.

CUSTOM
C

N

N

N

N

P

P

P

P

S

CUSTOM
C

C

C

D

D

P

P

P

P

R

S

U

CUSTOM
A

A

D

E

I

N

P

R

R

opyright © 2012 by Toon Boom Animation Inc. All rights reserved.  

 

eyboard Shortcuts for Toon Boom Studio 7.1
This document lists the default keyboard shortcuts for Toon Boom Studio 7.1. To use a shortcut, press the key(s) and the character simultaneously. The “

NOTE: Commands without shortcuts are left blank in these tables
NOTE: The Custom column is provided so you may write down the shortcuts which you customize.

In Toon Boom Studio you can create your own keyboard shortcuts. 
To assign your own keyboard shortcuts, select Edit > Preferences > Shortcuts from (Windows) or Toon Boom Studio (Mac OS X).

COMMAND WINDOWS MAC OS X
entre on Mouse N N

ext Drawing Shift+S Shift+S

ext Element F F

ext Element in X-Sheet Shift+F Shift+F

ext Frame S S

revious Drawing Shift+A Shift+A

revious Element D D

revious Element in X-Sheet Shift+D Shift+D

revious Frame A A

elect Skeleton Root Y Y

EDIT MENU
COMMAND WINDOWS MAC OS X
opy Ctrl+C Command+C

ut Ctrl+X Command+X

ut Special Ctrl+Shift+X Command+Shift+X

elete Delete Delete

eselect All Ctrl+Shift+A Command+Shift+A

aste Ctrl+V Command+V

aste New Object Ctrl+Shift+V Command+O

aste Special Ctrl+B Command+S

aste Special Again Ctrl+Shift+B Command+Shift+B

edo Ctrl+Shift+Z Command+Shift+Z

elect All Ctrl+A Command+A

ndo Ctrl+Z Command+Z

ELEMENT MENU
COMMAND WINDOWS MAC OS X
dd Exposure R R

dd Keyframe I I

elete Blank Cell Shift+E Shift+E

xtend Exposure Ctrl+Shfit+1 Command+Shift+1

nsert Blank Cells Shift+R Shift+R

ext Motion Point . .

revious Motion Point , ,

emove Exposure E E

emove Keyframe Ctrl+R Command+R
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et Exposure Ctrl+4 Command+4

et Exposure to 1 Ctrl+1 Command+1

et Exposure to 2 Ctrl+2 Command+2

et Exposure to 3 Ctrl+3 Command+3

FILE MENU
COMMAND WINDOWS MAC OS X
lose Ctrl+W

xit Ctrl+Q

ew Ctrl+N Command+N

pen Ctrl+O Command+O

ave Ctrl+S Command+S

ave As Ctrl+Shift+S Command+Shift+S

rint Ctrl+P Command+P

HELP MENU
COMMAND WINDOWS MAC OS X
oon Boom Studio Help F1 Shift+Command+? 

hat’s This? Help Shift+F1 Shift+Option+? 

LIBRARY MENU
COMMAND WINDOWS MAC OS X
efresh F5 F5

PLAY MENU
COMMAND WINDOWS MAC OS X
lay P P

review Exposure Sheet Ctrl+Alt+Enter Command+Option+Return

review Exposure Sheet Selection Shift+Enter Shift+Return 

review Movie Ctrl+Shift+Enter Shift+Command+Return 

review Scene Ctrl+Enter Command+Return

uick Preview Enter Return

TOOLS MENU
COMMAND WINDOWS MAC OS X
one Creator Tool U U

one Manipulator H H

one Setup Tool J J

rush Shift+2 Shift+2

ycle Brush Tools 2 2

ycle Eraser Tools 4 4

ycle Paint Tools 3 3

ycle Rotate Tools 8 8

ycle Select Tools 1 1

ycle Zoom Tools 5 5

ELEMENT MENU
COMMAND WINDOWS MAC OS X
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ropper (when Brush, Paint or Pencil tool is selected) Alt Option

raser Shift+4 Shift+4

rabber Shift+6 Shift+6

roup Selection Ctrl+G Command+G

otion 0 (zero) 0 (zero)

udge Backwards (when Transform tool is selected) Alt+ Option+

udge Forwards (when Transform tool is selected) Alt+ Option+
aint Shift+3 Shift+3

aint Multiple Drawings Shift+Alt Shift+Option

eg-Only Mode M M

cale 9 9

elect Drawing Objects Shift+1 Shift+1

elect Elements 6 6

tart New Bone Chain (when Bone Creator Tool is selected) Shift Shift

ext T T

ransform 7 7

ngroup Selection Ctrl+Shift+G Command+Shift+G

oom Shift+S Shift+S

VIEW MENU
COMMAND WINDOWS MAC OS X
oggle Floating Windows Visibility Tab Tab

rid Display Toggle G G

o Next Drawings Shift+W Shift+W

o Previous Drawings Shift+Q Shift+Q

nion Skin Next Drawing Cycle W W

nion Skin Previous Drawing Cycle Q Q

ecentre Shift+Space Shift+Space

eset Rotation Shift+C Shift+C

eset View Shift+V Shift+V

eset Zoom Shift+Z Shift+Z

otate Clockwise V V

otate Counter Clockwise C C

how/Hide Strokes K K

witch Active View B B

urn Auto Light Table On/Off L L

urn Full Screen On/Off Ctrl+F Command+F

oom In X X

oom Out Z Z

WINDOWS MENU
COMMAND WINDOWS MAC OS X
olour Palette Ctrl+Shift+C Command+Shift+C

xposure Ctrl+Shift+E Command+Shift+E

unction Editor Ctrl+Shift+F Command+Shift+F

inimize Command+M

en view Ctrl+Shift+N Command+Shift+N

TOOLS MENU
COMMAND WINDOWS MAC OS X
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roperties view Ctrl+Shift+P Command+Shift+P

cene Manager Ctrl+Shift+M Command+Shift+M

imeline Ctrl+Shift+T Command+Shift+T

WINDOWS MENU
COMMAND WINDOWS MAC OS X
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