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Chapter 1: Introduction

Chapter 1: Introduction
The user guide provides step by step guidance on how to use every core functionality in Storyboard Pro for 
their intended task. 

NOTE 

For more detailed descriptions of the many options, buttons and menu items available in the 
Storyboard Pro user interface, refer to the Reference Guide. For descriptions of the many 
preferences available in the Preferences dialog, refer to the Preference Guide.
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About Storyboard Pro
Storyboard Pro is a full-featured storyboard and animatic creation software for animated features, TV series, 
projects mixing 2D and 3D, live action productions, video games, or events with advanced features.

With Storyboard Pro, you can create anything from a simple storyboard with thumbnails and captions to a fully 
animated animatic with sound effects, music, transitions and video clips. Among other things, you can create 
your project's structure of scenes and panels and fill them with artwork using Storyboard Pro's powerful set of 
vector and bitmap drawing tools, time each panel for the animatic, apply static or animated transformations on 
your drawings, position layers in a 3D space, add 2D or 3D camera movements to your scene, import 3D models 
to your panels, cue and edit sound effects and split your project to have several collaborators work on it 
together. 

When you're done working on your storyboard or animatic, you can export your project in various formats such 
as a standard PDF storyboard, movie files, video editing sequence and, if your production uses Harmony, you 
can even export your project's scenes into Harmony scenes to kick-start the animation process.
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Chapter 1: Introduction

Installing Toon Boom Storyboard Pro
Installing Storyboard Proon your workstation is a relatively simple and straightforward process. After installing 
the product, you will need to activate it before you are able to launch and use it. 

On Windows, Storyboard Pro is provided in an installation wizard that will install the application and create 
shortcuts on the Desktop and in the Start menu. Launching the installation wizard must be authorized by a 
user with administrator privileges.

NOTE 

On Windows, Storyboard Pro has the following dependencies:             

 l Windows Media Player must be installed to enable Storyboard Pro's audio and video 
transcoding capabilities. On most consumer versions of Windows, it is installed by default. 

 l QuickTime Player is required if you want to export movie files in QuickTime Movie (.mov) format. 
Otherwise, Storyboard Pro will only export movie files in Windows Media Video (.wmv) format. 
However, the application does not need QuickTime Player to launch and can be used without it. 

 l Adobe Reader is required on Windows 7 and Windows 8.1 in order to read PDF documents. 
On Windows 10, Microsoft Edge can be used to read PDF files. 

On macOS, Storyboard Pro is provided in an Apple Disk Image(.dmg) file, which contains the software 
package. It must be opened and its content must be copied over to the Applications directory for the software 
to be installed.

Copying the application's files does not require administrator privileges. However, since the application cannot 
be verified by macOS, launching the application for the first time must be authorized by an administrator. After 
that, it will be authorized permanently and regular users will be able to launch it.

NOTE 

On macOS, QuickTime Player must be installed to enable Storyboard Pro's audio and video 
transcoding capabilities. It is typically installed by default.         

How to install Storyboard Pro on Windows

 1. In a file browser, double-click on the installer package you have downloaded.

 2. When prompted by Windows, confirm giving the permission to the installer to make changes to 
your device. 

NOTE 

You need an account with administrator privileges to launch the installer.
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 3. In the Choose Setup Language prompt, select the preferred language for the installation process 
and for the end-user license agreement. 

 4. Wait for the install package to be extracted.

 5. In the welcome screen, click on Next.

 6. If you accept the license agreement presented in the installation wizard, select I accept the terms in 
the license agreement, then click on Next. Otherwise, click on Cancel. 

 7. If you want to install Storyboard Pro in the default installation directory, select Next. Otherwise, click 
on Change and select a preferred installation directory. 

 8. Click on Install.

 9. Wait for the installation process to finish.

Once the process is finished, you can launch Storyboard Pro—see Starting Toon Boom Storyboard 
Pro on page 28. 

How to install Storyboard Pro on macOS

 1. Log in to an account with administrator privileges. 

 2. In a file browser, double-click on the application package you have downloaded.

 3. Wait for macOS to verify the content of the package.

The License Agreement prompt appears.

 4. If you accept the license agreement presented by the application package, click on the Agree 
button. Otherwise, click on Disagree. 

TIP 

If you want to see the license agreement in another language, select a language in the 
language drop-down above the license agreement.

 5. In the Finder window that opens, select Toon Boom Storyboard Pro 6.

 6. Drag and drop the selected folder in Applications.

 7. Wait for the application to finish copying.

 8. Double-click on Applications, then on Toon Boom Storyboard Pro 6.

 9. Ctrl + click on StoryboardPro and select Open.
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 10. When prompted by macOS, confirm that you want to launch the application even though the 
developer cannot be confirmed.

Storyboard Pro will launch. From that point on, the application will remain authorized and can be 
launched by any user simply by double-clicking on the application icon. 

How to activate Storyboard Pro

 l Refer to the  License Activation documentation for steps on how to activate your product. It can be 
found at the following address:

 l docs.toonboom.com/help/activation

How to install QuickTime Player

 l Go to the following address and follow the instructions: 

 l Windows: apple.com/quicktime/download/pc

 l macOS: apple.com/quicktime/download/mac

How to install Adobe Reader

 l Go to the following address and follow the instructions: 

 l Windows: adobe.com/support/downloads/pc

 l macOS: adobe.com/support/downloads/mac

How to install Windows Media Player

 l Windows Media Player is pre-installed on most versions of Windows, but may be disabled. Follow 
these steps to make sure it is enabled.

 1. From the Start menu search bar, search for Control Panel and launch the Control Panel.

 2. From the Control Panel, go to Programs > Turn Windows features on or off.

 3. In the list of Windows features, find and expand the Media Features option. Windows Media 
Player should listed under Media Features. If either of these options are not listed, see below. 

 4. Ensure both the Media Features and Windows Media Player check boxes are checked. 
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 5. Click OK.

 6. Wait for the installation to finish.

 7. Restart Windows.

 l If Media Features or Windows Media Player is not listed in the available features, make sure your 
edition of Windows supports it. If it does, it may be added by installing the Media Feature Pack for 
Windows. To do this, click on the link corresponding to your version of Windows and follow the 
instructions:

 l Media Feature Pack for Windows 7: 
https://www.microsoft.com/download/details.aspx?id=16546

 l Media Feature Pack for Windows 8: 
https://www.microsoft.com/download/details.aspx?id=30685

 l Media Feature Pack for Windows 10: 
https://www.microsoft.com/download/details.aspx?id=48231
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Chapter 2: Projects

Chapter 2: Projects
All projects created with Storyboard Pro are independent and local to the computer. There are a few different 
ways to create and open projects. You can create a project from the Welcome screen, File menu, Final Draft 
script, or Toon Boom Harmony scenes.

A Storyboard Pro project is composed of several files. The drawings and colour palettes are not embedded in 
the project. They are separate linked files. Therefore, if you want to archive or share a project, you require all the 
files contained in the folder structure.

NOTE 

You can save your project as an open directory or as a single file. To switch to a single file, see 
Saving Projects as a Single File on page 45

Here is an example of the file structure contained in a scene. As you work and use more features, different 
folders may appear in your structure.

The Storyboard Pro project folder contains the following folders: frames, audio, elements, etc.

Folder/File Contents

audio Contains all imported audio files.

elements Contains all the drawing files.

environments

Contains the exported palette files that were originally stored at the environment 
level in the Harmony Server database structure or the palettes in a Harmony Stand 
Alone scene that will be imported later at the environment level in Harmony 
Server. This is for compatibility with Toon Boom Harmony.
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frames
Contains the final frames after a render if you are using the default settings of the 
Write node in the Node view.

jobs

Contains the exported palette files that were originally stored at the environment 
level in the Harmony Server database structure or the palettes in a Harmony Stand 
Alone scene that will be imported later at the environment level in Harmony 
Server. This is for compatibility withToon Boom Harmony.

logs
Contains traces of operations and processes while working with Storyboard Pro. 
This can be useful for debugging.

palette-library Contains palettes  files.

*.sboard
This is the main Storyboard Pro file. This is the file you must click on to launch 
the software and load the project. This file links to all the other files in the 
directory.

PALETTE_LIST This is the list of all the different palettes in the project.
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Starting Toon Boom Storyboard Pro
T-SBFND-002-001

You can run Toon Boom Storyboard Pro on Windows and macOS.

How to start Storyboard Pro

 1. Do one of the following, depending on your operating system:

 l Windows: On the desktop, double-click on the Storyboard Pro  icon or open the 
Start menu and select  Programs > Storyboard Pro 6 > Storyboard Pro.

 l macOS: Open Finder, then select Applications > Toon Boom Storyboard Pro > 
Storyboard Pro.

Storyboard Pro launches and displays the following screen. If you want to explore, go ahead and 
click one of the buttons. Otherwise, click Close.

A second Welcome screen displays.
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Creating Projects
When creating projects, you have the choice of using the Welcome screen or the File menu in Storyboard Pro. 
You can also create a project from a Final Draft script or from Harmony scenes.
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Creating Projects from the Welcome Screen
T-SBFND-002-003

You can create a project from the Welcome screen. 

How to create a project from the Welcome screen

 1. In the Project Name field, type the name of the project. This name will appear as the file name.

 2. In the Project Directory field, specify the location of your new project.

 3. In the Project Title field, type the name of the project title. It is a good idea to use the Project Name 
for the Project Title. You can also type in the name of the Project Subtitle, but it is not mandatory. 
These titles will appear in the PDF exports of your storyboard.

 4. In the Camera Size menu, choose the resolution for your project—see Creating Custom Resolutions.

 5. Click Create Project.
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Creating Projects from the File Menu
T-SBFND-002-004

You can also use the File menu.  If a project is already open and you want to create a new one,  use the File menu. 
Note that the content of the project directory will appear when you save the project for the first time.

How to create a project from the File menu

 1. Do one of the following:

 l Select File > New. 

 l In the File toolbar, click the New  button.

 l Press Ctrl + N (Windows) or ⌘  + N (Mac OS X).

The New Project dialog box opens.

 2. In the Project Name field, type the name of the project. This name will appear as the file name.

 3. In the Project Directory field, specify the location of your new project.

 4. In the Project Title field, type the name of the project title. It is a good idea to use the Project Name 
for the Project Title. You can also type in the name of the Project Subtitle, but it is not mandatory. 
These titles will appear in the PDF exports of your storyboard.

 5. In the Camera Size menu, choose the resolution for your project—see Creating Custom Resolutions.

 6. Click Create Project.
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Creating Projects from Final Draft
T-SBADV-001-001

 

Storyboarding and script writing go hand-in-hand. Storyboard Pro lets you use your Final Draft script to create 
a new Storyboard Pro project. This feature is a time saver as it handles the creation of scenes and panels, as 
well as inserting all the text in the proper captions automatically.

The following steps give detailed instructions on how to import a typical Final Draft script and automatically 
break it down into scenes and panels. Since scripts are never really written on a "per-panel" basis, and every 
script is paced and structured differently, you may have to try different settings to get optimal results, and you 
may have to combine or split some of the automatically generated panels manually to best fit the pace of your 
story. 

NOTES 

 l Storyboard Pro has a preference to use Live Action terminology instead of Animation 
terminology, available in the General tab of the preferences dialog. With this preference, the 
following terminology is replaced in the Storyboard Pro user interface:   

 l The term Scene becomes Shot.

 l The term Sequence becomes Scene.

The steps below will specify the term for both terminology preferences where applicable. 

 l If you are using Final Draft 7 or earlier, you must export your script in .xml format using Tagger, 
as the native file format of Final Draft 7 and earlier (.fdr) is not supported by Storyboard Pro.

 l For more information on the Import from Final Draft dialog, see Import from Final Draft Dialog 
Box.

How to create project from a Final Draft script

 1. From the top menu, select File > New From Final Draft Script.

The Import from Final Draft dialog opens.

 2. Click on the  Browse  button.

 3. In the file browser, locate and select your Final Draft script, then click on Open.

Once your script is loaded, the types of tags contained in your script will appear in the list to the left. 
You will have to indicate to Storyboard Pro what to do with each of these tags when generating 
your project. 
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 4. If your script is structured with scene headings, but not shots, do the following:

 a. In the list to the left, select Scene Heading.

 b. In the Action drop-down, select New Scene (animation terminology) or New Shot (live 
action terminology).

 c. In the Destination caption field drop-down, select Notes.

 d. If your Scene Heading elements are numbered in your script and you want to include their 
number in your project's captions, check the Include Element Number when available option.

Your storyboard will have one scene (or shot) for every scene heading in your script, and the scene's 
description will be added to the Notes caption of every first panel of every scene. 

If your script is structured with both scene headings and shots, do the following:

 a. In the list to the left, select Scene Heading.

 b. In the Action drop-down, select New Sequence (animation terminology) or New Scene (live 
action terminology).

 c. In the Destination caption field drop-down, select Notes.

 d. If your Scene Heading elements are numbered and you want to include their number in your 
project's captions, check the Include Element Number when available option.

 e. In the list to the left, select Shot.

 f. In the Action drop-down, select New Scene (animation terminology) or New Shot (live 
action terminology).

 g. In the Destination caption field drop-down, select Notes.

 h. If your Shot elements are numbered in your script and you want to include their number in 
your project's captions, check the Include Element Number when available option.
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Your storyboard will have one sequence (or scene) for every scene heading in your script, and one 
scene (or shot) for every shot in your script. Their description will be added to the Notes caption of 
every first panel of their corresponding scene or sequence. 

 5. In the list to the left, select the Action tag, then:

 a. If you want one panel to be created for each action, select New Panel in the Action drop-
down. 

 b. If you want consecutive actions to be combined in the same panel, check the Combine 
successive elements option.

 c. In the Destination caption field drop-down, select Action Notes. This will store the content 
of the action tag into the Action Notes caption of each panel. 

 d. If your Action elements are numbered in your script and you want to include their number in 
your project's captions, check the Include Element Number when available option.

 6. In the list to the left, select the Character tag, if any, then:

 a. If you want one panel to be created for each dialogue, select New Panel in the Action drop-
down. 

 b. In the Destination caption field drop-down, select Dialogue.

 c. If your Character elements are numbered in your script and you want to include their number 
in your project's captions, check the Include Element Number when available option.

 7. In the list to the left, select the Parenthetical tag, if any and:

 a. In the Destination caption field drop-down, select Dialogue.

 b. If your Parenthetical elements are numbered in your script and you want to include their 
number in your project's captions, check the Include Element Number when available option.
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 8. In the list to the left, select the Dialogue tag, if any:

 a. In the Destination caption field drop-down, select Dialogue. 

 b. If your Dialogue elements are numbered in your script and you want to include their number 
in your project's captions, check the Include Element Number when available option.

 9. In the list to the left, select the Transition tag, if any:

 a. In the action drop-down, select New Transition. 

Overall, if your script is structured with scene headings, but not shots, the following settings are 
suggested:

 
Action (Animation 
Terminology)

Action (Live Action 
Terminology)

Destination caption 
field

Action New Panel New Panel Action Notes

Character New Panel New Panel Dialogue

Dialogue None None Dialogue

Parenthetical None None Dialogue

Scene Heading New Scene New Shot Notes

Transition New Transition New Transition None

And if your script is structured with scene headings and shots, the following settings are suggested:

 
Action (Animation 
Terminology)

Action (Live Action 
Terminology)

Destination Caption 
Field

Action New Panel New Panel Action Notes

Character New Panel New Panel Dialogue

Dialogue None None Dialogue
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Action (Animation 
Terminology)

Action (Live Action 
Terminology)

Destination Caption 
Field

Parenthetical None None Dialogue

Scene Heading New Sequence New Scene Notes

Shot New Scene New Shot Notes

Transition New Transition New Transition None

NOTE 

Depending on the way your script is structured and on how much the action or dialogue 
drive the pace, you might have to try creating a project with your script using different 
options to get the best storyboard structure for your needs. In the end, it is likely that 
you will have to split or combine some of the automatically generated panels.

 10. If you want to make the currently selected parameters default, check the Save as default rules 
checkbox. 

 11. Click Import.

The New Project dialog appears.

 12. In the New Project dialog, enter the name, location, title and resolution for your project.

NOTE 

For more information on creating a new Storyboard Pro project, see Creating Projects 
on page 30.

 13. If the currently opened project was not saved, confirm whether you want to save it.

Your new project is created, with scenes and panels automatically created and their captions filled 
with excerpts from your script, based on the settings you selected.

37

Storyboard Pro 6. User Guide                          



Chapter 2: Projects

Creating Projects from Harmony Scenes
You can create a project from Harmony scenes. Before you do this,  in Harmony, you must mark the frames you 
want to use as panels in your project. Frames must be marked in an annotation column called "EM". For each 
marked frame, a panel is created in Storyboard Pro. If you don't mark your frames, the first frame of each 
Harmony scene will be used.

You must group all your different Harmony scenes in one folder. Storyboard Pro will create one scene per 
Harmony scene. If your Harmony scene contains several EM markers in the annotation column, Storyboard Pro 
will create multiple panels within the scene.

How to create a project from Harmony scenes

 1. From the top menu, select File > New from Harmony Scenes.

The New Project dialog box opens.

 2. In the Project Directory field, specify the location of your new project.

 3. In the Project Name field, type the name of the project. This name will be used as the file name.

 4. In the Project Title field, type the name of the project title. It can be a good idea to use the Project 
Name for the Project Title. 

You can also type in the name of the Project Subtitle, but it is not mandatory. These titles will appear 
on the appropriate pages of PDF renders.

 5. In the Resolution section, choose the project’s resolution—see Creating Custom Resolutions.

 6. Click Create.

The Select Harmony Scenes Directory window opens.

 7. Select the folder you created that contains your multiple Harmony scenes; do not select the 
Harmony scene folder directly. Click Select Folder. 
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The name of the folder of each scene file is used to name the scene that is created. Panels are 
created in the Thumbnails and Timeline views.
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Creating Custom Resolutions
You can create a custom resolution from the Welcome screen or New Project window. Your new resolution will 
appear in the Camera Size menu of both the New Project window and Welcome screen.

If you no longer need a custom resolution, you can easily remove it.  However, you cannot delete the factory 
resolutions that come with Storyboard Pro.

How to create a custom resolution

 1. In the Welcome screen or New Project window, click the Add  button to add a new resolution to 
the list.

The New Resolution box opens.

 

 l Resolution Name: Type a name for your new resolution.

 l Width/Height: Enter the resolution width or height in pixels. These two parameters 
are linked; changing one changes the other.

 l Field of View: Set the field of view to use the horizontal or vertical resolution, or enter 
a custom field of view.

 l Frame Rate: Type the scene’s frame rate per second.

How to delete a custom resolution

 1. In the Welcome screen or New Project window, select a custom resolution from the Camera Size 
menu.
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 2. Click the Remove  button.

The selected custom resolution is deleted from the list.
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Opening Projects
T-SBFND-002-006

Existing projects can be opened from the Welcome screen when you start Storyboard Pro. If you already have 
Storyboard Pro open, you can open projects from the File menu.

How to open a project from the Welcome screen

 1. Start Storyboard Pro.

 2. In the Recent Projects section, do one of the following:

 l Select a project from the list.

 l Click Open Project and select a project (*.sboard file) from the browser that appears.

How to open a project from the File menu

 1. Do one of the following:

 l Select File > Open. 

 l In the File toolbar, click the Browse  button.

 l Press Ctrl+O (Windows) or ⌘+O (Mac OS X).

The Open Project window opens.

 2. Locate and select an *.sboard file.

 3. Click Open.
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About Saving
It is important to regularly save your project. For more information about the structure of a saved project, see 
Projects on page 26.

To save the current state of a project as a new one, you can use the Save As command. The Save As window 
prompts you to give a new name and choose a different location to this project before saving it. This will create 
a complete project directory for the new project.

You can also configure Storyboard Pro to automatically save your work—see.

A Storyboard Pro project is composed of many small files. Each drawing in a project is a file, which may result in 
projects containing over 10,000 files. This can quickly fill your storage solution with a high number of files, 
straining the file system and backup process. 

You can reduce the number of files and protect the integrity of projects by saving (packing) the project in a 
single file. A packed project file is appended with the .sbpz extension.

NOTE 

See About Project Management on page 748 to learn more about splitting and merging projects.
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Saving Projects
You can save your projects as is or save them as a new copy.

How to save a project

 l Select File > Save.

 l Press Ctrl + S (Windows/Linux) or ⌘  + S (macOS).

How to save a project as a copy (Save As)

 1. Select File > Save As.

 2. In the Save As dialog box, browse to the location of the new archive and give the copy of the project 
a new name.

 3. Click Save.
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Saving Projects as a Single File
T-SBADV-003-005

A Storyboard Pro project is composed of many small files. Each drawing in a project is a file, which may result in 
projects containing over 10,000 files. This can quickly fill your storage solution with a high number of files, 
straining the file system and backup process. 

You can reduce the number of files and protect the integrity of projects by saving (packing) the project in a 
single file. A packed project file is appended with the .sbpz extension.

The location of your packed file (*.sbpz) does not have to be in the same place as your current project file. For 
example, you can save the packed file on your company’s server and save the current version on your local 
computer.

You can open a packed file in the usual way by using the File > Open command or by double clicking the file in 
the Explorer (Windows) or Finder (macOS). The packed file extracts to a temporary folder on your computer. 

 l Windows: \Users\[username]\Documents\Toon Boom Animation\StoryboardPro Project Cache

 l macOS: /Users/[username]/Documents/Toon Boom Animation/StoryboardPro Project Cache

When opening a project in Storyboard Pro, you can select an .sbpz file (the packed project); this file will be 
updated when you perform a Save and Pack. If you opened an .sboard project, you can perform a Save As to a 
packed format, after which that file (the packed/zipped one) will be updated by the Save and Pack.

NOTE 

- Unpacked projects do not appear in the list of recent projects, so you don't accidentally open the 
project in the cache.
- Multiple users cannot open the same packed project at the same time.
- When working with a packed project and you have Storyboard Pro set to automatically save your 
project, Autosave, it is saved to the project cache.

How to set your project to save as a single file

 1. Do one of the following:

 l Select Edit > Preferences (Windows) or Storyboard Pro > Preferences (macOS).

 l Press .

 2. Select the Project Settings tab.

 3. Select the Save new projects in single file format (packed file) option and click OK.
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How to convert a standard Storyboard Pro project to a packed project

 1. Select File > Save As.

The Save As window opens.

 2. In the File Name field, give your packed file a name.

 3. From the Save as Type list, select Storyboard Packed File (*.sbpz).

 4. Click Save.

The project is saved and zipped to the location you specified.

How to save an unpacked project

 1. Do one of the following: 
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 l Select File > Save to save the project to your local cache.

 l Select File > Save and Pack to pack the project to the location you specified for your 
packed project. 

The unpacked project is saved and packed to the original zipped project file.

NOTE 

If the project already has a file, save the project locally using the Save command , then save to 
the zip file using the Save and Pack command.
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Recovering Your Project from the Cache
T-SBADV-003-006

In the event that Storyboard Pro unexpectedly quits, your project can be restored back to your latest version 
saved in the local cache.

At launch, Storyboard Pro always scan the cache folder to recover project.  Simply launch the application and 
you will receive the following prompt:

At this stage, you have three choices:

 l To recover and open the project, click Yes. Storyboard Pro will open the main interface and load the 
lastest save available in the cache.

  One the project is recovered, it is important that you “Save” or “Save As” your project before closing the 
application.

 l If you don’t want to recover immediately and you want to leave the project in the cache, click Skip.  On 
next launch of Storyboard Pro, you will receive the Project Recovery prompt again.

 l If you will never want to recover the project, you can delete the cache by clicking Delete.  This operation 
is irreversible and the cache will be cleared.

IMPORTANT 

Use Skip and Delete only if you know what you are doing. If you hesitate, it is recommended to 
proceed to the recovery by clicking Yes and use “Save As” command to restore the project to a new 
location.
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NOTE 

Storyboard Pro proposes to recover only one project at a time.  So if more than one projects are in 
the cache, more than one launch of Storyboard Pro will be necessary to recovert them all.
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About Project Optimization
T-SBFND-002-007

If you are concerned with file size and speed, there are a few things you can do to optimize your project.

NOTE 

Toon Boom Storyboard Pro has an optimized file structure that reduces the number of folders. For 
this reason, once a project is saved in this version, it can no longer be opened in Storyboard Pro 
2. However, Toon Boom Storyboard Pro is fully backwards compatible and will open files created by 
older versions of Storyboard Pro.
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Optimizing Projects
T-SBFND-002-008

You can optimize projects by flattening all drawings in your project, removing unused files, and reducing the 
texture size.

How to optimize your project

 1. Select File > Optimize Project.

The Optimize project dialog box opens.

 

 2. Select one or more of the following options:

 l Remove unused elements from the project: As you create a storyboard you will 
delete panels or layers, update drawings, unlink sounds, and so on. Some of these files 
are kept for backup purposes, but they take up space and increase the size of your 
project on your hard drive. This option removes these unwanted elements.

 l Flatten drawings in the project: Flattens all the brush or pencil line strokes of all the 
vector drawings in your project. This means that all overlapping strokes will no longer 
be editable as single strokes, but only as whole, drawn objects.

NOTE 

Strokes drawn with different colours will not be flattened together.

 l Reduce texture resolution of all drawings in the project: Reduces the resolution of 
bitmap textures in drawings that have an unnecessarily high pixel density.  

NOTE 

This cannot be reversed once you have reduced the resolution.  These operations 
cannot be undone and will empty the undo list.
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Optimizing Drawings
T-SBFND-002-009

When using any of the playback options in Storyboard Pro, the software must calculate the positioning of all 
the *.tvg (Toon Boom vector graphics) files. This is the file format created from all your drawing strokes. This 
calculation tends to slow down the rate of playback. There is, however, a way to circumvent this problem.

There is a second file format, *.tvgo (Toon Boom vector graphic optimized), that has all the pixel position 
information pre-calculated. Using these drawings should significantly speed up playback.

How to optimize playback and create optimized drawngs

 1. Select Edit > Preferences.

The Preferences dialog box opens.

 2. From the Advanced tab, under the Optimized Playback section, select the Use Optimized Drawings 
option.

 3. Select the Asynchronous Drawing Loading option to optimize playback.  There are cases in which, 
during playback, the software may encounter a particularly texture-heavy or complex panel.  When 
this happens, and this option is deselected, there will be a pause in playback while the frame loads.  
If you select this option, then playback will continue and the drawings will load as soon as they are 
available.  You may notice a short blink while the drawing loads.

 4. Select the Preload Drawings option to enhance playback further by loading drawings in memory 
before you reach them during playback. Storyboard Pro will determine which, between the two 
options, has more drawings to preload and use the appropriate option during playback.

 l Number of Frames to Preload: Storyboard Pro looks ahead for the number of frames, 
and checks to see how many drawings are used.  Each layer on each panel is a 
drawing.  If you have many short panels, then you will have more drawings than if you 
had one long panel.

 l Number of Panels to Preload: Storyboard Pro looks ahead for the specified number of 
panels to determine the number of drawings in those panels.  Keep in mind that each 
layer on each panel is a drawing.  If you have long panels, then it will want to look 
ahead several panels, instead of the specified number of frames.

 5. Click OK.

 6. Select File > Create Optimized Drawings.
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Optimization Best Practices
T-SBFND-002-010

When working in Storyboard Pro, there are some best practices you should follow to keep the file size low and 
playback speed fast.
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Plain Vector Versus Texture Brush
T-SBFND-002-011

When you draw on a layer, all the strokes that you create with the Brush tool are vector elements. There are 
two kinds of brushes:

 l Plain Brushes: By default, the Brush tool creates vector strokes filled with either a colour or a gradient. 
Vector strokes use a very small amount of memory and can be used rapidly because they do not contain 
any pixel information, only mathematical functions.

 l Texture Brushes: This type of brush also produces a vector contour for its strokes, but is filled with a 
bitmap texture. These textures allows you to produce drawings that have natural looking brush strokes 
that resemble lines drawn using a crayon or airbrush.

Because you are using a bitmap image mapped inside vector strokes, texture brushes use much more memory 
and processing time than brush strokes filled with colour. Therefore if you want to make your file size lighter 
and drawing speed faster, use only regular brushes to draw scenes. If you choose to use texture brushes, is it 
important to use a reasonable size bitmap for the texture brush.

NOTE 

When you use a bitmap layer instead of a vector layer, individual vector strokes are not created. 
Instead, individual pixels are laid down, recording information about the RGBA of each pixel.  
Because of this, when working with lots of shading and lots of different textures or colours, the 
bitmap layer is actually more efficient than the texture brush on the vector layer—see Drawing on 
page 210.
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Bitmap Import Optimization
T-SBFND-002-012

Storyboard Pro allows you to create storyboards by importing scanned images or bitmaps drawn in another 
software. During the import process, images are vectorized and placed in a new scene in a vector bounding box 
as a bitmap fill. The bitmap image’s resolution can affect your project’s file size and the speed at which 
Storyboard Pro functions while handling your project. When importing bitmaps into a storyboard, there is 
rarely a need to use a high resolution as it will not increase the quality of your PDF or animatic. You should 
import bitmaps with a resolution close to the project resolution. For example, in an NTSC project, using a bitmap 
with a 720 x 480 resolution or a 72 dpi quality will be fine.
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Flattening Drawings
T-SBFND-002-013

In Storyboard Pro, strokes inside a vector layer are independent. You can select a specific stroke and edit its 
position, scale, rotation, skew, colour and so on, whenever you want. However, this flexibility increases the 
amount of memory and resources used, especially when you have a lot of strokes in your drawing (which 
frequently happens when sketching).

You can flatten all drawings at the same time. However, you can retain partial flexibility and still minimize file 
size and resources needed by consciously flattening certain drawings as you draw, or even by selecting them 
after you have drawn them. You can take all strokes of the same colour with overlapping areas on the same 
layer and flatten them to create a single drawing with a vector contour.

Pencil lines of the same colour can be flattened together. If there are several colours used for the line, multiple 
line sets will be created. Pencil line size does not affect the flatten.

When you use the Flatten option in the Tools menu, Storyboard Pro automatically crops all textures, reducing 
the drawing size by removing the texture area which is not visible.

 

How to flatten strokes as you draw

 1. From the Tools toolbar, select the Brush  tool.

 2. In the Tool Properties view, click the Auto-Flatten  button.

 3. In the Stage view, sketch your first drawing. 

The strokes are automatically flattened.

How to flatten an existing drawing

 1. From the Tools toolbar, select the Select  tool.

 2. In the Stage view, select a group of strokes.

 l If you do not select a group of strokes, the entire layer will be flattened.

 l You can select multiple layers, so they are flattened individually.

 3. Select Tools > Flatten or press Alt + Shift + F.

56



About Project Properties
T-SBFND-002-014

When you created your new project, you chose the name and resolution. However, if you want to change these 
initial settings later on, you can. All global project properties such as the resolution, project name, copyright, 
field chart size, and frame rate are available in the Project Properties dialog box. 

How to access the project properties 

 l Select Storyboard > Properties.

The Project Properties  dialog box opens.
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About Project Backup
T-SBADV-001-002

As you work on your storyboard project, it is always a good idea to save continuously. At the end of each 
workday, it is even better to back up your work. The difference between backing up and saving is that a 
backup is a compressed version of your project. Backing up your work provides a safety net against corrupted 
files and allows you to have several versions of your project at different stages, in case you need to go back and 
work from an earlier point in the production.
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Backing Up Projects
T-SBADV-001-003

The place where you save your backup file (*.sbbkp) does not necessarily have to be the same place where you 
have your current project file saved. For example, you can save the backup on your company’s server, even 
though the current version is saved somewhere on your computer.

How to back up the current version of your Storyboard Pro project

 1. Select File > Backup Storyboard.

The Create Storyboard Backup window opens.

 2. Browse for a location on your computer to save this backup file. You can also rename it with a date or 
version number.

 3. Click Save. 

An *.sbbkp file is created and saved in the assigned location.
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Restoring Backups
T-SBADV-001-004

At times, you may need to restore a backup of a project you are working on. 

How to restore and open a backup file

 1. Do one the following:

 l Select File > Restore and Open Backup. In the Open Storyboard Backup window that 
appears, locate and select the *.sbbkp file.

 l On your computer, go to the location where you saved the *.sbbkp file and double-
click its icon. In the browser window, select a place to save the restored file.

 2. If multiple projects are present in the .sbbkp file, Storyboard Pro will ask you to choose which one 
you want to use.

 a. Select the desired project.

 b. Click OK.

 3. The project opens in Storyboard Pro.
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Chapter 3: Interface
T-SBFND-003-001

Understanding how to manage the Storyboard Pro interface helps you to work efficiently and organize your 
workspace conveniently. There are a many views and toolbars you can use for performing different operations. 
You will probably have your own preferred way of working in the Storyboard Pro interface as well.

When you start Storyboard Pro for the first time, the default workspace is displayed. It contains all of the main 
elements you need for creating a storyboard.

Top Menu
Located at the top of the Storyboard Pro interface, the top menu contains most of the commands. Depending 
on the view you are working in and the selected element, some commands are available and others not. 

Tools Toolbar
The Tools toolbar contains the main tools you need to work in Storyboard Pro. In the default workspace, this 
toolbar located on the left-most side of the interface. A small triangle at the lower-right corner of a tool 
indicates that additional tools can be selected in a pop-up menu. To access these tools, either click and hold on 
the tool button, or select the tool then click on it again. 

Storyboard Toolbar
The Storyboard toolbar contains all of the basic commands related to adding and deleting panels, scenes, and 
transitions, as well as switching between the 2D and 3D workspaces. In the default workspace, this toolbar is 
located at the top of the interface.
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Playback Toolbar
The Playback toolbar lets you play back your storyboard. When you create an animatic with transitions and 
sound, you can play it back in real time in the Stage view to check the timing. 

In the default workspace, this toolbar is located at the top of the interface.

Thumbnails View
The Thumbnails View displays all the panels of your project in chronological order. You can use this view to 
navigate through your storyboard, rearrange panels and scenes, and select the panel to display in the Stage 
view.

By default, it is not possible to draw in the Thumbnails view and there are no browsing buttons. But you can 
change these settings in the Preferences dialog box.

Stage View
The Stage view are the centre of operations in Storyboard Pro. In these views, you can build, draw, paint, 
animate the camera, create layers, and see your results.

Panel View
The Panel view displays the different captions related to the current panel, the in, out and duration, and lets 
you play any voice annotations related to the panel.

NOTE 

By default, when you modify the workspace, it is automatically saved. You can restore the default 
workspaces by selecting Windows > Restore Default Workspace. You can prevent this behaviour 
by deselecting the Save Workspace option in the Preferences dialog box—see General 
Preferences in the Preferences Guide.
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About Menus
In Storyboard Pro, you can access the commands from the following three types of menus:

Top Menu: Located at the top of the Storyboard Pro interface, the top menu contains most of the commands. 
Depending on the view you are working in and the selected element, some commands are available and others 
not. 

View Menus: Some views have their own menu containing commands specifically related to that view. To 
access a view menu, click the View Menu  button in the top-right corner of a view. 

Contextual Menus: Each view has a contextual menu containing commands for recurring actions. To access a 
contextual meu, right-click (Windows) or Ctrl+click (macOS) anywhere in a view.

64



About Views
T-SBFND-003-002

The Storyboard Pro user interface is comprised of different views, each one designed for a specific purpose. You 
can modify the location and accessibility of the views by adding a new view as a tab or as a window. You can 
also swap the view locations around, as well as do the following:

 l Add a view

 l Tab a view

 l Dock a view

 l Undock a view

 l Rename a view

 l Close a view

 l Move a view

 l Resize a view

 l Collapse a view

 l Expand a view

For details about the views in Storyboard Pro, see Reference Guide.

Here is a complete list of the views available in Storyboard Pro.

 l 3D Schematic

 l Camera

 l Colour

 l Function Editor

 l Guides

 l Layers

 l Library

 l Message Log

 l Panel

 l Panel PDF Options

 l PDF Export

 l Pitch Mode

 l Script Editor
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 l Side

 l Stage

 l Storyboard

 l Thumbnails

 l Timeline

 l Tool Properties

 l Top
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Adding Views
T-SBFND-003-002

Views contain specific groupings of features and can be positioned anywhere on your screen. You can tab, dock, 
and undock a view.

The Colour view is a bit different than other views in Storyboard Pro. By default, the Colour view is part of the 
Tool Properties view, not a separate view on its own. If you have chosen to separate the two views and want to 
reintegrate them into one view, select Windows > Restore Default Workspace. 

How to add a view

 1. Do one of the following:

 l Select Windows and then select a view from the list.

 l In Panel view, click the View Menu  button and select a view from the list.

How to dock a view 

 l Drag the window’s tab onto the Panel view and drop it in the tab area.

The view is added to the Panel view.
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How to undock a view

 1. In the Panel view, select a view by clicking its tab. 

 2. Drag the selected view to a new location, moving away from the Panel view. 

The view turns into a window.
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Renaming a View
T-SBFND-003-003

You can rename a view for convenience. When you do, the new name remains in effect as long as the view 
stays open. Once you close and reopen the view, its name, as displayed on the tab, will revert to the default 
name.

How to rename a view

 1. In the view to rename, click the View Menu  button.

 2. Select Rename Tab from the list.

The Rename View Tab dialog box opens.

 3. Type a new name for the tab you want to rename and click OK.
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Closing Views
T-SBFND-003-003

If there are views in your workspace that you do not use, you can close them to streamline your space.

How to close a view

 1. In the view to close, click the Close View  button.

 2. If there are several tabs, press Shift and click the Close View  button.

All the tabs are closed at the same time.

NOTE 

Don't forget, you can restore the default workspace at any time by selecting Windows > 
Restore Default Layout.
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Moving Views
T-SBFND-003-004

You can move and group views, create floating windows, or dock them in their own individual areas.

NOTE 

The Colour view is like other views, that is, you can dock and undock it. When you first open the 
Colour view, it is docked. You can undock it so it becomes its own window which you can move 
around freely.

How to move a view

 1. Select the tab of a view and drag it onto a view separator, top area, or onto another view’s tab.

 2. When a rectangle outline appears showing an available location for the view (see 1, 2 and 3 below), 
release the mouse button to drop the view into position.

The view becomes a tabbed window, a floating window, or a new docked window.
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Resizing Views
T-SBFND-003-005

By resizing a view, you can customize your workspace. You can change the width and height of the views in 
the workspace.

How to resize a view

 1. Position your cursor at the edge of the view you want to resize.

 2. When you see the Resizing cursor, drag the side of the window to the desired width or height.
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Expanding or Collapsing Views
T-SBFND-003-006

By temporarily expanding or collapsing a view, you can manipulate the workspace to suit your workflow. The 
expanded or collapsed state of a view will be saved as part of the workspace modifications.

How to expand or collapse a view

 1. On the edge of the view you want to hide, click the Expand/Collapse button. 

The view is collapsed and only the Expand/Collapse  button is visible.

 2. Click the Expand/Collapse  button to display the view again.

73

Storyboard Pro 6. User Guide                          



Chapter 3: Interface

About Toolbars
T-SBFND-003-007

The Storyboard Pro interface contains toolbars that quicky give you you access many useful tools. You can add, 
move and remove toolbars in your workspace. Some toolbars have optional buttons that are hidden by default, 
but which can be added.

These toolbars are available in Storyboard Pro.

 l Camera

 l Clips and Tracks

 l Coordinate

 l Edit

 l File

 l Layer

 l Navigation

 l Onion Skin

 l Playback

 l Scripting

 l Storyboard

 l View

 l Workspace

 l Tool Presets

 l Tools
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Adding and Closing Toolbars
T-SBFND-003-007

You can easily add a toolbar to your workspace or close one you don't use very often.

How to add a toolbar

‣ Select Windows > Toolbars > the toolbar to add.

How to close a toolbar

‣ Select Windows > Toolbars > the toolbar to close.
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Moving Toolbars
T-SBFND-003-008

You can move toolbars and place them at the top of the interface or beside a view.

How to move a toolbar

 1. Select the toolbar to move by clicking its anchor point  and dragging it to a toolbar area at the top 
or side of the interface. 

As you drag the toolbar, a rectangle outline appears to indicate the available locations for the 
toolbar.

 2. Release the toolbar to drop it into position.

76



Customizing Toolbars
T-SBFND-003-009

Some of the toolbars can be customized with your favourite tools and options. You can also organize the 
toolbars to suit your working preferences.

These are the toolbars that can be customized:

 l Layer

 l Storyboard

 l Navigation

 l Sound

 l Tools

The Tools toolbar can only be customized if the Flat Tools Toolbar preference is enabled. This preference allows 
you to display all the tools instead of having some of them grouped as drop-downs.

How to customize a toolbar

 1. Right-click (Windows) or Ctrl+click (macOS) on any button in a toolbar and select Customize.

The Toolbar Manager dialog box opens.

 2. Do any of the following:

 l Add a new icon to a toolbar: Select a tool/command from the Available Tools list and 
click the Right  Arrow button.

 l Remove an icon from a toolbar: Select a tool/command in the Toolbar list and click the 
Left  Arrow button to remove it from the toolbar.
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 l Reorder icons in a toolbar: Select a tool/command in the Toolbar list and click the Up 
 or Down  Arrow buttons to reposition it.

 3. Click Apply to apply the changes without closing the Toolbar Manager dialog box or click OK to 
apply the changes and close the window.

How to enable the Flat Tools Toolbar preference

 1. Open the Preferences dialog box by do:

 l Select File > Preferences (Windows) or Storyboard Pro > Preferences (macOS).

 l Press Ctrl + U (Windows) or ⌘  + , (Mac OS X).

 2. Select the Global UI tab.

 3. In the Toolbars section, select the Flat Tool Toolbar option.

 4. Restart Storyboard Pro. Once the software is restarted, you can customize the Tools toolbar. 
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About Workspaces
T-SBFND-003-010

The Storyboard Pro workspace is comprised of several views. You can customize your workspace to suit your 
work style, save it as a new workspace, and load it from the Workspace toolbar.

The first time you open Storyboard Pro, the default Drawing workspace is loaded. There are a total of eight 
ready-made workspaces.

Workspace Icon Description

Drawing

This workspace is designed to enable you to draw your storyboard efficiently. The main 
space is the large Stage view and the Thumbnails view is at the bottom. This workspace 
also gives you quick and easy access to all your tools, as well as the Panel and Storyboard 
views.

Timeline

This workspace is designed with the process of animatic creation in mind. The main 
space is the large Stage view and the Timeline view is at the bottom, where you can easily 
edit the timing of panels, transitions and sounds. This workspace also gives you quick 
and easy access to all your tools, as well as the Panel and Storyboard views.

Overview
This workspace is designed to provide an organized overview of your project. The main 
space is the Thumbnails view where you can efficiently reorganize the order of your 
panels.

Horizontal
This workspace displays your project as a classic horizontal paper storyboard layout. The 
main space displays three panels at a time, with the panel information shown below each 
one.

Vertical
This workspace displays your project as a classic vertical paper storyboard layout. The 
main space displays two panels at a time, with the panel information shown at the side of 
each.

Pitch Mode

This workspace displays your project with a different set of views than the other 
workspaces. Access is only given to a certain number of features. This maximizes the 
viewing space to focus solely on the story being pitched.

The Pitch Mode workspace occupies the entire display screen. There are no toolbars or 
top menu available.

PDF View
This workspace displays your project with the views required to quickly set up your PDF 
export.
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Workspace Icon Description

3D View
This workspace displays your project with the views appropriate for working with 3D 
objects, including the Camera, Top, Timeline, and Layers views.

When you create or change any of the customer workspaces, the file are stored in a folder called Toon Boom 
Storyboard Pro. You can copy this folder if you want to use the same workspaces on a different computer.

 l Windows:

 l C:\Users\[user_name]\AppData\Roaming\Toon Boom Animation\Toon Boom Storyboard 
Pro \1600-layouts-xml

 l macOS: On macOS, the Library folder is a hidden folder. To display the display the folder, hold down the 
Alt key when displaying Finder's Go menu.

 l /Users/[user_name]/Library/Preferences/Toon Boom Animation/Toon Boom Storyboard 
Pro/1600-layouts-xml
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Loading Workspaces
T-SBFND-003-011

There are several ways to load a workspace in Storyboard Pro.

How to load a workspace

 l From the View toolbar, click a workspace button.

 l Select Windows > Workspace > Workspace and then select a workspace.

 l Use the keyboard shortcuts 3 to 8 to open the corresponding workspaces. There is no keyboard 
shortcut for the PDF View. You must use the button on the View toolbar. 
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Creating a Workspace
Using the Workspace Manager, you can modify, create, delete, rename, and reorder workspaces. You can 
create a new workspace from an existing one and modify it to suit your needs.

How to create a new workspace

 1. Do one of the following:  

 l Select Windows > Workspace > Workspace Manager.

 l Select Windows > Toolbars > Workspace and in the Workspace toolbar, click the 
Workspace Manager  button.

 2. In the Available Workspaces list, select an existing workspace.

 3. At the bottom of the Available Workspaces list, click the Add  button to add a workspace.

 4. Select the new workspace you created, then click Rename and give it a new name.

 5. Select the new workspace and click the Right Arrow  button to send it to the Workspace toolbar.

 6. Click OK
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Renaming a Workspace
You can rename an existing workspace in the Workspace Manager.

How to rename a workspace

 1. Do one of the following:  

 l Select Windows > Workspace > Workspace Manager.

 l Select Windows > Toolbars > Workspace and in the Workspace toolbar, click the 
Workspace Manager  button.

 2. From the Available Workspaces column, select a workspace to rename.

 3. Click the Rename button.

 4. Type in a new name for the workspace.
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Saving a Workspace
Storyboard Pro automatically saves the changes made to a workspace. This means that when you resize, move 
around, add or delete views, your workspace will be automatically saved in its current state. 

You can save a workspace manually, or as a new version to avoid overwriting the current one.

How to save a workspace manually

 l Select Windows > Workspace > Save Workspace.

How to save your workspace as a new version

 1. Select Windows > Workspace > Save Workspace As.

The Save Workspace As dialog box opens.

 2. Type in a name for the workspace.
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Deleting a Workspace
You can delete a workspace from your list using the Workspace Manager. Note that you cannot delete the 
default worksapces.

How to delete a workspace

 1. Do one of the following:  

 l Select Windows > Workspace > Workspace Manager.

 l Select Windows > Toolbars > Workspace and in the Workspace toolbar, click the 
Workspace Manager  button.

 2. From the Toolbar list on the right, select the workspace to delete and click the Left Arrow  button 
to send it to the Available Workspaces list. This removes it from the Workspace toobar.

 3. From the Available Workspaces list on the left, select a workspace and click the Delete  button.

 4. Click OK.
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Showing and Hiding Workspaces
You can show and hide selected workspaces from the Workspace toolbar’s drop-down menu.

How to show a workspace

 1. Do one of the following:  

 l Select Windows > Workspace > Workspace Manager.

 l Select Windows > Toolbars > Workspace and in the Workspace toolbar, click the 
Workspace Manager  button.

 2. In the Available Workspaces list, select the workspace to be displayed. Click the Right Arrow  
button to send it to the Workspace toolbar.

How to hide a workspace

 1. Do one of the following:  

 l Select Windows > Workspace > Workspace Manager.

 l Select Windows > Toolbars > Workspace and in the Workspace toolbar, click the 
Workspace Manager  button.

 2. In the Workspace Manager, select the workspace to be hidden. Click the Left  Arrow button to 
send it to the Available Workspaces list.
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Reordering the Workspace List
You can edit the order that the available workspaces are listed in the Workspace toolbar’s drop-down menu.

How to reorder the workspace list

 1. Do one of the following:  

 l Select Windows > Workspace > Workspace Manager.

 l Select Windows > Toolbars > Workspace and in the Workspace toolbar, click the 
Workspace Manager  button.

 2. From the Toolbar list, select the workspace to be reordered and click the Up  or Down  Arrow buttons 
to move it up or down.
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Restoring the Default Workspace
T-SBFND-003-012

You can restore the modified workspaces to their original default layout. This is particularly useful if you have 
closed several views or moved toolbars.

How to restore the default workspace

 l Select Windows > Restore Default Workspace.
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Interface Navigation
Toon Boom Storyboard Pro lets you zoom in, zoom out, rotate, pan and reset views for easy navigation of the 
interface.

The navigation commands in the table below can be used in the following views, with some exceptions:

 l Stage

 l Camera

 l Timeline

 l Function Editor

 l Side and Top

Command Action Access Methods

Zoom In Zooms in the view. 

View > Zoom In

Press 2

Roll the mouse wheel up (except in the Timeline 
view)

Zoom Out Zooms out the view.

View > Zoom Out

Press 1 

Roll the mouse wheel down (except in the 
Timeline view)

Zoom In or Out Zooms in or out of the view.

Roll the middle mouse button up or down.

Hold down the Spacebar and the middle mouse 
button while dragging the mouse up or down.

Pan
Moves the view horizontally or 
vertically.

Hold down the Spacebar and drag in the direction 
you want to pan the view.

Reset Pan
Resets the view’s pan to its default 
position.

View > Reset Pan

Press Shift + N

Reset View
Resets the view to its default 
position.

View > Reset View

Press Shift + M
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Command Action Access Methods

Reset Rotation
Resets the view’s rotation to its 
default position.

View > Reset Rotation

Press Shift + X

Reset Zoom
Resets the view’s zoom to its 
default position.

View > Reset Zoom

Press Shift + Z

Rotate View Rotates the view left or right.
While holding Ctrl + Alt (Windows) or ⌘  + Alt 
(Mac OS X), click and drag the rotating disc to 
rotate it clockwise or counterclockwise.

3D Rotate View
Rotates the view in any direction. 
This is only available in the Stage 
view, if the scene is 3D-enabled. 

While holding Ctrl + Shift (Windows) or Shift + 
⌘  (Mac OS X), click and drag the stage to rotate 
it in any direction.

Rotate 30 CW
Rotates the Camera view 30 degrees 
clockwise, like an animation table.

View > Rotate View CW

Press V

Rotate 30 CCW
Rotates the Camera view 30 degrees 
counter-clockwise, like an animation 
table.

View > Rotate View CCW

Press C

Toggle Full Screen
Toggles between making the main 
application window full screen and 
restoring it to its original size. 

View > Toggle Full Screen

Ctrl + Alt + Shift + F (Windows) or ⌘  + Alt + 
Shift + F (Mac OS X)

Navigation Toolbar
Storyboards can easily become very extensive projects. The Navigation toolbar lets you quickly display the first 
and last frame of a panel.  These buttons grey out when the playhead is at the start or end of a panel.

To learn more about animatics and timing, see Animation on page 472.

How to access the Navigation toolbar

‣ Select Windows > Toolbars > Navigation.
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Icon Tool Name Description

First Frame Displays the first frame of the layer animation.

Last Frame Displays the last frame of the layer animation.
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Chapter 4: Storyboard Structure
T-SBFND-005-001

To build and organize your storyboard project, you will use panels, scenes, sequences, and acts. You have many 
options to customize these project elements in order to keep things clear and organized.

Below are examples of panels, scenes, sequences and acts in the Thumbnails and Timeline views.

 1. A panel represents an action. You can use multiple panels whenever you need more than one drawing to 
clearly express the acting within a scene. It is the white rectangle representing the camera view.  By 
default the current panel will be highlighted in red in the Thumbnails view.

 2. A scene is composed of one or several panels. In animation, whenever the camera angle changes, you 
should create a new scene. In live action, this is called a shot.In other words, if your action goes from a 
mid shot to a close shot, each of these shot should be a different scene. By default, a grey rectangle 
connects the different panels of a scene together.

 3. A sequence is a series of scenes that should be grouped together. Usually, scenes are grouped together 
by location. For example, all the scenes that are taking place in one location, should be in the same 
sequence and as soon as there is a change of location, it should be a new sequence. by default, a blue line 
connects the different scenes of a sequence together.

 4. An act is composed of one or several scenes and sequences. An act usually represents a story arc. It can 
be a certain time lapse in the story. For example, all the scenes in the first half of a TV series are one act, 
and the second act is after the commercial break. As for movies, live action, or even video games, there 
could have several different story arcs. In Storyboard Pro, a purple flag shows the beginning of a new 
act.
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About Scenes
T-SBFND-005-002

In live-action productions, scene changes occur when the location of the action changes, such as from the 
bedroom to the living room, from the living room to outside, from outside to across town. In traditional 
animation, every time a painted background has to be changed or the camera cuts, a scene change is required, 
even if the characters are in the same location. For example, two characters could be talking face-to-face in a 
forest, however the trees behind each character would be different as the shot cuts from one character to the 
other. Each shot would require a new scene. A sequence of these scenes taking place in the same location could 
be referred to as an act.

In Storyboard Pro, panels in the same scene are grouped together by a dark grey bounding box.

You can:

 l Create new scenes

 l Delete scenes

 l Rename scenes

 l Lock and unlock scene and panel names

 l Split scenes

 l Select all panels in a scene
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Creating Scenes
T-SBFND-005-003

When you create a new scene, it is usually added after a selected scene, but you can make the new scene 
appear before it. You can also create a new scene from a series of selected panels within a scene and then 
separate them as a new one.

How to create a new scene

 1. Do one of the following:

 l In the Storyboard toolbar, click the Add Scene  button.

 l Select Storyboard > Create Scene.

A new panel is created in the Timeline immediately after the current shot. The new panel is 
contained in a separate grey box.

Each scene is assigned a number. When you create a scene at the end of your project, Storyboard Pro 
automatically assigns it the number that comes right after the number of the last scene. If you try to insert a 
scene between two existing scenes, you will be prompted to indicate how this new scene should be named, 
and if scenes after the new scene should be re-numbered.

How to insert a scene between two existing scenes

 1. Select any panel the scene after which the new scene should be inserted.
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 2. Do one of the following:

 l In the Storyboard toolbar, click the New Scene  button. 

 l Right-click on a panel and select New Scene.

 l In the top menu, select Storyboard > New > New Scene.

The Rename Scene dialog appears.

 3. Do one of the following:

 l If you want the new scene to have a suffix, to indicate that it was inserted between existing 
scenes, you do not have to edit any of the fields. The New name field already contains the 
name of the currently selected scene followed by a letter suffix. For example, if you tried 
inserting a scene before scenes 2 and 3, Storyboard Pro will name the new scene 2_A by 
default.

 l If you want the scene to have the number after the number of the currently selected scene, 
and to renumber all subsequent scenes accordingly, enter this number in the New Name 
field. For example, if you're inserting a scene between scenes 2 and 3, type 3 in the New 
Name field. Then, in the Renaming Rule for Subsequent Scene dropdown menu, select 
Renumber Scenes.

 4. If you intend to use the same options whenever you insert a scene, check the Do not show this 
dialog automatically option.                                        

 5. Click OK.

A new scene, containing one blank panel, is added after the current scene, numbered according to 
your selected settings.
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How to create a scene before the current scene

 l Select Storyboard > New > New Scene Before.

A new scene containing a blank panel is added before the current scene.

How to create a scene from a selection of panels

 1. In the Thumbnails or Timeline view, select one or more consecutive panels.

 2. Select Storyboard > New > New Scene from Selected Panels.

The selected panels are joined together within the scene.
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Import Images as Scenes
T-SBADV-009-001

You can import one or more images and have Storyboard Pro automatically create a new scene for each. This 
useful when you have a series of bitmap images that you need to include, such as backgrounds or scanned 
storyboards.

The supported image formats include: *.bmp, *.jpg, *.omf, *.opt, *.pal, *.png, *.psd, *.scan, *.sgi, *.tga, *.tif, *.tvg, 
and *.yuv.

How to import images as scenes

 1. Select File > Import > Images as Scenes.

The Choose Image Files browser opens.

 2. Browse to the desired images, select one or more images, and click Open.

The images are imported and a new scene is created for one. 

NOTE 

By default, when importing images in Storyboard Pro, the images are vectorized in colour and 
imported in  vector layers. You can access more vectorization options by enabling the Display 
Vectorize Options Dialog preferences—see Importing Images as Layers on page 204.

Automatic Insertion
When using the Import Images as Scenes function, you can save a little time by using the following naming 
convention for your bitmap images when you scan. Having your bitmap images named in the following manner, 
will allow acts, scenes, panels and layers to be created upon import into Storyboard Pro.

How to use Automatic Insertion

 1. When scanning images, name them according to the following example:

<name>-A#-S#-E#-P#-L<layer name>.<extension>

 l Name: This is the name of the project. This string will not be inserted into the Storyboard Pro 
project, but it is mandatory.

 l A: Indicates the act the image will be placed in. Replace the # with the number of the act.

 l S: Indicates the first (or only) scene the image will be placed in. Replace the # with the 
number of the first scene this image will be used in.
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 l E: (Optional attribute) Use this attribute along with the S attribute if you want the image to 
be included in multiple scenes. Replace the # with the number of the last scene this image 
will be used in.

 l P: (Optional attribute) This attribute is to indicate which panel the image will be placed in. 
Replace the # with the number of the panel in the scene.

 l L: (Optional string) This string is to indicate the name of the layer where the image will be 
placed. Replace the # with the number of the layer in the scene.

 2. Select File > Import > Images as Scenes, and browse to the location on your computer where your 
images are saved.

99

Storyboard Pro 6. User Guide                          



Chapter 4: Storyboard Structure

The following are two examples of how the Automatic Insertion could be used:

How to use the Automatic Insertion

 1. The drawings are scanned and named as such:

 l RocketRodeo-A1-S103-P1-LBackground.jpeg

 l RocketRodeo-A1-S103-P2-LBackground.jpeg

 l RocketRodeo-A1-S103-P3-LBackground.jpeg

 l RocketRodeo-A1-S104-P1-LCity.jpeg

 2. Then, imported using the File > Import > Images as Scenes command, they are imported in the 
following order in the Storyboard Pro project:

How to use the Automatic Insertion using the E parameter

 1. A drawing is scanned and named like this: RocketRodeo-A1-S100-E102-P1-LBG.jpeg.

 2. Then, imported using the File > Import > Images as Scenes command, the image is placed in act 1, 
in scenes 100 through 102, on panel 1 on a layer called BG:
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Deleting Scenes
T-SBFND-005-004

If you have one or more scenes that are no longer needed, you can easily remove them. When you delete a 
scene or insert a new scene between two existing scenes, the numbering of the scenes will be out of order. By 
default, there is no automatic renaming of scenes. You can change this in the Preferences dialog box—see 
Renaming Scenes on page 103.

NOTE 

The last scene in your project cannot be deleted. There must always be at least one scene in the 
project.

How to delete a scene

 1. In the Thumbnails view, select a scene to delete. If it is composed of more than one panel, select 
them all. You can also click the minus sign (-) in the upper-left corner of the scene to collapse it into 
one panel. This will let you select all the panels with one click.

 

 2. Select Edit > Delete Selected Panels/Transitions or press Delete.

The selected scene is deleted from your storyboard.
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Renaming Scenes
T-SBFND-005-005

When you start moving scenes and panels around, the Rename Scene dialog box automatically opens and 
prompts you to rename them every time. You can also rename selected scenes as needed, using the Rename 
Scene command or the Panel view.

How to rename scenes with the Rename Scene command

 1. In the Thumbnails view, select a scene to rename.

 2. Select Storyboard > Rename Scene.

The Rename Scene dialog box opens.

 3. In the New name field, type the new name for the selected scene. You can type either a number or a 
name. 

 4. Use the Renaming Rule for Subsequent Scene menu and determine if the next scenes should be 
renamed. The Renumbered Scene Names section displays the current and new names for all the 
scenes that will be affected by the renaming process.
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 l Current Scene Only:Renames only the selected scene.

 l Renumber Scenes:Renumbers the current scene, as well as all the scenes that follow.

 l Renumber Selected Scenes: Renumbers the first selected scene of a multiselection, as 
well as all the following scenes that are part of the selection.

 l Renumber Prefix Only: Renumbers the scenes' numerical prefixes beginning at the 
selected scene. The new name must be a numerical value.

 5. Select the Reset Panel Name option to reset all panel names according to the current panel time 
automatic increment rule.

 6. Select the Do not show this dialog automatically option to prevent it from automatically opening 
every time you move scenes around.

How to rename a scene using the Panel view

 1. In the Thumbnails view, select a scene to rename.

 2. In the Panel view, type the new name or number for your scene in the Scene field.

 3. Press Enter to validate the scene name or number.

If the name is invalid or already used by another scene, a warning message will appear. If this 
happens, use the Rename command to rename all subsequent scenes.
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Locking and Unlocking Names
T-SBADV-004-009

It is possible to lock sequence, scene and panel names to prevent any unwanted modification.

NOTE 

To type custom panel names, you must enable the Allow Custom Panel Names preferences—see 
Locking and Unlocking Names on page 105.

How to lock scene and panel names

 l Select Storyboard > Lock Sequence, Scene and Panel Names.

The Scene and Panel fields become deactivated.

The Thumbnail view displays a locked icon in the header.

How to unlock scene and panel names

 l Select Storyboard > Unlock Sequence, Scene and Panel Names.

The names are unlocked and can be edited if necessary.
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Splitting Scenes
Using Storyboard Pro, you can split the current scene in two or break it into three parts. 

When you split a scene, it is divided before the current panel by default. 

NOTE 

You can change this in your preferences so that when you split a scene, it is broken into three parts 
and the selected panel is isolated. 

How to split the current scene

 1. In the Thumbnails view, select a scene to split. The current scene must contain two or more panels. 
The split will occur before the current panel.

 2. Select Storyboard > Split Current Scene.

The scene is split into two scenes.

How to break the current scene

 1. In the Preferences dialox box, select the General tab, and then select the Break Scene when 
performing the “Split Current Scene” command option. 

 2. In the Thumbnails view, select a scene to break. The current scene must contain two or more panels.
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 3. Select Storyboard > Split Current Scene.

The scene is divided in three.
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Selecting All Panels
T-SBADV-004-010

You can select all the panels in a scene, using the Select All Panels in Scene command.

NOTE 

You can also double-click on a panel's header to select all panels in the scene.

How to select all the panels of a scene

 1. In the Thumbnails or Timeline view, select one panel inside the scene you want to select all panels 
from.

 2. Select Edit > Select All Panels in Scene.
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Flipping Scenes
T-SBFND-009-024

This functionality enables you to easily flip a selection of scenes without flipping their layers one by one. This 
can be useful when re-using background elements.

Flipping the scene will flip all panels included in that scene, as well as the camera movements. Everything else 
will be kept the same, for example, keyframe timing.

Before:

After:

NOTE 

Flipping the scene flips all panels included in the scene. It is not possible to flip one or more panels 
in a scene without affecting the others. 

A 3D scene cannot be flipped.

How to flip a scene

 1. In Timeline view, select one scene or more.

 2. Do one of the following:

 l Select Storyboard > Flip Selected Scenes.

 l In the Thumbnails view, right-click on your selection and select Flip Selected Scenes.

 l In the Timeline view, right-click on your selection and select Flip Selected Scenes.

 l In the Storyboard Pro toolbar, click the Flip Selected Scenes   button. 
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 l Use the Flip Selected Scenes shortcut.
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Expanding and Collapsing Scenes
T-SBADV-004-006

As you work on a storyboard, you may accumulate a large number of scenes composed of a tremendous number 
of panels. You can collapse lengthy scenes into one panel to have more space in the Thumbnails view.

How to expand or collapse a scene

‣ In the Thumbnails view, click the Expand/Collapse Scene button at the top-left of a scene 
composed of many panels.

One of the following happens:

The scene collapses, leaving only the first panel visible. The Expand/Collapse icon changes to a plus 
(+) sign.

The scene expands to show all its panels. The Expand/Collapse icon change to a minus (-) sign.

How to collapse or expand all scenes

‣ In the Thumbnails view, click the Expand/Collapse All Scenes button at the top-right.
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Working with a Collapsed Scene
When your scene is collapsed, you can still work in the Timeline view. However when you select a panel, the 
entire scene is selected, not just one panel. This means that you cannot work only on a single panel in the 
Timeline view; you must first expand the collapsed scene.

IMPORTANT 

If you try to delete a panel in a collapsed scene, the entire scene will be deleted. You cannot delete a 
single panel. 
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About Panels
T-SBFND-005-006

Your scenes (shots) should comprise as many panels as needed to show the actions taking place. With 
Storyboard Pro, you can easily create many panels.

By default, you can find this information on the top of each panel:

You can: 

 l Create a panel

 l Delete a panel

 l Rename panels

 l Duplicate a panel

 l Move panels

 l Customize the panel colour
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Creating Panels
T-SBFND-005-007

When you create a new panel, it is added after the current panel.However, you can create a new panel before 
the current panel. You can also create a new panel that contains elements (layers) from another panel.

How to add a panel to a scene

 1. In the Thumbnails view, select the panel after which you want to insert a new panel.

 2. Do one of the following:

 l In the Storyboard toolbar, click the New Panel  button. 

 l Select Storyboard > New > New Panel. 

 l Press P.

A new panel is added to the storyboard and is part of the same scene as the current panel.

How to create a new panel before a selected panel

 1. In the Thumbnails view, select a panel.
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 2. Select Storyboard > New > New Panel Before.

A new panel is added before the selected panel and is inside the same scene.

How to use create a new panel that contain elements from another panel

 1. In the Thumbnails view, select the panel that contains the elements you want duplicate into the 
new panel.

 2. Do one of the following: 

 l Select Storyboard > Smart Add Panel.

 l In the Storyboard toolbar, click the Smart Add Panel  button.

The Smart Add Panel dialog box opens.

 3. Select the layers that contain elements you want to copy into the new panel.

 4. Select the Add default layer if missing option to create the default layers in the new panel if they 
are not part of the Smart Add Panel selection list.
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A new panel is created next to the selected panel. All layers are copied into the new panel, but only 
the layers you chose contain artwork.
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Renaming Panels
T-SBFND-005-009

You can rename panels one at a time using the Panel view or rename multiple panels using the Rename Panel 
command. But before you can rename panels, you must use the Preferences dialog box to enable the renaming 
of panel names. 

How to enable the renaming of panels

 1. Do one of the following:

 l Select Edit > Preferences (Windows) or Storyboard Pro > Preferences (macOS). 

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (macOS).

 2. In the Preferences dialog box, select the Naming tab.

 3. In the Panel section, select the Allow Custom Panel Names option.

How to rename a single panel

 1. In the Thumbnails view, select a panel to rename.

 2. In the Panel view, type a new name in the Panel field and press Enter.

The panel is renamed.
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How to rename multiple panels

 1. In the Thumbnails view, select a panel to rename.

 2. Select Storyboard > Rename Panel.

The Rename Panel dialog box opens.

 3. Type a new name in the New name field.

 4. You can use the Renaming Rule for Subsequent Panel menu to determine if the next scenes should 
be renamed:

 l Current Panel Only: Renames only the selected panel.

 l Renumber Panels: Renumbers the current panel, as well as all panels that follow.

 l Renumber Selected Panels: Renumbers the first selected panel of a multiselection, as 
well as all following panels that are part of the multiselection.

 l Renumber Prefix Only: Renumbers the panels’ numerical prefixes beginning at the 
selected scene. The new name must be a numerical value.

The Renumbered Panel Names section displays a list of the panels that will be renamed, their old 
names and the new names.
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Deleting Panels
T-SBFND-005-008

If there are panels you no longer need,  you can simply delete them. Note that it is impossible to have an empty 
project as there is a minimum of one panel.

How to delete panels

 1. In the Thumbnails view, select one or more panels to delete.

 2. Do one of the following: 

 l In the Storyboard toolbar, click the Delete Selected Panels  button. 

 l Select Edit > Delete Panel. 

 l Press Delete.

The selected panels are deleted from your storyboard.
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Duplicating Panels
T-SBFND-005-010

You can duplicate panels when you need an exact copy of an existing one.

How to duplicate panels

 1. In the Thumbnails view, select the panel or range of panels to duplicate.

 2. Do one of the following: 

 l In the Storyboard toolbar, click the Duplicate Selected Panels  button.

 l Select Storyboard > Duplicate Selected Panels.

A copy of the previous panel is created.

The duplicated panels are added at the end of the current scene. If the selection included panels 
from different scenes, new scenes are created for them.
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Moving Panels
T-SBFND-005-011

You can easily move panels in the Thumbnails and Timeline views to reorder, separate, or join them. Joining 
panels will make them part of the same scene.

You can reorder panels by clicking on the drag and drop handle  in the top left corner of the panel, then 
dragging the panel between the two panels where you want it to be moved. A red line will appear between 
two panels near your mouse cursor to indicate where the panel will be moved. 

TIP 

If you want to move several panels together, you can select them together, then click and drag the 
drag and drop handle of any panel in the selection. To select several panels in the Thumbnails view, 
do one of the following:         

 l Draw a rectangle in the Thumbnails view around all the panels you want to select.

 l While holding Shift, click on the first panel you want to add to your selection, then on the last 
panel you want to add to your selection. Every panel in-between will also be selected.

 l While holding Ctrl (Windows) or ⌘  (macOS), click on each panel that you want to add to your 
selection.

If you move a panel to the space between two scenes, you have the option of attaching the panel to the scene 
before or after this space, or to drop it into its own new scene. Where the scene will end up depends on how 
close to either scene you drop it. The red line that appears between the two scenes will indicate whether it will 
be attached to the scene before or after the space where the panel is being dropped, or moved to its own new 
scene.

121

Storyboard Pro 6. User Guide                          



Chapter 4: Storyboard Structure

You can join selected panels with another scene. Just drag the panel onto the edge of the scene you want it to 
attach to, and drop it when you see a right-facing or left-facing bracket appear.

To reorder selected panels in the Timeline view, drag and drop them when you see a green bracket or green 
shape. 

You can drag and drop a selection to remove it from a scene. Just drag the selection out and drop it between 
two scenes when you see a rounded green rectangle shape appear.

How to drag and drop panels

 1. In the Thumbnails or Timeline view, select one or more panels to move.
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 2. Click the header of the current panel and drag it to the new location.

 l When you move your cursor, a thumbnail with a number is displayed. The number 
represents the number of selected panels being moved.

 l In the Thumbnails view, a straight red line or a red bracket represents what the 
movement will do.

 l In the Timeline view, a green bracket or a green shape represents what the 
movement will do.
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Customizing the Panel Colour
T-SBADV-004-007

You can mark panels with a custom colour to quickly identify and manage them. You can also do this for audio 
clips—see Sound on page 598.

How to customize a panel with colour

 1. In the Timeline view, select the panel you want to mark with colour. You can also make a multiple 
selection.

 2. Right-click on your selection and select one of the following option: Set Colour > Red, Orange, 
Yellow, Green, Blue, Purple or Custom. Choosing custom, will open a Colour Picker dialog box, in 
which you can select the colour of your choice.

The selected panel will change to the colour you have chosen.

How to reset the panel colour

 1. In the Timeline view, select the panel you want to reset the colour to default. You can also make a 
multiple selection.

 2. Right-click on your selection and select Set Colour > Default Colour. 

The selected panel colour will reset to the default colour.

124



NOTE 

The default colour of panels is grey. However, you can change this value in the Preferences 
dialog box.
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Copying and Pasting Panels Between Projects
By opening two projects at the same time, you can copy and paste panels between projects, allowing you to 
reuse your assets more efficiently. To do this, you can simply launch two instances of Storyboard Pro, open the 
source project in one instance, the destination project in the other instance, and copy and paste between both 
instances.

NOTE 

On Windows, you can launch two instances of Storyboard Pro by launching it from the desktop or 
Start menu twice. On macOS, you must launch Storyboard Pro from the Finder application in order 
to be able to launch two instances of it. If you attempt to launch Storyboard Pro from the dock 
twice, it will only launch it once.

How to launch two instances of Storyboard Pro

 1. Do the following twice:

 l On Windows: Open the Start menu, then select  All Programs > Toon Boom  Storyboard 
Pro > Storyboard Pro.

 l On macOS: Open Finder, then go to Applications > Toon Boom  Storyboard Pro 
> Storyboard Pro. 

How to copy and paste panels between two projects

 1. Launch two instances of Storyboard Pro, and open your first project in the first instance, and your 
second project in the second instance.
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 2. In the project containing the panels you want to copy, in the Thumbnails or Timeline view, select the 
panel or panels you want to copy.

 3. Do one of the following:

 l In the top menu, select Edit > Copy Panels.

 l Press Ctrl + C.
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 4. In the project in which you want to paste the panels, in the Thumbnails or Timeline view, select the 
panel after which you want the copied panels to be inserted.

 5. Do one of the following:

 l In the top menu, select Edit > Paste Panels.

 l Press Ctrl + V (Windows) or ⌘  + V (Mac OS X).

The panels you copied from the first project will be inserted in the second project, right after the 
selected panel. 
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NOTE 

If you pasted the panels between two scenes, it will create a new scene and prompt you 
to decide how the new scene and subsequent scenes should be named—see Creating 
Scenes on page 95.
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About Sequences
T-SBADV-004-011

A sequence is a particular section of the story composed by one or several scenes that has a unity in either time 
or its location. Scenes that are contained in different sequences can have the same name. Like scenes, panels, 
and acts, you can manipulate the sequences of your story while you are building your storyboard. 

You can:

 l Create a sequence

 l Remove all sequences

 l Rename a sequence

 l Split and join sequences

 l Select all panels in a sequence
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Creating Sequences
T-SBADV-004-012

A sequence is a way of grouping scenes together. Using them is optional, but they can help organize your 
storyboard. For example, you can use sequences to group scenes that are part of the same setting together. 

When you start building a storyboard, by default, your scenes will not be part of any sequence. To use 
sequences in your project, you can take one of the two following approaches:

 l After you have created all the scenes that should be part of your first sequence, simply use the New 
Sequence command to create your next scene. All the scenes that are already in your project will be 
grouped together in the first sequence of your project, and a new scene, which will kick off the second 
sequence, will be added at the end of your project. 

From that point on, you can use the New Sequence command whenever you have to create a scene that 
should start off another sequence. 

 l After you have created all the scenes required for your project, you can split your storyboard into 
sequences by selecting scenes that should be part of the same sequence, grouping them together in a 
new sequence, and repeating the process until every scene is in the appropriate sequence. 

NOTE 

In live action terminology, a sequence is referred to as a scene, whereas what is referred to as 
scenes in animation terminology is instead referred to as shots.

How to create a new sequence

 1. Do one of the following:

 l In the Storyboard toolbar, click the New Sequence  button. 

 l Select Storyboard > New > New Sequence.

A new scene is added to your project and is now the starting point of a new sequence. 
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If this is the first sequence you add to a project, all scenes prior  to it will be combined into a separate 
sequence. Violet-coloured sequence markers will also become visible in both the Thumbnails and 
Timeline views.

How to create a new sequence from a selection

 1. In the Thumbnails or Timeline view, select all the scenes you want to put into a new sequence. To do 
this, while holding Shift, click on the first scene to be part of the new sequence, then on the last 
scene to be part of the new sequence. This selects every scene between the scenes you clicked on, 
inclusively. 

 2. Do one of the following:

 a. In the top menu, select Storyboard > New > New Sequence from Selection.

 b. Right-click on the selection, then select New Sequence from Selection.

Your selection becomes a new sequence. 

If this is the first sequence you add to your project, all the scenes before the selection will be grouped 
together into a separate sequence, and all the scenes after the selection will be grouped together 
into another sequence. Violet-coloured sequence markers will become visible in both the 
Thumbnails and Timeline views.

NOTE 

Sequences must include whole scenes. If you only select some of the panels in a scene, the 
whole scene will be included in the sequence.
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How to enable the Automatically Create New Sequence preference

 1. Do one of the following:

‣ Select Edit > Preferences (Windows) or Storyboard Pro > Preferences (macOS).

‣ Press Ctrl + U (Windows) or ⌘  + , (Mac OS X).

 2. In the Preferences dialog box, click the General tab.

 3. In the General section, select the Automatically Create New Sequence option.
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Renaming Sequences
T-SBADV-004-013

Once you start adding sequences to your project, the Sequence field will become visible in the Panel view, 
allowing you to view the selected sequence's name and edit it if needed.

You can rename a selected sequence using the Panel view or Rename Sequence command.

How to rename a sequence using the Panel view

 1. In the Thumbnails view, select a sequence to rename.

 2. In the Panel view, type the new name or number for the selected sequence in the Sequence field 
and press Enter/Return.

How to rename sequences with the Rename Sequence command

 1. In the Thumbnails view, select a sequence to rename.

 2. Select Storyboard > Rename Sequence.

The Rename Sequence dialog box opens.
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 3. In the New name field, type the new name for the selected sequence. You can type either a number 
or a name. If you type a name or a number that is already used by another sequence, a warning 
message will appear.

 4. You can use the Renaming Rule for Subsequent Sequence menu to determine how the next 
sequences should be renamed. The Renumbered Sequence Names section displays the current and 
new names for all the sequences that will be affected by the renaming process.

‣ Current Sequence Only: Renames only the selected sequence.

‣ Renumber Sequences: Renumbers the current sequence, and the ones that follow.

‣ Renumber Selected Sequences: Renumbers the first selected sequence of a multiselection, as 
well as all the following sequences that are part of the multiselection.

‣ Renumber Prefix Only: Renumbers renumbers the sequence numerical prefixes beginning at 
the selected sequence. Note that the new name must be a numerical value.
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Removing Sequences
T-SBADV-004-014

The sequences in your project can all be removed at the same time.

How to remove all sequences from a project

 l Select Storyboard > Remove All Sequences from Project.

All sequences are removed from your project.
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Joining and Splitting Sequences
T-SBADV-004-015

Two sequences can be joined using the Join Selected Sequences command. A sequence can also be split in two.

How to join sequences

 1. In the Thumbnails or Timeline view, select two consecutive sequences.

 2. Select Storyboard > Join Selected Sequences.

The selected sequences are joined as one.

How to split a sequence

 1. In the Thumbnails or Timeline view, select the scene before the sequence to be split.

 2. Select Storyboard > Split Current Sequence.
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The sequence is split in two and the Rename Sequence dialog box opens, prompting you to rename 
the second portion of the split sequence—see Joining and Splitting Sequences on page 137

138



Selecting All Panels in a Sequence
T-SBADV-004-016

You can select all the panels of a sequence simultaneously.

How to select all the panels in a sequence

 1. In the Thumbnails or Timeline view, select a panel in the sequence you want to select all panels from.

 2. Select Edit > Select All Panels in Sequence.
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About Acts
T-SBADV-004-017

An act is a particular section of the story delimited by a particular event or mood. 

For example, a story could be constructed in three acts:

 l Act 1: The initial situation, character introduction.

 l Act 2: The journey.

 l Act 3: The resolution.

Like scenes, panels and sequences, you can manipulate acts when building your storyboard. To add acts to your 
storyboard, you must first enable the option.

You can:

 l Enable acts

 l Create an act

 l Join acts
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Enabling Acts
T-SBADV-004-018

By default, the acts are disabled. You must enable them in the Preferences dialog box.

How to enable acts

 1. Open the Preferences dialog box:

 l Select Edit > Preferences (Windows) or Storyboard Pro> Preferences (macOS).

 l Press Ctrl + U (Windows) or ⌘  + , (Mac OS X).

 2. In the Preferences dialog box, select the General tab.

 3. In the  General section, select the Enable Acts option.

A purple flag appears at the beginning of your project, indicating the act.
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Starting New Acts
T-SBADV-004-019

Once you have enabled acts in your storyboard project, your entire animatic will be in Act 1. You can then start 
breaking it into several acts. 

How to start new acts

 1. In the Thumbnails view, click the panel where you want to create a new act.

 2. Do one of the following:

‣ Select Storyboard > New > Start New Act. 

‣ Right-click the selected panel and select Start New Act.

The Rename Scene dialog box is displayed.

 3. Enter a name for the new act and click OK.

The act is divided in two at the point you selected.
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Joining Acts
T-SBADV-004-020

Once an act has been split, it is possible to join acts at any time.

How to join acts

 1. In the Thumbnails view, select the last panel and first panel of the acts you want to join. 

You can also join more than two sections by selecting the last panel of the first section until the first 
panel of the last section you want to join.

 2. Do one of the following:

 l Select Storyboard > Join Selected Acts 

 l Right-click the selected panel and select Join Selected Acts.
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Selecting All Panels in an Act
T-SBADV-004-021

You can select all the panels of an act simultaneously. 

How to select all panels in an act

 1. In the Thumbnails or Timeline view, select a panel contained in the act in which you want to select 
all the panels.

 2. Select Edit > Select All Panels in Act.
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Setting a Default Layer Layout for New Panels
After you've set up layers in a panel, you can decide that the layout of the layers in this panel should be the 
default layout to use when creating new panels. This can save you time when creating panels for your 
storyboard, as you won't have to create, name and organize layers you need to have in each panel over and 
over again.

When you create a default layout, it is based on the layout in the current panel. It will include the layers, their 
name, their layer type (vector or bitmap), the layer groups and their hierarchy and the order in which layers are 
ordered in the panel. However, it will not preserve the artwork in the layers of the current panel. Hence, if you 
have a panel with an ideal layer layout but which already contains artwork, you can simply use that panel to 
create the default layout. New panels will have the same layer layout, but will not contain any artwork. 

NOTE 

The default layer layout is saved to your preferences and is applied every time you create a new 
panel in any project. 

How to configure the default layer layout for new panels

 1. In the Layer panel of the Stage or Camera view or in the Layers view, organize your layers the way 
you want them to be organized when you create a new panel:

 l Create as many layers as you want to have in new panels. 

 l Arrange them in the right order.

 l Group them as needed.

 l Give layers and groups their appropriate default names. 

 2. In the top menu, select  Layer > Set Layer Layout as Default.

Next time you create a panel, it will have the same layout of layers and groups as the current panel. 
The layout is saved in your preferences, so you do not need to preserve the panel and you can make 
changes to it without affecting the default layout.
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Regenerating Thumbnails
T-SBADV-004-008

You can get the most up-to-date thumbnails in the Thumbnails view. As you draw, a series of small images 
(thumbnails) is generated. These thumbnails are automatically refreshed based on the refresh duration you set 
in the Preferences dialog box (Advanced tab, Delay Before Updating Thumbnails parameter).

You can choose update thumbnails immediately. This deletes all cached thumbnails in the Thumbnails and 
Timeline views, and forces new thumbnails to be regenerated. 

How to regenerate all thumbnails

 1. Select File > Regenerate All Thumbnails. 

 2. In the dialog box that opens, click Yes. 

IMPORTANT 

This cannot be undone. All existing thumbnail images in the Library will be deleted.

All thumbnails are deleted and replaced with the regenerated ones.
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Chapter 5: Captions
T-SBFND-006-002

Captions are text fields you can edit to include special indications and notes specific to a panel in your 
storyboard. These text indications can be dialogue, action notes, sound effects, and more. You can customize 
the captions to include any information related to your project.

When you start your storyboard from a script, the caption fields are where you will break down the script to 
build the various scenes, panels, sequences, and acts of your project.

To add information to a particular panel, you will use the Panel view. This view displays the different captions 
related to a panel, as well as other useful information.

The Panel view always shows the information and captions of the selected panel—see Panel View in the 
Reference Guide.
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Importing Scripts
T-SBFND-006-001

A complete storyboard is not only made of drawings, but also dialogue, actions, and valuable indications. In 
Storyboard Pro, you can easily import a script into your storyboard project to help edit captions.

You can import a script in plain text (.txt), Rich Text Format (.rtf) or Final Draft XML (.fdx) directly into the Script 
field of the Storyboard view.

NOTE 

If you are using Final Draft 7 or earlier, you must export your script in .xml format using Tagger, as 
the native file format of Final Draft 7 and earlier (.fdr) is not supported by Storyboard Pro.

How to import a script into your Storyboard Pro project

 1. In the Storyboard view, click the Caption Menu  button and:

 l If your script is in plain text (.txt) or Rich Text Format (.rtf), select Import Caption.

 l If your script is in Final Draft XML (.fdx) format, select Import Final Draft Script.

 2. In the file browser, locate and select your script file, then click on Open.

The script appears in the Script caption field.
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Adding Captions
In each panel, there are four caption fields: Dialogue, Action Notes, Slugging and Notes. If you need to enter 
more information, you can add a new caption for your panels. The new caption will be available for every panel 
in your storyboard.

In the Storyboard view, by default, there is only one caption field which is called Script. If you need to, you can 
add more captions to this view such as production notes. These captions are only for reference and will not be 
exported.

Just like in a traditional storyboard, you can add drawn indications to a panel’s caption. For this, you need to 
add a Sketch caption to your panel. 

NOTE 

You cannot add a sketch caption to the Storyboard view.

How to add captions to a panel

 1. In the Thumbnails view, select a panel.

 2. Do one of the following:

‣ In the Panel view, click a Caption Menu button  and select Add Caption. 

‣ Select Caption > Add Caption to Panels.

The Choose Field Name dialog box opens.

 3. Type a name for your new Caption field. In the following example, the caption is named: SFX.

The new caption appears below the existing ones.

How to add captions in the Storyboard view

 1. In the Storyboard view, do one of the following:
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‣ Click a Script Caption Menu button  and select Add Caption. 

‣ Select Caption > Add Caption to Storyboard.

The Choose Field Name dialog box opens.

 2. Type a name for your new Caption field. 

The new caption appears below the Script caption. In the following example, the caption is named: 
Director Notes.

How to add a sketch to a panel

 1. In the Thumbnails view or Timeline view, select the panel to which you want to add a sketch.

 2. Do one of the following:

‣ In the Panel view, click a Caption Menu button  and select Add Sketch. 

‣ Select Caption > Add Sketch to Current Panel.

The Choose Field Name dialog box opens.

 3. Type a name for the Sketch field.

The Sketch field appears below the existing captions for this panel only.
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 4. Once you added a Sketch caption field, you can use any drawing tool to sketch in it—see Drawing 
on page 210 and Colour on page 428.
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Renaming Captions
T-SBFND-006-005

If it is more convenient for you, you can rename the captions. 

How to rename a caption

 1. In the Panel or Storyboard view, do one of the following: 

 l Select Caption > Rename Caption and then select the caption to rename from the list. 

 l In the caption to rename, click the Caption Menu  button and select Rename Caption.

 2. Type a new name for your caption field.

NOTE 

After you have changed the names of the captions and you are certain you want to keep these 
names throughout the project, you can set the new names as the default by selecting Caption 
> Save Captions Layout as Default.
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Deleting Captions

How to delete captions

 1. Display the Panel or Storyboard view, depending on whether it is a panel caption or storyboard 
caption you want to delete.

 2. In the Panel or Storyboard view, select a caption to delete. Click the Caption Menu  button and 
select Delete Caption. You can also select Caption > Delete Caption > select a caption to delete from 
the list.

A warning message opens.

‣ If you are sure you want to delete the caption, click Yes.

‣ If you want to cancel the process, click No.
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About Default Panel Captions
T-SBFND-006-003

There are several fields which are collectively known as panel captions. Captions are a method by which you 
can organize information in your project, and tie that information to a panel.  The types of captions for your 
project are fully customizable. By default, a new project will have the following type of captions:

 l Dialogue: The lines of dialogue spoken by the characters in the current panel. 

 l Action Notes: The actions performed by the characters in the current panel. 

 l Slugging: Notes regarding the timing of dialogues and actions in the current panel. These can be added 
while creating the storyboard to give instructions on how to create the animatic. 

 l Notes: Any relevent information about the current panel or the current scene, such as the scene 
heading, the characters and props, ambient sounds, background and foreground actions, continuity 
notes or, if working on a live action project, the cast, crew, props or material required to complete the 
shot.
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Saving the Caption Layout as Default
T-SBADV-004-003

When you are satisfied with your current caption combination and layout, you can save it as the default caption 
layout for any future Storyboard Pro projects. The next project you create will automatically have this layout by 
default.

How to save the caption layout as default

 l Select Caption > Save Captions Layout as Default.
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Expanding and Collapsing Captions
T-SBADV-004-001

When you have more than one caption field in a panel, you can expand or collapse them. Note that there must 
be more than one caption field in a panel in order to do this.

How to expand and collapse captions

 1. Display the Panel or Storyboard view. 

 2. Click the Expand and Collapse  button of the desired caption.

 3. On the first click, the selected caption expands and the other ones collapse.

 4. On the second click, the selected caption collapses and the other ones expand.

 5. On the third click, all the captions return to their original state
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Hiding Captions
T-SBADV-004-002

When there are captions you do not use regularly, you can hide them to streamline your workspace.

How to hide a caption in the Panel view

 1. Select Caption > Show/Hide Captions.

The Show/Hide Captions dialog box opens.

 2. Deselect the captions you want to hide. If you have added your own custom captions, they also 
appear in the list. Any captions that you renamed appears as you renamed them.
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Adding Text to Captions
T-SBFND-006-004

There are several ways to add text to a Caption field, and editing it is very easy. The quickest and easiest way 
to add text to the caption fields is to drag and drop it. For example, if you imported a script into the Script 
caption field of the Storyboard view, you can select the text you need and drop it in the desired panel’s caption 
field.

If you did not import a script or if you want to add more text, you can simply type in the needed instructions and 
information into the caption field.

How to add text to a caption

 l In the Panel view, click in a caption field and type the information, dialogue, or notes.

How to drag and drop text from the script into caption fields

 1. Switch to the Vertical workspace by doing one of the following:

 l In the Workspace toolbar, clicking on the Vertical Workspace  button.

 l From the top menu, select Windows > Workspace > Workspace > Vertical. 

 2. In the right pane of your workspace, select the Storyboard tab. 

Your workspace now has a vertical roll of each panel in your storyboard to the left, with their 
corresponding caption fields in the middle, and the script for your storyboard to the right. 
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 3. In the Thumbnails view, scroll to the panel in which you want to add captions.

 4. In the Script caption field of the Storyboard view, select the part of your script that you want to add 
to a panel caption. 

 5. In the Script caption, drag the selected text and drop it in the appropriate caption field of your 
panel.

 6. Repeat this until you have copied all the necessary text for each of your panels into their caption 
fields.

 7. Once you are done, you can restore the workspace you were using by selecting it from the 
Workspace toolbar or from the top menu, in Windows > Workspace > Workspace. 

NOTE 

You can also drag and drop text from any panel caption to another panel caption, or from a 
panel caption to the script. 
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Formatting Caption Text
Once you have imported, dragged and dropped, or typed some text into your storyboard captions, you can use 
the Text Formatting toolbar to enhance it.

How to apply Rich Text formatting to caption text

 1. In the Panel or Storyboard view, click  the Text Formatting  button of a caption.

 2. In a caption, select the text to format.

 3. Use the Text Formatting toolbar buttons and options to edit the text.

‣ Font Type: Choose the font type of your choice from this menu.

‣ Font Size: Change the size of the text using menu.

‣  Bold: Click the Bold  button to change the text to bold.

‣  Italic: Click the Italic  button to change your text to italic.

‣ Underline: Click the Underline  button to underline your text.

‣  Align Left: Click the Align Left  button to align your text to the left.

‣  Centre: Click the Centre  button to centre your text.

‣ Align Right: Click the Align Right  button to align your text to the right.

‣  Justify: Click  the Justify  button to justify your text.

‣ Colour: Click  the Colour Swatch  button to open the Select Colour dialog box and choose a 
new colour for your text.
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Setting the Default Caption Format
If you want to always use a specific font type and font size for all captions, you can set the default format by 
using the Default Caption Format dialog box. This sets the default caption font face and font size for new 
captions, but does not affect the formatting of existing captions or of new text typed into existing captions. 

How to set the Default Caption Format

 1. In the top menu, select Caption > Captions Default Format.

The Default Caption Format dialog box opens.

 2. In the Font drop down, select the preferred default font face.

 3. In the Font Size drop down, select or type the desired default font size.

 4. Click Ok.

NOTE 

The Default Captions Format is saved in your local preferences and will affect 
new captions in all projects.

163

Storyboard Pro 6. User Guide                          



Chapter 5: Captions

Searching Text in Captions
T-SBADV-004-004

You can search captions to find a specific part of your text. This can become very handy when you have a large 
number of captions and text in your project.

How to search for text in captions

 1. In the Panel or Storyboard view, select any caption field.

 2. Do one of the following:

‣ Click the Caption Menu button and select Find Text in Captions. 

‣ Select Caption > Find Text in Captions. 

‣ Press Ctrl + Shift + F (Windows) or ⌘  + Shift + F (Mac OS X).

The Find Text in Captions dialog box opens.

 3. Edit the search options:

‣ In the Find field, type in the word you are looking for.

‣ Select the Case sensitive option to have the search consider the case of the word.

‣ Select Forward or Backward for the search direction.

 4. Click Find.

The caption containing the first word fitting your search options is displayed in either the 
Storyboard or Panel view, and the word is highlighted in blue. The Find Text in Captions dialog box 
displays information about the caption in which the word was found.
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 5. Click Find to display the next result.
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Updating Captions from CSV
T-SBADV-004-005

In Storyboard Pro, you can efficiently update the caption text in your project.  If you generate a *.csv sheet 
(comma separated values) from your project, you can update the file, then import it into Storyboard Pro. Doing 
so will update all caption fields automatically. You must first generate the CSV from your current project.

How to generate a CSV from your current project

 1. Make sure your caption fields are up to date, and save your project.

 2. Select File > Export > CSV.

The Export to CSV dialog opens.

Once you have generated the CSV, you can update your spreadsheet if there are major changes, 
such as the dialogue. Working this way allows you to import the updated CSV into Storyboard Pro 
to update all caption fields.
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How to use the Update Captions from CSV option

 1. When you open the *.csv file in your spreadsheet application, select the field separator you used 
(i.e.: a comma).

The heading of each column contains the name of the caption field. Use this to determine where to 
add your caption updates.

 2. Find the captions you need to modify within the *.csv file. When you are finished, save and close 
your file.

 3. Open the Storyboard Pro project you want to update.

 4. Select File > Update Captions from CSV.

The Import CSV window opens.

 5. Browse to the folder that contains your *.csv file, select it, and click Import.

 6. In the Report section, notice which caption fields were updated.
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Any captions you modify in the *.csv file are also updated in the caption fields of your Storyboard 
Pro project.CSV files exported from Storyboard Pro are UTF-8. CSV files can be modified in 
Microsoft Excel if all the characters are part of the Latin character set. If non-Latin characters are 
used, the CSV files can be edited using Open Office.CSV files exported from Storyboard Pro can be 
edited in either Microsoft Excel or Open Office. Excel does not display non-English characters 
properly and will not recognize them when importing to Storyboard Pro.
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Chapter 6: Layers
T-SBFND-007-001

Storyboard Pro allows you to work with layers. Each panel in your project has its own list of layers, each of 
which can contain a separate drawing. 

Composed together, the layers make the drawing that appears in your panel. Working with layers allows you 
to keep separate elements in your panels, such as backgrounds, characters and props, into separate drawing 
spaces, as well as to manipulate or animate them if needed.

When you create a new project, or add a new scene or panel to your project, the panel will always have two 
layers by default: A character or prop layer (A) and a background layer (BG). You can add as many layers as you 
need to a panel, and you can also rename, reorder and delete layers.

Once your layer list is set up for your panel, you can start drawing on each layers. To draw on a specific layer, 
simply select this layer in the Layer panel, the Thumbnails view or the Layers view. When you use a drawing 
tool in the Stage view, the artwork you create or edit is always the one in the currently selected layer. Hence, 
you must always mind which layer is selected when drawing or editing your artwork. 

A layer in a panel can be copied into your library then added to another panel. Hence, drawing your scene 
elements on multiple layers can allow you to reuse drawings when a later panel or scene features the same 
element.
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Viewing the List of Layers
The go-to way of selecting and managing layers in a panel is to use the Layer panel, which is, by default, in the 
right section of the Stage and Camera views.

However, it is also possible to add the Layers view to your workspace, which works the same way. You can then 
hide the Layer panel by clicking on its Collapse  button in its top-left corner, leaving more space to work in 
the Stage and Camera views. 

You can also manage layers using the Thumbnails view. If the size of the Thumbnails view is big enough, each 
panel in it will have a vertical list of layers on its right edge, which allows you to scroll through and select layers. 
Left of the Thumbnails view, under the Tools toolbar, is a Layer toolbar, which allows you to add and remove 
layers to the selected panel.
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There are several ways to display layers in Storyboard Pro. The two main ways are in the Layer panel of the 
Stage and Camera views, and the Layers view. Both views display a thumbnail of each layer, followed by their 
name and some toggle buttons to control the behavior of your layers.

How to view or hide layers in the Stage or Camera view

 1. In the Stage or Camera view, do one of the following:

 l If the Layer panel is displayed, click on the Collapse  button in its top-left corner to 
collapse the panel.

 

 l If the Layer panel is hidden, click on the Expand  button in the top-right corner of the 
view to display the panel. 

How to view layers in the Layers view

 1. Do one of the following: 
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 l In the upper-right corner of a view, click the Add View  button and select Layers. 

 l Select Windows > Layers.

The Layers panel displays all the layers in the selected panel.
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About Layer Types
T-SBFND-007-002

Storyboard Pro supports four types of layers: Vector drawing layers, bitmap drawing layers, 3D layers and 
groups.

 l Vector Layers: Vector drawings are made of points and curves that compose the contours of the shapes 
of the artwork, along with the colour or textures these shapes are filled with. Hence, the artwork in 
vector layers can be scaled up and zoomed in without losing quality, unless they contain a texture.

When drawing on a vector layer, each drawing stroke and pencil line is a separate object which can be 
manipulated individually. You can select single drawing strokes, then move them around and transform 
them, even if drawing strokes were applied over them. Additionally,  because drawing strokes are made 
of points and curves, it is possible to edit their shape, making it easy to make corrections and changes to 
your artwork.

 l Bitmap Layers: Bitmap drawings are composed of a grid of pixels, which are small points that each have 
a single solid colour. Bitmap drawing tools allow you to lay on brush strokes onto a single flat canvas, and 
to tweak your artwork by the pixel if needed.

When you draw on a bitmap layer, each stroke is composited into the canvas, so it remains a single 
drawing that can only be painted or erased upon, but which does not allow you to tweak individual parts 
of it. 

Bitmap artwork can only be scaled up or zoomed in on as much as their pixel density allows without 
losing picture quality. By default, bitmap artwork has a pixel density of 100%, which is only enough to 
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display the artwork without zooming in on it or scaling it up, otherwise Storyboard Pro must generate 
new pixels within the artwork, which is liable to make it look blurry or pixelated. 

Hence, you might want to set the required pixel density for your bitmap artwork, based on whether 
you'll need to zoom on it or scale it up, before you start drawing on a bitmap layer—see Setting the 
Resolution of Bitmap Layers on page 202. 

 l 3D Layers: When you import a 3D model into your library, adding it to a panel will store the model into a 
3D layer. You can then manipulate and animate the 3D model, just like you can with a drawing layer.

 l Group: A group can contain several layers of any type. Just like you can transform and animate a layer, 
you can also transform and animate a group. Transformations and animations applied to a group will 
affect every layer inside the group simultaneously—see Grouping Layers on page 185.

In the Layer panel of the Stage or Camera view, layers can be quickly identified by their type by referring to the 
small colour bar on their left edge. 
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Adding Layers
T-SBFND-007-003

By default, a panel contains a background (BG) and a drawing layer (A), but you can add as many layers as you 
need to each panel in your project.

NOTE 

When adding a layer, you must decide if you need to add a vector layer or a bitmap layer. In most 
use cases, vector layers are preferable. For more information on layer types and how to choose the 
right type of layer to add, see About Layer Types on page 174.

How to add a layer to a panel

 1. In the Thumbnails or Timeline view, select the panel to which you want to add a new layer.

 2. In the Layer panel of the Stage or Camera view, the Layers view or the Thumbnails view, select the 
layer over which you want to create a new layer.

 3. Do one of the following: 

 l Click on the Add Vector Layer  or Add Bitmap Layer  button. These buttons are 
located at the bottom of the Layer panel in the Stage and Camera views, at the 
bottom of the Layers view and in the Layer toolbar.

 l In the top menu, select Layer > New > Vector Layer or New Bitmap Layer. 

NOTE 

If you added a bitmap layer, and you intend to scale it up or zoom in on it, make 
sure to increase its pixel density before you start drawing on it—see Setting the 
Resolution of Bitmap Layers on page 202.
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Selecting Layers
T-SBFND-007-004

You can select any layer from the Stage view, Layers panel, or Thumbnails view. Selected layers turn blue.

How to select a layer 

 1. Do one of the following:

 l Stage view and Layers panel: Click the layer you want to select. 

 l Thumbnails view:  Click the layer tab of the layer you want to select. Arrows above and 
below the layer tabs indicate additional layers.

 l To select multiple layers, press Ctrl (Windows) or ⌘  (macOS) and click each layer you 
want to select. Also, press Shift and click one layer and then another to select a 
sequence of layers.

How to select the next and previous layers

 1. Select a layer.

 2. From the top menu, select one of the following: 

 l Layer > Select Next Layer to select the next layer up the layer stack, stopping at the 
top of the stack.

 l Layer > Select Previous Layer to  select the next layer down the layer stack, stopping 
at the bottom of the stack.
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Duplicating Layers
Duplicating layers is a quick way to perform a quick copy and paste in one operation. Unlike copying a layer, you 
cannot paste multiple copies of a layer on other panels. Duplicating layers is only available within one panel. 
Duplicated layers retain their names and are appended with a number.

How to duplicate a layer

 1. Select a layer and do one of the following:

‣ Right-click the layer and select Duplicate Selected Layers.

‣ In the Stage view, Layers panel or Layers toolbar, click the Duplicate Selected Layer  button.

‣ Select Layer > Duplicate Layers.
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Renaming Layers
T-SBFND-007-006

When layers are named appropriately, you can work faster and keep track of all the layers.

How to rename a layer

 1. Select the panel with the layer you want to rename.

 2. Do one of the following:

 l Select Layer > Rename Layers.

 l Right-click the layer’s tab and select Rename Layer.

 l Double-click the layer tab.

 3. In the Change Layer Name dialog box, type in a new name for the layer.
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Deleting Layers
T-SBFND-007-005

You can delete layers that you do not need to avoid cluttering the layer list.

How to delete a layer from a panel

 1. In the Layer panel of the Stage or Camera view, the Layers view or the Thumbnails view, select the 
layer you want to delete. 

 2. Do one of the following:

 l Click on the Delete Selected Layers  button. This button is located at the bottom of 
the Layer panel in the Stage and Camera views, at the bottom of the Layers view and 
in the Layer toolbar.

 l Right-click the layer and select Delete Layers.                         

 l In the top menu, select Layer > Delete Layers.
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Copying Layers
You can reuse drawings from other panels throughout your storyboard. You can also modify drawing objects 
and transformations after they have been copied to a new layer, instead of redrawing similar objects.

When you copy a layer, it is placed on the Clipboard, so you can paste it in many different locations if needed.

How to copy a layer to another panel by dragging

 1. Click the tab of the layer you want to copy. Hold down Ctrl (Windows/Linux) or ⌘  (macOS) and 
select additional layers if needed. 

 2. Drag the selected layer to the layer section of the destination panel. Drop the layers at a specific 
position to place it in the desired layer order.

When you copy a layer, it retains its original layer name in the new panel. If a layer with the same 
name already exists, then you will be prompted to give it a new name or overwrite the existing 
layer.

For example, if layer A is copied to a panel, where a layer A already exists, the copied layer will be 
named A_1 by default. If it is copied into the panel a second time, the new layer will be named A_2.
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How to copy a layer to another panel by using copy and paste

 1. Select the layer you want to copy. Hold down Ctrl (Windows/Linux) or ⌘  (macOS) and select 
additional layers if needed. 

 2. Do one of the following:

‣ Select Layer > Copy Layers. Select the destination panel, and from the top menu,  select Layer > 
Paste Layers.

‣ Right-click the layer tab and select Copy Selected Layers. Select the destination panel, right-
click the layer tab and select Paste Layer.
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Reordering Layers
Layers can be rearranged to bring them closer to the front or back in relation to the other layers in a panel. For 
example, if you want to have a character move to the front of a shot, you can move the character layer above 
the others. In Storyboard Pro, the layers at the top of the list are displayed above the other layers in the Stage 
view. The layer order will be reflected in the final export.

There are several different ways to change the order of layers in a panel. You can reorder layers by selecting a 
layer and dragging it to a new location, or reorder layers through the Layers menu.

How to arrange a layer by dragging

 1. Select a layer to move. 

 2. Drag the layer above or below other layers to change their display priority in the Stage view.

How to arrange a layer using the Layers menu

 1. Select a layer to modify. 

 2. Select one of the following: 

‣ Layer > Arrange > Bring Layer to Front to move the selected layer in front of all other layers in 
the current panel.

 

‣ Layer > Arrange > Bring Layer to Forward to move the selected layer up one spot in the current 
panel.
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‣ Layer > Arrange > Send Layer to Back to move the selected behind all other layers in the 
current panel.

 

‣ Layer > Arrange > Bring Layer Backward to move the selected layer down one spot in the 
current panel.

 

NOTE 

If you changed the Z-depth, it supecedes the layer order.
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Grouping Layers
T-SBFND-007-007

Grouping layers helps organize your work and keeps your list of layers uncluttered. You can group selected 
layers or create an empty group layer and add layers to it.

When you group selected layers, they become the sub-layers of the group layer. The first newly-created group 
layer is named Group. Subsequent group layers are appended with a number. For example, Group_1. The 
number increments with each new group layer you create. The selected group layer is highlighted in blue and 
its sub-layers are displayed below. 

Within a group layer, you can create sub-groups to further streamline your work, and rename them to suit your 
project—see Renaming Layers on page 179. Grouped layers can also be animated.

How to group layers

 1. In the Layer panel of the Stage or Camera view or in the Layers view, select at least two layers to 
group.

 2. Do one of the following:

 l Click the Group Selected Layers  button. This button can be found at the bottom of the 
Layer panel in the Stage or Camera view and at the bottom of the Layers view.

 l Right-click on the selection, then select Group Selected Layers.

 l In the top menu, select Layer > Group Selected Layers.

TIP 

You can drag and drop layers into or out of groups. 
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How to ungroup a group layer

 1. Select a group layer.

 2. Do one of the following:

 l Right-click and select Ungroup Selected Layer.

 l Select Layer > Ungroup Selected Layer.

The selected group layer is ungrouped. The group layer disappears and its child layers are no longer 
grouped.

How to expand or collapse a group layer

 1. Click the Expand/Collapse button on a group layer.

How to create an empty group layer

 1. Select Layer > New > Group Layer.

A new, empty group layer is created in the list of layers and is highlighted in blue. The new layer is 
positioned above the layer that was selected before you created the group layer.

How to add layers to an empty group layer

 1. Select a layer.

 2. Drag and drop it on a group layer.
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Showing and Hiding Layers
When working with many layers, you can temporarily hide certain layers to avoid cluttering the stage.

You can also hide a group. When a group is hidden, all of the layers it contains appear hidden, but their 
individual visibility state is preserved. Therefore, if you hide only some layers inside a group, hide the group 
itself, then unhide the group, the layers that were individually hidden will remain hidden and the ones that 
were visible will be visible again.

How to show or hide a layer

 1. Do one of the following: 

 l In the Layer panel or the Layers view, click the Show/Hide Layer  icon just left of the layer.

 l In the Thumbnails view, click on the Show/Hide Layer  icon just beneath the layer's name.

 l In the Layer panel, the Layers view or the Thumbnails view, right-click on the layer and select 
Show/Hide Layers

 l In the Layer panel, the Layers view or the Thumbnails view, select the layer, then select Layer 
> Show/Hide Layers from the top menu.
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Locking and Unlocking Layers
You can lock a selected layer to protect any objects on it from being changed. Once locked, you can unlock the 
layer to make changes to any objects on it.

How to lock or unlock a layer

 1. Do one of the following:

 l In the Layer panel or the Layers view, click the Lock/Unlock  icon just left of the layer.

 l In the Thumbnails view, click on the Lock/Unlock  icon just beneath the layer's name.

 l In the Layer panel, the Layers view or the Thumbnails view, select the layer. Then, do one of 
the following:

 l Then, select Layer > Lock/Unlock Layers from the top menu.

 l In the Layer toolbar, click on the Lock/Unlock Layers  button.

 l Press Alt + L.

188



Transforming Layers
T-SBFND-007-010

Using the Layer Transform tool, you can re-position, rotate and scale one or several drawing layers. Contrary to 
the Select tool, which can do the same thing to a selection of artwork, the Layer Transform tool has no 
permanent effect on your artwork. You can reset transformations done with the Layer Transform tool. 

The Layer Transform tool is also essential in animating layers. If your layer has animation keyframes, 
transformations done with the Transform tool will be animated, whereas those done with the select tool will 
always apply to the whole panel—see Animating Layers on page 473.

How to reposition, rotate and scale a drawing layer

 1. In the Thumbnails or Timeline view, select the panel with the layer you want to transform.

 2. In the Layer Panel of the Stage or Camera view or in the Layers view, select the layer you want to 
transform.

 3. In the Tools toolbar, select the Layer Transform  tool.

In the Stage or Camera view, the controls of the Layer Transform tool appear around the selected 
drawing layer.

 4. Using the manipulator box, transform the layer so that it is in the desired position, angle and size:

 l To move the layer, either click on its artwork or on the blue point in the centre, then drag it to 
the desired position.
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TIPS 

 l If you are having trouble dragging the layer by its artwork, you can also click 
and drag on the blue point  in the centre. However, this point may be 
obstructed by the layer's pivot point . If that is the case, you can click and 
drag on the pivot point to move it out of the way, then click and drag on the 
centre point to move the layer. 

 l You can also nudge the selection by using the arrow keys on your keyboard.

 l You can also enter specific coordinates in the Horizontal Offset  and 
Vertical Offset  fields in the Tool Properties view.

 l To scale the layer, click on one of the squares at the edges or corners of the manipulator box 
and drag them to stretch or shrink the drawing.

TIPS 

 l You can preserve the horizontal and vertical proportions of the selection by 
holding the Shift key.

 l You can also enter specific scale percentages in the Horizontal Scale  and 
Vertical Scale  fields in the Tool Properties view.
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 l To rotate the layer, move the cursor just outside of one of the corners of the manipulator box 
until the mouse cursor becomes . Then, click and drag in either direction to rotate the layer 
clockwise or counterclockwise. 

TIPS 

 l You can rotate the artwork in 15° increments by hold the Shift key.

 l You can also enter a specific angle in degrees in the Angle  field of the Tool 
Properties view.

 l You can also rotate the clip in 90° increments by clicking on the Rotate 90 
CW  button in the Tool Properties view to rotate it 90° clockwise, or on the 
Rotate 90 CCW  button to rotate it 90°  counterclockwise. 

 l To flip the layer horizontally, click on the Flip Horizontally  button in the Tool Properties 
view.

 l To flip the layer vertically, click on the Flip Vertically  button in the Tool Properties view.

 l To reset a layer to its original position, scale and angle, do one of the following:

 l Select Layer > Reset Transform.

 l Press Ctrl + R (Windows) or ⌘  + R (Mac OS X).
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Resetting Transformations
When you no longer need a layer's transformation, you can easily reset the layer to its original position, scale 
and angle.

How to reset layer animation back to its default state

 1. In the Layer panel of the Stage or Camera view or in the Layers view, select the transformed layer.

 2. Do one of the following:

 l Select Layer > Reset Transform.

 l Press Ctrl + R (Windows) or ⌘  + R (Mac OS X).
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Merging Layers
T-SBFND-007-008

There are three ways to merge layers. You can quickly merge the current layer down with the layer just below 
it, you can quickly merge a selection of layers or you can merge specific layers with specific parameters with the 
Merge Layers dialog box. The resulting layer will be a single drawing layer, which you can edit and animate like 
any other drawing layer. 

Using the Merge Layers dialog box gives you more control over the result of the merge. You can pick a name for 
the resulting layer, specify whether it is a vector or bitmap layer, select source layers, and more.

NOTE 

 l When merging layers, the animation on all layers being merged is discarded.

 l If you quickly merge a bitmap layer with a vector layer, the resulting layer will be a bitmap layer. 

 l Layers containing a 3D object cannot be merged.

 l The artwork in hidden layers is not added to the merged artwork.

How to quickly merge one layer with the layer below it

 1. Select the topmost of the two layers you wish to merge.

 2. Do one of the following:

 l Right-click and select Merge Down.

 l Press Ctrl + E (Windows) or ⌘  + E (macOS)

 l In the top menu, select Layer > Merge Down.

How to quickly merge a selection of layers

 1. Select the layers to merge.

 2. Do one of the following: 

 l Right-click and select Merge Selected Layers. 

 l Select Layer > Merge Selected Layers.

How to merge layers using the Merge Layers dialog box

 1. Select the layers to merge.
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 2. Do one of the following: 

 l Right-click and select Merge Layers. 

 l Select Layer > Merge Layers.

The Merge Layers dialog box opens.

 3. In the Name field, enter a name for the merged layer. 

 4. Select one of the following: 

 l Vector Layer: Makes the merged layer a vector layer. If there are bitmap layers in your 
selection, they will be converted to vector rectangles with a bitmap texture inside them. 

 l Bitmap Layer: Makes the merged layer a bitmap layer. If there were vector layers in your 
selection, they will be converted to bitmap. 

 5. If your merged layer is bitmap, set the Bitmap Layer Canvas parameters.

 l Resolution Factor: The proportions of bitmap pixels to store in the drawing for each pixel 
that is visible when the drawing is not zoomed in or scaled up. You should increase this 
parameter if you intend to scale up or zoom in on the drawing.

 l Width Factor/Width: The width of the bitmap layer's canvas relative to the width of the 
stage. 

 l Height Factor/Height: The height of the bitmap layer's canvas, relative to the height of the 
stage.
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 6. If you want to discard the layers being merged together to only have the merged layer, check the 
Delete Source Layers option. If you want to preserve the layers being merged along with the 
merged layer, uncheck this option. 

 7. If you want invisible layers that are part of the selected layers to also be discarded, check the 
Remove Invisible Layers option. Since invisible layers do not get added to the merged artwork, this 
option is unchecked by default.

 8. Click OK.
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Changing Layer Opacity
T-SBFND-007-009

If necessary, you can modify the opacity of layers.

NOTE 

Layer transparency is not supported when exporting to the Toon Boom and/or FBX formats.

How to change the layer opacity

 1. Select the layer whose opacity you want to modify. 

 2. In the Stage or Layers view, do one of the following in the Opacity field:

 l Type in a new opacity between 0 and 100.

 l Click in the Opacity field and use the up/down arrows on your keyboard to set the 
opacity.

The changes you make are reflected in the Stage view.

How to modify the layer opacity in other ways

 l Right-click a layer and select Change Layer Opacity.

 l Select Layer > Change Layer Opacity.

In the Change Layer Opacity window that opens, enter a new opacity.
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Converting a Template or Group to a Drawing Layer
If you have imported an animated template or a template containing multiple elements, for example, a template 
created in Harmony, or a template made from importing a Flash Movie (.swf) file, you might not be able to edit it 
with the drawing tools. This is because the template is not a simple drawing layer. 

To remedy this, you can convert layers that contain  templates into simple drawing layers. Likewise, you can 
convert a group of drawing layers to a single drawing layer using the same method. 

NOTES 

 l In Storyboard Pro, a drawing layer can only contain one drawing for the whole panel, whereas a 
template may be animated and contain several frames with different drawings in each frame. If 
you convert an animated template to a drawing, the appearance of the template at current 
frame will be used to generate a static drawing layer.

 l Converting a template or a group to a drawing will discard any 3D object they contain.

How to convert a template layer or a group layer to a drawing layer

 1. If your template is an animated template, move the timeline playhead to the frame which you want 
to use to make the drawing layer. 

 2. Select the layer in which the template was imported or the group layer you wish to convert.

 3. Do one of the following:                 

 l Right-click the selected layer and select Convert to Drawing.

 l In the top menu, select Layer > Convert to Drawing.

The selection is converted to a simple drawing layer, which you can now edit freely with the 
Storyboard Pro drawing tools. 
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Converting Layers between Bitmap and Vector Layers
T-SBADV-007-002

You can convert a vector layer to a bitmap layer, and you can convert a bitmap layer to a vector layer. 

If you convert a vector layer to a bitmap layer, the vector artwork will be rasterized into a bitmap image. Hence, 
the artwork will no longer be scalable and you will only be able to draw, paint or erase over it.

Since bitmap layers have a canvas size and a pixel density, you will be prompted to choose the canvas size and 
pixel density of the layer when converting vector artwork to bitmap artwork. 

If you convert a bitmap layer to a vector layer, the bitmap artwork will be stored in a vector rectangle with a 
bitmap texture. This artwork will still technically be bitmap artwork, but any artwork you draw on that layer 
from that point on will be vector artwork. 

How to convert a bitmap layer to a vector layer

 1. Select one or several bitmap layers.

 2. Do one of the following:

 l Right-click the selected layer and select Convert to Vector Layer.

 l In the top menu, select Layer > Convert to Vector Layer.

The layer is converted to a vector layer, as indicated by its colour in the layer list. 

How to convert a vector layer to a bitmap layer

 1. Select one or more layers to convert.

 2. Do one of the following:

 l Right-click the selected layer and select Convert to Bitmap Layer.

 l In the top menu, select Layer > Convert to Bitmap Layer.
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If your layer was a vector layer, you will need to enter some parameters for the bitmap layer it will be 
converted to. The Choose Bitmap Layer resolution dialog appears.

 3. Select a canvas size and pixel density for the new bitmap layer and click OK.

The following message appears.

 4. Click OK.

The layer is converted to a bitmap layer, as indicated by its colour in the layer list.
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Setting Textured Vector Brush Resolution
In general, artwork in vector layers is not resolution-dependent, as most of it is made of vector shapes that can 
be scaled up or down. However, if you draw on a vector layer using a textured brush, the vector shapes your 
brush creates will be filled with a bitmap texture, which is resolution dependent. This means that if you scale up 
or zoom in on your artwork, you will be able to see the individual pixels that make the textures in your brush 
strokes. 

Just like with bitmap layers, the pixel density for textured brush strokes in vector layers can be set at the level 
of the layer. By default, the pixel density of vector layers is set to 100%, which means that your textures will 
drop in quality as soon as you scale them up or zoom in on them. Hence, if your scene has camera zoom-ins, or if 
you intend to scale up the artwork containing textured brushes, you should increase the pixel density of the 
layer to at least the percentage at which it will be scaled up. For example, if a layer gets scaled up to 200%, and 
the camera performs a 2x (6 fields) zoom on it, the layer will end up being scaled up by 400% in total. Hence, 
you should set the pixel density of that layer to at least 400% before you start drawing on it. 

WARNING 

If you increase the pixel density of a vector layer that already contains textured brush strokes, 
Storyboard Pro will need to resample the textures, which will make it lose quality. Hence, you 
should always set the proper pixel density for your layer before you start drawing with textured 
brushes. 

How to change the pixel density for textured brushes strokes in existing drawings

 1. From the Layers panel or the Layers view, select the vector layer for which you want to change the 
pixel density.

 2. Do one of the following:

 l Right-click the layer and select Change Vector Layer Brush Resolution.

 l From the top menu, select Layer > Change Vector Layer Brush Resolution.

The Change Vector Layer Brush Texture Resolution dialog appears.
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 3. In the Pixel Density field, set the pixel density to at least the amount of time your textured artwork 
will be zoomed in. For example, if a layer gets scaled up to 200%, and the camera performs a 2x (6 
fields) zoom on it, the layer will end up being scaled up by 400% in total. Hence, you should set the 
pixel density of that layer to at least 400% before you start drawing on it. 

 4. If your layer already contains textured brush strokes, and you want the texture in these brush 
strokes to be resampled to fit this new Pixel Density setting, check the Apply to Existing Strokes 
option.

 5. Click OK.
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Setting the Resolution of Bitmap Layers
By default, bitmap layers have a pixel density of 100%, which is just enough to display the artwork properly as 
long as it does not get scaled up and as long as the camera does not zoom in on it. If you intend to zoom in on a 
bitmap layer or to scale it up, it is important to increase its pixel density to at least the percentage at which it 
will be scaled up during the scene, to avoid any loss of picture quality. For example, if a bitmap layer gets scaled 
up to 200% in a panel, and the camera performs a 2x (6 fields) zoom on it, the layer will end up being scaled up 
by 400% in total. Hence, you should set the pixel density of that layer to at least 400% before you start 
drawing on it. 

Also, contrary to vector layers, bitmap layers have a limited canvas. By default, the dimensions of this canvas 
are set to 200% of your project's width and height, which gives you some extra space to draw beyond the 
edges of the camera field. You should increase your layer's canvas size if you intend to draw a very large image 
that extends way beyond the edges of the camera. You can increase your layer's canvas size at any time 
without loss of picture quality. However, if you shrink the canvas size of your layer, its artwork will be cropped 
to fit the new canvas. 

WARNING 

If you increase the pixel density of a bitmap layer that already contains artwork, Storyboard Pro will 
need to resample the artwork to preserve its proportions, which will make it lose picture quality. 
Hence, you should always set the proper pixel density for your bitmap artwork before you start 
drawing. 

How to change the resolution of a bitmap layer

 1. From the Layers panel or the Layers view, select the bitmap layer for which you want to change the 
resolution.

 2. Do one of the following:

 l Right-click the layer and select Change Bitmap Layer.

 l From the top menu, select Layer > Change Bitmap Layer Resolution.

The Change Bitmap Layer Resolution dialog box opens.
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 3. In the Width and Height fields, enter the percentage for the dimensions of the bitmap canvas, 
relative to the camera frame. By default, these settings are set to 200%, which means the 
dimensions of the canvas are twice the ones of the camera frame, giving you extra space to draw 
beyond the edges and pan your artwork, if needed.

 4. In the Pixel Density field, set the pixel density to at least the amount of time your bitmap artwork 
will be zoomed in. For example, if a layer gets scaled up to 200%, and the camera performs a 2x (6 
fields) zoom on it, the layer will end up being scaled up by 400% in total. Hence, you should set the 
pixel density of that layer to at least 400% before you start drawing on it. 

 5. If your layer already contains artwork, and you want it to be resampled to fit the new Pixel Density 
setting, check the Resample Bitmap option.

NOTE 

If you leave this option unchecked, your artwork will be scaled up if you decrease the 
pixel density, or scaled down if you increase it. 

 6. Click OK.
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Importing Images as Layers
T-SBADV-009-003

As you build your scene, you may want to use bitmap images for backgrounds and overlays. You may also want 
to import an image as a reference for a vector drawing you want to create. With Storyboard Pro, you can 
import a variety of bitmap formats (TVG, OPT, PAL, SCAN, SGI, TGA, YUV, OMF, PSD, PNG, JPG, JPE or JPEG) 
which you can combine with your vector-animated content to create rich and unique graphic styles. You can 
import a single image (or multiple images located in the same folder) into a new layer.

You can vectorize images upon import. To display the Vectorization Parameter dialog box, see Vectorizing 
Images on Import  on page 205.

IMPORTANT 

Storyboard Pro does not support import of 8-bit CMYK or 16-bit RGB or CMYK format PSD files. 
You can currently import only 8-bit RGBA format PSD files.

How to import images into the current panel

 1. Select the panel to which you want to import the image(s).

 2. Select File > Import > Images as Layers.

The Choose Image Files dialog box opens.

 3. Select the image to import and click Open.

NOTE 

To select multiple images, hold down Ctrl (Windows) or ⌘  (macOS) as you click.

A layer is created in your panel, containing the imported image. If you selected more than one 
image, each image will be imported in alphanumerical order on its own layer.

If you selected a *.psd image with multiple layers, a message will appear giving you the option to 
import each layer separately.

 l Click Yes to import each layer on its own layer in the panel.

 l Click No to create a layer behind the existing layers, containing the selected *.psd 
image.
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Vectorizing Images on Import 
T-SBADV-009-004

By default, when you import an image into your project using either the Import Image as Layers or Import 
Images as Scenes commands, the imported images will be vectorized in colour and fit the camera frame. The 
image resulting from a colour vectorization will appear exactly as the original picture.

With the Storyboard Pro, more options are available which give you better control over the vectorization of 
imported images. To access these options, you must first select the Display Vectorize Options Dialog option in 
the Preferences dialog box.

How to set the vectorization options

 1. Do one of the following:

 l Select Edit > Preferences (Windows) or Storyboard Pro > Preferences (macOS).

 l Press .

 2. In the User Preferences dialog box, select the Import/Export tab.

 3. Select the Display Vectorize Options Dialog option.

 4. Select File > Import > Images as Layers.

 5. In the browser that opens, select an image to import.

The Import Images dialog box opens.
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The preview area displays the original image on the left and the resulting image on the right. The 
preview of the resulting image automatically updates each time you modify a parameter.

 6. In the Import Options section, set the following parameters:

 l As Bitmap Layer: Preserves the exact look of the imported images and imports it in a 
bitmap layer.
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 l Colour to Vector Layer: Preserves the exact look of the imported images and imports 
it in a vector layer.

 l Gray Scale to Vector Layer:  Imports the selected images as a gray scale in a vector 
layer.

 l Black and White to Vector Layer: Imports the images as black line art. When you 
enable this option, more options become available:

 l Threshold (%): Filters out noise in your images. Noise can be dirt or faint smudges on 
your scanned images. For example, if your value is set to 70%, all colour values below 
70% are converted to white and ignored in the final image. If your value is set to 
100%, only completely black lines will be kept.

 l Expand: Enter a value between 1 and 100 to thicken lines or the outer edges of the 
bitmap. Use this option if your line art is too fine or pale so that their visibility is 
increased in the software.

 l Smooth: Enter a value between 1 and 5 to set the smoothness level. Greater 
smoothness equals less jaggedness and imperfections, but at a greater loss to detail.

 7. In the Resampling Options section, set the following parameters:

 l Maximum Size: Enter a specific maximum size for your imported image to be scaled 
down to. The original ratio of the image will be preserved during the operation. You 
can see the final values resulting from the scaling process in the Scale Size fields. Note 
that you can not use these fields to scale up an image.

 l Scaled Size: Displays the final size the image will be scaled after it is imported in your 
project.

 8. Once you have set the vectorization options:

 l Saves as default: Saves the current settings. Every time you open this dialog box, the 
new default parameters will automatically be set. The import images commands will 
still use this new default even if you deselect the Display Vectorize Options Dialog 
preferences.
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 l Do not show this dialog again: Deselects the Display Vectorize Options dialog option 
in the Preferences dialog box directly from here.
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Chapter 7: Drawing
Storyboard Pro has many powerful tools, views, and features for sketching, drawing and animating with ease. 
This chapter describes the main assets needed when drawing , as well as tips on how to start and use these 
tools efficiently. 
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About Drawing Tools
T-SBFND-008-001

Drawing Tools
The two main drawing tools in Storyboard Pro are the Brush  tool and the Pencil  tool. Depending on the 
drawing style you want to accommodate, you may prefer to work with Vector  or Bitmap  layers.

On vector layers, it is possible to draw with pencil lines, vector brushes and  textured bitmap brushes. While 
pencil lines are merely vector centrelines to which Storyboard Pro adds the thickness, brush strokes are solid 
vector shapes filled with a colour, and textured brush strokes are regular brush strokes filled with a bitmap 
texture that filter out their colour. 

On bitmap layers, you can only draw using solid or textured bitmap brushes. Hence, while vector layers are 
more flexible because they allow you to easily manipulate and tweak parts of your artwork, they can also 
accommodate more art styles.

However, if you use a textured brush on a vector layer, your brush strokes will have a bitmap texture. This 
means that, just like with artwork in bitmap layers, attempting to tweak or resize a textured brush stroke will 
require Storyboard Pro to resample the texture, which is liable to make it lose picture quality, unless its texture 
resolution was sufficiently increased before you started drawing.

One pitfall of using textured brushes on vector drawings is that, while bitmap drawings are always made of a 
single flat canvas, vector brush strokes are kept as separate objects. This means that laying on a lot of textured 
brush strokes on a vector drawing will require Storyboard Pro to store the texture for each of these strokes, 
and to composite them together in real time to display your drawing. This can cause texture-heavy vector 
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drawings to be heavier on application performance and in file size than bitmap drawings. This is however the 
only case where a vector drawing is likely to be heavier than a bitmap drawing. 

NOTE 

Even if you flatten your artwork, textured brush strokes of different colours cannot be flattened 
together on vector layers. 

The following table compares the different approaches to drawing available in Storyboard Pro:

Drawing Tool Layer Type Specifics

Pencil Vector

Advantages: Very light and easy to tweak. Can be manipulated, recoloured and 
tweaked by the centreline. Can be zoomed in on or scaled up without losing 
quality.

Disadvantages: Does not support textures. Not optimized for transparency.

Recommended Use: Sketches, clean drawings with a solid and uniform outline 
style. 

Solid Vector 
Brush

Vector

Advantages: Light file size. Reproduces traditional animation style. Can be 
manipulated, recoloured and edited by the contour or centreline. Can be zoomed 
in on or scaled up without losing quality.

Disadvantages: Cannot reproduce the look of natural media.

Recommended Use:  Sketches, clean traditional animation-style drawings.

Textured 
Vector Brush

Vector

Advantages: Can reproduce the look of natural media. As capable as textured 
bitmap brushes, but can be manipulated, edited and recoloured like solid vector 
brushes.

Disadvantages:  Overlapping strokes can make the drawing heavy on application 
performance and file sizes. Strokes of different colours cannot be flattened 
together. Tweaking, scaling up or zooming in on artwork is liable to make it lose 
texture quality.

Recommended Use:  For light bitmap-style textured artwork or mixed-style 
artwork.

Textured 
Bitmap Brush

Bitmap 

Advantages: Can reproduce the look of natural media. Better performance and 
lighter file size than texture-heavy vector artwork. Can be edited pixel by pixel.

Disadvantages: Strokes are always flattened together and cannot be modified 
individually. Can only be drawn or erased upon. Scaling up or zooming in on 
artwork is liable to make it lose picture quality.

Recommended Use: Texture-heavy bitmap artwork.
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Here are the drawing tools available in Storyboard Pro, followed by the types of layer on which they are 
supported.  If you are editing a vector layer, then all of the tools are available to you. If you are drawing on a 
bitmap layer, some tools are not available. When tools are not available, they are grayed out in the Tools 
toolbar. 

Icon Tool Name Vector Layer Bitmap Laye

Select ✓ ✓

Select by Colour ✓  

Cutter ✓ ✓

Contour Editor ✓  

Centerline Editor ✓  

Perspective ✓  

Edit Gradient/Texture ✓  

Brush ✓ ✓

Pencil ✓  

Stamp ✓  

Eraser ✓ ✓

Text ✓ ✓
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Icon Tool Name Vector Layer Bitmap Laye

Line ✓ ✓

Rectangle ✓ ✓

Ellipse ✓ ✓

Polyline ✓  

Paint ✓ ✓

Paint Unpainted ✓ ✓

Unpaint ✓ ✓

Close Gap ✓  

Dropper ✓ ✓

Each drawing tool has a series of options to customize its behaviour and drawing style. When you select a tool, 
the Tool Properties view displays the properties of the currently selected tool, where you can configure your 
drawing tool's behavior and style, if applicable. 
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About the Brush Tool
The Brush tool allows you to draw by creating shapes based on your drawing strokes and filling them with 
colour or textures. When used with a tablet, it is pressure sensitive, just like a real life brush.

You can use the Brush tool on both Vector  or Bitmap  layers layers. In either  case, the Brush tool can be 
made to create solid or textured brush strokes with almost the same capabilities. The main difference is that, on 
bitmap layers, your brush strokes are fully bitmap, and are always flattened into the canvas, whereas on vector 
layers, your brush strokes are made of a vector contour with a bitmap fill, and are kept as separate drawing 
objects that can be manipulated individually. This has the following implications:

 l Textured artwork is easier to edit and tweak on vector layers, as you can manipulate textured brush 
strokes with the Select Tool, the Contour Editor and the Centerline Editor.

 l Very texture-heavy artwork may turn out to be lighter, both in terms of performance and file size, on a 
bitmap layer than on a vector layer.

 l Erasing textured artwork with a textured eraser will look more natural on a bitmap layer than on a 
vector layer—see Creating a Textured Eraser on page 315.
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NOTE 

Should you choose to draw on bitmap layers, or to draw on vector layers with textured brushes, you 
should mind that your artwork will be resolution dependent. By default, the pixel density of bitmap 
and textured artwork is 100%, meaning that zooming in or scaling up your artwork will make it 
appear pixelated. To increase the pixel density of your artwork and prevent it from appearing 
pixelated, see Setting Textured Vector Brush Resolution on page 200 if you are working on a vector 
layer, and Setting the Resolution of Bitmap Layers on page 202 if you are working on a bitmap 
layer.
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Drawing with the Brush Tool
T-SBFND-008-002

When creating a new project in Storyboard Pro, you can immediately start drawing in the selected panel using 
one of the drawing tools at your disposal. 

NOTE 

To learn more about the options of the Brush tool, see Creating a Solid  Brush on page 219 and 
Creating a Textured Brush on page 222.

How to draw with the Brush tool

 1. In the Timeline or Thumbnails view, select the panel in which you want to draw.

 2. In the Layer panel of the Stage view, select the layer on which you want to draw.

 3. Do one of the following:

 l In the Tools toolbar, select the Brush  tool.

 l In the top menu, select Tools > Brush.

 l Press Alt + B.

 4. In the Presets list of the Tool Properties view, select a brush preset to use. 

 5. Use the Maximum Size slider to select the desired size for your brush.

 6. In the Colour view, do one of the following to select a colour:

 l Use the Hue, Saturation and Value sliders to select the colour with which you want to draw.

 l Select a colour swatch from the swatch list.

 7. In the Stage view, draw a stroke. 

217

Storyboard Pro 6. User Guide                          



Chapter 7: Drawing

TIPS 

 l If you press and hold the Shift key before you start drawing, your stroke will be a straight 
line. 

 l If you press and hold the Shift key while you're drawing, the part of your stroke from that 
point on will be a straight line until you release the Shift key. 

 l If you press and hold the Shift and the Alt keys before drawing, your stroke will be a 
straight line in an angle that is a multiple of 15 degrees. 

 l If you press and hold the Ctrl (Windows) or ⌘  (macOS) key while drawing, your stroke will 
be a closed shape.

 l If you press and hold the Alt key while drawing on a vector layer, your tool will snap in a 
straight line to the nearest existing shape. 
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Creating a Solid  Brush
When drawing with the Brush tool on a vector layer, you can use either solid vector brushes or textured vector 
brushes. By default, your brush will be a solid vector brush. A solid vector brush creates a vector shape and 
simply fills it with the selected colour, making lightweight, simple crisp strokes. 

A solid vector brush's tip can be shaped like a circle, a diamond or a square, and can be configured to have a 
specific size, aspect ratio and angle. Also, solid vector brushes can be automatically smoothed by Storyboard 
Pro as you draw.

If you are drawing on a bitmap layer, you can only use textured brushes. You can create a textured brush that 
makes solid looking strokes, but they can not be automatically smoothed by Storyboard Pro, nor can they 
tweaked with vector tools such as the Contour Editor. For more information, see About Layer Types on page 
174.

How to create a solid vector brush

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

The Brush Properties dialog opens.
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 1. In the Brush Type dropdown list, select Solid Vector.

 2. In the brush tip list, select either Circle, Diamond or Square. 

 3. Use the Maximum Size slider to set the maximum size of your brush tip.

NOTE 

When drawing with a mouse, your brush is always at its maximum size. When drawing 
with a pressure-sensitive pen tablet, your brush's size will range between its minimum 
and maximum size, depending on the amount of pressure you put on the pen when 
drawing. 

 4. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the size of your 
brush when using your pen with very little pressure. The minimum size is set to a percentage of your 
brush tip's maximum size, which is 25% by default. If you don't want the pressure on your pen to 
affect the brush size, set this parameter to 100%.

 5. If you want your brush tip to have uneven dimensions, use the Roundness slider to shrink the brush 
tip vertically all the while preserving its horizontal size.

 6. If you want your brush tip to be at an angle, use the Angle slider to rotate your brush tip.
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 7. Click on the Smoothing tab.

 8. Use the Centerline Smoothing slider to set the amount of smoothing Storyboard Pro should 
perform on your  stroke's direction, curves and corners. A higher setting will prevent your line from 
being shaky, but is liable to reduce your drawing precision and to round sharp corners into curves.

 9. Use the Contour Smoothing slider to set the amount of smoothing Storyboard Pro should perform 
on your stroke's contour. A higher setting will round sharp corners and reduce the amount of control 
points for the resulting vector shape. 

 10. Either close or set aside the Brush Properties dialog.

 11. In the Stage view, start drawing to test your brush settings.
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Creating a Textured Brush
Using textured brushes, you can create an infinite range of fuzzy, textured and watercolour lines. You can use 
bitmap brush tips, adjust your line's hardness and opacity, combine two tips and apply a paper texture to your 
brush strokes so as to adapt the Brush tool to a variety of art styles and create natural-looking brush strokes.

When drawing on a vector layer, brushes are solid vector brushes by default. You can however create a 
textured vector brush which combines both Storyboard Pro's vector and bitmap drawing capabilities. You can 
tweak textured vector brush strokes using various vector editing tools such as the Contour Editor,the 
Perspective tool and the Envelope tool, and Storyboard Pro will resample the textures inside your brush 
strokes with each modification.

If you are drawing on a bitmap layer, your brush is always textured. You can configure a textured brush to look 
crisp and solid if desired, but brush strokes on bitmap layers cannot be tweaked or smoothed.
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Configuring a Textured Brush Tip
The Brush tool supports two types of brush tips: Solid and Textured. Solid brush tips are plain shapes that can 
be used to draw vector shapes filled with a solid color, whereas textured brush tips are bitmap images with 
various shapes and opacity levels that can be used to create natural-looking brush strokes.

Solid brush tips are not customizable. The selection is limited to either a circle, diamond or square-shaped brush 
tip, the proportions and angle of which can be adjusted. While Storyboard Pro also comes bundled with preset 
textured brush tips, it is also possible to create and use your own textured brush tips. 

How to configure a textured brush tip

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.

223

Storyboard Pro 6. User Guide                          



Chapter 7: Drawing

 4. In the Brush Tip list, select the desired brush tip. If you want to create your own brush tip, see 
Adding a Brush Tip on page 226.

 5. Use the Maximum Size slider to set the maximum size of your brush tip.

NOTE 

When drawing with a mouse, your brush is always at its maximum size. When drawing 
with a pressure-sensitive pen tablet, your brush's size will range between its minimum 
and maximum size, depending on the amount of pressure you put on the pen when 
drawing. 

 6. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the size of your 
brush when using your pen with very little pressure. The minimum size is set to a percentage of your 
brush tip's maximum size, which is 25% by default. If you don't want the pressure on your pen to 
affect the brush size, set this parameter to 100%.

 7. If you want your brush tip to have uneven dimensions, use the Roundness slider to shrink the brush 
tip vertically all the while preserving its horizontal size.

 8. If you want your brush tip to be at an angle, use the Angle slider to rotate your brush tip.

224



 9. Use the Hardness slider to set how much of the outer part of your brush tip should fade to 
transparency. If you set it to 100 %, the brush will be completely solid. If you set it to 0 %, the brush 
will only be opaque in its center, and will gradually become transparent towards its edges. 

 10. Use the Spacing slider to set how much distance you must drag your brush before Storyboard Pro 
prints the brush tip onto your canvas, relative to your brush's size. The default setting is 7%, which 
produces a relatively realistic brush stroke-like result. If this setting is too low, your brush strokes 
might feel too thick and opaque. If this setting is too high, your strokes will look like the brush tip has 
been stamped repeatedly over your canvas instead of dragged on it.

 11. If you want the size of your brush tip to vary each time it's printed on your canvas, set the 
Random Size setting to any value above 0 %.

 12. If you want the angle of your brush tip to be random each time the tip is printed on your canvas, set 
the Random Angle setting to any value above 0 °.

 13. If you want the spacing between each instance of the brush tip to be random, set the Random 
Spacing setting to any value above 0 %.

 14. If you want the spacing between each instance of the brush tip to be random, set the Random 
Spacing setting to any value above 0 %.

 15. In the Stage view, start drawing to test your brush settings.
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Adding a Brush Tip
In the Brush or Eraser Properties dialog, you will find a set of default brush tips which are bundled 
with Storyboard Pro, but you can also create your own brush tips, then export your collection or import an 
existing set. 

To make your own brush tip, you must first create an image file containing the brush tip, either in Storyboard 
Pro or in a third party software, like Adobe Photoshop, then import it into Storyboard Pro. A brush tip must be 
a greyscale image. Colors in brush tips are not acknowledged by Storyboard Pro, as brush tips only use the 
colour you are painting with in Storyboard Pro. Your brush tip should also not contain transparency, as 
Storyboard Pro determines the brush tip's transparency based on its black, white and grey levels. Its black 
parts will appear 100% opaque, its white parts will appear 100% transparent, and its grey parts will appear 
semitransparent. 

You can import brush tips in any image format supported by Storyboard Pro. It is recommended to create brush 
tips in a resolution ranging from 100 x 100 pixels to 400 x 400 pixels.

Brush tips are shared between the brush tool and the eraser tool. Like paper textures and brush presets, paper 
textures are saved in your preferences. You can also export your brush tips into an .xml file, and import them 
on a different workstation, allowing you to share your brush tips between the different people collaborating on 
your project.

How to add a brush tip

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the 
brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the 
eraser tool. 

 4. Do one of the following:

 l Click on the Paper Texture menu icon  and select Add.

 l Click the Add Paper Texture button.
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 5. In the file browser window, navigate to the location of your texture image file and select it.

 6. Click Open to import the file into the Paper Texture library.

By default, an imported texture is given the name of the image file.
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Renaming Brush Tips
You can rename your bitmap brush tips to keep your list organized. 

How to rename a brush tip

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the 
brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the 
eraser tool. 

 4. Select the brush tip you wish to rename. 

 5. Click on the Paper Texture menu icon  and select Rename.

 6. In the Rename  dialog box that appears, type in the new name of the brush tip. 

 7. Click OK.

228



Deleting Brush Tips 
You can delete unnecessary brush tips to keep your list organized. 

How to delete a brush tip

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the 
brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the 
eraser tool. 

 4. Select the brush tip you wish to delete.

 5. Do one of the following:

 l Click on the Paper Texture menu icon  and select Delete.

 l Click the Delete  button.

NOTE 

You can delete any brush tip in the Paper Texture library, including the default paper textures, 
except for the three solid brush tips: Circle, Diamond and Square. Also, brush tips will not get 
deleted if they are used in a brush preset. 
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Exporting Brush Tips
You can export brush tips to share, backup or install on a new computer. 

How to export brush tips

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the 
brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the 
eraser tool. 

 4. Click on the Paper Texture menu icon  and select Export.

The Export Tips and Textures dialog opens. This dialog allows you to export both your textured 
brush tips and your paper textures.
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 5. By default, both your brush tips and your paper textures are selected for export. If you only wish to 
export your brush tips, uncheck the Select Paper Textures option.

 6. Click Export.

 7. In the Export Textures window that appears, browse to a location where you want save the .xml 
file and give it a name.

 8. Click Save.
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Importing Brush Tips
You can import Storyboard Pro brush tips you previously exported.

How to import brush tips

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the 
brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the 
eraser tool. 

 4. Click on the Paper Texture menu icon  and select Import.

 5. In the browser window that appears, navigate to and select the .xml file in which you exported 
your brush tips.

 6. Click Open.

In the Import Tips and Textures dialog box appears.
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 7. If the selected .xml file also contains paper textures, they will be selected for import along with the 
brush tips by default. If you wish to only import the paper textures, uncheck the Select Paper 
Textures option.

 8. Click Import.

The imported brush  tips appear in the Brush Tips Library. 
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Changing the Brush Tip Display
You can display your preset list as thumbnails or a list.

How to change the Brush Tips thumbnail display

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the 
brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the 
eraser tool. 

 1. Click on the Brush Tips menu icon .

 2. Select one of the following options:

 l Small Thumbnail: Displays brush tips in a grid of small thumbnails.

 l Large Thumbnail: Displays brush tips in a grid of large thumbnails with their name. 
The default view setting.

 l List View: Displays brush tips in a list, with their name on the left and their texture on 
the right of each row. 
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Configuring Smoothing for a Textured Brush
If you are drawing on a vector layer, the Brush Properties dialog will have a Smoothing tab, which allows to 
configure how Storyboard Pro automatically smooths your brush strokes. If you are drawing on a bitmap layer, 
this topic is not applicable, as bitmap layers do not support automatic smoothing. 

How to configure a textured brush's smoothing

 1. In the Brush Properties dialog, open the Smoothing tab.

 2. Use the Centerline Smoothing slider to set the amount of smoothing Storyboard Pro should 
perform on your  stroke's direction, curves and corners. A higher setting will prevent your line from 
being shaky, but is liable to reduce your drawing precision and to round sharp corners into curves.

 3. Use the Contour Smoothing slider to set the amount of smoothing Storyboard Pro should perform 
on your stroke's contour. A higher setting will round sharp corners and reduce the amount of control 
points for the resulting vector shape. 

 4. In the Stage view, start drawing to test your brush settings.
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Configuring Antialiasing and Transparency for a Textured Brush
A textured brush can be either antialiased or not antialiased. Without antialiasing, your brush strokes will only 
create fully opaque artwork. With antialiasing enabled, you also have the option to set the flow and opacity of 
your brush, allowing you to simulate the effect of inks and paints with various consistencies. 

NOTE 

If you are working on a vector layer, make sure the Brush Type option in the Tip tab is set 
to Textured Vector Brush to enable the textured brush options.

How to configure a brush's antialiasing and transparency settings

 1. In the Brush Properties dialog, open the Transparency tab.

 2. If you want your brush to have antialiasing or transparency, enable the Antialiasing option. 

NOTE 

If the Antialiasing option is disabled, all Transparency settings will be disabled, and your 
brush will only create fully opaque artwork.

 3. Use the Maximum Flow slider to set the consistency of your brush strokes. A lower flow will make 
your stroke more transparent towards the extremities and more opaque in its center, whereas a 
higher flow will make your stroke consistently opaque.

 4. If you are using a pressure-sensitive pen tablet, use the Minimum Flow slider to set the percentage 
of the maximum flow that you want your brush to use when using your pen with very little pressure. 
If you don't want the pressure on your pen to affect the flow, set this parameter to 100%.

 5. Use the Maximum Opacity slider to set the maximum opacity of your brush strokes. 
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 6. If you are using a pressure-sensitive pen tablet, use the Minimum Opacity slider to set the 
percentage of the maximum opacity that you want your brush to use when using your pen with very 
little pressure. If you don't want the pressure on your pen to affect the opacity, set this parameter to 
100%.

 7. If you want the Flow of your brush to be randomized, set the Random Flow setting to any value over 
0 %.

 8. If you want the Opacity of your brush to be randomized, set the Random Opacity setting to any 
value over 0 %.

 9. In the Stage view, start drawing to test your brush settings.

237

Storyboard Pro 6. User Guide                          



Chapter 7: Drawing

Configuring a Textured Brush with a Dual Tip
Textured brushes can also have a dual tip. A dual tip is a secondary tip that can be blended into your primary 
tip in various blend modes, with its own full set of tip settings. 

NOTE 

If you are working on a vector layer, make sure the Brush Type option in the Tip tab is set 
to Textured Vector Brush to enable the textured brush options.

How to configure a brush with a dual tip

 1. In the Brush Properties dialog, click on the Dual Tip tab.

 2. Check the check box in the Dual Tip tab to enable the Dual Tip functionality.

 3. In the Brush Tip list, select the desired brush tip. If you want to create your own brush tip, see 
Adding a Brush Tip on page 226.

 4. In the Blend Mode drop-down list, select the algorithm with which you want your secondary tip to 
blend into your primary tip:
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 l Multiply will draw the least opaque pixel of either brush tip, making more spaced out, 
inconsistent strokes. 

 l Color Dodge will add the opacity of the pixels in both brush tips, making more opaque 
strokes. 

 l Combine will draw the most opaque pixel of either brush tip, combining the tip shapes 
without increasing their opacity.

 5. Use the Maximum Size slider to set the maximum size of your brush tip.

NOTE 

When drawing with a mouse, your brush is always at its maximum size. When drawing 
with a pressure-sensitive pen tablet, your brush's size will range between its minimum 
and maximum size, depending on the amount of pressure you put on the pen when 
drawing. 

 6. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the size of your 
brush when using your pen with very little pressure. The minimum size is set to a percentage of your 
brush tip's maximum size, which is 25% by default. If you don't want the pressure on your pen to 
affect the brush size, set this parameter to 100%.

 7. If you want your brush tip to have uneven dimensions, use the Roundness slider to shrink the brush 
tip vertically all the while preserving its horizontal size.

 8. If you want your brush tip to be at an angle, use the Angle slider to rotate your brush tip.

 9. Use the Hardness slider to set how much of the outer part of your brush tip should fade to 
transparency. If you set it to 100 %, the brush will be completely solid. If you set it to 0 %, the brush 
will only be opaque in its center, and will gradually become transparent towards its edges. 

 10. Use the Spacing slider to set how much distance you must drag your brush before Storyboard Pro 
prints the brush tip onto your canvas, relative to your brush's size. The default setting is 7%, which 
produces a relatively realistic brush stroke-like result. If this setting is too low, your brush strokes 
might feel too thick and opaque. If this setting is too high, your strokes will look like the brush tip has 
been stamped repeatedly over your canvas instead of dragged on it.

 11. If you want the size of your brush tip to vary each time it's printed on your canvas, set the 
Random Size setting to any value above 0 %.

 12. If you want the angle of your brush tip to be random each time the tip is printed on your canvas, set 
the Random Angle setting to any value above 0 °.

 13. If you want the spacing between each instance of the brush tip to be random, set the Random 
Spacing setting to any value above 0 %.
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 14. If you want the spacing between each instance of the brush tip to be random, set the Random 
Spacing setting to any value above 0 %.

 15. In the Stage view, start drawing to test your brush settings.
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Configuring a Brush with a Paper Texture
Paper textures are bitmap textures that you can apply to your brush strokes as you draw. They act as 
transparency filters that are tiled over your brush strokes to make them look grainy, as if you were drawing on a 
rough paper surface. While Storyboard Pro comes bundled with preset paper textures, it is also possible to 
create and use your own paper textures. 

How to configure a brush with a paper texture

 1. In the Brush Properties dialog, click on the Paper Texture tab.

 2. Check the check box in the Paper Texture tab to enable paper textures.
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 3. In the paper texture list, select the desired paper texture. If you wish to create your own paper 
texture, see Adding a Paper Texture on page 243.

 4. Using the Texture Scale slider, select the scaling factor at which to scale the paper texture when 
applying it to your brush strokes.

 5. If you want your brush strokes to get more opaque as you drag your brush or when you draw over 
them, enable the Additive option.

 6. If you want the paper texture to always be aligned to the same grid regardless of where you draw 
your strokes, enable the Aligned option. Otherwise, your paper textures will be positioned relative 
to where you start your drawing stroke, and if you draw two strokes one over the other, their paper 
textures will clash with each other.

 7. In the Stage view, start drawing to test your brush settings.
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Adding a Paper Texture
In the Brush Properties dialog, you will find a set of default paper textures which are bundled with Storyboard 
Pro, but you can also create your own paper textures, then export your collection or import an existing set. 

To make your own paper texture, you must first create an image file containing the texture, either in Storyboard 
Pro or in a third party software, like Adobe Photoshop, then import it into Storyboard Pro. A paper texture 
must be a greyscale image. Colors in paper textures are not acknowledged by Storyboard Pro, as paper 
textures are applied onto the colour you are painting with in Storyboard Pro. Your texture should also not 
contain transparency, as Storyboard Pro determines the texture's transparency based on its black, white and 
grey levels. When drawing with a paper texture, its black parts will appear 100% opaque, its white parts will 
appear 100% transparents, and its grey parts will appear semitransparent. 

You can import brush tips in any image format supported by Storyboard Pro. It is recommended to create paper 
textures in a resolution ranging from 100 x 100 pixels to 400 x 400 pixels.

Like brush tips and brush presets, paper textures are saved in your preferences. You can also export your paper 
textures into an .xml file, and import them on a different workstation, allowing you to share your textures 
between the different people collaborating on your project.

How to add a paper texture

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.

 1. Click on the Paper Texture tab.

 2. Check the check box in the Paper Texture tab to enable paper textures.
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 1. In the Brush Properties dialog, do one of the following:

 l From the Paper Texture menu, select Add.

 l Click the Add Paper Texture button.

 2. In the browser window that appears, navigate to where you saved your texture file.

 3. Click Open to import the file into the Paper Texture library.

By default, an imported texture is given the name of the image file.
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Renaming a Paper Texture
You can rename your paper textures to keep your list organized. 

How to rename a paper texture

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.

 1. Click on the Paper Texture tab.

 2. Check the check box in the Paper Texture tab to enable paper textures.

 3. Select the texture you want to rename.

 4. Click on the Paper Texture menu icon  and select Rename.
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 5. In the Rename Texture dialog box that appears, type in the new name for the texture. 

 6. Click OK.
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Deleting Paper Textures
You can delete unnecessary paper textures from your preset list. 

How to delete a paper texture

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.

 1. Click on the Paper Texture tab.

 2. Check the check box in the Paper Texture tab to enable paper textures.

 1. Select the texture you want to delete.

 2. Do one of the following:

 l Click on the Paper Texture menu icon  and select Delete.

 l Click the Delete  button.
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NOTE 

You can delete any paper texture in the Paper Texture library, including the 
default paper textures, as long as no brush preset is using that paper texture. 
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Exporting Paper Textures
You can export paper textures into an .xml file which will contain their name and bitmap texture. This can be 
useful if you wish to back up or share your paper textures. 

How to export paper textures

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.

 4. Click on the Paper Texture tab.

 5. Check the check box in the Paper Texture tab to enable paper textures.

 6. Click on the Paper Texture menu icon  and select Export.

The Export Tips and Textures dialog opens. This dialog allows you to export both your textured 
brush tips and your paper textures.
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 7. By default, both your brush tips and your paper textures are selected for export. If you only wish to 
export your paper textures, uncheck the Select Brush Tips option.

 8. Click on the Export button.

 9. In the Export Textures dialog that appears, browse to a location where you would like to save the 
.xml file, then type in the desired file name.

 10. Click Save.
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Importing Paper Textures
You can import paper texture presets you previously exported from Storyboard Pro. 

How to import paper textures

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.

 4. Click on the Paper Texture tab.

 5. Check the check box in the Paper Texture tab to enable paper textures.

 6. Click on the Paper Texture menu icon  and select Import.

 7. In the browser window that appears, navigate to and select  the .xml file in which you exported 
your paper textures. 

 8. Click Open.

In the Import Tips and Textures dialog box appears.
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 9. If the selected .xml file also contains brush tips, they will be selected for import along with the 
paper textures by default. If you only wish to import the paper textures, uncheck the Select 
Brush Tips option.

 10. Click Import.

The imported paper textures will appear in the Paper Texture Library. 
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Changing the Paper Texture Display
You can change the way the paper textures are displayed in the paper textures list of the Brush Properties 
dialog.

How to change the Paper Texture thumbnail display

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.

 4. Click on the Paper Texture tab.

 5. Check the check box in the Paper Texture tab to enable paper textures.

 1. Click on the Paper Texture menu icon .

 2. Select one of the following options:

 l Small Thumbnail: Displays paper textures in a grid of small thumbnails.
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 l Large Thumbnail: Displays paper textures in a grid of large thumbnails with their 
names. The default view setting. 

 l List View: Displays paper textures in a list, with their name on the left and their 
texture on the right of each row. 
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About Brush Presets
Setting up your brush to perfectly reproduce the desired art style can require a lot of tweaking as well as trial 
and error. Once you have found the correct settings for your brush, you will want to reuse it throughout your 
project for consistency. You can do that by creating and using brush presets.

Storyboard Pro comes preloaded with many brush presets which you can select from the Tool Properties view. 
It is also possible to create your own brush presets by configuring your brush, then saving it as a preset. 

Like brush tips and paper textures, brush presets are saved in your preferences. You can also export your brush 
presets into an .xml file, and import them on a different workstation, allowing you to share your brush presets 
between the different people collaborating on your project.

NOTES 

 l Brush presets are not to be confused with brush tips and paper textures. A brush tip is one of 
the properties of a brush. A brush preset contains all of the properties for a given brush. 
However, both can be exported, imported and managed similarly. 

 l Brush presets for vector layers and for bitmap layers are separate. A brush preset created while 
working on a vector layer cannot be used when working on a bitmap layer, and vice versa. 
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Creating a Brush Preset
You can create your own custom brush presets by configuring your brush, then adding it as a preset. 

How to create a brush preset

 1. Make sure the current drawing layer is vector if you wish to create a vector brush preset, or bitmap if 
you wish to create a bitmap brush preset—see About Layer Types on page 174.

 2. In the Tools toolbar, select the Brush  tool or press Alt + B.

 3. Click on the Arrow button to open the Brush Properties dialog.

 4. Configure your brush to be exactly how you wish to use it in the future—see Creating a Solid  Brush 
or Creating a Textured Brush.

 5. Do one of the following:

 l From the Brush Properties dialog, click on the New Brush Preset  button in the top-
right corner. 

 l In the Tool Properties view, click the New Brush Preset  button.

 l In the Tool Properties view, open the Brush Presets  menu  and select New Brush 
Preset.

 6. In the New Preset window, type a name for your new brush preset.

Your new brush preset is added to the end of the list of brush presets.
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Selecting a Brush Preset
Storyboard Pro provides you with default brush presets available in the Tool Properties view. 

How to select a brush preset

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. In the Tool Properties view, select a brush preset from the Presets list.
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Updating a Brush Preset
If you want to modify the settings of an existing custom preset, you can do so by adjusting the parameters in 
the Tool Properties view, then updating your preset with your brush current's parameters.

How to update a brush preset

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 1. In the Tool Properties view, select the Brush Preset you wish to update.

 2. Click on the Arrow button to open the Brush Properties view.

 3. Configure your brush to be exactly how you wish to use it in the future—see Creating a Solid  Brush 
or Creating a Textured Brush.

 4. Click on the Update Brush Preset  button  in the upper-right corner of the Brush Properties 
dialog. 
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Renaming a Brush Preset
To keep your list comprehensive and organized, you can name your custom brush presets.

How to rename a brush preset

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. In the Tool Properties view, select a brush preset to rename. 

 3. Open the Brush Preset menu  and select Rename Brush. 

 4. Type in a new name for the brush and click OK.
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Deleting a Brush Preset
You can keep your preset list clean by deleting unwanted custom presets. 

How to delete a brush preset

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. In the Tool Properties view, select the brush preset you want to delete.

 3. Do one of the following:

 l Click the Delete Brush  button.

 l Open the Brush Preset menu  and select Delete Brush.
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Exporting Brush Presets
You can export brush presets into an .xml file which will contain all of your brush's settings. This can be useful 
if you wish to back up or share your brush presets.

How to export pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Export Brushes.

The Export Brushes dialog opens. This dialog allows you to export brush presets for the Brush, 
Pencil and Eraser tools. 

 3. By default, the presets for all your tools will be selected for export. If you only wish to export presets 
for specific tools, uncheck Select/Deselect All and select the tools for which you want to export the 
presets.

 4. Click Export.

 5. In the Export Presets dialog that appears, browse to the location where you want to save the .xml 
file and enter its file name.

 6. Click Save.
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Importing Brush Presets
You can import brush presets that you previously exported from Storyboard Pro. 

How to import pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Import Brushes.

 3. In the browser window that appears, navigate to and select the .xml file in which you exported 
your brush presets.

 4. Click Open.

The Import Brushes dialog box opens.

 5. By default, the presets for any tools included in the file will be selected for import. If you only wish to 
import presets for specific tools, uncheck Select/Deselect All and select the tools for which you want 
to export the presets

 6. Click Import.

The imported brush, eraser and pencil styles will appear in the Presets list.
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Changing the Brush Preset Display
You can display your preset list as thumbnails or a list. 

How to change the way presets are previewed in the Tool Properties view

 1. In the Tool Properties view, open the Brush Presets  menu.

 2. Select one of the following options:

 l Small Thumbnail: Displays presets in a grid of small thumbnails with a preview of their 
tip.

 l Large Thumbnail: Displays presets in a grid of big thumbnails, with their name and a 
preview of their tip.

 l Stroke View: Displays presets in a list, with their name and a preview of a stroke done 
with each preset. 
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About the Brush Tool Modes
The Brush tool creates contour lines as you draw on vector layers, adding each brush line on top of the previous 
ones. On bitmap layers, the Brush tool creates 2D graphics, laying down individual pixels.

When you select the Brush tool, the Tool Properties view displays the different Brush modes that control how 
the brush line is drawn:  Draw Behind and Auto Flatten. Click on the Brush Mode buttons to enable or disable 
the different states.

 Draw Behind Mode
When enabled, your drawing strokes will be added underneath the existing artwork instead of over it.

NOTE 

Your stroke will  appear over your artwork as you draw it, until you release the mouse cursor or 
tablet pen.  If you want a live preview of your stroke, activate the Realistic Preview option by 
selecting View > Realistic Preview from the top menu.
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  Auto Flatten Mode 
By default each brush stroke you draw is stored as a separate drawing object that can be manipulated 
individually. With the Auto Flatten option enabled, all overlapping brush strokes will be merged together into a 
single drawing object. This will make your artwork lighter in both file size and processing time, but may limit 
your ability to tweak and modify your artwork. 
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About the Pencil Tool
The Pencil  tool is used to draw and sketch on vector layers.

Vector strokes produce files that are very light, and are ideal for long projects because you do not have to 
compromise on efficiency during playback.  Also, you can modify the shape of the lines after you draw them 
using the Contour Editor or Perspective tool.  The strokes are stored as separate lines until the drawing is 
flattened.

• Advantage:  File sizes are light.

• Disadvantage:  Cannot get natural media-style textured drawings.

• Recommended Use:  For clean drawings, sketchy vector drawings, drawings you want to reuse from 
different distances (close, mid, far).

The Pencil tools support pressure sensitivity, allowing you to create lines with variable thickness, producing 
central vector lines of constant or variable width, making a clean line. This means that a pencil line’s control 
points (used to deform its shape) are located along the length of the central spine. The Pencil tool is very useful 
for tracing, clean or final drawings.

You can customize pencils, controlling the line’s colour, size, smoothness, and the minimum and maximum 
width.
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Drawing with the Pencil Tool
T-SBFND-008-003

You can draw with the Pencil tool to create central vector lines.

How to draw with the Pencil tool

 1. In the Thumbnails or Timeline view, select the panel on which you want to draw.

 2. In the Camera, Stage, or Thumbnails view, select a vector layer to draw on.

 3. In the Tools toolbar, select the Pencil  tool or press Alt + 9.

 4. You can change the current colour by adjusting the sliders in the Colour view, or click a swatch to 
use that colour.  To add colour swatches—see Adding Colour Swatches on page 433. 
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 5. In the Stage view, start drawing.

TIPS 

 l If you press and hold the Shift key before you start drawing, your stroke will be a straight 
line. 

 l If you press and hold the Shift key while you're drawing, the part of your stroke from that 
point on will be a straight line until you release the Shift key. 

 l If you press and hold the Shift and the Alt keys before drawing, your stroke will be a 
straight line in an angle that is a multiple of 15 degrees. 

 l If you press and hold the Ctrl (Windows) or ⌘  (macOS) key while drawing, your stroke will 
be a closed shape.

 l If you press and hold the Alt key, your tool will snap in a straight line to the nearest existing 
shape. 
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Using Pencil Presets
When you select the Pencil tool, its properties and options appear in the Tool Properties view. You can use 
these properties to change the size of the pencil line, define how the line size responds to pressure on the 
stylus, how the line acts in relation to other lines in the scene, and how to modify the line’s direction and size 
after it has been drawn.

The Preview area lets you see a preview of the stroke your drawing tool will make.

You can set the minimum and maximum sizes of your tool, which will produce the thick and thin effect on your 
line. This works with the pressure sensitivity of a pen tablet.

Also, you can optimize the smoothness of the contour of lines. You can modify the central line smoothness of 
your line using this option. This parameter smooths the initial movement of your line. Increasing the value will 
result in a smoother line with fewer less control points.

There are several line shapes to choose from. You can select how the start, end, and joints in the pencil line are 
drawn. 

Using the Pencil tool, you can draw invisible lines. This can be useful to draw tones and highlights directly on 
the character.

How to change the Presets display

 l In the Tool Properties view, click the Brush  menu, and select Small Thumbnail, Large 
Thumbnail, or Stroke View. 
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How to select a pencil style

 l In the Tool Properties, select a pencil style from the Presets section.

How to add a pencil preset

 1. Click the Add Brush  button. The new pencil style appears in the list of presets. 

How to rename a pencil preset

 1. In the Tool Properties view, select a pencil to rename. 

 2. From the Brush menu, select Rename Brush. 

 3. Type in a new name for the pencil.

How to delete a pencil preset

 1. In the Tool Properties view, select a pen to delete. 

 2. Do one of the following:
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‣ Click the Delete Brush  button.

‣ From the Brush menu, select Delete Brush.

How to adjust the size, smoothness and contour of lines

 1. In the Tool Properties view, click the arrow button.

The Properties window of the current tool opens.

 2. Do the following: 

‣ Maximum Size: Defines the maximum width of the line. 

‣ Minimum Size: Defines the minimum width of the line as a percentage of the maximum size.

‣ Smoothing: Defines the number of control points added to the centre line. 

‣ Contour Smoothing: Defines the number of control points added to the contour boundaries 
(around the line).

Lower values mean that the line will appear as you draw it (with more control points along the 
centre line). Higher values mean that the line will be smoothed out (removing control points from 
the centre line).

How to change the line shape

 1. In the Pencil Properties window, click a line shape in the Shape section. 

‣ Start: Make the beginning of the line round or flat. 

‣ End: Make the end of the line round or flat.
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‣ Join: Make joints round, mitred, or bevelled. 

How to draw invisible lines

 1. Select the panel and layer on which you want to draw.

 2. In the Tools toolbar, select the Pencil  tool or press Alt + 9.

 3. In the top menu, select View > Extras > Show Strokes to display the invisible lines in the Stage 
view.

 4. In the Tool Properties view, set the size to 0. You can also adjust the smoothness.

 5. In the Stage view, start drawing.

 6. You can modify the stroke shape with the Contour Editor  tool—see About the Contour Editor 
Tool on page 344.

272



About the Pencil Tool Modes
The Pencil tool allows you to draw simple contour lines that are defined by their centerline and their thickness. 

When you select the Pencil tool, the Tool Properties view displays the different Pencil modes that control how 
the pencil line is drawn.

 Draw Behind Mode
When enabled, your drawing strokes will be added underneath the existing artwork instead of over it.

NOTE 

Your stroke will  appear over your artwork as you draw it, until you release the mouse cursor or 
tablet pen.  If you want a live preview of your stroke, activate the Realistic Preview option by 
selecting View > Realistic Preview from the top menu.
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 Auto-Fill Mode 
When enabled, if you draw a closed shape, it will automatically be filled with the selected colour.

 Trim Extra Lines Mode 
When enabled, if you draw a closed shape, the lines extending from the point where your stroke intersects 
with itself will be automatically trimmed off.

 Align Handles After Trim Mode 
If the Trim Extra Lines Mode  is enabled, enable this to automatically smoothen the corner at which your 
stroke intersects with itself. 

 Auto Flatten Mode 
By default each pencil line you draw is a separate drawing object which can be manipulated individually. With 
the Auto-Flatten mode enabled, overlapping pencil lines will be merged together into single drawing objects. 
Pencil lines will be broken where they intersect, allowing you to select any segment of your artwork as if it was 
a separate stroke. 
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 Auto Close Gap Mode 
When enabled, small gaps between the pencil lines you draw will be closed by an invisible stroke to make sure 
your shapes are closed and that they can be filled with the Paint tool.

When drawing contours with pencil lines, the centreline is used to determine whether or not the contour is 
closed, but the visible tips of the pencil line will extend a bit beyond the tips of its centreline, making it possible 
to have shapes that appear closed, but are not really. This can prevent the shape from being filled with the 
Paint tool. Enabling this option when drawing with the Pencil or Line tool will prevent you from leaving 
invisible gaps in your contours.
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About the Rectangle, Ellipse and Line Tools

The rectangle, ellipse and line tools allow you to quickly add solid regular shapes and straight lines to your 
artwork. Drawing with are made of pencil lines, which means they are defined by a centreline to which 
Storyboard Pro adds an even thickness.
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Drawing lines with the Line Tool
You can draw simple straight or curved lines using the Line tool. The line will be added to your artwork as a 
simple pencil stroke.

How to draw with the line tool

 1. In the Timeline or Thumbnails view, select the panel, then layer on which you want to draw.

 2. In the Tools toolbar, select the Line  tool.

 3. In the Stage view, click and hold where you want the line to start, then move the mouse cursor 
where you want the line to end. 

 l If you want to snap the angle of your line to the nearest 15° angle, hold the Shift key.

 l If you want to snap the end of your line to the nearest shape, hold the Alt key.

 l If you want to draw a curved line, hold Ctrl (Windows) or ⌘  (macOS). The line will end where 
your mouse cursor currently is, and moving the mouse cursor will pull the line's curve towards 
it. 

TIP 

You can use the Contour Editor  tool to tweak the shape of your line—see About the 
Contour Editor Tool on page 344.                 
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Drawing shapes with the Rectangle or Ellipse tools
You can draw rectangles, squares, ellipses and circles using the Rectangle and Ellipse tools. The shapes will be 
added to your artwork using pencil lines.

How to draw with the rectangle or ellipse tool

 1. In the Timeline or Thumbnails view, select the panel and layer on which you want to draw.

 2. In the Tools toolbar, select the Rectangle  or Ellipse  tool.

 3. In the Stage view, click and hold where you want one of the corners of your shape to be, then move 
the mouse cursor where you want the opposing corner of the shape to be.

 l To draw a perfect square or circle (with equal width and height), hold the Shift key.

 l To draw the rectangle or ellipse from its centre instead of its corner, hold the Alt key.

TIP 

You can use the Contour Editor  tool to tweak the shape of your line—see About the 
Contour Editor Tool on page 344.                 
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About the Rectangle, Ellipse and Line Tool Modes
When you select the Rectangle, Ellipse, Polyline or Line tool, the Tool Properties view displays the different 
modes that control how the shape is drawn. Different modes are available depending on the selected tool and 
whether the layer is vector or bitmap. 

 Draw Behind Mode
When enabled, your drawing strokes will be added underneath the existing artwork instead of over it.

NOTE 

Your stroke will  appear over your artwork as you draw it, until you release the mouse cursor or 
tablet pen.  If you want a live preview of your stroke, activate the Realistic Preview option by 
selecting View > Realistic Preview from the top menu.
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 Auto Fill Mode 
When enabled, the shape you draw is automatically filled with the selected colour. By default, drawing a shape 
only creates its outlines. 

 Snap to Contour 
When enabled, while you're drawing, the mouse cursor will automatically snap to the nearby contours of 
existing artwork, allowing you to draw shapes that connect with other parts of your drawing. 

NOTE 

If you draw a line with the Line tool and make its tip snap to a contour or another control point in 
your artwork, they will be locked together. You can then manipulate both simultaneously using the 
Contour Editor  tool. You can also separate two drawing strokes that have been snapped 
together by selecting one of them with the Select  tool and moving it away.

 Snap and Align
When enabled, while you're drawing, the mouse cursor will automatically align with the edges of strokes and 
shapes in your artwork, allowing you to draw shapes that align with parts of your drawing.
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 Auto Flatten Mode 
By default each pencil line you draw is a separate drawing object which can be manipulated individually. With 
the Auto-Flatten mode enabled, overlapping pencil lines will be merged together into single drawing objects. 
Pencil lines will be broken where they intersect, allowing you to select any segment of your artwork as if it was 
a separate stroke. 

 

 Auto Close Gap Mode 
When enabled, small gaps between the pencil lines you draw will be closed by an invisible stroke to make sure 
your shapes are closed and that they can be filled with the Paint tool.

When drawing contours with pencil lines, the centreline is used to determine whether or not the contour is 
closed, but the visible tips of the pencil line will extend a bit beyond the tips of its centreline, making it possible 
to have shapes that appear closed, but are not really. This can prevent the shape from being filled with the 
Paint tool. Enabling this option when drawing with the Pencil or Line tool will prevent you from leaving 
invisible gaps in your contours.

 

NOTE 

This option is only available with the Line  tool, as the Rectangle  and Ellipse  tools will 
always create closed shapes.
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About the Polyline Tool
The Polyline tool allows you to create a line or a shape composed of multiple segments by defining each point in 
the shape one by one. This tool works similarly to the Pen tool in picture editing software.

The most basic approach to using the Polyline tool is to simply click where you want each point constituting 
your line or shape to be created. Straight line segments will appear between each point you create, making a 
segmented line or a straight shape. 

If you want your line or shape to have curves, you can then click and drag on the line segments using the 
Contour Editor  tool to make them into curves. 

Using a more advanced method, you can create curved lines directly with the Polyline tool. To do this, you must 
hold the mouse button down and drag the mouse cursor when you click to create a point. This will create the 
point's Bezier handles, which will influence the curve for the segment before and after this point. Hence, as you 
drag out these Bezier handles, you can see the influence it has on the line segment you just created, but you 
won't get to see its influence on the next line segment you create until you create the next point. 

Regardless of how you use the Polyline tool, you can always tweak the lines and shapes you have created using 
the Contour Editor  tool. Using both tools together allows you to create complex straight and curved shapes 
with all the precision you need. 
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Drawing with the Polyline Tool
T-SBFND-008-007A

You can use the Polyline tool to draw complex segmented lines or curved lines by creating each point 
constituting the line. 

How to draw with the Polyline tool

 1. In the Timeline or Thumbnails view, select the panel, then layer on which you want to draw.

 2. In the Tools toolbar, select the Polyline   tool.

 3. In the Stage  view, do one of the following:

 l Click to create a point with no Bezier handles.

 l Click and drag to create a point and its Bezier handles in the same stroke.

TIP 

While dragging to create a Bezier handle, you can:

 l Hold the Alt key to only change the angle of the outer handle, and leave the inner 
handle at its current angle.

 l Hold the Shift key to lock the angle of the handle at every 15 degrees. 

 4. Click or click and drag somewhere else to create the second point in your line. A line will be drawn 
between the first point and the second point. 

 

 5. Repeat the previous step until your line is complete. 

 6. While holding Ctrl (Windows) or ⌘  (macOS), click anywhere in the drawing space to release 
the Polyline tool from the line you've been building. You can then start building a new line. 

 7. If you want to make adjustments to the line you created, you can use the Contour Editor  tool—
see Reshaping with the Contour Editor Tool.

283

Storyboard Pro 6. User Guide                          



Chapter 7: Drawing

About the Polyline Tool Modes
When you select the Polyline tool, the Tool Properties view displays the different modes that control how the 
shape is drawn. 

 Snap to Contour
When this option is enabled, clicking close to a contour in your drawing will add the point to that contour. The 
line you are building will be linked to that contour.

If this option is disabled, attempting to click on existing contours will always create a point very close to that 
contour, but not exactly on it. Therefore, it is necessary to enable this mode if you want to create lines that 
branch from into existing contours in your drawing.
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NOTE 

If you draw a line with the Line tool and make its tip snap to a contour or another control point in 
your artwork, they will be locked together. You can then manipulate both simultaneously using the 
Contour Editor  tool. You can also separate two drawing strokes that have been snapped 
together by selecting one of them with the Select  tool and moving it away.

 Auto-Fill Mode 
When enabled, if you draw a closed shape, it will automatically be filled with the selected colour.

 Trim Extra Lines Mode 
When enabled, if you draw a closed shape, the lines extending from the point where your stroke intersects 
with itself will be automatically trimmed off.

 Align Handles After Trim Mode 
If the Trim Extra Lines Mode  is enabled, enable this to automatically smoothen the corner at which your 
stroke intersects with itself. 

 Auto Flatten Mode 
By default each pencil line you draw is a separate drawing object which can be manipulated individually. With 
the Auto-Flatten mode enabled, overlapping pencil lines will be merged together into single drawing objects. 
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Pencil lines will be broken where they intersect, allowing you to select any segment of your artwork as if it was 
a separate stroke. 
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About the Stamp Tool
The Stamp tool allows you to create stamps out of drawings in your projects, then stamp those drawings over 
your artwork. You can click on your artwork to apply your stamp once, or draw a stroke with the Stamp tool, as 
you would with the Brush or Pencil tool, to apply the stamp repeatedly along the stroke.

A stamp can contain one or several drawings. When a stamp is made of multiple drawings, it will cycle through 
each one of its drawings each time it is stamped onto your artwork. Hence, when you draw a stroke with a 
multi-drawing stamp, you will see the stamp tool cycle through the sequence of drawings as you draw the 
stroke. The way the drawings in a multi-drawing stamp are cycled through can even be customized. Among 
other settings, you can make it cycle backward, stamp random drawings or even stamp only a specific drawing 
in the sequence. 

Other than being able to easily re-use drawings, The Stamp tool can be used to streamline drawing if you need 
to draw something that requires a lot of repetitive detail, such as starry skies, grass, weather conditions or 
particle-type effects. For example, a stamp made of a few different drawings of a blade of grass can be used to 
draw a grass line by drawing a few strokes of that stamp over the same horizontal line. The ability to 
randomize the size, angle and distance of the stamping can give the result of using this procedure a more 
natural look. 
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NOTES 

 l To learn more about the Stamp tool properties, see the Reference Guide

 l The Stamp tool replaces the Dynamic Brush option of the Brush tool in Storyboard Pro 5.5 and 
earlier.
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Creating a Stamp
T-SBADV-005-012C

You can create a stamp by drawing the artwork for your stamp, then selecting it and creating a stamp preset. 

How to create a stamp 

 1. Create a vector layer in which you will draw the artwork for your stamp by doing one of the 
following:

 l In the Layer panel, the Layer toolbar or the Layers view, click on Add Vector Layer .

 l In the top menu, select Layer > New > Vector Layer.

 2. In the new vector layer, draw the artwork with which you want to create a stamp. 

 3. Do one of the following:

 l If you want to create a stamp with all the artwork in the layer, select this layer in the Layer 
panel, the Layers view or the Thumbnails view.

 l If you want to create a stamp with part of the artwork in the layer, select the Select  tool in 
the Tools toolbar, then select the parts of the artwork you want to have in your stamp—see 
Selecting Artwork with the Select Tool on page 327.

 4. In the Tools toolbar, select the  Stamp  tool.

 5. In the Tool Properties view, click on the New Preset  button.

 6. In the New Preset dialog, type the desired name for your new stamp.
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 7. Click OK.

A stamp containing the selected artwork is added to the Presets list for the Stamp tool. You can 
now draw with the Stamp tool using this stamp.

NOTE 

Once your stamp has been created, you can delete the artwork you used to create it from your 
project. The artwork in your stamps will be saved in your preferences.
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Creating a Multi-Drawing Stamp
You can create a stamp containing a series of  drawings. All you need to do is create each drawing you want to 
add to your stamp in a separate layer, then create a stamp with these layers selected. The resulting stamp will 
cycle through each one of these drawings as you use it. 

How to create a multi-drawing stamp 

 1. In the current panel, create one vector layer for each drawing you want to have in your stamp, by 
doing one of the following: 

 l In the Layer panel, the Layer toolbar or the Layers view, click on Add Vector Layer .

 l In the top menu, select Layer > New > Vector Layer.

NOTE 

You do not have to worry about the order in which the layers are for now, as you can 
decide in which order each layer is added to your stamp later. 

 2. In the first layer you have created, create the first drawing you want to have in the drawing 
sequence of your stamp.

 3. In the second layer you have created, create the second drawing you want to have in the drawing 
sequence of your stamp.

 4. Repeat until you have created every drawing you want to have in the drawing sequence of your 
stamp. 
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 5. In the Layer panel of the Layers view, select all the layers you want to have in your stamp. The order 
in which you select the layers will affect the order in which the drawings are sequenced in your 
stamp, hence:

 l If you want the drawing sequence to go from the bottommost layer to the topmost layer, click 
on the bottommost layer then, while holding Shift, click on the topmost layer. This will select 
all layers between the layers you clicked inclusively, in order from bottom to top.

 l If you want the drawing sequence to go from the topmost layer to the bottommost layer, click 
on the topmost layer then, while holding Shift, click on the bottommost layer. This will select 
all layers between the two layers you clicked inclusively, in order from top to bottom.

 l If you want to create a sequence going through the drawings in your layers in a more specific 
order, press and hold the Ctrl key, and click on each layer you want to add to your stamp, in 
the order in which you want them to be in the sequence. 

 l If you want to exclude any of the selected layers from your sequence, hold Ctrl and click on 
each one of the selected layers you want to exclude to unselected them. 

 6. In the Tools toolbar, select the   Stamp  tool.

 7. In the Tool Properties view, click on  New Preset.

The New Preset dialog appears.

 8. In the New Preset dialog, type the desired name for your new stamp.
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 9. Click OK.

A multi-drawing stamp containing the artwork in all the selected layers is added to the Presets list. 
The first drawing in the sequence appears in its thumbnail. 

 10. To preview the sequence of drawings in your stamp, select it in the Presets list. The sequence will 
appear in the preview area at the top of the Tool Properties view. 

NOTE 

Once your stamp has been created, you can delete the artwork you used to create it from your 
project. The artwork in your stamps will be saved in your preferences.
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Configuring a Stamp
When drawing a stroke with the stamp tool, the way the stamp is applied in terms of size, angle, spacing can 
be customized.

How to configure the size, pressure sensitivity, roundness, angle and spacing of a 
stamp

 1. In the Presets list of the Tool Properties view, select the stamp that you want to configure.

 2. In the Tool Properties view, just right of the stroke preview area, click on the Show Extended 
Properties   button.

The Stamp Properties dialog opens.

 3. If you want to adjust the size of the stamp, change the Maximum Scale setting until you obtain the 
desired size.

NOTE 

The Scale of a stamp is relative to the original size of the drawing used to create the 
stamp. At 100% scale, the stamp added to your artwork will be the same size as its 
original drawing. 
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 4. If you're using a pressure-sensitive pen tablet and want the size of the stamp to depend on the 
amount of pressure you put on your pen, reduce the Minimum Scale setting. 

 5. If you would like to flip the stamp horizontally, click on the two-ended horizontal arrow  over the 
stamp thumbnail. If you would like to flip the stamp vertically, click on the two-ended vertical arrow 
left of the stamp thumbnails. 

 6. If your stamp is round or square, and you would like it to appear flat or squished, reduce the 
Roundness parameter. This will scale down the stamp vertically.

 7. If you want your stamp to be added to your artwork at an angle, change the Angle parameter. This 
setting rotates the stamp counterclockwise, on a 360 degrees scale.

 8. If you want to change the amount of space between each stamp when you draw a stroke with the 
Stamp tool, adjust the Spacing parameter. 

 9. If you want the current settings to be saved to your stamp preset, click on the Update Brush Preset 
 button at the top-right corner of the Stamp Properties dialog.

NOTE 

You can use the Stamp tool with the currently selected settings without updating your 
preset. 

You can randomize the size, angle and spacing of the stamp. This will make the Stamp tool apply a randomly 
picked value to these parameters every time it applies a stamp to your artwork.
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How to randomize the size, angle and spacing of a stamp

 1. In the Presets list of the Tool Properties view, select the stamp that you want to configure.

 2. In the Tool Properties view, just right of the stroke preview area, click on the Show Extended 
Properties   button.

The Stamp Properties dialog opens.

 3. If you want the size of the stamp to be randomized every time the stamp is added to your artwork, 
decrease the Minimum Scale setting, then increase the Random Size setting.

NOTE 

The Random Size setting makes the size of each stamp vary randomly between its 
Minimum Scale and Maximum Scale. The higher the Random Size is, the closer to its 
Minimum Scale the random size can be.
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 4. If you want the angle of your stamp to be randomized every time the stamp is added to your 
artwork, increase the Random Angle setting.

 5. If you want the spacing of your stamp to be randomized every time the stamp is added to your 
artwork, increase the Random Spacing setting.

 6. If you want the current settings to be saved to your stamp preset, click on the Update Brush Preset 
 button at the top-right corner of the Stamp Properties dialog.

NOTE 

You can use the Stamp tool with the currently selected settings without updating your 
preset. 

You can make a multi-drawing stamp cycle through its sequence of drawings in several different ways. You can 
also randomize the cycle, or disable it so that it only stamps the drawing of your choice. 

How to change the way a multi-drawing stamp cycles through its drawings

 1. In the Presets list of the Tool Properties view, select the stamp that you want to configure.

 2. In the Tool Properties view, just right of the stroke preview area, click on the Show Extended 
Properties   button.
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The Stamp Properties dialog opens.

 1. In the Cycle drop-down, select the desired cycling method:

 l Forward: Starts by applying the first drawing in the sequence, then the next one, and so on 
until it reaches the last drawing in the sequence, then cycles back to the first one.

 l Reverse: Starts by applying the last drawing in the sequence, then the previous one, and so 
on until it reaches the first drawing in the sequence, then cycles back to the last one.

 l Forward->Reverse: Starts by cycling forward through the sequence until it reaches the last 
drawing, then cycles backward to the first drawing, and so on.

 l Reverse->Forward: Starts by cycling backward through the sequence until it reaches the 
first drawing, then cycles back to the last drawing, and so on.

 l Random: Applies a random drawing in the sequence each time the stamp is applied. 
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 l Hold: Applies a single one of the drawings in the sequence over and over again. 

 2. If you selected the Hold option, select which one of the stamps in the sequence you wish to stamp 
onto your artwork by changing the Stamp setting in the Tool Properties view. For example, if you 
only want to stamp the second drawing in the sequence, set the Stamp setting to 2.

 3. If you want the cycle to restart at the beginning of each one of your drawing strokes, enable the 
Reset Cycle for Each Stroke option.

 4. If you want the current settings to be saved to your stamp preset, click on the Update Brush Preset 
 button at the top-right corner of the Stamp Properties dialog.

NOTE 

You can use the Stamp tool with the currently selected settings without updating your 
preset. 
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Updating a Stamp
A stamp in your Presets list does not only contain its drawings, but also its properties. If you have made any 
changes to the properties of your stamp, and wish for those properties to be set automatically whenever you 
use that stamp, you can update the stamp. This will save the current properties of the stamp into its preset. 

Once that is done, the current properties of the stamp will be loaded the next time you select it from the 
Presets list, even after you close and reopen the project. 

NOTE 

You cannot update the drawings in a stamp. You can only update its parameters. If you need to use 
different drawings for your stamp, you must create a new stamp—seeCreating a Stamp on page 
289 and Creating a Multi-Drawing Stamp on page 291.

How to update a stamp

 1. In the Presets list of the Tool Properties view, select the stamp that you want to configure.

 2. In the Tool Properties view, just right of the stroke preview area, click on the Show Extended 
Properties   button.

The Stamp Properties dialog opens.
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 3. In the Stamp Properties dialog, adjust the settings of your stamp as desired—see Configuring a 
Stamp on page 294.

 4. In the top-right corner of the Stamp Properties dialog, click on the Update Preset  button.

The selected stamp properties will be loaded whenever you select this stamp, even after you close 
and reopen your project. 
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Drawing with the Stamp Tool
Once you have created a stamp, you can start drawing with it. You can either stamp it into your artwork once at 
a time, or draw strokes with the tool, making it apply the stamp repeatedly onto your artwork along your 
strokes.

How to draw with the Stamp tool

 1. In the Layer panel of the Stage or Camera view or the Layers view, select the layer on which you 
want to apply the stamp.                     

 2. In the Tools toolbar, select the  Stamp  tool.

 3. In the Tool Properties view, select a stamp from the Presets list—see Creating a Stamp on page 289 
and Creating a Multi-Drawing Stamp on page 291.

 4. Move the mouse cursor over the Stage or Camera view. You will see the stamp under your mouse 
cursor as it will be applied into your artwork. If you want to adjust the size in which it will be applied, 
adjust the Maximum Scale setting in the Tool Properties view.

 5. By default, your stamp will be applied at an even size, angle and distance. Also, if your stamp is a 
multi-drawing stamp, it will cycle through its drawings in their original order. If you want your stamp 
to be applied with different parameters, see Configuring a Stamp on page 294.

 6. In the Stage or Camera view, do one of the following:

 l To apply the stamp once, simply click where you want to apply it.

 l To draw a stroke along which the stamp is applied multiple times, simply draw a stroke with 
the tool as you would with the Brush or Pencil tool. 
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TIP 

If your stamp has multiple drawings in it, you can select which drawings to stamp by 
using the Stamp slider in the Tool Properties view. You can also cycle through the 
stamp's drawings by pressing the Left Arrow and Right Arrow keys. 

TIPS 

 l If you press and hold the Shift key before you start drawing, your stroke will be a straight 
line. 

 l If you press and hold the Shift key while you're drawing, the part of your stroke from that 
point on will be a straight line until you release the Shift key. 

 l If you press and hold the Shift and the Alt keys before drawing, your stroke will be a 
straight line in an angle that is a multiple of 15 degrees. 

 l If you press and hold the Ctrl (Windows) or ⌘  (macOS) key while drawing, your stroke will 
be a closed shape.

 l If you press and hold the Alt key, your tool will snap in a straight line to the nearest existing 
shape. 
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Renaming Stamps
You can rename stamps you have created to make them easier to identify in the Presets list. 

How to rename a stamp.

 1. In the Tools toolbar, select the Stamp  tool. 

 2. In the Presets list of the Tool Properties view, select the stamp you want to rename.

 3. Open the Brush Presets  menu, then select Rename Brush.

 4. In the Rename Brush dialog, enter the new name for your stamp.

 5. Click OK.

The stamp's new name updates in the Presets list. 
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Deleting Stamps
You can delete stamps you no longer need from the Presets list. 

How to delete a stamp.

 1. In the Tools toolbar, select the Stamp  tool. 

 2. In the Presets list of the Tool Properties view, select the stamp you want to delete.

 3. Click on the Delete Brush  button just above the Presets list.

The stamp is removed from the Presets list. 
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Exporting Stamps
You can export stamps you have created to keep a backup of them, or to import them for use in another project.

How to export stamps

 1. In the Tools toolbar, select the Stamp  tool. 

 2. In the Tool Properties view, open the Brush Preset   menu and select Export Brushes.

The Export Brushes dialog opens. This dialog allows you to export brush presets for the Brush, 
Pencil, Eraser and Stamp tools. 

 3. By default, the presets for all your tools will be selected for export. If you only wish to export your 
stamps, uncheck Select/Deselect All, then check Stamp.

 4. Click on Export.

A save dialog appears.

 5. Browse to the location where you want to save the .xml file that will contain your presets.

 6. Enter the desired file name for your presets file. 

 7. Click on Save.
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Importing Stamps
You can import stamps you have exported from another project into your current project, allowing you to reuse 
them between projects or to restore backups of your stamps. 

How to import stamps

 1. In the Tools toolbar, select the Stamp  tool. 

 2. In the Tool Properties view, open the Brush Preset menu  and select Import Brushes.

An Open File dialog appears.

 3. In the browser window that appears, navigate to and select the .xml file in which you exported 
your stamps

 4. Click Open.

The Import Brushes dialog box opens.

 5. By default, the presets for any tools included in the file will be selected for import. If you only wish to 
import the stamps from this file, uncheck Select/Deselect All and check Stamps.

 6. Click on Import.

The imported stamps will be added to the Presets list in the Tool Properties view. 
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Changing The Way Stamps Are Displayed
By default, your stamps are listed in the Tool Properties dialog as big thumbnails. You can also preview them 
with small thumbnails if you have many, or display them in a list with a preview of their stroke. The latter will 
allow you to visually identify multi-drawing stamps or stamps with randomness parameters.

How to change the way presets are previewed in the Tool Properties view

 1. In the Tool Properties view, open the Brush Presets  menu.

 2. Select one of the following options:

 l Small Thumbnail: Displays presets in a grid of small thumbnails with a preview of their 
tip.

 l Large Thumbnail: Displays presets in a grid of big thumbnails, with their name and a 
preview of their tip.

 l Stroke View: Displays presets in a list, with their name and a preview of a stroke done 
with each preset. 
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Stamp Tool Modes
When you select the Stamp tool, its properties are displayed in the Tool Properties view.

 Draw Behind Mode
When enabled, your drawing strokes will be added underneath the existing artwork instead of over it.

NOTE 

Your stroke will  appear over your artwork as you draw it, until you release the mouse cursor or 
tablet pen.  If you want a live preview of your stroke, activate the Realistic Preview option by 
selecting View > Realistic Preview from the top menu.
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About the Eraser Tool
Using the Eraser tool, you can erase portions of your drawing by drawing strokes over it. 

Just like the Brush tool, the Eraser tool is pressure-sensitive, allowing you to erase with more precision if you are 
using a pen tablet.

It is a good idea to create and save erasers with precise sizes and parameters in order to save time when 
drawing and designing. Storyboard Pro provides you with a variety of default eraser styles and allows you to 
create and save your own eraser presets. 

Just like the Brush tool, you can use the Eraser tool on both vector and bitmap layers, and you can configure an 
eraser to have a solid or textured tip, to have automatic smoothing, a dual tip and a paper texture.
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Erasing
With the Eraser tool, you can erase parts of drawings.

How to erase with the Eraser tool

 1. In the Thumbnails or Timeline view, select the panel where you want to erase.

 2. In the Thumbnails or Stage view, select a layer.

 3. In the Tools toolbar, select the Eraser  tool or press Alt + E.

 4. In the Presets list of the Tool Properties view, select a brush preset to use. 

NOTE 

To learn how to create an Eraser preset, see Creating a Solid  Eraser on page 312 and 
Creating a Textured Eraser on page 315.

 5. In the Tool Properties view, set the Maximum Size to the desired Eraser size. 

NOTE 

If you are drawing with a mouse, your strokes will always be at their maximum size. If 
you are using a pressure-sensitive tablet, your strokes will vary in size depending on the 
pressure of your pen, ranging between 25% to 100% of the maximum size. 

 6. In the Stage view, start erasing.

TIPS 

 l When working in vector, you can also use the Select  tool to select drawing objects and 
delete them instead of erasing.

 l You can also use Cutter  tool to select part of a drawing and then press Delete to erase.
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Creating a Solid  Eraser
When using the Eraser tool on a vector layer, you can use either solid vector erasers or textured vector erasers. 
By default, your eraser will be a solid vector eraser. A solid vector eraser cuts out the shape of its stroke from 
your vector artwork.

A solid vector eraser's tip can be shaped like a circle, a diamond or a square, and can be configured to have a 
specific size, aspect ratio and angle. Also, solid vector erasers can be automatically smoothed by Storyboard Pro 
as you draw.

If you are erasing on a bitmap layer, you can only use textured erasers, although you can configured a textured 
eraser to appear solid.

How to create                                      a solid vector eraser                 

 1. In the Tools toolbar, select the Eraser tool or press  Alt + B. 

 2. In the Tool Properties view,  click the arrow button to open the Eraser Properties view.

The Eraser Properties dialog opens.

312



 3. In the Eraser Type dropdown list, select Solid Vector.

 4. In the brush tip list, select either Circle, Diamond or Square. 

 5. Use the Maximum Size slider to set the maximum size of your eraser tip, in pixels. 

NOTE 

When drawing with a mouse, your eraser is always at its maximum size. When drawing 
with a pressure-sensitive pen tablet, your eraser's size will range between its minimum 
and maximum size, depending on the amount of pressure you put on the pen when 
drawing. 

 6. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the percentage 
of your eraser tip's maximum size your eraser should be when you use your pen with very little 
pressure. If you don't want the pressure on your pen to affect the eraser size, set this parameter to 
100%.
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 7. If you want your eraser tip to have uneven dimensions, use the Roundness slider to shrink the 
eraser tip vertically all the while preserving its horizontal size.

 8. If you want your eraser tip to be at an angle, use the Angle slider to rotate your brush tip.

 9. Click on the Smoothing tab.

 10. Use the Centerline Smoothing slider to set the amount of smoothing Storyboard Pro should 
perform on your  stroke's direction, curves and corners. A higher setting will prevent your line from 
being shaky, but is liable to reduce your drawing precision and to round sharp corners into curves.

 11. Use the Contour Smoothing slider to set the amount of smoothing Storyboard Pro should perform 
on your stroke's contour. A higher setting will round sharp corners and reduce the amount of control 
points for the resulting vector shape. 

 12. Either close or set aside the Eraser Properties dialog.

 13. In the Camera or Drawing view, start erasing to test your eraser settings.
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Creating a Textured Eraser
A textured eraser can have the same settings as a textured brush: It can have a bitmap tip of any shape, can be 
hard or soft, semi-transparent, combine two tips and be applied with a paper texture effect.

When working on a bitmap layer, the eraser tool is always textured, whereas when working on vector layers, 
erasers are solid vector by default. A solid vector eraser merely cuts out the shape of the eraser stroke from the 
vector artwork, whereas a textured vector eraser makes the artwork's bitmap texture more opaque or fully 
invisible, depending on its intensity, then cuts out some of the vector artwork that the eraser made fully 
invisible. 

A textured eraser works like a reverse textured brush: It makes the pixels in a brush stroke's texture more—or 
completely—transparent, depending on the eraser's intensity. This effect can only be obtained by using a 
textured eraser on a textured brush stroke. If you use a textured eraser on solid vector shapes or on pencil lines, 
the eraser will act like a solid vector eraser, that is, it will merely cut out the shape of the stroke from the 
artwork. This is because solid vector shapes and pencil lines don't have a bitmap texture, and therefore the 
textured eraser cannot work on the opacity of their individual pixels. Hence, when working on vector layers, it 
is better to use a textured eraser only if all your artwork is composed of textured brush strokes, or it might wield 
strange-looking results. 

This outlines one of the advantages of working with bitmap layers. On bitmap layers, your brushes and erasers 
always work as textured brushes and erasers. 

Another issue you might encounter when erasing textured vector artwork is that textured vector brush strokes 
are not flattened together, whereas on bitmap layers, your artwork is always flattened. This implies that if you 
use a semi-transparent eraser on textured vector artwork, and the artwork has overlapping strokes, all the 
strokes you erase will become semi-transparent, the resulting image will be a composite of the overlapping 
strokes. On a bitmap layer, this would simply result in a single layer of semi-transparent artwork.
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There are two different types of textured vector erasers: Textured and Textured, Preserve Vector. A simple 
textured eraser will do two things: First, it will make textured brush strokes more or completely transparent 
where you erased, and second, it will cut out from the brush stroke's vector shape where it made its texture 
completely transparent. In contrast, a Textured, Preserve Vector-type eraser will only make the texture brush 
strokes more or fully transparent, but will leave its vector shape intact. 

Creating a textured eraser works exactly like creating a textured brush. Therefore, you can follow the steps in 
the Creating a Textured Brush section to learn how to create a textured eraser.
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About Eraser Presets
Once you have found the correct settings for your eraser, you might want to reuse it throughout your project for 
consistency. You can do that by creating and using eraser presets.

Storyboard Pro comes preloaded with a few eraser presets which you can select from the Tool Properties view. 
It is also possible to create your own eraser presets by configuring your eraser then saving it as a preset. 

Like eraser tips and paper textures, eraser presets are saved in your preferences. You can also export your 
eraser presets into an .xml file, and import them on a different workstation, allowing you to share your eraser 
presets between the different people collaborating on your project.

NOTES 

 l Eraser presets are not to be confused with eraser tips and paper textures. Eraser tips and paper 
textures are one of the many properties of an eraser, whereas an eraser preset contains all the 
properties of a brush.

 l Eraser presets for vector layers and for bitmap layers are separate. An eraser preset created 
while working on a vector layer cannot be used when working on a bitmap layer, and vice versa. 
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Creating an Eraser Preset
You can create your own custom eraser preset by configuring your eraser, then adding it as a preset.

How to create an eraser preset

 1. Make sure the current drawing layer is vector if you wish to create a vector eraser preset, or bitmap 
if you wish to create a bitmap eraser preset—see  About Layer Types on page 174.

 2. In the Tools toolbar, select the  Eraser  tool or press Alt + E.

 3. Click on the Arrow button to open the Eraser Properties dialog.

 4. In the Eraser Properties dialog, configure your eraser—see Creating a Solid  Eraser  and Creating a 
Textured Eraser.

 5. Do one of the following:

 l From the Eraser Properties dialog, click on the New Brush Preset  button in the top-
right corner. 

 l In the Tool Properties view, click the New Brush Preset  button.

 l In the Tool Properties view, open the Brush Presets  menu  and select New Brush 
Preset.

 6. In the New Preset window, type a name for your new eraser preset.

Your new eraser preset is added to the end of the list of eraser presets.
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Selecting an Eraser Preset
Storyboard Pro provides you with default eraser presets available in the Tool Properties view. 

How to select a brush preset

 1. In the Tools toolbar, select the  Eraser  tool or press Alt + E.

 2. In the Tool Properties view, select an eraser preset from the Presets list.
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Updating a Brush Preset
If you want to modify the settings of an existing custom preset, you can do so by adjusting the parameters in 
the Tool Properties view, then updating your preset with your brush current's parameters.

How to update a brush preset

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 1. In the Tool Properties view, select the Brush Preset you wish to update.

 2. Click on the Arrow button to open the Brush Properties view.

 3. Configure your brush to be exactly how you wish to use it in the future—see Creating a Solid  Brush 
or Creating a Textured Brush.

 4. Click on the Update Brush Preset  button  in the upper-right corner of the Brush Properties 
dialog. 
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Renaming an Eraser Preset
To keep your list comprehensive and organized, you can name your custom brush presets.

How to rename a brush preset

 1. In the Tools toolbar, select the  Eraser  tool or press Alt + E.

 2. In the Tool Properties view, select an eraser preset to rename. 

 3. Open the Brush Preset menu  and select Rename Brush. 

 4. Type in a new name for the brush and click OK.
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Deleting a Brush Preset
You can keep your preset list clean by deleting unwanted custom presets. 

How to delete a brush preset

 1. In the Tools toolbar, select the  Eraser  tool or press Alt + E.

 2. In the Tool Properties view, select the eraser preset you want to delete.

 3. Do one of the following:

 l Click the Delete Brush  button.

 l Open the Brush Preset menu  and select Delete Brush.
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Exporting Eraser Presets
You can export eraser presets into an .xml file which will contain all of your eraser's settings. This can be useful 
if you wish to back up or share your eraser presets.

How to export pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Export Brushes.

The Export Brushes dialog opens. This dialog allows you to export brush presets for the Brush, 
Pencil and Eraser tools. 

 3. By default, the presets for all your tools will be selected for export. If you only wish to export presets 
for specific tools, uncheck Select/Deselect All and select the tools for which you want to export the 
presets.

 4. Click Export.

 5. In the Export Presets dialog that appears, browse to the location where you want to save the .xml 
file and enter its file name.

 6. Click Save.
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Importing Eraser Presets
You can import eraser presets that you previously exported from Storyboard Pro. 

How to import pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Import Brushes.

 3. In the browser window that appears, navigate to and select the .xml file in which you exported 
your brush presets.

 4. Click Open.

The Import Brushes dialog box opens.

 5. By default, the presets for any tools included in the file will be selected for import. If you only wish to 
import presets for specific tools, uncheck Select/Deselect All and select the tools for which you want 
to export the presets

 6. Click Import.

The imported brush, eraser and pencil styles will appear in the Presets list.
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Changing the Brush Preset Display
You can display your preset list as thumbnails or a list. 

How to change the way presets are previewed in the Tool Properties view

 1. In the Tool Properties view, open the Brush Presets  menu.

 2. Select one of the following options:

 l Small Thumbnail: Displays presets in a grid of small thumbnails with a preview of their 
tip.

 l Large Thumbnail: Displays presets in a grid of big thumbnails, with their name and a 
preview of their tip.

 l Stroke View: Displays presets in a list, with their name and a preview of a stroke done 
with each preset. 
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About the Select Tool
The Select tool lets you select strokes and apply basic transformations such as repositioning, rotating, scaling or 
skewing, using the different handles of the bounding box.

If you have text or pencil lines selected with the Select tool, their properties will display in the Tool Properties 
view, allowing you to make changes to your selection.
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Selecting Artwork with the Select Tool
Before you can perform transformations such as a rotation, scale, skew or flip, you must select the objects using 
the Select tool. You can click directly on a drawing stroke to select it, or draw a lasso around several drawing 
strokes to select them together. 

Once selected, you can transform all the objects within the bounding box simultaneously. There are various 
controls around the bounding box for you to manipulate a selection.

How to select objects

 1. In the Timeline or Thumbnails view, select the panel and layer on which you want to select objects.

 2. In the Tools toolbar, click the Select  tool or press Alt + S.

 3. In the Stage view, do one of the following:

 l To select a single drawing stroke, click on it.

 l To select all the drawing strokes within an area, draw a lasso around those strokes to select 
them simultaneously. 

 l To select several specific drawing strokes, hold the Ctrl key, then click on each drawing 
stroke you wish to add to your selection. 

 l To select all the artwork, press Ctrl + A.

TIP 

Your selection will be preserved even if you switch between panels or scenes, until you make a 
new selection.
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Transforming Artwork with the Select Tool.
Once a selection is made, you can manipulate it by moving it, rotating it, scaling it or skewing it. 

How to manipulate artwork in the Stage view

 1. In the Stage view, make a selection—seeSelecting Artwork with the Select Tool on page 327.

 2. Do one of the following:      

 l To move the selection, move the mouse cursor over the selected artwork, then click and drag 
it.

TIPS 

 l You can also nudge the selection by using the arrow keys on your keyboard.

 l To make it easier to move the selected artwork, you can enable the Select 
Tool Bounding Box is Movable option in the Tools tab of the Preferences 
dialog box. This lets you place the cursor anywhere inside the bounding box 
and move its contents. This option applies to these tools: Select , Select by 
Colour, and Cutter.

 l To resize the artwork, position the cursor over one of the square points at the corners and 
over the edges of the bounding box. When you see the scale cursor appear, click and drag to 
resize. 
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TIPS 

 l You can preserve the horizontal and vertical proportions of the artwork in the 
selection by holding the Shift key.

 l You can scale the artwork from the selection's pivot point by holding the Alt 
key.

 l To rotate the selected artwork, position the cursor at any corner of the bounding box. When 
you see the rotate cursor, drag to rotate. 

TIP 

You can rotate the artwork in 15° increments by hold the Shift key.

 l To skew the artwork, position the cursor on any side of the bounding box and drag to skew.
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 l To rotate the selected artwork by 90°, do one of the following:

 l In the Tool Properties view and click on Rotate 90 CW  to rotate it 90° clockwise, or 
on Rotate 90 CCW  to rotate it 90° counterclockwise. 

 l From the top menu, select Tools > Transform > Rotate 90 CW, Rotate 90 CCW or 
Rotate 180.

 l To flip the artwork, do one of the following:

 l Open the Tool Properties view and click the Flip Horizontal  or Flip Vertical .

 l Press Alt + H to flip horizontally. Press  Alt + V to flip vertically.

 l From the top menu, select Tools > Transform > Flip Horizontal or Flip Vertical.
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When rotating your selection, your artwork will rotate around its pivot point. This point is placed in the centre 
of your selection by default. You can move it to a different location before performing a rotation so that it rotates 
around the preferred pivot point position instead.

How to adjust the pivot point

 1. In the Stage view, select one or more objects.

The pivot point appears in the middle of the bounding box.

 2. Click and drag the pivot point to a new position.

This becomes the new position of the pivot point for the selection. It will remain in this position until 
you change the selection.
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Flattening a Selection

The Flatten operation is used to merge drawing objects and brush strokes into a single layer. If you draw new 
lines to fix a drawing or a line with many brush strokes, it can be useful to flatten them all into a single shape. 
By default, lines are drawn one on top of each other, if you intend repainting the lines or modifying their shape, 
it will be easier if they are flattened—see About Project Optimization on page 50. 

If you have selected strokes while using the flatten command, only these strokes will be flattened. If no strokes 
are selected, the entire current layer will be flattened. If you have selected multiple layers, they will all be 
flattened individually.

How to flatten a selection

 1. In the Tools toolbar, select the Select  tool.

 2. In the Stage view, select the strokes to flatten.

 3. Do one of the following: 

‣ In the Tool Properties view, click the Flatten  button.

‣ Press Alt + Shift + F.

‣ Select Tools > Flatten.
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Grouping Objects
By grouping objects together, you can reposition, scale and apply other transformations to multiple objects of a 
drawing. You can also ungroup a group of objects to fine-tune individual objects.

NOTE 

You can only group objects on one vector layer, you cannot group objects from several layers. Also, 
you cannot group objects on bitmap layers.

How to group or ungroup objects

 1. Select drawing strokes in the Stage view.

 2. In the top menu, select Edit > Group Drawing Selection or Ungroup Drawings.
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Converting Strokes
When drawing on vector layers, you may want to change brush strokes to pencil lines to convert contour 
strokes into centre line pencil strokes.

NOTE 

Any line thickness information is lost upon conversion from brush to pencil

At times, you may want to change pencil lines to brush strokes. This converts a centre line stroke to a contour 
line stroke. Or you can convert strokes to pencil lines.

 

How to convert pencil lines to brush

 1. Select the strokes you want to convert.

 2. Right-click and Convert > Pencil Lines to Brush Strokes. 

How to convert brush to pencil lines

 1. Select the strokes you want to convert.

 2. Right-click and select Convert > Brush Strokes to Pencil Lines. 
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Using the Select by Colour Tool
T-SBADV-005-019

The Select by Colour tool lets you quickly select all artwork painted or drawn with the selected colour. This 
makes it easy to select artwork from a single layer that contains different colours and shades. 

How to select by colour

 1. In the Tools toolbar, click the Select by Colour  button.

 2. In the Stage view, select a layer.

 3. Click on a colour.

All artwork painted or drawn with the selected colour is selected.

NOTE 

Selecting this tool is simply activates the Select tool with its Select by Colour mode enabled. You 
can achieve the same result by selecting the Select  tool, then enabling the Select by Colour  
mode in the Tool Properties view. 
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About the Select Tool Modes
When you use the Select tool, its properties and options appear in the Tool Properties view.

 Lasso  and  Marquee  Modes 
When selecting artwork, you can use the Lasso  mode to make a freehand selection or the Marquee  
mode to make a rectangular selection.

TIP 

You can press and hold the Alt key to temporarily switch from the selected mode to the other.

 Snap to Contour 
When enabled, while moving a selection, the mouse cursor (along with the selection) will snap against the 
nearby points and contours of your artwork, allowing you to snap parts of your artwork together. 

 Snap and Align
When enabled, while moving your selection, the rectangular bounding box of the selection will align with the 
rectangular bounding boxes of other strokes and shapes in your artwork. 

 Select by Colour Mode 
When enabled, clicking on a shape or pencil line will select everything in your drawing that is painted with the 
same colour.
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 Select All Drawings in Scene 
Click on this to select all the drawings in the current scene simultaneously. You can then manipulate them 
together. The outlines of drawings in other panels will appear in the Stage view. 
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About the Cutter Tool
You can cut a drawing area on a bitmap or vector layer to move, copy, cut or delete it.

338



Cutting
T-SBFND-008-007

The Cutter tool lets you cut out part of a drawing so that you can transform it, copy it or delete it. 

 

How to cut drawings

 1. In the Tools toolbar, select the Cutter  tool or press Alt + T.

 2. In the Stage or Camera view, draw a lasso around the artwork you want to cut away.

The artwork inside the lasso you drew will be cut from the rest of the artwork and will be selected. 

TIPS 

 l You can add another part of your artwork to the selection by holding Shift and 
drawing another lasso. 

 l By default, the Cutter tool will only work on the current layer. You can cut artwork 
from all visible layers by holding the Ctrl (Windows/Linux) or ⌘  (macOS) key.

 3. Once you've cut out artwork, you can manipulate it like with the Select tool. For example:

 l To move the selected artwork, click and drag it.

 l To delete the selected area, press Del.

 l To scale, rotate or skew the selection, use the controls around the selection's bounding box.

339

Storyboard Pro 6. User Guide                          



Chapter 7: Drawing

NOTE 

To transform your selection, see Transforming Artwork with the Select Tool. on page 328.
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About the Cutter Tool Modes
When you use the Cutter tool, its properties and options appear in the Tool Properties view. The four Cutter 
modes include: Lasso or Marquee, tip style, mouse gesture, and antialiasing.

 Lasso  and  Marquee  Modes 
When selecting artwork, you can use the Lasso  mode to make a freehand selection or the Marquee  
mode to make a rectangular selection.

TIP 

You can press and hold the Alt key to temporarily switch from the selected mode to the other.

 Tip Style
When cutting through pencil lines, this option decides what kind of pencil line tips to put at the extremities of 
the remaining pencil line segments, where they were cut. 

By default, this is set to Bevel , which will leave the tip of the pencil line cut at the same angle as your cutter 
stroke. If you prefer, you can make pencil lines that you split with the Cutter tool have Flat  or Round  tips 
instead. 
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 Use Mouse Gesture Cutter Mode
When this option is enabled along with the Lasso  selection type, quickly drawing a line with the Cutter tool 
over a line segment in your artwork will instantly delete it. This can be useful if you want to use the Cutter tool 
to quickly clean up your artwork. 

NOTE 

This option will only work when using the Cutter tool on separate brush or pencil strokes. Hence, it 
is important not to flatten your artwork if you intend to use this option to clean up your drawings. 
This option has no effect on bitmap layers as the artwork in bitmap layers is always flattened.

 Antialiasing Mode  
When working on bitmap artwork, enabling this will smooth the edges of the artwork you cut out, so that they 
do not appear pixelated. 
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NOTE 

This option is only available with bitmap layers.
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About the Contour Editor Tool
The Contour Editor lets you reshape vector shapes, brush strokes and lines in your drawings. 

Artwork in Storyboard Pro is made of vector shapes.  Vector shapes are defined by points, the lines joining the 
points together (contours) and the curve vectors, represented by Bezier handles, which make the curve of said 
lines.

The Contour Editor tool allows you to select a contour or point, and change the position of points, add and 
remove points from the shape, rotate, lengthen and shorten curve handles to influence the curve of contours 
between those points, or drag contours between points to change their curve directly. 

Since pencil lines are defined by a single line with a line width, you can use the Contour Editor to easily modify 
the shape of pencil lines. In contrast, brush strokes are full vector shapes, so the Contour Editor can be used to 
modify their shape. 

The Contour Editor can be used to tweak vector artwork in all sorts of ways. It can be used to perfect a pencil 
line, correct shapes, or create complex shapes out of a basic ellipse or rectangle.
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Reshaping with the Contour Editor Tool
T-SBFND-008-006

The Contour Editor lets you reshape vector shapes, brush strokes and lines in your drawings. 
If you use the Contour Editor or Perspective tool on a textured brush stroke, it is will deform its texture to fit the 
new shape of the brush stroke. Keep in mind that this will resample the texture, which is liable to make it lose 
quality. 

How to reshape with the Contour Editor tool

 1. In the Timeline or Thumbnails view, select the cell and layer into which you want to draw.

 2. In the Tools toolbar, select a shape tool: .

 3. In the Tool Properties view, click the Ellipse  button, click the Auto Fill  button and set the 
pencil size to 0.

 4. In the Stage view, draw a circle.

 5. In the Tools toolbar, select the Contour Editor  tool.

 6. In the Stage view, click the line to reshape it.

 7. Select one or several points by clicking on them or circling around.
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 8. Press Del to delete a selected point.

Press Ctrl (Windows/Linux) or ⌘  (macOS)and click on the contour to add a new point to adjust the 
contour.

 9. To modify the shape, you can:

 l Pull on the Bezier handle. Both point’s handles will move as one.

 l Hold down Alt and pull on one of the Bezier handles. The point’s handle will move independently 
from the other one.

 l Move the selected points to a new area.
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 l Pull directly on the line between two points. No selection is necessary. Holding down Shift will limit 
the contour modification to the curve between the two first points.

 l If an anchor point has no visible Bezier handles, hold down the Alt key to display them.

 l To add control points, press Ctrl (Windows/Linux) or ⌘  (macOS) and click the line.

 l To remove control points, select the control point and press Del.
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Smoothing a Selection

The Smooth Selection operation is used to smooth out selected drawing strokes and remove extra points. 
Smoothing is applied to the entire stroke.

Depending on how you draw your pencil line (changing the Smoothness or Contour Optimization), there may 
be few or many control points on the centre line. Just as you can modify a brush line, you can modify the 
direction of a pencil line using the Contour Editor to move its control points.

To learn how to create a pencil line with more or fewer control points, see Reshaping with the Contour Editor 
Tool on page 345.

How to modify a pencil line using control points

 1. Using the  Pencil tool, create a line that has control points along its centre line (adjust the 
Smoothness or Contour Optimization to set the right number of control points). 

 2. From the Tools toolbar, select the  Contour Editor tool and select the pencil line. 

The selected pencil line will display its centre line along and control points.

To add control points, press Ctrl and click to create control points.

 3. Drag any of the control points along the centre line to change the shape.
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About the Contour Editor Tool Modes
When you select the Contour Editor tool, its properties and options appear in the Tool Properties view.

 Lasso  and  Marquee  Modes 
When selecting artwork, you can use the Lasso  mode to make a freehand selection or the Marquee  
mode to make a rectangular selection.

TIP 

You can press and hold the Alt key to temporarily switch from the selected mode to the other.

 Snap to Contour Mode
When enabled, moving the control point in a contour near another contour will snap that control point against 
that contour. This will lock the point and the contour together, and moving the control point will deform the 
contour. 

This option can be especially useful if you need to makes the edges of two shapes snap together, like so:

You can also use this option to make a control point snap against another control point, allowing you to join 
lines together.
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NOTE 

When a control point is snapped against a contour or another control point in your drawing, the 
Contour Editor will manipulate them together. However, even if you make a point in one drawing 
stroke snap against another drawing stroke, they will remain separate drawing strokes unless they 
are flattened together, and you will still be able to manipulate them individually with the Select 
tool. 

How to snap two shapes together

 1. In the Tools toolbar, select the Contour Editor  tool.

 2. In the Contour Editor Tool Properties view, click the Snap to Contour  button.

 3. In the Stage view, click an anchor point you want to snap to the other shape, drag it on top of the 
contour line area and release it.
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About the Centerline Editor
T-SBFND-008-002A

The Centerline Editor allows you to tweak and reshape brush strokes by manipulating their centre line rather 
than their contour. This gives you a flexibility that is similar to the one you have when using the Contour Editor 
tool to manipulate pencil lines.

In Storyboard Pro, pencil lines are composed of a centreline, to which the thickness and colour is added by the 
application. This makes it easy to edit pencil lines with the Contour Editor, as you can tweak their centreline, 
and their contour will . Brush strokes, however, are stored as their outer shape. Therefore, using the contour 
editor on a brush strokes does not allow you to edit the center line of the stroke, but rather, its contours.

The Centerline Editor tool creates a center line for a brush stroke, and gives you access to control points and 
Bezier handles for this center line, allowing you to deform the brush stroke the same way you can deform a 
pencil line using the Contour Editor.

Keep in mind that brush strokes are vector shapes with a fill. As such, the Centerline Editor must do guess work 
to figure out the centreline of your brush strokes, and apply deformations on its shape as you tweak its control 
points. The Centerline Editor will not be able to make a accurate centreline out of brush strokes that merge 
together, that look scrambled or that otherwise do not have a clear direction.    
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NOTE 

If you use the Centerline Editor on a textured brush stroke, it will deform the texture to make it fit 
the new shape of the stroke. Keep in mind that this will resample its texture, which may make it 
lose quality.

NOTE 

  If you use the Centerline Editor to deform a closed brush stroke with a fill inside it, the fill will not be 
reshaped to fit the new shape of the brush stroke.

NOTE 

To learn more about the Centerline Editor tool options, see the Reference Guide.
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Reshaping Brush Strokes Using the Centerline Editor
You can use the Centerline Editor tool to reshape brush strokes from their center line rather than their contour, 
like you would reshape pencil lines using the Contour Editor.

How to reshape brush strokes

 1. In the Tools toolbar, double-click on the Contour Editor  button and select the Centerline Editor 
 tool, or press Alt + W.

 2. In the Stage view, click the contour or pencil line you want to edit near the area you wish to change.

The Centerline Editor creates a center line manipulator based on the outline's shape, with control 
points. 

 3. Click on one of the points to select it. 

The point's Bezier handles appears, as well as Bezier handles for the surrounding points. 

 4. Do one of the following:

 l To move a point or a selection of multiple points, click and drag it. 
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 l To change the curve on both sides of a point, drag one of its Bezier handles.

 l To change the curve on only one side of a point, press and hold the Alt key, then drag one of 
its Bezier handles.

 l To deform the contour, drag a part of the contour between two points.

 l To deform the curve between two points, hold the Shift key and drag the contour between 
two points.
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 l To remove a point's Bezier handles and make the lines it is connected to straight, press and 
hold the Alt key and click on the point.

 l Straight lines have no Bezier handles at their points by default. To create Bezier handles for 
these points and make their lines curved, pres and hold the Alt key, then click and hold the 
point and drag the mouse cursor away from it. A new Bezier handle will follow your mouse 
cursor until you release the mouse button. 

 l To add a control point, press Ctrl (Windows/Linux) or ⌘  (macOS) and click on the contour 
where you want the new point to be created.
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Centerline Editor Tool Modes
When you select the Centerline Editor tool, its properties are displayed in the Tool Properties view.

 Lasso  and  Marquee  Modes 
When selecting artwork, you can use the Lasso  mode to make a freehand selection or the Marquee  
mode to make a rectangular selection.

TIP 

You can press and hold the Alt key to temporarily switch from the selected mode to the other.
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About the Perspective Tool
When drawing on vector layers, the Perspective tool is used to deform a drawing selection and alter its 
perspective. 

NOTE 

This tool cannot be used on bitmap layers.
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Deforming a Drawing Using the Perspective Tool
T-SBADV-005-012D

When drawing on vector layers, the Perspective tool enables you to deform a drawing selection and alter its 
perspective. 

How to deform a drawing

 1. In the Tools toolbar, select the Perspective  tool.

 2. In the Stage view, select the drawing you want to deform.

 3. Click and drag the different anchor points to deform the shape.
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About the Perspective Tool Modes
When drawing on vector layers, selecting the Perspective tool displays its properties and options in the Tool 
Properties view.

 Lasso  and  Marquee  Modes 
When selecting artwork, you can use the Lasso  mode to make a freehand selection or the Marquee  
mode to make a rectangular selection.

TIP 

You can press and hold the Alt key to temporarily switch from the selected mode to the other.

 Snap to Contour Mode
When enabled, moving a control point near a contour in your artwork will make it snap against that contour.

 Snap and Align Mode
When enabled, moving a control point will make it align to the bounding box of strokes and lines in your 
artwork.

 Snap to Grid Mode
When enabled, moving a control point will make it snap to the intersection points in the grid. 

TIP 

To display the grid, select View > Grid > Show Grid from the top menu or press Ctrl + G (Windows) 
or ⌘  + G (Mac OS X).
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 Perspective and  Lattice Modes
When using the Perspective tool to deform artwork, you can deform artwork in two distinct ways. The 
Perspective mode deforms the drawing by simulating a perspective effect, which will make it look like you're 
rotating a sheet of paper in a 3D space. The Lattice mode simply deforms the artwork to make it fits the shape 
of the Perspective tool's control box. 

The difference between both modes becomes easier to understand if you apply a transformation to a drawing 
of a grid to make it look like it's laid down on a surface: 

As you can see, in perspective mode, the visible distance between the horizontal bars is proportional to how 
close to the point of view they would be in 3D perspective. In lattice mode, the vertical position of the horizontal 
bars was merely scaled down to fit the vertical size of the grid. 
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About the Text Tool
T-SBADV-005-013

With the Text tool, you can type text in your project, using various fonts and text attributes. Text objects are 
part of a drawing, so you can manipulate them the same way. You can use the Text tools on both vector and 
bitmap layers.
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Adding Text
T-SBADV-005-014

Whenever needed, you can add text to panels.

How to add text to drawings

 1. In the Tools toolbar, select the Text  tool, press Ctrl + Shift + T (Windows) or ⌘  + Shift + T (Mac 
OS X) or select Tools > Text.

 2. In the Timeline or Thumbnails view, select the panel and layer that contains the drawing on which 
you want to add text.

 3. In the Stage view, click the location at which you want to add text. 

 4. You can use the Text properties in the Tool Properties view to select the font, font size and format of 
the text you will type—see Adding Text on page 363. 

 5. Type in the desired text.

 6. Click outside the text box to exit the typing mode.

‣ If you want to create another text object, click outside the currently active text box. You can 
always return to edit the text by selecting the Text  tool and clicking in the text.
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Formatting Text
T-SBADV-005-015

Use the Text Tool Properties view to select the font type and other formatting options you want to apply to the 
text.

NOTE 

If the text is already written, use the Text tool to select the text you want to format.

Font Type
Use this drop-down menu to select the desired font, from the list of fonts available in your system.

Font Style
Use the Bold and Italic buttons to set the style for your text.
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Alignment
Use these buttons to align the paragraph.

 Left
 Centred 

 Right  Justified

Font Size
Type the desired size for the text in this field. You can also use the up and down arrow buttons to set the 
desired value.

Kerning
Use the kerning field to modify the spacing between letters and characters. You can select the Auto Kern 
option to set the kerning automatically, based on the font’s predefined standard. A negative value decreases 
spacing between each character creating a letter overlap and a positive value increases it.
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Indent
Enter a value in the Indent field to increase or decrease the indentation on the first line of your text. A positive 
value sets the first line of your paragraph farther to the right and a negative value sets it farther to the left.

Line Spacing
Enter a value in the Line Spacing field to decrease or increase the space between each line of text.
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Resizing the Text Box
T-SBADV-005-016

You can resize the text box by selecting your text box with the Text  tool and moving the anchor point right 
or left.

Using the Select tool will distort and scale your text itself rather than changing the width and height of your 
text box.
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Breaking Text
T-SBADV-005-017

Text contained in a text field is treated as a single drawing object. You can easily separate the text so that each 
character becomes an individual drawing object that you can select and modify independently.

How to break a text object

 1. In the Tools toolbar, click the Select  tool or press Alt + S.

 2. In the Stage View, select the text object you want to break.

 3. Right-click the text and select Convert > Break ApartText Layers.

Each character is now surrounded by its own bounding box that you can modify, they remain text 
objects that you can edit.

 4. If you want to convert your independent letter to a complete vector object that you can deform, 
using the Select tool, select the letters to convert.

 5. Right-click the text and select Convert > Break ApartText Layers to break the selection into a 
regular drawing object, with no more text attributes.

NOTE 

After your text has been broken apart twice, into a regular drawing object, you can use all the 
drawing tools such as the Eraser tool, on the drawing.  Be aware that if you want to use the 
Perspective tool on the text, you should create the text on a vector layer before breaking it 
apart twice; then you can use the Perspective tool on it.
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About Tool Presets
T-SBADV-005-006

Tool presets let you save a variety of settings and are very efficient for accessing the tools you use most often. 
That way, the tool is already set with the desired properties, such as colour, line thickness, whether to enable 
Draw Behind or Auto Flatten mode, and so on. You can create presets for these tools and many more: Brush, 
Pencil, Eraser, Rectangle, Ellipse, and Line. 

The difference between a tool preset and a brush preset is that when you save a tool preset, you have the 
option of saving the colour and assigning a shortcut, which you cannot do with brush presets.

You can assign a keyboard shortcut to tool presets to quickly access them—see Shortcut Preferences in the 
Preferences Guide.
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Creating Tool Presets
T-SBADV-005-007

To create a tool preset, you will need to select a tool, adjust the properties, and then create a tool preset for it. 
Once you have created a tool preset, you can make adjustments to fine-tune it, as well as create a keyboard 
shortcut for it. All tool presets are displayed in the Tool Presets toolbar.

How to create a tool preset

 1. In the Tools toolbar, select a tool, for example the Brush tool.

 2. In the Panel view, use the Tool Properties view and/or the Brush Properties window to customize 
the tool.

 3. To set a specific colour for your preset, in the Colour view, select the colour swatch to link to the tool. 

NOTE 

When using a tool preset in a scene that is not using the assigned colour swatch,  
a colour recovery dialog box appears prompting you to add the colour to the 
scene.

 4. In the Tool Presets toolbar, click the New Tool Preset   button.

 5. In the New Preset dialog box, in the Name field, type a name for your new preset.
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 6. From the icon list, select an icon to quickly identify your preset or upload your own by clicking the 
File  button.

 7. (Optional) From the Shortcut menu, set a keyboard shortcut to quickly access your preset. By 
default, the shortcuts are unassigned. To assign a keyboard shortcut, select Edit > Preferences > 
Shortcuts > Tool Presets (Windows) or Storyboard Pro > Preferences > Shortcuts > Tool Presets 
(macOS).

 8. When you select an option, it will take effect when you use the tool preset. If an option is deselected, 
then using a tool preset will not override your current settings. 

 l Colour: Saves the current colour into the tool preset.

 l Layer: Lets you select a drawing layer to be used on the current panel when the tool 
preset is clicked. When selecting the preset, if the assigned layer exists, it will be 
selected, if not, it will be created. When changing panels, depending on your global 
navigation setting, it will look for the layer. If it does not exist, the first layer will be 
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selected. Select the Layer option, assign a layer to the tool preset, and decide whether 
the layer is vector or bitmap.

 l Draw Behind: When this option is selected, saves the specified Draw Behind option to 
the tool preset.  When deselected, the current Draw Behind status is unchanged 
when the tool preset is clicked—see About the Brush Tool Modes on page 264.

 l Auto Flatten: When this option is selected, saves the specified Auto-Flatten state to 
the tool preset.  When deselected, the current Auto-Flatten state is unchanged when 
the tool preset is clicked—see About the Brush Tool Modes on page 264.

 9. Click OK.
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Updating Tool Presets
T-SBADV-005-008

As you work with a tool preset, you may need to fine-tune and update its parameters until it is exactly what you 
want. 

How to update a tool preset

 1. In the Tool Properties view, update the tool settings.

 2. In the Tool Presets toolbar, click the Manage Tool Presets  button.

 3. In the Manage Tool Presets dialog box, select the tool preset from the list. 

 4. Update the additional parameters such as the icon, Colour, Layer and Draw Behind options.

 5. Click Update.

 6. Click OK.
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Deleting Tool Presets
T-SBADV-005-009

If you no longer need a tool preset, you can delete it.

How to delete a tool preset

 1. In the Tool Presets toolbar, click the Manage Tool Presets  button.

 2. From the list of tool presets on the left, select a preset to delete and click the Trash icon.
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Importing and Exporting Tool Presets
T-SBADV-005-010

If there are tool presets created by other Storyboard Pro artists you want to use, you can import them to use in 
your projects. You can also export your tool presets for other artists to use.

How to import a tool preset

 1. In the Tool Presets toolbar, click the Manage Tool Presets  button.

The Manage Tool Presets dialog box opens.

 2. Click Import.

 3. In the Import Brush Presets window that opens, locate and select the preset(s) to import and click 
Open.

How to export a tool preset

 1. In the Tool Presets toolbar, click the Manage Tool Presets  button.

The Manage Tool Presets dialog box opens.

 2. Click Export.

 3. In the Export Brush Presets window that opens, select the preset(s) to export and click  Export.

 4. Give the exported preset(s) a name and click Save.
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Locking the Tool Preset Layer Selection
T-SBADV-005-011

It is possible to assign a tool preset to a specific layer. When the preset is selected, it will verify if the layer 
exists. If so, the layer will be selected and if not, it will be created.

When switching panels, by default Storyboard Prolooks for a layer with the same name as the one currently 
selected. If it does not exist, the first layer will be selected. To prevent Storyboard Pro from selecting a random 
layer, you can activate the Enable Brush Preset Layer Selection Lock option. This way, Storyboard Pro prevents 
you from drawing in the next panel unless you create the missing layer. Click on the preset again to create the 
missing layer.

How to enable the Enable Brush Preset Layer Selection Lock option

 1. Open the Preferences dialog box:

 l Windows: Select Edit > Preferences or press Ctrl + U.

 l macOS: Select Storyboard Pro > Preferences  or press⌘  + ,.

 2. Select the General tab.

 3. In the Layers section, select the Enable Brush Preset Layer Selection Lock option.
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About Drawing Space Navigation
When you are drawing in the Stage view, you can zoom, pan and rotate the view to make it easier to 
determine where to place objects, determine the scale of objects, and when zooming out, get an overall view of 
the panel and its contents.
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Zooming the Stage View
Zooming in and out of the Stage view lets you see elements close up and far away.

How to zoom the Stage view

 l From the Tools toolbar, select the Zoom  tool. Click the Stage view to zoom in. Press [Alt] to zoom 
out.

 l Zoom In: Select View > Zoom In or press 2. When the Zoom In mode is selected, hold [Alt] as you 
click to zoom out.

 l Zoom Out: Select View > Zoom Out or press 1.

How to reset zoom

 l Select View > Reset Zoom or press Shift + Z.

378



Panning the Stage View
Using the Hand tool, you can pan the Stage view.

How to pan the Stage view

 1. Do one of the following:

‣ In the Tools toolbar, click the Hand  tool.

‣ Hold down the Spacebar. 

‣ Select Tools > Hand.

 2. In the Stage view, drag the cursor. 

How to reset pan

 l Select View > Reset Pan or press Shift + N.
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Rotating the Stage View
You can rotate the Stage view in the same way as you would with an actual animation disc. You can also use the 
menu options to rotate the Stage view in 30 degree increments.

How to rotate the drawing space 

 1. Do one of the following:

 l From the Tools toolbar, select the Rotate View tool.

 l Hold down Ctrl + Alt (Windows) or ⌘  + Alt (Mac OS X).

 2. Drag the cursor in the Stage view to rotate the view.

How to rotate the drawing view in 30 degree increments

 l Select View > Rotate View CW (clockwise) or press V. 

 l Select View > Rotate View CCW (counterclockwise) or press C.

How to reset rotation

 l Select View > Reset Rotation or press Shift + X.
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About Drawing Space Efficiency
T-SBADV-005-001

Drawing can be time consuming and complicated if you don't take advantage of some of the time-saving 
features in Storyboard Pro. It starts with turning on the grid to help you determine the size and placement of 
objects as you draw. For your drawing tool, you can choose from a lasso or marquee type cursor.

With onion skinning, you can see the previous and next drawings, which is handy for referring to for the size, 
angle and position of the drawing in the current panel.

The light table lets you preview the previous and subsequent active layers in light colours. This is really useful 
for seeing other layers when designing or cleaning up your storyboard.

You can also quickly swap between two drawing tools by using keyboard shortcuts.

Everything you draw in Storyboard Pro is vector-based. When you draw in the Drawing or Camera view, 
notice that your lines may appear jagged. This is caused by the fast real-time display called OpenGL.  If you 
prefer to see smooth lines as you draw, you can enable the antialiasing preference.
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Displaying the Grid
T-SBADV-005-002

Using a grid is useful when positioning or drawing objects and characters in a scene. You can use the Show 
Grid option to display several different kinds of grids in the Stage or Camera views.

How to display the grid

 1. Do one of the following:

 l Click the Grid  button at the bottom of the Stage or Camera view.

 l Select View > Grid > Show Grid.

 l Press Ctrl + G (Windows) or ⌘  + G (Mac OS X).

 2. To choose a grid option, select View > Grid  and one of the following options:

Parameter Description

Grid Outline Only Displays only the contour of the grid.

Underlay Displays the grid behind the drawing elements.

Overlay Displays the grid over the drawing elements.

Square Displays a standard square grid.
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12 Field Grid Displays a 12 field size grid.

16 Field Grid Displays a 16 field size grid.

World Grid 
Displays a reference grid that remains the same size when you scale objects. 
This is useful when creating elements in your drawing and you need a 
reference point.
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Using the Light Table
T-SBFND-008-005

The light table is used to preview the previous and subsequent active layers. It is useful to see the other layers 
when designing or cleaning up your storyboard.

When the light table is activated, all layers apart from the currently selected one are shown in washed-out 
colours in the Stage and Camera views and when using the layer tools.

How to turn on the light table

 1. Select View > Light Table.

The drawings for the other layers are displayed as washed-out colours in the Stage view.
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About Onion Skin
T-SBFND-008-013

Using Onion Skin, you can display the outlines of the previous or next panels as semi-transparent overlays in 
the current panel, to use them as references for your artwork. 

You can display the artwork from one or several panels before and after the current panel as Onion Skin, 
allowing you to decide how much of the artwork surrounding the current panel to use as reference.

TIP 

By default, previous drawings appear in a shade of red and next drawings are displayed in green. 
You can change the display colours of onion skinned drawings in the Colours tab of the Preferences 
dialog box. 
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Enabling the Onion Skin
T-SBFND-008-014

After enabling the Onion Skin, you can set the number of previous and next panels to view. You can set the 
onion skin to display up to three panels.

How to enable Onion Skin

 1. Do one of the following: 

 l In the Onion Skin toolbar, click the Onion Skin  button.

 l Press Alt+O (Windows) or ⌘+Alt+O (Mac OS X). 

 l Select View > Onion Skin > Show Onion Skin.

The Onion Skin for the previous panel will display in the Stage and Camera view in red, and 
the Onion Skin for the next panel will display in green.
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Setting the Amount of Neighbouring Panels to Include in Onion Skin
When you enable Onion Skin, by default, only the previous and next panels will be included in the Onion Skin. 
You can however include up to three previous panels and up to three next panels in the Onion Skin. 

The amount of previous panels and next panels to include in the Onion Skin work independently. For example, 
you can display 1 previous panel and 3 next panels in the Onion Skin simultaneously. 

NOTE 

You can change the maximum amount of panels to include in the Onion Skin in the Camera Tab of 
the Preferences dialog.

How to set the number of previous panels to include in the Onion Skin

 1. In the Onion Skin toolbar, click the Show Previous button and select one of the following:

 l  No Previous Panels

 l  Previous Panel

 l  Previous Two Panels

 l  Previous Three Panels

The previous panel(s) appear in the Stage and Camera views, in a washed out red.

NOTE 

You can also select View > Onion Skin to access these options.

How to set the number of next panels to include in the Onion Skin

 1. In the Onion Skin toolbar, click the Show Next button and select one of the following:

 l  No Next Panels

 l  Next Panel

 l  Next Two Panels

 l  Next Three Panels

The previous panel(s) appear in the Stage and Camera views, in a washed out green.
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NOTE 

You can also select View > Onion Skin to access these options.
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Enabling Onion Skin for the Current Layer Only
If your panels contain several layers, you may want to only see the Onion Skin for a specific layer at a time, and 
ignore all other layers. In Storyboard Pro, you can set up the onion skin to only include artwork for the currently 
selected layer. 

Since layers are different for each panel, and Onion Skin displays the artwork in surrounding panels, 
Storyboard Pro identifies which layers match the currently selected layer in the current panel by name. Hence, 
to be able to use this option, your layers must have consistent names across panels. For example, if you only 
want to display the Onion Skin for a specific character, the layer on which that character is drawn should have 
the same name across the panels in your storyboard, so it could be named after the character's name. Or, you 
could decide that the main action is always drawn on a layer named A in every panel. 

NOTE 

Background layers are not displayed in the onion skin, even if the currently selected layer is a 
background layer.

How to enable Onion Skin for the current layer only and exclude other layers

 1. In the layer panel of the Stage or Camera view or in the Layers view, select the layer or layers which 
you want to include in the Onion Skin.

 2. Do one of the following:

 l In the Onion Skin toolbar, click on the Toggle Selected Layers Only  button.

 l In the top menu, select View > Onion Skin > Show Only the Selected Layers.

The Onion Skin will now only include artwork from previous and next panels that are in layers that 
have the same name as the currently selected layer(s).
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TIP 

If you have selected multiple layers, every layer in the selection will be included in the 
Onion Skin. When using a drawing tool on a selection of multiple layers, you are 
drawing on the first layer that was added to the selection, which will display in a lighter 
shade of cyan in the layer list. Hence, you can use this option with a selection of multiple 
layers, as long as you select the layer you wish to draw on first.
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Excluding Layers from the Onion Skin
Sometimes, you may not want to see certain layers of certain panels in the Onion Skin. In order to exclude 
layers from the Onion Skin, you can set those layers as Background layers.

When you create a panel, it contains two layers: A BG layer and an A layer. The BG layer is already set to be a 
background layer by default, which means it will not be included in the Onion Skin. At any time, you can choose 
which layers in a panel are actually considered background layers or not. All layers that are set to be 
background layers will be excluded from the Onion Skin. 

NOTE 

To set layers as background layers only affects whether or not they appear in the Onion 
Skin. Hence, setting layers that are not really background drawings as background layers will have 
no adverse effect on your storyboard.

How to change whether a layer is considered a background layer

 1. In the Onion Skin toolbar, click on Toggle Onion Skin  to enable Onion Skin.

The Toggle Background Layer  button appears in the top-left corner of each layer in the layer list. 
The BG layer that was automatically created with the panel will already be a background layer. 

 2. Do one of the following to change whether or not a layer is considered a background layer.

 l Click on the Toggle Background Layer  button of a layer to change whether or not it is 
considered a background layer.

 l Select one or several layers. Then, in the top menu, select Layer > Toggle Background 
Layers.

Layers that are set to be backgrounds will not be included in the Onion Skin, and layers that are not 
set to be background will be included in the Onion Skin.
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Flipping Through Onion Skin-Enabled Panels
T-SBFND-008-015

Using the Onion Skin toolbar, you can quickly flip through the drawings that are currently included in the 
Onion Skin, allowing you to get an idea of how they will look during playback.

How to flip through onion-skinned drawings

 1. In the Onion Skin toolbar, do one of the following:

 l Drag the Flip Slider towards the left to see the previous panels included in the Onion 
Skin or towards the right to see the next panels included in the Onion Skin.

 l Click and hold the Flip Forward  button to flip through all the panels included in the 
Onion Skin at an even pace. 
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Selecting Specific Panels to Include in Onion Skin
Using the Expand Onion Skin dialog, you can manually select which panels in the range of previous panels and 
which panels in the range of next panels to include in the Onion Skin. This method is a bit more complicated, 
but much more flexible, as only the panels you specifically choose to include in the Onion Skin will be included, 
and not every panel in-between. 

How to add more panels or only include specific panels in the Onion Skin

 1. In the Onion Skin toolbar, click the Expand Onion Skin  button. 

The Expand Onion Skin dialog appears.

 2. In the Expand Onion Skin dialog, click on the corresponding button for each panel that you want to 
include in the Onion Skin. For example, if you want to include the first and third previous panels and 
the second next panels, click on 1 and 3 in the left section and on 2 in the right section. 

 3. If you want to exclude a panel you already inclued, click on the button again to remove it from the 
Onion Skin. 

 4. Without closing the Expand Onion Skin dialog, move it out of the way of your drawing space and 
resume drawing.

 5. Once you are done using the expanded Onion Skin, close the Expand Onion Skin dialog. The Onion 
Skin will return to its normal settings. 
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About Quick Swap Shortcut
T-SBADV-005-003

Overriding one tool with another lets you increase productivity by rapidly switching between tools used for 
short tasks and your previous tool. Most drawing tool shortcuts are accessed using the Alt key followed by 
another key, such as the Eraser tool which is accessed by pressing Alt + E. 

For example, if you are drawing with the Brush tool and need to briefly switch to the Eraser before continuing, 
hold down the E key while you are erasing. When you are done, release the E key to return to the previous tool; 
in this case, the Brush tool. You can do the same for most drawing tools that have a shortcut composed of Alt 
followed by another key.

For a list of keyboard shortcuts, refer to one of the following: 

• Right-click on the Stage or Camera view to access the contextual menu.

• From the top menu, select Tools.

• Preferences dialog box, Shortcuts tab: Ctrl + U (Windows) or ⌘  + , (Mac OS X)

• Drawing Tools Shortcuts
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Antialiasing OpenGL Lines
T-SBADV-005-004

Everything you draw in Storyboard Pro is vector-based. When you draw in the Drawing or Camera view, 
notice that your lines may appear jagged. This is caused by the fast real-time display called OpenGL.  If you 
prefer to see smooth lines as you draw, you can enable the antialiasing preference.

Full scene antialiasing is generated by your computer’s graphics card. This antialiasing will not only antialias 
your drawings, but all your different views in the interface. Full scene antialiasing is an option you can turn on or 
off; by default, it is disabled. 

There is no need to modify your graphic card settings.

NOTE 

Full Scene Antialiasing parameters are only valid while you work in your scene. The scene will be 
rendered to 100% of its resolution regardless of your preference settings or graphic card panel.

How to customize the full scene antialiasing parameters

NOTE 

You must restart Storyboard Pro after you change the parameters.

 1. Do one of the following:

 l Select Edit > Preferences (Windows) or Storyboard Pro > Preferences (macOS). 

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (macOS).

The Preferences dialog box opens.
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 2. In the Advanced tab, select the Enable option in the Full Scene Antialiasing section.

 3. Number or samples: Enter the number of samples you want to be used for the antialiasing process. 
The number of samples is basically equivalent to the amount of times a pixel will be enlarged to 
calculate the antialiasing. This technique is called supersampling. The higher the number of samples, 
the better the antialiasing quality will be, but the longer it will take to calculate.

 4. Restart Storyboard Pro.
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Changing the Drawing Tool Cursor
T-SBADV-005-005

By default, the Brush tool cursor is displayed as a crosshair. You can change it to display the shape of the 
current brush size.

How to change the Brush tool cursor

 1. Open the Preferences dialog box:

‣ Select Edit > Preferences (Windows) or Storyboard Pro> Preferences (macOS).

‣ Press Ctrl + U (Windows) or ⌘  + , (Mac OS X).

 2. Select the Tools tab.

 3. In the Drawing section, select the Brush Size Cursor option.

 4. Click OK.

The cursor displays the current brush size.
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About Drawing Guides
T-SBADV-006-001

Drawing guides can assist you in drawing background and objects that require straight lines, square angles 
and, more importantly, perspective. In traditional art. This is usually done using rulers, set squares, and 
vanishing points to draw lines from. Guides are meant to reproduce the usage of such tools in combination with 
Storyboard Pro's drawing tools. 

When a guide is in use, it adds a horizon line and vanishing points to your drawing space, which can be moved 
to fit your scene's needs, and it locks your drawing tools so that they draw straight lines, either going from one 
of your vanishing points, or parallel to your guide's horizontal or vertical axis. This makes the process of drawing 
structures with volume and perspective streamlined. Also, guides display dotted lines going through your 
mouse cursor going from your vanishing points or parallel to your guide's horizontal and vertical axes to help 
you visualize the axes your drawing strokes will follow. 

Storyboard Pro supports the following types of drawing guides:

 l The Square Grid guide simply helps you draw on the horizontal and vertical axes, which are relative to 
the horizon line. 

 l The 1-Point Perspective guide helps you draw lines coming from a single vanishing point, which is in 
the middle of the horizon by default. It also helps you draw along the horizontal and vertical axes. This 
can help create realistic-looking backgrounds with buildings, walls and objects that are facing your 
camera. 
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 l The 2-Point Perspective guide helps you draw lines going from one of two vanishing points, which are 
positioned left and right of your drawing space. This can help create realistic-looking backgrounds with 
buildings, walls and objects that are at an angle from your camera. 

 l The 3-Point Perspective guide helps you draw lines going from one of 3 vanishing points: Two 
horizontal vanishing points positioned left and right of your drawing space, and one vertical vanishing 
point positioned below or above your drawing space. This can help you draw realistic looking 
backgrounds from a low or high angle. The 3-Point Perspective guide has two presets: Bird's Eye View 
preset and the Worm's-Eye View, which can be used for high angle and low angle perspectives, 
respectively. 

Guides are made to work with the following tools. They are only visible in your drawing space when one of 
these tools is selected:

 l Brush  

 l Pencil  

 l Line 

Before you can use a guide, you must use the Guide view to add the guide you wish to use to your panel's guides 
list. A new guide will have its horizon line and vanishing points in preset positions, which can be adjusted to fit 
your scene's needs. Using the Guides view, you can add, select, rename, delete, cut, copy, paste and reorder 
guides as needed. Your guides list can also be exported to a file and re-imported into a different panel. When a 
guide is selected, you can use it, but you can also adjust its horizon line and vanishing points.
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NOTE 

When creating a new panel, the guides list from the current panel is copied into the new panel. 
When creating a new scene, its guide list is empty. Guide lists for each of your panels are saved to 
your project. Changes done to a guides list or to a guide can be undone with the Undo command.
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Adding  Drawing Guides
T-SBADV-006-002

The first step in using drawing guides is to create a guide in the Guides view.

How to Add a Drawing Guide to your Panel

 1. From the top menu, select Windows > Guides to add the Guides view to the current workspace.

 2. In the Guides view, select the  New Guide  button and choose one of the following types of 
guides:

 l  Square Grid

 l  1-Point Perspective

 l  2-Point Perspective

 l  3-Point Perspective (Bird’s-eye View)

 l  3-Point Perspective (Worm’s-eye View)

The new guide appears in the Guides view list. 

 3. To add another guide, repeat the previous step.

NOTE 

Each Storyboard Pro panel has its own list of guides that can be independently managed—see 
About Drawing Guides on page 398.
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Renaming Drawing Guides
Since guides can be customized, you may want to give them specific name to help you identify them

How to rename a guide using the Guide Menu

 1. In the Guides view, select a guide from the list.

 2. In the Guide Menu, select Rename Guide.

The Rename Guide dialog box opens.

 3. In the Rename Guide dialog box, enter the new guide name.

 4. Press OK.

How to rename a guide using the Guide List

 1. In the Guides view, double-click on a guide displayed in the list.

The guide's name becomes editable.

 2. In the editable name field, enter a new name for the guide.

 3. Press Enter/Return.

NOTE 

It is not required to give a unique name to each guide in a guides list.
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Deleting Drawing Guides
T-SBADV-006-003

You can delete a drawing guide from your list.

How to delete a Drawing Guide

 1. In the Guides view, select one or multiple guides from the list.

 2. In the Guides view, select the Delete Guide  button or press Del (Windows) or Backspace (Mac 
OS X).

The selected guided are deleted from the list.
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Selecting Active Drawing Guides
A Storyboard Pro panel can have as many guides as needed, but you can only use one guide at a time. You can 
decide which guide you're using by selecting it from the guides list. The selected guide will display in your 
drawing space. 

Although you can select the active guide at any time, a guide will only behave as active if one of the following 
drawing tools is selected:

 l Brush  

 l Pencil  

 l Line 

Once a guide is active, it will display its horizon line and vanishing points in your drawing space. There will also 
be two or three dotted lines following your mouse cursor in the drawing area: One line for each horizontal or 
vertical axis in your guide, and one line going from each vanishing point in your guide through your mouse 
cursor. 

How to select the active guide from the guides list

 1. In the Guide view, click on the desired guide in the guides list

The selected guide will become active. 

NOTE 

If Guides are disabled, clicking on a guide in the guides list will enable them.

How to quickly switch between guides

 1. Set the focus on your Stage or Camera view, for example, by clicking on the view's tab.

 2. Press the Up Arrowor Down Arrow key to select the previous or next guide in the list. 

NOTE 

Using the Up Arrow or Down Arrow to select a guide will only work if guides are already 
enabled.
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Cutting Drawing Guides
You can cut a drawing guide from your guides list. This will remove the guide from the list allow you to paste it 
into anotherpanel or project.

How to cut a Drawing Guide

 1. In the Guides view, select one or multiple guides from the list.

 2. In the Guides view menu, select Cut or press Ctrl + X (Windows) or ⌘  + X (Mac OS X).

The selected guides are deleted from the list and stored in the clipboard.

 3. In the Timeline or Thumbnail view, select the destination panel in the same project or in another 
project.

 4. In the Guides view, click on the guides list to set the focus on it. If the guides list already contains 
guide, select a guide that will act as an insertion point.

 5. In the Guides View menu, select Paste or press Ctrl + V (Windows) or ⌘  + V (Mac OS X).

Drawing Guides that were copied from the previous guides list are pasted in the current guides list, 
under the selected guide, if any.

NOTE 

If you want to use the Cut, Copy and Paste keyboard shortcuts on guides, make sure the focus 
is on the Guides view.
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Copying Drawing Guides
T-SBADV-006-004

You can copy drawing guides and paste them into other panels or projects.

How to copy a Drawing Guide

 1. In the Guides view, select one or multiple guides from the list.

 2. In the Guides View menu, select Copy or press Ctrl + C (Windows) or ⌘  + C (Mac OS X).

 3. In the Timeline or Thumbnail view, select the destination panel in the same project or in another 
project.

 4. In the Guides view, click on the guides list to set the focus on it. If the guides list already contains 
guide, select a guide that will act as an insertion point.

 5. In the Guides View menu, select Paste or press Ctrl + V (Windows) or ⌘  + V (Mac OS X).

Drawing Guides that were copied from the previous guides list are pasted in the current guides list, 
under the selected guide, if any.

NOTE 

If you want to use the Cut, Copy and Paste keyboard shortcuts on guides, make sure the focus 
is on the Guides view.

406



Reordering Drawing Guide Lists
The drawing guides in your guides list can be reordered. 

How to reorder a Drawing Guide list

 1. In the Guides view, select one or multiple guides from the list.

 2. Drag and drop the selected guides to their desired position in the list.

407

Storyboard Pro 6. User Guide                          



Chapter 7: Drawing

Editing Drawing Guides
T-SBADV-006-005

When a new guide is created, it comes with a preset horizon line and, if applicable, preset vanishing points. 
The position and angle of the horizon line as well as the position of any vanishing point in the selected guide 
can be adjusted visually from within your drawing space. 

Guides can only be edited with the Brush, Pencil or Line tool. The selected guide will only be visible when one 
of these tools is selected.

How to edit a drawing guide

 1. In the Tools toolbar, select the  Brush ,  Pencil  or  Line  tool.

 2. In the Guides view, select a guide to make it the active guide. 

Once a guide is active, its horizon line and vanishing point(s) appear in the drawing area.

 3. In the Guides view, make sure the  Lock Guide  option is disabled. This ensures you're able to edit 
the active guide.  

 4. In the drawing area, zoom out until all vanishing points are visible (if necessary).

 5. In the drawing area, grab either the horizon or a vanishing point and move it to its desired location.

408



When using the square grid or 1-point perspective guides, the angle of the horizon can be modified 
by manipulating the horizon line itself.                 

When using the 2-point or 3-point perspective guides, the angle of the horizon can be modified by 
manipulating one of the two vanishing points on the horizon.                 

When adjusting the horizon line, you can hold down Shift to snap the horizon line at every 15 
degrees. This makes it easy to maintain a perfectly horizontal horizon.

NOTE 

Each modification to a guide can be undone with the Undo command.
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Drawing with Drawing Guides
T-SBADV-006-006

Once a guide is active and properly set up, you can use it to assist you in creating a drawing with perspective. 
The guide will display its axes going through your mouse cursor as you move it inside your drawing space. 
When you start drawing a stroke, your drawing tool will become locked to the axis that most closely matches 
the angle of your stroke, forcing you to draw a straight line along that axis, as if you were using a ruler or a set 
square. 

Guides can only be used with the Brush, Pencil or Line tool. The selected guide will only be visible when one of 
these tools is selected.

How to draw using guides

 1. In the Tools toolbar, select the  Brush ,  Pencil  or  Line  tool.

 2. In the Guides view, select the guide you wish to use.

 3. In the drawing area, draw a stroke with the current drawing tool. From the initial gesture, the tool 
locks on one of the guide's axes, forcing it to draw a straight line that follows the axis. 
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NOTE 

Some guides do not lock onto a horizontal or vertical axis line by design. At any time, when 
drawing with the Brush or Pencil tool, you can hold down Shift + Alt before starting the stroke; 
this will force the tool to draw a straight line that locks at every 15 degrees. You can also 
achieve the same effect with the Line tool by holding down Shift before drawing a stroke.
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Locking Drawing Strokes to a Specific Axis
T-SBADV-006-010

When using a drawing guide, your drawing tool with lock onto one of its axes based on the initial direction of 
your drawing stroke. In some situations, it may be hard for the tool to lock onto the expected guide axis. To 
remedy this, it is possible to manually select which axis you want to lock your drawing strokes to. 

How to lock your drawing tool to a specific axis

 1. Set the focus to the Stage or Camera view, for example, by clicking on the view's tab.

 2. Press the Left Arrow or Right Arrow key repeatedly to cycle through your guide's axes. The 
selected axis will be displayed in bold across your mouse cursor.

All your drawing strokes will lock onto the selected axis. 

How to re-enable using all axes

 1. Press the Left Arrow or Right Arrow key repeatedly to cycle through your guide's axes, until none of 
them are displayed in bold across your mouse cursor. 
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Drawing Freehand Perspective with Drawing Guides
By default, all strokes drawn with an active drawing guide are straight lines that follow one of the guide's axes. 
To achieve a different style, you might want to draw with freehand perspective instead, where you use the 
guides as references, but without forcing your strokes to be straight and aligned with their axes. This can be 
done by disabling the Align with Guide option, which is enabled by default. 

When the Align with Guide option is disabled:

 l The Brush, Pencil, Line  and Eraser  tools will no longer lock to your guide's axes, allowing you to draw 
strokes in any direction.

 l The guide will still be visible, but will only serve as a visual aid. 

 l The initial angle of your stroke will still determine which axis you're using, but instead of locking your 
stroke on the axis, it will simply make the reference line for that axis bolder, to help you draw along it.

How to draw freehand perspective

 1. In the Guides view, activate the Align with Guide  button, or press Shift + A. 

You can now draw freely and use the guide as a visual aid.

 2. Start drawing.
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Erasing Using Drawing Guides
By default, drawing guides have no effect when using the Eraser tool. However, if needed, you can make the 
Eraser tool use your selected guide. 

How to erase using a Drawing Guide

 1. In the Guides view, activate the Enable Guide with Eraser button.

The Eraser  tool will now  work with the currently selected guide, just like the Brush , Pencil  
and Line   tools. 

 2. Start erasing.

NOTE 

With the Enable Guide with Eraser option, you can also edit your guide's horizon line and 
vanishing points using the Eraser tool.
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Viewing Drawing Guide Reference Lines
T-SBADV-006-007

By default, a guide will only display its horizon line, its vanishing point, and its axes relative to your mouse 
cursor's position. To help you lay out the objects in your drawing, you can also enable reference lines. Reference 
lines are multiple semi-transparent lines that are drawn in parallel to your axes and from your vanishing points, 
at an equal distance or angle from each other, to cover your entire drawing space with visual guides. 

When using reference lines, you can decide the amount of lines that display in your drawing space. If you have 
too many reference lines, they will be very close to each other and your drawing space might feel cluttered, but 
if you have too few, you might not always have a reference line close enough to the stroke you wish to draw to 
help serve as a reference.

How to view Drawing Guide Reference lines

 1. In the Guides view, activate the Show Reference Lines  button, or press Shift + G. 

The reference lines appear as a semi-transparent overlay.

 2. In the Guides view, use the Number of Lines slider to adjust the line density. 
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Minimizing Guide Cursor Axes Display
By default, the guide axes that are drawn across your mouse cursor extend throughout your entire drawing 
space. You may want those axes to only extend to a short distance around your cursor, so that they can still 
serve as guides without obstructing your drawing space or drawing your eye away from your mouse cursor. You 
can do this by disabling the Full Cursor Display option, which is enabled by default.

When the Full Cursor Display option is disabled:

 l The guide axes displaying across your mouse cursor only span on a short distance from your mouse 
cursor.

 l When drawing a stroke, all guide axes disappear until you finish drawing the stroke. By default, only the 
axis you are drawing on disappears.

 l The actual axes used to lock your drawing tool still extend across the entire drawing space. Only the 
axes displayed in your drawing space are shortened.

How to minimize the Drawing Guide's cursor axes display

 1. In the Guides view, toggle the Full Cursor Display  button off. 

The guide axes now only span over a short distance from your mouse cursor.

416



Preventing the Editing of Drawing Guides
T-SBADV-006-008

When using a drawing tool with a guide, you are also able to edit the guide's horizon line and vanishing points. 
This may be a problem if you need to draw close to the horizon line or to your vanishing points, as you may 
accidentally displace them instead. Once you're sure that your guide is properly set up, it is recommended to 
lock your guides before you start drawing, so you don't have to worry about editing them by accident.

How to prevent editing of  Drawing Guides while drawing

 1. In the Guides view, activate the Lock Guide  button, or press Shift + L. 

NOTE 

The Lock Guide option locks the editing of all guides, not just the selected one. When creating 
a new guide, the Lock Guide option is automatically disabled to allow the new guide to be 
edited immediately.
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Enabling and Disabling Drawing Guides
T-SBADV-006-009

When you want to stop working with guides, you must disable them. When drawing guides are disabled:

 l The Brush, Pencil, Line and Eraser tools have their normal, non-constrained behavior. 

 l The horizon, vanishing points, guide axes and reference lines are not displayed.   

How to enable and disable a Drawing Guide

 1. To enable or disable Drawing Guides, do one of the following:        

 l In the Guides view, enable or disable the Enable Guide  button.

 l Press G.

NOTE 

The guide that was selected for your panel when you disable guides will be restored when you 
enable them again.

NOTE 

Drawing guides only work with the Brush, Pencil and Line tools. They will behave as if they 
were disabled when any other tool is selected.
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Importing and Exporting Drawing Guide Lists

How to export Drawing Guides to a file

 1. In the Guides view, select one or multiple guides from the list.

 2. In the Guides View menu, select Export Selected Guides.

 3. In the Export Guides dialog box that displays, choose a destination filename and folder and click 
Save.

The selected guides are written into the destination file. A message displays to confirm the amount 
of guides that were exported.

How to import Drawing Guides from a file

 1. In the Timeline or Thumbnail view, select the destination panel. 

 2. In the Guides View menu, select Import Guides.

 3. In the Import Guides dialog box that displays, choose a file from a previous export and click Open.

The Drawing Guides from the imported file are inserted at the bottom of the Drawing Guide list. A 
message displays to confirm the amount of guides that were added.

NOTE 

When importing a list of guides, duplicate guides are filtered out to avoid cluttering the list. The 
import confirmation will indicate if duplicates were detected and filtered out.
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Automatically Filling Drawings with a Matte
T-SBFND-008-019

When sketching characters with a background in Storyboard Pro, you might find that the outlines of 
characters clash too much with the outlines of backgrounds and that filling your character's outlines with white 
or another solid colour would make the panels more legible. However, since storyboarding is often a hasty 
process, you may not have time to fill each drawing you make manually. 

The Generate Auto-Matte dialog box allows you to quickly create a colour matte to fill the inside of sketch 
outlines, hiding anything that is behind your sketch. The shape of the matte generated automatically based on 
the outlines of your artwork, and will fill your drawing even if there are gaps in the outline and even if the 
drawing extends beyond the camera frame. 

You can generate a matte on one or several layers in a single panel at a time. 

How to fill drawing layers with a matte

 1. In the layer panel or the Layers view, select the layers for which you want to generate a matte by 
doing one of the following:

 l To select a single layer, simply click on it.

 l To select several non-contiguous layers, press and hold Ctrl (Windows) or ⌘  (macOS) and 
click on each layer you want to select.

 l To select several contiguous layers, press and hold Shift and click on the first layer you want 
to select, then on the last layer you want to select.
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 2. If you want your matte to be filled with one of the colours in your colour palette, select the desired 
colour in the Colour view. Otherwise, you can also pick a colour for the matte later. 

 3. Do one of the following:

 l In the top menu, select Layer > Generate Auto-Matte.

 l Right-click on the selected layer(s) and select Generate Auto-Matte.

The Generate Auto-Matte dialog appears.

 4. If you want a precise matte or a matte for a small drawing, reduce the Radius setting. If you want to 
generate a very rough or approximate matte, increase the Radius setting.

 5. If you want the matte to be filled with the currently selected colour, leave the Matte Colour setting 
to Current. Otherwise, set it to Custom, then click on the colour swatch to the right to open a colour 
picker dialog and select a colour for your matte.

 6. If you want the matte to be generated in the layer containing your outlines, uncheck the 
Create Matte on New Layer option. Otherwise, a new layer will be created underneath the layer 
containing your outlines, and the matte will be generated in that new layer. 

NOTE 

In both cases, the generated matte will appear behind the outlines in your artwork. 

 7. If you chose to generate the matte in a new layer, but you want to be able to fill the different 
sections of the matte in different colours, check the Copy Strokes to Destination option. This will 
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copy your artwork onto the matte, but as invisible outlines (referred to as strokes). You will be able to 
fill those outlines with different colours. 

 8. Click on OK.

A coloured matte is generated for each selected layer, and is placed behind the artwork in each 
selected layer. 

NOTE 

If you chose to create the matte in a new layer, and a matte layer already exists 
for one of the selected layers, you will be prompted to either Replace the existing 
matte, to Keep Both the old and new mattes or to Cancel.                         

If this happens for multiple layers, you can check the Apply to All option to either 
replace the matte, keep both mattes or cancel for all layers. 
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If you need to generate the matte for all the drawings in your storyboard, you should assign a keyboard 
shortcut to the Generate Auto-Matte dialog to streamline the procedure. 

How to assign a shortcut key to the Generate Auto-Matte dialog

 1. Select Edit > Preferences (Windows) or Stage > Preferences (Mac OS X).

 2. Select the Shortcuts tab.

 3. In the Shortcuts list, select Layer > Generate Auto-Matte.

 4. Click inside the Press Shortcut Key field.

 5. Press the shortcut key you want to assign to the Generate Auto-Matte dialog.

 6. Click on OK.
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Blurring Layers
T-SBADV-007-001

If the layer on which you want to apply an effect is a vector layer, you must first convert it to a bitmap layer.

How to apply an effect on a bitmap layer

 1. Select the layer(s) on which you want to apply an effect.

 2. Do one of the following: 

 l Right-click the layer and select Apply Effect on Bitmap Layer .

 l From the top menu, select Layer > Apply Effect on Bitmap Layer. 
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 3. Choose an option:

 l Blur 

 l Radial Zoom Blur

 l Directional Blur

 4. In the dialog box, enter your parameters.

 5. Click OK.
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Sharing Drawings
When there is a drawing that occurs across multiple panels, you can share (link) the drawing. This way, any 
changes you make to one of the drawing affects all other instances, making it faster and more efficient when 
managing and producing your storyboard.

Duplicating a panel that contains a shared drawing preserves the link.

When sharing is not needed, you can easily unlink an instance of a shared drawing from the other instances.

How to share a drawing

 1. In the Drawing list, right-click the layer that contains the drawing to share. 

 2. Right-click and select Share Drawing.

The drawing is now available in the Shared Drawings folder of the Library view. In the Layers list, a 
star appears beside the name of the drawing to indicate that it is a shared drawing.

 3. To use the shared drawing in another panel, drag it from the Share Drawings folder to the Layer list 
or Stage view.

How to unlink a shared drawing

 1. Right-click the layer to unlink and select Unlink from Shared Drawing.

The layer is unlinked from the shared drawing and its instances.
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Chapter 8: Colour

With Storyboard Pro, you can add colour to your projects.
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About Colour Swatches
T-SBFND-008-008

You can use two different types of colour swatches. You can paint drawings with vector swatches, which are 
the solid and gradient colours.

You can paint your vector drawings with bitmap texture swatches. You can import textures and add them to 
your palette. Textures must be *.psd or *.tga files. Transparency is supported. Once you have painted with 
textures, you can edit the gradient's position—see Using the Edit Gradient - Texture Tool on page 446.

429

Storyboard Pro 6. User Guide                          



Chapter 8: Colour

Changing the Current Colour
T-SBFND-008-009

There are several ways to modify the current colour. It can be modified directly in the Colour view using the 
sliders (HSV or RGB), or using the Colour Picker window.

How to change the current colour in the Colour view

 1. In the Colour view, make sure the Colour area is expanded by clicking the Collapse/Expand arrow.

 2. In the Colour view, drag the H,S,V sliders left or right to adjust the colour. 

 3. In the Opacity field, adjust the colour's alpha.

 4. In the HSV/RGB menu, you can switch between HSV and RGB sliders.

How to change the current colour in the Colour Picker window

 1. In the Colour view, make sure the Colour area is expanded by clicking the Collapse/Expand arrow.

 2. Double-click on the current colour swatch. 

The Colour Picker window opens.
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 3. In the Colour Picker window, do one of the following to modify the current colour:

 l In the colour picking area, click to select a colour.

 l Type in the HSV or RGB values in the corresponding fields. Select the R,G,B or H,S,V 
options to change the look of the colour picking area.

 l Drag the Dropper  to select any colour in the Storyboard Pro interface. 

NOTE 

When using the Dropper tool, the selected colour becomes the current colour, but 
is not added to the colour swatches.

You can also click the Multi Wheel Mode button to open the Multiwheel Colour dialog box. This 
displays all the picking area styles and a picking undo list. Click the Single Wheel Mode button 
return to the regular Colour Picker window.
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 4. Click the Shade Scale swatches to modify the shade of the selected colour.

 5. Adjust the level of transparency with the Alpha slider, or type the value directly in the Alpha field.

 6. Click the Add button to add the current selected colour to the Colour Storage Library, so you can 
quickly access it later.

 7. You can rename the colour swatch in the Colour Picker window or directly in the colour list by 
double-clicking its name.
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Adding Colour Swatches
T-SBFND-008-010

You can create your own vector colour swatches and import bitmap textures to use as swatches in your palette.

NOTE 

Once added, a colour swatch can no longer be modified. You must delete the swatch and add a new 
one.

How to add a vector colour swatch

 1. In the Colour view, make sure the Colour area is expanded by clicking the Collapse/Expand arrow.

 2. Using the Colour view sliders or the Colour Picker window, adjust the colour for the new swatch.

 3. Click the Add Colour  button or select New Colour Swatch from the Colour Swatch menu.

How to create a bitmap texture swatch

 1. In the Colour Swatch menu, select New Texture.

A browser window opens.

 2. Browse for a PSD or TGA bitmap file created in a third party software and click Open.
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A textured colour swatch is added to the swatch palette.
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Renaming Colour Swatches
If you plan on adding a lot of colour swatches to your palette, it is a good idea to organize them by naming and 
reordering them.

How to name a colour swatch

 1. In the Colour Swatch menu, deselect the Swatch Mode option.

 2. In the Colour list, double-click on a swatch name to rename it.

 3. Once you are done renaming the swatch, press Enter/Return to validate the entry.

How to order swatches

‣ In the Colour list, in Swatch mode or List mode, drag and drop the swatches to change the order.
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Deleting Colour Swatches
At any time, you can delete colour swatches that you are not using or not part of the colour palette you have in 
mind for a character or scene.

How to delete a colour swatch

 1. In the Colour view, select a colour swatch to delete by clicking a swatch. To select multiple swatches, 
press Ctrl (Windows) or ⌘  (macOS), and click the swatches to delete. To select multiple swatches in 
a range, press Shift, click the first swatch to delete and then click the last swatch.

 2. Do one of the following:

‣ Press Delete.

‣ From the Colour Swatch menu, select Delete Swatch. 

‣ Click the Remove Colour  button. 

436



Creating Gradients
Vector drawings can be painted using linear and radial gradients. Once painted, you can modify the position of 
the gradient—see Using the Edit Gradient - Texture Tool on page 446.

How to create a gradient colour

 1. In the Colour view, double-click the current colour swatch. 

The Colour Picker window opens.

 2. Select the Gradient option. 

 3. Select the Linear or Radial option.

 4. In the color picking area, use the gradient arrows to modify the colours.
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Sharing Colour Palettes
Once you have established the colours to be used throughout your storyboard, you can save it as your default 
colour palette for the project. You can also import and export colour palettes so that everyone on your team is 
using the same colours. 

NOTE 

Toon Boom colour palettes are appended with a .plt extension.

How to save a default colour palette

‣ In the Colour view, click the Colour Swatch menu and select Save as Default Palette.

How to export a colour palette

 1. From the Colour Swatch menu, select Export Colours.

 2. In the Export Colours window, give your palette a name and click Save.

How to import a colour palette

 1. From the Colour Swatch menu, choose Import Colours.

 2. In the Import Colours window, select a colour palette and click Open.
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About Colour Tools
The colour tools are available in the Tools toolbar. The Tool Properties view displays the properties of the 
currently selected tool on the current layer you are working. If you are editing a vector layer, then all of the tools 
are available to you. If you are drawing on a bitmap layer, some tools are not available.

NOTE 

You can display the Tools toolbar horizontally (flat toolbar) if you find it more efficient for your 
workflow—see Tools Toolbar in the Reference Guide.

Depending on the type of layer you select, here are the colour tools available:

 

Tool Vector Layer Bitmap Layer

Edit Gradient/Texture • •

Paint • •

Paint Unpainted • •

Unpaint • •

Close Gap •  

Dropper • •
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About the Paint Tool
The main tool you will use to paint your drawings is the Paint tool. The Paint tool can be used in several 
different modes, and can be customized in the Tool Properties view.

The Paint tool only paints closed zones. If you have gaps in your lines, you must close them using either the 
Brush, Pencil, or Close Gap tools.
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About Painting Modes
The Paint  tool has three different modes: Paint, Paint Unpainted, and Unpaint.

You can also find these tools in the Tools toobar and in the Tools menu.

You can also enable the Auto Close Gap mode to automatically close open areas while painting.
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Painting
T-SBFND-008-011

How to paint a drawing

 1. Do one of the following:

 l In the Tools toolbar, select the Paint  tool. 

 l In the top menu, select Tools > Paint.

 l Press Alt+I.

 2. In the Colour view, do one of the following to select a colour:

 l Use the Hue, Saturation and Value sliders to select the colour with which you want to draw.

 l Select a colour swatch from the swatch list.

 3. In the Stage view, start painting on your drawing by clicking the area to be painted. If you want to 
fill several areas simultaneously, draw a lasso around them.
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NOTE 

If the shape you are trying to paint is not fully closed, it will not fill. You can make the 
Paint tool automatically close small gaps in the shapes you attempt to fill by increasing 
the Close Gap  setting of the Paint tool in the Tool Properties view. To close big gaps, 
you can use the Close Gap  tool, which is available in the pop-up menu of the Paint 

 tool in the Tools toolbar.
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Using the Dropper Tool

While working in the Stage view, you can use the Dropper tool to pick a colour from your drawing without 
going to the Colour view. When picking a colour with the dropper, the colour is not added to the swatch list. It 
becomes the current colour.

How to select a single colour in a drawing

 1. Do one of the following:In the Tools toolbar, select the Dropper  tool.Select Tools > 
Dropper.Press Alt + D.

 2. In the Stage view, click the desired colour.

How to select a composite colour

 1. Do one of the following:In the Tools toolbar, select the Dropper  tool.Select Tools > 
Dropper.Press Alt + D. 

When enabled, the dropper picks the RGBA values of all the layers combined. When disabled, the 
dropper picks the RGBA value from just one layer at a time.

 2. In the Tool Properties view, click the Sample All Layers  button.

 3. In the Stage view, position the dropper tip over overlapping strokes and click to select the colour.

The new colour is displayed in the Colour view and becomes the current colour.
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How to select colours with or without transparency

 1. Do one of the following:In the Tools toolbar, select the Dropper  tool.Select Tools > 
Dropper.Press Alt + D.

 2. In the Tool Properties view, do one of the following:

‣ Click the Do Not Pick Transparency  button to select colours at 100% opacity, ignoring the 
alpha value.

‣ Do not click the Do Not Pick Transparency  button to select colours and retain the alpha value 
of the stroke.

 3. In the Stage view, position the dropper tip over a stroke and click to select the colour.

The new colour is displayed in the Colour view and becomes the current colour.
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Using the Edit Gradient - Texture Tool

If you paint a zone with a gradient or texture colour, you can use the Edit Gradient/Texture tool to modify its 
position in the zone. You can move, scale, rotate and skew. If you want to match the colour to the animation, set 
the first texture position and copy the Edit Gradient/Texture position. When moving to the next drawing, you 
can select the next texture and paste the previous position to continue the modifications.

If you are painting a hand-drawn animation or if you want the Brush and Paint tool to use your gradient’s 
position, angle and scale settings instead of the default ones, you can store your own settings and reuse them 
afterward.

This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawn with 
textured “brushes”. If you then paint your textured pencil line with a gradient, you can do so and then edit both 
elements independently at the same time.

How to use Edit Gradient/Texture tool

 1. In the Tools toolbar, select the Edit Gradient/Texture   tool or select Tools > Edit 
Gradient/Texture.

 1. Click the Gradient or Texture zone to be modified. To modify several areas at once, hold down the 
Shift key and click in the zones to be modified.
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 2. Move the edit texture’s anchor points to the desired result.

‣ If the same modification needs to be applied to another gradient in another drawing or texture 
zone, you can select the modified zone and select Edit > Copy. Select the zone to be modified in 
the other drawing and select Edit > Paste.
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Using the Close Gap Tool

The paint tool requires the area you attempt to fill to be closed in order to know exactly what area of your 
artwork must be filled. However, it is common for artists to accidentally leave small gaps in their artwork. 

The Close Gap tool allows you to quickly close small gaps in a shape by creating an invisible stroke connecting 
two extremities of the gap. You can then fill the area using the Paint tool, as this invisible stroke will be taken in 
account to determine the outline of the shape to fill. 

TIP 

You do not need to use the Close Gap tool with precision. If you draw a crude stroke near the gap 
you want to close, the tool will automatically detect the two closest line extremities and will draw an 
invisible straight line connecting them. closing the gap between them. 

How to use the Close Gap tool

 1. In the Tools toolbar, select the Close Gap   tool or select Tools > Close Gap.

 l Click the Auto Flatten  button in the Tool Properties view if you want the stroke you will 
draw to be flattened in your drawing instead of being on top.

 l You can display the invisible lines by selecting  View > Extras > Show Strokes in the top 
menu.

 l If you do not display the strokes, a warning message dialog box will appear. Enabling the 
Don’t Show This Message Again option prevents this Message from appearing.

 2. In the Stage view, trace an invisible line near to the gap to be closed. 

The gap automatically closes.
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Chapter 9: Timing
Once you have created a storyboard, you can start working on making your storyboard into a full-featured 
animatic. The first step to making an animatic is to time each panel and scene in your storyboard to match the 
intended pace of your action and, if applicable, the soundtrack. 

By default, each panel you add to your project is timed to last one second during playback. Hence, you already 
have a barebone animatic just as soon as you finished creating your storyboard. Using the Timeline view, you 
can adjust the cue time and length of each panel, then play your animatic to test the pace. 

In Storyboard Pro, time is expressed in the following format: HH:MM:SS:FF, where HH means hours, MM means 
minutes, SS means seconds and FF means frames. 

TIP 

By default, the time at frame 1 of the project is 00:00:00:00. However, in animation, the first 
frame of a scene is usually identified as frame 1. If you prefer the time at frame 1 of your project to be 
00:00:00:01, you can set the time code at the start of your project by changing the Project Start 
Time setting in the Settings tab of the Project Properties dialog. You can also change the default 
value of that setting for new projects in the Global UI tab of the Preferences dialog. 
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About the Panel Duration
T-SBFND-009-001 

When panels are initially created, their default length is 1 second, displayed in timecode format. When it comes 
to your animatic, you will want to be more accurate. Modifying the duration of a particular panel is key when 
working out timing. There are a few different ways to accomplish this.

In the Timeline view, it is easy to change the duration of a panel just by dragging to resize it. This way, you can 
easily see the length of panels in relation to one another.
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Changing the Panel Duration
T-SBFND-009-002

There are two ways to resize a panel, depending on how you want the change to affect subsequent panels. 
You can resize a panel in the Timeline view and shift all other panels down. This is handy when you are not 
concerned about modifying the position of all subsequent panels. Or you can resize a panel while only affecting 
the next panel. This is useful if you need to keep subsequent panels exactly where they are.

An accurate way of setting the duration of a panel is to use the Panel view, which will display, among other 
things, the exact timecode information for the selected panel. You can also use the Add Frame to Panel and 
Remove Frame from Panel commands, in the Storyboard Pro menu, to adjust the length of the selected panel 
frame by frame. 

NOTE 

When you change the duration of a panel, its camera and layer keyframes are repositioned. 
However, if you change the length of a panel one frame at a time, the position of keyframes might 
not follow. This is because keyframes can only be positioned on whole frames, so they cannot be 
shifted by distances too small. 

How to set the panel duration in the Panel view

 1. In the Timeline or Thumbnails view, select a panel.

 2. In the Panel view, do one of the following:

 l In the Duration field, type in the exact desired length for the panel, in the H:MM:SS:FF 
format, where H means hours, M means minutes, S means seconds and F means frames. 

 l Right of the Duration field, click on the Up  arrow to extend the panel by one frame, or on 
the Down  arrow to shorten the panel by one frame.
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How to adjust the length of a panel in the Timeline view and ripple subsequent panels

 1. Place the cursor over the right edge of the panel you want to resize. 

The resize icon displays.

 2. Click and drag the edge of the panel to the right to extend it, or to the left to shorten it. As you drag, 
the new length of the panel is indicated, along with the amount of time you are adding or 
subtracting from it. 

All subsequent panels will be rippled forward or backward to preserve their length. 

How to resize a panel without offsetting later panels and resize the next panel only

 1. Place the cursor over the right edge of the panel you want to resize. 

The resize icon displays.
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 2. While holding the Alt key, click and drag the edge of the panel to the right to extend it, or to the left 
to shorten it.  As you drag, the new length of the panel is indicated, along with the amount of time 
you are adding or subtracting from it. 

The length of the following panel will be adjusted to avoid shifting subsequent panels.

How to adjust the panel duration frame by frame

 1. In the Timeline or Thumbnails view, select a panel.

 2. Do one of the following:

 l Press + to add a frame to the panel, or - to remove a frame from the panel.

 l From the top menu, select Storyboard > Add Frame to Panel or Storyboard > Remove 
Frame from Panel.
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Setting the Panel's In and Out Point 
You can adjust the duration and position of a panel by moving its in and out points to a specific frame 
determined by the current position of the playhead.

NOTE 

Note that the frame you specify must be contained within the current position of the panel you 
want to change the in or out point of.

How to set a panel's in point to the current frame

 1. In the Timeline view, position the red playhead where you want the panel to start.

 2. Do one of the following:

‣ Select Storyboard > Move Panel In to Current Frame.

‣ Right-click on the selected panel and select Move Panel In to Current Frame.

The selected panel's in point is pushed to the new position, resulting in the previous panel being 
extended to this point.

How to set the panel's out point to the current frame

 1. In the Timeline view, position the red playhead to where you want the panel to end.

 2. Do one of the following: 
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‣ Select Storyboard > Move Panel Out to Current Frame. 

‣ Right-click on the selected panel and select Move Panel Out to Current Frame.

The selected panel's out point is pushed to the new position, shortening its duration.
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Splitting a Panel at the Current Frame
You can split your current panel into two pieces. Following this operation, you will have two identical panels 
generated from the original. All elements, including layers, will be in both panels. Each panel’s length will be 
determined by where you have the red playhead when you perform the operation.

How to split panel at current frame

 1. In the Timeline view, position the red playhead to where you want the panel to be split.

 2. Do one of the following to split the panel:

‣ Select Storyboard > Split Panel At Current Frame.

‣ In the Timeline view, right-click in your selected panel and select Split Panel At Current Frame.

Your panel is split into two pieces, precisely where the red playhead is positioned.

NOTE 

You may have to adjust any layer transformations you created before splitting the panels.
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Locking the Scene Duration
You can lock the duration of all scenes in your project with the Lock Scene Duration command. This ensures that 
the length of every scene is preserved when adding, duplicating, or deleting panels.

How to lock the scene duration

 1. Select Storyboard > Lock Scene Duration. 

NOTE 

You can add a custom keyboard shortcut to this option through the Preferences dialog box or 
use the Lock Scene Duration  button in the Storyboard toolbar. You may need to add the 
button to the toolbar. Right-click the toolbar area and select Customize.

 2. Once your scene duration is locked:

‣ Adding a panel using the New Panel or Smart Add Panel command reduces the size of the 
selected panel to make room for the new one. If the selected panel's length is one frame,  the 
panel length cannot be reduced and therefore the new panel cannot be inserted in the scene.

‣ Deleting or cutting one or more panels causes the preceding panel's length to extend to fill the 
gap and preserve the scene's duration. Cutting or deleting a scene or all the panels on a scene 
will not let you preserve the scene's duration.
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‣ Duplicating a single panel using the Duplicate Panel command reduce the length of the selected 
panel to make room for the duplicated one. Duplicating multiple panels will not keep the scene's 
duration.

‣ Copying and pasting panels, adding a scene or a sequence, or deleting an entire scene will not 
preserve scene duration.

‣ Manually changing the duration of a panel is still permitted and will modify the scene duration.
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Selecting All Panels Forward
By using a series of keyboard shortcuts, it is possible to select a panel and all the panels following. You can also 
do this on the audio tracks—see Sound on page 598.

How to select all panels forward

 1. In the Timeline view, select a panel.

 2. Hold Ctrl + Alt + Shift (Windows) or ⌘  + Alt (Mac OS X) and click the panel again.

The selected panel and all the panels following it, up until the end of the storyboard project, are 
selected.

‣ If you drag the selection forward, the panel preceding the selection will be extended.

‣ If you drag the selection backward, the panel preceding the selection will be reduced until it 
reaches the minimum length allowed (one frame). Then the second panel preceding it will be 
reduced.

How to select all panels and all sound clips forward

 1. In the Timeline view, press Ctrl + Alt + Shift (Windows) or ⌘  + Alt (Mac OS X) and  click the panel 
from which you want the selection to start.

The panel and all the panels following it, up until the end of the storyboard project, as well as all the 
sound clips in all audio tracks starting from the position of the play head are selected and can be 
moved together.

‣ If you drag the selection forwards, the panel preceding the selection will be extended.

‣ If you drag the selection backwards, the panel preceding the selection will be reduced until it 
reaches the minimum length allowed (one frame), then the second panel preceding it will be 
reduced. Overlapping sound clips will be overwritten by the ones that are selected.
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Playing Back the Animatic
You can preview your project as an animatic in Storyboard Pro at any time during its development process. 
Using the Playback toolbar, you can preview the visual content, including transformations and transitions, and 
have it synchronized with sounds.

How to preview an animatic

 1. In the Playback toolbar, click the Sound  button.

If you want to see how the shots will look with dynamic camera movement, click the Camera 
Preview  button.  You will need this option on to preview Camera moves and transitions. When 
you drag the timeline playhead while Camera Preview is enabled, it will adjust the Stage view to 
match the point of view of the camera.

 2. In the Timeline or Thumbnails view, select the panel where you want the playback to begin.

 3. In the Playback toolbar, click the Play Selection  or Play  buttons or press Shift + Enter.

 4. To play your project in a continuous loop, click the Loop  button.

 5. You may also scroll through the Timeline view by dragging the red playhead. 

 6. Select Play > Previous Frame or Next Frame to skip and play back one frame at a time. Or press 
comma (,) and period (.).
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About Markers
T-SBFND-009-017

Markers are visual indicators displayed at the top of the Timeline view, in the frame counter area. Use markers 
to denote anything relevant to your work. You can indicate the frames you want to clean up, a change in action, 
an impact, or where you intend to apply an effect. In addition, you can add a note to a scene marker, which will 
be displayed with the starting time value when you hover over the marker.
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Creating Markers on a Current Frame
T-SBFND-009-018

Using Markers, you can identify important moments in your storyboard. You can later easily find these moments 
by simply scanning the Timeline.

How to mark the current frame

 1. In Timeline view, drag the red playhead to the frame on which you want to add a marker.

 2. Do one of the following:

 l Select Storyboard > Markers > Add Marker.

 l Right-click in the frame counter area and select Add Marker.

A marker is added in the Timeline view at the exact position of the red playhead.

NOTE 

It is also possible to add a marker during a playback of the storyboard or to a 
sound by right-clicking in the the frame counter area. The marker will appear at 
the exact position of the red playhead at the moment of the right-click.
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Deleting Markers
T-SBFND-009-022

You can delete any marker no longer needed in the project.

How to delete a marker

 1. In the Timeline view, select the marker you want to delete.

 2. Do one of the following:

 l Select Storyboard > Markers > Delete Marker.

 l Right-click in the frame counter area and select Delete Marker.

How to delete all markers

 1. Do one of the following:

 l Select Storyboard > Markers > Delete All Markers.

 l Right-click in the frame counter area and select Delete All Markers.

NOTE 

When deleting all markers, it is not mandatory to select a marker first.
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Editing Markers
T-SBFND-009-019

Once a scene marker is created, you can modify the duration of the marker, modify its colour, apply a note to 
identify it, or move it.

The following image is an example of an edited marker:

How to edit a marker

 1. In the Timeline view, select a marker.

 2. Do one of the following:

 l Select Storyboard > Markers > Edit Marker.

 l Double-click on the marker.

 l Right-click in the frame counter area and select Edit Marker.

The Marker dialog box opens.

 3. Make your changes.

 4. Click OK.
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Displaying Marker Tooltips
T-SBFND-009-020

You can display marker tooltips by hovering the pointer over a marker.

How to display a marker’s tooltip

 1. In Timeline view, hover over a marker.

NOTE 

The marker's tooltip can display time, duration and note.

 2. Move the pointer over the next marker to see the next tooltip.

NOTE 

As default value, the marker tooltip only shows the information about the time. 
Depending on the changes made in the Marker dialog box, the tooltip may show 
additional information, such as duration and note. If a duration other than 
00:00:00.00 has been set, duration information will appear in the tooltip. The 
same logic applies to note information. For details, see Editing Markers on page 
467.

You can display the tooltip by hovering over the marker between its starting and 
ending points. The range varies depending on the duration of the marker.
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Moving Markers
T-SBFND-009-021

You can move a marker to another location when needed.

How to move a marker

 1. In Timeline view, select a marker.

 2. Drag and drop the marker to the new location.

NOTE 

Only one marker can be selected at a time; therefore, it is not possible to drag 
and drop multiple markers at the same time.

In the Timeline view, if more than one marker appears at the same time/frame, 
the last marker created or moved appears on top of the other(s).

How to snap a marker to the beginning of a panel

 1. In Timeline view, right-click in the frame counter area and select Snapping.

 2. Select the marker.

 3. Drag the marker near the beginning of the new panel.

When the marker snaps at the beginning of a new panel, a blue line with arrows will replace the 
red line of the red playhead.
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Exporting Markers to Toon Boom Harmony
When exporting scenes from Storyboard Pro to Toon Boom Harmony, the markers are exported automatically. 
All information about the markers (time, duration and note) will be brought over.

For more information, see Exporting Harmony Scenes on page 797

From Storyboard Pro:

To Toon Boom Harmony:

NOTE 

For more information about Scene Markers in Toon Boom Harmony, see About Scene Markers.

NOTE 

In Storyboard Pro, any marker having a range that exceeds another scene, will not be exported in 
the second scene in Harmony.
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Chapter 10: Animation
The camera and layers in your panels can be animated. This is helpful to test the potential animation of scene 
elements. In Storyboard Pro, you can add keyframes to move a camera or layer to a specific position and keep 
adding keyframes and moving the camera or layer until you are satisfied with the movement. When you play 
back the panels, the layer moves from one position to the next. 

By default, layers are not animated. To animate a layer, you will use the Layer Transform tool. Using the Layer 
Transform tool on a layer that contains no animation will affect the panel's entire duration.

NOTE 

When a layer is selected and the Layer Transform tool is active, the 3D path for the layer is 
displayed in the Stage, Camera, Top and Side views.

As you animate the position of a drawing layer, a motion path is created which are trajectories. Using 
keyframes, you can then record key positions along the trajectory. You can produce simple and advanced 
motions and trajectories.

About the Animate Mode
Animate mode records the position, rotation, scale, skew, etc. of objects as keyframes in the Timeline view. Turn 
off the Animate mode to reposition objects for the entire scene. When the Animate mode is disabled, 
keyframes are not created when an object's parameters change.

To animate a layer using multiple keyframes, you must first activate the Animate mode. You can modify the 
object in the panel and Storyboard Pro will transform the object from one keyframe to the next at a speed 
defined by the duration of the panel.

Deactivating the Animate mode clears all the keyframes and leaves the layer at the position of the current 
frame.
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Animating Layers
T-SBFND-009-008

By default, layers in Storyboard Pro are static, but they can be animated. 

A layer is animated by setting it in different positions, angles or sizes at two different frames in the timeline, 
then letting Storyboard Pro calculate the position, angle and size of the layer for each frame between those 
two frames. The frames at the beginning and end of an animation are referred to as keyframes. 

You can animate a layer by enabling animation on it, which will create a keyframe for it in its current position, at 
the current frame. From there, you can just go to another frame and change its position, which will 
automatically create another keyframe at the current frame. At this point, the layer is already animated from its 
original position to the position you just moved it to. 

How to animate a layer

 1. In the Timeline view, select the panel with the layer you want to animate.

 2. Move the Timeline cursor to the exact time where you want to create the first keyframe for your 
animation.

 3. In the Layer panel of the Stage or Camera view or in the Layers view, click on the Animate button 
of the 3D object you wish to animate.

The Animate button turns yellow and changes shape: .

In the Layer Animation track of the Timeline view, a keyframe is created at the current frame. This 
keyframe  stores the position, angle and size of the layer at the current frame. 
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 4. In the Tools toolbar, select the Layer Transform  tool.

In the Stage or Camera view, the controls of the Layer Transform tool appear around the selected 
drawing layer.

 5. Using the manipulator box, transform the layer so that it is in the position, angle and size you want 
it to be at the beginning of the animation:

 l To move the layer, either click on its artwork or on the blue point in the centre, then drag it to 
the desired position.
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TIPS 

 l If you are having trouble dragging the layer by its artwork, you can also click 
and drag on the blue point  in the centre. However, this point may be 
obstructed by the layer's pivot point . If that is the case, you can click and 
drag on the pivot point to move it out of the way, then click and drag on the 
centre point to move the layer. 

 l You can also nudge the selection by using the arrow keys on your keyboard.

 l You can also enter specific coordinates in the Horizontal Offset  and 
Vertical Offset  fields in the Tool Properties view.

 l To scale the layer, click on one of the squares at the edges or corners of the manipulator box 
and drag them to stretch or shrink the drawing.

TIPS 

 l You can preserve the horizontal and vertical proportions of the selection by 
holding the Shift key.

 l You can also enter specific scale percentages in the Horizontal Scale  and 
Vertical Scale  fields in the Tool Properties view.

 l To rotate the layer, move the cursor just outside of one of the corners of the manipulator box 
until the mouse cursor becomes . Then, click and drag in either direction to rotate the layer 
clockwise or counterclockwise. 
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TIPS 

 l You can rotate the artwork in 15° increments by hold the Shift key.

 l You can also enter a specific angle in degrees in the Angle  field of the Tool 
Properties view.

 l You can also rotate the clip in 90° increments by clicking on the Rotate 90 
CW  button in the Tool Properties view to rotate it 90° clockwise, or on the 
Rotate 90 CCW  button to rotate it 90°  counterclockwise. 

 l To flip the layer horizontally, click on the Flip Horizontally  button in the Tool Properties 
view.

 l To flip the layer vertically, click on the Flip Vertically  button in the Tool Properties view.

 l To reset a layer to its original position, scale and angle, do one of the following:

 l Select Layer > Reset Transform.

 l Press Ctrl + R (Windows) or ⌘  + R (Mac OS X).

 6. In the Timeline view, move the cursor to the frame where you want to create your second keyframe.

 7. In the Stage or Camera view, use the manipulator box to transform the layer so that it is in the 
position, angle and size you want it to be at the end of the animation. 
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A keyframe is created at the current frame as soon as you make the first transformation. 

 8. Move the timeline cursor back to the beginning of the panel. 

 9. In the Playback toolbar, click on the Play  button to preview the animation.

NOTE 

You can also use the Coordinate toolbar to enter values for the translation, scale and rotation 
values of a selected layer—see .

If you want to start over, you can instantly delete a layer's animation by disabling animation on it. 

How to clear all keyframes

 1. Select a layer that contains animation. This is indicated by the yellow Animate icon.

 2. Click the Animate  icon.

The following message appears when turning off the Animate mode.

 3. Click OK. 

All keyframes are cleared and the layer remains at the position of the current frame. The Animate 
icon on the layer turns grey to indicate that it does not contain animation.
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Moving the Pivot Point of a Drawing Layer
T-SBFND-009-009

The pivot point of a layer determines where is the axis around which a layer is rotated or on which the layer is 
scaled when you rotate or scale the layer with the Layer Transform tool.

By default, the pivot point of a layer is at the centre of the stage. You can reposition that pivot point to adjust 
the way your layer rotates or scales when animated. 

IMPORTANT 

Changing the pivot point of a layer affects the position of its pivot point throughout the entire 
panel. If your layer is already animated and you change the position of its pivot point, its position at 
the current frame will remain the same, but Storyboard Pro will have to adjust the position of the 
layer in other keyframes to work with the new position of the layer's pivot, which might negatively 
impact your animation. Hence, it is recommended to set the pivot point of your layer before 
animating it. 

How to set the pivot point of a layer

 1. In the Timeline view, select the panel on which you want to animate a layer.

 2. Do one of the following: 

 l From the Tools toolbar, click the Layer Transform  tool.

 l Select Tools > Layer Transform. 

 3. In the Stage view, select a layer to animate.

The selected layer’s transformation controls and pivot point become visible. The pivot point is 
represented by a blue circle at the centre of the camera frame.
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 4. In the Stage view, drag the pivot point to new location.

The new location of the pivot point will now be used as the reference when transforming layers.

How to set the pivot point at the centre of a selection

 1. In the Timeline view, select the panel containing the layer on which you want to set the pivot.

 2. From the Tools toolbar or the Tools menu, select the First Frame Transform  tool.

 3. In the Stage view, select the layer with the pivot you want to set at the centre.

 4. Do one of the following: 

 l In the First Frame Transform Tool Properties view, click the Center Pivot on Selection 
 button.

 l Select Layer > Pivot > Center Pivot on Selection. 

The pivot position is reset to the centre of the selection.

How to reset the pivot position

 1. In the Timeline view, select the panel containing the layer on which you want to reset the pivot.
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 2. From the Tools toolbar or the Tools menu, select the First Frame Transform  tool.

 3. In the Stage view, select the layer with the pivot to reset.

 4. Do one of the following: 

 l In the First Frame Transform Tool Properties view, click the Reset Pivot  button. 

 l Select Layer > Pivot > Reset Pivot.

The pivot position is reset to the centre of the camera frame.
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Adding Ease-In and Ease-Out to a Layer Animation
T-SBANIM-003-006

By default, when you animate a layer, it will move from its position in one keyframe to its position in the next 
keyframe  by progressing towards it at a constant pace, then stop moving abruptly. This rarely looks natural. To 
fine-tune the timing of an animation, you can add ease-in and ease-out to it. Adding ease-in to an animation 
will make it start slowly and gain in speed as it goes. Adding ease-out to an animation will make it slow down 
before it stops. 

You can set the ease-in and ease-out for an animation in the Tool Properties view. 

How to add ease-in and ease-out to a layer animation

 1. In the Tools toolbar, select the Layer Transform  tool.

 2. In the Layer panel of the Stage or Camera view, or in the Layers view, select the layer for which you 
want to add ease.
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The motion path for the selected layer's animation will appear in the Stage and Camera views.

 3. In the Timeline view, move the timeline cursor between the first and last keyframe of the layer 
animation to which you want to add ease.

 4. In the Tool Properties view, enter the desired length of the ease-in in the Ease In field in the 
H:MM:SS:FF format, where H means hours, MM means minutes, SS means seconds and FF means 
frames. The longer the length of the ease-in, the smoother it will be.

 5. Enter the desired length of the ease-out in the Ease Out field, in the same format. The longer the 
length of the ease-out, the smoother it will be.

As you make adjustments to the ease-in and ease-out of the animation, the notches in the motion 
path change place, giving you an idea of how the ease is affecting the timing.
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 6. To test your animation, move the timeline cursor to a point just before the start of the animation. 
Then, in the Playback toolbar, click on the Play  button.
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Copying and Pasting Keyframes
T-SBANIM-003-005

You can copy layer keyframes and paste them at a different time or on a different layer. It is possible to copy 
keyframes one at a time or in series. When copying several keyframes together, they will preserve their ease 
values, allowing you to copy motion and preserve its timing. 

How to copy and paste a Keyframe

 1. In the Timeline view, select a panel with an animated layer.

 2. In the Stage or Camera view select an animated layer.

 3. Select a layer keyframe from the Layer track.

The keyframe turns blue.

 4. Do one of the following:

 l Select Edit > Copy Layer Keyframes.

 l Press Ctrl + C (Windows/Linux) or ⌘  + C (macOS).

 5. Move the playhead to the position where you want to paste the keyframe. If you want to paste the 
keyframe on a different layer, be it in the same panel or in a different panel, select the destination 
layer in the Stage or Camera View.

 6. Do one of the following:

 l Select Edit > Paste Layer Keyframes.

 l Press Ctrl + V (Windows/Linux) or ⌘  + V (macOS).
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How to copy and paste several Keyframes

 1. In the Timeline view, select a panel with an animated layer.

 2. In the Stage or Camera view select a layer with several keyframes.

 3. Select the first keyframe in the series of keyframes to be copied.

 4. Hold Shift, then select the last keyframe in the series.

All the keyframes between the first and the last selected keyframes turn blue.

 5. Do one of the following:

 l Select Edit > Copy Layer Keyframes.

 l Press Ctrl + C (Windows/Linux) or ⌘  + C (macOS).

 6. Move the playhead to the position where you want to paste the keyframes. The first keyframe in the 
series will be pasted where the playhead is, and all subsequent keyframes will be pasted after this 
one.

NOTE 

If you try to paste an animation that would exceed the length of the panel, the 
keyframes that would end up beyond the end of the panel will be ignored.

 7. Do one of the following:

 l Select Edit > Paste Layer Keyframes.

 l Press Ctrl + V (Windows/Linux) or ⌘  + V (macOS).
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How to copy the end position from the start position

 1. In the Timeline view, select the panel that contains the start position to copy.

 2. Select Layer > Copy Start Layer Position to End.

How to copy the start position from the end position

 1. In the Timeline view, select the panel that contains the end position to copy.

 2. Select Layer > Copy End Layer Position to Start.
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Spreading the Layer Motion
T-SBANIM-003-004

Within the same shot, you can spread the current layer motion across all panels or a specified number of panels 
after the current panel.

A new layer will be added and the drawing will be duplicated for panels that do not have the same name in the 
defined range.

How to spread the motion from one panel to more than one panel

 1. In the Timeline view, select the layer with the motion you want to spread.

 2. Do one of the following:

‣ Select Layer > Spread Layer Motion.

‣ In the Layer toolbar, click the Spread Layer Motion  button. You may have to add this button 
to the Layer toolbar by customizing it.  
The Spread Layer Motion dialog box opens.

 3. Do one of the following:

 l To spread layer motion over all panels in the same shot, select the All panels in the 
same shot option.

 l To spread layer motion a specified number of panels after the current panel in the 
same shot, select Next panel(s) and enter or select the number of adjacent panels.
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About Animation Functions
T-SBANIM-003-006A

Using the Layer Transform tool, the Timeline view as well as the parameters in the Tool Properties view, you 
can control the position of each point in a layer, the position of each keyframe in time as well as  the ease-in and 
the ease-out of each movement. Layer animations are however composed of functions that can be customized 
in various other ways. If you need to tweak the animation of a layer in specific ways, you may have to use the 
Function Editor view. 

The Function Editor view displays all the functions which, internally, compose the movement of the selected 
layer or of the scene's camera. A function is simply a geometric (ie: position, size, angle) component of an 
animation. When you add a keyframe to a layer or to the camera, a keyframe is created for each animation 
function for that layer or camera, and that keyframe stores the value for that function at the current frame. 
Then, the value of the function for each frame between any two keyframes is calculated by Storyboard Pro. 

Animation Functions
A layer or camera animation is composed of the following functions:

 l Path X, Y and Z: The position of the object on the x, y and z axes, relative to the centre of the stage. The 
default value for these functions is 0.  

NOTE 

In 2D scenes, the Path Z function should always be 0, as it represents the distance of the 
layer relative to the camera. Changing the value of this function while in a 2D scene will 
convert the scene to a 3D scene.

 l Path Velo: This function is used to adjust the curve of the Path X, Y and Z functions between their 
keyframes. 

The Path Velo is automatically generated by Storyboard Pro and has one keyframe for each keyframe on 
the Path X, Y and Z functions. You cannot adjust the value of these keyframes, only the curve between 
the keyframes. When you do so, the curve between the keyframes of the Path Velo function is applied to 
the Path X, Y and Z functions. Basically, this allows you to adjust the ease of the object's movement on all 
three axes simultaneously, using a single function.

In summary, you can edit the Path X, Y and Z function to adjust the position of the object on different 
keyframes, and the Path Velo function to adjust the pace at which the object moves between keyframes.

NOTE 

The value of this function always progresses from 0 to 1. 
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 l Scale X, Y and Z: The size of the object on the x, y and z axes relative to its original size. The default 
value for these functions is 1. 

NOTE 

The Scale Z function only has a visible effect on 3D objects. 

 l Angle Z: The rotation angle of the object around the z-axis. 

 l Quaternion X, Y and Z: If you have rotated the object on any angle but the z-axis, a Quaternion (3D 
rotation) function is used to track and adjust its angle on each of the x, y and z axes. 

 l Quaternion Velo: Like the path function, the Quaternion function uses a Velo function to determine the 
ease of the rotation between keyframes. The values of the keyframes in the Quaternion Velo function 
cannot be adjusted, only the curve between its keyframes. This curve is applied to the Quaternion X, Y 
and Z functions, allowing you to adjust the ease of the object's rotation on all three axes simultaneously, 
using a single function.

Function types
The functions are of the following types:

 l Ease: An ease function determines how the interpolation between each keyframe is timed based on the 
length of the ease, in frames, before and after a keyframe. A function subjected to an ease-in will speed 
up for the length of the ease-in, then continue at constant pace until it reaches the next keyframe. A 
function subjected to an ease-out will start out progressing at a constant pace, then start slowing down 
when the ease-out begins. 

Path Velo and Quaternion Velo functions are ease functions. 

 l Bezier: A bezier function determines how the interpolation between each keyframe is timed based on 
Beziers that extend left and right of each keyframe, creating Bezier curves between keyframes. 

Scale functions as well as Angle Z functions are Bezier functions.
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 l Coordinate: The X, Y or Z component of a 3D Path or 3D Quaternion functions. These functions do not 
have Beziers nor ease. Their curve is determined by the Velo function to which they are associated 
(ie: Path Velo or Quaternion Velo).

For Path functions specifically, each keyframe can have a tension, continuity and bias setting which will 
influence on how the trajectory of the animation path is curved between each keyframe. 

Path X, Y and Z functions as well as Quaternion X, Y and Z functions are coordinate functions. However, 
only Path functions have tension, continuity and bias parameters.

Bezier Curves and Ease curves
Bezier curves and Ease curves are very similar at first glance. Their differences are mostly conceptual, 

The most noticeable difference between a Bezier and an ease function is that an ease function will cause a 
curve to occur only for the duration of an ease. So, with an ease function, the values between two keyframes 
can ease-in, then progress at a constant pace, then ease out. In contrast, in a Bezier function, the values 
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between two keyframes will either curve all throughout or, if the Bezier handles are in their neutral position, 
progress at a constant pace all throughout.
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Tweaking an Animation Path
T-SBANIM-003-007

Using the Function Editor view, you can fine-tune the animation of a layer or camera movement in very specific 
ways. 

How to view a layer or the camera's function curves

 1. In the Stage or Camera view, select a layer that contains animation. This is indicated by the yellow 
Animate  icon.

 2. From the Tools toolbar, click one of the following: 

 l Layer Transform  button for layer animation.

 l Camera  button for camera animation.

NOTE 

To switch between layer and camera functions, click the Show Camera Functions
button at the bottom of the Function Editor view. When the button is selected, camera 
functions are displayed in the graph, When deselected, layer functions are displayed.

 3. In the Tool Properties view, click  the Function Editor view  button.

The Function Editor view is blank until you select the layer containing the functions you want to 
display.

 4. In the list of functions, check the functions that you wish to edit, and uncheck the ones you want to 
leave unchanged so that they do not clutter the graph view to the right.

TIP 

You can change the colour of the function's representation in the graphic by double-clicking on 
the coloured square to the right of the function's name. This can help you identify the functions 
visually. 
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How to edit an Ease (Velocity) function

 1. In the function editor view, identify which functions are the Velocity (Velo) functions. If necessary, 
uncheck all other functions in the functions list so that only the velocity function you want to edit to 
appear. 

 2. If your functions appear too big, too small or cropped out of the view, adjust the graph view by doing 
one of the following:

 l Click on the Reset View  button to adjust the graph view to the size of the functions that 
are currently visible. 

 l Click on the Reset View Vertically  button if you only want the functions to fit within the 
view vertically. 

 l While holding Spacebar, click and drag on the graph to pan it.

 l Press 1 to zoom in on the graph or 1 to zoom out of the graph.

 3. Select one of the keyframes of one of the velocity function.

 4. In the top of the function view, right of the Frame and Value fields, expand the extra parameters 
section. If the arrow is pointing towards the right  , click on it so that it points to the bottom . 

The Left Angle , Left Ease Out , Right Angle  and Right Ease In  fields display at the 
right of the Frame and Value fields.

NOTE 

Since extra parameters depend on the type of keyframe selected, if keyframes from 
several different types of functions are selected at the same time, no extra parameters 
will be visible. To remedy this, discard the selection by clicking anywhere inside the 
function graph, then click on the keyframe you wish to select.

 5. In the Left Ease Out  field, type in the amount of frames the ease-out before this keyframe should 
last.

 6. In the Right Ease In  field, type in the amount of frames the ease-in after this keyframe should 
last.

 7. By default, the angles of each ease is horizontal. You can adjust the Left Angle and the Right Angle 
if you want the ease to be less abrupt or if you want to reverse the curve of the ease. To do this, do 
one of the following:       

 l Click on one of the points left and right of the selected keyframe and drag it along the circle 
to adjust the angle of the ease on that side of the keyframe.
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 l Type in the desired angles in the Left Angle  and Right Angle  fields.

How to edit a Coordinate function

 1. In the function editor view, identify which functions are the coordinate (Path X, Path Y and Path Z) 
functions. If necessary, uncheck all other functions in the functions list so that only they are visible.

 2. If your functions appear too big, too small or cropped out of the view, adjust the graph view by doing 
one of the following:

 l Click on the Reset View  button to adjust the graph view to the size of the functions that 
are currently visible. 

 l Click on the Reset View Vertically  button if you only want the functions to fit within the 
view vertically. 

 l While holding Spacebar, click and drag on the graph to pan it.

 l Press 1 to zoom in on the graph or 1 to zoom out of the graph.

 3. Select one of the keyframes of one of the coordinate functions.

 4. To adjust the value of the coordinate, click on the keyframe and drag it up or down, or type in a new 
value in the Value field at the top.

 5. To adjust the position of the keyframe in time, press and hold Alt, then click on the keyframe and 
drag it left or right. This will adjust the position of the keyframe in time for all corresponding 
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coordinate functions (X, Y, Z and Velo).

 6. In the top of the function view, right of the Frame and Value fields, expand the extra parameters 
section. If the arrow is pointing towards the right  , click on it so that it points to the bottom . 

The Tension , Continuity  and Bias  fields display at the right of the Frame and Value fields. 

NOTE 

Since extra parameters depend on the type of keyframe selected, if keyframes from 
several different types of functions are selected at the same time, no extra parameters 
will be visible. To remedy this, discard the selection by clicking anywhere inside the 
function graph, then click on the keyframe you wish to select.

 7. In the Tension  field, enter a value between -1 and 1. A positive tension will reduce the curve of 
the path between keyframes. A negative tension will increase it.

 8. In the Continuity field, enter a value between -1 and 1. A positive continuity will cause the path to 
curve beyond the trajectory between each keyframes. A negative continuity will have a reverse 
effect.

 9. In the Bias field, enter a value between -1 and 1. A high bias will make the curve more straight 
before the keyframe and more curved out after it. A negative bias will make the curve more curved 
out before the keyframe and more straight after it.
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NOTE 

Tension, Continuity and Bias settings are applied for all the functions in the same path 
(Path X, Path Y and Path Z) simultaneously. 

How to edit a Bezier function

 1. In the function editor view, identify which functions are the coordinate (Path X, Path Y and Path Z) 
functions. If necessary, uncheck all other functions in the functions list so that only they are visible.

 2. If your functions appear too big, too small or cropped out of the view, adjust the graph view by doing 
one of the following:

 l Click on the Reset View  button to adjust the graph view to the size of the functions that 
are currently visible. 

 l Click on the Reset View Vertically  button if you only want the functions to fit within the 
view vertically. 

 l While holding Spacebar, click and drag on the graph to pan it.

 l Press 1 to zoom in on the graph or 1 to zoom out of the graph.

 3. Select one of the keyframes of one of the coordinate functions.

 4. To adjust the value of the coordinate, click on the keyframe and drag it up or down, or type in a new 
value in the Value field at the top.

 5. To adjust the position of the keyframe in time, press and hold Alt, then click on the keyframe and 
drag it left or right. This will adjust the position of the keyframe in time for all corresponding 
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coordinate functions (X, Y, Z and Velo).

 6. Do one of the following to adjust the point's Bezier handles:

 l Locate the yellow arrows pointing towards the left and towards the right of the keyframe. By 
default, those arrows will be at the same position as the keyframe. You can click and drag on 
the left Bezier handle to adjust the curve at the left of the function, or on the right Bezier 
handle to adjust the curve at the right of the function. 

 l In the top of the function view, right of the Frame and Value fields, expand the extra 
parameters section. If the arrow is pointing towards the right  , click on it so that it points to 
the bottom . The Left Length , Left Angle , Right Length  and Right Angle 
fields will appear at the right of the Frame and Value fields. You can use these fields to adjust 
the angle and length of their respective Bezier handles relative to the keyframes. 

NOTE 

Since extra parameters depend on the type of keyframe selected, if keyframes 
from several different types of functions are selected at the same time, no extra 
parameters will be visible. To remedy this, discard the selection by clicking 
anywhere inside the function graph, then click on the keyframe you wish to 
select.
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Chapter 11: Camera
T-SBFND-009-003

In the Stage view, the camera is displayed as a frame that matches the aspect ratio of your chosen resolution.

You can enhance your animatics by adding camera movements to the scenes. You can restrict camera 
movements to one panel or spread it out across an entire scene/shot. An example of a camera movement would 
be if you wanted the camera to go from a wide shot and then zoom in to a close up.

Camera movements are created in much the same way as setting the Static Camera frame, but you will work 
with keyframes in the Timeline view to set the different camera positions over time. Once again you will use the 
Camera tool to animate the camera.
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NOTE 

This chapter covers mostly 2D camera movements. For information on how to position and animate 
the camera in a 3D scene, see Animating the 3D Camera  on page 593
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About the Stage and Camera Views
T-SBANIM-004-002

In Storyboard Pro, the Stage view is the default view in which to draw and manipulate objects . However, 
when working in 3D, it has one pitfall: When you pan, rotate, zoom into or zoom out of the stage view, you are 
changing the point of view from which you are looking at the stage. This means that the apparent position and 
size of elements may not be representative of what will appear in your storyboard or animatic. 

If you want to see a 3D scene exactly as it will look in your storyboard, you must use the Camera view. The 
Camera view always displays the stage from the point of view of the camera, even if you pan, rotate or zoom it. 
Therefore, you should always preview your scene from the Camera view if you make changes to the position of 
the Camera or of 3D objects, to make sure the composition of the scene is as expected.
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Positioning the Camera
T-SBANIM-004-003

You can move the camera’s position using the Camera  tool. 

You can also set up the Static Camera position using the Camera tool properties—see Camera Tool Properties 
in the Reference Guide.

How to position the Static Camera using the Camera tool

 1. In the Timeline view, select a panel within the scene in which you want to adjust the camera.

 2. In the Tools toolbar, select the Camera  tool.

The camera frame is displayed. It is represented by a black box. The default camera frame is set to 
12 fields.

 3. Do one of the following to modify the Static Camera:

‣ To position the selected panel along the Z-axis to create a truck in or truck out movement, drag 
the top-left corner of the camera frame up or down when you see the Truck  icon. To change 
the zoom level, change the Focal Length field in the Tool Properties view.

‣ To rotate the Static Camera on the X and Y axes, drag when you see the Rotation  icon. Hold 
the Shift key while rotating to restrict movement to the X or Y axis, depending on the axis on 
which you started dragging. 

‣ To rotate the Static Camera on the Z axis, position the cursor outside one of the corners of the 
camera frame. When you see the Rotation  icon, drag to rotate.

‣ To move the centre pivot point, position your the cursor over the centre point and when you see 
the drag  icon, drag to move in the X or Y axis. Hold down the Alt key when dragging the 
center point to move it on the Z axis. The farther you drag the mouse, the faster the camera 
moves. 
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Resetting the Camera
T-SBANIM-004-004

If necessary, you can remove all the keyframes in your scene, and revert back to the original Static Camera.

How to reset camera animation

 1. In the Timeline view, select the scene on which you want to reset the camera animation.

 2. Do one of the following:

‣ Select the Camera  tool, and in the Tool Properties view, click the Reset Camera  button.

‣ Select Camera > Reset Camera.

All camera keyframes for the selected scene are deleted and the scene’s Static Camera is reset.
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Copying and Pasting the Camera
T-SBFND-009-006

If you need to reuse a camera position, you can copy and paste it from one scene to another. It is not necessary 
to have the Camera tool selected to do this.

How to copy and paste the camera position

 1. In the Timeline view, select the scene that contains the Static Camera to copy.

 2. Select Camera > Copy Camera from Selected Panels.

 3. In the Timeline view, select the scene to which you want to paste the copied camera information.

 4. Select Camera > Paste and Fit Camera on Selected Panels.
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About Camera Movements
T-SBFND-009-004

Camera keyframes enable you to modify the position of your camera and have it change over time. The camera 
keyframes are coordinates indicating the position of your camera on a particular frame. In order to create any 
camera movements, you must set at least two camera keyframes. 

With Camera keyframes, you set the camera to go from one position in the frame to another, over a defined 
number of frames. You can also to control the velocity at which the camera attains its final position.

Keyframes appear as grey diamonds or half diamonds in the Timeline view. The space between keyframes in 
the Timeline view represents the number of frames it takes for the camera to move from one keyframe to the 
next, which determines the speed.

When a keyframe is selected in the Timeline view, it is displayed in blue. Camera keyframes are displayed in the 
Timeline view only, in a strip above the panel thumbnails. The first and last keyframes in a scene appear  as half 
diamonds, while any in between are displayed as full diamonds.

In the Timeline view, when the first keyframe of the panel is selected, the rectangle that defines the camera 
frame, along with a large X that quarters the camera frame, is highlighted in green. When the last keyframe is 
selected, these elements appear in red. If you have any keyframe between the first and last selected, then 
these elements will appear in blue.
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These are the default camera keyframe colours. You can use the Preferences dialog box to choose your own 
camera keyframe colours. When you do, the new colours will used in the Camera and Stage views, as well as in 
the different export formats of your storyboard.

If you want to create a truck in or truck out (a move along the Z-axis), you can use the manipulators in the Top or 
Side views, (you can also click on the upper-left corner of the frame in the Camera view). If you select the arrow 
pointing along the Z-axis and drag the manipulators from that arrow instead of from the centre point of the 
manipulator circle, your movements will be locked to that axis. This is useful if you do not want to accidentally 
displace the up and down or left and right position of your camera frame. 

Remember that the light-blue arrows in the Camera view do not necessarily indicate backward and forward 
movements. If your second camera frame appears larger or smaller than the initial camera frame position, then 
you can be sure that a camera truck in or truck out was made.
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Adding Keyframes
To create camera movement in a scene, you must start by creating at least two camera keyframes, then set the 
position of the camera in each of those keyframes. Storyboard Pro will interpolate the position of the camera on 
each frame between two keyframes.Below are four methods to add keyframes to the Timeline view.

How to add a camera keyframe at the current frame

 1. In the Timeline view, click and drag the timeline cursor to the frame at which you want to create a 
camera keyframe

 1. Select the Camera tool by doing one of the following: 

 l From the Tools toolbar, select the Camera  tool.

 l From the top menu, select Tools > Camera. 

 2. Create a camera keyframe by doing one of the following: 

 l In the Timeline view, in the left column of the Camera track, click on the Add Keyframe  
button. 

 l In the top menu, select Camera > Add Camera Keyframe at Current Frame.

 l In the Tool Properties view, click onthe Add Keyframe  button in the Camera Transform 
panel. 

A keyframe is added in the Camera track of the Timeline view, where the timeline cursor is. 

How to add a keyframe at the beginning of the current panel

 1. In the Timeline view, select the panel on which you want to add a keyframe.

 2. Do one of the following:

‣ In the Tools toolbar, click the Camera  tool.

‣ Select Tools > Camera.

 3. Do one of the following:

‣ Select Camera > Add Camera Keyframe at Beginning of panel.
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‣ In the Tool Properties view, click the Add Keyframe at Beginning of Current Panel  button.

In the Timeline view, a keyframe is added at the beginning of the selected panel.

How to add a keyframe at the end of the current panel

 1. In the Timeline view, select the panel on which you want to add a keyframe.

 2. Do one of the following:

‣ In the Tools toolbar, click the Camera  tool.

‣ Select Tools > Camera.

 1. Do one of the following:

‣ Select Camera > Add Camera Keyframe at End of panel.

‣ In the Tool Properties view, click the Add Keyframe at the End of Current Panel  button.

A keyframe is added in the Timeline view, at the end of the current panel.

How to use the Copy and Paste commands to add keyframes

 1. In the Timeline view, click to select a camera keyframe. 

The keyframe turns blue.

 2. In the Stage view, click the camera keyframe. 
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 3. Do one of the following:

‣ Select Edit > Copy Camera Keyframes.

‣ Press Ctrl + C (Windows) or ⌘  + C (Mac OS X).

‣ Select the Camera  tool. In the Tool Properties view click the Copy Camera from Selected 
Panels  button.
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 4. Move the playhead to the position within the same scene where you want to paste the keyframe.

 5. Do one of the following: 

‣ Select Edit > Paste Camera Keyframes.

‣ Press Ctrl + V (Windows) or ⌘  + V (Mac OS X).

‣ Select the Camera  tool, and in the Tool Properties view, click the Paste and Fit Camera on 
Selected Panels  button.

NOTE 

You can copy/paste several keyframes simultaneously if you selected multiple keyframes before 
performing the operation.
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Deleting Keyframes
When you no longer need keyframes, you can delete them from the Timeline view.

How to delete keyframes from the Timeline view

 1. Select the keyframe(s) to delete.

 2. Do one of the following:

‣ Select Edit > Delete Selected Camera Keyframes.

‣ Select the Camera  tool, and in the Tool Properties view, click the Delete Selected Keyframe
 button.

‣ Press Delete.

How to delete a keyframe at the current frame

 1. In the Timeline view, place the red playhead on the frame that contains the keyframe to delete.

 2. Select Camera > Remove Camera Keyframe at Current Frame.
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Animating Keyframes
T-SBFND-009-005

The position of the camera keyframes is set in much the same way as the Static Camera, using the Camera tool 
in the Stage view. You must do this for every keyframe you created, so the camera moves from one keyframe to 
the next when played back.

NOTE 

This section shows you how to set up a 2D Camera movement. When using the Camera in 3D 
space, new manipulators become available—see About 3D Objects on page 548 to learn more 
about 3D camera moves and framing your 3D scene.

NOTE 

When manipulating the Camera, you can enable the Camera Label  option in the Stage view 
status bar to display a letter in the corner of each camera frame, indicating their order in the camera 
movement. 

How to position camera keyframes in a 2D scene

 1. Select the Camera tool by doing one of the following: 

 l From the Tools toolbar, select the Camera  tool.

 l From the top menu, select Tools > Camera. 

 2. Do one of the following:

 l In the Camera track of the Timeline view, select the camera keyframe you want to modify. 

 l In the Stage or Camera view, zoom out to see all of the camera frames. Then, select the 
camera frame you want to modify by clicking on its edge or its centre point.
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TIP 

Even if your camera frames are in the same position, you can still select a specific one in 
the Stage or Camera view. Just below the bottom-left corner of the camera frames, you 
will find blue square-shaped dots. Each of these dots can be clicked on to select a 
specific camera frame. If two or more camera keyframes are in the same position, the 
order of these dots will represent their relative position on the timeline. The leftmost dot 
can be used to select the first camera keyframe, the second leftmost dot can be used to 
select the second camera keyframe, etc.

 3. Use one of the following methods to modify the camera frame:

 l Move: Move the mouse cursor over the edge or the centre point of the camera frame until the 
mouse cursor becomes  , then click and drag the camera frame to move it. 

 l Truck In or Truck Out: Move the mouse cursor over the point in the top-left corner of the 
camera frame until the mouse cursor becomes  , then click and drag this corner to shrink or 
stretch the camera frame. Shrinking the camera frame will make it zoom in, and stretching it 
will make it zoom out. 

514



 l Rotate: Move the mouse cursor just outside of one of the corners of the camera frame until the 
mouse cursor becomes  , then click and drag the corner in either direction to rotate the 
camera frame clockwise or counterclockwise. 

TIP 

You can also nudge the camera frame by using the arrow keys on your keyboard, or 
enter its exact coordinates in the Tool Properties view. 
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Timing Keyframes
T-SBANIM-004-008

If you need to change the frame or timing of a keyframe in the Timeline view, there are a few different ways to 
do this. Note that camera keyframes can only be moved to a new location within the same scene. 

The following two methods are useful when you want to move a keyframe to a new location, or cut and paste a 
keyframe.

How to drag camera keyframes to a new location in the Timeline view

 1. In the Timeline view, select one or more keyframes. 

The keyframe turns blue.

 2. Drag the selected keyframe left or right to choose a new position in time. You can only drag it to a 
new location within the current scene.

While you drag the keyframe, its position relative to the scene is displayed in a black box. The 
number of frames is also displayed from the original position the new keyframe will be located.

How to using the Cut and Paste commands to move keyframes

 1. In the Timeline view, select one or more keyframes. 

The keyframe turns blue.

 2. Select Edit > Cut Camera Keyframes or press Ctrl + X (Windows) or ⌘  + X (Mac OS X). 

The keyframe is removed and copied to the Clipboard.
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 3. Within the same scene, move the red playhead to the position on which you want to paste the 
keyframe.

 4. Select Edit > Paste Camera Keyframes or press Ctrl + V (Windows) or ⌘  + V (Mac OS X)).
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Spreading Camera Motions Across Panels
T-SBFND-009-007

A camera movement is not restricted to a panel. Keyframes for a particular camera movement can span multiple 
panels within the same scene.

How to spread a camera movement across multiple panels of a scene

 1. In the Timeline view, select the panel that contains the camera movement you want to span over 
multiple panels.

 2. Select the keyframe you want to move to a new panel.

 3. Drag the selected keyframe to another panel within the scene.
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Adding Ease-In and Ease-Out to a Camera Animation
By default, when you create camera movements, the camera will move from its position in one keyframe to its 
position in the next keyframe  by progressing towards it at a constant pace, then stop moving abruptly. If you 
want it to gain speed as it start moving or to slow down before it stops, you can do this by adding ease-in and 
ease-out to its animation. Adding ease-in to an animation will make it start slowly and gain in speed as it goes. 
Adding ease-out to an animation will make it slow down before it stops. 

You can set the ease-in and ease-out for an animation in the Tool Properties view. 

How to add ease-in and ease-out to a camera animation

 1. In the Tools toolbar, select the Camera  tool.

 2. In the Timeline view, move the timeline cursor between the first and last keyframe of the camera 
animation to which you want to add ease.
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 3. In the Tool Properties view, enter the desired length of the ease-in in the Ease In field in the 
H:MM:SS:FF format, where H means hours, MM means minutes, SS means seconds and FF means 
frames. The longer the length of the ease-in, the smoother it will be.

 4. Enter the desired length of the ease-out in the Ease Out field, in the same format. The longer the 
length of the ease-out, the smoother it will be.

 5. To test your camera animation, move the timeline cursor to a point just before the start of the 
camera movement. Then, in the Playback toolbar, click on the Play  button.
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Snapping Keyframes to Sound Clips
T-SBANIM-004-007

When snapping is enabled, camera keyframes will snap to sound clips and to the timeline cursor as you click 
and drag them. 

How to enable or disable snapping

 1. Do one of the following:

 l At the bottom-left of the Timeline view, click on the Snapping  button. 

 l Right-click the Timeline view and select Snapping.

NOTE 

While dragging a clip, you can temporarily override whether snapping is enabled by holding 
the Shift key.
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Syncing Keyframes
T-SBANIM-004-006

By default, when you change the duration of a panel, the position of camera keyframes within that panel is 
adjusted to fit the new length of the panel. This behavior can be adjusted depending on your preference. 

The Keyframes Sync Mode has three options:

 l None: When adjusting the length of a panel or a scene, the camera keyframes remain at their actual 
frames. This means that if you make a scene shorter than its camera movements, some of its last camera 
keyframes will get clipped out.

 l Relative to Panels: The default option. When adjusting the length of a panel, the position of camera 
keyframes within this panel will be adjusted to fit the new length of the panel. If camera keyframes are 
outside of that panel but inside the same scene, their distance relative to each other will not be affected. 

 l Relative to Scene: When adjusting the length of the panel, the position of all camera keyframes within 
the scene in which that panel is will be adjusted to fit the new length of the scene. This could cause some 
camera keyframes to end up in a different panel than the one where they originally were. However, 
since camera movements occur at the level of the scene, not the panel, this option may give preferable 
results in some situations.

How to change keyframe syncing settings

 1. Do one of the following:

 l Select Camera > Keyframe Sync Mode > None, Relative to PanelorRelative to Scene.

 l In the Timeline view, right-click on the Camera track and select Keyframes Sync Mode > 
None, Relative to Panel or Relative to Scene.
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About the Camera Path
You can adjust the Tension, Bias, and Continuity parameters on keyframes and control points by selecting the 
point in the Timeline view and using the Keyframes and Control Points toolbar.

• Continuity controls the smoothness of a transition between the segments joined by a point.
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• Tension controls how sharply the path bends as it passes through a control point or keyframe.

• Bias controls the slope of the path so that it flows towards one side of the motion point or the other.
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Adding Control Points
You can change the camera path from one keyframe to the next by adding control points to the trajectory.

How to add control points to a trajectory

 1. In the Timeline view, select the scene on which you want to modify the camera trajectory.

 2. From the Tools toolbar or the Tools menu, select the Camera  tool.

 3. In the Stage view, place the cursor over the trajectory between two keyframes.

 4. When you see this icon , click and drag the trajectory to reshape it. 

 5. A control point is added when you let go of the mouse button.
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Now, instead of the camera going from A to B in a linear fashion, there is a slight curve to the 
trajectory.

 6. Click the control point to move it and to reshape the trajectory if desired. You can also select the 
control point in the Stage view, Top view or Side view and click Del. You do not have to go to the 
Timeline.
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Deleting Control Points
Control points are visible in the Timeline, but you can only move them in the Stage view. To delete a control 
point, you must go to the Timeline. A control pointed is represented by a small dot between keyframes.

 How to delete a control point

 1. In the Timeline view, select the control point which represented by a small dot between keyframes. 

The control point turns blue.

 2. Press Delete to remove the selected point.

The trajectory reverts to its original shape.
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Adjusting the Curve of a Camera Movement
When you animate a camera movement with more than two keyframes, the path of the camera follows a curve 
that touches every keyframe in its animation. Using the Keyframes and Control Point toolbar, you can adjust 
how the path curves before and after each keyframe in the camera's trajectory. 

When a camera keyframe is selected, the Keyframes and Control Point toolbar gives you access to three 
settings that can be applied to that keyframe. Each setting can have a value ranging from -1 to 1. When all 
fields are set to their default value, 0, the curve is constant and even. Here is an example opf how each setting 
can affect the camera path:

 l T (Tension): A positive tension will reduce the curve of the path between keyframes. A negative tension 
will increase it.

 l C (Continuity): A positive continuity will cause the path to curve beyond the trajectory between each 
keyframes. A negative continuity will have a reverse effect.

 l B (Bias): A high bias will make the curve more straight before the keyframe and more curved out after it. 
A negative bias will make the curve more curved out before the keyframe and more straight after it.

How to adjust the Continuity, Tension and Bias parameters of a keyframe or control 
point

 1. Add the Keyframes and Control Points toolbar to your workspace by doing one of the following:

 l In the top menu, select Windows > Toolbars > Keyframes and Control Points.

 l Right-click on a toolbar or on the empty space around a toolbar and select Keyframes and 
Control Points.
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The Keyframes and Control Points toolbar appears

 2. In the Tools toolbar, select the Camera  tool.

 3. In the Timeline view, select the keyframe or control point you want to adjust.

 4. In the Keyframes and Control Points toolbar, enter values between -1 and 1 in the Continuity, 
Tension, and Bias fields until the path before and after the selected keyframe is the way you want it 
to be.

How to set defaults for the Continuity, Tension and Bias parameters for keyframes and 
control points

 1. Select Edit > Preferences (Windows) or Storyboard Pro > Preferences (macOS).

The Preferences dialog box opens.

 2. Select the Camera tab.

 3. In the Keyframes and Controls Points section, enter the defaults for Tension, Continuity and Bias, 
based on your preferred settings.
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Pinning Layer to Camera
You can make a layer follow the movement of the camera, so that it always appears in the same area of the 
camera field no matter the position of the camera.

NOTE 

If you are working on a 3D scene, see Aligning 2D Layers with a 3D Camera on page 596.

How to pin a drawing layer to the camera

 1. Add the Layers view to your workspace by doing one of the following:

 l In the top-right corner of any view, click on the Add View  button and select Layers.

 l In the top menu, select Windows > Layers.

 2. In the Layers view, select the layer you want to pin to the camera.

 3. In the Layer Alignment options, click on the Pin Layer to Camera  button.

NOTE 

To unpin the layer from the camera, select No alignment . The other option, Face Camera 
, is for 3D scenes—see Aligning 2D Layers with a 3D Camera on page 596.
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Storyboard Pro has an extensive set of 3D functionalities:

 l You can move drawing layers are different distances from the camera's point of view. 

 l You can rotate drawing layers on any axis.

 l You can import 3D models into your scene and place them into your panels at any position, size and 
angle.

 l You can animate the position, size and angle of 3D models.

 l You can adjust the position, size and angle of sub-objects in your 3D model.

 l You can separate a sub-object from its 3D model and animate it independently. 

Whether 3D functionalities are enabled depends on whether or not the current scene is in 2D mode or 
3D mode. By default, scenes created in your project are in 2D Mode. 2D Mode disables 3D functionalities to 
avoid letting them clutter your workflow, since storyboards are often strictly 2D projects. However, you can 
enable 3D on a scene instantly and at any time, without it having any negative impact on the scene. 3D 
functionalities cannot be enabled for a single panel, or for the whole project at a time.
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About Staging in 3D Space
Storyboard Pro adds a new dimension to the layout process by allowing you to plan your 2D scenes in a 3D 
space. The 3D space is described in terms of three planes:

• EW: Maps the horizontal plane in terms of East and West, this is the X coordinate.

• NS: Maps the vertical plane in terms of North and South, this is the Y coordinate.

• FB: Maps the depth of the plane in terms of Front and Back, this is the Z coordinate. 

When you add elements to a scene, they appear in layers in the initial position of zero fields NS, zero fields EW, 
and zero fields FB within the 3D scene space. Before the 3D space feature, you could only change the layer 
position—see .

But in 3D space, you can use the EW (X), NS (Y), and FB (Z) coordinates to place your elements at different 
distances in depth from the camera and from each other, adding a three-dimensional effect to your two-
dimensional animation.

Once you place the elements in your scene, you can move, rotate, or scale your elements in 3D space. 
Storyboard Pro automatically applies the changes to all of the contents in the element.

Where previously 2D objects could only be moved, rotated and animated on a 2D plane, now they too can be 
manipulated in 3D space. This means that flat, 2D objects can move forward or backward along the Z-axis, 
growing realistically bigger or smaller as they move towards or away from the camera. Features, such as 
Always Face Camera, mask the paper thin edges of 2D objects for camera rotations around these objects.
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Converting the Current Scene to 3D
When you create a scene, it is in 2D mode by default. This means layers are locked at the same position on the 
z-axis and can only be rotated on the z-axis. This is to avoid incumbering your workflow with 3D functionalities 
that are not needed. 

You can easily convert a 2D scene to 3D, and back and forth. In a 3D scene, you can move layers on the z-axis 
and rotate them in any direction. You can also rotate the camera in any direction and make it move across the 
depth of the stage. Likewise, you can rotate the Stage view in any angle and navigate the stage in its depth, 
allowing you to look at it from various points of view. 

NOTE 

You can convert a scene to 3D, but not a single panel. When switching to 3D mode, the mode is 
only applied to the current scene, not the entire project. 

How to enable the 3D option 

 1. In the Thumbnails or Timeline view, select the scene you want to convert to 3D.

 2. Do one of the following:

 l In the Storyboard toolbar, click the Enable 3D  button.

 l Select Storyboard > Enable 3D for Current Scene.
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Resetting the Current Scene to 2D
You can reset a 3D scene back to 2D. When you do this, the following changes are made to your scene:

 l Imported 3D models are removed.

 l 3D camera movements are converted to 2D camera movements. Camera movements on the z-axis will 
be converted to 2D camera zoom-ins and zoom-outs, but 3D rotations will be ignored.

 l 3D transformations on layers are converted to 2D transformations. Layers that have been moved on the 
z-axis will be scaled up or down to preserve their apparent proportions, but 3D rotations will be ignored.

How to reset a scene to 2D

 1. Do one of the following:

 l In the Storyboard toolbar, click the Reset Scene to 2D  button.

 l Select Storyboard > Reset Scene to 2D.
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Viewing Objects from the Top and Side
When working in 3D, you can use the Stage view to look at your stage from any point of view and any angle, 
allowing you to see how objects are positioned in space, and you can use the Camera view to look at your stage 
from the point of view of the camera. However, you may often need to have precise control over how objects 
and layers are positioned on the z-axis. 

The Top and Side views allow you to view the stage from its top and from its side, respectively. Because these 
views do not apply perspective to the stage, they can be used to position elements with more precision. Using 
the Side view, you can view and position layers and objects on the front-back (z) axis , as well as on the north-
south (y) axis. Using the Top view, you can view and position layers and objects on the front-back (z) as well as 
the east-west (x) axis. Hence, both views combined can help you position objects on the z-axis without losing 
sight of their position on the other axes.

The Top and Side views display 2D layers as thin segments, as if you were looking at sheets of paper from the 
side. You can manually select and manipulate 2D layers right from these views.
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Positioning 2D Objects in 3D Space
In a 3D scene, drawing layers can be manipulated like 3D objects. You can position them closer to or further 
away from the camera, allowing you to create a multiplane effect. You can also rotate them in any direction, 
allowing you to make pseudo-3D constructions such as open-faced rooms.. 

How to position 2D objects in 3D space

 1. In the Stage or Camera view, select a layer with a 2D object.

 2. From the Tools toolbar, click the Layer Transform  button. 

Manipulators appear over the object layer’s pivot point.

 3. Use the manipulators to manipulate your image in the following ways:

‣ To squash and stretch your image vertically: Pull the green, square points located at the top 
and bottom of the manipulator circle.
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‣ To squash and stretch the image horizontally: Pull the red, square points located on the right 
and left sides of the manipulator circle.

‣ To scale the image proportionally: Hover anywhere over the box outside the manipulator circle 
until the cursor turns into a white, double-headed arrow. Pull in any direction to scale the image 
up or down.

‣ To move the image vertically: Click the green, vertical arrow and pull it up or down.
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‣ To move the image horizontally: Click the red, horizontal arrow and pull it left or right.

‣ To move the image backwards or forwards along the Z-axis: Go to either the Top or Side views 
and use the blue arrow to pull the layer closer or farther from the static camera cone.
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‣ To rotate the image on the X-axis: Hover over the vertical line (actually a ring) bisecting the 

manipulator circle. The rotate X-axis cursor  appears. Pull up or down to rotate your object 
along this axis.

‣ To rotate the image on the Y-axis: Hover over the horizontal line (actually a ring) bisecting the 

manipulator circle. The rotate Y-axis cursor  appears. Pull towards the left or right to rotate 
your object along this axis.
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‣ To rotate the image on the Z-axis: hover anywhere over the manipulator ring. The rotate Z-axis 
cursor appears. Pull clockwise or counter clockwise to rotate the object.

You can perform any of these manipulations in combination. For example, after have rotated your 2D 
object 45 degrees around the Y-axis, you can reposition it along the Z-axis.
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Moving Layers in the 3D Space and Maintaining their Size
T-SBADV-011-015

When positioning elements, you can retain the visual scale of elements as you move them in the Z-axis in the 
Side or Top views. As you move drawing layers on the Z-axis, they are scaled to preserve their size in the 
camera.

How to position an element in the Top and Side views

 1. From the Tool toolbar, select the Maintain Size  tool.

 2. In the Side or Top view, select a layer.

The selected layer is highlighted in pink.

 3. Drag the layer to the correct depth position in the camera cone. 

Your element aspect remains the same in the Camera view.

 4. To scale the element up or down in relation to its distance to the camera, select the Layer Transform 
 tool from the Tools toolbar.

 5. In the Tool Properties view, make sure the Peg Selection Mode  option is deselected.

The selected layer is highlighted in the camera cone.

 6. In the Top  view, drag the element sideways to position it horizontally. Hold Shift while dragging to 
make sure it only moves along the X-axis.
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 7. In the Side view, drag the selected element up or down to position it vertically. Hold Shift while 
dragging to make sure it only moves along the Y-axis.
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Drawing on 2D Layers in a 3D Space
Flat 2D objects integrated into your 3D scene may sometimes need to be edited, even after the camera has 
been repositioned or rotated in 3D space. An edit usually requires redrawing and recolouring part of the object. 
However, after making several rotations or a movement in 3D space, the Stage view and the drawing layer of 
the 2D object might no longer be parallel to one another. If this happens, you cannot draw on that layer. To 
make your edits, you must use the Look At Selected feature.

How to use the Look at Selected feature

 1. Select a layer by doing one of the following: 

‣ Stage View: In the Layers section select a layer.

‣ Stage View: Use the Layer Transform  tool to select a layer.

‣ Thumbnails View: Click the scene's layer tab.

 2. In the Stage view status bar, click the Look At Selected button.

The Drawing object layer is perpendicular to the Stage view, ready for drawing edits.

NOTE 

You can use rotate the light table by pressing:  Ctrl + Alt (Windows) or ⌘  + Alt (Mac OS X).
You can rotate the Stage view by pressing V or C (Windows) or  Shift + ⌘   (macOS).
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Navigating the 3D Space
When working in the Stage view, you can quickly navigate through a scene using the mouse buttons or 
3D navigation tools.

By using your left, middle, and right mouse buttons, you can rotate around in the Stage view, dolly on the Z 
axis, and pan the X and Y axes. If you only have access to the left mouse button, such as when using a pen and 
tablet, you can still navigate easily in 3D space.

To increase efficiency while working with the tools in Storyboard Pro, you can temporarily swap one tool for 
another—see About Quick Swap Shortcut on page 394.

How to navigate 3D space using only the left mouse button

 1. In the Stage view, do any of the following:

 l Press Shift + Ctrl and left-click to rotate.

 l Press Spacebar and left-click to pan.

 l Press Spacebar+Alt and left-click to zoom out.

 l Press Spacebar+Ctrl and left-click to zoom in.

How to navigate 3D space using the three mouse buttons

 1. In the Stage view, hold down Shift + Ctrl and do any of the following:

 l Left Mouse Button: Hold down the left mouse button and drag to rotate the view.

 l Middle Mouse Button: Hold down the middle mouse button and drag to pan along the X and Y 
axes.

 l Right Mouse Button: Hold down the right mouse button and drag to dolly on the Z-axis.

 l Scroll Wheel: Roll the scroll wheel to dolly on the Z-axis.

How to navigate 3D space with the 3D Navigation tool

 1. From the Tools toolbar, click the 3D Navigation  tool.

 2. Do any of the following:

 l Hold down the left mouse and drag to rotate the scene.

 l Hold down the middle mouse and drag to pan the scene.

545

Storyboard Pro 6. User Guide                          



Chapter 12: 3D

 l Hold down the middle mouse button while pressing Spacebar and drag to dolly in the Z axis.

 l Roll the scroll wheel to dolly on the Z-axis.

You can get a first person perspective while navigating with the 3D Flying Navigation tool. By using your 
mouse buttons, mouse wheel, and arrow keys, you can move through 3D space interactively. 

When the 3D Flying Navigation tool is active, the cursor (hand) is not visible. You can now navigate through a 
scene. When you move the mouse, the view rotates around the current view point (instead of around a fixed 
pivot).

You can move around in the scene by using the following:

• The mouse wheel controls the Z axis.

• The Up/Down keys control the Z axis.

• The Left/Right keys control the X axis.

• The Pg Up/Pg Dn keys the Y axis.

You can deactivate the tool by clicking anywhere on the interface. 

NOTE 

When using the 3D Flying Navigation tool with a tablet, the cursor remains visible.

How to navigate with the 3D Flying Navigation tool

 1. In the Tools toolbar, select the 3D Flying Navigation  tool.

 2. To activate the tool, click on the Stage view.

The hand cursor disappears.

 l Move mouse to rotate the scene.

 l Roll the mouse wheel to move forwards or backwards. The more you roll the mouse wheel, 
the faster you navigate through the scene.

 l Press the arrow keys and PgUp/PgDn keys to move in all six directions. Press repeatedly to 
increase or decrease speed.

 3. To stop all motion, click anywhere on the interface.

The hand cursor reappears.
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About 3D Objects
T-SBADV-011-001

Storyboard Pro allows you to use 3D models in your storyboard. If your project uses 3D, you can import the 
background and character models that were designed for the animation of your project into your storyboard. 
By doing this, you will not only save time by not having to draw your characters and backgrounds in every 
panel, but you can also ensure that they are represented accurately and consistently in the storyboard. 

You can integrate 3D models to your project by importing them to your library, then dragging and dropping 
them into your panels where needed. Each Storyboard Pro project has its own 3D Models library. Since each 
instance of the model is sourced from your project's library, Storyboard Pro does not have to store a copy of 
your model for each panel that uses it. 

Storyboard Pro supports the following types of 3D models:

 l Filmbox (.fbx)

 l 3DS Max (.3ds)

 l Wavefront OBJ (.obj)

 l Allembic (.abc)

 l Collada (.dae)

NOTE 

It is recommended to use the Filmbox (.fbx) format, as it can be packaged with textures embedded 
in the model. 

There are two ways to integrate a 3D model into a scene. You can add a 3D model to a 3D scene, in which case 
it will remain a 3D object and be fully manipulable and animatable, or you can render it into a 2D scene. When 
you do that, the 3D model is rasterized into a flat drawing layer. The layer itself can be animated, but the model 
remains static throughout the panel. 
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Importing 3D Objects to your Project Library
T-SBADV-011-004

Before adding 3D objects to panels in your storyboard, you must first import them to your library.  When you 
import a 3D model, it is automatically added to the 3D Models library of your project, in the Library view. You 
can then drag and drop that 3D model to each panel in which you want to use it, without having to import it 
over and over again. 

Storyboard Pro supports the following types of 3D models:

 l Filmbox (.fbx)

 l 3DS Max (.3ds)

 l Wavefront OBJ (.obj)

 l Allembic (.abc)

 l Collada (.dae)

In addition to importing 3D objects into the 3D Models folder in the Library view, you can also open a folder 
containing 3D models as a library in the Library view. The models can then be dragged and dropped into the 
scene directly from that library. 

NOTE 

When a model is added to a panel from a library other than the 3D Models library, it is also added 
to the 3D Models library at the same time. 

How to import a 3D object into your project

 1. In the Library view, right-click on the 3D Models library folder, then select Import Files. 

 2. In the file browser, locate and select your 3D model, then click on Open.

The following prompt appears.

If you want, you can choose to import your model in its original format. Converting it to FBX will 
however make sure its textures are consolidated with the model in your project. 

 3. Click on OK.

The selected model appears in the 3D Models folder of the Library view. 
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NOTE 

If you delete a 3D model from the library, every instance of that model in the project will be 
deleted.

How to add a folder containing 3D models as a Library

 1. In the Library view, right-click in the list of libraries and select Open Library.

A file browser window opens. 

 2. In the file browser, browse for the folder that contains the 3D models that you want to use in your 
project. Those files should be .fbx, .abc, .osb, .3ds, or .obj files.

 3. Click on Select Folder.

The selected folder will appear in the list of libraries. 

 4. Select the folder you just added to the list of libraries.

Any files that can be imported into Storyboard Pro, including 3D models, templates and drawings 
that are located within this folder are listed in the list of items to the right.
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About Adding 3D Models to 3D Scenes
If you add a 3D model to a 3D scene, it is added as a 3D object. It can be transformed and animated in a 3D 
stage, rotated in any direction and scaled on any axis. You can also reposition the model's sub-objects, and 
even separate them so as to be able to animate them separately.

A 3D model in a 3D scene is linked to the model in your 3D Models library. This means that you can replace the 
model in your library, and by doing so, replace it in every panel in which the model was added. 

If you import a 3D model to a 2D scene, you can choose to either render it as a 2D layer or to convert the scene 
to 3D so it can be added as a 3D object. In the latter case, the camera as well every layer in your scene will be 
subject to 3D transformations and animations, not just the 3D model. Although a 3D scene is more flexible, 
having 3D controls over every element in your scene just because you have a single 3D element in it may be 
burdening. If you prefer, you can render your 3D model into a flat drawing layer. This will not give it the 
flexibility of a 3D object, but will preserve the 2D property of your scene and keep your workflow simple—see 
About Adding 3D Models to 2D Scenes.

You can also convert a scene to a 3D scene without importing a 3D model in it, allowing you to make 3D 
transformations on its drawing layers—see About Staging in 3D Space.
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About the Scale Factor of 3D Objects
T-SBADV-011-003

When importing a 3D object created in a 3D modeling application, such as Maya, Cinema4D, Blender or others,  
the 3D object can appear much larger or smaller than intended inStoryboard Pro. Therefore, you may have to 
scale it up or down for it to be in the right proportions. This is because 3D modeling applications use different 
base units than Storyboard Pro. For example, Autodesk Maya works in centimetres, and Blender works 
in metres, whereas Storyboard Pro works in fields. 

Instead of scaling your 3D model manually in each panel where you use it, you can add a scaling factor to your 
3D model as it is in your library, before you import it. From thereon, it will already be scaled according to that 
scaling factor whenever you import that model to one of your project's panels, and you won't have to scale it 
manually every time. 

At any time, you can change the scaling factor of your 3D model again. However, changing the scaling factor of 
a 3D model will cause its size to change in every panel in which it was already imported. Hence, it is important 
to make sure your scale factor is optimal before you start adding your 3D model to several panels. If you only 
need to adjust the size of your 3D model in a few panels, and not all the panels in which it appears, it might be 
better to adjust its size manually using the Layer Transform tool instead, as the Layer Transform tool will only 
affect its size in the current panel. 

The scale factor of a 3D model is retained if you create a template with your 3D model. Likewise, it is retained if 
you export your storyboard into Harmony scenes. 
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NOTE 

When you apply a scaling factor to your 3D model, it affects its apparent size in your storyboard, 
but it does not affect the model's scale value in your panels. This means that, when you add a 3D 
model with a scaling factor to one of your panels, although your model already appears scaled up or 
down, its scale is actually still 1, which is the default value. This way, you can differentiate the 
scaling that was manually applied to your model using the Layer Transform tool from the scaling 
applied to your model because of its scaling factor. 
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Setting the Scale Factor for a 3D Model
If you have imported a 3D model into your panels, and you find that its default size is too big or too small for 
your project's purposes, you can adjust its scale factor. The 3D Model's scale factor will affect its size in every 
panel in which it appears in the project.

NOTE 

A 3D model's scale factor should be used to set the default size of a 3D model. If you change your 
3D model's scale factor after it has been inserted into some of your project's panels, its size will be 
affected in every panel in which it appears, even if the size of the model was manually adjusted or 
animated in some of your project's panels. If you only want to adjust the size of a 3D model in a 
single panel, use the Layer Transform tool instead—see Positioning, Rotating and Scaling 3D 
Objects on page 560. 

How to set the scale factor of a 3D model

 1. In the Library view, select the 3D Models library.

 2. Select the 3D model for which you want to set the scale factor.  If you have not imported your 3D 
object to the 3D models library yet, see Importing 3D Objects to your Project Library on page 549.

 3. So that you can see the effects of the scale factor on your 3D model, add the 3D model to the current 
panel by dragging and dropping it to the Stage or Camera view. If the model is already in the 
current panel and has not been scaled up or down, skip this step. You can delete the model from 
your panel once you're done setting the scaling factor, if it is not needed in this panel. 

 4. Right-click on the 3D model and select Set Scale Factor.

The Model Properties dialog appears. 

By default, the model's scale factor is set to 1.000 (or 1), which means the model is neither scaled 
up or down.

 5. Do one of the following:

 l If you want the model to appear smaller, enter a value between 0 and 1. For example, to 
make the model half of its original dimensions, enter 0.5. 

 l If you want the model to appear bigger, enter a value above 1. For example, to make the 
model twice its original dimensions, enter 2. 

 6. Click on the OK button.
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The model's new scale factor is applied to all its instances in the project. If the model is currently 
visible in the Stage or Camera view, its size will update to match the new scale factor. 
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Determining the Scale Factor for a 3D model
T-SBADV-011-002

Before importing a 3D object, you must consider the scale factor to use. You can calculate the appropriate scale 
factor for a 3D model by comparing the measuring units used by Storyboard Pro to the ones used by your 3D 
modeling software. 

This can be done by importing a cube that is 1 unit in size, cubed, in your 3D modeling software, into 
Storyboard Pro. Then, you can adjust this cube's scale factor until it matches a unit in Storyboard Pro. 

To be able to match the size of the cube against a unit in Storyboard Pro, you can enable the World Grid, which 
is a lot like a standard 12 fields grid, except its fields are square-shaped, whereas units in Storyboard Pro are 
typically shorter vertically than horizontally, to match the 4:3 aspect ratio of legacy standard displays. 

How to determine the right scale factor for your 3D models

 1. In your 3D modeling software, create a cube that is 1 cubed unit in size (a cube that is 1 unit in 
width, 1 unit in height and 1 unit in depth).

 2. Export the model from into one of the formats supported by Storyboard Pro:

 l Filmbox (.fbx)

 l 3DS Max (.3ds)

 l Wavefront OBJ (.obj)

 l Allembic (.abc)

 l Collada (.dae)

 3. In the Library view of Storyboard Pro, select the 3D Models library. 

 4. Right-click in the 3D models list and select Import Files.

 5. In the file browser, locate and select the 3D model containing the cube.

 6. In the Library view, right-click on the imported model and select Set Scale Factor.

The Model Properties dialog appears.

 7. In the Scale Factor field, verify that the model's scaling factor is set to 1.0.

 8. Click on OK.

 9. Drag and drop the model into the Stage view. 
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The cube appears in the centre of the stage.

 10. In the top menu, select View > Grid > Show Grid or press Ctrl + G (Windows) or ⌘  + G (Mac OS X).

The default grid (the 12 Field Grid) displays over the 3D model in the Stage view. 

 11. In the top menu, select View > Grid > World Grid. 

The 12 Field Grid is replaced by the World Grid in the Stage and Camera views. 

 12. In the Layer panel of the Stage view, or in the Layers view, right-click on the layer for your 3D model 
and select Wireframe.

 13. While holding Ctrl + Shift, click and drag on the Stage view to rotate it, so that you can clearly see 
how the cube's vertexes align with the grid. 

 14. In the Library view, using trial and error, adjust the 3D model's scaling factor so that its corners 
touch the points (-1,1), (1,1), (-1,-1) and (1,-1) of the world grid, which are identified with a hollow 
1. 

Once you get the cube's size to be 1,1,1 in Storyboard Pro's coordinates system, you can use the 
scaling factor you applied to this cube onto your other 3D models to make their coordinates systems 
match Storyboard Pro's coordinates system as well.
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Setting the Default Scale Factor for 3D Models
To preserve the proportions between 3D models in Storyboard Pro, you should set all your 3D models to the 
same scale factor. Once you've determined the ideal scale factor for your project, you can set the default scale 
factor to apply to 3D models when you import a 3D model into your project.

How to set the default scale factor for 3D models for the current project

 1. In the top menu, select Storyboard > Properties.

The Preferences dialog appears.

 2. In the Settings tab, in the 3D Models section, in the Default Scale Factor field, type in the default 
scale factor for your 3D models. 

 3. Click on OK. 

From now on, when you import a 3D model into your project, its scale factor will automatically be set 
to the scale factor your just entered. 

How to set the default scale factor for 3D models for new projects

 1. In the top menu, select Edit (Windows) or Storyboard Pro (macOS) > Preferences.

The Preferences dialog appears.

 2. Select the Project Settings tab.

 3. In the 3D Models section, in the Default Scale Factor field, type in the default scale factor for your 
3D models. 

 4. Click on OK 

Projects you create in the future will have their default scale factor set to the scale factor you just 
entered.
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Adding a 3D Object to a Panel in a 3D Scene
T-SBADV-011-006

Once you have a 3D object in your library, you can insert it to your panels by dragging and dropping it from the 
Library view to the Stage or Camera view. Once a 3D object is in a panel, it is considered one of your panel's 
layers. You can move, rotate and resize your object, you can animate it and you can also hide, display and 
separate the various sub-objects of the 3D object.

NOTE 

You can only add a 3D object to your panel after having imported it to your project's 3D Models 
library—see Importing 3D Objects to your Project Library on page 549.

How to insert a 3D object into a panel

 1. In the Thumbnails or Timeline view, select the panel to which you want to add a 3D object. 

 2. In the Library view, select the 3D Models library. 

 3. In the list of 3D models, select the model you wish to add to the current panel. If you have not 
imported your 3D object to the 3D models library yet, see Importing 3D Objects to your Project 
Library on page 549.

 4. Drag and drop the 3D model from the Library view to the Stage or Camera view:

 l To insert it between two specific layers, drop it between those layers in the Layer panel of 
the Stage or Camera view. 

 l If you want to insert it over all the other layers, you can drop it directly in the Stage or Camera 
view. 

If your scene was in 2D mode, you will be presented with the following dialog box:

 5. Click on Use 3D Model. This will convert your scene to 3D so that the 3D model can be inserted in it. 

The 3D model is inserted into your panel, in its original size, in the centre of the stage. A layer for 
the 3D model is added to the layer list.

 6. To modify the position, size and angle of the 3D model, use the Layer Transform  tool—see 
Positioning, Rotating and Scaling 3D Objects on page 560. 
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Positioning, Rotating and Scaling 3D Objects
T-SBADV-011-009

If you select a 3D model with the Layer Transform  tool, a 3D transformation manipulator will appear over it 
in the Stage, Camera, Top and Side views. The transformation manipulator for 3D models is a cube with 
controls within it to move, rotate and scale the model on any of the three axes.

A 3D model that has just been imported into a panel will be facing the camera. Consequently, the cube of its 3D 
manipulator will also be facing the camera, making it look like a square. At this angle, it will not allow you to 
move or scale the model on the z-axis. To work around this, you must either rotate the Stage view, use the Top 
or Side views, or rotate the model itself. 

How to rotate the Stage view in 3D

 1. Do one of the following:

 l In the Tools toolbar, double-click on the Hand  tool and select the 3D Navigation  tool.

 l Press and hold Ctrl + Shift (Windows) or Shift + ⌘  (Mac OS X).

 2. Click and drag the inside of Stage view to rotate it in all directions.

How to manipulate a 3D object

 1. In the Tools toolbar, select the Layer Transform  tool.

 2. Select the 3D model you want to manipulate.
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 3. In the Stage view, Camera view, Top view or Side view, do one of the following:

 l To translate the model on the x-axis, click ad drag the red arrow.

 l To translate the model on the y-axis, click and drag the green arrow.

 l To translate the model on the z-axis, click and drag the blue arrow.

 l To translate the model laterally relative to your point of view, click and drag on its geometry.

 l To rotate the model on the x-axis, click and drag the red circle.

 l To rotate the model on the y-axis, click and drag the green circle.

 l To rotate the model on the z-axis, click and drag the blue circle.

 l To rotate the model in any direction, click and drag on its outer circle.

561

Storyboard Pro 6. User Guide                          



 l To scale the model on the x-axis, click and drag on the red square dot.

 l To scale the model on the y-axis, click and drag on the green square dot.

 l To scale the model on the z-axis, click and drag on the blue square dot.

 l To scale the model on all axes, click and drag on any vertex of the cube. 

TIP 

If you need to rotate or scale the 3D model from a specific pivot point, you can move the 
pivot point of the 3D model by clicking and dragging the pivot  in the middle of the 
manipulator. The manipulator and its pivot will move, but not the model. 
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Positioning, Rotating and Scaling 3D Sub-Objects
T-SBADV-011-016

You can select sub-objects in a 3D model and change their position, angle and size. 

Transformations done on a 3D model's sub-object are relative to the 3D model itself. This means that the sub-
object will follow the 3D model if it moves and will be subjected to the same rotations and size transformations 
as the 3D model.

Transforming a 3D sub-object works the same way as transforming a 3D object. The key difference is in 
selecting the sub-object. If you merely click on a 3D Model in the Stage or Camera view, you will select the 
whole 3D model. Using the 3D Graph view, you can see all the sub-objects in the selected 3D model and select 
the sub-objects you want to manipulate. 

You can also select sub-objects in the Stage or Camera view by holding Ctrl (Windows) or ⌘  (macOS), but it 
may be difficult to select the right sub-object when they are placed in a hierarchy.

NOTE 

While a 3D model can be animated, transformations on 3D sub-objects are static. If you need to 
animate a 3D sub-object, you must separate it from its model to make it into its own 3D model—
Separating 3D Sub-Objects for Animation on page 572.

How to add the 3D Graph view to your workspace

 1. Do one of the following:

 l In the top-right corner of any existing view in your workspace, click on the Add View  
button and select 3D Graph.

 l In the top menu, select Windows > 3D Graph.

 2. To display a 3D model's sub-nodes in the 3D Graph view, select this 3D model in the Stage, Camera 
or Layers view. 

How to select an individual sub-object in the 3D object

 1. In the Tools toolbar, select the Layer Transform  tool. 

 2. In the Stage, Camera or Layers view, select the 3D model containing the sub-object you want to 
transform.
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 3. Select the sub-object you want to transform by doing one of the following:         

 l While holding Ctrl (Windows) or ⌘  (macOS), click on the sub-object in the Stage or Camera 
view.

 l Select the sub-object in the 3D Graph view. 

TIPS 

 l Some sub-objects do not have geometry, and are represented with a peg  icon in 
the 3D graph view. Those objects only serve as parents of other sub-objects with 
geometry, represented with a drawing  icon in the 3D Graph view. Since those 
objects have no visible component, you have to use the 3D Graph view to select 
them. To help find these objects in the 3D Graph, you can select one of the object's 
visible children in the Stage or Camera view, then select that sub-object's parent in 
the 3D Graph view. 

 l To select multiple sub-objects in the Camera and Stage view, hold Ctrl + Shift 
(Windows) or Shift + ⌘  (Mac OS X) and click on each sub-object you want to select.

 l To select multiple sub-objects in the 3D Graph view, hold Ctrl (Windows) or ⌘  
(macOS) and click on each sub-object you want to select, or hold Shift and click on 
the first sub-object that you want to select.

 l To select a series of sub-objects in the 3D Graph view, hold Shift, click on the first 
sub-object you want to select, then on the last sub-object you want to select. Every 
sub-object in-between will be selected, inclusively. 

The selected sub-object will appear in green, and the 3D manipulator will be centered on the 
selected sub-object. 

TIP 

If you need to select a 3D sub-object that does not appear in the 3D Graph view, click 
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the Menu  button in the 3D Graph view and select Extended Mode.

 4. Using the controls of the 3D transformation manipulator in the Stage or Camera view, set the 
position, angle and scale of the selected sub-object. For information on how to use the 
3D transformation manipulator, see Positioning, Rotating and Scaling 3D Objects on page 560.
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Resetting a 3D Object's Position
T-SBADV-011-017

If you make changes to the 3D object, such as its dimensions, position, or rotation, and you want to revert back 
to the object’s original settings, you do not need to delete the object and start over. You have couple of options:

 l You can use the Undo command to undo any of the changes you made to the object or in the panel since 
the project was last saved.

 l You can use the Reset Transform command to revert to the object’s original settings (position and 
dimensions).

The Reset Transform command will only affect the selected element, reverting it back to its default dimensions, 
position, and rotation for all the frames in the panel (First Frame and Last Frame).

When you import a 3D element that contains 3D nodes, all these nodes are in their default position and 
size/proportion. You can make changes to these nodes, but if you want to reset a node to its default position 
(undoing all the changes you made), you can restore each node to its default settings.

How to reset the position, angle and size of a 3D object

 1. In the Stage, Camera or Layers view, select the 3D object you want to reset.

 2. Select Layer > Reset Transform.

How to reset the position, angle and size of a 3D sub-object

 1. Select the sub-object you want to reset by doing one of the following:         

 l While holding Ctrl (Windows) or ⌘  (macOS), click on the sub-object in the Stage or Camera 
view.

 l Select the sub-object in the 3D Graph view. 
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TIPS 

 l Some sub-objects do not have geometry, and are represented with a peg  icon in 
the 3D graph view. Those objects only serve as parents of other sub-objects with 
geometry, represented with a drawing  icon in the 3D Graph view. Since those 
objects have no visible component, you have to use the 3D Graph view to select 
them. To help find these objects in the 3D Graph, you can select one of the object's 
visible children in the Stage or Camera view, then select that sub-object's parent in 
the 3D Graph view. 

 l To select multiple sub-objects in the Camera and Stage view, hold Ctrl + Shift 
(Windows) or Shift + ⌘  (Mac OS X) and click on each sub-object you want to select.

 l To select multiple sub-objects in the 3D Graph view, hold Ctrl (Windows) or ⌘  
(macOS) and click on each sub-object you want to select, or hold Shift and click on 
the first sub-object that you want to select.

 l To select a series of sub-objects in the 3D Graph view, hold Shift, click on the first 
sub-object you want to select, then on the last sub-object you want to select. Every 
sub-object in-between will be selected, inclusively. 

The selected sub-object will appear in green, and the 3D manipulator will be centered on the 
selected sub-object. 

 2. Select Layer > Reset Selected 3D Sub-Object.

The selected sub-objects return to their default position, angle and size.
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Animating 3D Objects
T-SBANIM-003-002

Animating a 3D object is very similar to animating a drawing layer. All you need to do is enable animation on 
the 3D object, then put it in different positions, angles and sizes at different frames. Transforming an 
animation-enabled 3D object will create a keyframe at the current frame, storing its transformation parameters 
in that frame, and its position, angle and size will be interpolated by Storyboard Pro on each frame between 
the keyframes you create. 

How to animate a 3D object

 1. In the Timeline view, select the panel with the layer you want to animate.

 2. Move the Timeline cursor to the exact time where you want to create the first keyframe for your 
animation.

 3. In the Layer panel of the Stage or Camera view or in the Layers view, click on the Animate button 
of the layer you wish to animate.

The Animate button turns yellow and changes shape: .

In the Layer Animation track of the Timeline view, a keyframe is created at the current frame. This 
keyframe  stores the position, angle and size of the layer at the current frame. 

 4. In the Tools toolbar, select the Layer Transform  tool.
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In the Stage or Camera view, the controls of the Layer Transform tool appear around the selected 
3D object.

 5. Using the 3D manipulator box, transform the 3D model so that it is in the position, angle and size 
you want it to be at the beginning of the animation:

 l To translate the model on the x-axis, click ad drag the red arrow.

 l To translate the model on the y-axis, click and drag the green arrow.

 l To translate the model on the z-axis, click and drag the blue arrow.

 l To translate the model laterally relative to your point of view, click and drag on its geometry.
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 l To rotate the model on the x-axis, click and drag the red circle.

 l To rotate the model on the y-axis, click and drag the green circle.

 l To rotate the model on the z-axis, click and drag the blue circle.

 l To rotate the model in any direction, click and drag on its outer circle.

 l To scale the model on the x-axis, click and drag on the red square dot.

 l To scale the model on the y-axis, click and drag on the green square dot.

 l To scale the model on the z-axis, click and drag on the blue square dot.

 l To scale the model on all axes, click and drag on any vertex of the cube. 

570



TIP 

If you need to rotate or scale the 3D model from a specific pivot point, you can move the 
pivot point of the 3D model by clicking and dragging the pivot  in the middle of the 
manipulator. The manipulator and its pivot will move, but not the model. 

 6. In the Timeline view, move the cursor to the frame where you want to create your second keyframe.

 7. In the Stage or Camera view, use the 3D manipulator box to transform the 3D model so that it is in 
the position, angle and size you want it to be at the end of the animation. 

A keyframe is created at the current frame as soon as you make the first transformation. 

 8. Move the timeline cursor back to the beginning of the panel. 

 9. In the Playback toolbar, click on the Play  button to preview the animation.

NOTE 

You can also use the Coordinate toolbar to enter values for the translation, scale and rotation 
values of a selected 3D object—see .
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Separating 3D Sub-Objects for Animation
T-SBANIM-003-003

If you want to animate a specific part of a 3D model, you must separate it from the 3D model into its own 3D 
model. Separating a sub-object from its 3D model will store it into its own layer in the panel. You will then be 
able to animate the original model and the separated sub-object separately, since each layer in your panel can 
be transformed and animated independently. 

NOTE 

Separating a sub-object from its model does not actually modify the 3D model. It simply duplicates 
the 3D model. In the original model, the sub-object is hidden. In the duplicated model, everything 
but the sub-object is hidden. This creates the illusion that there is one model for the sub-object and 
another one for the remainder of the 3D model, but they both use the same 3D model in the 
3D Models library. 

How to separate a sub-object for animation

 1. Do one of the following to add the 3D Graph view to your workspace:

 l In the top-right corner of any existing view in your workspace, click on the Add View  
button and select 3D Graph.

 l In the top menu, select Windows > 3D Graph.

 2. In the Stage, Camera or Layers view, select the 3D model which contains the sub-object you want 
to separate.

 3. Select the sub-object you want to animate by doing one of the following:         

 l While holding Ctrl (Windows) or ⌘  (macOS), click on the sub-object in the Stage or Camera 
view.

 l Select the sub-object in the 3D Graph view. 
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TIPS 

 l Some sub-objects do not have geometry, and are represented with a peg  icon in 
the 3D graph view. Those objects only serve as parents of other sub-objects with 
geometry, represented with a drawing  icon in the 3D Graph view. Since those 
objects have no visible component, you have to use the 3D Graph view to select 
them. To help find these objects in the 3D Graph, you can select one of the object's 
visible children in the Stage or Camera view, then select that sub-object's parent in 
the 3D Graph view. 

 l To select multiple sub-objects in the Camera and Stage view, hold Ctrl + Shift 
(Windows) or Shift + ⌘  (Mac OS X) and click on each sub-object you want to select.

 l To select multiple sub-objects in the 3D Graph view, hold Ctrl (Windows) or ⌘  
(macOS) and click on each sub-object you want to select, or hold Shift and click on 
the first sub-object that you want to select.

 l To select a series of sub-objects in the 3D Graph view, hold Shift, click on the first 
sub-object you want to select, then on the last sub-object you want to select. Every 
sub-object in-between will be selected, inclusively. 

The selected sub-object will appear in green, and the 3D manipulator will be centered on the 
selected sub-object. 

 1. Right-click in the 3D Graph. In the pop-up menu that displays, select one of the following:

 l Separate Sub-Object: Will only separate the selected objects from the model. If those objects 
have children, those children will not be included in the separated object.

 l Separate Sub-Tree: Will separate the selected objects and their children from the model. 
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TIP 

You should select Separate Sub-Tree if your selection contains a sub-object with no 
geometry (represented by a peg  icon in the 3D Graph view) but you did not select 
that sub-object's children. Otherwise, only the sub-object with no geometry will be in 
the separated sub-object, and this sub-object will hence be invisible. 

The selected 3D model is separated into two 3D layers: One with only the selected sub-objects 
visible, and another one with the remainder of the 3D model visible. Both 3D objects are stored in a 
group. 

NOTE 

If the original 3D model had any transformations or animation, they will be transferred 
over to the group containing the separated sub-objects. 

 2. You can now animate the 3D model and its separated sub-object separately. If you want to animate 
both of them together, simply select and animate the group in which they were stored. For 
information on how to animate a 3D model, see Animating 3D Objects on page 568.
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Creating 2D Layers on Surface of 3D Objects
T-SBADV-011-013

Working in the Camera view, you can create a new vector or bitmap layer on the surface of a 3D object. The 
new layer will be positioned at the point in Z depth on which you clicked. It is positioned perpendicular to the 
camera so you can start drawing.

How to create a 2D layer on the surface of a 3D object

 1. In the Tools toolbar, select the Create Layer on Surface   tool.

A red crosshair appears in the Stage view.

 2. In the Tool Properties, select a layer type: Vector or Bitmap.

 3. In the Stage view, move the crosshair around (without clicking the mouse button) to see where it is 
possible to create a 2D layer. You can also click and drag the crosshair to display the drawing grid. 
The size of the grid is constant. When it is farther from the camera, it appears smaller.

 4. When you are satisfied with the position, release the mouse button. 

A 2D layer is created and is positioned perpendicular to the camera.
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Snapping to Surface or Ground
T-SBADV-011-018

When working in Storyboard Pro, you can snap a 2D layer or 3D object to the 3D surface directly below it. 
Contact between the layer or 3D object is maintained with the surface no matter what changes you make to 
your selection. This makes it  much faster to block out shots and also works with 2D artwork. 

When the layer or 3D object comes into contact with the surface, its pivot connects to the 3D surface directly 
below it if you are moving the mouse. If your selection is a 2D layer, you can move it on the X and Z axes; the Y 
axis is controlled by Storyboard Pro allowing for quick placement around the ground plane. Also, the layer 
automatically rotates to be parallel to the surface, which is useful with 2D layers. In the Tool Properties view, 
you can disable the rotation parameter if you do not want to the rotation to occur.

For both 2D layers and 3D objects, the angle is retained. If needed, you can change the rotation using the 
rotation controls. When snapping a layer, its lowest point snaps to the 3D surface. 

How to snap to a surface

 1. Select the layer that contains the object with which you will snap to a surface. 

 2. In the Tools toolbar, Layer Transform  button. 

 3. In the Tool Properties view, click the Snap to Surface  button.

The 3D navigation controls appear in the Camera and Stage views.
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 4. In the Tool Properties view, how you want to use the transform options in Layer Transform controls.

 l Translate: Activate this option to move the 3D object. Deactivate to keep the object in 
place.

 l Rotate: Activate this option if you want the 3D object to change its angle to match 
that of the 3D surface beneath it. Deactivate to keep the angle of the object.

 l Scale: Activate this option if you want to change the size of the 3D object. Deactivate 
to keep the size of the object.

 5. Position the cursor close to the centre pivot and when you see the Move Cursor  appear, click and 
drag the 3D object to a new location. As you move, the object will rotate and scale (if you selected 
these options in the Tool Properties), and adhere to the 3D surface underneath it.

 6. Continue moving the object around until you are satisfied with its placement.

 7. Deactivate the tool by clicking the Snap to Surface  button again.

How to snap to the ground

 1. Select the layer that contains the object with which you will snap to the ground. 
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 2. In the Tools toolbar, Layer Transform  button. 

 3. In the Tool Properties view, click the Snap to Surface  button. 

The 3D object snaps to the 3D surface directly beneath it.
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Changing the Display Mode of 3D Objects
T-SBADV-011-008

By default, 3D models that you add to your storyboard are displayed fully shaded. This might incumber your 
stage or overflow the panels with colours and textures that contrast too much with the sketched artwork. To 
remedy this, Storyboard Pro allows you to display 3D models in one of many display modes.

How to change the display mode of a 3D object

 1. In the Thumbnails or Timeline view, select the panel that contains a 3D object.

 2. In the Layer panel of the Stage or Camera view, or in the Layers view, select the layer that contains 
the 3D object.

 3. Right-click on the layer and select one of the following:

 l Shaded: The 3D object displays its colours and textures, shaded.

 l Washed: The 3D object is displayed with a washed-out appearance, so that its details do not 
overwhelm the stage. 

 l Flat: The 3D object displays the surface of its geometry in plain white, shaded.

 l Wireframe: The 3D object displays the vertexes defining its geometry.
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 l Wireframe on Shaded: The 3D objects displays its colours and textures with its wireframe on 
top.

 l Wireframe on Flat: The 3D objects displays the surface of its geometry in white with its 
wireframe on top.

TIP 

If you set your model's display mode to Wireframe, and only want to see the wireframe 
for the polygons facing your point of view and hide the ones for the polygons on the 
backside, right-click on the layer containing the 3D object again and select Backface 
Culling. 
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Replacing a 3D Object in your Project
T-SBADV-011-005

Once you have imported a 3D model in the Library, you can easily replace it with a new one using the Replace 
3D Model command. This will update all instances of the model used in the project.

How to replace a 3D model

 1. In the Library view, click the 3D Models folder to display its contents.

 2. From the 3D Models folder, select the model you want to replace.

 3. Right-click on the selected model and select Replace 3D Model.

A browser window opens.

 4. In the browser, locate the 3D model file you want to replace and click Open.

The Rename Node dialog box opens.

 l Click Yes to rename the model you are replacing.

 l Click No to keep the existing model name.

 l Select the Don't show this message again option to prevent this dialog box from 
opening again, and use the same behavior as you choose now for future use of the 
Replace 3D Model command.

The 3D model is updated in the Library view and in your project.
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About Adding 3D Models to 2D Scenes
It is possible to add a 3D model to a 2D scene by rendering into a 2D layer. If you attempt to import a 3D model 
into a 2D scene, you will be prompted to choose from which angle and position the model is going to be 
rendered. Once rendered, the 3D object is added to your scene as a bitmap layer. Hence, from that point on, 
you cannot manipulate  or animate the 3D object in all three dimensions, like you could with a 3D object in a 3D 
scene. You can only manipulate and animate the 2D layer in which the object is rendered horizontally and 
vertically, like you could with a regular drawing layer. 

Once the model is rendered in a 2D layer, it is possible to adjust the position and angle from which the model is 
rendered, and render it again. This updates the rendered 3D model throughout the entire panel in which it is 
rendered, as the position and angle from which it is rendered cannot be animated.

Although this approach is more limited, it can be preferable if you only need to use a 3D model as a reference or 
to make a static background, as creating a 2D scene is more simple than a 3D scene. If you need to be able to 
make 3D transformations or animations to your 3D models, you will need to convert your scene into a 3D scene 
and import your model as a 3D object—see About Adding 3D Models to 3D Scenes on page 551
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Adding a 3D Object as a Rendered Image in a 2D Scene
T-SBADV-005-012A

If you attempt to import a 3D model into a 2D scene, you can choose to either convert your scene to a 3D scene, 
or render the model in 2D. In the latter case, you can position the 3D model so it is rendered from the right 
point of view, then insert that model into a 2D bitmap layer in your scene. The rendered 3D model can then be 
used as is, or as a reference for your artwork. 

How to add a 3D model as a rendered 2D image in a 2D scene

 1. Make sure the current scene is a 2D scene—see Resetting the Current Scene to 2D on page 535.

 2. In the Thumbnails or Timeline view, select the panel to which you want to add a 3D object. 

 3. In the Library view, select the 3D Models library. 

 4. In the list of 3D models, select the model you wish to add to the current panel. If you have not 
imported your 3D object to the 3D models library yet, see Importing 3D Objects to your Project 
Library on page 549.

 5. Drag and drop the 3D model from the Library view to the Stage or Camera view:

 l To insert it between two specific layers, drop it between those layers in the Layer panel of 
the Stage or Camera view. 

 l If you want to insert it over all the other layers, you can drop it directly in the Stage or Camera 
view. 

The following dialog box appears:

 6. Click on Render to 2D.

The Render 3D Model dialog appears.
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NOTE 

For information on all the parameters in this dialog, see the Reference Guide.

 7. If you want the model to fit inside the camera field, click on the Fit Model to View button just 
beneath the parameters to the right.

 8. In the preview area, do the following to adjust the camera's point of view relative to the 3D model:

 l Either click and drag on the vertical slider to the right or scroll the mouse wheel up or down 
to adjust the distance between the camera and the model. 

 l Hold Ctrl + Shift (Windows) or Shift + ⌘  (Mac OS X), then click and drag on the preview area 
to rotate the camera.
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 l Hold Spacebar, then click and drag on the preview area to pan the camera laterally. 

 9. If you want to adjust the amount of perspective applied on the way the 3D model is rendered, adjust 
the Focal Length parameter. Increasing it will reduce the amount of perspective applied on the 
model, and decreasing it will increase the amount of perspective applied on the model. 

NOTE 

Increasing this setting will also decrease the perceived size of the 3D model, and 
decreasing it will increase its perceived size. You must then adjust the camera's distance 
from the model or the model's scaling to compensate. 

 10. Adjust the Translation parameters until the 3D model is in the right position for the scene:

 l X: The horizontal position of the 3D model, from west to east.

 l Y: The vertical position of the 3D model, from south to north.

 l Z: The position of the 3D model relative to the camera, from near to far. 

 11. Adjust the Rotation parameters until the 3D model is in the right angle for the scene:

 l X: The rotation angle of the model around the horizontal axis. 

 l Y: The rotation angle of the model around the vertical axis.

 l Z: The rotation angle of the model around the z-axis. 

 12. Adjust the Scaling parameters until the 3D model is in the right size for the scene:

 l Lock Scaling Axis: When enabled, you can use the X scaling field to set the scaling of the 
3D model on all axes, preserving its proportions. 

 l X: The horizontal scaling of the model.
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 l Y: The vertical scaling of the model.

 l Z: The scaling of the model on the z-axis.

 13. Once the model is in the right position, angle and size, click on Render to Scene.

The model is added to the current panel, rendered into a 2D layer.

NOTE 

The rendered 3D model is stored in a bitmap layer. However, to differentiate rendered 3D 
model layers from manually created bitmap layers, the color bar at the left of their layer is 
purple instead of blue. 
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Repositioning a Rendered 3D Model in a 2D Scene
If you have rendered a 3D model in a 2D scene, and later decide that you need the model to be rendered from a 
different point of view, you do not need to re-import it into your scene. You can change the point of view of the 
rendered model directly. 

IMPORTANT 

If you have drawn anything on the layer in which the 3D model was rendered, updating the 
model's position will discard the artwork on that layer.

How to change the point of view of a rendered 3D model in a 2D scene

 1. In the Layer panel of the Stage or Camera view or in the Layers view, select the layer with the 
rendered 3D model. 

 2. Do one of the following:

 l Right-click on the layer and select Update Model Position.

 l In the top menu, select Layer > Update Model Position.

The Render 3D Model dialog appears. The 3D model is in the same position as the one in which it 
was rendered, allowing you to tweak its current position.

NOTE 

For information on all the parameters in this dialog, see the Reference Guide.
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 3. If you want the model to fit inside the camera field, click on the Fit Model to View button just 
beneath the parameters to the right.

 4. In the preview area, do the following to adjust the camera's point of view relative to the 3D model:

 l Either click and drag on the vertical slider to the right or scroll the mouse wheel up or down 
to adjust the distance between the camera and the model. 

 l Hold Ctrl + Shift (Windows) or Shift + ⌘  (Mac OS X), then click and drag on the preview area 
to rotate the camera.

 l Hold Spacebar, then click and drag on the preview area to pan the camera laterally. 

 5. If you want to adjust the amount of perspective applied on the way the 3D model is rendered, adjust 
the Focal Length parameter. Increasing it will reduce the amount of perspective applied on the 
model, and decreasing it will increase the amount of perspective applied on the model. 

NOTE 

Increasing this setting will also decrease the perceived size of the 3D model, and 
decreasing it will increase its perceived size. You must then adjust the camera's distance 
from the model or the model's scaling to compensate. 
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 6. Adjust the Translation parameters until the 3D model is in the right position for the scene:

 l X: The horizontal position of the 3D model, from west to east.

 l Y: The vertical position of the 3D model, from south to north.

 l Z: The position of the 3D model relative to the camera, from near to far. 

 7. Adjust the Rotation parameters until the 3D model is in the right angle for the scene:

 l X: The rotation angle of the model around the horizontal axis. 

 l Y: The rotation angle of the model around the vertical axis.

 l Z: The rotation angle of the model around the z-axis. 

 8. Adjust the Scaling parameters until the 3D model is in the right size for the scene:

 l Lock Scaling Axis: When enabled, you can use the X scaling field to set the scaling of the 
3D model on all axes, preserving its proportions. 

 l X: The horizontal scaling of the model.

 l Y: The vertical scaling of the model.

 l Z: The scaling of the model on the z-axis.

 9. Click on Render to Scene.

The selected layer is updated with the 3D model as rendered from its new point of view. 
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About 3D Camera Movements
T-SBANIM-004-012

With your scene enabled for 3D, you can rotate your camera on all three axes in the Camera view, as well as in 
the Top and Side views. As you pass your cursor over the camera manipulators, the cursor changes to indicate 
this axis on which you will be performing the rotation. Think of the X, Y and Z axes as poles that you can clamp 
your camera to in order to rotate on that pole or axis. For example, the Y-axis would be a pole that extends from 
north to south. If you clamp your camera to that pole, your camera would actually move from side to side, or be 
rotating around that vertical axis.

In the Camera view, hover the cursor over:

• The N and S points on the manipulator circle will bring up the X-axis cursor . This means that if you 
pull up or down on these points, you will be rotating your camera on the X-axis, the axis that runs 
horizontally, or from east to west, in the Camera view. 

 

• The E and W points on the manipulator circle will bring up the Y-axis cursor . This means that if you 
pull towards the left or right on these points, you will be rotating your camera on the Y-axis, the axis that 
runs vertically, or from north to south, in the Camera view.

 

• Anywhere but the points on the manipulator circle will bring up the generic rotation cursor . In the 
Camera view, this cursor represents a rotation on the Z-axis.
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These cursors will obviously differ depending on which view you are in. For example, in the Top view, hovering 
your cursor over the manipulator circle will bring up the Y-axis cursor instead of the generic rotation cursor. In 
the Top and Side views, there are no points on the manipulator circle, but rather three rings that each control 
rotation on one of the three axes. Two of these axes are seen as lines instead of rings from the perspective.
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Animating the 3D Camera 
T-SBANIM-004-010

Not only can you move 2D and 3D objects in 3D space, but you can also move and animate your camera in this 
3D space as well. This makes for impressive animatics and is also a great way to show off imported 3D objects. 
If the first frame does not do justice to your 3D camera movement in a printed or PDF version of your 
storyboard, you can add snapshots to better illustrate those wide sweeping, 3D camera movements.

How to animate the 3D camera

 1. Be sure you are in the Camera view. You can also use the Top and Side views for further clarity if 
needed.

 2. In the Tool Properties view, click the Add Keyframe  button. Even if the playhead is not at the 
start of the currently selected panel, a keyframe will be added to the first frame of that panel.

NOTE 

If the Timeline view is not displayed, select Windows > Timeline.

 3. In the Camera view, use the Camera  tool and adjust the camera manipulators to change the 
camera‘s position and rotation—see About 3D Camera Movements on page 591.

 4. Do one of the following: 

 l In the Timeline view, move the playhead to the frame on which you want to place your final 
camera position. In the Tool Properties panel, click the Add Keyframe  button to current 
frame.
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 l Click the Add Keyframe  button at the end of current panel.

<

A keyframe is added to the selected location.

 5. In the Camera view, with the Camera  tool selected, use the camera manipulators to move the 
camera into its final position. If you do not see any manipulators in the Camera view, your second 
keyframe might not be selected in the Timeline view.

NOTE 

If the playhead is not at the correct keyframe, in the Tool Properties panel, click the Go to 
Selected Keyframe  button to move your playhead there.

 6. Continue to adjust your camera move until you are satisfied. In the Timeline view, use the red 
playhead to scrub back and forth between keyframes to view the smooth, interpolated movement. 
Adjust the camera position on the first or last frame or add more keyframes between the first and 
last keyframes.

From the Camera view Status Bar, use the Camera Mask  to get a better sense of what the exact 
scene framing will look like. 
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For information about the options available in the Camera tool’s Tool Properties, see About Camera 
Movements on page 506.
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Aligning 2D Layers with a 3D Camera
T-SBANIM-004-011

While working with layers, you may want to align specific layers with the camera, so any time you adjust the 
camera, the layer is always in full view. You can set a different alignment for each layer. The default behaviour is 
that the camera is not aligned with layers. 

How to align a layer with the camera

 1. Add the Layers view to your workspace by doing one of the following:

 l In the top-right corner of any view, click on the Add View  button and select Layers.

 l In the top menu, select Windows > Layers.

 2. In the Layers view, select a layer to align with the camera. 

 

 3. From the Layer Alignment section, select one of the following:

 l  No Alignment: The layer is independent of the camera. 

If the layer is set to No Alignment and you switch to Face Camera, the offset and scale is 
retained but the rotation is removed.If the layer is set to No Alignment and you switch to Pin 
to Camera, all layer transformation is reset and animation is removed.

If the layer is set to No Alignment and you switch to Pin to Camera, all layer transformation is 
reset and animation is removed.

 l  Face Camera: The layer is oriented to face the camera, so it rotates around its pivot point 
to always face the camera, but does not move with the camera. 
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If the layer is set to Face Camera and you switch to Pin to Camera, all layer transformation is 
reset and animation is removed.

If the layer is set to Face Camera and you switch to No Alignment, the offset and scaling are 
retained. You should change the rotation keyframes so the layer faced the camera at the 
current frame.

 l  Pin to Camera:  The layer is oriented to the camera's perspective. Essentially the layer 
always moves with the camera.

If a layer is set to Pin to Camera and you switch to No Alignment or Face Camera, the layer 
stays at its position at the current frame.

If a layer is set to Pin to Camera and set it back to No Alignment or Face Camera, the layer 
transformation is combined with the camera. The layer is left in place at the current frame. 
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Chapter 14: Sound

Chapter 14: Sound
T-SBFND-009-010

You can add audio, such as sound effects, dialogue and music, to your animatic.

In order to add sound to your animatic, you must either prepare your sound files in third party software, or 
record them directly into your project. You can put sound clips into audio tracks, cue each sound clip to be 
synchronized with the action, and even edit the volume of each clip. 

You can preview your panels with sound at any time by playing back an animatic of the current panel or the 
entire storyboard using the controls in the Play toolbar.

In order to work with audio in Storyboard Pro, you must use the Timeline view, as this view allows you to edit 
your audio tracks and their sound clips. 
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About Audio Tracks
Audio tracks are tracks in which you can add sound clips. Each sound clip in an audio track is cued at a specific 
time in your animatic, so that it can be synchronized with the action. 

Your project can have as many audio tracks as you want. Having several audio tracks is required if you want to 
play several sound clips at the same time, as a single audio track can have several sound clips cued across the 
animatic, but can only play one sound clip at any given time. You can also use different audio tracks to organize 
your sound clips, for example by having a specific track for each character's dialogue, one for music, and one for 
sound effects. Each audio track can be muted, and you can also enable solo mode on an audio track if you only 
want to hear that audio track.

NOTE 

Audio tracks in Storyboard Pro are not restricted to a specific channel mode. A single audio track 
can have both mono and stereo sound clips. 
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Adding Audio Tracks
T-SBANIM-002-002

If you need to have several sound clips playing at the same time, you must add additional audio tracks to your 
project so that you can cue several sound clips in the same areas of the timeline. 

How to add an audio track

 1. Do one of the following:

 l In the top menu, select Storyboard > New > New Audio Track.

 l In the Timeline view, either right-click on an existing audio track or underneath all tracks, 
then select New Audio Track.

 l In the Clips and Tracks toolbar, click the New Audio Track  button.

You can now import or move sound clips to the new audio track.

NOTE 

When importing or recording a sound clip, you can also choose to add the sound clip into its 
own new audio track—see Importing Sound Clips on page 609 and Recording Sound Clips on 
page 611. 
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Renaming Audio Tracks
T-SBANIM-002-004

By default, audio tracks in your project are named A followed by a number. If you prefer, you can assign custom 
names to your audio tracks to help keep your timeline organized. For example, you can name your audio tracks 
according to their specific purpose: Voice samples, sound effects, music, etc. You can also assign an audio track 
to each character in your scenario, and name each track with their character's name. 

NOTE 

Track names can only contain alphanumeric characters as well as the following characters: plus (+), 
minus (-), equal (=), underscore (_), comma (,) and period (.). Other characters will be replaced with 
underscores. 

How to rename audio tracks

 1. In the Timeline view, select the audio track you wish to rename.

 2. Do one of the following:

 l Right-click anywhere on the audio track and select Rename Track.

 l In the top menu, select Storyboard > Tracks > Rename Track.

 3. In the Rename Audio Track dialog, type in the desired name for the selected audio track.

 4. Click OK. 

The name of the selected audio track is updated in the Timeline view. 
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Reordering Audio Tracks
T-SBANIM-002-005

You can change the order of your audio tracks in the Timeline view. This can be useful to make them organized 
or to keep the one you're currently editing on top. 

How to reorder video tracks

 1. In the Timeline view, select the audio track you want to move.

 2. Do one of the following:

 l Right-click anywhere on the audio track and select Move Track Up or Move Track Down.

 l In the Clips and Tracks toolbar, click on the Move Track Up  or the Move Track Down  
button.

The track is moved up or down in the list of audio tracks.
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Deleting Audio Tracks
You can delete an audio track from your project in the Timeline view. When an audio track is deleted, all its 
sound clips are also deleted from the project. 

How to delete an audio track

 1. In the Timeline view, select the audio track you want to delete.

 2. Do one of the following:

 l Right-click anywhere on the audio track and select Delete Current Audio Track.

 l In the top menu, select Storyboard > Tracks > Delete Current Track.

The selected audio track is removed from the Timeline view and deleted from your project.
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Muting Audio Tracks
T-SBANIM-002-006

You can mute one or several audio tracks in your project.

How to mute or unmute an audio track

 1. In the Timeline view, near the left edge of an audio track, click on the Mute / Unmute  button.

The Mute / Unmute button will display a "muted"   icon. The next time you play your animatic, you 
will not hear this audio track.

 2. If you want to unmute the audio track, click on the Mute / Unmute   button again. 

The Mute / Unmute button will display an enabled   icon again. The next time you play your 
animatic, you will not hear this audio track.

TIP 

When all audio tracks are enabled, you can instantly mute all but one audio track by holding 
the Alt key and clicking on its Enable / Disable button. You can also instantly enable a single 
one of your audio tracks by enabling Solo Mode—see Using Solo Mode with Audio Tracks on 
page 605.
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Using Solo Mode with Audio Tracks
T-SBANIM-002-012

If you have several audio tracks and only want to hear one or two of them, you can enable solo mode on these 
tracks to temporarily mute all other tracks. 

If solo mode is enabled on at least one audio track, only the audio tracks with solo mode enabled will be audible. 
If solo mode is not enabled on any audio track, then all audio tracks will be audible. 

NOTE 

Muted audio tracks are never audible, even if solo mode is enabled on them.

How to use Solo Mode with audio tracks

 1. In the Timeline view, click the Solo Mode   button of an audio track.

The Solo Mode button will become active . From now on, you will only hear this audio track during 
playback.

 2. If you want to hear more than one audio track, you can activate the Solo Mode  button on other 
audio tracks. All audio tracks with Solo Mode enabled will be audible, provided that they are not 
muted.

 3. To remove a track from Solo Mode, click on its Solo Mode  button again to disable it for that track.

 4. When you want to stop using solo mode and resume hearing all audio tracks, click on the Solo Mode 
 button of all audio tracks on which it is enabled, until Solo Mode is no longer enabled on any 

audio track.

TIP 

You can also enable or disable solo mode for all but a single track by holding the Alt key and 
clicking on the  Solo Mode button of an audio track.
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Locking Audio Tracks
T-SBFND-009-013 

By default, the clips in your audio tracks follow the timing changes made to your animatic. For example, if you 
extend the duration of a panel, this moves all subsequent panels, and the audio clips after this panel will also be 
moved to follow the movement of subsequent panels. 

If you want to prevent this from happening, you can lock your audio tracks. Locking a track will prevent you 
from making any unwanted changes to the clips in the track. When a track is locked, it is impossible to move, 
delete, add or edit sound clips in this track.

How to lock or unlock an audio track

 1. In the Timeline view, just right of the name of the audio track you want to lock, click on the Lock / 
Unlock  button.

The Lock / Unlock button will display a "locked"  icon, and the track will appear cross-hatched to 
indicate that you can't make changes to it. 

 2. If you want to unlock the audio track, click on its Lock / Unlock  button again.

The Lock / Unlock button will display an "unlocked"  icon, and you will be able to edit the audio 
track again.

TIP 

You can also lock or unlock all but one audio track by holding the Alt button and clicking on the 
track's Lock / Unlock button.

If none of your project's audio tracks are locked, you can lock them all simultaneously. 

How to lock all audio tracks

 1. In the Timeline view, make sure that all audio tracks are unlocked, or else, the Lock All Audio Tracks 
command will be unavailable. and the Unlock Audio Tracks command will be available instead.

 2. In the top menu, select Storyboard > Tracks > Lock All Audio Tracks.

If at least one audio track is locked, you can unlock them all simultaneously. 
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How to unlock all audio tracks at once

 1. In the Timeline view, make sure there is at least one locked audio track. Otherwise, the Unlock All 
Audio Tracks command will be unavailable.

 2. In the top menu, select Storyboard > Tracks > Unlock All Audio Tracks.
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About Sound Clips
Once you have created audio tracks, you can import or record sound clips. Sound clips are audio files that are 
cued to play as your animatic plays. They are stored in your project's audio tracks, where they can be moved, 
trimmed at their beginning or their end, and have their volume adjusted.
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Importing Sound Clips
T-SBFND-009-011 

You can import sound clips (.wav, .aif, .aiff, or .mp3) into an audio track at the first frame or at the current frame. 
If the sound clip does not already exist in your project, Storyboard Pro copies the file from its present location to 
the audio folder in your storyboard project folder. You must work in the Timeline view.

IMPORTANT 

It is not recommended to work .mp3 files as it is a compressed format. Long .mp3 files may not 
properly sync with the action in your project. 

How to import a sound clip

 1. In the Timeline view, select the audio track in which you want to import sound clips.

 2. Do one of the following:

 l In the top menu, select File > Import > Sound Clip.

 l Right-click on the audio track in which you want to import sound clips, then select 
Import Sound Clips.

 l Right-click on the empty space below the tracks in the Timeline view, then select 
Import Sound Clips.

The Import Sound Clips dialog box opens.

 3. Click on the Browse  button.

 4. In the file browser, locate and select the sound file that you want to add to your project, then click on 
Open.

 5. In the Target Audio Track panel, select New Audio Track if you want to create a new audio track 
and import the sound file in it, or Current Audio Track if you want to import the sound file into the 
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selected audio track.

 6. In the Target Frame section, select whether you want the sound clip to be added to the First Frame 
of the audio track or to the Current Frame, where the timeline cursor is.

 7. If you selected the Current Audio Track option, and if other sound clips are present in the target 
audio track, specify what will happen if the imported sound clip is too long and spans over another 
existing sound clip by selecting an Import Rule:

 l Overwrite Existing Sound Clips: If there are existing sound clips where the imported clips are 
supposed to be added, the existing clips will be overwritten. 

 l Fill Next Available Frames: If there are existing sound clips where the new clips are supposed 
to be added, the clips will be trimmed just before the existing clips.

 8. Select the Set as default and don’t show dialogue again option if you want to use the same settings 
next time you need to import a sound file.
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Recording Sound Clips
T-SBANIM-002-011

You can record sound directly from Storyboard Pro and insert it in the timeline.

How to record sound in Storyboard Pro

 1. In the Timeline view, add a new audio track if needed.

 2. Position the play head at the frame you want your recording to begin and select the audio track you 
want to record your sound guide in.

 3. Do one of the following:

 l In the top menu, select File > Import > Record Sound.

 l In the Sound toolbar, click on Record Sound .

The Record Sound dialog box opens.

 4. In the Target Audio Track section:

 l Select the New Audio Tracks option to create a new audio track for the recording.

 l Select the Current Audio Track option to record in the selected audio track.

 5. In the Target Frame section:

 l Select the First Frame option to start the recording on the first frame of the project.

 l Select the Current Frame option to start the recording on the current frame.

 6. In the Import Rule section:

 l Select the Overwrite Existing Sound Clips option so that the resulting audio clip will 
be position in its entire length, overwriting any existing clip positioned in its way.
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 l Select the Fill Next Available Frames option so that the recording do not overwrite 
the position of existing audio clips that are on the same audio track.

 7. In the Record Sound Clip section:

 l Type in the name you want for your audio clip.

 l Click the Record  button to start the recording.

 l Click the Stop  button to stop the recording.

 l Click the Play  button to preview the recording.

 8. Click OK.

The recording is imported in the selected audio track of your project.

s
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Deleting Sound Clips
You can delete sound clips from an audio track.

How to delete one or several sound clips

 1. In the Timeline view, select the clip or clips you want to delete by doing one of the following:

 l To select a single sound clip, click on it.

 l To select a series of sound clips, draw a rectangle around them by clicking just outside of the 
clips you want to select, then dragging the mouse cursor all the way to the last clip you want 
to select:

 l To select a series of sound clips, you can also click on the first clip you want to select, then, 
while holding the Shift key, click on the last clip you want to select. This will select all clips 
between the two clips you clicked on, inclusively.

 l To select several sound clips, press and hold Ctrl (Windows/Linux) or ⌘  (macOS), then click 
on each clip you want to select. 

 2. Do one of the following:

 l Right-click on the selection and select Delete Selected Clips.

 l Press Del (Windows) or Backspace (Mac OS X).
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Moving Sound Clips
You can move one or several sound clips, even if they're on different audio tracks, at the same time. You can 
move them horizontally to change their cue time in the animatic, or vertically to move them from one audio 
track to another audio track.

How to move sound clips

 1. In the Timeline view, select the clip or clips you want to move by doing one of the following:

 l To select a single sound clip, click on it.

 l To select a series of sound clips, draw a rectangle around them by clicking just outside of the 
clips you want to select, then dragging the mouse cursor all the way to the last clip you want 
to select:

 l To select a series of sound clips, you can also click on the first clip you want to select, then, 
while holding the Shift key, click on the last clip you want to select. This will select all clips 
between the two clips you clicked on, inclusively.

 l To select several sound clips, press and hold Ctrl (Windows/Linux) or ⌘  (macOS), then click 
on each clip you want to select. 

 2. Click on one of the selected clips and drag the selection to the position where you want to move 
them. 

While dragging, a black text box displays the new starting time of the selected clip, along with the 
amount of seconds and frames by which you're moving the clip.

614



Adjusting the In and Out Points of Sound Clips
T-SBFND-009-012 

You can trim off the beginning and the end of sound clips so as to only play a specific part of the clip in your 
animatic. This is also referred to as changing the in and out points of clips. 

You can trim off parts of a clip in the Timeline view simply by dragging one of its left or right edges towards its 
middle. If you trim off part of a sound clip, the trimmed off part does not get deleted. At any time, you can 
extend the edges of clip back to their original position to restore the parts that were trimmed off. 

TIP 

It is easier to edit sound clips with their waveform displaying in the Timeline view—see Displaying 
Waveforms on page 629.

How to adjust the In and Out points of a sound clip

 1. Do one of the following:

 l Click on the left edge of the sound clip, then drag it towards the right to set the In point to 
later within the clip. 

As you move the cursor, the beginning of the sound file gets cut out from the clip. A black text 
box indicates the new length of the clip, as well as the length of the part of the clip you are 
cutting out.

 l Click on the right edge of the sound clip, then drag it towards the left to set the Out point to 
earlier within the clip.

As you move the cursor, the end of the original sound file is cut out from the clip. A black text 
box indicates the new length of the clip, as well as the length of the part of the clip you are 
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cutting out.

NOTES 

 l Trimming a sound clip does not delete the part of the audio that is trimmed off. At any time, 
you can click on the edge of the sound clip and drag it back to its original position to restore 
the part of the clip that you trimmed off.

 l Likewise, trimming a sound clip with volume keyframes does not delete the volume 
keyframes that get trimmed off. They are hidden, and extending the sound clip back to its 
original length will restore those keyframes.
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Snapping Sound Clips
When the Snapping option is enabled, when you drag and drop a video clip, the beginning and end of sound 
clips will snap against the beginning and end of panels as well as against the timeline cursor.

Likewise, when you adjust the in point or the out point of a sound clip while snapping is enabled, it will also 
snap against the beginning and end of panels and against the timeline cursor. 

How to enable or disable snapping

 1. Do one of the following:

 l At the bottom-left of the Timeline view, click on the Snapping  button. 

 l Right-click the Timeline view and select Snapping.

NOTE 

While dragging a clip, you can temporarily override whether snapping is enabled by holding 
the Shift key.
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Copying and Pasting Sound Clips
T-SBANIM-002-014

You can copy one or several clips from your project's audio tracks and paste them somewhere else in your 
project's audio tracks.

How to copy sound clips

 1. In Timeline view, select one or multiple sound clips by doing one of the following:

 l To select a single sound clip, click on it.

 l To select a series of sound clips, draw a rectangle around them by clicking just outside of the 
clips you want to select, then dragging the mouse cursor all the way to the last clip you want 
to select:

 l To select a series of sound clips, you can also click on the first clip you want to select, then, 
while holding the Shift key, click on the last clip you want to select. This will select all clips 
between the two clips you clicked on, inclusively.

 l To select several sound clips, press and hold Ctrl (Windows/Linux) or ⌘  (macOS), then click 
on each clip you want to select. 

 2. Do one of the following to copy the selected clips:

 l In the top menu, select Edit > Copy Clips.

 l Press Ctrl + C (Windows) or ⌘  + C (Mac OS X).

 3. In the Timeline view, select the audio track in which you want the clips to be pasted.

 4. Move the timeline cursor to the position in time where you want the clips to be pasted.

 5. Do one of the following to paste the copied clips:

 l In the top menu, select Edit > Paste Clips.

 l Press Ctrl + V (Windows) or ⌘  + V (Mac OS X).

The copied clips are pasted on the selected track, right after the Timeline cursor. 
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NOTES 

 l If a sound clip is already present on a destination audio track, the pasted clip will overwrite 
the sound clip on the destination track.

 l If sound clips are copied from multiple tracks, they will be pasted on multiple tracks as well. 
If needed, Storyboard Pro will create additional audio tracks to preserve the differences in 
tracks between the copied sound clips. 
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Splitting a Sound Clip
You can separate a sound clip into two sound clips, allowing you to cue different parts of the same sound sample 
at different points in the timeline. 

TIP 

It is easier to edit sound clips with their waveform displaying in the Timeline view—see Displaying 
Waveforms on page 629.

How to split a sound clip

 1. In the Timeline view, select the sound clip you want to split.

 2. Move the timeline cursor to the frame at which you want to split the clip.

 3. Do one of the following:

 l From the top menu, select Clips > Split Clip at Current Frame

 l In the Timeline view, right-click anywhere on the audio track and select Split Clip at Current 
Frame.

The sound clip is split. You can now move both parts independently.

NOTE 

When splitting a sound clip with volume keyframes, the two resulting clips will both have all 
the  volume keyframes the original sound clip did, but the volume keyframes outside of their 
respective boundaries will be hidden. 
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Selecting All Sound Clips
By using one of the following keyboard shortcuts, it is possible to select a sound clip and all the sound clips 
following it at once.  Similar shortcuts are also available for selecting panels—see About the Panel Duration on 
page 453

How to select all sound clips on a single audio track forward

 1. In the Timeline view, hold Ctrl + Alt and click the sound clip from which you want the selection to 
start.

The sound clip and all the ones following it on the same audio track, up until the end of the 
storyboard project, are selected.

How to select all sound clips on all audio tracks forward

 1. In the Timeline view, hold Ctrl + Shift + Alt and click the sound clip from which you want the 
selection to start.

The sound clip and all the sound clips following it on all audio tracks, up until the end of the 
storyboard project, are selected.

NOTE 

You can also simultaneously select all panels and sound clips forward—see Selecting All Panels 
Forward on page 462.
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Marking  Sound Clips with Colours
Marking sound clips with a custom colour allows you manage them and quickly identify them. 

NOTE 

You can also mark panels with a colour—see Storyboard Structure on page 92.

How to mark a sound clip with colour

 1. In the Timeline view, select one or more sound clips by doing one of the following:

 l To select a single sound clip, click on it.

 l To select a series of sound clips, draw a rectangle around them by clicking just outside of the 
clips you want to select, then dragging the mouse cursor all the way to the last clip you want 
to select:

 l To select a series of sound clips, you can also click on the first clip you want to select, then, 
while holding the Shift key, click on the last clip you want to select. This will select all clips 
between the two clips you clicked on, inclusively.

 l To select several sound clips, press and hold Ctrl (Windows/Linux) or ⌘  (macOS), then click 
on each clip you want to select. 

 2. Right-click on the selection, then select one of the following: Set Colour > Red, Orange, Yellow, 
Green, Blue, Purple or Custom. 

The colour of the selected sound clips change to the selected colour.
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How to reset the sound clip colour

 1. In the Timeline view, select the clip or clips which you want to reset to their default colour by doing 
one of the following:

 l To select a single soundvideo clip, click on it.

 l To select a series of soundvideo clips, draw a rectangle around them by clicking just outside of 
the clips you want to select, then dragging the mouse cursor all the way to the last clip you 
want to select:

 l To select a series of soundvideo clips, you can also click on the first clip you want to select, 
then, while holding the Shift key, click on the last clip you want to select. This will select all 
clips between the two clips you clicked on, inclusively.

 l To select several soundvideo clips, press and hold Ctrl (Windows/Linux) or ⌘  (macOS), then 
click on each clip you want to select. 

 2. Right-click on one of the clips in the selection and select Set Colour > Default Colour. 

The colour of the selected clip or clips resets to the default colour.
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Searching Sound Clips
T-SBANIM-002-007

If your project contains a lot of sound clips, you can search through your project's audio tracks using part or all of 
the name of the sound clip you're looking for. 

How to search for sound clips in your project

 1. Do one of the following:

 l In the top menu, select Clips > Find Sound Clips.

 l Right-click anywhere in one of your project's audio tracks, then select Find Sound Clips.

The Find Sound Clips dialog box appears.

 2. In the Search field, type in the name of the sound clip you want to find. You can also type part of its 
name.

 3. If you want to make sure to only find sound clips with the same case as your search string, check the 
Case Sensitive option. If you're not sure you typed the name of the sound clip with the correct case, 
leave this option unchecked. 

 4. If your project has a lot of audio tracks, and you want the Timeline view to scroll up or down to the 
right audio track when it finds a sound clip, check the Scroll Vertically on Find option. Otherwise, it 
will only scroll horizontally to the sound clip, and you might have to scroll up or down in the Timeline 
view to see it.

 5. Do one of the following:

 l Click on Find All if you want to simultaneously highlight all the sound clips that match your 
search criteria

 l Click on Next to search for the next matching sound clip. The sound clip will be selected and 
the timeline playhead will move to the beginning of the clip. 

 l Click on Previous to search for the previous matching sound clip. The sound clip will be 
selected and the timeline playhead will move to the beginning of the clip. 
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NOTE 

When you search with the Previous or Next buttons, the search will start from the position of 
the timeline playhead if no sound clip is selected, and will start from the position of the selected 
sound clip if a sound clip is selected. Since finding a sound clip makes it selected, if you want to 
start the search from a different position, you must first deselect this sound clip by clicking in 
the empty space in an audio track, then move the timeline cursor to the position where you 
want the search to start. 
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About Sound Playback and Display
By default, the soundtrack of your project is represented by rectangular sound clips spanning from their In 
point to their Out point, with the name of their audio file displayed in it. However, there are different ways to 
display and preview the audio in your project, all of which can help you synchronize the action in your animatic 
with its soundtrack, and vice versa. For example, you can enable audio playback when previewing your 
animatic, you can enable audio scrubbing, which plays a short part of the soundtrack at the current frame when 
you move the timeline cursor, or you can even display each sound clip's waveform in the Timeline view, giving 
you a visual representation of their content.
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Enabling Audio Playback
If you want to hear your soundtrack play as you preview your animatic, you must enable audio playback. You can 
also disable audio playback afterwards if you prefer.

How to enable or disable audio playback

 1. Do one of the following: 

 l In the Playback toolbar, click on the Sound  button.

 l In the top menu, select Play > Audio Playback.

Next time you play your animatic, you will hear the sound clips in your audio tracks play. To test this, 
click on the Play  button in the Playback toolbar. 
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Enabling Audio Scrubbing
Audio scrubbing allows you to get a quick and precise idea of the timing of your project's soundtrack as you 
work on your animatic. When enabled, Storyboard Pro will play a very short the part of your project's 
soundtrack at the current frame each time you move the timeline cursor, so that you can navigate your timeline 
of your animatic by sound. This makes it easier to synchronize the action and audio in your animatic.

How to enable or disable audio scrubbing

 1. Do one of the following: 

 l At the bottom-left corner of the Timeline view, click on the Sound Scrubbing  button.

 l In the top menu, select Play > Audio Scrubbing.

 l In the Timeline view, right-click anywhere on an audio track and select Audio Scrubbing. 

In the Timeline view, click and drag the timeline cursor over your sound clips to verify that you can 
hear bits of the soundtrack play.
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Displaying Waveforms
T-SBANIM-002-013

Waveform is a visual representation of the frequency waves that make a sound clip. Since waves are higher 
when the sound is louder or high-pitched, this allows you to see at which point in time the sound effects reach 
their highs and lows, and to time the action in your animatic accordingly. 

How to display or hide the waveform of sound clips

 1. Do one of the following:

 l In the bottom-left corner of the Timeline view, click the Menu  button and select Show 
Waveform.

 l In the top menu, select Clips > Show Waveform

 l In the Timeline view, right-click anywhere on the audio track area and select Show 
Waveform. 
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Changing the Audio Track Height
There are four sizes in which you can display audio tracks: Mini, Small, Medium and Large. The size of an audio 
track affects how much vertical space the audio track takes in the Timeline view. You can adjust the display size 
of each track individually. By default, all audio tracks are displayed in small size. 

Making audio tracks smaller can be useful if you have many audio tracks and want to see more audio tracks in 
the Timeline view. Making audio tracks bigger can make it easier to see the differences in waveform and in the 
volume envelope, and allows you to adjust the volume envelope with more precision—see Displaying 
Waveforms on page 629, Displaying Volume Envelope on page 633 and Animating the Volume of Sound Clips 
on page 636. 

How to set the audio track size

 1. In the Timeline view, right-click anywhere on an audio track, then select Track Size > Mini, Small, 
Medium or Large.

The height of the audio track in the Timeline view is adjusted to the new setting. 
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Showing or Hiding the Sound Clip Name 
By default, the clip's file names are displayed on the audio blocks. You can enable or disable showing clip 
names, depending on your preference.

How to show or hide the name of each clip in the audio tracks

 1. Do one of the following:

 l In the bottom-left corner of the Timeline view, click on the Menu  button and select  Show 
Sound Clip Names.

 l In the top menu select Clips > Show Sound Clip Names.

 l In the Timeline view, right-click anywhere on an audio track and select Show Sound Clip 
Names.
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About Volume Envelope
Each sound clip has its own volume envelope, which can be used to adjust its volume and make gradual volume 
changes. 
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Displaying Volume Envelope
The volume envelope is a graph representing the volume of a sound clip, which can be displayed over your 
sound clips. By default, each sound clip has a straight, neutral volume envelope. You can add keyframes to the 
volume envelope, each of which can be set to a different volume—see Adjusting Volume on page 634 and 
Animating the Volume of Sound Clips on page 636

How to show or hide the volume envelope of sound clips

 1. Do one of the following:

 l In the bottom-left corner of the Timeline view, click the Menu  button and select Show 
Volume.

 l In the top menu, select Clips > Show Volume Envelope

 l In the Timeline view, right-click anywhere on the audio track area and select Show Volume. 

The volume envelope of each sound clip displays over the sound clips in the Timeline view. By 
default the envelope is a straight line in the middle of the sound clip, which means the volume of the 
sound clip is neutral all throughout.
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Adjusting Volume
T-SBANIM-002-010

You can change the volume of a sound clip by creating a single volume keyframe on its envelope, then adjusting 
the volume of that keyframe. It will affect the volume of the whole clip. 

How to  adjust the volume of a sound clip

 1. Do one of the following to display each clip's volume envelope in the Timeline view.

 l In the bottom-left corner of the Timeline view, click the Menu  button and select Show 
Volume.

 l In the top menu, select Clips > Show Volume Envelope

 l In the Timeline view, right-click anywhere on the audio track area and select Show Volume. 

A blue line, indicating the sound level, is displayed for each sound sequence. 

 2. Do one of the following to display each clip's waveform. This is not required, but can be very useful in 
helping you decide where to position your volume keyframes.

 l In the bottom-left corner of the Timeline view, click the Menu  button and select Show 
Waveform.

 l In the top menu, select Clips > Show Waveform

 l In the Timeline view, right-click anywhere on the audio track area and select Show 
Waveform. 

 3. If needed, zoom in on the Timeline view so that you have enough space to properly position your 
volume keyframes. To zoom in on the Timeline view, do one of the following:

 l Near the top-left corner of the Timeline view, click and drag the timeline zoom slider towards 
the right.
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 l Click on the Timeline view to set the focus on it, then press 2.

 l Click on the Timeline view to set the focus on it. Then, in the top menu, select View  > Zoom 
In Timeline.

 4. If needed, increase the vertical size of the audio track so that you have enough space to properly 
adjust the volume keyframes. To do this, right-click on the audio track and select Track Size 
> Medium or Large.

 5. While holding the Alt key, click anywhere on the envelope to create a volume keyframe. 

 6. Click and drag the volume keyframe up or down to adjust the volume of the whole sound clip. The 
volume of the clip in decibels is displayed just right of the mouse cursor. 
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Animating the Volume of Sound Clips
You can make the volume of sound clip increase or decrease progressively as it plays out by creating volume 
keyframes on its volume envelope, then adjusting the volume of each of these keyframes. 

How to animate the volume of a sound clip

 1. Do one of the following to display each clip's volume envelope in the Timeline view.

 l In the bottom-left corner of the Timeline view, click the Menu  button and select Show 
Volume.

 l In the top menu, select Clips > Show Volume Envelope

 l In the Timeline view, right-click anywhere on the audio track area and select Show Volume. 

A blue line, indicating the sound level, is displayed for each sound sequence. 

 2. Do one of the following to display each clip's waveform. This is not required, but can be very useful in 
helping you decide where to position your volume keyframes.

 l In the bottom-left corner of the Timeline view, click the Menu  button and select Show 
Waveform.

 l In the top menu, select Clips > Show Waveform

 l In the Timeline view, right-click anywhere on the audio track area and select Show 
Waveform. 

 3. If needed, zoom in on the Timeline view so that you have enough space to properly position your 
volume keyframes. To zoom in on the Timeline view, do one of the following:

 l Near the top-left corner of the Timeline view, click and drag the timeline zoom slider towards 
the right.

636



 l Click on the Timeline view to set the focus on it, then press 2.

 l Click on the Timeline view to set the focus on it. Then, in the top menu, select View  > Zoom 
In Timeline.

 4. If needed, increase the vertical size of the audio track so that you have enough space to properly 
adjust the volume keyframes. To do this, right-click on the audio track and select Track Size 
> Medium or Large.

 5. While holding the Alt key, click on the volume envelope at the point in time where you want the 
volume change to start.

 6. While holding the Alt key still, click on the volume envelope to create another keyframe where you 
want the volume change to end.

 7. Once all the needed volume keyframes are created, click and drag each keyframe up and down to 
adjust their volume. As you drag, the volume of the keyframe in decibels is displayed just right of the 
mouse cursor.
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The slope in the volume envelope between each keyframe indicates that the volume progressively 
increases or decreases to go from the volume in one keyframe to the volume in the next keyframe. 

 8. If you want to adjust the position of a keyframe in time, simply click and drag it left or right.

 9. If you want to delete an existing volume keyframe, hold the Alt key and click on the keyframe. 
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Chapter 15: Image and Video Clips
As you create a storyboard, its panels and their drawing layers are all containing inside the storyboard track. 
However, it is also possible to add video tracks to your animatic, in which you can add image and video clips 
that will appear over or underneath the artwork in your storyboard.

Video tracks can serve as multitude of purposes: For example, they allow you to use images and videos as 
references for your artwork or animation,  add overlaying logos to the storyboard, import premade opening and 
credit sequences, make backgrounds span over several panels or scenes and insert live action sequences. 

The images and videos you add to video tracks are independent from your animatic. They are not bound to a 
panel or to a scene, and they are not affected by camera movements. 

NOTE 

Video tracks are exported when exporting to bitmap images, layouts, movie files, EDL/AAF/XML 
sequences, PDF and Harmony scenes with rendered images. However, they are not taken in 
account when exporting or importing for conformation, when inserting or merging projects, when 
exporting original Harmony scenes and when exporting to FBX.
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About Video Clip Format
When it comes to importing images as video clips, you can import images of any type supported by Storyboard 
Pro into your video tracks. However, if you want to import video files, some considerations must be taken in 
regards to the format of the video. 

One of the first things to consider when preparing a video clip for your project is that if you import video files 
with an audio track, that audio track will be ignored. Only the file's video stream will be added to your project. 
Hence, if you want to include your video's audio track into your project, you will need to export that video's 
audio track into a sound file, in Waveform (.wav) format or Audio Interchange File Format (.aiff), and import it as 
a sound clip into one of your project's audio tracks. 

The other possible limitation to consider is that Storyboard Pro will decode video using the codecs available for 
your machine's operating system. By default, the following formats are supported:

Operating System Supported Containers Supported Codecs

Windows

 l QuickTIme Movie (.mov)

 l MPEG-4 (.mp4, .m4v)

 l Windows Media Video (.wmv)

 l H.264

 l DV Video

 l MJPEG

 l MPEG-4 Part 2

 l MPEG-4 v1/v2/v3

 l Windows Media Video (WMV)

macOS
 l QuickTime Movie (.mov)

 l MPEG-4 (.mp4, .m4v)

 l H.264

 l Apple ProRes

NOTE 

 l The containers and codecs in bold are supported on both operating systems.

 l You may also be able to import video clips in other formats if you have additional codecs installed 
on your workstation. 

This means that a video file that is imported into your project via one machine may be playable on that 
machine, but may not be playable if you open the same project on a different machine, should that video file 
require a codec that is only available on some machines. To avoid this, it is recommended to create your video 
clips as QuickTime Movie (.mov) or MPEG-4 (.mp4, .m4v) video files in H.264 format, since these containers and 
this  codec are natively supported by both Windows and macOS.

In summary, when you create a video clip for a Storyboard Pro project, you can refer to this checklist to make 
sure it is compatible with your project and that it will be playable on the machine of other project collaborators:
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 l Export in QuickTime Movie (.mov) or MPEG-4 video (.mp4, .m4v) format.

 l Export using the H.264 video codec. 

 l Exporting the soundtrack in the movie file is not necessary. To have the movie's soundtrack in your 
project, you must export it as an .aiff or .wav sound file, so that you can import it in an audio track in your 
project.

TIP 

On macOS, QuickTime Player may be able to convert a video encoded in an unsupported format to 
Apple ProRes format. To do this, open the movie in QuickTime Player. You will see a progress bar 
with the caption Converting before the video is ready to play. Then, in the top menu, select File 
> Save to save the converted video into a new movie file. You will be able to import this file into your 
project. 
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About Video Tracks
T-SBANIM-001-002

Video tracks are tracks in which you can insert still images or videos, which are referred to as video clips, and 
which will appear over your animatic. The clips in video tracks can be cued and clipped at any time in your 
animatic, and they are independent from the scenes, panels and layers in your storyboard. 

By default, a Storyboard Pro project does not have any video track. Video tracks can be added and managed 
using the Timeline view. 

Your project can have several video tracks. If more than one video track plays a clip at the same time, the order 
of the video tracks in the Timeline view will determine the order in which they appear in the stage. Just like 
layers in a panel, video tracks at the top are rendered over video tracks underneath them. Video tracks in your 
project can be reordered as needed. 

When adding a video track to your project, it is added over the storyboard track, which contains your animatic. 
However, it is also possible to move a video track underneath the storyboard track. This means all its clips will 
appear behind the artwork and objects in your panels. This can be useful, for example, if you want to use the 
same background throughout several panels or scenes. Note however that video clips are not affected by 
camera movements in your scenes.
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Adding Video Tracks
T-SBANIM-001-003

By default, a Storyboard Pro project does not have any video track. If you want to add image or video clips to 
your project.

How to add a video track

 1. Do one of the following:

 l In the top menu, select Storyboard > New > New Video Track.

 l In the Timeline view, right-click on an existing video track or in the empty space below the 
tracks, and select New Video Track.

 l In the Clips and Tracks toolbar, click the New Video Track  button.

You can now import or move video clips to the new video track.

NOTE 

When importing an image or video clip, you can also choose to add the clip into its own new 
video track—see Importing Image and Video Clips on page 655.
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Renaming Video Tracks
By default, video tracks added to your project are named V followed by a number. If you prefer, you can assign 
custom names to your video tracks to help keep your timeline organized.

NOTE 

Track names can only contain alphanumeric characters as well as the following characters: plus (+), 
minus (-), equal (=), underscore (_), comma (,) and period (.). Other characters will be replaced with 
underscores. 

How to rename video tracks

 1. In the Timeline view, select the audio track you wish to rename.

 2. Do one of the following:

 l Right-click anywhere on the audio track and select Rename Track.

 l In the top menu, select Storyboard > Tracks > Rename Track.

 3. In the Rename Video Track dialog, type in the desired name for the selected video track.

 4. Click OK. 

The name of the selected video track is updated in the Timeline view. 
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Reordering Video Tracks
Just like layers in a panel, each video track renders over the video track below it in the Timeline view. You can 
change the order of video tracks relative to each other. 

NOTE 

You can also move video tracks below the storyboard track, to make them appear behind the 
artwork in your storyboard. 

How to reorder video tracks

 1. In the Timeline view, select the video track you want to move.

 2. Do one of the following:

 l Right-click anywhere on the video track and select Move Track Up or Move Track Down.

 l In the Clips and Tracks toolbar, click on the Move Track Up  or the Move Track Down  
button.

The track is moved up or down in the list of video tracks.
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Deleting Video Tracks
You can delete a video track from your project in the Timeline view. When a video track is deleted, all its clips 
are also deleted from the project. 

How to delete a video track

 1. In the Timeline view, select the video track you want to delete.

 2. Do one of the following:

 l Right-click anywhere on the video track and select Delete Current Video Track.

 l In the top menu, select Storyboard > Tracks > Delete Current Track.

The selected video track is removed from the Timeline view and deleted from your project.
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Hiding and Displaying Video Tracks
You can hide one or several video tracks in your project. This is useful if some video clips are cluttering the stage 
and you need to have them out of the way. 

How to hide or unhide a video track

 1. In the Timeline view, near the left edge of a video track, click on the Show / Hide  button to hide it

The Show / Hide button for that track will display a "hidden"  icon, and the clips in the video 
track will become invisible.

 2. If you want to display the video track again, click on the Show / Hide  button again to unhide it.

The Show / Hide button for that track will display a "visible"  icon again, and the clips in this 
video track will become visible again.  

It is also possible to simultaneously hide or unhide all video tracks that appear over your storyboard and all 
video tracks that appear behind your storyboard. 

If you have video tracks in your project, you may notice the following in the Layer panel of the Stage and 
Camera view and in the Layers view:

 l If you have one or more video tracks above the storyboard track, a Top Video Tracks layer will be on top 
of the list.

 l If you have one or more video tracks underneath the storyboard track, a Bottom Video Tracks layer will 
be at the bottom of the list.

These are not actual layers, but merely shortcuts to control the visibility of video tracks that appear over and 
behind the artwork in your storyboard.
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How to hide or unhide all video tracks that appear over your storyboard 

 1. In the Layer panel of the Stage or Camera view, or in the Layers view, click on the Show / Hide  
button near the left edge of the Top Video Tracks layer.

The Show / Hide button for the Top Video Track layer will display a "hidden"  icon, and the tracks 
that are above the storyboard track will instantly become hidden.

 2. If you want to display the top video tracks again, click on the Show / Hide  button of the Top 
Video Tracks layer again to unhide them.

The Show / Hide button for the Top Video Track layer will display a "visible"  icon again, and the 
tracks that are above the storyboard track will instantly become visible.

How to hide or unhide all video tracks that appear behind your storyboard 

 1. In the Layer panel of the Stage or Camera view, or in the Layers view, click on the Show / Hide  
button near the left edge of the Bottom Video Tracks layer.

The Show / Hide button for the Borttom Video Track layer will display a "hidden"  icon, and the 
tracks that are underneath the storyboard track will instantly become hidden.

 2. If you want to display the bottom video tracks again, click on the Show / Hide  button of the 
Bottom Video Tracks layer again to unhide them.

The Show / Hide button for the Bottom Video Track layer will display a "visible"  icon again, and 
the tracks that are underneath the storyboard track will instantly become visible.
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Using Solo Mode with Video Tracks
If you have several video tracks and only want one of them to be visible, you can enable solo mode on it.

If solo mode is enabled on at least one video track, only the video tracks with solo mode enabled will be visible. If 
solo mode is not enabled on any video track, then all video tracks will be visible. 

NOTE 

Hidden video tracks are never visible, even if solo mode is enabled on them.

How to use Solo Mode with video tracks

 1. In the Timeline view, click the Solo Mode   button of a video track.

The Solo Mode button will become active . From now on, only the clips in this video track will be 
visible in the Stage and Camera views. 

 2. If you want more than one video track to remain visible, you can activate the Solo Mode  button 
on other video tracks. The clips in all the video tracks with Solo Mode enabled will remain visible and 
the other clips will be hidden.

 3. To remove a track from Solo Mode, click on its Solo Mode  button again to disable it for that track.

 4. When you want to stop using solo mode, click on the Solo Mode  button of all video tracks on 
which it is enabled, until Solo Mode is no longer enabled on any video track.
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Locking Video Tracks
By default, the clips in your video tracks follow the timing changes made to your animatic. For example, if you 
extend the duration of a panel, this moves all subsequent panels, and the video clips after this panel will also be 
moved to follow the movement of subsequent panels. 

If you want to prevent this from happening, you can lock your video tracks. Locking a track will also prevent you 
from making any unwanted changes to the clips in the tracks. When a track is locked, it is impossible to move, 
delete, add or edit video clips in this track.

How to lock or unlock a video track

 1. In the Timeline view, just right of the name of the video track you want to lock, click on the Lock / 
Unlock  button.

The Lock / Unlock button will display a "locked"  icon, and the track will appear cross-hatched to 
indicate that you can't make changes to it. 

 2. If you want to unlock the video track, click on its Lock / Unlock  button again.

The Lock / Unlock button will display an "unlocked"  icon, and you will be able to edit the video 
track again.

If none of your project's video tracks are locked, you can lock them all simultaneously. 

How to lock all audio tracks

 1. In the Timeline view, make sure that all video tracks are unlocked, or else, the Lock All Video Tracks 
command will be unavailable.

 2. In the top menu, select Storyboard > Tracks > Lock All Video Tracks.

If at least one video track is locked, you can unlock them all simultaneously. 

How to unlock all audio tracks at once

 1. In the Timeline view, make sure there is at least one locked video track. Otherwise, the Unlock All 
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Video Tracks command will be unavailable.

 2. In the top menu, select Storyboard > Tracks > Unlock All Video Tracks.
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Changing the Video Track Height
There are four sizes in which you can display video tracks: Mini, Small, Medium and Large. The size of a video 
track affects how much vertical space the video track takes in the Timeline view. You can adjust the display size 
of each track individually. By default, all video tracks are displayed in small size. 

Making video tracks smaller can be useful if you have many video tracks and want to see more video tracks in 
the Timeline view at the same time, without having to scroll up or down or to increase the amount of space the 
Timeline view takes in your workspace. Making video tracks Medium or Large allows you to see a thumbnail 
inside each video clip, making it easier to identify the clips visually as you work with them.

How to set the audio track size

 1. In the Timeline view, right-click anywhere on the video track, then select Track Size > Mini, Small, 
Medium or Large.

The height of the video track in the Timeline view is adjusted to the new setting. 
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About Video Clips
Video clips are image and movie files that you can add to the video tracks of your project, to display them in 
your animatic. 

If you import an image file as a video clip, it will create a clip that displays the still image for a set amount of time. 
If you import a movie file as a video clip, it will import the video and play it as is, over your animatic. However, if 
the movie file contains an audio track, it will be ignored by Storyboard Pro.

Just like sound clips must be stored in audio tracks, video clips must be stored in video tracks. They can be cued 
at any time in your animatic, and their beginning and ending can be trimmed off if needed.

Just like layers in a panel, video clips can be moved, resized and rotated, can have their opacity adjusted and 
can even be animated. However, contrary to layers in a panel, video clips are not affected by camera 
movements. 

Video clips are completely independent from the structure of your animatic: They can span over several panels, 
scenes or even over your entire animatic, and they can start and end in the middle of a panel. 

Video clips are not subject to 3D transformations. Hence, they cannot be moved back and forth across the 
depth of the stage. However, a video track can be put above or underneath the storyboard track. Clips in video 
tracks that are above the storyboard track will always appear over the artwork and objects in the storyboard, 
and clips in video tracks that are underneath the storyboard track will always appear behind them. 

NOTE 

Video clips are subject to certain limitations regarding their format. For more information, see About 
Video Clip Format on page 641.
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Importing Image and Video Clips
T-SBANIM-001-004

To add image or video clips to your animatic, you must import image or video files into a video track.

NOTE 

For information on supported video formats, see About Video Clip Format on page 641

How to add an image or video to a video track

 1. If you want to import clips into an existing video track, select the video track in which you want to 
import clips in the Timeline view. 

 2. Do one of the following:

 l In the top menu, select File > Import > Videos/Images as Clips.

 l Right-click on the video track in which you want to import clips, then select Import 
Videos/Images as Clips.

 l Right-click on the empty space below the tracks in the Timeline view, then select Import 
Videos/Images as Clips.

The Import Video Clips dialog box opens.

 3. Click on the Browse  button.

 4. In the file browser, locate and select the image or video file that you want to add to your project, 
then click on Open.

 5. In the Destination panel, select New Video Track if your project does not have a video track or if you 
want to import the clip into a new video track, or Current Video Track if you want to import it into 
the currently selected video track. 

655

Storyboard Pro 6. User Guide                          



Chapter 15: Image and Video Clips

 6. If you have selected an image, set the desired duration of the still image in the Clips Duration field. 
This determines the amount of frames the image clip will span over in the timeline. For example, if 
the frame rate of your project is 24 frames per second, and you want the image to span for 1 second, 
set the Clips Duration to 24. 

 7. If you selected the Current Video Track option, and if other video clips are present in the target 
video track, specify what will happen if the imported  clip is too long and spans over another existing 
clips by selecting an Import Rule:

 l Overwrite Existing Clips: If there are existing video clips where the imported clips are 
supposed to be added, the existing clips will be overwritten. 

 l Fill Next Available Frames: If there are existing video clips where the new clips are supposed 
to be added, the clips will be trimmed just before the existing clips.

 8. Click OK. 

The video clip is added to your project, in its target video track. 
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Deleting Video Clips
You can delete video clips from a video track.

How to delete one or several video clips

 1. In the Timeline view, select the clip or clips you want to delete by doing one of the following:

 l To select a single video clip, click on it.

 l To select a series of video clips, draw a rectangle around them by clicking just outside of the 
clips you want to select, then dragging the mouse cursor all the way to the last clip you want 
to select:

 l To select a series of video clips, you can also click on the first clip you want to select, then, 
while holding the Shift key, click on the last clip you want to select. This will select all clips 
between the two clips you clicked on, inclusively.

 l To select several video clips, press and hold Ctrl (Windows/Linux) or ⌘  (macOS), then click 
on each clip you want to select. 

 2. Do one of the following:

 l Right-click on the selection and select Delete Selected Clips.

 l Press Del (Windows) or Backspace (Mac OS X).
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Moving Video Clips
You can move one or several video clips, even if they're on different video tracks, at the same time. You can 
move them horizontally to change their cue time in the animatic, or vertically to move them from one video 
track to another video track.

How to move video clips

 1. In the Timeline view, select the clip or clips you want to move by doing one of the following:

 l To select a single video clip, click on it.

 l To select a series of video clips, draw a rectangle around them by clicking just outside of the 
clips you want to select, then dragging the mouse cursor all the way to the last clip you want 
to select:

 l To select a series of video clips, you can also click on the first clip you want to select, then, 
while holding the Shift key, click on the last clip you want to select. This will select all clips 
between the two clips you clicked on, inclusively.

 l To select several video clips, press and hold Ctrl (Windows/Linux) or ⌘  (macOS), then click 
on each clip you want to select. 

 2. Click on one of the selected clips and drag the selection to the position where you want to move 
them. 

While dragging, a black text box displays the new starting time of the selected clip, along with the 
amount of seconds and frames by which you're moving the clip.
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Adjusting the In and Out Points of Video Clips
You can trim off the beginning and the end of video clips so as to only play a specific part of the clip in your 
animatic. This is also referred to as changing the in and out points of a clip. 

You can trim off parts of a clip in the Timeline view simply by dragging one of its left or right edges towards its 
middle. If you trim off part of a video clip, the trimmed off part does not get deleted. At any time, you can extend 
the edges of the clip back to their original position to restore the parts that were trimmed off. 

Since you can import images as video clips, and that, contrary to movies, images do not have a set length, you 
can use the same method to adjust the cue time and length of image clips in video tracks. While you cannot 
extend a video clip's length beyond the movie file's original length, you can extend an image clip's length 
indefinitely, since it an image clip simply displays the still image during its entire duration. 

How to adjust the In and Out points of a video clip

 1. Do one of the following:

 l Click on the left edge of the video clip, then drag it towards the right to set the In point to 
later within the clip. 

As you move the cursor, the beginning of the movie gets cut out from the clip. A black text 
box indicates the new length of the clip, as well as the length of the part of the clip you are 
cutting out.

NOTE 

If you are adjusting an image clip, you can also drag the edge towards the left and 
extend its length.

 l Click on the right edge of the video clip, then drag it towards the left to set the Out point to 
earlier within the clip.

As you move the cursor, the end of the original movie is cut out from the clip. A black text box 
indicates the new length of the clip, as well as the length of the part of the clip you are 
cutting out.
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NOTE 

If you are adjusting an image clip, you can also drag the edge towards the right 
and extend its length.

NOTE 

Trimming a video clip does not delete the part of the video that is trimmed off. At any time, you 
can click on the edge of the video clip and drag it back to its original position to restore the part 
of the clip that you trimmed off.                 
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Snapping Video Clips
When the Snapping option is enabled, when you drag and drop a video clip, the beginning and end of the clip 
will snap against the beginning and end of panels as well as against the timeline cursor.

Likewise, when you adjust the in point or the out point of a video clip while snapping is enabled, it will also snap 
against the beginning and end of panels and against the timeline cursor. 

How to enable or disable snapping

 1. Do one of the following:

 l At the bottom-left of the Timeline view, click on the Snapping  button. 

 l Right-click the Timeline view and select Snapping.

NOTE 

While dragging a clip, you can temporarily override whether snapping is enabled by holding 
the Shift key.

661

Storyboard Pro 6. User Guide                          



Chapter 15: Image and Video Clips

Copying and Pasting Video Clips
You can copy one or several clips from your project's video tracks and paste them somewhere else in your 
project's video racks.

How to copy sound clips

 1. In Timeline view, select one or multiple video clips by doing one of the following:

 l To select a single video clip, click on it.

 l To select a series of video clips, draw a rectangle around them by clicking just outside of the 
clips you want to select, then dragging the mouse cursor all the way to the last clip you want 
to select:

 l To select a series of video clips, you can also click on the first clip you want to select, then, 
while holding the Shift key, click on the last clip you want to select. This will select all clips 
between the two clips you clicked on, inclusively.

 l To select several video clips, press and hold Ctrl (Windows/Linux) or ⌘  (macOS), then click 
on each clip you want to select. 

 2. Do one of the following to copy the selected clips:

 l In the top menu, select Edit > Copy Clips.

 l Press Ctrl + C (Windows) or ⌘  + C (Mac OS X).

 3. In the Timeline view, select the video track in which you want the clips to be pasted.

 4. Click and drag on the red timeline cursor to move it to the position in time where you want the clips 
to be pasted.

 5. Do one of the following to paste the copied clips:

 l In the top menu, select Edit > Paste Clips.

 l Press Ctrl + V (Windows) or ⌘  + V (Mac OS X).

The copied clips are pasted on the selected track, right after the timeline cursor. 
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NOTES 

 l If a video clip is already present on a destination video track, the pasted clip will overwrite 
the video clip on the destination track.

 l If video clips are copied from multiple tracks, they will be pasted on multiple tracks as well. If 
needed, Storyboard Pro will create additional video tracks to preserve the differences in 
tracks between the copied video clips. 
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Splitting a Video Clip
You can separate a video clip into two video clips, allowing you to cue different parts of the video at different 
points in the timeline. 

How to split a video clip

 1. In the Timeline view, select the video clip you want to split.

 2. Move the timeline cursor to the frame at which you want to split the clip.

 3. Do one of the following:

 l From the top menu, select Clips > Split Clip at Current Frame

 l In the Timeline view, right-click anywhere on the video track and select Split Clip at Current 
Frame.

The video clip is split. You can now move both parts independently.

NOTE 

When splitting a video clip with animation keyframes, the animation keyframes will be split 
between the two resulting clips so that both parts preserve their respective part of the 
animation.
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Displaying Thumbnails
You can display the thumbnails of your video clips by increasing the display size of their video track to Medium 
or Large. 

How to set the audio track size

 1. In the Timeline view, right-click anywhere on the video track for which you want to display the clip's 
thumbnails, then select Track Size > Medium or Large.

Each clip in the selected video track will display a thumbnail near its left edge.
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Transforming Video Clips
Just like with drawing layers, you can apply geometric transformations to video clips by selecting them and 
manipulating them in the Stage view using the Layer Transform tool. 

NOTE 

Even if you are working on a 3D scene, video clips can only be subjected to 2D transformations and 
cannot be positioned on the Z-axis. However, you can make video clips appear over or underneath 
the artwork in your storyboard by changing their order in the Timeline view—see Reordering 
Video Tracks on page 646.

How to make transformations on a video clip

 1. In Tools toolbar, select the Layer Transform  tool.

 2. In the Timeline view, select on the clip you want to transform. 

In the Stage or Camera view, the controls of the Transform tool appear over the video clip.      

NOTE 

You cannot transform more than one clip at a time.

 3. Do one of the following:                                              

 l To move the clip, position the cursor over the clip. When the move  mouse cursor appears, 
click and drag on the clip to move it.             

666



TIPS 

 l You can also nudge the selection by using the arrow keys on your keyboard.

 l You can also enter specific coordinates in the Horizontal Offset  and 
Vertical Offset  fields in the Tool Properties view.

 l To resize the clip, position the cursor over one of the square points  at the corners or in the 
middle of the edges of the bounding box. When you see the scale  cursor appear, click and 
drag to resize the clip.             
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TIPS 

 l You can preserve the horizontal and vertical proportions of the selection by 
holding the Shift key.

 l You can also enter specific scale percentages in the Horizontal Scale  and 
Vertical Scale  fields in the Tool Properties view.

 l To rotate the clip, position the cursor just outside of one of the corners of the bounding box. 
When you see the rotate  cursor appear, click and drag to rotate the clip.             

TIPS 

 l You can rotate the artwork in 15° increments by hold the Shift key.

 l You can also enter a specific angle in degrees in the Angle  field of the Tool 
Properties view.

 l You can also rotate the clip in 90° increments by clicking on the Rotate 90 
CW  button in the Tool Properties view to rotate it 90° clockwise, or on the 
Rotate 90 CCW  button to rotate it 90°  counterclockwise. 

 l By default, the pivot point around which the clip is rotated and scaled is at the center of the 
clip. To temporarily move the pivot point elsewhere, move the mouse cursor over the round-
shaped pivot  in the middle of the clip. When the mouse cursor becomes , click and drag 
the pivot to move it.                             
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 l To flip the clip horizontally, click on the Flip Horizontally  button in the Tool Properties 
view.

 l To flip the clip vertically, click on the Flip Vertically  button in the Tool Properties view.
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Change the Opacity of Video Clips
You can set the opacity of individual video clips. This allows you to make some clips appear semi-transparent 
over the storyboard, so that they do not completely obstruct the artwork in your panels. 

How to change the opacity of a video clip

 1. In Timeline view, select the clips for which you want to set the opacity by doing one of the following:

 l To select a single video clip, click on it.

 l To select a series of video clips, draw a rectangle around them by clicking just outside of the 
clips you want to select, then dragging the mouse cursor all the way to the last clip you want 
to select:

 l To select a series of video clips, you can also click on the first clip you want to select, then, 
while holding the Shift key, click on the last clip you want to select. This will select all clips 
between the two clips you clicked on, inclusively.

 l To select several video clips, press and hold Ctrl (Windows/Linux) or ⌘  (macOS), then click 
on each clip you want to select. 

 2. Right-click on the video track and select Change Clips Opacity.

The Clips Opacity dialog appears.

 3. In the Clips Opacity dialog, type in a value between 0 and 100, where 0 is completely transparent 
and 100 is completely opaque.

 4. Click OK. 

The opacity of the selected clips is changed to the selected value. 
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About Video Clip Animation
It is possible to animate image and video clips. Just like with layers in a panel, video clips can move, rotate and 
change in size as the animatic plays out. You can also taper the timing of the animation to make it speed up or 
slow down with time. 
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Animating Video Clips
To animate a video clip, you must create at least two keyframes on the clip. Then, you can change the position, 
angle and size of the clip on each keyframe, and Storyboard Pro will interpolate the clip's position, angle and 
size between keyframes. 

How to animate a video clip

 1. In Tools toolbar, select the Layer Transform  tool.

 2. In the Timeline view, select on the clip you want to transform. 

NOTE 

You cannot transform more than one clip at a time.

 3. In the Timeline view, move the timeline cursor to the frame where you want to create the first 
keyframe of your animation.

 4. In the Tool Properties view, click on the Add Keyframe  button.

A keyframe is added on the clip, at the current frame.

 5. In the Stage or Camera view, manipulate the clip so that it is in the position, angle and scale you 
want it to be at the beginning of your animation—see Transforming Video Clips on page 666.

 6. In the Timeline view, move the timeline cursor to the point where you want to have your second 
keyframe.

 7. In the Tool Properties view, click on the Add Keyframe  button. 

A second keyframe is created on the video clip. A line going from the first keyframe to the second 
keyframe indicates that the clip is animated from the first to the second keyframe.

 8. In the Stage or Camera view, position the clip where you want it to be in the second keyframe.

 9. Create keyframes and position your video clip in each keyframe until your animation is completed.
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 10. If you need to move a keyframe to another position in time, simply click and drag it to the desired 
position.

 11. To add ease-in and ease-out to the timing of the animation, see Adding Ease-In and Ease-Out to a 
Video Clip Animation on page 674.

 12. If you want to delete a keyframe, move the Timeline cursor to the exact position of the 
keyframe. Then, in the Tool Properties view, click on Delete Keyframe .

 13. If you want to reset the clip to its original position on a keyframe, move the timeline cursor to the 
position of the keyframe. Then, in the Tool Properties view, click on Reset Keyframe .

 14. To test your animation, move the timeline cursor at the beginning of the clip. Then, in the Playback 
toolbar, click on the Play button.
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Adding Ease-In and Ease-Out to a Video Clip Animation
By default, when you animate a video clip, it will move from its position in one keyframe to its position in the 
next keyframe  by progressing towards it at a constant pace, then stop moving abruptly. If you want it to speed 
up as it starts moving and to slow down before it stops, you can do this by adding ease-in and ease-out to its 
animation. Adding ease-in to an animation will make it start slowly and gain in speed as it goes. Adding ease-
out to an animation will make it slow down before it stops.

You can set the ease-in and ease-out for an animation in the Tool Properties view. 

How to add ease-in and ease-out to a clip animation

 1. In the Tools toolbar, select the Layer Transform  tool.

 2. In the Timeline view, select the clip for which you want to add ease-in and ease-out

The motion path for the selected clip's animation will appear in the Stage and Camera views.
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 3. In the Timeline view, move the timeline cursor between the first and last keyframe of the clip 
animation to which you want to add ease.

 4. In the Tool Properties view, enter the desired length of the ease-in in the Ease In field in the 
H:MM:SS:FF format, where H means hours, MM means minutes, SS means seconds and FF means 
frames. The longer the length of the ease-in, the smoother it will be.

 5. Enter the desired length of the ease-out in the Ease Out field, in the same format. The longer the 
length of the ease-out, the smoother it will be.

As you make adjustments to the ease-in and ease-out of the animation, the notches in the motion 
path change place, giving you an idea of how the ease is affecting the timing of the movement.

 6. To test your animation, move the timeline cursor to a point just before the start of the animation. 
Then, in the Playback toolbar, click on the Play  button.
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Moving Video Clip Keyframes
After you have created keyframes in a video clip, you can change their position in time so as to adjust the 
starting time, length and pace of the clip animation.

How to move video clip keyframes

 1. In the Timeline view, select one or multiple keyframes in a clip by doing one of the following:

 l To select a single keyframe, click on it.

 l To select a sequence of several keyframes from the same clip, click on the first keyframe in the 
sequence you want to select. Then, while holding the Shift key, click on the last keyframe in 
the sequence you want to select. Both keyframes you clicked on as well as every keyframe 
between them will be selected. 

 l To select all keyframes in the clip, double click on the clip's animation keyframes track. 

Each selected keyframe will be highlighted in blue.

 2. Click and drag the selected keyframes towards the left to move the animation earlier in the clip, or 
towards the right to move the animation later in the clip.
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Copying and Pasting Video Clip Animation Keyframes
Just like you can copy video clips, you can also copy specific keyframes inside video clips. You can copy a 
selection of one or several keyframes and paste it at a different time on the same clip or on a different clip. 
When copying and pasting a single keyframe, the position, angle and size of the clip, is copied. When copying 
and pasting several keyframes, the position, angle and size of the clip in each keyframe as well as the animation 
between those keyframes is copied. 

How to copy and paste video clip keyframes

 1. In the Timeline view, select one or multiple keyframes in a clip by doing one of the following:

 l To select a single keyframe, click on it.

 l To select a sequence of several keyframes from the same clip, click on the first keyframe in the 
sequence you want to select. Then, while holding the Shift key, click on the last keyframe in 
the sequence you want to select. Both keyframes you clicked on as well as every keyframe 
between them will be selected. 

 l To select all keyframes in the clip, double click on the clip's animation keyframes track. 

Each selected keyframe will be highlighted in blue.

 2. Do one of the following to copy the selected keyframes:

 l In the top menu, select Edit > Copy Clips.

 l Press Ctrl + C (Windows) or ⌘  + C (Mac OS X)

 3. Click and drag on the red timeline cursor to move it to the position in time where you want the 
keyframes to be pasted. Make sure the timeline cursor is inside the clip in which you want to paste 
the keyframes. 

 4. Click on the clip in which you want to paste the keyframes.
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 5. Do one of the following to paste the copied keyframes:

 l In the top menu, select Edit > Paste Clips.

 l Press Ctrl + V.

The keyframes are pasted in the selected clip, at the position where the timeline cursor is. 
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Chapter 16: Transitions
T-SBANIM-005-002

By default, transitions between scenes are defined as cuts; the action in the panel at the end of a shot finishes 
and immediately displays the next scene. In Storyboard Pro, you can add one of two custom transitions 
between scenes: Wipe or Dissolve.

Dissolve
The Dissolve transition is the typical cross-dissolve transition effect. The images gradually fade in and out to a 
smooth scene transition.

Edge Wipe
By default, the Edge Wipe will pass from one scene to the other with a wiping motion from left to right. It is 
possible to customize the effect to change the direction of the wiping motion.

Clock Wipe
By default, the Clock wipe will pass from one scene to the other with a circular clockwise wiping motion. It is 
possible to customize the direction of the wipe as well as the starting angle.
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Slide
By default, the Slide transition will pass from one scene to the other by translating the next scene panel from 
the right side of the camera frame. It is possible to customize the angle and direction.
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Adding Transitions
T-SBANIM-005-003

A transition is inserted between scenes (shots).

How to add a transition

 1. In the Thumbnails or Timeline view, select the first of the two scenes between which you want to 
add a transition. For example, if you want to add a transition between scenes 2 and 3, select any 
panel from scene 2. 

 2. Do one of the following:

 l From the Storyboard toolbar, click the New Transition button.

 l Select Storyboard > Add Transition.

 l Right-click the scene thumbnails and select Add Transition.

 l From the Storyboard toolbar, click the New Transition button.

 l Select Storyboard > Add Transition.

682



 l Right-click the scene thumbnails and select Add Transition.

 3. Click on the transition to select it.

 4. Open the Panel view. When a transition is selected, the Panel view displays its properties and 
allows you to change them.

 5. In the Type drop-down, select which type of transition you want to use:

 l Dissolve: Fades the first scene out to black, then fades the second scene in from black.

 l Edge Wipe: Wipes the first scene out with the second scene, with a straight line going all the 
way across the screen. The angle of the line can be customized.

 l Clock Wipe: Wipes the first scene out with the second scene, with a line going from the 
centre of the screen to its edge, which rotates 360 degrees to cover the whole screen. The 
initial angle and direction of the line can be customized.

 l Slide: When set to Slide In, this makes the second scene slide from the edge of the screen 
over the first scene. When set to Slide Out, this makes the first scene slide towards the edge 
of the screen, leaving the second scene on the screen as if it had always been behind it. The 
angle at which the scene slides in or out can be customized. 

 6. Determine the length of the transition by doing one of the following:

 l In the Timeline view, click and drag the right edge of the transition towards the right to 
extend it, or towards the left to shorten it.

 l In the Panel view, right of the duration field, click on the Up  arrow to extend the transition 
by 1 frame, or on the Down  arrow to shorten the transition by one frame.                               

 l In the duration field of the Panel view, type in the duration of the transition in the 
H:MM:SS:FF format, where H means hours, M means minutes, S means seconds and F means 
frames
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NOTE 

When you extend a transition, the ensuing scenes are rippled backwards, and when 
you shorten a transition, the ensuing scenes are rippled forward. This is because the 
scenes before and after the transition overlap during the transition. This means that the 
scene after the transition starts while the scene before the transition has not ended yet, 
which shortens the length of the project. 
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Deleting Transitions
T-SBANIM-005-004

How to delete a transition

 1. Select a transition to remove.

 2. Do one of the following:

‣ In the Storyboard toolbar, click the Delete Transition  button.

‣ Right-click the transition and select Delete Transition.

‣ Select Storyboard > Delete Transition.

‣ Press Delete.
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Changing the Transition Type
T-SBANIM-005-005

By default, the transition is a dissolve, but you can easily change it to an edge or clock wipe by selecting the 
transition, and either double-clicking it or changing it in the Panel view. 

How to change the transition type

 1. In the Timeline or Thumbnails view, select the transition.

 2. Do one of the following:

 l In the Panel view, select Edge Wipe, Clock Wipe or Dissolve from the Type menu.

 l In the Timeline view, double-click the selected transition in the Timeline view to change the 
transition type between Dissolve, Edge Wipe, and Clock Wipe.

How to change the starting angle of a Clock Wipe transition

 1. In the Timeline or Thumbnails view, select the Clock Wipe transition.

 2. In the Panel view, set the starting angle by doing one of the following:

 l Click the Direction knob.

 l Type in a value in the text field.
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 3. In the Direction menu, select the wipe direction: Clockwise or Counterclockwise.
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Changing the Transition Duration
T-SBANIM-005-006

You can also use the Panel view to change the duration of the transition.

How to change the transition duration

 1. In the Timeline view, select a transition.

 2. Do one of the following:

 l Position the cursor on the left or right side of the transition and drag to lengthen or shorten.

 l In the Panel view, use the duration field to set the desired value.

 l Select Storyboard > Change Transition Duration and enter a new duration in frames.
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Chapter 17: Libraries
T-SBADV-010-001

Using libraries, you can share and reuse any elements you create in Storyboard Pro. With the library view, you 
can store several different elements such as characters, sets, props, layers, panels, audio files, video files, 3D 
models, animations and camera movements.

Libraries are stored on your hard drive and the same library can be used in several projects. Hence, you can use 
libraries to share assets between your projects. 

You can create templates simply by selecting assets in your project, such as layers, panels and clips, then 
dragging them into a library in the Library view. Likewise, you can import a template's content by dragging it 
from a library into its intended destination in your project. 
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About Library Folders
T-SBADV-010-002

By default, there are four libraries available in the Library view: 

 l 3D Models: The library in which all 3D models used by your projects are stored. This library is exclusive 
to the current project—see About 3D Objects on page 548.

 l Shared: The library in which all shared drawings in your project are stored. This library is exclusive to the 
current project—see Sharing Drawings on page 426.

 l Global: The default library to use for sharing assets between projects. This library is stored in the Toon 
Boom Storyboard Pro Library sub-folder of your Documents folder. 

 l Templates: A library of sample drawings bundled with Storyboard Pro. 

Hence, the go-to library for creating templates is the Global library. However, as you will probably create a 
large number of templates, you might eventually need to organize the assets into different libraries. For 
example, you may want to create libraries for characters, props, backgrounds, panels, sound clips, and any 
other type of asset your project needs to re-use. You can add as many libraries as you wish to the Library view, 
each of which can store different types of templates. 

Each library in the Library view corresponds to a folder in your workstation's file system. Since those folders can 
contain sub-folders, and the Library view allows you to browse sub-folders in a library, you can also organize 
the templates inside your libraries by storing them in different sub-folders.
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Creating Libraries
T-SBADV-010-003

There are two ways to create Library folders. 

 l Using Storyboard Pro’s interface

 l Directly through your operating system

To create a library using your operating system, create a new folder with a relevant name in the location where 
you want the library to be stored. This can be opened in Storyboard Pro when you require it—see Adding 
Libraries on page 694Adding Libraries on page 694.

Template libraries need to be organized. You can create different subfolders on your hard drive or directly in 
the Library view so that you can gain easy access to your assets.

How to create a library from Storyboard Pro

 1. In the Library view, right-click in the Library List section and select Open Library.

The Browser window opens.

 2. Browse for the location where you want to store your new library in your computer.

 3. Click New Folder.

 4. Name the new library with a relevant name and click Select Folder.

The new library appears in the Library List section.

How to create a folder

 1. In the Library view’s left side, select the library folder in which you want to create subfolders.

 2. Right-click on the selected library and select New Folder.

The new subfolder is added to the Library (although not immediately visible as it is collapsed in its 
parent folder). Click the root library folder containing the new folder and then click the plus (+) sign 
to expand it. The new subfolder appears.
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Adding Libraries
T-SBADV-010-004

You can open any folder on your hard drive or network as a library. Opening a library means linking the folder 
to your Library view. You only need to open the library once. The library folder is available every time you open 
the application until you decide to close the library and unlink it.

TIP 

You can add a folder that contains images, sound files or video files to your libraries. This will allow 
you to quickly import those assets into your project. You can drag and drop images directly into the 
Stage or Camera view, and you can drag and drop sound files and video files into audio or video 
tracks in the Timeline view. 

How to open a library

 1. In the Library view, right-click in the Library List section and select Open Library.

The Browser window opens.

 2. Browse to the location of the library folder.

 3. Select the folder and click OK.

The new library appears in the Library List section.
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Renaming Folders
T-SBADV-010-005

Once you add a folder, you can rename it. This also renames the folder on your hard drive.

How to rename a folder

 1. In the Library view’s left side, select the folder to rename.

 2. Right-click on the selected library and select Rename Folder.

 3. Rename the selected folder.

 4. Press Enter/Return to validate the operation.
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Closing Libraries and Deleting Folders
T-SBADV-010-006

If you want to remove a folder from your libraries, you must first understand the difference between a library 
and a sub-folder in a library. A library is a folder added at the root of your libraries list, and it is indicated by a 

 icon. A sub-folder is inside one of the libraries in the libraries list, and it is indicated by a  icon.

You can close a library , which will remove it from the Library view, but not from your hard drive. However, 
you cannot close a sub-folder . All the sub-folders in a library are always available in the Library view. 
However, you can delete sub-folder . This however will delete it from your hard drive permanently. 

Hence, in summary:

 l You can close a library , which will remove it from the Library view but not from your hard drive, but 
you cannot outright delete a library from Storyboard Pro. 

 l You can delete a library sub-folder , which will permanently remove it from your hard drive, but you 
cannot simply close a library sub-folder. 

Hence, if you find that some sub-folders are incumbering your library, but you don't want to lose their content, 
it would be best to open this library in a file browser, and move those folders somewhere else where you can 
retrieve them later.

NOTE 

You cannot close the following default libraries: 3D Models, Shared and Global.

IMPORTANT 

You can undo deleting a library sub-folder up until you close the project or exit the application. After 
that, the deleted files will be gone permanently and you will not be able to retrieve them.

How to close a library

 1. In the left pane of the Library view, select the library folder  that you want to remove.

 2. Right-click on the library and select Close.

How to delete a library sub-folder

 1. In the left pane of the Library view, browse to and select the library sub-folder  that you want to 
delete.
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 2. Do one of the following:

 l Right-click the selected library and select Delete Folder. 

 l Press Del.

A confirmation prompt will appear. 

If you are sure you want to permanently delete all the content of the selected folder from your hard 
drive, click Yes. Otherwise, click No.
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Refreshing Libraries
T-SBADV-010-007

If you update the content of your libraries through your operating system, you must refresh the library folders in 
the Library view.

How to refresh a library

 1. In the Library view’s left pane, right-click and select Refresh or press F5.
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About Templates
T-SBADV-010-009

If you want to reuse artwork, layers, panels or camera motions from your project in the same or other projects, 
you can create a template out of it. A template is a package containing a copy of the assets you stored in it, and 
which can easily be copied into any project as many times as needed.

Storyboard Pro templates can be made with the following types of assets:

Template Type Content

Layer The artwork, 3D models, layer animation, opacity of the layer or layers.

Panel
The length of the panel, its camera movements, all of its layers and 3D models, their layer 
animation and their opacity 

Video clip The video file, its In and Out points, its animation and its opacity

Sound clip The sound file, its In and Out points and its volume envelope

Camera 
movement

Camera animation keyframes

Layer 
animation

The layer's artwork and its animation keyframes 

NOTE 

When you create a template, it is not linked to the original project. A copy of the assets are created 
for the template, and you can modify the original project without affecting your template. Likewise, 
when you import a template into your project, it is copied into your project. Making changes to the 
template will not affect its imported copies, and you can make changes to the imported assets 
without affecting the template.
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Creating Templates
T-SBADV-010-010

You can create a template out of many assets in your project. You can create a template out of one or several 
panels, one or several layers in a panel, a sound clip, a video clip and even animation keyframes.

Creating a template is as simple as selecting the assets you want to store in the template, then dragging and 
dropping them into a library in the Library view. 

How to create a template from one or several layers using the Stage or Camera view

 1. In the Library view, select a folder in which you want to store your template.

 2. In the Layer panel of the Stage or Camera view, select one or several layers. To select several layers, 
do one of the following:

 l While holding Shift, click on the first layer you want to add to your selection, then on the last 
layer you want to add to your selection. All layers in-between will be part of the selection, 
inclusively.

 l While holding Ctrl (Windows) or ⌘  (macOS), click on each layer you want to add to your 
selection. 

 3. Drag and drop the selection into the right pane of the Library view.

 4. In the Rename dialog box, enter the name for your new template.

NOTE 

You can also rename a template after it is created by right-clicking on it and selecting Rename.

How to create a template of one or several panels using the Thumbnails view

 1. In the Library view, select a folder in which you want to store your template.
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 2. In the Thumbnails view, select one or several panels. To select several panels, do one of the 
following:

 l While holding Shift, click on the first panel you want to add to your selection, then on the last 
panel you want to add to your selection. Every panel in-between will be part of the selection, 
inclusively.

 l While holding Ctrl (Windows) or ⌘  (macOS), click on each panel you want to add to your 
selection.

 3. Click and drag on the drag and drop handle  of one of the selected panels, then drop the selection 
into the right pane of the Library view. 

 4. In the Rename dialog box, rename the new template.

NOTE 

You can also rename a template after it is created by right-clicking on it and selecting Rename.

How to create a template of one or several panels using the Timeline view

 1. In the Library view, select a folder in which you want to store your template.

 2. In the Timeline view, select one or several panels. To select several panels, do one of the following:

 l While holding Shift, click on the first panel you want to add to your selection, then on the last 
panel you want to add to your selection. Every panel in-between will be part of the selection, 
inclusively.
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 l While holding Ctrl (Windows) or ⌘  (macOS), click on each panel you want to add to your 
selection.

 3. Drag and drop the selected panels into the right pane of the Library view.

 4. In the Rename dialog box, enter the name for your new template.

NOTE 

You can also rename a template after it is created by right-clicking on it and selecting Rename.

How to create a template from a video or sound clip

 1. In the Library view, select a folder in which you want to store your template.

 2. In the Timeline view, select a video or sound clip.
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 3. Drag and drop the selected clip into the right pane of the Library view.

 4. In the Rename dialog box, enter the name for your new template.

NOTE 

You can also rename a template after it is created by right-clicking on it and selecting Rename.

How to create a camera movement template

 1. In the Timeline view, select the scene containing the camera movement. 

The camera's animation keyframes will appear in the Camera track of the Timeline view.

 2. In the Camera track of the Timeline view, select the animation keyframes you want to store in your 
template:                     

 l To select all the keyframes in the animation, double-click on one of the keyframes or on the 
space between one of the keyframes.

 l To select a series of keyframe, click on the first keyframe in the series then, while holding 
Shift, click on the last keyframe in the series.
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 l To select each keyframe individually, click on the first keyframe you want to select then, while 
holding Ctrl, click on each keyframe you wish to select.

 3. Do one of the following to copy the keyframes to the clipboard. 

 l In the top menu, select Edit > Copy Camera Keyframes.

 l Press Ctrl + C (Windows) or ⌘  + C (Mac OS X).

 4. In the Library view, select the folder in which you want to store your template.

 5. Do one of the following to paste the keyframes into a new template:

 l In the top menu, select Edit > Paste.

 l Press Ctrl + V (Windows) or ⌘  + V (Mac OS X).

 6. In the Rename dialog box, enter the name for your new template.

NOTE 

You can also rename a template after it is created by right-clicking on it and selecting Rename.

How to create a layer animation template

 1. In the Timeline view, select the panel containing the animation.

 2. In the Layer list of the Stage or Camera view, select the layer containing the animation.

The layer's animation keyframes will appear in the Layer track of the Timeline view.

 3. In the Layer track of the Timeline view, select the animation keyframes you want to store in your 
template:                     

 l To select all the keyframes in the animation, double-click on one of the keyframes or on the 
space between one of the keyframes.

 l To select a series of keyframe, click on the first keyframe in the series then, while holding 
Shift, click on the last keyframe in the series.
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 l To select each keyframe individually, click on the first keyframe you want to select then, while 
holding Ctrl, click on each keyframe you wish to select.

 4. Do one of the following to copy the keyframes to the clipboard. 

 l In the top menu, select Edit > Copy Layer Keyframes.

 l Press Ctrl + C (Windows) or ⌘  + C (Mac OS X).

 5. In the Library view, select the folder in which you want to store your template.

 6. Do one of the following to paste the keyframes into a new template:

 l In the top menu, select Edit > Paste.

 l Press Ctrl + V (Windows) or ⌘  + V (Mac OS X).

 7. In the Rename dialog box, enter the name for your new template.

NOTE 

You can also rename a template after it is created by right-clicking on it and selecting Rename.
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Importing Templates
T-SBADV-010-012

There are several ways you can import templates in your project. You can insert a panel template between two 
existing panels in the Thumbnails and Timeline view. You can import a template's layers into a panel by 
dragging it into the Stage or Camera view or over a panel's thumbnail in the Thumbnails or Timeline view.

How to import a template's layers into a panel

 1. In the Thumbnails or Timeline view, select the panel in which you want to insert the template.

 2. In the Library view, select the template you want to import.

 3. Drag and drop the template into the Stage or Camera view:

 l To insert it between two specific layers, drop it between those layers in the Layer panel of 
the Stage or Camera view. 

 l If you want to insert it over all the other layers, you can drop it directly into the Stage or 
Camera view. 

NOTES 

 l You can also drag and drop a template over the thumbnail of any panel in the Thumbnails 
or Timeline view. When you do this, the template's layers are added to that panel.

 l You can also import a template made of a single panel into the Stage or Camera view. 
When you do this, all of the template's layers are added to the current panel. However, you 
cannot import a template made of multiple panels into the Stage or Camera view.

How to insert a panel template  between two panels in the Thumbnails view

 1. In the Library view, select the template you want to import.

 2. Drag and drop the selected template into the Thumbnails view, between the two panels where you 
want it to be inserted.
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NOTE 

If you are inserting the template between two scenes, you are able to choose whether the 
panel will beattached to the previous scene or the next scene, or whether it will be inserted 
into its own scene. This will depend on how close to either scene or to the gap between them 
you drop the template. As you move the panel around in the gap, a red line will indicate where 
the panel will end up. 

How to insert a panel template between two panels in the Timeline view

 1. In the Library view, select the template you want to import.

 2. Drag the selected template into the Timeline view, between the two panels where you want it to be 
inserted.
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NOTE 

If you are inserting the template between two scenes, you are able to choose whether the 
panel will be attached to the previous scene or the next scene, or whether it will be inserted 
into its own scene. This will depend on how close to either scene you drop the template. As you 
move the panel around the seam between the scenes, a green bracket will indicate where the 
panel will end up.

How to import a video or sound clip template

 1. In the Library view, select a video clip template or a sound clip template.

 2. Drag the selected template into the Timeline view, onto the track and at the exact frame where you 
want the clip to be cued. 

708



How to import a camera movement template

 1. In the Library view, select a camera movement template.

 2. Do one of the following:

 l Right-click on the template and select Copy.

 l In the top menu, select Edit > Copy.

 l Press Ctrl + C (Windows) or ⌘  + C (Mac OS X).

 3. In the Timeline view, select the scene where you want to import the camera movement.

 4. Click on the Camera track.

 5. Move the timeline playhead where you want the camera movement to begin. 

 6. Do one of the following:

 l In the top menu, select Edit > Paste Camera Keyframes.

 l Press Ctrl + V (Windows) or ⌘  + V (Mac OS X).

The camera keyframes are pasted at the position of the timeline playhead onto the Camera track.

709

Storyboard Pro 6. User Guide                          



Chapter 17: Libraries

How to import a layer animation template

 1. In the Library view, select a layer animation template.

 2. Do one of the following:

 l Right-click on the template and select Copy.

 l In the top menu, select Edit > Copy.

 l Press Ctrl + C (Windows) or ⌘  + C (Mac OS X).

 3. In the Timeline view, select the panel containing the layer on which you want to import animation.

 4. In the Layer panel of the Stage or Camera view, select the layer on which you want to import 
animation.

 5. In the Timeline view, click on the Layer track.

 6. Move the timeline playhead where you want the camera movement to begin. 

 7. Do one of the following:

 l In the top menu, select Edit > Paste Layer Keyframes.

 l Press Ctrl + V (Windows) or ⌘  + V (Mac OS X).

The animation keyframes are pasted at the position of the timeline playhead, onto the layer's 
animation track.
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Deleting Templates
T-SBADV-010-011

You can delete a template directly from the Library view. 

NOTE 

It is possible to undo deleting a template up until the point where you close your project or exit the 
application. 

IMPORTANT 

If you delete a template via your operating system's file browser, you might not be able to undo it 
unless the template is moved to your workstation's recycle bin / trash bin and you do not empty it. 

How to delete a template

 1. In the Library view, select the template to delete.

 2. Do one of the following:

 l Right-click and select Delete

 l Press Del.
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Browsing a Template's Content
A template created in Storyboard Pro is a folder with a file structure, in which you can find its assets. If you 
want to import a specific asset from a template, such as a drawing or a 3D model, you can browse the 
template's file structure in the library view by opening it as a folder instead of as a template. 

How to open a template as a folder

 1. In the Library view, select the template to open.

 2. Right-click the selection and select Open As Folder.

The template will appear as a subfolder in the current library, with the subfolder  icon.

 3. Click on the Expand  button of the subfolder to explore it. If you are familiar with Harmony, you will 
find that the template has a file structure similar to a Harmony scene, which contains the following 
folders:

 l audio: The audio clips that were included with the template, if any.

 l elements: Contains the folders in which the drawings and 3D models used by the template 
are stored. 

 l environment: If the template was created in Harmony Server, this directory will contain the 
assets used by this template that were sourced from its environment. Otherwise, it will be 
empty.

 l frames: A directory typically used for the rendered frames of a Harmony scene. Usually 
empty for templates.
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 l jobs: If the template was created in Harmony Server, this directory will contain the assets 
used by this template that were sourced from its job. Otherwise, it will be empty.

 l palette-library: The palettes used by the template. 

As you browse the template's folders, if you select a folder that contains assets that can be imported 
in Storyboard Pro, they will appear in the assets list to the right.

NOTE 

Even if the template is opened as a folder, it is still also available as a template in your library. 
You can undo opening the template as a folder by right-clicking on the template and selecting 
Open As Folder again.
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Generating Thumbnails
T-SBADV-010-013

When you display thumbnails in the Library view, Storyboard Pro generates a series of small images 
(thumbnails) for you. However, it is possible to generate template thumbnails manually.

By default the automatic option is enabled, which means the thumbnails in the Library view will be 
automatically generated. You can disable this option to prevent the thumbnails from being automatically 
generated. 

You can delete the thumbnails files from the Library view.

How to generate thumbnails

 1. In the Library view’s right side, select a template.

 2. Right-click and select Generate Thumbnails.

714



How to disable the automatically Generate Thumbnails preference

 1. Do one of the following:

 l Select Edit > Preferences (Windows) or Storyboard Pro > Preferences (macOS).

 l Press .

 2. Select the General tab.

 3. In the General section, select the Automatically Generate Thumbnails in Library option.

NOTE 

When you deselect the Automatically Generate Thumbnails in Library option, you can 
manually generate them.

How to delete thumbnails

 l In the Library view, right-click in the left section and select Delete Thumbnails.
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Searching Libraries
You can use the Quick Search   field to rapidly locate a particular template using a keyword contained in the 
template’s name.

How to search for a template

 1. In the Quick Search field, type a word or part of a word contained in the template’s name. You 
can select a folder in the Library’s List to limit the search to this specific library.

 2. Press Enter/Return to validate.

The first template found is selected and displayed along with the other templates contained in the 
same folder.

 3. Click the Right Arrow  button to find the next template containing the keyword, or on the 
Left Arrow   button to see the previous result.
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About Importing Files
Using the Library view, you can import several types of files and store them in a library folder as a template. 
Once you have these new templates, you can use them throughout your storyboard projects just like the regular 
ones.

You can import all sorts of files using the Library view. You can import bitmaps as well as vector-based images, 
audio files, Adobe Flash movie file (.swf), and templates (.tpl) files made in Harmony 9.2 or highe. This can be 
useful for importing backgrounds created in Harmony directly into your storyboard.

You can alsoimport four types of 3D files. When you import a 3D model, it is automatically added to the Library 
in the 3D Models folder according to its format.
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Importing Images
T-SBFND-008-012

You can import all sorts of image files and reuse them throughout your project as templates. You can import 
bitmap as well as vector-based images, which can be really handy. The supported image formats include: .ai, 
.pdf, .tvg, .pal, .scan, .sgi, . tga, .yuv, .omf, .psd, .png, .jpg, .jpeg, .bmp and .tif.

How to import an image file

 1. In the Library view, right-click a library folder and select Import Files. 

The browser window opens.

 2. Find and select an image file and click Open.

The selected file appears in the Library view as a .tpl file inside the selected library folder.
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Importing Audio Files
You can import three types of audio files, which you can drag in the Timeline view when creating your animatic 
project. The supported audio file formats are: .wav, .aif and .mp3.

How to import an audio file

 1. In the Library view, right-click a library folder and select Import Files. 

The browser window opens.

 2. Find and select your audio file and click Open.

The selected audio appears in the Library view as a .tpl file inside the selected library folder.
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Importing Flash Movies (SWF)
You can import an Adobe Flash movie file (.swf) into the Library view. The movie file will become a single layer 
template that contains the animation.  Only the first 20 first frames of the animation will be imported in the 
template. 

How to import an Adobe Flash movie file

 1. In the Library view, right-click a library folder and select Import Files. 

The browser window opens.

 2. Find and select your Adobe Flash Move file (.swf) and click Open.

The selected .swf  files appears in the Library view as a .tpl file inside the selected library folder.

NOTE 

You can preview the animation contained in the new template by using the preview section of 
the Library view—see Library View in the Reference Guide.
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Importing Harmony Templates
You can import template (.tpl) files made in Harmony 9.2 or higher into the Library. This can be useful for 
importing backgrounds created in Harmony directly into your storyboard.

NOTE 

Because Harmony is an animation software and Storyboard Pro is not, animated templates and 
templates of rigged puppets created in Harmony may not import properly. Templates with multiple 
layers will retain their layer structure, but cut-out puppets may be rendered as flat objects with 
stationary parts.

How to import a template created in Harmony

 1. In the Library view, right-click on the left side of the Library view, under all the existing folders and 
select Open Library.

A browser window opens.

 2. Search for the folder with the .tpl  file to import. That folder is considered the “Library” that you 
choose to open. Note that the .tpl  file itself is also a folder. Select the Library folder and not the 
Template folder. For example, the library may be the Toon Boom Stage Library (found in the My 
Documents folder on Windows) and the name of the template inside Enchanted_Forest.tpl.

An orange book icon appears on the left side of the Library view with the name of the folder that 
you selected. 

 3. Click the folder to display the templates on the right side of the Library view. The template 
thumbnails may take a moment to generate. 

If there were any subfolders in the root library folder, they will appear as grey books within the root 
library. You may need to expand the root library to see them. Click on one of these grey book 
subfolders to display its templates on the right side of the Library view.
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Importing 3D Objects
Before adding 3D objects to panels in your storyboard, you must first import them to your library.  When you 
import a 3D model, it is automatically added to the 3D Models library of your project, in the Library view. You 
can then drag and drop that 3D model to each panel in which you want to use it, without having to import it 
over and over again. 

Storyboard Pro supports the following types of 3D models:

 l Filmbox (.fbx)

 l 3DS Max (.3ds)

 l Wavefront OBJ (.obj)

 l Allembic (.abc)

 l Collada (.dae)

In addition to importing 3D objects into the 3D Models folder in the Library view, you can also open a folder 
containing 3D models as a library in the Library view. The models can then be dragged and dropped into the 
scene directly from that library. 

NOTE 

When a model is added to a panel from a library other than the 3D Models library, it is also added 
to the 3D Models library at the same time. 

How to import a 3D object into your project

 1. In the Library view, right-click on the 3D Models library folder, then select Import Files. 

 2. In the file browser, locate and select your 3D model, then click on Open.

The following prompt appears.

If you want, you can choose to import your model in its original format. Converting it to FBX will 
however make sure its textures are consolidated with the model in your project. 

 3. Click on OK.

The selected model appears in the 3D Models folder of the Library view. 
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NOTE 

If you delete a 3D model from the library, every instance of that model in the project will be 
deleted.

How to add a folder containing 3D models as a Library

 1. In the Library view, right-click in the list of libraries and select Open Library.

A file browser window opens. 

 2. In the file browser, browse for the folder that contains the 3D models that you want to use in your 
project. Those files should be .fbx, .abc, .osb, .3ds, or .obj files.

 3. Click on Select Folder.

The selected folder will appear in the list of libraries. 

 4. Select the folder you just added to the list of libraries.

Any files that can be imported into Storyboard Pro, including 3D models, templates and drawings 
that are located within this folder are listed in the list of items to the right.
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Chapter 18: Pitching the Storyboard
Storyboard Pro has a Pitch Mode workspace that was is created specifically for pitching a storyboard or 
concept to a group of people.

You can use the Pitch Mode workspace to add comments based on the given feedback. A special Comments 
layer can automatically be added to your drawing for making notes and corrections.

NOTE 

The Camera view displays your drawings, camera moves and transitions. You do not have access to 
your layer list in this mode. All layers that are enabled are shown.
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Accessing and Exiting the Pitch Mode Workspace
The Pitch Mode workspace can be accessed in the same way as other default workspaces, but you must exit 
the mode in a different way.

You can easily exit by using the Exit Pitch Mode button at the bottom of the screen. This is useful when in full 
screen mode and you can no longer access the menus at the top of the interface. 

How to access the Pitch Mode workspace 

Do one of the following:

 l In the View toolbar, click on the Pitch Mode  button.

 l From the Workspace toolbar, select Pitch Mode .

 l In the top menu, select Windows > Workspace > Workspace > Pitch Mode.

How to exit the Pitch Mode workspace

 l In the Control Panel view, click the Exit Pitch Mode button.

NOTE 

To exit the workspace, you can also switch to another workspace using the top menu.
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Displaying Captions
As you play back your storyboard, your audience may want to see the dialogue or action notes as subtitles. For 
that reason, the Pitch Mode workspace lets you select one of the caption fields available in your storyboard and 
display it at the bottom of the Camera view. By default, the Dialogue caption is selected.

In the Control Panel view, you will find a drop-down menu that will allow you to select the captions in your 
storyboard. Note that you cannot select a sketch caption. Only text captions can be selected.

If you want to make the selected caption field larger, you can hide the Caption tools area. 

How to select a caption

‣ From the Caption menu, select a caption to display below the Camera view.

How to hide the Caption Tools area

‣ In the Caption Tools area, click the Arrow  button to hide the settings.

How to show the Caption Tools area

‣ Hover the cursor at the edge of the caption, when you see a splitter cursor, drag left to reveal the 
Caption Tools area. 
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Customizing Captions
By default, the selected caption field has a black background and a gray font. You can change the colours and 
the font.

How to customize the look of captions

In the Caption Tools area, do any of the following:

‣ Font: Click Font. In the Select Font dialog box, set the font parameters.

‣ Font Colour: Double-click the font colour swatch. In the Colour Picker window, select a new 
colour.

‣ Background Colour: Double-click the background colour swatch. In the Colour Picker window, 
select a new colour.
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Navigating the Storyboard
Navigating through your storyboard lets you see how your project is progressing. You can scrub through a 
scene, view a specific point in the scene, see it in slow motion, or check a particular section.

The slider lets you scrub through all the panels in a scene. You will see the camera motions and the transitions 
at the speed you want by sliding left or right. Sliding left brings you to the beginning of the scene and sliding 
right brings you to the end. Transitions, camera moves, and all panels will be displayed.

As you select or scrub through panels and scenes, the name and number of the current scene and panel are 
displayed.

As you navigate through the panels of your storyboard by either using shortcuts, clicking on panels or using the 
navigation buttons, you can  automatically play the camera moves. 

NOTE 

When you select a panel that contains a camera move, it will automatically play. If you do not want 
to see the transitions or camera motions, deselect the Camera Mode  button in the Control Panel 
view.

How to navigate through your storyboard

Do one of the following:

 l Press A and F

 l Select panels in the Thumbnails view

 l Use the Previous Panel  and Next Panel  buttons

How to automatically play camera moves

‣ In the Control Panel, select the Auto-play Camera Moves option. 
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Drawing Revisions
When presenting a storyboard, you will most likely receive comments and feedback. The Pitch Mode 
workspace allows you to easily draw comments and corrections over your panels.

In Pitch Mode, you do not have access to the drawing layers in your panels, so when you draw corrections on 
your panel, a new Comments layer is automatically added for you on top of the panel. You can use this new 
Comments layer the same way as any other drawing layer in your scene.

Adding comments and corrections in Pitch Mode is easy. As soon as you start drawing with the Brush tool, the 
Comments layer is added. 

If you no longer require a Comments layer, you can delete it while you are still in the Pitch Mode workspace.

NOTE 

In the Pitch Mode workspace, you can use the Onion Skin feature to see your previous and next 
panels—see About Onion Skin on page 385. To see the onion skinning, deselect the Camera Mode 

 button in the Control Panel view.

How to add comments and corrections

 1. In the Comments section of the Control Panel view, select the Brush  tool or press Alt + B.

 2. Click a colour swatch to select a colour for your brush. 

 3. To change the colour, double-click the colour swatch to open the Select Colour dialog box. Select a 
new colour—see Colour on page 428.
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 4. Set the brush size and click OK.

 5. In the Stage view, add your comments and corrections.

 6. In the Camera view, draw your correction.

A Comments layer is added on top of your layers. 

 7. To access the Comments layer, click the Exit Pitch Mode button.

The Pitch Mode workspace is closed.

How to erase a correction

‣ In the Comments section of the Control Panel, click Eraser  tool or press Alt + E.  

How to delete a comment

‣ In the Comments section of the Control Panel, click the Erase Layer
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 button.

The Comments layer is deleted. You cannot delete any other layers.

733

Storyboard Pro 6. User Guide                          



Chapter 18: Pitching the Storyboard

Recording Voice Annotations
Since the Pitch Mode workspace is all about reviewing and approving your storyboard, you can also record 
voice annotations—see About Voice Annotations on page 744. 

The Voice Annotation tools are not displayed by default. You must enable the sound tools in the Preferences 
dialog box.

How to enable the sound tools

 1. Do one of the following:

‣ Select Edit > Preferences (Windows) or Storyboard Pro > Preferences (macOS).

‣ Press Ctrl + U (Windows) or ⌘  + , (Mac OS X).

 2. In the Preferences dialog box, select the Pitch Mode tab.

 3. In the Control Panel section, select the Display Sound Tools option.

The voice annotation tools appear in the Control Panel.

How to record voice annotations

 1. Verify that you have a working voice recording device and that it is correctly connected to your 
computer.

 2. In the Thumbnails view, select the panel on which you want to record a voice annotation.

 3. Display the Panel view.

 l If the Panel view is not part of your current workspace, select Windows > Panel.

 4. In the Voice Annotations section, click the Record Voice Annotation  button.

The Record a Voice Annotation dialog box opens.

 l Click the Record  button to begin recording.

 l Click the Stop  button to stop the recording.
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 l Click the Play  button to preview your recording.

NOTE 

If you try to record your voice and the voice recording device is improperly connected or 
malfunctioning, a warning message will appear. If this happens, check the voice recording 
device.
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Navigating the Storyboard
Navigating through your storyboard lets you see how your project is progressing. You can scrub through a 
scene, view a specific point in the scene, see it in slow motion, or check a particular section.

The slider lets you scrub through all the panels in a scene. You will see the camera motions and the transitions 
at the speed you want by sliding left or right. Sliding left brings you to the beginning of the scene and sliding 
right brings you to the end. Transitions, camera moves, and all panels will be displayed.

As you select or scrub through panels and scenes, the name and number of the current scene and panel are 
displayed.

As you navigate through the panels of your storyboard by either using shortcuts, clicking on panels or using the 
navigation buttons, you can  automatically play the camera moves. 

NOTE 

When you select a panel that contains a camera move, it will automatically play. If you do not want 
to see the transitions or camera motions, deselect the Camera Mode  button in the Control Panel 
view.

How to navigate through your storyboard

Do one of the following:

 l Press A and F

 l Select panels in the Thumbnails view

 l Use the Previous Panel  and Next Panel  buttons

How to automatically play camera moves

‣ In the Control Panel, select the Auto-play Camera Moves option. 
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Chapter 19: Storyboard Supervision
Storyboard Pro goes beyond the storyboard and animatic creation tasks by providing powerful tools for the 
supervision of a storyboarding project. 

Project managers, storyboard supervisors and artistic directors now have an efficient supervision tool to help 
them track the changes and communicate their feedback, corrections and such to the storyboard artists.
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About Track Changes
T-SBADV-008-001

In Storyboard Pro, you can track changes in the storyboard’s panels. This allows the storyboard artist to 
integrate any comments the supervisor has made, and the supervisor can easily track any changes and validate 
or comment on them.

Modified panels are outlined in yellow. You also have the possibility to write revision notes about the changes. 
This visual indicator allows the supervisor to rapidly locate any panels which have changed. A new temporary 
caption field is added to the tracked panel's Panel view.
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Tracking Changes
T-SBADV-008-002

Storyboard Pro lets you automatically detect any changes in your project, and adds a visual indication in the 
Thumbnails and Timeline views.

You can also track changes by date. If a storyboard becomes very large, it may be easier to track changes made 
on a specific date.

You can add notes to the Revision Notes caption. The caption only appears once the panel is marked as 
changed. Note that the text you type here will also be displayed in the Track Changes dialog box during the 
validation process—see Tracking Changes on page 740.

How to enable auto tracking

 1. Select Storyboard >  Track Changes > Auto Tracking Mode.

Once the Auto Tracking Mode is enabled and you edit a panel, a yellow rectangle appears around 
the panel in the Thumbnails and Timeline views.

 2. Edit your panels either by drawing or modifying caption text. If applicable, add comments in the 
Revision Notes caption.

How to track changes by date

 1. Select Storyboard > Track Changes > Track Changes by Date.

The Search by Date dialog box opens.
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 2. Use the From and To fields to define a particular time range in which to track changes. If you want to 
track changes done on one specific day, place that day’s date in both the From and To fields. Click 
the From button  and select the first date. Only the dates at which a change occurred will be 
available. The other dates will appear dimmed. 

 3. Select the first date and click OK.

 4. Repeat these steps to select the To date.

 5. Once your dates are set, the information is updated.

The first line displays the number of panels found in the storyboard that have been modified during 
the defined time range, and the panel that is currently selected.The second line displays information 
about the currently selected panel, such as which scene it is part of, the name of the panel, and the 
date it was last modified.

 6. Use the Next and Previous buttons to jump from one modified panel to the next.

 7. Use the menu in the bottom-left corner to modify the status of the selected panel.

 l Mark as Changed: Marks the currently selected panel as being edited on the current 
date; this is the default option. Click the button to activate it.

 l Mark Scene as Changed: Marks the scene of the currently selected panel as being 
edited on the current date.

 l Mark All as Changed: Marks all the storyboard panels as being edited on the current 
date.
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Validating Changes
T-SBADV-008-003

When you use the Auto Tracking Mode feature, you can use the Validate Changes option to follow up on these 
changes.

How to validate changes

 1. Select Storyboard >  Track Changes > Validate Changes.

The Track Changes dialog box opens.

‣ Useful information is displayed on the top part of the dialog box:

‣ The first line displays the number of panels found in the storyboard that were modified while the 
Auto Tracking Mode was enabled, as well as which of the panels that fits the description is 
currently selected. 

‣ The second line displays information about the currently selected panel, such as which scene it is 
part of, the name of the panel, and the date it was modified.

 2. Use the Notes field to enter text about the selected panel. This information will be available in the 
tracked panel Panel view in the Revision caption. If notes were added in the Revision Notes caption 
field, they will be displayed in the Revision Notes field of the Track Changes dialog box.

NOTE 

This caption is temporary; it will be removed when the change is validated. 
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 3. Use the Validate menu to select a validation option:

‣ Validate: Validates the currently selected panel. This is the default option, simply click on the 
button to activate it, there is no need to use the drop-down menu.

‣ Validate All: Validates all of the panels in the storyboard. Click on the arrow button to display 
the drop-down menu and activate the command.

‣ Validate Scene: Validates the scene that the currently selected panel is part of. Click on the 
arrow button to display the drop-down menu and activate the command.

 4. Use the Next and Previous buttons to navigate from one tracked panel to the other.
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About Voice Annotations
T-SBADV-008-004

In Storyboard Pro, you can provide the storyboard artists with voice annotations as well as written notes.

After the voice annotation has been recorded, the Voice Annotations section indicates the total number of 
annotations, displaying the order of the current voice annotation in the sequence and the total number of voice 
annotations associated with the panel. As you record voice annotations, they accumulate in sequence without 
being overwritten. You can select and play back any of the annotations. 
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Recording Voice Annotations
T-SBADV-008-005

Recording a voice annotation is quite simple. All you need is a microphone correctly connected to your computer 
and Storyboard Pro. 

How to record voice annotations

 1. Verify that you have a working voice recording device and that it is correctly connected to your 
computer.

 2. In the Thumbnails view, select the panel on which you want to record a voice annotation.

 3. Display the Panel view.

 l If the Panel view is not part of your current workspace, select Windows > Panel.

 4. In the Voice Annotations section, click the Record Voice Annotation  button.

The Record a Voice Annotation dialog box opens.

 l Click the Record  button to begin recording.

 l Click the Stop  button to stop the recording.

 l Click the Play  button to preview your recording.

NOTE 

If you try to record your voice and the voice recording device is improperly connected or 
malfunctioning, a warning message will appear. If this happens, check the voice recording 
device.
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Playing Voice Annotations
T-SBADV-008-006

Once a voice annotation has been added to a panel, you can play it back using the playback controls. 

How to listen to voice annotations

 1. In the Thumbnails view, select the panel with the voice annotation which you want to listen to.

 2. In the Panel view, do any of the following in the Voice Annotations section:

 l Click the Next Voice Annotation  and Previous Voice Annotation  buttons to 
select the annotation you want to listen to. Use the order display in the Voice 
Annotation section to see which annotation is selected.

 l Click the Play Voice Annotation  button to play back the selected voice annotation.

 l Click the Stop Voice Annotation  button to stop playback.
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Deleting Voice Annotations
T-SBADV-008-007

When a voice annotation is no longer required, you can delete it.

How to delete a voice annotation

 1. In the Thumbnails view, select the panel with the voice annotation you want to delete.

 2. In the Panel view, do any of the following in the Voice Annotations section:

 l Click the Next Voice Annotation  and Previous Voice Annotation  buttons to 
select the annotation to delete. Use the order display in the Voice Annotation section 
to see which annotation is selected.

 l Click the Delete Voice Annotation  button.
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About Project Management
T-SBADV-002-001

The project management functionalities of Storyboard Pro allow you to split your storyboard into several small 
projects so that several contributors can work on parts of the project simultaneously. You can then merge the 
separated projects back into a single project. 

There are two approaches to separating your storyboard into smaller projects:

 l Splitting: Separates the current project into two projects. You can create two new projects, each of 
which make half of the current project, and keep the current project as the master project, or you can 
take out half of the scenes of the current project into another project, making the current project the 
other half. 

 l Extracting: Exports selected parts of the current project into one or several smaller projects. This allows 
you to split your project into more than two smaller projects. Like with splitting, you can choose to 
extract the whole storyboard into smaller projects and keep the current project as the master project, or 
you can remove the extracted chunks from the current project, making the current project one of the 
chunks that are part of the whole project.

There are three approaches to merging parts of a storyboard into a single project:

 l Inserting: Simply adds a single project's scenes into the current project. 

 l Merging: Allows you to add the scenes from one or several projects to the current project. You can decide 
in which order each project is added to the current project, and whether they are added before or after 
the current project's scenes.

 l Merging and Replacing: Allows you to replace the scenes in the current project with scenes from 
extracted projects. This is the method to use if you want to import changes made in extracted projects 
into the master project, as it will replace the master project's original scenes with the updated scenes. 
This method allows you to select which scenes to import from the smaller projects. If some scenes in the 
projects being imported cannot be matched with a scene in the current project, they will be added at 
the end of the current project.
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Splitting your Project into two Projects 
T-SBADV-002-002

Using the Split Storyboard dialog, you can divide your storyboard into two separate projects so that two 
project collaborators can work on their half of the project simultaneously. Later, you can assemble both halves of 
the project back into a single project.

There are two approaches to splitting your project: 

 l You can choose to export one half of the project into a different project and keep the other half in the 
current project. If you do this, you can assemble the project back into a single project by inserting the 
second half at the end of the first half, or by merging both projects together—see Inserting a 
Project's Scenes into the Current Project on page 757 and Merging Storyboard Projects on page 754.

 l You can choose to split the current project into two new projects and keep the current project as a 
master project. Later, you can assemble the split projects back into the master project using the Merge 
and Replace dialog—see Merging Projects and Replacing Scenes in the Current Project on page 758. 

IMPORTANT 

If you intend to split your project into two new projects, then import the changes made in the two 
new projects into the original project using the Merge and Replace dialog, it is highly recommended 
to lock you project's scene and panel numbers before splitting your project. To do this, in the top 
menu, select Storyboard > Lock Scene and Panel Names.

How to split a storyboard project into two projects

 1. In the Timeline, move the timeline playhead to the panel where you want the split to take place. 

NOTE 

You can choose in which project the current panel will go later.

 2. Select File > Project Management > Split.
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The Split Storyboard window opens.

 3. Do one of the following to decide how your project is separated:

 l If you want the current project to keep the first half of the storyboard and to extract the 
second half into a new project, make sure that Export before selected panel is unchecked 
and that Export after selected panel is checked.

 l If you want the current project to keep the second half of the storyboard and to extract the 
first half into a new project, make sure that Export before selected panel is checked and that 
Export after selected panel is unchecked.

 l If you want to keep the current project as the master project and to export both halves of the 
storyboard into new project, check both Export before selected panel and Export after 
selected panel.

 4. For each half of the project that you chose to extract into a new project:

 a. Click on the Browse  button for this half of the project. 

 b. In the Save dialog that appears, browse to the location where you want to save this half of 
the project.

 c. Type in a name for this half of the project and click on Save. 

 5. Do one of the following to decide in which half of the project the current panel will go:

 l If you want the current panel to be in the first half of the project:

 l If you chose to only export after the selected panel, leave both Include selected panel 
options unchecked.

 l If you chose to export before the selected panel, check the Include selected panel 
option under Export before selected panel. 

 l If you want the current panel to be in the second half of the project:

 l If you chose to only export before the selected panel, leave both Include selected 
panel options unchecked.

 l If you chose to export after the selected panel, check the Include selected panel option 
under Export after selected panel. 

 6. If you chose to only extract one half of the project into a new project, and only want to keep the 
remaining half in the current project, check the Remove exported panels from current project 
option. If you prefer to keep a copy of the scenes being extracted in the current project, make sure 
this option is unchecked.
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NOTE 

This option is not available if you are exporting every panel in your project, as that would 
leave an empty project.

 7. Click on OK.

Project folders containing the split projects will be created in their selected destinations, with their 
chosen project names.
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Extracting Parts of your Project into Other Projects
T-SBADV-002-003

Using the Extract Storyboard dialog, you can extract parts of your storyboard into their ownprojects. This 
allows you separate your project into smaller projects, each one representing a chunk of the original storyboard. 
You can then share these extracted projects with project collaborators so that several artists can work on their 
assigned part of the project simultaneously. 

There are two approaches to separating your projects into smaller projects: 

 l You can extract all but one part of the project into smaller projects, and keep the remaining part in the 
current project. Later, you can assemble the extracted projects back with the current project using the 
Merge dialog—see Merging Storyboard Projects on page 754. 

 l You can every part of your project into smaller projects and keep the current project as a master project. 
Later, you can assemble the extracted projects back into the master project using the Merge and 
Replace dialog—see Merging Projects and Replacing Scenes in the Current Project on page 758. 

IMPORTANT 

If you want to keep the extracted scenes in the original project, and later import the changes made 
to the extracted projects back into the original project using the Merge and Replace dialog, it is 
highly recommended to lock you project's scene and panel numbers before splitting your project. To 
do this, in the top menu, select Storyboard > Lock Scene and Panel Names.

How to extract scenes in your storyboard into different projects

 1. Select File > Project Management > Extract.

The Extract Storyboard window opens.
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 2. For each chunk of the project that you want to extract into a different project, do the following:

 a. In the scenes list, select one or multiple scenes. You can select multiple scenes by doing one of 
the following:

 l Click and hold on the first scene that you want to select, then drag the mouse cursor 
down to the last scene you want to select.

 l Select the first scene that you want to select. Then, while holding Shift or Ctrl, click on 
the last scene you want to select. 

 b. Click on Extract Selected Scenes.

 c. In the file browser dialog that appears, browse to the location where you want to extract the 
selected scenes.

 d. Type in a name for the project in which you want to extract the selected scenes.

 e. Click Save.

 3. If you want to change the way you separated your project, you can select one of the projects to 
extract from the Projects list and click on Remove Selected Project until all the chunks you wish to 
change are removed, then separate these chunks again the way you want them to be separated.

 4. If you want the scenes that you are extracting from the current project to be removed from the 
current project, check the Remove extracted scenes from current project option. Otherwise, if you 
want to keep the current project intact so that it is a master project, leave this option unchecked.

 5. Click on OK.

Project folders containing the extracted projects will be created in their selected destinations, with 
their chosen project names. 
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Merging Storyboard Projects
T-SBADV-002-004

Using the Merge Storyboard dialog, you can merge several small projects and make a big project. This is useful 
if you have split or extracted your project into several projects in the past, and now you want to assemble those 
small projects back together. 

How to merge different projects into a single project

 1. Select File > Project Management > Merge.

The Merge Storyboard window opens.

 2. For each project that you want to insert to your current project:

 a. Click on Import Project. 

 b. In the file browser dialog that appears, browse for and select the project file that you want to 
add to the current project, then click on Open.

The project is added to the list of projects at the top.

 c. If you want to change the order of the project relative to the other projects being assembled 
together, select it and click on Move Up or Move Down. In the end, the scenes of each project 
being merged together will be assembled in the order in which they appear in the list.
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NOTE 

You can move projects above the current project. Their scenes will be inserted 
before the scenes in the current project.

 3. In the Captions list, you can see your current project's caption fields alongside the caption fields of 
each project that you are merging. Do the following to ensure each project's caption fields are 
properly merged:

 a. If the caption fields of any project being imported are not horizontally aligned with their 
corresponding caption field for the current project, select these fields and use the Move Up 
and Move Down button until they are aligned. 

 b. If there are new caption fields in the projects being imported that you want to add to the 
current project, move them down to the bottom of the list, below the current project's caption 
fields. This will make it so these captions get added as new fields instead of their content 
getting inserted in existing fields. 

 c. If you want any caption field of one of the projects being imported to be left out, so that they 
are not added to the current project, move them down to the bottom of the list, below the 
current project's caption fields, then  click on Remove Caption.

Refer to the following example:

 4. By default, the scene numbers in the projects being merged will be have a suffix letter added to 
them if any other scene in the current project or in other projects being merged have the same 
scene number.  If would prefer that all scenes in the project are numbered in series regardless of 
what their previous scene number was:

 a. Enable the Force scenes numbering option. This will make it so every scene in the project 
will be numbered in a series after all the projects have been merged together. 

 b. In the Start scene base name field, type in the number that you want the first scene in the 
resulting project to have. 
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 5. If you are not re-numbering the scenes, you can add the name of each project getting merged into 
the current project to the name of their scenes, so that you can easily identify which scene came 
from which project. To do this, check the Use project name as scene's prefix option.

 6. If you want to have the audio tracks from each merged project to be imported into separate audio 
tracks in the resulting project, check the Create new audio tracks option . Otherwise, the audio clips 
from the merged projects will be inserted in the existing audio tracks of the current project, when 
possible, and new audio tracks will only be created if needed.

 7. Click on OK.
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Inserting a Project's Scenes into the Current Project
T-SBADV-002-005

You can quickly and easily insert a project in your current project. The inserted project's scenes will be added 
right after the current scene.

NOTE 

If you need to insert a project before every scene in the current project, you must use the Merge 
Projects dialog—see Merging Storyboard Projects on page 754. 

How to insert the scenes from a different project into your current project

 1. In your current project, in the Timeline view, move the timeline playhead over the scene after which 
you want the project to be inserted.

 2. From the top menu, select File > Project Management > Insert.

The Open Storyboard Project window appears.

 3. Browse to and select the *.sboard or *.sbpz file of the project you want to select and click on Open.

 1. You will be prompted with a dialog stating whether the inserted project's caption fields match with 
the current project's caption fields and what it intends to do with the inserted project's caption 
fields. If you agree with what it intends to do, click on OK. Otherwise, click on Customize. Then, in 
the Customize Captions dialog, do the following:

 a. If the caption fields of any project being imported are not horizontally aligned with their 
corresponding caption field for the current project, select these fields and use the Move Up 
and Move Down button until they are aligned. 

 b. If there are new caption fields in the projects being imported that you want to add to the 
current project, move them down to the bottom of the list, below the current project's caption 
fields. This will make it so these captions get added as new fields instead of their content 
getting inserted in existing fields. 

 c. If you want any caption field of one of the projects being imported to be left out, so that they 
are not added to the current project, move them down to the bottom of the list, below the 
current project's caption fields, then  click on Remove Caption.

 d. Click OK. 

All scenes from the selected project are inserted after the current scene in your current project. 

757

Storyboard Pro 6. User Guide                          



Chapter 19: Storyboard Supervision

Merging Projects and Replacing Scenes in the Current Project
T-SBADV-002-006

If you have extracted smaller projects out of your current project so that different project collaborators could 
work on parts of your storyboard simultaneously, you can replaced the scenes in your project with the updated 
scenes in their projects using the Merge and Replace dialog. 

NOTE 

When merging projects, the video and sound clips in the master project will remain synchronized 
with the cue time of their respective panels. Clips that extend beyond the boundaries of a panel will 
be synchronize with the panel in which they are cued, not the panel in which they end.

How to replace scenes in your project with the updated scenes in projects that were 
extracted from it

 1. Open your master project.

 2. Select File > Project Management > Merge and Replace.

The Advanced Merge Storyboard dialog box opens.
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 3. For each project that you want to merge into the current project:

 a. Click Import Project  

 b. Browse to and locate the .sboard or .sbpz file of the project you want to merge into the 
current project. 

 4. For each project that you added to the list of imported projects, do one of the following:

 l If you want to merge every scene from  the project you are importing, check the checkbox left 
of the project in the project list at the top. This will select every scene in that project for 
import. 

NOTE 

You can also select the scene, then click on the Select All button right of the 
scenes list. 

 l If you want to merge only some scenes from the project into the current project, select that 
project in the list of projects at the top. Then, in the list of scenes at the bottom, check every 
scene that you want to merge. 

NOTE 

If the project contains sequences, the list of scenes will contain sequences, and 
scenes will be listed under their respective sequence. You can check the 
checkbox next to a sequence to select every scene in that sequence. 

 l If you need to reorder one of the projects you imported, select it, then click on Move Up or 
Move Down to change its order in the list. 

NOTE 

If you are merging projects that were originally extracted from the current 
project, their order in the list does not matter as these projects' scenes will 
replace the original scenes in the current project.

 5. If you want to preserve a copy of the original scenes along with their updated version, check the 
Keep and move original scenes to the end option. A backup of each scene that gets replaced will be 
added at the end of the storyboard. 

 6. If you want audio tracks that you previously locked to remain exactly as they are, check the Respect 
locked audio tracks option. Otherwise, clips in locked audio tracks will be moved to remain 
synchronized with the panels in which they are cued. 
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 7. If you want changes made to the audio in the projects getting merged to be imported into the 
current project, check the Import audio changes from source project option.

 8. If you only want to import panels that have been marked as tracked for changes in the imported 
projects, check the Only Merge Modified Panels (Track Changes) option.

 9. If you don't want the adjustments to the length of panels and scenes made in the imported projects 
to be merged into the current project, check the Replace Artwork Only option.

 10. If you don't want the adjustments to the layer transformations and animations in the imported 
projects to be merged into the current project, check the Preserver Layer Transformations in 
Master Project option.

 11. Click on Merge.
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Chapter 20: Exporting
Now that you have finished your storyboard or animatic, it is time to export it as images, PDF, or a movie file. 
Depending on whether or not you plan to edit your movie in a third party software or export snapshots, 
Storyboard Pro supports several export formats.
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About Exporting to Portable Document Format (.pdf)
You can export your storyboard project as a PDF file which you can print or share digitally. This is where you 
can set up your visuals to represent a classic storyboard on paper, or any other format you desire.
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Setting Up the PDF Export
T-SBFND-010-002

You can set up the PDF export settings for a selected panel. This panel will be exported with all the others, but 
will follow its own rules.

How to specify independent PDF options for selected panels

 1. Display the Panel PDF Options view by doing one of the following:

 l In the Workspace toolbar, click the PDF View  button to switch to the PDF View 
workspace.

 l Select Windows > Panel PDF Options to display the view in your current workspace.

 2. In the Thumbnails view, select one or more panels.

 3. In the Panel PDF Options, set the export options to apply to the selected panels:

Parameter Description

Options

Export to PDF
Exports the selected panel. This option is enabled by default. Deselect 
this option if you do not want to export this particular panel.

Force New Page Starts panel on a new page.

Full Page Prints panel on a full page.
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Image

Maximum Height for Full 
Page

Lets you set the maximum image height for a full page panel. Applies to 
landscape orientation only. 0 = No Limit.

Expand Displays camera motion (such as pan, tilt, or zoom) in the image 
across several panels.

Zoom Level (%) Size, in percentage, that the panel will appear within its frame.

Caption & Sketch

Export All Captions

This option is enabled by default. All captions from this panel will be 
exported to PDF. If you want to select specific captions to export, 
deselect this option and use the Caption List option 
to make your selections.

Caption List
This option is unavailable when the Export All Captions option is 
enabled. When available, click the Browse button to open the List 
Picker for selecting specific captions to export.

Spread Captions

Adapts the box to the text and spreads it across the next panel if 
necessary.

When this option is deselected, caption text is cut if it is too long or big 
for the space available in the box. 

Caption Font Scale 
(%)

Select the scale, in percentage, the text will appear in the captions of 
this panel.

Shrink Text to Fit Shrinks captions if they do not fit in the panel.

Export Sketch Exports the sketch caption field of this panel.

Preview
Creates a quick PDF of the page containing the selected panel(s), using 
the current default PDF export profile for the other panels.

Restore All from Profile Returns the options to the current default PDF export profile.
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 4. Click Preview to create a quick pdf preview of the page containing the selected panel(s), using the 
current default pdf export profile for the other panels.

 5. Click Restore All from Profile to reset the options to the current default pdf export profile.
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Exporting to PDF
T-SBFND-012-001

Using the PDF Export view, you can set up your PDF export and run an analysis on the result before printing it 
to a PDF file. This can be useful in preventing overset text resulting from the selected profile and PDF layout 
options.

How to export a PDF

 1. In the top menu, select File > Export > PDF.

The Export to PDF dialog box opens.

 2. In the Destination Path section, click the Browse  button.

 3. In the Save dialog, browse to the location in which you want to export your PDF document. In the 
File name field, type in the desired name for the document and click on Save.

 4. In the PDF Export Parameters section, select a layout for the PDF file. 

 l 3 Panels Horizontal: This is a classic layout of a printed storyboard. It consists of three 
panels per page, including captions, in an horizontal arrangement.

 l 3 Panels Vertical: This is a classic layout of a printed storyboard. It consists of three 
panels per page, including captions, in a vertical arrangement.

 l Full Page: This layout consists of one large panel per page, including captions.

 l Overview 2x4 Panels: This layout consists of a total of eight panels per page, 
organized on two rows of four, with captions in the middle.
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 l Overview 4x3: This layout consists of a total of 12 panels per page, organized in three 
rows of four. No caption is included.

 l Overview 8x10: This layout consists of a total of 80 panels per page, organized in ten 
rows of four. No caption is included.

 l Typical Japanese Format: This layout consists of a total of five panels by page, aligned 
on the left side of the page. Captions and duration are aligned in two consecutive rows 
on the right side. Note that your PDF reader and system may require an additional 
font package in order to display the PDF file properly.

 l Alternate Vertical Layout: This layout consists of a total of 5 panels per page, aligned 
on the left side of the page. Captions are organized on the right size of each panel. 
This export also includes a cut and a duration column, and displays the duration of 
each scene at the beginning of every new one.

 l Alternate Japanese Layout: This layout consists of a total of 5 panels per page, aligned 
on the left side of the page. This export includes vertical columns for the dialog, action, 
sluggin, notes, and time (duration) column which is displayed near the end of each 
scene (optionally). The scene name appears near the top of the first panel of a scene. 
The caption titles appear at the top and do not repeat at each panel. The total 
duration appears at the bottom of the page.

 5. To enable the security, see Adding Security to a PDF on page 771.

 6. In the Export Range section, select whether you want to export the entire project, or only specific 
parts of it:

 l All: Exports the entire storyboard.

 l Selected Scenes: Select this option to export a specific selection of scenes. Then, click on the 
Select button to open the Scenes Picker dialog box, in which you can:

 l Type the number of a sequence or of a scene in the Sequence or Scene fields in the 
Filter section, to only show matching sequences or matching scenes in the list.

 l Click and drag to select a range of scenes. 

 l Hold the Ctrl key and click on each scene you want to add to your selection.

 l Hold the Shift key, then click on the first scene and the last scene you want to add to 
your selection, to select every scene between those two scenes inclusively. 

 l If your project has sequences, click on a sequence to select every scene in that 
sequence. 

 l Current Scene: Exports only the currently selected scene. 
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 l Current Panel: Exports only the currently selected panel.

 l Tracked Panels:Exports panels on which tracking changes is enabled.

 7. If you want to view the storyboard after it is exported, check the Open document after export 
option.

 8. Click on Export button.

How to analyse and export with the PDF Export view

 1. Done of the following:

 l In the Workspace toolbar, click the PDF View  button.

 l Select Windows > PDF Export.

 2. In the PDF Export view or window, do the following:

 l In the Profile section, use the drop-down menu to select a profile for your export. Click 
Edit to modify the current options of the layout if needed—see Creating Custom PDF 
Layout Profiles on page 773.

 3. Click the Expand  button to display the Export Range section:

 l By default, the export range is set to All, which means your entire storyboard project 
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will be exported.

 l Selected Scenes: Select this option and click Select to open the Scenes Picker dialog 
box in which you can select specific scenes to export.

 l Current Scene: Exports only the currently selected scene to PDF.

 l Current Panel: Exports only the selected panels to PDF.

 l Tracked Panels: Exports panels that are marked as tracked. The number of tracked 
panels will appear beside the option.

 4. In the Analysis section:

 l Click Filters and select the issue types you want the analysis to display. Options 
include: Text Overflow, Text Overlap, and Camera Pan issues.

 l Click Analyse to start the analysis of your PDF options.

If no issue is encountered, the list will remain empty and the word Done! will appear 
beside the Analyse button.

If issues are encountered, they will appear in the list area. The scene, panel, and page 
numbers will be indicated, as well as a description of the problem found.

You can select an issue and click Ignore to remove it from the list as you verify the 
critical level these elements have on your PDF export.

In the Filters menu, you can show ignored issues by selecting the Show Ignored 
option. Instead of being removed from the list, a red X will appear beside the issue. 

You can reset an ignored issue by clicking Restore Ignored to remove the red X.

 5. Click Preview to generate a PDF preview of the selected issue.

 6. Click Export to export your PDF file.

The Export to PDF dialog box opens.

 l In the Destination Path field, specify the location and name of the file that will contain 
the PDF. Either type in the path directly or click the Browse button to display a 
window to select a file. Refer to the Exporting to PDF on page 767 section to learn 
how to set up password protected security rules.

 l Select the Open document after export option to automatically open your PDF file 
when it is ready.
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Adding Security to a PDF
T-SBFND-010-003A

By giving your PDF file a password and restricting certain features, such as printing and editing, you can 
provide document security to your digital storyboard. When files have restricted features, any tools and menu 
items related to those features are not available.

How to protect a PDF

 1. Select File > Export > PDF.

The Export to PDF window opens.

 2. Set your PDF export options.

 3. In the Document Security section, set up the protection:

 l Select the Need Password Protection option to add password protection to your PDF 
file.

 l In the Master Password field, type an administrator password. The owners of this 
password will not be bound by the protection. 

 l Enter the Master Password in the top Confirm field. Note that the password must be 
at least 6 characters long.

 l In the User Password field, type a user password. The owners of this password will be 
bound to the protection options you have defined. Enter the user password in the 
bottom Confirm field. Note that the password must be at least 6 characters long. 

 l Define the permissions you want to give users:

 l Printable: Gives the user permission to print the storyboard.

 l Edit All: Gives users the following PDF permissions: Changing the Document, 
Document Assembly, Filling of Form Fields, Signing and Creation of Template Pages.

 l Copy: Gives users the following PDF permissions: Content Copying and Content 
Copying for Accessibility.
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 l Edit: Gives users the following PDF permissions: Commenting, Filing of Form Fields 
and Signing.

 l Select the Remember Protection Settings option to keep these settings as default. 
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Creating Custom PDF Layout Profiles
T-SBFND-010-003B

When exporting your storyboard project to a PDF file, various page layouts are available depending on your 
document standards. You can also define some preferences and create a personalized layout.

You can create your own custom PDF profiles. The information is stored in an XML file, pdfoptions.xml, that can 
be found here:

 l Windows: C:\Users\[user_name]\AppData\Roaming\Toon Boom Animation\Toon Boom Storyboard Pro 
\full-1600-pref\pdfoptions.xml

 l macOS: /Users/[user_name]/Library/Preferences/Toon Boom Animation/Toon Boom Storyboard Pro 
Premium/full-1600-pref/pdfoptions.xml

NOTE 

On macOS, the Library folder is a hidden folder. To display the display the folder, hold down 
the Alt key when displaying Finder's Go menu.

How to create a custom PDF Profile

 1. Select File > Export > PDF.

The Export to PDF dialog box opens.

 2. In the PDF Export Parameters section, click one of the following buttons:

 l New Profile: Creates a completely new layout.

 l Duplicate Profile: Makes a copy of the selected layout from the list.

 l Edit Profile: Lets you edit the selected layout from the list.

 l Delete Profile: Deletes the selected layout from the list.

 3. In the PDF Profile dialog box, adjust the parameters for your PDF profile. For information on how to 
set the parameters for a custom profile, see  the PDF Profile Dialog Box topic in the Reference Guide.
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Exporting Custom PDF Profiles
If you created custom PDF profiles, you can export them and share them with other artists, who can them 
import your exported profiles into their preferences and use them to export their PDF documents. 

How to export a Custom PDF Profile

 1. Select File > Export > PDF.

The Export to PDF dialog box opens.

 2. Click the Menu   button.

 3. Click Export Profile.

The Export PDF Profiles dialog box opens.
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 4. By default, all PDF Profiles are selected. De-select the profiles you do not require.

 5. Click Export.

 6. In the Export PDF Profiles dialog box that displays, enter a file name and select a location for your 
PDF Profiles.

 7. Click Save.

NOTE 

A single .sbpdf file will be exported. If multiple PDF Profiles have been selected 
and exported, they will be contained in the same .sbpdf file. If you want to have a 
.sbpdf file for each of your PDF Profiles, export them separately.
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Importing PDF Profiles
If someone has shared their PDF layout profiles with you, you can import them into your preferences and use 
them to export PDF documents. 

How to import a Custom PDF Profile

 1. Select File > Export > PDF.

The Export to PDF dialog box opens.

 2. Click the Menu   button.

 3. Click Import Profile.

 4. In the Import PDF Profiles dialog box that displays, enter the profile's file name or select the PDF 
Profile.

NOTE 

PDF Profiles have a file extension .sbpdf

 5. Click Open.

776



About Exporting Movie Files
Once you have created your storyboard and animatic, you can export it as a movie file to share it with project 
collaborators or import it in third party software. You can export a single file for your whole animatic, or one 
movie file for each scene or each sequence.

You can export movies in the following formats: 

 l QuickTime Movie (.mov)

 l Windows Media Video (.wmv) (Windows only)

 l Flash Movie (.swf)

 l Image sequence in Jpeg (.jpg), Portable Network Graphics (.png) or Targa (.tga) format. 
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Exporting a Movie
T-SBFND-010-004

You can export your project into one or several movie files. 

On Windows, you can export in Windows Media Video (.wmv) by default, and you can also export in QuickTime 
Movie (.mov) format if you have Apple QuickTime installed. On macOS, you can only export in QuickTime Movie 
(.mov) format. In either case, exporting in QuickTime Movie (.mov) format gives you access to a wider selection of 
video codecs and compression settings.

How to export a movie

 1. In the top menu, select File > Export > Movie.

The Export to Movie dialog box opens.

 2. In the Destination Path section, click the Browse  button and choose a folder in which to save the 
exported files. 

 3. In the File Pattern field, type in a prefix or a file naming pattern for the exported files—see About 
File Naming Patterns on page 836.
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 4. In the Export Movie Format panel, configure the following options:

 a. In the Movie Format drop-down, select an export format:

 l QuickTime Movie (*.mov) to export a video in QuickTime Movie (.mov) format.

 l Windows Media Video (*.wmv) to export a video in Windows Media Video (.wmv) 
format. This option is only available on Windows.

 b. Click on Movie Options if you want to customize the video and audio encoding settings for 
your movie file. If you are exporting in QuickTime Movie (.mov) format, see Configuring Movie 
Settings for QuickTime Movies on page 783. If you are exporting in Windows Media Video 
(.wmv) format, see Configuring Movie Settings for Windows Media Video on page 786.

 c. In the Resolution dropdown, select whether you want the exported movie to be in Full Size, 
Half Size or Quarter Size, relative to the resolution of your project. It is recommended to 
export your animatic in full size unless you want to quickly export a test video.

 d. In the One Clip drop-down, select how you want your video clips to be separated:

 l Per Scene: Create one movie file for each scene in your project.

 l Per Sequence: Create one movie file for each sequence in your project, if any.

 l Per Project: Export your whole animatic into a single video file. 

 5. In the Export Range section, select whether you want to export the entire project, or only specific 
parts of it:

 l All: Exports the entire storyboard.

 l Selected Scenes: Select this option to export a specific selection of scenes. Then, click on the 
Select button to open the Scenes Picker dialog box, in which you can:

 l Type the number of a sequence or of a scene in the Sequence or Scene fields in the 
Filter section, to only show matching sequences or matching scenes in the list.

 l Click and drag to select a range of scenes. 

 l Hold the Ctrl key and click on each scene you want to add to your selection.
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 l Hold the Shift key, then click on the first scene and the last scene you want to add to 
your selection, to select every scene between those two scenes inclusively. 

 l If your project has sequences, click on a sequence to select every scene in that 
sequence. 

 l Current Scene: Exports only the currently selected scene. 

 l Current Panel: Exports only the currently selected panel.

 l Tracked Panels:Exports panels on which tracking changes is enabled.

 6. In the Burn-In tab, choose what kind of information you want to have printed into the exported 
files:

 l Print Time Code: Prints the global timecode on each rendered image.

 l Print Scene Names and Panel Numbers: Prints the scene names and panel numbers as an 
overlay on your video.

 l Print Additional Duration: Prints another time code counting the time for the current panel, 
scene or sequence, depending on what is selected in the Repeat drop-down.

 l Units: Whether to print the additional duration in time units (seconds, minutes, etc.) or 
in frames. 

 l Repeat: Decide what to count the time of for the additional duration. For example, if 
set to per Panel, the time elapsed since the beginning of the current panel will be 
printed. 

 7. In the Camera Grids tab, using these options, decides whether you want any kind of camera frame 
to be printed into the exported files:
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 l Title Safe Area: Prints the Title Safe Area over the picture. By default, this area is 20% 
smaller than the camera frame. It is used as a guideline of the area that CRT displays might 
crop out of the picture. Visual elements such as text and logos should be placed within this 
area.

 l Action Safe Area: Prints the Action Safe Area over the picture. By default, this area is 10% 
smaller than the camera frame. It is used as a guideline of the area that CRT displays might 
crop out of the picture. Characters and action should be placed within this area. 

 l 4:3 Safety: Prints the title safe area and the action safe area for the 4:3 camera frame over 
the exported image. They can be used to position elements in projects that are meant to be 
displayed in both widescreen and 4:3 proportions.

 l 4:3 Reference: Prints the 4:3 camera frame over the exported image. This frame corresponds 
to the camera frame if the aspect ratio of the picture was 4:3. It can be used to position 
elements in projects that are meant to be displayed in both widescreen and 4:3 proportions.

 8. In the Captions tab, you can choose to print any of your storyboard’s captions into the exported 
movies using the following options—see Captions on page 148.

 l Print Captions: Choose whether to not print captions (None) or select one of your project’s 
captions to print into the exported movies. By default, a Storyboard Pro project has Action 
Notes, Dialog, Slugging and Notes captions, but you can also choose to print custom captions 
if your project has any.
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 l Font: Select which font the captions will be printed in. By default, they will be printed in 
Arial.

 l Height %: Sets the size of caption lines relative to the height of the exported movies. For 
example, if exporting a movie at 1080p with 3% Height captions, each caption line will be 32 
pixels in height.

 l Position: Prints the captions at either the Top Left, Top Centre, Top Right, Bottom Left, 
Bottom Centre or Bottom Right of the movie. By default, captions are printed to the Bottom 
Centre.

 l Max Lines: Sets the maximum amount of caption lines to print on each panel. If a caption 
being printed requires more than the maximum amount of lines, it will be cut off with an 
ellipsis (...) at the end. Note that even if captions are printed at the bottom, they will be 
aligned to the top of the space reserved for them, which is calculated by the amount of Max 
Lines x the Height %. Therefore, if this setting is too high and captions are printed at the 
bottom, they may appear closer to the middle of the picture than to the bottom.

 l Text Colour: Select the font colour in which to print the captions.

 l Bg Colour: Select the background colour on which to print the captions. If the checkbox is 
unchecked, the captions will be printed directly into the rendered picture. Otherwise, they 
will be printed in rectangular boxes of the chosen colour.

 9. If you want to automatically play the video or view the exported files once the export is done, check 
the Open document/folder after export option.

 10. Click on the Export button.
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Configuring Movie Settings for QuickTime Movies
If you are exporting in QuickTime Movie (.mov) format, you can configure the video and audio settings for your 
exported movies using the configuration interface provided by QuickTime. 

NOTE 

To export QuickTime Movies on Windows, Apple QuickTime must be installed on your machine. 

How to configure video and sound settings for QuickTime movies on Windows and 
macOS

 1. In the Movie Settings dialog box, select whether you want your movie to include Video and Sound 
data, as well as if the video should be optimized for Internet streaming.

 2. In the Video section, click Settings.

The Standard Video Compression Settings dialog box opens.
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 3. From the Compression Type menu, select a codec. The availability of certain compression settings 
depends on the Compression Type selected. For example, when the Animation compression type is 
selected, the Data Rate option is greyed out. 

 4. In the Motion section, choose a Frame Rate from the list. 

By default, it is set to match the frames-per-second (fps) of your Storyboard Pro project. If you 
choose a lower frame rate, your export playback will be faster than your actual project. The reverse 
is also true for a higher frame rate. 

 5. If you want keyframes inserted, select the Every option and set the number per frame. 

This is the option recommended by QuickTime. For further details, refer to the QuickTime 
documentation.

 6. In the Quality section, use the slider to choose a quality setting. Remember that the better the 
quality of the export, the larger the file.

 7. From the Data Rate section, either choose to allow the program to automatically select the most 
optimal bit rate, or enter a Restricted rate to save space and allow for faster downloading at a cost 
to the quality of the export. 

 8. In the same section, from the Optimized For menu, select the intended viewing method for the 
export.
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 9. Click OK.

 10. From the Movie Settings dialog box, click Sound Settings.

The Sound Settings dialog box opens.

 11. From the Compressor menu, select a compression type. The default setting is None. This exports 
your audio as is without performing any lossy compression or conversion, preserving its fidelity. 
Other compressors can be used if you need your movie's audio track to be exported in a specific 
format, or if disk space or download speed is critical, but they may impact the quality of your movie's 
soundtrack negatively. 

 12. From the Rate menu, select a rate. It is best to export your audio at a rate that matches the rate of 
your original sound files. For example, if your file has an audio sample rate of 48 kHz and you choose 
a conversion rate of 22.05 kHz, the sound will play at the same speed, but higher frequencies will be 
missing, making it sound muffled. For reference, the standard sound quality is 48 kHz for 
broadcasting and DVD. Lower rates are liable to impact the quality of your movie's soundtrack 
negatively, but they can be useful if disk space or download speed is critical.

 13. Select the Size of your audio's encoding. Also known as Bit Depth, this determines the amount of 
precision used to record each wavelength in the audio track. The standard size is 16-bit. If you 
choose 8-bit, the amount of disk space the audio track of your movie file requires is halved, but the 
audio quality will be significantly lower.

 14. Select whether to Use the Mono or Stereo channel mode.  Stereo sound has a separate audio track 
for the left and the right speakers, allowing to make the origin of each sound realistically match the 
origin of their corresponding action. If you choose Mono, the audio track in the exported movie file 
may use less disk space, but both the left and right channels will be merged into a single track.  
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Configuring Movie Settings for Windows Media Video
On Windows, it is possible to export in Windows Media Video format. 

How to configure video and sound settings for Windows Media Video

 1. In the Video section, select the desired Variable Bit Rate Quality for your video. A higher setting will 
ensure a better image quality. A lower setting will create a smaller video file.

 2. Using the Sound checkbox, select whether or not you want your movie file to have sound.

 3. Using the Profile drop-down menu, select the preferred compression settings for your movie's 
soundtrack. Each profile has a combination of audio sample rate, sample size and channel mode, 
which cover the following options:

 l  Sample rate: Available sample rates are 8000 Hz, 16000 Hz, 22050 Hz and 44100 Hz. The 
default setting is 22050 Hz. It is best to export your audio at a rate that matches the rate of 
your original sound files. For example, if your file has an audio sample rate of 48000 Hz and 
you choose a sample rate of 22050 Hz, the sound will play at the same speed, but higher 
frequencies will be missing, making it sound muffled. For reference, the standard sound 
quality is 44000 kHz for films, and 48000 kHz for DVD. Lower rates are liable to impact the 
quality of your movie's audio track negatively, but they can be useful if disk space or 
download speed is critical.

 l Sample size: Also known as Bit Depth, this determines the amount of precision used to 
record each wavelength in the audio track. The standard size is 16-bit. If you choose 8-bit, 
the amount of disk space the audio track of your movie file requires is halved, but the audio 
quality will be significantly lower. 

 l Channel mode:  Stereo sound has a separate audio track for the left and the right speakers, 
allowing to make the origin of each sound realistically match the origin of their corresponding 
action. If you choose Mono, the audio track in the exported movie file may use less disk space, 
but both the left and right channels will be merged into a single track. 

NOTE 

Exporting in 8-bit audio requires Apple QuickTime to be installed.
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Exporting an Image Sequence
The Export Movie dialog also allows you to export your project in sequences of images, each one representing a 
single frame in your animatic. 

How to export an image sequence

 1. Select File > Export > Movie.

The Export To Movie dialog box opens.

 2. In the Destination Path section, click the Browse  button and choose a folder in which to save the 
exported files. 

 3. In the File Pattern field, type in a prefix or a file naming pattern for the exported files—see About 
File Naming Patterns on page 836.

 4. In the Export Movie Format section:
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 l From the Movie Format menu, select the image format to export the sequence in:

 l Jpeg (*.jpg): An image format with lossy compression optimized for the Web. 
Only use this format if you want to make a quick test of your image sequence.

 l Targa (*.tga): An image format with standard lossless compression. 

 l Portable Network Graphics (*.png): An image format with a more effective 
lossless compression than Targa (.tga). Exporting in this format is slower, but 
saves a lot of disk space. Also, .png files are more portable and widely 
supported as an exchange format. 

 l In the Resolution dropdown, select whether you want the exported movie to be in 
Full Size, Half Size or Quarter Size, relative to the resolution of your project. It is 
recommended to export your animatic in full size unless you want to quickly export a 
test video.

 5. In the Export Range section, select whether you want to export the entire project, or only specific 
parts of it:

 l All: Exports the entire storyboard.

 l Selected Scenes: Select this option to export a specific selection of scenes. Then, click on the 
Select button to open the Scenes Picker dialog box, in which you can:

 l Type the number of a sequence or of a scene in the Sequence or Scene fields in the 
Filter section, to only show matching sequences or matching scenes in the list.

 l Click and drag to select a range of scenes. 

 l Hold the Ctrl key and click on each scene you want to add to your selection.

 l Hold the Shift key, then click on the first scene and the last scene you want to add to 
your selection, to select every scene between those two scenes inclusively. 

 l If your project has sequences, click on a sequence to select every scene in that 
sequence. 

 l Current Scene: Exports only the currently selected scene. 
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 l Current Panel: Exports only the currently selected panel.

 l Tracked Panels:Exports panels on which tracking changes is enabled.

 6. In the Burn-In tab, choose what kind of information you want to have printed into the exported 
files:

 l Print Time Code: Prints the global timecode on each rendered image.

 l Print Scene Names and Panel Numbers: Prints the scene names and panel numbers as an 
overlay on your video.

 l Print Additional Duration: Prints another time code counting the time for the current panel, 
scene or sequence, depending on what is selected in the Repeat drop-down.

 l Units: Whether to print the additional duration in time units (seconds, minutes, etc.) or 
in frames. 

 l Repeat: Decide what to count the time of for the additional duration. For example, if 
set to per Panel, the time elapsed since the beginning of the current panel will be 
printed. 

 7. In the Camera Grids tab, using these options, decides whether you want any kind of camera frame 
to be printed into the exported files:

 l Title Safe Area: Prints the Title Safe Area over the picture. By default, this area is 20% 
smaller than the camera frame. It is used as a guideline of the area that CRT displays might 
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crop out of the picture. Visual elements such as text and logos should be placed within this 
area.

 l Action Safe Area: Prints the Action Safe Area over the picture. By default, this area is 10% 
smaller than the camera frame. It is used as a guideline of the area that CRT displays might 
crop out of the picture. Characters and action should be placed within this area. 

 l 4:3 Safety: Prints the title safe area and the action safe area for the 4:3 camera frame over 
the exported image. They can be used to position elements in projects that are meant to be 
displayed in both widescreen and 4:3 proportions.

 l 4:3 Reference: Prints the 4:3 camera frame over the exported image. This frame corresponds 
to the camera frame if the aspect ratio of the picture was 4:3. It can be used to position 
elements in projects that are meant to be displayed in both widescreen and 4:3 proportions.

 8. In the Captions tab, you can choose to print any of your storyboard’s captions into the exported 
movies using the following options—see Captions on page 148.

 l Print Captions: Choose whether to not print captions (None) or select one of your project’s 
captions to print into the exported movies. By default, a Storyboard Pro project has Action 
Notes, Dialog, Slugging and Notes captions, but you can also choose to print custom captions 
if your project has any.

 l Font: Select which font the captions will be printed in. By default, they will be printed in 
Arial.

 l Height %: Sets the size of caption lines relative to the height of the exported movies. For 
example, if exporting a movie at 1080p with 3% Height captions, each caption line will be 32 
pixels in height.

 l Position: Prints the captions at either the Top Left, Top Centre, Top Right, Bottom Left, 
Bottom Centre or Bottom Right of the movie. By default, captions are printed to the Bottom 
Centre.

 l Max Lines: Sets the maximum amount of caption lines to print on each panel. If a caption 
being printed requires more than the maximum amount of lines, it will be cut off with an 
ellipsis (...) at the end. Note that even if captions are printed at the bottom, they will be 
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aligned to the top of the space reserved for them, which is calculated by the amount of Max 
Lines x the Height %. Therefore, if this setting is too high and captions are printed at the 
bottom, they may appear closer to the middle of the picture than to the bottom.

 l Text Colour: Select the font colour in which to print the captions.

 l Bg Colour: Select the background colour on which to print the captions. If the checkbox is 
unchecked, the captions will be printed directly into the rendered picture. Otherwise, they 
will be printed in rectangular boxes of the chosen colour.

 9. If you want to automatically play the video or view the exported files once the export is done, check 
the Open document/folder after export option.

 10. Click on the Export button.
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Exporting a Flash Movie (.swf)
Once you have completed your storyboard and animatic, you can export as Flash Movie (.swf) file which you can 
share and play back.

How to export a Flash movie

 1. Select File > Export > Movie.

The Export to Movie window opens.

 2. In the Destination Path section, click the Browse  button and choose a folder in which to save the 
exported files. 

 3. In the File Pattern field, type in a prefix or a file naming pattern for the exported files—see About 
File Naming Patterns on page 836.

 4. In the Movie Format drop-down, select Flash (*.swf).

 5. In the Resolution dropdown, select whether you want the exported movie to be in Full Size, Half 
Size or Quarter Size, relative to the resolution of your project. It is recommended to export your 
animatic in full size unless you want to quickly export a test video.
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 6. In the One Clip drop-down, select how you want your video clips to be separated:

 l Per Scene: Create one movie file for each scene in your project.

 l Per Sequence: Create one movie file for each sequence in your project, if any.

 l Per Project: Export your whole animatic into a single video file. 

 7. Click Options. 

The Flash Export Settings dialog box opens.

 a. To protect your movie from being imported in another application, select the Protect from 
Import option.

 b. To optimize the size of the exported Flash file, select the Compress option. 

 c. If your project includes any bitmap images or video clips, set the JPEG Quality to the preferred 
setting. A lower setting will save disk space but will affect the quality of all bitmap images in 
the exported file. A higher setting will preserve the quality of bitmap images.

 d. Click OK. 

 8. In the Export Range section, select whether you want to export the entire project, or only specific 
parts of it:

 l All: Exports the entire storyboard.

 l Selected Scenes: Select this option to export a specific selection of scenes. Then, click on the 
Select button to open the Scenes Picker dialog box, in which you can:

 l Type the number of a sequence or of a scene in the Sequence or Scene fields in the 
Filter section, to only show matching sequences or matching scenes in the list.
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 l Click and drag to select a range of scenes. 

 l Hold the Ctrl key and click on each scene you want to add to your selection.

 l Hold the Shift key, then click on the first scene and the last scene you want to add to 
your selection, to select every scene between those two scenes inclusively. 

 l If your project has sequences, click on a sequence to select every scene in that 
sequence. 

 l Current Scene: Exports only the currently selected scene. 

 l Current Panel: Exports only the currently selected panel.

 l Tracked Panels:Exports panels on which tracking changes is enabled.

 9. In the Burn-In tab, choose what kind of information you want to have printed into the exported 
files:

 l Print Time Code: Prints the global timecode on each rendered image.

 l Print Scene Names and Panel Numbers: Prints the scene names and panel numbers as an 
overlay on your video.

 l Print Additional Duration: Prints another time code counting the time for the current panel, 
scene or sequence, depending on what is selected in the Repeat drop-down.

 l Units: Whether to print the additional duration in time units (seconds, minutes, etc.) or 
in frames. 

 l Repeat: Decide what to count the time of for the additional duration. For example, if 
set to per Panel, the time elapsed since the beginning of the current panel will be 
printed. 

 10. In the Camera Grids tab, using these options, decides whether you want any kind of camera frame 
to be printed into the exported files:
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 l Title Safe Area: Prints the Title Safe Area over the picture. By default, this area is 20% 
smaller than the camera frame. It is used as a guideline of the area that CRT displays might 
crop out of the picture. Visual elements such as text and logos should be placed within this 
area.

 l Action Safe Area: Prints the Action Safe Area over the picture. By default, this area is 10% 
smaller than the camera frame. It is used as a guideline of the area that CRT displays might 
crop out of the picture. Characters and action should be placed within this area. 

 l 4:3 Safety: Prints the title safe area and the action safe area for the 4:3 camera frame over 
the exported image. They can be used to position elements in projects that are meant to be 
displayed in both widescreen and 4:3 proportions.

 l 4:3 Reference: Prints the 4:3 camera frame over the exported image. This frame corresponds 
to the camera frame if the aspect ratio of the picture was 4:3. It can be used to position 
elements in projects that are meant to be displayed in both widescreen and 4:3 proportions.

 11. In the Captions tab, you can choose to print any of your storyboard’s captions into the exported 
movies using the following options—see Captions on page 148.

 l Print Captions: Choose whether to not print captions (None) or select one of your project’s 
captions to print into the exported movies. By default, a Storyboard Pro project has Action 
Notes, Dialog, Slugging and Notes captions, but you can also choose to print custom captions 
if your project has any.
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 l Font: Select which font the captions will be printed in. By default, they will be printed in 
Arial.

 l Height %: Sets the size of caption lines relative to the height of the exported movies. For 
example, if exporting a movie at 1080p with 3% Height captions, each caption line will be 32 
pixels in height.

 l Position: Prints the captions at either the Top Left, Top Centre, Top Right, Bottom Left, 
Bottom Centre or Bottom Right of the movie. By default, captions are printed to the Bottom 
Centre.

 l Max Lines: Sets the maximum amount of caption lines to print on each panel. If a caption 
being printed requires more than the maximum amount of lines, it will be cut off with an 
ellipsis (...) at the end. Note that even if captions are printed at the bottom, they will be 
aligned to the top of the space reserved for them, which is calculated by the amount of Max 
Lines x the Height %. Therefore, if this setting is too high and captions are printed at the 
bottom, they may appear closer to the middle of the picture than to the bottom.

 l Text Colour: Select the font colour in which to print the captions.

 l Bg Colour: Select the background colour on which to print the captions. If the checkbox is 
unchecked, the captions will be printed directly into the rendered picture. Otherwise, they 
will be printed in rectangular boxes of the chosen colour.

 12. If you want to automatically play the video or view the exported files once the export is done, check 
the Open document/folder after export option.

 13. Click on the Export button.
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Exporting Harmony Scenes
T-SBANIM-008-002

Storyboard Pro can automatically export each scene in your project into a scene that can be opened 
in Harmony, where you can use the animatic to create and time your animation. The resulting Harmony scenes 
will be the same length as the scenes in your Storyboard Pro project, they will contain each of their panels so 
that you may animate over them, and they will contain their respective part of the animatic's soundtrack.

You can choose to export your animatic in rendered frames, which will not be editable in Harmony and can only 
be used as reference, or to export the drawings, 3D objects and camera movements of each scene in your 
project directly into the Harmony scenes, allowing you to reuse its elements in Harmony. If you are rendering 
your animatic, you can choose whether you want to export one scene for the whole project, for each sequence 
or for each act, whereas if you want to export original scenes, you can only export one Harmony scene for each 
scene in your animatic. 

NOTES 

 l Transitions in your project are not exported to Harmony.

 l If you choose to export original scenes instead of the rendered animatic, the content of video 
tracks will not be included in the exported Harmony scenes. 

How to export Harmony scenes

 1. In the top menu, select File > Export > Export to Harmony.
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The Export to Harmony dialog box opens.

 2. In the Destination Path section, click the Browse  button and choose a folder in which to save the 
exported files. 

 3. In the File Pattern field, type in a prefix or a file naming pattern for the exported files—see About 
File Naming Patterns on page 836.

 4. In the Format drop-down, select one of the following options: 

 l Harmony  Offline: This will create scenes that can be opened in Harmony Stand Alone.

 l Harmony  Database: This will create a package of scenes that can be imported into a 
Harmony Server database.

 5. Select one of the following export types, depending on what you prefer to work with, then select 
the desired settings for that export type.

 l Rendered Animatic:  Renders the animatic into a sequence of bitmap images that are 
assembled into the exported Harmony scenes. This ensures that the content of your animatic 
is accurately rendered in Harmony, especially if you intend to use an older version.
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 l Resolution: Allows you to select the resolution of rendered frames relative to the 
project resolution between the following options: Full Size, Half Size or Quarter Size.

 l Generate One Scene:  Allows you to select how to separate the project into Harmony 
scenes:

 l Per Scene: Generates one  scene for each scene in your project.

 l Per Sequence: Generates one  scene for each sequence in your project.

 l Per Act: Generates one  scene for each act in your project.

 l Optimize Still Images: When there is no animation or camera movement for a certain 
time span, a single drawing is rendered and its exposure is rendered until there is 
movement. If this option is disabled, one frame is rendered for every frame in your 
animatic, regardless of if there is movement or not.

 l Animatic on Top: If you generate scenes based on sequences or acts, this option 
becomes available. When enabled, the animatic is rendered and placed as the top 
layer and column in Harmony or Animate.

 l Original Scene:  Exports the animatic directly into Harmony scenes without rendering it. This 
preserves the layers, drawings and camera movements so that they can be used in Harmony. 
One scene will be generated for each scene in the project.

 l Nest Panels in Symbols: Upon export to Harmony or  Animate, the panel's content will 
be nested inside symbols. Instead of having several layers in your root timeline, you 
will have a single one. You will need to enter the symbol to edit its content.

 l Add a Camera Reference Layer: Adds a layer containing the different camera frames 
on top of the other layers to use as a reference in Harmony and Animate.

 l Apply Transformation on Drawings: Applies transformation on the first and last 
position of each panel. The in-between animation will be lost.

 6. In the Export Range section, select whether you want to export the entire project, or only specific 
parts of it:
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 l All: Exports the entire storyboard.

 l Selected Scenes: Select this option to export a specific selection of scenes. Then, click on the 
Select button to open the Scenes Picker dialog box, in which you can:

 l Type the number of a sequence or of a scene in the Sequence or Scene fields in the 
Filter section, to only show matching sequences or matching scenes in the list.

 l Click and drag to select a range of scenes. 

 l Hold the Ctrl key and click on each scene you want to add to your selection.

 l Hold the Shift key, then click on the first scene and the last scene you want to add to 
your selection, to select every scene between those two scenes inclusively. 

 l If your project has sequences, click on a sequence to select every scene in that 
sequence. 

 l Current Scene: Exports only the currently selected scene. 

 7. In the Sounds tab, decide how you want the audio in the storyboard project to be exported into the 
scenes.                     

 l Keep Original Files: Copies the sound clips from your project into the exported scenes, 
without mixing them.

 l Process Audio Tracks Individually: Creates a mixed sound file for each audio track and stores 
each sound file into its own sound layer in the exported scene. 

 l Merge All Audio Tracks: Creates a single sound file with all the audio tracks merged and 
stores it into a single sound layer in the exported scene.

 l Process Audio Tracks Individually and Merged: Creates a single sound file for each audio 
track and stores each sound file into its own sound layer, then adds an extra sound layer with 
all the audio tracks merged together.  . 

 l File Pattern: Allows you to type a prefix or a pattern for the names of the exported audio 
files—see About File Naming Patterns on page 836.
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 l Sample Rate: Sets the frequency rate of the exported audio files. It is recommended to export 
sound files at the rate at which they were originally created. For reference, the standard 
sample rate is 48.0 kHz for broadcasting and DVD.

 l Bit Depth: Sets the precision level of each wavelength in the sound file. The standard bit 
depth is 16 bit. Setting this to 8 bit will cut the size of audio files in half, but will significantly 
impact sound quality.

NOTE 

On Windows, audio can only be exported in 16 bit unless QuickTime Player is 
installed.

 l Channels: Allows you to select whether to export sound in Mono or Stereo. Stereo sound 
uses a separate track for the left and right speakers, which allows to simulate a realistic sound 
environment. Mono uses a single track for both speakers, which saves disk space. 

 8. In the Burn-In tab, when exporting rendered animatics, you can choose to print information about 
the panels and their position in the Timeline, into the exported scenes.

 l Print Time Code: Prints the global timecode on each rendered image.

 l Print Scene Names and Panel Numbers: Prints the scene names and panel numbers as an 
overlay on your video.

 l Print Additional Duration: Prints another time code counting the time for the current panel, 
scene or sequence, depending on what is selected in the Repeat drop-down.

 l Units: Whether to print the additional duration in time units (seconds, minutes, etc.) or 
in frames. 

 l Repeat: Decide what to count the time of for the additional duration. For example, if 
set to per Panel, the time elapsed since the beginning of the current panel will be 
printed. 
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 9. In the Camera Grids tab, using these options, you can add boundaries to the picture that indicates 
what the Camera includes or excludes.

 l Title Safe Area: Prints the Title Safe Area over the picture. By default, this area is 20% 
smaller than the camera frame. It is used as a guideline of the area that CRT displays might 
crop out of the picture. Visual elements such as text and logos should be placed within this 
area.

 l Action Safe Area: Prints the Action Safe Area over the picture. By default, this area is 10% 
smaller than the camera frame. It is used as a guideline of the area that CRT displays might 
crop out of the picture. Characters and action should be placed within this area. 

 l 4:3 Safety: Prints the title safe area and the action safe area for the 4:3 camera frame over 
the exported image. They can be used to position elements in projects that are meant to be 
displayed in both widescreen and 4:3 proportions.

 l 4:3 Reference: Prints the 4:3 camera frame over the exported image. This frame corresponds 
to the camera frame if the aspect ratio of the picture was 4:3. It can be used to position 
elements in projects that are meant to be displayed in both widescreen and 4:3 proportions.

 10. In the Scene Options tab, you can configure some of the settings for all of the exported Harmony 
scenes, so that you do not have to change these settings in each scene individually later:

 l Custom Write Node Parameters:  Enable this option to be able to customize the parameters 
for the Write nodes of the exported Harmony scenes. By doing this, you can ensure that the 
scenes will render their frames in the preferred location and format, and with the preferred 
file name, without having to configure the Write node for each exported scene in Harmony.
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 l Image Render Path: The path to the folder in which to save the rendered frames. This path 
can be absolute or relative to the scene's folder. For example, the default path for rendered 
frames is frames, which means the images are saved in the frames subfolder of the scene 
folder. If you want to select an absolute path, you can click on the Browse  button at the 
right of the text field and select the folder in which your scenes should export their frames. 

NOTE 

You can also use variables to make the image render path follow a pattern that 
can include the scene, sequence and act numbers, so that the image render path 
is different for each scene—see About File Naming Patterns on page 836.

 l Image Filename: The prefix for the file name of each exported frame. Frames will be named 
with this value, followed by the frame number and their image type extension. It is 
recommended to leave the hyphen (-) at the end of the prefix to separate the prefix from the 
frame number.

NOTE 

You can also use variables to make the image prefix follow a pattern that can 
include the scene, sequence and act numbers, so that the image prefix is different 
for each scene—see About File Naming Patterns on page 836.

 l Image Format: The image format in which the rendered frames will be saved.

 11. If you want to view the exported files once the export is done, check the Open document/folder 
after export checkbox. 

 12. Click on Export.

NOTE 

If you exported Harmony Database scenes, see Importing Harmony Scenes to a Harmony 
Database on page 804.
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Importing Harmony Scenes to a Harmony Database
If you have exported scenes from Storyboard Pro with the option Harmony Database, you will need to import 
the exported scene package into your Harmony Server database before you can start working in them.

How to import Harmony scenes exported from Storyboard Pro into your Harmony 
database

 1. Launch Control Center.

 2. In the log-in dialog, log into your Storyboard Pro database using an account with high privileges.

The main application window appears.

 3. In the top menu, select Environment > Create .

 4. In the Create Environment dialog, type in the name for the environment in which you wish to import 
your scenes. An environment is often used to separate different series or projects, so you can name 
your environment accordingly.

 5. Click on OK.
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 6. In the Environments list, select the environment you just created.

 7. In the top menu, select Jobs > Create.

 8. In the Create Job dialog:

 a. In the Job Name field, type in the name for the job in which you want to import your scenes. 
Jobs are often used to separate episodes in a series, so you can name your job accordingly.

 b. In the TD drop-down, select the user who should supervise the animation pipeline.

 c. In the ATD drop-down, select the user who should assist in supervising the animation 
pipeline. 

 d. In the Approvals field, select whether you want the approvals to be automatic or manual.

 e. Click OK.

Your new job is added to the Jobs list, as part of the jobs in your new environment.

 9. In the top menu, select Admin > Import.

The Import Scene(s) dialog appears.
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 10. Next to the Package Directory field, click on the Browse  button.

 11. In the Open dialog, browse to and select the IEContent.dat file that was exported with your 
scenes package.

 12. Next to the Destination section, click on the Browse  button.

 13. In the File System Selector dialog box:

 a. In the Environments list, select the environment you created for importing your scenes.

 b. In the Jobs list, select the job you created for importing your scenes.

 c. In the File System list, select the database file system where you want your scenes to be 
imported. 
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 14. By default, all the available options in the Data Options section will be checked. It is recommended 
to leave them all enabled so as to import all the assets and information exported by Storyboard Pro.

 l Audio: Imports the sound files exported from your project's audio tracks into the Harmony 
scenes.

 l Database: Imports the metadata exported with the scenes for use by Control Center.

 l Elements: Imports the drawing files exported with the scenes. 

 l Stage (xsheet & network): Imports the structure of the scene: Its drawing layers, composites, 
write nodes and the exposure of each drawing. 

 15. Click on Import.

The imported scenes will be available in the job in which they were imported.
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Exporting Layout Images
T-SBADV-012-003

The Export Layout window lets you export some or all of the scenes in your project to layout images. This can be 
used to properly position scene elements when working on different aspects of the scene throughout 
production. For example, a layout can be imported in Harmony to accelerate its set up and properly position the 
elements and camera keyframes of the scene. Also, a layout exported to .psd format can serve as the base to 
create the background art for the scene so that it is properly adapted to the scene’s layout, action and camera 
movements.

Layout images can be rendered with all layers combined or with one image per layer, and can optionally include 
camera keyframes and movements. Layouts can be exported in .psd (with separate layers), .tga, .jpg or .png 
format.

How to export a Layout

 1. Select File > Export > Layout.

The Export Layout dialog box opens.

 2. In the Destination Path section, click the Browse  button and choose a folder in which to save the 
exported files. 
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 3. In the File Pattern field, type in a prefix or a file naming pattern for the exported files—see About 
File Naming Patterns on page 836.

 4. In the Options panel, select the options you want to use for the exported layout images:

 l File Format: Allows you to select an image format in which to save the layout images:

 l Jpeg (*.jpg): A very compact image format with lossy compression. 

 l Targa (*.tga): An image format with basic lossless compression.

 l Photoshop (*.psd): The format used to store Adobe Photoshop projects. This 
format is uncompressed. 

 l Portable Network Graphics (*.png): An image format with strong lossless 
compression.

 l Transparent Background: When exporting in Photoshop (*.psd) format, enable this 
option to render the layers on a transparent background instead of a solid white 
background. 

 l Base Image Size: Allows you to select whether you export at the same size as your 
project's resolution, at half its dimensions or at a quarter of its dimensions. 

 l Expand Render Area: Expands the area to render into the layouts. By default, only the 
area of the scene that is covered by the camera is rendered, and exported layout 
images are cropped at the edges of the camera frames. If enabled, this option adds 
space around the render area and captures extra details outside the camera frames. 
By default, the render area is expanded by 10%. You can use the input field to the 
right of the option to change this ratio.

 

 l Scale Image Up to Smallest Camera Frame:Ensures that when a camera close-up is 
included in a scene, the exported image is larger so that the closest camera frame is at 
least the size of the chosen image size. This way, the layout does not appear pixelated 
when zooming in on the closest camera frame. If disabled, the size of the exported 
images will be based off the chosen Base Image Size and Expand Render Area 
options.

 l Limit Image Size: If the Scale Image Up to Smallest Camera Frame option is enabled, 
this ensures images do not get scaled up too much. If enabled, images will be limited to 
4096 pixels in width and height by default.
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 l Export One Image Per Layer: Exports each layer as a separate image file. If Print 
Camera Frames option is enabled, the camera frames and camera movements will be 
printed on each layer. 

 l Apply Layer Motion to Camera: When exporting one image per layer and with 
camera frames, if your layers are animated, this option allows you to combine the 
layer's animation with the camera movement that is printed on it. By following the 
resulting camera movement, the layer will appear to be animated just like it is in your 
animatic. 

For example, in a scene where a drawing layer moves towards the right, and the 
camera moves up, the camera movement that will be printed on the layer's layout 
image will be combined with that layer's animation, and the resulting camera 
movement will go up and towards the left, so that the layer itself appears to move 
towards the right.

 l Print Camera Frames: Prints the first and last camera frame of each scene into the 
exported layout images. If exporting in .psd format, the camera frames will be printed 
on a separate layer. 

 l Print a Frame for Each Camera Keyframe: If a scene contains a camera movement 
with more than two keyframes, this prints each camera keyframe into the layout.

 

 l Print Camera Labels: Adds the camera position label in the top-left corner of each 
camera frame. Camera frames are labeled with a letter of the alphabet indicating their 
respective order.
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 5. In the Export Range section, select whether you want to export the entire project, or only specific 
parts of it:

 l All: Exports the entire storyboard.

 l Selected Scenes: Select this option to export a specific selection of scenes. Then, click on the 
Select button to open the Scenes Picker dialog box, in which you can:

 l Type the number of a sequence or of a scene in the Sequence or Scene fields in the 
Filter section, to only show matching sequences or matching scenes in the list.

 l Click and drag to select a range of scenes. 

 l Hold the Ctrl key and click on each scene you want to add to your selection.

 l Hold the Shift key, then click on the first scene and the last scene you want to add to 
your selection, to select every scene between those two scenes inclusively. 

 l If your project has sequences, click on a sequence to select every scene in that 
sequence. 

 l Current Scene: Exports only the currently selected scene. 

 6. To view the location and contents of the exported folder when it is ready, select the Open folder 
after export option.

 7. Click on the Export button.
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Exporting Bitmap Images
T-SBFND-010-007

The Export Bitmap window lets you export a storyboard project to bitmap files in .jpg, .tga, .psd or .png format. 
The exported data includes a separate bitmap file for each panel in the storyboard.

NOTE 

For .psd files, the transform and transition animations are not exported. However, camera moves 
are rendered into an independent layer.

How to export a storyboard to a bitmap file

 1. Select File > Export > Bitmap.

The Export to Bitmap dialog box opens.
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 2. In the Destination Path section, click the Browse  button and choose a folder in which to save the 
exported files. 

 3. In the File Pattern field, type in a prefix or a file naming pattern for the exported files—see About 
File Naming Patterns on page 836.

 4. In the Setup Bitmap Export Parameters panel, select the options you want for the exported bitmap 
images:

 l Bitmap Format: Allows you to select an image format in which to save the exported 
bitmaps:

 l Jpeg (*.jpg): A very compact image format with lossy compression. 

 l Targa (*.tga): An image format with basic lossless compression.

 l Photoshop (*.psd): The format used to store Adobe Photoshop projects. This 
format is uncompressed. 

 l Portable Network Graphics (*.png): An image format with strong lossless 
compression.

 l Resolution: Sets the resolution to be a quarter size, half size, or full size of the current 
storyboard resolution.

 l Image Zoom Level: Sets the magnification of the image. Enter a value between 0 and 
400. The default value is  85%.

 l Transparent Background: This option is only available when the Adobe Photoshop 
(.psd) file format is selected. By default, this option is enabled and will export .psd files 
with a transparent background instead of an opaque white background.

 l Print Camera Frame: Prints the camera frame onto the exported images. If a panel has 
a camera movement, a camera frame will be printed for the position of the camera at 
the beginning of the panel as well as for the position of the camera at the end of the 
panel.

 l Print All Camera Frames: Prints a camera frame for each camera keyframe in the 
panel.

 l Rectify Static Camera: If the camera is at an angle in a panel, and there is no camera 
movement in that panel, enabling this option will render the panel as if the camera 
was at a straight angle. 
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 l Allow Camera Scaling: This option is enabled by default. This ensures that when a 
camera close-up is included in a scene, the exported image is larger so that the closest 
camera frame is at least the size of the chosen resolution. This way, the image will not 
appear pixelated when zooming in on the closest camera frame. If disabled, the 
exported images will be the size of the chosen resolution.

In the following example, the camera zooms out, but the image is exported big 
enough that the closest (smallest) camera frame is exactly the size of the export 
resolution. That way, if the image is zoomed in to the closest camera frame, it 
does not look scaled:

 l Maintain Size Through Scene: Ensures that the elements from the exported panels 
retain their size across the different panels of the same scene. For example, when 
exporting a scene where the camera zooms in on a character through two different 
panels, this option will make it so the character is the same size in both exported 
images. In the same situation with this option unchecked, both bitmaps will be just big 
enough so that their closest camera frame is as big as the chosen export resolution. 

In the following example, the camera zooms out on the scene throughout two 
panels. In the exported images, the scene elements are the same size, but the 
image canvas increases in size as the camera zooms out:  
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NOTE 

By default, exported bitmaps cannot be larger than 4096 x 4096 
pixels, which might cause this option not to work as expected when 
exporting scenes with camera zooms.

 l Expand Render Area to Scene Camera:  By default, exported panels only cover the 
area covered by the camera movements in the panel. With this option enabled, 
exported panels will cover the area covered by the camera movements in all the 
panels in their scene combined. That way, if all the exported panels in a scene are 
combined, the elements of the scene will all be in their proper position respective to 
each other.

In the following example, the camera goes from 1 to 2 in the first panel, then 
from 2 to 3 in the second panel, but both panels are exported to cover the 
whole camera movement, from 1 to 2 to 3: 

 l Include Camera Path: Ensures the exported images include all the areas covered by 
the camera movements. If this option is disabled, the exported images will cover the 
camera keyframes and everything in-between, but may not include parts of the 
panels that are covered by curvilinear camera movements.
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 l Export All Snapshots: If your project has a panel that contains several snapshots, by 
default, only the main snapshot in that panel will be exported. If this option is enabled, 
panels that contain several snapshots will be exported as several image files, one for 
each snapshot. 

NOTE 

To learn more about snapshots, see About Snapshots on page 839. 

 l Snapshot Pattern: When exporting all the snapshots in a panel that contains several 
snapshots, this field allows you to customize how the number of the snapshot is 
appended to the file name. The # symbol represents the number of the snapshot. Its 
default value is -#, which means that a dash followed by the snapshot number is 
appended to the file name. For example, if exporting  panel 4 of scene 16, and that 
panel contains three snapshots, the exported bitmaps for that panel would be named 
MyProject-16-4-1.jpg, MyProject-16-4-2.jpg and MyProject-16-4-
3.jpg.

NOTE 

Only images for panels that contain several snapshots will have a 
snapshot number appended to their file name.

 5. In the Export Range section, select whether you want to export the entire project, or only specific 
parts of it:
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 l All: Exports the entire storyboard.

 l Selected Scenes: Select this option to export a specific selection of scenes. Then, click on the 
Select button to open the Scenes Picker dialog box, in which you can:

 l Type the number of a sequence or of a scene in the Sequence or Scene fields in the 
Filter section, to only show matching sequences or matching scenes in the list.

 l Click and drag to select a range of scenes. 

 l Hold the Ctrl key and click on each scene you want to add to your selection.

 l Hold the Shift key, then click on the first scene and the last scene you want to add to 
your selection, to select every scene between those two scenes inclusively. 

 l If your project has sequences, click on a sequence to select every scene in that 
sequence. 

 l Current Scene: Exports only the currently selected scene. 

 l Current Panel: Exports only the currently selected panel.

 l Tracked Panels:Exports panels on which tracking changes is enabled.
 

 6. In the Burn-In tab, if you want to print the scene names and panel numbers onto the rendered 
images, check the Print Scene and Panel Numbers check-box.
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 7. In the Captions tab, you can choose to print any of your storyboard’s captions into the exported 
bitmaps using the following options—see Captions on page 148.

 l Print Captions: Choose whether to not print captions (None) or select one of your project’s 
captions to print into the exported movies. By default, a Storyboard Pro project has Action 
Notes, Dialog, Slugging and Notes captions, but you can also choose to print custom captions 
if your project has any.

 l Font: Select which font the captions will be printed in. By default, they will be printed in 
Arial.

 l Height %: Sets the size of caption lines relative to the height of the exported movies. For 
example, if exporting a movie at 1080p with 3% Height captions, each caption line will be 32 
pixels in height.

 l Position: Prints the captions at either the Top Left, Top Centre, Top Right, Bottom Left, 
Bottom Centre or Bottom Right of the movie. By default, captions are printed to the Bottom 
Centre.

 l Max Lines: Sets the maximum amount of caption lines to print on each panel. If a caption 
being printed requires more than the maximum amount of lines, it will be cut off with an 
ellipsis (...) at the end. Note that even if captions are printed at the bottom, they will be 
aligned to the top of the space reserved for them, which is calculated by the amount of Max 
Lines x the Height %. Therefore, if this setting is too high and captions are printed at the 
bottom, they may appear closer to the middle of the picture than to the bottom.

 l Text Colour: Select the font colour in which to print the captions.

 l Bg Colour: Select the background colour on which to print the captions. If the checkbox is 
unchecked, the captions will be printed directly into the rendered picture. Otherwise, they 
will be printed in rectangular boxes of the chosen colour.

 8. Select the Open document/folder after export option to view the file when it is ready.

 9. Click on the Export button.
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Exporting the Current Frame as a Bitmap Image
T-SBFND-010-009

You can export the current visible frame to a Targa (.tga), Jpeg (.jpg), Photoshop Document (.psd) or Portable 
Network Graphic (.png) image. If you choose to export in Photoshop Document (.psd) format, the layers in your 
panel will be exported on separate layers in the exported image.

NOTE 

No caption or camera frame will be exported in the image file.

How to export the current frame to .tga, .jpg, .psd or .png image

 1. In the Thumbnails view, select the panel containing the image to export as a bitmap image file.

 2. Select File > Export > Export Current Image.

The Export Current Image window opens.

 3. Select the destination folder for the image.

 4. Type a name for the image.

 5. Select the desired type from the Save as type menu.

 6. Click Save to begin the export.

The image inside the frame is exported as a bitmap image file.
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Exporting an EDL, AAF or XML Sequence
T-SBANIM-007-002

You can export your project into sequences that can be imported in non-linear editing (NLE) systems. This can 
be useful if you just created your storyboard and prefer making it into an animatic using video editing software, 
of if you're ready to edit the finished shots together and want to use the animatic as a template for the final cut.

You can export your project in the following formats:

 l Editing Decision List (.edl): A legacy video editing format that can be imported in most editing software, 
but which has limited capabilities. Can be imported in Final Cut Pro 7, Avid Media Composer and Adobe 
Premiere. 

 l Advanced Authoring Format (.aaf): A binary video editing format with advanced capabilities that can 
be imported in Avid Media Composer, Adobe Premiere, Avid Xpress and Sony Vegas. It has some 
incompatibilities with the transitions supported by Storyboard Pro.

 l Final Cut Pro XML Interchange Format (.xml): An XML video editing format that can be imported 
in Apple Final Cut Pro and Adobe Premiere. It is fully compatible with the capabilities of Storyboard Pro. 

When exporting your project into an editing sequence, Storyboard Pro creates a video render of all the scenes 
in your project, copies each sound file in your project, and creates a sequence file that links to these assets, with 
the same timing for each video and sound clip as in your project. 

WARNING 

The following steps are for exporting a sequence for editing in third party software, but will not 
allow you to apply the changes made to your animatic in the editing software back into your 
Storyboard Pro project. If you want to make changes to your animatic in a third party software, 
then apply these changes to your Storyboard Pro project, see Conformation on page 846.

How to export a storyboard to EDL or AAF or XML

 1. Select File > Export > EDL/AAF/XML. 

The Export to EDL/AAF/XML window opens.

820



 2. In the Destination Path section, click the Browse  button and choose a folder in which to save the 
exported files. 

 3. In the File Pattern field, type in a prefix or a file naming pattern for the exported files—see About 
File Naming Patterns on page 836.

 4. In the File Pattern field, you can set your own pattern which will be used to name the files created 
from the export. Leave this field blank to use the default pattern. The following variables can be 
used to define the file name pattern:

 l %t = Project title

 l %a = Act name (when acts are enabled)

 l %q = Sequence name (when project contains sequences)

 l %s = Scene name

 l %p = Panel name

 l %l = Layer name (when exporting one image per layer)
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You can add a number between the % sign and the letter of the variable to define a minimum 
number of characters to use. 

 5. In Export Type, select all the formats in which to store the editing information (ie: file names and 
timecodes for video and audio clips). One file will be created for each selected format:

 l Generate EDL file: Can be imported in Final Cut Pro, Avid Media Composer and Adobe 
Premiere.

NOTE 

Due to limitations with the EDL format, only the first four audio 
tracks in your project can be exported, and sound clips that are 
used multiple times in the project will only appear one time in the 
exported sequence.

 l Generate AAF file: Can be imported in Avid Media Composer, Avid Xpress, Sony 
Vegas and Adobe Premiere.

NOTE 

Due to limitation with the AAF format, Slide-in and Slide-out 
transitions will be converted to Dissolve transitions, Clock Wipe 
transitions will always be exported as 12 o’clock (0 degree) 
clockwise transitions, and Edge Wipe transitions will be exported 
as either Horizontal, Vertical or Corner Wipe transitions.

 l Generate XML file: Can be imported in Final Cut Pro and Adobe Premiere.

NOTE 

If your editing system is not mentioned above, check its specifications to verify 
which format can be imported.

 6. In the Options section:

 l Movie Format: Movie clips can be exported in Windows Media Video (*.wmv) format 
on Windows and in QuickTime Movie (*.mov) format on either Windows or Mac OS if 
QuickTime Player is installed. This option cannot be changed if only one movie format 
is available for export.
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NOTE 

Not all editing systems support importing Windows Media Video 
files. Check with your software’s documentation to see which movie 
file types are supported.

 l Video Config: Click this button to configure the video settings. When exporting in 
QuickTime, this allows to set the video codec, framerate and quality. When exporting 
in Windows Media Video, this allows to set the variable bit rate quality.

The resolution drop-down right of the Video Config button can be used to 
define the output resolution, since you might not always need to export the 
storyboard at full resolution. You can select Full, Half or Quarter of a project’s 
resolution.

 l One Movie Clip Per Panel: Exports one video file for each panel instead of for each 
scene. This can help obtain better granularity during editing, since the sequence will 
have smaller movie clips.

 l Copy Audio Files: Uncheck this option to skip copying the sound files. By default, the 
project’s sound files are copied to the same directory as the EDL/XML/AAF files and 
the video files when exporting. 

NOTE 

When this option is unchecked, the project’s audio tracks and their 
editing data will still be exported into the EDL/XML/AAF sequence. 
Only the actual sound files will be missing.

 l Generate Video Files: If you only need the EDL, AAF or XML files to be generated, 
uncheck this option so no video files are rendered.

 7. In the Export Range section, select whether you want to export the entire project, or only specific 
parts of it:
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 l All: Exports the entire storyboard.

 l Selected Scenes: Select this option to export a specific selection of scenes. Then, click on the 
Select button to open the Scenes Picker dialog box, in which you can:

 l Type the number of a sequence or of a scene in the Sequence or Scene fields in the 
Filter section, to only show matching sequences or matching scenes in the list.

 l Click and drag to select a range of scenes. 

 l Hold the Ctrl key and click on each scene you want to add to your selection.

 l Hold the Shift key, then click on the first scene and the last scene you want to add to 
your selection, to select every scene between those two scenes inclusively. 

 l If your project has sequences, click on a sequence to select every scene in that 
sequence. 

 l Current Scene: Exports only the currently selected scene. 

 l Current Panel: Exports only the currently selected panel.

 l Tracked Panels:Exports panels on which tracking changes is enabled.

 8. In the Burn-In tab, choose what kind of information you want to have printed into the exported 
files:

 l Print Time Code: Prints the global timecode on each rendered image.

 l Print Scene Names and Panel Numbers: Prints the scene names and panel numbers as an 
overlay on your video.

 l Print Additional Duration: Prints another time code counting the time for the current panel, 
scene or sequence, depending on what is selected in the Repeat drop-down.

 l Units: Whether to print the additional duration in time units (seconds, minutes, etc.) or 
in frames. 
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 l Repeat: Decide what to count the time of for the additional duration. For example, if 
set to per Panel, the time elapsed since the beginning of the current panel will be 
printed. 

 9. In the Camera Grids tab, using these options, decides whether you want any kind of camera frame 
to be printed into the exported files:

 l Title Safe Area: Prints the Title Safe Area over the picture. By default, this area is 20% 
smaller than the camera frame. It is used as a guideline of the area that CRT displays might 
crop out of the picture. Visual elements such as text and logos should be placed within this 
area.

 l Action Safe Area: Prints the Action Safe Area over the picture. By default, this area is 10% 
smaller than the camera frame. It is used as a guideline of the area that CRT displays might 
crop out of the picture. Characters and action should be placed within this area. 

 l 4:3 Safety: Prints the title safe area and the action safe area for the 4:3 camera frame over 
the exported image. They can be used to position elements in projects that are meant to be 
displayed in both widescreen and 4:3 proportions.

 l 4:3 Reference: Prints the 4:3 camera frame over the exported image. This frame corresponds 
to the camera frame if the aspect ratio of the picture was 4:3. It can be used to position 
elements in projects that are meant to be displayed in both widescreen and 4:3 proportions.

 10. In the Captions tab, you can choose to print any of your storyboard’s captions into the exported 
movies using the following options—see Captions on page 148.

825

Storyboard Pro 6. User Guide                          



Chapter 20: Exporting

 l Print Captions: Choose whether to not print captions (None) or select one of your project’s 
captions to print into the exported movies. By default, a Storyboard Pro project has Action 
Notes, Dialog, Slugging and Notes captions, but you can also choose to print custom captions 
if your project has any.

 l Font: Select which font the captions will be printed in. By default, they will be printed in 
Arial.

 l Height %: Sets the size of caption lines relative to the height of the exported movies. For 
example, if exporting a movie at 1080p with 3% Height captions, each caption line will be 32 
pixels in height.

 l Position: Prints the captions at either the Top Left, Top Centre, Top Right, Bottom Left, 
Bottom Centre or Bottom Right of the movie. By default, captions are printed to the Bottom 
Centre.

 l Max Lines: Sets the maximum amount of caption lines to print on each panel. If a caption 
being printed requires more than the maximum amount of lines, it will be cut off with an 
ellipsis (...) at the end. Note that even if captions are printed at the bottom, they will be 
aligned to the top of the space reserved for them, which is calculated by the amount of Max 
Lines x the Height %. Therefore, if this setting is too high and captions are printed at the 
bottom, they may appear closer to the middle of the picture than to the bottom.

 l Text Colour: Select the font colour in which to print the captions.

 l Bg Colour: Select the background colour on which to print the captions. If the checkbox is 
unchecked, the captions will be printed directly into the rendered picture. Otherwise, they 
will be printed in rectangular boxes of the chosen colour.

 11. If you want to automatically play the video or view the exported files once the export is done, check 
the Open document/folder after export option.

 12. Click on the Export button.

 13. You can now import the sequence into a third party editing software. Refer to the documentation of 
your editing software for information on importing the sequence into a project and editing it. 
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Exporting 3D Animation (FBX) Files
T-SBADV-012-004

You can export your project's scenes, sequences or the entire project into animated Filmbox (.fbx) files.  This can 
be useful if your project has 3D elements. The exported Filmbox (.fbx) file will contain all the 2D and 3D 
elements in your animatic as well as their animation. You can them import it in a third-party software and use it 
as a template to create the 3D animations for your production.

How to export an FBX file

 1. Select File > Export > FBX.

The Export to FBX dialog box opens.

 2. In the Destination Path section, click the Browse  button and choose a folder in which to save the 
exported files. 

 3. In the File Pattern field, type in a prefix or a file naming pattern for the exported files—see About 
File Naming Patterns on page 836.

 4. To include the camera frame’s black border in the scene, select the Export Camera Frame option.

 5. From the One Clip list, select one of the following:

 l Per Scene: Exports one clip per scene.

 l Per Project: Exports one clip for the entire project.

 l Per Sequence: Exports one clip per sequence. This option is available only if your project 
contains sequences.
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 6. In the Export Range section, select whether you want to export the entire project, or only specific 
parts of it:

 l All: Includes all the scenes in your project.

 l Current Scene: Includes only the scene you selected when you opened this dialog box.

 l Current Sequence: Includes only the scenes from the sequence you selected when you 
opened this dialog box. This option will only be visible if your project contains sequences.

 7. Click the OK button. 
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Exporting Sound Files
In Storyboard Pro, you can export your project’s audio into Waveform Audio Files (.wav). You can choose to 
export a single file for all your project's audio tracks, or to export each audio track individually. You can also 
choose to export a single track for your whole project, or to separate it by scene, sequence or act.

How to export your project's audio

 1. Select File > Export > Audio.

The Export Audio dialog opens.

 2. In the Destination Path section, click the Browse  button and choose a folder in which to save the 
exported files. 

 3. In the File Pattern field, type in a prefix or a file naming pattern for the exported files—see About 
File Naming Patterns on page 836.

 4. In the Options section, select the way you want the software to process your soundtracks:

 l Process Audio Tracks Individually: Exports each audio track in your project into 
separate sound files. 

 l Merge All Audio Tracks: Mixes down all the audio tracks in your project into a single 
soundtrack before exporting it.
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 l Process Audio Tracks Individually and Merged: Exports each audio track into 
separate sound files, then exports another file with all the audio tracks mixed 
together. 

 l Don't Break Sound: Exports audio tracks spanning for the entire length of your 
project. If you chose to merge audio tracks, you will have one sound file for the entire 
project. If you chose to export audio tracks separately, you will have one sound file for 
each audio track in your project.

 l Break Sound Per Scene: Breaks down each exported audio track into scenes. If you 
chose to merge the audio tracks, you will have one sound file for each scene in your 
project. If you chose to export audio tracks separately, you will have one sound file per 
scene per audio track.

 l Break Sound Per Sequence: Breaks down each exported audio track into sequences. 
If you chose to merge the audio tracks, you will have one sound file for each sequence 
in your project. If you chose to export audio tracks separately, you will have one sound 
file per sequence per audio track. This option is only available if your project contains 
sequences.

 l Break Sound Per Act: Breaks down each exported audio track into acts. If you chose 
to merge the audio tracks, you will have one sound file for each act in your project. If 
you chose to export audio tracks separately, you will have one sound file per actper 
audio track. This option is only available if your project contains acts.

 5. In the Sound Settings section:

 l Sample Rate: Sets the frequency rate of the exported audio files. It is recommended to 
export sound files at the rate at which they were originally created. For reference, the 
standard sample rate is 48.0 kHz for broadcasting and DVD.

 l Bit Depth: Sets the precision level of each wavelength in the sound file. The standard 
bit depth is 16 bit. Setting this to 8 bit will cut the size of audio files in half, but will 
significantly impact sound quality.

NOTE 

On Windows, audio can only be exported in 16 bit unless QuickTime 
Player is installed.

 l Channels: Allows you to select whether to export sound in Mono or Stereo. Stereo 
sound uses a separate track for the left and right speakers, which allows to simulate a 
realistic sound environment. Mono uses a single track for both speakers, which saves 
disk space. 
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 6. In the Export Range section, select whether you want to export the entire project, or only specific 
parts of it:

 l All: Exports the entire storyboard.

 l Selected Scenes: Select this option to export a specific selection of scenes. Then, click on the 
Select button to open the Scenes Picker dialog box, in which you can:

 l Type the number of a sequence or of a scene in the Sequence or Scene fields in the 
Filter section, to only show matching sequences or matching scenes in the list.

 l Click and drag to select a range of scenes. 

 l Hold the Ctrl key and click on each scene you want to add to your selection.

 l Hold the Shift key, then click on the first scene and the last scene you want to add to 
your selection, to select every scene between those two scenes inclusively. 

 l If your project has sequences, click on a sequence to select every scene in that 
sequence. 

 l Current Scene: Exports only the currently selected scene. 

 7. Select the Open folder after export option to have the system automatically open the folder 
containing your exported audio files.

 8. Click on the Export button.
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Exporting CSV Tables
T-SBADV-012-005

You can export the metadata of your storyboard, such as the names of scenes, panels and layers, transitions, 
captions and camera information into a Comma Separated Value (.csv) format table. You can then view and edit 
the Comma Separated Value (.csv) file in any standard spreadsheet editor, such as Microsoft Excel, OpenOffice 
Calc or Google Sheets. This can be useful if you need to analyze any specific aspect of your project. If you export 
your project's captions, you can also edit them, then import the edited .csv file back into Storyboard Pro to 
update your project's captions. This can be useful if you want to review and edit your storyboard's captions in 
bulk using a more lightweight interface. 

How to export a storyboard to a CSV file

 1. Select File > Export > CSV.

The Export to  CSV dialog box opens.

 2. In the Destination Path section, click the Browse  button.

 3. In the Save dialog, browse to the location in which you want to export your CSV file. In the File name 
field, type in the desired name for the document and click on Save.
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 4. In the Encoding drop-down, select the type of text encoding for the CSV file. Choosing the right 
encoding might be necessary depending on what kind of encoding the editor you plan to use 
supports, and whether it needs a specific kind of encoding for Unicode characters. In most cases, 
UTF-8 should do the job.

 5. In the Field Separator drop-down, select the character to use for separating each cell in the table. 
Generally, CSV editors expect the field separator to be commas. Otherwise, you can choose 
between the following characters: Comma, Semicolon, Tab or Vertical bar (pipe). 

 6. Check each type of data that you want to include in the exported table. 

The exported .csv file will contain one row for each exported panel. It will also have at least one 
column, the Object Id column, which stores a special identifier composed of 16 hexadecimal 
characters for each panel in your storyboard, making sure that Storyboard Pro can identify which 
row belongs to which panel in your project. 

 l Include Column Names: Adds an extra header row at the top which indicates the purpose of 
each column in the table.

 l Include Sequence Names:          Adds a Sequence column which indicates the number of the 
sequence for each panel.     

 l Include Scene Names: Adds a Scene column which indicates the number or name of each 
scene for each panel. 

 l Include Panel Names:          Adds a Panel column which indicates the number or name of each 
panel.     

 l Include Transitions: Adds a column for each transition in the project, between the rows 
corresponding to the two panels that are joined by the transition.

 l Include Scene Frame Number: Adds a column that indicates the length of the scene in 
frames.

 l Include Panel Frame Number: Adds a column that indicates the length of the panel in 
frames.

 l Include Captions: Adds a column for each caption type in your project, and which will 
indicate the content of each caption type for each panel.

 l Include Rich Text Formatting: If your captions have any formatting, check this option to 
export the content of your captions in HTML, which will preserve the formatting of your 
captions. If this option is unchecked, your captions will be exported in plain text. They will be 
easier to read and edit, but if you re-import the .csv file into your project, the formatting of the 
captions will be lost. 

 l Include Camera Information: Indicates whether the camera is static or dynamic 
(animated) for each panel.
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 l Include Layer Names: This will add as many columns as the amount of layers in the panel 
that has the most layers. For each panel, the name of each layer in the panel will be 
indicated. Layers at the bottom are listed in the leftmost layer column, and layers at the top 
are listed in the rightmost layer column. 

 l Include Tracking Information: Indicates whether or not the panel is tracked, the date at 
which the panel started getting tracked, and the tracking notes added to that panel, if any. 

 7. In the Export Range section, select whether you want to export the entire project, or only specific 
parts of it:

 l All: Exports the entire storyboard.

 l Selected Scenes: Select this option to export a specific selection of scenes. Then, click on the 
Select button to open the Scenes Picker dialog box, in which you can:

 l Type the number of a sequence or of a scene in the Sequence or Scene fields in the 
Filter section, to only show matching sequences or matching scenes in the list.

 l Click and drag to select a range of scenes. 

 l Hold the Ctrl key and click on each scene you want to add to your selection.

 l Hold the Shift key, then click on the first scene and the last scene you want to add to 
your selection, to select every scene between those two scenes inclusively. 

 l If your project has sequences, click on a sequence to select every scene in that 
sequence. 

 l Current Scene: Exports only the currently selected scene. 

 l Current Panel: Exports only the currently selected panel.

 l Tracked Panels:Exports panels on which tracking changes is enabled.

 8. To view the exported file in your machine's spreadsheet editor after the export, enable the Open 
document/folder after export option.

 9. Click on the Export button.
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About Advanced Export Techniques
Storyboard Pro features some advanced exporting techniques, namely: Excluding certain layers from certain 
types of exports, using variables in file naming patterns and using snapshots to export specific frames of certain 
panels. The following section explains how to use these advanced features. 
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About File Naming Patterns
T-SBADV-012-002

Several export dialogs in Storyboard Pro allow you to export several files at a time. By default, these dialogs will 
name each file they export with the necessary information to identify them: Scene number, panel number if the 
export is broken down into panels, and frame number when exporting an image sequence. However, these 
dialogs all have a File Pattern field. If you prefer, you can fill this field with a file pattern to determine how your 
exported files will be identified.

Variables
A file naming pattern are composed of variables. The following variables can be used, depending on the type of 
export, and on how the export is broken down:

Variable Definition Availability

%t Project title Always available.

%a Act number
When exporting one file per act, sequence, scene, panel or frame, and the 
project is separated in acts.

%q
Sequence 
number

When exporting one file per sequence, scene, panel or frame, and the project 
is separated in sequences.

%s Scene number When exporting one file per scene, panel or frame.

%p Panel number When exporting one file per panel or frame.

%f
Frame 
number

When exporting one file per frame (i.e.: an image sequence).

%n
Sound track 
number

When exporting sound files separated by sound track.

For example, when exporting an image sequence in Jpeg (.jpg) with a file pattern such as MyProject - 
scene %s - panel %p - frame %f, frame 44 in panel 3 of scene 2 would be exported as MyProject - 
scene 2 - panel 3 - frame 44.jpg.

If you put a variable in the file naming pattern that is not relevent for your export, for example the %p panel 
number variable when exporting one file per scene, the variable name will appear in the file name. 
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Padding
Storyboard Pro will automatically pad the numbers with zeros as needed. For example, if you're exporting a 
sequence of 10 scenes, the scenes will be numbered 01, 02, ... until 10. This way, all the scenes have the same 
amount of digits, making it easier to sort them in alphanumeric order.

If you prefer, you can decide the minimum amount of padding you want for each variable. To do this, simply add 
the amount of digits you want a variable to have between the % sign and the variable letter. For example, 
instead of %s, put %4s, and scene numbers in the file name will all have four digits. Scene numbers that would 
require less than four digits will be padded with zeros at their left. For example, scene 1 will be indicated with 
the number 0001. 

Fallback
If you prefer a more simple approach, you can always type a name in plain text in the File Pattern field. This 
name will be used as a prefix: Your exported files will contain the name you typed, followed by the required 
information (i.e.: scene number, panel number, etc.) separated by dashes. 

Likewise, if you type in a pattern that does not contain all the required variables, your exported files will have 
the missing variables added at the end, separated by dashes. For example, if you're exporting one image per 
panel, but type in a file naming pattern that only uses the %s scene number variable, the panel number will be 
added at the end of each file's name. This avoids exporting several files with the same name. 

At any time, you can just delete the content of the File Pattern field to let Storyboard Pro use its default file 
naming pattern, which will contain all the necessary information.
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Enabling and Disabling Layers for Export
T-SBADV-012-001

When exporting your storyboard, you can set the export behaviour for each layer. This can be handy if you 
have reference layers that you do not necessarily want to see in your final export. You can set individual layer 
export settings in the Layers panel.

How to change individual layer export behaviour

 1. Add the Layers view to your workspace by doing one of the following:

 l In the top-left corner of an existing view, click on the  Add View button and select Layers.

 l In the top menu, select Windows > Layers. 

 2. From the Thumbnails or Timeline view, select the panel containing the layer for which you want to 
change export options.

 3. In the Layers view, select the layer for which you want to change export options. 

 4. In the Export To section of the Layers view, check the export mediums in which you want the layer 
to be included, and uncheck the export mediums from which you want it to be excluded:

 l If you want the layer to be included when exporting your project as a Portable Document File 
(.pdf), unchechk PDF. Otherwise, uncheck it. 

 l If you want the layer to be included  when exporting your project as movie files or image 
sequences, check Movie. Otherwise, uncheck it.

 l If you want the layer to be included when exporting your project as Harmony scenes, 
check Harmony. Otherwise, uncheck it.
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About Snapshots
When you export your storyboard as a PDF document, by default, only the first frame of each panel is exported 
into the document. Likewise, if you export your storyboard as bitmap images, each exported image will contain 
the first frame of its respective panel. 

However, there might be situations where a panel is better represented by a specific frame in the middle of the 
panel rather than its first frame. For example, if the panel has a lot of layer animation, one of the in-between 
frames of that animation could be a lot more descriptive than the panel's first frame. 

Using Snapshots, you can indicate to Storyboard Pro which frame in a panel is the best frame to represent that 
panel when exporting it as a still image. A snapshot is simply a marker positioned on one of your panel's frames. 
When you export your storyboard as a PDF document or as bitmap images, if one of the exported panels 
contains a snapshot in one of its frames, this frame will be used to represent the panel in the exported image, 
instead of the first frame of the panel. 

You can add several snapshots to a panel. When you export your storyboard as a PDF document, each frame 
that is marked with a snapshot will be included in the storyboard, allowing you to export more than one frame 
for a single panel if necessary. When exporting your project as bitmap images, you can choose whether only 
the main snapshot of a panel that has several snapshots should be exported, or all of its snapshots. 
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When a 3D scene which contains a camera movement is exported in a PDF document, the panel is usually 
represented by two thumbnails: the first frame of the camera movement, and the last frame of the camera 
movement. Adding a snapshot to such a panel adds an extra thumbnail in the PDF. 

Using snapshots is completely optional and flexible. If you add a snapshot to a panel, Storyboard Pro will use 
the snapshot when exporting the panel as a PDF or as a bitmap image. If you don't add snapshots or if you 
delete snapshots from a panel, Storyboard Pro will use the first frame of the panel. When you add a snapshot, 
it is always added at the current frame, so you know what the panel will look like when you add a snapshot by 
looking at the Stage or Camera view. A marker for each snapshot is added to the Timeline view to help you 
keep track of them.

NOTE 

Snapshots do not affect the exported images when exporting layouts.
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Adding Snapshot Markers
T-SBFND-010-003

How to add a snapshot marker to a panel

 1. In the Timeline view, select the panel to which you want to add a snapshot marker.

 2. Position the timeline playhead to the exact position where you want to add a snapshot. While 
moving the timeline playhead, you can look at the Stage or Camera view to get a preview of what 
the snapshot will look like. 

 3. Do one of the following:

 l Select Storyboard > Add Snapshot.

 l Right-click the panel and select Add Snapshot.

The Snapshot marker, a blue arrow, appears in the Timeline view. 

 4. Repeat the previous steps to add additional snapshots to your panel, if desired. 
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Change Snapshot Frame
You can change the frame at which a panel's snapshot is simply by dragging it to the preferred frame in the 
Timeline view.

How to move a snapshot to a different frame in a panel

 1. Position the mouse cursor over the snapshot that you want to set as the main snapshot.

 2. When you see the Grab  mouse cursor, click and drag the snapshot to the frame where you want 
it to be.

As you move the snapshot, the Stage and Camera views will update to the position of the snapshot, 
so you can use either view as a reference to see what is in the snapshot's new position. 

NOTE 

You can only move a snapshot within its panel. If you move a snapshot outside of its panel, it 
will be deleted. 
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Setting the Main Snapshot in a Panel
Because exporting your storyboard as bitmap images exports only one image per panel, if a panel has several 
snapshots, Storyboard Pro can only export one of the snapshots for the panel. In order to decide which 
snapshot to use, it will use the panel's main snapshot. 

The main snapshot in a panel is indicated by its colour. In the Timeline view, a panel's main snapshot will 
appear in plain blue , whereas the other snapshots will appear in a darker shade of blue .

When you add more than one snapshot to a panel, the first snapshot you add is set as the main snapshot. At 
any time, you can change which snapshot in a panel is the panel's main snapshot. 

How to set the main snapshot for a panel

 1. Position the mouse cursor over the snapshot that you want to set as the main snapshot.

 2. When you see the Grab  mouse cursor, double-click on the snapshot.

The snapshot you double-clicked on will become a lighter shade of blue , and the snapshot that 
used to be the main snapshot will turn a darker shade of blue .
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Deleting Snapshot Markers
You can remove snapshot markers from the currently selected panel.

How to delete a snapshot marker

 1. Position the mouse cursor over the snapshot that you want to set as the main snapshot.

 2. When you see the Grab  mouse cursor, click and hold on the snapshot.

 3. Drag the snapshot either to the left beyond the starting point of the panel, or to the right beyond 
the ending point of the panel. When the snapshot is taken too far and disappears, release the 
mouse button.

The snapshot is deleted.
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Chapter 21: Conformation
T-SBANIM-006-002

In Storyboard Pro, you can export your Storyboard Pro project to Final Cut Pro, an Apple third party editing 
software, or Media Composer, an Avid third party editing software. You can then make your edits and import 
the changes back into your Storyboard Pro project using the Conformation feature. The conformation export 
will produce an XML or an AAF file containing the entire animatic project structure, as well as images of your 
panels. You can then import the XML into Final Cut Pro and the AAF into Media Composer and it will recreate 
the animatic.

You can also track the changes in your panels and export tracked panels only.

What is exported:

 l Panels exported as clips in the top composition. Rendering of the first frame of the panel is used as 
source image.

 l (XML only) Layers can be exported individually in nested clip. Layer motion keyframe is also exported.

 l Transitions type and duration.

 l Sounds clips (start/end frame) and volume keyframes.

 l Camera motion is exported as clip animation.

 l Optionally, all scenes' first frame can be exported as markers.

 l Optionally, panel captions can be exported as clip metadata.

 l Optionally, a scene reference track can be exported.  Each clip on this track represents a scene in 
Storyboard Pro.

 l Other metadata are exported in order to allow the conformation; panel ID, transformation data, project 
resolution.

What is conformed back:

 l Panels ordering and duration.

 l Duplication of panels; the original panels will be duplicated.

 l Deletion of panels; the original panels will be deleted.

 l New clips are conformed as new panels, source image is imported.

 l (XML only) New layers in the nested sequence are conformed as new layer, source image is imported.

 l Change of transition duration.

 l Change of transition type is conformed if supported by Storyboard Pro.

 l Unknown transitions are imported as dissolves.
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 l Adjustments to clip animation are conformed as camera motion. When conformed back, camera motion 
is optimized and redundant keyframes are removed.

 l (XML only) Adjustments to clip animation in nested clip are conformed as layer motion.

 l Changes to sound clip start time and duration.

 l Add/copy/move/delete sound clips.

 l Delete or add sound tracks.

 l Add/remove/update volume keyframes.

NOTE 

If your project contains video tracks, they will not be exported for conformation and they will not be 
affected when importing the edited sequence. 
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About XML Conformation
T-SBANIM-006-003

In Storyboard Pro, you can export your Storyboard Pro project to Final Cut Pro, an Apple third-party editing 
software.  Storyboard Pro is compatible with the XML format compatible with Final Cut Pro 7.

XML conformation is the most advanced way to conform with Storyboard Pro, since animation layers are 
supported on export and conform back.  You can also create a new layer inside a nested clip in Final Cut Pro, to 
create a new layer when importing the XML.

Guidelines:

Final Cut Pro (or other third party software compatible with FCP XML) have a wide variety of features or effects 
not compatible with Storyboard Pro.  For the conformation to be successful, the XML project must respect some 
rules and guidelines.

 l The XML sequence imported in Storyboard Pro should have been originally created in Storyboard Pro.

 l The structure of the composition (number of video tracks and order) in Final Cut Pro needs to respect the 
structure of the XML originally exported from Storyboard Pro.

 l All clips representing a panel need to be on the same video track. Other tracks will be ignored on import.

 l Metadata associated with original clips exported from Storyboard Pro must not be altered.

 l New clips and new layers should use image formats compatible with Storyboard Pro. See Importing 
Images as Layers on page 204 for details about supported formats.

 l New sound clips should use sound files compatible with Storyboard Pro. See  Importing Sound Clips on 
page 609 for details on supported formats.

 l On import, transitions not supported by Storyboard Pro will be imported as Dissolve transitions, timing 
will be preserved.
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In Storyboard Pro, you can export your Storyboard project to Media Composer, an Avid third party editing 
software.

Media Composer has its own compatibility with the AAF.  It does not follow the AAF Edit Protocol.  Since 
Storyboard Pro specifically targets Media Composer for conformation, the AAF exported by Storyboard Pro will 
not necessarily produce good results in other software used to import AAF.

Guidelines

Media Composer has a wide variety of features or effects not compatible with Storyboard Pro.  For a successful 
conformation, the AAF project must respect some rules and guidelines.

 l The AAF sequence imported in Storyboard Pro should have been originally created in Storyboard Pro.

 l The structure of the composition (number of video tracks and order) in Media Composer needs to respect 
the structure of the AAF originally exported from Storyboard Pro.

 l All clips representing a panel need to be on the same video track. Other tracks will be ignored on import.

 l Storyboard Pro exports the camera motion using a 3D Warp effect on the clip.  You should use the same 
pattern if you want to have camera motion on the new clip when conforming back the AAF.

 l Metadata associated to original clips exported from Storyboard Pro must not be altered.

 l In Media Composer, images should be imported using the Import Media options (not Link to Media).  In 
the import settings of Media Composer, Resize image to fit format raster should be used for the Image 
Size Adjustment option.

 l New clips and new layers should use image formats compatible with Storyboard Pro. See Importing 
Images as Layers on page 204 for details about supported formats.

 l New sound clips should use sound files compatible with Storyboard Pro. See Importing Sound Clips on 
page 609 for details about supported formats.

 l If you want to add new sound files in Media Composer, stereo sound files should be added to stereo 
tracks and mono sound files to mono tracks.

Transition Compatibility

Not all Storyboard Pro transition types are supported by Media Composer. When a transition is not supported, 
it will be converted at export time and a warning message will be displayed. Here are transitions not supported 
by Media Composer:

 l Slide-in and Slide-out transition are converted to dissolve.

 l Only 12 o’clock (0 degrees) clockwise is supported by Media Composer, therefore, all clock wipes are 
exported as 12 o’clock clockwise.
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 l Media Composer only supports horizontal wipe, vertical wipe, or corners wipe (45, -45, 135 and -135).  
All edge wipes with custom angles will be converted to the nearest wipe supported by Media Composer.
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Exporting for Conformation
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When you are ready to export, decide if you need to export the entire project, only the tracked panels or 
specific panels. If you are exporting to Flix, you can automate the process by using scripts.

NOTE 

When only selected or tracked panels are exported, the timeline in the third party software will 
have holes.  This selective export is not recommended if you plan to conform the project back, since 
the panels excluded from the XML/AFF will be deleted.

How to export for Conformation

 1. Do one of the following:

 l To export the entire project, select File > Conformation > Export Project in the top menu.

 l To export a selection of panels, select all the panels you want to export in the Thumbnails or 
Timeline view. Then, select File > Conformation > Export Selected Panels in the top menu.

 l To export only tracked panels, select File > Conformation > Export Tracked Panels in the 
top menu.
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 2. In the Destination Path section, enter the folder and the name for the exported files and optionally, 
enter a file pattern for exported images.

 3. Select the target format, Final Cut Pro XML if you want to export a sequence for Final Cut Pro 7, or 
AAF if you want to export a sequence for Avid Media Composer.

 4. If you have already exported your sequence in the same destination folder in the past, and you only 
want to export the sequence again without rendering the images again, uncheck the Render 
Images on Export option. Otherwise, keep this option checked at all times. 
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 5. In the Options tab, enable the options you want to use for exporting your project:

 l Export one image per layer: Exports the drawing layers in your panels as separate video clips 
instead of flattening them together to make one clip per panel. This option is only available 
when exporting in Final Cut Pro XML format.

 l Always nest layers: When exporting one image per layer, this will store all the layers for a 
single panel into a nested clip. By default, different layers are spread on different video 
tracks, except when a panel contains both camera movements and layer animations. 

 l Print Camera Frame: Prints the camera frames on the exported images. The first camera 
frame will be printed in green, and the last camera frame will be printed in red.

 l If the camera is at an angle in a panel, and there is no camera movement in that panel, 
enabling this option will render the panel as if the camera was at a straight angle. 
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 l Maintain image size throughout scene:          By default, the resolution of each image that is 
exported so that, at the end of a camera zoom-in, or at the beginning of a camera zoom-out, 
there is no pixelation. This means that the smallest camera frame in each panel must be at 
least the same resolution of the project. Hence, panels with small camera frames will have to 
be exported at a bigger resolution than other panels. For example, the following panel must 
be exported in a bigger resolution than the project's resolution, so that the smallest camera 
frame has the same resolution as the project:

This can also mean that, within a same scene, a panel that has a camera zoom-in or zoom-out 
will have to be exported in a bigger resolution than the other panels in the scene. With this 
option enabled, all the panels in any given scene are exported in the same resolution. 

NOTE 

The panels will appear as expected in your video editing software regardless of 
whether or not this option is enabled. 

 l Expand Render Area to Scene Camera:  By default, exported panels only cover the area 
covered by the camera movements in the panel. With this option enabled, exported panels 
will cover the area covered by the camera movements in all the panels in their scene 
combined. That way, if all the exported panels in a scene are combined, the elements of the 
scene will all be in their proper position respective to each other.

In the following example, the camera goes from 1 to 2 in the first panel, then from 2 to 3 in 
the second panel, but both panels are exported to cover the whole camera movement, from 1 
to 2 to 3: 
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 l Bitmap Format: Allows you to select the image format in which to save the exported panels:

 l Jpeg (*.jpg): A very compact image format with lossy compression. 

 l Targa (*.tga): An image format with basic lossless compression.

 l Photoshop (*.psd): The format used to store Adobe Photoshop projects. This format is 
uncompressed. 

 l Portable Network Graphics (*.png): An image format with strong lossless 
compression.

NOTE 

Since the images exported for conformation are generally not imported into the 
Storyboard Pro project when you re-import your sequence, the quality of 
exported images is not critical. Hence, the default image format for conformation 
is Jpeg (*.jpg). Although Jpeg images do not preserve picture quality, they are 
quicker to export and do not use a lot of disk space. 

 l Export Markers at Scene Beginning: Places a chapter marker at the beginning of each scene. 
These markers are used to find the in-point of each scene when conforming from Final Cut 
Pro to Storyboard Pro.  The markers are named "Scene:" followed by the name of their 
respective scene, and they have a unique scene ID and chapter marker as their comment.

 l Export scenes references track: Adds an extra video track to the sequence in which images 
indicating the number of the current scene are displayed. 

 l Export Captions: Includes the captions of each panel as metadata in the exported sequence. 
The captions can be edited in the sequence, and importing modified captions will update the 
captions in the Storyboard Pro project. 

 l Include Rich Text Formatting: If you're exporting the project's captions and your captions 
have special text formatting, this will export the captions in HTML instead of plain text, to 
preserve their formatting. If you export your captions in plain text, then re-import them, they 
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will lose their formatting. However, plain text captions are easier to read and edit in third 
party software.

 6. In the Burn-In tab, if you want to print the scene names and panel numbers onto the rendered 
images, check the Print Scene and Panel Numbers check-box.

 7. In the Camera Grids tab, using these options, decides whether you want any kind of camera frame 
to be printed into the exported files:

 l Title Safe Area: Prints the Title Safe Area over the picture. By default, this area is 20% 
smaller than the camera frame. It is used as a guideline of the area that CRT displays might 
crop out of the picture. Visual elements such as text and logos should be placed within this 
area.

 l Action Safe Area: Prints the Action Safe Area over the picture. By default, this area is 10% 
smaller than the camera frame. It is used as a guideline of the area that CRT displays might 
crop out of the picture. Characters and action should be placed within this area. 

 l 4:3 Safety: Prints the title safe area and the action safe area for the 4:3 camera frame over 
the exported image. They can be used to position elements in projects that are meant to be 
displayed in both widescreen and 4:3 proportions.

 l 4:3 Reference: Prints the 4:3 camera frame over the exported image. This frame corresponds 
to the camera frame if the aspect ratio of the picture was 4:3. It can be used to position 
elements in projects that are meant to be displayed in both widescreen and 4:3 proportions.

 8. In the Captions tab, you can choose to print any of your storyboard’s captions into the exported 
movies using the following options—see Captions on page 148.
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 l Print Captions: Choose whether to not print captions (None) or select one of your project’s 
captions to print into the exported movies. By default, a Storyboard Pro project has Action 
Notes, Dialog, Slugging and Notes captions, but you can also choose to print custom captions 
if your project has any.

 l Font: Select which font the captions will be printed in. By default, they will be printed in 
Arial.

 l Height %: Sets the size of caption lines relative to the height of the exported movies. For 
example, if exporting a movie at 1080p with 3% Height captions, each caption line will be 32 
pixels in height.

 l Position: Prints the captions at either the Top Left, Top Centre, Top Right, Bottom Left, 
Bottom Centre or Bottom Right of the movie. By default, captions are printed to the Bottom 
Centre.

 l Max Lines: Sets the maximum amount of caption lines to print on each panel. If a caption 
being printed requires more than the maximum amount of lines, it will be cut off with an 
ellipsis (...) at the end. Note that even if captions are printed at the bottom, they will be 
aligned to the top of the space reserved for them, which is calculated by the amount of Max 
Lines x the Height %. Therefore, if this setting is too high and captions are printed at the 
bottom, they may appear closer to the middle of the picture than to the bottom.

 l Text Colour: Select the font colour in which to print the captions.

 l Bg Colour: Select the background colour on which to print the captions. If the checkbox is 
unchecked, the captions will be printed directly into the rendered picture. Otherwise, they 
will be printed in rectangular boxes of the chosen colour.

 9. Select the Notify Flix option to automatically update the Flix assets database.

 10. Select the Open folder after export option to open the folder where the files will be stored when 
the export is complete.

 11. Click on Export.
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Importing an Edited XML or AAF Sequence back for Conformation
T-SBANIM-006-008

Once you have imported your project’s conformation (XML or AAF) into the third party software and completed 
editing, you will need to export it once again as an XML or AAF file to bring it back into your Storyboard Pro 
project.

NOTE 

Refer to your third party software’s documentation to learn how to export the animatic project in 
an XML or AAF file format.

IMPORTANT 

You can only reimport a modified conformation XML or AAF file into the original project from which 
it was first exported.

How to import a video editing sequence into your project

 1. In your original storyboard project, select File > Conformation > Import Animatic Project.

The Import Project window opens.

 2. Click the Browse  button and locate your XML or AAF file.
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 3. In the Options section, all of the options are enabled by default:

 l Process Audio: Uncheck this if you don't want the changes done to the audio tracks or sound 
clips in the sequence you're importing to be applied to your Storyboard Pro project. Your 
project's audio tracks will be left untouched.

 l Process Video: Uncheck this option if you don't want the changes done to the panels, scenes 
or transitons in the sequence you're importing to be applied to your Storyboard Pro project. 
This can be useful if you only wish to conform edits to the project's audio tracks. 

TIP 

You can import audio tracks composed from scratch in a video editing software by 
exporting them into an XML or AAF sequence, then importing the sequence via 
this dialog, with the Process Video option unchecked. 

 l Process Captions: Uncheck this option if you don't want changes to captions done in the 
sequence you're importing to be applied to your Storyboard Pro project. 

NOTE 

If you exported your captions without Rich Text Formatting, and made changes 
to them, they will lose their formatting when the changed captions are imported 
into your project. 

 4. Click OK to return to the Import Project window.

The Report section displays information relative to the conformation process. If an error happened 
during the conformation process, this is also where the details relative to this error would appear.
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Chapter 22: Scripting
Qt Script provides access to many of the functions supported in the  Storyboard Pro interface. With Qt Script, 
you can automate a number of Storyboard Pro functions to speed up the completion of various repetitive tasks.

Qt Script is an object-oriented scripting language based on the ECMAScript standard, like JavaScript and 
JScript. However, there are some differences that distinguish Qt Script from these other scripting languages, 
which are familiar to web programmers.

860



Scripting Reference
When scripting in Storyboard Pro, you can also open the scripting reference guide directly from the Script 
Editor view by opening the Script Editor view menu  and selecting Help > Scripting Interface 
Documentation.
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Creating Scripts
Using the Script Editor, you can create Qt scripts for Storyboard Pro. 

Your custom scripts and default scripts are stored here: 

• Windows: C:\Users\[user_name]\AppData\Roaming\Toon Boom Animation\Toon Boom Storyboard 
Pro\14200-scripts

• macOS: /Users/[user_name]/Library/Preferences/Toon Boom Animation/Toon Boom Storyboard 
Pro/14200-scripts

On macOS, the Library folder is a hidden folder. To display the display the folder, hold down the Alt key.

NOTE 

To access the Storyboard Pro scripting reference, see Scripting Reference on page 861

How to create a script

 1. Select Windows > Script Editor.

The Script Editor view opens. A list of all the available JavaScript files is displayed.

 2. From the Script Editor menu,  select File > New Script 
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The New Script dialog box appears.

 3. Enter a name and click OK.

The name of your script appears in the File column of the Script Editor view.

 4. Click in the right side of the Script Editor and start writing your script. Try typing in the following 
script:

function  projectQuery()

{

var storyboard = new StoryboardManager();

print("This project has " + storyboard.numberOfScenesInProject() + " 
scenes in the project");

}

NOTE 

For a tutorial on coding in JavaScript, refer to https://www.w3schools.com/js.

For a detailed Storyboard Pro script interface documentation, refer to Storyboard Pro Script 
Interface Documentation

There are also help files in the Script Editor view. In the Script Editor menu, select Help > 
Scripting Interface Documentation.

 5. To check your syntax, click Verify. 

A window opens with syntax information.
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 6. To test your script, select the script to run from the File column. 

 7. From the Script Editor menu,  select Play/Debug > Run.

A window opens to ask you for the target function to run. In the window, select the function you 
want to execute. 

NOTE 

To avoid selecting the function every time you want to run your script, you can set a target 
function. In the Script Editor menu, select Play/Debug > Set Target. In the Function column, 
select a function and click OK.

‣ To stop the execution of your script, select Play/Debug > Stop from the Script Editor menu.

‣ You may receive the following message: Only functions that have been saved or are explicitly 
called will be executed. 

This usually occurs if you did not select the function you wanted to run from the File column 
before running the script. When this happens, click Save and run your script again.

‣ You may also see the following message (in red) on the right side of the Script Editor:
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This is because the Storyboard Pro jumped to the <<Sandbox>> item in the Function column. 
The <<Sandbox>> is provided to test scripts without saving them. Simply click on your newly 
created script and run it again.
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Importing Scripts
If there are scripts that are ready for you to use, you must first transfer the *.js files from the computer where 
the scripts were created to the one you intend to use. Then you can use the Script Editor to import the *.js 
files into Storyboard Pro. 

When working with Storyboard Pro, scripts that you created while working on a scene or imported are 
available for all other projects created on the same computer; there's no need for  any kind of transfer or import. 
You can find your custom, default, and imported scripts here:

• Windows: C:\Users\[user_name]\AppData\Roaming\Toon Boom Animation\Toon Boom Storyboard 
Pro\14200-scripts

• macOS: /Users/[user_name]/Library/Preferences/Toon Boom Animation/Toon Boom Storyboard 
Pro/14200-scripts

On macOS, the Library folder is a hidden folder. To display the display the folder, hold down the Alt key.

How to import scripts

 1. Copy the *.js files you want to transfer onto a USB key, or use the transfer method of your choice.

 2. Transfer and save the *.js files onto the computer you intend to use. Be sure to save them in a 
logical location. You can save them directly in the default locations indicated above, in which case 
they will automatically appear in the Script Editor. If you prefer not to mix them with the default 
scripts, save them to a different location.

 3. In Storyboard Pro,  start a new scene or open an existing one.

 4. Add the Script Editor view to your workspace. 

 5. From the Script Editor menu, select File > Import Script. 

 6. Select the *.js file and click Open.

The script is imported and appears in the Files list of the Script Editor.
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Using an External Script Editor
If you are more comfortable editing your scripts using another text editor or syntax highlighter, Storyboard Pro 
allows you to set an external script editor and use that one instead.

NOTE 

On Windows and macOS, if you try to open a script in the external editor without setting it first, 
Storyboard Pro will open the script in the default editor for JavaScrtipt (.js) files on your machine. 

How to set an external editor

 1. Do one of the following:

 l In the Script Editor toolbar, click the  Set External Editor button.

 l In the top-left corner of the Script Editor view, click on the  Menu button and select  Editor 
> Set External Editor. 

The Set External Editor window opens.

 2. In the external editor, type  the complete and absolute path to the text editing application you want 
to use, including its name and extension. For example, if you want to use notepad++ on Windows, 
you could type:

C:\Program Files\Notepad++\notepad++.exe

On macOS, if you want to use an application that supports the AppleScript Open Document 
protocol, simply typing the name of the application might work, for example:

TextWrangler

Typing the name of the application you want to use will also work if that application has its path in 
the PATH environment variable, such as notepad on Windows or gedit on GNU/Linux. 

 3. Click on OK.

How to edit a script in an external editor

 1. In the File list, select the script you want to edit. 
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 2. Do one of the following:

 l In the Script Editor toolbar, click the  Open with External Editor button.

 l In the top-left corner of the Script Editor view, click on the  Menu button and select  Editor 
> External Editor. 

 3. In the external editor that opens, make the desired changes to your script, save the script and close 
the external editor. 

 4. In Storyboard Pro, the changes you made to your script in the external editor will not appear 
immediately. You can load those changes by selecting another script in the File list, then selecting 
the script you changed again. 
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Linking Scripts to Toolbar Buttons
To use scripts in your regular workflow, you can add them as buttons to the Scripting toolbar. You can add 
buttons to the Scripting toolbar that are configured to run ax specific function in a script and, if you want, give 
these button a specific icon and tool tip. 

NOTE 

For more information on the Scripting toolbar and the Scripts Manager dialog, see the Reference 
Guide. 

How to link a script to a toolbar button

 1. Add the Scripting toolbar to your workspace by doing one of the following:

 l From the top menu, select Windows > Toolbars > Scripting.

 l Right-click on any toolbar and select Scripting.

The Scripting toolbar is added to your workspace.

 1. In the Scripting toolbar, click the  Manage Scripts  button.

The Scripts Manager dialog box opens and displays the available scripts.

 2. In the Files list, select the script file containing the function you want to add to the toolbar.

The functions in the selected script appear in the Functions list.

 3. In the Functions list, select the function that you want to add to the toolbar.

 4. Between the Functions and In Toolbar list, click on the  Right Arrow  button.

The selected function is added to the In Toolbar list. 

 5. If you want to add a custom icon to the toolbar button for your script, click on the Customize Icon 
button and, in the Open dialog that appears, browse to and select the icon file that you want the 
button to have. 

You can use .png, .jpg, .xpm or .tvg files as toolbar icons. 

 6. If you want to add a custom tooltip to the toolbar button for your script, click on the Customize 
Tooltip button and, in the dialog that appears, type in the tooltip for your toolbar button.

869

Storyboard Pro 6. User Guide                          



Chapter 22: Scripting

 7. Click on OK.

A button for the selected function is added to the Scripting toolbar. If you click on this button, the 
function your selected will be executed. 

TIP 

You can stop a script while it is running by pressing the Esc key or clicking on the  Stop  button 
on the Scripting toolbar.
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