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Chapter 1 
Network Connection

What is Harmony? 
Harmony is a revolutionary team-based infrastructure for animation production. Its array of cutting-edge features 
increases productivity and encourages creativity. Developed in conjunction with the leading studios worldwide, 
Harmony is specifically designed for long-term episodic and feature length projects, providing a true animation 
pipeline. Several animators can work simultaneously on the same scene while the asset library provides users with easy 
access to up-to-date media assets. Harmony is truly scalable; more than 100 staging clients can share animation just 
as easily as a few can. 

Toon Boom Harmony is a powerful solution that brings together multiple teams working on the same project, whether 
in-house or remotely. The Harmony solution offers a robust asset management system that enables users to quickly 
locate assets, share tasks on complex scenes and centralize all assets in a common repository. Tremendous gains in 
efficiency and quality are made by the teams, who enjoy a smooth flow between each task, and more time dedicated 
to their creative assignments.
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What is Network Connection?
Harmony Network is the link between the machines and the Server. It lets you work on the different projects stored 
in the central Harmony database. 

At the heart of the Harmony Solution is the Server, which centralizes all the production assets in a repository. Loaded 
with production proven tools to manage administration tasks, the Server is completely flexible and will fit in your 
existing infrastructure, whether you are on Windows, Linux or Mac.

 To learn more, refer to the Harmony Server User Guide.

What is Contained in this Guide?
This guide was created to show you how to work on your project stored in the database using Harmony Network.

This guide is divided as follows:

• Connecting to the Database, on page 5
• Saving Different Versions of a Scene in the Database, on page 12
• Managing Palettes, on page 17
• Library, on page 26
• Batch Rendering, on page 27
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Connecting to the Database
When you launch Harmony Stage, you can decide to either work offline in the application as a stand alone software 
or connect to the database to work on projects via Harmony Network.

This topic explains the following:

• Working Offline with Toon Boom Harmony Stage
• Working with Toon Boom Harmony Stage Via Harmony Network

Working with Toon Boom Harmony Stage Via Harmony Network

When working with the Harmony solution via Harmony Network, the scenes and their data are stored directly on the 
server. No data is saved or stored on the client machine. The client machines access the database and load the scenes 
and drawings directly from the server. Each time the user saves his scene, the data is updated directly on the server. 
There are no upload or download operations done between the server and the clients.

Global Lock
Harmony has a lock system, referred to as Global Lock, for the different scenes and scene assets. As all the data on 
the server can be accessed directly and modified from any client machine, by default, the scenes are locked. The users 
need to obtain the rights to modify scenes in order to save their work onto the server.

Only one user at the time can modify a scene. Once a scene is opened on a client machine, the other users can only 
open the scene in read-only mode if they need to consult it, but they will not be able to save any modifications.

The Global Lock has three levels: 

• Get rights to modify the scene
Allows the user to modify the selected version of the scene and have access to the version manager during 
the opened session.

• Get rights to modify the scene version
Allows the user to modify the currently selected scene version but locks access to the version manager 
during the opened session.

• Get rights to modify the scene assets
Automatically gets all the edit rights for the selected version of the scene. This option is only recommended 
if you are certain that the selected scene can not be opened for editing by several users at the same time. 
Large studios should avoid this option.

These three levels of locking are available from the Database Selector when the user logs into Harmony Stage. From 
there you can select a scene and get the rights to modify it by enabling the desired lock option check boxes.

There are several different ways to obtain the rights to modify the scenes. It can be done when the user loads a scene 
from Harmony Stage, inside the application once the scene is loaded or when an Environment, Job or Scene is created 
using the Control Centre.

 Refer to the Harmony Server User Guide to learn more about the Control Centre.
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Acquiring Rights to a Scene Once it is Loaded

If you opened a scene for read only, but realize that you will need to modify it, you can easily acquire the necessary 
rights without closing and reloading the scene.

To set the scene’s rights after the scene is loaded:

 Select File > Rights to Modify Scene or Rights to Modify Scene Version.

 Note that it is not possible to acquire the rights to modify the scene assets once the scene is loaded. This process 
is done during the initial loading process of the scene.

 To learn more about enabling the rights to modify while creating Environments, Jobs and Scenes, refer to the 
Harmony Server User Guide.

Locking Drawings 
The drawings are also stored on the server database providing access to them from every client machine. They are 
locked to avoid different users from modifying the same drawings simultaneously. Only one person at the time can 
get the rights to modify them. The drawings’ rights are independent from the scene’s rights because in a production 
rush, two users may need to work on the same scene to finish painting the drawings faster. One user will get the rights 
for one set of drawings and the second user the rights to another set of drawings. This prevents work from being 
duplicated.

Edit Drawings Mode 

When enabled, this option will automatically give you the rights to modify drawings, as well as to create new drawings 
by drawing directly into an empty cell. This mode is enabled by default when you open a scene version with the rights 
enabled. 

To enable and disable the Edit Drawing Mode:

1. Select Edit > Edit Drawing Mode. When the option is enabled, a check mark appears beside it.

Get Rights to Modify Drawings 

When you disable the Edit Drawing Mode, you can use the Get Rights to Modify Drawings option on a selection of 
specific drawings. This is proven useful when, for example, many users are working on the same scene during the ink 
and paint process and they want to split the drawings to paint between them.

To get the rights on a selection of drawings:

1. Make sure that the Edit Drawing Mode is disabled.
2. In the Xsheet view, select the drawings you want to edit.
3. Select Edit > Get Rights to Modify Drawings or you can use the default keyboard shortcut [Alt]+[L].

Releasing the Rights to Modify Drawings 

Once you get the rights to modify drawings, you can release these rights if necessary.

To release the rights on a selection of drawings:

1. In the Xsheet view, select the drawings you want to release.
2. Select Edit > Release Rights to Modify Drawings or you can use the default keyboard shortcut [Alt]+[Shift]+[L].
6 
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Releasing Rights if your System Crashes 

If your system crashes and the drawings remain locked, you can force the release of the rights. 

NOTE: Use this option carefully, data loss may occur if the scene is currently open and being edited by another person. 
Verify that no one else is using the scene prior to forcing the release of the drawings' rights.

To force the release of the rights of locked drawings:

1. In the Xsheet view, select the drawings you want to release.
2. Select Edit > Force Release Rights to Modify Drawings.

A Warning dialog box opens.

 
• Click Yes if you want to continue to force the release.
• Click No if you want to cancel the force release. 

Read Changed Drawings 

Since the drawings are stored on the server, sometimes you might need to refresh the drawings that are displayed in 
your scene. 

To read changed drawings: 

 Select File > Read Changed Drawings 

Palette Lists and Palettes Lock 

Edit Palette List Mode 

Every drawing element has a palette list. The scene also has a palette list. A palette list is a file containing all of the 
links to the original palette files. For example, a drawing element can use three different palettes stored in three 
different locations, while another drawing element can use two of these palettes plus another one coming from 
another scene. The palette list keep tracks of the location of the palettes.

To prevent users accidently removing a link to a palette, the palette lists are locked. To add a new link to a palette, 
the user must first unlock the palette list.

To enable and disable the Edit Palette List Mode:

1. Select Edit > Edit Drawing Mode or Edit Palette List Mode. When the option is enabled, a check mark 
appears beside it.

When in Edit Palette Lists Mode, a grey pencil appears on the top corner of the Colour view palette list to 
indicate that it can be modified. 

 

Before you can add, remove or modify colours from a palette, you need to have the right to edit palettes. 
7
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Edit Palette Mode 

A colour palette is an actual file that can be found on the hard drive. These palette files can be stored in a different 
location on the server machine. They can be stored in the Environment, Job, Scene or Element folder and linked to 
any palette list. This means that if the original palette file is modified, it will update in every drawing element the 
palette is linked to. To avoid accidently modifying the palette, the palette files can be locked. The user must get the 
rights to modify them. 

To enable and disable the Edit Palette Mode: 

1. In the Colour view, click on the Edit Palette Mode button. 
When pushed in, the mode is enabled, a grey pencil icon appears in the top corner  

  
When pushed out, the mode is disabled.  

 

Connecting to the Database 
To be able to work in Harmony Stage via Harmony Network, you will need to be connected to the Harmony Database. 
When you connect to the database, you will not be able to create new scenes directly from Harmony Stage. The 
available scenes will be the ones that were previously created using the Control Centre. 

To get connected to the Harmony database: 

1. Launch Harmony Stage: 

 Mac OS X: Double-click on the Toon Boom Harmony Stage  icon or select:  
Applications > Toon Boom Harmony 9.2 > Stage 

 Windows: Double-click on the Toon Boom Harmony Stage  icon or select: 
Start > Programs/All Programs > Toon Boom Harmony 9.2 > Stage 

 Linux: Double-click on the Toon Boom Harmony Stage  icon or select: 
Applications > ToonBoom-Harmony_9.2 > Stage

The database login dialog box opens. 

 
2. Enable the Connect to Database option. 

 
3. Enter your Harmony username in the User Name field. 
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4. Click on the OK button. 

The Database Selector dialog box opens, displaying the Environments available from the Harmony database.

 
5. From Database Selector dialog, select the scene Environment. 

 
6. Then select the scene Job. 
7. And finally, select the Scene. 
8. Get the rights needed for this session by clicking in the appropriate checkbox (es): 

 
 Get rights to modify the scene  

Allows the user to modify the selected version of the scene and have access to the version manager during 
the opened session.

 Get rights to modify the scene version 
Allows the user to modify the currently selected scene version but locks access to the version manager 
during the opened session.

 Get rights to modify the scene assets 
Automatically gets all the edit rights for the selected version of the scene. 

This option is only recommended if you are certain that the selected scene cannot be opened for 
editing by several users at the same time. NOTE: Large studios should avoid this option.

9. Choose the version you want to open from the Version drop-down menu.

 
 The Saved By and Saved Date fields display the user who was the last to save the selected scene and the 

date of the last save.  
Refer to the Saving Different Versions of a Scene in the Database topic to learn more about scene’s 
versions.
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10. Click on the Open button.
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Working Offline with Toon Boom Harmony Stage 
The Work Offline mode is enabled by default when you launch Harmony Stage for the first time. Using this mode 
allows you to create new scenes and work locally on your machine on independent projects, as you would normally. 

However, the following limitations apply:

• Options exclusive to the Harmony Solution will not be available in the different menus
• You will not have access to any projects stored in the central database of Toon Boom Server.

To enable the Harmony Stage Work Offline mode:

1. Launch Harmony Stage: 

 Mac OS X: Double-click on the Toon Boom Harmony Stage  icon or select:  
Applications > Toon Boom Harmony 9.2 > Stage 

 Windows: Double-click on the Toon Boom Harmony Stage  icon or select: 
Start > Programs/All Programs > Toon Boom Harmony 9.2 > Stage 

 Linux: Double-click on the Toon Boom Harmony Stage  icon or select: 
Applications > ToonBoom-Harmony_9.2 > Stage

The database login dialog box opens. 

 
2. Enable the Work Offline option by clicking in the Work Offline radio button. 

 

The Harmony Stage Welcome Screen appears.

 Refer to Harmony Stage User Guide to learn more about creating and opening your projects as well as working 
with Harmony Stage as a stand alone application. 
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Saving Different Versions of a Scene in the Database 
When you use the Harmony Solution and work in a scene on the database there are many choices and options 
available when you save your work. 

• Save the scene as the current version
• Save different versions representing different stages of production of your scene
• Save different versions representing different scene setups 
• Choose specific assets that you want to save, such as drawings or palettes 

Once you have a different version of a scene stored in the database, you can manage the following:

• Saving the Current Version of a Scene
• Advanced Saving Options
• Deleting Versions

Saving the Current Version of a Scene 
When you open the scene from the database and you select the version you wanted to edit. You can either save the 
changes you made in the current version or create a new version. The simplest way to save your work is to update the 
current version. 

To save the current version of a scene: 

1. Make sure that you have the necessary rights to save the current scene version. If you do not, you can acquire 
the rights by selecting File > Rights to Modify Scene Version or Rights to Modify Scene. 

2. Select File > Save. You can also use the default keyboard shortcut [Ctrl]+[S] (Windows/Linux)  
or []+[S] (Mac OS X) to save the scene. 

When saving the scene for the first time, the Save dialog box opens, prompting you to name the version.

 
3. Edit the information in the current version:
 In the This Version field, enter a relevant name for the current version.

 
 In the Description field, enter a short description of the current version. 

 
4. Click on the Save button. 
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Advanced Saving Options 
Once the scene you are working on has been saved, use these options to save the scene as a different version or to 
select specific components of the scene you want to save.

To open the Save dialog box:

1. Make sure that you have the necessary rights to save the current scene version. If you do not, you can acquire 
the rights by selecting File > Rights to Modify Scene Version or Rights to Modify Scene. 

2. Select File > Save. You can also use the default keyboard shortcut [Ctrl]+[Shift]+[S] (Windows/Linux) or 
[]+[Shift]+[S] (Mac OS X). 

The Save dialog box opens. 

  

Selecting the Advanced Saving options
3. Select the components you want to save from the following tabs, each of which is explained in the section 

below:
• File
• Drawings
• Palettes
• Palette Lists

Once you have chosen the components to be saved you will conclude the procedure by following the instructions in 
the Saving your Advanced Saving options section at Step 4. 
13



Harmony Network User Guide
File 

In the File tab of the Save dialog box, you can do the following:

• Save the scene as a new version 
• Overwrite an existing version 
• Set a new Current version. 

A -  Save:
 Enable this option if you want to save the modifications made to the current scene. 
 Disable the Save option if you only want to save specific components of your scene listed in the 

Drawings, Palettes or Palette Lists tabs. This will disable all option in the File tab. 
B -  This Version (number):

 
 Enable this option if you want to save the current version of the scene. You can rename the current 

version by typing a new name into the field. 
C -  New Version (number):

 
 Enable this option if you want to save the current scene as a new version. You can name this new 

version by typing a name into the field. 
D -  Overwrite Existing Version:

 
 Enable this option and select an existing version of your scene from the list to overwrite it.
E -  Description:

 
 Use this field to add or edit an existing description for the scene version you want to save. 
F -  Mark as Current:
 Enable this option if you want to set this scene version as the current one. This version will be 

automatically selected as the default Current Version when the scene is selected in the Database 
Selector dialog box. 

A

B

C

D

E

F
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Drawings 

The Drawings tab lists the modified drawings.

 
A -  Drawing list:
 Select the modified drawings that you want to save.
 Deselect the modified drawings that you do not want to save.
B -  Select All:
 Click on the Select All button to select all modified drawings in list
C -  Deselect All
 Click on the Deselect All button to deselect all modified drawings in the list.

Palettes 

The Palette tab lists the modified colour palettes.

 
A -  Colour Palette list:
 Select the colour palette that you want to save.
 Deselect the modified colour palette that you do not want to save.
B -  Show Recovered:
 Select this option if you want to display the recovered palettes in the list of modified palettes.
C -  Select All:
 Click on the Select All button to select all modified colour palettes in the palette list.
D -  Deselect All
 Click on the Deselect All button to deselect all modified colour palettes in the palette list.

Palette Lists 

The Palette Lists tab lists all the modified colour palette lists.

 
A -  Palette Lists list:
 Select the modified palette lists that you want to save.
 Deselect the modified palette lists that you do not want to save.
B -  Show Recovered: 
Select this option if you want to display the recovered palettes lists in the list.
C -  Select All: 
Click on the Select All button to select all modified palette lists in the list.
D -  Deselect All 
Click on the Deselect All button to deselect all modified palette lists in the list.

A

B C

A

C D
B

A

C D
B
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Saving your Advanced Saving options
You should now have selected the components you wanted to save from the components in these tabs.

• File
• Drawings
• Palettes
• Palette Lists

Now that you have chosen the advanced saving criteria, do the following:

4. After selecting the components to be saved, click on the Save button.  
All the specific components that are selected throughout the different tabs of the Advanced Save dialog box 
will be saved. 

Deleting Versions 
You can delete any unnecessary versions using the Version Manager.

To delete versions: 

1. Make sure you have the necessary rights. If you do not, select File > Rights to Modify Scene. 
2. Select File > Manage Versions. 

The Versions dialog box opens. 

 
3. In the Existing Versions list, select the scene version you want to delete. When a version is selected, information 

about it appears in the Description list.
4. Click on the Delete button. 

 The Confirm Delete Versions dialog box opens, warning you that the operation cannot be undone. 

 
5. ONLY if you are certain that the version can be deleted, click on the Yes button. Click on the No button if you 

want to cancel the operation and keep the version. 
16 
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Managing Palettes 
The Harmony Solution incorporates palettes which hold all of the colours needed to paint elements, a concept that 
brings complete control and consistency to the painting process. A palette is created by assigning a set of colours to 
each character, prop or effect. The colour artist will create a new palette and add a new colour, called a colour pot, 
for each zone of the character, such as the skin, hair, tongue, shirt, pants and so on.  

When a zone on a character is painted with the colour contained in a colour pot, a link is automatically created 
between that colour pot and the zone. This means that if the tint of the colour in the colour pot is modified, any zone 
that is linked to it will automatically update to the new tint. This saves time and money spent on your production. 
Another advantage of this system is that you can also create complete palettes for different lighting situations. For 
instance, in addition to the regular palette for a character, you can have one for that character in the rain, using colours 
that are muted and less vibrant than the dry daytime colours, or another for use in a night scene. Using palettes that 
are linked to your character this way allows you to instantly change colouring to suit the mood and atmosphere of the 
scene without tediously repainting each element.

This topic is divided as follows:

• Creating a Palette in Harmony
• Palette Operations
• Palette Storage
• Palette Backup

Creating a Palette in Harmony 
Harmony Stage is set to Basic Palette Lists mode by default. This setting stores the palettes automatically for you and 
saves them at the Scene level. When you use Advanced Palette Lists mode, you can decide at which level you want 
to store your palettes; Environment, Job, Scene, Element.

 Refer to the Harmony Stage User Guide to learn how to create a palette in Basic Palette Lists mode.

To switch to Advanced Palette Lists mode: 

1. Open the Preferences panel: 
 Windows/Linux: Select Edit > Preferences or use the default keyboard shortcut [Ctrl]+[U]. 
 Mac OS X: Select Stage > Preferences or use the default keyboard shortcut []+[U]. 

The Preferences panel opens. 
2. Select the Advanced tab. 

 
3. Enable the Advance Palette Lists mode. 

 
4. Click on the OK button. 

To create a palette from the Advanced Palette Lists mode: 

1. Make sure that you have the necessary rights to modify the palette list. If you do not, select   
Edit > Edit Palette List Mode, a check mark will appear beside the command to indicate that the mode is 
enabled. 

2. In the Timeline or Xsheet View, select the drawing that requires a palette. 

3. In the Colour view, click on the Show Palette List View  button to display the palette list. 
17
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4. In the Colour view, click on the Menu  button and select Palettes > New or click on the Create Palette  
button. 

The Palette Browser: Create Palette dialog box opens. 

 
5. Select which level to store the palette file in. 

 
• Environment  

The Palette Library folder is stored in an Environment folder contained in the Scene folder.
• Job  

The Palette Library folder is stored in a Job folder contained in the Scene folder. 
• Scene  

The Palette Library folder is stored directly in the Scene folder. 
• Element   

The Palette Library folder is stored directly in the Drawing Element folder. 

See Palette Storage to learn more about storage levels and their purpose.

When you select a level that has a palette stored in it, the palette names are displayed in the Palette field.

 
6. Name the palette. (There is no need to add the suffix “palette” to the name as it is always recognized as a 

palette file.) 

 

18 
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7. Select a Palette List option: 

 
• Scene Palette List  

The Scene Palette List is mainly used with Cut-out animation. A cut-out character will often be divided in 
twenty to thirty different drawing elements that use the character’s master palette.  
The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to 
this list will appear in every drawing element created in the scene. There is no need to manually load the 
palette in each element. 

• Element Palette List  
The Element Palette List is mainly used with Traditional and Paperless animation. Unlike Cut-out animation, 
all columns (drawing elements) contain different characters, props, backgrounds and effects. The Element 
Palette List is used because you do not necessarily want all of the palettes for all of your elements linked in 
every column.  
The palette list is stored in the drawing element’s directory instead of directly in the Scene level. This 
ensures that the links to the palettes appear only in the appropriate element. If you prefer to access a global 
palette list, link your palettes to the Scene Palette List.

8. Click on the OK button. 

The new palette appears in the palette list. 

 

Linking a Palette in Harmony 
To link a palette in Harmony: 

1. Make sure that you have the necessary rights to modify the palette list. If you do not, select  
Edit > Edit Palette List Mode, a check mark will appear beside the command to indicate that the mode is 
enabled. 

2. In the Timeline or Xsheet View, select the drawing that requires a palette. 

3. In the Colour view, click on the Show Palette List View  button to display the palette list. 

4. In the Colour view, click on the Menu  button and select Palettes > Link or click on the Link Palette  
button. 

The Palette Browser: Link Palette dialog box opens.
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5. Select the location and level where the palette file is stored. When a level is selected, the palettes it contains are 
displayed in the Palette field. 

 
6. Select your palette. 

 
7. Select a Palette List option: 

 
• Scene Palette List  

The Scene Palette List is mainly used with Cut-out animation. A cut-out character will often be divided in 
twenty to thirty different drawing elements that use the character’s master palette.  
The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to 
this list will appear in every drawing element created in the scene. There is no need to manually load the 
palette in each element. 

• Element Palette List  
The Element Palette List is mainly used with Traditional and Paperless animation. Unlike Cut-out animation, 
all columns (drawing elements) contain different characters, props, backgrounds and effects. The Element 
Palette List is used because you do not necessarily want all of the palettes for all of your elements linked in 
every column.   
The palette list is stored in the drawing element’s directory instead of directly in the Scene level. This 
ensures that the links to the palettes appear only in the appropriate element. If you prefer to access a global 
palette list, link your palettes to the Scene Palette List. 

8. Click on the OK button. 

The palette appears in the drawing element’s palette list. 

 

20 



Chapter 1: Network Connection   Managing Palettes
Palette Operations 
When you launch Toon Boom Harmony Stage connected to the database, you can have access to the Palette 
Operations dialog box. The Palette Operations lets you clone, rename or delete palettes. 

 Refer to the Harmony Stage User Guide to learn more about palette cloning. 

To open the Palette Operation dialog box: 

1. Launch Toon Boom Harmony Stage and login on the database. Refer to Connecting to the Database. 
2. Click on the Close button to close the Database Selector dialog box. 
3. Select Tools > Palette Operations. 

The Palette Operations dialog box opens. 

 

To clone a palette in the Palette Operation dialog box: 

1. Select the palette you want to clone at the location and level it was stored in. 

 
2. Click on the Clone button. 
3. A Warning dialog box opens. 

 
 Click in the checkbox beside Don’t show this message again if you want to prevent the dialog box from 

opening every time you do this operation.
4. Click on the Yes button to continue or click on the No button to cancel the palette cloning operation.
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The Palette Browser dialog box opens. 

 
5. Select the location level where you want the new palette to be stored. 

 
6. Name the new palette. 

 
7. Select a Palette List option: 

 
• Scene Palette List  

The Scene Palette List is mainly used with Cut-out animation. A cut-out character will often be divided in 
twenty to thirty different drawing elements that use the character’s master palette.  
The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to 
this list will appear in every drawing element created in the scene. There is no need to manually load the 
palette in each element. 

• Element Palette List  
The Element Palette List is mainly used with Traditional and Paperless animation. Unlike Cut-out animation, 
all columns (drawing elements) contain different characters, props, backgrounds and effects. The Element 
Palette List is used because you do not necessarily want all of the palettes for all of your elements linked in 
every column.   
The palette list is stored in the drawing element’s directory instead of directly in the Scene level. This 
ensures that the links to the palettes appear only in the appropriate element. If you prefer to access a global 
palette list, link your palettes to the Scene Palette List. 

8. Click on the OK button. 
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To rename a palette in the Palette Operation dialog box: 

1. Select the palette you want to rename at the location and level it was stored in. 

 
2. Click on the Rename button. A Warning dialog box opens. 

 
 Click in the checkbox beside Don’t show this message again if you want to prevent the dialog box from 

opening every time you click on the Rename button.
3. Click on the Yes button to continue or click on the No button to cancel the palette renaming operation.

The Rename Palette dialog box opens. 

 
4. Rename the Palette. 
5. Click on the OK button. 

To delete a palette in the Palette Operation dialog box: 

1. Select the palette you want to clone at the location and level it was stored in. 

 
2. Click on the Delete button. A Warning dialog box opens. 

 
 Click in the checkbox beside Don’t show this message again if you want to prevent the dialog box from 

opening every time you click on the Delete button. It is not recommended to disable the warning message 
in this case. Deleting a palette can not be undone. 

3. Click on the Yes button to continue or click on the No button to cancel the palette deleting operation.
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Palette Storage 
When a palette is created from Harmony Stage it needs to be stored somewhere. In Harmony Stage, palettes are 
individual *.plt files that can be copied, transferred and stored. 

The palette files are saved in the scene directory and stored in a Palette Library folder. There are four locations where 
you can find Palette Library folders:  

• Element   
The Palette Library folder is stored directly in the Drawing Element folder. 

• Scene  
The Palette Library folder is stored directly in the Scene folder. 

• Job  
The Palette Library folder is stored in a Job folder contained in the Scene folder. 

• Environment  
The Palette Library folder is stored in an Environment folder contained in the Scene folder. 

Where to Save the Palette File? 
The palette storage location depends on the type of production and the backup plan being used. 

Some studios like to store their palettes at the Element level and others at the Environment level. This will not create 
a problem as long as the scene is in the Harmony structure, in fact as long as the structure is maintained it can be 
stored at any level. However, difficulties may occur when the scene is backed-up or transferred to another studio or 
database and removed from the initial structure. 

What Happens when you Export a Palette File? 
It is important to understand what is happening to a palette file when the scene is exported. 

Because of the Harmony client-server configuration, all of the data can be shared through all of the scenes via the 
central database. This also includes the palette files, even if they are stored at the Element, Scene, Job, Drawing or 
Environment level. This way, the palette files can be accessed from any scene of any project.

When you export scenes from Harmony using the Control Center, either to archive them or to send them to other 
users or studios, the palettes stored in external scenes, jobs or environment will NOT be exported. An exported scene 
will only carry palettes stored in its own Element’s palette library, Scene’s palette library, Job and Environment. Any 
other palette from other Environments, Jobs, Elements or Scenes (even from the same job) will NOT follow. Instead 
a recovery palette will be created when the scene is reopened in another Harmony system.

A recovery palette is a local palette created by the system when palettes and colours are missing. This palette is no 
longer shared with the rest of the project because the original link is broken. 
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For example, look at this chart. If you export Scene 2 from Job 1, the package will carry the palettes from Scene 2, 
Job 1 and Environment. It WILL NOT carry the palettes from Element 3 in Scene 1, Scene 1 and Job 2.

If Scene 2 was linked to any of these, the system would create a recovery palette the next time that Scene 2 is opened 
in another Toon Boom Harmony system.

 

The best place to store your palette is: 

• Environment level, for a movie or series 
• Job level, for a publicity or small project 
• Scene level, for a student exercise 

If you want to store your palettes with your colour models, you can use the Element level. However, this will require 
more structure when exporting the different scenes of your project. The scenes will have to be exported along with 
the colour model scene. Then, the other studio you are working with will have to recreate an identical structure to 
yours, to be able to import the received scenes into the same location as you did. This will ensure that the links are 
maintained. 

Palette Backup 
When sharing palettes between scenes, some users may modify the colours by accident. That is why it is a good idea 
to copy and backup your palette libraries and master palette directories. 

When a palette file is copied, it automatically becomes a clone palette, so there is no trouble as for replacing an 
altered file. Harmony automatically updates all of the files and drawings linked to it. 
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Library 
The Template Library is a storage centre for all of the production assets; the elements stored in the library are called 
templates. Although it is mainly used for Cut-out animation, the library also serves Paperless and Traditional animation 
processes. The Template Library can contain any asset used in a Toon Boom Harmony production. 

When working on the database, the structure of the Library differs from when working on Toon Boom Harmony Stage 
as a stand-alone application. 

 

Harmony provides different library folders. There are three default library folders available: 

• Symbols  
The only library folder containing Symbols for your project. You can organize the Symbols library folder 
using subfolders, but you cannot create a second Library for your Symbols. This library is local to your 
project. 

• Environment  
A folder located inside the Environment folder. Every asset stored in this folder is accessible from any job 
and scene contained within this environment. 

• Job  
A folder located inside the Job folder. Every asset stored in this folder is accessible from any scene 
contained within this job. 

 You can create a folder called “library” in the usa_db folder on the server to create a Global library. Once the 
Stage application is restarted, a “Global” library folder will automatically appear in every user’s Template Library. 
Every asset stored in this folder is accessible from any scene, job and environment. 

 Refer to the Harmony Stage User Guide to learn how to create and manage libraries, templates and symbols. 
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Batch Rendering 
To render your scene you must first choose the type of rendering and then set the rendering parameters.  

There are two ways to render out scenes using the Harmony Solution: 

• Local Rendering  
Local rendering is done directly on the user machine using its CPU. To perform local rendering you must use 
Toon Boom Harmony Stage. 

• Batch Rendering  
Send a scene to batch render when you want to continue working in Toon Boom Harmony Stage and do not 
want to wait for the application to complete the render process. 

 Refer to the Harmony Stage User Guide to learn how to render your scene locally. 

Batch Rendering 
Batch rendering is a background process divided over several machines or a render farm. Sending your scene to batch 
render will share the rendering load with other machines in the render farm and lessen the amount of work required 
by your computer. 

 Refer to the Harmony Stage User Guide to learn how to set up the Write module to render your scene. 

Sending a Scene to Batch Render from Harmony Stage
To send a scene to the batch rendering queue: 

1. Save all of the contents of your scene, all drawings, colour palettes and the palette list.  
Select File > Save or use the default keyboard shortcut [Ctrl]+[S] (Windows/Linux) or []+[S] (Mac OS X).

2. Select File > Export > Render Network, you can also use the default keyboard shortcut [Ctrl]+[Shift]+[Y] 
(Windows/Linux) or [Z]+[Shift]+[Y] (Mac OS X). 

 If the System Administrator did not complete the resolution configuration tasks, a warning message will open. 
This message notifies you that the resolution.conf file was not properly inserted in the configuration folder. 

 
3. Click on the OK button to continue. You will still be able to render your scene. 

The Render Network dialog box opens. 
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4. Select the frames you want to render: 
 All Frames: send all the frames in the scene to be rendered 
 Selected Frames: sends a range of frames to be rendered. 

5. Enable the Batch Composite option. 
 Select the Chunk checkbox if you want to split the frames into sets of frames. 
 Enter the number of frames for each chunk in the Size (Frames) field. For example, if your scene is 100 

frames long and you enter a value of 20, there would be five entries in the queue of 20 frames each. 
 Select the camera you want to use to render the scene’s images from the Camera drop-down list. These are 

the Camera modules you created in your scene. 
6. Enable the Field Composite Options checkbox if you want to create a field composite, to refine your selection.
 Select the Add Pull-down option to use the 3:2 pull-down technique. 
 Select the Automatic Combine option to combine even and odd fields on a scene’s images. 
 Select the Second Field First option to always start with the second field before combining with the first. 

7. Click OK to start the rendering process. 

A confirmation dialog box opens to inform you that the frames have been sent to the render queue. 

 
 If the selected frames were already sent to the render queue, a notification dialog box opens to inform you 

that these frames were already in the queue but that they have been updated with the latest rendering 
request. 

 

You can also send scenes to batch rendering and check the status of the rendering queue from the Control Center 
module. 

 Refer to the Harmony Server User Guide to learn how to send scene to batch render and check the status of the 
rendering queue. 
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