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About Harmony Preferences

About Harmony Preferences
The Preferences dialog box allows you to adjust preferences to suit your workflow and your production's needs.
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Accessing the Preferences Dialog

Accessing the Preferences Dialog 
You can access the Preferences dialog from the Edit menu on Windows, or from the Harmony Essentials menu 
on macOS. 

How to open the Preferences dialog box

 1. Do one of the following:

 l Windows:

 l In the top menu, select Edit > Preferences.

 l Press Ctrl + U.

 l macOS:

 l In the top menu, select Harmony Essentials > Preferences.

 l Press ⌘  + U.

6



7

Harmony 20 Essentials Preferences Guide                          



Switching Between Preference Sets

Switching Between Preference Sets
Harmony comes preloaded with five different preference presets (referred to as preference sets), each tailored 
for a different kind of task. By default, the Basic preference set is used. You can choose which preference set to 
use in Preferences dialog.

A large part of the default settings in the different preference sets are the same. The following table describes 
which option is different depending in each preference set, and how:

Tab / 
Location

Preference

Preference Set

Basic Compositing
Cutout 

Animation
Paperless 
Animation

Rigging

General

Focus on 
Mouse Enter

Off On On On On

Default 
Separate 
Position for 
Pegs

Off Off On Off On

Stop-Motion 
Keyframes

Off Off On Off On

Pencil Tool 
Properties

Auto Close 
Gap

On On On On Off

NOTES 

 l When you customize a preference manually, it is not saved to the current preference set. It is 
saved as an override for all preference sets. 

 l Switching between preference sets only affects preferences that you have not manually 
customized yourself.  This means, for example, that if you manually enable the Focus on Mouse 
Enter preference, this preference will no longer be affected when you switch to a different 
preference set. 

 l To make all your preferences affected by the preference set you select again, you must reset 
your preferences—see Resetting Preferences on page 14.
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How to switch between preference presets

 1. Do one of the following to open the Preferences dialog:

 l Windows:

 l In the top menu, select Edit > Preferences.

 l Press Ctrl + U.

 l macOS:

 l In the top menu, select Harmony Essentials > Preferences.

 l Press ⌘  + U.

 2. In the top-left corner of the Preferences dialog, open the Preference Set drop-down and select the 
preset you want to use.

Preferences will be updated according to the table above, except for those that you manually set. 

 3. Click on OK. 
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Exporting Preferences

Exporting Preferences
You can export your current preferences to an XML file. You can reimport this file later to restore your 
preferences, or share it with project collaborators so that you all use the same preferences.

NOTE 

When you export your preferences, only the preferences for the currently selected preference set 
are exported. 

How to export your preferences configuration

 1. Do one of the following to open the Keyboard Shortcuts dialog:

 l Windows:

 l In the top menu, select Edit > Preferences.

 l Press Ctrl + U.

 l macOS:

 l In the top menu, select Harmony Essentials > Preferences.

 l Press ⌘  + U.

 2. Near the top of the dialog, right of the Preference Set: drop-down, click on the  Save... button.

A save dialog appears.

 3. Browse to the location where you want to save your preference file.

 4. Type in the desired name for your preference file. 

 5. Click on Save.

Your current preference settings have been exported as an XML file, in the selected location with 
the file name you gave it.
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Importing Preferences

Importing Preferences
You can import a preference file exported from Harmony. 

NOTES 

 l To export preferences into a file, see Exporting Preferences on page 10.

 l When you import a preference file, it will override all your preferences for the currently selected 
preference set. 

How to import a keyboard shortcut configuration file

 1. Do one of the following to open the Keyboard Shortcuts dialog:

 l Windows:

 l In the top menu, select Edit > Preferences.

 l Press Ctrl + U.

 l macOS:

 l In the top menu, select Harmony Essentials > Preferences.

 l Press ⌘  + U.

 2. At the right of the Preference Set: drop-down, click on the  Load... button.

An open dialog appears.

 3. Browse to the directory where your preference file is located.

 4. Select the preference file you want to import.

 5. Click on Open.

The settings in the selected preference file are loaded into the Preferences dialog, overwriting your 
current preferences.
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Resetting Preferences

Resetting Preferences
You can reset the preferences in Harmony to their default settings.

IMPORTANT 

This will permanently undo all the changes you made to your Harmony preferences.

How to reset your keyboard shortcuts configuration

 1. Do one of the following to open the Keyboard Shortcuts dialog:

 l Windows: In the top menu, select Edit > Keyboard Shortcuts.

 l macOS: In the top menu, select Harmony Essentials > Keyboard Shortcuts.

 2. In the bottom-left corner of the Preferences dialog, click on Restore All Defaults.

A confirmation prompt appears.

 3. If you are sure you want to restore the default preferences for Harmony, click on Yes.

All the preferences in the Preferences dialog are now set to their default setting.
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Preferences File Location

Preferences File Location
T-HFND-002-002

After the first time you have launched Harmony, your preferences, along with numerous other options and 
switches in the user interface, are stored in a hidden directory on your computer.

Depending on your operating system, you can find your preference files in the following location:

 l Windows: C:\Users\[username]\AppData\Roaming\Toon Boom Animation\Toon Boom Harmony 
Essentials\full-2000-pref

NOTE 

On Windows, the AppData folder is hidden. To display it in Explorer, in the top menu, open 
the View pane and check the Hidden Items checkbox. 

 l macOS: /Users/[username]/Library/Preferences/Toon Boom Animation/Toon Boom Harmony 
Essentials/full-2000-pref

NOTE 

On macOS, the Library folder is hidden. To display it in Finder, hold down the Alt key.
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Preferences Dialog Reference

Preferences Dialog Reference
The following section contains a an article for each tab in the Preferences dialog. Each article contains a list of 
all the preferences in its tab, as well as a description of the preference. Refer to this section if you want to know 
more about what a specific preference does or if you want to get familiarized with all of the preferences in 
Harmony.

General Preferences 19

Camera Preferences 24

Exposure Sheet Preferences 25

Drawing Preferences 26

OpenGL Preferences 28

Advanced Preferences 30
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General Preferences

To customize your interface, you will use some of the preferences located in the General tab as well as the 
Camera tab.

Parameter Description

Save 

In Harmony Server, you can decide which kinds of assets are saved when 
you use the Save command. This can be useful if you need specific users to 
only be able to make changes to certain aspects of the scene they're 
working on, or if you want to prevent yourself from accidentally making 
undesired changes to important assets. Unchecking any of the following 
options will prevent you from saving their corresponding type of assets: 

 l Save Scene: Save changes to the list of layers, elements, animation, 
timing, layout, effects, scene properties, etc.

 l Save Palette Lists: Save changes to the list of palettes associated to 
the scene or to individual elements.

 l Save Palettes: Save changes to the colours and textures contained in 
palettes. 

 l Save Drawings: Save changes to existing drawings as well as newly 
created drawings.
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Preferences Dialog Reference

TIP 
If you want to save changes made to a type of asset that for which 
saving was disabled, you can do so by selecting File > Advanced 
Save from the top menu. In the Advanced Save dialog, assets for 
which saving is disabled will be unchecked, so you must manually 
check the assets you want to save.

IMPORTANT 
When you close a scene, Harmony will not ask for confirmation to 
discard changes made to assets for which saving is disabled. 

Auto-Save:

 l Interval (minutes): This is the frequency at which the auto-save 
takes place.

 l Inactivity Interval (seconds): When Auto-save is about to take place, 
it verifies if you are drawing or doing anything in the application. If 
so, Auto-save waits this number of seconds before attempting 
another save.

 l Ask Before Saving: Before performing an auto-save, the system will 
prompt you with a message to confirm if you want to save or not. 
You can choose to turn off this option.

 l Enabled: This enables the Auto-save feature. If you do not want the 
system to automatically save your work, deselect this option. The 
auto-save is off by default.

Automatically Save Workspace: Changes to your workspace, such as how 
views and toolbars are laid out, are automatically saved, making sure your 
workspace remains the same after you close and re-launch Harmony or if 
you switch between different workspaces. If this option is disabled, you 
must manually save changes to your workspace by selecting Windows > 
Workspace > Save Workspace from the top menu.

Options

Support Gestures: Enables manipulating views such as the Camera and 
Drawing views using the following gestures:

 l To pan the view, drag your two fingers in any direction, keeping 
both fingers at the same distance from each other.
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 l To zoom in, drag your two fingers away from each other.

 l To zoom out, drag your two fingers closer to each other.

 l To rotate, drag your two fingers in a curve so that they revolve in the 
same direction.
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Preferences Dialog Reference

Invert Scroll Direction: When panning a view by dragging it with your 
fingers in one direction, this makes the view pan in the opposite direction.

Touch Sensitivity: Control touch sensitivity. On macOS, higher numbers 
give a slower response to pans. On Windows, higher numbers favour 
scale/rotates over pans.

Auto Render: Controls whether the Camera view's Auto Render option is 
enabled or disabled when launching Harmony. When Auto Render is 
disabled, if any change is made to the scene while the Camera view is in 
Render Preview mode, it will switch to OpenGL Preview mode. When 
enabled, it will merely refresh the render preview. 

Focus on Mouse Enter: In Harmony, some keyboard shortcuts, menus or 
toolbar buttons are intended for specific views in your workspace. To use 
keyboard shortcuts or other functionalities on a specific view, this view 
must be focused on. For example, the Centre on Selection shortcut will find 
the selected element in the Timeline or Camera view, depending on which 
one is focused on. Harmony draws a red rectangle around the currently 
focused on view. 

By default, to set the focus on a view, you must click on its tab or on 
anything inside the view itself. The Focus on Mouse Enter preference will 
make Harmony automatically focus on the view the mouse cursor is over, 
making it switch the focus on a view and use keyboard shortcuts on it. 
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NOTE 
Some items in the top menu also have functionalities that are 
specific to the focused on view, but moving the mouse cursor to the 
top menu might leave the wrong view focused on. To circumvent 
this problem, it might be necessary to become familiar with 
keyboard shortcuts, contextual (right-click) menus and the view 
menus available via the menu  button at the top-left corner of 
some views.

Use Dark StyleSheet (Requires Relaunch): Application loads a dark skin for 
the User Interface. 

Language

Language (Requires Relaunch): The language in which to display the user 
interface. 

By default, this is set to Autodetect, which means that Harmony will launch 
in the language of your operating system, if it is one of the supported 
languages, and will otherwise launch in English.

Settings

Stop-Motion Keyframes: New keyframes are created as stop-motion 
keyframes. 

Default Separate Position for Pegs: New pegs are created with separate 
position functions.

Default Separate Scale for Pegs: New pegs are created with separate scale 
functions.

Timeline

Add Keyframe at Beginning and End: Add keyframes at beginning and end: 
Select this option to copy and paste a set of frames that includes an 
interpolated sequence between two keyframes, but only extracts a partial 
section. Under normal circumstances, cutting and pasting a function 
without either the start or end keyframe would render the function null. This 
option caps the partial function with a new keyframe when you perform the 
paste.

Extend Exposure of Previous Drawing: When drawing on a blank frame, a 
new drawing is created and the timing is extended from the previous 
exposed drawing.
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Preferences Dialog Reference

Camera Preferences

Parameter Description

Settings

Set Keyframe At Frame One With First Application of the Transform Tool: When 
this option is selected, wherever you set a keyframe on a layer, a keyframe is 
added on your frame 1. If this options is deselected, a keyframe is only added to 
the current frame. If later on, you add a keyframe on your frame 1, it may modify 
the first keyframe you added.

Small Bitmap Resolution: The size, in pixels, of the smaller bitmap version of your 
image. When you import a bitmap image into a scene, a smaller version of it is 
created in order to accelerate the compositing and playback processes.

Control Points

Show Control Points On Selected Layers: By default, when you select an element 
with the Transform tool, the motion path related to the object is displayed.

Control Point Tension: The default Tension value for new keyframes and control 
points.

Control Point Continuity: The default Continuity value for new keyframes and 
control points.

Control Point Bias: The default Bias value for new keyframes and control points.

Colours
Background Colour: Lets you change the background colour of the Camera view 
in OpenGL View mode. 
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Exposure Sheet Preferences

Parameter Description

Filtering

These preferences are used to display or hide certain layer types in the Xsheet 
view.

Show Drawing Columns: Displays the Drawing layers in the Xsheet view.

Show Sound Columns: Displays the Sound columns in the Xsheet view.

Show 3D Path Columns: Displays the 3D Path columns in the Xsheet view.

Show Function Columns: Displays the Function columns layers in the Xsheet 
view. 

Options

Default Add Columns: The default position where the new column will be added.

Default Column Width: The default width value for the new column being 
created.

Zoom Levels

You can set the minimum and maximum zoom levels to view the Xsheet, 
depending on the number of columns and rows in the project. Once you set a 
level, close and reopen the Xsheet so the new values take effect.

Minimum Zoom Level: Lets you set the lowest level of zoom. Choose a value 
between 1 and 6.

Maximum Zoom Level: Lets you set the highest level of zoom. Choose a value 
between 14 and 20. 

NOTE 
You can set a keyboard shortcut to view the entire Xsheet.
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Preferences Dialog Reference

Drawing Preferences

Parameter Description

Light Table

Onion Skin Render Style:

• Original Colours: Drawings displayed in the Onion Skin are rendered 
using their real colours.

• Coloured:Drawings displayed in the Onion Skin are displayed in solid red 
if they are before the current frame, or in solid green if they are after the 
current frame.

• Coloured Outlines: Drawings displayed in the Onion Skin are displayed in 
red outlines if they are before the current frame and in green outlines if 
they are after the current frame.

Light Table: Enable Shade: When enabled, the drawings appearing on the Light 
Table are displayed in washed out colours in the Drawing view. When this option 
is disabled, the drawings appearing in the Light Table are displayed using normal 
colours. This option is for the Drawing view only.

Light Table: Shade in Camera View: When enabled, the drawings appearing on 
other layers are displayed in washed-out colours in the Camera view. When this 
option is disabled, the drawings appearing on other layers are displayed using 
normal colours. This option is for the Camera view only.

Options

Grid On By Default: When opening the Drawing view, the grid displays 
automatically.

Brush Size Cursor: When this option is enabled, the brush tool displays the 
brush size as a circle around the cursor.

Synchronize Eraser and Brush: When enabled, changing any of the Brush tool's 
properties simultaneously changes the corresponding property for the Eraser tool 
to the same setting, and vice versa. Likewise, selecting a preset for one tool will 
apply this preset's properties for the other tool. 
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Auto Gap Closing in Pixel Units: Disabling this option will cause your gap to be 
zoom dependent. Zoom dependent means that the more you zoom in, the smaller 
the gap you can close with the Close Gap tools. By enabling this option, you 
choose to make the gap display available in pixel units, which is not zoom 
dependent.

Auto Gap Closing on Startup: The values for automatic gap closing while 
painting drawings are: 0 = Disabled, 1=Small, 2=Medium, 3=Big.

Pencil Lines Opacity (%): Lets you set the default tranparency of your pencil lines.

Colours

Background Colour: Lets you change the background colour of the Drawing 
view.

Grid Colour: Lets you change the colour of the grid.

Zoom

Enable Paper Zoom: Enabling this option allows you to set the 100% Zoom level 
onscreen, in order to physically match the measurements of your paper drawing.

Number of Pixels per Inch: Enter the PPI for your monitor. To obtain the PPI of 
your screen, divide the height or width of your monitor's resolution setting by the 
corresponding physical height or width  of your monitor screen (resolution height 
divided by physical height, or resolution width divided by physical width) in 
inches.

Quick Close Up Zoom Factor: Sets the zoom level for the Quick Close up Zoom 
keyboard shortcut. 

Maximum Zoom Factor: Sets the maximum zoom level for the paper zoom.

27

Harmony 20 Essentials Preferences Guide                          



Preferences Dialog Reference

OpenGL Preferences 

Parameter Description

Settings

Conservative Texture Management: Turns on and off conservative memory 
management for bitmap texture files. Performance will improve when this is 
enabled. If disabled, you will have a better on-screen rendering of bitmap files at 
the expense of slower performance.

Smooth Textures: Smooths out the pixels of bitmap images when zooming in; 
this improves bitmap image quality.

Alternate Gradient and Cutter: This is an alternative way to disable write in the 
OpenGL Backbuffer, required for some video cards (i.e. GeForce FX5200). Do not 
enable this option unless you are experiencing problems with gradients and 
cutters in OpenGL.

Support Triple Buffer: Enable this option for a better compatibility with Windows 
Vista if your video card driver does not allow to disable the triple buffering option. 
Not enabling this option may result in a dashing line when drawing a brush 
stroke.

Support Desktop Effects: Enable this option for better compatibility with 
Windows 7, Windows Vista and Mac OS X desktop effects. This will prevent 
graphic compositing problems from happening when the full-scene anti-aliasing 
option is enabled.

Maximum Texture Size: The size that the bitmap file will be reduced to when 
using the Conservative Texture Management.

Texture Memory: The amount of temporary memory used to store bitmap texture 
files.

Vector Drawing Maximum Texture Size: This is the size that the .tvg file will be 
reduced to for better performance when in OpenGL render mode.
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Full Scene Antialiasing

The following options allow you to configure the way drawings are previewed in 
Harmony. 

Enable              (Requires Relaunch)             : By default, drawings displayed in Harmony, such as 
in the Camera or Drawing view, have no antialiasing and display hard pixels at the 
edge of strokes and lines. If this preference is enabled, antialiasing will be done 
through the graphic card to enhance the quality of drawings and make a preview 
that resemble the final render more closely. This may impact application 
performance negatively. 

Number of samples: The amount of times the OpenGL preview is scaled up before 
processing it for antialiasing. The higher this value is, the better the antialiasing 
quality will be but the heavier it will be on the machine's resources. 

NOTES 

 l It may be necessary to restart the application to see the effects 
after changing either of these settings. 

 l These settings may be overriden by the 3D antialiasing settings 
of the driver for your graphics card. If changing these settings 
and restarting the application seems to have no effect, make sure 
your graphics card supports antialiasing, that antialiasing is 
enabled and that it is configured to let applications control their 
antialiasing. 

 l These settings only affect the way drawings are previewed in 
OpenGL. They have no effect on the final rendered image, or on 
the way the image looks when setting the Camera view in 
Render Preview mode.
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Preferences Dialog Reference

Advanced Preferences

Parameter Description

Advanced Options

Support CMYK in PDF/Illustrator Import: Lets you import .pdf and .ai files that 
were created or exported in CMYK mode. The colours of the resulting imported 
image may still not look 100% faithful to its CMYK original due to the RGB 
conversion. It is recommended that you convert these files to RGB images before 
importing them into Toon Boom Harmony Essentials. Disabling this option will 
cause all the colours of the imported image to be displayed as red to indicate that 
the file was not converted to RBG before import.

PDF/Illustrator Import as Separate Layers: Imports  the different groups/elements 
of the .pdf or .ai file as separate layers. For Illustrator files, the import will use the 
top level group as separate layer names. Deselect this option to import pdf or .ai 
files as a single layer.

Tablet Support
Use Qt Wintab Tablet Support (Requires Relaunch): If you are using a tablet 
other than Wacom, deselect this option (and relaunch) if you are having issues 
with offset or pressure sensitivity.

Unicode

Allow Unicode Names: Lets you use up to 120 ASCII characters for names of 
environments, jobs and scenes. This means you can use characters for languages, 
such as Japanese, Chinese, French, Spanish, and others, characters for names in 
your database setup.
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