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Introduction

Introduction

Harmony is a complete animation software allowing you to create all kinds of creative animation projects. It
comes with a very wide variety of tools and features.

In this Getting Started Guide, you will learn the basics of how to use the main features in Harmony Advanced,
which will quickly bring you up to speed. Refer to the complete Toon Boom Harmony documentation available
online at docs.toonboom.com to learn about all the tools and options, as well as more advanced techniques.



http://docs.toonboom.com/
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Chapter 1: Creating a Scene

Chapter 1: Creating a Scene

As soon as you launch Harmony, you are greeted with the Welcome screen, from which you can:
« Create scenes
o Choose your new scene's resolution
« Manage your scene resolution presets
o Quickly open recently opened scenes
« Browse for and open a scene you already created.
« Watch Harmony video tutorials on the web.

o Access the support web page.

@ Harmony

Open a recent
scene

Create or
remaove a scene
resolution preset

Select the scene
resolution

ch Video Tutorials - Get Help
4 : Browseforan
7 Open...
e open a scene
Get support
for Harmony

Watch video tutorials
for Harmony

NOTE

If you are using Harmony Server, you must use the @ Control Center application to create your
scenes before you can open them in Harmony. Harmony Server scenes cannot be created directly
in Harmony.
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How to create a scene from the Welcome screen

1. Inthe Name field, type the scene’s name.

NOTE

The scene name should not exceed 23 characters and cannot contain special
characters, such as *&A%!.

2. Todecide in which directory the scene will be created, click the Browse button next to the Location
field.

4. Click on Create Scene.

A new scene is created. The main application window will appear with your new scene opened in it.
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Chapter 2: Introduction to the Harmony User
Interface

Using Toon Boom Harmony will be significantly easier if you first become familiar with its user interface. This
chapter gives you a basic introduction to the most important elements of the user interface. As you go through
the ensuing chapters, you will learn more detailed information about each of these elements.

When you start Toon Boom Harmony for the first time, the default workspace is displayed. The workspace is
comprised of toolbars and panels, referred to as views, which allows you to create and edit your scene. The
default workspace contains the most commonly used toolbars and views for digital animation.

_Tool Properties
view

Tools
toolbar

Colour view

Camera
View

Playback
toolbar

Timeline view

How to add a view to your workspace as a tab

1. Inthetop-right corner of an existing view, click the 4 Add View button

10
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tadata Editor

del

2. Select the desired view from the list.

The view appears as a new tab, in the section of your workspace where you added it.

Tool Properties  Library

Transformation | D,

Position

NOTE

Some views, such as the Camera, Perspective, Library and Model views, can be opened in
multiple instances. For example, this can be useful if you want to have two instances of the
Camera views open, each focused on different areas of your scene, to quickly switch between

working on these two areas.

11
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How to add a view to your workspace as a window

1. Open the Windows menu.
2. Inthe Windows menu, select the view you wish to add.

The view will appear as a new window over Harmony's main application window.

How to dock a view window to your workspace

1. Click and drag the floating view by its tab and do one of the following:
« Drop the window over another tab to add it to that set of tabs.

« Drop the window above, below or beside an existing view. When you get close to the
edge of a view, a cyan rectangle appears, indicating where the view will be docked.

Views

Here is a short introduction to each of the most commonly used views in Harmony.

Camera view

The Camera view is the centre of operations in Harmony. In this view, you can draw, paint, animate, set up your
scene, manipulate objects, open symbols and preview your animation.

The Camera view also has a top and bottom toolbar that you can use to navigate in the view, change the
display mode or go up your symbol hierarchy.

12
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Symbol hierarchy

View menu
Tool presets

Light table [Zoom menu ][ Drawing name ][ Tool name ][ Frame number ] I Selected colour
Current drawing on top] [ Reset view |
| Camera maskl IOutIine locked drawings l

[ Safe area || BBox selection style |

Drawing view
In Harmony, you can draw in both the Drawing or Camera views. Although the two views are similar, there are
some differences when it comes to drawing.

Only the selected drawing is displayed by default in the Drawing view. You can use features, such as the light
table to display the current drawing of all the enabled layers of your scene in washed-out colours, or the Onion
Skin to display the previous and next drawings of the currently selected drawing layer.

13
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Drawing view toolbar |

View

menu Camera Drawing  ==[%

Tool
presets

i

Art
Layers

Drawing area

Drawing name Tool name

Frame number || Cursor position || Colour Picker

Tool Properties view

The Tool Properties view contains the most common options and operations related to the currently selected
tool. When you select a tool from the Tools toolbar, the Tool Properties view updates.

For example, if you choose the Select tool, the Tool Properties view will display the options and operations
related to it, such as Snap to Contour, Apply to All Drawings, Flip Horizontal, and Flatten.

Possible options
and modes for [T
the current tool

Possible
operations for
the current tool

Colour view

The Colour view is where you create colours and palettes and import existing palettes into your project. The
Colour view is also necessary for drawing, painting and creating colour styling.

14
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| Move palette up / down I | Edit palette list mode indocator ? I

| Link palettel | Show colour palettes I
Remove palette | Show pencil texture palettes I
Add palette Show all palettes

Cilour 4= %

| Collapse/Expand palette list

| Edit palette list mode indicator?!

Palette list

| Edit palette mode indicator?!

| am 1l s |

4 » B £ Edit palette mode? I

| Edit palette mode indicator? I

| Add colour swatch

| Remove colour swatch
Add texture

(

Colour swatch
Colour swatch list

+ -
—1
I
 —
 I—
—_—
1
|
—
—1
 I—
—
|
=
 —
 —

| 1The Edit Palette Mode button is only available in Harmony Server. Edit Palette Mode is always enabled in Harmony Standalone.

Timeline view

To set your animation timing, you will mostly work with the Timeline and Xsheet views. It's extremely useful to
become familiar with the Timeline view, how it works, and its interface.

The Timeline view is the main view used when adjusting the timing of drawings, adding keyframes and
ordering layers. The Timeline view displays layers, effects, sounds, keyframe values, scene length, layer names,
drawings, keyframes, timing, and frames.

15
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| Enable/Disable Layer |
[ Enable/Disable Solo Mode | Add Layer
[ Add/Remove Onion Skin | Delete Layer

Timeline cursor | | Drawing Exposure Split View

| Expand/Cellapse Group | Coordinates at

| Expand/Collapse Layer Hierarchy | current frame

[ Show/Hide Additional Links |

Show/Hide
Functions

Drawing Mumber
atcurrentframe

| Show/Hide Parameters |

|View Modes I

The Timeline view allows you to read your timing from left to right. It represents the scene’s elements in their
simplest form. You can also see the layers and their names, as well as the drawing’s exposure. The drawing
name is displayed when you place your pointer over the drawing’s exposure.

Xsheet view

The Xsheet view lets you read the timing vertically by displaying it in a grid, with each drawing layer
represented by a column, each frame of your scene represented by a row, and each exposed drawing displayed
by its name in the cells. It is meant to work like a traditional animation exposure sheet.

Using the functions panel, you can also view the functions and keyframes of the motion paths for the selected
column, with the value of those functions for each frame listed in the cells.

Contrary to the Timeline view, the Xsheet view does not display pegs, effects or layer hierarchy. Hence, it is
optimized for traditional and paperless animation, whereas the Timeline view is optimized for digital or cut-out
animation.

16
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Xsheet toolbar
Column header

Current drawing

Drawing exposure

Frame numbers

Overwrite / Insert
mode

Increase/
decrease exposure

Function
column

Currentdrawing/

element

Library view

The Library view is used to store elements such as animation, drawings, backgrounds and character models so
as to reuse in different scenes and projects. You can also use the Library view to create and store symbols, as
well as to store and import images and sound files.

Toreuse elements from a scene in other scenes, you must create a template so that you can import it into
different scenes. Templates can contain anything from a single drawing to a whole scene structure. You can
create a template by creating it in a scene, then copying the elements you want in your template into a library.
The resulting template is structured like a mini-scene that contains only the elements you copied into it. A
template does not have any dependencies on the scene it was originally created in. Hence, it can safely be
imported in any other scene.

Additionally, the Library view's Drawing Substitution panel allows you to quickly change the current frame's
exposure to one of the existing drawings in a layer. This is especially useful for animating a cut-out character's
mouths, hands, eyelids and other such body parts which typically contain several drawings to choose from.

17
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Assets list

Thumbnail preview

Drawing name !

| Asset/ Element name

| Frame/ Drawing slider

Search bar 1§
Library folder list

[ATWI

| The Drawing name field only appears if an element in your scene is selected.

Interface Navigation

Toon Boom Harmony lets you zoom in, zoom out, rotate, pan and reset views for easy navigation of the
interface.

The navigation commands in the table below can be used in the following views, with some exceptions:
« Camera
« Drawing
o Perspective
o Timeline
o Xsheet
« Function

o Sideand Top

« Model

Command Action Access Methods

View > Zoom In
. . Press 2

Zoom In Zooms in the view.
Roll the mouse wheel up (exceptin the
Timeline and Xsheet views)

Zoom Out Zooms out the view. View > Zoom Out

18
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Command

Action

Access Methods

Press 1

Roll the mouse wheel down (exceptin
the Timeline and Xsheet views)

Zoom In or Out

Zooms in or out of the view.

Roll the middle mouse button up or
down.

Hold down the Spacebar and the
middle mouse button while dragging
the mouse up or down.

Hold down the Spacebar and drag in

Pan Moves the view horizontally or vertically. . . .
the direction you want to pan the view.
View > Reset Pan

Reset Pan Resets the view's pan to its default position.
Press Shift + N
View > Reset View

Reset View Resets the view to its default position.

Press Shift + M

Reset Rotation

Resets the view’s rotation to its default
position.

View > Reset Rotation

Press Shift + X

Reset Zoom Resets the view’s zoom to its default position. View > Reset Zoom
While holding Ctrl + Alt
. . . (Windows/Linux) or Ctrl + 3 (macOS),
Rotate View Rotates the view left or right.

click and drag the rotating disc to rotate
it clockwise or counterclockwise.

3D Rotate View

Rotates the view in any direction. This is only
available in the Perspective view.

While holding Ctrl + Shift
(Windows/Linux) or 3§ + Shift
(mac0S9), click and drag the stage to
rotate it in any direction.

Rotate 30 CW

Rotates the Camera view 30 degrees
clockwise, like an animation table.

View > Rotate View CW

19
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between 400% and 100%.

Command Action Access Methods
Rotates the Camera view 30 degrees counter- i i

Rotate 30 CCW ] ) ) ) View > Rotate View CCW
clockwise, like an animation table.
Temporarily flips the Camera or Drawing view View > Mirror View

Mirror View horizontally, allowing you to view and edit In the Camera or Drawing toolbar, click
your artwork as if it was being mirrored. on the Mirror View button.
Instantly multiplies the view's Zoom Factor by

Toggle Quick 4. For example, if the Camera View's Zoom Shift + 7

i
Close-up Factor is at 100%, this will make it toggle

Toggle Full Screen

Cycles through the following display modes:

o Normal Full-Screen: The main
application window becomes full
screen.

o View Full-Screen: The selected view
becomes full screen and all other
views are collapsed.

o Normal: The main application window
is restored to its original size and
collapsed views are expanded.

View > Toggle Full Screen

Press Ctrl + F (Windows/Linux) or &8 +
F (macOS)

Touch Interface

If you are working with a touch screen, a trackpad or a tablet that supports touch input, you can also use

standard two-finger gestures to zoom, rotate and pan the Camera and Drawing Views. To be able to do this,

you must first enable the Support Gestures preference.

How to enable gesture support

1. From the top menu, go to Edit > Preferences (Windows/Linux) or Harmony > Preferences (Mac OS

X).

2. Open the General tab.

3. Inthe Touch Interface section, check the Support Gestures check box.

4. Click on OK.

20




Harmony 16.0 Advanced Getting Started Guide

5. Restart Harmony.

You can now manipulate the Camera and Drawing views by dragging two fingers on your touch
interface.

How to use gestures

1. Inthe Camera or Drawing view, press two fingers a short distance from each other.

2. Doone of the following:

o Topan theview, drag your two fingers in any direction, keeping both fingers at the same
distance from each other.

e« Tozoomin, drag your two fingers away from each other.

« Tozoom out, drag your two fingers closer to each other.

21
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« Torotate, drag your two fingers in a curve so that they revolve in the same direction.

22
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Chapter 2: How to Add Layers

Just like with traditional animation, Harmony uses layers to keep elements such as characters, backgrounds and
props separate from each other, allowing you to animate them independently.

When you create a new scene, your scene will have a default layer named Drawing, in which you can

immediately start drawing.

Default drawing layer

Layers can be selected and managed in the Timeline view. A scene can have as many layers as needed. When
your scene has several layers, layers higher in the list appear over lower layers.

R R —

Types of Drawing Layers
Harmony supports two types of drawing layers, each with their own advantages and limitations:

« Vector Layers: Vector drawings are made of points and curves that compose the contours of the shapes
of the artwork, along with the colour or textures these shapes are filled with. Hence, the artwork in
vector layers can be scaled up and zoomed in without losing quality, unless they contain a texture.

23
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When drawing on a vector layer, each drawing stroke and pencil line is a separate object which can be

manipulated individually. You can select single drawing strokes, then move them around and transform

them, even if drawing strokes were applied over them. Additionally, because drawing strokes are made
of points and curves, it is possible to edit their shape, making it easy to make corrections and changes to
your artwork.

« Bitmap Layers: Bitmap drawings are composed of a grid of pixels, which are small points that each have
a single solid colour. Bitmap drawing tools allow you to lay on brush strokes onto a single flat canvas, and
to tweak your artwork by the pixel if needed.

When you draw on a bitmap layer, each stroke is composited into the canvas, so it remains a single
drawing that can only be painted or erased upon, but which does not allow you to tweak individual parts
of it.

Bitmap artwork can only be scaled up or zoomed in on as much as their pixel density allows without
losing picture quality. By default, bitmap artwork has a pixel density of 100%, which is only enough to
display the artwork without zooming in on it or scaling it up, otherwise Harmony must generate new
pixels within the artwork, which is liable to make it look blurry or pixelated.

Hence, you might want to set the required pixel density for your bitmap artwork, based on whether
you'll need to zoom on it or scale it up, before you start drawing on a bitmap layer.

NOTE

Since vector layers are editable and scalable, it is recommended to start off using vector layers
while getting familiarized with Harmony. The default drawing layer in a new scene is a vector layer.

Art Layers

By default, each drawing layer actually has two art layers: The Line Art layer and the Colour Art layer. You can
use these layers to keep the line art and colours in your drawings separate.

24
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At the right of the Camera and Drawing view, you can control which art layer you are working on and whether
only the current art layer or both art layers are displayed.

Camera Drawing =%

Preview all art layers I

Set Line Art as current layer I

Set Colour Artas current Iayerl

By default, the Line Art layer is selected. So if you start drawing right away, you will be drawing in your
drawing layer's Line Art layer, unless you select the Colour Art layer first.

Using different art layers for your line art and colour art is entirely optional. If you like, you can use the Line Art

layer for both your line art and colour art.

NOTE

You can also enable extra Art Layers: The Overlay and Underlay Art layers. The Overlay Art layer is
typically used for annotations and the Underlay Art layer is typically used for rough sketches. To
enable them, check the Support Overlay and Underlay Arts option in the Advanced tab of the
Preferences dialog, which can be accessed by selecting Edit (Windows/Linux) or Harmony
Advanced (macOS) > Preferences in the top menu.

25
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Renaming Layers

In a new scene, there is only one layer created by default, named Drawing. In traditional animation, it is
common to name animation layers with single letters (A, B, C, etc.) and layout layers with acronyms (BG for
background, OL for overlay, etc). So you can start off your scene by giving your first layer an appropriate name.

How to rename a layer in the Timeline view

1. Inthe Timeline view, double-click on the name of the layer to rename.

2. Typein the new name for your layer and press Enter/Return.

The layer now has the new name.

Adding Layers

How to add a drawing element from the Timeline view

1. Doone of the following:

o Inthe Timeline view, click the % Add Drawing Layer button.
o Inthe top menuy, select Insert > Drawing.

o Press Ctrl + R (Windows/Linux) or & + R (macOS).

The Add Drawing Layer dialog appears.

2. Inthe Name field, type in the name for your new layer.

26
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2. Select whether you want the Line Art layer should be Vector or Bitmap.

3. Select whether you want the Colour Art layer should be Vector or Bitmap.

4. Do one of the following:
« Click Add to create this layer, but leave the dialog open so you can create more layers.
o Click Add and Close to create this layer and close the dialog.

A new drawing layer is added to the Timeline view.

¥
nOo=am

o
o

Deleting Layers

How to delete layers in the Timeline view

1. Inthe Timeline view, select the layers to delete.

NOTE

You can select several contiguous layers by holding down the Shift key, clicking on the
first layer you want to select, then on the last layer you want to select. You can also
select several layers by holding the Ctrl (Windows/Linux) or ¢ (macOS) key and
clicking on each layer you want to select.

2. Do one of the following:

o Inthe Timeline's Layer toolbar, click the — Delete Layers button.

27
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« Right-click on the selection and select Delete.

The selected layers are removed from the Timeline view.

Reordering Layers

How to reorder layers in the Timeline view

1. Inthe Timeline view, select the layers to move.

2. Click and drag the selection, then do one of the following:

o Drop the selection between two layers to move it between those layers. A cyan line will
appear between the layers where the selection will be moved.

Grouping Layers
Grouping layers allows you to keep your scene structure organized.

Additionally, you can put several layers inside a group, then add an effect on this group to apply that effect on
all the layers inside the group.

28
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How to group layers in the Timeline view

1. Inthe Timeline view, select the elements you want to group.

NOTE

Any layer between the selected layers will be grouped with the selected layers.

2. Do one of the following:
« Right-click on the highlighted layers and select Group Selection.

o Press Ctrl +Shift + G (Windows/Linux) or 3§ + Shift + G (macOS).

A new Group layer is added to the Timeline view.

If you click on the Expand Group button, you will find the grouped layers rigged as children of
the group layer.

Hiding and Showing Layers

You can temporarily hide layers so that they do not clutter the Camera view while you are working on other

layers.

How to hide a layer in the Timeline view

1. Inthe Timeline view, left of the layer you want to hide, click on the (¢¢ Disable Layer button.

29
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The layer will become invisible in the Camera view.

2. When you want to unhide the layer, click on the @@ Enable Layer button to display it again.

Locking and Unlocking Layers

You can temporarily lock layers. Locked layers can still be edited in the Timeline or Xsheet view, but you cannot
select them, draw them or manipulate them in the Camera view. This can be useful to avoid accidentally
selecting or drawing over your backgrounds, overlays, props or characters you are not currently working on.

How to lock a layer in the Timeline view

1. Inthe Timeline view, left of the layer you want to lock, click on the ﬁ Lock button.

The layer will become impossible to select or draw on in the Camera view. The name of the layer will

appear in red in the Timeline view.

2. When you want to unlock the layer, click on the Unlock Layer button to display it again.

30
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Chapter 3: How to Draw

As soon as Toon Boom Harmony is running and a scene is created, you can start drawing right away using the
default drawing layer in your new scene.

How to draw

1. Doone of the following:
o Inthe Tools toolbar, select the »” Brush tool or press Alt + B.
« Inthe Tools toolbar, select the # Pencil tool or press Alt + /.

2. Inthe Timeline or Xsheet view, click in the first cell of the drawing layer.

3. Toselect a colour, click on the colour you wish to use in the Colour view. For more information on how
to create and edit colours, see How to create or edit colour swatches on page 42.

Colour == (%

Scene Palettes

[Adlw ]
4 &

4. Inthe Drawing or Camera view, start drawing.

32
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Adjusting Artwork

Harmony offers multiple ways to adjust drawings. You can undo your last stroke, erase parts of a drawing,
move, transform or delete strokes, and tweak the points and curves of your strokes.

NOTE

You cannot manipulate or tweak individual drawing strokes when drawing on a bitmap layer—see
How to Add Layers on page 23.

How to undo your last stroke

1. Doone of the following:
o From the top menu, select Edit > Undo.

o Press Ctrl + Z (Windows/Linux) or 3£ + Z (macOS).

How to erase

1. Inthe Tools toolbar, select the g//// Eraser tool or press Alt + E.

2. Inthe Drawing or Camera view, draw a stroke over the parts of your drawing you want to erase.

How to manipulate drawing strokes

1. Inthe Tools toolbar, select the & Select tool or press Alt + S.

2. Inthe Camera or Drawing view, select strokes you want to edit by doing one of the following:

33
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o Click on a stroke to select it.
o Hold Shift while clicking on a stroke to add it to your selection.
o Draw alasso around drawing strokes to select them simultaneously.

3. Doone of the following to edit your selection:

« Toreposition the selected artwork, click on it and drag where you want to position it.

NOTE

You can also nudge your selection using the arrow keys, and fast-nudge your
selection by holding Shift and pressing the arrow keys.

o Torotate the selected artwork, click and grab just outside one of the handles at the corners of
the control box and rotate it.

« Toscale the selected artwork, click and drag on one of the control points at the corners or the
middle of the edges of the control box.
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.‘Q’. TIP

While scaling artwork, you can preserve its proportions by pressing and holding
the Shift key.

o Toskew, drag sideways or up and down the sides or top and bottom segments, between the
control points.

o Todelete, press Del (Windows/Linux) or Backspace (macOS).

How to edit lines

1. Doone of the following:

« Ifyoudrew with the Brush tool, in the Tools toolbar, double-click on % Contour Editor and
select the 2 Centerline Editor in the pop-up menu, or press Alt + W.

o Ifyoudrew with the Pencil tool, in the Tools toolbar, select the & Contour Editor tool or
press Alt + Q.
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2. Inthe Drawing or Camera view, click the shape, contour or pencil line you want to edit near the area
you wish to change.

The shape or line's control points appear.

/

3. Click on one of the points to select it.

The point's Bezier handles appears, as well as Bezier handles for the surrounding points.

TIP

You can select several points by drawing a lasso around the points, or by holding Shift
while clicking on points to add them to your selection. You can use the Contour Editor to
scale and rotate a selection of multiple points by enabling the L)+ Show Contour Editor
Control option in the Tool Properties view.

4. Do one of the following:

« Tomove a point or a selection of multiple points, click and drag it.
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o Tochange the curve on both sides of a point, drag one of its Bezier handles.

o Tochange the curve on only one side of a point, press and hold the Alt key, then drag one of
its Bezier handles.

/

o Todeformthe curve between two points, hold the Shift key and drag the contour between
two points.
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o Toremove a point's Bezier handles and make the lines it is connected to straight, press and
hold the Alt key and click on the point.

VA

« Straight lines have no Bezier handles at their points by default. To create Bezier handles for
these points and make their lines curved, pres and hold the Alt key, then click and hold the
point and drag the mouse cursor away from it. A new Bezier handle will follow your mouse
cursor until you release the mouse button.

» Toadd a control point, press Ctrl (Windows/Linux) or &8 (macOS) and click on the contour
where you want the new point to be created.
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« Toremove a control point, select the control point and press Del (Windows/Linux) or
Backspace (macOS).
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Chapter 4: How to Paint

Toon Boom Harmony has some very powerful painting features to add colour to your drawings. Whereas some
other software only allow users to work with one colour swatch at a time, painting in Harmony is done by using
palettes containing multiple colour swatches that can be saved and reused as needed.

00 L JECHT

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You
can add as many swatches as you want. You can also rename them and modify existing ones.

Ionanoanme

When you modify the colour of an existing swatch, it automatically updates all the zones painted with this
swatch throughout the entire scene. The colour swatch has a unique ID number that associates it with the
painted zones. This way, you can change the look of your character at any time without having to repaint it!

Another advantage of this system is that you can create complete palettes for different lighting situations. For
instance, in addition to the regular palette for a character, you could have one for that character in the rain
using colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night
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scene. Using palettes linked to your character in this way allows you to instantly change its colouring to suit the
mood and atmosphere of the scene without having to repaint each element.

Colour Palettes

In animation, specific colours are used to paint each part of each character. In order to maintain absolute
consistency, a base colour palette should be created for each character, prop and effect in the production. This
is referred to as a master palette.

Master palettes contain a colour swatch for each area to colour. Each swatch stores a colour in precise levels of
red, green, blue and opacity (the latter which is referred to as alpha).

Using a master colour palette has many benefits, including:
o Each character consistently retains their dedicated colours.
o You cannot accidentally use a colour which is not in the master palette.
« Standardization and colour consistency throughout the production.
o Multiple artists can use the same colour palette and produce the same results.

Harmony uses palettes to hold all the colours needed to paint your elements, allowing complete control and
consistency in the painting process.

A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette
and add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, tongue,
shirt, pants, and so on.

How to create a new palette
1. From the Colour view menu, select Palettes > New or click the New Palette -~ button.

The Create Palette dialog box opens.

2. Enter the palette name according to the model.

3. Click OK.

The palette appearsin the palette list.
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Scene Palettes

How to create or edit colour swatches

1. If youwant to create a new colour swatch, click the Add Colour =4 button in the Colour view. If you
want to edit an existing colour swatch, select the colour in the Colour view.

2. Do one of the following to edit the colour swatch:
e From the Colour view menu, select Colours > Edit.
o Double-click on the colour swatch.

The Colour Picker window opens.

Multi Wheel Mode

3. Toset your colour, do one of the following:

o Select either Red, Green, Blue, Hue, Saturarion of Value to change the colour wheel's
spectrum, then click on the desired colour in the colour wheel.

o Enterthe hue, saturation, value, red, green and blue values manually into their
corresponding fields. All values range from O to 255.
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NOTE

If you change a colour swatch after having drawn or painted areas of a drawing with it, all the
areas that were painted with this colour in your vector drawings will update to the new colour.

Painting

You can paint the closed zones of your drawings by using the Paint tool.

How to paint drawings

1. Inthe Timeline or Xsheet view, select the drawing you want to paint.
2. Inthe Tools toolbar, select the ® Paint tool or press Alt + .
3. Inthe Colour view, select your character's palette.

4. Select a colour from the palette.

W Palettes

Scene Palettes

[Adlw ]
‘Wm0 s B *

5. Inthe Drawing or Camera view, start painting the colours on your drawing.

43



Chapter 4: How to Paint

NOTE

When opening a scene, the scene's palettes will not be immediately loaded into the Colour

view. You must select a drawing first.

Closing Gaps

When painting, you may find that some areas of your drawings were not completely closed due to small gapsin
their outlines, which prevents the Paint tool from filling the area as it only fills closed shapes. To close the zone,
you can draw a line over the gap with the Brush or Pencil tool. However, it is also possible to close the gap by
adding an invisible line over it, which the Paint tool will treat like an ordinary line. In Harmony, invisible lines
used to define areas to colour are called strokes.

\

The Close Gap tool lets you close small gaps in a drawing's outline by instantly drawing a stroke to fill the gap.
Contrary to the Stroke tool, you do not need to draw with precision when using the Close Gap tool. Simply
drawing a crude stroke near the gap will automatically create a straight stroke that connects directly from one

end of the gap to the other.

How to use the Close Gap tool

1. Before working with strokes, it's recommended to enable the Show Strokes option so that you can
see them in the Drawing or Camera view. You can enable the Show Strokes option by doing one of

the following:
o Fromthe top menu, select View > Show > Show Strokes
e PressK

2. Do one of the following:
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e Inthe Tools toolbar, select the ( Close Gap tool.

o Fromthe top menu, select Drawing > Drawing Tools > Close Gap.

e PressAlt + C.

3. Inthe Camera or Drawing view, trace an invisible line near to the gap to be closed.

The gap automatically closes.

NOTE

The Paint tool also has a Close Gap option which can be enabled from the Tool Properties
view. When enabled, Harmony will attempt to automatically find and close small gaps when

you attempt to fill a shape that is not closed.
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Chapter 5: How to Create Paperless Traditional
Animation

Creating a Rough Animation

The first step to create paperless animation is the rough construction, which is the skeleton of your animation.
You would usually start by animating the most important part of a character's action. For example, to animate a
walk cycle, you will start with the torso motion and the legs. Secondary animation such as the head, arms and

clothes can be added afterward.

For a satisfactory animation, start by animating the main action with quick, rough sketches, then add the
details when you're satisfied with the movement. If you start animating all the details right away, you will lose a
lot of time if you have to make corrections, and your animation is likely to look rigid.

How to create a rough animation

1. Inthe top row of the Timeline view, click on Show All Thumbnails to enable Thumbnail mode.

2. Press Ctrl + U (Windows/Linux) or 36 + U (macOS) to open the Preferences dialog box.
3. Select the Exposure Sheet tab.

4. Select the Use Current Frame as Drawing Name option. When this preference is enabled, each
new drawing will be named by the frame number they are created on.

5. Inthe Tools toolbar, select the »” Brush tool or press Alt + B.
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6. In the Colour view, select a colour for the brush. It is a good idea to choose a light colour for your
rough animation. This will make the clean up process easier as your clean dark lines will contrast
with your light sketch lines.

7. Inthe Timeline or Xsheet view, select the cell where you want your first drawing to appear.

8. In the Camera or Drawing view, draw the first key drawing.

9. Increase the Timeline view's zoom level until you see the thumbnails inside the cells by doing one of
the following:

« Dragthe Timeline Zoom _ slider to the right.

o Click on the Timeline view's tab, then press 2 repeatedly.

« Move the mouse cursor in the Timeline view, then hold Ctrl (Windows/Linux) or 36 (macOS)
and roll the mouse wheel up.
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roSalM

10. With your first cell still selected, do one of the following to mark your drawing as a key drawing. This
will help you stay organized.

o Enable the Mark Drawing toolbar by selecting Windows > Toolbar > Mark Drawing
from the top menu, then click on the @© Mark Selected Drawings as Key button.

o Enable the Xsheet toolbar by focusing on the Xsheet, then selecting Windows
> Toolbar > Xsheet from the top menu. Then, click on the Mark as Key Drawing ©
button.

e Inthe Timeline view menu, select Drawings > Mark Drawing As > Key Drawing.

e
[

12. Inthe Tools toolbar, click the é Onion Skin button. This will display the previous and next
drawings in a light colour in the Camera or Drawing view, behind your current drawing, so that you
can use them as references to draw new drawings with accuracy. This can be useful to draw
breakdown poses between two key poses, or to add an in-between drawing between two other
drawings.

[ Range of drawings displayed in Onion Skin I
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13. Ensure the onion skin displays your first key drawing, so that you can base your second key drawing
on it. To do this, do one of the following:

o Inthe Timeline view, click and drag on the red onion skin marker to make it include the
previous drawings you want to display in the onion skin, then click and drag on the
green onion skin marker to make it include the next drawings you want to display in
the onion skin.

o Use the buttonsin the toolbar above the drawing space to adjust how many previous
and next drawings are included in the Onion Skin:

o Toincrease the amount of previous drawings to display, click on the é Add
Previous Drawing button in the Camera/Drawing view toolbar.

« Todecrease the amount of previous drawings to display, click on the ==
Remove Previous Drawing button in the Camera/Drawing view toolbar.

« Toincrease the amount of next drawings to display, click on the % Add Next
Drawing button in the Camera/Drawing view toolbar.

o Todecrease the amount of next drawings to display, click on the == Remove
Next Drawing button in the Camera/Drawing view toolbar.

[ Range of drawings displayed in Onion Skin I

NOTE

When in the Drawing view, you can use the Onion Skin toolbar to make onion
skin display only specific types of drawings, such as key drawings or
breakdowns. Keep in mind that this does not work in the Camera view.

14. Create a new empty drawing by doing one of the following:

« Inthe Timeline or Xsheet toolbar, click on the ¥ Create Empty Drawing button.

49



Chapter 5: How to Create Paperless Traditional Animation

e Press Alt + Shift + R.

15. In the Camera or Drawing view, draw your second key drawing.

ro=al
o

o

18. Using the onion skin markers, ensure the onion skin covers both your first and last drawings.

[ Range of drawings displayed in Onion Skin I

19. Create a new empty drawing by doing one of the following:

o Inthe Timeline or Xsheet toolbar, click on the
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¥ Create Empty Drawing button.
o Press Alt + Shift + R.

20. Inthe Camera or Drawing view, draw your new pose.

21. Inthe Timeline or Xsheet view, select a new cell and repeat the previous steps for each new

drawing.

NOTE

When working with overlay layers in the Camera view, you can enable the Current
Drawing on Top option in the status bar below the Camera view to make the layer you're

working on appear over other layers.

Reviewing your Animation

Flipping through drawings can help see if the drawings you're working on connect well together and create
the proper illusion of movement. You can quickly flip through your drawings using the Go to Previous Drawing
and Go to Next Drawing keyboard shortcuts, or use the Easy Flipping toolbar.

How to flip through drawings

1. Inthe Timeline or Xsheet view, select the drawing from which you wish to flip.
2. Doone of the following:

o PressFtogotothe previous drawing.

e Press G togotothe next drawing.

3. Presseither shortcut repeatedly at a fast pace to flip through drawings backward or forward.

How to use the Easy Flipping toolbar

1. Switch tothe Drawing view.
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In the top menu, select Windows > Toolbars > Easy Flipping to enable the Easy Flipping toolbar.

In the Easy Flipping toolbar, click the €1 Previous or 1> Next button to see the previous or next
drawing of your animation.

To display drawings in the first frame after you reach the last frame of your animation, select the
Loop option.

The further you move the slider to the left or right, the faster the drawings will flip.

In the Preroll field, enter the amount of drawings to automatically flip through before and after the
current drawing.

In the FPS field, enter the speed at which you would like to automatically flip through your drawings,
in frames per second.

Click on the Easy Flip button » to automatically flip through the drawings based on the Preroll and
FPS settings.

When your rough animation is finished, play it back to make sure it looks as expected before proceeding to the

next step.

How to play your animation

1.

In the Timeline view, click on the @ Solo Mode button left of each layer you want to see during
playback in the Timeline view to enable @ Solo mode on these layers.

When one or more layer has Solo Mode enabled, only layers with Solo Mode enabled are visible, and
other layers are hidden.
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2. Inthe Timeline view, move the red playhead to the first frame of your animation and click the Start
button on the Timeline toolbar. Then, move the playhead to the last frame of your animation and
click the Stop button.

3. Inthe Playback toolbar, click the O Loop button to enable looping during playback.

4. In the Playback toolbar, click the ®» Play button to begin playback.

Cleaning Up

When your rough animation is completed, it is time to clean it up and ink it. This step is also called tracing. It
consists of tracing solid and clean lines over the rough animation to close any open zones. This is the final
paperless animation step before the ink and paint step.

In traditional animation, cleaned up drawings are usually traced on a new sheet of paper with the rough
underneath, made visible using the animation disk's light table. Likewise, in Harmony, you will need to add a
new drawing layer on which to draw cleaned up drawings. When you're done cleaning up, you can simply
disable the layer containing the rough animation so that it does not appear in the final animation. This
approach also allows you to keep the roughs and the cleaned up drawings intact and to manage them

independently.

In the Camera view, you will see your rough animation while working on your clean up layer. If you prefer to
work in the Drawing view, you can enable the light table to display the rough animation while tracing on your

clean up layer.

How to trace your animation in a new layer
1. Inthe Timeline view, rename the layer on which you created your rough animation by double-

clicking on its name and entering its new name, for example: "Rough".

2. Inthe Timeline view, add a layer by doing one of the following:
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e Inthe Timeline view's layers toolbar, click on the ¥ Add Drawing Layer button
o Press Ctrl + R (Windows/Linux) or 3 + R (macOS).

The Add Drawing Layer dialog appears.

Add and Close

2. Inthe Name field, type in your new layer's name, for example: "Clean-up".
2. Select whether you want the Line Art layer should be Vector or Bitmap.

3. Select whether you want the Colour Art layer should be Vector or Bitmap.
4. Click Add and Close to add a new layer and close the window.

A new drawing layer is added to the Timeline view.

5. Inthe Timeline view, click the Lock icon of the layer containing your rough animation to prevent
the layer from being selected in the Camera view.

"OSaNE

6. Inthe Timeline or Xsheet view, select the new layer’s cell corresponding to the first key drawing of
your rough animation.
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7. Inthe Tools toolbar, select a drawing tool such as the Pencil £ tool.

8. In the Colour view, select a colour for tracing your animation. Pick a dark bold colour, such as black, to
make sure it contrasts well with the light colour of your rough animation.

9. Inthe Camera or Drawing view, start tracing the first key drawing.

NOTE

If overlay layers are in the way, you can disable them temporarily by clicking on
their (€4 Enable/Disable button in the Timeline view, so that only your rough
animation and your clean up layers are displayed.

10. Inthe Timeline or Xsheet view, select the next cell corresponding to a rough drawing.
11. Inthe Tools toolbar, click the & Enable Onion Skin button to enable Onion Skin.
12. Ensure onion skin displays your previous cleaned up drawing, by doing one of the following:

o Inthe Timeline view, click and drag on the red onion skin marker to make it include the
previous drawings you want to display in the onion skin, then click and drag on the
green onion skin marker to make it include the next drawings you want to display in

the onion skin.
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o Usethe buttonsin the toolbar above the drawing space to adjust how many previous
and next drawings are included in the Onion Skin:

« Toincrease the amount of previous drawings to display, click on the é Add
Previous Drawing button in the Camera/Drawing view toolbar.

« Todecrease the amount of previous drawings to display, click on the ==
Remove Previous Drawing button in the Camera/Drawing view toolbar.

o Toincrease the amount of next drawings to display, click on the % Add Next
Drawing button in the Camera/Drawing view toolbar.

« Todecrease the amount of next drawings to display, click on the == Remove
Next Drawing button in the Camera/Drawing view toolbar.

13. Inthe Camera view, trace your next drawing.

14. Repeat the previous steps for each drawing.
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Chapter 6: How to Morph Drawings

Hand-drawn animation requires you to spend a lot of time tracing in-between drawings. Harmony's morphing
feature can help speed up the process. This powerful feature automatically creates computer-generated
drawings between your vector drawings to save time and increase productivity. You can easily modify the
timing and velocity (ease in and ease out) of a morphing animation.

One of the main uses of the morphing feature is effects animation. For example, animating smoke or water can
be time-consuming because these types of effects are usually slow moving requiring a large number of closely
placed inbetweens.

The morphing feature is used to animate similar and simple shapes such as hair or smoke. It helps you by saving
time when you are working on tedious inbetweening and tracing tasks This, in turn, provides you with more
time to spend on complex animation tasks such as walk cycles or acrobatic sequences.

To learn how to morph drawings, it is better to start with basic shapes such as circles and rectangles. Once you
are more familiar with the tool, you can increase your knowledge and expertise. In a very short time you will be
producing some remarkable effects.

It is helpful to know the pros and cons of morphing before you start. Understanding what you can do and
which drawing lines may be more useful or problematic will enable you to design your key drawings so they
morph efficiently.

NOTE

The more complex the shape is, the longer it takes to morph. If it takes more time to morph a
drawing than to hand-draw it, then it is better to animate it instead of morphing. However, if you
spot an occasion when you can morph your drawings, do it! It allows you to fix your timing and
velocity in no time without having to create any extra drawings!
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How to create a basic morph

1. Inthe Timeline toolbar, click the Add Drawing Layer®. button to add a new layer to your project.
2. Rename the new layer ( for example, Morphing).

3. Inthe Timeline or Xsheet view, select the first cell in the layer.

4. Do one of the following:
« Inthe Tools toolbar, select the Rectangle [ tool.
e PressAlt+7.

5. Inthe Camera or Drawing view, draw a rectangle.

@ NOTE

When drawing a rectangle or an ellipsis, you can hold down the Shift key to

draw your shape with equal dimensions, so as to make a square or a circle
instead. You can also hold down the Alt key to draw the shape from its center
rather than from its corner.

6. Paint your rectangle using the Paint tool.

7. In the Xsheet or Timeline view, select the cell on which you want your morphing sequence to end.

8. Do one of the following:

« Inthe Tools toolbar, select the Ellipse
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O tool.
o PressAlt+=.

9. Draw and paint the ellipse with the same outline and fill colours as the rectangle.

10. Inthe Xsheet or Timeline view, select the range of frames going from your first drawing to your
second drawing, including the frames containing the drawings.

11. Do one of the following:
« Fromthe top menu, select Animation > Morphing > Create Morphing.
o Inthe Xsheet or Timeline view, right-click and select Morphing > Create Morphing
e Press Alt + M.

Arrows going from the first key drawing to the second key drawing appear, indicating that

computer-generated inbetweens have been created.

Adjusting the Morphing Velocity

When you look at your animation you will notice that the morphing motion is constant. To produce a less
mechanical motion, you will probably want to create some ease in or ease out.

How to add ease in and ease out to a morph

1. Inthe Tools toolbar, select the Morphing ?}) tool or press F3.

2. Inthe Timeline view, click on a frame in the morphing sequence you want to adjust.
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3. Inthe Tool Properties view, increase and decrease the Ease In and Ease Out value to adjust the
sequence's velocity.

s+ Mmain

ya

Adding Morph Hints

Harmony's Morphing tool allows you to control your morphing sequence in many ways. One of those ways is to
place hints to ensure Harmony morphs your drawings the way you intended.

Hints are points that are placed in both the source and destination drawings to associate zones and lines
between the two drawings. They are used to fix errors in the way Harmony morphs drawings, such as a line
that is not following the colour fill zone, or when a part of your source drawing doesn't morph into its
corresponding part of the destination drawing. By default, Harmony will associate a corner or a point in the
source drawing with the nearest corner or point in the destination drawing. Hence, hints quickly become
necessary if the shape being morphed or its movement is complex.

How to add and hints

1. Inthe Timeline or Xsheet view, select the source drawing of your morphing sequence.

2. Inthe Tools toolbar, select the ?}) Morphing tool or press F3.
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Use your other morphing key drawing, shown in the Drawing view's bottom right corner, as a

reference.

3. Inthe Tool Properties view, select the type of hint you want to use.

Select Contour Hint to correct a brush line or colour zone's contour (Contour vector).
Contour Hint points will behave similar to Pencil Hint points when used on a pencil
line. Note that you obtain better results using the Pencil Hint point on pencil line
rather than Contour Hint points.

Select Pencil Hint to correct a pencil line (Central vector).
Select Zone Hint to correct a colour zone morphing match.
Select Vanishing Point Hint to correct a vanishing shape's trajectory.

Select Appearing Point Hint to correct an appearing shape's trajectory.

4. Inthe Camera or Drawing view, click on the drawing near the problematic area.

5. Select the hint's point and move it to its correct position.
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6. Inthe Timeline or Xsheet view, select your destination drawing.

7. Find and move the corresponding hint's point to the matching part of your destination drawing.

—(0)
Q)

8. Inthe Playback toolbar, press the Play » button to see the result.
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Chapter 7: How to Import Images

By default, Harmony works with vector images created within its own interface. Vector images are primarily
composed of information about the different shapes composing the images, as well as their line and fill colours.
This makes them easy to edit and paint, and allows us to resize them without affecting the image quality. In
contrast, bitmap images are composed of colour information about each individual pixel composing the image.
Hence, they are more fit for very detailed or realistic pictures, but they cannot be scaled without losing image
quality, and can not be edited as easily as vector images.

Typically, you would need to work with bitmap images if you must create some of your scene assets, such as
backgrounds or props, in a different software. You can then import those bitmap image files into your Harmony

scene.

When importing a bitmap image, you must decide how Harmony must process it. You can choose between the

following options:

o Keep as Original Bitmap: This imports the image exactly as is and ensures that it cannot be modified
when working on the scene. This is useful for using backgrounds that were created in different software

in your project.

o Import as Toon Boom Bitmap Drawing: This imports the image asis, but allows you to edit it using
Harmony's bitmap drawing tools.

o Import as Toon Boom Vector Drawing: Converts a bitmap into Toon Boom vector art, which can easily
be painted and edited using Harmony's vector drawing tools. This can be useful for importing line art

scanned or created using a different software.

How to import a bitmap image in its original format

1. Doone of the following:
o From the top menu, select File > Import > Images.
« Inthe File toolbar, click the Import Images ‘[z button.

o Inthe Xsheet view, right-click anywhere in the frame area and select Import >

Images.

The Import Images dialog box opens.
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2. Inthe Files section of the Import Images dialog box, click Browse to find and select one or more

images on your computer.

3. Add the bitmap image to a new layer by selecting the Create Layer(s) option and one of the
following options:

o Create Single Layer Named: Creates a new layer with the specified name and imports

the imagesintoit.

o Create Layer(s) Based on Filenames: Creates a layer based on each unique filename
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this
will create two layers, one named "a" and one named "b". Layer "a" will contain the
two first images and "b" will contain the third one.

« Add to Existing Layer: Imports the images into the specified layer. Note that you can
only import into layers that are compatible with your import options. For example, if
you're importing images as vector drawings, you can only import them into vector
drawing layers.

4. Inthe Vectorization section, make sure the Vectorize Image option is unchecked.
5. In the Import Options section, select the Keep As Original Bitmap option.

6. Inthe Alignment section, decide on the size and placement of your image within the camera frame.
You can choose between the following options:

Parameter Description
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Fit

Adjusts the image's size to fit completely within the scene's field, both vertically
and horizontally, making sure the entire image is visible.

If the image's orientation is portrait, then it will adjust the image's height to fit
the field's height, without affecting the image's aspect ratio:

‘Camera resolution

Scene frame (grid)

Vertical image with Fit

alignment rule
If the image orientation is landscape, then it will adjust the image's width to fit
the field's width, without affecting the image's aspect ratio:
Camera resolution
Scene Frame (Grid)

Landscape image with

Fit alignment rule
This has the opposite effect to the fit parameter. The image's smallest dimension
will be made to fit the scene frame's matching dimension, and the image's
largest dimension will be adjusted proportionally, making the image fill the entire
scene field, and bleed past its boundaries it if its aspect ratio does not match the

Pan

field's aspect ratio. This option can be used to import a panning background
image, also referred to as a pan.

If the image's orientation is portrait, it will adjust the image's width to fit the
field's width, without affecting its aspect ratio:
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Verlical image with Pan
alignment rule

Camera
resolution

Scene frame (grid)

If the image's orientation is landscape, it will adjust the image's height to fit the
field's height, without affecting its aspect ratio:

Scene frame Camera Landscape image with Pan alignment rule
resclution

Scales the image to fit the scene's resolution, making each pixel in the image
Project take one pixel in the scene's field. For example, if the image's dimensions in
Resolution pixels are half of the scene's resolution in pixels, then the image's dimensions
will appear to be half of the scene field's dimensions.

7. Inthe Transparency section, decide how the bitmap image will be antialiased, more specifically, the
way the pixels along the edge are blended with the other colours. You can choose between the
following options:

Parameter Description

L . . Individual pixels at the edge of an image are blended with
Premultiplied with White hit
white.

Premultiplied with Black Pixels at the edge of an image are blended with black.
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Straight

Pixels at the edge of an image are blended with black, white
and greys.

Clamp Colour to Alpha

Premultiplies the colour value with the alpha value. When the
colour is clamped to the alpha, the colour value cannot be
higher than the alpha value. It calculates the real colour value
faster. When the RGB values are multiplied with the alpha
value, that is to say, if you have a pixel of value R=247,
G=188, B=29 and the alpha is 50% or the image has a 50%
transparency, then the actual RGB values that are output
would be half of the amounts listed above.

8. Click OK.

NOTE

By default, bitmap images will display in low resolution in the Camera view so as to avoid

affecting playback performance. You can also adjust the display quality of a bitmap image by

selecting it with the Transform tool, then opening the Bitmap Image Quality dialog via View >

Bitmap File Quality. You can also preview your bitmap image in your scene's resolution by

activating the Render Preview

Vectorizing Images

mode in the Camera view.

Harmony allows you to import images as vector drawings. Vector drawings can easily be painted and edited

using Harmony's vector drawing tools. This can be useful for importing line art scanned or created using a

different software, as you can then paint it in Harmony.

How to import a bitmap image as a Toon Boom bitmap drawing

1. Doone of the following:

o Fromthe top menu, select File > Import > Images.

« In the File toolbar, click the Import Images " button.

o Inthe Xsheet view, right-click anywhere in the frame area and select Import >

Images.

The Import Images dialog box opens.
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1.

2.

2.

In the Files section of the Import Images dialog box, click Browse to select one or more images from

your computer.
Select the destination for your images:

o Create Single Layer Named: Creates a new layer with the specified name and imports

the imagesintoit.

« Create Layer(s) Based on Filenames: Creates a layer based on each unique filename
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this
will create two layers, one named "a" and one named "b". Layer "a" will contain the
two first images and "b" will contain the third one.

» Add to Existing Layer: Imports the images into the specified layer. Note that you can
only import into layers that are compatible with your import options. For example, if
you're importing images as vector drawings, you can only import them into vector
drawing layers.

In the Alignment section, decide on the size and placement of your image within the camera
frame. You can choose between the following options:

Parameter Description

Adjusts the image's size so that its height matches the

Vertical Fit . . . .
scene's height, without affecting its aspect ratio.
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|— Camera resolution

Image with Vertical Fit
alignment rule Scene frame (grid)

Adjusts the image's size so that its width matches the
scene's width, without affecting its aspect ratio.

Horizontal Fit

Camera resclution

Image with Horizontal Scene frame (grid)

Fit alignment rule

Imports the image in its actual size, without adjusting its size
relative to the scene's resolution. For example, if the image's
Actual Size dimensions in pixels are half of the scene's resolution in
pixels, then the image's dimensions will appear to be half of
the scene field's dimensions.

In the Transparency section, decide how the bitmap image will be antialiased, more specifically, the
way the pixels along the edge are blended with the other colours. You can choose between the

following options:

Parameter Description

Individual pixels at the edge of an image are blended with

Premultiplied with White .
white.
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Premultiplied with Black Pixels at the edge of an image are blended with black.

. Pixels at the edge of an image are blended with black, white
Straight
and greys.

4. Click OK.

How to import and vectorize a bitmap image

1. Doone of the following:
o From the top menu, select File > Import > Images.
« In the File toolbar, click the Import Images " button.

o Inthe Xsheet view, right-click anywhere in the frame area and select Import >
Images.

The Import Images dialog box opens.

1. Inthe Files section of the Import Images dialog box, click Browse to select one or more images from
your computer.

2. Select the destination for your images:

o Create Single Layer Named: Creates a new layer with the specified name and imports
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the imagesintoit.

» Create Layer(s) Based on Filenames: Creates a layer based on each unique filename
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this
will create two layers, one named "a" and one named "b". Layer "a" will contain the
two first images and "b" will contain the third one.

« Add to Existing Layer: Imports the images into the specified layer. Note that you can
only import into layers that are compatible with your import options. For example, if
you're importing images as vector drawings, you can only import them into vector
drawing layers.

3. Inthe Ilmport Options section, select the Convert to Toon Boom Vector Drawing option.

4. Inthe Vectorization section, decide whether you want to import your image in black and white or in
greyscale. You can also click the New Preset button to create a custom vectorization parameter
preset.

» Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based
drawing. The outlines of your drawings will be painted with the Vectorized Line colour swatch of
your scene's colour palette.

» Grey: Vectorizes your image as a mix of vector contour and greyscale bitmap filling. Lines keep
the texture from the scan, and the white of the paper becomes transparent.

Grey preset Black and white preset

NOTE
You can double-click on any of the presets at any time to open the Vectorization Parameters

dialog box to customize your option.

5. Click OK.
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Your vectorized images will appear in their selected destination.

NOTE

If you have bitmap images in your Library, you can drag and drop them directly into your scene as a
quick way of importing a bitmap image. However, you will not have access to all the import options.
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Chapter 8: How to Position and Animate Layers

Setting up your scene can be compared to building a set for a television show. This is the point when you
position each scene element such as the camera frame, the background elements and the characters.

Positioning Layers

The first step to setting up your scene is to place each layer in their initial position, angle and size. You can make
any kind of geometric transformations on a layer using the Transform i} tool.

How to pan, rotate, scale or skew a layer using the Transform tool

1. Inthe Tools toolbar, select the i.} Transform tool or press Shift + T.

2. Inthe Tools toolbar, if < Animate Current Frame or = Animate Onion Skin Range mode is
enabled, click on it to open the Animate pop-up menu and select % Animate Off.

3. Inthe Tool Properties view, make sure /x Peg Selection Mode is disabled.

4. Inthe Camera or Timeline view, click on the layer you want to manipulate to select it.

TIPS

o Ifyou want to select multiple layers in the Camera view, hold down Shift and click on
each layer you wish to select.

o Ifyou want to select multiple layers in the Timeline view, hold down Ctrl
(Windows/Linux) or 38 (macOS) and click on each layer you wish to select.

« If you want to select a contiguous series of layers in the Timeline view, hold down
Shift, click on the first layer you want to select, then on the last layer you want to
select.
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A manipulator control box appears around the selected layer.

| Skew horizontallyl

n—' Scale horizontally & vertically

Scale horizontally & vertically

| Scale vertically

Scale horizontally & vertically

Skew vertically
Scale horizontally

1

i

Rotate

| Skew horizontallyl

Scale vertically

1. Doone of the following:

« To move: Move the cursor over the artwork. When the cursor changes into <{> click and
drag on the artwork to move it.

« To rotate: Place the pointer outside of a corner of the bounding box. When the cursor
changesinto, (), then click and drag to rotate.

ﬁ o

« To scale: Move the cursor over any of the yellow control points on the manipulator box.
When the cursor changesinto 7, click and drag to scale the layer.
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@ NOTE

When scaling your selection, you can hold down Shift to preserve the
proportions between its width and height.

« Move the cursor over one of the vertical edges of the manipulator box. When the cursor
changesinto 1|. , click and drag up or down to skew the layer vertically.

« Move the cursor over one of the horizontal edges of the manipulator box. When the cursor
changesinto ¥, click and drag left or right to skew the layer horizontally.

Repositioning the Pivot

Transformations made on a drawing layer, such as rotation, scale, skew and flip, are made relative to the
position of the drawing's pivot point. For example, rotating a layer will make it rotate around its pivot point, and
scaling the layer will make it scale as if its centre was actually its pivot point.
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While making transformations using the Transform tool, you can drag and drop your selection's pivot.
However, this has no permanent effect. It will only temporarily change the pivot's position to help you make
transformations at the selected frame, but the actual pivot point of your drawing layer will remain the same.

You can reposition a layer's pivot point permanently by using one of the tools in the Advanced Animation

toolbar.

NOTE

When you permanently move the pivot point of a layer that is already animated, all the

transformations done on the layer on other keyframes will be recalculated according to the new
pivot point's position. Therefore, your existing animation will look completely different, except at
the current frame. It is recommended to always make sure your pivot point is at its ideal position

before you start animating.

How to permanently reposition the pivot point of a layer

1. Inthe Advanced Animation toolbar, select the «%* Translate, (&} Rotate, (@ Scale, or /7 Skew tool.
2. Doone of the following:
o Inthe Timeline view, select the layer for which you want to move the pivot.

o Inthe Camera view, Ctrl + click (Windows/Linux) or 3£ + click (macOS) on the layer for which

you want to move the pivot.

The @ pivot point appears in the Camera view.

Pivot point

3. Move the cursor over the pivot point. When the mouse cursor becomes 4—}; click and drag on the

pivot point to reposition it.
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The layer's pivot point is now repositioned. If the layer has been animated, its position will be offset
across the scenes relative to how much you just offset the pivot point.

Animating a Layer

You can animate a layer by placing it in different positions, angles and sizes at different points across your
scene's timeline. To do this, you can create animation keyframes on your layer. A keyframe records the
geometrical transformations on a layer at a specific point in time. When two animation keyframes are on a layer
at different points in your scene's Timeline, Harmony will automatically interpolate the position, angle and size
of the layer on each frame between those two keyframes, creating an animation.

Position at
second keyframe

[ Position for each in-between frame

How to animate a layer

1. Inthe Tools toolbar, select the i.} Transform tool or press Shift + T.

2. Inthe Tools toolbar, if % Animate Off or g\i Animate Onion Skin Range mode is selected, click on it
to open the Animate pop-up menu and select Animate Current Frame.

3. Ifyour layer has a parent peg:

« If youwant to animate on the peg instead of the layer, make sure that /x Peg Selection
Mode is enabled in the Tool Properties view.

« If youwant to animate directly on the layer, make sure that /x Peg Selection Mode is
disabled in the Tool Properties view.

4. Inthe Timeline view, go to the first frame.

5. From the top menu, select Animation and make sure the Stop-Motion Keyframe option is
unchecked. This will make it so Harmony automatically creates the animation between the
animation keyframes you create.

6. Select the cell where you want to create your first keyframe
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10.

11.

To create your first keyframe, do one of the following:

« In the Timeline toolbar, click the ¢ Add Keyframe button.
o Right-click and select Add Keyframe.

e PressF6.

A keyframe is created on the first frame of the Timeline view.

rno=am
o

In the Camera view, select the element to animate and move, rotate, scale or skew it so that it isin
its proper starting position.

Select the cell where you want to create your second keyframe. right-click on the selection and
select Insert Keyframe.

The second keyframe appears in the Timeline view, along with a line going from your first keyframe
to your second keyframe. This indicates that every frame in-between will be animated by Harmony.

IIIIIIIIIF__|—

In the Camera view, move, rotate, scale or skew the element to that it isin its proper second
position.
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12. Inthe Timeline view, select the first frame to rewind to the beginning of your animation.

13. Inthe Playback toolbar, click on the » Play button to preview your animation.

NOTE

If you animate layers on the Z axis, you may want to preview your animations from the Top,
Side or Perspective views during playback. However, playback is disabled by default in those
view. To enable them, from the top menu, select Play > Enable Playback > Top View, Side

View or Perspective View.
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Chapter 9: How to Position and Animate the Camera

In Harmony, you can animate objects by drawing them on their individual layer, then positioning them at
different locations on different keyframes across the timeline, creating a motion path. The same principle can be
applied to the scene's camera, since it is a layer itself.

Adding a Camera

By default, a scene does not have a camera layer. In order to be able to tweak the scene's camera angle and
position, you must add one to your scene.

How to add a camera

1. Doone of the following:

o Inthe Timeline view, click the 4, Add Layer button and, in the pop-up menu, select
Camera.

o Fromthe top menu, select Insert > Camera.

A new camera layer is added to the scene and appears in the Timeline view.

Although it is possible to have several cameras in the same scene, you can only view your scene using one
camera at a time. This can be useful if you are still working on your scene composition and have different camera
set-upsto try out.

How to switch between cameras

1. Fromthe top menu, select Scene > Camera.

2. Among the listed cameras, select the one you want to work with.

Adding a Parent Peg

Although it is possible to position a camera without rigging it under a peg, it is recommended to always rig it
under a peg for two reasons:

« [t allows you to position, rotate and zoom the camera using the Transform tool.

o It allows youto animate camera movements. Without a parent peg, a camera's position, angle and zoom
are static.
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How to add a parent peg to a camera

1. Inthe Timeline view, select the Camera layer

2. Inthe Layerstoolbar, click the (% Add Peg button.

A Peg layer appears directly above the Camera layer and is automatically attached to it.

Positioning the Camera

The scene action occurs inside the camera frame, so it’s really important to set it up correctly. You can adjust the
camera resolution as well as other related parameters in the Scene Settings window, accessible from the Scene

top menu.

To reposition camera directly, you can move it using the .1 Transform or <-§+ Translate tool, you can rotate it
using the (& Rotate tool and you can zoom it using the | & Scale tool, from the Advanced Animation toolbar.
Alternatively, you can type in its coordinates directly in the Layer Properties view. If you rigged the camera
under a peg, you can do all sorts of manipulations to it using the Transform tool alone. The following steps
indicate how to manipulate the camera when it is rigged under a peg.
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How to position a camera rigged under a peg in the Camera view

1. Doone of the following to select the Camera's parent peg.

o Inthe Timeline view, click on the Camera's parent peg layer.

o Inthe Camera view, click on the camera frame. The camera frame is a thin rectangle around
your scene's stage.

A control box appears around the camera frame.

| Zoom In or Out

| Zoom In or Qut pe——o

Move

T Zoom In or Out
®

Zoom In or Out

2. Do one of the following:

o To move the camera frame: Position the cursor over any of its edges or over the centre.
When the cursor becomes +}+, click and drag on the camera frame to reposition it.

o To zoom in or zoom out: Position the cursor over one of the corners of the camera frame.
When the cursor becomes ™., click and drag on the corner to resize the camera frame.
Shrinking the camera frame will zoom in on your scene, and expanding it will zoom out.
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« To rotate the camera: Position the cursor just outside one of its corners. When the cursor
becomes &, click and drag to rotate the camera frame.

Animating the Camera

A scene's camera can be manipulated and animated just like any other layer. It is listed in the Timeline view and
you can use the same tools and selection modes to offset or animate it. However, the camera layer itself is static,
which means it keeps the same position and angle throughout the whole scene. In order to be able to animate
the camera, you need to connect it to a peg layer, which can be animated, and which will directly affect the

position and angle of the camera.

noO=am

o L]
o

You can animate your camera movements directly in the Camera view.

How to animate the camera

1. Inthe Tools toolbar, if $ Animate Off or =} Animate Onion Skin Range mode is selected, click on it
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to open the Animate pop-up menu and select <~ Animate Current Frame.

2. Inthe Tools toolbar, select the .} Transform tool or press Shift + T.

3. Ontheright side of the Timeline view, on the Camera peg layer, select the frame at which you want
the camera movement to start.

4. Do one of the following to add a keyframe:

« Inthe Timeline toolbar, click the ¢+ Add Keyframe button.
o Right-click and select Add Keyframe.

e PressF6.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera

position as this keyframe.

5. In the Camera view, manipulate the camera so that it is in the right position at the beginning of your
camera movement.

6. On the Timeline view, click on the cell where the camera movement will end.

7. Do one of the following:

« Inthe Timeline toolbar, click the ¢+ Add Keyframe button.
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o Right-click and select Add Keyframe.

e PressF6.

A keyframe appears in that cell.

8. In the Camera view, manipulate the camera so that it is in the right position for the end of your
camera movement.

9. Inthe Timeline view, select the first frame to rewind to the beginning of your animation.

10. Inthe Playback toolbar, click on the » Play button to preview your animation.
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Chapter 10: How to Rig a Cut-out Character

In Harmony, a character rig is basically a template based on your character's model, but in which all movable
parts are broken down into different layers, and arranged in a hierarchy that facilitates digital animation, also
known as cut-out animation.

To make a character rig, we must first make sure you have a character model to build on. If you have any
drawing of a character available, import it into a new scene, then scale and position it to your liking. Otherwise,
you can draw your character's model directly in Harmony. Once you have a model ready, we can start breaking
it down into parts to build your rig with.

There are many techniques you can use to break down a puppet. In this section, you will learn about one of the
most common and simplest methods. For your first character breakdown, follow these instructions to get an
idea of the way Harmony works. Once you understand Harmony's basic functions and commands, you will be
able to create your own techniques to satisfy the needs of your production.

M2

Drawing the Pieces

The main breakdown technique shown here is to trace your model.

How to break down a character by tracing

1. Inthe Timeline view, add a new drawing layer for each body part to separate. You can press Ctrl + R
(Windows/Linux) or & + R (macOS) to add new drawing layers.
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2. Inthe Timeline view, select the layer's first cell in which you want to draw the part.

3. Inthe Tools toolbar, select the drawing tool of your choice. There are two commonly used methods
to drawing the parts of a cut-out character model:

« Usingthe # Pencil tool, then smoothing your lines with the X Smooth Editor tool

« Usingthe G Polylinetool. This method allows you to draw with great precision, but
may take more time.

These methods ensure each part is made with as few points as possible, so that they are easy to
manipulate, modify or redraw.

4. In the Colour view, select a colour swatch. If you haven't created a palette for your character yet, see
How to Paint on page 40.

5. If you prefer working in the Drawing view, do one of the following to display the other layersin
washed out colours:

« Inthe Drawing view toolbar, lick the ‘¢ Light Table button.
o Press Shift + L.

6. Inthe Camera or Drawing view, draw the new part.
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7. If youwant to close an open shape without drawing a visible outline, you can draw an invisible line
using the (~ Stroke tool.

NOTE

By default, your strokes are not visible. To see the strokes in your drawing, select View >
Show > Show Strokes from the top menu or press K.

8. Inthe Tools toolbar, select the ® Paint or Paint ® Unpainted tool to colour your drawing.
9. In the Colour view, create the desired fill colour if it's not already in your palette, then select it.

10. Inthe Camera or Drawing view, paint your drawing.

11. Inthe Tools toolbar, select the & Select tool. Select your drawing and flatten the lines by clicking
the & Flatten button in the Tool Properties view.

12. Ifyour lines are composed of several pencil strokes, you might want to combine them into one single
smooth pencil line. Using the Select tool, select the pencil lines to be merged and in the Tool
Properties view, click the % Merge Pencil Lines button.
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13. Repeat the entire process for every body part that you wish to make animatable.

it

Adding Pegs

Pegs are a special type of layer that do not contain any drawing. They are used strictly to offset and transform
drawings that are under their hierarchy, without transforming the drawings directly.

When rigging or setting up a scene, it is recommended to add parent pegs for each of your drawing layers. This
allows you to keep animation keyframes and drawings on separate layers, making it easier to work on the
position and exposure of your drawing layers independently in the Timeline view. It also makes it easier to
create a hierarchy of which body parts can be animated together and independently.
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If you want to animate only on pegs, you can activate the Peg selection mode of the Transform tool in the Tool
Properties view. You can also disable animating drawing layers, so that only pegs can be animated.

NOTE

It is also possible to make a drawing layer the parent of another drawing layer. Just like the way
animating a peg animates its children layers, animating a drawing layer with children will also
animate its children layers. Both layers will still appear in the animation.

How to create parent pegs for your layers in the Timeline view

1. Inthe Timeline view, select all the layers.

+
|

¥

+

+ 4+t
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2. Inthe Timeline Layer toolbar, click the Add Peg (% button to add a parent peg to all selected layers.

)

+ |+ o ]

Creating a Layer Hierarchy

Harmony lets you build your rig in an elaborate hierarchy, allowing you to set which parts of your rig should
influence other limbs, and how they can move independently. For example, when rigging a simple character's
arm, you can make the forearm layer a child of the arm layer, and the hand layer a child of the forearm layer.
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This way, if the character moves their forearm, the hand will follow, and if they move their arm, the forearm and

hand will follow.

) ! 4—‘ Head hierarchy

Right arm hierarchy ]—F 1— Left arm hierarchy

¥
4 ]
_ Right leg hierarchy JI—P ’d—i Left leg hierarchy

When building a basic character rig, you should at least have a hierarchy for each arm and each leg. You can
make a hierarchy going from the torso, the neck and the head, and rig the arms to the torso, and you can rig

the legs to the hips. This would make a hierarchy like this:

How to create a hierarchy in the Timeline view

1. Inthe left area of the Timeline view, select the layer which you want to make a child layer.

2. Drag the child and drop it over the layer which you want to make the parent layer. Make sure you
are not dropping the child layer between two layers.

3. Repeat until you've created a hierarchy that rigs all of your character's parts, with a master peg at
the root. While rigging, if you want several layers to have a common parent, but no existing part of
your rig can serve as that parent, create a new peg and nest those layers under that peg.
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Without pegs

+ “+ (% +
+ + +
+ + +
+ + +
+ + +
+ + +
+ + +
+ + +
+ + +

NOTE

In the Timeline view, you can unparent layers by holding down Shift, dragging the selected
parent away from the child layer and dropping it somewhere else in the list.

When rigging, keep in mind that the order of the layers in the Timeline view affects the order in which they are
rendered. Layers on top of the list will be rendered over layers at the bottom of the list. Should you need to
change a layer's order while animating, you can nudge this layer's position on the Z-axis to override the layer

order and force it to appear beneath or over other layers.

How to nudge a layer on the Z-axis

1. Inthe Tools toolbar, select the i.} Transform tool.
2. Inthe Timeline, Node or Camera view, select the layer you want to nudge.

3. Ifyou selected the layer from the Timeline or Node view, click on the Camera view tab to set the
focus on the Camera view.

4. Do one of the following:
o Tonudge the layer forward, press Alt + Down Arrow.

o Tonudge the layer backward, press Alt + Up Arrow.

Master Peg

Your character rig should always have a master peg which connects to all of its parts. The master peg allows
you to manipulate the entire rig from a single layer, without having to manipulate each individual part. This is
useful for positioning and scaling your character relative to the scene, as well as to animate your character's
trajectory when it has to move between areas of the scene.
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How to add a master peg in the Timeline view

1. Inthe Timeline view, select the top layer.
2. Inthe Timeline view, click on the (% Add Peg button.

A new peg is added to the timeline as a parent of the selected layer.
3. Name the new peg Master plus the character's name.

4. Inthe Timeline view, select all the layers you want to attach to your new peg. Remember that your
top layer is already a child of the peg, so don't include it in your selection.

5. Drag your selection ON to the peg layer to parent all your character's pieces to the peg. If your layers
are added above the already parented layers, move that parented layer back on top of the layer
stack.
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Chapter 11: How to Animate a Cut-out Character

Harmony provides very useful tools for animating cut-out character models. Using the Transform tool, you can
move your character's parts to make your key poses, and let Harmony create the in-betweens. The timing of
the movement can be adjusted to make life-like motion, and the drawings for the character's parts can be
swapped at any point in your animation, allowing you to combine movement and drawing changes to create

frame-perfect cut-out animations.

How to create a simple cut-out animation

We will create a simple cut-out animation by making your character's first pose on the first frame, its

second pose on a later frame, and letting Harmony interpolate them.

1. Inthe Timeline view, collapse your character using the Expand/Collapse arrow.

3. Toensure your model doesn't disappear after 1 frame, open the Extend Exposure dialog by doing

one of the following:

o Right-click on the first frame in the Timeline and select Extend Exposure.

e PressFb.
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4.

7.

In the Extend Exposure dialog, type in the amount of frames in your scene and confirm. This will
make your model exposed (visible) throughout your whole scene.

Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame
of every layer of the model. This ensures that when you make the second pose later, your first pose
will not be affected. To do this do one of the following:

In the Timeline toolbar, click the ¢r Add Keyframe button.
Right-click and select Add Keyframe.
Press F6.

A keyframe is added on the current frame.

In the Tools toolbar, select the {.} Transform tool or press Shift + T.

In the Tools toolbar, if % Animate Off or g\% Animate Onion Skin Range mode is selected, click on it
to open the Animate pop-up menu and select Animate Current Frame.

In the Camera view, select the parts to animate. The Transform tool's control box will appear around
the selected layer. Each part of the Transform tool control can be used to make different kinds of
transformations:

Resize

Use the Transform tool to rotate, skew, scale or translate the selection to its new position.
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11.

Repeat for other parts of your character model until your first pose is complete.
In the Tools toolbar, enable the é Onion Skin feature.

In the Timeline view, select the frame where you want to have your second pose.

Create keyframe for your second pose by doing one of the following:
« Inthe Timeline toolbar, click the ¢+ Add Keyframe button.
o Right-click and select Add Keyframe.

e PressF6.

Your second keyframe appears, along with a line going from your first keyframe to your second
keyframe. This indicates that every frame in-between will be interpolated by Harmony.

If no line appears, it means your first keyframe was created as a stop-motion keyframe. To fix this, do
one of the following.

o Right-click on the first keyframe and select Set Motion Keyframe.
o Select the first keyframe and press Ctrl + K (Windows/Linux) or 38 + K (macQOS)

To make sure your new keyframes are set to Motion by default, select Animation from the top menu
and make sure the Stop-Motion Keyframe option is unchecked.

NOTE

Each keyframe can be a Motion keyframe or a Stop-Motion keyframe. The frames
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between two keyframes are interpolated by Harmony if the first of the two keyframes is
a Motion keyframe.

12. Inthe Camera view, change your character's pose again.

=]

-

Selected ,
layer

13. Repeat this process for all the poses you wish to add to your animation.

How to adjust the ease of the animation

1. Inthe Timeline view, collapse your character model's hierarchy.

2. Select one of your animation keyframes. Since your model's hierarchy is collapsed, this selects the

keyframe on every layer simultaneously.

3. Doone of the following:
o Inthe Timeline view, right-click and select Set Ease For Multiple Parameters.
« Inthe Timeline toolbar, you can click the Set Ease For Multiple Parameters =~ button.

The Set Ease For Multiple Parameters dialog box opens.
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4. Inthe graph, pull on the Bezier handle to adjust the velocity for all the selected functions.

5. Toapply these easing parameters to a certain type of function only, such as Rotation or Scale, in the
Filters section, deselect the function types you do not want to affect.

o Motion: Applies the easing parameters to the selected Position X, Position Y, Position
Z and 3D Path functions

« Rotation: Applies the easing parameters to the selected Angle functions.
o Scale: Applies the easing parameters to the selected Scale functions.
o Skew: Applies the easing parameters to the selected Skew functions.

o Morphing: Applies the easing parameters to the selected Morphing Velocity functions.
Note that it is applied to the Morphing Velocity function in the Layer Properties
window, not to the basic Morphing ease in the Tool Properties view.

o Other: Applies the easing parameters to all the other selected functions, such as all
functions created to animate effect parameters.
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6. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values
are calculated in percentage.

o Inthe Left Time Ratio and Right Time Ratio fields, type the percentage value
corresponding to the length of time you want the easing to last. The value must be
between 0% and 100%.

o Inthe Left Value Ratio and Right Value Ratio fields, type the percentage value of how
strong you want the easing out. The value must be between 0% and 100%.

« If your Time Ratio and Value Ratio values are equal, you will have a linear motion.
7. Click one of the following buttons:

« Apply/Previous: Applies the easing parameters to the selected keyframes and then
selects the previous keyframe in the timeline.

o Apply: Applies the easing parameters to the selected keyframes.

o Apply/Next: Applies the easing parameters to the selected keyframes and then
selects the next keyframe in the timeline.

o Close: Closes the dialog box. If you did not apply the modifications, they will be
cancelled.

NOTE

If a range containing multiple keyframes is selected, only the first selected keyframe will be
affected by the Seat Ease for Multiple Parameters functionality.

Navigating Layers

Since cut-out animation often involves complex models with extensive hierarchies, learning shortcuts to easily
navigate between layers can save a lot of time.

One very useful trick to learn is the Centre on Selection command, along with its keyboard shortcut. This
command allows you to navigate directly to the selected layer in the Timeline view. Hence, you can use the
Camera view to visually select the layer you wish to work on, then use the Centre on Selection shortcut to find
the layer in the Timeline view, instead of going through the scene structure to locate it.

How to centre on the current selection in the Timeline view

1. Inthe Timeline view, collapse all your layers.
2. Inthe Tools toolbar, select the i- Transform tool.

3. Inthe Camera view, select any layer.
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4. Do one of the following:
o Click on the Timeline view's tab to set the focus on it, then press O.
¢ Inthe Timeline view toolbar, click the Centre on Selection button.

The Timeline view is now centred on the selected layer, and all its parents have been automatically
expanded.

If you want to use the keyboard shortcut frequently, you might find that having to click on the Timeline view
tab every time is tedious. To remedy this, you can enable the Focus On Mouse Enter preference. This will set the
focus on a view as soon as your mouse cursor enters it, instantly making all of this view's keyboard shortcuts
functional.

How to enable the Focus On Mouse Enter preference

1. From the top menu, go to Edit > Preferences (Windows/Linux) or Harmony > Preferences (Mac OS
X).

2. Open the General tab.
3. In the Options section, check the Focus On Mouse Enter check box.
4. Click on OK.

Keyboard shortcuts for specific views will now work as soon as your mouse cursor enters the
intended view.

Harmony also has commands and keyboard shortcuts to quickly change your selection from the currently
selected layer toits parent, its child or to one of its siblings, allowing you to quickly navigate your character's
hierarchy from one layer to one of its related layers.

How to select the parent or child of the selected layer

1. Inthe Tools toolbar, select the i.i Transform tool.
2. Inthe Transform Tool Properties view, make sure the Peg Selection /& mode is deselected.

3. Inthe Camera or Timeline view, select a layer or object attached to a hierarchy.
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4. Do one of the following:

o Select Animation > Select Parent or press B to select the parent layer.
o Select Animation > Select Child or press Shift + B to select the child layer.

o Select Animation > Select Children to select all child layers at the same time.

NOTE

When going up or down your node hierarchy, these keyboard shortcuts skip any effect node in
the hierarchy and only select either peg or drawing nodes. This is because these shortcuts are
optimized for cut-out animation. In the Shortcuts tab of the Preferences dialog, under General,
these keyboard shortcuts are actually called Select Parent Skipping Effects and Select

Child Skipping Effects. If you want to use keyboard shortcuts to navigate the hierarchy
without skipping effect nodes, you can assign custom keyboard shortcuts for the Select Parent
and Select Child commands instead.

How to select the siblings of the selected layer

1. Inthe Timeline view, select a layer that has at least one sibling and do the following:
« Toselect the previous sibling in the family, press /.

o Toselect the next sibling in the family, press the question mark (?) key.
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Previous sibling
Next sibling

o
o
o
o
o
o
o
o
o
o
o
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Chapter 12: How to Use Deformers

Deformers give the ability to animate objects and parts of a character model using computer generated
deformations. This allows you to bend or distort drawings without having to redraw them. When used in cut-
out animation, they can extend considerably the range of movements and poses a character model can pull
without having any of its parts drawn in different poses, which can save a lot of time and make your cut-out
animation look much more natural with little effort.

Deformers can be used to deform a single drawing layer or a hierarchy of layers, so a single deformer can be
used to deform anything ranging from a simple prop to a whole character rig. They can be used on both vector
and bitmap drawings.

Deformers work by rigging them on the body part you wish to deform, building the deformation structure, then
animating it. This can be done easily using the {T Rigging tool.

There are two types of deformers available in Harmony Advanced:
« Bone

« Game Bone

Bone Deformer

The Bone deformation allows you to create a bone-like structure in which each part is solid, but with
articulations that are flexible. This is mostly useful for animating a character's limbs, such as the arms or legs, or
other parts that can be articulated such as torsos or fingers.

For example, a Bone deformation can be used to articulate an arm that is made of a single drawing, so that the
upper arm and forearm can be moved independently, without having to draw the upper arm and the forearm
on different layers. Harmony will deform the drawing to make it look articulated. The different parts of a Bone
deformation can be rotated around their joint, extended and shortened, giving you the same capabilities as
animating articulations on different layers, without having to worry about parts detaching, pivot points, or
clipping outlines.

(
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Articulation
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Game Bone Deformer

The Game Bone deformation is very similar to the Bone deformation. It allows you to create a bone-like
structure in which each part is solid, but with articulations that are flexible. However, it is optimized for game
engines such as Unity. Hence, it is usually only used for game development and not in animated productions.
Contrary to the Bone deformations, Game Bone deformations do not have a Bias property. The articulation
folds also look slightly more rounded.

(
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Creating Deformers

The most simple way of creating deformers is to use the §T Rigging tool, available in the Deformation toolbar.
With this tool, all you need to do to create a deformer is to select the layer you wish to deform, then place each
point of your deformer in the Camera view.

Deformers exist in your scene as a hierarchy of deformation layers. When you create a new deformer, the first
point you set is the deformer's root, and each new point you create is a child of the previous point. Deformers
are hence created in a chain, and should be created with your character's hierarchy in mind. For example, when
you create a deformer for an arm, the root should be the shoulder joint, the second point should be the elbow
and the third should be the wrist.

How to select the element on which to create a deformer

A deformer affects all the layers under its hierarchy. When you create a new deformer using the rigging
tool, it is automatically created as a parent of the selected layer, and will affect the selected layer and all its
children. Hence, it's important to select the right layer before attempting to create a deformer.

For example, if you wish to create a deformer for an arm, and the arm is broken into several layers, you
could rig the arm in a hierarchy where the upper arm is the root, the forearm is the upper arm's child and
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the hand is the forearm's child. Then, if you create your deformer on the upper arm, it will be created as a
parent of the upper arm, and will hence affect the whole arm.

You can also group several layers under a peg, and create your deformer with this peg selected. When you
create a deformer on a peg, the deformer is created as a child of the peg, but as a parent of all of this peg's
children. This is because a peg is likely to be more useful over a deformer than under. If you move layers
that are under a deformer, they will exit the intended deformation zone, and may appear severely warped
and distorted. Hence, it's better to create deformations under pegs as much as possible, and pegs under
deformers should only be animated if the deformer is left untouched. Since the deformer will be created as

a parent of all the peg's children, it will affect all the layers under the peg.

How to create a Bone deformer

1. Once your element is selected, select the §T Rigging tool in the Deformation toolbar.
2. Inthe Tool Properties view, enable the < Bone mode.

3. Click where you want to create the root articulation of the bone structure. The root articulation
should be the one that is bound to the remainder of the body. For example, for an arm, the root
articulation would be its shoulder.

4. Click where you want the second articulation to be created.

A bone will be created between the first and second articulation.
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Observe that, as you create a new point, the previous point now has a circle around it. Thisis the
radius of the articulation, which allows you to determine how much of the drawing should be part of
the articulation. Every point in a bone deformer, except for the first and the last one, has a radius.

6. Click and hold the previous articulation's radius control point and adjust the articulation's radius so

that it properly covers the articulation.

7. Repeat this until you are finished creating the Bone chain. Make sure you build each articulation in

the right order going from the root to the extremity.

Displaying Deformers

Harmony lets you control which deformers are displayed in the Camera view independently from the current
selection. When you create a deformation chain, its deformation controls are displayed in the Camera view.
However, if you select an existing deformer or a layer that's connected to existing deformers, its deformation
controls won't display automatically. Likewise, deselecting a deformation chain will not hide its deformation

controls.

Before you can animate or modify an existing deformation chain, you must manually display it.

How to display deformation controls

1. Doone of the following:
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o Inthe Camera or Timeline view, select one of the drawing layers linked to the deformation
chain you want to display.

o Inthe Timeline view, select any part of the deformation chain you want to display.

2. Inthe Deformation toolbar, click the S Show the Selected Deformation Chain and Hide All Others
button.

The selected deformation controls appear in the Camera view. If other deformations were displayed,
they are now hidden.

NOTE

The Show the Selected Deformation Chain and Hide All Others button will display all
deformation chains that are in the hierarchy of the selection. For example, if the master peg of
a character model is selected, all of its deformation chains will be displayed. Likewise, if multiple
layers linked with different deformation chains are selected, all of their deformation chains will
be displayed.

How to hide deformation controls

1. Doone of the following:

o Click in the negative space of the Camera view, Timeline view or Node view to discard
the current selection, then click on the & Show Selected Deformation Chain and Hide
All Others button in the Deformation toolbar.

« Select a layer that is not linked to any deformer, then click the < Show the Selected
Deformation Chain and Hide All Others button in the deformation toolbar.

o Inthe Camera toolbar, click the & Hide All Controls button.
o Fromthe top menu, select View > Hide All Controls.

e PressShift + C.

Modifying Existing Deformation Chains

As you attempt to animate a deformation, or if you need to make changes to the drawings under a deformation,
you may need to make adjustments to the deformation chain to better fit your needs.
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How to make adjustments to a Bone or Game Bone deformation chain

1. Doone of the following:

o Inthe Camera or Timeline view, select one of the drawing layers linked to the deformation

chain you want to edit.

o Inthe Timeline view, select any part of the deformation chain you want to edit.

2. In the Deformation toolbar, click the & Show the Selected Deformation Chain and Hide All Others
button.

The selected deformation controls appear in the Camera view. If other deformations were displayed,

they are now hidden.
1. In the Deformation toolbar, click the §T Rigging tool.

The deformation chain turns from green to red. A green chain indicates that you're animating the
deformation. A red chain indicates that you're modifying the rig.

N |
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2. Inthe Camera view, set up the deformation chain.

o Torotate the a bone, click and drag on it. This will rotate the selected bone and all

subsequent bones in the chain.
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I

o To offset the whole chain, click and drag on its root control point.

« Toreposition an articulation, click and drag on its control point.
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o Toadjust an articulation's radius, click and drag on its radius control point. Make sure
the radius of the articulation covers the articulation itself.

3. Repeat until all the articulations and bones of the chain are correctly aligned to the element to
which it is linked.

4. Test your modifications using the i.} Transform tool.

.‘Q'. TIP
When manipulating the articulation of a Bone or Game Bone deformer, you can press and hold
the Alt key to lock the bone's angle and only shorten or elongate the bone. You can also hold
the Ctrl (Windows/Linux) or &8 (macOS) key to break the articulation off its chain and make it

into a new, separate deformation chain.

How to add an articulation to a Bone or Game Bone deformation chain

1. Doone of the following:

o Inthe Camera or Timeline view, select one of the drawing layers linked to the deformation

chain you want to edit.

o Inthe Timeline view, select any part of the deformation chain you want to edit.

2. Inthe Deformation toolbar, click the & Show the Selected Deformation Chain and Hide All Others
button.

The selected deformation controls appear in the Camera view. If other deformations were displayed,

they are now hidden.

115



Chapter 12: How to Use Deformers

3. Inthe Deformation toolbar, select the {T Rigging tool.

The deformation chain turns from green to red, meaning that you are editing the deformation chain
rather than animating it.

4. Pressand hold the Alt key.

5. While holding the Alt key, click on the bone where you want to add an articulation.

xﬁﬁ“m-mh_
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Animating With Deformers

Just like with animating pegs and drawing layers, you can animate your deformers by creating keyframes on
their corresponding layers in the Timeline. Animating deformers works exactly like making modifications to a
deformer, except it requires using the i.} Transform tool instead of the Rigging tool. When the Transform tool
is selected, deformation controls in the Camera view display in green, which means they are in animation mode,
whereas when the Rigging tool is selected, they display in red, meaning they are in rigging mode.

How to animate Bone and Game Bone deformations

1. Inthe Timeline view, collapse your character using the Expand/Collapse arrow.

3. Toensure your model doesn't disappear after 1 frame, open the Extend Exposure dialog by doing

one of the following:
o Right-click on the first frame in the Timeline and select Extend Exposure.

e PressFb.
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4. Inthe Extend Exposure dialog, type in the amount of frames in your scene and confirm. This will
make your model exposed (visible) throughout your whole scene.

5. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame
of every layer of the model. This ensures that when you make the second pose later, your first pose
will not be affected. To do this do one of the following:

« Inthe Timeline toolbar, click the ¢r Add Keyframe button.
o Right-click and select Add Keyframe.
e PressF6.

A keyframe is added on the current frame.

4. Inthe Tools toolbar, select the i.1 Transform tool or press Shift + T.

5. In the Tools toolbar, if % Animate Off or g\% Animate Onion Skin Range mode is selected, click on it
to open the Animate pop-up menu and select Animate Current Frame.

6. Do one of the following:

o Inthe Camera or Timeline view, select one of the drawing layers linked to the deformation
chain you want to animate.

o Inthe Timeline view, select any part of the deformation chain you want to animate.

7. Inthe Deformation toolbar, click the & Show the Selected Deformation Chain and Hide All Others
button.

The selected deformation controls appear in the Camera view. If other deformations were displayed,
they are now hidden.

8. Inthe Camera view, do the following:

« Torotate the whole limb, click and drag on the first bone. This will rotate the first bone
and all subsequent bones.
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o Tobend thelimb, click and drag on another bone. This will rotate the bone and all
subsequent bones, but will leave the bones before it in their current position.

« Toreposition an articulation, click and drag on its control point. This can be used to
rotate, shorten or extend the bone, and will offset all subsequent bones.

o Toshorten or extend a bone without rotating it, press and hold the Alt key, then click
and drag on its control point.
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« To offset the whole limb, click and drag on its root point.

NS TIP

4 .

You can also nudge an articulation in any direction by selecting it, then
pressing on the arrow keys.

9. Inthe Timeline view, go to the frame on which you want to set the next key pose.
10. Add a keyframe on the current frame by doing one of the following:
e Inthe Timeline toolbar, click the Add Keyframe * button.
o Right-click and select Add Keyframe.
o PressF6.
11. Transform your deformation chain's points to make your new key pose.

12. Repeat the previous steps until your animation is complete.
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Importing Sound

If you wish to add sound to your animation, it is recommended to edit and mix your sound files in a sound
editing software. Having full-length pre-mixed soundtracks ensures the audio preserves its timing, mixing and
quality should you use third party software for post-production. Another good practice is to keep your
soundtrack separated in tracks for music, sound effects and characters to make it easier to sync your animation
with voices and sounds. Otherwise, it is possible to clip sound effects and adjust their volume directly

in Harmony when needed.

If you create your project in Toon Boom Storyboard Pro, you can export all of your project's scenes as separate
Harmony scenes. The storyboard's sound track will be cut up by scene and each piece will be inserted into the
exported scenes, allowing you to save time on splitting and importing your sound track.

Harmony can import .wav, .aiff and .mp3 audio files.

NOTE

Importing a soundtrack longer than your scene will not extend your scene's length. Sound playback
will stop at the end of your scene's length.

How to import a sound file

1. Doone of the following:
o From the top menu, select File > Import > Sound.

o Inthe Xsheet view, right-click anywhere in the frame area and select Import >
Sounds.

o Fromthe Xsheet menu, select File > Import > Sounds.
e Fromthe Timeline menu, select Import > Sounds.
The Select Sound File dialog box opens.
2. Fromthe Select Sound File dialog box, find and select a sound file.

The sound file appears as a layer in the Timeline view. Its waveform is displayed in the track to help
you visualize at which frames the sound effects in your soundtrack occur.
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Your soundtrack also appears as a column in the Xsheet view, but will not display a waveform by
default. If you wish, you can display a sound column's waveform by right-clicking on it, then
selecting Sound Display > Waveform.

Automatic Lip-Sync Detection

Adding a lip-sync to your animation is essential to making your characters seem alive. However, it is also a
particularly tedious part of the animation process.
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To solve this problem, Harmony provides an automatic lip-sync detection feature. This feature analyzes the
content of a sound track in your scene and associates each phoneme it detects with one of the mouth shapesin
the following mouth chart, which is a standard mouth chart in the animation industry.
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NOTE

The letters assigned to these mouth shapes are standard identifiers, they do NOT correspond to
the sound they are meant to produce.

This is an approximation of the English phonemes each mouth shape can be used to represent:
e« A:m,b,p,h
« B:s,d,j ikt
e Cea
« D:AE
« Eo
e F:u,00
o« G:f ph
o X:Silence, undetermined sound

When performing automatic lip-sync detection, Harmony does not create mouth drawings. It simply fills the
drawing column of your character's mouth layer with the generated lip-sync, by inserting the letter associated
with the right mouth shape into each cell of the column. Therefore, for the automatic lip-sync detection to work,
your character's mouth layer should already contain a mouth drawing for each drawing in the mouth chart, and
these drawings should be named by their corresponding letter.

How to generate a sound detection for lip-sync using the Layer Properties view
1. Inthe Timeline or Xsheet view, select the sound layer.

The options for that layer will appear in the Layer Properties view.

2. Inthe Layer Properties, click Detect.

Harmony analyzes the selected sound clips and assigns a lip-sync letter to each sound cell.

122



Harmony 16.0 Advanced Getting Started Guide

3. Click the Map button to open the Lip-Sync Mapping dialog box.

4. From the Destination Layer menu, select the layer that contains the mouth positions for the
character's voice track.

NOTE

If the selected layer contains symbols, you can map the lip-sync using drawings located
directly on the layer or use the symbol's frames. In the Symbol Layer field select Don't
Use Any Symbol if you want to use the drawings or select the desired symbol from the
drop-down menu.

5. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the
phoneme it represents. If your drawings are already named with the phoneme letters, you can skip
this step.

6. Click OK.
7. Inthe Playback toolbar, enable the ) Enable Sound option.
8. Pressthe » Play button in the Playback toolbar to see and hear the results in the Camera view

If you need to make adjustments to the automatically-generated lip-sync, see Animating Lip-Sync

Manually on page 124.
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Animating Lip-Sync Manually

You can manually create the lip-syncing for your scene by selecting which mouth drawing should be exposed at
each frame of your character's dialogue. For this process, you will be using the Sound Scrubbing functionality,
which plays the part of your sound track at the current frame whenever you move your Timeline cursor,
allowing you to identify which phonemes you should match your character's mouth to. You will also be using
drawing substitution to change which mouth drawing is exposed at every frame.

How to animate lip-sync using the Timeline view

1. Inthe Playback toolbar, enable the €S Sound Scrubbing button.
2. Inthe Timeline view, drag the red playhead along the sound layer waveform.

3. When you reach a frame where a mouth position should go, for example, an open mouth with
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

4. In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the
drawing name (often a letter) until it changes to the swapping ‘{5 pointer.

5. Pullthe cursor to see the list of mouth shape names and choose the one you want. The current

drawing automatically changes to the new selection.

How to animate lip-sync using the Library view

1. Inthe Playback toolbar, click the %S Sound Scrubbing button.
2. Inthe Timeline view, drag the red playhead along the waveform of your sound layer.

3. When you reach a frame where a mouth position should go, for example, an open mouth with
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

4. Inthe Drawing Substitution window of the Library view, drag the slider to choose a mouth shape.
The current drawing is swapped for the one in the preview window.
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When creating a scene, rigging a character or once your animation is finished, you can add effects such as blurs,
glows, shadows, colour filters and transparency filters and to enhance your project's quality. Effects change the
way layers or groups of layers are rendered in your scene.

About Effects

Effects are special types of layers that you can add to your scene's structure. For an effect layer to work, it must
be connected as the child of a drawing, a group, or another effect. Effects only alter the element that they are
connected to. This gives you flexibility in deciding which elements of your scene are affected by an effect.

Some effects need to be linked to another layer, referred to as a matte layer, which is used to define the area
they should affect. A good example of this is the Tone effect, which is used to add a shadow of a given shape to
a layer. Alone, the Tone effect has noimpact on the drawing it is connected to. Once combined with a matte
layer, the Tone effect will use the matte's shape to apply a shadow to the drawing. Even if the matte's shape
bleeds outside of the drawing's outlines, the shadow will only be applied within the drawing's outlines.
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A matte layer is simply a regular drawing layer that is connected to an effect as its matte. The effect takes the
shape of the drawing in the matte layer to determine the area of the drawing it affects. The colours and details
in the matte layer are ignored by the effect, only its shape is taken in account.

In the Timeline view, an effect must be rigged as the child of the drawing layer or group it is meant to affect.

If the effect can use a matte layer, it will have a Matte parameter when you expand its parameters list. You can
drag and drop the layer you want to use a matte for your effect onto the Matte parameter of your effect to link
them.

If the effect can use a matte layer, it will have a matte port on its left to which the matte layer can be connected.

Once your effect is connected, you can adjust its parameters by selecting it, then adjusting its parameters using
the Layer Properties view. You can also double-click on the layer to open its Layer Properties dialog. If desired,
you can even animate the parameters of your effect by converting their values to functions.

Adding an Effect

In Harmony, you can add effects by selecting the layer or group you wish to add an effect to, then adding the
effect through the Timeline view's Add Layers menu. Then, you can achieve the intended effect by adjusting its
parameters in the Layers Properties view, and connecting it to a matte layer if applicable.

How to add an effect

1. Inthe Timeline view, select the layer on which you want to add an effect.
2. Doone of the following:
o Inthe top menu, select Insert > Effects and select the effect you want to add.

« Inthe Layerstoolbar above the layer list, click the <4, Add Layers button, select
Effects then select the effect you want to add.

o Right-click on the layer, then select Insert > Effects and select the effect you want to
add.

The effect appearsin the Timeline view, underneath the selected layer.
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3. Inthe Camera view, click the Render View button to see the scene's rendered current frame and

effect.

NOTE

By default, your background will appear pitch black. To remedy this, you can add
a Colour Card layer at the bottom of your layers list, and tweak its colour in the

Layer Properties view.

4. Inthe Timeline view, double-click on the effect layer to open the Layer Properties window. You can
also select the effect layer and see its properties in the Layer Properties view.

The Layer Properties view opens, displaying the parameters available for the selected effect.

5. Inthe Layer Properties view, adjust the effect’s parameters as needed.

NOTE
Each time you make a change, the Camera view will need to refresh the rendered
image, which may cause a little delay before you can observe its effect.

6. Most effects will not play back in real time in Harmony. To play back your scene with the final effects,
in the Playback toolbar, click the & Render and Play button in the Timeline view toolbar.

NOTE

Once you have set the parameters for the effect, you can store it in the Library view as a
template, so you can quickly reuse it without resetting the parameters again—see How to

Create and Use Templates on page 154.

Adding an Effect with a Matte

The following tutorial demonstrates how to use the Cutter effect with a matte. Several effects in Harmony use

mattes to determine the area of the image they affect.
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The Cutter effect cuts out a portion of an image. To do this, it needs to be connected to the drawing it is
intended to cut as well as to a matte layer. The cutter will take the shape of the drawing in the matte layer and
cut this shape out of the drawing layer. This is especially useful if you want to make a character disappear
between a background element, or if you want to cut out a hole in the middle of a character.

Like all effects that use a matte, the Cutter's effect has an Inverted parameter, which is disabled by default.
When enabled, the Cutter will have the reverse effect: Instead of cutting the matte's shape out of the drawing,
it will cut everything outside of the matte's shape out of the drawing, leaving only the parts of the drawing that
are covered by the matte.

How to use the Cutter effect

1. Select a drawing layer.

2. Doone of the following:

« Inthe toolbar above the layer list in the Timeline view, click on the 4, Add Layer button and
select Effects > Cutter.

o Right-click on the layer and select Insert > Effects > Cutter.

The Cutter effect is created as a child of the selected layer.

1. In the toolbar above the layer list in Timeline view, click on %% Add Drawing Layer .

2. Inthe Add Drawing Layer dialog, give your new drawing layer a relevant name for a matte layer,
such as "Matte-Drawing", then click on Add and Close.
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3. Inthe new matte drawing layer, draw a matte for your effect. Your matte can be a simple shape, but
should be filled with a colour, as only parts of the matte that are opaque will be taken in account.

Drawing

NOTE

Mattes can also have semi-transparent areas. Areas of the drawing that are covered by
semi-transparent areas of the matte are partially affected by the effect.

4. Inthe Timeline view, click on the Expand + button right of the Cutter layer.

5. Drag and drop your matte layer next to your Cutter layer's Matte field, under the Parameters
column.
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The matte drawing layer becomes the Cutter layer's matte. At this point, areas of the artwork that
intersect with the artwork in the matte drawing layer are hidden.

6. If youwant toinvert the Cutter's effect, so that the artwork that intersects with the artwork in the
matte layer is visible and that everything else is hidden, double-click on the Cutter layer (but not on
its name) to open its Layer Properties dialog, then check the Inverted parameter.

Two other examples of effects that work with mattes are the Tone and Highlight effects. The Tone effect
applies a shadow to its drawing based on its matte, and the Highlight effect applies a highlight to a drawing
based on a matte. These effects are not applied outside of the drawings they are connected to, so you can

simply draw your character's highlights and shadow into your matte layers without worrying about drawing
outside of their outline.
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Adding these effects to a drawing works exactly the same way as adding a cutter to a drawing, except that
they have extra parameters to configure the colour, intensity and rendering of the effect.

Animating an Effect

You may need to animate some effects to obtain the expected results. For example, you may want the radius of
a Glow effect to slowly increase and decrease to make it pulsate throughout a scene, or you may want the
transparency of a Transparency effect to increase from 0% to 100% to make a drawing vanish.

Almost all numerical parameters in an effect can be attached to a function. A function allows you to set a
parameter to different values at different pointsin the scene by adding keyframes to it, and setting each
keyframes to a specific value. Between keyframes, the value of the parameter will progress from the value of the
previous keyframe to the value of the next keyframe. Drawing layers are animated by having their coordinates
associated to functions. Likewise, effects can be animated by associating their parameters to functions.

Some effect parameters can be animated directly in the Timeline view, but not all. When you expand an effect's
parameters in the Timeline view, some of its parameters may be hidden to avoid cluttering the Timeline view.
You can animate those parameters from the Layer Properties view or the Layer Properties dialog, which display
all of a layer's parameters.

How to animate an effect parameter in the Timeline view

1. Inthe Timeline view, locate the effect you want to animate, and click on the 4 Expand button right
of its name.

o+ [+ H+ T

2. Intheright area of the Timeline view, in the same row as the parameter you want to animate, select
the frame where you want to create the first animation keyframe for the effect.
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3. Create a keyframe by doing one of the following:

« In the Timeline toolbar, click the ¢ Add Keyframe button.

o Right-click and select Add Keyframe.

e PressF6.

4. In the left area of the Timeline view, under the Parameters column, adjust the value of the parameter
for this keyframe by doing one of the following:

o Click and hold on the value of the parameter, then drag it towards the left to reduce its value,
or towards the right to increase its value.

ro=al

o Click on the value of the parameter. A text field will appear. Type in the new value of the
parameter, then press Enter.

5. Inthe right area of the Timeline view, click on the frame where you want to create the second
animation keyframe for the effect.

6. Create the second keyframe for your effect's animation by doing one of the following:

« Inthe Timeline toolbar, click the ¢+ Add Keyframe button.

« Right-click and select Add Keyframe.
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7. Inthe Parameters column, adjust the value of the parameter at the current keyframe.

8. Repeat the steps to create as many animation keyframe for your effect as needed.

9. To adjust the timing between the keyframes of your animation, select the first keyframe.
10. Inthe Timeline toolbar, click on the 4~ Set Ease for Multiple Parameters button.

The Set Ease for Multiple Parameters dialog appear. The function graph in this dialog will be focused
on the first o keyframe in your animation, which should have a = Bezier handle right next to it,
pointing to the right.

Second keyframe

Bezier handle

11. Click on the = Bezier handle and drag it towards the right, at any angle, to adjust the ease-in of the
animation.
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12.

13.

14.

Click on Apply/Next.

The Set Ease for Multiple Parameters dialog will focus on the second keyframe. If this is the last
keyframe in the animation, it will only have one Bezier handle, pointing towards the left. If there are
more animation keyframes after this one, it will have two Bezier handles, one pointing in each
direction.

Click on the left .= Bezier handle and drag it towards the left, at any angle, to adjust the ease-out of
the animation between the previous keyframe and the current keyframe.

If there is a = Bezier handle pointing towards the right, click on it and drag it towards the right, at
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any angle, to adjust the ease-in of the animation between the current keyframe and the next
keyframe.

15. Repeat the previous steps until the timing for your animation is adjusted throughout the entire
scene.

How to animate an effect in the Layer Properties dialog

1. Open the effect's Layer Properties by doing one of the following:

o Add the Layer Properties view to your workspace, then select the effect in the Timeline view.

o Inthe Timeline view, double-click on the effect layer, but not on its name.

2. Inthe effect's layer properties, locate the parameter that you want to animate and click on the .S

Function button to its right.

The parameter's input field will be greyed out. This is because you cannot directly edit a parameter

once it is attached to a function. The field will indicate the name of the function that was created for
it, in this format:

Name of layer: Name of function: Value at current frame

3. Click on the parameter's Function button again.
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The Bezier Editor dialog opens.

Current frame cursor

Function graph

This dialog will allow you to animate the function. The function graph at the bottom is made to
represent the values of the function throughout each frame in the scene.

4. In the function graph, click and drag on the red cursor l to move it to the frame where you want to
create your first animation keyframe.

5. Click onthe ¢r Add Keyframe button to create the first animation keyframe for the effect.

A keyframe o is created and should be visible in the function graph. If you do not see it, that is
because the function graph is not positioned to include the keyframe within its frame. To move the
function graph to view the function's keyframe, click on the ©) Reset View or @ Reset View
Vertically button.

137



Chapter 14: How to Add Effects to a Scene

6. Adjust the value of the parameter at the current frame by doing one of the following:

« Inthe Value field over the function graph, type in the desired value for the parameter.

« Inthe function graph, click and drag on the o keyframe, and move it up to increase its value,
or down to decrease it.

Y- TIP

If you want to set the keyframe to a value that is outside of the function graph's

frame, you can press the 1 key to zoom out. You can also press the 2 key to zoom
back in.

7. Click and drag on the red cursor to move it to the frame where you want to create your second
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animation keyframe.

8. Click on the Add Keyframe ¢r button to create the second animation keyframe for the effect.

9. Adjust the value of the parameter at the current frame by doing one of the following:

« Inthe Value field over the function graph, type in the desired value for the parameter.

« Inthe function graph, click and drag on the o keyframe, and move it up to increase its value,
or down to decrease it.
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10. If you want to adjust the timing of the animation between the first and second keyframes, do the
following:

« Click and drag the = Bezier handle of the first keyframe towards the right, in any direction,
to affect the ease-in of the animation.

o Click and drag the <= Bezier handle of the second keyframe towards the left, in any direction,
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to affect the ease-out of the animation.

11. Repeat these steps until you created and timed every animation keyframe required to animate your
effect.

Creating an Effect Based on an Animated Character

The following tutorial demonstrates how to combine Effects with other Harmony functionalities to easily create
a drop shadow for an animated character. By following these steps, you can create a drop shadow that will
automatically follow your character's animation, even if you change the animation afterward.

How to create a drop shadow for an animated character

1. Inthe Timeline view, select all the layers making your character's rig. If your character is under a
master peg, selecting the master peg will also work.

2. Make sure your character'srig isin a group. If it is not, right-click on your selection, then select Group
Selection.
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3. With your character selected in the Timeline view, create a Clone of your character by doing one of
the following:

« Right click on your selection, then select Clone Selected Layers: Drawings and Timing.

o Fromthe Top menu, select Edit > Clone: Drawings and Timing.

NOTE

Contrary to a duplicate, a cloned layer always has the same timing and exposure as its
origin layer, even if its origin layer is changed later. Hence, you can make changes to
your character's animation, and your cloned character's animation will automatically
update with these changes.

4. Add a Shadow effect to your group by doing one of the following.

o Inthe Timeline view's layers toolbar, click on Add Layers <+, and select Effects
> Shadow.

« Right-click on your selection, then select Insert > Effects > Shadow.

5. Inthe Timeline view, select the root layer of your character's clone.
6. Create a parent peg for your clone by doing one of the following:
o Fromthe Timeline View layers toolbar, click the Add Peg (% button.

o Press Ctrl + P (Windows/Linux) or 3§ + P (macOS).
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7. Inthe Timeline view, select your clone's parent peg.
8. In the Tools toolbar, select the Transformi.: tool.

9. Inthe Camera view, scale and skew your clone so that it looks like a drop-shadow.
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Chapter 15: How to Use Drawing Guides

When you need to draw backgrounds or objects with a lot of straight lines, square angles and perspective, you
can use Drawing Guides to assist you. Guides add a horizon line as well as vanishing points to your drawing
space, which can be moved to fit your scene's needs, and they lock your drawing tools so that they always
draw straight lines, either going from one of your vanishing points, or parallel to your guide's horizontal or

vertical axis.
Harmony supports the following types of drawing guides:

o The Square Grid guide simply helps you draw on the horizontal and vertical axes, which are relative to

the horizon line.

o The 1-Point Perspective guide helps you draw lines coming from a single vanishing point, which is in
the middle of the horizon by default. It also helps you draw along the horizontal and vertical axes. This
can help create realistic-looking backgrounds with buildings, walls and objects that are facing your

camera.

o The 2-Point Perspective guide helps you draw lines going from one of two vanishing points, which are
positioned left and right of your drawing space. This can help create realistic-looking backgrounds with
buildings, walls and objects that are at an angle from your camera.
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o The 3-Point Perspective guide helps you draw lines going from one of 3 vanishing points: Two
horizontal vanishing points positioned left and right of your drawing space, and one vertical vanishing
point positioned below or above your drawing space. This can help you draw realistic looking
backgrounds from a low or high angle. The 3-Point Perspective guide has two presets: Bird's Eye View
preset and the Worm's-Eye View, which can be used for high angle and low angle perspectives,
respectively.

In order to use a drawing guide, you must first add it to your scene's Guides list.

How to add a drawing guide to your scene

1. From the top menu, select Windows > Guides to add the Guides view to the current workspace.

2. Inthe Guides view, select the + New Guide button and choose one of the following types of
guides:

. Square Grid

o fx 1-Point Perspective

o <P+ 2-Point Perspective

« ' 3-Point Perspective (Bird’s-eye View)

. @ 3-Point Perspective (Worm’s-eye View)

The new guide appearsin the Guides view list.
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3. Toadd another guide, repeat the previous step.

How to edit a drawing guide

1. Inthe Timeline or Xsheet view, select a drawing, or select an empty cell and create a new drawing
by doing one of the following:

« Right-click on the cell and select Drawing > Create Empty Drawing.

o Press Alt + Shift + R
2. Inthe Tools toolbar, select the »” Brush, # Pencil, (- Stroke or / Line tool.
3. Inthe Guides view, select a guide to make it the active guide.

Once a guide is active, its horizon line and vanishing point(s) appear in the drawing area.

4. In the Guides view, make sure the (5 Lock Guide option is disabled. This ensures you're able to edit
the active guide.

5. In the drawing area, zoom out until all vanishing points are visible (if necessary).

6. Inthe drawing area, grab either the horizon or a vanishing point and move it to its desired location.
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When using the square grid or 1-point perspective guides, the angle of the horizon can be modified
by manipulating the horizon line itself.

When using the 2-point or 3-point perspective guides, the angle of the horizon can be modified by
manipulating one of the two vanishing points on the horizon.

When adjusting the horizon line, you can hold down Shift to snap the horizon line at every 15
degrees. This makes it easy to maintain a perfectly horizontal horizon.

NOTE

Each modification to a guide can be undone with the Undo command.
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How to draw with drawing guides

1. Inthe Timeline or Xsheet view, select a drawing, or select an empty cell and create a new drawing
by doing one of the following:

o Right-click on the cell and select Drawing > Create Empty Drawing.
e Press Alt + Shift + R
2. Inthe Tools toolbar, select the »” Brush, # Pencil, (- Stroke or / Line tool.

3. Inthe Guides view, select the guide you wish to use.

4. Inthe drawing area, draw a stroke with the current drawing tool. From the initial gesture, the tool
locks on one of the guide's axes, forcing it to draw a straight line that follows the axis.

N
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Chapter 16: How to Create a Multiplane

In live action, when the camera moves around in a scene, objects near the camera will appear to move by a
greater distance than objects far from the camera. In 2D animation, a similar effect can be achieved by creating

a multiplane.

In Harmony, you can easily set-up a multiplane by creating a background over several layers, spreading them
on the Z-axis to add depth, and then moving the camera through the resulting environment to create an
impressive perspective illusion.

In the following example, the background is made of 6 different layers, each picturing an object that is at a
different distance from the camera. On the left, you can see how each object is positioned relative to the
camera, as if you were looking at them from the side. On the right, you can see how layers are positioned
relative to each other as if you were looking at the scene from a corner. Below, you can see the scene from the

camera's point of view.
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Using the Maintain Size tool, you can easily turn a normal multi-layered background into a multiplane. This tool
allows you to move a layer closer to or further away from the camera all the while automatically adjusting the
layer's size proportionally to its distance from the camera, preserving its a apparent size from the camera's
point of view. Hence, you do not have to worry about the size and position of your layers when you design your
background.

In a new Harmony scene, draw the different elements of a background on separate layers. Then, follow the

steps below to turn your background into a multiplane.

How to set up a multiplane using the Maintain Size tool

1. Make sure the No Z Dragging option in the Animation top menu is disabled.
2. Do one of the following:
« Inthe Advanced Animation toolbar, select the £1 Maintain Size tool.
o Fromthe top menu, select Animation > Tools > Maintain Size.
o PressAlt +6.

3. Inthe Side or Top view, select one of the layers in the thumbnails section. You can also select a layer
from the Timeline view.
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The selected layer is highlighted in the Top, Side and Camera views.

Your element will move on your scene's Z-axis, but it will keep the same apparent size in the Camera
view.

You can view your multiplane from different points of view using the Perspective view.

How to view your multiplane in the Perspective view

1. Enable the Perspective view by doing one of the following:

e Click on the Add view button next to the Camera and Drawing view tabs, then
select Perspective.

o Fromthe top menu, select Windows > Perspective.

2. Torotate the Perspective view in all 3 dimensions, hold Ctrl + Shift (Windows/Linux) or 3§ + Shift
(mac0S), then click and drag.
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Chapter 17: How to Create and Use Templates

You can create a template from a layer or from cells. You can store anything available in the Timeline view as a

template.
Creating a Template

How to create a template

1. Inthe Timeline view, select some cells or layers.

You can create a template from a whole hierarchy of layers by collapsing the hierarchy and selecting
its root layer. This can be useful for creating templates based on character rigs or scene

backgrounds.

2. Inthe Library view, select a folder to store the template. By default, you will have a library named
Harmony Advanced Library , which is stored on your computer, in the Toon Boom Harmony
Advanced Library subfolder of your Documents folder.

3. Ifthe library folder is locked, right-click and select Right to Modify.

4. Drag the selection to the chosen library folder.

Library
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5. In the Rename dialog box, give the new template a name.

6. Click OK.
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To rename a template once it is created, right-click on it and select Rename.

Importing a Template

How to import a template

1. IntheLibrary view, select the template you want to import.

2. Drag the selected template to the Camera view or to the left side of the Timeline view.

If you drop the template in the Camera view, its layers will be added at the top of your layers list. If
you drop a template in the layers list in the Timeline view, it will be inserted between the layers

where you dropped it.

If your template has the same layer structure as a part of your scene, you can drop the template
directly onto the frames on the right side of the Timeline view. Instead of inserting new layers into
your scene, this will replace the drawings and keyframes in your scene with the ones from the
template. This is useful for importing pose or animation templates for characters that are already in

your scene.
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Chapter 18: How to Export a Movie

Using the Export Movie dialog, you can export your animation as a video file. By default, Harmony will export
your entire scene in its full resolution. If you prefer, you can choose to export only a specific frame range in your
scene, or to export in a smaller resolution, which can be useful if you need to save on time or disk space.

If you have specific requirements for the quality and size of your exported video files, you can use the Movie
Options dialog to configure the video and audio compression settings. If you're exporting a QuickTime movie,
you have access to all of the codecs and compression settings made available by QuickTime's interface.

How to export a movie file

1. From the top menu, select File > Export > Movie.

The Export to QuickTime Movie dialog box opens.

2. Inthe Output section, open the Video Format drop-down and select the desired format for your

movie file:
o Quick Time Movie (*.mov): Available on Windows, macOS and GNU/Linux.

o Windows Media Video (*.wmv): Available on Windows only.

NOTE

On Windows and macOS, Apple QuickTime must be installed in order to export
QuickTime movies.
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3. Click on the Browse button.
4. Inthe Save dialog that appears, browse to the location where you want to export the movie file.
5. In the File name field, type in the file name you want the movie file to have.
6. Click on Save.
7. From the Export Range section, do one of the following:
o Select Allif you want to render the entire scene.

o Select Frames if you want to render a part of your scene. Then, in the field to the right, type
in the first frame of the sequence you want to export, and in the other field, the last frame of
the sequence you want to render.

8. Open the Resolution drop-down and do one of the following:

o Select Same as Scene Resolution if you want to export a movie with the same resolution as
your scene.

o Select 3/4 of Scene Resolution, 1/2 of Scene Resolution, 1/3 of Scene Resolution or 1/4 of
Scene Resolution if you want to export a movie that is smaller than the resolution of your
scene.

o Select Custom if you want to manually set the export resolution. Then, in the Width and
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10.

11.

Height fields, type in the desired resolution for your movie, in pixels.

Click OK.
In the Export to QuickTime Movie dialog box, click OK.

A progress bar appears.

Browse to the location on your computer where you exported your movie file, and double-click on it
to view it in your video player.
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Glossary

Term

Definition

3D stereoscopic

The ability to create stereo images which, when animated and viewed through 3D active
shutter glasses or using glasses with one red and one blue lens, will appear as a three-
dimensional movie.

alpha channel

An image channel that carries transparency information. An image already has three
channels: red, green and blue (RGB). The alpha channel is the fourth channel (A). The matte,
or the transparency information, is stored in this fourth channel. An image without an alpha
channel is always opaque.

animatic | A movie with sound that is developed from the storyboard. The storyboard panel is exposed
for the duration of the scene and at times, the characters are placed on a trajectory to indicate
motion. The camera moves are also animated. The animatic is used to determine the rhythm
of a project and provides a good overview of the project before beginning production.
animation | A simulation of movement created by displaying a series of pictures or frames.
anime | An animation style known for its sinister and dark feel; popular in Japan.
arc | Action rarely occurs in a straight-forward manner; rather it typically unfolds in what

storytellers refer to as an arc. The purpose of a story arc is to move a character or situation
from one state or scenario to the next.

aspect ratio

The relationship between the width and height dimensions for any scene, frame or film
format. Television ratio is 4:3 and widescreen ratio is 16:9.

auto-feed

An automated method of feeding drawings into a scanner in which multiple drawings are
stacked into a sheet feeder. When the scanner is activated, the drawings are scanned
consecutively, without further user intervention.

automatic lip-sync
detection

Automatically mapping drawings in an element to the mouth chart generated for a sound.
This can save time when lip-syncing a voice track.

axis

An imaginary line around which an object rotates.
For 2D graphics, there are two axes: X (horizontal and Y (vertical).
For 3D graphics, there are three axes: X (horizontal, Y (vertical) and Z (depth).

In animations that constantly rotate, the axis element specifies what axis the object rotates
around. A negative number causes an animation to rotate counter clockwise whereas a
positive number causes an animation to rotate clockwise.

background

The part of a scene that is farthest to the rear. The background is the artwork, or decor,
against which the animation takes place.

Bézier

A method of defining curved lines invented by French mathematician Pierre Bézier. A Bézier
curve is a mathematical or parametric curve. Bézier curves use at least three points to define a
curve.

bitmap

An image composed of pixels with a single resolution (size). If it is enlarged too much, it will
lose definition and individual pixels will begin to appear. This is known as pixelation.
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Term | Definition
Bitmap image files are defined as a standard rectangular mesh of individual pixels. Each
individual pixel contains a value that represents a specific colour.
breakdown | In cut-out animation, breakdown is the action of breaking a character into pieces to create a

puppet with articulations. To break down a character, the artist cuts parts, such as the hands
and arms, from the character's model and pastes them in separate layers. Next, the joints are
fixed and the pivots set.

In traditional animation, a breakdown is an animation pose generally found between two key
poses. The key poses are the main poses in an animation and the breakdowns are secondary
poses, ones that help describe the motion and the rotation curve (usually referred to as an
arc).

camera shake

Camera shake occurs in a scene when the camera moves slightly and quickly in several
directions. This gives the impression of an impact, vibration or, for example, bumps on the

road.
caption | A textfield containing dialogue, effects, sound or slugging information in a storyboard.
cel | Intraditional animation, a cel (also known as celluloid) is a transparent sheet on which the

animation is inked and painted before being sent to the camera. The picture's outline is
drawn on the front of the cel and then coloured along the back.

character design

Each character in an animated film is drawn from multiple angles in poster-style format,
called a model sheet, which serves as a reference for the animators.

chromatic aberration

In optics, chromatic aberration (CA), achromatism or chromatic distortion, is a type of
distortion in which there is a failure of a lens to focus all colours to the same convergence
point.

clean up

After rough drawings have been tested and approved, all the noise in the image (excess
lines, notes, etc.) is removed to create final drawings which can be inked, painted and shot.
The clean up process refers to either tracing a clean line over a rough drawing to achieve the
final version or removing dirt and extra lines left by the scanning process.

CMYK

Acronym for Cyan, Magenta, Yellow, Black. These colours are the standard model used in a
process called offset printing.

colour card

A colour card is a card containing one solid colour that is the same size as the camera. The
colour card fills the background with a solid colour when there is no background image
included.

colour model

The official colour design that must be used to paint the animation. A model is the definitive
character, prop or location design that each artist must follow for the production.

colour wheel

A display of the colour spectrum in the form of a circle.

compositing

Compositing is the action of incorporating all of a scene's elements to create the final result
prior to rendering. For example, the compositing artist will import all the animation
sequences, background, overlays and underlays in the scene and position them correctly.
The artist will then set the camera frame and animate it, if needed. Finally, the animator will
create all the computer-generated effects for the project.

cross dissolve

An effect used to fade two scenes, one into the other.
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cut

A direct transition between two scenes. When a cut is used, there are no transition effects
inserted to pass from one scene to the next. The first scene ends and the second one starts
immediately.

cut-out animation

The process known as cut-out animation is the action of animating characters made out of
several pieces by moving them around frame by frame. Cut-out animation can either be
computer generated or done traditionally using paper.

cycle | A group of images that together make up an action, such as walking. A cycle is an action
repeated as a loop over a period of time. It can be a series of animated drawings or
keyframes.
dialogue | The text spoken by a character in a movie or animation.
dope sheet | Used by animators, directors and other members of a crew to track the sequence and timing
of images, dialogue, sound effects, sound tracks and camera moves. Also known as an
exposure sheet.
doping | To assign a particular drawing to a range of frames.

double bounce walk

In the key frames and passing positions in a double bounce walk, the body is lower than a
reference line drawn in the upright position. During the in-betweens, the body is above this
line giving the appearance of a bounce.

DPI | Dots perinch is the standard measure of resolution for computerized printers. It is
sometimes applied to screens, in which case it should more accurately be referred to as
pixels per inch. Either way, the dot is the smallest discrete element making up the image.

ease | In animation, the ease, also known as velocity, is the acceleration and deceleration of a
motion. It can be a motion created by a function curve, or a series of animated drawings.
Other common terms for ease-in and ease-out are slow-in and slow-out.
ease-in | Gradual acceleration in the action. Also known as slow-in.
ease-out | Gradual deceleration in the action. Also known as slow-out.

establishing shot

A scene in which the viewer can see the whole area in which a sequence is happening. For
example, if a child is playing on the ground in front of his house, the establishing shot would
be a scene where the viewer can see the house, the ground, a part of the street and the
buildings around the central point of action. This helps the viewer understand the story
location and scene orientation.

exposure

In animation, an exposure is the number of cels on which a drawing appears in the scene.
For a drawing to appear longer, the exposure must be extended over a greater number of
cels.

exposure sheet

A sheet with several vertical columns and horizontal frames used to indicate a scene's
timing. Each column represents a scene layer. The drawing numbers in each column are
indicated and repeated over the particular amount of frames they need to appear.

The exposure sheet is used by animators, directors and other members of a crew to track the
sequence and timing of images, dialogue, sound effects, sound tracks and camera moves.
Also known as a dope sheet.
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fade in/fade out

Fade in or fade out is a transition effect used to open or close a sequence. A fade in occurs
when the first scene appears progressively, from complete transparency to its complete
opacity. A fade out occurs when the last scene progressively disappears, going from
complete opacity to complete transparency.

fast-in | Dramatic acceleration at the start of the action.
fast-out | Dramatic acceleration at the end of the action.
field | A measurement unit used to calculate motion, registration and camera positioning. A
standard animation scene will vary between 6 to 12 fields.
field chart | A guide containing all the field units that animation and layout artists use to determine a
scene size or camera motion.
film-1.33 | A resolution that is ideal for the widescreen film format that conforms to the standard 4:3
pixel aspect ratio.
film-1.66 | A resolution thatis ideal for the widescreen film format that conforms to the 16:9 pixel
aspect ratio. (The pixels are wider than they are high).
flipping | In traditional animation, flipping is the action of going through the drawings of an animation

sequence very quickly in order to see the animation in motion. Flipping can also be the action
of creating a mirror transformation of an object.

follow-through

The secondary motion caused by the main action. For example, a character wearing a cloak is
running. The main action is the body running. This will cause the cloak to follow the motion,
although it will not move at the same time, but react a few frames later and follow the main
motion curve.

forward kinematics

Forward kinematics is a feature used to animate principally 3D characters and cut-out
puppets with hierarchy. It is used to animate a puppet from one of parent parts, such as a
shoulder, and make the rest of the arm move with it as a single piece.

frame

An animation frame is a single photographic image in a movie. In traditional animation, the
North American standard generally contains 24 frames per second, while in Europe the
standard is 25 frames per second.

frame rate

The frame rate is the speed at which the frames are played. They are generally calculated by
frame per second. For example, a scene could be played back at 12, 24, 25, 30 or 60 frames
per second or any other number.

This is the measurement of the frequency (rate) at which an imaging device produces unique
consecutive images, called frames. The term applies equally to computer graphics, video
cameras, film cameras, and motion capture systems.

Frame rate is most often expressed in frames per second (fps) and in progressive-scan
monitors as hertz (Hz).

function

A computer-generated motion, trajectory or path on which elements, other trajectories and
effects parameters can be attached. The function can be controlled by adding keyframes and
control points on the function curve.

gamut

The range of colours that a particular device can represent.
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HDTV | Acronym for High Definition Television which delivers a higher quality image than standard
television because it has a greater number of lines of resolution. To take advantage of the
superior quality and make full use of your resolution setting, the output device must be
compatible with HDTV technology.
hold | A frame in the animation in which the character maintains its position without moving. A
hold can be created between any two keyframes.
HSV | Hue, Saturation, Value. A method of defining colours in terms of hue (tint), saturation
(shade) and value (tone or luminance).
in-between | The drawings that exist between the key poses. These are drawn to create fluid transitions
between poses.
ink and paint | The ink and paint process is the action of painting the empty zones and colouring the lines

on the final animation drawings, while following a colour model.

interpolation

The computer-generated motion created between two keyframes. You have the choice to
create interpolation, or not, between your keyframes.

inverse kinematics (IK)

A feature used mainly to animate 3D characters and cut-out puppets with hierarchy. Inverse
kinematics will animate a puppet from one of the extremities, such as a hand, and make the
rest of the body follow naturally.

jump cut | A jerky cut between two scenes. Typically, a jump cutis not visually pleasing. It is generally
caused by one scene ending, and a second one starting, with a similar image. The lack of
difference causes the eye to see a little jump between the two scenes.

key pose | Important positions in the action defining the starting and ending points of any smooth

transition. Keys, or key poses, are the main drawings in an animation sequence describing
the motion. For example, if an arm is waving, the keys will be of the arm at one extremity of
the wave motion and the other extremity. By flipping those drawings, the animator can see
the skeleton of the motion without having all the drawings.

keyboard shortcuts

One or more keyboard keys which, when used, cause an operation to be performed.

keyframe | Important positions in the action defining the starting and ending points of any action. A
keyframe is a computer-generated position at a specific moment (frame) on a given
trajectory.

layer | In animation, a layeris an individual column, level or character. A scene's layers are
superimposed to form the final image.
layout | The communication step between the storyboard and the animation. It is the action of

putting the storyboard on model. That is, drawing the character by following the design in
the model pack, so the animator can start working.

The layout artist draws the background, creates the camera and field guide matching the
scene and camera motion. Lastly, the animator draws on model the main action poses.

layout and posing

The action of putting on model (at the right scale) the storyboard for the animator to start

working.

layout artist

The artist who draws the background, and creates the camera and field guide to match the
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scene and camera motion. They will draw on model the main action poses.

layout planning

Drawing of the main features of the scene used as reference when planning the animation
and executing the initial stages of it.

layout process

The communication step between the storyboard and the animation.

library | A storage area containing templates and assets that can be reused in any project or scene.
light table | A device that allows you to see other layers in transparency while you are working on a
particular layer.
line of action | The main centreline in an action pose. When drawing action poses, minding the line of
action ensures the pose is dynamic and that its silhouette fits the direction of the action.
lip-sync | The process of synchronizing a character's mouth to sounds in the dialogue sound track.

The mouth is adjusted frame-by-frame to match the sound of the dialogue and provide the
illusion that the character is speaking. Lip-sync can be used for any sound sequence, not
only speech, you could for instance have a bird chirping or a wolf howling at the moon.

low resolution

A format that is ideal for videos destined for the web, where size and fast download of a
video file take precedence over quality. A low-resolution image is one that lacks fine detail.

manual lip-sync
detection

The manual swapping of mouth position drawings to match a voice track. For this process,
both sound scrubbing (listening to a sound wave broken up frame-by-frame) and drawing
substitutions are used.

master palette

A group of colours attributed to a character or prop. The palette is used throughout the
entire production to maintain consistency in the look and to ensure that the same colours are
used throughout the production. Also known as palette.

model/colour model

The definitive character, prop or location design each artist must follow for a production. A
colour model is the official colour design that must be used to paint the animation.

morphing

A feature for creating computer-generated drawings between a source drawing and a
destination drawing. Animation created with the morphing feature can be reused in different
projects.

motion keyframe

A keyframe with computer-generated interpolation.

mouth chart

A chart based on the eight animation phonemes (A, B, C, D, E, F, G, and X, which is used to
represent silence) used for lip-sync.

multiplane

The effect of passing through multiple levels of drawings to create a sense of depth in a
shot. A multiplane is a scene in which the layers are placed at different distances from the
camera so that when the camera moves, a depth illusion occurs. With a multiplane, all the
perspective and scale is calculated automatically.

NTSC

The standard analogue television broadcasting system used in North America. NTSC
conforms to North American standards on how rectangular pixels are displayed for computer
and television screens.

nudge

A small push (left, right, up, down, forward or backward) done with the keyboard arrow keys
on a selected element. Nudging is used to move a selection very slightly and precisely.

167



Glossary

Term | Definition
onion skin | A feature that lets you see the previous and next drawings of a sequence.
overlay | A part of the scene environment, such as a chair or a bush, that is placed in front of the main
animation.
PAL | A resolution that works best with the European format for television and computer screens,

as the rectangular pixels are displayed at a different orientation.

palette/master palette

A palette or master palette is a group of colours attributed to a character or a prop. The
palette is used throughout the entire project to maintain a consistency in the look and avoid
the colour changing during the animation. Also referred to as a master palette.

palette style | A palette style is a second version of an existing palette with a slight change in the tint and
value. A palette style can be used to create the night version of a palette. It may also be called
a clone palette.
pan | To move the camera across the scene in any direction.
panel | In astoryboard, a panel is a frame in a shot. A shot can be composed of one or several
panels.
paperless | The paperless animation process is the action of animating digitally. The main paperless

animation/tradigital

animation process is to draw, frame by frame, the animation directly in the software.

passing position

When drawing a walk sequence for a character, the passing position is the point at which
one leg passes the other.

path of action

Direction that the action will follow.

peg | In traditional animation, a tool used to ensure accurate registration of action as cel layers
move. In digital animation, in which you are doing a more advanced puppet rigging, you can
use peg layers. Peg layers are trajectory layers that do not contain drawings. They are motion
paths that you can use to add path articulations. For the latter, you can also use an inverse
kinematics tool.
phoneme | A unit of sound in alanguage.
pivot | The point around which a peg or drawing rotates.
pixel | The smallest element of an image displayed on a monitor or TV screen.

Pixel, short for picture element, is a single point in a graphic image. It is a small sample of an
image, a dot, a square, or a very small section made out of smooth filtering. If you zoom in
close enough on a digital image, you will see the pixels, which look like small squares of
different colours and intensity.

pose-to-pose animation

The pose-to-pose animation process is the action of creating all the main action poses,
called key poses, and then placing the secondary poses between the keys. The secondary
poses are called breakdowns. Finally, the animator fills the gaps with the in-between
drawings to achieve a smooth animation.

rendering

The final step when animating by computer. During rendering, the computer takes each pixel
that appears on screen and processes all of the components, as well as adding motion blur
before it produces a final image. The process of calculating the final images after the
compositing process.
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resolution | The size of a scene, generally calculated in pixels. For example, the NTSC resolution is 720 x
480. The resolution should match the final output: HDTV, film-1.33, film-1.66, NTSC, PAL,
low.
RGB | Red, Green, Blue. A method of defining colour by specifying amounts of these three colour
components.
rigging | The process of attaching the various parts of a cut-out puppet.

rotary table

Equivalent to the animation disk/table, a device that allows you to rotate the workspace for
greater comfort while drawing.

rotoscoping

An animation technique in which animators trace over live-action film movement, frame by
frame, for use in animated films. The act of sketching over live-action footage to create an
animated sequence.

roughs | Rough is a common name in an animation movie for a drawing that is used as a reference but
which does not form part of the final image. A layout is a rough.
The skeleton sketch of an animation or design. Roughs mainly consist of sketch lines and
shapes, but can also contain design details.
safearea | The zone at the center of a scene's frame that is safe from being cropped by the TV frame. As
a TV frame cuts a margin off the original frame size, maintaining a safe area ensures that the
scene's main action will remain clearly visible once the film is screened on television.
scene | A shotin amovie or show. A sequence is composed of several scenes. A scene changes to
another scene by a simple cut or transition.
script | The original text containing all the movie or show information. In animation, the script
contains all of the location descriptions, dialogue, time and more. A project starts with a
script.
sequence | A series of scenes or shots forming a distinct part of the story or movie, usually connected
by unity of location or time.
shot | A scenein a movie or show. A sequence is composed of several shots. A shot changes to
another shot by a simple cut or transition.
slow-in | The gradual acceleration in the action. Also known as ease-in.
slow-out | The gradual deceleration in the action. Also known as ease-out.
slugging | To indicate the start and stop times of dialogue and relevant actions.

sound scrubbing

A process that lets you hear sound in real time while you move the playhead forward or
backward. This is very useful for finely-tuning a lip-sync.

stop-motion keyframe

A keyframe with no computer-generated interpolation.

storyboard

A visual plan of all the scenes and shots in an animation. The storyboard indicates what will
happen, when it will happen and how the objects in a scene are laid out.

straight-ahead animation

A technique in which an entire sequence is drawn from the first position to the last, in order.
There is very little planning in this methodology. Where the character ends up and how it
gets there can be a surprise for both the audience and the animator. While this approach is
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spontaneous and creative, it can create inaccurate results.
strokes | Invisible vector lines forming the drawing zones. They can be adjusted with Bézier handles.
symbol | A symbol combines animation, artwork or layers into a single object that you can control in
one layer. You can also create symbols out of each body part in your cut-out puppets.
You can place whatever you want in a symbol. You can use symbols to animate a puppet or
create reusable animations such as blinking.
tablet/pen | A device used in conjunction with, or instead of, a mouse to move a mouse pointer
(sometimes referred to as the cursor) around the computer screen.
template | An asset stored in the library that can be reused in any project. A template can be a drawing,
a series of keyframes, a sound file, a panel, a cut-out character, an effect, a trajectory, an
animation, or anything else used in the animation.
thumbnail | A very small image used as a reference or indicator.
timecode | The timing information printed on a movie clip to indicate the scene, hour, minute and
second that is currently displayed on the screen.
timeline | A horizontal representation of a scene's elements, timing and keyframes.

trace and paint

After the rough animations have gone through cleanup and a final line or pencil test, each
drawing is traced and painted for the final animation. In today's digital world, this may be
done in a variety of ways other than the traditional celluloid or acetate methods.

track breakdown

The break down of an animated film's soundtrack into individual sounds to produce the
precise frame-by-frame position of each sound.

traditional animation

A type of animation process whereby all the animation sequences are drawn by hand on
paper before scanning or inking them on cels.

trajectory

A computer-generated path or trajectory that elements can follow. The trajectory can be
controlled by control points, keyframes and velocity.

transition

An effect placed between two scenes as they pass from one to the other. Common transition
effects are cross-dissolve and wipe.

underlay

In animation, an underlay is a specific part of the decor placed behind the main animation.

vector

A vector-based image is composed of points and Bézier curves. The computer reads the
points and traces the segments, linking them to reproduce the image shape. There is no fixed
size or resolution in a vector image. The graphic can be enlarged and distorted as much as
desired and the system will simply recalculate the segments and rebuild the shapes. Vector
images are translated and displayed in pixels once the calculation is done.

velocity

In animation, the velocity, also known as ease, is the acceleration or deceleration of a motion.
This can be achieved by a function curve, or via a series of animated drawings. Other
common terms for ease-in and ease-out are slow-in and slow-out.

walk cycle

An animation depicting a character walking in place. The illusion of movement is created by
the use of background pans. To avoid animating a character walking over and over again in
every episode in a series, it is common practice to prepare walk cycles for each characterin a
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production so that they can be reused as needed.

zone | An area which can be painted with colour.
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