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Getting Started

Getting Started
Harmony is a complete animation software allowing you to create all kinds of creative animation projects. It 
comes with a very wide variety of tools and features. 

In this Getting Started Guide, you will learn about the main features and basic concepts of Harmony Premium, 
which will quickly bring you up to speed. Refer to the complete Toon Boom Harmony documentation available 
online at docs.toonboom.com to learn about all the tools and options, as well as advanced techniques.
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Chapter 1: About the Welcome Screen

Chapter 1: About the Welcome Screen
When you start Toon Boom Harmony, the Welcome screen appears. If a scene is already open, you can display 
the Welcome screen by selecting Help > Show Welcome Screen.

NOTE

If you are using Harmony Server in Database mode, the Welcome screen will not open. Instead, the 
database selector will open and allow you to open a scene from the database.

The Welcome screen allows you to:

 1. Create scenes

 2. Choose your scene resolution

 3. Manage your scene resolution presets

 4. Quickly open recently opened scenes

 5. Browse for and open a scene from your documents

 6. Watch Harmony video tutorials

 7. Open the online support page

 8. Decide to skip the Welcome screen and open Harmony directly on launch from now on
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NOTE

To display the Welcome screen later on, go to the top menu and select Help > Show Welcome 
Screen. You can enable showing the Welcome screen on launch again by unchecking the Do not 
show this window on startup option.
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Chapter 2: Creating a Scene
All scenes created via Harmony Stand Alone are independent and local to the computer. You can create or 
open a scene using the Welcome screen.

If you are using Harmony Server, you must use the Control Center application to create your scenes before you 
can open them in Harmony. Harmony Server scenes cannot be created directly in Harmony.

How to create a scene from the Welcome screen

 1. In the  Name field, type the scene’s name.

NOTE

The scene name should not exceed 23 characters and cannot contain special 
characters, such as *&^%!.

 2. To decide in which directory the scene will be created, click the Browse button next to the Location 
field.

 3. From the Camera Size menu, select a scene resolution.

 4. Click on Create Scene.

A new scene is created.

10
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Chapter 3: Introduction to the Harmony User Interface

Chapter 3: Introduction to the Harmony User 
Interface
Using Toon Boom Harmony will be significantly easier if you first become familiar with its user interface. This 
chapter gives you a basic introduction to the most important elements of the user interface. As you go through 
the ensuing chapters, you will learn more detailed information about each of these elements. 

When you start Toon Boom Harmony for the first time, the default workspace is displayed. The workspace is 
comprised of toolbars and panels, referred to as views, which allows you to create and edit your scene. The 
default workspace contains the most commonly used toolbars and views for digital animation.

How to add a view to your workspace as a tab

 1. In the top-right corner of an existing view, click the Add View  button 
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 2. Select the desired view from the list.

The view appears as a new tab in the same section of your workspace:

NOTE

Some views, such as the Camera, Perspective, Library, Model and Node views, can be opened 
in multiple instances. For example, this can be useful if you want to have two instances of the 
Camera views open, each focused on different areas of your scene, to quickly switch between 
working on these two areas. 
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How to add a view to your workspace                                      as a window                 

 1. Open the Windows menu.                     

 2. Select the view you wish to add.                     

The view will appear as a new window over Harmony's main application window.

How to dock a view window to your workspace

 1. Drag a window by its tab and do one of the following:

 l Drop the window onto other existing tabs to add it to that set of tabs.

 l Drop the window above, below or beside an existing view. When you get close to the 
edge of a view, a black rectangle with a blue background appears, indicating where 
the view will be inserted.

Views
Here is a short introduction to each of the most commonly used views in Harmony.

Camera view
The Camera view is the centre of operations in Harmony. In this view, you can draw, paint, animate, set up your 
scene, manipulate objects, open symbols and preview your animation.
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The Camera view also has a top and bottom toolbar that you can use to navigate in the view, change the 
display mode or go up your symbol hierarchy. 

 

Drawing view
In Harmony, you can draw in both the Drawing or Camera views. Although the two views are similar, there are 
some differences  when it comes to drawing.

Only the selected drawing is displayed by default in the Drawing view. You can use features, such as the light 
table to display the current drawing of all the enabled layers of your scene in washed-out colours, or the Onion 
Skin to display the previous and next drawings of the currently selected drawing layer.
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Tool Properties view
The Tool Properties view contains the most common options and operations related to the currently selected 
tool. When you select a tool from the Tools toolbar, the Tool Properties view updates.

For example, if you choose the Select  tool, the Tool Properties view will display the options and operations 
related to it, such as Snap to Contour, Apply to All Drawings, Flip Horizontal, and Flatten.
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Colour view
The Colour view is where you create colours and palettes and import existing palettes into your project. The 
Colour view is also necessary for drawing, painting and creating colour styling.

Timeline view
To set your animation timing, you will mostly work with the Timeline and Xsheet views. It's extremely useful to 
become familiar with the Timeline view, how it works, and its interface.

The Timeline view is the main view used when adjusting the timing of drawings, adding keyframes and 
ordering layers. The Timeline view displays layers, effects,  sounds, keyframe values, scene length, layer names, 
drawings, keyframes, timing, and frames.
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The Timeline view allows you to read your timing from left to right. It represents the scene’s elements in their 
simplest form. You can also see the layers and their names, as well as the drawing’s exposure. The drawing 
name is displayed when you place your pointer over the drawing’s exposure.

Xsheet view
The Xsheet view lets you read the timing vertically by displaying it in a grid, with each drawing layer 
represented by a column, each frame of your scene represented by a row, and each exposed drawing displayed 
by its name in the cells. It is meant to work like a traditional animation exposure sheet. 

Using the functions panel, you can also view the functions and keyframes of the motion paths for the selected 
column, with the value of those functions for each frame listed in the cells. 

Contrary to the Timeline view, the Xsheet view does not display pegs, effects or layer hierarchy. Hence, it is 
optimized for traditional and paperless animation, whereas the Timeline view is optimized for digital or cut-out 
animation.
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Library view
The Library view is used to store elements such as animation, drawings, backgrounds and character models so 
as to reuse in different scenes and projects. You can also use the Library view to create and store symbols, as 
well as to store and import images, sound files and 3D models. 

To reuse elements from a scene in other scenes, you must create a template so that you can import it into 
different scenes. Templates can contain anything from a single drawing to a whole scene structure. You can 
create a template by creating it in a scene, then copying the elements you want in your template into a library. 
The resulting template is structured like a mini-scene that contains only the elements you copied into it. A 
template does not have any dependencies on the scene it was originally created in. Hence, it can safely be 
imported in any other scene.

Additionally, the Library view's Drawing Substitution panel allows you to quickly change the current frame's 
exposure to one of the existing drawings in a layer. This is especially useful for animating a cut-out character's 
mouths, hands, eyelids and other such body parts which typically contain several drawings to choose from. 
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Node view
In the Node view, you can connect effects and compositing nodes to form a network, also known as a node 
system. This view is very useful for rigging puppets, creating advanced effects and having a clear view of 
complex scenes. The organization and order of the nodes determines the flow of data during the compositing 
process and how your animation elements will be composited.

Interface Navigation
Toon Boom Harmony lets you zoom in, zoom out, rotate, pan and reset views for easy navigation of the 
interface.
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The navigation commands in the table below can be used in the following views, with some exceptions:

 l Camera

 l Drawing

 l Perspective

 l Timeline

 l Xsheet

 l Node View

 l Function

 l Side and Top

 l Model

Command Action Access Methods

Zoom In Zooms in the view. 

View > Zoom In

Press 2

Roll the mouse wheel up (except in 
the Timeline and Xsheet views)

Zoom Out Zooms out the view.

View > Zoom Out

Press 1 

Roll the mouse wheel down (except 
in the Timeline and Xsheet views)

Zoom In 
or Out

Zooms in or out of the view.

Roll the middle mouse button up or 
down.

Hold down the Spacebar and the 
middle mouse button while dragging 
the mouse up or down.

Pan Moves the view horizontally or vertically.
Hold down the Spacebar and drag in 
the direction you want to pan the 
view.

Reset Pan Resets the view’s pan to its default position.
View > Reset Pan

Press Shift + N
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Reset 
View

Resets the view to its default position.
View > Reset View

Press Shift + M

Reset 
Rotation

Resets the view’s rotation to its default position.
View > Reset Rotation

Press Shift + X

Reset 
Zoom

Resets the view’s zoom to its default position. View > Reset Zoom

Rotate 
View

Rotates the view.
Press Ctrl + Alt (Windows/Linux) or 
Ctrl + ⌘  (macOS) and drag in the 
direction you want to rotate the view.

Rotate 30 
CW

Rotates the Camera view 30 degrees clockwise, like an 
animation table.

View > Rotate View CW

Rotate 30 
CCW

Rotates the Camera view 30 degrees counter-clockwise, 
like an animation table.

View > Rotate View CCW

Toggle 
Quick 
Close-up

Instantly multiplies the view's Zoom Factor by 4. For 
example, if the Camera View's Zoom Factor is at 100%, 
this will make it toggle between 400% and 100%. 

Shift + Z

Toggle 
Full 
Screen

Cycles through the following display modes:

 l Normal Full-Screen: The main application 
window becomes full screen.

 l View Full-Screen: The selected view becomes full 
screen and all other views are collapsed.

 l Normal: The main application window is restored 
to its original size and collapsed views are 
expanded.

View > Toggle Full Screen

Press Ctrl + F (Windows/Linux) or ⌘  
+ F (macOS)

Touch Interface
If you are working with a touch screen, a trackpad or a tablet that supports touch input, you can also use 
standard two-finger gestures to zoom, rotate and pan the Camera and Drawing Views. To be able to do this, 
you must first enable the Support Gestures preference.
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How to enable gesture support

 1. From the top menu, go to Edit > Preferences (Windows/Linux) or Harmony > Preferences (Mac OS 
X).

 2. Open the General tab.

 3. In the Touch Interface section, check the Support Gestures check box.

 4. Click on OK.

 5. Restart Harmony.

You can now manipulate the Camera and Drawing views by dragging two fingers on your touch 
interface.

How to use gestures

 1. In the Camera or Drawing view, press two fingers a short distance from each other.

 2. Do one of the following:

 l To pan the view, drag your two fingers in any direction, keeping both fingers at the same 
distance from each other.

 l To zoom in, drag your two fingers away from each other.
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 l To zoom out, drag your two fingers closer to each other.

 l To rotate, drag your two fingers in a curve so that they revolve in the same direction.

24
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Chapter 4: How to Draw
As soon as Toon Boom Harmony is started, you can start to draw straight away using the default drawing 
layer. 

How to draw

 1. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 2. In the Timeline or Xsheet view, click in the first cell of the drawing layer.

 3. To select a colour, click on the colour you wish to use in the Colour view. For more information on how 
to create and edit colours, see How to create or edit colour swatches on page 36.

 4. In the Drawing or Camera  view, start drawing.
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Adjusting Drawings
Harmony offers multiple ways to adjust drawings. You can undo your last stroke, erase parts of a drawing, 
move, transform or delete strokes, and tweak the points and curves of your pencil lines. 

How to undo your last stroke

 1. Do one of the following:

 l From the top menu, select Edit > Undo

 l Press Ctrl + Z (Windows/Linux) or ⌘  + Z (macOS).

How to erase

 1. In the Tools toolbar, select the Eraser  tool or press Alt + E.

 2. In the Drawing or Camera view, draw a stroke over the parts of your drawing you want to erase.

How to edit drawing strokes

 1. In the Tools toolbar, select the Select  tool or press Alt + S.

 2. In the Camera or Drawing view, select strokes  you want to edit by doing one of the following:

 l Click on a stroke to select it.

 l Hold Shift while clicking on a stroke to add it to your selection.

 l Draw a lasso around drawing strokes to select them simultaneously.
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 3. Do one of the following to edit your selection:

 l To reposition, click the selected drawing object and drag the selection to a new area.

NOTE

You can also nudge your selection using the arrow keys, and fast-nudge 
your selection by holding Shift and pressing the arrow keys.

 l To rotate, grab the selection box handle and rotate it.

 l To scale, pull or push on the top, side, bottom or corner control point. Hold down Shift 
to lock the selection’s ratio.
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 l To skew, drag sideways or up and down the sides or top and bottom segments, 
between the control points.

 l To delete, press Del (Windows/Linux) or Backspace (macOS).

How to edit lines

 1. In the Tools toolbar, select the Contour Editor  tool or press Alt + Q.

 2. In the Drawing or Camera view, click the shape, contour or pencil line you want to edit near the area 
you wish to change.

The shape or line's control points appear.
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Chapter 4: How to Draw

 3. Click on one of the points to select it. 

The point's Bezier handles appears, as well as Bezier handles for the surrounding points. 

TIP

You can select several points by drawing a lasso around the points, or by holding Shift 
while clicking on points to add them to your selection. You can use the Contour Editor to 
scale and rotate a selection of multiple points by enabling the Show Contour Editor 
Control  option in the Tool Properties view.

 4. Do one of the following:

 l To move a point or a selection of multiple points, click and drag it. 

 l To change the curve on both sides of a point, drag one of its Bezier handles.
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 l To change the curve on only one side of a point, press and hold the Alt key, then drag one of 
its Bezier handles.

 l To deform the contour, drag a part of the contour between two points.

 l To deform the curve between two points, hold the Shift key and drag the contour between 
two points.

 l To remove a point's Bezier handles and make the lines it is connected to straight, press and 
hold the Alt key and click on the point.
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 l Straight lines have no Bezier handles at their points by default. To create Bezier handles for 
these points and make their lines curved, pres and hold the Alt key, then click and hold the 
point and drag the mouse cursor away from it. A new Bezier handle will follow your mouse 
cursor until you release the mouse button. 

 l To add a control point, press Ctrl (Windows/Linux) or ⌘  (macOS) and click on the contour 
where you want the new point to be created.

 l To remove a control point, select the control point and press Del (Windows/Linux) or 
Backspace (macOS).
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Chapter 5: How to Paint

Toon Boom Harmony has some very powerful painting features to add colour to your drawings. Whereas some 
other software only allow users to work with one colour swatch at a time, painting in Harmony is done by using 
palettes containing multiple colour swatches that can be saved and reused as needed.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You 
can add as many swatches as you want. You can also rename them and modify existing ones.

When you modify the colour of an existing swatch, it automatically updates all the zones painted with this 
swatch throughout the entire scene. The colour swatch has a unique ID number that associates it with the 
painted zones. This way, you can change the look of your character at any time without having to repaint it! 

Another advantage of this system is that you can create complete palettes for different lighting situations. For 
instance, in addition to the regular palette for a character, you could have one for that character in the rain 
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using colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night 
scene. Using palettes linked to your character in this way allows you to instantly change its colouring to suit the 
mood and atmosphere of the scene without having to repaint each element.

Colour Palettes
In animation, specific colours are used to paint each part of each character. In order to maintain absolute 
consistency, a base colour palette should be created for each character, prop and effect in the production. This 
is referred to as a master palette.

Master palettes contain a colour swatch for each area to colour. Each swatch stores a colour in precise levels of 
red, green, blue and opacity (the latter which is referred to as alpha).

Using a master colour palette has many benefits, including:

 l Each character consistently retains their dedicated colours.

 l You cannot accidentally use a colour which is not in the master palette.

 l Standardization and colour consistency throughout the production.

 l Multiple artists can use the same colour palette and produce the same results.

Harmony uses palettes to hold all the colours needed to paint your elements, allowing complete control and 
consistency in the painting process. 

A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette 
and add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, tongue, 
shirt, pants, and so on.

How to create a new palette 

 1. From the Colour view menu, select Palettes > New or click the New Palette button.

The Create Palette dialog box opens.

 2. Enter the palette name according to the model. 

 3. Click OK.

The palette appears in the palette list.
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How to create or edit colour swatches

 1. If you want to create a new colour swatch, click the Add Colour  button in the Colour view. If you 
want to edit an existing colour swatch, select the colour in the Colour view.

 2. Do one of the following to edit the colour swatch:

 l From the Colour view menu, select Colours  > Edit.

 l Double-click on the colour swatch.

The Colour Picker window opens. 

 3. To set your colour, do one of the following:

 l Select either Red, Green, Blue, Hue, Saturarion of Value to change the colour wheel's 
spectrum, then click on the desired colour in the colour wheel.

 l Enter the hue, saturation, value, red, green and blue values manually into their 
corresponding fields. All values range from 0 to 255. 
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NOTE

If you change a colour swatch after having drawn or painted areas of a drawing with it, all the areas 
that were painted with this colour in your vector drawings will update to the new colour. 

Painting
You can paint the closed zones of your drawings by using the Paint tool.

How to paint drawings

 1. In the Timeline or Xsheet view, select the drawing you want to paint.

 2. In the Tools toolbar, select the Paint  tool or press Alt + I.

 3. In the Colour view, select your character's palette.

 4. Select a colour from the palette.

 5. In the  Drawing or Camera view, start painting the colours on your drawing.
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NOTE

When opening a scene, the scene's palettes will not be immediately loaded into the Colour 
view. You must select a drawing first.

Closing Gaps
When painting, you may find that some areas of your drawings were not completely closed due to small gaps in 
their outlines, which prevents the Paint tool from filling the area as it only fills closed shapes. To close the zone, 
you can draw a line over the gap with the Brush or Pencil tool. However, it is also possible to close the gap by 
adding an invisible line over it, which the Paint tool will treat like an ordinary line. In Harmony, invisible lines 
used to define areas to colour are called strokes.

The Close Gap tool lets you close small gaps in a drawing's outline by instantly drawing a stroke to fill the gap. 
Contrary to the Stroke tool, you do not need to draw with precision when using the Close Gap tool. Simply 
drawing a crude stroke near the gap will automatically create a straight stroke that connects directly from one 
end of the gap to the other.

How to use the Close Gap tool

 1. Before working with strokes, it's recommended to enable the Show Strokes option so that you can 
see them in the Drawing or Camera view. You can enable the Show Strokes option by doing one of 
the following:

 l From the top menu, select  View > Show > Show Strokes

 l Press K.

 2. Do one of the following:
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 l In the Tools toolbar, select the Close Gap   tool. 

 l From the top menu, select Drawing > Drawing Tools > Close Gap.

 l Press Alt + C.

 3. In the Camera or Drawing view, trace an invisible line near to the gap to be closed. 

The gap automatically closes.

NOTE

The Paint tool also has a Close Gap option which can be enabled from the Tool Properties view. 
When enabled, Harmony will attempt to automatically find and close small gaps when you attempt 
to fill a shape that is not closed. 
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Chapter 6: How to Create Paperless Traditional 
Animation

Creating a Rough Animation
The first step to create paperless animation is the rough construction, which is the skeleton of your animation. 
You would usually start by animating the most important part of a character's action. For example, to animate a 
walk cycle, you will start with the torso motion and the legs. Secondary animation such as the head, arms and 
clothes can be added afterward.

For a satisfactory animation, start by animating the main action with quick, rough sketches, then add the 
details when you're satisfied with the movement. If you start animating all the details right away, you will lose a 
lot of time if you have to make corrections, and your animation is likely to look rigid. 

How to create a rough animation

 1. In the top row of the Timeline view, click on Show All Thumbnails  to enable Thumbnail mode. 

 2. Press Ctrl + U (Windows/Linux) or ⌘  + U (macOS) to open the Preferences dialog box. 

 3. Select the Exposure Sheet tab. 

 4. Select the Use Current Frame as Drawing Name option. When this preference is enabled, each 
new drawing will be named by the frame number they are created on.

 5. In the Tools toolbar, select the Brush  tool or press Alt + B.
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 6. In the Colour view, select a colour for the brush. It is a good idea to choose a light colour for your 
rough animation. This will make the clean up process easier as your clean dark lines will contrast 
with your light sketch lines. 

 7. In the Timeline or Xsheet view, select the cell where you want your first drawing to appear.

 8. In the Camera or Drawing view, draw the first key drawing.

As soon as you draw your first stroke, a drawing is automatically created in the cell you selected.

 9. Increase the Timeline view's zoom level until you see the thumbnails inside the cells by doing one of 
the following:

 l Drag the Timeline Zoom  slider to the right.

 l Click on the Timeline view's tab, then press 2 repeatedly. 

 l Move the mouse cursor in the Timeline view, then hold Ctrl (Windows/Linux) or ⌘  (macOS) 
and roll the mouse wheel up.
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 10. With your first cell still selected, do one of the following to mark your drawing as a key drawing. This 
will help you stay organized.

 l Enable the Mark Drawing toolbar by selecting Windows > Toolbar > Mark Drawing 
from the top menu, then click on the Mark Selected Drawings as Key  button. 

 l Enable the Xsheet toolbar by focusing on the Xsheet, then selecting Windows 
> Toolbar > Xsheet from the top menu. Then, click on the Mark as Key Drawing  
button. 

 l In the Timeline view menu, select Drawings > Mark Drawing As > Key Drawing.

 

 11. In the Timeline or Xsheet view, select the cell where your next key drawing will appear.

 12. In the Tools toolbar, click the Onion Skin  button. This will display the previous and next 
drawings in a light colour in the Camera or Drawing view, behind your current drawing, so that you 
can use them as references to draw new drawings with accuracy. This can be useful to draw 
breakdown poses between two key poses, or to add an in-between drawing between two other 
drawings.

 13. Ensure the onion skin displays your first key drawing, so that you can base your second key drawing 
on it. To do this, do one of the following:

 l In the Timeline view, drag the blue onion skin markers to extend the number of past 
and future drawings to display as onion skin.
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 l In the Camera View or Drawing View toolbar, use the Onion Skin Add One Previous 
Drawing , Onion Skin Reduce One Previous Drawing , Onion Skin Reduce One 
Next Drawing  and Onion Skin Add One Next Drawing  buttons to adjust the 
span of the onion skin frame by frame.

NOTE

When in the Drawing view, you can use the Onion Skin toolbar to make onion 
skin display only specific types of drawings, such as key drawings or 
breakdowns. Keep in mind that this does not work in the Camera view.  

 14. Create a new empty drawing by doing one of the following:

 l In the Timeline or Xsheet toolbar, click on the Create Empty Drawing  button.

 l Press Alt + Shift + R.

 15. In the Camera or Drawing view, draw your second key drawing.

 16. In the Xsheet or Timeline view, identify the drawing as a key drawing.
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 17. In the Timeline or Xsheet view, select a cell between the two key drawings. Using the onion skin 
markers, ensure the onion skin covers both your first and last drawings.

 18. Create a new empty drawing by doing one of the following:

 l In the Timeline or Xsheet toolbar, click on the Create Empty Drawing  button.

 l Press Alt + Shift + R.

 19. In the Camera or Drawing view, draw your new pose.

 20. In the Timeline or Xsheet view, select a new cell and repeat the previous steps for each new 
drawing.

NOTE

When working with overlay layers in the Camera view, you can enable the Current Drawing 
on Top  option to make the layer you're working on appear over other layers. 

Reviewing your Animation
Flipping through drawings can help see if the drawings you're working on connect well together and create 
the proper illusion of movement. You can quickly flip through your drawings using the Go to Previous Drawing 
and Go to Next Drawing keyboard shortcuts, or use the Easy Flipping toolbar.

How to flip through drawings

 1. In the Timeline or Xsheet view, select the drawing from which you wish to flip.
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 2. Do one of the following:

 l Press F to go to the previous drawing.

 l Press G to go to the next drawing.

 3. Press either shortcut repeatedly at a fast pace to flip through drawings backward or forward.

How to use the Easy Flipping toolbar

 1. Switch to the Drawing view. 

 2. In the top menu, select Windows > Toolbars > Easy Flipping to enable the Easy Flipping toolbar.

 3. In the Easy Flipping toolbar, click the Previous  or Next  button to see the previous or next 
drawing of your animation.

 4. To display drawings in the first frame after you reach the last frame of your animation, select the 
Loop option.

 5. Move the slider to the right to flip forward and to the left to flip backward through your drawings.

The further you move the slider to the left or right, the faster the drawings will flip.

 6. In the Preroll field, enter the amount of drawings to automatically flip through before and after the 
current drawing.

 7. In the FPS field, enter the speed at which you would like to automatically flip through your drawings, 
in frames per second. 

 8. Click on the Easy Flip button to automatically flip through the drawings based on the Preroll and 
FPS settings.

When your rough animation is finished, play it back to make sure it looks as expected before proceeding to the 
next step.
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How to play your animation

 1. In the Timeline view, use the Enable/Disable All  and Solo  buttons to turn off any layers you 
don't  want to see during playback.

 2. In the Timeline view, move the red playhead to the first frame of your animation and click the Start 
button on the Timeline toolbar. Then, move the playhead to the last frame of your animation and 
click the Stop button.

 3. In the Playback toolbar, click the Loop  button to enable looping during playback.

 4. In the Playback toolbar, click the Play  button to begin playback.

Cleaning Up
When your rough animation is completed, it is time to clean it up and ink it. This step is also called tracing. It 
consists of tracing solid and clean lines over the rough animation to close any open zones. This is the final 
paperless animation step before the ink and paint step. 

In traditional animation, cleaned up drawings are usually traced on a new sheet of paper with the rough 
underneath, made visible using the animation disk's light table. Likewise, in Harmony, you will need to add a 
new drawing layer on which to draw cleaned up drawings.  When you're done cleaning up, you can simply 
disable the layer containing the rough animation so that it does not appear in the final animation. This 
approach also allows you to keep the roughs and the cleaned up drawings intact and to manage them 
independently. 
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In the Camera view, you will see your rough animation while working on your clean up layer. If you prefer to 
work in the Drawing view, you can enable the light table to display  the rough animation while tracing on your 
clean up layer.

How to trace your animation in a new layer

 1. In the Timeline view, rename the layer on which you created your rough animation by double-
clicking on its name and entering its new name, for example: "Rough".

 2. In the Timeline view, add a layer by doing one of the following:

 l In the Timeline view's layers toolbar, click on the Add Drawing Layer  button 

 l Press Ctrl + R (Windows/Linux) or ⌘  + R (macOS).

The Add Drawing Layer window opens.

 2. In the Name field, type in your new layer's name, for example: "Clean-up".

 2. Set the Line Art and Colour Art options to Vector to get a vector layer or to Bitmap to have a 
bitmap layer.

 3. Click Add and Close to add a new layer and close the window.

A new drawing layer is added to the Timeline view.

 4. In the Timeline view, click the Lock  icon of the layer containing your rough animation to prevent 
the layer from being selected in the Camera view.
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 5. In the Timeline or Xsheet view, select the new layer’s cell corresponding to the first key drawing of 
your rough animation.

 6. In the Tools toolbar, select a drawing tool such as the Pencil  tool.

 7. In the Colour view, select a colour for tracing your animation. Pick a dark bold colour, such as black, to 
make sure it contrasts well with the light colour of your rough animation.

 8. In the Camera or Drawing view, start tracing the first key drawing.

NOTE

If overlay layers are in the way, you can disable them temporarily by clicking on 
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their Enable/Disable button  in the Timeline view, so that only your rough 
animation and your clean up layers are displayed.

 9. In the Timeline or Xsheet view, select the next cell corresponding to a rough drawing.

 10. In the Tools toolbar, click the Enable Onion Skin  button.

 11. Ensure onion skin displays your previous cleaned up drawing, by doing one of the following:

 l In the Timeline view, drag the blue onion skin markers to extend the number of past 
and future drawings to display as onion skin.

 l In the Camera View or Drawing View toolbar, use the Onion Skin Add One Previous 
Drawing , Onion Skin Reduce One Previous Drawing , Onion Skin Reduce One 
Next Drawing  and Onion Skin Add One Next Drawing  buttons to adjust the 
span of the onion skin frame by frame.

 12. In the Camera view, trace your next drawing.
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 13. Repeat the previous steps for each drawing.
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Chapter 7: How to Morph Drawings

Hand-drawn animation requires you to spend a lot of time tracing in-between drawings. Harmony's morphing 
feature can help speed up the process. This powerful feature automatically creates computer-generated 
drawings between your vector drawings to save time and increase productivity. You can easily modify the 
timing and velocity (ease in and ease out) of a morphing animation. 

One of the main uses of the morphing feature is effects animation. For example, animating smoke or water can 
be time-consuming because these types of effects are usually slow moving requiring a large number of closely 
placed inbetweens.

The morphing feature is used to animate similar and simple shapes such as hair or smoke. It helps you by saving 
time when you are working on tedious inbetweening and tracing tasks This, in turn, provides you with more 
time to spend on complex animation tasks such as walk cycles or acrobatic sequences.

To learn how to morph drawings, it is better to start with basic shapes such as circles and rectangles. Once you 
are more familiar with the tool, you can increase your knowledge and expertise. In a very short time you will be 
producing some remarkable effects. 

It is helpful to know the pros and cons of morphing before you start. Understanding what you can do and 
which drawing lines may be more useful or problematic will enable you to design your key drawings so they 
morph efficiently. 

NOTE

The more complex the shape is, the longer it takes to morph. If it takes more time to morph a 
drawing than to hand-draw it, then it is better to animate it instead of morphing. However, if you 
spot an occasion when you can morph your drawings, do it! It allows you to fix your timing and 
velocity in no time without having to create any extra drawings!
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How to create a basic morph

 1. In the Timeline toolbar, click the Add Drawing Layer  button to add a new layer to your project.

 2. Rename the new layer ( for example, Morphing).

 3. In the Timeline or Xsheet view, select the first cell in the layer.

 4. Do one of the following:

 l In the Tools toolbar, select the Rectangle  tool.

 l Press  Alt + 7.

 5. In the Camera or Drawing view, draw a rectangle.

NOTE

When drawing a rectangle or an ellipsis, you can hold down the Shift key to 
draw your shape with equal dimensions, so as to make a square or a circle 
instead. You can also hold down the Alt key to draw the shape from its center 
rather than from its corner.

 6. Paint your rectangle using the Paint tool.

 7. In the Xsheet or Timeline view, select the cell on which you want your morphing sequence to end.

 8. Do one of the following:
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 l In the Tools toolbar, select the Ellipse  tool.

 l Press  Alt + =.

 9. Draw and paint the ellipse with the same outline and fill colours as the rectangle.

 10. In the Xsheet or Timeline view, select the range of frames going from your first drawing to your 
second drawing, including the frames containing the drawings.

 11. Do one of the following:

 l From the top menu,  select Animation > Morphing > Create Morphing.

 l In the Xsheet or Timeline view, right-click and select Morphing > Create Morphing 

 l Press Alt + M.

Arrows going from the first key drawing to the second key drawing appear, indicating that 
computer-generated inbetweens have been created.

Adjusting the Morphing Velocity
When you look at your animation you will notice that the morphing motion is constant. To produce a less 
mechanical motion, you will probably want to create some ease in or ease out.

How to add ease in and ease out to a morph

 1. In the Tools toolbar, select the Morphing 
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 tool or press F3.

 2. In the Timeline view, click on a frame in the morphing sequence you want to adjust.

 3. In the Tool Properties view, increase and decrease the Ease In and Ease Out value to adjust the 
sequence's velocity.

Adding Morph Hints
Harmony's Morphing tool allows you to control your morphing sequence in many ways. One of those ways is to 
place hints to ensure Harmony morphs your drawings the way you intended.

Hints are points that are placed in both the source and destination drawings to associate zones and lines 
between the two drawings. They are used to fix errors in the way Harmony morphs drawings, such as a line 
that is not following the colour fill zone, or when a part of your source drawing doesn't morph into its 
corresponding part of the destination drawing. By default, Harmony will associate a corner or a point in the 
source drawing with the nearest corner or point in the destination drawing. Hence, hints quickly become 
necessary if the shape being morphed or its movement is complex. 

How to add and hints

 1. In the Timeline or Xsheet view, select the source drawing of your morphing sequence.

 2. In the Tools toolbar, select the Morphing  tool or press F3.
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Use your other morphing key drawing, shown in the Drawing view's bottom right corner, as a 
reference.

 3. In the Tool Properties view, select the type of hint you want to use.

 l Select Contour Hint to correct a brush line or colour zone's contour (Contour vector).
Contour Hint points will behave similar to Pencil Hint points when used on a pencil 
line. Note that you obtain better results using the Pencil Hint point on pencil line 
rather than Contour Hint points.

 l Select Pencil Hint to correct a pencil line (Central vector).

 l Select Zone Hint to correct a colour zone morphing match.

 l Select Vanishing Point Hint to correct a vanishing shape's trajectory. 

 l Select Appearing Point Hint to correct an appearing shape's trajectory. 

 4. In the Camera or Drawing view, click on the drawing near the problematic area.
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 5. Select the hint's point and move it to its correct position.

 6. In the Timeline or Xsheet view, select your destination drawing.

 7. Find and move the corresponding hint's point to the matching part of your destination drawing. 

 8. In the Playback toolbar, press the Play  button to see the result.
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Chapter 8: How to Import Images
By default, Harmony works with vector images created within its own interface. Vector images are primarily 
composed of information about the different shapes composing the images, as well as their line and fill colours. 
This makes them easy to edit and paint, and allows us to resize them without affecting the image quality. In 
contrast, bitmap images are composed of colour information about each individual pixel composing the image. 
Hence, they are more fit for very detailed or realistic pictures, but they cannot be scaled without losing image 
quality, and can not be edited as easily as vector images. 

Typically, you would need to work with bitmap images if you must create some of your scene assets, such as 
backgrounds or props, in a different software. You can then import those bitmap image files into your Harmony 
scene.

When importing a bitmap image, you must decide how Harmony must process it. You can choose between the 
following options:

 l Keep as Original Bitmap: This imports the image exactly as is and ensures that it cannot be modified 
when working on the scene. This is useful for using backgrounds that were created in different software 
in your project.

 l Import as Toon Boom Bitmap Drawing: This imports the image as is, but allows you to edit it using 
Harmony's bitmap drawing tools.

 l Import as Toon Boom Vector Drawing: Converts a bitmap  into Toon Boom vector art, which can easily 
be painted and edited using Harmony's vector drawing tools. This can be useful for importing line art 
scanned or created using a different software.

How to import a bitmap image in its original format

 1. Do one of the following:

 l From the top menu, select File > Import > Images. 

 l In the File toolbar, click the Import Images  button.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > 
Images.

The Import Images dialog box opens.
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 2. In the Files section of the Import Images dialog box, click Browse to find and select one or more 
images on your computer.

 3. Add the bitmap image to a new layer by selecting the Create Layer(s) option and one of the 
following options:

 l Create Single Layer Named: Creates a new layer with the specified name and imports 
the images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename 
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this 
will create two layers, one named "a" and one named "b". Layer "a" will contain the 
two first images and "b" will contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can 
only import into layers that are compatible with your import options. For example, if 
you're importing images as vector drawings, you can only import them into vector 
drawing layers. 

 4. In the Vectorization section, make sure the Vectorize Image option is unchecked.

 5. In the Import Options section, select the Keep As Original Bitmap option.

 6. In the Alignment section, decide on the size and placement of your image within the camera frame. 
You can choose between the following options:

Parameter Description
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Fit

Adjusts the image's size to fit completely within the scene's 
field, both vertically and horizontally, making sure the entire 
image is visible. 

If the image's orientation is portrait, then it will adjust the 
image's height to fit the field's height, without affecting the 
image's aspect ratio:

If the image orientation is landscape, then it will adjust the 
image's width to fit the field's width, without affecting the 
image's aspect ratio:

Pan

This has the opposite effect to the fit parameter. The image's 
smallest dimension will be made to fit the scene frame's 
matching dimension, and the image's largest dimension will 
be adjusted proportionally, making the image fill the entire 
scene field, and bleed past its boundaries it if its aspect ratio 
does not match the field's aspect ratio. This option can be 
used to import a panning background image, also referred to 
as a pan.
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If the image's orientation is portrait, it will adjust the image's 
width to fit the field's width, without affecting its aspect ratio:

If the image's orientation is landscape, it will adjust the 
image's height to fit the field's height, without affecting its 
aspect ratio:

Project Resolution

Scales the image to fit the scene's resolution, making each 
pixel in the image take one pixel in the scene's field. For 
example, if the image's dimensions in pixels are half of the 
scene's resolution in pixels, then the image's dimensions will 
appear to be half of the scene field's dimensions. 

 7. In the Transparency section, decide how the bitmap image will be antialiased, more specifically, the 
way the pixels along the edge are blended with the other colours. You can choose between the 
following options:

Parameter Description

Premultiplied with White Individual pixels at the edge of an image are blended with 
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white.

Premultiplied with Black Pixels at the edge of an image are blended with black.

Straight 
Pixels at the edge of an image are blended with black, white 
and greys.

Clamp Colour to Alpha

Premultiplies the colour value with the alpha value. When the 
colour is clamped to the alpha, the colour value cannot be 
higher than the alpha value. It calculates the real colour value 
faster. When the RGB values are multiplied with the alpha 
value, that is to say, if you have a pixel of value R=247, 
G=188, B=29 and the alpha is 50% or the image has a 50% 
transparency, then the actual RGB values that are output 
would be half of the amounts listed above.

 8. Click OK.

NOTE

By default, bitmap images will display in low resolution in the Camera view so as to avoid 
affecting playback performance. You can also adjust the display quality of a bitmap image by 
selecting it with the Transform tool, then opening the Bitmap Image Quality dialog via View > 
Bitmap File Quality. You can also preview your bitmap image in your scene's resolution by 
activating the Render Preview  mode in the Camera view. 

Vectorizing Images
Harmony allows you to import images as vector drawings. Vector drawings can easily be painted and edited 
using Harmony's vector drawing tools. This can be useful for importing line art scanned or created using a 
different software, as you can then paint it in Harmony.

How to import a bitmap image as a Toon Boom bitmap drawing

 1. Do one of the following:

 l From the top menu, select File > Import > Images. 

 l In the File toolbar, click the Import Images  button.
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 l In the Xsheet view, right-click anywhere in the frame area and select Import > 
Images.

The Import Images dialog box opens.

 1. In the Files section of the Import Images dialog box, click Browse to select one or more images from 
your computer.

 2. Select the destination for your images:

 l Create Single Layer Named: Creates a new layer with the specified name and imports 
the images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename 
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this 
will create two layers, one named "a" and one named "b". Layer "a" will contain the 
two first images and "b" will contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can 
only import into layers that are compatible with your import options. For example, if 
you're importing images as vector drawings, you can only import them into vector 
drawing layers. 

 2. In the Alignment section, decide on the size and placement of your image within the camera 
frame. You can choose between the following options:

Parameter Description
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Vertical Fit

Adjusts the image's size so that its height matches the 
scene's height, without affecting its aspect ratio.

Horizontal Fit

Adjusts the image's size so that its width matches the 
scene's width, without affecting its aspect ratio.

Actual Size

Imports the image in its actual size, without adjusting its size 
relative to the scene's resolution. For example, if the image's 
dimensions in pixels are half of the scene's resolution in 
pixels, then the image's dimensions will appear to be half of 
the scene field's dimensions. 

 3. In the Transparency section, decide how the bitmap image will be antialiased, more specifically, the 
way the pixels along the edge are blended with the other colours. You can choose between the 
following options:

Parameter Description

Premultiplied with White Individual pixels at the edge of an image are blended with 
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white.

Premultiplied with Black Pixels at the edge of an image are blended with black.

Straight 
Pixels at the edge of an image are blended with black, white 
and greys.

 4. Click OK.

How to import and vectorize a bitmap image

 1. Do one of the following:

 l From the top menu, select File > Import > Images. 

 l In the File toolbar, click the Import Images  button.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > 
Images.

The Import Images dialog box opens.

 1. In the Files section of the Import Images dialog box, click Browse to select one or more images from 
your computer.
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 2. Select the destination for your images:

 l Create Single Layer Named: Creates a new layer with the specified name and imports 
the images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename 
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this 
will create two layers, one named "a" and one named "b". Layer "a" will contain the 
two first images and "b" will contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can 
only import into layers that are compatible with your import options. For example, if 
you're importing images as vector drawings, you can only import them into vector 
drawing layers. 

 3. In the Import Options section, select the Convert to Toon Boom Vector Drawing option.

 4. In the Vectorization section, decide whether you want to import your image in black and white or in 
greyscale. You can also click the New Preset  button to create a custom vectorization parameter 
preset.

‣ Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based 
drawing. The outlines of your drawings will be painted with the Vectorized Line colour swatch of 
your scene's colour palette.

‣ Grey: Vectorizes your image as a mix of vector contour and greyscale bitmap filling. Lines keep 
the texture from the scan, and the white of the paper becomes transparent.
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NOTE

You can double-click on any of the presets at any time to open the Vectorization Parameters 
dialog box to customize your option. 

 5. Click OK.

Your vectorized images will appear in their selected destination.

NOTE

If you have bitmap images in your Library, you can drag and drop them directly into your scene as a 
quick way of importing a bitmap image. However, you will not have access to all the import options. 
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Chapter 9: How to Set Up a Scene
Setting up your scene can be compared to building a set for a television show. This is the point when you 
position each scene element such as the camera frame, the background elements and the characters.

Adding a Camera
By default, a scene does not have a camera layer. In order to be able to tweak the scene's camera angle and 
position, you must add one to your scene. Although it is possible to have several cameras in the same scene, you 
can only view your scene using one camera at a time. This can be useful if you are still working on your scene 
composition and have different camera set-ups to try out.

How to add a camera in the Timeline view or Top menu

 1. Do one of the following:

 l In the Timeline view, click the Add Layer  button and select Camera.

 l From the top menu, select Insert > Camera.

A new camera layer is added to the scene and appears in the Timeline view.

How to add a camera in the Node view

 1. In the Node Library view, select the Camera node from the Favorites or Move category.

 2. Drag the Camera node to the Node view.
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How to switch between cameras

 1. From the top menu, select Scene > Camera.

 2. Among the listed cameras, select the one you want to work with.

Positioning the Camera
The scene action occurs inside the camera frame, so it’s really important to set it up correctly. You can adjust the 
camera resolution as well as other related parameters in the Scene Settings window, accessible from the Scene 
top menu.

Note that the Camera layer is static. If you need to animate it, you must put it under a peg, which you can 
animate—see Animating the Camera on page 81.
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You can reposition your camera frame directly in the Camera view by using the Translate , Rotate and 
Scale  tools of the Advanced Animation toolbar.  Alternatively, you can set up your camera by typing its 
coordinates directly in the camera's properties. This can be useful if you've done your scene planning on paper, 
as the coordinates match the ones on a traditional animation camera grid. Hence, using this approach allows 
you to position the camera exactly where you want it to be.

How to reposition the camera frame in the Camera view

 1. In the Tools toolbar, disable the Animate  mode.

 2. Do one of the following: 

 l From the top menu, select Animation > Tools > Translate. 

 l In the Advanced Animation toolbar, click the Translate  tool.

 l Press Alt + 2.

 3. In the Camera view, click on the camera frame (thin rectangle) to select it. You can also select the 
camera layer from the Timeline or Node view.

The selected camera frame is highlighted.

 4. Drag the camera frame to a new position. 
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 5. To tilt the camera frame, do one of the following to select the Rotate tool:

 l From the top menu, select Animation > Tools > Rotate.

 l In the Advanced Animation toolbar, select the Rotate  tool.

 l Press Alt + 3.

 6. In the Camera view, drag to rotate the camera frame until it reaches the desired rotation angle.

 7. To move the camera frame closer to or further away from the scene, do one of the following to select 
the Scale tool:

 l From the top menu, select Animation > Tools > Scale.
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 l In the Advanced Animation toolbar, select the Rotate  tool.

 l Press Alt + 4.

NOTE

The Transform tool can also be used to move the camera, but not to rotate or scale it.

Positioning Objects
Setting up the scene also involves positioning the different scene elements within the camera frame.

How to pan a layer using the Transform tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, select a drawing layer. If you want to select multiple layers, hold down Shift and 
click on each layer you wish to select. 

 5. Drag the selection to a new area. 
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How to rotate a layer using the Transform tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, select a drawing layer. If you want to select multiple layers, hold down Shift and 
click on each layer you wish to select. 

 5. Place  the pointer outside of a corner of the bounding box, then click and drag to rotate.

NOTE

You can display a rotation handle on the bounding box when transforming a 
layer. In the Preferences dialog box, select the Camera tab and then select the 
Use Rotation Lever with Transformation Tools option. This preference is off by 
default.                         
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How to scale a layer using the Transform tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, select a drawing layer. If you want to select multiple layers, hold down Shift and 
click on each layer you wish to select. 

 5. Click an drag the top, side or corner control point.

NOTE

When scaling your selection, you can hold down Shift to preserve the proportions between its 
width and height.

How to skew a layer using the Transform tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, select a drawing layer. If you want to select multiple layers, hold down Shift and 
click on each layer you wish to select. 

 5. Place  the pointer on the edge of the selection's bounding box, between two control points and drag 
sideways or up and down. 
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Repositioning the Pivot
Transformations made on a drawing layer, such as rotation, scale, skew and flip, are made relative to the 
position of the drawing's pivot point. While making transformations using the Transform tool, you can drag and 
drop your selection's pivot. However, this has no permanent effect. It will only temporarily change the pivot's 
position to help you make transformations at the selected frame, but the actual pivot point of your drawing 
layer will remain the same. You can reposition a layer's pivot point permanently using the advanced animation 
tools.

How to permanently reposition the pivot point

 1. In the Advanced Animation toolbar, select the Translate , Rotate , Scale , or Skew  tool.

 2. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (macOS) to select your element. 

The pivot point appears in the Camera view.

 3. Drag the pivot point to a new position.
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NOTE

When you permanently move the pivot point of a layer that is already animated, all the 
transformations done on the layer on other keyframes will be recalculated according to the 
new pivot point's position. Therefore, your existing animation will look completely different, 
except at the current frame. It is recommended to always make sure your pivot point is at its 
ideal position before you start animating.
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Chapter 10: How to Animate Objects and the Camera
In Harmony, you can animate objects by drawing them on their individual layer, then positioning them at 
different locations on different keyframes across the timeline, creating a motion path. The same principle can be 
applied to the scene's camera, since it is a layer itself. 

Animating a Layer
You can create a motion path directly on layers (animated layers). 

You can control and define a trajectory using several different parameters, including:

 l X, Y and Z positions

 l Angle (rotation)

 l Skew

 l X and Y Scales

3D objects and 3D-enabled layers also have these extra paramaters:

 l Euler Angle or Quaternion Angle (when 3D option is enabled)

 l Z Scale (when 3D option is enabled)

Harmony keeps track of the animation by storing each parameter of each layer in their own function curve. 
When you add a keyframe to a layer, a keyframe is created on each of these functions, and transformations 
done on a layer via the Camera view are translated into coordinates which are then stored in those functions. It 
is possible to edit these functions individually using the Function view, but that is rarely necessary, as Harmony 
provides easy-to-use tools for visually controlling trajectories and timing in the Camera and Timeline views.
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How to animate a layer or a peg

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. If your layer has a parent peg and you want to animate the drawing layer directly, make sure the 
Peg Selection Mode  is disabled in the Tool Properties view.

 3. In the Tools toolbar, enable the Animate  mode. This allows the Transform tool to affect the 
position and size of a layer at the current keyframe only, whereas it would otherwise affect the 
layer's position and size throughout the whole scene. 

 4. In the Timeline view, go to the first frame.

 5. From the top menu, select Animation and make sure the Stop-Motion Keyframe option is 
unchecked. This will make it so Harmony automatically creates the animation between the 
animation keyframes you create.

 6. Select the cell where you want to create your first keyframe

 7. To create your first keyframe, do one of the following:

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe is created on the first frame of the Timeline view.
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 8. In the Camera view, select the element to animate and move it to its first position.

 9. In the Timeline view, go to the frame on which you want to set the second position.

 10. Select the cell where you want to create your second keyframe. right-click on the selection and 
select Insert Keyframe.

The second keyframe appears in the Timeline view, along with a line going from your first keyframe 
to your second keyframe. This indicates that every frame in-between will be animated by Harmony.

 11. In the Camera view, move the element to its second position.

 12. In the Timeline view, select the first frame to rewind to the beginning of your animation.

 13. In the Playback toolbar, click on the Play  button to preview your animation.
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NOTE

If your scene has 3D objects, or if you animate layers on the Z axis, you may want to preview 
your animations from the Top, Side or Perspective views  during playback. However, playback 
is disabled by default in those view. To enable them, from the top menu, select Play > Enable 
Playback > Top View, Side View or Perspective View.

Animating the Camera
A scene's camera can be manipulated and animated just like any other layer. It is listed in the Timeline view and 
you can use the same tools and selection modes to offset or animate it. However, the camera layer itself is static, 
which means it keeps the same position and angle throughout the whole scene. In order to be able to animate 
the camera, you need to connect it to a peg layer, which can be animated, and which will directly affect the 
position and angle of the camera. 

You can animate your camera movements directly in the Camera view. Alternatively, you can use the Side or 
Top views, which can be especially useful when animating a camera in a multiplane scene, where each layer is 
positioned at a different distance from the camera, or if your scene contains 3D models. 

How to open the Top and Side views

 1. Do one of the following:

 l From the top menu, select Windows > Top or Side.

 l From any view already open, click the Add View  button at the top-right corner 
and select Top or Side.

How to add a camera and its parent peg

 1. By default, new scenes do not have a camera layer. To add a camera layer, do one of the following: 

 l From the top menu, select Insert > Camera.

 l From the Layers toolbar, click the Add Layers  button and select Camera.

 l From  the Node Library view, select a Camera node and drag it to the Node view.

A new camera layer is added to the scene and appears in the Timeline view.

 2. In the Timeline view, select the Camera layer.
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 3. From the Layers toolbar, click the Add Peg  button.

A Peg layer appears directly above the Camera layer and is automatically attached to it. The new 
Peg layer takes the name of the camera layer with the suffix -P added to indicate that it is its Peg 
layer.

If the new Peg layer did not appear directly above the camera, you may have clicked elsewhere in 
the scene, which deactivated the layer on which you want to add the Peg layer. To fix this:

 l Select the Camera layer and drag and drop it under the new Peg layer. Or delete the 
misplaced Peg layer, select the Camera layer and click the Add Peg  button again.

 l From the Node Library view, select a Peg node and drag it to the Node view. Then 
connect the peg’s output port to the camera’s input port.

You can also press Ctrl + P (Windows/Linux) or  ⌘  + P (macOS) to create a peg and connect it to 
the camera, or select the Camera node and press Ctrl + P (Windows/Linux) or  ⌘  + P (macOS) to 
create a peg. 
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How to animate the camera

 1. In the Tools toolbar, enable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. On the right side of the Timeline view, on the Camera Peg layer, select  the frame at which you want 
the camera movement to start.

 4. Do one of the following to add a keyframe:

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera 
position as this keyframe.

 5. Do one of the following to move the camera:

 l In the Camera view, select the Camera, which is now be represented by a thin yellow 
rectangle with a red highlight, and move it to the desired position.
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 l In the Top or Side view, select the camera, which is now represented by a large, yellow 
V-shaped cone, and move it to the desired position.

 6. On the Timeline view, click on the cell where the camera movement will end.

 7. Do one of the following:

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe appears in that cell.

 8. Select the camera in the Camera, Top or Side view and move it to the desired position. 

 9. In the Timeline view, select the first frame to rewind to the beginning of your animation.

 10. In the Playback toolbar, click on the Play  button to preview your animation.
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Chapter 11: How to Rig a Cut-out Character
In Harmony, a character rig is basically a template based on your character's model, but in which all movable 
parts are broken down into different layers, and arranged in a hierarchy that facilitates digital animation, also 
known as cut-out animation.

To make a character rig, we must first make sure you have a character model to build on. If you have any 
drawing of a character available, import it into a new scene, then scale and position it to your liking. Otherwise, 
you can draw your character's model directly in Harmony. Once you have a model ready, we can start breaking 
it down into parts to build your rig with.

There are many techniques you can use to break down a puppet. In this section, you will learn about one of the 
most common and simplest methods. For your first character breakdown, follow these instructions to get an 
idea of the way Harmony works. Once you understand Harmony's basic functions and commands, you will be 
able to create your own techniques to satisfy the needs of your production.

Drawing the Pieces
The main breakdown technique shown here is to trace your model.

How to break down a character by tracing

 1. In the Timeline view, add a new drawing layer for each body part to separate. You can press Ctrl + R 
(Windows/Linux) or ⌘  + R (macOS).
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 2. In the  Timeline view, select the layer's first cell in which you want to draw the part.

 3. In the Tools toolbar, select the drawing tool of your choice. There are two commonly used methods 
to drawing the parts of a cut-out character model:

 l Using the Pencil tool, then smoothing your lines with the Smooth Editor tool

 l Using the Polyline tool. This method allows you to draw with great precision, but 
may take more time.

These methods ensure each part is made with as few points as possible, so that they are easy to 
manipulate, modify or redraw.

 4. In the Colour view, select a colour swatch. If you haven't created a palette for your character yet, see  
How to Paint on page 34.

 5. If you prefer working in the Drawing view, do one of the following to display the other layers in 
washed out colours:

 l In the Drawing view toolbar, lick the Light Table  button.

 l Press Shift + L.

 6. In the Camera or Drawing view, draw the new part.
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 7. If you want to close an open shape without drawing a visible outline, you can draw an invisible line 
using the Stroke  tool.

NOTE

By default, your strokes are not visible. To see the strokes in your drawing, select View > 
Show > Show Strokes from the top menu or press K.

 8. In the Tools toolbar, select the Paint or Paint Unpainted  tool to colour your drawing.

 9. In the Colour view, create the desired fill colour if it's not already in your palette, then select it.

 10. In the Camera or Drawing view, paint your drawing.

 11. In the Tools toolbar, select the Select  tool. Select your drawing and flatten the lines by clicking 
the Flatten  button in the Tool Properties view.

 12. If your lines are composed of several pencil strokes, you might want to combine them into one single 
smooth pencil line. Using the Select tool, select the pencil lines to be merged and in the Tool 
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Properties view, click the Merge Pencil Lines  button.

 13. Repeat the entire process for every body part that you wish to make animatable. 

Adding Pegs
Pegs are a special type of layer that do not contain any drawing. They are used strictly to offset and transform 
drawings that are under their hierarchy, without transforming the drawings directly.
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When rigging or setting up a scene, it is recommended to add parent pegs for each of your drawing layers. This 
allows you to keep animation keyframes and drawings on separate layers, making it easier to work on the 
position and exposure of your drawing layers independently in the Timeline view. It also makes it easier to 
create a hierarchy of which body parts can be animated together and independently. 

If you want to animate only on pegs, you can activate the Peg selection mode of the Transform tool in the Tool 
Properties view. You can also disable animating drawing layers, so that only pegs can be animated. 

NOTE

It is also possible to make a drawing layer the parent of another drawing layer. Just like the way 
animating a peg animates its children layers, animating a drawing layer with children will also 
animate its children layers. Both layers will still appear in the animation as long as they are also 
connected to your scene's composite.

How to create parent pegs for your layers in the Timeline view

 1. In the Timeline view, select all the layers.

 2. In the Timeline Layer toolbar, click the Add Peg button to add a parent peg to all selected layers.
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When creating layers or pegs in the Timeline view, your Node view may look tangled up. 

 3. In the Node view, select all the nodes and, in the  Network View toolbar, click the Order Network 
Down  button.

How to create parent pegs for your layers in the Node view

 1. From the Node view, select all the drawing layers for which you want to create pegs.

 2. Press Ctrl + Shift + P (Windows/Linux) or ⌘  + Shift + P (Mac OS X)

 3. Pegs are created, named and connected to their child drawing layers. They will not automatically 
connect if the top port of your drawing layer is already connected to another node.

 4. If the nodes are tangled,  select all the nodes and, in the  Network View toolbar, click the 
Order Network Down  button.
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Creating a Layer Hierarchy
Harmony lets you build your rig in an elaborate hierarchy, allowing you to set which parts of your rig should 
influence other limbs, and how they can move independently. For example, when rigging a simple character's 
arm, you can make the forearm layer a child of the arm layer, and the hand layer a child of the forearm layer. 
This way, if the character moves their forearm, the hand will follow, and if they move their arm, the forearm and 
hand will follow. 

When building a basic character rig, you should at least have a hierarchy for each arm and each leg. You can 
make a hierarchy going from the torso, the neck and the head, and rig the arms to the torso, and you can rig 
the legs to the hips. This would make a hierarchy like this:
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How to create a hierarchy in the Timeline view

 1. In the left area of the Timeline view, select the layer which you want to make a child layer.

 2. Drag the child and drop it over the layer which you want to make the parent layer. Make sure you 
are not dropping the child layer between two layers. 

 3. Repeat until you've created a hierarchy that rigs all of your character's parts, with a master peg at 
the root. While rigging, if you want several layers to have a common parent, but no existing part of 
your rig can serve as that parent, create a new peg and nest those layers under that peg.

NOTE

In the Timeline view, you can unparent layers by holding down Shift, dragging the selected 
parent away from the child layer and dropping it somewhere else in the list.

How to create a hierarchy in the Node view

 1. Position your nodes as if they were in a tree representing their intended hierarchy, with the highest 
nodes on top and the lowest nodes at the bottom.
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 2. Drag a cable from the output port (bottom) of a node which you want to make into a parent node.

 3. Connect the cable to the input port (top) of the node which you want to make into its child node.

 4. Repeat until you've created a hierarchy that rigs all of your character's parts, with a master peg at 
the root. While rigging, if you want several layers to have a common parent, but no existing part of 
your rig can serve as that parent, create a new peg and nest those layers under that peg.
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NOTE

In the Node view, you can unlink nodes from their parent and child by holding down the Alt 
key and moving them anywhere in the node view. This will delete the node's connections 
instantly. If the node has both a parent and a child, this will automatically connect its former 
parent to its former child.

When rigging, keep in mind that the order of the layers in the Timeline view affects the order in which they are 
rendered. Layers on top of the list will be rendered over layers at the bottom of the list. Likewise, in the Node 
view, layers that are connected to the leftmost port of a composite are rendered on top of layers connected to 
ports to the right. Should you need to change a layer's order while animating, you can nudge this layer's 
position on the Z-axis to override the layer order and force it to appear beneath or over other layers. 

How to nudge a layer on the Z-axis

 1. In the Tools toolbar, select the Transform  tool.

 2. In the Timeline, Node or Camera view, select the layer you want to nudge.

 3. If you selected the layer from the Timeline or Node view, click on the Camera view tab to set the 
focus on the Camera view.

 4. Do one of the following:

 l To nudge the layer forward, press Alt + Down Arrow.

 l To nudge the layer backward, press Alt + Up Arrow.

Master Peg
Your character rig should always have a master peg which connects to all of its parts. The master peg allows 
you to manipulate the entire rig from a single layer, without having to manipulate each individual part. This is 
useful for positioning and scaling your character relative to the scene, as well as to animate your character's 
trajectory when it has to move between areas of the scene.
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How to add a master peg in the Timeline view

 1. In the Timeline view, select the top layer.

 2. In the Timeline view, click on the Add Peg  button.

A new peg is added to the timeline as a parent of the selected layer.

 3. Name the new peg Master plus the character's name.

 4. In the Timeline view, select all the layers you want to attach to your new peg. Remember that your 
top layer is already a child of the peg, so don't include it in your selection.

 5. Drag your selection ON to the peg layer to parent all your character's pieces to the peg. If your layers 
are added above the already parented layers, move that parented layer back on top of the layer 
stack.
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How to add a master peg in the Node view

 1. In the Node view, hold Ctrl (Windows/Linux) or ⌘  (macOS) and select each node that you want to 
attach to your new peg.

 2. Do one of the following:

 l From the Node view menu, select Insert > Peg.

 l Press Ctrl + P (Windows/Linux) or  ⌘  + P (macOS).

 3. Rename the new peg Master plus the character's name. 

97

Harmony 15.0 Premium Getting Started Guide



Chapter 12: How to Animate a Cut-out Character

Chapter 12: How to Animate a Cut-out Character

Harmony provides very useful tools for animating cut-out character models. Using the Transform or the 
Inverse Kinematics tool, you can move your character's parts to make your key poses, and let Harmony create 
the in-betweens. The timing of the movement can be adjusted to make life-like motion, and the drawings for 
the character's parts can be swapped at any point in your animation, allowing you to combine movement and 
drawing changes to create frame-perfect cut-out animations.

How to create a simple cut-out animation

We will create a simple cut-out animation by making your character's first pose on the first frame, its 
second pose on a later frame, and letting Harmony interpolate them. 

 1. In the Timeline view, collapse your character using the Expand/Collapse arrow.

 2. Select the first frame of the scene.

 3. To ensure your model doesn't disappear after 1 frame, open the Extend Exposure dialog by doing 
one of the following:

 l Right-click on the first frame in the Timeline and select Extend Exposure. 

 l Press F5. 
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 4. In the Extend Exposure dialog, type in the amount of frames in your scene and confirm. This will 
make your model exposed (visible) throughout your whole scene.

 5. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame 
of every layer of the model. This ensures that when you make the second pose later, your first pose 
will not be affected. To do this do one of the following: 

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe is added on the current frame.

 6. In the Tools toolbar, select the Transform  tool or press Shift + T.

 7. In the Tools toolbar, enable the Animate  mode. This allows the Transform tool to affect the 
position and size of a layer at the current keyframe only, whereas it would otherwise affect the 
layer's position and size throughout the whole scene. 

 8. In the Camera view, select the parts to animate. The Transform tool's control box will appear around 
the selected layer. Each part of the Transform tool control can be used to make different kinds of 
transformations:

 9. Use the Transform  tool to rotate, skew, scale or translate the selection to its new position.

99

Harmony 15.0 Premium Getting Started Guide



Chapter 12: How to Animate a Cut-out Character

 10. Repeat for other parts of your character model until your first pose is complete. 

 11. In the Tools toolbar, enable the Onion Skin   feature.

 12. In the Timeline view, select the frame where you want to have your second pose.

 13. Create keyframe for your second pose by doing one of the following:

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

Your second keyframe appears, along with a line going from your first keyframe to your second 
keyframe. This indicates that every frame in-between will be interpolated by Harmony.

If no line appears, it means your first keyframe was created as a stop-motion keyframe. To fix this, do 
one of the following.

 l Right-click on the first keyframe and select Set Motion Keyframe.

 l Select the first keyframe and press Ctrl + K (Windows/Linux) or ⌘  + K (macOS)

To make sure your new keyframes are set to Motion by default, select Animation from the top menu 
and make sure the Stop-Motion Keyframe option is unchecked. 

NOTE

Each keyframe can be a Motion keyframe or a Stop-Motion keyframe. The frames 
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between two keyframes are interpolated by Harmony if the first of the two keyframes is 
a Motion keyframe. 

 14. In the Camera view, change your character's pose again.

 15. Repeat this process for all the poses you wish to add to your animation.

             How to adjust the ease of the animation         

 1. In the Timeline view, collapse your character model's hierarchy.

 2. Select one of your animation keyframes. Since your model's hierarchy is collapsed, this selects the 
keyframe on every layer simultaneously.

 3. Do one of the following:

 l In the Timeline view, right-click and select Set Ease For Multiple Parameters. 

 l In the Timeline toolbar, you can click the Set Ease For Multiple Parameters   button.

The Set Ease For Multiple Parameters dialog box opens.
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 4. In the graph, pull on the Bezier handle to adjust the velocity for all the selected functions.

 5. To apply these easing parameters to a certain type of function only, such as Rotation or Scale, in the 
Filters section, deselect the function types you do not want to affect.

 l Motion: Applies the easing parameters to the selected Position X, Position Y, Position 
Z and 3D Path functions

 l Rotation: Applies the easing parameters to the selected Angle functions.

 l Scale: Applies the easing parameters to the selected Scale functions.

 l Skew: Applies the easing parameters to the selected Skew functions.

 l Morphing: Applies the easing parameters to the selected Morphing Velocity functions. 
Note that it is applied to the Morphing Velocity function in the Layer Properties 
window, not to the basic Morphing ease in the Tool Properties view.

 l Other: Applies the easing parameters to all the other selected functions, such as all 
functions created to animate effect parameters.
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 6. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values 
are calculated in percentage.

 l In the Left Time Ratio and Right Time Ratio fields, type the percentage value 
corresponding to the length of time you want the easing to last. The value must be 
between 0% and 100%.

 l In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how 
strong you want the easing out. The value must be between 0% and 100%.

 l If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

 7. Click one of the following buttons:

 l Apply/Previous: Applies the easing parameters to the selected keyframes and then 
selects the previous keyframe in the timeline.

 l Apply: Applies the easing parameters to the selected keyframes.

 l Apply/Next: Applies the easing parameters to the selected keyframes and then 
selects the next keyframe in the timeline.

 l Close: Closes the dialog box. If you did not apply the modifications, they will be 
cancelled.

NOTE

If a range containing multiple keyframes is selected, only the first selected keyframe will be 
affected by the Seat Ease for Multiple Parameters functionality.

Navigating Layers
Since cut-out animation often involves complex models with extensive hierarchies, learning shortcuts to easily 
navigate between layers can save a lot of time. 

One very useful trick to learn is the Centre on Selection command, along with its keyboard shortcut. This 
command allows you to navigate directly to the selected layer in the Timeline or Node view. Hence, you can use 
the Camera view to visually select the layer you wish to work on, then use the Centre on Selection shortcut to 
find the layer in the Timeline or Node view, instead of going through the scene structure to locate it.

How to centre on the current selection in the Timeline view

 1. In the Timeline view, collapse all your layers. 

 2. In the Tools toolbar, select the Transform  tool.

 3. In the Camera view, select any layer.
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 4. Do one of the following:

 l Click on the Timeline view's tab to set the focus on it, then press O.

 l In the Timeline view toolbar, click the Centre on Selection button.

The Timeline view is now centred on the selected layer, and all its parents have been automatically 
expanded. 

How to centre on the current selection in the Node view

 1. In the Node view, navigate to the Top level of your node network.

 2. In the Tools toolbar, select the Transform  tool.

 3. In the Camera view, select any layer.

 4. Do one of the following: 

 l Click on the Node view's tab to set the focus on it, then press O.

 l In the Node view toolbar, click the Centre on Selection button.

The Node view is now inside the group where your layer is located, centred on the selected layer.

If you want to use the keyboard shortcut frequently, you might find that having to click on the Timeline or Node 
view tab every time is tedious. To remedy this, you can enable the Focus On Mouse Enter preference. This will 
set the focus on a view as soon as your mouse cursor enters it, instantly making all of this view's keyboard 
shortcuts functional.

How to enable the Focus On Mouse Enter preference

 1. From the top menu, go to Edit > Preferences (Windows/Linux) or Harmony > Preferences (Mac OS 
X).

 2. Open the General tab.

 3. In the Options section, check the Focus On Mouse Enter check box.

 4. Click on OK.

Keyboard shortcuts for specific views will now work as soon as your mouse cursor enters the 
intended view. 

Harmony also has commands and keyboard shortcuts to quickly change your selection from the currently 
selected layer to its parent, its child or to one of its siblings, allowing you to quickly navigate your character's 
hierarchy from one layer to one of its related layers.
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How to select the parent or child of the selected layer

 1. In the Tools toolbar, select the Transform  tool.

 2. In the Transform Tool Properties view, make sure the Peg Selection  mode  is deselected.

 3. In the Camera or Timeline view, select a layer or object attached to a hierarchy.

 4. Do one of the following:

 l Select Animation > Select Parent or press B to select the parent layer.

 l Select Animation > Select Child or press Shift + B to select the child layer. 

 l Select Animation > Select Children to select all child layers at the same time.

NOTE

When going up or down your node hierarchy, these keyboard shortcuts skip any effect node 
encountered. They will only change the selection to the next drawing or peg node found in the 
hierarchy. This is because those shortcuts are optimized for digital animation. In the Shortcuts 
tab of your preferences, you will find that these shortcuts are actually called Select Parent 
Skipping Effects and Select Child Skipping Effects. If you want to use keyboard shortcuts to 
navigate the hierarchy without skipping effect nodes, you can create custom keyboard 
shortcuts  for the Select Parent  and Select Child  commands in the Shortcuts tab of the 
Preferences dialog box. Refer to the Harmony Preferences Guide  to learn how to create custom 
keyboard shortcuts.
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How to select the siblings of the selected layer

 1. In the Timeline view, select a layer that has at least one sibling and do the following:

 l To select the previous sibling in the family, press /.

 l To select the next sibling in the family, press the question mark (?) key.
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Chapter 13: How to Use Deformers
Deformers give the ability to animate objects and parts of a character model using computer generated 
deformations. This allows you to bend or distort drawings without having to redraw them. When used in cut-
out animation, they can extend considerably the range of movements and poses a character model can pull 
without having any of its parts drawn in different poses, which can save a lot of time and make your cut-out 
animation look much more natural with little effort. 

Deformers can be used to deform a single drawing layer or a hierarchy of layers, so a single deformer can be 
used to deform anything ranging from a simple prop to a whole character rig. They can be used on both vector 
and bitmap drawings.

Deformers work by rigging them as a parent of the drawing you wish to deform, building the deformer 
structure, then animating it. This can be easily done using the Rigging  tool.

There are four types of deformers available in Harmony Premium:

 l Bone

 l Game Bone

 l Curve

 l Envelope

Bone Deformer
The Bone deformation allows you to create a bone-like structure in which each part is solid, but with 
articulations that are flexible. This is mostly useful for animating a character's limbs, such as the arms or legs, or 
other parts that can be articulated such as torsos or fingers. For example, a Bone deformation can be used to 
articulate an arm that is made of a single drawing, so that the upper arm and forearm can be moved 
independently, without having to draw the upper arm and the forearm on different layers. Harmony will 
deform the drawing to make it look articulated. The different parts of a Bone deformation can be rotated 
around their joint, extended and shortened, giving you the same capabilities as animating articulations on 
different layers, without having to worry about parts detaching, pivot points, or clipping outlines.
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Curve Deformer
The Curve deformation allows you to deform parts of a character using a vector curve. By manipulating the 
curve's points and their bezier handles, you can change the curve's direction, shape and length, and Harmony 
will deform the drawing to match the curve's shape. Curve deformations are mostly used to animate elements 
that don't have joints, such as hair bangs or facial features, or body parts with so many joints that they seem 
curved, such the torso. They can also be used to animate the limbs of characters in a rubber hose style of 
animation, where arms and legs are bent in curves. 

Envelope Deformer
The Envelope deformation allows you to deform an image using Bezier handles located all around the contour 
of the shape. Envelope deformation chains are composed of Curve deformation nodes. It is regularly used to 
deform shapes, such as hair, cloak, shoulder shape, head shape and so on. You can use the Envelope 
deformation to deform a drawing so it looks like it changes from a profile view to a front view to create head 
and character rotations using only one set of drawings.
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The main differences between the Curve and Envelope deformers is that the Envelope chain can be closed by 
connecting the last Curve deformation node to the initial Offset point. Once connected, the Offset point no 
longer repositions the entire chain, only its own control point.

NOTE

It's not recommended to use the Envelope deformations on bitmap images and textures.

Game Bone Deformer
The Game Bone deformation is very similar to the Bone deformation. It allows you to create a bone-like 
structure in which each part is solid, but with articulations that are flexible. However, it is optimized for game 
engines such as Unity. Hence, it is usually only used for game development and not in animated productions. 
Contrary to the Bone deformations, Game Bone deformations do not have Bias and Region of Influence 
properties. The articulation folds also look slightly more rounded.
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Creating Deformers
The most simple way of creating deformers is to use the Rigging  tool, available in the Deformation toolbar. 
With this tool, all you need to do to create a deformer is to select the layer you wish to deform, then place each 
point of your deformer in the Camera view.

Deformers exist in your scene as a hierarchy of deformation nodes. When you create a new deformer, the first 
point you set is the deformer's root, and each new point you create is a child of the previous point. Deformers 
are hence created in a chain, and should be created with your character's hierarchy in mind. For example, when 
you create a deformer for an arm, the root should be the shoulder joint, the second point should be the elbow 
and the third should be the wrist.

Adding several deformers to your scene is liable to make its layer structure appear heavy in the Timeline and 
Node views, as every deformation point is a layer of its own. Hence, it is recommended to have the 
Automatically create a group when creating a new deformation rig  option enabled in the Tool Properties 
view before building a deformer. This will create deformers within groups created specifically to contain their 
structure, making the resulting hierarchy appear a lot lighter. 

How to select the element on which to create a deformer 

A deformer affects all the layers under its hierarchy. When you create a new deformer using the rigging 
tool, it is automatically created as a parent of the selected layer, and will affect the selected layer and all its 
children. Hence, it's important to select the right layer before attempting to create a deformer.

For example, if you wish to create a deformer for an arm, and the arm is broken into several layers, you 
could rig the arm in a hierarchy where the upper arm is the root, the forearm is the upper arm's child and 
the hand is the forearm's child. Then, if you create your deformer on the upper arm, it will be created as a 
parent of the upper arm, and will hence affect the whole arm.
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You can also group several layers under a peg, and create your deformer with this peg selected. When you 
create a deformer on a peg, the deformer is created as a child of the peg, but as a parent of all of this peg's 
children. This is because a peg is likely to be more useful over a deformer than under. If you move layers 
that are under a deformer, they will exit the intended deformation zone, and may appear severely warped 
and distorted. Hence, it's better to create deformations under pegs as much as possible, and pegs under 
deformers should only be animated if the deformer is left untouched. Since the deformer will be created as 
a parent of all the peg's children, it will affect all the layers under the peg. 

How to create a                                    Bone                             deformation chain

 1. Make sure the right element for the creation of your deformation chain is selected.

 2. Once your element is selected, select the  Rigging tool in the Deformation toolbar

 3. In the Tool Properties view, click on the   Bone button to enable Bone mode.

 4. In the Tool Properties view, enable the Automatically create a group when creating a new 
deformation rig  option so that your deformation chains are created inside groups. Every point in 

112



a deformation chain is an individual layer, so creating deformers with this option disabled is liable to 
clutter your Timeline and Node view.

 5. Place the cursor at the root of your drawing or drawing hierarchy, click once and release. For 
example, if you're creating a deformer for a whole arm, click on the shoulder joint.

 6. Move your cursor at the location where you want your first bone to finish and your second bone to 
start, and click again. An articulation control point will automatically be inserted between each bone 
you create. 

 7. Move your cursor where you want the next articulation to be and click to create the next point. 

Observe that, as you create a new point, the previous point now has a circle around it. This is the 
radius of the articulation, which allows you to determine how much of the drawing should be part of 
the articulation. Every point in a bone deformer, except for the first and the last one, has a radius 
setting. 

 8. Click and hold the previous articulation's radius manipulator and adjust the articulation's radius so 
that it covers the limb.
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 9. Repeat this until you are finished creating the Bone chain. Make sure you build each articulation in 
the right order going from the root to the extremity.

How to create a Curve deformer 

 1. Once your element is selected, select the Rigging  tool in the Deformation toolbar.

 2. In the Tool Properties view, enable the Curve  mode.

 3. In the Tool Properties view, enable the Automatically create a group when creating a new 
deformation rig  option so that your deformation chains are created inside groups. Every point in 
a deformation chain is an individual layer, so creating deformers with this option disabled is liable to 
clutter your Timeline and Node view.

 4. Place the cursor at the root of your drawing or drawing hierarchy. For example, if you're creating a 
deformer for a whole arm, place your cursor over the shoulder joint. 

 5. Press and hold the mouse button to create the point, then drag to towards the direction where you 
want your curve to bend to set the position of this curve's bezier handle, just as you would when 
drawing a curve using the Polyline tool.

 6. Click again at the location where you want the curve to end and drag backwards to extend the 
second bezier handle.

 7. As you go, you can use your mouse cursor to reposition the existing bezier handles  as needed. You 
can hold down the Alt key if you wish to move a point's bezier handle without affecting the bezier 
on the opposite site of the point.

 8. Repeat this process until you have finished building the Curve chain.
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How to create an Envelope deformation rig

 1. Once your element is selected, select the Rigging  tool in the Deformation toolbar.

 2. In the Tool Properties view, enable the Envelope  mode.

 3. In the Tool Properties view, enable the Automatically create a group when creating a new 
deformation rig  option so that your deformation chains are created inside groups. Every point in 
a deformation chain is an individual layer, so creating deformers with this option disabled is liable to 
clutter your Timeline and Node view.

 4. Place the cursor where you want to start creating your envelope. 

 5. Press and hold the mouse button to create the point, then drag to towards the direction where you 
want your curve to bend to set the position of this curve's bezier handle, just as you would when 
drawing a curve using the Polyline tool.

 6. Working as you would when building a Curve deformer, continue adding control points around your 
shape. You can place your control points slightly outside of your contour line. 
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 7. As you go, you can use your mouse cursor to reposition the existing bezier handles  as needed. You 
can hold down the Alt key if you wish to move a point's bezier handle without affecting the bezier 
on the opposite site of the point.

 8. When you're ready to close Envelope deformer, hold down Alt and click on the first point of your 
deformation chain.

NOTE

It's not recommended to use the Envelope deformers on bitmap images and textures.

Displaying Deformers
Harmony lets you control which deformers are displayed in the Camera view independently from the current 
selection. When you create a deformation chain, its deformation controls are displayed in the Camera view. 
However, if you select an existing deformer or a layer that's connected to existing deformers, its deformation 
controls won't display right away. Likewise, deselecting a deformation chain will not hide its deformation 
controls. Before you can animate or modify an existing deformation chain, you must manually display it.
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How to display deformation controls

 1. Do one of the following:

 l In the Camera, Timeline or Node view, select one of the drawing elements linked to the 
deformation chain you want to display.

 l In the Timeline or Node view, select the deformation group or any part of the deformation 
chain you want to display.

 2. In the Deformation toolbar, click the Show the Selected Deformation Chain and Hide All Others  
button.

The selected deformation controls appear in the Camera view and all the others are hidden.

NOTE

The Show the Selected Deformation Chain and Hide All Others button will display all 
deformation chains that are in the hierarchy of the selection. For example, if the master peg of 
a character model is selected, all of its deformation chains will be displayed. Likewise, if multiple 
layers linked with different deformation chains are selected, all of their deformation chains will 
be displayed.

How to hide deformation controls

 1. Do one of the following:

 l Click in the negative space of the Camera view, Timeline view or Node view to discard 
the current selection, then click on  the Show Selected Deformation Chain and Hide All 
Others  button in the Deformation toolbar.

 l Select a layer that is not linked to any deformer, then click the Show the Selected 
Deformation Chain and Hide All Others  button in the deformation toolbar.

 l In the Camera toolbar, click the Hide All Controls  button. 

 l From the top menu, select View > Hide All Controls. 

 l Press Shift + C.

Modifying Existing Deformation Chains
As you attempt to animate a deformation, or if you need to make changes to the drawings under a deformation, 
you may need to make adjustments to the deformation chain to better fit your needs.
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How to add an articulation to an existing Bone or Game Bone deformation

 1. Select the drawing layer or the deformation chain to which you want to add an articulation.

 2. In the Deformation toolbar, click the Show the Selected Deformation Chain and Hide All Others  
button to display the deformer controls in the Camera view. This also hides all the deformer controls 
that were displayed.

 3. Select the Rigging  tool.

The deformation chain turns from green to red. A green chain indicates that you're animating the 
deformation. A red chain indicates that you're modifying the rig.

 4. Move your cursor over the bone segment, where you want to add an articulation.

 5. Hold Alt and click.

NOTE

You can only insert new articulations inside Bone and Game Bone deformations.

How to make adjustments to existing deformers 

 1. Select the drawing layer or the deformation chain for which you need to make adjustments. 

 2. In the Deformation toolbar, click the Show the Selected Deformation Chain and Hide All Others  
button to display the deformer controls in the Camera view. This also hides all the deformer controls 
that were displayed.

 3. In the Deformation toolbar, click the Rigging  tool.

The deformation chain turns from green to red. A green chain indicates that you're animating the 
deformation. A red chain indicates that you're modifying the rig.
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 4. In the Camera view, set up the deformation chain.

 l Rotate the first bone to change the angle of the chain.

 l Use the root control to reposition (offset) the entire chain.

119

Harmony 15.0 Premium Getting Started Guide



Chapter 13: How to Use Deformers

 l Use the control points to reposition the articulations. This will elongate, shorten or 
change the direction of the bone. This will also offset the subsequent points in the 
deformation chain.

 l Use the articulation's control (square) to change the size of the articulation. For quality 
purposes, it is recommended to have an articulation which fits the diameter of the part 
it controls.

 5. Repeat until all the articulations and bones of the chain are correctly aligned to the element to 
which it is linked. 

NOTE

When manipulating the articulation of a Bone or Game Bone deformer, you can hold the Alt 
key to lock the bone's angle and only shorten or elongate the bone. You can also hold the Ctrl 
(Windows/Linux) or ⌘  (macOS) key to break the articulation off its chain and make it into a 
new, separate deformer chain.
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Animating With Deformers
Just like with animating pegs and drawing layers, you can animate your deformers by creating keyframes on 
their corresponding layers in the Timeline. Animating deformers works exactly like making modifications to a 
deformer, except it requires using the Transform  tool instead of the Rigging tool. When the Transform tool 
is selected, deformation controls in the Camera view display in green, which means they are in animation mode, 
whereas when the Rigging tool is selected, they display in red, meaning they are in rigging mode.

How to animate Bone and Game Bone deformations

 1. In the Timeline view, collapse your character using the Expand/Collapse arrow.

 2. Select the first frame of the scene.

 3. To ensure your model doesn't disappear after 1 frame, open the Extend Exposure dialog by doing 
one of the following:

 l Right-click on the first frame in the Timeline and select Extend Exposure. 

 l Press F5. 

 4. In the Extend Exposure dialog, type in the amount of frames in your scene and confirm. This will 
make your model exposed (visible) throughout your whole scene.

 5. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame 
of every layer of the model. This ensures that when you make the second pose later, your first pose 
will not be affected. To do this do one of the following: 

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe is added on the current frame.
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 6. In the Tools toolbar, select the Transform  tool or press Shift + T.

 7. In the Tools toolbar, enable the Animate  mode. This allows the Transform tool to affect the 
position and size of a layer at the current keyframe only, whereas it would otherwise affect the 
layer's position and size throughout the whole scene. 

 8. Do one of the following:

 l In the Camera, Timeline or Node view, select one of the drawing elements linked to the 
deformation chain you want to display.

 l In the Timeline or Node view, select the deformation group or any part of the deformation 
chain you want to display.

 9. In the Deformation toolbar, click the Show the Selected Deformation Chain and Hide All Others  
button.

The selected deformation controls appear in the Camera view and all the others are hidden.

 10. In the Camera view, do the following:

 l Rotate the first bone to rotate the limb.

 l Rotate the subsequent bones to bend the limb.

 l Use the root control to reposition (offset) the entire chain.
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 l Use the control points to reposition the articulations. This will elongate, shorten, or 
change the direction of the bone and offset the subsequent children.

 11. In the Timeline view, go to the frame on which you want to set the next key pose. 

 12. Add a keyframe on the current frame by doing one of the following:

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

 13. Transform your deformation chain's points to make your new key pose. 

 14. Repeat the previous steps until your animation is complete. 

NOTE

When manipulating the articulation of a Bone or Game Bone deformer, you can hold the Alt 
key to lock the bone's angle and only shorten or elongate the bone. You can also hold the Ctrl 
(Windows/Linux) or ⌘  (macOS) key to break the articulation off its chain and make it into a 
new, separate deformer chain.
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How to animate Curve deformations

 1. In the Timeline view, collapse your character using the Expand/Collapse arrow.

 2. Select the first frame of the scene.

 3. To ensure your model doesn't disappear after 1 frame, open the Extend Exposure dialog by doing 
one of the following:

 l Right-click on the first frame in the Timeline and select Extend Exposure. 

 l Press F5. 

 4. In the Extend Exposure dialog, type in the amount of frames in your scene and confirm. This will 
make your model exposed (visible) throughout your whole scene.

 5. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame 
of every layer of the model. This ensures that when you make the second pose later, your first pose 
will not be affected. To do this do one of the following: 

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe is added on the current frame.

 6. In the Tools toolbar, select the Transform  tool or press Shift + T.

 7. In the Tools toolbar, enable the Animate  mode. This allows the Transform tool to affect the 
position and size of a layer at the current keyframe only, whereas it would otherwise affect the 
layer's position and size throughout the whole scene. 
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 8. Do one of the following:

 l In the Camera, Timeline or Node view, select one of the drawing elements linked to the 
deformation chain you want to display.

 l In the Timeline or Node view, select the deformation group or any part of the deformation 
chain you want to display.

 9. In the Deformation toolbar, click the Show the Selected Deformation Chain and Hide All Others  
button.

The selected deformation controls appear in the Camera view and all the others are hidden.

 10. In the Camera view, do the following:

 l Click on the centre of the deformation's root pivot and drag it around to reposition the 
entire limb.

 l Use the pivot’s square handle to rotate the entire chain.

 l Use the square control point located at the extremity of a bone to stretch or shorten 
its length.
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 l Use the curve handles to modify the shape of the curve. 

 l A point in an Curve deformation that's between two other points will have two bezier 
handles, one of each side. If you rotate one of the bezier handles, the opposite bezier 
will follow by default. If you wish to rotate one of the bezier handles independently 
from the other, do as follow:

 l Select the handle you want to move independently from the other. 

The handle’s colour turns white. 

 l Press and hold Alt. 

 l Rotate the handle.
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 l By default, transforming a point in a Curve deformation chain does not offset 
subsequent points. However, it is possible to offset a curve deformation point along 
with all its children:

 l Select the point you want to transform 

The point's colour turns white. 

 l Press and hold Ctrl (Windows/Linux) or ⌘  (macOS). 

 l Either move the deformation point or rotate one of its handles. If you 
move the deformation point, subsequent points will be offset 
horizontally and vertically. If you rotate one of its handles, subsequent 
points will rotate around the deformation point. 

How to animate Envelope deformations

 1. In the Timeline view, collapse your character using the Expand/Collapse arrow.

 2. Select the first frame of the scene.
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 3. To ensure your model doesn't disappear after 1 frame, open the Extend Exposure dialog by doing 
one of the following:

 l Right-click on the first frame in the Timeline and select Extend Exposure. 

 l Press F5. 

 4. In the Extend Exposure dialog, type in the amount of frames in your scene and confirm. This will 
make your model exposed (visible) throughout your whole scene.

 5. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame 
of every layer of the model. This ensures that when you make the second pose later, your first pose 
will not be affected. To do this do one of the following: 

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe is added on the current frame.

 6. In the Tools toolbar, select the Transform  tool or press Shift + T.

 7. In the Tools toolbar, enable the Animate  mode. This allows the Transform tool to affect the 
position and size of a layer at the current keyframe only, whereas it would otherwise affect the 
layer's position and size throughout the whole scene. 

 8. Do one of the following:

 l In the Camera, Timeline or Node view, select one of the drawing elements linked to the 
deformation chain you want to display.

 l In the Timeline or Node view, select the deformation group or any part of the deformation 
chain you want to display.

 9. In the Deformation toolbar, click the Show the Selected Deformation Chain and Hide All Others  
button.

The selected deformation controls appear in the Camera view and all the others are hidden.

 10. In the Camera view, do the following:

 l Move the control points located along the envelope to deform your drawing.                        
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 l Use the envelope's control point handles to modify the drawing`s shape.  

 l A point in an Envelope deformation that's between two other points will have two 
bezier handles, one of each side. If you rotate one of the bezier handles, the opposite 
bezier will follow by default. If you wish to rotate one of the bezier handles 
independently from the other, do as follow:

 l Select the handle you want to move independently from the other. 

The handle’s colour turns white. 

 l Press and hold Alt. 

 l Rotate the handle.
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Importing Sound
If you wish to add sound to your animation, it is recommended to edit and mix your sound files in a sound 
editing software. Having full-length pre-mixed soundtracks ensures the audio preserves its timing, mixing and 
quality should you use third party software for post-production. Another good practice is to keep your 
soundtrack separated in tracks for music, sound effects and characters to make it easier to sync your animation 
with voices and sounds. Otherwise, it is possible to clip sound effects and adjust their volume directly 
in Harmony when needed.

If you create your project in Toon Boom Storyboard Pro, you can export all of your project's scenes as separate 
Harmony scenes. The storyboard's sound track will be cut up by scene and each piece will be inserted into the 
exported scenes, allowing you to save time on splitting and importing your sound track.

Harmony can import .wav, .aiff and .mp3 audio files.

NOTE

Importing a soundtrack longer than your scene will not extend your scene's length. Sound playback 
will stop at the end of your scene's length.

How to import a sound file

 1. Do one of the following:

 l From the top menu, select File > Import > Sound.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > 
Sounds.

 l From the Xsheet menu, select File > Import > Sounds.

 l From the Timeline menu, select Import > Sounds.

The Select Sound File dialog box opens.

 2. From the Select Sound File dialog box, find and select a sound file.

The sound file  appears as a layer in the Timeline view. Its waveform is displayed in the track to help 
you visualize at which frames the sound effects in your soundtrack occur. 
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Your soundtrack also appears as a column in the Xsheet view, but will not display a waveform by 
default. If you wish, you can display a sound column's waveform by right-clicking on it, then 
selecting Sound Display > Waveform.

Automatic Lip-Sync Detection
Adding a lip-sync to your animation is essential to making your characters seem alive. However, it is also a 
particularly tedious part of the animation process. 

To solve this problem, Harmony provides an automatic lip-sync detection feature. This feature analyzes the 
content of a sound track in your scene and associates each phoneme it detects with one of the mouth shapes in 
the following mouth chart, which is a standard mouth chart in the animation industry.
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NOTE

The letters assigned to these mouth shapes are standard identifiers, they do NOT correspond to 
the sound they are meant to produce. 

This is an approximation of the English phonemes each mouth shape can be used to represent:

 l A: m, b, p, h

 l B: s, d, j, i, k, t

 l C: e, a

 l D: A, E

 l E: o

 l F: u, oo

 l G: f, ph

 l X: Silence, undetermined sound

When performing automatic lip-sync detection, Harmony does not create mouth drawings. It simply fills the 
drawing column of your character's mouth layer with the generated lip-sync, by inserting the letter associated 
with the right mouth shape into each cell of the column. Therefore, for the automatic lip-sync detection to work, 
your character's mouth layer should already contain a mouth drawing for each drawing in the mouth chart, and 
these drawings should be named by their corresponding letter. 

How to generate a sound detection for lip-sync using the Layer Properties view

 1. In the Timeline or Xsheet view, select the sound layer.

The options for that layer will appear in the Layer Properties view.

 2. In the Layer Properties, click Detect.
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Harmony analyzes the selected sound clips and assigns a lip-sync letter to each sound cell. 

 3. Click the Map button to open the Lip-Sync Mapping dialog box.

 4. From the Destination Layer menu, select the layer that contains the mouth positions for the 
character's voice track. 

NOTE

If the selected layer contains symbols, you can map the lip-sync using drawings located 
directly on the layer or use the symbol's frames. In the Symbol Layer field select Don't 
Use Any Symbol if you want to use the drawings or select the desired symbol from the 
drop-down menu.

 5. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the 
phoneme it represents. If your drawings are already named with the phoneme letters, you can skip 
this step.

 6. Click OK.

 7. In the Playback toolbar, enable the Enable Sound  option.

 8. Press the Play  button in the Playback toolbar to see and hear the results in the Camera view

If you need to make adjustments to the automatically-generated lip-sync, see Animating Lip-Sync 
Manually on page 134.
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Animating Lip-Sync Manually
You can manually create the lip-syncing for your scene  by selecting which mouth drawing should be exposed at 
each frame of your character's dialogue. For this process, you will be using the Sound Scrubbing functionality, 
which plays the part of your sound track at the current frame whenever you move your Timeline cursor, 
allowing you to identify which phonemes you should match your character's mouth to. You will also be using 
drawing substitution to change which mouth drawing is exposed at every frame.

How to animate lip-sync using the Timeline view

 1. In the Playback toolbar, enable the Sound Scrubbing   button.

 2. In the Timeline view, drag the red playhead along the sound layer waveform.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with 
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the 
drawing name (often a letter) until it changes to the swapping  pointer.

 5. Pull the cursor to see the list of mouth shape names and choose the one you want. The current 
drawing automatically changes to the new selection.

How to animate lip-sync using the Library view

 1. In the Playback toolbar, click the Sound Scrubbing   button.

 2. In the Timeline view, drag the red playhead along the waveform of your sound layer.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with 
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Drawing Substitution window of the Library view, drag the slider to choose a mouth shape. 
The current drawing is swapped for the one in the preview window.
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Chapter 15: How to Add Effects to a Scene
When creating a scene, rigging a character or once your animation is finished, you can add effects such as blurs, 
glows, shadows, colour filters and transparency filters and to enhance your project's quality. Effects change the 
way layers or groups of layers are rendered in your scene. 

About Effects
Effects are special types of nodes that you can add to your scene's structure. For an effect node to work, it must 
be connected under a drawing, a composite, another effect, or any other node that outputs an image. Effect 
nodes  alter the image information sent to their input port, and output the processed image through their 
output port. This gives you flexibility in deciding which elements of your scene are affected by an effect.

Some effects need to be linked to another layer, referred to as a matte layer, which is used to define the area 
they should affect.  A good example of this is the Tone effect, which is used to add a shadow of a given shape to 
a layer. Alone, the Tone effect has no impact on the drawing it is connected to. Once combined with a matte 
layer, the Tone effect will use the matte's shape to apply a shadow to the drawing. Even if the matte's shape 
bleeds outside of the drawing's outlines, the shadow will only be applied within the drawing's outlines. 
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A matte layer is simply a regular drawing layer that is connected to an effect as its matte. The effect takes the 
shape of the drawing in the matte layer to determine the area of the drawing it affects. The colours and details 
in the matte layer are ignored by the effect, only its shape is taken in account.

In the Node view, an effect must be connected to the drawing or composite it is meant to affect by its input 
(top) port, and its output (bottom) port must be connected to the scene's main composite.

If the effect can use a matte layer, it will have a matte port on its left to which the matte layer can be connected. 

The matte port has a Matte  icon underneath it. You can invert the matte by double-clicking on this icon, 
which will make the effect use the negative space of the matte drawing rather than the matte drawing itself as 
its matte. When an effect's matte is inverted, the Matte appears black on white instead of white on black: .

Once your effect is connected, you can adjust its parameters by selecting it, then adjusting its parameters using 
the Layer Properties view. You can also click on a node's Layer Properties  icon to open its layer properties in 
a dialog. If desired, you can even animate the parameters of your effect by converting their values to functions. 
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TIP

If you need to use the uncut version of your drawing layer anywhere else in your scene, you can 
bypass the effect it is connected to by connecting the drawing layer's output port to other input 
ports of your composite, or to other effects or composite, as needed. This will create new cables, 
leaving your layer's connection to its effect unaffected. 

Adding an Effect
In Harmony, you can add effects by dragging them from the Node Library view to the Node view and 
connecting them as an intermediary between their drawing layer and their composite. Then, you can achieve 
the intended effect by adjusting its parameters in the Layers Properties view, and connecting it to a matte or 
other types of input layers it might require. 

To add effects or other types of nodes to the Node view, you must first find them in the Node Library view. 

When you create a new project in Harmony, the default node system that appears in the Node view looks 
similar to the one below.
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Notice how layers are connected to your scene's composite. For an effect to work, it must be connected as an 
intermediary between a layer and its composite, as if it was made to filter the layer's drawing information 
before it reaches the composite. 

How to add effects in the Node view

 1. In the Node Library view, select an effect and drag it to the Node view. You can use the Search 
toolbar to find nodes quicker.

 2. For the effect to work, it must work as the intermediary between a drawing and its composite. You 
can add a node to the middle of an existing connection by pressing and holding the Alt key, then 
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dragging the node over the connection, like so:

 3. Click on the Layer Properties  icon just left of the node's name to open its Layer Properties dialog. 

The effect's Layer Properties dialog appears.

 

NOTE

Once you have set the parameters for the effect, you can store it in the Library view as a 
template, so you can quickly reuse it without resetting the parameters again—see How to 
Create and Use Templates on page 172.
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Adding an Effect with a Matte
The following tutorial demonstrates how to use the Cutter effect with a matte. Several effects in Harmony use 
mattes to determine the area of the image they affect. 

The Cutter effect cuts out a portion of an image. To do this, it needs to be connected to the drawing it is 
intended to cut as well as to a matte  layer. The cutter will take the shape of the drawing in the matte layer and 
cut this shape out of the drawing layer. This is especially useful if you want to make a character disappear 
between a background element, or if you want to cut out a hole in the middle of a character. 

Like all effects that use a matte, the Cutter's effect has an Inverted parameter, which is disabled by default. 
When enabled, the Cutter will have the reverse effect: Instead of cutting the matte's shape out of the drawing, 
it will cut everything outside of the matte's shape out of the drawing, leaving only the parts of the drawing that 
are covered by the matte.   

You can quickly toggle an effect's Inverted parameter by double-clicking on its Matte icon in the Node view. 

How to use the Cutter effect

 1. Select a drawing layer and do one of the following:

 l From the Node Library view, select the Cutter effect and drag it to the Node view. 

 l In the Node view, right-click and select Insert > Combine > Cutter. 

 2. While holding the Alt key, move the Cutter node over the cable connecting the drawing to your 
scene's main composite. The Cutter node will become connected as an intermediary between the 
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drawing and its composite. 

 1. In the toolbar above the layer list in Timeline view, click on Add Drawing Layer .

 2. In the Add Drawing Layer dialog, give your new drawing layer a relevant name for a matte layer, 
such as "Matte-Drawing", then click on Add and Close.

 3. In the new matte drawing layer, draw a matte for your effect. Your matte can be a simple shape, but 
should be filled with a colour, as only parts of the matte that are opaque will be taken in account.

NOTE

Mattes can also have semi-transparent areas. Areas of the drawing that are covered by 
semi-transparent areas of the matte are partially affected by the effect.

 4. In the Node view, connect the output port of the matte drawing node to the Cutter node's left input 
(matte) port.
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At this point, areas of the drawing layer that intersect with the artwork in the matte drawing node 
are hidden. 

 5. If you want to invert the Cutter's effect, so that the artwork that intersects with the artwork in the 
matte layer is visible and that everything else is hidden, double-click on the Cutter node's Matte  
icon to toggle its Inverted parameter. When an effect's matte is inverted, its matte port also appears 
inverted . 

Two other examples of effects that work with mattes are the Tone and Highlight effects. The Tone effect 
applies a shadow to its drawing based on its matte, and the Highlight effect applies a highlight to a drawing 
based on a matte.  These effects are not applied outside of the drawings they are connected to, so you can 
simply draw your character's highlights and shadow into your matte layers without worrying about drawing 
outside of their outline.
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Adding these effects to a drawing works exactly the same way as adding a cutter to a drawing, except that 
they have extra parameters to configure the colour, intensity and rendering of the effect.

Animating an Effect
You may need to animate some effects to obtain the expected results. For example, you may want the radius of 
a Glow effect to slowly increase and decrease to make it pulsate throughout a scene, or you may want the 
transparency of a Transparency effect to increase from 0% to 100% to make a drawing vanish. 

Almost all numerical parameters in an effect can be attached to a function. A function allows you to set a 
parameter to different values at different points in the scene by adding keyframes to it, and setting each 
keyframes to a specific value. Between keyframes, the value of the parameter will progress from the value of the 
previous keyframe to the value of the next keyframe. Drawing layers are animated by having their coordinates 
associated to functions. Likewise, effects can be animated by associating their parameters to functions. 

Some effect parameters can be animated directly in the Timeline view, but not all. When you expand an effect's 
parameters in the Timeline view, some of its parameters may be hidden to avoid cluttering the Timeline view. 
You can animate those parameters from the Layer Properties view or the Layer Properties dialog, which display 
all of a layer's parameters.

How to animate an effect parameter in the Timeline view

 1. In the Timeline view, locate the effect you want to animate, and click on the Expand  button right 
of its name. 
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The list of parameters that effect's paramaters that are available in the Timeline view appears.

 2. In the right area of the Timeline view, in the same row as the parameter you want to animate, select 
the frame where you want to create the first animation keyframe for the effect.

 3. Create a keyframe by doing one of the following:

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

 4. In the left area of the Timeline view, under the Parameters column, adjust the value of the parameter 
for this keyframe by doing one of the following:

 l Click and hold on the value of the parameter, then drag it towards the left to reduce its value, 
or towards the right to increase its value.
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 l Click on the value of the parameter. A text field will appear. Type in the new value of the 
parameter, then press Enter.

 5. In the right area of the Timeline view, click on the frame where you want to create the second 
animation keyframe for the effect.

 6. Create the second keyframe for your effect's animation by doing one of the following:

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

 7. In the Parameters column, adjust the value of the parameter at the current keyframe. 

 8. Repeat the steps to create as many animation keyframe for your effect as needed.

 9. To adjust the timing between the keyframes of your animation, select the first keyframe.

 10. In the Timeline toolbar, click on the Set Ease for Multiple Parameters  button.

146



The Set Ease for Multiple Parameters dialog appear. The function graph in this dialog will be focused 
on the first keyframe  in your animation, which should have a Bezier handle  right next to it, 
pointing to the right. 

 11. Click on the Bezier handle  and drag it towards the right, at any angle, to adjust the ease-in of 
the animation.

 12. Click on Apply/Next.

The Set Ease for Multiple Parameters dialog will focus on the second keyframe. If this is the last 
keyframe in the animation, it will only have one Bezier handle, pointing towards the left. If there are 
more animation keyframes after this one, it will have two Bezier handles, one pointing in each 
direction.
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 13. Click on the left Bezier handle  and drag it towards the left, at any angle, to adjust the ease-out 
of the animation between the previous keyframe and the current keyframe. 

 14. If there is a Bezier handle pointing towards the right , click on it and drag it towards the right, at 
any angle, to adjust the ease-in of the animation between the current keyframe and the next 
keyframe.

 15. Repeat the previous steps until the timing for your animation is adjusted throughout the entire 
scene. 

148



How to animate an effect in the Layer Properties dialog

 1. Open the effect's Layer Properties by doing one of the following:

 l Add the Layer Properties view to your workspace, then select the effect in the Timeline or 
Node view.

 l In the Timeline view, double-click on the effect layer, but not on its name.

 l In the Node view, locate the effect node and click on its Layer Properties  button. 

 2. In the effect's layer properties, locate the parameter that you want to animate and click on the 
Function  button to its right.

The parameter's input field will be greyed out. This is because you cannot directly edit a parameter 
once it is attached to a function. The field will indicate the name of the function that was created for 
it, in this format:

Name of node: Name of function: Value at current frame

 3. Click on the parameter's Function button again.

The Bezier Editor dialog opens. 
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This dialog will allow you to animate the function. The function graph at the bottom is made to 
represent the values of the function throughout each frame in the scene. 

 4. In the function graph, click and drag on the red cursor  to move it to the frame where you want to 
create your first animation keyframe.

 5. Click on the Add Keyframe  button to create the first animation keyframe for the effect.

A keyframe  is created and should be visible in the function graph. If you do not see it, that is 
because the function graph is not positioned to include the keyframe within its frame. To move the 
function graph to view the function's keyframe, click on the Reset View  or Reset View Vertically 

 button. 
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 6. Adjust the value of the parameter at the current frame by doing one of the following:

 l In the Value field over the function graph, type in the desired value for the parameter.

 l In the function graph, click and drag on the keyframe , and move it up to increase its value, 
or down to decrease it. 

TIP

If you want to set the keyframe to a value that is outside of the function graph's 
frame, you can press the 1 key to zoom out. You can also press the 2 key to zoom 
back in.
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 7. Click and drag on the red cursor to move it to the frame where you want to create your second 
animation keyframe. 

 8. Click on the Add Keyframe  button to create the second animation keyframe for the effect.

 9. Adjust the value of the parameter at the current frame by doing one of the following:

 l In the Value field over the function graph, type in the desired value for the parameter.

 l In the function graph, click and drag on the keyframe , and move it up to increase its value, 
or down to decrease it. 
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 10. If you want to adjust the timing of the animation between the first and second keyframes, do the 
following:

 l Click and drag the Bezier handle  of the first keyframe  towards the right, in any direction, 
to affect the ease-in of the animation.

 l Click and drag the Bezier handle  of the second keyframe  towards the left, in any 
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direction, to affect the ease-out of the animation.

 11. Repeat these steps until you created and timed every animation keyframe required to animate your 
effect.

Creating an Effect Based on an Animated Character
The following tutorial demonstrates how to combine Effects with other Harmony functionalities to easily create 
a drop shadow for an animated character. By following these steps, you can create a drop shadow that will 
automatically follow your character's animation, even if you change the animation afterward.

How to create a drop shadow for an animated character

 1. In the Node view, make sure your character's rig is in a group with a composite. If it is not, select all 
the nodes making your character's right, and do one of the following:

 l Right-click on the selection, then select Group > Group Selection with Composite.

 l In the top-left corner of the Node View, open the View Menu , then select Nodes 
> Group Selection with Composite.

 l Press Ctrl +Shift + G (Windows/Linux) or ⌘  + Shift + G (macOS).
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 2. Using the Node Library, add a Peg, an Apply-Peg-Transformation, and a Shadow node to your 
node system. 

 3. Connect the output port of your character rig to the input port of the Shadow node.

 4. Connect the output port of the Shadow node to the right-most input port (Image) of the Apply-
Peg-Transformation node.
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 5. Connect the output port of the peg to the leftmost input port (Transformation) of the Apply-Peg-
Transformation node.

 6. Connect the output port of the Apply-Peg-Transformation node to your scene's main composite, 
just right of the connection for your character rig. This way, the shadow will appear behind your 
character rig. 

 7. Select the Apply-Peg-Transformation's Peg node.
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 8. In the Tools toolbar, select the Transform  tool. 

 9. In the Camera view, scale and skew the selection so that it looks like a drop shadow. 
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Chapter 16: How to Use Drawing Guides
When you need to draw backgrounds or objects with a lot of straight lines, square angles and perspective, you 
can use Drawing Guides to assist you. Guides add a horizon line as well as vanishing points to your drawing 
space, which can be moved to fit your scene's needs, and they lock your drawing tools so that they always 
draw straight lines, either going from one of your vanishing points, or parallel to your guide's horizontal or 
vertical axis. 

Harmony supports the following types of drawing guides:

 l The Square Grid guide simply helps you draw on the horizontal and vertical axes, which are relative to 
the horizon line. 

 l The 1-Point Perspective guide helps you draw lines coming from a single vanishing point, which is in 
the middle of the horizon by default. It also helps you draw along the horizontal and vertical axes. This 
can help create realistic-looking backgrounds with buildings, walls and objects that are facing your 
camera. 

 l The 2-Point Perspective guide helps you draw lines going from one of two vanishing points, which are 
positioned left and right of your drawing space. This can help create realistic-looking backgrounds with 
buildings, walls and objects that are at an angle from your camera. 
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 l The 3-Point Perspective guide helps you draw lines going from one of 3 vanishing points: Two 
horizontal vanishing points positioned left and right of your drawing space, and one vertical vanishing 
point positioned below or above your drawing space. This can help you draw realistic looking 
backgrounds from a low or high angle. The 3-Point Perspective guide has two presets: Bird's Eye View 
preset and the Worm's-Eye View, which can be used for high angle and low angle perspectives, 
respectively. 

In order to use a drawing guide, you must first add it to your scene's Guides list.

How to add a drawing guide to your scene

 1. From the top menu, select Windows > Guides to add the Guides view to the current workspace.

 2. In the Guides view, select the  New Guide  button and choose one of the following types of 
guides:

 l  Square Grid

 l  1-Point Perspective

 l  2-Point Perspective

 l  3-Point Perspective (Bird’s-eye View)

 l  3-Point Perspective (Worm’s-eye View)

The new guide appears in the Guides view list. 
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 3. To add another guide, repeat the previous step.

How to edit a drawing guide

 1. In the Timeline or Xsheet view, select a drawing, or select an empty cell and create a new drawing 
by doing one of the following:

 l Right-click on the cell and select Drawing > Create Empty Drawing.

 l Press Alt + Shift + R

 2. In the Tools toolbar, select the Brush , Pencil , Stroke  or Line  tool.

 3. In the Guides view, select a guide to make it the active guide. 

Once a guide is active, its horizon line and vanishing point(s) appear in the drawing area.

 4. In the Guides view, make sure the Lock Guide  option is disabled. This ensures you're able to edit 
the active guide.  

 5. In the drawing area, zoom out until all vanishing points are visible (if necessary).

 6. In the drawing area, grab either the horizon or a vanishing point and move it to its desired location.
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When using the square grid or 1-point perspective guides, the angle of the horizon can be modified 
by manipulating the horizon line itself.                 

When using the 2-point or 3-point perspective guides, the angle of the horizon can be modified by 
manipulating one of the two vanishing points on the horizon.                 

When adjusting the horizon line, you can hold down Shift to snap the horizon line at every 15 
degrees. This makes it easy to maintain a perfectly horizontal horizon.

NOTE

Each modification to a guide can be undone with the Undo command.

161

Harmony 15.0 Premium Getting Started Guide



Chapter 16: How to Use Drawing Guides

 How to draw with drawing guides

 1. In the Timeline or Xsheet view, select a drawing, or select an empty cell and create a new drawing 
by doing one of the following:

 l Right-click on the cell and select Drawing > Create Empty Drawing.

 l Press Alt + Shift + R

 2. In the Tools toolbar, select the Brush , Pencil , Stroke  or Line  tool.

 3. In the Guides view, select the guide you wish to use.

 4. In the drawing area, draw a stroke with the current drawing tool. From the initial gesture, the tool 
locks on one of the guide's axes, forcing it to draw a straight line that follows the axis. 
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Chapter 17: How to Create a Multiplane
In live action, when the camera moves around in a scene, objects near the camera will appear to move by a 
greater distance than objects far from the camera. In 2D animation, a similar effect can be achieved by creating 
a multiplane.

In Harmony, you can easily set-up a multiplane by creating a background over several layers, spreading them 
on the Z-axis to add depth, and then moving the camera through the resulting environment to create an 
impressive perspective illusion. 

In the following example, the background is made of 6 different layers, each picturing an object that is at a 
different distance from the camera. On the left, you can see how each object is positioned relative to the 
camera, as if you were looking at them from the side. On the right, you can see how layers are positioned 
relative to each other as if you were looking at the scene from a corner. Below, you can see the scene from the 
camera's point of view.
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Using the Maintain Size tool, you can easily turn a normal multi-layered background into a multiplane.  This tool 
allows you to move a layer closer to or further away from the camera  all the while automatically adjusting the 
layer's size proportionally to its distance from the camera, preserving its a apparent size from the camera's 
point of view. Hence, you do not have to worry about the size and position of your layers when you design your 
background. 

In a new Harmony scene, draw the different elements of a background on separate layers. Then, follow the 
steps below to turn your background into a multiplane. 

How to set up a multiplane using the Maintain Size tool

 1. Make sure the No Z Dragging option in the Animation top menu is disabled. 

 2. Do one of the following:

 l In the Advanced Animation toolbar, select the Maintain Size  tool.

 l From the top menu, select Animation > Tools > Maintain Size.

 l Press Alt + 6.
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 3. In the Side or Top view, select one of the layers in the thumbnails section. You can also select a layer 
from the Timeline view.

The selected layer is highlighted in the Top, Side and Camera views.

 4. Drag the layer along the Z-axis inside the camera cone. 

Your element will move on your scene's Z-axis, but it will keep the same apparent size in the Camera 
view. 

You can view your multiplane from different points of view using the Perspective view. 

How to view your multiplane in the Perspective view

 1. Enable the Perspective view by doing one of the following:

 l Click on the Add view  button next to the Camera and Drawing view tabs, then 
select Perspective.

 l From the top menu, select Windows > Perspective.

 2. To rotate the Perspective view in all 3 dimensions, hold Ctrl + Shift (Windows/Linux) or ⌘  + Shift 
(macOS), then click and drag. 
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Chapter 18: How to Set Up Objects in 3D Space
In Harmony Premium, you can not only move layers on Z-axis, you can also enable full 3D manipulations on 
drawing layers, allowing you to rotate them on the X and Y axes. With this, you can simulate a 3D space by 
laying out 2D layers at different depths and angles in your scene's stage. This can be used to add realism to 
scenes with complex camera movements without requiring you to make an actual 3D model of your scene's 
environment.

In the following example, you will learn how to lay out layers making the different surfaces of a room to build an 
actual 3D room. Before you begin, create a layer for each surface in a simple rectangular room. Then, in each of 
these layer, draw a large colour-filled rectangle to make the surfaces of the walls, floor and ceiling. Feel free to 
add details such as tiles, textures, wall decorations or windows if you wish, and make sure to name each layer 
according to the part of the room they represent.

How to position layers in 3D space

 1. Next to the Camera and Drawing view tabs, click on the Add View button and select 
Perspective.

The Perspective view appears in the same section of your workspace as your Camera and Drawing 
views. This view allows you to view your scene from any angle and point of view, rather than from 
your Camera's point of view. In this view, the usual navigation keyboard shortcuts work the same, 
but you can also press Ctrl + Alt (Windows/Linux) or ⌘  + Alt (macOS) to rotate the view in any 
angle and on any axis
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 2. In the Timeline view, double-click on the new layer to open the Layer Properties dialog box.

 3. In the Transformation tab, select the Enable 3D option.

 4. In the Rotation section, select the Euler Angles option.

 5. In the (x) Axis field, type 90 to flip the floor so it is flat on the ground.
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 6. To position the height of the floor, type values in the Position section of the Layer Properties, use 
the Translate  tool or Transform  tool.

 7. Repeat the process for the other pieces to position.

 8. If you have parallel walls, once you have positioned one, select the Wall layer in the Timeline view.

 9. Do one of the following to duplicated the layer.

 l From the top menu, select Edit > Duplicate.

 l Right-click and select Edit > Duplicate.

 10. Once the layer is duplicated, use the Layer Properties window to enter the positioning values or use 
the Translate or Transform tool. If you want to position your layer visually, consider using the 
Camera, Top or Side view so as to be able to position it with precision.
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 11. If your walls are touching each other, you should make them intersect by extending one end of the 
wall through the other wall. This prevents accidentally leaving small gaps between them.

You now have a complete 3D room.

NOTE

The Transform tool as well as the Advanced Animation tool can be used with 3D layers as with 
2D layers. The Transform tool allows you to reposition, rotate and scale 3D layers on any axis, 
but does not allow you to skew 3D layers. You can use these tools on 3D layers in the Camera, 
Perspective, Top and Side views. 
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Chapter 19: How to Create and Use Templates
You can create a template from a layer or from cells. You can store anything available in the Timeline or Node 
view as a template. 

Creating a Template

How to create a template from the Timeline view

 1. In the Timeline view, select some cells or layers. 

You can create a template from a whole hierarchy of layers by collapsing the hierarchy and selecting 
its root layer. This can be useful for creating templates based on character rigs or scene 
backgrounds.

 2. In the Library view, select a folder to store the template. By default, you will have a library named 
Harmony Premium Library , which is stored on your computer, in the Toon Boom Harmony 
Premium Library subfolder of your Documents folder.

 3. If the library folder is locked , right-click and select Right to Modify.

 4. Drag the selection to the  chosen library folder. 

 5. In the Rename dialog box, give the new template a name.

 6. Click OK.
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The Timeline view and the Node view display different information about a scene and its structure. To make 
sure a character's main template, also called the master template, is rigged exactly the way it was meant to be 
when it's imported into a scene, it should be created with all the connections, effects, composites, nodes, pegs, 
groups, drawings, timings, as well as all the other information in the scene it was originally created in. 

Because the Node view is the most faithful representation of a rig's structure, it is recommended to create 
master templates from the Node view rather than the Timeline view. Templates created from the Timeline view 
may lose the extra connections, effects and groupings that are visible in the Node view but which aren't 
properly connected to its main structure. 

How to create a template from the Node view

 1. In the Library view, select the folder in which you want to store the template.

 2. If the library folder is locked , right-click and select Right to Modify. 

 3. In the Node view, select the nodes for creating the template and group them. It is very important to 
group your cut-out character rig before storing it in the Library, so your files are organized.

 4. From the top menu, select Edit > Group > Group Selected Layers or press Ctrl + G (Windows/Linux) 
or ⌘  + G (macOS). Make sure you have a composite under the connections before grouping, 
otherwise there will be numerous connections going outside the group.

 5. In the Node view, click on the group node's yellow button to open the Layer Properties window.
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 6. In the Node view, select the group node and copy and paste it inside the template folder in the 
Library view or press Ctrl + C and Ctrl + V (Windows/Linux) or ⌘  + C and  ⌘  + V (macOS).

 7. In the Rename dialog box, give the new template a name and click OK.

NOTE

If you create a template by selecting layers in the layers list of the Timeline view, or by selecting 
nodes in the Node view, your template with include the layer as well as all the drawings it contains, 
even drawings that are not exposed in the scene's timeline, whereas creating a template by 
selecting specific cells in the Timeline will only save the selected drawings in the template.

NOTE

To rename a template once it is created, right-click on the symbol and select Rename.

Importing a Template

How to import a template into the Timeline or Camera view

 1. In the Library view, select the template you want to import.

 2. Drag the selected template to the Camera view or to the left side of the Timeline view.
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If you drop the template in the Camera view, its layers will be added at the top of your layers list. If 
you drop a template in the layers list in the Timeline view, it will be inserted between the layers 
where you dropped it. 

If your template has the same layer structure as a part of your scene, you can drop the template 
directly onto the frames on the right side of the Timeline view. Instead of inserting new layers into 
your scene, this will replace the drawings and keyframes in your scene with the ones from the 
template. This is useful for importing pose or animation templates for characters that are already in 
your scene. 
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How to import a  template into the Node view

 1. In the Library view, select the template or symbol you want to import.

 2. Drag the selected template to the Node or Camera view or the left side of the Timeline view.
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 3. In the Node view, connect your template to your scene's Composite node. To do this, click its out-
port and drag the connection to the Composite node until an in-port appears.
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Chapter 20: How to Export a Movie
Using the Export Movie dialog, you can export your animation as a video file. By default, Harmony will export 
your entire scene in its full resolution. If you prefer, you can choose to export only a specific frame range in your 
scene, or to export in a smaller resolution, which can be useful if you need to save on time or disk space. 

If you have specific requirements for the quality and size of your exported video files, you can use the Movie 
Options dialog to configure  the video and audio compression settings. If you're exporting a QuickTime movie, 
you have access to all of the codecs and compression settings made available by QuickTime's interface. 

How to export a movie file

 1. From the top menu, select File > Export > Movie.

The Export to QuickTime Movie dialog box opens.

 2. In the Video Format drop-down menu, select the desired format for your movie file:

 l Quick Time Movie (*.mov): Available on Windows, macOS and GNU/Linux. 

 l Windows Media Video (*.wmv): Available on Windows only.
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NOTE

On Windows and macOS, Apple QuickTime must be installed in order to export 
QuickTime movies. On GNU/Linux, Harmony uses a more limited, open source 
QuickTime-compatible library which does not require additional software. 

 3. Click Browse to select the location and file name of your exported movie file.

 4. Click OK.

 5. In the Display Source section, select the Display node to use for rendering your project.

NOTE

If there is no Display node in your scene, the only available option will be Display All. 
This renders all the nodes in your scene, including ones that are not connected to 
anything, in the order in which they're listed in the Timeline view. If you wish to have 
control over what is rendered, it is recommended to have at least one Display node in 
your scene and to connect it to the composite you wish to render. 

 6. From the Export Range section, decide whether you want to export the entire scene (All) or a 
specific frame range. If you decide on the latter, enter the frame range.

 7. In the Resolution section, select one of the following from the menu:

 l A preferred resolution ratio.

 l Custom:  Enables the Width and Height fields so you can enter a specific size.
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 8. In the Options section, click Movie Options to configure your movie's video and sound compression 
settings. 

 l If your video format is Quick Time Movie, refer to the How to export a lossless 
QuickTime movie with transparency on page 182 and How to configure video and 
sound settings for QuickTime movies on page 180 sections. 

 l If your video format is Windows Media Video, refer to the How to configure video and 
sound settings for Windows Media Video on page 183 section.

 9. Click OK.

 10. In the Export to QuickTime Movie dialog box, click OK.

A progress bar appears.

 11. Browse to the location on your computer where you exported your movie and double-click on it to 
view it in your video player.

How to configure video and sound settings for QuickTime movies

 1. In the Movie Settings dialog box, select whether you want your movie to include Video and Sound 
data, as well as if the video should be optimized for Internet streaming.

 2. In the Video section, click Settings.

The Standard Video Compression Settings dialog box opens.
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 3. From the Compression Type menu, select a codec. The availability of certain compression settings 
depends on the Compression Type selected. For example, when the Animation compression type is 
selected, the Data Rate option is greyed out. 

TIP

If you want to render a QuickTime movie with high quality compression and 
transparency, you can use the Animation video codec with the colour depth set to 
Millions of Colours+. 

 4. In the Motion section, choose a Frame Rate from the list. 

By default, it is set to match the frames-per-second (fps) of your Harmony project. If you choose a 
lower frame rate, your export playback will be faster than your actual project. The reverse is also true 
for a higher frame rate. 

 5. If you want keyframes inserted, select the Every option and set the number per frame. 

This is the option recommended by QuickTime. For further details, refer to the QuickTime 
documentation.

 6. In the Quality section, use the slider to choose a quality setting. Remember that the better the 
quality of the export, the larger the file.
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 7. From the Data Rate section, either choose to allow the program to automatically select the most 
optimal bit rate, or enter a Restricted rate to save space and allow for faster downloading at a cost 
to the quality of the export. 

 8. In the same section, from the Optimized For menu, select the intended viewing method for the 
export.

 9. Click OK.

 10. From the Movie Settings dialog box, click Sound Settings.

The Sound Settings dialog box opens.

 11. From the Compressor menu, select a compression type. The default setting is None. This exports 
your audio as is without performing any lossy compression or conversion, preserving its fidelity. 
Other compressors can be used if you need your movie's audio track to be exported in a specific 
format, or if disk space or download speed is critical, but they may impact the quality of your movie's 
soundtrack negatively. 

 12. From the Rate menu, select a rate. It is best to export your audio at a rate that matches the rate of 
your original sound files. For example, if your file has an audio sample rate of 48 kHz and you choose 
a conversion rate of 22.05 kHz, the sound will play at the same speed, but higher frequencies will be 
missing, making it sound muffled. For reference, the standard sound quality is 48 kHz for 
broadcasting and DVD. Lower rates are liable to impact the quality of your movie's soundtrack 
negatively, but they can be useful if disk space or download speed is critical.

 13. Select the Size of your audio's encoding. Also known as Bit Depth, this determines the amount of 
precision used to record each wavelength in the soundtrack. The standard size is 16-bit. If you 
choose 8-bit, the amount of disk space your sound track requires is halved, but the audio will sound 
muffled.

 14. Select whether to Use the Mono or Stereo channel mode.  Stereo sound has a separate sound track 
for the left and the right speakers, allowing to make the origin of each sound realistically match the 
origin of their corresponding action. If you choose Mono, your sound track may use less disk space, 
but both the left and right channels will be merged into a single track.  

How to export a lossless QuickTime movie with transparency

 1. In the Video section of the Movie Settings dialog, select Settings.
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 2. In the Standard Video Compression Settings dialog, set the Compression Type to Animation.

 3. In the Compressor section, set the Depth to  Millions of Colors+ .

 4. Click OK.

How to configure video and sound settings for Windows Media Video

 1. In the Video section, select the desired Variable Bit Rate Quality for your video. A higher setting will 
ensure a better image quality. A lower setting will create a smaller video file.

 2. Using the Sound checkbox, select whether or not you want your movie file to have sound.

 3. Using the Profile drop-down menu, select the preferred compression settings for your movie's 
soundtrack. Each profile has a combination of audio sample rate, sample size and channel mode, 
which cover the following options:

 l  Sample rate: Available sample rates are 8000 Hz, 16000 Hz, 22050 Hz and 44100 Hz. The 
default setting is 22050 Hz. It is best to export your audio at a rate that matches the rate of 
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your original sound files. For example, if your file has an audio sample rate of 48000 Hz and 
you choose a sample rate of 22050 Hz, the sound will play at the same speed, but higher 
frequencies will be missing, making it sound muffled. For reference, the standard sound 
quality is 44000 kHz for films, and 48000 kHz for DVD. Lower rates are liable to impact the 
quality of your movie's soundtrack negatively, but they can be useful if disk space or 
download speed is critical.

 l Sample size: Also known as Bit Depth, this determines the amount of precision used to 
record each wavelength in the soundtrack. The standard size is 16-bit. If you choose 8-bit, 
the amount of disk space your sound track requires is halved, but the audio will sound 
muffled. 

 l Channel mode:  Stereo sound has a separate sound track for the left and the right speakers, 
allowing to make the origin of each sound realistically match the origin of their corresponding 
action. If you choose Mono, your sound track may use less disk space, but both the left and 
right channels will be merged into a single track. 

NOTE

Exporting in 8-bit audio requires Apple QuickTime to be installed.
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Glossary
Term Definition

3D stereoscopic                         The ability to create stereo images which, when animated and viewed through 3D active 
shutter glasses or using glasses with one red and one blue lens, will appear as a three-
dimensional movie. 

alpha channel An image channel that carries transparency information. An image already has three 
channels: red, green and blue (RGB). The alpha channel is the fourth channel (A). The matte, 
or the transparency information, is stored in this fourth channel. An image without an alpha 
channel is always opaque.

animatic                         A movie with sound that is developed from the storyboard. The storyboard panel is exposed 
for the duration of the scene and at times, the characters are placed on a trajectory to indicate 
motion. The camera moves are also animated. The animatic is used to determine the rhythm 
of a project and provides a good overview of the project before beginning production.

animation A simulation of movement created by displaying a series of pictures or frames.

anime An animation style known for its sinister and dark feel; popular in Japan.

arc                         Action rarely occurs in a straight-forward manner; rather it typically unfolds in what 
storytellers refer to as an arc. The purpose of a story arc is to move a character or situation 
from one state or scenario to the next.

aspect ratio The relationship between the width and height dimensions for any scene, frame or film 
format. Television ratio is 4:3 and widescreen ratio is 16:9.

auto-feed                             An automated method of feeding drawings into a scanner in which multiple drawings are 
stacked into a sheet feeder. When the scanner is activated, the drawings are scanned 
consecutively, without further user intervention.

automatic lip-sync 
detection                             

Automatically mapping drawings in an element to the mouth chart generated for a sound. 
This can save time when lip-syncing a voice track.

axis                             An imaginary line around which an object rotates.

For 2D graphics, there are two axes: X (horizontal and Y (vertical).

For 3D graphics, there are three axes: X (horizontal, Y (vertical) and Z (depth).

In animations that constantly rotate, the axis element specifies what axis the object rotates 
around. A negative number causes an animation to rotate counter clockwise whereas a 
positive number causes an animation to rotate clockwise.

background                         The part of a scene that is farthest to the rear. The background is the artwork, or decor, 
against which the animation takes place.

Bézier                             A method of defining curved lines invented by French mathematician Pierre Bézier. A Bézier 
curve is a mathematical or parametric curve. Bézier curves use at least three points to define a 
curve.

bitmap                             An image composed of pixels with a single resolution (size). If it is enlarged too much, it will 
lose definition and individual pixels will begin to appear. This is known as pixelation.
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Bitmap image files are defined as a standard rectangular mesh of individual pixels. Each 
individual pixel contains a value that represents a specific colour.

breakdown                             In cut-out animation, breakdown is the action of breaking a character into pieces to create a 
puppet with articulations. To break down a character, the artist cuts parts, such as the hands 
and arms, from the character's model and pastes them in separate layers. Next, the joints are 
fixed and the pivots set.

In traditional animation, a breakdown is an animation pose generally found between two key 
poses. The key poses are the main poses in an animation and the breakdowns are secondary 
poses, ones that help describe the motion and the rotation curve (usually referred to as an 
arc).

camera shake                             Camera shake occurs in a scene when the camera moves slightly and quickly in several 
directions. This gives the impression of an impact, vibration or, for example, bumps on the 
road.

caption                             A text field containing dialogue, effects, sound or slugging information in a storyboard.

cel                             In traditional animation, a cel (also known as celluloid) is a transparent sheet on which the 
animation is inked and painted before being sent to the camera. The picture's outline is 
drawn on the front of the cel and then coloured along the back.

character design Each character in an animated film is drawn from multiple angles in poster-style format, 
called a model sheet, which serves as a reference for the animators.

chromatic aberration                         In optics, chromatic aberration (CA), achromatism or chromatic distortion, is a type of 
distortion in which there is a failure of a lens to focus all colours to the same convergence 
point.

clean up                             After rough drawings have been tested and approved, all the noise in the image (excess lines, 
notes, etc.) is removed to create final drawings which can be inked, painted and shot. The 
clean up process refers to either tracing a clean line over a rough drawing to achieve the final 
version or removing dirt and extra lines left by the scanning process.

CMYK                             Acronym for Cyan, Magenta, Yellow, Black. These colours are the standard model used in a 
process called offset printing.

colour card A colour card is a card containing one solid colour that is the same size as the camera. The 
colour card fills the background with a solid colour when there is no background image 
included.

colour model                             The official colour design that must be used to paint the animation. A model is the definitive 
character, prop or location design that each artist must follow for the production. 

colour wheel                             A display of the colour spectrum in the form of a circle. 

compositing                             Compositing is the action of incorporating all of a scene's elements to create the final result 
prior to rendering. For example, the compositing artist will import all the animation 
sequences, background, overlays and underlays in the scene and position them correctly. 
The artist will then set the camera frame and animate it, if needed. Finally, the animator will 
create all the computer-generated effects for the project.

cross dissolve                             An effect used to fade two scenes, one into the other.

cut                             A direct transition between two scenes. When a cut is used, there are no transition effects 
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inserted to pass from one scene to the next. The first scene ends and the second one starts 
immediately.

cut-out animation                             The process known as cut-out animation is the action of animating characters made out of 
several pieces by moving them around frame by frame. Cut-out animation can either be 
computer generated or done traditionally using paper.

cycle                             A group of images that together make up an action, such as walking. A cycle is an action 
repeated as a loop over a period of time. It can be a series of animated drawings or keyframes. 

dialogue The text spoken by a character in a movie or animation.

dope sheet Used by animators, directors and other members of a crew to track the sequence and timing 
of images, dialogue, sound effects, sound tracks and camera moves. Also known as an 
exposure sheet.

doping To assign a particular drawing to a range of frames.

double bounce walk In the key frames and passing positions in a double bounce walk, the body is lower than a 
reference line drawn in the upright position. During the in-betweens, the body is above this 
line giving the appearance of a bounce.

DPI Dots per inch is the standard measure of resolution for computerized printers. It is 
sometimes applied to screens, in which case it should more accurately be referred to as 
pixels per inch. Either way, the dot is the smallest discrete element making up the image.

ease In animation, the ease, also known as velocity, is the acceleration and deceleration of a 
motion. It can be a motion created by a function curve, or a series of animated drawings. 
Other common terms for ease-in and ease-out are slow-in and slow-out.

ease-in Gradual acceleration in the action. Also known as slow-in.

ease-out Gradual deceleration in the action. Also known as slow-out.

establishing shot A scene in which the viewer can see the whole area in which a sequence is happening. For 
example, if a child is playing on the ground in front of his house, the establishing shot would 
be a scene where the viewer can see the house, the ground, a part of the street and the 
buildings around the central point of action. This helps the viewer understand the story 
location and scene orientation.

exposure                             In animation, an exposure is the number of cels on which a drawing appears in the scene. For 
a drawing to appear longer, the exposure must be extended over a greater number of cels.

exposure sheet                             A sheet with several vertical columns and horizontal frames used to indicate a scene's 
timing. Each column represents a scene layer. The drawing numbers in each column are 
indicated and repeated over the particular amount of frames they need to appear.

The exposure sheet is used by animators, directors and other members of a crew to track the 
sequence and timing of images, dialogue, sound effects, sound tracks and camera moves. 
Also known as a dope sheet.

fade in/fade out Fade in or fade out is a transition effect used to open or close a sequence. A fade in occurs 
when the first scene appears progressively, from complete transparency to its complete 
opacity. A fade out occurs when the last scene progressively disappears, going from 
complete opacity to complete transparency.
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fast-in Dramatic acceleration at the start of the action.

fast-out Dramatic acceleration at the end of the action.

field A measurement unit used to calculate motion, registration and camera positioning. A 
standard animation scene will vary between 6 to 12 fields.

field chart                             A guide containing all the field units that animation and layout artists use to determine a 
scene size or camera motion.

film-1.33 A resolution that is ideal for the widescreen film format that conforms to the standard 4:3 
pixel aspect ratio.

film-1.66 A resolution that is ideal for the widescreen film format that conforms to the 16:9 pixel 
aspect ratio. (The pixels are wider than they are high).

flipping In traditional animation, flipping is the action of going through the drawings of an animation 
sequence very quickly in order to see the animation in motion. Flipping can also be the action 
of creating a mirror transformation of an object.

follow-through The secondary motion caused by the main action. For example, a character wearing a cloak is 
running. The main action is the body running. This will cause the cloak to follow the motion, 
although it will not move at the same time, but react a few frames later and follow the main 
motion curve.

forward kinematics Forward kinematics is a feature used to animate principally 3D characters and cut-out 
puppets with hierarchy. It is used to animate a puppet from one of parent parts, such as a 
shoulder, and make the rest of the arm move with it as a single piece.

frame                             An animation frame is a single photographic image in a movie. In traditional animation, the 
North American standard generally contains 24 frames per second, while in Europe the 
standard is 25 frames per second.

frame rate                             The frame rate is the speed at which the frames are played. They are generally calculated by 
frame per second. For example, a scene could be played back at 12, 24, 25, 30 or 60 frames 
per second or any other number.

This is the measurement of the frequency (rate) at which an imaging device produces unique 
consecutive images, called frames. The term applies equally to computer graphics, video 
cameras, film cameras, and motion capture systems.

Frame rate is most often expressed in frames per second (fps) and in progressive-scan 
monitors as hertz (Hz).

function                             A computer-generated motion, trajectory or path on which elements, other trajectories and 
effects parameters can be attached. The function can be controlled by adding keyframes and 
control points on the function curve.

gamut                             The range of colours that a particular device can represent.

HDTV                             Acronym for High Definition Television which delivers a higher quality image than standard 
television because it has a greater number of lines of resolution. To take advantage of the 
superior quality and make full use of your resolution setting, the output device must be 
compatible with HDTV technology.

hold                         A frame in the animation in which the character maintains its position without moving. A 
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hold can be created between any two keyframes.

HSV                             Hue, Saturation, Value. A method of defining colours in terms of hue (tint), saturation 
(shade) and value (tone or luminance).

in-between                             The drawings that exist between the key poses. These are drawn to create fluid transitions 
between poses.

ink and paint                             The ink and paint process is the action of painting the empty zones and colouring the lines 
on the final animation drawings, while following a colour model.

interpolation                             The computer-generated motion created between two keyframes. You have the choice to 
create interpolation, or not, between your keyframes.

inverse kinematics (IK)                         A feature used mainly to animate 3D characters and cut-out puppets with hierarchy. Inverse 
kinematics will animate a puppet from one of the extremities, such as a hand, and make the 
rest of the body follow naturally.

jump cut                             A jerky cut between two scenes. Typically, a jump cut is not visually pleasing. It is generally 
caused by one scene ending, and a second one starting, with a similar image. The lack of 
difference causes the eye to see a little jump between the two scenes. 

key pose                             Important positions in the action defining the starting and ending points of any smooth 
transition. Keys, or key poses, are the main drawings in an animation sequence describing 
the motion. For example, if an arm is waving, the keys will be of the arm at one extremity of 
the wave motion and the other extremity. By flipping those drawings, the animator can see 
the skeleton of the motion without having all the drawings.

keyboard                              shortcuts                          One or more keyboard keys which, when used, cause an operation to be performed.

keyframe                         Important positions in the action defining the starting and ending points of any action. A 
keyframe is a computer-generated position at a specific moment (frame) on a given trajectory.

layer                             In animation, a layer is an individual column, level or character. A scene's layers are 
superimposed to form the final image.

layout                             The communication step between the storyboard and the animation. It is the action of 
putting the storyboard on model. That is, drawing the character by following the design in 
the model pack, so the animator can start working.

The layout artist draws the background, creates the camera and field guide matching the 
scene and camera motion. Lastly, the animator draws on model the main action poses.

layout and posing                             The action of putting on model (at the right scale) the storyboard for the animator to start 
working.

layout artist                         The artist who draws the background, and creates the camera and field guide to match the 
scene and camera motion. They will draw on model the main action poses.

layout planning                         Drawing of the main features of the scene used as reference when planning the animation 
and executing the initial stages of it.

layout process                         The communication step between the storyboard and the animation. 

library A storage area containing templates and assets that can be reused in any project or scene.

light table A device that allows you to see other layers in transparency while you are working on a 
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particular layer.

line of action                         The direction that the action will follow. Also known as path of action.

lip-sync The process of synchronizing a character's mouth to sounds in the dialogue sound track. 
The mouth is adjusted frame-by-frame to match the sound of the dialogue and provide the 
illusion that the character is speaking. Lip-sync can be used for any sound sequence, not 
only speech, you could for instance have a bird chirping or a wolf howling at the moon.

low resolution A format that is ideal for videos destined for the web, where size and fast download of a 
video file take precedence over quality. A low-resolution image is one that lacks fine detail.

manual lip-sync detection The manual swapping of mouth position drawings to match a voice track. For this process, 
both sound scrubbing (listening to a sound wave broken up frame-by-frame) and drawing 
substitutions are used.

master palette                         A group of colours attributed to a character or prop. The palette is used throughout the entire 
production to maintain consistency in the look and to ensure that the same colours are used 
throughout the production. Also known as palette.

model/colour model                         The definitive character, prop or location design each artist must follow for a production. A 
colour model is the official colour design that must be used to paint the animation.

morphing                         A feature for creating computer-generated drawings between a source drawing and a 
destination drawing. Animation created with the morphing feature can be reused in different 
projects.

motion keyframe A keyframe with computer-generated interpolation.

mouth chart A chart based on the eight animation phonemes (A, B, C, D, E, F, G, and X, which is used to 
represent silence) used for lip-sync.

multiplane                             The effect of passing through multiple levels of drawings to create a sense of depth in a shot. 
A multiplane is a scene in which the layers are placed at different distances from the camera 
so that when the camera moves, a depth illusion occurs. With a multiplane, all the 
perspective and scale is calculated automatically.

NTSC                         The standard analogue television broadcasting system used in North America. NTSC 
conforms to North American standards on how rectangular pixels are displayed for computer 
and television screens.

nudge                             A small push (left, right, up, down, forward or backward) done with the keyboard arrow keys 
on a selected element. Nudging is used to move a selection very slightly and precisely.

onion skin                             A feature that lets you see the previous and next drawings of a sequence.

overlay                             A part of the scene environment, such as a chair or a bush, that is placed in front of the main 
animation.

PAL                             A resolution that works best with the European format for television and computer screens, 
as the rectangular pixels are displayed at a different orientation.

palette/master palette                         A palette or master palette is a group of colours attributed to a character or a prop. The 
palette is used throughout the entire project to maintain a consistency in the look and avoid 
the colour changing during the animation. Also referred to as a master palette.

palette style                         A palette style is a second version of an existing palette with a slight change in the tint and 
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value. A palette style can be used to create the night version of a palette. It may also be called 
a clone palette.

pan To move the camera across the scene in any direction.

panel                         In a storyboard, a panel is a frame in a shot. A shot can be composed of one or several 
panels.

paperless 
animation/tradigital                         

The paperless animation process is the action of animating digitally. The main paperless 
animation process is to draw, frame by frame, the animation directly in the software.

passing position When drawing a walk sequence for a character, the passing position is the point at which 
one leg passes the other.

path of action Direction that the action will follow. Also known as line of action.

peg In traditional animation, a tool used to ensure accurate registration of action as cel layers 
move. In digital animation, in which you are doing a more advanced puppet rigging, you can 
use peg layers. Peg layers are trajectory layers that do not contain drawings. They are motion 
paths that you can use to add path articulations. For the latter, you can also use an inverse 
kinematics tool.

phoneme                          A unit of sound in a language.

pivot The point around which a peg or drawing rotates.

pixel The smallest element of an image displayed on a monitor or TV screen.

Pixel, short for picture element, is a single point in a graphic image. It is a small sample of an 
image, a dot, a square, or a very small section made out of smooth filtering. If you zoom in 
close enough on a digital image, you will see the pixels, which look like small squares of 
different colours and intensity.

pose-to-pose animation                         The pose-to-pose animation process is the action of creating all the main action poses, 
called key poses, and then placing the secondary poses between the keys. The secondary 
poses are called breakdowns. Finally, the animator fills the gaps with the in-between 
drawings to achieve a smooth animation.

rendering                          The final step when animating by computer. During rendering, the computer takes each pixel 
that appears on screen and processes all of the components, as well as adding motion blur 
before it produces a final image. The process of calculating the final images after the 
compositing process.

resolution                         The size of a scene, generally calculated in pixels. For example, the NTSC resolution is 720 x 
480. The resolution should match the final output: HDTV, film-1.33, film-1.66, NTSC, PAL, 
low.

RGB Red, Green, Blue. A method of defining colour by specifying amounts of these three colour 
components.

rigging The process of attaching the various parts of a cut-out puppet.

rotary table Equivalent to the animation disk/table, a device that allows you to rotate the workspace for 
greater comfort while drawing.

rotoscoping An animation technique in which animators trace over live-action film movement, frame by 
frame, for use in animated films. The act of sketching over live-action footage to create an 
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animated sequence.

roughs                          Rough is a common name in an animation movie for a drawing that is used as a reference but 
which does not form part of the final image. A layout is a rough.

The skeleton sketch of an animation or design. Roughs mainly consist of sketch lines and 
shapes, but can also contain design details.

safe area                         The zone at the center of a scene's frame that is safe from being cropped by the TV frame. As 
a TV frame cuts a margin off the original frame size, maintaining a safe area ensures that the 
scene's main action will remain clearly visible once the film is screened on television.

scene A shot in a movie or show. A sequence is composed of several scenes. A scene changes to 
another scene by a simple cut or transition.

script The original text containing all the movie or show information. In animation, the script 
contains all of the location descriptions, dialogue, time and more. A project starts with a 
script.

sequence                          A series of scenes or shots forming a distinct part of the story or movie, usually connected 
by unity of location or time.

shot                          A scene in a movie or show. A sequence is composed of several shots. A shot changes to 
another shot by a simple cut or transition.

slow-in The gradual acceleration in the action. Also known as ease-in.

slow-out The gradual deceleration in the action. Also known as ease-out.

slugging To indicate the start and stop times of dialogue and relevant actions.

sound scrubbing A process that lets you hear sound in real time while you move the playhead forward or 
backward. This is very useful for finely-tuning a lip-sync.

stop-motion keyframe A keyframe with no computer-generated interpolation.

storyboard A visual plan of all the scenes and shots in an animation. The storyboard indicates what will 
happen, when it will happen and how the objects in a scene are laid out.

straight-ahead animation                         A technique in which an entire sequence is drawn from the first position to the last, in order. 
There is very little planning in this methodology. Where the character ends up and how it 
gets there can be a surprise for both the audience and the animator. While this approach is 
spontaneous and creative, it can create inaccurate results.

strokes Invisible vector lines forming the drawing zones. They can be adjusted with Bézier handles.

symbol                         A symbol combines animation, artwork or layers into a single object that you can control in 
one layer. You can also create symbols out of each body part in your cut-out puppets.

You can place whatever you want in a symbol. You can use symbols to animate a puppet or 
create reusable animations such as blinking. 

tablet/pen A device used in conjunction with, or instead of, a mouse to move a mouse pointer 
(sometimes referred to as the cursor) around the computer screen.

template                          An asset stored in the library that can be reused in any project. A template can be a drawing, 
a series of keyframes, a sound file, a panel, a cut-out character, an effect, a trajectory, an 
animation, or anything else used in the animation.
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thumbnail A very small image used as a reference or indicator.

timecode                          The timing information printed on a movie clip to indicate the scene, hour, minute and 
second that is currently displayed on the screen.

timeline A horizontal representation of a scene's elements, timing and keyframes.

trace and paint                         After the rough animations have gone through cleanup and a final line or pencil test, each 
drawing is traced and painted for the final animation. In today's digital world, this may be 
done in a variety of ways other than the traditional celluloid or acetate methods.

track breakdown The break down of an animated film's soundtrack into individual sounds to produce the 
precise frame-by-frame position of each sound.

traditional animation A type of animation process whereby all the animation sequences are drawn by hand on 
paper before scanning or inking them on cels.

trajectory                          A computer-generated path or trajectory that elements can follow. The trajectory can be 
controlled by control points, keyframes and velocity.

transition                          An effect placed between two scenes as they pass from one to the other. Common transition 
effects are cross-dissolve and wipe.

underlay                         In animation, an underlay is a specific part of the decor placed behind the main animation.

vector A vector-based image is composed of points and Bézier curves. The computer reads the 
points and traces the segments, linking them to reproduce the image shape. There is no fixed 
size or resolution in a vector image. The graphic can be enlarged and distorted as much as 
desired and the system will simply recalculate the segments and rebuild the shapes. Vector 
images are translated and displayed in pixels once the calculation is done.

velocity In animation, the velocity, also known as ease, is the acceleration or deceleration of a motion. 
This can be achieved by a function curve, or via a series of animated drawings. Other 
common terms for ease-in and ease-out are slow-in and slow-out.

walk cycle                          An animation depicting a character walking in place. The illusion of movement is created by 
the use of background pans. To avoid animating a character walking over and over again in 
every episode in a series, it is common practice to prepare walk cycles for each character in a 
production so that they can be reused as needed. 

zone                          An area which can be painted with colour.
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