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Chapter 1: Reference     

Chapter 1: Reference 
Harmony has several commands, dialog boxes, and buttons. The Reference section lists all of them along with 
the matching definition. To understand how to use these functions in a production context, read the User guide. 

In the Reference guide, you will learn about the various parameters available in dialog boxes, menus, nodes, 
toolbars, views, and windows. 

The Preferences guide provides additional details about each individual preference. 

6



Harmony 14 Paint - Reference Guide

Chapter 2: Dialog Boxes
Dialog boxes contain controls such as options and lists through which you can carry out a particular command or 
task. For example, in the Scene Settings dialog box, you must indicate the resolution and alignment. A typical dialog 
box looks as follows:

Advanced Save Dialog Box 8

File Tab 9

Drawings (Harmony Server only) 9

Palettes Tab 10

Palette Lists Tab 11

Close Gaps Dialog Box 12

Configure Line Art to Colour Art Dialog Box 13

Create Palette Dialog Box 14

Database Selector Dialog Box 15

Element Manager Dialog Box 16

Manage Tool Presets Dialog Box 17

New Tool Preset Dialog Box 19

Onion Skin and Light Table Transparency Dialog Box 20

Palette Browser Dialog Box 21

Palette Operations Dialog Box 23

Pose Copier Dialog Box 24

Preferences Dialog Box 26

Remove Dirt Dialog Box 27

Remove Hair Dialog Box 28

Save Dialog Box 29

Scripts Manager Dialog Box 30

Tint Offset/Blend  Dialog Box 31

Toolbar Manager Dialog Box 32

Xsheet Column Width Dialog Box 33
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Advanced Save Dialog Box
In Harmony Server, the Advanced Save dialog box lets you save the scene as a new version, overwrite an 
existing version, set a new current version, display a list of modified drawings, colour palettes, and modified 
colour palette lists. 

How to access the Advanced Save dialog Box

 1. Make sure that you have the necessary rights to save the current scene version. 

 2. From the top menu, select File > Save. 
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File Tab

Parameter Description

Save

‣ Enable this option if you want to save the modifications made to the 
current scene. 

‣ Deselect the Save option if you only want to save specific components of 
your scene listed in the Drawings, Palettes or Palette Lists tabs. This will 
disable all option in the File tab. 

This Version (number)
Saves the current version of the scene. You can rename the current version by 
typing a new name into the field. 

New Version (number)
Saves the current scene as a new version. You can name this new version by typ-
ing a name into the field. 

Overwrite Existing Version Lets you select an existing version of your scene from the list to overwrite it.

Description
Use this field to add or edit an existing description for the scene version you want 
to save. 

Mark as Current
Lets you set this scene version as the current one. This version will be auto-
matically selected as the default current version when the scene is selected in the 
Database Selector dialog box

Drawings (Harmony Server only) 
The Drawings tab lists the modified drawings.
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Parameter Description

Drawing list
Lets you select the modified drawings to save, and deselect the ones you do 
not want to save.

Select All Selects all modified drawings in list.

Deselect All Deselects all modified drawings in the list.

Palettes Tab
The Palette tab lists the modified colour palettes.

 

Parameter Description
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Colour Palette list
Lets you select the colour palette to save, and deselect the ones you do not 
want to save.

Show Recovered Displays the recovered palettes in the list of modified palettes.

Select All Selects all modified colour palettes in the palette list.

Deselect All Deselects all modified colour palettes in the palette list.

Palette Lists Tab
The Palette Lists tab lists all the modified colour palette lists.

 

Parameter Description

Palette Lists
Lets you select the modified palette list to save, and deselect the ones you do not 
want to save.

Show Recovered Displays the recovered palettes in the list of modified palettes.

Select All Selects all modified palette lists in the list.

Deselect All Deselects all modified palette lists in the list.
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Close Gaps Dialog Box
The Close Gaps dialog box lets you close up drawing areas that not are closed. This may sometimes happen 
when painting. You can close small gaps in a drawing by creating small, invisible strokes between the two 
closest points to close the colour zone. You do not need to trace directly over the gap. You can draw it a few 
millimeters away. The two closest points automatically close the gap.

How to access the Close Gaps dialog box

 1. Select View >Show Strokes or press K to see a preview of the result.

 2. To flatten the strokes you draw, click the Auto-Flatten  button in the Tool Properties view.

 3. Select Drawing > Close Gaps or press Shift + F10 (Windows/Linux only).

The Close Gaps dialog box opens.

Parameter Description

Size Lets you set the size of the gap you want to be closed.

Apply to all drawings Closes all gaps in the drawing of the selected layer.
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Configure Line Art to Colour Art Dialog Box
The Configure Line Art to Colour Art dialog box lets you modify settings for the Line Art and Colour Art layers.

How to access the Configure Line Art to Colour Art dialog box

 1. In the Tools toolbar, select the Select tool. 

 2. In the Tool Properties view, hold down the Shift key and click on the Creatre Colour Art from Line Art button.

Parameter Description

Use rendered version of the 
drawing

Renders the drawing and vectorize it to calculate the position of the centreline 
that will produce the colour art stroke.

Maximum Resolution for 
rendered image

The size of the rendered image.

Threshold for rendered image The value of grey processed to create the rendered vectorized arts.

Fitting error for rendered Bez-
iers

This value represents how precise the fitting of the colour art zone in relation to 
the line art will be.

Source layer
Lets you select the layer (Line Art, Colour Art, Underlay or Overlay) you want the 
colour art to be created from.

Destination layer
Lets you select the layer (Line Art, Colour Art, Underlay or Overlay) you want the 
colour art to be created on.

Clear Destination Art Layer 
First

Deletes the content before the colour art is added. This is useful when you 
already have artwork on the destination layer.

Perform Line Art to Colour Art 
Operation Immediately

Performs the Create Colour Art from Line Art command when you click OK.
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Create Palette Dialog Box
The Create Palette dialog box lets you create a palette in Basic mode. For simple productions, it is recommended 
to use the Basic mode.  This setting stores the palettes automatically for you and saves them at the Scene level. 
When you use the Advanced Palette Lists mode, you can decide at which level you want to store your palettes: 
Environment, Job, Scene, or Element. 

How to access the Create Palette dialog box

 1. From the Colour view menu, select Palettes > New or click the New Palette button.

 l Make sure you have the rights to modify the palette list. If not, select  Edit > Edit Palette 
List Mode.

Parameter Description

New Palette Name Lets you enter a name for the new palette.
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Database Selector Dialog Box
The Database Selector dialog box lets you connect to your studio's central database when working on Harmony 
Server.

When you connect to the database, you cannot create new scenes directly from . The available scenes will be the 
ones that were previously created using the Control Center module. 

How to access the Database Selector dialog box

 1. Start  Paint.

The Database Selector dialog box opens.

Parameter Description

Environments Lets you select the scene's environment (project, movie).

Jobs Lets you select the scene's job (episode, sequence). 

Scenes Lets you select the scene.

Get rights to modify the scene
Allows you to modify the selected version of the scene and access the version 
manager during the opened session

Get rights to modify the scene 
version

Allows you to modify the currently selected scene version, but locks access to 
the version manager during the opened session.

Get rights to modify all scene 
assets

Automatically gets the rights to modify the scene and its assets. The user locking 
the scene using this option is the only one that can edit and save the scene 
version, all the drawings in that scene, all the palettes in the palette-list, both 
palette-lists, but not the library folders.

Version If you saved different versions of a scene, this lets you select one to open.

15



Chapter 2: Dialog Boxes     Element Manager Dialog Box

Element Manager Dialog Box
The Element Manager window lets you Opens the Element Manager window where you can add, delete or modify 
elements (drawing folders) in your scene. If you have drawing folders that are not linked to a column in your 
scene, use the Element Manager to delete them if needed. See xref Reference > Windows > Element Manager.

How to access the Element Manager window

 1. From the top menu, select Scene > Element Manager.

Parameter Description

Elements

Delete Elements Deletes the selected elements.

Delete Elements and 
Directories

Deletes  the selected layer and its directories (drawing folder).

Add/Modify Element

Name
Type in a new name in this field to create an element or to rename the selected 
element.

Vector
Select this option if the new element is a vector drawing or if you want to 
enable the parameters on the selected element in the Elements list.

Bitmap Format Lets you select the file format of the bitmap layer.

Scan Type
If you're planning to scan elements with the Toon Boom Harmony Scan 
module, select the scan type from the list.

Field Chart
If you're importing traditional animation, select the size of the paper on which 
the animation was drawn.

Add
Creates a new element with the current parameters entered in the Add/Modify 
Element section.

Modify Applies the parameter changes made to the selected element.
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Manage Tool Presets Dialog Box
The Tool Presets window lets you create new tool presets and manage them. 

How to access the Manage Tool Presets window

 1. Do one of the following:

 l From the top menu, select Windows > Toolbars > Tool Presets.

 l Right-click an empty area below the top menu and select Tool Presets.

 2. In the Tool Presets toolbar, click the Manage Presets  button.

Parameter Description

Icon Lets you select a preset to manage.

Import Lets you import an existing preset.

Export Lets you export a preset for use in other projects.

Delete Removes the preset from the list of tool presets.

Name Lets you change the name of the preset.

Icon list Lets you select an icon for the preset.

Folder icon Lets you select an image for the preset.

Shortcut Lets you assign a keyboard shortcut to the new preset.
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Colour Saves the current colour into the tool preset.

Tool

If you disable this option, only the colour will be associated. You could, for 
example, set three different colours with shortcuts not associated with any tool. 
The colour preset would then work on any selected tool. Selecting the brush tool 
was only a vehicle to get into the New Tool Preset dialog box. 

Update
After adjusting the settings for a preset, the current properties are applied to the 
presets, as well as any other changes you made in the Manage Tool Presets 
window.

18



Harmony 14 Paint - Reference Guide

New Tool Preset Dialog Box
The New Tool Preset dialog box lets you create new tool presets and manage them. 

Tool presets let you save a variety of settings and are very efficient for accessing the tools you use most often. That 
way, the tool is already set with the desired properties, such as colour, line thickness, whether to enable Draw 
Behind or Auto Flatten mode, and so on. You can create presets for these tools and many more: Brush, Pencil, 
Eraser, Rectangle, Ellipse, and Line. 

The difference between a tool preset and a brush preset is that when you save a tool preset, you have the option of 
saving the colour and assigning a shortcut, which you cannot do with brush presets.

How to access the New Tool Preset dialog box

 1. Do one of the following:

 l From the top menu, select Windows > Toolbars > Tool Presets.

 l Right-click an empty area below the top menu and select Tool Presets.

 2. In the Tool Presets toolbar, click the New Tool Preset   button.

Parameter Description

Name Lets you give the preset a meaningful name.

Icon list Lets you select an icon for the preset.

Folder icon Lets you select an image for the preset.

Shortcut Lets you assign a keyboard shortcut to the preset.

Colour Saves the current colour into the tool preset.

Tool

If you disable this option, only the colour will be associated. You could, for 
example, set three different colours with shortcuts not associated with any tool. 
The colour preset would then work on any selected tool. Selecting the brush tool 
was only a vehicle to get into the New Tool Preset dialog box. 
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Onion Skin and Light Table Transparency Dialog Box 
This dialog box lets you adjust the Onion Skin and Light table transparency parameters.

How to access the Onion Skin and Light Table Transparency dialog box 

 l In the Drawing view toolbar, click on the Top Light button to open the Onion Skin and Light Table Trans-
parency dialog box.

Command Description

Onion Skin Opacity
Sets the maximum opacity value for the onion skin opacity display.  Moving 
the slider all the way to the left = 0% opacity. Moving the slider all the way to 
the right = 100% opacity.

Lighttable Opacity
Sets the maximum opacity value for the light table display. Moving the slider 
all the way to the left = 0% opacity. Moving the slider all the way to the right 
= 100% opacity.

LightTable Wash
Sets the washed-out value for the light table display.  Moving the slider all the 
way to the left = 0% opacity. Moving the slider all the way to the right = 100% 
opacity.

Bitmap Background 
Wash

Sets the maximum opacity value for the background wash.   Moving the slider 
all the way to the left = 0% opacity. Moving the slider all the way to the right 
= 100% opacity. Only works for bitmap layers.

Pencil Lines Opacity
Sets the maximum opacity value for central vector lines (lines made by the 
Pencil or Shape tools). Moving the slider all the way to the left = 0% opacity. 
Moving the slider all the way to the right = 100% opacity.
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Palette Browser Dialog Box
When you start Toon Boom Harmony connected to the database, you can access the Palette Browser dialog box 
from the Palette Operations dialog box when you want to clone palettes. 

In Harmony, palettes are individual *.plt files that can be copied, transferred and stored. When a palette is created 
from Harmony, it needs to be stored somewhere. By default, the palette file is stored in the scene directory in a 
palette-library folder unless you specify a different location.

How to access the Palette Browser dialog box

 1. Start Paint and log in. 

 2. Close the Database Selector dialog box. 

 3. From the top menu, select Tools > Palette Operations. 

 1. In the Palette Operations dialog box that opens, select the palette you want to clone at the location and level 
in which it was stored. 

 2. Click Clone.

Parameter Description

Palette Location

Environment The production, project, feature film or series.

Job The episode and sequence from each environment.

Scene The scenes from each job.

Element The layers and columns in each scene.

Palette The scene palettes.

New Palette Name
Lets you enter a name for the new palette. There is no need to add the suffix 
"palette"  to the name as it is always recognized as a palette file.
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Palette List

Scene Palette List

The Scene Palette List is mainly used with cut-out animation. A cut-out character 
will often be divided in twenty to thirty different drawing elements that use the 
character's master palette. 

The palette list is stored at the scene level instead of the Element directory. This 
way, all palettes linked to this list will appear in every drawing element created in 
the scene. There is no need to manually load the palette in each element. 

Element Palette List

The Element Palette List is mainly used with traditional and paperless animation. 
Unlike cut-out animation, all columns (drawing elements) contain different 
characters, props, backgrounds and effects. The Element Palette List is used 
because you do not necessarily want all of the palettes for all of your elements 
linked in every column. 

The palette list is stored in the drawing element's directory instead of directly in 
the Scene level. This ensures that the links to the palettes appear only in the 
appropriate element. If you prefer to access a global palette list, link your palettes 
to the Scene Palette List.
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Palette Operations Dialog Box
When you start Toon Boom Harmony connected to the database, you can access the Palette Operations dialog box 
which lets you clone, rename, or delete palettes. 

In Harmony, palettes are individual *.plt files that can be copied, transferred and stored. When a palette is created 
from Harmony, it needs to be stored somewhere. By default, the palette file is stored in the scene directory in a 
palette-library folder unless you specify a different location.

There are four locations where you can find palette-library folders: Element, Scene, Job and Environment.

How to access the Palette Operations dialog box

 1. Start Paint and log in. 

 2. Close the Database Selector dialog box. 

 3. From the top menu, select Tools > Palette Operations. 

Parameter Description

Environment The production, project, feature film or series.

Job The episode and sequence from each environment.

Scene The scenes from each job.

Element The layers and columns in each scene.

Palette The scene palettes.

Description Notes, if any, of the project.

Clone
Opens the Palette Browser dialog box from which you can select the level in 
which to store the palette file.

Rename Lets you rename a palette.

Delete

Lets you delete a palette.

NOTE: It is not recommended to disable the warning message that appears 
when you are attempting to delete a palette as this operation cannot be 
undone.

Close Closes the Palette Operations dialog box.
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Pose Copier Dialog Box
The pose copier contains many buttons and other information to facilitate the insertion of poses in the animation.

Parameter Description

Preview Window Based on master template's generated thumbnails, previews currently selec-
ted frames.

UPD Updates the template with the newly selected template.

RST Reset the template's cache, getting rid of default destination information and 
excluded modules.

Template Name Name of the currently selected template.

Vertical Slider (SLV) Linked to the slv- node of the node system.

Horizontal Slider 1 (SLH) Linked to the slh- node of the node system. Default slider for the pose copier 
if no guide layers are created.

Horizontal Slider 2 (SLX) Linked to the slx- node of the node system.

Fill to Next Key Exposure Having this option checked will automatically extend the exposure of the 
pasted frame up to the next key.

Use Default Destination Module When enabled, the pasted keys will automatically refer to the destination 
defined in the option Set Default Destination Module.

Paste by Layer Name When this option is checked the pasted layers will look for the individual 

24



Harmony 14 Paint - Reference Guide

layer name instead of matching the hierarchy of the template. 

Set Default Destination Module Instead of selecting the destination every time, the layer set as default des-
tination will automatically paste the keys onto those layers.

Find This will center on the default destination in the timeline.

Paste Paste the current position of the pose copier onto the destination.

Vertical Currently selected frame on the vertical slider. (based on frame name in slv-
node)

Horizontal 1 Currently selected frame on the horizontal slider 1. (based on frame name in 
slh-node)

Horizontal 2 Currently selected frame on the horizontal slider 2. (based on frame name in 
slx-node)

Frame Frame number of the selected frame within the master template.
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Preferences Dialog Box
The Preferences dialog box lets you adjust preferences to suit your work style, allowing you to work more 
efficiently.

NOTE: To learn more about the individual preferences, refer to the Preferences guide.

NOTE: Some preferences require you to exit and restart the application, or close a view and reopen it.

How to access the Preferences dialog box

Do one of the following:

 l Select Edit > Preferences (Windows/Linux) or Harmony Paint > Preferences (Mac OS X). 

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).
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Remove Dirt Dialog Box
The Remove Dirt dialog box lets you select small dots and hairs on a drawing for removal.

When paper drawings are passed through a scanner, there can be some hair and dirt scattered across them. These 
lines and dots need to be cleaned. Harmony provides different tools to help get rid of them quickly.

How to access the Remove Dirt dialog box

 1. Do one of the following:

 l From the top menu, select Drawing > Remove Dirt.

 l Press Shift + D.

Parameter Description

Slider

Lets you adjust the amount of detail removed from the layer. 

Raising the Remove Dirt level will select bigger dots. When selecting larger dots, 
be careful not to lose small details like pupils and nostrils. Once you have chosen 
the level, you can apply it to the current drawing or the entire animation sequence. 
This is a quick way to get rid of most dirt and dust.

During this process, the dirt that will be removed is highlighted in red.

Apply to all drawings Applies the operation to all drawings in the layer.
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Remove Hair Dialog Box
The Remove Hair dialog box lets you remove any small strokes created in the Colour Art layer from very thick 
lines or filled zones. Increasing the Remove Hair level value will select larger strokes for removal from the 
drawing.

When paper drawings are passed through a scanner, there can be some hair and dirt scattered across them. 
These lines and dots need to be cleaned. Harmony provides different tools to help get rid of them quickly.

How to access the Remove Hair dialog box

 1. Select the drawing containing the drawing to clean.

 2. From the top menu, select View > Show Strokes to display the invisible lines or press K.

 3. In the top menu, select Drawing > Remove Hair.

Parameter Description

Slider Lets you adjust the number of length of hairs selected. 

Apply to all drawings Applies the operation to all drawings in the layer.
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Save Dialog Box
The Save dialog box lets you save a scene for the first time in Harmony Server.

How to access the Save dialog Box

 1. Make sure you have the necessary rights to save the current scene version. If you do not, you can acquire 
the rights by selecting File > Rights to Modify Scene Version or Rights to Modify Scene. 

 2. From the top menu, select File > Save or press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X). 

When saving the scene for the first time, the Save dialog box opens, prompting you to name the version.

 

Parameter Description

This Version Lets you enter a relevant name for the current version.

New Version
Lets you enter a relevant name to save your scene as a new version. Note that 
the drawing files are shared between versions. Only a new version of the timing, 
Xsheet, and Node view are saved (information contained in the xstage file).

Overwrite Existing Version Allows you to save the current state of your scene over an existing scene version.

Description Enter a short description of the current version.

Mark as Current
After selecting an existing version of your scene, you can make that version the 
current one that will open by default.
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Scripts Manager Dialog Box
The Scripts Manager dialog box lets you link a script to a toolbar button for quick and easy access. Once you 
select a script, you can add it to the toolbar, load a custom icon and add a tooltip.

How to access the Scripts Manager Dialog Box

 1. In the Scripting toolbar, click the Manage Scripts  button.

The Scripts Manager dialog box opens.

 

Parameter Description

Files A list of the available JavaScript files.

Functions A list of the available functions for the selected script.

In Toolbar Adds the selected script to the toolbar.

Execute Runs the script you selected. Press Esc to interrupt the execution of the script.

Customize Icon Lets you load a custom icon for the function. You can browse for a *.png, 
*.jpg or *.xpm file.

Customize Tooltip Lets you type in a tooltip for the function. When you hover over the button in the 
toolbar, your tooltip will appear.
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Tint Offset/Blend  Dialog Box 
You can offset, blend, or mix the colours in a colour palette using the sliders and increasing the Amount value.

How to access the Tint Offset/Blend dialog box

 1. From the Colour View  menu, select Palettes > Tint Panel or right-click and select Tint Panel.

The Blend/Offset Tint panel opens.

 

Parameter Description

Offset
Offsets the selected colours by the adjustments made using the HSB and RGB 
sliders. Use the Amount slider to adjust the degree of offset. Use the Alpha slider 
to adjust the opacity of the selected colour. 

Blend

Blends the selected colours with the colour swatch in the top-right corner. Use the 
Amount slider to adjust the degree of blend. A blend of 100% turns the selected 
colours into the same colour as the swatch. Adjusting the HSB and RGB sliders 
affect the swatch colour, which in turn affects the selected colours on the left. 
Use the Alpha slider to adjust the opacity of the swatch.

Mixer

Select a Base and Tint colour to form a third colour swatch. Use the slider just 
beneath to mix the Base and Tint colours by different amounts. This will affect the 
mixed swatch whether it is selected or not. Select either the Tint or Base swatch 
and use the HSB and RGB sliders to adjust its colour. This will affect the mixed 
swatch colour, which in turn affects the selected colours on the left.
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Toolbar Manager Dialog Box
The Toolbar Manager dialog box lets you customize the toolbar in any of the views. You can add your favourite 
tools to a toolbar for an efficient workflow.

How to access the Toolbar Manager dialog box

 1. Right-click on a toolbar in any view and select Customize. Note that the menu will not appear if you right-
click on a disabled icon.

 

Parameter Description

Available Tools Displays the complete list of tools available for customizing a toolbar.

Toolbar Displays a list of the tools currently available on the toolbar.

Default Restores the toolbar with its default items.
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Xsheet Column Width Dialog Box
The Xsheet Column Width dialog box lets modify the width of a column in the Xsheet view and use it as the default 
column width.

How to access the Xsheet Column Width Dialog Box

 1. In the Xsheet view, select a column.

 2. From the Xsheet menu, select View > Set Columns Width.

The Xsheet Column Width dialog box opens.

 

Parameter Description

Columns Width (pixels) Lets you set the width of the selected columns (in pixels).

Apply
Applies the value you entered to the selected column without closing the dialog 
box.

Set As Default Uses the value you entered as the default for all columns in the Xsheet.
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Chapter 3: Tools Properties
Harmony has a wide variety of drawing and manipulation tools and each one of them has a series of options and 
modes available in the Tool Properties view. This section covers these options.  
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Brush Tool Properties (Vector)
When you're drawing on a vector layer and select the Brush  tool, its properties and options appear in the Tool 
Properties view.

Icon Tool Name Description

 Previewing the Stroke

The Preview area lets you see a preview of the selected or customized 
stroke. You can click on the Show Extended Properties arrow to display 
advanced customization parameters.

 Maximum Size
Defines the maximum size of your drawing tool. This parameter defines 
the  width of the stroke.

 Smoothing
Defines the number of control points added to the centre line. The fewer 
the control points the smoother (but less faithful) the line.

 Brush Presets
Presets are created by saving the properties of the current tool to a new 
preset, which you can reuse for repeated tasks. You can create as many 
presets as you need.

New Brush Allows to create a new preset.

New Dynamic Brush Allows you to create a new dynamic brush to clone custom patterns. 

Delete Brush Allows you to delete your custom presets. 

 Rename Brush Allows you to rename a custom preset.

 Import Brushes
Allows you to import a set of XML Harmony presets previously exported 
via the Export Brushes command. 
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 Export Brushes
Allows you to export Harmony presets to backup or import on a different 
computer. 

 
Small Thumbnail, Large 
Thumbnail, and Stroke 
View

Allows you to display the presets as small square thumbnails, large 
square thumbnails or a list of stroke preview. 

Draw Behind

When drawing on vector layers, the Draw Behind mode lets you paint 
behind existing art. By default, strokes appear over your work until you 
release the tool.

Repaint Brush

The Repaint Brush  is used to repaint zones that have already been 
painted, it will not affect empty zones or pencil lines. You can use this 
mode to paint tones or highlights onto your character.

Automatically Create 
Colour Art 

As you draw in the Line Art layer, the Automatically Create Colour Art  
option instantly creates the corresponding strokes in the Colour Art layer.

Auto-Flatten Mode

When enabled, the Auto-Flatten  mode automatically flattens the new lines 
created with the existing artwork as you draw in the Drawingview. Brush 
strokes will flatten with brush strokes and pencil lines will flatten with 
pencil lines.

Respect Protected Col-
our

The Respect Protected Colour  option prevent the colours you marked as 
protected, in the Colour view, to be repainted using the Repaint Brush 
mode or any of the painting tools.

Use Stored Colour 
Gradient

The Use Stored Colour Gradient  option makes your tool use the previously 
stored gradient position. This way, every new brush line or colour fill will 
use the stored gradient position.

Size and Smoothness Tab 
You can access advanced properties by clicking on the Previewing the Stoke button in the Tool Properties view. 
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Tool Name Description

Maximum Size
Defines the maximum size of your drawing tool. This parameter defines the  width of 
the stroke.

Minimum Size
Defines the minimum size of your stroke as a percentage of the maximum size. If 
you do not have pressure sensitivity from a pen table, the minimum size value will be 
ignored. 

Smoothing
Defines the number of control points added to the centre line. The fewer the control 
points the smoother (but less faithful) the line.

Contour Smoothing
Defines the number of points on the contour share of your stroke. This will smooth 
out the bumps and waves on tour contour shape of your brush strokes.

Tip Shape

Lets you select a tip shape—from round and square ones to star shaped. This option 
is disabled when using a textured brush.

Paper Texture Tab 
You can create texture brushes to draw on vector layers. Enable the Paper Texture option to access the options. 

Parameter Description

Hardness

The hardness value corresponds to the softness of the line edge. The lower the 
value, the softer the line edge will be. The higher the value, the sharper the line 

edge will be.  
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Maximum Opacity
This value corresponds to the transparency of the stroke when the pressure is 
heavy.  

Minimum Opacity

This value corresponds to the transparency of the stroke when the pressure is 
light and is a percentage of the Maximum Opacity value. 
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Brush Tool Properties (Bitmap)
When you're drawing on a bitmap layer and select the Brush  tool, its properties and options appear in the Tool 
Properties view.

Icon Tool Name Description

 Previewing the Stroke

The Preview area lets you see a preview of the selected or customized 
stroke. You can click on the Show Extended Properties arrow to display 
advanced customization parameters.

 Maximum Size
Defines the maximum size of your drawing tool. This parameter defines 
the  width of the stroke.

 Flow

The Flow parameter lets Lets you set the range for the rate at which paint 
flows from the brush. The analogy works better with a pen. The greater the 
flow, the more ink comes out, which gives you a more consistent line 
colour and texture. If the flow is light,  then the colour and texture of the line 
may look spotty. The flow works with the pressure sensitivity of a pen 
tablet.

 Opacity
The Opacity parameter are where you set the transparency for a brush 
stroke. This works with the pressure sensitivity of a pen tablet.

 Brush Presets
Presets are created by saving the properties of the current tool to a new 
preset, which you can reuse for repeated tasks. You can create as many 
presets as you need.
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New Brush Allows to create a new preset.

Delete Brush Allows you to delete your custom presets. 

 Rename Brush Allows you to rename a custom preset.

 Import Brushes
Allows you to import a set of XML Harmony presets previously exported 
via the Export Brushes command. 

 Export Brushes
Allows you to export Harmony presets to backup or import on a different 
computer. 

 
Small Thumbnail, Large 
Thumbnail, and Stroke 
View

Allows you to display the presets as small square thumbnails, large 
square thumbnails or a list of stroke preview. 

Draw Behind

When drawing on vector layers, the Draw Behind mode lets you paint 
behind existing art. By default, strokes appear over your work until you 
release the tool.

Repaint Brush

The Repaint Brush  is used to repaint zones that have already been 
painted, it will not affect empty zones or pencil lines. You can use this 
mode to paint tones or highlights onto your character.
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Tip Tab

Tool Name Description
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Brush Tip 
Library

This is where you select the shape of the brush tip. By default it is round. Note that some tips are 
designed to have semitransparent areas, even when the maximum brush opacity is set to 100%.

To create a custom brush tip, you must prepare the file ahead of time, either in Harmony or in a third-
party software, such as Adobe Photoshop. Colour is not supported and transparency is not 
supported in the traditional sense. Black appears as 100% opaque, white appears as 100% 
transparent and all the shades of grey in between appear as varying degrees of semitransparency. A 
range of file formats are supported—.jpeg, .png, .tif, .psd, .tga to name a few. Alpha channels are 
disregarded on import. It is recommended that your file be between 100 x 100 pixels and 400 x 400 
pixels. 

You can also import brush tips that you exported from Harmony, so you can share them with 
colleagues.

Minimum 
and 
Maximum 
Size

The minimum and maximum sizes of your drawing tool produce the thick and thin effect on your 
stroke. This works with the pressure sensitivity of a pen tablet.

 l Maximum Size: Defines the maximum  width of the stroke.

 l Minimum Size: Defines the minimum width of the stroke in relation to and as a percentage of 
the maximum size.

NOTE: Setting the Minimum Size value to 100% eliminates the possibility of creating width vari-
ation on your stroke. In other words, you would be forcing a uniform line width using the Max-
imum Size value.

Roundness 
and Angle

The Roundness and Angle parameters allow you to change the shape and orientation of the brush 
tip.

 l Roundness: Squashes the height of the brush tip from its centre point. 100% roundness = 
the native height of the brush tip. A smaller percentage will make the brush tip look flatter and 
more narrow. The squashing is NOT relative to the angle value—if the brush tip is rotated, the 
squashing function still uses the brush tip's original orientation.

 l Angle: Rotates the brush tip counter-clockwise. 0° = the brush tip's native orientation.
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Hardness

The Hardness and Spacing parameters allow you to change the softness and spacing of the marks 
made by the brush tip. You can preview the hardness and spacing at the top of the Bitmap Brush 
Properties window, stroke preview area.

The hardness value corresponds to the softness of the brush tip's edges. The lower the value, the 
softer the tip edge. The higher the value, the sharper the tip edge. Be aware that some brush tips are 
not 100% opaque, so they will always appear somewhat soft, even at 100% hardness.

Spacing

Defines the amount of space between each stamp of the brush. A value of 100% sets the stamp 
marks edge to edge, if there is no white space around the shape. The larger the value, the greater 
the space between marks. A really large value can make the brush stroke appear as a string of 
individual marks. Conversely, a small spacing value will give the appearance of a fluid brush stroke. 

Spacing is only evident when making a continuous stroke. 

Ran-
domness

The Randomness parameters let you create a varied bitmap brush stroke. Refining these options 
can give your stroke a lovely, non-mechanical look.

Random 
Size

You can create variation between the thick and thin of your brush stroke just by setting the 
Maximum and Minimum Size values. If you add randomness to the mix, pressure sensitivity from 
your drawing tablet will still be applied. Light pressure will create random values around the 
minimum, while heavy pressure will create random values closer to the maximum. The larger the 
percentage, the larger the range of random variation.  
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NOTE: Setting the Minimum Size to 100% eliminates the possibility of creating width variation 
on your stroke, whether you are applying randomness or not. Therefore, you would be forcing a 
uniform line width using the Maximum Size value.

Random 
Angle

Sets the range for random rotation around the set Angle value. For example, if the Angle is set to 45° 
and the Random Angle set to 10°, the software will choose values between 40°–50° (plus or minus 5 
degrees, equaling a total of 10 degrees).

Random 
Spacing

Sets the range for random spacing around the set Spacing value. For example, if the Spacing is set 
to 50% and the Random Spacing is set to 10%, then Harmony will choose values between 45%–
55% (plus or minus 5 percent, equaling a total of 10 percent).
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Transparency Tab

Tool Name Description

Maximum and Minimum Flow

The Maximum and Minimum Flow parameters let you set the range for the rate 
at which paint flows from your brush. The analogy works better with a pen. 
The greater the flow, the more ink comes out, hence the more consistent the 
colour and texture of the line. If the flow is light,  then the colour and texture of 
the line may look spotty. This feature works with the pressure sensitivity of a 
pen tablet.

 l Maximum Flow: Sets the maximum rate at which colour and texture 
are applied as you create a fluid stroke. 

 l Minimum Flow: Sets the minimum rate at which colour and texture are 
applied as you create a fluid stroke. It is defined as a percentage of the 
Maximum Flow value. If the Minimum Flow value is set to 100%, then 
tablet pressure sensitivity will no longer be applicable. The flow will be 
set to the constant rate of the Maximum Flow value.
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Maximum Opacity and Min-
imum Opacity

The Maximum and Minimum Opacity parameters are where you set the 
opacity range for a brush mark. This works with the pressure sensitivity of a 
pen tablet.

 l Maximum Opacity: Sets the  transparency limit of the brush mark 
when the pressure is heavy. 

 l Minimum Opacity: Sets the transparency limit of the brush mark when 
the pressure is very light. It is defined as a percentage of the Maximum 
Opacity value. If the Minimum Opacity value is set to 100%, then tab-
let pressure sensitivity will no longer be applicable. The opacity will be 
set to the constant rate of the Maximum Opacity value.

Randomness
Th Randomness parameter lets you set the range for the randomness of the 
flow and opacity. This works with the pressure sensitivity of a pen tablet.

Randomness Flow

You can create variation in the flow of your brush stroke just by setting the 
Maximum and Minimum Flow values. If you add randomness to the mix, 
pressure sensitivity from your drawing tablet will still be applied. Light 
pressure will create random values around the minimum, while heavy 
pressure will create random values closer to the maximum. The larger the 
percentage, the larger the range of random variation. 
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NOTE: Setting the Minimum Flow value to 100% eliminates the pos-
sibility of creating flow variation on your stroke, whether you are applying 
randomness or not. That is, you would be forcing a uniform flow using the 
Maximum Flow value.

Random Opacity

You can create variation in the opacity of your brush stroke just by setting the 
Maximum and Minimum Opacity values. If you add randomness to the mix, 
pressure sensitivity from your drawing tablet will still be applied. Light 
pressure will create random values around the minimum, while heavy 
pressure will create random values closer to the maximum. The larger the 
percentage, the larger the range of random variation.

NOTE: Setting the Minimum Opacity value to 100% eliminates the pos-
sibility of creating opacity variation on your stroke, whether you are apply-
ing randomness or not. That is, you would be forcing a uniform opacity 
using the Maximum Opacity value.50
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Dual Tip Tab
The Dual Tip tab lets you set the parameters for creating a dual tip brush. The primary bitmap brush tip and the dual 
tip always work together. You can set the parameters for the primary tip in the Tip tab and those for the dual tip in the 
Dual Tip tab. The Blend mode you select determines how the tips are combined. 

You must select the Dual Tip option to access the tab's parameters. 

By default, the Blend Mode is set to Multiply and the Random Angle to 360°.
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Tool Name Description

Blend Mode The Blend modes let you decide how the primary tip and the dual tip are combined.

Multiply

This is the default blend mode. When the two brush tips are combined in this 
mode, they essentially cut each other out in overlapping areas, where one or both 
tips have an area of 100% transparency. The less opaque the brush tips are, the 
lighter their combination. 
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Colour Dodge
In this mode, the primary tip cuts out the shape of the dual tip. Where the tip 
shapes overlap, within the boundaries of the primary shape, the colour and opacity 
appear darker.
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Combine
This mode treats the two tips as two different and separate brushes that have the 
same colour and follow the same path.
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Paper Texture Tab
The Paper Texture tab lets you view and select a paper-like texture for your brush. You can also import paper 
textures that were previously exported.

You must select this option to access the tab's parameters.
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Tool 
Name

Description

Texture 
Scale

Increase or decreases the size of the paper texture.

Additive
This option layers the texture on top of itself as you scribble overlapping lines in one continuous 
stroke.  If this option is turned off, areas of overlapping lines from a single, continuous stroke will 
appear the same, in terms of darkness and texture, as non-overlapping areas.
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Aligned

This option defines the way separate, overlapping strokes behave. If this option is enabled, the 
paper texture's position does not change with each sweep of the brush. If this option is disabled, 
each sweep of the brush produces a different texture position. The texture orientation always stays 
the same.
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Close Gap Tool Properties
When you select the Close Gap tool, its properties and options appears in the Tool Properties view. 

Icon Tool Name Description

Auto-Flatten Mode When enabled, the Auto-Flatten  mode automatically 
flattens the new lines created with the existing 
artwork as you draw in the Drawingview. Brush 
strokes will flatten with brush strokes and pencil 
lines will flatten with pencil lines.

58



Harmony 14 Paint - Reference Guide

Contour Editor Tool Properties
When you select the Contour Editor tool, its properties and options appear in the Tool Properties view.

Icon Tool Name Description

Lasso Sets the selection mode to Lasso. Click and hold Alt to 
temporarily switch between the Marquee and Lasso 
modes.

Marquee Sets the selection mode to Marquee. Click and hold Alt 
to temporarily switch between the Marquee and Lasso 
modes.

Snap to Contour Snaps your selection or point to any line you position it 
on. As soon as you move it close enough to another 
line, your point or selection will snap to it. 

 

Snap and Align Snaps the selected anchor point to any existing line 
while displaying temporary rulers as a guide that you 
can also snap your anchor point to. 

Show Contour Editor Con-
trols

Use the Show Contour Editor Controls  option to show 
the contour editor controls. You can use these controls 
to scale, reposition and rotate the selected anchor 
points.

Apply to Line and Colour Art The Apply to Line and Colour Art  option uses the 
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concept of Line Art and Colour Art layers. Use this 
option to apply an action such as selecting, resizing or 
erasing a drawing on both Line Art and Colour Art 
layers, as well as the Overlay and Underlay layers.

Smooth Selection The Smooth operation lets you smooth out selected 
drawing strokes and remove extra points.

 l From the top menu, select Selected  > Smooth 
or press Alt + Shift + S.

Split Pencil Line and Join 
Pencil Lines

When drawing with the Polyline tool, your drawing has 
an even line thickness. You can use the Pencil Editor to 
adjust the thickness point by point, but if you want to 
adjust it quicker, you can use the Split Pencil Line and 
Point Pencil Lines options to create segments and 
apply a pencil stencil to your drawing. Note that if you 
did not join the pencil lines on your polyline stroke, the 
segments between the points will act as separated 
segments.
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Cutter Tool Properties
When you select the Cutter  tool, its properties and options appear in the Tool Properties view.

Ico-
n

Tool 
Name

Description

Lasso Sets the selection mode to Lasso. Click and hold Alt to temporarily switch between the Marquee 
and Lasso modes.

Marquee Sets the selection mode to Marquee. Click and hold Alt to temporarily switch between the Mar-
quee and Lasso modes.

Apply to 
Line and 
Colour Art

The Apply to Line and Colour Art  option uses the concept of Line Art and Colour Art layers. Use 
this option to apply an action such as selecting, resizing or erasing a drawing on both Line Art and 
Colour Art layers, as well as the Overlay and Underlay layers.

Use 
Mouse 
Gesture 

When using the Lasso  selection type, the Use Mouse Gesture  option lets you automatically 
delete any extra sections of line in your artwork by simply dragging your mouse over it. 

NOTE: For this operation to work, you lines CANNOT be flattened.

Use 
Mouse 
Gesture 
Breaker 
Mode

When using the Lasso  selection type, the Use Mouse Gesture Breaker Mode  option lets you 
draw an invisible stroke on a pencil line to cut it in two individual objects. Once a pencil line is cut 
with this option, you will be able to select the two portions independently with either the Cutter 
tool, Pencil Editor tool or Select tool.
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NOTE: This option only works with pencil lines.

 Tip Style If you erase the end of a pencil line or erase a pencil line through the centre, new line tips or line 
ends are created. Use the Tip Style option to customize the  shape of the new line tips that are 
created.

 Antiali-
asing

When drawing on a bitmap layer, lines are no longer clean vector shapes. For the edges to be 
smooth, a slight amount of antialiasing is used. When using the Cutter tool, you can cut a portion 
of your drawing with or without antialiasing. By default, the option is enabled. If you want to cut 
your drawing using a hard edge, you can select the Antialiasing Off option. 

Flip Hori-
zontal

Flips the current selection horizontally.

Flip Ver-
tical

Flips the current selection vertically.

Rotate 90 
Degrees 
CW

Rotates the current selection 90 degrees clockwise.

Rotate 90 
Degrees 
CCW

Rotates the current selection 90 degrees counter-clockwise.
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Drawing Pivot Tool Properties
The Drawing Pivot  tool lets you set the pivots on your character. You can set the drawing pivots on drawings and 
symbols.

Icon Tool Name Description

Setting the Drawing Pivot 
for Symbols on All Frames

The Set the Pivot for Symbol on All Frames  option is 
enabled by default. When you set a drawing pivot on a 
symbol, all of its cells use the same drawing pivot. This 
means you do not have to set a drawing pivot on all 
frames. Once you set it, it is done.

If you prefer to set a different drawing pivot for a series 
of cells, you can deselect the option and set your pivots 
on each cell or cell range.

NOTE: If you have already set several different 
pivots on your symbol's cells and selected the Set 
the Pivot for Symbol on All Frames option, once 
you set a new pivot on the same symbol, all of its 
pivots will be reset and will use your new pivot.

Snap to Contour Snaps your selection or point to any line you position it 
on. As soon as you move it close enough to another 
line, your point or selection will snap to it.

Snap and Align Snaps the selected anchor point to any existing line 
while displaying temporary rulers as a guide that you 
can also snap your anchor point to.

Snap to Grid Snaps your selection following the currently enabled 
grid. 

Reset Pivot When you click the Reset Pivot  option, the drawing 
pivot of the selected drawing or symbol is reset to the 
centre of the Camera view.
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Copying Pivot on Parent 
Symbol

When you import new extra drawings, such as hands 
and mouths, you can use the drawing pivot that was set 
on your drawings and report them to the symbol's cells. 
Use the Copy Pivot to Parent Symbol   command for 
this.

NOTE: When you copy drawing pivots to the par-
ent symbol, there is no link between the drawings' 
pivots and the symbol's pivots. If you modify the 
drawing pivot later, it will not link to the symbol. 
You would need to perform the operation again. If 
you need to modify the symbol's pivots, you can do 
it directly on the symbol's cells.
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Dropper Tool Properties
When you select the Dropper tool, its properties and options appears in the Tool Properties view. 

Icon Tool Name Description

Sample All Layers On bitmap layers, if strokes with transparency located 
on separated art layers overlap, the Dropper will pick 
the combination of the two colours. When disabled, the 
Dropper will pick the colour on the current art layer.

Do not Pick Transparency On bitmap layers, when enabled, the dropper will pick 
the colour at 100% of opacity even if the selection has 
some transparency.
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Ellipse Tool Properties
When you select the Ellipse tool, its properties and options appear in the Tool Properties view. There are a few 
less options available when working on a bitmap layer. 

Icon Tool Name Description

 Previewing the Stroke

The Preview area lets you see a preview of the selected or customized 
stroke. You can click on the Show Extended Properties arrow to 
display advanced customization parameters.

 Size
Defines the maximum size of your drawing tool. This parameter defines 
the  width of the stroke.

 Shape You can adjust the start, end, and joint  style of a pencil line.
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 l Start: Lets you select the style of the start  tip, which is the first 
tip you drew. You can choose between Round or Flat style.

 l End: Lets you select the style of the end tip, which is the last tip 
you drew. You can choose between Round or Flat style.

 l Join: Lets you select the joint style. The joints are where the line 
curves abruptly. You could also define the Join style as the 
corner style. You can choose between Round, Mitre and Bevel 
style.

 Presets

Harmony provides a variety of presets and also lets you create and 
save your own. It is a good idea to create and save pencils with precise 
sizes and parameters when you draw and design for efficiency and 
consistency. 

All tools using pencil lines share the same preset list. Therefore, the 
Polyline, Line, Rectangle, Ellipse, and Pencil tools share the same 
preset list.

New Brush Allows to create a new preset.

Delete Brush Allows you to delete your custom presets. 

 Rename Brush Allows you to rename a custom preset.

 Import Brushes
Allows you to import a set of XML Harmony presets previously 
exported via the Export Brushes command. 

 Export Brushes
Allows you to export Harmony presets to backup or import on a 
different computer. 

 
Small Thumbnail, Large 
Thumbnail, and Stroke 
View

Allows you to display the presets as small square thumbnails, large 
square thumbnails or a list of stroke preview. 

Draw Behind

When drawing on vector layers, the Draw Behind mode lets you paint 
behind existing art. By default, strokes appear over your work until you 
release the tool.

Automatic Filling

Use the Automatic Filling  option to automatically fill your shape with the 
selected colour as you draw. By default, the Shape tool creates the 
outline of an empty shape that you can later fill using the Paint tool. 
This option is unavailable for the line tool. 

67



Chapter 3: Tools Properties     Ellipse Tool Properties

Snap to Contour
Snaps your selection or point to any line you position it on. As soon as 
you move it close enough to another line, your point or selection will 
snap to it.

Snap and Align
Snaps the selected anchor point to any existing line while displaying 
temporary rulers as a guide that you can also snap your anchor point to.

Snap to Grid

Snaps your selection following the currently enabled grid. 

Automatically Create 
Colour Art 

As you draw in the Line Art layer, the Automatically Create Colour Art  
option instantly creates the corresponding strokes in the Colour Art 
layer.

Auto-Flatten Mode

When enabled, the Auto-Flatten  mode automatically flattens the new 
lines created with the existing artwork as you draw in the Drawingview. 
Brush strokes will flatten with brush strokes and pencil lines will flatten 
with pencil lines.

NOTE: 
Using the Select tool, you can use select and remove a segment of 
flattened pencil lines. Overlapping pencil lines drawn with the Auto-
Flatten mode are essentially cut into segments by the overlap and 
can be treated as individual lines.
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Use Stored Colour Gradi-
ent

The Use Stored Colour Gradient  option makes your tool use the 
previously stored gradient position. This way, every new brush line or 
colour fill will use the stored gradient position.

 Draw Circle
Enable this option to draw perfect circle (ratio 1:1) without holding any 
keyboard shortcuts. As an alternative, you can hold down the Shift key.

Size and Smoothness Tab 
You can access advanced properties by clicking on the Previewing the Stoke button in the Tool Properties view. 

Tool Name Description

Maximum Size
Defines the maximum size of your drawing tool. This parameter defines the  width of 
the stroke.

Minimum Size
Defines the minimum size of your stroke as a percentage of the maximum size. If 
you do not have pressure sensitivity from a pen table, the minimum size value will be 
ignored. 

Smoothing
Defines the number of control points added to the centre line. The fewer the control 
points the smoother (but less faithful) the line.

Contour Smoothing
Defines the number of points on the contour share of your stroke. This will smooth 
out the bumps and waves on tour contour shape of your brush strokes.

Shape

You can adjust the start, end, and joint  style of a pencil line.

 l Start: Lets you select the style of the start  tip, which is the first tip you drew. 
You can choose between Round or Flat style.

 l End: Lets you select the style of the end tip, which is the last tip you drew. 
You can choose between Round or Flat style.

 l Join: Lets you select the joint style. The joints are where the line curves 
abruptly. You could also define the Join style as the corner style. You can 
choose between Round, Mitre and Bevel style.
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Texture Tab 
You can access advanced properties by clicking on the Previewing the Stoke button in the Tool Properties view. 

  

Icon Tool Name Description

Copy to Preferences You can add a pencil texture to your preset preferences. 

 New Texture Adds a new custom pencil texture to the list.

 Delete Texture Deletes a texture preset from the list.

 Rename Texture Renames the selected texture to keep the list organized.

 Presets
Harmony provides a variety of pencil texture presets and also lets you 
create and save your own.

 Pencil Texture Palette
Displays the colour palette assigned to hold the pencil textures. Use 
the Colour View menu to assign a new palette.
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Envelope Tool Properties
Selecting the Envelope tool displays its properties and options in the Tool Properties view. 

Icon Tool Name Description

 Width and Height Increase the width and height values to add more 
columns and rows to the deformation grids.

Lasso Sets the selection mode to Lasso. Click and hold Alt to 
temporarily switch between the Marquee and Lasso 
modes.

Marquee Sets the selection mode to Marquee. Click and hold Alt 
to temporarily switch between the Marquee and Lasso 
modes.

Snap to Contour Snaps your selection or point to any line you position it 
on. As soon as you move it close enough to another 
line, your point or selection will snap to it.

Snap and Align Snaps the selected anchor point to any existing line 
while displaying temporary rulers as a guide that you 
can also snap your anchor point to.

Snap to Grid Snaps your selection following the currently enabled 
grid. 
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Show Advanced Controls To display more controls,you can click on the Show 
Advanced Controls  button.

Apply to Line and Colour Art The Apply to Line and Colour Art  option uses the 
concept of Line Art and Colour Art layers. Use this 
option to apply an action such as selecting, resizing or 
erasing a drawing on both Line Art and Colour Art 
layers, as well as the Overlay and Underlay layers.

Flip Horizontal Flips the current selection horizontally.

Flip Vertical Flips the current selection vertically.

Rotate 90 Degrees CW Rotates the current selection 90 degrees clockwise.

Rotate 90 Degrees CCW Rotates the current selection 90 degrees counter-clock-
wise.

Smooth You can modify the central line smoothness  of your line 
using this option. This parameter smooths the deformed 
lines. Increasing the value will result in a smoother line 
with fewer control points. The more you increase the 
value, the less details and curves you will get. Use the 
left and right arrows to increment the value by one full 
unit. Use the Up - Down slider to quickly increment the 
value.
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Eraser Tool Properties
When you're drawing on vector layer and you select the Eraser  tool, its properties and options appear in the Tool 
Properties view.

The bitmap eraser options are identical to those of the bitmap brush with one obvious exception. Instead of 
customizing the parameters of a mark or stroke, you will be customizing the parameters for the absence of a mark or 
stroke. 

It is a good idea to create an eraser preset with the identical properties of a brush preset and to use them as a pair. 
That way, when part of a stroke is erased, its soft textured look is not interrupted with a hard edged eraser mark.

Icon Tool Name Description

 Previewing the Stroke

The Preview area lets you see a preview of the selected or customized 
stroke. You can click on the Show Extended Properties arrow to display 
advanced customization parameters.

 Maximum Size
Defines the maximum size of your drawing tool. This parameter defines 
the  width of the stroke.

 Smoothing
Defines the number of control points added to the centre line. The fewer 
the control points the smoother (but less faithful) the line.

 Eraser Presets
Presets are created by saving the properties of the current tool to a new 
preset, which you can reuse for repeated tasks. You can create as many 
presets as you need.

New Brush Allows to create a new preset.
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Delete Brush Allows you to delete your custom presets. 

 Rename Brush Allows you to rename a custom preset.

 Import Brushes
Allows you to import a set of XML Harmony presets previously exported 
via the Export Brushes command. 

 Export Brushes
Allows you to export Harmony presets to backup or import on a different 
computer. 

 
Small Thumbnail, Large 
Thumbnail, and Stroke 
View

Allows you to display the presets as small square thumbnails, large 
square thumbnails or a list of stroke preview. 

Apply to Line and Colour 
Art

The Apply to Line and Colour Art  option uses the concept of Line Art and 
Colour Art layers. Use this option to apply an action such as selecting, 
resizing or erasing a drawing on both Line Art and Colour Art layers, as 
well as the Overlay and Underlay layers.

 Tip Style

If you erase the end of a pencil line or erase a pencil line through the 
centre, new line tips or line ends are created. Use the Tip Style option to 
customize the  shape of the new line tips that are created.

Apply to Synced Drawing 
Layers

Applies to the Camera view only. Works in conjunction with the Works on 
Single Drawing. Only selects lines from the current drawing and drawing 
layers synced to the current drawing.

Size and Smoothness Tab 
You can access advanced properties by clicking on the Previewing the Stoke button in the Tool Properties view. 

Tool Name Description
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Maximum Size
Defines the maximum size of your drawing tool. This parameter defines the  width 
of the stroke.

Minimum Size
Defines the minimum size of your stroke as a percentage of the maximum size. If 
you do not have pressure sensitivity from a pen table, the minimum size value will 
be ignored. 

Smoothing
Defines the number of control points added to the centre line. The fewer the control 
points the smoother (but less faithful) the line.

Contour Smoothing
Defines the number of points on the contour share of your stroke. This will smooth 
out the bumps and waves on tour contour shape of your brush strokes.

Tip Shape

Lets you select a tip shape—from round and square ones to star shaped. This 
option is disabled when using a textured brush.

Soft Eraser Tab 
You can create texture brushes to draw on vector layers. Enable the Soft Eraser option to access the options.  

Hardness
Defines the softness of the stroke edge. The lower the value, the softer the stroke 
edge will be. The higher the value, the sharper the stroke edge will be.

Saturation
Lets you adjust the softness of edge feathering. Works in conjunction with the 
Hardness, e.g. 100% Hardness will yield no results in saturation change. 0% 
Hardness will allow a fine tuning of the feathering of the soft stroke edge.

Maximum Opacity

The transparency of the brush when the pressure is heavy.  A smaller value will 
leave semi-transparent colour and texture. A larger value will ensure that 
everything is properly erased. This option in unavailable if the Keep Vectors 
option is disabled.

Minimum Opacity

Sets the minimum transparency of the brush, in relation to the Maximum Opacity, 
when the pressure is very light. A smaller value will leave semi-transparent colour 
and texture. A larger value will ensure that everything is properly erased.  This 
option in unavailable if the Keep Vectors option is disabled.

Keep Vectors

Keeps the vector frames around your strokes intact, only the texture fill dis-
appears. Disabling this option will cut the stroke's vector frame into different 
pieces when the Eraser tool passes over it. If you disable this option, the max-
imum and minimum opacity sliders are disabled as well.
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Ink Tool Properties
When you select the Ink tool, its properties and options appear in the Tool Properties view.

Icon Tool Name Tool

Lasso
Sets the selection mode to Lasso. Click and hold 
Alt to temporarily switch between the Marquee 
and Lasso modes. 

Marquee
Sets the selection mode to Marquee. Click and 
hold Alt to temporarily switch between the 
Marquee and Lasso modes. 

Show Inkable Lines

Highlights all pencil lines (no brush strokes) on the 
selected layer. Pencil line segments that are 
already inked with the selected swatch colour 
from the colour palette are also not highlighted.

Be Smart on Connecting Lines

As you hover and move the cursor across 
intersecting pencil lines, the path that you create 
will be highlighted. When you click on your mouse 
or stylus the highlighted segments are inked.  With 
this option disabled, all the intersecting segments 
that your cursor comes near will be highlighted 
and become part of the selection, even if they 
were not situated in the direction of the chosen 
path.

NOTE: This option only works if the Ink tool 
is in Hover mode.

Select Mode

Use this mode instead of the Hover Mode. In the 
Hover Mode, any potentially inkable pencil line 
will have its central vector line highlighted as the 
Ink tool’s cursor hovers over it. Use Ctrl (Win-
dows/Linux) or ⌘  (Mac OS X) to toggle between 
the two modes.

Select Newly Painted, Repainted, 
and Unpainted Contours/Lines

In the Paint   tool properties, this option  keeps a 
selection highlighted around the latest painted 
zone after using the Paint, Repaint, Unpaint, or 
Paint Unpainted tool.
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Raise

As you ink the pencil line, the segment will be 
moved on top of the other intersecting strokes. 
Disable this option for the line to be sent behind. 
Hold down the Alt key to perform the opposite 
operation as you ink.

Mitre

As you hover over two perpendicular or nearly per-
pendicular segments, a highlighted path with a 
corner is created. Clicking on these highlighted 
segments inks both segments and makes them 
appear as a single stroke with a corner or bend. 
Options include: As Is, Round, Miter, and Bevel.

Tip Style
Lets you customize the edge of the Ink tool. 
Options include: Round, Flat, and Bevel.
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Line Tool Properties
When you select the Line tool, its properties and options appear in the Tool Properties view. There are a few less 
options available when working on a bitmap layer. 

Icon Tool Name Description

 Previewing the Stroke

The Preview area lets you see a preview of the selected or customized 
stroke. You can click on the Show Extended Properties arrow to display 
advanced customization parameters.

 Size
Defines the maximum size of your drawing tool. This parameter defines 
the  width of the stroke.

 Shape You can adjust the start, end, and joint  style of a pencil line.
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 l Start: Lets you select the style of the start  tip, which is the first 
tip you drew. You can choose between Round or Flat style.

 l End: Lets you select the style of the end tip, which is the last tip 
you drew. You can choose between Round or Flat style.

 l Join: Lets you select the joint style. The joints are where the line 
curves abruptly. You could also define the Join style as the 
corner style. You can choose between Round, Mitre and Bevel 
style.

 Presets

Harmony provides a variety of presets and also lets you create and save 
your own. It is a good idea to create and save pencils with precise sizes 
and parameters when you draw and design for efficiency and 
consistency. 

All tools using pencil lines share the same preset list. Therefore, the 
Polyline, Line, Rectangle, Ellipse, and Pencil tools share the same 
preset list.

New Brush Allows to create a new preset.

Delete Brush Allows you to delete your custom presets. 

 Rename Brush Allows you to rename a custom preset.

 Import Brushes
Allows you to import a set of XML Harmony presets previously exported 
via the Export Brushes command. 

 Export Brushes
Allows you to export Harmony presets to backup or import on a different 
computer. 

 
Small Thumbnail, Large 
Thumbnail, and Stroke 
View

Allows you to display the presets as small square thumbnails, large 
square thumbnails or a list of stroke preview. 

Draw Behind

When drawing on vector layers, the Draw Behind mode lets you paint 
behind existing art. By default, strokes appear over your work until you 
release the tool.

Snap to Contour
Snaps your selection or point to any line you position it on. As soon as 
you move it close enough to another line, your point or selection will 
snap to it.

Snap and Align
Snaps the selected anchor point to any existing line while displaying 
temporary rulers as a guide that you can also snap your anchor point to.

Snap to Grid Snaps your selection following the currently enabled grid. 
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Automatically Create 
Colour Art 

As you draw in the Line Art layer, the Automatically Create Colour Art  
option instantly creates the corresponding strokes in the Colour Art 
layer.

Auto-Flatten Mode

When enabled, the Auto-Flatten  mode automatically flattens the new 
lines created with the existing artwork as you draw in the Drawingview. 
Brush strokes will flatten with brush strokes and pencil lines will flatten 
with pencil lines.

NOTE: 
Using the Select tool, you can use select and remove a segment of 
flattened pencil lines. Overlapping pencil lines drawn with the Auto-
Flatten mode are essentially cut into segments by the overlap and 
can be treated as individual lines.

Auto-Close Gap

When using the pencil tool, you can automatically close strokes with an 
invisible stroke. 

It is recommended to keep this option enabled when drawing with the 
Pencil tool.

80



Harmony 14 Paint - Reference Guide

Line Building Mode

The Line Building mode is very useful when drawing long lines and 
curves in small increments with pencil lines or the Line tool. As the 
pencil lines are central vector lines, it may be difficult to align the line 
tips perfectly to create a uniform stroke and close all gaps.

In this mode, you can draw lines in small increments and the tips are 
merge into one single stroke.

NOTE: This mode only works with pencil lines or the line  tool.

Use Stored Colour Gradi-
ent

The Use Stored Colour Gradient  option makes your tool use the 
previously stored gradient position. This way, every new brush line or 
colour fill will use the stored gradient position.

 Draw Circle
Enable this option to draw perfect circle (ratio 1:1) without holding any 
keyboard shortcuts. As an alternative, you can hold down the Shift key.

Size and Smoothness Tab 
You can access advanced properties by clicking on the Previewing the Stoke button in the Tool Properties view. 

Tool Name Description

Maximum Size
Defines the maximum size of your drawing tool. This parameter defines the  width of 
the stroke.

Minimum Size
Defines the minimum size of your stroke as a percentage of the maximum size. If 
you do not have pressure sensitivity from a pen table, the minimum size value will be 
ignored. 

Smoothing
Defines the number of control points added to the centre line. The fewer the control 
points the smoother (but less faithful) the line.
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Contour Smoothing
Defines the number of points on the contour share of your stroke. This will smooth 
out the bumps and waves on tour contour shape of your brush strokes.

Shape

You can adjust the start, end, and joint  style of a pencil line.

 l Start: Lets you select the style of the start  tip, which is the first tip you drew. 
You can choose between Round or Flat style.

 l End: Lets you select the style of the end tip, which is the last tip you drew. 
You can choose between Round or Flat style.

 l Join: Lets you select the joint style. The joints are where the line curves 
abruptly. You could also define the Join style as the corner style. You can 
choose between Round, Mitre and Bevel style.

Texture Tab 
You can access advanced properties by clicking on the Previewing the Stoke button in the Tool Properties view. 

  

Icon Tool Name Description

Copy to Preferences You can add a pencil texture to your preset preferences. 

 New Texture Adds a new custom pencil texture to the list.

 Delete Texture Deletes a texture preset from the list.

 Rename Texture Renames the selected texture to keep the list organized.

 Presets
Harmony provides a variety of pencil texture presets and also lets you 
create and save your own.
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 Pencil Texture Palette
Displays the colour palette assigned to hold the pencil textures. Use 
the Colour View menu to assign a new palette.
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Paint Tool Properties 
When you select the Paint tool, its properties and options appears in the Tools Properties view.

Icon Tool Name Description

Lasso Sets the selection mode to Lasso. Click and hold Alt to 
temporarily switch between the Marquee and Lasso modes. 

Marquee Sets the selection mode to Marquee. Click and hold Alt to 
temporarily switch between the Marquee and Lasso modes. 

Paint Modes The Paint tool has four different modes available: 

 l The Paint  mode paints everything it touches, including 
empty and filled zones. 

 l The Paint Unpainted  mode paints only empty zones. 
Any line or filled zone will remain unchanged.

 l The Repaint  mode paints everything it touches except 
empty zones. Any zone that is not painted will remain 
intact. 

 l The Unpaint  mode unpaints everything it touches, 
including empty and filled zones.

Paint and Remove Tex-
tures

The Paint and Remove Texture  option is used when you 
vectorized images as greyscale texture style. An image 
vectorized as texture is a mix of bitmap filling encapsulated in 
a vector-based frame. Painting a textured zones with the 
Paint tool will change the tint of the textured lines. Painting 
the textured zones using the Paint and Remove Texture 
option transforms the bitmap filling into a 100% vector based 
zone and fills it with a solid colour.
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Apply to Multiple Draw-
ings

The Apply to Multiple Drawings  option is used for fast painting 
in hand-drawn animation. When you want to paint several 
drawings in a same layer at once, such as a walk cycle, you 
can enable this option and make a selection in the Drawing 
view. All the closed zones located within your Paint tool 
selection are painted with the selected colour swatch.

You do not need to enable the Onion Skin preview to use this 
option. The option will stay enabled only for the next action. If 
you want to use it again, you must click on the Apply to 
Multiple Drawings button again, or press Alt + A.

Respect Protected Col-
our

The Respect Protected Colour option is enabled by default. In 
your Colour view, you can protect some colour swatches to 
avoid repainting or unpainting the zones linked to that swatch. 

If you disable this option the Paint tool will not follow the 
protect colour rule and will repaint or unpaint the protected 
colours on your drawings until you enable the option again.

Use Stored Colour Gradi-
ent

When you paint a zone with a gradient or textured colour 
swatch, the gradient or texture’s position is set relative to the 
size of the zone you are painting. If you want the Paint tool to 
use a particular size and position, you must first store your 
desired position and size using the Select  tool and then 
enable the Use Stored Colour Gradient   option in the Paint tool 
properties.

Select Newly Painted, 
Repainted, and 
Unpainted Con-
tours/Lines

In the Paint   tool properties, this option  keeps a selection 
highlighted around the latest painted zone after using the 
Paint, Repaint, Unpaint, or Paint Unpainted tool.
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Close Gap The Close Gap option has four modes available. When the 
option is enabled, Harmony will consume more resources 
while painting.

 l No Close Gap: The moment a zone has a gap in it, the 
Paint tool will not fill the area. 

 l Close Small Gap: If a zone has a small gap in it, the 
Paint tool will fill the area. You can zoom out to make 
the gap appear smaller and the Paint tool will paint. 

 l Close Medium Gap: If a zone has a medium gap in it, 
the Paint tool will fill the area. You can zoom out to 
make the gap appear smaller and the Paint tool will 
paint.  

 l Close Large Gap: If a zone has a large gap in it, the 
Paint tool will fill the area. You can zoom out to make 
the gap appear smaller and the Paint tool will paint. 
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 Pencil Tool Properties
When you select the Pencil  tool, its properties and options appears in the Tool Properties view. 

Icon Tool Name Description

 Previewing the Stroke

The Preview area lets you see a preview of the selected or customized 
stroke. You can click on the Show Extended Properties arrow to display 
advanced customization parameters.

 Maximum Size
Defines the maximum size of your drawing tool. This parameter defines 
the  width of the stroke.

 Smoothing
Defines the number of control points added to the centre line. The fewer 
the control points the smoother (but less faithful) the line.

 Shape

You can adjust the start, end, and joint  style of a pencil line.

 l Start: Lets you select the style of the start  tip, which is the first tip 
you drew. You can choose between Round or Flat style.
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 l End: Lets you select the style of the end tip, which is the last tip 
you drew. You can choose between Round or Flat style.

 l Join: Lets you select the joint style. The joints are where the line 
curves abruptly. You could also define the Join style as the corner 
style. You can choose between Round, Mitre and Bevel style.

 Presets

Harmony provides a variety of pencil presets and thickness stencils and 
also lets you create and save your own. It is a good idea to create and 
save pencils with precise sizes and parameters when you draw and 
design for efficiency and consistency.

A thickness stencil saves the thickness information across the length of 
the line.  When drawing with a thickness stencil, the pressure sensitivity of 
the tablet is discarded. A thickness stencil can be used while drawing, or 
applied afterwards.

You also have the possibility to apply different textures to your lines by 
either using the default presets or importing your own.

You can  export the pencil presets that you have created and import those 
that others have created. This is a good way for you and project 
collaborators to keep a consistent look for the project.

New Brush Allows to create a new preset.

Delete Brush Allows you to delete your custom presets. 

 Rename Brush Allows you to rename a custom preset.

 Import Brushes
Allows you to import a set of XML Harmony presets previously exported 
via the Export Brushes command. 

 Export Brushes
Allows you to export Harmony presets to backup or import on a different 
computer. 

 
Small Thumbnail, Large 
Thumbnail, and Stroke 
View

Allows you to display the presets as small square thumbnails, large 
square thumbnails or a list of stroke preview. 

Draw Behind

When drawing on vector layers, the Draw Behind mode lets you paint 
behind existing art. By default, strokes appear over your work until you 
release the tool.

Automatically Create 
Colour Art 

As you draw in the Line Art layer, the Automatically Create Colour Art  
option instantly creates the corresponding strokes in the Colour Art layer.

Auto-Flatten Mode When enabled, the Auto-Flatten  mode automatically flattens the new lines 
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created with the existing artwork as you draw in the Drawingview. Brush 
strokes will flatten with brush strokes and pencil lines will flatten with 
pencil lines.

NOTE: 
Using the Select tool, you can use select and remove a segment of 
flattened pencil lines. Overlapping pencil lines drawn with the Auto-
Flatten mode are essentially cut into segments by the overlap and 
can be treated as individual lines.

Auto-Close Gap

When using the pencil tool, you can automatically close strokes with an 
invisible stroke. 

It is recommended to keep this option enabled when drawing with the 
Pencil tool.

Line Building Mode

The Line Building mode is very useful when drawing long lines and curves 
in small increments with pencil lines or the Line tool. As the pencil lines 
are central vector lines, it may be difficult to align the line tips perfectly to 
create a uniform stroke and close all gaps.

In this mode, you can draw lines in small increments and the tips are 
merge into one single stroke.

NOTE: This mode only works with pencil lines or the line  tool.
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Auto Adjust Thickness

The Auto Adjust Thickness  tool is useful when you want to render a 
portion of a line thicker. When tracing a drawing on paper, you will often go 
back to a section of a curve to make it thicker to add dynamism to the line. 
Using the Auto Adjust Thickness tool, you can draw highlight strokes over 
the section to make thicker. Once you release the pen or mouse, the line 
becomes thicker following the shape and curve of the original stroke. This 
way is much faster and smoother than using the Pencil Editor tool. You do 
not have to add extra points and adjust the position and Bezier handles.

The default overlay colour is light yellow. If this colour is difficult to see 
because of the background or drawing colour, you can adjust the colour.

Line Pushing Mode

The Line Pushing Mode  option lets you draw highlight strokes over 
existing pencil lines. You can reshape the curves. Depending how you 
draw the pushing stroke over your line, the highlighted section will be 
reshaped in one direction or the other.

The default overlay colour is light yellow. If this colour is difficult to see 
because of the background or drawing colour, you can adjust the colour.

 

 Colour

You can change the colour for the Line Pushing Mode anf the Auto Adjust 
Thickness option by clicking on the Colour swatch and selecting a new 
colour in the Colour Picking window. 

Size and Smoothness Tab 
You can access advanced properties by clicking on the Previewing the Stoke button in the Tool Properties view. 
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Tool Name Description

Maximum Size
Defines the maximum size of your drawing tool. This parameter defines the  width of 
the stroke.

Minimum Size
Defines the minimum size of your stroke as a percentage of the maximum size. If 
you do not have pressure sensitivity from a pen table, the minimum size value will be 
ignored. 

Smoothing
Defines the number of control points added to the centre line. The fewer the control 
points the smoother (but less faithful) the line.

Contour Smoothing
Defines the number of points on the contour share of your stroke. This will smooth 
out the bumps and waves on tour contour shape of your brush strokes.

Shape

You can adjust the start, end, and joint  style of a pencil line.

 l Start: Lets you select the style of the start  tip, which is the first tip you drew. 
You can choose between Round or Flat style.

 l End: Lets you select the style of the end tip, which is the last tip you drew. 
You can choose between Round or Flat style.

 l Join: Lets you select the joint style. The joints are where the line curves 
abruptly. You could also define the Join style as the corner style. You can 
choose between Round, Mitre and Bevel style.

Texture Tab 
You can access advanced properties by clicking on the Previewing the Stoke button in the Tool Properties view. 
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Icon Tool Name Description

Copy to Preferences You can add a pencil texture to your preset preferences. 

 New Texture Adds a new custom pencil texture to the list.

 Delete Texture Deletes a texture preset from the list.

 Rename Texture Renames the selected texture to keep the list organized.

 Presets
Harmony provides a variety of pencil texture presets and also lets you 
create and save your own.

 Pencil Texture Palette
Displays the colour palette assigned to hold the pencil textures. Use 
the Colour View menu to assign a new palette.
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Pencil Editor Tool Properties
When you select the Pencil Editor  tool, its properties and options appear in the Tool Properties view. 

Ico-
n

Tool 
Name

Description

Lasso
Sets the selection mode to Lasso. Click and hold Alt to temporarily switch between the Marquee 
and Lasso modes.

93



Chapter 3: Tools Properties     Pencil Editor Tool Properties

Marquee
Sets the selection mode to Marquee. Click and hold Alt to temporarily switch between the Mar-
quee and Lasso modes.

 
Maximum 
Size

Defines the maximum size of your drawing tool. This parameter defines the  width of the stroke.

 
Minimum 
Size

Defines the minimum size of your stroke as a percentage of the maximum size. If you do not 
have pressure sensitivity from a pen table, the minimum size value will be ignored. 

 Shape

You can adjust the start, end, and joint  style of a pencil line.

 l Start: Lets you select the style of the start  tip, which is the first tip you drew. You can 
choose between Round or Flat style.

 l End: Lets you select the style of the end tip, which is the last tip you drew. You can 
choose between Round or Flat style.

 l Join: Lets you select the joint style. The joints are where the line curves abruptly. You 
could also define the Join style as the corner style. You can choose between Round, 
Mitre and Bevel style.

 Presets

Harmony provides a variety of pencil presets and thickness stencils and also lets you create 
and save your own. It is a good idea to create and save pencils with precise sizes and 
parameters when you draw and design for efficiency and consistency.

A thickness stencil saves the thickness information across the length of the line.  When drawing 
with a thickness stencil, the pressure sensitivity of the tablet is discarded. A thickness stencil 
can be used while drawing, or applied afterwards.

You also have the possibility to apply different textures to your lines by either using the default 
presets or importing your own.

You can  export the pencil presets that you have created and import those that others have 
created. This is a good way for you and project collaborators to keep a consistent look for the 
project.

New 
Brush

Allows to create a new preset from the selected pencil line.

Delete 
Brush

Allows you to delete your custom presets. 

 
Rename 
Brush

Allows you to rename a custom preset.

 

Small 
Thumb-
nail, Large 
Thumb-
nail, and 
Stroke 
View

Allows you to display the presets as small square thumbnails, large square thumbnails or a list 
of stroke preview. 
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Copy to 
Prefer-
ences

You can add a pencil texture to your preset preferences. 

 
New Tex-
ture

Adds a new custom pencil texture to the list.

 
Delete 
Texture

Deletes a texture preset from the list.

 
Rename 
Texture

Renames the selected texture to keep the list organized.

 Presets
Harmony provides a variety of pencil texture presets and also lets you create and save your 
own.

 
Pencil Tex-
ture 
Palette

Displays the colour palette assigned to hold the pencil textures. Use the Colour View menu to 
assign a new palette.

Smooth 
Selection

The Smooth operation lets you smooth out selected drawing strokes and remove extra points.

 l From the top menu, select Selected  > Smooth or press Alt + Shift + S.

Pump Pen-
cil Pres-
sure

The Pump Pencil Pressure  option is used to increase the line thickness of a selected area on a 
pencil line.

Deflate 
Pencil 
Pressure

The Deflate Pencil Pressure option is used to decrease the line thickness of a selected area on 
a pencil line.
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Merge Pen-
cil Lines

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to 
align them and make it look like it is one single line. With the Select tool, you can select several 
pencil lines and merge them as one single object using the Merge Pencil Lines  option. The ends 
of your lines are adjusted to form one single line.

 

Reverse 
Pencil 
Thickness

The Reverse Pencil Thickness  option inverts the thick and thin section on a selected pencil line. 
This option will take the thickest size on the line and apply it to the thinnest, and it will apply the 
thinnest to the thickest.
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Perspective Tool Properties
Selecting the Perspective tool displays its properties and options in the Tool Properties view. 

Icon Tool Name Description

Selection Tool Options

Lasso Sets the selection mode to Lasso. Click and hold Alt to 
temporarily switch between the Marquee and Lasso 
modes.

Marquee Sets the selection mode to Marquee. Click and hold Alt 
to temporarily switch between the Marquee and Lasso 
modes.

Snap to Contour Snaps your selection or point to any line you position it 
on. As soon as you move it close enough to another 
line, your point or selection will snap to it.

Snap and Align Snaps the selected anchor point to any existing line 
while displaying temporary rulers as a guide that you 
can also snap your anchor point to.

Snap to Grid Snaps your selection following the currently enabled 
grid. 

Apply to Line and Colour Art The Apply to Line and Colour Art  option uses the 
concept of Line Art and Colour Art layers. Use this 
option to apply an action such as selecting, resizing or 
erasing a drawing on both Line Art and Colour Art 
layers, as well as the Overlay and Underlay layers.

Flip Horizontal Flips the current selection horizontally.

Flip Vertical Flips the current selection vertically.

Rotate 90 Degrees CW Rotates the current selection 90 degrees clockwise.

Rotate 90 Degrees CCW Rotates the current selection 90 degrees counter-clock-

97



Chapter 3: Tools Properties     Perspective Tool Properties

wise.
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Polyline Tool Properties
When you select the Polyline  tool, its properties and options appear in the Tool Properties view. 

Icon Tool Name Description

 Previewing the Stroke

The Preview area lets you see a preview of the selected or customized 
stroke. You can click on the Show Extended Properties arrow to display 
advanced customization parameters.

 Size
Defines the maximum size of your drawing tool. This parameter defines 
the  width of the stroke.

 Presets

Harmony provides a variety of presets and also lets you create and save 
your own. It is a good idea to create and save pencils with precise sizes 
and parameters when you draw and design for efficiency and consistency.
 

All tools using pencil lines share the same preset list. Therefore, the 
Polyline, Line, Rectangle, Ellipse, and Pencil tools share the same preset 
list.

New Brush Allows to create a new preset.

Delete Brush Allows you to delete your custom presets. 

 Rename Brush Allows you to rename a custom preset.

 Import Brushes Allows you to import a set of XML Harmony presets previously exported 
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via the Export Brushes command. 

 Export Brushes
Allows you to export Harmony presets to backup or import on a different 
computer. 

 
Small Thumbnail, Large 
Thumbnail, and Stroke 
View

Allows you to display the presets as small square thumbnails, large 
square thumbnails or a list of stroke preview. 

Snap to Contour
Snaps your selection or point to any line you position it on. As soon as you 
move it close enough to another line, your point or selection will snap to it.

Automatically Create 
Colour Art 

As you draw in the Line Art layer, the Automatically Create Colour Art  
option instantly creates the corresponding strokes in the Colour Art layer.

Auto-Flatten Mode

When enabled, the Auto-Flatten  mode automatically flattens the new lines 
created with the existing artwork as you draw in the Drawingview. Brush 
strokes will flatten with brush strokes and pencil lines will flatten with 
pencil lines.

NOTE: 
Using the Select tool, you can use select and remove a segment of 
flattened pencil lines. Overlapping pencil lines drawn with the Auto-
Flatten mode are essentially cut into segments by the overlap and 
can be treated as individual lines.

Size and Smoothness Tab 
You can access advanced properties by clicking on the Previewing the Stoke button in the Tool Properties view. 
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Tool Name Description

Maximum Size
Defines the maximum size of your drawing tool. This parameter defines the  width of 
the stroke.

Minimum Size
Defines the minimum size of your stroke as a percentage of the maximum size. If 
you do not have pressure sensitivity from a pen table, the minimum size value will be 
ignored. 

Smoothing
Defines the number of control points added to the centre line. The fewer the control 
points the smoother (but less faithful) the line.

Contour Smoothing
Defines the number of points on the contour share of your stroke. This will smooth 
out the bumps and waves on tour contour shape of your brush strokes.

Shape

You can adjust the start, end, and joint  style of a pencil line.

 l Start: Lets you select the style of the start  tip, which is the first tip you drew. 
You can choose between Round or Flat style.

 l End: Lets you select the style of the end tip, which is the last tip you drew. 
You can choose between Round or Flat style.

 l Join: Lets you select the joint style. The joints are where the line curves 
abruptly. You could also define the Join style as the corner style. You can 
choose between Round, Mitre and Bevel style.

Texture Tab 
You can access advanced properties by clicking on the Previewing the Stoke button in the Tool Properties view. 
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Icon Tool Name Description

Copy to Preferences You can add a pencil texture to your preset preferences. 

 New Texture Adds a new custom pencil texture to the list.

 Delete Texture Deletes a texture preset from the list.

 Rename Texture Renames the selected texture to keep the list organized.

 Presets
Harmony provides a variety of pencil texture presets and also lets you 
create and save your own.

 Pencil Texture Palette
Displays the colour palette assigned to hold the pencil textures. Use 
the Colour View menu to assign a new palette.
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Rectangle Tool Properties
When you select the Rectangle tool, its properties and options appear in the Tool Properties view. There are a few 
less options available when working on a bitmap layer. 

Icon Tool Name Description

 Previewing the Stroke

The Preview area lets you see a preview of the selected or customized 
stroke. You can click on the Show Extended Properties arrow to display 
advanced customization parameters.

 Size
Defines the maximum size of your drawing tool. This parameter defines 
the  width of the stroke.

 Shape

You can adjust the start, end, and joint  style of a pencil line.

 l Start: Lets you select the style of the start  tip, which is the first tip 
you drew. You can choose between Round or Flat style.

 l End: Lets you select the style of the end tip, which is the last tip 
you drew. You can choose between Round or Flat style.
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 l Join: Lets you select the joint style. The joints are where the line 
curves abruptly. You could also define the Join style as the corner 
style. You can choose between Round, Mitre and Bevel style.

 Presets

Harmony provides a variety of presets and also lets you create and save 
your own. It is a good idea to create and save pencils with precise sizes 
and parameters when you draw and design for efficiency and consistency.
 

All tools using pencil lines share the same preset list. Therefore, the 
Polyline, Line, Rectangle, Ellipse, and Pencil tools share the same preset 
list.

New Brush Allows to create a new preset.

Delete Brush Allows you to delete your custom presets. 

 Rename Brush Allows you to rename a custom preset.

 Import Brushes
Allows you to import a set of XML Harmony presets previously exported 
via the Export Brushes command. 

 Export Brushes
Allows you to export Harmony presets to backup or import on a different 
computer. 

 
Small Thumbnail, Large 
Thumbnail, and Stroke 
View

Allows you to display the presets as small square thumbnails, large 
square thumbnails or a list of stroke preview. 

Draw Behind

When drawing on vector layers, the Draw Behind mode lets you paint 
behind existing art. By default, strokes appear over your work until you 
release the tool.

Automatic Filling

Use the Automatic Filling  option to automatically fill your shape with the 
selected colour as you draw. By default, the Shape tool creates the outline 
of an empty shape that you can later fill using the Paint tool. This option is 
unavailable for the line tool. 

Snap to Contour
Snaps your selection or point to any line you position it on. As soon as you 
move it close enough to another line, your point or selection will snap to it.

Snap and Align
Snaps the selected anchor point to any existing line while displaying tem-
porary rulers as a guide that you can also snap your anchor point to.

Snap to Grid Snaps your selection following the currently enabled grid. 
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Automatically Create 
Colour Art 

As you draw in the Line Art layer, the Automatically Create Colour Art  
option instantly creates the corresponding strokes in the Colour Art layer.

Auto-Flatten Mode

When enabled, the Auto-Flatten  mode automatically flattens the new lines 
created with the existing artwork as you draw in the Drawingview. Brush 
strokes will flatten with brush strokes and pencil lines will flatten with 
pencil lines.

NOTE: 
Using the Select tool, you can use select and remove a segment of 
flattened pencil lines. Overlapping pencil lines drawn with the Auto-
Flatten mode are essentially cut into segments by the overlap and 
can be treated as individual lines.

Use Stored Colour Gradi-
ent

The Use Stored Colour Gradient  option makes your tool use the previously 
stored gradient position. This way, every new brush line or colour fill will 
use the stored gradient position.

 Draw Square
Enable this option to draw perfect square (ratio 1:1) without holding any 
keyboard shortcuts. As an alternative, you can hold down the Shift key.

Size and Smoothness Tab 
You can access advanced properties by clicking on the Previewing the Stoke button in the Tool Properties view. 

105



Chapter 3: Tools Properties     Rectangle Tool Properties

Tool Name Description

Maximum Size
Defines the maximum size of your drawing tool. This parameter defines the  width 
of the stroke.

Minimum Size
Defines the minimum size of your stroke as a percentage of the maximum size. If 
you do not have pressure sensitivity from a pen table, the minimum size value will 
be ignored. 

Smoothing
Defines the number of control points added to the centre line. The fewer the control 
points the smoother (but less faithful) the line.

Contour Smoothing
Defines the number of points on the contour share of your stroke. This will smooth 
out the bumps and waves on tour contour shape of your brush strokes.

Shape

You can adjust the start, end, and joint  style of a pencil line.

 l Start: Lets you select the style of the start  tip, which is the first tip you 
drew. You can choose between Round or Flat style.

 l End: Lets you select the style of the end tip, which is the last tip you drew. 
You can choose between Round or Flat style.

 l Join: Lets you select the joint style. The joints are where the line curves 
abruptly. You could also define the Join style as the corner style. You can 
choose between Round, Mitre and Bevel style.

Texture Tab 
You can access advanced properties by clicking on the Previewing the Stoke button in the Tool Properties view. 
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Icon Tool Name Description

Copy to Preferences You can add a pencil texture to your preset preferences. 

 New Texture Adds a new custom pencil texture to the list.

 Delete Texture Deletes a texture preset from the list.

 Rename Texture Renames the selected texture to keep the list organized.

 Presets
Harmony provides a variety of pencil texture presets and also lets you 
create and save your own.

 Pencil Texture Palette
Displays the colour palette assigned to hold the pencil textures. Use the 
Colour View menu to assign a new palette.
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Reposition All Drawings Tool Properties
When you use the Reposition All Drawings tool, its properties and options appear in the Tool Properties view. 

Icon Option Description

Flip Horizontal Flips the current selection horizontally.

Flip Vertical Flips the current selection vertically.

Rotate 90 Degrees CW
Rotates the current selection 90 degrees 
clockwise.

Rotate 90 Degrees CCW
Rotates the current selection 90 degrees 
counter-clockwise.

 Offset X and Y

Use the Offset X and Offset Y operation fields 
to enter specific values and precisely 
reposition the selected shape.

 1. X: Type a value in this field to repos-
ition your selection along the X-axis.

 2. Y: Type a value in this field to repos-
ition your selection along the Y-axis.

 3. Up/Down arrows: Use the up and 
down arrows to modify the value in the 
X or Y value field.

 Width and Height
Use the Width and Height operation fields to 
enter specific values to resize the selected 
shape with precision.
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 1. Width: Type a value in this field to res-
ize the width of your selection.

 2. Height: Type a value in this field to res-
ize the height of your selection.

 3. Up/Down arrows: Use the up and 
down arrows to modify the value in the 
Width or Height fields.

 4. Lock icon: Click the lock icon to lock 
or unlock the ratio between the Width 
and Height values.

 Angle

The Angle operation lets you to enter specific 
values and accurately rotate the selected 
shape.

 1. Angle: Type a degree value in this field 
to rotate your selection.

 2. Up/Down arrows: Use the up and 
down arrows to modify the value in the 
Angle value field.

109



Chapter 3: Tools Properties     Select Tool Properties

Select Tool Properties
When you use the Select  tool, its properties and options appear in the Tool Properties view. 

Icon Tool Name Description

Selection Tool Options

Lasso Sets the selection mode to Lasso. Click and hold Alt to 
temporarily switch between the Marquee and Lasso 
modes. 

Marquee Sets the selection mode to Marquee. Click and hold Alt to 
temporarily switch between the Marquee and Lasso 
modes. 

Snap to Contour Snaps your selection or point to any line you position it 
on. As soon as you move it close enough to another line, 
your point or selection will snap to it.

Snap and Align Snaps the selected anchor point to any existing line while 
displaying temporary rulers as a guide that you can also 
snap your anchor point to.

Snap to Grid Snaps your selection following the currently enabled grid. 

Select by Colour Lets you select all the zones and lines in your drawing 
painted with the same colour swatch. 
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In the Drawing view, click on any zone or line in your 
drawing. All zones and lines of the same colour are 
selected. Click the Select tool again to return to the 
regular Select mode.

NOTE: Only the zones painted with the SAME col-
our swatch will be selected. If another zone is col-
oured with the exact same RGB value (same colour), 
but not painted with the same colour swatch, it will 
not be selected.

Permanent Selection Lets you maintain a selection over multiple drawings. 
Once this option is enabled, the selection zone made 
using the Select tool will remain as you navigate through 
drawings of the same layer and drawings from other 
drawing layers. This option can be used to 
simultaneously delete artwork inside or outside of the 
selection on several drawings when combined with the 
Apply to Multiple Drawings option.

Apply to Multiple Draw-
ings

The Apply to Multiple Drawings  option is used to perform 
an action on all the drawings contained in a layer. With 
the Select tool, this option can be used to select and 
remove vector shapes on all the drawings contained in a 
layer. To use it, activate Permanent Selection option and 
make a selection that can be applied to all your drawings. 
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Then, activate the Apply to Multiple Drawings option and 
press delete. This will delete all the shapes that would 
have been selected by the permanent selection on every 
drawing in the layer. This can be used for example to 
remove dirt and registration on the same areas of all the 
drawings simultaneously on a layer.

The Apply to Multiple Drawings option disables itself after 
each action.

Apply to Line and Colour 
Art

The Apply to Line and Colour Art  option uses the concept 
of Line Art and Colour Art layers. Use this option to apply 
an action such as selecting, resizing or erasing a drawing 
on both Line Art and Colour Art layers, as well as the 
Overlay and Underlay layers.

 

Ico-
n

Tool 
Name

Description

Selection Tool Operations

Flip Hori-
zontal

Flips the current selection horizontally.

Flip Ver-
tical

Flips the current selection vertically.

Rotate 
90 
Degrees 
CW

Rotates the current selection 90 degrees clockwise.

Rotate 
90 
Degrees 
CCW

Rotates the current selection 90 degrees counter-clockwise.

Smooth Smooth out selected drawing strokes and remove extra points.
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Flatten Merges drawing objects and brush strokes into a single layer. If you draw new lines to fix a 
drawing or line with many brush strokes, it can be useful to flatten them all into a single shape. 
By default, lines are drawn one on top of each other. If you intend to repaint the lines or modify 
their shape, it will be easier if they are flattened. 

Create 
Colour 
Art from 
Line Art

Lets you use the outline you traced on one of the four embedded layers (line art, colour art, 
overlay, underlay) and create invisible strokes to paint your drawings on separate layers. This 
provides more inking and painting flexibility. 

You can also configure this option to create the invisible strokes on any of the four embedded 
layers.

Store 
Colour 
Gradient 

Use the Store Colour Gradient  operation to record the selected gradient’s position. This reuses 
the stored position of the gradient when drawing new brush lines or painting colour zones. 
Enable the Use Stored Colour Gradient  option in the Paint or Brush Tool Properties view to 
do this.

Pencil to 
Brush

Converts the selected centre line pencil strokes into contour strokes brush lines.

Merge 
Pencil 
Lines

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to 
align them and make it look like it is one single line. With the Select tool, you can select several 
pencil lines and merge them as one single object using the Merge Pencil Lines  option. The 
ends of your lines are adjusted to form one single line.
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NOTE: Points must be close enough to be merged. If there is a large gap between the 
lines, they will not be merged.

Reverse 
Pencil 
Thick-
ness

The Reverse Pencil Thickness  option inverts the thick and thin section on a selected pencil 
line. This option will take the thickest size on the line and apply it to the thinnest, and it will 
apply the thinnest to the thickest.

 Offset X 
and Y

Use the Offset X and Offset Y operation fields to enter specific values and precisely reposition 
the selected shape.

 1. X: Type a value in this field to reposition your selection along the X-axis.

 2. Y: Type a value in this field to reposition your selection along the Y-axis.

 3. Up/Down arrows: Use the up and down arrows to modify the value in the X or Y value 
field.

 Width 
and 
Height

Use the Width and Height operation fields to enter specific values to resize the selected shape 
with precision.

 1. Width: Type a value in this field to resize the width of your selection.
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 2. Height: Type a value in this field to resize the height of your selection.

 3. Up/Down arrows: Use the up and down arrows to modify the value in the Width or 
Height fields.

 4. Lock icon: Click the lock icon to lock or unlock the ratio between the Width and Height 
values.

 Angle The Angle operation lets you to enter specific values and accurately rotate the selected shape.

 1. Angle: Type a degree value in this field to rotate your selection.

 2. Up/Down arrows: Use the up and down arrows to modify the value in the Angle value 
field.

 Adjust-
ing the 
Pencil 
Line 
Thick-
ness

When you select a pencil line with the Select tool, additional options appear in the Tool 
Properties view. 

Use the Adjusting the Pencil Line Thickness operation field to resize the selected centreline 
strokes. This operation is not permitted on contour line shapes, such as brush strokes or shape 
fills.

 1. Minimum Size: Type a value in this field to set the minimum thickness of the selected 
centreline stroke.

 2. Maximum Size: Type a value in this field to set the maximum thickness of the selected 
centreline stroke.

 3. Up/Down arrows: Use the up and down arrows to modify the value contained in the 
Thickness value field.

 Pencil 
Line 
Shape

You can adjust the start, end, and joint  style of a pencil line.

 l Start: Lets you select the style of the start  tip, which is the first tip you drew. You can 
choose between Round or Flat style.

 l End: Lets you select the style of the end tip, which is the last tip you drew. You can 
choose between Round or Flat style.

 l Join: Lets you select the joint style. The joints are where the line curves abruptly. You 
could also define the Join style as the corner style. You can choose between Round, 
Mitre and Bevel style.
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 Pencil 
Stencils

Gives you the flexibility to change the style and thickness of your pencil lines even after they 
are drawn. You can apply preset pencil stencils or create your own.

 Adding 
Texture 
to a Pen-
cil Line

Pencil lines support texture. Once a pencil line is drawn, you can apply a preset texture or load 
your own. Textures are independent from pencil stencils.

 Adjust-
ing the 
Text 
Selec-
tion

When you select text with the Select tool, the  tool properties will display the Text tool options 
on the bottom of the view. You can also press Alt + 9 to display only the Text properties in the 
Tool Properties view—see Text Tool Properties on page 120.
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Smooth Editor Tool Properties
When you select the Smooth Editor tool, its properties and options appear in the Tool Properties view. 

Icon Tool Name Description

Smoothing 
Style 

The Smoothing Style options allow you to smooth a portion of your drawing by tracing a 
smoothing stroke over the zone to optimize or by selecting an area of the drawing with 
the Marquee or Lasso.

Note that by default, the Smooth Editor tool colour is yellow, it was changed to orange 
for screen grab clarity.

 

Show Control 
Points 

The Show Control Points  option allows you to show or hide the Bezier points around 
lines. When the Bezier points are displayed, you can see the result of your smoothing 
and the number of points left on the curve. When it is turned off, only the original artwork 
is displayed.

 Minimum Size 
and Maximum 
Size 

This is where you set the minimum and maximum sizes of your drawing tool which will 
produce the thick and thin effect on your stroke. This works with the pressure sensitivity 
of a pen tablet.

This options is available while using the Brush Smoothing  style.

 l Maximum and Minimum Size: Defines the maximum and minimum width of the 
stroke.

 l Up/Down arrows: Use the up and down arrows to set the minimum and max-
imum size value.

Smoothness The Smoothness impacts the strength of the smoothing result. The higher the value, the 
more points are removed and the smoother the curve. The Smoothness range is from 0 
to 100; the default value is 20.
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 Colour You can modify the colour of the control points displayed on the artwork while working 
with the Smooth Editor tool by double-clicking on the colour swatch.
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Stroke Tool Properties
When you select the Stroke tool, its properties and options appears in the Tool Properties view. 

Icon Tool Name Description

Draw Stroke as Straight 
Lines 

Enable the Draw Stroke as Straight Lines  option if you 
want the new strokes you draw to be a perfect straight 
line. Disable the option if you want the stroke to follow 
the mouse gesture.

Connect Line Ends Enable the Connect Line Ends  option if you want the 
start or end point of your new stroke to connect to your 
existing strokes to make sure no gaps are left in your 
drawing.

Auto-Flatten Mode When enabled, the Auto-Flatten  mode automatically 
flattens the new lines created with the existing artwork 
as you draw in the Drawingview. Brush strokes will 
flatten with brush strokes and pencil lines will flatten 
with pencil lines.

Apply to Line and Colour 
Art

The Apply to Line and Colour Art  option uses the 
concept of Line Art and Colour Art layers. Use this 
option to apply an action such as selecting, resizing or 
erasing a drawing on both Line Art and Colour Art 
layers, as well as the Overlay and Underlay layers.

 Smoothness You can modify the central line smoothness  of your line 
using this option. This parameter smooths the initial 
movement of your line. Increasing the value will result in 
a smoother line with fewer control points. Use the left 
and right arrows to increment the value by one full unit. 
Use the Up - Down slider to quickly increment the 
value.
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Text Tool Properties
Use the Text tool's properties to select the font type and other formatting options you want to apply to the text.

If you already wrote your text, you must first use the Text tool and select the text portion you want to format. You 
can modify the parameters of an entire text box using the Select tool. 

Icon Tool Name Description

 Font Type Use the Font drop-down menu to select a font. OTF 
fonts are supported.

Bold Use this option to bold your text selection. 

Italic Use this option to italicize your text selection. 

 

Left Alignment Use this option to left align the paragraph. 

Centered Alignment Use this option to center align the paragraph. 
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Right Alignment Use this option to right align the paragraph. 

Justified Alignment Use this option to justify align the paragraph. 

 Font Size Enter a size for the text. 

 Kerning Use the kerning field to modify the spacing between 
letters and characters. You can select the Auto Kern 
option to set the kerning automatically based on the 
font’s predefined standard. A negative value decreases 
spacing between each character, creating a letter 
overlap and a positive value increases it.

 Indent Enter a value in the Indent field to increase or decrease 
the indentation on the first line of your text. A positive 
value sets the first line of your paragraph farther to the 
right and a negative value sets it farther to the left.
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 Line Spacing Enter a value in the Line Spacing field to decrease or 
increase the space between each line of text.
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Zoom Tool Properties
When you select the Zoom tool, its properties are displayed in the Tool Properties view.

Parameter Button Description

Zoom Tool Options
Zoom In Zooms in

Zoom Out Zooms out

Operations

Perform Zoom In
Zoom in the Camera or Drawing view. 

The keyboard shortcut is 2.

Perform Zoom Out
Zoom out the Camera or Drawing view. 

The keyboard shortcut is 1.

Reset Zoom Restores the current zoom level to 100%.

Reset View
Restores the original display by resetting any 
pan, rotation or zoom actions.
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Chapter 4: Toolbars
Harmony contains toolbars which, by default, are located at the top of the interface. Some views also have a toolbar 
which you can reposition to suit your work style. You can show or hide toolbars, as well as customize it with the 
tools you use most often and hide the ones you don't.

Top Toolbars 126

Edit Toolbar 127

File Toolbar 128

Playback Toolbar 129

Tool Presets Toolbar 130

Tools Toolbar 131

Workspace Toolbar 134

View Toolbars 135
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Top Toolbars
Harmony has a series of toolbars that are added by default at the top of the interface. These toolbars can be 
moved on the sides of the interface as well as within specific views. 

All top toolbars can be added through the top menu Windows > Toolbars > desired toolbar.

Edit Toolbar 127

File Toolbar 128

Playback Toolbar 129

Tool Presets Toolbar 130

Tools Toolbar 131

Workspace Toolbar 134
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Edit Toolbar
The Edit toolbar contains common operations such as Copy, Paste, Cut, Undo and Redo. These options can also 
be found in the Edit menu.

How to access the Edit toolbar

 1. Select Windows > Toolbars > Edit.

 

Icon Tool Name Description

Undo Removes the last change made to your project. 
Harmony supports multiple undo, so you can undo 
changes you made in the order you made them.

Redo Redoes an operation you have undone. This command 
is active only after you use the Undo command.

Cut Removes selected objects. You can then paste the 
object or its properties to another object.

Copy Copies selected objects and properties.

Paste Places an object you cut or copied into the location you 
select in a view.

Create Symbol Creates a symbol from selected drawing elements in 
the Drawing or Camera view or a layer or cells in the 
Timeline view.
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File Toolbar
The File toolbar contains the common file operations such as New, Save and Open. These options can also be 
found in the File menu.

How to access the File toolbar

 1. Select Windows > Toolbars > File.

 

Icon Tool Name Description

New (Harmony Stand 
Alone)

Open Displays the Open Scene dialog box where you can 
browse for a scene file.  You can open a new scene 
from the current one and the previous scene will 
close.

Save Saves all changes made to the opened scene, 
drawings, palettes, and palette lists.

Save As Saves the current file with a different name and at a 
different location.

Saves the current state of a scene as another scene. 
The Save As window prompts you for a new name 
and a different location for this scene before saving 
it. This will create a complete scene directory for the 
new scene.

NOTE: The scene name cannot exceed 23 char-
acters.

Import Images Imports bitmap images which you can choose to 
vectorize.

128



Harmony 14 Paint - Reference Guide

Playback Toolbar
The Playback toolbar lets you play back animation and sound. Use it to scrub the sound to create your lip-sync, loop 
the playback, navigate through frames, and change the playback range and speed.

Name Button Description

Play

Plays and stops the animation.

You can also select Play > Play Scene 
Forward or Stop.

Render and Play
Creates a render of your scene to play back the 
final result including the effects.

Loop

Repeatedly plays back your animation 
indefinitely.

You can also select Play > Loop.

Sound
Enables sound in the playback. 

You can also select Play > Enable Sound.

Sound Scrubbing

Enables sound scrubbing in the playback.

You can also select Play > Enable Sound 
Scrubbing.

Jog Frames Lets you scroll through the playback’s frames.

Frame ---
Lets you move the playhead by entering a frame 
number.

Start ---

Lets you change the start frame by entering a 
new value in the Start field.

You can also click on Start button to set the start 
frame at the current frame.

Stop ---

Lets you change the end frame by entering a new 
value in the Stop field.

You can also click on Stop button to set the end 
frame at the current frame.

FPS ---
Lets you enter a new value to change the speed 
of the playback.
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Tool Presets Toolbar
The Tool Presets toolbar lets you create new tool presets and manage them.

How to access the Tool Presets toolbar

 1. Select Windows > Toolbars > Tool Presets.

 

Icon Tool Name Description

New Tool Preset Creates a new tool preset from the current tool 
settings.

Manage Presets Opens the Manage Tool Preset dialog box where you 
can update, organize, and delete existing presets.
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Tools Toolbar
The Tools toolbar contains all the main tools you need to work in Harmony. In the default workspace, this toolbar 
located on the left-most side of the interface. A small triangle at the lower-right corner of a tool indicates additional 
tools under the main tool. To access these tools, hold down the left mouse button until the additional tools appear, 
then select one. 

You can display the Tools toolbar horizontally if you find it more efficient for your workflow. Be sure to restart 
Harmony in order to see the new position of the Tools toolbar.

How to display the Tools toolbar as a flat (horizontal) toolbar

 1. Do one of the following:

 l Select Edit > Preferences (Windows/Linux) or Harmony Paint > Preferences (Mac OS X). 

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

 2. Select the General tab.

 3. In the Options section, select the Flat Tool Toolbar option.
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 4. Click OK and restart Harmony.

 

Tool Name Icon Description

Select
Lets you select elements from the Camera and Drawing 
views.

Cutter Lets you cut a drawing area to move, copy, cut or delete it.

Reposition All 
Drawings

Lets you reposition, scale, rotate or skew all drawing strokes 
on every drawing included in a layer.

Contour Editor
Lets you add, remove or modify points on a vector line and 
control them.

Pencil Editor Lets you modify the thick and thin contours of a pencil line.

Smooth Editor
Lets you optimize contours and reduce the number of points 
on a line.

Perspective Lets you deform a drawing selection and alter its perspective.

Envelope
Lets you deform and warp part of a drawing using a grid 
envelope and Bezier handles.

Edit 
Gradient/Texture

Lets you modify the position of a gradient or texture colour 
within a specific zone.

Brush
A pressure-sensitive tool for creating a contour shape with a 
thick and thin line effect, as if created with a paint brush.

Pencil
A pressure-sensitive tool for  drawing the final images, such 
as character nodes, cut-out puppet and clean animation. 
Creates a central vector shape.

Text
Lets you type text in your project using various fonts and text 
attributes.

Eraser
A pressure-sensitive tool for precisely erasing parts of a 
drawing.

Paint Lets you paint both empty and filled zones.

Ink
Lets you paint only the segment you clicked on between two 
intersections to be painted.

Paint Unpainted
Lets you paint only empty zones. Lines and filled zones 
remain unchanged.

Repaint
Lets  you paint zones except empty zones. Any zone that is 
not painted remains intact.

Unpaint Lets you unpaint empty and filled zones.

Stroke Lets you draw stokes, connect line ends and flatten lines.

Close Gap
Lets you close small gaps in a drawing by creating small, 
invisible strokes between the two closest points.

Line Lets you draw straight lines which you can then edit.
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Rectangle Lets you draw rectangles which you can then edit.

Ellipse Lets you draw ellipses which you can then edit.

Polyline Lets you draw polylines lines which you can then edit.

Dropper Lets you pick a colour directly from a drawing.

Drawing Pivot Lets you set pivots on a characters, drawings and symbols.

Morphing
Lets you control a morphing sequence by placing different 
types of hints to help Harmony morph the animation the way 
you want it.

Hand Lets you pan the Drawing or Camera view.

Zoom Lets you zoom in and out of the Drawing or Camera view.

Rotate View
Lets you rotate the Drawing or Camera view just like with a 
real animation disc. Can also be used in Perspective view.

Animate Mode
Automatically creates a keyframe on the drawing layer. Used 
to animate layers over time.

Transform
Lets you create a global selection so you can reposition, 
scale, rotate and skew as one unit, which is useful for cut-out 
characters.

Inverse Kinematics
Lets you pull on a character's extremities, such as the hands 
and feet, and have the rest of the body follow. Can be used 
on any piece connected in a hierarchy. 

Onion Skin
Displays the previous and next frames of an animation. 
Useful when animating cut-out characters.
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Workspace Toolbar
The Workspace toolbar lets you load other workspaces. The first time you start Harmony, the default workspace 
is loaded. Other workspaces are available such as the Hand-Drawn Animation and Compositing workspaces; 
these display different views and toolbars. You can access these workspaces and any you create, from the 
Windows menu and the Workspace toolbar.

How to access the Workspace toolbar

 1. Select Windows > Toolbars > Workspace.

 

Icon Tool Name Description

 Workspace List Allows you to select an existing workspace.

Workspace Manager Opens the Workspace Manager where you can 
organize, display, and remove workspace from your 
list.

Save Workspace When the Automatically Save Workspace pref-
erence is disabled, the Save Workspace button 
becomes available. This allows you to manually 
save your new workspace configuration.
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View Toolbars
Harmony has a series of view specific toolbars that are only available in a given view. These toolbars can be moved 
only within their view. 

All view toolbars can be added, as long as the view is visible, through the top menu Windows > Toolbars > desired 
toolbar.
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Chapter 5: Views
The Harmony interface is composed of different views, each one designed for a specific purpose. You can modify 
the location of the views by adding a new view as a tab or as a window. You can also swap the location of a view.  

When a view is active, a red rectangle appears around the view. Keyboard shortcuts and top menu options are 
associated with the active view. If a menu option is greyed out, it means it does not apply to the layer, drawing or 
other type of selection or the option does not apply to the active view.

Colour View 138

Drawing View 143

Integrated Help View 145

Message Log View 146

Model View 147

Tool Properties View 148
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Colour View
The Colour view is where you create colours and palettes and import existing palettes into your project. The 
Colour view is also necessary for drawing, painting and creating colour styling.

How to access the Colour view

Do one of the following:
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 l From the top menu, select Windows > Colour.

 l From any of the other views, click the Add View  button and select Colour.

Icon Section Description

View Menu The View menu contains all the commands and options that you can use in 
the Colour view to manage colours and palettes.

 Show/Hide 
Palette List View

The Show/Hide Palette List View   button lets you display the Palette List view 
in the Colour view. This option is for the advanced user who wants to create 
colour palettes for their props and characters.

Add Palette The Add Palette  button lets you add a new palette to the bottom of your 
palette list.

Remove Palette The Remove Palette  button lets you delete the currently selected palette. If 
the colour swatch is used in your project, zones painted with colour swatches 
which have been deleted will turn red, easily identifying them so you can 
repaint them with another colour swatch.

Link Palette The Link Palette button lets you access other palettes created in the project 
and link them to your scene.

Order Palette List The Up and Down arrows let you reorder the selected palette. When using 
clone palettes (colour styles), the highest palette is the list will override its 
clone located lower in the list.

Edit Palette Mode In Harmony Server, the Edit Palette Mode  button lets you get the rights to 
modify the palette. The palette files can be locked to avoid accidentally 
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modifying the palette.

Add Colour The Add Colour  button lets you add a new colour swatch to the bottom of your 
colour list.

Remove Colour The Remove Colour  button lets you delete the currently selected colour 
swatches. If the colour swatch is used in your project, the Delete Colour 
dialog box will appear asking you to confirm the operation. Click OK to 
confirm the operation or Cancel to cancel it.

Zones painted with colour swatches which have been deleted will turn red, 
easily identifying them so you can repaint them with another colour swatch.

Add Texture The Add Texture  button lets you add a bitmap colour swatch to your palette. 
You can load photos and textures and paint your drawings with it. The bitmap 
image must be a .tga or .psd file format.

Set Current Brush 
Colour 

The Set Current Brush Colour  button let you set the currently selected colour 
swatch as the colour used by the Brush  tool. If you select a new colour in the 
Colour view while using the Brush tool, the Set Current Brush Colour swatch 
will be updated.

Set Current Pencil 
Colour 

The Set Current Pencil Colour  button lets you set the currently selected colour 
swatch as the colour used by the Pencil , Polyline , Ellipse , Rectangle  and 
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Line  tools. If you select a new colour in the Colour view while using any of 
these tools, the Set Current Pencil Colour swatch will be updated.

Set Current Paint 
Colour 

The Set Current Paint Colour  button lets you set the currently selected colour 
swatch as the colour used by the Paint tool. If you select a new colour in the 
Colour view while using the Paint tool, the Set Current Paint Colour swatch 
will be updated.

Link/Unlink Three 
Colours 

The Link/Unlink Three Colours  button lets you link the Set Current Brush 
Colour, Set Current Pencil Colour and Set Current Paint Colour swatches to 
the currently selected colour swatches in the Colour view.

 Colour Swatch 
Name 

Each colour swatch available in the Colour view can have its own name, 
making it easy to identify which colour is used to paint what part of your 
character or background. 

Two colours can have the same name.

 Colour Swatch A colour swatch is a specific colour used to paint a certain zone of a character 
or background. Colour palettes are composed of colour swatches. They can 
also be called colour pots. When you paint a zone with a colour swatch, the 
zone is linked to the swatch. So if you update the swatch’s tint, the zone will 
be updated along with it. This allows you to modify your animation colours 
even after it is completely painted.

 Colour Editor The Colour Editor panel allows you to modify the HSV and RGBA values of 
the selected colour without using the Colour Picker window.

 Drawing Nav-
igation and Art 
Layers

These controls are used to quickly have access to common commands.
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 l Previous and Next Drawing 

These buttons let you switch to the previous or next drawings. The 
shortcuts are F and G.

 l Previous and Next Layer 

These buttons are used to switch to the previous or next layer when 
you have different layers loaded. The shortcuts are H and J.

 l Line Art, Colour Art, Preview Mode 

Use these buttons to toggle between the Line Art to Colour Art layers. 
The shortcut is L. You can also enable or disable the Preview mode. 
The shortcuts are Shift + P.
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Drawing View
Only the selected drawing is displayed by default in the Drawing view. You can use features, such as the light table 
to display the current drawing of all the enabled layers of your scene in washed-out colours, or the Onion Skin to 
display the previous and next drawings of the currently selected drawing layer.

How to access the Drawing view

Do one of the following:

 l From the top menu, select Windows > Drawing .

 l From any of the other views, click the Add View  button and select Drawing.

 

Icon Section Description

View Menu The View menu contains all the tools and options that 
you can use in the Drawing view to draw, animate and 
paint.

 Drawing Area This is the main space in the Drawing view. It is where 
you draw and where the drawings are displayed.
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 Zoom Menu The Zoom menu lets you enlarge or reduce the Camera 
or Drawing view display. 

To make the camera frame size always match the size 
of your view, select the Fit to View option. Click the 
drop-down arrow and select a zoom level or press 1 and 
2.

 Drawing Name The Drawing Name field displays the name of the 
selected drawing, as well as the layer containing it. If 
the cell does not contain any drawing, an Empty Cell 
text is shown in the field.

 Tool Name The Tool Name field displays the name of the selected 
tool. If you temporarily override a drawing tool using a 
keyboard shortcut, the tool’s name will be highlighted in 
red. You can temporarily override a tool by holding its 
keyboard shortcut without the Alt key. For example, the 
Select tool shortcut is Alt + S. If you hold down the S 
key, you will switch to the Select tool. When you 
release the key, you will return to the tool you were 
using.

 Frame Number This field displays the current frame of the animation 
you are working on.

 Cursor Coordinates This indicates the position of the your pointer in the 
drawing area.

 Colour Picker The Colour Picker allows you to select a colour for 
drawing.

 Drawing Thumbnails Panel The Drawing Thumbnails panel displays a list with 
thumbnails of the loaded drawings. The highlighted 
drawing is the one displayed in the drawing area. You 
can select the drawing you want to paint directly from 
this list.
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Integrated Help View
Use the Integrated Help when you are unsure about what a certain menu item is or the function of a specific 
preference in the Preferences panel, 

If you keep the Integrated Help window open for the entire duration of your work session, then you can use the 
forward and backward arrows to scroll through  a history of the help information that you called up during your 
session.

How to access the Integrated Help view

 1. Do one of the following:

 l From the top menu, select Windows > Integrated Help.

 l From any of the other views, click the Add View  button and select Integrated Help.
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Message Log View
The Message log view displays information gathered during a render task, such as which frames and at what time 
they were each rendered. The view also contains a list of the colour recovery operations.

How to access the Message Log view

Do one of the following:

 l From the top menu, select Windows > Message Log.

 l From any of the other views, click the Add View  button and select Message Log.
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Model View
T-ANIMPA-004-004

Once you have a fully painted drawing, you can use it as a colour model and load it in the Model view. This drawing 
can be used and loaded in any of your Harmony scenes. 

Once a drawing is loaded in the Model view, you can use the Dropper  tool to select a colour from the model and 
use it to paint in the Camera or Drawing view without having to pick the colour from the colour palette.

How to access the Model view

Do one of the following:

 l From the top menu, select Windows > Model.

 l From any of the other views, click the Add View  button and select Model.

Icon Section Description

View Menu The View menu contains all the tools and options that 
you can use to manage models.

 Model View Toolbar The Model View toolbar contains all the tools and 
options you can use in the Model view to navigate 
through and manage models.
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Tool Properties View
T-HFND-004-002

The Tool Properties view contains the most common options and operations related to the currently selected tool. 
When you select a tool from the Tools toolbar, the Tool Properties view updates.

For example, if you choose the Select  tool, the Tool Properties view will display the options and operations 
related to it, such as Snap to Contour, Apply to All Drawings, Flip Horizontal, and Flatten.

NOTE: To learn more about the options appearing in the Tool Properties view, see Tools Properties on page 
35.

How to access the Tool Properties view

Do one of the following:

 l From the top menu, select Windows > Tool Properties.

 l From any of the other views, click the Add View  button and select Tool Properties.

148


	Toon Boom Harmony 14.0Paint ModuleReference Guide
	Contents
	Chapter 1: Reference
	Chapter 2: Dialog Boxes
	Advanced Save Dialog Box
	File Tab
	Drawings (Harmony Server only)
	Palettes Tab
	Palette Lists Tab

	Close Gaps Dialog Box
	Configure Line Art to Colour Art Dialog Box
	Create Palette Dialog Box
	Database Selector Dialog Box
	Element Manager Dialog Box
	Manage Tool Presets Dialog Box
	New Tool Preset Dialog Box
	Onion Skin and Light Table Transparency Dialog Box
	Palette Browser Dialog Box
	Palette Operations Dialog Box
	Pose Copier Dialog Box
	Preferences Dialog Box
	Remove Dirt Dialog Box
	Remove Hair Dialog Box
	Save Dialog Box
	Scripts Manager Dialog Box
	Tint Offset/Blend Dialog Box
	Toolbar Manager Dialog Box
	Xsheet Column Width Dialog Box

	Chapter 3: Tools Properties
	Brush Tool Properties (Vector)
	Size and Smoothness Tab
	Paper Texture Tab

	Brush Tool Properties (Bitmap)
	Tip Tab
	Transparency Tab
	Dual Tip Tab
	Paper Texture Tab

	Close Gap Tool Properties
	Contour Editor Tool Properties
	Cutter Tool Properties
	Drawing Pivot Tool Properties
	Dropper Tool Properties
	Ellipse Tool Properties
	Size and Smoothness Tab
	Texture Tab

	Envelope Tool Properties
	Eraser Tool Properties
	Size and Smoothness Tab
	Soft Eraser Tab

	Ink Tool Properties
	Line Tool Properties
	Size and Smoothness Tab
	Texture Tab

	Paint Tool Properties
	Pencil Tool Properties
	Size and Smoothness Tab
	Texture Tab

	Pencil Editor Tool Properties
	Perspective Tool Properties
	Polyline Tool Properties
	Size and Smoothness Tab
	Texture Tab

	Rectangle Tool Properties
	Size and Smoothness Tab
	Texture Tab

	Reposition All Drawings Tool Properties
	Select Tool Properties
	Smooth Editor Tool Properties
	Stroke Tool Properties
	Text Tool Properties
	Zoom Tool Properties

	Chapter 4: Toolbars
	Top Toolbars
	Edit Toolbar
	File Toolbar
	Playback Toolbar
	Tool Presets Toolbar
	Tools Toolbar
	Workspace Toolbar

	View Toolbars

	Chapter 5: Views
	Colour View
	Drawing View
	Integrated Help View
	Message Log View
	Model View
	Tool Properties View


