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Chapter 1: Compositing - An Introduction
Once the ink and paint is done, the animation completed and the timing locked, you are ready to move on to 
compositing. This includes different components, such as the elements' positioning, scene resolution, trajectories, 
camera moves, effects and filters, and so on. During compositing, you are working with computer-generated effects 
done with Harmony's many effect nodes. You can create many types of interesting effects and then customize it to 
suit your animation style.

It is during the compositing phase that the three animation workflows merge together. Whatever your chosen path, 
they all end up in the same animation, together in the same scene. However, the cut-out compositing can be a bit 
more complex due to the advanced networking of the different puppets.

Topics in this section:

• Import on page 9

• Library on page 83

• Scene Setup on page 117

• 3D Space on page 209

• Path Animation on page 237

• Sound on page 329

• 2D-3D Integration on page 307

• Effects on page 353

• Particles on page 541

• Light Shading Effect on page 585
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• OpenFX on page 611

• Export on page 619
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Chapter 2: Import

Toon Boom Harmony allows you to import external content as well as being able to draw directly in the software. 
This means that characters, backgrounds and videos created in other drawing, painting and multimedia programs 
can be brought in and animated. You can import QuickTime videos, pictures, multilayered .psd files, as well as .ai, 
.swf, .pdf, and .fla files. You can also scan images and import them as bitmap or vectorize them.

This chapter contains the following topics:

• Importing Bitmap Images  on page 10

• Importing PSD Files as Separate Layers  on page 25

• Exporting and Reimporting a PSD Layout on page 31

• Scanning Images  on page 41

• Importing AI and PDF Files  on page 49

• Scanning Images  on page 41

• Importing Adobe Flash Files on page 51

• Importing QuickTime Movies on page 67

• Creating Custom Vectorization Parameters  on page 68

NOTE: For sound import, refer to Importing a Sound File on page 329.
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Importing Bitmap Images 

Images can come in many different file formats and are usually saved in a format that retains the original 
specifications set by the image creator. Some formats can preserve the transparency or transparent layers, while 
others are not resolution dependent due to their vector nature. Toon Boom Harmony supports the following 
formats: JPEG, BMP, PNG, TGA, PSD, TIFF, SGI, TVG, OMF, PAL, SCAN.

When importing images and 3D models and linking images, the settings are saved in your user settings.

In this section, you will cover the following topics:

• Importing a Bitmap Image Without Vectorization on page 10

• Importing and Vectorizing Bitmap Images on page 18

• Linking a Layer to an External Image on page 20

Importing a Bitmap Image Without Vectorization

How to open the Import Images dialog box

 1. Do one of the following:

‣ From the top menu, select File > Import > Images. 

‣ In the File toolbar, click the Import Images  button.

‣ In the Xsheet view, right-click anywhere in the frame area and select Import > Images.

The Import Images dialog box opens.
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How to import a bitmap image in its original format

 1. In the Files section of the Import Images dialog box, click Browse to find and select one or more images on 
your computer.

 2. Decide if the bitmap image will go on a new layer or an existing layer. To add the bitmap image to a new layer, 
go to step 3. To add the bitmap image to an existing layer, go to step 4.

 3. Add the bitmap image to a new layer by selecting the Create Layer(s) option and one of the following 
options and then proceed to step 5: 

‣ Create Single Layer Named: Creates a layer you can name.

‣ Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. For 
example, the filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b", where "a" has two 
drawings and "b" has one. When creating a single layer from these three filenames, all three drawings will 
be inserted in the new layers.

 4. Select the Add to Existing Layer option to place the bitmap image on a layer you select from the list.  If only 
vector  layers are available in your scene, they will not be displayed in the list. You can choose to encapsulate 
the bitmap in a symbol by selecting the Create Symbols for Imported Items option. 

 5. In the Import Options section, select the Keep As Original Bitmap  option. In the Alignment section, decide 
on the size and placement of your image within the camera frame. Depending on the Scene Settings (the 
height and width in pixels that you chose for your project), an image that you import may be scaled to the 
point where all its individual pixels become visible. There are three options available in the Alignment section:

Parameter Description

Fit
Enlarges or shrinks (but not distorts) the image height to match the 
full height of the scene grid.
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If the image orientation is landscape, this will enlarge or shrink (but 
not distort) the image width to match that of the scene grid.

Note that the Fit alignment rule equals the Center Fit rule in the 
layer properties.

Pan

This is the opposite of the Fit parameter. If the image orientation is 
portrait, its width will be made to match the width of the scene grid. 
As a result, part of the image’s height will extend beyond the height 
of the frame. This can be useful if you want to make your 
background move up and down, or from left to right to make it 
appear as if the camera is panning or to actually perform a camera 
pan.
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The opposite will apply to a landscape image. Its height will be fit to 
the scene grid, therefore it is possible that the image will extend 
beyond the scene grid's boundaries.

Note that the Pan alignment rule equals the Center First Page rule 
in the layer properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The 
system looks at the resolution of the bitmap image, for example 
4000 x 2000, then compares it to the scene's resolution, for 
example 1920 x 1080, and adjusts the scale factor in proportion. 
So, in this example, the bitmap would appear at 208% (4000/1920). 
If you import a bitmap that is 960 x 540, it will be displayed at 50% 
(960/1920) of the size of the project resolution.

Note that the Project Resolution alignment rule is equal to the As Is 
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rule in the layer properties.

 6. In the Transparency section, select one of the following from the Alpha menu:

Parameter Description

Premultiplied with White Individual pixels at the edge of an image are blended with white.

Premultiplied with Black 
Semitransparent pixels in the original image are blended with 
black.

Straight 
Pixels at the edge of an image are blended with black, white and 
greys.

Clamp Colour to Alpha

Premultiplies the colour value with the alpha value. When the 
colour is clamped to the alpha, the colour value cannot be higher 
than the alpha value. It calculates the real colour value faster. 
When the RGB values are multiplied with the alpha value, that 
is, if you have a pixel of value R=247, G=188, B=29 and the 
alpha is 50% or the image has a 50% transparency, then the 
actual RGB values that are output would be half of the amounts 
listed above.

 7. Click OK.

Adding Images to a Bitmap Layer

How to add more bitmap images to an existing bitmap layer

 1. In the Timeline view, if the bitmap image is contained in a symbol, double-click on the bitmap symbol cell 
to edit the symbol. Otherwise, if the bitmap image is on a bitmap  layer, leave it as is.

 

 2. If necessary, in the Timeline view, pull on the red bracket to extend the exposure.

 3. From the top menu, select File > Import > Images or click the Import Image  button.

The Import Images dialog box opens.
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 4. Click Browse to find and select one or several images on your computer.

 5. In the Layer section, select the Add to Existing Layer option and select an existing bitmap layer from the 
menu.

 6. Deselect the Create Symbol for Imported Items option.

 7. In the Import Options section, select the Keep As Original Bitmap option. In the Alignment section, decide 
on the size and placement of your image within the camera frame. Depending on the Scene Settings (the 
height and width in pixels that you chose for your project), an image that you import may get scaled to the 
point where all its individual pixels become visible. There are three options available in the Alignment section:

Parameter Description

Fit

Enlarges or shrinks (but not distorts) the image height to match the full height of 
the scene grid.

If the image orientation is landscape, this will enlarge or shrink (but not distort) the 
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image width to match that of the scene grid.

Note that the Fit alignment rule equals the Center Fit rule in the layer properties.

Pan

This is the opposite of the Fit parameter. If the image orientation is portrait, its 
width will be made to match the width of the scene grid. As a result, part of the 
image’s height will extend beyond the height of the frame. This can be useful if 
you want to make your background move up and down, or from left to right to 
make it appear as if the camera is panning or to actually perform a camera pan.

The opposite will apply to a landscape image. Its height will be fit to the scene 
grid, therefore it is possible that the image will extend beyond the scene grid's 
boundaries.

Note that the Pan alignment rule equals the Center First Page rule in the layer 
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properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The system looks at the 
resolution of the bitmap image, for example 4000 x 2000, then compares it to the 
scene's resolution, for example 1920 x 1080, and adjusts the scale factor in 
proportion. So, in this example, the bitmap would appear at 208% (4000/1920). If 
you import a bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the 
size of the project resolution.

Note that the Project Resolution alignment rule is equal to the As Is rule in the 
layer properties.

 8. In the Transparency section, select one of the following from the Alpha menu:

Parameter Description

Premultiplied with White Individual pixels at the edge of an image are blended with white.

Premultiplied with Black Pixels at the edge of an image are blended with black.

Straight Pixels at the edge of an image are blended with black, white and greys.

Clamp Colour to Alpha

Premultiplies the colour value with the alpha value. When the colour is clamped to 
the alpha, the colour value cannot be higher than the alpha value. It calculates the 
real colour value faster. When the RGB values are multiplied with the alpha value, 
that is to say, if you have a pixel of value R=247, G=188, B=29 and the alpha is 
50% or the image has a 50% transparency, then the actual RGB values that are 
output would be half of the amounts listed above.

 9. Click OK.

 

 Bitmap Image Quality 

If the bitmap images that you imported look blurry or slightly pixelated, you can clean up the image by changing the 
quality of the preview in the Camera view. It will not affect the final render.

How to change the bitmap image quality

 1. In the Camera view, double-click on the bitmap image to enter its symbol if the image is encapsulated or 
simply select the bitmap image layer in the Timeline view if it's not.

 2. Do one of the following:
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‣ From the top menu, select View > Bitmap File Quality.

‣ From the Camera menu, select View > Bitmap File Quality.

‣ Press Ctrl + Q (Windows/Linux) or ⌘  + Q (Mac OS X).

The Bitmap Image Quality dialog box opens.

 3. Drag the slider to the right to improve the quality.

 4. Click OK.

 5. If you are inside a symbol, go to the top of the Camera view and click Top to exit the symbol and return to 
your scene.

Importing and Vectorizing Bitmap Images

You can turn bitmap images into vector drawings, while maintaining the sketchiness of a pencil line or into vector 
images with a bitmap fill. Both options can add life to an animation, which straight vectorization with smoothing 
does not usually afford.

How to import and vectorize a bitmap image

 1. Do one of the following:

‣ From the top menu, select File > Import > Images.

‣ In the File toolbar, click the Import Images  button.

The Import Images dialog box opens.
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 2. Click Browse to locate images.

 3. In the Layer section, decide if the scanned or imported image will be placed on a new layer or existing layer. 

‣ Create Layer: Scans or imports the image into a new layer. Select one of the following options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For example, the 
filenames a-1.tga, a-2.tga and b-1.tga will create layers named "a" and 
"b", where "a" has two drawings and "b" has one. When creating a 
single layer from these three filenames, all three drawings will be inser-
ted in the new layers.

‣ Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from the Layer 
list. You must scan into the same layer type if you're using an existing layer.

‣ Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix bitmap images 
with vector drawings on the same layer, the bitmap image must be encapsulated in a symbol and vice 
versa. Symbols will also be automatically added to the Symbol folder in the Library view.

 4. In the Import Options section, select the Convert to Toon Boom Vector Drawing option.

 5. In the Vectorization section, decide whether you want to import your image in colour, black and white,  grey, 
or if you want to add a new preset.

‣ Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based drawing. 
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‣ Grey: Vectorizes your image as a mix of vector contour and greyscale bitmap filling. Lines keep the 
texture from the scan, and the white of the paper becomes transparent.

‣ New Preset: The New Preset  button lets you create custom vectorization parameters via the 
Vectorization Parameters interface. 

NOTE: 
You can double-click on any of the presets at any time to open the Vectorization Parameters dialog box to 
customize your option. 

NOTE: The vectorized images are painted with the Vectorize Line colour swatch from the colour palette.

 6. Click OK.

A symbol or new layer contains the vector drawing. For images contained in a symbol, double-click on the 
image’s first cell in the Timeline view to enter the symbol so you can edit the image. 

Linking a Layer to an External Image

When working on a large production, you may want to centralize the backgrounds in one directory instead of 
duplicating the background several times in different scenes. As backgrounds are generally reused in many 
scenes, some studios like to save space on the server and link the different scenes to the background directory. 
Also, if they modify one background, it is modified everywhere at the same time without having to reimport it. To 
do so, you must use the Timing columns.

Timing columns are exposure sheet columns that link to files that are outside the scene’s structure. Because of 
these external links, care must be taken not to break the links by moving the scene’s location or the background 
directory’s location. Breaking a link will result in images not appearing in your scene.
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NOTE: Refer to the  Timing chapter in the Traditional Animation, Paperless Animation or Cut-out Animation Guide to 
learn more about using Timing columns.

If you are working with Toon Boom Harmony Server and all your scenes are located on a centralized server, you can 
also use the Link to Images option.

How to link the scene to an external image (Harmony Server only)

 1. From the top menu, select File > Import > Link to Images.

The Link to Images dialog box opens.

 2. Click the Browse button to select the image you want to link your scene to.

 3. Do one of the following:

‣ Select the Create Timing Layer option to create a new Timing column in the Xsheet view. Then select 
one of the following:

Create Single Timing Named: Type the new column name in the text field.

Create Timing(s) Based on Filenames: Creates file names based on the selected file's name.

‣ Select the Add to Existing Timing Layer option to insert the file into an existing Timing column.

 4. Select the Copy to Timings Directory option if you want to copy the selected file into the Timings folder loc-
ated in the scene directory. Note that the Timing column will link to the Timings folder.

 5. In the Import Options section, select one of the following:

‣ Keep As Original Bitmap: Retains an imported image as a bitmap. In the Alignment section, decide on 
the size and placement of your image within the camera frame. Depending on the Scene Settings (the 
height and width in pixels that you chose for your project), an image that you import may get scaled to the 
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point where all its individual pixels become visible. There are three options available in the Alignment 
section:

Parameter Description

Fit

Enlarges or shrinks (but not distorts) the image height to match the full height 
of the scene grid.

If the image orientation is landscape, this will enlarge or shrink (but not distort) 
the image width to match that of the scene grid.

Note that the Fit alignment rule equals the Center Fit rule in the layer 
properties.

Pan

This is the opposite of the Fit parameter. If the image orientation is portrait, its 
width will be made to match the width of the scene grid. As a result, part of the 
image’s height will extend beyond the height of the frame. This can be useful if 
you want to make your background move up and down, or from left to right to 
make it appear as if the camera is panning or to actually perform a camera pan.
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The opposite will apply to a landscape image. Its height will be fit to the scene 
grid, therefore it is possible that the image will extend beyond the scene grid's 
boundaries.

Note that the Pan alignment rule equals the Center First Page rule in the layer 
properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The system looks at 
the resolution of the bitmap image, for example 4000 x 2000, then compares it 
to the scene's resolution, for example 1920 x 1080, and adjusts the scale 
factor in proportion. So, in this example, the bitmap would appear at 208% 
(4000/1920). If you import a bitmap that is 960 x 540, it will be displayed at 50% 
(960/1920) of the size of the project resolution.

Note that the Project Resolution alignment rule is equal to the As Is rule in the 
layer properties.
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‣ Import As Toon Boom Bitmap Drawing: Imports a drawing into a vector layer where you can edit the 
image using the drawing tools. In the Alignment section, select one of the following:

Parameter Description

Vertical Fit

Enlarges or shrinks (but not distort) to your image height to match the full 
height of the scene frame (alignment grid).

Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match the full width 
of the scene frame (alignment grid).

Actual Size

Scales the image in proportion to the scene's resolution. The system looks at 
the resolution of the bitmap image, for example 4000 x 2000, then compares it 
to the scene's resolution, for example 1920 x 1080, and adjusts the scale 
factor in proportion. So, in this example, the bitmap would appear at 208% 
(4000/1920). If you import a bitmap that is 960 x 540, it will be displayed at 50% 
(960/1920) of the size of the project resolution.

‣ Convert to Toon Boom Vector Drawing: Imports a drawing and converts it to a Toon Boom vector 
drawing. In the Vectorization section, select one of the following:
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Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based drawing.

Grey: Vectorizes the image as a mix of vector contour and greyscale bitmap filling. Lines keep the texture 
from the scan, and the white of the paper becomes transparent.

New Preset: Lets you create a new preset.

Delete Preset: Lets you delete any preset in the list.

Custom vectorization: Lets you set custom vectorization parameters—see Creating a Vectorization Style  
on page 76.

 6. Click OK.

Importing PSD Files as Separate Layers 

PSD files (a format exportable exclusively from Adobe Photoshop) are unique in that they are able to retain multiple 
layers. This is advantageous as the image remains fully editable in terms of any colour correction, effects, masking, 
transparency, or compositing that were made to the .psd file in Adobe Photoshop.

NOTE: Note that your .psd image file must be set to RGB mode within Adobe Photoshop prior to being imported into 
Harmony.

How to import the separated layers of a .psd file

1. In Adobe Photoshop, organize your file so that all your layers are “grouped” into individual folders, or that all 
the elements you want to import as a single layer in Harmony are grouped together in their own folder. Any 
layer that is not in a folder group, by itself or otherwise, will not be imported.
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 1. In Harmony, go to the top menu and select File > Import > Images or click the Import Images  button.

The Import Images dialog box opens.

 2. In the Files section, click Browse to find and select the .psd image on your computer.

 3. In the Layer section, select the Create Layer(s) option, then select one of the following options:

‣ Create Single Layer Named: Creates a layer you can name.

‣ Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. For 
example, the filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b", where "a" has 
two drawings and "b" has one. When creating a single layer from these three filenames, all three 
drawings will be inserted in the new layers.

 4. Select the Create Symbol for Imported Items option if you want the layers to be contained in symbols.

 5. In the Import Options section, select one of the following:

‣ Keep As Original Bitmap: Retains an imported image as a bitmap. In the Alignment section, decide 
on the size and placement of your image within the camera frame. Depending on the Scene Settings 
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(the height and width in pixels that you chose for your project), an image that you import may get scaled to 
the point where all its individual pixels become visible. There are three options available in the Alignment 
section:

Parameter Description

Fit

Enlarges or shrinks (but not distorts) the image height to match the full height of 
the scene grid.

If the image orientation is landscape, this will enlarge or shrink (but not distort) the 
image width to match that of the scene grid.

Note that the Fit alignment rule equals the Center Fit rule in the layer properties.

Pan

This is the opposite of the Fit parameter. If the image orientation is portrait, its 
width will be made to match the width of the scene grid. As a result, part of the 
image’s height will extend beyond the height of the frame. This can be useful if 
you want to make your background move up and down, or from left to right to 
make it appear as if the camera is panning or to actually perform a camera pan.
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The opposite will apply to a landscape image. Its height will be fit to the scene 
grid, therefore it is possible that the image will extend beyond the scene grid's 
boundaries.

Note that the Pan alignment rule equals the Center First Page rule in the layer 
properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The system looks at the 
resolution of the bitmap image, for example 4000 x 2000, then compares it to the 
scene's resolution, for example 1920 x 1080, and adjusts the scale factor in 
proportion. So, in this example, the bitmap would appear at 208% (4000/1920). If 
you import a bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the 
size of the project resolution.

Note that the Project Resolution alignment rule is equal to the As Is rule in the 
layer properties.
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‣ Import As Bitmap Drawing: Imports a drawing into a vector layer where you can edit the image using the 
drawing tools. In the Alignment section, select one of the following:

Parameter Description

Vertical Fit

Enlarges or shrinks (but not distort) to your image height to match the full height of 
the scene frame (alignment grid).

Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match the full width of 
the scene frame (alignment grid).

Actual Size

Scales the image in proportion to the scene's resolution. The system looks at the 
resolution of the bitmap image, for example 4000 x 2000, then compares it to the 
scene's resolution, for example 1920 x 1080, and adjusts the scale factor in 
proportion. So, in this example, the bitmap would appear at 208% (4000/1920). If 
you import a bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the 
size of the project resolution.

‣ Convert to Toon Boom Vector Drawing: Imports a drawing and converts it to a Toon Boom vector 
drawing. In the Vectorization section, select one of the following:
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Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based drawing.

Grey: Vectorizes the image as a mix of vector contour and greyscale bitmap filling. Lines keep the texture 
from the scan, and the white of the paper becomes transparent.

New Preset: Lets you create a new preset.

Delete Preset: Lets you delete any preset in the list.

Custom vectorization: Lets you set custom vectorization parameters—see Creating a Vectorization Style 
 on page 76.

 6. Decide whether to select Vectorize Imported Items option.

NOTE: If you decide to use the Vectorize Imported Items option, see Importing and Vectorizing Bitmap Images on 
page 18 to learn more about vectorization settings.

NOTE: If you disable the Vectorize Imported Items options, the Transparency and Alignment settings will appear in 
place of the Vectorization settings—see Importing a Bitmap Image Without Vectorization on page 10.

 7. Click OK.

The Multilayer Image Import Settings dialog box opens.

 8. From the Create  menu, select one of the following:

‣ Single Layer: To import the Camera and Layout layers merged together.

‣ Separated Layers: To keep your Camera and Layout layers separated.

 9. From the Transparency menu, select one of the following if applicable:

Parameter Description
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Premultiplied with White Individual pixels at the edge of an image are blended with white.

Premultiplied with Black Pixels at the edge of an image are blended with black.

Straight Pixels at the edge of an image are blended with black, white and greys.

Clamp Colour to Alpha

Premultiplies the colour value with the alpha value. When the colour is 
clamped to the alpha, the colour value cannot be higher than the alpha value. It 
calculates the real colour value faster. When the RGB values are multiplied 
with the alpha value, that is to say, if you have a pixel of value R=247, G=188, 
B=29 and the alpha is 50% or the image has a 50% transparency, then the 
actual RGB values that are output would be half of the amounts listed above.

 10. Click OK.

Your image appears as separate layers in the Timeline view, corresponding to the PSD layer group folders.

NOTE: The artwork displayed in every one of your layers as a result of a multilayer PSD file import is linked to the 
same source image. This means that if you use the Drawing > Delete Selected Drawings command to physically 
delete the drawing from the project folder, the exposed drawing will be deleted in all layers at once. Once deleted 
from the project folder, the image cannot be retrieved unless you reimport your psd file.

Exporting and Reimporting a PSD Layout

Harmony allows you to export the contents of your scene as a PSD layout. This can be helpful for scene setup, 
background art retakes, or even planning of animation. 

Exporting a Layout

Before exporting a layout, all the elements must be well positioned. For example, if you plan to include a camera 
movement in this scene, you should also set this up, as you can export the camera keyframes to generate a clear 
and complete layout.

You can also create all the layouts for your production in the same Harmony  project which can be imported later on 
when you start each scene’s project. This will help set up the scene and begin its creation. You can use the layout 
.psd files to create the background art of each scene and make sure everything is correctly framed and at the right 
size. Finally, you can also have a layer with a drawing of the rough poses of the character or action and generate 
your layout posing from there.
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NOTE: Because the layout image is one static .psd file, only the first frame of your drawing layers will be 
exported—see Scene Setup on page 117 and Path Animation on page 237.

How to export your scene as a layout

Before exporting your scene as a layout, position your background elements, and everything you need as a 
reference in your scene, including a camera movement. 

 1. From the top menu, select one of the following:

‣ File > Export > Layout Image to export all the elements in your scene to the layout .psd file.

‣ File > Export > Layout Image from Selection to export only the selected elements. 

The Export Layout Image dialog box opens.

 2. In the Export Layout Image dialog box, set the export parameters:

Parameter Description

Destination Path
Use the Browse button to select a location to save your layout and name the 
resulting .psd file.

 
File Pattern: Automatically puts the name of the scene and/or the frame num-
ber in the name of the file you create.

Image Size
The size of the .psd image file that will be exported. The resulting image will be 
72 dpi as the standard television resolution and its size in pixel will fit your 
scene resolution settings. i.e HDTV, NTSC, PAL, etc. Note that if you have a 
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camera movement going over the normal camera frame limit, for example a 
pan, the image will be bigger.

Options

File Format: Lets you select the format to export your layout.

Export Camera Frame: This option is disabled by default. You can enable it 
to export an additional layer to your .psd file displaying the camera frame on it.

Add a Camera Frame for Each Keyframe: This option is disabled by default, 
meaning that if you have a camera movement with more than a starting and an 
ending point, only these positions of the camera frame will appear on the 
camera layer of the exported layout .psd file. You must enable this option if you 
need to the in-between keyframes to also be displayed.

Label Camera Frame: Adds the camera position label in the top corner of the 
camera frames. The camera label is a single alphabet letter determining the 
order of the camera frame position.

 

Expand Render Area: This option is disabled by default, meaning the layout 
image will take the complete PSD area, cropped at the very edge of the 
canvas. You can enable this option to add a transparent area all around the 
layout. You must setup the size of this area by using the Scale field lower. The 
resulting image will be larger.

Scale Image: Sets the size of the transparent border around the layout image. 
By default the value is set to 100% to export the image as is with no 
transparent area around it. Increase the percentage value to add the extra 
around the image to create the border.

Maximum Size: This option is enabled by default, meaning that when you 
have a camera zoom movement, the size of the layout image will be adjusted 
accordingly. The resulting percentage will be calculated following the maximal 
camera zoom value appearing in the layout. This allows the image to be 
exported at an appropriate resolution, preventing the layout image from 
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appearing pixelated or blurry when the camera zoom occurs. You can disable 
this option to export the image layout at the normal size.

 

Vector Options 

If you export one or more vector-based drawing layers in your layout image, 
you have the option to export only the drawing layers you want. Enable or 
disable the following options to export or prevent the export of the 
corresponding art layers.  

Overlay: Exports the art in the Overlay layer of the drawings to be exported to 
the layout image.  

Line Art: Exports the art in the Line layer of the drawings to be exported to the 
layout image.  

Colour Art: Exports the art in the Colour layer of the drawings to be exported to 
the layout image.  

Underlay: Exports the art in the Underlay layer of the drawings to be exported 
to the layout image.

 3. Click OK to validate the settings and export a .psd file of your layout.

The resulting image is a .psd file with one or two layers, each of which is contained in a corresponding 
group. These groups make the layout .psd file ready for a multilayer .psd import. 

The Camera_Set group contains the camera drawing layer. If you selected the Export Camera option, this 
group and layer appear in your layout image.

The Layout_Set group contains a merged drawing layer of all the content of your scene’s first frame when 
you exported the layout image.
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NOTE: An .xli  file is exported along with your .psd file. This file contains all the necessary information for correctly 
importing and automatically positioning your layout image in a Harmony project. Do not delete the .xli file or rename 
it. Also, always keep it at the same location as the layout .psd file.

Importing a Photoshop Layout

If you exported a Photoshop layout image from a Harmony project, you can easily import it back into Harmony. Just 
be sure to import it at the beginning of the project for accurate scene planning.

How to import a PSD layout

 1. In your Harmony project, select File > Import > Images.

The Import Images dialog box opens.

 2. In the Files section, click Browse to find and select the .psd  layout file on your computer. Note that this lay-
out file must have its corresponding .xli file in the same folder.
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 3. Once you have selected the layout file, the Use Position Information Contained in XLI File option appears 
in the Layer section. 

This option is enabled by default. When you import the layout image in your scene, it will be automatically 
positioned to fit the original layout scene creating an accurate layout guide. You can disable this option if 
you want the imported layout image to be imported according to the normal behaviour of the import 
process. The layout image will be incorrectly aligned as it was when it was first created.

 4. In the Layer section, select the Create Layer(s) option, then select one of the following options:

‣ Create Single Layer Named: Creates a layer you can name.

‣ Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. For 
example, the filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b", where "a" has 
two drawings and "b" has one. When creating a single layer from these three filenames, all three 
drawings will be inserted in the new layers.

 5. Select the Create Symbol for Imported Items option if you want the layers to be contained in symbols.

 6. In the Import Options section, select one of the following:

‣ Keep As Original Bitmap: Retains an imported image as a bitmap. In the Alignment section, decide 
on the size and placement of your image within the camera frame. Depending on the Scene Settings 
(the height and width in pixels that you chose for your project), an image that you import may get scaled 
to the point where all its individual pixels become visible. There are three options available in the 
Alignment section:

Parameter Description

Fit
Enlarges or shrinks (but not distorts) the image height to match the full height 
of the scene grid.
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If the image orientation is landscape, this will enlarge or shrink (but not distort) 
the image width to match that of the scene grid.

Note that the Fit alignment rule equals the Center Fit rule in the layer 
properties.

Pan

This is the opposite of the Fit parameter. If the image orientation is portrait, its 
width will be made to match the width of the scene grid. As a result, part of the 
image’s height will extend beyond the height of the frame. This can be useful if 
you want to make your background move up and down, or from left to right to 
make it appear as if the camera is panning or to actually perform a camera pan.
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The opposite will apply to a landscape image. Its height will be fit to the scene 
grid, therefore it is possible that the image will extend beyond the scene grid's 
boundaries.

Note that the Pan alignment rule equals the Center First Page rule in the layer 
properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The system looks at 
the resolution of the bitmap image, for example 4000 x 2000, then compares it 
to the scene's resolution, for example 1920 x 1080, and adjusts the scale 
factor in proportion. So, in this example, the bitmap would appear at 208% 
(4000/1920). If you import a bitmap that is 960 x 540, it will be displayed at 50% 
(960/1920) of the size of the project resolution.

Note that the Project Resolution alignment rule is equal to the As Is rule in the 
layer properties.
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‣ Import As Toon Boom Bitmap Drawing: Imports a drawing into a vector layer where you can edit the 
image using the drawing tools. In the Alignment section, select one of the following:

Parameter Description

Vertical Fit

Enlarges or shrinks (but not distort) to your image height to match the full height of 
the scene frame (alignment grid).

Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match the full width of 
the scene frame (alignment grid).

Actual Size

Scales the image in proportion to the scene's resolution. The system looks at the 
resolution of the bitmap image, for example 4000 x 2000, then compares it to the 
scene's resolution, for example 1920 x 1080, and adjusts the scale factor in 
proportion. So, in this example, the bitmap would appear at 208% (4000/1920). If 
you import a bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the 
size of the project resolution.

‣ Convert to Toon Boom Vector Drawing: Imports a drawing and converts it to a Toon Boom vector 
drawing. In the Vectorization section, select one of the following:
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Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based drawing.

Grey: Vectorizes the image as a mix of vector contour and greyscale bitmap filling. Lines keep the texture 
from the scan, and the white of the paper becomes transparent.

New Preset: Lets you create a new preset.

Delete Preset: Lets you delete any preset in the list.

Custom vectorization: Lets you set custom vectorization parameters—see Creating a Vectorization Style 
 on page 76.

 7. Click OK.

The Multilayer Image Import Settings dialog box opens.

 8. From the Create  menu, select one of the following:

‣ Single Layer: To import the Camera and Layout layers merged together.

‣ Separated Layers: To keep your Camera and Layout layers separated.

 9. From the Transparency menu, select one of the following if applicable:

Parameter Description

Premultiplied with White Individual pixels at the edge of an image are blended with white.

Premultiplied with Black Pixels at the edge of an image are blended with black.

Straight Pixels at the edge of an image are blended with black, white and greys.

Clamp Colour to Alpha

Premultiplies the colour value with the alpha value. When the colour is 
clamped to the alpha, the colour value cannot be higher than the alpha value. It 
calculates the real colour value faster. When the RGB values are multiplied 
with the alpha value, that is to say, if you have a pixel of value R=247, G=188, 
B=29 and the alpha is 50% or the image has a 50% transparency, then the 
actual RGB values that are output would be half of the amounts listed above.

 10. Click OK.
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Your image appears as separate layers in the Timeline view, corresponding to the .psd layer group folders 
Camera_Set and Layout_Set. You can now use this layout as a guide for scene settings.

NOTE: Refer to Scene Setup on page 117 to learn more about the scene setup task.

Scanning Images 

Toon Boom Harmony can receive images from any TWAIN device such as scanners and digital cameras. These 
images can either be loaded into your scene as bitmaps or converted into vector- based images that can be edited 
using Toon Boom Harmony.

If your operating system does not automatically recognize your device after it has been connected, you must install 
the correct TWAIN drivers in order to access its contents. You can usually download the drivers from the device 
manufacturer’s website.

How to open the Scan Drawings window and set your scanner

 1. From the top menu, select File > Import > From Scanner.

The Scan Drawings window opens. 
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 2. In the Scan Drawings window, select your scanner or other supported TWAIN device from the Scanner 
menu. If none are available, check your device to ensure that it's properly connected to your computer. If 
your device still does not appear in the menu, you may have to shut down and restart the software.

How to scan an image in its original format

 1. In the Layer section, decide if the scanned or imported image will be placed on a new layer or existing 
layer. 

‣ Create Layer: Scans or imports the image into a new layer. Select one of the following options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For example, 
the filenames a-1.tga, a-2.tga and b-1.tga will create layers named 
"a" and "b", where "a" has two drawings and "b" has one. When cre-
ating a single layer from these three filenames, all three drawings will 
be inserted in the new layers.

‣ Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from the Layer 
list. You must scan into the same layer type if you're using an existing layer.

‣ Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix bitmap 
images with vector drawings on the same layer, the bitmap image must be encapsulated in a symbol 
and vice versa. Symbols will also be automatically added to the Symbol folder in the Library view.
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 2. In the Import Options section, select the Keep As Original Bitmap option.

 3. In the Alignment section, decide on the size and placement of your scanned image within the camera frame. 
Depending on the scene settings (the height and width, in pixels, that you chose for your project), an image 
that you scan may be scaled to the point where all its individual pixels become visible.

Parameter Description

Fit

Enlarges or shrinks (but not distorts) the image height to match the full height of 
the scene grid.

If the image orientation is landscape, this will enlarge or shrink (but not distort) the 
image width to match that of the scene grid.

Note that the Fit alignment rule equals the Center Fit rule in the layer properties.

Pan

This is the opposite of the Fit parameter. If the image orientation is portrait, its 
width will be made to match the width of the scene grid. As a result, part of the 
image’s height will extend beyond the height of the frame. This can be useful if 
you want to make your background move up and down, or from left to right to 
make it appear as if the camera is panning or to actually perform a camera pan.
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The opposite will apply to a landscape image. Its height will be fit to the scene 
grid, therefore it is possible that the image will extend beyond the scene grid's 
boundaries.

Note that the Pan alignment rule equals the Center First Page rule in the layer 
properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The system looks at the 
resolution of the bitmap image, for example 4000 x 2000, then compares it to the 
scene's resolution, for example 1920 x 1080, and adjusts the scale factor in 
proportion. So, in this example, the bitmap would appear at 208% (4000/1920). If 
you import a bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the 
size of the project resolution.

Note that the Project Resolution alignment rule is equal to the As Is rule in the 
layer properties.

44



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

 4. In the Drawing Options section, set the following options if desired:

‣ Drawing Name: Name of the drawing to import.

‣ Hold Value: Type the number of frames that the drawing will be exposed.

‣ Scan and Advance: Lets you scan one drawing after another every time you click Scan.

‣ Flip Drawing: Mirrors the drawings horizontally and scans it this way.

 5. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the view.

 6. Click Scan to scan your drawing.

 7. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next letter to cap-
ture your next frame.

 8. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until you have 
finished scanning all your drawings.

How to scan an image as a Toon Boom bitmap drawing

 1. In the Import Options section, select the Import as Toon Boom Bitmap Drawing  option. 

 2. In the Layer section, decide if the scanned or imported image will be placed on a new layer or existing layer. 

‣ Create Layer: Scans or imports the image into a new layer. Select one of the following options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For example, the 
filenames a-1.tga, a-2.tga and b-1.tga will create layers named "a" and 
"b", where "a" has two drawings and "b" has one. When creating a 
single layer from these three filenames, all three drawings will be inser-
ted in the new layers.

‣ Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from the Layer 
list. You must scan into the same layer type if you're using an existing layer.
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‣ Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix bitmap 
images with vector drawings on the same layer, the bitmap image must be encapsulated in a symbol 
and vice versa. Symbols will also be automatically added to the Symbol folder in the Library view.

 3. In the Alignment section, decide on the size and placement of your scanned image within the camera 
frame. Depending on the scene settings (the height and width, in pixels, that you chose for your project), 
an image that you scan may be scaled to the point where all its individual pixels become visible.

NOTE: Make sure you're in the Camera view’s Render mode when judging an imported image, otherwise it may 
appear blurry.

The following three Alignment Rules options are available:

Parameter Description

Vertical Fit

Enlarges or shrinks (but not distort) to your image height to match the full 
height of the scene frame (alignment grid).

Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match the full width 
of the scene frame (alignment grid).

Actual Size Scales the image in proportion to the scene's resolution. The system looks at 
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the resolution of the bitmap image, for example 4000 x 2000, then compares it 
to the scene's resolution, for example 1920 x 1080, and adjusts the scale 
factor in proportion. So, in this example, the bitmap would appear at 208% 
(4000/1920). If you import a bitmap that is 960 x 540, it will be displayed at 50% 
(960/1920) of the size of the project resolution.

 4. In the Drawing Options section, set the following options if desired:

‣ Drawing Name: Name of the drawing to import.

‣ Hold Value: Type the number of frames that the drawing will be exposed.

‣ Scan and Advance: Lets you scan one drawing after another every time you click Scan.

‣ Flip Drawing: Mirrors the drawings horizontally and scans it this way.

 5. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the view.

 6. Click Scan to scan your drawing.

 7. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next letter to cap-
ture your next frame.

 8. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until you have 
finished scanning all your drawings.

How to scan an image and convert it to a Toon Boom vector drawing

 1. In the Import Options section, select the Convert to Toon Boom Vector Drawing  option. You can choose to 
encapsulate the image in a symbol by selecting the Create Symbols for Imported Items option. 

 2. In the Layer section, decide if the scanned or imported image will be placed on a new layer or existing layer. 

‣ Create Layer: Scans or imports the image into a new layer. Select one of the following options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Create Layer(s) Based on Filenames
Creates a layer based on each unique filename prefix. For example, the 
filenames a-1.tga, a-2.tga and b-1.tga will create layers named "a" and 
"b", where "a" has two drawings and "b" has one. When creating a 
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single layer from these three filenames, all three drawings will be inser-
ted in the new layers.

‣ Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from the Layer 
list. You must scan into the same layer type if you're using an existing layer.

‣ Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix bitmap 
images with vector drawings on the same layer, the bitmap image must be encapsulated in a symbol 
and vice versa. Symbols will also be automatically added to the Symbol folder in the Library view.

 3. In the Vectorization section, decide whether you want to import your image in black and white or grey.

Parameter Description

Black and White
Vectorizes drawings as a solid black line; creates a 100% vector-based draw-
ing.

Grey
Vectorizes your image as a mix of vector contour and greyscale bitmap filling. 
Lines keep the texture from the scan, and the white of the paper becomes trans-
parent.

 1. In the Drawing Options section, set the following options if desired:

‣ Drawing Name: Name of the drawing to import.

‣ Hold Value: Type the number of frames that the drawing will be exposed.

‣ Scan and Advance: Lets you scan one drawing after another every time you click Scan.

‣ Flip Drawing: Mirrors the drawings horizontally and scans it this way.

 2. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the view.

 3. Click Scan to scan your drawing.

 4. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next letter to 
capture your next frame.
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 5. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until you have 
finished scanning all your drawings.

Importing AI and PDF Files 

You can import AI (Adobe Illustrator) and PDF files into Toon Boom Harmony to convert your files to the Toon Boom 
format (TVG) and create a colour palette based on the colour settings of the original file. 

When importing AI and PDF files:

• RGB is supported, CMYK is not.

• Gradients and textures are not supported.

• Only legacy versions of Adobe Illustrator are supported. Exported SWFs, including Actionscript 2 and 
Actionscript 3, cannot be imported.

• When importing an Illustrator or PDF file in Toon Boom Harmony, by default the file will be imported as 
separate layers. The import will use the Illustrator file's top level groups as separate layer names. However, 
you can change this behaviour by deselecting the PDF/Illustrator Import as Separate Layers option, to import 
your file as a single layer .

How to import an AI or PDF file

 1. In the Library view, right-click on the Stage Library folder and select Right to Modify to unlock the library 
folder. Make sure the Lock icon disappears from the folder. If not, your library will remain locked and you will 
not be able to import files.

NOTE: For more information, refer to the Library  chapter in the Cut-out Animation Guide.
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 2. Do one of the following:

‣ In the top menu, select File > Import > SWF, Illustrator Files to Library. 

‣ Right-click on any unlocked folder and select Import Fi les.

The browser window opens.

 3. Find and select your AI or PDF file in the Import Files dialog box and click Open.

The Rename dialog box opens.

 4. Type in a name for the new template or keep the name of the original AI or PDF file. 

 5. Click OK.

A new template folder is created in the Library view.

 6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until the copy 

cursor  appears before releasing the folder.

The message window opens.

 7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before clicking 
the Yes button, you have the option of selecting the Do Not Ask Again For This Session option if you 
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plan to import multiple .ai or .pdf files.

The colour palette used to create the .ai or .pdf file is imported and a new palette is created under the imported 
file’s name.

NOTE: 
To learn about the Support CMYK in PDF/Illustrator Import option, refer to the Preferences Guide.

Importing Adobe Flash Files

If a project was started in Adobe Flash and needs a more professional boost, such as camera movements or 
multiplaning, it can easily be imported into Harmony. 

The actual *.fla file is not supported in Harmony, so you must export your project from Adobe Flash.

This chapter contains the following topics:

• Importing SWF Files on page 52

• Importing FLA Files on page 54
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Importing SWF Files

You can import .swf files in Harmony that were published using any version of Flash Player, up to version 14. 
Note that some effects may not appear when imported in Harmony. 

How to import a SWF file

 1. In the Library view, right-click on the Stage Library folder and select Right to Modify to unlock the library 
folder. Make sure the Lock icon disappears from the folder. If not, your library will remain locked and you 
will not be able to import files.

NOTE: For more information, refer to the Library  chapter in the Cut-out Animation Guide.

 2. Do one of the following:

‣ In the top menu, select File > Import > SWF, Illustrator Files to Library. 

‣ Right-click on any unlocked folder and select Import Fi les.

The browser window opens.

 3. Find and select your.swf file from the Import Files dialog box and click Open.

The Rename dialog box opens.

 4. Type a name for the new template or keep the name of the original *.swf file. 

 5. Click OK.

A new template folder is created in the Library view.

 6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until the copy 

cursor  appears before releasing the folder.
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 7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before clicking the 
Yes button, you have the option of selecting the Do Not Ask Again For This Session option. This might be 
useful if you plan to import multiple *.swf files.

The colour palette used to create the .ai or .pdf file is imported and a new palette is created under the 
imported file’s name.

NOTE: All the Flash layers are automatically attached to a parent peg called GlobalFlashPeg. DO NOT DELETE 
THIS PEG. To maintain the look of your movie, it's important not to delete this peg or detach its child layers.

The Adobe Flash file layers appear in the Timeline view. Symbols that were created in Flash become regular 
drawing layers, but can be reconverted into symbols in Harmony. Symbols within symbols or drawings within 
symbols collapse into their corresponding parent symbol.
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NOTE: Some layers in your .swf movie may be combined in a single layer as a result of optimization 
enhancements in your movie file. You can easily move these elements back onto separate layers.

In addition, all drawing elements that are dynamically linked to the Toon Boom Harmony file are grouped 
together in one folder. In our example, this means that when you scroll through the Drawing Substitution 
preview in the Library view, the different hand, leg, tentacles, antennae, torso and facial positions are all 
organized together.

Redistributing Elements

In some instances, due to an optimization enhancement in the exported SWF file (CS4), some of the layers might 
be combined as a single layer. If so, you can quickly redistribute these elements onto individual layers again. 

How to distribute to layers

 1. In the Tools toolbar, click the Select  tool.

 2. In the Camera view, select the drawing that contains elements you want to redistribute onto individual lay-
ers.  To select the all the elements of the selected drawing layer, press Ctrl + A (Windows/Linux) or ⌘  + A 
(Mac OS X).

 3. Do one of the following:

‣ From the top menu, select Drawing > Distribute to Layers.

‣ In the Tool Properties view of the Select tool, click the Distribute to Layers  button.

The number of drawing layers corresponding to the different grouped elements are created in the Timeline 
view. The selected elements in the original drawing layer are removed. Each element is distributed onto a 
new drawing layer.

 4. Repeat the process for each drawing that contains elements to redistribute.

Importing FLA Files

You can export files from Flash and import them in Harmony to  transfer character rigs, props and backgrounds.

Flash import is available on all three editions of Harmony on Windows and Mac OS X. It is not possible to do so 
on Linux versions.
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On the Flash side, users can work with these versions: Adobe Flash CS5 to Adobe Flash CC. Exports from older 
versions of Flash are not possible.

Preparing and Exporting Files from Flash

At the scene level (top timeline), you must have a symbol, such as a movie clip or graphic. Colour shapes, shape 
lines, drawing objects, groups and bitmaps at the scene level won’t be exported. If these elements are present, you 
will be prompted to perform a clean up of the scene level. For details on importing Flash files, see Guidelines for 
Creating a Flash File Before Exporting to Harmony on page 63

As part of preparing to import Flash files in Harmony, you must add an extension to Flash using Adobe Extension 
Manager. The extension is required in order for Flash to export files to Harmony. The extension is called Export 
to Harmony.zxp and is located here: 

OS Edition Location

Windows

Premium
C:\Program Files (x86)\Toon Boom Animation\Toon Boom Har-
mony [version] Premium\resources\flash

Advanced
C:\Program Files (x86)\Toon Boom Animation\Toon Boom Har-
mony [version] Advanced\resources\flash

Essentials
C:\Program Files (x86)\Toon Boom Animation\Toon Boom Har-
mony [version] Essentials\resources\flash

Mac OS X

Premium
Applications > Toon Boom Harmony [version] Premium Network 
> tba > resources > flash

Advanced
Applications > Toon Boom Harmony [version] Advanced Net-
work > tba > resources > flash

Essentials Applications >  Essentials > tba > resources > flash

NOTE: Before installing the extension, you must remove all Harmony offline and database preferences.

It is important to use the correct version of Adobe Extension Manager: 

• If more than one version of Flash is installed on your computer, be careful where you install the extension. If 
it's added to Adobe Extension Manager of Flash CS6, the extension will only be added in this version and not 
the other.

• If you have a previous version of the  extension, you must remove it first and install the latest extension—see 
How to remove a previously installed Export to Harmony.zxp extension (if applicable) on page 57.

When you export your files, a folder will be created that contains the stage.tpl and export.json files, as well 
as all the .swf and .txt  files in your scene. The export.json file is used by a Harmony script to organize and 
construct the node system from your exported files.

How to install the Toon Boom Animation extension

 1. To remove your Harmony offline or database preferences (if any), open the following folder: 

Windows:
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• Toon Boom Harmony Premium: C:\Users\[user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Harmony

• Toon Boom Harmony Advanced: C:\Users\[user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom StageAdvanced

• Toon Boom Harmony Essentials: C:\Users[\user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom StageEssentials

Mac OS X: 

• Toon Boom Harmony Premium: /Users/[user_name]/Library/Preferences/Toon Boom 
Animation/Toon Boom Harmony

• Toon Boom Harmony Advanced: /Users/[user_name]/Library/Preferences/Toon Boom 
Animation/Toon Boom Stage Advanced

• Toon Boom Harmony Essentials: /Users/[user_name]/Library/Preferences/Toon Boom 
Animation/Toon Boom Stage Essentials

On Mac OS X, the Library folder is a hidden folder. To display the display the folder, told down the Alt key.

‣ Global: [Server_Name] > USA_DB > scripts

‣ Environment: [Server_Name] > USA_DB > environments > [environment_name]

‣ Job: [Server_Name] > USA_DB > jobs > [job name]

‣ User: [Server_Name] > USA_DB > users > [user_name] > stage > 1200-scripts

 2. Delete these folders:

‣ full-1200-pref

‣ 1200-scripts

 3. In Adobe Extension Manager, click Install.

 4. Locate and open the Export to Harmony.zxp file.

A message opens informing you that you're about to install the Export to Harmony extension.

 5. Click Accept.

You may see the following message confirming that you want to install the extension. Click Install.

 6. In order for the changes to take effect, you must close and restart Adobe Flash.
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 7. Click OK.

How to remove a previously installed Export to Harmony.zxp extension (if applicable)

 1. If open, close Adobe Flash.

 2. Start Adobe Extension Manager.

 3. From the Products list, select Adobe Flash. 

If you have a previous version of the Export to Harmony.zxp extension installed, it will be listed in the 
right pane.

 4. Select the extension and click Remove.

A message opens asking you to confirm the removal of the extension.

 5. Click Yes.

How to export FLA files from Adobe Flash

 1. Open your.fla file in Adobe Flash. 

NOTE: In case of a new file, it needs to be saved before continuing the exportation process. If not, the export won't be 
completed.

 2. Return to the scene level.

Before exporting to Harmony, it is assumed that you are at the scene level even if you're not.

 3. Do one of the following:

‣ Older versions of Adobe Flash: Select Window > Other Panels > Export to Harmony. 

‣ Adobe Flash CC: Window > Extensions > Export to Harmony.

57



Chapter 2: Import     

NOTE: This window must be opened once after installing the extension in the extension manager because it 
creates a drect link to Harmony (even if the window is not used). Afterwards, you do not have to reopen it if there is 
no need to change the option.

The Export to Harmony window opens from which you can set the resolution of the files as it will appear in 
Harmony. The default resolution is set to 1920 x 1080, like the HD default resolution value of Harmony. If 
needed, you can change the compression: Photo (JPG) or Lossless (PNG).

 4. Do one of the following:

‣ In the Export to Harmony window, click Export button. 

‣ Select Commands > Export to Harmony.

The Output tab displays information about the conversions necessary for the export including:

Distributing to layers, breaking apart, the presence of shapes at the scene level, ungrouping all groups to 
verify if any symbols are hidden inside, breaking drawing objects to transfer them as shapes, drawing 
substitutions, and so on. Problematic situations will also be mentioned. If nothing appears in the Output 
tab, then your.fla file is clean and does not need any conversions.

The .txt files contain the drawing substitution information and at which frame they are exposed. A .swf 
file is created for each symbol in Flash and a .tpl file is created of them. The corresponding export.json 
file is also created, which you will need when importing your Flash scene in Harmony. These files are in a 
folder located at the same location as the.fla file.  The folder name is the same as the .fla file.

NOTE: If  a folder with the same name as the .fla file already exists, you will be prompted to replace the folder. 
Be aware that saving Flash projects as .xfl files will automatically create a folder with the same name as the .fla 
file. In this case, the folder of the export will be created inside the folder of the xfl. If this not what you want, place 
a copy of the.fla in another path on your computer before the export.
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Importing Flash Files in Harmony

When importing Flash files, the Scripting toolbar must be displayed, which should contain the Import Flash Scene 
icon. If the icon does not appear in the toolbar, add it to the Scripting toolbar. Note that you will only have to do this 
once. After that, you can import Flash files whenever needed.

How to display the Flash icon

 1. From the top menu, select Windows > Toolbars > Scripting.

The Scripting toolbar bars appears below the File toolbar in the upper-left of the Harmony interface.

 2. Click the Manage Scripts  button.

The Scripts Manager opens.
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 3. From the Files section, select TB_Import_Flash_Scene.js. 

On your computer, here is the location of the script file:

 l Global: [Server_Name] > USA_DB > scripts

 l Environment: [Server_Name] > USA_DB > environments > [environment_name]

 l Job: [Server_Name] > USA_DB > jobs > [job name]

 l User: [Server_Name] > USA_DB > users > [user_name] > stage > 1200-scripts

 5. From the Functions section, select TB_Import_Flash_Scene and click the arrow button to move it to the 
In Toolbar section.

 6. Click OK.

The Import Flash icon appears in the Scripting toolbar. Everything is now ready to import Flash scenes.
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How to import FLA files

 1. In the Scripting toolbar, click the Import Flash  button.

 2. In the Import Files dialog box, locate the export.json file contained in the folder that was created when you 
exported your files from Flash.

 3. Click Open.

In a few moments, the colour recovery dialog box appears, requesting a colour recovery. 

 4. Before clicking Yes, you have the option of selecting the Do Not Ask Again For This Session option. 

In a few moments, the .fla files are imported in Harmony. 
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 5. In the Node view, press 1 to zoom out of the Node view and see the entire node system.

Your Flash Scene in Harmony

Once the Flash project is successfully imported into Harmony, here's how the node system was constructed:

• Each symbol has its own peg in which all the transformation information is stored.

• Whenever there are more than three symbols nested inside a symbol, a Composite node is automatically 
created to group them all.

• The pivot information is stored in the peg's Layer Properties (Pivot fields). The pivot information came from 
the rotation point of the symbol in Flash.

• Registration point of the symbol in Flash represents the centre of the drawing space in Harmony. 
Therefore, the position of the drawing inside a symbol will be exactly the same in Stage.
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• The imported node system is connected to the Composite of the scene, which contains the Write and 
Display nodes.

• One colour palette is created for each Flash import. One colour swatch is created per RGB value. If you have 
more than one zone using the same colour, they will be linked to the same colour swatch.

• If there are masks in your Flash project, they will reconstructed in Harmony using Cutter effects. Harmony is 
now able to understand when more than one symbol share the same mask in Flash. Each symbol sharing the 
same mask will be grouped by a composite and connected to the cutter.

Guidelines for Creating a Flash File Before Exporting to Harmony

Scene Root

What can be at the scene root:

• Only symbols. A minimum of one symbol is necessary. It could be a MovieClip or a graphic.

What cannot be used at the scene root:

• Shapes: Colour shapes and line shapes

• Bitmaps

• Drawing objects

• Groups: The group works differently at the scene level. They are understood as shapes at the scene level—
see Mixed Layers on page 65.

Timeline

These features can be used in the Flash file, but will not appear in Stage Premium:

• Guide layers for references

• Locked layers

• Disabled layers

• Folders in the Timeline view
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• Other: Several symbols on the same layer/keyframe. In this case, Stage Premium will separate them, 
giving them a proper layer/Drawing node. In other words, a Distribute to Layers action performed in the 
process of exporting/importing.

Not recommended:

• Mixed layers—see Mixed Layers on page 65

• Symbols with shapes, bitmaps, or group on the same layer/keyframe

• Symbols with drawing objects

Library View

In the Library view, the following will not be exported:

• ActionScript Linkage

• Embedded fonts

Effects

The following effects will not be exported:

Filters

Adjust Colour

Drop Shadow

Blur

Glow

Gradient Bevel

Gradient Glow

Colour Effects (other than None)

Alpha 

Advanced 

Brightness

Tint

Display 

Blending (other than Normal):

• Layer

• Darken

• Multiply

• Lighten

• Screen

• Overlay

• Hard Light

• Add

• Subtract
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• Difference

• Invert

• Alpha

• Erase

 

Render: Cache as Bitmap

Component parameters

Drawing Features

• Width tool: Any change on the thick and thin of a line

• Line: 

• Width

• Cap: Any change of the line cap will be replaced by the round cap (None and Square)

• Join: Any change of the line join will be replaced by the round join (Miter and Bevel)

• Gradient (Flow): Reflect colour, Repeat colour

• Import Bitmap: When importing .swf files, you can import files that have an image compression of Photo 
(JPG) or Lossless (PNG). 

Mixed Layers

Mixed layers are something you must seriously consider before trying to export a Flash project to Harmony. 
Otherwise, there can be unexpected results or no export at all. In fact, it's best to avoid having mixed layers 
altogether.

A mixed layer is defined as a layer that has more than one instance of objects at the same keyframe. It could be a 
mix of symbols and groups; groups and drawing objects; symbols and shapes, and so on. Since Harmony 
understands symbols better than groups or drawing elements, some information can be lost along the way.

Understanding Drawing Objects and Groups

Drawing Objects  

No matter what is inside a drawing object, it will always be understood as a shape. So if a drawing object shares the 
same layer with a shape, it won’t be a real mixed layer, since they are all understood as shapes.

Groups that Contain Only Symbols (MovieClip or graphic)

When there is a symbol inside a group, the group will be ungrouped automatically during the export from Flash. The 
symbol inside it will be understood by Harmony as a Drawing node.

But if there is more than one symbol inside the group, all the symbols will be understand as if they were only one 
symbol. For example, if you have a group containing five MovieClips and one graphic, Harmony will create one 
Drawing node to  contain the five MovieClips and one graphic. This can be useful when you want to create a 
repetitive texture and you don’t want to have each repetition separated in Harmony. There is no differentiation 
between symbols.

Groups that Contain Symbols and Shapes
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When there is one or more symbols with shapes inside the same group, the group will be ungrouped automatically 
during the export from Flash, but all the symbols and shapes will be exported as if they were one symbol. There is 
no differentiation between symbols and shapes.

Mixed Layers

Symbols and Groups on the Same Layer 

If there are symbols and groups sharing the same layer, each symbol will be separated from all the groups which 
will then be grouped together as one element. In Harmony, each symbol will have its own Drawing node, but all 
groups share one Drawing node. Since only symbols can have a name, its name is propagated to the Drawing 
node and peg. 

Groups, however, will receive the name of the MovieClip followed by an underscore and an appropriate number. 
For example, of you have a group inside a symbol called HEAD, the group will receive the name HEAD_1 if there 
is already a Drawing node that was created with the same name.

Symbols and Drawing Objects/Shapes on the Same Layer

If there are symbols and drawing objects/shapes sharing the same layer, the symbols will be separated from 
them and all the drawing objects/shapes will be kept together. Drawing objects and shapes cannot be separated. 
In Harmony, the symbols will have their own Drawing node and the drawing objects/shapes will share the same 
Drawing node. Since only symbols can have a name, its name is propagated to the Drawing node and peg.

Drawing objects and shapes, however, can't do this. Drawing objects and shapes will receive the name of the 
MovieClip followed by an underscore and an appropriate number. For example, if you have a group inside a 
symbol called HEAD, the group will be named HEAD_1 if there is already a Drawing node that was created with 
the same name.

Groups and Drawing Objects or Shapes on the Same Layer

In order to have groups and drawing objects/shapes on the same layer, these elements must first be inside a 
symbol. Groups and drawing objects/shapes sharing the same layer in Flash will be exported as one Drawing 
node. This Drawing node will contain both drawing objects and shapes, and receive the name of the symbol in 
which they are contained.

Mixed Instances at the Same Level as a Symbol

Mixed instances at the same level as a symbol can occur when, at the same level inside a symbol, there is more 
than one type of element sharing the same timeline at a specific frame. Those elements may be mixed layers.

Type of problems that can occur if mixed instances are kept:

• Order of appearance can be lost

• Some layers can merge together

• Transparency of shapes can cut other shapes
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Importing QuickTime Movies

When creating an animation, it is not unusual to embed moving elements saved as videos within the animation. 
Toon Boom Harmony allows you to import QuickTime movies into your project. 

How to import a QuickTime movie

 1. From the top menu, select File > Import > Movie.

 2. Browse for the QuickTime movie to import and click Open.

The Import Images dialog box opens.

NOTE: Do not browse for the movie file again. Leave the automatically generated field text as “many files selected”.
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 3. Make your decisions for the Layer, Alignment and Transparency sections of this dialog box—see Importing 
a Bitmap Image Without Vectorization on page 10.

 4. Click OK.

The QuickTime video appears in the Timeline view as an image sequence. You can scroll through the film 
frame-by-frame just as you would scroll through your animation drawing-by-drawing.

Creating Custom Vectorization Parameters 
You can create your own vectorization settings with Harmony. The vectorization parameters you create can be 
saved, shared and also inserted into the VectOptions.conf file used by the Scan and Control Center modules 
when scanning or vectorizing a series of drawings.

You can use an interface to select and test the different options, as well as type in some advanced settings.

The Vectorization Parameters dialog box lets you vectorize pencil drawings, along with any red, blue or green 
pencil marks you may have used to indicate highlights and shadows. The drawing will be vectorized into pure red, 
blue, green and black (RGB values), while creating colour art zones wherever lines connect. After painting in your 
tones and highlights, change your pure RGB colours to transparent (0 Alpha) in the Colour Picker window and 
watch the indicator colour zone lines disappear.

How to open the Vectorization Parameters dialog box

 1. From the top menu, select File > Import > From Scanner.
You can also open it from any other import option that allows you to customize the vectorization para-
meters (i.e. from the scanner).

 2. In the Scan Drawings window, do the following:

‣ In the Layer section, decide on the layer options.

‣ In the Import Options section, select the Convert to Toon Boom Vector Drawing option

‣ Click Preview.
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 3. In the Vectorization section, click the Vectorization Parameters button.

The Vectorization Parameters dialog box opens.

• Options Tab  on page 69

• Help Tab on page 71

Options Tab 

The Options tab contains the main vectorization settings. More settings are available in the Help tab.

Parameter Description
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Input

The input filters are applied to the bitmap image before it is vectorized.

One Pass: One threshold value is applied to both the Line and Colour Art. For 
drawings with distinct vector-style lines of mattes, you only need one pass.

Two Passes: Applies a different threshold value to each layer. For greyscale 
drawings, you may want to perform the vectorization process twice to apply dif-
ferent threshold values to the Line and Colour Art layers.

Threshold: Determines which values in the scanned image are considered part 
of the Line or Colour Art layer and what will be eliminated from the vectorized 
drawing; 0% is white and 100% is black. The threshold is between these two 
values.

Expand Bitmap: Lets you enter a value to scale the bitmap to detect small 
variations in the line. Use this option if you scanned a greyscale image and want 
to preserve small variations in the texture to apply to the line art.

Jag Filter: Lets you enter a value to scale back the bitmap to remove some of the 
line’s roughness. This is useless when you have a drawing that appears quite 
rough; the Jag filter will eliminate excess strokes in the final drawing.

Output

The output filters are applied during the vectorization process.

No Colour Art: Does not generate filling zones in the Colour Art layer.

No Texture: Does not generate texture in the Line Art layer in the final images. 
Select this option to create solid lines in the final line art.

Generate Matte in Underlay Layer: Creates an opaque zone behind your 
drawing’s lines to avoid seeing through the layers.

Colour as Texture: Converts colour values into a texture layer.

Optical Registration

The optical registration options are used to automatically align drawings based on 
the position of the peg holes on the animation paper. The peg holes must appear 
in the scanned drawings for the optical registration to work.

DPI: Lets you enter the dots-per-inch value of your image. You must enter the 
same value as the DPI used to scan the image.

Peg Side: Lets you select the position of the peg holes on your drawings. Identify 
whether they are on the top, bottom, left or right.

Strictness: Determines how exact the location of the peg holes must be for the 
software to recognize them. There are two values to choose from:

• Strict: The peg holes must be in a tightly defined area to be recognized.

• Loose: The peg holes can be recognized somewhere in a larger area. This 
is the recommended setting.

Field Chart: Lets you indicate the size of the animation paper, 12 or 16.
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Post Processing

The Post Processing filters are applied to the final vector images.

Remove Holes: Removes holes of a specified value that might make painting 
difficult.

Remove Dirt: Removes stray marks and dirt of a specified value. Try a value 
around 500.

Remove Hair Size: Removes small strokes that have no line art.

Remove Hair: Number of Passes: The number of times the drawing will be 
analyzed to identify hair marks.

Miscellaneous

Close Gaps: Closes gaps in the Colour Art so you can paint it.

Smooth Passes for Line Art Before Breaking Triangles: The number of times 
the smoothing operation runs before creating the triangles that break lines in the 
drawing. If unnecessary triangles are appearing in the drawing, increase this 
value.

Smooth Passes for Line Art: The number of times the smoothing operation is 
performed after the triangles have been created. This further smooths the line art.

Preview
Show Strokes: Shows the strokes in the Vectorized Image panel.

Stroke Thickness: Shows the size of the strokes.

Help Tab

The Help tab contains the most advanced vectorization settings which you type in the Advanced Option fields at the 
bottom of the Vectorization Parameters dialog box.

File IO Options 

-file <filename (including extension)> [ options ]

-infile <filename (including extension)>; same as -file

-outfile <filename>; alternate output file

-informat <format>; the input format. Used if reading from stdin

-debug; turn on debug mode

-noforce; don't force output if image is inconsistent
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-version; print version information and quit

-output_version <version>; output files of this version. Valid versions can be: 0 or 604

-force_unamed_palette_for_texture; will generate a texture in TVG's internal palette

Registration Options 

-register <dpi side strictness>; perform optical registration.

• Side can be one of left, right, top, bottom or l, r, t, b.

• Strictness can be either loose, strict or l, s.

-register_center_peg_holes; will use only round holes in 16 fields page

-rcph; short form of register_center_peg_holes

-registration_looseness_factor <factor>; registration looseness factor (default 2.000000)

-rlf; short form of registration_looseness_factor

-rdebug; output registration debug messages

-pegpitch <inch (default 8.000000)>; distance between peg bars

-threshr < (default 0.500000)>; threshold for optical registration; range 0.0 to 1.0

-rmargin <inch (default 1)>; region size where to look for peg bars 

-peg_distance_from_center <inch (default 5.25)>; peg distance from centre of the image 

-pdfc; short form of -peg_distance_from_center 

-out_peg_position <side (default same)>; wanted position of the peg on the drawing.

• Can be one of right, left, top, bottom (or r, l, t, b) or same.

• A rotation will be performed if it is different from the side passed to -register.

-output_peg_matrix; output the peg transformation matrix on standard output.

-scanner_calibrate; < (default 1.0000 1.0000) > x and y scale factors to be applied to scanner image.

Filtering Options 

-pixel <pixel_shape (default '4x3')>; Valid values: 4x3

-gap <worldUnits (default 10)>; close gaps up to this big

-pencil; generate line art only

-keep_dirt; don't filter out dirt

-thresh <threshold (default 0.2)>; range 0.0 to 1.0

-rmv_hairs <worldUnits (default 1)> <passes (default 1)> 

• remove hairs of size smaller than "size" in "passes" passes 

-rmv_holes <area (default 7)>; remove holes smaller than "area" 

-rmv_dirt <area (default 1)>; remove dirt smaller than "area" 
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• try values between 100 and 500 for rmv_holes and rmv_dirt. The area is in world units squared

-rmv_triangles <worldUnits (default 30.000000)>; remove triangles at "pixels" 

• distance from each other. Use -no_break to remove all triangles

-no_texture; don't generate textured strokes

-color_as_texture; will vectorize the alpha channel and put the RGB colour in a textured colour

-noclosegap; disable all gap closing algorithms

-no_break; disable the breaking of line art

-jag_filter <pixels (default 0>; expand the pixels in the vectorization bitmap

-expand_bitmap <pixels (default 0>; expand the pixels in the vectorization bitmap

-fit_errorc <error (default 1.000000>; fitting error for the colour art

-fit_errorl <error (default 1.000000>; fitting error for the line art

-smoothl <passes (default 1>; number of smooth passes for line art

-smoothc <passes (default 1>; number of smooth passes for colour art

-first_smooth <passes (default 0>; number of smooth passes for line art before breaking triangles

-first_smoothl <passes (default 0>; number of smooth passes for line art before breaking triangles

-first_smoothc <passes (default 0>; number of smooth passes for line art in colour art pass (needs -2pass)

-2pass; specify two sets of parameters; one for line art "l", one for colour art "c"

(-thresh, -rmv_holes and -rmv_dirt will be overridden by -threshl, threshc, -rmv_holesl,

-rmv_holesc, -rmv_dirtl and -rmv_dirtc)

-threshl <threshold for line art (default 0.5)>; range 0.0 to 1.0

-threshc <threshold for color art (default 0.5)>; range 0.0 to 1.0

-jag_filterl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art

-jag_filterc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art

-expand_bitmapl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art

-expand_bitmapc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art

-rmv_holesl <area (default 7)>; remove line art holes smaller than "area" 

-rmv_holesc <area (default 7)>; remove colour art holes smaller than "area" 

-rmv_dirtl <area (default 1)>; remove line art dirt smaller than "area" 

-rmv_dirtc <area (default 1)>; remove colour art dirt smaller than "area" 

try values between 100 and 500 for rmv_holesl, rmv_holesc, rmv_dirtl and rmv_dirtc. The values are in world 
units squared 

-margins <inch (default 0.25)>; remove margin around bitmap 

-top_margin <inch (default 0.25)>; remove margin at top of bitmap 

-bottom_margin <inch (default 0.25)>; remove margin at bottom of bitmap 
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-left_margin <inch (default 0.25)>; remove margin at left of bitmap 

-right_margin <inch (default 0.25)>; remove margin at right of bitmap 

-remove_peg_bars; remove the peg bar holes

-field_size <fields (default 12 or use value in scan file)>; set the drawing to this field size

-fs; short hand for -field_size

-peg_bar_size <inch (default 1)>; the size of the peg bar region

-noframe; do not put a frame around the colour art

-frame_fields <default -1.000000>; put a frame of the specified dimension around the colour art

-downscale_input <default 1>; downscale the raw input by this integer factor

-downscale_texture <default 1>; downscale the output texture by this integer factor

-buildmatte; generate a matte on underlay for line test

-buildmatte_colourart; generate a matte on colour art for line test

Note: -buildmatte and -buildmatte_colourart are mutually exclusive

-copystrokes; copy original strokes when building matte.

Options for bitmap that has no registration information 

-pixel_margins <inch (default 0)>; remove margin around bitmap 

-top_pixel_margin <inch (default 0)>; remove margin at top of bitmap 

-bottom_pixel_margin <inch (default 0)>; remove margin at bottom of bitmap 

-left_pixel_margin <inch (default 0)>; remove margin at left of bitmap 

-right_pixel_margin <inch (default 0)>; remove margin at right of bitmap 

-dpi <(default -1)>; dpi information of input bitmap 

RGB Keying Options 

-rgb; generate separate zones for red, green and blue lines

-rgb_alpha <value (default 255)>; generate red, green and blue colour with alpha of this value

-no_red; ignore red colour in vectorization

-no_green; ignore green colour in vectorization

-no_blue; ignore blue colour in vectorization

-flatten; flatten the drawing after generating colours

-rmv_rgb_dirt <threshold area default 0.0>; remove red, green and blue regions smaller than area

-expand_bitmap_rgb <pixels (default 0>; expand the pixels in the vectorization bitmap for rgb

-threshrgb <value> <threshold for rgb vectorization default 0.200000>;
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-threshsv <saturation threshold default 0.500000> <value threshold default 0.500000>; thresholds on saturation and 
value to consider a pixel to be grey

Colour Vectorization Options 

-color_vectorize; perform a colour vectorization

-file2 <colour art filename>; specify the colour art bitmap

-penstyle <center alpha (0.0-20.0)> <edge alpha (0.0-20.0)> <gamma (0-10)><centre pressure effect (0.0-1.0)> 
<edge pressure effect (0.0-1.0)><texture bitmap downscaling (0.2-20)> <texture bitmap file (valid filename or "" if no 
file)>; generate brush texture for the line art

-pressure_variation <strategy (0, 1 or 2)> <min pressure (0.0-1.0)> <max pressure (0.0-1.0)> <max variation (0.0-
1.0)>; specify a pressure strategy for the centre line. 

-blur_radius <pixels (default 0)>; blur the penstyle texture generated

-color_contour_smooth_passes <times (default 3)>; perform number of smooth passes on contour before 
computing texture

-ccsp <times (default 3)>; short for -color_contour_smooth_passes

-color_rmv_holesl <world units (default 0.000000)>; remove holes of this size when computing texture

-color_fill_holesl <world units (default 0.000000)>; fill holes of this size for colour line art

Bubble Usage (implemented only for colour vectorization's line art)

-create_bubbles; add bubbles into the LineArt. Implemented for colour vectorization only 

-bubble_gap <value (default 3)>; max number of colour art points between 2 bubbles

-bubble_length <value (default 10)>; max number of circles in a bubble

-min_radius <value (default 1.5000)>; min radius of a circle in a bubble relative to the line thickness (must be >= 
1.0)

-max_radius <value (default 3.5000)>; max radius of a circle in a bubble relative to the line thickness (must be >= 
1.0)

-uniform_gap; the space between bubbles is constant 

4 Colour Vectorization

-4colours [key:value] ... [key:value] ; The key value list can be empty. The list of keys is:

rgbdiff:value ; between [0.0-1.0] or [0-255]

dark:value    ; between [0.0-1.0] or [0-255]

grey:value    ; between [0.0-1.0] or [0-255]

white:value   ; between [0.0-1.0] or [0-255]

dirt:value    ; dirt area. 200 is a good value

rt:value      ; between [0.0-1.0] or [0-255]

gt:value      ; between [0.0-1.0] or [0-255]
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bt:value      ; between [0.0-1.0] or [0-255]

NOTE: 
There must be no space between the colon and the key/value. For example: -4colours rgbdiff:20 dark:20 grey:120 
white:250 dirt:200 rt:240 gt:240 bt:240

Creating a Vectorization Style 

With Harmony, you can create custom vectorization parameters that can be saved, reused, shared, or used to 
set the Scan module vectorization style list.

You can vectorize drawings using one of the following methods:

• Black and White: All the lines become vector based and 100% black. The white areas become 
completely transparent.

• Greyscale: All the lines preserve their initial textured look in grey shades as a bitmap image contained 
inside a vector frame. The white areas become completely transparent.

• Four Colours: With the advanced parameters, you can isolate the red, green, blue, and black lines and 
turn them into 100% vector lines, preserving their original colours—see Creating Custom Vectorization 
Parameters  on page 68.

How to create or modify the vectorization parameters

 1. Set the different options available in the Vectorization Parameters dialog box.
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 2. Click the Vectorize  button to update the Vectorized Image preview.

The vectorized image is just a preview. The actual vectorization happens when you click OK in the Import 
Images dialog box. There are many options to try in the Vectorization Parameters dialog box. These are 
applied during the vectorization process.

 3. To set advanced parameters, read the information on the Help tab, then type in the Advanced Options field at 
the bottom of the dialog box.

 4. To save your vectorization parameters to reuse them later, share them, or use them to set the Scan module 
vectorization style list, click  Save.

 5. In the Browser window, name and save the file.

 6. To save the current settings as your default settings, click Save As Default. To restore the default settings, 
click Restore Defaults.

 7. To load a vectorization style, click Load and locate the existing *.vof file.

 8. Click OK.
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Setting the VectOptions.conf File

Toon Boom Harmony Server uses a file called VectOptions.conf to get the vectorization style when batch 
vectorizing a series of drawings. A series of default styles is available in this file, but you will certainly want to 
create your own to fit your production style.

How to set the VectOptions.conf file on Windows or Mac OS X

 1. Open the vectOptions.conf file:

‣ Windows: Select Programs / All Programs > Harmony 12.2 > Tools > Configuration Editor.

‣ Mac OS X: Select Applications > Harmony 12.2 > Tools > Configuration Editor.

The Configuration Editor window opens.

 2. In the bottom section of the window, select the VectOptions.conf tab.

 3. Scroll down the VectOptions.conf file to see all the different options available for creating your custom vec-
torization style. These options are the same as in the Vectorization Parameters dialog box. It is recom-
mended that you create your vectorization style using Harmony and the Vectorization Parameters window 
and copy the result parameters in this file—see Creating a Vectorization Style  on page 1.

 4. Scroll down toward the bottom of the file to see the default styles. You can modify them or add new ones 
to the list using the parameters you got using the Vectorization Parameters window. Notice that some of 
the lines have a “#” sign at the beginning to indicate that the line is a comment and will not appear in the 
style list. The lines that have no sign at the beginning appear in the style list.
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 5. To create a new style, type the following below the existing styles: 

style_name:

This should be followed by the name of your new style. For example: style_name: Black Lines.

 6. Under the style name line, type the following: 

options:

 7. Copy and paste the information in your *.vof style when saving your settings in the Vectorization Parameters 
window.

‣ To open the *.vof file, use any plain text editor application.

 8. In the Configuration Editor’s top menu, select File > Save.

 9. If you have Toon Boom Harmony Scan on your computer, you can start the application and verify that the 
new style appears in the Vectorization Style list under Edit > Vectorization Style.  
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NOTE: 
If you are using the batch processing method available with Toon Boom Harmony Server to scan and vectorize 
drawings, the selected style must be available on all the machines included in the batch processing list.

Refer to the Control Center Guide Guide to learn more about setting up and using batch processing.

How to set the VectOptions.conf file on Linux using the vi text editor

 1. Open a Terminal window:
Menu: Applications > System Tools > Terminal

 2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_12.2/etc

 3. Change your user to "root":

$ su

‣ If your user is part of the sudoers list, enter the following command and go to step 5. 

$ sudo vi VectOptions.conf

 4. Enter the root password.

 5. Open the VectOptions.conf file:

$ vi VectOptions.conf

 6. To start editing, press I to enter Insert mode.

 7. When you're finished editing the file, press Esc to exit Insert mode.

 8. To save the changes made to the file, type the following and press Enter/Return:

$ :w!

 9. To exit the vi editor and return to the Terminal, type the following and press Enter/Return:

$ :q
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 10. If you have Toon Boom Harmony Scan module on your computer, start the application and verify that the new 
style appears in the Vectorization Style list under Edit > Vectorization Style.

NOTE: 
If you are using the batch processing method available with Toon Boom Harmony Server to scan and vectorize 
drawings, the selected style must be available on all the machines included in the batch processing list.

Refer to the Control Center Guide Guide to learn more about setting up and using batch processing.

How to set the VectOptions.conf file on Linux using the gedit text editor

 1. Open a Terminal window:
Menu: Applications > System Tools > Terminal

 2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_12.2/etc

 3. Change your user to "root":

$ su

‣ If your user is part of the sudoers list, enter the following command and go to step 5.

$ sudo gedit VectOptions.conf

 4. Enter the root password.

 5. Open the VectorOptions.conf file:

$ gedit VectOptions.conf

 6. Edit the parameters of the VectOptions.conf file as you would do in most text editor applications.

 7. Select File > Save.

 8. Select File > Quit.

 9. If you have Toon Boom Harmony Scan module on your computer, start the application and verify that the new 
style appears in the Vectorization Style list under Edit > Vectorization Style.
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NOTE: 
If you are using the batch processing method available with Toon Boom Harmony Server to scan and vectorize 
drawings, the selected style must be available on all the machines included in the batch processing list.

Refer to the Control Center Guide Guide to learn more about setting up and using batch processing.
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Chapter 3: Library

Using templates and symbols , you can share and reuse any elements you create in Harmony. The Harmony library 
lets you store several different elements such as puppets, backgrounds, animations and key poses. In fact, 
anything you create in Harmony can be stored in the library.

This chapter contains the following topics:

• Understanding the Library Concept on page 83

• Library View on page 86

• Organizing the Library on page 88

• Templates on page 92

• Symbols on page 96

• Importing Symbols and Templates on page 105

• Importing Files Through the Library on page 110

• Using Paste Special on page 111

Understanding the Library Concept
The Library view is where you can store and reuse your artwork and animation in other scenes or build props and 
puppets.

• What is a Library? on page 84

• Understanding the Library Concept on page 83

• What is a Symbol? on page 84

• Libraries in Harmony Server on page 85
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What is a Library?

The library is a storage centre for all production assets; the elements stored in the library are called templates. 
Although it is mainly used for cut-out animation, the library is also useful for paperless and traditional animation 
processes. The library can contain any asset used in a Toon Boom Harmony production. 

Using the library is as simple as dragging the content into the library to store your artwork and then dragging it to 
the Timeline or Camera view when you want to reuse it.

You can organize your library using several different subfolders and store them on your hard drive or network.

What is a Template?

A template is an individual copy of the artwork stored in the library which you can reuse in different scenes. Once 
a template is stored in the library, you can access it from any project.

Dragging a template into your scene copies the content in your Timeline and does not link it to the original. You 
can modify this individual copy at any time.

What is a Symbol?

A symbol is a container used to build your props, puppets and looping clips. You can use symbols to contain 
artwork and animation and manipulate them as a single object. You can also use symbols as a placeholder in 
which you place a series of different drawings for each body part of your puppets or when you have a repeating 
cycle. However, symbols are not necessary for creating characters. 

To create a symbol, drag your artwork to the Symbol library. When you drag a symbol from the Symbol library into 
your scene, it will be linked to the original symbol. If you drag a symbol into your scene several times in the 
Timeline view, they will all be linked to the original symbol. If you modify one, they will all be modified.
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A symbol is local to the project and cannot be accessed directly from other scenes. To reuse a symbol's content in 
another scene, you must create a template out of it.

When a symbol is exposed in the Timeline view, the symbol's cells are represented as a movie strip.

Libraries in Harmony Server

When working on the database, the structure of the library differs from when working on Harmony Server. 

Harmony provides three default library folders: 

• Symbols: The only library folder containing symbols for your project. You can organize the symbols library 
folder using subfolders, but you cannot create a second library for your symbols. This library is local to your 
project. 

• Environment: A folder located inside the Environment folder. Every asset stored in this folder is accessible 
from any job and scene contained within this environment. 

• Job: A folder located inside the Job folder. Every asset stored in this folder is accessible from any scene 
contained within this job. 

NOTE: You can create a folder called "library"  in the usa_db folder on the server to create a global library. Once the 
Harmonyapplication is restarted, a "Global"  library folder will automatically appear in every user's library. Every asset 
stored in this folder is accessible from any scene, job and environment. 

85



Chapter 3: Library     

Library View

You use the Library view to create and manage your symbols and templates, display the folders and manage and 
all of the content. 

Library View Menu

The Library menu lets you access commands specific to the Library view, such as opening a Library or getting the 
rights to modify a library folder.

Preview Window

The Preview window lets you preview the content of a symbol or template, and swap between drawings and 
symbol cells in the Timeline view. This window is also used as the Drawing Substitution window.

How to preview a template or symbol's content

 1. In the Library view's right side, click or double-click on the symbol or template to preview.

 2. In the Preview window, click the Play  button or drag the slider to scrub through the frames.
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Library Search Tool

When working on a movie or series, you will probably end up with many templates and symbols in your library. Using 
the Search tool, you can quickly find the templates and symbols in your folders.

How to use the Library Search tool

 1. From the left side of the Library view, select the library in which you want to search.

 2. In the Search field, type the name or partial name of the symbol or template you are looking for.

 3. Click the left  and right  arrows to see the previous and next results. The Search engine will look for 
results within the library master folder and its subfolders. It will not look in other libraries.

Library List

The Library list lets you navigate through the different libraries and subfolders. You can also open, close and create 
new libraries from here.

The Library folders have these default libraries:

• Symbols: The only library folder containing symbols for your project. You can organize the symbols library 
folder using subfolders, but you cannot create a second library for your symbols. This library is local to your 
project. 

• Harmony Library: This folder contains templates and is stored on your hard drive. You can organize the 
Harmony library folder using subfolders. This folder does not contain symbols.
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Templates and Symbols List

s

The symbols and templates contained in the selected Library list can be displayed on the right side of the Library 
view as thumbnails, in a list or as details.

How to access the templates and symbols list display options

‣ In the Library view's right side, right-click and select View > List, Thumbnails or Details.

‣ In the Library View toolbar, you can click the following buttons:

 Thumbnails

 List

 Details

Organizing the Library
As you will probably create a large number of symbols and templates, you will soon realize they need to be 
organized. You can create different libraries and subfolders to easily access your assets. For example, you can 
create a different library for each project and divide it into several categories, such as:

• Characters

• Props

• Backgrounds

Although you can only have one symbol library folder, you can organize it by creating subfolders.

There are two ways to create library folders. 

• Directly through your operating system

• Using Harmony's interface

Folders can be opened in Harmony when you require it. You can open any folder on your hard drive or network as 
a library. Opening a library means linking the folder to your Library view. You only need to open the library once. 
The library folder is available every time you open the application until you decide to close the library and unlink it.
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You may not always require all the library folders in the Library List. If so, you can close the ones you do not need. 
Closing a folder does not delete it; it only unlinks it from the Library view. If you want to reopen it, locate it on your 
hard drive or network and open it in the Library view.

Symbol and template libraries need to be organized. You can create different subfolders on your hard drive or in the 
Harmony Library view, so you can easily access assets. By default, any new library you link to your Library view is 
locked to prevent accidental deletion or modification of symbols and templates. You must obtain the right to modify it 
before being able to add a new folder to it.

You can delete a folder from the library if its contents are no longer needed.

NOTE: Warning: All templates and symbols in the folder will be deleted from your hard drive. Once deleted, the data 
cannot be retrieved.

Once you add a folder, you can rename it. This also renames the folder on your hard drive.

If you update the content of your libraries through your operating system, you will need to refresh your library folders 
in the Library view.

When you display thumbnails in the Library view, the system generates a series of small images (thumbnails) for 
you. You can generate template thumbnails yourself, if they do not display or if the process has been stopped.

You can also delete thumbnails if you want to send a template to another user or studio and keep your packages 
small.

How to create a library folder through your operating system

 1. On your computer, create a new folder with a relevant name in the location where you want the library to be 
stored.

How to create a library folder in Harmony

 1. In the Library View menu, select Folders > Open Library.

The Browser window opens.

 2. Browse for the location where you want to store your new library folder.

 3. Click the New Folder button.

A new folder appears.

 4. Name the new library folder with a relevant name and click OK.

The new library appears in the Library List section.
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How to open a library

 1. In the Library View menu, select Folders > Open Library.

The Browser window opens.

 2. Browse to the location of the library folder.

 3. Select the folder and click OK.

The new library appears in the Library Folders section.

How to close a library

 1. On the right side of the Library view, select the library folder to close.

 2. In the Library View menu, select Folders > Close Library.

The library closes.

How to create a folder

 1. On the left side of the Library view, select the library folder to which you want to add a subfolder.

 2. In the Library View menu, select Edit > Right to Modify.

 3. In the Library View menu, select Folders > New Folder.

The new folder appears in the Library. Click on the library containing the new folder and click the plus [+] 
sign to expand it.

How to delete a folder

 1. In the Library view's left side, select the folder to delete.

 2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and select 
Right to Modify.

 3. In the Library View menu, select Folders > Delete Folder or press Delete.
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How to rename a folder

 1. In the Library view's left side, select the folder to rename.

 2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and select Right 
to Modify.

 3. In the Library View menu, select Folders > Rename Folder.

 4. Rename the selected folder.

 5. Press Enter/Return to validate the operation.

How to refresh a library

 1. In the Library view's left side, select the folder to refresh.

 2. In the Library View menu, select Folders > Refresh or press F5.

The library displays the new content.

How to generate thumbnails

 1. In the Library view's right side, select the template in which you want to generate thumbnails.

 2. In the Library View menu, select View > Generate Thumbnails.

The progress bar appears.

How to delete thumbnails

 1. In the Library View menu, select Edit > Delete Thumbnails.

All the thumbnails contained in the library are removed.
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Templates

When you want to reuse artwork and animation from your project in other scenes, you must create a template 
from it. A template can be seen as a portable scene or package that you can drag inside your project. You can 
open a template and edit it just like any other project. If you want modify your templates, you can edit them using 
the Edit Template command.

You can create a template from both the Timeline and Node views:

• Master Template on page 92

• Creating a Template from the Node View 

• Action Templates

• Creating a Template from the Timeline View on page 94

To delete templates from your library, use the Library view. Harmony lets you undo the action if necessary. 

Master Template

You can create a master template out of a cut-out puppet you created so you can reuse it throughout a single 
project or a full production. A cut-out character's master template stores the entire rig, structure, drawings, and 
keyframes of the different poses of your puppet into a single asset.

Master templates are created from the Node view.

Creating a Template from the Node View 

The Timeline and Node views display different information about a scene. 

A main character's template, also known as a master template, is created from the Node view. This template 
contains all the connections, effects, composites, nodes, pegs, advanced groupings, function columns, scene 
lengths, drawings, timings, and so on. The template is saved in the Library view and must be imported back into 
the scene for use, either into the Node view or the left side of the Timeline view.

NOTE: If you are creating a template from a character rig master template, you should collapse everything inside a 
master peg and put a keyframe on the first frame before creating the template.
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How to create a template from the Node view

 1. In the Library view, select the folder in which you want to store the template.

 2. If the library folder is locked, right-click and select Right to Modify. 

 3. In the Node view, select the nodes for creating the template and group them. It is very important to group your 
cut-out character rig before storing it in the Library, so your files are organized.

 4. From the top menu, select Edit > Group > Group Selected Layers or press Ctrl + G (Windows/Linux) or ⌘  
+ G (Mac OS X). Make sure you have a composite under the connections before grouping, otherwise there 
will be numerous connections going outside the group.

 5. In the Node view, click on the group node's yellow button to open the Layer Properties window.

 6. In the Node view, select the group node and copy and paste it inside the template folder in the Library view or 
press Ctrl + C and Ctrl + V (Windows/Linux) or ⌘  + C and  ⌘  + V (Mac OS X).
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 7. In the Rename dialog box, give the new template a name and click OK.

Action Templates

An action template, also known as  animation template, is created from the Timeline view. This template allow 
you to reuse animations, key poses and part of an animation and contains mainly keyframes and drawing 
exposures. For example, you can reuse head positions or a leg animation from a walk-cycle and place them 
inside other animations. When it is extracted from the Timeline view, it loses the extra connections, effects, and 
groupings from the Node view.

An action template is used with a master template. It cannot be used on its own since it does not contain all the 
information required to rebuild the puppet skeleton and advanced connections. The standard process is to first 
import the master template to the Node view or Timeline’s left side, and then slide the action template into the 
Timeline’s right side. This allows you to first build the skeleton and then give it the right pose.

The combination of master and action templates will function as long as the layer order and connections are the 
same.

When you create an action template, be sure to name it so you can easily identify it as an animation.

Creating a Template from the Timeline View

How to create a template from the Timeline view

 1. In the Timeline view, select some cells or layers.

 2. In the Library view, select a folder to store the template.

 3. If a library folder is locked, right-click and select Right to Modify.

 4. Drag the selection to the  Stage Premium Library folder or any other library folder.
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 5. In the Rename dialog box, give the new template a name.

To rename a template once it is created, right-click on the symbol and select Rename.

 6. Click OK.

How to delete a template

 1. In the Library view, select the folder containing the template to delete.

NOTE: If the library folder is locked, right-click on the folder and select Right to Modify.

 2. Right-click on the selection and select Delete or press Delete.

How to edit a template

 1. In the Library view, select the folder containing the template to edit.

NOTE: If the library folder is locked, right-click on the folder and select Right to Modify.
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 2. Right-click on the selection and select Edit Template.

A new Harmony application opens.

 3. Edit the template.

 4. From the top menu, select File > Save.

 5. In the top menu, select File > Quit (Windows/Linux) or Stage Premium > Quit (Mac OS X).

Symbols

A symbol combines animation, artwork or layers into a single object that you can control in one layer. You can 
also create symbols out of each body part in your cut-out puppets.

You do not need to create symbols in order to create drawings or characters in Toon Boom Harmony.

When you delete a symbol, it will be deleted from your hard drive. You can use the Undo function to retrieve the 
data. The symbol cannot be retrieved once you close the application.

When you import a symbol from the library to the Timeline view it is linked to the original symbol in the library. If 
you import a symbol into your scene several times in the Timeline view, they will all be linked to the original 
symbol. If you modify one, they will all be modified. 

If you want to edit a symbol without modifying the other instances, you must duplicate the symbol first. If other 
symbols are nested inside the new symbol, they are not duplicated. If you modify them, the original and other 
instances will also be modified.

You can either edit a symbol from the Timeline view or from the Library view.

When you edit a symbol, the drawings contained in it are not placed at the centre of the stage, but are located in 
the position where they were created. The pivot is translated at the centre of the symbol.
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When you enter a symbol to edit it, you are entering another scene with an independent timeline. You can nest many 
symbols one inside the other. To help you follow the hierarchy of your nested symbol, take note of the Editing stack 
at the top of the Camera view which displays the path to your symbol's location. You can click on the symbol's 
name to move up the chain.

You can share a symbol and use its contents (the drawings) in another scene. To do this, you must first convert your 
symbol into a template. This conversion breaks the drawing's link with both the original scene and symbol. It then 
becomes a separate entity that you can import into other projects.

How to create a symbol from a drawing selection

 1. In the Tools toolbar, select the Select  or Cutter  tool.

 2. In the Camera view, select the drawing elements to create a symbol.

 3. From the top menu, select Edit > Create Symbol or press F8.

‣ Clicking the Create Symbol  button in the Edit toolbar will create a symbol from the entire layer.

The Create Symbol from Drawing Selection dialog box opens.
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 4. In the Symbol Name field, type the name of the symbol.

‣ You can also select an existing layer from the Symbol Name drop-down menu. It will add your symbol 
on the layer's current cell. If there is already an exposure on that cell, the symbol will be added to a new 
layer.

 5. You can choose to place the current selected artwork in the drawing or remove it:

‣ To remove currently selected artwork from the drawing and place it in the new symbol, select the Cut 
Artwork From Source Drawing option. 

‣ To keep currently selected artwork in both the drawing and in the new symbol, deselect the Cut 
Artwork From Source Drawing option.

 6. Click OK.

The new symbol appears in the Library view's symbol folder and in the Timeline view as a new layer.

How to create a symbol from the Timeline view

 1. In the Timeline view, select the layer or cells from which your want to create a symbol.

 2. Do one of the following:

‣ From the top menu, select Edit > Create Symbol. 

‣ In the Edit toolbar, click the Create Symbol  button.

‣ Press F8.

‣ Drag your selection to the Symbol folder in the Library view.
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The Create Symbol dialog box opens

 3. In the Enter Symbol's Name field, type the new symbol's name.

To rename a symbol once it is created, right-click on the symbol and select Rename.

 4. Click OK.

The new symbol appears in the Library view's Symbol folder. The current selection is not replaced by the new 
symbol. The new symbol only appears in the library. You must drag it into your scene to use it.

 How to create a symbol from the Node view

 1. In the Node view, select the nodes from which you want to create a symbol.

 2. Do one of the following:

‣ From the top menu, select Edit > Create Symbol. 

‣ In the Edit toolbar, click the Create Symbol  button.

‣ Press F8.

‣ Copy and paste Ctrl + C and Ctrl + V (Windows/Linux) or ⌘  + C and  ⌘  + V (Mac OS X) your selection to 
the Symbol folder in the Library view.
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The Create Symbol dialog box opens.

 3. In the Enter Symbol's Name field, type the new symbol's name.

To rename a symbol once it is created, right-click on the symbol and select Rename.

 4. Click OK.

The new symbol appears in the Library view's Symbol folder. The current selection is not replaced by the 
new symbol. The new symbol only appears in the library. You must drag it into your scene to use it.

 

How to create an empty symbol

 1. In the Library view, select the Symbol folder.

 2. Do one of the following:

‣ In the Library view's right side, right-click and select New Symbol. 

‣ From the top menu, select Insert > Create Empty Symbol in Library.

The new empty symbol appears in the Library view.
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The symbol is ready for you to edit (add content to). To go back to the root timeline, click the Top  button 
in the Camera view.

To rename a symbol once it is created, right-click on the symbol and select Rename.

How to delete a symbol

 1. In the Library view, select the symbol to delete.

 2. Right-click and select Delete or press Delete.

‣ If the symbol is currently in use in the scene, a warning message displays. Click OK to delete the symbol 
from the library and scene.

How to edit a symbol from the Timeline view

 1. Do one of the following:

‣ In the Timeline view, double-click on the symbol's cell to edit the symbol. 

‣ In the Camera view, double-click on the symbol or press Ctrl + E (Windows/Linux) or ⌘  + E (Mac OS X)). 

‣ Click the Edit Selected Symbol  button in the Camera View toolbar's extra buttons.
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You are now inside the symbol and you are able to edit it.

 2. Do one of the following:

To return to the project's timeline, click the Top  button in the Camera view's top-left corner, press  Ctrl + Shift 
+ E (Windows/Linux) or ⌘  + Shift + E (Mac OS X). 

‣ In the Timeline view's right side, right-click and select Symbols > Leave Current Symbol.

How to edit a symbol from the Library view

 1. In the Library view, select the symbol to edit.

 2. Right-click and select Edit > Edit Symbol or double-click on the symbol.

You are now inside the symbol and you are able to edit it.
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To return to the project's timeline, click the Top  button in the Camera view's top-left corner, press  Ctrl + Shift + 
E (Windows/Linux) or ⌘  + Shift + E (Mac OS X). 

How to duplicate a symbol

 1. In the Timeline view, go to the frame where you want to duplicate the symbol.

 2. Select the symbol's cell.

 3. From the top menu, select Edit > Duplicate Selected Symbol.

In the Library view, the symbol is duplicated and in the Timeline view, the current cell and its held exposure is 
replaced with the new symbol. You can now modify the symbol's content.

How to convert a symbol into a template

 1. From the Library view, select the symbol to convert into a template and drag it to the Camera or Timeline 
view.  If you drop your symbol into the Camera view instead of the Timeline view, it will not be placed in the 
centre of your camera frame, but rather wherever your cursor drops it within the camera frame.
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 2. In the Timeline view, select the symbol's cells or layer and drag it to the Stage Library folder or to any other 
library folder. Make sure you have the right to modify the library folder.

 3. In the Rename dialog box, rename the new template.
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 4. Click OK.

Importing Symbols and Templates
There are several ways you can import symbols and templates in your scene.

Sometimes a character rig is not a straightforward matter. Rigs, which are usually saved as templates, can contain 
symbols such as a leg that was made with a patch. However, a symbol does not work in the same way as an action 
template. In the Timeline view, you can add an action template into another template of the same structure. When 
working on a layer on the right side of the Timeline view and you place a symbol into a symbol of the same structure, 
instead of being added to the previous symbol, the new symbol becomes a copy.  

For greater control over how the action template behaves when brought into the Timeline view, you can use the 
Paste Special feature—see Using Paste Special on page 111.

In Harmony, when you import a symbol in your scene, you can navigate through it in the Node view.

Since a template is like a scene, you can open the template's folder and select elements inside it such as drawings. 

Instead of importing the entire contents of a template, you may only want to import a few drawings or a palette. In 
this case, use the Open As Folder command to import the items you want. 

If you want to import a palette, simply drag the palette file into the Palette list section of the Colour view.

You can use the Expand Symbol command to extract a symbol's contents and place it on the root timeline. The 
symbol will not be removed from the Timeline view. Its contents will be copied and inserted into the root timeline. 
The symbol's layers will be parented to it in case you created motions and transformations on the drawing layer that 
contains the symbol. Breaking the hierarchy could result in the loss of any scaling and animation you may have 
created.

You can also expand a symbol within a group to avoid crowding the timeline with a series of layers. When you 
expand the symbols, the layers will be contained in a group node that you can expand to see the content.

How to import a template into the Timeline or Camera view

 1. In the Library view, select the template you want to import.

 2. Drag the selected template to the Camera view or to the left side of the Timeline view.
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 3. You can also drag a template to the right side of the Timeline view and into existing layers if the layer struc-
ture is the same as the existing one.

How to import a node view template

 1. In the Library view, select the template or symbol you want to import.

 2. Drag the selected template to the Node or Camera view or the left side of the Timeline view.
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 3. If necessary, in the Node view, connect your template to the Composite node. To do this, click its out-port 
and drag the connection to the Composite node until an in-port appears.

 

NOTE: If the template you are importing was created in the Node view, make sure to drop it in the Node view or on 
the left side of the Timeline view. Otherwise, some network connections could be broken. If you are importing a 
template containing the exact same connections as a template you imported previously, you can drop it on the 
Timeline view's right side over the existing layer. This will combine both templates and keep the same existing layers.

How to import a symbol in the Timeline view

 1. In the Library view, select the symbol you want to import.

 2. Drag the selected symbol to one of the following:

‣ The Timeline view's left side to import it into the centre of the camera frame.

‣ The Camera view to place it at the location where you release your cursor.

NOTE: This may be useful if you saved a character's body parts as separate symbols. If you dropped them into the 
Timeline view, then they would all appear in the centre, haphazardly one on top of the other. It would be more 
efficient to arrange them into their correct places as you bring them into the scene.
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How to import a template with symbols

 1. From the right side of the Library view, select the action template that contains symbols.

 2. Hold down Alt (Windows/Linux) or ⌘  (Mac OS X) as you drag it from the Library view to the right side of 
the Timeline view and drop it next to a template with the exact same rig.

The Paste Special window opens.

 3. Select the Advanced tab.

 4. Select one of the following options from the Symbols menu:

‣ Copy symbols if they do not exist: This is the default setting for this operation and will prevent 
symbols in an action template from being copied.

‣ Duplicate symbols: Makes copies of the symbols in your template.

How to navigate your symbol in the Node view

 1. In the Node view, select the symbol you want to open and press Ctrl + E (Windows/Linux) or ⌘  + E (Mac 
OS X) to use the Edit Selected Symbol command.

 2. In the Node view, inside the Symbol’s top node is the composition of your symbol. In this example, a group 
node was turned into a symbol.
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 3. In the Node view’s top-left corner, click the Top  button to return to the top node. Or press Ctrl + Shift + E 
(Windows/Linux) or ⌘  + Shift + E (Mac OS X) to use the Leave Current Symbol command.

How to open a template as a folder

 1. In the Library view, select the folder that contains the template to open. If the library folder is locked, right-
click on the folder and select Right to Modify.

 2. Right-click on the selection and select Open As Folder.

 3. In the library list section, click on the template's folder to display its content.

 4. Drag the content to the Timeline or Colour view.

How to expand a symbol

 1. In the Timeline view, select the symbol to expand.

 2. From the top menu, select Edit > Expand Symbol or press Shift + F8.
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How to expand a symbol in a group

 1. In the Timeline or Node view, select the symbol cell or symbol node you want to expand.

 2. From the top menu, select Edit > Expand Selected Symbol in a Group.

 3. In the Timeline view, click the plus sign (+) to see the group content. In the Node view, click the Expand 
Arrow to enter the group.

Importing Files Through the Library
Harmony lets you import sound files and images directly through the library. Simply open the folder containing 
your files in the Library view and drag them directly from there.

How to open a file through the Library

 1. In the Library View menu, select Folders > Open Library.

 2. Browse for the folder containing the files you want to import.
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 3. Click Open.

 4. From the Library's template list, drag the file you want to import in the Timeline or Camera view.

Using Paste Special
When you import a template in the Timeline view, all layers are created as well as drawings and keyframes. You can 
choose to import only the keyframes without the drawings or import only the drawings that are not already in your 
layers. You can adjust the behaviour using the Paste Special dialog box.When you import a symbol in your scene, 
its full length is exposed by default. If you import a symbol in the Timeline view’s left side, all the frames will be 
exposed. However, if you import it into an existing layer, you can use the Paste Special dialog box to adjust the 
import behaviour to fit your requirements.Once you set the parameters, Harmony will reuse them each time you 
import a symbol in the Timeline view’s right side until you set new parameters. 

How to open the Paste Special dialog box

 1. In the Library view, select the symbol or template to import.

 2. Press Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS X) and drag the selection to the Timeline view.

NOTE: Drop the selection in the Timeline view before releasing the keyboard shortcut key.

The Paste Special dialog box opens.

 3. Set the parameters and click OK. 
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Basic Tab

Parameter Description

Drawings

Only create drawing 
files when they do not 
exist

When adding exposures to a drawing layer, new drawings will be created only 
when drawings with the same name do not already exist in the destination.

Always create drawing 
files

When adding exposures to a drawing layer, new drawings will always be cre-
ated. If drawing files with the same name already exist, Harmony will create a 
new name for the drawing.

Paste all Frames of the 
Symbols (full movie)

When enabled, the Paste Special command exposes all the symbol's frames 
instead of only the first one.

Enforce Key Drawings Creates a key exposure on the same drawing.

Cycle

Number of Cycles Lets you set the number of cycles.

Cycle Type

Normal (forward): Pastes your selection as is, starting with the first cell and 
ending with the last.

Reverse: Pastes your selection in reverse, starting with the last cell and 
ending with the first.

Forward > Reverse: Pastes your selection as a yo-yo, starting with the first 
cell, going to the last one and ending with the first cell.

Reverse > Forward: Pastes your selection as a reverse yo-yo, starting with 
the last cell, going to the first one and ending with the last cell.
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Advanced Tab

Parameter Description

Drawings

Do Nothing Does not create or overwrite drawings.

Update Drawing Pivot
Revises the drawing pivot in the destination to use the same drawing pivot as the 
first drawing in the template. If you have a range of drawings selected in the 
destination, the pivot points of all selected drawings will be updated.

Add/Remove Exposure

Never create drawing files: When adding exposures to a drawing layer, drawing 
files will not be created.

Only create drawing files when they do not exist: When adding exposures to a 
drawing layer, new drawings will be created only when drawings with the same 
name do not already exist in the destination.

Replace existing drawings. Create drawing files when they do not exist: 
Replace drawings with the same names to update a scene with new modified 
drawings and preserve the animation.

Tip: If you don't want to lose the existing animation when pasting a 
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template,  such as when placing new drawings after the animation, 
then delete the template's animation.  It will still have updated the 
drawings but not override the existing animation.

Always create drawing files: When adding exposures to a drawing layer, new 
drawings will always be created. If drawing files with the same name already 
exist, Harmony will create a new name for the drawing.

Paste all frames of the symbol (full movie): When enabled, the Paste Special 
command exposes all the symbol's frames instead of only the first one.

Enforce Key Exposure: If there are key exposures that exist on copied draw-
ings, they are preserved when pasting. No key exposures are added. This is the 
default behavior when pasting.

Fill Gap with Previous Drawing: Fills selected area in the Xsheet or Timeline 
view with the previous drawing.

Fill to Next Key Exposure: Fills selected area till the next key exposure.

Add Remove/Keyframes

Motion Copies the properties of the selected motion keyframe to the new frame.

Velocity Copies the properties of the selected velocity keyframe to the new frame.

Rotation Copies the properties of the selected rotation keyframe to the new frame.

Scale Copies the properties of the selected scale keyframe to the new frame.

Skew Copies the properties of the selected skew keyframe to the new frame.

Force Keyframes at 
Function's Beginning 
and End

 Adds a keyframe to the beginning and end of the pasted function, reproducing the 
source function.

Offset Keyframes
When pasting functions, offsets keyframes from the function's last frame value 
by the values in the pasted function. This will continue the progression of a func-
tion instead of repeating the values.

Options

Palettes

Do nothing: Does not create, overwrite, merge or link palettes.

Reuse palettes. Copy palettes if they do not exist: Palettes in the destination 
drawings are left as they are.

Copy and overwrite existing palettes: Overwrites destination palettes with the 
palettes from the source drawings.

Copy and create new palette files: Creates new palette files, placing them at 
the same relative environment and scene level as the source. If the palettes in the 
templates were stored at the environment level of the source scene, the paste 
operation will place the palettes in the environment level of the destination scene.

Copy and create new palette files in element folder: Creates new palette files 
in the element folders of the destination scene, rather than in the same relative job 
or environment.

Copy palette and merge colours. Add new colours only: Adds new colours to 
the destination palettes and ignores colours that are the same in the two palettes.
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Copy palettes and update existing colours: Adds new colours to the 
destination palette and updates duplicate colours in the destination with colour 
values from the source.

Link to original palettes (colour model): Links the colour palettes in the 
destination scene to the palettes in the source. Use this to link drawings to the 
palettes in a colour model.

Copy scene palettes and merge colours. Add new colours only: Adds new 
colours to the destination scene palettes and ignores colours that are the same in 
the two palettes.

Copy scene palettes and update existing colours: Adds new colours to the 
destination scene palette and updates duplicate colours in the destination with the 
colour values from the source.

Symbols

Copy symbols if they do not exist: This is the default setting for this operation 
and will prevent Symbols in an Action template from being copied.

Duplicate symbols: Creates a duplicate of the symbol instead of linking the Sym-
bol instance to the original one. The new Symbol is created in the Library.

Cycles

Normal (forward):Pastes your selection as is, starting with the first cell and end-
ing with the last.

Reverse: Pastes your selection in reverse, starting with the last cell and ending 
with the first.

Forward > Reverse:Pastes your selection as a yo-yo, starting with the first cell, 
going to the last one and ending with the first cell.

Reverse > Forward: Pastes your selection as a reverse yo-yo, starting with the 
last cell, going to the first one and ending with the last cell.

Nodes
Create New Columns: A new column is created when you copy and paste 
nodes from the Node view or layer in the Timeline view. If the layers are linked to 
function curves, the function curves, drawings and timing will be duplicated.

Elements
Reuse existing elements: Lets you paste existing elements without creating 
new ones. This should be used only when pasting within versions of the same 
scene.
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Chapter 4: Scene Setup

Setting up your scene can be compared to building a set for a television show. This is the point when you position 
each scene element such as the camera frame, the background elements and the characters.

This chapter contains the following topics:

• Importing the Scene Elements on page 117

• Setting the Camera Frame  on page 118

• Positioning the Scene Elements on page 124

• Cloning and Duplicating Layers  on page 157

• Setting Up the Node Structure on page 161

• Working with Groups on page 184

• Display Concepts on page 193

• Timeline View Modes on page 196

• Creating a Multiplane on page 198

• Orthographic Camera on page 206

Importing the Scene Elements
The first step in the scene setup task is gathering the scene’s different components and then importing them into 
your project. You might need to import some backgrounds, sound files or movie clips to complete your scene. You 
can refer to the following topics to learn how to bring those elements in.

• Importing Bitmap Images  on page 10

• Importing QuickTime Movies on page 67

• Importing a Sound File on page 329

If you have trouble finding elements you imported, it is a good idea to verify if your elements are connected to your 
Composite node in the Node view. Refer to Setting Up the Node Structure on page 161 and Display Concepts on 
page 193 to learn more about the Node view connections and display concepts.

117



Chapter 4: Scene Setup     

Setting the Camera Frame 
The scene action occurs inside the camera frame, so it’s really important to set it up correctly. You can adjust the 
camera resolution and other parameters in the Scene Settings window. Refer to the Fundamentals Guide, 
Starting Harmony  chapter to learn more. If you're working in a gaming animation pipeline, you also have to 
possibility to set an orthographic camera.

The Camera layer is static which means that if you need to animate it, you must add a peg.

You need to add a camera layer to your scene, so you can edit the camera frame. You can only see one camera at 
a time. If you add several cameras to your scene, you can use the Camera list to select the active one. You could 
use this feature if you are still working on your scene composition and have different camera framing to try out.

You can reposition your camera frame directly in the Camera view, using the advanced animation tools. Another 
way to set up your camera frame is to type the coordinates directly in the camera's properties. Doing this 
positions the camera precisely where you want it to be rather than gauging it visually.

You can easily reset the camera to its original position. Using the Reset command, you can reset the value of the 
selected element to the initial value of the active tool. For example, if the Rotate  tool is active, the 
transformation angle will be reset to 0 and if the Transform  tool is active, then all parameters values will be 
reset.

You can change the near and far clipping planes of the camera. The near plane is the point on the camera cone 
where the camera is located. The far clipping plane is the far end of the camera cone. Nothing outside that range 
is visible. This is useful when dealing with 3D elements and 3D sets.  For example, the camera can be looking 
inside a 3D box or room and you might want the foreground wall to not obstruct the view of the interior. By default, 
the near clipping plane is set to 1 field and the far clipping plane is set to 1000 fields.
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How to add a camera in the Timeline view

 1. Do one of the following:

‣ In the Timeline view, click the Add Layer  button and select Camera.

‣ From the top menu, select Insert > Camera.

A new camera layer is added to the scene and appears in the Timeline view.

NOTE: You cannot add a camera inside a symbol.

How to add a camera in the Node view

 1. In the Node Library view, select the Camera node from the Favourites or Move category.

 2. Drag the Camera node to the Node view.

119



Chapter 4: Scene Setup     

How to select a camera from the Camera list (set the active camera)

 1. From the top menu, select Scene > Camera > the desired camera.

If you only add one camera to your scene, you will only see Default Camera in your list.

How to reposition the camera frame directly in the Camera view

 1. In the Tools toolbar, disable the Animate  mode.

 2. Do one of the following: 

‣ From the top menu, select Animation > Tools > Translate. 

‣ In the Advanced Animation toolbar, click the Translate  tool.

‣ Press Alt + 2.

 3. In the Camera view, click on the camera frame (thin rectangle) to select it. You can also select the camera 
layer from the Timeline or Node view.

The selected camera frame is highlighted.

 4. Drag the camera frame to a new position. 
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 5. To tilt the camera frame, do one of the following to select the Rotate tool:

‣ From the top menu, select Animation > Tools > Rotate.

‣ In the Advanced Animation toolbar, select the Rotate  tool.

‣ Pres Alt + 3.

 6. In the Camera view, drag to rotate the camera frame until it reaches the desired rotation angle.

How to modify the camera clipping plane

 1. In the Timeline or Node view, select the Camera node.

 2. In the Layer Properties view, go to the Clipping Planes section.
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 3. Modify the value of the Near Plane to pull or push the clipping area closer to the camera. Anything behind 
this plane will no longer be visible.

 4. Modify the value of the Far Plane to pull or push the clipping area closer to the camera. Anything beyond 
this plane will no longer be visible.

How to set up the camera frame using the Layer Properties view

 1. In the Timeline view, select the camera layer.

 2. In the Layer Properties view, adjust the camera's properties.
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Parameter Description

Enable/Disable Turns the camera layer on or off.

Change Track Colour

The Change Track Colour  button lets you change the colour of the exposed 
frames; this helps you to quickly locate a layer in the Timeline view. Click the 
Change Track Colour  button to open the Select Colour window and choose a 
new colour. You can modify the colour for any type of layer, such as group, peg, 
drawing, and effects.

Name
Displays the current layer name. You can rename the layer by typing in a new 
layer name.

Position

Displays the current position of the camera layer using X-axis (East/West), Y-
axis (North/South) and Z-axis (Forward/Backward) coordinates. To reposition 
your camera frame, type in the new values corresponding to the desired position 
coordinates. You can also use the up and down arrows to set the value of each 
field—see Positioning an Element Using the Layer Properties View on page 141.

Angle
Displays the current rotation value. To set a new rotation position, type in a new 
angle value. You can also use the up and down arrows to set the new angle value.

Pivot

Displays the current position of the rotation pivot of the camera layer. The camera 
will perform a rotation taking the position of the pivot as its angle centre. By 
default, the pivot is set at the centre of the camera frame. To reposition the pivot 
point, type in new X and Y coordinates values in the appropriate field. You can 
also use the up and down arrows to set the position values.
In order to see the pivot's position you will need to have the Rotate tool selected.

Clipping Planes

You can change the near and far clipping planes of the camera. The near plane is 
the point on the camera cone where the camera is located. The far clipping plane 
is the far end of the camera cone. Nothing outside that range is visible. This is 
useful when dealing with 3D elements and 3D sets.  For example, the camera can 
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be looking inside a 3D box or room and you might want the foreground wall to not 
obstruct the view of the interior. By default, the near clipping plane is set to 1 field 
and the far clipping plane is set to 1000 fields.

Override Scene FOV Enable the FOV field in which you can type in a new field-of-view value. 

FOV

Displays the current field-of-view default value. When enabled, you can type in a 
new zoom value for your camera frame. You can also use the up and down arrows 
to set the new zoom value.

Click on the Create Function button to animate the camera zoom value—see Path 
Animation on page 237 to learn more about creating functions.

Set Default FOV Resets the custom zoom value to its default value. 

How to reset the camera position

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Timeline, Node, or Camera view, select the camera layer.

 3. From the top menu, select Animation > Reset or press Shift + R.

The camera automatically returns to its original position.

Positioning the Scene Elements

Setting up the scene also involves positioning the different scene elements within the camera frame.

Here are the main features and topics you need to know about to position your elements:

• Animate Mode on page 125

• Selecting a Layer  on page 125

• Positioning an Element Using the Transform Tool  on page 130

• Positioning an Element Using the Advanced Animation Tools on page 138

• Positioning an Element Using the Layer Properties View on page 141

• Drawing Layer Properties Reference on page 144
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• Setting Properties for Many Layers on page 154

• Auto Apply Option  on page 156

• Resetting a Transformation  on page 156

Animate Mode

When positioning elements, make sure the Animate Mode is turned off, or it will create a keyframe on your drawing 
layer. The animate mode is used to animate layers over time.

How to turn off the Animate mode

‣ In the Tools toolbar, click the Animate Mode  button. Make sure the button is depressed.

‣ In the top menu, disable Animation > Animate.

Selecting a Layer 

There are different ways to select the layers you want to reposition.

You can select your elements directly in the Camera view using the Transform  tool. When using this tool, its 
properties and options appear in the Tool Properties view. Always make sure that the Peg Selection  Mode option in 
the Tool Properties view is disabled or it will limit the selection to pegs only.

When you have several layers in the Timeline view, you may find it hard to locate which one is selected. You can 
use the Centre on Selection feature to display the selected layer in the Timeline view.

Like the Timeline view with its many layers, when you have several nodes in the Node view, you may find it hard to 
locate which one is selected. You can use the Centre on Selection feature as well as the Search toolbar to focus on 
the selected node in the Node view. You can also select elements in the Timeline or Xsheet view. This can be useful 
when there are too many objects in the scene or when an object is hard to grab. Finally, you can select all the 
elements within a group at once via via the Node or Timeline view.

You can change the display style of selected elements to a bounding box style. This removes the default overlay 
highlight and leaves only the bounding box around the selected element.

How to select a layer in the Camera view

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.
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1. In the Tool Properties view, make sure that the Peg Selection Mode  is deselected.

 2. In the Camera view, click on the element to be repositioned. You can select more than one element at a 
time. Hold down Shift while clicking on the elements to be selected.

The corresponding layers and columns are highlighted in the Timeline and Xsheet views.

How to set the bounding box selection style

 1. In the Camera view bottom toolbar, click the BBox Selection Style  button.

How to center on the selected layer in the Timeline view

 1. In the Camera view, select a layer.

 2. Do one of the following:

‣ From the Timeline view menu, select View > Centre on Selection or press O.

‣ In the Timeline view toolbar, click the Centre on Selection  button.

How to center on the selected layer in the Node view

 1. In the Camera or Timeline view, select a layer.

 2. Do one of the following:

‣ From the Node View menu, select View > Centre on Selection. 

‣ In the Node View toolbar, click the Centre On Selection  button. 

‣ In the Node view, press O.

How to select from the Timeline or Xsheet view

‣ In the Timeline view, click the layer corresponding to the element you want to reposition. 

‣ In the Xsheet view, click the column header corresponding to the element you want to reposition.

The selected element is highlighted in the Camera view.

How to select all elements within a group in the Node view

 1. In the Node view, navigate to the group whose elements you want to select.

 2. Hold down Alt and drag a marquee selection around the group node.
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All elements within that group are selected.

How to select all elements within a group in the Timeline view

 1. With a group collapsed or expanded, hold down Alt and click on the group in the Timeline view.

All elements contained within the group are selected.

Locking Layers in the Timeline View 

You can prevent correctly positioned layers from being selected in the Camera view by locking them in the Timeline 
view. This is useful for making a multiple selection inside the Camera view while avoiding to select them. Once a 
layer has been locked, its locked state will be remembered the next time you open a saved project.

You can perform five types of locking actions on your layers:

• The Lock  option lets you lock one or a multiple selection of layers. 

• The Unlock  button lets you unlock one or a multiple selection of locked layers.

• The Lock All  option lets you lock all the layers in the Timeline view. 

• The Unlock All  button lets you unlock all the layers in the Timeline view. 
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• The Lock All Others  button lets you lock every layer except the selected ones.

How to lock a layer or a selection of layers

 1. In the Timeline view, select one or more layers.

 2. Do one of the following: 

‣ From the top menu, select Animation > Lock > Lock. 

‣ Click one of the selected layer’s Lock  icon. 

‣ Press Ctrl + Alt + L (Windows/Linux) or ⌘  + Alt + L (Mac OS X).

All selected layers are locked. 

How to unlock a locked layer or a selection of locked layers

 1. In the Timeline view, select one or more locked layers.

 2. Do one of the following: 

‣ From the top menu, select Animation > Lock > Unlock. 

‣ Click a selected layer’s Lock  icon. 

‣ Press Ctrl + Shift + K (Windows/Linux) or ⌘  + Shift + K (Mac OS X). 

All selected layers are unlocked.
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How to lock all layers

 1. Do one of the following:

‣ From the top menu, select Animation > Lock > Lock All. 

‣ In the Timeline view, select all layers and click Lock  icon of a selected layer. 

‣ Press Ctrl + Shift + L (Windows/Linux) or ⌘  + Shift + L (Mac OS X).

All layers are locked.

How to unlock all layers

 1. Do one of the following:

‣ From the top menu, select Animation > Lock > Unlock All. 

‣ In the Timeline view, select all layers (locked) and click Lock icon of a selected layer. 

‣ Press Ctrl + Alt + Shift + L (Windows/Linux) or ⌘  + Alt + Shift + L (Mac OS X). 

All layers are unlocked.

How to lock all other layers

 1. In the Timeline view, select the layers you do not want to lock.
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 2. Do one of the following: 

‣ From the top menu, select Animation > Lock > Lock All Others. 

‣ Press Ctrl + Alt + Shift + O (Windows/Linux) or ⌘  + Alt + Shift + O (Mac OS X). 

All layers are locked except the selected ones.

Positioning an Element Using the Transform Tool 

Using the Transform tool, you can easily reposition, scale, rotate and even skew layers directly in the Camera 
view. 

When positioning a drawing layer using the Transform tool, always make sure the Peg Selection Mode  is 
deselected in the Tool Properties view. Otherwise, it will limit the selection to pegs in the Camera view.
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NOTE: Refer to Positioning Elements in 3D Space on page 219 to learn about the 3D Transform tool and how to 
position elements in 3D space.

There are two different options you can use when you want to flip your element.

The Flip Horizontal and Flip Vertical options let you flip a drawing layer along the Camera view’s horizontal and 
vertical axis.

Once your drawing layer is rotated, the original horizontal and vertical axes change. The Flip Scale X and Flip Scale 
Y will perform a flip on your drawing layer following its original axis.

• The Flip Horizontal command flips the layer following the Camera view X-axis.

• The Flip Scale X command uses the original X-axis of the layer and flips the element following it.
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Transformations, such as rotation, scale, skew and flip are made relative to the pivot point position. You can 
temporarily reposition the pivot point for each transformation using the Transform tool. Note that the pivot is only 
moved temporarily. When animating the position, the interpolation is calculated from the permanent pivot 
position—see Positioning an Element Using the Advanced Animation Tools on page 138.

How to temporarily reposition the pivot point

 1. In the Tools toolbar, select the Transform  tool.

 2. In the Tool Properties view, make sure the Peg Selection Mode  is disabled.

 3. In the Camera view, select your element.

The pivot point appears at the center of the scene space (coordinates 0, 0, 0), unless previously 
repositioned.

 4. Click on the pivot point and drag it to a new position.

This will be the new position of the pivot point for the current transformation. It will remain in this position 
as long as you do not deselect the drawing. Using the Transform tool to reposition your pivot will 
temporarily override the existing pivot point position until you complete the current transformation. Then it 
returns automatically to its original position.
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When you translate the pivot point using the Transform tool, the permanent pivot will appear as a ghost so 
you know where it is and also from where the animation will be interpolated when you create motion paths. 
The animation is always interpolated from the original pivot and not the temporary pivot.

How to pan a layer using the Transform tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, select a drawing layer and drag the selection to a new area. You can select multiple lay-
ers to reposition them at the same time. Hold down Shift and select the different layers.

How to rotate a layer using the Transform tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, select a drawing layer.

 5. Place  the pointer outside of a corner of the bounding box and drag to rotate.
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NOTE: 
You can display a rotation handle on the bounding box when transforming a layer. In the Preferences dialog box, 
select the Camera tab and then select the Use Rotation Lever with Transformation Tools option. This preference 
is off by default.

How to scale a layer using the Transform tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, select a drawing layer and push or pull on the size, top, or corner control point. Hold 
down Shift to lock the selection's aspect ratio. 

How to skew a layer using the Transform tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

134



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, select a drawing layer.

 5. Place  the pointer between two controls points and drag sideways or up and down. 

How to flip a layer

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, use the Transform  tool to select a drawing layer to flip.

 5. Do one of the following:

‣ From the top menu, select Animation > Flip > Flip Horizontal or Flip Vertical. 

‣ In the Tool Properties view, click the Flip Horizontal  and the Flip Vertical  buttons.

‣ Press 4 or 5. 

How to flip an element following its original axis

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 3. In the Camera view, use the Transform  tool to select an element that has already been transformed.

 4. From the top menu, select Animation > Flip > Flip Scale X or Flip Scale Y.
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Transform Tool Properties

Icon Tool Name

Lasso and Marquee on page 136

Peg Selection Mode on page 137

Snap Options on page 137

Hide Manipulator Controls on page 137

Flip Horizontal and Flip Vertical on page 137

Rotate 90 Degrees CW and CCW on page 137

Width and Height  on page 137

Offset X and Y  on page 138

Angle  on page 138

Lasso and Marquee

The Lasso and Marquee options let you choose the type of selection the current tool will perform. The default 
selection mode is Marquee.

• Lasso  lets you draw a custom selection box around zones.

• Marquee  makes a rectangle selection box.

NOTE: 
Hold down the Alt key to switch to toggle between the selection modes.
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Peg Selection Mode

In the Camera view, the Peg Selection Mode limits the selection to peg layers instead of drawing layers. This 
mode is useful when you have created a character rig using peg layers for each drawing.  That way, you do not 
accidentally select the drawing layer when you want to animate on the peg.

When disabled, the Transform  tool selects the drawing layers.

Snap Options

When transforming or repositioning a layer using the Transform tool, you can enable different snap options to help 
you. 

• Snap and Align: Snaps the selected layer to any existing object, while automatically displaying 
temporary rulers that guide you and that you can also snap your object to.

• Snap to Grid: Snaps your selection according to the currently enabled grid.

Hide Manipulator Controls

The Hide Manipulator Controls  button lets you hide the bounding box and manipulator controls from the Camera 
view when an element is selected.

Flip Horizontal and Flip Vertical

The Flip Horizontal  and Flip Vertical  buttons let you flip the selected element horizontally or vertically. You 
can also select Animation > Flip > Flip Horizontal and Flip Vertical from the top menu or press 4 or 5.

Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW  and Rotate 90 Degrees CCW  operations rotate the current selection 90 
degrees clockwise or counter-clockwise.

Width and Height 

The Width  and Height  fields allow you to enter specific values for accurately resizing a selected layer.

• Width: Enter a width value in this field to resize the width of your selection.
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• Height: Enter a height value in this field to resize the height of your selection.

• Lock: Click the Lock icon to lock or unlock the ratio between the width and height values. 

Offset X and Y 

Use the Offset X and Offset Y  fields to enter specific values to reposition the selected layer accurately.

• X: Enter an offset value in this field to reposition the selected layer along the X-axis.

• Y: Enter an offset value in this field to reposition the selected layer along the Y-axis.

Angle 

The Angle  field lets you enter specific values to rotate the selected layer accurately. A positive value rotates 
the layer counterclockwise and a negative value rotates the layer clockwise.

• Angle: Enter a degree value in this field to rotate the selected layer.

Positioning an Element Using the Advanced Animation Tools

You can also use the advanced animation tools to position your layers. The difference between these tools and 
the Transform tool is that they modify only one parameter of the position such as the rotation or the scale as the 
Transform tool adjusts all parameters together.
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Transformations, such as rotation, scale, skew and flip, are made relative to the pivot point position. You can 
reposition this pivot point anywhere using the advanced animation tools.

How to permanently reposition the pivot point

 1. In the Advanced Animation toolbar, select the Translate , Rotate , Scale , or Skew  tool.

 2. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) to select your element. 

The pivot point appears in the Camera view.

 3. Drag the pivot point to a new position.

All transformations, including existing ones will be recalculated from this new pivot postion.

How to pan a layer using the Translate tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. Do one of the following: 

‣ From the top menu, select Animation > Tools > Translate. 

‣ In the Advanced Animation toolbar, click the Translate  tool.

‣ Press Alt + 2.

 3. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) to select your element. 

 4. Drag the selection to a new area. 
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‣ You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) or ⌘  + 
Shift + click (Mac OS X) on each element to select them. 

How to rotate a layer using the Rotate tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. Do one of the following: 

‣ From the top menu, select Animation > Tools > Rotate. 

‣ In the Advanced Animation toolbar, click the Rotate  tool.

‣ Press the Alt + 3. 

 3. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) to select your element.  

 4. Rotate the layer. 

‣ You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) or ⌘  + 
Shift + click (Mac OS X) on each element to select them. 

How to scale a layer using the Scale tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. Do one of the following: 

‣ From the top menu, select Animation > Tools > Scale. 

‣ In the Advanced Animation toolbar, click the Scale  tool.

‣ Press Alt + 4. 

1. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) to select your element. 

 3. Pull or push either on the side, top or corner control point. Hold down Shift to lock the selection’s ratio 
when using the corner control points. 
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‣ You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) or ⌘  + Shift + 
click (Mac OS X) on each element to select them. 

How to scale a layer using the Skew tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. Do one of the following: 

‣ Select Animation > Tools > Skew. 

‣ In the Advanced Animation toolbar, click the Skew  tool.

‣ Press Alt + 5.

 3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) on the element to select it and 
drag a side of the bounding box up, down or sideways. 

‣ You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) or ⌘  + Shift + 
click (Mac OS X) on each element to select them. 

Positioning an Element Using the Layer Properties View

Each layer has a series of parameters that you can modify to adjust an element's position. You can access these 
parameters in the Layer Properties view. In this view, you can type in a value instead of moving the object in the 
Camera view. These values can also be animated over time. See Drawing Layer Properties Reference on page 144 
for additional details.

You can also access a layer's parameters in the Timeline view. Click on the Expand Parameters button.
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It is important to understand the coordinate values in Harmony. Harmony's core is based on the origins of 
animation. In traditional animation, a scene's size and camera motion are calculated in fields. A field has a 4:3 
ratio and measures 0.5 inches (12.7 mm) in width. A specific grid has been created for this purpose known as a 
field chart. Harmony uses this unit of measurement as its coordinate system.

A field chart uses the cardinal directions. The X axis is the east-west (left-right) direction, the Y axis is the north-
south (up-down) direction and the Z axis is the forward-backward direction.

In Harmony, a drawing's pivot is located at the centre of the field chart, regardless where your drawing has been 
drawn on the page. Your drawing is the entire sheet of paper, not only the drawing strokes you have drawn on the 
page. This allows scanned drawings, imported images and paperless drawings to be properly registered together.

If you want to move your drawing in the upper-left region of the camera frame, you would type in something like 
the following:

• X Axis: -4 or 4W (4 West)

• Y Axis: 5 or 5N (5 North)

If you want to move your drawing in the lower-right region of the camera frame, you would type in something like 
the following:

• X Axis: 3 or 3E (3 East)

• Y Axis: -2 or 2S (2 South)

How to display layer parameters

 1. Do one of the following:
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‣ In the Layer Properties view is not part of your workspace, from the top menu, select Windows > Layer 
Properties. In the Timeline view, select a layer

‣ In the Timeline view, double-click on a layer.

‣ Press Shift + E.

‣ In the Node view, click on a node’s yellow properties button.

The properties display.

How to position an element

 1. In the Timeline view, select a layer.

 2. In the Layer Properties view, select Enable 3D option to display the 3D parameters in the Layer Properties—
see Enabling the 3D Option on page 210.

 3. In the Position section, select one of the following options:
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‣ Separate to independently edit the different coordinate fields. Continue to step 3.

‣ 3D Path to use a 3D path function when animating your element. Continue to step 4.

 

 4. In the (x), (y) and (z) Axis fields, type in a new coordinates corresponding to the desired position—see 
Creating a Multiplane on page 198.

As you type in values, the element’s position is updated in the Camera view. 

1. Use the Function  buttons to create function curves and add keyframes to animate the parameter.

 5. In the Scale section, select one of the following options:

‣ Locked to resizes the element uniformly in three directions.

‣ Separate to resize the element in any direction without affecting the others.

 

 6. In the (x) and (y) Axis fields, type in a new coordinates corresponding to the desired position

2. Use the Function  buttons to create function curves and add keyframes to animate the parameter.

 7. In the Rotation section, Angle z field, type in a degree value for the rotation angle. Note that you can enter 
values greater than 360 and -360 degrees. If you enter 720, the object will rotate twice.

 8. In the Skew field, type in a degree value between -90 to 90 for the skew angle.

 9. In the Pivot section, type in the desired coordinate value to reposition the transformation pivot. This will 
change the permanent position of the pivot.

For detailed information on the Layer Properties parameters, see Drawing Layer Properties Reference on page 
144.

Drawing Layer Properties Reference

The drawing layer's properties is composed of the following tabs:
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• Transformation Tab on page 145

• Drawing Tab on page 148

• Controls Tab on page 150

• Advanced Tab  on page 150

Transformation Tab

The Transformation tab contains parameters for adjusting the position, scale, rotation, skew and pivots of an 
element.

When the Enable 3D option is selected, additional parameters appear in the Rotation and Pivot sections to rotate 
objects on 3 axis in the 3D space.

Parameter Description
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Enable 3D Displays additional parameters for working with 3D objects.

Position

3D Path: Lets you use a 3D path function to animate an element.

Separate: Lets you independently edit the different coordinate fields.

Path (x) Axis: Lets you type in a new East/West coordinate corresponding to the 
desired position.

Path (y) Axis: Lets you type in a new North/South coordinate corresponding to 
the desired position.

Path (z) Axis: Lets you ype in a new Forward/Backward coordinate 
corresponding to the desired position.

Velocity: When the 3D Path option is selected, lets you set the speed at which 

Scale

Locked: Resizes the element while keeping its ratio. The X and Y axes scale 
proportionally

Separate: Resizes the element allowing to modify the ratio (squash and stretch).

(x) Axis: Lets you type in the horizontal scale value.

(y) Axis: Lets you type in the vertical scale value.

Scale in Fields: Instead of using the standard scaling units, when this option is 
enabled, images are scaled using field units, based on the traditional animation 
field chart.

Ignore Parent Scaling: When this option is enabled, any scaling value applied to 
a parent layer is ignored in the current layer. This can be handy in cut-out rigs 
when you need to scale an arm without affecting the forearm. 

Rotation
Angle z: Lets you  type in a degree value for the rotation angle. Note that you can 
enter values greater than 360 and -360 degrees. If you enter 720, the object will 
rotate twice.

Skew Skew: Lets you type in a degree value between -90 to 90 for the skew angle.

Pivot

(x) Axis: Lets you type in a new East/West coordinate corresponding to the 
desired position.

(y) Axis: Lets you ype in a new North/South coordinate corresponding to the 
desired position.

Drawing Pivot

Use Embedded Pivots: 

Harmony has three types of pivots:

• Permanent Pivot
This is a permanent pivot, sometime referred to as peg pivot, that is 
applied to the entire drawing or peg layer. If you modify its position, it will 
be changed for the entire layer, modifying the animation, scale and rotation 
interpolation. The permanent pivot is set using the Rotate, Translate or 
Scale tool. The Transform tool will only move that pivot temporarily for 
positioning purposes, but the animation interpolation will be done from the 
original permanent pivot's position. The Transform tool is designed to 
move the pivot temporarily during the animation process. It also permits 
you to select multiple pegs and apply a common temporary pivot.
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To permanently move a peg pivot, use the Rotate  or Scale  tool. You can 
also directly type the values in the Layer Properties window in the Pivot 
section's (x) Axis and (y) Axis fields.

In the Layer Properties window, in the Drawing Pivot section, select the 
Don't Use Embedded Pivot option to use the permanent pivot.

• Drawing Pivot
The Drawing pivot is contained within each drawing. In one layer, each 
drawing can have its own pivot. If you have many different views of a 
character within one layer, the pivot can be different and the animation will 
adjust to the pivot. The Drawing pivot can also be referred to as embedded 
pivot. If you are not mixing different views within the same layers or are 
using pegs to animate your layers, it is recommended to use the 
permanent pivot.

You can set a different pivot for each one of your drawings. For example, if 
you have a series of drawings from different views, they are not likely to 
rotate from the same location. In that case, you can set a different pivot for 
these drawings by using the Drawing Pivot  tool.

In the Layer Properties window, in the Drawing Pivot section, select the 
Apply Embedded Pivot on Drawing Layer option to use the drawing 
pivot directly on the drawing layer. If you want to apply the drawing pivot to 
a parent peg to force the peg to follow the drawing pivot variations, enable 
the Apply Embedded Pivot on Parent Peg option.

• Symbol Pivot
The Symbol pivot is similar to the Drawing pivot. Each symbol cell can 
have its own pivot and act the same as the Drawing pivot. The Symbol 
pivot can also be referred to as embedded pivot. Inside a symbol, each 
drawing can have its own pivot. If you are not mixing different views within 
the same layers or are using pegs to animate your layers, it is 
recommended to use the Peg pivot.

For a simple character rig, it is recommended to set the Peg pivot (even on 
drawing layers) using the Rotate  tool.
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Drawing Tab

The Drawing tab contains parameters for the element and timing columns, designating art layers, and setting 
bitmap options.

Parameter Description

Element Columns

Full Name: Select which element to connect to the node from the list of 
elements that already exist in your scene.  

Drawing Path: Displays the full path to the current drawing.

Timing Columns

Name: Path to the file you want to link to.  

Timing Column: Link to the column that contains the desired timing.  

Extension: When linking to a background file, enter its file name extension.  

Field Chart: If you are importing traditional animation, select the size of the 
paper on which the animation was drawn.

Art Layers

Overlay Art Enabled: Enables the Overlay Art display.

Line Art Enabled: Enables the Line Art display.

Colour Art Enabled: Enables the Colour Art display. 

Underlay Art Enabled: Enables the Underlay Art display.  

Overlay Art Type: Allows you to set the Overlay Art as Vector or Bitmap type.

Line Art Type: Allows you to set the Line Art as Vector or Bitmap type.

Colour Art Type: Allows you to set the Colour Art as Vector or Bitmap type.

Underlay Art Type: Allows you to set the Underlay Art as Vector or Bitmap 
type.
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Bitmap File Options

When an image is created with an external software and that image has some 
transparency, there are several formats the software can use when writing the 
RBG channels. The purpose of the four import options for the transparency is 
for the user to tell Harmony how to interpret the RGB channels of the imported 
image. The correct option has to match the ouput format of the software that 
was used to create the image in the first place. For instance, if the you used 
Adobe Photoshop and exported an image as Straight, then it should be 
imported in Harmony as Straight in order to get the correct result. 

Note that if the image has no alpha channel or if it does have an alpha channel 
and all the pixels are 100% opaque, it does not make any difference which 
option is selected. 

Colour: Controls the production of colour information from bitmap images. If 
this module reads 3 or 4-channel bitmaps, this selection determines whether 
the colour should be read or ignored. If this module reads 1-channel bitmaps, 
this selection determines whether the channel should be read as colour. When 
this option is selected with 1-channel images, the resulting image will be a 
greyscale image.  

Transparency: Controls the production of alpha information from bitmap 
images. If this module reads a 1 or 3-channel image, this option will create a 
matte from the colour values in the image. If the module reads a 4-channel 
image and this option is not selected, the alpha information in the image will be 
ignored.

Transparency Type  

Premultiplied with Black: Semi-transparent pixels in the original image are 
blended with black. 

Premultiplied with White: Semi-transparent pixels in the original image are 
blended with white. 

Straight: Semi-transparent pixels in the original image are left as is 
(unmatted). 

Clamp Colour to Alpha: Semi-transparent pixels in the original image are 
blended with black. On import, each of the RGB channels is clamped so that a 
color value never exceed the alpha value for a given pixel. When the RGB 
values are multiplied with the alpha value, that is to say, if you have a pixel of 
value R=247, G=188, B=29 and the alpha is 50% or the image has a 50% 
transparency, then the actual RGB values output would be half of the amounts 
listed above.
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Controls Tab

The Controls tab contains animation control options.

Parameter Description

Animation

Animate Using Animation Tools: By default, a drawing layer can be animated 
using the same parameters as a peg, but you can disable this feature. Being 
able to switch your drawing layers so they can no longer be animated without a 
peg has certain advantages. In cut-out animation, it is easier to separate your 
drawing exposure and keyframes to change timing easier and rearrange 
keyframe position in the Timeline view. This feature is also available for 
backward compatibility when bringing in templates created in older versions of 
the software, so as not to lose their offset keyframes or drawing substitution 
keyframes.

Angle Limit Values

Lets you set a maximum and minimum rotation angle for a drawing. This option 
is used mainly for a cut-out character when you do not want an elbow to bend 
too far in or out. 

 Enable Min/Max Angle: Activates the minimum and maximum angle 
constraints. 

Min Angle: Type the minimum angle you want the drawing to rotate too. 

Max Angle: Type the maximum angle you want the drawing to rotate too.

Spline Offset

In the X, Y and Z axis fields, type the coordinates of where you want to offset 
the visual trajectory. By default, the trajectory is displayed at the centre 
drawing, using the layer's pivot position. If you want to move it so it 
corresponds better with your drawing, either type new coordinates or use the 
Spline Offset  tool available in the Advanced Animation toolbar.  

To display the trajectory in the Camera view, select your drawing and select 
View > Show > Control. You can also press Shift + F11 (Windows/Linux) or 
⌘  + F11 (Mac OS X).

Advanced Tab 

The Advanced tab contains options for setting the alignment of drawings, clipping, line thickness, vector render 
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options, and more.

Parameter Description

Alignment

Alignment Rule: The alignment rule selections are intended to deal with drawings 
that were created on paper of a different size or orientation from the default 
alignment rule (set up in the Scene Settings dialog box) or imported bitmap 
images. The drawings are then scaled to match the Harmony alignment 
rectangle. Note that alignment rules are not based on the camera frame, but on 
the scene frame. Refer to the Fundamentals Guide to learn more about scene 
alignment and scene settings.

• Left: The default alignment for drawings; aligns the drawings to the left 
side of the scene’s alignment rectangle. Harmony scales the drawings to 
match their height to the alignment rectangle of the scene.

• Right: Aligns the drawings to the right side of the alignment rectangle. 
Harmony scales the drawings to match their height to the height of the 
alignment rectangle of the scene.

• Top: Aligns the drawings to the top of the alignment rectangle. Harmony 
scales the drawings to match their widths to the width of the alignment 
rectangle of the scene.

• Bottom: Aligns the drawings to the bottom of the alignment rectangle. 
Harmony scales the drawings to match their widths to the width of the 
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alignment rectangle of the scene.

• Centre Fit: Centers the drawings.

• Centre Fill: Centers the drawings and then scales them so the width or 
height fills the available space.

• Centre LR: Aligns the drawings in the left-right centre of the alignment 
rectangle. Harmony scales the drawings to match their height to the height 
of the alignment rectangle of the scene.

• Centre TB: Aligns the drawings in the top-bottom centre of the alignment 
rectangle. Harmony scales the drawings to match their widths to the width 
of the alignment rectangle of the scene.

• Stretch: Scales the drawings so they fit within the alignment rectangle of 
the scene. This is particularly useful for images that you will manipulate 
with a Quadmap node. If the drawings in the Quadmap node do not have 
the same aspect ratio as the alignment rectangle of the scene (from the 
Scene Settings dialog box), the handles on the quadmap will not appear on 
the corners of the image, making it difficult to manipulate the quadmap. In 
this case, you would set the drawing layer of the quadmap images to 
Stretch to make the handles appear on the corner of the image. This can 
have the effect of distorting the images, but it is not an issue with images 
that will be distorted through the Quadmap node anyways.

• As Is: Leaves the drawings aligned as they are. 

• Centre First Page: Aligns the centre of the first part of a standard pan cel 
with the centre of the field chart.

Turn Before Alignment: Rotates  the drawings in the selected element 90 
degrees to the left before scaling and aligning them according to the alignment 
rule, and before performing any offset, rotation or scaling for the element or peg. 
This and the Alignment Rule are intended for drawings that were created on paper 
of a different size or orientation than the other paper in the scene, and requires 
alignment  so they are treated accurately.

Flip Horizontal: Flips the drawing on the X-axis.

Flip Vertical: Flips the drawing on the Y-axis.

Clipping

No Clipping: Select this option if you do not want to clip the images in this node 
before an effect is applied to it.

Clipping Factor (X)/(Y): This is an option for rendering images that are larger 
than the final frame. With this option enabled, images can be moved by an Apply 
Peg Transformation node without black entering into the composite as a result 
of early clipping. In addition, this option is useful for images that have a blur that 
should appear in the frame even though the image itself is not in frame—see Apply 
Image Transformation on page 385 and Apply Peg Transformation on page 380.

Line Thickness

As you move the camera in your scene along the Z-axis, notice that, logically, the 
lines of the elements become thicker the closer the camera gets to the drawing. If 
you prefer the lines to remain the same size or become thicker at a different 
speed, you can use the thickness feature to adjust your brush stroke and pencil 
line thickness. You can modify the size of the lines even if the camera is not 
animated.
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To learn how to use this feature, see Camera Truck-ins and Line Thickness on 
page 260.

Adjust Pencil Lines Thickness: Lets you work with pencil lines and adjust their 
thickness. You will not see any changes to lines in the Camera view OpenGL 
mode. You must switch to the Render mode.

Normal Thickness: Disables all overrides on the brush stroke line thickness. 
This option must be enabled in order for the pencil line thickness parameter and 
pencil lines to appear. If you want to modify the brush stroke thickness, deselect 
this option. To enable brush strokes to work with the line thickness feature, you 
must first create central strokes in the Colour Art layer. The central strokes 
control the line variation of your brush strokes in the Line Art layer. Select 
Drawing > Create Colour Art from Line Art.

Zoom Independent Thickness: Select this if you want your line thickness to 
remain constant independently from the camera move. Everything else will 
increase in size, but the line thickness will stay the same.

Proportional: Enter a multiple by which you want to increase the line thickness 
base on its original thickness. A value of 1 will result in no change; a value of 0 
(zero) will hide the lines.

Constant:  Enter a value in pixels (based on a 720x540 screen resolution) to 
indicate the amount of pixels you want to add around the existing line.

Minimum: Enter a value in pixels (based on a 720x540 screen resolution) for the 
minimum line thickness allowed.

Maximum: Enter a value in pixels (based on a 720x540 screen resolution) for the 
maximum line thickness allowed.

Vector Render Options

• Antialiasing Quality: A smoothness (antialiasing) setting applied to the 
final rendered image. 

• Low: No antialiasing 

• Medium Low: Basic antialiasing

• Medium: Improved antialiasing (blurs the textures)

• High: High quality antialiasing (does not blur the textures)

Higher quality images require more time to render and more system 
memory. Choose a lower quality if you are rendering a pencil test.

• Antialiasing Exponent: Controls the size of the area around the final 
image edges used in the antialiasing process. A higher value uses less 
area, resulting in sharper edges, while a lower value uses more area, 
resulting in softer edges. If the Antialiasing Quality value is set to Low (no 
antialiasing) or Medium Low, this value is ignored. Values: Between 0 and 
1.

• Texture Filter: This option changes the way coloured pixels of TVG 
textures are calculated when rendered for different degrees of accuracy. 

• Bilinear: This option takes the four pixels around each point and 
makes a bilinear interpolation between them. (Medium Quality)

• Nearest: This option chooses the colour of the closest pixel to a point. 
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(Lower Quality)

• Nearest (Filtered): This option is an improved version of Bilinear and 
improves the quality when zooming on a texture. (Best Quality)

Miscellaneous

• Depth: Overrides the order of cables in the node system to determine the 
forward/backward order in which this element is rendered. The Z position 
value overrides the depth value.

• Morphing Velocity: Creates a velocity function curve for morphing 
sequences in the layer. This function modifies the interpolation percentage 
between the 2 drawings. If set, the morphing between the two drawings 
will not be linear over time between the two drawings but will be modulated 
according to this curve.  This can be used to create a periodic morphing 
over a long period of time.

• Opacity: Lets you quickly change the transparency of the selected 
element. Opacity settings here will be reflected in both OpenGL preview, 
and full render.  

 

Setting Properties for Many Layers

When working with several nodes, you may frequently want to modify a series of settings. Instead of opening the 
properties for each individual layer, you can set the properties for many layers so you can change a common 
setting in a single click. 

This allows you to modify the following settings:

• 3D Path or Separate mode

• Use Embedded Pivot

• Overlay

• Line Art

• Colour Art

• Underlay

• Animate Using Animation Tools

NOTE: You can access this function in the Node View toolbar. You can add the button to the Timeline View 
toolbar through the Toolbar Manager. In the Toolbar Manager, you will find the feature in the script section under 
the name Script: TB_Set_Properties_on_manu_layers in TB_Set_Properties_on_many_layers.js.

How to set properties for many layers

 1. In the Node or Timeline view, select all the layers you want to modify at the same time.
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 2. In the Node or Timeline View toolbar, click the Set Properties for Many Layers button. This option is not 
available by default in the Timeline View toolbar. You must add it through the Customize option. Right-click 
on the toolbar and select Customize. In the Available Tools list, select Script: TB_Set_Properties_on_many_
layers and move it to the Toolbar list.

The Set Properties for Many Layers dialog box opens.

 3. Modify the properties. If your nodes have different parameters enabled for a certain setting, leave the As Is 
option selected to avoid modifying it. Each node will keep its original setting. Select any other options for all 
nodes to change to this parameter regardless of their original setting.

 4. Click OK.
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Auto Apply Option 

When you modify a parameter in a property dialog box, Harmony applies the modification automatically and 
displays the result immediately in the Camera view. If you do not want to immediately display every change made 
to your scene, turn off this default setting by deselecting the Auto Apply option. This is useful when you are 
working on a very heavy scene.

When you disable this function, Apply and OK buttons at added at the bottom of the Layer Properties view and 
any other parameter dialog boxes. 

• Click Apply to apply the current change.

• Click OK to apply the current change and close the Layer Properties.

NOTE: If you want to always work in Auto-Apply mode, you can deselect the Auto-Apply option in the Preferences 
dialog box (General tab). Then, each time you start Harmony, the Auto-Apply  mode will be off. You must click the 
Apply button to see any modifications.

How to enable or disable the Auto Apply option

‣ From the top menu, select Edit > Auto-Apply.

How to enable or disable the Auto-Apply preference

 1. In the top menu, select Edit > Preferences (Windows/Linux) or
Stage Premium > Preferences (Mac OS X).

The Preferences dialog box opens.

 2. In the Preferences dialog box, select the General tab.

 3. In the Options section, select or deselect the Auto Apply option.

Resetting a Transformation 

You can easily reset layers to their original position. With the Reset command, you can return the value of a 
selected element to the initial value of the active tool. For example, if the Rotate  tool is active, the 
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transformation angle will be reset to 0 and if the Transform  tool is active, the all transformation parameters 
values will be reset.

When selecting elements in the Camera view using the Transform tool, always make sure that the Peg Selection 
Mode  is deselected in the Tool Properties view. Otherwise, it will limit the selection to pegs only.

How to completely reset the layers' parameters

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Timeline or Camera view, select one or more drawing layers to reset. 

 3. Do one of the following: 

‣ From the top menu, select Animation > Reset or press R. This will reset the current frame if keyframes 
were created.

‣ Right-click the selected layers and select Clear All Values. This will remove all keyframes and reset all 
values for the entire layer.

‣ In the Timeline view menu, select Layers > Clear All Values. This will remove all keyframes and reset 
all values for the entire layer.

The selected layers return to their original position.

How to reset an individual parameter

 1. In the Advanced Tools toolbar, select the Translate , Rotate , Scale , or Skew  tool based on 
the parameter to reset.

 2. In the Timeline or Camera view, select the layer to reset. 

 3. From the top menu, select Animation > Reset or press R. This will reset the current frame if keyframes were 
created.

The selected parameter returns to its original position.

How to reset all transformation values except Z

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Timeline or Camera view, select one or more drawing layers to reset. 

 3. From the top menu, select Animation > Reset All Except Z.

All values except for those set on the Z axis are reset.

Cloning and Duplicating Layers 
At times, you will need to create a large group of characters such as a crowd, school of fish or flock of birds. You can 
do this by cloning or duplicating a layer. The difference between cloning and duplicating is that a clone uses the 
same drawings for all layers. A duplicated layer is simply an independent copy.
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If you want to maintain the ability to modify drawings and propagate the changes through all layers, you should 
clone your layer. If you simply want to copy your layers and be able to modify your drawings without affecting the 
original layer, use the duplicate option.

Cloning Layers

A cloned layer is linked to the original element directory. If a drawing is modified in the original or cloned layer, 
both will be updated. However, cloned layers can have different timings.

In the Timeline view, the left part of the layer is a node, same as in the Node view. These nodes are linked to 
columns. The right part of the Timeline view corresponds to the Xsheet column. These columns can contain 
drawing exposures or value keyframes. One node can be linked to several columns; one drawing column and 
several parameter columns (rotation, position, scale, pivot, etc.).

When cloning layers, you have the ability to clone the drawings and the corresponding columns (timing) or only 
the drawings. If you choose to clone the drawings and timing, your node will be linked to the same element folder, 
as well as the same drawing and function columns. Therefore, if you change the drawing exposure or keyframe on 
one layer, all cloned layers will be updated.

You may want to create a large group of characters reusing the same animation, but want to slightly offset the 
timing so they're not dancing or walking quite on the same beat. For example, if you create a walk-cycle for a 
soldier and want to use it for an entire army, you may want to have 50 layers with 50 different drawing exposures 
to produce a slight difference in the timing. If you copy your layers and drawings 50 times over, it will create a 
heavier scene. It is better to clone the 50 layers with only their drawings without linking to the same timing 
(function and exposure columns). 
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How to clone a layer

 1. In the Timeline, Xsheet or Network view, select a layer to clone. You can select multiple layers.

 2. Do one of the following:

‣ From the Xsheet menu, select Columns > Clone Selected Columns: Drawings Only or Columns > 
Clone Selected Columns: Drawings and Timing.

‣ From the top menu, select Edit > Clone Drawings Only or Edit > Clone Drawings and Timing.

‣ From the Timeline menu, select Layers > Clone Selected Layers: Drawings Only or Layers > Clone 
Selected Layers: Drawings and Timing.

‣ In the Timeline view, right-click on the layers and select Clone Selected Layers: Drawings Only or 
Clone Selected Layers: Drawings and Timing.

‣ In the Node menu, select Nodes > Clone Selected Layers: Drawings Only or Nodes > Clone 
Selected Layers: Drawings and Timing. When you clone a node, it does not automatically connect 
itself to the Composite node of your scene.

The cloned layer appears. 

NOTE: 
By default, when you select a node in the Node view and perform a copy/paste using Ctrl + C and Ctrl + V 
(Windows/Linux) or ⌘  + C and  ⌘  + V (Mac OS X), this creates a CLONE not a duplicate.  Nodes will be linked to the 
same drawings.  Pegs will be linked to the same function columns.

To duplicate a layer in the Node view using keyboard shortcuts, press Ctrl + C (Windows/Linux) or ⌘  + C (Mac OS X) 
and Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS X) for Paste Special, and in the Advanced tab, select Nodes: Create 
New Columns.

Duplicating Layers

You can duplicate a layer to have a copy of the drawings that are independent from the original ones, as well as an 
independent timing (exposure). When you need the drawings to be modified independently, you will want to duplicate 
the layer instead of cloning it.
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How to duplicate a layer

 1. In the Timeline, Xsheet or Network view, select a layer to clone. You can select multiple layers.

 2. Do one of the following:

‣ In the Timeline menu, select Layers > Duplicate Selected Layers.

‣ In the Timeline view, right-click on the layers and select Duplicate Selected Layers.

‣ In the Node menu, select Nodes > Duplicate Selected Nodes. When you duplicate a node, it does 
not automatically connect itself to the Composite node of your scene.

‣ From the Xsheet menu, select Columns > Duplicate Selected Layers.

‣ From the top menu, select Edit > Duplicate.

The duplicated layer appears.

NOTE: 
By default, when you select a node in the Node view and perform a copy/paste using Ctrl + C and Ctrl + V 
(Windows/Linux) or ⌘  + C and  ⌘  + V (Mac OS X), this creates a CLONE not a duplicate.  Nodes will be linked to 
the same drawings.  Pegs will be linked to the same function columns.

To duplicate a layer in the Node view using keyboard shortcuts, press Ctrl + C (Windows/Linux) or ⌘  + C (Mac OS 
X) and Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS X) for Paste Special, and in the Advanced tab, select Nodes: 
Create New Columns.
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Setting Up the Node Structure

The Node view uses a visual set of connections (nodes) to show how each element in the scene is connected and 
brought to the final image. It allows you to add extra elements and effects, and to move beyond the possibilities 
offered by the Timeline and Xsheet views.

This section is divided as follows:

• Node View on page 356

• About Nodes on page 163

• Input and Output Ports  on page 166

• Working with the Node View on page 167

• Composite Node on page 172

• Working with Backdrops on page 175

• Enabling and Disabling Nodes on page 180

• Node Thumbnails  on page 181

Node View

In the Node view, you can connect effects and compositing nodes to form a network, also known as a node system. 
This view is very useful for rigging puppets, creating advanced effects and having a clear view of complex scenes. 
The organization and order of the nodes determines the flow of data during the compositing process and how your 
animation elements will be composited.
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Symbol Stack

When entering symbols, the Symbol Stack lets you navigate back to the top and see the hierarchy of the symbol 
in which you are working.

Node System

The main area of the Node view is where you can add and organize different nodes to represent a scene.

Navigator

The Navigator view lets you pan the visible area to move quickly through extensive node sets.

Search Toolbar

The Search toolbar lets you find and match a node in the project. The search is not case-sensitive. Once you 
have entered characters in the search field, press Enter/Return to validate and find the pattern in the node names. 
If successful, the node is selected and centred in the view. If many instances are found, use the Previous and 
Next buttons to cycle through each node.

162



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

Group Navigation

When entering a group, the Group Navigation allows you to navigate back to the top and see the hierarchy of the 
group in which you are.

About Nodes

Each element in the Node view is called a node. There are several different types of nodes: 

Node Description

Drawing Transfers drawing information.

Effect Processes effects on drawings and transfers drawing information.

Input/Output Acts as the interface between each node and node system.

Transformation Controls the camera and element transformations over time.
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Composite Combines multiple source images.

 

Drawing Node 

This is an example of an average node, a simple drawing node that represents a layer in the Timeline view. This 
node has an input port (top) that allows information to flow through it. It has an output port (bottom) that exports its 
information in a downward flow. On the left is a yellow button that displays the node's property editor, where you 
can adjust its parameters. Lastly, there is an arrow that displays a thumbnail of the node's contents at the current 
frame. 

Write and Display Nodes 

Both the Write and Display nodes do not have output ports. This is because the information that flows into them 
can go no further in the node system. The Write node records the images and renders the final output. The 
Display node captures the visual information and outputs it to the Camera, Perspective, Top, Side and Timeline 
views.

Composite Node 

The Composite node combines multiple source images (drawing and effect nodes), including all transformations 
and effects, into a single bitmap or vector image for each frame.

The Composite node layers the images based on the composition order rule. 

First, the Z-values of the elements are analyzed to determine depth. When multiple elements have the same Z-
value, the Depth values in the drawing nodes are used. If the Depth values are also the same between elements, 
the composition order is determined by the cable order of nodes on the Composite node. By default, nodes 
connected to the right are rendered below those connected to the left. You can override this default in the 
Composite node editor. The Composite node is an example of a node that can have an infinite number of input 
ports that can take in multiple, individual sources of information. The leftmost input port on the Composite node is 
always green. This lets you know that, in terms of stacking order, whatever is plugged into this port will appear on 
top of the composite after the Z-depth is taken into account. 
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Effect Node

This is an example of a simple effect node taking a single image input and outputting a processed (blurred in this 
case) image.

An Effect node can often have two input ports. The right input port is for the drawing layer that is to be acted upon by 
this effect, while the left port is usually reserved for a matte.

Matte Input

A matte, also called mask, is the shape that will be used by the effect node to modify the original image (left input 
port). The effect will only be applied where the matte overlaps the original image. Sometimes the matte will act as a 
negative shape that the effect will exclude. This all depends on the nature and editing properties of the effect.

Transformation Ports

Some effects contain three input ports. If they are green, then they require a transformation (Peg, Quadmap, Quake, 
etc.) connection (coordinate and value information).

Peg Node 

The Peg nodes control the transformation of elements (position, scale, skewing and rotation) over time. The green 
ports at the top and bottom of the node indicate that it accepts transformation information which can be passed on 
(inputs and outputs transformation information).

One peg can be used to control many different nodes or one node can accept more than one peg. In a situation like 
the latter, one peg might be used to modify the rotation, while the other is used to modify the position of the effect 
and then animated differently over time. 
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Input and Output Ports 

Each node has an input port at the top and an output port at the bottom. Some are blue and others are light-green 
or bright green. 

Blue indicates drawing information.

Light green indicates position and movement (transformation).

Bright green shows the element on top of the composition and outputs that element’s Z position to the Composite 
node. When many elements have different Z positions (multiplane, different distances from the camera) and are 
placed through a Composite node that flattens them together (producing one image with one Z value), the system 
needs to give a Z position to this new image. It uses the bright green port information.

Finally, some nodes contain more than one input port. These are usually effect nodes needing different drawing or 
position information in order to perform their calculation. When the two ports are blue, the Drawing is on the right 
and the Matte is on the left. If it's light-green, the drawing needs extra position information.

If you are unsure of the type of connection required for a node, you can click on the port itself and the port type will 
be displayed.
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On each port is a tooltip which displays the source of input ports and the destination(s) of the output ports (node 
names).

How to display port information

 1. In the Node view, hover the pointer over a port.

The port's tooltip displays source and destination information. 

 2. Click on any port to display the port type label. The label will also display as you connect cables into ports.

Working with the Node View

The basic rules of the Node view are quite simple. Once you understand them, a lot can be accomplished.
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Each node used to build a node system is available in the Node Library view as well as through the Insert menu in 
the Node view. In addition, each time you create a layer from the Timeline or Xsheet views, the corresponding 
node is created in the Node view.

You can navigate to the parent or child node of the selected node or selected cable in the Node view. 

When you are working in the Node view and adding many nodes, your scene may look a bit messy and be difficult 
to follow.  Harmony provides scripts which organize and display the nodes in a more orderly fashion.

You can customize the look of the cables in the Node view to fit your style of working. You can display the cable 
lines as Bezier (curved) lines or straight lines.

The Navigator is a small square window inside the Node view that displays a bird's eye view of the network. The 
view displayed in the Node view is shown framed in the Navigator display. You can drag this frame to pan the 
current Node view display.

When your networks grows more complex, you can pan the Node view to locate and work on specific nodes.

How to add nodes from the Node Library

Do any of the following:

‣ In the Node Library, select a node and drag it to the Node view.

‣ In the Node Library, select a node and press Enter/Return to add it to the Node view.
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How to add nodes using the Insert menu

 1. Anywhere in the Node view, right-click and select Insert > the desired category > the desired node. The 
categories are the same as in the Node Library view.

‣ In the Node View menu, you can also select Insert > Effects > the desired category > the desired 
node.

The new node appear at the center of the visible Node view area.

How to organize the node system

 1. In the Node view, select some or all of your nodes.

 2. Display the Node View toolbar by selecting Window > Toolbars > Node View.

 3. Click the Order Node View Up  or Order Node View Down  button. 

The Order Node View Settings dialog box opens.

 

 4. Set values for the X Overlap%, Layer Spacing and Vertical Spacing. The default value is set for optimal organ-
ization.

 5. Click OK.
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How to connect nodes

 1. In the Node view, do one of the following: 

‣ Extend a cable from the first node’s output port (bottom port) and connect it to the second node’s input 
port (top port). 

‣ Select the node to connect, hold down the Alt key and drag the node on an existing cable.

It is possible to create links between nodes in the Node view by clicking on one node and Ctrl-clicking (Windows) 
or ⌘-clicking (Mac OS X) on a second port.

Select a node and Ctrl-click (Windows) or ⌘-click (Mac OS X) a port:

‣ Click a node and then Ctrl-click (Windows) or ⌘-click (Mac OS X) the input port of a different node. The 
nodes are linked.

‣ Click the output port of a node, and then Ctrl-click (Windows) or ⌘-click (Mac OS X) a different node. 
The nodes are linked.

‣ Click the output port of a node, and then Ctrl-click (Windows) or ⌘-click (Mac OS X) a Composite 
node. The node is linked to a new input port of the Composite.

‣ Click a port of a node and then Ctrl+ Alt-click (Windows) or ⌘+ Alt-click (Mac OS X) port of a 
Composite node. The selected port replaces the link in the Composite's input port.

‣ Click an output port of a node and then Ctrl-click (Windows) or ⌘-click (Mac OS X) the input port of a 
Group node. The selected output port replaces the link to the group.

‣ Click an output port of a node and then Ctrl+ Alt-click (Windows) or ⌘+ Alt-click (Mac OS X) the input 
port of a Group node. The selected output port links to a new in-port of the group.

NOTE: You can reconnect a node's output port without disconnecting its destination port by dragging the connect 
from the output port to another output port while holding Ctrl (Windows/Linux) or ⌘  (Mac OS X).

How to disconnect nodes

 1. In the Node view, select the node to disconnect, hold down the Alt key and drag the node away.
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How to change cable styles

‣ In the Node View menu, select View > Cable Style > Bezier or Line.

How to navigate the Node view

 1. In the Node view, select a node or cable, and press the Ctrl + Up/Down arrows (Windows) or ⌘ + Up/Down 
arrows (Mac OS X).

How to display all nodes

 1. From the Node View menu, select View > Show All Nodes or press Shift + comma (,).

How to show or hide the navigator, do one of the following

‣ In the Node view menu, select View > Navigator > Hide Navigator or Show Navigator. 

‣ Press Ctrl + Shift + W (Windows/Linux) or ⌘  + Shift + W (Mac OS X).
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How to position the navigator

‣ In the Node view menu, select View > Navigator > and select Top Left, Top Right, Bottom Left, or 
Bottom Right.

How to magnify the Node view

 1. In the Node view, hold down Z. 

A black outline surrounds the area you were at before pressing Z.

 2. Change the magnification level of the magnifier by rolling the mouse wheel. You can also pan your mouse 
to move around the magnified area.

 3. When satified with the magnified area's position, click inside the magnified area to set it as your new view 
point.

How to pan the Node view

 1. Select a node, press Spacebar and drag to a new location.

Composite Node

The Composite node allows you to use several images and output a single image. You can compare that to doing 
pre-compositions in editing software. You can connect several drawing, image generators and effect nodes in 
your Composite node and one bitmap (or vector in some cases) comes out of it.

By default, the image resulting from the Composite node is a bitmap. The layers are composited together 
depending on their position on the Z-axis (forward-backward) first, then their order in the Composite node. If two 
images are at the same position on the Z-axis, their order in the Composite will determine which one is displayed 
in front and which one is displayed behind.

For more information about the Composite node options in a 3D environment context, refer to Managing a Node 
System with a 3D Scene Setup on page 232.
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Parameter Description

Mode

As Bitmap: Composites all images into a single, flat bitmap image. The Z value of 
the final image is based on the Output Z selection.

As Vector: Composites all the images as a single vector image. The Z value of 
the final image is based on the Output Z selection. Bitmap elements are ignored 
and do not appear in the final frame.

As Seamless Bitmap: Composites all the images into a single, flat bitmap image 
(just like the As Bitmap compositing mode). The main difference between the As 
Bitmap and As Seamless Bitmap modes is that the seamless version ensures 
that there is no visible seam between adjacent vector drawings that have 
matching geometries. This can be useful for cut-out animation, where multiple 
drawings may align perfectly like pieces of a puzzle (using masking/cutter). This 
can also be useful when building a 3D set out of flat drawings rotated in 3D. In this 
case, using the Seamless mode will produce the correct result when two 
drawings are intersecting or nearly intersecting. When using this mode, the 
following effects are not supported: Shadow, Glow, Blending  and Focus.

Pass Through: No compositing operations occur. No image is merged or 
flattened. Each individual image  keeps its own properties. The compositing 
operations happen only in the next Composite node connected below. In this 
case, the port ordering is ignored.

If a Composite set to Pass Through it is the last one in the compositing chain, it 
will act the same as the As Bitmap option. At that point, the Input Ordering 
options are considered.

Input Ordering

2D: Elements connected in the node are composited based on their port ordering. 
The Z-axis (forward-backward) values are ignored. The scaling value will be 
correct, but the actual position on the Z-axis is ignored. 

You can use the 2D composite type to create effects such as a camera recording 
overlay on your scene. Since you always want this element to be in front 
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regardless of the other elementsè Z-axis position, you can set the option to 2D.

3D Flat: The Z-axis value of the elements connected in the Composite node are 
considered, so the visual representation is correct in the Camera view. The output 
is a flat image.

3D: The Z-axis value of the elements connected in the composite node are 
considered, so the visual representation is correct in the Camera view. The image 
is not flattened. The 3D aspect of the elements are kept. For example, if you 
rotated elements on the three axes, the information is retained and elements 
composited in lower levels are able to intersect with the elements coming from a 
3D Composite node.
The 3D Composite node should only be used in advanced cases. It is better to 
use a Pass Through composite type than a 3D composite type. This way, all the 
elements are composited in the final Composite node.

Output Options

Output Z: Identifies which element’s front-back value from the current 
composition is applied to the entire composited image in the next operation. If you 
select Portnumber, identify the appropriate port by its position using the Port For 
Output Z menu.

Port for Output Z: When using the Portnumber option in the Output Z menu, you 
can select which port you want to use as the Z value for the Composite node. The 
port used appears in a bright green colour on the Composite node. By default, the 
leftmost port is displayed in front and the rightmost port is displayed behind.

Bitmap Options

These options are active when you select the As Bitmap mode.

Apply Focus: Activates the Focus effect for this node in the composite operation.

Focus Multiplier: The value entered in this field is used as a multiplier for the 
radius value specified in the Focus or Focus-Multiplier nodes. 

Vector Options

These options are active when you select the As Vector mode.

Palette Name: When you render files using As Vector Composite nodes, use 
this field to set the name of the palette files that Toon Boom Harmony will create 
for them.

174



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

Flatten: Flattens vector drawings into one vector drawing file. Any transparency 
will be lost in the process. This creates smaller vector files, but might increase 
the time required to composite the drawings. This can be useful when reusing 
drawings. Because they will be vector files, you can still apply vector-based 
transformations and effects.

Working with Backdrops

Backdrops are a way to work with complex node systems that let you associate a selected set of nodes by colour. 
You can add as many backdrops to your node structure as needed. The idea is to visually organize the structure so 
you can quickly identify the particular set of nodes.

You can customize the backdrops with different colours. For example, the upper part of a character's body could be 
in different shades of red, while the lower body is in shades of green. When you create a backdrop to the Node view, 
the default colour is red. 

Once you have created a backdrop with nodes inside, you can move the backdrop to the desired location and 
arrange multiple backdrops neatly. You can also resize backdrops to accommodate the number of nodes in your rig.

You can select the nodes you want to add to the backdrop before creating it and vice versa—create an empty 
backdrop and then drag the desired nodes into the backdrop.

NOTE: 
Because backdrops are not layers, its properties do not appear in a node's properties.
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How to add a backdrop

 1. In the Node view, do one of the following:

‣ Select the nodes to include in the backdrop.

‣ Click anywhere in the Node view to deselect any selected items.

 2. From the Node View menu, select Insert > Backdrop.

If you selected nodes, a red backdrop displays around the nodes you selected.

If you did not select anything, a red backdrop displays in the Node view.

How to remove a backdrop

 1. In the Node view, clear any backdrop or node selections.

 2. Alt+ click on the title bar of a backdrop to only select the backdrop, without the nodes.

‣ If you want to delete the backdrop and all its nodes, simply select the backdrop without using the Alt 
key.
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 3. Press Delete.

‣ If you had a node selection, depending on your project, the Confirm Delete window may display. Deselect 
the Delete Drawing Files and Element Folders. If you have multiple version of a scene, you will want to 
keep all the files and folders associated with it. If you select this option, all the drawings and folders linked 
to this backdrop will be deleted.

Customizing a Backdrop

Once you've created a backdrop, customizing it is a great way to organize your work. You can change the colour of 
the backdrop, give it a name which displays in the title bar of the backdrop, and add any notes or instructions 
pertaining to the nodes contained in the backdrop.

How to customize a backdrop

 1. To resize a backdrop, drag the triangle in the lower-right corner of the backdrop window.

 2. Click the yellow square properties button.

The Backdrop Properties window opens.

 3. To change the colour of the backdrop, click the Colour list and select a colour.
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 4. In the Name field, type in a name for the backdrop.

 5. In the Text field, type in any notes or instructions in the backdrop.

Organizing Nodes in Backdrops

Once you have deselected all items in the Node view, you can organize any of the nodes by dragging and moving 
them around even if they are in a backdrop. You can move nodes from one backdrop to another.

How to organize nodes in backdrops

 1. Click anywhere in the Node view to deselect all items.

 2. Organize the nodes by dragging them from one or more backdrops.

Moving a Backdrop

When you want to move a backdrop, you can do so either with or without the nodes it contains. Moving a 
backdrop with its nodes lets you quickly organize entire sections of a complex rig. Moving the backdrop only 
(without its nodes) gives you a chance to reorganize a node structure. Perhaps nodes should be grouped 
differently for a better workflow or nested within another backdrop for optimal organization.
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How to move a backdrop and its contents

 1. Click anywhere in the Node view to deselect all items.

 2. Click the title bar of a backdrop and drag to a new location.

How to move a backdrop without its contents

 1. Click anywhere in the Node view to deselect all items.

 2. Hold down Alt (Windows/Linux) or ⌘  (Mac OS X) and drag the backdrop by the title bar to a new location.

 3. Click anywhere outside the backdrop to set its new position.

Copying and Pasting a Backdrop

When you copy a backdrop, its contents are copied along with the backdrop name, colour, and any notes. When 
selecting a backdrop, all backdrops underneath it are also selected.

When you select a backdrop with the Alt (Windows/Linux) or ⌘  (Mac OS X) key, the backdrop retains its Z order.

NOTE: 
A selection that contains only backdrops cannot be copied.

 

How to copy and paste a backdrop

 1. Select one or more backdrops to copy and press Ctrl + C (Windows/Linux) or ⌘  + C (Mac OS X).

 2. To paste the copied backdrop(s), press Ctrl + V (Windows/Linux) or ⌘  + V (Mac OS X). Note that nodes will 
be pasted as clones. They will link to the same drawing columns and existing function columns.
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Adding Backdrops to the Library

For your convenience, you can add backdrops as templates to the library—see Create a Template from the Node 
view in Chapter 7: Library of the Cut-out Animation Guide.

Enabling and Disabling Nodes

As with the Timeline layers, you can turn the Node view nodes on or off. When you turn off a node in the Node 
view, its corresponding layer in the Timeline and Xsheet views is also turned off. Nodes that are turned off are 
displayed in red.

How to disable nodes

 1. In the Node view, select the node(s) you want to enable.

 2. In the Node View menu, select Nodes > Disable or press D.

How to disable all other nodes

 1. In the Node view, select the node(s) to remain enabled.

 2. In the Node view menu, select Nodes > Disable All Others.

All nodes are disabled except for those selected. This  operation only affects the current level layers. It 
does not affect the nested nodes within a group.

How to enable nodes

 1. In the Node view, select the disabled node(s) you want to enable.
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 2. In the Node View menu, select Nodes > Enable or press A. This keyboard shortcut is also valid in the 
Timeline view.

How to enable all nodes

 1. In the Node View menu, select Nodes > Enable All.

Node Thumbnails 

In the Node view, some nodes have a thumbnail option, identified by an arrow next to the properties button (square 
yellow button). Thumbnails can be very useful when navigating the network to easily identify the content of each 
node or analyze the flow of images and effects.

How to display a node’s thumbnail

 1. In the Node view, click on the arrow in the node.

The thumbnail opens.
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If no thumbnail appears, click the Render View  button in the Camera view (bottom toolbar) to generate 
them.

How to show thumbnails of selected nodes

 1. In the Node view, select the node(s) whose thumbnails you want to display. 

 2. In the Node View menu, select View > Show Selected Thumbnails or press T.

If no thumbnail appears, click the Render View  button in the Camera view (bottom toolbar) to generate 
them.

How to hide a node’s thumbnail

 1. In the Node view, click the arrow in the node.

The thumbnail closes and the node returns to its closed state.
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How to hide thumbnails for the selected nodes

 1. In the Node view, select the node(s) whose thumbnails you want to hide. 

 2. In the Node View menu, select View > Hide Selected Thumbnails or press T. 

How to hide all nodes thumbnails

 1. In the Network View menu, select View > Hide All Thumbnails.
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Working with Groups
With so many connections and nodes possible, the Timeline and Node views can quickly become crowded. Keep 
things organized by grouping your nodes.

You can create a simple group or a group with a Composite node. There are several advantages to using the 
Group Selection With Composite command over the simple Group Selection (which references both the Group 
layer in the Timeline view and the Group node in the Node view.

One of the advantages of using this command is that it groups all the selected elements into a neat node that has 
a nested composite. This means there is only one connection coming out of the Group node. With the simple 
Group node or command, the Group displays the same number of connections as elements in the group. Both 
grouping commands display the same structure in the Timeline view.

The Group Selection With Composite command should only be used before any work has been done in the Node 
view and is recommended for objects whose stacking order is of no consequence.
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Using the Group Selection from Composite command on elements that have effects, have been tweaked in the 
Node view, or whose stacking order is of consequence, may cause the grouped elements to lose their properties 
once grouped in this way. In addition, though you may only select a few nodes to group, if there are other layers in 
the Timeline view that exist between the selected layers, they will automatically be grouped, even if not selected.

Once you create a group node, it is easy to enter into or exit from it.

Using the Move to Parent Group command allows you to move the selected node to the parent level, maintaining all 
connections.  If the operation cannot maintain the connections between the nodes, you will be notified and the 
operation will be terminated.

To quickly access parameters for nodes that are grouped, you can use the Publish Attribute Mode feature to select 
your most common parameters to modify and make them appear in the group Layer Properties editor. This way, you 
can access them directly without having to enter the group every time.

How to group nodes

 1. In the Node view, drag a selection around the nodes you want to group.
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 2. In the Node menu, do one of the following:

‣ Select Edit > Group > Group Selected Layers.

‣ Press Ctrl + G (Windows/Linux) or ⌘  + G (Mac OS X).

The selected nodes are grouped.

NOTE: 
To ensure that you have a Multi-Port Out node in your group and that your group remains connected, include a 
Composite node in your selection and make sure it is connected to the main Composite node of the scene before 
grouping.

How to group elements in the Node view

 1. In the Node view, select the elements you want to group. 

 2. Right-click in the Node view and select one of the following:
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‣ Group > Group Selection With Composite or press Ctrl +Shift + G (Windows/Linux) or ⌘  + Shift + G 
(Mac OS X).

‣ Group > Group Selection or press Ctrl + G (Windows/Linux) or ⌘  + G (Mac OS X).

The selected nodes are grouped.

How to group elements in the Timeline view

 1. In the Timeline view, select the elements you want to group. 

Any layers between the selected layers will be automatically grouped as well, so if the stacking order does 
not matter, move extra layers above or below the layers want to group. 

 2. Do one of the followings: 

‣ Right-click on the highlighted layers and select Group Selection With Composite. 

‣ Right-click on the highlighted layers and select Group Selection.

‣ From the top menu, select Edit > Group > Group Selected Layers.

The layers appear indented under a new Group layer in the Timeline view and in a new Group node in the 
Node view. 

How to ungroup a group of nodes

 1. In the Node view, select the group you want to ungroup.

 2. In the Node menu, select Edit > Group > Ungroup.

The selected group is ungrouped.
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How to enter a group node

 1. In the Node view, click the arrow on the right side of the group node you want to enter.

‣ Inside the group node, the Multi-Port In and Multi-Port Out nodes ensure that your connections 
continue beyond the group.

How to exit a group node

 1. In the Node view, click the destination in the Group Hierarchy menu. You can also select Nodes > Exit 
Group from the Node menu.

‣ You can click on the top blue arrow in the Node view to exit the current group.

‣ When you enter a group, the Group Hierarchy menu displays the path to where you are. In this 
example, we are inside the group named Deform_Bob. To exit this group, click Top at the bottom-left 
corner of the Node view.
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How to move up a level in a group

‣ Click the arrow at the top of the Node view.
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How to move a selected node to its parent group

 1. In the Node view, go inside the group and select the nodes you want to move up to the parent group level.

 2. From the Node menu, select Nodes > Move to Parent Group or press Ctrl + Shift + U (Windows/Linux) 
or ⌘  + Shift + U (Mac OS X).

The selected nodes are moved to the parent group level.
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How to use the Publish Attribute mode

 1. From the Node menu, select View > Publish Attribute Mode.

 2. In the Node view, enter the group containing the nodes you want to promote.

 3. Select the node whose attributes you want to publish.

 4. In the Layer Properties view, enable or disable the publishing options for the different parameters. You can 
easily distinguish them as they are labeled in red.
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 5. Repeat the previous step for all the nodes that contain attributes you want to publish.

 6. In the Node view, exit the group.

 7. Select the Group node.

In the Layer Properties view, you can see all published attributes. The different nodes are tabbed for easy 
access and organization.
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Display Concepts
The Display node is an important node; it is used by the export and views to display your scene, primarily the 
Camera and Timeline views. By default, a scene's node system always has a Display node which can be used to 
show your entire scene, a single node or a group of nodes through a Composite or Group node. You might use it to 
see one single character as you animate it, debug your node system as you create complex effects or export your 
complete scene or a portion of it. 

You can have more than one Display node in the Node view, so you can visualize different sections of the scene 
without disabling or disconnecting elements that are in the way. This is useful in cut-out animation as it allows you to 
see one puppet without viewing all the other characters. It's also useful during compositing and helps you visualize 
and debug effects.

To use this display concept, show the Display toolbar which will let you select different Display nodes available in 
the node system. 

You can also use the Scene > Display menu to select the desired Display node to update the contents of the 
Camera, Top, Side, Perspective, and Timeline views.
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When your scene does not have a Display node, it is automatically set to Display All which uses the Timeline 
view ordering and shows floating nodes from the Node view. You can also set your scene to use Display All using 
the Display toolbar.

NOTE: If you try to add a peg or other transformation layer in the Timeline view without having a layer selected, an 
error message will display. Make sure to change to Display All. The peg layer will be floating in the Node view and 
will not be visible in the Timeline view.  The Timeline view shows only layers that are connected to the Composite 
node.

If you switch to Display All, you run the risk of not realizing when you have floating nodes that are not connected to 
your composite.  For this reason, it is not recommended to work in Display All mode.

When your scene contains many nodes and you cannot see them all, you can display all nodes at that level.

Harmony has two display modes. By default, it is set to the Basic Display mode.

When creating a scene in Basic Display mode, a Display node is automatically added to the node system and 
connected to the final Composite node. All of the views are set to use this Display node. This means that only the 
elements connected in that Composite node will show in the Camera view. 
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You can add and connect more Display nodes to your node system and select the one you want by using the 
Display menu. In Basic mode, every view is set to the same Display node.

In Advanced Display mode, every view using the display concept has its own Display menu and each one can be 
set to a different Display node. To switch from Basic to Advanced Display mode, you must enable the Advanced 
Display option in the Preferences dialog box (Advanced tab). These Display menus allow you to set the views to 
different displays. By default, all views are set to Default to follow the main Display toolbar selection. However, you 
may want different views set on different displays. For example, you can have one Camera view to display the full 
scene and another Camera view to only display the character being animated. In this case, you can set the first 
Camera view on the final display and the second on the character’s Display node.

If you want the views to follow the main Display toolbar selection, set the display option of EACH display menu to 
Default.

How to add a Display node

 1. Do one of the followings:

‣ In the Node view, press Ctrl + Y (Windows/Linux) or  ⌘  + Y (Mac OS X).

‣ In the Node menu, select Insert > Display.

‣ In the Node view, right-click and select Insert > Output > Display.

‣ In the Node Library view, in the Output category, select a Display node and drag it to the Node view.

How to set a different Display node as a global display

‣ From the top menu, select Scene > Default Display > desired display or open the Display toolbar menu 
and select a display from the list. 

Each view is updated if set to the Default display option.
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How to enable the Advanced Display option

 1. Do one of the following:

‣ From the top menu, select Edit > Preferences (Windows/Linux) or Stage Premium > Preferences 
(Mac OS X). 

‣ Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

 2. In the Preferences dialog box, select the Advanced tab. 

 3. In the Advanced Options section, select the Advanced Display option.

A Display menu appears in the top-left corner of the Camera, Timeline, Perspective, Top, and Side views.

Timeline View Modes
The View Modes  button lets you streamline the process of working with elements in the Timeline view. There 
are three different view modes you can choose to work in. With each mode you select, certain elements may or 
may not be visible in the Timeline view. Depending on your workflow, this can be useful for quickly hiding 
elements when you want to focus on specific ones. To select a view mode, use the drop-down menu in the 
bottom-left corner of the Timeline view.

 Normal View Mode

Normal View  mode is the default Timeline view mode. It shows everything connected to the chosen display. 
In this mode, anything not connected to the currently set default display will not be shown in the Timeline view. 
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This also means that you cannot add certain elements to the Timeline view, as by default, when added they are not 
connected to any display or composite node. An example of such an element is a peg.

NOTE: If you prefer to work as you did before, where you see everything in the Timeline whether it is connected to a 
Display or not, you can change the Always Display Unconnected Nodes setting in the Preferences dialog box, 
Timeline tab.

Selection Only Mode

When working in Selection Only  mode, only elements currently selected in the Camera or Node view will be 
visible in the Timeline. This makes it easier to concentrate on one or a few elements at a time.

View Tagged Layers

The View Tagged Nodes   mode lets 

you see only elements which have been assigned a Tagged status. An item that has been tagged will appear in the 
Timeline view with a small asterisk beside its name.

Once your elements are tagged and you have switched over to View Tagged Layers mode, the Timeline view will 
display only tagged elements. The red bar on the left of the layers indicates you are in this view mode.

While in this mode, the asterisks are not displayed beside the tagged elements.

How to tag or untag elements in the Timeline or Node view

 1. In the Timeline or Node view, select one or more elements.

 2. Do one of the following:

‣ Right-click and select Tag and one of the following: 
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‣ In the Timeline or Node view menu, select Edit > Tag and one of the following: 

Timeline Tag: Tags selected elements in the Timeline or Node views.

Timeline Untag: Untags selected layer in the Timeline view.

Timeline Untag All: Untags all tagged elements.

Timeline Untag All Others: Untags all elements except the selected one.

Creating a Multiplane

One of the most exciting features in Harmony is the multiplane or Z-depth. In the multiplane, you can create 
backgrounds in several layers, spread them on the Z-axis to add depth, and then move the camera through this 
environment to create an impressive perspective illusion.

To construct a multiplane, you must imagine what a real environment is like. Take a look at your background 
picture and imagine a camera moving through the space. Notice that objects in the picture move at different 
speeds depending on where they are in relation to the camera lens.

Building a multiplane requires an understanding of the scene's background, as well as the positioning of the 
elements on different layers.
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For example, in the background illustrated above, the main objects to be separated are:

 1. Fern

 2. Front tower

 3. Second tower

 4. Moon

 5. Stars

 6. Sky

Although the bottom of the tower is hidden behind the plant and the ladder, each of the multiplane layers should be a 
complete drawing. This is because hidden portions may show up during a camera move later on in the scene.

You can position layers on the Z-axis using the Side and Top view. 

Positioning your element closer to the camera makes them appear bigger. You can also move elements towards the 
camera or away from the camera while keeping the same size aspect ratio in the Camera view.

It is a good idea to keep a Camera view open to see what your scene looks like while positioning elements in the Top 
and Side views—see Top View on page 202, Side View on page 203 and Perspective View on page 205.
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You can see the cumulative Z value information in the Coordinates and Control Points view. When you select a 
drawing cell that includes a keyframe, it will display the cumulative Z value.

When a layer is parented to other layers that are moved forward or backward on the Z-axis, the currently selected 
layer's position Z value may not be accurate since its parent will also have an offset on the Z-axis. The 
Cumulative Z value is a compilation of all the Z-axis offsets to give the real Z-axis offset value related to the (0,0) 
centre.

200



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

How to position an element in the Top and Side views

NOTE: Before distributing layers along the Z-axis using the Top and Side views, deselect the No Z Dragging option 
by selecting Animation > No Z Dragging. This option is disabled by default.

 1. To maintain the visual scale in the Camera view as you move your element, do one of the following:

‣ In the Advanced Animation toolbar, select the Maintain Size  tool.

‣ From the top menu, select Animation > Tools > Maintain Size.

‣ Press Alt + 6.

 2. In the Side or Top view, select one of the layers in the thumbnails section. You can also select a layer from 
the Timeline view.

The selected layer is highlighted in the Top, Side and Camera views.

 3. Drag the layer to the correct depth position in the camera cone. Your element aspect will remain the same in 
the Camera view.

 4. For your element to scale up or down in relation to their distance to the camera, do one of the following:

‣ In the Tools toolbar, select the Transform  tool. Make sure the Peg Selection Mode  option is 
disabled in the Tool Properties view.

‣ In the Advanced Animation toolbar, select the Translate  tool and select a layer from the thumbnails 
section of the Top or Side view.

‣ Select a layer from the Timeline view.
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The selected layer is highlighted in the camera cone.

 5. In the Top  view, drag the element sideways to position it horizontally. Hold Shift while dragging the ele-
ment to make sure it only moves along the X-axis.

 6. In the Side view, drag the selected element up or down to position it vertically. Hold Shift while dragging 
the element to make sure it only moves along the Y-axis.

Top View

The Top view is used mainly for multiplane scenes and to position elements in 3D space. It allows you to see the 
scene’s stage  from above. This lets the camera cone and the spacing between the elements be seen.

 1. A thumbnail of each drawing layer in the scene. The order of the thumbnail images is based on each ele-
ment’s FB position in the scene space. You can see a representation of the FB position of each layer in the 
camera cone.

 2. The camera cone represents the camera’s position and field-of-view (FOV). 
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 3. The axis reference arrows let you maintain your orientation when navigating in the Perspective view.

 4. There are two view option buttons displayed in the lower-left corner of the view.

‣ Show/Hide Camera: Shows or hides the camera frame in the Perspective view. 

‣ Reset View: Resets the pan, rotation and zoom of the Perspective view.

 5. This field displays the current zoom level in the Perspective view. You can use the Zoom menu to select a 
zoom level from 2.5% to 6400%. You can also select Fit To View to automatically use a zoom level that lets 
you see all of the scene layers and information in the Perspective view at once.

 6. Displays the currently selected layer and drawing name.

 7. Displays the currently selected tool.

 8. Displays the currently selected frame of your animation.

 9. Displays the currently selected colour in the palette.

Side View

The Side view is used mainly for multiplane scenes and to position elements in 3D space. It allows you to see a 
scene’s stage  from  the side. This lets the camera cone and spacing between the elements to be seen.
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 1. A thumbnail of each drawing layer in the scene. The order of the thumbnail images is based on each ele-
ment’s FB position in the scene space. You can see a representation of the FB position of each layer in the 
camera cone.

 2. The camera cone represents the camera’s position and field-of-view (FOV). 

 3. The axis reference arrows let you maintain your orientation when navigating in the Perspective view.

 4. There are two view option buttons displayed in the lower-left corner of the view.

‣ Show/Hide Camera: Shows or hides the camera frame in the Perspective view. 

‣ Reset View: Resets the pan, rotation and zoom of the Perspective view.

 5. This field displays the current zoom level in the Perspective view. You can use the Zoom menu to select a 
zoom level from 2.5% to 6400%. You can also select Fit To View to automatically use a zoom level that 
lets you see all of the scene layers and information in the Perspective view at once.
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 6. Displays the currently selected layer and drawing name.

 7. Displays the currently selected tool.

 8. Displays the currently selected frame of your animation.

 9. Displays the currently selected colour in the palette.

Perspective View

The Perspective view is used during scene setup. It allows you to see a multiplane scene’s orientation. The 
Perspective view is similar to a 3D display, as it lets you rotate the scene through all possible angles to understand 
the spacing between the elements. You can also position and rotate your layers and the camera inside the 3D 
display to achieve some 3D setup and camera moves.

 1. The red circle rotates the view on its X axis.

 2. The green circle rotates the view on its Y axis.

 3. The blue circle rotates the view on its Z axis.

 4. This is a perspective grid reference.

 5. The axis reference arrows let you maintain your orientation when navigating in the Perspective view.

 6. There are three view option buttons displayed in the lower-left corner of the view.

‣ Show/Hide Camera: Shows or hides camera frame in the Perspective view. 

‣ Reset View: Resets the pan, rotation, and zoom of the Perspective view.
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‣ Reset Rotation: Resets the rotation of the Perspective view.

 7. This field displays the current zoom level in the Perspective view. You can use the Zoom level drop-down 
menu to select a specific zoom level from the list. Zoom levels from 2.5% to 6400% are available; you can 
also select Fit To View to automatically use a zoom level that lets you see all your scene layers and inform-
ation in the Perspective view at once.

 8. This field displays the currently selected layer and drawing name.

 9. This field displays the currently selected tool.

 10. This field displays the currently selected frame of your animation.

 11. This field displays the currently selected colour in the palette.

How to rotate a scene in the Perspective view

 1. In the Tools toolbar, select the Rotate View   tool.

‣ Click in the view, and drag the cursor around to rotate the view.

‣ Press and hold Ctrl + Alt (Windows/Linux) or ⌘  + Alt (Mac OS X) and click and drag to rotate the view 
one axis at a time. 

Orthographic Camera
The orthographic camera is specific to the gaming pipeline. It changes the camera type from perspective to 
orthographic. It becomes a camera without vanishing points. This means there is no more perspective in the 
Camera view. Objects, when moved on the Z-axis, will not change in size or scale.
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The orthographic camera can be set in the Scene Settings dialog box. In order  to create scenes with the orthographic 
camera, by default, you need to create a new custom scene resolution. Refer to the Fundamentals Guide to learn 
about custom resolutions.

How to set an orthographic camera

 1. From the top menu, select Scene > Scene Settings.

 2. Select the Resolution tab. 

 3. In the Projection section, select Orthographic option.
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Chapter 5: 3D Space

Harmony is well known for its multiplane space where you can move your layers forward and backward on the Z-
axis. Harmony brings you a true three-dimensional space where you can actually rotate your camera and layers on 
all axes. This lets you perform a 360 degree rotation around elements, create a floor and even build sets! 

NOTE: If you are using 3D rotations in your animation, do not render your project as a SWF as these parameters are 
not supported by that format.

This chapter contains the following topics:

• Enabling the 3D Option on page 210

• 3D Tools on page 215

• Positioning Elements in 3D Space on page 219

• 3D Camera Motion on page 226

209



Chapter 5: 3D Space     

Enabling the 3D Option

Before you can rotate layers in three axes instead of two, you must enable the 3D option in the layer properties. 
By default, when you create layers in Harmony, you can only move them as flat layers.    

How to enable the 3D option

1. In the Timeline view, select the layer you want to move in 3D space.

 1. In the Layer Properties view select the Transformation tab.

 2. Select the Enable 3D option to display the 3D parameters for that layer.

210



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

New parameters appear in the Layer Properties window.

 

3D Parameters

When working in 3D, notice that three sets of parameters are modified:

• Scale on page 211

• Rotation on page 213

• Pivot on page 214

Scale

When using 3D, the Z-axis parameter appears in the list of settings. You can have the Scale locked or separated. 
When the Scale is locked, the object you are scaling is uniformly resized in three directions. When the Scale is 
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separated, the object you are scaling can be squashed and stretched in any direction without affecting the other 
ones.

NOTE: You cannot add thickness to an object by scaling it in the third dimension. Three-dimensional scaling is 
used to scale objects that were rotated on their axes or to scale a group of objects laid out in three dimensions.
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Rotation

The main parameter you will use when working in three-dimensions is rotation. Without using 3D rotation, you are 
simply working using the multiplane technique.

3D rotation can be used in two different ways:

• Quaternion Rotation on page 213

• Euler Angles Rotation on page 213

Quaternion Rotation

Quaternion Rotation is very similar to the 3D path position parameters. A Quaternion is composed of three rotation 
functions: X, Y and Z to control the rotation on three axes, and a velocity function to control the velocity of the three 
rotation functions simultaneously. 

The X, Y and Z functions are linked. When you add a keyframe on one of them, it also adds it to the two others.

If you are planning to animate an element such as the camera, you should use the Quaternion rotation rather than 
Euler Angles. Quaternion creates a smooth trajectory and interpolation since the path is controlled by the same 
keyframes and a single velocity.

Euler Angles Rotation
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The Euler Angles Rotation is very similar to the Separate position parameters. The Euler Angles parameter is 
composed of three functions: X, Y and Z to control the rotation on three axes. These three functions are 
independent of each other; each has its own velocity.

When you add a keyframe on one function, the other ones do not receive it, allowing you to control each axis 
independently.

Euler Angles are mainly used to position elements with exact coordinates and rotate elements on a single axis. 
The interpolation between the keyframes will not be as smooth as the Quaternion one since each function works 
individually.

Pivot

When working in 3D, the drawing or layer pivot becomes a location that can move on three axes. When you work 
in two dimensions, the pivot is mainly an anchor point somewhere in the drawing from where the transformations 
will be performed. In 3D, the transformations are made on three axes, so the centre of rotation and scaling also 
becomes three-dimensional.

By default, the pivot is positioned at the centre of the stage: (0,0,0). When you use the Pivot  tool to reposition 
the centre of transformation, the pivot position is changed on the X and Y axes, but the Z-axis remains at zero 
until you change it in the Top, Side or Perspective view using the transformation tools.
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3D Tools

Once the 3D option is enabled, your transformation tools become 3D transformation tools. These tools are found in 
the Advanced Animation toolbar as well as the Transform  tool. Instead of letting you move elements only on the 
X and Y axes, you can also manipulate them on the Z-axis.

3D Translate Tool

Once you enable the 3D option, the 3D Translate  tool becomes available and you will see direction arrows 
appear around the pivot points to indicate the different axes.

You can click on the direction arrows to move your layer on only one axis. If you click anywhere else, the layer can 
move freely on two axes at once. Once the arrow is selected, it will turn pink.

NOTE: If you move the layers in the Perspective view, it may be difficult to control the motion since you may not have 
the optimum point of view on your stage to understand the setup. In this case, it is best to use the direction arrows.
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3D Rotate Tool

Once you enable the 3D option, the 3D Rotate  tool becomes available and you will see a rotation sphere 
appear around the pivot points indicating the different axes.

You can click on the direction ellipses to rotate your layer on one axis only. If you click anywhere else, the layer 
rotates freely on two axes at once. Once the ellipse is selected, it will turn pink.

NOTE: If you move the layers in the Perspective view, it may be difficult to control the motion since you may not 
have the optimum point of view on your stage to understand the setup. In this case, it is best to use the direction 
ellipses.

3D Scale Tool

Once you enable the 3D option, the 3D Scale  tool is available. You will see one of two things:

• A scaling rectangle appears if your drawing is flat.
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• A scaling cube appears if your object has some rotated layers around the pivot points, indicating the different 
axes.

Click on one of the three control points to scale the shape on one axis. Hold down the Shift key to scale the object 
proportionally. Once the control point is selected, it will turn pink.

NOTE: If you move the layers in the Perspective view, it may be difficult to control the motion since you may not have 
the optimum point of view on your stage to understand the setup.

3D Transform Tool

Once you enable the 3D option, the 3D Transform tool become available. This tool is a combination of the 3D 
Translate, 3D Rotate and 3D Scale tools.

To translate an element, grab the direction arrows in the same way that you would with the Translate tool.
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To rotate an element, grab the rotation ellipses in the same way that you would with the Rotate tool.

To scale an element, grab the scaling control points in the same way that you would with the Scale  tool.
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Positioning Elements in 3D Space

To position elements in 3D space, you need to understand what you want to build and what is involved in building it.

Simple sets like the above one are easy to build, light to manage and probably what you will use 3D staging for most 
often.

If you have a project based on a room, it can be useful to build it in 3D. This saves you from having to redraw the 
background for each scene and it will be entirely vector based.

Here, you can see some of the different backgrounds you can get in only three seconds from this set.
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Planning Your Pieces

When you are building a room, there are only a few pieces to prepare. Before starting to build your set, map out 
the parts you need.

A complex set that is more intricate in its design will require more careful planning. Not only will you have to list 
the pieces you need, but you will also have to think about what can be reused. If you have a series of windows in 
your set, you would create a symbol from the drawing, rather than copy paste it several times all over your set. 
This way, if you need to make any correction to its design, you will only need to do it once and all the instances of 
your symbol throughout your set will be corrected. The same can be done with for each piece of your set.

Here is an example of all the source drawings required to build the castle. 
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These are the only drawings required to build the entire castle. As you can see, there are not that many considering 
the final result. The rest is constructed by assembling symbols and through reuse. However, keep in mind that 
although you are using simple drawings and symbols to optimize your set, the more you add to your project, the 
heavier the toll it takes on your machine's RAM. While the scene's package itself is really light, running the scene 
places heavy demands on your RAM and video card.

Using the drawings shown previously, here are a couple of pieces that were put together.

Here is the final result. A large and impressive fortress.
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Using Complex Sets in Production Scenes

When your main set is built, you will want to store it in the Library. It is important to know that when you import 
such a large structure in one of your production scenes, the set may be slow to run. To avoid long rendering 
sessions or slow manipulation, remove all faces and planes that are not visible in your scene.
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Positioning the Layers

Once your drawings and symbols are assembled, it is time to position them. This section explains how this is done 
using the example of a simple room.

How to position layers in 3D space

 1. In the Timeline view, double-click on the new layer to open the Layer Properties dialog box.

 2. In the Transformation tab, select the Enable 3D option.

 3. In the Rotation section, select the Euler Angles option.

 4. In the (x) Axis field, type 90 to flip the floor so it is flat on the ground.
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NOTE: Use  the Perspective view to see this. Press Ctrl + Alt (Windows/Linux) or ⌘  + Alt (Mac OS X) to change the 
angle of the view.

 5. To position the height of the floor, type values in the Position section of the Layer Properties, use the Trans-
late  tool or Transform  tool.

 6. Repeat the process for the other pieces to position.

 7. If you have parallel walls, once you have positioned one, select the Wall layer in the Timeline view.

 8. Do one of the following to duplicated the layer.

‣ From the top menu, select Edit > Duplicate.

‣ Right-click and select Edit > Duplicate.

 

NOTE: If the drawing is contained within a symbol, the symbol will not be duplicated, only the layer containing the 
symbol. This way, you are still using the same drawing.
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 9. Once the layer is duplicated, use the Layer Properties window to enter the positioning values or use the trans-
formation tools.

 10. When using the transformation tools, use the Camera, Top, or Side view to position the elements instead of 
the Perspective view to position your layers precisely.

 11. If your walls are touching each other, you should make them intersect by extending one end of the wall 
through the other wall. This prevents seeing a small gap between them.

Now have a complete 3D room.
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3D Camera Motion
Once you have a 3D set, the exciting part is to do a camera move in it. This section teaches you the main steps 
required to perform a 3D camera move. Once you know how to do this, you can enjoy the delights of working in 
3D space and traveling through your creations!

You can change the near and far clipping planes of the camera. The near plane is the point on the camera cone 
where the camera is located. The far clipping plane is the far end of the camera cone. Nothing outside that range 
is visible. This is useful when dealing with 3D elements and 3D sets.  For example, the camera can be looking 
inside a 3D box or room and you might want the foreground wall to not obstruct the view of the interior. By default, 
the near clipping plane is set to 1 field and the far clipping plane is set to 1000 fields.

If you want to view your 3D camera move, you must be in the Perspective view.
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How to create a 3D camera move

1. In the Tools toolbar, enable the Animate  mode.

2. In the Timeline view, click the Add Layers  button and select Camera to add a camera to your scene.

 1. In the Timeline view, select the new camera layer.

 2. In the Timeline Layer toolbar, click the Add Peg  button to add a parent peg to the camera.

3. In the Timeline view, double-click on the new peg layer to open the Layer Properties dialog box.

4. In the Layer Properties dialog box, go to the Transformation tab and select the Enable 3D option.

 3. In the Rotation section, select the Quaternion option.

 4. In the Perspective view, click the Show/Hide Camera button to see your camera cone.

5. Setup your workspace to display the Camera view and Perspective view at the same time so you can 
compare the results.

 5. In the Tools toolbar, select the Transform  tool.

6. In the Timeline view, select the Camera-Peg layer first frame and select Insert > Keyframe.

7. In the Timeline view, select the Camera-Peg layer.

8. In the Timeline view, go to the last frame.
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9. In the Perspective view, grab one of the rotation ellipses and rotate the camera on one axis only. Always 
do one axis at a time to keep control of the positioning.

10.Once the camera is rotated at the correct angle, grab one of the direction arrows to move the camera to the 
correct position. A keyframe is automatically created in the Timeline view.

How to modify the camera clipping plane

 1. In the Timeline or Node view, select the Camera node.

 2. In the Layer Properties view, go to the Clipping Planes section.
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 3. Modify the value of the Near Plane to pull or push the clipping area closer to the camera. Anything behind this 
plane will no longer be visible.

 4. Modify the value of the Far Plane to pull or push the clipping area closer to the camera. Anything beyond this 
plane will no longer be visible.

How to enable the playback mode in 3D

 1. From the top menu, select Play > Enable Playback > Perspective View.

 2. In the Playback toolbar, click the Play button to see the results.

Locking Flat Drawings to the Camera Angle

 

When you create a 3D camera move in your scene, notice that layers are treated as flat objects. That is, animation 
layers that are supposed to face the camera at all times will look like a flat sheet of rotating paper. Use the Ortholock 
layer when mixing flat animation layers with a set built in 3D. Ortholock forces your drawing layer to always follow 
the Camera angle. It does not follow its position or zooming level, only the rotation. This prevents drawings from 
being distorted by the camera motion.
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NOTE: Adding an Ortholock layer in a symbol will not give the correct result. The Ortholock contained inside a 
symbol does not consider the position of the camera contained in the root scene. Keep your Ortholock layers in the 
root scene.

How to add an Ortholock layer

 1. In the Node Library view, select the Move category.

 2. Select the Ortholock node and drag it to the Node view.

 3. In the Node view, drag an output cable from the Ortholock node and connect it to the node you want to 
keep facing the camera.

Managing a Node System with a 3D Scene Setup
In Harmony, you can create very advanced networks using effects, complex connections and multiple-level 
compositing.

The Composite node's main task takes all of your image's output and converts it into a single flat image that you 
can render out. You can alter it further by manipulating a three-dimensional scene setup. You can also modify a 
Composite's behaviour as seen in the Scene Setup on page 117 chapter. 
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Input and Output Options

The default options combination is:

• As Bitmap, for the output behaviour

• 3D flat, for the input ordering

By default, a Composite node is set to output a flat bitmap image and to correctly composite elements positioned in 
3D space.

For example, if you have two intersecting walls, and use the default combination, you will see the following result:
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This image is correctly represented in the Camera view and is output from the Composite node as a flat drawing. 
The Z-axis value of your elements are not retained, it becomes an independent composition with only one 
forward-backward value.

NOTE: When building a 3D set out of planes, it is recommended that you set the composite mode to As Seamless 
Bitmap. This avoids intersection issues when rendering the 3D objects created out of planes.

3D Input Ordering Option

The visual result for the 3D Input Ordering option is the same as the 3D Flat option. The visual result in the 
Camera view will be correct, but the elements will not be converted into a flat image. The 3D position of your 
images will be remembered until the next Composite node. This mode is quite advanced and should only be used 
in very advanced cases. Most of the time you will use the 3D Flat Input ordering option.

2D Input Ordering Option

If you switch the Input Ordering option to 2D, the walls will be calculated as flat 2D objects and not as 3D objects. 
The perspective caused by the 3D rotation will be correctly represented, but the elements will not intersect. The 
result will be similar to the following:

Managing a Node System with a 3D Scene Setup
In Harmony, you can create very advanced networks using effects, complex connections and multiple-level 
compositing.
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The Composite node's main task takes all of your image's output and converts it into a single flat image that you can 
render out. You can alter it further by manipulating a three-dimensional scene setup. You can also modify a 
Composite's behaviour as seen in the Scene Setup on page 117 chapter. 

Input and Output Options

The default options combination is:

• As Bitmap, for the output behaviour

• 3D flat, for the input ordering

By default, a Composite node is set to output a flat bitmap image and to correctly composite elements positioned in 
3D space.

For example, if you have two intersecting walls, and use the default combination, you will see the following result:

233



Chapter 5: 3D Space     

This image is correctly represented in the Camera view and is output from the Composite node as a flat drawing. 
The Z-axis value of your elements are not retained, it becomes an independent composition with only one 
forward-backward value.

NOTE: When building a 3D set out of planes, it is recommended that you set the composite mode to As Seamless 
Bitmap. This avoids intersection issues when rendering the 3D objects created out of planes.

3D Input Ordering Option

The visual result for the 3D Input Ordering option is the same as the 3D Flat option. The visual result in the 
Camera view will be correct, but the elements will not be converted into a flat image. The 3D position of your 
images will be remembered until the next Composite node. This mode is quite advanced and should only be used 
in very advanced cases. Most of the time you will use the 3D Flat Input ordering option.

2D Input Ordering Option

If you switch the Input Ordering option to 2D, the walls will be calculated as flat 2D objects and not as 3D objects. 
The perspective caused by the 3D rotation will be correctly represented, but the elements will not intersect. The 
result will be similar to the following:

How to Organize Your 3D Composite Nodes

If you start combining several composite nodes in your Node view, it is important to understand how they work if 
you want to get the desired result.

234



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

There is a specific order in which you should set your Composite nodes. Each time you process images through a 
3D Flat Composite node, the images will be merged together. Images processed in later Composite nodes cannot 
be inserted between images of the previous composite since it is a flat image.

If you used Pass-Through type Composite nodes in your network, the images will not be processed together before 
the final Composite. It is important to keep your final Composite as a 3D Flat Composite in order to read the layer 
ordering correctly.

The most efficient networking system for obtaining the desired result is likely  the Pass-Through composite mode 
throughout the whole network. This way, you can create individual compositions to keep your network clean and 
organized, but process everything together at the end.

NOTE: When building a 3D set out of planes, it is recommended that you set the composite mode to As Seamless 
Bitmap. This avoids intersection issues when rendering the 3D objects created out of planes.
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Chapter 6: Path Animation

With Harmony, you can animate layers using computer-generated trajectories, create multiplane camera moves and 
camera shakes, adjust the easing, shape your paths with control points and much more.

This chapter contains the following topics:

• Animating a Layer on page 237

• Differences between Animated Layers and Pegs on page 239

• Layer Parameters on page 245

• Adding and Deleting Keyframes on page 248

• Motion and Stop-motion Keyframes on page 250

• Animating the Camera on page 254

• Modifying a Path in the Camera, Top and Side Views on page 261

• Modifying a Path in the Timeline View on page 268

• Modifying a Path in the Function View on page 270

• Modifying a Path in the Xsheet View on page 277

• Function Curves on page 279

• Copying and Pasting a Motion on page 286

• Adjusting the Velocity on page 293

• Expression Columns on page 300

Animating a Layer
Before animating the position of drawing layers, you need to create motion paths which are trajectories on which you 
can attach drawing objects. Using keyframes, you can then record key positions along the trajectory. 
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Harmony’s wide range of features let you produce simple and advanced motions and trajectories. By creating a 
simple motion, you will learn the basics of animating a layer.

The Animate mode lets you keyframe drawing layers to create computer-generated animation. When working in 
the Animate mode, you can animate a layer's position and then turn off the mode to reposition a layer for the entire 
scene. When the Animate mode is disabled, keyframes are created on selected layers at the current frame. 
Depending on what transformations were performed (rotation, translation, skew), the new keyframes are added 
on the corresponding parameters (function curves).

How to turn the Animate mode on or off

 1. In the Tools toolbar, click the Animate  button or select Animation > Animate.

How to animate a layer

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 3. In the Tools toolbar, enable the Animate  mode. This will create keyframes at the current frame when 
moving objects.

 4. In the Timeline view, go to the first frame.

 5. In the Camera view, select the element to animate and move it to its first position.

A keyframe is created on the first frame of the Timeline view.

 6. In the Timeline view, go to the frame on which you want to set the second position.
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 7. In the Camera view, move the element to its second position.

A second keyframe is created on the Timeline view.

 8. Play back  your animation.

To see your motion animations in the Top, Side or Perspective views while you play back, you must turn on 
the Playback option. From the top menu, select Play > Enable Playback > Top View or Side View or 
Perspective View.

Differences between Animated Layers and Pegs
There are two ways to create motion paths: animated drawing layers and pegs. They each have different purposes. 

You can create a motion path directly on layers (animated layers). 

You can control and define a trajectory using several different parameters, including:

• X, Y and Z positions (3D Path or Separate Positions)
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• Angle (rotation)

• Skew

• X and Y Scales

• Euler Angle or Quaternion Angle (when 3D option is enabled)

• Z Scale (when 3D option is enabled)

Each parameter has its own function curve where you can add keyframes and control the easing. If you're not 
familiar with graphs and function curves, these are easy-to-use tools for visually controlling trajectories in the 
Camera and Timeline views.

By default, you can animate a drawing layer using the same parameters as a peg, but you can choose not to do so 
by turning off this feature. This allows you to switch your drawing layers so they can no longer be animated 
without a peg, which has certain advantages. In cut-out animation, it's easier to separate drawing exposure and 
keyframes to change the timing and rearrange keyframe position in the Timeline view. This also works for 
backward compatibility when bringing in templates created in older versions of Harmony so as not to lose their 
offset keyframes or drawing substitution keyframes.

If you do not want to animate a drawing layer, you can turn off its animation parameter. To do so, simply select 
the layer and in the Layer Properties view, deselect the Animate Using Animation Tools option on the Controls 
tab. If your layer was already animated, then your keyframes will appear dimmed so you can easily  identify them 
as ones that cannot be modified. To modify keyframes, select the Animate Using Animation Tools options.

A Peg layer is a trajectory that contains no drawings on which you can hook your drawings.
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Pegs have been used for a long time in the traditional animation process, mainly for registration purposes. Peg holes 
at the bottom or top of the animation paper are used to keep all the sheets even and at the same registration.

There are three peg holes in regular animation paper. The centre peg hole is round while the left and right ones are 
oval shaped. The oval peg holes are located on each side of the page, four inches away from the centre peg hole.

To keep the drawings together, the animator uses a peg bar. This peg bar has three pins that correspond to the 
shape and location of the peg holes. Peg bars are normally found at the bottom and top of animation discs.

Before digital compositing, the peg bars were also used to move layers on the camera stand to create pans and 
camera moves. They were the equivalent of digital trajectories. Harmony makes use of these concepts to create 
animation and camera motion. 

A peg is composed of many customizable parameters. These parameters are:

• X, Y and Z positions (3D Path or Separate Positions)

• Angle (rotation)

• Skew

• X and Y Scales

• Euler Angle or Quaternion Angle (when 3D option is enabled)

• Z Scale (when 3D option is enabled)

You can control a peg’s trajectory the same way as the animated drawing layer.

A peg layer is mainly used to control a series of drawing layers, such as clouds, a school of fish or a flock of birds. 
You can attach them to a peg layer and make them follow a trajectory as a single unit. This makes trajectory 
modifications much easier and faster. When building a puppet, most of the time you will add a master peg to control 
your puppet as one object.

In Harmony, you can add pegs to the Node view using the Node Library view and they will instantly appear in the 
Timeline view. The nodes you add to the Node view are synchronized with the ones in the Timeline view.
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In the Tool Properties view, the Peg Selection Mode  lets you automatically select the peg layers in the 
Camera view instead of the drawing layers. If you animate with pegs instead of animating the drawing layers 
directly, enable the Peg Selection Mode to avoid having to select in the Timeline view or use the Select Parent 
Skipping Effects command.

How to disable the animation feature on a layer

 1. In the Timeline view, double-click the layer on which you want to set the parameter.

The Layer Properties editor opens.

 2. In the Controls tab, deselect the Animate Using Animation Tools option.

How to add a peg in the Timeline view

 1. In the Timeline view, select the layer on which you want to attach a peg.

 2. Do one of the following: 

‣ From the Timeline View layers toolbar, click the Add Peg  button.

‣ From the Timeline view menu, select Insert > Peg.

‣ From the top menu, select Insert > Peg.

‣ In the Node Library, select a Peg node  and drag it to the Node view.

The layer that was originally selected becomes a child of the new parent Peg layer. The new Peg layer 
automatically takes the name of its child layer, with the addition of the suffix -P.

The indentation of the layer, along with the "L" indicates hierarchy and that the layer is attached to the Peg 
layer. This relationship is called a parent-child relationship.

 3. If you intend to add multiple pegs or if the layer name that was added to the peg does not accurately rep-
resent the content of the Peg layer, you can rename it. Click the layer name and type in a new name. Or 
double-click the layer and type a new name into the dialog box.

 4. If you did not create your peg layer directly above the layer you intended on parenting it to, then drag the 
layer you want to attach to the peg and drop it directly below the Peg layer. The indentation of the layer 
below the Peg layer indicates whether it was correctly attached or not.
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‣ You can unparent layers by holding down Shift and dragging the selected parents away from the child 
layer. Drop your selected between other layers.

How to add a peg in the Node view via the Node Library

 1. In the Node Library view, select the Move tab.

 2. Select a Peg node and drag it to the Node view.

 3. In the Node view, select the Peg node's output port and connect it to a Drawing or Camera node.

The advanced connections in the Node view are shown in the Timeline view, unless they cannot be 
reproduced in a timeline layout.
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How to add a peg to the Node view using a keyboard shortcut

 1. In the Node view, position the pointer at the location at which  you want to add the new peg node.

 2. Press Ctrl + P (Windows/Linux) or ⌘  + P (Mac OS X).

The new peg appears in the Node view.

How to create an automatic connection to a parent peg

‣ In the Node view, select one or more drawing nodes that are not parented to any other node.

‣ Press Ctrl + P (Windows/Linux) or ⌘  + P (Mac OS X) to add a new peg node to the Node view and 
automatically connect it to the selected nodes.

‣ Press Ctrl + Shift + P (Windows/Linux) or ⌘  + Shift + P (Mac OS X) to add a peg to each node.

How to enable the Peg Selection Mode

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 1. In the Tool Properties view, click the Peg Selection Mode  button.
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 2. In the Camera view, select an element parented to a peg.

 

Layer Parameters
A layer is composed of many customizable parameters, such as the X, Y and Z positions, angle (rotation), skew and 
scales. Each parameter has its own function which is a mathematical formula expressing the relationship between 
position values. You can view each function on a graph as a simple curve, such as the one below.

There are six options available for setting up function parameters:

‣ Locked Positions (3D Path)

‣ Separate Positions

‣ Locked Scales

‣ Separate Scales

‣ Quaternion (3D Rotation)

‣ Euler Angles (3D Rotation)
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You must select 3D Path, Separate Positions, Separate Scale, or Locked Scale before starting the animation. 
When you lock or unlock parameters, this does not convert the functions from one to the other, but creates new 
ones.

In a 3D Path, the X, Y and Z curves are locked together and controlled by a single velocity function. When you 
add a keyframe, it is added on all three trajectories at once, as is the velocity. This is very useful for long, smooth 
trajectories.

When the Separate Positions option is used, the X, Y and Z curves are independent and have velocity controls 
directly on their function curve. This is useful when you want to set keyframes on one of the curves without 
affecting the others.
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When using the Scale parameter, you can use a single function curve to control both the vertical and horizontal 
scale, or two separate scales. When using a single function curve, the values are the same for the X (horizontal) and 
Y (vertical) axes for uniform size changes without distortion. However, if you separate the scale functions, you can 
squash, stretch and skew your elements.

How to display the layer parameters in the Timeline view

 1. Do one of the following:

‣ In the Timeline’s left side, click a layer's Expand  button. 

‣ In the Timeline view menu, select View > Show Functions.

‣ Press Alt + F. 

How to set the layer parameters

 1. In the Timeline view, double-click on the layer on which you want to set the parameter. You can also see the 
parameters in the Layer Properties window when you select the layer in the Timeline view.

The Layer Properties window opens.
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 2. Select the Transformation tab.

 3. In the Position section, select the 3D Path or Separate option.

 4. In the Scale section, select the Locked or Separate option.

 5. Click Close.

Adding and Deleting Keyframes
There are several different ways you can create keyframes. You can add a coordinate keyframe, position 
keyframe or a keyframe along with your drawing duplication.

You can create a keyframe without a drawing. This adds new coordinate points but the drawing in the layer stays 
the same. At the same time, you may also want to duplicate your drawing if you need to modify it and do not want 
to modify the original.

You can also add a position keyframe instead of a regular keyframe. When you do this, keyframes will only be 
added on the X, Y and Z parameters of the selected layer. Keyframes are not added on the Angle, Scale and 
Skew parameters.

NOTE: If you select a keyframe in the Timeline view and press the Delete key, you will also delete the drawing 
exposure. To only delete the keyframe, you must use the Delete Keyframe command—see Adding and Deleting 
Keyframes on page 248.

248



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

How to create keyframes

 1. In the Timeline view, select the cell on which you want to add a keyframe.

 2. Add a keyframe  by doing one of the following:

‣ From the top menu, select Insert > Keyframe.

‣ Right-click  on the selection and select Insert Keyframe.

‣ Press F6.

‣ In the Timeline View toolbar, click the Add Keyframe  button.

If the Animate mode is enabled in the Camera view,  a keyframe is automatically created on the current frame.

How to create a keyframe and duplicate the drawing at the same time

 1. In the Timeline view, select the cell containing the drawing you want to duplicate and add a keyframe.

 2. Do one of the following:

‣ From the top menu, select Insert > Keyframe and Duplicate Drawing.

‣ Right-click on the selection and select Insert Keyframe and Duplicate Drawing.

‣ Press F6.

A keyframe and a duplicate of the drawing is created. The duplicated drawing sits on top of the original 
drawing.

How to add a Position keyframe

 1. In the Timeline view, select the cell on which you want to add a position keyframe.

 2. From the top menu, select Insert > Position Keyframe.
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How to delete a keyframe

‣ In the Timeline view, select a keyframe and do one of the following:

Right-click and select Delete Keyframes. 

In the Timeline view menu, select Motion > Delete Keyframes.

From the top menu, select Animation > Delete Keyframe.

Press F7.

‣ Use the Transform  tool to select a keyframe to delete from the trajectory in the Camera view and 
press Delete.

Motion and Stop-motion Keyframes
Interpolation is the computer-generated motion between two keyframes. Some animators and compositors like to 
create their own in-betweens, while others like to have the computer do it. Harmony has stop-motion (no 
interpolation) and motion keyframes (computer-generated interpolation).

In stop-motion keyframes, there is no computer-generated motion between two keyframes. The segment is 
constant or flat. The drawing remains still until the playback reaches the next keyframe, then the drawing pops to 
its new location.

In motion keyframes, there is no automatic interpolation created between the selected point and the next one. The 
layer will maintain its position until the animation reaches the frame of the next point and will then jump to the new 
position. Deselect this option to generate interpolation and get the layer to progressively move to the next 
position.
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You can switch a keyframe from stop-motion to motion at any time in the Timeline view and Function Editor.

To easily identify stop-motion keyframes in the Timeline view, you can customize the colour In the Preferences 
dialog box.

How to switch between motion and stop-motion in the Timeline view

 1. On the right side of the Timeline view, select one or more keyframes to modify.

 2. Switch between motion and stop-motion by doing one of the following:

‣ Right-click on the selected keyframes and select Set Motion Keyframes or Set Stop-Motion 
Keyframes.

‣ Press Ctrl + K (Windows/Linux) or ⌘  + K (Mac OS X) for motion keyframes and Ctrl + L (Windows/Linux) 
or ⌘  + L (Mac OS X) for stop-motion keyframes.

‣ In the Timeline View toolbar, click the Motion Keyframe  or Stop-Motion Keyframe  button.

How to switch between motion and stop-motion in the Coordinates and Control Points view

 1. Using the Transform  tool, in the visible path in the Camera or Timeline view, select the keyframe to con-
vert.

 2. In the Coordinates and Control Point view, select/deselect the Stop-Motion Keyframe option.
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How to switch between motion and stop-motion keyframes in the Function view

 1. Open the Function view.

 2. In the Timeline view, double-click on the layer that contains the keyframes you want to convert.

The Layer Properties window opens.

 3. Do one of the following:

‣ In the Transformation tab, click the Function Editor  button.

‣ In the Timeline view, click the Expand Function  button or press Alt + F and double-click on the 
function to edit.

 4. On the function curve, select one or more keyframes to modify.
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 5. Select or deselect the Stop-motion Keyframe  button to set a stop-motion or motion keyframe.

How to set the stop-motion keyframe colour

 1. Open the Preferences dialog box by pressing Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

 2. Select the General tab. 

 3. In the Colours section, click Edit Colours.

 4. In the Colours dialog box, select the Xsheet and Timeline tab.

 5. In the Timeline section, click the  Stop Motion Keyframe swatch.

 6. In the Select Colour window, select a new colour and close the windows.
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Constant Z

When using a 3D path, the X, Y and Z functions work together using the same keyframes. This allows for the 
velocity to control the curve and create a smooth trajectory. Even if a function does not have any variation on its 
curve (for example, all keyframes are at zero), the velocity might add a slight motion to ensure a smooth 
trajectory. This can cause elements that are very close to each other on the Z-axis to pop in front of one another. 
This is why in cut-out animation it is recommended to use separate position settings. But if you work with 3D 
path, you can use the Constant Z feature to avoid this from happening.

The Constant Z feature is used when creating motion keyframes. The Z function will use stop-motion keyframes 
and will not be interpolated, which can be very useful for cut-out animation. The Constant Z feature only works 
with 3D paths.

You can also enable the Constant Z option directly in the Function view for specific functions.

How to enable the Constant Z option

 1. In the Timeline view, expand the layer on which you want to set the Constant Z feature. Note that you 
must select the 3D Path option for the layer.

 2. Double-click on one of the position functions to open the Function editor.

 3. In the Function editor, select the Constant Z  button.

Animating the Camera
In Harmony is a camera that can move along the X, Y, and Z axes. Having the camera move on the Z-axis offers 
the possibility to create truck in and truck outs, as well as multiplane camera moves. The default camera position 
is centred and backed up to 12 fields.
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It is important to understand the coordinate values in Harmony. Harmony's core is based on the origins of animation. 
In traditional animation, a scene's size and camera motion are calculated in fields. A field has a 4:3 ratio and 
measures 0.5 inches (12.7 mm) in width. A specific grid has been created for this purpose known as a field chart. 
Harmony uses this unit of measurement as its coordinate system.

A field chart uses the cardinal directions. The X axis is the east-west (left-right) direction, the Y axis is the north-
south (up-down) direction and the Z axis is the forward-backward direction.

The camera is treated the same way as any other element. You can use the same tools and selection modes to 
offset or animate it, but the camera is a static object. To animate the camera, you need to connect it to a peg layer. A 
peg is a trajectory layer.

While making camera moves, you can use the Top, Side, and Camera views.

How to open the Top and Side views

 1. Do one of the following:

‣ From the top menu, select Windows > Top or Side.
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‣ From any view already open, click the Add View  button at the top-right corner and select Top or 
Side.

How to add a camera and parent it to a peg

 1. If you don't already have a camera layer, do one of the following: 

‣ From the top menu, select Insert > Camera.

‣ From the Layers toolbar, click the Add Layers  button and select Camera.

‣ From  the Node Library view, select a Camera node and drag it to the Node view.

A new camera layer is added to the scene and appears in the Timeline view.

 2. In the Timeline view, select the Camera layer.

 3. From the Layers toolbar, click the Add Peg  button.

A Peg layer appears directly above the Camera layer, which is automatically attached to it. 

The Peg layer automatically takes the name of the camera and adds the suffix -P to indicate that it is a 
Peg layer, for example Camera-P.

If the new Peg layer did not appear directly above the camera, you may have clicked elsewhere in the 
scene, which deactivated the layer on which you want to add the Peg layer. To fix this:

‣ Select the Camera layer and drag and drop it under the new Peg layer. Or delete the misplaced Peg 
layer, select the Camera layer and click the Add Peg  button again.

‣ From the Node Library view, select a Peg node and drag it to the Node view. Then connect the peg’s 
output port to the camera’s input port.

You can also press Ctrl + P (Windows/Linux) or  ⌘  + P (Mac OS X) to create a peg and connect it to 
the camera, or select the Camera node and press Ctrl + P (Windows/Linux) or  ⌘  + P (Mac OS X) to 
create a peg. 

256



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

‣ You can unparent layers by holding down Shift and dragging the selected parents away from the child 
layer. Drop your selected between other layers.

How to animate the camera

 1. In the Tools toolbar, enable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. On the right side of the Timeline view, on the Camera Peg layer, select  the frame at which you want the cam-
era move to start.

 4. Do one of the following:

‣ In the Timeline toolbar, click the Add Keyframe  button.

‣ Right-click and select Insert Keyframe.

‣ Press F6.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera 
position as this keyframe.

 5. In the Top, Side or Camera view, select the camera (the large V-shaped cone) and move it to the desired pos-
ition. In the Camera view, the camera is represented by a thin frame. You need to click directly on one of the 
edges.
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 6. On the Timeline view, click on another cell a bit further down in time to indicate where the camera move 
will end.

 7. Select the camera in the Camera, Top or Side view and move it to the desired position. 

A second keyframe appears and a line is created between the two frames to indicate that the subsequent 
motion between the frames will be calculated and rendered by the program.

 8. Play back  your animation.

Animating a Camera Shake Using the Quake Node

One very common camera move you will do is a camera shake. You can use the Quake node to generate an 
automated quake instead of manually entering random keyframes. This way, you can simulate the shock of 
something heavy falling on the ground, like an earthquake or a strong vibration.

How to use the Quake node to create a camera shake

 1. From the Node Library view, drag a Quake node to the Node view.

 2. If you do not have a Camera node already, drag one from the Node Library view to the Node view.

 3. Connect the Quake node to the Camera node.
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 4. Click the Quake node's yellow square properties button to open the Quake properties.

 5. In the Quake properties window, adjust the following parameters:

‣ Hold Time: Enter the number of frames you want one of the quake vibrations (position) to hold for. Most 
camera shakes are done in a single frame (1) or double frame (2).

‣ Interpolate: An interpolation is generated between the random values. Instead of jumping to the next 
position, it will slowly progress forwards to the next position. It's the same principle as stop-motion 
keyframes and motion keyframes.

‣ Move Amplitude: This is the strength of the quake. The higher the value, the stronger the quake. If the 
value is set to 0, there is no  motion. To have the motion start and stop at a specific frame during the 
scene, you can create a function curve and animate the amplitude over time. Simply click the Function 
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 button to generate the function, then click on it again to open the Function Editor.

‣ Apply on X, Y, Z: Applies the quake to the X, Y and Z-axis.

‣ Rotation Amplitude: When the value is higher than 0, a rotating quake is applied. The higher the value, 
the stronger the quake.

‣ Random Seed: Generates a different randomization pattern. If you cascade two Quake nodes or more 
to apply a different amplitude on a different axis, you can change the Random Seed value to generate a 
different randomization pattern. If the X quake has a strong amplitude and the Y quake a weak 
amplitude and you do not want them to follow the same random pattern, then set the Random Seed 
value of the Quake nodes to different numbers.

Camera Truck-ins and Line Thickness

As you move the camera in your scene along the Z-axis, notice that, logically, the lines of the elements become 
thicker the closer the camera gets to the drawing. If you prefer the lines to remain the same size or become 
thicker at a different speed, you can use the thickness feature to adjust your brush stroke and pencil line 
thickness. You can modify the size of the lines even if the camera is not animated.

NOTE: This feature can only be viewed in the Camera view's render mode.
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How to adjust the pencil line thickness of a drawing layer in the Camera view

 1. In the Timeline view, double-click on a drawing layer to display the Layer Properties window.

 2. Select the Advanced tab.

 3. In the Line Thickness section, adjust some of the following parameters until you achieve the desired effect.

Adjust Pencil Lines Thickness: Lets you work with pencil lines and adjust their thickness. You will 
not see any changes to lines in the Camera view OpenGL mode. You must switch to the Render 
mode.

Normal Thickness: Disables all overrides on the brush stroke line thickness. This option must be 
enabled in order for the pencil line thickness parameter and pencil lines to appear. If you want to 
modify the brush stroke thickness, deselect this option. To enable brush strokes to work with the line 
thickness feature, you must first create central strokes in the Colour Art layer. The central strokes 
control the line variation of your brush strokes in the Line Art layer. Select Drawing > Create Colour 
Art from Line Art.

Zoom Independent Thickness: Select this if you want your line thickness to remain constant 
independently from the camera move. Everything else will increase in size, but the line thickness will 
stay the same.

Proportional: Enter a multiple by which you want to increase the line thickness base on its original 
thickness. A value of 1 will result in no change; a value of 0 (zero) will hide the lines.

Constant:  Enter a value in pixels (based on a 720x540 screen resolution) to indicate the amount of 
pixels you want to add around the existing line.

Minimum: Enter a value in pixels (based on a 720x540 screen resolution) for the minimum line 
thickness allowed.

Maximum: Enter a value in pixels (based on a 720x540 screen resolution) for the maximum line 
thickness allowed.

Modifying a Path in the Camera, Top and Side Views
Camera moves and motion paths can become quite advanced, especially with moves through 3D space. Harmony 
provides tools to view your camera’s path and make adjustments to it from both a 2D and 3D perspective.

You can display the trajectory of a motion path when you select an object in the Timeline or Camera view.

A motion path is easy to manipulate. One important concept to understand is that a trajectory contains both 
keyframes and control points. Both can be used to shape a path; each have their own significance and behaviour, 
however only keyframes appear in the Timeline view. 

• Keyframes have a transformation value and a position in space at a given frame. Keyframes are locked in 
time.
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• Control points have a position but no fixed frame or timing. It is mainly used to deform a trajectory. There 
are no velocity handles available on a control point. The velocity segments are set between keyframes 
only, making curves and trajectories much smoother. Control points can only be added on a 3D path.

You can edit keyframes and control point parameters, such as the position, continuity, bias, tension and lock-in-
time using the Coordinates and Control Points view. 

Each time you select a keyframe or control point in the Camera, Timeline or Xsheet view, its parameters appear 
in the Coordinates and Control Point view. You can also see the same information in the Coordinates and Control 
Points toolbar.

You can adjust these parameters by selecting the control points and keyframes in the Camera, Top and Side 
views with the Transform  tool.

You can set the default Continuity, Bias and Tension parameters in the Preferences panel.

Continuity: Controls the smoothness of a transition between the segments joined by a point.
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Tension: Controls how sharply the path bends as it passes through a control point or keyframe.

Bias: Controls the slope of the path so it flows towards one side of the motion point or the other.

When you select a control point on a path, you can switch between a rounded or square corner by using the 
Linear/Curve command. 

How to view the layer’s trajectory using the Control command

 1. Verify that the Camera view (click its tab) is selected and that the layer whose trajectory you want to display 
is selected in the Timeline view.
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 2. From the top menu, select View > Show > Control or press Shift + F11.

NOTE: If nothing appears in the Camera view, you may not have animated or selected the layer.

How to add a control point on a trajectory

 1. In the Timeline or Camera view, select the peg or layer on which you want to add a control point.

 2. If the selected element’s trajectory is not displayed, select View > Show > Control from the top menu or 
press Shift + F11.

The trajectory appears in the Camera, Top, Side and Perspective views.
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 3. Add control points on a 3D path trajectory by placing the cursor where you want to add the point and press P 
once. If you hold the key down, control points will be added continuously until you release the key.

How to switch between keyframe and control point

 1. In the Camera view, use the Transform  tool select a point to convert.

 2. To convert the point:

‣ In the Coordinates and Control Points view, select or deselect the Locked in Time option.

‣ From the top menu, select Animation > Lock in Time.
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‣ In the Function view or Function Editor, select the keyframe to convert and click the Lock in Time  
button.

‣ Press Alt+L.

How to adjust the Continuity, Tension and Bias parameters

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Timeline view, select the layer that contains the parameters you want to adjust.

 3. From the top menu, select View > Show > Control  or press Shift + F11 to display the trajectory.

 4. In the Camera view, select a control point or keyframe.

 5. In the Coordinates and Control Points view, adjust the Continuity, Tension and Bias parameters.
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How to adjust the control point preferences

 1. From the top menu, select Edit > Preferences (Windows) or Stage Premium > Preferences (Mac OS X).

The Preferences dialog box opens.

 2. Select the Camera tab and adjust the parameters in the Control Points section.

How to toggle between a linear and curved corner

 1. In the Timeline view, double-click the layer that contains the point you want to convert.

The Layer Properties window opens.

 2. On the Transformation tab, select the 3D Path option.

 3. In the Tools toolbar, select the Transform  tool or press Shift + T.

 4. In the Camera view, select the point to convert.

 5. From the top menu, select Animation > Linear Motion.

Offsetting a Trajectory

By offsetting a trajectory, you reposition the visual trajectory without offsetting or modifying your animation. By 
default, the trajectory is located at 0,0,0 fields. If your elements were drawn in a different location than the centre of 
the drawing area, it will look like the trajectory is not aligned with your drawing. Also, if you have several elements 
attached to one trajectory, you might want your trajectory to be at a different location to represent the group's motion 
better.

How to offset a trajectory

 1. In the Animation Tools toolbar, select the Spline Offset  tool or press Alt + 8.
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 2. In the Camera, Top, Side or Timeline view, select the layer whose trajectory you want to offset.

 3. From the top menu, select View > Show > Control to display the trajectory. If you do not display the tra-
jectory, any transformation done using the Spline Offset tool will be ignored.

 4. In the Camera view, drag the trajectory to the proper position. You can move it on the X and Y axes, but 
also on the Z-axis using the Top and Side views.

Modifying a Path in the Timeline View
When you select a peg or drawing layer in the Camera view and move it around, Harmony will automatically 
create keyframes on the corresponding function curves. If you want to modify these curves, you can do it through 
the peg or drawing layer parameters in the Timeline view.

Harmony lets you also flip between the selected layer's keyframes in the Timeline view.
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 How to create the function curve in the Timeline view

 1. In the Timeline view, expand the layer's parameters.

 2. Click the Function button and, in the drop-down menu, select Create Bezier or Create Ease.

 How to add a keyframe in the Timeline view

 1. On the right side of the Timeline view, select a cell on the layer’s function that you want to animate.

 2. Do one of the following:

‣ Right-click the selected cell and select Insert Keyframe.

‣ Press F6.

‣ In the Timeline View menu, select Motion > Insert Keyframe.

‣ In the Timeline View toolbar, click the Add Keyframe  button.

How to delete a keyframe in the Timeline view

 1. On the right side of the Timeline, select a keyframe to delete. You can [Shift]+click several keyframes to 
select a group before deleting the keyframes. 

 2. Do one of the following:

‣ Right-click on the selected keyframe and select Delete Keyframes.

‣ Press F7.

‣ In the Timeline View menu, select Motion > Delete Keyframes.

‣ In the Timeline View toolbar, click on the Delete Keyframes  button.
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NOTE: If you select a keyframe or group of keyframes and press Delete, the corresponding drawings on that cell 
are also deleted.

How to change the keyframe values in the Timeline view

1. In the Timeline view, open the drawing or layer’s parameters by clicking the Expand  button or press Alt 
+ F. 

2. Select the parameter for which you want to create a function curve.

 1. Place the cursor over the blue number value of the parameter and do one of the following:

‣ Wait until the cursor changes to a white hand with a two-way arrow and then drag the hand left to 
decrease the value or right to increase the value.

‣ Double-click on the blue number and enter a value in the field.

How to flip through keyframes

 1. In the Camera or Timeline view, select the layer that contains the keyframes you want to flip through.

 2. From the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe or press 
semicolon (;) and single quote (').

Modifying a Path in the Function View
If you are accustomed to using graphs and function curves, you can use the Function view to define trajectories.
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The graph in the Function view displays the motion over the first and last keyframes set in the scene, as well as any 
keyframes created between. If the scene is 60 frames, but the character's motion ends at frame 40, then the editor 
will only display up to frame 40.

The Function view lets you edit function curves and parameters. It is a visual graph for adding, removing, and editing 
keyframes, as well as adjusting the velocity. The Function view allows you to display multiple functions in the 
background as a reference.

How to display functions in the Function view

 1. Open the Function view.

The Function view is blank until you select the layer containing the functions you want to display.

 2. To display a function in the Function view, click on the layer containing the functions to adjust in the Timeline 
view.

 3. To select the functions you want to edit, select them in the Function list.

 

Parameter Description

Function List
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When selecting a layer in the Timeline view, all the corresponding functions are 
displayed. Select all the functions you want to see and edit; hide the ones you 
don't.

Display Toolbar

The Display toolbar allows you to modify how the editing area is displayed. You 
can hide the grid, disable the synchronization with the current frame, reset the 
zoom level and normalize the function display by stacking them one over the 
other to compare them regardless of their value range.

Current Frame Displays the current scene frame.

Selected Keyframe Value Displays the value of the selected keyframe.

Display Advanced Parameter 
Values

Displays the Projection, Bias, Tension and Continuity parameters to adjust the 
curve around the selected keyframe.

Keyframe, Velocity and Inter-
polation Options

This toolbar lets you add and delete keyframes, adjust the velocity curve, adjust 
the segments to motion or stop-motion keyframes and set the velocity to create 
steps instead of a constant progression.

Function Types
This toolbar lets you click on the different function types to enable or disable all 
the listed functions of that type.

Value Scale
Displays the value range for the displayed editing area. It can be referenced to 
know the value of a keyframe.

Selected Keyframe
The selected keyframe is displayed in red. When selected, the keyframe values 
are displayed in the corresponding fields.

Bezier Handles
The Bezier handles let you adjust the ease in and ease out of each keyframe. The 
more the handle is pulled out horizontally, the slower the animation will be. The 
more the handle is pulled out vertically, the faster the animation will be.

Function Curve
The thin line going from keyframe to keyframe is the actual curve. The section of 
a curve located between two keyframes is called a segment.

Frame Scale
The Frame Scale displays the frame range for the displayed editing area. It can be 
referenced to know the current frame of a keyframe.

How to edit a function in the Function view

 1. In the graph of the Function editor, select a white keyframe. 

The keyframe turns red and displays a pointed yellow handle.

 2. Drag the point up or down, or click and pull one of the handles to adjust the curve of the graph.
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In the example above, changing the velocity from a straight line (constant velocity) to a curved one changes 
the ease-in (where the curve shoots up and then flattens out) and ease-out (where the curve flattens out and 
then shoots up) values.

The centre keyframe cannot be dragged up or down because the velocity is set. Theoretically, dragging it 
downwards towards zero would put it back to a place of nonmovement.

 3. Press the Enter/Return key with the editor still open to watch the result of your curve adjustment in the Cam-
era view.

How to add or delete keyframes in the Function editor

1. In the Timeline view, open the drawing or layer’s parameters by clicking the Expand  button or press Alt + F. 

 1. Double-click on the parameter layer name to open the Function editor window or click once on the parameter 
layer to display it in the Function view.
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 2. Do one of the following:

‣ In the graph section, click on the frame number where you want to make changes.

‣ In the Frame field, enter the frame number.

In the graph, the vertical red line moves to the frame number.

 3. Do one of the following:

‣ In the Function editor, click the Add/Remove Keyframes  button. 

‣ In the Function view, click the Add Keyframe  and Delete keyframe  buttons.

 4. Click on the newly created keyframe and drag it up (to decrease the width of the object) or down (to 
increase the width of the object) or pull on the handles to create a smooth fluctuation of the drawing 
object's width.

 5. If you do not like the changes you just made, select and delete the new keyframe by pressing  Delete or 
clicking the Add/Remove Keyframes  button.

You can delete an existing keyframe by using the same process.

How to change a keyframe value in the Function view

 1. In the Timeline view, open the peg element's parameters by clicking the Plus  sign next the peg layer's 
name.
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 2. Double-click on the parameter layer name to open the Editor window or click once on the parameter layer to 
display it in the Function view.

 3. In the Value field, enter a value. You can also drag the keyframe up or down in the graph. 

 4. Press Enter/Return or click the Play  button to view the changes made in the Camera view.

 5. Keep adjusting the values until you're satisfied with the results.

 6. Click Close.

Function View

The Function view lets you edit function curves and parameters. It is a visual graph for adding, removing, and editing 
keyframes, as well as adjusting the velocity. The Function view allows you to display multiple functions in the 
background as a reference.
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How to display functions in the Function view

 1. Open the Function view.

The Function view is blank until you select the layer containing the functions you want to display.

 2. To display a function in the Function view, click on the layer containing the functions to adjust in the 
Timeline view.

 3. To select the functions you want to edit, select them in the Function list.

 

Parameter Description

Function List

When selecting a layer in the Timeline view, all the corresponding functions are 
displayed. Select all the functions you want to see and edit; hide the ones you 
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don't.

Display Toolbar

The Display toolbar allows you to modify how the editing area is displayed. 
You can hide the grid, disable the synchronization with the current frame, reset 
the zoom level and normalize the function display by stacking them one over 
the other to compare them regardless of their value range.

Current Frame Displays the current scene frame.

Selected Keyframe Value Displays the value of the selected keyframe.

Display Advanced Parameter 
Values

Displays the Projection, Bias, Tension and Continuity parameters to adjust the 
curve around the selected keyframe.

Keyframe, Velocity and Inter-
polation Options

This toolbar lets you add and delete keyframes, adjust the velocity curve, 
adjust the segments to motion or stop-motion keyframes and set the velocity 
to create steps instead of a constant progression.

Function Types
This toolbar lets you click on the different function types to enable or disable all 
the listed functions of that type.

Value Scale
Displays the value range for the displayed editing area. It can be referenced to 
know the value of a keyframe.

Selected Keyframe
The selected keyframe is displayed in red. When selected, the keyframe val-
ues are displayed in the corresponding fields.

Bezier Handles
The Bezier handles let you adjust the ease in and ease out of each keyframe. 
The more the handle is pulled out horizontally, the slower the animation will be. 
The more the handle is pulled out vertically, the faster the animation will be.

Function Curve
The thin line going from keyframe to keyframe is the actual curve. The section 
of a curve located between two keyframes is called a segment.

Frame Scale
The Frame Scale displays the frame range for the displayed editing area. It can 
be referenced to know the current frame of a keyframe.

Modifying a Path in the Xsheet View
If you are prefer working with the Xsheet view, you can also create keyframes and type values in the Xsheet view.

You cannot create function curves directly in the Xsheet view. You must do this in the Layer Properties window or 
the Timeline view.

To edit a function column in the Xsheet view, you must first display the Functions section of the Xsheet view and 
then select the layer you want to modify. If you double-click on a function column's header, you will display the 
corresponding function curve in the Function editor.

How to display the function columns in the Xsheet view

 1. In the Xsheet view, click the Expand button located on the right side of the main section to show the Func-
tions section. 
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 2. In the Timeline view, select the layer that contains the parameters to modify.

The columns appear in the Xsheet view if function curves were previously created by adding keyframes in 
the Xsheet view or Layer Properties window. Otherwise, the columns do not appear.

How to add a keyframe in the Xsheet view

 1. In the Xsheet view, go to the function column on which you want to add a keyframe.

 2. Double-click on the cell on which you want to add a keyframe and type a numeric value.

 3. Press Enter/Return to continue to the next cell.

 4. Press Esc to exit the typing mode.
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How to convert a cell into a keyframe

 1. In the Xsheet view, go to the function column on which you want to add a keyframe.

 2. Select the cell to convert.

 3. Right-click on the cell and select Set Selection As Keyframe or press F6.

 4. To remove a keyframe, select the keyframe, right-click on the cell and select Clear Keyframe in Selection 
or press F7.

Function Curves
By default, when a drawing layer or peg is added to a scene, no function curves are created. You will generally 
create the ones you need to avoid being overloaded with too many functions you might not use.
When you select an element in the Camera view and move it around, it will automatically create the corresponding 
function curves. If you need to create certain functions manually, you can always do it through the Layer Properties 
view or editor.  You can then share it with other layer parameters or set keyframes directly on the function curve 
instead of doing it in the Timeline or Camera view.
You can also link a layer's parameter to an existing function curve or attach several parameters to the same function 
curve. For example, if you have an aircraft performing loops between clouds, you may want the camera to follow the 
aircraft's motion path. If you attach the camera to the aircraft's layer, the camera will also loop, but this may produce 
undesirable results and even induce a feeling of motion sickness as you watch the final animation. Instead, you can 
share the X, Y and Z positions of the aircraft with the camera's peg layer, but ignore the angle, scale and skew. 

By default, all function curves can only be used and modified using their original parameter. If you want another layer 
or parameter to use the same function curve, you must share it.

There are two ways to share a function:

• Share Functions command

• Layer Properties editor

When you create a function curve in the Layer Properties view or editor, there are several choices available:
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Parameter Description

Create 3D Path Creates a new 3D Path Column set

Create Bezier Creates a new Bezier curve

Create Ease Creates a new Ease curve

Local Disconnects the parameter from any function and changes it to shared.

3D Path Displays the list of every shared 3D Path function available

Bezier Displays the list of every shared Bezier curve available

Ease Displays the list of every shared Ease curve available

Velobased Displays the list of every shared velocity based curve available

Expression Displays the list of every shared Expression function available

3D Rotation Displays the list of every shared 3D Rotation function available

Connected Displays the list of every shared connected function curve

Unconnected Displays the list of every shared unconnected function curve

All Displays the list of every shared function curve

You have the choice of creating a new function curve or linking it to a shared function. This way, you can have 
two or more parameters following the same function.

Depending on your favourite working method, you can create different types of function curves to suit your needs, 
including: 

• Ease function

• Bezier function

• Velobased function

When you create a function to control a parameter over time (Scale, X, Y, Z, Rotate), you have the choice of an 
Ease or Bezier function.
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These function editors present different ways of editing the values over time. The shape of the created graph 
indicates the velocity of the function, regardless of the chosen editor. The type of function that you choose is largely 
based on your working preference. 
With the Ease editor, you can edit the shape of the function curves using the ease-in and ease-out controls.
You can also create Velobased functions for certain effects, like changes in rotation or size over time. When you do 
this, the Velobased functions are linked to the velocity of a 3D path. You cannot change the shape of a Velobased 
function to control its velocity.
With Velobased functions, you can link changes in rotation or scaling to the velocity of a 3D path. This makes it 
possible for changes in rotation or scaling to progress at the same speed as changes to the position of an element.

You can convert Ease and Bezier function so you can edit them  using the controls offered by that type of function. 

How to create function curves

 1. In the Timeline view, double-click on a layer.

The Layer Properties Editor opens.
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 2. In the Transformation tab, click the Function Arrow button beside the local function information.

 3. Create a 3D Path, Bezier, Ease or Velobased curve. You can also create an Expression column—see 
Expression Columns on page 300.

You can click the Function  button to open the Function editor.

How to share a function using the Share Functions command

 1. In the Timeline view, select the function layer to share.

 2. Right-click  and select Share Functions.

The function is shared with the other layers and parameters.
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Shared functions are visible in the main section of the Xsheet view.

 3. In the Timeline view, double-click on the layer that contains the parameters you want to link to the shared 
function.

The Layer Properties Editor opens.

 4. In the Transformation tab, click the Function Arrow  button beside the function you want to link to the func-
tion column.

 5. From the menu, select the function you just shared from the 3D Path, Bezier, Ease, Velobased, Expression, 
Connected, Unconnected, or All menu and attach it to your parameter.

The two parameters are both linked to the same function curve and should follow the same path. If you 
modify the curve, both parameters will update.

How to share a function using the Layer Properties editor

 1. In the Timeline view, double-click on the layer that contains the function to share.
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The Layer Properties window displays.

 2. In the Transformation tab, click the Arrow  button beside the function you want to share and select Local.

The function is shared with the other layers and parameters.

Shared functions are visible in the main section of the Xsheet view.

 3. From the same menu in which you chose the Bezier option (in our example), select the function you just 
shared and attach it to your parameter.
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 4. In the Timeline view, open the Layer Properties editor of the other layer that contains the parameters you 
want to link to the shared function.

 5. In the Layer Properties editor or view, attach the parameter to the shared function the same way you did for 
the first layer.

The two parameters are both linked to the same function curve and follow the same path. If you modify the 
curve, both parameters will update.

How to convert Ease and Bezier functions

 1. In the Xsheet view, show the function columns.

 2. In the Xsheet view, click the Expand button located on the right side of the main section to show the Func-
tions section. Click on the same button to collapse it. You can also use the Show Column List  button in 
the Xsheet View toolbar.

 3. On the right side of the Functions section, click the Expand button to display the Column List section.
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 4. In the Timeline view, click the layer that contains you function columns you want to display.

 5. In the Xsheet view, right-click on the column header, select Convert and one of the following:

‣ Convert the Column: The values of multiple effects may be linked to the original column. When you 
use the Convert the Column command, all links to the original column will transfer to the new 
converted column.

‣ Create a New Column and Update Links: Creates a new function from the original. All links to the 
original column will transfer to the new column. The original function column will remain in the exposure 
sheet in case you decide you want to switch back to it.

‣ Create a New Unused Column: Creates a new column based on the values in the original column 
and leaves all links pointing to the original column. You can use this command to experiment with 
various functions and then link effect values to the new function curve column.

Copying and Pasting a Motion
In the Timeline view, you can easily drag keyframes to change the animation timing, delete them, cycle them and 
even copy them.

As you animate, you will find that you reuse many positions, drawings, and keys. However, you may only want to 
paste the drawings or just the keys or maybe everything. There are different paste options available in the 
Timeline view which give you maximum flexibility when reusing and pasting.

Note that these modes also apply when you drag instead of copying and pasting.

There are three different modes for pasting your selection:

•  Paste Mode: All Drawing Attributes: Pastes the drawing exposure and keyframes.

•  Paste Mode: Keyframes Only: Pastes only the keyframes.

•   Paste Mode: Exposures Only: Pastes only the drawing exposure.

When you have position keyframes set in your drawing layer and you want to move them around when moving 
your drawing's timing, you can use the Paste Special feature to only move selected keyframes.

You can also use the Paste Cycle and Paste Reverse feature to cycle your selection including keyframes and 
drawings.

If you want to cycle a portion of your animation, you can use the Paste Cycle command. You can also use the 
Paste Reverse command to completely reverse the flow of your animation.
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How to copy and paste a motion using Paste Special

 1. In the Timeline view, select the keyframes to copy and paste. If you want to move the keyframes, go to step 
3.

 2. From the top menu, select Edit > Copy Cells from the Timeline or press Ctrl + C (Windows/Linux) or ⌘  + C 
(Mac OS X).

 3. Edit your selection by doing the following:

‣ To paste the selection, in the Timeline view, select the first cell on which you want to paste your 
keyframes and from the top menu, select Edit > Paste Special or press Ctrl + B (Windows/Linux) or ⌘  + 
B (Mac OS X).

‣ To move the selection, in the Timeline view, drag the selection and hold down Alt (Windows/Linux) or ⌘  
(Mac OS X). Drop the selection where you need it and release the hot key.

The Paste Special window opens.

 4. Set the Drawing, Pegs and Functions, and Cycles parameters. 

 5. Click OK.

How to open the Paste Special dialog box

 1. In the Library view, select the symbol or template to import.

 2. While dragging the selection to the Timeline view, hold down the Alt (Windows/Linux) or ⌘  (Mac OS X). Drop 
the selection in the Timeline view before releasing the hot key.

The Paste Special window opens.

 3. Set the parameters.
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How to cycle a portion of an animation

 1. In the Xsheet or Timeline view, select the cell range and keyframes to loop.

 2. From the top menu, select Edit > Copy Cells from the Xsheet/Timeline.

 3. In the Xsheet or Timeline view, select the cell on which you want the cycles to start.

 4. From the top menu, select Edit > Paste Cycle or press Ctrl + / (Windows/Linux) or ⌘  + / (Mac OS X).

The Paste Cycle dialog box opens.
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 5. In the Number of Cycles field, increase or decrease the number of cycles you want to paste.

 6. In the Cycle Type, select the type of cycle to paste.

‣ Normal (forward): Pastes your selection as it is, starting with the first cell and ending with the last.

‣ Reverse: Pastes your selection reversed, starting with the last cell and ending with the first.

‣ Forward > Reverse: Pastes your selection as a yo-yo, starting with the first cell, going to the last one 
and ending with the first cell.

‣ Reverse > Forward: Pastes your selection as a reversed yo-yo, starting with the last cell, going to the 
first one and ending with the last cell.

How to reverse the animation flow

 1. In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.

 2. From the top menu, select Edit > Copy.

 3. In the Xsheet or Timeline view, select the cell on which you want the cycles to start.

 4. From the top menu, select Edit > Paste Reverse or press Ctrl + . (Windows/Linux) or ⌘  + . (Mac OS X).
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Paste Special Options

Basic Tab

Parameter Description

Drawings

Only create drawing 
files when they do not 
exist

When adding exposures to a drawing layer, new drawings will be created only 
when drawings with the same name do not already exist in the destination.

Always create drawing 
files

When adding exposures to a drawing layer, new drawings will always be cre-
ated. If drawing files with the same name already exist, Harmony will create a 
new name for the drawing.

Paste all Frames of the 
Symbols (full movie)

When enabled, the Paste Special command exposes all the symbol's frames 
instead of only the first one.

Enforce Key Drawings Creates a key exposure on the same drawing.

Cycle

Number of Cycles Lets you set the number of cycles.

Cycle Type

Normal (forward): Pastes your selection as is, starting with the first cell and 
ending with the last.

Reverse: Pastes your selection in reverse, starting with the last cell and 
ending with the first.

Forward > Reverse: Pastes your selection as a yo-yo, starting with the first 
cell, going to the last one and ending with the first cell.

Reverse > Forward: Pastes your selection as a reverse yo-yo, starting with 
the last cell, going to the first one and ending with the last cell.
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Advanced Tab

Parameter Description

Drawings

Do Nothing Does not create or overwrite drawings.

Update Drawing Pivot
Revises the drawing pivot in the destination to use the same drawing pivot as the 
first drawing in the template. If you have a range of drawings selected in the 
destination, the pivot points of all selected drawings will be updated.

Add/Remove Exposure

Never create drawing files: When adding exposures to a drawing layer, drawing 
files will not be created.

Only create drawing files when they do not exist: When adding exposures to a 
drawing layer, new drawings will be created only when drawings with the same 
name do not already exist in the destination.

Replace existing drawings. Create drawing files when they do not exist: 
Replace drawings with the same names to update a scene with new modified 
drawings and preserve the animation.

Tip: If you don't want to lose the existing animation when pasting a 
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template,  such as when placing new drawings after the animation, 
then delete the template's animation.  It will still have updated the 
drawings but not override the existing animation.

Always create drawing files: When adding exposures to a drawing layer, new 
drawings will always be created. If drawing files with the same name already 
exist, Harmony will create a new name for the drawing.

Paste all frames of the symbol (full movie): When enabled, the Paste Special 
command exposes all the symbol's frames instead of only the first one.

Enforce Key Exposure: If there are key exposures that exist on copied draw-
ings, they are preserved when pasting. No key exposures are added. This is the 
default behavior when pasting.

Fill Gap with Previous Drawing: Fills selected area in the Xsheet or Timeline 
view with the previous drawing.

Fill to Next Key Exposure: Fills selected area till the next key exposure.

Add Remove/Keyframes

Motion Copies the properties of the selected motion keyframe to the new frame.

Velocity Copies the properties of the selected velocity keyframe to the new frame.

Rotation Copies the properties of the selected rotation keyframe to the new frame.

Scale Copies the properties of the selected scale keyframe to the new frame.

Skew Copies the properties of the selected skew keyframe to the new frame.

Force Keyframes at 
Function's Beginning 
and End

 Adds a keyframe to the beginning and end of the pasted function, reproducing the 
source function.

Offset Keyframes
When pasting functions, offsets keyframes from the function's last frame value 
by the values in the pasted function. This will continue the progression of a func-
tion instead of repeating the values.

Options

Palettes

Do nothing: Does not create, overwrite, merge or link palettes.

Reuse palettes. Copy palettes if they do not exist: Palettes in the destination 
drawings are left as they are.

Copy and overwrite existing palettes: Overwrites destination palettes with the 
palettes from the source drawings.

Copy and create new palette files: Creates new palette files, placing them at 
the same relative environment and scene level as the source. If the palettes in the 
templates were stored at the environment level of the source scene, the paste 
operation will place the palettes in the environment level of the destination scene.

Copy and create new palette files in element folder: Creates new palette files 
in the element folders of the destination scene, rather than in the same relative job 
or environment.

Copy palette and merge colours. Add new colours only: Adds new colours to 
the destination palettes and ignores colours that are the same in the two palettes.
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Copy palettes and update existing colours: Adds new colours to the 
destination palette and updates duplicate colours in the destination with colour 
values from the source.

Link to original palettes (colour model): Links the colour palettes in the 
destination scene to the palettes in the source. Use this to link drawings to the 
palettes in a colour model.

Copy scene palettes and merge colours. Add new colours only: Adds new 
colours to the destination scene palettes and ignores colours that are the same in 
the two palettes.

Copy scene palettes and update existing colours: Adds new colours to the 
destination scene palette and updates duplicate colours in the destination with the 
colour values from the source.

Symbols

Copy symbols if they do not exist: This is the default setting for this operation 
and will prevent Symbols in an Action template from being copied.

Duplicate symbols: Creates a duplicate of the symbol instead of linking the Sym-
bol instance to the original one. The new Symbol is created in the Library.

Cycles

Normal (forward):Pastes your selection as is, starting with the first cell and end-
ing with the last.

Reverse: Pastes your selection in reverse, starting with the last cell and ending 
with the first.

Forward > Reverse:Pastes your selection as a yo-yo, starting with the first cell, 
going to the last one and ending with the first cell.

Reverse > Forward: Pastes your selection as a reverse yo-yo, starting with the 
last cell, going to the first one and ending with the last cell.

Nodes
Create New Columns: A new column is created when you copy and paste 
nodes from the Node view or layer in the Timeline view. If the layers are linked to 
function curves, the function curves, drawings and timing will be duplicated.

Elements
Reuse existing elements: Lets you paste existing elements without creating 
new ones. This should be used only when pasting within versions of the same 
scene.

 

Adjusting the Velocity
To add ease in and ease out on motion paths, you can display the function curve and modify the Bezier or Ease 
curve. To apply ease to multiple functions and keyframes, you can use the Set Ease For Multiple Parameters script 
and set the amount.

The Velocity, or ease, is used on motion keyframes. The Velocity must be adjusted directly on the function curve in 
the Function view or Function editor. When a keyframe is selected, easing values appear in the right handle and left 
handle fields, as well as Bezier handle or Ease wheel controls on each selected keyframe. Pull on them to adjust the 
ease in and ease out, or type values in the fields.

You can reshape the velocity function using Bezier controls.
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You can also reshape the velocity function using Ease controls.

s

You can create a stepped curve to hold the same value over a selected number of frames. This works well when 
you are animating drawings on 2s, for example, and you want to hold the same value for a function over those two 
frames.

If you have several functions whose velocity you want to adjust at the same time, you can use the Set Ease for 
Multiple Parameters dialog box. It allows you to apply the same velocity parameters to all the selected keyframes 
in the same frame.

How to display the velocity curve

 1. In the Timeline view, click the Expand  button on a layer or press Alt + F.

The layer’s functions are displayed.
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 2. Double-click the desired function.

The Function Editor opens as the Ease Editor or Bezier Editor.

The editor will not be displayed if the function does not already exist. You can reshape the function using the 
Bézier or Ease controls.
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How to reshape a function using Bézier controls

 1. Select a keyframe.

 2. Drag the handles to modify the shape of the curve.

 3. The Continuity options influence how you can move the handles:

‣ Straight: Lets you move the handles together, maintaining the same angle to the point.

‣ Corner: Lets you move the handles independently.

‣ Smooth: Lets you move the handles together, maintaining the same distance and angle to the point.

How to reshape the function using Ease controls

 1. Select a keyframe.

 2. To set the number of frames in the ease-in, press Alt, click to the right of the keyframe and drag the green 
line. The ease in slope is indicated in blue. 

As you change the values visually, the value in the Ease In field is updated. This value represents the 
number of frames in the ease-in.
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 3. To set the number of frames in the ease-out, press Alt, click to the left of the keyframe and drag the green 
line. The ease-out slope is indicated in red. 

As you change the values visually, the value in the Ease Out field is updated. This value represents the 
number of frames in the ease-out.

 4. To adjust the ease-in or ease-out, drag the handles around the keyframe.

The Continuity options, Corner and Straight, influence how you can move the handles:

‣ Straight: Lets you move the handles together, maintaining the same angle to the point.

‣ Corner: Lets you move the handles independently.

How to hold the same value over several frames

 1. Click the Hold Value Editor  button.

The Hold Value editor opens.

 2. In the Hold Value Editor, enter the following values:

‣ Start: The starting frame for the effect.

‣ Stop: The last frame for the effect.

‣ Step: The number of frames to hold the value.

The function curve is updated based on the values you entered.

You can reshape the curve to create a linear velocity, so the values are interpolated (tweened) consistently 
between keyframes. That is, there is no acceleration in the effect.

How to set the ease on multiple parameters

 1. In the Timeline view, select a keyframe on one or more layers.
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NOTE: Only the first selected keyframe will be considered when using the Set Ease For Multiple Parameter 
function. If many keyframes are selected on the same layer, the ease values will be applied only on the first 
keyframe and the rest will be ignored.

 2. Do one of the following:

‣ In the Timeline view, right-click and select Set Ease For Multiple Parameters. 

‣ In the Timeline toolbar, click the Set Ease For Multiple Parameters  button.

The Set Ease For Multiple Parameters dialog box opens.

 3. In the graph, adjust the Bezier handles to change the velocity for all the selected functions.

 4. In the Filters section, you can apply the easing parameters to a specific type of function only, such as 
Rotation or Scale. Deselect the function types you do not want to affect.

‣ Motion: Applies the easing parameters to the selected Position X, Position Y, Position Z and 3D Path 
functions.

‣ Rotation: Applies the easing parameters to the selected Angle functions.

‣ Scale: Applies the easing parameters to the selected Scale functions.

‣ Skew: Applies the easing parameters to the selected Skew functions.
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‣ Morphing: Applies the easing parameters to the selected Morphing Velocity functions. Note that it 
applies to the Morphing velocity function found in the Layer Properties window, not the basic morphing 
ease in the Tool Properties view.

‣ Other: Applies the easing parameters to all the other the selected functions, such as all functions created 
to animate effect parameters.

 5. You can also adjust the easing by typing values in the Time and Value Ratio fields. The values are calculated 
in percentage.

‣ In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding to the length 
of time you want the easing to last. Stay between 0% and 100%. If you go beyond 100%, your motion will 
overshoot. 

‣ In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong you want the 
easing out to be. Stay between 0% and 100%. If you go beyond 100%, your motion will overshoot. 

‣ If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

 6. Once done, click one of the following:

‣ Apply/Previous: Applies the easing parameters to the selected keyframes and then selects the previous 
keyframe in the timeline.

‣ Apply: Applies the easing parameters to the selected keyframes.

‣ Apply/Next: Applies the easing parameters to the selected keyframes and then selects the next 
keyframe in the timeline.

‣ Close: Close the dialog box. If you did not apply the modifications, they will be cancelled.

How to set the ease in the Timeline view

 1. In the Timeline view, select a keyframe on one or more layers.

NOTE: Only the first selected keyframe will be considered when using the Set Ease For Multiple Parameter function. 
If many keyframes are selected on the same layer, the ease values will be applied only on the first keyframe and the 
rest will be ignored.

 2. In the Timeline toolbar, select an option from the Set Ease Type menu.
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NOTE: TIP: Optimize your workflow by adding the Apply Ease to Selection  button to the Timeline toolbar. This 
lets you quickly reapply the ease type without going through the Set Ease Type menu each time. To add the button 
to the toolbar, right-click on the toolbar area of the Timeline view and select Customize. 

Expression Columns

In Harmony, you can use expressions to automate the calculation of effect values based on the values in another 
function. An expression is a mathematical formula that allows you to manipulate the value in the source function 
to create new values for the destination effect.

For example, in a scene with two characters, one is walking across the stage and the other is following the same 
path two steps behind. Without expressions, you would have to manually enter the values for the position of the 
peg to be one frame behind the original element. However, you can save time by building an expression that does 
it for you. Then, if you change the position of the element in the original column, Harmony automatically updates 
the Expression columns linked to it.

When you want to create an expression for an effect, you must add an Expression column to the Xsheet view, 
build the expression and then link the Expression column to the parameter you want to control.
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Writing Expressions

Expressions are based on a JavaScript (JS) program. You can access the full capability of the JS language and 
write any type of program, as long as it executes relatively quickly.

The entire JavaScript must be defined within the expression code. There is no common repository of JS functions 
and services available to the expression column scripting environment. However, with the Harmony C++ SDK, you 
can extend the API of functions available to the expression scripting environment.

If you're working with an old project that contains expressions, they are converted to a JS program. Only simple 
expressions are updated. Complex expressions and expressions using non-ported services cannot be converted. 
For these type of expressions, you must convert them manually.

Expression Dialog Box

The Expression dialog box is where you write expressions. It's a simple text editor that can handle incomplete or 
invalid JS programs although they will not be evaluated. Harmony can save and load invalid JS programs.

The Expression editor evaluates the current script at the current global frame and reports any errors or returns the 
numerical result of the program.

Expression JavaScript Program

An expression JavaScript program can be any valid program. The only requirement is the last statement of the script 
must leave a number on the stack. The “return” statement is NOT needed as the script is not a function.

Valid Expression Column JS Program

Example 1

10

This is a simple program returning 10.

Example 2

currentFrame

This is another simple program returning the current frame. The variable “currentFrame” is one of the predefined 
variables and services available.

Example 3

value( “MyBezierFunction”, currentFrame - 1 );

A simple expression program that returns the value of the Bezier function “MyBezierFunction” at the previous frame. 
If this function does not exist in the scene, the expression column will be blank in the Xsheet. If this function does 
exist, the expression column will show the value of that function at the frame.

Example 4
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This programs evaluates the Fibonacci series starting at the current frame. The value will be computed up to a 
certain frame. After that frame, the program is too complex and will be stopped by the engine before finishing.

Errors

Programs that take too long to execute, that don't generate a numerical value, or has syntax errors will not be 
compiled and will not compute a value. The scripting editor will show the condition that triggers this, but the 
Xsheet will display a blank field.

API

Using Column Names and Frame Numbers

To refer to the values in a column, use the column name and frame number. If you do not state the frame number, 
then Harmony uses the value of the current frame. You can refer to the frame numbers in the following ways:

• currentFrame: Refers to the current frame number.

• numFrames: Refers to the total number of frames in a scene.

Consider the expression: value ( “peg x”, currentFrame-1)

• This expression says that the current frame value will be the same as the previous frame value of the 
element peg x.

Now consider this expression: value ( “peg_angle”, currentFrame - 2] * 3

• In this expression, Harmony is to look two frames before the current frame in the column "peg_angle" and 
multiply the value by 3 to derive the value for the current frame of the expression column.

Predefined Functions

Most mathematic functions are obvious. They either take an angle or value, or return an angle or  value. Angles are 
always specified in degrees. If the input argument is not valid, the function will log an error (which is visible in the 
script editor) and the Xsheet does not display anything.

The two variants of the function value() are used to get the value of 2D functions at the current frame or the 
specified frame. The first argument is always a string that identifies the function. The optional second argument is 
the frame to use.

For example: value( “myFavBezier”, currentFrame-1)

Function Description

sin (angle) Returns the sinus from the angle specified in degrees.

cos (cosine) Returns the cosinus from the angle specified in  degrees.
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tan (angle) Returns the tangent from the angle specified in  degrees.

asin( v ) Returns the arcs in degrees.

acos( v ) Returns the arccos in degrees.

atan( v ) Returns arctan as an angle in degrees from the first  quadrant.

atan2( x, y ) Returns the arc tangent in degrees.

int Returns the integer value of the “v”. Undefined  behaviour for negative number.

ceil( v ) Returns the next integer greater or equal than “v”.

floor( v ) Returns the integer value of v. Remove the fractional  part.

abs( v ) Returns the absolute value.

sqrt( v ) Returns the square root for v >= 0.

exp( v ) Returns the “e” exponent v. (see c library exp( f )).

ln( v ) Returns the natural logarithmic of v for v > 0.

ln Logarithm of a value.

value( columnName) Value of the function specified by “columnName” at the current frame.

value(columnName,frame)
Value of the function specified by “columnName” at the frame specified by 
“frame”.

column( columnName )

Indentify the text wrapped by columnName to be renamed whenever the 
column named “columnName” is renamed.

column() is a keyword that does nothing at runtime, but helps Harmony track 
which references to a function needs to be renamed in the script when a 
function is renamed. For example, if you have a function named “B” and this 
one gets renamed to “C” through some scripts or by the user, all expression 
scripts referencing “B” will automatically be updated to refer to “C” if their call 
was wrapped as column( “B” ).

node( nodeName )

node( nodeName ) 

Identifies a node/node that is in the same group as another node which is using 
this expression column.

node( nodeName) and node( nodeName ) are two functions that return a proxy 
to a node that must be in the same group as another node using that 
expression column. For this method to work, the expression must be 
connected to a node “A” and the script must refer to a node “B” in the same 
group as node “A”. The resulting object is a proxy to a node which cannot be 
converted to a number. This proxy object is only usable by an SDK plugin.

numFrames A constant that represents the number of frames in the current scene.

currentFrame A constant that represents the current frame (1 based).

Building an Expression for an Effect

How to build an expression for an effect

 1. In the Xsheet view menu, select Columns > Add Columns or press Shift + C.

The Add Column dialog box opens.
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 2. In the Name field, type a name for the column.

 3. From the Type menu, select Expression and click OK.

 4. Double-click on the column's header to open the Expression dialog box.

 5. Type an expression in the dialog box.

NOTE: To address a specific component of a 3D path, the syntax is "Peg x", not "Peg_x".

 6. Click OK or Apply to activate the expression.

The cells in the Expression column are filled with values based on the expression you created.
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 7. To apply the values in the Expression column to an effect, link the Expression column to the parameter val-
ues. In the drawing's layer properties, link the function to the new Expression column.
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Chapter 7: 2D-3D Integration

Harmony provides you with impressive 2D-3D integration possibilities. This allows you to combine the two 
animation genres within the same production, resulting in some remarkable scene composition and a unique style.

Harmony supports the following 3D formats:

• FBX

• 3DS

• OBJ

• OSB

• Alembic (*.abc)

• Collada (*.dae)

You can work with Autodesk Maya, PIXIE, or 3Delight. In this guide, Autodesk Maya will be used. To work with 
Pixie or 3Delight, contact store.toonboom.com/contact/support.

This chapter contains the following topics:

• How 2D-3D Integration Works on page 307

• Exporting a 3D Object for Harmony Using Autodesk Maya on page 309

• Importing a 3D Object on page 311

• Manipulating the 3D Object on page 313

• Rendering 3D Models with Autodesk Maya on page 321

How 2D-3D Integration Works
Harmony allows you to import 3D models and reposition them in Harmony and animate them over time. 
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Importing a Reference Model 

When working in Harmony, the first thing to do is import a reference model. This model is what will be represented 
in the Camera view OpenGL mode.  Animators can reposition this model, animate the camera, and interact with it.  
Although several formats are supported, FBX (*.fbx) is the recommended format as this will allow you to embed 
textures for nicer looking reference models. 

Other supported formats are  Alembic (*.abc), (*.osb), Autodesk 3ds Max (*.3ds), Object (*.obj), and Collada 
(*.dae). The support of the Collada format enables artists using SketchUp to export to Harmony without the need 
to use SketchUp Pro.

Harmony offers options to convert  the 3D files directly to OSB (*.osb) files and save them so that the next time 
you reload the scene it doesn’t have reconvert them.

The following chapters show you how to import such a model and animate it in Harmony.  

When importing an FBX (*.fbx) model, remember that model will never be used for the final render.  Harmony itself 
does not have a 3D rendering engine embedded.  

Rendering of the OpenGL representation of the model is supported. However, this is not a high enough quality for 
a final product. Instead, rendering is supported through outside rendering engines.  The majority of users use Maya 
Softrender, although 3Delight and Pixie are also supported. 

Because this model is never used for a final render, you can optimize it quite a bit.  The imported FBX model does 
not require high-resolution textures or sophisticated shaders.  It can even have a lower poly count than your final 
model.  It does, however, need to be the same size as your final model, as Harmony will be sending the position, 
rotation, and scale information of the model in the Harmony scene to Maya later to render.  Keeping the imported 
FBX file as light as possible will give you snappy performance while animating. 

Rendering

When it comes to rendering, a connection is opened between Harmony and the rendering engine—in this case 
Maya Softrender.  
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Maya Batch is opened in the background and the information from the Harmony scene file is sent to Maya.  All the 
information needed, including the animation on the model and the position of the camera, is sent to Maya.  Maya 
Batch then opens in the background and the original .mb file is opened.  This file should match the FBX model in size, 
but may have a higher polygon count, a more advanced texturing setup, or even a more advanced set of shaders.  
Since the full Maya scene is loaded, you can use any shader, lighting setup, and texture that Maya Softrender 
supports.   

The opened scene file repositions the model inside based on the information provided from the Harmony scene file.  
For consistent lighting effects, you may want to parent the lighting rig to the model so it is also repositioned along 
with the model.    

The frame is then rendered and sent back to Harmony to be composited there.  The data comes back into Harmony 
as a series of Maya *.iff images.  These images contain not just image data, but also depth information, and 
Harmony will use this depth information to properly clip any 2D layers that are interacting with the 3D model in the 
Harmony scene, resulting in a perfect composite without the need to track any masks. 

You can also apply any effects that are supported on bitmaps to the rendered sequence, such as blurs and blending 
modes.   

Exporting a 3D Object for Harmony Using Autodesk Maya
Once you set up Toon Boom Harmony and your system for the use of 3D, the next step is to generate the 3D models 
you plan to import and use in your scene. You can use Autodesk Maya for this. Although FBX models can be 
exported from any software and imported into Harmony,  Maya has a better integration with Harmony if you require 
software rendered, high-quality images in your pipeline.
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How to export a 3D object for Harmony

1. In Autodesk Maya, create your 3D object.

You should also complete the texturing of your 3D object, as well as set up a few lights in your scene. 
When you render your scene later through Harmony, it will use this original Maya scene to render with the 
shaders, textures, and lighting of the scene.

NOTE: When you animate the object in Harmony, it will use this scene file and push the animation from Harmony 
into this scene. For this reason, you may want to parent the lights to the object, so the lighting you set up moves 
with the object when it is animated. If not, the object may be rotated out of the lighting, resulting in a very dark 3D 
object. In Maya, you can parent one layer to another by middle-mouse clicking and dragging that layer.

 1. Save your Maya binary file *.mb as you will use it later on.

 2. Use the export command to export your model. Select File > Export All.

The Export All dialog box opens.
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2. In the Files of Type menu, select FBX Export.  

3. Select the Embed Media option to see the textures on the model when you import the FBX model into 
Harmony.  

4. From the Type list, select Binary. 

5. From the Version list, select FBX 2015 or below.

When you complete the export, an *.fbx file will be created.

Instructions may differ depending on the version of Autodesk Maya you are using. Therefore it is 
important to refer to the Maya documentation for the correct instructions on how to create and export 
a 3D model.

Importing a 3D Object
Once you have exported a model using a 3D authoring software, you can import it into Harmony and integrate it to 
set up your 2D animation scene.

You have the possibility to convert  your 3D models to *.osb files upon import to Harmony and save them as such. 
This will allow Harmony to render 3D files with the associated textures without the need to copy them manually (as 
long as the auxiliary files are linked correctly and named appropriately on your disk).

311



Chapter 7: 2D-3D Integration     

How to import 3D models

 1. In Harmony, select File > Import > 3D Models.

The Import 3D Models dialog box opens.

 2. Click Browse and locate your *.fbx or other supported 3D format files.

 3. Click Open to validate your choice and close the browsing window.

 4. In the Layer section, choose your import options.

‣ Create Layer(s): This option is selected by default. A new layer will be created for the selected files 
for the import. You have two choices:

Create Single Layer Named: Imports all your selected *.fbx files in the same layer you can name.

Create Layer(s) Based on Filename: Creates a different layer for each file selected import. The 
layers will be automatically named according to the file names.

‣ Add to Existing Layer: Imports the selected files into an existing layer in the scene. Use the drop-
down menu to select a layer. Note that if you add to an existing layer which is a vector layer, it will 
encapsulate the 3D model inside a symbol.

 5. In the Conversion section, select the Convert to OSB format option if you want your file to be transformed 
into an OSB and import all related files.

 6. Click OK  to validate your choices and import the selected file(s).

The 3D models are imported in the scene.

312



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

Manipulating the 3D Object
Once you have imported the 3D model into your scene, you can easily manipulate it to set up your scene. You can 
even add keyframes, just like any other element, and animate it on a trajectory.

This section is divided as follows:

• Working in the Different Views on page 313

• Using Peg Nodes to Control the Position of 3D Objects on page 316

Working in the Different Views

Before you can properly view and set up the 3D element in your scene, you will need to use the Perspective and 
Camera views together, as well as the Top and Side views. 

• Perspective View on page 313

• Camera View on page 314

• Top and Side Views on page 315

Perspective View

In the Perspective view, you can see your scene in a complete 3D environment. In this environment, you can set up 
and animate your 3D model more easily. You can rotate the view on the three axes. 

How to rotate the Perspective view

 1. Hold down ⌘  + Alt (Mac OS X), and click and drag.
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Camera View

You can preview the position of your 3D model in the Camera view and see what it will look like in the camera 
frame. You can preview your scene in  OpenGL  mode.

 

You can view your 3D objects in Render  mode, but only basic settings will be used to render the 3D element. 
To get a fully textured and lit render, you can use Autodesk Maya. If you want to render using your 3D objects 
using Maya as a background process, before you can view your 3D elements in Render  mode, you must add 
a Maya Batch Render node to your Node view and set up your system with the correct path to the rendering utility 
you will be using. Note that you will need to add your Maya project inside the 3D object's element folder in your 
Harmony scene. If you do not complete this setup, the 3D model will simply not appear—see Rendering 3D 
Models with Autodesk Maya on page 321.
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If you want to override the order of your 2D and 3D elements to follow the Composite node ordering rather than the Z-
axis order, you can use the Flatten node—see Flatten on page 465.

Top and Side Views

The Top and Side views help you position your element in the 3D environment. This can be really helpful for 
precisely visualizing the actual position of your model without perspective.
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Using Peg Nodes to Control the Position of 3D Objects

You can use Peg nodes to control the position of 3D objects, and connect them as you would with 2D layers to 
create rigs. 
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Using Transformation Tools to Manipulate 3D Models

Once the 3D option is enabled, your transformation tools automatically become 3D transformation tools. This means 
you can now manipulate them on the Z-axis as well. The Translate , Rotate  and Scale  tools are found in 
the Advanced Animation toolbars and the Transform  tool can be found in the Tools toolbar. You can use these 
tools to set up or animate your 3D model. 

You can also set up all these position parameters using the Layer Properties window—see 3D Parameters on page 
211.

NOTE: If you want to set up the position of your 3D model, you must disable the Animate  mode. Don't forget to 
re-enable it when if you want to animate it.

Translate Tool

Once you enable the 3D option, the 3D Translate tool becomes available. Direction arrows appear around the pivot 
points to indicate the different axes.

 

If you click on a direction arrow, you can move a layer on only one axis. If you click anywhere else, the layer can 
move freely on two axes at once. Once the arrow is selected, it turns pink.
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If you move the layers in the Perspective view, it may be difficult to control the motion since you may not have the 
optimum point of view on your stage to understand the setup. In this case, it is best to use the direction ellipses.

Rotate Tool

Once you enable the 3D option, the 3D Rotate tool becomes available. A rotation sphere appears around the pivot 
points to indicate the different axes.

You can click on the direction ellipses to rotate your layer on one axis only. If you click anywhere else, the layer 
rotates freely on two axes at the same time. When the ellipse is selected, it turns pink.

If you move the layers in the Perspective view, it may be difficult to control the motion since you may not have the 
optimum point of view on your stage to understand the setup.
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Scale Tool

Once you enable the 3D option, the 3D Scale tool is available. You will see one of two things:

• A scaling rectangle appears if your drawing is flat.

• A scaling cube appears if your object has some rotated layers around the pivot points, indicating the different 
axes. If you click and drag on this scaling cube, it will scale proportionally on all axes.

Click on one of the three control points to scale the shape on one axis. Hold down the Shift key to scale the object 
proportionally. When the control point is selected, it turns pink.

Transform Tool
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Once you enable the 3D option, the 3D Transform tool become available. This tool is a combination of the 3D 
Translate, 3D Rotate and 3D Scale tools.

To translate an element, grab the direction arrows in the same way that you would with the Transform  tool.

To rotate an element, grab the rotation ellipses in the same way that you would with the Rotate  tool.

To scale an element, grab the scaling control points in the same way that you would with the Scale  tool.

If you click and drag on the scaling cube, it will scale proportionally on all axes.
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Rendering 3D Models with Autodesk Maya
There are  two ways to preview and render 3D elements in Toon Boom Harmony. You can render your scene using 
the OpenGL preview, or render calling Autodesk Maya, Pixie or 3Delight in the background.

If you do not set up a plugin to preview your model with Maya or your 3D software, the preview and rendering will be 
done using the OpenGL preview. The result will look flat and jagged, but it can be very handy while working and 
exporting shots for approval.

If you render a scene calling Autodesk Maya, Pixie or 3Delight, you will get a smooth result with texture and lighting.

Before you can render the 3D objects you imported in Harmony through Autodesk Maya soft render, you must 
prepare your system by setting some environment variables, and adjusting the Node view in Harmony.

This section is divided as follows:

• Preparing the Project Directory on page 321

• Setting the Path on Windows on page 322

• Setting the Script on Mac OS X on page 324

• Setting the Path on Windows on page 322

This section is very technical; if you need help, or experience problems while setting up the 3D 
rendering, contact store.toonboom.com/contact/support.

Preparing the Project Directory

How to set up rendering

 1. Copy your original Maya binary file  *.mb into your Harmony project directory at the same location as the .fbx 
file you imported. This .fbx file should be in the elements folder, inside a subfolder named like the element.

Example: If the element is called PirateShip,then the subfolder should be named PirateShip. 
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 2. Rename the .mb file so it has the same name as the *.osb file. You saved the Maya *.mb file in Exporting a 
3D Object for Harmony Using Autodesk Maya on page 309 of this document.

For example: If the *.fbx is called PirateShip-1.fbx, name the *.mb: PirateShip-1.mb.

 3. Copy any textures used in the Maya project into this same folder.

Setting the Path on Windows

 

The path needs to be set up so that when Harmony launches Maya, it knows exactly where to look for the 
application.  On Windows, this can be set up using an environment variable.

How to set up the environment variable on Windows

 1. From Start, right-click on Computer and select Properties.

 2. From the Computer Properties dialog box, select Advanced System Settings.

The  System Properties dialog box opens.
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 3. In the System Properties dialog box, click Environment Variables.

The Environment Variables dialog box opens.

1. The first variable to set up is the Maya path. In the System Variables section, browse for the Path variable 
and select it.

 4. Click Edit.

The Edit System Variable dialog box opens.

 5. In the Variable value field, add a semicolon (;) at the end of the last path.

 6. Copy the path to the bin folder of Maya following the semicolon. 

For example: For Autodesk Maya 2011 on Windows, the path would be as follows: 
C:\Program Files\Autodesk\Maya2011\bin

NOTE: You can browse to the installation folder of Maya and copy the complete path to the bin folder from the 
browser window to ensure you have the exact path.
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 7. Click OK.

If you receive an error readout in the command line when you try to render, contact 
store.toonboom.com/contact/support and provide the error readout content.

Setting the Script on Mac OS X

The Path needs to be set up so when Harmony launches Maya, it knows exactly where to look for the application.  
On Mac, you can set this up by placing a script in usr/bin.

Follow these steps to create the script to call Maya and to set it up. 

From the Terminal, you must create a file in which to save the script. 

How to create the script and set it up

 1. Switch to the directory in which you want to create the script file:

cd /usr/bin

 2. If the bin directory does not exist, then create it:

mkdir /usr/bin

 3. Create the script file called maya:

sudo vim maya

 4. Type in your password to get administrator access.

 5. From inside the text editor, select "i" to go to Insert Mode, and copy and paste the following text. Make 
sure the path is updated to the version of Maya you have running on your machine.

#!/bin/bash

exec /Applications/Autodesk/maya2014/Maya.app/Contents/MacOS/Maya "$@"

 6. Save and exit:

Esc :wq

 7. Edit the file to make sure all users can access it:

chmod ugo+x maya

Setting the Path on Linux

The path needs to be set up so when Harmony launches Maya, it knows exactly where to look for the application. 
You can either do it in a tcshrc or a bash shell. In both instances, you are simply adding your path to the beginning 
of the $PATH environment variable. Note, this should generally be added to your .tcshrc file ( in your home 
directory ) or in your .bash_profile, depending on the type of shell you use.
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How to set the path on Linux

 1. Do one of the following:

‣ In a tcshrc shell:
setenv PATH /whatever/the/path/to/Maya/is:$PATH

‣ In a bash shell:
export PATH=/whatever/the/path/to/Maya/is:$PATH

  Setting Up the Node View

Now that your environment variables have been properly set up, the final step is to prepare your network to call the 
Autodesk Maya rendering utility. Once this is done, you can render the 3D objects in your Harmony project and 
preview them in the Camera view in Render View  mode. This will allow you to composite your 3D scene and 
effects.

There are two types of script nodes that work with the Harmony-Maya connection:

• Render Maya Batch
This node uses the script renderMayaBatch();

This script starts a Maya Batch session, renders the 3D elements on that frame, and then closes the 
session. It will open and close the session for every frame to be rendered.

• Render Maya Batch Server
This node uses the script renderMayaBatchServer();

This script starts a Maya Batch session that stays open so when you render 3D objects through multiple 
frames, it does not close the session between each of them.

How to prepare the project network

 1. Start Toon Boom Harmony. It is recommended that you  run it from the command line. This way, you will have 
a printout of the process as it renders. Once it is started, you may also want to display the Message Log 
view.

 2. In the Node view, locate the 3D object node.
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1.        In the Node Library view, select the RenderMayaBatch or RenderMayaBatchServer node and drag it 
to the Node view.

2.        In the Node view, hold the Alt key down while dragging the Maya Render node under the 3D object node 
to connect it.

 3. Repeat the previous steps for each 3D object node in your scene.

 4. Save and reload your scene so Autodesk Maya files can be retrieved from the project folder.

 5. In the Camera view, click the Render View  button.

All the elements of your scene appear in this complete preview of the rendered scene.

3. To add effect filter nodes to your 3D object, make sure to connect them under the Maya render node.

You are now set to render your animation project.

Possible Artifacts Resolved with Z-Buffer Smoothing

When batch rendering 3D models originating from Maya, some unwanted artifacts may appear, particularly on 
models with outlines. This is due to problems with the depth information. You can use the Z-Buffer Smoothing 
node to smooth out the edges. 
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Z Buffer Smoothing Node Properties

Parameter Description

Histogram Range

Lets you define the range of clean pixels in the depth histogram when rendering 
3D models.  Only opaque or semi-transparent values are considered.  

A low value means fewer pixels are used in the depth calculations and may flatten 
your object, while a higher value uses more pixels in the depth calculations, but 
may not eliminate all the image artifacts.

Kernel Size

Lets you determine the size of the matrix used for calculating the depth of a single 
pixel.  For example, for an operation with a kernel size of 3 pixels, Harmony uses 
the pixels within a 1-pixel radius to calculate the effect. A larger kernel size 
means longer calculations.

How to use the Z Buffer Smoothing

 1. In the Node Library, select the 3D tab. 

 2. Select the Z Buffer Smoothing node and drag it to the Node view.

 3. In the Node view, place it between a MayaBatchRender node and the final Composite node.
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 4. Display the Z Buffer Smoothing node properties. 

 5. Adjust the Histogram Range and Kernel Size parameters to achieve the optimal rendering of your Maya 
models. In most cases, you will have to experiment with a balance between the histogram range and the 
kernel size.
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Chapter 8: Sound

With Harmony, you can import soundtracks and dialogue into your animation.There are several sound editing 
features you can use to synchronize sounds to individual frames or moments in time. You can also edit them to trim 
unwanted seconds from the beginning and end of your sound files, as well as loop sounds that you want to continue 
throughout your animation.

Your ability to add dialogue to animation is greatly enhanced with the Harmony automatic lip-sync detection. 
Harmony can analyze voice tracks to determine which of the eight animation phonemes (lip positions) would best 
apply to each frame of sound. With the mouth chart that is generated, you can easily draw lip positions for your 
character. Furthermore, Harmony can automatically apply drawings of lip positions to each frame of your animation 
based on the mouth chart.

This chapter contains the following topics:

• Importing a Sound File on page 329

• Sound Layer Properties and Sound Element Editor on page 330

• Sound Displays on page 331

• Sound Playback on page 332

• Sound Scrubbing on page 333

• Editing a Sound File on page 336

• Adding an Empty Sound Layer on page 343

• Exporting a Sound File on page 627

Importing a Sound File
If you decide to add sound to your animation, you must first prepare the sound outside of Harmony. Once this is 
done, you must add a sound element in Harmony to the organize the sound files in your animation. Sound will play in 
the movie until it reaches the end of the file or a stop frame that you created in the Sound Element Editor.

If you first create your project in Toon Boom Storyboard Pro, the sound will be cut up into the different scenes for you 
automatically.

You can import .wav, .aiff or .mp3 sound files.
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How to import a sound file

 1. Do one of the following:

‣ From the top menu, select File > Import > Sound.

‣ In the Xsheet view, right-click anywhere in the frame area and select Import > Sounds.

‣ From the Xsheet menu, select File > Import > Sounds.

‣ From the Timeline menu, select Import > Sounds.

The Select Sound File dialog box opens.

 2. From the Select Sound File dialog box, find and select a sound file.

The sound file  appears as a layer in the Timeline and Xsheet views.

 

Sound Layer Properties and Sound Element Editor
When you select a sound layer in the Timeline view, the options related to that layer appear in the Layer 
Properties view and in the Sound Element editor when you double click on the layer. 
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• Mute/Unmute: This button mutes and unmutes the sound layer during the scene play back.

• Layer Name: This field displays the layer's name.

• Sound Editor: This button opens the Sound editor.

• Start Frame/End Frame: These fields determine the start and end frame of the sound file.

• Detect: This button launches the automated lip-sync detection.

• Map: This button opens the Map Lip-sync dialog box.

• Mouth Shapes: This section shows the automated lip-sync detection during the scene play back. Click on the 
thumbnail image of each mouth to change the phoneme assigned to the current frame.

Sound Displays
Within the Xsheet view, you can display the sound file in different ways, depending on your sound editing needs.

You can show or hide the waveform in the Timeline view by selecting the Waveform  button in the Timeline View 
toolbar. You must customize the toolbar to display this button because it is not included in this toolbar by default.

How to change the sound display in the Timeline view

 1. In the Timeline view's right area, right-click in the frame section and select Show Sound Waveforms or in 
the Timeline view menu, select View > Show > Show Sound Waveforms.
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‣ You can change the waveform scale using the Zoom Waveform  icon on individual sound layers in 
the Timeline view's left side.

How to change the sound display in the Xsheet view

 1. Right-click in the sound column or on the sound column header, and select Sound Display and one of the 
following:

‣ Sound Name: Shows the name of the sound file, as well as the file format. The line running vertically 
through the column frames between the same file name indicates a continuity of the same sound file in 
these frames.

‣ Mouth Shapes: Shows the letter (or name depending on the way you named your character's different 
mouth positions) in the column's frames. There is only one mouth position allotted per frame and this 
position should correspond to the sound file after performing a lip-sync.

‣ Waveform: Shows a vertical display of the sound file's actual waveform. In the column header, in the 
field under the column name, you can type in a percentage to zoom in or zoom out on the waveform, or 
pass the scroll cursor  over the Zoom Waveform  icon.

Sound Playback
Before playing back any sound, click the Enable Sound  button in the Playback toolbar or enable it through the 
Play menu (in the top menu). This will ensure that you can hear the sound layers in your scene, even the ones 
included within symbols.

If there are two or more sound layers and you want to listen to them independently, you can disable the unwanted 
sound by clicking the Disable Layer  button on the sound name layer in the Timeline view.

If you are trying to do a playback with sound and the frame rate doesn't reach 24 fps (frame per second), you can 
do one of the following to troubleshoot the issue:
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 l Shrink down the Camera view size to reduce the cached image size.

 l Playback your scene without sound first, then add the sound. If you do not cache the imahes first without 
sound, the playback will try to follow the sound by skipping images that will never get cached.

 l In the Preferences panel, in the OpenGL tab, reduce the size of the Playback Cache Size (in mb) preference.

How to play back sound

 1. To select a starting point:

‣ In the Xsheet view, click on a cell in the sound column.

‣ In the Timeline view, click on a cell in the sound layer. You can also slide the red playhead to the correct 
cell.

 2. In the Playback toolbar, activate the Enable Sound  button.

 3. Do one of the following:

‣ Click the Play  button in the Playback toolbar.

‣ From the top menu, select Play > Play or click on the Enter/Return key.

 4. To hear the sound played back again and again, do one of the following:

‣ Click the Loop  button in the Playback toolbar 

‣ From the top menu, select Play > Loop.

 5. To mute soundtrack, on the left side of the sound layer, click the Disable Layer  button.

Sound Scrubbing
Harmony uses a process known as Sound Scrubbing to let you hear sound in real-time while you move the playback 
pointer forward or backward. This is very useful for finely-tuned lip-synching. You can scrub sounds from the 
Timeline view. 

How to scrub a sound from the Timeline view

 1. Do one of the following:

‣ From the top menu, select Play > Enable Sound Scrubbing. 

‣ Right-click in the frame bar of the Timeline view and select Play > Enable Sound Scrubbing.

‣ In the Playback toolbar, enable the Sound Scrubbing  button. 
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 2. At the top of the Timeline view, drag the red playhead to hear the sound at each frame.

 3. In the Playback toolbar, you can use the jog slidder to playback forward and backward subsequent sound 
frames. This allows you to do a more fluid scrubbing.

Analog Sound Scrubbing

Harmony is set to the digital sound scrubbing mode by default. This means that all sounds are played in real time. 
It also means that as you scrub over a frame, you will hear the section of your sound file that is allotted to that 
frame. As you are scrubbing, although it is accurate, the sound can sound clipped. It can also be difficult to hear 
nuances in pitch and tone. 

Harmony has an analog sound scrubbing option. When sound scrubbing in this mode, the sound is played back 
according to the speed that the playhead or jog is manually adjusted. Harmony's interface offers shuttle and jog 
sliders to perform analog sound scrubbing, however, external hardware and their corresponding software can be 
used in conjunction with Harmony for improved analog sound scrubbing results. 

334



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

NOTE: Refer to the device's manual to configure its functionality with Harmony.

Performing an Analog Sound Scrub in Harmony

Before you can perform an analog sound scrub in Harmony, you have to learn about the Shuttle and Jog controls.

• Shuttle: Pull the Shuttle control backward or forward to make the red playhead in the Timeline view jump by 
large increments in the direction you are moving the shuttle.

• Jog: Drag the Jog control to make the "dial" rotate. The Jog controls finer incremental movements along the 
soundwave. Use the Frame field to see the frame number which you are on. As you rotate the dial, your 
speed in fps appears directly after the FPS field. 

How to perform an analog sound scrub

 1. Do one of the following:

‣ From the top menu, select Play > Enable Sound Scrubbing. 

‣ Right-click in the frame bar of the Timeline view and select Play > Enable Sound Scrubbing.

‣ In the Playback toolbar, enable the Sound Scrubbing  button. 

 2. In the top menu, select Edit > Preferences (Windows) or Stage Premium > Preferences (Mac OS X).

 3. In the Sound tab, select the Analog Sound Scrubbing option.

 4. Click OK.

 5. Do one of the following:

‣ In the Playback toolbar, use the Shuttle to find the general location of where you want to start your sound 
scrub. 

‣ In the Timeline view, drag the red playhead to the desired location.

 6. In the Playback toolbar, use the Jog to fine-tune your scrub to just a few frames.
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Editing a Sound File
Now that you have successfully imported a sound file into Harmony, it is time to familiarize yourself with the 
sound editing interface. The Sound Element editor makes it possible to edit sounds that were created outside of 
Harmony and imported into your scene.

How to open the Sound Element editor

1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

The Sound Element Editor dialog box opens.

The Sound Element editor consists of three main parts.
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‣ Sound Element: The waveform in the Sound Element Editor is the actual sample that will be heard when 
the final movie is rendered. It may be shorter than the original sound sample due to the length of the 
scene. If any edits are made to the sound sample, they can be heard here. In the Sound Element panel, 
notice the coloured tabs that indicate the start and end frames of a sound segment. The frame number is 
displayed in the tab.

‣ Current Sound: Displays the original sound file in its entirety and is where you can edit its properties. 
This window remains empty until you click inside the Sound Element Editor.

‣ Lip-sync Preview: Lets you preview the automated detection and to manually insert different mouth 
positions to correspond with the sound sample. 

You can accomplish the following tasks in the Sound Element Editor:

• Changing the Start or End Frame of a Sound on page 337

• Trimming the Start and End of a Sound File on page 339

• Looping a Sound on page 340

• Mixing the Sound Volume on page 341

• Customizing the Playback Range on page 342

Changing the Start or End Frame of a Sound

To synchronize the sound with specific images in your scene, you must set a start frame for your sound. To make 
sure the sound ends by a certain frame, you must set an end frame.

In the Sound Element panel you will see some coloured tabs, these tabs represent the frames. The frame number is 
shown inside the tab flag marker. These tabs indicate the start and end frames of a sound segment.
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How to change start or end frame of a sound

1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

2. In the Sound Element editor, select a sound sample from the Sound Element section. To distinguish one 
sound section from another on the same sound layer, check the frame numbers that appear on tabs 
flanking the start and stop lines of each waveform section.

Click the Play  button in the Current Sound section (only the selected sound plays).

 1. Within the Sound Element panel, drag the selected clip to the frame number where you want it to start play-
ing. 

You can only move the clip to a section that does not already contain a clip; you cannot overlap two clips in 
the same element.

 2. To change the end frame, drag the yellow marker at the end of the waveform to the frame position.
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 3. To hear how all the clips fit together in the element, click the Play  button  in the Sound Element section.

If you only want to hear the selected clip, click the Play  button  in the Current Sound section.

 4. Click Apply/Next.

The Xsheet and Timeline views display the sound clip at the start frame you selected.

Trimming the Start and End of a Sound File

To play only a section of a sound file, use the Sound Element editor to select the exact part you want to use. For 
example, if there is a bit of noise at the start of the sound, use the Sound Element editor to cut the noise. 

The Sound Element Editor does not change the original sound file; it only plays a section of it, ignoring the rest. This 
means that the entire sound file is included on export. If you need to be mindful of file size, it is better to edit sound 
files completely in a sound editor before bringing them into Harmony.

How to trim the start and end of a sound file

1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

2. In the Sound Element editor, select a sound sample from the Sound Element section. To distinguish one 
sound section from another on the same sound layer, check the frame numbers that appear on tabs flanking 
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the start and stop lines of each waveform section. Or select a soundwave and click the Play  button in 
the Current Sound panel (only the selected sound plays).

 1. Using the Current Sound section, decide on the part of the file you want to play by dragging the left and 
right boundaries of the selection area.

 2. Click the Play  button in the Current Sound section to check that you have trimmed the desired sec-
tions. Use the Zoom slider at the bottom of the panel to zoom in on the waveform so you can trim it more 
accurately.

 3. Click Apply/Next. 

The trimmed sound sample appears in both the Timeline and Xsheet views at the start and end positions 
you selected.

Looping a Sound

To repeat a sound, specify the number of times that you want it to loop in the Sound Element editor.

How to loop a sound sample

1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

 1. From the Sound Element section, select the sound section you want to loop.

 2. In the Current Sound section, type the number of times you want the sound to play in the Number of Loops 
field.
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 3. Press the Enter/Return key. 

The looped sound appears after the current sound. They are indicated by their grey waveforms, as opposed to 
black.

When you loop a sound, the looped sections fill the cells in the sound element (column or layer) until the next 
sound sample starts or until the scene ends. This means that the looping could be cut if the next sound 
sample starts too soon or if the scene ends too quickly.

Mixing the Sound Volume

You can adjust the volume of an entire sound clip or modify the volume in increments by adjusting the fade-in and 
fade-out times, otherwise known as sound envelopes. The fade edit only affects the playback; the original sound file 
is not affected.

How to adjust the overall volume of the entire sound clip

1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

 1. In the Sound Element section, select the sound you want to work on. 

A more detailed version of the selected sound appears in the Current Sound section.

 2. In the Current Sound section, use the Volume slider to adjust the volume.

 3. Click the Play  button in the Current Sound panel to verify the volume.

How to create the fade in/out effect on a sound clip

1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

 1. In the Sound Element section, select the sound you want to work on.
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 2. In the Current Sound section, click on the thin blue line above the waveform to add an envelope marker.

 3. Drag the envelope markers to adjust the volume at that frame and to create the time of the transition. The 
line from the edge of the clip to the envelope marker identifies how the volume increases (fades-in) or 
decreases (fades-out) over time.

Dragging the marker to the bottom of the channel mutes the volume, while dragging it upwards increases 
the volume. 

NOTE: To create an even effect, be sure to adjust the envelope markers uniformly in both the left and right (bottom 
and top) channels.

 4. Click the Play  button in the Current Sound panel to check the fade envelopes.

Customizing the Playback Range

To hear a specific section of the sound element, adjust the playback range in the Sound Element editor to start or 
stop at specific frames. This customized playback range does not affect the actual sound in the Sound element. 

How to change the playback range in the Sound Element editor 

 1. Drag the start or end range markers in the Sound Element section to the boundary frames you want.
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 2. When you click the Play  button to play back your sound in the Sound Element editor, it only plays the 
sound which exists between the two markers.

Adding an Empty Sound Layer
When performing sound editing tasks, it can be useful to chop up a sound sample into different layers. For example, 
when performing a lip-sync, only a single view of the various mouth positions for a character can exist on one layer. 
Therefore, if you want to have a character turn its head from a profile view to a three-quarter view and have mouth 
position changes to fit with the sound sample from these two different views, you would need to cut up the sound 
samples needed for the profile view mouth positions on one layer and the sound samples needed for the three-
quarter view on another.

For this task, you will need an empty sound layer. 

How to add an empty sound layer

 1. In the Timeline Layer toolbar, click the Add Layer button.

 2. From the drop-down menu, select Sound.

An empty (silent) sound layer appears in both the Timeline and Xsheet views.

 3. Rename the layers accordingly by double-clicking on the layer name and renaming it in the Sound Element 
editor. Click Apply/Next to accept the change.
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1. In the sound file you want to grab sounf frames from, click the cell where you want to start the cut and Shift 
+ click on the final cell of the cut. The sample to be cut becomes highlighted.

2. Drag the selection into the empty sound layer below.

 4. You can now continue to cut-up and distribute the sound sample between the two layers or carry on to the 
lip-synching process for each layer and its corresponding facial view.

NOTE: If you need to duplicate your sound layer to keep an unedited copy for safety, select the Duplicate Selected 
Layers button in the Timeline View toolbar. You must customize the toolbar to display this button because it is not 
included in this toolbar by default.

Lip-sync
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Adding a lip-sync to a project can really enhance its quality and storytelling. However, it can be difficult to shape a 
character's mouth to match the sound at a precise frame. 

To solve this problem, Harmony provides a lip-sync feature which analyzes the contents of a sound element and 
generates a mouth chart (see below) based on the eight animation phonemes (A, B, C, D, E, F, G, and X for silence).

The mouth shapes used by Harmony are based on the conventional mouth chart used in the animation industry.

NOTE: The letters used to represent the shapes do NOT correspond to an actual sound.

NOTE: If you are doing cut-out animation, refer to the Cut-out Animation Guide, Character Building chapter, "Adding 
Extra Drawings" topic to learn how to add extra drawings to your character.

Here is an approximation of the sound each mouth shape can produce:

• A: m, b, p, h

• B: s, d, j, i, k, t

• C: e, a

• D: A, E

• E: o

• F: u, oo

• G: f, ph

• X: Silence, undetermined sound

You can lip-sync the traditional way or let the system automatically create the basic detection. 

You can refer to the mouth chart positions as you draw the shape of the character's mouth. 

Generating a Lip-sync Detection

There are several places where you can perform a lip-sync detection: Layer Properties view, Timeline view, Xsheet 
view and Sound Element editor.
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How to generate a sound detection for lip-sync using the Layer Properties view

 1. In the Timeline or Xsheet view, select the sound layer.

The options for that layer will appear in the Layer Properties view.

 2. In the Layer Properties, click Detect.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to 
each sound cell.

 3. Click the Map button to open the Lip-Sync Mapping dialog box.

 4. From the Destination Layer menu, select the layer that contains the mouth positions for the character's 
voice track. 
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 5. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on the layer 
or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to use the 
drawings or select the desired symbol from the drop-down menu.

 6. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the phoneme it rep-
resents. If your drawings are already named with the phoneme letters, you do not have to do anything.

 7. Click OK.

 8. Press the Play  button in the Playback toolbar to see and hear the results in the Camera view. To play 
back your scene with sound, enable the Sound button in the Playback toolbar.

How to generate a  sound detection for lip-sync in the Xsheet or Timeline view

 1. Do one of the following: 

‣ In the Xsheet or Timeline view, right-click on the sound layer's cells and select Lip-Sync > Auto Lip-
Sync Detection. 

‣ From the top menu, select Animation > Lip-Sync > Auto Lip-Sync Detection.

NOTE: To show the mouth chart letters, if they're not already present in the Xsheet view, right-click on the sound 
column and select Lip-Sync > Sound Display > Mouth Shapes. 

Harmony analyzes the selected sound clips and assigns a lip-sync letter to each frame. The X markers in the 
frame are replaced by these designated letters.

How to generate a sound detection for lip-sync using the Sound Element editor

 1. Do one of the following:
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‣ In the Timeline view, double-click on the sound layer.

‣ In  the Xsheet view, double-click on the sound column header.

The Sound Element editor opens.

 2. In Sound Element section, select the waveform for which you want to generate a mouth chart.

 3. Right-click on the sound file and select Auto Lip-Sync Detection.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to 
each sound cell.

Mapping the Lip-Sync Detection

Harmony can automatically map drawings in an element to the mouth chart you have generated for a sound. This 
can save time when you are lip-synching a voice track.

In the Layer Properties view, you can identify each lip drawing of a character. Harmony then automatically labels 
all of the cells in the character's element with the appropriate name.

How to automatically map lip-sync drawings to a mouth layer

 1. To open the Lip-Sync Mapping dialog box, do one of the following:

‣ In the Layer Properties view, click on the Map button.

‣ In the Timeline view, right-click on any cell in the sound sample layer and select Lip-Sync > Map Lip-
Sync. 

‣ From the top menu, select Animation > Lip-Sync > Map Lip-Sync.

The Lip-Sync Mapping dialog box opens.
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 2. From the Destination Layer menu, select the layer that contains the mouth positions for the character's voice 
track. 

 3. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on the layer 
or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to use the 
drawings or select the desired symbol from the drop-down menu.

 4. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the phoneme it rep-
resents. If your drawings are already named with the phoneme letters, you do not have to do anything.

Modifying the Lip-sync

You can change the mouth position assigned to a frame if you think another position is more appropriate. 

For example, you may have a character who says nothing for 10 frames between two speeches. Harmony would 
normally assign an X image for the silent period. However, if you want your character's mouth to hang open in 
astonishment for these 10 frames, you can change the lip assignment for these frames from an X to an F.

If you modify the sound detection, you will need to remap the lip-sync to your animation—see Mapping the Lip-Sync 
Detection on page 348.

How to change the mouth position assignment of a sound from the Sound Element editor and Layer Prop-
erties view

 1. Double-click the sound layer name in the Timeline view or the sound column header in the Xsheet view to 
open the Sound Element editor.
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 2. In the Sound Element section, drag the frame slider to the frame you want to change the mouth position 
assignment on.

In the Lip-sync image area, the image on top represents the lip position assigned to the current frame. 

1. To change the image assigned to the frame, click on the image of the mouth position you want from below 
the preview image. The preview image changes to the mouth position image you select. You can perform 
the same operation in the Layer Properties view.

The position is updated in the Timeline and Xsheet views.

How to change the lip assignment of a sound in the Xsheet or Timeline view

1. Right-click in the cell that contains the mouth position you want to change.

2. From the pop-up menu, select Lip-Sync > Change Mouth Shape to and choose the letter that reflects 
the mouth position you want to use for that sound. You can also select Animation > Lip-Sync > Change 
Mouth Shape > the desired mouth shape from the top menu.

NOTE: Note that if you modify the lip-sync detection you must remap the detection to your mouth layer.

Manual Lip-sync

Harmony allows for the manual swapping of mouth position drawings to match a voice track. For this process, 
both sound scrubbing (listening to a sound wave broken up frame-by-frame) and drawing substitutions are used.

How to animate lip-sync using the Timeline view

 1. In the Playback toolbar, enable the Sound Scrubbing  button.

 2. In the Timeline view, drag the red playhead along the sound layer waveform.
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 3. When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips for 
an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the drawing name 
(often a letter) until it changes to the swapping  pointer.

 5. Pull the cursor to see the list of mouth shape names and choose the one you want. The current drawing auto-
matically changes to the new selection.

How to animate lip-sync using the Library view

 1. In the Playback toolbar, click the Sound Scrubbing  button.

 2. In the Timeline view, drag the red playhead along the waveform of your sound layer.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips for 
an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Drawing Substitution window of the Library view, drag the slider to choose a mouth shape. The current 
drawing is swapped for the one in the preview window.

Exporting a Sound File
At some point during the production, you might need to export a sound file to use it in another application, such as an 
editing software. Harmony allows you to export sound files as a merged soundtrack or as a series of individual files. 
The exported soundtracks are generated as *.wav files.

How to export a soundtrack

 1. From the top menu, select File > Export > Soundtrack.

The Export Soundtracks dialog box opens.
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 2. In the Output section, click Browse and specify where you want to save the exported sound file.

 3. In the Export Range section, select one of the following options:

‣ All: Exports the sound over all the frames of your scene.

‣ Frames: Sets the start and end frames in the corresponding fields on the right.

 4. From the Options menu, select one of the following:

‣ Process Soundtracks Individually: Each soundtrack from all layers is exported as individual files.

‣ Merge all Soundtracks: One single file is created, combining all the sound files you imported in your 
scene. Note that it will only use the sound files in the selected frame range set in the Export Range 
section. If you selected to export all the frames, all the sound files will be processed.

 5. In the Sound Settings section, set the Rate, Size and Use parameters for the soundtracks to export. It is 
a good idea to verify what is required by the software or device that  you may want to use next with the 
sound file.

 6. Click OK.

The generated sound files appear in the selected directory and are named according to the scene name. 
Individual files keep their original name; only a prefix matching the scene name is added.

352



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

Chapter 9: Effects

Once your animation is completed, you can add effects such as blurs and glows to make your project look even 
better! Harmony provides you with a series of essential effects that you can add to your layers.

This chapter contains the following topics:

• Adding Effects  on page 353

• Animating an Effect over Time  on page 371

• How Does an Effect  Work?  on page 373

• Exposure Fill Using Render Change on page 374

• Effects in Harmony on page 377

• Extra Commands  on page 539

Adding Effects 
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In Harmony, you can add effects through the Node view. You can select an effect from the Node Library view, 
drag it to the Node view and connect it to drawing layers to form a network of nodes. Then, by adjusting each 
node's parameters, you can achieve exactly the look you have in mind.

Although all effects should be added through the Node view, there are some effects that you can also quickly add 
through the Timeline view. 

This topic is divided as follows: 

• Node View on page 356

• Node Library View on page 357

• Connecting Effects on page 364

How to use effects with more than one port

 1. Select a drawing layer and do one of the following:

‣ From the Node Library view, select  an effect with more than one port, such as Highlight and drag it to 
the Node view. 

‣ In the Node view, right-click and select Insert > Combine > Highlight. 

 2. Connect the  node (Highlight in this example) between the drawing and Composite node.

 3. In the Drawing or Camera view, create a drawing on a new layer that will act as the matte.

 4. In the Timeline view, click the Collapse/Expand  button on the effect layer.
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 5. Do one of the following:

‣ Drag and drop the matte layer beside the Matte field.

‣ Connect the Matte drawing to the Matte port of the Highlight node.

 6. Display the effect properties and adjust them until you achieve the desired effect.
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Node View

In the Node view, you can connect effects and compositing nodes to form a network, also known as a node 
system. This view is very useful for rigging puppets, creating advanced effects and having a clear view of 
complex scenes. The organization and order of the nodes determines the flow of data during the compositing 
process and how your animation elements will be composited.
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Symbol Stack

When entering symbols, the Symbol Stack lets you navigate back to the top and see the hierarchy of the symbol in 
which you are working.

Node System

The main area of the Node view is where you can add and organize different nodes to represent a scene.

Navigator

The Navigator view lets you pan the visible area to move quickly through extensive node sets.

Search Toolbar

The Search toolbar lets you find and match a node in the project. The search is not case-sensitive. Once you have 
entered characters in the search field, press Enter/Return to validate and find the pattern in the node names. If 
successful, the node is selected and centred in the view. If many instances are found, use the Previous and Next 
buttons to cycle through each node.

Group Navigation

When entering a group, the Group Navigation allows you to navigate back to the top and see the hierarchy of the 
group in which you are.

Node Library View

If you need to add new effects and other nodes to the Node view, you will need to get them from the Node Library 
view.
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When you create a new project in Harmony, the default node system that appears in the Node view looks similar 
to the one below. 

Node Library View Toolbar

In the Node Library View toolbar, you can change how the nodes are displayed. You can display nodes as icons, 
as a textual list or as icons with their names and a description.
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Node Categories

The Node Library view is conveniently divided into several categories:

Category Description

3D Nodes related to working with 3D models within Harmony.

Combine                     Nodes for combining images.

Deformation
Nodes needed for building a deformation chain, as well as advanced effects 
such as Fold and Auto Muscle. The Deformation category is divided into the 
Bone and Distort categories.

Favorites
Nodes most commonly used. To add nodes to the Favorites category, select 
any node from any other section and drag it onto the Favorites category.

Filter
Effect nodes, such as blurs. This category is subdivided into the following cat-
egories: Adjust, Blur, Colour Correct, Isolate and Stylize.

Generator Nodes that create an image, such as a gradient or colour.

Group Nodes for grouping, like Group nodes and Multi-Port-In nodes.

Misc Various nodes including External, Note, Script and Visibility.

Move
Nodes for changing elements over time, like Peg nodes, as well as certain 
transformations.

Output Output (Export) nodes such as Crop, Display, Scale-Output and Write nodes.

Particle
Nodes needed to construct complex particle systems. This category includes 
a series of examples of particle effects and is subdivided into the following cat-
egories: Basic, Examples and Modifier.

Plugins Plugin nodes.

Shading Nodes for light shading.

How to display all the nodes

 1. If a category is selected and you want to see all the nodes available in the library, in the Node Library view, 
place your cursor in the Node Search field.

The Node Library view displays all the nodes.

Adding, Removing and Renaming Categories

Customizing the categories is a great way to organize the nodes according to how you like to work and the nodes 
you use most often. You can easily add categories and subcategories, remove categories you don't use, and 
rename categories.

How to add a category

 1. Do one of the following:
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‣ To create a new main category, click in the Node Search field.

‣ To create a subcategory, select a category.

 2. Do one of the following:

‣ From the Node Library menu, select New Category.

‣ Right-click in the category area and select New Category.

The New Category window displays.

 3. In the New Category window, type in the name of a new category and click OK.

The new category appears in the Category list. Now you can add nodes to your new category—see Adding 
and Removing Nodes on page 362.
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How to remove categories

 1. From the Category list, select a category to remove.

 2. Do one of the following:

‣ From the Node Library menu, select Remove Category.

‣ Right-click in the category area and select Remove Category.

The Confirm Remove Category window displays.

 3. Click Yes.

How to rename categories

 1. From the Category list, select a category to rename.

 2. Do one of the following:

‣ From the Node Library menu, select Rename Category.

‣ Right-click in the category area and select Rename Category.

The Confirm Rename Category window displays.

 3. Type in a new name for the category and click OK.

Adding and Removing Nodes

Once you've created a category, you can add nodes to it for easy access. Later on, you can go back and remove 
any nodes you no longer use. You can only add and remove nodes from a category you created.

When you add a node to a new category, it is essentially a copy of the node. The node in its default location 
remains there. You cannot delete nodes from their default categories or move them.

How to add nodes

 1. Select a node from any category and drag it to a category you created.
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A copy of the selected node is added to your new category.

How to remove nodes

 1. Select a node from a category you created.

NOTE: Nodes from the default categories cannot be removed.

 2. Do one of the following:

‣ From the Node Library menu, select Remove Node.

‣ Right-click in the category area and select Remove Node.

‣ Press Delete.

The node is removed from the category. 

Searching for Nodes, Categories and Descriptions

Sometimes it's faster to type in the name of a node instead of looking through all the categories. You can also search 
for category names or descriptions as well. Once you type in the name of a node, description or category in the Node 
Search tool, it is displayed in the library. Sometimes the result of a node search is in one or more categories for 
convenience. 

How to search for nodes

 1. In the Node Library, place your cursor in the Node Search field.

The Node Library view displays all the nodes.

 2. Type in the name of a node, category or description.
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Depending on how you are viewing the nodes, the Node Library view displays the node, categories and/or 
description you typed in.  

 3. To return to displaying all the nodes, place your cursor in the Node Search field again and delete the node 
name in the Search field.

 

Connecting Effects

To bring a node into the Node view, drag it from the Node Library and drop it in the Node view. Once in the Node 
view, you can click on the input or output port of a node and drag out a cable. You can then connect this cable to 
the output port or input port of another node.

If you want to connect a node between two connected nodes, you can use the Alt key as you drag the new node 
over the existing cable connection. Using the same Alt key, you can also disconnect a node.

If you want to remove a node, select and press Delete to remove it from the Node view.

You can create a simple group or a group with a Composite node. There are several advantages to using the 
Group Selection With Composite command over the simple Group Selection (which references both the Group 
layer in the Timeline view and the Group node in the Node view.

364



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

One of the advantages of using this command is that it groups all the selected elements into a neat node that has a 
nested composite. This means there is only one connection coming out of the Group node. With the simple Group 
node or command, the Group displays the same number of connections as elements in the group. Both grouping 
commands display the same structure in the Timeline view.

The Group Selection With Composite command should only be used before any work has been done in the Node 
view and is recommended for objects whose stacking order is of no consequence.

Using the Group Selection from Composite command on elements that have effects, have been tweaked in the 
Node view, or whose stacking order is of consequence, may cause the grouped elements to lose their properties 
once grouped in this way. In addition, though you may only select a few nodes to group, if there are other layers in 
the Timeline view that exist between the selected layers, they will automatically be grouped, even if not selected.

Once you create a group node, it is easy to enter into or exit from it.

Using the Move to Parent Group command allows you to move the selected node to the parent level, maintaining all 
connections.  If the operation cannot maintain the connections between the nodes, you will be notified and the 
operation will be terminated.

To quickly access parameters for nodes that are grouped, you can use the Publish Attribute Mode feature to select 
your most common parameters to modify and make them appear in the group Layer Properties editor. This way, you 
can access them directly without having to enter the group every time.

Grouping in the Timeline View

You can create a simple group or a group with a Composite node. There are several advantages to using the Group 
Selection With Composite command over the simple Group Selection (which references both the Group layer in the 
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Timeline view and the Group node in the Node view.

One of the advantages of using this command is that it groups all the selected elements into a neat node that has 
a nested composite. This means there is only one connection coming out of the Group node. With the simple 
Group node or command, the Group displays the same number of connections as elements in the group. Both 
grouping commands display the same structure in the Timeline view.

The Group Selection With Composite command should only be used before any work has been done in the Node 
view and is recommended for objects whose stacking order is of no consequence.

Using the Group Selection from Composite command on elements that have effects, have been tweaked in the 
Node view, or whose stacking order is of consequence, may cause the grouped elements to lose their properties 
once grouped in this way. In addition, though you may only select a few nodes to group, if there are other layers in 
the Timeline view that exist between the selected layers, they will automatically be grouped, even if not selected.

Once you create a group node, it is easy to enter into or exit from it.

Using the Move to Parent Group command allows you to move the selected node to the parent level, maintaining 
all connections.  If the operation cannot maintain the connections between the nodes, you will be notified and the 
operation will be terminated.

To quickly access parameters for nodes that are grouped, you can use the Publish Attribute Mode feature to 
select your most common parameters to modify and make them appear in the group Layer Properties editor. This 
way, you can access them directly without having to enter the group every time.
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How to group selected elements in the Timeline view

 1. In the Timeline view, select the elements you want to group. 

Any layers between the selected layers will be automatically grouped as well, so if the stacking order does 
not matter, move extra layers above or below the layers want to group. 

 2. To group, do one of the followings: 

‣ Right-click on the highlighted layers and select Group Selection With Composite. 

‣ Right-click on the highlighted layers and select Group Selection.

‣ In the top menu, select Edit > Group > Group Selected Layers.

The layers appear indented under a new Group layer in the Timeline view and in a new Group node in the 
Node view. 

Previewing Effects
Most effects must be rendered so you can preview them properly. Some effects can be displayed in the OpenGL 
view, but most of them must be rendered and previewed in the Render Mode of the Camera view.

Once you preview your effect, you may want to adjust it. By default, as soon as you modify a parameter, Harmony 
will recalculate the preview image. If your scene is heavy and you do not want the preview rendered automatically, 
deselect the Auto-Render option and do the preview update manually.

You might also need to play back your animation and see the final effect before final rendering. But first, you must 
connect a Render Preview node to each effect.

You cannot play back your animation in Render mode. You must perform a render or a preview render to see your 
animation with the final effects or use a Render Preview node for each effect.  Effects must be calculated before they 
can be viewed in real time.

To make your previews calculate faster, you may want to render them at a smaller resolution. You can use the 
Preview Resolution command so you will not have to modify the resolution of your scene every time you make a 
check preview.

The Preview Resolution command allows you to quickly get a preview at three-quarter, half, one-third, or one-quarter 
of the scene resolution. You can even customize the preview resolution size.

How to preview effects

 1. In the Camera view status bar, click the Render Mode  button.

In the bottom-right corner of the Camera view, the progress bar indicates the status of the render. Depending 
on the size of the frame to render, it may take several seconds.

How to disable the Auto-Render option

 1. In the Camera view status bar, click the Auto-Render  button. In the top menu, you can enable and dis-
able Scene > Render > Auto-Render.

Once the Auto-Render option is disabled, you must request the preview update by clicking the Auto-Render 
 button.
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How to manually update the rendering preview

 1. In the Camera view status bar, click the Render button.

How to preview effects in OpenGL mode 

 1. To adjust the effect's visual controls in OpenGL mode, from the Node Library view, drag a Render Preview 
node to the Node view. Connect it between the effect and the Composite nodes.

 2. In the Camera view, enable the OpenGL  mode to see the rendered effect in OpenGL.

As you modify the effect's parameters and controls, the frames are rendered to ensure a real-time 
playback. The larger the resolution and the heavier the effect, the longer the rendering process will take. 
Green frames are rendered, red frames are pending and yellow frames are rendering.

 3. To display the controls, select the node in the Node view,  and do one of the following:

‣ In the Camera View toolbar, click the Show Control button.

‣ From the top menu, select View > Show > Control.

‣ Press Shift + F11 (Windows/Linux) or ⌘  + F11 (Mac OS X).

The controls appear.
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 4. In the Tools toolbar, select the Transform  tool or press Shift + T.

 5. In the Camera view, adjust the controls.

 6. To set the preview parameters, click the yellow square properties button on the Preview Render node.

The Preview Render properties display.

Parameter Description

Name Allows you to change the node's name.

Preview Resolution
Lets you  set the resolution used to generate the preview. Res-
olutions range from 1/4 to 1/64th of the scene resolution. 

Outdated Images Mode

Do Not Render: Does not render any effects in your scene.

Show Without Effects: Shows the outdated images without any 
effect.

Use Previously Rendered: Uses the previously rendered images. 
The old images will be used until the new ones are rendered.

Pre-render Next Frames Starts a pre-render job for every frame of the timeline.
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How to play back effects

 1. In the Playback toolbar, click the Render and Play  button.

The Play node opens and loads the frames.

 2. Once the frames are loaded, click the Play  button in the Play window.

 3. Select Scene > Render > Cancel Preview Render to cancel the rendering.

NOTE: While previewing effects, you can press the Spacebar to stop and start playback.

How to use the Preview Resolution command

 1. From the top menu, select View > Preview Resolution and one of the following: 

‣ Same as Scene Resolution

‣ 3/4 of Scene Resolution

‣ 1/2 of Scene Resolution

‣ 1/3 of Scene Resolution

‣ 1/4 of Scene Resolution 

‣ Custom

If you selected the Custom option, the Custom Preview Resolution dialog box opens.

 2. In the dialog box, select a resolution from the presets or type a new X-Y value.

 3. Click OK.

 4. Preview your effects animation.
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Animating an Effect over Time 
When compositing your scene, you will often want to animate the parameters of an effect over time. For example, 
you may want an object to fade in or out by changing the transparency level over time or by increasing the colour 
contrast on one of your drawings over a certain frame range.

To animate an effect over time, create a function curve by adding keyframes to the parameters you want to animate. 
To do this, you will use these views: Layer Properties,  Node and Timeline. You can fine tune your animation using 
the Function view.

How to animate an effect over time

 1. Add an effect node to the Node view by doing one of the following: 

‣ Right-click in the Node view and select Insert > desired effect.

‣ Drag a node from the Node Library view to the Node view.

 2. Connect the effect between the drawing element on which you want to apply the effect and a composite 
node. You can do this by manually unplugging and plugging, or by holding Alt as you drag it through a con-
nection. 

The effect also appears in the Timeline view.
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 3. Create the function curve by doing one of the following:

‣ Double-click on the effect layer to display the effect properties. Click the Function  button of the 
parameter you want to animate and create a function curve.

‣ In the Timeline view, expand the effect layer's parameters by clicking the Collapse/Expand  button. 
Then click the Function  button of the parameter you want to animate and create a function curve.

 4. In the Timeline view, go to the frame on which you want to start animating the effect.

 5. In the Timeline toolbar, click the Add Keyframe  button.

 6. In the Value field of the parameter you want to animation, enter the keyframe value. If your keyframes are 
stop-motion keyframes, in the Timeline view, select the new keyframes. Right-click and select Set 
Motion Keyframe.
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 7. Repeat this process for each keyframe to be added.

NOTE: Refer to Previewing Effects on page 367 to learn how to preview animated effects.

How Does an Effect  Work? 
An effect always needs a drawing connection and sometimes a matte or shape connection. A matte provides 
drawing information that determines the area on which the effect will be applied on the drawing. The details and 
colours within the matte drawing don't matter, as only the shape and transparencies are used. A matte is also known 
as mask.

The matte principle can be demonstrated with the Cutter effect.

In general, a drawing layer is connected to the right port of the effect and the matte (mask) to the left. 

The Cutter effect cuts out a portion of an image using a matte drawing. You can use the Cutter effect to allow a 
character to disappear behind a background element or to cut a virtual hole into the layer itself. The Cutter requires a 
matte input.

Adjust the Cutter properties to invert the effect of the matte on an image. Instead of the object being hidden by the 
mask, it will only be visible where it intersects with the matte shape area. 

You can adjust the effect parameters in the Layer Properties view and link any of them to a function column to be 
animated over time. This means that all of the effects can be customized.
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If, in addition to having one layer cut by another layer, you still want to see the cut layer, drag another connection 
from that drawing node's port and connect it to the composite.

Exposure Fill Using Render Change
A frequent effect applied at the compositing stage is texture overlay. Either a shaky textured line will be applied 
on an animation or colour fills will be replaced with textures. Most of these effects are created using the Colour 
Override effect—see Colour-Override  on page 428.

You can replace a colour fill with a static or animated texture. For an animated texture, you can fill a character's 
wool sweater with four or five variations, filling the sweater zone and loop it throughout the sequence. This way 
the final animation can have a bit more of an organic style with moving textures and shaking lines.

You might also want to control when the textures move. When your character is still, you might want the texture 
to remain still as well. You could also want the texture to remain still if the character only moves slightly. You can 
control when the texture will move based on the animation motion. You can set the parameters that define what is 
considered a big enough change for the texture to start moving.

The motion analysis is based on the rendered images sent to a Display node. You can use the main Display node 
set below your final Composite node or add a specific Display node to analyze a specific portion of your node 
system, such as a character's sweater layers—see Display Concepts on page 193. 

NOTE: To help display the scene, use the Advanced Display. In the Preferences dialog box, select the Advanced 
tab, then select the Advanced Display option. This allows different views to use individual Display nodes. 

The Exposure Fill Using Render Change command can be applied on any drawing or bitmap layer, but the most 
common case where this feature will be used is on a bitmap or drawing layer connected in a Colour-Override's 
texture port—see Overriding a Colour with a Bitmap Image Sequence on page 440. The overridden colours should 
use the Texture - Use Image Input setting. Note that you might need to parent your character's master peg to the 
texture layer for the texture animation to follow your character.
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NOTE: The Exposure Fill Using Render Change command modifies the timing (exposure) of the selected layer. If you 
modify the character animation, you may need to reapply the exposure fill as the texture's exposure might no longer 
give the same final result.

How to use the Exposure Fill Using Render Change option

 1. In the Timeline view, select the textures or live-action sequence.

 2. From the top menu, select Scene > Default Display > desired Display node.

 3. From the top menu, select Animation > Exposure Fill > Using Render Change.

Wait while Harmony creates a low resolution render of the images to preview.
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 4. In the Fill Exposure Using Render Changes window, use the Frame slider to view the motion change ana-
lysis.

 5. Based on your style preference, adjust the parameters to assign when the texture exposure changes will 
occur. You can adjust the type of filter to use for the motion detection, as well as threshold values to indic-
ate what will be considered a big enough motion variation for an exposure change. 

Parameter Description

Changes Detection Settings

Frame: Use the slider to see when a change is necessary. A red edge indic-
ates there is a large enough motion for the texture to change.

Use: Lets you use either the Red, Green, Blue, or Alpha channel, or Lumin-
ance difference between frames to analyze the motion changes. The Alpha 
channel is selected by default as it is the most commonly used parameter.

Pixel Value Change Threshold: The percentage of change in a pixel to be 
considered different from one frame to another. The higher the value, the more 
change is required when comparing two images in order for a new texture to be 
used.

Area Change Threshold: The percentage of non-empty pixels that must 
change from one frame to another to be considered different.

Fill Settings

These settings let you change the exposure. You can also decide on how 
many images you want to cycle. 

First/Last Frame: Lets you set the first and last frame for the exposure 
change. You can set this for the entire scene or for part of the scene (frames 20 
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to 32 for example).

 Number of Drawings in Cycle: Lets you set of the number of drawings to 
include in the cycle.

 First Drawing Used in Cycle: Lets you set the first drawing used in the cycle. 
Your drawings must be named using numeric values only, or number values 
with a prefix or suffix. It cannot only be letters.

 Drawing Name Prefix: Adds a prefix before the number. For example, 
texture_01, texture_02 and so on.

 Drawing Name Suffix: Adds a suffix after the number. For example, 01_tex-
ture, 02_texture and so on.

 

 6. Click OK.

The selected layer's exposure is updated. If you modify the exposure of motion in your animation, you may 
need to repeat this procedure.

Effects in Harmony
Here is the list of the main effects available in Harmony. Each effect and how to use it is described in the 
corresponding section.

• Anti-Flicker  on page 379

• Apply Peg Transformation on page 380

• Apply Image Transformation on page 385

• Auto Patch on page 387

• Blending  on page 389

• Bloom on page 394

• Blur - Box on page 397

• Blur - Gaussian on page 401

• Blur-Directional  on page 399Blur-
Directional  on page 399

• Blur - Radial   on page 403Blur - Radial   on 
page 403

• Blur - Radial Zoom on page 404

• Motion-Blur  on page 507

• Blur-Variable on page 415

• Brightness and Contrast  on page 410

• Contrast  on page 453

• Contrast  on page 453

• Cutter on page 455

• Dither  on page 457

• External  on page 458

• Field Chart on page 
461

• Focus  on page 465

• Focus Multiplier  on 
page 467

• Glow  on page 469

• Glue  on page 471

• Gradient  on page 473

• Grain  on page 476

• Greyscale  on page 
477

• Grid on page 480

• Median on page 502

• Motion-Blur  on page 
507

• Multi-Port-In  on page 
508

• Multi-Port-Out  on page 
509

• Negate on page 510

• Note  on page 511

• Overlay Layer  on page 
512

• Pixelate  on page 514

• Quake on page 515

• Quadmap  on page 517

• Refract  on page 519

• Remove Transparency  
on page 520

377



Chapter 9: Effects     

• Channel Selector  on page 416

• Channel Swap on page 418

• Chroma-Keying on page 419

• Colour Art  on page 423

• Colour Banding on page 424

• Colour-Card  on page 426

• Colour-Override  on page 428

• Colour-Scale  on page 447

• Highlight  on page 482

• Hue-Saturation on 
page 486

• Image Switch on page 
489

• Layer Selector  on 
page 490

• Lens Flare on page 
492

• Line Art on page 494

• Luminance Threshold 
on page 496

• Matte-Blur  on page 
498

• Matte-Resize  on page 
500

• Shadow  on page 522

• Sparkle  on page 524

• Tone  on page 526

• Transparency  on page 
529

• Turbulence on page 531

• Turbulent Noise on page 
534

• Underlay Layer on page 
537

• Visibility on page 581

For more information:

•   See the Deformers effects in the Cut-out Animation guide.

•  Working with the Node View on page 167, Composite Node on page 172 and Managing a Node System 
with a 3D Scene Setup on page 232.

•  Display Concepts on page 193.

• Previewing Effects on page 367.

•  Rendering Images and Movies from the Node View on page 641 and Multiple Renders on page 633.

•  Locking Flat Drawings to the Camera Angle on page 229.

•  Animating a Camera Shake Using the Quake Node on page 258.

•  Particles on page 541.

• Possible Artifacts Resolved with Z-Buffer Smoothing on page 326.
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Anti-Flicker 

Use the Anti-Flicker to compensate for flickering in your output to TV formats. The Anti-Flicker effect applies a 
vertical blur to the rendered output. You should place the Anti-Flicker before a Write node in the Node view.

Use the Anti-Flicker editor to control the amount of blur that is applied to rendered output. In the Radius field, enter a 
value for the number of pixels to be considered in the blur.
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Apply Peg Transformation

Use the Apply Peg Transformation node to apply a transformation coming from a Peg, Ortholock, or Quadmap 
node on a single node or a group of nodes. When using the drawing layer's No Clipping option, you can use this 
node to apply all Camera and Peg transformations once all of the effects and nodes connected above the drawing 
node are calculated.

You can use this effect node to create a simple highlight on a cut-out puppet or use the No Clipping option 
available in the drawing layer.

The No Clipping option, found under the drawing Layer Properties' Advanced tab is used when you do not want to 
crop your images before all effects are applied to your drawing. No camera motion or peg transformation will be 
applied to your drawing until you connect an Apply Peg Transformation.

NOTE: Refer to Positioning an Element Using the Layer Properties View on page 141 to learn more about the 
drawing layer's Advanced tab.

The advantage of this node is that you can create a second output of your image or puppet and offset it, scale it or 
apply any kind of transformation on it.

The transformations set in the Peg, Ortholock, or Quadmap node connected to the Apply Peg Transformation 
node are applied BEFORE the image is composited.

Here is an example of how to connect the Apply Peg Transformation node:
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The transformation set in the Peg node from the example above is applied before the image is composited, which is 
the equivalent of the following network:

In the following images you can see the result of the transformation without the Apply Peg Transformation node and 
with it:
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Using the Apply Peg Transformation you can apply transformation on drawings that are outside the camera frame 
and make them appear inside the frame.

If you are using the Apply Image Transformation node to create a drop-down shadow for a character, it will work 
correctly so long as the character is not going outside of the camera frame or that the drawing connected in it is a 
VECTOR drawing. The reason is the Apply Image Transformation node applies the transformation once the 
drawing is rendered, moved by its own set of Pegs, motion paths and quadmap and cropped to the camera frame 
size. This crop operation does not occur if the drawing is a vector drawing (*.TVG). Although, as soon as the 
drawing is passed through an effect node or a bitmap type Composite node, the drawing is turned into a bitmap 
image and gets cropped.

So, if you offset a bitmap half inside and half outside the camera frame, the outside part is cropped out and then 
moved by the Apply Image Transformation node. A part of the original drawing is cut. You need to use the Apply 
Peg Transformation node for the transformation to be applied before the image is processed and cropped.
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Advanced Apply Peg Transformation 

You can use the Apply Peg Transformation's middle port to apply the transformation you connected to the node after 
one of the Peg or Quadmap connected above the drawing node.

In the following example, two pegs were added to control the different motions on independent trajectories:

• Peg-Translation

• Peg-Scale
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When there is no Apply Peg Transformation node, the Peg-Translation is the first trajectory to affect the drawing 
node. Then, once the translation is applied, the Scale trajectory affects the drawing node.

When using an Apply Peg Transformation node without using the middle port, the Peg-Rotation connected in the 
APT node is applied at the top of everything. The order in which the trajectories are applied to the drawing node is:

 1. Peg-Rotation

 2. Peg-Translation

 3. Peg-Scale 

When the Peg-Translation is connected in the Apply Peg Transformation's middle port, the Peg-Rotation is 
applied after the Peg-Translation and before the Peg-Scale. This means that the translation is done before the 
rotation instead of the rotation before the translation.

The order in which the trajectories are applied to the drawing node is:

 1. Peg-Translation

 2. Peg-Rotation

 3. Peg-Scale

Use the Apply Peg Transformation editor to rename the node.
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Apply Image Transformation

The Apply Image Transformation effect is mainly used when you want to pan an object out of the camera frame and 
that object has an effect such as a Glow or a Blur on it. When you use a peg or the Apply Peg Transformation node to 
translate an object such as the sun out of the camera frame, as soon as the sun starts to go outside of the camera 
frame, the sun's circle is cropped and the blur is applied on the shape left over. This also means that when the sun is 
completely out of the frame, the Blur is not calculated anymore and the Blur pops out.

To prevent this from happening, you must use the Apply Image Transformation node to pan the sun out.

The Apply Image Transformation node applies the panning transformation once the full drawing of the sun is blurred, 
once the image is composited. Here is an example of this network:

Here is how to connect the Blur effect for a sun panning out:

Here is the visual result of the blurred sun:
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Look at the following example to understand better why using the Apply Image Transformation instead of a regular 
peg or the Apply Peg Transformation node.

The normal rendering behaviour is to crop the image before applying the effects. When planning a sunset using 
either a Peg or the Apply Peg Transformation node, as soon as the drawing of the sun is out of the camera frame, 
the drawing is cropped and there is no image left to blur. This means that the glowing edge pops out of the camera 
instead of panning out gradually. Using the Apply Image Transformation node, the image is blurred before being 
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panned out, so this means that even once the drawing is out of the camera frame, its glowing edge will still show 
until the drawing is far enough from the camera border. This way, there is no pop when panning out blurred objects.

Use the Apply Image Transformation editor to change the name of the node.

Auto Patch

The Auto Patch node is used mainly when creating joint patches for cut-out puppets drawn with pencil lines and 
painted in the Colour Art layer. Instead of removing a portion of the outline to attempt to create a seamless joint, you 
can draw complete pieces, and with the Auto Patch node, automatically create a perfect articulation.

The requirements for this effect to work are:

• Drawing outlines must be drawn in pencil lines

• Drawing outlines must be drawn in the Line Art layer

• Drawing fill colours must be painted in the Colour Art layer

Pencil lines are central vector lines. The vector is located along the centre of the line. This means that when you 
paint a zone delimited by a pencil line, the colour fill will expand to the centre of the pencil line.

When using the regular patch technique, recommended for the brush line, the result with pencil lines is very odd 
looking because the colour fill zone is bigger than the pencil line inner contour.
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Instead of using the regular patch method, you can use the Auto Patch node. It will automatically extract the 
Colour Art and clip it to the right size. Then, you can connect it in front of the piece to be covered.

The node connection for the Auto Patch is quite simple. Once your basic character rigging is done, add the Auto 
Patch node to the joints you want to cover. There is no need to set any parameters.
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Blending 

Effects nodes, like the Tone node and Highlight node, can control the colour and alpha composite operations for you. 
These nodes were created with preset colour and alpha composite operations to fit the most frequently used, 
composite operations.

You might, however, still want to control the colour and alpha composite operation between two images using the 
Blending node, to create a multiplicity of lighting, shadow, filter or ambient effects. The Blending node combines two 
images into one output image, following the parameters you choose for your movie and images sequence or SWF 
movie exports.

The drawing node connected to the Blending effect will act as the blending image and will be applied to all the 
drawing layers situated under them in the Composite node or Timeline view order.
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Blending Properties

Parameter Description

Name Lets you rename the node.

Blend Mode and SWF Blend 
Mode

Choose the blending effect mode you wish to apply to your layer. The Blend 
Mode type will only be visible when the Camera view is set to Render  
mode and will only export to a bitmap movie file or sequence of images.

Both the Blending node and Composite-Generic node have regular blending 
modes and legacy blending modes. The regular blending modes will take the 
source images and unmultiply them before blending the two inputs together. 
The images will be remultiplied when being output from the  node. The legacy 
blending modes use the pre-multipled source images as is in order to apply the 
effect. Unmultiplying the images before processing them will give a final result 
closer to what can be found in software such as Adobe Photoshop.

• Normal: The layer attached to the effect acts as a normal layer and will 
not create any blending mode effect.

• Multiply: This operation multiplies the blending element colour with the 
output image. This will darken the colour of the overlapping area.

• Screen: This operation multiplies the inverted colour of the blending 
element with the image. This will lighten the colour of the overlapping 

390



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

area.
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• Lighten (Lighten Legacy): This operation lightens the area of the 
output image which, is darker than the blending element’s colours. The 
lighter colours will remain unchanged.

• Darken: This operation darkens the area of the output image, which is 
lighter than the blending element’s colours. The darker colours will 
remain unchanged.

• Difference  (Difference Legacy): This operation subtracts the 
blending elements colour from the output image colours or vice-versa, 
depending on which of them has more bright colours. The final result will 
be colours that are more vibrant.

• Add (Add Legacy): This operation lightens the output image using the 
blending element.

• Subtract (Subtract Legacy): This operation darkens the output image 
using the blending element.

• Invert: This operation inverts the output image colours on the area 
overlapping the blending layer colours.

• Overlay (Overlay Legacy): This operation multiplies or screens the 
colours from the blending image, with those of the output image, 
depending on the base colour. Colours from the blending element 
overlay the colours of the drawing elements, while preserving the 
highlights and shadows of the base colour. The base colour is not 
replaced, but mixed with the blend colour to reflect the lightness, or 
darkness, of the original colour.

• Hardlight(Hardlight Legacy): This operation multiplies, or screens, 
the colours of the blending layer with those of the output image, 
depending on the blend colour. If the blend colour is lighter than 50% 
grey, the image is lightened, as if it were screened. This is useful for 
adding highlights to an image. If the blend colour is darker than 50% 
grey, the image is darkened, as if it were multiplied. This is useful for 
adding shadows to an image. Painting with pure black or white results in 
pure black or white. Play with the Opacity value to create a subtler look.

• Alpha: This operation will blend the alpha value of the blending layer 
with the output image. This effect is not available for SWF Blend Mode.

• Erase: This operation produces a cutter effect using the blending 
element. This effect is not available for SWF Blend Mode.

• Divide (Divide Legacy): This operation divides the output image colour 
values by the blending layer colour values. The blending image colour 
values are inverted, creating a negative image. The negative image’s 
colour values are then multiplied by the right image colour values. This 
effect is not available for SWF Blend Mode.

• Replace: This operation replaces the output image by the blending 
layer. This effect is not available for SWF Blend Mode.

• Softlight: This operation darkens or lightens the colours in a soft and 
diffuse way, depending on the blend colour (image in left port). If the 
blend colour is lighter than 50% grey, the image is lightened. If the blend 
colour is darker than 50% grey, the image is darkened. Painting with 
pure black or white produces a distinctly darker or lighter area, but does 
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not result in pure black or white. 

• Linear Light: This operation burns or dodges the colours by decreasing 
or increasing the brightness depending on the colour of the underlying 
colour. If the blend colour is lighter than 50% grey, the colour is 
lightened because the brightness is increased. If the blend colour is 
darker than 50% grey, the colour is darkened because the brightness is 
decreased.

• Pin Light: This operation will replace the colours, depending on the 
underlying colour . If the blend colour is lighter than 50% grey, pixels 
darker than the underlying colour are replaced, and pixels lighter than 
the underlying colour do not change. If the blend colour is darker than 
50% grey, pixels lighter than the underlying colour are replaced, and 
pixels darker than the underlying colour do not change.

• Vivid Light: This operation burns or dodges the colours by decreasing 
or increasing the brightness depending on the colour of the underlying 
colour. If the colour is lighter than 50% grey, the blend colour is 
lightened because the contrast is decreased. If the colour is darker than 
50% grey, the blend colour is darkened because the contrast is 
increased.

• Exclusion: This operation produces a similar result to the Difference 
mode, but with a lower contrast. 

• Dodge: This operation will lighten the colour.

• Burn: This operation will darken the colour.

• Hue: This operation will result in a colour that will take the luminosity 
and saturation of the underlying colour, and the hue of the source colour.

• Saturation: This operation will result in a colour that will have the same 
luminosity and hue of the underlying colour, and the saturation of the 
source colour.

• Colour: This operation will result in a colour that will have the 
luminosity of the underlying colour, and the hue and saturation of the 
source colour.

• Luminosity: This operation will result in a colour which has the hue and 
saturation of the underlying colour, and the luminosity of the source 
colour. This mode is opposite to the Colour mode. 

NOTE: It is possible to select two different blending modes in the same Blending effect layer, in the event that  you 
want to export your project to both a Bitmap and an SWF movie file with different results.
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Bloom

The Bloom effect is used to make a specular area blurrier on a bitmap image, such as street lamps at night.

It's  a combination of the Luminance Threshold, Cutter, Blur - Gaussian and Composite Generic nodes—see 
Luminance Threshold on page 496, Cutter on page 455 Blur - Gaussian on page 401, and Composite-Generic  on 
page 449.
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Bloom Properties

Parameter Description

Name Allows you to change the node's name.

Threshold

 

Controls how much of the dark value to clamp off. A high value will keep only the bright areas 
of your image.
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Soften Colours

Brings back the entire spectrum of luminance in areas defined by the threshold to avoid 
having only bright values.

Gamma Correction

Multiplies the gamma value to make the area brighter or darker.  A value of 1 keeps the 
gamma the same as the original image.  You can use the gamma modification on the whole 
image if you use a threshold of 0 for example.

Output Greyscale 
Matte

Allows you output an image in grey values to use in combination with a Blending or Cutter  
node elsewhere in the node structure.
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Invert Matte Lets you invert the mask shape if you connected a mask image to the node's left port.

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo a change of 
depth or scale. When this option is deselected, the effect's values remain unchanged 
regardless of any depth or scale changes. This option should be deselected when multiple 
drawings are composited and attached to this effect.

Radius Adjusts the amount of blur applied to the image.

Quality
Controls the quality of the blur. A higher quality yields better results, but will be slower to 
render.

Composite with 
Source Image

Blends the area defined by the threshold with the original image.

Blend Mode
Defines the blending mode between the original image and the area defined by the threshold 
to avoid having to add a Composite Generic node after the Bloom node.

Blur - Box
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The Blur - Box effect  is a quick and easy way to create a blurring effect. The Box blur changes the colour value of 
each pixel based on the pixels next to it in the vertical and horizontal directions. The look of the blur is similar to 
the look achieved using Gaussian blur, but renders much faster. This effect is useful when a fast rendering time is 
important, and the quality of the blur is less important. Also, you can use a matte with this effect to isolate areas 
of the image.

For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/video-
tutorials/chapter/adam-phillips-harmony-effects.

Blur - Box Properties 

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo 
a change of depth or scale. When this option is deselected, the effect's values 
remain unchanged regardless of any depth or scale changes. This option 
should be deselected when multiple drawings are composited and attached to 
this effect.

Repeat Edge Pixels
Makes the blur algorithm operate as if the pixel values beyond the edge of the 
layer are the same as the values of the edge pixels. This keeps edges sharp, 
preventing them from darkening and becoming more transparent.
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Blurriness Amount of blur applied to the layer.

Directional
Blurs according to the length, width, and angle you specify. For example, if a 
character is walking east, the blur may fall to the west.

Radius

Size of the blur. The larger the value, the greater the strength or reach of the 
blur. The blur radius is affected by the drawing scale and camera position. 
Click the Edit Curve button to change these values over time by adjusting the 
function curve.

Length Length of the blur.

Width Thickness of the blur.

Angle
The direction in which the blur is applied: sideways, up, down,  90 degrees, 45 
degrees, and so on.

Bidirectional Applies the blur on both sides of the pixel.

Fall Off

The distance where the blur fades from the edge of the image. Select a value 
between 0 and 1. A fall-off rate of 0 causes the blur to fade out slowly, dis-
tributing the blur evenly from the edge of the character to the farthest edge of 
the blur. A fall-off rate of 1 causes the blur to fade out quickly, so the blur is 
heaviest closer to the edge of the image.

Number of Iterations
The number of times the blur is applied to the image. A higher number of iter-
ations creates smoother transitions between colours and increases the blur, 
but also increases render time.

Precision
Precision: Blurs the image the number of times the precision indicates at 
different radius (between 0 and the specified radius).

Blur-Directional 

The Blur-Directional effect creates the effect of a motion blur that pulls and smears the image from one contour edge 
to a different direction or angle. This effect is useful in creating the impression of speed, such as the streaks of 
colour that follow a car travelling at high speed.
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Use the Blur-Directional editor to control the settings of the Blur-Directional effect.

Blur-Directional Properties

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo 
a change of depth or scale. When this option is deselected, the effect's values 
remain unchanged regardless of any depth or scale changes. This option 
should be deselected when multiple drawings are composited and attached to 
this effect.

Radius

Size of the blur. The larger the value, the greater the strength or reach of the 
blur. The blur radius is affected by the drawing scale and camera position. 
Click the Edit Curve button to change these values over time by adjusting the 
function curve.

Falloff Rate

The distance where the blur fades from the edge of the image. Select a value 
between 0 and 1. A fall-off rate of 0 causes the blur to fade out slowly, dis-
tributing the blur evenly from the edge of the character to the farthest edge of 
the blur. A fall-off rate of 1 causes the blur to fade out quickly, so the blur is 
heaviest closer to the edge of the image.
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Angle

The direction of the blur. Enter a value from 0 to 360.

0: Blurs the image to the west.

90: Blurs the image to the south.

180: Blurs the image to the east.

270: Blurs the image to the north.

Direction of trail
If you do not set an Angle for the direction of the blur, you can select a direction 
(north, south, east, or west) from this menu. The calculations for this feature 
are faster than the calculations for the Angle setting.

Ignore Alpha
Controls the leading edge of the blur. Deselect this option for a solid or hard 
leading edge on the blur.

Extra Final Blur
Adds a second blur after the Blur-Directional is created. If you have a Blur-Dir-
ectional that begins at 0 and gradually gets stronger, deselect this option to 
ensure a smooth progression.

Number of Iterations
The number of times the blur is applied to the image. A higher number of iter-
ations creates smoother transitions between colours and increases the blur, 
but also increases render time.

Blur - Gaussian

The Blur - Gaussian effect softens the image, reducing the amount of noise and detail. The look of the Gaussian blur 
is smooth, but does take some rendering time. This effect is useful when rendering time is less important, and 
quality is more important. Also, you can use a matte with this effect to isolate areas of the image.

For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/video-
tutorials/chapter/adam-phillips-harmony-effects.
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s

Blur - Gaussian Properties 

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo 
a change of depth or scale. When this option is deselected, the effect's values 
remain unchanged regardless of any depth or scale changes. This option 
should be deselected when multiple drawings are composited and attached to 
this effect.

Repeat Edge Pixels
Makes the blur algorithm operate as if the pixel values beyond the edge of the 
layer are the same as the values of the edge pixels. This keeps edges sharp, 
preventing them from darkening and becoming more transparent.

Blurriness

Directional
Blurs according to the length, width, and angle you specify. For example, if a 
character is walking east, the blur may fall to the west.

Blurriness Amount of blur applied to the layer.

Horizontal Blurriness Length of the blur.

Vertical Blurriness Thickness of the blur.

Angle
The direction in which the blur is applied: sideways, up, down,  90 degrees, 45 
degrees, and so on.
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Bidirectional Blurs in both horizontal and vertical directions.

Matte
Precision: Blurs the image the number of times the precision indicates at 
different radius (between 0 and the specified radius).

Blur - Radial  

The Blur-Radial effect creates an effect that softens, fogs or obscures the image evenly in all directions. This effect 
is useful when you want to make cloudy images not realistically seen in detail, such as a drawing object that is 
farther back or in the background of your scene, usually blurry due to the laws of atmospheric perspective. Other 
uses include the general softening of objects such as snow, stars and shadows that do not naturally have a hard 
outline.

Use the Blur-Radial editor to change the values of the Blur effect.
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Blur-Radial Properties

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo 
a change of depth or scale. When this option is deselected, the effect's values 
remain unchanged regardless of any depth or scale changes. This option 
should be deselected when multiple drawings are composited and attached to 
this effect.

Radius

Size of the blur. The larger the value, the greater the strength or reach of the 
blur. The blur radius is affected by the drawing scale and camera position. 
Click the Edit Curve button to change these values over time by adjusting the 
function curve.

Quality
Select High for a slow and accurate operation or Low for a faster operation with 
a more raw look.

Blur - Radial Zoom
The Blur - Radial Zoom effect creates blurs around a centre point, simulating the look of a zooming or rotating 
camera. You can use a matte to isolate the area of the image from which you want the effect to radiate from. For 
example, in the illustration below, a circular matte was created to mask the eyeball and a Negate effect was 
applied so the blur is outside the matte. Then the centre point was positioned on the character's iris, which is the 
centre of the matte.

For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/video-
tutorials/chapter/adam-phillips-harmony-effects.
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How to use the Blur Radial Zoom

 1. In the Camera view, enable the Render mode.

 2. From the Node Library view, drag a Blur Radial Zoom node to the Node view.

 3. Connect your drawing to the Blur Radial Zoom's right port.

 4. Connect the Blur Radial Zoom node to the Composite node.

 5. On  the Blur Radial Zoom node, click the yellow square properties button to open its property editor.

 6. In the Layer Properties windowo, increase the Blurriness value.
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 7. In the Direction section, click on any of the direction presets to modify the blur spin or zoom.

How to create a radial-zoom blur around an isolated area

 1. Connect a drawing and a background image to a Composite node.

 2. Connect the Composite node to the Blur-Radial Zoom node.

 3. Connect a Blur-Radial-Zoom node to the Composite node and add the Write and Display nodes.
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 4. Create a matte to isolate an area of the image. In the Timeline view, click the Add Layers  button and 
select Drawing. Give the layer a name, such as Mask.

 5. In the Drawing view, draw a filled shape. 

 6. The blur should radiate outwards from the mask. To do this, connect a Negate node to the mask. In the Neg-
ate properties, select the Negate Colour and Negate Alpha options. Deselect the Negate Colour Clamp 
to Alpha option. 

 7. Connect these nodes to the rest of the tree. Your node structure should look like this:
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 8. In the Blur - Radial Zoom property editor, Center section,  select one of the following options:

‣ 2D Path: Lets you move the centre point visually in the Camera view.

‣ Separate: Lets you control the x and y axis by entering values in the fields or by moving the centre 
point in the Camera view.

 9. Set a value for the Blurriness.

 10. With the Blur - Radial Zoom node selected in the Node view, select View > Show > Control or press Shift 
+ F11. 

A red centre point appears in the centre of the Camera view.

 11. In the Tools toolbar, select the Transform  tool.

 12. Click the Animate Mode  button in the Tools toolbar if you want to create function curves to keyframe 
over time. Otherwise, values will be created for the duration of the scene.

 13. Move the centre point to the desired position. In our example, the centre was moved to the centre of the 
mask.

 14. In the Node view, select the mask you created. 
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 15. In the Camera view, move the mask to the desired position.

 16. Continue to adjust the blur values until you achieve the desired effect.

Blur - Radial Zoom Properties 

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo a 
change of depth or scale. When this option is deselected, the effect's values 
remain unchanged regardless of any depth or scale changes. This option should 
be deselected when multiple drawings are composited and attached to this effect.

Focus

2D Path: Lets you move the centre point visually in the Camera view.

Separate: Lets you control the x and y axis by entering values in the fields or by 
moving the centre point visually in the Camera view.

(x) and (y) Axis
When the Separate type of centre is selected, lets you individually set the x and y 
coordinates for the centre.

Blurriness Amount of blur applied to the layer.

Variation

Constant: An equal, constant blur is applied on all pixels.

Linear: A gradual blur is applied on all pixels.

Quadratic: An exponential blur is applied on all pixels.

Direction Lets you select preset blur types or create a custom blur.

Presets
A set of preset radial, zoom, and spiral blurs to get you started. You can then 
adjust the type to customize the blur.
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Custom Create your own blur by entering a value for the direction of the blur lines.

Fall Off

The distance where the blur fades from the edge of the image. Select a value 
between 0 and 1. A fall-off rate of 0 causes the blur to fade out slowly, distributing 
the blur evenly from the edge of the character to the farthest edge of the blur. A 
fall-off rate of 1 causes the blur to fade out quickly, so the blur is heaviest closer 
to the edge of the image.

Bidirectional Applies the blur on both sides of the pixel.

Quality
Affects the quality of the blur by defining how fine the reference radial grid is on 
the image.  This determines the width of all the wedges.   A higher quality yields 
achieve better results, but will be slower to render.

Matte
Precision: Blurs the image the number of times the precision indicates at 
different radius (between 0 and the specified radius).

 

Brightness and Contrast 

The Brightness and Contrast effect lets you modify the brilliance or dullness of an image or to create a greater 
difference between the lights and darks of an image by increasing their respective intensities. This effect can be 
used when an image appears too flat. Increasing the brightness or contrast can give a drawing a more attractive 
and 3D quality. This can be useful if you want to push your background to the rear by making it look dull and flat 
and pulling your foreground elements to the front by giving them a higher contrast.
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Brightness and Contrast Properties

Parameter Description

Brightness
A value less than 0 will darken the image; a value greater than 0 will brighten it. 
Attach a Bezier or Ease function to change the brightness over time.

Contrast
A value less than 0 will reduce contrast; a value greater than 0 will increase con-
trast. Attach a Bezier or Ease function to change the contrast over time.

Legacy Brightness/Contrast
If you are using an older version of this effect, the Legacy Brightness and Legacy 
Contrast options are automatically selected. This ensures that the resulting effect 
looks the same as in older versions.
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Burn-In

The Burn-In effect lets you add scene information which is visible in the Camera view. The information is 
displayed on top of any content in the scene. You can choose to display the scene name, timecode, frame count, 
environment and job, as well as add a frame offset if you need blank frames to precede the scene content. Also, 
to make the information more visible, you can also add a background and choose its colour, and customize the 
text font and alignment.

When you attach a Burn-In node to a Composite node, the burn-in information is rendered when you export the 
scene—see Export on page 619.

NOTE: When you're working with 3D objects with a high Z position value, you may find the objects obscuring the 
scene information. To work around this, use a peg to ensure the burned in scene information is always visible.

How to add burn in scene information

 1. In the Node Library, drag a Burn-In node to the Node view.

 2. Connect it to the Composite node.
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 3. On the Burn-In node, click the square yellow properties button. 

The Burn-In property window displays.

 4. In the Show section, enter the following information:

‣ Frame Number: The frame number to start the burn-in information.

‣ Time code: The time code at which the burn-in information starts.

‣ Scene name: By default the scene name, environment and job information is display. Type the following 
to display specific types of information. 

Scene Name: %s

Environment: %e

Job: %j

‣ Frame Offset: Add lead-in frames before the scene begins or at a specific frame. Use positive values for 
frames that precede the scene content and negative values to start your scene information at a certain 
frame number.

 5. In the Text section, customize the text that is displayed.

 6. In the Background section, add a background box to make the text more visible and then customize the col-
our.

Burn-In Properties

Parameter Description

Name Allows you to change the node's name.
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Show

Frame Number Displays the number of the current frame.

Time Code Displays the time code of the current frame.

Scene Name

Lets you display different types of information, including the scene name, envir-
onment and job. You can display one or all of these pieces of information. To do 
so, type the following in the Scene Name field:

• Scene Name: %s

• Environment: %e

• Job: %j
You can rearrange the order in which the information is displayed. For example, 
you may want to see the job before the environment.

Frame Offset
Lets you add blank lead-in frames before the scene or somewhere in the scene. 
Use positive values for frames that precede the scene content and negative val-
ues to start your scene information at a certain frame number.

Text

Font Lets you select a font for the information displayed.

Alignment Lets you set the alignment of the text: Left, Center, Right.

Size Lets you set the size of the text.

Background

Add Background Box
Adds a box behind the scene information which is useful when the scene contains 
colours or content that may make it difficult to read the scene information.

Colour

Red/Green/Blue/Alpha Lets you enter R, G, B and A values for the colour of the background box.

Colour Swatch

Opens the Colour Picker window where you can select a colour from the palette 
or use the Dropper  tool to select a colour directly from your image—see 
Selecting a Colour in a Drawing in Chapter 7: Ink and Paint in the Paperless 
Animation Guide.
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Blur-Variable

Use the Blur-Variable effect to create a radial blur that varies within a single image based on the white and black 
values in the matte you supply. You can set one blur value for the black regions in the matte, and another blur value 
for the white regions. The blur value for each grey region is interpolated between your black and white blur settings.

The following example is a network for a Variable Blur effect. A black and white copy of the character was used to 
create the effect. Use the Blur-Variable editor to control the blur value for the white and black radius.

Blur Variable Properties
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Black radius
The amount of blur to apply to the black (transparent) values in the matte. 
Higher values create more blur in the colour image's regions that correspond to 
the black matte region.

White radius
The amount of blur to apply to the white (opaque) values in the matte. Higher 
values create more blur in the colour image's regions that correspond to the 
white matte region.

Quality
Select High for a slow and accurate operation or Low for a faster operation with 
a more raw look.

Keep inside source image This option confines the blur to the source image.

Channel Selector 

The Channel Selector effect lets you isolate one of the four colour channels of an image.
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Use the Channel Selector editor to choose which channel to isolate.

Channel Selector Properties

Parameter Description

Name Allows you to change the node's name.

Red Lets you select the red channel of an image.

Green Lets you select the green channel of an image.

Blue Lets you select the blue channel of an image.

Alpha Lets you select the alpha channel of an image.
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Channel Swap

The Channel Swap effect lets you take the image information from one channel and use it in another channel to 
achieve interesting effects. You can extract the following: red, green, blue, alpha values, hue, saturation, 
lightness, and luminance, as well as turn the information on or off. 

For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/video-
tutorials/chapter/adam-phillips-harmony-effects.
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Channel Swap Properties 

Parameter Description

Red, Green, Blue, and Alpha 
Channel From

Lets you select the image information to feed into the red, green, blue, and alpha 
channels. Full On sets all values to 255 and Full Off sets all values to 0.

Chroma-Keying

The Chroma-Keying effect lets you create an alpha channel (transparency zone) for a bitmap image or image 
sequence. For example, if you have a series of bitmap images with a character filmed on a green or blue screen, you 
can use this node to create an alpha channel based on the screen colour and cut it out from your image sequence.

The  Chroma-Keying  node MUST be connected to a bitmap image. The Chroma-Keying  node will create an alpha 
channel that can be seen in the Camera view in the Matte Render mode. To cut the background colour from your 
image, you will need to use a Cutter node.
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To obtain a better result than just extracting the raw colour, you can adjust some parameters such as the contour 
blurriness and the matte size. You can see all the options available in the  Chroma-Keying  properties.

Chroma-Keying Properties

Parameter Description

Name Allows you to change the node's name.

Colour

Red/Green/Blue/Alpha Lets you enter the RGBA values for the colour to extract from your image.

Colour Swatch
Opens the Colour Picker window where you can select a colour from the 
palette or use the Dropper  tool to select a colour directly from your image—
see Selecting a Colour in a Drawing in Chapter 7: Ink and Paint in the 
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Paperless Animation Guide.

Matte

Black Point

Increases the transparent (black) portion of the Chroma Key matte. This will 
reduce the edge of the visible image.

White Point

Reduces the transparent (black) portion of the Chroma Key matte. This will 
increase the edge of the visible image.
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Blur Passes

Lets you set the number of times the image will be blurred.

Adjacent Pixels per Pass

When blurring the matte edge's with the Blur Passes parameter, the Adjacent 
Pixel parameter will blur the matte border with the next few pixels (amount 
indicated in the field) to create a nicer edge.

Output

Threshold Mate
Applies a threshold (tolerance) to the selected colour to be removed. The 
Threshold amount is set in the Threshold field.

Threshold 

Increases or decreases the tolerance for the selected colour to be removed 
from the image. The higher the value, the more coloured pixels will be con-
sidered in the  Chroma-Keying  matte. The pixel colour value will not have to be 
as close to the RGB value as the one selected in the colour swatch. A lower 
Threshold value means the RGB values must be closer to the selected colour 
in order to be part of the matte.

Cut Colour

Removes the selected colour from the image and leaves a transparent zone so 
you can see the background and other layers behind the image. If the option is 
disabled, the colour will remain, but an alpha channel is created that you can 
use with any other nodes with a a Matte input.
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Colour Art 

The Colour-Art effect lets you isolate the colour art in a layer. Placing a Colour Art node after a drawing node in the 
Node view only displays the Colour Art output. You can connect the Colour-Art node after nodes of any type. Any 
bitmap information will pass through the node and be processed.

This effect will only work if there is something on the Colour Art layer of the drawing.

 

Colour-Art Properties

Parameter Description
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Name Allows you to change the node's name.

Flatten

When placing the node below a Composite node containing several drawing 
nodes, such as a cut-out character, you can use this option to flatten the 
extracted result. For example, when extracting a series of outlines, parts that 
may have been hidden by colour fills might now be visible. Enable the Flatten 
option to cut the extra artwork. Harmony will use the colour fills to cut 
unnecessary artwork. If your zones are not painted, nothing will be cut. This 
option works with both pencil lines and brush strokes.

Apply to Matte Ports on Input 
Effects

At times, you may have situations where your node is placed below a Cutter 
node using a mask input and a drawing input. By default, the effect only 
processes the colours in the drawing input. The mask drawing remains 
untouched. If you want to also filter the mask drawing, select the Apply to 
Matte Ports on Input Effects option.

Antialiasing Quality

Smoothness setting applied to Colour-Art. Choose from Low (no antialiasing), 
Medium Low, Medium and High (extensive antialiasing). The higher the set-
ting, the greater the amount of antialiasing applied. Higher quality images 
require more time to render and more memory from your system. Use a lower 
quality when rendering a pencil test.

Antialiasing Exponent

Controls the extent of the area around the Colour-Art edges used in the anti-
aliasing process. A higher value uses less area, resulting in sharper edges, 
while a lower value uses more area, resulting in softer edges. If the Antialiasing 
Quality value is set to Low (no antialiasing), this value is ignored.

Colour Banding

Use the Colour Banding effect to add a colour banding visual effect to your elements. The node will associate a 
flat colour to the different regions of your element. These regions are delimited according the alpha values that are 
set up in the effect node and which will be recognized on the original element. You can use this effect to change 
the visual style of a particle node, for example, by giving it a more cartoonish look.

In this example, a Colour Banding node has been connected to a fire created with particle effects.
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Use the Colour Banding layer properties dialog box to set up the colour banding effect.

Colour Banding Properties

In the Colour Banding properties, there are four sections with which to set up the four different region's alpha and 
colour override values.

This is how the regions range are calculated.

• Region1: Threshold 1 to Threshold 2

425



Chapter 9: Effects     

• Region2: Threshold 2 to Threshold 3

• Region3: Threshold 3 to Threshold 4

• Region4: Threshold 4 to 100% alpha

Parameter Description

Threshold 1

Use this first threshold field to determine the first region outer limit. A value of 0 
represent an alpha of 0 which is completely transparent. A value of 100 rep-
resents an alpha of 255 which is completely opaque. If for example, you enter a 
value of 5 for the first threshold, the region of your element which is within the 
range of alpha going from 5% to the Threshold 2 value, will be coloured with the 
Area 1 colour value.

RGBA
Enter the value of red, green, blue, and alpha for the first, second, third, and 
fourth region colour.

Colour Swatch Opens the Colour Picker where you can specify the colour for the first region.

Blur1–4 Add a blur effect to the edge of the first, second, third, and fourth region.

Colour-Card 

The Colour Card is a solid background the same size as the camera. The Colour Card lets you fill the scene's 
background with a solid colour when there is no background image. If no background or colour card is added to the 
scene, the resulting export will appear with a black background.

By default, the Colour Card has a Z ordering value of 12 Backward. This puts the Colour card behind all 
elements that have a value lower than 12 Backward. Most of the time, the Colour card will appear automatically 
behind all the scenes elements as they are all set to 0 Backward, unless you have changed the Z ordering of the 
scene components. If so, the Colour Card will be in front of the elements that are pushed back to more than 12 
fields backward.
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Colour Card Properties

Parameter Description

Depth
The value used to determine composition order when the Z value of two elements 
is the same.

Offset Z
The front-back position of the Colour Card layer in 3D space. This value can be 
verified in the Top view.

Red/Green/Blue/Alpha

The colour and transparency of the Colour Card. You can also attach these 
parameters to function columns to change their values over time. 

Click the colour swatch to open the Colour Picker window and select a colour.

Colour Swatch Opens the Colour Picker window in which you can specify the colour.
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Colour-Override 

The Colour-Override effects processes the colours in a drawing layer. Using this effect, you can change colours 
from the palette without affecting the actual palette, swap clone palettes, or even replace a specific colour zone.  
You can also substitute colour areas with bitmap textures. The drawings in this layer must be .tvg files as the 
Colour-Override uses the colour palettes linked to them.

The Colour-Override effect lets you:

• Change colour values in drawings during the compositing process.

• Use colour values from a specific colour palette in the palette list.

• Establish the priority of override palettes in the palette list. For example, you may have different clones of 
the same palette, such as a daytime and nighttime version.

• Isolate specific areas of a drawing by selecting certain colours. For example, using specific colours to 
generate a matte for a glow effect.

• Hide certain colours.

This topic is divided as follows:
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Colour-Override Editor Interface

The Colour-Override editor interface  is comprised of the following sections: 

• Palettes on page 429

• Colours on page 430

• Whole Palette Overrides on page 430

• Individual Colour Overrides on page 430

• Render Selected Colours Only on page 431

Palettes

The Palettes section displays the palettes in the palette list of the selected layer. You can move these palettes into 
the Whole Palette Overrides section to reorder them. If you have cloned palettes, the higher one in the list will 
override the others. This is useful for overriding the clone palette ordering set in the scene through the Colour view. 

You can load additional palettes in the palette list from either your project, by clicking on The Palette  button, or 
your computer by clicking on the Browse  button.

• The Palette  button allows you to load a palette contained within the project hierarchy (Environment, Job, 
Scene and Elements).

• The Browse  button allows you to load a palette located outside the project hierarchy, anywhere on your 
system or server. If you link to a palette outside of your project, you will be prompted with the following 
warning message:
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Colours

The Colours section displays the colour swatches of the selected palette. Move a swatch into the Colour-
Overrides section to change its value.

Whole Palette Overrides

The Whole Palette Overrides section forces the use of a particular palette (clone palette) or palette list ordering 
during the compositing process. You must drag palettes from the Palettes section to change their order. Harmony 
uses the palettes in the order they appear in the palette list to find the colour values associated with the colour IDs 
of each colour zone. To apply a different version of a colour palette to, for example, switch from a day to a night 
palette, use the Override section to change the order of the colour palettes (you must be working with cloned 
palettes).

Individual Colour Overrides

When you drag a swatch from the Colours section to this section, you can override its value. You can also 
override a colour with a texture. The default override mode is set to New RGBA so you can override the RGB 
value as well as the transparency value.
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The Current column always displays the colours from the currently active palette.  Selecting a clone palette in the 
Palettes area will not change the colours if you haven't changed the active palette in the Whole Palette Overrides 
section. The update will be done once you close and reopen the Colour Override Layer Properties window.

Render Selected Colours Only

The Render Selected Colours Only section is used to display some colours and ignore all others. You may, for 
example, want to display only the colour used for the character outline and ignore all the filling colours.

Only the colour swatches listed in the Rendered Selected Colours Only section will be rendered. The option is not 
activated by default. If you want to display only the selected colours, you must select the correct option from the 
Rendering menu:

• Render All: This is the default option. All colours in the palettes are rendered regardless of the listed 
selection. This allows you to quickly switch back and forth between your selection of colours and all the 
colours without having to delete and add your swatches from and to the list.

• Render Selected Colours: When this option is selected, the Colour Override module displays only the 
colours listed in your selection.

• Rendered Selected Colours and Bitmaps: This option displays all colours listed as well as any bitmap 
images passing through the Colour Override node. For example, if you have a Composite node grouping a 
series of drawing and bitmap nodes, the vector colours will be filtered through the Colour Override nodes but 
the bitmap images will pass through without being affected. Note that you must be in Render View mode to 
see the colours and bitmaps. 

You might have situations where your Colour Override node is placed below a Cutter node using a mask input and a 
drawing input. By default, the Colour Override only processed the colours in the drawing input. The mask drawing 
remains untouched. If you want the Colour Override to also filter the mask drawing, select the Apply to Matte Ports 
on Input Effects option.
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Overriding a Colour

With the Colour-Override node, you can change the colour of some swatches.

How to override colours

1. From the Colours section, select the colour swatch to modify and move it to the Individual Colour 
Overrides section. Several options are available to modify your colours.

2. Once the swatch appears in the Colour-Overrides section, click the drop-down arrow and select one of the 
following options from the Mode menu:

‣ Override colour: When selecting a colour swatch from a clone palette (not set as the current palette), 
use this option to override the current colour and use the swatch from the clone palette over the 
corresponding one in the current palette.

‣ Colour Not Visible: Renders the selected colour invisible in the Camera view.

‣ New RGB Only: Overrides the colour swatch RGB value while maintaining its original alpha value. 
You can select a new colour by clicking on the colour swatch and choosing a new colour from the 
Colour Picker window.

‣ New Alpha Only: Overrides the swatch's alpha channel while maintaining its original RGB values. 
You can select a new alpha value by clicking on the colour swatch and choosing an alpha value from 
the Colour Picker window.

‣ New RGBA: Overrides the swatch's colour and alpha values. You can select a new colour by  clicking 
on the colour swatch and choosing an alpha value from the Colour Picker window.
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Overriding a Colour With a Texture

With the Colour Override node, you can apply a texture over a selected colour. Any zone painted with the selected 
colour swatch will be overridden by the selected texture.

There are different ways to apply the texture over your colour:

NOTE: The result will only be visible in the Camera view in Render mode. In OpenGL mode, you will see the original 
colour.
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The matrix position can be modified using the Edit Gradient and Texture  tool. To do so, your drawing zone 
must be painted with a gradient swatch or texture swatch.

Texture - Original Matrix

Overrides the swatch's colour with a pattern or texture. You must right-click under the Texture header to bring up 
the Browser window to search for your texture. The texture's default matrix (fixed proportion and orientation) is 
mapped to the full size of the bounding box of each colour area to be overridden.

Texture - Global Bbox Matrix

Overrides the colour with a texture that is scaled non-proportionally to the size of the bounding box encompassing 
the colour areas to be overridden. With multiple objects, it will look as though their fills were all traced and cut 
from the same piece of stretched or squashed fabric.

Texture - Global Bbox Centered
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Overrides the colour with a texture that is scaled proportionally to the size of the bounding box encompassing all 
colour areas to be overridden. With multiple objects, it will look as though their fills were all traced and cut from the 
same piece of fabric.

Texture - Contour Bbox Matrix

Overrides the colour with a disproportionately scaled texture for each individual colour area. In other words, each fill 
area will not only have the texture scaled to its individual proportions, but also stretched or squashed to fit within its 
contours.

Texture - Scale to Screen

Disproportionately scales the texture to the output resolution before applying it as an override.

Modulate Pencil Texture Colour (Replace Transformation)

Overrides the initial texture fill's transformation (matrix) established when you painted the line or modified it with the 
Edit Gradient and Texture  tool. This transformation override will be done by modifying the Peg's position.

Modulate Pencil Texture Colour (Combine Transformation)

Combines the initial texture fill's transformation (matrix) established when you drew the line or modified it with the 
Edit Gradient and Texture  tool with the new position transformation you will create when modifying the Peg's 
position.
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Override with This Texture Centered on Overridden Objects' Centre

Overrides the colour with a texture that is centered in the bounding box encompassing all colour areas to be 
overridden. With multiple objects, it will look as though their fills were all traced and cut from the same piece of 
fabric. The texture will not be stretched or distorted. It will be tiled in proportion. The centre of the texture zone will 
be centered in the middle of the bounding box's centre.

With this option, you can connect a Peg in the middle port to apply a transformation on the texture's position. The 
advantage of being able to animate the texture is that it can be adjusted, scaled, rotated and translated to follow 
the general motion of a character if you want the texture to follow instead of having the character moving across 
the fixed texture—see How to animate a texture override with a peg on page 437.

Texture - Use Input Peg

Overrides the colour with a texture that is scaled non-proportionally to the size of the bounding box encompassing 
the colour areas to be overridden. With multiple objects, it will look as though their fills were all traced and cut 
from the same piece of stretched or squashed fabric.

With this option, you can connect a Peg in the middle port to apply a transformation on the texture's position.

Textures - Use Input Image

How to apply a texture over a colour

 1. From the Colours section, select the colour swatch to override and drag it to the Individual Colour Over-
rides section.

 2. Once the swatch appears in the Individual Colour Overrides section, select it and then click on the  Mode 
drop-down button  and select one of the following options:

‣ Texture - Original Matrix

‣ Texture - Global Bbox Matrix

‣ Texture - Global Bbox Centered
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‣ Texture - Contour Bbox Matrix

‣ Texture - Scale to Screen

‣ Override With This Texture Centered on Overridden Objects Centre

‣ Texture - Use Input Peg

‣ Texture - Use Image Image

The Browse  icon appears in the New column.

 3. In the Colour-Override section, in the New column, click the Browse  icon to select your custom texture.

 4. Browse for your texture file.

 5. Click Open.

 6. If you want to select a new texture to replace the existing one, click the Browse  button again and select a 
new one to replace the existing one.

How to animate a texture override with a peg

 1. From the Node Library view, drag a Peg node to  the Node view.
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1. Connect the Peg node in the Colour Override's middle port. The green port will take the transformation of 
the Peg to modify the texture's position.

 2. In the Node view, select the Peg node.

 3. In the Advanced Animation toolbar, select the Translate , Rotate  or Scale  tool.

 4. In the Camera view bottom toolbar, enable the Render  mode.

 5. In the Camera view, move the Peg's position. As you move it, you can see the texture being modified. You 
can animate the position by adding position keyframes in the Timeline view. You can use the Random Fill 
function to quickly create a random shake.

Modifying a Texture Fill's Transformation

When you paint a zone with a bitmap texture swatch, you may want to modify the size or position of the texture's 
matrix at the compositing level. For example, you may want to do this to animate the position of the texture in a 
zone. With the Colour-Override and a Peg node, you can animate the texture.

How to modify a texture fill's transformation

From the Node Library view, drag a Colour-Override node and a Peg node to the Node view.
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1. In the Node view, connect the Colour-Override node under the Drawing node you want to animate the line for. 
Note that for a cut-out puppet, you would connect the Colour-Override under the final Composite, set as 
Pass-Through.

2. Connect the Peg node in the Colour Override's middle port. The green port will take the transformation of the 
Peg to modify the texture's position.

3. Click the Colour-Override's square yellow properties button to open its property editor.

 1. In the Palettes section, select the palette containing the bitmap texture swatch.

 2. In the Colours section, select the texture swatch you used to paint the drawing and drag it to the Individual 
Colour Overrides section.

 3. Once the swatch appears in the Individual Colour Overrides section, select it and then click the Override 
Mode button and select one of the following:
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‣ Override the colour's transformation: Overrides the initial texture's transformation (matrix) 
established when you painted the zones or modified with the Edit Gradient and Texture  tool. This 
transformation override will be done by modifying the Peg's position.

‣ Combine the colour's transformation: Combines the initial texture's transformation (matrix) 
established when you painted the zones or modified with the Edit Gradient and Texture  tool with the 
new position transformation you will create when modifying the Peg's position.

 4. In the Node view, select the Peg node.

 5. In the Advanced Animation toolbar, select the Translate , Rotate  or Scale  tool.

 6. In the Camera view bottom toolbar, enable the Render  mode.

 7. In the Camera view, move the Peg's position. As you move it, you will see the texture fills being modified. 
You can animate the position by adding position keyframes in the Timeline view.

Overriding a Colour with a Bitmap Image Sequence

In production, you may need to map a live action sequence or bitmap image sequence into a zone or over several 
zones. For example, you could have a mirror shattered into several pieces and you want to map video or someone 
talking into those pieces. You can paint the mirror pieces with a specific colour swatch and use the Colour-
Override node to map the image sequence into the pieces. It can also be a single image without having to be an 
image sequence.

To learn how to modify a texture's exposure based on an animation or character's motion, see Exposure Fill 
Using Render Change on page 374.

How to override a colour with a bitmap image sequence

 1. From the Node Library view, drag a Colour-Override node to the Node view.

440



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

 2. In the Node view, connect the Colour-Override node under the drawing node that contains the line you want to 
animate.

 3. Connect the Live Action or Bitmap Image Sequence node in the Colour-Override's left port. The blue left port 
will input the images into the colour zones. Note that your image sequence's exposure needs to span over all 
the frames you it to be visible for. If there is not images exposed, the colour will not be overridden when 
frames are blank.

 4. Click the Colour-Override's square yellow button to open its property editor.

 5. In the Colour-Override window, in the Palettes section, select the palette containing the colour to override.

 6. In the Colours section, select the pencil texture used to draw your lines and drag it to the Colour-Override sec-
tion.

 7. Once the swatch appears in the Colour-Override section, select it and then click the Override Mode button 
and select Texture - Use Image Input.

 8. In the Node view, select the bitmap image node.

 9. In the Advanced Animation toolbar, select the Translate , Rotate  or Scale  tool.

 10. In the Camera view bottom toolbar, enable the Render  mode.
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 11. In the Camera view, move the Bitmap Image position. As you move it, you will see the texture fills being 
modified. You can animate the position by adding position keyframes in the Timeline view.

Overriding a Texture on a Pencil Line

A pencil line can be drawn with a texture but also painted with a texture swatch. With the Colour-Override node, 
you can override the pencil line's texture or texture fill and replace it by another one, or you can animate the 
texture's position.

With the Edit Gradient and Texture  tool, you can modify the size and position for both types of textures on a 
pencil line; the drawing texture and the filling texture. By doing that, you are actually modifying the texture's 
matrix.

Modifying a Texture Fill on a Pencil Line

When you paint a pencil line with a bitmap colour swatch, you can override the position of the texture fill using the 
Colour-Override node and a Peg.
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How to modify the pencil line texture

From the Node Library view, drag a Colour-Override node and a Peg node to the Node view.

1. In the Node view, connect the Colour-Override node under the Drawing node you want to animate the line for. 
Note that for a cut-out puppet, you would connect the Colour-Override under the final Composite, set as 
Pass-Through.

2. Connect the Peg node in the Colour Override's middle port. The green port will take the transformation of the 
Peg to modify the texture's position.

3. Click the Colour-Override's square yellow properties button to open its property editor.

 1. In the Palettes section, select the palette containing the colour to override.

 2. In the Colours section, select the bitmap texture swatch you used to paint your lines and drag it to the Indi-
vidual Colour Overrides section.
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 3. Once the swatch appears, select it and then click on the Override Mode  button. Select one of the following 
options from the drop-down menu:

‣ Modulate Pencil Texture Colour (replace transformation): Overrides the initial texture fill's 
transformation (matrix) established when you painted the line or modified it with the Edit Gradient and 
Texture  tool. This transformation override will be done by modifying the Peg's position.

‣ Modulate Pencil Texture Colour (combine transformation): Combines the initial texture fill's 
transformation (matrix) established when you drew the line or modified it with the Edit Gradient and 
Texture  tool with the new position transformation you will create when modifying the Peg's 
position.

 4. In the Node view, select the Peg node.

 5. In the Advanced Animation toolbar, select the Translate , Rotate  or Scale  tool.

 6. In the Camera view bottom toolbar, enable the Render  mode.

 7. In the Camera view, move the Peg's position. As you move it, you will see the texture fills being modified. 
You can animate the position by adding position keyframes in the Timeline view.

Modifying a Pencil Texture

You can modify and animate a pencil texture's position using the Colour-Override node and a Peg node. This lets 
you create a shaky line style which is a very popular design style. The main issue with this style is that it works 
well in traditional and tradigital animation, when the artist draws the line differently on each drawing, but it does 
not work in cut-out animation where the same drawing is used for the entire animation. The same issue happens 
when the same drawing is held for more than a few frames. The line moves during the animation, but stops 
moving during the drawing hold, which looks bad.

With the Colour-Override node, you can animate the position of the pencil line texture independently from the 
drawing exposure. Even if a drawing's exposure is held over several frames, the line will move.

How to modify the pencil line texture

From the Node Library view, drag a Colour-Override node and a Peg node to the Node view.
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4. In the Node view, connect the Colour-Override node under the Drawing node you want to animate the line for. 
Note that for a cut-out puppet, you would connect the Colour-Override under the final Composite, set as 
Pass-Through.

5. Connect the Peg node in the Colour Override's middle port. The green port will take the transformation of the 
Peg to modify the texture's position.

6. Click the Colour-Override's square yellow properties button to open its property editor.

 1. In the Palettes section, select the penstyle_opacity palette.

 2. In the Colours section, select the pencil texture used to draw your lines and drag it to the Individual Colour 
Overrides section.
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 3. When the swatch appears in the Individual Colour Overrides section, select it and click the 
Override Mode  button. Select one of the following:

‣ Change Pencil Texture Transformation: Overrides the initial pencil texture's transformation (matrix) 
established when you drew the line or modified with the Edit Gradient and Texture  tool. This 
transformation override will be done by modifying the Peg's position.

‣ Modulate Pencil Texture Matrix: Combines the initial pencil texture's transformation (matrix) that 
was established when you drew the line or modified with the Edit Gradient and Texture  tool with 
the new position transformation you will create when modifying the Peg's position.

 4. In the Node view, select the Peg node.

 5. In the Advanced Animation toolbar, select the Translate , Rotate  or Scale  tool.

 6. In the Camera view bottom toolbar, enable the Render  mode.

 7. In the Camera view, move the Peg's position. As you move it, you will see the pencil texture being mod-
ified. You can animate the position by adding position keyframes in the Timeline view. You can use the 
Random Fill function to quickly create a random shake. 

 

446



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

Colour-Scale 

The Colour-Scale effect offsets an image's colours. This effect is useful in creating ambient transitions, such as 
from daytime to nighttime.
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Colour-Scale Properties

Parameter Description

Red, Green, Blue, Alpha The red, green, blue and alpha used to offset the image.

Hue The colour or hue to offset the image.

Saturation The amount of colour to offset the image.

Value

Enter the value for the colour to offset the image. The actual colour values of 
the image are not changed; instead, the channels are multiplied by a selected 
amount. For example:

• A value of 1 does not change the colour values.

• A value greater than 1 brings the colour channel value closer to 255 (or 
white).

• A value less than 1 brings the colour channel value closer to zero (0 or 
black).
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Composite-Generic 

During the composition of images, colour and alpha values of an input image are combined with the image 
underneath to produce the output image. 

Effects nodes, like Tone and Highlight, can control the colour and alpha composite operations for you. A Composite 
node was created, in which the colour and alpha composite operation are preset to the standard, and more frequently 
used, composite operations.

You may, however, still want to control the colour and alpha composite operation between two images using the 
Composite-Generic Node which combines two images into one output image. The image linked to the left port of the 
node is layered on top of the image in the right port based on the selected colour and alpha composite operation.

Use the Composite-Generic editor to control the calculation of colour and alpha values during the composition 
process.

The following abbreviations are used in the descriptions of composite operations:

• ORGB: RGB values of the Output Image

The Output Image is the resulting image from a composite operation. In the formulas for the composite 
operations, this image is also processed through a composite operation, representing the bottom layer in the 
composited image.

• LRGB: RGB values of the Left Image

• RRGB: RGB values of the Right Image

• LA: Alpha of the Left Image

• RA: Alpha of the Right Image

• OA: Alpha of the Output Image
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Composite-Generic Properties

Parameter Description

Colour Operation

The colour values of the output image are determined based on the alpha and 
colour values of the left and right image.

Both the Blending node and Composite-Generic node have regular blending 
modes and legacy blending modes. The regular blending modes will take the 
source images and unmultiply them before blending the two inputs together. 
The images will be remultiplied when being output from the  node. The legacy 
blending modes use the pre-multipled source images as is in order to apply the 
effect. Unmultiplying the images before processing them will give a final result 
closer to what can be found in software such as Adobe Photoshop.

Right: The colour values in the output image are derived from the image in the 
right port. Colour values in the left port are ignored.

Left: The colour values in the output image are derived from the image in the 
left port. Colour values in the right port are ignored.

Apply With Alpha: ORGB=[RRGB*(1-LA)]+LRGB. This is a standard 
composite operation called "alpha blending." During this operation, colour 
values of the left and right images are combined based on the alpha value of 
the left image. Where the left image is completely opaque (LA=1), the ORGB 
will be replaced completely with LRGB. Where the left image is completely 
transparent (LA=0), the ORGB is unaffected. Where the left image is partially 
transparent, you get a blend of the RRGB and the LRGB, where the values are 
added together and clipped to 255. The LA is the opacity of the left image. This 
operation (1-LA) calculates the amount of opacity to retain in the output image. 
The operation [RRGB*(1-LA)] removes as much of the output image as you 
are about to add from the left image. Remember that LRGB has been pre-
multiplied by the LA, so the equation is really ORGB=[RRGB*(1-LA)]+
(LRGB*LA), which is simply the weighted average of L and R, with LA 
supplying the weight.

Apply Tone Highlight: ORGB=RRGB+(LRGB*RA). This operation restricts 
the output of the tone to the region of the matte (RA), and uses the 
transparency and colour value of the input image to determine the colour 
values of the output. This is used to lighten or darken the output image. 
Darkening occurs when RRGB contains negative values.

Apply Add (Apply Add Legacy): ORGB=RRGB+LRGB. This operation 
uses the transparency and colour value of the left image to determine the 
output values. Effects such as shadows and glows are calculated in this 
manner. Unlike the Apply Tone Highlight operation, the result is not clipped to 
the matte (RA) of the output image.

Apply Matte For Overlay: ORGB=RRGB*(1-LA).This operation prepares 
the output image using the overlay's matte; the matte's RGB values are 
ignored. This operation prepares the output image to receive the colour portion 
of the overlay. It is typically used when an overlay and its matte are stored in 
separate images.

Apply Overlay Into Matte: ORGB=RRGB+(LRGB*RA). This operation 
maps an overlay into an area prepared by a matte. It is typically used when an 
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overlay and its matte are stored in separate images, and Apply Matte For 
Overlay has been used to prepare the output image to receive the RGB portion 
of the overlay.

Apply Transparency: ORGB=RRGB*(1-LA). This operation is used for a 
cutter matte to prepare the output image to receive the colour values of another 
image. It has the effect of increasing the transparency of ORGB (but not OA), 
based on the LA. This function is the equivalent to Apply Matte for Overlay. It 
is almost always used with Apply Transparency Matte, an Alpha Composite 
Operation.

Apply Multiplicative Tone: ORGB=RRGB*(LRGB+1-LA). This operation 
multiplies the left and right images (see the Multiply colours selection), to be 
combined with the right image colour, creating a darker output colour. This 
effect created by this operation is identical to the Multiply Colour Blending 
effect in Photoshop.

Multiply Colours: ORGB=RRGB*LRGB. This operation multiplies the left 
and right image colours. Multiplying colours filters the colour values of the right 
image from the output image. For instance, to make the left image less blue, 
you can add a right image to this node with a blue colour value and select this 
option.

Linear Light: This operation burns or dodges the colours by decreasing or 
increasing the brightness depending on the colour of the underlying colour. If 
the blend colour is lighter than 50% grey, the colour is lightened because the 
brightness is increased. If the blend colour is darker than 50% grey, the colour 
is darkened because the brightness is decreased.

Pin Light: This operation will replace the colours, depending on the underlying 
colour . If the blend colour is lighter than 50% grey, pixels darker than the 
underlying colour are replaced, and pixels lighter than the underlying colour do 
not change. If the blend colour is darker than 50% grey, pixels lighter than the 
underlying colour are replaced, and pixels darker than the underlying colour do 
not change.

Vivid Light: This operation burns or dodges the colours by decreasing or 
increasing the brightness depending on the colour of the underlying colour. If 
the colour is lighter than 50% grey, the blend colour is lightened because the 
contrast is decreased. If the colour is darker than 50% grey, the blend colour is 
darkened because the contrast is increased.

Exclusion: This operation produces a similar result to the Difference mode, but 
with a lower contrast. 

Dodge: This operation will lighten the colour.

Burn: This operation will darken the colour.

Hue: This operation will result in a colour that will take the luminosity and 
saturation of the underlying colour, and the hue of the source colour.

Saturation: This operation will result in a colour that will have the same 
luminosity and hue of the underlying colour, and the saturation of the source 
colour.

Colour: This operation will result in a colour that will have the luminosity of the 
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underlying colour, and the hue and saturation of the source colour.

Luminosity: This operation will result in a colour which has the hue and 
saturation of the underlying colour, and the luminosity of the source colour. 
This mode is opposite to the Colour mode. 

Divide Colours (Divide Colours Legacy): ORGB=RRGB/LRGB. This 
operation divides the right image colour values by the left colour values. The 
left image colour values are inverted, creating a negative image (1/LRGB). The 
negative's colour values are then multiplied by the right image colour values.

Lighten (Lighten Legacy): This operation looks at the colour information 
coming from both the images in the left and right ports and selects the base or 
blend colour - whichever is lighter - as the result colour. Pixels darker than the 
blend colour are replaced, and pixels lighter than the blend colour do not 
change. 

Softlight (Softlight Legacy): This operation darkens or lightens the colours in 
a soft and diffuse way, depending on the blend colour (image in left port). If the 
blend colour is lighter than 50% grey, the image is lightened. If the blend colour 
is darker than 50% grey, the image is darkened. Painting with pure black or 
white produces a distinctly darker or lighter area, but does not result in pure 
black or white. 

Hardlight (Hardlight Legacy): This operation multiplies or screens the 
colours of the image in the left port with those of the image in the right port, 
depending on the blend colour. If the blend colour (left port image) is lighter than 
50% grey, the image is lightened, as if it were screened. This is useful for 
adding highlights to an image. If the blend colour is darker than 50% grey, the 
image is darkened, as if it were multiplied. This is useful for adding shadows to 
an image. Painting with pure black or white results in pure black or white. Play 
with the Opacity value to create a subtler look.

Overlay (Overlay Legacy): This operation multiplies or screens the colours 
from the image connected to the left port, with those on the right, depending on 
the base colour. Colours from the left-port element overlay the colours of the 
drawing elements connected to the right, while preserving the highlights and 
shadows of the base colour. The base colour is not replaced, but mixed with 
the blend colour to reflect the lightness or darkness of the original colour. 

Opacity The level of transparency.

Alpha Operation

Right: The transparency of the output image is derived from the alpha values 
of the image in the right port. The values in the left port are ignored.

Left: The transparency of the output image is derived from the alpha values of 
the image in the left port. The values in the right port are ignored.

Apply: OA=[RA*(1-LA)]+LA. This operation computes the output alpha of the 
output image based on the alpha values of the left and right images. This is the 
standard method of combining alpha channels. Notice its similarity to the 
Apply With Alpha colour Composite Operation.

Add: OA=RA+LA. This operation adds the alpha values of the two images to 
produce the alpha value of the output image.

Subtract: OA=RA-LA. This operation subtracts the alpha values of the input 
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image from the alpha values of the output image. It is useful in situations where 
two tone levels have been drawn with overlap, but a double-darkening in the 
overlap is not wanted. This operation will reduce the opacity of overlapping 
regions.

Apply Transparent Matte: OA=RA*(1-LA). This operation is used to 
increase the transparency of the output alpha in the final composited image.

Black: OA=0. Sets the matte of the entire output image to black, so that it is 
transparent.

White: OA=1. Sets the matte of the entire output image to white, so that it is 
opaque.

Output Z

Leftmost: Indicates that the Z value for the output image will be taken from the 
node in the left port.

Rightmost: Indicates that the Z value for the output image will be taken from 
the node in the right port.

Backmost: Indicates that the Z value for the output image will be taken from 
the image that is the farthest back in the scene.

Frontmost: Indicates that the Z value for the output image will be taken from 
the image that is closest to the front of the scene.

Portnumber: Indicates that the Z value for the output image will be taken from 
the node in the selected port. Enter the appropriate port in the Port for Output 
Z field.

Contrast 

Use the Contrast effect to increase or decrease the level of contrast in an image. This is done by changing the 
contrast in the dark and bright pixels and setting the transition point between dark and bright.
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Contrast Properties

Parameter Description

Mid Point

The value that separates dark from bright colours. The midpoint is a value 
between 0 and 1 that represents the percentage of the 0 to 255 RGB channel 
range.

Pixels with colour values lower than the midpoint: These are considered 
dark pixels. 

Pixels with colour values higher than the midpoint: These are considered 
bright pixels.

Dark Pixel Adjustment and 
Bright Pixel Adjustment

The amount of contrast to be applied to pixels that fall on either side of the Mid 
Point value.

A value equal to 1: No change

A value less than 1: The node makes the pixel colours brighter

A value greater than 1: The node makes the pixel colours darker

You can enter static values in the dialog box fields or you can attach these values to function curves to change 
over time.
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Cutter

The Cutter effect cuts out a portion of an image using a matte drawing. You can use the Cutter effect to allow a 
character to disappear behind a background element or to cut a virtual hole into the layer itself. The Cutter requires a 
matte input.

Adjust the Cutter properties to invert the effect of the matte on an image. Instead of the object being hidden by the 
mask, it will only be visible where it intersects with the matte shape area. 

How to use the Cutter effect

 1. Select a drawing layer and do one of the following:

‣ From the Node Library view, select the Cutter effect and drag it to the Node view. 

‣ In the Node view, right-click and select Insert > Combine > Cutter. 

 2. Connect the Cutter node between the drawing and Composite node.
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 3. In the Drawing or Camera view, create a drawing on a new layer that will act as the matte.

 4. In the Timeline view, click the Collapse/Expand  button on the effect layer.

1. Do one of the following:

‣ Drag and drop the matte layer beside the Matte field.

‣ Connect the Matte drawing to the Matte port of the Cutter node.

456



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

 5. Display the Cutter properties and adjust the properties to control the type and amount of blur and the colour of 
the Cutter effect.

Cutter Properties

Parameter Description

Name Allows you to change the node's name.

Inverted
When this option is enabled, the Cutter node will invert the matte shape to cut the 
drawing. Instead of cutting the image intersecting with the matte, it will cut any 
artwork outside of the matte shape.

Dither 

Dithering is the process of approximating a higher number of colours in a low bit-depth colour system. Use the Dither 
effect to give the appearance of greater colour variability in 8-bit per channel colour images. 

The Dither effect is useful in the case of a gradient that varies between 100 and 105 in the blue channel, for example. 
Since the difference in the colour values is not great, banding might appear in the image. In this case, use the Dither 
node to give the impression of greater values of blue, decreasing the unwanted banding effect.
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The results of the dither operation may be imperceptible.

Dither Properties

Parameter Description

Magnitude

A magnitude of 1 performs a normal dithering operation, using all bands of col-
our. A magnitude greater than 1 introduces a bias towards brighter colours. A 
magnitude of less than 1 creates a faster transition between bands of colour, 
lessening the bias towards brighter colours.

Correlate
When selected, the three colour channels (RGB) are changed simultaneously, 
for better colour accuracy. When this option is not selected, the three channels 
are dithered separately, resulting in smoother transitions.

Random The standard algorithm for the dithering operation.

External 

Use the External node to process images through external programs and input the resulting images back into the 
network. Note that not all programs work with the External node.

Using the External node lets you avoid having to export your animation to another software to do some 
processing over it and then bringing it back to Harmony. This way, you can modify your scene and animation as 
much as you want and still use the effects or render process from a third-party software.

Harmony also supports OpenFX plugins—see OpenFX on page 611.
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The External node writes input files to temporary files on the system. It then calls the external program, which will 
process the input images. If two images are input into the node, the program must composite them together to 
produce one output image. Finally, the file produced by the external program is read back into the network.

The command is sent to the external program in the following format:

program_name file_1 file_2 output_file numerical_param extension

Use the External editor to control the program that is launched by the node, the files that it reads, and the file that it 
outputs into the network.

In this example, the ImageMagick 6.3 software was used without a matte connection.

Use the External editor to write down the parameters matching the chosen external program.
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External Properties

Parameter Description

External Program

The name of the program launched by the External node. This field can include 
a full or relative path to the executable file. If no path is entered, the user's path 
is searched to locate the program.

Enter the command directly into this field. 

For example:

mogrify -spread $NUM $IN1

Where:

mogrify: Is the name of the program

spread: Is the option to be applied, 

$NUM and $IN1: Are the numerical parameter and first input file variable 
declared in the External node.

Program First Input File ($IN1)
The name and location of the temporary file that Harmony will write to the file 
system for the external program to read. It must not include the dot or the exten-
sion; the External node will add these based on the Extension field.

Program Second Input File 
($IN2)

When processing two files through this node (such as an image and a matte), 
this is the name and location of the second temporary file that Harmony writes 
to the file system for the external program to read. It must not include the dot or 
the extension; the External node will add these based on the Extension field.

Program Output File ($OUT)
The name and location of the temporary file that the external program will write 
to the file system so that Harmony can read it back into the network.

Extension ($EXT) The file type that will be processed by the external program.

Numerical Parameter($NUM)
A value passed to the external program as a file processing option. It can be 
attached to a function curve to change over time.
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The program files are temporary files that are overwritten at each frame as the node is executed. They are only 
meant to temporarily store the image that is being processed at each frame.

Generate Unique FileNames

If this option is enabled, the temporary output file will have a unique iden-
tification number added to its name to avoid any file override if another scene or 
External script is rendered at the same time. It could be possible to have an 
override when two scenes using the External nodes are rendered in batch pro-
cessing.

Field Chart

The Field Chart node displays a traditional animation field chart, which allows you to position elements in the 
Camera view. The Field Chart node doesn't export. If you want to export a field chart, use the Grid node—see Grid on 
page 480.
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Field Chart Properties

Parameter Description

Name Lets you rename the node.

Drawing

Size
Adjusts the number of units in the grid (field chart). The grid size will always be 
a 4:3 ratio, as per traditional animation standards. The gird is available in 12 or 
16 fields.

Opaque
Inserts  a white background behind the grid and covers everything else behind 
it. By default, you can see through the grid.

Antialiasing

• Antialiasing Quality: A smoothness (antialiasing) setting applied to the 
final rendered image. 

• Low: No antialiasing 

• Medium Low: Basic antialiasing

• Medium: Improved antialiasing (blurs the textures)

• High: High quality antialiasing (does not blur the textures)

Higher quality images require more time to render and more system 
memory. Choose a lower quality if you are rendering a pencil test.

• Antialiasing Exponent: Controls the size of the area around the final 
image edges used in the antialiasing process. A higher value uses less 
area, resulting in sharper edges, while a lower value uses more area, 
resulting in softer edges. If the Antialiasing Quality value is set to Low 
(no antialiasing) or Medium Low, this value is ignored. Values: Between 
0 and 1.

Alignment Rule
The alignment rule selections are intended to deal with drawings that were 
created on paper of a different size or orientation from the default alignment rule 
(set up in the Scene Settings dialog box) or imported bitmap images. The 
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drawings are then scaled to match the Harmony alignment rectangle. Note that 
alignment rules are not based on the camera frame, but on the scene frame. 
Refer to the Fundamentals Guide to learn more about scene alignment and 
scene settings.

• Left: The default alignment for drawings; aligns the drawings to the left 
side of the scene’s alignment rectangle. Harmony scales the drawings 
to match their height to the alignment rectangle of the scene.

• Right: Aligns the drawings to the right side of the alignment rectangle. 
Harmony scales the drawings to match their height to the height of the 
alignment rectangle of the scene.

• Top: Aligns the drawings to the top of the alignment rectangle. 
Harmony scales the drawings to match their widths to the width of the 
alignment rectangle of the scene.

• Bottom: Aligns the drawings to the bottom of the alignment rectangle. 
Harmony scales the drawings to match their widths to the width of the 
alignment rectangle of the scene.

• Centre Fit: Centers the drawings.

• Centre Fill: Centers the drawings and then scales them so the width or 
height fills the available space.

• Centre LR: Aligns the drawings in the left-right centre of the alignment 
rectangle. Harmony scales the drawings to match their height to the 
height of the alignment rectangle of the scene.

• Centre TB: Aligns the drawings in the top-bottom centre of the 
alignment rectangle. Harmony scales the drawings to match their 
widths to the width of the alignment rectangle of the scene.

• Stretch: Scales the drawings so they fit within the alignment rectangle 
of the scene. This is particularly useful for images that you will 
manipulate with a Quadmap node. If the drawings in the Quadmap node 
do not have the same aspect ratio as the alignment rectangle of the 
scene (from the Scene Settings dialog box), the handles on the 
quadmap will not appear on the corners of the image, making it difficult 
to manipulate the quadmap. In this case, you would set the drawing 
layer of the quadmap images to Stretch to make the handles appear on 
the corner of the image. This can have the effect of distorting the 
images, but it is not an issue with images that will be distorted through 
the Quadmap node anyways.

• As Is: Leaves the drawings aligned as they are. 

• Centre First Page: Aligns the centre of the first part of a standard pan 
cel with the centre of the field chart.

Turn Before Alignment

Turn Before Alignment: Rotates  the drawings in the selected element 90 
degrees to the left before scaling and aligning them according to the alignment 
rule, and before performing any offset, rotation or scaling for the element or 
peg. This and the Alignment Rule are intended for drawings that were created 
on paper of a different size or orientation than the other paper in the scene, and 
requires alignment  so they are treated accurately.
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Depth
Overrides the order of cables in the node system to determine the 
forward/backward order in which this element is rendered. The Z position value 
overrides the depth value.

Position

Animate Using Animation 
Tools

By default, the grid can be animated using the same parameters as a peg, but 
you can disable this feature so the field chart remains in place. You can 
connect it to a peg to animate it or move it.

When  this option is deselected, you cannot move the layer in the Camera view 
using the Transform and Advanced tools. This prevents you from accidentally 
displacing or modifying a layer.

Position

3D Path: Lets you use a 3D path function to animate an element.

Separate: Lets you independently edit the different coordinate fields.

Path (x) Axis: Lets you type in a new East/West coordinate corresponding to 
the desired position.

Path (y) Axis: Lets you type in a new North/South coordinate corresponding to 
the desired position.

Path (z) Axis: Lets you ype in a new Forward/Backward coordinate 
corresponding to the desired position.

Scale

Locked: Resizes the element while keeping its ratio. The X and Y axes scale 
proportionally

Separate: Resizes the element allowing to modify the ratio (squash and 
stretch).

(x) Axis: Lets you type in the horizontal scale value.

(y) Axis: Lets you type in the vertical scale value.

Scale in Fields: Instead of using the standard scaling units, when this option 
is enabled, images are scaled using field units, based on the traditional 
animation field chart.

Angle Z
Lets you  type in a degree value for the rotation angle. Note that you can enter 
values greater than 360 and -360 degrees. If you enter 720, the object will 
rotate twice.

Pivot

(x) Axis: Lets you type in a new East/West coordinate corresponding to the 
desired position.

(y) Axis: Lets you ype in a new North/South coordinate corresponding to the 
desired position.
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Flatten

The Flatten node is used to transform 3D objects into flat planes when ordered in the Composite node. That plane 
can then be moved arouned like any other drawing. Instead of intersecting with 2D layers, the 3D object will either be 
behind or in front.

When all objects are at the same distance (z value) from the camera, the order is based on the Composite ports. 
When elements are placed at different distances from the camera, the z axis value overrides the composite port 
ordering.

Focus 

Use the Focus effect to set up depth-of-field effects for your scene. The Focus node is used to determine how much 
blur will be applied to images, based on their distance from the focal point. 

The focal point can be the zero value of your scene or you can link the Focus node to another node, such as a 
drawing or peg layer, to retrieve the focal point from the node's Z-axis position.
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Use the Focus editor to determine how the focus will change as objects move farther from the focal point.

In the Side view window, you can see how the blur values change based on their distance from the focal point. 
Select the Focus node in the Node view, make sure you are using the Transform tool, then right-click on the Side 
view window and select Control from the pop-up menu.

If you edited the function curve and adjusted the velocity, you can also adjust the Bezier handles in the Side view.
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Focus Properties

Parameter Description

Mirror Select this option to also blur images in front of the focal point.

Mirror Front/Back Ratio
When the Mirror option is selected, this ratio is applied to the calculation of the 
blur on images in front of the focal point. The default ratio of 1:2 produces realistic 
results. Experiment with different values to create customized effects.

Radius
Controls the amount of blur applied to an element based on its distance from the 
focal point. Click on the Edit Curve button to change these values by adjusting 
the function curve.

Quality
Controls the quality of the blur. A higher quality will achieve better results but will 
be slower to render.

Focus Multiplier 
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The Focus Multiplier effect works with the Focus node. This node applies a blur to the selected layer, based on 
the blur radius in the Focus node.

Use the Focus Multiplier node when you want to apply the focus to selected elements or when you need to apply 
the focus before doing more effects in a composite operation.

You must disable the Apply Focus option in the Composite node in order to apply the focus effect to the selected 
node only. If you do not disable that option, the focus effect will be calculated twice on the selected node.

Use the Focus Multiplier editor to multiply the Focus Radius by a selected value. You can enter a static value in 
the Multiplier field or attach it to a function curve.
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Glow 

The Glow effect adds a bright soft-edged light or diffuse light region around an image. The Glow effect is useful for 
creating a shining rim around objects, such as the sun or stars.

Use the Glow editor to control the direction of the blur that creates the glow, as well as its colour.
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Glow Properties

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo 
a change of depth or scale. When disabled, the effect's values will remain 
unchanged regardless of depth or scale changes. It is recommended that this 
option be disabled when multiple drawings are composited and attached this 
effect.

Blur Type

Radial: The edges of the matte are blurred evenly around points that make up 
the edge of the matte.

Directional: The matte is blurred in the direction you select.

Radius
Enter a value for the size of the blur. The larger the value, the greater the blur 
effect. The blur radius is affected by the drawing scale and camera position.

Directional Angle

If you selected the Directional Blur type, you can set the direction of the blur by 
entering a value from 0 to 360 in this field.

0: Blurs the image to the west.

90: Blurs the image to the south.

180: Blurs the image to the east.

270: Blurs the image to the north.

Directional Falloff Rate

The distance where the blur fades from the edge of the image. Select a value 
between 0 and 1.

0: Makes the blur fade out slowly, distributing the blur evenly from the edge of 
the character to the farthest edge of the blur.

1: Makes the blur fade out quickly. The blur is heaviest closer to the edge of 
the image.

Invert Matte Inverts the matte used to create the tone, shadow, or highlight.
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Use Matte/Source Colour

Creates the shadow or tone using the matte shape's colour. Be sure that you 
are in render mode  to see this effect and that your background is NOT 
white and that you do NOT have a white colour card node attached to the com-
posite. As the matte only gives colour information, but no alpha, the matte is 
automatically multiplied with the background colours. If there is no colour card 
attached and the background appears black, you will see the matte colour at 
full opacity. If it is multiplied with a white background, the colours disappear 
into the full 255.

Multiplicative Multiplies the tone or shadow colours with the background.

Colour

RGBA
Enter a value to add or subtract from the colour channels in the drawings or 
attach these values to function curves.

Colour Swatch Opens the Colour Picker where you can specify the colour.

Intensity
Lets you set a value to determine the strength of the effect or attach a function 
to animate the effect.

NOTE: If this effect is connected below a Composite node set to Pass-Through, the effect will be applied to each 
element connected in the Composite node individually. If some of these elements are overlapping, the effect will also 
overlap.

Glue 

The Glue effect lets you repair the cracks that appear between joints during animation.

The Glue node has three ports:

471



Chapter 9: Effects     

• Left Port (Matte): Receives the matte.

• Middle Port (Port A): Receives the element that will not be used to fill the joint.

• Right Port (Port B): Receives the element that will be used to fill the joint.

For most effects with the Glue node, the default options are sufficient. However, you can modify these options 
using the Glue editor.

Glue Properties

Parameter Description

Bias
Indicates the tendency to favour the static or moving element. Set to 0, it 
favours element A; set to 1 it favours element B; set to 0.5 it is in between A 
and B.

Tension
Indicates how tight the joint will be. Set to 1, the tension has no effect; set less 
than 1, the tension decreases; set greater than 1, the tension increases. 

Type
From this menu, select the type of joint to create. You can choose from among 
Curve (default), Line and Corner.

Use Z for Composition Order
You can use this option to choose the drawing with the higher front-back value 
to create the joint.

A Over B Indicates which image is rendered on top in the final image. By default, A is 
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rendered on top of B, which indicates that the image in the middle port (A) is 
rendered on top of the image in the right port (B).

Spread A

By default, the image in port B is spread to fill the joint. You can use this option 
to choose the image in the A port to create the joint. If you select this option, 
the drawing node must receive position information from the "B" element. 
Thus, you must connect the Drawing node of the "B" element to the Drawing 
node of the matte.

Invert Matte
Activate this option to invert the matte used to fill the joint. If you want to use 
the "B" element as the matte, you must select this element.

Gradient 

The Gradient effect lets you create a transition of colour or alpha values between two areas of colours. You can 
create a linear or radial gradient. Use two points to indicate where those two coloured areas are. You can then move 
these points to create the transition.

The Gradient node covers the entire camera frame and beyond. You do not need to scale it up or down. It will 
automatically cover an infinite zone. You simply need to connect it behind your scene's elements. You can connect 
it in front of some elements you want to cover. By default, the Gradient has a Z ordering value of 0. When you select 
the Gradient node, the Camera view displays yellow triangles to indicate that it's selected.

Use the Gradient property editor to modify the values of the gradient and the position of its output.
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Controlling the Gradient in the Camera View

If you want to control the gradient's orientation and points position in the Camera view, you can use the Control 
command to display the points and move them.

How to control the gradient in the Camera view

 1. In the Tools toolbar, select the Transform  tool.

 2. In the Node view, select the Gradient node.

 3. From the top menu, select View > Show > Control.

 4. In the Camera view, click the Gradient's points and move them.
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Gradient Properties

Parameter Description

Gradient Type Lets you select a linear or radial gradient.

Point 1, Point 1
These sections control the values of the first point (point 0) and the second point 
(point 1) in the gradient.

Red, Green, Blue, Alpha

The colour and alpha values of the corresponding point. You can also click the 
colour swatch to open the Colour Picker window and select a new colour. These 
colours can be animated over time if the value parameter is attached to a function 
curve. Default values: 0,0,0 and 255, 255, 255.

(x) Axis Sets the X coordinate for the corresponding point.

(z) Axis Sets the Y coordinate for the corresponding point.

Offset Z
Enter the front-back position of the Gradient layer in 3D space. You can verify this 
value in the Top view.

Depth Determines the composition order when the Z value of two elements is the same.
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Grain 

Use the Grain effect to add a film grain to an image; the film grain looks like video noise.

 

The Grain node has two input ports. 

• On the left port, attach the element that will act as the matte defining the grain area.

• On the right port, attach the element on which you want to apply the grain effect.

Use the Grain editor to adjust the amount of grain to add to an image; you can also use it to adjust the sharpness 
or softness of the grain.

476



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

Grain Properties

Parameter Description

Noise
The amount of grain to add to the image based on the percentage of pixels to alter. 
The larger the value, the courser the grain. The smaller the value is to 0 (zero), the 
finer the grain.

Smooth
The amount of blending to apply to the grain effect, based on the blur radius, to 
make the effect appear less pixelated. The larger the value, the greater the 
smoothing.

Random at Each Frame

Computes the colour shift in the grain using a different value at each composite. 
This means that your images will look different each time you render them. 
Deselect this option and select a Seed Value to ensure the same result every 
time you composite the grain effect.

Seed Value
This value corresponds to a unique pattern in the grain. If you want to retain this 
pattern in other frames, you can reuse this value.

Greyscale 

The Greyscale effect lets you convert a colour image to greyscale. This example demonstrates what happens when 
you set the greyscale to 100% using the Greyscale node. You can also use the Contrast node to adjust the darkness 
and lightness of the pixels in your element. 
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Using the Matte Output Option

Here is an example on how to use the Matte Output option of the Greyscale node. A frosted window was created 
using a snowflake image over a blue rectangle and a colourful background.

Here are the three drawings used for the example:

When the snowflake image is connected into the Greyscale node, it turns into a greyscale image. There is no 
transparency visible in the Camera view Matte View mode.

When the Matte Output option is enabled, the snowflake image colours are displayed as normal, but when the 
Matte View mode of the Camera view is enabled, you can see the transparency levels generated from the colour 
values. 

When you connect the Snowflake images into a Cutter effect's Matte port along with the Window images, the 
window will be semitransparent, matching the alpha (transparency) channel generated by the Greyscale node.
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Greyscale Properties

Parameter Description

Name Lets you rename the node.

Percent
Lets you enter the percentage of black and white to apply to the image. You can 
enter a static value in the Percent field or attach the value to a function curve to 
change over time.

Matte Output
Maintains the colour values. However, alpha values are read from the colours you 
see in the Camera view Matte View mode.
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Grid

The Grid node displays a grid, in field chart unit, which allows you to position elements in the Camera view.
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Grid Properties

Parameter Description

Name Lets you rename the node.

Size

Adjusts the amount of units in the grid (field chart). The grid size will always be a 
4:3 ratio, as per traditional animation standards, but will adjust the camera frame 
width. You can change the grid to adjust to the camera frame by deselecting the 
Fit Vertical option.

Aspect

The grid size default format is 4:3 ratio, as per traditional animation standards, but 
will adjust the camera frame width. You can change the grid ratio by entering a 
new ratio. To find your scene ratio, select Scene > Scene Settings.
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Fit Vertical

Makes the grid size adjust the camera width or height.

Display Text Turns the display of numbers on or off.

Fill
Makes the grid's background opaque. Nothing behind will be shown. You can also 
click on the colour swatch to open the Colour Picker window and select a 
background colour.

RGBA
The colour and alpha values of the corresponding point. You can also click on the 
colour swatch to open the Colour Picker window and select a grid or background 
colour. Default values: 0,0,0 and 255, 255, 255.

Colour Swatch Opens the Colour Picker window in which you can specify the colour.

Highlight 

The Highlight effect lets you to turn a drawing's area lighter to simulate a light source. For this effect, you will 
need to create a matte to determine the shape and position of the highlight on another element and so you can blur 
the edges to create a softer effect. By adjusting the Highlight properties, you can control the type and amount of 
blur, as well as the colour of the highlight effect.

How to use the Highlight effect

 1. Select a drawing layer and do one of the following:

‣ From the Node Library view, select the Highlight effect and drag it to the Node view. 

‣ In the Node view, right-click and select Insert > Combine > Highlight. 

 2. Connect the Highlight node between the drawing and Composite node.
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 3. In the Drawing or Camera view, create a drawing on a new layer that will act as the matte.

 4. In the Timeline view, click the Collapse/Expand  button on the effect layer.

1. Do one of the following:

‣ Drag and drop the matte layer beside the Matte field.

‣ Connect the Matte drawing to the Matte port of the Highlight node.

483



Chapter 9: Effects     

 5. Display the Highlight properties and adjust the properties to control the type and amount of blur and the col-
our of the highlight effect.

Highlight Properties

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo 
a change of depth or scale. When disabled, the effect's values will remain 
unchanged regardless of depth or scale changes. It is recommended that this 
option be disabled when multiple drawings are composited and attached this 
effect.

Blur Type
Radial: The edges of the matte are blurred evenly around points that make up 
the edge of the matte.
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Directional: The matte is blurred in the direction you select.

Radius
Enter a value for the size of the blur. The larger the value, the greater the blur 
effect. The blur radius is affected by the drawing scale and camera position.

Directional Angle

If you selected the Directional Blur type, you can set the direction of the blur by 
entering a value from 0 to 360 in this field.

0: Blurs the image to the west.

90: Blurs the image to the south.

180: Blurs the image to the east.

270: Blurs the image to the north.

Directional Falloff Rate

The distance where the blur fades from the edge of the image. Select a value 
between 0 and 1.

0: Makes the blur fade out slowly, distributing the blur evenly from the edge of 
the character to the farthest edge of the blur.

1: Makes the blur fade out quickly. The blur is heaviest closer to the edge of 
the image.

Invert Matte Inverts the matte used to create the tone, shadow, or highlight.

Use Matte/Source Colour

Creates the shadow or tone using the matte shape's colour. Be sure that you 
are in render mode  to see this effect and that your background is NOT 
white and that you do NOT have a white colour card node attached to the com-
posite. As the matte only gives colour information, but no alpha, the matte is 
automatically multiplied with the background colours. If there is no colour card 
attached and the background appears black, you will see the matte colour at 
full opacity. If it is multiplied with a white background, the colours disappear 
into the full 255.

Multiplicative Multiplies the tone or shadow colours with the background.

Colour

RGBA
Enter a value to add or subtract from the colour channels in the drawings or 
attach these values to function curves.

Colour Swatch Opens the Colour Picker where you can specify the colour.

Intensity
Lets you set a value to determine the strength of the effect or attach a function 
to animate the effect.
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Hue-Saturation

The Hue-Saturation effect lets you adjust the hue, saturation and lightness values individually or by using the 
HLS picker or Hue Range picker. You can achieve effects over the entire image, such as a sepia tone. Changes 
you make to the values are additive to the final image.

For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/video-
tutorials/chapter/adam-phillips-harmony-effects.
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Hue-Saturation Properties 

Parameter Description

Master

Allows you to remap all the colours at the same time using the Hue, Saturation 
and Lightness fields. 

Note: When using the Master parameters, the Colorize parameters are disabled.

Opens the Hue Range Picker which displays the original colour spectrum of the 
image in the top bar and the new colour spectrum in the bottom bar. The 
Saturation and Lightness in the upper bar can range from -100 to 100, allowing you 
to decrease the original values.

 

 

Colourize
Lets you set the hue, saturation, and lightness by entering values or by using the 
HSL Picker. In the Colorize mode, Lightness can range from -100 to 100. 
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Select a colour by moving the colour picker.

Note: When using the Colourize parameters, the Master parameters and other 
colour tabs are disabled.

Hue The colour or hue of the image.

Saturation The amount of colour in the image.

Lightness The brightness of the image.

Colour Swatch Opens the HLS Picker where you can specify the colour.

Tabs Reds, Greens, Blues, Cyans, Magentas, Yellows

Opens the Hue Range Picker. The top bar displays the colour spectrum with 
arrows for defining the colour range more precisely. The triangles indicate the 
falloff of the effect, which you can also adjust. 

Specify the hue as an angle from 0° to 360° that corresponds to a location on the 
color wheel. Specify saturation and lightness (B) as percentages (0 to 100).

Reset Range
Resets only the range of hue values over which the effect is applied, i.e. the 
arrows and triangles. The HSL adjustments are maintained.
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Image Switch

 

The Image Switch  effect lets you use multiple effects, such as Colour Override, and choose which port will be sent 
to rendering if you want to apply different variations of an effect that cannot be changed over time. You then create 
multiple separate versions of the effect, connect them all to the Image Switch, and then if you want to change to a 
different version of the effect at different points in your scene, you would add a curve and animate the port number. 
Image Switch simply lets you change over time which port is being rendered.

 

Image Switch Properties 

Parameter Description

Port Index Switches from one image to another. There is no gradual animation from one 
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colour to another as you are only changing (over time) which port will be rendered. 
Use whole values.

Click the Function  button to open the Function editor to animate a parameter 
over time—see .

Layer Selector 

The Layer Selector effect lets you isolate and display one or more art layers:

• Overlay

• Line Art

• Colour Art

• Underlay 
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Layer Selector Properties

Parameter Description

Name Lets you rename the node.

Read Overlay, Line Art, Col-
our Art, Underlay

Turns the display of the Overlay, Line Art, Colour Art and Underlay layers on or 
off.

Flatten

When placing the node below a Composite node containing several drawing 
nodes, such as a cut-out character, you can use this option to flatten the 
extracted result. For example, when extracting a series of outlines, parts that may 
have been hidden by colour fills might now be visible. Enable the Flatten option to 
cut the extra artwork. Harmony will use the colour fills to cut unnecessary 
artwork. If your zones are not painted, nothing will be cut. This option works with 
both pencil lines and brush strokes.

Apply to Matte Ports 
on Input Effects

At times, you may have situations where your node is placed below a Cutter node 
using a mask input and a drawing input. By default, the effect only processes the 
colours in the drawing input. The mask drawing remains untouched. If you want to 
also filter the mask drawing, select the Apply to Matte Ports on Input Effects 
option.

Antialiasing Quality

Smoothness setting applied to the art layer. Choose from Low (no antialiasing), 
Medium Low, Medium and High (extensive antialiasing). The higher the quality of 
the chosen setting, the greater the amount of antialiasing that is applied. Higher 
quality images require more time to render and more memory from your system.

Antialiasing Exponent

Controls the amount of area around the art layer edges that is used in the 
antialiasing process. A higher value uses less area, resulting in sharper edges, 
while a lower value uses more area, resulting in softer edges. If the Antialiasing 
Quality value is set to Low (no antialiasing), this value is ignored.
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Lens Flare

The Lens Flare effect simulates the refraction caused by shining a bright light into a camera lens. The shape of 
the lens flare can be circular or hexagonal.

For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/video-
tutorials/chapter/adam-phillips-harmony-effects.

Here is how a typical lens flare can be set up:
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Lens Flare Properties 

Parameter Description

Flares

Flare Type
Custom: Lets you use your own custom art or drawing.

Type 1: Circular lens flare.
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Type 2: Hexagonal lens flare.

Blend Mode: Normal/Screen

Lets you apply a normal or screen blending mode to the image.

Normal: When selected, this operation will not create any blending mode effect.

Screen: When deselected, this operation multiplies the inverted colour of the 
blending element with the image. This lightens the colour of the overlapping area. 
Screen is the default blending mode.

Position X, Y, Z Lets you precisely orient the flare in the x, y, and z axes.

Brightness

Intensity The strength of the lens flare.

Red Red values of the image.

Green Green values of the image.

Blue Blue values of the image.

Alpha Alpha values of the image.

Colour Swatch Opens the Colour Picker where you can specify the colour of the main flare.

Flare 1–10
Lets you create custom lens flares by associating them with specific drawings. 
You can create up to 10 different flares.

 

Drawing: Lets you specify a drawing to use for the flare.

Position: The position of the flare. 

Size: The size of the flare.

Blur Intensity: The strength of the flare.

Line Art

The Line Art effect lets you read only the Line Art in an element. Place a Line Art node after a drawing node in the 
Node view to display only the node's Line Art output. The Line Art node can be connected after nodes of any type. 
Any bitmap information will pass through and be processed. 

This effect will only work if you drew something on the Line Art layer of the drawing.
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Line Art Properties

Parameter Description

Name Lets you rename the node.

Flatten

When placing the node below a Composite node containing several drawing 
nodes, such as a cut-out character, you can use this option to flatten the 
extracted result. For example, when extracting a series of outlines, parts that may 
have been hidden by colour fills might now be visible. Enable the Flatten option to 
cut the extra artwork. Harmony will use the colour fills to cut unnecessary 
artwork. If your zones are not painted, nothing will be cut. This option works with 
both pencil lines and brush strokes.

Apply to Matte Ports on Input 
Effects

At times, you may have situations where your node is placed below a Cutter node 
using a mask input and a drawing input. By default, the effect only processes the 
colours in the drawing input. The mask drawing remains untouched. If you want to 
also filter the mask drawing, select the Apply to Matte Ports on Input Effects 
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option.

Antialiasing Quality

Smoothness setting applied to the art layer. Choose from Low (no antialiasing), 
Medium Low, Medium and High (extensive antialiasing). The higher the quality of 
the chosen setting, the greater the amount of antialiasing that is applied. Higher 
quality images require more time to render and more memory from your system.

Antialiasing Exponent

Controls the amount of area around the art layer edges that is used in the 
antialiasing process. A higher value uses less area, resulting in sharper edges, 
while a lower value uses more area, resulting in softer edges. If the Antialiasing 
Quality value is set to Low (no antialiasing), this value is ignored.

Luminance Threshold

The Luminance Threshold effect generates a matte by thresholding the luminance of an image. This works well 
with bitmap images that have many shades of colours. A pure vector image with flat colors could use a color 
override to isolate areas.

Thresholding is a method to segment or isolate certain zones in an image. This effect will isolate areas based on 
the image's luminance. Thresholding is used within the Bloom effect—see Bloom on page 394.
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Luminance Threshold Properties

Parameter Description

Name Allows you to change the node's name.

Threshold

Controls how much of the dark value to clamp off. A high value will keep only the bright areas 
of your image.

Soften Colours

Brings back the entire spectrum of luminance in areas defined by the threshold to avoid 
having only bright values.

Gamma Correction
Multiplies the gamma value to make the area brighter or darker.  A value of 1 keeps the 
gamma the same as the original image.  You can use the gamma modification on the whole 
image if you use a threshold of 0 for example.
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Output Greyscale 
Matte

Allows you output an image in grey values to use in combination with a Blending or Cutter  
node elsewhere in the node structure.

Matte-Blur 

Use the Matte-Blureffect to blur a matte or change its colour. Here is an example of a network with the result of a 
Matte-Blur effect.
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Use the Matte-Blur editor to control the output of the node.

Matte-Blue Properties

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo a 
change of depth or scale. When this option is deselected, the effect's values 
remain unchanged regardless of any depth or scale changes. This option should 
be deselected when multiple drawings are composited and attached to this effect.

Blur Type

Directional: Blurs the matte in the direction you select. For example, if a 
character is walking east, the blur may fall to the west. 

Radial: Blurs the edges of the matte evenly around points that make up its edge.

Radius Enter a value for the size of the blur. The larger the value, the greater the blur 
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effect. The blur radius is affected by the drawing scale and camera position.

Directional Angle

If you select a Blur Directional type, you can select the direction of the blur by 
entering a value from 0 to 360 in this field.

‣ 0: Blurs the image to the west.

‣ 90: Blurs the image to the south.

‣ 180: Blurs the image to the east.

‣ 270: Blurs the image to the north.

Directional Fall-off Rate

The distance where the blur fades from the edge of the image. Select a value 
between 0 and 1.

‣ A fall-off rate of zero causes the blur to fade out slowly, distributing the blur 
evenly from the edge of the character to the farthest edge of the blur.

‣ A fall-off rate of 1 causes the blur to fade out quickly so that the blur is 
heaviest closer to the edge of the image.

Invert Matte
Inverts the matte used to create the glow. The matte will become a black sil-
houette while the glow fills the background space.

Use Source Colour
Uses the colours painted in the matte for the glow effect. If you deselect this 
option, select a colour and alpha values in the Colour section.

Multiplicative Creates a more diffused glow.

Colour Lets you choose the colour and alpha values for the glow effect.

Intensity
Lets you set a value to determine the strength of the effect or attach a function to 
animate the effect.

NOTE: If this effect is connected below a Composite node set to Pass-Through, the effect will be applied to each 
element connected in the Composite node individually. If some of these elements are overlapping, the effect will 
also overlap.

Matte-Resize 
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The Matte-Resize effect lets you evenly expand a matte outward in all directions. The matte increases size from its 
centre.

If you use the Matte-Resize node to create a pulsating glow, you can enlarge the region without softening the edges. 
Using the Blur-Radial effect, the effect may be softer than you intend. This node produces a limited antialiased 
matte, which can have slightly jagged edges. You could use this node in combination with other nodes, such as:

• Tone

• Highlight

• Glow

• Shadow

• Matte-Blur

Matte Resize Properties

Parameter Description

Name Lets you rename the node.

Radius
Lets you enter a static value for the radius of the matte. You can also attach the 
Radius value to a function column to change the value over time. 
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Median

The Median effect lets you reduce the noise in a drawing while preserving its edges. Harmony sorts the values of 
pixels within a specified radius and uses the median value. You can also use this effect to create a Impressionist 
type of style.

The Median effect is only visible when the Camera view is set to Render  mode.
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Median Properties

Parameter Description

Name Allows you to change the node's name.

Radius

Lets you specify the size of the area of values to consider determining the median value. A 
median is calculated by sorting all the pixel values from the surrounding area into numerical 
order. Then the middle pixel value is used to replace the pixel being considered. 

The median tends to make an image look a bit blurrier because it reduces the contrast of 
adjacent pixels. However, it does a good job of smoothing the image and removing artifacts.

Colour Depth

Determines the number of levels per colour channel. The larger the number, the more levels 
of colour are used in the image and the more time it takes to render. Conversely, the lower the 
colour depth, the fewer colours are used, the faster it is to render. 
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Mesh Warp

Use the Mesh Warp effect to distort your drawings. With this node you can create effects such as a character in a 
warped mirror and looking through a glass jar. You can also animate the position of the grid to perform the 
distortion over time.

The Mesh Warp node is a position node, same as a Peg node.

How to use the Mesh Warp Effect

 1. In the Node Library, under the Filter tab, select the Mesh Warp node and drag it to the Node view.

 2. In the Node view, connect the Mesh-Warp node to your drawing or group nodes to deform.

504



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

 3. In the Node view, select the Mesh Warp node.

 4. Select View > Show > Control or press Shift + F11 (Windows/Linux) or ⌘  + F11 (Mac OS X) to display the 
deformation grid.

 5. Move the intersection points and move the Bezier handles to deform the grid.

 6. Grab the grid in the void spaces to pan it around. Using keyframes, you can animate its position over time.

Mesh Warp Properties

Use the Mesh Warp editor to adjust the grid size, deformation quality and the region of interest.
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Parameter Description

Rows
Increase or decrease the Rows value to change the amount of rows to use in 
the deformation grid.

Columns
Increase or decrease the Columns value to change the amount of columns to 
use in the deformation grid.

Region of Interest
Select the 2D Path option if you want both your X and Y curves to be controlled 
by the same velocity function. Select the Separate option if you want your X 
and Y curves to be independent and have independent velocity.

(x) Axis
This is the X position of the gird. This value can be animated overtime to move 
the grid horizontally.

(y) Axis
This is the Y position of the gird. This value can be animated overtime to move 
the grid vertically.

Width
This is the width value of the gird. This value can be animated overtime to 
squash or stretch the grid horizontally.

Height
This is the height value of the gird. This value can be animated overtime to 
squash or stretch the grid vertically.

Deformation Quality
This is the quality of the warm deformation. It ranges from Low to Extreme. 
The higher the quality, the better the formation will look, but the longer it will 
take to render.
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Motion-Blur 

The Motion-Blur effect is used to create a faded trail behind objects animated on a motion path. You cannot create a 
Motion-Blur on a hand-drawn animation. The layer must be moving along a trajectory (motion path) in order to work 
properly.

The Motion- Blur effect automatically creates a matte for the drawing layer attached to it, so it is not necessary to 
connect any matte into the Mask layer.

Use the Motion-Blur editor to modify the motion blur, crowd simulation or particle system effect.
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Motion-Blur Properties

Parameter Description

Number of Frames in Trail Number of frames before the current frame that will be used in the trail.

Number of Samples
Number of copies of each drawing used in the trail. The higher the number, the 
more continuous the trail appears.

Fall-off Rate

The distance where the blur fades from the edge of the image. Select a value 
between 0 and 1. 

A fall-off rate of 0 causes the trail to fade out slowly, distributing the colour 
evenly from the edge of the character to the farthest edge of the trail. 

A fall-off rate of 1 causes the trail to fade out quickly so that the trail is more 
opaque closer to the edge of the image and transparent at the end of the trail.

Intensity
Select a value to define the opacity of the trail between 0 and 10. A value of 10 
will make the trail very dark and almost opaque, where as a value of 0 will 
make the trail quite pale and ghostly transparent.

Use Mirror on Edges

When enabled this option appear when the image is close to the edge of the 
camera frame. It forces the software to use a mirror of the image to calculate 
the blur so that it appears on both sides of the drawing object. Without this 
option once your drawing reaches the edge of the Camera frame, it gets 
cropped so does the trail.

Multi-Port-In 

A Multi-Port-In node is added by default in a new Group node. Use it to add one or more input ports to the Group 
node so that you can process an image through the nodes in the Group node. 
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When you plug an element to a Multi-Port-In node, an input port appears at the top of the Group node. You can add 
additional ports to the nodes as needed.

Pass your cursor over the Group node input port to see the name of the Port Image In node that it connects to. You 
will notice that the Group node in these examples has no output port. It requires a Multi-Port-Out node to output data 
from its network.

A Multi-Port-In is automatically added when you create a group.

Use the Multi-Port-In editor to rename the node.

Multi-Port-Out 

A Multi-Port-Out node is added in a new Group node by default. Use it to add output ports to the Group node so that 
you can output the result of the group operation to the rest of the network. After you plug an element to a Multi-Port-
Out node, an output port appears on the bottom of your Group node. You can add additional output ports as needed.
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A Multi-Port-Out is automatically added when you create a group.

Use the Multi-Port-Out editor to rename the node in the network.

Negate

The Negate effect lets you invert the colour and/or alpha values in the Colour Art and Line Art of an image. The 
original value of each channel (RGB or A) is subtracted from the maximum value of that channel (255 for 8-bit 
channels) to produce the negative image.

510



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

Negate Properties

Parameter Description

Negate Colour Inverts the values of the colour channels.

Negate Alpha Inverts the transparency value (alpha channel).

Negate Colour Clamp to Alpha Limits the negated area to the alpha channel.

Note 

The Note node allows you to record any textual information that is relevant to your project. You can add comments, 
suggestions or reminders. You can add Note nodes anywhere in the network, including groups.
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Overlay Layer 

The Overlay Layer effect lets you read an element's Overlay Art layer. By placing an Overlay Layer node after a 
drawing node in the Node view, you can display only the node's Overlay layer output. The Overlay Layer node can 
be connected after nodes of any type. Any bitmap information will pass through and be processed. 

This effect will only work if something has been drawn or painted on a drawing's Overlay Art layer.
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Overlay Layer Properties

Parameter Description

Name Lets you rename the node.

Flatten

When placing the node below a Composite node containing several drawing 
nodes, such as a cut-out character, you can use this option to flatten the 
extracted result. For example, when extracting a series of outlines, parts that may 
have been hidden by colour fills might now be visible. Enable the Flatten option to 
cut the extra artwork. Harmony will use the colour fills to cut unnecessary 
artwork. If your zones are not painted, nothing will be cut. This option works with 
both pencil lines and brush strokes.

Apply to Matte Ports on Input 
Effects

At times, you may have situations where your node is placed below a Cutter node 
using a mask input and a drawing input. By default, the effect only processes the 
colours in the drawing input. The mask drawing remains untouched. If you want to 
also filter the mask drawing, select the Apply to Matte Ports on Input Effects 
option.

Antialiasing Quality

Smoothness setting applied to the art layer. Choose from Low (no antialiasing), 
Medium Low, Medium and High (extensive antialiasing). The higher the quality of 
the chosen setting, the greater the amount of antialiasing that is applied. Higher 
quality images require more time to render and more memory from your system.

Antialiasing Exponent

Controls the amount of area around the art layer edges that is used in the 
antialiasing process. A higher value uses less area, resulting in sharper edges, 
while a lower value uses more area, resulting in softer edges. If the Antialiasing 
Quality value is set to Low (no antialiasing), this value is ignored.
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Pixelate 

The Pixelate effect lets you apply a mosaic effect to an image (and its matte) based on the matte you supply. 
Pixelation makes the image look like it is made up of square tiles.

There are two input ports on the Pixelate node: 

• The left port receives the matte 

• The right port receives the image 

Pixelate Properties
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Parameter Description

Name Lets you rename the node.

Factor
Lets you control the amount the image is pixelated. You can attach the Factor 
value to a function curve to change the value over time.

Antialiasing Exponent

Controls the amount of area around the art layer edges that is used in the 
antialiasing process. A higher value uses less area, resulting in sharper edges, 
while a lower value uses more area, resulting in softer edges. If the Antialiasing 
Quality value is set to Low (no antialiasing), this value is ignored.

Quake

The Quake node lets you create a very common camera move, the camera shake. Using the Quake node, you can 
generate an automated quake instead of manually entering random keyframes. This way, you can simulate the 
shock of something heavy falling on the ground, like an earthquake or a strong vibration.

How to use the Quake node to create a camera shake

 1. From the Node Library view, drag a Quake node to the Node view.

 2. If you do not have a Camera node already, drag one from the Node Library view to the Node view.

 3. Connect the Quake node to the Camera node.

 4. Click on the Quake node's yellow square properties button to open the Quake properties.

 5. In the Quake properties window, adjust the properties.
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Quake Properties

Parameter Description

Name Lets you rename the node.

Hold Time
Lets you enter the number of frames you want one of the quake vibrations (pos-
ition) to hold for. Most camera shakes are done in a single frame (1) or double 
frame (2).

Interpolate
An interpolation is generated between the random values. Instead of jumping to 
the next position, it will slowly progress forwards to the next position. It is the 
same principle as stop-motion keyframes and motion keyframes.

Move Amplitude

This is the strength of the quake. The higher the value, the stronger the quake. 
If the value is set to 0, there will be no  motion. To have the motion start and 
stop at a specific frame during the scene, you can create a function curve and 
animate the amplitude over time. Simply click the Function  button to gen-
erate the function, then click on it again to open the Function editor.

Apply on X, Y, Z Applies the quake to the X, Y and Z-axis.

Rotation Amplitude
When the value is higher than 0, a rotating quake is applied. The higher the 
value, the stronger the quake.
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Random Seed

Generates a different randomization pattern. If you cascade two Quake nodes 
or more to apply a different amplitude on a different axis, you can change the 
Random Seed value to generate a different randomization pattern. If the X 
quake has a strong amplitude and the Y quake a weak amplitude and you do 
not want them to follow the same random pattern, then set the Random Seed 
value of the Quake nodes to different numbers.

 

Quadmap 

The Quadmap transformation layer lets you deform the shape of an element. For example, you can use it to create a 
drop-shadow effect on an element.

You can edit the Quadmap visually in the Camera view.

How to edit the Quadmap in the Camera view

 1. In the Timeline view, click the Add Layer  button and select Quadmap.

 2. Connect the drawing you want to deformto the Quadmap.

‣ In the Node view, add a Quadmap node and connect to the drawing element node that you want the effect 
to act on.
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 3. In the Tools toolbar, disable the Animate mode to change the value for the Quadmap over the entire dur-
ation of the element.

 4. In the Timeline view, click on the Quadmap layer to select it.

 5. From the top menu, select View > Show > Control or press Shift + F11.

The quadmap handles appear around the element in the window. There is also a pivot point at the centre of 
the quadmap frame that you can reposition.

 6. In the Camera view window, use the Transform tool to move the points on the quadmap. Shift + click to 
select multiple points.

The value of each point on the quadmap can be changed gradually. To do this, use the Quadmap node Layer 
Properties to attach the points to function curves.

Only the X and Y values of each point in the quadmap can be changed.

Quadmap Properties

Parameter Description
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Name Lets you rename the node.

2D Path
Changes the X and Y values simultaneously and control the velocity of the 
change.

Separate
Changes the X and Y values separately. Each one can be attached to separate 
function curves.

 

Refract 

Use the Refract effect to create effects such as ripples and heat haze. This effect is based on the refraction of light, 
which occurs when a beam of light passes through media of different density, causing the light to refract or change 
angles. This effect makes objects appear distorted or offset from their actual positions. If you imagine an object in a 
pool of water the part beneath the surface of the water appears offset from its true position.

To create a refraction effect, you need a matte with alpha values. This creates the effect of a volume passing over 
an image, refracting the light that bounces off the contents below. For a ripple effect moving across an image, you 
must move the matte with a Peg layer.
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If your matte is only black and white, meaning that there is no gradients and only solid colours in your matte 
drawing, you will need to connect a Blur Radial node after your matte Drawing node to soften the edges and get 
nicer waves.

Refract Properties

Parameter Description

Name Lets you rename the node.

Intensity
The amount of refraction to apply to the image. 

You can attach the value to a function curve to change its  value over time.

Height

The amount of depth to add to the refraction effect. When coupled with the 
Intensity effect, this value can create the effect of bending the objects below 
the refraction matte.

You can attach the value to a function curve to change its  value over time.

Remove Transparency 

The Remove Transparency effect negates transparent values in an image. You can use the Remove 
Transparency node to remove the result of antialiasing around an image.

520



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

Remove Transparency Properties

Parameter Description

Name Lets you rename the node.

Threshold
All values above the Threshold represent a transparent value. In this field, you 
must identify the value above which all alpha values are considered transparent. 
Alpha is measured from 0 to 255.

Remove Colour Transparency
Determines which pixels in the Colour-Art (RGB channels) to make fully opaque 
or fully transparent.

Remove Alpha Transparency
When selected, the Threshold value is used to determine which pixels in the 
alpha channel to make fully opaque or fully transparent.
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Shadow 

With the Shadow effect, you can turn a drawing into a shadow. It doesn't matter if the drawing layer is a fully 
coloured character. The Shadow effect will render it into a grey, semitransparent, slightly blurry silhouette. 

To add a shadow stretched out on the ground, simply add a Quadmap node to flip, stretch and skew the matte. 
Attach the entire effect to the same trajectory as your drawing layer and watch the shadow move along with your 
character. 

NOTE: Don't forget that you need to connect your character in both the final Composite node and the Shadow 
effect if you want to see your character and its shadow.
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Use the Shadow editor to modify the way the Shadow effect is created.

The Shadow effect uses the shape of the drawing connected to create the shadow behind another element and can 
blur the edges to create a softer effect. You can control the type and amount of blur, as well as the colour of the 
shadow. 

For more information on the Apply-Peg-Transformation node, see Apply Peg Transformation on page 380.

Shadow Properties

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo a 
change of depth or scale. When disabled, the effect's values will remain 
unchanged regardless of depth or scale changes. It is recommended that this 
option be disabled when multiple drawings are composited and attached this 
effect.

Blur Type

Radial: The edges of the matte are blurred evenly around points that make up the 
edge of the matte.

Directional: The matte is blurred in the direction you select.

Radius
Enter a value for the size of the blur. The larger the value, the greater the blur 
effect. The blur radius is affected by the drawing scale and camera position.

Directional Angle

If you selected the Directional Blur type, you can set the direction of the blur by 
entering a value from 0 to 360 in this field.

0: Blurs the image to the west.

90: Blurs the image to the south.

180: Blurs the image to the east.

270: Blurs the image to the north.

Directional Falloff Rate

The distance where the blur fades from the edge of the image. Select a value 
between 0 and 1.

0: Makes the blur fade out slowly, distributing the blur evenly from the edge of the 
character to the farthest edge of the blur.

1: Makes the blur fade out quickly. The blur is heaviest closer to the edge of the 
image.

Invert Matte Inverts the matte used to create the tone, shadow, or highlight.

Use Matte/Source Colour

Creates the shadow or tone using the matte shape's colour. Be sure that you are 
in render mode  to see this effect and that your background is NOT white and 
that you do NOT have a white colour card node attached to the composite. As the 
matte only gives colour information, but no alpha, the matte is automatically mul-
tiplied with the background colours. If there is no colour card attached and the 
background appears black, you will see the matte colour at full opacity. If it is mul-
tiplied with a white background, the colours disappear into the full 255.

Multiplicative Multiplies the tone or shadow colours with the background.

Colour

RGBA Enter a value to add or subtract from the colour channels in the drawings or attach 
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these values to function curves.

Colour Swatch Opens the Colour Picker where you can specify the colour.

Intensity
Lets you set a value to determine the strength of the effect or attach a function to 
animate the effect.

NOTE: If this effect is connected below a Composite node set to Pass-Through, the effect will be applied to each 
element connected in the Composite node individually. If some of these elements are overlapping, the effect will 
also overlap.

Sparkle 

The Sparkle effect transforms a vector drawing into sparkles. You have a high degree of control over the 
appearance of the sparkles.

The sparkle effect can only be used with vector drawings. If the sparkle effect node is attached to a composite, 
verify that the Composite editor is set to Vector Flatten Output.
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Use the Sparkle editor to modify how the Sparkle node creates the sparkle effect. You can also use Bezier and Ease 
function curves to change the values of factors over time.

Sparkle Properties

Parameter Description

Start Angle
Enter a value between -360 and 360 to indicate the angle of rotation of each 
sparkle.

Scale
Sparkles are determined by the size of the bounding box of the coloured areas in 
the drawing. Enter the multiple to use to scale the sparkle size.

Factor
Enter a value between 0.1 and 1 to determine how pointy the sparkle is. A value 
closer to 0 will result in a more pointed sparkle. A value closer to 1 will result in a 
more rounded sparkle.

Density Adjusts the density level.

Number of Points Enter the number of points you want each sparkle to have.

Probability of Appearing
Enter the percentage of possibility that sparkles will be displayed. Enter 100 to 
always show sparkles. Enter 0 to always hide sparkles.

Point Noise
Enter a value between 0.1 and 1 to indicate the amount by which points in a 
sparkle will distort.

Centre Noise
Enter a value between 0.1 and 1 to indicate the amount by which the angles 
between each point in a sparkle will distort.

Angle Noise
Enter a value between 0.1 and 1 to indicate the amount by which the Start Angle 
in a sparkle will distort.

Random Seed Enter a positive integer value that will be used to determine the sparkle pattern.

Use Drawing Colours Select this option to use the colour attributes of the drawing for the sparkle colour. 
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When this selection is disabled (default setting), the colour values will be used as 
they are entered in the editor.

Flatten Sparkles of Same Col-
our

Flatten all drawings of the same colour into a single layer.

Red/Green/Blue/Alpha In the RGBA fields, enter the values to use for the sparkle colour. 

Tone 

The Tone effect lets you add a dark-coloured region to your drawing and simulate the shaded area away from a 
light source. To produce the tone effect, create a drawing to control where the tone will appear. The Tone effect 
uses a matte to determine the shape and position of the tone on your drawing and can be blurred at the edges to 
create a softer effect. 

How to use the Tone effect

 1. Select a drawing layer and do one of the following:

‣ From the Node Library view, select the Tone effect and drag it to the Node view. 

‣ In the Node view, right-click and select Insert > Combine > Tone. 

 2. Connect the Tone node between the drawing and Composite node.

 3. In the Drawing or Camera view, create a drawing on a new layer that will act as the matte.

 4. In the Timeline view, click the Collapse/Expand  button on the effect layer.
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1. Do one of the following:

‣ Drag and drop the matte layer beside the Matte field.

‣ Connect the Matte drawing to the Matte port of the Tone node.

 5. Display the Tone properties and adjust the properties to control the type and amount of blur and the colour of 
the tone effect.
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Tone Effect Properties

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo 
a change of depth or scale. When disabled, the effect's values will remain 
unchanged regardless of depth or scale changes. It is recommended that this 
option be disabled when multiple drawings are composited and attached this 
effect.

Blur Type

Radial: The edges of the matte are blurred evenly around points that make up 
the edge of the matte.

Directional: The matte is blurred in the direction you select.

Radius
Enter a value for the size of the blur. The larger the value, the greater the blur 
effect. The blur radius is affected by the drawing scale and camera position.

Directional Angle

If you selected the Directional Blur type, you can set the direction of the blur by 
entering a value from 0 to 360 in this field.

0: Blurs the image to the west.

90: Blurs the image to the south.

180: Blurs the image to the east.

270: Blurs the image to the north.

Directional Falloff Rate

The distance where the blur fades from the edge of the image. Select a value 
between 0 and 1.

0: Makes the blur fade out slowly, distributing the blur evenly from the edge of 
the character to the farthest edge of the blur.

1: Makes the blur fade out quickly. The blur is heaviest closer to the edge of 
the image.
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Invert Matte Inverts the matte used to create the tone, shadow, or highlight.

Use Matte/Source Colour

Creates the shadow or tone using the matte shape's colour. Be sure that you 
are in render mode  to see this effect and that your background is NOT 
white and that you do NOT have a white colour card node attached to the com-
posite. As the matte only gives colour information, but no alpha, the matte is 
automatically multiplied with the background colours. If there is no colour card 
attached and the background appears black, you will see the matte colour at 
full opacity. If it is multiplied with a white background, the colours disappear 
into the full 255.

Multiplicative Multiplies the tone or shadow colours with the background.

Colour

RGBA
Enter a value to add or subtract from the colour channels in the drawings or 
attach these values to function curves.

Colour Swatch Opens the Colour Picker where you can specify the colour.

Intensity
Lets you set a value to determine the strength of the effect or attach a function 
to animate the effect.

Transparency 

The Transparency effect is used to make an image partially transparent. The Transparency effect is useful when 
fading images in and out, such as a phantom or to make something partially see-through, such as a window.
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You can enter a value in the Transparency field or change the transparency value over time by linking it to a 
function curve. Entering a value of 100 in the Transparency field will make the element 100% transparent, in other 
words, invisible. Entering a value of 0 will render the element completely opaque.

It is also possible to adjust a layer/node's transparency directly in the Layer Properties window without using the 
Transparency node. In the layer's properties, go to the Drawing tab and adjust the Opacity parameter. This 
parameter is visible in OpenGL mode.

Use the Transparency editor to control how translucent the element should be.
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Transparency Properties

Parameter Description

Name Allows you to change the node's name.

Transparency
Lets you set the opacity of an element.  Values range from 0 to 100. A value of 100 
will make the element 100% transparent and a value of 0 will render the element 
completely opaque.

Turbulence

The Turbulence effect is a mathematically generated effect that uses fractal noise to create turbulent distortions in 
an image. You can see the effect when used with an image as the background. You can create flowing water, 
funhouse mirrors, and waving flags.

For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/video-
tutorials/chapter/adam-phillips-harmony-effects.
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Turbulence Properties 

Parameter Description
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Noise Type

Lets you select a type of noise pattern.

Perlin: Creates pseudo random patterns. The greyscale contains a continuity 
between different tones of grey.

Simplex: Creates a more contrasted noise pattern with more variation than Per-
lin. There is a smooth variation of intensity.

Sinusoidal: Creates a repeated wavelike pattern.

Sub Scaling: Applies Perlin noise twice. The second noise is added where 
dark areas appear in the original. The frequency of the second iteration is 
higher so the noise is smaller.

Rocky: Uses the Perlin pattern but converts the very high and low values to 
more moderate values. For example, the whites become light greys and the 
blacks become dark greys.

Small Bumps: Uses the Perlin pattern. The transitional grey areas between 
blacks and whites become inverted so they look like dark lines. The extremes, 
black and white areas, become whitish.

Fractal Type

Transforms the noise pattern, created by the Noise type and controls the way 
layers are composited. These are variations of the basic noise.

Turbulent Twist: Applies a turbulent effect on the pattern so it changes the 
transition between black and white by adding more modulation.

Fractional Brownian: Applies a basic application of noise and composites by 
adding subsequent layer with the Complexity parameter.

Threshold: Changes the dark greys into black values so there is more black in 
the noise for higher contrast.

Invert Threshold: Inverts all the values of the Threshold type so a negative 
image of it is created.

 Terrain: Adds contrast and converts the dark greys into white or light greys.

Pinning Constrains the effect within the image boundaries.

Amount Specifies the amplitude of displacement.

Frequency
The density of displacement appearing in the noise. A higher value produces a 
greater amount of displacement in a given area; a lower value produces a smal-
ler amount.

Offset Moves the entire image.

Seed
This value determines the starting noise pattern on the first evolution of the 
effect.

Locked Applies parameter value while retaining the X and Y ratio.

Separate Allows you to apply different parameter values to X and Y.

xy
When locked, applies parameter values to both X and Y. When separated, 
allows you to apply different value to X and Y.

Evolution Determines the displacement pattern over time.

 
Evolution Frequency: This factor makes the complexity iterations animate or 
transform at a higher speed. In other words, the second, third, etc. passes, con-
trolled by the Complexity parameter, will mutate faster than the main one.
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Complexity

Complexity: The number of noise layers that make up the noise. Each 
successive layer has a higher frequency, resulting in a smaller noise effect. 
You can have up to seven passes. Increasing this number increases the depth 
and amount of detail in the noise. Use Complexity with Sub Scaling when the 
value is 1 or greater. Note: Increasing the Complexity results in longer 
rendering times. 

 

Gain: Controls the amount of opacity present in the iteration of noise. This also 
affects the layer when using Sub Scaling. With a value of 0, you will not see 
the sub noise. A value of 1 will show the sub noise just as strong as the main 
one. For example, with water ripples, a higher amount of Gain will reveal more 
ripple or subripples.

 

Sub Scaling: The factor by which the main noise is modified at each iteration 
of complexity. A value of 1 make the two noises identical. A value of 2 makes 
the sub noise twice as small. The next iteration would be 4 times smaller. Val-
ues must be greater than 1.

Turbulent Noise

The Turbulent Noise effect uses Perlin noise to create greyscale noise for organic-looking backgrounds, 
displacement maps, and textures, or to simulate clouds, fire, lava, steam, flowing water, or vapour. The Turbulent 
Noise effect models turbulent systems with smaller noise features moving more quickly than larger noise 
features.  The Turbulent Noise effect creates smooth animations and takes less time to render than other noise or 
grain effects. 

For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/video-
tutorials/chapter/adam-phillips-harmony-effects.
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Turbulent-Noise Properties

Parameter Description

Noise Type

Perlin: Creates pseudo random patterns. The greyscale contains a continuity 
between different tones of grey.

Simplex: Creates a more contrasted noise pattern with more variation than Perlin. 
There is a smooth variation of intensity.

Sinusoidal: Creates a repeated wavelike pattern.

Sub Scaling: Applies Perlin noise twice. The second noise is added where dark 
areas appear in the original. The frequency of the second iteration is higher so the 
noise is smaller.

Rocky: Uses the Perlin pattern but converts the very high and low values to more 
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moderate values. For example, the whites become light greys and the blacks 
become dark greys.

Small Bumps: Uses the Perlin pattern. The transitional grey areas between 
blacks and whites become inverted so they look like dark lines. The extremes, 
black and white areas, become whitish.

Fractal Type

Transforms the noise pattern, created by the Noise type and controls the way lay-
ers are composited. These are variations of the basic noise.

Turbulent Twist: Applies a turbulent effect on the pattern so it changes the trans-
ition between black and white by adding more modulation.

Fractional Brownian: Applies a basic application of noise and composites by 
adding subsequent layer with the Complexity parameter.

Threshold: Changes the dark greys into black values so there is more black in 
the noise for higher contrast.

Invert Threshold: Inverts all the values of the Threshold type so a negative 
image of it is created.

Terrain: Adds contrast and converts the dark greys into white or light greys.

Frequency
The density of displacement appearing in the noise. A higher value produces a 
greater amount of displacement in a given area; a lower value produces a smaller 
amount.

Offset Moves the entire image.

Locked Applies parameter value while retaining the X and Y ratio.

Separate Allows you to apply different parameter values to X and Y.

xy
When locked, applies parameter values to both X and Y. When separated, allows 
you to apply different value to X and Y.

Evolution Determines the displacement pattern over time.

 
Evolution Frequency: This factor makes the complexity iterations animate or 
transform at a higher speed. In other words, the second, third, etc. passes, con-
trolled by the Complexity parameter, will mutate faster than the main one.

Complexity

Complexity: The number of noise layers that make up the noise. Each suc-
cessive layer has a higher frequency, resulting in a smaller noise effect. You can 
have up to seven passes. Increasing this number increases the depth and amount 
of detail in the noise. Use Complexity with Sub Scaling when the value is 1 or 
greater. Note: Increasing the Complexity results in longer rendering times. 

 

Gain: Controls the amount of opacity present in the iteration of noise. This also 
affects the layer when using Sub Scaling. With a value of 0, you will not see the 
sub noise. A value of 1 will show the sub noise just as strong as the main one. For 
example, with water ripples, a higher amount of Gain will reveal more ripple or sub-
ripples.

 

Sub Scaling: The factor by which the main noise is modified at each iteration of 
complexity. A value of 1 make the two noises identical. A value of 2 makes the 
sub noise twice as small. The next iteration would be 4 times smaller. Values 
must be greater than 1.

 
Depth:  This value determines the composition order when the Z value of two ele-
ments is the same.
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Underlay Layer

The Underlay Layer effect lets you read an element's Underlay Art layer. By placing an Underlay Layer node after a 
drawing node in the Node view, you can display only the node's Underlay layer output. The Underlay Layer node can 
be connected after nodes of any type. Any bitmap information will pass through and be processed. 

This effect will only work if something has been drawn or painted on a drawing's Underlay layer.
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Underlay Layer Properties

Parameter Description

Name Lets you rename the node.

Flatten

When placing the node below a Composite node containing several drawing 
nodes, such as a cut-out character, you can use this option to flatten the 
extracted result. For example, when extracting a series of outlines, parts that 
may have been hidden by colour fills might now be visible. Enable the Flatten 
option to cut the extra artwork. Harmony will use the colour fills to cut 
unnecessary artwork. If your zones are not painted, nothing will be cut. This 
option works with both pencil lines and brush strokes.

Apply to Matte Ports 
on Input Effects

At times, you may have situations where your node is placed below a Cutter 
node using a mask input and a drawing input. By default, the effect only 
processes the colours in the drawing input. The mask drawing remains 
untouched. If you want to also filter the mask drawing, select the Apply to 
Matte Ports on Input Effects option.

Antialiasing Quality

Smoothness setting applied to the art layer. Choose from Low (no antialiasing), 
Medium Low, Medium and High (extensive antialiasing). The higher the quality 
of the chosen setting, the greater the amount of antialiasing that is applied. 
Higher quality images require more time to render and more memory from your 
system.

Antialiasing Exponent

Controls the amount of area around the art layer edges that is used in the 
antialiasing process. A higher value uses less area, resulting in sharper edges, 
while a lower value uses more area, resulting in softer edges. If the Antialiasing 
Quality value is set to Low (no antialiasing), this value is ignored.

Visibility

The Visibility node lets you control whether an item is visible in OpenGL mode versus the Soft Render mode in 
the Camera view. If the Soft Render option is not enabled, the layer will not be exported.
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Visibility Properties

Parameter Description

Display in OpenGL View Displays your render in OpenGL mode.

Soft Render  

Extra Commands 
These are some useful compositing commands you can find in Harmony.

Recalculate All
Refreshes the node structure and 
rerenders the display when the Camera 
view is in render mode. 

In the select Network View menu, select
Scene > Render > Recalculate All.

Recalculate 
Selected

Refreshes the node structure and 
rerenders the display of selected 
elements when the Camera View is in 
render mode.

In the Network View menu, select 
Scene > Render > Recalculate 
Selected.

Auto Render 
Write

Renders a frame each time the current 
frame is changed. 

You must have a Write node in your node 
structure to use this command.

In the Network View menu, select 
Scene > Render > Auto Render Write 
or press Ctrl + W (Windows/Linux) or ⌘  
+ W (Mac OS X).

Print Node View Prints the Node view.

Select File > Print > Node View.

In the Node View menu, select 
File > Print.
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Chapter 10: Particles

Particle effects are both cool and a huge time saver. You can create atmospheric effects, such as rain, grass or fire 
to more complex systems, such as swarms of animated insects-- all in a fraction of the time it would usually take.

Particle effects act in the same way as all other effects in Harmony, except they always work within their own 
specifically structured system. You can attach a Blur effect node under a Drawing node and the image contained in 
the Drawing node will become blurry. Particle effect set-ups are more complex than simply adding a node and 
playing with its parameters. To keep things simple, just think of each Particle effect as its own group.

Main topics:

Basic Structure 542

Accessing Default Particle Templates 543

Particle Nodes 543

3D Region 544

Baker 546

Baker Composite 548

Bounce 548

Explosion 549

Gravity 551

Image Fracture 553

Kill 557

Move Particles 558

Orbit 560

Planar Region 562

Random 564

Region Composite 565

Repulse 566

Rotation Velocity 567

Sink 569

Size 569

Sprite Emitter 571
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System Composite 578

Velocity 578

Visualizer 580

Vortex 582

Wind-Friction 583

Basic Structure

This is what the basic structure of a Particle effect looks like in the Node view. This structure can change 
depending on the type of effect you are trying to create. 

Colour Coding

Particle effects are colour coded to make them easy to identify by colour and function. Each colour represents a 
different function. For example, Action nodes, such as Velocity, Move-Particles and the Sprite Emitter are bright 
purple. These colours can be edited in the Preferences dialog box by going to Edit/File > Preferences > General 
tab > Edit Colours button > Particle tab.
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In addition to defining groups by colour, node in-ports and out-ports are also colour-coded. In the network shown in 
the illustration above, the Particle-Baker is dark yellow and the Particle Visualizer purple. Look closely and you will 
notice that the in-port on the Particle Visualizer, where the Particle-Baker is connected, is also dark yellow. 
Similarly, the out-port on the Particle-Baker, where the Particle Visualizer is connected, is purple.

This system gives you an idea, at the very least, of what type of node is needed to fill a specific port.    

• Visualizer - This node assembles a particle system through its middle port. It can accept a Peg on either 
side. The system is flattened at this node and generated as a single image. This lets you move the effect's 
position in your scene or change its render order.

• Action - These nodes affect the particle dynamics; they determine how they are created and moved around in 
space. If there are multiple Action nodes hooked to a composite, they are executed from right to left. Due to 
this ordering, there should generally be an emitter on the right-most port.

• System Composite - Unlike a regular composite that reads all the position information from its in-port nodes 
and combines them accordingly, a System Composite is specifically designed to handle Action node 
information.

• Baker - These nodes allow you to make decisions about the particle system's position, angle, number, etc. the 
same way that a baker would make decisions about the ingredients that go in a cake.

• Region Composite - This node combines Region nodes. In case you have more than one Region in your 
effect, this composite will help define the position and render order of the different Regions.

• Region - These nodes are used to define the region from where the particles are emitted. These regions can 
be Planar or 3D.

Accessing Default Particle Templates
Harmony comes with some basic Particle effect templates. You can change the effect's "sprite" with a drawing, 
image or animated sequence of your own. Then tweak its properties to adjust the effect to your liking. Or you can 
use the templates to analyze their structure so you can build your own.

How to access the Particle templates

 1. From the top menu, select Insert > Particle > and one of the following Particle effect templates:
 l Basic Particle System: This effect template has the simplest structure and the parameters for all of 

its nodes are set to the default values. For example, the Planar-Region has not been rotated or res-
ized, the particles have not been randomized in the Sprite-Emitter, and the particles start their gen-
eration on the first frame and die out at the maximum number allotted in the Particle-Baker.    

 l Basic Gravity Based System: This effect template simulates particles being generated from a 
source with special emphasis on adding gravity to the particle system.

Particle Nodes
You can access the Particle effects through the Node Library view. The Particle category contains all the nodes 
needed to build various Particle effect systems.

543



Chapter 10: Particles     

This section explains each node's purpose, its layer properties and how to adjust these properties. 

3D Region

The 3D Region effect lets you define the 3D region, which can take many forms, such as a sphere, cone, cylinder 
or box. The 3D Region node acts in contrast to the Planer Region node, which generates and emits particles from 
a 2D plane.

You can connect a 3D Region to a Sprite-Emitter to define the region from which particles are generated. It could 
also be connected to a Bounce node to define a region against which particles bounce. If connected to a Sink 
node, it will define a region where the particles will disappear.

How to preview the 3D Region

1. From the top menu, select View > Show > Control or press Shift + F11 (Windows/Linux) or ⌘  + F11 
(Mac OS X).
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3D Region Properties

Parameter Description

Name Lets you rename the node.

Shape

Choose a shape for the 3D Region by clicking on the Type drop-down menu and 
selecting either Box, Cylinder, Cones, Sphere or Image.

If you select Image, you must connect the node of a vector drawing or a 
vectorized bitmap image to the left port (blue node) of the 3D Region node. The 
particles will then be emitted from that image' shape. Don't forget that you can 
rotate your vector drawing in 3D space by enabling the 3D option in its Layer 
Properties.

Size

Enter different values into the Width, Height and Depth fields to change the 
dimensions of the 3D Region's selected shape. Depending on the shape 
selected, some fields may be greyed-out if they are not applicable. You can also 
modify the shape with the Transform Tool by grabbing the control handles 
(turquoise squares) in the Camera or Perspective views. You can also change the 
dimensions of the region over time by click on the function button at the end of 
each field.

Radius

Enter different values in the Max or Min fields to change the inner or outer radius 
of applicable shapes, such as a cylinder, cone or sphere. You can also change 
the radii by grabbing the control handles (turquoise squares) in the Camera or 
Perspective views. The radii of the region can be changed over time by clicking 
the function button at the end of each field.
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Baker

The Baker effect, also known as Particle-Baker, lets you make decisions about the particle system's position, 
angle, number, etc. in the same way that a baker would make decisions about the ingredients that go into baking 
a cake. The Baker performs the particle simulation, combining all the ingredients specified to get the final result. 
The Baker must always be connected to the Particle-Visualizer.
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Particle Baker Properties

Parameter Description

Name Lets you rename the node.

Seed

Allows you to apply a random effect to the particle system. There may be times 
when you want to copy the particle system to two different locations on your 
screen. You can take the out-port of the Particle System Composite node, and 
plug this into two separate Bakers and Visualizers. Then you could move one 
system over by attaching a peg into the left side of one Visualizer. This makes the 
two systems look exactly the same. Add a random Seed to make them look 
different.

Simulation Quality

Defines how many simulation steps per frame are performed. The lowest quality 
creates one step per frame. Raising the quality will divide the simulation time and 
create two or more steps of simulation for each frame. This increases the 
computation time, but also increases the quality of the result.

Number of Pre-roll Frames

Allows you to select a start position in the particle effect sequence, other than the 
start (generation) of the sequence. This allows you to start the particle effect part-
way through its cycle, even if it starts on frame 1 of your project. An example of 
when this parameter might come in handy is when you want it to be already 
raining at the start of your scene. If you don't change the number of Pre-roll 
Frames, it will always start to rain at the beginning of the scene.

Maximum Number of Particles
Lets you put a limit on the number of particles that will be created; particles will 
stop being generated once this number is reached. 

Age Particles

Tracks how long a particle has existed in its cycle from the time of its inception. 
Knowing a particles "age"  means you can tack other parameters onto its life span, 
such as having the particle start to disappear or change colour at a certain 
time.age.

Move Position

Allows the particles to move position, otherwise the particles cannot flow in a 
specified direction. This option also exists in the Move Particles node. You do not 
always need a Move Particles node; this is why this option exists in the Baker. 
This option is also useful when your Move Particles node is cut off by a sink—see 
Sink on page 569. 

Move Angle
Allow particles to flow from different angles. This option also exists in the Move 
Particles node. You do not always need a Move Particles node; this is why this 
option exists in the Baker. This option is also useful for when your Move Particles 
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node is cut off by a sink—see Sink on page 569. 

Baker Composite

The Baker Composite effect is used to composite more than one Particle-Baker, as well as any other elements 
that need to be combined before they pass through the Particle Visualizer.

Bounce

The Bounce effect lets you to make particles bounce off a surface with realistic physical modelling. This node 
should have a region connected to it, and that region will act as a bounce plane so when any particle hits it, it will 
bounce off at the correct angle.
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Bounce Properties

Parameter Description

Name Lets you rename the node.

Trigger An on/off switch using binary code. 1 = on, 0 = off.

Friction

Enter a value in this field to increase the amount of friction each particle exper-
iences as it makes contact with the planar surface. A positive value creates more 
friction and slows the particle down. A negative value lessens the friction and 
makes the surface appear more slippery.

Resilience

Increases or decreases the bounciness of the particle. A value of zero causes the 
particle to hit the planar surface once and slide off any downward facing angle. A 
positive value, even by decimal increments, causes the particle to become 
bouncy. A negative value deadens the effect, the same way a lack of Region 
would.

Cutoff Speed
Increasing this value widens the bounce arc. If the connected Planar Region is 
completely flat, a value of zero will cause the particle to bounce up and down in 
place. A tilted plane in the direction of the bounce will also widen the arc.

Explosion

The Explosion effect lets you create an explosion. As it is an Action node, it should be connected to the Particle 
System Composite after the Sprite Emitter. As the explosion occurs, the particles will burst rapidly away from the 
centre of the explosion (the centre of the defined Region), then gradually slow down.
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Explosion Properties

Parameter Description

Name Lets you rename the node.

Trigger An on/off switch using binary code. 1 = on, 0 = off.

Coordinates
Use the X, Y and Z fields to enter different position values to move the particle 
system around in 3D space. You can also connect a Peg node to the Explosion 
to manipulate its position with the Transform or Move tool.

Radius

Defines the surface of an invisible sphere. As the explosion occurs, the 
exploded particles inside the boundaries of this sphere will be effected by the 
force of the explosion, while the particles that eventually pass through will 
remain unaffected.

Sigma
The higher the Sigma value, the longer it takes for the particles to completely 
disappear, even if the initial explosion seems to occur just as rapidly.

Magnitude Defines the magnitude of the explosion. The greater the magnitude, the faster 
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the particles break up.

Epsilon

This value works in opposition to the Sigma value. The higher the value, the 
slower the initial explosion occurs. If the value is high (an integer value) then lar-
ger particles remain suspended for a longer period of time from the initial explo-
sion and takes a while to gradually break down. A smaller (decimal) value 
breaks the particles down to smaller forms more rapidly from the time of the ini-
tial explosion. 

: 

Gravity

The Gravity effect lets you define the gravity of the particle system.
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Gravity Properties

Parameter Description

Name Lets you rename the node.

Trigger An on/off switch using binary code. 1 = on, 0 = off.

Apple Gravity

Forces the particle system to adhere to the force of gravity. Values must be 
entered into the Direction fields, along with enabling this option, in order for it to 
work. If this option is not selected, the particle system will explode outwards 
from its origin point.

X Direction
Directs the particle stream to the left or right (along the X-axis). A value of 1 
forces the particle stream to the right, while a value of -1 forces the particle 
stream to the left.

Y Direction
Directs the particle stream up or down (along the Y-axis). A value of 1 forces 
the particle stream to flow upwards, while a value of -1 forces the particle 
stream to flow downwards.

Z Direction
Directs the particle stream forwards or backwards (along the Z-axis). A value 
of 1 forces the particle stream to flow forwards, while a value of -1 forces the 
particle stream to flow backwards.

Apply Gravity between 
Particles (Relative Gravity)

Applies gravity between each particle, taking their masses into account. The 
mass of the particle can be specified at emission time via the Sprite or Image 
Emitter. 

Relative Gravity Magnitude Adjust the amount of gravity applied between particles. 

Relative Gravity Epsilon

The acceleration falls off the further the particles get from each other. When 
the particles are very close to each other, the acceleration becomes very high, 
so you should define a small region around the particles so they never actually 
touch.

Relative Gravity Maximum 
Distance

Adjusts the radius beyond which particles do not affect each other.
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Image Fracture

The Image Fracture effect breaks an image into pieces. This effect requires two image objects: the image to be cut 
and the shape of the cut pieces (matte). The image to be cut can be anything from a vector drawing to a bitmap 
image to an entire scene's composite—effects and all. The image to be cut should be hooked to the Image Fracture's 
right port.

The matte should be flattened if you want it to work like a cookie cutter (hollow shape with a frame) and can be 
composed of brush or pencil lines. It can also be a solid shape, many solid filled shapes, and even many solid filled 
overlapping shapes. When the matte is made of overlapping pieces, the cut image will be multiplied at those zones 
to break apart in multiple layers. The matte drawing should be hooked to the Image Fracture's left port.

The two image objects overlap perfectly when combined in the Image Fracture. This means that you must take the 
12 by 12 field into account when judging the scale and proportion of these objects. If the matte does not overlap a 
part of the image, that part of the image will not be cut. The matte does not have to be a continuous shape. It could 
be three separate circles, which would then be cut and pulled away from the image.
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NOTE: You can display the grid and use the Light Table feature in the Drawing view while drawing or scaling the 
image and matte to ensure that they're the correct size relative to one another.

Here's an example of a node structure with the Image Fracture effect:
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Image Fracture Properties

Generation Tab

Parameter Description

Emission

Trigger An on/off switch using binary code. 1 = on, 0 = off.

Type
You may want to design a variety of different drawings that will vary the appear-
ance of the particle system. In this case, you should put each drawing on its own 
cell in the drawing layer. Each drawing will then be a new type of particle.

Type Generation Strategy
Lets you sequentially or randomly assign a type (moving from one drawing to the 
next).

Particle Type 0
This is the frame number of the first drawing. If you have a 5-frame cycle that 
starts on frame 1, you would put a 1 here.

Particle Type 1
This is the frame number of the last drawing. If you have a 5-frame cycle that 
starts on frame 1, you would put 5 here.

Age

Age at Birth
A different start frame number can be entered in this field. This means that a 
particle can start with a different drawing than the drawing on frame 1.

Age at Birth Standard Devi-
ation

Allows a random deviation for the birth of the particles. If you have a five-frame 
cycle that starts on frame 1, but you want the particles to be a random type, then 
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you may want to set the Age and Birth to 3 with a standard deviation of 2. That 
means the particles will randomly be born at any frame from 1 to 5.

Advanced

Particles Mass
Defines a mass for the particles which will affect how the particles interact with 
gravity.

Align Initial Velocity
Aligns the initial velocity with the region from which the particles are being emit-
ted. If you are emitting from a sphere, the particles will all start out moving away 
from the centre of the sphere.

Rendering Tab

Parameter Description

Transformation

Size over Age
Lets you determine the size of the particle as it ages. Attach a function to this 
attribute if you would like to, for example, have the particles get smaller as time 
goes on.

Directional Scale Scales the particle in the direction of its movement.

Directional Scale Exponent 
Factor

Sets an exponent here for how much you would like that particle to scale.

Align with Direction Aligns the particle in the direction of its movement.

Axis to Align
Select the axis that you want to align. This axis refers to the axis of the Draw-
ing grid from the Drawing node plugged into the emitter.

Flip X Axis to Match Direction
You may want to have the particle align to the X direction of movement. You 
can see this property being used in the Lemmings example.

Flip Y Axis to Match Direction
Similar to flipping the X axis, you may want to flip the Y axis of a drawing to 
match the direction of the particle movement.

Use Rotation of Particle Enables rotation on the particle.

Keep Volume
When you choose to do a Directional Scale, this will automatically maintain the 
volume of the particle by squashing it proportionally to how much it stretches 
as a result of the directional scale.

Colouring

Colouring Strategy Lets you choose how to define the colour of the particle.

Use Drawing Colour The particle remains the same colour as it was drawn with.

Map RGB Based on Age
Attach a function to this to vary the Red, Green, and Blue values of the particle 
as it ages.

Map RGBA Based on Age
Attach a function to this to vary the Red, Green, Blue, and Alpha values of the 
particle as it ages.

Apply Opacity Based on Age
Keeps the original RGB values from the drawing, but vary the Alpha (Opacity) 
according to a function that you define here.

Map RGB Based on Frame  
Changes the Red, Green, and Blue values of the particles based on the frame. 
Changing based on the frame means that ALL particles will change colour on 
that frame, regardless of their age.
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Map RGBA Based on Frame  
Changes the Red, Green, Blue, and Alpha values of all particles on a given 
frame by attaching a function.

Apply Opacity Based on 
Frame

Uses the original RGB values from your drawing, but varies the Alpha (Opa-
city) of the particles on a certain frame by attaching a function to this.

Red, Blue, Green, Alpha
This is where you can attach functions to the Red, Blue, Green and Alpha val-
ues. You can also click on the colour swatch to adjust the colour.

Compositing

Blur

Lets you attach a function to define how you want the particles to blur based on 
the age, frame or camera distance of each particle. There are low and high qual-
ity blurs. Also, you can attach a function to define how all particles should be 
blurred. 

Blur Intensity
Lets you set a value or attach a function to animate the blur according to the 
type of blur that was defined from the drop-down list.

Falloff Rate

The distance where the blur fades from the edge of the image. Select a value 
between 0 and 1.

A falloff rate of 0 causes the blur to fade out slowly, distributing the blur evenly 
from the edge of the drawing to the farthest edge of the blur.

A falloff rate of 1 causes the blur to fade out quickly so that the blur is heaviest 
at the edge of the drawing. 

Blend Mode Defines a blend mode for the particles to get cool effects.

Blend Intensity
This is a percentage of how opaque you want the particles to be blended. 50 = 
50% transparent. 100 = opaque.

Kill
The Kill effect lets you determine when particles disappear.
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Kill Properties

Parameter Description

Name Lets you rename the node.

Trigger An on/off switch using binary code. 1 = on, 0 = off.

Use Maximum Lifespan Makes particles disappear when they reach their maximum lifespan.

Kill Younger

To use this parameter, you must attach a function to this property because if 
you select this option at time 0, you will never see any particles. If you set Kill 
Younger to 10, at time 0, there will be no particles older than 10, so you will 
never see any particles. 

It may be useful to have the particles animating over time, and at some point in 
time, you may want to kill all the younger particles. An example would be an 
animation where the particles change from blue to yellow. At every frame, new 
particles are generated, and the particles that already exist age. Then you 
would add an explosion that kills all particles younger than 10 frames. It would 
kill all the blue particles, leaving only the yellow particles.

Kill Younger Than This is where you can animate the effect for Kill Younger.

Kill Older Makes particles disappear when they reach a certain level of maturity.

Kill Older Than Lets you set the age at which particles disappear.

Move Particles

The Move Particles effect lets you determine whether the particles are stationary (like grass) or moving (like rain), 
and you can animate this function on and off. 
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Move Particles Properties

Parameter Description

Trigger An on/off switch using binary code. 1 = on, 0 = off.

Age Particles

Ages the particles. Note that if you select the Move Position and Move Angle, 
then the particles will age implicitly. If you do not want the particles to move, but 
still want them to age, deselect Move Position and Move Angle, and select Age 
Particles. 

The Age Particles parameter also exists in the Baker, however whatever happens 
in the Baker happens after everything else in the particle system. So, if for 
example you have a Kill node, it will kill the particles before they age. You 
probably want to age the particles before you determine whether to kill them. 
Therefore, if you have a Kill node, make sure to age the particles in your Move 
node before you kill them. If you age the particles both in the Move and Baker 
node, then the particles will age twice on that frame instead of once.

Move Position

Lets you enable movement on the particles. There is also a Move Particles option 
in the Baker. If it's deselected in the Baker and in the Move node, the particles will 
not move; they will simply generate in place and stay there. If the option is 
selected on the Baker, the particles will move. But if you need the particles to 
interact with another Action, say a Sink, then you want the particles to move 
before they reach the sink. This is why you have a separate Move node, so you 
can place this Move before (to the right of) the Sink in your particle system 
composite.

Move Angle
Like the Move Position, this enables the rotation of particles in the particle 
system.

Move Particles Follow Each 
Other

Allows one particle to follow another particle, through an attraction between the 
particles. This is particularly useful when you want to create a snake-like effect, 
where the particles are animating across the screen and following each other.

Follow Intensity
Lets you adjust the strength of the attraction between particles following each 
other.
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Orbit

The Orbit effect lets you define an axis the particles will be attracted to and orbit around. You can place a Peg 
layer into the orbit to move the position of the orbit without adjusting the parameters in the Layer Properties.

Fine-tuning the Orbit effect can take a bit of finesse because the orbit takes into account the velocity of the 
particles, and uses this to determine whether:

• The particle will orbit around the axis

• The particle will be influenced but eventually escape

• The particle will hardly be influenced at all. 

This is just like how gravity between astral bodies works in space. Here are some examples of how having the 
orbit in the wrong place can give some cool (but perhaps not useful) effects:

You will also want to make sure that your initial velocity is varied, so use an interpolated speed and set two 
different values. That way, there will be a spread between them. If not, then you will get the effects as shown 
above.

Also, you should use the Peg layer to move the position of the Orbit node around until you find the right spot to get 
the look you're trying to achieve. It also helps to set some pre-roll frames on your Baker to get things ramped-up 
before you start to manipulate the position of the Orbit node.

Here's an example of what a typical node structure with an Orbit node looks like:
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Orbit Properties

Parameter Description

Name Lets you rename the node.

Trigger An on/off switch using binary code. 1 = on, 0 = off.

Orbit Type
Lets you select the type of Orbit you want to use. For most scenarios, like 
asteroids orbiting a planet, a point will suffice. If you want to rotate around an axis 
instead, choose between the X, Y, Z axes or set up your own custom axis.

Magnitude

Adjust the amount that the acceleration of each particle will be adjusted. The 
higher the value, the more the particle will accelerate towards the orbit. A 
magnitude of 0.001 is a good number to use for this. When the magnitude is set 
too high, the particles will simply fly out into space.

  

Point X
Defines the X position of the centre of the Orbit. You may also leave this at 0 and 
use a peg to move the position of the Orbit node.
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Point Y and Z Defines the Y and Z position of the centre of the Orbit.

Direction X

Defines the X component of the axis of rotation for the orbit. This is only taken 
into account if you choose to set up a custom axis. If this is set to 1, and Y and Z 
are set to 0, then the axis will be going in the same direction as the X axis. If the X 
component is set to 1, and the Y component is also set to 1, then the axis will be 
at a 45 degree angle between the two.

Direction Y and Z Defines the Y and Z components of the axis of rotation for the orbit.

Planar Region

Like the 3D region, this determines a region that you can use as a source or as a bounce plane, but instead of a 
3D region, it's a 2D plane. Connect a peg to the right in-port to adjust the position of the plane.
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Planar Region Properties

Parameter Description

Name Lets you rename the node.

Shape Type

Lets you define the shape of the plane. The parameters that you can adjust below 
will be greyed out depending on the shape type you choose. Each shape can be 
adjusted from the Camera view using the Transform tool by selecting the Planar 
Region and then selecting View > Show > Control.

Rectangle: The width and height on a rectangle.

Disc: The point (the centre) of the disk. You can also adjust values for the 
minimum and maximum radius. A minimum radius of 0 will simply be a circle.

Triangle: The three points of the triangle independently.
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Line: The two points on a line.

Point: The position of one single point.

Image: If you choose to use the Image option, then you should use the left in-port 
of the Planar-Region to connect a drawing layer that can be used as a mask.

Mirror Negative Frames
Mirrors the input peg transformation to generate positions for frames before the 
scene begins.  

Size
Width: The width of a rectangular region.

Height: Adjust the height of a rectangular region.

Radius
Minimum: The minimum radius on a disc region.

Maximum: Adjust the maximum radius on a disc region.

P1

X: The X position of Point 1. Point 1 could refer to the point on a triangle, line, or 
point.

Y: The Y position of Point 1.

P2
X: The X position of Point 2. Point 2 could refer to the point on a triangle or line.

Y: The Y position of Point 2.

P3
X: The X position of Point 3. Point 3 refers to a point on a triangle.

Y: The Y position of Point 3.

Random
The Random effects lets you put a random seed on some qualities like acceleration, speed, rotation speed, and 
position. There's also a Seed value in the Baker, but you may only want to make one particular aspect of the 
system random. This effect gives you control over the randomness of a particular property.
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Random Properties

Parameter Description

Name Lets you rename the node.

Trigger An on/off switch using binary code. 1 = on, 0 = off.

Parameter
Lets you choose a parameter to make random: None, Acceleration, Speed, Rota-
tion Speed, and Position.

 

Region Composite

The Region Composite effect lets you composite multiple regions, 3D regions or planar regions. You may want to 
emit particles from multiple regions in the same particle system.
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Repulse
The Repulse effect repulses a particle around a region, but is different than the Bounce node as it is repelled 
before it physically hits the region.

Repulse Properties

Parameter Description

Name Lets you rename the node.

Trigger An on/off switch using binary code. 1 = on, 0 = off.

Magnitude This value should be between 0 and 2. The higher the value, the more drastic-
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ally the particles will be repulsed.

Look Ahead
Determines how far ahead of the particle's current position to see whether 
there's an obstacle coming. This value should be between 0 and 100.

Epsilon
Affects how quickly the effect of the repulse wears off. The smaller the num-
ber, the longer the effect lasts. This value should be between 0.1 and 0.0001.

Rotation Velocity

The Rotation Velocity effect lets you define the initial rotational velocity of the particles. The values that you set up 
for this node refer to each individual particle's drawing axes. This means that if you choose to rotate around the X-
axis, it will rotate around each particle's local X-axis as defined by its drawing plane.

The rotational velocity should be set before you emit the particles, such as to the right, so the velocity is taken into 
account when the particles are created.
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Rotation Velocity Properties

Parameter Description

Name Lets you rename the node.

General

Trigger: An on/off switch using binary code. 1 = on, 0 = off.

Axis Type: Lets you select the type of axis to use.

• Use Input Shape: Uses a region to define the rotational axis of the 
particles. The axis of each particle's rotation will be perpendicular to the 
plane that particle is created on.

• Constant Axis: If you choose to rotate the particles around a 
constant axis, then each particle will rotate around the same axis. 
This axis will then be defined as Axis0.

• Interpolated Axis: If you choose to rotate the particles around an 
interpolated axis, that means each particle will have its own 
rotational velocity which lies somewhere between Axis0 and Axis1.

Axis

Axis0 X: Defines the X component of Axis0. If you set the X to 1, and the Y 
and Z to 0, then the particle will rotate around its X-axis as defined by its 
drawing plane. If you set X to 1 and also Y to 1, then it will rotate around an axis 
that is 45 degrees between X and Y.

Axis0 Y: Defines the Y component of Axis0.

Axis0 Z: Defines the Z component of Axis0.

Axis1 X: Defines the X component of Axis1. This applies only when you have 
selected an Interpolated axis.

Axis1 Y: Defines the Y component of Axis1.

Axis1 Z: Defines the Z component of Axis1.
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Speed (Degrees/Frame)

Minimum: The minimum initial rotation that a particle can have, in degrees per 
frame.

Maximum: The maximum initial rotation that a particle can have, in degrees 
per frame.

Sink
The Sink effect causes particles to disappear when outside the region that is plugged into the sink. It can also be 
inverted, so the particles disappear when they enter the region instead.

Sink Properties

Parameter Description

Name Lets you rename the node.

Invert
The default behaviour of the sink is for particles to disappear when they depart the 
region. When inverted, the particles disappear when they enter the region instead.

Size
The Size effect lets you animate the size of the particles.
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Size Properties

Parameter Description

Name Lets you rename the node.

Trigger An on/off switch using binary code. 1 = on, 0 = off.

Size Type

Lets you select a type for the size. If you choose Constant Size, then all 
particles will be animated to have the same size. If you choose Input Shape 
instead, then you must input a Region into the in-port of the Size node. It will 
use this region to determine the size of the particles.

Size Lets you adjust the size of the particles.

: 

: 
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Sprite Emitter

The Sprite Emitter effect is an all-purpose emitter. You can plug it into a drawing layer to generate particles that look 
like your drawing layer. You could also just output dot particles if you have no image layer connected. There are 
many parameters to control how particles are emitted. 

Sprite Emitter Properties

Generation Tab

Parameter Description

Emission

Trigger: An on/off switch using binary code. 1 = on, 0 = off.

Number of Particles: This is where you can define how many particles will be emitted on 
each frame.

Probability of Generating Any Particles: This is a probability percentage between 0 and 
100. If the probability is set to 100%, it will generate the Number of Particles specified. If 
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you set the percentage to 50%, then there's only a 50% chance that it will generate the 
number of particles set in the Number of Particles. You can play with this value to add 
random spacing to the generation of particles.

Generator

Streak Seed: The number of streaks to generate.

Source Sampling Time Offset: Sets the streak start at a different time to offset its 
position.

Source Sampling Duration: This parameter is the key to generating streaks. If set to 0, 
the behaviour is the same as before. If set to -10 for example, it will sample the input 
region (in this example the Planar-Region) 10 frames in the past. If in this mode, the 
Number of Particles parameter is the number of streaks to generate. If you want to 
generate five streaks for example, you need to set the Streak Size to a value different 
than 0, otherwise all the streaks will be at the same spot.

Source Samples Per Frame: The number of subdivisions for each frame. A value of 1 
generates a particle for each frame. A value of 16 generates a particle on each 1/16th of a 
frame.

Streak Size: The radius of the sphere used for sampling the offset of the streak.

Region Size for Baked Particle Input: The Baked Particle Input property refers to when 
you use a Baker as an input to a Sprite Emitter. You can do this when you want to 
generate particles from other particles. When you do this, you have the option of setting a 
sphere around the source particle from which the new particle system will generate 
particles. That is the region which is referred to in this value. If you look at the following 
example, you'll see that the purple smiley faces are generating smaller green, blue, and 
yellow smiley faces. This is done by plugging the Baker from the purple smiley faces into 
the Sprite Emitter of the other smiley faces. See the following images:

Type
You may want to design a variety of different drawings that will vary the appearance of 
your particle system. To do this, you should put each drawing on its own cell in the 
drawing layer. Each drawing will then be a new Type of particle.
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Type Generation Strategy: 

Lets you sequentially or randomly assign a type (moving from one drawing to the next).

Particle Type 0: 

This is the frame number of the first drawing. If you have a 5-frame cycle that starts on 
frame 1, you would put a 1 here.

Particle Type 1:

This is the frame number of the last drawing. If you have a 5-frame cycle that starts on 
frame 1, you would put 5 here.

Initial Parameters Tab

Parameter Description

Age

Age at Birth: A different start frame number can be entered in this field. This means that 
a particle can start with a different drawing than the drawing that you have on frame 1.

Age at Birth Standard Deviation: Allows a random deviation for the birth of the 
particles. If you have a 5-frame cycle that starts on frame 1, but you want the particles to 
be of a random type, then you may want to set the Age and Birth to 3 with a standard 
deviation of 2. That means that particles will randomly be born at any frame from 1 to 5.

Set Maximum Lifespan: Makes particles die automatically.

Maximum Lifespan: This is how long the particle will exist before dying.

Maximum Lifespan Sigma: The lifespan variation of particles. If set to 0, all particles 
will have the same lifespan. A larger value means that particle lifespans will be 
distributed over a larger range.

Advanced

Particles Mass: Define a mass for the particles. This mass will affect how the particles 
interact with gravity.

Copy Particle Velocity for Baked Particle Input: If you select this option, the velocity 
of the parent system will be applied to the child system when a Baker is used as the 

573



Chapter 10: Particles     

region for a Sprite Emitter.

Add Particle Age for Baked Particle Input: If you select this option, the age of the 
parent system will be inherited by the child system when a Baker is used as the region for 
a Sprite Emitter.

Align Initial Velocity: This aligns the initial velocity with the region from which the 
particles are being emitted. If you are emitting from a sphere, then the particles will all 
start out moving away from the centre of the sphere.

Minimum Initial Rotation: Define a minimum rotation in degrees that the particle can 
have when it is generated. There is also a separate Rotation-Velocity node in which you 
can define this parameter.

Maximum Initial Rotation: Define a maximum rotation in degrees that the particle can 
have when it is generated.

Rendering Tab

Parameter Description

Sprite Selection
Rendering Strategy: Select a method to determine the particle type defined 
for each particle that is created.
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• Render as Dot: Renders each particle as a dot. This is useful 
mainly for previewing the effects of your particle system without 
using the drawing layer (sprite).

• Use Frame Number: As the frame number increases, the type of 
particle will change to match the frame number. This means that 
ALL particles in the system will change together as the frame 
number changes. If you only have a few drawings, then you may 
want to enable Cycling to cycle those drawings.

• Use Frame Number as Index in Selector: When you select this 
option, you can use the Selector to animate the Frame Number it 
uses over time. So, instead of taking the current frame as the Frame 
Number, you can write your own function instead. For example, if 
you animate the selector so that at frame 1, it starts out at 2, then 8 
frames later you add another keyframe to set the value to 4. 
Between frame 1 and frame 8, the particles will all change type 
together from what they look like on frame 2 to what they look like on 
frame 4.

• Use Particle Type: Each particle that is generated will look like the 
Particle Type that was assigned on the Generation tab. For 
example, if you use a value of 1 for Particle Type 0, and 6 for 
Particle Type 1, then each particle will be assigned a type from 1 to 
6. This type corresponds to the drawing that appears on the sprite on 
that frame number. So if you have a drawing layer called Sprite that 
is plugged into the left in-port of the Emitter, it will look for the 
drawings in cells 1 to 6 of Sprite to assign those drawings to each 
particle.

• Use Particle Type as Index in Selector: This option allows you to 
use the Selector to manually create a function that assigns how 
many of which particle will be created. 

For example, you can set the Particle Type to go from 1 to 100 in the 
Generation tab. Then use the Selector to remap the particle types to 
a certain drawing. So for example you could create five drawings, 
labelled 1 to 5, and use the selector to create mainly 1s, no 2s, a few 
3s, 4s, and a very few 5s. What it's doing is looking at the X-axis to 
find what the particle "type" is, then looking at the Y-axis to find out 
which drawing to assign to that "type." When you use 1 to 100 as a 
type, then when you're setting the values, they act as a percentage.
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• Use Age: As the particle ages, it will change appearance from what 
appears on the Sprite's first drawing to the subsequent drawings. 
This means that each particle can have its appearance animated as 
it gets older.

• Use Age as Index in Selector: You can animate the Selector to 
change how a particle ages over time. For example, if you have a 
Sprite with six drawings on it, you might want to animate it so it 
changes from drawing 1, on frame 1, to drawing 2, on frame 10, then 
drawing 3 on frame 14, drawing 4 on frame 16, drawing 5 on frame 
17, etc. so the particle rapidly ages. This allows you to change the 
timing of the aging dynamically through the selector, instead of 
having to modify the exposure of the cells on the Sprite.

Selector: Animates the Selector in conjunction with the Rendering Strategy to 
adjust the parameters that control the particle’s appearance at birth and over 
time.

Cycling: If you're using rendering strategies like Frame Number or Age, you 
may want to cycle the drawings. For example, if you are using Frame Number, 
but you've only got 5 frames worth of drawings in your Sprite, then if you use 
"No Cycle," your Particles will disappear after frame 5. You can choose to 
cycle Normally (1-2-3-4-5-1-2-3-4-5) or Back and Forth (1-2-3-4-5-4-3-2-1).

Number of Drawings in Cycle: Lets you indicate how many frames from your 
Sprite you'd like to cycle.

Transformation

Size over Age: Lets you determine the size of the particle as it ages. Attach a 
function to this attribute if you want to, for example, have the particles get 
smaller as time goes on.

Directional Scale: Scales the particle in the direction of its movement.

Directional Scale Exponent Factor: Sets an exponent here for how much 
you want that particle to scale.

Align with Direction: Aligns the particle in the direction of its movement.

Axis to Align: Select the axis that you want to align. This axis refers to the axis 
of the Drawing grid from the Drawing node plugged into the emitter.

Flip X Axis to Match Direction: You may want to have the particle align to the 
X direction of movement. You can see this property being used in the 
Lemmings example.
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Flip Y Axis to Match Direction: Similar to flipping the X axis, you may want to 
flip the Y axis of a drawing to match the direction of the particle movement..

Use Rotation of Particle: Enables rotation on the particle.

Keep Volume: When you choose to do a Directional Scale, this will 
automatically maintain the volume of the particle by squashing it proportionally 
to how much it stretches as a result of the directional scale.

Colouring

Colouring Strategy: Lets you choose how to define the colour of the particle.

• Use Drawing Colour: The particle remains the same colour as it 
was drawn with.

• Map RGB Based on Age: Attach a function to this to vary the Red, 
Green, and Blue values of the particle as it ages.

• Map RGBA Based on Age: Attach a function to this to vary the 
Red, Green, Blue, and Alpha values of the particle as it ages.

• Apply Opacity Based on Age: Keeps the original RGB values from 
the drawing, but vary the Alpha (Opacity) according to a function 
that you define here.

• Map RGB Based on Frame: Changes the Red, Green, and Blue 
values of the particles based on the frame. Changing based on the 
frame means that ALL particles will change colour on that frame, 
regardless of their age.

• Map RGBA Based on Frame: Changes the Red, Green, Blue, and 
Alpha values of all particles on a given frame by attaching a 
function.

• Apply Opacity Based on Frame: Uses the original RGB values 
from your drawing, but varies the Alpha (Opacity) of the particles on 
a certain frame by attaching a function to this.

Red, Blue, Green, Alpha: This is where you can attach functions to the Red, 
Blue, Green and Alpha values. You can also click on the colour swatch to 
adjust the colour.

Compositing

Blur: Lets you determine the Blur to apply to the particles.

• No Blur: No blur will be applied to the particles.

• Directional Blur Based on Age: Attaches a function to define how 
you want the particles to blur based on the age of each particle. The 
particle will blur in the direction of movement.

• Directional Blur Based on Frame: Attaches a function to define 
how all particles should be blurred at a particular frame. The particle 
will blur in the direction of movement.

• Low Quality Radial Blur Based on Age: Attaches a function to 
define how you want the particles to blur based on the age of each 
particle. This will be a low quality blur.

• Low Quality Radial Blur Based on Frame: Attaches a function to 
define how all particles should be blurred at a particular frame. This 
will be a low quality blur.

• Low Quality Radial Blur Based on Camera Distance: Defines 
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how you want the particles to blur based on their distance from the 
camera. This is a low quality blur. 

• High Quality Radial Blur Based on Age: Attaches a function to 
define how you want the particles to blur based on the age of each 
particle. This is a high quality blur.

• High Quality Radial Blur Based on Frame: Attaches a function to 
define how all particles should be blurred at a particular frame. This 
is a high quality blur.

• High Quality Radial Blur Based on Camera Distance: Defines 
how you want the particles to blur based on their distance from the 
camera. This is a high quality blur. 

Blur Intensity: Lets you set a value or attach a function to animate the blur 
according to the type of blur that was defined from the drop-down list.

Falloff Rate: The distance where the blur fades from the edge of the image. 
Select a value between 0 and 1. A falloff rate of 0 causes the blur to fade out 
slowly, distributing the blur evenly from the edge of the drawing to the farthest 
edge of the blur. A falloff rate of 1 causes the blur to fade out quickly so that the 
blur is heaviest at the edge of the drawing.

Blend Mode: Defines a blend mode for the particles to get cool effects.

Blend Intensity: This is a percentage of how opaque you want the particles to 
be blended. 50 = 50% transparent. 100 = opaque.

 

System Composite
The System Composite node is where you connect all the "Actions" of your particle system. An action includes 
any of the light-purple nodes, like Gravity, Emitters, and velocity parameters. All of the "Actions" help to define 
the behaviour of the particle system.

Velocity
The Velocity effect defines the initial velocity of the particles that are emitted in the particle system. You can 
select this node and select View > Show > Control to display the manipulation handles to help you set the 
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parameters of this node. Use your Transform tool to modify the manipulation handles in the Camera or Perspective 
view.

Velocity Properties

Parameter Description

General

Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

Velocity Type

• Use Input Shape: If you plug a Region into the in-port of the Velocity 
node, it will take the shape of this region to determine the initial velocity 
of the particles. They will take a velocity that is perpendicular to the 
surface of the shape.

• Constant Speed: Sets a constant speed for the initial velocity of the 
particles.

• Interpolated Speed: Each particle is assigned an initial speed that is 
somewhere between the two values set for Interpolated Speed.

• Random in All Directions 2D: All particles will be assigned a random 
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velocity in any direction on a 2D plane.

• Random in All Directions 3D: All particles will be assigned a random 
velocity in any direction.

• Random in Cone: Particles will be assigned an initial velocity 
anywhere in the shape of a cone.

• Random in 2D-Pie: Particles will be assigned an initial velocity 
anywhere in the shape of a pie slice on a 2D plane.

Bilateral: Generates positive and negative velocities in a given direction. For 
example, you can generate particles with cone-shaped velocity, (e.g. a bazooka 
firing) going only in the forward direction, but you can also generate velocities in 
the opposite direction.

Direction of Normal (for Ran-
dom in all Directions 2D)

Lets you input values for the perpendicular direction for the Random property in All 
Directions 2D.

X: Sets a value between 0 and 1 to determine how much influence the X-axis has 
over the direction of the normal. For example, if the X value is set to 1, and Y and 
Z are set to 0, then the perpendicular (normal) will be going in the X direction. If X 
is set to 1, and Y is also set to 1, then the axis will be 45 degrees, halfway 
between X and Y. Feel free to use the Manipulation Handles for the velocity node 
by selecting the Velocity node and then selecting View > Show > Control. This 
will allow you to use the Transform tool in the Camera View or the Perspective 
View to set the appropriate values.

Y: Set a value between 0 and 1 to determine how much influence the Y-axis has 
over the direction of the normal.

Z: Set a value between 0 and 1 to determine how much influence the Z-axis has 
over the direction of the normal.

Speed

Minimum: There are some speeds that are constant, and some that are a range of 
values between a minimum and maximum. Set the minimum speed here.

Maximum: Set the maximum speed for interpolated speeds.

Deviation from Direction

Minimum Angle: This is used for Cone and Pie shapes. Put a non-zero value 
here if you want there to be a hole in the middle of your cone or pie.

Maximum Angle: Set the maximum angle for your cone or pie here.

Visualizer
The Particle-Visualizer effect renders and flattens the particle system down to a single plane. You can plug a peg 
module into the left port to animate the position of the whole particle system. Plugging a peg into the right port will 
move the depth where the flat plane is generated, so you can move it behind or in front of various other drawing 
layers in your scene. You can even have two Visualizers with pegs in the right in-ports that are at different depths 
to display some particles in front of and some particles behind a character or drawing in the scene.
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Visualizer Properties

Parameter Description

Force Render as Dots

Temporarily renders your system as Dots when previewing a simulation. All draw-
ings are ignored and the system is forced to render as dots.  
Note: You can also use the option View > Particle > Show Particles as Dots in 
OpenGL. When enabled, the particles will always be displayed as dots in the 
OpenGL preview mode to make playback speed faster for heavy scenes.

Rendering Order

Lets you set the order in which you want the particles to appear in the render.  

Back to Front: Added particles will appear behind existing particles.  

Front to Back: Added particles will appear in front of existing particles.  

Oldest to Youngest: Older particles will appear behind younger particles.  

Youngest to Oldest: Older particles will appear in front of younger particles. 

 Ascending Types: Lower types will appear behind higher types.  

Descending Types: Lower types will appear in front of higher types.

Fix Output Alpha

This is an important option when using some filters like Screen or Multiply in the 
Blend Mode that can be specified in the Rendering tab of the Emitter. When work-
ing with premultiplied images, if the alpha is not fixed in the visualizer, you may 
see some unusual artifacts. 

Scale Particle System Using 
Parent Peg

Respects the scaling of a particle system so you can position and resize it as you 
like. Old scenes with particle system will still work as this option is disabled.

Global Scaling Factor Lets you set the scaling factor for particle system.

Visibility

The Visibility node lets you control whether an item is visible in OpenGL mode versus the Soft Render mode in the 
Camera view. If the Soft Render option is not enabled, the layer will not be exported.
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Visibility Properties

Parameter Description

Display in OpenGL View Displays your render in OpenGL mode.

Soft Render  

Vortex

The Vortext effect allows you to define an axis as a vortex, so the particles will spin around this axis.
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Vortex Properties

Parameter Description

Trigger An on/off switch using binary code, where 1 = on and 0 = off.

X Direction Defines the X portion of the axis of rotation for the Vortex.

Y Direction Defines the Y portion of the axis of rotation for the Vortex.

Z Direction Defines the Z portion of the axis of rotation of the Vortex.

Radius Defines the radius at the top of the vortex.

Exponent (1=cone)
Defines a curve that gives the Vortex a certain silhouette. 1 forms a cone, greater 
than 1 curves inward.

Up Acceleration Defines the vertical acceleration of the particles that are inside the Vortex.

In Acceleration Defines the inward acceleration of particles that are outside the Vortex.

Around Acceleration Defines the acceleration around the vortex of particles that are inside the Vortex.

Wind-Friction
The Wind-Friction effect lets you define the amount of wind in the scene, and animate the wind over time.
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Wind-Friction Properties

Parameter Description

Trigger An on/off switch using binary code, where 1 = on and 0 = off.

Friction/Wind X, Y, Z
Defines the amount that the wind will dampen or increase the speed of the 
particles in the X, Y or Z direction.

Min Speed
The minimum speed of particles that will be affected by the wind. Particles 
moving slower than this will not be affected

Max Speed
The maximum speed of particles that will be affected by the wind. Particles 
moving faster than this will not be affected.
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Chapter 11: Light Shading Effect

Cut-out animation allows for great advancements and time saving in production, but it has certain limitations. One of 
the main advantages of using a cut-out puppet is the ability to reuse your characters without having to redraw them 
and you can modify your animations very quickly. This speeds up the process quite a bit. One of the disadvantages 
of cut-out animation when wanting to retain the time saving factor and ability to quickly modify an animation, is the 
fact that you cannot easily create tones and highlights. To do so, you must draw all the highlight zones for each 
frame by hand. Following that, if you want to modify your animation, you have to redraw those zones. This slows 
down the process. There are a few tricks for doing simple automated highlights, but the results are not always 
convincing.

The Harmony Light Shading effect provides a proper solution to this issue. It allows you to add a few nodes to your 
original puppet rig and obtain a customizable lighting effect on your characters. It can be applied to any object in your 
scene, not only on cut-out characters. The light shading effect allows you to define your volume zones as well as 
your light source and animate its position.

This chapter is divided as follows:

• About Light Shading on page 585

• Light Shading Nodes on page 588

• Light Shading Setup on page 591

• Light Shading Properties on page 601

About Light Shading
In Harmony, all drawings are flat 2D planes, unless you imported 3D elements. A light source cannot interact well 
with a flat shape to create tone and highlight areas within it. To create shading zones, Harmony uses the bevel 
principle to create a three-dimensional shape illusion. To do that, you must define which object or combination of 
objects should be defined as a volume. Next, you can carve and emboss areas  using colour zones within the 
volumes to create what is referred to as 3D geometry.
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If you have a scene with one single drawing layer, you will define that layer as your volume object, since there are 
no other elements in the scene. The light shading effect will emboss the contour of the shape, but if you want to 
have highlight and tone zones within the drawing, you will need to carve and emboss areas using specific colour 
zones.

If you have a cut-out character composed of several drawing layers, you will need to identify the different layers or 
group of layers you want to define as volume objects. For example, you could group the arm, forearm and hand 
layers as one object, while the head could be another volume. Depending on your design, you will have to analyze 
and decide what should be grouped. You can then use colours to carve areas within those volumes.
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The beauty of the light shading effect is that you only have to set it up once. You can animate the light source 
position, shading style, as well as colour and your volume objects, carving and adding areas will be accurately used. 
There's no need to redraw another set of zones depending on the light source or even draw tones for any animation 
frames. This only needs to be done once in the character rig. The compositing artist will then have the freedom to 
play around with the light positioning and ambiances.

Harmony provides you with a series of nodes and parameters allowing you to shape, carve and model your image's 
3D geometry as you like. Each volume object has an ID number. You can have several volumes using the same ID 
so they can receive the same shading, smoothing and bevelling parameters. If you want to treat each area 
individually, you can assign them different ID numbers.

You also have the possibility to create tones, not only highlights. You can also combine both on the same image. 
Both tones and highlights react to the same carving colours, modelling parameters, and set volume objects.
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Light Shading Nodes
You can build your light shading effect using these five nodes:

• Volume Object on page 588

• Normal Map on page 589

• Light Position on page 590

• Light Shader on page 590

• Tone Shader on page 591

To learn more about each node's parameters, see Light Shading Properties on page 601.

Volume Object

The Volume Object node lets you define a volume zone the light will interact with.

If three is a single drawing on which you want to apply shading, you only need one Volume Object node. For cut-
out characters, you will require more as you will define which should be different volumes. For example, you could 
decide that the arm, forearm, and hand will form one shape for the light to hit and create a highlight. You could 
then define the body as a separate volume. If you use different Volume Object nodes on the arm pieces, you will 
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get odd carvings and bumps where the joints overlap. Before adding light shading to your rig, you should analyze 
how the parts will interact with one another.

All the Volume Object nodes in your structure will be gathered in the Normal Map node where you can define the 
parameter for each volume.

Normal Map

The Normal Map node lets you centralize all Volume Object nodes and chisel out the shading 3D geometry (bevel 
height, smoothing, carving, etc.). It could be described as carving a bas relief. You only need one Normal Map node 
per light shading effect and, in general, only one per scene.

The normal map will carve and emboss a flat plane using vectors. The X, Y and Z coordinates of the normal map 
vectors are stored in RGB values to convert the 3D aspect into a visual result and use it to create various effects, 
such as light reflections (light shading). The X value is stored in the Red channel. The Y value is stored in the Green 
channel. The Z value is stored in the Blue channel.

A normal map can be used to create other effects. If you're are working with an OpenFX plugin or other plugin 
requiring a normal map, you can use the Normal Map Converter node to translate the Harmony normal map to a 
format supported by your plugin. The Normal Map Converter node has been optimized to work with GenArts® 
plugins, but you also have the ability to use it on custom plugins..
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Light Position

The Light Position node is the actual light source interacting with all the defined volume objects. You can set its 
position in relation to the objects and animate it over time. All volumes will react according to the light's motion.

This is not where you set the light type or colour. You'll be adjusting these in the Light Shader and Tone Shader 
nodes.

Light Shader

The Light Shader node lets you adjust the highlight parameters, such as the colour, to create the desired 
ambiance. You can animate most parameters over time to create a mood change, sunset or any other type of light 
transition. The beveling height and smoothing is set in the Normal Map node.
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Tone Shader

The Tone Shader node lets you adjust the tone parameters, such as the colour, to create the desired ambiance. You 
can animate most parameters over time to create shade transitions. The beveling height and smoothing is set in the 
Normal Map node.

Light Shading Setup
The first step in setting up your light shading effect is to identify which volumes you want the light to interact with.

Here's what a basic light shading effect node structure looks like:

To learn more about each node's parameters, see Light Shading Properties on page 601.
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Once your basic volumes are set up, you can use colours from your colour palettes to carve or add zones. 
Depending on the design of the drawing, you may want to use the same palette as the character, background or 
object, or you may want to use a specific palette reserved specifically for this purpose.

Finally, you can set up the light source and animate it.

How to set up a basic light shading effect

 1. In the Node Library view, select a Volume Object node from the Shading category and drag it to the Node 
view.

 2. In the Node view, connect the Volume Object node between the drawing node and the Composite node. 
Click on the node's properties button (yellow square) and rename it with the volume it represents. This will 
make it much easier to edit the beveling in the Normal Map node later on.
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If you need to combine several elements into one volume, you can connect the elements into a Composite 
node set to Pass-Through and connect that Composite node to the Volume Object node.

 3. In the Node Library view, in the Shading category, select a Normal Map node and drag it to the Node view.

 4. In the Node view, connect a second connection from the Volume Object node to the Normal Map node. Don't 
connect the Normal Map's output port yet.
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 5. In the Node Library view, in the Shading category, select a Light Shader or Tone Shader node and drag it to 
the Node view.

 6. In the Node view, connect the Normal Map output node to the shader node's middle input port.

 7. From the Volume Object node, pull out a third connection and connect it to the shader node's right input 
port.
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 8. In the Node Library view, in the Shading category, select a Light Position node and drag it to the Node view.

 9. In the Node view, connect the Light Position output node to the shader node's left input port (green).

 10. Connect the shader's output port to the Composite node to the left (in front) of the Volume Object's Com-
posite connection. This will display the light shading effect on top of the original drawing. Connecting it to the 
right would result to nothing as the effect would be hidden behind the drawing.
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 11. If you added colours to your drzwing to carve in some areas, in the Node Library view, select a Colour-
Override node and drag it to the Node view.

 12. In the Node view, connect the Colour-Override node between the Volume Object and the Composite 
nodes. Make sure the Volume Object node is connected to the Colour-Override's right input port.
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 13. Click the Colour-Override node's properties button (yellow square) to open the Layer Parameters dialog. From 
the Colours section, drag your carving colours to the Individual Colour Overrides section. In the Mode 
column, set all your colours to Colour not visible.

 14. To combine both the Tone Shader and the Light Shader, from the Node Library bring the other shader node 
and drag it to the Node view.

 15. In the Node view, connect the same Light Position, Normal Map and Volume Object nodes to the new shader 
node.

 16. Click the Normal Map node's properties button (yellow square) to open the Layer Parameters dialog.
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 17. In the Volume Creation section, from the Object List , select all the Volume Object nodes you want to use 
in this map.

‣ It's possible to add all Volume Object nodes at the same time by selecting the Add all Defined 
Objects option or it's possible to add each Volume Object node one by one.

 18. In the Camera view, enable the Render mode to view the final effect.

 19. See Light Shading Properties on page 601 to adjust the light shading parameters.

How to add and carve volumes

 1. Add colour swatches in your character's colour palette or in a new palette solely reserved for carving. 
Name them Carving and Adding. By choosing different colours, it will be easier to differentiate where 
those colours will carve or add.

 2. In the Camera or Drawing view, draw the areas you want to carve out and add. It's recommended to draw 
them in the Underlay or Colour Art layer.
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 3. In the Node view, click the Normal Map's properties button (yellow square) to open the Layer Properties win-
dow.

 4. In the Override Modelling by Colour section, click Add Colour and select the palette containing your carving 
and adding colours.

 5. Add your Carving and Add colour swatches.

 6. Increase or decrease the Carving - Adding value by adjusting the slider to carve or emboss your volumes 
using the colour zones.

 7. In the Camera view, enable the Render mode to view the final effect.
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How to display the controls of the Light Position node

 1. In the Node view, select the Light Position node.

 2. Do one of the following:

‣ In the Camera View toolbar, click the Show Control button.

‣ From the top menu, select View > Show > Control.

‣ Press Shift + F11 (Windows/Linux) or ⌘  + F11 (Mac OS X).

A yellow camera appears in the scene, representing the light source.

How to animate the light source and the target

 1. In the Tools toolbar, select the Transform  tool and animate the light source or target.

 2. Before moving the light source for the first time, you must move the light to make it visible. At the moment, 
the target is not visible because it is hidden behind the light source.

A red line appears, starting at the light source. This line represents the direction of the light. The green dot 
at the end of the line represents the target. Depending on the setting of your Light Shader or Tone Shader 
node, the direction or target may be more useful.
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Light Shading Properties
Harmony provides you with a wide series of parameters to customize your light shading effects. See below the 
description for each node's parameters.

• Volume Object Properties on page 601

• Normal Map Properties on page 602

• Light Position Properties on page 605

• Light Shader Properties on page 606

• Tone Shader Properties on page 608

Volume Object Properties

Parameter Description

Name

With the light shading feature, the naming of the nodes becomes important. Since 
there isn’t any limitation on the number of Volume Object nodes that can be added 
to a node structure, it's quite important to give a good name to each Volume 
Object node. These names will later appear in the Normal Map node, in the 
Volume Creation section.

ID

This is the identity number you assign to a drawing or a group of drawings that will 
be represented in the same volume once it is generated by the Normal Map node. 
This ID is also in the Normal Map node, where a list of all Volume Objects is 
applied.

Cut Volume Cues with Geo-
metry

When this option is not selected, Harmony cuts the 3D geometry (shading bas 
relief) of the drawing after it has been generated by the Normal Map node. 

Some nodes, such as filters, can affect the shape or colour of the drawing. Those 
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nodes will be processed and recognized by the Normal Map node. Therefore, it is 
possible to limit the 3D geometry only on a part of the drawing, but not all of it. The 
3D geometry follows the edge of the entire drawing and will not be affect by the 
filters.

Use Drawing to Create 
Volume

During the generation created by the Normal Map node, the shape of the drawing 
or group of drawings identified with the same ID will be recognized to create the 
volume. When this option is selected, the Light Shader and Tone Shader effect 
appear inside the contour of those drawings.

Elevation Baseline

The baseline defines how much you can add or carve the Volume Object. The 
drawing or group of drawings connected to this Volume Object node share the 
same baseline value. Because this setting is closely tied to the adding/curving 
option called Intensity (0-100) (accessible in the Volumetric Colour Information of 
the Normal Map node), both places need to have some parameters set. Playing 
only with the Geometry Intensity won’t change anything if there aren’t any 
parameters set in the Normal Map node.

Normal Map Properties

Parameter Description

Volume Creation
Lists all the different volume object IDs are listed. This is where you can define 
the basic volumetric shape of each Volume Object node connect to the Normal 
Map.
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Object

Let you add or remove Volume Object nodes that are connected to the Normal 
Map node.

Add All Defined Objects: Adds all Volume Object nodes connected to the 
Normal Map node.

Remove Selected Objects: Removes all Volume Object nodes from the 
Volume Creation list.

Name

The name that was previously set ineach Volume Object node. This 
information can be really helpful when there are many  volume objects listed. 
With a good name, it is easy to discover what the ID number is related to.    
When you hover over this column, a tooltip appears listing all volume objects 
with the same ID.

In the following image, the tooltip indicates that three copies were made from 
FootR-Object. By keeping the same name, you can easily see that each time 
you see a Volume Object named “FootR-Object”, the ID will be the same.

In the second example, a specific name was created for each volume object, 
even if they have the same ID. That way, it is easy to find a specific nodenode 
when searching for an element with the Search tool in the NetworkNode view.

ID
The identity number that was previously set in the volume object nodenode 
appears here. The tooltip in the ID column lists all drawing elements that are 
connected to the volume object with this identity number.
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Bevel Size
Defines the size of the bevel on the contour of all the drawings related to a 
specific ID number

Elevation
Defines the elevation of a specific volume object. The higher the value, the 
more the volumetry of this Volume Object resembles a conical or pyramidal 
shape.

Elevation Smoothness
Complementary to the Elevation column. Instead of keeping a conical or 
pyramidal shape, the shape will be smoothed to create a sphere or a bump 
shape. The edge will be round instead of sharp.

Bevel Multiplier
A multiplier of the Bevel Size value in the board. This affects every object 
listed.

Elevation Multiplier A multiplier of the Elevation value in the board. This affects every object listed.

Elevation Smoothness Mul-
tiplier

A multiplier of the Elevation Smoothness value in the list. This affects every 
object listed.

Consider Truck Factor

Keeps the same ratio for the Light Shading system when the camera zooms in 
or out. This parameter cannot work properly if the size of the drawing, with a 
volume object nodenode, is changed on the drawing itself. In other words, if the 
animation is directly created on the drawing layer.

Override Modelling by Colour

Add Colour
Lets you add or remove any colour that will affect the Adding/ Carving options 
in the list beneath.  When you select this button, each colour palette in the 
scene is listed and all their swatches are displayed.

Swatches
The first column of the Override Modelling by Colour board is the Swatches. 
This column does not have a name. When you select a colour swatch from the 
Add Colour list, the colour swatch appears at the beginning of the list. 

Generate Normals Activates or deactivates the generation of the Normal Map.

Normal Map Quality Lets you change the Quality of the Normal Map from low to high. 

Output Elevation in Blue Chan-
nel

When selected, the Elevation is calculated and appears in the soft render 
mode. 

When deselected, the object ID appears in the soft render mode. 

Because it is connected to the blue channel of a drawing, the result will only 
affect the blue channel.
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Light Position Properties

Parameter Description

Source Lets you control the value of the light source.

Target The point or direction at which the light is pointing

 

3D Path: Lets you use a 3D path when animating the light.

Separate: Lets you enter separate values for the X, Y and Z axes.

(x) Axis: Lets you type in a new East/West coordinate corresponding to the 
desired position.

(y) Axis: Lets you type in a new North/South coordinate corresponding to the 
desired position.

(z) Axis: Lets you type in a new Forward/Backward coordinate corresponding to 
the desired position.
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Light Shader Properties

Parameter Description

Name Lets you rename the node.

Light

Light Type

Directional: A light that is parallel in the scene. Each “beam” of light follows 
the direction defined by the light source and target, and point in the same 
direction. This type of light is used when the light source is far away or very 
big, like the sun.

Point: A light that illuminates everything around it. Its “beam” of light will go in 
all directions like a fire.

Spot: A light that forms a conical shape like a flashlight.

Cone Angle
The value that defines the light’s cone angle. This option is only accessible 
with the Light Type set to Spot.

Diffusion
Lets you play with the diffusion of the light on the surface of the drawing. In 
other words, it is the edge softness. This option is only accessible with the 
Light Type set to Spot.

Light Source Elevation
Defines the height of the spotlight. This option is only accessible when the 
Light Type set to Spot or Point.

Shading Type
Smooth: The light and tone fx will have smooth edges.

Sharp: The light and tone fx will have sharp edges.

Bias Define the polarization of the light. 
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When the Shade type is set to Smooth, it defines the width of the light’s 
smooth zone. 

When the Shade type is set to Sharp, the Bias defines the antialiasing on the 
edge of the hightlight or tone zone. But,if the Shade type is set to Sharp, the 
Bias option need a small value such as 0.1 or 0.2. The exponent will be able to 
compensate the limitation of this small value.

Abruptness
This is a multiplier value of the Bias option. It will define how quick the 
polarization of the light will change from a value to another.

Adjust Light Intensity Lets you adjust the light intensity.

Intensity Lets you set the strength of the light.

Multiplier Multiplies the value of the Intensity option.

Surface Reflectivity
This option is useful for exaggerating the light on the edge of the 3D geometry. 
The closer an edge is to the light source, the more intense the light will be.

Colour

Red/Green/Blue/Alpha

The colour and transparency of the Colour Card. You can also attach these 
parameters to function columns to change their values over time. 

Click the colour swatch to open the Colour Picker window and select a colour.

Colour Swatch Opens the Colour Picker window in which you can specify the colour.

Use Image Colour
Lets you use the colour of the drawing in a lighter or darker colour for the 
highlight and tone fx.

Image Colour Intensity Lets you blend the colour of the light with the image colour.

Flatten Fx
This is useful when there are several highlight and tone fx, one over the other, 
but are supposed to be merged together. Sometimes, shadows and lights look 
better when they do not overlap.
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Tone Shader Properties

Parameter Description

Name Lets you rename the node.

Light

Light Type

Directional: A light that is parallel in the scene. Each “beam” of light follows 
the direction defined by the light source and target, and point in the same 
direction. This type of light is used when the light source is far away or very 
big, like the sun.

Point: A light that illuminates everything around it. Its “beam” of light will go in 
all directions like a fire.

Spot: A light that forms a conical shape like a flashlight.

Cone Angle
The value that defines the light’s cone angle. This option is only accessible 
with the Light Type set to Spot.

Diffusion
Lets you play with the diffusion of the light on the surface of the drawing. In 
other words, it is the edge softness. This option is only accessible with the 
Light Type set to Spot.

Light Source Elevation
Defines the height of the spotlight. This option is only accessible when the 
Light Type set to Spot or Point.
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Shading Type
Smooth: The light and tone fx will have smooth edges.

Sharp: The light and tone fx will have sharp edges.

Bias

Define the polarization of the light. 

When the Shade type is set to Smooth, it defines the width of the light’s 
smooth zone. 

When the Shade type is set to Sharp, the Bias defines the antialiasing on the 
edge of the hightlight or tone zone. But,if the Shade type is set to Sharp, the 
Bias option need a small value such as 0.1 or 0.2. The exponent will be able to 
compensate the limitation of this small value.

Abruptness
This is a multiplier value of the Bias option. It will define how quick the 
polarization of the light will change from a value to another.

Adjust Light Intensity Lets you adjust the light intensity.

Intensity Lets you set the strength of the light.

Multiplier Multiplies the value of the Intensity option.

Surface Reflectivity
This option is useful for exaggerating the light on the edge of the 3D geometry. 
The closer an edge is to the light source, the more intense the light will be.

Colour

Red/Green/Blue/Alpha

The colour and transparency of the Colour Card. You can also attach these 
parameters to function columns to change their values over time. 

Click the colour swatch to open the Colour Picker window and select a colour.

Colour Swatch Opens the Colour Picker window in which you can specify the colour.

Use Image Colour
Lets you use the colour of the drawing in a lighter or darker colour for the 
highlight and tone fx.

Image Colour Intensity Lets you blend the colour of the light with the image colour.

Flatten Fx
This is useful when there are several highlight and tone fx, one over the other, 
but are supposed to be merged together. Sometimes, shadows and lights look 
better when they do not overlap.
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Chapter 12: OpenFX

To expand your compositing possibilities, you can use OpenFX plugins directly in Harmony.

OpenFX is an open standard used to create visual effects plugins. These plugins can be used in any application that 
supports the standard. This means that banks of visual effect plugins can be developed by programmers and shared 
with various platform users. Harmony is one of these platforms.

To learn more about OpenFX, refer to:

• openfx.sourceforge.net

• openeffects.org

To learn more about  the main OpenFX plugin providers, refer to:

• toolfarm.com/products/category/3316/all

To demonstrate this feature, the Sapphire package from GenArts® will be used. You can download the Sapphire 
library at:

• genarts.com/sapphire

Installation

Once you have purchased or downloaded an OpenFX package, you need to launch the executable file to install it. All 
OpenFX plugins install in a centralized location that all applications can read from. You will not need to do anything in 
Harmony. They will appear automatically in the Node Library view once the package of your choice is installed.

Here is the centralized installation path:

• Windows: C:\Program Files (x86)\Common Files\OFX\Plugins

• Mac OS X: /Library/OFX/Plugins

• Linux: /usr/OFX/Plugins
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Normal Map Converter

Harmony has the ability to generate normal maps. The main usage is to create light shading effects on flat 2D 
drawings. The normal map will carve and emboss a flat plane using vectors. The X, Y and Z coordinates of the 
normal map vectors are stored in RGB values to convert the 3D aspect into a visual result and use it to create 
various effects, such as light reflections (light shading). The X value is stored in the Red channel. The Y value is 
stored in the Green channel. The Z value is stored in the Blue channel.

A normal map can be used to create other effects. If you're are working with an OpenFX plugin or other plugin 
requiring a normal map, you can use the Normal Map Converter node to translate the Harmony normal map to a 
format supported by your plugin. The Normal Map Converter node has been optimized to work with GenArts® 
plugins, but you also have the ability to use it on custom plugins.

NOTE: Note that not all normal map formats are supported.

The Normal Map Converter uses the following formula per channel:

• value * (+/- length) + offset

• * +/- depending if inverse is set to true ("-" if true)

How to install an OpenFX package for Harmony

 1. Download the OpenFX package you want to install.

 2. Quit Harmony.

 3. Launch the OpenFX package installer and follow the installation instructions.

 4. Launch Harmony.

 5. In the Node Library view, in the Categories section, select the category matching the package's name. 
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All effects included in the package are now available to use in Harmony.

Using OpenFX Plugins

All OpenFX plugins can be customized by adjusting their parameters. Settings are organized by category and some 
of them can be expanded and collapsed for clarity. Parameters can also be animated over time.

Some effects also have visual controls to set the position or angle. If you want to adjust the controls for your effect, 
you must do so in OpenGL mode. To see the effect in OpenGL mode, you need to connect a Render Preview node to 
your effect.

How to use and edit an OpenFX plugin in Harmony

 1. From the Node Library view, select an effect plugin and drag it to the Node view.

 2. Connect your drawing nodes or other required nodes to the effect plugin.

 3. In the Camera view, enable the Render  mode to see the final rendered effect.
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 4. In the Node view, click the effect node's yellow square to open the Layer Properties window and adjust its 
parameters.

NOTE: 
In the Layer Properties window, you can expand some parameter sections to see many more controls.
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 5. Adjust the effect's visual control in OpenGL mode by dragging a Render Preview node from the Node Library 
view to the Node view. Connect it between the plugin and the Composite nodes.

 6. In the Camera view, enable the OpenGL  mode to see the rendered effect in OpenGL.

 7. To display the controls, in the Node view, select the plugin effect node and do one of the following:

‣ In the Camera toolbar, click the Show Control button.

‣ From the top menu, select View > Show > Control.

‣ Press Shift + F11 (Windows/Linux) or ⌘  + F11 (Mac OS X).

The controls appear.
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 8. In the Tools toolbar, select the Transform  tool or press Shift + T.

 9. In the Camera view, adjust the controls.

How to use the Normal Map Converter node

 1. In the Node Library view, go to the Shading category and select the Normal Map Converter node.

 2. Drag it to the Node view.

 3. Connect the Normal Map Converter node between the Normal Map node and your custom plugin node.
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 4. Select the Normal Map Converter node.

 5. In the Layer Properties view, adjust the node's properties.

Parameter Description

Conversion Type
By default, the conversion type is set to Genarts. If you work with a different man-
ufacturer and want to adjust the parameters, set the conversion type to Custom.

Offset
Offsets the original position of the vector. You need to read the plugin doc-
umentation to know the offset you need to use. You must use the same offset 
value as the manufacturer is using. By default the offset is set to 0.

Length
The Normal Map Converter normalizes Harmony vectors to 1. By default the 
length value is set to 1. If your plugin requires shorter or longer vectors, enter a 
value smaller or greater than 1. It will multiply the vector length.

Invert Red
Inverts the red value (x). If your value is 125, the invert setting will transform it to -
125.

Invert Green
Inverts the green value (y). If your value is 125, the invert setting will transform it 
to -125.

Invert Blue
Inverts the blue value (z). If your value is 125, the invert setting will transform it to 
-125.

 6. If the plugin you are using stores the X,Y and Z coordinates in different channels, you can use the Channel-
Swap node to reassign the colour channels.
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Chapter 13: Export

Now that you've finished your animation, it's time to render your movie. Depending on whether you plan to further 
edit your movie using a third party software, composite the movie in a larger body of work or put it up directly on the 
web, Harmony supports several formats for all your rendering needs.

The render resolution for the various editions of Harmony are:

• Harmony Essentials: 2K (2048x1556)

• Harmony Advanced: 4K (4096x3112)

• Harmony Premium: Unlimited

 

This chapter contains the following topics:

• Exporting a QuickTime Movie on page 619

• Exporting an SWF Movie on page 624

• Exporting OpenGL Frames on page 626

• Exporting a Sound File on page 627

• Advanced Export on page 628

• Batch Rendering on page 642

Exporting a QuickTime Movie
If you require a video file, you can export your animation as a QuickTime movie. To render a QuickTime movie with 
transparency, you need to set the Depth to Millions of Colours +. You can set this this when exporting a QuickTime 
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movie.

If your exported video is too small or too large, you can change the project size from the top menu in Scene > 
Scene Settings. This will change the size of the video output.

If you added burn-in information to your scene, it will be included in your exported file—see Burn-In on page 412.

How to export a QuickTime Movie

 1. From the top menu, select File > Export > Movie.

The Export to QuickTime Movie dialog box opens.

 2. Click Browse and select a folder in which to save your movie and give it a file name for the export.

 3. Click OK.

 1. In the Display Source section, select the Display node to use for rendering your project. If there is no Dis-
play node in the scene, the drop-down list will indicate Display All and render the scene in the same order 
as the Timeline view, including nodes floating in the Node view. It is always recommended to render from 
the Display node, located under the final Composite node, unless you want to render a specific section isol-
ated by a particular Display node.

 2. From the Export Range section, decide whether you want to export the entire scene (All) or a specific 
frame range. If you decide on the latter, enter the frame range.

 3. In the Resolution section, select one of the following from the menu:

‣ A preferred resolution ratio.

‣ Custom:  Enables the Width and Height fields so you can enter a specific size.
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 4. In the Options section, click Movie Options.

Parameter Description

Video

Enables the customization of the video settings, filters and size.

Settings: Opens the Standard Video Compression Settings dialog 
box.

Filter: Opens the Choose Video Filter dialog box, where you can 
select from a range of filters to apply to your video export.

Size: Opens the Export Size Settings dialog box. The size settings 
are overridden by the Harmony's scene settings.

Sound
Enables the customization of the sound settings.

Settings: Opens the Sound Settings dialog box (see below).

Prepare for Internet Streaming Enables the customization of the Internet streaming options.

 5. In the Video section, click Settings.

The Standard Video Compression Settings dialog box opens.
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 6. From the Compression Type menu, select a codec. The availability of certain compression settings 
depends on the Compression Type selected. For example, Animation is the default compression type and 
as a result the Data Rate option is greyed out. 

 7. In the Motion section, choose a Frame Rate from the list. 

By default, it is set to match the frames-per-second (fps) of your Harmony project. If you choose a lower 
frame rate, your export playback will be faster than your actual project. The reverse is also true for a higher 
frame rate. 

 8. If you want keyframes inserted, select the Every option and set the number per frame. 

This is the option is recommended by QuickTime. For further details, refer to the QuickTime 
documentation.

 9. In the Quality section, use the slider to choose a quality setting. Remember that the better the quality of 
the export, the larger the file.

 10. From the Data Rate section, either choose to allow the program to automatically select the most optimal 
bit rate, or enter a Restricted rate to save space and allow for faster downloading at a cost to the quality of 
the export. 

 11. In the same section, from the Optimized For menu, select the intended viewing method for the export.

 12. Click OK.

 13. From the Movie Settings dialog box, click Sound Settings.

The Sound Settings dialog box opens.
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 14. From the Compressor menu, select a compression type. The default setting is None. This will preserve your 
original sound file without the loss of information. However, an uncompressed sound file will inevitably add 
“weight” to the overall size of your video export.

 15. From the Rate menu, select a rate. It is best to check and match the original properties of your sound file. For 
example, if your file has an audio sample rate of 48 kHz and you choose a conversion rate of 22.05 kHz, the 
sound will play at the same speed, but with higher frequencies missing. For a standard film sound quality, 
choose 44.1 kHz, or 48 kHz for DVD quality. Anything less will make the sound “dull” or less bright. For 
things like recorded voice, this doesn't matter so much, but for music it can make an audible difference. If file 
size is a consideration, such as with videos for the Internet, then a lower rate might be more practical.

 16. Select the Size and Use, which are related. It is advisable to check your original sound file properties. If the 
file was recorded in one channel (mono), there is no point in choosing the two channel (stereo) option. 
Although Mono can support a 16-bit channel, the extra information is unnecessary. Mono is generally paired 
with 8-bit and Stereo with 16-bit.

 17. Click OK.

 18. In the Export to QuickTime Movie dialog box, click OK.

A progress bar appears.

 19. Browse to the location on your computer where you saved your QuickTime video and double-click on it to 
view the export.

How to set the depth to Millions of Colours + to export a QuickTime movie with transparency

‣ In the Standard Video Compression Settings dialog box, select Millions of Colors+ from the Depth menu—
see Exporting a QuickTime Movie on page 619.
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Exporting an SWF Movie
The SWF export supports some bitmap effects (which can be previewed in Render View  mode) and SWF Blend 
Modes (vector effects which can be previewed in OpenGL View  mode).

The following are also supported:

• Pencil line thickness: They are converted to brush strokes in the .swf file.

• Auto Patch node for creating joint patches.

• Burn-in information incuding time code, frame number and scene information—see Burn-In on page 412.

If you have not already done so, you should preview the .swf by using the SWF preview  button to see what 
the two types of effects look like when blended together. Once you are satisfied with the results, go ahead and 
export your movie. 

How to export a .swf movie

 1. From the top menu, select File > Export > SWF.

The Export to Flash Movie (.swf) dialog box opens.
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 2. Click Browse and select a file name and destination path for your movie.

 3. In the Display Source section, select a Display node to read from in the Export From Display Node menu.

 4. In the Export Range section, select one of the following options:

‣ All: To export all the frames of your movie.

‣ Frames: To export a frame range. Enter the frame range in the fields.

 5. In the Options section, enter a Frame rate (fps). By default, it will be set to match the fps of your Harmony pro-
ject. If you choose a lower frame rate, your export playback will be faster than your actual project. The 
reverse is also true for a higher frame rate. 

 6. In the same section, select the JPEG quality:

‣ 100 = Full quality

‣ 50 = Average quality at about 1/5th of the size.

‣ 25 = Medium quality where loss of high image resolution starts to occur.

‣ 10 = Low quality where “macro-blocking” or large pixelation become obvious.

‣ 1 = Lowest quality where there is extreme loss of colour and detail and the image becomes nearly 
unrecognizable. 

 7. To prevent your movie from being imported into another application, select the Protect from Import option.
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 8. For a lighter format, select the Compress Movie option. The movie may lose some quality, but the file will 
be lighter.

 9. To retain the thickness of pencil lines, select the Convert Pencil Lines to Brush Lines option. 

 10. In the Do Not Export section, select the effects you do NOT want to be rendered in the SWF movie.

Note that certain Harmony effects are not listed in this section as they are not compatible and therefore not 
available for SWF export. These effects will not appear in the SWF render. 

 11. Click OK.

 12. Browse to the location on your computer where you saved your Flash Movie and double-click on it to view 
the export.

Exporting OpenGL Frames
You can export the OpenGL frames (fast display mode) if you need a quick render for your scene. Heavier scenes 
containing 3D, multiple effects and camera moves can be fairly long to export.

Use the Export OpenGL Frames dialog box to select the frames you want to render from the OpenGL Camera 
view, then save the rendered frames as image files or as a QuickTime movie.

Frames saved from OpenGL view have neither antialiasing nor special effects. To render final frames with 
effects, export as images or a movie.

How to export OpenGL Frames

 1. From the top menu, select File > Export > OpenGL Frames.

The Export OpenGL Frames dialog box opens.

 2. In the Output section, click Browse and select a folder for the frames.

 3. In the Filename field, enter a name (prefix) for the frames or revert to the default name by clicking Default.
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 4. In the Format section, decide if you want to export individual image frames or a movie.

‣ Suffix: Lets you select the desired suffix. If you intend to render only a few frames, use 1 or 01, whereas if 
you intend to render 1000 frames, you can select 0001.

‣ Drawing Type: Lets you select the file type to render, such as .tga or .sgi. 

 5. Click Movie Options to customize the Audio and Video settings for the *.mov export—see Exporting a Quick-
Time Movie on page 619. 

 6. From the Resolution section, select a resolution for export. If you are running some quick tests, then you 
might want to reduce the resolution to save time and space. You also have the option to set a Custom width 
and height to produce smaller or larger frames.

 7. In the Range section, decide whether you want to render all your frames, a range of frames, the current frame 
or selected frames.

 8. In the Options section, select a Display node to use for rendering your OpenGL frames from.  It is always 
recommended to render from the Display node located under the final Composite node, unless you want to 
render a specific section displayed by a particular Display node.

 9. Click OK.

Exporting a Sound File
At some point during the production, you might need to export a sound file to use it in another application, such as an 
editing software. Harmony allows you to export sound files as a merged soundtrack or as a series of individual files. 
The exported soundtracks are generated as *.wav files.

How to export a soundtrack

 1. From the top menu, select File > Export > Soundtrack.

The Export Soundtracks dialog box opens.

 2. In the Output section, click Browse and specify where you want to save the exported sound file.
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 3. In the Export Range section, select one of the following options:

‣ All: Exports the sound over all the frames of your scene.

‣ Frames: Sets the start and end frames in the corresponding fields on the right.

 4. From the Options menu, select one of the following:

‣ Process Soundtracks Individually: Each soundtrack from all layers is exported as individual files.

‣ Merge all Soundtracks: One single file is created, combining all the sound files you imported in your 
scene. Note that it will only use the sound files in the selected frame range set in the Export Range 
section. If you selected to export all the frames, all the sound files will be processed.

 5. In the Sound Settings section, set the Rate, Size and Use parameters for the soundtracks to export. It is 
a good idea to verify what is required by the software or device that  you may want to use next with the 
sound file.

 6. Click OK.

The generated sound files appear in the selected directory and are named according to the scene name. 
Individual files keep their original name; only a prefix matching the scene name is added.

Advanced Export
The Node view allows you to make advanced connections and isolate certain portions of your project. It also 
allows you to perform multiple exports from the entire node structure or from specific sections.

For this kind of process, use the Write node in the Node Library view. The Write node lets you render and output 
the connected image information. Using the Write node, you can export a project as a QuickTime movie or as 
image sequences. You can export one format at a time or both simultaneously.

To export an image sequence, you need to adjust a few settings in the Write node’s properties.

You can export image sequences as several different formats. Note that formats with transparency are 
premultiplied.

Format Description

TVG Toon Boom Vector Graphic. The Toon Boom vector proprietary format.

TGA (TGA1, TGA3, TGA4) Select TGA4 to export your sequence with an alpha channel (transparency).

SGI (SGI1, SGI3, SGI4) Select SGI4 to export your sequence with an alpha channel (transparency).

SGIDP (SGIDP1, SGIDP3, 
SGIDP4)

Select SGIDP4 to export your sequence with an alpha channel (transparency).

OMFJPEG Exports your sequence as OMFJPEG files.

PSD (PSD1, PSD3, PSD4) Select PSD4 to export your sequence with an alpha channel (transparency).

PSDDP (PSDDP1, PSDDP3, 
PSDDP4)

Select PSDDP4 to export your sequence with an alpha channel (trans-
parency).

YUV Exports your sequence as YUV files.
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PAL Exports your sequence as PAL files.

SCAN Exports your sequence as SCAN files.

PNG (PNG4)
Select PNG4 to export your sequence with an alpha channel 
(transparency). PNG4 images are straight.

JPG Exports your sequence as JPG files.

BMP (BMP4) Select BMP4 to export your sequence with an alpha channel (transparency).

IFF (IFF_16) Exports your sequence as IFF files.

OPT (OPT1, OPT3,OPT4) : Select OPT4 to export your sequence with an alpha channel (transparency).

VAR Exports your sequence as VAR files.

TIFF Exports your sequence as TIFF files.

DPX (DPX3_8, DPX3_10, 
DPX3_12, DPX3_16, DPX3_
10_INVERTED_CHANNELS, 
DPX3_12_INVERTED_
CHANNELS)

Exports your sequence as DPX files.

PDF
Exports your sequence as PDF files. Your drawings must be vector and all 
your Composite nodes must be set as Vector to obtain vector PDFs.

 

NOTE: The formats used if you need to output a vector format are .tvg and .pdf. You can also export a .swf movie.

To export a QuickTime movie, you need to adjust few settings in the Write node’s properties.

How to add a Write node

 1. In the Node Library, select the Output from the list of categories.

 2. Select the Write node and drag it to the Node view.
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 3. In the Node view, connect the final Composite node or any other node which outputs an image you want to 
render to the Write node.

How to set the Write node to export an image sequence

 1. In the Node view, open the Write node’s editor by clicking its square yellow properties button.

 2. In the Output tab, select the Drawing option to create an image sequence.

 3. Click Choose and browse to the directory where you want to save the output. You can also use the 
default directory to save in the default frames folder included in the scene directory.

 4. In the Drawing Filename field, type the image sequence’s name prefix. It is recommended to leave the 
hyphen (-) at the end of the name to separate the image name from the image number.
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 5. In the Start field, select the starting number for the image sequence.

 6. In the Leading Zeros field, select the number of digits you want to see after the sequence prefix.

 7. In the Drawing Type field, select the file format in which your project will output.

NOTE: When the file format includes a "4" at the end of its name, it means that an alpha channel will be created.

 8. Click Close.

The project will not start rendering yet, since these are only the settings. You can still modify your scene.

How to set the Write node to export a QuickTime movie

 1. In the Node view, open the Write node’s property editor by clicking on its square yellow properties button.

 2. In the Output tab, select the Movie option to create a movie file.

 3. Click Choose and browse to the desired directory to save the output.

You can also use the default directory to save in the default Frames folder included in the scene folder.

 4. In the Movie Filename field, name the output file. You do not need to write the file format extension.
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 5. Click Customize  to open the Movie Settings dialog box.

 6. In the Movie Settings dialog box, in the Video section, click Settings to set your video options.

 7. Click OK.

 8. In the Movie Settings dialog box, in the Sound section, click Settings to set your audio options.
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 9. Click  OK.

The project will not start rendering yet. These are only the settings. You can still modify your scene.

Multiple Renders

Harmony lets you simultaneously render many formats and resolutions for a scene. This saves a lot of time as you 
do not have to return between each render to start a new one.

To use multiple renders, connect as many Write nodes as needed to match the required number of exports. Then, 
adjust each Write node’s settings to create image sequences or movies.

NOTE: YOU MUST GIVE DIFFERENT NAMES TO EACH OUTPUT FILE. This is especially important if you save them 
all in the same folder, so they do not overwrite each other.

When you have multiple Write nodes in a scene, it is useful to rename the nodes according to their output settings 
such as: low_resolution_movie or HDTV_sequence.

To export different resolutions concurrently, you need to create a combination of the following:

• Write node—see Advanced Export on page 628
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• Scale-Output node

• Crop node

Once your Write nodes are connected, you need some Scale-Output nodes to change the resolution output of the 
Write node. For example, if you export in a high resolution and a low resolution, you need one Scale-Output node.

Set the project’s resolution to the highest resolution needed for this export and use the Scale-Output nodes to 
scale down the other outputs. 

DO NOT scale up the output size, that will not provide a good result. It is also better to use the Scale-Output node 
to scale down in a same aspect ratio so that it does not distort the image.

To output two files with different aspect ratios, such as 16:9 and 4:3, you can use the Crop node. This node is 
used to crop the final image in order to discard excess information without distorting the render.

If you start with a higher resolution and want to crop down to a lower resolution, such as HDTV to NTSC, you will 
need to combine the Crop node with a Scale node.

Once you know the type of render you want to do, you will need to retrieve your nodes from the Node Library and 
connect them to the scene’s network.

How to add a Scale-Output node

 1. In the Node Library view, select Scale-Output from the list of categories.

 2. Select the Scale-Output node and drag it to the Node view.
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 3. In the Node view, connect the Composite node to the Input port of the Scale-Output node.

 4. In the Node view, connect the Scale-Output node to the input ports of both the Display node and the Write 
node.

How to set the Scale-Output node

 1. In the Node view, open the Scale-Output node’s editor by clicking its yellow square properties button.

 2. In the Layer Properties dialog box, select a resolution from the suggested Resolution Name list or type in new 
resolution values to indicate the resolution to scale to.

635



Chapter 13: Export     

 3. Click Close.

How to add a Crop Node

 1. In the Node Library view, select Output from the list of categories on the left.

 2. Drag the Crop node to the Node view.

 3. In the Node view, connect the Composite node to the Input port of the Crop node.

 4. In the Node view, connect the Crop node to the input ports of both the Display node and the Write node.
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How to set the Crop node

 1. In the Node view, open the Crop node’s property editor by clicking the yellow square properties button.

 2. In the Layer Properties dialog box, type new resolution values to indicate the resolution to crop to.

 3. You can manually enter the X -Y Offset, or move it in the Camera view. Select the right Display node in the 
Display toolbar. In the Advanced Animation toolbar, select the Translate  tool and with the middle mouse 
button, move the crop area. If the Animate  mode is enabled, the position of the crop area will be animated 
over time.

 4. If you want to create a Pan and Scan effect (panning the cropped selection over time to show more inform-
ation), you can create a function to animate the cropped selection. Click the Function  button beside the 
Local dialog box to create a Bezier or ease curve.
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 5. If you created a function curve to animate the cropped selection, click again on the Function  button 
and edit the curve by adding keyframes and moving the selection box in the Camera view.If you created a 
function curve to animate the cropped selection, click again on the Function  button and edit the curve 
by adding keyframes and moving the selection box in the Camera view.

 6. Enable the Draw Frame option if, instead of cropping the images, you prefer to have Harmony draw the 
frame over the rendered scene.

 7. Click in the colour rectangle to adjust the frame colour as desired if you have enabled the Draw Frame 
option.

 8. Click Close.

The Crop node also has an advanced Enabling tab for determining when the Crop node should be 
activated.
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‣ Always Enabled: Makes the Crop node always produce output.

‣ Enabled when resolution name is: Activates the Crop node only when the resolution of the scene 
matches the value in the Filter Name menu. The listed resolutions come from the Resolution/Frame Rate 
dialog box.

‣ Enabled when resolution is: Activates the Crop node whenever the scene’s resolution matches the 
values in the X and Y resolution fields.

How to connect nodes to export multiple renders

 1. In the Node Library view, retrieve the necessary Write, Scale-Output and Crop nodes.

 2. Connect the final Composite node to the first Write node. (Make sure you have a Display node reading the 
same information.)

 3. Open the Write node’s editor by clicking on its square yellow properties button.

 4. Name the Write node according to the render type that you are planning to do.

 5. Set the Write node parameters—see How to set the Write node to export an image sequence on page 630.
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 6. Connect the other Write nodes and repeat steps 2 to 5.

 7. Using the Alt key, insert the Scale-Output nodes between the final Composite node and their cor-
responding Write node.

 8. Using the Alt key, insert the Crop nodes between the final Composite node and their corresponding Write 
or Scale node.
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‣ If the output from the Crop node has to be scaled down, use a Scale-Output node.

 9. Connect a Display node to each Scale-Output or Crop node to see each final image in the Camera view.

Rendering Images and Movies from the Node View

If you want to render from your Write node, you will need to use the Render Write Nodes option found in the File 
menu.

When working with Harmony Server, you can send your scene to batch processing and to a render farm—see Batch 
Rendering on page 642
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How to render the scene from the Write node

 1. From the top menu, select File > Export > Render Write Nodes or press Ctrl + Shift + Y (Win-
dows/Linux) or ⌘  + Shift + Y (Mac OS X).

 2. In the Range section, select the frame range to render.

 3. Select the Field Composite Options option 

 4. To render the final images as fields for display on interlaced monitors, select the Field Composite 
Options.

 5. Select the Preview option to automatically see the image sequence result once the render is done. The 
preview will not show up for a QuickTime movie.

 6. Click OK.

All renders start.

Batch Rendering
Harmony Server has the possibility to render your scene locally or send it to a render farm so other computers can 
render your scenes while you continue working on your station. This option is not available with Harmony Stand 
Alone. 

The Harmony Server rendering processes are named:

• Local Rendering is done directly on the user machine using its CPU. To perform local rendering you must 
use Stage. 

• Batch Rendering lets you send a scene to render while you continue working in Stage. This way, you do 
not have to wait for the application to complete the render process. 

Batch rendering is a background process divided over several machines or a render farm. Sending your scene to 
batch render will share the rendering load with other machines in the render farm and lessen the amount of work 
required by your computer. 

The parameters for the format and file type to render are set in the Write nodes contained in your scene's Node 
view. Before sending your scene to batch rendering, make sure to set the Write nodes to export in the proper 
location, and set the format parameters. Note that you can have more than one Write nodes in your scene if you 
require several exports—see Advanced Export on page 628.
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NOTE: Refer to the Control Center Guide and Installation Guide to learn how to send scenes to batch render and 
check the status of the Render queue. 

How to send a scene to the batch rendering queue

 1. Save all the contents of your scene, all drawings, colour palettes and the palette list. 

 2. Select File > Save or press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X).

 3. From the top menu, select File > Export > Render Write Nodes or press Ctrl + Shift + Y (Windows/Linux) 
or ⌘  + Shift + Y (Mac OS X).

If the system administrator did not complete the resolution configuration tasks, a warning message will open. 
This message notifies you that the resolution.conf file was not properly inserted in the configuration folder. 

 4. Click OK to continue. You will still be able to render your scene. 

The Render Write Nodes dialog box opens. 
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 5. In the Range section, select the frames you want to render: 

‣ All Frames: Sends all the frames in the scene to be rendered.

‣ Selected Frames: Sends a range of frames to be rendered. 

 6. Select the Batch Composite option. 

‣ Select the Chunk option if you want to split the frames into sets of frames or QuickTime movie into 
small chunks. Note that when the render farm (server) is done rendering all the small movie chunks, it 
will put them all back together to create one single movie file.

‣ Enter the number of frames for each chunk in the Size (Frames) field. For example, if your scene is 100 
frames long and you enter a value of 20, there would be five entries in the queue of 20 frames each. 

‣ Select the camera for rendering the scene's images from the Camera list. These are the Camera nodes 
you created in your scene. 

 7. Select the Field Composite Options option to create a field composite to refine your selection.

‣ Add Pull-down: Uses the 3:2 pull-down technique. 

‣ Automatic Combine: Combines even and odd fields on a scene's images. 

‣ Second Field First: Always starts with the second field before combining with the first. 

 8. Click OK to start the rendering process. 

A confirmation dialog box opens to inform you that the frames have been sent to the Render queue. 

‣ If the selected frames were already sent to the Render queue, a notification dialog box opens to inform 
you that these frames were already in the queue, but that they have been updated with the latest 
rendering request. 
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You can also send scenes to batch rendering and check the status of the rendering queue from the Control Center 
node. 
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Glossary
3D stereoscopic The ability to create stereo images which, when animated and viewed through 3D active 

shutter glasses or using glasses with one red and one blue lens, will appear as a three-
dimensional movie. 

alpha channel An image channel that carries transparency information. An image already has three 
channels: red, green and blue (RGB). The alpha channel is the fourth channel (A). The 
matte, or the transparency information, is stored in this fourth channel. An image without 
an alpha channel is always opaque.

animatic A movie with sound that is developed from the storyboard. The storyboard panel is 
exposed for the duration of the scene and at times, the characters are placed on a 
trajectory to indicate motion. The camera moves are also animated. The animatic is used 
to determine the rhythm of a project and provides a good overview of the project before 
beginning production.

animation A simulation of movement created by displaying a series of pictures or frames.

anime An animation style known for its sinister and dark feel; popular in Japan.

arc Action rarely occurs in a straight-forward manner; rather it typically unfolds in what 
storytellers refer to as an arc. The purpose of a story arc is to move a character or 
situation from one state or scenario to the next.

aspect ratio The relationship between the width and height dimensions for any scene, frame or film 
format. Television ratio is 4:3 and widescreen ratio is 16:9.

auto-feed An automated method of feeding drawings into a scanner in which multiple drawings are 
stacked into a sheet feeder. When the scanner is activated, the drawings are scanned 
consecutively, without further user intervention.

automatic lip-sync 
detection

Automatically mapping drawings in an element to the mouth chart generated for a sound. 
This can save time when lip-syncing a voice track.

axis An imaginary line around which an object rotates.

For 2D graphics, there are two axes: X (horizontal and Y (vertical).

For 3D graphics, there are three axes: X (horizontal, Y (vertical) and Z (depth).

In animations that constantly rotate, the axis element specifies what axis the object 
rotates around. A negative number causes an animation to rotate counter clockwise 
whereas a positive number causes an animation to rotate clockwise.

background The part of a scene that is farthest to the rear. The background is the artwork, or decor, 
against which the animation takes place.

Bézier A method of defining curved lines invented by French mathematician Pierre Bézier. A 
Bézier curve is a mathematical or parametric curve. Bézier curves use at least three 
points to define a curve.

bitmap An image composed of pixels with a single resolution (size). If it is enlarged too much, it 
will lose definition and individual pixels will begin to appear. This is known as pixelation.

Bitmap image files are defined as a standard rectangular mesh of individual pixels. Each 
individual pixel contains a value that represents a specific colour.
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breakdown In cut-out animation, breakdown is the action of breaking a character into pieces to create 
a puppet with articulations. To break down a character, the artist cuts parts, such as the 
hands and arms, from the character's model and pastes them in separate layers. Next, 
the joints are fixed and the pivots set.

In traditional animation, a breakdown is an animation pose generally found between two 
key poses. The key poses are the main poses in an animation and the breakdowns are 
secondary poses, ones that help describe the motion and the rotation curve (usually 
referred to as an arc).

camera shake Camera shake occurs in a scene when the camera moves slightly and quickly in several 
directions. This gives the impression of an impact, vibration or, for example, bumps on 
the road.

caption A text field containing dialogue, effects, sound or slugging information in a storyboard.

cel In traditional animation, a cel (also known as celluloid) is a transparent sheet on which 
the animation is inked and painted before being sent to the camera. The picture's outline 
is drawn on the front of the cel and then coloured along the back.

character design Each character in an animated film is drawn from multiple angles in poster-style format, 
called a model sheet, which serves as a reference for the animators.

chromatic 
aberration

In optics, chromatic aberration (CA), achromatism or chromatic distortion, is a type of 
distortion in which there is a failure of a lens to focus all colours to the same convergence 
point.

clean up After rough drawings have been tested and approved, all the noise in the image (excess 
lines, notes, etc.) is removed to create final drawings which can be inked, painted and 
shot. The clean up process refers to either tracing a clean line over a rough drawing to 
achieve the final version or removing dirt and extra lines left by the scanning process.

CMYK Acronym for Cyan, Magenta, Yellow, Black. These colours are the standard model used 
in a process called offset printing.

colour card A colour card is a card containing one solid colour that is the same size as the camera. 
The colour card fills the background with a solid colour when there is no background 
image included.

colour model The official colour design that must be used to paint the animation. A model is the 
definitive character, prop or location design that each artist must follow for the 
production. 

colour wheel A display of the colour spectrum in the form of a circle. 

compositing Compositing is the action of incorporating all of a scene's elements to create the final 
result prior to rendering. For example, the compositing artist will import all the animation 
sequences, background, overlays and underlays in the scene and position them 
correctly. The artist will then set the camera frame and animate it, if needed. Finally, the 
animator will create all the computer-generated effects for the project.

cross dissolve An effect used to fade two scenes, one into the other.

cut A direct transition between two scenes. When a cut is used, there are no transition 
effects inserted to pass from one scene to the next. The first scene ends and the second 
one starts immediately.

cut-out animation The process known as cut-out animation is the action of animating characters made out 
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of several pieces by moving them around frame by frame. Cut-out animation can either 
be computer generated or done traditionally using paper.

cycle A group of images that together make up an action, such as walking. A cycle is an action 
repeated as a loop over a period of time. It can be a series of animated drawings or 
keyframes. 

dialogue The text spoken by a character in a movie or animation.

dope sheet Used by animators, directors and other members of a crew to track the sequence and 
timing of images, dialogue, sound effects, sound tracks and camera moves. Also known 
as an exposure sheet.

doping To assign a particular drawing to a range of frames.

double bounce 
walk

In the key frames and passing positions in a double bounce walk, the body is lower than a 
reference line drawn in the upright position. During the in-betweens, the body is above 
this line giving the appearance of a bounce.

DPI Dots per inch is the standard measure of resolution for computerized printers. It is 
sometimes applied to screens, in which case it should more accurately be referred to as 
pixels per inch. Either way, the dot is the smallest discrete element making up the image.

ease In animation, the ease, also known as velocity, is the acceleration and deceleration of a 
motion. It can be a motion created by a function curve, or a series of animated drawings. 
Other common terms for ease-in and ease-out are slow-in and slow-out.

ease-in Gradual acceleration in the action. Also known as slow-in.

ease-out Gradual deceleration in the action. Also known as slow-out.

establishing shot A scene in which the viewer can see the whole area in which a sequence is happening. 
For example, if a child is playing on the ground in front of his house, the establishing shot 
would be a scene where the viewer can see the house, the ground, a part of the street 
and the buildings around the central point of action. This helps the viewer understand the 
story location and scene orientation.

exposure In animation, an exposure is the number of cels on which a drawing appears in the scene. 
For a drawing to appear longer, the exposure must be extended over a greater number of 
cels.

exposure sheet A sheet with several vertical columns and horizontal frames used to indicate a scene's 
timing. Each column represents a scene layer. The drawing numbers in each column are 
indicated and repeated over the particular amount of frames they need to appear.

The exposure sheet is used by animators, directors and other members of a crew to track 
the sequence and timing of images, dialogue, sound effects, sound tracks and camera 
moves. Also known as a dope sheet.

fade in/fade out Fade in or fade out is a transition effect used to open or close a sequence. A fade in 
occurs when the first scene appears progressively, from complete transparency to its 
complete opacity. A fade out occurs when the last scene progressively disappears, going 
from complete opacity to complete transparency.

fast-in Dramatic acceleration at the start of the action.

fast-out Dramatic acceleration at the end of the action.

field A measurement unit used to calculate motion, registration and camera positioning. A 

648



Harmony 12.2 Premium - Compositing and Effects Guide (Server)

standard animation scene will vary between 6 to 12 fields.

field chart A guide containing all the field units that animation and layout artists use to determine a 
scene size or camera motion.

film-1.33 A resolution that is ideal for the widescreen film format that conforms to the standard 4:3 
pixel aspect ratio.

film-1.66 A resolution that is ideal for the widescreen film format that conforms to the 16:9 pixel 
aspect ratio. (The pixels are wider than they are high).

flipping In traditional animation, flipping is the action of going through the drawings of an 
animation sequence very quickly in order to see the animation in motion. Flipping can 
also be the action of creating a mirror transformation of an object.

follow-through The secondary motion caused by the main action. For example, a character wearing a 
cloak is running. The main action is the body running. This will cause the cloak to follow 
the motion, although it will not move at the same time, but react a few frames later and 
follow the main motion curve.

forward kinematics Forward kinematics is a feature used to animate principally 3D characters and cut-out 
puppets with hierarchy. It is used to animate a puppet from one of parent parts, such as a 
shoulder, and make the rest of the arm move with it as a single piece.

frame An animation frame is a single photographic image in a movie. In traditional animation, 
the North American standard generally contains 24 frames per second, while in Europe 
the standard is 25 frames per second.

frame rate The frame rate is the speed at which the frames are played. They are generally calculated 
by frame per second. For example, a scene could be played back at 12, 24, 25, 30 or 60 
frames per second or any other number.

This is the measurement of the frequency (rate) at which an imaging device produces 
unique consecutive images, called frames. The term applies equally to computer 
graphics, video cameras, film cameras, and motion capture systems.

Frame rate is most often expressed in frames per second (fps) and in progressive-scan 
monitors as hertz (Hz).

function A computer-generated motion, trajectory or path on which elements, other trajectories 
and effects parameters can be attached. The function can be controlled by adding 
keyframes and control points on the function curve.

gamut The range of colours that a particular device can represent.

HDTV Acronym for High Definition Television which delivers a higher quality image than 
standard television because it has a greater number of lines of resolution. To take 
advantage of the superior quality and make full use of your resolution setting, the output 
device must be compatible with HDTV technology.

hold A frame in the animation in which the character maintains its position without moving. A 
hold can be created between any two keyframes.

HSV Hue, Saturation, Value. A method of defining colours in terms of hue (tint), saturation 
(shade) and value (tone or luminance).

in-between The drawings that exist between the key poses. These are drawn to create fluid 
transitions between poses.
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ink and paint The ink and paint process is the action of painting the empty zones and colouring the 
lines on the final animation drawings, while following a colour model.

interpolation The computer-generated motion created between two keyframes. You have the choice to 
create interpolation, or not, between your keyframes.

inverse kinematics 
(IK)

A feature used mainly to animate 3D characters and cut-out puppets with hierarchy. 
Inverse kinematics will animate a puppet from one of the extremities, such as a hand, 
and make the rest of the body follow naturally.

jump cut A jerky cut between two scenes. Typically, a jump cut is not visually pleasing. It is 
generally caused by one scene ending, and a second one starting, with a similar image. 
The lack of difference causes the eye to see a little jump between the two scenes. 

key pose Important positions in the action defining the starting and ending points of any smooth 
transition. Keys, or key poses, are the main drawings in an animation sequence 
describing the motion. For example, if an arm is waving, the keys will be of the arm at one 
extremity of the wave motion and the other extremity. By flipping those drawings, the 
animator can see the skeleton of the motion without having all the drawings.

keyboard 
shortcuts 

One or more keyboard keys which, when used, cause an operation to be performed.

keyframe Important positions in the action defining the starting and ending points of any action. A 
keyframe is a computer-generated position at a specific moment (frame) on a given 
trajectory.

layer In animation, a layer is an individual column, level or character. A scene's layers are 
superimposed to form the final image.

layout The communication step between the storyboard and the animation. It is the action of 
putting the storyboard on model. That is, drawing the character by following the design in 
the model pack, so the animator can start working.

The layout artist draws the background, creates the camera and field guide matching the 
scene and camera motion. Lastly, the animator draws on model the main action poses.

layout and posing The action of putting on model (at the right scale) the storyboard for the animator to start 
working.

layout artist The artist who draws the background, and creates the camera and field guide to match 
the scene and camera motion. They will draw on model the main action poses.

layout planning Drawing of the main features of the scene used as reference when planning the 
animation and executing the initial stages of it.

layout process The communication step between the storyboard and the animation. 

library A storage area containing templates and assets that can be reused in any project or 
scene.

light table A device that allows you to see other layers in transparency while you are working on a 
particular layer.

line of action The direction that the action will follow. Also known as path of action.

lip-sync The process of synchronizing a character's mouth to sounds in the dialogue soundtrack. 
The mouth is adjusted frame-by-frame to match the sound of the dialogue and provide the 
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illusion that the character is speaking. Lip-sync can be used for any sound sequence, not 
only speech, you could for instance have a bird chirping or a wolf howling at the moon.

low resolution A format that is ideal for videos destined for the web, where size and fast download of a 
video file take precedence over quality. A low-resolution image is one that lacks fine 
detail.

manual lip-sync 
detection

The manual swapping of mouth position drawings to match a voice track. For this 
process, both sound scrubbing (listening to a sound wave broken up frame-by-frame) and 
drawing substitutions are used.

master palette A group of colours attributed to a character or prop. The palette is used throughout the 
entire production to maintain consistency in the look and to ensure that the same colours 
are used throughout the production. Also known as palette.

model/colour 
model

The definitive character, prop or location design each artist must follow for a production. 
A colour model is the official colour design that must be used to paint the animation.

morphing A feature for creating computer-generated drawings between a source drawing and a 
destination drawing. Animation created with the morphing feature can be reused in 
different projects.

motion keyframe A keyframe with computer-generated interpolation.

mouth chart A chart based on the eight animation phonemes (A, B, C, D, E, F, G, and X, which is 
used to represent silence) used for lip-sync.

multiplane The effect of passing through multiple levels of drawings to create a sense of depth in a 
shot. A multiplane is a scene in which the layers are placed at different distances from 
the camera so that when the camera moves, a depth illusion occurs. With a multiplane, 
all the perspective and scale is calculated automatically.

NTSC The standard analogue television broadcasting system used in North America. NTSC 
conforms to North American standards on how rectangular pixels are displayed for 
computer and television screens.

nudge A small push (left, right, up, down, forward or backward) done with the keyboard arrow 
keys on a selected element. Nudging is used to move a selection very slightly and 
precisely.

onion skin A feature that lets you see the previous and next drawings of a sequence.

overlay A part of the scene environment, such as a chair or a bush, that is placed in front of the 
main animation.

PAL A resolution that works best with the European format for television and computer 
screens, as the rectangular pixels are displayed at a different orientation.

palette/master 
palette

A palette or master palette is a group of colours attributed to a character or a prop. The 
palette is used throughout the entire project to maintain a consistency in the look and 
avoid the colour changing during the animation. Also referred to as a master palette.

palette style A palette style is a second version of an existing palette with a slight change in the tint 
and value. A palette style can be used to create the night version of a palette. It may also 
be called a clone palette.

pan To move the camera across the scene in any direction.

panel In a storyboard, a panel is a frame in a shot. A shot can be composed of one or several 
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panels.

paperless 
animation/tradigital

The paperless animation process is the action of animating digitally. The main paperless 
animation process is to draw, frame by frame, the animation directly in the software.

passing position When drawing a walk sequence for a character, the passing position is the point at which 
one leg passes the other.

path of action Direction that the action will follow. Also known as line of action.

peg In traditional animation, a tool used to ensure accurate registration of action as cel layers 
move. In digital animation, in which you are doing a more advanced puppet rigging, you 
can use peg layers. Peg layers are trajectory layers that do not contain drawings. They 
are motion paths that you can use to add path articulations. For the latter, you can also 
use an inverse kinematics tool.

phoneme A unit of sound in a language.

pivot The point around which a peg or drawing rotates.

pixel The smallest element of an image displayed on a monitor or TV screen.

Pixel, short for picture element, is a single point in a graphic image. It is a small sample of 
an image, a dot, a square, or a very small section made out of smooth filtering. If you 
zoom in close enough on a digital image, you will see the pixels, which look like small 
squares of different colours and intensity.

pose-to-pose 
animation

The pose-to-pose animation process is the action of creating all the main action poses, 
called key poses, and then placing the secondary poses between the keys. The 
secondary poses are called breakdown. Finally, the animator fills the gaps with the in-
between drawings to achieve a smooth animation.

rendering The final step when animating by computer. During rendering, the computer takes each 
pixel that appears on screen and processes all of the components, as well as adding 
motion blur before it produces a final image. The process of calculating the final images 
after the compositing process.

resolution The size of a scene, generally calculated in pixels. For example, the NTSC resolution is 
720 x 480. The resolution should match the final output: HDTV, film-1.33, film-1.66, 
NTSC, PAL, low.

RGB Red, Green, Blue. A method of defining colour by specifying amounts of these three 
colour components.

rigging The process of attaching the various parts of a cut-out puppet.

rotary table Equivalent to the animation disk/table, a device that allows you to rotate the workspace 
for greater comfort while drawing.

rotoscoping An animation technique in which animators trace over live-action film movement, frame 
by frame, for use in animated films. The act of sketching over live-action footage to 
create an animated sequence.

roughs Rough is a common name in an animation movie for a drawing that is used as a reference 
but which does not form part of the final image. A layout is a rough.

The skeleton sketch of an animation or design. Roughs mainly consist of sketch lines 
and shapes, but can also contain design details.
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safe area The zone at the center of a scene's frame that is safe from being cropped by the TV 
frame. As a TV frame cuts a margin off the original frame size, maintaining a safe area 
ensures that the scene's main action will remain clearly visible once the film is screened 
on television.

scene A shot in a movie or show. A sequence is composed of several scenes. A scene 
changes to another scene by a simple cut or transition.

script The original text containing all the movie or show information. In animation, the script 
contains all of the location descriptions, dialogue, time and more. A project starts with a 
script.

sequence A series of scenes or shots forming a distinct part of the story or movie, usually 
connected by unity of location or time.

shot A scene in a movie or show. A sequence is composed of several shots. A shot changes 
to another shot by a simple cut or transition.

slow-in The gradual acceleration in the action. Also known as ease-in.

slow-out The gradual deceleration in the action. Also known as ease-out.

slugging To indicate the start and stop times of dialogue and relevant actions.

sound scrubbing A process that lets you hear sound in real time while you move the playhead forward or 
backward. This is very useful for finely-tuning a lip-sync.

stop-motion 
keyframe 

A keyframe with no computer-generated interpolation.

storyboard A visual plan of all the scenes and shots in an animation. The storyboard indicates what 
will happen, when it will happen and how the objects in a scene are laid out.

straight-ahead 
animation

A technique in which an entire sequence is drawn from the first position to the last, in 
order. There is very little planning in this methodology. Where the character ends up and 
how it gets there can be a surprise for both the audience and the animator. While this 
approach is spontaneous and creative, it can create inaccurate results.

strokes Invisible vector lines forming the drawing zones. They can be adjusted with Bézier 
handles.

symbol A symbol combines animation, artwork or layers into a single object that you can control 
in one layer. You can also create symbols out of each body part in your cut-out puppets.

You can place whatever you want in a symbol. You can use symbols to animate a puppet 
or create reusable animations such as blinking. 

tablet/pen A device used in conjunction with, or instead of, a mouse to move a mouse pointer 
(sometimes referred to as the cursor) around the computer screen.

template An asset stored in the library that can be reused in any project. A template can be a 
drawing, a series of keyframes, a sound file, a panel, a cut-out character, an effect, a 
trajectory, an animation, or anything else used in the animation.

thumbnail A very small image used as a reference or indicator.

timecode The timing information printed on a movie clip to indicate the scene, hour, minute and 
second that is currently displayed on the screen.
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timeline A horizontal representation of a scene's elements, timing and keyframes.

trace and paint After the rough animations have gone through cleanup and a final line or pencil test, each 
drawing is traced and painted for the final animation. In today's digital world, this may be 
done in a variety ways other than the traditional celluloid or acetate methods.

track breakdown The break down of an animated film's soundtrack into individual sounds to produce the 
precise frame-by-frame position of each sound.

traditional 
animation 

A type of animation process whereby all the animation sequences are drawn by hand on 
paper before scanning or inking them on cels.

trajectory A computer-generated path or trajectory that elements can follow. The trajectory can be 
controlled by control points, keyframes and velocity.

transition An effect placed between two scenes as they pass from one to the other. Common 
transition effects are cross-dissolve and wipe.

underlay In animation, an underlay is a specific part of the decor placed behind the main animation.

vector A vector-based image is composed of points and Bézier curves. The computer reads the 
points and traces the segments, linking them to reproduce the image shape. There is no 
fixed size or resolution in a vector image. The graphic can be enlarged and distorted as 
much as desired and the system will simply recalculate the segments and rebuild the 
shapes. Vector images are translated and displayed in pixels once the calculation is 
done.

velocity In animation, the velocity, also known as ease, is the acceleration or deceleration of a 
motion. This can be achieved by a function curve, or via a series of animated drawings. 
Other common terms for ease-in and ease-out are slow-in and slow-out.

walk cycle A series of drawings "on the spot"  that describe the walk for a character. The illusion of 
movement is created by the use of background pans. To avoid making innumerable 
drawings, animators routinely make a walk cycle for a character.

zone An area which can be painted with colour.
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Index
3D

positioning layers  223

alpha channel  646

animatic  646

animating

camera  257

animation  646

anime  646

arc  646

aspect ratio  646

auto-feed  646

axis  646

background  646

Bezier  646

bitmap images  646

importing in original format  11

breakdown  647

camera

adding and parenting to peg  256

animating  257

orthographic, gaming  206

camera shake  647

caption  647

cel  647

celluloid

See cel.  647

character design  647

clean up  647

CMYK  647

colour card  647

colour model  647, 651

colour wheel  647

Composite node  164

compositing  647

cross dissolve  647

cut  647

cut-out animation  647

cycle  648

dialogue  648

Display nodes  164

dope sheet  648

doping  648

DPI  648

Drawing node  164

ease  648

ease-in  648

ease-out  648

Effect node  165

establishing shot  648

exposure  648

exposure sheet  648

fade-in  648

fade-out  648

field chart  649

film-1.33  649

film-1.66  649

flipping  649

follow-through  649

forward kinematics  649

frame  649

frame rate  649

Function view  275

displaying functions  271, 276

functions  649

displaying  271, 276

gaming

orthographic camera  206

gamut  649

group navigation  163, 357

HDTV  649

Hold  649

HSV  649

importing

bitmap image in original format  11

sound file  330

templates  105

in-between  649

ink and paint  650

interpolation  650

jump cut  650

key pose  650

keyboard shortcuts  650

keyframes  650

Layer Properties editor

displaying  142

layers  650

panning with Transform tool  133

positioning in 3D space  223

rotating with Transform tool  133

skewing with Transform tool  134

layout  650

layout and posing  650

library  650

Library view

importing templates  105

light table  650

line of action  650

lip-sync  650

auto detection  646

lip-sync detection

manual  651

low resolution  651

manual lip-sync detection  651

master palette  651

Matte Drawing module  165

model  651

model sheet  See character design

motion keyframe  651
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mouth

chart  651

multiplane  651

Navigator view  162, 357

Node Library toolbar  358

Node Library view  357

toolbar  358

node system  162, 357

Node view  161, 356

Composite node  164

Drawing node  164

Effect node  165

group navigation  163, 357

Matte Drawing node  165

Navigator view  162, 357

Peg node  165

position ports  165

Search toolbar  162, 357

Symbol Stack  162, 357

Write and Display nodes  164

nodes

Composite  164

Display  164

Drawing  164

Effect  165

Matte Drawing  165

Peg  165

ports  165

Write  164

NTSC  651

nudge  651

onion skinning  651

orthographic camera

gaming  206

overlay  651

PAL  651

palettes  651

style  651

panel  651

panning  651

layer using Transform tool  133

paperless animation  652

passing position  652

path of action  652

Peg node  165

pegs  652

pen  653

Perspective view  205

rotating a scene  206

phoneme  652

pivot  652

repositioning permanently  139

pixel  652

pixelation  See bitmap image

ports  165

pose-to-pose  652

rendering  652

resolution  652

RGB  652

rigging  652

rotary table  652

rotating

layer with Transform tool  133

rotoscoping  652

roughs  652

safe area  653

scaling

layer with Transform tool  134

scanning

VectOptions.conf file  78

scene setup

panning layer using Transform 
tool  133

repositioning pivot permanently  139

rotating layer with Transform 
tool  133

scaling layer with Transform 
tool  134

skewing layer with Transform 
tool  134

scenes  653

rotating in Perspective view  206

script  653

scrubbing  653

sequences  653

shot  653

Side view  203

opening  255

positioning elements  201

skewing

layer with Transform tool  134

slow-in  653

slow-out  653

slugging  653

sound

importing sound file  330

scrubbing  653

stop-motion keyframe  653

storyboard  653

straight-ahead  653

strokes  653

Symbol Stack  162, 357

tablet  653

templates  653

creating  94

importing  105

thumbnails  653

timecode  653

timeline  654

toolbars

Module Library view  358
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Search, Network view  162, 357

Top view  202

opening  255

positioning elements  201

trace and paint  654

track breakdown  654

tradigital  652

traditional animation  654

trajectory  654

Transform tool

panning layer  133

rotating layer  133

scaling layer  134

skewing layer  134

transition  654

underlay  654

VectOptions.conf file  78

Mac  78

Windows  78

vector  654

vectorization

creating a style  76

parameters, creating  76

parameters, custom  68

parameters, modifying  76

Vectorization Parameters dialog box

Help tab  71

opening  68

Options tab  69

velocity  648, 654

views

Function  275

Navigator  162, 357

Node  161, 356

Node Library  357

Perspective  205

Side  203

Top  202

walk cycle  654

Write node  164

zone  654
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