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Chapter 1: Compositing - An Introduction

Once the ink and paint is done, the animation completed and the timing locked, you are ready to move on to
compositing. This includes different components, such as the elements' positioning, scene resolution, trajectories,
camera moves, effects and filters, and so on. During compositing, you are working with computer-generated effects
done with Harmony's many effect nodes. You can create many types of interesting effects and then customize it to
suit your animation style.

It is during the compositing phase that the three animation workflows merge together. Whatever your chosen path,
they all end up in the same animation, together in the same scene. However, the cut-out compositing can be a bit
more complex due to the advanced networking of the different puppets.
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Topics in this section:
* Import on page 7
* Library on page 77
» Scene Setup on page 105
» Path Animation on page 153
* Soundon page 207
+ Effects on page 231
» Export on page 267
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Chapter 2: Import

Toon Boom Harmony allows you to import external content as well as being able to draw directly in the software.
This means that characters, backgrounds and videos created in other drawing, painting and multimedia programs
can be brought in and animated. You can import QuickTime videos, pictures, multilayered .psd files, as well as .ai,
.swf, .pdf, and .fla files. You can also scan images and import them as bitmap or vectorize them.

This chapter contains the following topics:

* Importing Bitmap Images on page 8

» Importing PSD Files as Separate Layers on page 18

»  Exporting and Reimporting a PSD Layout on page 25

» Scanning Images on page 35

» Importing Al and PDF Files on page 43

» Scanning Images on page 35

» Importing Adobe Flash Files on page 45

»  Importing QuickTime Movies on page 60

* Creating Custom Vectorization Parameters on page 61

NOTE: For sound import, refer to Importing a Sound File on page 207.
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Importing Bitmap Images

Images can come in many different file formats and are usually saved in a format that retains the original
specifications set by the image creator. Some formats can preserve the transparency or transparent layers, while
others are not resolution dependent due to their vector nature. Toon Boom Harmony supports the following
formats: JPEG, BMP, PNG, TGA, PSD, TIFF, SGI, TVG, OMF, PAL, SCAN.

When importing images and 3D models and linking images, the settings are saved in your user settings.
In this section, you will cover the following topics:

» Importing a Bitmap Image Without Vectorization on page 8

» Importing and Vectorizing Bitmap Images on page 16

Importing a Bitmap Image Without Vectorization

How to open the Import Images dialog box

1. Do one of the following:
» From the top menu, select File > Import > Images.
> Inthe File toolbar, click the Import Images - button.
» Inthe Xsheet view, right-click anywhere in the frame area and select Import > Images.
The Import Images dialog box opens.
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How to import a bitmap image in its original format

1. Inthe Files section of the Import Images dialog box, click Browse to find and select one or more images on
your compulter.

2. Decide if the bitmap image will go on a new layer or an existing layer. To add the bitmap image to a new layer,
go to step 3. To add the bitmap image to an existing layer, go to step 4.

3. Add the bitmap image to a new layer by selecting the Create Layer(s) option and one of the following
options and then proceed to step 5:

» Create Single Layer Named: Creates a layer you can name.

» Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. For
example, the filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b", where "a" has two
drawings and "b" has one. When creating a single layer from these three filenames, all three drawings will
be inserted in the new layers.

4. Select the Add to Existing Layer option to place the bitmap image on a layer you select from the list. If only
vector layers are available in your scene, they will not be displayed in the list. You can choose to encapsulate
the bitmap in a symbol by selecting the Create Symbols for Imported Items option.

5. Inthe Import Options section, select the Keep As Original Bitmap option. In the Alignment section, decide
on the size and placement of your image within the camera frame. Depending on the Scene Settings (the
height and width in pixels that you chose for your project), an image that you import may be scaled to the
point where all its individual pixels become visible. There are three options available in the Alignment section:

Parameter Description
. Enlarges or shrinks (but not distorts) the image height to match the
Fit . .
full height of the scene grid.




Chapter 2: Import

‘Camera resolution

Scene frame (grid)

Vertical image with Fit
alignment rule

If the image orientation is landscape, this will enlarge or shrink (but
not distort) the image width to match that of the scene grid.

‘Camera resolution

Scene Frame (Grid)

Landscape image with
Fit alignment rule

Note that the Fit alignment rule equals the Center Fit rule in the
layer properties.

Pan

This is the opposite of the Fit parameter. If the image orientation is
portrait, its width will be made to match the width of the scene grid.
As aresult, part of the image’s height will extend beyond the height
of the frame. This can be useful if you want to make your
background move up and down, or from left to right to make it
appear as if the camera is panning or to actually perform a camera
pan.

10
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Vertical image with Pan
alignment rule

Camera
resolution

Scene frame (grid)

The opposite will apply to a landscape image. Its height will be fit to
the scene grid, therefore it is possible that the image will extend
beyond the scene grid's boundaries.

Scene frame Camera Landscape image with Pan alignment rule
resolution

Note that the Pan alignment rule equals the Center First Page rule
in the layer properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The
system looks at the resolution of the bitmap image, for example
4000 x 2000, then compares it to the scene's resolution, for
example 1920 x 1080, and adjusts the scale factor in proportion.
So, in this example, the bitmap would appear at 208% (4000/1920).
If you import a bitmap that is 960 x 540, it will be displayed at 50%
(960/1920) of the size of the project resolution.

Note that the Project Resolution alignment rule is equal to the As |Is

11
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rule in the layer properties.

6. Inthe Transparency section, select one of the following from the Alpha menu:

Parameter Description

Premultiplied with White Individual pixels at the edge of an image are blended with white.

Semitransparent pixels in the original image are blended with

Premultiplied with Black black.

Pixels at the edge of an image are blended with black, white and
greys.

Premultiplies the colour value with the alpha value. When the
colour is clamped to the alpha, the colour value cannot be higher
than the alpha value. It calculates the real colour value faster.
When the RGB values are multiplied with the alpha value, that
is, if you have a pixel of value R=247, G=188, B=29 and the
alpha is 50% or the image has a 50% transparency, then the
actual RGB values that are output would be half of the amounts
listed above.

Straight

Clamp Colour to Alpha

7. Click OK.

Adding Images to a Bitmap Layer

How to add more bitmap images to an existing bitmap layer

1. Inthe Timeline view, if the bitmap image is contained in a symbol, double-click on the bitmap symbol cell
to edit the symbol. Otherwise, if the bitmap image is on a bitmap layer, leave it as is.

2. If necessary, in the Timeline view, pull on the red bracket to extend the exposure.
3. From the top menu, select File > Import > Images or click the Import Image - button.

The Import Images dialog box opens.

12
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4. Click Browse to find and select one or several images on your computer.

5. Inthe Layer section, select the Add to Existing Layer option and select an existing bitmap layer from the
menu.

6. Deselect the Create Symbol for Imported ltems option.

7. Inthe Import Options section, select the Keep As Original Bitmap option. In the Alignment section, decide
on the size and placement of your image within the camera frame. Depending on the Scene Settings (the
height and width in pixels that you chose for your project), an image that you import may get scaled to the
point where all its individual pixels become visible. There are three options available in the Alignment section:

Parameter Description

Enlarges or shrinks (but not distorts) the image height to match the full height of
the scene grid.

Camera resolution

Fit

Scene frame (grid)

Vertical image with Fit
alignment rule

If the image orientation is landscape, this will enlarge or shrink (but not distort) the

13
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image width to match that of the scene grid.

‘Camera resolution

Scene Frame (Grid)

Landscape image with
Fit alignment rule

Note that the Fit alignment rule equals the Center Fit rule in the layer properties.

Pan

This is the opposite of the Fit parameter. If the image orientation is portrait, its
width will be made to match the width of the scene grid. As a result, part of the
image’s height will extend beyond the height of the frame. This can be useful if
you want to make your background move up and down, or from left to right to
make it appear as if the camera is panning or to actually perform a camera pan.

Vertical image with Pan
alignment rule

Camera
resolution

Scene frame (grid)

The opposite will apply to a landscape image. Its height will be fit to the scene
grid, therefore it is possible that the image will extend beyond the scene grid's
boundaries.

Scene frame Camera Landscape image with Pan alignment rule
resolution

Note that the Pan alignment rule equals the Center First Page rule in the layer

14
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properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The system looks at the
resolution of the bitmap image, for example 4000 x 2000, then compares it to the
scene's resolution, for example 1920 x 1080, and adjusts the scale factor in
proportion. So, in this example, the bitmap would appear at 208% (4000/1920). If
you import a bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the
size of the project resolution.

Note that the Project Resolution alignment rule is equal to the As Is rule in the
layer properties.

8. Inthe Transparency section, select one of the following from the Alpha menu:

Parameter

Description

Premultiplied with White

Individual pixels at the edge of an image are blended with white.

Premultiplied with Black

Pixels at the edge of an image are blended with black.

Straight

Pixels at the edge of an image are blended with black, white and greys.

Clamp Colour to Alpha

Premultiplies the colour value with the alpha value. When the colour is clamped to
the alpha, the colour value cannot be higher than the alpha value. It calculates the
real colour value faster. When the RGB values are multiplied with the alpha value,
that is to say, if you have a pixel of value R=247, G=188, B=29 and the alpha is
50% or the image has a 50% transparency, then the actual RGB values that are
output would be half of the amounts listed above.

9. Click OK.

Bitmap Image Quality

If the bitmap images that you imported look blurry or slightly pixelated, you can clean up the image by changing the
quality of the preview in the Camera view. It will not affect the final render.

How to change the bitmap image quality

1. Inthe Camera view, double-click on the bitmap image to enter its symbol if the image is encapsulated or
simply select the bitmap image layer in the Timeline view if it's not.

2. Do one of the following:

15
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» From the top menu, select View > Bitmap File Quality.

» From the Camera menu, select View > Bitmap File Quality.
» Press Ctrl + Q (Windows/Linux) or 38 + Q (Mac OS X).

The Bitmap Image Quality dialog box opens.

Min: 128

Current Resolution: 512

OK

3. Drag the slider to the right to improve the quality.
4. Click OK.

5. If you are inside a symbol, go to the top of the Camera view and click Top to exit the symbol and return to
your scene.

Importing and Vectorizing Bitmap Images

)
|

You can turn bitmap images into vector drawings, while maintaining the sketchiness of a pencil line or into vector
images with a bitmap fill. Both options can add life to an animation, which straight vectorization with smoothing
does not usually afford.

How to import and vectorize a bitmap image

1. Do one of the following:

» From the top menu, select File > Import > Images.
> Inthe File toolbar, click the Import Images ; button.

The Import Images dialog box opens.

16
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2. Click Browse to locate images.

3. Inthe Layer section, decide if the scanned or imported image will be placed on a new layer or existing layer.

» Create Layer: Scans or imports the image into a new layer. Select one of the following options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Creates a layer based on each unique filename prefix. For example, the
filenames a-1.tga, a-2.tga and b-1.tga will create layers named "a" and
Create Layer(s) Based on Filenames "b", where "a" has two drawings and "b" has one. When creating a
single layer from these three filenames, all three drawings will be inser-
ted in the new layers.

» Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from the Layer
list. You must scan into the same layer type if you're using an existing layer.

» Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix bitmap images
with vector drawings on the same layer, the bitmap image must be encapsulated in a symbol and vice
versa. Symbols will also be automatically added to the Symbol folder in the Library view.

4. Inthe Import Options section, select the Convert to Toon Boom Vector Drawing option.

5. Inthe Vectorization section, decide whether you want to import your image in colour, black and white, grey,
or if you want to add a new preset.

» Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based drawing.

17
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» Grey: Vectorizes yourimage as a mix of vector contour and greyscale bitmap filling. Lines keep the
texture from the scan, and the white of the paper becomes transparent.

» New Preset: The New Preset button lets you create custom vectorization parameters via the
Vectorization Parameters interface.

NOTE:

You can double-click on any of the presets at any time to open the Vectorization Parameters dialog box to
customize your option.

NOTE: The vectorized images are painted with the Vectorize Line colour swatch from the colour palette.

6. Click OK.

Greyscale preset Black and white preset Colour preset

A symbol or new layer contains the vector drawing. For images contained in a symbol, double-click on the
image’s first cell in the Timeline view to enter the symbol so you can edit the image.

Importing PSD Files as Separate Layers

18



Harmony 12.2 Advanced - Compositing and Effects Guide

PSD files (a format exportable exclusively from Adobe Photoshop) are unique in that they are able to retain multiple
layers. This is advantageous as the image remains fully editable in terms of any colour correction, effects, masking,
transparency, or compositing that were made to the . psd file in Adobe Photoshop.

NOTE: Note that your .psd image file must be setto RGB mode within Adobe Photoshop prior to being imported into
Harmony.

How to import the separated layers of a .psd file

1. In Adobe Photoshop, organize your file so that all your layers are “grouped” into individual folders, or that all
the elements you want to import as a single layer in Harmony are grouped together in their own folder. Any
layer that is not in a folder group, by itself or otherwise, will not be imported.

11
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1. InHarmony, go to the top menu and select File > Import > Images or click the Import Images “; button.

The Import Images dialog box opens.

Alignment
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Transparency

Alpha: | Premultiplied w
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2. Inthe Files section, click Browse to find and select the . psd image on your computer.

3. Inthe Layer section, select the Create Layer(s) option, then select one of the following options:

» Create Single Layer Named: Creates a layer you can name.

» Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. For
example, the filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b", where "a" has
two drawings and "b" has one. When creating a single layer from these three filenames, all three
drawings will be inserted in the new layers.

4. Select the Create Symbol for Imported Items option if you want the layers to be contained in symbols.

5. Inthe Import Options section, select one of the following:

» Keep As Original Bitmap: Retains an imported image as a bitmap. In the Alignment section, decide
on the size and placement of your image within the camera frame. Depending on the Scene Settings
(the height and width in pixels that you chose for your project), an image that you import may get scaled
to the point where all its individual pixels become visible. There are three options available in the
Alignment section:

Parameter Description

Enlarges or shrinks (but not distorts) the image height to match the full height

Fit of the scene grid.

20
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‘Camera resolution

Scene frame (grid)

Vertical image with Fit
alignment rule

If the image orientation is landscape, this will enlarge or shrink (but not distort)
the image width to match that of the scene grid.

‘Camera resolution

Scene Frame (Grid)

Landscape image with
Fit alignment rule

Note that the Fit alignment rule equals the Center Fit rule in the layer
properties.

This is the opposite of the Fit parameter. If the image orientation is portrait, its
width will be made to match the width of the scene grid. As a result, part of the
Pan image’s height will extend beyond the height of the frame. This can be useful if
you want to make your background move up and down, or from left to right to
make it appear as if the camera is panning or to actually perform a camera pan.

21
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Vertical image with Pan
alignment rule

Camera
resolution

Scene frame (grid)

The opposite will apply to a landscape image. Its height will be fit to the scene
grid, therefore it is possible that the image will extend beyond the scene grid's
boundaries.

Scene frame Camera Landscape image with Pan alignment rule
resolution

Note that the Pan alignment rule equals the Center First Page rule in the layer
properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The system looks at
the resolution of the bitmap image, for example 4000 x 2000, then compares it
to the scene's resolution, for example 1920 x 1080, and adjusts the scale
factor in proportion. So, in this example, the bitmap would appear at 208%
(4000/1920). If you import a bitmap that is 960 x 540, it will be displayed at 50%
(960/1920) of the size of the project resolution.

Note that the Project Resolution alignment rule is equal to the As Is rule in the
layer properties.

22
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» Import As Bitmap Drawing: Imports a drawing into a vector layer where you can edit the image using the
drawing tools. In the Alignment section, select one of the following:

Parameter Description
Enlarges or shrinks (but not distort) to your image height to match the full height of
the scene frame (alignment grid).

Vertical Fit

Camera resolution

Image with Vertical Fit

alignment rule Scene frame (grid)

Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match the full width of
the scene frame (alignment grid).

Camera resclution

Image with Horizontal Scene frame (grid)
Fitalignment rule

Actual Size

Scales the image in proportion to the scene's resolution. The system looks at the
resolution of the bitmap image, for example 4000 x 2000, then compares it to the
scene's resolution, for example 1920 x 1080, and adjusts the scale factor in
proportion. So, in this example, the bitmap would appear at 208% (4000/1920). If
you import a bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the
size of the project resolution.

» Convert to Toon Boom Vector Drawing: Imports a drawing and converts it to a Toon Boom vector
drawing. In the Vectorization section, select one of the following:

23
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New preset
Delete preset

Custom vectorization

Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based drawing.

Grey: Vectorizes the image as a mix of vector contour and greyscale bitmap filling. Lines keep the texture
from the scan, and the white of the paper becomes transparent.

New Preset: Lets you create a new preset.
Delete Preset: Lets you delete any preset in the list.
Custom vectorization: Lets you set custom vectorization parameters—see Creating a Vectorization Style

on page 69.

6. Decide whether to select Vectorize Imported Items option.

NOTE: If you decide to use the Vectorize Imported ltems option, see Importing and Vectorizing Bitmap Images on
page 16 to learn more about vectorization settings.

NOTE: If you disable the Vectorize Imported ltems options, the Transparency and Alignment settings will appear in
place of the Vectorization settings—see Importing a Bitmap Image Without Vectorization on page 8.

7. Click OK.

The Multilayer Image Import Settings dialog box opens.

8. From the Create menu, select one of the following:

» Single Layer: To import the Camera and Layout layers merged together.
» Separated Layers: To keep your Camera and Layout layers separated.

9. From the Transparency menu, select one of the following if applicable:

Parameter Description

24
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Premultiplied with White Individual pixels at the edge of an image are blended with white.
Premultiplied with Black Pixels at the edge of an image are blended with black.
Straight Pixels at the edge of an image are blended with black, white and greys.

Premultiplies the colour value with the alpha value. When the colour is
clamped to the alpha, the colour value cannot be higher than the alpha value. It
calculates the real colour value faster. When the RGB values are multiplied

Clamp Colour to Alpha with the alpha value, that is to say, if you have a pixel of value R=247, G=188,
B=29 and the alpha is 50% or the image has a 50% transparency, then the
actual RGB values that are output would be half of the amounts listed above.

10. Click OK.

Your image appears as separate layers in the Timeline view, corresponding to the PSD layer group folders.

NOTE: The artwork displayed in every one of your layers as a result of a multilayer PSD file import is linked to the
same source image. This means that if you use the Drawing > Delete Selected Drawings command to physically
delete the drawing from the project folder, the exposed drawing will be deleted in all layers at once. Once deleted
from the project folder, the image cannot be retrieved unless you reimport your psd file.

Exporting and Reimporting a PSD Layout

Harmony allows you to export the contents of your scene as a PSD layout. This can be helpful for scene setup,
background art retakes, or even planning of animation.

Exporting a Layout

Before exporting a layout, all the elements must be well positioned. For example, if you plan to include a camera
movement in this scene, you should also set this up, as you can export the camera keyframes to generate a clear
and complete layout.

You can also create all the layouts for your production in the same Harmony project which can be imported later on
when you start each scene’s project. This will help set up the scene and begin its creation. You can use the layout
.psd files to create the background art of each scene and make sure everything is correctly framed and at the right
size. Finally, you can also have a layer with a drawing of the rough poses of the character or action and generate
your layout posing from there.

25
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NOTE: Because the layoutimage is one static .psd file, only the first frame of your drawing layers will be
exported—see Scene Setup on page 105 and Path Animation on page 153.

How to export your scene as a layout

Before exporting your scene as a layout, position your background elements, and everything you need as a
reference in your scene, including a camera movement.
1. From the top menu, select one of the following:

» File > Export > Layout Image to export all the elements in your scene to the layout .psd file.
» File > Export > Layout Image from Selection to export only the selected elements.
The Export Layout Image dialog box opens.

2. Inthe Export Layout Image dialog box, set the export parameters:

Parameter Description

Use the Browse button to select a location to save your layout and name the

Destination Path resulting .psd file.

File Pattern: Automatically puts the name of the scene and/or the frame num-
ber in the name of the file you create.

The size of the .psd image file that will be exported. The resulting image will be
Image Size 72 dpi as the standard television resolution and its size in pixel will fit your
scene resolution settings. i.e HDTV, NTSC, PAL, etc. Note that if you have a

26
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camera movement going over the normal camera frame limit, for example a
pan, the image will be bigger.

File Format: Lets you select the format to export your layout.

Export Camera Frame: This option is disabled by default. You can enable it
to export an additional layer to your .psd file displaying the camera frame onit.

Add a Camera Frame for Each Keyframe: This option is disabled by default,
meaning that if you have a camera movement with more than a starting and an
ending point, only these positions of the camera frame will appear on the
camera layer of the exported layout .psd file. You must enable this option if you
need to the in-between keyframes to also be displayed.

Options

Label Camera Frame: Adds the camera position label in the top corner of the
camera frames. The camera label is a single alphabet letter determining the
order of the camera frame position.

Expand Render Area: This option is disabled by default, meaning the layout
image will take the complete PSD area, cropped at the very edge of the
canvas. You can enable this option to add a transparent area all around the
layout. You must setup the size of this area by using the Scale field lower. The
resulting image will be larger.

Scale Image: Sets the size of the transparent border around the layout image.
By default the value is set to 100% to export the image as is with no
transparent area around it. Increase the percentage value to add the extra
around the image to create the border.

Maximum Size: This option is enabled by default, meaning that when you
have a camera zoom movement, the size of the layout image will be adjusted
accordingly. The resulting percentage will be calculated following the maximal
camera zoom value appearing in the layout. This allows the image to be
exported at an appropriate resolution, preventing the layout image from
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appearing pixelated or blurry when the camera zoom occurs. You can disable
this option to export the image layout at the normal size.

Vector Options

If you export one or more vector-based drawing layers in your layout image,
you have the option to export only the drawing layers you want. Enable or
disable the following options to export or prevent the export of the
corresponding art layers.

Overlay: Exports the art in the Overlay layer of the drawings to be exported to
the layout image.

Line Art: Exports the art in the Line layer of the drawings to be exported to the
layout image.

Colour Art: Exports the art in the Colour layer of the drawings to be exported to
the layout image.

Underlay: Exports the art in the Underlay layer of the drawings to be exported
to the layout image.

3. Click OKto validate the settings and export a .psd file of your layout.

The resulting image is a .psd file with one or two layers, each of which is contained in a corresponding
group. These groups make the layout .psd file ready for a multilayer .psd import.

The Camera_Set group contains the camera drawing layer. If you selected the Export Camera option, this
group and layer appear in your layout image.

A
|
|
|
|

The Layout_Set group contains a merged drawing layer of all the content of your scene’s first frame when

you exported the lay

out image.
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NOTE: An xlifile is exported along with your .psd file. This file contains all the necessary information for correctly
importing and automatically positioning your layout image in a Harmony project. Do not delete the .xli file or rename
it. Also, always keep it at the same location as the layout .psd file.

ep0l_scened02.ps  epll_scenel02.ps
d duxdi

Importing a Photoshop Layout

If you exported a Photoshop layout image from a Harmony project, you can easily import it back into Harmony. Just
be sure to import it at the beginning of the project for accurate scene planning.

How to import a PSD layout

1. Inyour Harmony project, select File > Import > Images.

The Import Images dialog box opens.

Browse, .,

Transparency

Alpha: | Premultiplied with White

Cancel

2. Inthe Files section, click Browse to find and select the .psd layout file on your computer. Note that this lay-
out file must have its corresponding .xli file in the same folder.
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ep0l_scened02.ps  epll_scenel02.ps
d duxdi

3. Once you have selected the layout file, the Use Position Information Contained in XLI File option appears
in the Layer section.

This option is enabled by default. When you import the layout image in your scene, it will be automatically
positioned to fit the original layout scene creating an accurate layout guide. You can disable this option if
you want the imported layout image to be imported according to the normal behaviour of the import
process. The layout image will be incorrectly aligned as it was when it was first created.

4. Inthe Layer section, select the Create Layer(s) option, then select one of the following options:

» Create Single Layer Named: Creates a layer you can name.

» Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. For
example, the filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b", where "a" has
two drawings and "b" has one. When creating a single layer from these three filenames, all three
drawings will be inserted in the new layers.

5. Select the Create Symbol for Imported Items option if you want the layers to be contained in symbols.

6. Inthe Import Options section, select one of the following:

» Keep As Original Bitmap: Retains an imported image as a bitmap. In the Alignment section, decide
on the size and placement of your image within the camera frame. Depending on the Scene Settings
(the height and width in pixels that you chose for your project), an image that you import may get scaled
to the point where all its individual pixels become visible. There are three options available in the
Alignment section:

Parameter Description

Enlarges or shrinks (but not distorts) the image height to match the full height

Fit of the scene grid.
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‘Camera resolution

Scene frame (grid)

Vertical image with Fit
alignment rule

If the image orientation is landscape, this will enlarge or shrink (but not distort)
the image width to match that of the scene grid.

‘Camera resolution

Scene Frame (Grid)

Landscape image with
Fit alignment rule

Note that the Fit alignment rule equals the Center Fit rule in the layer
properties.

This is the opposite of the Fit parameter. If the image orientation is portrait, its
width will be made to match the width of the scene grid. As a result, part of the
Pan image’s height will extend beyond the height of the frame. This can be useful if
you want to make your background move up and down, or from left to right to
make it appear as if the camera is panning or to actually perform a camera pan.
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Vertical image with Pan
alignment rule

Camera
resolution

Scene frame (grid)

The opposite will apply to a landscape image. Its height will be fit to the scene
grid, therefore it is possible that the image will extend beyond the scene grid's
boundaries.

Scene frame Camera Landscape image with Pan alignment rule
resolution

Note that the Pan alignment rule equals the Center First Page rule in the layer
properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The system looks at
the resolution of the bitmap image, for example 4000 x 2000, then compares it
to the scene's resolution, for example 1920 x 1080, and adjusts the scale
factor in proportion. So, in this example, the bitmap would appear at 208%
(4000/1920). If you import a bitmap that is 960 x 540, it will be displayed at 50%
(960/1920) of the size of the project resolution.

Note that the Project Resolution alignment rule is equal to the As Is rule in the
layer properties.
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» Import As Toon Boom Bitmap Drawing: Imports a drawing into a vector layer where you can edit the
image using the drawing tools. In the Alignment section, select one of the following:

Parameter Description
Enlarges or shrinks (but not distort) to your image height to match the full height of
the scene frame (alignment grid).

Vertical Fit

Camera resolution

Image with Vertical Fit

alignment rule Scene frame (grid)

Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match the full width of
the scene frame (alignment grid).

Camera resclution

Image with Horizontal Scene frame (grid)
Fitalignment rule

Actual Size

Scales the image in proportion to the scene's resolution. The system looks at the
resolution of the bitmap image, for example 4000 x 2000, then compares it to the
scene's resolution, for example 1920 x 1080, and adjusts the scale factor in
proportion. So, in this example, the bitmap would appear at 208% (4000/1920). If
you import a bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the
size of the project resolution.

» Convert to Toon Boom Vector Drawing: Imports a drawing and converts it to a Toon Boom vector
drawing. In the Vectorization section, select one of the following:
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New preset
Delete preset

Custom vectorization

Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based drawing.

Grey: Vectorizes the image as a mix of vector contour and greyscale bitmap filling. Lines keep the texture
from the scan, and the white of the paper becomes transparent.

New Preset: Lets you create a new preset.
Delete Preset: Lets you delete any preset in the list.
Custom vectorization: Lets you set custom vectorization parameters—see Creating a Vectorization Style

on page 69.

7. Click OK.

The Multilayer Image Import Settings dialog box opens.

8. From the Create menu, select one of the following:

» Single Layer: To import the Camera and Layout layers merged together.
» Separated Layers: To keep your Camera and Layout layers separated.

9. From the Transparency menu, select one of the following if applicable:

Parameter Description

Premultiplied with White Individual pixels at the edge of an image are blended with white.
Premultiplied with Black Pixels at the edge of an image are blended with black.

Straight Pixels at the edge of an image are blended with black, white and greys.

Premultiplies the colour value with the alpha value. When the colour is
clamped to the alpha, the colour value cannot be higher than the alpha value. It
calculates the real colour value faster. When the RGB values are multiplied

Clamp Colour to Alpha with the alpha value, that is to say, if you have a pixel of value R=247, G=188,
B=29 and the alpha is 50% or the image has a 50% transparency, then the
actual RGB values that are output would be half of the amounts listed above.

10. Click OK.
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Your image appears as separate layers in the Timeline view, corresponding to the .psd layer group folders
Camera_Set and Layout_Set. You can now use this layout as a guide for scene settings.

NOTE: Refer to Scene Setup on page 105 to learn more about the scene setup task.

Scanning Images

Toon Boom Harmony can receive images from any TWAIN device such as scanners and digital cameras. These
images can either be loaded into your scene as bitmaps or converted into vector- based images that can be edited
using Toon Boom Harmony.

If your operating system does not automatically recognize your device after it has been connected, you must install
the correct TWAIN drivers in order to access its contents. You can usually download the drivers from the device
manufacturer's website.

How to open the Scan Drawings window and set your scanner

1. From the top menu, select File > Import > From Scanner.

The Scan Drawings window opens.
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2. Inthe Scan Drawings window, select your scanner or other supported TWAIN device from the Scanner
menu. If none are available, check your device to ensure that it's properly connected to your computer. If
your device still does not appear in the menu, you may have to shut down and restart the software.

How to scan an image in its original format

1. Inthe Layer section, decide if the scanned or imported image will be placed on a new layer or existing
layer.

» Create Layer: Scans or imports the image into a new layer. Select one of the following options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Creates a layer based on each unique filename prefix. For example,
the filenames a-1.tga, a-2.tga and b-1.tga will create layers named
Create Layer(s) Based on Filenames "a" and"b", where "a" has two drawings and "b" has one. When cre-
ating a single layer from these three filenames, all three drawings will
be inserted in the new layers.

» Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from the Layer
list. You must scan into the same layer type if you're using an existing layer.

» Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix bitmap
images with vector drawings on the same layer, the bitmap image must be encapsulated in a symbol
and vice versa. Symbols will also be automatically added to the Symbol folder in the Library view.
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2. Inthe Import Options section, select the Keep As Original Bitmap option.

3. Inthe Alignment section, decide on the size and placement of your scanned image within the camera frame.
Depending on the scene settings (the height and width, in pixels, that you chose for your project), an image
that you scan may be scaled to the point where all its individual pixels become visible.

Parameter Description
Enlarges or shrinks (but not distorts) the image height to match the full height of
the scene grid.
‘Camera resolution
Scene frame (grid)
Vertical image with Fit
alignment rule
Fit If the image orientation is landscape, this will enlarge or shrink (but not distort) the
image width to match that of the scene grid.
‘Camera resolution
Scene Frame (Grid)
Landscape image with
Fit alignment rule
Note that the Fit alignment rule equals the Center Fit rule in the layer properties.
This is the opposite of the Fit parameter. If the image orientation is portrait, its
width will be made to match the width of the scene grid. As a result, part of the
Pan image’s height will extend beyond the height of the frame. This can be useful if

you want to make your background move up and down, or from left to right to
make it appear as if the camera is panning or to actually perform a camera pan.
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Vertical image with Pan
alignment rule

Camera
resolution

Scene frame (grid)

The opposite will apply to a landscape image. Its height will be fit to the scene
grid, therefore it is possible that the image will extend beyond the scene grid's
boundaries.

Scene frame Camera Landscape image with Pan alignment rule
resolution

Note that the Pan alignment rule equals the Center First Page rule in the layer
properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The system looks at the
resolution of the bitmap image, for example 4000 x 2000, then compares it to the
scene's resolution, for example 1920 x 1080, and adjusts the scale factor in
proportion. So, in this example, the bitmap would appear at 208% (4000/1920). If
you import a bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the
size of the project resolution.

Note that the Project Resolution alignment rule is equal to the As Is rule in the
layer properties.
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4. Inthe Drawing Options section, set the following options if desired:

» Drawing Name: Name of the drawing to import.

» Hold Value: Type the number of frames that the drawing will be exposed.

» Scan and Advance: Lets you scan one drawing after another every time you click Scan.
» Flip Drawing: Mirrors the drawings horizontally and scans it this way.

5. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the view.

6. Click Scan to scan your drawing.

7. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next letter to cap-
ture your next frame.

8. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until you have
finished scanning all your drawings.

How to scan an image as a Toon Boom bitmap drawing

1. Inthe Import Options section, select the Import as Toon Boom Bitmap Drawing option.

2. Inthe Layer section, decide if the scanned or imported image will be placed on a new layer or existing layer.

» Create Layer: Scans orimports the image into a new layer. Select one of the following options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Creates a layer based on each unique filename prefix. For example, the
filenames a-1.tga, a-2.tga and b-1.tga will create layers named "a" and
Create Layer(s) Based on Filenames "b", where "a" has two drawings and "b" has one. When creating a
single layer from these three filenames, all three drawings will be inser-
ted in the new layers.

» Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from the Layer
list. You must scan into the same layer type if you're using an existing layer.
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» Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix bitmap
images with vector drawings on the same layer, the bitmap image must be encapsulated in a symbol
and vice versa. Symbols will also be automatically added to the Symbol folder in the Library view.

3. Inthe Alignment section, decide on the size and placement of your scanned image within the camera
frame. Depending on the scene settings (the height and width, in pixels, that you chose for your project),
an image that you scan may be scaled to the point where all its individual pixels become visible.

NOTE: Make sure you're in the Camera view’s Render mode when judging an imported image, otherwise it may

appear blurry.

The following three Alignment Rules options are available:

Parameter Description
Enlarges or shrinks (but not distort) to your image height to match the full
height of the scene frame (alignment grid).

Vertical Fit

Camera resolution

Image with Vertical Fit

alignmant rule Scene frame (grid)

Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match the full width
of the scene frame (alignment grid).

Camera resclution

Image with Horizontal Scene frame (grid)
Fitalignment rule

Actual Size

Scales the image in proportion to the scene's resolution. The system looks at

40




Harmony 12.2 Advanced - Compositing and Effects Guide

the resolution of the bitmap image, for example 4000 x 2000, then compares it
to the scene's resolution, for example 1920 x 1080, and adjusts the scale
factor in proportion. So, in this example, the bitmap would appear at 208%
(4000/1920). If you import a bitmap that is 960 x 540, it will be displayed at 50%
(960/1920) of the size of the project resolution.

4. Inthe Drawing Options section, set the following options if desired:

» Drawing Name: Name of the drawing to import.

» Hold Value: Type the number of frames that the drawing will be exposed.

» Scan and Advance: Lets you scan one drawing after another every time you click Scan.
» Flip Drawing: Mirrors the drawings horizontally and scans it this way.

5. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the view.

6. Click Scan to scan your drawing.

7. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next letter to cap-
ture your next frame.

8. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until you have
finished scanning all your drawings.

How to scan an image and convert it to a Toon Boom vector drawing

1. Inthe Import Options section, select the Convert to Toon Boom Vector Drawing option. You can choose to
encapsulate the image in a symbol by selecting the Create Symbols for Imported Items option.

2. Inthe Layer section, decide if the scanned or imported image will be placed on a new layer or existing layer.

» Create Layer: Scans orimports the image into a new layer. Select one of the following options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Creates a layer based on each unique filename prefix. For example, the
Create Layer(s) Based on Filenames filenames a-1.tga, a-2.tga and b-1.tga will create layers named "a" and
"b", where "a" has two drawings and "b" has one. When creating a
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single layer from these three filenames, all three drawings will be inser-
ted in the new layers.

» Add to Existing Layer: Scans orimports the image into an existing layer. Select a layer from the Layer
list. You must scan into the same layer type if you're using an existing layer.

» Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix bitmap
images with vector drawings on the same layer, the bitmap image must be encapsulated in a symbol
and vice versa. Symbols will also be automatically added to the Symbol folder in the Library view.

3. Inthe Vectorization section, decide whether you want to import your image in black and white or grey.

Parameter Description

Black and White Yectorlzes drawings as a solid black line; creates a 100% vector-based draw
ing.
Vectorizes your image as a mix of vector contour and greyscale bitmap filling.

Grey Lines keep the texture from the scan, and the white of the paper becomes trans
parent.

1. Inthe Drawing Options section, set the following options if desired:

» Drawing Name: Name of the drawing to import.

» Hold Value: Type the number of frames that the drawing will be exposed.

» Scan and Advance: Lets you scan one drawing after another every time you click Scan.
» Flip Drawing: Mirrors the drawings horizontally and scans it this way.

2. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the view.

3. Click Scan to scan your drawing.

4. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next letter to
capture your next frame.
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5. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until you have
finished scanning all your drawings.

Importing Al and PDF Files

You can import Al (Adobe lllustrator) and PDF files into Toon Boom Harmony to convert your files to the Toon Boom
format (TVG) and create a colour palette based on the colour settings of the original file.

When importing Al and PDF files:
* RGB is supported, CMYK is not.
» Gradients and textures are not supported.

* Only legacy versions of Adobe lllustrator are supported. Exported SWFs, including Actionscript 2 and
Actionscript 3, cannot be imported.

*  When importing an lllustrator or PDF file in Toon Boom Harmony, by default the file will be imported as
separate layers. The import will use the Illustrator file's top level groups as separate layer names. However,
you can change this behaviour by deselecting the PDF/lllustrator Import as Separate Layers option, to import
your file as a single layer .

How to import an Al or PDF file

1. Inthe Library view, right-click on the Stage Advanced Library folder and select Right to Modify to unlock the
library folder. Make sure the Lock icon disappears from the folder. If not, your library will remain locked and
you will not be able to import files.

NOTE: For more information, refer to the Library chapter in the Cut-out Animation Guide.
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2. Do one of the following:

» Inthe top menu, select File > Import > SWF, lllustrator Files to Library.
» Right-click on any unlocked folder and select Import Fi les.
The browser window opens.

3. Find and select your Al or PDF file in the Import Files dialog box and click Open.

The Rename dialog box opens.

4. Type in a name for the new template or keep the name of the original Al or PDF file.
5. Click OK.
A new template folder is created in the Library view.
6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until the copy

I
cursor appears before releasing the folder.

The message window opens.

7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before clicking
the Yes button, you have the option of selecting the Do Not Ask Again For This Session option if you
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plan to import multiple .ai or .pdf files.

The colour palette used to create the .ai or .pdf file is imported and a new palette is created under the imported
file’s name.

NOTE:
To learn about the Support CMYK in PDF/lllustrator Import option, refer to the Preferences Guide.

Importing Adobe Flash Files

If a project was started in Adobe Flash and needs a more professional boost, such as camera movements or
multiplaning, it can easily be imported into Harmony.

The actual * . £1a file is not supported in Harmony, so you must export your project from Adobe Flash.
This chapter contains the following topics:

* Importing SWF Files on page 46

» Importing FLA Files on page 48
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Importing SWF Files

You canimport . sw£ files in Harmony that were published using any version of Flash Player, up to version 14.
Note that some effects may not appear when imported in Harmony.

How to import a SWF file

1. Inthe Library view, right-click on the Stage Advanced Library folder and select Right to Modify to unlock
the library folder. Make sure the Lock icon disappears from the folder. If not, your library will remain locked
and you will not be able to import files.

NOTE: For more information, refer to the Library chapter in the Cut-out Animation Guide.

2. Do one of the following:

» Inthe top menu, select File > Import > SWF, lllustrator Files to Library.
» Right-click on any unlocked folder and select Import Fi les.
The browser window opens.

3. Find and select your. swf file from the Import Files dialog box and click Open.

The Rename dialog box opens.

Enter a new file name for the template.

4. Type aname for the new template or keep the name of the original * . swf file.

5. Click OK.

A new template folder is created in the Library view.
6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until the copy

[,
cursor appears before releasing the folder.
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i
i
i

7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before clicking the
Yes button, you have the option of selecting the Do Not Ask Again For This Session option. This might be
useful if you plan to import multiple * . sw€ files.

The colour palette used to create the . ai or . pdf file is imported and a new palette is created under the
imported file’s name.

NOTE: All the Flash layers are automatically attached to a parent peg called GlobalFlashPeg. DO NOT DELETE
THIS PEG. To maintain the look of your movie, it's important not to delete this peg or detach its child layers.

The Adobe Flash file layers appear in the Timeline view. Symbols that were created in Flash become regular
drawing layers, but can be reconverted into symbols in Harmony. Symbols within symbols or drawings within
symbols collapse into their corresponding parent symbol.
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NOTE: Some layers in your .swf movie may be combined in a single layer as a result of optimization
enhancements in your movie file. You can easily move these elements back onto separate layers.

In addition, all drawing elements that are dynamically linked to the Toon Boom Harmony file are grouped
together in one folder. In our example, this means that when you scroll through the Drawing Substitution
preview in the Library view, the different hand, leg, tentacles, antennae, torso and facial positions are all
organized together.

Redistributing Elements

In some instances, due to an optimization enhancement in the exported SWF file (CS4), some of the layers might
be combined as a single layer. If so, you can quickly redistribute these elements onto individual layers again.

How to distribute to layers

1. Inthe Tools toolbar, click the Select w tool.

2. Inthe Camera view, select the drawing that contains elements you want to redistribute onto individual lay-
ers. To select the all the elements of the selected drawing layer, press Ctrl + A (Windows/Linux) or 35 + A
(Mac OS X).

3. Do one of the following:

» From the top menu, select Drawing > Distribute to Layers.
» Inthe Tool Properties view of the Select tool, click the Distribute to Layers gz button.

The number of drawing layers corresponding to the different grouped elements are created in the Timeline
view. The selected elements in the original drawing layer are removed. Each element is distributed onto a
new drawing layer.

4. Repeat the process for each drawing that contains elements to redistribute.

Importing FLA Files

& 2015 Crazy Chicken by Clémence Dufresne

You can export files from Flash and import them in Harmony to transfer character rigs, props and backgrounds.

Flash import is available on all three editions of Harmony on Windows and Mac OS X. It is not possible to do so
on Linux versions.
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On the Flash side, users can work with these versions: Adobe Flash CS5 to Adobe Flash CC. Exports from older
versions of Flash are not possible.

Preparing and Exporting Files from Flash

At the scene level (top timeline), you must have a symbol, such as a movie clip or graphic. Colour shapes, shape
lines, drawing objects, groups and bitmaps at the scene level won’'t be exported. If these elements are present, you
will be prompted to perform a clean up of the scene level. For details on importing Flash files, see Guidelines for
Creating a Flash File Before Exporting to Harmony on page 57

As part of preparing to import Flash files in Harmony, you must add an extension to Flash using Adobe Extension
Manager. The extension is required in order for Flash to export files to Harmony. The extension is called Export
to Harmony.zxp and is located here:

0S Edition Location
. C:\Program Files (x86)\Toon Boom Animation\Toon Boom Har-
Premium . :
mony [version] Premium\resources\flash
Wind Advanced C:\Program Files (x86)\Toon Boom Animation\Toon Boom Har-
Indows mony [version] Advanced\resources\flash
. C:\Program Files (x86)\Toon Boom Animation\Toon Boom Har-
Essentials . .
mony [version] Essentials\resources\flash
. Applications > Toon Boom Harmony [version] Premium Network
Premium
> tba > resources > flash
Mac OS X Applications > Toon Boom Harmony [version] Advanced Net-
Advanced
work > tba > resources > flash
Essentials Applications > Essentials > tba > resources > flash

NOTE: Before installing the extension, you must remove all Harmony offline and database preferences.

It is important to use the correct version of Adobe Extension Manager:

» If more than one version of Flash is installed on your computer, be careful where you install the extension. If
it's added to Adobe Extension Manager of Flash CS6, the extension will only be added in this version and not
the other.

» If you have a previous version of the extension, you must remove it first and install the latest extension—see
How to remove a previously installed Export to Harmony.zxp extension (if applicable) on page 51.

When you export your files, a folder will be created that contains the stage . tpl and export. json files, as well
as allthe . swf and . txtfiles in your scene. The export. json file is used by a Harmony script to organize and
construct the hierarchy from your exported files.

How to install the Toon Boom Animation extension

1. Toremove your Harmony offline preferences (if any), open the following folder:

Windows:
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* Toon Boom Harmony Premium: C:\Users\[user_name]\AppData\Roaming\Toon Boom
Animation\Toon Boom Harmony

» Toon Boom Harmony Advanced: C:\Users\[user_name]\AppData\Roaming\Toon Boom
Animation\Toon Boom StageAdvanced

* Toon Boom Harmony Essentials: C:\Users[\user_name]\AppData\Roaming\Toon Boom
Animation\Toon Boom StageEssentials

Mac OS X:

* Toon Boom Harmony Premium: /Users/[user_name]/Library/Preferences/Toon Boom
Animation/Toon Boom Harmony

* Toon Boom Harmony Advanced: /Users/[user_name]/Library/Preferences/Toon Boom
Animation/Toon Boom Stage Advanced

» Toon Boom Harmony Essentials: /Users/[user_name]/Library/Preferences/Toon Boom
Animation/Toon Boom Stage Essentials

On Mac OS X, the Library folder is a hidden folder. To display the display the folder, told down the Alt key.
» Global: [Server_Name] > USA_DB > scripts
» Environment: [Server_Name] > USA_DB > environments > [environment_name]
» Job: [Server_Name] > USA_DB > jobs > [job name]
» User: [Server_Name] > USA_DB > users > [user_name] > stage > 1200-scripts
2. Delete these folders:
»  full-1200-pref
» 1200-scripts

3. In Adobe Extension Manager, click Install.

4. Locate and open the Export to Harmony.zxp file.
A message opens informing you that you're about to install the Export to Harmony extension.
5. Click Accept.
You may see the following message confirming that you want to install the extension. Click Install.

Adobe Extension Manager

You are about to install the unsigned extension, "Export to
Harmony'. Are you sure you want to install this Extension?

» Mame: Export to Harmony

The extension is not signed.

+~ Don't show this dialog again.

6. Inorder for the changes to take effect, you must close and restart Adobe Flash.
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7. Click OK.

How to remove a previously installed Export to Harmony.zxp extension (if applicable)

1. If open, close Adobe Flash.
2. Start Adobe Extension Manager.

3. From the Products list, select Adobe Flash.

If you have a previous version of the Export to Harmony.zxp extensioninstalled, it will be listed in the
right pane.

4. Select the extension and click Remove.

(;‘, ADOBE* EXTENSION MANAGER €S5 "h mstall [T Exchange @ nelp

File Help
PRODUCTS Enabled Extension Version  Author
Flash CS5 i -.- Export to Harmony 1.0.4 Toon Boom Ar Remove
Fireworks CS5

Dreamweaver CS5

=/
H

21 & =1

Photoshop CS5 64
s Photoshop CS5 32
InDesign CS5

Ps
Ps
[+]

Tllustrator CS5

-

Bridge CS5
The command can be found in Commands xport to Harmony

A message opens asking you to confirm the removal of the extension.

5. Click Yes.

How to export FLA files from Adobe Flash

1. Openyour. £1a file in Adobe Flash.

NOTE: In case of a new file, it needs to be saved before continuing the exportation process. If not, the export won't be
completed.

2. Returntothe scene level.

Before exporting to Harmony, it is assumed that you are at the scene level even if you're not.

3. Do one of the following:

» Older versions of Adobe Flash: Select Window > Other Panels > Export to Harmony.
» Adobe Flash CC: Window > Extensions > Export to Harmony.
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NOTE: This window must be opened once after installing the extension in the extension manager because it
creates a drect link to Harmony (even if the window is not used). Afterwards, you do not have to reopen itif there is
no need to change the option.

The Export to Harmony window opens from which you can set the resolution of the files as it will appear in
Harmony. The default resolution is set to 1920 x 1080, like the HD default resolution value of Harmony. If
needed, you can change the compression: Photo (JPG) or Lossless (PNG).

x
Export to Harmony

SWF options

Resolution Export: 1920 | x | 1080

Image Compression: | Lossless (PNG) -

Expori

4. Do one of the following:

» Inthe Export to Harmony window, click Export button.
» Select Commands > Export to Harmony.
The Output tab displays information about the conversions necessary for the export including:

Distributing to layers, breaking apart, the presence of shapes at the scene level, ungrouping all groups to
verify if any symbols are hidden inside, breaking drawing objects to transfer them as shapes, drawing
substitutions, and so on. Problematic situations will also be mentioned. If nothing appears in the Output
tab, then your. £1a file is clean and does not need any conversions.

The . txt files contain the drawing substitution information and at which frame they are exposed. A .swf
file is created for each symbol in Flash and a . tp1 file is created of them. The corresponding export.json
file is also created, which you will need when importing your Flash scene in Harmony. These files are ina
folder located at the same location as the . £1a file. The folder name is the same as the . £1a file.

NOTE: If a folder with the same name as the . £1a file already exists, you will be prompted to replace the folder.
Be aware that saving Flash projects as .x£1 files will automatically create a folder with the same name as the . fla
file. In this case, the folder of the export will be created inside the folder of the x£1. If this not what you want, place
a copy of the . £1a in another path on your computer before the export.
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SWFopions
Resoliton Bxpon. 1920 ) % (1080
Imaga Compression: |Lowswms P31~ |

Output tab: Information Exson

is displayed here during
the export process.

Importing Flash Files in Harmony

When importing Flash files, the Scripting toolbar must be displayed, which should contain the Import Flash Scene
icon. If the icon does not appear in the toolbar, add it to the Scripting toolbar. Note that you will only have to do this

once. After that, you can import Flash files whenever needed.

Import Flash Scene

How to display the Flash icon

1. From the top menu, select Windows > Toolbars > Scripting.

The Scripting toolbar bars appears below the File toolbar in the upper-left of the Harmony interface.

2. Click the Manage Scripts button.

The Scripts Manager opens.
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Cancel

3. From the Files section, select TB_Import_Flash_Scene.js.

On your computer, here is the location of the script file:

o Windows:

« Toon Boom Harmony Premium: C:\Users\[user_name]\AppData\Roaming\Toon Boom
Animation\Toon Boom Harmony\1200-scripts

» Toon Boom Harmony Advanced: C:\Users\[user_name]\AppData\Roaming\Toon Boom
Animation\Toon Boom Advanced\1200-scripts

- Toon Boom Harmony Essentials: C:\Users[\user_name]\AppData\Roaming\Toon Boom
Animation\Toon Boom Essentials\1200-scripts

e MacOSX:

« Toon Boom Harmony Premium: /Users/[user_name]/Library/Preferences/Toon Boom
Animation/Toon Boom Harmony/1200-scripts

« Toon Boom Harmony Advanced: /Users/[user_name]/Library/Preferences/Toon Boom
Animation/Toon Boom Advanced/1200-scripts

- Toon Boom Harmony Essentials: /Users/[user_name]/Library/Preferences/Toon Boom
Animation/Toon Boom Essentials/1200-scripts

On Mac OS X, the Library folder is a hidden folder. To display the display the folder, told down the Alt key.

2. From the Functions section, select TB_Import_Flash_Scene and click the arrow button to move it to the
In Toolbar section.
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ene in TB_Import_FI

Customize Icon

Customize Tooltip

3. Click OK.

The Import Flash icon appears in the Scripting toolbar. Everything is now ready to import Flash scenes.

Import Flash Scene

How to import FLA files

1. Inthe Scripting toolbar, click the Import Flash button.

2. Inthe Import Files dialog box, locate the export.json file contained in the folder that was created when you
exported your files from Flash.

3. Click Open.

In a few moments, the colour recovery dialog box appears, requesting a colour recovery.
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4. Before clicking Yes, you have the option of selecting the Do Not Ask Again For This Session option.

In afew moments, the . £1a files are imported in Harmony.
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402015 Crazy Chicken by Clémence Dufresne

5. Inthe Node view, press 1to zoom out of the Node view and see the entire node system.
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Your Flash Scene in Harmony
Once the Flash project is successfully imported into Harmony, here's how the hierarchy was constructed:
» Each symbol has its own peg in which all the transformation information is stored.

» The pivot information is stored in the peg's Layer Properties (Pivot fields). The pivot information came from
the rotation point of the symbol in Flash.

* Registration point of the symbol in Flash represents the centre of the drawing space in Harmony. Therefore,
the position of the drawing inside a symbol will be exactly the same in Stage.

* One colour palette is created for each Flash import. One colour swatch is created per RGB value. If you have
more than one zone using the same colour, they will be linked to the same colour swatch.

» If there are masks in your Flash project, they will reconstructed in Harmony using Cutter effects. Harmony is
now able to understand when more than one symbol share the same mask in Flash. Each symbol sharing the
same mask will be grouped by a composite and connected to the cutter.

Guidelines for Creating a Flash File Before Exporting to Harmony

Scene Root

What can be at the scene root:
*  Only symbols. A minimum of one symbol is necessary. It could be a MovieClip or a graphic.

What cannot be used at the scene root:
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» Shapes: Colour shapes and line shapes
* Bitmaps
« Drawing objects

» Groups: The group works differently at the scene level. They are understood as shapes at the scene level—
see Mixed Layers on page 59.

Timeline

These features can be used in the Flash file, but will not appear in Stage Advanced:
» Guide layers for references
* Locked layers
» Disabled layers
* Folders in the Timeline view

» Other: Several symbols on the same layer/keyframe. In this case, Stage Advanced will separate them,
giving them a proper layer. In other words, a Distribute to Layers action performed in the process of
exporting/importing.

Not recommended:
* Mixed layers—see Mixed Layers on page 59
» Symbols with shapes, bitmaps, or group on the same layer/keyframe

« Symbols with drawing objects

Library View
In the Library view, the following will not be exported:

» ActionScript Linkage
* Embedded fonts

Effects

The following effects will not be exported:

Adjust Colour
Drop Shadow
Blur
Filters
Glow
Gradient Bevel

Gradient Glow

Alpha
Colour Effects (other than None) Advanced

Brightness
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Tint

Blending (other than Normal):

e Layer

* Darken

e Multiply

* Lighten

* Screen

*  Overlay

* Hard Light
Display * Add

* Subtract

« Difference

¢ |nvert
* Alpha
¢ FErase

Render: Cache as Bitmap

Component parameters

Drawing Features
»  Width tool: Any change on the thick and thin of a line
+ Line:
+  Width

» Cap: Any change of the line cap will be replaced by the round cap (None and Square)
» Join: Any change of the line join will be replaced by the round join (Miter and Bevel)

» Gradient (Flow): Reflect colour, Repeat colour

* Import Bitmap: When importing .swf files, you can import files that have an image compression of Photo
(JPG) or Lossless (PNG).

Mixed Layers

Mixed layers are something you must seriously consider before trying to export a Flash project to Harmony.
Otherwise, there can be unexpected results or no export at all. In fact, it's best to avoid having mixed layers
altogether.

A mixed layer is defined as a layer that has more than one instance of objects at the same keyframe. It could be a
mix of symbols and groups; groups and drawing objects; symbols and shapes, and so on. Since Harmony
understands symbols better than groups or drawing elements, some information can be lost along the way.
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Understanding Drawing Objects

Drawing Objects

No matter what is inside a drawing object, it will always be understood as a shape. So if a drawing object shares
the same layer with a shape, it won’t be a real mixed layer, since they are all understood as shapes.

Mixed Layers

Symbols and Drawing Objects/Shapes on the Same Layer

If there are symbols and drawing objects/shapes sharing the same layer, the symbols will be separated from
them and all the drawing objects/shapes will be kept together. Drawing objects and shapes cannot be separated.
In Harmony, the symbols will have their own Drawing node and the drawing objects/shapes will share the same
Drawing node. Since only symbols can have a hame, its name is propagated to the Drawing node and peg.

Drawing objects and shapes, however, can't do this. Drawing objects and shapes will receive the name of the
MovieClip followed by an underscore and an appropriate number. For example, if you have a group inside a
symbol called HEAD, the group will be named HEAD_1if there is already a Drawing node that was created with
the same name.

Mixed Instances at the Same Level as a Symbol

Mixed instances at the same level as a symbol can occur when, at the same level inside a symbol, there is more
than one type of element sharing the same timeline at a specific frame. Those elements may be mixed layers.

Type of problems that can occur if mixed instances are kept:
* Order of appearance can be lost

» Some layers can merge together

» Transparency of shapes can cut other shapes

Importing QuickTime Movies

When creating an animation, it is not unusual to embed moving elements saved as videos within the animation.
Toon Boom Harmony allows you to import Quick Time movies into your project.
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How to import a QuickTime movie

1. From the top menu, select File > Import > Movie.

2. Browse for the QuickTime movie to import and click Open.

The Import Images dialog box opens.

NOTE: Do not browse for the movie file again. Leave the automatically generated field text as “many files selected”.

3. Make your decisions for the Layer, Alignment and Transparency sections of this dialog box—see Importing a
Bitmap Image Without Vectorization on page 8.

4. Click OK.

The QuickTime video appears in the Timeline view as an image sequence. You can scroll through the film
frame-by-frame just as you would scroll through your animation drawing-by-drawing.

Creating Custom Vectorization Parameters

You can create your own vectorization settings with Harmony. The vectorization parameters you create can be
saved, shared and also inserted into the VectOptions. conf file used by the Scan and Control Center modules
when scanning or vectorizing a series of drawings.

You can use an interface to select and test the different options, as well as type in some advanced settings.

The Vectorization Parameters dialog box lets you vectorize pencil drawings, along with any red, blue or green pencil
marks you may have used to indicate highlights and shadows. The drawing will be vectorized into pure red, blue,
green and black (RGB values), while creating colour art zones wherever lines connect. After painting in your tones
and highlights, change your pure RGB colours to transparent (0 Alpha) in the Colour Picker window and watch the
indicator colour zone lines disappear.
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How to open the Vectorization Parameters dialog box

1. From the top menu, select File > Import > From Scanner.
You can also open it from any other import option that allows you to customize the vectorization para-
meters (i.e. from the scanner).

2. Inthe Scan Drawings window, do the following:

» Inthe Layer section, decide on the layer options.
» Inthe Import Options section, select the Convert to Toon Boom Vector Drawing option

» Click Preview.
3. Inthe Vectorization section, click the Vectorization Parameters button.

The Vectorization Parameters dialog box opens.

Restore Defaults

» Options Tab on page 62
* Help Tabon page 64

Options Tab

The Options tab contains the main vectorization settings. More settings are available in the Help tab.
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Parameter

Description

Input

The input filters are applied to the bitmap image before it is vectorized.

One Pass: One threshold value is applied to both the Line and Colour Art. For
drawings with distinct vector-style lines of mattes, you only need one pass.

Two Passes: Applies a different threshold value to each layer. For greyscale
drawings, you may want to perform the vectorization process twice to apply dif-
ferent threshold values to the Line and Colour Art layers.

Threshold: Determines which values in the scanned image are considered part
of the Line or Colour Art layer and what will be eliminated from the vectorized
drawing; 0% is white and 100% is black. The threshold is between these two
values.

Expand Bitmap: Lets you enter a value to scale the bitmap to detect small
variations in the line. Use this option if you scanned a greyscale image and want
to preserve small variations in the texture to apply to the line art.

Jag Filter: Lets you enter a value to scale back the bitmap to remove some of the
line’s roughness. This is useless when you have a drawing that appears quite
rough; the Jag filter will eliminate excess strokes in the final drawing.

Output

The output filters are applied during the vectorization process.

No Colour Art: Does not generate filling zones in the Colour Art layer.

No Texture: Does not generate texture in the Line Art layer in the final images.
Select this option to create solid lines in the final line art.

Generate Matte in Underlay Layer: Creates an opaque zone behind your
drawing’s lines to avoid seeing through the layers.

Colour as Texture: Converts colour values into a texture layer.

Optical Registration

The optical registration options are used to automatically align drawings based on
the position of the peg holes on the animation paper. The peg holes must appear
in the scanned drawings for the optical registration to work.

DPI: Lets you enter the dots-per-inch value of yourimage. You must enter the
same value as the DPI used to scan the image.

Peg Side: Lets you select the position of the peg holes on your drawings. Identify
whether they are on the top, bottom, left or right.
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Strictness: Determines how exact the location of the peg holes must be for the
software to recognize them. There are two values to choose from:

» Strict: The peg holes must be in a tightly defined area to be recognized.

* Loose: The peg holes can be recognized somewhere in a larger area. This
is the recommended setting.

Field Chart: Lets you indicate the size of the animation paper, 12 or 16.

Post Processing

The Post Processing filters are applied to the final vector images.

Remove Holes: Removes holes of a specified value that might make painting
difficult.

Remove Dirt: Removes stray marks and dirt of a specified value. Try a value
around 500.

Remove Hair Size: Removes small strokes that have no line art.

Remove Hair: Number of Passes: The number of times the drawing will be
analyzed to identify hair marks.

Miscellaneous

Close Gaps: Closes gaps in the Colour Art so you can paint it.

Smooth Passes for Line Art Before Breaking Triangles: The number of times
the smoothing operation runs before creating the triangles that break lines in the
drawing. If unnecessary triangles are appearing in the drawing, increase this
value.

Smooth Passes for Line Art: The number of times the smoothing operation is
performed after the triangles have been created. This further smooths the line art.

Preview

Show Strokes: Shows the strokes in the Vectorized Image panel.

Stroke Thickness: Shows the size of the strokes.

Help Tab

The Help tab contains the most advanced vectorization settings which you type in the Advanced Option fields at
the bottom of the Vectorization Parameters dialog box.

File 10 Options

-file <filename (including extension)> [ options ]
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-infile <filename (including extension)>; same as -file

-outfile <filename>; alternate output file

-informat <format>; the input format. Used if reading from stdin

-debug; turn on debug mode

-noforce; don't force output if image is inconsistent

-version; print version information and quit

-output_version <version>; output files of this version. Valid versions can be: 0 or 604

-force_unamed_palette_for_texture; will generate a texture in TVG's internal palette

Registration Options
-register <dpi side strictness>; perform optical registration.
» Side can be one of left, right, top, bottomor|, r, t, b.
+ Strictness can be either loose, strict or|, s.
-register_center_peg_holes; will use only round holes in 16 fields page
-reph; short form of register_center_peg_holes
-registration_looseness_factor <factor>; registration looseness factor (default 2.000000)
-rif; short form of registration_looseness_factor
-rdebug; output registration debug messages
-pegpitch <inch (default 8.000000)>; distance between peg bars
-threshr < (default 0.500000)>; threshold for optical registration; range 0.0to 1.0
-rmargin <inch (default 1)>; region size where to look for peg bars
-peg_distance_from_center <inch (default 5.25)>; peg distance from centre of the image
-pdfc; short form of -peg_distance_from_center
-out_peg_position <side (default same)>; wanted position of the peg on the drawing.
+ Can be one of right, left, top, bottom (orr, I, t, b) or same.
» Avrotation will be performed if it is different from the side passed to -register.
-output_peg_matrix; output the peg transformation matrix on standard output.

-scanner_calibrate; < (default 1.0000 1.0000) > x and y scale factors to be applied to scanner image.

Filtering Options

-pixel <pixel_shape (default '4x3")>; Valid values: 4x3
-gap <worldUnits (default 10)>; close gaps up to this big
-pencil; generate line art only

-keep_dirt; don't filter out dirt
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-thresh <threshold (default 0.2)>; range 0.0to 1.0
-rmv_hairs <worldUnits (default 1)> <passes (default 1)>
* remove hairs of size smaller than "size" in "passes" passes
-rmv_holes <area (default 7)>; remove holes smaller than "area"
-rmv_dirt <area (default 1)>; remove dirt smaller than "area"
* try values between 100 and 500 for rmv_holes and rmv_dirt. The area is in world units squared
-rmv_triangles <worldUnits (default 30.000000)>; remove triangles at "pixels"
» distance from each other. Use -no_break to remove all triangles
-no_texture; don't generate textured strokes
-color_as_texture; will vectorize the alpha channel and put the RGB colour in a textured colour
-noclosegap; disable all gap closing algorithms
-no_break; disable the breaking of line art
-jag_filter <pixels (default 0>; expand the pixels in the vectorization bitmap
-expand_bitmap <pixels (default 0>; expand the pixels in the vectorization bitmap
-fit_errorc <error (default 1.000000>; fitting error for the colour art
-fit_errorl <error (default 1.000000>; fitting error for the line art
-smoothl <passes (default 1>; number of smooth passes for line art
-smoothc <passes (default 1>; number of smooth passes for colour art
-first_smooth <passes (default 0>; number of smooth passes for line art before breaking triangles
-first_smoothl <passes (default 0>; number of smooth passes for line art before breaking triangles
-first_smoothc <passes (default 0>; number of smooth passes for line art in colour art pass (needs -2pass)

-2pass; specify two sets of parameters; one for line art "I", one for colour art "c"

(-thresh, -rmv_holes and -rmv_dirt will be overridden by -threshl, threshc, -rmv_holesl,
-rmv_holesc, -rmv_dirtl and -rmv_dirtc)

threshl <threshold for line art (default 0.5)>; range 0.0to 1.0

-threshc <threshold for color art (default 0.5)>; range 0.0to 1.0

-jag_filterl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art
-jag_filterc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art
-expand_bitmapl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art
-expand_bitmapc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art
-rmv_holesl <area (default 7)>; remove line art holes smaller than "area"

-rmv_holesc <area (default 7)>; remove colour art holes smaller than "area"

-rmv_dirtl <area (default 1)>; remove line art dirt smaller than "area"

-rmv_dirtc <area (default 1)>; remove colour art dirt smaller than "area"
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try values between 100 and 500 for rmv_holesl|, rmv_holesc, rmv_dirtl and rmv_dirtc. The values are in world
units squared

-margins <inch (default 0.25)>; remove margin around bitmap

-top_margin <inch (default 0.25)>; remove margin at top of bitmap

-bottom_margin <inch (default 0.25)>; remove margin at bottom of bitmap

-left_margin <inch (default 0.25)>; remove margin at left of bitmap

-right_margin <inch (default 0.25)>; remove margin at right of bitmap
-remove_peg_bars; remove the peg bar holes

-field_size <fields (default 12 or use value in scan file)>; set the drawing to this field size
-fs; short hand for -field_size

-peg_bar_size <inch (default 1)>; the size of the peg bar region

-noframe; do not put a frame around the colour art

-frame_fields <default -1.000000>; put a frame of the specified dimension around the colour art
-downscale_input <default 1>; downscale the raw input by this integer factor
-downscale_texture <default 1>; downscale the output texture by this integer factor
-buildmatte; generate a matte on underlay for line test

-buildmatte_colourart; generate a matte on colour art for line test

Note: -buildmatte and -buildmatte_colourart are mutually exclusive
-copystrokes; copy original strokes when building matte.

Options for bitmap that has no registration information
-pixel_margins <inch (default 0)>; remove margin around bitmap
-top_pixel_margin <inch (default 0)>; remove margin at top of bitmap
-bottom_pixel_margin <inch (default 0)>; remove margin at bottom of bitmap
-left_pixel_margin <inch (default 0)>; remove margin at left of bitmap
-right_pixel_margin <inch (default 0)>; remove margin at right of bitmap

-dpi <(default -1)>; dpi information of input bitmap

RGB Keying Options

-rgb; generate separate zones for red, green and blue lines

-rgb_alpha <value (default 255)>; generate red, green and blue colour with alpha of this value
-no_red; ignore red colour in vectorization

-no_green; ignore green colour in vectorization

-no_blue; ignore blue colour in vectorization

flatten; flatten the drawing after generating colours
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-rmv_rgb_dirt <threshold area default 0.0>; remove red, green and blue regions smaller than area
-expand_bitmap_rgb <pixels (default 0>; expand the pixels in the vectorization bitmap for rgb
-threshrgb <value> <threshold for rgb vectorization default 0.200000>;

-threshsv <saturation threshold default 0.500000> <value threshold default 0.500000>; thresholds on saturation
and value to consider a pixel to be grey

Colour Vectorization Options
-color_vectorize; perform a colour vectorization
file2 <colour art filename>; specify the colour art bitmap

-penstyle <center alpha (0.0-20.0)> <edge alpha (0.0-20.0)> <gamma (0-10)><centre pressure effect (0.0-1.0)>
<edge pressure effect (0.0-1.0)><texture bitmap downscaling (0.2-20)> <texture bitmap file (valid filename or "" if
no file)>; generate brush texture for the line art

-pressure_variation <strategy (0, 1 or 2)> <min pressure (0.0-1.0)> <max pressure (0.0-1.0)> <max variation
(0.0-1.0)>; specify a pressure strategy for the centre line.

-blur_radius <pixels (default 0)>; blur the penstyle texture generated

-color_contour_smooth_passes <times (default 3)>; perform number of smooth passes on contour before
computing texture

-ccsp <times (default 3)>; short for -color_contour_smooth_passes
-color_rmv_holesl <world units (default 0.000000)>; remove holes of this size when computing texture

-color_fill_holesl <world units (default 0.000000)>; fill holes of this size for colour line art

Bubble Usage (implemented only for colour vectorization's line art)
-create_bubbles; add bubbles into the LineArt. Implemented for colour vectorization only
-bubble_gap <value (default 3)>; max number of colour art points between 2 bubbles
-bubble_length <value (default 10)>; max number of circles in a bubble

-min_radius <value (default 1.5000)>; min radius of a circle in a bubble relative to the line thickness (must be >=
1.0)

-max_radius <value (default 3.5000)>; max radius of a circle in a bubble relative to the line thickness (must be
>=1.0)

-uniform_gap; the space between bubbles is constant

4 Colour Vectorization

-4colours [key:value] ... [key:value] ; The key value list can be empty. The list of keys is:
rgbdiff:value ; between [0.0-1.0] or [0-255]

dark:value ; between [0.0-1.0] or [0-255]

grey:value ; between [0.0-1.0] or [0-255]

white:value ; between [0.0-1.0] or [0-255]
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dirt:value ; dirt area. 200 is a good value
rt:value ; between [0.0-1.0] or [0-255]
gt:value ; between [0.0-1.0] or [0-255]
bt:value ; between [0.0-1.0] or [0-255]

NOTE:
There must be no space between the colon and the key/value. For example: -4colours rgbdiff:20 dark:20 grey:120

white:250 dirt:200 rt:240 gt:240 bt:240

Creating a Vectorization Style

With Harmony, you can create custom vectorization parameters that can be saved, reused, shared, or used to set
the Scan module vectorization style list.

You can vectorize drawings using one of the following methods:

» Black and White: All the lines become vector based and 100% black. The white areas become completely
transparent.

» Greyscale: All the lines preserve their initial textured look in grey shades as a bitmap image contained inside
a vector frame. The white areas become completely transparent.

* Four Colours: With the advanced parameters, you can isolate the red, green, blue, and black lines and turn
them into 100% vector lines, preserving their original colours—see Creating Custom Vectorization
Parameters on page 61.

How to create or modify the vectorization parameters

1. Set the different options available in the Vectorization Parameters dialog box.
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Cancel

2. Click the Vectorize button to update the Vectorized Image preview.

The vectorized image is just a preview. The actual vectorization happens when you click OK in the Import
Images dialog box. There are many options to try in the Vectorization Parameters dialog box. These are
applied during the vectorization process.

3. Toset advanced parameters, read the information on the Help tab, then type in the Advanced Options field
at the bottom of the dialog box.

4. Tosave your vectorization parameters to reuse them later, share them, or use them to set the Scan mod-
ule vectorization style list, click Save.

5. Inthe Browser window, name and save the file.

6. To save the current settings as your default settings, click Save As Default. To restore the default set-
tings, click Restore Defaults.

7. Toload a vectorization style, click Load and locate the existing * . vof£ file.

8. Click OK.
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Setting the VectOptions.conf File

Toon Boom Harmony Server uses afile called VectOptions . conf to get the vectorization style when batch
vectorizing a series of drawings. A series of default styles is available in this file, but you will certainly want to create
your own to fit your production style.

How to set the VectOptions.conf file on Windows or Mac OS X

1. OpenthevectOptions.conf file:

» Windows: Select Programs / All Programs > Harmony 12.2 > Tools > Configuration Editor.
» Mac OS X: Select Applications > Harmony 12.2 > Tools > Configuration Editor.
The Configuration Editor window opens.

Configuration Editor E]@

File

This file contains Vectorization parameters that are automatically |_
to the vectorization queue from Scan and Manager. [
211 the options must be on a single line preceded by the style name
Only the style name appears in the menu in Scan and Manager
& line that starts with # is considered as comment
The syntax used must be style name: name

cptions: optionl cption2 option3

O R o TR

p33333333333333323333333333333333333333333333333333333 % s s s

#Registration options:

-register <dpi side strictness>; Perform optical registratio
Side can be one of left, right, top, bottom or 1, r,
Strictness can be either loose, strict or 1, s.

F

-register center peg holes; Will use only round holes in 16
-reph; Short form of register center peg holes

-registration looseness factor <factor>; Registration loosen
-rlf; short form of registration looseness factor

—-rdebug; output registration debug messages

-pegpitch <inch (default 8.000000)>; distance between peg ba
—-threshr < (default 0.500000)>; threshold for optical regist ¥

1 }

AR R B

| Manager.conf Scan.conf I VectOptions. conf I SErverini |

2. Inthe bottom section of the window, select the VectOptions.conf tab.

3. Scroll down the VectOptions.conf file to see all the different options available for creating your custom vec-
torization style. These options are the same as in the Vectorization Parameters dialog box. It is recom-
mended that you create your vectorization style using Harmony and the Vectorization Parameters window
and copy the result parameters in this file—see Creating a VVectorization Style on page 1.

4. Scroll down toward the bottom of the file to see the default styles. You can modify them or add new ones to
the list using the parameters you got using the Vectorization Parameters window. Notice that some of the
lines have a “#” sign at the beginning to indicate that the line is a comment and will not appear in the style list.
The lines that have no sign at the beginning appear in the style list.
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ol -~

(\l’emriutionsnles BRI EEIIEIREIIRRIIRNINERIIRIIRRRIRREIRESIERIIRRSS
[ocfadSe ] §

(TVGOefaut style m——f 2t yles £or TVG drawings

'.m-Hg‘-ls-.’B-\'Jnoe-wﬁ:-\ ]

S style_name: (TVG)Default style

SRpaCh R options: -no_texture -rmv_holes 7 -rmv_dirt 10 -fit_errorl 2.0 -fit_ex
Grayscale soft edge N = = - = -
[PNTIBW cefaut

[PNTIB+W notriangles atyle name: tones/hilighta(B+W notriangles)
m\w o0 options: -no_texture -rmv_holes 7 -rmv_dirt 10 -fit_errorl 2.0 -fit_ex

Teonshader
style_name: Grayscale
\fp‘:ion:: -2pass -threshl 0.05 -threshc 0.05 -rmv_holesal 7 -rmv_holesc

L tyle_name: Grayacale rougher lines

options: -Zpass -threshl 0.1 -threshc 0.2 -rmv_holesl 7 -rmv_holesec 7

style_name: Grayscale soft edge
options: -2pass -threshl 0.05 -threshc 0.05 -rmv_holesl 7 -rmv_holesc
v

[£] >

5. Tocreate a new style, type the following below the existing styles:

style_name:

This should be followed by the name of your new style. Forexample: style name: Black Lines.
6. Under the style name line, type the following:

options:

7. Copy and paste the information in your *.vof style when saving your settings in the Vectorization Para-
meters window.

» Toopenthe *.vof file, use any plain text editor application.

blackLines.vof - WordPad ==

File Edit View Insert Format Help
DEE S # L 2@ o B

-threshl 0.54 -threshc 0.37 -rmv_hairs 1 1 -rmv_holes 7 -rmv_dirt 1 -expand bitmap 0 -jag_filter
|0 -no_texture -2Zpass -gap 5 -thresh 0.11 -smoothl 5 -first smoothl 5 -field size 12

For Help, press F1 MM

style _name: Grayscale soft edge
options: —2pass -threshl 0.05 —thresh'D.DS -rmv_holesl 7 -rmv_holesc [

—
style name: Black Lines
options: -threshl 0.54 -threshe 0.37 -rmv_hairs 1 1 -rmv_holes 7 -rmv_

< I | B

Manager.conf | Scan.conf | VectOptions.conf* | server.ini

8. Inthe Configuration Editor's top menu, select File > Save.

9. If you have Toon Boom Harmony Scan on your computer, you can start the application and verify that the
new style appears in the Vectorization Style list under Edit > Vectorization Style.
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NOTE:
If you are using the batch processing method available with Toon Boom Harmony Server to scan and vectorize
drawings, the selected style must be available on all the machines included in the batch processing list.

Refer to the Control Center Guide Guide to learn more about setting up and using batch processing.

Vectorization Styles

Default Style

(TVG)Default style
tones/hilights(B+W notriangles)
Grayscale

Grayscale rougher lines

(PNT)B+W notriangles
(PNT)Grayscale .50
Toonshader

oK l [ Cancel

How to set the VectOptions.conf file on Linux using the vi text editor

1. Open a Terminal window:
Menu: Applications > System Tools > Terminal

2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony 12.2/etc

3. Change your user to "root":
$ su
» If your useris part of the sudoers list, enter the following command and go to step 5.

$ sudo vi VectOptions.conf
4. Enterthe root password.

5. Open the VectOptions.conf file:

$ vi VectOptions.conf
6. To start editing, press | to enter Insert mode.
7. When you're finished editing the file, press Esc to exit Insert mode.

8. Tosave the changes made to the file, type the following and press Enter/Return:

$ :w!

9. Toexit the vi editor and return to the Terminal, type the following and press Enter/Return:

$ :q
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10. If you have Toon Boom Harmony Scan module on your computer, start the application and verify that the
new style appears in the Vectorization Style list under Edit > Vectorization Style.

NOTE:

If you are using the batch processing method available with Toon Boom Harmony Server to scan and vectorize
drawings, the selected style must be available on all the machines included in the batch processing list.

Refer to the Control Center Guide Guide to learn more about setting up and using batch processing.

Vectorization Styles

Default Style
(TVG)Default style
tones/hilights(B+W notriangles)
Grayscale

Grayscale rougher lines

=0

:EP NT)B+W notriangles
(PNT)Grayscale .50
Toonshader

oK l [ Cancel

How to set the VectOptions.conf file on Linux using the gedit text editor

1. Open a Terminal window:

Menu: Applications > System Tools > Terminal

2. Openthe etc folderinside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony 12.2/etc

3. Change your user to "root":

$ su

» If your useris part of the sudoers list, enter the following command and go to step 5.

$ sudo gedit VectOptions.conf

4. Enterthe root password.

5. Openthe VectorOptions. conf file:

$ gedit VectOptions.conf

6. Edit the parameters of the VectOptions. conf file as you would do in most text editor applications.

7. Select File > Save.

8. Select File > Quit.

9. If you have Toon Boom Harmony Scan module on your computer, start the application and verify that the
new style appears in the Vectorization Style list under Edit > Vectorization Style.
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NOTE:

If you are using the batch processing method available with Toon Boom Harmony Server to scan and vectorize
drawings, the selected style must be available on all the machines included in the batch processing list.

Refer to the Control Center Guide Guide to learn more about setting up and using batch processing.

Vectorization Styles

Default Style

(TVG)Default style
tones/hilights(B+W notriangles)
Grayscale

Grayscale rougher lines

(| EEEN
(PNT)B+W notriangles
(PNT)Grayscale .50
Toonshader

oK l ’ Cancel
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Chapter 3: Library

Using templates and symbols , you can share and reuse any elements you create in Harmony. The Harmony library
lets you store several different elements such as puppets, backgrounds, animations and key poses. In fact,
anything you create in Harmony can be stored in the library.

This chapter contains the following topics:

» Understanding the Library Concept on page 77

* Library View on page 79
* Organizing the Library on page 81

» Templates on page 85

» Symbols on page 87
» Importing Symbols and Templates on page 95

» Importing Files Through the Library on page 99

* Using Paste Special on page 99

Understanding the Library Concept

The Library view is where you can store and reuse your artwork and animation in other scenes or build props and
puppets.

*  Whatis a Library?on page 78

* Understanding the Library Concept on page 77

*  What is a Symbol? on page 78

» Understanding the Library Concept on page 77
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What is a Library?

The library is a storage centre for all production assets; the elements stored in the library are called templates.
Although it is mainly used for cut-out animation, the library is also useful for paperless and traditional animation
processes. The library can contain any asset used in a Toon Boom Harmony production.

Using the library is as simple as dragging the content into the library to store your artwork and then dragging it to
the Timeline or Camera view when you want to reuse it.

You can organize your library using several different subfolders and store them on your hard drive or network.

What is a Template?

A template is an individual copy of the artwork stored in the library which you can reuse in different scenes. Once
atemplate is stored in the library, you can access it from any project.

Dragging a template into your scene copies the content in your Timeline and does not link it to the original. You
can modify this individual copy at any time.

What is a Symbol?

A symbol is a container used to build your props, puppets and looping clips. You can use symbols to contain
artwork and animation and manipulate them as a single object. You can also use symbols as a placeholder in
which you place a series of different drawings for each body part of your puppets or when you have a repeating
cycle. However, symbols are not necessary for creating characters.

To create a symbol, drag your artwork to the Symbol library. When you drag a symbol from the Symbol library into
your scene, it will be linked to the original symbol. If you drag a symbol into your scene several times in the
Timeline view, they will all be linked to the original symbol. If you modify one, they will all be modified.
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A symbol is local to the project and cannot be accessed directly from other scenes. To reuse a symbol's content in
another scene, you must create a template out of it.

When a symbol is exposed in the Timeline view, the symbol's cells are represented as a movie strip.

Regular drawing cells
Symbol cells

Library View

Library menu , Lbrary (%

Preview window
Flag_Animation

.
Al Living_Roo
Library search tool

I llA

Library list

Templates and symbols list

You use the Library view to create and manage your symbols and templates, display the folders and manage and all
of the content.

Library View Menu

The Library menu lets you access commands specific to the Library view, such as opening a Library or getting the
rights to modify a library folder.

Preview Window

79



Chapter 3: Library

The Preview window lets you preview the content of a symbol or template, and swap between drawings and
symbol cells in the Timeline view. This window is also used as the Drawing Substitution window.

How to preview a template or symbol's content

1. Inthe Library view's right side, click or double-click on the symbol or template to preview.

2. Inthe Preview window, click the Play » button or drag the slider to scrub through the frames.

Library Search Tool

When working on a movie or series, you will probably end up with many templates and symbols in your library.
Using the Search tool, you can quickly find the templates and symbols in your folders.

How to use the Library Search tool

1. From the left side of the Library view, select the library in which you want to search.

2. Inthe Search field, type the name or partial name of the symbol or template you are looking for.

TATIWI

3. Click the left and right arrows to see the previous and next results. The Search engine will look for
results within the library master folder and its subfolders. It will not look in other libraries.

Library List
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The Library list lets you navigate through the different libraries and subfolders. You can also open, close and create
new libraries from here.

The Library folders have these default libraries:

+ Symbols: The only library folder containing symbols for your project. You can organize the symbols library
folder using subfolders, but you cannot create a second library for your symbols. This library is local to your
project.

+ Harmony Library: This folder contains templates and is stored on your hard drive. You can organize the
Harmony library folder using subfolders. This folder does not contain symbols.

Templates and Symbols List

Flag_Animatio

Limpa_|

S

The symbols and templates contained in the selected Library list can be displayed on the right side of the Library
view as thumbnails, in a list or as details.

How to access the templates and symbols list display options

» Inthe Library view's right side, right-click and select View > List, Thumbnails or Details.
» Inthe Library View toolbar, you can click the following buttons:

Thumbnails

List

Details

Organizing the Library

As you will probably create a large number of symbols and templates, you will soon realize they need to be
organized. You can create different libraries and subfolders to easily access your assets. For example, you can
create a different library for each project and divide it into several categories, such as:

» Characters
*  Props
» Backgrounds

Although you can only have one symbol library folder, you can organize it by creating subfolders.
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There are two ways to create library folders.
» Directly through your operating system
* Using Harmony's interface

Folders can be opened in Harmony when you require it. You can open any folder on your hard drive or network as
a library. Opening a library means linking the folder to your Library view. You only need to open the library once.
The library folder is available every time you open the application until you decide to close the library and unlink it.

You may not always require all the library folders in the Library List. If so, you can close the ones you do not need.
Closing a folder does not delete it; it only unlinks it from the Library view. If you want to reopen it, locate it on your
hard drive or network and open it in the Library view.

Symbol and template libraries need to be organized. You can create different subfolders on your hard drive or in
the Harmony Library view, so you can easily access assets. By default, any new library you link to your Library
view is locked to prevent accidental deletion or modification of symbols and templates. You must obtain the right
to modify it before being able to add a new folder to it.

You can delete a folder from the library if its contents are no longer needed.

NOTE: Warning: All templates and symbols in the folder will be deleted from your hard drive. Once deleted, the
data cannot be retrieved.

Once you add a folder, you can rename it. This also renames the folder on your hard drive.

If you update the content of your libraries through your operating system, you will need to refresh your library
folders in the Library view.

When you display thumbnails in the Library view, the system generates a series of small images (thumbnails) for
you. You can generate template thumbnails yourself, if they do not display or if the process has been stopped.

You can also delete thumbnails if you want to send a template to another user or studio and keep your packages
small.

How to create a library folder through your operating system

1. Onyour computer, create a new folder with a relevant name in the location where you want the library to be
stored.

How to create a library folder in Harmony

1. Inthe Library View menu, select Folders > Open Library.

The Browser window opens.
2. Browse for the location where you want to store your new library folder.

3. Click the New Folder button.

A new folder appears.

4. Name the new library folder with a relevant name and click OK.
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The new library appears in the Library List section.

How to open a library

1. Inthe Library View menu, select Folders > Open Library.

The Browser window opens.
2. Browse to the location of the library folder.

3. Select the folder and click OK.

The new library appears in the Library Folders section.

How to close a library

1. Ontheright side of the Library view, select the library folder to close.

2. Inthe Library View menu, select Folders > Close Library.

The library closes.

How to create a folder

1. Onthe left side of the Library view, select the library folder to which you want to add a subfolder.
2. Inthe Library View menu, select Edit > Right to Modify.

3. Inthe Library View menu, select Folders > New Folder.

The new folder appears in the Library. Click on the library containing the new folder and click the plus [+] sign
to expand it.

How to delete a folder

1. Inthe Library view's left side, select the folder to delete.
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2. Inthe Library View menu, select Edit > Right to Modify or right-click on the selected library and select
Right to Modify.

3. Inthe Library View menu, select Folders > Delete Folder or press Delete.

How to rename a folder

1. Inthe Library view's left side, select the folder to rename.

2. Inthe Library View menu, select Edit > Right to Modify or right-click on the selected library and select
Right to Modify.

3. Inthe Library View menu, select Folders > Rename Folder.

4. Rename the selected folder.

5. Press Enter/Return to validate the operation.

How to refresh a library

1. Inthe Library view's left side, select the folder to refresh.

2. Inthe Library View menu, select Folders > Refresh or press F5.

The library displays the new content.

How to generate thumbnails

1. Inthe Library view's right side, select the template in which you want to generate thumbnails.

Ballerina_Puppet.tpl

Flag_Animation.tpl Joetpl

~mtt!
ot

-
ot

2. Inthe Library View menu, select View > Generate Thumbnails.

The progress bar appears.

How to delete thumbnails

1. Inthe Library View menu, select Edit > Delete Thumbnails.
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All the thumbnails contained in the library are removed.

Templates

When you want to reuse artwork and animation from your project in other scenes, you must create a template from
it. A template can be seen as a portable scene or package that you can drag inside your project. You can open a
template and edit it just like any other project. If you want modify your templates, you can edit them using the Edit
Template command.

You can create a template using the Timeline view.

To delete templates from your library, use the Library view. Harmony lets you undo the action if necessary.

How to create a template from the Timeline view

1. Inthe Timeline view, select some cells or layers.

2. Inthe Library view, select a folder to store the template.

w

If a library folder is locked, right-click and select Right to Modify.

4. Drag the selection to the Stage Advanced Library folder or any other library folder.

85



Chapter 3: Library

Tool Properties

TATTWI

5. Inthe Rename dialog box, give the new template a name.

To rename a template once it is created, right-click on the symbol and select Rename.

6. Click OK.

How to delete a template

1. Inthe Library view, select the folder containing the template to delete.

NOTE: If the library folder is locked, right-click on the folder and select Right to Modify.

2. Right-click on the selection and select Delete or press Delete.

How to edit a template

1. Inthe Library view, select the folder containing the template to edit.

NOTE: If the library folder is locked, right-click on the folder and select Right to Modify.
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2. Right-click on the selection and select Edit Template.

A new Harmony application opens.
3. Edit the template.
4. From the top menu, select File > Save.

5. Inthe top menu, select File > Quit (Windows/Linux) or Stage Advanced > Quit (Mac OS X).

Symbols

A symbol combines animation, artwork or layers into a single object that you can control in one layer. You can also
create symbols out of each body part in your cut-out puppets.

You do not need to create symbols in order to create drawings or characters in Toon Boom Harmony.

When you delete a symbol, it will be deleted from your hard drive. You can use the Undo function to retrieve the data.
The symbol cannot be retrieved once you close the application.

When you import a symbol from the library to the Timeline view it is linked to the original symbol in the library. If you
import a symbol into your scene several times in the Timeline view, they will all be linked to the original symbol. If
you modify one, they will all be modified.

If you want to edit a symbol without modifying the other instances, you must duplicate the symbol first. If other
symbols are nested inside the new symbol, they are not duplicated. If you modify them, the original and other
instances will also be modified.

You can either edit a symbol from the Timeline view or from the Library view.

When you edit a symbol, the drawings contained in it are not placed at the centre of the stage, but are located in the
position where they were created. The pivot is translated at the centre of the symbol.
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When you enter a symbol to edit it, you are entering another scene with an independent timeline. You can nest
many symbols one inside the other. To help you follow the hierarchy of your nested symbol, take note of the
Editing stack at the top of the Camera view which displays the path to your symbol's location. You can click on
the symbol's name to move up the chain.

You can share a symbol and use its contents (the drawings) in another scene. To do this, you must first convert
your symbol into a template. This conversion breaks the drawing's link with both the original scene and symbol. It
then becomes a separate entity that you can import into other projects.

How to create a symbol from a drawing selection

1. Inthe Tools toolbar, select the Select w or Cutter ~ tool.

2. Inthe Camera view, select the drawing elements to create a symbol.

3. From the top menu, select Edit > Create Symbol or press F8.

» Clicking the Create Symbol ga button in the Edit toolbar will create a symbol from the entire layer.

The Create Symbol from Drawing Selection dialog box opens.
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5

&

Create Symbol from Drawing Selection

4. Inthe Symbol Name field, type the name of the symbol.

» You can also select an existing layer from the Symbol Name drop-down menu. It will add your symbol on
the layer's current cell. If there is already an exposure on that cell, the symbol will be added to a new
layer.

5. You can choose to place the current selected artwork in the drawing or remove it:

» Toremove currently selected artwork from the drawing and place it in the new symbol, select the Cut
Artwork From Source Drawing option.

» Tokeep currently selected artwork in both the drawing and in the new symbol, deselect the Cut Artwork
From Source Drawing option.

6. Click OK.

The new symbol appears in the Library view's symbol folder and in the Timeline view as a new layer.

4+ — % % Parameters

How to create a symbol from the Timeline view

1. Inthe Timeline view, select the layer or cells from which your want to create a symbol.

2. Do one of the following:

» From the top menu, select Edit > Create Symbol.
» Inthe Edit toolbar, click the Create Symbol ga button.

» Press F8.

» Drag your selection to the Symbol folder in the Library view.
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[TATIWI

_-1‘ Stage Library

IAdl !

The Create Symbol dialog box opens

3. Inthe Enter Symbol's Name field, type the new symbol's name.

To rename a symbol once it is created, right-click on the symbol and select Rename.

4. Click OK.

The new symbol appears in the Library view's Symbol folder. The current selection is not replaced by the
new symbol. The new symbol only appears in the library. You must drag it into your scene to use it.

How to create an empty symbol

1. Inthe Library view, select the Symbol folder.

2. Do one of the following:

» Inthe Library view's right side, right-click and select New Symbol.
» From the top menu, select Insert > Create Empty Symbol in Library.
The new empty symbol appears in the Library view.
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Library — ==|%
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Timeline  ==|%

The symbol is ready for you to edit (add content to). To go back to the root timeline, click the Top ¢ button
in the Camera view.

To rename a symbol once it is created, right-click on the symbol and select Rename.
How to delete a symbol

1. Inthe Library view, select the symbol to delete.

2. Right-click and select Delete or press Delete.

» If the symbol is currently in use in the scene, a warning message displays. Click OK to delete the symbol
from the library and scene.

ill also remove all references to this symbol from

How to edit a symbol from the Timeline view

1. Do one of the following:

» Inthe Timeline view, double-click on the symbol's cell to edit the symbol.
» Inthe Camera view, double-click on the symbol or press Ctrl + E (Windows/Linux) or 3§ + E (Mac OS X)).
> Click the Edit Selected Symbol g@ button in the Camera View toolbar's extra buttons.
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2. Do one of the following:

To return to the project's timeline, click the Top ¢y button in the Camera view's top-left comer, press Ctrl + Shift
+ E (Windows/Linux) or 3§ + Shift + E (Mac OS X).

» Inthe Timeline view's right side, right-click and select Symbols > Leave Current Symbol.

How to edit a symbol from the Library view

1. Inthe Library view, select the symbol to edit.

2. Right-click and select Edit > Edit Symbol or double-click on the symbol.

You are now inside the symbol and you are able to edit it.
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To return to the project's timeline, click the Top ¢y button in the Camera view's top-left comer, press Ctrl + Shift +
E (Windows/Linux) or &§ + Shift + E (Mac OS X).

How to duplicate a symbol

1. Inthe Timeline view, go to the frame where you want to duplicate the symbol.

2. Select the symbol's cell.

3. From the top menu, select Edit > Duplicate Selected Symbol.

In the Library view, the symbol is duplicated and in the Timeline view, the current cell and its held exposure is
replaced with the new symbol. You can now modify the symbol's content.

How to convert a symbol into a template

1. From the Library view, select the symbol to convert into a template and drag it to the Camera or Timeline
view. If you drop your symbol into the Camera view instead of the Timeline view, it will not be placed in the
centre of your camera frame, but rather wherever your cursor drops it within the camera frame.
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2. Inthe Timeline view, select the symbol's cells or layer and drag it to the Stage Library folder or to any other
library folder. Make sure you have the right to modify the library folder.
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3. Inthe Rename dialog box, rename the new template.
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Enter a new file name for the template.

Cancel

4. Click OK.

Importing Symbols and Templates

There are several ways you can import symbols and templates in your scene.

Sometimes a character rig is not a straightforward matter. Rigs, which are usually saved as templates, can contain
symbols such as a leg that was made with a patch. However, a symbol does not work in the same way as an action
template. In the Timeline view, you can add an action template into another template of the same structure. When
working on a layer on the right side of the Timeline view and you place a symbol into a symbol of the same structure,
instead of being added to the previous symbol, the new symbol becomes a copy.

For greater control over how the action template behaves when brought into the Timeline view, you can use the
Paste Special feature—see Using Paste Special on page 99.

Since a template is like a scene, you can open the template's folder and select elements inside it such as drawings.

Instead of importing the entire contents of a template, you may only want to import a few drawings or a palette. In
this case, use the Open As Folder command to import the items you want.

If you want to import a palette, simply drag the palette file into the Palette list section of the Colour view.

You can use the Expand Symbol command to extract a symbol's contents and place it on the root timeline. The
symbol will not be removed from the Timeline view. Its contents will be copied and inserted into the root timeline.
The symbol's layers will be parented to it in case you created motions and transformations on the drawing layer that
contains the symbol. Breaking the hierarchy could result in the loss of any scaling and animation you may have
created.

You can also expand a symbol within a group to avoid crowding the timeline with a series of layers. When you
expand the symbols, the layers will be contained in a group node that you can expand to see the content.

How to import a template into the Timeline or Camera view

1. Inthe Library view, select the template you want to import.

2. Drag the selected template to the Camera view or to the left side of the Timeline view.
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3. You can also drag a template to the right side of the Timeline view and into existing layers if the layer struc-
ture is the same as the existing one.

How to import a symbol in the Timeline view

1. Inthe Library view, select the symbol you want to import.

2. Drag the selected symbol to one of the following:

» The Timeline view's left side to import it into the centre of the camera frame.
» The Camera view to place it at the location where you release your cursor.

96



Harmony 12.2 Advanced - Compositing and Effects Guide

NOTE: This may be useful if you saved a character's body parts as separate symbols. If you dropped them into the
Timeline view, then they would all appear in the centre, haphazardly one on top of the other. It would be more
efficient to arrange them into their correct places as you bring them into the scene.

How to import a template with symbols

1. From the right side of the Library view, select the action template that contains symbols.

2. Hold down Alt (Windows/Linux) or 3£ (Mac OS X) as you drag it from the Library view to the right side of the
Timeline view and drop it next to a template with the exact same rig.

The Paste Special window opens.

3. Select the Advanced tab.

4. Select one of the following options from the Symbols menu:

Options

Palettes:

» Copy symbols if they do not exist: This is the default setting for this operation and will prevent symbols
in an action template from being copied.

» Duplicate symbols: Makes copies of the symbols in your template.

How to open a template as a folder

1. Inthe Library view, select the folder that contains the template to open. If the library folder is locked, right-
click on the folder and select Right to Modify.

2. Right-click on the selection and select Open As Folder.

3. Inthelibrary list section, click on the template's folder to display its content.

97



Chapter 3: Library

TATTW]

Il

4. Dragthe content to the Timeline or Colour view.
How to expand a symbol

1. Inthe Timeline view, select the symbol to expand.

How to expand a symbol in a group

1. Inthe Timeline or Node view, select the symbol cell or symbol node you want to expand.

2. From the top menu, select Edit > Expand Selected Symbolin a Group.

3. Inthe Timeline view, click the plus sign (+) to see the group content. In the Node view, click the Expand
Arrow to enter the group.
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Importing Files Through the Library

Harmony lets you import sound files and images directly through the library. Simply open the folder containing your
files in the Library view and drag them directly from there.

How to open a file through the Library

1. Inthe Library View menu, select Folders > Open Library.
2. Browse for the folder containing the files you want to import.
3. Click Open.

4. From the Library's template list, drag the file you want to import in the Timeline or Camera view.

Using Paste Special

When you import a template in the Timeline view, all layers are created as well as drawings and keyframes. You can
choose to import only the keyframes without the drawings or import only the drawings that are not already in your
layers. You can adjust the behaviour using the Paste Special dialog box.When you import a symbol in your scene,
its full length is exposed by default. If you import a symbol in the Timeline view’s left side, all the frames will be
exposed. However, if you import it into an existing layer, you can use the Paste Special dialog box to adjust the
import behaviour to fit your requirements.Once you set the parameters, Harmony will reuse them each time you
import a symbol in the Timeline view’s right side until you set new parameters.

How to open the Paste Special dialog box

1. Inthe Library view, select the symbol or template to import.

2. Press Ctrl + B (Windows/Linux) or 3£ + B (Mac OS X) and drag the selection to the Timeline view.
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NOTE: Drop the selection in the Timeline view before releasing the keyboard shortcut key.

The Paste Special dialog box opens.

3. Set the parameters and click OK.

Basic Tab

Parameter

Description

Drawings

Only create drawing
files when they do not
exist

When adding exposures to a drawing layer, new drawings will be created only
when drawings with the same name do not already exist in the destination.

Always create drawing
files

When adding exposures to a drawing layer, new drawings will always be cre-
ated. If drawing files with the same name already exist, Harmony will create a
new name for the drawing.

Paste all Frames of the
Symbols (full movie)

When enabled, the Paste Special command exposes all the symbol's frames
instead of only the first one.

Enforce Key Drawings

Creates a key exposure on the same drawing.

Cycle

Number of Cycles

Lets you set the number of cycles.

Cycle Type

Normal (forward): Pastes your selection as is, starting with the first cell and
ending with the last.

Reverse: Pastes your selection in reverse, starting with the last cell and
ending with the first.

Forward > Reverse: Pastes your selection as a yo-yo, starting with the first
cell, going to the last one and ending with the first cell.

Reverse > Forward: Pastes your selection as a reverse yo-yo, starting with
the last cell, going to the first one and ending with the last cell.
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Advanced Tab

Parameter Description
Drawings
Do Nothing Does not create or overwrite drawings.
Revises the drawing pivot in the destination to use the same drawing pivot as the
Update Drawing Pivot | first drawing in the template. If you have a range of drawings selected in the

destination, the pivot points of all selected drawings will be updated.

Add/Remove Exposure

Never create drawing files: When adding exposures to a drawing layer, drawing
files will not be created.

Only create drawing files when they do not exist: When adding exposures to a
drawing layer, new drawings will be created only when drawings with the same
name do not already exist in the destination.

Replace existing drawings. Create drawing files when they do not exist:
Replace drawings with the same names to update a scene with new modified
drawings and preserve the animation.

Tip: If you don't want to lose the existing animation when pasting a
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template, such as when placing new drawings after the animation,
then delete the template's animation. It will still have updated the
drawings but not override the existing animation.

Always create drawing files: When adding exposures to a drawing layer, new
drawings will always be created. If drawing files with the same name already
exist, Harmony will create a new name for the drawing.

Paste all frames of the symbol (full movie): When enabled, the Paste Special
command exposes all the symbol's frames instead of only the first one.

Enforce Key Exposure: If there are key exposures that exist on copied draw-
ings, they are preserved when pasting. No key exposures are added. This is the
default behavior when pasting.

Fill Gap with Previous Drawing: Fills selected area in the Xsheet or Timeline
view with the previous drawing.

Fill to Next Key Exposure: Fills selected area till the next key exposure.

Add Remove/Keyframes

Motion Copies the properties of the selected motion keyframe to the new frame.
Velocity Copies the properties of the selected velocity keyframe to the new frame.
Rotation Copies the properties of the selected rotation keyframe to the new frame.
Scale Copies the properties of the selected scale keyframe to the new frame.
Skew Copies the properties of the selected skew keyframe to the new frame.

Force Keyframes at
Function's Beginning
and End

Adds a keyframe to the beginning and end of the pasted function, reproducing the
source function.

Offset Keyframes

When pasting functions, offsets keyframes from the function's last frame value
by the values in the pasted function. This will continue the progression of a func-
tion instead of repeating the values.

Options
Do nothing: Does not create, overwrite, merge or link palettes.
Reuse palettes. Copy palettes if they do not exist: Palettes in the destination
drawings are left as they are.
Copy and overwrite existing palettes: Overwrites destination palettes with the
palettes from the source drawings.
Copy and create new palette files: Creates new palette files, placing them at

Palettes the same relative environment and scene level as the source. If the palettes in the

templates were stored at the environment level of the source scene, the paste
operation will place the palettes in the environment level of the destination scene.

Copy and create new palette files in element folder: Creates new palette files
in the element folders of the destination scene, rather than in the same relative job
or environment.

Copy palette and merge colours. Add new colours only: Adds new colours to
the destination palettes and ignores colours that are the same in the two palettes.
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Copy palettes and update existing colours: Adds new colours to the
destination palette and updates duplicate colours in the destination with colour
values from the source.

Link to original palettes (colour model): Links the colour palettes in the
destination scene to the palettes in the source. Use this to link drawings to the
palettes in a colour model.

Copy scene palettes and merge colours. Add new colours only: Adds new
colours to the destination scene palettes and ignores colours that are the same in
the two palettes.

Copy scene palettes and update existing colours: Adds new colours to the
destination scene palette and updates duplicate colours in the destination with the
colour values from the source.

Symbols

Copy symbols if they do not exist: This is the default setting for this operation
and will prevent Symbols in an Action template from being copied.

Duplicate symbols: Creates a duplicate of the symbol instead of linking the Sym-
bol instance to the original one. The new Symbol is created in the Library.

Cycles

Normal (forward):Pastes your selection as is, starting with the first cell and end-
ing with the last.

Reverse: Pastes your selection in reverse, starting with the last cell and ending
with the first.

Forward > Reverse:Pastes your selection as a yo-yo, starting with the first cell,
going to the last one and ending with the first cell.

Reverse > Forward: Pastes your selection as a reverse yo-yo, starting with the
last cell, going to the first one and ending with the last cell.

Nodes

Create New Columns: A new column is created when you copy and paste
nodes from the layer in the Timeline view. If the layers are linked to function
curves, the function curves, drawings and timing will be duplicated.

Elements

Reuse existing elements: Lets you paste existing elements without creating
new ones. This should be used only when pasting within versions of the same
scene.
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Chapter 4: Scene Setup

Setting up your scene can be compared to building a set for a television show. This is the point when you position
each scene element such as the camera frame, the background elements and the characters.

This chapter contains the following topics:

» Importing the Scene Elements on page 105

+ Setting the Camera Frame on page 105

» Positioning the Scene Elements on page 109

* Cloning and Duplicating Layers on page 140

»  Working with Groups on page 142

* Display Concepts on page 142

» Timeline View Modes on page 143

» Creating a Multiplane on page 145

Importing the Scene Elements

The first step in the scene setup task is gathering the scene’s different components and then importing them into
your project. You might need to import some backgrounds, sound files or movie clips to complete your scene. You
can refer to the following topics to learn how to bring those elements in.

» Importing Bitmap Images on page 8

* Importing Quick Time Movies on page 60

» Importing a Sound File on page 207

Setting the Camera Frame

The scene action occurs inside the camera frame, so it’s really important to set it up correctly. You can adjust the
camera resolution and other parameters in the Scene Settings window. Refer to the Fundamentals Guide, Starting
Harmony chapter to learn more.

The Camera layer is static which means that if you need to animate it, you must add a peg.

105



Chapter 4: Scene Setup

You need to add a camera layer to your scene, so you can edit the camera frame. You can only see one camera at
atime. If you add several cameras to your scene, you can use the Camera list to select the active one. You could
use this feature if you are still working on your scene composition and have different camera framing to try out.

You can reposition your camera frame directly in the Camera view, using the advanced animation tools. Another
way to set up your camera frame is to type the coordinates directly in the camera's properties. Doing this
positions the camera precisely where you want it to be rather than gauging it visually.

You can easily reset the camera to its original position. Using the Reset command, you can reset the value of the
selected element to the initial value of the active tool. For example, if the Rotate v tool is active, the

transformation angle will be reset to 0 and if the Transform ;-3 tool is active, then all parameters values will be
reset.

How to add a camera in the Timeline view

1. Do one of the following:

» Inthe Timeline view, click the Add Layer button and select Camera.

» From the top menu, select Insert > Camera.
A new camera layer is added to the scene and appears in the Timeline view.

NOTE: You cannot add a camera inside a symbol.

How to select a camera from the Camera list (set the active camera)

1. From the top menu, select Scene > Camera > the desired camera.

If you only add one camera to your scene, you will only see Default Camerain your list.

How to reposition the camera frame directly in the Camera view

1. Inthe Tools toolbar, disable the Animate mode.

2. Do one of the following:

» From the top menu, select Animation > Tools > Translate.
» Inthe Advanced Animation toolbar, click the Translate «I» tool.

» Press Alt + 2.

3. Inthe Camera view, click on the camera frame (thin rectangle) to select it. You can also select the camera
layer from the Timeline view.

The selected camera frame is highlighted.
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4. Drag the camera frame to a new position.

5. Totilt the camera frame, do one of the following to select the Rotate tool:

» From the top menu, select Animation > Tools > Rotate.
> Inthe Advanced Animation toolbar, select the Rotate @ tool.
» Pres Alt + 3.

6. Inthe Camera view, drag to rotate the camera frame until it reaches the desired rotation angle.
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How to set up the camera frame using the Layer Properties view

1. Inthe Timeline view, select the camera layer.

2. Inthe Layer Properties view, adjust the camera's properties.

Parameter

Description

Enable/Disable

Turns the camera layer on or off.

Change Track Colour

The Change Track Colour |:| button lets you change the colour of the
exposed frames; this helps you to quickly locate a layer in the Timeline view.
Click the Change Track Colour |:| button to open the Select Colour window
and choose a new colour. You can modify the colour for any type of layer, such
as group, peg, drawing, and effects.

Displays the current layer name. You can rename the layer by typing in a new

Name
layer name.
Displays the current position of the camera layer using X-axis (East/West), Y-
axis (North/South) and Z-axis (Forward/Backward) coordinates. To reposition
Position your camera frame, type in the new values corresponding to the desired pos-

ition coordinates. You can also use the up and down arrows to set the value of
each field—see Positioning an Element Using the Layer Properties View on

108




Harmony 12.2 Advanced - Compositing and Effects Guide

page 125.

Displays the current rotation value. To set a hew rotation position, type ina
Angle new angle value. You can also use the up and down arrows to set the new
angle value.

Displays the current position of the rotation pivot of the camera layer. The cam-
era will perform a rotation taking the position of the pivot as its angle centre. By
default, the pivot is set at the centre of the camera frame. To reposition the
Pivot pivot point, type in new X and Y coordinates values in the appropriate field. You
can also use the up and down arrows to set the position values.

In order to see the pivot's position you will need to have the Rotate tool selec-
ted.

How to reset the camera position

1. Inthe Tools toolbar, select the Transform ;i tool or press Shift + T.

2. Inthe Timeline or Camera view, select the camera layer.

3. From the top menu, select Animation > Reset or press Shift + R.

The camera automatically returns to its original position.

Positioning the Scene Elements

-

Setting up the scene also involves positioning the different scene elements within the camera frame.
Here are the main features and topics you need to know about to position your elements:
* Animate Mode on page 110

» Selecting a Layer on page 110

» Positioning an Element Using the Transform Tool on page 114

» Positioning an Element Using the Advanced Animation Tools on page 122

» Positioning an Element Using the Layer Properties View on page 125

» Drawing Layer Properties Reference on page 128
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» Setting Properties for Many Layers on page 137

* Auto Apply Option on page 138

* Resetting a Transformation on page 139

Animate Mode

When positioning elements, make sure the Animate Mode is turned off, or it will create a keyframe on your
drawing layer. The animate mode is used to animate layers over time.

Animate mode is on. Animate mode is off.
(Pushed in)

How to turn off the Animate mode

» Inthe Tools toolbar, click the Animate Mode button. Make sure the button is depressed.

» Inthe top menu, disable Animation > Animate.

Selecting a Layer

There are different ways to select the layers you want to reposition.

You can select your elements directly in the Camera view using the Transform tool. When using this tool, its
properties and options appear in the Tool Properties view. Always make sure that the Peg Selection Mode option
in the Tool Properties view is disabled or it will limit the selection to pegs only.

When you have several layers in the Timeline view, you may find it hard to locate which one is selected. You can
use the Centre on Selection feature to display the selected layer in the Timeline view.

You can change the display style of selected elements to a bounding box style. This removes the default overlay
highlight and leaves only the bounding box around the selected element.

How to select a layer in the Camera view
1. Inthe Tools toolbar, select the Transform ;-3 tool or press Shift + T.
1. Inthe Tool Properties view, make sure that the Peg Selection Mode - is deselected.

2. Inthe Camera view, click on the element to be repositioned. You can select more than one element at a
time. Hold down Shift while clicking on the elements to be selected.

The corresponding layers and columns are highlighted in the Timeline and Xsheet views.

110



Harmony 12.2 Advanced - Compositing and Effects Guide

How to set the bounding box selection style

1. Inthe Camera view bottom toolbar, click the BBox Selection Style button.

How to center on the selected layer in the Timeline view

1. Inthe Camera view, select a layer.

2. Do one of the following:

» From the Timeline view menu, select View > Centre on Selection or press O.

» Inthe Timeline view toolbar, click the Centre on Selection Q button.

How to select from the Timeline or Xsheet view

» Inthe Timeline view, click the layer corresponding to the element you want to reposition.
» Inthe Xsheet view, click the column header corresponding to the element you want to reposition.
The selected element is highlighted in the Camera view.

How to select all elements within a group in the Timeline view

1. With a group collapsed or expanded, hold down Alt and click on the group in the Timeline view.
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Locking Layers in the Timeline View

You can prevent correctly positioned layers from being selected in the Camera view by locking them in the Timeline
view. This is useful for making a multiple selection inside the Camera view while avoiding to select them. Once a
layer has been locked, its locked state will be remembered the next time you open a saved project.

You can perform five types of locking actions on your layers:
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» TheLock option lets you lock one or a multiple selection of layers.

* The Unlock button lets you unlock one or a multiple selection of locked layers.
» ThelLock All 4, option lets you lock all the layers in the Timeline view.

* TheUnlock All =, button lets you unlock all the layers in the Timeline view.

» The Lock All Others button lets you lock every layer except the selected ones.

How to lock a layer or a selection of layers

1. Inthe Timeline view, select one or more layers.
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2. Do one of the following:
» From the top menu, select Animation > Lock > Lock.
» Click one of the selected layer's Lock E icon.

» Press Ctrl + Alt + L (Windows/Linux) or 3§ + Alt + L (Mac OS X).
All selected layers are locked.
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How to unlock a locked layer or a selection of locked layers

1. Inthe Timeline view, select one or more locked layers.

8888888 83§&
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2. Do one of the following:
» From the top menu, select Animation > Lock > Unlock.
» Click a selected layer’s Lock icon.

» Press Ctrl + Shift + K (Windows/Linux) or 3£ + Shift + K (Mac OS X).
All selected layers are unlocked.
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How to lock all layers

1. Do one of the following:
» From the top menu, select Animation > Lock > Lock All.
» Inthe Timeline view, select all layers and click Lock E icon of a selected layer.
» Press Ctrl + Shift + L (Windows/Linux) or 3 + Shift + L (Mac OS X).
All layers are locked.
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How to unlock all layers

1. Do one of the following:

» From the top menu, select Animation > Lock > Unlock All.

» Inthe Timeline view, select all layers (locked) and click Lock 1 icon of a selected layer.
» Press Ctrl + Alt + Shift + L (Windows/Linux) or 3£ + Alt + Shift + L (Mac OS X).

All layers are unlocked.
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How to lock all other layers

1. Inthe Timeline view, select the layers you do not want to lock.
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2. Do one of the following:

» From the top menu, select Animation > Lock > Lock All Others.
» Press Ctrl + Alt + Shift + O (Windows/Linux) or 3£ + Alt + Shift + O (Mac OS X).

All layers are locked except the selected ones.
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Positioning an Element Using the Transform Tool

Using the Transform tool, you can easily reposition, scale, rotate and even skew layers directly in the Camera
view.

When positioning a drawing layer using the Transform tool, always make sure the Peg Selection Mode  is
deselected in the Tool Properties view. Otherwise, it will limit the selection to pegs in the Camera view.
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Transformation | Drawing

©

Rotation Rotation

The Rotation tool only affects the Rotation and Pivot

The Transform tool can affect the Position, Scale, Rotation,
parameters.

and Skew parameters, but not the Pivot parameter.

There are two different options you can use when you want to flip your element.

The Flip Horizontal and Flip Vertical options let you flip a drawing layer along the Camera view’s horizontal and
vertical axis.

Once your drawing layer is rotated, the original horizontal and vertical axes change. The Flip Scale X and Flip Scale
Y will perform a flip on your drawing layer following its original axis.

» The Flip Horizontal command flips the layer following the Camera view X-axis.

* The Flip Scale X command uses the original X-axis of the layer and flips the element following it.

The Flip Horizontal command flips your drawing based on its position
in the Camera view and its pivot.

—

Flip Horizontal

—

Flip Scale X

The Flip Scale X command remembers the original X-axis of
the layer and flips the element following it.
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Transformations, such as rotation, scale, skew and flip are made relative to the pivot point position. You can
temporarily reposition the pivot point for each transformation using the Transform tool. Note that the pivot is only
moved temporarily. When animating the position, the interpolation is calculated from the permanent pivot
position—see Positioning an Element Using the Advanced Animation Tools on page 122.

How to temporarily reposition the pivot point

1. Inthe Tools toolbar, select the Transform i-: tool.
2. Inthe Tool Properties view, make sure the Peg Selection Mode ;. is disabled.

3. Inthe Camera view, select your element.

The pivot point appears at the center of the scene space (coordinates 0, 0, 0), unless previously
repositioned.

4. Click on the pivot point and drag it to a new position.

This will be the new position of the pivot point for the current transformation. It will remain in this position
as long as you do not deselect the drawing. Using the Transform tool to reposition your pivot will
temporarily override the existing pivot point position until you complete the current transformation. Then it
returns automatically to its original position.

When you translate the pivot point using the Transform tool, the permanent pivot will appear as a ghost so
you know where it is and also from where the animation will be interpolated when you create motion paths.
The animation is always interpolated from the original pivot and not the temporary pivot.

How to pan a layer using the Transform tool

1. Inthe Tools toolbar, disable the Animate mode.
2. Inthe Tools toolbar, select the Transform -: tool or press Shift + T.

3. Inthe Tool Properties view, make sure the Peg Selection Mode . is deselected.
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4. Inthe Camera view, select a drawing layer and drag the selection to a new area. You can select multiple lay-
ers to reposition them at the same time. Hold down Shift and select the different layers.

How to rotate a layer using the Transform tool

1. Inthe Tools toolbar, disable the Animate -2 mode.
2. Inthe Tools toolbar, select the Transform ;-3 tool or press Shift + T.
3. Inthe Tool Properties view, make sure the Peg Selection Mode - is deselected.

4. Inthe Camera view, select a drawing layer.

5. Place the pointer outside of a corner of the bounding box and drag to rotate.

NOTE:

You can display a rotation handle on the bounding box when transforming a layer. In the Preferences dialog box,
select the Camera tab and then select the Use Rotation Lever with Transformation Tools option. This preference is
off by default.
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Rotation handle

How to scale a layer using the Transform tool

1. Inthe Tools toolbar, disable the Animate mode.
2. Inthe Tools toolbar, select the Transform -1 tool or press Shift + T.

3. Inthe Tool Properties view, make sure the Peg Selection Mode /; is deselected.

4. Inthe Camera view, select a drawing layer and push or pull on the size, top, or corner control point. Hold
down Shift to lock the selection's aspect ratio.

3

How to skew a layer using the Transform tool

1. Inthe Tools toolbar, disable the Animate mode.

2. Inthe Tools toolbar, select the Transform ;i tool or press Shift + T.

3. Inthe Tool Properties view, make sure the Peg Selection Mode / is deselected.
4. Inthe Camera view, select a drawing layer.

5. Place the pointer between two controls points and drag sideways or up and down.
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Original drawing Cursor placed between Cursor placed between
control points and control points and
dragged upwards dragged sideways

How to flip a layer

1. Inthe Tools toolbar, disable the Animate mode.
2. Inthe Tools toolbar, select the Transform ;-3 tool or press Shift + T.

- is deselected.

3. Inthe Tool Properties view, make sure the Peg Selection Mode ¢

4. Inthe Camera view, use the Transform i-: tool to select a drawing layer to flip.

5. Do one of the following:

» From the top menu, select Animation > Flip > Flip Horizontal or Flip Vertical.
» Inthe Tool Properties view, click the Flip Horizontal s; andthe Flip Vertical + buttons.

"

» Press4orb.

How to flip an element following its original axis

1. Inthe Tools toolbar, disable the Animate mode.
2. Inthe Tool Properties view, make sure the Peg Selection Mode - is deselected.
3. Inthe Camera view, use the Transform ;-3 tool to select an element that has already been transformed.

4. From the top menu, select Animation > Flip > Flip Scale X or Flip Scale Y.
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Transform Tool Properties

Icon Tool Name
Lasso and Marguee on page 120
%
~ Peg Selection Mode on page 121
i _
Snap Options on page 121
<)\
%] Hide Manipulator Controls on page 121
512
P Flip Horizontal and Flip Vertical on page 121
Rotate 90 Degrees CW and CCW on page 121
Width and Height on page 121
Offset X and Y on page 122
@ Angle on page 122

Lasso and Marquee

The Lasso and Marquee options let you choose the type of selection the current tool will perform. The default
selection mode is Marquee.

* Lasso () lets you draw a custom selection box around zones.

* Marquee [,/ makes a rectangle selection box.

NOTE:
Hold down the Alt key to switch to toggle between the selection modes.
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Peg Selection Mode

In the Camera view, the Peg Selection Mode ,; limits the selection to peg layers instead of drawing layers. This
mode is useful when you have created a character rig using peg layers for each drawing. That way, you do not
accidentally select the drawing layer when you want to animate on the peg.

When disabled, the Transform tool selects the drawing layers.

Snap Options

When transforming or repositioning a layer using the Transform tool, you can enable different snap options to help
you.

* = Snap and Align: Snaps the selected layer to any existing object, while automatically displaying
temporary rulers that guide you and that you can also snap your object to.

* — Snap to Grid: Snaps your selection according to the currently enabled grid.

Hide Manipulator Controls

The Hide Manipulator Controls ¢ button lets you hide the bounding box and manipulator controls from the Camera
view when an element is selected.

Flip Horizontal and Flip Vertical

The Flip Horizontal 52 and Flip Vertical -~ buttons let you flip the selected element horizontally or vertically. You
can also select Animation > Flip > Flip Horizontal and Flip Vertical from the top menu or press 4 or 5.

Rotate 90 Degrees CW and CCW

™

The Rotate 90 Degrees CW and Rotate 90 Degrees CCW operations rotate the current selection 90
degrees clockwise or counter-clockwise.

Width and Height

The Width and Height fields allow you to enter specific values for accurately resizing a selected layer.

» Width: Enter a width value in this field to resize the width of your selection.

121



Chapter 4: Scene Setup

* Height: Enter a height value in this field to resize the height of your selection.

* Lock: Click the Lock icon to lock or unlock the ratio between the width and height values.

Offset Xand Y

Use the Offset X < and Offset Y fields to enter specific values to reposition the selected layer accurately.

» X: Enter an offset value in this field to reposition the selected layer along the X-axis.
» Y: Enter an offset value in this field to reposition the selected layer along the Y-axis.
Angle

The Angle @ field lets you enter specific values to rotate the selected layer accurately. A positive value rotates
the layer counterclockwise and a negative value rotates the layer clockwise.

* Angle: Enter a degree value in this field to rotate the selected layer.

Positioning an Element Using the Advanced Animation Tools

You can also use the advanced animation tools to position your layers. The difference between these tools and
the Transform tool is that they modify only one parameter of the position such as the rotation or the scale as the
Transform tool adjusts all parameters together.

Transformation | Drawing

Transformation | Drawing

©

The Ratation tool only affects the Rotation and Pivat

The Transform tool can affect the Position, Scale, Rotation,
parameters.

and Skew parameters, but not the Pivot parameter.
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Transformations, such as rotation, scale, skew and flip, are made relative to the pivot point position. You can
reposition this pivot point anywhere using the advanced animation tools.

How to permanently reposition the pivot point

1. Inthe Advanced Animation toolbar, select the Translate ., Rotate @, Scale 1, orSkew ;7 tool.

2. Inthe Camera view, Ctrl + click (Windows/Linux) or &£ + click (Mac OS X) to select your element.

The pivot point appears in the Camera view.

Pivot point

3. Drag the pivot point to a new position.

All transformations, including existing ones will be recalculated from this new pivot postion.

How to pan a layer using the Translate tool

1. Inthe Tools toolbar, disable the Animate mode.

2. Do one of the following:

» From the top menu, select Animation > Tools > Translate.
» Inthe Advanced Animation toolbar, click the Translate s tool.

» Press Alt+ 2.
3. Inthe Camera view, Ctrl + click (Windows/Linux) or 3 + click (Mac OS X) to select your element.

4. Drag the selection to a new area.
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» You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) or &£ +
Shift + click (Mac OS X) on each element to select them.

How to rotate a layer using the Rotate tool

1. Inthe Tools toolbar, disable the Animate mode.

2. Do one of the following:

» From the top menu, select Animation > Tools > Rotate.
» Inthe Advanced Animation toolbar, click the Rotate @ tool.

» PresstheAlt + 3.
3. Inthe Camera view, Ctrl + click (Windows/Linux) or &£ + click (Mac OS X) to select your element.

4. Rotate the layer.

» You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) or 3£ +
Shift + click (Mac OS X) on each element to select them.

How to scale a layer using the Scale tool

1. Inthe Tools toolbar, disable the Animate mode.

2. Do one of the following:

» From the top menu, select Animation > Tools > Scale.
» Inthe Advanced Animation toolbar, click the Scale 7 tool.

» Press Alt +4.
1. Inthe Camera view, Ctrl + click (Windows/Linux) or 3£ + click (Mac OS X) to select your element.

3. Pull or push either on the side, top or corner control point. Hold down Shift to lock the selection’s ratio
when using the corner control points.
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» You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) or &8 + Shift +
click (Mac OS X) on each element to select them.

How to scale a layer using the Skew tool

1. Inthe Tools toolbar, disable the Animate mode.

2. Do one of the following:
» Select Animation > Tools > Skew.
» Inthe Advanced Animation toolbar, click the Skew ;7 tool.
» Press Alt+5.

3. Inthe Camera view, Ctrl + click (Windows/Linux) or 3 + click (Mac OS X) on the element to select it and
drag a side of the bounding box up, down or sideways.

;/r:f A

>

» You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) or 3£ + Shift +
click (Mac OS X) on each element to select them.

Positioning an Element Using the Layer Properties View

Each layer has a series of parameters that you can modify to adjust an element's position. You can access these
parameters in the Layer Properties view. In this view, you can type in a value instead of moving the object in the
Camera view. These values can also be animated over time. See Drawing Layer Properties Reference on page 128
for additional details.

You can also access a layer's parameters in the Timeline view. Click on the Expand Parameters button.
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Expands parameters

Parameters Values

It is important to understand the coordinate values in Harmony. Harmony's core is based on the origins of
animation. In traditional animation, a scene's size and camera motion are calculated in fields. A field has a 4:3
ratio and measures 0.5 inches (12.7 mm) in width. A specific grid has been created for this purpose known as a
field chart. Harmony uses this unit of measurement as its coordinate system.

A field chart uses the cardinal directions. The X axis is the east-west (left-right) direction, the Y axis is the north-
south (up-down) direction and the Z axis is the forward-backward direction.

In Harmony, a drawing's pivot is located at the centre of the field chart, regardless where your drawing has been
drawn on the page. Your drawing is the entire sheet of paper, not only the drawing strokes you have drawn on the
page. This allows scanned drawings, imported images and paperless drawings to be properly registered together.

If you want to move your drawing in the upper-left region of the camera frame, you would type in something like
the following:

*  XAxis: 4 or4W (4 West)
* Y Axis: 50r 5N (5 North)

If you want to move your drawing in the lower-right region of the camera frame, you would type in something like
the following:

» X Axis: 3or3E (3 East)
* Y Axis: -2 or 2S (2 South)

How to display layer parameters

1. Do one of the following:
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» Inthe Layer Properties view is not part of your workspace, from the top menu, select Windows > Layer
Properties. In the Timeline view, select a layer

» Inthe Timeline view, double-click on a layer.
» Press Shift + E.
The properties display.

Rotation

How to position an element

1. Inthe Timeline view, select a layer.

2. Inthe Position section, select one of the following options:

» Separate to independently edit the different coordinate fields. Continue to step 3.

» 3D Path to use a 3D path function when animating your element. Continue to step 4.

3. Inthe (x), (y) and (z) Axis fields, type in a new coordinates corresponding to the desired position—see Creat-
ing a Multiplane on page 145.
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As you type in values, the element’s position is updated in the Camera view.
Usethe Function = buttons to create function curves and add keyframes to animate the parameter.
In the Scale section, select one of the following options:

» Locked to resizes the element uniformly in three directions.
» Separate to resize the element in any direction without affecting the others.

In the (x) and (y) Axis fields, type in a new coordinates corresponding to the desired position

Use the Function = buttons to create function curves and add keyframes to animate the parameter.

In the Rotation section, Angle z field, type in a degree value for the rotation angle. Note that you can enter
values greater than 360 and -360 degrees. If you enter 720, the object will rotate twice.

In the Skew field, type in a degree value between -90 to 90 for the skew angle.

In the Pivot section, type in the desired coordinate value to reposition the transformation pivot. This will
change the permanent position of the pivot.

For detailed information on the Layer Properties parameters, see Drawing Layer Properties Reference on page

128.

Drawing Layer Properties Reference

The drawing layer's properties is composed of the following tabs:

Transformation Tab on page 128

Drawing Tab on page 131
Controls Tabon page 133

Advanced Tab on page 134

Transformation Tab

The Transformation tab contains parameters for adjusting the position, scale, rotation, skew and pivots of an
element.
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Parameter

Description

Position

3D Path: Lets you use a 3D path function to animate an element.
Separate: Lets you independently edit the different coordinate fields.

Path (x) Axis: Lets you type in a new East/West coordinate corresponding to the
desired position.

Path (y) Axis: Lets you type in a new North/South coordinate corresponding to
the desired position.

Path (z) Axis: Lets you ype in a new Forward/Backward coordinate
corresponding to the desired position.

Velocity: When the 3D Path option is selected, lets you set the speed at which

Scale

Locked: Resizes the element while keeping its ratio. The X and Y axes scale
proportionally

Separate: Resizes the element allowing to modify the ratio (squash and stretch).
(x) Axis: Lets you type in the horizontal scale value.
(y) Axis: Lets you type in the vertical scale value.

Scale in Fields: Instead of using the standard scaling units, when this option is
enabled, images are scaled using field units, based on the traditional animation
field chart.
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Ignore Parent Scaling: When this option is enabled, any scaling value applied to
a parent layer is ignored in the current layer. This can be handy in cut-out rigs
when you need to scale an arm without affecting the forearm.

Angle z: Lets you type in a degree value for the rotation angle. Note that you can

Rotation enter values greater than 360 and -360 degrees. If you enter 720, the object will
rotate twice.

Skew Skew: Lets you type in a degree value between -90 to 90 for the skew angle.
(x) Axis: Lets you type in a new East/West coordinate corresponding to the
desired position.

Pivot

(y) Axis: Lets you ype in a new North/South coordinate corresponding to the
desired position.

Drawing Pivot

Use Embedded Pivots:
Harmony has three types of pivots:

* Permanent Pivot
This is a permanent pivot, sometime referred to as peg pivot, that is
applied to the entire drawing or peg layer. If you modify its position, it will
be changed for the entire layer, modifying the animation, scale and rotation
interpolation. The permanent pivot is set using the Rotate, Translate or
Scale tool. The Transform tool will only move that pivot temporarily for
positioning purposes, but the animation interpolation will be done from the
original permanent pivot's position. The Transform tool is designed to
move the pivot temporarily during the animation process. It also permits
you to select multiple pegs and apply a common temporary pivot.

To permanently move a peg pivot, use the Rotate or Scale tool. You can
also directly type the values in the Layer Properties window in the Pivot
section's (x) Axis and (y) Axis fields.

In the Layer Properties window, in the Drawing Pivot section, select the
Don't Use Embedded Pivot option to use the permanent pivot.

* Drawing Pivot
The Drawing pivot is contained within each drawing. In one layer, each
drawing can have its own pivot. If you have many different views of a
character within one layer, the pivot can be different and the animation will
adjust to the pivot. The Drawing pivot can also be referred to as embedded
pivot. If you are not mixing different views within the same layers or are
using pegs to animate your layers, it is recommended to use the
permanent pivot.

130




Harmony 12.2 Advanced - Compositing and Effects Guide

You can set a different pivot for each one of your drawings. For example, if
you have a series of drawings from different views, they are not likely to
rotate from the same location. In that case, you can set a different pivot for
these drawings by using the Drawing Pivot ¢ tool.

In the Layer Properties window, in the Drawing Pivot section, select the
Apply Embedded Pivot on Drawing Layer option to use the drawing
pivot directly on the drawing layer. If you want to apply the drawing pivot to
a parent peg to force the peg to follow the drawing pivot variations, enable
the Apply Embedded Pivot on Parent Peg option.

+ Symbol Pivot
The Symbol pivot is similar to the Drawing pivot. Each symbol cell can
have its own pivot and act the same as the Drawing pivot. The Symbol
pivot can also be referred to as embedded pivot. Inside a symbol, each
drawing can have its own pivot. If you are not mixing different views within
the same layers or are using pegs to animate your layers, it is
recommended to use the Peg pivot.

For a simple character rig, it is recommended to set the Peg pivot (even on
drawing layers) using the Rotate (& tool.

Drawing Tab

The Drawing tab contains parameters for the element columns, designating art layers, and setting bitmap options.
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n | Drawing | Controls

Art Layers

tmap File Options

Advanced

Parameter

Description

Art Layers

Overlay Art Enabled: Enables the Overlay Art display.

Line Art Enabled: Enables the Line Art display.

Colour Art Enabled: Enables the Colour Art display.

Underlay Art Enabled: Enables the Underlay Art display.

Overlay Art Type: Allows you to set the Overlay Art as Vector or Bitmap type.
Line Art Type: Allows you to set the Line Art as Vector or Bitmap type.
Colour Art Type: Allows you to set the Colour Art as Vector or Bitmap type.

Underlay Art Type: Allows you to set the Underlay Art as Vector or Bitmap
type.

Bitmap File Options

When an image is created with an external software and that image has some
transparency, there are several formats the software can use when writing the
RBG channels. The purpose of the four import options for the transparency is
for the user to tell Harmony how to interpret the RGB channels of the imported
image. The correct option has to match the ouput format of the software that
was used to create the image in the first place. For instance, if the you used
Adobe Photoshop and exported an image as Straight, then it should be
imported in Harmony as Straight in order to get the correct result.

Note that if the image has no alpha channel or if it does have an alpha channel
and all the pixels are 100% opaque, it does not make any difference which
option is selected.

Colour: Controls the production of colour information from bitmap images. If
this module reads 3 or 4-channel bitmaps, this selection determines whether
the colour should be read or ignored. If this module reads 1-channel bitmaps,
this selection determines whether the channel should be read as colour. When
this option is selected with 1-channel images, the resulting image will be a
greyscale image.

Transparency: Controls the production of alpha information from bitmap

132




Harmony 12.2 Advanced - Compositing and Effects Guide

images. If this module reads a 1 or 3-channel image, this option will create a
matte from the colour values in the image. If the module reads a 4-channel
image and this option is not selected, the alpha information in the image will be
ignored.

Transparency Type

Premultiplied with Black: Semi-transparent pixels in the original image are
blended with black.

Premultiplied with White: Semi-transparent pixels in the original image are
blended with white.

Straight: Semi-transparent pixels in the original image are left as is
(unmatted).

Clamp Colour to Alpha: Semi-transparent pixels in the original image are
blended with black. On import, each of the RGB channels is clamped so that a
color value never exceed the alpha value for a given pixel. When the RGB
values are multiplied with the alpha value, that is to say, if you have a pixel of
value R=247, G=188, B=29 and the alpha is 50% or the image has a 50%
transparency, then the actual RGB values output would be half of the amounts
listed above.

Controls Tab

Transformation =~ Drawing Controls | Advanced

The Controls tab contains animation control options.

Parameter

Description

Animation

Animate Using Animation Tools: By default, a drawing layer can be animated
using the same parameters as a peg, but you can disable this feature. Being able
to switch your drawing layers so they can no longer be animated without a peg
has certain advantages. In cut-out animation, it is easier to separate your drawing
exposure and keyframes to change timing easier and rearrange keyframe position
in the Timeline view. This feature is also available for backward compatibility
when bringing in templates created in older versions of the software, so as not to
lose their offset keyframes or drawing substitution keyframes.

Spline Offset

Inthe X, Y and Z axis fields, type the coordinates of where you want to offset the
visual trajectory. By default, the trajectory is displayed at the centre drawing,
using the layer's pivot position. If you want to move it so it corresponds better
with your drawing, either type new coordinates or use the Spline Offset tool
available in the Advanced Animation toolbar.
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To display the trajectory in the Camera view, select your drawing and select View
> Show > Control. You can also press Shift + F11 (Windows/Linux) or 34§ + F11
(Mac OS X).

Advanced Tab

The Advanced tab contains options for setting the alignment of drawings, line thickness, vector render options,
and more.

Advanced

Alignment

Miscellaneous

Parameter Description

Alignment Rule: The alignment rule selections are intended to deal with
drawings that were created on paper of a different size or orientation from the
default alignment rule (set up in the Scene Settings dialog box) or imported
bitmap images. The drawings are then scaled to match the Harmony alignment
rectangle. Note that alignment rules are not based on the camera frame, but on
the scene frame. Refer to the Fundamentals Guide to learn more about scene
Alignment alignment and scene settings.

* Left: The default alignment for drawings; aligns the drawings to the left
side of the scene’s alignment rectangle. Harmony scales the drawings
to match their height to the alignment rectangle of the scene.

* Right: Aligns the drawings to the right side of the alignment rectangle.
Harmony scales the drawings to match their height to the height of the
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alignment rectangle of the scene.

» Top: Aligns the drawings to the top of the alignment rectangle.
Harmony scales the drawings to match their widths to the width of the
alignment rectangle of the scene.

» Bottom: Aligns the drawings to the bottom of the alignment rectangle.
Harmony scales the drawings to match their widths to the width of the
alignment rectangle of the scene.

+ Centre Fit: Centers the drawings.

» Centre Fill: Centers the drawings and then scales them so the width or
height fills the available space.

+ Centre LR: Aligns the drawings in the left-right centre of the alignment
rectangle. Harmony scales the drawings to match their height to the
height of the alignment rectangle of the scene.

+ Centre TB: Aligns the drawings in the top-bottom centre of the
alignment rectangle. Harmony scales the drawings to match their
widths to the width of the alignment rectangle of the scene.

» Stretch: Scales the drawings so they fit within the alignment rectangle
of the scene. This is particularly useful forimages that you will
manipulate with a Quadmap node. If the drawings in the Quadmap node
do not have the same aspect ratio as the alignment rectangle of the
scene (from the Scene Settings dialog box), the handles on the
quadmap will not appear on the corners of the image, making it difficult
to manipulate the quadmap. In this case, you would set the drawing
layer of the quadmap images to Stretch to make the handles appear on
the corner of the image. This can have the effect of distorting the
images, but it is not an issue with images that will be distorted through
the Quadmap node anyways.

* As ls: Leaves the drawings aligned as they are.

» Centre First Page: Aligns the centre of the first part of a standard pan
cel with the centre of the field chart.

Turn Before Alignment: Rotates the drawings in the selected element 90
degrees to the left before scaling and aligning them according to the alignment
rule, and before performing any offset, rotation or scaling for the element or
peg. This and the Alignment Rule are intended for drawings that were created
on paper of a different size or orientation than the other paper in the scene, and
requires alignment so they are treated accurately.

Flip Horizontal: Flips the drawing on the X-axis.

Flip Vertical: Flips the drawing on the Y-axis.

As you move the camera in your scene along the Z-axis, notice that, logically,
the lines of the elements become thicker the closer the camera gets to the
Line Thickness drawing. If you prefer the lines to remain the same size or become thicker at a
different speed, you can use the thickness feature to adjust your brush stroke
and pencil line thickness. You can modify the size of the lines even if the
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camera is not animated.

To learn how to use this feature, see Camera Truck-ins and Line Thickness on
page 170.

Adjust Pencil Lines Thickness: Lets you work with pencil lines and adjust
their thickness. You will not see any changes to lines in the Camera view
OpenGL mode. You must switch to the Render mode.

Normal Thickness: Disables all overrides on the brush stroke line thickness.
This option must be enabled in order for the pencil line thickness parameter and
pencil lines to appear. If you want to modify the brush stroke thickness,
deselect this option. To enable brush strokes to work with the line thickness
feature, you must first create central strokes in the Colour Art layer. The
central strokes control the line variation of your brush strokes in the Line Art
layer. Select Drawing > Create Colour Art from Line Art.

Zoom Independent Thickness: Select this if you want your line thickness to
remain constant independently from the camera move. Everything else will
increase in size, but the line thickness will stay the same.

Proportional: Enter a multiple by which you want to increase the line
thickness base on its original thickness. A value of 1 will result in no change; a
value of 0 (zero) will hide the lines.

Constant: Enter a value in pixels (based on a 720x540 screen resolution) to
indicate the amount of pixels you want to add around the existing line.

Minimum: Enter a value in pixels (based on a 720x540 screen resolution) for
the minimum line thickness allowed.

Maximum: Enter a value in pixels (based on a 720x540 screen resolution) for
the maximum line thickness allowed.

Vector Render Options

+ Antialiasing Quality: A smoothness (antialiasing) setting applied to the
final rendered image.

* Low: No antialiasing

+ Medium Low: Basic antialiasing

* Medium: Improved antialiasing (blurs the textures)

» High: High quality antialiasing (does not blur the textures)
Higher quality images require more time to render and more system
memory. Choose a lower quality if you are rendering a pencil test.

« Antialiasing Exponent: Controls the size of the area around the final
image edges used in the antialiasing process. A higher value uses less
area, resulting in sharper edges, while a lower value uses more area,
resulting in softer edges. If the Antialiasing Quality value is set to Low
(no antialiasing) or Medium Low, this value is ignored. Values: Between
Oand 1.

» Texture Filter: This option changes the way coloured pixels of TVG
textures are calculated when rendered for different degrees of accuracy.

+ Bilinear: This option takes the four pixels around each point and
makes a bilinear interpolation between them. (Medium Quality)
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* Nearest: This option chooses the colour of the closest pixel to a
point. (Lower Quality)

* Nearest (Filtered): This option is an improved version of Bilinear
and improves the quality when zooming on a texture. (Best Quality)

» Opacity: Lets you quickly change the transparency of the selected
Miscellaneous element. Opacity settings here will be reflected in both OpenGL
preview, and full render.

Setting Properties for Many Layers

When working with several nodes, you may frequently want to modify a series of settings. Instead of opening the
properties for each individual layer, you can set the properties for many layers so you can change a common setting
in a single click.

This allows you to modify the following settings:
» 3D Path or Separate mode
* Use Embedded Pivot

*  Overlay

» Line Ant

+ Colour Art
* Underlay

* Animate Using Animation Tools

NOTE: You can add the button to the Timeline View toolbar through the Toolbar Manager. In the Toolbar Manager,
you will find the feature in the script section under the name Script: TB_Set_Properties_on_manu_layers in TB_Set_
Properties_on_many_layers.js.

How to set properties for many layers

1. Inthe Timeline view, select all the layers you want to modify at the same time.

2. Inthe Timeline View toolbar, click the Set Properties for Many Layers #, button. This option is not available
by default in the Timeline View toolbar. You must add it through the Customize option. Right-click on the tool-
bar and select Customize. In the Available Tools list, select Script: TB_Set_Properties_on_many_layers and
move it to the Toolbar list.

The Set Properties for Many Layers dialog box opens.
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3. Modify the properties. If your nodes have different parameters enabled for a certain setting, leave the As Is
option selected to avoid modifying it. Each node will keep its original setting. Select any other options for
all nodes to change to this parameter regardless of their original setting.

4. Click OK.

Auto Apply Option

When you modify a parameter in a property dialog box, Harmony applies the modification automatically and
displays the result immediately in the Camera view. If you do not want to immediately display every change made
to your scene, turn off this default setting by deselecting the Auto Apply option. This is useful when you are
working on a very heavy scene.

When you disable this function, Apply and OK buttons at added at the bottom of the Layer Properties view and
any other parameter dialog boxes.

» Click Apply to apply the current change.

* Click OK to apply the current change and close the Layer Properties.

I Layer Properties A @

. Layer Properties

Auto-Apply is OFF Auto-Apply is OFF

Auto-Apply is ON No modifications in the editor Modificationsin the editor
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NOTE: If you want to always work in Auto-Apply mode, you can deselect the Auto-Apply option in the Preferences
dialog box (General tab). Then, each time you start Harmony, the Auto-Apply mode will be off. You must click the
Apply button to see any modifications.

How to enable or disable the Auto Apply option

» From the top menu, select Edit > Auto-Apply.

How to enable or disable the Auto-Apply preference

1. Inthe top menu, select Edit > Preferences (Windows/Linux) or
Stage Advanced > Preferences (Mac OS X).

The Preferences dialog box opens.
2. Inthe Preferences dialog box, select the General tab.

3. Inthe Options section, select or deselect the Auto Apply option.

Resetting a Transformation

You can easily reset layers to their original position. With the Reset command, you can return the value of a selected
element to the initial value of the active tool. For example, if the Rotate @ tool is active, the transformation angle
will be reset to 0 and if the Transform =3 tool is active, the all transformation parameters values will be reset.

When selecting elements in the Camera view using the Transform tool, always make sure that the Peg Selection
Mode 4 is deselected in the Tool Properties view. Otherwise, it will limit the selection to pegs only.

How to completely reset the layers' parameters

1. Inthe Tools toolbar, select the Transform ;-1 tool or press Shift + T.
2. Inthe Timeline or Camera view, select one or more drawing layers to reset.

3. Do one of the following:
» From the top menu, select Animation > Reset or press R. This will reset the current frame if keyframes
were created.

» Right-click the selected layers and select Clear All Values. This will remove all keyframes and reset all
values for the entire layer.

» Inthe Timeline view menu, select Layers > Clear All Values. This will remove all keyframes and reset
all values for the entire layer.

The selected layers return to their original position.

How to reset an individual parameter

1. Inthe Advanced Tools toolbar, select the Translate «t», Rotate &, Scale 71, orSkew ;7 tool basedon
the parameter to reset.
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2. Inthe Timeline or Camera view, select the layer to reset.

3. From the top menu, select Animation > Reset or press R. This will reset the current frame if keyframes
were created.

The selected parameter returns to its original position.

How to reset all transformation values except Z

1. Inthe Tools toolbar, select the Transform i-3 tool or press Shift + T.
2. Inthe Timeline or Camera view, select one or more drawing layers to reset.

3. From the top menu, select Animation > Reset All Except Z.

All values except for those set on the Z axis are reset.
Cloning and Duplicating Layers

At times, you will need to create a large group of characters such as a crowd, school of fish or flock of birds. You
can do this by cloning or duplicating a layer. The difference between cloning and duplicating is that a clone uses
the same drawings for all layers. A duplicated layer is simply an independent copy.

If you want to maintain the ability to modify drawings and propagate the changes through all layers, you should
clone your layer. If you simply want to copy your layers and be able to modify your drawings without affecting the
original layer, use the duplicate option.

Cloning Layers

A cloned layer is linked to the original element directory. If a drawing is modified in the original or cloned layer,
both will be updated. However, cloned layers can have different timings.

Cloned layer - Changes to the original layer propagate to the cloned layer.

When cloning layers, you have the ability to clone the drawings and the corresponding columns (timing) or only
the drawings. If you choose to clone the drawings and timing, your node will be linked to the same element folder,
as well as the same drawing and function columns. Therefore, if you change the drawing exposure or keyframe on
one layer, all cloned layers will be updated.

You may want to create a large group of characters reusing the same animation, but want to slightly offset the
timing so they're not dancing or walking quite on the same beat. For example, if you create a walk-cycle fora
soldier and want to use it for an entire army, you may want to have 50 layers with 50 different drawing exposures
to produce a slight difference in the timing. If you copy your layers and drawings 50 times over, it will create a
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heavier scene. It is better to clone the 50 layers with only their drawings without linking to the same timing (function
and exposure columns).

How to clone a layer

1. Inthe Timeline, Xsheet view, select a layer to clone. You can select multiple layers.

2. Do one of the following:

» From the Xsheet menu, select Columns > Clone Selected Columns: Drawings Only or Columns >
Clone Selected Columns: Drawings and Timing.

» From the top menu, select Edit > Clone Drawings Only or Edit > Clone Drawings and Timing.

» From the Timeline menu, select Layers > Clone Selected Layers: Drawings Only or Layers > Clone
Selected Layers: Drawings and Timing.

» Inthe Timeline view, right-click on the layers and select Clone Selected Layers: Drawings Only or
Clone Selected Layers: Drawings and Timing.

The cloned layer appears.

Duplicating Layers

You can duplicate a layer to have a copy of the drawings that are independent from the original ones, as well as an
independent timing (exposure). When you need the drawings to be modified independently, you will want to duplicate
the layer instead of cloning it.

Duplicated layer - Changes to the original layer do not propagate to the duplicated layer.

How to duplicate a layer

1. Inthe Timeline, Xsheet view, select a layer to clone. You can select multiple layers.

2. Do one of the following:

» Inthe Timeline menu, select Layers > Duplicate Selected Layers.
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» Inthe Timeline view, right-click on the layers and select Duplicate Selected Layers.
» From the Xsheet menu, select Columns > Duplicate Selected Layers.
» From the top menu, select Edit > Duplicate.

The duplicated layer appears.

Working with Groups

With so many connections and nodes possible, the Timeline view can quickly become crowded. Keep things
organized by grouping your nodes.

| P

Ungrouped layers Grouped layers

Expanded group

Grouped layers
Collapsed group

How to group elements in the Timeline view

1. Inthe Timeline view, select the elements you want to group.

Any layers between the selected layers will be automatically grouped as well, so if the stacking order does
not matter, move extra layers above or below the layers want to group.

2. Do one of the followings:

» Right-click on the highlighted layers and select Group Selection.
The layers appear indented under a new Group layer in the Timeline view.

Display Concepts

When you open a scene coming from Harmony Premium, it may contain multiple Display nodes allowing you to
see isolated portions of the scene.

The Display node is an important node; it is used by the export and views to display your scene, primarily the
Camera and Timeline views. By default, a scene's node system always has a Display node which can be used to
show your entire scene, a single node or a group of nodes through a Composite or Group node. You might use it to
see one single character as you animate it, debug your node system as you create complex effects or export your
complete scene or a portion of it.
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Harmony Advanced doesn't allow you to add Display nodes. The display selection feature is only available for the
possible scenario that you need to use a specific Display node created by a Harmony Premium user.

How to set a different Display node as a global display

» From the top menu, select Scene > Default Display > desired display.
Each view is updated if set to the Default display option.

Timeline View Modes

The View Modes button lets you streamline the process of working with elements in the Timeline view. There
are three different view modes you can choose to work in. With each mode you select, certain elements may or may
not be visible in the Timeline view. Depending on your workflow, this can be useful for quickly hiding elements when
you want to focus on specific ones. To select a view mode, use the drop-down menu in the bottom-left corner of the
Timeline view.

Normal View Mode

Normal View mode is the default Timeline view mode. It shows everything connected to the chosen display. In

this mode, anything not connected to the currently set default display will not be shown in the Timeline view. This
also means that you cannot add certain elements to the Timeline view, as by default, when added they are not
connected to any display or composite node. An example of such an element is a peg.
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NOTE: If you prefer to work as you did before, where you see everything in the Timeline whether itis connected to
a Display or not, you can change the Always Display Unconnected Nodes setting in the Preferences dialog box,
Timeline tab.

Selection Only Mode

When working in Selection Only mode, only elements currently selected in the Camera or Node view will be
visible in the Timeline. This makes it easier to concentrate on one or a few elements at a time.

View Tagged Layers

The View Tagged Nodes @@ mode lets

you see only elements which have been assigned a Tagged status. An item that has been tagged will appear in
the Timeline view with a small asterisk beside its name.

+ =+ %

HE |+ H A [+

Once your elements are tagged and you have switched over to View Tagged Layers mode, the Timeline view will
display only tagged elements. The red bar on the left of the layers indicates you are in this view mode.

Viewing tagged layers in the Timeline view

While in this mode, the asterisks are not displayed beside the tagged elements.

How to tag or untag elements in the Timeline or Node view

1. Inthe Timeline or Node view, select one or more elements.

2. Do one of the following:

» Right-click and select Tag and one of the following:
» Inthe Timeline or Node view menu, select Edit > Tag and one of the following:

Timeline Tag: Tags selected elements in the Timeline or Node views.
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Timeline Untag: Untags selected layer in the Timeline view.
Timeline Untag All: Untags all tagged elements.
Timeline Untag All Others: Untags all elements except the selected one.

Creating a Multiplane

One of the most exciting features in Harmony is the multiplane or Z-depth. In the multiplane, you can create
backgrounds in several layers, spread them on the Z-axis to add depth, and then move the camera through this
environment to create an impressive perspective illusion.

To construct a multiplane, you must imagine what a real environment is like. Take a look at your background picture
and imagine a camera moving through the space. Notice that objects in the picture move at different speeds
depending on where they are in relation to the camera lens.

Building a multiplane requires an understanding of the scene's background, as well as the positioning of the
elements on different layers.
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For example, in the background illustrated above, the main objects to be separated are:

1.

2.

5.

6.

Fern

Front tower
Second tower
Moon

Stars

Sky

Although the bottom of the tower is hidden behind the plant and the ladder, each of the multiplane layers should be
a complete drawing. This is because hidden portions may show up during a camera move later on in the scene.

You can position layers on the Z-axis using the Side and Top view.

Positioning your element closer to the camera makes them appear bigger. You can also move elements towards
the camera or away from the camera while keeping the same size aspect ratio in the Camera view.

It is a good idea to keep a Camera view open to see what your scene looks like while positioning elements in the
Top and Side views—see Top View on page 148, Side View on page 150 and Perspective View on page 151.
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How to position an element in the Top and Side views

NOTE: Before distributing layers along the Z-axis using the Top and Side views, deselect the No Z Dragging option
by selecting Animation > No Z Dragging. This option is disabled by default.

1. Tomaintain the visual scale in the Camera view as you move your element, do one of the following:

» Inthe Advanced Animation toolbar, select the Maintain Size £ tool.
» From the top menu, select Animation > Tools > Maintain Size.
» Press Alt +6.

2. Inthe Side or Top view, select one of the layers in the thumbnails section. You can also select a layer from
the Timeline view.

The selected layer is highlighted in the Top, Side and Camera views.

3. Drag the layer to the correct depth position in the camera cone. Your element aspect will remain the same in
the Camera view.
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4. Foryourelement to scale up or down in relation to their distance to the camera, do one of the following:

> Inthe Tools toolbar, select the Transform :-; tool. Make sure the Peg Selection Mode . optionis
disabled in the Tool Properties view.

> Inthe Advanced Animation toolbar, select the Translate 1. tool and select a layer from the thumbnails
section of the Top or Side view.

» Select a layer from the Timeline view.
The selected layer is highlighted in the camera cone.

5. Inthe Top view, drag the element sideways to position it horizontally. Hold Shift while dragging the ele-
ment to make sure it only moves along the X-axis.

6. Inthe Side view, drag the selected element up or down to position it vertically. Hold Shift while dragging
the element to make sure it only moves along the Y-axis.

Top View

The Top view is used mainly for multiplane scenes and to position elements in 3D space. It allows you to see the
scene’s stage from above. This lets the camera cone and the spacing between the elements be seen.
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A thumbnail of each drawing layer in the scene. The order of the thumbnail images is based on each ele-
ment’s FB position in the scene space. You can see a representation of the FB position of each layer in the
camera cone.

The camera cone represents the camera’s position and field-of-view (FOV).
The axis reference arrows let you maintain your orientation when navigating in the Perspective view.

There are two view option buttons displayed in the lower-left corner of the view.

> Show/Hide Camera: Shows or hides the camera frame in the Perspective view.
> Reset View: Resets the pan, rotation and zoom of the Perspective view.
This field displays the current zoom level in the Perspective view. You can use the Zoom menu to select a

zoom level from 2.5% to 6400%. You can also select Fit To View to automatically use a zoom level that lets
you see all of the scene layers and information in the Perspective view at once.

Displays the currently selected layer and drawing name.
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7. Displays the currently selected tool.
8. Displays the currently selected frame of your animation.

9. Displays the currently selected colour in the palette.

Side View

The Side view is used mainly for multiplane scenes and to position elements in 3D space. It allows you to see a
scene’s stage from the side. This lets the camera cone and spacing between the elements to be seen.

1. Athumbnail of each drawing layer in the scene. The order of the thumbnail images is based on each ele-
ment’s FB position in the scene space. You can see a representation of the FB position of each layer in the
camera cone.

2. The camera cone represents the camera’s position and field-of-view (FOV).
3. The axis reference arrows let you maintain your orientation when navigating in the Perspective view.

4. There are two view option buttons displayed in the lower-left corner of the view.

> Show/Hide Camera: Shows or hides the camera frame in the Perspective view.
> Reset View: Resets the pan, rotation and zoom of the Perspective view.
5. This field displays the current zoom level in the Perspective view. You can use the Zoom menu to select a

zoom level from 2.5% to 6400%. You can also select Fit To View to automatically use a zoom level that
lets you see all of the scene layers and information in the Perspective view at once.
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9.

Displays the currently selected layer and drawing name.
Displays the currently selected tool.
Displays the currently selected frame of your animation.

Displays the currently selected colour in the palette.

Perspective View

The Perspective view is used during scene setup. It allows you to see a multiplane scene’s orientation. The
Perspective view is similar to a 3D display, as it lets you rotate the scene through all possible angles to understand
the spacing between the elements. You can also position and rotate your layers and the camera inside the 3D
display to achieve some 3D setup and camera moves.

1.

The red circle rotates the view on its X axis.

151



Chapter 4: Scene Setup

2.

3.

4.

10.

11.

The green circle rotates the view onits Y axis.

The blue circle rotates the view on its Z axis.

This is a perspective grid reference.

The axis reference arrows let you maintain your orientation when navigating in the Perspective view.

There are three view option buttons displayed in the lower-left corner of the view.

> Show/Hide Camera: Shows or hides camera frame in the Perspective view.
> Reset View: Resets the pan, rotation, and zoom of the Perspective view.
> Reset Rotation: Resets the rotation of the Perspective view.

This field displays the current zoom level in the Perspective view. You can use the Zoom level drop-down
menu to select a specific zoom level from the list. Zoom levels from 2.5% to 6400% are available; you can
also select Fit To View to automatically use a zoom level that lets you see all your scene layers and inform-
ation in the Perspective view at once.

This field displays the currently selected layer and drawing name.
This field displays the currently selected tool.
This field displays the currently selected frame of your animation.

This field displays the currently selected colour in the palette.

How to rotate a scene in the Perspective view

In the Tools toolbar, select the Rotate View @ tool.

» Click inthe view, and drag the cursor around to rotate the view.

» Press and hold Ctrl + Alt (Windows/Linux) or 38 + Alt (Mac OS X) and click and drag to rotate the view
one axis at atime.
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Chapter 5: Path Animation

With Harmony, you can animate layers using computer-generated trajectories, create multiplane camera moves and
camera shakes, adjust the easing, shape your paths with control points and much more.

This chapter contains the following topics:

* Animating a Layeron page 153

» Differences between Animated Layers and Pegs on page 155

» Layer Parameters on page 159

* Adding and Deleting Keyframes on page 162

»  Motion and Stop-motion Keyframes on page 163

» Animating the Camera on page 167

*  Modifying a Path in the Camera, Top and Side Views on page 171

»  Modifying a Path in the Timeline View on page 177

* Modifying a Path in the Function View on page 179

* Modifying a Path in the Xsheet View on page 186

* Function Curves on page 188

» Copying and Pasting a Motion on page 192

» Adjusting the Velocity on page 199
Animating a Layer

Before animating the position of drawing layers, you need to create motion paths which are trajectories on which you
can attach drawing objects. Using keyframes, you can then record key positions along the trajectory.

Harmony’s wide range of features let you produce simple and advanced motions and trajectories. By creating a
simple motion, you will learn the basics of animating a layer.
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The Animate mode lets you keyframe drawing layers to create computer-generated animation. When working in
the Animate mode, you can animate a layer's position and then turn off the mode to reposition a layer for the entire
scene. When the Animate mode is disabled, keyframes are created on selected layers at the current frame.
Depending on what transformations were performed (rotation, translation, skew), the new keyframes are added
on the corresponding parameters (function curves).

How to turn the Animate mode on or off

1. Inthe Tools toolbar, click the Animate button or select Animation > Animate.

How to animate a layer

1. Inthe Tools toolbar, select the Transform -: tool or press Shift + T.
2. Inthe Tool Properties view, make sure the Peg Selection Mode ;. is deselected.

3. Inthe Tools toolbar, enable the Animate mode. This will create keyframes at the current frame when
moving objects.

4. Inthe Timeline view, go to the first frame.

5. Inthe Camera view, select the element to animate and move it to its first position.

&

A keyframe is created on the first frame of the Timeline view.

Keyframe

6. Inthe Timeline view, go to the frame on which you want to set the second position.
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7. Inthe Camera view, move the element to its second position.

A second keyframe is created on the Timeline view.

Keyframe

8. Play back » youranimation.

To see your motion animations in the Top, Side or Perspective views while you play back, you must turn on
the Playback option. From the top menu, select Play > Enable Playback > Top View or Side View or
Perspective View.

Differences between Animated Layers and Pegs

There are two ways to create motion paths: animated drawing layers and pegs. They each have different purposes.

You can create a motion path directly on layers (animated layers).

You can control and define a trajectory using several different parameters, including:
+ X, Y andZ positions (3D Path or Separate Positions)
* Angle (rotation)
+ Skew
+ XandY Scales
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Each parameter has its own function curve where you can add keyframes and control the easing. If you're not
familiar with graphs and function curves, these are easy-to-use tools for visually controlling trajectories in the
Camera and Timeline views.

Expands parameters

Parameters Values

By default, you can animate a drawing layer using the same parameters as a peg, but you can choose not to do so
by turning off this feature. This allows you to switch your drawing layers so they can no longer be animated
without a peg, which has certain advantages. In cut-out animation, it's easier to separate drawing exposure and
keyframes to change the timing and rearrange keyframe position in the Timeline view. This also works for
backward compatibility when bringing in templates created in older versions of Harmony so as not to lose their
offset keyframes or drawing substitution keyframes.

If you do not want to animate a drawing layer, you can turn off its animation parameter. To do so, simply select
the layer and in the Layer Properties view, deselect the Animate Using Animation Tools option on the Controls
tab. If your layer was already animated, then your keyframes will appear dimmed so you can easily identify them
as ones that cannot be modified. To modify keyframes, select the Animate Using Animation Tools options.

[
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Pegs have been used for a long time in the traditional animation process, mainly for registration purposes. Peg holes
at the bottom or top of the animation paper are used to keep all the sheets even and at the same registration.

There are three peg holes in regular animation paper. The centre peg hole is round while the left and right ones are
oval shaped. The oval peg holes are located on each side of the page, four inches away from the centre peg hole.

To keep the drawings together, the animator uses a peg bar. This peg bar has three pins that correspond to the
shape and location of the peg holes. Peg bars are normally found at the bottom and top of animation discs.

Before digital compositing, the peg bars were also used to move layers on the camera stand to create pans and
camera moves. They were the equivalent of digital trajectories. Harmony makes use of these concepts to create
animation and camera motion.

A peg is composed of many customizable parameters. These parameters are:
* X, Y and Z positions (3D Path or Separate Positions)
* Angle (rotation)
+  Skew
+ XandY Scales

You can control a peg’s trajectory the same way as the animated drawing layer.

A peg layer is mainly used to control a series of drawing layers, such as clouds, a school of fish or a flock of birds.
You can attach them to a peg layer and make them follow a trajectory as a single unit. This makes trajectory
modifications much easier and faster. When building a puppet, most of the time you will add a master peg to control
your puppet as one object.

In the Tool Properties view, the Peg Selection Mode ,; lets you automatically select the peg layers in the Camera
view instead of the drawing layers. If you animate with pegs instead of animating the drawing layers directly, enable
the Peg Selection Mode to avoid having to select in the Timeline view or use the Select Parent Skipping Effects
command.

How to disable the animation feature on a layer

1. Inthe Timeline view, double-click the layer on which you want to set the parameter.

The Layer Properties editor opens.

2. Inthe Controls tab, deselect the Animate Using Animation Tools option.

How to add a peg in the Timeline view

1. Inthe Timeline view, select the layer on which you want to attach a peg.
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2. Do one of the following:

» From the Timeline View layers toolbar, click the Add Peg £~ button.

» From the Timeline view menu, select Insert > Peg.
» From the top menu, select Insert > Peg.

The layer that was originally selected becomes a child of the new parent Peg layer. The new Peg layer
automatically takes the name of its child layer, with the addition of the suffix -P.

The indentation of the layer, along with the "L" indicates hierarchy and that the layer is attached to the Peg
layer. This relationship is called a parent-child relationship.

3. If youintend to add multiple pegs or if the layer name that was added to the peg does not accurately rep-
resent the content of the Peg layer, you can rename it. Click the layer name and type in a new name. Or
double-click the layer and type a new name into the dialog box.

4. If you did not create your peg layer directly above the layer you intended on parenting it to, then drag the
layer you want to attach to the peg and drop it directly below the Peg layer. The indentation of the layer
below the Peg layer indicates whether it was correctly attached or not.

» You can unparent layers by holding down Shift and dragging the selected parents away from the child
layer. Drop your selected between other layers.

How to enable the Peg Selection Mode
1. Inthe Tools toolbar, select the Transform :-; tool or press Shift + T.
1. Inthe Tool Properties view, click the Peg Selection Mode - button.

2. Inthe Camera view, select an element parented to a peg.
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Layer Parameters

A layer is composed of many customizable parameters, such as the X, Y and Z positions, angle (rotation), skew and
scales. Each parameter has its own function which is a mathematical formula expressing the relationship between
position values. You can view each function on a graph as a simple curve, such as the one below.

-4 Frame I

Keyframe value

\J

There are six options available for setting up function parameters:

» Locked Positions (3D Path)
» Separate Positions

» Locked Scales

» Separate Scales

Separate Positions

Locked Scale
Separate Scale
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You must select 3D Path, Separate Positions, Separate Scale, or Locked Scale before starting the animation.
When you lock or unlock parameters, this does not convert the functions from one to the other, but creates new
ones.

Ina 3D Path, the X, Y and Z curves are locked together and controlled by a single velocity function. When you
add a keyframe, it is added on all three trajectories at once, as is the velocity. This is very useful for long, smooth
trajectories.

When the Separate Positions option is used, the X, Y and Z curves are independent and have velocity controls
directly on their function curve. This is useful when you want to set keyframes on one of the curves without
affecting the others.

When using the Scale parameter, you can use a single function curve to control both the vertical and horizontal
scale, or two separate scales. When using a single function curve, the values are the same for the X (horizontal)
and Y (vertical) axes for uniform size changes without distortion. However, if you separate the scale functions,
you can squash, stretch and skew your elements.

How to display the layer parameters in the Timeline view

1. Do one of the following:

» Inthe Timeline’s left side, click a layer's Expand button.

» Inthe Timeline view menu, select View > Show Functions.
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» Press Alt+F.

Layer parameters are displayed

How to set the layer parameters

1.

In the Timeline view, double-click on the layer on which you want to set the parameter. You can also see the
parameters in the Layer Properties window when you select the layer in the Timeline view.

The Layer Properties window opens.

Select the Transformation tab.

In the Position section, select the 3D Path or Separate option.
In the Scale section, select the Locked or Separate option.

Click Close.
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Adding and Deleting Keyframes

There are several different ways you can create keyframes. You can add a coordinate keyframe, position
keyframe or a keyframe along with your drawing duplication.

You can create a keyframe without a drawing. This adds new coordinate points but the drawing in the layer stays

the same. At the same time, you may also want to duplicate your drawing if you need to modify it and do not want
to modify the original.

You can also add a position keyframe instead of a regular keyframe. When you do this, keyframes will only be

added on the X, Y and Z parameters of the selected layer. Keyframes are not added on the Angle, Scale and
Skew parameters.

NOTE: If you select a keyframe in the Timeline view and press the Delete key, you will also delete the drawing

exposure. To only delete the keyframe, you must use the Delete Keyframe command—see Adding and Deleting
Keyframes on page 162.

How to create keyframes

1. Inthe Timeline view, select the cell on which you want to add a keyframe.

2. Add a keyframe by doing one of the following:

» From the top menu, select Insert > Keyframe.
» Right-click on the selection and select Insert Keyframe.
» Press F6.

» Inthe Timeline View toolbar, click the Add Keyframe # button.

If the Animate mode is enabled in the Camera view, a keyframe is automatically created on the current
frame.

How to create a keyframe and duplicate the drawing at the same time

1. Inthe Timeline view, select the cell containing the drawing you want to duplicate and add a keyframe.

2. Do one of the following:

» From the top menu, select Insert > Keyframe and Duplicate Drawing.

» Right-click on the selection and select Insert Keyframe and Duplicate Drawing.
» Press F6.
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A keyframe and a duplicate of the drawing is created. The duplicated drawing sits on top of the original
drawing.

Criginal drawing Duplicated drawing is selected
and moved

How to add a Position keyframe

1. Inthe Timeline view, select the cell on which you want to add a position keyframe.

2. From the top menu, select Insert > Position Keyframe.

How to delete a keyframe

» Inthe Timeline view, select a keyframe and do one of the following:
Right-click and select Delete Keyframes.
In the Timeline view menu, select Motion > Delete Keyframes.
From the top menu, select Animation > Delete Keyframe.
Press F7.

» Usethe Transform ;-1 tool to select a keyframe to delete from the trajectory in the Camera view and
press Delete.

o

Motion and Stop-motion Keyframes

Interpolation is the computer-generated motion between two keyframes. Some animators and compositors like to
create their own in-betweens, while others like to have the computer do it. Harmony has stop-motion (no
interpolation) and motion keyframes (computer-generated interpolation).

In stop-motion keyframes, there is no computer-generated motion between two keyframes. The segment is constant
or flat. The drawing remains still until the playback reaches the next keyframe, then the drawing pops to its new
location.
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Constant segment

Moves to next position

In motion keyframes, there is no automatic interpolation created between the selected point and the next one. The
layer will maintain its position until the animation reaches the frame of the next point and will then jump to the new
position. Deselect this option to generate interpolation and get the layer to progressively move to the next
position.

You can switch a keyframe from stop-motion to motion at any time in the Timeline view and Function Editor.

To easily identify stop-motion keyframes in the Timeline view, you can customize the colour In the Preferences
dialog box.

Stop-motion keyframe colour
customized to orange

How to switch between motion and stop-motion in the Timeline view

1. On the right side of the Timeline view, select one or more keyframes to modify.
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2.

Switch between motion and stop-motion by doing one of the following:
» Right-click on the selected keyframes and select Set Motion Keyframes or Set Stop-Motion
Keyframes.

» Press Ctrl + K (Windows/Linux) or 3£ + K (Mac OS X) for motion keyframes and Ctrl + L (Windows/Linux)
or & + L (Mac OS X) for stop-motion keyframes.

» Inthe Timeline View toolbar, click the Motion Keyframe _~ or Stop-Motion Keyframe . button.

How to switch between motion and stop-motion keyframes in the Function view

1.

2.

3.

4.

Open the Function view.

In the Timeline view, double-click on the layer that contains the keyframes you want to convert.

The Layer Properties window opens.

Transformation

Do one of the following:

» Inthe Transformation tab, click the Function Editor _ button.

» Inthe Timeline view, click the Expand Function button or press Alt + F and double-click on the
function to edit.

Expands parameters

Parameters Values

On the function curve, select one or more keyframes to modify.
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Bezier Editor =

5. Select or deselect the Stop-motion Keyframe . . button to set a stop-motion or motion keyframe.

Bezier Editor E

How to set the stop-motion keyframe colour

1. Open the Preferences dialog box by pressing Ctrl + U (Windows/Linux) or 3£ + U (Mac OS X).
2. Select the General tab.

3. Inthe Colours section, click Edit Colours.

4. Inthe Colours dialog box, select the Xsheet and Timeline tab.

5. Inthe Timeline section, click the Stop Motion Keyframe swatch.

6. Inthe Select Colour window, select a new colour and close the windows.
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Constant Z

When using a 3D path, the X, Y and Z functions work together using the same keyframes. This allows for the
velocity to control the curve and create a smooth trajectory. Even if a function does not have any variation on its
curve (for example, all keyframes are at zero), the velocity might add a slight motion to ensure a smooth trajectory.
This can cause elements that are very close to each other on the Z-axis to pop in front of one another. This is why in
cut-out animation it is recommended to use separate position settings. But if you work with 3D path, you can use the
Constant Z feature to avoid this from happening.

The Constant Z feature is used when creating motion keyframes. The Z function will use stop-motion keyframes and
will not be interpolated, which can be very useful for cut-out animation. The Constant Z feature only works with 3D
paths.

You can also enable the Constant Z option directly in the Function view for specific functions.

How to enable the Constant Z option

1. Inthe Timeline view, expand the layer on which you want to set the Constant Z feature. Note that you must
select the 3D Path option for the layer.

2. Double-click on one of the position functions to open the Function editor.

3. Inthe Function editor, select the Constant Z 1 button.

3D Path Editor ]

Animating the Camera

In Harmony is a camera that can move along the X, Y, and Z axes. Having the camera move on the Z-axis offers the
possibility to create truck in and truck outs, as well as multiplane camera moves. The default camera position is
centred and backed up to 12 fields.
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It is important to understand the coordinate values in Harmony. Harmony's core is based on the origins of
animation. In traditional animation, a scene's size and camera motion are calculated in fields. A field has a4:3
ratio and measures 0.5 inches (12.7 mm) in width. A specific grid has been created for this purpose known as a
field chart. Harmony uses this unit of measurement as its coordinate system.

A field chart uses the cardinal directions. The X axis is the east-west (left-right) direction, the Y axis is the north-
south (up-down) direction and the Z axis is the forward-backward direction.

The camera is treated the same way as any other element. You can use the same tools and selection modes to
offset or animate it, but the camera is a static object. To animate the camera, you need to connect it to a peg
layer. A peg is a trajectory layer.

While making camera moves, you can use the Top, Side, and Camera views.

How to open the Top and Side views

1. Do one of the following:

» From the top menu, select Windows > Top or Side.

» From any view already open, click the Add View button at the top-right corner and select Top or
Side.
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How to add a camera and parent it to a peg

1.

If you don't already have a camera layer, do one of the following:

» From the top menu, select Insert > Camera.
» From the Layers toolbar, click the Add Layers button and select Camera.

A new camera layer is added to the scene and appears in the Timeline view.

In the Timeline view, select the Camera layer.

From the Layers toolbar, click the Add Peg @ button.

A Peg layer appears directly above the Camera layer, which is automatically attached to it.

The Peg layer automatically takes the name of the camera and adds the suffix -P to indicate that it is a Peg
layer, for example Camera-P.

Collapsed Peg layer

Expanded Peg layer

If the new Peg layer did not appear directly above the camera, you may have clicked elsewhere in the scene,
which deactivated the layer on which you want to add the Peg layer. To fix this:

» Select the Camera layer and drag and drop it under the new Peg layer. Or delete the misplaced Peg layer,
select the Camera layer and click the Add Peg . button again.

» You can unparent layers by holding down Shift and dragging the selected parents away from the child
layer. Drop your selected between other layers.

How to animate the camera

1.

2.

In the Tools toolbar, enable the Animate mode.
In the Tools toolbar, select the Transform ;-3 tool or press Shift + T.

On the right side of the Timeline view, on the Camera Peg layer, select the frame at which you want the cam-
era move to start.

Do one of the following:

» Inthe Timeline toolbar, click the Add Keyframe # button.
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» Right-click and select Insert Keyframe.
» Press F6.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera
position as this keyframe.

5. Inthe Top, Side or Camera view, select the camera (the large V-shaped cone) and move it to the desired
position. In the Camera view, the camera is represented by a thin frame. You need to click directly on one
of the edges.

6. Onthe Timeline view, click on another cell a bit further down in time to indicate where the camera move
will end.

7. Select the camera in the Camera, Top or Side view and move it to the desired position.

A second keyframe appears and a line is created between the two frames to indicate that the subsequent
motion between the frames will be calculated and rendered by the program.

8. Play back p youranimation.

Camera Truck-ins and Line Thickness

As you move the camera in your scene along the Z-axis, notice that, logically, the lines of the elements become
thicker the closer the camera gets to the drawing. If you prefer the lines to remain the same size or become
thicker at a different speed, you can use the thickness feature to adjust your brush stroke and pencil line
thickness. You can modify the size of the lines even if the camera is not animated.
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NOTE: This feature can only be viewed in the Camera view's render mode.

How to adjust the pencil line thickness of a drawing layer in the Camera view

1. Inthe Timeline view, double-click on a drawing layer to display the Layer Properties window.
2. Select the Advanced tab.

3. Inthe Line Thickness section, adjust some of the following parameters until you achieve the desired effect.

Line Thickn

Adjust Pencil Lines Thickness: Lets you work with pencil lines and adjust their thickness. You will
not see any changes to lines in the Camera view OpenGL mode. You must switch to the Render
mode.

Normal Thickness: Disables all overrides on the brush stroke line thickness. This option must be
enabled in order for the pencil line thickness parameter and pencil lines to appear. If you want to
modify the brush stroke thickness, deselect this option. To enable brush strokes to work with the line
thickness feature, you must first create central strokes in the Colour Art layer. The central strokes
control the line variation of your brush strokes in the Line Art layer. Select Drawing > Create Colour
Art from Line Art.

Zoom Independent Thickness: Select this if you want your line thickness to remain constant
independently from the camera move. Everything else will increase in size, but the line thickness will
stay the same.

Proportional: Enter a multiple by which you want to increase the line thickness base on its original
thickness. A value of 1 will result in no change; a value of 0 (zero) will hide the lines.

Constant: Enter a value in pixels (based on a 720x540 screen resolution) to indicate the amount of
pixels you want to add around the existing line.

Minimum: Enter a value in pixels (based on a 720x540 screen resolution) for the minimum line
thickness allowed.

Maximum: Enter a value in pixels (based on a 720x540 screen resolution) for the maximum line
thickness allowed.

Modifying a Path in the Camera, Top and Side Views

Camera moves and motion paths can become quite advanced, especially with moves through 3D space. Harmony
provides tools to view your camera’s path and make adjustments to it from both a 2D and 3D perspective.

You can display the trajectory of a motion path when you select an object in the Timeline or Camera view.
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A motion path is easy to manipulate. One important concept to understand is that a trajectory contains both
keyframes and control points. Both can be used to shape a path; each have their own significance and behaviour,
however only keyframes appear in the Timeline view.

+ Keyframes have a transformation value and a position in space at a given frame. Keyframes are locked in
time.

» Control points have a position but no fixed frame or timing. It is mainly used to deform a trajectory. There
are no velocity handles available on a control point. The velocity segments are set between keyframes
only, making curves and trajectories much smoother. Control points can only be added on a 3D path.

You can set the default Continuity, Bias and Tension parameters in the Preferences panel.

Continuity: Controls the smoothness of a transition between the segments joined by a point.

A Continuity of -1 sharpens
the transition on both sides
of the control point.

A Continuity of +1 rounds
out the transition, creatinga
gentle curve on both sides of

the control point.
& 2 &

Tension: Controls how sharply the path bends as it passes through a control point or keyframe.

@ ]
A Tension of -1 increases the A Tension of +1 sharpens the
curve an both sides of the control curve on bath sides of the
point. ® o control point. ®

Bias: Controls the slope of the path so it flows towards one side of the motion point or the other.

Y @
A Bias of -1 favours the left A Bias of +1 favours the right side
side of the control point. of the control point.
® @ ® .

When you select a control point on a path, you can switch between a rounded or square corner by using the
Linear/Curve command.
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How to view the layer’s trajectory using the Control command

1. Verify that the Camera view (click its tab) is selected and that the layer whose trajectory you want to display
is selected in the Timeline view.

2. From the top menu, select View > Show > Control or press Shift + F11.

NOTE: If nothing appears in the Camera view, you may not have animated or selected the layer.

How to add a control point on a trajectory

1. Inthe Timeline or Camera view, select the peg or layer on which you want to add a control point.

2. If the selected element’s trajectory is not displayed, select View > Show > Control from the top menu or
press Shift + F11.

The trajectory appears in the Camera, Top, Side and Perspective views.
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3. Add control points on a 3D path trajectory by placing the cursor where you want to add the point and press
P once. If you hold the key down, control points will be added continuously until you release the key.

A control pointis added to the trajectory
tool select a point to convert.

How to switch between keyframe and control point

In the Camera view, use the Transform
In the Function view or Function Editor, select the keyframe to convert and click the Lock in Time

1.

2. Toconvert the point:
From the top menu, select Animation > Lock in Time.

>

>

button.
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» Press Alt+L.

How to adjust the control point preferences

1. From the top menu, select Edit > Preferences (Windows) or Stage Advanced > Preferences (Mac OS X).

The Preferences dialog box opens.

2. Select the Camera tab and adjust the parameters in the Control Points section.

How to toggle between a linear and curved corner

1. Inthe Timeline view, double-click the layer that contains the point you want to convert.

The Layer Properties window opens.
2. Onthe Transformation tab, select the 3D Path option.
3. Inthe Tools toolbar, select the Transform -3 tool or press Shift + T.
4. Inthe Camera view, select the point to convert.

5. From the top menu, select Animation > Linear Motion.

175



Chapter 5: Path Animation

Offsetting a Trajectory

By offsetting a trajectory, you reposition the visual trajectory without offsetting or modifying your animation. By
default, the trajectory is located at 0,0,0 fields. If your elements were drawn in a different location than the centre
of the drawing area, it will look like the trajectory is not aligned with your drawing. Also, if you have several

elements attached to one trajectory, you might want your trajectory to be at a different location to represent the
group's motion better.

How to offset a trajectory

1. Inthe Animation Tools toolbar, select the Spline Offset ;5 tool or press Alt + 8.

2. Inthe Camera, Top, Side or Timeline view, select the layer whose trajectory you want to offset.

3. From the top menu, select View > Show > Control to display the trajectory. If you do not display the tra-
jectory, any transformation done using the Spline Offset tool will be ignored.

o

-

4. Inthe Camera view, drag the trajectory to the proper position. You can move it on the X and Y axes, but
also on the Z-axis using the Top and Side views.

176



Harmony 12.2 Advanced - Compositing and Effects Guide

Trajectory is moved downwards

Modifying a Path in the Timeline View

When you select a peg or drawing layer in the Camera view and move it around, Harmony will automatically create
keyframes on the corresponding function curves. If you want to modify these curves, you can do it through the peg

or drawing layer parameters in the Timeline view.

Harmony lets you also flip between the selected layer's keyframes in the Timeline view.

How to create the function curve in the Timeline view

1. Inthe Timeline view, expand the layer's parameters.

2. Click the Function button and, in the drop-down menu, select Create Bezier.

How to add a keyframe in the Timeline view

1. Ontheright side of the Timeline view, select a cell on the layer’s function that you want to animate.
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2. Do one of the following:

» Right-click the selected cell and select Insert Keyframe.

» Press F6.

» Inthe Timeline View menu, select Motion > Insert Keyframe.

» Inthe Timeline View toolbar, click the Add Keyframe # button.

How to delete a keyframe in the Timeline view

1. Ontheright side of the Timeline, select a keyframe to delete. You can [Shift]+click several keyframes to
select a group before deleting the keyframes.

2. Do one of the following:

» Right-click on the selected keyframe and select Delete Keyframes.

» PressF7.

» Inthe Timeline View menu, select Motion > Delete Keyframes.

» Inthe Timeline View toolbar, click on the Delete Keyframes & button.

NOTE: If you select a keyframe or group of keyframes and press Delete, the corresponding drawings on that cell
are also deleted.

How to change the keyframe values in the Timeline view

1. Inthe Timeline view, open the drawing or layer's parameters by clicking the Expand * button or press Alt
+F.

2. Select the parameter for which you want to create a function curve.

1. Place the cursor over the blue number value of the parameter and do one of the following:

» Wait until the cursor changes to a white hand with a two-way arrow and then drag the hand left to
decrease the value or right to increase the value.
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» Double-click on the blue number and enter a value in the field.

How to flip through keyframes

1. Inthe Camera or Timeline view, select the layer that contains the keyframes you want to flip through.

2. From the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe or press semi-
colon (;) and single quote ().

Modifying a Path in the Function View

If you are accustomed to using graphs and function curves, you can use the Function view to define trajectories.

The graph in the Function view displays the motion over the first and last keyframes set in the scene, as well as any
keyframes created between. If the scene is 60 frames, but the character's motion ends at frame 40, then the editor
will only display up to frame 40.

The Function view lets you edit function curves and parameters. It is a visual graph for adding, removing, and editing
keyframes, as well as adjusting the velocity. The Function view allows you to display multiple functions in the
background as a reference.
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How to display functions in the Function view
1. Open the Function view.
The Function view is blank until you select the layer containing the functions you want to display.

2. Todisplay afunction in the Function view, click on the layer containing the functions to adjust in the
Timeline view.

3. Toselect the functions you want to edit, select them in the Function list.

Parameter Description

Function List

When selecting a layer in the Timeline view, all the corresponding functions are
displayed. Select all the functions you want to see and edit; hide the ones you
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don't.

Display Toolbar

The Display toolbar allows you to modify how the editing area is displayed.
You can hide the grid, disable the synchronization with the current frame, reset
the zoom level and normalize the function display by stacking them one over
the other to compare them regardless of their value range.

Current Frame

Displays the current scene frame.

Selected Keyframe Value

Displays the value of the selected keyframe.

Display Advanced Parameter
Values

Displays the Projection, Bias, Tension and Continuity parameters to adjust the
curve around the selected keyframe.

Keyframe, Velocity and Inter-
polation Options

This toolbar lets you add and delete keyframes, adjust the velocity curve,
adjust the segments to motion or stop-motion keyframes and set the velocity
to create steps instead of a constant progression.

Function Types

This toolbar lets you click on the different function types to enable or disable all
the listed functions of that type.

Value Scale

Displays the value range for the displayed editing area. It can be referenced to
know the value of a keyframe.

Selected Keyframe

The selected keyframe is displayed in red. When selected, the keyframe val-
ues are displayed in the corresponding fields.

Bezier Handles

The Bezier handles let you adjust the ease in and ease out of each keyframe.
The more the handle is pulled out horizontally, the slower the animation will be.
The more the handle is pulled out vertically, the faster the animation will be.

Function Curve

The thin line going from keyframe to keyframe is the actual curve. The section
of a curve located between two keyframes is called a segment.

Frame Scale

The Frame Scale displays the frame range for the displayed editing area. It can
be referenced to know the current frame of a keyframe.

How to edit a function in the Function view

1. Inthe graph of the Function editor, select a white keyframe.

The keyframe turns red and displays a pointed yellow handle.

2. Drag the point up or down, or click and pull one of the handles to adjust the curve of the graph.
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In the example above, changing the velocity from a straight line (constant velocity) to a curved one
changes the ease-in (where the curve shoots up and then flattens out) and ease-out (where the curve
flattens out and then shoots up) values.

The centre keyframe cannot be dragged up or down because the velocity is set. Theoretically, dragging it
downwards towards zero would put it back to a place of nonmovement.

Press the Enter/Return key with the editor still open to watch the result of your curve adjustment in the
Camera view.

How to add or delete keyframes in the Function editor

1.

In the Timeline view, open the drawing or layer's parameters by clicking the Expand * button or press Alt
+F.

Double-click on the parameter layer name to open the Function editor window or click once on the para-
meter layer to display it in the Function view.
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Bezier Editor @

N

Do one of the following:

» Inthe graph section, click on the frame number where you want to make changes.
» Inthe Frame field, enter the frame number.

In the graph, the vertical red line moves to the frame number.

3. Do one of the following:

» Inthe Function editor, click the Add/Remove Keyframes button.

» Inthe Function view, click the Add Keyframe # and Delete keyframe £ buttons.

>

Click on the newly created keyframe and drag it up (to decrease the width of the object) or down (to increase
the width of the object) or pull on the handles to create a smooth fluctuation of the drawing object's width.

5. If youdo not like the changes you just made, select and delete the new keyframe by pressing Delete or click-
ing the Add/Remove Keyframes button.

You can delete an existing keyframe by using the same process.

How to change a keyframe value in the Function view

1. Inthe Timeline view, open the peg element's parameters by clicking the Plus sign next the peg layer's
name.
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Collapsed Peg layer

Expanded Peg layer

2. Double-click on the parameter layer name to open the Editor window or click once on the parameter layer
to display it in the Function view.

Bezier Editor

3. Inthe Value field, enter a value. You can also drag the keyframe up or down in the graph.

4. Press Enter/Return orclick the Play . button to view the changes made in the Camera view.
5. Keep adjusting the values until you're satisfied with the results.

6. Click Close.

Function View

The Function view lets you edit function curves and parameters. It is a visual graph for adding, removing, and
editing keyframes, as well as adjusting the velocity. The Function view allows you to display multiple functions in
the background as a reference.
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How to display functions in the Function view

1. Open the Function view.

The Function view is blank until you select the layer containing the functions you want to display.

2. Todisplay a function in the Function view, click on the layer containing the functions to adjust in the Timeline
view.

3. Toselect the functions you want to edit, select them in the Function list.

Parameter Description

Function List

When selecting a layer in the Timeline view, all the corresponding functions are
displayed. Select all the functions you want to see and edit; hide the ones you
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don't.

Display Toolbar

The Display toolbar allows you to modify how the editing area is displayed. You
can hide the grid, disable the synchronization with the current frame, reset the
zoom level and normalize the function display by stacking them one over the
other to compare them regardless of their value range.

Current Frame

Displays the current scene frame.

Selected Keyframe Value

Displays the value of the selected keyframe.

Display Advanced Parameter
Values

Displays the Projection, Bias, Tension and Continuity parameters to adjust the
curve around the selected keyframe.

Keyframe, Velocity and Inter-
polation Options

This toolbar lets you add and delete keyframes, adjust the velocity curve, adjust
the segments to motion or stop-motion keyframes and set the velocity to create
steps instead of a constant progression.

Function Types

This toolbar lets you click on the different function types to enable or disable all
the listed functions of that type.

Value Scale

Displays the value range for the displayed editing area. It can be referenced to
know the value of a keyframe.

Selected Keyframe

The selected keyframe is displayed in red. When selected, the keyframe values
are displayed in the corresponding fields.

Bezier Handles

The Bezier handles let you adjust the ease in and ease out of each keyframe. The
more the handle is pulled out horizontally, the slower the animation will be. The
more the handle is pulled out vertically, the faster the animation will be.

Function Curve

The thin line going from keyframe to keyframe is the actual curve. The section of
a curve located between two keyframes is called a segment.

Frame Scale

The Frame Scale displays the frame range for the displayed editing area. It can be
referenced to know the current frame of a keyframe.

Modifying a Path in the Xsheet View

If you are prefer working with the Xsheet view, you can also create keyframes and type values in the Xsheet

view.

You cannot create function curves directly in the Xsheet view. You must do this in the Layer Properties window or

the Timeline view.

To edit a function column in the Xsheet view, you must first display the Functions section of the Xsheet view and
then select the layer you want to modify. If you double-click on a function column's header, you will display the
corresponding function curve in the Function editor.

How to display the function columns in the Xsheet view

1. Inthe Xsheet view, click the Expand button located on the right side of the main section to show the Func-

tions section.
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2. Inthe Timeline view, select the layer that contains the parameters to modify.

The columns appear in the Xsheet view if function curves were previously created by adding keyframes in the
Xsheet view or Layer Properties window. Otherwise, the columns do not appear.

Drawing Drawing

Scale_x Scale_y

L1 0.000 L1 1.000 L1 1.000

How to add a keyframe in the Xsheet view

1. Inthe Xsheet view, go to the function column on which you want to add a keyframe.

2. Double-click on the cell on which you want to add a keyframe and type a numeric value.

L 0.000 L 0.000 L 0.000

3. Press Enter/Return to continue to the next cell.

4. Press Esc to exit the typing mode.

L 0.000 L 0.000
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How to convert a cell into a keyframe

1. Inthe Xsheet view, go to the function column on which you want to add a keyframe.

2. Select the cell to convert.

4. Toremove a keyframe, select the keyframe, right-click on the cell and select Clear Keyframe in Selec-
tion or press F7.

Function Curves

By default, when a drawing layer or peg is added to a scene, no function curves are created. You will generally
create the ones you need to avoid being overloaded with too many functions you might not use.

When you select an element in the Camera view and move it around, it will automatically create the
corresponding function curves. If you need to create certain functions manually, you can always do it through the
Layer Properties view or editor. You can then share it with other layer parameters or set keyframes directly on the
function curve instead of doing it in the Timeline or Camera view.

You can also link alayer's parameter to an existing function curve or attach several parameters to the same
function curve. For example, if you have an aircraft performing loops between clouds, you may want the camera
to follow the aircraft's motion path. If you attach the camera to the aircraft's layer, the camera will also loop, but
this may produce undesirable results and even induce a feeling of motion sickness as you watch the final
animation. Instead, you can share the X, Y and Z positions of the aircraft with the camera's peg layer, but ignore
the angle, scale and skew.

By default, all function curves can only be used and modified using their original parameter. If you want another
layer or parameter to use the same function curve, you must share it.

There are two ways to share a function:
» Share Functions command
» Layer Properties editor

When you create a function curve in the Layer Properties view or editor, there are several choices available:
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Parameter Description

Create 3D Path Creates a new 3D Path Column set

Create Bezier Creates a new Bezier curve

Local Disconnects the parameter from any function and changes it to shared.
3D Path Displays the list of every shared 3D Path function available
Bezier Displays the list of every shared Bezier curve available
Velobased Displays the list of every shared velocity based curve available
3D Rotation Displays the list of every shared 3D Rotation function available
Connected Displays the list of every shared connected function curve
Unconnected Displays the list of every shared unconnected function curve
All Displays the list of every shared function curve

You have the choice of creating a new function curve or linking it to a shared function. This way, you can have two or
more parameters following the same function.

Depending on your favourite working method, you can create different types of function curves to suit your needs,
including:

* Bezierfunction
» Velobased function

When you create a function to control a parameter over time (Scale, X, Y, Z, Rotate), you can use a Bezier function.

Bezier function

These function editors present different ways of editing the values over time. The shape of the created graph
indicates the velocity of the function, regardless of the chosen editor. The type of function that you choose is largely
based on your working preference.

You can also create Velobased functions for certain effects, like changes in rotation or size over time. When you do
this, the Velobased functions are linked to the velocity of a 3D path. You cannot change the shape of a Velobased
function to control its velocity.

With Velobased functions, you can link changes in rotation or scaling to the velocity of a 3D path. This makes it
possible for changes in rotation or scaling to progress at the same speed as changes to the position of an element.
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You can convert a Bezier functions so you can edit it using the controls offered by that type of function.
How to create function curves

1. Inthe Timeline view, double-click on a layer.

Transformation

osition

2. Inthe Transformation tab, click the Function Arrow button beside the local function information.

3. Create a 3D Path, Bezier, or Velobased curve.
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Rotation

Local

You can click the Function _ button to open the Function editor.

How to share a function using the Layer Properties editor

1. Inthe Timeline view, double-click on the layer that contains the function to share.

The Layer Properties window displays.

2. Inthe Transformation tab, click the Arrow button beside the function you want to share and select Local.

Transformation

Local

The function is shared with the other layers and parameters.

Shared functions are visible in the main section of the Xsheet view.
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3. From the same menu in which you chose the Bezier option (in our example), select the function you just
shared and attach it to your parameter.
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Rotation

4. Inthe Timeline view, open the Layer Properties editor of the other layer that contains the parameters you
want to link to the shared function.

5. Inthe Layer Properties editor or view, attach the parameter to the shared function the same way you did for
the first layer.

The two parameters are both linked to the same function curve and follow the same path. If you modify the
curve, both parameters will update.

Copying and Pasting a Motion

In the Timeline view, you can easily drag keyframes to change the animation timing, delete them, cycle them and
even copy them.

As you animate, you will find that you reuse many positions, drawings, and keys. However, you may only want to
paste the drawings or just the keys or maybe everything. There are different paste options available in the
Timeline view which give you maximum flexibility when reusing and pasting.

Note that these modes also apply when you drag instead of copying and pasting.

There are three different modes for pasting your selection:
+ [ Paste Mode: All Drawing Attributes: Pastes the drawing exposure and keyframes.
. Paste Mode: Keyframes Only: Pastes only the keyframes.
. Paste Mode: Exposures Only: Pastes only the drawing exposure.

When you have position keyframes set in your drawing layer and you want to move them around when moving
your drawing's timing, you can use the Paste Special feature to only move selected keyframes.

You can also use the Paste Cycle and Paste Reverse feature to cycle your selection including keyframes and
drawings.

If you want to cycle a portion of your animation, you can use the Paste Cycle command. You can also use the
Paste Reverse command to completely reverse the flow of your animation.

How to copy and paste a motion using Paste Special

1. Inthe Timeline view, select the keyframes to copy and paste. If you want to move the keyframes, go to
step 3.
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2. From the top menu, select Edit > Copy Cells from the Timeline or press Ctrl + C (Windows/Linux) or 3£ + C
(Mac OS X).

3. Edit your selection by doing the following:

» To paste the selection, in the Timeline view, select the first cell on which you want to paste your
keyframes and from the top menu, select Edit > Paste Special or press Ctrl + B (Windows/Linux) or 3£ +
B (Mac OS X).

» Tomove the selection, in the Timeline view, drag the selection and hold down Alt (Windows/Linux) or &5
(Mac OS X). Drop the selection where you need it and release the hot key.

The Paste Special window opens.

4. Setthe Drawing, Pegs and Functions, and Cycles parameters.

5. Click OK.

How to open the Paste Special dialog box

1. Inthe Library view, select the symbol or template to import.

2. While dragging the selection to the Timeline view, hold down the Alt (Windows/Linux) or 3£ (Mac OS X). Drop
the selection in the Timeline view before releasing the hot key.

The Paste Special window opens.

3. Set the parameters.
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How to cycle a portion of an animation

1. Inthe Xsheet or Timeline view, select the cell range and keyframes to loop.
2. From the top menu, select Edit > Copy Cells from the Xsheet/Timeline.

3. Inthe Xsheet or Timeline view, select the cell on which you want the cycles to start.

4. From the top menu, select Edit > Paste Cycle or press Ctrl + / (Windows/Linux) or 38 +/ (Mac OS X).

The Paste Cycle dialog box opens.
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5. Inthe Number of Cycles field, increase or decrease the number of cycles you want to paste.

6. Inthe Cycle Type, select the type of cycle to paste.

» Normal (forward): Pastes your selection as it is, starting with the first cell and ending with the last.
» Reverse: Pastes your selection reversed, starting with the last cell and ending with the first.

» Forward > Reverse: Pastes your selection as a yo-yo, starting with the first cell, going to the last one
and ending with the first cell.

» Reverse > Forward: Pastes your selection as a reversed yo-yo, starting with the last cell, going to the
first one and ending with the last cell.

How to reverse the animation flow

1. Inthe Xsheet or Timeline view, select the cell range and keyframes to paste inverted.

2. From the top menu, select Edit > Copy.
3. Inthe Xsheet or Timeline view, select the cell on which you want the cycles to start.

4. From the top menu, select Edit > Paste Reverse or press Ctrl + . (Windows/Linux) or &£ + . (Mac OS X).
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Paste Special Options

Basic Tab

Parameter

Description

Drawings

Only create drawing
files when they do not
exist

When adding exposures to a drawing layer, new drawings will be created only
when drawings with the same name do not already exist in the destination.

Always create drawing
files

When adding exposures to a drawing layer, new drawings will always be cre-
ated. If drawing files with the same name already exist, Harmony will create a
new name for the drawing.

Paste all Frames of the
Symbols (full movie)

When enabled, the Paste Special command exposes all the symbol's frames
instead of only the first one.

Enforce Key Drawings

Creates a key exposure on the same drawing.

Cycle

Number of Cycles

Lets you set the number of cycles.

Cycle Type

Normal (forward): Pastes your selection as is, starting with the first cell and
ending with the last.

Reverse: Pastes your selection in reverse, starting with the last cell and
ending with the first.

Forward > Reverse: Pastes your selection as a yo-yo, starting with the first
cell, going to the last one and ending with the first cell.

Reverse > Forward: Pastes your selection as a reverse yo-yo, starting with
the last cell, going to the first one and ending with the last cell.
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Advanced Tab

Parameter Description
Drawings
Do Nothing Does not create or overwrite drawings.
Revises the drawing pivot in the destination to use the same drawing pivot as the
Update Drawing Pivot | first drawing in the template. If you have a range of drawings selected in the

destination, the pivot points of all selected drawings will be updated.

Add/Remove Exposure

Never create drawing files: When adding exposures to a drawing layer, drawing
files will not be created.

Only create drawing files when they do not exist: When adding exposures to a
drawing layer, new drawings will be created only when drawings with the same
name do not already exist in the destination.

Replace existing drawings. Create drawing files when they do not exist:
Replace drawings with the same names to update a scene with new modified
drawings and preserve the animation.

Tip: If you don't want to lose the existing animation when pasting a
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template, such as when placing new drawings after the animation,
then delete the template's animation. It will still have updated the
drawings but not override the existing animation.

Always create drawing files: When adding exposures to a drawing layer, new
drawings will always be created. If drawing files with the same name already
exist, Harmony will create a new name for the drawing.

Paste all frames of the symbol (full movie): When enabled, the Paste Special
command exposes all the symbol's frames instead of only the first one.

Enforce Key Exposure: If there are key exposures that exist on copied draw-
ings, they are preserved when pasting. No key exposures are added. This is the
default behavior when pasting.

Fill Gap with Previous Drawing: Fills selected area in the Xsheet or Timeline
view with the previous drawing.

Fill to Next Key Exposure: Fills selected area till the next key exposure.

Add Remove/Keyframes

Motion Copies the properties of the selected motion keyframe to the new frame.
Velocity Copies the properties of the selected velocity keyframe to the new frame.
Rotation Copies the properties of the selected rotation keyframe to the new frame.
Scale Copies the properties of the selected scale keyframe to the new frame.
Skew Copies the properties of the selected skew keyframe to the new frame.

Force Keyframes at
Function's Beginning
and End

Adds a keyframe to the beginning and end of the pasted function, reproducing the
source function.

Offset Keyframes

When pasting functions, offsets keyframes from the function's last frame value
by the values in the pasted function. This will continue the progression of a func-
tion instead of repeating the values.

Options
Do nothing: Does not create, overwrite, merge or link palettes.
Reuse palettes. Copy palettes if they do not exist: Palettes in the destination
drawings are left as they are.
Copy and overwrite existing palettes: Overwrites destination palettes with the
palettes from the source drawings.
Copy and create new palette files: Creates new palette files, placing them at

Palettes the same relative environment and scene level as the source. If the palettes in the

templates were stored at the environment level of the source scene, the paste
operation will place the palettes in the environment level of the destination scene.

Copy and create new palette files in element folder: Creates new palette files
in the element folders of the destination scene, rather than in the same relative job
or environment.

Copy palette and merge colours. Add new colours only: Adds new colours to
the destination palettes and ignores colours that are the same in the two palettes.
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Copy palettes and update existing colours: Adds new colours to the
destination palette and updates duplicate colours in the destination with colour
values from the source.

Link to original palettes (colour model): Links the colour palettes in the
destination scene to the palettes in the source. Use this to link drawings to the
palettes in a colour model.

Copy scene palettes and merge colours. Add new colours only: Adds new
colours to the destination scene palettes and ignores colours that are the same in
the two palettes.

Copy scene palettes and update existing colours: Adds new colours to the
destination scene palette and updates duplicate colours in the destination with the
colour values from the source.

Symbols

Copy symbols if they do not exist: This is the default setting for this operation
and will prevent Symbols in an Action template from being copied.

Duplicate symbols: Creates a duplicate of the symbol instead of linking the Sym-
bol instance to the original one. The new Symbol is created in the Library.

Cycles

Normal (forward):Pastes your selection as is, starting with the first cell and end-
ing with the last.

Reverse: Pastes your selection in reverse, starting with the last cell and ending
with the first.

Forward > Reverse:Pastes your selection as a yo-yo, starting with the first cell,
going to the last one and ending with the first cell.

Reverse > Forward: Pastes your selection as a reverse yo-yo, starting with the
last cell, going to the first one and ending with the last cell.

Nodes

Create New Columns: A new column is created when you copy and paste
nodes from the layer in the Timeline view. If the layers are linked to function
curves, the function curves, drawings and timing will be duplicated.

Elements

Reuse existing elements: Lets you paste existing elements without creating
new ones. This should be used only when pasting within versions of the same
scene.

Adjusting the Velocity

To add ease in and ease out on motion paths, you can display the function curve and modify the Bezier or Ease
curve. To apply ease to multiple functions and keyframes, you can use the Set Ease For Multiple Parameters script

and set the amount.

The Velocity, or ease, is used on motion keyframes. The Velocity must be adjusted directly on the function curve in
the Function view or Function editor. When a keyframe is selected, easing values appear in the right handle and left
handle fields, as well as Bezier handle or Ease wheel controls on each selected keyframe. Pull on them to adjust the
ease in and ease out, or type values in the fields.

You can reshape the velocity function using Bezier controls.
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You can create a stepped curve to hold the same value over a selected number of frames. This works well when
you are animating drawings on 2s, for example, and you want to hold the same value for a function over those two
frames.

If you have several functions whose velocity you want to adjust at the same time, you can use the Set Ease for
Multiple Parameters dialog box. It allows you to apply the same velocity parameters to all the selected keyframes
in the same frame.

How to display the velocity curve

1. Inthe Timeline view, click the Expand * button on a layer or press Alt + F.

The layer’s functions are displayed.

2. Double-click the desired function.

The Function Editor opens as the Bezier Editor.
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Bezier Editor =

The editor will not be displayed if the function does not already exist. You can reshape the function using the
Bézier controls.

How to reshape a function using Bézier controls

1. Select a keyframe.
2. Drag the handles to modify the shape of the curve.

3. The Continuity options influence how you can move the handles:

» Straight: Lets you move the handles together, maintaining the same angle to the point.
» Corner: Lets you move the handles independently.
» Smooth: Lets you move the handles together, maintaining the same distance and angle to the point.

How to reshape the function using Ease controls

1. Select a keyframe.

2. To set the number of frames in the ease-in, press Alt, click to the right of the keyframe and drag the green
line. The ease in slope is indicated in blue.
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As you change the values visually, the value in the Ease In field is updated. This value represents the
number of frames in the ease-in.

3. To set the number of frames in the ease-out, press Alt, click to the left of the keyframe and drag the green
line. The ease-out slope is indicated in red.

As you change the values visually, the value in the Ease Ouit field is updated. This value represents the
number of frames in the ease-out.

4. To adjust the ease-in or ease-out, drag the handles around the keyframe.

The Continuity options, Corner and Straight, influence how you can move the handles:
» Straight: Lets you move the handles together, maintaining the same angle to the point.
» Corner: Lets you move the handles independently.

How to hold the same value over several frames

1. Click the Hold Value Editor button.

The Hold Value editor opens.

2. Inthe Hold Value Editor, enter the following values:

» Start: The starting frame for the effect.
» Stop: The last frame for the effect.
» Step: The number of frames to hold the value.

The function curve is updated based on the values you entered.

You can reshape the curve to create a linear velocity, so the values are interpolated (tweened) consistently
between keyframes. That is, there is no acceleration in the effect.

How to set the ease on multiple parameters

1. Inthe Timeline view, select a keyframe on one or more layers.
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NOTE: Only the first selected keyframe will be considered when using the Set Ease For Multiple Parameter function.
If many keyframes are selected on the same layer, the ease values will be applied only on the first keyframe and the
rest will be ignored.

2. Do one of the following:

» Inthe Timeline view, right-click and select Set Ease For Multiple Parameters.
» Inthe Timeline toolbar, click the Set Ease For Multiple Parameters =~ button.

The Set Ease For Multiple Parameters dialog box opens.

3. Inthe graph, adjust the Bezier handles to change the velocity for all the selected functions.

O

'/fo 15 20 25 0

4. Inthe Filters section, you can apply the easing parameters to a specific type of function only, such as Rota-
tion or Scale. Deselect the function types you do not want to affect.

» Motion: Applies the easing parameters to the selected Position X, Position Y, Position Z and 3D Path
functions.

» Rotation: Applies the easing parameters to the selected Angle functions.

» Scale: Applies the easing parameters to the selected Scale functions.

» Skew: Applies the easing parameters to the selected Skew functions.
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>

Morphing: Applies the easing parameters to the selected Morphing Velocity functions. Note that it
applies to the Morphing velocity function found in the Layer Properties window, not the basic morphing
ease in the Tool Properties view.

Other: Applies the easing parameters to all the other the selected functions, such as all functions
created to animate effect parameters.

5. You can also adjust the easing by typing values in the Time and Value Ratio fields. The values are cal-
culated in percentage.

>

In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding to the
length of time you want the easing to last. Stay between 0% and 100%. If you go beyond 100%, your
motion will overshoot.

In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong you want
the easing out to be. Stay between 0% and 100%. If you go beyond 100%, your motion will overshoot.

If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

6. Once done, click one of the following:

>

Apply/Previous: Applies the easing parameters to the selected keyframes and then selects the
previous keyframe in the timeline.

Apply: Applies the easing parameters to the selected keyframes.

Apply/Next: Applies the easing parameters to the selected keyframes and then selects the next
keyframe in the timeline.

Close: Close the dialog box. If you did not apply the modifications, they will be cancelled.

How to set the ease in the Timeline view

1. Inthe Timeline view, select a keyframe on one or more layers.

NOTE: Only the first selected keyframe will be considered when using the Set Ease For Multiple Parameter
function. If many keyframes are selected on the same layer, the ease values will be applied only on the first
keyframe and the rest will be ignored.

2. Inthe Timeline toolbar, select an option from the Set Ease Type menu.
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Set Ease Type menu

NOTE: TIP: Optimize your workflow by adding the Apply Ease to Selection -~ button to the Timeline toolbar. This

lets you quickly reapply the ease type without going through the Set Ease Type menu each time. To add the button to
the toolbar, right-click on the toolbar area of the Timeline view and select Customize.
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Chapter 6: Sound

With Harmony, you can import soundtracks and dialogue into your animation. There are several sound editing
features you can use to synchronize sounds to individual frames or moments in time. You can also edit them to trim
unwanted seconds from the beginning and end of your sound files, as well as loop sounds that you want to continue
throughout your animation.

Your ability to add dialogue to animation is greatly enhanced with the Harmony automatic lip-sync detection.
Harmony can analyze voice tracks to determine which of the eight animation phonemes (lip positions) would best
apply to each frame of sound. With the mouth chart that is generated, you can easily draw lip positions for your
character. Furthermore, Harmony can automatically apply drawings of lip positions to each frame of your animation
based on the mouth chart.

This chapter contains the following topics:

» Importing a Sound File on page 207

» Sound Layer Properties and Sound Element Editor on page 208

* Sound Displays on page 209

» Sound Playback on page 210
» Sound Scrubbing on page 211

» Editing a Sound File on page 214

» Adding an Empty Sound Layeron page 221
Importing a Sound File

If you decide to add sound to your animation, you must first prepare the sound outside of Harmony. Once this is
done, you must add a sound element in Harmony to the organize the sound files in your animation. Sound will play in
the movie until it reaches the end of the file or a stop frame that you created in the Sound Element Editor.

If you first create your project in Toon Boom Storyboard Pro, the sound will be cut up into the different scenes for you
automatically.

You can import .wav, .aiff or.mp3 sound files.
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How to import a sound file

1. Do one of the following:

» From the top menu, select File > Import > Sound.

» Inthe Xsheet view, right-click anywhere in the frame area and select Import > Sounds.
» From the Xsheet menu, select File > Import > Sounds.

» From the Timeline menu, select Import > Sounds.

The Select Sound File dialog box opens.

2. From the Select Sound File dialog box, find and select a sound file.

The sound file appears as a layer in the Timeline and Xsheet views.

Different views of the same sound file

| Kalimba.mp3

Sound Layer Properties and Sound Element Editor

When you select a sound layer in the Timeline view, the options related to that layer appear in the Layer
Properties view and in the Sound Element editor when you double click on the layer.

Lip chartin layer properties window

Mute/Unmute

Layer name

Sound Editor

Start Frame/End Frame

Detect Map

Mouth shapes
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Sound Element Editor @

| ayer name

e \louth shapes

m== Start Frame/End Frame

¢ Mute/Unmute: This button mutes and unmutes the sound layer during the scene play back.
* Layer Name: This field displays the layer's name.

* Sound Editor: This button opens the Sound editor.

» Start Frame/End Frame: These fields determine the start and end frame of the sound file.

* Detect: This button launches the automated lip-sync detection.

* Map: This button opens the Map Lip-sync dialog box.

* Mouth Shapes: This section shows the automated lip-sync detection during the scene play back. Click on the
thumbnail image of each mouth to change the phoneme assigned to the current frame.

Sound Displays
Within the Xsheet view, you can display the sound file in different ways, depending on your sound editing needs.

You can show or hide the waveform in the Timeline view by selecting the Waveform button in the Timeline View
toolbar. You must customize the toolbar to display this button because it is not included in this toolbar by default.

How to change the sound display in the Timeline view

1. Inthe Timeline view's right area, right-click in the frame section and select Show Sound Waveforms or in
the Timeline view menu, select View > Show > Show Sound Waveforms.
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» You can change the waveform scale using the Zoom Waveform ¢ icon on individual sound layers in
the Timeline view's left side.

How to change the sound display in the Xsheet view

1. Right-click in the sound column or on the sound column header, and select Sound Display and one of the
following:

» Sound Name: Shows the name of the sound file, as well as the file format. The line running vertically
through the column frames between the same file name indicates a continuity of the same sound file in
these frames.

» Mouth Shapes: Shows the letter (or name depending on the way you named your character's different
mouth positions) in the column's frames. There is only one mouth position allotted per frame and this
position should correspond to the sound file after performing a lip-sync.

» Waveform: Shows a vertical display of the sound file's actual waveform. In the column header, in the
field under the column name, you can type in a percentage to zoom in or zoom out on the waveform, or
pass the scroll cursor ‘¥ over the Zoom Waveform ¢, icon.

Lox

Sound Playback

Before playing back any sound, click the Enable Sound «, button in the Playback toolbar or enable it through the

Play menu (in the top menu). This will ensure that you can hear the sound layers in your scene, even the ones
included within symbols.

If there are two or more sound layers and you want to listen to them independently, you can disable the unwanted
sound by clicking the Disable Layer button on the sound name layer in the Timeline view.

If you are trying to do a playback with sound and the frame rate doesn't reach 24 fps (frame per second), you can
do one of the following to troubleshoot the issue:
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« Shrink down the Camera view size to reduce the cached image size.

« Playback your scene without sound first, then add the sound. If you do not cache the imahes first without

sound, the playback will try to follow the sound by skipping images that will never get cached.

« Inthe Preferences panel, in the OpenGL tab, reduce the size of the Playback Cache Size (in mb) preference.

How to play back sound

1.

To select a starting point:

» Inthe Xsheet view, click on a cell in the sound column.

» Inthe Timeline view, click on a cell in the sound layer. You can also slide the red playhead to the correct
cell.

In the Playback toolbar, activate the Enable Sound , button.

Do one of the following:

» Clickthe Play » buttoninthe Playback toolbar.

» From the top menu, select Play > Play or click on the Enter/Return key.
To hear the sound played back again and again, do one of the following:

» Click the Loop o button in the Playback toolbar

» From the top menu, select Play > Loop.

To mute soundtrack, on the left side of the sound layer, click the Disable Layer button.

Sound Scrubbing

Harmony uses a process known as Sound Scrubbing to let you hear sound in real-time while you move the playback
pointer forward or backward. This is very useful for finely-tuned lip-synching. You can scrub sounds from the
Timeline view.

How to scrub a sound from the Timeline view

1.

Do one of the following:

» From the top menu, select Play > Enable Sound Scrubbing.
» Right-click in the frame bar of the Timeline view and select Play > Enable Sound Scrubbing.
» Inthe Playback toolbar, enable the Sound Scrubbing s button.
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2. Atthe top of the Timeline view, drag the red playhead to hear the sound at each frame.

-

3. Inthe Playback toolbar, you can use the jog slidder to playback forward and backward subsequent sound
frames. This allows you to do a more fluid scrubbing.

Analog Sound Scrubbing

Harmony is set to the digital sound scrubbing mode by default. This means that all sounds are played in real time.
It also means that as you scrub over a frame, you will hear the section of your sound file that is allotted to that
frame. As you are scrubbing, although it is accurate, the sound can sound clipped. It can also be difficult to hear
nuances in pitch and tone.

Harmony has an analog sound scrubbing option. When sound scrubbing in this mode, the sound is played back

according to the speed that the playhead or jog is manually adjusted. Harmony's interface offers shuttle and jog

sliders to perform analog sound scrubbing, however, external hardware and their corresponding software can be
used in conjunction with Harmony for improved analog sound scrubbing results.

Jog

Shuttle

Contour Shuttle Pre, an example ofan
external sound scrubbing controller.
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NOTE: Refer to the device's manual to configure its functionality with Harmony.

Performing an Analog Sound Scrub in Harmony

Before you can perform an analog sound scrub in Harmony, you have to learn about the Shuttle and Jog controls.

Your speed in fps will
Shuttle appear in this area.

Jog

Shuttle: Pull the Shuttle control backward or forward to make the red playhead in the Timeline view jump by
large increments in the direction you are moving the shuttle.

Jog: Drag the Jog control to make the "dial" rotate. The Jog controls finer incremental movements along the
soundwave. Use the Frame field to see the frame number which you are on. As you rotate the dial, your
speed in fps appears directly after the FPS field.

How to perform an analog sound scrub

Do one of the following:

» From the top menu, select Play > Enable Sound Scrubbing.
» Right-click in the frame bar of the Timeline view and select Play > Enable Sound Scrubbing.
» Inthe Playback toolbar, enable the Sound Scrubbing «s button.

In the top menu, select Edit > Preferences (Windows) or Stage Advanced > Preferences (Mac OS X).
In the Sound tab, select the Analog Sound Scrubbing option.
Click OK.

Do one of the following:

» Inthe Playback toolbar, use the Shuttle to find the general location of where you want to start your sound
scrub.

» Inthe Timeline view, drag the red playhead to the desired location.

In the Playback toolbar, use the Jog to fine-tune your scrub to just a few frames.
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Editing a Sound File

Now that you have successfully imported a sound file into Harmony, it is time to familiarize yourself with the

sound editing interface. The Sound Element editor makes it possible to edit sounds that were created outside of
Harmony and imported into your scene.

How to open the Sound Element editor

1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.
The Sound Element Editor dialog box opens.

Sound Element Editor @

The Sound Element editor consists of three main parts.
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Sound Element Editor @

Sound

Element )
| Lipsync
Preview

| Current
Sound

» Sound Element: The waveform in the Sound Element Editor is the actual sample that will be heard when
the final movie is rendered. It may be shorter than the original sound sample due to the length of the
scene. If any edits are made to the sound sample, they can be heard here. In the Sound Element panel,
notice the coloured tabs that indicate the start and end frames of a sound segment. The frame number is
displayed in the tab.

» Current Sound: Displays the original sound file in its entirety and is where you can edit its properties.
This window remains empty until you click inside the Sound Element Editor.

» Lip-sync Preview: Lets you preview the automated detection and to manually insert different mouth
positions to correspond with the sound sample.

You can accomplish the following tasks in the Sound Element Editor:

Changing the Start or End Frame of a Sound on page 215

Trimming the Start and End of a Sound File on page 217

Looping a Sound on page 218
Mixing the Sound Volume on page 219

Customizing the Playback Range on page 220

Changing the Start or End Frame of a Sound

To synchronize the sound with specific images in your scene, you must set a start frame for your sound. To make
sure the sound ends by a certain frame, you must set an end frame.

In the Sound Element panel you will see some coloured tabs, these tabs represent the frames. The frame number is
shown inside the tab flag marker. These tabs indicate the start and end frames of a sound segment.
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How to change start or end frame of a sound

Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

2. Inthe Sound Element editor, select a sound sample from the Sound Element section. To distinguish one
sound section from another on the same sound layer, check the frame numbers that appear on tabs

flanking the start and stop lines of each waveform section.

Sound Element Editor @

Click the Play » button in the Current Sound section (only the selected sound plays).

Frame numbers are
indicated inside coloured tab
like these.

1. Within the Sound Element panel, drag the selected clip to the frame number where you want it to start play-

ing.

You can only move the clip to a section that does not already contain a clip; you cannot overlap two clips in

the same element.

2. Tochange the end frame, drag the yellow marker at the end of the waveform to the frame position.
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3. To hear how all the clips fit together in the element, click the Play » button in the Sound Element section.

I AT R T O DO S S Y

4. Click Apply/Next.

The Xsheet and Timeline views display the sound clip at the start frame you selected.

Trimming the Start and End of a Sound File

To play only a section of a sound file, use the Sound Element editor to select the exact part you want to use. For
example, if there is a bit of noise at the start of the sound, use the Sound Element editor to cut the noise.

The Sound Element Editor does not change the original sound file; it only plays a section of it, ignoring the rest. This
means that the entire sound file is included on export. If you need to be mindful of file size, it is better to edit sound
files completely in a sound editor before bringing them into Harmony.

How to trim the start and end of a sound file

1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

2. Inthe Sound Element editor, select a sound sample from the Sound Element section. To distinguish one
sound section from another on the same sound layer, check the frame numbers that appear on tabs flanking
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the start and stop lines of each waveform section. Or select a soundwave and click the Play » buttonin
the Current Sound panel (only the selected sound plays).

1. Using the Current Sound section, decide on the part of the file you want to play by dragging the left and
right boundaries of the selection area.

2. Clickthe Play p button inthe Current Sound section to check that you have trimmed the desired sec-

tions. Use the Zoom slider at the bottom of the panel to zoom in on the waveform so you can trim it more
accurately.

3. Click Apply/Next.

The trimmed sound sample appears in both the Timeline and Xsheet views at the start and end positions
you selected.

Looping a Sound

To repeat a sound, specify the number of times that you want it to loop in the Sound Element editor.

How to loop a sound sample

1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.
1. From the Sound Element section, select the sound section you want to loop.

2. Inthe Current Sound section, type the number of times you want the sound to play in the Number of Loops
field.
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3. Press the Enter/Return key.

The looped sound appears after the current sound. They are indicated by their grey waveforms, as opposed to
black.

When you loop a sound, the looped sections fill the cells in the sound element (column or layer) until the next
sound sample starts or until the scene ends. This means that the looping could be cut if the next sound
sample starts too soon or if the scene ends too quickly.

Mixing the Sound Volume

You can adjust the volume of an entire sound clip or modify the volume in increments by adjusting the fade-in and
fade-out times, otherwise known as sound envelopes. The fade edit only affects the playback; the original sound file
is not affected.

How to adjust the overall volume of the entire sound clip
1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

1. Inthe Sound Element section, select the sound you want to work on.

A more detailed version of the selected sound appears in the Current Sound section.

2. Inthe Current Sound section, use the Volume slider to adjust the volume.

1

3. Click the Play p buttoninthe Current Sound panel to verify the volume.

How to create the fade in/out effect on a sound clip
1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

1. Inthe Sound Element section, select the sound you want to work on.
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2. Inthe Current Sound section, click on the thin blue line above the waveform to add an envelope marker.

{ |

3. Drag the envelope markers to adjust the volume at that frame and to create the time of the transition. The
line from the edge of the clip to the envelope marker identifies how the volume increases (fades-in) or

decreases (fades-out) over time.

Dragging the marker to the bottom of the channel mutes the volume, while dragging it upwards increases
the volume.

NOTE: To create an even effect, be sure to adjust the envelope markers uniformly in both the left and right (bottom
and top) channels.

4. Click the Play » buttoninthe Current Sound panel to check the fade envelopes.

Customizing the Playback Range

To hear a specific section of the sound element, adjust the playback range in the Sound Element editor to start or
stop at specific frames. This customized playback range does not affect the actual sound in the Sound element.

How to change the playback range in the Sound Element editor

1. Drag the start or end range markers in the Sound Element section to the boundary frames you want.
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2. Whenyou click the Play » button to play back your sound in the Sound Element editor, it only plays the
sound which exists between the two markers.

WCEE T T R SO

Adding an Empty Sound Layer

When performing sound editing tasks, it can be useful to chop up a sound sample into different layers. For example,
when performing a lip-sync, only a single view of the various mouth positions for a character can exist on one layer.
Therefore, if you want to have a character turn its head from a profile view to a three-quarter view and have mouth
position changes to fit with the sound sample from these two different views, you would need to cut up the sound
samples needed for the profile view mouth positions on one layer and the sound samples needed for the three-
quarter view on another.

For this task, you will need an empty sound layer.

How to add an empty sound layer

1. Inthe Timeline Layer toolbar, click the Add Layer button.

2. From the drop-down menu, select Sound.

An empty (silent) sound layer appears in both the Timeline and Xsheet views.

3. Rename the layers accordingly by double-clicking on the layer name and renaming it in the Sound Element
editor. Click Apply/Next to accept the change.
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1. Inthe sound file you want to grab sounf frames from, click the cell where you want to start the cut and Shift
+ click on the final cell of the cut. The sample to be cut becomes highlighted.

2. Drag the selection into the empty sound layer below.

4. You can now continue to cut-up and distribute the sound sample between the two layers or carry on to the
lip-synching process for each layer and its corresponding facial view.

NOTE: If you need to duplicate your sound layer to keep an unedited copy for safety, select the Duplicate Selected
Layers button in the Timeline View toolbar. You must customize the toolbar to display this button because itis not
included in this toolbar by default.

Lip-sync
=~ -~ - = = \)
\
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Adding a lip-sync to a project can really enhance its quality and storytelling. However, it can be difficult to shape a
character's mouth to match the sound at a precise frame.

To solve this problem, Harmony provides a lip-sync feature which analyzes the contents of a sound element and
generates a mouth chart (see below) based on the eight animation phonemes (A, B, C, D, E, F, G, and X for silence).

The mouth shapes used by Harmony are based on the conventional mouth chart used in the animation industry.

NOTE: The letters used to represent the shapes do NOT correspond to an actual sound.

NOTE: If you are doing cut-out animation, refer to the Cut-out Animation Guide, Character Building chapter, "Adding
Extra Drawings" topic to learn how to add extra drawings to your character.

//:/; /\ - /i 5 7,/ N
o \

A B C D
;- S Y
N 1 N ;;}_A\ L:_——a
E F G X
(
Extra mouth

Here is an approximation of the sound each mouth shape can produce:

 Am,b,ph

* B:s,d,j,ik,t
+ C:ea

- D:AE

+ E:o

e F:uy, 00

« G:f,ph

» X: Silence, undetermined sound
You can lip-sync the traditional way or let the system automatically create the basic detection.
You can refer to the mouth chart positions as you draw the shape of the character's mouth.
Generating a Lip-sync Detection

There are several places where you can perform a lip-sync detection: Layer Properties view, Timeline view, Xsheet
view and Sound Element editor.
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How to generate a sound detection for lip-sync using the Layer Properties view

1. Inthe Timeline or Xsheet view, select the sound layer.

The options for that layer will appear in the Layer Properties view.

2. Inthe Layer Properties, click Detect.

Layer Properties == (%

Sound Editor

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to
each sound cell.

3. Click the Map button to open the Lip-Sync Mapping dialog box.

4. From the Destination Layer menu, select the layer that contains the mouth positions for the character's
voice track.
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5. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on the layer
or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to use the
drawings or select the desired symbol from the drop-down menu.

6. Inthe Mapping section, type the drawing name or Symbol frames in the field to the right of the phoneme it rep-
resents. If your drawings are already named with the phoneme letters, you do not have to do anything.

7. Click OK.
8. PressthePlay » buttoninthe Playback toolbar to see and hear the results in the Camera view. To play

back your scene with sound, enable the Sound - button in the Playback toolbar.

How to generate a sound detection for lip-sync in the Xsheet or Timeline view

1. Do one of the following:

» Inthe Xsheet or Timeline view, right-click on the sound layer's cells and select Lip-Sync > Auto Lip-
Sync Detection.

» From the top menu, select Animation > Lip-Sync > Auto Lip-Sync Detection.

NOTE: To show the mouth chart letters, if they're not already present in the Xsheet view, right-click on the sound
column and select Lip-Sync > Sound Display > Mouth Shapes.

animation_hero animation_hero

e
ox
ox
B
Cox
Cox
e
ox
[

Harmony analyzes the selected sound clips and assigns a lip-sync letter to each frame. The X markers in the
frame are replaced by these designated letters.

How to generate a sound detection for lip-sync using the Sound Element editor

1. Do one of the following:
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» Inthe Timeline view, double-click on the sound layer.
» Inthe Xsheet view, double-click on the sound column header.

The Sound Element editor opens.
2. In Sound Element section, select the waveform for which you want to generate a mouth chart.

3. Right-click on the sound file and select Auto Lip-Sync Detection.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to
each sound cell.

Mapping the Lip-Sync Detection

Harmony can automatically map drawings in an element to the mouth chart you have generated for a sound. This
can save time when you are lip-synching a voice track.

In the Layer Properties view, you can identify each lip drawing of a character. Harmony then automatically labels
all of the cells in the character's element with the appropriate name.

How to automatically map lip-sync drawings to a mouth layer

1. To open the Lip-Sync Mapping dialog box, do one of the following:

» Inthe Layer Properties view, click on the Map button.

» Inthe Timeline view, right-click on any cell in the sound sample layer and select Lip-Sync > Map Lip-
Sync.

» From the top menu, select Animation > Lip-Sync > Map Lip-Sync.
The Lip-Sync Mapping dialog box opens.

226



Harmony 12.2 Advanced - Compositing and Effects Guide

Y]

{

a

2. From the Destination Layer menu, select the layer that contains the mouth positions for the character's voice
track.

3. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on the layer
or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to use the
drawings or select the desired symbol from the drop-down menu.

4. Inthe Mapping section, type the drawing name or Symbol frames in the field to the right of the phoneme it rep-
resents. If your drawings are already named with the phoneme letters, you do not have to do anything.

Modifying the Lip-sync
You can change the mouth position assigned to a frame if you think another position is more appropriate.

For example, you may have a character who says nothing for 10 frames between two speeches. Harmony would
normally assign an X image for the silent period. However, if you want your character's mouth to hang open in
astonishment for these 10 frames, you can change the lip assignment for these frames from an X toan F.

If you modify the sound detection, you will need to remap the lip-sync to your animation—see Mapping the Lip-Sync
Detection on page 226.

How to change the mouth position assignment of a sound from the Sound Element editor and Layer Prop-
erties view

1. Double-click the sound layer name in the Timeline view or the sound column header in the Xsheet view to
open the Sound Element editor.

227



Chapter 6: Sound

2.

1.

In the Sound Element section, drag the frame slider to the frame you want to change the mouth position
assignment on.

In the Lip-sync image area, the image on top represents the lip position assigned to the current frame.

To change the image assigned to the frame, click on the image of the mouth position you want from below
the preview image. The preview image changes to the mouth position image you select. You can perform
the same operation in the Layer Properties view.

The position is updated in the Timeline and Xsheet views.

How to change the lip assignment of a sound in the Xsheet or Timeline view

Right-click in the cell that contains the mouth position you want to change.

From the pop-up menu, select Lip-Sync > Change Mouth Shape to and choose the letter that reflects
the mouth position you want to use for that sound. You can also select Animation > Lip-Sync > Change
Mouth Shape > the desired mouth shape from the top menu.

NOTE: Note that if you modify the lip-sync detection you must remap the detection to your mouth layer.

Manual Lip-sync

Harmony allows for the manual swapping of mouth position drawings to match a voice track. For this process,
both sound scrubbing (listening to a sound wave broken up frame-by-frame) and drawing substitutions are used.

How to animate lip-sync using the Timeline view

1.

2.

In the Playback toolbar, enable the Sound Scrubbing s button.

In the Timeline view, drag the red playhead along the sound layer waveform.
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When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips for
an "oh" sound, click on that frame on your mouth shapes layer.

In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the drawing name
(often a letter) until it changes to the swapping ‘$ pointer.

Pull the cursor to see the list of mouth shape names and choose the one you want. The current drawing auto-
matically changes to the new selection.

How to animate lip-sync using the Library view

—_

In the Playback toolbar, click the Sound Scrubbing s button.
In the Timeline view, drag the red playhead along the waveform of your sound layer.

When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips for
an "oh" sound, click on that frame on your mouth shapes layer.

In the Drawing Substitution window of the Library view, drag the slider to choose a mouth shape. The current
drawing is swapped for the one in the preview window.
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Chapter 7: Effects

Once your animation is completed, you can add effects such as blurs and glows to make your project look even
better! Harmony provides you with a series of essential effects that you can add to your layers.

This chapter contains the following topics:

* Adding Effects on page 231

* Animating an Effect over Time on page 236

* How Does an Effect Work? on page 238

» Effects in Harmony on page 238

Adding Effects

In Harmony, you can add effects through the Timeline view, connecting them to your drawing layers and then
adjusting the parameters until you achieve the look you want.
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How to add effects in the Timeline view

1. Inthe Timeline view, select the layer on which you want to add an effect.

2. Do one of the following:

» From the top menu, select Insert > Effects > desired effect.
» Inthe Layers toolbar, click the Add Layers button and select Effects > desired effect.

» From the Timeline menu, select Insert > Effects > desired effect.

The effect appears in the Timeline view.

3. Inthe Camera view, click the Render View button to see the scene's rendered current frame and
effect. Note that most effects cannot be played back in real time. You need to use the Render and Play
option in the Playback toolbar. )

NOTE: If your background appears all in black, it's because you need to add a Colour Card. To do this, follow step
2.

4. Inthe Timeline view, double-click on the effect layer to open the Layer Properties window. You can also
select the effect layer and see its properties in the Layer Properties view.

The Layer Properties view opens, displaying the parameters available for the selected effect.

e ropere: I

5. Inthe Layer Properties view, adjust the effect’s parameters—see Effects in Harmony on page 238.

6. To play back your scene with the final effects, in the Playback toolbar, click the Render and Play g but-
ton.

NOTE:
Once you have set the parameters for the effect, you can store itin the Library view as a template, so you can

quickly reuse it without resetting the parameters again—see Templates in Chapter 7: Library of the Cut-out
Animation Guide.
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How to use effects with more than one port

1. Select a drawing layer.

2. Click the Add Layers button and select Effects > Highlight.

The Highlight effect is parented to the selected layer.

3. Inthe Drawing or Camera view, create a drawing on a new layer that will act as the matte.

4. Inthe Timeline view, click the Collapse/Expand button on the effect layer.

5. Drag and drop the matte layer beside the Matte field.

6. Display the effect properties and adjust them until you achieve the desired effect.
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Previewing Effects

Most effects must be rendered so you can preview them properly. Some effects can be displayed in the OpenGL
view, but most of them must be rendered and previewed in the Render Mode of the Camera view.

Once you preview your effect, you may want to adjust it. By default, as soon as you modify a parameter,
Harmony will recalculate the preview image. If your scene is heavy and you do not want the preview rendered
automatically, deselect the Auto-Render option and do the preview update manually.

You cannot play back your animation in Render mode. You must perform a render or a preview render to see your
animation with the final effects. Effects must be calculated before they can be viewed in real time.

To make your previews calculate faster, you may want to render them at a smaller resolution. You can use the
Preview Resolution command so you will not have to modify the resolution of your scene every time you make a
check preview.

The Preview Resolution command allows you to quickly get a preview at three-quarter, half, one-third, or one-
quarter of the scene resolution. You can even customize the preview resolution size.

How to preview effects

1. Inthe Camera view status bar, click the Render Mode button.
In the bottom-right corner of the Camera view, the progress bar indicates the status of the render.

Depending on the size of the frame to render, it may take several seconds.

How to disable the Auto-Render option

1. Inthe Camera view status bar, click the Auto-Render s, button. In the top menu, you can enable and dis-
able Scene > Render > Auto-Render.

Once the Auto-Render option is disabled, you must request the preview update by clicking the Auto-
Render »#, button.
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How to manually update the rendering preview

1. Inthe Camera view status bar, click the Render *. button.

How to play back effects

1. Inthe Playback toolbar, click the Render and Play g, button.

The Play node opens and loads the frames.

Loading Frames. ..

-_— 53%

2. Once the frames are loaded, click the Play  button in the Play window.

3. Select Scene > Render > Cancel Preview Render to cancel the rendering.

NOTE: While previewing effects, you can press the Spacebar to stop and start playback.

How to use the Preview Resolution command

1. From the top menu, select View > Preview Resolution and one of the following:

» Same as Scene Resolution
» 3/4 of Scene Resolution

» 1/2 of Scene Resolution

» 1/3 of Scene Resolution

» 1/4 of Scene Resolution

» Custom

If you selected the Custom option, the Custom Preview Resolution dialog box opens.
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2. Inthe dialog box, select a resolution from the presets or type a new X-Y value.
3. Click OK.

4. Preview your effects animation.

Animating an Effect over Time

When compositing your scene, you will often want to animate the parameters of an effect over time. For example,
you may want an object to fade in or out by changing the transparency level over time or by increasing the colour
contrast on one of your drawings over a certain frame range.

To animate an effect over time, create a function curve by adding keyframes to the parameters you want to
animate. To do this, you will use these views: Layer Properties and Timeline. You can fine tune your animation
using the Function view.

How to animate an effect over time

1. Inthe Timeline view, select a layer and add an effect to it by doing one of the following:

» Click the Add Layer button and select Effects > desired effect.

» Right-click and select Insert > Effects > desired effect.
» From the top menu, select Insert > Effects > desired effect.

2. Create the function curve by doing one of the following:

» Double-click on the effect layer to display the effect properties. Click the Function _ button of the
parameter you want to animate and create a function curve.
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» Inthe Timeline view, expand the effect layer's parameters by clicking the Collapse/Expand button.
Then click the Function _~ button of the parameter you want to animate and create a function curve.

3. Inthe Timeline view, go to the frame on which you want to start animating the effect.
4. Inthe Timeline toolbar, click the Add Keyframe # button.

5. Inthe Value field of the parameter you want to animation, enter the keyframe value. If your keyframes are
stop-motion keyframes, in the Timeline view, select the new keyframes. Right-click and select Set Motion
Keyframe.

6. Repeat this process for each keyframe to be added.

NOTE: Refer to Previewing Effects on page 234 to learn how to preview animated effects.
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How Does an Effect Work?

An effect always needs a drawing connection and sometimes a matte or shape connection. A matte provides
drawing information that determines the area on which the effect will be applied on the drawing. The details and
colours within the matte drawing don't matter, as only the shape and transparencies are used. A matte is also
known as mask.

The matte principle can be demonstrated with the Cutter effect.

The Cutter effect cuts out a portion of an image using a matte drawing. You can use the Cutter effect to allow a
character to disappear behind a background element or to cut a virtual hole into the layer itself. The Cutter
requires a matte input.

Adjust the Cutter properties to invert the effect of the matte on animage. Instead of the object being hidden by the
mask, it will only be visible where it intersects with the matte shape area.

You can adjust the effect parameters in the Layer Properties view and link any of them to a function column to be
animated over time. This means that all of the effects can be customized.

Effects in Harmony

Here is the list of the main effects available in Harmony. Each effect and how to use it is described in the
corresponding section.

»  Blur- Gaussianon page 242
- Bluron page 244 Bluron page 244 e Cutteron page 252 » Shadow on page 260
» Brightness and Contrast on page 245 *  Glow on page 253 » Tone onpage 261
. L] 1 1 L]
. Colour-Override on page 247 Highlight on page Transparency on page
e 255 264
» Colour-Scale on page 251
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Blending

Effects nodes, like the Tone node and Highlight node, can control the colour and alpha composite operations for you.
These nodes were created with preset colour and alpha composite operations to fit the most frequently used,
composite operations.

You might, however, still want to control the colour and alpha composite operation between two images using the
Blending node, to create a multiplicity of lighting, shadow, filter or ambient effects. The Blending hode combines two
images into one output image, following the parameters you choose for your movie and images sequence or SWF
movie exports.

The drawing node connected to the Blending effect will act as the blending image and will be applied to all the
drawing layers situated under them in the Timeline view order.

+ “+ ("¢ Parameters

+
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Blending Properties

Parameter

Description

Name

Lets you rename the node.

Blend Mode and SWF Blend
Mode

Choose the blending effect mode you wish to apply to your layer. The Blend
Mode type will only be visible when the Camera view is set to Render

mode and will only export to a bitmap movie file or sequence of images.

Both the Blending node and Composite-Generic node have regular blending
modes and legacy blending modes. The regular blending modes will take the
source images and unmultiply them before blending the two inputs together.
The images will be remultiplied when being output from the node. The legacy
blending modes use the pre-multipled source images as is in order to apply the
effect. Unmultiplying the images before processing them will give a final result
closer to what can be found in software such as Adobe Photoshop.

* Normal: The layer attached to the effect acts as a normal layer and will
not create any blending mode effect.

*  Multiply: This operation multiplies the blending element colour with the
output image. This will darken the colour of the overlapping area.

» Screen: This operation multiplies the inverted colour of the blending
element with the image. This will lighten the colour of the overlapping
area.

« Lighten (Lighten Legacy): This operation lightens the area of the
output image which, is darker than the blending element’s colours. The
lighter colours will remain unchanged.

» Darken: This operation darkens the area of the output image, which is
lighter than the blending element’s colours. The darker colours will
remain unchanged.

+ Difference (Difference Legacy): This operation subtracts the
blending elements colour from the output image colours or vice-versa,
depending on which of them has more bright colours. The final result will
be colours that are more vibrant.

» Add (Add Legacy): This operation lightens the output image using the
blending element.

» Subtract (Subtract Legacy): This operation darkens the output image
using the blending element.

* Invert: This operation inverts the output image colours on the area
overlapping the blending layer colours.

* Overlay (Overlay Legacy): This operation multiplies or screens the
colours from the blending image, with those of the output image,
depending on the base colour. Colours from the blending element
overlay the colours of the drawing elements, while preserving the
highlights and shadows of the base colour. The base colour is not
replaced, but mixed with the blend colour to reflect the lightness, or
darkness, of the original colour.

» Hardlight(Hardlight Legacy): This operation multiplies, or screens,
the colours of the blending layer with those of the output image,
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depending on the blend colour. If the blend colour is lighter than 50%
grey, the image is lightened, as if it were screened. This is useful for
adding highlights to an image. If the blend colour is darker than 50%
grey, the image is darkened, as if it were multiplied. This is useful for
adding shadows to an image. Painting with pure black or white results in
pure black or white. Play with the Opacity value to create a subtler look.

Alpha: This operation will blend the alpha value of the blending layer
with the output image. This effect is not available for SWF Blend Mode.

Erase: This operation produces a cutter effect using the blending
element. This effect is not available for SWF Blend Mode.

Divide (Divide Legacy): This operation divides the output image colour
values by the blending layer colour values. The blending image colour
values are inverted, creating a negative image. The negative image’s
colour values are then multiplied by the right image colour values. This
effect is not available for SWF Blend Mode.

Replace: This operation replaces the output image by the blending
layer. This effect is not available for SWF Blend Mode.

Softlight: This operation darkens or lightens the colours in a soft and
diffuse way, depending on the blend colour (image in left port). If the
blend colour is lighter than 50% grey, the image is lightened. If the blend
colour is darker than 50% grey, the image is darkened. Painting with
pure black or white produces a distinctly darker or lighter area, but does
not result in pure black or white.

Linear Light: This operation burns or dodges the colours by decreasing
or increasing the brightness depending on the colour of the underlying
colour. If the blend colour is lighter than 50% grey, the colour is
lightened because the brightness is increased. If the blend colour is
darker than 50% grey, the colour is darkened because the brightness is
decreased.

Pin Light: This operation will replace the colours, depending on the
underlying colour . If the blend colour is lighter than 50% grey, pixels
darker than the underlying colour are replaced, and pixels lighter than
the underlying colour do not change. If the blend colour is darker than
50% grey, pixels lighter than the underlying colour are replaced, and
pixels darker than the underlying colour do not change.

Vivid Light: This operation burns or dodges the colours by decreasing
or increasing the brightness depending on the colour of the underlying
colour. If the colour is lighter than 50% grey, the blend colour is
lightened because the contrast is decreased. If the colour is darker than
50% grey, the blend colour is darkened because the contrast is
increased.

Exclusion: This operation produces a similar result to the Difference
mode, but with a lower contrast.

Dodge: This operation will lighten the colour.

Burn: This operation will darken the colour.

Hue: This operation will result in a colour that will take the luminosity
and saturation of the underlying colour, and the hue of the source colour.
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» Saturation: This operation will result in a colour that will have the same
luminosity and hue of the underlying colour, and the saturation of the
source colour.

» Colour: This operation will result in a colour that will have the
luminosity of the underlying colour, and the hue and saturation of the
source colour.

* Luminosity: This operation will result in a colour which has the hue and
saturation of the underlying colour, and the luminosity of the source
colour. This mode is opposite to the Colour mode.

NOTE: Itis possible to select two different blending modes in the same Blending effect layer, in the event that you
want to export your project to both a Bitmap and an SWF movie file with different results.

Blur - Gaussian

The Blur - Gaussian effect softens the image, reducing the amount of noise and detail. The look of the Gaussian
blur is smooth, but does take some rendering time. This effect is useful when rendering time is less important,
and quality is more important. Also, you can use a matte with this effect to isolate areas of the image.

For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/video-
tutorials/chapter/adam-phillips-harmony-effects.
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Enable/Disable

ame: | Blur-Gaussi

Blurriness
Dir: |

Precision Medium &

Blur - Gaussian Properties

Parameter

Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo a
change of depth or scale. When this option is deselected, the effect's values
remain unchanged regardless of any depth or scale changes. This option should
be deselected when multiple drawings are composited and attached to this effect.

Makes the blur algorithm operate as if the pixel values beyond the edge of the

Repeat Edge Pixels layer are the same as the values of the edge pixels. This keeps edges sharp, pre-
venting them from darkening and becoming more transparent.
Blurriness
o Blurs according to the length, width, and angle you specify. For example, if a char-
Directional . .
acter is walking east, the blur may fall to the west.
Blurriness Amount of blur applied to the layer.

Horizontal Blurriness

Length of the blur.

Vertical Blurriness

Thickness of the blur.

The direction in which the blur is applied: sideways, up, down, 90 degrees, 45

Angle degrees, and so on.
Bidirectional Blurs in both horizontal and vertical directions.
Matte Precision: Blurs the image the number of times the precision indicates at

different radius (between 0 and the specified radius).
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Blur

The Blur-Radial effect creates an effect that softens, fogs or obscures the image evenly in all directions. This
effect is useful when you want to make cloudy images not realistically seen in detail, such as a drawing object
that is farther back or in the background of your scene, usually blurry due to the laws of atmospheric perspective.
Other uses include the general softening of objects such as snow, stars and shadows that do not naturally have a
hard outline.

Blur-Radial Properties

Parameter Description

Activated by default, this option readjusts the blur when the elements undergo
a change of depth or scale. When this option is deselected, the effect's values
Truck Factor remain unchanged regardless of any depth or scale changes. This option
should be deselected when multiple drawings are composited and attached to
this effect.

Size of the blur. The larger the value, the greater the strength or reach of the
blur. The blur radius is affected by the drawing scale and camera position.
Click the Edit Curve button to change these values over time by adjusting the
function curve.

Radius
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Select High for a slow and accurate operation or Low for a faster operation with

Qualit
y a more raw look.

Brightness and Contrast

The Brightness and Contrast effect lets you modify the brilliance or dullness of an image or to create a greater
difference between the lights and darks of an image by increasing their respective intensities. This effect can be
used when an image appears too flat. Increasing the brightness or contrast can give a drawing a more attractive and
3D quality. This can be useful if you want to push your background to the rear by making it look dull and flat and
pulling your foreground elements to the front by giving them a higher contrast.

Brightness and Contrast standard node

Brightness and Contrast Properties

Parameter Description

A value less than 0 will darken the image; a value greater than 0 will brighten it.

Brightn . . : .
ghiness Attach a Bezier or Ease function to change the brightness over time.

A value less than 0 will reduce contrast; a value greater than 0 will increase con-

ntrast . . .
Contras trast. Attach a Bezier or Ease function to change the contrast over time.

If you are using an older version of this effect, the Legacy Brightness and Legacy

Legacy Brightness/Contrast Contrast options are automatically selected. This ensures that the resulting effect
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looks the same as in older versions.

Colour-Card

The Colour Card is a solid background the same size as the camera. The Colour Card lets you fill the scene's
background with a solid colour when there is no background image. If no background or colour card is added to the
scene, the resulting export will appear with a black background.

By default, the Colour Card has a Z ordering value of 12 Backward. This puts the Colour card behind all
elements that have a value lower than 12 Backward. Most of the time, the Colour card will appear automatically
behind all the scenes elements as they are all set to 0 Backward, unless you have changed the Z ordering of the
scene components. If so, the Colour Card will be in front of the elements that are pushed back to more than 12
fields backward.

Layer Properties @

r Colourswatch

Colour Card Properties

Parameter Description
Deoth The value used to determine composition order when the Z value of two ele-
P ments is the same.

The front-back position of the Colour Card layer in 3D space. This value can be

Offset Z e .
verified in the Top view.

Red/Green/Blue/Alpha The colour and tran§parency of the Colour Car.d. You can alsg attach these
parameters to function columns to change their values over time.
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Click the colour swatch to open the Colour Picker window and select a colour.

Colour Swatch Opens the Colour Picker window in which you can specify the colour.

Colour-Override

The Colour-Override effects processes the colours in a drawing layer. Using this effect, you can change colours
from the palette without affecting the actual palette, swap clone palettes, or even replace a specific colour zone. The
drawings in this layer must be .tvg files as the Colour-Override uses the colour palettes linked to them.

The Colour-Override effect lets you:

Change colour values in drawings during the compositing process.
Use colour values from a specific colour palette in the palette list.

Establish the priority of override palettes in the palette list. For example, you may have different clones of the
same palette, such as a daytime and nighttime version.

Isolate specific areas of a drawing by selecting certain colours. For example, using specific colours to
generate a matte for a glow effect.

Hide certain colours.

This topic is divided as follows:
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Colour-Override Editor Interface

The Colour-Override editor interface is comprised of the following sections:
+ Palettes on page 248
» Colours on page 249
»  Whole Palette Overrides on page 249

* Individual Colour Overrides on page 249

Palettes

The Palettes section displays the palettes in the palette list of the selected layer. You can move these palettes
into the Whole Palette Overrides section to reorder them. If you have cloned palettes, the higher one in the list will
override the others. This is useful for overriding the clone palette ordering set in the scene through the Colour
view.

You can load additional palettes in the palette list from either your project, by clicking on The Palette @3 button,
or your computer by clicking on the Browse = button.

+ The Palette @3 button allows you to load a palette contained within the project hierarchy (Environment,
Job, Scene and Elements).

+ TheBrowse = button allows you to load a palette located outside the project hierarchy, anywhere on

your system or server. If you link to a palette outside of your project, you will be prompted with the
following warning message:
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if the scene is transferred to another machine.

Colours

The Colours section displays the colour swatches of the selected palette. Move a swatch into the Colour-Overrides
section to change its value.

Whole Palette Overrides

The Whole Palette Overrides section forces the use of a particular palette (clone palette) or palette list ordering
during the compositing process. You must drag palettes from the Palettes section to change their order. Harmony
uses the palettes in the order they appear in the palette list to find the colour values associated with the colour IDs of
each colour zone. To apply a different version of a colour palette to, for example, switch from a day to a night palette,
use the Override section to change the order of the colour palettes (you must be working with cloned palettes).

Scene palette ordering
1 /

2

Colour override effect palette ordering

LA W |

My_Palette

Individual Colour Overrides

When you drag a swatch from the Colours section to this section, you can override its value. The default override
mode is set to New RGBA so you can override the RGB value as well as the transparency value.

The Current column always displays the colours from the currently active palette. Selecting a clone palette in the
Palettes area will not change the colours if you haven't changed the active palette in the Whole Palette Overrides
section. The update will be done once you close and reopen the Colour Override Layer Properties window.
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Overriding a Colour

With the Colour-Override node, you can change the colour of some swatches.

How to override colours

1. From the Colours section, select the colour swatch to modify and move it to the Individual Colour
Overrides section. Several options are available to modify your colours.

MNew alpha only

2. Once the swatch appears in the Colour-Overrides section, click the drop-down arrow and select one of the
following options from the Mode menu:

>

Override colour: When selecting a colour swatch from a clone palette (not set as the current palette),
use this option to override the current colour and use the swatch from the clone palette over the
corresponding one in the current palette.

Colour Not Visible: Renders the selected colour invisible in the Camera view.

New RGB Only: Overrides the colour swatch RGB value while maintaining its original alpha value.
You can select a new colour by clicking on the colour swatch and choosing a new colour from the
Colour Picker window.

New Alpha Only: Overrides the swatch's alpha channel while maintaining its original RGB values.
You can select a new alpha value by clicking on the colour swatch and choosing an alpha value from
the Colour Picker window.

New RGBA: Overrides the swatch's colour and alpha values. You can select a new colour by clicking
on the colour swatch and choosing an alpha value from the Colour Picker window.
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Colour-Scale

The Colour-Scale effect offsets an image's colours. This effect is useful in creating ambient transitions, such as
from daytime to nighttime.

Colour-Scale Properties

Parameter Description

Red, Green, Blue, Alpha The red, green, blue and alpha used to offset the image.
Hue The colour or hue to offset the image.

Saturation The amount of colour to offset the image.

Enter the value for the colour to offset the image. The actual colour values of the

image are not changed; instead, the channels are multiplied by a selected

amount. For example:

Value

+ Avalue of 1does not change the colour values.

» Avalue greater than 1 brings the colour channel value closer to 255 (or
white).
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» Avalue less than 1 brings the colour channel value closer to zero (0 or
black).

Cutter

The Cutter effect cuts out a portion of an image using a matte drawing. You can use the Cutter effect to allow a

character to disappear behind a background element or to cut a virtual hole into the layer itself. The Cutter
requires a matte input.

Adjust the Cutter properties to invert the effect of the matte on animage. Instead of the object being hidden by the
mask, it will only be visible where it intersects with the matte shape area.

Mo=al

L11] Z ¥ 8 Drawing

o | | *

How to use the Cutter effect

1. Select a drawing layer.

2. Click the Add Layers button and select Effects > Cutter.

The Highlight effect is parented to the selected layer.

Z ¥ & Drawing

[ ] *

3. Inthe Drawing or Camera view, create a drawing on a new layer that will act as the matte.

4. Inthe Timeline view, click the Collapse/Expand button on the effect layer.

1. Drag and drop the matte layer beside the Matte field.
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5. Display the Cutter properties and adjust the properties to control the type and amount of blur and the colour of

the Cutter effect.

Layer Properties

=

Cutter Properties

Parameter Description
Name Allows you to change the node's name.
When this option is enabled, the Cutter node will invert the matte shape to cut the
Inverted drawing. Instead of cutting the image intersecting with the matte, it will cut any
artwork outside of the matte shape.
Glow

The Glow effect adds a bright soft-edged light or diffuse light region around an image. The Glow effect is useful for
creating a shining rim around objects, such as the sun or stars.

Use the Glow editor to control the direction of the blur that creates the glow, as well as its colour.
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Glow Properties

Parameter

Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo
a change of depth or scale. When disabled, the effect's values will remain
unchanged regardless of depth or scale changes. It is recommended that this
option be disabled when multiple drawings are composited and attached this
effect.

Blur Type

Radial: The edges of the matte are blurred evenly around points that make up
the edge of the matte.

Directional: The matte is blurred in the direction you select.

Radius

Enter a value for the size of the blur. The larger the value, the greater the blur
effect. The blur radius is affected by the drawing scale and camera position.

Directional Angle

If you selected the Directional Blur type, you can set the direction of the blur by
entering a value from 0 to 360 in this field.

0: Blurs the image to the west.
90: Blurs the image to the south.
180: Blurs the image to the east.

270: Blurs the image to the north.

Directional Falloff Rate

The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.

0: Makes the blur fade out slowly, distributing the blur evenly from the edge of
the character to the farthest edge of the blur.

1: Makes the blur fade out quickly. The blur is heaviest closer to the edge of
the image.

Invert Matte

Inverts the matte used to create the tone, shadow, or highlight.
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Creates the shadow or tone using the matte shape's colour. Be sure that you
are inrender mode 3% to see this effect and that your background is NOT
white and that you do NOT have a white colour card node attached to the com-
posite. As the matte only gives colour information, but no alpha, the matte is
automatically multiplied with the background colours. If there is no colour card
attached and the background appears black, you will see the matte colour at
full opacity. If it is multiplied with a white background, the colours disappear
into the full 255.

Use Matte/Source Colour

Multiplicative Multiplies the tone or shadow colours with the background.
Colour
Enter a value to add or subtract from the colour channels in the drawings or
RGBA .
attach these values to function curves.
Colour Swatch Opens the Colour Picker where you can specify the colour.
. Lets you set a value to determine the strength of the effect or attach a function
Intensity :
to animate the effect.
Highlight

The Highlight effect lets you to turn a drawing's area lighter to simulate a light source. For this effect, you will need to
create a matte to determine the shape and position of the highlight on another element and so you can blur the edges
to create a softer effect. By adjusting the Highlight properties, you can control the type and amount of blur, as well as
the colour of the highlight effect.

How to use the Highlight effect

1. Select a drawing layer.

2. Click the Add Layers button and select Effects > Highlight.

The Highlight effect is parented to the selected layer.

3. Inthe Drawing or Camera view, create a drawing on a new layer that will act as the matte.

4. Inthe Timeline view, click the Collapse/Expand button on the effect layer.
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1. Drag and drop the matte layer beside the Matte field.

5. Display the Highlight properties and adjust the properties to control the type and amount of blur and the col-
our of the highlight effect.

Highlight Properties

Parameter Description

Activated by default, this option readjusts the blur when the elements undergo
a change of depth or scale. When disabled, the effect's values will remain

Truck Factor unchanged regardless of depth or scale changes. It is recommended that this
option be disabled when multiple drawings are composited and attached this
effect.

Blur Type Radial: The edges of the matte are blurred evenly around points that make up
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the edge of the matte.

Directional: The matte is blurred in the direction you select.

Enter a value for the size of the blur. The larger the value, the greater the blur

Radius effect. The blur radius is affected by the drawing scale and camera position.

If you selected the Directional Blur type, you can set the direction of the blur by
entering a value from 0 to 360 in this field.

0: Blurs the image to the west.
Directional Angle 90: Blurs the image to the south.
180: Blurs the image to the east.

270: Blurs the image to the north.

The distance where the blur fades from the edge of the image. Select a value
between O and 1.

0: Makes the blur fade out slowly, distributing the blur evenly from the edge of

Directional Falloff Rate the character to the farthest edge of the blur.

1: Makes the blur fade out quickly. The blur is heaviest closer to the edge of
the image.

Invert Matte Inverts the matte used to create the tone, shadow, or highlight.

Creates the shadow or tone using the matte shape's colour. Be sure that you
are in render mode to see this effect and that your background is NOT
white and that you do NOT have a white colour card node attached to the com-
posite. As the matte only gives colour information, but no alpha, the matte is
automatically multiplied with the background colours. If there is no colour card
attached and the background appears black, you will see the matte colour at
full opacity. If it is multiplied with a white background, the colours disappear
into the full 255.

Use Matte/Source Colour

Multiplicative Multiplies the tone or shadow colours with the background.
Colour
Enter a value to add or subtract from the colour channels in the drawings or
RGBA .
attach these values to function curves.
Colour Swatch Opens the Colour Picker where you can specify the colour.
Intensity Lets you set a value to determine the strength of the effect or attach a function

to animate the effect.
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Quadmap

The Quadmap transformation layer lets you deform the shape of an element. For example, you can use it to
create a drop-shadow effect on an element.

You can edit the Quadmap visually in the Camera view.

How to edit the Quadmap in the Camera view

1. Inthe Timeline view, click the Add Layer button and select Quadmap.

2. Connect the drawing you want to deformto the Quadmap.

3. Inthe Tools toolbar, disable the Animate mode to change the value for the Quadmap over the entire dur-
ation of the element.

4. Inthe Timeline view, click on the Quadmap layer to select it.

5. From the top menu, select View > Show > Control or press Shift + F11.

The quadmap handles appear around the element in the window. There is also a pivot point at the centre of
the quadmap frame that you can reposition.

6. Inthe Camera view window, use the Transform tool to move the points on the quadmap. Shift + click to
select multiple points.
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The value of each point on the quadmap can be changed gradually. To do this, use the Quadmap node Layer
Properties to attach the points to function curves.

Only the X and Y values of each point in the quadmap can be changed.

Quadmap Properties

Layer Properties @

Parameter Description
Name Lets you rename the node.
oD Path Changes the X and Y values simultaneously and control the velocity of the
change.
Changes the X and Y values separately. Each one can be attached to separate
Separate

function curves.
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With the Shadow effect, you can tum a drawing into a shadow. It doesn't matter if the drawing layer is a fully
coloured character. The Shadow effect will render it into a grey, semitransparent, slightly blurry silhouette.

To add a shadow stretched out on the ground, simply add a Quadmap node to flip, stretch and skew the matte.
Attach the entire effect to the same trajectory as your drawing layer and watch the shadow move along with your
character.

Use the Shadow editor to modify the way the Shadow effect is created.

The Shadow effect uses the shape of the drawing connected to create the shadow behind another element and
can blur the edges to create a softer effect. You can control the type and amount of blur, as well as the colour of
the shadow.

For more information on the Apply-Peg-Transformation node, see Apply Peg Transformation on page 1.

Shadow Properties

Parameter Description

Activated by default, this option readjusts the blur when the elements undergo
a change of depth or scale. When disabled, the effect's values will remain
Truck Factor unchanged regardless of depth or scale changes. It is recommended that this
option be disabled when multiple drawings are composited and attached this
effect.

Radial: The edges of the matte are blurred evenly around points that make up
Blur Type the edge of the matte.

Directional: The matte is blurred in the direction you select.

Enter a value for the size of the blur. The larger the value, the greater the blur

Radius effect. The blur radius is affected by the drawing scale and camera position.

If you selected the Directional Blur type, you can set the direction of the blur by

Directional Angle entering a value from 0 to 360 in this field.
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0: Blurs the image to the west.
90: Blurs the image to the south.
180: Blurs the image to the east.

270: Blurs the image to the north.

The distance where the blur fades from the edge of the image. Select a value
between O and 1.

0: Makes the blur fade out slowly, distributing the blur evenly from the edge of

Directional Falloff Rate the character to the farthest edge of the blur.

1: Makes the blur fade out quickly. The blur is heaviest closer to the edge of
the image.

Invert Matte Inverts the matte used to create the tone, shadow, or highlight.

Creates the shadow or tone using the matte shape's colour. Be sure that you
are in render mode to see this effect and that your background is NOT
white and that you do NOT have a white colour card node attached to the com-
posite. As the matte only gives colour information, but no alpha, the matte is
automatically multiplied with the background colours. If there is no colour card
attached and the background appears black, you will see the matte colour at
full opacity. If it is multiplied with a white background, the colours disappear
into the full 255.

Use Matte/Source Colour

Multiplicative Multiplies the tone or shadow colours with the background.
Colour
Enter a value to add or subtract from the colour channels in the drawings or
RGBA .
attach these values to function curves.
Colour Swatch Opens the Colour Picker where you can specify the colour.
. Lets you set a value to determine the strength of the effect or attach a function
Intensity ;
to animate the effect.
Tone

The Tone effect lets you add a dark-coloured region to your drawing and simulate the shaded area away from a light
source. To produce the tone effect, create a drawing to control where the tone will appear. The Tone effect uses a
matte to determine the shape and position of the tone on your drawing and can be blurred at the edges to create a
softer effect.
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How to use the Tone effect

1. Select a drawing layer.

2. Click the Add Layers button and select Effects > Tone.

The Tone effect is parented to the selected layer.

3. Inthe Drawing or Camera view, create a drawing on a new layer that will act as the matte.

4. Inthe Timeline view, click the Collapse/Expand button on the effect layer.

1. Drag and drop the matte layer beside the Matte field.

5. Display the Tone properties and adjust the properties to control the type and amount of blur and the colour
of the tone effect.
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Tone Effect Properties

Parameter

Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo a
change of depth or scale. When disabled, the effect's values will remain
unchanged regardless of depth or scale changes. It is recommended that this
option be disabled when multiple drawings are composited and attached this
effect.

Blur Type

Radial: The edges of the matte are blurred evenly around points that make up the
edge of the matte.

Directional: The matte is blurred in the direction you select.

Radius

Enter a value for the size of the blur. The larger the value, the greater the blur
effect. The blur radius is affected by the drawing scale and camera position.

Directional Angle

If you selected the Directional Blur type, you can set the direction of the blur by
entering a value from 0 to 360 in this field.

0: Blurs the image to the west.
90: Blurs the image to the south.
180: Blurs the image to the east.

270: Blurs the image to the north.

Directional Falloff Rate

The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.

0: Makes the blur fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.

1: Makes the blur fade out quickly. The blur is heaviest closer to the edge of the
image.
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Invert Matte

Inverts the matte used to create the tone, shadow, or highlight.

Use Matte/Source Colour

Creates the shadow or tone using the matte shape's colour. Be sure that you are
inrender mode #% to see this effect and that your background is NOT white and
that you do NOT have a white colour card node attached to the composite. As the
matte only gives colour information, but no alpha, the matte is automatically mul-
tiplied with the background colours. If there is no colour card attached and the
background appears black, you will see the matte colour at full opacity. If it is mul-
tiplied with a white background, the colours disappear into the full 255.

Multiplicative Multiplies the tone or shadow colours with the background.

Colour

RGBA Enter a value to add or subtract from the colour channels in the drawings or attach
these values to function curves.

Colour Swatch Opens the Colour Picker where you can specify the colour.

. Lets you set a value to determine the strength of the effect or attach a function to

Intensity .

animate the effect.
Transparency

The Transparency effect is used to make an image partially transparent. The Transparency effect is useful when
fading images in and out, such as a phantom or to make something partially see-through, such as a window.

You can enter a value in the Transparency field or change the transparency value over time by linkingitto a
function curve. Entering a value of 100 in the Transparency field will make the element 100% transparent, in other
words, invisible. Entering a value of 0 will render the element completely opaque.

It is also possible to adjust a layer/node's transparency directly in the Layer Properties window without using the
Transparency node. In the layer's properties, go to the Drawing tab and adjust the Opacity parameter. This
parameter is visible in OpenGL mode.
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Layer Properties

Enable,
Mame: | Drawing

Transformation  Drawing

Alignment

High

Use the Transparency editor to control how translucent the element should be.

Transparency Properties

[ Layer Properties E‘

Parameter Description
Name Allows you to change the node's name.
Lets you set the opacity of an element. Values range from 0 to 100. A value of 100
Transparency will make the element 100% transparent and a value of 0 will render the element
completely opaque.
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Chapter 8: Export
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Now that you've finished your animation, it's time to render your movie. Depending on whether you plan to further
edit your movie using a third party software, composite the movie in a larger body of work or put it up directly on the
web, Harmony supports several formats for all your rendering needs.

The render resolution for the various editions of Harmony are:
* Harmony Essentials: 2K (2048x1556)
* Harmony Advanced: 4K (4096x3112)

» Harmony Premium: Unlimited

This chapter contains the following topics:

»  Exporting a Quick Time Movie on page 267

»  Exporting an SWF Movie on page 272

» Exporting Image Sequences on page 274

»  Exporting OpenGL Frames on page 275
Exporting a QuickTime Movie

If you require a video file, you can export your animation as a QuickTime movie. To render a Quick Time movie with
transparency, you need to set the Depth to Millions of Colours +. You can set this this when exporting a QuickTime
movie.
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If your exported video is too small or too large, you can change the project size from the top menu in Scene >
Scene Settings. This will change the size of the video output.

How to export a QuickTime Movie

1. From the top menu, select File > Export > Movie.

The Export to QuickTime Movie dialog box opens.

2. Click Browse and select a folder in which to save your movie and give it a file name for the export.
3. Click OK.
1. Inthe Display Source section, select the Display node to use for rendering your project.

2. From the Export Range section, decide whether you want to export the entire scene (All) or a specific
frame range. If you decide on the latter, enter the frame range.

3. Inthe Resolution section, select one of the following from the menu:

» A preferred resolution ratio.
» Custom: Enables the Width and Height fields so you can enter a specific size.

4. Inthe Options section, click Movie Options.
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5.

Movie Settings
V| Video
msctaon EEE}%TEEEEQASQET%‘S;
| Pter. | Eé&?“‘?” .
7 rame rate:
Size...
Allow Transcoding
| Sound
[ | s TomrE
Sample size: 16
Channels: 1
/| Prepare for Intemet Streaming
Fast Start - T
Cancel
Parameter Description
Enables the customization of the video settings, filters and size.
Settings: Opens the Standard Video Compression Settings dialog
box.
Video Filter: Opens the Choose Video Filter dialog box, where you can
select from a range of filters to apply to your video export.
Size: Opens the Export Size Settings dialog box. The size settings
are overridden by the Harmony's scene settings.
Sound Enables the customization of the sound settings.
oun

Settings: Opens the Sound Settings dialog box (see below).

Prepare for Internet Streaming

Enables the customization of the Intermet streaming options.

In the Video section, click Settings.

The Standard Video Compression Settings dialog box opens.
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10.

11.

12.

13.

Standard Video Compression Settings

Compression Type:  Animation -
Motion Data Rate
Frame Rate: 24 - fps Data Rate: (@) Automatic
Restrict to kbits/sec
Key Frames: () Automatic
@ Every 43 frames Optimized for: | Download
Al
Frame Reordering
Compressor Preview
Depth:  Millions of Colors -
Quality
L:aast Lcluw Meélium Hilgh Best
B -

From the Compression Type menu, select a codec. The availability of certain compression settings
depends on the Compression Type selected. For example, Animation is the default compression type and
as a result the Data Rate option is greyed out.

In the Motion section, choose a Frame Rate from the list.

By default, it is set to match the frames-per-second (fps) of your Harmony project. If you choose a lower
frame rate, your export playback will be faster than your actual project. The reverse is also true for a higher
frame rate.

If you want keyframes inserted, select the Every option and set the number per frame.

This is the option is recommended by QuickTime. For further details, refer to the Quick Time
documentation.

In the Quality section, use the slider to choose a quality setting. Remember that the better the quality of
the export, the larger the file.

Quality
L:aast Lcluw Meélium Hilgh Best
-=F -

From the Data Rate section, either choose to allow the program to automatically select the most optimal
bit rate, or enter a Restricted rate to save space and allow for faster downloading at a cost to the quality of
the export.

In the same section, from the Optimized For menu, select the intended viewing method for the export.
Click OK.

From the Movie Settings dialog box, click Sound Settings.

The Sound Settings dialog box opens.
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14.

15.

16.

17.

18.

19.

Sound Settings

Compressor: Mone hd

Rate: 22,050 kHz [

Size: 8 bit @ 16 bit

Use: @ Mono Sterso
Options Cancel

From the Compressor menu, select a compression type. The default setting is None. This will preserve your
original sound file without the loss of information. However, an uncompressed sound file will inevitably add
“weight” to the overall size of your video export.

From the Rate menu, select a rate. It is best to check and match the original properties of your sound file. For
example, if your file has an audio sample rate of 48 kHz and you choose a conversion rate of 22.05 kHz, the
sound will play at the same speed, but with higher frequencies missing. For a standard film sound quality,
choose 44.1 kHz, or 48 kHz for DVD quality. Anything less will make the sound “dull” or less bright. For
things like recorded voice, this doesn't matter so much, but for music it can make an audible difference. If file
size is a consideration, such as with videos for the Internet, then a lower rate might be more practical.

Select the Size and Use, which are related. It is advisable to check your original sound file properties. If the
file was recorded in one channel (mono), there is no point in choosing the two channel (stereo) option.
Although Mono can support a 16-bit channel, the extra information is unnecessary. Mono is generally paired
with 8-bit and Stereo with 16-bit.

Click OK.

In the Export to QuickTime Movie dialog box, click OK.

A progress bar appears.

Frame: 212

Browse to the location on your computer where you saved your Quick Time video and double-click on it to
view the export.

How to set the depth to Millions of Colours + to export a QuickTime movie with transparency

| 4

In the Standard Video Compression Settings dialog box, select Millions of Colors+ from the Depth menu—
see Exporting a Quick Time Movie on page 267.
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Standard Video Compression Settings

Compression Type:  Animation
Motion

Frame Rate: 24 - fps

Key Frames: () Automatic

@ Every 48 frames

Al

Frame Reordering

Compressor

Depth: = Millions of Colors l:]
Quality Black and White

4 Grays
4 Colors =

[—
1

Least | Low 16Grays

16 Colors

256 Grays

256 Colors
Thousands of Colors
Millions of Colors

(2

Exporting an SWF Movie

The SWF export supports some bitmap effects (which can be previewed in Render View mode) and SWF Blend
Modes (vector effects which can be previewed in OpenGL View mode).

The following are also supported:
* Pencil line thickness: They are converted to brush strokes in the .swf file.
» Auto Patch node for creating joint patches.

If you have not already done so, you should preview the .swf by using the SWF preview g button to see what
the two types of effects look like when blended together. Once you are satisfied with the results, go ahead and
export your movie.

How to export a .swf movie

1. From the top menu, select File > Export > SWF.

The Export to Flash Movie (.swf) dialog box opens.
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Click Browse and select a file name and destination path for your movie.

In the Export Range section, select one of the following options:

» All: To export all the frames of your movie.
» Frames: To export a frame range. Enter the frame range in the fields.

In the Options section, enter a Frame rate (fps). By default, it will be set to match the fps of your Harmony pro-
ject. If you choose a lower frame rate, your export playback will be faster than your actual project. The
reverse is also true for a higher frame rate.

In the same section, select the JPEG quality:

» 100 = Full quality

» 50 = Average quality at about 1/5th of the size.

» 25= Medium quality where loss of high image resolution starts to occur.

» 10 = Low quality where “macro-blocking” or large pixelation become obvious.

» 1= Lowest quality where there is extreme loss of colour and detail and the image becomes nearly
unrecognizable.

To prevent your movie from being imported into another application, select the Protect from Import option.

For a lighter format, select the Compress Movie option. The movie may lose some quality, but the file will be
lighter.

To retain the thickness of pencil lines, select the Convert Pencil Lines to Brush Lines option.

Inthe Do Not Export section, select the effects you do NOT want to be rendered in the SWF movie.

273



Chapter 8: Export

Note that certain Harmony effects are not listed in this section as they are not compatible and therefore not
available for SWF export. These effects will not appear in the SWF render.

10. Click OK.

11. Browse to the location on your computer where you saved your Flash Movie and double-click on it to view
the export.

Exporting Image Sequences

In Harmony, you can export a scene as a bitmap image sequence. If there is sound in your scene, it will not be
exported with the images.

If you want to export images with transparency, you need to select the file type that supports this option, such as
.tga, .psd or .png. The Colour Mode menu changes according to the File Type selected. For example, selecting
.tif will result in only having "Colour" as a Colour Mode option, whereas .png will have "Colour" and "Colour with
Transparency".

How to render an image sequence

1. From the top menu, select File > Export > Images or press Ctrl + Shift + Y (Windows/Linux) or 3£ + Shift
+Y (Mac OS X).
The Export Images dialog box opens.

Default

2. Inthe Output section, choose a prefix. The prefix is the file name. Each image in the sequence will have
this name, plus a sequence number and file format extension. For example: final-0001.jpg.

3. Click Browse and specify the location in which your movie will be saved. The default location is the file dir-
ectory’s frames folder.

4. Inthe Format section, choose the File Type, Colour Mode and Colour Depth from their respective menus.

5. Inthe Range section, select the Frame Range to render.

» AllFrames: Exports export the entire scene.
» Selected Frames: Lets you specify the first and last frame of the frame range to export.
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6. Select the Preview option to see the images being rendered.

7. Click OK.

If you selected the Preview option, a generic player opens so you can watch the image sequence strung
together as a video. The image sequence is how available in the scene’s frames directory. You should be
able to preview each frame as an individual image.

How to render an image sequence with transparency

1. Open the Export Images dialog box.

2. Inthe Format section, select Colour with Transparency from the Colour Mode menu.

Format

Exporting OpenGL Frames

You can export the OpenGL frames (fast display mode) if you need a quick render for your scene. Heavier scenes
containing 3D, multiple effects and camera moves can be fairly long to export.

Use the Export OpenGL Frames dialog box to select the frames you want to render from the OpenGL Camera view,
then save the rendered frames as image files or as a Quick Time movie.

Frames saved from OpenGL view have neither antialiasing nor special effects. To render final frames with effects,
export as images or a movie.

How to export OpenGL Frames

1. From the top menu, select File > Export > OpenGL Frames.

The Export OpenGL Frames dialog box opens.
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Height:

Formak Range

© all Frames

W COpenin Player

2. Inthe Output section, click Browse and select a folder for the frames.
3. Inthe Filename field, enter a name (prefix) for the frames or revert to the default name by clicking Default.

4. Inthe Format section, decide if you want to export individual image frames or a movie.

» Suffix: Lets you select the desired suffix. If you intend to render only a few frames, use 1 or 01,
whereas if you intend to render 1000 frames, you can select 0001.

» Drawing Type: Lets you select the file type to render, such as .tga or .sgi.

5. Click Movie Options to customize the Audio and Video settings for the *.mov export—see Exporting a
Quick Time Movie on page 267.

6. From the Resolution section, select a resolution for export. If you are running some quick tests, then you
might want to reduce the resolution to save time and space. You also have the option to set a Custom
width and height to produce smaller or larger frames.

7. Inthe Range section, decide whether you want to render all your frames, a range of frames, the current
frame or selected frames.

8. Inthe Options section, select the Open in Player option to view the rendered frames.

9. Click OK.
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Glossary

3D stereoscopic

The ability to create stereo images which, when animated and viewed through 3D active
shutter glasses or using glasses with one red and one blue lens, will appear as a three-
dimensional movie.

alpha channel

An image channel that carries transparency information. An image already has three
channels: red, green and blue (RGB). The alpha channel is the fourth channel (A). The
matte, or the transparency information, is stored in this fourth channel. An image without an
alpha channel is always opaque.

animatic A movie with sound that is developed from the storyboard. The storyboard panel is exposed
for the duration of the scene and at times, the characters are placed on a trajectory to
indicate motion. The camera moves are also animated. The animatic is used to determine
the rhythm of a project and provides a good overview of the project before beginning
production.

animation A simulation of movement created by displaying a series of pictures or frames.

anime An animation style known for its sinister and dark feel; popular in Japan.

arc Action rarely occurs in a straight-forward manner; rather it typically unfolds in what

storytellers refer to as an arc. The purpose of a story arc is to move a character or situation
from one state or scenario to the next.

aspect ratio

The relationship between the width and height dimensions for any scene, frame or film
format. Television ratio is 4:3 and widescreen ratio is 16:9.

auto-feed

An automated method of feeding drawings into a scanner in which multiple drawings are
stacked into a sheet feeder. When the scanner is activated, the drawings are scanned
consecutively, without further user intervention.

automatic lip-sync
detection

Automatically mapping drawings in an element to the mouth chart generated for a sound.
This can save time when lip-syncing a voice track.

axis

An imaginary line around which an object rotates.
For 2D graphics, there are two axes: X (horizontal and Y (vertical).
For 3D graphics, there are three axes: X (horizontal, Y (vertical) and Z (depth).

In animations that constantly rotate, the axis element specifies what axis the object rotates
around. A negative number causes an animation to rotate counter clockwise whereas a
positive number causes an animation to rotate clockwise.

background

The part of a scene that is farthest to the rear. The background is the artwork, or decor,
against which the animation takes place.

Bézier

A method of defining curved lines invented by French mathematician Pierre Bézier. A Bézier
curve is a mathematical or parametric curve. Bézier curves use at least three points to
define a curve.

bitmap

An image composed of pixels with a single resolution (size). If it is enlarged too much, it will
lose definition and individual pixels will begin to appear. This is known as pixelation.

Bitmap image files are defined as a standard rectangular mesh of individual pixels. Each
individual pixel contains a value that represents a specific colour.

277




Glossary

breakdown

In cut-out animation, breakdown is the action of breaking a character into pieces to create a
puppet with articulations. To break down a character, the artist cuts parts, such as the
hands and arms, from the character's model and pastes them in separate layers. Next, the
joints are fixed and the pivots set.

In traditional animation, a breakdown is an animation pose generally found between two key
poses. The key poses are the main poses in an animation and the breakdowns are
secondary poses, ones that help describe the motion and the rotation curve (usually referred
to as an arc).

camera shake

Camera shake occurs in a scene when the camera moves slightly and quickly in several
directions. This gives the impression of an impact, vibration or, for example, bumps on the
road.

caption

A text field containing dialogue, effects, sound or slugging information in a storyboard.

cel

In traditional animation, a cel (also known as celluloid) is a transparent sheet on which the
animation is inked and painted before being sent to the camera. The picture's outline is
drawn on the front of the cel and then coloured along the back.

character design

Each character in an animated film is drawn from multiple angles in poster-style format,
called a model sheet, which serves as a reference for the animators.

chromatic In optics, chromatic aberration (CA), achromatism or chromatic distortion, is a type of

aberration distortion in which there is a failure of a lens to focus all colours to the same convergence
point.

clean up After rough drawings have been tested and approved, all the noise in the image (excess
lines, notes, etc.) is removed to create final drawings which can be inked, painted and shot.
The clean up process refers to either tracing a clean line over a rough drawing to achieve the
final version or removing dirt and extra lines left by the scanning process.

CMYK Acronym for Cyan, Magenta, Yellow, Black. These colours are the standard model used in a
process called offset printing.

colour card A colour card is a card containing one solid colour that is the same size as the camera. The
colour card fills the background with a solid colour when there is no background image
included.

colour model The official colour design that must be used to paint the animation. A model is the definitive
character, prop or location design that each artist must follow for the production.

colour wheel A display of the colour spectrum in the form of a circle.

compositing Compositing is the action of incorporating all of a scene's elements to create the final result

prior to rendering. For example, the compositing artist will import all the animation
sequences, background, overlays and underlays in the scene and position them correctly.
The artist will then set the camera frame and animate it, if needed. Finally, the animator will
create all the computer-generated effects for the project.

cross dissolve

An effect used to fade two scenes, one into the other.

cut

A direct transition between two scenes. When a cut is used, there are no transition effects
inserted to pass from one scene to the next. The first scene ends and the second one starts
immediately.

cut-out animation

The process known as cut-out animation is the action of animating characters made out of
several pieces by moving them around frame by frame. Cut-out animation can either be
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computer generated or done traditionally using paper.

cycle A group of images that together make up an action, such as walking. A cycle is an action
repeated as a loop over a period of time. It can be a series of animated drawings or
keyframes.

dialogue The text spoken by a character in a movie or animation.

dope sheet Used by animators, directors and other members of a crew to track the sequence and timing
of images, dialogue, sound effects, sound tracks and camera moves. Also known as an
exposure sheet.

doping To assign a particular drawing to a range of frames.

double bounce
walk

In the key frames and passing positions in a double bounce walk, the body is lower than a
reference line drawn in the upright position. During the in-betweens, the body is above this
line giving the appearance of a bounce.

DPI Dots perinch is the standard measure of resolution for computerized printers. It is
sometimes applied to screens, in which case it should more accurately be referred to as
pixels per inch. Either way, the dot is the smallest discrete element making up the image.

ease In animation, the ease, also known as velocity, is the acceleration and deceleration of a
motion. It can be a motion created by a function curve, or a series of animated drawings.
Other common terms for ease-in and ease-out are slow-in and slow-out.

ease-in Gradual acceleration in the action. Also known as slow-in.

ease-out Gradual deceleration in the action. Also known as slow-out.

establishing shot

A scene in which the viewer can see the whole area in which a sequence is happening. For
example, if a child is playing on the ground in front of his house, the establishing shot would
be a scene where the viewer can see the house, the ground, a part of the street and the
buildings around the central point of action. This helps the viewer understand the story
location and scene orientation.

exposure

In animation, an exposure is the number of cels on which a drawing appears in the scene.
For a drawing to appear longer, the exposure must be extended over a greater number of
cels.

exposure sheet

A sheet with several vertical columns and horizontal frames used to indicate a scene's
timing. Each column represents a scene layer. The drawing numbers in each column are
indicated and repeated over the particular amount of frames they need to appear.

The exposure sheet is used by animators, directors and other members of a crew to track
the sequence and timing of images, dialogue, sound effects, sound tracks and camera
moves. Also known as a dope sheet.

fade in/fade out

Fade in or fade out is a transition effect used to open or close a sequence. A fade in occurs
when the first scene appears progressively, from complete transparency to its complete
opacity. A fade out occurs when the last scene progressively disappears, going from
complete opacity to complete transparency.

fast-in Dramatic acceleration at the start of the action.
fast-out Dramatic acceleration at the end of the action.
field A measurement unit used to calculate motion, registration and camera positioning. A

standard animation scene will vary between 6 to 12 fields.
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field chart

A guide containing all the field units that animation and layout artists use to determine a
scene size or camera motion.

film-1.33

A resolution that is ideal for the widescreen film format that conforms to the standard 4:3
pixel aspect ratio.

film-1.66

A resolution that is ideal for the widescreen film format that conforms to the 16:9 pixel
aspect ratio. (The pixels are wider than they are high).

flipping

In traditional animation, flipping is the action of going through the drawings of an animation
sequence very quickly in order to see the animation in motion. Flipping can also be the
action of creating a mirror transformation of an object.

follow-through

The secondary motion caused by the main action. For example, a character wearing a cloak
is running. The main action is the body running. This will cause the cloak to follow the
motion, although it will not move at the same time, but react a few frames later and follow
the main motion curve.

forward kinematics

Forward kinematics is a feature used to animate principally 3D characters and cut-out
puppets with hierarchy. It is used to animate a puppet from one of parent parts, such as a
shoulder, and make the rest of the arm move with it as a single piece.

frame

An animation frame is a single photographic image in a movie. In traditional animation, the
North American standard generally contains 24 frames per second, while in Europe the
standard is 25 frames per second.

frame rate

The frame rate is the speed at which the frames are played. They are generally calculated
by frame per second. For example, a scene could be played back at 12, 24, 25, 30 or 60
frames per second or any other number.

This is the measurement of the frequency (rate) at which an imaging device produces
unique consecutive images, called frames. The term applies equally to computer graphics,
video cameras, film cameras, and motion capture systems.

Frame rate is most often expressed in frames per second (fps) and in progressive-scan
monitors as hertz (Hz).

function

A computer-generated motion, trajectory or path on which elements, other trajectories and
effects parameters can be attached. The function can be controlled by adding keyframes
and control points on the function curve.

gamut

The range of colours that a particular device can represent.

HDTV

Acronym for High Definition Television which delivers a higher quality image than standard
television because it has a greater number of lines of resolution. To take advantage of the
superior quality and make full use of your resolution setting, the output device must be
compatible with HDTV technology.

hold

A frame in the animation in which the character maintains its position without moving. A
hold can be created between any two keyframes.

HSV

Hue, Saturation, Value. A method of defining colours in terms of hue (tint), saturation
(shade) and value (tone or luminance).

in-between

The drawings that exist between the key poses. These are drawn to create fluid transitions
between poses.

ink and paint

The ink and paint process is the action of painting the empty zones and colouring the lines
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on the final animation drawings, while following a colour model.

interpolation

The computer-generated motion created between two keyframes. You have the choice to
create interpolation, or not, between your keyframes.

inverse kinematics

(1K)

A feature used mainly to animate 3D characters and cut-out puppets with hierarchy. Inverse
kinematics will animate a puppet from one of the extremities, such as a hand, and make the
rest of the body follow naturally.

jump cut A jerky cut between two scenes. Typically, a jump cut is not visually pleasing. It is generally
caused by one scene ending, and a second one starting, with a similarimage. The lack of
difference causes the eye to see a little jump between the two scenes.

key pose Important positions in the action defining the starting and ending points of any smooth
transition. Keys, or key poses, are the main drawings in an animation sequence describing
the motion. For example, if an arm is waving, the keys will be of the arm at one extremity of
the wave motion and the other extremity. By flipping those drawings, the animator can see
the skeleton of the motion without having all the drawings.

keyboard One or more keyboard keys which, when used, cause an operation to be performed.

shortcuts

keyframe Important positions in the action defining the starting and ending points of any action. A
keyframe is a computer-generated position at a specific moment (frame) on a given
trajectory.

layer In animation, a layer is an individual column, level or character. A scene's layers are
superimposed to form the final image.

layout The communication step between the storyboard and the animation. It is the action of

putting the storyboard on model. That is, drawing the character by following the design in the
model pack, so the animator can start working.

The layout artist draws the background, creates the camera and field guide matching the
scene and camera motion. Lastly, the animator draws on model the main action poses.

layout and posing

The action of putting on model (at the right scale) the storyboard for the animator to start
working.

layout artist

The artist who draws the background, and creates the camera and field guide to match the
scene and camera motion. They will draw on model the main action poses.

layout planning

Drawing of the main features of the scene used as reference when planning the animation
and executing the initial stages of it.

layout process The communication step between the storyboard and the animation.

library A storage area containing templates and assets that can be reused in any project or scene.

light table A device that allows you to see other layers in transparency while you are working on a
particular layer.

line of action The direction that the action will follow. Also known as path of action.

lip-sync The process of synchronizing a character's mouth to sounds in the dialogue soundtrack.

The mouth is adjusted frame-by-frame to match the sound of the dialogue and provide the
illusion that the character is speaking. Lip-sync can be used for any sound sequence, not
only speech, you could for instance have a bird chirping or a wolf howling at the moon.

low resolution

A format that is ideal for videos destined for the web, where size and fast download of a
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video file take precedence over quality. A low-resolution image is one that lacks fine detail.

manual lip-sync
detection

The manual swapping of mouth position drawings to match a voice track. For this process,
both sound scrubbing (listening to a sound wave broken up frame-by-frame) and drawing
substitutions are used.

master palette

A group of colours attributed to a character or prop. The palette is used throughout the entire
production to maintain consistency in the look and to ensure that the same colours are used
throughout the production. Also known as palette.

model/colour
model

The definitive character, prop or location design each artist must follow for a production. A
colour model is the official colour design that must be used to paint the animation.

morphing

A feature for creating computer-generated drawings between a source drawing and a
destination drawing. Animation created with the morphing feature can be reused in different
projects.

motion keyframe

A keyframe with computer-generated interpolation.

mouth chart

A chart based on the eight animation phonemes (A, B, C, D, E, F, G, and X, which is used
to represent silence) used for lip-sync.

multiplane The effect of passing through multiple levels of drawings to create a sense of depthina
shot. A multiplane is a scene in which the layers are placed at different distances from the
camera so that when the camera moves, a depth illusion occurs. With a multiplane, all the
perspective and scale is calculated automatically.

NTSC The standard analogue television broadcasting system used in North America. NTSC
conforms to North American standards on how rectangular pixels are displayed for
computer and television screens.

nudge A small push (left, right, up, down, forward or backward) done with the keyboard arrow keys
on a selected element. Nudging is used to move a selection very slightly and precisely.

onion skin A feature that lets you see the previous and next drawings of a sequence.

overlay A part of the scene environment, such as a chair or a bush, that is placed in front of the main
animation.

PAL A resolution that works best with the European format for television and computer screens,

as the rectangular pixels are displayed at a different orientation.

palette/master
palette

A palette or master palette is a group of colours attributed to a character or a prop. The
palette is used throughout the entire project to maintain a consistency in the look and avoid
the colour changing during the animation. Also referred to as a master palette.

palette style

A palette style is a second version of an existing palette with a slight change in the tint and
value. A palette style can be used to create the night version of a palette. It may also be
called a clone palette.

animation/tradigital

pan To move the camera across the scene in any direction.

panel In a storyboard, a panel is a frame in a shot. A shot can be composed of one or several
panels.

paperless The paperless animation process is the action of animating digitally. The main paperless

animation process is to draw, frame by frame, the animation directly in the software.

passing position

When drawing a walk sequence for a character, the passing position is the point at which
one leg passes the other.
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path of action

Direction that the action will follow. Also known as line of action.

ped In traditional animation, a tool used to ensure accurate registration of action as cel layers
move. In digital animation, in which you are doing a more advanced puppet rigging, you can
use peg layers. Peg layers are trajectory layers that do not contain drawings. They are
motion paths that you can use to add path articulations. For the latter, you can also use an
inverse kinematics tool.

phoneme A unit of sound in a language.

pivot The point around which a peg or drawing rotates.

pixel The smallest element of an image displayed on a monitor or TV screen.

Pixel, short for picture element, is a single point in a graphic image. It is a small sample of
an image, a dot, a square, or a very small section made out of smooth filtering. If you zoom
in close enough on a digital image, you will see the pixels, which look like small squares of
different colours and intensity.

pose-to-pose
animation

The pose-to-pose animation process is the action of creating all the main action poses,
called key poses, and then placing the secondary poses between the keys. The secondary
poses are called breakdown. Finally, the animator fills the gaps with the in-between
drawings to achieve a smooth animation.

rendering

The final step when animating by computer. During rendering, the computer takes each
pixel that appears on screen and processes all of the components, as well as adding motion
blur before it produces a final image. The process of calculating the final images after the
compositing process.

resolution

The size of a scene, generally calculated in pixels. For example, the NTSC resolution is 720
x 480. The resolution should match the final output: HDTV, film-1.33, film-1.66, NTSC,
PAL, low.

RGB

Red, Green, Blue. A method of defining colour by specifying amounts of these three colour
components.

rigging

The process of attaching the various parts of a cut-out puppet.

rotary table

Equivalent to the animation disk/table, a device that allows you to rotate the workspace for
greater comfort while drawing.

rotoscoping

An animation technique in which animators trace over live-action film movement, frame by
frame, for use in animated films. The act of sketching over live-action footage to create an
animated sequence.

roughs

Rough is a common name in an animation movie for a drawing that is used as a reference
but which does not form part of the final image. A layout is a rough.

The skeleton sketch of an animation or design. Roughs mainly consist of sketch lines and
shapes, but can also contain design details.

safe area

The zone at the center of a scene's frame that is safe from being cropped by the TV frame.
As a TV frame cuts a margin off the original frame size, maintaining a safe area ensures that
the scene's main action will remain clearly visible once the film is screened on television.

scene

A shot in a movie or show. A sequence is composed of several scenes. A scene changes to
another scene by a simple cut or transition.

283




Glossary

script The original text containing all the movie or show information. In animation, the script
contains all of the location descriptions, dialogue, time and more. A project starts with a
script.

sequence A series of scenes or shots forming a distinct part of the story or movie, usually connected
by unity of location or time.

shot A scene in a movie or show. A sequence is composed of several shots. A shot changes to
another shot by a simple cut or transition.

slow-in The gradual acceleration in the action. Also known as ease-in.

slow-out The gradual deceleration in the action. Also known as ease-out.

slugging To indicate the start and stop times of dialogue and relevant actions.

sound scrubbing

A process that lets you hear sound in real time while you move the playhead forward or
backward. This is very useful for finely-tuning a lip-sync.

stop-motion A keyframe with no computer-generated interpolation.
keyframe
storyboard A visual plan of all the scenes and shots in an animation. The storyboard indicates what will

happen, when it will happen and how the objects in a scene are laid out.

straight-ahead

A technigue in which an entire sequence is drawn from the first position to the last, in order.

animation There is very little planning in this methodology. Where the character ends up and how it
gets there can be a surprise for both the audience and the animator. While this approach is
spontaneous and creative, it can create inaccurate results.

strokes Invisible vector lines forming the drawing zones. They can be adjusted with Bézier handles.

symbol A symbol combines animation, artwork or layers into a single object that you can control in
one layer. You can also create symbols out of each body part in your cut-out puppets.
You can place whatever you want in a symbol. You can use symbols to animate a puppet or
create reusable animations such as blinking.

tablet/pen A device used in conjunction with, or instead of, a mouse to move a mouse pointer
(sometimes referred to as the cursor) around the computer screen.

template An asset stored in the library that can be reused in any project. A template can be a drawing,
a series of keyframes, a sound file, a panel, a cut-out character, an effect, a trajectory, an
animation, or anything else used in the animation.

thumbnail A very small image used as a reference or indicator.

timecode The timing information printed on a movie clip to indicate the scene, hour, minute and
second that is currently displayed on the screen.

timeline A horizontal representation of a scene's elements, timing and keyframes.

trace and paint

After the rough animations have gone through cleanup and a final line or pencil test, each
drawing is traced and painted for the final animation. In today's digital world, this may be
done in a variety ways other than the traditional celluloid or acetate methods.

track breakdown

The break down of an animated film's soundtrack into individual sounds to produce the
precise frame-by-frame position of each sound.

traditional

A type of animation process whereby all the animation sequences are drawn by hand on
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paper before scanning or inking them on cels.

trajectory

A computer-generated path or trajectory that elements can follow. The trajectory can be
controlled by control points, keyframes and velocity.

transition

An effect placed between two scenes as they pass from one to the other. Common
transition effects are cross-dissolve and wipe.

underlay

In animation, an underlay is a specific part of the decor placed behind the main animation.

vector

A vector-based image is composed of points and Bézier curves. The computer reads the
points and traces the segments, linking them to reproduce the image shape. There is no
fixed size or resolution in a vector image. The graphic can be enlarged and distorted as
much as desired and the system will simply recalculate the segments and rebuild the
shapes. Vector images are translated and displayed in pixels once the calculation is done.

velocity

In animation, the velocity, also known as ease, is the acceleration or deceleration of a
motion. This can be achieved by a function curve, or via a series of animated drawings.
Other common terms for ease-in and ease-out are slow-in and slow-out.

walk cycle

A series of drawings "on the spot" that describe the walk for a character. The illusion of
movement is created by the use of background pans. To avoid making innumerable
drawings, animators routinely make a walk cycle for a character.

Zone

An area which can be painted with colour.
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alpha channel 277
animatic 277
animating
camera 169
animation 277
anime 277
arc 277
aspectratio 277
auto-feed 277
axis 277
background 277
Bezier 277
bitmap images 277
importing in original format 9
breakdown 278
camera
adding and parenting to peg 169
animating 169
camera shake 278
caption 278
cel 278
celluloid
See cel. 278
character design 278
clean up 278
CMYK 278
colour card 278
colour model 278, 282
colour wheel 278
compositing 278
cross dissolve 278
cut 278
cut-out animation 278
cycle 279
dialogue 279

dope sheet 279

doping 279

DPI 279

ease 279

ease-in 279

ease-out 279

establishing shot 279

exposure 279

exposure sheet 279

fade-in 279

fade-out 279

field chart 280

film-1.33 280

film-1.66 280

flipping 280

follow-through 280

forward kinematics 280

frame 280

frame rate 280

Function view 184
displaying functions 180, 185

functions 280
displaying 180, 185

gamut 280

HDTV 280

Hold 280

HSV 280

importing
bitmap image in original format 9
sound file 208
templates 95

in-between 280

ink and paint 280

interpolation 281

jump cut 281

key pose 281

keyboard shortcuts 281

287

keyframes 281
Layer Properties editor
displaying 126
layers 281
panning with Transform tool 116
rotating with Transform tool 117
skewing with Transform tool 118
layout 281
layout and posing 281
library 281
Library view
importing templates 95
lighttable 281
line of action 281
lip-sync 281
auto detection 277
lip-sync detection
manual 282
low resolution 281
manual lip-sync detection 282
master palette 282
model 282
model sheet See character design
motion keyframe 282
mouth
chart 282
multiplane 282
NTSC 282
nudge 282
onion skinning 282
overlay 282
PAL 282
palettes 282
style 282
panel 282
panning 282

layer using Transform tool 116
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paperless animation 282
passing position 282
path of action 283
pegs 283
pen 284
Perspective view 151

rotating a scene 152
phoneme 283
pivot 283

repositioning permanently 123
pixel 283
pixelation See bitmap image
pose-to-pose 283
rendering 283
resolution 283
RGB 283
rigging 283
rotary table 283
rotating

layer with Transform tool 117
rotoscoping 283
roughs 283
safe area 283
scaling

layer with Transform tool 118
scanning

VectOptions.conffile 71
scene setup

panning layer using Transform
tool 116

repositioning pivot permanently 123

rotating layer with Transform
tool 117

scaling layer with Transform
tool 118

skewing layer with Transform
tool 118

scenes 283

rotating in Perspective view 152

script 284
scrubbing 284
sequences 284
shot 284
Side view 150
opening 168
positioning elements 147
skewing
layer with Transform tool 118
slow-in 284
slow-out 284
slugging 284
sound
importing sound file 208
scrubbing 284
stop-motion keyframe 284
storyboard 284
straight-ahead 284
strokes 284
tablet 284
templates 284
creating 85
importing 95
thumbnails 284
timecode 284
timeline 284
Top view 148
opening 168
positioning elements 147
trace and paint 284
track breakdown 284
tradigital 282
traditional animation 284
trajectory 285
Transform tool
panning layer 116

rotating layer 117

288

scaling layer 118
skewing layer 118
transition 285
underlay 285
VectOptions.conffile 71
Mac 71
Windows 71
vector 285
vectorization
creating a style 69
parameters, creating 69
parameters, custom 61
parameters, modifying 69
Vectorization Parameters dialog box
Help tab 64
opening 62
Options tab 62
velocity 279, 285
views
Function 184
Perspective 151
Side 150
Top 148
walk cycle 285
zone 285



	Toon Boom Harmony 12.2.1- Advanced Edition -Compositing and Effects Guide
	Contents
	Chapter 1: Compositing - An Introduction
	Chapter 2: Import
	Importing Bitmap Images
	Importing PSD Files as Separate Layers
	Exporting and Reimporting a PSD Layout
	Scanning Images
	Importing AI and PDF Files
	Importing Adobe Flash Files
	Importing QuickTime Movies
	Creating Custom Vectorization Parameters

	Chapter 3: Library
	Understanding the Library Concept
	Library View
	Organizing the Library
	Templates
	Symbols
	Importing Symbols and Templates
	Importing Files Through the Library
	Using Paste Special

	Chapter 4: Scene Setup
	Importing the Scene Elements
	Setting the Camera Frame
	Positioning the Scene Elements
	Cloning and Duplicating Layers
	Working with Groups
	Display Concepts
	Timeline View Modes
	Creating a Multiplane

	Chapter 5: Path Animation
	Animating a Layer
	Differences between Animated Layers and Pegs
	Layer Parameters
	Adding and Deleting Keyframes
	Motion and Stop-motion Keyframes
	Animating the Camera
	Modifying a Path in the Camera, Top and Side Views
	Modifying a Path in the Timeline View
	Modifying a Path in the Function View
	Modifying a Path in the Xsheet View
	Function Curves
	Copying and Pasting a Motion
	Adjusting the Velocity

	Chapter 6: Sound
	Importing a Sound File
	Sound Layer Properties and Sound Element Editor
	Sound Displays
	Sound Playback
	Sound Scrubbing
	Editing a Sound File
	Adding an Empty Sound Layer
	Lip-sync

	Chapter 7: Effects
	Chapter 7: Effects
	Adding Effects
	Previewing Effects
	Animating an Effect over Time
	How Does an Effect Work?
	Effects in Harmony
	Blending
	Blur - Gaussian
	Blur

	Chapter 8: Export
	Exporting a QuickTime Movie
	Exporting an SWF Movie
	Exporting Image Sequences
	Exporting OpenGL Frames

	Glossary
	Index

