
TOON BOOM HARMONY 12.1
- Premium Edition -

Cut-out Animation Guide (Server)



Legal Notices

Toon BoomAnimation Inc.
4200 Saint-Laurent, Suite 1020
Montreal, Quebec, Canada
H2W 2R2

Tel: +1 514 278 8666
Fax: +1 514 278 2666

toonboom.com

Disclaimer

The content of this guide is covered by a specific limited warranty and exclusions and limit of liability under the
applicable License Agreement as supplemented by the special terms and conditions for Adobe®Flash® File
Format (SWF). For details, refer to the License Agreement and to those special terms and conditions.

The content of this guide is the property of Toon BoomAnimation Inc. and is copyrighted.

Any reproduction in whole or in part is strictly prohibited.

Trademarks

Harmony is a trademark of Toon BoomAnimation Inc.

Publication Date

2015-08-07

Copyright © 2015 Toon BoomAnimation Inc. All rights reserved.

2

http://www.toonboom.com/


Harmony 12.1 Premium - Cut-out Animation Guide (Server)

Contents
Toon Boom Harmony 12.1- Premium Edition -Cut-out Animation Guide (Server) 1

Contents 3

Chapter 1: Cut-out Animation - An Introduction 15

Chapter 2: Design and Drawing Tools 17

Preparation 17

Getting References 18

Using the Workspace 18

Sketching the Model 19

Drawing with the Brush or Pencil Tool 19

Override Tool 20

Relative Size 21

Palettes and Colours 25

Sketching the Character 32

Cleaning and Inking the Model 34

Drawing Tasks 39

Current Drawing on Top 40

Drawing with the Pencil Tool 40

Working with Pencil Presets 43

Pencil Line Texture 49

Drawing with the Brush Tool 53

Drawing with Textured Brushes on Vector Drawing Layer 60

Drawing with Bitmap Brushes on Bitmap Drawing Layers 71

Creating Bitmap Brushes 81

Viewing the Final Lines as You Draw 83

Full Scene Antialiasing 83

Selecting the Current Colour of a Tool 84

Using Independent Colours when Working with Bitmap Layers 87

Selecting Drawing Objects 87

Erasing Parts of a Drawing 91

Reshaping a Drawing Using the Contour Editor Tool 94

Reshaping Pencil Lines with the Pencil Editor Tool 96

Drawing with Shapes 99

Drawing with the Polyline Tool 100

Drawing with Invisible Lines 101

3



Contents

Deforming a Drawing with the Perspective Tool 103

Warping a Drawing with the Envelope Tool 104

Cutting Drawing Parts 106

Smoothing Lines 107

WorkingWith Text 108

Working with Tool Presets 109

The Tool Presets Toolbar 109

More Drawing Tools 112

Arrange 112

Convert Brush Strokes to Pencil Lines 113

Pencil Lines to Brush Strokes 114

Strokes to Pencil Lines 114

Optimize 114

Remove Extra Strokes 115

Reduce Drawing Texture Resolution 115

Crop Brush Textures 116

Create Contour Stroke 117

Remove Contour Stroke 117

Grid 118

Group/Ungroup 118

Hand 118

Rotate View 119

Drawing Tool References 119

Pencil Tool Options 120

Vector Brush Tool Options 125

Bitmap Brush Tool Options 129

Select Tool Options 153

Reverse Pencil Thickness 160

Eraser Tool Options 162

Bitmap Eraser Options 166

Contour Editor Options 166

Pencil Editor Options 169

Shape Tool Options 173

Polyline Tool Options 177

Stroke Tool Options 179

4



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

Perspective Tool Options 180

Envelope Tool Options 181

Cutter Tool Options 184

Smooth Editor Tool Options 186

Text Tool Options 188

Drawing Pivot Tool 192

Chapter 3: Colour Styling and Colour Models 195

Preparation 195

Colour Model Storage 196

Scene Creation 196

Colour Model Scene Structure 197

Setting Up the Workspace 197

Naming 197

Working with Palettes 200

Palette Lists 201

Palette File Storage 205

Element Level 205

Scene Level 206

Where to Save the Palette File 206

What happens when you export a palette file? 206

Palette Backup 207

Creating a Colour Palette 207

Duplicating a Colour Palette 211

Cloning a Colour Palette 213

Palette Operations 215

Importing and Linking Palettes 219

Colours 224

Adding a Colour Swatch 225

Editing Gradients and Textures 232

Colour Display Modes 237

Copying and Pasting Colours 238

Mixing Colours 239

Painting the Model 241

Sharing the Colour Model 243

Chapter 4: Timing 249

5



Contents

Preparation 249

Frames 251

Creating Drawings 253

Layer and Column Concepts 254

Layer and Column Types 255

Advanced Column Types 258

Adding New Drawing Elements 258

Deleting Layers and Columns 261

Layer and Column Properties 262

Modifying Layers and Columns 265

Duplicating Layers and Columns 268

Cloning Layers and Columns 268

Adding an Annotation Column 269

Linking External Files with Timing Columns 274

Filling Exposure 276

Filling Exposure Mode 277

Typing Exposure 277

Holding Exposure 279

Extending a Single Exposure 280

Extending an Exposure Sequence 281

Extending the Exposure of Previous Drawings 282

Dragging Cells 283

Increasing and Decreasing Exposure 286

Deleting Exposure 288

Inserting Blank Cells 289

Setting the Exposure 290

Filling a Selection with a Single Exposure 291

Filling a Selection with a Sequence 292

Filling a Selection Randomly 294

Filling Empty Cells 295

Creating Cycles 296

Overwriting Exposures and Keyframes 299

Managing Key Exposures 300

Adding Key Exposures 300

Removing Key Exposures 302

6



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

Removing Duplicate Key Exposures 302

Pasting Key Exposures Using Different Modes 303

Navigating between Frames and Columns 305

Managing Drawings 306

Renaming a Drawing 306

Deleting a Drawing 308

Duplicating a Drawing 309

Copying and Pasting Drawings 309

Merging Drawings 311

Modifying the Layer and Column Display 314

Expanding and Collapsing Layers and Columns 314

Showing or Hiding Layers 315

Showing and Hiding Columns 317

Modifying the Look of the Column 320

Drawing Identification 321

Key Drawing 322

Breakdown Drawing 323

Xsheet Thumbnails 325

Changing the Colour of a Layer or Column 326

Setting Scene Markers 327

Setting Tempo Markers 330

Printing the Xsheet 331

Modifying Paste Presets 333

Chapter 5: Character Building 337

About the Model 338

Model Alignment 338

Photo Puppets 339

Relative Sizes 339

Line Up 340

Field Chart 341

Brush Size 341

Studying the Model 342

Eyelids and Pupils 343

Separating the Mouth Elements and Jaw 343

Keeping Fingers Attached to the Hand 343

7



Contents

Flipping Logos 344

Complete and Overlapping Pieces 344

Setting the Default Separate Position Preferences 345

Naming Conventions 345

Adding a Prefix or Suffix to a Layer 346

Naming the Drawings 346

Disabling the Animation on Drawing Layers 347

Art Layers 349

Creating Strokes 354

Breaking Down the Character 356

Tracing the Model 356

Articulations 359

Classical Articulation 360

Auto-patch Articulations 362

About the Auto Patch Node 364

Ordering the Layers 366

Ordering the Timeline Layers 367

Ordering Layers in the Network View 367

Nudging Parts Backwards and Forwards 368

Rigging 370

About Rigging 370

Simple Rigging 371

Parenting Layers 372

Rigging Using Pegs 373

Adding Pegs 374

Rigging the Head 375

Rigging the Body 377

Connecting Nodes to a Composite Node 378

Creating a Hierarchy 379

Adding the Master Peg 381

Creating the Keyframes 382

Setting Properties for Many Layers 383

Masking 385

Adding Extra Drawings 387

Setting the Pivots 389

8



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

Skeleton Optimization 391

Deleting the Write Node 391

Renaming the Display Node 392

Changing the Composite Type 393

Grouping Nodes 394

Storing the Character in the Library 396

Appendix 400

Break Down: Cutting the Character in Pieces 401

Breaking Down the Main Parts 401

Breaking Down the Secondary Parts 404

Selecting and Incorporating to an Existing Layer 407

Breaking Down the Extra View Main Parts 407

Breaking Down Secondary Parts in the Extra Views 408

Completing the Parts and Articulation 409

Cleaning the Parts 409

Break Down: Distribute to Layers 412

Converting the Layers into Symbols 413

Patch Articulation 416

Setting Different Pivots for a Puppet Using Symbols 421

Setting Pivots on a Frame Range 423

Adding New Drawings to an Existing Template 425

Chapter 6: Deformation 427

Main Types of Deformations 427

Bone Deformation 428

Game Bone Deformation 428

Curve Deformation 429

Envelope Deformation 429

Adding Basic Deformation Chains 431

Setting Up the Resting Position 439

Regions of Influence 448

Displaying the Deformation Controls 456

Assembling Pieces 457

Assembling Guidelines 457

Animating Deformations 462

About Deformation Poses (Transformation Chains) 471

9



Contents

Preparing the Character 471

Understanding the Multi-pose Structure 472

Renaming the Drawings 473

Creating New Deformation Chains (Transformation Chains) 474

Converting Deformation Animation to Drawings 479

Handling Legacy Deformations 479

Deformation Toolbar 483

Rigging Tool Properties 486

Mode 486

Rig Tool Options 486

Operations 487

Deformation Nodes 488

Chapter 7: Library 517

Understanding the Library Concept 517

What is a Library? 518

What is a Template? 518

What is a Symbol? 518

Libraries in Harmony Server 519

Library View 520

Structuring the Library 522

Templates 526

Master Template 526

Creating a Template from the Node View 526

Action Templates 528

Creating a Template from the Timeline View 528

Symbols 530

Importing Symbols and Templates 539

Importing Files Through the Library 544

Using Paste Special 545

Chapter 8: Cut-out Animation 551

Getting the Character 552

Selecting the Pose 555

Extending the Exposure 556

Keyframes and Drawing Blocks 557

Creating Keyframes and Drawings in the Timeline View 557

10



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

Creating a Simple Cut-out Animation 559

Selecting Layers to Animate or Position 561

Animate Mode 561

Selecting Drawing Layers Using the Transform Tool 562

Selecting an Element in the Camera View Using the Transform Tool 563

Selecting a Layer in the Timeline View 563

Selecting in the Network View 563

Navigating the Hierarchy 564

Animating Using the Transform Tool 565

Animating Using Inverse Kinematics 567

About IK Hierarchy Chains 568

Single Chains 568

Direct Chains 569

All Chains 569

Where to Start with Inverse Kinematics? 569

Inverse Kinematics Tool Properties 571

Mode 571

IK Options 572

Selection 572

Setting Up the Character to Use IK 573

Nails 576

Minimum andMaximum Angle 577

IK Keyframes 578

When to Use the Inverse Kinematics (IK) Tool 580

IK Tool and Rigging 581

The Basic Rig Technique 581

The Hierarchy Rig Technique 581

The Mixed Rig Technique 581

Animating with the Tools 581

Inverse Kinematics Philosophy 581

Tips and Tricks for Inverse Kinematics 582

Animating in Stop-motion 582

Creating a Stop-motion Keyframe 583

Animating Using Computer-generated Interpolation 583

Creating a Motion Keyframe 584

11



Contents

Adjusting the Ease 585

Marking the Timeline 589

Flipping Through Poses 592

Using the Onion Skin in Cut-out Animation 593

Flipping Parts 596

Using Action Templates 597

Swapping Drawings 598

Adding Key Exposures 602

Removing Key Exposures 603

Animating Lip-Sync 604

Adding a New Drawing 608

Duplicating a Drawing 608

Reposition Drawing Tool 609

Ordering Layers Over Time 612

Resetting a Transformation 613

Creating Cycles 614

Copying and Pasting Animation 616

Adding Pegs 618

Offsetting a Portion of an Animation 619

Chapter 9: Morphing 621

Understanding Morphing 622

Ideas behind Morphing 622

Source and Destination Drawings 622

Morphing Rules 623

Creating a Basic Morphing Sequence 627

Tool Properties View 629

Adjusting the Velocity and Timing 632

Morphing Tool and Hints 635

Using the Morphing Tool 636

Hints 639

Copying Hint Points from One Drawing to Another 641

Morphing Layers 643

Morphing Two Sequences in a Row 650

Inserting a Morphing Key Drawing 651

Converting Morphing Inbetweens to Drawings 652

12



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

Morphing Holes and Transparencies 652

Adjusting the Morphing Quality 655

Tips and Tricks 655

Glossary 656

Index 667

13



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

14



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

Chapter 1: Cut-out Animation - An Introduction
Harmony is a high-performance animation software which not only offers a wide range of features, but also
handles more than one animation type and workflow. In this guide, you will learn how to perform tasks related to
the cut-out animation workflow from start to finish using Harmony.

Before reading this guide, be sure to take some time to familiarize yourself with the basic concepts in the
Fundamentals Guide. Each chapter is self-contained. so you can concentrate only on the chapter pertaining to
your task. You do not need to read the entire guide, but you should read the whole chapter before starting to
work.

Topics in this section:

• Design and Drawing Tools on page 17

• Colour Styling and Colour Models on page 195

• Timing on page 249

• Character Building on page 337

• Library on page 517

15



Chapter 1: Cut-out Animation - An Introduction

• Cut-out Animation on page 551

• Deformation on page 427

• Morphing on page 621
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Chapter 2: Design and Drawing Tools

Another important step in the project creation is the character, prop and location design. This determines the
style and models to follow for the entire project.

This is also the step where you will need to usemost of Harmony's drawing tools.

The design can be created on paper and scanned in or it can be created digitally. You can draw and even create
the colours entirely on paper, while others like to design on paper and scan the drawings to create the colour
model in a software program. Themost popular method is to design directly in Harmony.

To save paper and time and avoid having to recreate colour palettes, Harmony gives you the ability to design all
elements directly in the application. This keeps all your work within the same software, avoids using a lot of paper
and losing time scanning in elements and importing them.

The character and prop design process is divided in three steps:

• Preparation on page 17

• Sketching theModel on page 19

• Cleaning and Inking theModel on page 34

Harmony has an extensive set of drawing tools that can be used to design your characters. You can learnmore
about this in the following topic:

• Drawing Tasks on page 39

Each drawing tool has a series of options to customize its behaviour and drawing style. You can learnmore about
them in the following section:

• Drawing Tool References on page 119

Preparation
To prepare for the design task, you will need to go through a few steps:

• Getting References on page 18

• Using theWorkspace on page 18
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Getting References

Creating models requires two main reference sources, the script and the storyboard. Once you have the script
in hand, you can learn about the characters and their personalities, the props, the ambiances, and so on. This
will be your main reference, so it is very important to read it carefully.

The storyboard is the second reference source and it can be quite useful as well. Although it will not yet be the
final version of the storyboard, it will show youwhat the character is doing and what props need to be
designed.

Using the Workspace

Once your scene is created, you can open it and set your workspace.

To sketch the characters, props or locations directly in Harmony, you will mostly use the Camera or Drawing
views along with the Colour, Timeline and Tool Properties views.

18
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Sketching the Model

Now that your references and scene are created, you can start designing. To draw your characters, props and key
locations, you will need to learn the following:

Drawing with the Brush or Pencil Tool

The Brush and Pencil tools are used for drawing and sketching. Both tools support pressure sensitivity,
allowing you to create lines with variable thickness. The Brush tool produces contour vector lines. The Pencil and
shape tools produce central vector lines. This means that a pencil line’s control points (used to deform its shape)
are located along the length of the central spine, while the Brush line’s control points are located along the
contour.

• If you draw with the Brush tool and want to modify the thickness variation, use the Contour Editor
tool.

• If you draw with the Pencil tool and want to modify the thickness variation, use the Pencil Editor tool.

• You can also convert a brush zone into a pencil line with the Brush Stroke to Pencil Line option.
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If you sketch a drawing using a semitransparent colour to get a paper-like feel, you should use the Brush tool
as it produces a more realistic and natural feel. The pencil line is very useful for tracing clean or final drawings.

Also, it is recommended to use brush lines when designing cut-out puppet articulations which use patches.

Override Tool

TheOverride tool lets you increase productivity by rapidly switching between tools used for short tasks and
your previous tool. Most drawing tool shortcuts are accessed using the Alt key followed by another key, such
as the Eraser tool which is accessed by pressing Alt + E.

If you are drawing with the Brush tool and need to briefly switch to the Eraser before continuing, hold down
the E key while you are erasing. Once you are done, release the E key to return to the previous tool; in this
case, the Brush tool. You can do the same for most drawing tools that have a shortcut composed of Alt
followed by another key.

20



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

Relative Size

The size relation between the props, characters and backgrounds is very important inmaintaining consistency
and structure throughout the project.

A production can containmany characters and props. It is not unusual for these to be created by different people.
If there is no size control implemented, the characters and elements created by different artists can vary greatly.
When this occurs, the characters that are placed together in a scene will be out of proportion. The animator or
person doing the scene setup will then have to scale them to the correct size.

When a character or prop is scaled down, the outline will become increasingly thinner. By the time the element is
scaled to its proper size, the outlinemay be so thin that a difference between one character's outline and the one
beside it will not look very good.

Here are a few tips you can use to create a suitable size relation.
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Line Up

A line up consists of copying and pasting all your character designs into the same drawing and then scaling
them to the correct proportion in relation to the other characters. This line up is very important and should be
handed to any animator, layout and posing artist or scene setup person working on the project.

For the prop design, it is recommended that you paste one of themain character's hands or even the full body
beside the prop. This enables the animator to know what size to draw the prop.

In your character design scene, it is a good idea to create a column for the character line up.The line up is
usually done during the character design step. When the character builder imports themodel to the
breakdown scene, the size relation should be correct.

Field Chart

Harmony includes a field chart in its Drawing and Camera views. This tool is very useful in setting the
characters' and props' heights.

It is recommended that you keep the character design and breakdown inside the 12 field size. This ensures that
it fits the default camera size and the template thumbnails. If some parts were drawn too big or too far apart,
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you can use the Reposition All Drawings tool and reposition, scale or rotatemultiple drawings from different
layers all at once.

Use the Show Grid option to display a grid in the Drawing or Camera views.

Name Button Description Keyboard Shortcut

Show Grid
Displays the grid.

View > Grid > Show Grid

Press Ctrl + ' (Windows/Linux) or⌘ +
' (MacOS X).

Grid OutlineOnly Displays the outline of the grid only. View > Grid > GridOutline Only

Square Displays a standard square grid. View > Grid > Square

12 Field Grid Displays a 12-field size grid. View > Grid > 12 Field Grid

16 Field Grid Displays a 16-field size grid. View > Grid > 16 Field Grid

Underlay
Displays the grid under the drawing
elements.

View > Grid > Underlay

Overlay
Displays the grid over the drawing
elements.

View > Grid > Overlay

How to reposition all drawings

1. In the Tools toolbar from the Select drop-downmenu, select the Reposition All Drawings tool. This
also automatically selects every stroke in your drawing in the Drawing and Camera views.

2. To deform or reposition a selection:

‣ To reposition, click and drag your selection to a new area.

‣ To scale, pull or push on the top, side, bottom or corner control points. Hold down Shift to lock the
selection’s ratio.

23



Chapter 2: Design and Drawing Tools

3. When you release your cursor, every drawing contained in the drawing layer you repositioned, scaled,
rotated or skewed will follow the same transformation.

Brush Size

Harmony provides a variety of pens and brushes and also allows you to create and save your own through
creating a tool preset.

It is a good idea to create and save pens with precise sizes and parameters to trace and design your models
and breakdowns.

How to create a tool preset

1. In the Tools toolbar, select a tool, for example the Brush tool.

1. Use the Tool Properties view to customize the tool.

2. To set a specific colour for your preset, in the Colour view, select the colour swatch to link to the tool.
Note that when using this preset in another scene not using that colour palette, upon selecting this new
preset, a colour recovery dialog box will appear asking to add this colour to your scene.

3. In the Tool Presets toolbar, click the New Tool Preset button.

4. In the New Preset dialog box, in the Name field, type a name for your new preset.
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2. From the icon list, select an icon to quickly identify your preset or upload your own by clicking the File
button.

5. (Optional) From the Shortcut menu, set a keyboard shortcut to quickly access your preset. By default, the
shortcuts are unassigned. To assign a keyboard shortcut, go to the top menu and select Edit > Prefer-
ences > Shortcuts > Tool Presets (Windows/Linux) or Stage > Preferences >Shortcuts > Tool Presets
(MacOS X).

6. When you select any of the following options, they will take effect when you use the tool preset. If an
option is deselected, then using a tool preset will not override your current settings.

‣ Colour: Saves the current colour into the tool preset.

7. Click OK.

For more information on Tool Presets—seeWorking with Tool Presets

Palettes and Colours

Harmony has an integrated palette system. Each character, prop or background can have its own set of colours
and each colour in the palette can be associated to colour fill zones on a drawing. You can create as many
palettes and colours as you need.
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Each scene created in Harmony includes a default colour palette which contains a standard set of colours for
sketching and painting.

You can sketch and design using the default palette without any problem. However, it is not recommended
that you use the default palette for the colour models. A different colour palette should be created for each
colour model.

To sketch and design with a different colour swatch or create a palette for each character, prop or key
location, you will need to learn how to manage the Harmony palettes.

How to create a new palette (Basic Palette Lists mode)

1. From the Colour View menu, select Palettes >New or click the New Palette button.

‣ Make sure you have the necessary rights to modify the palette list. If not, select Edit > Edit Palette
List Mode.

The Create Palette window opens.

2. Enter the palette name according to themodel.
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3. Click OK.

The palette appears in the drawing element’s palette list.

How to create a palette from the Advanced Palette Lists mode

1. In the Timeline or Xsheet view, select the drawing that requires a palette.

2. Make sure that you have the necessary rights to modify the palette list. If you do not, select Edit > Edit
Palette List Mode.

3. In the Colour view, click the Show Palette List View button to display the palette list.

4. Do one of the following:

‣ From the Colour view menu, select Palettes > New.

‣ Click the Create Palette button.

The Palette Browser: Create Palette dialog box opens.
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5. Select the level to store the palette file.

‣ Environment: The palette-library folder is stored in the scene's parent environment folder.

‣ Job: The palette-library folder is stored in the scene's parent job folder.

‣ Scene: The palette-library folder is stored directly in the scene folder.

‣ Element: The palette-library folder is stored directly in the drawing element folder.

When you select a level that has a palette stored in it, the palette names are displayed in the Palette
field.

6. Name the palette. There is no need to add the suffix "palette"  to the name as it is always recognized as
a palette file.

7. Select a Palette List option.

‣ The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be divided
in twenty to thirty different drawing elements that use the character's master palette.

The palette list is stored at the scene level instead of the Element directory. This way, all palettes
linked to this list will appear in every drawing element created in the scene. There is no need to
manually load the palette in each element.

‣ The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-out
animation, all columns (drawing elements) contain different characters, props, backgrounds and
effects. The Element Palette List is used because you do not necessarily want all of the palettes for
all of your elements linked in every column.
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The palette list is stored in the drawing element's directory instead of directly in the Scene level. This
ensures that the links to the palettes appear only in the appropriate element. If you prefer to access a
global palette list, link your palettes to the Scene Palette List.

8. Click OK.

The new palette appears in the palette list.

How to lock or unlock the palette list

‣ In the Colour view, click the Edit PaletteMode button.

A grey pencil icon appears in the top-right corner of the Palette list.

How to add or modify a solid colour swatch

1. In the Colour view, click the Add Colour button.

2. From the Colour View menu, select Colours > Edit or double-click on the colour swatch.

The Colour Picker window opens.

3. To set your colour, do one of the following:

‣ In the colour wheel, select a colour.

‣ Enter the HSV or RGB values in the corresponding fields. Select the R,G,B,H,S or V options to change
the look of the colour picking area.

29



Chapter 2: Design and Drawing Tools

‣ Hold down the Dropper button as youmove along the desktop to preview colours, then release
to select the colour. It can be from the Toon BoomHarmony interface, your operating system or any
other open application.

NOTE: If the Sticky Eye Dropper option in the Preferences dialog box (Drawing tab > Options section) is selected,
the dropper will not have this behaviour.

You can also clickMultiWheelMode to open theMultiwheel Colour dialog box. This displays all the
picking area styles together and also contains a picking undo list. To return to the regular Colour Picker
window, click Single WheelMode.
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4. Click on the Shade Scale swatches to modify the shade of the selected colour.

5. Adjust the desired level of transparency with the Alpha slider, or type the value directly in the Alpha field.

6. Click theAdd button to add the current selected colour to the Colour Storage Library, so you can quickly
access it later.

7. You can rename the colour swatch in the Colour Picker window or directly in the colour list by double-click-
ing on its name.
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Sketching the Character

You are now ready to sketch your models. There are two tasks to perform in order to draw your characters:

l Add a drawing layer

l Sketch themodel

You have the choice to sketch your model as a bitmap or vector drawing. If you like the feel of drawing with
bitmap lines, you can set your layer as bitmap. If you like drawing with vectors, you can set your layer as vector.
If you use vector, you will be able to enlarge your drawing and zoom into it without losing quality or resolution.
You can also use the Contour Editor and Select tools to resize and modify lines. If you draw with bitmap, you
will not be able to scale the drawing beyond 100% of its resolution without encountering pixelization issues.

If you would like to separate your lines and colours on separated art layers, seeArt Layers on page 349

How to add a drawing layer

1. In the Timeline view, click the Add Drawing Layer button or press Ctrl + R (Windows/Linux) or⌘ +
R (MacOS X).

The Add Drawing Layer window opens.
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2. In the Name field, name your new layer.

3. Set the Line Art and Colour Art options to Vector to get a vector layer or to Bitmap to have a bitmap
layer.

4. Do one of the following:

‣ Click Add to add a first layer and keep the window open to addmore layers.

‣ Click Add and Close to add a new layer and close the window.

A new drawing layer is added to the Timeline view.

How to sketch a model

1. In the Tools toolbar, select the Brush tool or press Alt + B.

2. In the Tool Properties view, select a brush preset and adjust its parameters.

3. In the Timeline or Xsheet view, click in the first cell of the drawing layer.

4. In the Drawing or Camera view, enable theGrid (Field Chart). You can press Ctrl + ' (Windows/Linux) or⌘
+ ' (MacOS X).

‣ Make sure the Drawing or Camera view is the active view while using the keyboard shortcut.

5. In the Drawing or Camera view, start drawing.
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6. To select a different colour, in the Colour view, select a different colour swatch. Double-click on the col-
our swatch to open the Colour Picker window andmodify the colour. Remember that anything already
painted with that colour swatch will update to the new colour.

7. In the Camera or Drawing view, use the Rotary Table to rotate your workspace.You can press
Ctrl+Alt (Windows/Linux) or Ctrl+⌘ (MacOS X).

‣ The default keyboard shortcut to reset the workspace rotation is Shift + X.

8. If you decide to draw in the next cell and need to see your previous drawing, enable theOnion Skin by
pressing Alt + O.

Cleaning and Inking the Model
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When your roughmodels are ready, it is time to clean and ink them. You can still use the default palette and
colours to do so, especially if you are not the one doing the colour styling. If you have already created a palette
for your model, you can add new colours for tracing.

If you want to keep your roughs and sketches, add a new drawing layer and trace in it using the Light Table. This
is the equivalent of adding a sheet of paper and tracing over the rough using the animation disk light table. You
only need to disable the rough layer to prevent it from appearing in the final scene render.

If you would like to separate your lines and colours on separated art layers, seeArt Layers on page 349

How to trace your character in a new layer

1. In the Timeline view, add a new drawing layer and name it: clean.

2. If you work in the Drawing view, enable the Light Table or press Shift + L.

3. Do one of the following:

‣ In the Tools toolbar, select a drawing tool.

‣ From the top menu, select Drawing > Drawing Tools > desired tool.

4. In the Timeline or Xsheet view, select the cell in which you want to draw.

5. Trace themodel.

6. To make perfect points and corners, you can intersect the two strokes to create a point. Using the Cutter
tool, you can automatically trim the excess portion. In the Tool Properties view, enable the Lasso

selection type. Make sure the UseMouseGesture button is enabled. In this mode, you can auto-
matically delete any extra sections of line in your artwork by simply clicking, holding and dragging your
mouse over it.
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7. If you are using the Pencil tool to clean your drawing, you will need to merge your pencil lines together
after cropping the points.

‣ In the Tools toolbar, select the Select tool.

‣ In the Camera or Drawing view, select the two strokes to bemerged.

‣ In the Tool Properties view, click theMerge Pencil Lines button.

‣ You can also set the Join option toMitre.
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How to add thick and thin Lines

1. In the Tools toolbar, select the Pencil Editor tool located in the Contour Editor menu.

2. In the Camera or Drawing view, select a pencil line and click the line to reshape it.

3. Select one or several points by clicking on them or circling around.

4. Press Delete to delete a selected point.

5. Press Ctrl (Windows/Linux) or⌘ (MacOS X) and click the central spine to add a set of points to adjust the
contour.

6. To modify the shape, you can:

‣ Move the selected points to a new area.

‣ Pull the Bézier handle to move both points' handles as one.
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‣ Hold Alt down and pull one of the Bézier handles to move it independently from the other one.

‣ Pull directly on the line in-between two points. No selection is necessary. Holding down the Shift key
limits the contour modification to the curve between the two first points.

‣ If an anchor point has no visible bezier, hold down the Alt key to display them.

7. You can also use the Brush tool to draw some of the lines and change the tip to an oblique shape or
use a pen tablet which provides pressure sensitivity and lets you draw lines of variable thickness.
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Drawing with the Brush tool does not allow you to reshape your lines as easily as with the Polyline or Pencil
tool. The Brush tool creates contour vector lines (also known as fills) where the vector points are situated
on the line’s contour. Pencil lines are central vector lines in which the points follow the centre of the line.

Drawing Tasks
Harmony has a wide variety of drawing tools for all kinds of drawing tasks. This section covers how to use these
tools. For the complete details on their options in the Tool Properties view, seeDrawing Tool References on
page 119.

In this topic, you will learn about:

• Current Drawing on Top on page 40

• Drawing with the Pencil Tool on page 40

• Drawing with the Brush Tool on page 53

• Drawing with Textured Brushes on Vector Drawing Layer on page 60

• Viewing the Final Lines as YouDraw on page 83

• Selecting the Current Colour of a Tool on page 84Selecting the Current Colour of a Tool

• Selecting Drawing Objects on page 87

• Erasing Parts of a Drawing on page 91

• Reshaping a Drawing Using the Contour Editor Tool on page 94

• Reshaping Pencil Lines with the Pencil Editor Tool on page 96

• Drawing with Shapes on page 99

• Drawing with the Polyline Tool on page 100

• Drawing with Invisible Lines on page 101

• Deforming a Drawing with the Perspective Tool on page 103

• Warping a Drawing with the Envelope Tool on page 104

• Cutting Drawing Parts on page 106

• Smoothing Lines on page 107

• WorkingWith Text on page 108

• Working with Tool Presets on page 109

• More Drawing Tools on page 112
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Current Drawing on Top

In Harmony, when you draw on a layer, the artwork is displayed in the correct order. For example, if the layer
on which you are drawing is located behind an object on another layer, the lines you are drawing will be hidden
behind that object.

This lets you display the selected drawing on top of everything while you draw. By enabling this option, each
time you select a drawing tool, the selected drawing is displayed in front of everything in the Camera view. The
Timeline and Node view ordering remain unchanged.

The Current Drawing on Top status (enabled or disabled) is remembered when you exit Harmony. When you
restart the application, the last status will be used.

You only need to enable this option once, it is not necessary to do it each time you select a drawing tool.

How to display the drawing on top

1. Do one of the following:

‣ From the top menu, select View > Show > Current Drawing on Top.

‣ In the Camera bottom toolbar, click the Current Drawing on Top button.

2. In the Tools toolbar, select a drawing tool.

3. In the Camera view, start drawing.

Drawing with the Pencil Tool
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The Pencil tool is for drawing the final images, such as character nodes, cut-out puppet and clean animation. The
pencil creates a central vector shape. Pencil lines support pressure sensitivity and texture.

How to draw with the Pencil tool

1. In the Timeline or Xsheet view, select the cell on which you want to draw.

2. In the Tools toolbar, select the Pencil tool or press Alt + /.

3. In the Colour view, click a colour swatch to select a colour.

4. In the Drawing or Camera view, start drawing.

‣ When you get close to an existing pencil line, hold Alt to draw and connect your stroke to the existing
one. Pencil lines are central vector lines and youmight think your line is connected, but in fact, only the
contour is touching the other one. Also, make sure the central vector crosses the other one.
To connect the start or end of your stroke, hold Alt when you start or finish drawing a line.

‣ To draw a straight line, press Shift + Alt as you draw.

How tomodify the pencil settings

1. In the Tools toolbar, select the Pencil tool or press Alt + /.

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you customize
the different parameters in the Tool Properties view. Click the arrow button.
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The Pencil Properties window opens.

This is where you set theminimum andmaximum sizes of your drawing tool which will produce the thick
and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

Parameter Description

Size and Smoothness tab

Maximum Size Sets themaximumwidth of the line.
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Minimum Size Sets theminimumwidth of the line in relation to themaximum size.

Smoothness
Lets youmodify the central line smoothness of the line. This parameter
smooths the initial movement of your line. Increasing the value will result in a
smoother line with fewer control points.

Contour Smoothness
Optimizes the contour line smoothness of the line. This parameter will
smooth the contour of the line once it has been traced; the higher the value,
the fewer control points will compose your line.

Shape
You can adjust the start, end, and joint style of a selected pencil line.

• Start: Lets you select the style of the start tip, which is the first tip you
drew. You can choose between Round or Flat style.

• End: Lets you select the style of the end tip, which is the last tip you
drew. You can choose between Round or Flat style.

• Join: Lets you select the joint style. The joints are where the line
curves abruptly. You could also define the Join style as the corner
style. You can choose between Round, Mitre and Bevel style.

Texture tab

Texture See Pencil Line Texture on page 49.

Working with Pencil Presets

Apencil preset is a pencil with specific properties. You can work with regular pencil presets and thickness stencils.

Regular pencil presets allow you to set the size and smoothing of the line or shape. As you draw, the thickness of
the line varies according the amount of pressure you apply with a pen and tablet.

Thickness stencils that are indicated with this icon are also set with specific properties, but disregards the
pressure you use with your pen and tablet. The line thickness varies. You can access thickness stencils from the list
of presets on the Tool Properties view or create your own.
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How to select a pencil preset

1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle tool.

2. In the Tool Properties view, use the Presets menu to select a pencil preset.

3. In the Drawing or Camera view, draw your pencil line or shape.

How to select a pencil thickness stencil

1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle tool.

2. In the Tool Properties view, use the Presets menu to select a thickness stencil. They aremarked with this
icon.

3. In the Drawing or Camera view, draw your pencil line or shape.
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How to create a pencil preset

1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle tool.

2. In the Tool Properties view, adjust your pencil settings—seeHow to modify the pencil settings on page 41.

3. In the Tool Properties view, click the New Brush button.

TheNew Preset dialog box opens.

4. Type in a name for your new pencil thickness stencil and click OK.

5. Start drawing in the Drawing or Camera view.

How to create a pencil thickness stencil

1. In the Tools toolbar, select the Select tool.

2. In the Camera view, select the pencil line or shape fromwhich you want to take the style.

3. In the Tool Properties view, click the New Thickness Stencil button.

A new thickness stencil is added to the end of the list in the Presets menu.

4. In the Presets menu, select a new thickness stencil and click on a line or shape in the Drawing or Camera
view to apply the thickness stencil you created.

How to apply a thickness stencil to a pencil line or shape

1. In the Tools toolbar, select the Select tool.
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2. In the Drawing or Camera view, select the pencil line or shape onwhich you want to apply a style.

3. In the Tool Properties view, select the style you want to apply from the Presets list.

The style you selected is applied to your selection.

How to rename a thickness stencil or pencil preset

1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle tool.

2. In the Presets menu, select the thickness stencil or preset you want to rename.

3. From the Brushmenu , select Rename Brush.

The Rename Preset dialog box opens.

4. In the Name field, type in the new name.

5. Click OK.
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How to delete a thickness stencil or pencil preset

1. In the Tools toolbar, select the Pencil tool.

2. In the Presets menu, select the thickness stencil or preset to delete.

3. Click the Delete Preset button.

How to import pencils, brushes and erasers

1. From the Brushmenu , select Import Brushes.

2. In the browser window that appears, navigate to and select the .xml file.

3. Click Open.

4. In the Import Brushes dialog box, select the brushes brushes and erasers you want to import. You can also
import pencils at the same time.

5. Click Import.

The imported brush, eraser and pencil styles will appear in the presets library. You can reuse any of the
imported tips to create other brush, eraser and pencil style presets.
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How to export pencils, brushes and erasers

1. From the Brushmenu, select Export.

2. In the Export Brushes dialog box, select the bitmap and vector brushes and erasers to export, as well
as any pencils.

3. Click Export.

4. In the Export Brushes window that appears, browse to the location where you want to save the .xml file
and give it a name.

5. Click Save.

How to change the Presets Library thumbnail display

1. From the Brushmenu, select one of the following:

Parameter Description

Small Thumbnail
Reduces the size of the thumbnails in order to view more at the same time.
Displays an image of the tool's tip and its maximum size.

Large Thumbnail
Increases the size of the thumbnails in order to see the images more clearly.
Displays an image of the tool's tip, its maximum size and its name.

Stroke View Displays the tool's name, maximum size and stroke preview.
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Pencil Line Texture

You can apply a texture to a pencil line. Pencil lines support texture. Before drawing, you can select or import a
texture and apply it to your lines. You can also change it afterwards using the Select tool. Textures are
independent from pencil templates.

When you import a texture in your pencil styles, it is saved in your scene. If you want to add that texture to a bank
that you will reuse in different scenes, you can add that texture to your preferences.

There is a pencil texture palette created in each scene. In order for this palette to be created, you need to draw a
pencil stroke using texture. To see it, you need to enable the Advance Palette Lists option. Once enabled, you will
see a palette named pencilstyle_opacity in your palette list.

For advanced usage, you can assign a custom palette as your pencil texture palette. All textures used to draw in
your scene will be added to this custom palette. This gives you the ability to save your custom palette at the
Environment or Job level if you want to reuse that palette inmore than one scene.

How to apply a preset texture to a pencil line

1. In the Tools toolbar, select the Pencil tool.

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you customize
the different parameters in the Tool Properties view. Click the arrow button.

3. In the Pencil Properties editor, select the Texture tab.

4. In the Texture library, select a texture for the pencil.

5. In the Camera or Drawing view, draw a pencil line.

49



Chapter 2: Design and Drawing Tools

How to create a pencil texture template with the Pencil tool

1. In the Tools toolbar, select the Pencil tool.

2. In the Tool Properties view, click the arrow button beside the stroke preview area.

3. In the Pencil Properties editor, click the New Texture button or select New Texture from the Tex-
ture menu.

‣ To delete a preset style, click the Delete Texture button or select Delete Texture from the
Texture menu.

4. Browse for your bitmap texture file.

NOTE:
The following file formats are supported: .jpg, .png, .psd, .sgi, .tif. Your textureMUST HAVE an alpha channel.

5. Click Open.

The imported texture is saved in your texture list.

6. In the Pencil Properties editor, select your new texture.
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7. Click the Texturemenu and select Rename Texture.

The RenameOpacity Texture dialog box opens.

8. In the Name field, type the template name and click OK.

9. In the Camera or Drawing view, draw your pencil line with your new texture.

How to add a texture to your preferences

1. In the Tools toolbar, select the Pencil tool.

2. In the Tool Properties view, click the arrow button beside the stroke preview area.

3. In the Pencil Properties editor, select a texture from the Textures area to add to your preferences.

4. Click the Copy to Preference button.
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How to apply a preset texture to a pencil line

1. In the Tools toolbar, select the Select tool.

2. In the Drawing or Camera view, select a pencil line.

3. In the Tool Properties view, select a texture from the Textures area to apply to the selected stroke.

How to assign a custom palette as the Pencil Texture Palette

1. In the Colour view, create your custom palette and save it at the level of your choice.

2. Select the palette you want to assign as your pencil texture palette.

3. From the Colour view menu, select Palette > Pencil Texture Palette.

How to enable the Advanced Palette Lists preference

1. From the top menu, select Edit > Preferences ( Windows/Linux ) or Stage > Preferences ( MacOS X ).

2. In the Preferences dialog box, select theAdvanced tab.

3. In the Advanced Options section, select theAdvanced Palette Lists option.

4. Click OK.
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Drawing with the Brush Tool

The Brush tool is pressure sensitive and lets you create a contour shapewith a thick and thin line effect, as if it was
created with a paint brush.

With the Brush tool, you can draw as vector or bitmap, depending on your preference. When you add a drawing
layer, you can simply select the vector or bitmap option. If you draw with vector, you can enlarge your drawing
and zoom into it without losing quality or resolution. You can also use the Contour Editor and Select tools to
resize and modify lines. If you draw with bitmap, you will not be able to scale your drawing beyond 100% of its
resolution without encountering pixelization issues.

You can create your own brush styles. A variety of brush styles are provided allowing you to create and save your
own.This way you can create brushes with precise sizes and parameters and save them so you can draw and
design with them. Renaming a brush canmake it easier to identify and access the brushes you usemost
frequently.

A dynamic brush can be created for drawing using patterns created from your artwork. Create a new dynamic
brush to copy a pattern you have drawn to reproduce it quickly. You can create dynamic brushes using a single or
multiple patterns that automatically switch through the patterns as you draw.

How to draw with the Brush tool

1. In the Timeline view, click the Add Drawing Layer button or press Ctrl + R (Windows/Linux) or⌘ + R
(MacOS X).

The Add Drawing Layer window opens.
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2. In the Name field, name your new layer.

3. Set the Line Art and Colour Art options to Vector to get a vector layer or to Bitmap to have a bitmap
layer.

4. Do one of the following:

‣ Click Add to add a first layer and keep the window open to addmore layers.

‣ Click Add and Close to add a new layer and close the window.

A new drawing layer is added to the Timeline view.

5. In the Timeline or Xsheet view, select the cell on which you want to draw.

6. In the Tools toolbar, select the Brush tool or press Alt + B.

7. In the Colour view, click a colour swatch to select a colour.

8. In the Drawing or Camera view, start drawing.

‣ Hold Ctrl (Windows/Linux) or⌘ (MacOS X) to force a line to join the start and end of the shape
while drawing.
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How to select a brush style

1. In the Tools toolbar, select the Brush tool or press Alt + B.

2. In the Tool Properties view, select a brush style from the Presets section.

How tomodify the brush settings

1. In the Tools toolbar, select the Brush tool or press Alt + B.

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you customize
the different parameters. Click the arrow button.

The Brush Properties window opens.

This is where you set theminimum andmaximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.
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Parameter Description

Size and Smoothness Tab

Maximum Size Sets themaximumwidth of the line.

Minimum Size Sets theminimumwidth of the line in relation to themaximum size.

Smoothness
Lets youmodify the central line smoothness of the line. This parameter
smooths the initial movement of your line. Increasing the value will result in a
smoother line with fewer control points.

Contour Smoothness
Optimizes the contour line smoothness of the line. This parameter smooths
the contour of the line once it has been traced. The higher the value, the
fewer control points will compose your line.

Tip Shape

Lets you select a tip shape—from round and square ones to star shaped.
This option is disabled when using a textured brush.

Texture Tab

Texture SeeDrawing with Textured Brushes on Vector Drawing Layer on page 60

NOTE: If you are trying to create artwork on a bitmap drawing layer, and therefore with a bitmap brush, see
Drawing with Bitmap Brushes on Bitmap Drawing Layers on page 71

How to create a brush preset

1. Make sure your current brush has the settings you want in the preset you will create.

2. In the Tool Properties view, do one of the following:

‣ Click the arrow button to display the Brush Properties window and click the New Brush button
in the upper-right corner.

‣ Click theNew Brush button.

‣ From the Brush menu, select New Brush Preset.

3. In the New Preset window, type a name for your new brush preset.

The new brush is added to the end of the list of brush presets.

56



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

How to update a brush preset

1. Select the brush preset to update and click the arrow button to display the Brush Properties window.

2. Change the brush settings and click the Update Brush Preset button in the upper-right corner.

How to rename a brush

1. In the Tool Properties view, select a brush to rename.

2. From the Brush menu, select Rename Brush.

3. Type in a new name for the brush and click OK.

How to delete a brush preset

1. In the Tool Properties view, select the brush preset you want to delete.

2. Do one of the following:

‣ Click the Delete Brush button.

‣ From the Brush menu , select Delete Brush.

How to create a new dynamic brush

1. In the Tools toolbar, select a drawing tool.

2. In the Camera or Drawing view, draw the pattern you want to use as your dynamic brush stamp.

3. In the Tools toolbar, click the Select tool and select the parts of the drawing youwant to repeat.
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4. In the Tools toolbar, select the Brush tool or press Alt + B.

5. In the Tool Properties view, click the Add Dynamic Brush button to add your selection as a new
dynamic brush preset.

6. From the Brush menu, select Rename Brush.

7. Type in a name for the new dynamic brush and click OK.

8. In the Camera or Drawing view, start drawing with your dynamic brush to quickly repeat a pattern.

9. To adjust the scale of your pattern to make it bigger or smaller as you stamp it, adjust theMaximum
Size value in the Tool Properties view.

How to create a dynamic brush with multiple drawings

1. In the Timeline view, click the Add Drawing Layers button to create the layers you want to use as
patterns in your dynamic brush. Make sure to rename your layers.

2. In the Camera view, draw the individual drawings of your pattern on separate layers.
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3. In the Tools toolbar, select the Select tool.

4. In the Tool Properties view, disable theWorks on Single Drawing option to allow the Select tool to
grab artwork onmultiple layers.

5. In the Camera view, select all the drawings you want to add to your new dynamic brush.

6. In the Tools toolbar, select the Brush tool or press Alt + B.

7. Click the Add Dynamic Brush button to add your selection as a new Dynamic Brush preset.

8. From the Brushmenu, select Rename Brush.

The Rename Preset dialog box opens.
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9. Type in a name for the new dynamic brush and click OK.

10. In the Camera or Drawing view, start drawing with your dynamic brush to quickly repeat a pattern.
When you use this brush, you will cycle through the drawings.

Drawing with Textured Brushes on Vector Drawing Layer
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In Harmony, you can use the Brush tool to draw bitmap textured lines.

In the Brush Tool Properties view, you will find a series of default textured "brushes", but you can also create and
import your own custom collection. In Harmony, when using a textured brush on a vector layer, the texture of a
brush is referred to as the Paper Texture. In other words, we are attributing the texture not to the tool, but to
the texture of the surface that is revealed when a stroke passes over it. You will understand why when youwork
with bitmap brushes on bitmap layers, where it is possible to have both a textured brush tip and a paper texture.

To create your own textured brush, youmust prepare your texture file ahead of time, either in Harmony or in a
third-party software, such as Adobe Photoshop. Colour is not supported and transparency is not supported in
the traditional sense. Black appears as 100% opaque, white appears as 100% transparent, and all the shades of
grey in between appear as varying degrees of semitransparenty. A range of file formats are supported—.jpeg,
.png, .tif, .psd, .tga to name a few. Alpha channels are disregarded on import. It is recommended that you
maintain the texture resolution between 100 x 100 pixels and 400 x 400 pixels.

You can import your custom paper textures in the extended Brush Properties window. Browsing for a texture file
with a brush selected that is already using a paper texture will replace the file currently in use. It will not, however,
replace the texture in lines already drawn. The replaced texture swatch will no longer be the selected texture, but
it will remain in the texture library and not be deleted.

Harmony also allows you to import textures as an .xml file that was exported from another project. In this way,
you do not have to import individual image files one-by-one to have the same texture library and brush presets as
others who you are collaborating with. You can also export brush presets and textures, in order to share your
default or customized textures and presets with other project collaborators.

When you use the Eraser tool to erase a portion of a textured line, the vector frame is cut straight and you lose
the feather created while drawing with the Brush tool. In Harmony, a special option in the Eraser Tool Properties
lets you create a soft edge on your textured lines. You can also cut or keep the vector frame as is.

At some point, youmay want to modify the look of a textured drawing if you suddenly find that your lines look
too hard or too light. You can adjust those parameters by using the Adjust Line TextureOpacity command.

To draw with textured lines, use the Brush tool and the correct brush in the list. You can also draw with pencil line
texture—see Pencil Line Texture on page 49

How to draw with textured lines

1. In the Tools toolbar, select the Brush tool or press Alt + B.

2. In the Tool Properties view, select a brush and click the Arrow button to open the Brush Properties view.

3. Click the Texture tab, select the Texture option.
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4. Set the following parameters:

Parameter Description

Hardness

The hardness value corresponds to the softness of the line edge. The lower
the value, the softer the line edgewill be. The higher the value, the sharper
the line edgewill be.

MaximumOpacity
This value corresponds to the transparency of the stroke when the pressure
is heavy.

MinimumOpacity

This value corresponds to the transparency of the stroke when the pressure
is light and is a percentage of theMaximumOpacity value.
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5. Select a texture for your brush from the premade textures available.

6. Adjust the Texture Scale to change the size of the texture in the lines you draw. If you are using a plaid tex-
ture, the squares will be larger if you increase the value and smaller if you decrease it.

7. In the Camera or Drawing view, start drawing.
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How to add a paper texture

1. Do one of the following:

‣ From the Paper Texturemenu , select Add.

‣ Click the Add Paper Texture button.

2. In the browser window that appears, navigate to where you saved your texture file.

3. Click Open to import the file into the Paper Texture library.

By default, an imported texture is given the name of the image file.
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How to rename a paper texture

1. In the Paper Texture library, select a texture.

2. From the Paper Texturemenu, select Rename.

3. In the Rename Texture dialog box that appears, type in the new name for the texture.

4. Click OK.

How to delete a paper texture

1. In the Paper Texture library, select a texture.

2. Do one of the following:

‣ In the Paper Texturemenu, select Delete.

‣ Click the Delete button.

NOTE: You can delete any texture in the texture library as long as there is no brush preset using it.
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How to change the Paper Texture thumbnail display

1. From the Paper Texturemenu, select one of the following:

Parameter Description

Small Thumbnail Reduces the size of the thumbnails in order to view more at the same time.

Large Thumbnail Increases the size of the thumbnails in order to see the images more clearly.

List View Allows you to see the name, as well as the thumbnail.

How to import paper textures

1. In the Paper Texturemenu, select Import.

2. In the browser window that appears, navigate to and select the .xml file.

3. Click Open.

4. In the Import Textures dialog box, select the paper textures that you wish to import. You can import
any available brush tips at the same time too.

5. Click Import.

The imported paper textures will appear in the Paper Texture Library. You can reuse any of the
imported paper textures to create other brush style presets.
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How to export paper textures

1. In the Paper Texturemenu, select Export.

2. In the Export Tips and Textures window, scroll down the textures list to the paper textures and select or
deselect any textures to create the list that you wish to export. You can export brush tips at the same time
too.

3. Click on the Export button.

4. In the Export Textures window that appears, browse to a location where you would like to save the .xml
file and give it a name.

5. Click Save.

How to erase textured lines

1. In the Tools toolbar, select the Eraser tool, press Alt + E.

2. In the Tool Properties view, click the arrow button.

The Eraser Properties window opens.
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3. Adjust the following:

Parameter Description

Size and Smoothness Tab

Maximum Size Sets themaximumwidth of the line.

Minimum Size Sets theminimumwidth of the line in relation to themaximum size.

Smoothness
Lets youmodify the central line smoothness of the line. This parameter
smooths the initial movement of your line. Increasing the value will result in a
smoother line with fewer control points.

Contour Smoothness
Optimizes the contour line smoothness of the line. This parameter smooths
the contour of the line once it has been traced. The higher the value, the
fewer control points will compose your line.

Tip Shape

Lets you select a tip shape—from round and square ones to star shaped.
This option is disabled when using a textured brush.

Soft Eraser Tab

Hardness
Defines the softness of the stroke edge. The lower the value, the softer the
stroke edgewill be. The higher the value, the sharper the stroke edgewill
be.

Saturation
Lets you adjust the softness of edge feathering. Works in conjunction with
the Hardness, e.g. 100% Hardness will yield no results in saturation change.
0% Hardness will allow a fine tuning of the feathering of the soft stroke edge.

MaximumOpacity
The transparency of the brush when the pressure is heavy. A smaller value will
leave semi-transparent colour and texture. A larger value will ensure that
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everything is properly erased. This option in unavailable if the Keep Vectors
option is disabled.

MinimumOpacity

Sets theminimum transparency of the brush, in relation to theMaximumOpa-
city, when the pressure is very light. A smaller value will leave semi-trans-
parent colour and texture. A larger value will ensure that everything is
properly erased. This option in unavailable if the Keep Vectors option is dis-
abled.

Keep Vectors

Keeps the vector frames around your strokes intact, only the texture fill dis-
appears. Disabling this option will cut the stroke's vector frame into different
pieces when the Eraser tool passes over it. If you disable this option, themax-
imum andminimum opacity sliders are disabled as well.

4. In the Camera or Drawing view, erase your textures lines.

How to adjust the line texture opacity

1. If you are in Camera view, select theCurrent Drawing on Top option—seeCurrent Drawing on Top on
page 40.

2. In the Timeline or Xsheet view, select the drawing that contains the opacity you want to adjust.

3. In the Camera or Drawing view menu, select Drawing > Adjust Line Texture Opacity.

The Adjust Line TextureOpacity dialog box opens.
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4. Drag the sliders toward themiddle to increase the contrast and opacity of the textured lines.

5. If you want to apply the changes to all drawings exposed on the layer, select theApply to All Drawings
option and click OK.
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Drawing with Bitmap Brushes on Bitmap Drawing Layers

With Harmony, you have the choice to draw with vector or bitmap brushes. This is decided by what modes you
select for your layer. When adding a new drawing layer in Harmony, you can set your art layers (Line Art, Colour
Art) to vector or bitmap. This way, you can draw in bitmap and paint in vector, draw everything in bitmap, or any
other combination that suits your needs. If you are using theOverlay and Underlay layers, you can also set them
to either bitmap or vector.

Not all drawing tools are available whenworking on a bitmap layer. You can use the following tools:

• Brush

• Cutter

• Dropper

• Edit Gradient/Texture

• Ellipse

• Eraser

• Line

• Paint

• Paint Unpainted

• Pivot

• Rectangle

• Repaint

• Reposition All Drawings

• Select

• Text

• Unpaint

Any tool that is unavailable for use will be greyed out.

On a bitmap layer, a temporary vector layer is created when painting with a gradient. Until a modification is made
on your layer with a bitmap drawing tool, you can edit your last painted zone—by either editing the gradient
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swatch, which is dynamically linked to the painted zone or with the Edit Gradient texture tool. Themoment a
bitmap drawing tool or action is used, a vector-to-bitmap conversion occurs. If there are vector elements on
the layer (such as if you switched your art mode from vector to bitmap after having created vector artwork),
they too will be converted to bitmap.

Here is a list of tools and actions that will trigger a vector-to-bitmap conversion:

• Brush

• Ellipse

• Eraser

• Line

• Paint

• Paint Unpainted

• Rectangle

• Repaint

• Unpaint

• Performing a paste with the Select tool selected

• Performing a paste with the Cutter tool selected

This means that certain tools, such as the Text tool or the Cutter tool, will not trigger a conversion.

If you selected the incorrect art modes for your layer, you can open the Layer Properties view and change
them. If you switch the art mode for a layer that already has strokes on it, the artwork will NOT be converted
for bitmap artwork, but will be for vector artwork, though not immediately. A drawing with bitmap strokes on
a newly converted vector layer will remain bitmap. This means that the bitmap artwork will not be editable by
some tools, such as the Eraser tool, but will be editable by other tools, such as the Cutter tool. However, a
drawing with vector lines on a newly converted bitmap layer will remain vector temporarily, until a bitmap
drawing tool or action is used. Then the vector-to-bitmap conversion will occur.

To always reuse the same art mode settings, you can adjust them in the Preferences dialog box.

If you want to be able to edit the artwork in the new mode, you need to convert the drawings.

Vector-to-bitmap conversion includes flattening individual drawings into a single image. Flattening means that
it will not be possible to select non-overlapping or overlapping elements as individual objects with the Select
tool. Instead, the selection of one drawing will initiate the selection of all elements, with a single vector frame
surrounding them.

Resampling is also triggered on bitmap layers with the use of a bitmap drawing tool. For example, if you draw
the outline of a circle, scale it down and then zoom into it, you will see tiny square pixels along the edge of the
line. If you then draw a line right next to it, you will notice two things: first that the square pixels of the new line
are gigantic by comparison and that the pixels in the line of your circle suddenly become the same size. This is
because the circle was resampled. It was not resampled when you scaled it down. It was resampled when you
used a bitmap drawing tool. It is resampled so that all the drawn objects are scaled to the same bitmap grid, in
other words that their basic unit, the pixel, is the same size. The grid is defined by the bitmap layer's
resolution.
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Before you start drawing in bitmap, it is important to understand that your artwork will now be resolution
dependent. If you zoom in your scene, you artwork will be enlarged. It is important to plan ahead and decide how
high of a resolution you need your artwork to be. If you plan to zoom in your scene, the smallest section of the
image that the camera will framemust be 100% the size of your scene resolution. For example, if your scene
resolution is set to 1920 x 1080 and you zoom- in 300% with your camera, then the resolution of the bitmap layer
also has to be set to 300%, otherwise its elements will look pixelated in the final render. It is important to change
the bitmap layer resolution before you start drawing.
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The bitmap resolution can be set at the scene level or drawing level. The setting at the scene level affects newly
created bitmap art layers.

Note that even if your drawing resolution is set to be very large, it doesn't mean that your file will be very
heavy. It depends on the amount of artwork you draw in it.

There is a function to change the resolution of bitmap art for individual drawings. You can reduce the
resolution of your bitmap file as well as increase it. Be careful because enlarging the bitmap resolution on an
existing drawing will result in a loss of quality.Harmony will perform a pixel smoothing pass (resampling) and
create additional pixels to avoid losing too much quality, but only to a certain extent. For example, what if you
used the default scene’s resolution for some bitmap art, but then discover you are zooming-in quite close? If
you do not want to see the pixels appear too much when you are zoomed in, you can set the bitmap resolution
to 200% and the bitmap art will have a higher resolution with smaller pixels, but will NOT retain 100% of its
quality. You can use this function onmultiple drawings using the Apply to All Drawings option. Changing this
option will affect existing and selected bitmap art layers.

If you draw an outline on a bitmap layer, you can still vectorize it. Using a vector drawing layer, simply select
your bitmap drawing and the vector cell of where you want your vectorized line to be, and use the Vectorize
Line Art in Selected Drawing function.

You should avoid scaling up your bitmap strokes using the Select tool. If you do, keep inmind that when you
continue drawing, your imagewill be resampled and your new strokes will be scaled to the scene resolution.
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NOTE: Your drawing should be scaled up using the Transform tool when animating, instead of the Select tool, in

order to avoid creating very large bitmap layers. Harmony calculates the scaling of your drawings when you use the
Transform tool; your image is mathematically transformed. When you use the Select tool to scale, you are physically
scaling the drawing.

How to add a bitmap layer

1. In the Timeline view, click the Add Drawing Layer button,

The Add Drawing Layer window opens.

If you are using theOverlay and Underlay layers, those art layers are also displayed.

2. For each art layer, select theVector or Bitmap option.

3. Click OK.

How to change the art mode

1. Open the Layer Properties view.

2. In the Timeline view, select the layer you want to edit.

3. In the Layer Properties view, select theDrawing tab.
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4. In the Art Layers section, select the art mode for each art layer.

How to adjust the art mode settings in the Preferences dialog box

1. From the top menu, select Edit > Preferences ( Windows/Linux ) or Stage > Preferences ( MacOS X ).

2. Select theNode View tab.

3. In the Layer Drawing Options section, set the art layers to the desired art mode. Once this option is
enabled, all new layers will follow these settings. It will not affect any existing layers.

4. Click OK.

How to convert drawings to match the art mode

1. In the Timeline view, select the layer that contains the drawings you want to convert.

2. From the Timeline view menu, select Layers > Convert Drawings toMatch Art Layer Type.

You can also right-click on the selected layer and select Convert Drawings toMatch Art Layer Type.

All drawings in the layer are converted to the selected art mode. Note that bitmap strokes are not
vectorized when converted to a vector art layer. They are simply inserted in a square vector frame
containing a bitmap texture.

How to change the bitmap layer resolution at the scene level

1. From the top menu, select Scene > Scene Settings.

The Scene Settings dialog box opens.

2. Select the Bitmap Resolution tab.

3. Change the bitmap resolution settings and click OK.

The bitmap resolution settings at the scene level affects newly created bitmap art layers.
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Parameter Description

Scene Resolution This is the scene resolution preset name and size in pixels.

Width

This is the width of the resolution for the bitmap that will be created. This is not
the actual size of the bitmap. TVG drawings (Toon Boomdrawing native
format) have an infinite size. Bitmap TVGs are composed of small tiles. There-
fore it does not mean that because you have artwork at the four corners of your
camera frame or even quite far outside of your drawing that your bitmap image
will be very large and heavy. By default, it is set to the samewidth as the scene
resolution.

Height
This is the height of the resolution for the bitmap that will be created. By
default, it is set to the same height as the scene resolution.

Resolution Factor

This is the size of the bitmap resolution in relation to the scene resolution. If you
increase the percentage, the width and height fields will increase accordingly. If
you plan to animate the camera and zoom into your background, you will need
to set a higher resolution so that the smaller area in which you will zoomwill be
100% of the scene resolution.

How to change the bitmap resolution at the drawing level

1. In the Timeline view, select the drawing whose resolution you want to change.

NOTE: Note that the drawing can be enlarged slightly and retain its original look, but you may lose quality if you
enlarge it too much. Pixels are created and a smoothing pass is applied. You should set your resolution before
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drawing. If you need to change the resolution of a drawing to be larger than the one set in the Scene Settings
dialog box, create an empty drawing first and then follow this procedure.

2. From the top menu, select Drawing > Change BitmapDrawing Resolution.

The Change Bitmap Drawing Resolution window opens.

Parameter Description

Scene Resolution This is the scene resolution preset name and size in pixels.

Width

This is the width of the resolution for the bitmap that will be created. This is
not the actual size of the bitmap. TVG drawings (Toon Boomdrawing native
format) have an infinite size. Bitmap TVGs are composed of small tiles. There-
fore it does not mean that because you have artwork at the four corners of
your camera frame or even quite far outside of your drawing that your bit-
map imagewill be very large and heavy. By default, it is set to the samewidth
as the scene resolution.

Height
This is the height of the resolution for the bitmap that will be created. By
default, it is set to the same height as the scene resolution.

Resolution Factor

This is the size of the bitmap resolution in relation to the scene resolution. If
you increase the percentage, the width and height fields will increase accord-
ingly. If you plan to animate the camera and zoom into your background, you
will need to set a higher resolution so that the smaller area in which you will
zoomwill be 100% of the scene resolution.

Resample Bitmap

When this option is selected, the existing bitmap image is modified to match
the new resolution. If the width and height are increased, more pixels will be
created to enlarge the image. Visually, the existing artwork will look the
same, maybe a little bit smoothed out, but the size will look the same. When
this option is deselected, the artwork is not modified. Only the reference
grid is resized. If the scene resolution is 1920 x 1080 and you reduce the
bitmap resolution to 960 x 540, the imagewill be scaled up to twice the size
of the scene.

Apply to All Drawings
Themodified settings are applied to all drawings in the drawing layer for a
given art layer. If the Apply to Line Art and Colour Art option is enabled, it
will then be applied to all bitmap art layers.
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3. Change the bitmap resolution.

4. Click OK.

How to draw with bitmap brushes

1. In the Timeline view, add a bitmap drawing layer—seeHow to add a bitmap layer on page 75.

2. In the Tools toolbar, select the Brush tool or press Alt + B.

3. In the Colour view, select a colour.

‣ To switch the bitmap colour picker fromHSV to RGB, in the Colour view menu, select Colour > Bitmap
Colour Sliders > HSV Sliders or RGB Sliders. You can also right-click on the colour sliders and select
RGB Sliders or HSV Sliders.

When using bitmap colours, there is no longer a link between the painted zones and selected colour. You can edit
the colour as much as you want, but your drawing will not be affected. You can still select colours from your
vector colour palette to use the same tint, but you will not create links between your drawing and the swatches.

4. In the Camera or Drawing view, start drawing.
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How to vectorize a bitmap drawing

1. In the Timeline view, add a vector drawing layer BELOW the bitmap drawing layer containing the draw-
ing to vectorize. In your bitmap drawing, the artwork to vectorizemust be placed on the Line Art layer
(default drawing layer).

NOTE:
If you place the vector drawing on top of the bitmap layer, you will not be able to perform the operation. A warning
dialog box will display.

2. On the right side of the Timeline view, select the bitmap drawing and corresponding cell in the vector
drawing layer.

3. Right-click and select Drawings > Vectorize Line Art in SelectedDrawing.

The Convert to Vector Drawing dialog box opens.

4. In the Vectorization section, select a vectorization preset. You can customize your own preset using the
Add or Edit buttons.

5. Click OK.

Your vectorized drawing is created in the vector drawing layer. Your bitmap drawing remains intact.
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Creating Bitmap Brushes

With bitmap brushes in Harmony, you can create an infinite range of fuzzy, textured and watercolour lines. You
can combine two different brush tips, with separate sets of parameters, with the Dual Tip feature. You can also
select a paper texture that will mimic the texture of the surface that is being painted on. Uses these features
separately or in combination to create distinct, natural-looking strokes.

How to create a Bitmap Brush

1. In the Timeline view, create a new Bitmap drawing layer.

2. In the Tools toolbar, select the Brush tool or press Alt + B.

3. In the Tool Properties view, select a brush and click the Arrow button to open the Bitmap Brush Properties
view.

4. In the Tip tab, select a brush tip.
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5. Click on the different tabs to access the options available for adjustment. You can use the brush stroke
preview at the top to view all your adjustments in real time.

‣ Tip tab: Make adjustments to size, brush tip angle, hardness and spacing—see Bitmap Brush Tool
Options on page 129.

‣ Transparency tab: Make adjustments to flow and opacity—see Transparency Tab on page 140.

‣ Dual Tip tab: Select this option to enable the Dual Tip feature. Select a dual brush tip and make
adjustments to its size, brush tip angle, hardness and spacing—seeDual Tip Tab on page 143.

‣ Paper Texture tab: Select this option to enable the Paper Texture feature. Select a paper texture
and make adjustments to its scale, alignment and additivity—see Paper Texture tab on page 147.

6. When you are satisfied with the look of your bitmap brush, click the Add New Brush Preset button
at the top-right corner of the Bitmap Brush Properties window.
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7. In the New Preset dialog box that appears, enter the name for your brush preset.

8. Click OK.

If you continue to make adjustments to your new brush preset and want to save these changes, click the
Update Preset button. Otherwise, your modifications will only be saved until another brush preset or
drawing tool is selected.

Viewing the Final Lines as You Draw

Everything you draw in Harmony is vector-based, unless you purposely elected to draw as bitmap. Although,
when you draw in the Drawing or Camera view, notice that your lines may appear jagged. This is caused by the
fast real-time display called OpenGL. If you prefer to see smooth lines as you draw, you can enable the
antialiasing preference.

Full Scene Antialiasing

Full scene antialiasing is generated by your computer’s graphics card. This antialiasing will not only antialias your
drawings, but all your different views in the interface. Full scene antialiasing is an option you can turn on and off;
by default, it is disabled.

There is no need to modify your graphic card settings.
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NOTE: Full Scene Antialiasing parameters are only valid while you work in your scene. The scene will be rendered
to 100% of its resolution regardless of your preference settings or graphic card panel.

How to customize the full scene antialiasing parameters

NOTE: You must restart Harmony after you change the parameters.

1. Do one of the following:

‣ From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (MacOS
X).

‣ Press Ctrl + U (Windows/Linux) or⌘ + U (MacOS X).

The Preferences dialog box opens.

2. In theOpenGL tab, go to the Full Scene Antialiasing section.

‣ Enable: Select this option to enable/disable the Full Scene Antialiasing.

3. Number or samples: Enter the number of samples you want to be used for the antialiasing process.
The number of samples is basically equivalent to the amount of times a pixel will be enlarged to cal-
culate the antialiasing. This technique is called supersampling. The higher the number of samples, the
better the antialiasing quality will be, but the longer it will take to calculate.

4. Restart Harmony.

Selecting the Current Colour of a Tool

While drawing and painting, you can let Harmony retain the last colour you selected for each one of the
following tools:

• Brush

• Paint

• Pencil, Ellipse, Line, Rectangle, Polyline
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The Colour view has three swatches where you can set a colour for the Brush , Paint,  and Pencil tools.

How to unlink the storage swatches

1. In the Colour view, if the storage swatches are linked, click the Link button to unlink them.

2. Click on the Brush storage swatch.

3. In the Colour list, select the desired colour.

4. Click the Pencil storage swatch.

5. In the Colour list, select a colour.

6. Click the Paint storage swatch.

7. In the Colour list, select a colour.
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NOTE: If you prefer to have Harmony use the same colour swatches regardless of the selected tool, you can link
the three swatches together.

How to link the storage swatches

1. In the Tools toolbar, select one of the following tools:

‣ Brush

‣ Paint

‣ Pencil

‣ Polyline

‣ Line

‣ Ellipse

‣ Rectangle

2. In the Colour view, if the storage swatches are unlinked, click the Link button to link them.

Each time you select a new colour for your current tool, all the storage swatches are updated.

How to link the storage swatches

1. In the Tools toolbar, select one of the following tools:

‣ Brush

‣ Paint

‣ Pencil

‣ Polyline

‣ Line

‣ Ellipse

‣ Rectangle

2. In the Colour view, if the storage swatches are unlinked, click the Link button to link them.
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Each time you select a new colour for your current tool, all the storage swatches are updated.

Using Independent Colours when Working with Bitmap Layers

Whenworking in the Colour view, by default the current colour is active for both vector and bitmap layers. You
can however, use different reference colours for each layer.

When using bitmap colours, there is no longer a link between the painted zones and selected colour. You can edit
the colour as much as you want, but your drawing will not be affected. You can still select colours from your
vector colour palette to use the same tint, but you will not create links between your drawing and the swatches.

How to use independent colours

‣ From the Colour view menu, select Colours > Independent Bitmap Colour.

Whichever colour you choose as the reference color is retained for that layer type.

Selecting Drawing Objects

The Select tool is used to select strokes in both the Drawing and Camera views, and apply basic transformations,
such as repositioning, rotating, scaling or skewing using the different handles of the bounding box.

Sometimes, when youwant to select multiple objects while leaving one unselected, it can be handy to select only
the stroke or line that you do not want included in your selection. Then, you can invert the selection so that
everything else becomes selected. This can be quite a time saver.

By default, when you draw a selection box, the Select tool will select only the drawing strokes of the current
drawing. If you prefer the Select tool to select all the strokes on all layers, you can disable theWorks on Single
Drawing option in the Tool Properties view or the Select Tool Works on Single Drawing option in the Preferences
dialog box.

Some of the transformations, such as rotation, scale, skew, and flip are done relative to the position of the pivot
point. You can temporarily reposition this pivot point for a transformation using the Select tool.
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How to select with the Select tool

1. In the Timeline view, select the cell on which you want to select drawing objects.

2. In the Tools toolbar, select the Select tool or press Alt + S.

3. In the Camera or Drawing view, select the drawing objects.

‣ You can select all the drawing objects in a drawing by using Edit > Select All or by pressing Ctrl + A
(Windows/Linux) or⌘ + A (MacOS X).

4. To deform or reposition a selection:

‣ To reposition, click the selected drawing object and drag the selection to a new area.

‣ To rotate, grab the selection box handle and rotate it.

‣ To scale, pull or push on the top, side, bottom or corner control point. Hold down Shift to lock the
selection’s ratio.
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‣ To skew, drag sideways or up and down the sides or top and bottom segments, between the control
points.

How to invert a selection

1. From the top menu, select Edit > Invert Selection or press Ctrl + Shift + I.

‣ You can also find the Invert Selection option in the Camera or Drawing View menu by selecting Edit >
Invert Selection.

How to enable and disable the Select ToolWorks on Single Drawing preference

1. In the Tools toolbar, select the Select tool or press Alt + S.

2. Do one of the followings:

‣ From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (MacOS X).
In the Camera tab, go to the Tools section and select or deselect the Select ToolWorks on Single
Drawing option and click OK.

‣ In the Tool Properties view, disable theWorks on Single Drawing option.

3. In the Camera view, make your selection. It is possible that you will have to restart Harmony depending on
your system.

89



Chapter 2: Design and Drawing Tools

How to temporarily reposition the pivot point

1. In the Camera or Drawing view, select the drawing object you want to transform.

The pivot point appears in themiddle of your selection.

2. Click the pivot point and drag it to a new position.

This becomes the new position of the pivot point for the current transformation and will remain there
until youmake a new selection.
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Erasing Parts of a Drawing

The Eraser tool is pressure sensitive, like the Brush tool, giving youmore precision when erasing parts of a
drawing. You can also use the Select tool to select drawing objects and delete them instead of erasing.

It is a good idea to create and save erasers with precise sizes and parameters in order to save timewhen drawing
and designing. There are two icons located at the top, right corner of the Eraser Properties window. One is to
create a new preset, while the other is to update the currently selected preset. Use them after you have set all the
parameters for the new eraser preset.
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‣ New Brush Preset: Click on this button to create a new eraser brush style. The new eraser style will
appear at the bottom of the list in the Presets section of the Tool Properties window. All the values
and selected options in the Eraser Properties window will be attributed to this new style.

‣ Update Preset: Click on this button to update the selected eraser preset with any changes made in
the Eraser Properties window. If youmake changes and do not click on the Update Preset button,
then all the changes madewill only be applied to the selected eraser preset temporarily. The
moment you switch to another eraser preset or to another drawing tool, thesemodifications to the
eraser preset will disappear.

How to erase with the Eraser tool

1. In the Timeline or Xsheet view, select the cell that contains objects you want to erase.

2. In the Tools toolbar, select the Eraser tool or press Alt + E.

3. In the Camera or Drawing view, start erasing.

How tomodify the eraser settings

1. In the Tools toolbar, select the Eraser tool .

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you cus-
tomize the different parameters in the Eraser Properties view. Click the arrow button.

The Eraser Properties window opens.
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The Size and Smoothness tab is where you set theminimum andmaximum sizes of your drawing tool which will
produce the thick and thin effect on your stroke.

The Soft Eraser tab needs to be enable for its parameters to become active. This feature only works on soft or
textured brush strokes. Both tabs works with the pressure sensitivity of a pen tablet.

Parameter Description

Size and Smoothness Tab

Maximum Size Sets themaximumwidth of the line.

Minimum Size Sets theminimumwidth of the line in relation to themaximum size.

Smoothness
Lets youmodify the central line smoothness of the line. This parameter smooths
the initial movement of your line. Increasing the value will result in a smoother
line with fewer control points.

Contour Smoothness
Optimizes the contour line smoothness of the line. This parameter smooths the
contour of the line once it has been traced. The higher the value, the fewer con-
trol points will compose your line.

Tip Shape

Lets you select a tip shape—from round and square ones to star shaped. This
option is disabled when using a textured brush.

Soft Eraser Tab

Hardness
Defines the softness of the stroke edge. The lower the value, the softer the
stroke edgewill be. The higher the value, the sharper the stroke edgewill be.

Saturation
Lets you adjust the softness of edge feathering. Works in conjunction with the
Hardness, e.g. 100% Hardness will yield no results in saturation change. 0%
Hardness will allow a fine tuning of the feathering of the soft stroke edge.

MaximumOpacity

The transparency of the brush when the pressure is heavy. A smaller value will
leave semi-transparent colour and texture. A larger value will ensure that
everything is properly erased. This option in unavailable if the Keep Vectors
option is disabled.

MinimumOpacity

Sets theminimum transparency of the brush, in relation to theMaximumOpa-
city, when the pressure is very light. A smaller value will leave semi-transparent
colour and texture. A larger value will ensure that everything is properly erased.
This option in unavailable if the Keep Vectors option is disabled.

Keep Vectors

Keeps the vector frames around your strokes intact, only the texture fill dis-
appears. Disabling this option will cut the stroke's vector frame into different
pieces when the Eraser tool passes over it. If you disable this option, themax-
imum andminimum opacity sliders are disabled as well.
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Reshaping a Drawing Using the Contour Editor Tool

The Contour Editor tool is a powerful tool that allows you to add, remove or modify points on a vector line and
control themwith Bezier handles. It is used to correct line shapes and modify a single part of a colour zone. If a
line is too thin or has a gap in it, you canmodify and correct it with the Contour Editor tool. You can also use
this tool to create elaborate shapes.

The Contour Editor displays vector points around a shape and the central vector points in a pencil line. Pulling
or pushing on these points adjusts the brush’s line thickness. Points can be selected and deleted. Each point
has two Bezier handles for correcting the curves between two points. Shapes can bemodified by pulling and
pushing directly on the segment between the points. You can use it to perfect a central shape pencil line, a
contour shape brush line, or even create an elaborate shape from a basic ellipse or square.

How to reshape with the Contour Editor tool

1. In the Timeline or Xsheet view, select the cell in which you want to draw.

1. In the Tools toolbar, select a shape tool: .

2. In the Tool Properties view, click the Ellipse button, click the Auto Fill button and set the pencil
size to 0.

3. In the Drawing or Camera view, draw a circle.

4. In the Tools toolbar, select the Contour Editor tool.
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5. In the Drawing or Camera view, click the line to reshape it.

6. Select one or several points by clicking on them or circling around.

7. Press Delete to delete a selected point.

Press Ctrl (Windows/Linux) or⌘ (MacOS X)and click on the contour to add a new point to adjust the
contour.

8. To modify the shape, you can:

‣ Pull on the Bezier handle. Both point’s handles will move as one.

‣ Hold downAlt and pull on one of the Bezier handles. The point’s handle will move independently from
the other one.

‣ Move the selected points to a new area.

‣ Pull directly on the line between two points. No selection is necessary. Holding down Shift will limit the
contour modification to the curve between the two first points.
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‣ If an anchor point has no visible Bezier handles, hold down the Alt key to display them.

‣ To add control points, press Ctrl (Windows/Linux) or⌘ (MacOS X) and click the line.

‣ To remove control points, select the control point and press Delete.

Reshaping Pencil Lines with the Pencil Editor Tool

The Pencil Editor tool is used to modify the thick and thin contour o f a pencil line. A pencil line is a central
vector shape. The shape control points are located all along the central spine allowing you to adjust the stroke
curve and position. When using the Contour Editor tool, you can repos ition the spine of the stroke. When
using the Pencil Editor tool, you can ad just the thick and thin areas of lines.
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How to use the Pencil Editor tool

1. In the Tools toolbar, select the Pencil Editor tool or press Alt + W.

2. In the Camera or Drawing view, select a pencil line and click the line to reshape it.

3. Select one or several points by clicking them or circling around.
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4. Press Delete to delete a selected point.

5. Press Ctrl (Windows/Linux) or⌘ (MacOS X) and click the central spine to add a set of points to adjust
the contour.

6. To modify the shape, you can:

‣ Move the selected points to a new area. If you select matching points on each side of the line,
holding the Shift key will move them both. This way you can thicken or thin a line from both sides at
the same time.

‣ Pull on the Bezier handle to move both points’ handles s one.

‣ Hold downAlt and pull on one of the Bezier handles. It moves the handle independently from the
other one.
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‣ Pull directly on the line between two points. No selection is necessary. Holding down the Shift key will
limit the contour modification to the curve between the two first points.

‣ If an anchor point has no visible Bezier handle, hold downAlt to display them.

Drawing with Shapes

In Harmony, you can use the shape tools to draw circles, lines and squares. You can also easily reshape a square
or circle into a muchmore complex drawing such as these butterfly wings—see Reshaping a Drawing Using the
Contour Editor Tool on page 94 and Reshaping Pencil Lines with the Pencil Editor Tool on page 96.

How to draw with a Shape tool

1. In the Timeline or Xsheet view, select the cell on which you want to draw.

2. In the Tools toolbar, select a shape tool: .
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3. To automatically fill the shape, in the Tool Properties view, select the Auto Fill option.

4. In the Camera view, click and drag to draw the shape.

‣ Hold down Shift to lock the rectangle or the ellipse ratio to 1:1.

‣ Hold downAlt to draw the rectangle or ellipse from its centre.

‣ Hold down Shift to snap the line every 15 degrees.

‣ Hold downAlt to snap the start or end of the line to a nearby stroke.

5. Use the Contour Editor tool to deform the shape and create your drawing.

Drawing with the Polyline Tool
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The Polyline tool is used to draw shapes with a central vector type of line. To form a shape, you click to add a
point and then, without releasing themouse, pull the handle in the desired direction before adding the next point
and repeat the operation. To edit the shape, you can use the Contour Editor tool.

How to draw with the Polyline tool

1. In the Timeline view, select the cell on which you want to draw.

2. In the Tools toolbar, select the Polyline tool or press Alt + _.

3. In the Camera or Drawing view, click and drag to create a point and a Bezier handle to shape your line.

‣ Press Alt to pull only one handle, instead of two.

‣ Press Shift to snap the handles to 45, 90, or 180 degrees.

4. Click a new area and drag to create a second point and Bezier handle.

5. Repeat the previous step until your shape is completed.

6. Press Ctrl (Windows/Linux) or⌘ (MacOS X) and click to release the Polyline tool from the current path or
shape that it is creating. Continue to use the tool to makemultiple, independent paths or shapes.

7. If necessary, reshape the lines using the Contour Editor tool—see Reshaping a Drawing Using the Con-
tour Editor Tool on page 94.

Drawing with Invisible Lines

There are two different ways to draw invisible lines.
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Using the Pencil tool, you can draw as strokes only, meaning that the line will be invisible. This can be useful for
drawing tones and highlights directly on the character.

The Stroke tool draws invisible lines only. You cannot add thickness to the line. Unlike the Close Gap tool that
creates a short, straight line between two points, the stroke line will stay exactly where you draw it. This tool
can be useful for closing a zone in a particular way or creating some hard shadows or highlight areas.

Sometimes, it may be difficult to see your strokes, especially if your colours are similar to the blue stroke
colour. In Harmony, you can display the strokes in washed-out colours so that the invisible lines stand out.

How to draw invisible lines with the Pencil tool

1. In the Timeline or Xsheet view, select the cell on which you want to draw.

2. In the Tools toolbar, select the Pencil tool or press Alt + /.

3. From the top menu, select View > Drawing > Show Strokes or press K.

4. In the Tool Properties view, set the Pen Style size to 0. You can also adjust the smoothness.

5. In the Camera or Drawing view, start drawing.

If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a
Message dialog box opens.

Select theDon’t Show This Message Again option if you do not want the dialog box to notify you
about the Show Strokes option.

6. Click OK.

7. You canmodify the stroke shapewith the Contour Editor tool.

How to draw invisible lines with the Stroke tool

1. In the Timeline or Xsheet view, select the cell on which you want to draw.
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2. In the Tools toolbar from the Paint drop-downmenu, select the Stroke tool or press Alt + V.

3. From the top menu, select View > Show Drawing > Show Strokes or press K.

4. In the Tool Properties view, you can adjust the smoothness.

5. In the Camera or Drawing view, start drawing.

If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a
Message dialog box opens.

Select theDon’t Show This Message Again option if you do not want the dialog box to notify you about
the Show Strokes option.

6. Click OK.

7. You canmodify the stroke shapewith the Contour Editor tool.

How to show the strokes with washed-out colours

‣ From the top menu, select View > Show > Show Stroke With ColourWash.

Deforming a Drawing with the Perspective Tool

The Perspective tool lets you deform a drawing selection and alter its perspective.
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How to deform a drawingwith the Perspective tool

1. In the Tools toolbar, select the Perspective tool from the Contour Editor drop-downmenu or press
Alt + 0.

2. In the Camera or Drawing view, select a drawing to deform.

3. Click and drag the different anchor points to deform the shape.

Warping a Drawing with the Envelope Tool

The Envelope tool lets you deform and warp part of a drawing using a grid envelope and Bezier handles.

How to warp a drawingwith the Envelope tool

1. In the Tools toolbar, select the Envelope tool from the Contour Editor drop-downmenu.

2. In the Timeline view, select a drawing to deform.

3. In the Camera or Drawing view, select the region you want to deform
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4. Click and drag the different anchor points and handles to deform the image.

5. To displaymore controls, in the Tool Properties view, click the Show Advanced Controls button.
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6. Increase the height and width of the grid to get more control points to deform your image.

Cutting Drawing Parts

The Cutter tool lets you cut a drawing area to move, copy, cut or delete it.

How to cut with the Cutter tool

1. In the Tools toolbar, select the Cutter tool or press Alt + T.
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2. In the Camera or Drawing view, make a selection around an area to cut away.

‣ To delete the selected zone, press Delete.

‣ To move the selection, click the selection and drag it to a new area.

‣ Use the bounding box controls to scale, skew, or rotate the cut piece.

Smoothing Lines
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When drawing in a digital application, it is not like drawing on a sheet of paper. Sometimes the lines you draw
may look as if they were drawnwith an unsteady hand. When this occurs, youmay need to correct the look of
your lines.

Harmony has a very powerful tool you can use to optimize contours and reduce the number of points on the
lines, the Smooth Editor tool.

How to optimize lines with the Smooth Editor tool

1. In the Tools toolbar, select the Smooth Editor tool or select Drawing > Tools > Smooth Editor.

2. In the Camera or Drawing view, place your pointer over the lines to smooth. Youmay need to pass over
the same line several times to removemore points and make the line smoother. Note that by default,
the Smooth Editor tool colour is yellow, it was changed to orange for screen grab clarity—see Smooth
Editor Tool Options on page 186 to learn about the various settings available.

Working With Text

With the Text tool, you can type text in your project using various fonts and texts attributes. Text objects are
part of a drawing, so you canmanipulate them in the sameway. OTF fonts are also supported.

How to add text to drawings

1. Do one of the following:

‣ In the Tools toolbar, select the Text tool.

‣ From the top menu, select Drawing > Tools > Text.

‣ Press Alt + 9.

2. In the Timeline view, select the cell containing the drawing onwhich you want to add text.

3. In the Drawing or Camera view, click on the location you want the text to begin.
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4. You can use the Tool Properties view to select the font, font size and format of the text you will type—see
Text Tool Options on page 188.

5. Type in the desired text.

6. Click outside the text box to exit the typing mode.

If you want to create another text object, click outside the currently active text box. You can always return
to edit the text by selecting the Text tool and clicking in the text.

Working with Tool Presets

Tool presets let you save a variety of settings and are very handy and efficient for accessing the tools you use
most often. That way, the tool is already set with the desired properties, such as colour, line thickness, whether
to enable Draw Behind or Auto Flattenmode, and so on. You can create presets for these tools and manymore:
Brush, Pencil, Eraser, Rectangle, Ellipse, and Line. First, select a tool, adjust the properties, and then create a
tool preset for it. Once you have created a tool preset, you can always make adjustments to fine-tune it, as well as
create a keyboard shortcut for it.

What's the difference between a tool preset and a brush preset?When you save a tool preset, you have the
option of saving the colour, which you cannot do with brush presets.

The Tool Presets Toolbar

The Tool Presets toolbar lets you create new tool presets and manage them.

How to display the Tool Presets toolbar

1. Do one of the following:

‣ From the top menu, selectWindows > Toolbars > Tool Presets.

‣ Right-click an empty area below the top menu and select Tool Presets.
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How to create a tool preset

1. In the Tools toolbar, select a tool, for example the Brush tool.

1. Use the Tool Properties view to customize the tool.

2. To set a specific colour for your preset, in the Colour view, select the colour swatch to link to the tool.
Note that when using this preset in another scene not using that colour palette, upon selecting this new
preset, a colour recovery dialog box will appear asking to add this colour to your scene.

3. In the Tool Presets toolbar, click the New Tool Preset button.

4. In the New Preset dialog box, in the Name field, type a name for your new preset.

2. From the icon list, select an icon to quickly identify your preset or upload your own by clicking the File
button.

5. (Optional) From the Shortcut menu, set a keyboard shortcut to quickly access your preset. By default,
the shortcuts are unassigned. To assign a keyboard shortcut, go to the top menu and select Edit >
Preferences > Shortcuts > Tool Presets (Windows/Linux) or Stage > Preferences >Shortcuts > Tool
Presets (MacOS X).
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6. When you select any of the following options, they will take effect when you use the tool preset. If an
option is deselected, then using a tool preset will not override your current settings.

‣ Colour: Saves the current colour into the tool preset.

7. Click OK.

How to select a tool preset

‣ In the Tool Presets toolbar, click the tool preset icon you assigned when creating the preset. Note
that when using this preset in a new scene not using the assigned colour swatch, a colour recovery
dialog box appears prompting you to add the colour to the scene.

How to delete a tool preset

1. In the Tool Presets toolbar, click theManage Tool Presets button.

2. From the list of tool presets on the left, select a preset to delete and click the Trash icon.

How to import a tool preset

1. In the Tool Presets toolbar, click theManage Tool Presets button.

TheManage Tool Presets dialog box opens.

3. Click Import.

4. In the Select Folder window that opens, locate and select the preset(s) to import and click Select Folder.

How to export a tool preset

1. In the Tool Presets toolbar, click theManage Tool Presets button.
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TheManage Tool Presets dialog box opens.

5. Click Export.

2. In the Export Brush Presets window that opens, click Export.

6. Select a folder and click Select Folder.

How to update a tool preset

1. To update the colour of your preset, youmust first select it in the Colour view.

2. In the Tool Presets toolbar, click theManage Tool Presets button.

3. In theManage Tool Presets dialog box that opens, select the tool preset from the left side of the dialog
box.

4. Make any changes you would like to the preset.

5. Click Update.

More Drawing Tools

Harmony offers a wide variety of useful tools to optimize your drawings and work more efficiently; tools such
as Group, Arrange, and the animation disk to rotate your workspace.

• Arrange on page 112

• Convert Brush Strokes to Pencil Lines on page 113

• Pencil Lines to Brush Strokes on page 114

• Strokes to Pencil Lines on page 114

• Optimize on page 114

• Remove Extra Strokes on page 115

• Reduce Drawing Texture Resolution on page 115

• Crop Brush Textures on page 116

• Create Contour Stroke on page 117

• Remove Contour Stroke on page 117

• Grid on page 118

• Group/Ungroup on page 118

• Hand on page 118

• Rotate View on page 119

Arrange

The different Arrange options let you reorder drawing objects inside a single layer in the Drawing or Camera
view.
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Name Button Description Access Method

Bring to Front
Moves the selected art to the front
(on top).

From the top menu, select Drawing >
Arrange > Bring to Front.

Press Ctrl + Shift + PgUp
(Windows/Linux) or⌘ + Shift + PgUp
(MacOS X).

Bring Forward
Moves the selected art one level for-
ward (closer to the front).

From the top menu, select Drawing >
Arrange > Bring Forward.

Press Ctrl + PgUp (Windows/Linux) or
⌘ + PgUp (MacOS X).

Send Backward
Moves the selected art one level
lower (behind).

From the top menu, select Drawing >
Arrange > Send Backward.

Press Ctrl + PgDown (Windows/Linux)
or⌘ + PgDown (MacOS X).

Send to Back
Moves the selected art behind
everything (bottom / back).

From the top menu, select Drawing >
Arrange > Send to Back.

Press Ctrl + Shift + PgDown
(Windows/Linux) or⌘ + Shift +
PgDown (MacOS X).

Convert Brush Strokes to Pencil Lines

The Brushes Strokes to Pencil Lines operation converts selected contour strokes into centreline pencil strokes.
The brush stroke thickness will be lost.

How to convert brush strokes to pencil lines

‣ From the top menu, select Drawing > Convert > Brush Strokes to Pencil Lines or press ^.

‣ Right-click on the selection, select Convert > Brush Strokes to Pencil Lines or press ^
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Pencil Lines to Brush Strokes

The Pencil Lines to Brush Strokes operation converts the selected centreline pencil strokes into contour
strokes brush lines.

How to convert pencil lines to brush strokes

‣ From the top menu, select Drawing > Convert > Pencil Lines to Brush Strokes or press &.

‣ Right-click on the selection, select Convert > Pencil Lines to Brush Strokes or press &

Strokes to Pencil Lines

The Strokes to Pencil Lines operation converts the selected invisible line to a pencil line.

How to convert strokes to pencil lines

‣ From the top menu, select Drawing > Convert > Strokes to Pencil Lines or press Shift + F12
(Windows/Linux only).

‣ Right-click on the selection, select Convert > Strokes to Pencil Lines or press Shift + F12
(Windows/Linux only)

Optimize
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TheOptimize command reduces the number of layers, such as overlapping brush strokes, in the selected drawing
objects. Drawing objects will only be flattened and optimized if the selected objects do not change the
appearance of the final imagewhen they aremerged.

For example, if you have selected a number of partially transparent objects, which you layered to create an
additive colour effect, the selected transparent drawing objects will not bemerged. This is becausemerging the
transparent drawing objects will cause them to lose the effect of the layered transparent colours.

How to optimize

‣ Use the Select tool to select the drawing objects you want to optimize.

‣ From the top menu, select Drawing > Optimize > Optimize.

‣ From the Camera or Drawing view menu, select Drawing > Optimize > Optimize.

Remove Extra Strokes

The Remove Extra Strokes option let you remove the invisible lines in your selection.

How to remove extra strokes

1. In the Tools toolbar, select the Select tool.

2. In the Camera or Drawing view, use the Select tool to select the drawing objects you want to remove invis-
ible lines from.

3. From the top menu, select Drawing > Optimize > Remove Extra Strokes.

‣ From the Camera or Drawing view menu, select Drawing > Optimize > Remove Extra Strokes.

Reduce Drawing Texture Resolution

When you import and vectorize as texture (colour) a high resolution image, the size of your drawing can be heavy.
You can reduce the size and resolution of the textures in a drawing.

When you import and vectorize drawings using the grey or colour preset styles, you don't have control on the size
of the bitmap texture. You can reduce that bitmap texture.

How to reduce the drawing texture resolution

1. In the Tools toolbar, select the Select tool.

2. In the Camera or Drawing view, use the Select tool to select the drawing objects you want to reduce the
texture resolution for.

3. From the top menu, select Drawing > Optimize > Reduce Drawing Texture Resolution.

‣ From the Camera or Drawing view menu, select Drawing > Optimize > Reduce Drawing Texture
Resolution.
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4. In the dialog box, drag the slider toward the left to reduce the texture resolution.

5. Enable theApply to All Drawings option if you want themodification to be applied to all the drawings
in your layer.

6. Click OK.

Crop Brush Textures

The Crop Brush Textures option is used to crop an unnecessarily large texture bitmap that lies unseen beneath
the vector contour of a textured line. This often occurs when you cut and paste textured lines from one
drawing into another. If you cut a portion from a textured line and paste it into a different drawing, Harmony
pastes the entire unseen texture bitmap from the source drawing into the new one, even if you only took a
small portion of the source drawing. Using the Crop Brush Texture command will crop away extraneous
texture that does not touch the vector area. If there aremany textured lines in your scene, this will greatly
reduce the file size.

In the example shown above, a textured line is cut from a drawing and pasted into a new drawing. At first, it
appears as if only a cropped section of the underlying texture bitmap was cut and pasted as well. However,
using the Contour Editor tool to expand the vector envelope of the textured line, it is revealed that more
texture bitmap exists beyond the cropped boundary. If you use the Crop Brush Texture command, the bitmap
texture is cropped to the boundaries of the textured line’s vector contour (as seen in the fourth imagewhere
the vector envelope has been pulled out to reveal empty space).

How to crop the brush texture

1. In the Timeline or Xsheet view, select the drawing whose texture you want to crop.
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2. From the top menu, select Drawing > Optimize > Crop Brush Textures.

3. From the Camera or Drawing menu, select Drawing > Optimize > Crop Brush Textures.

Create Contour Stroke

The Create Contour Stroke option is used to add a permanent invisible line around a shape that was drawn
directly in Harmony. This allows you to unpaint your lines with the Paint tool but maintain the shape of the
lines, should you need to repaint later.

This command is useful when inking and painting and using the Apply to All Drawings in Layer option.

How to create contour strokes

1. In the Tools toolbar, select the Select tool.

2. In the Camera or Drawing view, use the Select tool to select the drawing objects you want to create con-
tour strokes for.

3. From the top menu, select Drawing > Optimize > Create Contour Strokes.

Remove Contour Stroke

The Remove Contour Stroke option is used to remove any permanently invisible lines that were created while
scanning and vectorizing drawings or manually adding contour strokes. This is useful if you want to remove the
intersection triangles created during vectorization.

How to remove contour strokes

1. In the Tools toolbar, select the Select tool.

2. In the Camera or Drawing view, use the Select tool to select the drawing objects you want to remove con-
tour strokes for.

3. From the top menu, select Drawing > Optimize > Remove Contour Strokes.
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Grid

Use the Show Grid option to display a grid in the Drawing or Camera views.

Name Button Description Keyboard Shortcut

Show Grid
Displays the grid.

View > Grid > Show Grid

Press Ctrl + ' (Windows/Linux) or
⌘ + ' (MacOS X).

Grid OutlineOnly Displays the outline of the grid only. View > Grid > GridOutline Only

Square Displays a standard square grid. View > Grid > Square

12 Field Grid Displays a 12-field size grid. View > Grid > 12 Field Grid

16 Field Grid Displays a 16-field size grid. View > Grid > 16 Field Grid

Underlay
Displays the grid under the drawing
elements.

View > Grid > Underlay

Overlay
Displays the grid over the drawing
elements.

View > Grid > Overlay

Group/Ungroup

Use theGroup option to group selected drawing objects. This can help in the selection, repositioning, re-
scaling and other transformations to be applied to multiple objects of a drawing.

• From the top menu, select Edit > Group > Group or Edit > Group > Ungroup.

• From the Camera or Drawing view menu, select Edit > Group > Group or Edit > Group > Ungroup.

• Press Ctrl + G and Ctrl + Shift + G (Windows/Linux) or⌘ + G and⌘ + Shift + G (MacOS X).

Hand

Use the Hand tool to pan through the Drawing or Camera view.
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• In the Tools toolbar, select the Hand tool, click in the Drawing or Camera view and drag.

• You can also Hold down the Spacebar, click in the Drawing or Camera view andmove your mouse in the
direction you want to pan the view.

Rotate View

The Rotate View tool lets you rotate the Drawing or Camera view, the sameway as you would do with a real
animation disc. This tool can also be used in the Perspective view.

How to use the Rotate View tool

1. Do one of the following:

‣ From the top menu, select Drawing > Tools > Rotate View.

‣ Press Ctrl + Alt (Windows/Linux) or⌘ + Alt (MacOS X).

‣ In the Tools toolbar, select the Rotate View tool.

‣ In the Drawing or Camera view, right-click and select Drawing Tools > Rotate View.

2. In the Drawing or Camera view, click and drag to rotate the space.

Drawing Tool References
Harmony has a wide variety of drawing tools and each one of them has a series of options and modes available.
This section covers these options. For details on how to use these tools, seeDrawing Tasks on page 39.

• Pencil Tool Options on page 120

• Vector Brush Tool Options on page 125

• Bitmap Brush Tool Options

• Select Tool Options on page 153

• Eraser Tool Options on page 162

• Bitmap Eraser Options
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• Contour Editor Options on page 166

• Pencil Editor Options on page 169

• Shape Tool Options on page 173

• Polyline Tool Options on page 177

• Stroke Tool Options on page 179

• Perspective Tool Options on page 180

• Envelope Tool Options on page 181

• Cutter Tool Options on page 184

• Smooth Editor Tool Options on page 186

• Text Tool Options on page 188

• Drawing Pivot Tool on page 192

Pencil Tool Options

When you select the Pencil tool, its properties and options appears in the Tool Properties view.

Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view.
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1. Select a brush style from the Presets section. It's a good idea to choose a brush preset that is closest to
the style you want to create.

2. Click on the Show Extended Properties arrow to display advanced customization parameters.

Maximum Size and Smoothing

This is where you set themaximum size of your drawing tool.

‣ MaximumSize: Defines the width of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line. The fewer the control
points the smoother (but less faithful) the line.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.

• Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between
Round or Flat style.

• End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between Round
or Flat style.

• Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define the
Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Pencil Presets and Thickness Stencils

Harmony provides a variety of pencil presets and thickness stencils and also lets you create and save your own. It
is a good idea to create and save pencils with precise sizes and parameters when you draw and design for
efficiency and consistency.

A thickness stencil saves the thickness information across the length of the line. When drawing with a thickness
stencil, the pressure sensitivity of the tablet is discarded. A thickness stencil can be used while drawing, or
applied afterwards.

You also have the possibility to apply different textures to your lines by either using the default presets or
importing your own—See Pencil Line Texture on page 49.

You can export the pencil presets that you have created and import those that others have created. This is a
good way for you and project collaborators to keep a consistent look for the project—seeWorking with Pencil
Presets on page 43
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Pencil Line Texture

You can apply a bitmap texture on your pencil line and adjust it as needed—see Pencil Line Texture on page 49

Draw Behind

When drawing on vector layers, the Draw Behind mode lets you paint behind existing art. By default,
strokes appear over your work until you release the tool.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically option automatically creates the
corresponding strokes in the Colour Art layer.

Auto-Flatten Mode

When drawing on vector layers, lines do not usually become one object. The Auto-Flatten mode
automatically merges lines created with the existing ones into one single object as you draw.

When drawing on a bitmap layer, you are laying down the bare pixels, so they are always flattened. You can no
longer access the individual stroke after you draw it.

NOTE:
Using the Select tool, you can use select and remove a segment of flattened pencil lines. Overlapping pencil lines
drawn with the Auto-Flatten mode enabled are essentially cut into segments by the overlap and can therefore be
treated as individual lines.
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Auto-Close Gap

When using the pencil tool, you can automatically close strokes with an invisible stroke.

It is recommended to keep this option enabled when drawing with the Pencil tool.

Line BuildingMode

The Line Building mode is very useful when drawing long lines and curves in small increments with pencil lines
or the line tool. As the pencil lines are central vector lines, it may be difficult to align the line tips perfectly to
create a uniform stroke and close all gaps.

In this mode, you can draw lines in small increments and the tips aremerge into one single stroke.

NOTE: This mode only works with pencil lines or the line tool.

Auto Adjust Thickness
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The Auto Adjust Thickness tool is useful when youwant to render a portion of a line thicker. When tracing
a drawing on paper, you will often go back to a section of a curve to make it thicker to add dynamism to the
line. Using the Auto Adjust Thickness tool, you can draw highlight strokes over the section to make thicker.
Once you release the pen or mouse, the line becomes thicker following the shape and curve of the original
stroke. This way is much faster and smoother than using the Pencil Editor tool. You do not have to add extra
points and adjust the position and Bezier handles.

The default overlay colour is light yellow. If this colour is difficult to see because of the background or drawing
colour, you can adjust the colour.

How to change the Auto Adjust Thickness Colour

1. In the Tools toolbar, select the Pencil tool.

2. In the Tool Properties view, click the Auto Adjust Thickness button.

3. Click the colour swatch.

The Colour Picker window opens.

4. In the Colour Picker window, select a new colour.

Line PushingMode

The Line PushingMode option lets you draw highlight strokes over existing pencil lines. You can reshape
the curves. Depending how you draw the pushing stroke over your line, the highlighted section will be
reshaped in one direction or the other.

The default overlay colour is light yellow. If this colour is difficult to see because of the background or drawing
colour, you can adjust the colour.

To change the Line PushingMode colour

1. In the Tools toolbar, select the Pencil tool.

2. In the Tool Properties view, select the Line PushingMode button.
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3. Click the colour swatch.

The Colour Picker window opens.

4. In the Colour Picker window, select a new colour.

Vector Brush Tool Options

When you're drawing on a vector layer and select the Brush tool, its properties and options appear in the
Tool Properties view.

Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view.

1. Select a brush style from the Presets section. It's a good idea to choose a brush preset that is closest to
the style you want to create.

2. Click on the Show Extended Properties arrow to display advanced customization parameters.
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Maximum Size and Smoothing

This is where you set themaximum size of your drawing tool.

‣ MaximumSize: Defines the width of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line. The fewer the control
points the smoother (but less faithful) the line.

Brush Presets

Brush presets are created by saving the properties of the current brush to a new preset, which you can reuse
for repeated tasks. You can create as many brush presets as you need—seeDrawing with the Brush Tool on
page 53.

How to import pencils, brushes and erasers

1. From the Brushmenu , select Import Brushes.

2. In the browser window that appears, navigate to and select the .xml file.

3. Click Open.

4. In the Import Brushes dialog box, select the brushes brushes and erasers you want to import. You can
also import pencils at the same time.
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5. Click Import.

The imported brush, eraser and pencil styles will appear in the presets library. You can reuse any of the
imported tips to create other brush, eraser and pencil style presets.

How to export pencils, brushes and erasers

1. From the Brushmenu, select Export.

2. In the Export Brushes dialog box, select the bitmap and vector brushes and erasers to export, as well as
any pencils.

3. Click Export.

4. In the Export Brushes window that appears, browse to the location where you want to save the .xml file
and give it a name.

5. Click Save.

How to change the Presets Library thumbnail display

1. From the Brushmenu, select one of the following:

Parameter Description

Small Thumbnail Reduces the size of the thumbnails in order to view more at the same time. Dis-
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plays an image of the tool's tip and its maximum size.

Large Thumbnail
Increases the size of the thumbnails in order to see the images more clearly. Dis-
plays an image of the tool's tip, its maximum size and its name.

Stroke View Displays the tool's name, maximum size and stroke preview.

Draw Behind

When the Draw Behind mode is enabled, the lines you draw will appear behind the art that already exists.

Repaint Brush Mode

The Repaint Brush is used to repaint zones that have already been painted, it will not affect empty zones or
pencil lines. It also automatically flattens each of its brush lines so it does not add new brush lines on top of
existing ones. You can use this mode to paint tones or highlights onto your character.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically option automatically creates the
corresponding strokes in the Colour Art layer.

Auto-Flatten Mode

When enabled, the Auto-Flatten

128



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

mode automatically flattens the new lines created with the existing artwork as you draw in the Drawing or
Camera view. Brush strokes will flatten with brush strokes and pencil lines will flatten with pencil lines.

Respect Protected Colour

The Respect Protected Colour option prevent the colours youmarked as protected, in the Colour view, to be
repainted using the Repaint Brushmode or any of the painting tools.

Use Stored Colour Gradient

The Use Stored Colour Gradient optionmakes your tool use the previously stored gradient position. This
way, every new brush line or colour fill will use the stored gradient position.

Bitmap Brush Tool Options
When you're drawing on a bitmap layer and select the Brush tool, its properties and options appear in the
Tool Properties view.

Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view.

1. Select a brush style from the Presets section. It's a good idea to choose a brush preset that is closest to
the style you want to create.

2. Click on the Show Extended Properties arrow to display advanced customization parameters.
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Maximum Size

This is where you set themaximum size of your drawing tool. This parameter defines the width of the stroke.

Flow

The Flow parameter lets you set the range for the rate at which paint flows from your brush. The analogy
works better with a pen. The greater the flow, themore ink comes out, hence themore consistent the colour
and texture of the line. If the flow is light, then the colour and texture of the linemay look spotty. This feature
works with the pressure sensitivity of a pen tablet.

Opacity

TheOpacity parameter are where you set the opacity for a brushmark. This works with the pressure sensitivity
of a pen tablet.

Brush Presets

Brush presets are created by saving the properties of the current brush to a new preset, which you can reuse
for repeated tasks. You can create as many brush presets as you need.

How to create a brush preset

1. Make sure your current brush has the settings you want in the preset you will create.

2. In the Tool Properties view, do one of the following:

‣ Click the arrow button to display the Brush Properties window and click the New Brush button
in the upper-right corner.

‣ Click theNew Brush button.

‣ From the Brush menu, select New Brush Preset.

3. In the New Preset window, type a name for your new brush preset.

The new brush is added to the end of the list of brush presets.

How to update a brush preset

1. Select the brush preset to update and click the arrow button to display the Brush Properties window.
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2. Change the brush settings and click the Update Brush Preset button in the upper-right corner.

Draw Behind

When the Draw Behind mode is enabled, the lines you draw will appear behind the art that already exists.

Repaint Brush Mode

The Repaint Brush is used to repaint zones that have already been painted, it will not affect empty zones or
pencil lines. You can use this mode to paint tones or highlights onto your character.
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Tip Tab
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Brush Tips Library

This is where you select the shape of the brush tip. By default it is round. Note that some tips are designed to
have semitransparent areas, even when themaximumbrush opacity is set to 100%.

To create a custom brush tip, youmust prepare the file ahead of time, either in Harmony or in a third-party
software, such as Adobe Photoshop. Colour is not supported and transparency is not supported in the
traditional sense. Black appears as 100% opaque, white appears as 100% transparent and all the shades of grey
in between appear as varying degrees of semitransparency. A range of file formats are supported—.jpeg, .png,
.tif, .psd, .tga to name a few. Alpha channels are disregarded on import. It is recommended that your file be
between 100 x 100 pixels and 400 x 400 pixels.

You can also import brush tips that you exported fromHarmony, so you can share themwith colleagues.

How to add a brush tip

1. Do one of the following:

‣ From the Brush Tip menu, select Add.

‣ Click the Add button.

2. In the browser window that appears, navigate to where you saved your file.

3. Click Open to import the file into the Brush Tip Library.

By default, an imported brush tip is given the name of the image file.

How to rename a brush tip

1. In the Brush Tip Library, select a brush tip.

2. From the Brush Tip menu, select Rename.

3. In the Rename dialog box that appears, type in the new name of the brush tip.

4. Click OK.
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How to delete a brush tip

1. In the Brush Tip Library, select a brush tip.

2. Do one of the following:

‣ In the Brush Tip menu, select Delete.

‣ Click the Delete button.

The linked brush tip file does not get deleted and can therefore be reimported.

How to import brush tips

1. In the Brush Tip menu, select Import.

2. In the browser window that appears, navigate to and select the .xml file.

3. Click Open.

4. In the Import Textures dialog box, select the brush tips to import. You can also import paper textures
at the same time.

5. Click Import.
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The imported brush tips appear in the Brush Tips Library. You can reuse any of the imported tips to create
other brush style presets.

How to export brush tips

1. In the Brush Tip menu, select Export.

2. In the Export Tips and Textures window, select or deselect any of the brush tips to create the list to
export. You can also export paper textures at the same time.

3. Click Export.

4. In the Export Textures window that appears, browse to a location where you want save the .xml file and
give it a name.

5. Click Save.

How to change the Brush Tips thumbnail display

1. From Brush Tip menu, select one of the following options:

Parameter Description
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Small Thumbnail Reduces the size of the thumbnails in order to view more at the same time.

Large Thumbnail Increases the size of the thumbnails in order to see the images more clearly.

List View Allows you to see the name, as well as the thumbnail.

Minimum andMaximum Size

Theminimum andmaximum sizes of your drawing tool produce the thick and thin effect on your stroke. This
works with the pressure sensitivity of a pen tablet.

‣ Maximum Size: Defines themaximumwidth of the stroke.

‣ Minimum Size: Defines theminimumwidth of the stroke in relation to and as a percentage of the
maximum size.

NOTE: Setting the Minimum Size value to 100% eliminates the possibility of creating width variation on your
stroke. In other words, you would be forcing a uniform line width using the Maximum Size value.

Roundness andAngle

The Roundness and Angle parameters allow you to change the shape and orientation of the brush tip.

‣ Roundness: Squashes the height of the brush tip from its centre point. 100% roundness = the native
height of the brush tip. A smaller percentage will make the brush tip look flatter and more narrow.
The squashing is NOT relative to the angle value—if the brush tip is rotated, the squashing function
still uses the brush tip's original orientation.

‣ Angle: Rotates the brush tip counter-clockwise. 0° = the brush tip's native orientation.

Hardness and Spacing

The Hardness and Spacing parameters allow you to change the softness and spacing of themarks made by the
brush tip. You can preview the hardness and spacing at the top of the Bitmap Brush Properties window, stroke
preview area.

‣ Hardness: The hardness value corresponds to the softness of the brush tip's edges. The lower the
value, the softer the tip edge. The higher the value, the sharper the tip edge. Be aware that some
brush tips are not 100% opaque, so they will always appear somewhat soft, even at 100% hardness.
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‣ Spacing: Defines the amount of space between each stamp of the brush. A value of 100% sets the
stampmarks edge to edge, if there is no white space around the shape. The larger the value, the
greater the space betweenmarks. A really large value canmake the brush stroke appear as a string of
individual marks. Conversely, a small spacing value will give the appearance of a fluid brush stroke.

Spacing is only evident whenmaking a continuous stroke.

Randomness

The Randomness parameters let you create a varied bitmap brush stroke. Refining these options can give your
stroke a lovely, non-mechanical look.

‣ Random Size: You can create variation between the thick and thin of your brush stroke just by setting
theMaximum andMinimum Size values. If you add randomness to themix, pressure sensitivity from
your drawing tablet will still be applied. Light pressure will create random values around theminimum,
while heavy pressure will create random values closer to themaximum. The larger the percentage, the
larger the range of random variation.

NOTE: Setting the Minimum Size to 100% eliminates the possibility of creating width variation on your stroke,
whether you are applying randomness or not. Therefore, you would be forcing a uniform line width using the
Maximum Size value.
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‣ Random Angle: Sets the range for random rotation around the set Angle value. For example, if the
Angle is set to 45° and the RandomAngle set to 10°, the software will choose values between 40°–
50° (plus or minus 5 degrees, equaling a total of 10 degrees).

‣ Random Spacing: Sets the range for random spacing around the set Spacing value. For example, if
the Spacing is set to 50% and the Random Spacing is set to 10%, then Harmony will choose values
between 45%–55% (plus or minus 5 percent, equaling a total of 10 percent).
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Transparency Tab

Maximum andMinimum Flow

TheMaximum andMinimum Flow parameters let you set the range for the rate at which paint flows from your
brush. The analogy works better with a pen. The greater the flow, themore ink comes out, hence themore
consistent the colour and texture of the line. If the flow is light, then the colour and texture of the linemay look
spotty. This feature works with the pressure sensitivity of a pen tablet.

‣ Maximum Flow: Sets themaximum rate at which colour and texture are applied as you create a fluid
stroke.

‣ Minimum Flow: Sets theminimum rate at which colour and texture are applied as you create a fluid
stroke. It is defined as a percentage of theMaximum Flow value. If theMinimum Flow value is set to
100%, then tablet pressure sensitivity will no longer be applicable. The flow will be set to the
constant rate of theMaximum Flow value.
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Maximum Opacity andMinimum Opacity

TheMaximum andMinimumOpacity parameters are where you set the opacity range for a brushmark. This
works with the pressure sensitivity of a pen tablet.

‣ Maximum Opacity: Sets the transparency limit of the brushmark when the pressure is heavy.

‣ Minimum Opacity: Sets the transparency limit of the brushmark when the pressure is very light. It is
defined as a percentage of theMaximumOpacity value. If theMinimumOpacity value is set to 100%,
then tablet pressure sensitivity will no longer be applicable. The opacity will be set to the constant rate
of theMaximumOpacity value.

Randomness

Th Randomness parameter lets you set the range for the randomness of the flow and opacity. This works with the
pressure sensitivity of a pen tablet.

‣ Random Flow: You can create variation in the flow of your brush stroke just by setting theMaximum
andMinimum Flow values. If you add randomness to themix, pressure sensitivity from your drawing
tablet will still be applied. Light pressure will create random values around theminimum, while heavy
pressure will create random values closer to themaximum. The larger the percentage, the larger the
range of random variation.
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NOTE: Setting the Minimum Flow value to 100% eliminates the possibility of creating flow variation on your stroke,
whether you are applying randomness or not. That is, you would be forcing a uniform flow using the Maximum
Flow value.

‣ Random Opacity: You can create variation in the opacity of your brush stroke just by setting the
Maximum andMinimumOpacity values. If you add randomness to themix, pressure sensitivity from
your drawing tablet will still be applied. Light pressure will create random values around the
minimum, while heavy pressure will create random values closer to themaximum. The larger the
percentage, the larger the range of random variation.

NOTE: Setting the MinimumOpacity value to 100% eliminates the possibility of creating opacity variation on your
stroke, whether you are applying randomness or not. That is, you would be forcing a uniform opacity using the
MaximumOpacity value.

142



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

Dual Tip Tab

TheDual Tip tab lets you set the parameters for creating a dual tip brush. The primary bitmap brush tip and the
dual tip always work together. You can set the parameters for the primary tip in the Tip tab and those for the
dual tip in the Dual Tip tab. The Blend mode you select determines how the tips are combined.

Youmust select the Dual Tip option to access the tab's parameters.

By default, the BlendMode is set to Multiply and the RandomAngle to 360°.

143



Chapter 2: Design and Drawing Tools

BlendMode

The Blend modes let you decide how the primary tip and the dual tip are combined.

‣ Multiply: This is the default blend mode. When the two brush tips are combined in this mode, they
essentially cut each other out in overlapping areas, where one or both tips have an area of 100%
transparency. The less opaque the brush tips are, the lighter their combination.
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‣ Colour Dodge: In this mode, the primary tip cuts out the shape of the dual tip. Where the tip shapes
overlap, within the boundaries of the primary shape, the colour and opacity appear darker.
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‣ Combine: This mode treats the two tips as two different and separate brushes that have the same
colour and follow the same path.
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Paper Texture tab

The Paper Texture tab lets you view and select a paperlike texture for your brush. You can also import paper
textures that were previously exported.

Youmust select this option to access the tab's parameters.
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How to add a paper texture

1. Do one of the following:

‣ From the Paper Texturemenu , select Add.

‣ Click the Add Paper Texture button.
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2. In the browser window that appears, navigate to where you saved your texture file.

3. Click Open to import the file into the Paper Texture library.

By default, an imported texture is given the name of the image file.

How to rename a paper texture

1. In the Paper Texture library, select a texture.

2. From the Paper Texturemenu, select Rename.

3. In the Rename Texture dialog box that appears, type in the new name for the texture.

4. Click OK.

How to delete a paper texture

1. In the Paper Texture library, select a texture.

2. Do one of the following:

‣ In the Paper Texturemenu, select Delete.

‣ Click the Delete button.
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NOTE: You can delete any texture in the texture library as long as there is no brush preset using it.

How to import paper textures

1. In the Paper Texturemenu, select Import.

2. In the browser window that appears, navigate to and select the .xml file.

3. Click Open.

4. In the Import Textures dialog box, select the paper textures that you wish to import. You can import
any available brush tips at the same time too.
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5. Click Import.

The imported paper textures will appear in the Paper Texture Library. You can reuse any of the imported
paper textures to create other brush style presets.

How to export paper textures

1. In the Paper Texturemenu, select Export.

2. In the Export Tips and Textures window, scroll down the textures list to the paper textures and select or
deselect any textures to create the list that you wish to export. You can export brush tips at the same time
too.

3. Click on the Export button.

4. In the Export Textures window that appears, browse to a location where you would like to save the .xml
file and give it a name.

5. Click Save.

How to change the Paper Texture thumbnail display

1. From the Paper Texturemenu, select one of the following:
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Parameter Description

Small Thumbnail Reduces the size of the thumbnails in order to view more at the same time.

Large Thumbnail Increases the size of the thumbnails in order to see the images more clearly.

List View Allows you to see the name, as well as the thumbnail.

‣ Texture Scale: Increase or decreases the size of the paper texture.

‣ Additive: This option layers the texture on top of itself as you scribble overlapping lines in one
continuous stroke. If this option is turned off, areas of overlapping lines from a single, continuous
stroke will appear the same, in terms of darkness and texture, as non-overlapping areas.

‣ Aligned: This option defines the way separate, overlapping strokes behave. If this option is enabled,
the paper texture's position does not changewith each sweep of the brush. If this option is
disabled, each sweep of the brush produces a different texture position. The texture orientation
always stays the same.
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Select Tool Options

When you use the Select tool, its properties and options appear in the Tool Properties view.

Lasso andMarquee

Choose between the Lasso andMarquee options to change the selection style of the tool.

• Click and hold Alt to temporarily switch from the current mode to the other.

SnapOptions

You can enable different snapping modes to help you when repositioning drawings using the Select tool.

• Snap to Contour: Snaps your selection or point to any line you position it on. As soon as youmove it
close enough to another line, your point or selection will snap to it.

• Snap andAlign: Snaps the selected anchor point to any existing line while displaying temporary rulers
as a guide that you can also snap your anchor point to.

• Snap to Grid: Snaps your selection following the currently enabled grid.

How to snap to the grid

1. Do one of the following:

‣ Select View > Grid > Show Grid to display the grid in the Camera or Drawing view or press Ctrl + '
(Windows/Linux) or⌘ + ' (MacOS X).

‣ Select View > Grid > Square Grid, 12 Field Grid or 16 Field Grid for your current needs.
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2. In the Tools toolbar, select the Contour Editor tool or press Alt + Q.

3. In the Tool Properties view, click the Snap to Grid button.

4. In the Camera or Drawing view, click on the anchor point you want to snap to the grid, drag it to the
desired position and release.

Selecting by Colour

The Select by Colour mode lets you select all the zones and lines in your drawing painted with the same colour
swatch.

NOTE: Only the zones painted with the SAME colour swatch will be selected. If another zone is coloured with the
exact same RGB value (same colour), but not painted with the same colour swatch, it will not be selected.

154



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

How to select areas by colour

1. In the Tools toolbar, select the Select tool or press Alt + S.

2. In the Tool Properties view, click the Select by Colour button.

3. In the Camera or Drawing view, click on any zone or line in your drawing.

All zones and lines of the same colour are selected.

4. Click the Select tool again to return to the regular Select mode.

Permanent Selection

The Permanent Selection option lets youmaintain a selection over multiple drawings. Once this option is
enabled, the selection zonemade using the Select tool will remain as you navigate through drawings of the same
layer and drawings from other drawing layers. This option can be used to simultaneously delete artwork inside or
outside of the selection on several drawings when combined with the Apply to Multiple Drawings option.

Apply to All Drawings in Layer
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The Apply to All Drawings in Layer option is used to perform an action on all the drawings contained in a
layer. For example, you could enable the option to paint a section on all the drawings simultaneously. The
Apply Tool to All Drawings optionmust be activated before performing the action and will stay enabled only
for the next action.

Apply to Line and Colour Art

The Apply to Line and Colour Art option uses the concept of Line Art and Colour Art layers. Use this
option to apply an action such as selecting, resizing or erasing a drawing on both Line Art and Colour Art
layers, as well as theOverlay and Underlay layers.

Single Mode

By default, when you draw a selection box in the Camera view, the Select tool will select only the drawing
strokes of the current drawing. If you prefer the Select tool to select all the strokes on all layers, you can
disable theWorks on Single Drawing option in the Tool Properties view or disable the Select tool Works
on Single Drawing preference. To do this, go to the top menu, select Edit > Preferences > Camera
(Windows/Linux) or Stage > Preferences > Camera (MacOS X) and uncheck the Select tool Works on Single
Drawing option.

Flip Horizontal and Vertical
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The Flip Horizontal and Flip Vertical operations flip the current selection horizontally or vertically.

‣ From the top menu, select Drawing > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW andCCW

The Rotate 90 Degrees CW and Rotate 90 Degrees CCW operations rotate the current selection 90
degrees clockwise or counter-clockwise.

‣ From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 Degrees
CCW.

‣ Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or⌘ + 7 and⌘ + 9 (MacOS X).

Smooth

The Smooth operation lets you smooth out selected drawing strokes and remove extra points.

‣ From the top menu, select Drawing> Optimize > Smooth or press Alt + Shift + S.

Flatten

The Flatten operation is used to merge drawing objects and brush strokes into a single layer. If you draw new
lines to fix a drawing or line withmany brush strokes, it can be useful to flatten them all into a single shape. By
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default, lines are drawn one on top of each other. If you intend to repaint the lines or modify their shape, it will
be easier if they are flattened.

‣ From the top menu, select Drawing > Optimize > Flatten or pres Alt + Shift + F.

Create Colour Art from Line Art

Lets you use the outline you traced on one of the four embedded layers (line art, colour art, overlay, underlay)
and create invisible strokes to paint your drawings on separate layers. This provides more inking and painting
flexibility.

You can also configure this option to create the invisible strokes on any of the four embedded layers.

How to create Colour Art zones out of the Line Art content

1. In the Tools toolbar, select the Select tool or press Alt + S.

2. In the Camera or Drawing view, select the artwork to transfer to the Colour Art.

3. In the Tool Properties view or the Drawing View toolbar, click the Create Colour Art from Line Art
button or press *.

How to configure the Create Colour Art from Line Art option

1. In the Tools toolbar, select the Select tool or press Alt + S.

2. In the Tool Properties view or the Drawing View toolbar, Shift + click the Create Colour Art from Line
Art button.

The Configure Line Art to Colour Art dialog box opens.

Parameter Description

Use rendered version of the
drawing

Renders the drawing and vectorize it to calculate the position of the
centreline that will produce the colour art stroke.

MaximumResolution for
rendered image

The size of the rendered image.
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Threshold for rendered image The value of grey processed to create the rendered vectorized arts.

Fitting error for rendered Bez-
iers

This value represents how precise the fitting of the colour art zone in relation
to the line art will be.

Source layer
Lets you select the layer (Line Art, Colour Art, Underlay orOverlay) you want
the colour art to be created from.

Destination layer
Lets you select the layer (Line Art, Colour Art, Underlay orOverlay) you want
the colour art to be created on.

Clear Destination Art Layer
First

Deletes the content before the colour art is added. This is useful when you
already have artwork on the destination layer.

Perform Line Art to Colour
Art Operation Immediately

Performs theCreate Colour Art from Line Art command when you click OK.

Distribute to Layers

TheDistribute to Layers option is used to separate the selected art strokes and send them to new drawing
layers. In the Camera view, once you have drawn your artwork, you can select the strokes you want to distribute
using the Select tool and click on the Distribute to Layers button; you can also select Drawing >
Distribute to Layers. It will automatically take every stroke from the drawing selectionmade in the Camera view
and separate them into a different layer for each. If an artwork is composed of several strokes, youmust group
them using Edit > Group > Group before using the Distribute to Layers option. This option cannot be done from
the Drawing view.

Store Colour Gradient

Use the Store Colour Gradient operation to record the selected gradient’s position. This reuses the stored
position of the gradient when drawing new brush lines or painting colour zones. Enable the Use Stored Colour
Gradient option in the Paint or Brush Tool Properties view to do this.

Pencil to Brush

The Pencil to Brush operation converts the selected centre line pencil strokes into contour strokes brush
lines.

From the top menu, select Drawing > Convert > Pencil Lines to Brush or press &.
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Merge Pencil Lines

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to align them and
make it look like it is one single line. With the Select tool, you can select several pencil lines and merge them as
one single object using theMerge Pencil Lines option. The ends of your lines are adjusted to form one
single line.

NOTE: Points must be close enough to be merged. If there is a large gap between the lines, they will not be
merged.

Reverse Pencil Thickness

The Reverse Pencil Thickness option inverts the thick and thin section on a selected pencil line. This option
will take the thickest size on the line and apply it to the thinnest, and it will apply the thinnest to the thickest.

Offset X and Y

Use theOffset X and Offset Y operation fields to enter specific values and precisely reposition the selected
shape.

1. X: Type a value in this field to reposition your selection along the X-axis.

2. Y: Type a value in this field to reposition your selection along the Y-axis.

3. Up/Down arrows: Use the up and down arrows to modify the value in the X or Y value field.
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Width andHeight

Use theWidth and Height operation fields to enter specific values to resize the selected shapewith precision.

1. Width: Type a value in this field to resize the width of your selection.

2. Height: Type a value in this field to resize the height of your selection.

3. Up/Down arrows: Use the up and down arrows to modify the value in theWidth or Height fields.

4. Lock icon: Click the lock icon to lock or unlock the ratio between theWidth and Height values.

Angle

The Angle operation lets you to enter specific values and accurately rotate the selected shape.

1. Angle: Type a degree value in this field to rotate your selection.

2. Up/Down arrows: Use the up and down arrows to modify the value in the Angle value field.

When you select a pencil line with the Select tool, additional options appear in the Tool Properties view.

Adjusting the Pencil Line Thickness

Use the Adjusting the Pencil Line Thickness operation field to resize the selected centreline strokes. This
operation is not permitted on contour line shapes, such as brush strokes or shape fills.

1. Minimum Size: Type a value in this field to set theminimum thickness of the selected centreline stroke.

2. Maximum Size: Type a value in this field to set themaximum thickness of the selected centreline stroke.

3. Up/Down arrows: Use the up and down arrows to modify the value contained in the Thickness value field.

Adjusting the Pencil Line Style
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You can adjust the start, end, and joint style of a selected pencil line.

• Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between
Round or Flat style.

• End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between
Round or Flat style.

• Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define
the Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Pencil Stencils

Toon BoomHarmony gives you the flexibility to change the style and thickness of your pencil lines even after
they are drawn. You can apply preset pencil stencils or create your own—seeWorking with Pencil Presets on
page 43.

Adding Texture to a Pencil Line

Pencil lines support texture. Once a pencil line is drawn, you can apply a preset texture or load your own.
Textures are independent from pencil stencils—see Pencil Line Texture on page 49.

Adjusting the Text Selection

When you select text with the Select tool, the tool properties will display the Text tool options on the bottom
of the view. You can also press Alt + 9 to display only the Text properties in the Tool Properties view—see
Text Tool Options on page 188.

Eraser Tool Options

When you're drawing on vector layer and you select the Eraser tool, its properties and options appear in
the Tool Properties view.

For information on erasing textured lines—see See How to erase textured lines on page 67.

For information on Bitmap Eraser tool options—see See Bitmap Eraser Options on page 166.
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Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view. Click on the Show Extended Properties arrow to display advanced
customization parameters,

Maximum Size and Smoothing

This is where you set themaximum size of your drawing tool.

‣ MaximumSize: Defines the width of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line. The fewer the control
points the smoother (but less faithful) the line.

Eraser Presets

It is a good idea to create and save erasers with precise sizes and parameters in order to save timewhen drawing
and designing. Toon BoomHarmony provides you with a variety of default eraser styles and allows you to create
and save your own.

Eraser presets are created by saving the properties of the current eraser as a preset, in order to reuse it again
and again. You can create a new preset from the Eraser Tool Properties view, but it is better to do it from the
Eraser Properties—see Erasing Parts of a Drawing on page 91.

The Eraser tool uses its own preset list, separated from the Brush tool.
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How to import pencils, brushes and erasers

1. From the Brushmenu , select Import Brushes.

2. In the browser window that appears, navigate to and select the .xml file.

3. Click Open.

4. In the Import Brushes dialog box, select the brushes brushes and erasers you want to import. You can
also import pencils at the same time.

5. Click Import.

The imported brush, eraser and pencil styles will appear in the presets library. You can reuse any of the
imported tips to create other brush, eraser and pencil style presets.

How to export pencils, brushes and erasers

1. From the Brushmenu, select Export.

2. In the Export Brushes dialog box, select the bitmap and vector brushes and erasers to export, as well
as any pencils.
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3. Click Export.

4. In the Export Brushes window that appears, browse to the location where you want to save the .xml file
and give it a name.

5. Click Save.

How to change the Presets Library thumbnail display

1. From the Brushmenu, select one of the following:

Parameter Description

Small Thumbnail
Reduces the size of the thumbnails in order to view more at the same time. Dis-
plays an image of the tool's tip and its maximum size.

Large Thumbnail
Increases the size of the thumbnails in order to see the images more clearly. Dis-
plays an image of the tool's tip, its maximum size and its name.

Stroke View Displays the tool's name, maximum size and stroke preview.

Apply to Line and Colour Art

The Apply to Line and Colour Art option uses the concept of Line Art and Colour Art layers. Use this option
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to apply an action such as selecting, resizing or erasing a drawing on both Line Art and Colour Art layers, as
well as theOverlay and Underlay layers.

Tip Style

If you erase the end of a pencil line or erase a pencil line through the centre, new line tips or line ends are
created. Use the Tip Style option to customize the shape of the new line tips that are created.

Bitmap Eraser Options

The bitmap eraser options are identical to those of the bitmap brush with one obvious exception. Instead of
customizing the parameters of a mark or stroke, you will be customizing the parameters for the absence of a
mark or stroke.

It is a good idea to create an eraser preset with the identical properties of a brush preset and to use them as a
pair. That way, when part of a stroke is erased, its soft textured look is not interrupted with a hard edged
eraser mark.

Contour Editor Options

When you select the Contour Editor tool, its properties and options appear in the Tool Properties view.

Lasso andMarquee

Choose between the Lasso andMarquee options to change the selection style of the tool.

• Click and hold Alt to temporarily switch from the current mode to the other.

Snap to Contour
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The Snap to Contour option will snap the selected anchor point to any line you position it on.

How to snap two shapes together

1. In the Tools toolbar, select the Contour Editor tool or press Alt + Q.

2. In the Tool Properties view, click the Snap to Contour button.

3. In the Camera or Drawing view, click on an anchor point you want to snap to the other shape, drag it on
top of the contour line area and release it.

Snap andAlign

The Snap and Align option lets you snap the selected anchor point to any existing line while displaying
temporary rulers as a guide that you can also snap your anchor point to.

How to snap and align

1. In the Tools toolbar, select the Contour Editor tool or press Alt + Q.

2. In the Tool Properties view, click the Snap and Align button.

3. In the Camera or Drawing view, click on an anchor point you want to snap, drag it until a ruler is displayed,
position it on the ruler or on the contour line and release.
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Show Contour Editor Controls

Use the Show Contour Editor Controls option to show the contour editor controls. You can use these
controls to scale, reposition and rotate the selected anchor points.

Apply to Line and Colour Art

The Apply to Line and Colour Art option uses the concept of Line Art and Colour Art layers. Use this
option to apply an action such as selecting, resizing or erasing a drawing on both Line Art and Colour Art
layers, as well as theOverlay and Underlay layers.

Smooth Selection

The Smooth operation lets you smooth out selected drawing strokes and remove extra points.

‣ From the top menu, select Drawing> Optimize > Smooth or press Alt + Shift + S.

Split Pencil Line and Join Pencil Lines

When drawing with the Polyline tool, your drawing has an even line thickness. You can use the Pencil Editor to
adjust the thickness point by point, but if you want to adjust it quicker, you can use the Split Pencil Line and
Point Pencil Lines options to create segments and apply a pencil stencil to your drawing. Note that if you did
not join the pencil lines on your polyline stroke, the segments between the points will act as separated
segments.
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How to split and join pencil lines

1. In the Tools toolbar, select the Contour Editor tool.

2. In the Drawing or Camera view, select the contour points you want to split or join.

3. In the Tool Properties view, click on the Join Pencil Lines or Separate Pencil Line buttons.

Pencil Editor Options

When you select the Pencil Editor tool, its properties and options appear in the Tool Properties view.
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Lasso andMarquee

Choose between the Lasso andMarquee options to change the selection style of the tool.

• Click and hold Alt to temporarily switch from the current mode to the other.

Maximum Size and Smoothing

This is where you set themaximum size of your drawing tool.
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‣ MaximumSize: Defines the width of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line. The fewer the control
points the smoother (but less faithful) the line.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.

• Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between
Round or Flat style.

• End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between Round
or Flat style.

• Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define the
Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Preset

To work with Pencil line presets, seeWorking with Pencil Presets on page 43.

Textures

To work with Pencil Line Texture, see Pencil Line Texture on page 49

Smooth

The Smooth operation lets you smooth out selected drawing strokes and remove extra points.

‣ From the top menu, select Drawing> Optimize > Smooth or press Alt + Shift + S.
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Pump Pencil Pressure

The Pump Pencil Pressure option is used to increase the line thickness of a selected area on a pencil line.

Deflate Pencil Pressure

TheDeflate Pencil Pressure option is used to decrease the line thickness of a selected area on a pencil line.

Merge Pencil Lines

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to align them and
make it look like it is one single line. With the Select tool, you can select several pencil lines and merge them as
one single object using theMerge Pencil Lines option. The ends of your lines are adjusted to form one
single line.
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Reverse Pencil Thickness

The Reverse Pencil Thickness option inverts the thick and thin section on a selected pencil line. This option will
take the thickest size on the line and apply it to the thinnest, and it will apply the thinnest to the thickest.

Shape Tool Options

When you select a shape tool (Rectangle, Ellipse, Line), its properties and options appear in the Tool Properties
view.

If the Tool Properties looks different than the image below, youmaybe on a bitmap drawing layer instead of a
vector drawing layer. If you want to use a shape tool on a bitmap drawing layer—See Bitmap Brush Tool Options
on page 129.

Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the different
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parameters in the Tool Properties view.

1. Select a brush style from the Presets section. It's a good idea to choose a brush preset that is closest to
the style you want to create.

2. Click on the Show Extended Properties arrow to display advanced customization parameters.

Size

Move the Size slider left to reduce the line thickness and to the right to increase its width.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.

• Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between
Round or Flat style.

• End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between
Round or Flat style.

• Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define
the Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Pencil Presets and Thickness Stencils

Harmony provides a variety of pencil presets and thickness stencils and also lets you create and save your own.
It is a good idea to create and save pencils with precise sizes and parameters when you draw and design for
efficiency and consistency.

A thickness stencil saves the thickness information across the length of the line. When drawing with a thickness
stencil, the pressure sensitivity of the tablet is discarded. A thickness stencil can be used while drawing, or
applied afterwards.

You also have the possibility to apply different textures to your lines by either using the default presets or
importing your own—See Pencil Line Texture on page 49.

You can export the pencil presets that you have created and import those that others have created. This is a
good way for you and project collaborators to keep a consistent look for the project—seeWorking with Pencil
Presets on page 43
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Draw Behind

When the Draw Behind mode is enabled, the lines you draw will appear behind the art that already exists.

Automatic Filling

Use the Automatic Filling option to automatically fill your shapewith the selected colour as you draw. By
default, the Shape tool creates the outline of an empty shape that you can later fill using the Paint tool. This
option is unavailable for the line tool.

SnapOptions

When drawing a shape, you can enable different snap modes to help you create your shape.

• The Snap to Contour option snaps your shape to any line you position it on.

• The Snap and Align option snaps the selected anchor point to any existing line, while displaying
temporary rulers as a guide that you can also snap your anchor point to.

• The Snap to Grid snaps your shape to the currently enabled grid.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically option automatically creates the
corresponding strokes in the Colour Art layer.

Auto-Flatten Mode

When enabled, the Auto-Flatten
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mode automatically flattens the new lines created with the existing artwork as you draw in the Drawing or
Camera view. Brush strokes will flatten with brush strokes and pencil lines will flatten with pencil lines.

Using the Select tool, you can use themiddlemouse button to select a segment of flattened pencil line. This
creates a nice finish on the lines and corners of your artwork.

Auto-Close Gap

When enabled, the Auto-Close Gap mode automatically connects, with an invisible stroke, the pencil lines
you draw close to each other in the Camera or Drawing view.

NOTE: It is recommended to leave this option enabled when drawing with the Pencil tool.

Use Stored Colour Gradient

The Use Stored Colour Gradient optionmakes your tool use the previously stored gradient position. This
way, every new brush line or colour fill will use the stored gradient position.

Line BuildingMode
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The Line Building mode is very useful when drawing long lines and curves in small increments with pencil lines
or the line tool. As the pencil lines are central vector lines, it may be difficult to align the line tips perfectly to
create a uniform stroke and close all gaps.

In this mode, you can draw lines in small increments and the tips aremerge into one single stroke.

NOTE: This mode only works with pencil lines or the line tool.

Keep Proportion

When the Ellipse or Rectanglemode is enabled in the Tool Properties view, the Draw Circle or Draw Square
option appears. When selecting these options, the shape produced will be a perfect circle or square (as opposed
to an oval or rectangle).

Enabling this option is a good idea if you plan to createmany squares or circles. However, if you only need to
create one, holding down the Shift key as you create your shapewill maintain the proportion in the sameway.

Polyline Tool Options

When you select the Polyline tool, its properties and options appear in the Tool Properties view.
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Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view.

1. Select a brush style from the Presets section. It's a good idea to choose a brush preset that is closest to
the style you want to create.

2. Click on the Show Extended Properties arrow to display advanced customization parameters.

Size

The Size parameter lets you set the size of the polyline that you will draw.

Pencil Presets and Thickness Stencils

Harmony provides a variety of pencil presets and thickness stencils and also lets you create and save your own.
It is a good idea to create and save pencils with precise sizes and parameters when you draw and design for
efficiency and consistency.

A thickness stencil saves the thickness information across the length of the line. When drawing with a thickness
stencil, the pressure sensitivity of the tablet is discarded. A thickness stencil can be used while drawing, or
applied afterwards.

You also have the possibility to apply different textures to your lines by either using the default presets or
importing your own—See Pencil Line Texture on page 49.

You can export the pencil presets that you have created and import those that others have created. This is a
good way for you and project collaborators to keep a consistent look for the project—seeWorking with Pencil
Presets on page 43

Snap to Contour

The Snap to Contour option will snap your selection to any line you position it on.

Create Colour Art Automatically
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As you draw in the Line Art layer, the Create Colour Art Automatically option automatically creates the
corresponding strokes in the Colour Art layer.

Auto-Flatten Mode

When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing artwork
as you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes and pencil lines will
flatten with pencil lines.

Stroke Tool Options

When you select the Stroke tool, its properties and options appears in the Tool Properties view.

Draw Stroke as Straight Lines

Enable the Draw Stroke as Straight Lines option if you want the new strokes you draw to be a perfect
straight line. Disable the option if you want the stroke to follow themouse gesture.

Connect Line Ends

Enable the Connect Line Ends option if you want the start or end point of your new stroke to connect to your
existing strokes to make sure no gaps are left in your drawing.

Auto-Flatten Mode

When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing artwork
as you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes and pencil lines will
flatten with pencil lines.

Apply to Line and Colour Art

The Apply to Line and Colour Art option uses the concept of Line Art and Colour Art layers. Use this option
to apply an action such as selecting, resizing or erasing a drawing on both Line Art and Colour Art layers, as well
as theOverlay and Underlay layers.

Smoothness

You canmodify the central line smoothness of your line using this option. This parameter smooths the initial
movement of your line. Increasing the value will result in a smoother line with fewer control points. Use the left
and right arrows to increment the value by one full unit. Use the Up - Down slider to quickly increment the value.
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Perspective Tool Options

Selecting the Perspective tool displays its properties and options in the Tool Properties view.

Lasso andMarquee

Choose between the Lasso andMarquee options to change the selection style of the tool.

• Click and hold Alt to temporarily switch from the current mode to the other.

SnapOptions

• The Snap to Contour option will snap the selected anchor point to any line you position it on—see
Contour Editor Options on page 166.

• The Snap and Align option lets you snap the selected anchor point to any existing line while
displaying temporary rulers as a guide that you can also snap your anchor point to—seeContour Editor
Options on page 166.

• The Snap to Grid option snaps your selection according to the currently enabled grid.

Apply to Line and Colour Art

The Apply to Line and Colour Art option uses the concept of Line Art and Colour Art layers. Use this
option to apply an action such as selecting, resizing or erasing a drawing on both Line Art and Colour Art
layers, as well as theOverlay and Underlay layers.

Flip Horizontal and Vertical
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The Flip Horizontal and Flip Vertical operations flip the current selection horizontally or vertically.

‣ From the top menu, select Drawing > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW andCCW

The Rotate 90 Degrees CW and Rotate 90 Degrees CCW operations rotate the current selection 90
degrees clockwise or counter-clockwise.

‣ From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 Degrees
CCW.

‣ Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or⌘ + 7 and⌘ + 9 (MacOS X).

Envelope Tool Options

Selecting the Envelope tool displays its properties and options in the Tool Properties view.

Width andHeight

Increase the width and height values to addmore columns and rows to the deformation grids.
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Lasso andMarquee

Choose between the Lasso andMarquee options to change the selection style of the tool.

• Click and hold Alt to temporarily switch from the current mode to the other.

SnapOptions

• The Snap to Contour option will snap the selected anchor point to any line you position it on—see
Contour Editor Options on page 166.

• The Snap and Align option lets you snap the selected anchor point to any existing line while
displaying temporary rulers as a guide that you can also snap your anchor point to—seeContour Editor
Options on page 166.

• The Snap to Grid option snaps your selection according to the currently enabled grid.

Show Advanced Controls

To displaymore controls,you can click on the Show Advanced Controls button.

182



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

Apply to Line and Colour Art

The Apply to Line and Colour Art option uses the concept of Line Art and Colour Art layers. Use this option
to apply an action such as selecting, resizing or erasing a drawing on both Line Art and Colour Art layers, as well
as theOverlay and Underlay layers.

Flip Horizontal and Vertical

The Flip Horizontal and Flip Vertical operations flip the current selection horizontally or vertically.

‣ From the top menu, select Drawing > Flip Horizontal and Flip Vertical.
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Rotate 90 Degrees CW andCCW

The Rotate 90 Degrees CW and Rotate 90 Degrees CCW operations rotate the current selection 90
degrees clockwise or counter-clockwise.

‣ From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90
Degrees CCW.

‣ Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or⌘ + 7 and⌘ + 9 (MacOS X).

Smoothness

You canmodify the central line smoothness of your line using this option. This parameter smooths the
deformed lines. Increasing the value will result in a smoother line with fewer control points. Themore you
increase the value, the less details and curves you will get. Use the left and right arrows to increment the value
by one full unit. Use the Up - Down slider to quickly increment the value.

Cutter Tool Options

When you select the Cutter tool, its properties and options appear in the Tool Properties view.

Lasso andMarquee

Choose between the Lasso andMarquee options to change the selection style of the tool.

• Click and hold Alt to temporarily switch from the current mode to the other.

Apply to Line and Colour Art

The Apply to Line and Colour Art option uses the concept of Line Art and Colour Art layers. Use this
option to apply an action such as selecting, resizing or erasing a drawing on both Line Art and Colour Art
layers, as well as theOverlay and Underlay layers.

Use Mouse Gesture

When using the Lasso
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selection type, the UseMouseGesture option lets you automatically delete any extra sections of line in
your artwork by simply dragging your mouse over it.

NOTE: For this operation to work, you lines CANNOT be flattened.

Use Mouse Gesture Breaker Mode

When using the Lasso selection type, the UseMouseGesture Breaker Mode option lets you draw an
invisible stroke on a pencil line to cut it in two individual objects. Once a pencil line is cut with this option, you will
be able to select the two portions independently with either the Cutter tool, Pencil Editor tool or Select tool.

NOTE: This option only works with pencil lines.

Tip Style

If you erase the end of a pencil line or erase a pencil line through the centre, new line tips or line ends are created.
Use the Tip Style option to customize the shape of the new line tips that are created.

Antialiasing
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When drawing on a bitmap layer, lines are no longer clean vector shapes. For the edges to be smooth, a slight
amount of antialiasing is used. When using the Cutter tool, you can cut a portion of your drawing with or
without antialiasing. By default, the option is enabled. If you want to cut your drawing using a hard edge, you
can select the Antialiasing Off option.

Flip Horizontal and Vertical

The Flip Horizontal and Flip Vertical operations flip the current selection horizontally or vertically.

‣ From the top menu, select Drawing > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW andCCW

The Rotate 90 Degrees CW and Rotate 90 Degrees CCW operations rotate the current selection 90
degrees clockwise or counter-clockwise.

‣ From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90
Degrees CCW.

‣ Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or⌘ + 7 and⌘ + 9 (MacOS X).

Smooth Editor Tool Options

When you select the Smooth Editor tool, its properties and options appear in the Tool Properties view.
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Brush, Marquee and Lasso Smoothing Style

The Smoothing Style options allow you to smooth a portion of your drawing by tracing a smoothing stroke over
the zone to optimize or by selecting an area of the drawing with theMarquee or Lasso.

Note that by default, the Smooth Editor tool colour is yellow, it was changed to orange for screen grab clarity.

Show Control Points

The Show Control Points option allows you to show or hide the Bezier points around lines. When the Bezier
points are displayed, you can see the result of your smoothing and the number of points left on the curve. When it
is turned off, only the original artwork is displayed.

Minimum Size andMaximum Size

This is where you set theminimum andmaximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.

This options is available while using the Brush Smoothing style.

‣ Maximum andMinimum Size: Defines themaximum andminimumwidth of the stroke.

• Up/Down arrows: Use the up and down arrows to set theminimum andmaximum size value.

Smoothness

The Smoothness impacts the strength of the smoothing result. The higher the value, themore points are
removed and the smoother the curve. The Smoothness range is from 0 to 100; the default value is 20.
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Colour

You canmodify the colour of the control points displayed on the artwork while working with the Smooth
Editor tool by double-clicking on the colour swatch.

Text Tool Options

Use the Text tool's properties to select the font type and other formatting options you want to apply to the
text.

If you already wrote your text, youmust first use the Text tool and select the text portion you want to format.

Font Type

Use the Font drop-downmenu to select a font. OTF fonts are supported.
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Font Style

Use these buttons to select a style for your text:

• Bold

• Italic

Alignment

Use these buttons to align the paragraph.

Left Centered

Right Justified

Font Size

Enter a size for the text.
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Kerning

Use the kerning field to modify the spacing between letters and characters. You can select the Auto Kern
option to set the kerning automatically based on the font’s predefined standard. A negative value decreases
spacing between each character, creating a letter overlap and a positive value increases it.

Indent

Enter a value in the Indent field to increase or decrease the indentation on the first line of your text. A positive
value sets the first line of your paragraph farther to the right and a negative value sets it farther to the left.

Line Spacing

Enter a value in the Line Spacing field to decrease or increase the space between each line of text.

Resizing the Text Box

You can resize the text box by selecting your text box with the Text tool and moving the anchor point
right or left. Using the Select tool will distort and scale your text itself rather than changing the width and
height of your text box.
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Converting Text into Separate Objects

Text contained in a text field is treated as a single drawing object. You can easily separate the text so each
character becomes an individual drawing object that you can select and modify independently.

How to break a text object

1. In the Tools toolbar, click the Select tool or press Alt + S.

2. In the Drawing or Camera view, select the text object you want to break.

3. From the top menu, select Drawing > Convert > Break ApartText Layers.

‣ From the Drawing or Camera view menu, select Drawing > Convert > Break ApartText Layers.

Each character is surrounded by a bounding box that you canmodify; they remain text objects that you can
edit.

4. If you want to convert your independent letter to a complete vector object that you can deform, use the
Select tool to select the letters to convert.

5. From the top menu, select Drawing > Convert > Break Apart Text Layers to break the selection into a
regular drawing object, with no more text attributes.

‣ From the Drawing or Camera view menu, select Drawing > Convert > Break Apart Text Layers to
break the selection into a regular drawing object, with no more text attributes.
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Drawing Pivot Tool

TheDrawing Pivot tool lets you set the pivots on your character. You can set the drawing pivots on
drawings and symbols.

Setting the Drawing Pivot for Symbols on All Frames

The Set the Pivot for Symbol on All Frames option is enabled by default. When you set a drawing pivot on
a symbol, all of its cells use the same drawing pivot. This means you do not have to set a drawing pivot on all
frames. Once you set it, it is done.

If you prefer to set a different drawing pivot for a series of cells, you can deselect the option and set your
pivots on each cell or cell range.

NOTE: If you have already set several different pivots on your symbol's cells and selected the Set the Pivot for
Symbol on All Frames option, once you set a new pivot on the same symbol, all of its pivots will be reset and will
use your new pivot.

Snapping

When you drag the drawing pivot around, you can enable a snap option so that when the drawing pivot is
released, it either snaps to the reference grid, drawing's contour, or aligns with an existing drawing stroke.

Reset Pivot

When you click the Reset Pivot option, the drawing pivot of the selected drawing or symbol is reset to the
centre of the Camera view.

Copying Pivot on Parent Symbol

When you import new extra drawings, such as hands and mouths, you can use the drawing pivot that was set
on your drawings and report them to the symbol's cells. Use the Copy Pivot to Parent Symbol command
for this.
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NOTE:When you copy drawing pivots to the parent symbol, there is no link between the drawings' pivots and the
symbol's pivots. If you modify the drawing pivot later, it will not link to the symbol. You would need to perform the
operation again. If you need to modify the symbol's pivots, you can do it directly on the symbol's cells.
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Chapter 3: Colour Styling and Colour Models

Once the characters, props and locations are designed, it's time for the colour styling and colour models
creation. This is when the colours and moods are determined. The linemodels created during the design step are
painted and organized as colour models for the colourists.

Harmony has a great concept of colour palettes. Each character can have its own set of colours that is carried
through the entire project called themaster palette. If themaster is modified, the colours in the entire project are
updated simultaneously.

By doing the colour styling in Harmony, your master palette will be created at the same time, so you do not need
to use third party software. Also you will not have to recreate the colour palette again in Harmony. It is possible
to create this step in an external software, but it is a great time saver to do it directly in Harmony.

To create the colour style and colour models, follow these steps:

• Preparation on page 195

• Working with Palettes on page 200

• Colours on page 224

• Painting theModel on page 241

Preparation
Before painting, you need to organize the colour model scenes and bring in your references. The colour styling
preparation is done in five steps:

• Colour Model Storage on page 196

• Scene Creation on page 196

• Setting Up theWorkspace on page 197

• Naming on page 197
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Colour Model Storage

First, you will need to create a storage location for all your models and palettes. The best way to do this is to
create a colour model scene. There are different possibilities available to structure your designs and colour
model scenes. We strongly recommend that you put all of your colour models in the same scenes. It is
important to maintain a structure for your models so they do not end up scattered throughout the project.

There are four mainmodel categories:

If you have a small project, such as a short or an advertising contract, you can always place all the characters,
props, effects, and locations in the same scene. For large projects such as feature-length productions or series,
you should create four separatemodel scenes following these categories.

Scene Creation

In order to create colour models, you need to create your scenes.

Whenworking on a paperless or cut-out animation project, if you have designed your characters, props,
effects and locations directly in Harmony, you can paint your models directly in your design scene. You can also
create a new colour model scene and import your designs in that one. Refer to the Fundamentals Guide to
learnmore about creating a scene.

If you have not already done so, refer to the Fundamentals Guide to learn about production structure, file
organization, and how to create a Project root directory. We recommend storing your colour model scenes in
the root directory or in a colour models subdirectory for even better organization.

A useful way to name your colour model scene is to include the project name, then the colour model type such
as characters, props, effects, or locations, and finally colourmodel. For example, a character colour model
scene for the Adventure project would be named adventure_characters_colourmodel. This ensures
that you always know what scene corresponds to what.
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To learn how to create environment, job, and scene for your colour models, refer to the Control Center Guide.

Colour Model Scene Structure

To store your colour models in a scene, you should create one drawing layer for each character, prop, effect, or
location. You should name these according to themodel.

You can also load other colour references in the scene to balance your overall colours. For example, if you work in
a character colour model scene, it's a good idea to import some of the key locations to compare and adjust the
colours so theymatch well.

Setting Up the Workspace

Now that your scenes are created and structured, you can open the corresponding colour model scene. For the
optimal workspace for inking and painting, set up your workspace with these views:

• Xsheet

• Camera

• Drawing

• Colour

• Model

Naming

Now that your models are imported, you can rename them appropriately. You should rename elements (layers)
and drawings corresponding to themodel. This will help keep the work organized andmake it easy for others to
follow.

For example, if there is a black and white character model called Erik in one drawing element and its colour
models in another one, rename your elements to include the character's name. For example, the colour model for
Erik's armour could be named: erik_armour_colour.
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How to rename a drawing element

1. Do one of the following:

‣ In the Xsheet view, double-click on the column header of the drawing element.

‣ In the Timeline view, double-click on the drawing element's layer.

The Layer Properties window opens.
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2. Type in a new name.

How to rename a drawing

1. In the Xsheet view, click on a drawing name.

2. Do one of the following:

‣ From the Xsheet view menu, select Drawings > Rename Drawing.

‣ Right-click on the drawing name and select Drawings >Rename Drawing.

‣ Press Ctrl + D (Windows/Linux) or⌘ + D (MacOS X).

The RenameDrawing dialog box opens.
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3. Type in a new name and click OK.

Working with Palettes
In animation, specific colours are used to paint each particular character. In order to maintain absolute
consistency, a colour palette is created for each character, prop and effect throughout the production. This is
referred to as amaster palette.

Master palettes contain a colour swatch for each zone to colour with a precise RGBA colour value.

Using a master colour palette has many benefits, including:

• Each character consistently retains their dedicated colours.

• You cannot accidentally use a colour which is not in themaster palette.

• Standardization and colour consistency throughout the production

• Multiple artists can use the same colour palette and produce the same results.

Toon BoomHarmony uses palettes to hold all the colours needed to paint your elements, allowing complete
control and consistency in your painting process.

A palette is created by assigning a set of colours to each character, prop or effect. You will create a new
palette and add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair,
tongue, shirt, pants, and so on.

In Harmony, palettes are individual files that you can copy, transfer, and store. Palettes have a *.plt file name
extension—see Palette File Storage on page 205.

When a zone on the character is painted with the colour contained in a colour swatch, a link is automatically
created between that colour swatch and the zone. This means that if the tint of the colour in the colour swatch
is changed, any zone linked to it will update to the new tint. This is one way that colour palettes can save time
andmoney in your production.

Another advantage of this system is that you can create complete palettes for different lighting situations. For
instance, in addition to the regular palette for a character, you could have one for that character in the rain
using colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night
scene. Using palettes linked to your character in this way allows you to instantly change its colouring to suit the
mood and atmosphere of the scene without tediously repainting each element.
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This section is divided as follows:

• Palette Lists on page 201

• Palette File Storage on page 205

• Creating a Colour Palette on page 207

• Duplicating a Colour Palette on page 211

• Cloning a Colour Palette on page 213

• PaletteOperations on page 215

• Importing and Linking Palettes on page 219

Palette Lists

The Colour view has two modes: basic and advanced.

• BasicMode
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The Colour view’s basic mode only shows the Colour list. When you open Toon BoomHarmony, you
only see the colours available in the Default palette which contains six basic colour swatches and is
automatically named the same as your scene. For simple projects, you canmanagewith the default
palette, but for movies, series, or shorts it is recommended that you create palettes for your characters.
To create a palette, you have to switch to the Advanced mode of the Colour view and show the Palette
list.

• AdvancedMode

The Advanced mode displays the list of all palettes that are linked to the scene. To create palettes for
your characters, youmust display the Palette list.

A palette list is a file containing all of the links to the original palette files. Every drawing layer has a palette list.
The scene also has a palette list. For example, a drawing layer can use three different palettes stored in three
different locations, while another drawing layer can use two of these palettes plus another one coming from
another scene. The palette list keep track of the locations of the palettes.

There are two types of palette lists:

• Scene Palette List

The Scene Palette list is mainly used with cut-out animation, but is also very useful for paperless and
traditional animations. A cut-out character will often be divided into 20 to 30 different drawing elements
that use the character’s master palette.

The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked
to this list will appear in every drawing element created in the scene. There is no need to manually load
the palette in each element.

The Scene Palette list is the simplest one to use. By default, Toon BoomHarmony is set to use only
Scene Palette lists.

• Element Palette List
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In Toon BoomHarmony, you can switch to Advanced Palette List mode and choose to save your palette at
an element’s level. The Element Palette list is mainly used with traditional and paperless animation. Unlike
cut-out animation, all columns (drawing elements) contain different characters, props, backgrounds, and
effects. The Element Palette list is used when you do not necessarily want all of the palettes for all of your
elements linked in every column.

The palette list is stored in the drawing element’s directory instead of directly in the Scene level. This
ensures that the links to the palettes appear only in the appropriate element. If you prefer to access a
global palette list, link your palettes to the Scene Palette list.

To prevent users from accidentally removing a link to a palette, the palette lists are locked. To link or create a
new palette, the palette list must first be unlocked.

When you are using several cloned palettes that are related to the same original palette, Toon BoomHarmony
uses the palette located highest in the list to determine the colour of the painted zones—seeCloning a Colour
Palette on page 213.

How to show or hide the Palette list

‣ In the Colour view, click the Show/Hide Palette List View button to expand or collapse the Palette
List area.

The Palette List window opens and displays all your palettes.
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How to lock and unlock to the palette list

‣ From the top menu, select Edit > Edit Palette List Mode.

A grey pencil appears on the top-right corner of the Palette list to indicate that it can bemodified.

How to set the Advanced Palette Lists mode

1. Do one of the following:

‣ From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (MacOS
X).

‣ Press Ctrl + U (Windows/Linux) or⌘ + U (MacOS X).

1. Select theAdvanced tab.

2. In the Advanced Options section, select theAdvanced Palette Lists option.

3. Click OK.

How to reorder palettes in the Palette list

Do one of the following:

‣ From the Colour View menu, select Palettes >Move Up orMove Down.

‣ In the Palette list, click the Up and Down buttons.
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Palette File Storage

In Harmony, palettes are individual *.plt files that can be copied, transferred and stored. When a palette is
created fromHarmony, it needs to be stored somewhere. By default, the palette file is stored in the scene
directory in a palette-library folder unless you specify a different location. There are four locations where you can
find palette-library folders:

l Element: The Palette Library folder is stored directly in the drawing Element folder.

l Scene: The Palette Library folder is stored directly in the Scene folder.

l Job: The Palette Library folder is stored in a Job folder contained in the Scene folder.

l Environment: The Palette Library folder is stored in an Environment folder contained in the Scene folder.

By default, the palette is stored at the scene level. For simple projects and standalone projects, it is
recommended to keep it as is. If you work with a larger studio, it is recommended to verify with them on the file
structure.

This existing structure is compatible with Harmony Server. Harmony’s database has a leveled structure starting
from the Environment down to the Element. Its client-server configuration allows all data, such as palettes and
scenes, to be shared between a series of client machines.

Element Level

Working with Harmony Stand Alone, the Element level is very useful when there are a lot of different palettes.
When a colour model drawing is created, it is stored in its element folder. By storing the corresponding palette
file with the colour model, the colourist can load them both from the same location. This also creates a more
organized structure.
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Scene Level

Working with Harmony Stand Alone, a palette file can also be saved at the scene level, so that all of the
palettes from the scene are stored together. The palette naming must be structured so the colourist or
character builders can find the correct one. Saving the palettes at the scene level makes it very easy to back up
the palettes and retrieve their location.

The scene level can also be useful for cut-out animation. Instead of creating a colour model scene that includes
all of the characters, props, effects, and location, the colour palette or model will often be directly imported
to, or created in, the character building scene. Just as with a cut-out character building scene, each element
uses the same palette so it would not be efficient to save the palette inside one element. Instead, it is saved at
the scene level. This prevents a palette overload because all of themodels are in different scenes. It also allows
each scene to have its own set of palettes corresponding to its model.

Whenworking on a cut-out animation production, it is highly recommended that you work with the Scene level.

Where to Save the Palette File

The palette storage location depends on the type of production and the backup plan being used. Some
studios like to store their palettes at the Element level and others at the Environment level as this will not
create a problem so long as the scene is in the Harmony structure. In fact, as long as the Harmony structure is
maintained it can be stored at any level. However, difficulties may occur when the scene is backed up or
transferred to another studio or database and removed from the structure.

What happens when you export a palette file?

It is important to understand what is happening to a palette file when the scene is exported.

Because of the Harmony client-server configuration, all of the data can be shared through all of the scenes in
the database. This also includes the palette files, even if they are stored at the Element, Scene, Job, Drawing
or Environment level. The palette files can be accessed from any scene of any project.

When you export scenes fromHarmony to either archive or send them to other users or studios, the palettes
stored in external scenes, jobs or environment will NOT be exported.

An exported scene will carry palettes stored in its own Element’s Palette Library, scene’s palette library, the
Job and the Environment where it is stored. Any other palette from other Environments, Jobs, Elements or
Scenes (even from the same job) willNOT follow. Instead a recovery palette will be created when the scene is
reopened in another Harmony system. A recovery palette is a local palette created by the systemwhen
palettes and colours aremissing. This palette is no longer shared with the rest of the project.

For example, in the following chart, if you export Scene 2 from Job 1, the package will carry the palettes from
Scene 2, Job 1 and Environment. ItWILL NOT carry the palettes from Element 3 in Scene 1, Scene 1 and Job 2.
If Scene 2 was linked to any of these, the systemwill create a recovery palette the next time Scene 2 is opened
in another Harmony system.
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The best place to store your palette is:

• Environment level for a movie or series

• Job level for a publicity or small project

• Scene level for a student exercise

To store your palette with their colour models, you can use the Element level, however, it will requiremore
structure when exporting the scenes. The scene will have to be exported along with its colour model scene. The
other studio you are working withmust recreate an identical structure to yours, then import the received scenes
into the same location as you have them in order to maintain the links.

Palette Backup

When sharing palettes between scenes, some users may accidentally modify the colours, even though the
palettes are locked by default. That is why it is a good idea to copy and back up your palette libraries and master
palette directories.

When a palette file is copied, it automatically becomes a clone palette, so there will not be any trouble replacing
an altered file. Harmony automatically updates all of the files and drawings linked to it.

Creating a Colour Palette

You can create a palette in either Basic or Advanced mode.
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By default, Toon BoomHarmony is set to the Basic mode. For simple productions, it is recommended to use
the Basic mode. This setting stores the palettes automatically for you and saves them at the Scene level. When
you use the Advanced Palette Lists mode, you can decide at which level you want to store your palettes:
Environment, Job, Scene, or Element.

If you are using Harmony Server, see Palette File Storage on page 205.

Before you can create a palette in the Advanced Palette Lists mode, youmust first set your preferences to
Advanced Palette Lists mode in the Preferences dialog box. You also need to have the rights to modify the
palette list. If you do not, select Edit > Edit Palette List Mode from the top menu.

You can remove palettes from your Palette list if they're not needed in your scene. The actual palette file will
not be deleted and you can reimport it in your Palette list later on.

How to set the Advanced Palette Lists mode

1. Do one of the following:

‣ From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (MacOS
X).

‣ Press Ctrl + U (Windows/Linux) or⌘ + U (MacOS X).

1. Select theAdvanced tab.

2. In the Advanced Options section, select theAdvanced Palette Lists option.

3. Click OK.

How to create a new palette (Basic Palette Lists mode)

1. From the Colour View menu, select Palettes >New or click the New Palette button.

‣ Make sure you have the necessary rights to modify the palette list. If not, select Edit > Edit Palette
List Mode.

The Create Palette window opens.

2. Enter the palette name according to themodel.

3. Click OK.

The palette appears in the drawing element’s palette list.
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How to create a palette from the Advanced Palette Lists mode

1. In the Timeline or Xsheet view, select the drawing that requires a palette.

2. Make sure that you have the necessary rights to modify the palette list. If you do not, select Edit > Edit
Palette List Mode.

3. In the Colour view, click the Show Palette List View button to display the palette list.

4. Do one of the following:

‣ From the Colour view menu, select Palettes > New.

‣ Click the Create Palette button.

The Palette Browser: Create Palette dialog box opens.

5. Select the level to store the palette file.

‣ Environment: The palette-library folder is stored in the scene's parent environment folder.

‣ Job: The palette-library folder is stored in the scene's parent job folder.

‣ Scene: The palette-library folder is stored directly in the scene folder.

‣ Element: The palette-library folder is stored directly in the drawing element folder.

When you select a level that has a palette stored in it, the palette names are displayed in the Palette field.
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6. Name the palette. There is no need to add the suffix "palette"  to the name as it is always recognized as
a palette file.

7. Select a Palette List option.

‣ The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be divided
in twenty to thirty different drawing elements that use the character's master palette.

The palette list is stored at the scene level instead of the Element directory. This way, all palettes
linked to this list will appear in every drawing element created in the scene. There is no need to
manually load the palette in each element.

‣ The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-out
animation, all columns (drawing elements) contain different characters, props, backgrounds and
effects. The Element Palette List is used because you do not necessarily want all of the palettes for
all of your elements linked in every column.

The palette list is stored in the drawing element's directory instead of directly in the Scene level. This
ensures that the links to the palettes appear only in the appropriate element. If you prefer to access
a global palette list, link your palettes to the Scene Palette List.

8. Click OK.

The new palette appears in the palette list.

How to rename a palette

1. In the Colour view, select the palette to rename.
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2. Do one of the following:

‣ Right-click and select Rename.

‣ From the Colour View menu, select Palettes > Rename.

3. In the Rename dialog box, give the palette a new name and click OK.

How to remove a palette

1. In the Colour view, select the palette to remove.

2. Do one of the following:

‣ From the Colour View menu, select Palettes > Remove.

‣ Right-click on the selected palette and select Remove.

‣ Click the Remove Palette button located above the Palette list.

If the palette was used in your scene, the zones painted with its colours turn red.

Duplicating a Colour Palette

Aduplicated palette is a simple copy of the original palette. It uses the same names, colour values, but has a
different ID and is independent from the original palette. This ensures that both palettes are completely
independent.

This option is used when there are similar models and youwant to avoid recreating and naming all the colours.
You can change the values and the names afterward without affecting the original palette. You can also keep
some RGBA values, such as the eyes, teeth, tongue, insidemouth, etc.
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How to duplicate a palette

1. In the Colour view, select the palette to be duplicated.

2. Do one of the following:

‣ From the Colour menu, select Palettes > Duplicate.

‣ Right-click on the selected palette and select Duplicate.

The Palette Browser: Duplicate Palette window opens.

3. If you are in Advanced Palette List mode, select the palette storage level—see Palette File Storage on
page 205.

4. In the New Palette Name field, name the palette.

5. In the New Palette Name field, name the palette.

6. Click OK.

The palette appears in the palette list.
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Cloning a Colour Palette

A character usually has only onemaster palette, although there are times when the characters are placed in
different lighting conditions and require a different colour shading. The night palette is a popular choice when a
scene or sequence changes from day to night. It can be difficult and time-consuming to repaint everything and
creating two independent palettes can be quite complex. As an alternative, Toon BoomHarmony provides clone
palettes.

The clone palette is a copy of themaster palette. The colours in each palette have the same properties. The
colours have the same identification number pointing to the same colour zones, but they can have different names
and RGBA values. Depending on the palette (night or day) you're currently using, the painted drawing will
update. So there's no need to repaint the animation. All you have to do is create or import a clone palette
(palette style).

How to clone a palette

1. In the Colour view, select a palette to clone.

2. From the Colour menu, select Palettes > Clone or right-click and select Clone.

The Palette Browser: Clone Palette dialog box opens.
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3. If you're in Advanced Palette List mode, select the palette storage level—see Palette File Storage on
page 205.

4. In the New Palette Name field, name the palette. We recommend keeping the "-clone" in the name.

5. Click OK.

The cloned palette appears in the palette list.

6. In the Palette list, select the clone palette you created to offset or blend colours—seeMixing Colours
on page 239.

7. From the Colour View menu, select Palettes > Tint Panel or right-click and select Tint Panel.

The Blend/Offset Tint panel opens.
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8. Select one or more colours to modify. You can select all your colours by pressing Ctrl + A (Windows/Linux)
or⌘ + A (MacOS X).

9. Offset, blend, or mix the colours using the sliders and increasing the Amount value.

10. Select the Preview option to see a preview of the colours while you adjust them.

NOTE: You can also modify the colours individually with the Colour Picker window.

Palette Operations

When you start Toon BoomHarmony connected to the database, you can access the PaletteOperations dialog
box which lets you clone, rename, or delete palettes.

How to open the Palette Operations dialog box

1. Start Harmony and log in.
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2. Close the Database Selector dialog box.

3. From the top menu, select Tools > Palette Operations.

The PaletteOperations dialog box opens.

How to clone a palette in the Palette Operations dialog box

1. Select the palette you want to clone at the location and level in which it was stored.

2. Click Clone.

AWarning dialog box opens.
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3. Select theDon't show this message again option if you do not want to see this message every time you
perform this operation.

4. Click Yes.

The Palette Browser dialog box opens.

5. Select the level to store the palette file.

6. Name the palette. There is no need to add the suffix "palette"  to the name as it is always recognized as a
palette file.

7. Select a Palette List option.

‣ The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be divided in
twenty to thirty different drawing elements that use the character's master palette.

The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked
to this list will appear in every drawing element created in the scene. There is no need to manually load
the palette in each element.

‣ The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-out
animation, all columns (drawing elements) contain different characters, props, backgrounds and
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effects. The Element Palette List is used because you do not necessarily want all of the palettes for
all of your elements linked in every column.

The palette list is stored in the drawing element's directory instead of directly in the Scene level. This
ensures that the links to the palettes appear only in the appropriate element. If you prefer to access
a global palette list, link your palettes to the Scene Palette List.

8. Click OK.

How to rename a palette in the Palette Operation dialog box

1. Select the palette you want to rename at the location and level in which it was stored.

2. Click Rename.

AWarning dialog box opens.

3. Select theDon't show this message again option if you do not want to see this message every time
you perform this operation.

4. Click Yes.

The Rename Palette dialog box opens.

5. Type in a name for the palette.
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6. Click OK.

How to delete a palette in the Palette Operation dialog box

1. Select the palette you want to delete at the location and level in which it was stored.

2. Click Delete.

AWarning dialog box opens.

3. Select theDon't show this message again option if you do not want to see this message every time you
perform this operation.

NOTE: It is not recommended to disable the warning message as deleting a palette cannot be undone.

4. Click Yes.

Importing and Linking Palettes

Before starting colouring work such as ink and paint or even creating new colour models, youmay want to load
existing colour palettes to your scene. You can do so by linking colour palettes to your palette lists.

Youmay encounter a case where only a colour palette is visible when a layer is selected. If you need that palette in
a second layer, you can link the palette to the second layer's palette list. A good example would be a scene where
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there is a character on one layer and its arm is on another. In order for both layers to access the palette, you
must link both Element Palette lists to that palette. If your palette is linked to the Scene Palette list, it will be
accessible by all layers.

If you created a palette in another project and youwant to import it in your current project, you can browse for
the palette file on your computer and add it to your scene. When the palette is imported in your scene, the file
is copied in the project’s directory. It is not linked to the original file.

Harmony lets This method is not recommended. It is always safer to have the palettes contained within the
database to avoid data loss if the source palette were to be deleted or the project exported without including
the external palettes.

You will notice that when you create or link a palette, a small icon appears on its left. These icons represent the
palette's link status.

Icon Description

Indicates that the palette is safe.

There won’t be any problems once the scene is exported. For example, the palette file is
stored in the scene folder and is linked to the Scene Palette List.

Indicates that the palette file is stored in a directory external to the scene’s structure.

The palette file is probably stored in a Master Palette directory on a hard drive external to
the palette-libraries planned for the palette storage. The warning in this case is that if you
move your Master Palette directory to another location, youmay loose the palette in your
scene.

Indicates that a palette file stored in a level such as Element, Scene, Job or Environment is
linked to a Palette list that is not on the same level.

For example, a palette file is stored into the Environment folder and is linked to the
Element Palette list. The palette is shared.

Indicates a potentially dangerous situation.

Problems may occur when trying to export or link to the palette file. For example, a palette
file is stored into the element folder and is linked to the Scene Palette list. The issue in this
case is that if you decide to delete the layer containing the palette, it will be lost from your
scene.

How to link a colour palette

1. Do one of the following:

‣ From the Colour View menu, select Palettes > Link.

‣ Right-click and select Link.

‣ Click the Import button.

The Palette Browser: Link Palette dialog box opens.
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2. Select the level where the palette file is stored—see Palette File Storage on page 205.

3. Select the palette list linking level by enabling either Scene Palette List or Element Palette List—see
Palette Lists on page 201.

The palette appears in the Colour view.

How to import a palette into your project

1. Do one of the following:

‣ From the Colour menu, select Palettes > Import.

‣ Right-click and select Import.

The Browser window opens.

2. Browse for a palette file located (*.plt) on your hard drive. You will generally find the palettes in your pro-
ject's palette-library directory.

3. Click Open.

The Palette Browser opens.
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4. If you're in Advanced Palettemode, select the level where the palette file is stored—see Palette File Stor-
age on page 205.

5. If you're in Advanced Palettemode, select the palette list linking level by enabling either Scene Palette
List or Element Palette List—see Palette Lists on page 201.

6. In the New Palette Name, name the imported palette.

The palette appears in the Colour view and the file is copied in your project.

How to link to an external palette

1. In the Colour view, click on theCreate Palette button to create a palette to be used as external.

2. Save your scene by selecting File > Save from the top menu or by clicking the Save button or press
Ctrl + S (Windows/Linux) or⌘ + S (MacOS X).

3. On your computer or server, create a master directory. Ideally, this should be created in your Root
folder to keep it within the project directory. You could also place it inside your Colour Model’s sub-
directory—seeChapter 6: Project Organization and File Structure in the Fundamentals Guide.

4. Name the folder appropriately, for example: Joe_master_palette.
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5. From your operating system, browse to your Toon BoomHarmony scene and open the palette-library
folder.

6. Select and copy your palette *.plt file to copy it to themaster palette directory.

7. Create a new Toon BoomHarmony scene or open the scene where you will link this palette.

8. In the Timeline or Xsheet view, select the element to link the palette to.

9. From the Colour View menu, select Palettes > Link to External.

The Link to External Palette dialog box opens.

10. Click Browse to search for your master palettes folder and select the palette *.plt file you want to link.

11. In the Palette list section, select how youwant to load the palette; at the scene or element level.

12. Click OK.

The linked palette appears in the Colour view.
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If a palette is outside the scene, the External icon appears beside the palette name.

NOTE: To link an element (such as a colour model) to the palette that is stored in the external palette directory,
you must remove the original palette from the element’s palette list. You will then load the duplicated palette into
the palette list using the Link to External command, like you did for the other elements.

Colours
Toon BoomHarmony has some very powerful colouring features when it comes to painting. To paint your
drawings, you will use different colour swatches, unlike some other painting programs where youmodify the
main swatch each time youwant to paint with a different colour.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You
can add as many swatches as you want. You can also rename them andmodify existing ones.

224



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

When youmodify the colour of an existing swatch, it automatically updates all the zones painted with this swatch
throughout the entire project. The colour swatch has a unique ID number that associates it with the painted
zones. This way, you can change the look of your character at any timewithout having to repaint it!

This section is divided as follows:

• Adding a Colour Swatch on page 225

• Editing Gradients and Textures on page 232

• Colour DisplayModes on page 237

• Copying and Pasting Colours on page 238

• Mixing Colours on page 239

Adding a Colour Swatch

You can use several different types of colour swatches, including solid colour, gradient colour and bitmap texture
swatches.

A colour palette is an actual file on the hard drive. These palette files can be stored in a different location on the
server. They can be stored in the Environment, Job, Scene, or Element folder and linked to any palette list. This
means that if the original palette file is modified, it will update in every drawing element the palette is linked to.

To avoid accidentally modifying the palette, the palette files can be locked. If a palettemust bemodified, you
must get the rights to modify them before doing so.

In Toon BoomHarmony, when you click the Add Colour button, a new colour swatch is created using the
colour of the currently selected swatch from your palette. However, you can set a default colour to be used every
time you create a new colour in your colour palette. This is useful for creating different shades of the same basic
colour.

The default colour is also the colour used when you choose to vectorize images you're scanning into your scene,
however you add the Default colour swatch to your palette in a different way, so it's unique. It has a unique ID
number that makes it easily recognizable from all the other colours in your colour palettes. Being able to change
this colour allows you to change the basic colour of all scanned drawings. This can be useful onmore than just an
aesthetic level as sometimes when you go to NTSC or PAL, pure colours, such as pure black, can create
problems.
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How to lock and unlock the palette list

‣ In the Colour view, click the Edit PaletteMode button.

A grey pencil icon appears in the top-right corner of the Palette list.

How to add or modify a solid colour swatch

1. In the Colour view, click the Add Colour button.

2. From the Colour View menu, select Colours > Edit or double-click on the colour swatch.

The Colour Picker window opens.

3. To set your colour, do one of the following:

‣ In the colour wheel, select a colour.

‣ Enter the HSV or RGB values in the corresponding fields. Select the R,G,B,H,S or V options to
change the look of the colour picking area.
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‣ Click the Dropper button to select any colour on your screen. It can be from the Harmony interface,
your operating system or any other open application.

You can also clickMultiWheelMode to open theMultiwheel Colour window. This displays all the picking
area styles together and also contains a picking undo list. To return to the regular Colour Picker window,
click Single WheelMode.

4. Click on the Shade Scale swatches to modify the shade of the selected colour.

5. Adjust the transparency with the Alpha slider or type the value directly in the Alpha field.
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6. Click theAdd button to add the current selected colour to the Colour Storage Library, so you can
quickly access it later.

7. Rename the colour swatch in the Colour Picker window or directly in the colour list by double-clicking on
its name.

How to change the default swatch colour for all your colour palettes

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (MacOS X).

2. In the Preferences dialog box, select theDrawing tab.

3. In the New Colour Pots section, select theCreate New Colour Pots Using the Default Colour option.
You can also click on the colour swatch beside the option to change the default colour.

How to add a new colour swatch using the default colour

‣ From the Colour View menu, select Colours > New.

A new swatch is added to your palette using the default colour swatch colour. The new swatch created
with theNew command will be named New 0.

How to create a gradient colour swatch

1. In the Colour view, select a colour to modify .

2. Do one of the following:

‣ Click the new colour and from the Colour View menu, select Colours > New.

‣ Double-click on the colour swatch.

The Colour Picker window opens.
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3. Select theGradient option.

4. Select the Linear or Radial option.

5. Adjust the Gradient arrows to modify the colours.

‣ Add extra colours by clicking between the arrows below the gradient bar. Then click on the Colour
Preview to select a colour.

‣ Pull down the arrows to remove them.

‣ Move the arrows left and right to modify the gradient distance.

NOTE: To learn how to reposition the gradient zones in your drawings, see Editing Gradients and Textures on page
232.

How to create a texture colour

1. From the Colour menu, select Colours > New Texture or click the New Texture button.

The Browser window opens.

2. Browse for a PSD or TGA bitmap file created with a third party software and click Open.

The texture is added to the colour list.
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NOTE:
To learn how to reposition the textured zones in your drawings, see Editing Gradients and Textures on page 232.

You can also replace a texture once it is painted. If you decide to make the character’s shirt wool instead of
plaid, just update the texture file in the swatch and the entire project updates. Any transformation previously
applied to the texture’s position in your drawings will be kept.

How to replace a texture swatch

1. In the Colour view, select the texture swatch that contains the bitmap texture you want to replace.

2. From the Colour View menu, select Colours > Edit Texture or double-click on the swatch.

The Browser window opens.

3. Browse for the new PSD or TGA bitmap file created in a third party software.
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4. Click Open to update the colour swatch.

How to delete a colour swatch

1. In the Colour view, select the colour swatches to delete.

2. Do one of the following:

‣ From the Colour View menu, select Colours > Delete.

‣ Click the Delete Colour button.

‣ Right-click and select Delete.

‣ Press Delete.

If the colour swatch is used in a drawing, the Delete Colour dialog box opens.

3. Click OK to delete the colours or click Cancel to abort the operation.

‣ If you delete colour swatches already in use, the zones painted with them turn red so you can easily
identify them.
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Editing Gradients and Textures

If you paint a zone with a gradient or texture colour, you can use the Edit Gradient/Texture tool to modify its
position in the zone. You canmove, scale, rotate and skew. If you want to match the colour to the animation,
set the first texture position and copy the Edit Gradient/Texture position. Whenmoving to the next drawing,
you can select the next texture and paste the previous position to continue themodifications.

If you are painting a hand-drawn animation or if your want the Brush tool and Paint tool to use your gradient’s
position, angle and scale settings instead of the default ones, you can store your own settings and reuse them
afterward.

This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawnwith
textured “brushes”. If you then paint your textured pencil line with a gradient, you can do so and then edit
both elements independently at the same time.

How to use Edit Gradient/Texture tool

1. Do one of the following:

‣ In the Tools toolbar, click the Edit Texture tool.

‣ From the Camera or Drawing View menu, select Drawing Tools > Edit Gradient/Texture.

‣ Press Shift + F3.

2. Click the gradient or texture colour to modify.

A blue selection frame surrounds the selected gradient or texture.
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3. Edit the gradient or texture by adjusting the control handles around the selection frame.

How to store gradient and texture settings

1. In the Tools toolbar, select the Select tool or press Alt + S.

2. In the Camera or Drawing view, select the gradient or texture zone to store.

3. In the Tool Properties view, click the Store Colour Gradient button.

How to use the stored gradient and texture settings

1. In the Tools toolbar, select the Brush or Paint tool.

2. In the Tool Properties view, click the Use Stored Colour Gradient button.

3. In the Camera or Drawing view, draw and paint.

How to use Pencil Editor tool to edit the texture or gradient on a pencil line

1. Do one of the following:

‣ In the Tools toolbar, select the Pencil Editor   tool.

‣ From the top menu, select Drawing > Drawing Tools > Pencil Editor.
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‣ Press Alt + W.

2. Click on the pencil line to bemodified to bring up its contour envelope.

3. Select one of the contour points around the envelope andmove its position to change the size of the
tiled texture or gradient. You can also pull directly on the lines of the contour envelope or play with the
Bezier handles of any given point in order to continue to modify the envelope form.

Expanding the width of the envelope parallel to the pencil line’s central vector will cause the tiled
texture to be stretched. Conversely, reducing the envelope’s width will cause the tiled texture to look
squashed.

Reducing the contour’s width perpendicular to the pencil line’s central vector will reduce the number of
tiles, while expanding it will increase the number of tiled images.

This editing technique does not just work on texture fills, but can also be applied to pencil lines drawn
with a textured “brush”.
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How to use Edit Gradient/Texture tool to edit the texture or gradient on a pencil line

1. Do one of the following:

‣ In the Tools toolbar, select the Edit Gradient/Texture   tool.

‣ From the top menu, select Drawing > Drawing Tools > Edit Gradient/Texture.

‣ Press Shift + F3.

2. Click on the pencil line to bemodified to bring up the editor controls.

3. The editor controls delineate a single tile in the texture. For gradients, this is less applicable. Pull on the
top of the editor controls to stretch the tiled texture throughout the length of the stroke.

As gradients are parallel to the stroke’s central vector, this will stretch the way that the gradient is
distributed in the pencil line’s envelope. The envelope still acts as a boundary for the texture or gradient.
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4. Drag the editor control perpendicular to the stroke. You will feel it glide along the strokes central vec-
tor line. This is another way to resize the texture tile. Instead of stretching or shrinking it vertically, this
motion stretches or shrinks it vertically. As gradients are parallel to the pencil line’s central vector,
stretching them vertically gives no visual result.

How to use Edit Gradient/Texture tool to edit the texture and gradient of a pencil line

1. Do one of the following:

‣ In the Tools toolbar, select the Edit Gradient/Texture   tool.

‣ From the top menu, select Drawing > Drawing Tools > Edit Gradient/Texture.

‣ Press Shift + F3.

2. Click on the pencil line to bemodified to bring up the editor controls.

3. Use the top editor controls edit the gradient.

4. Use the bottom controls edit the “brush” texture.
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Colour Display Modes

The Colour view has two displaymodes:

• List

• Swatch

You can also display the RGB values and names of your solid colour swatches instead of only the name. This
option is not available when displaying the colours in Swatchmode.

How to switch between the display modes

1. From the Colour View menu, and do one of the following:

‣ Select Colours > Swatch Mode to display the swatches.

‣ Deselect Colours > Swatch Mode to display the colour list.
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How to display the swatch colour values

‣ From the Colour View menu, select Palettes > Display Colour Values.

The solid colour swatches’ RGB values are displayed between the colour swatch and its name. The
gradient colour swatches will be identified as (gradient).

Copying and Pasting Colours

When you're creating palettes, youmay want to copy colour swatches or their values and paste them in other
palettes to save time. You can also quickly copy a colour value from a palette in your scene to a selected colour
swatch in a different palette.

You can copy a selected colour swatch and paste it as a clone. Since it produces a clone colour swatch, it is
impossible to use the Paste as Clone command in the same palette as you copied the original colour swatch
from.

If you would like to keep a reference file of some colour IDs or use themwith custom plug-ins, you can copy the
colour swatch IDs. Here is an example of colour ID: 075cf5b552401130.

‣ In the Colour view, click the Edit PaletteMode button to edit the colour list.

How to copy and paste colours

1. In the Colour view, select one or more colours to copy.

‣ In the Colour view, click the Edit PaletteMode button to edit the colour list.
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2. In the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or⌘ + C (MacOS X).

3. In the Palette list, select the palette in which you want to paste the colours.

4. From the Colour View menu, select Colours > Paste as New Colours or press Ctrl + V (Windows/Linux) or
⌘ + V (MacOS X).

‣ To paste the colour values of the copied swatch over an existing colour swatch, select Colours > Paste
Colour Values.

How to clone a colour swatch

1. In the Colour view, select the colour swatch you want to clone.

‣ In the Colour view, click the Edit PaletteMode button to edit the colour list.

2. From the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or⌘ + C (MacOS
X).

3. In the Colour view, select the colour palette you want to paste the clone into or create a new palette.

4. From the Colour View menu, select Colours > Paste as Clone.

The cloned colour swatch appears in the palette.

How to copy a colour ID

1. In the Colour view, select the colour swatch you want toget the ID from.

‣ In the Colour view, click the Edit PaletteMode button to edit the colour list.

2. From the Colour View menu, select Colours > Copy Colour ID or press Ctrl + C (Windows/Linux) or⌘ +
C (MacOS X).

3. Paste the copied value as plain text in the desired document.

Mixing Colours

If you want to modify a series of colours to blend a tint in them or offset their RGBA values, you can use the Tint
panel. You can also create palette styles, such as night and day styles.

How tomix colours

1. In the Colour view, select the palette that contains the colours you want to offset or blend.
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2. Do one of the following:

‣ From the Colour View menu, select Palettes > Tint Panel.

‣ Right-click and select Tint Panel.

The Tint Blend/Offset panel opens.

3. Select one or more colours to modify in the colour list. To select all the colours, press Ctrl + A (Win-
dows/Linux) or⌘ + A (MacOS X).

4. Select Preview option.

5. Select theOffset, Blend, orMixer option.
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Parameter Description

Offset
Offsets the selected colours by the adjustments made using the HSB and RGB
sliders. Use the Amount slider to adjust the degree of offset. Use the Alpha
slider to adjust the opacity of the selected colour.

Blend

Blends the selected colours with the colour swatch in the top-right corner. Use
the Amount slider to adjust the degree of blend. A blend of 100% turns the
selected colours into the same colour as the swatch. Adjusting the HSB and
RGB sliders affect the swatch colour, which in turn affects the selected colours
on the left. Use the Alpha slider to adjust the opacity of the swatch.

Mixer

Select a Base and Tint colour to form a third colour swatch. Use the slider just
beneath to mix the Base and Tint colours by different amounts. This will affect
themixed swatch whether it is selected or not. Select either the Tint or Base
swatch and use the HSB and RGB sliders to adjust its colour. This will affect the
mixed swatch colour, which in turn affects the selected colours on the left.

6. Click Apply.

Painting the Model
Now that you've created the colours and the palette, you're ready to paint your model.

The colour model needs to be painted in order to adjust the colours with the other elements in the production.
You can paint your model regardless of the colour RGBA and adjust them later when all the elements are
together.

Once your palette is created and your model is painted, you can import a key background and other characters
using the Import Drawings option or the Library to compare and adjust the palettes—see Sharing the Colour
Model on page 243 to learn how to import your background file.
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For paperless and cut-out animation, it's a good idea to provide a line-up template with the colour model to
show the scale ratio between the characters, props and backgrounds.

Once your colour model is completed, create a line-up template by pasting one of the production's main
characters, or even just a hand, beside the colour model to show the relative size. This allows the animator,
layout artist, or scene setup artist to retain the correct scaling throughout the entire project when setting the
elements in the scene. You can store your template in the Library.

How to paint a colour model

1. From the Drawing or Camera View menu, select View > Switch to Colour Art/Switch to Line Art or
press L.

2. Create your master colour palette—seeCreating a Colour Palette on page 207

3. Add new colours to the palette—seeAdding a Colour Swatch on page 225.

4. Select your Paint Bucket tool. We recommend the Paint Unpainted tool.

5. In the Colour view, select a colour to paint your drawing.
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6. Paint themodel by selecting colour swatches in the palette and clicking on your drawing. Note that only
closed zones will be painted. If there's a gap in your artwork, youmust close before you can paint it.

7. To separate the lines and fill zones on separated art layers, seeArt Layers on page 349.

8. Adjust the colours—seeMixing Colours on page 239.

Sharing the Colour Model
When your colour models are prepared and organized in a colour model scene, it's time to share them.

The Library is a central repository for all the data which will be reused throughout the production. It can be
accessed from any Harmony scene; if multiple users are connected to the same network, all machines can access a
central library. Thesemodels can be shared among all the users to ensure that everyone has the same set of
colours and references.

A template is a set of elements created from a Harmony scene that can be imported into other scenes. It can
contain drawings, palettes, and any other elements available in Harmony.

A colour model template is very simple to make. When a drawing is stored in the Library, the corresponding
palette is attached to it. This means that whenever the colour model is imported from the Library into the scene,
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the palette is also imported. To learnmore about libraries and templates—see the Harmony Cut-Out
Animation Guide.

NOTE: It is recommended that you add a colour model subfolder to your library.

In the Timeline view, you can create a template by selecting the drawing element's node. This contains all
drawings from the drawing element, palettes, and exposure. A template that was created by selecting the
drawing exposure contains the selected drawings, their exposures, and the palettes.

How to create a template from the Timeline view

1. In the Library, select a folder to store the template. Right-click and select Right toModify.

2. From the Timeline view, select the drawings, pegs, effects, keyframes, sounds, exposures, and nodes,
and drag them to the Library's folder. Anything that is available in the Timeline view can be stored as a
template.

The Renamewindow opens.

3. Type in a name for the template and click OK.

There is no need to save the library. Everything is automatically stored and saved as soon as it is pasted
in the library.

How to load a colour model from the Timeline or Xsheet view

1. In the Timeline or Xsheet view, select a drawing (*.tvg).

2. Bring themodel into theModel view by doing one of the following:

‣ In the Timeline view, drag the selected drawing and drop it directly in theModel view.
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‣ From theModel View menu, select Use Current Drawing as Model.

NOTE: The Use Current Drawing as Model button is not part of the default Model View toolbar. To add the Use
Current Drawing as Model button to the Model toolbar, right-click in the Model view toolbar and select Customize.
Drag the Use Current Drawing as Model button from the Available Tools column and move it to the right (Toolbar)

column. Click OK.

‣ In theModel View toolbar, click Current Drawing button.

Themodel appears in theModel view.

How to browse for a colour model drawing on your hard drive

1. Do one of the following: 

‣ In theModel View toolbar, click the Import Model button.

‣ From theModel View menu, select Import Model.

‣ Select File > Import > Colour Model.

2. In the Browser window, browse for any *.tvg drawing file on your hard drive or in the database.

3. Click Open.

Themodel appears in theModel view.

How to load the default models

1. In your scene’s folder, create a new folder and name it: models.

2. On your hard drive, copy the *.tvg drawing file you want to use as colour models in your scene.

3. Do one of the following:

‣ From theModel View menu, select LoadDefault Models.

‣ In theModel View toolbar, click the Load Default Model button.

NOTE: The Load Default Model button is not part of the default Model View toolbar. To add the Load Default Model
button to the Model toolbar, right-click in the Model view toolbar and select Customize. Drag the Load Default Model

button from the Available Tools column and move it to the right (Toolbar) column. Click OK.

How to load a single drawing from the Library view

1. In the Library view, click the template containing the drawing to import in theModel view.

2. Right-click on the template and selectOpen As Folder.
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3. In the Library view’s left side, select the template’s folder and continuing expanding its subfolders until
*.tvg files appear on the right side.

4. In the Library view’s right side, select the TVG drawing to import and drag it into theModel view.

How to load a template with multiple drawings from the Library view

1. In the Library view, find the template you want to import in theModel view.

2. In the Library view’s right side, drag the template (*.tpl file) and drop it directly in theModel view.

3. Use the Previous Model and Next Model buttons in theModel View toolbar to view all the
drawings contained in the template. This can often be the front, profile, and 3/4 views of a character.
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How to load a symbol from the Library view

1. In the Library view’s left side, select the Symbols folder.

2. In the Library view’s right side, select the symbol you want to use as a model, and drag and drop it into the
Model view.

3. Use the Previous Model  and Next Model buttons in theModel View toolbar to view all the draw-
ings contained in the template. This can often be the front, profile, and 3/4 views of a character.

How to clear a colour model

‣ In theModel View menu, select Clear Model or press Delete.

How to copy the entire model from the Model view

1. In theModel View toolbar, select the Select tool.

1. In theModel view, select your model.

2. From the top menu, select Edit > Copy DrawingObject or pressCtrl + C (Windows/Linux) or⌘ + C (Mac
OS X).
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2. In the Timeline view, make sure you have the correct layer and frame selected.

3. Select the Drawing or Camera view, then go to the top menu and select Edit > Paste DrawingObject,
or select the Timeline view and from the top menu, select Edit > Paste cells in the Timeline or pressCtrl
+ V (Windows/Linux) or⌘ + V (MacOS X).

Themodel appears in the selected view.

How to copy part of the model in the Model view

1. In theModel View toolbar, select the Cutter tool or press Alt + T.

1. In theModel view, use the Cutter tool to create a selection around the part of your model that you want
to copy.

2. From the top menu, select Edit > Copy DrawingObject or pressCtrl + C (Windows/Linux) or⌘ + C
(MacOS X).

2. In the Timeline view, make sure you have the correct layer and frame selected.

3. Do one of the following:

‣ Select the Drawing or Camera view and select Edit > Paste DrawingObject.

‣ Select the Timeline view and select Edit > Paste cells in the Timeline or press Ctrl + V
(Windows/Linux) or⌘ + V (MacOS X).

Themodel appears in the selected view.
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Chapter 4: Timing

When you create hand-drawn animation traditionally or in a paperless environment, it's important to know how
to set and modify the timing of your drawings.

In a traditional workflow, the person in charge of the digital exposure sheet reproduces the paper exposure
sheet created by the animator. In a paperless workflow, the animator creates and manages their own exposure
sheet directly in Harmony without the need for reproduction.

If you'remore of a traditional animator, you will probably work with an exposure sheet. If you're a digital
animator, youmay prefer to work with a timeline to visualize your timing. Harmony offers both.

The Xsheet view displays the digital reproduction of a traditional paper exposure sheet used in hand-drawn
animation. You can set the animation sequence's exposure and name the drawings.

The Timeline view is also used to visualize timing, and represents elements and groups of elements as layers.

You can adjust timing in both views; your choice depends on which technique you're accustomed to using.
Depending on your working style, some actions may seem preferable to do in one view instead of another. Many
of the actions you perform in the Xsheet can also be accomplished in the Timeline. This chapter will often show
both techniques. You can choose which one you prefer.

In this chapter, you will learn how to work on your drawing’s exposure and length. The exposure and animation
paths for symbols are covered in separate chapters.

NOTE: The exposure sheet is not mandatory for cut-out animation. It can be useful for creating characters and parts,
but is not really needed for animation and timing. If you plan to work with cut-out animation, you can still learn useful
tips by reviewing the section on exposure sheets.

The basic digital exposure sheet process is divided into the following steps:

Preparation
The digital exposure task is quite simple. There are very few things to prepare in order to get ready.
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Opening the Scene

The scene is generally created during a previous step, such as scanning (in a traditional animation workflow),
scene set up, digital layout, or production organization.

Using the Workspace

The person creating the exposure sheet will need only the Xsheet view to create the digital exposure sheet,
although the Timeline view may also be helpful. If you're doing paperless animation, use the Camera or
Drawing view if you want to sketch at the same time.

If you work with this layout often, you can use theWorkspaceManager to save it as a workspace,and name it
Xsheet, for example.

While drawing and animating paperless animation, you can use theWorkspaceManager to save a frequently
used layout and name it Paperless Animation, for example.

Preparing References
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To start an exposure sheet, you need to prepare your references. For traditional animation, you will need to
reproduce the animator's paper exposure sheet. If you're working remotely, the studio can scan the paper
exposure sheet using third-party software and send the digital files to be opened and viewed digitally.

In paperless animation, you will usually create an exposure sheet from the Xsheet view.The information from your
layout and posing or storyboard will help you approximate how many elements are required in the scene.

Frames
Once the references are ready, you need to set the scene length by adding the right number of frames to your
scene. You can set the global scene length from the top menu.

In the Xsheet and Timeline view, you can add and remove frames from a scene to edit its length.

How to set the scene length

1. From the top menu, select Scene > Scene Length.

The Set Scene Length dialog box opens.

2. In the Number of Frames field, enter the number of frames needed.

How to extend or reduce the scene length in the Timeline view

When you remove frames at the end of a scene to reduce the scene length in the Timeline view, the exposed
drawings and symbols are not deleted. They're still available if you extend the scene afterward.

1. In the Timeline view, drag the scene length bracket:

‣ Right: To addmore frames to your scene.

‣ Left: To reduce the number of frames in your scene.

How to add frames in the middle of a scene

You can add frames anywhere in themiddle of the scene—before or after a selection. If you select a frame row in
the Xsheet view, Harmony will add the new frames before or after the selection, depending on your choice.

1. Do one of the following:

‣ In the Xsheet view, select a frame row.
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‣ In the Timeline view, select the frame to which you want to add frames before or after.

2. Do one of the following:

‣ From the top menu, select Scene > Frame > Add Frames Before Selection or Add Frames After
Selection.

‣ In the Xsheet view, right-click and select Frames > Add Frames Before Selection or Add Frames
After Selection.

‣ In the Xsheet toolbar, click the Add Frames button to add frame after your selection.

‣ Press Ctrl + G and Ctrl + H (Windows/Linux) or⌘ + G and Ctrl + H (MacOS X).

The Add Frames dialog box opens.

3. In the Number of Frames to Add field, enter the number of frames needed in the scene.

4. Click OK.

How to add frames at the start or end of a scene

1. In the top menu, select Scene > Frames > Add Frames at Start or Add Frames at End.

The Add Frames dialog box opens.

2. In the Number of Frames to Add field, enter the number of frames needed in the scene.
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3. Click OK.

How to remove a frame or a range of frames to reduce the scene length in the Xsheet view

In the Xsheet view, you can remove any selected frame range, such as the last frame.

1. In the Xsheet view, do one of the following:

‣ Select a frame in a given column.

‣ Select a frame range by clicking the first frame’s number and then dragging the selection highlight
down to the last frame to delete.

2. To delete the selected frames, do one of the following:

‣ From the top menu, select Scene > Frame > Remove Selected Frames.

‣ Press Delete to delete the selection.

‣ Click the Remove Frames button. To remove several frame selections, click the button repeatedly.

If you selected a range of frames, theWarning dialog box may open.

3. To complete the operation:

‣ Click Yes to delete the selection.

‣ Click No to delete only the exposure in the cell and not the frames.

‣ Select theDon’t Show This Message Again option to prevent the warning message from being
displayed each time you delete a frame range.

Creating Drawings
Before filling any value or setting any timing or exposure, you need to add different drawing elements.

253



Chapter 4: Timing

Each drawing element is represented as a vertical element column in the Xsheet view and a horizontal element
layer in the Timeline view.

In Harmony, whether you work in the Timeline or Xsheet view, anymodification you do to one view will be
applied to both. You can also see your layers displayed in theNode view as nodes.

To start an exposure sheet, you will use drawing elements. Drawing elements are drawing containers. Any
image file, either bitmap or vector, will use a drawing element.

When you add a drawing element to your scene, a folder is added to the scene directory. This folder is named
the sameway as the drawing element. Its purpose is to contain all the drawings related to this element. For
example, in cut-out animation, a character can havemany heads available. All of the head drawings will be
contained in this folder, even if they are not exposed in the Timeline or the Xsheet view. There is always a
drawing container connected to a drawing element (layer, column).

NOTE: There are different element types available, such as sound and expression. A sound element contains
sound files. Expressions, Beziers, eases, 3D path, Quadmaps and Pegs are for motion purposes during the
compositing step. It's not necessary to create these types to create your exposure sheet.

You can add drawing elements from the Timeline view, Xsheet view, and the Scenemenu.

This section is divided as follows:

• Layer and ColumnConcepts on page 254

• Layer and Column Types on page 255

• Adding New Drawing Elements on page 258

• Deleting Layers and Columns on page 261

• Layer and Column Properties on page 262

• Modifying Layers and Columns on page 265

• Duplicating Layers and Columns on page 268

• Cloning Layers and Columns on page 268

• Adding an Annotation Column on page 269

• Linking External Files with Timing Columns on page 274

Layer and Column Concepts

A layer is linked to a directory, the location where all its drawings are saved. This directory has the same name
as the layer. When a name is typed in a cell ,Harmony searches the layer's directory for the corresponding
drawing to display. If there is no corresponding drawing, a new one is created.

Drawings are exposed in cells and linked to the drawings saved in the layer's directory. When you remove a
drawing from a cell, it is not displayed and still exists in the directory.

A drawing that is exposed multiple times (for example, in a walk-cycle) would be linked to the same original
drawing in the layer's directory. If youmodify, repaint, or correct the drawing, all exposed drawings with the
same name are updated simultaneously. Youmust duplicate or create a new drawing to modify a single
exposure and retain the others.
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When you create a drawing cycle, all of the repeated drawings are linked to the original files. This means that
when youmodify, repaint, or correct a drawing named “1,” all drawings named “1” are updated simultaneously.
In order to modify a drawing independently from its other exposures, youmust duplicate the drawing.

Layer and Column Types

A column is also known as a layer. There are several types of layers that you can add in the Xsheet and Timeline
view. Each layer is indicated by an icon to help you differentiate them. Some layers are represented differently in
the Xsheet view.

Drawing Layer

Themost common layer type is the drawing layer. Any time you need to create a vector drawing or import a
symbol or image, you can use a drawing layer. You can also create bitmap artwork on a drawing layer.

NOTE: Bitmap images are contained in bitmap layers.

Bitmap Layer

If you import a bitmap images (as original bitmap) in your project, they are inserted in a Bitmap layer. If you
choose to vectorize your imagewhen you import, the vectorized object will be placed on a Drawing layer.

When importing a bitmap image, you have the option of encapsulating the image in a symbol. If you place a
bitmap into a symbol, you will be able to mix vector drawings with it on the same layer.
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Camera Layer

You can only have one Camera layer at a time in the Timeline view. By default, there is no Camera layer when
you create a scene. You need to add a Camera layer when youwant to create a camera motion.

The Camera layer is not visible in the Xsheet view.

NOTE: If you want to have several cameras with different settings, you can keep adding Camera layers in your
Timeline view (however, only one will ever be visible at a time as you can only have one camera at a time in your
timeline). To switch to a different camera, select Scene > Camera and select another camera layer.

Effect Layer

To enhance the look of your scene, you can add effect layers and attach your drawings to them.

In Harmony, there is a series of effect nodes in theNode Library view.

When you select the Effect layer in the Timeline view, the effect’s parameter columns are displayed in the
Functions section of the Xsheet view.

Colour-Card Layer

The Colour-Card layer is used to add a plain colour background to a scene. By default, your scene has no
background colour and if you render it as a QuickTimemovie or image sequence, it will have a black
background.

This layer is not visible in the Xsheet view.

Group Layer

AGroup layer can be used to organize both the Timeline and Node views. You can drag and drop other layers
onto a Group layer and then collapse theGroup layer to hide these other layers from view.

If you create theGroup layer in the Timeline view, a corresponding nodewill appear in the Node view. Any
layers that you connect to theGroup layer will appear in the Group node connected to an Input and Output
port.
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Peg Layer

A Peg layer is a trajectory or motion path layer that does not contain drawings. It can be attached to any drawing
layer, cut-out puppet, or other peg layers; they will all follow the trajectory you set in the Peg layer.

When you select the Peg layer in the Timeline view, the peg’s function columns are displayed in the Functions
section of the Xsheet view.

Quadmap Layer

AQuadmap layer can be described as a deformation transformation layer that does not contain drawings. This
can be attached to any drawing layer, cut-out puppet, or even other Peg layers. They will all follow the
deformation you set in theQuadmap layer.

When you select theQuadmap layer in the Timeline view, theQuadmap’s function columns are displayed in the
Functions section of the Xsheet view.

Sound Layer

You can import sound files to add dialog and sound effects to your project. The sound layer will be added to your
Timeline and Xsheet view when you import a sound file in your scene.

In the Xsheet view, the Sound layer is a dark grey colour.
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Advanced Column Types

In the Xsheet view, you can add several advanced column types to create particular animation paths. When you
create these columns, they are not linked automatically to any particular drawing layer. You can create a
motion path using these columns and then link or unlink several drawing or peg layers to it.

Advanced column types include:

• Timing

• 3D Path

• 3D Rotation

• Bezier Curve

• Ease Curve

• Expression

• Annotation

Adding New Drawing Elements

There are different ways to add a drawing layer to your project. By default, when you create a new scene there
is one Drawing column in the Xsheet view and one corresponding Drawing layer in the Timeline view.

You can add an element for each drawing and it will appear as a column in the Xsheet view, a layer in the
Timeline view, and a node in theNode view.

How to add a drawing element from the Timeline view

1. In the Timeline view, click the Add Drawing Layer button or press Ctrl + R (Windows/Linux) or⌘ +
R (MacOS X).

The Add Drawing Layer window opens.

2. In the Name field, name your new layer.

3. Set the Line Art and Colour Art options to Vector to get a vector layer or to Bitmap to have a bitmap
layer.

4. Do one of the following:

‣ Click Add to add a first layer and keep the window open to addmore layers.

‣ Click Add and Close to add a new layer and close the window.

258



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

A new drawing layer is added to the Timeline view.

How to add a drawing element from the topmenu

1. From the top menu, select Insert > Drawing.

The Add Drawing Layer dialog box opens.

2. In the Name field, type a relevant element name and click OK.

The new drawing element appears in your scene.

How to add a drawing element from the Xsheet view

1. Do one of the following:

‣ In the Xsheet menu, select Columns > AddColumns.

‣ Click the Add Columns button.

‣ Press Shift + C.

The Add Column dialog box opens.

2. In the Name field, type a relevant element name.

3. In the Type field, select Drawing.

4. To complete the operation:

‣ Click OK to add your new layers and close the dialog box.

‣ Click Apply to add your new layers and keep the dialog box open to add column.

‣ Click Close to cancel the operation.
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The new drawing element appears in the Timeline, Xsheet and Node views—see Layer and Column
Types on page 255.

How to create a column using the advancedAddColumn dialog box

You can use the advanced Add Column dialog box to makemore file format and field size options available
when you insert a column.

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (MacOS X)
and select theAdvanced tab.

2. In the Advanced Options section, select theAdvanced ElementMode option to access the advanced
Add Column dialog box.

3. Click OK.

4. In the Xsheet menu, select Columns > AddColumn or press Shift + C.

The Add Column dialog box opens.

5. In the Name field, type the new column’s name.
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6. In the Typemenu, select the Drawing type.

7. In the Element section, select one of the following:

‣ Create New Element: Creates an independent columnwith its own drawing folder.

‣ Reuse Existing Folder: Links your column to an existing folder within the Element folder of your scene.
If you select this option, in the Folder menu, select the folder to which you want to link your new
column.

‣ Use Existing Element: Uses drawings from an existing column in the new column. Both columns will be
attached to the same set of drawings, but their timing will remain independent from one another. If you
modify one of the drawings, it will bemodified in both columns. This is the same principle as the Clone
column.

In the Namemenu, select the column to which you want to link your new column.

8. If you selected the Create New Element option:

‣ Deselect theVector option if you want your layer to contain bitmap images or enable it if you want the
layer to contain vector drawings. Most of the time, the Vector option will be enabled.

‣ If you deselected theVector option, from the Bitmap Format list, select which type of bitmap image
youwant to insert in the column. Select the SCAN type if you are planning to scan drawings using the
Toon BoomHarmony Scanmodule.

‣ If you deselected theVector option and you chose the SCAN type, from the Scan Typemenu, select
what kind of scanning you want to achieve.

‣ In the Field Chart field, when importing traditional animation, indicate the size of paper on which the
animation or background was drawn. If you are not using perforated animation paper, leave the 12
field default value as is.

9. Do one of the following:

‣ Click OK button to create the new column and close the dialog box.

‣ Click Apply to create the new column but keep the dialog box opened to create other new columns.

Deleting Layers and Columns

You can delete an element in the Timeline view or Xsheet view.

How to delete layers in the Timeline view

1. In the Timeline view, select the layers to delete.

261



Chapter 4: Timing

2. Do one of the following:

‣ In the Timeline’s Layer toolbar, click the Delete Layers button.

‣ Right-click on the selection and select Delete.

How to delete columns in the Xsheet view

1. In the Xsheet view, select the columns to be deleted by clicking on their header.

2. Do one of the following

‣ Right-click on the selection and select Delete Columns.

‣ In the Xsheet toolbar, click the Delete Columns button.

‣ Press Delete.

The ConfirmDelete dialog box opens.

‣ Select theDelete Drawing Files and Element Folder option if you want to delete the drawings and
folders linked to the selected column.

3. To complete the operation:

‣ Click OK to delete the selected layers.

‣ Click Cancel to cancel the operation.

TheWarning dialog box may open.

4. Do one of the following:

‣ Click Yes to delete all the frames from your scene.

‣ Click No to keep the frames in your scene.

‣ Select theDon’t Show This Message Again option if you do not want the dialog box to display
again in the future.

Layer and Column Properties

Each element has its own set of properties that you canmodify, including effect and peg layers.
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If you want to modify an element’s properties, you can display the properties of a selected layer in the Timeline
view or selected node in theNode view. If you're working with the Xsheet, you can display its properties as well.
You can display a layer's properties as a window or as a view of its own.

The Layer Properties editor allows you to:

• Rename the layer

• Enable or disable the layer

• Lock the layer

• Change the track colour

• Activate the onion skin preview

• Adjust the positioning and animation parameters

• Adjust many other advanced parameters

The Column Properties editor allows you to:

• Rename the layer

• Enable or disable the layer

How to display a layer's properties

1. Do one of the following:

‣ In the Layer Properties view is not part of your workspace, from the top menu, selectWindows >
Layer Properties. In the Timeline view, select a layer

‣ In the Timeline view, double-click on a layer.

‣ Press Shift + E.

‣ In the Node view, click on a node’s yellow properties button.

The properties display.
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How to display a column's properties in the Xsheet view

1. In the Xsheet view, do one of the following:

‣ Double-click on a column header.

‣ Right-click on a column header and select Column Editor.

The properties for the column are displayed.
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2. (Optional) To view additional properties, select Edit > Preferences from the top menu.

3. In the Preferences dialog box, select theAdvanced tab, then select theAdvanced ElementMode option.

4. In the Xsheet view, double-click on a column header.

Additional properties for the column are displayed.

Modifying Layers and Columns

Once you add layers and columns to your project, you canmodify their properties, names, or ordering.

You can change the order of your elements in the Timeline view and Xsheet view. When you change the order of
your elements in one view, the other one is updated.

The Element Manager window lets you add, delete or modify elements (drawing folders) in your scene. If you have
drawing folders that are not linked to a column in your scene, use the Element Manager to delete them if needed.

How to rename a layer in the Timeline view

1. In the Timeline view, double-click on the name of the layer to rename.

2. In the Name field, rename the layer and press Enter/Return.
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How to rename a layer in the Layer Properties editor

1. In the Timeline view, double-click anywhere on the layer except the layer name to rename.

The Layer Properties editor opens.

2. In the Name field, rename the layer.

3. Click Close.

How to rename a column

1. In the Xsheet view, double-click on a column name. Do not click on the drawing folder name that the
column is linked to (this also appears in the column header just below the column name).

The Drawing dialog box opens.

2. In the Name field, rename the column.

3. Click OK.

How to reorder layers in the Timeline view

1. In the Timeline view, select the layers to move.

2. Drag the selection to the new location.
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3. Do one of the following:

‣ Drop the selection on an existing layer to make it a child of another element layer.

‣ Drop it between the existing layers. Timeline layers that are located above the selection are displayed
in front it. Layers located under it in the Timeline View are displayed behind it.

How to reorder columns in the Xsheet view

1. In the Xsheet view, click on the column’s header with themiddlemouse button.

2. Drag the column to its new position.

How to use the ElementManager dialog box

‣ From the top menu, select Scene > ElementManager.

Interface Element Action

Elements Displays a list of the elements in the scene.

Delete Elements Deletes the selected elements.

Delete Elements andDirectories
Deletes the selected layer and its directories
(drawing folder).
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Interface Element Action

Add/Modify Element Use this area to add or modify an element.

Name
Type in a new name in this field to create an
element or to rename the selected element.

Vector
Select this option if the new element is a vector
drawing or if you want to enable the parameters
on the selected element in the Elements list.

Bitmap Format Lets you select the file format of the bitmap layer.

Scan Type
If you're planning to scan elements with the Toon
BoomHarmony Scanmodule, select the scan
type from the list.

Field Chart
If you're importing traditional animation, select
the size of the paper on which the animation was
drawn.

Add
Creates a new element with the current para-
meters entered in theAdd/Modify Element sec-
tion.

Modify
Applies the parameter changes made to the selec-
ted element.

Duplicating Layers and Columns

Duplicating an element provides you with a copy of the drawings and their exposure. You canmodify anything
you want in the duplicated element without affecting the original one.

How to duplicate an element

1. In the Timeline or Xsheet view, click the layer or column youwant to duplicate.

1. In the Timeline or Xsheet menu, select Drawings > Duplicate Drawings or press Alt + Shift + D.

The new duplicated layer or column appears.

Cloning Layers and Columns

Cloning a layer or column provides you with a copy of the selected element that uses the same drawings as the
original. For example, if youmodify a drawing in the cloned or original column, it is updated in both columns.

You can choose whether or not to copy the column timing to the cloned columns.

• You canmodify the column timing independently from each other, but the drawings remain linked.
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• You can copy the columns timing, so drawings and timings remain linked.

You can clone selected nodes from theNode view in the sameway.

This is useful when youwant to reuse a hand-drawn animation but have different timings.

How to clone an element

1. In the Timeline or Xsheet view, select the layer or column youwant to clone.

1. Do one of the following:

‣ From the top menu, select Edit > Clone: Drawings Only to clone only the layer or column drawings.

‣ From the Timelinemenu, select Layers > Clone Selected Layers: Drawings Only.

‣ In the Xsheet menu, select Columns: Clone Selected Columns: Drawings Only.

The new cloned layer or column appears.

Adding an Annotation Column

The annotation columns are useful for marking actions, corrections or other information related to your
animation that you want to draw or write. This way, you can print your Xsheet, take it back to your animation
table and work with the annotations.

Before you can draw in the Annotation column, youmust first activate the Enable Drawing option to activate the
Drawing mode. Pen tablet pressure sensitivity is not supported in the annotation column.

In the annotation column, you can type in your notes and relevant information, as well as draw sketches and ideas
that will be useful in producing your animation.

Typing in an annotation column is independent from the Drawing mode. You can be in either mode and the typing
will work. To learn about typing values in the Xsheet view, see Typing Exposure on page 277.

You can erase part or all of the annotation column’s text and drawn annotations. Annotations that you type in
cannot be erased using this method.

You can change the pen size and colour when you draw in the annotation column.

Whenworking with the annotation columns, it is useful to display tick marks on odd-numbered frames.
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To display the tick marks, youmust run a short script.

If you scanned your paper exposure sheet’s annotations or if you need to place some pictures or drawings in
the Annotation columns, you can easily import them.

How to add an annotation column

1. Do one of the following:

‣ In the Xsheet menu, select Columns > AddColumns.

‣ In the Xsheet toolbar, click theAddColumns button.

‣ Press Shift + C.

The Add Column dialog box opens.

2. In the Name field, type in an appropriate name.

3. From the Type list, select Annotation and click OK.

The new column appears.

How to draw in the annotation column

1. Do one of the following:

‣ In the Xsheet menu, select Annotation > Enable Drawing.
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‣ In the Annotation column header, click the icon in the upper-right corner to cycle through the icons until
the Brush icon is displayed.

The Drawing mode is enabled.

2. To draw in an Annotation column, simply use your mouse or pen tablet.

How to type in an annotation column

1. Do one of the following:

‣ In the selected cell, press Ctrl (Windows/Linux) or⌘ (MacOS X).

‣ In the selected cell, hold downCtrl + Shift + click (Windows/Linux) or⌘ + Shift + click (MacOS X).

2. In the selected cell, type the desired text.
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How to erase part of a drawn annotation using Erasingmode

1. In the annotation column header, click the icon in the upper-right corner to cycle through the icons until
the Eraser icon is displayed.

2. In the column, click and drag the cursor on top of the drawn annotation to erase parts of it.

NOTE:When using a pen on a tablet, you MUST flip your pen to the eraser side for the eraser to
work.

How to change the pen width

1. In the Xsheet menu, select Annotation > Pen Width and do one of the following:

‣ Select a pen width preset.

‣ Select Change Current to display the PenWidth dialog box. In the PenWidth field, type the
number of pixels for the pen size and click OK.

How to change the pen colour

1. In the Xsheet menu, select Annotation > Change Pen Colour.

The Select Colour dialog box opens.
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2. Choose a new colour.

3. Click OK.

How to display tick marks

1. From the top menu, selectWindows > Script Editor.

2. From the Script Editor menu, select File > New Script.

3. Type in a name for your script and click OK.

4. In the File list, select the script you created.

5. On the right side of the view, type the following script:

function display_tick_marks()

{

preferences.setBool("XSHEET_ANNOTATION_FRAME_MARKER", true);

MessageLog.trace( preferences.getBool("XSHEET_ANNOTATION_FRAME_MARKER", false));

}

6. Click Verify.

The script is verified.

7. From the Script Editor menu, select Play/Debug > Run.

A dialog box opens with your script selected in the Files column.

8. In the Functions column, select display_tick_marks and click OK.

Tick marks appear on odd frames in the Annotation column. If you do not see tick marks, close and restart
Harmony.
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How to turn off the display of tick marks

1. Follow steps 1 to 5 ofHow to display tick marks and use the following script:

{

preferences.setBool("XSHEET_ANNOTATION_FRAME_MARKER", false);

MessageLog.trace( preferences.getBool("XSHEET_ANNOTATION_FRAME_MARKER", false));

}

2. Follow steps 6 to 8.

All tick marks are removed from the Annotation column.

How to import annotation files

1. In the Xsheet view, select the first cell in the Annotation columnwhere you want the imported image to
start.

2. Do one of the following:

‣ Right-click on the cell and select Annotation > Import File.

‣ From the Xsheet menu, select Annotation > Import File.

3. Browse for the bitmap image to import.

4. Click Open.

The image appears in the Annotation column.

Linking External Files with Timing Columns

Timing columns are unique in that they can reference a source folder outside of the project folder to bring
images into the project. For example, youmay have background scenes created in a third party software that
youmight need to update in the future. By using Timing columns, you can dynamically link your backgrounds,
expose different backgrounds at different times, and have live, automatic updating capabilities.
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IMPORTANT: If the project file is moved, or if the folder that the column is linked to is moved, then dynamic linking is
broken and the images that were in that folder will disappear in Toon Boom Harmony.

How to use a Timing column

1. In the Xsheet view, click the Add Columns button.

1. In the Add Column dialog box, type in the name of the new column, then from the Typemenu, select Tim-
ing.

1. Do one of the following:

‣ Click OK if you are finished.

‣ Click Apply if you want to continue adding more columns and column types.

A peach coloured column appears in the Xsheet with the name you typed in, and for the header,
<unused>.

1. In the Node view, add a new node.

1. Open the Layer Properties editor by clicking the yellow square of the node.

1. In the Drawing tab, select the Timing Columns option.

1. In the Name field, enter the path of the folder you want to access. If you use the Browse button to locate a
folder, youmust select a file in the folder you want and then delete the dash and the suffix (for example,
background-01 should be renamed to background) from the file name in the field. If you leave the full
file name selected, Harmony will display that file for the entire duration of the scene, regardless of the con-
tents of the Timing Column field.

NOTE: This means that all the images in the folder that you are linking to are named using the naming convention
described above. If for some reason you are unable to access a certain directory, type the directory extension directly
in the path extension field at the top of the browser window.

1. In the Timing Column field, click theArrow button to create a new timing column, or select the name of the
column from the list. If you have an element directory selected in theName field, the Timing Columnwill
indicate which files are called from that element directory. Remember that the file displayed at each frame
is based on the element name, cell label, and extension. If the element is toto, the timing column is
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labeled 1, 2, and 3, and the extension is TVG, Harmony will display drawings totobody-1.tvg, toto-
body-2.tvg, and totobody-3.tvg at the selected frames.

In the Xsheet, the <unused> header changes to the name of the node in theNode view.

1. From the Extension list, select the file format of the files you want to display.

1. Click OK.

1. In the Xsheet view, in the Timing column, type the number that corresponds to the suffix of the drawing
file that you want to expose to make it appear in the Camera view.

Filling Exposure
Harmony provides different tools to fill in exposures and values, create cycles, and set increments.

This section is divided as follows:

• Filling ExposureMode on page 277

• Typing Exposure on page 277

• Holding Exposure on page 279

• Extending a Single Exposure on page 280

• Extending an Exposure Sequence on page 281

• Extending the Exposure of Previous Drawings on page 282

• Dragging Cells on page 283

• Increasing and Decreasing Exposure on page 286

• Inserting Blank Cells on page 289

• Setting the Exposure on page 290

• Filling a Selection with a Single Exposure on page 291

• Filling a Selection with a Sequence on page 292

• Filling a Selection Randomly on page 294

• Filling Empty Cells on page 295

• Deleting Exposure on page 288

• Creating Cycles on page 296

• Managing Key Exposures on page 300
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Filling Exposure Mode

In the Xsheet view, you can fill columns using two different filling modes: Overwrite or Insert. Thesemodes control
the filling behaviour. The Timeline view only uses theOverwritemode.

By default, the Xsheet view is set to Overwritemode. Adding a new value or a new value sequence overwrites
existing ones. The existing timing sequence remains in the same place and is not pushed down the column.

The Insert mode is the opposite of theOverwritemode. When you add a new value or a new value sequence over
existing ones, the new values are inserted between the old ones. The existing timing sequence is pushed down
the column.

How to switch between Overwrite and Insert modes

1. Do one of the following:

‣ In the bottom-right corner of the Xsheet view, click Overwrite/Insert.

‣ Press I.

Typing Exposure

To fill in your exposure, you can type the values directly in the Xsheet view.

If you want to type an exact drawing name or value in the Timeline view, youmust use the Parameters section of
the Timeline.
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NOTE: You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).

How to type a value in the Timeline view

1. In the Drawing Substitution field, double-click to edit the field and type the name of the drawing you
want to create.

2. Press Enter/Return to validate the value.

How to type values in the Xsheet view

1. In an Xsheet column, double-click on a cell.

2. Type a value or drawing name in the cell.

3. Press Enter/Return to move to the next cell.

278



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

4. Press Esc to exit the typing mode and return to normal mode.

Holding Exposure

Drawings in an animation project are often exposed for more than one frame. Themost common exposure of a
drawing is two frames. In the industry, this type of exposure is known as animation in double frames or animation
on twos. A drawing can also be exposed for three, four, or five cells and so on. To prevent mistakes and save
time, you can hold cells automatically as you type in the Xsheet view.

How to hold exposure

1. Do one of the following:

‣ In the Xsheet menu, select Exposure > Hold Exposure > Hold 2 Cells.

‣ In the Xsheet view, right-click and select Exposure > Set Exposure To > Set Exposure to 1, 2,3, or
Set Exposure. The settings you select will be kept from session to session. You do need to set them
every time you use Harmony.

‣ From the top menu, select Animation > Cell > Hold Exposure > the desired option.

2. Type a value or drawing name in the cell.

‣ Press Enter/Return to move on to the next cell.

‣ Press Esc to quit the typing mode.

‣ If you selected Set Exposure, the Set Exposure dialog box opens. You can hold as many cells as
needed.
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Extending a Single Exposure

Extending the exposure lets you select a cell that contains a value and pull it down to the desired frame.

How to extend a cell exposure gesturally

1. In the Xsheet view, select the red arrow in the cell’s right side. Make sure you see the drag down
cursor.

2. Pull down the selected cell to the desired frame.

NOTE: The red selection box must be visible when releasing the cursor. If not, the action is
considered cancelled.

How to extend a sequence from the topmenu

1. Do one of the following:

‣ From the top menu, select Animation > Cell > Extend Exposure.

‣ Press F5.

The Extend Exposure dialog box opens.

2. Enter the frame number you want to extend the cell to.
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Extending an Exposure Sequence

Whenworking with a sequence that contains only numbers, you can extend an exposure sequence in a similar
manner to extending a single exposure.

How to extend an exposure to create a sequence

1. In the Xsheet view, select a cell containing a number.

2. In the selected cell, click the red arrow on the cell’s right side. Make sure to see the drag down
cursor.

3. Hold down the Shift key. Make sure a plus sign (+) appears.

4. Pull down the selection box to the desired frame.

NOTE: The red selection box must be visible when releasing the cursor. If not, the action is considered
cancelled.

5. First release the Shift key, then release themouse button.
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Extending the Exposure of Previous Drawings
When drawing on a blank frame you can automatically create a new drawing and extend the timing from the
previous exposed drawing.

In the following example, a cell is selected on the timeline for creating a new drawing in image A. In image B,
the previous exposure does not extend to the new drawing, while in image C, it does.

How to extend the exposure of previous drawings

1. Open the Preferences dialog box by doing one of the following:

‣ From the top menu, select Edit > Preferences.

‣ Press Ctrl + U (Windows/Linux) or⌘ + U (MacOS X).

The Preferences dialog box opens.

2. Select the Exposure Sheet tab.
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3. In the Drawing Creation section, select the Extend Exposure of Previous Drawing option.

4. On the left side of the Timeline view, select a cell and create a new drawing.

The previous exposure automatically extends to the beginning of the new drawing.

Dragging Cells

To readjust your timing, you can drag one or more cells to a new location. You can drag a cell to any other frame
in the same column or into another column.

You can turn off the Gestural Drag mode for the Xsheet view to prevent drawings from being dragged from one
location to another. This feature does not apply to Annotation columns.

How to drag a cell to another location in the Timeline view

1. In the Timeline view, select one or more cells to move.
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2. Drag the cells to the new location.

3. Drop the selection by doing one of the following:

‣ Drop by simply releasing themouse or pen.

‣ Hold Ctrl (Windows/Linux) or⌘ (MacOS X) while dropping the selection to copy the cells. The
original cells will not bemoved.

‣ Press Shift while dropping the selection to insert them between existing frames.

How to drag a cell to another location in the Xsheet view

1. In the Xsheet view, select one or more cells.

2. In the Xsheet view, position the pointer over the small dotted area on the left side of the selected
cells.
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3. Drag the selection to any other cell in the same column or in another column.

4. Do one of the following:

‣ Drop the selection to overwrite the existing cells.

‣ Hold downCtrl (Windows/Linux) or⌘ (MacOS X) while dropping the selection to copy the cells. The
original selection will not bemoved.

‣ Press Shift while dropping the selection to insert it between existing frames.
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How to turn off the Gestural Dragmode

1. Do one of the following:

‣ In the Xsheet view, right-click and deselect theGestural DragMode option.

‣ In the Xsheet toolbar, click the Toggle Gestural DragMode button (youmay have to customize the
toolbar to display it).

The dragging pad disappears on selected cells when theGestural Drag mode is off.

Increasing and Decreasing Exposure

Once a value is entered in the Timeline or Xsheet view, you can increase and decrease its exposure.

Increasing the exposure adds onemore exposure to a selected cell; repeating this action adds an extra cell
each time. This is an efficient way to extend a drawing's exposure and is always set in Insert mode. Increasing
an exposure pushes the existing exposure forward.

Decreasing the exposure removes one exposure from a selected cell and pulls any cells following it to the
beginning of selection.

How to increase exposure

1. In the Timeline or Xsheet view, select a cell.
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2. Do one of the following:

‣ From the top menu, select Animation > Cell > Increase Exposure.

‣ In the Xsheet toolbar, click the Increase Exposure button.

‣ At the bottom-right corner of the Xsheet view, set the number of cells over which the drawing will be
exposed.

‣ Right-click and select Exposure > Increase Exposure.

‣ Press +.

How to decrease exposure

1. In the Timeline or Xsheet view, select a cell.

2. Do one of the following:

‣ From the top menu, select Animation > Cell > Decrease Exposure.

‣ In the Xsheet toolbar, click the Decrease Exposure button.

‣ At the bottom-right corner of the Xsheet view, set the number of cells over which the drawing will be
exposed.

‣ Right-click and select Exposure > Decrease Exposure.

‣ Press -.
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How to use the Clear Exposure and Pull feature

1. In the Timeline or Xsheet view, select a range of cells.

2. Do one of the following:

‣ From the top menu, select Animation > Cell > Clear Exposure and Pull.

‣ Right-click and select Exposure > Clear Exposure and Pull.

‣ In the Xsheet toolbar, click the Clear Exposure and Pull button.

The exposure is reduced by the selected number of cells.

Deleting Exposure

You can delete a drawing’s exposure in several ways. When you delete a drawing’s exposure from the Timeline
or Xsheet view, you are not deleting the actual drawing file. You can always retrieve it by typing its name again
in a cell.

You can delete the exposure in a selected cell range or delete the entire exposure of a drawing exposed over
several cells. Note that you can also delete the exposure for drawings inside a collapsed group.

How to delete selected exposures

1. In the Timeline or Xsheet view, select the exposure you want to delete.

2. Do one of the following:

‣ Right-click and select Delete.

‣ Press Delete.

How to clear the entire exposure of a drawing

1. In the Timeline or Xsheet view, select a cell of a drawing exposed over several cells.
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2. Do one of the following:

‣ From the top menu, select Animation > Cell > Clear Exposure.

‣ In the Timeline view, right-click and select Exposure > Clear Exposure.

‣ In the Xsheet toolbar, click the Clear Exposure button (youmay have to customize the toolbar to
display it).

Inserting Blank Cells

You can place an empty cell between other cells.

How to insert blank cells

1. In the Timeline or Xsheet view, select the cell in which you want to insert a blank cell.

2. Do one of the following:

‣ In the top menu, select Animation > Cell > Insert Blank Cell.

‣ Right-click on the selected cell and select Exposure > Insert Blank Cell.

‣ In the Timeline or Xsheet toolbar, click the Insert Blank Cell button (youmay have to customize the
toolbar to display it).

‣ Press Shift + J.

A blank cell is inserted.
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How to clear a selected cell range without changing the exposure and timing

1. In the Xsheet view, select a frame range to clear.

2. Right-click and select Clear.

Setting the Exposure

You can easily increase or decrease the exposure for a selected cell range.

How to set the exposure

1. In the Timeline or Xsheet view, select the cell range onwhich you want to set the exposure.
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2. Do one of the following:

‣ From the top menu, select Animation > Cell > Set Exposure to > Set Exposure to 1, 2, 3, or Set
Exposure.

‣ In the Timeline toolbar, click one of the Set Exposure buttons (youmay have to
customize the toolbar to display them).

‣ In the Xsheet view, right-click and select Exposure > Set Exposure to > Set Exposure to 1, 2, or 3, or
Set Exposure.

3. If you chose the Set Exposure option, the Set Exposure dialog box opens. Enter the number of frames you
want the drawings to display and click OK.

The new timing is displayed in the Xsheet view.

Filling a Selection with a Single Exposure

You can fill the same value over an entire selection. The selection can be over one cell, a cell range in one column, a
cell range over many columns, an entire column, or many columns. You can use numbers, words, letters, or any
alphanumeric value.
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How to fill a selection with a single exposure

1. In the Timeline or Xsheet view, select a cell range.

2. Do one of the following:

‣ From the top menu, select Animation > Cell > Fill Selection.

‣ In the Xsheet toolbar, click the Fill Selection button (youmay have to customize the toolbar to
display it).

‣ Press Ctrl + T (Windows/Linux) or⌘ + T (MacOS X)).

The Fill Selection dialog box opens.

3. In the Value field, type the desired value.

4. To insert a key exposure in the frame following the last cell in the selection, select theAddKey Expos-
ure After option. Otherwise, leave it deselected.

5. Click OK.

Filling a Selection with a Sequence

You can create a numbered sequence over a selection. The sequence can be forward, backward, single, double
or higher increment, as a cycle, and so on. The selection can be over one cell or a cell range in one column or
more or an entire column or many entire columns.
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How to fill a selection with a sequence

1. In the Timeline or Xsheet view, select a cell range.

2. Do one of the following:

‣ From the top menu, select Animation > Cell > Sequence Fill.

‣ In the Timeline view, right-click and select Exposure > Sequence Fill.

‣ In the Xsheet toolbar, click the Sequence Fill button (youmay have to customize the toolbar to
display it).

‣ Press Ctrl + M (Windows/Linux) or⌘ +M (MacOS X)).

The Sequence Fill dialog box opens.

3. In the Starting Value field, type the first number in the sequence.

4. In the Increment field, type the number by which the drawing number will increase from frame to frame. For
example, an increment of 1 gives you: 1-2-3-4; an increment of 2 gives you: 1-3-5-7; and -2 gives you
this: 8-6-4-2.
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Filling a Selection Randomly

You can fill in random values over a selection. You can give a maximum and a minimum value and create
a range for Harmony to choose the random values from. The selection can be over one cell or a cell
range in one column or more or an entire column or many entire columns.

How to fill cells randomly

1. In the Timeline or Xsheet view, select a cell range.

2. Do one of the following:

‣ Select Animation > Cell > Fill Cells Randomly.

‣ In the Xsheet view, click the Fill Cells Randomly button (youmay have to customize the toolbar
to display it).

The Fill Cells Randomly dialog box opens.
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3. In theMinimumValue field, enter the lowest acceptable value.

4. In theMaximumValue field, enter the highest acceptable value.

5. In the Hold field, choose an exposure holding value.

6. If you are applying this option to a drawing column, select theWhole Numbers option to avoid decimal
points.

7. Click OK.

Filling Empty Cells

You can fill empty cells to extend the exposure of single frame drawings to fill the range of empty cells after each
one.When creating drawings on cells that are not side-by-side, the exposure of the first drawing no longer fills
automatically. Youmust select the frame rangewhere you want your drawings to hold their exposure up to the
next drawing and use the Fill Empty Cells command.

How to fill empty cells

1. In the Timeline or Xsheet view, select a cell range.

2. Do one of the following:

‣ Right-click and select Exposure > Fill Empty Cells.

‣ From the top menu, select Animation > Cell > Fill Empty Cells.

‣ In the Timeline toolbar, click the Fill Empty Cells button.
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Each drawing in the selection is exposed in the range of empty cells that follow it.

Creating Cycles

Once you have entered a series of drawings and exposures, you can create cycles out of them in several ways.

You can loop your drawings using the following commands:

• Create Cycle

• Paste Cycle

• Paste Reverse

When you create a drawing cycle, all of the repeated drawings are linked to the same original files. This
means that when youmodify, repaint, or correct a drawing named “1” for example, all drawings named
“1” are updated simultaneously. In order to modify a drawing independently from its other exposures,
youmust duplicate the drawing.

How to create a cycle

1. In the Timeline or Xsheet view, select the cell range to loop.

2. Right-click on the selection and select Create Cycle or in the Timeline toolbar, click the Create Cycle
button (youmay have to customize the toolbar to display it).

The Create Cycle dialog box opens.
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3. Enter the number of cycles you want, including the current selection.

How to paste a cycle

1. In the Timeline or Xsheet view, select the cell range to loop.

1. From the top menu, select Edit > Copy Cell from Timeline or Xsheet or press Ctrl + C (Windows/Linux)
or⌘ + C (MacOS X).

2. In the Timeline or Xsheet view, select the cell where you want your cycles to start.

3. Do one of the following:

‣ From the top menu, select Edit > Paste Cycle.

‣ Right-click and select Paste Cycle.

‣ Press Ctrl + / (Windows/Linux) or⌘ + / (MacOS X).

The Paste Cycle dialog box opens.
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4. Do one of the following:

‣ In the Number of Cycles field, enter the number of cycles you want to paste.

‣ Increase or decrease the number of cycles you want to paste.

5. In the Cycle Typemenu, select the type of cycle you want to paste.

‣ Normal (forward): Pastes cycles as for all cycles, starting with the first cell of your selection and
ending with the last.

‣ Reverse: Pastes cycles in the reverse order of the original selection, starting with the last cell of your
selection and ending with the first one.

‣ Forward > Reverse: Pastes the first cycle in your selection as is, then the following one in reverse
order. This repeated until all cycles are pasted.

‣ Reverse > Forward: Pastes the first cycle in your selectionin reverse order, then the following one as
is. This repeated until all cycles are pasted.

6. Click OK.

NOTE: You can perform the same operation using the Paste Special dialog box. To open the Paste
Special dialog box, select Edit > Paste Special or press Ctrl + B (Windows/Linux) or⌘ + B (Mac OS
X).

How to paste a reversed cycle

1. In the Timeline or Xsheet view, select the cell range to paste in reverse order.
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2. From the top menu, select Edit > Copy Cell from Timeline or Xsheet or press Ctrl + C (Windows/Linux)
or⌘ + C (MacOS X).

3. In the Timeline or Xsheet view, select the cell where you want your cycles to start.

4. Do one of the following:

‣ From the top menu, select Edit > Paste Reverse.

‣ Right-click and select Paste Reverse.

‣ Press Ctrl + . (Windows/Linux) or⌘ + . (MacOS X).

Overwriting Exposures and Keyframes
If the area on which you are dropping a selection contains exposures and/or keyframes, they are overwritten by
the content you are selected by dragging. You can set this mode in two places: the Timeline toolbar and the
Preferences dialog box.

How to override exposure and keyframes

1. In the Timeline or Xsheet view, drag to select the drawings you want to move.

2. Do one of the following:

‣ In the Timeline toolbar, click the ToggleOverride Exposure and KeyframeDuring Drag and Drop
button (youmay have to customize the toolbar to display it).
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‣ From the top menu, select Edit > Preferences or press Ctrl + U (Windows/Linux) or⌘ + U (MacOS
X). Select the Timeline tab, then select theOverride Exposure and Keyframe DuringDrag and
Drop option.

3. Drop your selection at the desired location.

Managing Key Exposures
Before working with key exposures, it's important to understand how keyframes, exposure and key exposure
work in Harmony:

• Keyframe: A keyframe is a point in timewhere a change to the properties of the object or character
occurs. In Harmony, keyframes consist of the coordinates that determine how an entire layer and its
contents aremoved. Keyframes include these parameters: XYZ position, skew, scale, angle and pivot.

• Exposure: Exposure is a property; it is the length of time that a drawing is visible over a series of
frames. In Harmony, exposure is independent of keyframes. That is, keyframes are not linked to
drawings. Keyframes can bemoved independently from the drawing exposure.

• Key Exposure: A key exposure in Harmony is a type of exposure that forces a drawing to remain
exposed on a specific frame. If a drawing is exposed before a key exposure and you swap out that
drawing for another one, then the original drawing is retained. This preserves the key drawing. Note
that Harmony automatically sets a key exposure when you perform a drawing swap.

Adding Key Exposures

Key exposures aremainly used for swapping drawings in cut-out animation where you will have numerous
drawings for the various positions of themouth or eyes of a character for example.

If there is a particular drawing youwant to keep on a specific frame, you can set it as a key exposure. This
prevents it from be overwritten by a drawing swap on a preceding frame. A key exposure is simply a property
of an exposure that forces it to be exposed on a certain frame regardless of whether the previous exposure is
the same drawing or not.

NOTE: Keep in mind that if you modify the artwork in a drawing, all instances of that drawing will be automatically
updated even if set as a key exposure. This keeps your existing animation key poses intact. It is frequently used on
a mouth or eyes layer.

Example: Swapping a drawing with no key exposure
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In the following example, drawing 3 (DR 3) is selected on the timeline and it contains no key exposure.

When it is swapped for drawing 4 (DR 4), the entire duration of drawing 3 substituted for drawing 4.

Example: Swapping a drawing with a key exposure

Here's what happens when swapping a drawing with a key exposure. In the following example, the playhead is
positioned in themiddle of drawing 5 (DR 5) to set the position for the new key exposure. When the new key
exposure is added, drawing 5 is split in two; both halves contain drawing 5. Now if you swap the first drawing 5
for drawing 1, the second drawing 5 retains its exposure.

How to add a key exposure

1. In the Timeline view, select the drawing cell to set as the key exposure.

2. Do one of the following:In the Timeline toolbar, click the Add Key Exposure button.

‣ In the Timeline toolbar, click the Add Key Exposure button.

‣ In the Timelinemenu, select Exposure > AddKey Exposure.

‣ Right-click and select Exposure > Add Key Exposure.

A new key exposure is added. 
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If you added a key exposure at the beginning of the drawing, the entire exposure is filled with that same
drawing. If you added a key exposure anywhere other than the beginning of the drawing, then the
drawing is split in two and both parts contain the same drawing.

Removing Key Exposures

When you no know longer need a key exposure, you can remove it. When you do this, the existing key
exposure is replaced by the preceding exposure. In the following example, a key exposure is set to drawing 1
(DR 1). When the key exposure is removed, the exposure is replaced by the preceding exposure, drawing 4
(DR 4).

How to remove a key exposure

1. In the Timeline view, select a key exposure to remove.

2. Do one of the following:

‣ In the Timeline toolbar, click the Remove Key Exposure button.

‣ In the Timelinemenu, select Exposure > Remove Key Exposure.

‣ Right-click and select Exposure > Remove Key Exposure.

The key exposure is removed and replaced by the preceding exposure.

Removing Duplicate Key Exposures

Whenworking with drawings to adjust the timing of a mouth in a lipsync, for example, and forcing the use of
specific key exposures, unnecessary key exposures will be created. You can delete these duplicates without
affecting the rest of the drawing. The first drawing of the selection will be used for the range.

NOTE: Duplicate key exposures may occur when pasting with the Enforce Key Exposure option selected.

How to remove duplicate key exposures

1. In the Timeline view, select the layer that contains duplicate key exposures.
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2. In the Timeline toolbar, click the RemoveDuplicate Key Exposure button (youmay have to customize
the toolbar to display it).

Pasting Key Exposures Using Different Modes

As you animate, you will find that you reuse key exposures. There are different options to paste your selected
drawings when they contain key exposures:

• Enforce Key Exposure: If there are key exposures that exist on copied drawings, they are preserved when
pasting. No key exposures are added. This is the default behavior when pasting.

• Fill Gapwith Previous Drawing: Fills selected area in the Xsheet or Timeline view with the previous
drawing.

• Fill to Next Key Exposure: Fills selected area till the next key exposure.

How to paste using different modes

1. In the Timeline or Xsheet view, select the drawings you want to copy and press Ctrl + C (Windows/Linux)
or⌘ + C (MacOS X).

2. In the Timeline or Xsheet view, select the cell where you want your pasted selection to start.

3. Do one of the following:

‣ Press Ctrl + B (Windows/Linux) or⌘ + B (MacOS X).

The Paste Special dialog box opens.
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‣ From the Timelinemenu, select Edit > Modify Paste Presets > Exposure.

The Edit Exposure Paste Preset dialog box opens.
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4. Select the Enforce Key Exposure or Fill to Next Key Exposure option. In the Paste Special dialog box,
these options are on the Basic tab.

5. Click OK.

6. Press Ctrl + V (Windows/Linux) or⌘ + V (MacOS X) to paste your selection.

Navigating between Frames and Columns
Once a cell is selected in the Timeline or Xsheet view, you can navigate between the drawings, frames, and layers
using keyboard shortcuts that work in the Camera, Drawing, Xsheet and Timeline views.

You can navigate through:

• Drawings

• Frames

• Columns

How to navigate through drawings, frames and columns

1. In the Timeline or Xsheet view, select a cell.

2. Once the cell is selected, you can navigate between:

‣ Previous and next layers: From the top menu, select Drawing > Previous Layer andNext Layer or
press H and J.

‣ Previous and next drawings: From the top menu, select Drawing > Previous Drawing andNext
Drawing or press F and G.
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‣ Previous and next frames: From the top menu, select Play > Previous Frame andNext Frame or
press comma (,) and period (.).

Managing Drawings
Drawings that are created in Toon BoomHarmony are not stored in their cells. They are actual files stored in
the project’s folder. If you want to rename a drawing or delete a drawing from your project, you need to edit
the file and not the cells.

This section is divided as follows:

• Renaming a Drawing on page 306

• Deleting a Drawing on page 308

• Duplicating a Drawing on page 309

• Copying and Pasting Drawings on page 309

• Merging Drawings on page 311

Renaming a Drawing

To rename a drawing, you need to select the drawing cell and use the RenameDrawing command.

How to rename a drawing

1. In the Timeline or Xsheet view, select the drawing to rename.
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2. Do one of the following:

‣ Right-click and select Drawings > Rename Drawing.

‣ In the Timeline toolbar, click the RenameDrawing button (youmay have to customize the toolbar
to display it).

‣ Press Ctrl + D (Windows/Linux) or⌘ + D (MacOS X).

The RenameDrawing dialog box opens.

3. In the New Name field, type in the new drawing name.

How to rename a drawing sequence with a prefix

You can rename a drawing sequence with a prefix, which can be quite useful for cut-out puppet breakdown and
deformation animation.

1. In the Timeline or Xsheet view, select a drawing sequence. Note that you can only select a drawing range in
one column or layer at a time.

2. Right-click and select Drawings > Rename Drawingwith Prefix.

The RenameDrawing with Prefix dialog box opens.

3. In the Prefix to Add field, type the prefix to add before the drawing name.

How to rename drawings by their frame position

You can rename a series of drawings relative to their frame position. This is useful in hand-drawn animation.

1. In the Timeline or Xsheet view, select the drawing sequence to rename.

307



Chapter 4: Timing Extending the Exposure of Previous Drawings

2. From the top menu, select Drawing > Rename by Frame.

Deleting a Drawing

You can permanently delete a drawing file from a project's folder.

NOTE: Deleting a drawing file is an operation that cannot be undone.

How to delete a drawing

1. In the Timeline or Xsheet view, select the drawings to delete.

2. Do one of the following:

‣ From the top menu, select Drawing > Delete SelectedDrawings.

‣ Right-click and select Drawings > Delete SelectedDrawings.
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Duplicating a Drawing

If you want to modify a drawing that already exists, but keep the original drawing intact, you can duplicate the
drawing and work on the copy. When duplicating a drawing, the selected cell is replaced with the new drawing.
The exposure of the original drawing that was on the current cell is removed. The original drawing is not deleted
from the project folder or other cells in which it is exposed.

With Toon BoomHarmony, you can create a keyframe at the same time as you duplicate your drawing. This way,
you canmodify and reposition drawings without affecting the original drawing.

How to duplicate a drawing

1. In the Timeline or Xsheet view, select the drawing to duplicate.

2. Do one of the following:

‣ From the top menu, select Drawing > Duplicate Drawings.

‣ Right-click and select Drawings > Duplicate Drawings.

‣ In the Xsheet toolbar, click the Duplicate Drawing button.

‣ Press Alt + Shift + D.

Copying and Pasting Drawings

When you copy and paste a selection in the Timeline or Xsheet view, you are not copying and pasting the actual
drawings, you are pasting the exposure. Exposure is a property; it is the length of time that a drawing is visible
over a series of frames. In Harmony, exposure is independent of keyframes. That is, keyframes are not linked to
drawings. Keyframes can bemoved independently from the drawing exposure.

If you want to copy and paste selected drawings into a different layer or paste the selection in the same layer to
duplicate the drawings, youmust use the Paste Special feature.

There are four different ways to paste your selected drawings with the Paste Special dialog box:

Never create drawing files: When adding exposures to a drawing layer, drawing files will not be
created.

Only create drawing files when they do not exist: When adding exposures to a drawing layer,
new drawings will be created only when drawings with the same name do not already exist in the
destination.
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Replace existing drawings. Create drawing files when they do not exist: Replace drawings
with the same names to update a scene with new modified drawings and preserve the animation.

Tip: If you don't want to lose the existing animation when pasting a template, such
as when placing new drawings after the animation, then delete the template's
animation. It will still have updated the drawings but not override the existing
animation.

Always create drawing files: When adding exposures to a drawing layer, new drawings will
always be created. If drawing files with the same name already exist, Harmony will create a new
name for the drawing.

If you want to perform another Paste Special operation using the same settings you used previously, you can
use the Paste Special Again command instead. You can paste your selection using the same settings as in the
most recent Paste Special operation, without opening the Paste Special dialog box.

How to paste drawings with the Paste Special command

1. In the Timeline or Xsheet view, select the drawings to copy and press Ctrl + C (Windows/Linux) or⌘ +
C (MacOS X).

2. In the Timeline or Xsheet view, select the cell where you want your pasted selection to start.

3. Do one of the following:

‣ Right-click and select Paste Special.

‣ From the top menu, select Edit > Paste Special.

‣ In the Xsheet or Timeline toolbar, click the Paste Special button (youmay need to customize the
toolbar to display it).

‣ Press Ctrl + B (Windows/Linux) or⌘ + B (MacOS X).

The Paste Special dialog box opens.
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4. Select the Basic tab.

5. In the Drawings section, select theAlways Create Drawings orOnly Create Drawings When They Do
Not Exist option.

How to paste new drawings with the previous Paste Special settings

1. Do one of the following:

‣ From the top menu, select Edit > Paste Special Again.

‣ Right-click and select Paste Special Again

‣ In the Timeline or Xsheet toolbar, click the Paste Special Again button (youmay have to customize
the toolbar to display it).

‣ Press Ctrl + Shift + B (Windows/Linux) or⌘ + Shift + B (MacOS X).

Merging Drawings
There are two methods of merging drawings.
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• You canmerge selected drawings in adjacent elements. The columns and layers will be left intact, and
each new merged drawing will reside in the frames of the left-most column or lower layer.

• You canmerge elements. All drawings will bemerged. Unused columns and layers will be deleted, but
the original drawing files are still accessible.

How tomerge selected drawings

1. In the Xsheet view, select the drawings to merge.

2. Do one of the following:

‣ In the Xsheet menu, select Columns> Merge SelectedDrawings.

‣ In the Timelinemenu, select Layers > Merge SelectedDrawings.

312



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

3. Do one of the following:

‣ In the Xsheet menu, select Columns > Merge Selected Columns.

‣ In the Timelinemenu, select Layers > Merge Selected Layers.

In the Xsheet view, the right-most columnwill contain themerged drawings and the remaining columns will be left
blank at the corresponding frames. In the Timeline view, the bottom timeline layer will contain themerged
drawings from all layers and the other layers will be left blank at the corresponding frames. Drawings are not
deleted and are still accessible.

How tomerge drawings in entire layers or columns

1. Do one of the following:

‣ In the Timeline view, select the layers you want to merge.

‣ In the Xsheet view, Shift-click the headers of the columns you want to merge.

2. Do one of the following:

‣ In the top menu, select Edit > Merge.

313



Chapter 4: Timing Extending the Exposure of Previous Drawings

‣ In the Xsheet menu, select Columns > Merge Selected Columns.

‣ In the Timelinemenu, select Layers > Merge Selected Layers.

In the Xsheet view, the right-most columnwill contain themerged drawings and the other columns will
be deleted. In the Timeline view, the bottom timeline layer will contain themerged drawings from all
layers and the other layers will be deleted. Drawings are not deleted and are still accessible.

Modifying the Layer and Column Display

You can change the way a column in the Xsheet view displays. You can change the way a layer in the Timeline
view or a column in the Xsheet view displays. You can stay organized without changing the content of elements
or your animation output.

This section is divided as follows:

• Expanding and Collapsing Layers and Columns on page 314

• Showing or Hiding Layers on page 315

• Showing and Hiding Columns on page 317

• Modifying the Look of the Column on page 320

• Xsheet Thumbnails on page 325

• Changing the Colour of a Layer or Column on page 326

• Setting SceneMarkers on page 327

• Setting Tempo Markers on page 330

Expanding and Collapsing Layers and Columns

To simplify the look of the Timeline or Xsheet view, you can expand and collapse the layers and columns. If
some layers are parented to other ones, you can collapse the parent layer to hide its children.

How to collapse or expand selected layers in the Timeline view

1. In the Timeline view, select the layer(s) to collapse or expand.

2. Do one of the following:
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‣ Right-click on the selection and select Collapse/Expand > Collapse/Expand.

‣ Click the Expand Children Arrow button on the parent layer.

‣ Click the Collapse/Expand button (youmay have to customize the toolbar to display it).

‣ Press Ctrl + I (Windows/Linux) or⌘ + I (MacOS X).

How to collapse or expand all layers in the Timeline view

1. Do one of the following:

‣ Right-click on the layers and select Collapse/Expand > ExpandAll or Collapse All.

‣ In the Timeline toolbar, click the Collapse All or Expand All buttons (youmay have to
customize the toolbar to display them).

‣ Press 0 and 9.

How to collapse and expand 3D path or rotation columns in the Xsheet view

1. In the Xsheet toolbar, click the Show Column List button to display the Functions list.

2. In the Xsheet view, select the column header of the 3D path or 3D rotation column to collapse or expand.

3. Do one of the following:

‣ Right-click on the column’s header and select Expand/Collapse > Collapse Selection or Expand
Selection.

‣ In the Xsheet toolbar, click the Collapse Selection or Expand Selection buttons (youmay have
to customize the toolbar to display it).

How to collapse or expand all 3D path and 3D rotation columns in the Xsheet view

Do one of the following:

‣ Right-click on any column’s header and select Expand/Collapse > ExpandAll or Collapse All.

‣ Press 0 and 9.

‣ In the Xsheet toolbar, click the Collapse All or Expand All buttons (youmay have to customize
the toolbar to display it).

Showing or Hiding Layers

As youwork in the Drawing or Camera view, some layers may be in the way or are used as references. You can
hide these layers to make your work area less cluttered and easier to navigate. You can show and hide layers in
the Timeline view in several different ways.

When using the Solo mode to show or hide layers, here's how it works:

• If you have anything selected, it is not affected.
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• Whenmultiple layers are selected and you enable/disable the Solo mode on any of those layers, it is
applied to all the selected layers.

• Whenmultiple layers are selected and you enable/disable the Solo mode on layers that are not part of
the selection, it is applied only to those particular layers.

When exporting or rendering a scene, the Solo mode setting of layers is ignored.

NOTE:
When a layer is affected by an inverted cutter, enabling the Solo mode for this layer will not show it unless the
mask is also enabled.

How to show or hide all layers

1. Click one of the following in the Layers toolbar:

‣ Enable/Disable All button to show or hide all layers.

Any hidden layers are unhidden, so you can view all layers.

‣ Solo Mode button to view disable your current Solo mode selection. Any soloed drawing or
sound layers are disabled, so you can view all layers. When you click again on the Solo Mode button,
you last Solo selection is displayed.

How to show or hide individual layers

1. Do one of the following:

‣ In the Layer toolbar, click the Solo Mode button.

‣ Click the layer's Enable/Disable All button to show or hide that layer.

‣ Press A to show a layer or D to hide selected layers.

‣ In the Timeline toolbar, click the Enable/Disable button (youmay have to customize the toolbar
to display it).

When you deselect a layer in the Timeline view, the corresponding column is hidden in the Xsheet view.

How to enable the selected layer and disable all others

1. Do one of the following:

‣ Hold downAlt and click the Solo Mode button of the layer you want to solo and hide all other
layers.

316



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

‣ In the Timeline toolbar, click the Disable All Others button (youmay have to customize the toolbar
to display it).

In the Timeline view, you can hide or show certain types of layers such as Group and Effect.

How to show and hide layer types in the Timeline view

1. Do one of the following:

‣ From the Timelinemenu, select View > Show > Show Manager.

‣ You can also select View > Show > Show Sounds, Show Effects or Show Groups to immediately
show or hide the selected type. This option will remain only for the current session. When you close and
reopen Harmony, the default settings will return.

The Show Manager dialog box opens.

2. Select the types of layers you want to display and deselect the ones you want to turn off.

3. Click Set As Default to make these new settings the default ones that will be used each time to start the
application. Click Restore Default to restore the settings used when installing the application.

In the Xsheet view, you have the choice of hiding or showing certain types of columns such as Annotation
and Functions.

Showing and Hiding Columns

The Xsheet view has a Column List section that displays all the columns contained in the exposure sheet. It can be
used to hide individual columns.

If you need to see a column after it has been hidden, you can display it directly from the Xsheet view without using
the Column List section.

You can also hide a column type, such as Drawing or Sound. When you do this, its corresponding layer is disabled
in the Timeline view.

How to show or hide columns in the Xsheet view

1. In the Xsheet toolbar, click the Show Column List button.

2. On the right side of the Functions section, click the Expand button to display the Column List section.

3. Do one of the following:

‣ In the Column List section, select the columns to display and deselect the columns to hide.

‣ In the Xsheet toolbar, click the Hide Selected Column button (youmay have to customize the
toolbar to display it).
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How to show a hidden column in the Xsheet view

1. In the Xsheet menu, click on the thick grey line that represents a hidden column. You can also right-click
on the column header and select Show Hidden Columns.

The Show Hidden Columns dialog box opens.

2. In the Show column, select the hidden columns you want to display in the Xsheet view.

‣ Click Check to select all the selected columns.

‣ Click Uncheck to deselect all selected columns.

How to show all columns

‣ In the Xsheet menu, select View > Unhide All Columns.

How to show and hide column types

1. In the Xsheet view, select View > Column Types Manager.

The Column Types dialog box opens.
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2. Select the types of columns you want to display and disable the ones you want to hide.

3. Click Set As Default if you want to make these new settings the default ones that will be used each time to
start the application.

4. Click Restore Default if you want to restore the settings used when installing the application.

How to show or hide Xsheet columns using the Column List

1. In the Xsheet toolbar, click the Show Column List button.

2. On the right side of the Functions section, click the Expand button to display the Column List section.

3. In the Column List section, select the columns to display and deselect the columns to hide.

How to show or hide an Xsheet column type using the Column List

1. In the Column List section, click the button corresponding to the column type youwant to show or hide.

Column Type Action

Show/Hide All Columns

Show/Hide Drawing Columns

Show/Hide Function Columns

Show/Hide 3D Path Columns
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Show/Hide 3D Rotation Columns

Show/Hide Sound Columns

Show/Hide Annotation Columns

How to show or hide function columns on the left side of the Xsheet view

1. Right-click on a column and select Tag > Function Columns Visible or Function Columns Invisible.

Modifying the Look of the Column

In Harmony, you canmodify the way the column displays drawings, empty cells and the columnwidth.

You canmodify the following elements:

• Empty cells

• Row units

• Held exposure

• Columnwidth

How tomodify the look of empty cell

1. From the Xsheet menu, select View > Empty Cells > With an “X” or Blank.

How tomodify row units

1. From the Xsheet menu, select View > Row Units > Frames or Feet.
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How tomodify the look of a held exposure

1. In the Xsheet menu, select View > Held Exposures > Line or Value.

How tomodify column width

1. In the Xsheet view, select any column to modify the width.

2. From the Xsheet menu, select View > Set Columns Width.

The Xsheet ColumnWidth dialog box opens.

3. In the ColumnWidth field, enter the desired width in pixels.

4. Do one of the following:

‣ Click OK to validate and close the dialog box.

‣ Click Apply to validate the operation and keep the dialog box opened to adjust the next column’s
width.

‣ Click Set As Default to create all the new columns to this width.

‣ Click Close to cancel the operation.

5. To restore all columns to the default value, in the Xsheet menu, select View > All Columns to Default
Width.

Drawing Identification

In the Xsheet view, you can identify drawings as Key, Breakdown or In-between. This helps to keep the Xsheet well
organized while animating.

Whenworking with several animators, directors or even other studios, the necessity for retakes will often arise.
Harmony gives you the possibility to mark new drawings as either Retake Key, Retake Breakdown, or Retake In-
betweens.

If your production requires you to mark drawings with a custommarker, you also have the option to create your
own.

Make custommarks for the Xsheet by creating your own icons, then cutting, pasting and changing a bit of code.
Not only is it possible to have your custommark appear in the Xsheet andMark Drawing toolbars, but also in the
Onion Skin and Flip toolbars.
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NOTE: You can create custom shortcuts for the Drawing Identification options in the Preferences dialog box.

Key Drawing

A key drawing is a visually significant pose in a movement, often an extreme position. For example, if a
character that is sitting down falls on his back, the key poses would be the character sitting and the character
on his back. Of course, it may vary from one animation to another.
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Breakdown Drawing

Abreakdown drawing is a pose somewhere between two key poses that better shows themovement. Most
animationmoves are arcs, such as an armwaving, somebody bending, or a leg walking. All of thesemovements
are rotations. The breakdown pose is used to describe this curve better.

The breakdown drawing is then used to indicate secondary poses, also called the follow-through. These actions
can be a big stomach jiggle as somebody jumps, a cloak floating behind somebody that is running, or arms
moving after themain body action. Thesemoves will generally have a different timing than the primary action.
They will mainly start later and finish later. So, the breakdown drawings are used to complete the key drawings.

Note that a breakdown drawing is not always placed exactly in themiddle of two keys. It will often be closer to
one or the other depending on the timing and the action. Also, you can havemore than one breakdown pose
between two keys.

How tomark a drawing as Key, Breakdown or In-between

1. From the top menu, selectWindows > Toolbars > Mark Drawing.

TheMark Drawing toolbar displays.

2. In the Xsheet view, select the cell you want to identify. This option is not available in the Timeline view.

3. In theMark Drawing toolbar, click one of these buttons: Mark as Key Drawing  , Mark as Breakdown
Drawing   or Mark as In-betweenDrawing  . In the Xsheet menu, you can also select Drawing > Mark
Drawing As > Key Drawing, Breakdown Drawing, In-between Drawing, Retake Key, Retake BD and
Retake IB.

‣ If you selectedMark as Key Drawing, a icon appears in the cell.

‣ If you selectedMark as BreakdownDrawing, a icon appears in the cell.

‣ If you selectedMark as In-BetweenDrawing, there is no icon displayed in the cell since it is used to
remove a Key or Breakdownmarker.
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How to create custom markers

1. With a bitmap editing software, create the following icons in PNG format:

‣ Mark Drawing Toolbar icon (24 x 24 pixel)

‣ Onion Skin Toolbar icon (24 x 24 pixel)

‣ Flip Toolbar icon (24 x 24 pixel)

‣ Xsheet Column icon (16 x 16 pixel)

2. Close Harmony.

3. When your icons are ready, open the Toon BoomHarmony drawingTypes.d folder.

In Harmony Server, the path is global for all users so youmust create the folder and place in /USA_DB.

‣ /USA_DB/drawingTypes.d

NOTE:
If the drawingTypes.d folder does not exist, you must create it. To do so, copy the resources
folder from the following location.

• Windows: Start > Programs > Harmony 12.1 Premium
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• Mac OS X: Applications > Toon BoomHarmony 12.1Premium > resources >
drawingTypes.d

• Linux: /usr/local/ToonBoomAnimation/harmony_12/lnx86_
64/bin/Stage/resources/drawingTypes.d

4. Paste your icons in the drawingTypes.d directory.

5. In the same directory, open the drawingTypes.xml file in a text editor.

6. For each custom icon you want to create, add the following line. Make sure to place it before this closing
tag: </DrawingTypes>.

‣ <DrawingType text="NewButtonName" pixmapFile="XsheetIcon.png"
commandIcon="MarkDrawingIcon.png" flipIcon="FlipIcon.png" onionIcon="OnionIcon.png" />

7. In that line, replace the following information with your new icon information:

‣ NewButtonName: Write the name of your new marker. This namewill appear in the button tooltip.

‣ XsheetIcon.png: Write the name of the icon that you created to appear in the Xsheet column. Include
the file extension.

‣ MarkDrawingIcon.png: Write the name of the icon that you created to appear in theMark Drawing
toolbar. Include the file extension.

‣ FlipIcon.png: Write the name of the icon that you created to appear in the Flip toolbar. Include the file
extension.

‣ OnionIcon.png: Write the name of the icon that you created to appear in theOnion Skin toolbar.
Include the file extension.

8. Save the file and close it.

9. Start Harmony.

Xsheet Thumbnails

When there are a large number of columns in the exposure sheet, it's not easy to quickly identify a particular
column. Displaying the column thumbnails makes this easier. This option displays a small thumbnail picture of the
current frame below the column header.

How to display the thumbnails

1. Do one of the following:

‣ In the Xsheet toolbar, click the Show Thumbnails button.

‣ In the Xsheet menu, select View > Show Thumbnails.

The thumbnails appear.
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Changing the Colour of a Layer or Column

To easily identify elements in the Timeline or Xsheet view, you can change the colour of layers and columns. The
colours you choose will be reflected in theNode view.

How to change the layer’s colour in the Timeline view

1. In the Timeline view, click the Change Track Colour button of the layer you want to modify.

2. In the Select Colour dialog box, select a new colour for your layer.

3. Click OK.

The layer’s background colour is updated. In a Drawing layer, exposed cells are the brighter, selected
colour for easy identification. The corresponding column colour is also updated in the Xsheet.

How to reset a layer’s colour in the Timeline view

1. In the Timeline view, select the layers to reset.

2. In the Timeline toolbar, click the Default Track Colour button (youmay have to customize the tool-
bar to display it).
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How to change a column’s colour in the Xsheet view

1. In the Xsheet view, select one or more columns to modify.

2. Right-click on the column’s header and select Colour > Change Columns Colour.

3. In the Select Colour dialog box, select a new colour for your columns.

4. Click OK.

The column’s colour is updated. The corresponding column colour is also updated.

How to reset the column’s colour in the Xsheet view

1. In the Xsheet view, select the columns to reset.

2. Right-click on the column’s header and select Colour > Default Columns Colour.

Setting Scene Markers

Scenemarkers are visual indicators displayed at the top of the Timeline view in the frame counter area. You can
use it to denote anything relevant to your work. You can indicate the frames you want to clean up, a change in
action, an impact, or where you intend to apply an effect. You can also add a note to a scenemarker, which is
displayed when you hover over the scenemarker.

There are two ways to add a scenemarker. You canmark the current frame or make a frame range selection and
mark the whole section.
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How tomark the current frame

1. In the Timeline view, make sure the red playhead is set on the frame youwant to mark. Even if you right-
click on a different frame, the scenemarker will be created on the current frame onwhich the playhead is
positioned.

2. Right-click in the frame counter area and select Scene Markers > Mark Current Frame.

The Timeline SceneMarker dialog box opens. The Colour box displays a black colour swatch, or the
colour of the last scenemarker you created.

3. Click the Colour swatch to open theMark Colour dialog box and select a colour for the scenemarker.
Click OK.

4. In the Note field, enter text to display as the tooltip and click OK.

In the Timeline view, the scenemarker is displayed at the current frame.
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5. Hover over the scenemarker to display its tooltip.

How to create a scene marker on a frame range

1. In the frame counter area of the Timeline view, select the frame range youwant to mark.

The Timeline SceneMarker dialog box opens. The Colour box displays a black colour swatch, or the colour
of the last scenemarker you created.

2. Click the Colour swatch to open theMark Colour dialog box and select a colour for the scenemarker.
Click OK.

3. In the Note field, enter text to display as the tooltip and click OK.

In the Timeline view, the scenemarker is displayed over the selected frame counters.

4. Hover over the scenemarker to display its tooltip.
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How to edit a scene marker

NOTE: If you select only a part of a scene marker, you will not open the scene marker for editing. You will only be
able to create a new scene marker to overwrite it.

1. In the Timeline view frame counter, select the entire scenemarker.

2. Right-click the selection and select Scene Markers > Edit Scene Marker.

The Timeline SceneMarker dialog box opens.

3. Make your changes.

4. Click OK.

How to delete a scene marker

1. In the Timeline view frame counter, at least one frame counter in the scenemarker you want to delete.

2. Right-click the selection and select Scene Markers > Delete Scene Marker.

Setting Tempo Markers
Tempo markers are used to synchronize your animation with a musical score. This lets you reproduce the FPB
(Frames Per Beat) and use the tempo signature as tempo markers. The Xsheet view allows you to pace your
animation according to the tempo or beat of the soundtrack music or to any rhythmic sound, such as the
ticking of a clock or water leaking from a spout.
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How to set the tempomarkers

1. In the Xsheet menu, select View > Set TempoMarker.

The Tempo Marker dialog box opens.

2. Reproduce the tempo and beat value of your music or sound for the Xsheet view marker display.

‣ Starting Frame: Enter the number of the framewhere you want the tempo markers to begin.

‣ Frames/Beat: Set the frames per beat value. This will determine the frequency (in frames) in which a
beat marker will appear. Keep inmind that, by default, 24 frames represent 1 second.

‣ Beat/Bar: Set the tempo of your music or sound. This will determine the frequency (in beats) in which a
tempo marker will appear in the Xsheet view.

3. Click OK.

Printing the Xsheet
Once you havemarked all the information, corrections, and timing youwant in the Xsheet view, you can print your
exposure sheet. Printing the Xsheet allows you to take it with you to your animation table or give a copy to the
animator. You can also use it to create your Xsheet skeleton directly in Harmony.
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How to print your exposure sheet

1. Select File > Print > Xsheet.

The Print dialog box opens.

2. To set up your print:

‣ Windows: In the Select Printer section, select your printer and adjust the rest of the printing
settings.
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‣ Linux: In the Print Destination section, select your printer and adjust the rest of the printing settings.

‣ MacOS X: In the Printer section, select your printer and adjust the rest of the settings by clicking on
the Parameters button. You can also click PDF and select an option from themenu if you want to
save a PDF version of your exposure sheet.

NOTE: Refer to your printer user guide to learn more about its options.

3. Do one of the following:

‣ Windows andMacOS X: Click Print.

‣ Linux: Click OK.

Modifying Paste Presets
When pasting key frames and exposures, you canmodify the existing presets to your liking. There are three
presets you canmodify: the default presets for both key frames and exposures, key frames only and exposures
only.

How tomodify paste presets

1. From the Timeline view menu, select Edit > Modify Paste Presets and one of the following options:

‣ All to edit the default paste preset settings.

‣ Key Frame to edit the preset settings for pasting key frames.

‣ Exposure to edit the preset settings for pasting exposures.

The Edit Paste Presets dialog box opens.
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2. Refer to the following table and edit the presets as desired.

Edit Paste Preset Dialog Box Parameters

Parameter Description

Drawings

Add/Remove Exposure

Never create drawing files: Never create drawing files: When adding
exposures to a drawing layer, drawing files will not be created.

Only create drawing files when they do not exist: When adding exposures
to a drawing layer, new drawings will be created only when drawings with
the same name do not already exist in the destination.

Always create drawing files: When adding exposures to a drawing layer,
new drawings will always be created. If drawing files with the same name
already exist, Harmony will create a new name for the drawing.

Enforce Key Exposure
If there are key exposures that exist on copied drawings, they are preserved
when pasting. No key exposures are added. This is the default behavior
when pasting.

Fill Gap with Previous
Drawing

Fills selected area in the Xsheet or Timeline view with the previous drawing.

Fill to Next Key
Exposure

Fills selected area till the next key exposure.

Keyframes

Add/Remove
Keyframes

Motion: Copies the properties of the selected motion keyframe to the new
frame.

Velocity: Copies the properties of the selected velocity keyframe to the new
frame.

Rotation: Copies the properties of the selected rotation keyframe to the
new frame.
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Scale: Copies the properties of the selected scale keyframe to the new
frame.

Skew: Copies the properties of the selected skew keyframe to the new
frame.

Force Keyframes at Function's Beginning and End: Adds a keyframe to
the beginning and end of the pasted function, reproducing the source
function.
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Chapter 5: Character Building

Harmony is a great tool for building characters. You can use different techniques and features to break down
your puppets.

This chapter will guide you through all the steps to create a complete simple rig. Harmony allows you to create
very advanced puppets using deformations, hierarchies and z ordering. As you practice and get familiar with
those concepts, you will be able to develop more complex rigs and combine various advanced features.

For more great options and features to create powerful rigs, refer to Deformation on page 427.

This chapter contains the following topics:

• About theModel on page 338

• Relative Sizes on page 339

• Studying theModel on page 342

• Setting the Default Separate Position Preferences on page 345

• Naming Conventions on page 345

• Disabling the Animation onDrawing Layers on page 347

• Art Layers on page 349

• Breaking Down the Character on page 356

• Ordering the Layers on page 366

• Rigging on page 370

• Adding Extra Drawings on page 387

• Setting the Pivots on page 389

• SkeletonOptimization on page 391

• Storing the Character in the Library on page 396

• Appendix on page 400
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About the Model

To begin breaking down your puppet, youmust first import your character into a new project. You can also
draw your character directly in the scene.

You can import your character in several different formats:

• Library template—see Library on page 517

• Bitmap image or picture—see Compositing Guide > Import chapter > Import Bitmap Images topic

• External vector format—see Compositing Guide > Import chapter > Import AI and PDF Files topic

Model Alignment

When setting the character model in your scene, we recommend that you to center it in the Camera view and
scale it to fit inside the safe area frame—see Field Chart on page 341.
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If you have several views of your character, place each view in a separate cell and center them one on top of
another. This will facilitate the break down process and ensure that all of your puppets are aligned and the same
size.

Photo Puppets

If you are creating a cut-out puppet out of photos, break down the different parts in a bitmap editing software.
Then, import your parts and vectorize them as textured images.

A good way to set and import your bitmap parts is to organize them in a multilayered PSD file.

In Adobe Photoshop, organize your file so that all your layers are “grouped” into individual folders, or that all the
elements you want to import as a single layer in Harmony are grouped together in their own folder. Any layer that
is not in a folder group, by itself or otherwise, will not be imported.

Relative Sizes
Understanding the relative size of every character and prop is important for maintaining consistency and structure
throughout your project.

A productionmay containmany characters and props. It is not unusual for these to have been created by different
people. If there is no size control implemented, the characters and elements created by different artists can vary
greatly in size. When this occurs, the characters that are put together in a scene will be out of proportion. The
animator or person doing the scene setup will then have to scale them to the correct size.
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When a character or a prop is scaled down, the outline will get increasingly thinner. By the time the element is
scaled to its proper size, the outlinemay be so thin that the difference between one character's outline and
another's will not look very good.

These tips will help you to create and determine the correct relative sizes for each puppet:

• Line Up on page 340

• Field Chart on page 341

• Brush Size on page 341

Line Up

A line up consists of copying and pasting all of your character designs into the same drawing and then scaling
them so they are in proportion with each other. This line up is very important and should be handed to any
animator, layout and posing artist, or scene setup person working on the project.

For the prop design, it is recommended that you paste one of themain character's hands or even the full body
beside the prop. This enables the animator to know what size to draw or set the prop.

In your character design scene, it is a good idea to create a layer for the character line up. The line up is usually
done during the character design step. When the character builder imports themodel to the break down
scene, the size relation should be correct.
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Field Chart

The field chart in Harmony is a tool that is very useful when setting the height of characters and props. You can
display the field chart using the Show Grid option in the Camera and Drawing views.

How to display the field chart

1. Do one of the following:

‣ From the top menu, select View > Grid > Show Grid.

‣ Press Ctrl + ' (Windows/Linux) or⌘ + ' (MacOS X).

‣ Click the Show Grid button in the Camera View and Drawing View toolbars.

Brush Size

There are a variety of pens and brushes in Harmony and you can also create and save your own. It is a good idea
to create and save pens with precise sizes and parameters to trace and design your models and break downs—
seeDrawing with the Brush Tool on page 53.
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Studying the Model

Now that you have imported or designed your model, the next step is to analyze it. This is to determine what
parts will be broken apart and how they will be divided. Will the hair be separated into one, two or three
sections?Will the hand be separated from the sleeve? To determine what is best for your character, observe
themodel in the Camera or Drawing view.

• Eyelids and Pupils on page 343

• Separating theMouth Elements and Jaw on page 343

• Keeping Fingers Attached to the Hand on page 343

• Flipping Logos on page 344

• Complete and Overlapping Pieces on page 344
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Eyelids and Pupils

For increased flexibility when animating the eyes, you can split them into three layers: the eyeball, the pupil and
the eyelid. The eyelid layer is used for the blink and to cut the pupil when it gets too close to the side of the
eyeball. For a more advanced break down, the two eyes are separated on their own individual three-layer sets.

Separating the Mouth Elements and Jaw

To get a greater level of flexibility, you can separate the jaw from the head. You can also separate themouth
shape, teeth, tongue and interior one from another.

Keeping Fingers Attached to the Hand
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To avoid needlessly complicating the break down, the fingers are not usually separated from the hand. The full
hand is a single layer with a bank of different hands stored inside. This technique is easy to work with and
produces a less mechanical effect.

Flipping Logos

You can separate logos and letters that appear on a character or a prop. This allows you to flip and reuse a
character's puppet.

Complete and Overlapping Pieces

For a better result with animated parts, it is important to understand that theymust be properly overlapping
and complete. A commonmistake is to trace the part just as it appears on themodel.
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Setting the Default Separate Position Preferences
Before you adding layers to your puppets, make sure the Default Separate Position for Elements and the Default
Separate Position for Pegs preferences are enabled.

With the Default Separate Position preferences selected, when you create new layers, their X, Y and Z axes are
independent from each other.

By default, the Default Separate Position for Elements preference is enabled. For cut-out animation, you want to
have three independent axes so you can control them individually.

When you lock the three positions together, each time you add a keyframe, it is added on all three positions at
the same time.

When you separate the three positions and add a keyframe on one axis, it is not added on the other two. This
gives youmore freedomwhen animating withmotion keyframes and nudging parts forward and backward over
time.

How to set the Default Separate Position options

1. Do one of the following:

‣ Windows/Linux: Select Edit > Preferences.

‣ MacOS X: Select Stage > Preferences.

‣ Press Ctrl + U (Windows/Linux) or⌘ + U (MacOS X).

2. In the Preferences dialog box, select theGeneral tab.

3. In the Settings section, select theDefault Separate Position for Elements and theDefault Separate Pos-
ition for Pegs options.

4. Click OK.

Naming Conventions
Whenworking on a production, it is critical to keep work well organized with a naming convention chart before
starting the project. It is crucial that everyone follows the criteria laid out in the naming convention chart. When
dealing with thousands of characters, pieces and puppets, it is easy to get lost.
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Adding a Prefix or Suffix to a Layer

It is highly recommended that you incorporate a naming convention for the layers. This will be very convenient
in later steps. We suggest that you add one or two letters for the character/prop name before the part name
and an "R" or "L" for right and left to identify the corresponding character/prop:

• Character Abby's right arm = ab_r_arm.

If you plan to work with different angles for your characters (front, side, three-quarter, back), you can add one
or two letters to identify the angle:

• Character Abby's right arm, front view = ab_r_arm_f.

How to add a prefix to a series of layers

1. In the Network or Timeline view, select all the nodes or layers to rename or press Ctrl + A (Win-
dows/Linux) or⌘ + A (MacOS X).

2. In the Scripting toolbar, click the Add Prefix or Suffix Script button. If the Scripting toolbar is not vis-
ible, you can display it by selectingWindows > Toolbars from the top menu. If the script is not available
in your Scripting toolbar, refer to Fundamentals Guide > Interface chapter > Managing Toolbars topic
to learn how to add it.

The Add Prefix or Suffix dialog box opens.

3. Select the Prefix or Suffix option depending onwhat you want to add to the layer's name.

4. Type the prefix or suffix information to be added to the layer's name.

5. Click OK.

Naming the Drawings

We recommend that you use a naming convention for your drawings. If you combine all the angles of a
character in the same breakdown scene, it is a good idea to identify each angle used.
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Before breaking down the characters for your production, we recommend that you create a drawing name
convention that represents the angle used. For example, use "f" for front, "s" for side, "q" for three-quarter so
that the drawing name looks like this: f1, f2, f3, s1, s2, etc. This will be quite useful during animation and drawing
substitution. Since drawings are displayed in alphabetical and numerical order, all the drawings for the front view
will be together, then all the drawings for the three quarter view, and so on.

How to add a prefix to one or more drawings

1. In the Timeline view, select the drawing range to rename.

2. Do one of the following:

‣ Right-click on the selection and select Drawings > Rename Drawingwith Prefix.

‣ From the top menu, select Drawing > Rename Drawingwith Prefix.

The RenameDrawing with Prefix dialog box opens.

3. Type the characters you want to add before the current drawing name.

4. Click OK.

NOTE: To rename a drawing, select the drawing and use the Rename Drawing option.Do not double-click on the
frame and write a new name, as this will create a new drawing and hide your actual one. Note that the hidden drawing
has not been deleted and is still located within the element folder. Simply retype the name and it will reappear.

Disabling the Animation on Drawing Layers
By default, a drawing layer can be animated, but Harmony lets you disable this feature. Being able to switch your
drawings so they can no longer be animated without a peg has certain advantages. It means that you can access
the drawing substitution feature for this drawing layer, while being able to create keyframes on its parent peg.
This feature is also available for backward compatibility when bringing in templates created in older versions of
Harmony, so as not to lose their offset keyframes or drawing substitution keyframes.

When selecting the element in the Camera view, the actual drawing layer is selected, but themotion you will
create will automatically be transposed to the peg layer. You cannot animate (add keyframes) directly onto the
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drawing layer if the option is disabled. You will still be able to perform certain offset movements in the
Transformation tab of the Layer Properties, but not using any of the animation tools in the Tools toolbar.

There are two ways to disable animation on drawing layers, via the Layer Properties window and the
Preferences dialog box. When you disable animation in the Layer Properties window, it affects only the
selected layer and not any others.

If you prefer this style of animation and want every drawing element that you create to not be animated, you
can disable the Element Node “Animate Using Animation Tools” Default Value preference. This will disable the
Animate Using Animation Tools option on all the new layers you will create from that point on so you don't
have to do this through the Layers Properties window for every layer. It is recommended to disable this
preference before starting a new character rig.

How to disable animation in the Layer Properties view

1. In the Timeline view, double-click on a layer.

The Layer Properties window opens.

2. In the Controls tab, disable theAnimate Using Animation Tools option.

Notice that the layer functions are no longer available in the Timeline view.

3. Click Close.

How to disable the option in the Preferences dialog box

1. Do one of the following:

‣ Windows/Linux: Select Edit > Preferences.

‣ MacOS X: Select Stage > Preferences.

‣ The keyboard shortcut is Ctrl + U (Windows/Linux) or⌘ + U (MacOS X).

2. Select theAdvanced tab.

3. In the Advanced Options section, deselect the Element Node "Animate Using Animation Tools"
Default Value option.

348



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

Art Layers

Art layers give you the possibility to divide the artwork in your drawing on different layers. For example, you can
separate the outline and colour fill on two art layers, similar to 1950s traditional cell animation. These art layers
are contained within a single drawing as opposed to the layers in the Timeline view or Xsheet columns where
individual drawings with individual timing are stacked one on top of the other—seeCreating Strokes on page
354.

Toon BoomHarmony drawings include four art layers.

• Overlay on page 350

• Line Art on page 351

• Colour Art on page 351

• Underlay on page 352

You can access the art layers through the Art Layer toolbar. By default, only the Line Art and Colour Art are
displayed. You need to enable the Support Overlay and Underlay Arts option in the Preferences dialog box.

Each layer can be used for separate hand-drawn animation tasks, letting you organize your work and facilitate
creation and revision.
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Overlay

TheOverlay layer can servemultiple purposes:

• Highlights and tones

• Annotations and corrections

• Sketching

You can also draw in theOverlay layer as it's a regular layer.
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Line Art

In hand-drawn animation, the Line Art layer is mainly used to trace and clean up animation. The outline is drawn in
the Line Art layer and colour is painted in the Colour Art layer.

Colour Art

In hand-drawn animation, you use the Colour Art layer to paint your animation. The outline is drawn in the Line Art
layer and colour is painted in the Colour Art layer. Strokes (invisible lines) are generated from Line Art to contain
the painted area.

When you are doing rough animation, youmay want to send a clip for feedback or approval before carrying on
with your work. If you have several characters in your project that are overlapping, it may be difficult to
understand what is going on as you can see through the characters. Toon BoomHarmony can generate a matte
automatically in the Underlay, or even in the Colour Art layer, and fill all the zones inside your characters to make
them opaque. This process is fast and easy, and allows you to send easy-to-understand movies.
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Underlay

The Underlay layer can servemultiple purposes. It is frequently used by animators to sketch rough animation or
generate a matte colour when doing line testing.

How to enable the Support Overlay andUnderlay Arts option

1. From the top menu, select Edit > Preferences ( Windows/Linux ) or Stage > Preferences ( MacOS X ).

2. In the Preferences dialog box, select theAdvanced tab.

3. In the Advanced Options section, select the Support Overlay andUnderlay Arts option.

4. Click OK.

How to switch between drawing layers

1. In the Art Layer toolbar, click the Line Art or Colour Art buttons. When switching art layers, you
can edit the select layer without affecting the other one.

2. Click the Preview All Enabled Art Layers button to display both layers together. Even when the Pre-
view mode is enabled, you will only be able to edit the select art layer. The other ones are only displayed
as a reference. By default, the Preview mode is always enabled in the Camera view. Youwill only be able
to see the select art layer by itself if you enable the Current Drawing on Top option located in the
Camera bottom toolbar.

NOTE:
To edit both Line Art and Colour Art at the same time, you must enable the Apply to Line Art and Colour Art

button in the Tool Properties of the tools supporting the operation.

How to switch between the drawing layers in AdvancedArt mode

1. In the Art Layer toolbar, click theOverlay Art , Line Art , Colour Art or Underlay Art but-
tons to display the appropriate layer—seeHow to enable the Support Overlay and Underlay Arts
option on page 352. When switching art layers, you can edit the selected layer without affecting the
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other one.

2. Click the Preview All Enabled Art Layers button to display all the layers together. The other ones are
only displayed as a reference. By default, the Preview mode is always enabled in the Camera view. You can
view only the selected art layer if you select the Current Drawing on Top option in the Camera bottom
toolbar.

How to generate a matte

1. Do one of the following:

‣ In the Tools toolbar, select the Select tool.

‣ Press Alt + S.

2. In the Camera or Drawing view, select the drawing youwant to create a matte for.

NOTE: You can also apply the operation to all the drawings in the layer at the same time.

3. Do one of the following:

‣ From the top menu, select Drawing > Generate Auto-Matte.

‣ In the Camera or Drawing menu, select Drawing > Generate Auto-Matte.

The Auto-Matte dialog box opens.

4. If you want to create a matte for all the drawings included in your layer, select theApply toMultiple Draw-
ings option.

5. Depending on how precise or rough your line is, increase or decrease the radius value. The lower the value,
the closer to your lines’ contours thematte will be shaped. The higher the value, the looser thematte will
be shaped.
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6. In the Source Art menu, select the layer fromwhich you want thematte created: Line Art, Colour Art,
Underlay orOverlay.

7. In the Destination Art menu, select the layer on which you want thematte to be created: Line Art, Col-
our Art, Underlay orOverlay.

8. If you already have artwork on the destination layer and youwant the content to be deleted before the
matte is added into it, select theClear Destination Art First option.

9. If you want the contour of your lines to be copied as invisible lines in your matte drawing (in case you
ever need to keep them for later), select theCopy Stroke in Destination option.

10. Click OK.

Creating Strokes

Adrawing is composed of Line and Colour filling layers. Lines and colours can be separated or kept together,
depending onwhich animation process you use. The following diagram presents Line Art and Colour Art
recommendations based on the selected animation workflow.
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When a traditional drawing is scanned, strokes are automatically created in the Colour Art from the Line Art when
drawings are vectorized unless you specified otherwise.

Whenworking with Cut-out animation, we recommend that you do all of the work in the Line Art.

Once the drawing sequence is completed for paperless drawings, you can proceed with creating Colour Art
strokes if you plan to paint the animation in the Colour Art. Use the Create Colour Art from Line Art option to
create strokes from your lines.

You can create strokes in the Colour Art during the following stages:

• After the full drawing is completed in Line Art

• While drawing in Line Art

Youmay have some traditional drawings that need to be fixed; for example, needing extra lines to patch gaps.
Use the Auto-Create Colour Art from Brush option to create the strokes at the same time as the lines are drawn.
This creates strokes from the lines and brush strokes created in the Line Art while you draw and is useful for fixing
drawings. However, if you are drawing a new sketch, it is better to create the strokes afterward using the Create
Colour Art from Line Art option.

How to create Colour Art zones out of the Line Art content

1. In the Tools toolbar, select the Select tool or press Alt + S.

2. In the Tool Properties view, click the Permanent Selection button if you want to apply the operation on
all drawings in the layer.

3. In the Camera or Drawing view, select the artwork to transfer to the Colour Art. Create a selection around
the entire animation sequence if you want to apply the operation to all your drawings.

1. In the Drawing View toolbar, click the Create Colour Art from Line Art button or press *.

How to create strokes with the Create Colour Art Automatically option

1. In the Tools toolbar, select the Brush tool.

2. In the Tool Properties view, enable the Create Colour Art Automatically option.

3. Draw the required lines.

4. Once you're done, deselect the Create Colour Art Automatically option.

You are now ready to paint your model.
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Breaking Down the Character

There aremany techniques you can use to break down a puppet. In this section, you will learn about one of the
most common and simplest methods. For your first character breakdown, follow these instructions to get an
idea of the way Harmony works. Once you understand Harmony's basic functions and commands, you will be
able to create your own techniques to satisfy the needs of your production.

Refer to theAppendix on page 400 at the end of the chapter for alternate tips.

This section is divided as follows:

• Tracing theModel on page 356

• Articulations on page 359

Tracing the Model

Themain breakdown technique shown here is to trace your model—see theAppendix on page 400 to learn
about more techniques.

How to break down a character

1. In the Timeline view, add a new drawing layer for each body part to separate. You can press Ctrl + R
(Windows/Linux) or⌘ + R (MacOS X)—seeNaming Conventions on page 345.
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2. In the Timeline view, select the layer's first cell in which you want to draw the part.

3. In the Tools toolbar, select a drawing tool.

4. In the Colour view, select a colour swatch. If you haven't created a palette for your character yet, seeCol-
our Styling and Colour Models on page 195.

5. In the Camera or Drawing view, draw the new part with as with as few points as possible so the pieces are
easy to manipulation, modify or redraw. Using the Polyline tool would make it easy to do this.

If you are working in the Drawing view, click the Light Table button in the Drawing View toolbar to
display the other layers as washed out colours. You can also press Shift + L.

6. You can use the Stroke tool in the Tools toolbar to create an invisible hairline if you want to close a shape
without drawing an actual stroke.

‣ Select View > Show > Show Strokes or press K to display the invisible lines.

7. In the Tools toolbar, select the Paint or Paint Unpainted tool to colour your drawing.

8. In the Colour view, select the corresponding colour.
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9. In the Camera or Drawing view, paint your drawing.

10. In the Tools toolbar, select the Select tool. Select your drawing and flatten the lines by clicking the
Flatten button in the Tool Properties view.

11. If your lines are composed of several pencil strokes, youmight want to combine them into one single
smooth pencil line. Using the Select tool, select the pencil lines to bemerged and in the Tool Properties
view, click theMerge Pencil Lines button.

12. Repeat the entire process until the break down is completed.
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Articulations

Once your pieces are traced, you can go ahead and complete the articulations.

Articulations are an important aspect of any cut-out break down because without them, a puppet cannot move
properly and will not look good.
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If you are using deformations to animate the limbs, your articulations don't need to overlap. The deformer
effect will create the joint for you.

This topic is divided as follows:

• Classical Articulation on page 360

• Auto-patch Articulations on page 362

Classical Articulation

Classical articulation is themost popular technique for basic characters. It is quite simple and produces
excellent results, but it's not themost efficient method. Inmany instances, it causes limitations and extra
drawing corrections. For example, theremay be a gap in the articulation if the part is bent too far. Joint design
is usually a circle; the overlapping part cannot be sent behind without showing the joint.

For a more advanced articulation, see Patch Articulation on page 416 in the Appendix section.

Classical articulation is done by erasing a part of the line from the overlay layer, leaving the colour overlapping
the bottom layer. You can use this technique for all the articulations on your puppet.

How to create a classical articulation

1. In the Timeline view, select the cell containing the part to modify (piece located behind), such as the
upper arm.

360



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

2. In the Tools toolbar, select the Pencil , Polyline , Ellipse , Cutter , or Contour Editor
tool.

3. In the Colour view, select an outline colour.

4. In the Drawing or Camera view, use your drawing tool to make sure the joint overlaps the other part in a
half-circle shape.

If you are working in the Drawing view, click the Light Table button in the Drawing toolbar or press
Shift + L.

5. From the top menu, select View > Show > Show Strokes or press K to display the invisible lines that may
be present in your drawing.

6. In the Drawing or Camera view, select all the strokes in your drawing.

7. In the Tools Properties view, click the Flatten button.

8. In the Drawing or Camera view, select all the strokes in your drawing.

9. In the top menu, select Drawing > Optimize > Remove Extra Strokes to remove any unnecessary, invis-
ible lines in your drawing.

10. Repeat the previous steps for the other articulations.

11. In the Timeline view, select the cell of the part that will be on top of the joint.
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NOTE:When placing rotation pivots later on, make sure they are positioned at the centre of the
articulation.

Auto-patch Articulations

Harmony has a very efficient node to automatically patch an articulation without you having to do any line
adjustment or colour overlapping. You can draw your two pieces with their complete lines overlapping each
other in semicircles and the Auto-patch nodewill create a perfect articulation from it.

In order for the Auto-patch to work on your puppet, youmust draw the outline with the Pencil tool (pencil
lines) on the Line Art layer of your drawing, and then paint the colour on the Colour Art layer.
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You can use this technique in evenmore efficiently by adding extra lines in theOverlay layer of your drawing to
create a fold illusion for a bent elbow.
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About the Auto Patch Node

The Auto Patch node is used mainly when creating joint patches for cut-out puppets drawnwith pencil lines
and painted in the Colour Art layer. Instead of removing a portion of the outline to attempt to create a
seamless joint, you can draw complete pieces, and with the Auto Patch node, automatically create a perfect
articulation.

The requirements for this effect to work are:

• Drawing outlines must be drawn in pencil lines

• Drawing outlines must be drawn in the Line Art layer

• Drawing fill colours must be painted in the Colour Art layer

Pencil lines are central vector lines. The vector is located along the centre of the line. This means that when you
paint a zone delimited by a pencil line, the colour fill will expand to the centre of the pencil line.
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When using the regular patch technique, recommended for the brush line, the result with pencil lines is very odd
looking because the colour fill zone is bigger than the pencil line inner contour.

Instead of using the regular patchmethod, you can use the Auto Patch node. It will automatically extract the
Colour Art and clip it to the right size. Then, you can connect it in front of the piece to be covered.

The node connection for the Auto Patch is quite simple. Once your basic character rigging is done, add the Auto
Patch node to the joints you want to cover. There is no need to set any parameters.
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Ordering the Layers

At this point, it is possible that your character's pieces may show up in the wrong order.

There are several ways to fix this. First, you can reorder your layers by dragging them to a higher or lower level
in the Timeline view. The top layer is displayed in front of the others and the bottom one is displayed behind.
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Second, you can use the Z-axis nudging (forward and backward) if you have extra views included in the same
layers (front, three-quarter, back, etc.).

This topic is divided as follows:

• Ordering the Timeline Layers on page 367

• Ordering Layers in the Network View on page 367

• Nudging Parts Backwards and Forwards on page 368

Ordering the Timeline Layers

In the Timeline view, the layer positioned at the top will be displayed in front and the ones below will be displayed
behind. If you havemultiple views, you should order your layers based on themost common view, which is
generally the three-quarter front.

How to order the layers

‣ In the Timeline view, drag a layer to reorder it and drop it between other layers.

If you drop it on a layer, it will create a parent hierarchy, so make sure to drop it between layers.

Ordering Layers in the Network View
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TheNode view allows you to reorder layers without breaking any hierarchy. For example, if you want the Head
layer to appear behind all the facial features, in the Timeline view, you cannot simplymove the layer down
because you will break the parenting between the head layers. In the Node view, since you have a set of flexible
connections, you can change the Composite node ordering without breaking the parenting between the
nodes.

The Composite node ordering corresponds to your timeline ordering unless the Node view's organization is
too complex for the Timeline view to display. The element connected in the left-most port of the Composite
node is displayed in front in the Camera view and the one connected in the right-most port is displayed behind.

How to order layers in the Node view

‣ In the Node view, select the node's output cable connected to the Composite node and drag it to its
new position.

Nudging Parts Backwards and Forwards

If you created a hierarchy on your arms, legs or other body parts, it is possible that you will want a part, such as
the hand, to appear in front of its parent. Yet, if youmove the hand layer above the arm layer, you will break
the hierarchy. To reorder a layer rigged in a hierarchy, nudge it backwards or forwards on the z-axis.
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NOTE: You will do the same for the layers that are not in the right order on the extra views. Do not place the drawing
on another layer. You want to keep all your drawings of the body parts in the same layers like a box containing all of
the hands or all of the shoes.

Harmony allows you to move your elements in three dimensions:

• Up and down (Y-axis)

• Left and right (X-axis)

• Backwards and forwards (Z-axis)

In the sameway you createmultiplane backgrounds (depth), you can perform a micro nudge of the part to be
reordered and see it in front of the other elements, even if its layer is actually behind the other ones in the
Timeline view. The forward-backward position can also be animated over time.

Repeat the following instructions for all the views.

How to nudge your parts backward and forward

1. In the Tools toolbar, select the Transform tool. Make sure to enable the Animate   mode.

2. In the Camera view, select the element you want to reorder. Make sure the focus (red outline) is around the
Camera view before selecting the element.

3. To move the element forward, press Alt + DownArrow and to move the element backward, press Alt +
Up Arrow.
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Rigging

s

The rigging process is where building a puppet can take several different directions.

In this section, you will learn how to create a simple rig. Afterwards, you will learn how to add pegs and create
a hierarchy. You can also seemore advanced tricks in theAppendix on page 400. For a very flexible and
advanced rig, seeDeformation on page 427.

• About Rigging on page 370

• Adding Pegs on page 374

• Rigging the Head on page 375

• Rigging the Body on page 377

• Creating a Hierarchy on page 379

• Ordering the Layers on page 366

• Adding theMaster Peg on page 381

• Creating the Keyframes on page 382

• Setting Properties for Many Layers on page 383

• Masking on page 385

About Rigging

There are some basic concepts to know when rigging and layer parenting:

• Simple Rigging on page 371

• Parenting Layers on page 372
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• Rigging Using Pegs on page 373

Simple Rigging

Simple rigging is very fast and easy to do. It is built as follows:

• All the body parts are independent

• All the timeline layers are attached to a master peg layer (trajectory layer)

The advantage of using this technique is that you are free to move any part around without being influenced by a
parent layer.

However, since the parts are not parented to each other, the parts will move from point A to point B along a
straight trajectory. The hand will not follow the arm's rotation. You will have to set more keyframes for the hand
to move along a curved path.
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Parenting Layers

When youwant one part to follow another part, such as the forearm following the arm, you can attach the
layers one to the other. For example, you can attach the forearm layer to the arm layer without having to
encapsulate the forearm into the arm layer. They will still be parented, but you can access the forearm directly
without having to enter the arm layer.

The advantage of parenting layers is that the child layers will follow the parent smoothly without having to
select them or create a series of keyframes.

The disadvantage of parenting layers is that you are not able to move the parent independently of its children,
since the child layers receive all the transformation information from their parent.
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Parenting layers, such as the arms and legs, and allowing the torso and hips to be independent from them is often
a good solution.

NOTE:
To attach one layer to another, you must drag the desired layer onto the other one in the Timeline view.

Harmony offers powerful techniques to create hierarchies between your layers without having to encapsulate layers
into each other. These techniques are a great improvement over the less efficient and time consuming method of
creating parenting between your layers by inserting symbols into other symbols. Therefore, rigging with symbols
inside symbols is NOT recommended.

Rigging Using Pegs

Peg layer are useful when you are doing more advanced puppet rigging. Peg layers are trajectory layers that do
not contain drawings. They aremotion paths that you can use to control your entire puppet or advanced
hierarchies.

Parenting a drawing layer to a peg layer allows you to divide your motions on two separate levels. You can scale a
body part up the chain of pegs directly on the drawing layer. This way, you do not affect any child layers that
could be attached to that part.

Then, you can perform your translation and rotation on the peg layer so all the parts attached to that peg layer
follow the same trajectory.
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Adding Pegs

It is recommended to add parent pegs to your drawing layers which are path layers that let you add keyframes
to modify the positions of pieces over time. It is not mandatory, but it is helpful to have your drawings and
keyframes separated—seeDisabling the Animation onDrawing Layers on page 347.

How to parent drawing layers to pegs

1. In the Timeline view, select all the layers.

2. In the Timeline Layer toolbar, click the Add Parent Peg button to add a parent peg to all selected lay-
ers.

374



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

s

At this point, in the Node view, the layers look tangled.

3. In the Node view, select all the nodes and, in the Network View toolbar, click theOrder Network Down
button.

Rigging the Head

Youwill start by attaching the facial features to the head.
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The advantage of parenting the head and the facial features to the same peg is that you can easily animate
each facial feature, and they will all follow the head motion.

You can also use additional pegs to control smaller groups of pieces such as the facial features or all the left
eye pieces. You can parent as many pegs as you want to obtain a maximum of control on your rig.

How to parent the facial features to the head

1. In the Timeline view, deselect any selected layers.

2. Select the head peg layer.

3. In the Timeline View Layer toolbar, click the Add Parent Peg button to add a new peg layer to your
timeline. You can rename the peg to keep your work organized.

A new peg is added and parented to the head peg layer.
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1. Select all the remaining head and facial feature layers and drag themONTO the peg layer or BETWEEN
the head peg layer and the new head peg to parent them.

Rigging the Body

When the character's head is ready, you canmove on to rigging the body. You can do a simple rigging where all
the body parts are independent of each other, or create parenting between some of the layers. Refer to Creating
a Hierarchy on page 379 to learn how to parent your layers.

Simple rigging consists of leaving the layers in the Timeline view without doing any kind of parenting. Later on,
you will attach those layers to a master peg and organize them in the correct order—seeAdding theMaster Peg
on page 381 andOrdering the Layers on page 366.

Your drawings must be connected to a Composite node. A Composite node takes all the drawing layers
connected in it and flattens them into a single imagewhich allows you to organize your network and manipulate
your puppet easily. It also allows you to apply effects on your complete character. The Composite node is useful
when you are working withmany nodes in theNode view.

If you create your layers in the Timeline view, they will automatically be connected to the Composite node in the
Node view, as long as you are not using the Display All mode in the Display toolbar.
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Connecting Nodes to a Composite Node

In Harmony, if your nodes are not connected to a Composite node in theNode view, you can connect them all
at once following the Timeline order.

How to connect your nodes to a Composite node

1. If you do not have a Composite node, open a Node Library view. From the top menu, selectWindow >
Node Library.

2. Select the Favorites tab and select theComposite node.

3. Drag the Composite node to theNode view or press Ctrl + H.

4. In the Timeline view, select all the nodes you can to connect to your Composite node.
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5. Right-click on the selection and select Connect To Composite > select the desired Composite node.

Your nodes are now connected to the Composite node in the same order as the Timeline view.

Creating a Hierarchy

Harmony lets you extend your rigging techniques beyond normal boundaries and sets new standards. You can
create hierarchies without encapsulating pieces inside each other by creating a linked structure between layers.

You should create a hierarchy on the arms and legs, and keep them separated from the body. This gives youmore
animation freedom, and when you need to scale or skew the torso, it will not affect the entire body.
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How to create a hierarchy in the Timeline view

1. Drag the child piece (hand) and drop it ON the parent piece (forearm). Then, you can drag the parent
(forearm) piece onto another parent piece (upper arm).

‣ You can unparent layers by holding down Shift and dragging the selected parents away from the
child layer. Drop your selected between other layers.
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How to create a hierarchy in the Node view

‣ Without Pegs: From the parent part, drag a new cable connection out of the node's output port
(bottom) and connect it to the child part node's input port (top).

‣ With Pegs: From the parent part's peg, drag a new cable connection out of the node's output port
(bottom) and connect it to the child part's peg input port (top).

Adding the Master Peg

When you animate your character, you will probably need to resize and reposition it to fit your scene. When you
need to scale down or move your character, it is a good idea to hook (attach) the whole puppet to a trajectory.
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Attaching your puppet to a peg will allow you to scale it and reposition it without having to do this to the
different parts and pieces. Only one layer will contain the position information, whichmakes your animation
easier to modify and control.

How to add amaster peg

1. In the Timeline view, select the top layer to parent a peg to it. You need to select a layer to be able to
add a peg to your scene. Unless you use the Display All mode from the Display toolbar, you will get an
error message if you try to add a peg without any selection.

2. In the Timeline view, click on the Add Peg button.

A new peg is added to the timeline as a parent of the selected layer.

1. Name the new peg Master plus the character's name.

3. In the Timeline view, select all the layers you want to attach to your new peg. Remember that one item is
already parented to that peg.

2. Drag your selectionON to the peg layer to parent all your character's pieces to the peg. If your layers
are added above the already parented layers, move that parented layer back on top of the layer stack.

Creating the Keyframes

Once all your drawings are ordered and your master peg is added, you need to insert keyframes on each cell to
create all of the function curves and block your pose in place.

How to create the keyframes

1. In the Timeline view, collapse themaster peg by clicking the Expand arrow.
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2. In the Timeline view, select the first cell.

3. Do one of the following:

‣ From the top menu, select Insert > Keyframe.

‣ In the Timeline View toolbar, click the Add Keyframe button.

‣ Press F6.

NOTE: If you use the F6 shortcut when working Flash keyboard shortcuts flavour, this not only creates a keyframe but
also duplicates a drawing.

Setting Properties for Many Layers

Whenworking with several nodes, youmay frequently want to modify a series of settings. Instead of opening the
properties for each individual layer, you can set the properties for many layers so you can change a common
setting in a single click.

This allows you to modify the following settings:

• 3D Path or Separatemode

• Use Embedded Pivot

• Overlay

• Line Art

• Colour Art

• Underlay

• Animate Using Animation Tools

NOTE: You can access this function in the Node View toolbar. You can add the button to the Timeline View toolbar
through the Toolbar Manager. In the Toolbar Manager, you will find the feature in the script section under the name
Script: TB_Set_Properties_on_manu_layers in TB_Set_Properties_on_many_layers.js.

How to set properties for many layers

1. In the Node or Timeline view, select all the layers you want to modify at the same time.
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2. In the Node or Timeline View toolbar, click the Set Properties for Many Layers button. This option is
not available by default in the Timeline View toolbar. Youmust add it through the Customize option.
Right-click on the toolbar and select Customize. In the Available Tools list, select Script: TB_Set_Prop-
erties_on_many_layers and move it to the Toolbar list.

The Set Properties for Many Layers dialog box opens.

3. Modify the properties. If your nodes have different parameters enabled for a certain setting, leave the
As Is option selected to avoid modifying it. Each nodewill keep its original setting. Select any other
options for all nodes to change to this parameter regardless of their original setting.

4. Click OK.
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Masking

When rigging a character, theremay be instances when youwant to have the ability to move a particular piece to
give the illusion of a rotation or move the pupil within the white of an eye without having the extra bit of the
drawing sticking out of the character or eyeball. To do so, you can usemasks to cut anything you don't want to
be visible.

How tomask an object in the Node view

1. In the Timeline view, make sure the keyframe is added on the object that will bemasking the piece to cut.

2. From theNode Library view, select the Favorites category and then select theCutter node.

3. Drag the Cutter node to theNode view.

4. Connect the object you want to cut to the Cutter node's right port and connect the Cutter to the Com-
posite node.
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5. Pull out a cable from themasking object and connect it to the Cutter node's left port.

6. Your masking effect is most likely inverted and what you want to cut is probably showing. Click the
Mask node's yellow button to open the Layer Properties window. In the Layer Properties window,
enable the Inverted option.

7. From the Tools toolbar, select the Transform tool and move the cut object within themasking
zone.
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Adding Extra Drawings

Your break down is now complete. You canmove on to adding the extra drawings your character needs, such as
principal hand positions and mouth shapes. If you ever forget to add extra drawings in your main character's
template, you can easily add them later.

NOTE: Add your extra drawings in the layer corresponding to the part you are drawing. You should see the layers as
containers for the different pieces. Each body part has its own container in which you can add more drawings of the
same part.

If you want to use the auto lip-sync detection feature to animate your dialog, you should create the following
mouths for your puppet.

Themouth shapes used by Harmony are based on the conventional mouth chart used in the animation industry.

NOTE: The letters used to represent the shapes do NOT correspond to an actual sound.

NOTE: If you are doing cut-out animation, refer to the Cut-out Animation Guide, Character Building chapter, "Adding
Extra Drawings" topic to learn how to add extra drawings to your character.
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Here is an approximation of the sound eachmouth shape can produce:

• A: m, b, p, h

• B: s, d, j, i, k, t

• C: e, a

• D: A, E

• E: o

• F: u, oo

• G: f, ph

• X: Silence, undetermined sound

You can lip-sync the traditional way or let the system automatically create the basic detection.

You can refer to themouth chart positions as you draw the shape of the character's mouth.

How to add extra drawings

1. In the Timeline view, select the cell where you want to add a new drawing. If you want to duplicate the
current drawing and work from it, you can select Drawing > Duplicate Drawings or press Alt + Shift +
D.
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A new drawing is created in the selected cell and automatically extended to the next one. The new drawing
is a duplicate of the one that was selected so it contains a duplicate of the art. You canmodify it to create
your new drawing or delete its contents in the Camera or Drawing view and start from scratch.

1. In the Tools toolbar, select a drawing tool for drawing your extra part.

2. In the Camera or Drawing view, draw your new drawing.

2. Using the Select tool, select your drawing and flatten the lines by clicking the Flatten button in the
Tool Properties view.

Setting the Pivots

One of the last steps before storing the character in the library is to set the pivots for the different parts.

Harmony has three types of pivots:

• Permanent Pivot
This is a permanent pivot, sometime referred to as peg pivot, that is applied to the entire drawing or peg
layer. If youmodify its position, it will be changed for the entire layer, modifying the animation, scale and
rotation interpolation. The permanent pivot is set using the Rotate, Translate or Scale tool. The Transform
tool will only move that pivot temporarily for positioning purposes, but the animation interpolation will be
done from the original permanent pivot's position. The Transform tool is designed to move the pivot
temporarily during the animation process. It also permits you to select multiple pegs and apply a common
temporary pivot.
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To permanently move a peg pivot, use the Rotate or Scale tool. You can also directly type the values in
the Layer Properties window in the Pivot section's (x) Axis and (y) Axis fields.

In the Layer Properties window, in the Drawing Pivot section, select theDon't Use Embedded Pivot
option to use the permanent pivot.

• Drawing Pivot
TheDrawing pivot is contained within each drawing. In one layer, each drawing can have its own pivot. If
you havemany different views of a character within one layer, the pivot can be different and the
animation will adjust to the pivot. The Drawing pivot can also be referred to as embedded pivot. If you
are not mixing different views within the same layers or are using pegs to animate your layers, it is
recommended to use the permanent pivot.

You can set a different pivot for each one of your drawings. For example, if you have a series of
drawings from different views, they are not likely to rotate from the same location. In that case, you can
set a different pivot for these drawings by using the Drawing Pivot tool.

In the Layer Properties window, in the Drawing Pivot section, select theApply Embedded Pivot on
Drawing Layer option to use the drawing pivot directly on the drawing layer. If you want to apply the
drawing pivot to a parent peg to force the peg to follow the drawing pivot variations, enable theApply
Embedded Pivot on Parent Peg option.

• Symbol Pivot
The Symbol pivot is similar to the Drawing pivot. Each symbol cell can have its own pivot and act the
same as the Drawing pivot. The Symbol pivot can also be referred to as embedded pivot. Inside a
symbol, each drawing can have its own pivot. If you are not mixing different views within the same layers
or are using pegs to animate your layers, it is recommended to use the Peg pivot.

For a simple character rig, it is recommended to set the Peg pivot (even on drawing layers) using the Rotate
tool.

If you want the puppet's pieces to rotate correctly, youmust set the pivot points right in themiddle of an
articulation, such as an elbow or a knee.

By default, your master peg pivot is placed at the centre of the Camera view, which generally equates to your
character's hips. A good way to set your peg's pivot is to move it between the character's feet.

How to set the pivots with the Rotate tool

1. In the Advanced Animation toolbar, select the Rotate tool.
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2. In the Camera or Timeline view, select the layer whose pivot you want to set. In the Camera view, you can
also hold downCtrl (Windows/Linux) or⌘ (MacOS X) and click on the piece whose pivot you want to set.

3. In the Camera view, drag the blue pivot to reposition it.

4. Repeat the previous steps for all the pieces, including the eyes, nose and mouth. If you are unsure as where
to place the pivot, put it in the center of the selected piece or group of pieces.

NOTE: If you added other pegs to your rig, you must set their pivot using the same method.

Skeleton Optimization
In the Node view, you can add extra nodes, such as a Display, and group all the nodes to keep your work
organized.

There are four steps to make sure your puppet can be reused efficiently:

• Deleting theWrite Node on page 391

• Renaming the Display Node on page 392

• Changing the Composite Type on page 393

• Grouping Nodes on page 394

Deleting the Write Node

The first step in optimizing your network is to delete theWrite node, which used for rendering certain portions of
the Node view.

When you render a scene that contains three or four characters and they each have a Write node in their skeleton,
a render is created for each one and they overwrite each other.
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How to delete the Write node

1. In the Node view, select theWrite node.

2. From the top menu, select Edit > Delete or press Delete.

Renaming the Display Node

TheDisplay node lets you see a section of the network in the Camera view. By renaming the Display nodewith
your character's name, you can quickly identify it in the Global Display toolbar and isolate your character to see
it better while working on it.

If you do not have a Display node in your network, you can add one by selecting one from theNode Library
view and dragging it into theNode view.

How to rename your Display node

1. In the Node view, click on the Display node's Properties button to open the editor.

2. In the Layer Properties window, rename the Display nodewith your character's name.

3. Click Close.
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How to add a Display node

1. In the Node Library view, select the IO tab and select theDisplay node.

2. Drag the node to theNode view.

3. Connect the Composite node's output port into the Display node's input port.

Changing the Composite Type

When you create a character with Harmony, you have to connect all your nodes in the Composite node. The
Composite node takes all the different images coming out of your drawing nodes and flattens them into one
single image.

This is useful when it is time to apply an effect to your entire character or group your layers for a more organized
network.

The regular Composite nodewill flatten all the pieces into one image preventing interaction with props or
characters connected to a different Composite node. That is why you have to change the Composite node's type
to a special one that will still output one single image but will not flatten the drawings together. This will allow
you to nudge your drawings on the Z-axis so that parts of you characters can pass in front and behind other
characters and objects. This Composite type is called Pass Through.
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How to change your Composite node to a Pass Through type

1. In the Node view, click on the Composite node's Properties button.

The Layer Properties dialog box opens.

2. From theModemenu, select Pass Through.

3. Click Close.

Grouping Nodes

Once your rigging is completed, youmust group the puppet's skeleton to help organize the often large and
complex networks. This way, once you have imported two or three characters into the scene, threeGroup
nodes will be displayed instead of all the rigging connections of three puppets.
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How to group nodes

1. In the Node view, select all your nodes.

2. In the top menu, select Edit > Group > Group Selected Layers or press Ctrl + G (Windows/Linux) or⌘ +
G (MacOS X).

Your nodes are grouped.

3. Click on theGroup node's right arrow to enter the group.

4. If you do not have a Multi-Port Out node inside your group, in the Node Library view, select theGroup cat-
egory and select aMulti-Port Out node.
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5. Drag theMulti-Port-Out node to theNode view.

6. Connect the Composite node's output port into theMulti-Port Out node.

An output port is created on your Group node.

7. In the bottom-left corner of the Node view, click Top to return to the network's root. You should now
see an output port on your Group node.

8. Click on theGroup's Properties button to open the Layer Properties window.

9. In the Layer Properties window, rename theGroup nodewith your character's name.

10. Click Close.

Storing the Character in the Library
For maximum efficiency and reuse of your character in different scenes, youmust store a template in the
Library view. You can create different kinds of templates, such as templates that include all the layers, a
template for a body, key pose or even some containing only the head.

396



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

Harmony has a Timeline and a Node view. The Timeline view represents the layers in a linear and simple way. The
Node view lets you create all sorts of complex connections that the Timeline view cannot display. This means that:

• Any template created from the Timeline view must be imported in the Timeline view.

• Any template created from theNode view must be imported in theNode view. These templates are also
referred to asmaster templates.

NOTE: It is highly recommended that you create a cut-out puppet's main template (master template) from the Node
view since it contains advanced connections, Display nodes and Composite nodes.

When you create a template from the Timeline view's right side, youmust first import your master template in
order for everything to work properly when you reimport it into a scene. Once themaster template is imported,
you can import the key pose (action) template's content into the right side of the Timeline view.

When you create a template from a keyframe in the Timeline view's right side, it only copies the drawings and
keyframes. It does not copy all of the node system's advanced connections and composites. If you import a
template that was created in the Timeline view into theNode view or in the Timeline view's left side, the layers will
be in the wrong order and will not be connected to a composite.

How to create a template from the Node view

1. In the Library view, right-click on the desired library folder and select Right ToModify.

2. In the Timeline view, collapse themaster peg layer.

1. If your scene has a series of blank cells, theymust also be included in the template if you drag the layer to
the Library view. Reduce the scene length so there are no empty cells before creating your template.

2. Add a keyframe on the collapsed character.
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3. In the Node view, select your character's group and in the top menu, select Edit > Copy. In the Library
view, select the folder in which you want to store the template and in the top menu, select Edit > Paste.

The Rename dialog box opens.

3. In the Name field, type in a name for the template.

4. Click OK.

How to create a template from the Timeline view

1. In the Library view, right-click on the desired library folder and select Right ToModify.

2. In the Timeline view, collapse themaster peg layer.

3. If your scene has a series of blank cells, they will also be included in the template if you drag the layer to
the Library view. Reduce the scene length to have no empty cells before creating your template.

4. In the Timeline view, select your master peg and drag it to the Library view.
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The Rename dialog box opens.

5. In the Name field, name the new template.

6. Click OK.

How to create a key pose (action template)

1. In the Library view, right-click on the desired library folder and select Right ToModify.

2. In the Timeline view, collapse themaster peg layer.

3. Select the cell containing the desired view and drag it into the desired library folder.
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The Rename dialog box opens.

4. In the Name field, type in a name for the template.

5. Click OK.

Appendix

Themany options and animation techniques available for building a puppet make it impossible to determine
only onemethod to break down a character. Here are some advanced tips on breaking down puppets. As you
becomemore familiar with the software, you will find more ways to improve the construction of your puppet.

This section is divided as follows:

• Break Down: Cutting the Character in Pieces on page 401

• Break Down: Distribute to Layers on page 412

• Converting the Layers into Symbols on page 413

• Patch Articulation on page 416

• Setting Different Pivots for a Puppet Using Symbols on page 421

• Setting Pivots on a Frame Range on page 423

• Adding New Drawings to an Existing Template
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Break Down: Cutting the Character in Pieces

If you do not want to redraw all the artwork for your character, you can use the cut away technique where, with
the Cutter tool, you select and send pieces of themodel on a new layer.

The first step in breaking down your character is to do a rough cut down of themain parts, such as the body,
arms, legs and head. Using the Create Drawing fromDrawing Selection feature lets you automatically create
layers and copy your selection in it.

This section is divided as follows:

• Breaking Down theMain Parts on page 401

• Breaking Down the Secondary Parts on page 404

• Selecting and Incorporating to an Existing Layer

• Breaking Down the Extra View Main Parts on page 407

• Breaking Down Secondary Parts in the Extra Views on page 408

Breaking Down the Main Parts

To break down themain body parts, you will use the Create Drawing FromDrawing Selection feature. There is no
need to create any layers prior to this process. Make sure your model is well centered and sized in the Camera
view.

You do not need to make clean cuts around your parts; a rough one is sufficient as long as it includes all the
artwork of the part you want to break down. Youwill clean the extra bits and pieces later.

Using the Cutter tool, you will roughly cut themain sections, and then use the Select  tool to select precise lines
and colour zones.
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How to break down the main parts

1. In the Timeline view, select themodel's cell that corresponds to the first view to break down.

2. In the Tools toolbar, select the Cutter tool.

‣ If you prefer to use the Select tool, choose the Select tool from the Tools toolbar or press Alt +
S.

‣ In the Tool Properties view, you can switch to the Lasso selectionmode.

3. In the Camera view, create a selection around the first part to break down. If you click on a zone, the Cut-
ter tool will select the zone. It will end the selection at the first point of intersection that it meets.

‣ Hold down Shift to create a new lasso selection around another zone and add it to your previous
selection.
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4. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 (Windows/Linux)
or⌘ + F9 (MacOS X).

The Create Drawing FromDrawing Selection dialog box opens.

5. In the Layer Name field, type the name of the layer you want to create following the naming convention you
established previously.

6. Deselect theCut Artwork From Source option to keep the selected artwork on your original drawing.
You do not want to cut the artwork from the colour model.

7. Click OK.

The new layer is created and your selection is copied in it. The drawing is created in the same frame
number as the cell it was taken from.

8. Repeat the previous steps for eachmain body part.
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Breaking Down the Secondary Parts

You should now have a layer for eachmain part of the character for the first view to break down. You are now
ready to break down thosemain pieces into smaller ones.

Breaking down the secondary parts is similar to themain part break down process except that this time you
will cut away the artwork from the layer it has been selected from.

How to break down the secondary parts

1. In the Timeline view, lock your model layer by clicking its Lock button.

2. In the Timeline view, select the cell that corresponds to themain part you want to break down.

3. In the Tools toolbar, select the Cutter tool.

‣ If you prefer to use the Select tool, choose the Select tool from the Tools toolbar or press Alt +
S.

4. In the Camera view, create a selection around the part to break down.
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‣ If you click on a zone, the Cutter tool will select the zone and end the selection at the first point of
intersection that it meets. Click on the line with the Cutter tool to select it up to the next intersection.

5. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 (Windows/Linux)
or⌘ + F9 (MacOS X).

The Create Drawing FromDrawing Selection dialog box opens.

6. In the Layer Name field, type the name of the layer you want to create following the naming convention you
established previously.

7. Select theCut Artwork From Source option to remove the selected artwork from your original drawing.
In this case, you want to cut the artwork from the colour model.

8. Click OK.

405



Chapter 5: Character Building

The new layer is created and your selection is copied in it. The drawing is created in the same frame
number as the cell it was taken from.

9. Repeat the previous steps for each body part.

NOTE:
If you forgot to add some artwork to a layer you previously created, you can always add it later.

In the Camera view, select the artwork to send to the existing layer. Open the Create Drawing from Drawing
Selection dialog box by pressing F9 (Windows/Linux) or⌘ + F9 (Mac OS X). In the dialog box, select an existing
layer from the list instead of typing a new name. Click OK to add the artwork to the existing drawing in the layer
you selected.
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Selecting and Incorporating to an Existing Layer

Your first view should now be completely broken down. If your articulations are still rough and bits and pieces are
missing you will fix those in the next step.

If your character model has more than one view, now is the time to break them down.

The process is very similar to breaking down the first view. You have two choices:

• Breaking down the new view in a net set of layers

• Braking down the new views in the same existing layers
If your layers are not in the correct order, you can reorder them later. Simply add the part that you are
breaking down to the layer you previously created for the same body part.

Start by breaking down themain pieces, as you did before. The secondary parts will be broken down later on.

Breaking Down the Extra View Main Parts

Repeat the following steps for each extra view you need to break down.

How to break down the other views

1. In the Timeline view, selected themodel's cell corresponding to the view to break down. Don't forget to
unlock the layer.

2. In the Tools toolbar, select the Cutter tool.

‣ If you prefer to use the Select tool, in the Tools toolbar select the Select tool or press Alt + S.

3. In the Camera view, create a selection around the first part to break down.
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4. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 (Win-
dows/Linux) or⌘ + F9 (MacOS X).

The Create Drawing FromDrawing Selection dialog box opens.

5. In the Layer Name field, select the corresponding layer from the list if you want to use the same layers or
type a new name if you want to create a new layer.

6. Deselect theCut Artwork From Source option to keep the selected artwork on your original drawing.
You do not want to cut the artwork from the colour model.

7. Click OK.

The artwork is inserted into the existing layer. The drawing is created in the same frame number as the
cell it was taken from. It is not incorporated in the other view's drawings.

8. Repeat step 1 to 7 for eachmain body part.

Breaking Down Secondary Parts in the Extra Views

To break down the secondary parts for your extra views, follow the exact same process as you did for the first
view you broke down, but you will incorporate the new parts in the existing layers—see Breaking Down the
Secondary Parts on page 404.

Each view can have its own set of layers in the Timeline view, therefore each view does not necessarily need to
have the same layer structure.

Here is an example of how your timeline should look at this stage:
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Completing the Parts and Articulation

Now that all the layers are created and the parts are basically broken down, it is time to clean up the parts and
complete the articulation.

Cleaning the Parts

Youwill need to use a series of drawing tools to clean the parts:

• Brush tool

• Eraser tool

• Select tool

• Cutter tool

• Contour Editor tool

• Paint tool

• Close Gap tool
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How to clean your drawings

1. In the Tools toolbar, select the drawing tool you need to fix your drawings.

2. In the Timeline view, select the cell containing the drawing to fix.

3. In the Camera view, delete the extra bits using the Select or Cutter tool. You can also use the
Eraser tool.

4. Draw themissing lines using the Brush tool. If you use the Brush tool, it is recommended that you
enable the Auto-Flatten option in the Tool Properties view.

5. Using the Paint tool, paint the gaps. You can close some gaps with invisible lines using the Close
Gap tool or press Alt + C.
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6. Reshape your lines using the Contour Editor tool or press Alt + Q.

7. Using the Select tool, select the entire drawing and click the Flatten button in the Tool Properties
view to flatten your drawings.

8. From the top menu, select View > Show > Show Strokes to display the invisible lines that could be
present in your drawing or press K.

9. From the top menu, select Drawing > Optimize > Remove Extra Strokes to remove any unnecessary invis-
ible lines in the drawing.

10. Repeat this entire process for each drawing to fix.

411



Chapter 5: Character Building

Break Down: Distribute to Layers

When breaking down a character, you can distribute each selected art stroke to a new layer.

Each stroke you select in the Camera view is automatically placed on a new layer. One layer per stroke.

If one part of your puppet is composed of several strokes, youmust group them before distributing them onto
new layers.

NOTE: You cannot distribute layers in the Drawing view; it must be done in the Camera view.

How to distribute to layers

1. In the Tools toolbar, click the Select tool.

2. In the Camera view, select the art strokes you want to distribute to different layers.

3. From the top menu, select Drawing > Distribute to Layers or click the Distribute to Layers button
in the Tool Properties view.
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Drawing layers are created in the Timeline view, each corresponding to the different strokes or groups of
strokes selected. Each stroke or group of strokes is distributed into each new Drawing layer. The selected
strokes in the original drawing layer are removed.

Converting the Layers into Symbols

NOTE: Converting your layers into symbols is optional. When animating, you will need to enter the symbol to create a
new drawing. If you want to use morphing when animating, keep your layers as drawings. Do NOT use symbols.

Once the breakdown is completed, you can create symbols out of each drawing. The symbol will encapsulate
each drawing of the layer. Later on, even if you only expose the first frame, such as the front head, you will still
have access to all of the head drawings you placed in the symbol. This will also allow you to addmore drawings,
as your characters' master templates will evolve throughout the production of your movie or series.

All your layers should be stored in the library as symbols. Before building your puppet, remove all the current
layers in your scene. All of your work is saved in the library.

If you are not sure that you put everything in your library, you can always perform a Save As on your scene and
work on a new version.
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How to create a symbol

1. Create a symbol by doing one of the following:

‣ From the Timeline view, drag the layer to the Symbols library folder.

‣ In the Timeline view, select the layer to convert to a symbol. From the top menu, select Edit >
Create Symbol or press F8. You can also click on the Create Symbol button available in the Edit
toolbar.

The Create Symbol dialog box opens.

2. In the Enter Symbol's Name field, type the new symbol's name. It is recommended that you keep your
original layer's name.

3. Click OK.

4. Repeat this process for each layer in the Timeline view.

NOTE: Make sure all your layers are stored in the symbol library.
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How to clean the Timeline view

1. In the Timeline view, select all of your layers.

2. In the Timeline's Layer toolbar, click the Delete Layers button.

3. In the ConfirmDelete dialog box, click OK.

Your timeline is now ready to receive the body part symbols for the rigging process.

Your Node view should look like this:
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Patch Articulation

The Harmony advanced rigging can use an articulation fixing technique called Patch Articulation. This
technique is a colour fill patch that is drawn on a third layer and is used to cover the joint lines. It is a simple, yet
powerful method.

With this technique, you avoid having to create a correction layer at the end of the animation to fill the gaps in
the joints. You do not need to worry about the articulations at all. Once a patch is set, the articulation is fixed
for the entire length of the animation.

To make this technique evenmore efficient, Harmony lets you draw the patch inside the same drawing, but on
a separate contained layer. The Line Art and Colour Art layers are not only useful in traditional ink and paint,
but also in advanced cut-out breakdown. You can draw the patch in the Colour Art layer and extract it in the
Node view. The advantage of doing it this way is that when animating and using the drawing substitution, the
patch drawing will change at the same time as themain drawing.

How to create a patch articulation

1. In the Tools toolbar, select the Transform tool or press Shift + T.

2. If you plan to create your patch on an independent layer, do the following. If not, go the next step.

‣ In the Timeline view, add a new drawing layer by clicking the Add Drawing Layer   button or press
Ctrl + R (Windows/Linux) or⌘ + R (MacOS X).
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3. In the Camera view, select the part for which you want to create a patch. For example, if you are fixing the
elbow articulation, select the arm or forearm drawing to edit it.

4. In the Tools toolbar, select the Select tool or press Alt + S.

5. If you drew your lines with pencil lines, it is recommended to convert them to brush lines (fill shapes):

‣ In the Camera view, select the pencil lines.

‣ In the Tools Properties view, click the Convert Brush Strokes to Pencil Lines button.
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‣ In the Camera view, select the piece's outline and fill.

‣ In the Tool Properties view, click the Flatten button to remove the excess colour fill located
under the contour stroke.

NOTE: If you want to keep your lines as pencil and create a patch joint, you will need to use the
Auto-patch Articulations on page 362 node.

6. In the Camera view, select the fill zone of the part's drawing.
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7. In the Camera view, right-click and select Copy.

8. To paste the selection:

‣ If you are using the recommendedmethod, which is to paste your selection in the Colour Art, in the Art
Layer toolbar, click the Colour Art button.
OR

‣ If you are using an independent layer, in the Timeline view, select the cell in which you want to create the
patch.

9. In the Camera view, right-click and select Paste.

10. In the Tools toolbar, select the Cutter tool.

11. In the Camera view, make a selection around the pasted zone to cut everything out but a small overlapping
zone to cover the articulation.

12. To extract the patch from the Colour Art layer:

‣ In the Node view, select the node containing the drawing with the patch.

‣ Copy and paste the selected node. Note that when you copy and paste from theNode view, by default
it creates a clone, so any changes that aremade to one affect the other.

‣ Click on the node's yellow button to open the Layer Properties window.

‣ In the Name field, add the word patch to the node's name.

‣ Close the Layer Properties window.
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13. In the Node Library, select theAll Node tab. Drag a Colour Art node and connect it below the Patch
node.

14. In the Node view, connect themain part you create the patch from and parent it to the patch node.

15. Select the patch node's connection to the Composite node and drag it in front of the piece to be
covered. In this case, the elbow patch is parented to the arm and connected in front of the forearm.
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1. Repeat the process for each articulation which requires fixing.

Setting Different Pivots for a Puppet Using Symbols

If you want the puppet's pieces to rotate correctly, youmust set the pivot points onto the articulations. You can
set the pivots using the Rotate tool which sets it for the entire layer or you can set the pivots directly on your
symbol and have a different pivot for each symbol cell. By default, when you create symbols, the symbol pivot is
located at the centre of your drawing. You will need to move it onto the shoulder or elbow.
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Youwill set the pivot on the symbol's cells, not directly on the drawings. To set your pivots, youmust be at the
top level of your character building scene and not inside the symbols.

By default, when you set the pivot onto a symbol, all the cells use the same pivot. If you need different pivots
for different cells, refer to the following procedure.

Do the following steps for each layer in the Timeline view.

How to set the pivots for the body parts

1. In the Tools toolbar, select the Drawing Pivot tool or select Drawing > Tools > Drawing Pivot.

2. In the Camera or Timeline view, select the symbol on which you want to set a pivot.

3. If you only want to set one pivot for your symbol, in the Tool Properties view, select the Set the Pivot for
Symbol on All Frames button.

‣ Deselect this button if you want to set a series of different pivots for your symbol's cells.

4. In the Camera view, click where you want the pivot to be. You can also drag the pivot marker to the
desired location.
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5. If you want to set a different pivot for another drawing or symbol cell, select the drawing or cell and in the
Camera view, set the new pivot.
Make sure the Set the Pivot for Symbol on All Frames button is deselected.

Setting Pivots on a Frame Range

If you are using the drawing pivots rather than the Rotate tool pivot and if some elements need the same drawing
pivot, such as all of the three-quarter hands, you can select all of these hands cells and set the pivot all at once. If
your pivot is already correctly set on your first drawing, copy and paste that pivot onto the other drawings in the
Timeline or Xsheet view.

Youmust have the same drawing pivots on the extra parts from the same angle. If you substitute a drawing while
the part is rotating, the animation risks popping out of place if the pivot is uneven.

How set the drawing pivot of a frame range

1. In the Drawing or Camera view, set the first drawing pivot of the series. For example, set it on hand-1.
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2. In the Timeline view, select the cell that contains the correct pivot.

3. From the top menu, select Edit > Copy.

4. In the Timeline view, select the cell range that requires the same pivot.

5. From the top menu, select Edit > Paste Special or press Ctrl + B (Windows/Linux) or⌘ + B (MacOS
X).

The Paste Special dialog box opens.

6. In the Paste Special dialog box, select the Advanced tab.

7. In the Drawings section, select theUpdate Drawing Pivot option.
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8. Click OK.

NOTE: You can also copy and paste the pivot from one drawing to another using the keyboard
shortcuts Ctrl + C and Ctrl + V (Windows/Linux) or⌘ + C and⌘ + V (Mac OS X) when the drawing
pivot tool is active and the focus is around the Camera view.

Adding New Drawings to an Existing Template

How to add new drawings to an existing drawing template

1. In the Library view, right-click on the library folder containing the template to modify and select Right To
Modify.

2. In the Library view's right side, right-click on the extra drawings template to modify and select Edit Tem-
plate.

A new instance of Harmony opens.

3. In the Tools toolbar, select a drawing tool.

4. In the Colour view, select a colour.

5. In the template's timeline, select the blank cell where you want to draw your new piece.

6. In the Camera or Drawing view, draw the new pieces.
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7. If you are using drawing pivots, in the Tools toolbar, select the Drawing Pivot tool and in the Cam-
era view, set the pivot directly on the new drawing's cell. If you are using symbols and symbol pivots,
you do not set the pivot on the symbol's cell.

8. From the top menu, select File > Save or press Ctrl + S (Windows/Linux) or⌘ + S (MacOS X).

9. From the top menu, select File > Quit (Windows/Linux) or Stage > Quit Toon Boom Stage (MacOS
X).
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Chapter 6: Deformation

Deformations let you animate bitmap or vector-based graphics, including gradients and textures. Deformations
act as a skeleton with limbs and articulations you can bend, reshape, and curve. You can deform a character made
out of one, or many, drawing or image layers and make it move as if it were a cut-out puppet. This also allows you
to take an area in a single bitmap image and create animation by distortion. A deformation skeleton is composed
of deformation nodes, which are the various pieces (here represented as layers or nodes) required to articulate or
deform your drawings, such as a series of bones, curves or game bones—seeDeformation Nodes on page 488.

NOTE: It's important to note that the deformation feature was completely rebuilt in Harmony 12 to simplify the
process and no longer works like it was in the previous releases. If you would like to convert characters with
deformation chains created in Harmony 11 or before, you can use the TB_ConvertLegacyDeformation.js script to
do so—see Handling Legacy Deformations on page 479.

Main Types of Deformations
These are the types of deformations.
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Bone Deformation

The Bone deformation allows you to create a skeleton structure in which the parent bonemoves the child
bone. The Bone deformation is useful when animating the extremities of a character, such as the arms or legs,
adding fluidity and a natural feel to the animation. It can bemanipulated to rotate a limb at an articulation joint
and to shorten or elongate the extremities of a limb. It's also quite handy for bending the torso.

NOTE: If you are creating a rig to be used in a game, use the Game Bone deformation.

Game Bone Deformation

TheGame Bone deformation is very similar to the Bone deformation and allows you to create a skeleton
structure in which the parent bonemoves the child bone. The difference is that the Game Bone deformation is
optimized to export to game engines, mainly Unity.
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TheGame Bone deformation is mostly used when animating the extremities of a character, such as the arms or
legs, adding fluidity and a natural feel to the animation. TheGame Bone deformation can bemanipulated to
rotate a limb at an articulation joint and to shorten or elongate the extremities of a limb. It's also quite useful for
bending the torso.

Themain differences between the Bone and Game Bone deformations are that the Game Bone deformation
doesn't have the Bias parameter and no regions of influence settings. The rendered result is also different for the
articulation folds. They are slightly rounded.

Curve Deformation

The Curve deformation allows you to deform an image using Bezier handles. For example, when editing curves,
you can deform a straight line into an arc or a zigzag. Curve deformations aremostly used to animate elements
that don't have joints, such as hair or facial features. However, in some cases they can be used to animate limbs
to create a specific animation style, similar to the early rubber hose style of animation with typically simple,
flowing curves without articulation (no hinged wrists or elbows).

Envelope Deformation

The Envelope deformation allows you to deform an image using Bezier handles located all around the contour of
the shape. Envelope deformation chains are composed of Curve deformation nodes. It is regularly used to
deform shapes, such as hair, cloak, shoulder shape, head shape and so on. You can use the Envelope deformation
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to deform a drawing so it looks like it changes from a profile view to a front view to create head and character
rotations using only one set of drawings.

Themain differences between the Curve and Envelope deformers is that the Envelope chain can be closed by
connecting the last Curve deformation node to the initial Offset point. Once connected, theOffset point no
longer repositions the entire chain, only its own control point.

NOTE: It's not recommended to use the Envelope deformations on bitmap images and textures.

430



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

Adding Basic Deformation Chains
Using the Rigging tool, you can quickly create a basic deformation rig. As you create chains, you can automatically
group the deformation nodes to keep your structure clean and organized.

As you create your chains, the controls will be showing. However, whenever you close your project, the
deformation controls display is turned off. When you reopen the project, you can display all controls or only some
of them—see Displaying the Deformation Controls on page 456.

Before adding deformations, youmight want to use a default type of region of influence. You can set these
parameters in the Rigging tool's properties—seeDeformation Toolbar on page 483.

TheNode Library view allows you to manually add the nodes necessary to create the deformation skeleton.
Additional nodes such as the Kinematic Output are available to create advanced rigs.

How to automatically group deformation nodes

1. From the Deformation toolbar, click the Rigging tool.

2. In the Tool Properties view, in the Rig Tool Options section, enable the Automatically Create Group when
Creating a New Deformation Rig option.

This option automatically creates a deformation group connected to the input port of the selected
element. This group includes all the necessary deformation nodes you created.

How to select an element to add deformation to

1. From the Deformation toolbar, click the Rigging tool.

2. In the Node, Camera or Timeline view, select the element on which you want to add a deformation. When
selecting a drawing node, the deformation components will be automatically added on top of the drawing
node. When selecting a peg node, the deformation components will be added below the peg.
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NOTE: Never place a deformation node above a peg node. Having a peg below a deformation node (Bone, Game
Bone, Curve, etc.) will cause unexpected result. The animation on the peg will move the image out of the defined
deformation zone. The same applies to animations created on the drawing layer itself. A drawing layer has an
embedded peg.

3. In the Camera view, create your rig. See the following procedures to learn how to add a specific deform-
ation type.

How to add a Bone or Game Bone deformation chain

1. Once your element and the Rigging tool selected, in the Tool Properties view, enable the Bone
mode or theGame Bonemode depending on your purpose—seeMain Types of Deformations on page
427.

2. Place the cursor at the root of your drawing or group of drawings, click once and release. For example,
on the shoulder.

3. Click again at the location where you want your first bone to finish and your second bone to start. An
articulation control point will automatically be inserted between each bone you create. Note that the
articulation parameters are part of the Bone and Game Bone nodes since Harmony 12.
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4. Repeat this until you are finished creating the Bone chain.

5. If you need to insert a bone between existing ones, hold down the Alt key. When the Insert Bone cursor is
displayed, click on the existing bone segment at the location where you want to add an additional bone.

l Note that you can click on any Bone articulation point to start a new bone chain from that
point. Once the articulation point is selected (white), click on the location where you want to
add a bone and a new bone chain will be created, parented to the previous one.

l When you have several chains controlling the same drawing or group of drawings, a Deform-
ation Composite node is automatically be created and appears in the Timeline view. In the
Additional Links section of the Timeline view, you can see which nodes are connected to the
Deformation Composite.
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6. With the deformation nodes or group still selected, in the Deformation toolbar, click the Reset Current
Keyframe button. This will set the current resting position as the current frame one.

How to add a Curve deformation chain

1. Once your element and the Rigging tool selected, in the Tool Properties view, enable the Curve
mode.

2. Click at the root of your drawing, for example, the shoulder and drag to extend the control handle and
release just as you would when using the Polyline tool—seeDrawing with the Polyline Tool on page 100.

3. Click again at the location where you want the curve to end and drag backwards to extend the second
control handle.

4. Repeat this process until you have finished building the Curve chain.
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NOTE: Note that you can click on any curve point (not the Bezier handle) to start a new curve chain from that point.
Once the control point is selected (white), click on the next location where you want to add a curve and a new chain
will be created, parented to the previous one.

l When you have several chains controlling the same drawing or group of drawings, a Deform-
ation Composite node is automatically be created and appears in the Timeline view. In the
Additional Links section of the Timeline view, you can see which nodes are connected to the
Deformation Composite.

NOTE: The Deformation nodes are stacked on top of each other. You can organize the node system by selecting all
the nodes, clicking the Order Node View Up or Node View Down button.

NOTE: You can click on any curve point (not the Bezier handle) to start a new curve chain from that point. Once the
control point is selected (white), click on the next location where you want to add a curve and a new chain will be
created, parented to the previous one.

5. With the deformation nodes or group still selected, in the Deformation toolbar, click the Reset Current
Keyframe button. This will set the current resting position as the current frame one.
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How to create an Envelope deformation rig

1. Once your element and the Rigging tool selected, in the Tool Properties view, enable the Envelope
mode.

2. Click at the starting point of your drawing shape, for example, the cheekbone and drag the cursor to
extend the control handle and release just as you would when using the Polyline tool—seeDrawing with
the Polyline Tool on page 100.

3. Working as you would with the Curve deformer, continue adding control points around your shape. An
Envelope chain is composed of Curve deformers. You can place your control points slightly outside of
your contour line. As you go, place your cursor over the Bezier handle controls to reposition them. Hold
down the Alt key to move only one of the two Bezier control handles.

4. To close Envelope deformer, hold downAlt and click on theOffset starting point.
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NOTE: You can click on any control point (not the Bezier handle) to start a new envelope chain from that point. Once
the control point is selected (white), click on the next location where you want to add a curve and a new chain will be
created, parented to the previous one.

l When you have several chains controlling the same drawing or group of drawings, a Deform-
ation Composite node is automatically be created and appears in the Timeline view. In the
Additional Links section of the Timeline view, you can see which nodes are connected to the
Deformation Composite.

5. With the deformation nodes or group still selected, in the Deformation toolbar, click the Reset Current
Keyframe button. This will set the current resting position as the current frame one.
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NOTE: It's not recommended to use the Envelope deformers on bitmap images and textures.

How to add a deformation node

1. In the Node Library view, select theDeformation category.

2. From theNode Library view, select a deformation node and drag it to theNode view. Note that the
Glue, MeshWarp, Refract, and Turbulence nodes are not directly related to deformation rigging. You
can read more about these effect in the Compositing and Effects Guide.
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Setting Up the Resting Position
Once you have a deformation chain created, you can optimize its positioning to fit the element it will deform.

A deformation rig has a resting position and an animated position. The resting position is the original pose the
character is in when not animated with keyframes. You can always revert your animated character to its resting
position to recover the initial scale, angle, and shape. You can revert the entire character or only certain
deformation chains, such as the arm or leg. Just make sure your resting position is fully set before deploying the
character in production.

You can also set additional parameters in the Layer Properties window—seeDeformation Nodes on page 488.

To understand better the various parameters available in the nodes' layer properties, you should know more
about the following terms:

• Radius: The radius determines the size of a zone. The radius value is the length from the central point of
the zone to its edge. By increasing the radius value, you increase the size of the area.

• Transversal: The transversal parameter is related to the width of the zone in relation to the bone. The
transversal value cuts across the bone.

• Longitudinal: The longitudinal parameter is related to the length of the zone in relation to the bone. The
longitudinal value is parallel to the bone's length.
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How to set up Bone andGame Bone deformation chains

1. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain
you want to set.

2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others button to dis-
play the deformer controls in the Camera view. This also hides all the deformer controls that were dis-
played.

3. In the Deformation toolbar, click the Rigging tool.

The chain turns from green to red. A green chain indicates the puppet is in animationmode. A red chain
indicates the puppet is in a resting position. Make sure your chain is red.
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4. In the Camera view, set up the deformation chain.

‣ Rotate the first bone to change the angle of the chain.

‣ Use the root control to reposition (offset) the entire chain.
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‣ Use the control points to reposition the articulations. This will elongate, shorten or change the
direction of the bone and offset the subsequent children.

‣ Use the articulation's control (square) to change the size of the articulation. For quality purposes, it
is recommended to have an articulation which fits the diameter of the part it controls.
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5. Repeat until all the articulations and bones of the chain are correctly aligned to the element to which it is
linked. You can also set additional parameters in the Layer Properties window—seeDeformation Nodes
on page 488.

6. With the deformation nodes or group still selected, in the Deformation toolbar, click the Reset Current
Keyframe button. This will set the current resting position as the current frame one.

7. Use the Transform tool. For optimal results, make sure the size of the articulation is approximately the
same size as the drawing.

8. If you need to insert a bone between existing ones, hold down the Alt key. When the Insert Bone cursor is
displayed, click on the existing bone segment at the location where you want to add an additional bone.

How to set up a Curve deformation chain

1. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain you
want to set.

2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others button to display
the deformer controls in the Camera view. This also hides all the deformer controls that were displayed.

3. In the Deformation toolbar, click the Rigging tool.

The chain turns from green to red. A green chain indicates the puppet is in animationmode. A red chain
indicates the puppet is in a resting position. Make sure your chain is red.
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4. In the Camera view, setup the deformation chain.

l Use the Pivot rotation handle to change the angle of the chain.

l Use the Pivot centre control point to reposition the entire chain.

l Use the curve handles to modify the shape of the curve.
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l Use the curve’s square control points to resize and reposition each segment of the curve
chain.

5. Repeat until all the curves of the chain are correctly aligned to the element to which it is linked. You can
also set additional parameters in the Layer Properties window—seeDeformation Nodes on page 488.

6. With the deformation nodes or group still selected, in the Deformation toolbar, click the Reset Current
Keyframe button. This will set the current resting position as the current frame one.

7. Test your modifications using the Transform tool.

How to set up an Envelope deformation chain

1. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain you
want to set.

2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others button to display
the deformer controls in the Camera view. This also hides all the deformer controls that were displayed.

3. In the Deformation toolbar, click the Rigging tool.

The chain turns from green to red. A green chain indicates the puppet is in animationmode. A red chain
indicates the puppet is in a resting position. Make sure your chain is red.
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4. In the Camera view, set up the deformation chain.

l Use the envelope’s square control points to resize and reposition each segment of the
envelope chain.

l Use the curve handles to modify the shape of the envelope.
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5. Repeat until all the curves of the chain are correctly aligned to the element to which it is linked. You can
also set additional parameters in the Layer Properties window—seeDeformation Nodes on page 488.

6. With the deformation nodes or group still selected, in the Deformation toolbar, click the Reset Current
Keyframe button. This will set the current resting position as the current frame one.

7. Test your modifications using the Transform tool.
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Regions of Influence

To increase the quality of your animation and the accuracy of the deformation effect, you canmodify the
regions of influence around the deformation chains. A region of influence is the zone around the deformer
within which art will be influenced by the deformation. The deformer has the power to shape all art contained
within the influence area on its own element or on its children elements.

Zones of influence are different depending on the deformer type and zone type you selected. Note that the
Game Bone deformers do not support regions of influences. Game Bone deformers are set to Infinite and
cannot be changed.

You can find the settings for the zones of influence in the Layer Properties of the Curve, Bone and Envelope
nodes, as well as in the Rigging tool properties—seeDeformation Toolbar on page 483.

There are four types of region of influence:

• Zero: This creates no influence around the deformer.

• Infinite: This is the default option. The influence goes all the way to the image boundaries or until it
intersects with another zone of influence. Whenworking on a cut-out puppet built on several element
layers, the best choice is to keep the default Infinite option as the zone of influence type. In the following
examples, the zones of influence are explained through deformation chains on a single bitmap image.
It's also recommended to keep the regions of influence to Infinite when using Envelope deformers.

• Elliptic: This creates a region of influence following the deformer. Its size is based on a radius value.
When you set up the shape of your Elliptic zone of influence, you should be as accurate as possible and
make sure that only the element you want to follow the deformation is included inside the zone.

• Shaped: This creates a custom region of influence around the deformer that can be adjusted using
control points and Bezier handles. When you set up the boundaries of your Shaped zone of influence,
you should be as accurate as possible and make sure that only the elements that you want to follow the
deformation are included inside the zone.

When you have an Elliptic zone of influence selected in theNode view, you can convert it to a Shaped
zone using the Convert Elliptic Zone of Influence to Shape option.

To illustrate the zone of influence Fade Radius and its effect, the bitmap picture will be swapped with a grid
pattern.
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There is an area called the deformer Fadewhich surrounds the region of influence; this is the link between the
strict boundaries of the zone of influence and the surrounding region. This area gradually stretches or squashes
following the deformation. You can change the Fade Radius value to modify the size of this area and the exponent
of the deformation fade effect.

If you built a custom deformation system from theNode Library view and are using a Deformation-Switch node,
you can change the default behaviour so the fading effect is inside the zone of influence instead of outside. This is
explained in this example.

NOTE: You can also prevent a child’s element from undergoing its parent deformation by connecting it through a
kinematic output—see Assembling Pieces on page 457.

How to select a region of influence type

1. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain you
want to set the region of influence for—seeDisplaying the Deformation Controls on page 456.

2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others button to display
the deformer of the selected piece.
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3. In the Layer Properties window, in the Region of Influence tab, set the Influence Type:

‣ Zero

‣ Infinite

‣ Elliptic

‣ Shaped

How to set up the Elliptic region of influence

1. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain
you want to set the region of influence for—seeDisplaying the Deformation Controls on page 456.

2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others button to dis-
play the deformer of the selected piece.

3. In the Layer Properties window, in the Region of Influence tab, set the Influence type to Elliptic.

4. Set up the ellipse shape by adding values to the various fields:

Influence Fade Radius
This defines the size of the fade area around the actual region
of influence's boundaries—seeHow to modify the Influence
Fade radius on page 454.

Transversal Influence Radius
Left

When the Symmetric Ellipse of Influence option is enabled, this
field controls the Left and Right transversal radius values.
When disabled, it controls the size of the left transversal
radius. By default, this value is set to 2.

Transversal Influence Radius
Right

When the Symmetric Ellipse of Influence option is enabled, this
field becomes inactive. The Left Transversal radius value is
automatically applied to the Right Transversal. When the
Symmetric Ellipse of Influence option is disabled, it controls the
size of the Right Transversal radius. By default, this value is set
to 2.
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Longitudinal Influence Radius
Begin

When the Symmetric Ellipse of Influence option is enabled, this
field becomes inactive. The End Longitudinal value is
automatically applied to the Begin Longitudinal value. When
the Symmetric Ellipse of Influence option is disabled, it controls
the size of the Begin Longitudinal radius. By default, this value
is set to 0.25.

Longitudinal Influence Radius
End

When the Symmetric Ellipse of Influence option is enabled, this
field controls both the Begin and End Longitudinal radius
values. When this option is disabled, it controls the size of the
End Longitudinal radius. By default, this value is set to 0.25.

Symmetric Ellipse Influence

Enabled by default. The shape of the ellipse will be symmetrical
on both the transversal and longitudinal radii. In this case, use
the Transversal Influence Radius Left field to set the transversal
radius value and use the Longitudinal Influence Radius End field
to set the longitudinal radius value. The two other fields will
remain unused unless you disable the Symmetric Ellipse
Influence option. In that case, you can set up different radius
sizes for the four radii directions.

5. You can also modify the elliptic shape in the Camera view using the Rigging tool.

‣ If the Symmetric Ellipse of Influence option is enabled, one control point will be available in the Camera
view. Drag this point in any direction to increase or decrease the size of the Zone. Dragging it left/right
will modify both longitudinal radius sizes. Dragging it up/downwill modify both transversal radius
sizes.
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‣ If the Symmetric Ellipse of Influence is disabled, two control points will be available in the Camera
view. Drag the top-corner point left/right to modify the end longitudinal radius size and up/down to
modify the left transversal radius size. Drag the bottom-corner control point left/right to modify the
beginning longitudinal radius size and up/down to modify the right transversal radius size.

How to convert an Elliptic zone of influence to a shape

1. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain
you want to set the region of influence for—seeDisplaying the Deformation Controls on page 456.

2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others button to dis-
play the deformer of the selected piece.

3. In the Tools toolbar, click the Rigging button.

4. In the Tool Properties view, in theOperations section, click the Convert Elliptic Zone of Influence to
Shape button.

The zone of influence is automatically converted to a shape. The shape is retained and control points
appear around the zone, so you can customize the shape.

How to set up the Shaped zone of influence

1. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain
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you want to set the region of influence for—seeDisplaying the Deformation Controls on page 456.

2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others button to display
the deformer of the selected piece.

If you selected the Shaped option in the Layer Properties window or in the Rigging tool properties, the
zone of influence will be square. This square has control points on all four corners and each control point as
two control levers. If you converted an Elliptic zone to a shape, the zone will havemore control points and
handles.

3. In the Layer Properties window, in the Region of Influence tab, set the Influence type to Shaped.

All radius options are disabled except the Influence Fade Radius option—seeHow to modify the Influence
Fade radius on page 454.

l In the Camera view, use the Rigging tool and drag a control point to redefine its position and
shape.

l Click and drag the control lever handle to modify the corners and redefine the shape.
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l Hold Alt downwhile dragging the control lever handle to move one handle at a time.

How tomodify the Influence Fade radius

1. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain
you want to set the region of influence for—seeDisplaying the Deformation Controls on page 456.

2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others button to dis-
play the deformer of the selected piece.

3. In the Layer Properties window, under the Region of Influence section, adjust the Influence Fade
Radius field to modify size of the fading area. The default value is 0.5.

4. If you built a custom node structure, using deformation nodes from previous versions of Harmony and
are using a Deformation-Switch node, you can also set the fade radius there. In the Node view, select
the Deformation-Switch node under the Deformation-Composite node in your deformation chain.
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5. In the Layer Properties window, set the following options:

Parameter Description

Influence Fade Exponent

Modify the exponent value or type the exact value in the field.

• A value of 1 is similar to a linear curve.

• A higher value will result in an ease-in type of curve.

• A lower value will result in an ease-out type of curve.

Fade Inside Zones
By default this option is disabled, meaning that the Fade effect
will occur outside the zone of influence. You can enable this option
so the fade effect is inside the zone of influence.
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Displaying the Deformation Controls
Before you canmanipulate the deformer outside of the Rigging mode, youmust display the deformation
controls.

If you just created the deformation rig, the controls will still be showing. However, when you close your
project, the deformers are turned off. When reopening a project, youmust display the controls so you can you
see the ones you need while animating.

How to display the selected deformation controls

1. In the Camera, Node or Timeline view, select the drawing layer or deformation group or nodes con-
taining the deformation chain you want to display.

2. Do one of the following:

‣ In the Camera toolbar, click the Show Control button.

‣ From the top menu, select View > Show > Control.

‣ Press Shift + F11.

How to display the selected deformation controls and hide all the others

1. In the Camera, Node or Timeline view, select the drawing layer or deformation group or nodes con-
taining the deformation chain you want to display.

2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others button.

The selected deformation controls appear in the Camera view and all the others are hidden.

How to display all the deformer controls at the same time

1. In the Top level of the Node view or in the Timeline view, select Edit > Select All from the top menu to
select all the nodes or press Ctrl + A (Windows/Linux) or⌘ + A (MacOS X).

2. In the Camera toolbar, click the Show Control button or press Shift + F11.

All deformation controls in scene are displayed.

How to hide the deformer controls

1. Do one of the following:

‣ In the Camera toolbar, click the Hide All Controls button.

‣ From the top menu, select View > Hide All Controls.

‣ Press Shift + C.
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Assembling Pieces
After you have created all the deformation chains for your character, you will need to assemble these separate
body parts into a puppet. Your pieces should be properly overlapping and not set apart.

To avoid problems such as having the head stretched by the neck deformers or a hand modified by the body
deformers, you can use the Kinematic Output node to assemble your pieces without propagating the
deformations down the hierarchy chains.

The Kinematic Output node lets you hook a separate element that you want to be linked to the deformation chain
but not be part of the deformation, such as a hand to an arm or an arm to the body. These elements will follow
themovement of the chain just like a regular cut-out character hierarchy piece without being influenced by the
deformation of the arm. If you don't use the Kinematic Output, the piece's pivot will not follow the deformation.

When building a cut-out puppet with deformations, each part controlled by a deformation chain will automatically
rotate from the chain root point, which acts like a pivot. Because it is unlikely that every piece of your character
will be rigged with a deformation chain, youmust set pivot points for the pieces that are not using
deformations—see Setting the Pivots on page 389.

Assembling Guidelines

When assembling a puppet with deformers, there are some guidelines to keep inmind:

l You cannot parent deformers directly because deformers are not designed to be used on other
deformers. To assemble deformers, youmust insert a Kinematic Output node.
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l Your pegmust be placed above the deformer.

How to assemble a puppet using the Kinematic Output node in the Timeline view

1. Select the element to attach to the Kinematic Output node, such as the hand or head peg.

2. From the top menu, select Insert > Kinematic Output.

The node appears in the Timeline view as a parent of your selection.
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3. In the Timeline view, drag and drop the Kinematic Output layer ONTO the deformation layer you want
your limb or piece to follow. For example, onto the neck deformer if you want your head to follow it
without being deformed or onto the arm deformer if you want your hand to follow.

l If your pieces are no longer ordered properly, use the Z-nudging feature to reorder them—
seeNudging Parts Backwards and Forwards on page 368.

l It's good practice to rename the Kinematic Output layer to reflect which deformer it is
assigned to as the Timeline view can become very large and layers can be positioned far
apart. Select the Kinematic Output node and in the Layer Properties window, rename the
node. You can also double-click on the layer's name.

How to assemble a puppet using the Kinematic Output node in the Node view

1. In the Node Library view, go to the Deformation section, select theKinematic Output node and drag it to
theNode view.
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2. Pull out a second output connection (bottom port) from the deformer node youwant your piece or limb
to follow and connect it to the Kinematic Output port.

3. Connect the Kinematic Output node to the piece you want to follow the deformer.
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‣ If it a good practice to rename the Kinematic Output node to reflect which deformer it is assigned to as
the node structure can become very large and nodes can be positioned far apart. Select the Kinematic
Output node and in the Layer Properties view, rename the node.

‣ You can pull out multiple connections from the same Kinematic Output node if many limbs and pieces
must follow a single deformer. For example, you can use the same Kinematic Output node for both
arms and the neck to follow the body deformer.
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Animating Deformations
The controls to animate deformations work the same as those for setting up the chains. You simply need to
create keyframes and position the control points.

As Envelope deformations are composed of Curve deformations, there aremany similarities in the way they
are animated.

If you need to reset the current pose of the entire chain for the entire scene, you have the possibility to reset
the deformation chain to the resting position on the current or all frames.

When adding new drawings while animating, youmay need to see the reference drawings as their original
resting position as it may be quite difficult to draw on a deformed canvas. You have the possibility to disable
the deformations to see the resting position while drawing. Note that this will not affect the exported images.
It's only a displaymode. You can see the result in OpenGL and Render modes in the Camera view, but the
exported images will always be deformed.

How to animate Bone andGame Bone deformations

1. In the Timeline view, go the frame onwhich you want to create the first animation pose.

2. In the Tools toolbar, select the Transform tool.

3. If you want to create animation keyframes, enable the Animate mode in the Tools toolbar.

4. Do one of the following:

l In the Timeline toolbar, click the Add Keyframe button.

l Right-click and select AddKeyframe.

l Press F6.

A keyframe is added on the current frame.

5. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain
you want to animate—seeDisplaying the Deformation Controls on page 456.

6. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others button to dis-
play the deformer of the selected piece.

7. In the Camera view, do the following:

l Rotate the first bone to rotate the limb.
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l Rotate the subsequent bones to bend the limb.

l Use the root control to reposition (offset) the entire chain.

l Use the control points to reposition the articulations. This will elongate, shorten, or change
the direction of the bone and offset the subsequent children.
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l Use the articulation's control (square) to change the size of the articulation. For quality
purposes, it is recommended to have an articulation which fits the diameter of the part it
controls.

8. In the Timeline view, go the frame onwhich you want to set the next key pose. You will need to expend
the exposure to see your drawings further down the Timeline view.

9. Add a keyframe on the current frame by doing one of the following:

l In the Timeline toolbar, click the Add Keyframe button.

l Right-click and select AddKeyframe.

l Press F6.

10. Repeat the previous steps to animate your character.

You can also manipulate the deformer by typing values directly in the Layer Properties of the
deformation effect nodes.
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How to animate Curve Deformations

1. In the Timeline view, go the frame onwhich you want to create the first animation pose.

2. In the Tools toolbar, select the Transform tool.

3. If you want to create animation keyframes, enable the Animate mode in the Tools toolbar.

4. Do one of the following:

l In the Timeline toolbar, click the Add Keyframe button.

l Right-click and select AddKeyframe.

l Press F6.

A keyframe is added on the current frame.

5. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain you
want to animate—seeDisplaying the Deformation Controls on page 456.

6. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others button to display
the deformer of the selected piece.

7. In the Camera view, do the following:

l Click on the centre of the Deformation-Root pivot and drag it around to reposition the entire
limb.
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l Use the pivot’s square handle to rotate the entire chain.

l Use the square control point located at the extremity of a bone to stretch or shorten its
length.

l Use the curve handles to modify the shape of the curve.
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8. If you have a chain of several curves, you can get all the children of a curve to follow themovement of one
handle. This can be useful when, for example, animating an arm and you don't want the fingers sticking to
their original place while moving the wrist.

l Select the handle you want to move. The handle’s colour turns white.

l Hold Ctrl (Windows/Linux) or⌘ (MacOS X) and move the handle. All the children follow the
movement.

9. If you have a double-sided handle, you can lock it, so only one sidemoves at a time.

l Select the handle you want to move independently from the other. The handle’s colour turns
white.

l Hold Alt and move the handle.

You can also manipulate the deformers by typing values directly in the Layer Properties of the Deformation
nodes.
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How to animate Envelope deformations

1. In the Timeline view, go the frame onwhich you want to create the first animation pose.

2. In the Tools toolbar, select the Transform tool.

3. If you want to create animation keyframes, enable the Animate mode in the Tools toolbar.

4. Do one of the following:

l In the Timeline toolbar, click the Add Keyframe button.

l Right-click and select AddKeyframe.

l Press F6.

A keyframe is added on the current frame.

5. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain
you want to animate—seeDisplaying the Deformation Controls on page 456.

6. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others button to dis-
play the deformer of the selected piece.

7. In the Camera view, do the following:

‣ Move the control points located along the envelope to deform your drawing.
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‣ Use the envelope's control point handles to modify the drawing`s shape.

8. If you have a double-sided handle, you can lock it, so only one sidemoves at a time.

‣ Select the handle you want to move independently from the other.

The handle’s colour turns white.

‣ Hold Alt and move the handle.

You can also manipulate the deformers by typing values directly in the Layer Properties of the Deformation
nodes.
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How to remove keyframes and reset positions

1. In the Timeline view, move the playhead to the framewhere you want to reset the puppet to the resting
position.

2. In the Timeline or Node view, select the deformation group or node youwant to reset.

3. In the Deformation toolbar, click on the Reset Current Keyframe button to reset the position of the
selected chain on the current frame.

l To completely reset the position and remove all keyframes on all frames, click on the
Reset All Keyframes button.

How to disable the deformations to create new drawings

1. In the Timeline or Camera view, create or duplicate your new drawing.

2. In the Deformation toolbar, enable or disable the Enable Deformations button, depending on your
needs.

3. In the Camera view, start drawing.

4. To continue animating, in the Deformation toolbar, reactivate the Enable Deformations button.
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About Deformation Poses (Transformation Chains)

Creating and rigging a full character turnaround can be achieved by creating multiple deformation chains on a
same character without having to create completely different puppets.

For a simplified process, you can keep each view of your character separate in the Timeline or Node view. If you
create separate rigs for each view, then you can simply turn on or off the exposure of each view in the timeline
when needed.

However, if you want to keep the entire character, with all views, in one group/rig on the timeline, then you can
follow the process described here by building a multi-pose deformation rig, also known as multiple
transformation chains.

Preparing the Character

Before building a puppet’s deformation skeleton, youmust prepare your character. The best way to proceed is
to have the limbs on separate drawing layers. This is similar to a standard cut-out puppet preparation, but uses
fewer pieces. Since this is a more advanced type of puppet, you should keep the character’s head, hands, feet,
and facial features on a separate layer from the body, arms, and legs. This will prevent the extremities from being
distorted if the limbs are stretched during an action. It will also let you use drawing substitution to swap hands,
feet, eyes and mouth poses during animation.
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There aremany ways to break down a cut-out puppet. The example described in this chapter uses these
pieces:

• Body • Left Ear • Right Ear

• Head • Left Eye • Right Eye

• Mouth • Left Eyebrow • Right Eyebrow

• Nose • Left Arm • Right Arm

• Left Hand • Right Hand

• Left Leg • Right Leg

• Left Foot • Right Foot

Refer to the following topics to learn how to break down a character:

l About theModel on page 338

l Relative Sizes on page 339

l Studying theModel on page 342

l Breaking Down the Character on page 356

l Adding Extra Drawings on page 387

Understanding the Multi-pose Structure

Each pose (transformation chain) you rig within the same element has to be part of a separate subgroup, all of
which are gathered together by a Transformation-Switch node. The group name is not relevant in themulti-
pose structure. These subgroups can be renamed once the rig is complete. The Transformation-Switch node
uses the drawing name to associate a transformation chain with it. If you rename a drawing after is has been
linked to a transformation chain, you will have to manually change the drawing name associated to the chain in
the Transformation-Switch layer properties. Youmight want to rename your drawing before you start rigging
so the names correspond to the poses. For example: front, side, quarter, etc.
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Renaming the Drawings

Although renaming your drawings is not mandatory, it can prove useful in maintaining a clear node structure for
your project. If you leave your drawing as is and do not rename it, your deformation subgroups could become
slightly confusing. If you plan to have several drawings using the same rig within an element, for instance, drawing
substitution, then you should rename these extra drawings before starting your rig.

How to rename drawings

1. In the Xsheet view, locate the column that corresponds to the element which includes several drawings that
will use the same chain, such as a character that has several costumes which you plan to swap by using
drawing substitution. In our example, wewill use the rabbit’s feet, which will all use the same deformation
curve.

2. In the Xsheet view, select the first drawing of the column. This is the one that will be rigged.

3. From the Xsheet menu, select Drawings > Rename Drawing or press Ctrl + D (Windows/Linux) or⌘ + D
(MacOS X).

4. In the RenameDrawing dialog box, type a relevant new name for the drawing and click OK.

473



Chapter 6: Deformation Animating Deformations

5. In the Xsheet view, select the next drawing in the column and select Drawings > Rename Drawing from
the Xsheet menu.

6. In the RenameDrawing dialog box, type the same name that you gave the first drawing of the column,
exactly as it is written and add and any number. For example, if the first drawing is named front, the
subsequent drawings are named: front_1, front_2, front_3, etc.

7. Repeat steps 5 and 6 for each subsequent drawing that needs to be renamed.

Creating New Deformation Chains (Transformation Chains)
The process of creating multiple deformation chains on the same character is divided in four steps: creating the
main chain, creating additional chains, renaming the chains, and associating additional drawings to the chains.

The drawings are associated with deformation chains. For example, if you want to rig the puppet's arm, you
will need to add a deformation chain to the arm drawing. If the arm has multiple pieces such as upper arm,
forearm and hand, you will create the deformation chain on the upper arm and afterward link the forearm and
hand to that same chain. When creating the additional transformation chains on the other views of your rig,
you will create them on the upper arm. The forearm and hand will not influence which chain is used. They will
follow the upper arm chain. If the drawing exposure is changed on the upper arm, the deformation chain will
change to the associated one. If the forearm or hand exposure is changed, the same deformation chain will
remain. Youmust create the deformation chain on the drawing that will have themost influence when changing
the puppet's view.

After creating your deformation rig, youmay want to convert an animated character's pose to a new
deformation chain. This can be useful when youwant to add a pose to a turn-around deformation rig you have
already spent time creating and manipulating. You can take the pose at the current frame and the state of the
deformations and create a new drawing set along with a new deformation chain using the current position.

How to create the main deformation chain

1. In the Timeline view, make sure the timemarker is set to the frame displaying your first drawing.

2. In the Node view, select the drawing layer containing the drawing youwant to create the chain for. If you
want to create the chain for an arm composed inmultiple pieces, youmust select only one of the draw-
ing layer, such as the upper arm. The additional pieces will be added afterward.

3. In the Deformation toolbar, click the Create New Deformation Chain button.

A new deformation chain is created and appears in the Transformation Chain drop-down list.
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4. In the Deformation toolbar, select the Rigging tool.

5. Create your deformer structure—seeAdding Basic Deformation Chains on page 431.

6. If needed, in the Node view, link the new deformation group to the additional pieces, such as the forearm
and hand.

7. Repeat these steps for all the deformation chains that need to be created on the current puppet's view.

These chains are now the default deformation chains that will be used on all drawings not using a custom
deformation chain.

How to create additional deformation chains

1. In the Timeline view, move the playhead (current frame) to the next character's position.

2. In the Node or Timeline view, select the drawing youwant to set a new deformation chain (transformation
chain) for. If you had previously selected the upper arm in a multiple parts arm structure, select the same
drawing layer (upper arm).
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3. In the Deformation toolbar, click the Create New Deformation Chain button.

A new deformation chain is created and appears in the Transformation Chain drop-down list.

4. In the Deformation toolbar, select the Rigging tool.

5. Create your new deformer structure—seeAdding Basic Deformation Chains on page 431.

How to rename a transformation chain (deformation chain)

1. In the Timeline or Node view, select the drawing layer containing the chains you want to rename. Make
sure your current frame contains a deformation chain.

2. In the Deformation toolbar, click on the Rename Transformation button,

The Rename Transformations dialog opens.

3. Rename the different transformation chains (deformation chains) to match the view they are associated
with.
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4. Click OK.

How to associate a drawing to a transformation chain

1. In the Timeline or Node view, select the drawing layer containing the drawing youwant to link to an exist-
ing deformation chain. The deformation chain has to exist on that same layer. You cannot associate a draw-
ing to a chain created on a different layer.

2. To associate the drawing to the chain, do one of the the following:

‣ In the Deformation toolbar, select the desired chain from the Transformation Chain drop-down list.

‣ In the Node view, select the Transformation-Switch contained in the deformation group and in the
Layer Properties view, type the drawing name in the field corresponding to the desired chain. The
drawing names must be semi-colon separated.

How to convert a drawing to a new deformation chain

1. In the Timeline view, go to the frame youwant to transform into an new pose (deformation chain).

2. Select the drawing youwant to convert and add a new chain.

3. Do one of the following:

‣ From the top menu, select Animation > Deformation > Convert to New Drawing andAdd
Deformation Chain.
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‣ In the Deformation toolbar, click the Convert to New Drawing and Add Deformation Chain
button.

A new transformation is created and added to the list.
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Converting Deformation Animation to Drawings
At times, youmay want to adjust your deformation animation using the drawing tools to perfect something or
add detail. Youmay also want to change the timing and set it on double frame instead of single frame. Harmony
offers you the option to convert your deformation animation to an actual drawing sequence.

How to convert deformation animation to drawings

1. In the Timeline view, select the deformation frame range for which you want to convert to drawings.

2. From the top menu, select Animation > Deformation > Convert DeformedDrawing to Drawings.

The Baking Drawing window opens. Wait for the baking to complete.

Your selection is converted to vector drawings.

Handling Legacy Deformations
Releases prior to Harmony 12 used a different deformation structure. The current structure is simplified.

You can transfer all of the information from first curve deformer to its parent Offset node. This is useful for a
legacy scene created using Curve deformations where theOffset's position has been placed far away from the
drawing to make sure it doesn't affect the drawing's deformation. You can bring back the offset and give it the
first curve's position. The Envelope deformation lets you animate the offset of each curve separately. The offset
no longer needs to be placed far away.
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You can also convert a legacy deformation rig to the new format using a script. You can select which chain you
want to transform. Certain legacy nodes will remain in the structure to make sure the integrity of your original
puppet is maintained.

How to transfer a curve's position to its parent offset

1. In the Node view, select the root Offset and the first curve.

2. From the top menu, select Animation > Deformation > Set Curves andOffsets Independent from
Parent.

3. In the Node view, select only the first curve node.
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4. From the top menu, select Animation > Deformation > Transfer Curve Values to Offset.

In the Node view, the first Curve node is disabled and the values are transferred to the parent Offset node.

How to convert legacy deformation chains to the new structure

1. In the Node or Timeline view, select the deformation group containing the chain you want to convert to the
new structure.

2. In the Scripting toolbar, click on TB_ConvertLegacyDeformation. If the script is not available in the tool-
bar, you can load it.

l In the Scripting toolbar, click onManage Scripts

l In the Script Manager dialog, in the File column, select the TB_CovertLegacyDeformation.js
script. If you cannot find the script in the list (most likely due to a software upgrade install-
ation), you can load the script through the Script Editor view from the default resources
folder—see Importing Scripts in the Scripting guide.

l In the Functions column, select TB_ConvertLegacyDeformation.

l Click the Right Arrow button to move the function to the Scripting toolbar.

481



Chapter 6: Deformation Converting Deformation Animation to Drawings

l Click OK.

The legacy chain is converted.

482



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

Deformation Toolbar
TheDeformation toolbar contains the various tools and options used to create a deformation rig. This toolbar is
displayed in the default interface.

By default, the Deformation toolbar only contains the essential options. If you right-click on the toolbar and select
Customize, you can add additional buttons.

Icon Tool Name Description

Rigging Tool

The Rigging tool is used to create either a Bone or Curve
deformation chain. You also use it to set up the resting
position—seeAdding Basic Deformation Chains on page
431 and Setting Up the Resting Position on page 439.

To learnmore about the Rigging tool's properties, see
Rigging Tool Properties on page 486.

Show SelectedManip-
ulators and Hide All Oth-
ers

The Show SelectedManipulators and Hide All Others
button hides all manipulators displayed in the Camera
view. Only themanipulators of the selected deformation
node are displayed—seeDisplaying the Deformation
Controls on page 456 to learn how to make the
manipulators visible in the Camera view.

Reset Current Keyframe

The Reset Current Keyframe copies the resting position,
the original setup of your skeleton before undergoing any
deformation, to your current frame. Once you have
created a deformation chain, you can use the Rigging tool
to adjust the position and appearance of the rig to fit the
element. When the skeleton is in place, you can use the
Reset Current Keyframe button to reset the current frame
position to the resting position.

Create New Deform-
ation Chain

The Create New Deformation Chain option allows you to
create a new deformation chain on a same character. For
example, if you have drawings for the different views of
your puppet (front, profile, back, etc.), you can use this fea-
ture to setup a new set of chains for each angle without
having to create completely different puppets.

Rename Transformation The Rename Transformation option allows you to give spe-
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cific names to your different transformation chains. By
default, chains are named Transformation plus the number
of the chain, such as Transformation 2. You can rename
these to identify them easier, such as front, side, back, and
so on.

Transformation Selector

The Transformation Selector drop-downmenu allows you
to assign an existing chain to a set of drawings. For
example youmight want to reuse the front deformation
chains for another series of drawing.

When creating a new drawing, the Default Transformation
is assigned. While on the new drawing frames, from the
drop-downmenu, select a different chain to
automoatically assign it.

Enable Deformations

The Enable Deformations button allows you to display
your drawings in their original state or with deformations
while creating additional drawings. Depending on the
artwork you need to create, youmight need to refer to the
other images either deformed or in their original position.

Note that this will not affect the exported images. It's only
a displaymode. You can see the result in OpenGL and
Render modes in the Camera view, but the exported
images will always be deformed.

Convert Elliptic Zone of
Influence to Shape

After you have created a deformation chain using Elliptic
as the Zone of Influence type, you can select your deformer
and click on this button to convert it to a Shaped type.
Control points will appear around the shapemaking it
easy to customize.

NOTE: You can also convert the Elliptic zone of influence
to a shape. From the top menu, select Animation >
Deformation > Convert Elliptic Deformation ROI to
Shape. This will create a much smaller initial zone of
influence than if you were to convert it directly to a shape.

Convert to New
Drawing and Add
Deformation Chain

Takes the pose/drawing and the deformer of the selected
frame and converts it to a new pose/drawing with the cor-
responding deformer.

Remove All Keyframes
The Remove All Keyframes option removes all keyframes
on the selected deformation chain.

Show All Controls

The Show All Controls button lets you visualize the resting
position in red (Setup mode) and the active position
(Animation) in green at the same time—seeDisplaying the
Deformation Controls on page 456 to learn how to make
themanipulators visible in the Camera view.
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Show All Regions of Influ-
ence

The Show All Regions of Influence button displays all
regions of influence in the deformers in your project. Note
that the deformer’s controls must be visible in order for its
zones of Influence to show. The regions will not be
displayed when a deformer’s zone of Influence is set to
Infinite or Zero.

NOTE: Region of influences are not available for Game
Bone deformers.
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Rigging Tool Properties
In the Tool Properties view, you can customize not only the behaviour of the tool but also the settings of the
deformers that you will create.

l Mode on page 486

l Rig Tool Options on page 486

l Operations on page 487

Mode

Name Button Description

AutomaticMode
Sets the Rigging tool to automatically create a Bone or
Curve deformer, corresponding to themovement of the
cursor in the Camera view.

BoneMode Sets the Rigging tool to create Bone deformers.

CurveMode Sets the Rigging tool to create Curve deformers.

EnvelopeMode Sets the Rigging tool to create Envelope deformers.

Game BoneMode Sets the Rigging tool to create Game Bone deformers.

Rig Tool Options

Parameter Button Description
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Show All Manipulators
(Show All Controls)

Lets you immediately see the resting position in red (Setup)
and the animated position in green.

Show All Regions of Influ-
ence

Lets you visualize the area within which the art will be influ-
enced by the deformation effect—see Rigging Tool Prop-
erties on page 486.

Automatically Create
Group when Creating a
New Deformation Rig

This option automatically creates a deformation group con-
nected to the input port of the selected element. This group
includes all the necessary deformation nodes you created.

Bone and Curve Zone of
Influence

The Zone of Influence setting used as the default when cre-
ating an articulation, bone deformer or curve deformer using
the Rigging tool.

Zero Influence: The Zone of Influence does not exist. No
deformation will happen.

Infinite Influence: This is the default option and is themost
commonly used. The Zone of Influence has no boundary and
covers the whole element to which the deformer is linked
and its children, excluding areas that are already part of
another elliptic or shaped Zone of Influence. The Infinite Influ-
ence zone will extend from the centre of your skeleton to
infinity, working perpendicularly to the skeleton.

Elliptic Influence: The Zone of Influence boundary is defined
by an elliptical shape; its size can be customized using the
Bone,or Articulation or Curve node properties or by using
the Transform tool. The Elliptic Influence will most likely be
used on a bitmap picture you want to deform.

Shaped Influence: The Zone of Influence boundary is
defined by a shapewhich you can customize using the Trans-
form tool. The Shaped Influence will most likely be used on a
bitmap picture you want to deform.

Influence Radius: This value is the size of the influence zone.
The default value is 2.

Operations

Name Button Description

Convert Elliptic Zone of Influ-
ence to Shape

After you have created a deformation chain using Elliptic as
the Zone of Influence type, you can select your deformer
and click on this button to convert it to a Shaped type.
Control points will appear around the shapemaking it easy
to customize.

Reset Deform (Reset Current
Keyframe)

Copies the resting position of the deformation skeleton to
the current frame.
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Deformation Nodes
The deformation rigs are composed of several different types of nodes. Additional ones such as the Kinematic
Output node can be used to enhance the results.

From the Insert menu and Node Libray view, you can insert the following nodes.

Articulation (Legacy)

The Articulation node is no longer used in the current release of Harmony. This node is still available for
compatibility purposes with previous deformation rigs.

The Articulation node is used between two bones (legacy) to create a joint where the limb or element will
rotate. The current Bone and Game Bone nodes include the articulation parameters.

Parameter Description

Name Use this field to rename the node.

Resting Parameters

Rest Radius
Lets you set the resting radius of the articulation (size of the
circle).

Resting Orientation Lets you set the resting rotation angle value of the articulation.

Rest Bias

Lets you set the resting bias value of the articulation, which can
also be seen as the steepness of the articulation. The smaller the
bias value, the smoother the articulation angle, and the larger the
bias value, themore angular the articulation is.

Deformation Parameters

Radius
Lets you set the radius of the articulation (size of the circle). When
animated, this value will be connected to a function.
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Orientation
Lets you set the rotation angle value of the articulation. When
animated, this value will be connected to a function.

Bias
Lets you set the bias value, which can also be seen as the steep-
ness of the articulation. When animated, this value will be con-
nected to a function.

Region of Influence

For more information, see Regions of Influence on page 448.

AutoFold

The AutoFold node lets you automatically fix the folding area of a deformer, so no line overlap occurs. If your
drawing pieces are separated on different layers, you will not need the AutoFold node. The AutoFold node is
similar to the Fold node, but since it's automated, it is optimized to fit themost standard folding point with fewer
controls to set up. You can also avoid this issue by separating your drawing onto two layers or separating your
drawing in two pieces using the Cutter tool and repasting it in place in the same drawing.

How to use the AutoFold node

1. In the Node view, navigate to the Deformation nodes causing the unwanted overlap.

2. In the Node Library view, select anAutoFold node and drag it to theNode view.

3. Connect the AutoFold node directly under the Deformation nodewhich is causing the unwanted line effect,
for example the forearm.
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4. Select the AutoFold node and in the Layers Properties view, customize the AutoFold settings.

Parameter Description

Name Name this field to rename the node.

Enable AutoFold

Type 1 to enable it or 0 to disable the effect.

If you connect this option to a function, then you can enable or disable the
effect at a specific point in your animation.

Length

Sets the length of the fold axis line.

Auto-Muscle

The Auto-Muscle node is used to simulatemusclemovement. This will allow your characters to flex their
muscles when they lift something or to createmuscle tone when theymove. When the Auto-Muscle node is
connected to a BoneDeformer that is rotated, the drawing is automatically inflated to simulatemuscle

490



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

movement in the limb.

How to use the Auto-Muscle node

1. In the Node view, navigate to the drawing node to which you want to add an Auto-Muscle effect.

2. In the Node Library view, select anAuto-Muscle node and drag it to theNode view.

3. Connect the Auto-Muscle node above the drawing youwant to add a muscle to and after the Bone chain.

Parameter Description

Name Use this field to rename the node.

Muscle Left

This option is enabled by default. When enabled, the left side of the BoneDeformer will
inflate as the articulation is rotated toward the direction of the BoneDeformer. Disable
this option if you do not want the left side of the bone to inflate.

Left Start

The default value of the starting position of the left muscle is set to -2. This means it will
start at the deformer situated two steps before the position where the Auto-Muscle is
connected. You can change the starting point by typing the number corresponding to
the deformer node.

Left Span
This parameter controls the length (muscle length) over which the effect nodewill be
applied to the left side of the deformer. By default the setting is 1, representing the
length of the deformer to which it is applied.

Left Amplitude This parameter controls the physical size of the left muscle. Increase the value to make
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themuscle bigger, decrease the value to make it smaller.

Muscle Right

This option is enabled by default. When enabled, the right side of the BoneDeformer
will inflate as the articulation is rotated toward the direction of the BoneDeformer.
Disable this option if you don't want the right side of the bone to inflate.

Same as Left

This option is enabled by default, allowing each side of the BoneDeformer to inflate to
follow the rotation of the articulation. Enable this option to synchronize the right muscle
with the left so bothmuscles inflate when the articulation is rotated to the left.

Right Start
The default value of the starting position of the right muscle is set to -2. This means it
will start at the deformer situated two steps before where the Auto-Muscle is
connected, in this case, Bone. You can change the starting point by typing the number
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corresponding to the deformer node.

Right Span
This parameter controls the length (muscle length) over which the effect nodewill be
applied to the right side of the deformer. By default the setting is 1, representing the
length of the deformer to which it is applied.

Right Amplitude
This parameter controls the physical size of the right muscle. Increase the value to make
themuscle bigger, decrease the value to make it smaller.

Bone

The Bone node is one of themain nodes used to build a deformation rig. Each Bone node consists of a bone and
an articulation. You can chain Bone nodes to create a skeleton chain for your character. The Rigging tool can be
used to create and connect those nodes automatically—seeAdding Basic Deformation Chains on page 431.
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Parameter Descriptions

Resting Parameters Rest Offset

(x) Axis This is the bone x-axis (horizontal) coordinates for the resting position.

(y) Axis This is the bone y-axis (vertical) coordinates for the resting position.

Rest Radius
This is the articulation's radius value (articulation size) for the resting pos-
ition.

Rest Orientation This is the bone's orientation angle for the resting position.

Rest Bias
This is the articulation's bias (roundness and smoothness) for the resting pos-
ition.

Rest Length This is the bone's length for the resting position.

Deform Parameters Offset

2D Path
When this option is enabled, the X and Y-axis parameters are controlled by
the same 2D path function.

Separate
When this option is enabled, the X and Y-axis parameters are individual one
from another.

Path When using a 2D Path, this field displays the name of the function.

(x) Axis
This is the bone X-axis (horizontal) coordinates for the animation position.
This parameter can be linked to a function to be animated over time.

(y) Axis
This is the bone y-axis (vertical) coordinates for the animation position. This
parameter can be linked to a function to be animated over time.

Radius This is the articulation's radius value (articulation size) for the animation pos-
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ition. This parameter can be linked to a function to be animated over time.

Orientation
This is the bone's orientation angle for the animation position. This para-
meter can be linked to a function to be animated over time.

Bias
This is the articulation's bias (roundness and smoothness) for the animation
position. This parameter can be linked to a function to be animated over
time.

Length
This is the bone's length for the animation position. This parameter can be
linked to a function to be animated over time.

Region of Influence

For more information, see Regions of Influence on page 448.

Curve

The Curve node is one of themain nodes for building a deformation rig. You can chaining Curve nodes to create a
Bezier handles skeleton. The Rigging tool can be used to create and connect the nodes automatically—see
Adding Basic Deformation Chains on page 431.

Parameter Description

Resting Parameters RestingOffset

(x) Axis This is the curve x-axis (horizontal) coordinates for the resting position.

(y) Axis This is the curve y-axis (vertical) coordinates for the resting position.
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Resting Orientation 0 This is the orientation for the first Bezier handle for the resting position.

Rest Length 0 This is the length for the first Bezier handle for the resting position.

Resting Orientation 1 This is the orientation for the second Bezier handle for the resting position.

Rest Length 1 This is the length for the second Bezier handle for the resting position.

Deform Parameters Offset

2D Path
When this option is enabled, the X and Y-axis parameters are controlled by the
same 2D path function.

Separate
When this option is enabled, the X and Y-axis parameters are individual one
from another.

(x) Axis This is the curve X-axis (horizontal) coordinates for the animation position.

(y) Axis This is the curve Y-axis (vertical) coordinates for the animation position.

Orientation 0 This is the orientation for the first Bezier handle for the animation position.

Length 0 This is the length for the first Bezier handle for the animation position.

Orientation 1 This is the orientation for the second Bezier handle for the animation position.

Length 1 This is the length for the second Bezier handle for the animation position.

Envelope Parameters

Apply Parent Modifier's Trans-
formation

When this option is disabled, the deformation from the parent curves are no
longer affecting the current curve. Interesting effects can be achieved when dis-
abling this effect on the last child curve and rotating theOffset point. The curve
tail end will remain pinned on the spot while the rest of the curves deforms.

Close Contour
When this option is enabled, the extrimity of the curve is snapped to the initial
chain's Offset point. This creates an Envelope deformation. More than one
curve can be linked to theOffset point.

Region of Influence

For more information, see Regions of Influence on page 448.

Deformation-Composite

Just like a standard Composite node, the Deformation-Composite node is used to bring together all the
elements that are connected to it, allowing you to customize parameters that will influence the result of the
output. The Deformation-Composite links the deformation chain to the graphic element to which it is related.
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You can set up the following parameters in the Deformation-Composite Layer Properties window:

Parameter Description

Name Use this field to rename the node.

Output Kinematic Only

This option is disabled by default, allowing the deformation chain to
output deformation and position information. This option should be
enabled in order to output the chain information position only. This will
allow you to connect a part to the hierarchy without it undergoing the
deformation applied to the rest of the chain.

Output Selected Port Only

This option is important if you have several deformation chains for one
element, as in the case of a character withmultiple poses.

• When this option is enabled, it will only use the selected chain,
which you will be able to define in theOutput Kinematic Chain
options of the Deformation-Composite. In some situations, this
option is enabled and setup automatically (For example, when
you are working with the Create Posed Deformer in Create
Deformation Above/Under enabled)—seeAbout Deformation
Poses (Transformation Chains) on page 471

• When this option is disabled, all the different chains for this
element will be used at once.

Output Kinematic Chain
Lets you select a deformation chain option to use. This parameter is
used when theOutput Selected Port Only option is enabled.
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Rightmost: Only the first chain connected to the right of the com-
posite nodewill be used.

Leftmost: Only the first chain connected to the left of the composite
nodewill be used.

Select: If you select this option, you can define which chain to output
according to the order they are connected from left to right.

Use First Connected Element’s Exposure as Key: Allows the deform-
ation effect to automatically detect which deformation chain to use
(subgroup) by detecting the exposure of the first element connected
to the deformation. This option is used in the case of a multiple pose
rig—seeAbout Deformation Poses (Transformation Chains) on page
471

Use Parent Composite’s Connected Element Exposure: When the
Output Kinematic Only option enabled, the information from the par-
ent element’s exposure is used to attach the child to the correct chain,
following which pose is exposed—see

Output Kinematic Chain Selection

When theOutput Selected Port Only option is selected AND the Select
option is used as theOutput Kinematic Chain setting, this field defines
which deformation chain you want to use on your element. Select the
number which corresponds to the left to right order that the chains are
connected to the Deformation-Composite node.

You can attach this value to a function and enable different chains over
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a period of time on specific frames. This value can bemodified in the
Timeline view by using the Deformation-Switch layer. Since the
Deformation-Composite node is only visible in the Node view, the layer
has a reference to this parameter enabling you to easily edit the value
whenworking in the Timeline view.

Deformation-Root (Legacy)

TheDeformation-Root is used when creating manual legacymulti-pose rigs. It can be placed at the start of the
deformation chains. This node is no longer used for the current multi-pose rig structure.

You canmodify the quality level of the Deformation effect in the Deformation-Root Layer Properties window:

Parameter Description

Name Use this field to rename the node.

Quality

Defines the number of slices the graphic is split into and used when undergoing
a deformation. The higher the quality level, themore slices are created and the
smoother the deformation applied to the graphic. There are five levels of
quality:

• Low

• Medium

• High

• Very High (default value)

• Extreme

Deformation-Scale

The deformers can only be scaled along the centre axis to adjust the length of the limb. The Deformation-Scale
can be used in combination with a Bone or Curve deformer to scale a drawing so it follows the opposite direction
of the deformer axis (the width). For example, when combined with function curves this can be used to create
advanced muscle effects. All these settings can be animated over time.

How to set up the Deformation-Scale effect node

1. In the Node view, navigate to the node to which you want to add a Deformation-Scale effect.

2. In the Node Library view, select a Deformation-Scale node and drag it to theNode view.

499



Chapter 6: Deformation Deformation Nodes

3. Connect the Deformation-Scale node directly under the lower deformer node of your chain.

4. In the Node view, select the Deformation-Scale node and select View > Show > Control to display its
controls in the Camera view.

5. Click on the square yellow button of the Deformation-Scale node to open the Layer Properties window.
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Parameter Description

Name Use this field to rename the node.

This series of options controls the left scaling deformation.

Scale Left

This option is enabled by default. It allows the left side of the deformer to be
scaled. In the Camera view, the dark blue controls are used for the left side. If you
disable this option, the controls will be hidden and no scaling deformation will
occur for this side.

Left Fade In
The value is set to 0 (no fade) by default. Increase the value to add a fade effect to
smooth the transition between the starting point of the scale and the area before
it.

Left FadeOut
The value is set to 0 (no fade) by default. Increase the value to add a fade effect to
smooth the transition between the Left Span point of the scale and the area after
it.

Left Start
Defines the starting point of the left scale deformation. The default value is 0 and
represents the Deformation-Root. Eachmain control point count for +1.

Left Span Defines the length of the left scale effect.

Left Start Scale Defines the start of the left scale effect.
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Left End Scale Defines the end of the left scale effect.

Left Start Handle Position Defines the starting position of the left handle.

Left End Handle Position Defines the ending position of the left handle.

Left Start Handle Scale Defines the starting position of the left scale handle.

Left End Handle Scale Defines the ending position of the left scale handle.

Scale Right

This option is enabled by default. It allows the right side of the deformer to be
scaled. In the Camera view, the light blue controls are used for the right side. If
you disable this option, the controls will be hidden and no scaling deformation will
occur for this side.

Same as Left

This option is disabled by default. It means that the left and right sides will use
different scaling parameters. If you enable this option, the right side controls will
be hidden in the Camera view and the left parameters will be used for both side
for a symmetrical scaling effect.

The right side parameters are a mirror of the left side parameters

6. In the Layer Properties window, you can set up all the parameters.

7. In the Tools toolbar, select the Transform tool.

8. In the Camera view, set up the Deformation-Scale node (you can also set these parameters directly in
the Layer Properties window):

‣ To modify the scaling value of the curve, drag the two control handles away and forward from the
deformation axis.

‣ Move the first blue arrow along the deformer’s central axis to set the starting point of the
Deformation-Scale and the last arrow to set the length (span) of the transformation.
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‣ Drag the square scaling curve control points away and forward from the deformer axis to set the
scaling value at the starting and ending point.

‣ Drag the two middle blue arrows along the deformer’s centre axis to set the position of the curve
handles.
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9. You can animate the different parameters of the Deformation-Scale node by enabling the Animate
mode in the Tools toolbar and adding keyframes. In this case, different values will be connected to func-
tions.

NOTE: If the controls are too far away from the deformer, you can change the default display of the Deformation-
Scale and Deformation-Uniform-Scale controls in the Preferences dialog box to bring them closer.

Deformation-Switch (Legacy)

TheDeformation-Switch node acts as a on and off switch for the deformation chain. It is used when building
legacymulti-pose rigs. It is also the nodewhich controls the Region of Influence Fade area. The Deformation-
Switch also displays a Kinematic Chain Selection Reference option, which allows you to modify the chain
selection directly in the Timeline view.

The Deformation-Switch has been replaced with the Transformation-Switch node.

Parameter Description

Name Use this field to rename the node.

Vector Quality Defines the quality of the deformation effect when your drawings are
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stretched and deformed. There are five levels of quality:

• Low

• Medium

• High

• Very High (default value)

• Extreme

Influence Fade Exponent
A value of 1 is similar to a linear curve. A higher value will result in an ease-in
type of curve. A lower value will result in an ease-out type of curve.

Fade Inside Region
This option is disabled by default. The fade effect will occur outside the zone
of influence. Enable this option to have the fade effect inside the Zone of Influ-
ence—see Regions of Influence on page 448.

Enable Deformation
Acts as an on/off switch for the deformation. The value of this field is set to 1
by default, whichmeans the deformation is enabled. Enter a value of 0 to dis-
able it.

Kinematic Chain Selection
Reference

Determines which chain is selected and used at a specific frame. It is a ref-
erence to the option in the Deformation-Composite node. Having this ref-
erence in the Deformation-Switch node allows you to use and modify the
chain selection value directly in the Timeline view since the Deformation-Com-
posite node is only visible in the Node view.

Deformation-Uniform-Scale

TheDeformation-Uniform-Scale effect node let you create the squash and stretch effect on your animated
deformation rig. You can scale the rigged element on the opposite axis of the deformer (width).

How to use the Deformation-Uniform-Scale node

1. In the Node view, navigate to the deformation node to which you want to add a Deformation-Uniform-
Scale node.

2. In the Node Library view, select the Deformation-Uniform-Scale node and drag it to theNode view.

3. Connect the Deformation-Uniform-Scale node directly below the lowest deformation node in your chain.
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4. Connect the Deform-Uniform-Scale node to all the drawing nodes it should scale.

5. In the Node view, select the Deformation-Uniform-Scale node.

6. Display the Uniform Scale controls in the Camera view by pressing Shift + F11—seeDisplaying the
Deformation Controls on page 456.

7. In the Camera view, drag the handle to resize the width of the limb. You can also use the Scale field to
enter a specific value. These parameters can be animated over time.

NOTE: If the controls are too far away from the deformer, you can change the default display of the Deformation-
Scale and Deformation-Uniform-Scale controls in the Preferences dialog box to bring them closer.

Deformation-Wave

TheDeformation-Wave effect deforms the chain by adjusting the scaling in a waveform style. It can be used to
animate a wave deformation effect on your deformation chain over a period of time.
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How to use the Deformation-Wave effect

1. In the Node view, navigate inside the Deformation node to which you want to add a Deformation-Wave
effect.

2. In the Node Library view, select an Deformation-Wave node and drag it to theNode view.

3. Connect the Deformation-Wave node to your deformation chain.

A wave deformation is applied to the limb or art connected to the deformation chain.

4. In the Node view, open the Layer Properties window of the Deformation-Wave node.

5. Set the following parameters in the Deformation-Wave properties:

Parameter Description

Name Use this field to rename the node.

Wave Left
This option is enabled by default, allowing the Deformation-Wave effect to be
applied on the left side of the deformer chain. Disable this option to prevent the
effect from being applied.
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Left Start Defines the length of the left wave effect.

Left Span
Defines the starting point of the left wave deformation. The default value is 0
and represents the root point. Eachmain control point count for +1.

Left Offset Deformer
This is the parameter youmay want to connect to a function. It controls the
offset of the deformation on the left side and allows you to create a fluid wave
animation along the deformer axis.

Left Amplitude Controls the height of the left wave effect.

Left Offset Scaling
Used to apply an offset value to the amplitude of the left wave. The wave will be
lifted and become higher, or dropped and become lower, depending whether
the value is increased or decreased.

Left Period
Controls the interval of occurrence of the left waves. By default the value is 1,
meaning that a wave will occur for every deformer. If you decrease the value to
0.5, it will result in a wave occurring every half deformer.

Wave Right
By default this option is enabled, allowing the Deformation-Wave effect to be
applied on the right side of the deformer chain. Disable this option to prevent
the effect from being applied.

Same as Left
This option is disabled by default. It allows the left and right size of the
Deformation-Wave to be controlled separately. Select this option if you want
the effect to be symmetrical and controlled by the left side parameters.

Right Start
Defines the starting point of the right wave deformation. The default value is 0
and represents the Deformation-Root. Eachmain control point count for +1.

Right Span Defines the length of the right wave effect.

Right Offset Deformer
This is the parameter youmight want to connect to a function. It controls the
offset of the deformation on the right side, allowing you to create a fluid wave
animation along the deformer axis.

Right Amplitude Controls the height of the right wave effect.

Right Offset Scaling
Used to apply an offset value to the amplitude of the right wave. The wave will
be lifted and become higher, or dropped and become lower, depending
whether the value is increased or decreased.

Right Period
Controls the interval of occurrence of the right side waves. By default the value
is 1, meaning that a wave will occur for every deformer. If you decrease the value
at 0.5 it will result in a wave occurring every half deformer.
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Fold

The Fold effect is used when bending a deformation further than the drawing is able to take it. This may result in
an unwanted overlap of the line art at the junction of the articulation or deformation. The Fold effect lets you
control certain parameters that will help eliminate the unwanted line effect. You can also avoid this issue by
separating your drawing onto two layers or separating your drawing in two pieces using the Cutter tool and
repasting it in place in the same drawing.

The Fold effect works best with the Curve deformers.

How to set up the Fold node

1. In the Node view, navigate to the Deformation node causing the unwanted overlap (in this case, an artic-
ulation).

2. In the Node Library view, select the Fold node and drag it to theNode view.

3. Connect the Deformation-Fold node directly under the deformation effect nodewhich is causing the
unwanted line effect.

4. In the Node view, select theDeformation-Fold node.
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5. From the top menu, select View > Show > Control or press Shift + F11 (Windows/Linux) or⌘ + F11
(MacOS X) to display its controls in the Camera view.

6. In the Tools toolbar, select the Transform tool.

7. In the Camera view, set up the Deformation-Fold. You can also set these parameters directly in the
Deformation-Fold properties:

‣ Click on the fold axis and rotate it to match the angle of the bend articulation.

‣ Use themiddle arrow to position the axis along the deformer’s central line. It should be in the corner
of the bending area.

‣ Use the right and left arrows to control the appearance of the two overlapping lines.
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‣ Use the axis’s square handle to lengthen or shorten the axis.

8. If your character moves a lot and you need to adjust the fold at different positions to follow the limb anim-
ation, you can set up the Deformation-Fold node in a different position over time. To do this, enable the
Animation mode in the Tools toolbar and add keyframes. In this case, the different values will be con-
nected to functions.

9. You can also enable/disable the Deformation-Fold node over time by connecting a function to the Enable
Fold parameter in the Layer Properties. A value of 1 enables the effect, a value of 0 disables the effect.
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Game Bone

The Bone node is one of themain node used to build a deformation rig. Each Bone node consists of a bone and
an articulation. Chaining Bone nodes will create a skeleton chain for your character. The Rigging tool can be
used to create and connect those nodes automatically—seeAdding Basic Deformation Chains on page 431.

Parameter Descriptions

Resting Parameters Rest Offset

(x) Axis This is the bone X-axis (horizontal) coordinates for the resting position.

(y) Axis This is the bone Y-axis (vertical) coordinates for the resting position.

Rest Radius
This is the articulation's radius value (articulation size) for the resting pos-
ition.

Rest Orientation This is the bone's orientation angle for the resting position.

Rest Length This is the bone's length for the resting position.

Deform Parameters Offset
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2D Path
When this option is enabled, the X and Y axis parameters are controlled by
the same 2D path function.

Separate
When this option is enabled, the X and Y axis parameters are individual from
each other.

Path When using a 2D Path, this field displays the name of the function curve.

(x) Axis
This is the bone X-axis (horizontal) coordinates for the animation position.
This parameter can be linked to a function curve to be animated over time.

(y) Axis
This is the bone Y-axis (vertical) coordinates for the animation position. This
parameter can be linked to a function curve to be animated over time.

Radius
This is the articulation's radius value (articulation size) for the animation pos-
ition. This parameter can be linked to a function curve to be animated over
time.

Orientation
This is the bone's orientation angle for the animation position. This para-
meter can be linked to a function curve to be animated over time.

Length
This is the bone's length for the animation position. This parameter can be
linked to a function curve to be animated over time.

Offset

TheOffset node lets you position the root of your deformation chain. It is automatically added to your
deformation rig when you create a Curve or Envelope deformation rig using the Rigging tool.

Parameter Description

Name Use this field to rename the node.

(x) Axis Sets the resting position on the X (east/west) axis.

(y) Axis Sets the resting position on the Y (north/south) axis.

Resting Orientation Sets the rotation angle of the resting position.

Offset Type Lets you choose the type of coordinates to use:
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Separate: The two coordinates are set separately. If they are connected to a
function, each onewill have its own function curve. This is the default setting.

2DPath: The two coordinates are set together within a single 2D path function.

(x) Axis

(y) Axis

This option is only available when the Type is set to Separate. It is used to set
the active position value of the Deformation-Root on the X (east/west) and Y
(north/south) axis.

You can enter the value, use the up and down arrow buttons to choose a value,
or use the Transform tool, when Setup mode is NOT enabled, to move the
deformation chain. Remember, that if you want to add a keyframe, you need to
enable Animationmode from the Tools toolbar.

Path

This option is only available when the Type is set to 2D Path. It is used to set the
active position value of both the Y and X axis. Use the Transform tool when
Setup mode is NOT enabled to move the deformation chain along the 2D path.
Remember, if you want to add a keyframe, you need to enable the Animation
mode on the Tools toolbar.

Orientation

Sets the rotation angle of the active position of the Deformation-Root. You can
enter the angle, use the up and down arrow buttons to choose the desired
value, or use the Transform tool when Setup mode is NOT enabled to rotate
the deformation chain. Remember, if you want to add a keyframe, you need to
enable Animationmode on the Tools toolbar.

Apply Parent Modifier's Trans-
formation

When this option is disabled, the parent's deformations no longer affect the cur-
rent deformer.

Kinematic Output

The Kinematic Output node lets you hook a separate element that you want to be linked to the deformation
chain but not be part of the deformation, such as a hand to an arm or an arm to the body. These elements will
follow themovement of the chain just like a regular cut-out character hierarchy piece without being influenced
by the deformation of the arm. If you don't use the Kinematic Output, the piece's pivot will not follow the
deformation.

Connect a Kinematic Output node below the deformation node youwant your drawing to follow.
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Stick (Legacy Bone)

The Stick node is available for compatibility with previous versions of deformation rigs. This node is the legacy
Bone node. When the Stick node is imported in theNode view, it is renamed Bone.

Parameter Descriptions

Rest Length This is the bone's length for the resting position.

Length
This is the bone's length for the animation position. This parameter can be
linked to a function to be animated over time.

Region of Influence

For more information, see Regions of Influence on page 448.

Transformation-Switch

The Transformation-Switch node acts as a on and off switch for the deformation chains. It is used when building
multi-pose (multiple deformation chains) rigs. the Transformation-Switch can also be used with other node types
than Deformation nodes. It can be used with any transformation nodes such as Peg and Quadmap nodes.
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The Transformation-Switch replaces the Deformation-Switch node.

Parameter Description

Name Use this field to rename the node.

Element Columns

Full Name: Select which element to connect to the node from the list of
elements that already exist in your scene.

Drawing Path: Displays the full path to the current drawing.

Timing Columns

Name: Path to the file you want to link to.

Timing Column: Link to the column that contains the desired timing.

Extension: When linking to a background file, enter its file name extension.

Field Chart: If you are importing traditional animation, select the size of the
paper on which the animation was drawn.

Transformation Names
List the drawing names associated to each transformation chain. You can
enter additional drawings and separate the names with semi-colons (;).
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Chapter 7: Library

Using templates and symbols , you can share and reuse any elements you create in Harmony. The Harmony library
lets you store several different elements such as puppets, backgrounds, animations and key poses. In fact,
anything you create in Harmony can be stored in the library.

This chapter contains the following topics:

• Understanding the Library Concept on page 517

• Library View on page 520

• Structuring the Library on page 522

• Templates on page 526

• Symbols on page 530

• Importing Symbols and Templates on page 539

• Importing Files Through the Library on page 544

• Using Paste Special on page 545

Understanding the Library Concept
The Library view is where you can store and reuse your artwork and animation in other scenes or build props and
puppets.

• What is a Library? on page 518

• Understanding the Library Concept on page 517

• What is a Symbol? on page 518

• Libraries in Harmony Server on page 519

517



Chapter 7: Library

What is a Library?

The library is a storage centre for all production assets; the elements stored in the library are called templates.
Although it is mainly used for cut-out animation, the library is also useful for paperless and traditional
animation processes. The library can contain any asset used in a Toon BoomHarmony production.

Using the library is as simple as dragging the content into the library to store your artwork and then dragging
it to the Timeline or Camera view when youwant to reuse it.

You can organize your library using several different subfolders and store them on your hard drive or network.

What is a Template?

A template is an individual copy of the artwork stored in the library which you can reuse in different scenes.
Once a template is stored in the library, you can access it from any project.

Dragging a template into your scene copies the content in your Timeline and does not link it to the original.
You canmodify this individual copy at any time.

What is a Symbol?

A symbol is a container used to build your props, puppets and looping clips. You can use symbols to contain
artwork and animation and manipulate them as a single object. You can also use symbols as a placeholder in
which you place a series of different drawings for each body part of your puppets or when you have a repeating
cycle. However, symbols are not necessary for creating characters.

To create a symbol, drag your artwork to the Symbol library. When you drag a symbol from the Symbol library
into your scene, it will be linked to the original symbol. If you drag a symbol into your scene several times in the
Timeline view, they will all be linked to the original symbol. If youmodify one, they will all bemodified.
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A symbol is local to the project and cannot be accessed directly from other scenes. To reuse a symbol's content in
another scene, youmust create a template out of it.

When a symbol is exposed in the Timeline view, the symbol's cells are represented as a movie strip.

Libraries in Harmony Server

Whenworking on the database, the structure of the library differs fromwhenworking on Harmony Server.

Harmony provides three default library folders:

• Symbols: The only library folder containing symbols for your project. You can organize the symbols library
folder using subfolders, but you cannot create a second library for your symbols. This library is local to
your project.

• Environment: A folder located inside the Environment folder. Every asset stored in this folder is accessible
from any job and scene contained within this environment.

• Job: A folder located inside the Job folder. Every asset stored in this folder is accessible from any scene
contained within this job.

NOTE: You can create a folder called "library"  in the usa_db folder on the server to create a global library. Once the
Harmonyapplication is restarted, a "Global"  library folder will automatically appear in every user's library. Every asset
stored in this folder is accessible from any scene, job and environment.
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Library View

You use the Library view to create and manage your symbols and templates, display the folders and manage
and all of the content.

Library View Menu

The Librarymenu lets you access commands specific to the Library view, such as opening a Library or getting
the rights to modify a library folder.

Preview Window

The Preview window lets you preview the content of a symbol or template, and swap between drawings and
symbol cells in the Timeline view. This window is also used as the Drawing Substitution window.

How to preview a template or symbol's content

1. In the Library view's right side, click or double-click on the symbol or template to preview.

2. In the Preview window, click the Play button or drag the slider to scrub through the frames.
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Library Search Tool

Whenworking on a movie or series, you will probably end up withmany templates and symbols in your library.
Using the Search tool, you can quickly find the templates and symbols in your folders.

How to use the Library Search tool

1. From the left side of the Library view, select the library in which you want to search.

2. In the Search field, type the name or partial name of the symbol or template you are looking for.

3. Click the left and right arrows to see the previous and next results. The Search engine will look for

results within the librarymaster folder and its subfolders. It will not look in other libraries.

Library List

The Library list lets you navigate through the different libraries and subfolders. You can also open, close and
create new libraries from here.

The Library folders have these default libraries:

• Symbols: The only library folder containing symbols for your project. You can organize the symbols library
folder using subfolders, but you cannot create a second library for your symbols. This library is local to
your project.

• Harmony Library: This folder contains templates and is stored on your hard drive. You can organize the
Harmony library folder using subfolders. This folder does not contain symbols.
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Templates and Symbols List

s

The symbols and templates contained in the selected Library list can be displayed on the right side of the
Library view as thumbnails, in a list or as details.

How to access the templates and symbols list display options

‣ In the Library view's right side, right-click and select View > List, Thumbnails or Details.

‣ In the Library View toolbar, you can click the following buttons:

Thumbnails

List

Details

Structuring the Library
As youwill probably create a large number of symbols and templates, you will soon realize they need to be
organized. You can create different libraries and subfolders to easily access your assets. For example, you can
create a different library for each project and divide it into several categories, such as:

• Characters

• Props

• Backgrounds

Although you can only have one symbol library folder, you can organize it by creating subfolders.

There are two ways to create library folders.

• Directly through your operating system

• Using Harmony's interface

Folders can be opened in Harmony when you require it. You can open any folder on your hard drive or network
as a library. Opening a librarymeans linking the folder to your Library view. You only need to open the library
once. The library folder is available every time you open the application until you decide to close the library and
unlink it.
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Youmay not always require all the library folders in the Library List. If so, you can close the ones you do not need.
Closing a folder does not delete it; it only unlinks it from the Library view. If you want to reopen it, locate it on
your hard drive or network and open it in the Library view.

Symbol and template libraries need to be organized. You can create different subfolders on your hard drive or in
the Harmony Library view, so you can easily access assets. By default, any new library you link to your Library view
is locked to prevent accidental deletion or modification of symbols and templates. Youmust obtain the right to
modify it before being able to add a new folder to it.

You can delete a folder from the library if its contents are no longer needed.

NOTE: Warning: All templates and symbols in the folder will be deleted from your hard drive. Once deleted, the data
cannot be retrieved.

Once you add a folder, you can rename it. This also renames the folder on your hard drive.

If you update the content of your libraries through your operating system, you will need to refresh your library
folders in the Library view.

When you display thumbnails in the Library view, the system generates a series of small images (thumbnails) for
you. You can generate template thumbnails yourself, if they do not display or if the process has been stopped.

You can also delete thumbnails if you want to send a template to another user or studio and keep your packages
small.

How to create a library folder through your operating system

1. On your computer, create a new folder with a relevant name in the location where you want the library to
be stored.

How to create a library folder in Harmony

1. In the Library View menu, select Folders > Open Library.

The Browser window opens.

2. Browse for the location where you want to store your new library folder.

3. Click the New Folder button.

A new folder appears.

4. Name the new library folder with a relevant name and click OK.

The new library appears in the Library List section.
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How to open a library

1. In the Library View menu, select Folders > Open Library.

The Browser window opens.

2. Browse to the location of the library folder.

3. Select the folder and click OK.

The new library appears in the Library Folders section.

How to close a library

1. On the right side of the Library view, select the library folder to close.

2. In the Library View menu, select Folders > Close Library.

The library closes.

How to create a folder

1. On the left side of the Library view, select the library folder to which you want to add a subfolder.

2. In the Library View menu, select Edit > Right toModify.

3. In the Library View menu, select Folders > New Folder.

The new folder appears in the Library. Click on the library containing the new folder and click the plus [+]
sign to expand it.

How to delete a folder

1. In the Library view's left side, select the folder to delete.

2. In the Library View menu, select Edit > Right toModify or right-click on the selected library and select
Right toModify.

3. In the Library View menu, select Folders > Delete Folder or press Delete.
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How to rename a folder

1. In the Library view's left side, select the folder to rename.

2. In the Library View menu, select Edit > Right toModify or right-click on the selected library and select
Right toModify.

3. In the Library View menu, select Folders > Rename Folder.

4. Rename the selected folder.

5. Press Enter/Return to validate the operation.

How to refresh a library

1. In the Library view's left side, select the folder to refresh.

2. In the Library View menu, select Folders > Refresh or press F5.

The library displays the new content.

How to generate thumbnails

1. In the Library view's right side, select the template in which you want to generate thumbnails.

2. In the Library View menu, select View > Generate Thumbnails.

The progress bar appears.

How to delete thumbnails

1. In the Library View menu, select Edit > Delete Thumbnails.

All the thumbnails contained in the library are removed.
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Templates

When youwant to reuse artwork and animation from your project in other scenes, youmust create a template
from it. A template can be seen as a portable scene or package that you can drag inside your project. You can
open a template and edit it just like any other project. If you want modify your templates, you can edit them
using the Edit Template command.

You can create a template from both the Timeline and Node views:

• Master Template on page 526

• Creating a Template from theNode View

• Action Templates

• Creating a Template from the Timeline View on page 528

To delete templates from your library, use the Library view. Harmony lets you undo the action if necessary.

Master Template

You can create a master template out of a cut-out puppet you created so you can reuse it throughout a single
project or a full production. A cut-out character's master template stores the entire rig, structure, drawings,
and keyframes of the different poses of your puppet into a single asset.

Master templates are created from theNode view.

Creating a Template from the Node View

The Timeline and Node views display different information about a scene.

Amain character's template, also known as amaster template, is created from theNode view. This template
contains all the connections, effects, composites, nodes, pegs, advanced groupings, function columns, scene
lengths, drawings, timings, and so on. The template is saved in the Library view andmust be imported back
into the scene for use, either into theNode view or the left side of the Timeline view.

NOTE: If you are creating a template from a character rig master template, you should collapse everything inside a
master peg and put a keyframe on the first frame before creating the template.
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How to create a template from the Node view

1. In the Library view, select the folder in which you want to store the template.

2. If the library folder is locked, right-click and select Right toModify.

3. In the Node view, select the nodes for creating the template and group them. It is very important to group
your cut-out character rig before storing it in the Library, so your files are organized.

4. From the top menu, select Edit > Group > Group Selected Layers or press Ctrl + G (Windows/Linux) or
⌘ + G (MacOS X). Make sure you have a composite under the connections before grouping, otherwise
there will be numerous connections going outside the group.

5. In the Node view, click on the group node's yellow button to open the Layer Properties window.

6. In the Node view, select the group node and copy and paste it inside the template folder in the Library
view or press Ctrl + C and Ctrl + V (Windows/Linux) or⌘ + C and⌘ + V (MacOS X).

527



Chapter 7: Library

7. In the Rename dialog box, give the new template a name and click OK.

Action Templates

An action template, also known as animation template, is created from the Timeline view. This template allow
you to reuse animations, key poses and part of an animation and contains mainly keyframes and drawing
exposures. For example, you can reuse head positions or a leg animation from a walk-cycle and place them
inside other animations. When it is extracted from the Timeline view, it loses the extra connections, effects,
and groupings from theNode view.

An action template is used with a master template. It cannot be used on its own since it does not contain all the
information required to rebuild the puppet skeleton and advanced connections. The standard process is to
first import themaster template to theNode view or Timeline’s left side, and then slide the action template
into the Timeline’s right side. This allows you to first build the skeleton and then give it the right pose.

The combination of master and action templates will function as long as the layer order and connections are
the same.

When you create an action template, be sure to name it so you can easily identify it as an animation.

Creating a Template from the Timeline View

How to create a template from the Timeline view

1. In the Timeline view, select some cells or layers.

2. In the Library view, select a folder to store the template.

3. If a library folder is locked, right-click and select Right toModify.

4. Drag the selection to the Stage Library folder or any other library folder.
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5. In the Rename dialog box, give the new template a name.

To rename a template once it is created, right-click on the symbol and select Rename.

6. Click OK.

How to delete a template

1. In the Library view, select the folder containing the template to delete.

NOTE: If the library folder is locked, right-click on the folder and select Right to Modify.

2. Right-click on the selection and select Delete or press Delete.

How to edit a template

1. In the Library view, select the folder containing the template to edit.

NOTE: If the library folder is locked, right-click on the folder and select Right to Modify.
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2. Right-click on the selection and select Edit Template.

A new Harmony application opens.

3. Edit the template.

4. From the top menu, select File > Save.

5. In the top menu, select File > Quit (Windows/Linux) or Stage > Quit (MacOS X).

Symbols

A symbol combines animation, artwork or layers into a single object that you can control in one layer. You can
also create symbols out of each body part in your cut-out puppets.

You do not need to create symbols in order to create drawings or characters in Toon BoomHarmony.

When you delete a symbol, it will be deleted from your hard drive. You can use the Undo function to retrieve
the data. The symbol cannot be retrieved once you close the application.

When you import a symbol from the library to the Timeline view it is linked to the original symbol in the library.
If you import a symbol into your scene several times in the Timeline view, they will all be linked to the original
symbol. If youmodify one, they will all bemodified.

If you want to edit a symbol without modifying the other instances, youmust duplicate the symbol first. If other
symbols are nested inside the new symbol, they are not duplicated. If youmodify them, the original and other
instances will also bemodified.

You can either edit a symbol from the Timeline view or from the Library view.

When you edit a symbol, the drawings contained in it are not placed at the centre of the stage, but are located
in the position where they were created. The pivot is translated at the centre of the symbol.
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When you enter a symbol to edit it, you are entering another scene with an independent timeline. You can nest
many symbols one inside the other. To help you follow the hierarchy of your nested symbol, take note of the
Editing stack at the top of the Camera view which displays the path to your symbol's location. You can click on
the symbol's name to move up the chain.

You can share a symbol and use its contents (the drawings) in another scene. To do this, youmust first convert
your symbol into a template. This conversion breaks the drawing's link with both the original scene and symbol. It
then becomes a separate entity that you can import into other projects.

How to create a symbol from a drawing selection

1. In the Tools toolbar, select the Select or Cutter tool.

2. In the Camera view, select the drawing elements to create a symbol.

3. From the top menu, select Edit > Create Symbol or press F8.

‣ Clicking the Create Symbol button in the Edit toolbar will create a symbol from the entire layer.

The Create Symbol fromDrawing Selection dialog box opens.
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4. In the Symbol Name field, type the name of the symbol.

‣ You can also select an existing layer from the Symbol Name drop-downmenu. It will add your
symbol on the layer's current cell. If there is already an exposure on that cell, the symbol will be
added to a new layer.

5. You can choose to place the current selected artwork in the drawing or remove it:

‣ To remove currently selected artwork from the drawing and place it in the new symbol, select the
Cut Artwork From Source Drawing option.

‣ To keep currently selected artwork in both the drawing and in the new symbol, deselect theCut
Artwork From Source Drawing option.

6. Click OK.

The new symbol appears in the Library view's symbol folder and in the Timeline view as a new layer.

How to create a symbol from the Timeline view

1. In the Timeline view, select the layer or cells fromwhich your want to create a symbol.

2. Do one of the following:

‣ From the top menu, select Edit > Create Symbol.

‣ In the Edit toolbar, click the Create Symbol button.

‣ Press F8.

‣ Drag your selection to the Symbol folder in the Library view.

532



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

The Create Symbol dialog box opens

3. In the Enter Symbol's Name field, type the new symbol's name.

To rename a symbol once it is created, right-click on the symbol and select Rename.

4. Click OK.

The new symbol appears in the Library view's Symbol folder. The current selection is not replaced by the
new symbol. The new symbol only appears in the library. Youmust drag it into your scene to use it.

How to create a symbol from the Node view

1. In the Node view, select the nodes fromwhich you want to create a symbol.

2. Do one of the following:

‣ From the top menu, select Edit > Create Symbol.

‣ In the Edit toolbar, click the Create Symbol button.

‣ Press F8.

‣ Copy and paste Ctrl + C and Ctrl + V (Windows/Linux) or⌘ + C and⌘ + V (MacOS X) your selection
to the Symbol folder in the Library view.
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The Create Symbol dialog box opens.

3. In the Enter Symbol's Name field, type the new symbol's name.

To rename a symbol once it is created, right-click on the symbol and select Rename.

4. Click OK.

The new symbol appears in the Library view's Symbol folder. The current selection is not replaced by the
new symbol. The new symbol only appears in the library. Youmust drag it into your scene to use it.

How to create an empty symbol

1. In the Library view, select the Symbol folder.

2. Do one of the following:

‣ In the Library view's right side, right-click and select New Symbol.

‣ From the top menu, select Insert > Create Empty Symbol in Library.

The new empty symbol appears in the Library view.
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The symbol is ready for you to edit (add content to). To go back to the root timeline, click the Top
button in the Camera view.

To rename a symbol once it is created, right-click on the symbol and select Rename.

How to delete a symbol

1. In the Library view, select the symbol to delete.

2. Right-click and select Delete or press Delete.

‣ If the symbol is currently in use in the scene, a warning message displays. Click OK to delete the symbol
from the library and scene.

How to edit a symbol from the Timeline view

1. Do one of the following:

‣ In the Timeline view, double-click on the symbol's cell to edit the symbol.

‣ In the Camera view, double-click on the symbol or press Ctrl + E (Windows/Linux) or⌘ + E (MacOS
X)).

‣ Click the Edit Selected Symbol button in the Camera View toolbar's extra buttons.
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You are now inside the symbol and you are able to edit it.

2. Do one of the following:

To return to the project's timeline, click the Top button in the Camera view's top-left corner, press Ctrl +
Shift + E (Windows/Linux) or⌘ + Shift + E (MacOS X).

‣ In the Timeline view's right side, right-click and select Symbols > Leave Current Symbol.

How to edit a symbol from the Library view

1. In the Library view, select the symbol to edit.

2. Right-click and select Edit > Edit Symbol or double-click on the symbol.

You are now inside the symbol and you are able to edit it.
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To return to the project's timeline, click the Top button in the Camera view's top-left corner, press Ctrl +
Shift + E (Windows/Linux) or⌘ + Shift + E (MacOS X).

How to duplicate a symbol

1. In the Timeline view, go to the framewhere you want to duplicate the symbol.

2. Select the symbol's cell.

3. From the top menu, select Edit > Duplicate Selected Symbol.

In the Library view, the symbol is duplicated and in the Timeline view, the current cell and its held exposure
is replaced with the new symbol. You can now modify the symbol's content.

How to convert a symbol into a template

1. From the Library view, select the symbol to convert into a template and drag it to the Camera or Timeline
view. If you drop your symbol into the Camera view instead of the Timeline view, it will not be placed in the
centre of your camera frame, but rather wherever your cursor drops it within the camera frame.
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2. In the Timeline view, select the symbol's cells or layer and drag it to the Stage Library folder or to any
other library folder. Make sure you have the right to modify the library folder.

3. In the Rename dialog box, rename the new template.
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4. Click OK.

Importing Symbols and Templates
There are several ways you can import symbols and templates in your scene.

Sometimes a character rig is not a straightforward matter. Rigs, which are usually saved as templates, can contain
symbols such as a leg that was madewith a patch. However, a symbol does not work in the sameway as an
action template. In the Timeline view, you can add an action template into another template of the same
structure. Whenworking on a layer on the right side of the Timeline view and you place a symbol into a symbol of
the same structure, instead of being added to the previous symbol, the new symbol becomes a copy.

For greater control over how the action template behaves when brought into the Timeline view, you can use the
Paste Special feature—seeUsing Paste Special on page 545.

In Harmony, when you import a symbol in your scene, you can navigate through it in the Node view.

Since a template is like a scene, you can open the template's folder and select elements inside it such as drawings.

Instead of importing the entire contents of a template, youmay only want to import a few drawings or a palette.
In this case, use theOpen As Folder command to import the items you want.

If you want to import a palette, simply drag the palette file into the Palette list section of the Colour view.

You can use the Expand Symbol command to extract a symbol's contents and place it on the root timeline. The
symbol will not be removed from the Timeline view. Its contents will be copied and inserted into the root timeline.
The symbol's layers will be parented to it in case you created motions and transformations on the drawing layer
that contains the symbol. Breaking the hierarchy could result in the loss of any scaling and animation youmay have
created.

You can also expand a symbol within a group to avoid crowding the timeline with a series of layers. When you
expand the symbols, the layers will be contained in a group node that you can expand to see the content.

How to import a template into the Timeline or Camera view

1. In the Library view, select the template you want to import.

2. Drag the selected template to the Camera view or to the left side of the Timeline view.
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3. You can also drag a template to the right side of the Timeline view and into existing layers if the layer
structure is the same as the existing one.

How to import a node view template

1. In the Library view, select the template or symbol you want to import.

2. Drag the selected template to theNode or Camera view or the left side of the Timeline view.
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3. If necessary, in the Node view, connect your template to the Composite node. To do this, click its out-port
and drag the connection to the Composite node until an in-port appears.

NOTE: If the template you are importing was created in the Node view, make sure to drop it in the Node view or on
the left side of the Timeline view. Otherwise, some network connections could be broken. If you are importing a
template containing the exact same connections as a template you imported previously, you can drop it on the
Timeline view's right side over the existing layer. This will combine both templates and keep the same existing layers.

How to import a symbol in the Timeline view

1. In the Library view, select the symbol you want to import.

2. Drag the selected symbol to one of the following:

‣ The Timeline view's left side to import it into the centre of the camera frame.

‣ The Camera view to place it at the location where you release your cursor.

NOTE: This may be useful if you saved a character's body parts as separate symbols. If you dropped them into the
Timeline view, then they would all appear in the centre, haphazardly one on top of the other. It would be more
efficient to arrange them into their correct places as you bring them into the scene.
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How to import a template with symbols

1. From the right side of the Library view, select the action template that contains symbols.

2. Hold downAlt (Windows/Linux) or⌘ (MacOS X) as you drag it from the Library view to the right side
of the Timeline view and drop it next to a template with the exact same rig.

The Paste Special window opens.

3. Select theAdvanced tab.

4. Select one of the following options from the Symbols menu:

‣ Copy symbols if they do not exist: This is the default setting for this operation and will prevent
symbols in an action template from being copied.

‣ Duplicate symbols: Makes copies of the symbols in your template.

How to navigate your symbol in the Node view

1. In the Node view, select the symbol you want to open and press Ctrl + E (Windows/Linux) or⌘ + E
(MacOS X) to use the Edit Selected Symbol command.

2. In the Node view, inside the Symbol’s top node is the composition of your symbol. In this example, a
group nodewas turned into a symbol.
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3. In the Node view’s top-left corner, click the Top button to return to the top node. Or press Ctrl + Shift
+ E (Windows/Linux) or⌘ + Shift + E (MacOS X) to use the Leave Current Symbol command.

How to open a template as a folder

1. In the Library view, select the folder that contains the template to open. If the library folder is locked, right-
click on the folder and select Right toModify.

2. Right-click on the selection and selectOpen As Folder.

3. In the library list section, click on the template's folder to display its content.

4. Drag the content to the Timeline or Colour view.

How to expand a symbol

1. In the Timeline view, select the symbol to expand.

2. From the top menu, select Edit > Expand Symbol or press Shift + F8.
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How to expand a symbol in a group

1. In the Timeline or Node view, select the symbol cell or symbol node youwant to expand.

2. From the top menu, select Edit > Expand Selected Symbol in a Group.

3. In the Timeline view, click the plus sign (+) to see the group content. In the Node view, click the Expand
Arrow to enter the group.

Importing Files Through the Library
Harmony lets you import sound files and images directly through the library. Simply open the folder containing
your files in the Library view and drag them directly from there.

How to open a file through the Library

1. In the Library View menu, select Folders > Open Library.

2. Browse for the folder containing the files you want to import.
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3. Click Open.

4. From the Library's template list, drag the file you want to import in the Timeline or Camera view.

Using Paste Special
When you import a template in the Timeline view, all layers are created as well as drawings and keyframes. You
can choose to import only the keyframes without the drawings or import only the drawings that are not already in
your layers. You can adjust the behaviour using the Paste Special dialog box.

When you import a symbol in your scene, its full length is exposed by default. If you import a symbol in the
Timeline view’s left side, all the frames will be exposed. However, if you import it into an existing layer, you can
use the Paste Special dialog box to adjust the import behaviour to fit your requirements.

Once you set the parameters, Harmony will reuse them each time you import a symbol in the Timeline view’s right
side until you set new parameters.

How to open the Paste Special dialog box

1. In the Library view, select the symbol or template to import.

2. Hold downAlt (Windows/Linux) or⌘ (MacOS X) and drag the selection to the Timeline view.

NOTE: Drop the selection in the Timeline view before releasing the keyboard shortcut key.

The Paste Special dialog box opens.

3. Set the parameters and click OK.
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Basic Tab

Parameter Description

Drawings

Only create drawing
files when they do not
exist

When adding exposures to a drawing layer, new drawings will be created
only when drawings with the same name do not already exist in the des-
tination.

Always create drawing
files

When adding exposures to a drawing layer, new drawings will always be cre-
ated. If drawing files with the same name already exist, Harmony will create a
new name for the drawing.

Paste all Frames of the
Symbols (full movie)

When enabled, the Paste Special command exposes all the symbol's frames
instead of only the first one.

Enforce Key Drawings Creates a key exposure on the same drawing.

Cycle

Number of Cycles Lets you set the number of cycles.

Cycle Type

Normal (forward): Pastes your selection as is, starting with the first cell and
ending with the last.

Reverse: Pastes your selection in reverse, starting with the last cell and
ending with the first.

Forward > Reverse: Pastes your selection as a yo-yo, starting with the first
cell, going to the last one and ending with the first cell.

Reverse > Forward: Pastes your selection as a reverse yo-yo, starting with
the last cell, going to the first one and ending with the last cell.
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Advanced Tab

Parameter Description

Drawings

Do Nothing Does not create or overwrite drawings.

Update Drawing Pivot
Revises the drawing pivot in the destination to use the same drawing pivot as
the first drawing in the template. If you have a range of drawings selected in the
destination, the pivot points of all selected drawings will be updated.

Add/Remove Exposure

Never create drawing files: When adding exposures to a drawing layer, draw-
ing files will not be created.

Only create drawing files when they do not exist:When adding exposures to
a drawing layer, new drawings will be created only when drawings with the
same name do not already exist in the destination.

Replace existing drawings. Create drawing files when they do not exist:
Replace drawings with the same names to update a scene with new modified
drawings and preserve the animation.
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Tip: If you don't want to lose the existing animation when pasting
a template, such as when placing new drawings after the
animation, then delete the template's animation. It will still have
updated the drawings but not override the existing animation.

Always create drawing files: When adding exposures to a drawing layer, new
drawings will always be created. If drawing files with the same name already
exist, Harmony will create a new name for the drawing.

Paste all frames of the symbol (full movie): When enabled, the Paste Special
command exposes all the symbol's frames instead of only the first one.

Enforce Key Exposure: If there are key exposures that exist on copied draw-
ings, they are preserved when pasting. No key exposures are added. This is the
default behavior when pasting.

Fill Gapwith Previous Drawing: Fills selected area in the Xsheet or Timeline
view with the previous drawing.

Fill to Next Key Exposure: Fills selected area till the next key exposure.

Add Remove/Keyframes

Motion Copies the properties of the selected motion keyframe to the new frame.

Velocity Copies the properties of the selected velocity keyframe to the new frame.

Rotation Copies the properties of the selected rotation keyframe to the new frame.

Scale Copies the properties of the selected scale keyframe to the new frame.

Skew Copies the properties of the selected skew keyframe to the new frame.

Force Keyframes at
Function's Beginning
and End

Adds a keyframe to the beginning and end of the pasted function, reproducing
the source function.

Offset Keyframes
When pasting functions, offsets keyframes from the function's last frame value
by the values in the pasted function. This will continue the progression of a func-
tion instead of repeating the values.

Options

Palettes

Do nothing: Does not create, overwrite, merge or link palettes.

Reuse palettes. Copy palettes if they do not exist: Palettes in the destination
drawings are left as they are.

Copy and overwrite existing palettes: Overwrites destination palettes with
the palettes from the source drawings.

Copy and create new palette files: Creates new palette files, placing them at
the same relative environment and scene level as the source. If the palettes in
the templates were stored at the environment level of the source scene, the
paste operation will place the palettes in the environment level of the
destination scene.

Copy and create new palette files in element folder: Creates new palette
files in the element folders of the destination scene, rather than in the same
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relative job or environment.

Copy palette andmerge colours. Add new colours only: Adds new colours to
the destination palettes and ignores colours that are the same in the two
palettes.

Copy palettes and update existing colours: Adds new colours to the
destination palette and updates duplicate colours in the destination with colour
values from the source.

Link to original palettes (colour model): Links the colour palettes in the
destination scene to the palettes in the source. Use this to link drawings to the
palettes in a colour model.

Copy scene palettes andmerge colours. Add new colours only: Adds new
colours to the destination scene palettes and ignores colours that are the same
in the two palettes.

Copy scene palettes and update existing colours: Adds new colours to the
destination scene palette and updates duplicate colours in the destination with
the colour values from the source.

Symbols

Copy symbols if they do not exist: This is the default setting for this operation
and will prevent Symbols in an Action template from being copied.

Duplicate symbols: Creates a duplicate of the symbol instead of linking the Sym-
bol instance to the original one. The new Symbol is created in the Library.

Cycles

Normal (forward):Pastes your selection as is, starting with the first cell and end-
ing with the last.

Reverse: Pastes your selection in reverse, starting with the last cell and ending
with the first.

Forward > Reverse:Pastes your selection as a yo-yo, starting with the first cell,
going to the last one and ending with the first cell.

Reverse > Forward: Pastes your selection as a reverse yo-yo, starting with the
last cell, going to the first one and ending with the last cell.

Nodes
Create New Columns: A new column is created when you copy and paste
nodes from theNode view or layer in the Timeline view. If the layers are linked
to function curves, the function curves, drawings and timing will be duplicated.

Elements
Reuse existing elements: Lets you paste existing elements without creating
new ones. This should be used only when pasting within versions of the same
scene.
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Chapter 8: Cut-out Animation

Harmony provides some great tools for animating puppets. You can create simple animation using the Transform
tool, as well as create advanced animation using both forward and inverse kinematics. Harmony has advanced
onion skinning and image swapping features to help you animate efficiently and quickly. For animation freedom,
you have the ability to mix several different techniques of animation, such as simple rigging, hierarchy and symbol
animation.

• Getting the Character on page 552

• Keyframes and Drawing Blocks on page 557

• Creating a Simple Cut-out Animation on page 559

• Selecting Layers to Animate or Position on page 561

• Navigating the Hierarchy on page 564

• Animating Using the Transform Tool on page 565

• Animating Using Inverse Kinematics on page 567

• Animating in Stop-motion on page 582

• Animating Using Computer-generated Interpolation on page 583

• Marking the Timeline on page 589

• Flipping Through Poses on page 592

• Using theOnion Skin in Cut-out Animation on page 593

• Flipping Parts on page 596

• Using Action Templates on page 597

• Swapping Drawings on page 598

• Animating Lip-Sync on page 604

• Adding a New Drawing on page 608

• Ordering Layers Over Time on page 612

• Resetting a Transformation on page 613

• Creating Cycles on page 614
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• Copying and Pasting Animation on page 616

• Adding Pegs on page 618

• Offsetting a Portion of an Animation on page 619

Getting the Character
The first step in animating your character is to import a master template from the library.

In Harmony, you can create your character template from theNode view.

NOTE: If the template you are importing was created in the Node view, make sure to import it first and drop it into
the Node view or the left side of the Timeline view. Otherwise, some network connections may be broken.

How to import a character from the library

1. Create a new Harmony project.

2. In the Library view, select a character master template to animate.

3. Drag the selected template to the Camera or Timeline view’s left side. You can also import a template
directly in the Node view.
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4. In the Timeline view, drag the red scene length bracket to extend or shorten the scene length.

How to import a network template

1. In the Library view, select the template or symbol you want to import.

2. Drag the selected template to theNetwork or Camera view or the left side of the Timeline view.

553



Chapter 8: Cut-out Animation

3. If necessary, in the Node view, connect your template to the Composite node. To do this, click its out-
port and drag the connection to the Composite node until an in-port appears.

NOTE: If the template you are importing was created in the Node view, make sure to drop it in the Node view or
on the left side of the Timeline view. Otherwise, some network connections may be broken. If you are importing a
template containing the exact same connections as a template you imported previously, you can drop it on the
Timeline view's right side over the existing layer. This will combine both templates and keep the existing layers.

How to import a network template (master template)

1. Create a new Harmony project.

2. In the Library view, select the character's master template you want to animate.

3. Drag the selected template in theNode view.
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4. In the Node view, connect the template's group node to the Composite node by clicking its out-port and
dragging the connection to the Composite node until an in-port appears.

5. In the Timeline view, extend or shorten the scene length by dragging the scene length bracket.

Selecting the Pose

If the template you imported contains several poses, youmust choose the pose for starting the animation and
remove the others.

If you created your different views in separate templates, you can import them on separate layers, and turn them
on or off in the Timeline view depending onwhich one you need.

How to select the character's pose

1. In the Timeline view, collapse the character's layers.
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2. In the Timeline view's right side, select the keyframe corresponding to the pose you want to keep.

3. Drag the selected keyframe to the first frame.

4. Select all the extra drawings and keyframes that you don't need and press Delete.

Extending the Exposure

Once you have chosen a pose, all that's left to do is extend the exposure of the character to the end of the
scene.

How to extend the exposure of the character

1. In the Timeline view, collapse the character.

2. In the Timeline view’s right side, select the last cell of the character.

3. Right-click and select Extend Exposure or press F5. You can also copy the first pose and paste it in the
last cell.

The drawing exposure is extended to the end. You will not see any changes in the Timeline view when
themaster peg is collapsed.
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Keyframes and Drawing Blocks
When you extend the exposure of a drawing, it is represented by a grey block in the Timeline view. When you
expose a second drawing, a second grey block is displayed.

You can consider these blocks as drawing blocks.

To animate the position of a block over time, you don't need to create a second block, just add a position
keyframe. The position keyframes are coordinates indicating the position of your drawing on a particular frame.
These appear as black squares in the Timeline view.

In the example below, notice that the keyframes are positioned on frames independently from the beginning and
end of each drawing block.

You can keyframe three different positions for a drawing in the same drawing block and create a motion path
between them.

Creating Keyframes and Drawings in the Timeline View

You can see how the Timeline view behaves differently depending onwhether you create a new drawing, a new
keyframe, or both at the same time.

How to create a drawing in the Timeline view

1. Do one of the following:

‣ From the top menu, select Drawing > Create Empty Drawing.

‣ In the Timeline toolbar, click the Create Empty Drawing button.

‣ Press Alt + Shift + R.
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A new drawing block is inserted.

How to create a keyframe in the Timeline view

1. Do one of the following:

‣ From the top menu, select Insert > Keyframe

‣ In the Timeline toolbar, click the Add Keyframe button.

‣ Press F6.

A keyframe is created in the layer.

How to create a drawing and a keyframe simultaneously in the Timeline view

1. From the top menu, select Insert > Keyframe andDuplicate Drawing.

A drawing block is created which contains copies of the selected drawing and a keyframe.
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Creating a Simple Cut-out Animation

Here is how you can create a simple cut-out animation. Follow these steps so you can try the animation tools
you'll be learning in the next topics.

How to create a simple cut-out animation

1. In the Tools toolbar, select the Transform tool or press Shift + T.

2. In the Tools toolbar, enable the Animate mode so everything youmovewill be keyframed auto-
matically.

3. From the top menu, select Animation > Stop-Motion Keyframe so the interpolation is not created auto-
matically between keyframes.

4. In the Timeline view, collapse your character.

5. In the Timeline view, go to the framewhere you want to set the first pose.

6. To ensure that nothing moves on the new pose, in the Timeline view, select the frame corresponding to the
pose, right-click and select AddKeyframe or press F6.

7. In the Camera view, select the parts to animate.
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8. Use the Transform tool to rotate, skew, scale or translate the selection to its new position. To
rotate the piece, place your cursor slightly outside of a corner until you see the rotation cursor.

A new keyframe appears in the Timeline view if you did not create one previously. Always create your
keyframe first.

9. In the Tools toolbar, enable theOnion Skin feature.

10. In the Timeline view, go to the framewhere you want to set the second keyframe. Youwill need to
expend the exposure to see your drawings further down the Timeline view.

11. To ensure that nothing moves on the new pose, in the Timeline view, select the frame corresponding to
the pose, right-click and select AddKeyframe or press F6.

12. In the Camera view, animate your character.
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13. Repeat this process for all the poses.

Selecting Layers to Animate or Position

When you're animating characters, it's important to understand how the Animatemode allows you to create
keyframes on the current frame or reposition the entire layer.

Animate Mode

The Animate button, in the Tools toolbar, turns keyframing on or off. With this mode enabled, as soon as you
move an element in the Camera view, a keyframe is positioned on the current frame in the Timeline view to
indicate the new position.

When you turn off the Animatemode, and you select and move an element, the entire animation in the layer will
be offset.
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This means that when you are animating a character, youmust enable the Animatemode. If you are scaling
down your puppet to fit the scene composition and want to resize the entire animation, youmust disable the
Animatemode.

How to turn the Animate mode on or off

1. In the Tools toolbar, click the Animate button or select Animation > Animate.

Selecting Drawing Layers Using the Transform Tool

To manipulate the drawing layers in order to animate them, youmust use the Transform   tool. The Select
tool is used to modify the drawing strokes and not the actual drawing layer.

When selecting the drawing layers with the Transform tool, make sure the Peg SelectionMode option is
turned off in the Transform Tool Properties view. Otherwise, if it's left on, it will limit the selection in the
Camera view to pegs only.

How to select using the Transform tool

1. Do one of the following:

‣ In the Tools toolbar, click the Transform tool.

‣ From the top menu, select Animation > Tools > Transform.

‣ Press Shift + T.

2. In the Transform Tool Properties view, make sure the Peg Selection mode is deselected.

3. In the Camera view, select the element to animate.

562



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

Selecting an Element in the Camera View Using the Transform Tool

When you select an element in the Camera view using the Transform tool, make sure the Peg Selection mode
is disabled in the Transform Tool Properties view. The element selected is the actual drawing layer corresponding
to the selected element. If you have a layer parented to a peg, youmust use the keyboard shortcuts to go up the
hierarchy chain, select it in the Timeline view, or enable the Peg Selection mode option in the Transform Tool
Properties view. This will limit the selection in the Camera view to pegs only.

If the layer has child layers, they will also be highlighted. Depending onwhether you're using pegs or only drawing
layers in your rig, the selection can bemagenta, yellow or both.

Selecting a Layer in the Timeline View

When you select a layer in the Timeline view, the corresponding element is highlighted in the Camera view. If the
selected layer has child layers, they are also highlighted.

Selecting in the Network View

As with the Timeline view, when you select a node in theNode view, the corresponding element will be
highlighted in the Camera view. If the selected node has child layers, they will also be highlighted.
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Navigating the Hierarchy
If there is a layer hierarchy in the puppet you built, use the keyboard shortcuts to travel up and down the
parent-child chain. You can also navigate between the children of the same parent.

How to select the parent or child layer

1. In the Tools toolbar, select the Transform tool.

2. In the Transform Tool Properties view, make sure the Peg Selection mode is deselected.

3. In the Camera or Timeline view, select a layer attached to a hierarchy.

4. From the top menu, select Animation > Select Parent or press B to select the parent layer. Select
Animation > Select Child or press Shift + B to select the child layer.

NOTE: These keyboard shortcuts ignore any effect node encountered in the Node or Timeline view. Only drawing
and peg nodes are considered. If you want to navigate the hierarchy including the effect nodes, you can create a
custom keyboard shortcut in the Preferences dialog box for the Select Parent Skipping Effects and Select Child
Skipping Effects commands on the General tab. Refer to the Harmony Preferences Guide to learn how to create
custom keyboard shortcuts.

How to select the children layers

1. In the Tools toolbar, select the Transform tool.
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2. In the Camera or Timeline view, select a layer attached to a parent layer with several children or not par-
ented at all.

3. From the top menu, select:

‣ Animation > Select Previous Sibling or press / to select the previous child layer.

‣ Animation Select Next Sibling or press ? to select the next child layer.

‣ Animation > Select Children to select all child layers at the same time.

Animating Using the Transform Tool
The Transform tool is themain tool to use whenworking with a cut-out character. The Transform tool has many
useful functions:
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Using the individual Rotate, Translate, Scale and Skew tools is not recommended, as theymove each piece
from their own pivot point. They are compositing tools. The Transform tool creates a global selection, so
whenmany parts are selected, you canmove them as one unit. The Transform tool is highly recommended for
cut-out animation.

When animating with the Transform tool, make sure to select the right selectionmode. In this example, make
sure that the Peg Selection Mode is disabled in the Tool Properties view or it will limit the selection in the
Camera view to pegs only.

If there are hierarchy connections in the cut-out character, the Transform tool will also be used as the Forward
Kinematics equivalent.

The Transform tool can be used on any kind of rigging.

Whenmany parts are selected with the Transform tool, the first selected part's pivot will be used as the global
selection's pivot. This pivot can bemoved temporarily for the animation. When you offset the pivot, the
permanent pivot is displayed as a ghost.

NOTE: The interpolation of the animation poses is always calculated from each individual part's permanent pivot. If
there's a parent peg on a limb, make sure to select it instead of making a selection of each part to avoid setting
individual keyframes.

How to use the Transform tool

1. In the Tools toolbar, click the Transform tool or press Shift + T.

2. In the Transform Tool Properties view, make sure the Peg Selection mode is deselected.

3. In the Timeline view, go to the frame onwhich you want to set the first position.

4. In the Timeline toolbar, click the Add Keyframe button or press F6. It is recommended to add a key-
frame beforemoving the character. Moving a character's part without setting a keyframewill create
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keyframes only on certain parameters of the animation. You could run into issues later on when setting
poses between existing ones. Creating a keyframe on all layers and parameters will ensure your pose is set
and will not bemodified by other poses later on.

5. In the Camera view, select the element to animate and move it.

6. In the Timeline view, go to the framewhere you want to set the next position.

7. In the Timeline toolbar, click the Add Keyframe button or press F6.

8. In the Camera view, animate the character.

Animating Using Inverse Kinematics

The Inverse Kinematics (IK) tool allows you to pull on a character's extremities, such as the hands and feet, and
have the rest of the body follow. It can be used on any piece connected in a hierarchy. However, you don't have to
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use IK every time you have a hierarchy rig. This tool is useful when youwant to bend a character's knees, make
it sit and move the rest of the body, and so on. It will also assist you with posing difficult moves.

In most 3D animation software, Inverse Kinematics is implemented as a skeleton system. Harmony uses the
rigging hierarchy already created in the Timeline view, so there is no need to place bones in the character.
Inverse Kinematics in Harmony uses the connection between each of the parts' pivots.

Inverse Kinematics will not work on basic rigs without hierarchy because there is no hierarchy chain present. IK
only works on a hierarchy where the pivots are properly set.

When animating a hierarchy puppet, you will use both the Transform and Inverse Kinematics tools.

• About IK Hierarchy Chains on page 568

• Where to Start with Inverse Kinematics? on page 569

• Inverse Kinematics Tool Properties on page 571

• Setting Up the Character to Use IK on page 573

• Nails on page 576

• Minimum andMaximumAngle on page 577

• IK Keyframes on page 578

• When to Use the Inverse Kinematics (IK) Tool on page 580

About IK Hierarchy Chains

Before going any further, a word about IK chains. There are three types of chains:

• Single Chains on page 568

• Direct Chains on page 569

• All Chains

Single Chains

The single chains are themost basic of chains. A single chain is a straight line with no secondary chain attached.
It goes up to the first intersection.
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Direct Chains

Adirect chain is a single chain which goes directly to the core (root).

All Chains

All chains are attached andmove together when one part is moved.

Where to Start with Inverse Kinematics?

Inverse Kinematics works best when you lock a part of the character on the spot, such as a foot on the floor, then
select the entire body or another extremity and move it. It also works well in single chainmodewhen you need to
simply position a limb.

NOTE: Tip: To lock a part in place, use the IK Nail option—see Nails on page 576.

How to use the Inverse Kinematics tool

1. In the Tools toolbar, select the Inverse Kinematics tool or press Shift + I.

2. In the Camera view, Ctrl + click (Windows/Linux) or⌘ + click (MacOS X) on a part of the body.
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The entire IK skeleton appears.

3. Click on a part of the body and pull on it to move the character.

4. Hold down the Shift key and click on the pivot belonging to the part you want to lock in place.You can
Shift + click on a bone to lock the orientation of the bone.

5. Click on another part of the character and pull on it.
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Inverse Kinematics Tool Properties

Mode

The IK tool has a series of different modes available in the Tool Properties view.

Mode Button Description

Bone Selection

Enabled by default, this mode lets you click on any bone in a character
and move it without having to select the actual layer.

When you disable this mode, you cannot move any bone except the
selected one. This allows you to grab and rotate the selected part
frommany angles and locations. You can click completely outside the
character and move the pieces.

Chain

• Simple Chain Mode: This is the default mode and will only
allow for themovement of parts attached to a single chain up
to the point of intersection. A single chain is a straight line with
no secondary chain attached.

• Direct Chain Mode: This mode allows you to move parts
up a simple secondary chain to a principle chain, as long as
translationmovement is possible (the principle chain is
attached to its own peg), but will ignore all secondary chains. A
direct chain is a single chain which goes directly to the core.

• All Chain Mode: This mode allows you to move all parts
attached to all chains in the IK skeleton. All chains are attached
andmove simultaneously when one part is moved.

IKManipulation

Themain working mode for the IK tool. Enable this modewhen you
want to animate and position a puppet.

Ctrl + click (Windows/Linux) or⌘ + click (MacOS X) on a body part
to select it. You do not need to select a part to be able to move it.

Apply IK Constraints
Lets you correct a part's position on a series of frames. For example,
if the character's foot is sinking into the floor, you can correct its pos-
ition and angle over a series of frames.
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Edit Min/Max Angle
Lets you set a rotation restriction on some of your parts, such as
elbows, knees and ankles.

Bone Editing
Lets you fix the bone orientation on extremities, such as hands and
feet.

IK Options

Parameter Description

IK Keyframe
Used in combination with the IK Constraints mode, this option determines
the starting frame of the constraint you will apply.

Ease Shape While animating with the IK tool and before doing a movement, set an easing
preset so themotion is not so mechanical.

Beforemoving the part, select a preset from the Ease Shapemenu:

If you select a new preset in the list and move the part again on the same
keyframe, the easing will automatically update.

Selection

Parameter Description

Enable Translation If Top of
Hierarchy
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Used only onmaster pegs. This option is useful when you have this particluar
situation: You want the character to do a perfect split (sitting downwith the
legs at right angles to the body or at the sides with the torso facing for-
wards), then the hip will need to translate and not just rotate on the spot.
And since IK is all about rotation, you would select the hip layer and enable
the translation option.

Enable Rotation

This option is enabled by default. The pivot disappears but you can still see
the bone. When this option is disabled, the selected part cannot be rotated
and will remain in the same position. You can use this option to simulate an
arm in a plaster cast.

Exclude from IK
This option lets you exclude certain parts of the puppet from the IK influence,
such as the eyes and mouth.

IK Nails
These options let you temporarily fix a part of a character to a spot either in
translation or rotation, or enablemaximum andminimum angle usage.

Stiffness

When a certain part is selected, you can apply a stiffness value to it. A dif-
ferent stiffness value can be set to each body part individually. The greater
the stiffness, themore difficult it is to make that part rotate, thereby ren-
dering it stiff while the other parts continue to move freely on their joints.

Setting Up the Character to Use IK

The first time you display the character's skeleton, notice a series of bones on the extremities which are out of
place. Theremay also be some elements that you would like to exclude from the IK chain.
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It is highly recommended to set up the skeleton before starting your animation.

Before fixing any bones, or excluding layers from the IK skeleton, make sure all the elements you want to be
parented in a chain are set up.

You do not need to have hierarchy chains all over the body. They could exist only on the legs and arms. If the
body is not completely rigged in hierarchy, the skeleton will look a bit moremessy, but the IK tool will still work
properly.

Whenworking with the IK tool, you will probably want to move themain parts around, but not necessarily the
small ones such as the nose or ears. To do this, you can select some elements on your character and exclude
them from the skeleton.

Once you remove the extra elements from the skeleton, set the bone orientation for the extremity parts. By
default, they are oriented horizontally towards the right. This orientation often works for the feet but not
necessarily for the hair or hands.

How to exclude elements from the skeleton

1. In the Tools toolbar, select the Inverse Kinematics tool or press Shift + I.

2. In the Tool Properties view, make sure the IKManipulationMode is enabled.

3. In the Camera view, Ctrl + click (Windows/Linux) or⌘ + click (MacOS X) on the part to exclude from
the skeleton.
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4. In the Tool Properties view, click the Exclude from IK button.

5. Repeat the process for every part to be excluded from the skeleton.

How to set the bone orientation

1. In the Tools toolbar, select the Inverse Kinematics tool or press Shift + I.

2. In the Tool Properties view, enable the Bone Editing mode.

3. In the Camera view, click on the pivot belonging to the part whose bone youwant to reposition, then pull
the pivot in the desired direction.

4. Repeat this process for each bone youwant to position.
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NOTE: This command only works on the extremities.

Nails

Often, you will want to animate only part of a character, such as the arm and not the entire body. You can do
this using IK nails, which are IK constraints that temporarily cut or constrain the chain. With IK nails, you can cut
an IK chain or block a part on the spot. For example, you can fix a character's feet to the ground when it walks.

There are different types of constraints you can place on the chain:

• IK Nail: Blocks the X, Y and Z positions.

• HoldOrientation: Blocks the angle.

• Hold X: Blocks only the X position.

• Hold Y: Blocks only the Y position.

• Enable Maximum andMinimum Angles: Sets limitations on the angle parameter to prevent the
puppet from bending too far.

How to set an IK nail

1. In the Tools toolbar, select the Inverse Kinematics tool or press Shift + I.

2. In the Tool Properties view, make sure the IKManipulationMode is enabled.

3. In the Camera view, Ctrl + click (Windows/Linux) or⌘ + click (MacOS X) on the part to set a nail on.

4. In the Tool Properties view, select a type of nail:

‣ Hold the Shift key and click on any part's pivot to set a regular nail on it without having to select it.

‣ Hold the Shift key and click on the bone to set a Hold Orientation nail.
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‣ Select the nail type in the top menu by selectingAnimation > IK Constraints > desired nail.

‣ Remove the nail at any time using the same technique you did for placing the nail. It will not affect the
animation.

5. To remove all nails except the EnableMin/Max Angle ones, from the top menu, select Animation > IK Con-
straints > Remove All Constraints.

Minimum and Maximum Angle

Harmony allows you to set a minimum andmaximum angle constraint on certain joints, such as the knees or
elbows. When using the Inverse Kinematics tool or even the Forward Kinematics (Transform tool), it is possible
that some joints will bend in the wrong direction.

If you plan to animate a lot with the Inverse Kinematics tool, it's a good idea to try the angle constraints. The
angle constraints can be set by the character builder or by the animator in particular scenes where it's needed.

NOTE:
It is recommended to use the minimum and maximum angles only if the character does not change view within the
same layers. For example, if a character is facing the camera and has some angle limitations enabled, it could be
problematic if the character switches to side or quarter view since the joints won't bend the same way.

Use the minimum and maximum angle constraints if your character's views are in different templates or layers. If the
character's views are in the same layers, then it's better not to use the angle constraints.

How to set the minimum andmaximum angles

1. In the Tools toolbar, select the Inverse Kinematics tool or press Shift + I.

2. In the Tool Properties view, in theMode section, make sure the Edit Min/Max AngleMode is enabled.
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3. In the Camera view, Ctrl + click (Windows/Linux) or⌘ + click (MacOS X) on the piece to set themin-
imum andmaximum angle.

4. In the Tool Properties view, in the Selection section, click the EnableMin/Max Angle option.

5. In the Camera view, rotate theMinimum andMaximum handles to set the angle.

6. Test the angles using the IKManipulation mode.

7. For additional control over theMin/Max Angle, go to Edit > Preferences (Windows/Linux) or Stage >
Preferences (MacOS X). Select theCamera tab. In the Inverse Kinematics section, look at theMin/Max
Angle Constraint Weight. Although themaximum value goes up to 1.0, in a production setting, the
most practical value would be closer to 0.1. This value acts similar to the Stiffness setting in the Tool
Properties view. The higher the value, themore difficult it becomes to approach theminimum andmax-
imum values.

IK Keyframes

When you animate a walking character and lock the feet down, the locked position will be perfect on the key
poses. However, when you usemotion keyframes to auto in-between the animation, you'll notice a movement
of the feet. This motion is caused by the in-betweening of the rotations.
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The nail holds in place the body part on the keyframe, but it will not hold it for the entire duration between
keyframes.

If you place a nail on the shoulder to move just the arm, you don't necessarily want to keep the shoulder in the
same place until the next key pose. You will probably want the shoulder, or any other part that is nailed, to have a
slight, natural motion following themain body action. Of course, this is not the case when you fix a hand or a foot
on the spot. If you have a fixed hand or foot, you will probably want it to stay exactly where you placed it. That is
why you can apply an IK constraint on a frame range and on selected body parts.

To fix the part on the same spot requires an angle (rotation) correction on the parts that aremoving too much.
For example, to fix a foot that is moving too much, youmust correct the angles on the foot, leg and thigh. To fix a
hand, youmust correct the angles on the hand, forearm and upper arm.

How to apply IK constraints on a frame range

1. In the Tools toolbar, select the Inverse Kinematics tool or press Shift + I.

2. In the Camera view, click on the part on which you want to apply the constraint.

3. In the Timeline view, select the first frame onwhich you want to start applying the constraint.

4. In the Tool Properties view, enable the Apply IK Constraints mode.

5. In the Tool Properties view, click the IK Keyframe button to enter the first frame number.

6. In the Timeline view, move the playhead to the last frame onwhich you want to apply the constraint.

The IK Keyframe field should now look like this:

7. In the Camera view, set a nail at the top of the limb you are correcting. For a foot, set the nail on the thigh
by holding down the Shift key and clicking its pivot.
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8. In the Tool Properties view, select the type of constraint to apply to the piece.Themost common one is
a combination of the regular Nail and Hold Orientation options.

9. In the Camera view, click on the bone of the part you want to apply a constraint to.

A warning message appears asking you to confirm that you want to add a constraint on that particular
piece and for that frame duration.

10. Click OK.

The constraint is applied.

When to Use the Inverse Kinematics (IK) Tool

Harmony provides different tools for animating cut-out characters and trajectories. The two main tools used
to animate characters are the Transform and Inverse Kinematics tools.

Here, we'll compare the usage of these tools and explain the Inverse Kinematics philosophy.

• Transform Tool

Also known as forward kinematics, the Transform tool is themain tool to use for cut-out animation. This
tool rotates, scales, moves and skews selected elements as one global element.

Forward kinematics means that the limb is animated from the parent down to the last child as a single
piece. In other words, if the shoulder is animated, then the arm, forearm and hand follow as a complete
arm drawing.

• Inverse Kinematics Tool (IK)

This tool helps you achieve complex motions, such as sitting down or knee bending. The Inverse
Kinematics tool moves and rotates every selected element as a chain.

Inverse kinematics means that the element is animated from the child up to the parent. In other words, if
the hand is animated, then the forearm, arm and shoulder follow the hand in a fairly natural way in terms
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of themovement, rotation and bending.

IK Tool and Rigging

The IK tool cannot be used on every type of cut-out character. It depends on the way the pieces and parts are
attached to one another. In other words, it depends on the rigging type.

There are several ways to rig a puppet. These are the threemain rigging techniques:

The Basic Rig Technique

• This is the simplest rig technique.

• There are no connections between the parts.

• They are free to move, rotate and scale independently from each other.

• The Inverse Kinematics tool CANNOT be used on this type of rigging.

The Hierarchy Rig Technique

• This is a complex rig technique.

• All the parts are connected to each other.

• As theymove, rotate and scale, they will influence all the other parts.

• The Inverse Kinematics tool can be used on this type of rigging.

The Mixed Rig Technique

• This is the best of the basic and hierarchy rig.

• Some parts are independent such as the torso.

• Some parts are set up in a hierarchy such as the arms and legs.

• Independent parts are rigged in hierarchy using parent pegs.

• The Inverse Kinematics tool can be used on this type of rigging.

Animating with the Tools

Puppets are animated by using a combination of the Transform and Inverse Kinematics tools.

You will mainly use the Transform tool (forward kinematics) as it has all themainmotions: rotate, scale, skew,
move and select. You can also control the exact position of the parts while using the Transform tool. As well, the
Transform tool creates a temporary global pivot on the selection that can bemoved around for the animation
purpose.

To complete complex motions, such as bending the knees while keeping the feet on the ground, you can use the
Inverse Kinematics tool as an assistance tool. By adding IK constraints (nails), it is possible to lock the feet or any
other part to a particular spot and move the rest of the body, which will react to the constraints.

Inverse Kinematics Philosophy

It is important to keep inmind that the Inverse Kinematics tool is an assistance tool. You will not be using it to
animate all the time.

Also, the Inverse Kinematics tool can be used to create the character's posing faster. Posing is a crucial part in the
animation process. The Inverse Kinematics tool can be used to pose the character more naturally, depending on
your own preferences.
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An IK nail can be added anywhere on the character to animate only a small part of the hierarchy chain, such as
an arm or a portion of the arm.

Tips and Tricks for Inverse Kinematics

Here are some tips and tricks to help you to use the Inverse Kinematics tool.

• Inverse Kinematics on Mixed Rigs

The Inverse Kinematics tool can be used on a full puppet's body even if it's connected as a mixed rig,
meaning some parts are rigged in a hierarchy and others not. For example, you can add IK nails on the
puppet's feet, select the full bodymaster peg andmove the character as if it was connected in a full
hierarchy rig. This technique works onmost mix rigs.

• Inverse Kinematics Constraints

It's important to remember that you can add and remove IK constraints (nails, hold orientation, etc.) at
any time during the animation. They hold a certain part on the spot while you animate the rest of the
body. Because they're not constricting one part to another object, you can add or remove themwithout
affecting any of the animation you have already completed.

• Useful Shortcuts

• While using the Inverse Kinematics tool, you can Ctrl + click (Windows/Linux) or⌘ + click (MacOS
X) to select any part.

• Hold Alt to rotate the selected part without affecting the IK chain.

• Press Shift and click in a part's pivot to add or remove an IK Nail.

• Press Shift and click on a bone to add or remove and Hold Orientation constraint.

Animating in Stop-motion
To start animating your character, start by doing your key poses. In fact, most of your timewill be spent doing
key poses. It is better to work with stop-motion keyframes so Harmony does not automatically create the
interpolation between your keyframes.

When using stop-motion keyframes, also known as step keyframes, the segment between two keyframes is
constant. There is no animation generated by the computer between the poses. The drawing remains in
position until the next keyframe, thenmoves to its new position.
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Creating a Stop-motion Keyframe

You can create a stop-motion keyframe in several different ways. You can have Harmony create it automatically,
transform a motion keyframe into a stop-motion keyframe, or even switch your preferences to get Harmony to
always create stop-motion keyframes by default.

How to automatically create stop-motion keyframes

1. In the top menu, make sure theAnimation > Stop-motion Keyframe option is selected.

2. In the Timeline view, select the cell on which you want to add a keyframe.

3. Do one of the following:

‣ Right-click and select Insert Keyframe.

‣ In the Timeline toolbar, click the Add Keyframe   button.

‣ Press F6.

In the Camera view, if the Animatemode is enabled, as soon as youmove the selected element, a keyframe
is automatically created on the current frame.

How to convert a motion keyframe into a stop-motion keyframe

1. In the Timeline view, select themotion keyframes to convert into stop-motion keyframes or press S.

2. Do one of the following:

‣ Right-click and select Set Stop-Motion Keyframes.

‣ In the Timeline toolbar, click the Stop-Motion Keyframe   button.

‣ Press Ctrl + L (Windows/Linux) or⌘ + L (MacOS X).

Animating Using Computer-generated Interpolation
After you have created the key poses, you can animate the in-between poses yourself or let Harmony do it using
motion keyframes. When you usemotion keyframes, the drawings gradually move to the next position instead of
staying on the spot until the next keyframe.
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Creating a Motion Keyframe

You can create a motion keyframe in several different ways. You can have Harmony create it automatically,
transform a stop-motion keyframe into a motion keyframe and even switch your preferences to have Harmony
always createmotion keyframes by default.

How to automatically create motion keyframes

1. In the top menu, make sure theAnimation > Stop-Motion Keyframe option is disabled.

2. In the Timeline view, select the cell on which you want to add a keyframe.

3. Do one of the following:

‣ Right-click on the selection and select Insert Keyframe.

‣ Click the Add Keyframe   button in the Timeline toolbar.

‣ Press F6.

In the Camera view, if the Animatemode is enabled, as soon as youmove the selected element, a
keyframewill be automatically created on the current frame.

How to convert a stop-motion keyframe into a motion keyframe

1. In the Timeline view, select the stop-motion keyframes to convert into motion keyframes.
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2. Do one of the following:

‣ Right-click on the selection and select Set Motion Keyframe.

‣ Click theMotion Keyframe  button in the Timeline View toolbar.

‣ Press Ctrl + K (Windows/Linux) or⌘ + K (MacOS X).

Adjusting the Ease

To add ease in and ease out onmotion paths, you can display the function curve and modify the Bezier or Ease
curve. To apply an ease to multiple functions and keyframes, use the Set Ease for Multiple Parameters feature and
set the amount desired.

The velocity, or ease, is used onmotion keyframes. The velocity must be adjusted directly on the function curve in
the Function view or Function editor. When a keyframe is selected, easing values appear in the right handle and
left handle fields, as well as the Bezier handle or Ease wheel controls on each selected keyframe. You can pull on
them to adjust the ease in and ease out, or type values in the fields.

If there are several functions whose velocity you want to adjust at the same time, such as the hand, forearm and
arm of a cut-out character, you can apply the same velocity parameters to all the selected keyframes in one frame.

How to adjust the velocity in the Function view

1. In the Timeline view, click the Expand Function button to display all the layer’s functions.
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2. Double-click on a function.

The Function Editor opens.

NOTE: The Function editor will not display if the function does not already exist. Add a keyframe to create the
function.

3. Select a keyframe and pull on its Bezier handles or Ease wheel to adjust the velocity. Refer to the Com-
positing and Effects Guide to learn how to create Ease curves instead of Bezier curves.
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How to set ease on multiple parameters

1. In the Timeline view, select a keyframe from one or more layers.

NOTE: Only the first keyframe selected on each layer is considered when using the Set Ease for Multiple Parameter
function. If many keyframes are selected on the same layer, the ease values will be applied only to the first one and
the rest will be ignored.

2. Do one of the following:

‣ In the Timeline view, right-click and select Set Ease ForMultiple Parameters.

‣ In the Timeline toolbar, you can click the Set Ease For Multiple Parameters   button. If the button is
not in the toolbar, you can add it through the Toolbar Manager. Right-click on the toolbar and select
Customize.

The Set Ease For Multiple Parameters dialog box opens.
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3. In the graph, pull on the Bezier handle to adjust the velocity for all the selected functions.

4. To apply these easing parameters to a certain type of function only, such as Rotation or Scale, in the Fil-
ters section, deselect the function types you do not want to affect.

‣ Motion: Applies the easing parameters to the selected Position X, Position Y, Position Z and 3D
Path functions

‣ Rotation: Applies the easing parameters to the selected Angle functions.

‣ Scale: Applies the easing parameters to the selected Scale functions.

‣ Skew: Applies the easing parameters to the selected Skew functions.

‣ Morphing: Applies the easing parameters to the selectedMorphing Velocity functions. Note that it
is applied to theMorphing Velocity function in the Layer Properties window, not to the basic
Morphing ease in the Tool Properties view.

‣ Other: Applies the easing parameters to all the other selected functions, such as all functions
created to animate effect parameters.

5. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values are
calculated in percentage.

‣ In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding to the
length of time youwant the easing to last. The valuemust be between 0% and 100%.

‣ In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong you
want the easing out. The valuemust be between 0% and 100%.

‣ If your Time Ratio and Value Ratio values are equal, you will have a linear motion.
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6. Click one of the following buttons:

‣ Apply: Applies the easing parameters to the selected keyframes.

‣ Apply/Previous: Applies the easing parameters to the selected keyframes and then selects the
previous keyframe in the timeline.

‣ Apply/Next: Applies the easing parameters to the selected keyframes and then selects the next
keyframe in the timeline.

‣ Close: Closes the dialog box. If you did not apply themodifications, they will be cancelled.

Marking the Timeline
As you animate, the Timeline view will containmany layers and keyframes. Youmight want to identify them using
coloured layers and scenemarkers.

Scenemarkers are visual indicators displayed at the top of the Timeline view in the frame counter area. You can
use it to denote anything relevant to your work. You can indicate the frames you want to clean up, a change in
action, an impact, or where you intend to apply an effect. You can also add a note to a scenemarker, which is
displayed when you hover over the scenemarker.

There are two ways to add a scenemarker. You canmark the current frame or make a frame range selection and
mark the whole section.

How tomark the current frame

1. In the Timeline view, make sure the red playhead is set on the frame youwant to mark. Even if you right-
click on a different frame, the scenemarker will be created on the current frame onwhich the playhead is
positioned.

2. Right-click in the frame counter area and select Scene Markers > Mark Current Frame.

The Timeline SceneMarker dialog box opens. The Colour box displays a black colour swatch, or the colour
of the last scenemarker you created.

3. Click the Colour swatch to open theMark Colour dialog box and select a colour for the scenemarker.
Click OK.
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4. In the Note field, enter text to display as the tooltip and click OK.

In the Timeline view, the scenemarker is displayed at the current frame.

5. Hover over the scenemarker to display its tooltip.

How to create a scene marker on a frame range

1. In the frame counter area of the Timeline view, select the frame range youwant to mark.

The Timeline SceneMarker dialog box opens. The Colour box displays a black colour swatch, or the
colour of the last scenemarker you created.
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2. Click the Colour swatch to open theMark Colour dialog box and select a colour for the scenemarker.
Click OK.

3. In the Note field, enter text to display as the tooltip and click OK.

In the Timeline view, the scenemarker is displayed over the selected frame counters.

4. Hover over the scenemarker to display its tooltip.

How tomodify a layer's colour

1. Click the Change Track Colour button of a layer.

The Select Colour dialog box opens.
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2. Select a colour for the layer. You canmodify the colour for any type of layer, such as group, peg, draw-
ing and effects.

Flipping Through Poses

When animating, it is useful to flip through poses to see the flow of your animation without going through each
frame in the Timeline view. Harmony lets you flip between the selected element’s keyframes.
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How to flip through poses

1. In the Camera or Timeline view, select a layer that contains the poses you want to view.

2. Do one of the following:

‣ From the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe

‣ Press semicolon (;) and single quote (').

Using the Onion Skin in Cut-out Animation

When animating cut-out characters, it is useful to see the previous and next frames on the animation. However, it
can sometimes be confusing to see the onion skin for every part of the character. You will often only want to see
the onion skin on a single part or a few parts, such as the arm that is currently being animated. Harmony offers
that possibility.

While animating in the Camera view, there is a series of different onion skin options. You can enable these options
in themenu or manually in the Timeline view using the layer's Show Onion Skin button. Unless you change the
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onion skin options when you display the onion skin, only the selected layers will be displayed in the onion skin
preview.

How to use the onion skin

1. In the Tools toolbar, click theOnion Skin button or press Alt + O.

2. In the Tools toolbar, click the Transform tool or press Shift + T.

3. In the Camera view, select one or more elements.

4. From the top menu, select View > Onion Skin > Add to Onion Skin, Remove From Onion Skin,
Remove Unselected from Onion Skin, AddAll to Onion Skin or Remove All from Onion Skin.

Add to Onion Skin

The Add to Onion Skin command is used to add a series of selected elements to the onion skin preview. The
keyboard shortcut is Shift + S.

Remove from Onion Skin

The Remove FromOnion Skin command is used to remove a series of selected elements from the onion skin
preview.
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Remove Unselected from Onion Skin

The Remove Unselected fromOnion Skin command is used to remove all elements except the ones selected from
the onion skin preview.

AddAll to Onion Skin

The Add All to Onion Skin command is used to add all of the scene's elements to the onion skin preview. The
keyboard shortcut is Alt + Shift + O.

Remove All from Onion Skin
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The Remove All Onion Skin command is used to remove all of the scene's elements from the onion skin
preview. The keyboard shortcut is Ctrl + Shift + O (Windows/Linux) or⌘ + Shift + O (MacOS X).

Flipping Parts

If you want to flip a part, a limb or a whole puppet, use the Transform tool and the Flip Horizontal and Flip
Vertical options. If the Scaling parameter is not set to Separate Scale, the flip is not applied to the selection.

How to flip a selection

1. In the Tools toolbar, select the Transform tool or press Shift + T.

2. In the Tool Properties view, make sure the Peg SelectionMode is disabled.

3. In the Camera view, select the parts to be flipped.

4. In the Tool Properties view, click the Flip Horizontal or Flip Vertical option or press 4 or 5
respectively.
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Using Action Templates

Reusing animation and assets is an important aspect of cut-out animation. This is why Harmony includes a library
for storing all the reusable information.

When you created the character rig, youmost likely created a master template along with some action templates

To save time, you can take an action that you've already animated, such as a walk-cycle or jump, and reuse it. You
can store the initial animation's keyframes in the Library view, then drag it into a master template of a new scene.

You can import a master template into the Timeline view (or Node view) and start animating with it. You can
import an action template into the right side of the Timeline view. An action template is composed of drawings
(like a blink) or keyframes (like a walk cycle) that you can reuse in an animation sequence.

To insert an action template into a master template, the layer ordering has to be exactly the same. If it's
inconsistent, the templates cannot be combined.

597



Chapter 8: Cut-out Animation

You can create a single keyframe action template of the different views (front, three-quarter or side view). Then
import and insert them into the animation to turn the character. The same pattern can be created for a head,
arm, full upper body, etc.

If themaster template you are importing was created in theNode view, make sure to import it first and drop it
into theNode view or the left side of the Timeline view. Failure to do this may break some node system
connections.

If you created templates for different body parts, you can reuse them in your scene by dragging them to your
layers. You can also open a template as a folder and select a particular drawing from it and drag it onto a
drawing layer.

Swapping Drawings

Cut-out animation is not only about moving parts around. It's also about swapping drawings to give the
animation a more traditional animation look. You can add as many new drawings as you want in your scene and
use them in your current animation. You can also add new drawings to the library and use them in other scenes.
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But before starting to swap drawings, it's important to understand how keyframes, exposure and key exposure
work in Harmony:

• Keyframe: A keyframe is a point in timewhere a change to the properties of the object or character
occurs. In Harmony, keyframes consist of the coordinates that determine how an entire layer and its
contents aremoved. Keyframes include these parameters: XYZ position, skew, scale, angle and pivot.

• Exposure: Exposure is a property; it is the length of time that a drawing is visible over a series of frames.
In Harmony, exposure is independent of keyframes. That is, keyframes are not linked to drawings.
Keyframes can bemoved independently from the drawing exposure.

• Key Exposure: A key exposure in Harmony is a type of exposure that forces a drawing to remain exposed
on a specific frame. If a drawing is exposed before a key exposure and you swap out that drawing for
another one, then the original drawing is retained. This preserves the key drawing. Note that Harmony
automatically sets a key exposure when you perform a drawing swap.

When youwant to swap drawings, you can do so in the Timeline or Library view. In the Timeline view, the
Parameters area is where you can select a drawing to swap. In the Library view, the Drawing Substitution window
lets you see the drawings before selecting one for swapping. In this view, you are actually selecting drawings in
your scene layers, not drawings in the Library.

NOTE: Keep in mind that when you swap a drawing, its entire exposure is replaced up to the next drawing exposure.

When selecting a certain frame range to be swapped, the behaviour of the Timeline and Library views is different.
If you are using the Parameters area of the Timeline view to select a drawing to replace a selected frame range,
the new drawing will replace the frame range and continue until the next key exposure. In the following example,
drawing 2 (DR2) is replaced by a new drawing, starting at the beginning of the selected frame range and ending
at the next key exposure.

If you use the Drawing Substitution window in the Library view to select a drawing, the drawing is split in two and
the exposure before and after the frame range remain the same. In the following example, drawing 2 (DR 2) is
split in two and the selected frame range is filled with a new drawing.
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How to swap a drawing in the Timeline view

1. In the Timeline view’s right side, select the cell containing the drawing or symbol cell to swap.

2. In the Drawing Substitution field, position the pointer over the value and drag left or right to change the
cell or drawing exposed for another one. You can also type in the drawing name or symbol’s cell num-
ber if you know it.

How to swap images in the Library view

1. In the Tools toolbar, select the Transform tool.

2. In the Transform Tool Properties view, make sure the Peg Selection button is deselected.

3. In the Camera view, use the Transform tool to select a part of the drawing to swap.

NOTE: You can swap the frames in symbols or the drawings in a layer. However, you cannot swap one symbol for
another.
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4. In the Timeline view, select the cell range in which you want to swap the drawing.

5. In the Library view, go to the Drawing Substitution window.

6. Scroll through the symbol's frames or drawings by doing one of the following:

‣ From the top menu, select Animation > Substitute Drawing Previous or Substitute DrawingNext.

‣ Drag the slider left or right.

‣ Press +.

The drawing or symbol’s cell on the current frame is replaced.
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Adding Key Exposures

If there is a particular drawing youwant to keep on a specific frame, you can set it as a key exposure. This
prevents it from be overwritten by a drawing swap on a preceding frame. A key exposure is simply a property
of an exposure that forces it to be exposed on a certain frame regardless of whether the previous exposure is
the same drawing or not.

NOTE: Keep in mind that if you modify the artwork in a drawing, all instances of that drawing will be automatically
updated even if set as a key exposure. This keeps your existing animation key poses intact. It is frequently used on
a mouth or eyes layer.

Example: Swapping a drawing with no key exposure

In the following example, drawing 3 (DR 3) is selected on the timeline and it contains no key exposure.

When it is swapped for drawing 4 (DR 4), the entire duration of drawing 3 substituted for drawing 4.

Example: Swapping a drawing with a key exposure

Here's what happens when swapping a drawing with a key exposure. In the following example, the playhead is
positioned in themiddle of drawing 5 (DR 5) to set the position for the new key exposure. When the new key
exposure is added, drawing 5 is split in two; both halves contain drawing 5. Now if you swap the first drawing
5 for drawing 1, the second drawing 5 retains its exposure.
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How to add a key exposure

1. In the Timeline view, select the drawing cell to set as the key exposure.

2. Do one of the following:In the Timeline toolbar, click the Add Key Exposure button.

‣ In the Timeline toolbar, click the Add Key Exposure button.

‣ In the Timelinemenu, select Exposure > AddKey Exposure.

‣ Right-click and select Exposure > Add Key Exposure.

A new key exposure is added. 

If you added a key exposure at the beginning of the drawing, the entire exposure is filled with that same
drawing. If you added a key exposure anywhere other than the beginning of the drawing, then the drawing
is split in two and both parts contain the same drawing.

Removing Key Exposures

When you no know longer need a key exposure, you can remove it. When you do this, the existing key exposure is
replaced by the preceding exposure. In the following example, a key exposure is set to drawing 1 (DR 1). When
the key exposure is removed, the exposure is replaced by the preceding exposure, drawing 4 (DR 4).
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How to remove a key exposure

1. In the Timeline view, select a key exposure to remove.

2. Do one of the following:

‣ In the Timeline toolbar, click the Remove Key Exposure button.

‣ In the Timelinemenu, select Exposure > Remove Key Exposure.

‣ Right-click and select Exposure > Remove Key Exposure.

The key exposure is removed and replaced by the preceding exposure.

How to remove a key exposure

1. In the Timeline view, select a key exposure to remove.

2. Do one of the following:

‣ In the Timeline toolbar, click the Remove Key Exposure button.

‣ In the Timelinemenu, select Exposure > Remove Key Exposure.

The key exposure is removed and replaced by the preceding exposure.

Animating Lip-Sync

Adding a lip-sync to a project can really enhance its quality and storytelling. However, it can be difficult to shape a
character's mouth to match the sound at a precise frame.

To solve this problem, Harmony provides a lip-sync feature which analyzes the contents of a sound element
and generates a mouth chart (see below) based on the eight animation phonemes (A, B, C, D, E, F, G, and X
for silence).
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Themouth shapes used by Harmony are based on the conventional mouth chart used in the animation industry.

NOTE: The letters used to represent the shapes do NOT correspond to an actual sound.

NOTE: If you are doing cut-out animation, refer to the Cut-out Animation Guide, Character Building chapter, "Adding
Extra Drawings" topic to learn how to add extra drawings to your character.

Here is an approximation of the sound eachmouth shape can produce:

• A: m, b, p, h

• B: s, d, j, i, k, t

• C: e, a

• D: A, E

• E: o

• F: u, oo

• G: f, ph

• X: Silence, undetermined sound

You can lip-sync the traditional way or let the system automatically create the basic detection.

You can refer to themouth chart positions as you draw the shape of the character's mouth.

605



Chapter 8: Cut-out Animation

How to generate a sound detection for lip-sync using the Layer Properties view

1. In the Timeline or Xsheet view, select the sound layer.

The options for that layer will appear in the Layer Properties view.

2. In the Layer Properties, click Detect.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to
each sound cell.

3. Click theMap button to open the Lip-SyncMapping dialog box.

4. From the Destination Layer menu, select the layer that contains themouth positions for the character's
voice track.
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5. If the selected layer contains symbols, you canmap the lip-sync using drawings located directly on the layer
or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to use the
drawings or select the desired symbol from the drop-downmenu.

6. In theMapping section, type the drawing name or Symbol frames in the field to the right of the phoneme it
represents. If your drawings are already named with the phoneme letters, you do not have to do anything.

7. Click OK.

8. Press the Play button in the Playback toolbar to see and hear the results in the Camera view. To play
back your scene with sound, enable the Sound button in the Playback toolbar.

Harmony allows for themanual swapping of mouth position drawings to match a voice track. For this process,
both sound scrubbing (listening to a sound wave broken up frame-by-frame) and drawing substitutions are used.

How to animate lip-sync using the Timeline view

1. In the Playback toolbar, enable the Sound Scrubbing  button.

2. In the Timeline view, drag the red playhead along the sound layer waveform.

3. When you reach a framewhere a mouth position should go, for example, an openmouth with rounded lips
for an "oh" sound, click on that frame on your mouth shapes layer.

4. In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the drawing
name (often a letter) until it changes to the swapping pointer.

5. Pull the cursor to see the list of mouth shape names and choose the one youwant. The current drawing
automatically changes to the new selection.

How to animate lip-sync using the Library view

1. In the Playback toolbar, click the Sound Scrubbing   button.

2. In the Timeline view, drag the red playhead along the waveform of your sound layer.

3. When you reach a framewhere a mouth position should go, for example, an openmouth with rounded lips
for an "oh" sound, click on that frame on your mouth shapes layer.
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4. In the Drawing Substitution window of the Library view, drag the slider to choose a mouth shape. The
current drawing is swapped for the one in the preview window.

Adding a New Drawing
If you need to add a new drawing to a scene, you can do so by duplicating the existing drawing on the current
frame. If you're using symbols, you can also add a new drawing inside the body part’s symbol.

Duplicating a Drawing

If your character doesn't use symbols, youmust duplicate the drawing on the cell on which you need to a new
drawing. You could also create a new blank drawing, but duplicating the existing drawing allows you to keep
the pivot you previously set (if you're using drawing pivots) and you can also reuse a portion of the existing
artwork. When you create a new drawing, you get a blank cell with a pivot set at the centre of the Camera
view.

How to duplicate a drawing

1. In the Timeline or Camera view, select the drawing to duplicate.

2. From the top menu, select Drawing > Duplicate Drawing or press Alt + Shift + D.

The new drawing appears in the currently selected cell.

3. In the Camera view, draw the new piece.
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Reposition Drawing Tool

When creating additional drawings for a cut-out puppet, you should generally try to create them in the same
location as the original drawings (resting position) so you can scale and rotate the same pivot.

Although, when adding drawings that are specific to an animation, it may be easier to draw it in relation to the
character's position and scene's composition. If you draw a series of drawings that are not in the same location,
you can use the Reposition Drawing tool to reposition the drawing strokes while simultaneously creating
keyframes in the Timeline view to compensate for the repositioning. In the Camera view, the drawings will retain
the location and position in which you drew themwhile in the Drawing view, all your drawings will be aligned.

How to reposition and align drawings

1. In the Advanced Animation toolbar, select the Reposition Drawing tool.

2. In the Camera view, Ctrl + click (Windows/Linux) or⌘ + click (MacOS X) to select the drawing to repos-
ition. You can also select the drawing layer or the parented peg in the Timeline view.

The Reposition Drawing controls appear in the Camera view. They are positioned on top of each other.
The source controls are represented by black lines. The destination controls are represented by dotted
blue lines.

3. On your first drawing (reference drawing), position the black source controls to indicate the position at
which all other drawings will be aligned.
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4. In the Timeline view, move to the next drawing.

5. In the Camera view, move the blue destination controls to match the reference position you set on the
original drawing. You can use the long handle to rotate the position. If you rotate the control multiple
times, the drawing will rotatemultiple times.

6. Select the blue checkbox once the position is correct.

7. Repeat the previous two steps for all drawings in your animation.
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8. Once all the drawings are completed, in the Drawing view, verify that the drawing strokes are correctly
aligned.

9. If necessary, delete the last keyframe if the last drawing moves back to the reference drawing's position.

10. If the animation does not require interpolation, in the Timeline view, select the newly created keyframes. In
the Timeline toolbar, click the Set Stop-Motion Keyframe button to remove any computer-generated
interpolation.
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Ordering Layers Over Time

The layer ordering system in Harmony saves time and simplifies your work. There is no need to create a new
layer or copy and paste artwork into other layers to change the order. The Z-axis (forward/backward) allows
you to create a multiplane and move elements closer or farther from the camera. This allows you to move the
puppet’s pieces in front of or behind other ones without physically changing the layer position.

Harmony provides you with a shortcut to move the piece with a micro nudge on the Z-axis. A keyframe is
created where different Z values can be entered. This allows the piece to move forward and backwards in
space without requiring you to change the drawing’s original position or break the layer hierarchy. This also
means that the layer ordering is maintained throughout the scene. You can combine animation assets so
Harmony can interpolate them.

How to nudge elements on the Z-axis

1. In the Tools toolbar, select the Transform tool or press Shift + T.

2. In the Tools toolbar, click the Animate button.

3. In the Camera view, select the part to be repositioned and hold down the Alt key.

4. Using the Up or Down arrow keys, nudge the part until it moves to the desired position.
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Resetting a Transformation
If youmade too many transformations and it's not going where you want it to go, or simply because you want to
reset a pose you're reusing from another animation, you can reset your character's position. Once the layers are
positioned in the Camera view, you can easily return them to their original position. There are three different ways
to reset a transformation.

Using the Reset command, you can reset the value of the selected element to the initial value of the active tool.
For example, if the Rotate tool is active, the transformation angle will be reset to 0 and if the Transform
tool is active, all the transformation values will be reset.

The Reset All option resets all transformations on the current frame in a selected layer. Your keyframewill remain,
but all the values will return to the default position. All transformations are reset regardless of the tool you're
using.

The Reset All Except Z option resets all transformations on the current frame except the Z position. This is useful
when doing cut-out animation. Cut-out puppets often have a particular Z ordering for the different views of a
character. Youmight want to reset the transformation, but not necessarily the Z position.

In the Timeline view, you can also use the Clear All Values command to reset all transformation values on the
selected layers. Right-click on the selected layers and select Layers > Clear All Values.

NOTE:When using the Transform tool to select elements in the Camera view, always make sure the Peg Selection
Mode option in the Tool Properties view is disabled or it will limit the selection to peg only.

How to reset the transformation on the current frame

1. In the Tools toolbar, select the Transform tool or any Advanced Animation tool.

2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

3. From the top menu, select Animation > Reset or press Shift + R.

The selected layer(s) return to their original position.
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How to reset all transformations on the current frame

1. In the Tools toolbar, select the Transform tool or any Advanced Animation tool.

2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

3. From the top menu, select Animation > Reset All or press Shift + R.

The selected layer(s) return to their original position.

How to reset all transformations except the Z position on the current frame

1. In the Tools toolbar, select the Transform tool or any Advanced Animation tool.

2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

3. From the top menu, select Animation > Reset All Except Z.

The selected layer(s) return to their original position, except for the Z values.

Creating Cycles
You can create cycles from a portion of your animation or completely reverse the flow of your animation.

How to create an animation cycle

1. In the Xsheet or Timeline view, select the cell range and keyframes to loop.

2. From the top menu, select Edit > Copy Cells From the Timeline.

3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4. From the top menu, select one of the following:

‣ Edit > Paste Cycle or press Ctrl + / (Windows/Linux) or⌘ + / (MacOS X).
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The Paste Special dialog box opens.

‣ Edit > Paste Special or press Ctrl + B (Windows/Linux) or⌘ + B (MacOS X).

The Paste Special dialog box opens.

5. In the Number of Cycles field, enter the number of cycles to paste.

6. In the Cycle Typemenu, select a type of cycle to paste.

‣ Normal (forward): Pastes the selection as is, starting with the first cell and ending with the last.

‣ Reverse: Pastes the selection reversed, beginning with the last cell and ending with the first.

‣ Forward -> Reverse: Pastes the selection as a yo-yo, starting with the first cell, going to the last cell
and ending with the first cell.

‣ Reverse -> Forward: Pastes the selection as a reversed yo-yo, starting with the last cell, going to the
first one and ending with the last cell.

7. Click OK.
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How to create a reverse animation cycle

1. In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.

2. From the top menu, select Edit > Copy.

3. In the Xsheet or Timeline view, select the cell where you want the cycles to start.

4. From the top menu, select Edit > Paste Reverse or press Ctrl + . (Windows/Linux) or⌘ + . (MacOS X).

Copying and Pasting Animation
As you animate, you will find that you reusemany positions, drawings, and keys. However, youmay only want
to paste the drawings or just the keys or maybe everything. There are different paste options available in the
Timeline view which give youmaximum flexibility when reusing and pasting.

Note that thesemodes also apply when you drag instead of copying and pasting.

There are three different modes for pasting your selection:

• Paste Mode: All Drawing Attributes: Pastes the drawing exposure and keyframes.

• Paste Mode: Keyframes Only: Pastes only the keyframes.

• Paste Mode: Exposures Only: Pastes only the drawing exposure.
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How to paste a selection using different modes

1. In the Timeline view, select the cells you want to copy and paste.

2. In the Timeline toolbar, click the desired Paste mode button.

3. From the top menu, select Edit > Copy Cells from the Timeline or press Ctrl + C (Windows/Linux) or⌘ +
C (MacOS X).

4. In the Timeline view's right side, select the cell on which you want to paste your selection.

5. Select Edit > Paste Cells in the Timeline or press Ctrl + V (Windows/Linux) or⌘ + V (MacOS X).

Paste Mode: All Drawing Attributes

Paste Mode: Keyframes Only

Paste Mode: Exposures Only
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Adding Pegs
Now that you have your puppet on stage, you probably need to resize and reposition it to fit the scene. When
you need to scale down or move a character, it's a good idea to hook (attach) the whole puppet to a
trajectory.

In Harmony, there is a type of layer you can add to your timeline, allowing you to create a motion path or
reposition drawings. This trajectory layer is called a peg. Any drawing or layer you hook to a peg will follow the
defined motion path, rotation, scaling and skewing information.

Attaching your puppet to a peg allows you to scale and reposition it without having to do the same on all the
different parts and pieces. Only one layer will contain the position information, making your animation easier
to modify and control.

Next, position your character on the stage bymoving it and scaling it to the correct size. You will not scale
each layer individually. You can do it on the top symbol or top peg layer.

How to add a repositioning peg

1. In the Timeline view, select the top layer on which you want to parent a peg.

NOTE: You must select a layer to be able to add a peg to your scene. Unless you use the Display All mode from the
Display toolbar, an error message will display if you try to add a peg without any selection.

2. In the Timeline view, click the Add Peg button.

A new peg is added to the timeline as a parent of the selected layer.

3. Double-click on the name of new peg layer and rename it: Master_Peg.

4. In the Timeline view, select all the layers you want to attach to the new peg. Remember that one item is
already parented to that peg.
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5. Drag the selection and drop it on the peg layer to parent all the character's pieces to the peg. If your layers
are added above the already-parented layers, move that parented layer back on top of the layer stack.

How to reposition a character

1. In the Timeline view, select the top peg layer (master peg).

2. In the Tools toolbar, select the Transform tool and disable the Animate mode.

3. In the Camera view, position the character.

Offsetting a Portion of an Animation
If there is a section of the animation that you want to reposition, such as the head's height or the puppet's
position, you can do so using the function curve.

How to reposition a portion of an animation

1. In the Timeline view, click the Expand Function button of the body part layer to reposition. If you want
to reposition the entire body, expand themaster peg's parameters.
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2. Double-click on the layer's parameter controlling the keyframes you want to reposition.

The Function Editor opens.

3. In the Function editor, select the keyframes you want to reposition by tracing a selection box.

4. Click the Show Current Frame button to view the transformation results in the Camera view as you
do them.

5. Drag the keyframe selection up or down to reposition the sequence.

6. Close the Function editor.
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Chapter 9: Morphing

Hand-drawn animation requires you to spend a lot of time tracing in-between drawings. Harmony speeds up the
process using its helpful morphing feature. This powerful and useful feature creates computer-generated
drawings and places them between vector drawings to save time and increase productivity. Animation created
with themorphing feature can be reused in different projects. You can easily modify the timing and velocity (ease
in and ease out).

One of themain uses of themorphing feature is effects animation. For example, animating smoke or water can be
time-consuming because these types of effects are usually slow moving requiring a large number of closely placed
inbetweens.

This chapter is divided as follows:

• UnderstandingMorphing on page 622

• Source and Destination Drawings on page 622

• Morphing Rules on page 623

• Creating a BasicMorphing Sequence on page 627

• Tool Properties View on page 629

• Adjusting the Velocity and Timing on page 632

• Morphing Tool and Hints on page 635

• Morphing Layers on page 643

• Morphing Two Sequences in a Row on page 650

• Inserting a Morphing Key Drawing on page 651

• Converting Morphing Inbetweens to Drawings on page 652

• Morphing Holes and Transparencies on page 652

• Adjusting theMorphing Quality on page 655

• Tips and Tricks on page 655
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Understanding Morphing
Themorphing feature is used to animate similar and simple shapes such as hair or smoke. It helps you by
saving timewhen you are working on tedious inbetweening and tracing tasks This, in turn, provides you with
more time to spend on complex animation tasks such as walk cycles or acrobatic sequences.

Ideas behind Morphing

To learn how to morph drawings, it is better to start with basic shapes such as circles and rectangles. Once
you aremore familiar with the tool, you can increase your knowledge and expertise. In a very short time you
will be producing some remarkable effects.

It is helpful to know the pros and cons of morphing before you start. Understanding what you can do and
which drawing lines may bemore useful or problematic will enable you to design your key drawings so they
morph efficiently.

NOTE: The more complex the shape is, the longer it takes to morph. If it takes more time to morph a drawing than
to hand-draw it, then it is better to animate it instead of morphing. However, if you spot an occasion when you can
morph your drawings, do it! It allows you to fix your timing and velocity in no time without having to create any
extra drawings!

Source and Destination Drawings

Themorphing featurematches similar shapes in a source and a destination drawing. Harmony evaluates the
source's shape properties and matches them to themost similar ones in the destination drawing.

Morphing works between similar shapes, which are drawings that have the same palette, colours and number
of shapes. You can even change any shape into another one, as long as the source and destination keep the
same colours, number of lines and number of shapes.
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Morphing Rules
Harmony follows a set of rules as it evaluates the shapes. Familiarize yourself with these basic morphing rules
before you start morphing.

NOTE: Note that a morphing sequence can only be done on vector drawings. You cannot morph bitmap layers or
Toon Boom bitmap drawings.

Closest Similar Shape

A colour, line shape or zone will morph with the closest similar one in the destination drawing. This means it will
morph with the zone nearest to it, as long as that zone uses the same palette's colour swatch (colour ID) and has
the same vector properties (Central or Contour).

In the example above, the red heart shape (1) will morph with the closest shape using the same colour swatch. It
will morph with the red diamond shape (1) in the next drawing. The red diamond shape (2) in the source drawing
will morph with the red heart shape (2) located in the same area in the destination drawing. The black spade
shape (3) in the source drawing will morph with the black club shape (3) located in the same area in the
destination drawing. Finally, the black club shape (4) in the source drawing will morph into the black spade shape
(4) located above in the destination drawing.

Pencil Line to Pencil Line

If you trace a shape using a pencil line such as the Ellipse , Rectangle , Polyline , Line or Pencil
tool, you have to morph it with another pencil line. Make sure that both drawings are pencil shapes (central
vector).
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Apencil line will never morph with a brush stroke.

Pencil lines with thickness are supported inmorphing sequences. The thickness will morph according to the
thickest and thinnest areas in the source and destination drawings.

Pencil lines with textures are not supported in a morphing sequence. During themorphing, the texture will
disappear and show without pencil line opacity texture.
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If you have pencil lines in your source drawing, the same number of pencil lines must be present in the destination
drawings. A pencil line will appear if it is not found in the destination drawing. It will pop out on the first or last
frame depending onwhich one it is drawn.

When two pencil lines cross one another, they are considered to be two lines and not four lines anymore (as it was
in version 7.8 and below of the application). In this case, youmust have two pencil lines in your destination
drawing for your morphing to work correctly.

Fill Shape to Fill Shape

If you have a brush stroke or a colour fill ( contour vectors), make sure that youmorph it with another brush
stroke or fill zone. It is important to undersand that strokes drawnwith the Brush tool are the same thing as
zones painted with the Paint tool. Vector points are located along the contour. They are simply not the same size.
Contour vectors will not morph with pencil lines (central vectors). A brush stroke canmorph into a colour fill zone
and vice versa as they are the exact same thing.
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Colour Swatch to Same Colour Swatch

Harmony does not morph between colours. If you want to perform a colour transition, you have to create the
effect during the compositing step of your production. A colour palette is composed of colour swatches. Each
colour swatch has its own unique identification number, even if two swatches are the same colour value, they
are identified independently. A colour zone or shapewill morph with another one painted with the same colour
swatch.

Vanishing andAppearing

If a colour zone does not find a match in the first or the second drawing, it will progressively appear or
disappear.

Colour Art to Colour Art and Line Art to Line Art

In Harmony, there is an advanced concept for painting your drawings called Line Art and Colour Art. Basically,
an extra layer is added in your drawings so that you can fill the colour zones on a separate layer. The regular
layer on which you are drawing is called Line Art and the extra layer under the Line Art is the Colour Art.

• A shape drawn in Colour Art can only bemorphed with another shape existing in the Colour Art.

• A shape drawn in Line Art can only bemorphed with another shape existing in the Line Art.

• A shape created in Colour Art can never morph with a shape created in Line Art.
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Creating a Basic Morphing Sequence

When it comes to morphing, you will need to practice and become at ease with it. Once you are familiar with the
basic rules, you can start creating morphing sequences. To begin, start with simple elements. When you are
confident with themorphing process, you can start to use complex and advanced morphing techniques, such as
head rotations or full characters.

Youmay want to delete an entiremorphing sequence in order to redo a sequence from scratch.

How to create a basicmorph

1. In the Timeline toolbar, click the Add Drawing Layer button to add a new layer to your project.

2. Rename the new layer ( for example, Morphing).

3. In the Timeline or Xsheet view, select the first cell in the layer.

4. Do one of the following:

‣ In the Tools toolbar, select the Rectangle tool.

‣ Press Alt + 7.

5. In the Camera or Drawing view, draw a rectangle.

6. Do one or both of the following:

‣ Hold down the Shift key to draw a square.

‣ Hold down the Alt key to draw the rectangle from its centre.

7. Paint your rectangle using the Paint tool.
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8. In the Xsheet or Timeline view, select the cell on which you want your morphing sequence to end.

9. Do one of the following:

‣ In the Tools toolbar, select the Ellipse tool.

‣ Press Alt + =.

10. Draw and paint the ellipse using the same outline colour as the rectangle.

11. In the Xsheet or Timeline view, select the first frame and all the frames up to and including the last
frame, which is the rectangle drawing.

12. Do one of the following:

‣ From the top menu, select Animation > Morphing > Create Morphing.

‣ In the Xsheet or Timeline view, right-click and selectMorphing > Create Morphing

‣ Press Alt + M.

Arrows appear between the two key drawings to show that computer generated inbetweens have been
created.
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NOTE: Use the Playback toolbar to play the morphing sequence. To flip through the inbetweens, toggle between
comma ( , ) and period ( . ). Press F4 to toggle between the two key drawings.

How to delete an entire morphing sequence

1. In the Xsheet or Timeline view, select a cell in themorphing sequence.

2. Do one of the following:

‣ From the top menu, select Animation > Morphing > Delete Morphing.

‣ In the Xsheet or Timeline view, selectMorphing > Delete Morphing.

‣ Right-click on your sequence and selectMorphing > Delete Morphing.

The entire sequence between the two keyframes is removed.

Tool Properties View

As you create and adjust your morphing sequences, you will often use the Tool Properties view. Using this view
allows you to do things such as toggle between your key drawings, adjust the easing or select a hint type.

How to access the content of the Tool Properties view

1. Do one of the following:

‣ In the Tools toolbar, select theMorphing tool.

‣ Press F3.
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Hint Type

The Hint Type drop-downmenu allows you to select the correct hint to remedy any problem areas in your
drawing—seeContour Hint on page 639 andMorphing Tool and Hints on page 635.

You can havemore than one hint type in your drawings. You canmix all of the hint types in your morphing
sequence.

Hide Hints

The Hide Hints button temporarily hides the hint points from the key drawings. Use this option when you
have a series of hint points hiding some lines you would like to see.

Show Morphing in Place

The ShowMorphing In Place option is used withmorphing layers. Enabling this option prevents the
currently selected morphing layer from being shown on top of the others and maintains the correct layer
ordering—seeMorphing Layers on page 643.

Suggest Hints

The Suggest Hints option is used to automatically set hint points on key drawings as a help tool. If you're
not sure where to set hints, you can use this option. It will set themain hints which you can then fine tune.

Switch Between Drawings

The Switch BetweenDrawings button is used to toggle between the two key drawings in your morphing
sequence. This option is useful while setting hints. You can use the default keyboard shortcut F4 to toggle
between your drawings.

Flatten

The Flatten
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option is used when you have to morph a sequence with a semi-transparent or transparent colour in it—see
Morphing Holes and Transparencies on page 652.

Quality

TheQuality setting is used to make the lines of themorphed drawings smoother. Adjust this parameter when you
are doing an extreme close up of your animation—seeAdjusting theMorphing Quality on page 655.

Morphing Layers

TheMorphing Layers option is used whenworking withmorphing layers. You can add, remove andmanage your
different morphing layers in this space—seeMorphing Layers on page 643

Easing

The Easing option is used to adjust the starting and ending velocity of your morphing sequence so that the
motion is smooth and not mechanical.

You can adjust the Ease In and EaseOut value by dragging your cursor up and down or typing a new value. The
values go from -1.0 to 1.0—seeAdjusting the Velocity and Timing on page 632

Convert Hints

The Convert Hints option is used to switch the type of the selected hint points. This option is useful when you
position hints and then realize they are not the right type. You can select them and convert them to the correct
type instead of deleting them and setting new ones.

Use theMorphing tool to select the hints and then convert them by going to the Tool Properties view and
selecting the new hint type from the Convert Hints drop-downmenu.
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Time

The Time field is used to set the timing on Appearing Point and Vanishing Point hints. These hints are used to
set the trajectory of appearing and vanishing objects, With the Time field, select your Appearing Point or
Vanishing Point hint and type the frame number on which the object will start its appearing or vanishing
animation.

Adjusting the Velocity and Timing

Once you have set up a morphing sequence, you can control its timing and velocity. When you look at your
animation you will notice that themorphing motion is constant. To produce a less mechanical motion, you will
probably want to create some ease in or ease out.

If you did not place your source and destination drawings on the correct frames youmay need to extend or
shrink the sequence length.

If you have several morphing sequences on a single layer, youmay find it easier to adjust their velocities on one
function curve rather than several separate ones. Having all of your velocity parameters in one place is more
efficient and easier to modify.

Adjusting the velocity in the Layer Properties editor also allows you to reverse a section of themorphing
sequence. The sequence will always start with the source drawing and end at the destination. You can play the
morphing sequence backwards or forwards during the animation.

You can have two levels of easing:

• In the Tool Properties View, you can adjust the velocity of each sequence in your layer independently

• In the Layer Properties editor, you can adjust themorphing velocity function to control the entire layer's
easing

How to extend or shrink a morphing sequence length

1. In the Timeline view, select the source or destination drawing.
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2. Click on your selection and drag the drawing to its new frame.

How to adjust the velocity in the Tool Properties view

1. In the Timeline view, click on a frame in themorphing sequence you want to adjust.

2. In the Tool Properties view, increase and decrease the Ease In and EaseOut value to adjust the sequence's
velocity.

How to adjust the velocity in the Layer Properties editor

1. In the Timeline view, double-click on the drawing layer to open the Layer Properties editor.

2. In the Layer Properties editor, go to the Advanced tab and click on the Function button to create a
function curve.

3. In the Layer Properties editor, click the Function button again to open the velocity curve.

4. Add a keyframe at the first frame of themorphing (source) and one at the end (destination) by clicking on
the Add/Remove Keyframe button.
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5. Move the destination keyframe upward.

NOTE: It is important that the last keyframe remains above the first one.

6. Make sure that the first keyframe is not a stop-motion keyframe. To do this, disable the Stop-motion
Keyframe button. To use the Toggle Stop-Motion Segment feature, press S.

7. Click on the keyframes and pull the Bezier handles to create ease in and ease out. If youmake the curve
go downward instead of upward, the animation will play backward until the curve starts to go upward
again.
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NOTE: If you have more than one morphing sequence in the same layer, you need to add a keyframe on the velocity
curve for each source and destination drawing.

8. If you want your morphing to play back on a double frame exposure rather than single frame, you can use
the Hold Value editor and set the velocity to change every second frame, instead of every frame.

9. In theMorphing Function editor, click on the Hold Value Editor button and set the parameters to hold
the value for two frames.

Morphing Tool and Hints

Harmony's Morphing tool controls your morphing sequence, this works by placing different types of hints to
help the systemmorph the animation the way that you want it.
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Hints are points that are placed in both the source and destination drawings. They associate zones and lines
between the two drawings. Hints are used to fix problem zones, such as a line that is not following the colour
fill zone.

Corners and points aremore challenging, in general. Animation curves are complex and may be unable to
match corners. It will generally associate a corner with its nearest neighbour; this is not always correct and it is
why we use hint points to determine what goes with what.

Using the Morphing Tool

Hints are identification points existing in both the source and destination drawings to create associations
between the two of them.

To correct morphing distortions, Harmony has different types of hints available for controlling different types
of problems:

• Contour Hint on page 639

• Zone Hint on page 639

• Pencil Hint on page 640

• Vanishing Point Hint on page 640

• Appearing Point Hint on page 641

Each type of hint has a different purpose and they can all be used in the same drawing. Use theMorphing tool
to add hints to your morphing sequences.

A hint will automatically appear in both the source and destination drawings when it is added. A hint cannot
exist in a single drawing. If you delete a hint from one drawing, it will be also deleted from the other.

The key to placing your hints is to put themwhere the biggest problem is. Fix the largest distortions first, this
may also fix the smaller ones at the same time.
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Do not add too many hints, this is a commonmistake whenmorphing, it takes some practice to learn how to
correctly use and place hints.

How to Add and Remove Hints

1. In the Timeline or Xsheet view, select the source or destination drawing of your morphing sequence.

2. In the Tools toolbar, select theMorphing tool or press F3.

Use your other morphing key drawing, shown in the Drawing view's bottom right corner, as a reference.

3. In the Tool Properties view, select the type of hint you want to use.

‣ Select Contour Hint to correct a brush line or colour zone's contour (Contour vector).
Contour Hint points will behave similar to Pencil Hint points when used on a pencil line. Note that you
obtain better results using the Pencil Hint point on pencil line rather than Contour Hint points.

‣ Select Pencil Hint to correct a pencil line (Central vector).

‣ Select Zone Hint to correct a colour zonemorphing match.
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‣ Select Vanishing Point Hint to correct a vanishing shape's trajectory.

‣ Select Appearing Point Hint to correct an appearing shape's trajectory.

4. In the Camera or Drawing view, click on the drawing near the problematic area.

5. Select the hint's point and move it to its correct position.

6. Select one or many hints and press Delete to remove extra or unused hints.

‣ To delete all of the hint points at once, press Shift + Delete.

7. In the Playback toolbar, press the Play button to see the result.
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Hints

Hint points in the source drawing are green and red in the destination drawing.

Contour Hint

The Contour Hint point is used on the colour fill zone and brush lines; in other words, on Contour vectors. It
allows you to control the line thickness and contour position. Also, if a contour is not animated correctly, you can
use hints to correct the animation. For example, if a flag is not waving properly.

When adding a Contour Hint point, make sure to place it far enough away from the contour so you can see it snap
to the contour.

Contour Hint points are yellow.

NOTE: Do not place the Contour Hint directly on the line as it may look like it has snapped to the contour, when in
fact, it has not and the morphing will remain unchanged.

NOTE: To correct a brush stroke, place a hint on both sides of the line to indicate its thickness variations over time.

Zone Hint

The Zone Hint point is used on a colour zone to control the proximity rule. The Zone Hint is placed in the
centre of the colour zone. Sometimes a colour zone is not associated with the corresponding one by default. For
example, in a splash animation there aremany water droplets that are the same colour. Harmony automatically
morphs the droplet to the nearest one. This is not always the one youmay have predicted. A Zone Hint will force
a colour zone to morph with another one.

Zone Hint points are cyan in colour.
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Pencil Hint

A Pencil Hint point is used to control a pencil line, also known as central vector. It can be used on drawings
that were done using the Pencil, Polyline, Ellipse, Line and Rectangle tools. Like the Contour Hint, the Pencil
Hint snaps to the central vector. Make sure to place it far enough away from the line so you will see it snap
when youmove it.

Pencil Hint points aremagenta in colour.

Vanishing Point Hint

AVanishing Point Hint is used to control the trajectory of a vanishing shape. A shapewill vanish from the
source drawing when there is no corresponding shape in the destination drawing. If you do not place a
Vanishing Point Hint to control the point of disappearance, the shapewill vanish into its centre.

Vanishing Point Hint points are green in colour.
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Appearing Point Hint

AnAppearing Point Hint is used to control the trajectory of an appearing shape. A shapewill appear in the
destination drawing when there is no corresponding shape in the source drawing. If you do not place an
Appearing Point Hint to control the point of appearance, the shapewill appear from its centre and expand
outwards.

Appearing Point Hint points are violet in colour.

Copying Hint Points from One Drawing to Another
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If you have two morphing sequences that use the same drawing and youwould like to copy it and its hint
points, you can do so in the Drawing view.

How to copy a drawing and its hints

1. Do one of the following:

‣ In the Tools toolbar, click the Select tool.

‣ Press Alt + S.

2. In the Drawing view, select the drawing to reuse in your second morphing sequence.

3. Do one of the following:

‣ In the top menu, select Edit > Copy.

‣ Press Ctrl + C (Windows/Linux) or⌘ + C (MacOS X).

4. In the Timeline view, select the cell where the new drawing will be.

5. In the Drawing view, paste your selection.

6. Do one of the following:

‣ In the top menu, select Edit > Paste .

‣ Press Ctrl + V (Windows/Linux) or⌘ + V (MacOS X).

7. In the Timeline view, select the cell where the second drawing will be.

642



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

8. In the Drawing or Camera view, draw your second drawing.

9. Do one of the following:

‣ In the Timeline view, create themorphing sequence for the new drawings.

‣ Press Alt + M.

10. Do one of the following:

‣ In the Tools toolbar, select theMorphing tool.

‣ Press F3.

11. In the Drawing or Camera view, position your hint points.

Morphing Layers
Morphing layers simplify themorphing animation. Complex shapes are often too difficult to control and may not
work properly, by dividing the drawings into morphing layers, the task becomes much easier.

Themajor points used in controlling a morphing sequence are the intersections. If there aremany lines
intersecting within a drawing, the systemwill requiremore control—seeHints on page 639

An important aspect of morphing is to identify possible problem zones in order to fix them and avoid potentially
frustrating situations.
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Identifying Problem Zones

Simple details that look easy to morph can sometimes bemore challenging than theymay initially appear to
be. For example, youmay find that the nose becomes an issue when performing a head rotation. As explained
earlier, the drawings need to be similar in their number of shapes. Generally, on a head rotation, the source
nose is in the centre of the face, but on the destination, the nose line is part of the face outline. This means that
on the source drawing, the nose and the face outline are two separate shapes, whereas they are combined into
one shape on the destination drawing.

Morphing a full face as demonstrated on the figure below will cause the source nose to slowly vanish as the
destination nose grows from the character's cheek.

Any shape that is contained inside another one and has to morph out of that shape will be problematic for the
same reasons as the nose is. At some point during themorphing sequence, the shape contained inside the face
will merge with the face outline, and then become a separate shape again.
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Morphing Layer Properties

It is because of these reasons, explained in the section, Identifying Problem Zones on page 644, that morphing
layers exist. Morphing layers are all contained in the same drawing layer. It is like having a mini Timeline within a
Timeline layer, or a mini Xsheet within an Xsheet column.

Eachmorphing layer can have its own duration and velocity. Also, because you only have a single element to
handle in your Timeline or Xsheet view, it will be treated as one element for the Compositing process, making the
compositor's work easier.

You can separate all of your elements into different drawing elements and havemany layers, but you would have
to create a large number of morphing sequences and make sure that youmodify all of their timings properly.

NOTE: Both solutions are correct, but morphing layers makes it easier to handle and does not change the scene
structure by adding more elements, which can be very important for Cut-out animation puppets. For example, if you
morph a front head to a three-quarter head where the ear needs to be separate, you do not want to add a new ear
layer at the same time and have to worry about connecting it inside the puppet's construction. Instead, simply create
an ear morphing layer within the head layer.
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How to create a morph with morphing Layers

When you click on a morphing layer drawing, it automatically appears on top of the others. If you want it to
stay in place, for example the wing behind the body, enable the Show Morphing in Place option in the
Morphing Tool Properties view.

NOTE: Use a naming convention for each morphing layer such as ear_1, ear_2 or head_1, head_2. You can also use
the numbers 1 to 9 for the first layer, 10 to 19 for the second one, 20 to 29 for the third one and so one. This
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technique is useful if you plan to do more than one morphing sequence in the same column. For example, front head
to three-quarter head to side head. The three-quarter drawings will be used in both morphing sequences.

How to create a morph with morphing layers

1. In the Timeline view, add a new drawing element and name it properly.

2. In the first cell, draw themain source shape such as the head shape or body shape. Do not add details like
eyes.

3. In the Timeline view, select the destination cell.

4. Enable and extend theOnion Skin.

5. In the destination cell, draw the second drawing.

6. In the Timeline view, select the in-between cells.

7. Do one of the following:
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‣ Right-click and selectMorphing > Create Morphing.

‣ Press Alt + M.

8. In the Tools toolbar, select theMorphing tool.

9. In theMorphing Tools Properties view, click on the Add Layer button to add a new morphing layer.

10. Double-click on the new layer's name and name it appropriately.

11. Press Enter/Return.

12. Use the Up and Down arrow buttons to move the new layer above or below the Main layer.

‣ If placed above the Main layer, it will be displayed in front. If it is placed below, it will be displayed
behind.
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13. To create new drawings, double-click on the blank area under the From section to create the source draw-
ing and the To section for the destination drawing and type a different value than the ones used for the
main layer.

14. Press Enter/Return.

You do not need to type any value for the Main layer as it uses the one from the Xsheet column.

15. Click on the new source drawing to start drawing the new part. (Make sure that you are working on the
proper drawing by verifying the name in the Camera or Drawing view's bottom left corner.)

16. In the Camera or Drawing view, draw the source drawing.
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17. Once the source drawing is done, use theMorphing Tool Properties view and click on the destination
drawing's name and draw it in the Camera or Drawing view.

18. Repeat steps 9 to 15 for each layer needed. You can add as many layers as you want.

19. Enable or disable the layers that you want to display or hide while drawing.

20. If you want to change the layer duration, click on the layer and change the start and stop numbers.

The length indicator changes according to the new values.

Morphing Two Sequences in a Row
If you aremorphing two sequences in a row, you will have to create a different set of hint points for each
sequence.

Morphing two sequences in a row requires three drawings: 1, 2 and 3. Using these three drawings you create
two morphing sequences; one sequence between drawings 1 and 2, and a second sequence between drawings
2 and 3.
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NOTE: Each morphing sequence has its own set of parameters and hints. This means that Drawing 2 will have a set of
hints for the first sequence and another set for the second sequence. The two sets of hints will not show at the same
time. Each set of hints that appears always corresponds to the morphing sequence you are working on.

Inserting a Morphing Key Drawing

Once you have a morphing sequence, you can add a morphing key drawing.

Amorphing key drawing allows you to insert extra details into a morphing sequence. For example, during a
morphing sequence youmay need to insert a detail such as teeth or a mouth; this is easy to do when you use a
morphing key drawing. Instead of creating an entirely new drawing, convert a computer generated in-between to
a morphing key drawing and add your extra details to it and the next key drawing.

Amorphing key drawing converts a computer-generated morphing frame into a real drawing that you can edit. It
splits themorphing sequence into two sequences, retaining any previous modifications.

How to insert a morphing key drawing

1. In the Timeline or Xsheet view, select themorphing frame youwant to transform into a morphing key-
frame.

2. Do one of the following:

‣ In the top menu, select Animation > Morphing > Insert Morphing Key Drawing.

‣ Right-click and selectMorphing > Insert Morphing Key Drawing.
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The new morphing key drawing appears.

3. In the Drawing or Camera view, draw your new details on themorphing key drawing.

4. In the Playback toolbar, press the Play button to see the result.

Converting Morphing Inbetweens to Drawings
Harmony lets you convert your morphing inbetweens to real drawings you can edit. This is useful when
manually editing a morphing sequence or if you prefer to have animation timing in double frame (on twos)
instead of single frame (on ones).

How to convert morphing inbetweens to drawings

1. In the Timeline or Xsheet view, select a morphed drawing in themorphing sequence you want to convert
to real drawings.

2. Do one of the following:

‣ In the top menu, select Animation > Morphing > Convert Morphing to Drawings.

‣ Right-click and selectMorphing > Convert Morphing to Drawings.

The Converting Morph dialog box opens.

3. Type the drawing basename youwant to give to your new drawings. In this case, you could type
circle.

4. Click OK.

Morphing Holes and Transparencies
To be able to morph shapes with holes or transparent colours, it is important to understand the process of
analyzing and morphing a shape. Harmony begins the process by reading the exterior outline of the entire
shape. So if you aremorphing a doughnut, it will first read the entire circular shape and ignore the central hole.
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Once the general morphing shape is analyzed, the systemwill carry on analyzing the interior details such as colour
zones and holes.

As you can see, because the hole was placed on top after themain shapewas morphed, the centre is filled with an
opaque brown colour. In order to avoid opaque holes, you have to paint the zone with a transparent colour so
that you can control it and flatten the transparency to cut a hole through themain shape.

The same thing happens when you have holes painted with semi-transparent colours. To see through your
shapes, you have to follow the same process as morphing shapes with holes.

How tomorph a shape with a hole

1. In your Colour view, select an unused colour swatch and set its alpha (transparency) to 0.
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2. Paint both holes on the source and destination drawings.

3. In the Timeline or Xsheet view, click on a cell in your morphing sequence.

4. Do one of the following:

‣ In the Tools toolbar, select theMorphing tool.

‣ Press F3.

5. In the Tool Properties view, enable the Flatten button.

A hole appears in the shape.
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Adjusting the Morphing Quality
Increasing themorphing quality settings improves the line shape between vector points. It also creates a larger
file, so only increase quality when you are zooming in closely. You can adjust the quality in the Tool Properties
view and in the Preferences panel.

Whenmorphing in Toon BoomHarmony, there is a preference you can set to help you set the default quality of
morphing sequences. Refer to the following parameter in the Preferences Guide for complete descriptions.

• Drawing tab: Settings, Morphing Quality

How to set a morphing sequence's quality level

1. In the Timeline or Xsheet view, click on a cell in your morphing sequence.

2. Do one of the following:

‣ In the Tools toolbar, select theMorphing tool.

‣ Press F3.

3. In the Tool Properties view, adjust theQuality level.

Tips and Tricks
This section provides a list of easy tips and tricks to help youmorph your drawings more efficiently.

Using the Brush Tool as a Beginner

When learning about morphing, it is recommended that you use the Brush tool. You can use the Pencil line for
simple closed shapes.

Using the Contour Hint on Pencil Lines

If you are using pencil lines, use Contour hints instead of Pencil hints. Use Pencil hint if you want the Pencil line to
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switch direction.

FlatteningDrawings

Flatten your drawing before starting a morphing sequence.

Cleaning-up your Drawings

If you leave a dot, even the smallest one, it is possible that your morphing will create odd shapes. If the source
line is closer to the dot than the destination line, the source line will morph into the dot and the destination line
will disappear.

Using the Same Colour Swatch

Use the same colour swatch between two drawings. You cannot morph between two different colour swatches
even if they have the same RGB values. This can be turned to your advantage for complex morphing.

Morphing Similar Shapes

Similar shapes should have the same number of colour zones. This only applies to the number of zones and
lines and not the number of points on a curve.

Avoiding Crossing Zones DuringMorphing

If a zone inside a larger zone on the source drawing ends up outside on the destination drawing, themorphing
will fail.

A line cannot cross another line during a morphing sequence.

For example, if you aremorphing a face so it turns from the front to the side, the nose is located in themiddle
of the face on the source drawing. However if after morphing, the nose ends up outside or merged with the
face profile line on the destination drawing, this will give undesirable results. You can avoid this by using
morphing layers and splitting the nose on a separate layer.

Glossary

alpha channel

An image channel that carries transparency information. An image already
has three channels: red, green and blue (RGB). The alpha channel is the
fourth channel (RGBA). Thematte, or the transparency information, is
stored in this fourth channel. An imagewithout an alpha channel is always
opaque.

animatic

Amovie with sound that is developed from the storyboard. The storyboard
panel is exposed for the duration of the scene and at times, the characters
are placed on a trajectory to indicatemotion. The camera moves are also
animated. The animatic is used to determine the rhythm of a project and
provides a good overview of the project before beginning production.

animation
A simulation of movement created by displaying a series of pictures or
frames.

anime An animation style known for its sinister and dark feel; popular in Japan.
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arc
Action rarely occurs in a straight-forward manner; rather it typically unfolds
in what storytellers refer to as an arc. The purpose of a story arc is to move
a character or situation from one state or scenario to the next.

aspect ratio
The relationship between the width and height dimensions for any scene,
frame or film format. Television ratio is 4:3 and widescreen ratio is 16:9.

auto-feed
An automated method of feeding drawings into a scanner in whichmultiple
drawings are stacked into a sheet feeder. When the scanner is activated,
the drawings are scanned consecutively, without further user intervention.

automatic lip-sync detection
Automatically mapping drawings in an element to themouth chart
generated for a sound. This can save timewhen lip-syncing a voice track.

axis

An imaginary line around which an object rotates.

For 2D graphics, there are two axes: X (horizontal and Y (vertical).

For 3D graphics, there are three axes: X (horizontal, Y (vertical) and Z
(depth).

background
The part of a scene that is farthest to the rear. The background is the
artwork, or decor, against which the animation takes place.

Bézier
Amethod of defining curved lines invented by Frenchmathematician Pierre
Bézier. A Bézier curve is a mathematical or parametric curve. Bézier curves
use at least three points to define a curve.

bitmap
An image composed of pixels with a single resolution (size). If it is enlarged
too much, it will lose definition and pixels will begin to appear. This is
known as pixelation.

breakdown

In cut-out animation, breakdown is the action of breaking a character into
pieces to create a puppet with articulations. To break down a character,
the artist cuts parts, such as the hands and arms, from the character's
model and pastes them in separate layers. Next, the joints are fixed and the
pivots set.

In traditional animation, a breakdown is an animation pose generally found
between two key poses. The key poses are themain poses in an animation
and the breakdowns are secondary poses, ones that help describe the
motion and the rotation curve (usually referred to as an arc).

camera shake
Camera shake occurs in a scene when the camera moves slightly and quickly
in several directions. This gives the impression of an impact, vibration or,
for example, bumps on the road.

caption
A text field containing dialogue, effects, sound, or slugging information in a
storyboard.

cel

In traditional animation, a cel (also known as celluloid) is a transparent
sheet on which the animation is inked and painted before being sent to the
camera. The picture's outline is drawn on the front of the cel and then
coloured along the back.

In Harmony, a cel is an individual space in an Xsheet column fromwhich you
can expose a drawing or a function's coordinate.

character design Each character in an animated film is drawn frommultiple angles in poster-
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style format, called amodel sheet, which serves as a reference for the
animators.

clean up

After rough drawings have been tested and approved, all the noise in the
image (excess lines, notes, etc) is removed to create final drawings which
can be inked, painted and shot. The cleanup process refers to either tracing
a clean line over a rough drawing to achieve the final version, or removing
dirt and extra lines left by the scanning process.

CMYK
Cyan, Magenta, Yellow, Black. Refers to the process used by printers to
define colour on the printed page.

colour card
A colour card is a solid colour card that is the same size as the camera. The
colour card can be used to fill the background with a solid colour when
there is no background image included.

colour model
The official colour design that must be used to paint the animation. A
model is the definitive character, prop, or location design that each artist
must follow for the production.

colour wheel Adisplay of the colour spectrum in the form of a circle.

compositing

Compositing is the action of incorporating all of a scene's elements to
create the final result prior to rendering. For example, the compositing
artist will import all the animation sequences, background, overlays and
underlays in the scene and position them correctly. The artist will then set
the camera frame and animate it, if needed. Finally, the animator will create
all the computer-generated effects for the project.

cross dissolve An effect used to fade two scenes, one into the other.

cut
Adirect transition between two scenes. When a cut is used, there are no
transition effects inserted to pass from one scene to the next. The first
scene ends and the second one starts immediately.

cut-out animation
The action of animating characters made of several pieces bymoving them
around frame by frame. Cut-out animation can either be computer
generated or done traditionally using paper.

cycle
Agroup of images that together make up an action, such as walking. A
cycle is an action repeated as a loop over a period of time. It can be a series
of animated drawings or keyframes.

dialogue The text spoken by a character in a movie or animation.

dope sheet
Used by animators, directors and other members of a crew to track the
sequence and timing of images, dialogue, sound effects, sound tracks and
camera moves. Also known as an exposure sheet or Xsheet.

doping To assign a particular drawing to a range of frames.

DPI

Dots per inch is the standard measure of resolution for computerized
printers. It is sometimes applied to screens, in which case it should more
accurately be referred to as pixels per inch. Either way, the dot is the
smallest discrete element making up the image.

ease/velocity
In animation, the ease, also known as velocity, is the acceleration and
deceleration of a motion. It can be a motion created by a function curve, or
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a series of animated drawings. Other common terms for ease-in and ease-
out are slow-in and slow-out.

ease-in Gradual acceleration in the action. Also known as slow-in.

ease-out Gradual deceleration in the action. Also known as slow-out.

establishing shot

A scene in which the viewer can see the whole area in which a sequence is
happening. For example, if a child is playing on the ground in front of his
house, the establishing shot would be a scene where the viewer can see the
house, the ground, a part of the street and the buildings around the central
point of action. This helps the viewer understand the story location and
scene orientation.

exposure
In animation, an exposure is the number of cels on which a drawing appears
in the scene. For a drawing to appear longer, the exposuremust be
extended over a greater number of cels.

exposure sheet

A sheet with several vertical columns and horizontal frames used to indicate
a scene's timing. Each column represents a scene layer. The drawing
numbers in each column are indicated and repeated over the particular
amount of frames they need to appear.

The exposure sheet is used by animators, directors and other members of a
crew to track the sequence and timing of images, dialogue, sound effects,
sound tracks and camera moves. Also known as a dope sheet.

fade in/fade out

Fade in or fade out is a transition effect used to open or close a sequence. A
fade in occurs when the first scene appears progressively, from complete
transparency to its complete opacity. A fade out occurs when the last scene
progressively disappears, going from complete opacity to complete
transparency.

fast-in Dramatic acceleration at the start of the action.

fast-out Dramatic acceleration at the end of the action.

field
In animation, a field is a measurement unit used to calculatemotion,
registration and camera positioning. A standard animation scene will vary
between 6 to 12 fields.

field chart
Aguide containing all the field units that animation and layout artists use to
determine a scene size or camera motion.

film-1.33
A resolution that is ideal for the widescreen film format that conforms to
the standard 4:3 pixel aspect ratio.

film-1.66
A resolution that is ideal for the widescreen film format that conforms to
the 16:9 pixel aspect ratio. (The pixels are wider than they are high).

flipping

In traditional animation, flipping is the action of going through the drawings
of an animation sequence very quickly in order to see the animation in
motion. Flipping can also be the action of creating a mirror transformation
of an object.

follow-through
The secondarymotion caused by themain action. For example, a character
wearing a cloak is running. Themain action is the body running. This will
cause the cloak to follow themotion, although it will not move at the same
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time, but react a few frames later and follow themainmotion curve.

forward kinematics

Forward kinematics is a feature used to animate principally 3D characters
and cut-out puppets with hierarchy. It is used to animate a puppet from one
of parent parts, such as a shoulder, and make the rest of the armmovewith
it as a single piece.

frame
A single photographic image in a movie. In traditional animation, the North
American standard generally contains 24 frames per second, while in
Europe the standard is 25 frames per second.

frame rate

The frame rate is the speed at which the frames are played. They are
generally calculated by frame per second. For example, a scene could be
played back at 12, 24, 25, 30 or 60 frames per second or any other number.

This is themeasurement of the frequency (rate) at which an imaging device
produces unique consecutive images, called frames. The term applies
equally to computer graphics, video cameras, film cameras, and motion
capture systems.

Frame rate is most often expressed in frames per second (fps) and in
progressive-scanmonitors as hertz (Hz).

functions
A computer-generated motion, trajectory or path on which elements, other
trajectories and effects parameters can be attached. The function can be
controlled by adding keyframes and control points on the function curve.

gamut The range of colours that a particular device can represent.

HDTV

High Definition Television delivers a higher quality image than standard
television does because it has a greater number of lines of resolution. To
take advantage of the superior quality and make full use of your resolution
setting, the output devicemust be compatible with HDTV technology.

hold
A frame in the animation in which the character maintains its position
without moving. A hold can be created between any two keyframes.

HSV
Hue, Saturation, Value. Amethod of defining colours in terms of hue (tint),
saturation (shade) and value (tone or luminance).

in-between
The drawings that exist between the key poses. These are drawn to create
fluid transitions between poses.

ink and paint
The ink and paint process is the action of painting the empty zones and
colouring the lines on the final animation drawings, while following a colour
model.

interpolation
The computer-generated motion created between two keyframes. You
have the choice to create interpolation, or not, between your keyframes.

jump cut

A jerky cut between two scenes. Typically, a jump cut is not visually
pleasing. It is generally caused by one scene ending, and a second one
starting, with a similar image. The lack of difference causes the eye to see a
little jump between the two scenes.

key pose
Important positions in the action defining the starting and ending points of
any smooth transition. Keys, or key poses, are themain drawings in an
animation sequence describing themotion. For example, if an arm is
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waving, the keys will be of the arm at one extremity of the wavemotion and
the other extremity. By flipping those drawings, the animator can see the
skeleton of themotion without having all the drawings.

keyboard shortcuts
One or more keyboard keys which, when used, cause an operation to be
performed.

keyframe
Important positions in the action defining the starting and ending points of
any action. A keyframe is a computer-generated position at a specific
moment (frame) on a given trajectory.

layers
In animation, a layer is an individual column, level or character. A scene's
layers are superimposed to form the final image.

layout

The communication step between the storyboard and the animation. It is
the action of putting the storyboard onmodel. That is, drawing the
character by following the design in themodel pack, so the animator can
start working.

The layout artist draws the background, creates the camera and field guide
matching the scene and camera motion. Lastly, the animator draws on
model themain action poses.

layout and posing
The action of putting onmodel. That is, at the right scale, the storyboard
for the animator to start working.

library
A storage area containing templates and assets that can be reused in any
project or scene.

light table
Adevice that allows you to see other layers in transparency while you are
working on a particular layer.

line of action The direction that the action will follow. Also known as path of action.

lip-sync
The character's mouth synchronization with the dialogue sound track.
Frame by frame, themouth will be adjusted to fit the sound to give the
illusion of the character is speaking.

low resolution
A format that is ideal for videos destined for the web, where size and fast
download of a video file take precedence over quality. A low-resolution
image is one that lacks fine detail.

manual lip-sync detection
Themanual swapping of mouth position drawings to match a voice track.
For this process, both sound scrubbing (listening to a sound wave broken
up frame-by-frame) and drawing substitutions are used.

master palette

A group of colours attributed to a character or prop. The palette is used
throughout the entire production to maintain consistency in the look and to
ensure that the same colours are used throughout the production. Also
known as palette.

model/colour model
The definitive character, prop or location design each artist must follow for
a production. A colour model is the official colour design that must be used
to paint the animation.

motion keyframe A keyframewith computer-generated interpolation.

mouth chart
A chart based on the eight animation phonemes (A, B, C, D, E, F, G, and X,
which is used to represent silence) used for lip-sync.
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multiplane

The effect of passing throughmultiple levels of drawings to create a sense
of depth in a shot. Amultiplane is a scene in which the layers are placed at
different distances from the camera so that when the camera moves, a
depth illusion occurs. With a multiplane, all the perspective and scale is
calculated automatically.

NTSC
The standard analogue television broadcasting system used in North
America. NTSC conforms to North American standards on how rectangular
pixels are displayed for computer and television screens.

nudge
A small push (left, right, up, down, forward or backward) done with the
keyboard arrow keys on a selected element. Nudging is used to move a
selection very slightly and precisely.

onion skin A feature that lets you see the previous and next drawings of a sequence.

overlay
Apart of the scene environment, such as a chair or a bush, that is placed in
front of themain animation.

PAL
A resolution that works best with the European format for television and
computer screens, as the rectangular pixels are displayed at a different
orientation.

palette/master palette

Apalette or master palette is a group of colours attributed to a character
or a prop. The palette is used throughout the entire project to maintain a
consistency in the look and avoid the colour changing during the animation.
Also referred to as a master palette.

palette style
Apalette style is a second version of an existing palette with a slight change
in the tint and value. A palette style can be used to create the night version
of a palette. It may also be called a clone palette.

pan To move the camera across the scene in any direction.

panel
In a storyboard, a panel is a frame in a shot. A shot can be composed of one
or several panels.

paperless animation/tradigital
The paperless animation process is the action of animating digitally. The
main paperless animation process is to draw, frame by frame, the
animation directly in the software.

passing position
When drawing a walk sequence for a character, the passing position is the
point at which one leg passes the other.

path of action Direction that the action will follow. Also known as line of action.

peg

In traditional animation, a tool used to ensure accurate registration of
action as cel layers move. In digital animation, in which you are doing a
more advanced puppet rigging, you can use peg layers. Peg layers are
trajectory layers that do not contain drawings. They aremotion paths that
you can use to add path articulations. For the latter, you can also use the
Inverse Kinematics tool.

phoneme A unit of sound in a language.

pivot The point around which a peg or drawing rotates.

pixel The smallest element of an image displayed on a monitor or TV screen.
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Pixel, short for picture element, is a single point in a graphic image. It is a
small sample of an image, a dot, a square, or a very small sectionmade out
of smooth filtering. If you zoom in close enough on a digital image, you will
see the pixels, which look like small squares of different colours and
intensity.

pose-to-pose animation

The pose-to-pose animation process is the action of creating all themain
action poses, called key poses, and then placing the secondary poses
between the keys. The secondary poses are called breakdown. Finally, the
animator fills the gaps with the in-between drawings to achieve a smooth
animation.

rendering

The final step when animating by computer. During rendering, the
computer takes each pixel that appears on screen and processes all of the
components, as well as adding motion blur before it produces a final
image. The process of calculating the final images after the compositing
process.

resolution
The size of a scene, generally calculated in pixels. For example, the NTSC
resolution is 720 x 480. The resolution should match the final output: HDTV,
film-1.33, film-1.66, NTSC, PAL, low.

RGB
Red, Green, Blue. Amethod of defining colour by specifying amounts of
these three colour components.

rigging The process of attaching the various parts of a cut-out puppet.

rotary table
Equivalent to the animation disk/table, a device that allows you to rotate
the workspace for greater comfort while drawing.

rotoscoping
An animation technique in which animators trace over live-action film
movement, frame by frame, for use in animated films. The act of sketching
over live-action footage to create an animated sequence.

roughs
The skeleton sketch of an animation or design. Roughs mainly consist of
sketch lines and shapes, though they can also contain design details.

safe area

The zone at the center of a scene's frame that is safe from being cropped
by the TV frame. As a TV frame cuts a margin off the original frame size,
maintaining a safe area ensures that the scene's main action will remain
clearly visible once the film is screened on television.

scene
A shot in a movie or show. A sequence is composed of several scenes. A
scene changes to another scene by a simple cut or transition.

script
The original text containing all themovie or show information. In animation,
the script contains all of the location descriptions, dialogue, time andmore.
A project starts with a script.

sequence
A series of scenes or shots forming a distinct part of the story or movie,
usually connected by unity of location or time.

shot
A scene in a movie or show. A sequence is composed of several shots. A
shot changes to another shot by a simple cut or transition.

slow-in The gradual acceleration in the action. Also known as ease-in.

slow-out The gradual deceleration in the action. Also known as ease-out.
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slugging To indicate the start and stop times of dialogue and relevant actions.

sound scrubbing
Aprocess that lets you hear sound in real timewhile youmove the playhead
forward or backward. This is very useful for finely-tuning a lip-sync.

stop-motion keyframe A keyframewith no computer-generated interpolation.

storyboard
A visual plan of all the scenes and shots in an animation. The storyboard
indicates what will happen, when it will happen and how the objects in a
scene are laid out.

straight-ahead

A technique in which an entire sequence is drawn from the first position to
the last, in order. There is very little planning in this methodology. Where
the character ends up and how it gets there can be a surprise for both the
audience and the animator. While this approach is spontaneous and
creative, it can create inaccurate results.

strokes
Invisible vector lines forming the drawing zones. They can be adjusted with
Bézier handles.

tablet/pen
Adevice used in conjunction with, or instead of, a mouse to move a mouse
pointer (sometimes referred to as the cursor) around the computer screen.

template

An asset stored in the library that can be reused in any project. A template
can be a drawing, a series of keyframes, a sound file, a panel, a cut-out
character, an effect, a trajectory, an animation, or anything else used in the
animation.

thumbnails A very small image used as a reference or indicator.

timecode
The timing information printed on a movie clip to indicate the scene, hour,
minute and second that is currently displayed on the screen.

timeline A horizontal representation of a scene's elements, timing and keyframes.

trace and paint

After the rough animations have gone through cleanup and a final line or
pencil test, each drawing is traced and painted for the final animation. In
today's digital world, this may be done in a variety ways other than the
traditional celluloid or acetatemethods.

track breakdown
The break down of an animated film's soundtrack into individual sounds to
produce the precise frame-by-frame position of each sound.

traditional animation
A type of animation process whereby all the animation sequences are
drawn by hand on paper before scanning or inking them on cels.

trajectory
A computer-generated path or trajectory that elements can follow. The
trajectory can be controlled by control points, keyframes and velocity.

transition
An effect placed between two scenes as they pass from one to the other.
Common transition effects are cross-dissolve and wipe.

underlay
In animation, an underlay is a specific part of the decor placed behind the
main animation.

aspect ratio
The aspect ratio describes the shape of the grid unit. A square grid unit
would have a 1:1 ratio , whereas a grid unit of aspect ratio 4:3 is a unit with
one side 1.33 times as big as the other side.
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vector

A vector-based image is composed of points and Bézier curves. The
computer reads the points and traces the segments, linking them to
reproduce the image shape. There is no fixed size or resolution in a vector
image. The graphic can be enlarged and distorted as much as desired and
the systemwill simply recalculate the segments and rebuild the shapes.
Vector images are translated and displayed in pixels once the calculation is
done.

velocity

In animation, the velocity, also known as ease, is the acceleration or
deceleration of a motion. This can be achieved by a function curve, or via a
series of animated drawings. Other common terms for ease-in and ease-out
are slow-in and slow-out.

walk cycle

A series of drawings "on the spot" that describe the walk for a character.
The illusion of movement is created by the use of background pans. To
avoid making innumerable drawings, animators routinely make a walk cycle
for a character.

Xsheet (exposure sheet)

The Xsheet or exposure sheet, is a sheet with several vertical columns and
horizontal frames used to indicate a scene's timing.

Each column represents a scene's layer. In each column, the drawing
numbers are indicated and spread over the specific number of frames in
which they appear.

The exposure sheet is used by animators, directors and other members of
the crew to track the sequence and timing of images, dialogue, sound
effects, sound tracks and camera moves. Also known as dope sheet.

zone An area which can be painted with colour.

665



Harmony 12.1 Premium - Cut-out Animation Guide (Server)

666



•

Index

alpha channel 656

animatic 656

animation 656

anime 656

Annotation column 269

erasing annotations 272

pen colour 272

pen width 272

annotations

changing pen colour 272

changing pen width 272

erasing 272

arc 657

aspect ratio 657, 664

auto-feed 657

axis 657

background 657

backing up

palettes 207

Bezier 657

bitmap images 657

Bitmap layer 255

bitmap resolution

height 77-78

resolution factor 77-78

width 77-78

Bone deformer

basic rig 431

Bone rig 432

Curve rig 434, 436

Bone rig

creating 432

breakdown 657

character 356

brush size 24

Brush tool

drawing 19

presets 24, 110

size 24

brushes

exporting 48, 127, 164

importing 47, 126, 164

Camera layer 256

camera shake 657

caption 657

cel 657

celluloid

See cel. 657

character building

breaking down 356

character design 657

drawing with brush 19

drawing with pencil 19

getting references 18

preparation 17

sketching model 19

chart

field 22

clean up 658

cleaning

model 34

cloning

layers and columns 268

CMYK 658

Colour-Card

layer 256

colour card 658

colour model 658, 661

colour palettes

back up 207

location 205

storage location 206

colour swatch

adding 29

colour wheel 658

colours 25

adding colour swatch 29

Column Properties editor

displaying in Xsheet 264

columns

advanced types 258

changing colour 326

cloning 268

collapsing 314

deleting 261

duplicating 268

expanding 314

modifying 265

modifying look 320

navigating 305

properties 262

renaming 266

reordering 267

Timing 274

types 255

Xsheet 254

compositing 658

copying

drawings 309

cross dissolve 658

Curve rig

creating 434, 436

cut 658
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cut-out animation 658

creating 559

selecting layers 564

cycle 658

cycles

exposure, creating 296

deformation

basic rig 431

Bone rig 432

chain, setting up bone and
articulation 440

Curve rig 434, 436

deleting

drawings 308

design tools 17

Override 20

designing

brush size 24

characters 32

drawing with brush 19

drawing with pencil 19

field chart 22

getting references 18

line up 22

preparation 17

relative size 21

sketching model 19

tool presets 24, 110

dialogue 658

dope sheet 658

doping 658

DPI 658

drawing

applying thickness stencil 45

brush size 24

Brush tool 19

brushes, exporting 48, 127, 164

brushes, importing 47, 126, 164

characters 32

cleaning model 34

colour swatch, adding 29

colours 25

creating thickness stencil 45

current drawing on top 40

deletiing thickness stencil 47

exporting brushes 48, 127, 164

field chart 22

importing brushes 47, 126, 164

inking model 34

line up 22

model 33

Override tool 20

palettes 25

pencil presets, creating 45

pencil presets, selecting 44

Pencil tool 19, 40

presets, pencil 45

relative size 21

stencils 43

tasks 39

thickness stencil, applying 45

thickness stencil, creating 45

thickness stencil, deleting 47

thickness stencil, renaming 46

thickness stencil, selecting 44

tool presets 24, 110

drawing elements

adding 258

creating 253

duplicating 268

Drawing layer 255

drawing tools 17

drawings

copying/pasting 309

deleting 308

duplicating 309

identifying 323

managing 306

marking 323

merging 311

navigating 305

renaming 306

repositioning 23

duplicating

drawings 309

ease 658

setting on multiple parameters 587

ease-in 659

ease-out 659

editors

Column Properties 264

Effect layer 256

Element Manager dialog box

parameters 267

establishing shot 659

exporting

brushes 48, 127, 164

erasers 48, 127, 164

palettes 206

pencils 48, 127, 164

exposure 659

creating cycles 296

decreasing 286

deleting 288

extending 280

extending sequence 281
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Fill Exposure mode 277

filling 276

filling empty cells 295

filling selection 292

filling selection randomly 294

filling sequence with single
exposure 291

holding 279

increasing 286

inserting blank cells 289

moving cells 283

setting 290

typing in values 277

exposure sheet 659, 665

printing 331

extending

exposure 280

exposure sequence 281

fade-in 659

fade-out 659

field 659

field chart 22, 659

Fill Exposure mode 277

film-1.33 659

film-1.66 659

flipping 659

follow-through 659

forward kinematics 660

frame 660

frame rate 660

frames 251

adding before/after selection 251

navigating 305

functions 660

gamut 660

Gestural Drag mode 286

Group layer 256

HDTV 660

hiding

columns 317

layers 315

Hold 660

holding exposure 279

HSV 660

importing

brushes 47, 126, 164

erasers 47, 126, 164

pencils 47, 126, 164

templates 539

in-between 660

ink and paint 660

inking

model 34

interpolation 660

jump cut 660

key pose 660

keyboard shortcuts 661

keyframes 661

Layer Properties editor

displaying 263

renaming layers 266

layers 254, 661

bitmap 255

camera 256

changing colour 326

cloning 268

collapsing 314

Colour-Card 256

deleting 261

drawing 255

duplicating 268

effect 256

expanding 314

Group 256

hiding 315

modifying 265

Peg 257

properties 262

Quadmap 257

renaming 265-266

reordering 266

selecting parent or child layer 564

showing 315

Sound 257

types 255

layout 661

layout and posing 661

library 661

Library view

importing templates 539

light table 661

line of action 661

line up 22

linking

external files 274

lip-sync 661

auto detection 657

lip-sync detection

manual 661

locking

palettes 29

low resolution 661

manual lip-sync detection 661

markers

tempo, setting 330
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markers, scene

setting 327

marking

drawings 323

master palette 661-662

exporting 206

master peg

adding 382

merging

drawings 311

model 661

cleaning 34

inking 34

rough 35

sketching 19, 33

model sheet See character design

morphing

deleting 629

motion keyframe 661

mouth

chart 661

multiplane 662

navigating

columns 305

drawings 305

frames 305

NTSC 662

nudge 662

onion skinning 662

overlay 662

Overrride tool 20

PAL 662

palettes 25, 662

backup 207

creating, Advanced Palette List
mode) 27, 209

creating, Basic Palette List mode) 26,
208

exporting 206

location 205

locking 29

storage location 206

style 662

unlocking 29

panel 662

panning 662

paperless animation 662

passing position 662

Paste Special

pasting with 310

pasting

drawings 309-310

path of action 662

Peg layer 257

pegs 662

adding master 382

pen 664

pencil line

texture 49

pencil presets 43

creating 45

renaming 46

selecting 44

Pencil tool

drawing 19, 40

settings, modify 41

phoneme 662

pivot 662

pixel 662

pixelation See bitmap image

pose-to-pose 663

presets

creating 24, 110

pencil 43

pencil, creating 45

pencil, selecting 44

printing

exposure sheet 331

Quadmap layer 257

relative size 21

renaming

drawings 306

rendering 663

repositioning

drawings 23

resolution 663

factor, bitmap 77-78

height, bitmap 77-78

scene 77-78

width, bitmap 77-78

RGB 663

rigging 663

adding master peg 382

basic deformation rig 431

Bone rig 432

chain, setting up bone and
articulation 440

Curve rig 434, 436

rotary table 663

rotoscoping 663

rough

models 35

roughs 663

safe area 663

scene markers

setting 327

scene resolution 77-78
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scenes 663

adding frames before/after
selection 251

extending 251

removing frames 253

setting length 251

script 663

scrubbing 664

sequences 663

shot 663

showing

columns 317

layers 315

size

brush 24

relative 21

sketching

characters 32

model 19, 33

slow-in 663

slow-out 663

slugging 664

sound

scrubbing 664

Sound layer 257

stencils, thickness

applying 45

deleting 47

pencil 45

renaming 46

selecting 44

thickness 43

stop-motion keyframe 664

storyboard 664

straight-ahead 664

strokes 664

tablet 664

templates 664

creating 528

importing 539

tempo markers

setting 330

textures

pencil line 49

thickness stencil 43

applying 45

deleting 47

pencil, creating 45

pencil, selecting 44

renaming 46

thumbnails 664

tick marks, Xsheet

turning off 274

timecode 664

timeline 664

Timeline view

cloning layers and columns 268

expanding and collapsing
layers/columns 314

modifying layers and columns 265

renaming layers 265-266

reordering layers 266

timing

adding frames before/after
selection 251

Annotation column, adding 269

creating cycles 296

decreasing exposure 286

deleting exposure 288

erasing annotation 272

extending exposure 280

extending exposure sequence 281

extending scenes 251

Fill Exposure mode 277

filling empty cells 295

filling exposure 276

filling selection randomly 294

filling selection with sequence 292

filling sequence with single
exposure 291

frames 251

holding exposure 279

increasing exposure 286

inserting blank cells 289

linking external files 274

moving cells 283

preparing 249

references 250

removing frames 253

scene length 251

setting exposure 290

setting scene markers 327

setting tempo markers 330

Timing column 274

typing in exposure values 277

Timing column 274

linking external files 274

using 275

tool presets

creating 24, 110

tools

Override 20

trace and paint 664

track breakdown 664

tradigital 662

traditional animation 664

trajectory 664

transition 664
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underlay 664

unlocking

palettes 29

vector 665

velocity 658, 665

walk cycle 665

Xsheet view 265, 665

adding frames before/after
selection 251

advanced column types 258

Annotation column, adding 269

cloning layers and columns 268

collapsing/expanding 3D path or
rotation columns 315

columns 254

displaying thumbnails 325

erasing annotations 272

expanding and collapsing
layers/columns 314

layers 254

modifying layers and columns 265

printing exposure sheet 331

removing frames 253

renaming columns 266

reordering columns 267

showing/hiding columns 317

Timing column 274

zone 665
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