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Chapter 1: Compositing - An Introduction
Once the ink and paint is done, the animation completed and the timing locked, you are ready to move 
on to compositing. This includes different components, such as the elements' positioning, scene 
resolution, trajectories, camera moves, effects and filters, and so on. During compositing, you are 
working with computer-generated effects done with Harmony's many effect modules. You can create 
many types of interesting effects and then customize it to suit your animation style.

It is during the compositing phase that the three animation workflows merge together. Whatever your 
chosen path, they all end up in the same animation, together in the same scene. However, the cut-out 
compositing can be a bit more complex due to the advanced networking of the different puppets.

Topics in this section:

• Import on page 17

• Scene Setup on page 85

• 3D Space on page 173

• Animation Paths on page 201

• Sound on page 279

• 2D-3D Integration on page 309

• Effects on page 335

• Export on page 589
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Chapter 1: Import

Toon Boom Harmony allows you to import external content as well as being able to draw directly in 
the software. This means that characters, backgrounds and videos created in other drawing, painting 
and multimedia programs can be brought in and animated. You can import QuickTime videos, 
pictures, multilayered PSD files, as well as AI, SWF and PDF files. You can also scan your images and 
import them as bitmap or vectorize them.

This chapter contains the following topics:

• Importing Bitmap Images  on the next page

• Importing PSD Files as Separate Layers  on page 34

• Exporting and Reimporting a PSD Layout on page 41

• Scanning Images  on page 52

• Importing AI and PDF Files  on page 60

• Scanning Images  on page 52

• Importing Adobe Flash Files on page 63

• Importing QuickTime Movies  on page 67

• Custom Vectorization Parameters  on page 69

For sound import, refer to Importing a Sound File on page 280.
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Importing Bitmap Images 

Images can come in many different file formats and are usually saved in a format that retains the 
original specifications set by the image creator. Some formats can preserve the transparency or 
transparent layers, while others are not resolution dependent due to their vector nature. Toon Boom 
Harmony supports the following formats: JPEG, BMP, PNG, TGA, PSD, TIFF, SGI, TVG, OMF, PAL, 
SCAN.

When importing images and 3D models and linking images, your settings are saved in your user 
settings.

In this section, you will cover the following topics:

• Importing a Bitmap Image Without Vectorization  below

• Importing and Vectorizing Bitmap Images  on page 26

• Linking Your Layer to an External Image on page 28

Importing a Bitmap Image Without Vectorization 

How to open the Import Images dialog box

1. Do one of the following:

‣ From the top menu, select File > Import > Images. 

‣ In the File toolbar, click the Import Images  button.

‣ In the Xsheet view, right-click anywhere in the frame area and select Import > Images.

The Import Images dialog box opens.

18
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How to import a bitmap image in its original format

1. In the Files section of the Import Images dialog box, click Browse to find and select one or more 
images on your computer.

2. Decide if the bitmap image will go on a new layer or an existing layer. To add the bitmap image to 
a new layer, go to step 4. To add the bitmap image to an existing layer, go to step 5.

3. Add the bitmap image to a new layer by selecting the Create Layer(s) option and one of the 
following options: 

‣ Create Single Layer Named: Creates a layer you can name.

‣ Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. 
For example, the filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b", 
where "a" has two drawings and "b" has one. When creating a single layer from these three 
filenames, all three drawings will be inserted in the new layers.

4. Select the Add to Existing Layer option if you want to place the bitmap image on a layer you select 
from the list.  If only vector  layers are available in your scene, they will not be displayed in the 
list. You can choose to encapsulate the bitmap in a symbol by selecting the Create Symbols for 
Imported Items option. 

5. In the Import Options section, select the Keep As Original Bitmap  option. In the Alignment 
section, decide on the size and placement of your image within the camera frame. Depending on 
the Scene Settings (the height and width in pixels that you chose for your project), an image that 
you import may be scaled to the point where all its individual pixels become visible. There are three 
options available in the Alignment section:

Parameter Description

Fit
Enlarges or shrinks (but not distorts) the image height to 
match the full height of the scene grid.

19
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If the image orientation is landscape, this will enlarge or 
shrink (but not distort) your image width to match that of 
the scene grid.

Note that the Fit alignment rule equals the Center Fit rule in 
the layer properties.

Pan

This is the opposite of the Fit parameter. If the image 
orientation is portrait, its width will be made to match the 
width of the scene grid. As a result, part of the image’s 
height will extend beyond the height of the frame. This can 
be useful if you want to make your background move up and 
down, or from left to right to make it appear as if the 
camera is panning, or to actually perform a camera pan.

20
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The opposite will apply to a landscape image. Its height will 
be fit to the scene grid, therefore it is possible that the 
image will extend beyond the scene grid's boundaries.

Note that the Pan alignment rule equals the Center First 
Page rule in the layer properties.

Project Res-
olution

Scales the image in proportion to the scene's resolution. 
The system looks at the resolution of the bitmap image, for 
example 4000 x 2000, then compares it to the scene's 
resolution, for example 1920 x 1080, and adjusts the scale 
factor in proportion. So, in this example, the bitmap would 
appear at 208% (4000/1920). If you import a bitmap that is 
960 x 540, it will be displayed at 50% (960/1920) of the size 
of the project resolution.
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Note that the Project Resolution alignment rule is equal to 
the As Is rule in the layer properties.

6. In the Transparency section, select one of the following from the Alpha menu:

Parameter Description

Premultiplied with 
White 

Individual pixels at the edge of an image are 
blended with white.

Premultiplied with 
Black 

Semi-transparent pixels in the original image 
are blended with black.

Straight 
Pixels at the edge of an image are blended with 
black, white and greys.

Clamp Colour to 
Alpha

Premultiplies the colour value with the alpha 
value. When the colour is clamped to the alpha, 
the colour value cannot be higher than the alpha 
value. It calculates the real colour value faster. 
When the RGB values are multiplied with the 
alpha value, that is, if you have a pixel of value 
R=247, G=188, B=29 and the alpha is 50% or 
the image has a 50% transparency, then the 
actual RGB values that are output would be half 
of the amounts listed above.

7. Click OK.

Adding Images to a Bitmap Layer

How to add more bitmap images to an existing bitmap layer

1. In the Timeline view, if the bitmap image is contained in a symbol, double-click on the bitmap 
symbol cell to edit the symbol. Otherwise, if the bitmap image is on a bitmap  layer, leave it as 
is.

 

2. If necessary, in the Timeline view, pull on the red bracket to extend the exposure.

3. From the top menu, select File > Import > Images or click the Import Image  button.

The Import Images dialog box opens.
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4. Click Browse to find and select one or several images on your computer.

5. In the Layer section, select the Add to Existing Layer option and select an existing bitmap layer 
from the menu.

6. Deselect the Create Symbol for Imported Items option.

7. In the Import Options section, select the Keep As Original Bitmap option. In the Alignment 
section, decide on the size and placement of your image within the camera frame. Depending on 
the Scene Settings (the height and width in pixels that you chose for your project), an image that 
you import may get scaled to the point where all its individual pixels become visible. There are 
three options available in the Alignment section:

Parameter Description

Fit

Enlarges or shrinks (but not distorts) the image height to 
match the full height of the scene grid.

If the image orientation is landscape, this will enlarge or 
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shrink (but not distort) your image width to match that of the 
scene grid.

Note that the Fit alignment rule equals the Center Fit rule in 
the layer properties.

Pan

This is the opposite of the Fit parameter. If the image 
orientation is portrait, its width will be made to match the 
width of the scene grid. As a result, part of the image’s height 
will extend beyond the height of the frame. This can be useful 
if you want to make your background move up and down, or 
from left to right to make it appear as if the camera is 
panning, or to actually perform a camera pan.

The opposite will apply to a landscape image. Its height will 
be fit to the scene grid, therefore it is possible that the image 
will extend beyond the scene grid's boundaries.
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Note that the Pan alignment rule equals the Center First Page 
rule in the layer properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The 
system looks at the resolution of the bitmap image, for 
example 4000 x 2000, then compares it to the scene's 
resolution, for example 1920 x 1080, and adjusts the scale 
factor in proportion. So, in this example, the bitmap would 
appear at 208% (4000/1920). If you import a bitmap that is 
960 x 540, it will be displayed at 50% (960/1920) of the size of 
the project resolution.

Note that the Project Resolution alignment rule is equal to 
the As Is rule in the layer properties.

8. In the Transparency section, select one of the following from the Alpha menu:

Parameter Description

Premultiplied with 
White 

Individual pixels at the edge of an image are blended with 
white.

Premultiplied with 
Black 

Pixels at the edge of an image are blended with black.

Straight 
Pixels at the edge of an image are blended with black, white 
and greys.

Clamp Colour to Alpha

Premultiplies the colour value with the alpha value. When the colour is 
clamped to the alpha, the colour value cannot be higher than the alpha 
value. It calculates the real colour value faster. When the RGB values are 
multiplied with the alpha value, that is to say, if you have a pixel of value 
R=247, G=188, B=29 and the alpha is 50% or the image has a 50% trans-
parency, then the actual RGB values that are output would be half of the 
amounts listed above.
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9. Click OK.

 

 Bitmap Image Quality 
If the bitmap images that you imported look blurry or slightly pixelated, you can clean up the image. 
You can change the quality of the preview in the Camera view and it will not affect the final render.

How to change the bitmap image quality

1. In the Camera view, double-click on the bitmap image to enter its symbol if the image is 
encapsulatesd or simply select the bitmap image layer in the Timeline view if it is not.

2. From the top menu or Camera menu, select View > Bitmap File Quality or press Ctrl + Q 
(Windows/Linux) or  ̂  + Q (Mac OS X).

The Bitmap Image Quality dialog box opens.

3. Drag the slider to the right to improve the quality.

4. Click OK.

5. If you are inside a symbol, go to the top of the Camera view and click Top to exit the symbol and 
return to your scene.

Importing and Vectorizing Bitmap Images 

You can turn bitmap images into vector drawings, while maintaining the sketchiness of a pencil line or 
into vector images with a bitmap fill. Both options can add life to an animation, which straight 
vectorization with smoothing does not usually afford.

How to import and vectorize a bitmap image

1. From the top menu, select File > Import > Images or click the Import Image  button in the File 
toolbar.

The Import Images dialog box opens.
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2. Click Browse to locate images.

3. In the Layer section, decide if the scanned or imported image will be placed on a new layer or 
existing layer. 

‣ Create Layer: Scans or imports the image into a new layer. Select one of the following 
options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For 
example, the filenames a-1.tga, a-2.tga and b-1.tga will create 
layers named "a" and "b", where "a" has two drawings and 
"b" has one. When creating a single layer from these three file-
names, all three drawings will be inserted in the new layers.

‣ Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from 
the Layer list. You must scan into the same layer type if you are using an existing layer.

‣ Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix 
bitmap images with vector drawings on the same layer, the bitmap image must be 
encapsulated in a symbol and vice versa. Symbols will also be automatically added to the 
Symbol folder in the Library view.

4. In the Import Options section, select the Convert to Toon Boom Vector Drawing option.

5. In the Vectorization section, decide whether you want to import your image in colour, black and 
white, or grey.In the Vectorization section, decide whether you want to import your image in colour, 
black and white,  grey, or if you want to add a new preset.
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‣ Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based 
drawing. 

‣ Grey: Vectorizes your image as a mix of vector contour and greyscale bitmap filling. Lines 
keep the texture from the scan, and the white of the paper becomes transparent.

‣ New Preset: The New Preset  button lets you create custom vectorization parameters via 
the Vectorization Parameters interface. 

You can double-click on any of the presets at any time to open the Vectorization 
Parameters dialog box to customize your option. 

The vectorized images are painted with the Vectorize Line colour swatch from the colour palette.

6. Click OK.

A symbol or new layer contains the vector drawing. For images contained in a symbol, double-click 
on the image’s first cell in the Timeline view to enter the symbol so you can edit the image. 

Linking Your Layer to an External Image
When working on a large production, you may want to centralize your backgrounds into one directory 
instead of duplicating your background several times in different scenes. As backgrounds are 
generally reused in many scenes, some studios like to save space on the server and link the different 
scenes to the background directory. Also, if they modify one background, it is modified everywhere at 
the same time without having to reimport it. To do so, you must use the Timing columns.

Timing columns are exposure sheet columns that link to files that are outside the scene’s structure. 
Because of these external links, care must be taken not to break the links by moving the scene’s 
location or the background directory’s location. Breaking a link will result in images not appearing in 
your scene.
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Refer to the  chapter to learn more about using Timing columns.

If you are working with Toon Boom Harmony Server and all your scenes are located on a centralized 
server, you can also use the Link to Images option.

How to link the scene to an external image (Harmony Server only)

1. From the top menu, select File > Import > Link to Images.

The Link to Images dialog box opens.

2. Click the Browse button to select the image you want to link your scene to.

3. Do one of the following:

‣ Select the Create Timing Layer option to create a new Timing column in your Xsheet view. 
Then select one of the following:

Create Single Timing Named: Type the new column name in the text field.

Create Timing(s) Based on Filenames: Creates file names based on the selected file's name.

‣ Select the Add to Existing Timing Layer option to insert the file into an existing Timing 
column.

4. Select the Copy to Timing Directory option if you want to copy the selected file into the Timing 
folder located in the scene directory. Note that the Timing column will link to the Timing folder.

5. In the Import Options section, select one of the following:

‣ Keep As Original Bitmap: Retains an imported image as a bitmap. In the Alignment 
section, decide on the size and placement of your image within the camera frame. 
Depending on the Scene Settings (the height and width in pixels that you chose for your 
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project), an image that you import may get scaled to the point where all its individual pixels 
become visible. There are three options available in the Alignment section:

Parameter Description

Fit

Enlarges or shrinks (but not distorts) the image height to 
match the full height of the scene grid.

If the image orientation is landscape, this will enlarge or 
shrink (but not distort) your image width to match that of the 
scene grid.

Note that the Fit alignment rule equals the Center Fit rule in 
the layer properties.

Pan

This is the opposite of the Fit parameter. If the image 
orientation is portrait, its width will be made to match the 
width of the scene grid. As a result, part of the image’s height 
will extend beyond the height of the frame. This can be useful 
if you want to make your background move up and down, or 
from left to right to make it appear as if the camera is 
panning, or to actually perform a camera pan.
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The opposite will apply to a landscape image. Its height will 
be fit to the scene grid, therefore it is possible that the image 
will extend beyond the scene grid's boundaries.

Note that the Pan alignment rule equals the Center First Page 
rule in the layer properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The 
system looks at the resolution of the bitmap image, for 
example 4000 x 2000, then compares it to the scene's 
resolution, for example 1920 x 1080, and adjusts the scale 
factor in proportion. So, in this example, the bitmap would 
appear at 208% (4000/1920). If you import a bitmap that is 
960 x 540, it will be displayed at 50% (960/1920) of the size of 
the project resolution.
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Note that the Project Resolution alignment rule is equal to 
the As Is rule in the layer properties.

‣ Import As Toon Boom Bitmap Drawing: Imports a drawing into a vector layer where you 
can edit the image using the drawing tools. In the Alignment section, select one of the 
following:

Parameter Description

Vertical Fit

Enlarges or shrinks (but not distort) to your image height to match 
the full height of the scene frame (alignment grid).

Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match 
the full width of the scene frame (alignment grid).

Actual Size

Scales the image in proportion to the scene's resolution. The system 
looks at the resolution of the bitmap image, for example 4000 x 
2000, then compares it to the scene's resolution, for example 1920 x 
1080, and adjusts the scale factor in proportion. So, in this example, 
the bitmap would appear at 208% (4000/1920). If you import a 
bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the 
size of the project resolution.
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‣ Convert to Toon Boom Vector Drawing: Imports a drawing and converts it to a Toon 
Boom vector drawing. In the Vectorization section, select one of the following:

Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based drawing.

Grey: Vectorizes the image as a mix of vector contour and greyscale bitmap filling. Lines keep the 
texture from the scan, and the white of the paper becomes transparent.

New Preset: Lets you create a new preset.

Delete Preset: Lets you delete any preset in the list.

Custom vectorization: Lets you set custom vectorization parameters—see Creating a 
Vectorization Style  on page 77.

6. Click OK.
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Importing PSD Files as Separate Layers 

PSD files (a format exportable exclusively from Adobe Photoshop) are unique in that they are able to 
retain multiple layers. This is advantageous as the image remains fully editable in terms of any colour 
correction, effects, masking, transparency, or compositing that were made to the PSD file in Adobe 
Photoshop.

Note that your PSD image file must be set to RGB mode within Adobe Photoshop prior to being imported 
into Harmony.

How to import the separated layers of a PSD file

1. Organize your Adobe Photoshop file so that all your layers are “grouped” into individual folders, 
or that all the elements you want to import as a single layer in Harmony are grouped together in 
their own folder. Any layer that is not in a folder group, by itself or otherwise, will not be imported.

2. In Harmony, go to the top menu and select File > Import > Images or click the Import Image  
button.

The Import Drawings dialog box opens.
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3. In the Files section, click Browse to find and select the PSD image on your computer.

4. In the Layer section, select the Create Layer(s) option, then select one of the following options:

‣ Create Single Layer Named: Creates a layer you can name.

‣ Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. 
For example, the filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b", 
where "a" has two drawings and "b" has one. When creating a single layer from these three 
filenames, all three drawings will be inserted in the new layers.

5. Select the Create Symbol for Imported Items option if you want the layers to be contained in 
symbols.

6. In the Import Options section, select one of the following:

‣ Keep As Original Bitmap: Retains an imported image as a bitmap. In the Alignment 
section, decide on the size and placement of your image within the camera frame. 
Depending on the Scene Settings (the height and width in pixels that you chose for your 
project), an image that you import may get scaled to the point where all its individual pixels 
become visible. There are three options available in the Alignment section:

Parameter Description

Fit
Enlarges or shrinks (but not distorts) the image height to 
match the full height of the scene grid.
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If the image orientation is landscape, this will enlarge or 
shrink (but not distort) your image width to match that of the 
scene grid.

Note that the Fit alignment rule equals the Center Fit rule in 
the layer properties.

Pan

This is the opposite of the Fit parameter. If the image 
orientation is portrait, its width will be made to match the 
width of the scene grid. As a result, part of the image’s height 
will extend beyond the height of the frame. This can be useful 
if you want to make your background move up and down, or 
from left to right to make it appear as if the camera is 
panning, or to actually perform a camera pan.
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The opposite will apply to a landscape image. Its height will 
be fit to the scene grid, therefore it is possible that the image 
will extend beyond the scene grid's boundaries.

Note that the Pan alignment rule equals the Center First Page 
rule in the layer properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The 
system looks at the resolution of the bitmap image, for 
example 4000 x 2000, then compares it to the scene's 
resolution, for example 1920 x 1080, and adjusts the scale 
factor in proportion. So, in this example, the bitmap would 
appear at 208% (4000/1920). If you import a bitmap that is 
960 x 540, it will be displayed at 50% (960/1920) of the size of 
the project resolution.
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Note that the Project Resolution alignment rule is equal to 
the As Is rule in the layer properties.

‣ Import As Bitmap Drawing: Imports a drawing into a vector layer where you can edit the 
image using the drawing tools. In the Alignment section, select one of the following:

Parameter Description

Vertical Fit

Enlarges or shrinks (but not distort) to your image height to match 
the full height of the scene frame (alignment grid).

Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match 
the full width of the scene frame (alignment grid).

Actual Size

Scales the image in proportion to the scene's resolution. The system 
looks at the resolution of the bitmap image, for example 4000 x 
2000, then compares it to the scene's resolution, for example 1920 x 
1080, and adjusts the scale factor in proportion. So, in this example, 
the bitmap would appear at 208% (4000/1920). If you import a 
bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the 
size of the project resolution.
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‣ Convert to Toon Boom Vector Drawing: Imports a drawing and converts it to a Toon 
Boom vector drawing. In the Vectorization section, select one of the following:

Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based drawing.

Grey: Vectorizes the image as a mix of vector contour and greyscale bitmap filling. Lines keep the 
texture from the scan, and the white of the paper becomes transparent.

New Preset: Lets you create a new preset.

Delete Preset: Lets you delete any preset in the list.

Custom vectorization: Lets you set custom vectorization parameters—see Creating a 
Vectorization Style  on page 77.

7. Decide whether to select Vectorize Imported Items option.

If you decide to use the Vectorize Imported Items option, see Importing and Vectorizing Bitmap Images  on 
page 26 to learn more about vectorization settings.

If you disable the Vectorize Imported Items options, the Transparency and Alignment settings will appear in 
place of the Vectorization settings—see Importing a Bitmap Image Without Vectorization  on page 18.

8. Click OK.

The Multilayer Image Import Settings dialog box opens.

9. From the Create  menu, select one of the following:

‣ Single Layer: To import the Camera and Layout layers merged together.

‣ Separated Layers: To keep your Camera and Layout layers separated.

10. From the Transparency menu, select one of the following if applicable:
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Parameter Description

Premultiplied with 
White 

Individual pixels at the edge of an image are blended with 
white.

Premultiplied with 
Black 

Pixels at the edge of an image are blended with black.

Straight 
Pixels at the edge of an image are blended with black, white 
and greys.

Clamp Colour to Alpha

Premultiplies the colour value with the alpha value. When the colour is 
clamped to the alpha, the colour value cannot be higher than the alpha 
value. It calculates the real colour value faster. When the RGB values are 
multiplied with the alpha value, that is to say, if you have a pixel of value 
R=247, G=188, B=29 and the alpha is 50% or the image has a 50% trans-
parency, then the actual RGB values that are output would be half of the 
amounts listed above.

11. Click OK.

Your image appears as separate layers in the Timeline view, corresponding to the PSD layer group 
folders.

The artwork displayed in every one of your layers as a result of a multilayer PSD file import is linked to the 
same source image. This means that if you use the Drawing > Delete Selected Drawings command to 
physically delete the drawing from the project folder, the exposed drawing will be deleted in all layers at 
once. Once deleted from the project folder, the image cannot be retrieved unless you reimport your psd 
file.
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Exporting and Reimporting a PSD Layout

Toon Boom Harmony allows you to export the content of your scene as a PSD layout. This can be 
helpful for scene setup, background art retakes or even planning of animation.

Refer to Scene Setup on page 85 to learn more about the scene setup task.

Exporting a Layout
Before exporting a layout, all the elements must be well positioned. For example, if you plan to include 
a camera movement in this scene, you should also set this up, as you can export the camera keyframes 
to generate a clear and complete layout.

You can also create all the layouts for your production in the same Harmony  project which can be 
imported later on when you start each scene’s project. This will help set up the scene and begin its 
creation. You can use these layout PSD files to create the background art of each scene and make sure 
everything is correctly framed and at the right size. Finally, you can also have a layer with a drawing of 
the rough poses of the character or action and generate your layout posing from there.

Note that only the first frame of your drawing layers will be exported, as the layout image is one static PSD 
file.

For more information, refer to Scene Setup on page 85 and Animation Paths on page 201 
and the Drawing chapter in the Paperless Animation Guide.

How to export your scene as a layout

Before exporting your scene as a layout, position your background elements, and everything you 
need as a reference in your scene, including a camera movement. 

1. From the top menu, select one of the following:
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‣ File > Export > Layout Image to export all the elements in your scene to the layout PSD 
file.

‣ File > Export > Layout Image from Selection to export only the elements. 

The Export Layout Image dialog box opens.

2. In the Export Layout Image dialog box, set the export parameters:

Parameter Description

Destination Path
Use the Browse button to select a location to save your layout and 
name the resulting PSD file.

 
File Pattern: Automatically puts the name of the scene and/or the frame 
number in the name of the file you create.

Image Size

The size of the PSD image file that will be exported. The resulting image 
will be 72 dpi as the standard television resolution and its size in pixel 
will fit your scene resolution settings. i.e HDTV, NTSC, PAL, etc. Note 
that if you have a camera movement going over the normal camera 
frame limit, for example a pan, the image will be bigger.

Options File Format: Lets you select the format to export your layout.

 
Export Camera Frame: This option is disabled by default. You can 
enable it to export an additional layer to your PSD file displaying the 
camera frame on it.

 Add a Camera Frame for each Key Frame: This option is 
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disabled by default, meaning that if you have a camera 
movement with more than a starting and an ending point, 
only these positions of the camera frame will appear on the 
camera layer of the exported layout PSD file. You must 
enable this option if you need to the in-between keyframes to 
also be displayed.

 

Label Camera Frame: Adds the camera position label in the 
top corner of the camera frames. The camera label is a single 
alphabet letter determining the order of the camera frame 
position.

 

Add Border to Layout: This option is disabled by default, 
meaning the layout image will take the complete PSD area, 
cropped at the very edge of the canvas. You can enable this 
option to add a transparent area all around the layout. You 
must setup the size of this area by using the Scale field lower. 
The resulting image will be larger.

 

• Scale: Sets the size of the transparent border around the 
layout image. By default the value is set to 100% to export 
the image as is with no transparent area around it. 
Increase the percentage value to add the extra around the 
image to create the border.

 

Adjust Scaling Factor: This option is enabled by default, 
meaning that when you have a camera zoom movement, the 
size of the layout image will be adjusted accordingly. The 
resulting percentage will be calculated following the maximal 
camera zoom value appearing in the layout. This allows the 
image to be exported at an appropriate resolution, 
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preventing the layout image from appearing pixelated or 
blurry when the camera zoom occurs. You can disable this 
option to export the image layout at the normal size.

 

• Scale: When the Adjust Scaling Factor option is enabled, 
the Scale value is automatically calculated according to the 
maximum camera zoom in your layout. You can modify this 
value.

Vector Options: If you export one or more vector-based 
drawing layers in your layout image, you have the option to 
export only the drawing layers you want. Enable or disable 
the following options to export or prevent the export of the 
corresponding art layers.

• Overlay:  Exports the art in the Overlay layer of the 
drawings to be exported to the layout image.

• Line Art:  Exports the art in the Line layer of the drawings 
to be exported to the layout image. 

• Colour Art:  Exports the art in the Colour layer of the 
drawings to be exported to the layout image.

• Underlay:  Exports the art in the Underlay layer of the 
drawings to be exported to the layout image.

3. Click OK to validate the settings and export a PSD file of your layout.

The resulting image is a PSD file with one or two layers, each of which is contained in a 
corresponding group. These groups make the layout PSD file ready for a multilayer PSD import. 

The Camera_Set group contains the camera drawing layer. If you selected the Export Camera 
option, this group and layer appear in your layout image.

The Layout_Set group contains a merged drawing layer of all the content of your scene’s first 
frame when you exported the layout image.
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An XLI file is exported along with your PSD file. This file contains all the necessary information for correctly 
importing and automatically positioning your layout image in a Harmony project. Do not delete the XLI file 
or rename it. Also, always keep it at the same location as the layout PSD file.

Importing a Photoshop Layout
If you exported a Photoshop layout image from a Harmony project, you can easily import it back into 
Harmony. Just be sure to import it at the beginning of the project for accurate scene planning.

How to import a PSD layout

1. In your Harmony project, select File > Import > Images.

The Import Images dialog box opens.

2. In the Files section, click Browse to find and select the PSD layout file on your computer. Note that 
this layout file must have its corresponding XLI file in the same folder.
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3. Once you have selected the layout file, the Use Position Information Contained in XLI file option 
appears in the Layer section. 

This option is enabled by default. When you import the layout image in your scene, it will be 
automatically positioned to fit the original layout scene creating an accurate layout guide. You can 
disable this option if you want the imported layout image to be imported according to the normal 
behaviour of the import process. The layout image will be incorrectly aligned as it was when it was 
first created.

4. In the Layer section, select the Create Layer(s) option, then select one of the following options:

‣ Create Single Layer Named: Creates a layer you can name.

‣ Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. 
For example, the filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b", 
where "a" has two drawings and "b" has one. When creating a single layer from these three 
filenames, all three drawings will be inserted in the new layers.

5. Select the Create Symbol for Imported Items option if you want the layers to be contained in 
symbols.

6. In the Import Options section, select one of the following:

‣ Keep As Original Bitmap: Retains an imported image as a bitmap. In the Alignment 
section, decide on the size and placement of your image within the camera frame. 
Depending on the Scene Settings (the height and width in pixels that you chose for your 
project), an image that you import may get scaled to the point where all its individual pixels 
become visible. There are three options available in the Alignment section:

Parameter Description

Fit
Enlarges or shrinks (but not distorts) the image height to 
match the full height of the scene grid.
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If the image orientation is landscape, this will enlarge or 
shrink (but not distort) your image width to match that of the 
scene grid.

Note that the Fit alignment rule equals the Center Fit rule in 
the layer properties.

Pan

This is the opposite of the Fit parameter. If the image 
orientation is portrait, its width will be made to match the 
width of the scene grid. As a result, part of the image’s height 
will extend beyond the height of the frame. This can be useful 
if you want to make your background move up and down, or 
from left to right to make it appear as if the camera is 
panning, or to actually perform a camera pan.
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The opposite will apply to a landscape image. Its height will 
be fit to the scene grid, therefore it is possible that the image 
will extend beyond the scene grid's boundaries.

Note that the Pan alignment rule equals the Center First Page 
rule in the layer properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The 
system looks at the resolution of the bitmap image, for 
example 4000 x 2000, then compares it to the scene's 
resolution, for example 1920 x 1080, and adjusts the scale 
factor in proportion. So, in this example, the bitmap would 
appear at 208% (4000/1920). If you import a bitmap that is 
960 x 540, it will be displayed at 50% (960/1920) of the size of 
the project resolution.
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Note that the Project Resolution alignment rule is equal to 
the As Is rule in the layer properties.

‣ Import As Toon Boom Bitmap Drawing: Imports a drawing into a vector layer where you 
can edit the image using the drawing tools. In the Alignment section, select one of the 
following:

Parameter Description

Vertical Fit

Enlarges or shrinks (but not distort) to your image height to match 
the full height of the scene frame (alignment grid).

Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match 
the full width of the scene frame (alignment grid).

Actual Size

Scales the image in proportion to the scene's resolution. The system 
looks at the resolution of the bitmap image, for example 4000 x 
2000, then compares it to the scene's resolution, for example 1920 x 
1080, and adjusts the scale factor in proportion. So, in this example, 
the bitmap would appear at 208% (4000/1920). If you import a 
bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the 
size of the project resolution.
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‣ Convert to Toon Boom Vector Drawing: Imports a drawing and converts it to a Toon 
Boom vector drawing. In the Vectorization section, select one of the following:

Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based drawing.

Grey: Vectorizes the image as a mix of vector contour and greyscale bitmap filling. Lines keep the 
texture from the scan, and the white of the paper becomes transparent.

New Preset: Lets you create a new preset.

Delete Preset: Lets you delete any preset in the list.

Custom vectorization: Lets you set custom vectorization parameters—see Creating a 
Vectorization Style  on page 77.

7. Click OK.

The Multilayer Image Import Settings dialog box opens.

8. From the Create  menu, select one of the following:

‣ Single Layer: To import the Camera and Layout layers merged together.

‣ Separated Layers: To keep your Camera and Layout layers separated.

9. From the Transparency menu, select one of the following if applicable:

Parameter Description

Premultiplied with 
White 

Individual pixels at the edge of an image are blended with 
white.

Premultiplied with 
Black 

Pixels at the edge of an image are blended with black.

Straight 
Pixels at the edge of an image are blended with black, white 
and greys.

Clamp Colour to Alpha
Premultiplies the colour value with the alpha value. When the colour is 
clamped to the alpha, the colour value cannot be higher than the alpha 
value. It calculates the real colour value faster. When the RGB values are 
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multiplied with the alpha value, that is to say, if you have a pixel of value 
R=247, G=188, B=29 and the alpha is 50% or the image has a 50% trans-
parency, then the actual RGB values that are output would be half of the 
amounts listed above.

10. Click OK.

Your image appears as separate layers in the Timeline view, corresponding to the PSD layer group 
folders Camera_Set and Layout_Set. You can now use this layout as a guide for scene settings.

Refer to Scene Setup on page 85 to learn more about the scene setup task.
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Scanning Images 

Toon Boom Harmony can receive images from any TWAIN device such as scanners and digital 
cameras. These images can either be loaded into your scene as bitmaps or converted into vector- 
based images that can be edited using Toon Boom Harmony.

If your operating system does not automatically recognize your device after it has been connected, you 
must install the correct TWAIN drivers in order to access its contents. You can usually download the 
drivers from the device manufacturer’s website.

How to open the Scan Drawings window and set your scanner

1. From the top menu, select File > Import > From Scanner.

The Scan Drawings window opens. 

2. In the Scan Drawings window, select your scanner or other supported TWAIN device from the 
Scanner menu. If none are available, check your device to ensure that it is properly connected to 
your computer. If your device still does not appear in the menu, you may have to shut down and 
restart the software.

How to scan an image in its original format

3. In the Layer section, decide if the scanned or imported image will be placed on a new layer or 
existing layer. 
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‣ Create Layer: Scans or imports the image into a new layer. Select one of the following 
options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For 
example, the filenames a-1.tga, a-2.tga and b-1.tga will create 
layers named "a" and "b", where "a" has two drawings and 
"b" has one. When creating a single layer from these three file-
names, all three drawings will be inserted in the new layers.

‣ Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from 
the Layer list. You must scan into the same layer type if you are using an existing layer.

‣ Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix 
bitmap images with vector drawings on the same layer, the bitmap image must be 
encapsulated in a symbol and vice versa. Symbols will also be automatically added to the 
Symbol folder in the Library view.

4. In the Import Options section, select the Keep As Original Bitmap option.

5. In the Alignment section, decide on the size and placement of your scanned image within the 
camera frame. Depending on the scene settings (the height and width, in pixels, that you chose for 
your project), an image that you scan may be scaled to the point where all its individual pixels 
become visible.

Parameter Description

Fit

Enlarges or shrinks (but not distorts) the image height to 
match the full height of the scene grid.

If the image orientation is landscape, this will enlarge or 
shrink (but not distort) your image width to match that of the 
scene grid.
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Note that the Fit alignment rule equals the Center Fit rule in 
the layer properties.

Pan

This is the opposite of the Fit parameter. If the image 
orientation is portrait, its width will be made to match the 
width of the scene grid. As a result, part of the image’s height 
will extend beyond the height of the frame. This can be useful 
if you want to make your background move up and down, or 
from left to right to make it appear as if the camera is 
panning, or to actually perform a camera pan.

The opposite will apply to a landscape image. Its height will 
be fit to the scene grid, therefore it is possible that the image 
will extend beyond the scene grid's boundaries.
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Note that the Pan alignment rule equals the Center First Page 
rule in the layer properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The 
system looks at the resolution of the bitmap image, for 
example 4000 x 2000, then compares it to the scene's 
resolution, for example 1920 x 1080, and adjusts the scale 
factor in proportion. So, in this example, the bitmap would 
appear at 208% (4000/1920). If you import a bitmap that is 
960 x 540, it will be displayed at 50% (960/1920) of the size of 
the project resolution.

Note that the Project Resolution alignment rule is equal to 
the As Is rule in the layer properties.

6. In the Drawing Options section, set the following options if desired:

‣ Drawing Name: Name of the drawing to import.

‣ Hold Value: Type the number of frames that the drawing will be exposed.

‣ Scan and Advance: Lets you scan one drawing after another every time you click Scan.

‣ Flip Drawing: Mirrors the drawings horizontally and scans it this way.

7. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the 
view.
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8. Click Scan to scan your drawing.

9. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next 
letter to capture your next frame.

10. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until 
you have finished scanning all your drawings.

How to scan an image as a Toon Boom bitmap drawing

1. In the Import Options section, select the Import as Toon Boom Bitmap Drawing  option. 

2. In the Layer section, decide if the scanned or imported image will be placed on a new layer or 
existing layer. 

‣ Create Layer: Scans or imports the image into a new layer. Select one of the following 
options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For 
example, the filenames a-1.tga, a-2.tga and b-1.tga will create 
layers named "a" and "b", where "a" has two drawings and 
"b" has one. When creating a single layer from these three file-
names, all three drawings will be inserted in the new layers.

‣ Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from 
the Layer list. You must scan into the same layer type if you are using an existing layer.

‣ Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix 
bitmap images with vector drawings on the same layer, the bitmap image must be 
encapsulated in a symbol and vice versa. Symbols will also be automatically added to the 
Symbol folder in the Library view.

3. In the Alignment section, decide on the size and placement of your scanned image within the 
camera frame. Depending on the scene settings (the height and width, in pixels, that you chose for 
your project), an image that you scan may be scaled to the point where all its individual pixels 
become visible.

Make sure you are in the Camera view’s Render Mode when judging an imported image, otherwise it may 
appear blurry.

The following three Alignment Rules options are available:

Parameter Description

Vertical Fit
Enlarges or shrinks (but not distort) to your image height to match 
the full height of the scene frame (alignment grid).
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Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match 
the full width of the scene frame (alignment grid).

Actual Size

Scales the image in proportion to the scene's resolution. The system 
looks at the resolution of the bitmap image, for example 4000 x 
2000, then compares it to the scene's resolution, for example 1920 x 
1080, and adjusts the scale factor in proportion. So, in this example, 
the bitmap would appear at 208% (4000/1920). If you import a 
bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the 
size of the project resolution.

4. In the Drawing Options section, set the following options if desired:

‣ Drawing Name: Name of the drawing to import.

‣ Hold Value: Type the number of frames that the drawing will be exposed.
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‣ Scan and Advance: Lets you scan one drawing after another every time you click Scan.

‣ Flip Drawing: Mirrors the drawings horizontally and scans it this way.

5. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the 
view.

6. Click Scan to scan your drawing.

7. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next 
letter to capture your next frame.

8. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until 
you have finished scanning all your drawings.

How to scan an image and convert it to a Toon Boom vector drawing

1. In the Import Options section, select the Convert to Toon Boom Vector Drawing  option. You can 
choose to encapsulate the image in a symbol by selecting the Create Symbols for Imported Items 
option. 

2. In the Layer section, decide if the scanned or imported image will be placed on a new layer or 
existing layer. 

‣ Create Layer: Scans or imports the image into a new layer. Select one of the following 
options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For 
example, the filenames a-1.tga, a-2.tga and b-1.tga will create 
layers named "a" and "b", where "a" has two drawings and 
"b" has one. When creating a single layer from these three file-
names, all three drawings will be inserted in the new layers.

‣ Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from 
the Layer list. You must scan into the same layer type if you are using an existing layer.

‣ Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix 
bitmap images with vector drawings on the same layer, the bitmap image must be 
encapsulated in a symbol and vice versa. Symbols will also be automatically added to the 
Symbol folder in the Library view.

3. In the Vectorization section, decide whether you want to import your image in black and white or 
grey.
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Parameter Description

Black and White
Vectorizes drawings as a solid black line; creates a 100% vector-based 
drawing.

Grey
Vectorizes your image as a mix of vector contour and greyscale bitmap 
filling. Lines keep the texture from the scan, and the white of the paper 
becomes transparent.

4. In the Drawing Options section, set the following options if desired:

‣ Drawing Name: Name of the drawing to import.

‣ Hold Value: Type the number of frames that the drawing will be exposed.

‣ Scan and Advance: Lets you scan one drawing after another every time you click Scan.

‣ Flip Drawing: Mirrors the drawings horizontally and scans it this way.

5. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the 
view.

6. Click Scan to scan your drawing.

7. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next 
letter to capture your next frame.

8. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until 
you have finished scanning all your drawings.
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Importing AI and PDF Files 

You can import AI (Adobe Illustrator) and PDF files into Toon Boom Harmony to convert your files to 
the Toon Boom format (TVG) and create a colour palette based on the colour settings of the original 
file. 

When importing AI and PDF files:

• RGB is supported, CMYK is not.

• Gradients and textures are not supported.

• Only legacy versions of Adobe Illustrator are supported. Exported SWFs, including Actionscript 
2 and Actionscript 3, cannot be imported.

• When importing an Illustrator or PDF file in Toon Boom Harmony, by default the file will be 
imported as separate layers. The import will use the Illustrator file's top level groups as 
separate layer names. However, you can change this behaviour by deselecting the 
PDF/Illustrator Import as Separate Layers option, to import your file as a single layer .

How to import an AI or PDF file

1. In Library view, right-click on the Stage Library folder and select Right to Modify to unlock the 
library folder. Make sure the Lock icon disappears from the folder. If not, your library will remain 
locked and you will not be able to import files.

For more information, refer to the Library  chapter in the Cut-out Animation Guide.
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2. Do one of the following:

‣ In the top menu, select File > Import > SWF, Illustrator Files to Library. 

‣ Right-click on any unlocked folder and select Import Fi les.

The browser window opens.

3. Find and select your AI or PDF file in the Import Files dialog box and click Open.

The Rename dialog box opens.

4. Type in a name for the new template or keep the name of the original AI or PDF file. 

5. Click OK.

A new template folder is created in the Library view.

6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until 

the copy cursor  appears before releasing the folder.

The message window opens.

7. Click Yes to perform a colour recovery. Note that you can select the Do Not Ask Again For This 
Session option if you plan to import multiple AI or PDF files.
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The colour palette used to create the AI or PDF file is imported and a new palette is created under 
the imported file’s name.

To learn about the Support CMYK in PDF/Illustrator Import option, refer to the 
Preferences Guide.
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Importing Adobe Flash Files

If a project was started in Adobe Flash and it needs a more professional boost, such as camera 
movements or multiplaning, it can easily be imported into Harmony. The actual *.fla file is not 
supported, so you must export your project as a *.swf movie. 

How to import a Flash file

1. In Library view, right-click on the Stage Library folder and select Right to Modify to unlock the 
library folder. Make sure the Lock icon disappears from the folder. If not, your library will remain 
locked and you will not be able to import files.

For more information, refer to the Library  chapter in the Cut-out Animation Guide.

2. Do one of the following:

‣ In the top menu, select File > Import > SWF, Illustrator Files to Library. 

‣ Right-click on any unlocked folder and select Import Fi les.

The browser window opens.
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For more information, refer to the Library  chapter in the Cut-out Animation Guide.

3. Find and select your.swf file in the Import Files dialog box and click Open.

The Rename dialog box opens.

4. Type a name for the new template or keep the name of the original *.swf file. 

5. Click OK.

A new template folder is created in the Library view.

6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until 

the copy cursor  appears before releasing the folder.

7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before 
clicking the Yes button, you have the option of selecting the Do Not Ask Again For This Session 
option. This might be useful if you plan to import multiple *.swf movies.
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The colour palette used to create the AI or PDF file is imported and a new palette is created under 
the imported file’s name.

All the Flash layers are automatically attached to a parent peg called GlobalFlashPeg. DO NOT DELETE 
THIS PEG. To maintain the look of your movie, it is important that this peg is not deleted, nor its child 
layers detached.

The Adobe Flash file layers appear in the Timeline view. Symbols that were created in Flash become 
regular drawing layers, but can be reconverted into symbols in Harmony. Symbols within symbols 
or drawings within symbols collapse into their corresponding parent symbol.

Some layers in your SWF movie may be combined in a single layer as a result of optimization 
enhancements in your movie file. You can easily move these elements back onto separate layers—see 
Redistributing Elements below.

In addition, all drawing elements that are dynamically linked to the Toon Boom Harmony file are 
grouped together in one folder. In our example, this means that when you scroll through the 
Drawing Substitution preview in the Library view, the different hand, leg, tentacles, antennae, 
torso and facial positions are all organized together.

Redistributing Elements
In some instances, due to an optimization enhancement in the exported SWF file (CS4), some of the 
layers might be combined as a single layer. If so, you can quickly redistribute these elements onto 
individual layers again. 

How to distribute to layers

1. In the Tools toolbar, click the Select  tool.

2. In the Camera view, select the drawing that contains elements you want to redistribute onto 
individual layers.  To select the all the elements of the selected drawing layer, press Ctrl + A 
(Windows/Linux) or ⌘  + A (Mac OS X).

3. From the top menu, select Drawing > Distribute to Layers or click the Distribute to Layers  
button in the Select tool’s Tool Properties view.
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The number of drawing layers corresponding to the different grouped elements are created in the 
Timeline view.

‣ The selected elements in the original drawing layer are removed. Each element is 
distributed onto a new drawing layer.

4. Repeat the process for each drawing that contains elements to redistribute.
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Importing QuickTime Movies 

When creating an animation, it is not unusual to embed moving elements saved as videos within the 
animation. Toon Boom Harmony allows you to import QuickTime movies into your project. 

How to import a QuickTime movie

1. From the top menu, select File > Import > Movie.

2. Browse for the QuickTime movie to import and click Open.

The Import Drawings dialog box opens.

Do not browse for the movie file again. Leave the automatically generated field text as “many files 
selected”.
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3. Make your decisions for the Layer, Alignment and Transparency sections of this dialog box—see 
Importing a Bitmap Image Without Vectorization  on page 18.

4. Click OK.

The QuickTime video appears in the Timeline view as an image sequence. You can scroll through 
the film frame-by-frame just as you would scroll through your animation drawing-by-drawing.
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Custom Vectorization Parameters 

You can create your own vectorization settings with Harmony. 

The vectorization parameters you will create here can be saved, shared and also inserted into the 
VectOptions.conf file used by the Harmony Scan and Control Center modules when scanning or 
vectorizing a series of drawings.

You can use an interface to select and test the different options and you can also type in some 
advanced settings.

How to open the Vectorization Parameters dialog box

1. From the top menu, select File > Import > From Scanner.
You can also open it from any other import option that allows you to customize the vectorization 
parameters (i.e. from the scanner).

2. Select your file, decide on the layer options, and click Preview.

3. In the Vectorization section, click the New Preset  button.

The Vectorization Parameters dialog box opens.
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• Options Tab  below

• Help Tab on page 72

Options Tab 

The Options tab contains the main vectorization settings. More settings are available in the Help tab.

Parameter Description

Input

The input filters are applied to the bitmap image before it is 
vectorized.

One Pass: One threshold value is applied to both the Line and 
Colour Art. For drawings with distinct vector-style lines of 
mattes, you only need one pass.

Two Passes: Applies a different threshold value to each layer.

For greyscale drawings, you may want to perform the 
vectorization process twice to apply different threshold values 
to the Line and Colour Art layers.

Threshold: Determines which values in the scanned image are 
considered part of the Line or Colour Art layer and what will be 
eliminated from the vectorized drawing; 0% is white and 100% 
is black. The threshold is between these two values.

Expand Bitmap: Lets you enter a value to scale the bitmap to 
detect small variations in the line. Use this option if you scanned 
a greyscale image and want to preserve small variations in the 
texture to apply to the line art.

Jag Filter: Lets you enter a value to scale back the bitmap to 
remove some of the line’s roughness. This is useless when you 
have a drawing that appears quite rough; the Jag filter will 
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eliminate excess strokes in the final drawing.

Output

The output filters are applied during the vectorization process.

No Colour Art: Does not generate filling zones in the Colour 
Art layer.

No Texture: Does not generate texture in the Line Art in the 
final images. Select this option to create solid lines in the final 
line art.

Generate Matte in Underlay Layer: Creates an opaque zone 
behind your drawing’s lines to avoid seeing through the layers.

Colour as Texture: Converts colour values into a texture layer.

Optical Registration

The optical registration options are used to automatically align 
drawings based on the position of the peg holes on the 
animation paper. The peg holes must appear in the scanned 
drawings for the optical registration to work.

DPI: Lets you enter the dots-per-inch value of your image. You 
must enter the same value as the DPI used to scan the image.

Peg Side: Lets you select the position of the peg holes on your 
drawings. Identify whether they are on the top, bottom, left or 
right.

Strictness: Determines how exact the location of the peg holes 
must be for the software to recognize them. You have two 
values to choose from:

• Strict: The peg holes must be in a tightly defined area to 
be recognized.

• Loose: The peg holes can be recognized somewhere in a 
larger area. This is the recommended setting.

Field Chart: Lets you indicate the size of the animation paper; 
12 or 16.

Post Processing

The Post Processing filters are applied to the final vector 
images.

Remove Holes: Removes holes of a specified value that might 
make painting difficult.

Remove Dirt: Removes stray marks and dirt of a specified 
value. Try a value around 500.

Remove Hair: Removes small strokes that have no line art.

Remove Hair: Number of Passes: The number of times the 
drawing will be analyzed to identify hair marks.

Miscellaneous

Close Gaps: Closes gaps in the Colour Art so that you can 
paint it.

Smooth Passes for Line Art before Breaking Triangles: The 
number of times the smoothing operation runs before creating 
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the triangles that break lines in your drawing. If unnecessary 
triangles are appearing in your drawing, increase this value.

Smooth Passes for Line Art: The number of times the 
smoothing operation is performed after the triangles have 
been created. This further smooths the Line Art.

Preview

Show Strokes: Shows the strokes in the Vectorized Image 
panel.

Stroke Thickness: Shows the size of the strokes.

Help Tab

The Help tab contains the most advanced vectorization settings which you type in the Advanced 
Option fields at the bottom of the Options tab.

File IO Options 

-file <filename (including extension)> [ options ]

-infile <filename (including extension)>; same as -file

-outfile <filename>; alternate output file

-informat <format>; the input format. Used if reading from stdin

-debug; turn on debug mode

-noforce; don't force output if image is inconsistent

-version; print version information and quit

-output_version <version>; output files of this version. Valid versions can be: 0 or 604

-force_unamed_palette_for_texture; will generate a texture in TVG's internal palette

Registration Options 

-register <dpi side strictness>; perform optical registration.
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• Side can be one of left, right, top, bottom or l, r, t, b.

• Strictness can be either loose, strict or l, s.

-register_center_peg_holes; will use only round holes in 16 fields page

-rcph; short form of register_center_peg_holes

-registration_looseness_factor <factor>; registration looseness factor (default 2.000000)

-rlf; short form of registration_looseness_factor

-rdebug; output registration debug messages

-pegpitch <inch (default 8.000000)>; distance between peg bars

-threshr < (default 0.500000)>; threshold for optical registration; range 0.0 to 1.0

-rmargin <inch (default 1)>; region size where to look for peg bars 

-peg_distance_from_center <inch (default 5.25)>; peg distance from centre of the image 

-pdfc; short form of -peg_distance_from_center 

-out_peg_position <side (default same)>; wanted position of the peg on the drawing.

• Can be one of right, left, top, bottom (or r, l, t, b) or same.

• A rotation will be performed if it is different from the side passed to -register.

-output_peg_matrix; output the peg transformation matrix on standard output.

-scanner_calibrate; < (default 1.0000 1.0000) > x and y scale factors to be applied to scanner image.

Filtering Options 

-pixel <pixel_shape (default '4x3')>; Valid values: 4x3

-gap <worldUnits (default 10)>; close gaps up to this big

-pencil; generate line art only

-keep_dirt; don't filter out dirt

-thresh <threshold (default 0.2)>; range 0.0 to 1.0

-rmv_hairs <worldUnits (default 1)> <passes (default 1)> 

• remove hairs of size smaller than "size" in "passes" passes 

-rmv_holes <area (default 7)>; remove holes smaller than "area" 

-rmv_dirt <area (default 1)>; remove dirt smaller than "area" 

• try values between 100 and 500 for rmv_holes and rmv_dirt. The area is in world units squared

-rmv_triangles <worldUnits (default 30.000000)>; remove triangles at "pixels" 

• distance from each other. Use -no_break to remove all triangles

-no_texture; don't generate textured strokes

-color_as_texture; will vectorize the alpha channel and put the RGB colour in a textured colour

-noclosegap; disable all gap closing algorithms

-no_break; disable the breaking of line art

-jag_filter <pixels (default 0>; expand the pixels in the vectorization bitmap
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-expand_bitmap <pixels (default 0>; expand the pixels in the vectorization bitmap

-fit_errorc <error (default 1.000000>; fitting error for the colour art

-fit_errorl <error (default 1.000000>; fitting error for the line art

-smoothl <passes (default 1>; number of smooth passes for line art

-smoothc <passes (default 1>; number of smooth passes for colour art

-first_smooth <passes (default 0>; number of smooth passes for line art before breaking triangles

-first_smoothl <passes (default 0>; number of smooth passes for line art before breaking triangles

-first_smoothc <passes (default 0>; number of smooth passes for line art in colour art pass (needs -
2pass)

-2pass; specify two sets of parameters; one for line art "l", one for colour art "c"

(-thresh, -rmv_holes and -rmv_dirt will be overridden by -threshl, threshc, -rmv_holesl,

-rmv_holesc, -rmv_dirtl and -rmv_dirtc)

-threshl <threshold for line art (default 0.5)>; range 0.0 to 1.0

-threshc <threshold for color art (default 0.5)>; range 0.0 to 1.0

-jag_filterl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art

-jag_filterc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art

-expand_bitmapl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art

-expand_bitmapc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art

-rmv_holesl <area (default 7)>; remove line art holes smaller than "area" 

-rmv_holesc <area (default 7)>; remove colour art holes smaller than "area" 

-rmv_dirtl <area (default 1)>; remove line art dirt smaller than "area" 

-rmv_dirtc <area (default 1)>; remove colour art dirt smaller than "area" 

try values between 100 and 500 for rmv_holesl, rmv_holesc, rmv_dirtl and rmv_dirtc. The values are 
in world units squared 

-margins <inch (default 0.25)>; remove margin around bitmap 

-top_margin <inch (default 0.25)>; remove margin at top of bitmap 

-bottom_margin <inch (default 0.25)>; remove margin at bottom of bitmap 

-left_margin <inch (default 0.25)>; remove margin at left of bitmap 

-right_margin <inch (default 0.25)>; remove margin at right of bitmap 

-remove_peg_bars; remove the peg bar holes

-field_size <fields (default 12 or use value in scan file)>; set the drawing to this field size

-fs; short hand for -field_size

-peg_bar_size <inch (default 1)>; the size of the peg bar region

-noframe; do not put a frame around the colour art

-frame_fields <default -1.000000>; put a frame of the specified dimension around the colour art
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-downscale_input <default 1>; downscale the raw input by this integer factor

-downscale_texture <default 1>; downscale the output texture by this integer factor

-buildmatte; generate a matte on underlay for line test

-buildmatte_colourart; generate a matte on colour art for line test

Note: -buildmatte and -buildmatte_colourart are mutually exclusive

-copystrokes; copy original strokes when building matte.

Options for bitmap that has no registration information 

-pixel_margins <inch (default 0)>; remove margin around bitmap 

-top_pixel_margin <inch (default 0)>; remove margin at top of bitmap 

-bottom_pixel_margin <inch (default 0)>; remove margin at bottom of bitmap 

-left_pixel_margin <inch (default 0)>; remove margin at left of bitmap 

-right_pixel_margin <inch (default 0)>; remove margin at right of bitmap 

-dpi <(default -1)>; dpi information of input bitmap 

RGB Keying Options 

-rgb; generate separate zones for red, green and blue lines

-rgb_alpha <value (default 255)>; generate red, green and blue colour with alpha of this value

-no_red; ignore red colour in vectorization

-no_green; ignore green colour in vectorization

-no_blue; ignore blue colour in vectorization

-flatten; flatten the drawing after generating colours

-rmv_rgb_dirt <threshold area default 0.0>; remove red, green and blue regions smaller than area

-expand_bitmap_rgb <pixels (default 0>; expand the pixels in the vectorization bitmap for rgb

-threshrgb <value> <threshold for rgb vectorization default 0.200000>;

-threshsv <saturation threshold default 0.500000> <value threshold default 0.500000>; thresholds on 
saturation and value to consider a pixel to be grey

Colour Vectorization Options 

-color_vectorize; perform a colour vectorization

-file2 <colour art filename>; specify the colour art bitmap

-penstyle <center alpha (0.0-20.0)> <edge alpha (0.0-20.0)> <gamma (0-10)><centre pressure effect 
(0.0-1.0)> <edge pressure effect (0.0-1.0)><texture bitmap downscaling (0.2-20)> <texture bitmap 
file (valid filename or "" if no file)>; generate brush texture for the line art

-pressure_variation <strategy (0, 1 or 2)> <min pressure (0.0-1.0)> <max pressure (0.0-1.0)> <max 
variation (0.0-1.0)>; specify a pressure strategy for the centre line. 

-blur_radius <pixels (default 0)>; blur the penstyle texture generated
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-color_contour_smooth_passes <times (default 3)>; perform number of smooth passes on contour 
before computing texture

-ccsp <times (default 3)>; short for -color_contour_smooth_passes

-color_rmv_holesl <world units (default 0.000000)>; remove holes of this size when computing 
texture

-color_fill_holesl <world units (default 0.000000)>; fill holes of this size for colour line art

Bubble Usage (implemented only for colour vectorization's line art)

-create_bubbles; add bubbles into the LineArt. Implemented for colour vectorization only 

-bubble_gap <value (default 3)>; max number of colour art points between 2 bubbles

-bubble_length <value (default 10)>; max number of circles in a bubble

-min_radius <value (default 1.5000)>; min radius of a circle in a bubble relative to the line thickness 
(must be >= 1.0)

-max_radius <value (default 3.5000)>; max radius of a circle in a bubble relative to the line thickness 
(must be >= 1.0)

-uniform_gap; the space between bubbles is constant 

4 Colour Vectorization

-4colours [key:value] ... [key:value] ; The key value list can be empty. The list of keys is:

rgbdiff:value ; between [0.0-1.0] or [0-255]

dark:value    ; between [0.0-1.0] or [0-255]

grey:value    ; between [0.0-1.0] or [0-255]

white:value   ; between [0.0-1.0] or [0-255]

dirt:value    ; dirt area. 200 is a good value

rt:value      ; between [0.0-1.0] or [0-255]

gt:value      ; between [0.0-1.0] or [0-255]

bt:value      ; between [0.0-1.0] or [0-255]

There must be no space between the colon and the key/value. For example: -4colours 
rgbdiff:20 dark:20 grey:120 white:250 dirt:200 rt:240 gt:240 bt:240

The Vectorization Parameters dialog box lets you vectorize pencil drawings, along with any red, blue 
or green pencil marks you may have used to indicate highlights and shadows. The drawing will be 
vectorized into pure red, blue, green and black (RGB values), while creating colour art zones wherever 
lines connect. After painting in your tones and highlights, change your pure RGB colours to 
transparent (0 Alpha) in the Colour Picker window and watch the indicator colour zone lines 
disappear.
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Creating a Vectorization Style 
With Harmony, you have the possibility to create custom vectorization parameters that can be saved 
and reused.

You can vectorize drawings using one of the following methods:

• Black and White: All the lines become vector based and 100% black. The white areas become 
completely transparent.

• Greyscale: All the lines preserve their initial textured look in grey shades as a bitmap image 
contained inside a vector frame. The white areas become completely transparent.

• Four Colours: With the advanced parameters, you can isolate the red, green, blue, and black 
lines and turn them into 100% vector lines, preserving their original colours—see Custom 
Vectorization Parameters  on page 69.

How to create or modify the vectorization parameters

1. Set the different options available in the Vectorization Parameters dialog box.
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2. Click the Vectorize  button to update the Vectorized Image preview.

The vectorized image is just a preview. The actual vectorization happens when you click OK in the 
Import Images dialog box. There are many options to try in the Vectorization Options dialog box. 
These are applied during the vectorization process.

3. To set advanced parameters, read the information on the Help tab, then type in the Advanced 
Options field at the bottom of the Options tab.

4. To save your vectorization parameters to reuse them later, share them, or use them to set the 
Harmony Scan module vectorization style list, click  Save.

5. In the Browser window, name and save the file.

6. To save the current settings as your default settings, click Save As Default. To restore the default 
settings, click Restore Defaults.

7. To load a vectorization style, click Load and locate the existing *.vof file.

8. Click OK.

Setting the VectOptions.conf File
Toon Boom Harmony Server uses a file called VectOptions.conf to get the vectorization style 
when batch vectorizing a series of drawings. A series of default styles is available in this file, but you 
will certainly want to create your own to fit your production style.

This section deals with setting the VectOptions.conf file on:
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• Setting the VectOptions.conf File on Windows and Mac OS X below

• Setting the VectOptions.conf File on Linux on page 81

Setting the VectOptions.conf File on Windows and Mac OS X

How to set the VectOptions.conf file on Windows or Mac OS X

1. Open the vectOptions.conf file:

‣ Windows: Select Programs / All Programs > Harmony 11.1 > Tools > Configuration 
Editor.

‣ Mac OS X: Select Applications > Harmony 11.1 > Tools > Configuration Editor.

The Configuration Editor window opens.

2. In the bottom section of the window, select the VectOptions.conf tab.

3. Scroll down the VectOptions.conf file to see all the different options available for creating your 
custom vectorization style. These options are the same as in the Vectorization Parameters dialog 
box. It is recommended that you create your vectorization style using Harmony and the 
Vectorization Parameters window and copy the result parameters in this file—see Creating a 
Vectorization Style  on page 77

4. Scroll down toward the bottom of the file to see the default styles. You can modify them or add 
new ones to the list using the parameters you got using the Vectorization Parameters window. 
Notice that some of the lines have a “#” sign at the beginning to indicate that the line is a comment 
and will not appear in the style list. The lines that have no sign at the beginning appear in the style 
list.
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5. To create a new style, type the following below the existing styles: 

style_name:

This should be followed by the name of your new style. For example: style_name: Black 
Lines.

6. Under the style name line, type the following: 

options:

7. Copy and paste the information in your *.vof style when saving your settings in the Vectorization 
Parameters window.

‣ To open the *.vof file, use any plain text editor application.

8. In the Configuration Editor’s top menu, select File > Save.

9. If you have Toon Boom Harmony Scan on your computer, you can start the application and verify 
that the new style appears in the Vectorization Style list under Edit > Vectorization Style.  
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If you are using the batch processing method available with Toon Boom Harmony Server 
to scan and vectorize your drawings, the selected style must be available on all the 
machines included in the batch processing list.

Refer to the Control Center Guide to learn more about setting up and using batch 
processing.

Setting the VectOptions.conf File on Linux

These are the two methods used to edit the VectOptions.conf file on Linux. 

• Using the “vi” text editor

• Using the “gedit” text editor 

How to set the VectOptions.conf file on Linux using the “vi” text editor

1. Open a Terminal window:
Menu: Applications > System Tools > Terminal

2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_11.0/etc

3. Change your user to "root":

$ su

‣ If your user is part of the sudoers list, enter the following command and go to See "Open 
the 'VectOptions.conf using the  "vi" text editor:" on page 81: 

$ sudo vi VectOptions.conf

4. Enter the "root" password.

5. Open the 'VectOptions.conf using the  "vi" text editor:

$ vi VectOptions.conf

6. To start editing, press the [i] key on your keyboard to enter Insert mode.

7. Once you are done editing the file, press Esc to exit Insert mode.

8. To save the changes made to the file, type the following and press Enter/Return:

$ :w!
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9. To exit the "vi" editor and return to the Terminal, type the following and press Enter/Return:

$ :q

10. If you have Toon Boom Harmony Scan on your computer, you can start the application and verify 
that the new style appears in the Vectorization Style list under Edit > Vectorization Style.

If you are using the batch processing method available with Toon Boom Harmony Server 
to scan and vectorize your drawings, the selected style must be available on all the 
machines included in the batch processing list.

Refer to the Control Center Guide to learn more about setting up and using batch 
processing.

How to set the VectOptions.conf file on Linux using the “gedit” text editor

1. Open a Terminal window:
Menu: Applications> System Tools> Terminal

2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_11.0/etc

3. Change your user to "root":

$ su

‣ If your user is part of the sudoers list, enter the following command and go to See "Open 
the 'VectorOptions.conf using the  "gedit" text editor:" on page 82: 
$ sudo gedit VectOptions.conf

4. Enter the root password.

5. Open the 'VectorOptions.conf using the  "gedit" text editor:

$ gedit VectOptions.conf

6. Edit the parameters of the VectOptions.conf file like you would do in most text editor 
application.

7. Select File > Save.

8. Select File > Quit.
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9. If you have Harmony Scan on your computer, you can start the application and verify that the new 
style appears in the Vectorization Style list under Edit > Vectorization Style.

If you are using the batch processing method available with Toon Boom Harmony Server 
to scan and vectorize your drawings, the selected style must be available on all the 
machines included in the batch processing list.

Refer to the Control Center Guide to learn more about setting up and using batch 
processing.
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Chapter 2: Scene Setup

Setting up your scene can be compared to building a set for a television show. This is the point when 
you position each scene element such as the camera frame, the background elements and the 
characters.

This chapter contains the following topics:

• Importing the Scene Components  on the next page

• Setting the Camera Frame  on page 87

• Positioning the Scene Components  on page 92

• Cloning and Duplicating Layers  on page 124

• Setting Up the Network  on page 128

• Display Concepts on page 157

• Creating a Multiplane on page 163

• Orthographic Camera on page 172
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Importing the Scene Components 

The first step in the scene setup task is gathering the scene’s different components and then 
importing them into your project. You might need to import some backgrounds, sound files or movie 
clips to complete your scene. You can refer to the following topics to learn how to bring those 
elements in.

• Importing Bitmap Images  on page 18

• Importing QuickTime Movies  on page 67

• Importing a Sound File on page 280

If you have trouble finding elements you imported, it is a good idea to verify if your elements are 
connected to your Composite module in the Network view. Refer to Setting Up the Network  on 
page 128 and Display Concepts on page 157 to learn more about the Network view connections and 
display concepts.
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Setting the Camera Frame 

The scene action occurs inside the camera frame, so it’s really important to set it up correctly.

The Camera layer is static which means that if you need to animate it, you must add a peg—see 
Animating the Camera on page 221 and 3D Camera Motion on page 192.

To set the camera frame, you need to add a camera layer to your scene, so you can edit the camera 
frame. If you have added more than one camera to the scene, you can switch the active camera by 
selecting Scene > Camera and then selecting a camera.

In Toon Boom Harmony, you can also use the Network and Module Library views to add a camera to 
your scene.

In the Timeline view, you can only see one camera at the time. If you add several cameras to your 
scene, you can use the Camera List to select the active one. You could use this feature if you are still 
working on your scene composition and have different camera framing to try out.

You can reposition your camera frame directly in the Camera view, using the Translate  and Rotate 
 tools.

Another way to set up your camera frame is to type the coordinates directly in the camera's Layer 
Properties dialog box. Doing this positions the camera precisely where you want it to be rather than 
gauging it visually—see Positioning an Element Using the Layer Properties  on page 108.

Once you set up your camera frame, you can always easily reset it to its original position. Use the 
Reset command to reset the value of the selected element to the initial value of the active tool. For 
example, if the Rotate  tool is active, the transformation angle will be reset to 0 and if the 
Transform  tool is active, then all parameters values will be reset.

You cannot add a camera inside a symbol.

How to add a camera layer in the Timeline view

1. Do one of the following:

‣ In the Timeline view, click the Add Layer  button and select Camera.

‣ From the top menu, select Insert > Camera.

A new camera layer is added to the scene and appears in the Timeline view.

How to add a Camera module in the Network view

1. Display the Network view.

2. In the Module Library view, select a Camera module from the Favorites, Move or All Modules tab.
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3. Drag the Camera module into the Network view.

How to select a camera from the Camera list (set the active camera)

1. From the top menu, select Scene > Camera > the desired camera.

If you only add one camera to your scene, you will only see Default Camera in your list.

How to reposition the camera frame directly in the Camera view

1. In the Tools toolbar, disable the Animate  mode.

2. Do one of the following: 

‣ From the top menu, select Animation > Tools > Translate. 

‣ In the Advanced Animation toolbar, click the Translate  tool.

‣ Press Alt + 2.

3. In the Camera view, click on the camera frame to select it. You can also select the camera layer 
from the Timeline or Network view.

The selected camera frame is highlighted in purple.

4. Drag the camera frame to a new position. 
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5. To tilt the camera frame, do one of the following to select the Rotate tool:

‣ From the top menu, select Animation > Tools > Rotate.

‣ In the Advanced Animation toolbar, select the Rotate  tool.

‣ Pres Alt + 3.

6. In the Camera view, drag to rotate the camera frame until it reaches the desired rotation angle.

How to set up the camera frame using the camera Layer Properties

‣ In the Timeline view, double-click on the Camera layer.

The camera Layer Properties dialog box opens.
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Parameter Description

Enable/Disable Turns the camera layer on or off.

Change Track Colour

The Change Track Colour  button lets you change the colour of the 
exposed frames; this helps you to quickly locate a layer in the Timeline 
view. Double-click on the colour swatch to open the Select Colour win-
dow and choose a new colour. You can modify the layer for any type of 
layer, such as group, peg, drawing, and effects.

Name
Displays the current layer name. You can rename the layer by typing in a 
new layer name.

Position

Displays the current position of the camera layer using X-axis 
(East/West), Y-axis (North/South) and Z-axis (Forward/Backward) 
coordinates. To reposition your camera frame, type in the new values 
corresponding to the desired position coordinates. You can also use 
the up and down arrows to set the value of each field—see Positioning 
an Element Using the Layer Properties  on page 108.

Angle
Displays the current rotation value. To set a new rotation position, type 
in a new angle value. You can also use the up and down arrows to set 
the new angle value.

Pivot

Displays the current position of the rotation pivot of the camera layer. 
The camera will perform a rotation taking the position of the pivot as its 
angle centre. By default, the pivot is set at the centre of the camera 
frame. To reposition the pivot point, type in new X and Y coordinates 
values in the appropriate field. You can also use the up and down 
arrows to set the position values.
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In order to see the pivot's position you will need to have the Rotate tool 
selected.

Clipping Planes

You can change the near and far clipping planes of the 
camera. The near plane is the point on the camera cone 
where the camera is located. The far clipping plane is the far 
end of the camera cone. Nothing outside that range is visible. 
This is useful when dealing with 3D elements and 3D sets.  For 
example, the camera can be looking inside a 3D box or room 
and you might want the foreground wall to not obstruct the 
view of the interior. By default, the near clipping plane is set 
to 1 field and the far clipping plane is set to 1000 fields.

Override Scene FOV Enable the FOV field in which you can type in a new field-of-view value. 

FOV

Displays the current field-of-view default value. When 
enabled, you can type in a new zoom value for your camera 
frame. You can also use the up and down arrows to set the 
new zoom value.

Click on the Create Function button to animate the camera 
zoom value—see Animation Paths on page 201 to learn more 
about creating functions.

Set Default FOV Resets the custom zoom value to its default value. 

How to reset the camera position

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

2. In the Timeline or directly in the Camera view, select the camera layer.

3. From the top menu, select Animation > Reset or press Shift + R.

The camera automatically returns to its original position.
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Positioning the Scene Components 

Setting up the scene also involves positioning the different scene elements within the camera frame.

Here are the main features and topics you need to know about to position your elements:

• Animate Mode below

• Selecting a Layer  below

• Positioning an Element Using the Transform Tool  on page 97

• Positioning an Element Using the Advanced Animation Tools on page 105

• Flipping an Element on page 103

• Positioning an Element Using the Layer Properties  on page 108

• Auto Apply Option  on page 121

• Resetting a Transformation  on page 122

Animate Mode
When positioning elements, make sure the Animate Mode is turned off, or it will create a keyframe on 
your drawing layer. The animate mode is used to animate layers over time.

How to turn off the Animate mode

‣ In the Tools toolbar, click the Animate Mode  button.

‣ In the top menu, disable Animation > Animate.

Selecting a Layer 
There are different ways to select the layers you want to reposition in the Camera view.

You can select your elements directly in the Camera view using the Transform  tool. When using this 
tool, its properties and options appear in the Tool Properties view. Always make sure that the Peg 
Selection  Mode option in the Tool Properties view is disabled or it will limit the selection to pegs only.

You can change the display style of selected elements to a bounding box style. This removes the 
default overlay highlight and leaves only the bounding box around the selected element.
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When you have several layers in the Timeline view, you may find it hard to locate which one is selected. 
You can use the Centre on Selection feature to display the selected layer in the Timeline view.

Like the Timeline view with its many layers, when you have several modules in the Network view, you 
may find it hard to locate which one is selected. You can use the Centre on Selection feature to focus 
on the selected module in the Network view. You can also select elements in the Timeline or Xsheet 
view. This can be useful when there are too many objects in the scene or when an object is hard to 
grab. Finally, you can select all the elements within a group at once via via the Network or Timeline 
view.

How to select a layer in the Camera view

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

2. In the Transform Tool Properties view, make sure that the Peg Selection Mode  is deselected.

3. In the Camera view, select the element to be repositioned. You can select more than one element 
at a time.

The corresponding layers and columns are highlighted in the Timeline and Xsheet views.

How to set the bounding box selection style

1. Do one of the following:

‣ From the top menu, select View > Show > BBox Selection Style. 

‣ In the Camera View bottom toolbar, click the BBox Selection Style  button.

How to center on the selected layer in the Timeline view

1. In the Camera view, select a layer.

2. Click anywhere in the Timeline view to make it the currently active view.

3. Do one of the following:

‣ From the Timeline view menu, select View > Centre on Selection or press O. If your 
selected layer is in a group or is a child of one or more elements, continue pressing O to 
expand the layers in the Timeline until your selected layer becomes visible.
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‣ In the Timeline View toolbar, click the Centre on Selection  button.

How to center on the selected layer in the Network view

1. In the Camera or Timeline view, select a layer.

2. Click anywhere in the Network view to make it the currently active view.

3. Do one of the following:

‣ From the Network View menu, select View > Centre on Selection. 

‣ In the Network View toolbar, click the Centre On Selection  button. 

‣ Press O.

How to select from the Timeline or Xsheet view

‣ In the Timeline view, click the layer corresponding to the element you want to reposition. 

‣ In the Xsheet view, click the column header corresponding to the element you want to 
reposition.

The selected element is highlighted in the Camera view.

How to select all elements within a group in the Network view

1. In the Network view, navigate to the group whose elements you want to select.

2. Drag a marquee selection around the group module.

All elements within that group are selected.

How to select all elements within a group in the Timeline view

1. With a group collapsed or expanded, hold down Alt and click on the group in the Timeline view.
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All elements contained within the group are selected.

Locking Layers in the Timeline View 
You can prevent correctly positioned layers from being selected by locking them in the Timeline view. 
This is useful for making a multiple selection inside the Camera view and leaving them visible. Once a 
layer has been locked, its locked state will be remembered the next time you open a saved project.

You can perform five types of locking actions on your layers:

• The Lock  option lets you lock one or a multiple selection of layers. 

• The Unlock  button lets you unlock one or a multiple selection of locked layers.

• The Lock All  option lets you lock all the layers in the Timeline view. 

• The Unlock All  button lets you unlock all the layers in the Timeline view. 

• The Lock All Others  button lets you lock every layer except the selected ones.

How to lock a layer or a selection of layers

1. In the Timeline view, select one or more layers.
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2. Do one of the following: 

‣ From the top menu, select Animation > Lock > Lock. 

‣ Click one of the selected layer’s Lock  icon. 

‣ Press Ctrl + Alt + L (Windows/Linux) or ⌘  + Alt + L (Mac OS X).

All selected layers are locked. 

 

How to unlock a locked layer or a selection of locked layers

1. In the Timeline view, select one or more locked layers.

2. Do one of the following: 

‣ From the top menu, select Animation > Lock > Unlock. 

‣ Click a selected layer’s Lock  icon. 

‣ Press Ctrl + Shift + K (Windows/Linux) or ⌘  + Shift + K (Mac OS X). 

All selected layers are unlocked.

How to lock all layers

1. Do one of the following:

‣ From the top menu, select Animation > Lock > Lock All. 

‣ In the Timeline view, select all layers and click Lock  icon of a selected layer. 

‣ Press Ctrl + Shift + L (Windows/Linux) or ⌘  + Shift + L (Mac OS X).

All layers are locked.

96



Harmony 11.1 Compositing Guide (Network)

How to unlock all layers

1. Do one of the following:

‣ From the top menu, select Animation > Lock > Unlock All. 

‣ Press Ctrl + Alt + Shift + L (Windows/Linux) or ⌘  + Alt + Shift + L (Mac OS X). 

All layers are unlocked.

How to lock all other layers

1. In the Timeline view, select the layers you do not want to lock.

2. Do one of the following: 

‣ From the top menu, select Animation > Lock > Lock All Others. 

‣ Press Ctrl + Alt + Shift + O (Windows/Linux) or ⌘  + Alt + Shift + O (Mac OS X). 

All layers are locked except the selected ones.

Positioning an Element Using the Transform Tool 
Using the Transform tool, you can easily reposition, scale, rotate and even skew layers directly in the 
Camera view. 

When positioning a drawing layer using the Transform tool, always make sure the Peg Selection Mode 
 is deselected in the Tool Properties view. Otherwise, it will limit the selection to pegs in the 

Camera view.
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Refer to Positioning Elements in 3D Space on page 184 to learn about the 3D Transform tool and how to 
position elements in 3D space.

Transformations, such as rotation, scale, skew and flip are made relative to the pivot point position. 
You can temporarily reposition the pivot point for each transformation using the Transform tool. Note 
that the pivot is only moved temporarily. When animating the position, the interpolation is calculated 
from the permanent pivot position—see Positioning an Element Using the Advanced Animation Tools 
on page 105.

How to temporarily reposition the pivot point

1. In the Tools toolbar, select the Transform  tool.

2. In the Tool Properties view, make sure the Peg Selection Mode  is disabled.

3. In the Camera view, select your element.

The pivot point appears in the Camera view.

4. Click on the pivot point and drag it to a new position.
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This will be the new position of the pivot point for the current transformation. It will remain in this 
position as long as you do not deselect the drawing. Using the Transform tool to reposition your 
pivot will temporarily override the existing pivot point position until you complete the current 
transformation. Then it returns automatically to its original position.

When you translate the pivot point using the Transform tool, the permanent pivot will appear as a 
ghost so you know where it is and also from where the animation will be interpolated when you 
create motion paths. The animation is always interpolated from the original pivot and not the 
temporary pivot.

How to pan a layer using the Transform tool

1. In the Tools toolbar, disable the Animate  mode.

2. In the Tools toolbar, select the Transform  tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

4. In the Camera view, select a drawing layer and drag the selection to a new area. You can select 
multiple layers to reposition them at the same time. Press Shift and select the different layers.

How to rotate a layer using the Transform tool

1. In the Tools toolbar, disable the Animate  mode.

2. In the Tools toolbar, select the Transform  tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

4. In the Camera view, select a drawing layer.

5. Place  the pointer outside of a corner of the bounding box and drag to rotate.
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You can display a rotation handle on the bounding box when transforming a layer. In the 
Preferences dialog box, select the Camera tab and then select the Use Rotation Lever 
with Transformation Tools option. This preference is off by default.

How to scale a layer using the Transform tool

1. In the Tools toolbar, disable the Animate  mode.

2. In the Tools toolbar, select the Transform  tool or press Shift + T.

3. In the Transform Tool Properties view, make sure the Peg Selection Mode  is deselected.

4. In the Camera view, select a drawing layer and pull or push on the size, top, or corner control 
point. Hold down Shift to lock the selection's aspect ratio. 

How to skew a layer using the Transform tool

1. In the Tools toolbar, disable the Animate  mode.

2. In the Tools toolbar, select the Transform  tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

4. In the Camera view, select a drawing layer.

5. Place  the cursor between two controls points and drag sideways or up and down. 
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Transform Tool Properties

Icon Tool

Lasso and Marquee below

Peg Selection Mode on the next page

Snap Options on the next page

Hide Manipulator Controls on the next page

Works on Single Drawing on the next page

Flip Horizontal and Flip Vertical on the next page

Rotate 90 Degrees CW and CCW on page 103

Offset X and Y  on page 103

Width and Height  on page 103

 Angle  on page 103

Lasso and Marquee

The Lasso and Marquee options let you choose the type of selection the current tool will perform. 
The default selection mode is Marquee.

• Lasso  lets you draw a custom selection box around zones.

• Marquee  makes a rectangle selection box.

Hold down the Alt key to switch to the opposite mode of your selection.

How to invert a selection

1. Do one of the following:

‣ From the top menu, select Edit > Invert Selection. 

‣ From the Camera or Drawing menu, select Edit > Invert Selection.
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‣ Press Ctrl + Shift + I (Windows/Linux) or ⌘  + Shift + I (Mac OS X). 

Peg Selection Mode

In the Camera view, the Peg Selection Mode limits the selection to peg layers instead of drawing 
layers. This mode is useful when you have created a character rig using peg layers for each drawing.  
That way, you do not accidentally select the drawing layer when you want to animate on the peg.

When disabled, the Transform  tool selects the drawing layers.

Snap Options

When transforming or repositioning a layer using the Transform tool, you can enable different snap 
options to help you. 

• Snap and Align: Snaps the selected layer to any existing line, while automatically 
displaying temporary rulers that guide you and that you can also snap your object to.

• Snap to Grid: Snaps your selection according to the currently enabled grid.

Hide Manipulator Controls

The Hide Manipulator Controls  button lets you hide the bounding box and manipulator controls 
from the Camera view when an element is selected.

Flip Horizontal and Flip Vertical

The Flip Horizontal  and Flip Vertical  buttons let you flip the selected element horizontally or 
vertically. You can also select Animation > Flip > Flip Horizontal and Flip Vertical from the top 
menu or press 4 or 5.

Works on Single Drawing

By default, when you draw a selection box in the Camera view, the Select tool will select only the 
drawing strokes of the current drawing. If you prefer the Select tool to select all the strokes on all 
layers, deselect the Works on Single Drawing  button.
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Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW  and Rotate 90 Degrees CCW  operations rotate the current 
selection 90 degrees clockwise or counter-clockwise.

‣ From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 
Degrees CCW.

‣ Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or ⌘  + 7 and  ⌘  + 9 (Mac OS X).

Width and Height 

The Width  and Height  fields allow you to enter specific values for accurately resizing a 
selected layer.

• Width: Enter a width value in this field to resize the width of your selection.

• Height: Enter a height value in this field to resize the height of your selection.

• Lock: Click the Lock icon to lock or unlock the ratio between the width and height values. 

Offset X and Y 

Use the Offset X and Offset Y  fields to enter specific values to reposition the selected layer 
accurately.

• X: Enter an offset value in this field to reposition the selected layer along the X-axis.

• Y: Enter an offset value in this field to reposition the selected layer along the Y-axis.

Angle 

The Angle  field lets you enter specific values to rotate the selected layer accurately. A positive 
value rotates the layer counterclockwise and a negative value rotates the layer clockwise.

• Angle: Enter a degree value in this field to rotate the selected layer.

Flipping an Element

There are two different options you can use when you want to flip your element.
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The Flip Horizontal and Flip Vertical options let you flip a drawing layer along the Camera view’s 
horizontal and vertical axis.

Once your drawing layer is rotated, the original horizontal and vertical axes change. The Flip Scale X 
and Flip Scale Y will perform a flip on your drawing layer following its original axis.

• The Flip Horizontal command flips the layer following the Camera view X-axis.

• The Flip Scale X command uses the original X-axis of the layer and flips the element following it.

How to flip a layer

1. In the Tools toolbar, disable the Animate  mode.

2. In the Tools toolbar, select the Transform  tool or press Shift + T.

3. In the Transform Tool Properties view, make sure the Peg Selection Mode  is deselected.

4. In the Camera view, use the Transform  tool to select a drawing layer to flip.

5. Do one of the following:

‣ From the top menu, select Animation > Flip > Flip Horizontal or Flip Vertical. 

‣ In the Tool Properties view, click the Flip Horizontal  and the Flip Vertical  buttons.

‣ Press 4 or 5. 

How to flip an element following its original axis

1. In the Tools toolbar, disable the Animate 
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 mode.

2. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

3. In the Camera view, use the Transform  tool to select an element that has already been 
transformed.

4. From the top menu, select Animation > Flip > Flip Scale X or Flip Scale Y.

Positioning an Element Using the Advanced Animation Tools
You can also use the advanced animation tools to position your layers. The difference between these 
tools and the Transform tool is that they modify only one parameter of the position such as the 
rotation or the scale as the Transform tool adjusts all parameters together.

Transformations, such as rotation, scale, skew and flip, are made relative to the pivot point position. 
You can reposition this pivot point anywhere using the advanced animation tools.

How to permanently reposition the pivot point

1. In the Advanced Animation toolbar, select the Translate , Rotate , Scale , or Skew  
tool.

2. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) to select your element. 

The pivot point appears in the Camera view.
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3. Drag the pivot point to a new position.

All transformations, including existing ones will be recalculated from this new pivot postion.

How to pan a layer using the Translate tool

1. In the Tools toolbar, disable the Animate  mode.

2. Do one of the following: 

‣ From the top menu, select Animation > Tools > Translate. 

‣ In the Advanced Animation toolbar, click the Translate  tool.

‣ Press Alt + 2.

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) on the element to select 
it and drag the selection to a new area. 

You can select multiple layers to reposition them at the same time. Press Ctrl + Shift + click 
(Windows/Linux) or ⌘  + Shift + click (Mac OS X) on each element to select them.

How to rotate a layer using the Rotate tool

1. In the Tools toolbar, disable the Animate  mode.

2. Do one of the following: 

‣ From the top menu, select Animation > Tools > Rotate. 

‣ In the Advanced Animation toolbar, click the Rotate  tool.

‣ Press the Alt + 3. 
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3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) on the element to select 
it and rotate the layer. 

You can select multiple layers to rotate them at the same time. Press Ctrl + Shift + click 
(Windows/Linux) or ⌘  + Shift + click (Mac OS X) on each element to select them. 

How to scale a layer using the Scale tool

1. In the Tools toolbar, disable the Animate  mode.

2. Do one of the following: 

‣ From the top menu, select Animation > Tools > Scale. 

‣ In the Advanced Animation toolbar, click the Scale  tool.

‣ Press Alt + 4. 

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) on the element to select 
it and pull or push either on the side, top or corner control point. Hold down Shift to lock the 
selection’s ratio when using the corner control points. 

You can select multiple layers to scale them at the same time. Press Ctrl + Shift + click 
(Windows/Linux) or ⌘  + Shift + click (Mac OS X) on each element to select them.

How to scale a layer using the Skew tool

1. In the Tools toolbar, disable the Animate  mode.

2. Do one of the following: 

‣ Select Animation > Tools > Skew. 

‣ In the Advanced Animation toolbar, click the Skew  tool.

‣ Press Alt + 5.

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) on the element to select 
it and drag a side of the bounding box up, down or sideways. 
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You can select multiple layers to skew them at the same time. Press Ctrl + Shift + click 
(Windows/Linux) or ⌘  + Shift + click (Mac OS X) on each element to select them. 

Positioning an Element Using the Layer Properties 
Each layer has a series of parameters that can be modified to adjust the object's position. These 
parameters can be access in the Layer Properties view. In the Layer Properties view, you can type in a 
value rather than moving the object in the Camera view. These values can also be animated over time.

You can also access a layer's parameters in the Timeline view. Click on the Expand Parameters arrow 
and the Show Data View button.
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It is important to understand the coordinate values in Harmony. Harmony's core is based on the 
origins of animation. In traditional animation, a scene's size and camera motion are calculated in fields. 
A field has a 4:3 ratio and measures 0.5 inch in width. A specific grid has been created for this purpose. 
It is known as a field chart. Harmony uses this unit of measurement as its coordinate system.

A field chart uses cardinal directions. The X axis is the east-west direction, the Y axis is the north-south 
direction and the Z axis is the forward-backward direction.

In Harmony, a drawing's pivot is located at the centre of the field chart, regardless where your 
drawing has been drawn on the page. Your drawing is the entire sheet of paper, not only the drawing 
strokes you have drawn on the page. This allows scanned drawings, imported images and paperless 
drawings to be properly registered together.

If you want to move your drawing in the upper left region of the camera frame, you would type in 
something like the following:

• X Axis: -4 or 4W (4 West)

• Y Axis: 5 or 5N (5 North)

If you want to move your drawing in the lower right region of the camera frame, you would type in 
something like the following:

• X Axis: 3 or 3E (3 East)

• Y Axis: -2 or 2S (2 South)

How to position an element using its Layer Properties dialog box

1. Do one of the following:

‣ In the Timeline view, right-click on the drawing layer and select Layer Properties  

‣ In the Network view, clicking the module’s square yellow button. 

‣ Single-click or double-click on the layer.

‣ Press Shift + E. 

The Layer Properties dialog box opens.
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The Enable 3D check box displays the 3D parameters in the Layer Properties—see Enabling the 3D 
Option on page 174.

2. In the Position section, type in the desired values:

‣ X - Left/right or east/west

‣ Y - Up/down or north/south

‣ Z - Forward/backward

As you type in the new values, the element’s position is updated in the Camera view. 

 

‣ Select the Separate option to enable the independent edit of the different coordinate fields 
or select the 3D Path option to enable the use of a 3D path function when animating your 
element—see Layer Parameters on page 211 .

‣ In the (x) Axis field, type in a new East/West coordinate corresponding to the desired 
position.
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‣ In the (y) Axis field, type in a new North/South coordinate corresponding to the desired 
position.

‣ In the (z) Axis field, type in a new Forward/Backward coordinate corresponding to the 
desired position—see Creating a Multiplane on page 163.

‣ The Function  buttons are used to create function curves to add keyframes when 
animating.

3. In the Scale section, select one of the following: 

 

‣ Locked: Resizes the element while keeping its ratio.

(xy) Axis: Type in the horizontal and vertical scales value.

‣ Separate: Resizes the element with independent X and Y scales. This allows you to squash 
and stretch.

(x) Axis: Type in the horizontal scale value.

(y) Axis: Type in the vertical scale value.

‣ The Function  buttons are used to create function curves to add keyframes when 
animating.

4. In the Angle Z field, type in a degree value for the rotation angle. Note that you can enter values 
greater than 360 and -360 degrees. If you enter 720, the object will rotate twice.

5. In the Skew field, type in a degree value between -90 to 90 for the skew angle.

6. In the Pivot section, type in the desired coordinate value to reposition the transformation pivot. 
This will change the permanent position of the pivot.

‣ In the (x) Axis field, type in a new East/West coordinate corresponding to the desired 
position.

‣ In the (y) Axis field, type in a new North/South coordinate corresponding to the desired 
position.

Layer Properties Options

A drawing layer properties dialog box is composed of four tabs.
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• Transformation Tab

• Drawing Tab  on the facing page

• Advanced Tab  on page 114

• Controls Tab  on page 119
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Drawing Tab 

Parameter Description

Element Columns

Full Name: Select which element to connect to the module 
from the drop-down list of elements that already exist in your 
scene.

Drawing Path: Displays the full path to the current drawing.

Timing Columns

Name: Path to the file that you want to link to.

Timing Column: Link to the column that contains the desired 
timing.

Extension: When linking to a background file, enter its 
filename extension.

Field Chart: If you are importing traditional animation, select 
the size of the paper on which the animation was drawn.

Art Layers

Line Art/Colour Art Enabled: Lets you set layers as line art, 
colour art, or both.

Line Art Type: Designates the layer as a Line Art layer.

Colour Art Type:  Designates the layer as a Colour Art layer.
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Bitmap File Options

When an image is created with an external software and that 
image has some transparency, there are several formats the 
software can use when writing the RBG channels. The 
purpose of the four import options for the transparency is for 
the user to tell Harmony how to interpret the RGB channels of 
the imported image. The correct option has to match the 
ouput format of the software that was used to create the 
image in the first place. For instance, if the you used Adobe 
Photoshop and exported an image as Straight, then it should 
be imported in Harmony as Straight in order to get the 
correct result.

Note that if the image has no alpha channel, or if it does have 
an alpha channel and all the pixels are 100% opaque, itdoes 
not make any difference which option is selected.

Colour: Controls the production of colour information from 
bitmap images. If this module reads 3 or 4-channel bitmaps, 
this selection determines whether the colour should be read 
or ignored. If this module reads 1-channel bitmaps, this 
selection determines whether the channel should be read as 
colour. When this option is selected with 1-channel images, 
the resulting image will be a greyscale image.

Transparency: Controls the production of alpha information 
from bitmap images. If this module reads a 1 or 3-channel 
image, this option will create a matte from the colour values 
in the image. If the module reads a 4-channel image and this 
option is not selected, the alpha information in the image will 
be ignored.

Transparency Type

• Premultiplied with Black: Semi-transparent pixels in the 
original image are blended with black.

• Premultiplied with White: Semi-transparent pixels in the 
original image are blended with white.

• Straight: Semi-transparent pixels in the original image are 
left as is (unmatted).

• Clamp Colour to Alpha: Semi-transparent pixels in the 
original image are blended with black. On import, each of 
the RGB channels is clamped so that a color value never 
exceed the alpha value for a given pixel. When the RGB 
values are multiplied with the alpha value, that is to say, if 
you have a pixel of value R=247, G=188, B=29 and the 
alpha is 50% or the image has a 50% transparency, then 
the actual RGB values output would be half of the amounts 
listed above. 

Advanced Tab 

In the drawing layer's Layer Properties dialog box, you will find an Advanced tab containing some 
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very useful options:

Parameter Description

Alignment

Alignment Rule: The alignment rule selections are intended 
to deal with drawings that were created on paper of a 
different size or orientation from the default alignment rule 
(set up in the Scene Setting dialog box) or imported bitmap 
images. The drawings are then scaled to match Toon Boom 
Harmony alignment rectangle. Note that alignment rules are 
not based on the camera frame, but on the scene frame. 
Refer to the Fundamentals Guide to learn more about scene 
alignment and scene settings.

• Left: The default alignment for drawings; aligns the drawings 
on the left side of the scene’s alignment rectangle. Toon Boom 
Harmony scales the drawings to match their height to the 
alignment rectangle of the scene.

• Right: Aligns the drawings on the right side of the alignment 
rectangle. Toon Boom Harmony scales the drawings to match 
their height to the height of the alignment rectangle of the 
scene.

• Top: Aligns the drawings on the top of the alignment 
rectangle. Toon Boom Harmony scales the drawings to match 
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their widths to the width of the alignment rectangle of the 
scene.

• Bottom: Aligns the drawings on the bottom of the alignment 
rectangle. Toon Boom Harmony scales the drawings to match 
their widths to the width of the alignment rectangle of the 
scene.

• Centre Fit: Centres the drawings.

• Centre Fill: Centres the drawings and then scales them so that 
the width or height fills the available space.

• Centre LR: Aligns the drawings in the left-right centre of the 
alignment rectangle. Toon Boom Harmony scales the drawings 
to match their height to the height of the alignment rectangle 
of the scene.

• Centre TB: Aligns the drawings in the top-bottom centre of 
the alignment rectangle. Toon Boom Harmony scales the 
drawings to match their widths to the width of the alignment 
rectangle of the scene.

• Stretch: Scales the drawings so that they fit within the 
alignment rectangle of the scene. This is particularly useful for 
images that you will manipulate with a Quadmap module. If the 
drawings in the Quadmap module do not have the same aspect 
ratio as the alignment rectangle of the scene (from the Scene 
Settings dialog box), the handles on the quadmap will not 
appear on the corners of the image, making it difficult to 
manipulate the quadmap. In this case, you would set the 
drawing layer of the quadmap images to Stretch so that the 
handles appear on the corner of the image. This can have the 
effect of distorting the images, but this is not an issue with 
images that will be distorted through the Quadmap module 
anyway.

• As Is: Leaves the drawings aligned as they are. 

• Centre First Page: Aligns the centre of the first part of a 
standard pan cel with the centre of the field chart.

Turn Before Alignment: This option rotates the drawings in 
the selected element 90 degrees to the left before scaling and 
aligning them according to the alignment rule, and before 
performing any offset, rotation or scaling for the element or 
the peg. This and the Alignment Rule are intended for 
drawings that were created on paper of a different size or 
orientation than the other paper in the scene, and requires 
alignment so as to be able to accurately treat them.

Flip Horizontal: Flips the drawing on the X-axis.

Flip Vertical: Flips the drawing on the Y-axis.

Clipping No Clipping: Select this option if you do not want to clip the 
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images in this module before an effect is applied to it.

Clipping Factor (X)/(Y): This is an option for rendering 
images that are larger than the final frame. With this option 
enabled, images can be moved by an Apply Peg 
Transformation module without black entering into the 
composite as a result of early clipping. In addition, this option 
is useful for images that have a blur that should appear in the 
frame even though the image itself is not in frame—see Apply 
Image Transformation on page 360 and Apply Peg 
Transformation on page 355.

Line Thickness

As you move the camera in your scene along the Z-axis, notice 
that, logically, the lines of the elements become thicker the 
closer the camera gets to the drawing. If you prefer the lines 
to remain the same size or become thicker at a different 
speed, you can use the thickness feature to adjust your brush 
stroke and pencil line thickness. You can modify the size of 
the lines even if the camera is not animated.

To learn how to use this feature, see Camera Truck-ins and 
Line Thickness on page 226.

Adjust Pencil Lines Thickness: Lets you work with pencil 
lines and adjust their thickness. You will not see any changes 
to lines in the Camera view OpenGL mode. You must switch 
to the Render mode.

Normal Thickness: Disables all overrides on the brush stroke 
line thickness. This option must be enabled in order for the 
pencil line thickness parameter and pencil lines to appear. If 
you want to modify the brush stroke thickness, deselect this 
option. To enable brush strokes to work with the line 
thickness feature, you must first create central strokes in the 
Colour Art layer. The central strokes control the line variation 
of your brush strokes in the Line Art layer. Select Drawing > 
Create Colour Art from Line Art.

Zoom Independent Thickness: Select this if you want your 
line thickness to remain constant independently from the 
camera move. Everything else will increase in size, but the line 
thickness will stay the same.

Proportional: Enter a multiple by which you want to increase 
the line thickness base on its original thickness. A value of 1 
will result in no change; a value of 0 (zero) will hide the lines.

Constant:  Enter a value in pixels (based on a 720x540 screen 
resolution) to indicate the amount of pixels you want to add 
around the existing line.

Minimum: Enter a value in pixels (based on a 720x540 screen 
resolution) for the minimum line thickness allowed.

Maximum: Enter a value in pixels (based on a 720x540 screen 
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resolution) for the maximum line thickness allowed.

Vector Render Options

• Antialiasing Quality: A smoothness (antialiasing) setting 
applied to the final rendered image. 

• Low: No antialiasing 

• Medium Low: Basic antialiasing

• Medium: Improved antialiasing (Blurs the textures)

• High: High quality antialiasing (Does not blur the 
textures)

Higher quality images require more time to render and 
more system memory. Choose a lower quality if you are 
rendering a pencil test.

• Antialiasing Exponent: Controls the size of the area 
around the final image edges that is used in the 
antialiasing process. A higher value uses less area, 
resulting in sharper edges, while a lower value uses more 
area, resulting in softer edges. If the Antialiasing Quality 
value is set to Low (no antialiasing) or Medium Low, this 
value is ignored. The accepted values are between 0 and 
1.

• Texture Filter: This option changes the way coloured 
pixels of TVG textures are calculated when rendered for 
different degrees of accuracy. 

• Bilinear: This option takes the four pixels around each 
point and makes a bilinear interpolation between them. 
(Medium Quality)

• Nearest: This option chooses the colour of the closest 
pixel to a point. (Lower Quality)

• Nearest (Filtered): This option is an improved version 
of Bilinear and improves the quality when zooming on a 
texture. (Best Quality)

Miscellaneous

• Depth: Overrides the order of cables in the network to 
determine in which order this element is rendered. The Z 
position value overrides the depth value.

• Morphing Velocity: Creates a velocity function curve for 
morphing sequences in the layer. This function modifies 
the interpolation percentage between the 2 drawings. If 
set, the morphing between the two drawings will not be 
linear over time between the two drawings but will be 
modulated according to this curve.  This can be used to 
create a periodic morphing over a long period of time.

• Opacity: Lets you quickly change the transparency of the 
selected element. Opacity settings here will be reflected in 
both OpenGL preview, and full render.  
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Controls Tab 

The Controls tab contains animation control options.

Parameter Description

Animation

• Animate Using Animation Tools: By default, a drawing layer 
can be animated using the same parameters as a peg, but you 
can disable this feature. Being able to switch your drawing 
layers so they can no longer be animated without a peg has 
certain advantages. In cut-out animation, it is easier to 
separate your drawing exposure and keyframes to change 
timing easier and rearrange keyframe position in the Timeline 
view. This feature is also available for backward compatibility 
when bringing in templates created in older versions of the 
software, so as not to lose their offset keyframes or drawing 
substitution keyframes.

Angle Limit Values

Lets you set a maximum and minimum rotation angle for a 
drawing. This option is used mainly for a cut-out character 
when you do not want an elbow to bend too far in or out.

• Enable Min/Max Angle: Activates the minimum and maximum 
angle constraints.

• Min Angle: Type the minimum angle you want the drawing to 
rotate too.

• Max Angle: Type the maximum angle you want the drawing to 
rotate too.

Spline Offset

In the X, Y and Z axis fields, type the coordinates of where 
you want to offset the visual trajectory. By default, the 
trajectory is displayed at the centre drawing, using the layer's 
pivot position. If you want to move it so it corresponds better 
with your drawing, either type new coordinates or use the 
Spline Offset  tool available in the Advanced Animation 
toolbar.

To display the trajectory in the Camera view, select your 
drawing and select View > Show > Control. You can also 
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press Shift + F11 (Windows/Linux) or ⌘  + F11 (Mac OS X).

Setting Properties for Many Layers
When working with several modules, you may frequently want to modify a series of settings. Instead of 
opening the properties for each individual layer, you can set the properties for many layers so you can 
change a common setting in a single click. 

This allows you to modify the following settings:

• 3D Path or Separate mode

• Use Embedded Pivot

• Overlay

• Line Art

• Colour Art

• Underlay

• Animate Using Animation Tools

You can access this function in the Network View toolbar. You can also add the button to the Timeline View 
toolbar through the Toolbar Manager. In the Toolbar Manager, you will find the feature in the script section 
under the name Script: TB_Set_Properties_on_manu_layers in TB_Set_Properties_on_many_layers.js.

How to properties for many layers

1. In the Network or Timeline view, select all the layers you want to modify at the same time.

2. In the Network or Timeline View toolbar, click the Set Properties for Many Layers button.

The Set Properties for Many Layers dialog box opens.
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3. Modify the properties. If your modules have different parameters enabled for a certain setting, 
leave the As Is option selected to avoid modifying it. Each module will keep its original setting. 
Select any other options for all modules to change to this parameter regardless of their original 
setting.

4. Click OK.

Auto Apply Option 
When you modify a parameter in a property dialog box, Toon Boom Harmony calculates the 
modification automatically and displays the result immediately in the Camera view. If you do not want 
to immediately display every change made to your scene, you can turn off this default setting by 
deselecting the Auto Apply option. This is useful when you are working on a very heavy scene.

When you disable this function, Apply and OK buttons at added at the bottom of the Layer Properties 
view and any other parameter dialog box. 

• Click Apply to apply the current change.

• Click OK to apply the current change and close the Layer Properties.
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If you want to always work in Auto-Apply mode, you can deselect the Auto-Apply option in the Preferences 
dialog box. Then, each time you start Harmony, the Auto-Apply  mode will be off. You must click the Apply 
button to see any modifications.

How to enable or disable the Auto Apply option

‣ From the top menu, select Edit > Auto-Apply.

How to enable or disable the Auto-Apply preference

1. In the top menu, select Edit > Preferences (Windows/Linux) or
Stage > Preferences (Mac OS X).

The Preferences dialog box opens.

2. In the Preferences dialog box, select the General tab.

3. In the Options section, select or deselect the Auto Apply option.

Resetting a Transformation 
You can easily reset layers to their original position. With the Reset command, you can return the value 
of a selected element to the initial value of the active tool. For example, if the Rotate  tool is active, 
the transformation angle will be reset to 0 and if the Transform  tool is active, the all 
transformation parameters values will be reset.

When selecting elements in the Camera view using the Transform tool, always make sure that the Peg 
Selection Mode  is deselected in the Tool Properties view. Otherwise, it will limit the selection to 
pegs only.

How to completely reset the layers' position

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

2. In the Timeline or Camera view, select one or more drawing layers to reset. 

3. Do one of the following: 

‣ From the top menu, select Animation > Reset or press R.

‣ Right-click the selected layers and select Clear All Values.

‣ In the Timeline view menu, select Layers > Clear All Values.

The selected layers return to their original position.

How to reset a layer's parameter

1. In the Advanced Tools toolbar, select the Translate , Rotate , Scale , or Skew  tool 
based on the parameter to reset.
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2. In the Timeline or Camera view, select the layer to reset. 

3. From the top menu, select Animation > Reset or press R.

The selected parameter returns to its original position.

How to reset all transformation values except Z

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

2. In the Timeline or Camera view, select one or more drawing layers to reset. 

3. From the top menu, select Animation > Reset All Except Z.

All values except for those set on the Z axis are reset.
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Cloning and Duplicating Layers 

At times, you will need to create a large group of characters such as a crowd, school of fish or flock of 
birds. You can do this by cloning or duplicating a layer during production. The difference between 
cloning and duplicating is that a clone uses the same drawings for all layers. A duplicate is simply an 
independent copy.

If you want to maintain the ability to modify drawings and propagate the changes through all layers, 
then you should clone drawings. If you simply want to copy your drawings and be able to modify your 
drawings without affecting the original layer, use the duplicate option.

Cloning Layers
A cloned layer is linked to the original element directory. If a drawing is modified in the original or 
cloned layer, both will be updated. However, clone layers can have linked or different timings.

In the Timeline view, the left part of the layer is a module, same as in the Network view. These modules 
are linked to columns. The right part of the Timeline view corresponds to the Xsheet column. These 
columns can contain drawing exposures or value keyframes. One module can be linked to several 
columns; one drawing column and parameter columns (rotation, position, scale, pivot, etc.).

When cloning layers, you have the ability to clone the drawings and the corresponding columns 
(timing) or only the drawings. If you choose to clone the drawings and timing, your module will be 
linked to the same element folder as well as the same drawing and function columns. Therefore, if you 
change the drawing exposure or keyframe on one layer, all cloned layers will be updated.
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You may want to create a large group of characters reusing the same animation, but want to slightly 
offset the timing so they are not dancing or walking quite on the same beat. For example, if you create 
a walk-cycle for a soldier and want to use it for an entire army, you may want to have 50 layers with 50 
different drawing exposures to produce a slight difference in the timing. If you copy your layers and 
their drawings 50 times over, it will create a heavier scene. It is better to clone the 50 layers with only 
their drawings without linking to the same function and exposure columns. 

How to clone a layer

1. In the Timeline, Xsheet or Network view, select a layer to clone. You can select multiple layers.

 

2. Do one of the following:

‣ From the Xsheet view menu, select Columns > Clone Selected Columns: Drawings Only 
or Columns > Clone Selected Columns: Drawings and Timing.

‣ From the top menu, select Edit > Clone to clone the columns' drawings only.

‣ From the Timeline view menu, select Layers > Clone Selected Layers: Drawings Only or 
Layers > Clone Selected Layers: Drawings and Timing.

‣ In the Xsheet View or Timeline View toolbar, click the Clone Selected Layers/Columns: 
Drawings Only   button. You might need to add this button to your toolbar using the 
Toolbar Manager.

‣ In the Network View menu, select Modules > Clone Selected Layers: Drawings Only or 
Modules > Clone Selected Layers: Drawings and Timing. When you clone a module, it 
does not automatically connect itself to the Composite module of your scene.

The cloned layer appears. 

 

By default, when you select a module in the Network view and perform a copy/paste 
using Ctrl + C and Ctrl + V (Windows/Linux) or ⌘  + C and  ⌘  + V (Mac OS X), this 
creates a CLONE not a duplicate.  Modules will be linked to the same drawings.  Pegs 
will be linked to the same function columns.

To duplicate a layer in the Network view using shortcuts, press Ctrl + C 
(Windows/Linux) or ⌘  + C (Mac OS X) and Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS 
X) for Paste Special, and select Create New Columns.

Duplicating Layers
You can duplicate a layer to have a copy of the drawings that are independent from the original ones, 
as well as an independent timing (exposure). When you need the drawings to be modified 
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independently, you will want to duplicate the layer instead of cloning it.

How to duplicate a layer

1. In the Timeline, Xsheet or Network view, select a layer to clone. You can select multiple layers.

 

2. Do one of the following:

‣ In the Timeline view menu, select Layers > Duplicate Selected Layers.

‣ In the Network view menu, select Modules > Duplicate Selected Modules. When you 
duplicate a module, it does not automatically connect itself to the Composite module of 
your scene.

‣ From the Xsheet view menu, select Columns > Duplicate Selected Layers.

‣ From the top menu, select Edit > Duplicate.

‣ In the Xsheet View or Timeline View toolbar, click the Duplicate Selected Layers/Columns  
 button. You might need to add this button to your toolbar using the Toolbar Manager.

The duplicated layer appears.
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By default, when you select a module in the Network view and perform a copy/paste 
using Ctrl + C and Ctrl + V (Windows/Linux) or ⌘  + C and  ⌘  + V (Mac OS X), this 
creates a CLONE not a duplicate.  Modules will be linked to the same drawings.  Pegs 
will be linked to the same function columns.

To duplicate a layer in the Network view using shortcuts, press Ctrl + C 
(Windows/Linux) or ⌘  + C (Mac OS X) and Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS 
X) for Paste Special, and select Create New Columns.
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Setting Up the Network 

The Network view uses a visual set of connections (nodes) to show how each element in the scene is 
connected and brought to the final image. It allows you to add extra elements and effects, and to 
move beyond the possibilities offered by the Timeline and Xsheet views.

This section is divided as follows:

• Network View  on page 336

• Network Navigation and Basic Rules  on page 133

• Composite Module on page 141

• Groups on page 143

• Enabling and Disabling Modules on page 152

• Module Thumbnails  on page 153

Network View 
In the Network view, you can connect effects and compositing modules to form a network, also known 
as a node system. This view is very useful for rigging puppets, creating advanced effects and having a 
clear view of complex scenes. The organization and order of the modules determines the flow of data 
during the compositing process and how your animation elements will be composited.
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Symbol Stack

When entering symbols, the Symbol Stack lets you navigate back to the top and see the hierarchy of 
the symbol in which you are working.

Node System

The main area of the Network view is the node system area where you can add and organize 
different modules to represent a scene.

Navigator

The Navigator view lets you pan the visible area to move quickly through extensive node sets.

Search Toolbar

The Search toolbar is used to find and match a module in the project. The search is not case-
sensitive. Once you have entered characters in the search field, press Enter/Return to validate and 
find the pattern in the module names. If successful, the module is selected and centred in the view. If 
many instances are found, use the Previous and Next buttons to cycle through each node.
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Group Navigation

When entering a group, the Group Navigation allows you to navigate back to the top and see the 
hierarchy of the group in which you are.

Modules

There is a series of modules available to compose the network. Here are some basic types and 
information about the main modules.

1. Drawing Module 
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This is an example of an average module, a simple drawing module that represents a layer in the 
Timeline view. This module has an input port (top) that allows information to flow through it. It has 
an output port (bottom) that exports its information in a downward flow. On the left is a yellow box 
that displays the module's property editor, where you can adjust its parameters. Lastly, there is a 
dark arrow that displays a thumbnail of the module's contents. 

2. Write and Display Modules 

Both the Write and Display modules do not have output ports. This is because the information that 
flows into them can go no further in the network. The Write module records the images and renders 
the final output. The Display module captures the visual information and outputs it to the Camera 
view.

3. Composite Module 

The Composite module combines multiple source images (drawing and effect modules), including all 
transformations and effects, into a single bitmap or vector image for each frame.

The Composite module layers the images based on the composition order rule. First, the Z-values of 
the elements are analyzed to determine depth. When multiple elements have the same Z-value, the 
Depth values in the drawing modules are used. If the Depth values are also the same between 
elements, the composition order is determined by the cable order of modules on the Composite 
module. By default, modules connected to the right are rendered below those connected to the left. 
You can override this default in the Composite module editor—see Composite Module on page 141. 
The Composite module is an example of a module that can have an infinite number of input ports 
that can take in multiple, individual sources of information. The leftmost input port on the 
Composite module is always green. This lets you know that, in terms of stacking order, whatever is 
plugged into this port will appear on top of the composite after the Z-depth is taken into account. 
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4. Effect Module

An Effect module can often have two input ports. The right input port is for the drawing layer that is 
to be acted upon by this effect, while the left port is usually reserved for a matte.

5. Matte Drawing 

A matte, also called mask, is the shape that will be used by the effect module to modify the original 
image. The effect will only be applied where the matte overlaps with the original image. Sometimes 
the matte will act as a negative shape that the effect will exclude. This all depends on the nature and 
editing properties of the effect.

6. Position Ports

Some effects contain three input ports. If they are green, then they require a Peg module connection 
(coordinate and value information). In the case above, the effect can accommodate two pegs.

7. Peg Module 

The Peg modules control the transformation of elements (position, scale, skewing and rotation) over 
time. The green ports at the top and bottom of the module indicate that it accepts position 
information and can then pass this information on.

One peg can be used to control many different modules or one module can accept more than one 
peg. In a situation like the latter, one peg might be used to modify the rotation, while the other used 
to modify the position of the effect and then animated differently over time. 
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Network Navigation and Basic Rules 
The basic rules of the Network view are quite simple. Once you understand them, a lot can be 
accomplished.

• About Modules  below

• Input and Output Ports  on the next page

• Adding Modules on page 136

• Composite Module on page 136

• Organizing Modules on page 137

• Connecting and Disconnecting Modules on page 137

• Cable Styles  on page 139

• Navigator Display  on page 139

• Panning the Network View on page 141

About Modules 

Each element in the Network view is called a module. Modules are often referred to as nodes. There 
are several different types of modules: 

Module Description

Drawing Transfers drawing information.

Effect
Processes effects on drawings and transfers drawing inform-
ation.

Input/Output Act as the interface between each module and network.

Move Controls the camera and element transformations over time.

Compositing Combines multiple source images.
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Input and Output Ports 

Each module has an input port at the top and an output port at the bottom. Some are blue and others 
are light-green or bright green. 

• Blue indicates drawing information.
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• Light green indicates position and movement.

• Bright green shows the element on top of the composition and outputs that element’s Z 
position to the Composite module. When many elements have different Z positions (multiplane, 
different distances from the camera) and are placed through a Composite module that flattens 
them together (producing one image with one Z value), the system needs to give a Z position to 
this new image. It uses the bright green port information.

Finally, some modules contain more than one input port. These are usually effect modules needing 
different drawing or position information in order to perform their calculation. When the two ports 
are blue, the Drawing is on the right and the Matte is on the left. If it is light green, the drawing needs 
extra position information.

Viewing Port Information

On each port is a tooltip which displays the source of input ports and the destination(s) of the output 
ports.

How to display port information

‣ Hover the pointer over a port.

The port's tooltip displays source and destination information.
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Navigating the Network View

You can navigate to the parent or child module of the selected module or selected cable in the 
Network view. 

How to navigate the Network view

‣ In the Network view, select a module or cable, and press the Ctrl + Up/Down arrows.

Adding Modules

Each module used to build a network is available in the Module Library view. In addition, each time you 
create a layer from the Timeline or Xsheet views, the corresponding module is created in the Network 
view.

How to import modules from the Module Library

‣ In the Module Library, select a module and drag it to the Network view.

Composite Module

The Composite module allows you to use several images and output a single image. You can compare 
that to doing pre-compositions in editing software. You connect several drawing modules in your 
Composite module and one bitmap comes out of it—see Composite Module on page 141.
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By default, the image resulting from the Composite module is a bitmap. The layers are composited 
together depending on their position on the Z-axis (forward-backward) first, then their order in the 
Composite module. If two images are at the same position on the Z-axis, their order in the Composite 
will determine which one is displayed in front and which one is displayed behind.

Organizing Modules

When you are working in the Network view and adding many modules, your scene may look a bit 
messy and be difficult to follow.  Harmony provides scripts which organize and display the modules in a 
more orderly fashion.

How to organize the network

1. In the Network view, select some or all of your modules.

2. Display the Network View toolbar by selecting Window > Toolbars > Network View.

3. Click the Order Network Up  or Order Network Down  button. 

The Order Network Settings dialog box opens.

 

4. Set values for the X Overlap%, Layer Spacing and Vertical Spacing. The default value is set for 
optimal organization.

5. Click OK.

Connecting and Disconnecting Modules

Making or removing connections between modules is quite simple.
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How to connect modules

1. In the Network view, do one of the following: 

‣ Extend a cable from the first module’s output port (bottom port) and connect it to the 
second module’s input port (top port). 

‣ Select the module to connect, hold down the Alt key and drag the module on an existing 
cable.

It is possible to create links between nodes in the Network views by clicking on one node and ctrl-
clicking on a second port.

Select a node and Ctrl-click a port:

• Click a node and then Ctrl-click the input port of a different node. The nodes are linked.

• Click the output port of a node, and then Ctrl-click a different node. The nodes are linked.

• Click the output port of a node, and then Ctrl-click a Composite node. The node is linked to a 
new input port of the Composite.

• Click a port of a node and then Ctrl + Alt-click a port of a Composite node. The selected port 
replaces the link in the Composite's input port.

• Click an output port of a node and then Ctrl-click the input port of a Group node. The selected 
output port replaces the link to the group.

• Click an output port of a node and then Ctrl + Alt-click the input port of a Group node. The 
selected output port links to a new in-port of the group.

You can reconnect a module's output port without disconnecting its destination port by dragging the link 
while holding  Ctrl (Windows/Linux) or ⌘ (Mac OS X).

How to disconnect modules

1. In the Network view, do one of the following: 

‣ Select the module to disconnect, hold down the Alt key and drag the module away.
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Cable Styles 

You can customize the look of the cables in the Network view to fit your style of working. You can 
display the cable lines as Bezier (curved) lines or straight lines.

How to switch cable styles

‣ In the Network View menu, select View > Cable Style > Bezier or Line.

Navigator Display 

The Navigator is a small square window inside the Network view that displays a bird's eye view of the 
network. The view displayed in the Network view is shown framed in the Navigator display. You can 
drag this frame to pan the current Network view display.
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Showing or Hiding the Navigator 

You can show or hide the Navigator from the Network view.

How to show or hide the navigator, do one of the following

‣ In the Network view menu, select View > Navigator > Hide Navigator or Show Navigator. 

‣ Press Ctrl + Shift + W (Windows/Linux) or ⌘  + Shift + W (Mac OS X).

Positioning the Navigator 

The Navigator display can be placed in any corner of the Network view.

How to position the navigator

‣ In the Network view menu, select View > Navigator > and select Top Left, Top Right, Bottom 
Left, or Bottom Right.

Magnifying the Network view:

The magnifier helps you view the entire network so you can navigate and view the different modules.  

How to magnify the Network view

1. Press Z. 

A black outline surrounds the area you were at before pressing Z.

2. Change the magnification level of the magnifier by rolling the mouse wheel.
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When the magnifier is displayed, it is possible to temporarily switch in and out of the magnified view by 
clicking in the magnifier.

Panning the Network View

When your networks grows more complex, you can pan the Network view to locate and work on 
specific modules.

How to pan the Network view

1. Select a node, press Spacebar and drag to a new location.

Composite Module

The Composite module allows you to use several images and output a single image. You can compare 
that to doing pre-compositions in editing software. You connect several drawing modules in your 
Composite module and one bitmap comes out of it.

For more information about the Composite module options in a 3D environment context, refer to 
Managing a Network with a 3D Scene Setup on page 197.

Parameter Description

Mode

As Bitmap: Composites all images into a single, flat bitmap 
image. The Z value of the final image is based on the Output Z 
selection.

As Vector: Composites all the images as a single vector image. 
The Z value of the final image is based on the Output Z 
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selection. Bitmap elements are ignored and do not appear in 
the final frame.

As Seamless Bitmap: Composites all the images into a single, 
flat bitmap image (just like the As Bitmap compositing mode). 
The main difference between the As Bitmap and As Seamless 
Bitmap modes is that the seamless version ensures that there is 
no visible seam between adjacent vector drawings that have 
matching geometries. This can be useful for cut-out animation, 
where multiple drawings may align perfectly like pieces of a 
puzzle (using masking/cutter). This can also be useful when 
building a 3D set out of flat drawings rotated in 3D. In this 
case, using the Seamless mode will produce the correct result 
when two drawings are intersecting or nearly intersecting. 
When using this mode, the following effects are not supported: 
Shadow, Glow, Blending  and Focus.

Pass Through: No compositing operations occur. No image is 
merged or flattened. Each individual image  keeps its own 
properties. The compositing operations happen only in the 
next Composite module connected below. In this case, the port 
ordering is ignored.

If a Composite set to Pass Through it is the last one in the 
compositing chain, it will act the same as the As Bitmap option. 
At that point, the Input Ordering options are considered.

Input Ordering

2D: Elements connected in the module are composited based 
on their port ordering. The Z-axis (forward-backward) values 
are ignored. The scaling value will be correct, but the actual 
position on the Z-axis is ignored. 

You can use the 2D composite type to create effects such as a 
camera recording overlay on your scene. Since you always want 
this element to be in front regardless of the other elementsè Z-
axis position, you can set the option to 2D.

3D Flat: The Z-axis value of the elements connected in the 
Composite module are considered, so the visual 
representation is correct in the Camera view. The output is a 
flat image.
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3D: The Z-axis value of the elements connected in the 
composite module are considered, so the visual representation 
is correct in the Camera view. The image is not flattened. The 
3D aspect of the elements are kept. For example, if you 
rotated elements on the three axes, the information is retained 
and elements composited in lower levels are able to intersect 
with the elements coming from a 3D Composite module.
The 3D Composite module should only be used in advanced 
cases. It is better to use a Pass Through composite type than a 
3D composite type. This way, all the elements are composited 
in the final Composite module.

Output Options

Output Z: Identifies which element’s front-back value from the 
current composition is applied to the entire composited image 
in the next operation. If you select Portnumber, identify the 
appropriate port by its position using the Port For Output Z 
menu. The port used appears in a bright green colour on the 
Composite module. By default, the leftmost port is displayed in 
front and the rightmost port is displayed behind.

Bitmap Options

These options are active when you select the As Bitmap mode.

Apply Focus: Activates the Focus effect for this module in the 
composite operation.

Focus Multiplier: The value entered in this field is used as a 
multiplier for the radius value specified in the Focus or Focus-
Multiplier modules. 

Vector Options

These options are active when you select the As Vector mode.

Palette Name: When you render files, use this field to set the 
name of the palette files that Toon Boom Harmony will create 
for them.

Flatten: Flattens vector drawings into one vector drawing file. 
Any transparency will be lost in the process. This creates 
smaller vector files, but might increase the time required to 
composite the drawings. This can be useful when reusing 
drawings. Because they will be vector files, you can still apply 
vector-based transformations and effects.

Groups
With so many connections and modules possible, the network can quickly become crowded. Keep 
things organized by grouping your modules.
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There are several advantages to using the Group Selection With Composite command over the simple 
Group Selection (which references both the Group layer in the Timeline view and the Group module in 
the Network view.

One of the advantages of using this command is that it groups all the selected elements into a neat 
module that has a nested composite. This means that there is only one connection coming out of the 
Group module. With the simple Group module or command, the Group displays the same number of 
connections as elements in the group. Both grouping commands display the same structure in the 
Timeline view.

The Group Selection With Composite command should only be used before any work has been done 
in the Network view and it recommended for objects whose stacking order is of no consequence.

Using the Group Selection from Composite command on elements that have effects, have been 
tweaked in the Network view, or whose stacking order is of consequence, may cause the grouped 
elements to lose their properties once grouped in this way. In addition, though you may only select a 
few modules to group, if there are other layers in the timeline that exist between the selected layers, 
they will automatically be grouped, even if not selected.

Once you create a group module, it is easy to enter into or exit from it.

Using the Move to Parent Group command allows you to move the selected module to the parent 
level, maintaining all connections.  If the operation cannot maintain the connections between the 
modules, you will be notified and the operation will be terminated.
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To quickly access parameters for modules that are grouped, you can use the Publish Attribute Mode 
feature to select your most common parameters to modify and make them appear in the group Layer 
Properties editor. This way, you can access them directly without having to enter the group every 
time.

How to group selected modules

1. In the Network view, drag a selection around the modules you want to group.

2. In the Network View menu, do one of the following:

‣ Select Edit > Group > Group Selected Layers.

‣ Press Ctrl + G (Windows/Linux) or ⌘  + G (Mac OS X).

The modules are grouped.

To ensure that you have a Multi-Port Out Module in your group and that your group 
remains connected, include a Composite module in your selection and make sure it is 
connected to the main Composite module of the scene before grouping.

How to group selected elements using the Group Selection With Composite com-
mand in the Network view

1. In the Network view, select the elements that you want to group. 
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2. Right-click in the Network view and select Group > Group Selection With Composite. 

The selected modules are grouped.

How to group selected elements using the Group Selection With Composite com-
mand in the Timeline view

1. In the Timeline view, in the layers section, select the elements that you want to group. 

Any layers between the selected layers will be automatically grouped as well, so if the stacking 
order does not matter, move extra layers above or below the layers want to group. 

2. Right-click on one of the highlighted layers and select Group Selection With Composite. 

The layers appear indented under a new Group layer in the Timeline view and in a new Group 
module in the Network view. 

How to ungroup a group

1. In the Network view, select the group of modules you want to ungroup.

2. In the Network View menu, select Edit > Group > Ungroup  or press Ctrl + Shift + G 
(Windows/Linux) or ⌘  + Shift + G (Mac OS X).

The selected group is ungrouped.
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How to enter a group module

3. In the Network view, click the arrow on the right side of the group module you want to enter.

‣ Inside the group module, the Multi-Port In and Multi-Port Out modules ensure that your 
connections continue beyond the group.

How to exit a group module

1. In the Network view, click the destination in the Group Hierarchy menu. You can also select 
Modules > Exit Group from the Network View menu.

‣ You can click on the top and bottom blue arrows appearing in the Network view to exit the 
current group.

‣ When you enter a group, the Group Hierarchy Menu displays the path to where you are. In 
this example, we are inside the group named group. To exit this group, click on Top located 
at the bottom left corner of the Network view.
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How to move up a level in a group

‣ Click the arrow at the top of the Network view.
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How to move a selected module to its parent group

1. In the Network view, go inside the group and select the modules you wish to move up to the 
parent group level.

2. In the Network View menu, select Modules > Move to Parent Group or press Ctrl + Shift + U 
(Windows/Linux) or ⌘  + Shift + U (Mac OS X).

The selected modules are moved to the parent group level.
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How to use the Publish Attribute Mode function

1. In the Network View menu, select View > Publish Attribute Mode.

2. In the Network view, enter the group containing the modules you want to promote.

3. Select the module you want to publish attributes for.

4. In the Layer Properties view, enable or disable the publishing checkboxes for the different 
parameters. You can easily distinguish them as they are labeled in red.
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5. Repeat the previous step for all the modules you want to publish attributes for.

6. In the Network view, exit the group.

7. Select the Group module.

In the Layer Properties view, you can see all published attributes. The different modules are tabbed 
for easy access and organization.
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Enabling and Disabling Modules
As with the Timeline layers, you can turn the Network view modules on or off. When you turn off a 
module in the Network view, its corresponding layer in the Timeline view is also turned off. Modules 
that are turned off are displayed in red.

How to enable modules

1. In the Network view, select the disabled module(s) you want to enable.

2. In the Network view menu, select Modules > Enable or press A. This keyboard shortcut is also 
valid in the Timeline view.

How to enable all modules

1. In the Network view menu, select Modules > Enable All.
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How to disable modules

1. In the Network view, select the module(s) you want to enable.

2. In the Network View menu, select Modules > Disable or press D.

How to disable all other modules

1. In the Network view, select the module(s) to remain enabled.

2. In the Network view menu, select Modules > Disable All Others.

All modules are disabled except for those selected. This  operation only affects the current level 
layers. It does not affect the nested modules within a group.

Module Thumbnails 
In the Network view, some modules have a thumbnail option, identified by an arrow next to the square 
yellow button. Thumbnails can be very useful when navigating the network to easily identify the 
content of each module or analyze the flow of images and effects.
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How to display a module’s thumbnail

‣ In the Network view, click on the arrow in the module.

The thumbnail opens.

‣ If no thumbnail appears, click the Render View Mode  button in the Camera view 
(bottom toolbar) to generate them.

How to show thumbnails of selected modules

1. In the Network view, select the module(s) whose thumbnails you want to display. 

2. In the Network view menu, select View > Show Selected Thumbnails or press T.

‣ If no thumbnail appears, click the Render View Mode  button in the Camera view 
(bottom toolbar) to generate them.
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How to hide a module’s thumbnail

‣ In the Network view, click the arrow in the module.

The thumbnail closes and the module returns to its closed state.

How to hide thumbnails for the selected modules

1. In the Network view, select the module(s) whose thumbnails you want to hide. 

2. In the Network view menu, select View > Hide Selected Thumbnails or press T. 

How to hide all modules thumbnails

1. In the Network View menu, select View > Hide All Thumbnails.
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Display Concepts

The Display module is an important module.This is the module used by the export and views to display 
your scene, primarily the Camera and Timeline views. By default, a scene's network always has a 
display module. It is also available in the Module Library and can be imported in the Network view to 
be connected to any module that outputs drawing images, such as drawing elements, effects or 
composite modules. 

The Display module can be used to either show your entire scene, a single module or a group of 
module through a composite or group module. You might use it to see one single character as you 
animate it, debug your network as you create complex effects or export your complete scene or a 
portion of it.

This topic is divided as follows:

• Display Modules  below

• Global Display on the next page

• Display All on the next page

• Display Modes  on page 159

Display Modules 
You can have more than one display module in the Network view, allowing you to visualize different 
sections of the scene without disabling or disconnecting elements that could be in the way. This 
technique is useful in cut-out animation as it allows you to see one puppet without viewing all of the 
other characters. It is also useful during compositing and helps you visualize and debug effects.

You can add a display module to the Network view by dragging one from the Module Library view.

To use this display concept, you must first show the Display toolbar. The Display toolbar will show you 
a drop-down list of all display modules available in your Network view. Simply select the desired 
display to update the Camera and Timeline views content.
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Global Display
The Display toolbar let you select the different display modules available in the network. 

When selecting a new display, all the views update to show the content of the new display module. 
The concept of all views following the display selected in the Display toolbar is called Global Display.

How to select a different display module as a global display

‣ Open the Display toolbar drop-down list and select a display from the list.

Each view display is updated.

Display All
When your scene does not have a Display module, it is automatically set to Display All which uses the 
Timeline view ordering and shows floating modules from the Network view. 

You can also set your display to Display All using the Display toolbar.
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If you try to add a peg layer in the Timeline view without having a layer selected, the peg 
layer will be floating in the Network view and will not be visible in the Timeline view.  The 
Timeline view shows only layers that are connected to the Composite module.

If you switch to Display All, you run the risk of not realizing when you have floating 
modules that are not connected to your composite.  For this reason, it is not 
recommended to work in Display All mode.

Show All Modules
When your scene contains many modules and you cannot see them all, you can display all modules at 
that level. 

How to display all modules

‣ From the Network View menu, select View > Show All Modules or press Shift + comma (,).

Display Modes 
Toon Boom Harmony has two display modes. By default, it is set to the Basic Display mode.

When creating a scene in Basic Display mode, a display module is automatically added to the network 
and connected to the final composite module. All of the views are set to used this display module. This 
means that only the elements connected in that composite module will show in the Camera view. 

You can add and connect more display modules to your network and select the one you want using the 
Display menu. In Basic mode, every view is set to the same Display module.

In Advanced Display mode, every view has its own Display menu and each one can be set to a different 
display module. To switch from Basic to Advanced Display mode, you must enable the Advanced 
Display preference. These menus allow you to set the views for different displays. By default, all views 
are set to Default to follow the main Display toolbar selection. However, you may want different views 
set on different displays. For example, you can have one Camera view to display the full scene and 
another Camera view to only display the character being animated. In this case, you can set the first 
Camera view on the final display and the second on the character’s display module.

If you want the views to follow the main Display toolbar selection, set the view display menu to 
Default display.
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How to enable the Advanced Display preference

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS 
X) to open the Preferences dialog box. The Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

2. In the Preferences dialog box, select the Advanced tab. 

3. In the Advanced Options section, select the Advanced Display option.

A Display drop-down menu appears in the top-left corner of the Camera, Timeline, Perspective, 
Top, and Side views.

Timeline View Modes
To streamline the process of working with elements in the Timeline view, there are three different view 
modes you can choose to work in. With each mode you select, certain elements may or may not be 
visible in the Timeline view. Depending on your workflow, this can be useful for quickly hiding elements 
when you want to focus on specific ones. To select a view mode, use the drop-down menu in the 
Timeline view.

 Normal View Mode

Normal View  mode is the default Timeline view mode. It shows everything that is connected to 
the chosen display. While in this mode, anything not connected to the currently set default display 
will not be shown in the Timeline view. This also means that you cannot add certain elements to the 
Timeline view, as by default, when added they are not connected to any display or composite 
module. An example of such an element is a peg.

If you prefer to work as you did before, where you see everything in the Timeline whether it is connected 
to a Display or not, you can change the Always Display Unconnected Modules setting in the Preferences 
dialog box, Timeline tab.

 Selection Only Mode

When working in Selection Only  mode, only elements currently selected in the Camera or 
Network view will be visible in the Timeline. This makes it easier to concentrate on one or a few 
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elements at a time.

View Tagged Modules

The View Tagged Modules   mode lets you see only elements which have been assigned a Tagged 
status. An item that has been tagged will appear in the Timeline view with a small asterisk beside its 
name.

Once your elements are tagged and you have switched over to View Tagged Modules mode, the 
Timeline view will display only tagged elements. The red bar along the far left of the Timeline 
indicates you are in this view mode.

While in View Tagged Modules mode, the asterisks will no longer be displayed beside the tagged 
elements.

How to tag or untag elements in the Camera view

1. In the Camera view, select one or more elements.

2. Right-click and select Tag or Untag.

How to tag or untag elements in the Network or Timeline view

1. In the Network or Timeline view, select one or more elements.
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2. Do one of the following:

‣ Right-click on the selection and select Tag and one of the following: 

‣ Timeline Tag

‣ Timeline Untag

‣ Timeline Untag All

‣ Timeline Untag All Others

‣ In the Timeline view or Network view menu, select Edit > Tag and one of the following: 

‣ Timeline Tag

‣ Timeline Untag

‣ Timeline Untag All

‣ Timeline Untag All Others
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Creating a Multiplane

One of the most exciting features in Harmony is the multiplane or Z-depth. In the multiplane, you can 
create backgrounds in several layers, spread them on the Z-axis to add depth, and then move the 
camera through this environment to create an impressive perspective illusion.

Setting Up the Multiplane
To construct a multiplane, you must imagine what a real environment is like. Take a look at your 
background picture and imagine a camera moving through the space. Notice that objects in the 
picture move at different speeds depending on where they are in relation to the camera lens.

Building a multiplane requires an understanding of the scene's background, as well as the positioning 
of the elements on different layers.
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For example, in the background illustrated above, the main objects to be separated are:

1. Fern

2. Front tower

3. Second tower

4. Moon

5. Stars

6. Sky

Although the bottom of the tower is hidden behind the plant and the ladder, each of the multiplane 
layers should be a complete drawing. This is because hidden portions may show up during a camera 
move later on in the scene.

Distributing Elements on the Z-axis
Now is the time to distribute the layers that comprise your multiplane along the Z-axis. You can 
position layers on the Z-axis using the Side and Top view. 

Positioning your element closer to the camera makes them appear bigger. You can also move element 
towards the camera or away from the camera while keeping the same size aspect ratio in the Camera 
view.

It is a good idea to keep a Camera view open to see what your scene looks like while positioning 
elements in the Top or Side view—see Top View on page 167, Side View on page 169 and Perspective 
View on page 170.
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Positioning Elements in the Top and Side Views

Before distributing layers along the Z-axis using the Top and Side views, deselect the No Z Dragging 
option by selecting Animation > No Z Dragging. This option is disabled by default.

How to position an element in the Top and Side views

1. To maintain the visual scale in the Camera view as you move your element, in the Advanced 
Animation toolbar, select the Maintain Size  tool or press Alt + 6.

2. In the Side view, select one of the layers in the thumbnails section of the Top or Side view. You can 
also select a layer from the Timeline view.

The selected layer is highlighted in the Top, Side and Camera views.

3. Drag the layer to the correct depth position in the camera cone. Your element aspect will remain 
the same in the Camera view.

4. For your element to scale up or down in relation to their distance to the camera, do one of the 
following:
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‣ In the Tools toolbar, select the Transform  tool. Make sure the Peg Selection Mode  
option is disabled in the Tool Properties view.

‣ In the Advanced Animation toolbar, select the Translate  tool and select a layer from the 
thumbnails section of the Top or Side view.

‣ Select a layer from the Timeline view.

The selected layer is highlighted in the camera cone.

5. In the Top  view, drag the element sideways to position it horizontally . Hold Shift while dragging 
the element to make sure it only moves along the X-axis.

6. In the Side view, drag the selected element up or down to position it vertically. Hold Shift while 
dragging the element to make sure it only moves along the Y-axis.

Cumulative Z Value
You can see the cumulative Z value information in the Coordinates and Control Points view. When you 
select a drawing cell that includes a keyframe, it will display the cumulative Z value.

When a layer is parented to other layers that are moved forward or backward on the Z-axis, the 
currently selected layer's position Z value may not be accurate since its parent will also have an offset 
on the Z-axis. The Cumulative Z value is a compilation of all the Z-axis offsets to give the real Z-axis 
offset value related to the (0,0) centre.
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Top View
The Top view is used mainly for multiplane scenes and to position elements in 3D Space. It allows you 
to see the scene’s stage  from above. This lets the camera cone and the spacing between the elements 
to be seen.
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1. A thumbnail of each drawing layer in the scene. The order of the thumbnail images is based on each 
element’s FB position in the scene space. You can see a representation of the FB position of each 
layer in the camera cone.

2. The camera cone represents the camera’s position and field-of-view (FOV). 

3. The axis reference arrows let you maintain your orientation when navigating in the Perspective view.

4. There are two view option buttons displayed in the lower-left corner of the view.

‣ Show/Hide Camera: Shows or hides the camera frame in the Perspective view. 

‣ Reset View: Resets the pan, rotation and zoom of the Perspective view.

5. This field displays the current zoom level in the Perspective view. You can use the Zoom menu to 
select a zoom level from 2.5% to 6400%. You can also select Fit To View to automatically use a zoom 
level that lets you see all of the scene layers and information in the Perspective view at once.

6. Displays the currently selected layer and drawing name.

7. Displays the currently selected tool.

8. Displays the currently selected frame of your animation.
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9. Displays the currently selected colour in the palette.

Side View
The Side view is used mainly for multiplane scenes and to position elements in 3D Space. It allows you 
to see a scene’s stage  from  the side. This lets the camera cone and spacing between the elements to 
be seen.

1. A thumbnail of each drawing layer in the scene. The order of the thumbnail images is based on each 
element’s FB position in the scene space. You can see a representation of the FB position of each 
layer in the camera cone.

2. The camera cone represents the camera’s position and field-of-view (FOV). 

3. The axis reference arrows let you maintain your orientation when navigating in the Perspective view.

4. There are two view option buttons displayed in the lower-left corner of the view.

‣ Show/Hide Camera: Shows or hides the camera frame in the Perspective view. 

‣ Reset View: Resets the pan, rotation and zoom of the Perspective view.

5. This field displays the current zoom level in the Perspective view. You can use the Zoom menu to 
select a zoom level from 2.5% to 6400%. You can also select Fit To View to automatically use a zoom 
level that lets you see all of the scene layers and information in the Perspective view at once.
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6. Displays the currently selected layer and drawing name.

7. Displays the currently selected tool.

8. Displays the currently selected frame of your animation.

9. Displays the currently selected colour in the palette.

Perspective View
The Perspective view is used during scene setup. It allows you to see a multiplane scene’s orientation. 
The Perspective view is similar to a 3D display, as it lets you rotate the scene through all possible 
angles to understand the spacing between the elements. You can also position and rotate your layers 
and the camera inside the 3D display to achieve some 3D setup and camera moves.

1. The red circle rotates the view on its X axis.

2. The green circle rotates the view on its Y axis.

3. The blue circle rotates the view on its Z axis.
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4. This is a perspective grid reference.

5. The axis reference arrows let you maintain your orientation when navigating in the Perspective view.

6. There are three view option buttons displayed in the lower-left corner of the view.

‣ Show/Hide Camera: Shows or hides camera frame in the Perspective view. 

‣ Reset View: Resets the pan, rotation, and zoom of the Perspective view.

‣ Reset Rotation: Resets the rotation of the Perspective view.

7. This field displays the current zoom level in the Perspective view. You can use the Zoom level drop-
down menu to select a specific zoom level from the list. Zoom levels from 2.5% to 6400% are 
available; you can also select Fit To View to automatically use a zoom level that lets you see all your 
scene layers and information in the Perspective view at once.

8. This field displays the currently selected layer and drawing name.

9. This field displays the currently selected tool.

10. This field displays the currently selected frame of your animation.

11. This field displays the currently selected colour in the palette.

How to rotate a scene in the Perspective view

1. In the Tools toolbar, select the Rotate View   tool.

‣ Click in the view, and drag the cursor around to rotate the view.

‣ Press and hold Ctrl + Alt (Windows/Linux) or ⌘  + Alt (Mac OS X) and click and drag to 
rotate the view one axis at a time. 
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Orthographic Camera

The orthographic camera is specific to the gaming pipeline. It changes the camera type from 
perspective to orthographic. It becomes a camera without vanishing points. This means there is no 
more perspective in the Camera view. Objects, when moved on the Z-axis, will not change in size or 
scale.

Refer to the Gaming Guide to learn more about orthographic cameras and exporting animation for 
interactive games.

The orthographic camera can be set in the Scene Settings dialog box. In order  to create scenes with 
the orthographic camera, by default, you need to create a new custom scene resolution. Refer to the 
Fundamentals Guide to learn about custom resolutions.

How to set an orthographic camera

1. From the top menu, select Scene > Scene Settings.

2. Select the Resolution tab. 

3. In the Projection section, select Orthographic option.
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Chapter 3: 3D Space

Harmony is well known for its multiplane space where you can move your layers forward and backward 
on the Z-axis. Harmony brings you a true three-dimensional space where you can actually rotate your 
camera and layers on all axes. This lets you perform a 360 degree rotation around elements, create a 
floor and even build sets! 

If you are using 3D effects in your animation, do not render your project as a SWF as these effects are not 
supported by that format.

This chapter contains the following topics:

• Enabling the 3D Option on the next page

• 3D Tools on page 180

• Positioning Elements in 3D Space on page 184

• 3D Camera Motion on page 192
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Enabling the 3D Option

Before you can rotate layers in three axes instead of two, you must enable the 3D option in the layer 
properties. By default, when you create layers in Harmony, you can only move them as flat layers.    

How to enable the 3D option

1. In the Timeline view, select the layer you want to move in 3D space.

2. Double-click on the selected layer to open its Layer Properties dialog box.

3. Select the Transformation tab.

4. Select the Enable 3D option to display the 3D parameters for that layer.

5. Click Close.
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New parameters appear in the Layer Properties window.

3D Parameters
When working in 3D, notice that three sets of parameters are modified:
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• Scale below

• Rotation on the facing page

• Pivot on page 179

Scale

When using 3D, the Z-axis parameter appears in the list of settings. You can have the Scale locked or 
separated. When the Scale is locked, the object you are scaling is uniformly resized in three directions. 
When the Scale is separated, the object you are scaling can be squashed and stretched in any direction 
without affecting the other ones.

You cannot add thickness to an object by scaling it in the third dimension. Three-dimensional scaling is used 
to scale objects that were rotated on their axes or to scale a group of objects laid out in three dimensions.
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Rotation

The main parameter you will use when working in three-dimensions is rotation. Without using 3D 
rotation, you are simply working using the multiplane technique.

3D rotation can be used in two different ways:
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• Quaternion Rotation below

• Euler Angles Rotation below

Quaternion Rotation

Quaternion Rotation is very similar to the 3D path position parameters. A Quaternion is composed of 
three rotation functions: X, Y and Z to control the rotation on three axes, and a velocity function to 
control the velocity of the three rotation functions simultaneously. 

The X, Y and Z functions are linked. When you add a keyframe on one of them, it also adds it to the 
two others.

If you are planning to animate an element such as the camera, you should use the Quaternion rotation 
rather than Euler Angles. Quaternion creates a smooth trajectory and interpolation since the path is 
controlled by the same keyframes and a single velocity.

Euler Angles Rotation

The Euler Angles Rotation is very similar to the Separate position parameters. The Euler Angles 
parameter is composed of three functions: X, Y and Z to control the rotation on three axes. These 
three functions are independent of each other; each has its own velocity.

When you add a keyframe on one function, the other ones do not receive it, allowing you to control 
each axis independently.

Euler Angles are mainly used to position elements with exact coordinates and rotate elements on a 
single axis. The interpolation between the keyframes will not be as smooth as the Quaternion one 
since each function works individually.
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Pivot

When working in 3D, the drawing or layer pivot becomes a location that can move on three axes. 
When you work in two dimensions, the pivot is mainly an anchor point somewhere in the drawing from 
where the transformations will be performed. In 3D, the transformations are made on three axes, so 
the centre of rotation and scaling also becomes three-dimensional.

By default, the pivot is positioned at the centre of the stage: (0,0,0). When you use the Pivot  tool 
to reposition the centre of transformation, the pivot position is changed on the X and Y axes, but the 
Z-axis remains at zero until you change it in the Top, Side or Perspective view using the transformation 
tools.
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3D Tools

Once the 3D option is enabled, your transformation tools become 3D transformation tools. These 
tools are found in the Advanced Animation toolbar as well as the Transform  tool. Instead of 
letting you move elements only on the X and Y axes, you can also manipulate them on the Z-axis.

3D Translate Tool
Once you enable the 3D option, the 3D Translate  tool becomes available and you will see 
direction arrows appear around the pivot points to indicate the different axes.

You can click on the direction arrows to move your layer on only one axis. If you click anywhere else, 
the layer can move freely on two axes at once. Once the arrow is selected, it will turn pink.

If you move the layers in the Perspective view, it may be difficult to control the motion since you may not 
have the optimum point of view on your stage to understand the setup. In this case, it is best to use the 
direction arrows.
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3D Rotate Tool
Once you enable the 3D option, the 3D Rotate  tool becomes available and you will see a rotation 
sphere appear around the pivot points indicating the different axes.

You can click on the direction ellipses to rotate your layer on one axis only. If you click anywhere else, 
the layer rotates freely on two axes at once. Once the ellipse is selected, it will turn pink.

If you move the layers in the Perspective view, it may be difficult to control the motion since you may not 
have the optimum point of view on your stage to understand the setup. In this case, it is best to use the 
direction ellipses.

3D Scale Tool
Once you enable the 3D option, the 3D Scale  tool is available. You will see one of two things:

181



Chapter 3: 3D Space     3D Tools

• A scaling rectangle appears if your drawing is flat.

• A scaling cube appears if your object has some rotated layers around the pivot points, indicating 
the different axes.

Click on one of the three control points to scale the shape on one axis. Hold down the Shift key to 
scale the object proportionally. Once the control point is selected, it will turn pink.

If you move the layers in the Perspective view, it may be difficult to control the motion since you may not 
have the optimum point of view on your stage to understand the setup.

3D Transform Tool

Once you enable the 3D option, the 3D Transform tool become available. This tool is a combination of 
the 3D Translate, 3D Rotate and 3D Scale tools.

To translate an element, grab the direction arrows in the same way that you would with the Translate 
tool.
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To rotate an element, grab the rotation ellipses in the same way that you would with the Rotate tool.

To scale an element, grab the scaling control points in the same way that you would with the Scale  
tool.
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Positioning Elements in 3D Space

To position elements in 3D space, you need to understand what you want to build and what is involved 
in building it.

Simple sets like the above one are easy to build, light to manage and probably what you will use 3D 
staging for most often.

If you have a project based on a room, it can be useful to build it in 3D. This saves you from having to 
redraw the background for each scene and it will be entirely vector based.

Here, you can see some of the different backgrounds you can get in only three seconds from this set.
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Planning Your Pieces
When you are building a room, there are only a few pieces to prepare. Before starting to build your 
set, map out the parts you need.

A complex set that is more intricate in its design will require more careful planning. Not only will you 
have to list the pieces you need, but you will also have to think about what can be reused. If you have a 
series of windows in your set, you would create a symbol from the drawing, rather than copy paste it 
several times all over your set. This way, if you need to make any correction to its design, you will only 
need to do it once and all the instances of your symbol throughout your set will be corrected. The 
same can be done with for each piece of your set.

Here is an example of all the source drawings required to build the castle. 
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These are the only drawings required to build the entire castle. As you can see, there are not that 
many considering the final result. The rest is constructed by assembling symbols and through reuse. 
However, keep in mind that although you are using simple drawings and symbols to optimize your set, 
the more you add to your project, the heavier the toll it takes on your machine's RAM. While the 
scene's package itself is really light, running the scene places heavy demands on your RAM and video 
card.

Using the drawings shown previously, here are a couple of pieces that were put together.

Here is the final result. A large and impressive fortress.
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Using Complex Sets in Production Scenes

When your main set is built, you will want to store it in the Library. It is important to know that when 
you import such a large structure in one of your production scenes, the set may be slow to run. To 
avoid long rendering sessions or slow manipulation, remove all faces and planes that are not visible in 
your scene.
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Positioning the Layers
Once your drawings and symbols are assembled, it is time to position them. This section explains how 
this is done using the example of a simple room.

To position your layers, the following elements are required:

• Camera view

• Top view

• Side view

• Perspective view

• Library view

• Timeline view

• 3D Transformation tools

• Layer Properties view or dialog box

How to position layers in 3D space

1. In the Timeline view, double-click on the new layer to open the Layer Properties dialog box.
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2. In the Transformation tab, select the Enable 3D option.

3. In the Rotation section, select the Euler Angles option.

4. In the (x) Axis field, type 90 to flip the floor so it is flat on the ground.

5. To position the height of the floor, type values in the Position section of the Layer Properties, use 
the 3D Translate  tool or 3D Transform  tool.

6. Repeat the process for the other pieces to import.

7. If you have parallel walls, once you have positioned one, select the Wall layer in the Timeline view.

8. From the top menu, select Edit > Duplicate to duplicate the layer. 

If the drawing is contained within a symbol, the symbol will not be duplicated, only the layer containing the 
symbol. This way, you are still using the same drawing.
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9. Once the layer is duplicated, use the Layer Properties window to enter the positioning values or 
use the 3D transformation tools.

10.When using the transformation tools, use the Camera, Top, or Side view to position the elements 
instead of the Perspective view to position your layers precisely.

11. If your walls are touching each other, you should make them intersect by extending one end of the 
wall through the other wall. This prevents seeing a small gap between them.

Now have a complete 3D room.
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3D Camera Motion

Once you have a 3D set, the exciting part is to do a camera move in it. This section teaches you the 
main steps required to perform a 3D camera move. Once you know how to do this, you can enjoy the 
delights of working in 3D space and travelling through your creations!

How to create a 3D camera move

1. In the Tools toolbar, enable the Animate  mode.

2. In the Timeline view, click the Add Layers  button and select Camera to add a camera to your 
scene.

3. In the Timeline view, select the new camera layer.

4. In the Timeline Layer toolbar, click the Add Peg  button to add a parent peg to the camera.

5. In the Timeline view, double-click on the new peg layer to open the Layer Properties dialog box.

6. In the Layer Properties dialog box, go to the Transformation tab and select the Enable 3D option.

7. In the Rotation section, select the Quaternion option.

8. In the Perspective view, click the Show/Hide Camera button to see your camera cone.

9. Setup your workspace to display the Camera view and Perspective view at the same time so you 
can compare the results.

10. In the Tools toolbar, select the Transform  tool.

11.In the Timeline view, select the Camera-Peg layer first frame and select Insert > Keyframe.
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12.In the Timeline view, select the Camera-Peg layer.

13.In the Timeline view, go to the last frame.

14.In the Perspective view, grab one of the rotation ellipses and rotate the camera on one axis only. 
Always do one axis at a time to keep control of the positioning.

15.Once the camera is rotated at the correct angle, grab one of the direction arrows to move the 
camera to the correct position.
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Camera Clipping Planes
You can change the near and far clipping planes of the camera. The near plane is the point on the 
camera cone where the camera is located. The far clipping plane is the far end of the camera cone. 
Nothing outside that range is visible. This is useful when dealing with 3D elements and 3D sets.  For 
example, the camera can be looking inside a 3D box or room and you might want the foreground wall 
to not obstruct the view of the interior. By default, the near clipping plane is set to 1 field and the far 
clipping plane is set to 1000 fields.

How to modify the camera clipping plane

1. In the Timeline or Network view, select the Camera module.

2. In the Layer Properties view, go to the Clipping Planes section.
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3. Modify the value of the Near Plane to pull or push the clipping area closer to the camera. Anything 
behind this plane will no longer be visible.

4. Modify the value of the Far Plane to pull or push the clipping area closer to the camera. Anything 
beyond this plane will no longer be visible.

Playing Back Your 3D Camera Moves

If you want to view your 3D camera move, you must be in the Perspective view.

How to enable the playback mode in 3D

1. From the top menu, select Play > Enable Playback > Perspective View.

2. In the Playback toolbar, click the Play button to see the results.

Locking Flat Drawings to the Camera Angle

When you create a 3D camera move in your scene, notice that layers are treated as flat objects. That 
is, animation layers that are supposed to face the camera at all times will look like a flat sheet of 
rotating paper. Use the Ortholock layer when mixing flat animation layers with a set built in 3D. 
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Ortholock forces your drawing layer to always follow the Camera angle. It does not follow its position 
or zooming level, only the rotation. This prevents drawings from being distorted by the camera 
motion.

Adding an Ortholock layer in a symbol will not give the correct result. The Ortholock contained inside a 
symbol does not consider the position of the camera contained in the root scene. Keep your Ortholock 
layers in the root scene.

How to add an Ortholock layer

1. In the Module Library view, select the Move tab.

2. Select the Ortholock module and drag it to the Network view.

3. In the Network view, drag an output cable from the Ortholock module and connect it to the module 
you want to keep facing the camera.
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Managing a Network with a 3D Scene Setup

In Harmony, you can create very advanced networks using effects, complex connections and multiple-
level compositing.

The Composite module's main task takes all of your image's output and converts it into a single flat 
image that you can render out. You can alter it further by manipulating a three-dimensional scene 
setup. You can also modify a Composite's behaviour as seen in the Scene Setup on page 85 chapter. 

Input and Output Options

The default options combination is:

• As Bitmap, for the output behaviour

• 3D flat, for the input ordering

By default, a Composite module is set to output a flat bitmap image and to correctly composite 
elements positioned in 3D space.
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For example, if you have two intersecting walls, and use the default combination, you will see the 
following result:

This image is correctly represented in the Camera view and is output from the Composite module as a 
flat drawing. The Z-axis value of your elements are not retained, it becomes an independent 
composition with only one forward-backward value.

When building a 3D set out of planes, it is recommended that you set the composite mode to As 
Seamless Bitmap. This avoids intersection issues when rendering the 3D objects created out of 
planes.

3D Input Ordering Option

The visual result for the 3D Input Ordering option is the same as the 3D Flat option. The visual result in 
the Camera view will be correct, but the elements will not be converted into a flat image. The 3D 
position of your images will be remembered until the next Composite module. This mode is quite 
advanced and should only be used in very advanced cases. Most of the time you will use the 3D Flat 
Input ordering option.

2D Input Ordering Option

If you switch the Input Ordering option to 2D, the walls will be calculated as flat 2D objects and not as 
3D objects. The perspective caused by the 3D rotation will be correctly represented, but the elements 
will not intersect. The result will be similar to the following:
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How to Organize Your 3D Composite Modules
If you start combining several composite modules in your Network view, it is important to understand 
how they work if you want to get the desired result.

There is a specific order in which you should set your Composite modules. Each time you process 
images through a 3D Flat Composite module, the images will be merged together. Images processed 
in later Composite modules cannot be inserted between images of the previous composite since it is a 
flat image.

If you used Pass-Through type Composite modules in your network, the images will not be processed 
together before the final Composite. It is important to keep your final Composite as a 3D Flat 
Composite in order to read the layer ordering correctly.

The most efficient networking system for obtaining the desired result is likely  the Pass-Through 
composite mode throughout the whole network. This way, you can create individual compositions to 
keep your network clean and organized, but process everything together at the end.
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When building a 3D set out of planes, it is recommended that you set the composite mode to As Seamless 
Bitmap. This avoids intersection issues when rendering the 3D objects created out of planes.
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Chapter 4: Animation Paths

With Harmony, you can animate layers using computer-generated trajectories, create multiplane 
camera moves and camera shakes, adjust the easing, shape your paths with control points and much 
more.

This chapter contains the following topics:

• Animating a Layer on the next page

• Differences between Pegs and Animated Layers on page 204

• Layer Parameters on page 211

• Adding and Deleting Keyframes on page 214

• Motion and Stop-motion Keyframes on page 216

• Animating the Camera on page 221

• Modifying a Path in the Camera, Top and Side Views on page 228

• Modifying a Path in the Timeline View on page 236

• Modifying a Path in the Function View on page 239

• Modifying a Path in the Xsheet View on page 246

• Function Curves on page 248

• Copying and Pasting a Motion on page 255

• Adjusting the Ease on page 265

• Expression Columns on page 271
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Animating a Layer

Before animating the position of drawing layers, you need to create motion paths which are 
trajectories on which you can attach drawing objects. Using keyframes, you can then record key 
positions along the trajectory. 

Harmony’s wide range of features let you produce simple and advanced motions and trajectories. By 
creating a simple motion, you will learn the basics animating a layer.

The Animate mode lets you keyframe drawing layers to create computer-generated animation. When 
the Animate mode is enabled, you can animate a layer's position and disable it to reposition a layer for 
the entire scene. In this mode, keyframes are created on selected layers at the current frame. 
Depending on what transformations were performed (rotation, translation, skew, etc.), the new 
keyframes are added on the corresponding parameters (function curves).

How to turn the Animate mode on or off

1. In the Tools toolbar, click the Animate  button or select Animation > Animate.

How to animate a layer

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

2. In the Tool Properties view, make sure that the Peg Selection Mode  is deselected.

3. In the Tools toolbar, enable the Animate  mode. This will create keyframes at the current frame 
when moving objects.

4. In the Timeline view, go to the first frame.

5. In the Camera view, select the element to animate and move it to its first position.

A keyframe is created on the first frame of the Timeline view.

6. In the Timeline view, go to the frame on which you want to set the second position.
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7. In the Camera view, move the element to its second position.

A second keyframe is created on the Timeline view.

8. Play back  your animation.

To see your motion animations in the Top, Side or Perspective views while you play back, you must 
turn on the Playback option. From the top menu, select Play > Enable Playback > Top View or 
Side View or Perspective View.
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Differences between Pegs and Animated Layers

There are two ways to create motion paths: animated drawing layers and pegs. They each have 
different purposes. 

You can create a motion path directly on layers (animated layers). 

You can control and define a trajectory using several different parameters, including:

• X, Y and Z positions (3D Path or Separate Positions)

• Angle (rotation)

• Skew

• X and Y Scales

• Euler Angle or Quaternion Angle (when 3D option is enabled)

• Z Scale (when 3D option is enabled)

Each parameter has its own function curve where you can add keyframes and control the easing. 

If you are not familiar with graphs and function curves, Harmony has a series of easy-to-use tools for 
visually controlling trajectories in the Camera and Timeline view.
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By default, a drawing layer can be animated using the same parameters as a peg, but you can disable 
this feature. Being able to switch your drawing layers so they can no longer be animated without a peg 
has certain advantages. In cut-out animation, it is easier to separate drawing exposure and keyframes 
to change the timing easier and rearrange keyframe position in the Timeline view. This also works for 
backward compatibility when bringing in templates created in older versions of the software, so as 
not to lose their offset keyframes or drawing substitution keyframes.

If you do not want to animate a drawing layer, you have the option of disabling its animation 
parameter. To do so, simply select the layer and in the Layer Properties view, deselect the Animate 
Using Animation Tools option on the Controls tab.

If your layer was already animated and you deselect the Animate Using Animation Tools option, your 
keyframes will be dimmed, enabling you  to easily  identify them as ones that cannot be modified. Select 
the Animate Using Animation Tools option in order  to modify them again.

A Peg layer is a trajectory that contains no drawings on which you can hook your drawings.

Pegs have been used for a long time in the traditional animation process, mainly for registration 
purposes. Peg holes at the bottom or top of the animation paper are used to keep all the sheets even 
and at the same registration.

There are three peg holes in regular animation paper. The centre peg hole is round while the left and 
right ones are oval shaped. The oval peg holes are located on each side of the page, four inches away 
from the centre peg hole.
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To keep the drawings together, the animator uses a peg bar. This peg bar has three pins that 
correspond to the shape and location of the peg holes. Peg bars are normally found at the bottom 
and top of animation discs.

Before digital compositing, the peg bars were also used to move layers on the camera stand to create 
pans and camera moves. They were the equivalent of digital trajectories. Harmony makes use of these 
concepts to create animation and camera motion. 

A peg is composed of many customizable parameters. These parameters are:

• X, Y and Z positions (3D Path or Separate Positions)

• Angle (rotation)

• Skew

• X and Y Scales

• Euler Angle or Quaternion Angle (when 3D option is enabled)

• Z Scale (when 3D option is enabled)

You can control a peg’s trajectory the same way as the animated drawing layer.

A peg layer is mainly used to control a series of drawing layers, such as clouds, a school of fish or a 
flock of birds. You can attach them to a peg layer and make them follow a trajectory as a single unit. 
This makes trajectory modifications much easier and faster. When building a puppet, most of the time 
you will add a master peg to control your puppet as one object.

In Harmony, you can add pegs to the Network view using the Module Library view and they will 
instantly appear in the Timeline view. The modules you add to the Network view are synchronized with 
the ones in the Timeline view.

You can automatically create connections between modules in the Network view without having to 
drag cables out of the ports.

In the Tool Properties view, the Peg Selection Mode  lets you automatically select the peg layers in 
the Camera view instead of the drawing layers. If you animate with pegs instead of animating the 
drawing layers directly, enable the Peg Selection Mode to avoid having to select in the Timeline view 
or use the Select Parent Skipping Effects command.
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How to disable the animation feature on a layer

1. In the Timeline view, double-click the layer on which you want to set the parameter.

The Layer Properties editor opens.

2. In the Advanced tab, deselect the Animate Using Animation Tools option.

How to add a peg in the Timeline view

1. In the Timeline view, select the layer on which you want to attach a peg.

2. Do one of the following: 

‣ From the Timeline View layers toolbar, click the Add Peg  button.

‣ From the top menu, select Insert > Peg.

‣ Right-click on the layer and select Add > Peg.

‣ In the Module Library, select a Peg module  and drag it to the Network view.

The layer that was originally selected becomes a child of the new parent Peg layer. The new Peg 
layer automatically takes the name of its child layer, with the addition of the suffix -P.

3. If you intend to add multiple pegs or if the layer name that was added to the peg does not 
accurately represent the content of the Peg layer, you can rename it. Clicking the layer name and 
type in a new name. Or double-click the layer and type a new name into the dialog box.

4. If you did not create your peg layer directly above the layer you intended on parenting it to, then 
drag the layer you want to attach to the peg and drop it directly below the Peg layer. The 
indentation of the layer below the Peg layer indicates whether it was correctly attached or not.

How to add a peg in your Network view via the Module Library

1. In the Module Library view, select the Move tab.
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2. Select a Peg module and drag it to the Network view.

3. In the Network view, select the Peg module's output port and connect it to a Drawing or Camera 
module.

The advanced connections in the Network view are shown in the Timeline view, unless they cannot 
be reproduced in a timeline layout.

How to add a peg to the Network view using a keyboard shortcut

1. In the Network view, position the pointer at the location at which  you want to add the new peg 
module.

2. Press Ctrl + P (Windows/Linux) or ⌘  + P (Mac OS X).
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The new peg appears in the Network view.

How to create an automatic connection to a parent peg

‣ In the Network view, select one or more drawing modules that are not parented to any 
other module.

‣ Press Ctrl + P (Windows/Linux) or ⌘  + P (Mac OS X) to add a new peg module to the 
Network view and automatically connect it to the selected modules.

‣ Press Ctrl + Shift + P (Windows/Linux) or ⌘  + Shift + P (Mac OS X) to add a peg to each 
module.

How to enable the Peg Selection Mode

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

2. In the Tool Properties view, click the Peg Selection Mode  button.

3. In the Camera view, select an element parented to a peg.
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Layer Parameters

A layer is composed of many customizable parameters, such as the X, Y and Z positions, angle 
(rotation), skew and scales. Each parameter has its own function which is a mathematical formula 
expressing the relationship between position values. You can view each function on a graph as a 
simple curve, such as the one below.

There are six options available for setting up function parameters:

‣ Locked Positions (3D Path)

‣ Separate Positions

‣ Locked Scales

‣ Separate Scales

‣ Quaternion (3D Rotation)

‣ Euler Angles (3D Rotation)

You must select 3D Path, Separate Positions, Separate Scale, or Locked Scale before starting the 
animation. When you lock or unlock parameters, this does not convert the functions from one to the 
other, but creates new ones.
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In a 3D Path, the X, Y and Z curves are locked together and controlled by a single velocity function. 
When you add a keyframe, it is added on all three trajectories at once, as is the velocity. This is very 
useful for long, smooth trajectories.

When the Separate Positions option is used, the X, Y and Z curves are independent and have velocity 
controls directly on their function curve. This is useful when you want to set keyframes on one of the 
curves without affecting the others.

When using the Scale parameter, you can use a single function curve controlling both the vertical and 
horizontal scale, or two separate scales. When using a single function curve, the values are the same 
for the X (horizontal) and Y (vertical) axes for uniform size changes without distortion. However, if you 
separate the scale functions, you can squash, stretch and skew your elements.

How to display the Layer parameters in the Timeline view

1. Do one of the following:

‣ In the Timeline’s left side, click a layer's Expand  button or press Alt + F. 

‣ In the Timeline view menu, select View > Show Functions.
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How to set the layer parameters

1. In the Timeline view, double-click on the layer on which you want to set the parameter. You can also 
see the parameters in the Layer Properties view when you select the layer in the Timeline view.

The Layer Properties editor opens.

2. Select the Transformation tab.

3. In the Position section, select the 3D Path or Separate option.

4. In the Scale section, select the Locked or Separate option.

5. Click Close.
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Adding and Deleting Keyframes

There are several different ways you can create keyframes. You can add a coordinate keyframe, 
position keyframe or a keyframe along with your drawing duplication.

You can create a keyframe without a drawing. This adds new coordinate points but the drawing in the 
layer stays the same. At the same time, you may also want to duplicate your drawing if you need to 
modify it and do not want to modify the original.

You can also add a Position keyframe instead of a regular keyframe. When you add a Position 
keyframe, keyframes will only be added on the X, Y and Z parameters of the selected layer. Keyframes 
are not added on the Angle, Scale and Skew parameters.

If you select a keyframe in the Timeline view and press the Delete key, you will also delete the drawing 
exposure. To only delete the keyframe, you must use the Delete Keyframe command.

How to create keyframes

1. In the Timeline view, select the cell on which you want to add a keyframe.

2. Add a keyframe  by doing one of the following:

‣ From the top menu, select Insert > Keyframe.

‣ Right-click  on the selection and select Insert Keyframe.

‣ Press F6.

‣ In the Timeline View toolbar, click the Add Keyframe  button.

If the Animate mode is enabled in the Camera view,  a keyframe is automatically created on the 
current frame.

How to create a keyframe and duplicate the drawing at the same time

1. In the Timeline view, select the cell containing the drawing where you want to add a keyframe and 
duplicate.

2. To add a keyframe and duplicate, do one of the following:

‣ From the top menu, select Insert > Keyframe and Duplicate Drawing.

‣ Right-click on the selection and select Insert Keyframe and Duplicate Drawing.

‣ Press F6.
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How to add a Position keyframe

1. In the Timeline view, select the cell where you want to add a position keyframe.

2. In the top menu, select Insert > Position Keyframe.

How to delete a keyframe

1. Do one of the following:

‣ Use the Transform  tool to select a keyframe to delete from the trajectory in the Camera 
view and press Delete.

‣ In the Timeline view, select a keyframe, right-click and select Delete Keyframes, or press 
F7. 

‣ In the Timeline view, select a keyframe and in the Timeline view menu, select Motion > 
Delete Keyframes.

‣ In the Timeline view, select a keyframe, and from the top menu, select Animation > Delete 
Keyframe.
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Motion and Stop-motion Keyframes

Interpolation is the computer-generated motion between two keyframes. Some animators and 
compositors like to create their own in-betweens, while others like to have the computer do it. 
Harmony has stop-motion (no interpolation) and motion keyframes (computer-generated 
interpolation).

A stop-motion keyframe means there is no computer-generated motion between two keyframes. The 
segment is constant or flat. The drawing remains still until the playback reaches the next keyframe, 
then the drawing pops to its new location.

A motion keyframe means that there is computer-generated motion between two keyframes. The 
segment has a variation over time. The drawing progressively moves towards the next keyframe 
location as the animation is played back.

You can switch a keyframe from stop-motion to motion at any time in the Timeline view and Function 
Editor.

In the Preferences dialog box, you can set a different colour for your stop-motion keyframes in order 
to create a greater visual difference in the Timeline view.
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How to switch between motion and stop-motion in the Timeline view

1. On the right side of the Timeline, select one or more keyframes to modify.

2. Switch between motion and stop-motion by doing one of the following:

‣ Right-click on the selected keyframes and select Set Motion Keyframes or Set Stop-
Motion Keyframes.

‣ Press Ctrl + K (Windows/Linux) or ⌘  + K (Mac OS X) for motion keyframes and Ctrl + L 
(Windows/Linux) or ⌘  + L (Mac OS X) for stop-motion keyframes.

‣ In the Timeline View toolbar, click the Motion Keyframe  or Stop-Motion Keyframe  
button.

How to switch between motion and stop-motion in Coordinates and Control Point 
view

1. Using the Transform tool, in the visible path in the Camera view or Timeline view, select the 
keyframe to convert.

2. In the Coordinates and Control Point view, select/deselect the Stop-Motion Keyframe option.

How to switch between motion and stop-motion keyframes in the Function Editor

1. Open the Function Editor.

2. In the Timeline view, double-click on the layer that contains the keyframes you want to convert.

The Layer Properties dialog box opens.
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3. Do one of the following:

‣ In the Transformation tab, click the Function Editor  button.

‣ In the Timeline view, click the Expand Function  button and double-click on the function 
to edit. Or press Alt + F.

4. On the function curve, select one or more keyframes to modify.

218



Harmony 11.1 Compositing Guide (Network)

5. Select or deselect the Stop-motion Keyframe  button to set a stop-motion or motion keyframe.

How to set the stop-motion keyframe colour

1. Open the Preferences dialog box by pressing Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

2. Select the General tab. 

3. In the Colours section, click Edit Colours.

4. In the Colours dialog box, select the Xsheet and Timeline tab.

5. In the Timeline section, click the  Stop Motion Keyframe swatch.

6. In the Select Colour window, select a new colour.

7. Click OK to close the Select Colour window.

8. Click OK to close the Colours dialog box.

9. Click OK to  close the Preferences dialog box.
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Constant Z
When using a 3D path, the X, Y and Z functions are working together using the same keyframes. This 
allows for the velocity to control the curve and create a smooth trajectory. Even if a function does not 
have any variation on its curve (for example, all keyframes are at zero), the velocity might add a slight 
motion to ensure a smooth trajectory. This can cause elements that are very close to each other on the 
Z-axis to pop in front of one another. This is why in cut-out animation it is recommended to use 
separate position settings. But if you work with 3D path, you can enable the Constant Z feature to 
avoid this from happening.

The Constant Z feature is used when creating motion keyframes. The Z function will use stop-motion 
keyframes and will not be interpolated, which can be very useful for cut-out animation. The Constant Z 
feature only works with 3D paths.

You can also enable the Constant Z option directly in the Function Editor for specific functions.

How to enable the Constant Z option

1. In the Timeline view, expand the layer on which you want to set the Constant Z feature. Note that 
the 3D Path option must be enabled for that particular layer.

2. Double-click on one of the position functions to open the Function editor.

3. In the Function Editor window, select the Constant Z  button.
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Animating the Camera

-Harmony has a camera that can move along the X, Y, and Z axes. Having the camera move on the Z-
axis offers the possibility to create truck in and truck out, as well as multiplane camera moves. The 
default camera position is centred and backed up to 12 fields.

It is important to understand the coordinate values in Harmony. Harmony's core is based on the 
origins of animation. In traditional animation, a scene's size and camera motion are calculated in fields. 
A field has a 4:3 ratio and measures 0.5 inch in width. A specific grid has been created for this purpose. 
It is known as a field chart. Harmony uses this unit of measurement as its coordinate system.

A field chart uses cardinal directions. The X axis is the east-west direction, the Y axis is the north-south 
direction and the Z axis is the forward-backward direction.

The camera is treated the same way as any other element. The same tools and selection modes are 
used to offset or animate it, but the camera is a static object. To animate the camera, you need to 
connect it to a peg layer. A peg is a trajectory layer.
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While making camera moves, you can use the Top, Side, and Camera views.

How to open the Top and Side views

‣ From the top menu, select Windows > Top or Side.

‣ From any existing window already open in your project, click the Add View  button at 
the top-right corner and select Top or Side.

How to add a camera and parent it to a peg

1. If you do not already have a camera layer, do one of the following: 

‣ From the top menu, select Insert > Camera.

‣ From the Timeline view layers toolbar, click the Add Layers  button and select Camera.

‣ From  the Module Library view, select a Camera module and drag it to the Network view.

A new camera layer is added to the scene and appears in the Timeline view.

2. In the Timeline view, select the Camera layer.

3. From the Timeline View Layer toolbar, click the Add Peg  button.

A Peg layer appears directly above the Camera layer. The Camera layer is automatically attached 
to it. 

The Peg layer automatically takes the name of the camera and adds the suffix -P to indicate that it 
is a Peg layer, for example Camera-P.

If the new Peg layer did not appear directly above the camera, you may have clicked elsewhere in 
the scene, which deactivated the layer on which you want to add the Peg layer. 

‣ Select the Camera layer and drag and drop it under the new Peg layer. Or delete the 
misplaced Peg layer, select the Camera layer and click the Add Peg  button again.

‣ From the Module Library view, you can select a Peg module and drag it to the Network 
view. Then you can connect the peg’s output port to the camera’s input port.
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How to animate the camera

1. In the Tools toolbar, enable the Animate  mode.

2. In the Tools toolbar, select the Transform  tool or press Shift + T.

3. On the right side of the Timeline view, on the Camera Peg layer, select  the frame at which you want 
the camera move to start.

4. Do one of the following:

‣ Right-click and select Insert Keyframe.

‣ In the Timeline View toolbar, click the Add Keyframe  button.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera 
position as in this keyframe.

5. In the Top, Side or Camera view, select the camera (the large V-shaped cone) and move it to the 
desired position. In the Camera view, the camera is represented by a thin frame. You need to click 
directly on one of the edges.
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6. On the Timeline view, click on another cell a bit further down in time to indicate where the camera 
move will end.

7. Select the camera in the Camera, Top or Side view and move it to the desired position. 

A second keyframe appears and a line is created between the two frames to indicate that the 
subsequent motion between the frames will be calculated and rendered by the program.

8. Play back  your animation.

Animating a Camera Shake Using the Quake Module
One very common camera move you will do is a camera shake. You can use the Quake module to 
generate an automated quake instead of manually entering random keyframes. This way, you can 
simulate the shock of something heavy falling on the ground, like an earthquake or a strong vibration.

How to use the Quake module to create a camera shake

1. From the Module Library view, drag a Quake module to the Network view.

2. If you do not have a Camera module already, drag one from the Module Library view to the 
Network view.

3. Connect the Quake module to the Camera module.
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4. Click on the Quake module's square yellow button to open the Quake layer properties.

5. In the Quake Layer Properties window, adjust the following parameters:

‣ Hold Time: Enter the number of frames you want one of the quake vibrations (position) to 
hold for. Most camera shakes are done in a single frame (1) or double frame (2).

‣ Interpolate: An interpolation is generated between the random values. Instead of jumping 
to the next position, it will slowly progress forwards to the next position. It is the same 
principle as stop-motion keyframes and motion keyframes.

‣ Move Amplitude: This is the strength of the quake. The higher the value, the stronger the 
quake. If the value is set to 0, there will be no  motion. To have the motion start and stop at 
a specific frame during the scene, you can create a function curve and animate the amplitude 
over time. Simply click the Function  button to generate the function, then click on it 
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again to open the Function Editor.

‣ Apply on X, Y, Z: Applies the quake to the X, Y and Z-axis.

‣ Rotation Amplitude: When the value is higher than 0, a rotating quake is applied. The 
higher the value, the stronger the quake.

‣ Random Seed: Generates a different randomization pattern. If you cascade two Quake 
modules or more to apply a different amplitude on a different axis, you can change the 
Random Seed value to generate a different randomization pattern. If the X quake has a 
strong amplitude and the Y quake a weak amplitude and you do not want them to follow 
the same random pattern, then set the Random Seed value of the Quake modules to 
different numbers.

Camera Truck-ins and Line Thickness
As you move the camera in your scene along the Z-axis, notice that, logically, the lines of the elements 
become thicker the closer the camera gets to the drawing. If you prefer the lines to remain the same 
size or become thicker at a different speed, you can use the thickness feature to adjust your brush 
stroke and pencil line thickness. You can modify the size of the lines even if the camera is not animated.
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This feature can only be viewed in the Camera view's render mode.

How to adjust the pencil line thickness of a drawing layer in the Camera view

1. In the Timeline view, double-click on a drawing layer to display the Layer Properties panel.

2. Select the Advanced tab.

3. In the Line Thickness section, adjust some of the following parameters until you achieve the desired 
effect.

Adjust Pencil Lines Thickness: Lets you work with pencil lines and adjust their 
thickness. You will not see any changes to lines in the Camera view OpenGL mode. You 
must switch to the Render mode.

Normal Thickness: Disables all overrides on the brush stroke line thickness. This 
option must be enabled in order for the pencil line thickness parameter and pencil lines 
to appear. If you want to modify the brush stroke thickness, deselect this option. To 
enable brush strokes to work with the line thickness feature, you must first create 
central strokes in the Colour Art layer. The central strokes control the line variation of 
your brush strokes in the Line Art layer. Select Drawing > Create Colour Art from 
Line Art.

Zoom Independent Thickness: Select this if you want your line thickness to remain 
constant independently from the camera move. Everything else will increase in size, but 
the line thickness will stay the same.

Proportional: Enter a multiple by which you want to increase the line thickness base on 
its original thickness. A value of 1 will result in no change; a value of 0 (zero) will hide 
the lines.

Constant:  Enter a value in pixels (based on a 720x540 screen resolution) to indicate the 
amount of pixels you want to add around the existing line.

Minimum: Enter a value in pixels (based on a 720x540 screen resolution) for the 
minimum line thickness allowed.

Maximum: Enter a value in pixels (based on a 720x540 screen resolution) for the 
maximum line thickness allowed.
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Modifying a Path in the Camera, Top and Side Views

Camera moves and motion paths can become quite advanced, especially with moves through 3D 
space. Harmony provides tools to view your camera’s path and make adjustments to it from both a 
2D and 3D perspective.

You can display the trajectory of a motion path when you select an object in the Timeline or Camera 
view.

If you want to see the trajectory, enable the Show Control Points on Selected Layers option in the 
Preferences dialog box.

A motion path is easy to manipulate. One important concept to understand is that a trajectory 
contains both keyframes and control points. Both can be used to shape a path; each have their own 
significance and behaviour, however only keyframes appear in the Timeline view. 

• Keyframe: Has a transformation value and a position in space at a given frame. Keyframes are 
locked in time.

• Control Point: Has a position but no fixed frame or timing. It is mainly used to deform a 
trajectory. There are no velocity handles available on a control point. The velocity segments are 
set between keyframes only, making curves and trajectories much smoother. Control points can 
only be added on a 3D path.

You can edit keyframes and control point parameters, such as the position, continuity, bias, tension 
and lock-in-time using the Coordinates and Control Point view. 

Each time a keyframe or control point is selected in the Camera, Timeline or Xsheet view, its 
parameters appear in the Coordinates and Control Point view. You can also see the same information 
in the Coordinate and Control Point toolbars.
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You can adjust these parameters by selecting the control points and keyframes in the Camera, Top 
and Side views with the Transform  tool.

• Continuity controls the smoothness of a transition between the segments joined by a point.
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• Tension controls how sharply the path bends as it passes through a control point or keyframe.

• Bias controls the slope of the path so that it flows towards one side of the motion point or the 
other.

If you find that you are using the same Continuity, Tension and Bias settings, you can set a preference 
to remember your settings.

When you select a control point on a path, you can switch between a rounded or square corner by 
using the Linear/Curve command. 

How to view the layer’s trajectory using the Control command

1. Verify that the Camera view (click its tab) is selected and that the layer whose trajectory you want 
to display is selected in the Timeline view.

2. From the top menu, select View > Show > Control or press Shift + F11.
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If nothing appears in the Camera view, you may not have animated or selected the layer.

How to add a control point on a trajectory

1. In the Timeline or Camera view, select the peg or layer on which you want to add a control point.

2. If the selected element’s trajectory is not displayed, select View > Show > Control from the top 
menu or press Shift + F11.

The Trajectory appears in the Camera, Top, Side and Perspective views.

3. Add control points on a 3D path trajectory by placing the cursor where you want to add the point 
and press P once. If you hold the key down, control points will be added continuously until you 
release the key.
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How to display control points on selected layers

1. In the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X) 
or press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

The Preferences dialog box opens.

2. Select the Camera tab.

3. In the Control Points section, select the Show Control Points on Selected Layers option.

4. Click OK.

If the trajectory is hidden when you select an element, you may want to display it using the Control 
command.

How to switch between keyframe and control point

1. In the Camera view, use the Transform  tool select a point to convert.

2. To convert the point:

‣ In the Coordinates and Control Point view, select or deselect the Locked in Time option.

‣ From the top menu, select Animation > Lock in Time or press Alt + L.

‣ In the Function view or Function Editor, select the keyframe to convert and click the Lock in 
Time  button.

How to adjust the Continuity, Tension and Bias parameters

1. In the Tools toolbar, select the Transform  tool or press Shift + T.
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2. In the Timeline view, select the layer that contains the parameters you want to adjust.

3. From the top menu, select View > Show > Control  or press Shift + F11 to display the trajectory.

4. In the Camera view, select a control point or keyframe.

5. In the Coordinates and Control Points view, adjust the Continuity, Tension and Bias parameters.

How to adjust the control point preferences

1. From the top menu, select Edit > Preferences (Windows) or Stage > Preferences (Mac OS X).

The Preferences dialog box opens.

2. Select the Camera tab and adjust the parameters in the Control Points section.

How to toggle between a linear and curved corner

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

2. In the Camera view, select the point to convert.

3. From the top menu, select Animation > Linear/Curve.
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Offsetting a Trajectory
By offsetting a trajectory, you reposition the visual trajectory without offsetting or modifying your 
animation. By default, the trajectory is located at 0,0,0 fields. If your elements were drawn in a 
different location than the centre in the drawing area, it will look like the trajectory is not aligned with 
your drawing. Also, if you have several elements attached to one trajectory, you might want your 
trajectory to be a different location to represent the group's motion better.

How to offset a trajectory

1. In the Animation Tools toolbar, select the Spline Offset  tool or press Alt + 8.

2. In the Camera Top, Side or Timeline view, select the layer whose trajectory you want to offset.

3. From the top menu, select View > Show > Control to display the trajectory. If you do not display 
the trajectory, any transformation done using the Spline Offset tool will be ignored.
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4. In the Camera view, move the trajectory to the proper position. You can move it on the X and Y 
axes, but also on the Z-axis using the Top and Side views.
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Modifying a Path in the Timeline View

When you select a peg or drawing layer in the Camera view and move it around, Harmony will 
automatically create keyframes on the corresponding function curves. If you want to modify these 
curves, you can do it through the peg or drawing layer parameters in the Timeline view.

Harmony lets you also flip between the selected layer's keyframes in the Timeline view.

 How to create the function curve in the Timeline view

1. In the Timeline view, double-click on a drawing or peg layer.

The Layer Properties window opens.

2. Identify the section for the type of function you want to create.

3. Click the drop-down arrow at the end of the corresponding row and select Create Bézier or 
Create Ease.

 How to add a keyframe in the Timeline view

1. On the right side of the Timeline view, select a cell on the layer’s function that you want to animate.

2. Do one of the following:

‣ Right-click the selected cell and select Insert Keyframe.

‣ Press F6.

‣ In the Timeline view menu, select Motion > Insert Keyframe.

‣ In the Timeline View toolbar, click the Add Keyframe  button.

How to delete a keyframe in the Timeline view

1. On the right side of the Timeline, select a keyframe to delete. You can [Shift]+click several 
keyframes to select a group before deleting the keyframes. 

2. Do one of the following:
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‣ Right-click on the selected keyframe and select Delete Keyframes.

‣ Press F7.

‣ In the Timeline view menu, select Motion > Delete Keyframes.

‣ In the Timeline View toolbar, click on the Delete Keyframes  button.

If you select a keyframe or group of keyframes and press Delete, the corresponding drawings on that cell 
are also deleted.

How to change the keyframe values in the Timeline view

1. In the Timeline view, open the drawing or layer’s parameters by clicking the Expand  button or 
press Alt + F. 

2. At the top of the Timeline view, click the Show/Hide Data View  button.

3. Select the parameter for which you want to create a function curve: Path, Velocity, Scale; x or y, 
Angle, or Skew.

4. Pass the cursor over the blue number value of the parameter layer being modified.

‣ Wait until the cursor changes to a white hand with a two-way arrow and then drag the hand 
slightly to the left or right to decrease or increase the value.
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OR

‣ Double-click on the blue number and enter a value into the field that appears.

How to flip through poses

1. In the Camera or Timeline view, select the layer that contains the keyframes you want to flip 
through.

 

2. From the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe or 
press semicolon (;) and single quote (').
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Modifying a Path in the Function View

If you are used to graphs and function curves, you can use the Function view to define trajectories.

The Function view graph displays the motion over the first and last keyframes set in the scene, as well 
as any keyframes created between. If the scene is 60 frames, but the character's motion ends at frame 
40, then the editor will only display up to frame 40.

The Function view lets you edit function curves and parameters. It is a visual graph for adding, 
removing, and editing keyframes, as well as adjusting the velocity. The Function view allows you to 
display multiple functions in the background as a reference.

How to display functions in the Function view

1. Open the Function view.

The Function view is blank until you select the layer containing the functions you want to display.

2. To display a function in the Function view, click on the layer containing the functions to adjust in the 
Timeline view.

3. To select the functions you want to edit, select them in the Functions List section.
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Parameter Description

Function List

When selecting a layer in the Timeline view, all the 
corresponding functions are displayed. Until a keyframe is 
added on the function in the Timeline view, it will not be 
displayed in the Function view. Select all the functions you want 
to see and edit; hide the ones you do not.

 

The Display toolbar allows you to modify how the editing area 
is displayed. You can hide the grid, disable the synchronization 
with the current frame, reset the zoom level and normalize the 
function display by stacking them one over the other to 
compare them regardless of their value range.

Current Frame Displays the current scene frame.

Selected Keyframe Value Displays the value of the selected keyframe.

Display Advanced Parameter 
Values

Displays the Projection, Bias, Tension and Continuity 
parameters to adjust the curve around the selected keyframe.

Keyframe, Velocity and Inter-
polation Options

This toolbar lets you add and delete keyframes, adjust the 
velocity curve, adjust the segments to motion or stop-motion 
keyframes and set the velocity to create steps instead of a 
constant progression.

Function Type
This toolbar lets you click on the different function types to 
enable or disable all the listed functions of that type.

Value Scale
displays the value range for the displayed editing area. It can be ref-
erenced to know the value of a keyframe.

Selected Keyframe
The selected keyframe is displayed in red. When selected, the 
keyframe values are displayed in the corresponding fields.

Bezier Handles

The Bezier handles let you adjust the ease in and ease out of 
each keyframe. The more the handle is pulled out horizontally, 
the slower the animation will be. The more the handle is pulled 
out vertically, the faster the animation will be.

Function Curve
The thin line going from keyframe to keyframe is the actual 
curve. The section of a curve located between two keyframes is 
called a segment.

Frame Scale
The Frame Scale displays the frame range for the displayed 
editing area. It can be referenced to know the current frame of 
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a keyframe.

How to edit a function in the Function view

1. In the graph of the Function editor, select a white keyframe. 

The keyframe turns red and displays a pointed yellow handle.

2. Drag the point up or down, or click and pull one of the handles to adjust the curve of the graph.

In this case, changing the velocity from a straight line (constant velocity) to a curved one, changes 
the ease-in (where the curve shoots up and then flattens out) and ease-out (where the curve 
flattens out and then shoots up) values.

The centre keyframe cannot be dragged up or down because the velocity is set. Theoretically, 
dragging it downwards towards zero would put it back to a place of nonmovement.

3. Press the Enter/Return key with the editor still open to watch the result of your curve adjustment in 
the Camera view.

How to add or delete keyframes in the Function editor

1. In the Timeline view, open the layer parameters by clicking the Expand Function  button next 
the layer's name.

2. Select the parameter for which you want to create a function curve: Path, Velocity, Scale: x or y, 
Angle or Skew.

3. Double-click on the parameter layer name to open the Function editor window or click once on the 
parameter layer to display it in the Function view.
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4. In the graph section, click on the frame number where you want like to make changes, or enter the 
frame number in the Frame field.

In the graph section, a vertical blue line indicates the selected frame number.

5. Do one of the following:

‣ In the Function editor, click the Add/Remove Keyframes  button. 

‣ In the Function view, click the Add Keyframe  and Delete keyframe buttons.

6. Click on the newly created keyframe and drag it up (to decrease the width of the object) or down 
(to increase the width of the object) or pull on the handles to create a smooth fluctuation of the 
drawing object's width.

7. If you do not like the changes you just made, select and delete the new keyframe by pressing  
Delete or clicking the Add/Remove Keyframes  button.

You can delete an existing keyframe by using the same process.

How to change a keyframe value in the Function view

1. In the Timeline view, open the peg element's parameters by clicking the Plus  sign next the peg 
layer's name.

2. Select the parameter for which you want to create a function curve: Path, Velocity, Scale:x or 
y,Angle or Skew. 

3. Double-click on the parameter layer name to open the Editor window or click once on the 
parameter layer to display it in the Function view.
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4. In the Value field, enter a value. You can also drag the keyframe up or down in the function graph. 

5. Press Enter/Return or click the Play  button to view the changes made in the Camera view.

6. Keep adjusting the values until you are satisfied with the results.

7. Click Close.

Function View
The Function view lets you edit function curves and parameters. It is a visual graph for adding, 
removing, and editing keyframes, as well as adjusting the velocity. The Function view allows you to 
display multiple functions in the background as a reference.
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How to display functions in the Function view

1. Open the Function view.

The Function view is blank until you select the layer containing the functions you want to display.

2. To display a function in the Function view, click on the layer containing the functions to adjust in the 
Timeline view.

3. To select the functions you want to edit, select them in the Functions List section.

 

Parameter Description

Function List

When selecting a layer in the Timeline view, all the 
corresponding functions are displayed. Until a keyframe is 
added on the function in the Timeline view, it will not be 
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displayed in the Function view. Select all the functions you want 
to see and edit; hide the ones you do not.

 

The Display toolbar allows you to modify how the editing area 
is displayed. You can hide the grid, disable the synchronization 
with the current frame, reset the zoom level and normalize the 
function display by stacking them one over the other to 
compare them regardless of their value range.

Current Frame Displays the current scene frame.

Selected Keyframe Value Displays the value of the selected keyframe.

Display Advanced Parameter 
Values

Displays the Projection, Bias, Tension and Continuity 
parameters to adjust the curve around the selected keyframe.

Keyframe, Velocity and Inter-
polation Options

This toolbar lets you add and delete keyframes, adjust the 
velocity curve, adjust the segments to motion or stop-motion 
keyframes and set the velocity to create steps instead of a 
constant progression.

Function Type
This toolbar lets you click on the different function types to 
enable or disable all the listed functions of that type.

Value Scale
displays the value range for the displayed editing area. It can be ref-
erenced to know the value of a keyframe.

Selected Keyframe
The selected keyframe is displayed in red. When selected, the 
keyframe values are displayed in the corresponding fields.

Bezier Handles

The Bezier handles let you adjust the ease in and ease out of 
each keyframe. The more the handle is pulled out horizontally, 
the slower the animation will be. The more the handle is pulled 
out vertically, the faster the animation will be.

Function Curve
The thin line going from keyframe to keyframe is the actual 
curve. The section of a curve located between two keyframes is 
called a segment.

Frame Scale
The Frame Scale displays the frame range for the displayed 
editing area. It can be referenced to know the current frame of 
a keyframe.
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Modifying a Path in the Xsheet View

If you are prefer working with the Xsheet view, you can also create keyframes and type values in the 
Xsheet view.

You cannot create function curves directly in the Xsheet view. You must do this in the Layer Properties 
editor or the Timeline view.

To edit a function column in the Xsheet view, you must first display the Functions section of the Xsheet 
view and then select the layer you want to modify. If you double-click on a function column's header, 
you will display the corresponding function curve in the Function editor.

How to display the function columns in the Xsheet view

1. In the Xsheet view, click on the Expand Function Section button.

2. In the Timeline view, select the layer containing the parameters to modify.

The columns appear in the Xsheet view. The columns will not appear if function curves were not 
previously created by adding keyframes or through the Layer Properties view.

How to add a keyframe in the Xsheet view

1. In the Xsheet view, go to the function column on which you want to add a keyframe.

2. Double-click on the cell on which you want to add a keyframe and type a numeric value.
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3. Press Enter/Return to continue to the next cell.

4. Press Esc to exit the typing mode.

How to convert a cell into a keyframe

1. In the Xsheet view, go to the function column on which you want to add a keyframe.

2. Select the cell to convert.

3. Right-click on the cell and select Set Selection As Keyframe or press F6.

‣ If you want to remove a keyframe, select the keyframe, right-click on the cell and select 
Clear Keyframe in Selection or press F7.
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Function Curves

By default, when a drawing layer or peg is added to a scene, no function curves are created. You will 
generally create the ones needed to avoid being overloaded with too many functions you might not 
use.

When you select an element in the Camera view and move it around, it will automatically create the 
corresponding function curves. If you need to create certain functions manually, you can always do it 
through the Layer Properties view or editor.  You can then share it with other layer parameters or set 
your keyframes directly on the function curve instead of the Timeline or Camera view.

You can also link a layer's parameter to an existing function curve or attach several parameters to the 
same function curve. For example, if you have an aircraft performing loops between clouds, you may 
want the camera to follow the aircraft's motion path. If you attach the camera to the aircraft's layer, 
the camera will also loop, but this may produce undesirable results and even induce a feeling of motion 
sickness as you watch the final animation. Instead, you can share the X, Y and Z position of the aircraft 
with the camera's peg layer, but ignore the angle, scale and skew. 

By default all the function curves you create are private. This means that the function curves can only be 
used and modified using their original parameter. If you want another layer or parameter to use the 
same function curve, you must make the function public by sharing it.

There are two ways to share a function:

• Share Functions command

• Layer Properties Editor

When you create a function curve in the Layer Properties view or editor, there are several choices 
available: 

• Create 3D Path: Creates a new 3D Path Column set

• Create Bezier: Creates a new Bezier curve

• Create Ease: Creates a new Ease curve

• Local: Disconnects the parameter from any function and turns it public

• 3D Path: Displays the list of every public 3D Path function available

• Bezier: Displays the list of every public Bezier curve available

• Ease: Displays the list of every public Ease curve available

• Velobased: Displays the list of every public velocity based curve available

• Expression: Displays the list of every public Expression function available

• 3D Rotation: Displays the list of every public 3D Rotation function available

• Connected: Displays the list of every public connected function curve

• Unconnected: Displays the list of every public unconnected function curve

• All: Displays the list of every public function curve

You have the choice of creating a new function curve or linking it to an existing public one. This way, 
you can have two or more parameters following the same function.

Depending on your favourite working method, you can create different types of function curves to suit 
your needs. 

You have several choices available:
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• Ease function

• Bezier function

• Velobased function

When you create a function to control a parameter over time (Scale, X, Y, Z, Rotate), you have the 
choice of an Ease or Bezier function.

These function editors present different ways of editing the values over time. The shape of the created 
graph indicates the velocity of the function, regardless of the chosen editor. The type of function that 
you choose is largely based on your working preference. 

With the Ease editor, you can edit the shape of the function curves using the ease-in and ease-out 
controls.

You can also create Velobased functions for certain effects, like changes in rotation or size over time. 
In these cases, the Velobased functions are linked to the velocity of a 3D path. You cannot change the 
shape of a Velobased function to control its velocity.

With Velobased functions, you can link changes in rotation or scaling to the velocity of a 3D path. This 
makes it possible for changes in rotation or scaling to progress at the same speed as changes to the 
position of an element.

249



Chapter 4: Animation Paths     Function Curves

You can convert Ease and Bezier functions so you can edit them using the controls offered by that type 
of function. 

How to create the function curves

1. In the Timeline view, double-click on a layer.

The Layer Properties Editor opens.

2. Select the Transformation tab.

3. Click the Function Arrow button beside the local function information.

4. Create a 3D Path, Bezier, Ease or Velobased curve. You can also create an Expression column—
see Expression Columns on page 271.
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You can click the Function  button to open the Function editor.

5. Click OK.

How to share a function using the Share Functions command

1. In the Timeline view, select the function layer to share.

2. Right-click  and select Share Functions.

The function becomes public to the other layers and parameters, and can be shared.

Public functions are visible in the main section of the Xsheet view.

3. In the Timeline view, open the Layer Properties editor of the layer that contains the parameters you 
want to link to the public function.

4. To open the Layer Properties editor, in the Timeline view, double-click on the layer containing the 
function to share or click once to display it in the Layer Properties view.

The Layer Properties Editor opens.

5. Select the Transformation tab.

6. Click the Function Arrow  button beside the function you want to link to the function column.

7. From the menu, select the function you just made public from the 3D Path, Bezier, Ease, 
Velobased, Expression, Connected, Unconnected, or All menu and attach it to your parameter.
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The two parameters are now both linked to the same function curve and should follow the same 
path. If you modify the curve, both parameters will update.

How to share function curves

1. To open the Layer Properties editor, in the Timeline view, double-click on the layer containing the 
function to share or click once to display it in the Layer Properties view.

2. Select the Transformation tab.

3. Click the Function Arrow  button beside the function to share.

4. In the drop-down menu, select Local.

5. Click the Function Arrow  button beside the Function field and choose a function from the drop-
down menu.

The function becomes public to the other layers and parameters, and can be shared.

Public functions are visible in the main section of the Xsheet view.
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6. In the same drop-down menu, where you chose the Local option (in our example), select the 
function you just made public from the 3D Path, Bezier, Ease, Velobased, Expression, 3D Path, 
Connected, Unconnected or All menu and attach it to your parameter.

7. In the Timeline view, open the Layer Properties editor of the other layer that contains the 
parameters you want to link to the public function.

8. In the Layer Properties editor or view, attach the parameter to the public function the same way 
you did for the first layer.

The two parameters are both linked to the same function curve and follow the same path. If you 
modify the curve, both parameters will update.

How to convert Ease and Bezier functions

1. In the Xsheet view, show the function columns.

2. In the Xsheet view, click on the Expand button located on the right side of the main section to show 
the Functions section. Click on the same button to collapse it. You can also use the Show Column 
List  button in the Xsheet View toolbar.
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3. Click the Expand button on the right side of the Functions section to display the Column List 
section.

4. In the Timeline view, click the layer that contains you function columns you want to display.

5. In the Xsheet view, right-click on the column header and select one of the following from the menu:

‣ Convert the column: The values of multiple effects may be linked to the original column. 
When you use the Convert the Column command, all links to the original column will transfer 
to the new converted column.

‣ Create a new column and update links: Creates a new function from the original. All links 
to the original column will transfer to the new column. The original function column will 
remain in the exposure sheet in case you decide you want to switch back to it.

‣ Create a new unused column: Creates a new column based on the values in the original 
column and leaves all links pointing to the original column. You can use this command to 
experiment with various functions and then link effect values to the new function curve 
column.
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Copying and Pasting a Motion

In the Timeline view, you can easily drag keyframes to change the animation timing, delete them, cycle 
them and even copy them.

As you animate, you will find that you reuse many positions, drawings, and keys. However, you may 
only want to paste the drawings or just the keys or maybe everything. There are different paste 
options available in the Timeline view which give you maximum flexibility when reusing and pasting.

Note that these modes also apply when you use drag instead of copy and paste.

There are three different modes for pasting your selection:

•  Paste Mode: All Drawing Attributes: Pastes the drawing exposure and keyframes.

• Paste Mode: Keyframes Only: Pastes only the keyframes.

•   Paste Mode: Exposures Only: Pastes only the drawing exposure.

When you have position keyframes set in your drawing layer and you want to move them around when 
moving your drawing's timing, you can use the Paste Special feature to only move selected keyframes.

You can also use the Paste Cycle and Paste Reverse feature to cycle your selection including keyframes 
and drawings.

If you want to cycle a portion of your animation, you can use the Paste Cycle command. You can also 
use the Paste Reverse command to completely reverse the flow of your animation.

How to paste a selection using the different Timeline pasting and dragging modes

1. In the Timeline view, select the cells you want to copy and paste.

2. In the Timeline view's left side, enable the desired Paste  mode.

3. From the top menu, select Edit > Copy cells from the Timeline or press Ctrl + C (Windows/Linux) 
or ⌘  + C (Mac OS X).

4. In the Timeline view's right side, select the cell on which you want to paste your selection.

5. From the top menu, select Edit > Paste Cells in the Timeline  or press Ctrl + V (Windows/Linux) or 
⌘  + V (Mac OS X).

Paste Mode: All Drawing Attributes
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Paste Mode: Keyframes Only

Paste Mode: Exposures Only

How to copy and paste a motion using Paste Special

1. In the Timeline view, select the keyframes, to copy and paste. If you want to move the keyframes, 
move on to step 3.

2. In the top menu, select Edit > Copy.

3. Edit your selection by doing the following:

‣ To paste the selection, in the Timeline view, select the first cell on which you want to paste 
your keyframes and from the top menu, select Edit > Paste Special.

‣ To move the selection, in the Timeline view, drag the selection and hold down Alt 
(Windows/Linux) or ⌘  (Mac OS X). Drop the selection where you need it and release the 
hot key.

The Paste Special window opens.

4. Set the Drawing, Pegs and Functions, and Cycles parameters. 
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5. Click OK.

How to open the Paste Special dialog box

1. In the Library view, select the symbol or template to import.

2. While dragging the selection to the Timeline view, hold down the Alt (Windows/Linux) or ⌘  (Mac 
OS X). Drop the selection in the Timeline view before releasing the hot key.

The Paste Special window opens.

3. Set the parameters.
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How to cycle a portion of an animation

1. In the Xsheet or Timeline view, select the cell range and keyframes to loop.

2. From the top menu, select Edit > Copy.

3. In the Xsheet or Timeline view, select the cell on which you want the cycles to start.

4. From the top menu, select Edit > Paste Cycle or press Ctrl + / (Windows/Linux) or ⌘  + / (Mac OS 
X).

The Paste Cycle dialog box opens.
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5. In the Number of Cycles field, increase or decrease the number of cycles you want to paste.

6. In the Cycle Type, select the type of cycle to paste.

‣ Normal (forward): Pastes your selection as it is, starting with the first cell and ending with 
the last.

‣ Reverse: Pastes your selection reversed, starting with the last cell and ending with the first.

‣ Forward > Reverse: Pastes your selection as a yo-yo, starting with the first cell, going to 
the last one and ending with the first cell.

‣ Reverse > Forward: Pastes your selection as a reversed yo-yo, starting with the last cell, 
going to the first one and ending with the last cell.

How to reverse the animation flow

1. In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.

2. From the top menu, select Edit > Copy.

3. In the Xsheet or Timeline view, select the cell on which you want the cycles to start.

4. From the top menu, select Edit > Paste Reverse or press Ctrl + . (Windows/Linux) or ⌘  + . (Mac 
OS X).
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Paste Special Options

Basic Tab

Parameter Description

Drawings

Only create drawing files when they do not exist: When adding 
exposures to a drawing layer, new drawings will be created only when 
drawings with the same name do not already exist in the destination.

Always create drawing files: When adding exposures to a drawing 
layer, new drawings will always be created. If drawing files with the 
same name already exist, Harmony will create a new name for the draw-
ing.

Paste all Frames of the Symbols (full movie): When enabled, the Paste 
Special command will expose all the Symbol's frames instead of the first 
one only.

Cycle

Number of Cycles: Use the up and down arrows to increase 
or decrease the number of cycles you want to paste. You can 
also type the value directly in the field.

Cycle Type

• Normal (forward): This pastes your selection as it is, starting 
with the first cell and ending with the last one.

• Reverse: This pastes your selection in reverse, starting with the 
last cell and ending with the first one.

• Forward -> Reverse: This pastes your selection as a yo-yo, 
starting with the first cell, going to the last one and ending with 
the first cell.

• Reverse -> Forward: This pastes your selection as a reverse 
yo-yo, starting with the last cell, going to the first one and 
ending with the last cell.
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Advanced Tab

Parameter Description

Drawings

Do Nothing: Does not create or overwrite drawings.

Update Drawing Pivot: Revises the drawing pivot in the 
destination to use the same drawing pivot as the first 
drawing in the template. If you have a range of drawings 
selected in the destination, the pivot points of all selected 
drawings will be updated.

Add/Remove Exposure: Creates/deletes exposure values in 
the selected layer.

You have the following choices as to how to treat drawings 
that will be created when adding an exposure:

• Never create drawing files: When adding exposures to 
a drawing layer, drawing files will not be created.

• Only create drawing files when they do not exist: 
When adding exposures to a drawing layer, new 
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drawings will be created only when drawings with the 
same name do not already exist in the destination.

• Always create drawing files: When adding exposures 
to a drawing layer, new drawings will always be created. 
If drawing files with the same name already exist, 
Harmony will create a new name for the drawing.

• Extend Exposure: Extends the exposure of drawings to 
fill the range of cells to the destination frame.

• Key Drawing Mode (Substitution): Pasting an 
exposure value replaces the cell value in the current 
frame and in all frames following in sequence with the 
original cell value.

• Paste all Frames of the Symbols (full movie): When 
enabled, the Paste Special command exposes all the 
Symbol's frames instead of only the first one.

Add/Remove Keyframes

Motion: Copies the properties of the selected motion 
keyframe to the new frame.

Velocity: Copies the properties of the selected velocity 
keyframe to the new frame.

Rotation: Copies the properties of the selected rotation 
keyframe to the new frame.

Skew: Copies the properties of the selected skew keyframe 
to the new frame.

Scale: Copies the properties of the selected scale keyframe 
to the new frame.

Force Keyframes at Function's Beginning and End: Adds a 
keyframe to the beginning and end of the pasted function, 
reproducing the source function.

Offset Keyframes: When pasting functions, this option 
offsets the keyframes from the function's last value by the 
values in the pasted function. This will continue the 
progression of a function rather than repeat the values. 

Options

Palettes

• Do nothing: Does not create, overwrite, merge or link 
palettes.

• Reuse palettes. Copy palettes if they do not exist: 
Palettes in the destination drawings are left as they are.

• Copy and overwrite existing palettes: Overwrites 
destination palettes with the palettes from the source 
drawings.

• Copy and create new palette files: Creates new palette 
files, placing them at the same relative environment and 
scene level as the source. If the palettes in the templates 
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were stored at the environment level of the source scene, the 
paste operation will place the palettes in the environment level 
of the destination scene.

• Copy and create new palette files in element folder: Creates 
new palette files in the element folders of the destination 
scene, rather than in the same relative job or environment.

• Copy palette and merge colours. Add new colours only: 
Adds new colours to the destination palettes and ignores 
colours that are the same in the two palettes.

• Copy palette and update existing colours only: Adds new 
colours to the destination palette and updates duplicate 
colours in the destination with colour values from the source.

• Link to original palettes (colour model): Links the colour 
palettes in the destination scene to the palettes in the source. 
Use this to link drawings to the palettes in a colour model.

• Copy scene palettes and merge colours. Add new colours 
only: Adds new colours to the destination scene palettes and 
ignores colours that are the same in the two palettes.

• Copy scene palettes and update existing colours: Adds new 
colours to the destination scene palette and updates duplicate 
colours in the destination with the colour values from the 
source.

• Duplicate All Symbol Content: Instead of linking the Symbol 
instance to the original one, the Symbol will be duplicated. A 
new Symbol is created in the Library.

Symbols

• Copy symbols if they do not exist: This is the default 
setting for this operation and will prevent Symbols in an 
Action template from being copied.

• Duplicate symbols: Creates a duplicate of the symbol 
instead of linking the Symbol instance to the original one. 
The new Symbol is created in the Library.

• Overwrite symbols: If a modification was made to a 
Symbol that does not exist in the basic rig template for a 
character, select this option to overwrite the previous 
Symbol.

Cycles

• Normal (forward): Pastes your selection as is, starting 
with the first cell and ending with the last.

• Reverse: Pastes your selection in reverse, starting with 
the last cell and ending with the first.

• Forward > Reverse: Pastes your selection as a yo-yo, 
starting with the first cell, going to the last one and ending 
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with the first cell.

• Reverse > Forward: Pastes your selection as a reverse yo-yo, 
starting with the last cell, going to the first one and ending with 
the last cell.

• Number of Cycles: Lets you set the number of cycles.

Modules: Create New Columns: A new column is created 
when you copy and paste modules from the Network view or 
Layer in the Timeline view. If the layers are linked to function 
curves, the function curves, drawings and timing will be 
duplicated.

Elements: Reuse existing elements: Lets you paste existing elements 
without creating new ones. This should be used only when pasting 
within versions of the same scene.
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Adjusting the Ease

To add ease in and ease out on motion paths, you can display the function curve and modify the Bezier 
or Ease curve. To apply ease to multiple functions and keyframes, you can use the Set Ease For 
Multiple Parameters script and set the amount.

The Velocity, or ease, is used on motion keyframes. The Velocity must be adjusted directly on the 
function curve in the Function view or Function editor. When a keyframe is selected, easing values 
appear in the right handle and left handle fields, as well as Bezier handle or Ease wheel controls on 
each selected keyframe. Pull on them to adjust the ease in and ease out, or type values in the fields.

You can reshape the velocity function using Bezier controls.

You can also reshape the velocity function using Ease controls.

You can create a stepped curve to hold the same value over a selected number of frames. This works 
well when you are animating drawings on 2s, for example, and you want to hold the same value for a 
function over those two frames.

If you have several functions whose velocity you want to adjust at the same time, you can use the Set 
Ease for Multiple Parameters dialog box. It allows you to apply the same velocity parameters to all the 
selected keyframes in the same frame.
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How to display the velocity curve

1. In the Timeline view, click the Expand  button on a layer or press Alt + F to display the layer’s 
functions.

2. Double-click the desired function.

The Function Editor opens as the Ease Editor or Bezier Editor.
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The editor will not be displayed if the function does not already exist. You can reshape the function 
using the Bézier or Ease controls.
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How to reshape a function using Bézier controls

1. Select a keyframe.

2. Drag the handles to modify the shape of the curve.

3. The Continuity options influence how you can move the handles:

‣ Straight: Lets you move the handles together, maintaining the same angle to the point.

‣ Corner: Lets you move the handles independently.

‣ Smooth: Lets you move the handles together, maintaining the same distance and angle to 
the point.

How to reshape the function using Ease controls

1. Click on the keyframe to select it.

2. To set the number of frames in the ease-in, press Alt, click to the right of the keyframe and drag 
the green line. The ease in slope is indicated in blue. 

As you change the values visually, the value in the Ease In field is updated. This value represents the 
number of frames in the ease-in.

3. To set the number of frames in the ease-out, press Alt, click to the left of the keyframe and drag 
the green line. The ease out slope is indicated in red. 

As you change the values visually, the value in the Ease Out field is updated. This value represents 
the number of frames in the ease-out.

4. To adjust the ease-in or ease-out, drag the handles around the keyframe.

The Continuity options, Corner and Straight, influence how you can move the handles:

‣ Straight: allows you to move the handles together, maintaining the same angle to the point.

‣ Corner: allows you to move the handles independently.

How to hold the same value over several frames

1. Click the Hold Value Editor  button.

The Hold Value editor opens.

2. In the Hold Value Editor, enter the following values:

‣ Start: Enter the starting frame for the effect.

‣ Stop: Enter the last frame for the effect.

‣ Step: Enter the number of frames to hold the value.

The function curve is updated based on the values you entered.

268



Harmony 11.1 Compositing Guide (Network)

You can reshape the curve to create a linear velocity, so the values are interpolated (tweened) 
consistently between keyframes. That is, there is no acceleration in the effect.

How to set eases on multiple parameters

1. In the Timeline view, select a keyframe on one or more layers.

Only the first selected keyframe will be considered when using the Set Ease For Multiple Parameter 
function. If many keyframes are selected on a same layer, the ease values will be applied only to the first 
one and the rest will be ignored.

2. In the Timeline view,right-click and select Set Ease For Multiple Parameters. In the Timeline View 
toolbar, you can click the Set Ease For Multiple Parameters  button.

The Set Ease For Multiple Parameters dialog box opens.

3. In the graph, pull on the Bezier handle to adjust the velocity for all the selected functions.
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4. In the Filters section, you can apply the easing parameters to a specific type of function only, such 
as Rotation or Scale. Deselect the function types you do not want to affect.

‣ Motion: If this option is enabled, the easing parameters will be applied to the selected 
Position X, Position Y, Position Z and 3D Path functions

‣ Rotation: If this option is enabled, the easing parameters will be applied to the selected 
Angle functions.

‣ Scale: If this option is enabled, the easing parameters will be applied to the selected Scale 
functions.

‣ Skew: If this option is enabled, the easing parameters will be applied to the selected Skew 
functions.

‣ Morphing: If this option is enabled, the easing parameters will be applied to the selected 
Morphing Velocity functions. Note that it applies to the Morphing velocity function found in 
the Layer Properties dialog and not to the basic morphing ease in the Tool Properties view.

‣ Other: If this option is enabled, the easing parameters will be applied to all the other the 
selected functions such as all functions created to animate effect parameters.

5. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values 
are calculated in percentage.

‣ In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding 
to the length of time you want the easing to last for. It is recommended to remain between 
0% and 100%. If you go beyond 100%, your motion will overshoot. 

‣ In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong 
you want the easing out to be. It is recommended to remain between 0% and 100%. If you 
go beyond 100%, your motion will overshoot. 

‣ If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

6. Once done, click on one of the following buttons:

‣ Apply: Applies the easing parameters to the selected keyframes.

‣ Apply/Previous: Applies the easing parameters to the selected keyframes and then selects 
the previous keyframe in the timeline.

‣ Apply/Next: Applies the easing parameters to the selected keyframes and then selects the 
next keyframe in the timeline.

‣ Close: Close the dialog box. If you did not apply the modifications, they will be cancelled.
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Expression Columns

In Harmony, you can use expressions to automate the calculation of effect values based on the values 
in another function. An expression is a mathematical formula that allows you to manipulate the value in 
the source function to create new values for the destination effect.

For example, there are two characters. One is walking across the stage and the other is following the 
same path two steps behind. Without expressions, you would have to manually enter the values for 
the position of the peg so it is one frame behind the original element. However, you can save time by 
building an expression that does this for you. Then, if you change the position of the element in the 
original column, Harmony automatically updates the Expression columns linked to it.

When you want to create an expression for an effect, you must add an Expression column to the 
Xsheet view, build the expression and then link the Expression column to the parameter you want to 
control.

Writing Expressions
Expressions are based on a JavaScript (JS) program. You can access the full capability of the JS 
language and write any type of program, as long as it executes relatively quickly.

The entire JavaScript must be defined within the expression code. There are no common repository of 
JS functions and services available to the expression column scripting environment. However, with the 
Harmony C++ SDK, you can extend the API of functions available to the expression scripting 
environment.

If you are working with an old project that contains expressions, they are converted to a JS program. 
Only simple expressions are updated. Complex expression and expressions using non-ported services 
cannot be converted. For these type of expressions, you must convert them manually.

Expression Editor

The Expression editor is where you write expressions. It is a simple text editor that can handle 
incomplete or invalid JS programs although they will not be evaluated, Harmony can save and load 
invalid JS programs.
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The Expression editor evaluates the current script at the current global frame and reports any errors 
or returns the numerical result of the program.

Expression JavaScript Program

An expression JavaScript program can be any valid program. The only requirement is the last 
statement of the script must leave a number on the stack. The “return” statement is NOT needed as 
the script is not a function.

Valid Expression Column JS Program

Example 1

10

This is a simple program returning 10.

Example 2

currentFrame

This is another simple program returning the current frame. The variable “currentFrame” is one of the 
predefined variables and services available.

Example 3

value( “MyBezierFunction”, currentFrame - 1 );

A simple expression program that returns the value of the Bezier function “MyBezierFunction” at the 
previous frame. If this function does not exist in the scene, the expression column will be blank in the 
XSheet. If this function does exist, the expression column will show the value of that function at the 
frame.

Example 4

This programs evaluates the Fibonacci series starting at the current frame. The value will be computed 
up to a certain frame. After that frame, the program is too complex and will be stopped by the engine 
before finishing.

Errors

Programs that take too long to execute, do not generate a numerical value, or has syntax errors will 
not be compiled and will not compute a value. The scripting editor will show the condition that 
triggers this, but the Xsheet will simply display a blank field.
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API

Using Column Names and Frame Numbers

To refer to the values in a column, use the column name and the frame number. If you do not state the 
frame number, then Harmony uses the value of the current frame. You can refer to the frame numbers 
in the following ways:

• currentFrame: Refers to the current frame number.

• numFrames: refers to the total number of frames in a scene.

Consider the expression: value ( ̀ `peg x”, currentFrame-1)

• This expression says that the current frame value will be the same as the previous frame value of 
the element peg x.

Now consider this expression: value ( ̀ `peg_angle”, currentFrame - 2] * 3

• In this expression, Harmony is to look two frames before the current frame in the column "peg_
angle" and multiply the value by 3 to derive the value for the current frame of the expression 
column.

Predefined Functions

Most mathematic functions are obvious. They either take an angle or value or return an angle or a 
value. Angles are always specified in degrees. If the input argument is not valid, the function will log an 
error (which is visible in the script editor) and the Xsheet does not display anything.

The two variants of the function value() are used to get the value of 2D functions at the current frame 
or the specified frame. The first argument is always a string that identifies the function. The optional 
second argument is the frame to use.

For example: value( “myFavBezier”, currentFrame-1)

Function Description

sin (angle) Returns the sinus from angle specified in degrees

cos (cosine) Returns the cosinus from the angle specified in  degrees

tan (angle) Returns the tangent from the angle specified in  degrees

asin( v ) Returns the arcsin in degrees

acos( v ) Returns the arccos in degrees

atan( v ) Returns arctan as an angle in degrees from the first  quadrant

atan2( x, y ) Returns the arc tangent in degrees

int
Returns the integer value of the “v”. Undefined  behaviour for negative 
number.

ceil( v ) Returns the next integer greater or equal than “v”

floor( v ) Returns the integer value of v. Remove the fractional  part.

abs( v ) Return the absolute value
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sqrt( v ) Returns the square root for v >= 0

exp( v ) Returns the “e” exponent v. (see c library exp( f ))

ln( v ) Returns the natural logarithmic of v for v > 0

ln Logarithm of a value

value( columnName) Value of the function specified by “columnName” at the current frame

value(columnName,frame)
the value of the function specified by “columnName” at the frame spe-
cified by “frame”

column( columnName )

Indentify the text wrapped by columnName to be renamed 
whenever the column named “columnName” is renamed.

column() is a keyword that does nothing at runtime, but, it 
helps Harmony track which references to a function needs to be 
renamed in the script when a function is renamed. For example, 
if you have a function named “B” and this one gets renamed to 
“C” through some scripts or by the user, all expression script 
referencing “B” will automatically be updated to refer to “C” if 
their call was wrapped as column( “B” ).

node( nodeName )

module( nodeName 
) 

Identifies a module/node that is in the same group as another 
module which is using this expression column.

node( nodeName) and module( nodeName ) are two functions 
that return a proxy to a module that must live in the same 
group as another module using that expression column. For 
this method to work, the expression must be connected to a 
module “A” and the script must refer to a module “B” in the 
same group as module “A”. The resulting object is a proxy to a 
module which cannot be converted to a number. This proxy 
object is only usable by an SDK plugin.

numFrames A constant that represents the number of frames in the current scene

currentFrame A constant that represents the current frame (1 based)

Building an Expression for an Effect

How to build an expression for an effect

1. In the Xsheet view menu, select Columns > Add Columns or press Shift + C.

The Add Column dialog box opens.
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2. In the Name field, type a name for the column.

3. From the Type menu, select Expression and click OK.

4. Double-click on the column's header to open the Expression dialog box.

5. Type an expression in the dialog box.

To address a specific component of a 3D Path, the syntax is "Peg x", and not "Peg_x".

6. Click OK or Apply to activate the expression.

The cells in the Expression column are filled with values based on the expression you created.
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7. To apply the values in the Expression column to an effect, link the Expression column to the 
parameter values. In the drawing's layer properties, link the function to the new Expression 
column.
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Chapter 5: Sound

With Harmony, you can import soundtracks and dialogue into your animation to make it more 
engaging and entertaining.There are several sound editing features you can use to synchronize sounds 
to individual frames or moments in time. You can also use them to trim unwanted seconds from the 
beginning and end of your sound files, as well as loop sounds that you want to continue throughout 
your animation.

Your ability to add dialogue to animation is greatly enhanced with the Harmony lip-sync tools. 
Harmony can analyze voice tracks to determine which of the eight animation phonemes (lip positions) 
would best apply to each frame of sound. With the mouth chart that is generated, you can easily draw 
lip positions for your character. Furthermore, Harmony can automatically apply drawings of lip 
positions to each frame of your animation based on the mouth chart.

This chapter contains the following topics:

• Importing a Sound File on the next page

• Sound Layer Properties - Sound Element Editor on page 281

• Sound Displays on page 283

• Sound Playback on page 285

• Sound Scrubbing on page 286

• Editing a Sound File on page 289

• Adding an Empty Sound Layer on page 297

• Exporting a Sound File on page 599
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Importing a Sound File

If you decide to add sound to your movie, you must first prepare the sound outside of Harmony. Once 
this is done, you must add a sound element in Harmony to the organize the sound files in your 
animation. Sound will play in the movie until it reaches the end of the file or a stop frame that you have 
created in the Sound Element Editor.

You can import WAV, AIFF or MP3 sound files.

How to import a sound file

1. Do one of the following:

‣ From the top menu, select File > Import > Sounds.

‣ In the Xsheet view, right-click anywhere in the frame area of the Xsheet view and select 
Import > Sounds.

‣ From the Xsheet view menu, select File > Import > Sounds.

‣ From the Timeline view menu, select Import > Sounds.

The Select Sound File dialog box opens.

2. From the Select Sound File dialog box, find and select a sound file.

The sound file  appears as a layer in the Timeline and Xsheet views.
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Sound Layer Properties - Sound Element Editor

When you select a sound layer in the Timeline view, the options related to that layer appear in the 
Layer Properties view or in the Sound Element Editor when you double click on the layer. 
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• Mute/Unmute: This button mutes and unmutes the sound layer during the scene play back.

• Layer Name: This field displays the layer's name.

• Sound Editor: This button opens the Sound editor.

• Start Frame/End Frame: These fields determine the start and end frame of the sound file.

• Detect: This button launches the automated lip-sync detection.

• Map: This button opens the Map Lip-sync dialog box.

• Mouth Shapes: This section shows the automated lip-sync detection during the scene play back. Click 
on the thumbnail image of each mouth to change the phoneme assigned to the current frame.
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Sound Displays

Within the Xsheet view, you can display the sound file in different ways, depending on your sound 
editing needs.

You can show or hide the waveform in the Timeline view by selecting the Waveform  button in the 
Timeline View toolbar. You must customize the toolbar to display this button because it is not 
included in this toolbar by default.

How to change the sound display in the Timeline view

1. In the Timeline view's right area, right-click in the frame section and select Show Sound 
Waveforms.

‣ You can change the waveform scale using the Zoom Waveform  icon on individual sound 
layers in the Timeline view's left side.

How to change the sound display in the Xsheet view

1. Right-click in the sound column or on the sound column header, and select Sound Display and one 
of the following:

‣ Sound Name: Shows the name of the sound file, as well as the file format. The line running 
vertically through the column frames between the same file name indicates a continuity of 
the same sound file in these frames.

‣ Mouth Shapes: Shows the letter (or name depending on the way you named your 
character's different mouth positions) in the column's frames. There is only one mouth 
position allotted per frame and this position should correspond to the sound file after 
performing a lip-sync.

‣ Waveform: Shows a vertical display of the sound file's actual waveform. In the column 
header, in the field under the column name, you can type in a percentage to zoom in or 
zoom out on the waveform, or pass the scroll cursor  over the Zoom Waveform  
icon.
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Sound Playback

Before playing back any sound, click the Enable Sound  button in the Playback toolbar or enable it 
through the Play menu (in the top menu). This will ensure that you can hear the sound layers in your 
scene, even the ones included within symbols.

How to play back sound

1. To select a starting point:

‣ In the Xsheet view, click on a cell in the sound column.

‣ In the Timeline view, click on a cell in the sound layer. You can also slide the red playhead to 
the correct cell.

2. In the Playback toolbar, activate the the Enable Sound  button.

3. Do one of the following:

‣ Click the Play  button in the Playback toolbar.

‣ From the top menu, select Play > Play Scene Forward or click on the Enter/Return key.

4. To hear the sound played back again and again, do one of the following:

‣ Click the Loop  button in the Playback toolbar 

‣ From the top menu, select Play >Loop.

Mute
If there are two or more sound layers and you want to listen to them independently, you can disable 
the unwanted sound by clicking the Mute Sound  button on the sound name layer in the Timeline 
view.
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Sound Scrubbing

Harmony uses a process known as Sound Scrubbing to let you hear sound in real-time while you move 
the playback pointer forward or backward. This is very useful for finely-tuned lip-synching. You can 
scrub sounds from the Timeline view. 

How to scrub a sound from the Timeline view

1. Do one of the following:

‣ From the top menu, select Play > Enable Sound Scrubbing. 

‣ Right-click in the frame bar of the Timeline view and select Play > Enable Sound Scrubbing.

‣ In the Playback toolbar, enable the Sound Scrubbing  button. 

2. At the top of the Timeline view, drag the red playhead to hear the sound at each frame.

Analog Sound Scrubbing
Harmony is set to the digital sound scrubbing mode by default. This means that all sounds are played 
in real time. It also means that as you scrub over a frame, you will hear the section of your sound file 
that is allotted to that frame. As you are scrubbing, although it is accurate, the sound can sound 
clipped. It can also be difficult to hear nuances in pitch and tone. 

Harmony has an analog sound scrubbing option. When sound scrubbing in this mode, the sound is 
played back according to the speed that the playhead or jog is manually adjusted. Harmony's 
interface offers shuttle and jog sliders to perform analog sound scrubbing, however, external 
hardware and their corresponding software can be used in conjunction with Harmony for improved 
analog sound scrubbing results. 
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Refer to the device's manual to configure its functionality with Harmony.

Performing an Analog Sound Scrub in Harmony

Before you can perform an analog sound scrub in Harmony, you have to learn about the Shuttle and 
Jog controls.

• Shuttle: Pull the Shuttle control backward or forward to make the red playhead in the Timeline 
view jump by large increments in the direction you are moving the shuttle.

• Jog: Drag the Jog control to make the "dial" rotate. The Jog controls finer incremental 
movements along the soundwave. Use the Frame field to see the frame number which you are 
on. As you rotate the dial, your speed in fps appears directly after the FPS field. 

How to perform an analog sound scrub

1. Do one of the following:

‣ From the top menu, select Play > Enable Sound Scrubbing. 

‣ Right-click in the frame bar of the Timeline view and select Play > Enable Sound Scrubbing.

‣ In the Playback toolbar, enable the Sound Scrubbing  button. 
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2. In the top menu, select Edit > Preferences (Windows/Linux) or Stage> Preferences (Mac OS X).

3. In the Sound tab, select the Analog Sound Scrubbing option.

4. Click OK.

5. Do one of the following:

‣ In the Playback toolbar, use the Shuttle to find the general location of where you want to 
start your sound scrub. 

‣ In the Timeline view, drag the red playhead to the desired location.

6. In the Playback toolbar, use the Jog to fine-tune your scrub to just a few frames.
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Editing a Sound File

Now that you have successfully imported a sound file into Harmony, it is time to familiarize yourself 
with the sound editing interface. The Sound Element editor makes it possible to edit sounds that were 
created outside of Harmony and imported into your scene.

How to open the Sound Element editor

1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

The Sound Element Editor dialog box opens.

The Sound Element editor consists of three main parts.
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‣ Sound Element: The waveform in the Sound Element Editor is the actual sample that will be 
heard when the final movie is rendered. It may be shorter than the original sound sample 
due to the length of the scene. If any edits are made to the sound sample, they can be heard 
here. In the Sound Element panel, notice the coloured tabs that indicate the start and end 
frames of a sound segment. The frame number is displayed in the tab.

‣ Current Sound: Displays the original sound file in its entirety and is where you can edit its 
properties. This window remains empty until you click inside the Sound Element Editor.

‣ Lip-sync Preview: Lets you preview the automated detection and to manually insert 
different mouth positions to correspond with the sound sample. 

You can accomplish the following tasks in the Sound Element Editor:

• Changing the Start or End Frame of a Sound below

• Trimming the Start and End of a Sound File on page 292

• Looping a Sound on page 293

• Mixing the Sound Volume on page 294

• Customizing the Playback Range on page 295

• Recomputing the Mouth Chart on page 304

Changing the Start or End Frame of a Sound
To synchronize the sound with specific images in your scene, you must set a start frame for your 
sound. To make sure the sound ends by a certain frame, you must set an end frame.

In the Sound Element panel you will see some coloured tabs, these tabs represent the frames. The 
frame number is shown inside the tab flag marker. These tabs indicate the start and end frames of a 
sound segment.
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How to change start or end frame of a sound

1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

2. In the Sound Element Editor, select a sound sample from the Sound Element panel. To distinguish 
one sound section from another on the same sound layer, check the frame numbers that appear on 
tabs flanking the start and stop lines of each waveform section.

Click the Play  button in the Current Sound panel (only the selected sound plays).

3. Within the Sound Element panel, drag the selected clip to the frame number where you want it to 
start playing. 

You can only move the clip to a section that does not already contain a clip; you cannot overlap two 
clips in the same element.

4. To change the end frame, drag the yellow marker at the end of the waveform to the frame 
position.
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5. To hear how all the clips fit together in the element, click the Play  button  in the Sound Element 
panel.

If you only want to hear the selected clip, click the Play  button  in the Current Sound panel.

6. Click Apply/Next.

The Xsheet and Timeline views display the sound clip at the start frame you selected.

Trimming the Start and End of a Sound File
To play only a section of a sound file, use the Sound Element Editor to select the exact part you want 
to use. For example, if there is a bit of noise at the start of the sound, use the Sound Element Editor to 
cut the noise. 

The Sound Element Editor does not change the original sound file; it only plays a section of it, ignoring 
the rest. This means that the entire sound file is included on export. If you need to be mindful of file 
size, it is better to edit sound files completely in a sound editor before bringing them into Harmony.

How to trim the start and end of a sound file

1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.
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2. In the Sound Element Editor, select a sound sample from the Sound Element panel. To distinguish 
one sound section from another on the same sound layer, check the frame numbers that appear on 
tabs flanking the start and stop lines of each waveform section. Or select a soundwave and click 
the Play  button in the Current Sound panel (only the selected sound plays).

3. Using the Current Sound panel, decide on the part of the file you want to play by dragging the left 
and right boundaries of the selection area.

4. Click the Play  button in the Current Sound panel to check that you have trimmed the desired 
sections. Use the Zoom slider at the bottom of the panel to zoom in on the waveform so you can 
trim it more accurately.

5. Click Apply/Next. 

The trimmed sound sample appears in both the Timeline and Xsheet views at the start and end 
positions you selected.

Looping a Sound
To repeat a sound, specify the number of times that you want it to loop in the Sound Element editor.

How to loop a sound sample

1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

2. From the Sound Element panel, select the sound section you want to loop.

3. In the Current Sound panel, type the number of times you want the sound to play in the Number of 
Loops field.
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4. Press the Enter/Return key. 

The looped sound appears after the current sound. They are indicated by their grey waveforms, as 
opposed to black.

When you loop a sound, the looped sections fill the cells in the sound element (column or layer) 
until the next sound sample starts or until the scene ends. This means that the looping could be cut 
if the next sound sample starts too soon or if the scene ends too quickly.

Mixing the Sound Volume
You can adjust the volume of an entire sound clip or modify the volume in increments by adjusting the 
fade-in and fade-out times, otherwise known as sound envelopes. The fade edit only affects the 
playback; the original sound file is not affected.

How to adjust the overall volume of the entire sound clip

1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

2. In the Sound Element panel, select the sound you want to work on. 

A more detailed version of the selected sound appears in the Current Sound panel.

3. In the Current Sound panel, use the Volume slider to adjust the volume.

4. Click the Play  button in the Current Sound panel to verify the volume.

How to create the fade in/out effect on a sound clip

1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

2. In the Sound Element panel, select the sound you want to work on.

3. In the Current Sound panel, click on the thin blue line above the waveform to add an envelope 
marker.
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4. Drag the envelope markers to adjust the volume at that frame and to create the time of the 
transition. The line from the edge of the clip to the envelope marker identifies how the volume 
increases (fades-in) or decreases (fades-out) over time.

Dragging the marker to the bottom of the channel mutes the volume, while dragging it upwards 
increases the volume. 

To create an even effect, be sure to adjust the envelope markers uniformly in both the left and right 
(bottom and top) channels.

5. Click the Play  button in the Current Sound panel to check the fade envelopes.

Customizing the Playback Range
To hear a specific section of the sound element, adjust the playback range in the Sound Element Editor 
to start or stop at specific frames. This customized playback range does not affect the actual sound in 
the Sound element. 

How to change the playback range in the Sound Element Editor 

1. Drag the start or end range markers in the Sound Element panel to the boundary frames you want.
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2. When you click the Play  button to play back your sound in the Sound Element editor, it only 
plays the sound which exists between the two markers.
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Adding an Empty Sound Layer

When performing sound editing tasks, it can be useful to chop up a sound sample into different layers. 
For example, when performing a lip-sync, only a single view of the various mouth positions for a 
character can exist on one layer. Therefore, if you want to have a character turn its head from a profile 
view to a three-quarter view and have mouth position changes to fit with the sound sample from these 
two different views, you would need to cut up the sound samples needed for the profile view mouth 
positions on one layer and the sound samples needed for the three-quarter view on another.

For this task, you will need an empty sound layer. 

How to add an empty sound layer

1. From the top menu, select Windows > Toolbars > Timeline View. 

The Timeline view toolbar appears at the top of the Timeline view.

2. Right-click on the Timeline View toolbar and select Customize.

3. Choose the Add Sound  button from the Available Tools column on the left and add it to the 
Toolbar column on the right. Click Ok to accept the change.

4. Click the Add Sound  button.

An empty (silent) sound layer appears in both the Timeline and Xsheet views.

5. Rename the layers accordingly by double-clicking on the layer name and renaming it in the Sound 
Element Editor. Click Apply/Next to accept the change.
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6. Click the cell where you want to start the cut and Shift + click on the final cell of the cut. The sample 
to be cut becomes highlighted.

7. Drag the selection into the empty sound layer below.

8. You can now continue to cut-up and distribute the sound sample between the two layers or carry 
on to the lip-synching process for each layer and its corresponding facial view.

If you need to duplicate your sound layer to keep an unedited copy for safety, select the Duplicate 
Selected Layers button in the Timeline View toolbar. You must customize the toolbar to display this button 
because it is not included in this toolbar by default.
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Lip-sync

Adding a lip-sync to a project can really enhance its quality and storytelling. However, it can be difficult to 
shape a character's mouth to match the sound at a precise frame. 

To solve this problem, Harmony provides a lip-sync feature which analyzes the contents of a sound 
element and generates a mouth chart (see below) based on the eight animation phonemes (A, B, C, D, 
E, F, G, and X, which is used to represent silence).

The mouth shapes used by Harmony are based on the conventional mouth chart used in the animation 
industry.

The letters used to represent the shapes do NOT correspond to an actual sound.

If you are doing cut-out animation, refer to the Cut-out Animation Guide, Character Building chapter, 
"Adding Extra Drawings" topic to learn how to add extra drawings to your character.
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Here is an approximation of which sound each mouth shape can produce:

• A: m, b, p, h

• B: s, d, j, i, k, t

• C: e, a

• D: A, E

• E: o

• F: u, oo

• G: f, ph

• X: Silence, undetermined sound

You can lip-sync the traditional way or let the system automatically create the basic detection. 

You can refer to the mouth chart positions as you draw the shape of your character's mouth. 

Generating a Lip-sync Detection
There are two places where you can perform a lip-sync detection: Timeline or Xsheet views and Sound 
Element Editor.
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How to generate a  sound detection for lip-sync using the Xsheet or Timeline view

1. To show the mouth chart letters, if they are not already present in the Xsheet view,right-click on 
the sound column and select Lip-Sync > Sound Display > Mouth Shapes from the pop-up menu. 

2. In the Xsheet view or Timeline view, right-click on the sound layer's cells and select Lip-Sync > Auto 
Lip-Sync Detection. You can also select Animation > Lip-Sync > Auto Lip-Sync Detection from 
the top menu.

Harmony analyzes the selected sound clips and assigns a lip-sync letter to each frame. The X 
markers in the frame are replaced by these designated letters.

How to generate a sound detection for lip-sync using the Sound Element Editor

1. Do one of the following:

‣ In the Timeline view, double-click on the sound layer.

‣ In  the Xsheet view, double-click on the sound column header.

The Sound Element Editor opens.

2. In Sound Element panel, select the waveform for which you want to generate a mouth chart.

3. Right-click on the sound file and select Auto Lip-Sync Detection.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync 
letter to each sound cell.

Mapping the Lip-Sync Detection
Harmony can automatically map drawings in an element to the mouth chart you have generated for a 
sound. This can save time when you are lip-synching a voice track.

In the Lip-Sync Mapping dialog box, you can identify each lip drawing of a character. Harmony then 
automatically labels all of the cells in the character's element with the appropriate name.

How to automatically map lip-sync drawings to a mouth layer

1. To open the Lip-Sync Mapping dialog box, do one of the following:
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‣ In the Timeline view, right-click on any cell in the sound sample layer and select Lip-Sync > 
Map Lip-Sync. 

‣ From the top menu, select Animation > Lip-Sync > Map Lip-Sync.

The Lip-Sync Mapping dialog box opens.

2. From the Destination Layer menu, select the layer that contains the mouth positions for the 
character's voice track. 

3. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on 
the layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you 
want to use the drawings or select the desired symbol from the drop-down menu.

4. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the 
phoneme it represents. If your drawings are already named with the phoneme letters, you do not 
have to do anything.

5. Click OK. 

6. Press the Play  button in the Playback toolbar to see and hear the results in the Camera view. 
To play back your scene with sound, enable the Sound  button in the Playback toolbar. 

Modifying the Lip-sync
You can change the mouth position assigned to a frame if you think another position is more 
appropriate. 

For example, you may have a character who says nothing for 10 frames between two speeches. 
Harmony would normally assign an X image for the silent period. However, if you want your 
character's mouth to hang open in astonishment for these 10 frames, you can change the lip 
assignment for these frames from an X to an F.
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You can also change the mouth assignment of a sound in the Sound Element editor.

How to change the lip assignment of a sound in the Xsheet

1. Right-click in the cell that contains the mouth position you want to change.

2. From the pop-up menu, select Lip-Sync > Change Mouth Shape to and choose the letter that 
reflects the mouth position you want to use for that sound. You can also select Animation > Lip-
Sync > Lip-Sync > the desired mouth shape from the top menu.

The drawing is automatically updated in the Camera view.

How to change the mouth position assignment of a sound from the Sound Element 
editor

1. Double-click the sound layer name in the Timeline view or the sound column header in the Xsheet 
View to open the Sound Element editor.

2. In the Sound Element panel, drag the frame slider to the frame you want to change the mouth 
position assignment on.

In the Lip-sync image area, the image on top represents the lip position assigned to the current 
frame. 

3. To change the image assigned to the frame, click on the image of the mouth position you want 
from below the preview image. The preview image changes to the mouth position image you 
select. You can perform the same operation in the Layer Properties view.

The position is updated in the Timeline and Xsheet views.

Note that if you modify the lip-sync detection you must remap the detection to your mouth latyer. See See 
"Mapping the Lip-Sync Detection" on page 301
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Recomputing the Mouth Chart

When you generate the mouth chart for a sound in a sound element, you can either accept the mouth 
positions assigned by Harmony or assign your own lip-sync images.

However, if you change the sound's start frame or reassign its mouth position, you must reanalyze the 
sound and regenerate the mouth chart for it. This erases any manual modifications you may have made 
to the mouth assignments in the mouth chart.

To recompute the mouth chart for a selected sound from the Sound column

1. In a Sound column in the Xsheet or Timeline view,right-click on a cell that contains the sound file you 
want to recompute the lip-sync for. Select Lip-Sync > Auto Lip-Sync Detection from the pop-up 
menu. The mouth position assignment for each frame is recomputed, erasing any modifications you 
have made.

To recompute the mouth chart for a selected sound from the Sound Element Editor

1. Double-click the sound layer name in the Timeline view or the sound column header in the Xsheet 
view to open the Sound Element editor.

2. Click on the waveform in the Sound Element section in the Sound Element editor.

3. Right-click and select Auto-Lip Sync Detection. 

Manual Lip-sync
Harmony allows for the manual swapping of mouth position drawings to match a voice track. For this 
process, both sound scrubbing (listening to a soundwave broken up frame-by-frame) and drawing 
substitutions from the Library View are used.

How to perform a manual lip-sync

1. In the Playback toolbar, enable the Sound Scrubbing  button.

2. In the Timeline view, drag the red position indicator along the sound layer waveform.

3. When you reach a frame where a mouth position should go, for example, an open mouth with 
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

4. In the Timeline view, click on the Expand  button to display the Data view. 

5. Staying on your mouth shapes layer, place your cursor on top of the drawing name (often a letter) 
until it changes to the swapping  pointer.

6. Pull the cursor to see the list of mouth shape names and choose the one you want. The current 
drawing automatically changes to the new selection.

You can also use the Library view to swap drawings.

How to perform a manual lip-sync using the Library view

1. In the Playback toolbar, enable the Sound Scrubbing  button.

2. In the Timeline view, drag the red playhead along the waveform of your sound layer.
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3. When you reach a frame where a mouth position should go, for example, an open mouth with 
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

4. In the Drawing Substitution window of the Library view, click and drag the slider to choose a mouth 
shape. The current drawing is swapped for the one in the preview window.
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Exporting a Sound File

At some point during the production, you might need to export a sound file to use it in another 
application, such as an editing software. Harmony allows you to export sound files as a merged 
soundtrack or as a series of individual files. The exported soundtracks are generated as *.wav files.

How to export a soundtrack

1. From the top menu, select File > Export > Soundtrack.

The Export Soundtracks dialog box opens.

2. In the Output section, click Browse and specify where you want to save the exported sound file.

3. In the Export Range section, select one of the following options:

‣ All: Exports the sound over all the frames of your scene.

‣ Frames: Sets the start and end frames in the corresponding fields on the right.

4. From the Options menu, select one of the following:

‣ Process Soundtracks Individually: Each soundtrack from all layers is exported as individual 
files.

‣ Merge all Soundtracks: One single file is created, combining all the sound files you 
imported in your scene. Note that it will only use the sound files in the selected frame range 
set in the Export Range section. If you selected to export all the frames, all the sound files 
will be processed.

5. In the Sound Settings section, set the Rate, Size and Use parameters for the soundtracks to 
export. It is a good idea to verify what is required by the software or device that  you may want to 
use next with the sound file.

6. Click OK.
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The generated sound files appear in the selected directory and are named according to the scene 
name. Individual files keep their original name; only a prefix matching the scene name is added.
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Chapter 6: 2D-3D Integration

Harmony provides you with impressive 2D-3D integration possibilities. This allows you to combine the 
two animation genres within the same production resulting in some remarkable scene composition 
and a unique style.

Harmony supports the following 3D formats:

• 3DS

• OBJ

• FBX

• OSB

You can work with Autodesk Maya, PIXIE, or 3Delight. In this guide, Autodesk Maya will be used. To 
work with PIXIE or 3Dlight, contact support@toonboom.com.

All Harmony licenses include the 3D functionality by default. If you obtained your license at the initial 
release of Harmony, you might not have the 3D license. If you are unable to work with 3D elements, contact 
support@toonboom.com.

This chapter contains the following topics:

• How 2D-3D Integration Works on the next page

• Exporting a 3D Object for Harmony Using Autodesk Maya on page 315

• Importing a 3D Object from Autodesk Maya to Harmony on page 318

• Working in the Different Views on page 312

• Manipulating the 3D Object on page 320

• Rendering and Compositing 3D Models on page 325

• Rendering 3D Models on page 332
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How 2D-3D Integration Works

Harmony allows you to import 3D models and reposition them in Harmony and animate them over 
time. 

Importing a Reference Model 
When working in Harmony, the first thing to do is import a reference model. This model is what will be 
represented in the OpenGL view.  Animators can reposition this model, animate the camera, and 
interact with it.  Although several formats are supported, FBX is the recommended format as this will 
allow you to embed textures for nicer looking reference models.  

The following chapters show you how to import such a model and animate it in Harmony.  

When importing an FBX model, remember that model will never be used for the final render.  Harmony 
itself does not have a 3D rendering engine embedded.  

Rendering of the OpenGL representation of the model is supported. However, this is not a high 
enough quality for a final product. Instead, rendering is supported through outside rendering engines.  
The majority of users use Maya Softrender, although 3Delight and Pixie are also supported. 

Because this model is never used for a final render, you can optimize this model quite a bit.  The 
imported FBX model does not require high-res textures or sophisticated shaders.  It can even have a 
lower poly count than your final model.  It does, however, need to be the same size as your final model, 
as Harmony will be sending the position, rotation, and scale information of the model in the Harmony 
scene to Maya later to render.  Keeping the imported FBX file as light as possible will give you snappy 
performance while animating. 

Rendering
When it comes to rendering, a connection is opened between Harmony and the rendering engine - in 
this case Maya Softrender.  
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Maya Batch is opened in the background, and the information from the Harmony scene file is sent to 
Maya.  All the information needed, including the animation on the model and the position of the 
camera, is sent to Maya.  Maya Batch then opens in the background and the original .mb file is opened.  
This file should match the FBX model in size, but may have a higher polygon count, a more advanced 
texturing setup, or even a more advanced set of shaders.  Since the full Maya scene is loaded, you can 
use any shader, lighting setup, and texture that Maya Softrender supports.   

The opened scene file repositions the model inside based on the information provided from the 
Harmony scene file.  For consistent lighting effects, you may want to parent the lighting rig to the 
model so it is also repositioned along with the model.    

The frame is then rendered and sent back to Harmony to be composited there.  The data comes back 
into Harmony as a series of Maya .iff images.  These images contain not just image data, but also 
depth information, and Harmony will use this depth information to properly clip any 2D layers that are 
interacting with the 3D model in the Harmony scene, resulting in a perfect composite without the need 
to track any masks. 

You can also apply any effects that are supported on bitmaps to the rendered sequence, such as blurs 
and blending modes.   
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Working in the Different Views

Before you can properly view and set up the 3D element in your scene, you will need to use the 
Perspective and Camera views together, as well as the Top and Side views. 

• Perspective View below

• Camera View below

• Top and Side Views on the facing page

Perspective View

In the Perspective view, you can see your scene in a complete 3D environment. This environment will 
allow you to setup and animate your 3D model more easily. You can rotate the view on the three axes. 

How to rotate the Perspective view

1. Hold down ⌘  + Alt (Mac OS X), and click and drag.

Camera View

You can preview the position of your 3D model in the Camera view and see what it will look like in the 
camera frame. You can preview your scene in  OpenGL  mode.
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Before you can view your 3D elements in Render  mode , you must add a script module to your 
Network view and set up your system with the correct path to the rendering utility you will be using. If 
you do not complete this setup, the 3D model will simply not appear.

Top and Side Views

You can use the Top and Side views to help you position your element in the 3D environment. This can 
really help you precisely visualize the actual position of your model without perspective.

313



Chapter 6: 2D-3D Integration     Top and Side Views

314



Harmony 11.1 Compositing Guide (Network)

Exporting a 3D Object for Harmony Using Autodesk Maya

Once you set up Toon Boom Harmony and your system for the use of 3D, the next step is to generate 
the 3D models you plan to import and use in your scene. You will need to use Autodesk Maya for this. 
Although FBX models can be exported from any software and imported into Harmony, at the 
moment, only Maya is supported for full rendering with effects.

How to export a 3D object for Harmony

1. In Autodesk Maya, create your 3D object.

You should also complete the texturing of your 3D object, as well as set up a few lights in your 
scene. When you render your scene later through Harmony, it will use this original Maya scene to 
render with the shaders, textures, and lighting of the scene.

When you animate the object in Harmony, it will use this scene file and push the animation from Harmony 
into this scene. For this reason, you may want to parent the lights to the object, so the lighting you set up 
moves with the object when it is animated. If not, you may end up with a situation where the object is 
rotated out of the lighting, and you can see a very dark 3D object. In Maya, you can parent one layer to 
another by middle-mouse clicking and dragging that layer.

2. Save your Maya binary file *.mb as you will use it later on.

3. Use the export command to export your model. Select File > Export All.
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The Export All dialog box opens.
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4. In the Files of Type menu, select FBX Export.  

5. Select the Embed Media option to see the textures on the model when you import the FBX model 
into Harmony.  

6. From the Type list, select Binary. 

7. From the Version list, select FBX 2012.

8. When you complete the export, an *.fbx file will be created.

Instructions may differ depending on the version of Autodesk Maya you are using. It is therefore 
important that you refer to their documentation for the correct instructions on how to create and 
export a 3D model.
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Importing a 3D Object from Autodesk Maya to Harmony

Once you have exported a model in using Autodesk Maya, you can import it into Harmony and 
integrate it to set up your 2D animation scene.

How to import 3D model(s) from Autodesk Maya to Harmony

1. In Harmony, select File > Import > 3D Models.

The Import 3D Models dialog box opens.

2. Click Browse and locate your *.fbx files.

3. Click Open to validate your choice and close the browsing window.

4. In the Import 3D Models dialog box, choose your import options.

‣ Create Layer(s): This option is selected by default, meaning that a new layer will be created 
for the selected files for the import. You have two choices.

‣ Create Single Layer Named: Imports all your selected *.fbx files in the same layer you can 
name.

‣ Create Layer(s) Based on Filename: Creates a different layer for each file selected for the 
import. The layers will be automatically named in accordance with the file names.

‣ Add to Existing Layer: Imports the selected files into an existing layer in the scene. Use the 
drop-down menu to select a layer.

If you choose to add to an existing layer which is a vector layer, then it will encapsulate the 3D model inside 
a symbol.

5. Click OK  to validate your choices and import the selected file(s).

The 3D models are imported in the scene.
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Note that, if at this point, the Preview mode is set to Render View  mode, then the 3D model will not be 
visible in the Camera view. If this is the case, click the OpenGL View  button, you should now be able to 
see your 3D models.

Using Peg Modules to Control the Position of 3D Objects

You can use Peg modules to control the position of 3D objects, and connect them as you would with 
2D layers to create rigs. 
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Manipulating the 3D Object

Once you have imported the 3D model into your scene, you can easily manipulate it to set up your 
scene. You can even add keyframes, just like any other element and animate it on a trajectory.

Using Transformation Tools to Manipulate 3D Models
Once the 3D option is enabled, your transformation tools automatically become 3D transformation 
tools. This means that you can now manipulate them on the Z-axis as well. The Translate , Rotate 

 and Scale  tools are found in the Advanced Animation toolbars and the Transform  tool can 
be found in the Tools toolbar. You can use these tools to set up or animate your 3D model. 

If you want to set up the position of your 3D model, you must disable the Animate  mode. Do not forget 
to re-enable it when if you want to animate it.

Translate Tool
Once you enable the 3D option, the 3D Translate tool becomes available. Direction arrows appear 
around the pivot points to indicate the different axes.

 

If you click on a direction arrow, you can move a layer on only one axis. If you click anywhere else, the 
layer can move freely on two axes at once. Once the arrow is selected, it turns pink.
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If you move the layers in the Perspective view, it may be difficult to control the motion since you may not 
have the optimum point of view on your stage to understand the setup. In this case, it is best to use the 
direction ellipses.

 

Rotate Tool
Once you enable the 3D option, the 3D Rotate tool becomes available. A rotation sphere appears 
around the pivot points to indicate the different axes.

You can click on the direction ellipses to rotate your layer on one axis only. If you click anywhere else, 
the layer rotates freely on two axes at once. Once the ellipse is selected, it turns pink.
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If you move the layers in the Perspective view, it may be difficult to control the motion since you may not 
have the optimum point of view on your stage to understand the setup.

Scale Tool
Once you enable the 3D Option, the 3D Scale tool is available. You will see one of two things:

• A Scaling Rectangle, this appears if your drawing is flat.

• A Scaling Cube, this appears if your object has some rotated layers around the pivot points, 
indicating the different axes. If you click and drag on this Scaling Cube, it will scale proportionally 
on all axes.

Click on one of the three control points to scale the shape on one axis. Hold down the Shift key to 
scale the object proportionally. When the control point is selected, it turns pink.

If you move the layers in the Perspective view, it may be difficult to control the motion since you may not 
have the optimum point of view on your stage to understand the setup.
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Transform Tool

Once you enable the 3D Option, the 3D Transform tool become available. This tool is a combination 
of the 3D Translate, 3D Rotate and 3D Scale tools.

• Translating an Element with the Transform Tool below

• Rotating an Element with the Transform Tool on the next page

• Scaling an Element with the Transform Tool on the next page

Translating an Element with the Transform Tool

To translate an element, grab the direction arrows in the same way that you would with the Transform
 tool.
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Rotating an Element with the Transform Tool

To rotate an element, grab the rotation ellipses in the same way that you would with the Rotate  
tool.

Scaling an Element with the Transform Tool

To scale an element, grab the scaling control points in the same way that you would with the Scale  
tool.

If you click and drag on the scaling cube, it will scale proportionally on all axes.

You can also set up all these position parameters using the Layer Properties dialog box—see 3D Parameters 
on page 175.
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Rendering and Compositing 3D Models

There are  two ways to preview and render 3D elements in Toon Boom Harmony. You can render your 
scene using the OpenGL preview, or render calling Autodesk Maya, PIXIE or 3Delight in the 
background.

If you do not set up a plug-in to preview your model with Maya or your 3D software, the preview and 
rendering will be done using the OpenGL preview. The result will look flat and jagged, but it can be 
very handy while working and exporting shots for approval.

If you render a scene calling Autodesk Maya, PIXIE or 3Delight, you will obtain a smooth result with 
texture and lighting.

Before you can render the 3D objects you imported in Harmony through Autodesk Maya soft render, 
you must prepare your system by setting some environment variables, and adjusting the Network view 
in Harmony.

This section is very technical; if you need help, or experience problems while setting up the 3D 
rendering, please contact the Toon Boom Support team at support@toonboom.com.

Preparing the Project Directory

How to set up rendering

1. Copy your original Maya binary file  *.mb into your Harmony project directory at the same location 
as the *.fbx file you have imported. This *.fbx file should be in the elements folder, inside a 
subfolder named like the element. For example: if the element is called PirateShip,the the 
subfolder should be named PirateShip.

You saved the Maya *.mb file in Exporting a 3D Object for Harmony Using Autodesk Maya on page 315 of 
this document.

2. Rename the *.mb file so it has the same name as the *.osb file. 
For example: if the *.fbx is called PirateShip-1.fbx, name the *.mb as PirateShip-1.mb.
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3. Copy any textures used in the Maya project into this same folder.

Setting the Path on Windows
The path needs to be set up so that when Harmony launches Maya, it knows exactly where to look for 
the application.  On Windows, this can be set up using an environment variable.

How to set up the environment variable on Windows

1. In Windows, go to Start.

2. Right-click on Computer and select Properties.

3. From the Computer Properties dialog box, select Advanced System Settings.

The  System Properties dialog box opens.
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4. In the System Properties dialog box, click Environment Variables.

The Environment Variables dialog box opens.

5. The first variable to set up is the Maya path. In the System Variables section, browse for the Path 
variable and select it.

6. Click Edit.

The Edit System Variable dialog box opens.

7. In the Variable value field, add a semicolon (;) at the end of the last path.

8. Copy the path to the bin folder of Maya following the semicolon. 

For example: For Autodesk Maya 2011 on Windows, the path would be as follows: 

C:\Program Files\Autodesk\Maya2011\bin

You can browse to the installation folder of Maya and copy the complete path to the bin folder from the 
explorer browsing window to make sure you have the exact path.

9. Click OK.
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If you receive an error readout in the command line when you try to render, contact Support at 
support@toonboom.com and provide the error readout content.

Setting the Path on Mac OS X
The Path needs to be set up so that when Harmony launches Maya, it knows where exactly to look for 
the application.  On Mac, you can set this up by placing a script in usr/bin.

Creating and Setting Up the Script on Mac OS X

Follow these steps to create the script to call Maya and to set it up. 

Contact Support at support@toonboom.com if you experience any problem while creating the script and 
setting it up or 3D rendering.

From the Terminal, you must create a file in which to save the script. 

How to create the script and set it up

1. Switch to the directory in which you want to create the script file:

cd /usr/bin

2. If the bin directory does not exist, then create it:

mkdir /usr/bin

3. Create the script file called maya:

sudo vim maya

4. Type in your password to grant administrator access.

5. From inside the text editor, select "i" to go to Insert Mode, and copy and paste the following 
text. Make sure the path is updated to the version of Maya you have running on your machine.

#!/bin/bash

exec /Applications/Autodesk/maya2014/Maya.app/Contents/MacOS/Maya "$@"

6. Save and exit by typing:

Esc :wq

7. Edit the file to make sure all users can access it. Type the following:

chmod ugo+x maya

Setting Up the Environment Variable on Mac OS X

Follow these steps to set up the environment variable on Mac OS X. 
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Contact Support at support@toonboom.com if you experience any problems while setting up the 
environment variable or 3D rendering.

How to set up the environment variable on Mac OS X

1. Using Terminal, open the folder Mac OS X. This is a hidden folder, so you need to open it using the 
line: 
cd; open .MacOSX  

2. If the folder does not exist, create it by typing the following:

mkdir .MacOSX

3. Navigate to the Mac OS X folder and create the environment.plist file. 
You can use the following lines:

cd .MacOSX/touch environment.plist

sudo vim environment.plist

4. Type in your password to edit the file.

From inside the text editor, type "i" to go to Insert Mode.

5. Copy or type the following text into the environment.plist file:

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" 
"http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

        <key>TOONBOOM_MAILBOX</key>

        <string>7778</string>

        <key>PATH</key>

        <string>/usr/local/bin:/bin</string>

</dict>

</plist>

6. When you have finished copying the text into the plist file, type Esc :wq to save and quit the vi 
text editor.

If you receive an error readout in the command line when you try to render, contact  
support@toonboom.com and provide the error readout content.

Creating and Setting Up the Script on Mac OS X

Follow these steps to create the script to call Maya and to set it up. 

329

mailto:support@toonboom.com?subject=Problems with Environment Variable Set up
mailto:support@toonboom.com?subject=Error Readout in Command Line when Trying to Render 3D


Chapter 6: 2D-3D Integration     Rendering and Compositing 3D Models

Contact Support at support@toonboom.com if you experience any problem while creating the script and 
setting it up or 3D rendering.

From the Terminal, you must create a file in which to save the script. 

You may create this file in either /usr/local/bin or ~/bin.  If you save it in usr/local/bin, then 
all users will be able to render on that machine. If you create the file in ~/bin, then only the current 
user will be able to render from that machine.

How to create the script and set it up

1. Switch to the directory in which you want to create the script file:

cd /usr/local/bin

2. If the bin directory does not exist, then create it:

mkdir /usr/local/bin

3. Create the script file called maya:

sudo vim maya

4. Type in your password to grant administrator access.

5. From inside the text editor, select "i" to go to Insert Mode, and copy and paste the following 
text:

#!/bin/bash

exec /Applications/Autodesk/maya2012/Maya.app/Contents/MacOS/Maya "$@"

6. Save and exit by typing:

Esc :wq

7. Edit the file to make sure all users can access it. Type the following:

chmod ugo+x maya

  Setting Up the Network View
Now that your environment variables have been properly set up, the final step is to prepare your 
network to call the Autodesk Maya rendering utility. Once this is done, you can render the 3D objects 
in your Harmony project and preview them in the Camera view in Render View  mode. This will 
allow you to composite your 3D scene and effects.

There are two types of script modules that work with the Harmony-Maya connection:

• Render Maya Batch
This module uses the script renderMayaBatch();

This script starts a Maya Batch session, renders the 3D elements on that frame, and then closes the 
session. It will open and close the session for every frame to be rendered.
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• Render Maya Batch Server
This module uses the script renderMayaBatchServer();

This script starts a Maya Batch session that stays open so that when you render 3D objects 
through multiple frames, it does not close the session between each of them.

How to prepare the project network

1. Start Toon Boom Harmony.

It is recommended that you  run it from the command line. This way, you will have a printout of the 
process as it renders. Once it is started, you might also want to display the Message Log view.

2. In the Network view, locate the 3D object module.

3.        In the Module Library view, select the RenderMayaBatch or RenderMayaBatchServer module 
and drag it to the Network view.

4.        In the Network view, hold the Alt key down while dragging the Maya Render module right under 
the 3D object module to connect it.

5. Repeat the previous steps for each 3D object module in your scene.

6. Save and reload your scene so that Autodesk Maya files can be retrieved from the project folder.

7. In the Camera view, click the Render View  button.
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All the elements of your scene appear in this complete preview of the rendered scene.

8. If you want to add effect filter modules to your 3D object, make sure to connect them right under 
the Maya render module.

You are now all set to render your animation project.

If it does not render as expected, run Toon Boom Harmony from the command line and see if you received 
an error readout when clicking the Render View button. Email this information to: 
support@toonboom.com.

Rendering 3D Models
When batch rendering 3D models originating from Maya, some unwanted artifacts may appear, 
particularly on models with outlines. This is due to problems with the depth information. You can use 
the Z-Buffer Smoothing module to smooth out the edges. 
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How to render 3D models

1. In the Module Library, select the 3D tab. 

2. Select the Z Buffer Smoothing module and drag it to the Network view.

3. In the Network view, place it between a MayaBatchRender module and the final Composite 
module.

4. Display the Z Buffer Smoothing module properties. 

333



Chapter 6: 2D-3D Integration     Rendering and Compositing 3D Models

5. Adjust the Histogram Range and Kernel Size parameters to achieve the optimal rendering of your 
Maya models. In most cases, you will have to experiment with a balance between the histogram 
range and the kernel size.

 

Z Buffer Smoothing Module Properties

Parameter Description

Histogram Range

Lets you define the range of clean pixels in the depth histogram 
when rendering 3D models.  Only opaque or semi-transparent 
values are considered.  

A low value means fewer pixels are used in the depth 
calculations and may flatten your object, while a higher value 
uses more pixels in the depth calculations, but may not 
eliminate all the image artifacts.

Kernel Size

Lets you determine the size of the matrix used for calculating 
the depth of a single pixel.  For example, for an operation with 
a kernel size of 3 pixels, Harmony uses the pixels within a 1-
pixel radius to calculate the effect. A larger kernel size means 
longer calculations.
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Chapter 7: Effects

Once your animation is completed, you can add effects such as blurs and glows to make your project 
look even better! Harmony provides you with a series of essential effects that you can add to your 
layers.

This chapter contains the following topics:

• Adding Effects  on the next page

• Animating an Effect Over Time  on page 347

• How Does an Effect  Work?  on page 351

• Using Effects  on page 353

• Particle Effects on page 491

• Extra Commands  on page 588
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Adding Effects 

In Harmony, to add an effect, you will use the Network view. You can add an effect module to your 
network, drag modules from the Module Library view, and connect them to the associated drawing 
elements and adjust the parameters.

This topic is divided as follows: 

• Network View  below

• Module Library View on page 341

• Importing a Module  on page 342

Network View 
In the Network view, you can connect effects and compositing modules to form a network, also known 
as a node system. This view is very useful for rigging puppets, creating advanced effects and having a 
clear view of complex scenes. The organization and order of the modules determines the flow of data 
during the compositing process and how your animation elements will be composited.
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Symbol Stack

When entering symbols, the Symbol Stack lets you navigate back to the top and see the hierarchy of 
the symbol in which you are working.

Node System

The main area of the Network view is the node system area where you can add and organize 
different modules to represent a scene.

Navigator

The Navigator view lets you pan the visible area to move quickly through extensive node sets.

Search Toolbar

The Search toolbar is used to find and match a module in the project. The search is not case-
sensitive. Once you have entered characters in the search field, press Enter/Return to validate and 
find the pattern in the module names. If successful, the module is selected and centred in the view. If 
many instances are found, use the Previous and Next buttons to cycle through each node.
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Group Navigation

When entering a group, the Group Navigation allows you to navigate back to the top and see the 
hierarchy of the group in which you are.

Modules

There is a series of modules available to compose the network. Here are some basic types and 
information about the main modules.

1. Drawing Module 
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This is an example of an average module, a simple drawing module that represents a layer in the 
Timeline view. This module has an input port (top) that allows information to flow through it. It has 
an output port (bottom) that exports its information in a downward flow. On the left is a yellow box 
that displays the module's property editor, where you can adjust its parameters. Lastly, there is a 
dark arrow that displays a thumbnail of the module's contents. 

2. Write and Display Modules 

Both the Write and Display modules do not have output ports. This is because the information that 
flows into them can go no further in the network. The Write module records the images and renders 
the final output. The Display module captures the visual information and outputs it to the Camera 
view.

3. Composite Module 

The Composite module combines multiple source images (drawing and effect modules), including all 
transformations and effects, into a single bitmap or vector image for each frame.

The Composite module layers the images based on the composition order rule. First, the Z-values of 
the elements are analyzed to determine depth. When multiple elements have the same Z-value, the 
Depth values in the drawing modules are used. If the Depth values are also the same between 
elements, the composition order is determined by the cable order of modules on the Composite 
module. By default, modules connected to the right are rendered below those connected to the left. 
You can override this default in the Composite module editor—see Composite Module on page 141. 
The Composite module is an example of a module that can have an infinite number of input ports 
that can take in multiple, individual sources of information. The leftmost input port on the 
Composite module is always green. This lets you know that, in terms of stacking order, whatever is 
plugged into this port will appear on top of the composite after the Z-depth is taken into account. 
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4. Effect Module

An Effect module can often have two input ports. The right input port is for the drawing layer that is 
to be acted upon by this effect, while the left port is usually reserved for a matte.

5. Matte Drawing 

A matte, also called mask, is the shape that will be used by the effect module to modify the original 
image. The effect will only be applied where the matte overlaps with the original image. Sometimes 
the matte will act as a negative shape that the effect will exclude. This all depends on the nature and 
editing properties of the effect.

6. Position Ports

Some effects contain three input ports. If they are green, then they require a Peg module connection 
(coordinate and value information). In the case above, the effect can accommodate two pegs.

7. Peg Module 

The Peg modules control the transformation of elements (position, scale, skewing and rotation) over 
time. The green ports at the top and bottom of the module indicate that it accepts position 
information and can then pass this information on.

One peg can be used to control many different modules or one module can accept more than one 
peg. In a situation like the latter, one peg might be used to modify the rotation, while the other used 
to modify the position of the effect and then animated differently over time. 
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Module Library View
If you need to add new effects and other modules to the Network view, you will need to get them from 
the Module Library.

When you create a new project in Harmony, the default network that appears in the Network view 
looks similar to the one below. 

Module Library View Toolbar

In the Module Library View toolbar, you can change how the effects are displayed. 
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•  View as Icons

•  View as List

•  View as Icons with Names

Module Tabs

The Module Library is conveniently broken up into several sections or tabs:

• 3D: Includes the modules related to working with 3D models within Harmony.

• Deformation: Includes the modules needed for building a deformation chain, as well as 
advanced effects such as Fold and Auto Muscle.

• Favorites: Includes the most common modules. To add extra modules to the Favorites tab, 
select any module from any other section and drag it onto the Favorites tab.

• Filter: Effect modules, such as blurs.

• Group: Modules for grouping, like Group modules and Multi-Port modules.

• IO: Includes Display, Drawing, Write and Note modules.

• Move: Modules for changing elements over time, like Peg modules, as well as certain 
transformations.

• Particle: Includes all the modules necessary to construct complex particle systems.

• Particle-Examples: Includes a series of examples of particle effects.

• Plug-ins: Includes plug-in modules.

• All Modules: Lists all of the modules available.

Importing a Module 
To bring a module into the Network view, drag it from the Module Library and drop it in the Network 
view. Once in the Network view, you can click on the input or output port of a module and drag out a 
cable. You can then connect this cable to the output port or input port of another module.
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If you want to connect a module between two connected modules, you can use the Alt key as you drag 
the new module over the existing cable connection. Using the same Alt key, you can also disconnect a 
module.

If you want to remove a module, select and press Delete to remove it from the Network view.

Adding Effects Through the Timeline View       
Although all effects should be added through the Network view, there are two effects that can be 
quickly added through the Timeline view. These effects, Colour Card and Quadmap, can also be 
added through the Network view in the usual manner. In addition, there is a special way of grouping 
elements that can only be done through the Timeline view. 

How to add effects in the Timeline view

1. In the Timeline view, click on the Add Layers  button and from the Layers drop-down menu 
select the desired effect that you would like to add. 

2. The effect appears in the Timeline view. The Colour-Card does not require to be parented to any 
layer.

3. For the Quadmap, drag the drawing layer onto the Quadmap layer to parent it.

4. In the Timeline view, double-click on the Quadmap layer to open the Layer Properties view.

5. In the Layer Properties view, adjust the parameters.
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Once you have set the parameters for your effect, you can store it in the Library view as a template so you 
can quickly reuse it later on without having to set the parameters again.
Refer to  learn more about creating templates.

Grouping from the Timeline View

There are several advantages to using the Group Selection With Composite command (only found 
through the Timeline view) over the simple Group Selection (which references both the Group layer in 
the Timeline view and the Group module in the Network view.

One of the advantages that this command has is that it groups all the selected elements into a neat 
module that has a nested composite. This means that there is only one connection coming out of the 
Group module. With the simple Group module or command, the Group displays the same number of 
connections as elements in the group. Both grouping commands display the same structure in the 
Timeline view.
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The Group Selection With Composite command should only be used before any work has been done 
in the Network view and it recommended for objects whose stacking order is of no consequence.

Using the Group Selection from Composite command on elements that have effects, have been tweaked in 
the Network view, or whose stacking order is of consequence, may cause the grouped elements to lose their 
properties once grouped in this way. In addition, though you may only select a few modules to group, if 
there are other layers in the timeline that exist between the selected layers, they will automatically be 
grouped, even if not selected.

How to group selected elements using the Group Selection With Composite com-
mand

1. In the Timeline view, in the layers section, select the elements that you wish to group. 

Any layers between the selected layers will automatically get grouped as well, so if the stacking 
order is of no consequence, move extra layers either above or below the layers that you wish to 
group. 

2. Right-click on one of the highlighted layers and from the pop-up menu select Group Selection With 
Composite. 

3. The layers appear indented under a new Group layer in the Timeline view and in a new Group 
module in the Network view. 
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Previewing Effects

Most effects must be rendered so you can preview them properly. Some effects can be displayed in 
the OpenGL view, but most of them must be rendered and previewed in the Render Mode of the 
Camera view.

How to preview effects

1. In the Camera view status bar, click the Render Mode  button.

In the bottom-right corner of the Camera view, the progress bar indicates the status of the 
rendering. Depending on the size of the frame to render, it may take several seconds.

Once you preview your effect, you may want to adjust it. By default, as soon as you modify a 
parameter, Harmony will recalculate the preview image. If your scene is heavy and you do not want 
preview rendered automatically, you can disable the Auto-Render option and request the preview 
update yourself.

How to disable the Auto-Render option

1. In the Camera view status bar, click the Auto-Render  button.

Once the Auto-Render option is disabled, you must request the preview update by clicking the 
Auto-Render  button.

How to manually update the rendering preview

‣ In the Camera view status bar, click the Render button.

Note that you cannot play back your animation in Render mode. You must perform a render or a preview 
render to see your animation with the final effects.
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Animating an Effect Over Time 

In Harmony, to animate an effect over time, create a function curve by adding keyframes to the 
parameters you want to animate. To do this, you will use the Layer Properties view and the Timeline 
view. You can fine tune your animation using the Function view.

How to animate an effect over time

1. In the Timeline view, add the effect and connect the layers to it. See Adding Effects Through the 
Timeline View        on page 343.

2. Select the Effect layer.

3. To create the function curve:

‣ In the Layer Properties view, click on the Function  button you want to animate to 
create a function curve.

OR

‣ You can also expand the effect layer's parameters in the Timeline view by clicking on the 
Expand  Function button and add a keyframe using the F6 key to the parameter you 
want to animate.

4. In the Timeline view, click on the Show Data View  button.

5. In the Timeline view, go to the frame where you want to start animating the effect.

6. In the Data view, click on the Add Keyframe  button.
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7. In the Value field scroll to the keyframe value or type the value in the field.

‣ If your keyframes are stop-motion keyframes, in the Timeline view, select the new 
keyframes. Right-click on the selection and select Set Motion Keyframe.

8. Repeat this process for each keyframe to be added.

When compositing your scene, it will often happen that you want to animate the parameters of an 
effect over time. You may want to have an object fading in or out by changing the transparency level 
over time or increasing the colour contrast on one of your drawings over a certain frame range.

To animate an effect over time, create a function curve by adding keyframes to the parameters you 
want to animate. To do this, you will use these views: Layer Properties,  Network and Timeline. You 
can fine tune your animation using the Function view.

 How to animate an effect over time

1. In the Network view, drag an effect module from the Module Library view and to the Network 
view.

2. Plug the effect between the drawing element on which you want to apply the effect and a 
composite module. You can do this by manually unplugging and plugging, or by holding down Alt 
as you drag it through a connection. 
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The effect should also appear in the Timeline view.

3. To animate the value of the parameter, you must create a function curve and add keyframes on it. 
For example, you can set the Blur-Radial effect to have no blur on the first frame and become very 
blurry by the end of the scene by animating its Radius parameter. Do one of the following to create 
the function curve:

‣ In the Layer Properties view, click the Function  button you want to animate to create a 
function curve.

‣ Expand the effect layer's parameters in the Timeline view by clicking the Expand Function 
 button and press F6 to add a keyframe to the parameter you want to animate.

4. In the Timeline view, click the Show Data View  button.

5. In the Timeline view, go to the frame on which you want to start animating the effect.

6. In the Data view, click the Add Keyframe  button.

7. In the Value field, scroll to the keyframe value or type the value in the field.
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‣ If your keyframes are stop-motion keyframes, in the Timeline view, select the new 
keyframes. Right-click and select Set Motion Keyframe.

8. Repeat this process for each keyframe to be added.

Refer to the Previewing and Playing Back Effects  on page 586 to learn how to preview animated effects.
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How Does an Effect  Work? 

An effect always needs a drawing connection and sometimes a matte or shape connection. A matte 
provides drawing information that determines the area on which the effect will be applied on the 
drawing. The details and colours within the matte drawing do not matter, as the system will only use 
the shape and transparencies in it. A matte is also known as mask.

The matte principle can be demonstrated with the Tone effect.

The drawing layer is connected to the right port of the effect and the matte (mask) on the left. The 
Tone effect then applies darker colours where the matte overlaps the image, blurs the tone edge, and 
finally clips out the extra tone zone outside the drawing before outputting a final drawing with a tone.

You can adjust the tone's parameters in the Layer Properties view and link any of them to a function 
column to be animated over time. This means that all of the effects can be customized.
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Using Effects 

Here is the list of the main effects available in Harmony. Each effect and how to use it is described in 
the corresponding section.

• Anti-Flicker  on the next 
page

• Apply Peg Transformation 
on page 355

• Apply Image 
Transformation on page 360

• Auto Patch on page 362

• Blending  on page 364

• Blur - Box on page 370

• Blur - Gaussian on page 375

• Blur-Directional  on 
page 372Blur-Directional  on 
page 372

• Blur - Radial   on 
page 377Blur - Radial   on 
page 377

• Blur - Radial Zoom on 
page 379

• Blur-Variable on page 386

• Brightness and Contrast  on 
page 385

• Channel Selector  on 
page 387

• Channel Swap on page 389

• Chroma-Keying on page 390

• Colour-Art  on page 394

• Colour Banding on page 396

• Colour-Card  on page 398

• Colour-Override  on 
page 399

• Colour-Scale  on page 416

• Contrast  on page 422

• Contrast  on page 422

• Cutter on page 424Cutter 
on page 424Cutter on 
page 424

• Dither  on page 425

• External  on page 426

• Focus  on page 429

• Focus Multiplier  on 
page 431

• Glow  on page 432

• Glue  on page 434

• Gradient  on page 436

• Grain  on page 438

• Greyscale  on page 440

• Grid / Field Chart on 
page 442

• Highlight  on page 446

• Hue-Saturation on page 449

• Image Switch on page 452

• Layer Selector  on page 454

• Lens Flare on page 456

• Line Art on page 458

• Matte-Blur  on page 459

• Matte-Resize  on page 462

• Motion-Blur  
on page 466

• Multi-Port-In  
on page 467

• Multi-Port-
Out  on 
page 468

• Negate on 
page 469

• Note  on 
page 470

• Overlay 
Layer  on 
page 471

• Pixelate  on 
page 473

• Placeholder  
on page 474

• Quadmap  
on page 474

• Refract  on 
page 476

• Remove 
Transparency 
 on page 478

• Shadow  on 
page 479

• Sparkle  on 
page 482

• Tone  on 
page 484

• Transparency 
 on page 487

• Turbulence 
on page 572

• Turbulent 
Noise on 
page 576
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• Underlay 
Layer  on 
page 488

• Visibility on 
page 489

For more information:

•  Composite Module on page 136, Composite Module on page 141 and Managing a Network 
with a 3D Scene Setup on page 197.

•  Display Concepts on page 157.

•  Rendering Images and Movies from the Network on page 614 and Multiple Renders on 
page 606.

•  Locking Flat Drawings to the Camera Angle on page 195.

•  Animating a Camera Shake Using the Quake Module on page 224.

•  Particle Effects on page 491.

• Rendering 3D Models on page 332.

Anti-Flicker 

Use the Anti-Flicker to compensate for flickering in your output to TV formats. The Anti-Flicker effect 
applies a vertical blur to the rendered output. You should place the Anti-Flicker before a Write module 
in the Network view.
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Use the Anti-Flicker editor to control the amount of blur that is applied to rendered output. In the 
Radius field, enter a value for the number of pixels to be considered in the blur.

Apply Peg Transformation

Use the Apply Peg Transformation module to apply a transformation coming from a Peg, Ortholock, 
or Quadmap module on a single module or a group of modules. When using the drawing layer's No 
Clipping option, you can use this module to apply all Camera and Peg transformations once all of the 
effects and modules connected above the drawing module are calculated.

You can use this effect module to create a simple highlight on a cut-out puppet or use the No Clipping 
option available in the drawing layer.
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The No Clipping option, found under the drawing Layer Properties' Advanced tab is used when you 
do not want to crop your images before all effects are applied to your drawing. No camera motion or 
peg transformation will be applied to your drawing until you connect an Apply Peg Transformation.

Refer to Positioning an Element Using the Layer Properties  on page 108 to learn more about the drawing 
layer's Advanced tab.

The advantage of this module is that you can create a second output of your image or puppet and 
offset it, scale it or apply any kind of transformation on it.

The transformations set in the Peg, Ortholock, or Quadmap module connected to the Apply Peg 
Transformation module are applied BEFORE the image is composited.

Here is an example of how to connect the Apply Peg Transformation module:

The transformation set in the Peg module from the example above is applied before the image is 
composited, which is the equivalent of the following network:
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In the following images you can see the result of the transformation without the Apply Peg 
Transformation module and with it:

Using the Apply Peg Transformation you can apply transformation on drawings that are outside the 
camera frame and make them appear inside the frame.

If you are using the Apply Image Transformation module to create a drop-down shadow for a 
character, it will work correctly so long as the character is not going outside of the camera frame or 
that the drawing connected in it is a VECTOR drawing. The reason is the Apply Image Transformation 
module applies the transformation once the drawing is rendered, moved by its own set of Pegs, 
motion paths and quadmap and cropped to the camera frame size. This crop operation does not 
occur if the drawing is a vector drawing (*.TVG). Although, as soon as the drawing is passed through 
an effect module or a bitmap type Composite module, the drawing is turned into a bitmap image and 
gets cropped.

So, if you offset a bitmap half inside and half outside the camera frame, the outside part is cropped 
out and then moved by the Apply Image Transformation module. A part of the original drawing is cut. 
You need to use the Apply Peg Transformation module for the transformation to be applied before 
the image is processed and cropped.
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Advanced Apply Peg Transformation 

You can use the Apply Peg Transformation's middle port to apply the transformation you connected 
to the module after one of the Peg or Quadmap connected above the drawing module.

In the following example, two pegs were added to control the different motions on independent 
trajectories:
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• Peg-Translation

• Peg-Scale

When there is no Apply Peg Transformation module, the Peg-Translation is the first trajectory to 
affect the drawing module. Then, once the translation is applied, the Scale trajectory affects the 
drawing module.

When using an Apply Peg Transformation module without using the middle port, the Peg-Rotation 
connected in the APT module is applied at the top of everything. The order in which the trajectories 
are applied to the drawing module is:

1. Peg-Rotation

2. Peg-Translation

3. Peg-Scale 

When the Peg-Translation is connected in the Apply Peg Transformation's middle port, the Peg-
Rotation is applied after the Peg-Translation and before the Peg-Scale. This means that the translation 
is done before the rotation instead of the rotation before the translation.

The order in which the trajectories are applied to the drawing module is:

1. Peg-Translation

2. Peg-Rotation

3. Peg-Scale

Use the Apply Peg Transformation editor to rename the module.
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Apply Image Transformation
The Apply Image Transformation effect is mainly used when you want to pan an object out of the 
camera frame and that object has an effect such as a Glow or a Blur on it. When you use a peg or the 
Apply Peg Transformation module to translate an object such as the sun out of the camera frame, as 
soon as the sun starts to go outside of the camera frame, the sun's circle is cropped and the blur is 
applied on the shape left over. This also means that when the sun is completely out of the frame, the 
Blur is not calculated anymore and the Blur pops out.

To prevent this from happening, you must use the Apply Image Transformation module to pan the sun 
out.

The Apply Image Transformation module applies the panning transformation once the full drawing of 
the sun is blurred, once the image is composited. Here is an example of this network:

Here is how to connect the Blur effect for a sun panning out:

Here is the visual result of the blurred sun:
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Look at the following example to understand better why using the Apply Image Transformation 
instead of a regular peg or the Apply Peg Transformation module.

The normal rendering behaviour is to crop the image before applying the effects. When planning a 
sunset using either a Peg or the Apply Peg Transformation module, as soon as the drawing of the sun 
is out of the camera frame, the drawing is cropped and there is no image left to blur. This means that 
the glowing edge pops out of the camera instead of panning out gradually. Using the Apply Image 
Transformation module, the image is blurred before being panned out, so this means that even once 
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the drawing is out of the camera frame, its glowing edge will still show until the drawing is far enough 
from the camera border. This way, there is no pop when panning out blurred objects.

Use the Apply Image Transformation editor to change the name of the module.

Auto Patch

The Auto Patch module is used mainly when creating joint patches for cut-out puppets drawn with 
pencil lines and painted in the Colour Art layer. Instead of removing a portion of the outline to attempt 
to create a seamless joint, you can draw complete pieces, and with the Auto Patch module, 
automatically create a perfect articulation.

The requirements for this effect to work are:

• Drawing outlines must be drawn in pencil lines

• Drawing outlines must be drawn in the Line Art layer

• Drawing fill colours must be painted in the Colour Art layer

Pencil lines are central vector lines. The vector is located along the centre of the line. This means that 
when you paint a zone delimited by a pencil line, the colour fill will expand to the centre of the pencil 
line.

When using the regular patch technique, recommended for the brush line, the result with pencil lines is 
very odd looking because the colour fill zone is bigger than the pencil line inner contour.

362



Harmony 11.1 Compositing Guide (Network)

Instead of using the regular patch method, you can use the Auto Patch module. It will automatically 
extract the Colour Art and clip it to the right size. Then, you can connect it in front of the piece to be 
covered.

The network connection for the Auto Patch is quite simple. Once your basic character rigging is done, 
you can add the Auto Patch module to the joints you want to cover. There is no need to set any 
parameters.
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Blending 

Effects modules, like the Tone module and Highlight module, can control the colour and alpha 
composite operations for you. These modules were created with pre-set colour and alpha composite 
operations to fit the most frequently used, composite operations.

You might, however, still want to control the colour and alpha composite operation between two 
images using the Blending module, to create a multiplicity of lighting, shadow, filter or ambient 
effects. The Blending module combines two images into one output image, following the parameters 
you choose for your movie and images sequence or SWF movie exports.

The drawing module connected to the Blending effect will act as the blending image and will be 
applied to all the drawing layers situated under them in the Composite module or Timeline view order.
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Blending Properties

Parameter Description

Name Use this field to rename the module.

Blend Mode and SWF Blend 
Mode

Choose the blending effect mode you wish to apply to your 
layer. The Blend Mode type will only be visible when the 
Camera view is set to Render  mode and will only export to 
a bitmap movie file or sequence of images.

Both the Blending module and Composite-Generic module 
have regular blending modes and legacy blending modes. The 
regular blending modes will take the source images and 
unmultiply them before blending the two inputs together. The 
images will be remultiplied when being output from the  
module. The legacy blending modes use the pre-multipled 
source images as is in order to apply the effect. Unmultiplying 
the images before processing them will give a final result closer 
to what can be found in software such as Adobe Photoshop.

• Normal: The layer attached to the effect acts as a normal layer 
and will not create any blending mode effect.

• Multiply: This operation multiplies the blending element colour 
with the output image. This will darken the colour of the 
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overlapping area.
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• Screen: This operation multiplies the inverted colour of the 
blending element with the image. This will lighten the colour 
of the overlapping area.

• Lighten (Lighten Legacy): This operation lightens the area 
of the output image which, is darker than the blending 
element’s colours. The lighter colours will remain 
unchanged.

• Darken: This operation darkens the area of the output 
image, which is lighter than the blending element’s colours. 
The darker colours will remain unchanged.

• Difference  (Difference Legacy): This operation subtracts 
the blending elements colour from the output image 
colours or vice-versa, depending on which of them has more 
bright colours. The final result will be colours that are more 
vibrant.

• Add (Add Legacy): This operation lightens the output 
image using the blending element.

• Subtract (Subtract Legacy): This operation darkens the 
output image using the blending element.

• Invert: This operation inverts the output image colours on 
the area overlapping the blending layer colours.

• Overlay (Overlay Legacy): This operation multiplies or 
screens the colours from the blending image, with those of 
the output image, depending on the base colour. Colours 
from the blending element overlay the colours of the 
drawing elements, while preserving the highlights and 
shadows of the base colour. The base colour is not 
replaced, but mixed with the blend colour to reflect the 
lightness, or darkness, of the original colour.

• Hardlight(Hardlight Legacy): This operation multiplies, or 
screens, the colours of the blending layer with those of the 
output image, depending on the blend colour. If the blend 
colour is lighter than 50% grey, the image is lightened, as if 
it were screened. This is useful for adding highlights to an 
image. If the blend colour is darker than 50% grey, the 
image is darkened, as if it were multiplied. This is useful for 
adding shadows to an image. Painting with pure black or 
white results in pure black or white. Play with the Opacity 
value to create a subtler look.

• Alpha: This operation will blend the alpha value of the 
blending layer with the output image. This effect is not 
available for SWF Blend Mode.

• Erase: This operation produces a cutter effect using the 
blending element. This effect is not available for SWF Blend 
Mode.

• Divide (Divide Legacy): This operation divides the output 
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image colour values by the blending layer colour values. The 
blending image colour values are inverted, creating a 
negative image. The negative image’s colour values are 
then multiplied by the right image colour values. This effect 
is not available for SWF Blend Mode.

• Replace: This operation replaces the output image by the 
blending layer. This effect is not available for SWF Blend 
Mode.

• Softlight: This operation darkens or lightens the colours in 
a soft and diffuse way, depending on the blend colour 
(image in left port). If the blend colour is lighter than 50% 
grey, the image is lightened. If the blend colour is darker 
than 50% grey, the image is darkened. Painting with pure 
black or white produces a distinctly darker or lighter area, 
but does not result in pure black or white. 

• Linear Light: This operation burns or dodges the colours by 
decreasing or increasing the brightness depending on the 
colour of the underlying colour. If the blend colour is lighter 
than 50% grey, the colour is lightened because the 
brightness is increased. If the blend colour is darker than 
50% grey, the colour is darkened because the brightness is 
decreased.

• Pin Light: This operation will replace the colours, 
depending on the underlying colour . If the blend colour is 
lighter than 50% grey, pixels darker than the underlying 
colour are replaced, and pixels lighter than the underlying 
colour do not change. If the blend colour is darker than 50% 
grey, pixels lighter than the underlying colour are replaced, 
and pixels darker than the underlying colour do not change.

• Vivid Light: This operation burns or dodges the colours by 
decreasing or increasing the brightness depending on the 
colour of the underlying colour. If the colour is lighter than 
50% grey, the blend colour is lightened because the 
contrast is decreased. If the colour is darker than 50% grey, 
the blend colour is darkened because the contrast is 
increased.

• Exclusion: This operation produces a similar result to the 
Difference mode, but with a lower contrast. 

• Dodge: This operation will lighten the colour.

• Burn: This operation will darken the colour.

• Hue: This operation will result in a colour that will take the 
luminosity and saturation of the underlying colour, and the 
hue of the source colour.

• Saturation: This operation will result in a colour that will 
have the same luminosity and hue of the underlying colour, 
and the saturation of the source colour.
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• Colour: This operation will result in a colour that will have 
the luminosity of the underlying colour, and the hue and 
saturation of the source colour.

• Luminosity: This operation will result in a colour which has 
the hue and saturation of the underlying colour, and the 
luminosity of the source colour. This mode is opposite to 
the Colour mode. 

It is possible to select two different blending modes in the same Blending effect layer, in the event that  you 
want to export your project to both a Bitmap and an SWF movie file with different results.
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Blur - Box

The Blur - Box effect  is a quick and easy way to create a blurring effect. The Box blur changes the 
colour value of each pixel based on the pixels next to it in the vertical and horizontal directions. The 
look of the blur is similar to the look achieved using Gaussian blur, but renders much faster. This effect 
is useful when a faster rendering time is important, and the quality of the blur is less important. Also, 
you can use a matte with this effect to isolate areas of the image.

For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/video-
tutorials/chapter/adam-phillips-harmony-effects.
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Blur - Box Effect Properties 

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements 
undergo a change of depth or scale. When this option is deselected, the 
effect's values remain unchanged regardless of any depth or scale 
changes. This option should be deselected when multiple drawings are 
composited and attached to this effect.

Repeat Edge Pixels

Makes the blur algorithm operate as if the pixel values beyond the edge 
of the layer are the same as the values of the edge pixels. This keeps 
edges sharp, preventing them from darkening and becoming more trans-
parent.

Blurriness Amount of blur applied to the layer.

Directional

Blurs according to the length, width, and angle you specify. For 
example, if a character is walking east, the blur may fall to the 
west.

Length: Length of the blur.

Width: Thickness of the blur.

Angle: The direction in which the blur is applied: sideways, up, 
down,  90 degrees, 45 degrees, and so on.

Radius

Size of the blur. The larger the value, the greater the strength or reach of 
the blur. The blur radius is affected by the drawing scale and camera pos-
ition. Click the Edit Curve button to change these values over time by 
adjusting the function curve.

Bidirectional Applies the blur on both sides of the pixel.

Fall Off

The distance where the blur fades from the edge of the image. Select a 
value between 0 and 1. A fall-off rate of 0 causes the blur to fade out 
slowly, distributing the blur evenly from the edge of the character to the 
farthest edge of the blur. A fall-off rate of 1 causes the blur to fade out 
quickly, so the blur is heaviest closer to the edge of the image.

Number of Iterations
The number of times the blur is applied to the image. A higher number of 
iterations creates smoother transitions between colours and increases 
the blur, but also increases render time.
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Blur-Directional 

The Blur-Directional effect creates the effect of a motion blur that pulls and smears the image from 
one contour edge to a different direction or angle. This effect is useful in creating the impression of 
speed, such as the streaks of colour that follow a car travelling at high speed.

Use the Blur-Directional editor to control the settings of the Blur-Directional effect.
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Blur-Directional Property Editor

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the 
elements undergo a change of depth or scale. When this option 
is deselected, the effect's values remain unchanged regardless 
of any depth or scale changes. This option should be 
deselected when multiple drawings are composited and 
attached to this effect.

Radius

Size of the blur. The larger the value, the greater the strength or reach of 
the blur. The blur radius is affected by the drawing scale and camera pos-
ition. Click the Edit Curve button to change these values over time by 
adjusting the function curve.

Falloff Rate

The distance where the blur fades from the edge of the image. Select a 
value between 0 and 1. A fall-off rate of 0 causes the blur to fade out 
slowly, distributing the blur evenly from the edge of the character to the 
farthest edge of the blur. A fall-off rate of 1 causes the blur to fade out 
quickly, so the blur is heaviest closer to the edge of the image.

Angle

The direction of the blur. Enter a value from 0 to 360.

0: Blurs the image to the west.

90: Blurs the image to the south.

180: Blurs the image to the east.

270: Blurs the image to the north.

Direction of trail
If you do not set an Angle for the direction of the blur, you can select a dir-
ection (north, south, east, or west) from this menu. The calculations for 
this feature are faster than the calculations for the Angle setting.

Ignore Alpha
Controls the leading edge of the blur. Deselect this option for a solid or 
hard leading edge on the blur.

Extra Final Blur
Adds a second blur after the Blur-Directional is created. If you have a Blur-
Directional that begins at 0 and gradually gets stronger, deselect this 
option to ensure a smooth progression.

Number of Iterations The number of times the blur is applied to the image. A higher number of 
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iterations creates smoother transitions between colours and increases 
the blur, but also increases render time.
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Blur - Gaussian

The Blur - Gaussian effect softens the image, reducing the amount of noise and detail. The look of the 
Gaussian blur is smooth, but does take some rendering time. This effect is useful when rendering time 
is less important, and quality is more important. Also, you can use a matte with this effect to isolate 
areas of the image.

For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/video-
tutorials/chapter/adam-phillips-harmony-effects.
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Blur - Gaussian Effect Properties 

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements 
undergo a change of depth or scale. When this option is deselected, the 
effect's values remain unchanged regardless of any depth or scale 
changes. This option should be deselected when multiple drawings are 
composited and attached to this effect.

Repeat Edge Pixels

Makes the blur algorithm operate as if the pixel values beyond 
the edge of the layer are the same as the values of the edge 
pixels. This keeps edges sharp, preventing them from 
darkening and becoming more transparent.

Blurriness Amount of blur applied to the layer.

Directional

Blurs according to the length, width, and angle you specify. For 
example, if a character is walking east, the blur may fall to the 
west.

Length: Length of the blur.

Width: Thickness of the blur.

Angle: The direction in which the blur is applied: sideways, up, 
down,  90 degrees, 45 degrees, and so on.

Blurriness Amount of blur applied to the layer.

Bidirectional Applies the blur on both sides of the pixel.
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Blur - Radial  

The Blur-Radial effect creates an effect that softens, fogs or obscures the image evenly in all directions. 
This effect is useful when you want to make cloudy images not realistically seen in detail, such as a 
drawing object that is farther back or in the background of your scene, usually blurry due to the laws 
of atmospheric perspective. Other uses include the general softening of objects such as snow, stars 
and shadows that do not naturally have a hard outline.

Use the Blur-Radial editor to change the values of the Blur effect.
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Blur-Radial Properties

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements 
undergo a change of depth or scale. When this option is deselected, the 
effect's values remain unchanged regardless of any depth or scale 
changes. This option should be deselected when multiple drawings are 
composited and attached to this effect.

Radius

Size of the blur. The larger the value, the greater the strength or reach of 
the blur. The blur radius is affected by the drawing scale and camera pos-
ition. Click the Edit Curve button to change these values over time by 
adjusting the function curve.

Quality
Select High for a slow and accurate operation or Low for a 
faster operation with a more raw look.
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Blur - Radial Zoom

The Blur - Radial Zoom effect creates blurs around a centre point, simulating the look of a zooming or 
rotating camera. You can use a matte to isolate the area of the image from which you want the effect 
to radiate from. For example, in the illustration below, a circular matte was created to mask the 
eyeball and a Negate effect was applied so the blur is outside the matte. Then the centre point was 
positioned on the character's iris, which is the centre of the matte.

For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/video-
tutorials/chapter/adam-phillips-harmony-effects.

How to use the Blur Radial Zoom

1. In the Camera view, enable the Render mode.

2. From the Module Library view, drag a Blur Radial Zoom module to the Network view.

3. Connect your drawing to the Blur Radial Zoom's right port.

4. Connect the Blur Radial Zoom module to the Composite module.
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5. Click on the Blur Radial Zoom edit button (yellow square) to open the properties panel.

6. In the Layer Properties dialog box, increase the Blurriness value.

7. In the Direction section, click on any of the direction presets to modify the blur spin or zoom.

How to create a radial-zoom blur around an isolated area

1. Connect a drawing and a background image to a Composite module.

2. Connect the Composite module to the Blur-Radial Zoom module.
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3. Connect a Blur-Radial-Zoom module to the Composite module and add the Write and Display 
modules.

4. Now you will need to create a matte to isolate an area of the image. In the Timeline view, click the 
Add Layers  button and select Drawing. Give the layer a name, such as Mask.

5. In the Drawing view, draw a filled shape. 

6. The blur should radiate outward from the mask. To do this, connect a Negate module to the 
mask. In the Negate properties, select the Negate Colour and Negate Alpha options. Deselect 
the Negate Colour Clamp to Alpha option. 
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7. Connect these modules to the rest of the tree. Your Network view should look like this:

8. Open the Blur - Radial Zoom property editor. 

9. From the Center section, select one of the following options:

‣ 2D Path: Lets you move the centre point visually in the Camera view.

‣ Separate: Lets you control the x and y axis by entering values in the fields or by moving the 
centre point in the Camera view.

10. Set a value for the Blurriness.

11. With the Blur - Radial Zoom module selected in the Network view, select View > Show > Control 
or press Shift + F11. 

A red centre point appears in the centre of the Camera view.
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12. In the Tools toolbar, select the Transform  tool.

13. Click the Animate Mode  button in the Tools toolbar if you want to create function curves to 
keyframe over time. Otherwise, values will be created for the duration of the scene.

14. Move the centre point to the desired position. In our example, the centre was moved to the centre 
of the mask.

15. In the Network view, select the mask you created. 

16. In the Camera view, move the mask to the desired position.

17. Continue to adjust the blur values until you achieve the desired effect.

Blur - Radial Zoom Effect Properties 
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Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements 
undergo a change of depth or scale. When this option is deselected, the 
effect's values remain unchanged regardless of any depth or scale 
changes. This option should be deselected when multiple drawings are 
composited and attached to this effect. 

Centre
Sets the point where the blur will apppear to be "zooming" out from. By 
default, the centre appears in the middle of the Camera view.

Type

2D Path: Lets you move the centre point visually in the Camera 
view.

Separate: Lets you control the x and y axis by entering values 
in the fields or by moving the centre point visually in the Camera 
view.

(x) and (y) Axis
When the Separate type of centre is selected, lets you individually set the 
x and y coordinates for the centre.

Path
When 2D Path is selected, indicates that the coordinates are confined to 
the image.

Blurriness Amount of blur applied to the layer.

Variation

Constant: An equal, constant blur is applied on all pixels.

Linear: A gradual blur is applied on all pixels.

Quadratic: An exponential blur is applied on all pixels.

Direction Lets you select preset blur types or create a custom blur.

Presets
A set of preset radial, zoom, and spiral blurs to get you started. You can 
then adjust the type to customize the blur.

Custom Create your own blur by entering a value for the direction of the blur lines.

Fall Off

The distance where the blur fades from the edge of the image. Select a 
value between 0 and 1. A fall-off rate of 0 causes the blur to fade out 
slowly, distributing the blur evenly from the edge of the character to the 
farthest edge of the blur. A fall-off rate of 1 causes the blur to fade out 
quickly, so the blur is heaviest closer to the edge of the image.

Bidirectional Applies the blur on both sides of the pixel.

Angle Quality

Affects the quality of the blur by defining how fine the reference 
radial grid is on the image.  This determines the width of all the 
wedges.   A higher quality yields achieve better results, but will 
be slower to render.

Radius Quality
Controls the quality of the blur. A higher quality yields better results, but 
will be slower to render.
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Brightness and Contrast 

The Brightness and Contrast effect is used to modify the brilliance or dullness of an image or to create 
a greater difference between the lights and darks of an image by increasing their respective 
intensities. This effect can be used when an image appears too flat. Increasing the brightness or 
contrast can give a drawing a more attractive and 3D quality. This can be useful if you want to push 
your background to the rear by making it look dull and flat and pulling your foreground elements to 
the front by giving them a higher contrast.

Use the Brightness and Contrast editor to change the values of the Brightness and Contrast effect.
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Brightness and Contrast Effect Properties

Brightness
A value that is less than 0 will darken the image; a value greater than 0 will 
brighten it. Attach a Bezier or Ease function to change the brightness 
over time.

Contrast
A value that is less than 0 will reduce contrast; a value greater than 0 will 
increase contrast. Attach a Bezier or Ease function to change the contrast 
over time.

Blur-Variable

Use the Blur-Variable effect to create a radial blur that varies within a single image based on the white 
and black values in the matte you supply. You can set one blur value for the black regions in the matte, 
and another blur value for the white regions. The blur value for each grey region is interpolated 
between your black and white blur settings.

The following example is a network for a Variable Blur effect. A black and white copy of the character 
was used to create the effect. Use the Blur-Variable editor to control the blur value for the white and 
black radius.
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Blur Variable Effect Properties

Black radius
The amount of blur to apply to the black (transparent) values in the 
matte. Higher values create more blur in the colour image's regions that 
correspond to the black matte region.

White radius
The amount of blur to apply to the white (opaque) values in the matte. 
Higher values create more blur in the colour image's regions that cor-
respond to the white matte region.

Quality
Select High for a slow and accurate operation or Low for a faster oper-
ation with a more raw look.

Keep inside source image This option confines the blur to the source image.

Channel Selector 

Use the Channel Selector effect to isolate one of the four colour channels of an image:
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Use the Channel Selector editor to choose which channel to isolate.
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Channel Swap

The Channel Swap effect lets you take the image information from one channel and use it in another 
channel to achieve interesting effects. You can extract the following: red, green, blue, alpha values, 
hue, saturation, lightness, and luminance, as well as turn the information on or off. 

For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/video-
tutorials/chapter/adam-phillips-harmony-effects.
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Channel Swap Effect Properties 

Parameter Description

Red, Green, Blue, and Alpha 
Channel From

Lets you select the image information you want to feed into the red, 
green, blue, and alpha channels. Full On sets all values to 255 and Full Off 
sets all values to 0.

Chroma-Keying

The Chroma-Keying effect lets you create an alpha channel (transparency zone) for your bitmap image 
or image sequence. For example, if you have a series of bitmap images with a character filmed on a 
green screen or blue screen, you can use this module to create an alpha channel based on the screen 
colour and cut it out from your image sequence.

The  Chroma-Keying  module MUST be connected to a bitmap image. The Chroma-Keying  will create 
an alpha channel that can be seen in the Camera view in the Matte Render Mode. To cut the 
background colour from your image, you will need to use a Cutter module.
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To obtain a better result than just extracting the raw colour, you can adjust some parameters such as 
the contour blurriness and the matte size. You can see all the options available in the  Chroma-Keying  
Properties window.
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• Red/Green/Blue/Alpha: In the Colour section, you can enter the RGB value for the colour to 
extract from your image. You can also click on the colour swatch to open the Colour Picker 
window and select a new window. To select the exact colour in your image, you can use the Eye 
Dropper found in the Colour Picker window and pick it directly in your image.

• Black Point: The Black Point parameter will increase the transparent (black) portion of the 
Chroma Key matte. This means that it will reduce the edge of the visible image.
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• Adjacent Pixels Per Pass: When blurring the matter edge's with the Blur Intensity parameter, 
the Adjacent Pixel parameter will blur the matte border with the next few pixels (amount 
indicated in the field) to create a nicer edge.
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• Threshold Matte: This option will apply a threshold (tolerance) to the selected colour to be 
removed. The Threshold amount is set in the Threshold field.

• Threshold: The Threshold value will increase or decrease the tolerance for the selected colour 
to be removed from the image. The higher the value is the more coloured pixels will be 
considered in the  Chroma-Keying  matte. The pixel colour value will not have to be such a close 
RGB value to the one selected in the colour swatch. The lower the Threshold value, the closer 
RGB value the pixels will have to be to the selected colour to be part of the matte.

• Cut Colour: If this option is enabled, the selected colour will be removed from the image and will 
leave a transparent zone so that you can see the background and other layers behind the image. 
If the option is disabled, the colour will remain, but an Alpha channel is created that can be used 
with any other modules requesting a Matte input.

Colour-Art 

Use the Colour-Art effect to isolate the Colour-Art in a layer. Placing a Colour-Art module after a 
drawing module in the Network view only displays the Colour-Art output. The Colour-Art module can 

394



Harmony 11.1 Compositing Guide (Network)

only be connected after a vector drawing layer or a vector type Composite module. Any bitmap 
information will not be processed.

This effect will only work if the user drew or painted something into the Colour-Art layer of the 
drawing.

 

Use the Colour-Art editor to control how the module renders the Colour-Art.

Colour-Art Effect Properties

Parameter Description

Antialiasing Quality

Smoothness setting applied to Colour-Art. Choose from Low (no anti-
aliasing), Medium Low, Medium and High (extensive antialiasing). The 
higher the setting, the greater the amount of antialiasing applied. Higher 
quality images require more time to render and more memory from your 
system. Use a lower quality when rendering a pencil test.

Antialiasing Exponent

Controls the extent of the area around the Colour-Art edges that is used 
in the antialiasing process. A higher value uses less area, resulting in 
sharper edges, while a lower value uses more area, resulting in softer 
edges. If the Antialiasing Quality value is set to Low (no antialiasing), this 
value is ignored.
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Colour Banding

In this example, a Colour Banding module has been connected to a fire created with particle effects.

Use the Colour Banding effect to add a colour banding visual effect to your elements. The module will 
associate a flat colour to the different regions of your element. These regions are delimited according 
the alpha values that are set up in the effect module and which will be recognized on the original 
element. You can use this effect to change the visual style of a particle module, for example, by giving 
it a more cartoonish look.

Use the Colour Banding layer properties dialog box to set up the colour banding effect.
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In the Colour Banding layer properties, you have four sections with which to set up the four different 
regions alpha and colour override values.

This is how the regions range are calculated.

• Region1: Threshold 1 to Threshold 2

• Region2: Threshold 2 to Threshold 3

• Region3: Threshold 3 to Threshold 4

• Region4: Threshold 4 to 100% alpha

1. Threshold 1: Use this first threshold field to determine the first region outer limit. A value of 0 
represent an alpha of 0 which is completely transparent. A value of 100 represents an alpha of 255 
which is completely opaque. If for example, you enter a value of 5 for the first threshold, the region 
of your element which is within the range of alpha going from 5% to the Threshold 2 value, will be 
coloured with the Area 1 colour value.

2. Red: Use this field to manually enter the value of red for the first region colour.

3. Green: Use this field to manually enter the value of green for the first region colour.

4. Blue: Use this field to manually enter the value of blue for the first region colour.
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5. Alpha: Use this field to manually enter the transparency value for the first region colour.

6. Colour: Click in this colour space to open the Colour Picker dialog box and select a colour for the 
first region.

7. Blur1: Use this field to add a blur effect to the edge of the first region.

The three other sections will set up the regions two, three and four.

Colour-Card 

The Colour Card is a solid background the same size as the camera. The Colour Card lets you fill the 
scene's background with a solid colour when there is no background image. If no background or 
colour card is added to the scene, the resulting export will appear with a black background.

By default, the Colour Card has a Z ordering value of 12 Backward. This puts the Colour card behind 
all elements that have a value lower than 12 Backward. Most of the time, the Colour card will appear 
automatically behind all the scenes elements as they are all set to 0 Backward, unless you have 
changed the Z ordering of the scene components. If so, the Colour Card will be in front of the 
elements that are pushed back to more than 12 fields backward.
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Colour Card Effect Properties

Parameter Description

Depth
The value used to determine composition order when the Z value of two 
elements is the same.

Offset Z
The front-back position of the Colour Card layer in 3D space. This value 
can be verified in the Top view.

Red/Green/Blue/Alpha

The colour and transparency of the Colour Card. You can also 
attach these parameters to function columns to change their 
values over time. 

Click the colour swatch to open the Colour Picker window and 
select a colour.

Colour Swatch Opens the Colour Picker where you can specify the colour.

Colour-Override 

The Colour-Override processes the colours in a drawing layer. The drawings in this layer must be TVG 
files.

Using this effect you can change colours from the palette without affecting the actual palette, swap 
clone palettes, replace a specific colour zone with a bitmap texture or hide and display selected 
colours.
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Use the Colour-Override effect to:

• Change colour values in drawings during the compositing process.

• Use colour values from a specific colour palette in the palette list.

• Establish the priority of override palettes in the palette list. For example, you may have different 
clones of the same palette, for example a daytime and nighttime version.

• Isolate specific areas of a drawing by selecting certain colours. For example, using specific 
colours to generate a matte for a glow effect.

• Hide certain colours.

Use the Colour-Override editor to set the colour override operations for TVG elements and their 
drawings.

Colour-Override Editor Interface
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The Colour-Override editor interface  is comprised of four sections: 

• Palettes below

• Colours below

• Palette Overrides below

• Colour Overrides on the next page

Palettes

This section displays the palettes in the palette list of the selected layer. Drag these palettes into the 
Palette Overrides section to re-order them. You can load additional palettes in the palette list from 
either your project, by clicking on The Palette  button, or your computer by clicking on the Browse 

 button.

• The Palette  button allows you to load a palette contained within the project hierarchy 
(Environment, Job, Scene and Elements).

• The Browse  button allows you to load a palette located outside the project hierarchy, 
anywhere on your system or server.

Colours

This section displays the colours swatches of the selected palette. Drag a swatch into the Colour-
Overrides section to change its value or drag it into the Selected Colours section to render only that 
colour.

Palette Overrides

This section forces the use of a particular palette or palette list order, during the composition process. 
You must drag palettes from the Palettes section to change their order. Harmony searches the 

401



Chapter 7: Effects     Channel Swap

palettes in the order that they appear in the palette list to find the colour values associated with the 
colour IDs of each image. To apply a different version of a colour palette, for example to switch from a 
day to a night palette, use the override section to change the order of colour palettes (you must be 
working with cloned palettes).

Colour Overrides

Drag a swatch from the Colours section to this section to override its value. You can also override a 
colour with a texture.

Overriding a Colour

With the Colour-Override module, you can change the colour of some swatches. To do so, from the 
Colours section, you must drag the colour swatch to modify to the Colour-Overrides section.

Several options are available to modify your colours.
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Once the swatch appears in the Colour-Overrides section, click on the Select Override Mode  button to 
right-click on the Override Colour word and select one of the following option in the drop-down menu:

• Colour not visible: Renders the selected colour invisible in the Camera view.

• New RGB only: Overrides the colour swatch while maintaining its original alpha value. You can 
select a new colour by pressing the eye dropper  button or clicking directly on the colour 
swatch and choosing a new colour from the Colour Picker window.

• New alpha only: Overrides the swatch's alpha channel while maintaining its original RGB values. 
You can select a new alpha value by pressing the eye dropper  button or clicking directly on 
the colour swatch and choosing an alpha value from the Colour Picker window.

• New RGBA: Overrides the swatch's colour and alpha values. You can select a new colour by 
pressing the eye dropper  button or clicking directly on the colour swatch and choosing an 
alpha value from the Colour Picker window.

Overriding a Colour With a Texture

With the Colour Override module, can apply a texture over a selected colour. Any zone painted with 
the selected colour swatch will be overridden by the selected texture.
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How to Apply a Texture Over a Colour

From the Colours section, select the colour swatch to override and drag it to the Colour Override 
section.

1. Once the swatch appears in the Colour Override section, select it and then click on the Select 
Override Mode  button to right-click on the Override Colour word and select one of the following 
option in the drop-down menu:

‣ Texture - Original Matrix

‣ Texture - Global Bbox Matrix

‣ Texture - Global Bbox Centered

‣ Texture - Contour Bbbox Matrix

‣ Texture - Scale to Screen

‣ Override With This Texture Centered on Overridden Objects Centre

‣ Texture - Use Input Peg

2. In the Colour-Override section, under the Texture Filename section, click on "Not used".

3. Browse for your texture file.

4. Click on the Open button.

There are different ways to apply the texture over your colour:
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The result will only be visible in the Camera view while in Render mode. In OpenGL mode, you will see your 
original colour.

The matrix position can be modified using the Edit Gradient and Texture  tool. To do so, your 
drawing zone must be painted with a gradient swatch or texture swatch.
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Texture - Original Matrix

Overrides the swatch's colour with a pattern or texture. You must right-click under the Texture header 
to bring up the Browser window to search for your texture. The texture's default matrix (fixed 
proportion and orientation) is mapped the full size of the bounding box of each colour area to be 
overridden.

Texture - Global Bbox Matrix

Overrides the colour with a texture that is scaled non-proportionally to the size of the bounding box 
encompassing the colour areas to be overridden. With multiple objects, it will look as though their fills 
were all traced and cut from the same piece of stretched or squashed fabric.

Texture - Global Bbox Centered

Overrides the colour with a texture that is scaled proportionally to the size of the bounding box 
encompassing all colour areas to be overridden. With multiple objects, it will look as though their fills 
were all traced and cut from the same piece of fabric.

Texture - Contour Bbox Matrix

Overrides the colour with a disproportionately scaled texture for each individual colour area. In other 
words, each fill area will not only have the texture scaled to its individual proportions, but also 
stretched or squashed to fit within its contours.

Texture - Scale to Screen

Disproportionately scales the texture to the output resolution before applying it as an override.

Override with this Texture Centered on Overridden Objects Centre

Overrides the colour with a texture that is centered in the bounding box encompassing all colour 
areas to be overridden. With multiple objects, it will look as though their fills were all traced and cut 
from the same piece of fabric. The texture will not be stretched or distorted. It will be tiled in 
proportion. The centre of the texture zone will be centered in the middle of the bounding box's 
centre.

With this option, you can connect a Peg in the middle port to apply a transformation on the texture's 
position. Refer to How to Animate a Texture Override with a Peg below to learn how.

Texture - Use Input Peg

Overrides the colour with a texture that is scaled non-proportionally to the size of the bounding box 
encompassing the colour areas to be overridden. With multiple objects, it will look as though their fills 
were all traced and cut from the same piece of stretched or squashed fabric.

With this option, you can connect a Peg in the middle port to apply a transformation on the texture's 
position. Refer to How to Animate a Texture Override with a Peg below to learn how.

How to Animate a Texture Override with a Peg

The advantage of being able to animate the texture is that it can be adjusted, scaled, rotated and 
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translated to follow the general motion of a character if you want the texture to follow instead of 
having the character moving across the fixed texture.

1. From the Module Library view, drag a Peg module and drop it in the Network view.

2. Connect the Peg module in the Colour Override's middle port. The green port will take the 
transformation of the Peg to modify the pencil texture's position.

3. In the Network view, select the Peg module.

4. In the Advanced Animation toolbar, select the Translate , Rotate  or Scale  tool.

5. In the Camera view bottom toolbar, enable the Render  mode.

6. In the Camera view, move the Peg's position. As you move it, you will see the texture getting 
modified. You can animate the position by adding position keyframes in the Timeline view. You can 
use the Random Fill function to quickly create a random shake.

Rendering Selected Colours Only

With the Colour-Override module, you can isolate some colours in your drawing and render those 
ones only.

How to Render Selected Colours

1. From the Colours section, drag the colour swatches to render and drop them into the Render 
Selected Colours section.
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You have to enable the Render Selected Colours option for the module to proceed with the operation.

Modifying a Texture Fill's Transformation

When you paint a zone with a bitmap texture swatch, you might want to modify the size or position of 
the texture's matrix at the compositing level. Maybe for an effect purpose you need to animate the 
position of the texture in a zone. With the Colour-Override module and a Peg, you can animate the 
texture.

How to Modify a Texture Fill's Transformation

1. From the Module Library view, drag a Colour-Override module and drop it in the Network view.

2. From the Module Library view, drag a Peg module and drop it in the Network view.

3. In the Network view, connect the Colour-Override module under the drawing module you want to 
animate the line for. Note that for a cut-out puppet, you would connect the Colour-Override under 
the final Composite, set as Pass-Through.

4. Connect the Peg module in the Colour-Override's middle port. The green port will take the 
transformation of the Peg to modify the pencil texture's position.

5. Click on the Colour-Override's yellow button to open the editor.

6. In the Colour-Override window, in the Palettes section, select the palette containing the bitmap 
texture swatch.

7. In the Colours section, select the texture swatch you used to paint the drawing and drag it to the 
Colour-Override section.
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8. Once the swatch appears in the Colour-Override section, select it and then click on the Select 
Override Mode button to right-click on the New RGBA word and select one of the following option 
in the drop-down menu:

‣ Override the colour's transformation:This option will override the initial texture's 
transformation (matrix) established when you painted the zones or modified with the Edit 
Gradient and Texture  tool. This transformation override will be done by modifying the 
Peg's position.

‣ Combine the colour's transformation:This option will combine the initial texture's 
transformation (matrix) established when you painted the zones or modified with the Edit 
Gradient and Texture  tool with the new position transformation you will create when 
modifying the Peg's position.

9. In the Network view, select the Peg module.

10. In the Advanced Animation toolbar, select either the Translate , Rotate  or Scale  tool.

11. In the Camera view bottom toolbar, enable the Render  mode.

12. In the Camera view, move the Peg's position. As you move it, you will see the texture fills getting 
modified. You can animate the position by adding position keyframes in the Timeline view.

409



Chapter 7: Effects     Channel Swap

Overriding a Colour with a Bitmap Image Sequence

In production, it will happen that you need to map a live action sequence or bitmap image sequence 
into a zone or over several zone. For example, you could have a mirror shattered in several pieces and 
you want to map in it the video or someone talking. You can paint the mirror pieces with a specific 
colour swatch and use the Colour-Override module to map the image sequence into the pieces. It can 
also be a single image without having to be an image sequence.

How to Override a Colour with a Bitmap Image Sequence

1. From the Module Library view, drag a Colour-Override module and drop it in the Network view.

2. In the Network view, connect the Colour-Override module under the drawing module you want to 
animate the line for.

3. Connect the Live Action or Bitmap Image Sequence module in the Colour-Override's left port. The 
left blue port will input the images into the colour zones.

4. Click on the Colour-Override's yellow button to open the editor.

5. In the Colour-Override window, in the Palettes section, select the palette containing the colour to 
override.

6. In the Colours section, select the pencil texture you used to draw your lines and drag it to the 
Colour-Override section.

7. Once the swatch appears in the Colour-Override section, select it and then click on the Select 
Override Mode button to right-click on the New RGBA word and select Texture - Use Image Input.
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8. In the Network view, select the bitmap image module.

9. In the Advanced Animation toolbar, select either the Translate , Rotate  or Scale  tool.

10. In the Camera view bottom toolbar, enable the Render  mode.

11. In the Camera view, move the Bitmap Image position. As you move it, you will see the texture fills 
getting modified. You can animate the position by adding position keyframes in the Timeline view.

Overriding a Texture on a Pencil Line

A pencil line can be drawn with a texture but also painted with a texture swatch. With the Colour-
Override module, you can either override either the pencil line's texture or texture fill and replace it by 
another one or you can also animate the texture's position.

With the Edit Gradient and Texture  tool, you can modify the size and position for both types of 
texture on a pencil line; the drawing texture and the filling texture. By doing that, you are actually 
modifying the texture's matrix.

Modifying a Texture Fill on a Pencil Line

When you paint a pencil line with a bitmap colour swatch, you can override the position of the texture 
fill using the Colour-Override module and a Peg.

How to Modify the Pencil Line Texture

1. From the Module Library view, drag a Colour-Override module and drop it in the Network view.

2. From the Module Library view, drag a Peg module and drop it in the Network view.
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3. In the Network view, connect the Colour-Override module under the Drawing module you want to 
animate the line for. Note that for a cut-out puppet, you would connect the Colour-Override under 
the final Composite, set as Pass-Through.

4. Connect the Peg module in the Colour-Override's middle port. The green port will take the 
transformation of the Peg to modify the pencil texture's position.

5. Click on the Colour-Override's yellow button to open the editor.

6. In the Colour-Override window, in the Palettes section, select the palette containing the colour to 
override.

7. In the Colours section, select the bitmap texture swatch you used to paint your lines and drag it to 
the Colour-Override section.

8. Once the swatch appears in the Colour-Override section, select it anMac OS Xd then click on the 
Select Override Mode  button to right-click on the New RGBA word and select one of the following 
option in the drop-down menu:
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‣ Modulate Pencil Texture Colour (replace transformation):This option will override the 
initial texture fill's transformation (matrix) established when you painted the line or modified 
it with the Edit Gradient and Texture  tool. This transformation override will be done by 
modifying the Peg's position.

‣ Modulate Pencil Texture Colour (combine transformation):This option will combine the 
initial texture fill's transformation (matrix) established when you drew the line or modified it 
with the Edit Gradient and Texture  tool with the new position transformation you will 
create when modifying the Peg's position.

9. In the Network view, select the Peg module.

10. In the Advanced Animation toolbar, select either the Translate , Rotate  or Scale  tool.

11. In the Camera view bottom toolbar, enable the Render  mode.

12. In the Camera view, move the Peg's position. As you move it, you will see the texture fill getting 
modified. You can animate the position by adding position keyframes in the Timeline view. 

 

Modifying a Pencil Texture

You can modify and animate a pencil texture's position using the Colour-Override module and a Peg 
module. This lets you create a shaky line style which is a very popular design style. The main issue with 
this style is that it works well in traditional and tradigital animation, when the artist draws the line 
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differently on each drawing, but it does not work in cut-out animation where the same drawing is used 
for the entire animation. The same issue happens when the same drawing is held for more than a few 
frames. The line moves during the animation, but stops moving during the drawing hold, which looks 
bad.

With the Colour-Override module, you can animate the position of the pencil line texture 
independently from the drawing exposure. Even if a drawing's exposure is held over several frames, 
the line will move.

How to Modify the Pencil Line Texture

1. From the Module Library view, drag a Colour-Override module and drop it in the Network view.

2. From the Module Library view, drag a Peg module and drop it in the Network view.

3. In the Network view, connect the Colour-Override module under the drawing module you want to 
animate the line for. Note that for a cut-out puppet, you should connect the Colour-Override under 
the final Composite, set as Pass-Through.

4. Connect the Peg module in the Colour-Override's middle port. The green port will take the 
transformation of the Peg to modify the pencil texture's position.

5. Click the Colour-Override's yellow button to open the editor.

6. In the Colour-Override window, in the Palettes section, select the penstyle_opacity palette.

7. In the Colours section, select the pencil texture you used to draw your lines and drag it to the 
Colour Overrides section.
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8. Once the swatch appears in the Colour-Override section, select it and click the 
Select Override Mode  button to right-click on the New RGBA word and select one of the 
following:

‣ Change Pencil Texture Transformation: Overrides the initial pencil texture's 
transformation (matrix) established when you drew the line or modified with the Edit 
Gradient and Texture  tool. This transformation override will be done by modifying the 
Peg's position.

‣ Modulate Pencil Texture Matrix: Combines the initial pencil texture's transformation 
(matrix) that was established when you drew the line or modified with the Edit Gradient and 
Texture  tool with the new position transformation you will create when modifying the 
Peg's position.

9. In the Network view, select the Peg module.

10. In the Advanced Animation toolbar, select the Translate , Rotate  or Scale  tool.

11. In the Camera view bottom toolbar, select the Render  mode.

12. In the Camera view, move the Peg's position. As you move it, you will see the pencil texture getting 
modified. You can animate the position by adding position keyframes in the Timeline view. You can 
use the Random Fill function to quickly create a random shake. 
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Colour-Scale 

The Colour-Scale effect offsets an images colours. This effect is useful in creating ambient transitions, 
such as from daytime to nighttime.

Use the Colour-Scale editor to set the colour scale effect by entering a value in the scale fields.
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The actual colour values of the image are not changed; instead, the channels are multiplied by a 
selected amount. For example:

• If you enter a value of 1, the colour values do not change.

• If you enter a value greater than 1, you increase the colour channel value closer to 255 (or white).

• If you enter a value less than 1, you decrease the colour channel value closer to zero (0 or black).

You can set the colour scale value by entering a value in the field. You can also change the values of the 
colour scale effect over time by attaching it to a Bezier or Ease function curve  and adding 
keyframes.

Composite-Generic 
During the composition of images, colour and alpha values of an input image are combined with the 
image underneath to produce the output image. 

Effects modules, like Tone and Highlight, can control the colour and alpha composite operations for 
you. A Composite module was created, in which the colour and alpha composite operation are preset 
to the standard, and more frequently used, composite operations.

You may, however, still want to control the colour and alpha composite operation between two 
images using the Composite-Generic Module which combines two images into one output image. The 
image linked to the left port of the module is layered on top of the image in the right port based on 
the selected colour and alpha composite operation.

Use the Composite-Generic editor to control the calculation of colour and alpha values during the 
composition process.
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The following abbreviations are used in the descriptions of composite operations:

• ORGB: RGB values of the Output Image

The Output Image is the resulting image from a composite operation. In the formulas for the 
composite operations, this image is also processed through a composite operation, representing 
the bottom layer in the composited image.

• LRGB: RGB values of the Left Image

• RRGB: RGB values of the Right Image

• LA: Alpha of the Left Image

• RA: Alpha of the Right Image

• OA: Alpha of the Output Image

Composite-Generic Effect Properties

Parameter Description

Colour Operation

The colour values of the output image are determined based 
on the alpha and colour values of the left and right image.

Both the Blending module and Composite-Generic module 
have regular blending modes and legacy blending modes. The 
regular blending modes will take the source images and 
unmultiply them before blending the two inputs together. The 
images will be remultiplied when being output from the  
module. The legacy blending modes use the pre-multipled 
source images as is in order to apply the effect. Unmultiplying 
the images before processing them will give a final result closer 
to what can be found in software such as Adobe Photoshop.

Right: The colour values in the output image are derived from 
the image in the right port. Colour values in the left port are 
ignored.

Left: The colour values in the output image are derived from 
the image in the left port. Colour values in the right port are 
ignored.

Apply With Alpha: ORGB=[RRGB*(1-LA)]+LRGB. This is a 
standard composite operation called "alpha blending." During 
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this operation, colour values of the left and right images are 
combined based on the alpha value of the left image. Where 
the left image is completely opaque (LA=1), the ORGB will be 
replaced completely with LRGB. Where the left image is 
completely transparent (LA=0), the ORGB is unaffected. 
Where the left image is partially transparent, you get a blend of 
the RRGB and the LRGB, where the values are added together 
and clipped to 255. The LA is the opacity of the left image. This 
operation (1-LA) calculates the amount of opacity to retain in 
the output image. The operation [RRGB*(1-LA)] removes as 
much of the output image as you are about to add from the left 
image. Remember that LRGB has been pre-multiplied by the 
LA, so the equation is really ORGB=[RRGB*(1-LA)]+
(LRGB*LA), which is simply the weighted average of L and R, 
with LA supplying the weight.

Apply Tone Highlight: ORGB=RRGB+(LRGB*RA). This 
operation restricts the output of the tone to the region of the 
matte (RA), and uses the transparency and colour value of the 
input image to determine the colour values of the output. This 
is used to lighten or darken the output image. Darkening 
occurs when RRGB contains negative values.

Apply Add (Apply Add Legacy): ORGB=RRGB+LRGB. This 
operation uses the transparency and colour value of the left 
image to determine the output values. Effects such as shadows 
and glows are calculated in this manner. Unlike the Apply Tone 
Highlight operation, the result is not clipped to the matte (RA) 
of the output image.

Apply Matte For Overlay: ORGB=RRGB*(1-LA).This 
operation prepares the output image using the overlay's 
matte; the matte's RGB values are ignored. This operation 
prepares the output image to receive the colour portion of the 
overlay. It is typically used when an overlay and its matte are 
stored in separate images.

Apply Overlay Into Matte: ORGB=RRGB+(LRGB*RA). This 
operation maps an overlay into an area prepared by a matte. It 
is typically used when an overlay and its matte are stored in 
separate images, and Apply Matte For Overlay has been used 
to prepare the output image to receive the RGB portion of the 
overlay.

Apply Transparency: ORGB=RRGB*(1-LA). This operation is 
used for a cutter matte to prepare the output image to receive 
the colour values of another image. It has the effect of 
increasing the transparency of ORGB (but not OA), based on 
the LA. This function is the equivalent to Apply Matte for 
Overlay. It is almost always used with Apply Transparency 
Matte, an Alpha Composite Operation.

Apply Multiplicative Tone: ORGB=RRGB*(LRGB+1-LA). This 
operation multiplies the left and right images (see the Multiply 
colours selection), to be combined with the right image colour, 
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creating a darker output colour. This effect created by this 
operation is identical to the Multiply Colour Blending effect in 
Photoshop.

Multiply Colours: ORGB=RRGB*LRGB. This operation 
multiplies the left and right image colours. Multiplying colours 
filters the colour values of the right image from the output 
image. For instance, to make the left image less blue, you can 
add a right image to this module with a blue colour value and 
select this option.

Linear Light: This operation burns or dodges the colours by 
decreasing or increasing the brightness depending on the 
colour of the underlying colour. If the blend colour is lighter 
than 50% grey, the colour is lightened because the brightness is 
increased. If the blend colour is darker than 50% grey, the 
colour is darkened because the brightness is decreased.

Pin Light: This operation will replace the colours, depending on 
the underlying colour . If the blend colour is lighter than 50% 
grey, pixels darker than the underlying colour are replaced, and 
pixels lighter than the underlying colour do not change. If the 
blend colour is darker than 50% grey, pixels lighter than the 
underlying colour are replaced, and pixels darker than the 
underlying colour do not change.

Vivid Light: This operation burns or dodges the colours by 
decreasing or increasing the brightness depending on the 
colour of the underlying colour. If the colour is lighter than 50% 
grey, the blend colour is lightened because the contrast is 
decreased. If the colour is darker than 50% grey, the blend 
colour is darkened because the contrast is increased.

Exclusion: This operation produces a similar result to the 
Difference mode, but with a lower contrast. 

Dodge: This operation will lighten the colour.

Burn: This operation will darken the colour.

Hue: This operation will result in a colour that will take the 
luminosity and saturation of the underlying colour, and the hue 
of the source colour.

Saturation: This operation will result in a colour that will have 
the same luminosity and hue of the underlying colour, and the 
saturation of the source colour.

Colour: This operation will result in a colour that will have the 
luminosity of the underlying colour, and the hue and saturation 
of the source colour.

Luminosity: This operation will result in a colour which has the 
hue and saturation of the underlying colour, and the luminosity 
of the source colour. This mode is opposite to the Colour 
mode. 

Divide Colours (Divide Colours Legacy): ORGB=RRGB/LRGB. 
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This operation divides the right image colour values by the left 
colour values. The left image colour values are inverted, 
creating a negative image (1/LRGB). The negative's colour 
values are then multiplied by the right image colour values.

Lighten (Lighten Legacy): This operation looks at the colour 
information coming from both the images in the left and right 
ports and selects the base or blend colour - whichever is lighter 
- as the result colour. Pixels darker than the blend colour are 
replaced, and pixels lighter than the blend colour do not 
change. 

Softlight (Softlight Legacy): This operation darkens or 
lightens the colours in a soft and diffuse way, depending on the 
blend colour (image in left port). If the blend colour is lighter 
than 50% grey, the image is lightened. If the blend colour is 
darker than 50% grey, the image is darkened. Painting with 
pure black or white produces a distinctly darker or lighter area, 
but does not result in pure black or white. 

Hardlight (Hardlight Legacy): This operation multiplies or 
screens the colours of the image in the left port with those of 
the image in the right port, depending on the blend colour. If 
the blend colour (left port image) is lighter than 50% grey, the 
image is lightened, as if it were screened. This is useful for 
adding highlights to an image. If the blend colour is darker than 
50% grey, the image is darkened, as if it were multiplied. This is 
useful for adding shadows to an image. Painting with pure 
black or white results in pure black or white. Play with the 
Opacity value to create a subtler look.

Overlay (Overlay Legacy): This operation multiplies or screens 
the colours from the image connected to the left port, with 
those on the right, depending on the base colour. Colours from 
the left-port element overlay the colours of the drawing 
elements connected to the right, while preserving the 
highlights and shadows of the base colour. The base colour is 
not replaced, but mixed with the blend colour to reflect the 
lightness or darkness of the original colour. 

Opacity The level of transparency.

Alpha Operation

Right: The transparency of the output image is derived from 
the alpha values of the image in the right port. The values in the 
left port are ignored.

Left: The transparency of the output image is derived from the 
alpha values of the image in the left port. The values in the right 
port are ignored.

Apply: OA=[RA*(1-LA)]+LA. This operation computes the 
output alpha of the output image based on the alpha values of 
the left and right images. This is the standard method of 
combining alpha channels. Notice its similarity to the Apply 
With Alpha colour Composite Operation.

421



Chapter 7: Effects     Channel Swap

Add: OA=RA+LA. This operation adds the alpha values of the 
two images to produce the alpha value of the output image.

Subtract: OA=RA-LA. This operation subtracts the alpha 
values of the input image from the alpha values of the output 
image. It is useful in situations where two tone levels have been 
drawn with overlap, but a double-darkening in the overlap is 
not wanted. This operation will reduce the opacity of 
overlapping regions.

Apply Transparent Matte: OA=RA*(1-LA). This operation is 
used to increase the transparency of the output alpha in the 
final composited image.

Black: OA=0. Sets the matte of the entire output image to 
black, so that it is transparent.

White: OA=1. Sets the matte of the entire output image to 
white, so that it is opaque.

Output Z

Leftmost: Indicates that the Z value for the output image will 
be taken from the module in the left port.

Rightmost: Indicates that the Z value for the output image will 
be taken from the module in the right port.

Backmost: Indicates that the Z value for the output image will 
be taken from the image that is the farthest back in the scene.

Frontmost: Indicates that the Z value for the output image will 
be taken from the image that is closest to the front of the 
scene.

Portnumber: Indicates that the Z value for the output image 
will be taken from the module in the selected port. Enter the 
appropriate port in the Port for Output Z field.

Contrast 
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Use the Contrast effect to increase or decrease the level of contrast in an image. This is done by 
changing the contrast in the dark and bright pixels and setting the transition point between dark and 
bright.

Contrast Effect Properties

Parameter Description

Mid Point

The value that separates dark from bright colours. The 
midpoint is a value between 0 and 1 that represents the 
percentage of the 0 to 255 RGB channel range.

Pixels with colour values lower than the midpoint: These are 
considered dark pixels. 

Pixels with colour values higher than the midpoint: These are 
considered bright pixels.

Dark Pixel Adjustment and 
Bright Pixel Adjustment

The amount of contrast to be applied to pixels that fall on 
either side of the Mid Point value.

A value equal to 1: No change

A value less than 1: The module makes the pixel colours 
brighter

A value greater than 1: The module makes the pixel colours 
darker

You can enter static values in the dialog box fields or you can attach these values to function curves to 
change over time.
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Cutter

The Cutter cuts out a portion of an image using a matte drawing. You can use the Cutter to allow a 
character to disappear behind a background element or to cut a virtual hole into the layer itself. The 
Cutter requires a matte input.

Use the Cutter editor to invert the effect of the matte on an image. Instead of the object being hidden 
by the mask, it will only be visible where it intersects with the matte shape area. 
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Dither 

Dithering is the process of approximating a higher number of colours in a low bit-depth colour system. 
Use the Dither effect to give the appearance of greater colour variability in 8-bit per channel colour 
images. 

The Dither effect is useful in the case of a gradient that varies between 100 and 105 in the blue channel, 
for example. Since the difference in the colour values is not great, banding might appear in the image. 
In this case, use the Dither module to give the impression of greater values of blue, decreasing the 
unwanted banding effect.

The results of the dither operation may be imperceptible.

 

Dither Effect Properties

Parameter Description

Magnitude
A magnitude of 1 performs a normal dithering operation, using all bands 
of colour. A magnitude greater than 1 introduces a bias towards brighter 
colours. A magnitude of less than 1 creates a faster transition between 
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bands of colour, lessening the bias towards brighter colours.

Correlate

When selected, the three colour channels (RGB) are changed sim-
ultaneously, for better colour accuracy. When this option is not selected, 
the three channels are dithered separately, resulting in smoother trans-
itions.

Random The standard algorithm for the dithering operation.

External 

Use the External module to process images through external programs and input the resulting images 
back into the network. Note that not all programs work with the External module.

Using the External module avoids you having to export your animation to another software to do 
some processing over it and then bring it back to Harmony. This way, you can modify your scene and 
animation as much as you want and still use the effects or render process from a third-party software.

The External module writes input files to temporary files on the system. It then calls the external 
program, which will process the input images. If two images are input into the module, the program 
must composite them together to produce one output image. Finally, the file produced by the 
external program is read back into the network.

426



Harmony 11.1 Compositing Guide (Network)

The command is sent to the external program in the following format:

program_name file_1 file_2 output_file numerical_param extension

Use the External editor to control the program that is launched by the module, the files that it reads, 
and the file that it outputs into the network.

In this example, the ImageMagick 6.3 software was used without a matte connection.

Use the External editor to write down the parameters matching the chosen external program.

• External Program: The name of the program launched by the External module. This field can 
include a full or relative path to the executable file. If no path is entered, the user's path is 
searched to locate the program.

Enter the command directly into this field. 

For example:

mogrify -spread $NUM $IN1

Where:
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• mogrify: Is the name of the program, 

• spread: Is the option to be applied, 

• and $NUM and $IN1: Are the numerical parameter and first input file variable declared in the 
External module.

• Program First Input File ($IN1): The name and location of the temporary file that Harmony will 
write to the file system for the external program to read. It must not include the dot or the 
extension; the External module will add these based on the Extension field.

• Program Second Input File ($IN2): When processing two files through this module (such as an 
image and a matte), this is the name and location of the second temporary file that Harmony 
writes to the file system for the external program to read. It must not include the dot or the 
extension; the External module will add these based on the Extension field.

• Program Output File ($OUT): The name and location of the temporary file that the external 
program will write to the file system so that Harmony can read it back into the network.

• Extension ($EXT): The file type that will be processed by the external program.

• Numerical Parameter($NUM): A value passed to the external program as a file processing 
option. It can be attached to a function curve to change over time.

The program files are temporary files that are overwritten at each frame as the module is 
executed. They are only meant to temporarily store the image that is being processed at each 
frame.

• Generate Unique FileNames: If this option is enabled, the temporary output file will have a 
unique identification number added to its name to avoid any file override if another scene or 
External script is rendered at the same time. It could be possible to have an override when two 
scenes using the External modules are rendered in batch processing.

Flatten

The Flatten module is used to transform 3D objects into flat planes when ordered in the Composite 
module. That plane can then be moved arouned like any other drawing. Instead of intersecting with 2D 
layers, the 3D object will either be behind or in front.

When all objects are at the same distance (z value) from the camera, the order is based on the 
Composite ports. When elements are placed at different distances from the camera, the z axis value 
overrides the composite port ordering.
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Focus 

Use the Focus effect to set up depth-of-field effects for your scene. The Focus module is used to 
determine how much blur will be applied to images, based on their distance from the focal point. 

The focal point can be the zero value of your scene or you can link the Focus module to another 
module, such as a drawing or peg layer, to retrieve the focal point from the module's Z-axis position.

Use the Focus editor to determine how the focus will change as objects move farther from the focal 
point.
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Focus Effect Properties

Parameter Description

Mirror Select this option to also blur images in front of the focal point.

Mirror Front/Back Ratio

When the Mirror option is selected, this ratio is applied to the calculation 
of the blur on images in front of the focal point. The default ratio of 1:2 
produces realistic results. Experiment with different values to create cus-
tomized effects.

Radius
Controls the amount of blur applied to an element based on its distance 
from the focal point. Click on the Edit Curve button to change these val-
ues by adjusting the function curve.

Quality
Controls the quality of the blur. A higher quality will achieve better results 
but will be slower to render.

In the Side view window, you can see how the blur values change based on their distance from the focal 
point. Select the Focus module in the Network view, make sure you are using the Transform tool, then 
right-click on the Side view window and select Control from the pop-up menu.
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If you edited the function curve and adjusted the velocity, you can also adjust the Bezier handles in the 
Side view.

Focus Multiplier 
 

The Focus Multiplier effect works with the Focus effect. This module applies a blur to the selected 
layer, based on the blur radius in the Focus module.

Use the Focus Multiplier module when you want to apply the focus to selected elements or when you 
need to apply the focus before doing more effects in a composite operation.
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You must disable the Apply Focus option in the Composite module in order to apply the focus effect 
to the selected module only. If you do not disable that option, the focus effect will be calculated twice 
on the selected module.

Use the Focus Multiplier editor to multiply the Focus Radius by a selected value. You can enter a static 
value in the Multiplier field or attach it to a function curve.

Glow 

The Glow effect adds a bright soft-edged light or diffuse light region around an image. The Glow 
effect is useful in creating a shining rim around objects such as the sun or stars.

Use the Glow editor to control the direction of the blur that creates the glow, as well as its colour.
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Glow Effect Properties

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements 
undergo a change of depth or scale. When this option is deselected, the 
effect's values remain unchanged regardless of any depth or scale 
changes. This option should be deselected when multiple drawings are 
composited and attached to this effect.

Blur Type

Directional: Blurs the matte in the direction you select. For 
example, if a character is walking east, the blur may fall to the 
west. 

Radial: Blurs the edges of the matte evenly around points that 
make up its edge.

Radius
Enter a value for the size of the blur. The larger the value, the greater the 
blur effect. The blur radius is affected by the drawing scale and camera 
position.

Directional Angle

If you select a Blur Directional type, you can select the direction 
of the blur by entering a value from 0 to 360 in this field.

‣ 0: Blurs the image to the west.

‣ 90: Blurs the image to the south.

‣ 180: Blurs the image to the east.

‣ 270: Blurs the image to the north.

Directional Fall-off Rate
The distance where the blur fades from the edge of the image. 
Select a value between 0 and 1.
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‣ A fall-off rate of zero causes the blur to fade out slowly, 
distributing the blur evenly from the edge of the character to 
the farthest edge of the blur.

‣ A fall-off rate of 1 causes the blur to fade out quickly so that 
the blur is heaviest closer to the edge of the image.

Invert Matte
Inverts the matte used to create the glow. The matte will become a black 
silhouette while the glow fills the background space.

Use Source Colour
Uses the colours painted in the matte for the glow effect. If you deselect 
this option, select a colour and alpha values in the Colour section.

Multiplicative Creates a more diffused glow.

Colour Lets you choose the colour and alpha values for the glow effect.

If this effect is connected below a Composite module set to Pass-Through, the effect will be applied to each 
element connected in the Composite individually. If some of these elements are overlapping, the effect will 
also overlap.

Glue 

The Glue effect lets you repair the cracks that appear between joints during animation.

The Glue module has three ports:
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• Left Port (Matte): Receives the matte.

• Middle Port (Port A): Receives the element that will not be used to fill the joint.

• Right Port (Port B): Receives the element that will be used to fill the joint.

For most effects with the Glue module, the default options are sufficient. However, you can modify 
these options using the Glue editor.

Glue Effect Properties

Parameter Description

Bias
Indicates the tendency to favour the static or moving element. Set to 0, it 
favours element A; set to 1 it favours element B; set to 0.5 it is in between 
A and B.

Tension
Indicates how tight the joint will be. Set to 1, the tension has no effect; set 
less than 1, the tension decreases; set greater than 1, the tension 
increases. 

Type
From this menu, select the type of joint to create. You can choose from 
among Curve (default), Line and Corner.

Use Z for Composition Order
You can use this option to choose the drawing with the higher front-back 
value to create the joint.
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A Over B
Indicates which image is rendered on top in the final image. By default, A 
is rendered on top of B, which indicates that the image in the middle port 
(A) is rendered on top of the image in the right port (B).

Spread A

By default, the image in port B is spread to fill the joint. You can use this 
option to choose the image in the A port to create the joint. If you select 
this option, the drawing module must receive position information from 
the "B" element. Thus, you must connect the Drawing module of the "B" 
element to the Drawing module of the matte.

Invert Matte
Activate this option to invert the matte used to fill the joint. If you want to 
use the "B" element as the matte, you must select this element.

Gradient 

The Gradient effect lets you create a transition of colour or alpha values between two areas of colours. 
You can create a linear or radial gradient. Use two points to indicate where those two coloured areas 
are. You can then move these points to create the transition.

The Gradient module covers the entire camera frame and beyond. You do not need to scale it up or 
down. It will automatically cover an infinite zone. You simply need to connect it behind your scene's 
elements. You can connect it in front of some elements you want to cover. By default, the Gradient has 
a Z ordering value of 0. When you select the Gradient module, the Camera view displays yellow 
triangles to indicate that it's selected.
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Use the Gradient property editor to modify the values of the gradient and the position of its output.

Gradient Effect Properties

Parameter Description

Gradient Type Lets you select a linear or radial gradient.

Point 1, Point 1
These sections control the values of the first point (point 0) and the 
second point (point 1) in the gradient.

Red, Green, Blue, Alpha

The colour and alpha values of the corresponding point. You can also click 
the colour swatch to open the Colour Picker window and select a new col-
our. These colours can be animated over time if the value parameter is 
hooked to a function curve. Default values are 0,0,0 and 255, 255, 255.

(x) Axis Sets the X coordinate for the corresponding point.

(z) Axis Sets the Y coordinate for the corresponding point.

Offset Z
Enter the front-back position of the Gradient layer in 3D space. You can 
verify this value in the Top view.

Depth Determines the composition order when the Z value of two elements is 
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the same.

Controlling the Gradient in the Camera View

If you want to control the gradient's orientation and points position in the Camera view, you can use 
the Control command to display the points and move them.

How to control the gradient in the Camera view

1. In the Tools toolbar, select the Transform  tool.

2. In the Network view, select the Gradient module.

3. From the top menu, select View > Show > Control.

4. In the Camera view, click the Gradient's points and move them.

Grain 

Use the Grain effect to add a film grain to an image; the film grain looks like video noise.
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The Grain module has two input ports. 

• On the left port, attach the element that will act as the matte defining the grain area.

• On the right port, attach the element on which you want to apply the grain effect.

Use the Grain editor to adjust the amount of grain to add to an image; you can also use it to adjust the 
sharpness or softness of the grain.

Parameter Description

Noise
The amount of grain to add to the image based on the percentage of 
pixels to alter. The larger the value, the courser the grain. The smaller the 
value is to 0 (zero), the finer the grain.

Smooth
The amount of blending to apply to the grain effect, based on the blur 
radius, to make the effect appear less pixelated. The larger the value, the 
greater the smoothing.

Random at Each Frame

Computes the colour shift in the grain using a different value at each com-
posite. This means that your images will look different each time you 
render them. Deselect this option and select a Seed Value to ensure the 
same result every time you composite the grain effect.

Seed Value
This value corresponds to a unique pattern in the grain. If you want to 
retain this pattern in other frames, you can reuse this value.
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Greyscale 

The Greyscale effect lets you convert a colour image to greyscale. This example demonstrates what 
happens when you set the greyscale to 100% using the Greyscale module. The Contrast module can 
also be used to adjust the darkness and lightness of the pixels in your element. 

Use the Greyscale editor to enter the percentage of black and white to apply to the image. You can 
enter a static value in the Percent field or attach the value to a function curve to change over time.
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• Matte Output: When this option is activated, the colour values do not change. However, alpha 
values are read from the colours which you can see in the Camera view Matte View mode.

How to Use the Matte Output Option

You can see in this section a concrete example on how to use the Matte Output option of the 
Greyscale module. We created a frosted window using a snowflake image over a blue rectangle and a 
colourful background.

Here are the three drawings used for the example:

When the snowflake image is connected into the Greyscale module, it turns into a greyscale image. 
There is no transparency visible in the Camera view Matte View mode.

When the Matte Output option is enabled, the snowflake image colours are displayed as normal, but 
when the Matte View mode of the Camera view is enabled, you can see the transparency levels 
generated from the colour values. 

 

When you connect the Snowflake images into a Cutter effect's Matte port along with the Window 
images, the window will be semi-transparent, matching the alpha (transparency) channel generated by 
the Greyscale module.
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Grid / Field Chart

The Grid module displays a grid, in field chart unit, which allows you to position elements in the 
Camera view windows. The Grid is also referred to as the Field Chart.
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Use the Grid editor to control the quality and alignment of the field chart that appear in the Camera 
view.

Size

This parameter adjusts the amount of units in the grid (field chart). The grid size will always be a 4:3 
ration, as per traditional animation standards, but will adjust the camera frame width. You can change 
the grid to adjust to the camera frame by disabling the Fit Vertical option.
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Display Text

Disable this option is you only want to see the grid but not the numbers. Enable this option to see the 
number gradation.

Red/Green/Blue/Alpha

The colour and alpha values of the corresponding point. You can also click on the colour swatch to 
open the Colour Picker window and select a grid colour. You can click on the second colour swatch to 
open the Colour Picker window and select a background colour.

Fill

When selected, the grid's background becomes opaque. Nothing behind will be shown. You can also 
click on the second colour swatch to open the Colour Picker window and select a background colour.
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Fit Vertical

The grid size will adjust the camera frame. You can change the grid to either adjust to the camera 
width or height by disabling the Fit Vertical option.

Aspect Ratio

The grid size default format is 4:3 ratio, as per traditional animation standards, but will adjust the 
camera frame width. You can change the grid ratio by entering a new ratio in the Aspect Ratio field. 
You can find your scene ratio by selecting Scene > Scene Settings.
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Highlight 

Use the Highlight effect to turn a drawing's area lighter to simulate a light source. To produce the 
highlight effect, you must draw a shape to control where the highlight will appear on the original 
drawing.
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The Highlight effect uses a matte to determine the shape and position of the highlight on another 
element and can blur the edges to create a softer effect. Use the Highlight editor to control the type 
and amount of blur, as well as the colour of the highlight effect.

Highlight Effect Properties

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements 
undergo a change of depth or scale. When this option is deselected, the 
effect's values remain unchanged regardless of any depth or scale 
changes. This option should be deselected when multiple drawings are 
composited and attached to this effect.
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Blur Type

Directional: Blurs the matte in the direction you select. For 
example, if a character is walking east, the blur may fall to the 
west. 

Radial: Blurs the edges of the matte evenly around points that 
make up its edge.

Radius
Enter a value for the size of the blur. The larger the value, the greater the 
blur effect. The blur radius is affected by the drawing scale and camera 
position.

Directional Angle

If you select a Blur Directional type, you can select the direction 
of the blur by entering a value from 0 to 360 in this field.

‣ 0: Blurs the image to the west.

‣ 90: Blurs the image to the south.

‣ 180: Blurs the image to the east.

‣ 270: Blurs the image to the north.

Directional Fall-off Rate

The distance where the blur fades from the edge of the image. 
Select a value between 0 and 1.

‣ A fall-off rate of zero causes the blur to fade out slowly, 
distributing the blur evenly from the edge of the character to 
the farthest edge of the blur.

‣ A fall-off rate of 1 causes the blur to fade out quickly so that 
the blur is heaviest closer to the edge of the image.

Invert Matte
Inverts the matte used to create the glow. The matte will become a black 
silhouette while the glow fills the background space.

Use Matte Colour
Uses the colours in the matte for the highlight effect. If you 
deselect this option, select a colour and alpha values in the 
Colour section.

Multiplicative Creates a more diffused glow.

Colour Lets you choose the colour and alpha values for the glow effect.
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Hue-Saturation

The Hue-Saturation effect lets you adjust the hue, saturation and lightness values individually or by 
using the HLS picker or Hue Range picker. You can achieve effects over the entire image, such as a 
sepia tone. Changes you make to the values are additive to the final image.

For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/video-
tutorials/chapter/adam-phillips-harmony-effects.
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Hue-Saturation Effect Properties 

Parameter Description

Master

Allows you to remap all the colours at the same time using the 
Hue, Saturation and Lightness fields. 

Note: When using the Master parameters, the Colorize 
parameters are disabled.

Opens the Hue Range Picker which displays the original colour 
spectrum of the image in the top bar and the new colour 
spectrum in the bottom bar. The Saturation and Lightness in 
the upper bar can range from -100 to 100, allowing you to 
decrease the original values.

 

 

Colourize
Lets you set the hue, saturation, and lightness by entering 
values or by using the HSL Picker. In the Colorize mode, 
Lightness can range from -100 to 100. 
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Select a colour by moving the colour picker.

Note: When using the Colourize parameters, the Master 
parameters and other colour tabs are disabled.

Hue The colour or hue of the image.

Saturation The amount of colour in the image.

Lightness The brightness of the image.

Colour Swatch Opens the HLS Picker where you can specify the colour.

Tabs Reds, Greens, Blues, Cyans, Magentas, Yellows

Opens the Hue Range Picker. The top bar displays the colour 
spectrum with arrows for defining the colour range more 
precisely. The triangles indicate the falloff of the effect, which 
you can also adjust. 

Specify the hue as an angle from 0° to 360° that corresponds to 
a location on the color wheel. Specify saturation and lightness 
(B) as percentages (0 to 100).

Reset Range
Resets only the range of hue values over which the effect is 
applied, i.e. the arrows and triangles. The HSL adjustments are 
maintained.
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Image Switch

The Image Switch  effect lets you use multiple effects, such as Colour Override, and choose which port 
will be sent to rendering if you want to apply different variations of an effect that cannot be changed 
over time. You then create multiple separate versions of the effect, connect them all to the Image 
Switch, and then if you want to change to a different version of the effect at different points in your 
scene, you would add a curve and animate the port number. Image Switch simply lets you change over 
time which port is being rendered.
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Image Switch Effect Properties 

Parameter Description

Port Index

Switches from one image to another. There is no gradual 
animation from one colour to another as you are only changing 
(over time) which port will be rendered. Use whole values.

Click the Function  button to open the Function editor to 
animate a parameter over time—see .
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Layer Selector 

Use the Layer Selector effect to isolate and display one or several drawing layers:

• Overlay

• Line Art

• Colour Art

• Underlay 

Use the Layer Selector editor to select the desired layers.
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• Antialiasing Quality: Smoothness setting applied to Overlay art layer. Choose from Low (no 
antialiasing), Medium Low, Medium and High (extensive antialiasing). The higher the quality of 
the chosen setting, the greater the amount of antialiasing that is applied. Higher quality images 
require more time to render and more memory from your system.

• Antialiasing Exponent: Controls the amount of area around the Overlay art layer edges that is 
used in the antialiasing process. A higher value uses less area, resulting in sharper edges, while a 
lower value uses more area, resulting in softer edges. If the Antialiasing Quality value is set to 
Low (no antialiasing), this value is ignored.
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Lens Flare

The Lens Flare effect simulates the refraction caused by shining a bright light into a camera lens. The 
shape of the lens flare can be circular or hexagonal.

For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/video-
tutorials/chapter/adam-phillips-harmony-effects.

Here is how a typical lens flare can be set up:
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Lens Flare Effect Properties 

Parameter Description

Flares  

Flare Type

Custom: Lets you use your own custom art or drawing.

Type 1: Circular lens flare.

Type 2: Hexagonal lens flare.

Blend Mode: Normal/Screen

Lets you apply a normal or screen blending mode to the image.

Normal: When selected, this operation will not create any 
blending mode effect.
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Screen: When deselected, this operation multiplies the 
inverted colour of the blending element with the image. This 
lightens the colour of the overlapping area. Screen is the 
default blending mode.

Position X, Y, Z Lets you precisely orient the flare in the x, y, and z axes.

Brightness  

Intensity The strength of the lens flare.

Red Red values of the image.

Green Green values of the image.

Blue Blue values of the image.

Alpha Alpha values of the image.

Colour Swatch
Opens the Colour Picker where you can specify the colour of the main 
flare.

Flare 1–10
Lets you create custom lens flares by associating them with specific draw-
ings. You can create up to 10 different flares.

 

Drawing: Lets you specify a drawing to use for the flare.

Position: The position of the flare. 

Size: The size of the flare.

Blur Intensity: The strength of the flare.

Line Art

Use the Line Art effect to read only the Line Art in an element. Place a Line Art module after a drawing 
module in the Network view to display only the module's Line Art output. The Line Art module can 
only be connected after a vector Drawing layer or a vector type Composite module. Any bitmap 
information will not be processed. 

This effect will only work if the user drew or painted something into the Line Art layer of the drawing.
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Use the Line Art editor to control how the Line Art is rendered by the module.

• Antialiasing Quality: Smoothness setting applied to Overlay art layer. Choose from Low (no 
antialiasing), Medium Low, Medium and High (extensive antialiasing). The higher the quality of 
the chosen setting, the greater the amount of antialiasing that is applied. Higher quality images 
require more time to render and more memory from your system.

• Antialiasing Exponent: Controls the amount of area around the Overlay art layer edges that is 
used in the antialiasing process. A higher value uses less area, resulting in sharper edges, while a 
lower value uses more area, resulting in softer edges. If the Antialiasing Quality value is set to 
Low (no antialiasing), this value is ignored.

Matte-Blur 
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Use the Matte-Blureffect to blur a matte or change its colour. Here is an example of a network with 
the result of a Matte-Blur effect.

Use the Matte-Blur editor to control the output of the module.

 

Matte-Blue Effect Properties

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the elements 
undergo a change of depth or scale. When this option is deselected, the 
effect's values remain unchanged regardless of any depth or scale 
changes. This option should be deselected when multiple drawings are 
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composited and attached to this effect.

Blur Type

Directional: Blurs the matte in the direction you select. For 
example, if a character is walking east, the blur may fall to the 
west. 

Radial: Blurs the edges of the matte evenly around points that 
make up its edge.

Radius
Enter a value for the size of the blur. The larger the value, the greater the 
blur effect. The blur radius is affected by the drawing scale and camera 
position.

Directional Angle

If you select a Blur Directional type, you can select the direction 
of the blur by entering a value from 0 to 360 in this field.

‣ 0: Blurs the image to the west.

‣ 90: Blurs the image to the south.

‣ 180: Blurs the image to the east.

‣ 270: Blurs the image to the north.

Directional Fall-off Rate

The distance where the blur fades from the edge of the image. 
Select a value between 0 and 1.

‣ A fall-off rate of zero causes the blur to fade out slowly, 
distributing the blur evenly from the edge of the character to 
the farthest edge of the blur.

‣ A fall-off rate of 1 causes the blur to fade out quickly so that 
the blur is heaviest closer to the edge of the image.

Invert Matte
Inverts the matte used to create the glow. The matte will become a black 
silhouette while the glow fills the background space.

Use Source Colour
Uses the colours painted in the matte for the glow effect. If you deselect 
this option, select a colour and alpha values in the Colour section.

Multiplicative Creates a more diffused glow.

Colour Lets you choose the colour and alpha values for the glow effect.

If you select the Pass Through option in the Layer Properties of a Composite where this effect is connected, 
the effect will be multiplied in areas where the drawing elements that the effect is acting on overlap.
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Matte-Resize 

Use the Matte-Resize effect to evenly expand a matte outward in all directions. The Matt-Resize 
module increases the size of a matte from its centre. Here is an example of a network with the result of 
a Matte-Resize effect.

If you use the Matte-Resize module to create a pulsating glow you can enlarge the region without 
softening the edges. Using the Blur-Radial effect, the effect may be softer than you intend. This 
module produces a limited antialiased matte, which can have slightly jagged edges. You could use this 
module in combination with other modules, such as:

• Tone

• Highlight

• Glow

• Shadow

• Matte-Blur

In the Layer Properties, you can enter a static value for the Radius of the resize operation. You can also 
attach the Radius value to a function column to change the value over time.
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Mesh Warp

Use the Mesh Warp effect to distort your drawings. With this module you can create effects such as a 
character in a warped mirror and looking through a glass jar. You can also animate the position of the 
grid to perform the distortion over time.

The Mesh Warp module is a position module, same as a Peg module.

How to use the Mesh Warp Effect

1. In the Module Library, under the Filter tab, select the Mesh Warp module and drag it to the 
Network view.

2. In the Network view, connect the Mesh-Warp module to your drawing or group modules to 
deform.
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3. In the Network view, select the Mesh Warp module.

4. Select View > Show > Control or press Shift + F11 (Windows/Linux) or ⌘  + F11 (Mac OS X) to 
display the deformation grid.

5. Move the intersection points and move the Bezier handles to deform the grid.

6. Grab the grid in the void spaces to pan it around. Using keyframes, you can animate its position 
over time.

Mesh Warp Properties

Use the Mesh Warp editor to adjust the grid size, deformation quality and the region of interest.
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Parameter Description

Rows
Increase or decrease the Rows value to change the amount of rows to 
use in the deformation grid.

Columns
Increase or decrease the Columns value to change the amount of 
columns to use in the deformation grid.

Region of Interest

Select the 2D Path option if you want both your X and Y curves to be 
controlled by the same velocity function. Select the Separate option if 
you want your X and Y curves to be independent and have independent 
velocity.

(x) Axis
This is the X position of the gird. This value can be animated overtime to 
move the grid horizontally.

(y) Axis
This is the Y position of the gird. This value can be animated overtime to 
move the grid vertically.

Width
This is the width value of the gird. This value can be animated overtime 
to squash or stretch the grid horizontally.

Height
This is the height value of the gird. This value can be animated overtime 
to squash or stretch the grid vertically.

Deformation Quality
This is the quality of the warm deformation. It ranges from Low to 
Extreme. The higher the quality, the better the formation will look, but 
the longer it will take to render.
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Motion-Blur 

The Motion-Blur effect is used to create a faded trail behind objects animated on a motion path. You 
cannot create a Motion-Blur on a hand-drawn animation. The layer must be moving along a trajectory 
(motion path) in order to work properly.

The Motion- Blur effect automatically creates a matte for the drawing layer attached to it, so it is not 
necessary to connect any matte into the Mask layer.

Use the Motion-Blur editor to modify the motion blur, crowd simulation or particle system effect.
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Motion-Blur Effect Properties

Parameter Description

Number of Frames in Trail Number of frames before the current frame that will be used in the trail.

Number of Samples
Number of copies of each drawing used in the trail. The higher the num-
ber, the more continuous the trail appears.

Fall-off Rate

The distance where the blur fades from the edge of the image. 
Select a value between 0 and 1. 

A fall-off rate of 0 causes the trail to fade out slowly, 
distributing the colour evenly from the edge of the character to 
the farthest edge of the trail. 

A fall-off rate of 1 causes the trail to fade out quickly so that the 
trail is more opaque closer to the edge of the image and 
transparent at the end of the trail.

Intensity
Select a value to define the opacity of the trail between 0 and 10. A value 
of 10 will make the trail very dark and almost opaque, where as a value of 
0 will make the trail quite pale and ghostly transparent.

Use Mirror on Edges

When enabled this option appear when the image is close to the edge of 
the camera frame. It forces the software to use a mirror of the image to 
calculate the blur so that it appears on both sides of the drawing object. 
Without this option once your drawing reaches the edge of the Camera 
frame, it gets cropped so does the trail.

Multi-Port-In 
A Multi-Port-In module is added by default in a new Group module. Use it to add one or more input 
ports to the Group module so that you can process an image through the modules in the Group 
module. 

467



Chapter 7: Effects     Lens Flare

When you plug an element to a Multi-Port-In module, an input port appears at the top of the Group 
module. You can add additional ports to the modules as needed.

Pass your cursor over the Group module input port to see the name of the Port Image In module that 
it connects to. You will notice that the Group module in these examples has no output port. It requires 
a Multi-Port-Out module to output data from its network.

A Multi-Port-In is automatically added when you create a group.

Use the Multi-Port-In editor to rename the module.

Multi-Port-Out 

A Multi-Port-Out module is added in a new Group module by default. Use it to add output ports to 
the Group module so that you can output the result of the group operation to the rest of the network. 
After you plug an element to a Multi-Port-Out module, an output port appears on the bottom of your 
Group module. You can add additional output ports as needed.
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A Multi-Port-Out is automatically added when you create a group.

Use the Multi-Port-Out editor to rename the module in the network.

Negate

Use the Negate effect to invert the colour and/or alpha values in the Colour Art and Line Art of an 
image. The Negate module subtracts the original value of each channel (RGB or A) from the maximum 
value of that channel (255 for 8-bit channels) to produce the negative image.
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Use the Negate editor to select the colour and/or alpha values to invert.

Negate Effect Properties

Parameter Description

Negate Colour Inverts the values of the colour channels.

Negate Alpha Inverts the transparency value (alpha channel).

Negate Colour Clamp to Alpha Limits the negated area to the alpha channel.

Note 
The Note module allows you to record any textual information that is relevant to your project. Use its 
editor to enter comments, suggestions or reminders. Note modules can be added anywhere in the 
network, including in groups.

470



Harmony 11.1 Compositing Guide (Network)

Use the Note editor to add or update relevant notes with any textual information.

Overlay Layer 

Use the Overlay Layer effect to read only the Overlay layer in an element. Place a Overlay Layer module 
after a drawing module in the Network view to display only the module's Overlay layer output. The 

471



Chapter 7: Effects     Lens Flare

Overlay Layer module can only be connected after a vector drawing layer or a vector type Composite 
module. Any bitmap information will not be processed. 

This effect will only work if the user drew or painted something into the Overlay layer of the drawing.

Use the Overlay Layer editor to control how the Overlay layer is rendered by the module.
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• Antialiasing Quality: Smoothness setting applied to Overlay art layer. Choose from Low (no 
antialiasing), Medium Low, Medium and High (extensive antialiasing). The higher the quality of 
the chosen setting, the greater the amount of antialiasing that is applied. Higher quality images 
require more time to render and more memory from your system.

• Antialiasing Exponent: Controls the amount of area around the Overlay art layer edges that is 
used in the antialiasing process. A higher value uses less area, resulting in sharper edges, while a 
lower value uses more area, resulting in softer edges. If the Antialiasing Quality value is set to 
Low (no antialiasing), this value is ignored.

Pixelate 

The Pixelate effect lets you apply a mosaic effect to an image (and its matte) based on the matte you 
supply. Pixelation makes the image look like it is made up of square tiles.

There are two input ports on the Pixelate module: 

• The left port receives the matte 

• The right port receives the image 

Use the Pixelate editor to control the amount (Factor) the image is pixelated. You can attach the 
Factor value to a function curve to change the value over time.
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Placeholder 
Use the Placeholder module in a network when you are either unsure of which module you will put in its 
place or if you want to lay out a custom network for future use.

Use the Placeholder editor to rename the module.

Quadmap 

Use the Quadmap transformation layer to deform the shape of an element. For example, you can use 
it to create a drop-shadow effect on an element.

You can edit the Quadmap visually in the Camera view.
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How to edit the Quadmap in the Camera view

1. In the Timeline view, click the Add Layer  button and select Quadmap.

2. Do one of the following:

‣ Connect the Quadmap layer to the drawing layer that you want to deform.

‣ In the Network view, add a Quadmap module and connect it above the drawing element 
module that you want the effect to act on.

3. In the Tools toolbar, disable the Animate mode to change the value for the Quadmap over the 
entire duration of the element.

4. In the Timeline view, click on the Quadmap layer to select it.

5. From the top menu, select View > Show > Control or press Shift + F11.

The quadmap handles appear around the element in the window. There is also a pivot point at the 
centre of the quadmap frame that you can reposition.

6. In the Camera view window, use the Transform tool to move the points on the quadmap. Shift + 
click to select multiple points.

The value of each point on the quadmap can be changed gradually. To do this, use the Quadmap 
module Layer Properties to attach the points to function curves.
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Only the X and Y values of each point in the quadmap can be changed.

• 2D Path: change the X and Y values simultaneously and control the velocity of the change.

• Separate: change the X and Y values separately. Each of these can be attached to separate 
function curves.

Refract 

Use the Refract effect to create effects such as ripples and heat haze. This effect is based on the 
refraction of light, which occurs when a beam of light passes through media of different density, 
causing the light to refract or change angles. This effect makes objects appear distorted or offset 
from their actual positions. If you imagine an object in a pool of water the part beneath the surface of 
the water appears offset from its true position.
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To create a refraction effect, you need a matte with alpha values. This creates the effect of a volume 
passing over an image, refracting the light that bounces off the contents below. For a ripple effect 
moving across an image, you must move the matte with a Peg layer.

If your matte is only black and white, meaning that there is no gradients and only solid colours in your 
matte drawing, you will need to connect a Blur Radial module after your matte Drawing module to 
soften the edges and get nicer waves.

Use the Refract editor to control the effect.

• Intensity: The amount of refraction to apply to the image. 

• Height: The amount of depth to add to the refraction effect. When coupled with the Intensity 
effect, this value can create the effect of bending the objects below the refraction matte.

Attaching the Intensity and Height values to function curves changes their values over time.
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Remove Transparency 

The Remove Transparency effect negates transparent values in an image. You can use the Remove 
Transparency module to remove the result of antialiasing around an image.

Use the Remove Transparency editor to control the effects of the module.

478



Harmony 11.1 Compositing Guide (Network)

• Threshold: All values above the Threshold represent a transparent value. In this field, you must 
identify the value above which all alpha values are considered transparent. Alpha is measured 
from 0 to 255. 

• Remove Colour Transparency: When selected, the Threshold value is used to determine which 
pixels in the Colour-Art (RGB channels) to make fully opaque or fully transparent.

• Remove Alpha Transparency: When selected, the Threshold value is used to determine which 
pixels in the alpha channel to make fully opaque or fully transparent.

Shadow 

With the Shadow effect, you can turn a drawing into a shadow. It does not matter if your drawing layer 
is a fully coloured character, the Shadow effect will render it into a grey, semi-transparent, slightly 
blurry silhouette. 

To add a shadow stretched out on the ground, simply add a Quadmap module to flip, stretch and 
skew the matte. Attach the entire effect to the same trajectory as your drawing layer and watch the 
shadow move along with your character. 
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Do not forget that you need to connect your character in both the final Composite module and the Shadow 
effect if you want to see your character and its shadow.

Use the Shadow editor to modify the way the Shadow effect is created.

The Shadow effect uses the shape of the drawing connected to create the shadow behind another 
element and can blur the edges to create a softer effect. You can control the type and amount of blur, 
as well as the colour of the shadow, in this dialog box.

480



Harmony 11.1 Compositing Guide (Network)

• Truck Factor: Activated by default, this option readjusts the blur when the elements undergo a 
change of depth or scale. When this option is disabled, the effect's values remain unchanged 
regardless of any depth or scale changes. It is recommended that this option be disabled when 
multiple drawings are composited and attached to this effect.

• Blur Type (Directional or Radial): 

• If Directional is selected, Harmony will blur the matte in the direction you select.

• If Radial is selected, Harmony will blur the edges of the matte evenly around points that make up 
the edge of it. 

• Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The 
blur radius is affected by the drawing scale and camera position.

• Directional Angle: If you select a Directional Blur Type, you can select the direction of the blur 
by entering a value from 0 to 360 in this field.

• 0: blurs the image to the west.

• 90: blurs the image to the south.

• 180: blurs the image to the east.

• 270: blurs the image to the north.

• Directional Fall-off Rate: The distance where the blur fades from the edge of the image. Select a 
value between 0 and 1.

• A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of 
the character to the farthest edge of the blur.

• A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the 
edge of the image.

• Invert Matte: Activate this option to invert the matte used to create the shadow. In the render 
mode, the background will appear grey, while a the matte shape will act as a cut-out window, 
allowing you to see the original background colours beneath. 

• Use Source Colour: Create the shadow using the matte shape's colour. Be sure that you are in 
render mode  to see this effect and that your background is NOT white and that you do 
NOT have a white colour card module attached to the composite. As the shadow matte only 
gives colour information, but no alpha, the matte is automatically multiplied with the 
background colours. If there is no colour card attached and the background appears black, you 
will see the matte colour at full opacity. If it is multiplied with a white background, the colours 
disappear into the full 255.    

• Multiplicative: Multiplies the shadow colours with the background.

• Red/Green/Blue/Alpha: In the RGBA fields, you can enter the value to add or subtract from the 
colour channels in the drawings or you can attach these values to function curves.

If this effect is connected below a Composite module set to Pass-Through, the effect will be applied to each 
element connected in the Composite module individually. If some of these elements are overlapping, the 
effect will also overlap.
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Sparkle 

The Sparkle effect transforms a vector drawing into sparkles. You have a high degree of control over 
the appearance of the sparkles.

The sparkle effect can only be used with vector drawings. If the sparkle effect module is attached to a 
composite, verify that the Composite editor is set to Vector Flatten Output.

Use the Sparkle editor to modify how the Sparkle module creates the sparkle effect. You can also use 
Bezier and Ease function curves to change the values of factors over time.
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• Start Angle: Enter a value between -360 and 360 to indicate the angle of rotation of each 
sparkle.

• Scale: Sparkles are determined by the size of the bounding box of the coloured areas in the 
drawing. Enter the multiple to use to scale the sparkle size.

• Factor: Enter a value between 0.1 and 1 to determine how pointy the sparkle is. A value closer 
to 0 will result in a more pointed sparkle. A value closer to 1 will result in a more rounded 
sparkle.

• Density: Adjusts the density level.

• Number of Points: Enter the number of points you want each sparkle to have.

• Probability of Appearing: Enter the percentage of possibility that sparkles will be displayed. 
Enter 100 to always show sparkles. Enter 0 to always hide sparkles.

• Point Noise: Enter a value between 0.1 and 1 to indicate the amount by which points in a sparkle 
will distort.

• Centre Noise: Enter a value between 0.1 and 1 to indicate the amount by which the angles 
between each point in a sparkle will distort.

• Angle Noise: Enter a value between 0.1 and 1 to indicate the amount by which the Start Angle in 
a sparkle will distort.

• Random Seed: Enter a positive integer value that will be used to determine the sparkle pattern.

• Use Drawing Colours: Select this option to use the colour attributes of the drawing for the 
sparkle colour. When this selection is disabled (default setting), the colour values will be used as 
they are entered in the editor.

• Flatten Sparkles of Same Colour: Flatten all drawings of the same colour into a single layer.

• Red/Green/Blue/Alpha: In the RGBA fields, enter the values to use for the sparkle colour. 

Tone 

The Tone effect lets you add a dark-coloured region to your drawing and simulate the shaded area 
away from a light source. To produce the tone effect, create a drawing to control where the tone will 
appear. The Tone effect uses a matte to determine the shape and position of the tone on your 
drawing and can be blurred at the edges to create a softer effect. 
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Use the Tone editor to control the type and amount of blur, as well as the colour of the tone.

Tone Effect Properties 

Parameter Description

Truck Factor

Activated by default, this option readjusts the blur when the 
elements undergo a change of depth or scale. When disabled, 
the effect's values will remain unchanged regardless of depth 
or scale changes. It is recommended that this option be 
disabled when multiple drawings are composited and attached 
this effect.

Blur Type Radial: The edges of the matte are blurred evenly around 
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points that make up the edge of the matte.

Directional: The matte is blurred in the direction you select.

Radius
Enter a value for the size of the blur. The larger the value, the greater the 
blur effect. The blur radius is affected by the drawing scale and camera 
position.

Directional Angle

If you selected the Directional Blur type, you can set the 
direction of the blur by entering a value from 0 to 360 in this 
field.

0: Blurs the image to the west.

90: Blurs the image to the south.

180: Blurs the image to the east.

270: Blurs the image to the north.

Directional Falloff Rate

The distance where the blur fades from the edge of the image. 
Select a value between 0 and 1.

0: Makes the blur fade out slowly, distributing the blur evenly 
from the edge of the character to the farthest edge of the blur.

1: Makes the blur fade out quickly. The blur is heaviest closer to 
the edge of the image.

Invert Matte Inverts the matte used to create the tone.

Use Matte Colour Uses the matte shape colour to create the tone.

Multiplicative Multiplies the tone colours with the background.

Colour

Red Red values of the image.

Green Green values of the image.

Blue Blue values of the image.

Alpha Alpha values of the image.

Colour Swatch
Opens the Colour Picker where you can specify the colour of the main 
flare.
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Transparency 

The Transparency effect is used to make an image partially transparent. The Transparency effect is 
useful when fading images in and out, such as a phantom or to make something partially see-through, 
such as a window.

Use the Transparency editor to control how translucent the element should be.

487



Chapter 7: Effects     Lens Flare

You can enter a value in the Transparency field or change the transparency value over time by linking it 
to a function curve. Entering a value of 100 in the Transparency field will make the element 100% 
transparent, in other words, invisible. Entering a value of 0 will render the element completely opaque.

It is also possible to adjust a layer/module's transparency directly in the Layer Properties window without 
using the Transparency module. In the layer's properties, go to the Drawing tab and adjust the Opacity 
parameter. This parameter is visible in OpenGL mode.

Underlay Layer 
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Use the Underlay Layer effect to read only the Underlay layer in an element. Place a Underlay Layer 
module after a drawing module in the Network view to display only the module's Underlay layer 
output. The Underlay Layer module can only be connected after a vector drawing layer or a vector 
type Composite module. Any bitmap information will not be processed. 

This effect will only work if the user drew or painted something into the Underlay layer of the drawing.

Use the Underlay Layer editor to control how the Underlay layer is rendered by the module.

• Antialiasing Quality: Smoothness setting applied to the Underlay layer. Choose from Low (no 
antialiasing), Medium Low, Medium and High (extensive antialiasing). The higher the quality of 
the chosen setting, the greater the amount of antialiasing that is applied. Higher quality images 
require more time to render and more memory from your system.

• Antialiasing Exponent: Controls the amount of area around the Underlay layer edges that is 
used in the antialiasing process. A higher value uses less area, resulting in sharper edges, while a 
lower value uses more area, resulting in softer edges. If the Antialiasing Quality value is set to 
Low (no antialiasing), this value is ignored.

Visibility

The Visibility module lets you control whether an item is visible in OpenGL mode versus the Soft 
Render mode in the Camera view. If the Soft Render option is not enabled, the layer will not be 
exported.
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Visibility Properties

Parameter Description

Display in OpenGL View Displays your render in OpenGL mode.

Soft Render  
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Particle Effects

Particle effects are both cool and a huge time saver. You can create atmospheric effects, such as rain, 
grass or fire to more complex systems, such as swarms of animated insects and all in a fraction of the 
time it would usually take.

Particle Effects act in the same way as all other effects in Harmony, except that they always work 
within their own specifically structured system. You can attach a Blur effect module under a Drawing 
module and the image contained in the Drawing module will become blurry. Particle effect set-ups are 
more complex than simply adding a module and playing with its parameters. To keep things simple, 
just think of each Particle Effect as its own group.
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Basic Structure

This is what a the basic structure of a Particle Effect looks like in the Network view. This structure can 
change depending on the type of effect that you are trying to create. 

Colour Coding

To make particle effects less confusing, the Particle Effects modules have been colour-coded. Each 
colour represents a different function. For example, Action modules, such as Velocity, Move-Particles 
and the Sprite Emitter are coloured bright purple. These colours, can be edited in the Preference 
panel by going to Edit/File > Preferences > General (tab) > Edit Colours (button) > Particle (tab). 

In addition to defining groups by colour, module in-ports and out-ports are also colour-coded. In the 
network shown in the diagram above, the Particle-Baker is dark yellow and the Particle Visualizer 
purple. If you look closely, you will notice that the in-port on the Particle Visualizer, where the Particle-
Baker is connected, is also dark yellow. Similarly, the out-port on the Particle-Baker, where the Particle 
Visualizer is connected, is purple.

This system gives you an idea, at the very least, of what type of module is needed to fill a specific port.    
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• Visualizer - This module assembles a particle system through its middle port. It can accept a Peg 
on either side. The system is flattened at this module and generated as a single image. This is so 
you can move the effect's position in your scene or change its render order.

• Action - These modules affect the particles dynamics; they determine how they are created and 
moved around in space. If there are multiple Action modules hooked to a composite, they are 
executed from right to left. Due to this execution ordering, there should generally be an emitter 
on the right-most port.  

• System Composite - Unlike a regular composite that reads all the position information from its 
in-port modules and combines them accordingly, a System Composite is specifically designed to 
handle Action module information.

• Baker - These modules allow you to make decisions about the particle systems position, angle, number, 
etc. the same way that a baker would make decisions about the ingredients that go in a cake.

• Region Composite - This module combines Region modules. In case you have more than one 
Region in your effect, this composite will help define the position and render order of the 
different Regions.

• Region - These modules are used to define the region from where the particles are emitted. 
These regions can be Planar or 3D.

Help Notes

Display the Integrated Help View and click on a Particle Module in the Network view to find 
information relating to that module, often with explanations about the options found in the module 
Layer Properties panel. 
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Accessing Default Particle Effect Templates
Harmony comes with some basic Particle Effect templates. Change the effect's "sprite" with a 
drawing, image or animated sequence of your own. Tweak its properties to adjust the effect to your 
liking. Or use the templates to analyze their structure so you can build your own.

How to access the Particle Effects Templates

1. From the top menu, select Insert > Particle > and one of one of the following default Particle 
Effects templates:

• Basic Particle System: This effect template has the simplest structure and the parameters for 
all of its modules are set to the default values. For example, the Planar-Region has not been 
rotated or resized, the particles have not been randomized in the Sprite-Emitter, and the 
particles start their generation on the first frame and die out at the maximum number allotted 
in the Particle-Baker.    

• Basic Gravity Based System: Simulates particles being generated from a source with special 
emphasis on adding gravity to the particle system.

Creating a Custom Particle Effect
There is a new tab in the  Module Library view. It is called Particle and it contains all the modules 
specifically needed to build various Particle effect systems.
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To create a custom Particle effect, click and drag the Particle modules from the Module Library to the 
Network view.

Particle Effect Modules
This section explains the each module's purpose, its layer properties and how to adjust these 
properties. 

This topic is divided as follows:

‣ 3D Region on the next page

‣ Baker on page 497

‣ Baker Composite on page 497

‣ Bounce on page 499

‣ Explosion on page 500

‣ Gravity on page 502

‣ Image Fracture on page 504

‣ Kill on page 540

‣ Move Particles on page 541

‣ Orbit on page 543

‣ Planar Region on page 546

‣ Random on page 548

‣ Region Composite on page 550

‣ Repulse on page 551

‣ Rotation Velocity on page 552

‣ Sink on page 554

‣ Size on page 555

‣ Sprite Emitter on page 556

‣ System Composite on page 570

‣ Velocity on page 579

‣ Visibility on page 489

‣ Visualizer on page 581

‣ Vortex on page 582

‣ Wind-Friction on page 584
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3D Region

This module defines 3D region. The region can take on many forms, such as a sphere, cone, cylinder or 
box. The 3D Region module acts in contrast to the Planer Region module, which generates and emits 
particles from a 2D plane.

A 3D Region can be connected to a Sprite-Emitter, to define the region from which particles are 
generated. It could also be connected to a Bounce module, to define a region against which particles 
will bounce. If connected to a Sink, it will define a region where the particles will disappear.

Click on View > Show > Control in order to view a preview of what the 3D Region looks like. 

Layer Properties

Use the 3D Region's Layer Properties to adjust the 3D region.
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• Shape: Choose a shape for the 3D Region by clicking on the Type drop-down menu and 
selecting either Box, Cylinder, Cones, Sphere or Image.

If you select Image, you must connect the module of a vector drawing or a vectorized bitmap image 
to the left port (blue node) of the 3D Region module. The particles will then be emitted from that 
image' shape. Don't forget that you can rotate your vector drawing in 3D space by enabling the 3D 
option in its Layer Properties.

• Size: Enter different values into the Width, Height and Depth fields to change the dimensions of 
the 3D Region's selected shape. Depending on the shape selected, some fields may be greyed-
out if they are not applicable. You can also modify the shape with the Transform Tool by 
grabbing the control handles (turquoise squares) in the Camera or Perspective views. You can 
also change the dimensions of the region over time by click on the function button at the end of 
each field.

• Radius: Enter different values into the Min or Max fields to change the inner or outer radius of 
applicable shapes, such as a cylinder, cone or sphere. The radii can also be modified by grabbing 
the control handles (turquoise squares) in the Camera or Perspective views. The radii of the 
region can be changed over time by clicking on the function button at the end of each field.

Baker Composite

The Baker Composite is used to composite more than one Particle-Baker, as well as any other 
elements that need to be combined before they pass through the Particle Visualizer.

Baker
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This module, also known as the Particle-Baker, allows you to make decisions about the particle 
systems position, angle, number, etc. the same way that a baker would make decisions about the 
ingredients that go into baking a cake. The Baker performs the particle simulation, combining 
together all the ingredients specified to get the final result. The Baker must always be connected to 
the Particle-Visualizer.

Layer Properties

Use the Particle Baker's Layer Properties to adjust your particle system's various parameters.

• Seed: This value allows you to apply a random effect to the particle system. There may be times 
when you want to copy the particle system to two different locations on your screen. You can 
take the out port of the Particle System Composite module, and plug this into two separate 
Bakers and Visualizers. Then you could move one system over by attaching a peg into the left 
side of one Visualizer. If you do this, the two systems will look exactly the same. Add a random 
Seed to make them look different.

• Simulation Quality: This option defines how many simulation steps per frame are performed. 
The lowest quality creates one step per frame. Raising the quality will divide the simulation time 
and create two or more steps of simulation for each frame. This increases the computation time, 
but also increases the quality of the result.

• Number of Pre-roll Frames: Allows you to select a start position in the particle effect sequence, 
other than the start (generation) of the sequence. This essentially allows you to start the particle 
effect part-way through its cycle, even if it starts on frame one of your project. An example of 
when this parameter might come in handy is when you want it to be already raining at the start 
of your scene. If you don't change the number of Pre-roll Frames, it will always start to rain at the 
beginning of your scene.

• Maximum Number of Particles: Entering a value in this field puts a cap on the number of 
particles that will be created; the software will stop generating particles once it reaches this 
number. 

• Age Particles: Check this option if you want the software to keep track of how long a particle 
has existed in its cycle from the time of its inception. Knowing a particles "age"  means that you 
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can tack other parameters onto its lifespan, such as having the particle start to disappear or 
change colour at a certain age.

• Move Position: Check this option to allow the particles to move position, otherwise the particles 
will not be able to flow in a specified direction. This option also exists in the Move Particles 
module. You do not always need a Move Particles module, hence why this option exists in the 
Baker. This option is also useful for when your Move Particles module is cut-off by a sink, refer to 
Sink on page 554 for information on that particle effects module. 

• Move Angle: Check this option to allow the particles to flow from different angles. This option 
also exists in the Move Particles module. You do not always need a Move Particles module, hence 
why this option exists in the Baker. This option is also useful for when your Move Particles module 
is cut-off by a sink. 

Related Topics 

• Particle Effect Modules on page 495

Bounce

Use this module to make your particles bounce off a surface with realistic physical modeling. This 
module should have a region connected to it, and that region will act as a bounce plane so that when 
any particle hits it, it will bounce off at the correct angle.
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Layer Properties

Use the Bounce's Layer Properties panel to adjust the effect's parameters.

• Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

• Friction: Enter a value into this field to increase the amount of friction that each particle 
experiences as it makes contact with the planar surface. A positive value creates more friction 
and therefore slows the particle down. A negative value lessens the friction and therefore makes 
the surface appear more slippery.

• Resilience: Changing this value effectively increases or decreases the bounciness of the particle. 
A value of zero causes the particle to hit the planar surface once and slide off any downward 
facing angle. A positive value, even by decimal increments, causes the particle to become 
bouncy. A negative value deadens the effect, the same way a lack of Region would.

• Cutoff: Increasing this value widens the bounce arc. If the connected Planar Region is completely 
flat, a value of zero will cause the particle to bounce up and down in place. A tilted plane in the 
direction of the bounce will also widen the arc.

Explosion

Use this module to create an explosion. As it is an Action module, it should be connected to the 
Particle System Composite after the Sprite Emitter. As the explosion occurs, the particles will burst 
rapidly away from the centre of the explosion (the centre of the defined Region), then gradually slow 
down.
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Layer Properties

Use the Explosion's Layer Properties panel to adjust the effect's parameters.
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• Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

• Coordinates: User the X, Y and Z fields to enter different position values, in order to move the 
particle system around in 3D space. You can also connect a Peg module to the Explosion to 
manipulate its position with the Transform tool or Move tool.

• Radius: The radius defines the surface of an invisible sphere. As the explosion occurs, the 
exploded particles inside the boundaries of this sphere will be effected by the force of the 
explosion, while the particles that eventually pass through will remain unaffected.

• Sigma: The higher the Sigma value, the longer it takes for the particles to completely disappear, 
even if the initial explosion seems to occur just as rapidly.

• Magnitude: This value defines the magnitude of the explosion. The greater the magnitude, the 
faster the particles break-up.

• Epsilon: This value works in opposition to the Sigma value. The higher the value, the slower the 
initial explosion seems to occur. If the value is high (an integer value) then larger particles remain 
suspended for longer from the initial explosion and take a while to gradually break down. A 
smaller (decimal) value breaks the particles down to smaller forms more rapidly from the time of 
the initial explosion. 

Gravity

This module allows you to define the gravity of the particle system.
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Layer Properties

Use the Gravity module's Layer Properties panel to adjust the effect's parameters.
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• Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

• Apply Gravity: Enable this option to force the particle system to adhere to the force of gravity. 
Values must be entered into the Direction fields, along with enabling this option, in order for it 
to work. If this option is not enabled, the particle system will explode outwards from its origin 
point.

• X Direction: Directs the particle stream either to the left or the right (along the x-axis). A value 
of 1 forces the particle stream to the right, while a value of -1 forces the particle stream to the 
left.

• Y Direction: Directs the particle stream either up or down (along the y-axis). A value of 1 forces 
the particle stream to flow upwards, while a value of -1 forces the particle stream to flow 
downwards.

• Z Direction: Directs the particle stream either forwards or backwards (along the z-axis). A value 
of 1 forces the particle stream to flow forwards, while a value of -1 forces the particle stream to 
flow backwards.

• Apply Gravity between Particles (Relative Gravity): Relative Gravity will apply gravity between 
each particle taking their masses into account. The mass of the particle can be specified at 
emission time via the Sprite or the Image Emitter. 

• Relative Gravity Magnitude: Adjust the amount of gravity that will be applied between 
particles. 

• Relative Gravity Epsilon: The acceleration falls off the further the particles get away from each 
other, but when the particles are very close to each other, the acceleration becomes very high - 
so you should define a small region around the particles so that they never actually touch.

• Relative Gravity Maximum Distance: Adjusts the radius beyond which particles don't affect 
each other.

Image Fracture

Use the Image Fracture to break an image apart into pieces. This Effect module requires 2 image 
objects: the image to be cut and the shape of the cut pieces (matte). The image to be cut can be 
anything from a vector drawing to a bitmap image to an entire scene's composite, with effects and all. 
The image to be cut should be hooked to the Image Fracture's fight port.

The matte should be a flattened if you want it to work like a cookie cutter (hollow shape with a frame) 
and can be composed of either brush or pencil lines. It can also be a solid shape, may solid filled 
shapes and even many solid filled overlapping shapes. When the matte is made up of overlapping 
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pieces, the cut image will be multiplied at those zones to break apart in multiple layers. The matte 
drawing should be hooked to the Image Fracture's left port.

The 2 image objects overlap perfectly when they are combined in the Image Fracture. This means that 
you have to take 12 by 12 field into account when judging the scale and proportion of these objects. If 
the matte does not overlap at a part of the image, that part of the image will not get cut. The matte 
does not have to be a continuous shape. It could be 3 separate circles, which would then be cut and 
pulled away from the image.

You can turn on the grid and use the Light Table feature in the Drawing view while drawing or scaling the 
Image and Matte, in order to ensure that they are the correct size relative to one another.

Look at an example of a Network that uses the Image Fracture:
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Layer Properties

Use the Image Fracture's Layer Properties panel to adjust the effect's parameters.

506



Harmony 11.1 Compositing Guide (Network)

Generation Tab
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• Emission: 
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• Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.
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• Type: You may want to design a variety of different drawings that will vary up the appearance of 
your particle system. In this case, you should put each drawing on its own cell in the drawing 
layer. Each drawing will then be a new Type of particle.
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• Type Generation Strategy: This allows you to choose between Sequentially assigning a type 
(moving from one drawing to the next) or Randomly.

511



Chapter 7: Effects     Particle Effects

• Particle Type 0: This is the frame number where the first drawing can be found. If you have a 5-
frame cycle that starts on frame 1, you would put a 1 here.
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• Particle Type 1: This is the frame number where the last drawing can be found. If you have a 5-
frame cycle that starts on frame 1, you would put 5 here.
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• Age:
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• Age at Birth: A different start frame number can be entered in this field. This means that a 
particle can start with a different drawing than the drawing that you have on frame 1.
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• Age at Birth Standard Deviation: Allows a random deviation for the birth of the particles. If you 
have a 5-frame cycle that starts on frame 1, but you want the particles to be of a random type, 
then you may want to set the Age and Birth to 3 with a standard deviation of 2. That means that 
particles will randomly be born at any frame from 1 to 5.
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• Advanced:
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• Particles Mass: Define a mass for the particles. This mass will affect how the particles interact 
with gravity.
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• Align Initial Velocity: This aligns the initial velocity with the region from which the particles are 
being emitted. If you are emitting from a sphere, then the particles will all start out moving away 
from the centre of the sphere.
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Rendering Tab
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• Transformation: 
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• Size over Age: Use this value to set how you would like the size of the particle to change as it 
ages. Attach a function to this attribute if you would like to, for example, have the particles get 
smaller as time goes on.

522



Harmony 11.1 Compositing Guide (Network)

• Directional Scale: Check this checkbox if you would like to scale the particle in the direction of its 
movement.
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• Directional Scale Exponent Factor: Set an exponent here for how much you would like that 
particle to scale.
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• Align with Direction: Check this checkbox if you would like to align the particle in the direction of 
its movement.
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• Axis to Align: Select the axis that you would like to align from the drop-down box. This axis 
refers to the axis of the Drawing grid from the Drawing module plugged into the emitter
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• Flip X Axis to Match Direction: You might want to have the particle align to the X direction of 
movement. You can see this property being used in the Lemmings example.
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• Flip Y Axis to Match Direction: Similar to flipping the X axis, you may wish to flip the Y axis of a 
drawing to match the direction of the particle movement.
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• Use Rotation of Particle: Check this checkbox to enable rotation on the particle.
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• Keep Volume: When you choose to do a Directional Scale, then this will automatically maintain 
the volume of the particle by squashing it proportionally to how much it stretches as a result of 
the directional scale.
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• Colouring:
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• Colouring Strategy: This drop-down box allows you to set how you would like to define the 
colour of the particle.
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• Use Drawing Colour: In this case, the particle will remain the same colour as it was drawn with.

533



Chapter 7: Effects     Particle Effects

• Map RGB Based on Age: Attach a function to this to vary the Red, Green, and Blue values of the 
particle as it ages.
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• Map RGBA Based on Age: Attach a function to this to vary the Red, Green, Blue, and Alpha 
values of the particle as it ages.
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• Apply Opacity Based on Age: Keep the original RGB values from the drawing, but vary the 
Alpha (Opacity) according to a function that you define here.
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• Map RGB Based on Frame: Change the Red, Green, and Blue values of the particles based on 
the frame. Changing based on the frame means that ALL particles will change colour on that 
frame, regardless of their age.
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• Map RGBA Based on Frame: Change the Red, Green, Blue, and Alpha values of all particles on a 
given frame by attaching a function.
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• Apply Opacity Based on Frame: Use the original RGB values from your drawing, but vary the 
Alpha (Opacity) of the particles on a certain frame by attaching a function to this.

539



Chapter 7: Effects     Particle Effects

• Red, Blue, Green: This is where you can attach functions to Red, Blue, and Green values. You can 
also click on the colour swatch to adjust the colour.

• Alpha: This is where you can attach a function to the Alpha (Opacity) of your particles.

• Compositing:

• Blur: Define whether you would like to apply a Blur to the particles.

• No Blur: No blur will be applied to the particles.

• Directional Blur Based on Age: Attach a function to define how you would like the particles to 
blur based on the age of each particle. The particle will blur in the direction of movement.

• Directional Blur Based on Frame: Attach a function to define how all particles should be blurred 
at a particular frame. The particle will blur in the direction of movement.

• Low Quality Radial Blur Based on Age: Attach a function to define how you would like the 
particles to blur based on the age of each particle. This will be a low quality blur.

• Low Quality Radial Blur Based on Frame: Attach a function to define how all particles should be 
blurred at a particular frame. This will be a low quality blur.

• Low Quality Radial Blur Based on Camera Distance: Define how you would like the particles to 
blur based on their distance from the camera. This is a low quality blur. 

• High Quality Radial Blur Based on Age: Attach a function to define how you would like the 
particles to blur based on the age of each particle. This is a high quality blur.

• High Quality Radial Blur Based on Frame: Attach a function to define how all particles should be 
blurred at a particular frame. This is a high quality blur.

• High Quality Radial Blur Based on Camera Distance: Define how you would like the particles to 
blur based on their distance from the camera. This is a high quality blur. 

• Blur Intensity: This is where you can set a value, or attach a function to animate the blur 
according to the type of blur that was defined from the drop-down list.

• Falloff Rate: The distance where the blur fades from the edge of the image. Select a value 
between 0 and 1.

• A falloff rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of 
the drawing to the farthest edge of the blur.

• A falloff rate of 1 causes the blur to fade out quickly so that the blur is heaviest at the edge of the 
drawing. 

• Blend Mode: Define a blend mode for the particles to get cool effects.

• Blend Intensity: This is a percentage of how opaque you would like the particles to be blended. 
A value of 50 would be 50% transparent. A value of 100 would be fully opaque.

Kill

This module determines when you want particles to disappear.
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Layer Properties

Use the Kill Module's Layer Properties panel to adjust the effect's parameters.

• Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

• Kill Younger:There are only a couple of specific scenarios where you might want to use this 
property. In order to make use of Kill Younger, you would generally want to attach a function to 
this property. The reason for this is, if you just turn on a "Kill Younger" right away at time 0, then 
you'll never see any particles. For example say that you set Kill Younger to 10, at time 0, there 
will be no particles that are older than 10, so you'll never see any particles. What you might want 
to do, however, is have your particles animating over time, and at some point in time, you may 
suddenly want to kill all the younger particles. Let's take the example of an animation where the 
particles change from blue to yellow. At every frame, new particles are generated, and the 
particles that already exist age. There might come a point, perhaps where you do something 
like an explosion, where you want to kill all the particles that are younger than 10 frames old - so 
in my example it would kill all of the blue particles, leaving only the yellow particles.

• Kill Younger Than:This is where you could animate the effect for "Kill Younger."

• Kill Older:When this option is checked, particles will disappear when they reach a certain level of 
maturity.

• Kill Older Than: Set the age at which particle will disappear.

Move Particles

This module allows you to determine whether the particles are stationary (like grass) or moving (like 
rain), and you can animate this function on and off. 
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Layer Properties

Use the Move Module's Layer Properties panel to adjust the effect's parameters.
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• Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

• Age Particles:Check this checkbox to age the particles. Be aware that if you check "Move Position" and 
"Move Angle," then the particles will age implicitly. If you do not want the particles to move, however, 
and you do still want them to age, then uncheck Move Position and Move Angle, and check Age 
Particles. The "Age Particles" property also exists in the Baker, however whatever happens in the Baker 
happens after everything else in the particle system. So, if for example you have a Kill module, it will kill 
the particles before it ages them, and you probably want to age the particles before you determine 
whether to kill them. Therefore, if you have a Kill module, make sure to age the particles in your Move 
module before you kill them. If you age the particles both in the Move module as well as in the Baker, 
then the particles will age twice on that frame instead of once.

• Move Position: Check this checkbox to enable movement on the particles. There is also a 
"Move Particles"  checkbox in the Baker. If it is disabled in the Baker and in the Move module, 
the particles will not move, they will simply generate in place and stay there. If the checkbox is 
checked on the Baker, the particles will move, but if you need the particles to interact with 
another Action, say a Sink, then you want the Particles to move before they reach the sink. This 
is why you have a separate Move module, so that you can place this Move before (to the right of) 
the Sink in your Particle System Composite.

• Move Angle: Like the Move Position, this checkbox will enable the rotation of particles in the particle 
system. 

• Make Particles Follow each Other:  This property allows one particle to follow another particle, 
through an attraction between the particles. This is particularly useful when you want to create a 
snake-like effect, where the particles are animating across the screen and following each other.

• Follow Intensity: Adjust the strength of the attraction between particles that are following each 
other.

Orbit

The Orbit module allows you to define an axis that the particles will be attracted to and orbit around. 
Plug a peg layer into the orbit to move the position of the orbit without adjusting the parameters in 
the Layer Properties.

Fine-tuning the Orbit module can take a little finesse, because the orbit takes into account the velocity 
of the particles, and uses this to determine whether the particle will orbit around the axis, whether it 
will be influenced but eventually escape, or whether it will hardly be influenced at all. This is just like 
how Gravity between astral bodies works in space.

See a couple of examples of how having the orbit in the wrong place can give some cool (but perhaps 
not useful) effects:
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You will also want to make sure that your initial velocity is varied, so use an interpolated speed and set 
two different values, that way there will be a spread between them. If not, then you will get the effects 
as shown above.

Also, you should use the peg layer to move the position of the Orbit module around until you find the 
right spot to get the look you're trying to achieve. It also helps to set some Pre-Roll frames on your 
Baker to get things ramped-up before you start to manipulate the position of the Orbit module.

See an example of what a typical Network involving an Orbit module looks like:

Layer Properties

Use the Orbit Module's Layer Properties panel to adjust the effect's parameters.
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• Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

• Orbit Type: Select the type of Orbit you'd like to use from the drop-down list. For most 
scenarios, like asteroids orbiting a planet, then a point will suffice for this. If you would like to 
rotate around an axis instead, then choose between the X, Y, Z axes or set up your own custom 
axis.

• Magnitude: Adjust the amount that the acceleration of each particle will be adjusted. The higher 
this value, the more the particle will accelerate towards the orbit. A magnitude of 0.001 is a 
good number to use for this. When the magnitude is set too high, the particles will simply fly out 
into space.

• Point X:Defines the X position of the centre of the Orbit. You may also leave this at 0 and use a 
peg to move the position of the Orbit module.

• Point Y:Defines the Y position of the centre of the Orbit.

• Point Z:Defines the Z position of the centre of the Orbit.

• Direction X:Defines the X component of the axis of rotation for the orbit. This is only taken into 
account if you choose to set up a custom axis. If this is set to 1, and Y and Z are set to 0, then the 
axis will be going in the same direction as the X axis. If the X component is set to 1, and the Y 
component is also set to 1, then the axis will be at a 45 degree angle between the two.

• Direction Y:Defines the Y component of the axis of rotation for the orbit.

• Direction Z:  Defines the Z component of the axis of rotation for the orbit.

Planar Region
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Like the 3D region, this determines a region that could be used as a source or as a bounce plane, but 
instead of a 3D region it's a 2D plane. Connect a peg to the right in-port to adjust the position of the 
plane.

Layer Properties

Use the Planar Region's Layer Properties panel to adjust the effect's parameters.
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• General:

• Shape Type: This is where you can define the shape of the plane. The parameters that you can 
adjust below will be greyed out depending on which shape type you choose. Each shape can be 
adjusted from the Camera view using the Transform Tool by selecting the Planar Region and 
then selecting View > Show > Control.

• Rectangle: Adjust the width and height on a rectangle.

• Disc: Adjust the point (the centre) of the disk. You may also adjust values for minimum and 
maximum radius. A minimum radius of 0 will simply be a circle.

• Triangle: Adjust the three points of the triangle independently.

• Line: Adjust two points on a line.

• Point: Adjust the position of one single point.

• Image: If you choose to use the Image option, then you should make use of the left in-port of the 
Planar-Region to connect a drawing layer that can be used as a mask.

• Size:  

• Width: Adjust the width of a rectangular region.

• Height: Adjust the height of a rectangular region.

• Radius:

• Minimum: Adjust the minimum radius on a disc region.

• Maximum: Adjust the maximum radius on a disc region.

• P1:

• X: Adjust the X position of Point 1. Point 1 could refer to the point on a triangle, a line, or a point.

• Y: Adjust the Y position of Point 1.

• P2:

• X: Adjust the X position of Point 2. Point 2 could refer to the point on a triangle or a line.

• Y: Adjust the Y position of Point 2.

• P3:

• X: Adjust the X position of Point 3. Point 3 refers to a point on a triangle.

• Y: Adjust the Y position of Point 3.

Random

Allows you to put a random seed on some qualities like acceleration, speed, rotation speed, and 
position. There is also a Seed value in the Baker, but you may only want to make one particular aspect 
of the system random. This module gives the control over the randomness of a particular property.
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Layer Properties

Use the Random Module's Layer Properties panel to adjust the effect's parameters.
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• Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

• Parameter:  Allows you to choose which parameter you would like to make random.

• None

• Acceleration

• Speed

• Rotation Speed

• Position

Region Composite

This module can composite together multiple regions, 3D Regions or Planar Regions. You may wish to 
emit particles from multiple regions in the same particle system.
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Repulse

This module will repulse a particle around a region, but different from bounce, it's repelled before it 
physically hits the region.

Layer Properties

Use the Repulse Module's Layer Properties panel to adjust the effect's parameters.
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• Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

• Magnitude: This value should be between 0 and 2. The higher the value, the more drastically the 
particles will be repulsed.

• Look Ahead: This value alters how far ahead of the particle's current position it will look to see 
whether there's an obstacle coming ahead. This value should be between 0 and 100.

• Epsilon: This value affects how quickly the effect of the repulse wears off. The smaller the 
number, the longer the effect lasts. This value should be between 0.1 and 0.0001.

Rotation Velocity

This module allows you to define the initial rotational velocity of the particles. The values that you set 
up for this module refer to each individual particle's drawing axes. This means that if you choose to 
rotate around the X axis, it will rotate around each particle's local X axis as defined by its drawing 
plane.

The rotational velocity should be set before you emit the particles, i.e. to the right, so that the velocity 
is taken into account when the particles are created.

Layer Properties

Use the Rotation Velocity's Layer Properties panel to adjust the effect's parameters.
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• General:

• Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

• Axis Type: Select the type of axis you would like to use.

• Constant Axis: If you choose to rotate the particles around a constant axis, then each particle 
will rotate around the same axis. This axis will then be defined as Axis0.

• Interpolated Axis: If you choose to rotate the particles around an interpolated axis, that means 
each particle will have its own rotational velocity which lies somewhere between Axis0 and Axis1.

• Use Input Shape: Use a region to define the rotation axis of the particles. The axis of each 
particle's rotation will be perpendicular to the plane that particle is created on.

• Axis:

• Axis0 X: Define the X component of Axis0. If you set the X to 1, and the Y and Z to 0, then the 
particle will rotate around its X axis as defined by its drawing plane. If you set X to 1 and also Y to 
1, then it will rotate around an axis that is 45 degrees between X and Y.

• Axis0 Y: Define the Y component of Axis0.

• Axis0 Z: Define the Z component of Axis0.

• Axis1 X: Define the X component of Axis1. This applies only when you have selected an 
Interpolated axis.

• Axis1 Y: Define the Y component of Axis1.

• Axis1 Z: Define the Z component of Axis1.

• Speed (Degrees / Frame):

• Minimum: Enter the minimum initial rotation that a particle can have, in degrees per frame.

• Maximum: Enter the maximum initial rotation that a particle can have, in degrees per frame.

Sink

This module will cause the particles to disappear when outside of the region plugged into the sink. It 
can also be inverted, so that the particles disappear when they enter the region instead.

Layer Properties

Use the Sink Module's Layer Properties panel to adjust the effect's parameters.
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• Invert: The default behaviour of the sink is for particles to disappear when they depart the 
region. When inverted, the particles disappear when they enter the region instead.

Size

This allows you to animate the size of the particles.

Layer Properties

Use the Size Module's Layer Properties panel to adjust the effect's parameters.
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• Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

• Size Type: If you choose Constant Size, then all particles will be animated to have the same size. 
If you choose Input Shape instead, then you must input a Region into the in-port of the Size 
module. It will use this region to determine the size of the particles.

• Size: Change this value to adjust the size of the particles.

Sprite Emitter

This is your all-purpose emitter, that you can plug a drawing layer into, and it will generate particles 
that look like your drawing layer. You could also just output dot particles if you have no image layer 
connected. There are many parameters to determine how you would like to emit your particles. 

Layer Properties

Use the Sprite Emitter's Layer Properties panel to adjust the effect's parameters.
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Generation Tab

558



Harmony 11.1 Compositing Guide (Network)

• Emission: 
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• Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.
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• Number of Particles: This is where you can define how many particles will be emitted on each 
frame.
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• Probability of Generating Any Particles: This is a probability percentage between 0 and 100. If 
the probability is set to 100%, it will absolutely generate the Number of Particles specified. If you 
put the percentage down to 50%, then there's only a 50% chance that it will generate the number 
of particles set in Number of Particles. Play with this value to add random spacing to the 
generation of particles.
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• Type: You may want to design a variety of different drawings that will vary up the appearance of 
your particle system. In this case, you should put each drawing on its own cell in the drawing 
layer. Each drawing will then be a new Type of particle.

• Type Generation Strategy: This allows you to choose between Sequentially assigning a type 
(moving from one drawing to the next) or Randomly assigning a type.

• Particle Type 0: This is the frame number where the first drawing can be found. If you have a 5-
frame cycle that starts on frame 1, you would put a 1 here.

• Particle Type 1: This is the frame number where the last drawing can be found. If you have a 5-
frame cycle that starts on frame 1, you would put 5 here.

• Age:

• Age at Birth: A different start frame number can be entered in this field. This means that a 
particle can start with a different drawing than the drawing that you have on frame 1.

• Age at Birth Standard Deviation: Allows a random deviation for the birth of the particles. If you 
have a 5-frame cycle that starts on frame 1, but you want the particles to be of a random type, 
then you may want to set the Age and Birth to 3 with a standard deviation of 2. That means that 
particles will randomly be born at any frame from 1 to 5.

• Advanced:

• Particles Mass: Define a mass for the particles. This mass will affect how the particles interact 
with gravity.

• Region Size for Baked Particle Input: The Baked Particle Input property refers to when you use 
a Baker as an input to a Sprite Emitter. You can do this when you want to generate particles from 
other particles. When you do this, you have the option of setting a sphere around the source 
particle from which the new particle system will generate particles. That is the region which is 
referred to in this value. If you look at the following example, you'll see that the purple smiley 
faces are generating smaller green, blue, and yellow smiley faces. This is done by plugging the 
Baker from the purple smiley faces into the Sprite Emitter of the other smiley faces. 
See the following images:
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• Copy Particle Velocity for Baked Particle Input: If you select this option, the velocity of the 
parent system will be applied to the child system when a Baker is used as the region for a Sprite 
Emitter.
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• Add Particle Age for Baked Particle Input: If you select this option, the age of the parent system 
will be inherited by the child system when a Baker is used as the region for a Sprite Emitter.
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• Align Initial Velocity: This aligns the initial velocity with the region from which the particles are 
being emitted. If you are emitting from a sphere, then the particles will all start out moving away 
from the centre of the sphere.
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• Minimum Initial Rotation: Define a minimum rotation in degrees that the particle can have when 
it is generated. There is also a separate Rotation-Velocity module in which you can define this 
parameter.

• Maximum Initial Rotation: Define a maximum rotation in degrees that the particle can have when 
it is generated.

Rendering Tab

• Sprite Selection:

• Rendering Strategy: Select a method to use to decide which particle type will be defined for 
each particle that is created.

• Render as Dot: This will simply render each particle as a dot. This is useful mainly for previewing 
the effects of your particle system without using the drawing layer (sprite)

• Use Frame Number: As the frame number increases, the type of particle will change to match 
the frame number. This means that ALL particles in the system will change together as the frame 
number changes. If you only have a few drawings, then you may want to enable Cycling in order 
to cycle those drawings.

• Use Frame Number as Index in Selector: When you select this option, then you may use the 
Selector option to animate the Frame Number that it uses over time. Meaning, instead of taking 
the current frame as the Frame Number, you can write your own function instead. For example, if 
I were to animate the selector so that at frame 1, it starts out at 2, then 8 frames later I add 
another keyframe to set the value to 4, between the frame 1 and frame 8 the particles will all 
change type together from what they look like on frame 2 to what they look like on frame 4.

• Use Particle Type: Each particle that is generated will look like the Particle Type that was 
assigned under the Generation tab. For example, if you put 1 for Particle Type 0, and then you 
put 6 for Particle Type 1, then each particle will be assigned a type from 1 to 6. This type 
corresponds to the drawing that appears on the sprite on that frame number. So if I have a 
drawing layer called Sprite that I have plugged into the left in-port of my Emitter, it will look for 
the drawings in cells 1 to 6 of Sprite to assign those drawings to each Particle.

• Use Particle Type as Index in Selector: This option allows you to use the Selector to manually 
create a function that assigns how many of which particle will be created. For example, we can 
set the Particle Type to go from 1 to 100, in the Generation tab. Then we will use the Selector to 
remap the particle types to a certain drawing. So for example I could create 5 drawings, labelled 
1 to 5, and I can use my selector to say I'd like to create mainly 1s, no 2s, a few 3s, 4s, and a very 
few 5s. What it's doing is, it is looking at the x-axis to find what the particle "type" is, then it is 
looking at the y-axis to find out which drawing to assign to that "type." When you use 1 to 100 as 
a type, then when you're setting the values, they act in fact as a percentage. See the following 
images for further clarification:

567



Chapter 7: Effects     Particle Effects

• Use Age: As the particle ages, it will change appearance from what appears on the Sprite's first 
drawing to the subsequent drawings. This means that each particle can have its appearance 
animated as it gets older.
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• Use Age as Index in Selector: You can animate the Selector in order to change how a particle 
ages over time. For example, if I have a Sprite that has 6 drawings on it, I might want to animate 
it so that it changes from drawing 1, on frame 1, to drawing 2, on frame 10, then drawing 3 on 
frame 14, drawing 4 on frame 16, drawing 5 on frame 17, etc. so that the particle rapidly ages. 
This allows me to change the timing of the aging dynamically through the selector, instead of 
having to modify the exposure of the cells on the Sprite.

• Selector:Animate the Selector in conjunction with the Rendering Strategy to adjust the 
parameters that control the particle’s appearance at birth and over time.

• Cycling: If you're using rendering strategies like Frame Number or Age, you may want to cycle 
the drawings. For example, if you are using Frame Number, but you've only got 5 frames worth 
of drawings in your Sprite, then if you use "No Cycle," your Particles will disappear after frame 5. 
You can choose to cycle Normally, 1-2-3-4-5-1-2-3-4-5, or Back and Forth, 1-2-3-4-5-4-3-2-1.

• Number of Drawings in Cycle: You should indicate how many frames from your Sprite you'd like 
to cycle.

• Transformation:  

• Size over Age: Use this value to set how you would like the size of the particle to change as it 
ages. Attach a function to this attribute if you would like to, for example, have the particles get 
smaller as time goes on.

• Directional Scale: Click this checkbox if you'd like to scale the particle in the direction of its 
movement.

• Directional Scale Exponent Factor: Set an exponent here for how much you'd ike that particle to 
scale.

• Align with Direction: Check this checkbox if you'd like to align the particle in the direction of its 
movement.

• Axis to Align: Select the axis that you'd like to align from the drop-down box. This axis refers to 
the axis of the Drawing grid from the Drawing module plugged into the emitter.

• Flip X Axis to Match Direction: You might want to have the particle align to the X direction of 
movement. You can see this property being used in the Lemmings example.

• Flip Y Axis to Match Direction: Similar to flipping the X axis, you may wish to flip the Y axis of a 
drawing to match the direction of the particle'd movement.

• Use Rotation of Particle: Check this checkbox to enable rotation on the particle.

• Keep Volume: If you choose the Directional Scale option, then Keep Volume will become 
available. This option maintains the volume of the object by squashing it in one axis when it 
stretches it in another.

• Colouring:

• Colouring Strategy: This drop-down box allows you to set how you would like to define the 
colour of the particle.

• Use Drawing Colour: In this case, the particle will remain the same colour as it was drawn with.

• Map RGB Based on Age: Attach a function to this to vary the Red, Green, and Blue values of the 
particle as it ages.

• Map RGBA Based on Age: Attach a function to this to vary the Red, Green, Blue, and Alpha 
values of the particle as it ages.

• Apply Opacity Based on Age: Keep the original RGB values from the drawing, but vary the 
Alpha (Opacity) according to a function that you define here.

• Map RGB Based on Frame: Change the Red, Green, and Blue values of the particles based on 
the frame. Changing based on the frame means that ALL particles will change colour on that 
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frame, regardless of their age.

• Map RGBA Based on Frame: Change the Red, Green, Blue, and Alpha values of all particles on a 
given frame by attaching a function.

• Apply Opacity Based on Frame: Use the original RGB values from your drawing, but vary the 
Alpha (Opacity) of the particles on a certain frame by attaching a function to this.

• Red, Blue, Green: This is where you can attach functions to Red, Blue, and Green values. You can 
also click on the colour swatch to adjust the colour.

• Alpha: This is where you can attach a function to the Alpha (Opacity) of your particles.

• Compositing:

• Blur: Define whether you'd like to apply a Blur to the particles.

• No Blur: No blur will be applied to the particles.

• Directional Blur Based on Age: Attach a function to define how you would like the particles to 
blur based on the age of each particle. The particle will blur in the direction of movement.

• Directional Blur Based on Frame: Attach a function to define how all particles should be blurred 
at a particular frame. The particle will blur in the direction of movement.

• Low Quality Radial Blur Based on Age: Attach a function to define how you would like the 
particles to blur based on the age of each particle. This will be a low quality blur.

• Low Quality Radial Blur Based on Frame: Attach a function to define how all particles should be 
blurred at a particular frame. This will be a low quality blur.

• Low Quality Radial Blur Based on Camera Distance: Define how you would like the particles to 
blur based on their distance from the camera. This is a low quality blur. 

• High Quality Radial Blur Based on Age: Attach a function to define how you would like the 
particles to blur based on the age of each particle. This is a high quality blur.

• High Quality Radial Blur Based on Frame: Attach a function to define how all particles should be 
blurred at a particular frame. This is a high quality blur.

• High Quality Radial Blur Based on Camera Distance: Define how you would like the particles to 
blur based on their distance from the camera. This is a high quality blur. 

• Blur Intensity: This is where you can set a value, or attach a function to animate the blur 
according to the type of blur that was defined from the drop-down list.

• Falloff Rate: The distance where the blur fades from the edge of the image. Select a value 
between 0 and 1.

• A falloff rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of 
the drawing to the farthest edge of the blur.

• A falloff rate of 1 causes the blur to fade out quickly so that the blur is heaviest at the edge of the 
drawing. 

• Blend Mode: Define a blend mode for the particles to get cool effects.

• Blend Intensity: This is a percentage of how opaque you would like the particles to be blended. 
A value of 50 would be 50% transparent. A value of 100 would be fully opaque.

System Composite

This is where you connect together all of the "Actions" of your particle system. An action is any of the 
light purple modules, like Gravity, Emitters, velocity parameters. All of the "Actions" help to define 
the behaviour of the particle system.
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Turbulence

The Turbulence effect is a mathematically generated effect that uses fractal noise to create turbulent 
distortions in an image. You can see the effect when used with an image as the background. You can 
create flowing water, funhouse mirrors, and waving flags.

For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/video-
tutorials/chapter/adam-phillips-harmony-effects.
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Turbulence Effect Properties 

Parameter Description
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Noise Type

Lets you select a type of noise pattern.

Perlin: Creates pseudo random patterns. The greyscale 
contains a continuity between different tones of grey.

Simplex: Creates a more contrasted noise pattern with more variation 
than Perlin. There is a smooth variation of intensity.

Sinusoidal: Creates a repeated wavelike pattern.

Sub Scaling: Applies Perlin noise twice. The second noise is 
added where dark areas appear in the original. The frequency 
of the second iteration is higher so the noise is smaller.

Rocky: Uses the Perlin pattern but converts the very high and low values 
to more moderate values. For example, the whites become light greys 
and the blacks become dark greys.

Small Bumps: Uses the Perlin pattern. The transitional grey 
areas between blacks and whites become inverted so they look 
like dark lines. The extremes, black and white areas, become 
whitish.

Fractal Type

Transforms the noise pattern, created by the Noise type and controls the 
way layers are composited. These are variations of the basic noise.

Turbulent Twist: Applies a turbulent effect on the pattern so it changes 
the transition between black and white by adding more modulation.

Fractional Brownian: Applies a basic application of noise and composites 
by adding subsequent layer with the Complexity parameter.

Threshold: Changes the dark greys into black values so there is more 
black in the noise for higher contrast.

Invert Threshold: Inverts all the values of the Threshold type so a neg-
ative image of it is created.

 
Terrain: Adds contrast and converts the dark greys into white or light 
greys.

Pinning Constrains the effect within the image boundaries.

Amount Specifies the amplitude of displacement.

Frequency
The density of displacement appearing in the noise. A higher value pro-
duces a greater amount of displacement in a given area; a lower value pro-
duces a smaller amount.

Offset Moves the entire image.

Seed
This value determines the starting noise pattern on the first evolution of 
the effect.

Locked Applies parameter value while retaining the X and Y ratio.

Separate Allows you to apply different parameter values to X and Y.

xy
When locked, applies parameter values to both X and Y. When sep-
arated, allows you to apply different value to X and Y.
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Evolution Determines the displacement pattern over time.

 

Evolution Frequency: This factor makes the complexity iterations anim-
ate or transform at a higher speed. In other words, the second, third, etc. 
passes, controlled by the Complexity parameter, will mutate faster than 
the main one.

Complexity

Complexity: The number of noise layers that make up the 
noise. Each successive layer has a higher frequency, resulting in 
a smaller noise effect. You can have up to seven passes. 
Increasing this number increases the depth and amount of 
detail in the noise. Use Complexity with Sub Scaling when the 
value is 1 or greater. Note: Increasing the Complexity results in 
longer rendering times. 

 

Gain: Controls the amount of opacity present in the iteration of noise. 
This also affects the layer when using Sub Scaling. With a value of 0, you 
will not see the sub noise. A value of 1 will show the sub noise just as 
strong as the main one. For example, with water ripples, a higher amount 
of Gain will reveal more ripple or subripples.

 

Sub Scaling: The factor by which the main noise is modified at each iter-
ation of complexity. A value of 1 make the two noises identical. A value of 
2 makes the sub noise twice as small. The next iteration would be 4 times 
smaller. Values must be greater than 1.
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Turbulent Noise

The Turbulent Noise effect uses Perlin noise to create greyscale noise for organic-looking 
backgrounds, displacement maps, and textures, or to simulate clouds, fire, lava, steam, flowing 
water, or vapour. The Turbulent Noise effect models turbulent systems with smaller noise features 
moving more quickly than larger noise features.  The Turbulent Noise effect creates smooth animations 
and takes less time to render than other noise or grain effects. 

For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/video-
tutorials/chapter/adam-phillips-harmony-effects.
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Turbulent-Noise Effect Properties 

Parameter Description

Noise Type

Perlin: Creates pseudo random patterns. The greyscale 
contains a continuity between different tones of grey.

Simplex: Creates a more contrasted noise pattern with more variation 
than Perlin. There is a smooth variation of intensity.

Sinusoidal: Creates a repeated wavelike pattern.

Sub Scaling: Applies Perlin noise twice. The second noise is added where 
dark areas appear in the original. The frequency of the second iteration is 
higher so the noise is smaller.

Rocky: Uses the Perlin pattern but converts the very high and low values 
to more moderate values. For example, the whites become light greys 
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and the blacks become dark greys.

Small Bumps: Uses the Perlin pattern. The transitional grey areas 
between blacks and whites become inverted so they look like dark lines. 
The extremes, black and white areas, become whitish.

Fractal Type

Transforms the noise pattern, created by the Noise type and controls the 
way layers are composited. These are variations of the basic noise.

Turbulent Twist: Applies a turbulent effect on the pattern so it changes 
the transition between black and white by adding more modulation.

Fractional Brownian: Applies a basic application of noise and composites 
by adding subsequent layer with the Complexity parameter.

Threshold: Changes the dark greys into black values so there is more 
black in the noise for higher contrast.

Invert Threshold: Inverts all the values of the Threshold type so a neg-
ative image of it is created.

Terrain: Adds contrast and converts the dark greys into white or light 
greys.

Frequency
The density of displacement appearing in the noise. A higher value pro-
duces a greater amount of displacement in a given area; a lower value pro-
duces a smaller amount.

Offset Moves the entire image.

Locked Applies parameter value while retaining the X and Y ratio.

Separate Allows you to apply different parameter values to X and Y.

xy
When locked, applies parameter values to both X and Y. When sep-
arated, allows you to apply different value to X and Y.

Evolution Determines the displacement pattern over time.

 

Evolution Frequency: This factor makes the complexity iterations anim-
ate or transform at a higher speed. In other words, the second, third, etc. 
passes, controlled by the Complexity parameter, will mutate faster than 
the main one.

Complexity

Complexity: The number of noise layers that make up the noise. Each suc-
cessive layer has a higher frequency, resulting in a smaller noise effect. 
You can have up to seven passes. Increasing this number increases the 
depth and amount of detail in the noise. Use Complexity with Sub Scaling 
when the value is 1 or greater. Note: Increasing the Complexity results in 
longer rendering times. 

 

Gain: Controls the amount of opacity present in the iteration of noise. 
This also affects the layer when using Sub Scaling. With a value of 0, you 
will not see the sub noise. A value of 1 will show the sub noise just as 
strong as the main one. For example, with water ripples, a higher amount 
of Gain will reveal more ripple or subripples.

 
Sub Scaling: The factor by which the main noise is modified at each iter-
ation of complexity. A value of 1 make the two noises identical. A value of 
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2 makes the sub noise twice as small. The next iteration would be 4 times 
smaller. Values must be greater than 1.

 
Depth:  This value determines the composition order when the Z value of 
two elements is the same.

 

Velocity

This defines the initial velocity of the particles that are emitted in the particle system. You may select 
this module and select View > Show > Control to display manipulation handles to help you set the 
parameters of this module. Use your Transform Tool to modify the manipulation handles in the 
Camera View or the Perspective View.

Layer Properties

Use the Velocity Module's Layer Properties panel to adjust the effect's parameters.
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• General:

• Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

• Bilateral: This option serves to generate positive and negative velocities in a given direction. For 
example, you can generate particles with cone-shaped velocity, (e.g. a bazooka firing) going only 
in the forward direction, but you can also generate velocities in the opposite direction.

• Velocity Type: 

• Use Input Shape: If you plug a Region into the in-port of the Velocity module, it will 
take the shape of this region to determine the initial velocity of the particles. They 
will take a velocity that is perpendicular to the surface of the shape.

• Constant Speed: Set a constant speed for the initial velocity of the particles.

• Interpolated Speed: Each particle will be assigned an initial speed that is 
somewhere between the two values set for Interpolated Speed.

• Random in All Directions 2D: All particles will be assigned a random velocity in any 
direction on a 2D plane.

• Random in All Directions 3D: All particles will be assigned a random velocity in any 
direction.

• Random in Cone: Particles will be assigned an initial velocity anywhere in the shape 
of a cone.

• Random in 2D-Pie: Particles will be assigned an initial velocity anywhere in the 
shape of a pie slice on a 2D plane.
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• Direction of Normal (for Random in All Directions 2D):Use these values to input the 
perpendicular direction for the property Random in All Directions 2D.

• X: Set a value between 0 and 1 to determine how much influence the X axis has over the direction 
of the normal. For example, if the X value is set to 1, and Y and Z are set to 0, then the 
perpendicular (normal) will be going in the X direction. If X is set to 1, and Y is also set to 1, then 
the axis will be 45 degrees, halfway between X and Y. Feel free to use the Manipulation Handles 
for the velocity module by selecting the Velocity module and then selecting View > Show > 
Control. This will allow you to use the Transform tool in the Camera View or the Perspective View 
to set the appropriate values.

• Y: Set a value between 0 and 1 to determine how much influence the Y axis has over the direction 
of the normal.

• Z: Set a value between 0 and 1 to determine how much influence the Z axis has over the direction 
of the normal.

• Speed:

• Minimum: There are some speeds that are constant, and some that are a range of values 
between a minimum and maximum. Set the minimum speed here.

• Maximum: Set the maximum speed for interpolated speeds.

• Deviation from Direction:

• Minimum Angle: This is used for Cone and Pie shapes. Put a non-zero value here if you want 
there to be a hole in the middle of your cone or pie.

• Maximum Angle: Set the maximum angle for your cone or pie here.

Visualizer

The Partical-Visualizer module renders and flattens the particle system down to a single plane. You can 
plug a peg module into the left port to animate the position of the whole particle system. Plugging a 
peg into the right port will move the depth where the flat plane is generated, so you can move it 
behind or in front of various other drawing layers in your scene. You can even have two Visualizers with 
pegs in the right in-ports that are at different depths to display some particles in front of and some 
particles behind a character or drawing in the scene.

Visualizer Properties

Parameter Description

Force Render as Dots
Temporarily renders your system as Dots when previewing a 
simulation. All drawings are ignored and the system is forced 
to render as dots.
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Note: You can also use the option View > Particle > Show 
Particles as Dots in OpenGL. When enabled, the particles will 
always be displayed as dots in the OpenGL preview mode to 
make playback speed faster for heavy scenes.

Rendering Order

Lets you set the order in which you want the particles to appear 
in the render.

• Back to Front: Added particles will appear behind 
existing particles.

• Front to Back: Added particles will appear in front of 
existing particles.

• Oldest to Youngest: Older particles will appear behind 
younger particles.

• Youngest to Oldest: Older particles will appear in front 
of younger particles.

• Ascending Types: Lower types will appear behind higher 
types.

• Descending Types: Lower types will appear in front of 
higher types.

Fix Output Alpha

This is an important option when using some filters like Screen or Multiply 
in the Blend Mode that can be specified in the Rendering tab of the Emit-
ter. When working with premultiplied images, if the alpha is not fixed in 
the visualizer, you may see some unusual artifacts. 

Scale Particle System Using 
Parent Peg

Respects the scaling of a particle system so you can position 
and resize it as you like. Old scenes with particle system will still 
work as this option is disabled.

Global Scaling Factor Lets you set the scaling factor for particle system.

Vortex

This particle allows you to define an axis as a vortex, so the particles will spin around this axis.
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Layer Properties

Use the Vortex Module's Layer Properties panel to adjust the effect's parameters.
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• Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

• X Direction:Defines the X portion of the axis of rotation for the Vortex.

• Y Direction:Defines the Y portion of the axis of rotation for the Vortex.

• Z Direction:Defines the Z portion of the axis of rotation of the Vortex.

• Radius: Defines the radius at the top of the vortex.

• Exponent (1=cone): Defines a curve that gives the Vortex a certain silhouette. 1 forms a cone, 
greater than 1 curves inward.

• Up Acceleration:Defines the vertical acceleration of the particles that are inside the Vortex.

• In Acceleration:Defines the inward acceleration of particles that are outside the Vortex.

• Around Acceleration:  Defines the acceleration around the vortex of particles that are inside 
the Vortex.

Wind-Friction

This module allows you to define the amount of wind in the scene, and animate the wind over time.

Layer Properties

Use the Wind Friction's Layer Properties panel to adjust the effect's parameters.
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• Trigger: Is an on/off switch using binary code, where 1 = on, while 0 = off.

• Friction/Wind X: Defines the amount that the wind will dampen or increase the speed of the 
particles in the X direction.

• Friction/Wind Y:  Defines the amount that the wind will dampen or increase the speed of the 
particles in the Y direction.

• Friction/Wind Z:  Defines the amount that the wind will dampen or increase the speed of the 
particles in the Z direction.

• Min Speed: The minimum speed of particles that will be affected by the wind. Particles moving 
slower than this will not be affected.

• Max Speed:  The maximum speed of particles that will be affected by the wind. Particles moving 
faster than this will not be affected.
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Previewing and Playing Back Effects 

To preview your effects, you will have to perform a quick render. Effects must be calculated before 
they can be viewed in real time.

How to preview effects

1. In the Playback toolbar, click the Render and Play  button.

The Play module opens and loads the frames.

2. Once the frames are loaded, click the Play  button in the Play window.

Tip: While previewing effects, press Spacebar to stop and start playback.

Preview Resolution 

To make your previews calculate faster, you may want to render them out at a smaller resolution. You 
can use the Preview Resolution command so you will not have to modify the resolution of your scene 
every time you make a check preview.

The Preview Resolution command allows you to quickly ask for a preview at either a quarter, half or 
three-quarter of the scene resolution. You can even customize the preview resolution size.

How to use the Preview Resolution command

1. From the top menu, select View > Preview Resolutionand a resolution: Same as Scene 
Resolution, 3/4 of Scene Resolution, 1/2 of Scene Resolution, 1/3 of Scene Resolution, 1/4 of 
Scene ResolutionorCustom.

If you selected the Custom option, the Custom Preview Resolution dialog box opens.
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2. In the dialog box, select a resolution from the presets or type a new X-Y value.

3. Click OK.

4. Preview your effects animation.
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Extra Commands 

These are some useful commands you can find only in Harmony.

Recalculate 
All

Refreshes the network and 
rerenders the display when 
the Camera View is in 
render mode. 

In the select Network 
View menu, select
Edit > Recalculate All.

Recalculate 
Selected

Refreshes the network and 
rerenders the display of 
selected elements when the 
Camera View is in render 
mode.

In the Network View 
menu, select 
Edit > Recalculate 
Selected.

Auto 
Render 
Write

Renders a frame each time 
the current frame is 
changed. 

You must have a Write 
module in your network to 
use this command.

In the Network View 
menu, select 
Edit > Auto Render 
Write or press Ctrl + W 
(Windows/Linux) or ⌘  + 
W (Mac OS X).

Print 
Network

Prints the Network view. Select File > Print > 
Network.

In the Network View 
menu, select 
File > Print.
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Chapter 8: Export

Now that you have finished your animation, it is time to render your movie. Depending on whether you 
plan to further edit your movie in a third party software, composite the movie in a larger body of work 
or put it up directly on the web, Harmony supports several formats for all your rendering needs.

This chapter contains the following topics:

• Exporting a QuickTime Movie on the next page

• Exporting an SWF Movie on page 595

• Exporting OpenGL Frames on page 597

• Exporting a Sound File on page 599

• Advanced Export on page 601

• Batch Rendering on page 619
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Exporting a QuickTime Movie

If you require a video file, you can export your animation as a QuickTime movie. To render a 
QuickTime movie with transparency, you need to set the Depth setting to Millions of Colours +.

If your exported video is too small or too large, change the project size from the top menu in Scene > 
Scene Settings. This will change the size of the video output.

How to export a QuickTime Movie

1. From the top menu, select File > Export > Movie.

The Export to QuickTime Movie dialog box opens.

2. Click Browse and select a folder in which to save your movie and give it an appropriate file name 
for the export.

3. Click OK.

4. In the Display Source section, select the Display module to use for rendering your project.

If there is no Display module in the scene, the drop-down list will indicate Display All and render the 
scene in the same order as the Timeline view, including modules floating in the Network view. It is 
always recommended to render from the Display module, located under the final Composite 
module, unless you want to render a specific section isolated by a particular Display module.

5. From the Export Range section, decide whether you want to export the entire scene (All) or a 
specific frame range. If you decide on the latter, enter the frame range.

6. In the Resolution section, select one of the following from the menu:

‣ A preferred resolution ratio.

‣ Custom:  Enables the Width and Height fields so you can enter a specific size.
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7. In the Options section, click Movie Options.

Parameter Description

Video

Enables the customization of the video settings, filters and 
size.

Settings: Opens the Standard Video Compression Settings 
dialog box (see below).

Filter: Opens the Choose Video Filter dialog box, where 
you can select from a range of filters to apply to your video 
export.

Size: Opens the Export Size Settings dialog box. The size 
settings are overridden by the Harmony's scene settings.

Sound

Check this box to enable the customization of the sound set-
tings.

Settings: Opens the Sound Settings dialog box (see 
below).

Prepare for Internet Stream-
ing

Select this option to enable the customization of the Inter-
net streaming options.

8. In the Video section, click Settings.

The Standard Video Compression Settings dialog box opens.
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9. From the Compression Type menu, select a codec. The availability of certain compression settings 
depends on the Compression Type selected. For example, Animation is the default compression 
type and as a result the Data Rate option is greyed out. 

10. In the Motion section, choose a Frame Rate from the list. 

By default, it is set to match the frames-per-second (fps) of your Harmony project. If you choose a 
lower frame rate, your export playback will be faster than your actual project. The reverse is also 
true for a higher frame rate. 

11. If you want key frames inserted, select the Every option and set the number per frame. 

This is the option is recommended by QuickTime. Refer to the QuickTime documentation for further 
details.

12. In the Compressor section, choose a Depth based on your movie’s needs. For example, Millions of 
Colours+ houses an alpha channel.

13. In the Quality section, use the slider to choose a quality setting. Remember that the better the 
quality of the export, the larger the file.

14. From the Data Rate section, either choose to allow the program to automatically select the most 
optimal bit rate, or enter a Restricted rate to save space and allow for faster downloading at a cost 
to the quality of the export. 

15. In the same section, from the Optimized For menu, select the intended viewing method for the 
export.

16. Click OK.

17. From the Movie Settings dialog box, click Sound Settings.

The Sound Settings dialog box opens.
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18. From the Compressor menu, select a compression type. 

The default setting is None. This will preserve your original sound file without the loss of information. 
However, an uncompressed sound file will inevitably add “weight” to the overall size of your video 
export.

19. Select a Rate by pressing the arrow button next to kHz.

It is best to check and match the original properties of your sound file. For example, if your file has an 
audio sample rate of 48 kHz and you choose a conversion rate of 22.05 kHz, the sound will play at 
the same speed, but with higher frequencies missing.

For a standard film sound quality, choose 44.1 kHz, or 48 kHz for DVD quality. Anything less will 
make the sound “dull” or less bright. For things like recorded voice this doesn't matter so much, but 
for music it can make an audible difference.

If file size is a consideration, such as with videos for the Internet, then a lower rate might be more 
practical.

20. Next, choose the Size and the Use, which are related. Once again, it is advisable to check your 
original sound file properties. If the file was recorded in one channel (mono), there is little point in 
choosing the two channel (stereo) option. Although Mono can support a 16-bit channel, the extra 
information is unnecessary. Mono is generally paired with 8-bit and Stereo with 16-bit.

21. Click OK.

22. In the Export to QuickTime Movie dialog box, click OK.

A progress bar appears.

23. Browse to the location on your computer where you saved your QuickTime video and double-click on 
it to view the export.

How to set the depth to Millions of Colours + to export a QuickTime movie with 
transparency

‣ In the Standard Video Compression Settings dialog box, select Millions of Colors+ from the Depth 
menu—see Exporting a QuickTime Movie on page 590.

593



Chapter 8: Export     Exporting a QuickTime Movie

594



Harmony 11.1 Compositing Guide (Network)

Exporting an SWF Movie

The SWF export supports some bitmap effects (which can be previewed in Render View  mode) 
and SWF Blend Modes (vector effects which can be previewed in OpenGL View  mode). 

The following are also supported:

• Pencil line thickness: They are converted to brush strokes in the SWF file.

• Auto Patch module for creating joint patches.

If you have not already done so, you should preview the SWF by using the SWF preview  button to 
see what the two types of effects look like when blended together. Once you are satisfied with the 
results, go ahead and export your movie. 

How to export a SWF movie

1. From the top menu, select File > Export > SWF.

The Export to Flash Movie (SWF) dialog box opens.

2. Click Browse and choose an appropriate file name and a destination path for your movie.

3. In the Display Source section, select a Display module to read from in the Export From Display 
Module menu.

4. In the Export Range section, select one of the following options:

‣ All: To export all the frames of your movie.

‣ Frames: To export a frame range. Enter the frame range in the fields.
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5. In the Options section, enter your Frame rate (fps). By default, it will be set to match the fps of your 
Harmony project. If you choose a lower frame rate, your export playback will be faster than your 
actual project. The reverse is also true for a higher frame rate. 

6. In the same section, select the JPEG quality:

‣ 100 = Full quality

‣ 50 = Average quality at about 1/5th of the size.

‣ 25 = Medium quality where loss of high image resolution starts to occur.

‣ 10 = Low quality where “macro-blocking” or large pixelation become obvious.

‣ 1 = Lowest quality where there is extreme loss of colour and detail and the image becomes 
nearly unrecognizable. 

7. If you want to prevent your movie from being imported in another application, select the Protect 
from Import option.

8. Select the Compress Movie option if you want to get a lighter format. The movie may lose some 
quality, but the file will be lighter.

9. In the Disabled Effects section, select the effects you do NOT want to be rendered in the SWF 
movie.

Note that certain Harmony effects are not listed in this section as they are not compatible and 
therefore not available for SWF export. These effects will not appear in the SWF render. 

10. Click OK.

11. Browse to the location on your computer where you saved your Flash Movie and double-click on it 
to view the export.
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Exporting OpenGL Frames

You can export the OpenGL frames (fast display mode) if you need a quick render for your scene. 
Some heavier scenes containing 3D, multiple effects and camera moves can be fairly long to export.

Use the Export OpenGL Frames dialog box to select the frames you want to render from the OpenGL 
Camera view, then save the rendered frames as image files or as a QuickTime movie.

Frames saved from OpenGL view have neither antialiasing nor special effects. To render final frames 
with effects, export Images or a Movie.

How to export OpenGL Frames

1. From the top menu, select File > Export > OpenGL Frames.

The Export OpenGL Frames dialog box opens.

2. In the Output section, in the Location field, click Browse to select a folder for the frames.

3. In the Filename field, enter a name (prefix) for the frames or revert to the default name by clicking 
Default.

4. In the Format section, decide if you want to export individual image frames or a movie.

‣ Suffix: Lets you select the desired suffix. If you intend to render only a few frames, use 1 or 
01, whereas if you intend to render 1000 frames, you can select 0001.

‣ Drawing Type: Lets you select the file type to render, such as TGA or SGI. 

5. Click Movie Options to customize the Audio and Video settings for the *.mov export—see 
Exporting a QuickTime Movie on page 590. 

6. From the Resolution section, select a resolution for export. If you are running some quick tests, 
then you might want to reduce the resolution to save time and space. You also have the option to 
set a Custom width and height to produce smaller or larger frames.

7. In the Range section, decide whether you want to render all your frames, a range of frames, the 
current frame or selected frames.
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8. Use the Display menu to select a Display module to use for rendering your OpenGL frames from.  It 
is always recommended to render from the Display module located under the final Composite 
module, unless you want to render a specific section displayed by a particular Display module.

9. Click OK.
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Exporting a Sound File

At some point during the production, you might need to export a sound file to use it in another 
application, such as an editing software. Harmony allows you to export sound files as a merged 
soundtrack or as a series of individual files. The exported soundtracks are generated as *.wav files.

How to export a soundtrack

1. From the top menu, select File > Export > Soundtrack.

The Export Soundtracks dialog box opens.

2. In the Output section, click Browse and specify where you want to save the exported sound file.

3. In the Export Range section, select one of the following options:

‣ All: Exports the sound over all the frames of your scene.

‣ Frames: Sets the start and end frames in the corresponding fields on the right.

4. From the Options menu, select one of the following:

‣ Process Soundtracks Individually: Each soundtrack from all layers is exported as individual 
files.

‣ Merge all Soundtracks: One single file is created, combining all the sound files you 
imported in your scene. Note that it will only use the sound files in the selected frame range 
set in the Export Range section. If you selected to export all the frames, all the sound files 
will be processed.

5. In the Sound Settings section, set the Rate, Size and Use parameters for the soundtracks to 
export. It is a good idea to verify what is required by the software or device that  you may want to 
use next with the sound file.

6. Click OK.
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The generated sound files appear in the selected directory and are named according to the scene 
name. Individual files keep their original name; only a prefix matching the scene name is added.
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Advanced Export

The Network view allows you to make advanced connections and isolate certain portions of your 
project. It also allows you to perform multiple exports from the entire network or from specific 
sections.

For this kind of process, use the Write module in the Module Library view. The Write module lets you 
render and output the connected image information. Using the Write module, you can export a 
project as a QuickTime movie or as image sequences. You can export one format at a time or both 
simultaneously.

To export an image sequence, you need to adjust a few settings in the Write module’s properties.

You can export image sequences as several different formats:

• TVG
TVG (Toon Boom Vector Graphic) is the Toon Boom vector proprietary format.

• TGA (TGA1, TGA3, TGA4) 
Select TGA4 to export your sequence with an alpha channel (transparency).

• SGI (SGI1, SGI3, SGI4) 
Select SGI4 to export your sequence with an alpha channel (transparency).

• SGIDP (SGIDP1, SGIDP3, SGIDP4) 
Select SGIDP4 to export your sequence with an alpha channel (transparency).

• OMFJPEG

• PSD (PSD1, PSD3, PSD4) 
Select PSD4 to export your sequence with an alpha channel (transparency).

• PSDDP (PSDDP1, PSDDP3, PSDDP4) 
Select PSDDP4 to export your sequence with an alpha channel (transparency).

• YUV

• PAL

• SCAN

• PNG (PNG4) 
Select PNG4 to export your sequence with an alpha channel (transparency).

PNG4 is the recommended format to export an image sequence with transparency.
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• JPG

• BMP (BMP4) 
Select BMP4 to export your sequence with an alpha channel (transparency).

• IFF (IFF_16)

• OPT (OPT1, OPT3,OPT4) 
Select OPT4 to export your sequence with an alpha channel (transparency).

• VAR

• TIFF

• DPX (DPX3_8, DPX3_10, DPX3_12, DPX3_16, DPX3_10_INVERTED_CHANNELS, DPX3_12_
INVERTED_CHANNELS)

• PDF

The formats used if you need to output a vector format are TVG and PDF. You can also export a SWF movie.

To export a QuickTime movie, you need to adjust few settings in the Write module’s Properties.

How to add a Write module

1. In the Module Library, select the IO tab.

2. Select the Write module and drag it to the Network view.

3. In the Network view, connect the final Composite module or any other module which outputs an 
image you want to render to the Write module.
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How to set the Write Module to export an image sequence

1. In the Network view, open the Write module’s editor by clicking its yellow Properties button.

2. In the Output tab, select the Drawing option to create an image sequence.

3. Click Choose and browse to the directory where you want to save the output. You can also use the 
default directory to save in the default frames folder included in the scene directory.

4. In the Drawing Filename field, type the image sequence’s name prefix. It is recommended to leave 
the hyphen (-) at the end of the name to separate the image name from the image number.

5. In the Start field, select the starting number for the image sequence.

6. In the Leading Zeros field, select the number of digits you want to see after the sequence prefix.
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7. In the Drawing Type field, select the file format in which your project will output.

When the file format includes a "4" at the end of its name, it means that an alpha channel will be created.

8. Click Close.

The project will not start rendering yet, since these are only the settings. You can still modify your 
scene.

How to set the Write module to export a QuickTime movie

1. In the Network view, open the Write module’s editor by clicking on its Properties button.

2. In the Output tab, select the Movie option to create a movie file.

3. Click Choose and browse to the desired directory to save the output.

‣ You can also use the default directory to save in the default Frames folder included in the 
scene folder.

4. In the File name field, name the output file. You do not need to write the file format extension.
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5. In the Movie Options field, click Customize  to open the Movie Settings dialog box.

6. In the Movie Settings dialog box, in the Video section, click Settings to set your video options.

7. Click OK.

8. In the Movie Settings dialog box, in the Sound section, click Settings to set your audio options.
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9. Click  OK and Close.

The project will not start rendering yet. These are only the settings. You can still modify your scene.

Multiple Renders
Harmony lets you simultaneously render many formats and resolutions for a scene. This saves a lot of 
time as you do not have to return between each render to start a new one.

To use multiple renders, connect as many Write modules as needed to match the required number of 
exports. Then, adjust each Write module’s settings to create image sequences or movies.

YOU MUST GIVE DIFFERENT NAMES TO EACH OUTPUT FILE. This is especially important if you save them 
all in the same folder, so they do not overwrite each other.

When you have multiple Write modules in a scene, it is useful to rename the modules according to their 
output settings such as: low_resolution_movie or HDTV_sequence.

To export different resolutions concurrently, you need to create a combination of the following:

• Write module—see Advanced Export on page 601

• Scale-Output module

• Crop module

Once your Write modules are connected, you need some Scale-Output modules to change the 
resolution output of the Write module. For example, if you export in a high resolution and a low 
resolution, you need one Scale-Output module.

Set the project’s resolution to the highest resolution needed for this export and use the Scale-Output 
modules to scale down the other outputs. 
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DO NOT scale up the output size, that will not provide a good result. It is also better to use the Scale-
Output module to scale down in a same aspect ratio so that it does not distort the image.

To output two files with different aspect ratios, such as 16:9 and 4:3, you can use the Crop module. 
This module is used to crop the final image in order to discard excess information without distorting 
the render.

If you start with a higher resolution and want to crop down to a lower resolution, such as HDTV to 
NTSC, you will need to combine the Crop module with a Scale module.

Once you know the type of render you want to do, you will need to retrieve your modules from the 
Module Library and connect them to the scene’s network.

How to add a Scale-Output Module

1. In the Module Library view, select a Scale-Output module and drag it to the Network view.

2. In the Network view, connect the Composite module to the Input port of the Scale-Output module.

3. In the Network view, connect the Scale-Output module to the input ports of both the Display 
module and the Write module.
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How to set the Scale-Output module

1. In the Network view, open the Scale-Output module’s editor by clicking on its Properties button.

2. In the Layer Properties dialog box, select a resolution from the suggested Resolution Name list or 
type new resolution values to indicate the resolution to scale to.

3. Click Close.

How to add a Crop Module

1. In the Module Library view, select a Crop module and drag it to the Network view.
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2. In the Network view, connect the Composite module to the Input port of the Crop module.

3. In the Network view, connect the Crop module to the input ports of both the Display module and 
the Write module.

How to set the Crop module

1. In the Network view, open the Crop module’s editor by clicking on the module’s Properties 
button.
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2. In the Layer Properties dialog box, type new resolution values to indicate the resolution to crop to.

3. You can manually enter the X -Y Offset, or move it in the Camera view. Select the right Display 
module in the Display toolbar. In the Advanced Animation toolbar, select the Translate  tool 
and with the middle mouse button, move the crop area. If the Animate  mode is enabled, the 
position of the crop area will be animated over time.

4. If you want to create a Pan and Scan effect (panning the cropped selection over time to show more 
information), you can create a function to animate the cropped selection. Click on the Function  
button beside the Local dialog box to create a Bezier or ease curve—see .

5. If you created a function curve to animate the cropped selection, click again on the Function  
button and edit the curve by adding keyframes and moving the selection box in the Camera view.If 
you created a function curve to animate the cropped selection, click again on the Function  
button and edit the curve by adding keyframes and moving the selection box in the Camera view—
see .

6. Enable the Draw Frame option if, instead of cropping the images, you prefer to have Harmony 
draw the frame over the rendered scene.
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7. Click in the colour rectangle to adjust the frame colour as desired if you have enabled the Draw 
Frame option.

8. Click Close.

The Crop module also has an advanced Enabling tab for determining when the Crop module 
should be activated.

‣ Always Enabled: Makes the Crop module always produce output.

‣ Enabled when resolution name is: Activates the Crop module only when the resolution of 
the scene matches the value in the Filter Name menu. The listed resolutions come from the 
Resolution/Frame Rate dialog box.

‣ Enabled when resolution is: Activates the Crop module whenever the scene’s resolution 
matches the values in the X and Y resolution fields.

How to connect modules to export multiple renders

1. In the Module Library view, retrieve the necessary Write, Scale-Output and Crop modules.
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2. Connect the final Composite module to the first Write module. (Make sure you have a Display 
module reading the same information.)

3. Open the Write module’s editor by clicking on its yellow Properties button.

4. Name the Write module according to the render type that you are planning to do.

5. Set the Write module parameters—see How to set the Write Module to export an image sequence 
on page 603.

6. Connect the other Write modules and repeat steps 2 to 5.

7. Using the Alt key, insert the Scale-Output modules between the final Composite module and their 
corresponding Write module.
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8. Using the Alt key, insert the Crop modules between the final Composite module and their 
corresponding Write or Scale module.

‣ If the output from the Crop module has to be scaled down, use a Scale-Output module.

9. Connect a Display module to each Scale-Output or Crop module to see each final image in the 
Camera view.
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Rendering Images and Movies from the Network
If you want to render from your Write module, you will need to use the Render Network option found 
in the File menu.

When working with Harmony in Network mode, you can send your scene to batch processing and to a 
render farm, see Batch Rendering on page 619

How to render the network from the Write module

1. Select File > Export > Render Network or press Ctrl + Shift + Y (Windows/Linux) or ⌘  + Shift + Y 
(Mac OS X).

2. In the Range section, select the frame range to render.

3. Select the Field Composite option to render the final images as fields for display on interlaced 
monitors.

4. Select the Preview option to automatically see the image sequence result once the render is done. 
The preview will not show up for a QuickTime movie.

5. Click OK.

All renders start.
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Partitioning Renders

By partitioning renders, you can separate the elements of a scene or character, and render them 
separately according to group and Z position. This is useful when you want to export part of a 
character or scene in Harmony, so you can add effects and create the final composite using a different 
software application.

Using the Write module, you can partition the rendering of images based on group and Z position. 
First, you determine which groups you want to render.  Then you define the render by their Z 
position—see Groups on page 143. 

The Z position is based on fields. Each field is equal to one partition, which is centered on the absolute 
value of the range you define. Each partition yields a separate folder that contains your exported, 
rendered image.

How to export images based on group and Z position

1. In the Module Library, select the IO tab. 

2. Select the Write  module and drag it to the Network view.

3. In the Network view, attach the groups you want to render to a Composite module.

In the following example, there are three groups connected to one Composite module. They will 
be rendered simultaneously, producing three separate folders to hold the renders. If you have 
more groups, you can go ahead and connect those you want to render. Otherwise, disconnect the 
ones you don't want to render.

4. Display the Write module properties. Select the Output tab and set the following: 

‣ Drawing Folder: Type in a name for the folder that will hold the renders.

‣ Drawing Filename: Type in a prefix for the names of the subfolders.
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5. Select the Partitioning tab.

Parameter Description

Composite Partitioning

Off: Renders the entire network and places 
separate images of the composite in the 
Drawing Folder.

Group and Z Partitioning: Creates multiple 
renders and places the folders that correspond 
to their group in the Network view.

Z Partition Range
Based on the Z position, defines the range of 
the partition, centered on the absolute value.

Clean up partition folders
When selected, removes old folders from the 
Drawing Folder each time you perform an 
export. 
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When deselected, each time you render, more 
folders are added to the existing ones.

6. Set the parameters in the Partitioning tab.

7. Start the render by selecting File > Export > Render Network or press Ctrl + Shift + Y 
(Windows/Linux) or ⌘  + Shift + Y (Mac OS X).

8. To see your renders, navigate to the Drawing Folder you defined in step 4.
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Batch Rendering

Harmony Network has the possibility to render your scene locally or send it to a render farm so other 
computers can render your scenes while you continue working on your station. This option is not 
available with Harmony Stand Alone. The Harmony Network rendering processed are named:

• Local Rendering is done directly on the user machine using its CPU. To perform local rendering 
you must use Harmony Stage. 

• Batch Rendering lets you send a scene to render while you continue working in Harmony Stage. 
This way, you do not have to wait for the application to complete the render process. 

Batch rendering is a background process divided over several machines, or a render farm. Sending 
your scene to batch render will share the rendering load with other machines in the render farm and 
lessen the amount of work required by your computer. 

The parameters for the format and file type to render are set in the Write modules contained in your 
scene's Network view. Before sending your scene to batch rendering, make sure to set the Write 
modules to export in the proper location, and set the format parameters. Note that you can have 
more than one Write modules in your scene if you require several exports—see Advanced Export on 
page 601.

Refer to the Control Center and Server Guide to learn how to send scenes to batch render and check the 
status of the Render queue. 

How to send a scene to the batch rendering queue

1. Save all the contents of your scene, all drawings, colour palettes and the palette list. 

2. Select File > Save or press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X).

3. From the top menu, select File > Export > Render Network or press Ctrl + Shift + Y 
(Windows/Linux) or ⌘  + Shift + Y (Mac OS X).
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If the system administrator did not complete the resolution configuration tasks, a warning 
message will open. This message notifies you that the resolution.conf file was not properly 
inserted in the configuration folder. 

4. Click OK to continue. You will still be able to render your scene. 

The Render Network dialog box opens. 

5. In the Range section, select the frames you want to render: 

‣ All Frames: Sends all the frames in the scene to be rendered.

‣ Selected Frames: Sends a range of frames to be rendered. 

6. Select the Batch Composite option. 

‣ Select the Chunk option if you want to split the frames into sets of frames or QuickTime 
movie into small chunks. Note that when the render farm (server) is done rendering all the 
small movie chunks, it will put them all back together to create one single movie file.

‣ Enter the number of frames for each chunk in the Size (Frames) field. For example, if your 
scene is 100 frames long and you enter a value of 20, there would be five entries in the queue 
of 20 frames each. 

‣ Select the camera for rendering the scene's images from the Camera list. These are the 
Camera modules you created in your scene. 

7. Select the Field Composite Options option to create a field composite to refine your selection.

‣ Add Pull-down: Uses the 3:2 pull-down technique. 

‣ Automatic Combine: Combines even and odd fields on a scene's images. 
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‣ Second Field First: Always starts with the second field before combining with the first. 

8. Click OK to start the rendering process. 

A confirmation dialog box opens to inform you that the frames have been sent to the Render 
queue. 

‣ If the selected frames were already sent to the Render queue, a notification dialog box 
opens to inform you that these frames were already in the queue, but that they have been 
updated with the latest rendering request. 

You can also send scenes to batch rendering and check the status of the rendering queue from the 
Control Center module. 
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Glossary

alpha channel

The image's channel carrying the transparency information. An 
image already has three channels: red, green and blue (RGB). The 
alpha channel is the fourth channel (RGBA). The matte, or the 
transparency information, is stored in this fourth channel. An image 
without an alpha channel is always opaque.

animatic

A movie with sound that is developed from the storyboard. The 
storyboard panel is exposed for the duration of the scene and at 
times, the characters are placed on a trajectory to indicate motion. 
The camera moves are also animated. The animatic is used to 
determine the rhythm of a project and provides a good overview of 
the project before beginning production.

animation
A simulation of movement created by displaying a series of pictures 
or frames.

anime
An animation style known for its sinister and dark feel; popular in 
Japan.

arc

Action rarely occurs in a straight-forward manner; rather it typically 
unfolds in what storytellers refer to as an arc. The purpose of a 
story arc is to move a character or a situation from one state or 
scenario to the next.

aspect ratio
The relationship between the width and height dimensions for any 
scene, frame or film format. Television ratio is 4:3 and widescreen 
ratio is 16:9.

auto-feed

An automated method of feeding drawings into a scanner in which 
multiple drawings are stacked into a sheet feeder. When the 
scanner is activated, the drawings are scanned consecutively, 
without further user intervention.

automatic lip-sync detection
Automatically mapping drawings in an element to the mouth chart 
generated for a sound. This can save time when lip-syncing a voice 
track.

axis

An imaginary line around which an object rotates.

For 2D graphics, there are two axes:

• X: Horizontal

• Y: Vertical

For 3D graphics, there are three axes:

• X: Horizontal

• Y: Vertical

• Z: Depth

background
The part of a scene that is farthest to the rear. The background is 
the artwork, or decor, against which the animation takes place.

Bézier A method of defining curved lines invented by French 
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mathematician Pierre Bézier. A Bézier curve is a mathematical or 
parametric curve. Bézier curves use at least three points to define a 
curve. 

In Toon Boom, a function can be hooked to a Bézier curve and vary 
along with the curve value information. Bézier curves are also very 
useful in vector graphics. They are used to model smooth curves 
and can be scaled indefinitely.

bitmap
An image composed of pixels with a single resolution (size). If it is 
enlarged too much, it will lose definition and pixels will begin to 
appear. This is known as pixelation.

breakdown

In cut-out animation, breakdown is the action of breaking a 
character into pieces to create a puppet with articulations. To 
break down a character, the artist cuts part, such as hands and 
arms, from the character's model and pastes them in separate 
layers. Next, the joints are fixed and the pivots set.

In traditional animation, a breakdown is an animation pose 
generally found between two key poses. The key poses are the 
main poses in an animation and the breakdowns are secondary 
poses, ones that help to describe the motion and the rotation 
curve.

camera shake
Camera shake occurs in a scene when the camera moves slightly 
and quickly in several directions. This gives the impression of an 
impact, vibration or, for example, bumps on the road.

caption
In a storyboard, a caption is a text field containing dialogue, 
effects, sound, or slugging information.

cel

In traditional animation, a cel, also known as a celluloid, is a 
transparent sheet on which the animation is inked and painted 
before being sent to the camera.The picture's outline is drawn on 
the front of the cel and then coloured along the back. 

In Toon Boom, a cel is an individual space encountered in an 
Xsheet's column, from which you can expose a drawing or a 
function`s coordinate.

character design
Each character in an animated film is drawn from multiple angles in 
poster-style format, called a model sheet, which serves as a 
reference for the animators.

clean up 

After rough drawings have been tested and approved, all the noise 
in the image (excess lines, notes, etc) is removed to create final 
drawings which can be inked, painted and shot. The cleanup 
process refers to either tracing a clean line over a rough drawing to 
achieve the final version, or removing dirt and extra lines left by the 
scanning process.

CMYK
Cyan, Magenta, Yellow, Black. Refers to the process used by 
printers to define colour on the printed page.

colour card
A Colour Card is a solid colour card that is the same size as the 
camera. The Colour Card can be used to fill the background with a 
solid colour when there is no background image included.
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colour model

In animation, a colour model is the official colour design that must 
be used to paint the animation. A model is the definitive character, 
prop, or location design that each artist must follow for the 
production. 

colour wheel A display of the colour spectrum in the form of a circle. 

compositing

Compositing is the action of incorporating all of a scene's elements 
to create the final result prior to rendering. For example, the 
compositing artist will import all the animation sequences, 
background, overlays and underlays in the scene and position them 
correctly. The artist will then set the camera frame and animate it, if 
needed. Finally, the animator will create all the computer-
generated effects for the project.

cross dissolve An effect used to fade two scenes, one into the other.

cut
A direct transition between two scenes. When a cut is used, there 
are no transition effects inserted to pass from one scene to the 
next. The first scene ends and the second one starts immediately.

cut-out animation
The action of animating characters made of several pieces by 
moving them around frame by frame. Cut-out animation can either 
be computer generated or done traditionally using paper.

cycle
A group of images that together make up an action, such as 
walking. A cycle is an action repeated as a loop over a period of 
time. It can be a series of animated drawings or keyframes. 

dialogue The text spoken by a character in a movie or animation.

dope sheet

Used by animators, directors and other members of a crew to 
track the sequence and timing of images, dialogue, sound effects, 
sound tracks and camera moves. Also known as an exposure sheet 
or Xsheet.

doping To assig a particular drawing to a range of frames.

DPI

Dots Per Inch is the standard measure of resolution for 
computerized printers. It is sometimes applied to screens, in which 
case it should more accurately be referred to as pixels per inch. 
Either way, the dot is the smallest discrete element making up the 
image.

ease/velocity

In animation, the ease, also known as velocity, is the acceleration 
and deceleration of a motion. It can be a motion created by a 
function curve, or a series of animated drawings. Other common 
terms for ease-in and ease-out are slow-in and slow-out.

ease-in
Gradual acceleration in the action. Another common term for ease-
in is slow-in.

ease-out 
Gradual deceleration in the action. Another common term for ease-
out is slow-out.

establishing shot
A scene in which the viewer can see the whole area in which a 
sequence is happening. For example, if a child is playing on the 
ground in front of his house, the establishing shot would be a scene 
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where the viewer can see the house, the ground, a part of the 
street and the buildings around the central point of action. This 
helps the viewer understand the story location and scene 
orientation.

exposure
In animation, an exposure is the number of cels on which a drawing 
appears in the scene. For a drawing to appear longer, the 
exposure must be extended over a greater number of cels.

exposure sheet (Xsheet)

The exposure sheet or Xsheet, is a sheet with several vertical 
columns and horizontal frames used to indicate a scene's timing.

Each column represents a scene's layer. In each column, the 
drawing's numbers are indicated and repeated over the particular 
amount of frames they need to appear.

The exposure sheet is used by animators, directors and other 
members of a crew to track the sequence and timing of images, 
dialogue, sound effects, sound tracks and camera moves. Also 
known as a dope sheet.

fade in/fade out

Fade in or fade out is a transition effect used to open or close a 
sequence. A fade in occurs when the first scene appears 
progressively, from complete transparency to its complete opacity. 
A fade out occurs when the last scene progressively disappears, 
going from complete opacity to complete transparency.

fast-in Dramatic acceleration at the start of the action.

fast-out Dramatic acceleration at the end of the action.

field
In animation, a field is a measurement unit used to calculate 
motion, registration and camera positioning. A standard animation 
scene will vary between 6 to 12 fields.

field chart
A guide containing all the field units that animation and layout artists use to 
determine a scene size or camera motion.

film-1.33 
Use this resolution setting for the widescreen film format that 
conforms to the standard 4:3 pixel aspect ratio.

film-1.66 
Use this resolution setting for the widescreen film format that 
conforms to the 16:9 pixel aspect ratio. (The pixels are wider than 
they are high).

flipping

In traditional animation, flipping is the action of going through the 
drawings of an animation sequence very quickly in order to see the 
animation in motion. Flipping can also be the action of creating a 
mirror transformation of an object.

follow-through

The follow-through is the secondary motion caused by the main 
action. For example, a character wearing a cloak is running. The 
main action is the body running. This will cause the cloak to follow 
the motion, although it will not move at the same time, but react a 
few frames later and follow the main motion curve.

forward kinematics
Forward kinematics is a feature used to animate principally 3D 
characters and cut-out puppets with hierarchy. It is used to animate 
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a puppet from one of parent parts, such as a shoulder, and make 
the rest of the arm move with it as a single piece.

frame

A frame is a single photographic image in a movie. In traditional 
animation, the North American standard generally contains 24 
frames per second, while in Europe the standard is 25 frames per 
second.

frame rate

This is the measurement of the frequency (rate) at which an imaging 
device produces unique consecutive images, called frames. The 
term applies equally to computer graphics, video cameras, film 
cameras, and motion capture systems.

Frame rate is most often expressed in frames per second (FPS) and 
in progressive-scan monitors as hertz (Hz).

The frame rate is the speed at which the frames are played. They 
are generally calculated by frame per second. For example, a scene 
could be played back at 12, 24, 25, 30 or 60 frames per second or 
any other number

functions

A function is a computer generated motion, trajectory or path that 
elements, other trajectories and effects parameters can be 
attached to. The function can be controlled by adding keyframes 
and control points on the function curve.

gamut The range of colours that a particular device can represent.

HDTV 

High Definition Television delivers a higher quality image than 
standard television does because it has a greater number of lines 
of resolution. To take advantage of the superior quality and make 
full use of your resolution setting, your output device must be 
compatible with HDTV technology.

hold
This is a frame in the animation in which the character maintains its 
position without moving. A hold can be created between any two 
keyframes.

HSV
Hue, Saturation, Value. A method of defining colours in terms of 
hue (tint), saturation (shade) and value (tone or luminance).

in-between
The drawings that exist between the key poses. These are drawn 
to create fluid transitions between poses.

ink and paint
The ink and paint process is the action of painting the empty zones 
and colouring the lines on the final animation drawings, while 
following a colour model.

interpolation
In animation, the interpolation is the computer generated motion 
created between two keyframes. You have the choice to create 
interpolation, or not, between your keyframes.

jump cut

A jump cut is a jerky cut between two scenes. Typically, a jump cut 
is not visually pleasing. It is generally caused by one scene ending, 
and a second one starting, with similar a image. The lack of 
difference causes the eye to see a little jump between the two 
scenes. 
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key pose

Important positions in the action defining the starting and ending 
points of any smooth transition. Keys, or key poses, are the main 
drawings in an animation sequence describing the motion. For 
example, if an arm is waving, the keys will be of the arm at one 
extremity of the wave motion and the other extremity. By flipping 
those drawings, the animator can see the skeleton of the motion 
without having all of the drawings.

keyboard shortcuts 

One or more keyboard keys which, when used, cause an operation 
to be performed. Keyboard shortcuts are used throughout the 
Toon Boom software and form an integral part of the workflow. It 
is, in most cases, possible to customize the shortcuts in the 
Preferences dialog of the software.

The shortcuts are written as follows in the Toon Boom user 
documentation: Each key in a sequence is shown inside square 
brackets as in: [Ctrl]+[A]. The brackets "[ ]"  separate the key from 
the plus  sign (+). Neither the brackets, nor the plus sign are part of 
the sequence. To use a shortcut, press the key and the character 
simultaneously.

keyframe 
Important positions in the action defining the starting and ending 
points of any action. A keyframe is a computer generated position 
at a specific moment (frame) on a given trajectory.

layer
In animation, a layer is an individual column, level or character. A 
scene's layers are superposed to form the final image.

layout

The layout process is the communication step between the 
storyboard and the animation. The layout and posing process is 
the action of putting the storyboard on model, that is drawing the 
character following the design in the model pack, so that the 
animator can start his work. The layout artist will draw the 
background, create the camera and field guide matching the scene 
and the camera motion. Lastly, he will draw on model the main 
action poses.

layout and posing
The action of putting on model, that is, at the right scale, the 
storyboard for the animator to start his work.

library
A library is a storage area containing templates and assets that can 
be reused in any project or scenes.

light table
The Light Table feature allows you to see the other layers in 
transparency while you are working on a particular one in the 
Drawing view.

line of action
Direction that the action will follow. Also known as the Path of 
Action

lip-sync
The lip-sync is the character`s mouth synchronization with the 
dialogue sound track. Frame by frame, the mouth will be adjusted 
to fit the sound to give the illusion of the character is speaking.

low resolution
This format is ideal for videos destined for the web, where size and 
fast download of a video file might take precedence over quality. A 
low-resolution image is one that lacks fine detail.
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manual lip-sync detection

The manual swapping of mouth position drawings to match a voice 
track. For this process, both sound scrubbing (listening to a sound 
wave broken up frame-by-frame) and drawing substitutions from 
the Library view are used.

master palette

A master palette is a group of colours attributed to a character or 
a prop. The palette is used throughout the entire production to 
maintain consistency in the look and to ensure that the same 
colours are used throughout the production. Also known as 
palette.

model/colour model

In animation, a model is the definitive character, prop or location 
design that each artist must follow for the production. A colour 
model is the official colour design that must be used to paint the 
animation.

motion keyframe 
In Toon Boom, the motion keyframe is a keyframe with computer-
generated interpolation.

mouth chart 

Adding a lip-sync to a project can really enhance its quality and 
storytelling. However, it can be difficult to shape a character's 
mouth so that it matches the sound at the precise frame. To solve 
this problem, Toon Boom provides a lip-sync feature which 
analyses the contents of a sound element and generates a mouth 
chart based on the eight animation phonemes (A, B, C, D, E, F, G, 
and X, which is used to represent silence).

multiplane 

The effect of passing through multiple levels of drawings to create 
a sense of depth in a shot. A multiplane is a scene in which the 
layers are placed at different distances from the camera so that 
when the camera moves, a depth illusion occurs. With a multiplane, 
all the perspective and scale is calculated automatically.

NTSC

The standard analogue television broadcasting system used in 
North America. NTSC conforms to North American standards on 
how rectangular pixels are displayed for computer and television 
screens.

nudge
A small push (left, right, up, down, forward or backward) done 
with the keyboard arrow keys on a selected element. Nudging is 
used to move a selection very slightly and precisely.

onion skin
A feature that lets you see the previous and next drawings of a 
sequence.

overlay
A part of the scene environment, such as a chair or a bush, that is 
placed in front of the main animation.

PAL
A resolution that works best with the European format for 
television and computer screens, as the rectangular pixels are 
displayed at a different orientation.

palette/master palette

A palette or master palette is a group of colours attributed to a 
character or a prop. The palette is used throughout the entire 
project to maintain a consistency in the look and avoid the colour 
changing during the animation. Also referred to as a master 
palette.
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palette style

A palette style is a second version of an existing palette with a 
slight change in the tint and value. A palette style can be used to 
create the night version of a palette. It may also be called a clone 
palette.

pan To move the camera across the scene in any direction.

panel 
In a storyboard, a panel is a frame in a shot. A shot can be 
composed of one or several panels.

paperless animation/tradigital
The paperless animation process is the action of animating 
digitally. The main paperless animation process is to draw, frame 
by frame, the animation directly in the software.

passing position 
When drawing a walk sequence for a character, the passing 
position is the point at which one leg passes the other.

path of action
Direction that the action will follow. Also known as the Line of 
Action.

peg

In traditional animation, a tool used to ensure accurate registration 
of action as cel layers move. In digital animation, in which you are 
doing a more advanced puppet rigging, you can use peg layers. 
Peg layers are trajectory layers that do not contain drawings. They 
are motion paths that you can use to add path articulations. For 
the latter, you can also use the Inverse Kinematics tool.

phoneme Unit of sound in a language.

pivot A pivot is the point around which a peg or a drawing rotates.

pixel

Smallest element of an image displayed on a monitor or TV screen.

Pixel, short for Picture Element, is a single point in a graphic image. 
It is a small sample of an image, a dot, a square, or a very small 
section made out of smooth filtering. If you zoom in close enough 
on a digital image, you will see the pixels, which look like small 
squares of different colours and intensity.

pose-to-pose animation

The pose-to-pose animation process is the action of creating all the 
main action poses, called key poses, and then placing the 
secondary poses between the keys. The secondary poses are 
called breakdown. Finally, the animator fills the gaps with the in-
between drawings to achieve a smooth animation.

rendering 

The final step when animating by computer. During rendering, the 
computer takes each pixel that appears on screen and processes 
all of the components as well as adding motion blur before it 
produces a final image. In animation, the rendering process is the 
action of calculating the final images after the compositing 
process.

resolution

The resolution is the size of a scene, generally calculated in pixel. 
For example, the NTSC resolution is 720 x 480. Resolution type 
should match your final output: HDTV, film-1.33, film-1.66, NTSC, 
PAL, low.

RGB Red, Green, Blue: method of defining colour by specifying amounts 
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of these three colour components.

rigging 
The rigging process is the action of attaching the cut-out puppet 
parts one to the other.

rotary table
The Rotary Table is equivalent to the animation disk/table and 
allows one to rotate the workspace to be more comfortable while 
drawing.

rotoscoping 

Is an animation technique in which animators trace over live-action 
film movement, frame by frame, for use in animated films. The act 
of sketching over live-action footage to create an animated 
sequence.

roughs 
The roughs are the skeleton sketch of an animation or a design. 
Roughs mainly consist of sketch lines and shapes, though they can 
also contain design details.

safey area

In animation and movie parlance, the safey area is the zone at the 
centre of the scene's frame, one safe from being cropped by the TV 
frame. As a TV frame cuts a margin off the original frame size, 
maintaining a safey area ensures that the scene's main action will 
remain clearly visible once the film is screened on television.

scene 
A scene is a shot in a movie or show. A sequence is composed of 
several scenes. A scene changes to another scene by a simple cut, 
or a transition.

script 

The script is the original text containing all the movie or show 
information. In animation, the script contains all of the location 
descriptions, dialogues, time and more. A project starts with a 
script.

sequence 
In animation, a sequence is a series of scenes or shots forming a 
distinct part of the story or movie, usually connected by unity of 
location or time.

shot 
A shot is a scene in a movie or show. A sequence is composed of 
several shots. A shot changes to another shot by a simple cut, or a 
transition.

slow-in
Gradual acceleration in the action. Another common term for slow-
in is ease-in.

slow-out 
Gradual deceleration in the action. Another common term for slow-
out is ease-out.

slugging
In Storyboard Pro, slugging refers to indicating the start and stop 
times of dialogue and relevant actions.

sound scrubbing
A process that lets you hear sound in real time while you move the 
playhead forward or backward. This is very useful for finely-tuned 
lip-syncing.

stop-motion keyframe 
A stop-motion keyframe is a keyframe with no computer generated 
interpolation.

storyboard 
A visual plan of all the scenes and shots in an animation. The 
storyboard indicates what will happen, when it will happen and 
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how the objects in a scene are laid out.

straight-ahead 

A technique in which an entire sequence is drawn from the first 
position to the last, in order. There is very little planning in this 
methodology, and where the character ends up and how it gets 
there can be a surprise for both the audience and the animator. 
While this approach is a lot more spontaneous and creative, it can 
create inaccurate results.

strokes
Strokes are invisible vector lines forming the drawing zones. They 
can be adjusted with Bézier handles.

tablet/pen 
Device used in conjunction with, or instead of, a mouse to move a 
mouse pointer (sometimes referred to as the cursor) around the 
computer screen.

template 

In Toon Boom, a template is an asset stored in the library, one that 
can be reused in any project. A template can be a drawing, a series 
of keyframes, a sound file, a panel, a cut-out character, an effect, a 
trajectory, an animation, or anything else used in the software.

thumbnails A thumbnail is a very small image used as a reference or indicator.

timecode 
Timecode is timing information printed on a movie clip to indicate 
what scene, hour, minute and second is currently displayed on the 
screen.

timeline 
The timeline is a horizontal representation of the scene`s elements, 
timing and keyframes.

trace and paint 

After the rough animations have gone through cleanup and a final 
line or pencil test, each drawing is traced and painted for the final 
animation. In today's digital world, this may be done in a variety 
ways other than via the traditional celluloid or acetate methods.

track breakdown 
The soundtrack for animated film is broken down into individual 
sounds documenting the precise frame-by-frame position of each 
sound.

traditional animation 
The traditional animation process is the action of drawing on paper 
all of the animation sequences, before either scanning them or 
inking them on cels.

trajectory 
A computer generated path or trajectory that elements can follow. 
The trajectory can be controlled by control points, keyframes and 
velocity.

transition 
A transition is an effect placed between two scenes as they pass 
from one to the other. Common transition effects are cross-
dissolve and wipe.

underlay
In animation, an underlay is a specific part of the decor placed 
behind the main animation.

aspect ratio
The aspect ratio describes the shape of the grid unit. A square grid 
unit would have the ratio 1:1, whereas a grid unit of aspect ratio 
4:3 is a unit with one side 1.33 times as big as the other side.
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vector

A vector-based image is composed of points and Bézier curves. 
The computer reads the points and traces the segments, linking 
them to reproduce the image shape. There is no fixed size or 
resolution in a vector image. The graphic can be enlarged and 
distorted as much as desired and the system will simply recalculate 
the segments and rebuild the shapes. Vector images are translated 
and displayed in pixels once the calculation is done.

velocity/ease

In animation, the velocity, also known as ease, is the acceleration or 
deceleration of a motion. This can be achieved by a function curve, 
or via a series of animated drawings. Other common terms for 
ease-in and ease-out are slow-in and slow-out.

walk cycle 

To avoid making innumerable drawings, animators routinely make 
a walk cycle for their character. This comprises a series of drawings 
``on the spot``  that describe the walk for that character. The illusion 
of movement is created via the use of background pans.

workspace
In Toon Boom, the workspace is made up of the views, toolbars, 
and menus.

Xsheet (exposure sheet)

The Xsheet or exposure sheet, is a sheet with several vertical 
columns and horizontal frames used to indicate a scene's timing.

Each column represents a scene's layer. In each column, the 
drawing numbers are indicated and spread over the specific 
amount of frames they need to appear.

The exposure sheet is used by animators, directors and other 
members of a crew to track the sequence and timing of images, 
dialogue, sound effects, sound tracks and camera moves. Also 
known as a Dope Sheet.

zone An area which can be painted with colour.
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manual lip-sync detection

_defined  628

master palette

_defined  628

Matte Drawing module  132, 340

model

_defined  628

model sheet  See character design

Module Library view  341

toolbar  341

Module Library view toolbar  341

modules  130, 338

Composite  131, 339

Display  131, 339

Drawing  130, 338

Effect  132, 340

Matte Drawing  132, 340

Peg  132, 340

ports  132, 340

Write  131, 339

motion keyframe

_defined  628

mouth

chart  628

shapes  300

multiplane

_defined  628

positioning elements  165

Navigator view  129, 337

Network view  128, 336

Composite module  131, 339

Drawing modules  130, 338

Effect module  132, 340

group navigation  130, 338
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Matte Drawing module  132, 340

modules  130, 338

Navigator view  129, 337

Peg modules  132, 340

position ports  132, 340

Search toolbar  129, 337

Symbol Stack  129, 337

Write and Display modules  131, 339

node system  129, 337

NTSC

_defined  628

nudge

_defined  628

onion skinng

_defined  628

overlay

_defined  628

PAL

_defined  628

palettes

_defined  628

style, defined  629

panel

_defined  629

panning

_defined  629

layer using Transform tool  99

paperless animation

_defined  629

passing position

_defined  629

path of action

_defined  629

Peg module  132, 340
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pegs

_defined  629

pen

_defined  631

Perspective view  170

rotating a scene  171

phoneme

_defined  629

pivot

_defined  629

repositioning permanently  105

pixel

_defined  629

pixelation  See bitmap image

ports  132, 340

pose-to-pose

_defined  629

rendering

_defined  629

resolution

_defined  629

RGB

_defined  629

rigging

_defined  630

rotary table

_defined  630

rotating

layer with Transform tool  99

rotoscoping

_defined  630

roughs

_defined  630
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safe area

_defined  630

scaling

layer with Transform tool  100

scanning

VectOptions.conf file  78

scene setup

panning layer using Transform tool  99

repositioning pivot permanently  105

rotating layer with Transform tool  99

scaling layer with Transform tool  100

skewing layer with Transform tool  100

scenes

_defined  630

rotating in Perspective view  171

script

_defined  630

scrubbing

_defined  630

sequences

_defined  630

shot

_defined  630

Side view  169

opening  222

positioning elements  165

skewing

layer with Transform tool  100

slow-in

_defined  630

slow_out

_defined  630

slugging

_defined  630
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sound

importing sound file  280

scrubbing

_defined  630

stop-motion keyframe

_defined  630

storyboard

_defined  630

straight-ahead

_defined  631

strokes

_defined  631

Symbol Stack  129, 337

tablet

_defined  631

templates

_defined  631

thumbnails

_defined  631

timecode

_defined  631

timeline

_defined  631

toolbars

Module Library view  341

Search, Network view  129, 337

Top view  167

opening  222

positioning elements  165

trace and paint

_defined  631

track breakdown

_defined  631
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tradigital

_defined  629

traditional animation

_defined  631

trajectory

_defined  631

Transform tool

panning layer  99

rotating layer  99

scaling layer  100

skewing layer  100

transition

_defined  631

underlay

_defined  631

VectOptions.conf file  78

Linux  81

Mac  79

setting  79

Windows  79

vector

_defined  632

vectorization

creating a style  77

parameters, creating  77

parameters, custom  69

parameters, modifying  77

Vectorization Parameters dialog box

Help tab  72

opening  69

Options tab  70

velocity

defined  624, 632
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views

Function  243

Module Library  341

Navigator  129, 337

Network  128, 336

Perspective  170

Side  169

Top  167

walk cycle

_defined  632

workspace

_defined  632

Write module  131, 339

Xsheet view

_defined  632

zone

_defined  632
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